PHP Manual

PHP Manual

Mehdi Achour
Friedhelm Betz
Antony Dovgal
Nuno Lopes
Hannes Magnusson
Georg Richter
Damien Seguy
Jakub Vrana

Edited by

Philip Olson

This file was generated: Mon Dec 03 05:59:50 2007
Go to http://www.php.net/docs.php to get the actual version.

Copyright © 1997 - 2007 the PHP Documentation Group


Manuál PHP

by

Mehdi Achour
Friedhelm Betz
Antony Dovgal
Nuno Lopes
Hannes Magnusson
Georg Richter
Damien Seguy
Jakub Vrana

A mnoho dalších

Sestavil

Philip Olson

Lukáš Jelínek

Jakub Vrána

Copyright © 1997-2006 the PHP Documentation Group

Vydáno: 2007-12-03

Obsah

Předmluva
Autoři a přispěvatelé
I. Začínáme
1. Úvod
2. Stručný tutoriál
II. Instalace a konfigurace
3. Obecné instalační úvahy
4. Installation on Unix systems
5. Installation on Mac OS X
6. Installation on Windows systems
7. Installation of PECL extensions
8. Problems?
9. Runtime Configuration
III. Reference jazyka
10. Základní syntaxe
11. Types
12. Proměnné
13. Konstanty
14. Výrazy
15. Operátory
16. Řídicí struktury
17. Funkce
18. Classes and Objects (PHP 4)
19. Classes and Objects (PHP 5)
20. Namespaces
21. Exceptions
22. Vysvětlení referencí (odkazů)
IV. Bezpečnost
23. Úvod
24. Obecné úvahy
25. Installed as CGI binary
26. Instalace jako modul do Apache
27. Bezpečnost souborových systémů
28. Database Security
29. Hlášení chyb
30. Using Register Globals
31. User Submitted Data
32. Magic Quotes
33. Skrývání PHP
34. Aktualizace systému
V. Vlastnosti
35. HTTP autentikace a PHP
36. Cookies
37. Sessions
38. Dealing with XForms
39. Zpracování uploadu souborů
40. Použití vzdálených souborů
41. Obsluha spojení
42. Persistentní databázová spojení
43. Bezpečný režim
44. Použití PHP z příkazové řádky
VI. Reference funkcí
I. .NET Functions
II. Funkce specifické pro Apache
III. Alternative PHP Cache
IV. Advanced PHP debugger
V. Funkce pro práci s poli
VI. Aspell funkce [zastaralé]
VII. BBCode Functions
VIII. BCMath funkce pro výpočty s libovolnou přesností
IX. PHP bytecode Compiler
X. Kompresní funkce bzip2
XI. Kalendářové funkce
XII. CCVS API Functions
XIII. Funkce pro práci s třídami/objekty
XIV. Classkit Functions
XV. ClibPDF Functions [deprecated]
XVI. Funkce na podporu COM ve Windows
XVII. Crack Functions
XVIII. Character Type Functions
XIX. Funkce pro práci s CURL, Client URL Library
XX. Cybercash platební funkce
XXI. Credit Mutuel CyberMUT functions
XXII. Cyrus IMAP administration Functions
XXIII. Funkce pro datum a čas
XXIV. DB++ Functions
XXV. Database (dbm-style) Abstraction Layer Functions
XXVI. dBase Functions
XXVII. DBM Funkce [zastaralé]
XXVIII. dbx Functions
XXIX. Direct IO Functions
XXX. Adresářové funkce
XXXI. DOM Functions
XXXII. DOM XML Functions
XXXIII. enchant Functions
XXXIV. Error Handling and Logging Functions
XXXV. Exif Functions
XXXVI. Expect Functions
XXXVII. File Alteration Monitor Functions
XXXVIII. Forms Data Format Functions
XXXIX. Fileinfo Functions
XL. filePro funkce
XLI. Funkce filesystému
XLII. Filter Functions
XLIII. Firebird/InterBase Functions
XLIV. Firebird/Interbase Functions (PDO_FIREBIRD)
XLV. FriBiDi Functions
XLVI. FrontBase Functions
XLVII. FTP Functions
XLVIII. Funkce pro práci s funkcemi
XLIX. GeoIP Functions
L. Gettext
LI. GMP Functions
LII. gnupg Funkce
LIII. Net_Gopher
LIV. Haru PDF Functions
LV. hash Functions
LVI. HTTP
LVII. Hyperwave Functions
LVIII. Hyperwave API Functions
LIX. i18n Funkce
LX. IBM Functions (PDO_IBM)
LXI. IBM DB2, Cloudscape and Apache Derby Functions
LXII. iconv Functions
LXIII. ID3 Functions
LXIV. IIS Administration Functions
LXV. Image Functions
LXVI. Imagick Image Library
LXVII. IMAP, POP3 and NNTP Functions
LXVIII. Informix Functions
LXIX. Informix Functions (PDO_INFORMIX)
LXX. Ingres II Functions
LXXI. IRC Gateway Functions
LXXII. PHP / Java Integration
LXXIII. JSON Functions
LXXIV. KADM5
LXXV. LDAP Functions
LXXVI. libxml Functions
LXXVII. Lotus Notes Functions
LXXVIII. LZF Functions
LXXIX. Mailové funkce
LXXX. Mailparse Functions
LXXXI. Matematické funkce
LXXXII. MaxDB PHP Extension
LXXXIII. MCAL Functions
LXXXIV. Mcrypt Encryption Functions
LXXXV. MCVE (Monetra) Payment Functions
LXXXVI. Memcache Functions
LXXXVII. Mhash funkce
LXXXVIII. Mimetype Functions
LXXXIX. Ming functions for Flash
XC. Různé funkce
XCI. mnoGoSearch Functions
XCII. Microsoft SQL Server Functions
XCIII. Microsoft SQL Server and Sybase Functions (PDO_DBLIB)
XCIV. Mohawk Software Session Handler Functions
XCV. mSQL Functions
XCVI. Multibyte String Functions
XCVII. muscat Functions
XCVIII. MySQL funkce
XCIX. MySQL Functions (PDO_MYSQL)
C. MySQL Improved Extension
CI. Ncurses Terminal Screen Control Functions
CII. Síťové funkce
CIII. Newt Functions
CIV. NSAPI-specific Functions
CV. Object Aggregation/Composition Functions
CVI. Object property and method call overloading
CVII. Oracle Functions
CVIII. ODBC Functions (Unified)
CIX. ODBC and DB2 Functions (PDO_ODBC)
CX. oggvorbis
CXI. OpenAL Audio Bindings
CXII. OpenSSL funkce
CXIII. Oracle Functions [deprecated]
CXIV. Oracle Functions (PDO_OCI)
CXV. Funkce pro řízení výstupu
CXVI. Ovrimos SQL Functions
CXVII. Paradox File Access
CXVIII. Parsekit Functions
CXIX. Process Control Functions
CXX. Regular Expression Functions (Perl-Compatible)
CXXI. PDF funkce
CXXII. PDO Functions
CXXIII. Phar archive stream and classes
CXXIV. PHP volby a informace
CXXV. POSIX Functions
CXXVI. Regular Expression Functions (POSIX Extended)
CXXVII. PostgreSQL Functions
CXXVIII. PostgreSQL Functions (PDO_PGSQL)
CXXIX. Printer Functions
CXXX. Funkce spouštění programů
CXXXI. PostScript document creation
CXXXII. Pspell Functions
CXXXIII. qtdom Functions
CXXXIV. Radius
CXXXV. Rar Functions
CXXXVI. GNU Readline
CXXXVII. GNU Recode funkce
CXXXVIII. RPM Header Reading Funkce
CXXXIX. runkit Functions
CXL. SAM - Simple Asynchronous Messaging
CXLI. Satellite CORBA klient extenze
CXLII. SCA Functions
CXLIII. SDO Functions
CXLIV. SDO XML Data Access Service Functions
CXLV. SDO Relational Data Access Service Functions
CXLVI. Semaphore, Shared Memory and IPC Functions
CXLVII. SESAM Database Functions
CXLVIII. PostgreSQL Session Save Handler
CXLIX. Session Handling Functions
CL. Funkce pro práci se sdílenou pamětí
CLI. SimpleXML functions
CLII. SNMP Functions
CLIII. SOAP Functions
CLIV. Socket Functions
CLV. Standard PHP Library (SPL) Functions
CLVI. SQLite Functions
CLVII. SQLite Functions (PDO_SQLITE)
CLVIII. Secure Shell2 Functions
CLIX. Statistics Functions
CLX. Stream Functions
CLXI. Funkce pro práci s řetězci
CLXII. Subversion Funkce
CLXIII. Shockwave Flash Functions
CLXIV. Swish Functions
CLXV. Sybase Functions
CLXVI. TCP Wrappers Functions
CLXVII. Tidy Functions
CLXVIII. Tokenizer Functions
CLXIX. Unicode Functions
CLXX. URL funkce
CLXXI. Variable Handling Functions
CLXXII. Funkce pro práci s Verisign Payflow Pro
CLXXIII. vpopmail Functions
CLXXIV. W32api Functions
CLXXV. WDDX funkce
CLXXVI. win32ps Functions
CLXXVII. win32service Functions
CLXXVIII. xattr Functions
CLXXIX. xdiff Functions
CLXXX. XML Parser Functions
CLXXXI. XML-RPC Functions
CLXXXII. XMLReader functions
CLXXXIII. XMLWriter Functions
CLXXXIV. XSL functions
CLXXXV. XSLT funkce
CLXXXVI. YAZ Functions
CLXXXVII. Funkce pro práci s YP/NIS
CLXXXVIII. Zip File Functions
CLXXXIX. Zlib Compression Functions
VII. PHP at the Core: A Hacker's Guide to the Zend Engine
45. The PHP 5 build system
46. Extension structure
47. Memory management
48. Working with variables
49. Writing functions
50. Working with classes and objects
51. Working with resources
52. Working with INI settings
53. Working with streams
54. PDO Driver How-To
55. Extension FAQs
56. Zend Engine 2 API reference
57. Zend Engine 1
58. The future: PHP 6 and Zend Engine 3
VIII. FAQ: Často kladené otázky
59. Obecné informace
60. E-mailové konference (mailing lists)
61. Získání PHP
62. Záležitosti databází
63. Instalace
64. Sestavovací (kompilační) problémy
65. Používání PHP
66. PHP a HTML
67. PHP a COM
68. PHP a jiné jazyky
69. Přechod z PHP 2 na PHP 3
70. Přechod z PHP 3 na PHP 4
71. Přechod z PHP 4 na PHP 5
72. Ostatní otázky
IX. Appendices
A. Historie PHP a souvisejících projektů
B. Migrating from PHP 5.1.x to PHP 5.2.x
C. Migrating from PHP 5.0.x to PHP 5.1.x
D. Migrating from PHP 4 to PHP 5
E. Přechod z PHP 3 na PHP 4
F. Přechod z PHP/FI 2 na PHP 3
G. Ladění (debugging) PHP
H. Konfigurační volby
I. Direktivy php.ini
J. List of Supported Timezones
K. Kategorizace rozšíření
L. Seznam aliasů funkcí
M. List of Reserved Words
N. Seznam typů prostředků
O. List of Supported Protocols/Wrappers
P. Seznam dostupných filtrů
Q. Seznam podporovaných socketových transportů
R. Tabulky porovnání datových typů v PHP
S. Seznam tokenů parseru
T. Userland Naming Guide
U. O tomto manuálu
V. Open Publication License
W. Rejstřík funkcí
X. Co zde chybí
X. Vydání HTML Help
73. O tomto vydání
74. Použití prohlížeče HTML nápovědy
75. The Full Text Search
76. Specialities of this Edition
77. Integrating the PHP Manual
78. Skin development
79. CHM Edition Credits
Další
Předmluva


Předmluva

Autoři a přispěvatelé

PHP, což znamená "PHP: Hypertext Preprocessor", je široce používaný mnohoúčelový skriptovací jazyk, šířený pod Open Source licencí, zvlášť vhodný pro vývoj WWW aplikací a způsobilý pro vkládání do HTML. Velká část jeho syntaxe je vypůjčená z C, Javy a Perlu, a lze se ji snadno naučit. Cílem tohoto jazyka je je umožnit webovým vývojářum rychle psát dynamicky generované stránky - ale s PHP můžete dělat mnohem víc!

Tento manuál je tvořen především referenční příručkou funkcí, ale obsahuje také refereční příručku jazyka, vysvětlení hlavních vlastností a možností PHP a různé doplňkové informace.

Manuál si můžete stáhnout v řadě formátů na » http://www.php.net/download-docs.php. Více informací o tom, jak je tento manuál vyvíjen, můžete najít v dodatku 'O tomto manuálu'. Zajímáte-li se o historii PHP, navštivte příslušný dodatek.

Autoři a přispěvatelé

Lidi, kteří jsou v současnosti nejaktivnější, uvádíme na titulní straně manuálu. Ale je zde také mnoho dalších přispěvatelů, kteří nám nyní pomáhají s naší prací nebo v minulosti odvedli velký kus práce na projektu. Je také spousta "bezejmenných" lidí, kteří pomohli svými uživatelskými poznámkami na manuálových stránkách. Tyto poznámky jsou trvale brány v úvahu a práce těchto lidí je tedy velmi vděčná. Všechny seznamy uvedené níže jsou v abecedním pořádku.

Autoři a editoři

Přestože nyní nejsou aktivní, udělali tito přispěvatelé již dříve velký kus práce na manuálu: Bill Abt, Jouni Ahto, Alexander Aulbach, Daniel Beckham, Stig Bakken, Jesus M. Castagnetto, Ron Chmara, Sean Coates, John Coggeshall, Simone Cortesi, Markus Fischer, Wez Furlong, Sara Golemon, Rui Hirokawa, Brad House, Pierre-Alain Joye, Etienne Kneuss, Moriyoshi Koizumi, Rasmus Lerdorf, Andrew Lindeman, Stanislav Malyshev, Rafael Martinez, Rick McGuire, Yasuo Ohgaki, Derick Rethans, Rob Richards, Sander Roobol, Egon Schmid, Thomas Schoefbeck, Sascha Schumann, Dan Scott, Masahiro Takagi, Michael Wallner, Lars Torben Wilson, Jim Winstead, Jeroen van Wolffelaar, a Andrei Zmievski.

Tito přispěvatelé, přestože nyní nejsou aktivní, již dříve velice pomohli se sestavováním manuálu: Stig Bakken, Gabor Hojtsy, Hartmut Holzgraefe, a Egon Schmid.

Správci uživatelských poznámek

Aktivní správci jsou (aktuální stav): Mehdi Achour, Etienne Kneuss, Nuno Lopes, Hannes Magnusson, Bobby Matthis, a Maciek Sokolewicz.

Tito lidé také v minulosti vložili mnoho úsilí do správy uživatelských poznámek: Daniel Beckham, Friedhelm Betz, Victor Boivie, Jesus M. Castagnetto, Nicolas Chaillan, Ron Chmara, Sean Coates, James Cox, Vincent Gevers, Sara Golemon, Zak Greant, Szabolcs Heilig, Oliver Hinckel, Hartmut Holzgraefe, Rasmus Lerdorf, Matthew Li, Andrew Lindeman, Aidan Lister, Maxim Maletsky, James Moore, Philip Olson, Sebastian Picklum, Derick Rethans, Sander Roobol, Damien Seguy, Jason Sheets, Tom Sommer, Jani Taskinen, Yasuo Ohgaki, Jakub Vrana, Lars Torben Wilson, Jim Winstead, Jared Wyles, a Jeroen van Wolffelaar.

Předcházející | Nahoru | Další
Manuál PHP | Domů | I. Začínáme


Část I. Začínáme

Obsah

1. Úvod
2. Stručný tutoriál
Předcházející | Nahoru | Další
Předmluva | Domů | 1. Úvod


Kapitola 1. Úvod

Obsah

Co je PHP?
Co dokáže PHP?

Co je PHP?

PHP (rekurzivní akronym pro "PHP: Hypertext Preprocessor") je rozšířený univerzální skriptovací jazyk s volně dostupným zdrojovým kódem (Open Source), který je obzvláště vhodný pro vývoj webových aplikací a lze jej zapouzdřit do HTML.

To je jednoduchá odpověd, ale co to znamená ve skutečnosti? Příklad:

Příklad 1.1. Úvodní příklad

<html>
    <head>
        <title>Příklad</title>
    </head>
    <body>

        <?php
        echo "Ahoj, já jsem PHP skript!";
        ?>

    </body>
</html>

Povšimněte si odlišností od skriptů psaných v jiných jazycích, jako Perl nebo C -- místo psaní programu s množstvím příkazů pro výstup HTML vytvoříte HTML soubor s vloženým kódem, který něco vykoná (v tomto případě vypíše text). PHP kód je uzavřen mezi zvláštními uvozujícími a koncovými tagy, které vám umožňují vstoupit a opustit "PHP mód".

PHP se liší od jazyků, jako je JavaScript na straně klienta, tím, že je vykonáván na straně serveru. Kdybyste měli na svém serveru takový skript, jaký byl uveden výše, klient by obdržel pouze výstup z toho skriptu bez možnosti zjistit, jaký může být použitý zdrojový kód. Můžete dokonce nakonfigurovat svůj webový server tak, aby zpracovával veškeré vaše HTML soubory. Pak už by opravdu neexistoval způsob, kterým by uživatel zjistil, co máte v rukávu.

Nejlepší na PHP je, že je extrémně jednoduché pro začátečníka, ale poskytuje mnoho pokročilých vlastností i profesionálnímu programátorovi. Není třeba se obávat, že budete muset pročíst dlouhý seznam vlastností PHP. Během chvilky se na něj můžete vrhnout a za několik hodin můžete psát jednodušší skripty.

Ačkoli je programování v PHP zaměřeno na skripty na straně serveru, můžete v něm vytvořit mnohem více. Čtěte dál a v sekci Co dokáže PHP? se dozvíte více, nebo jděte přímo na úvodní výukovou lekci, pokud vás zajímá pouze programování pro web.

Předcházející | Nahoru | Další
I. Začínáme | Domů | Co dokáže PHP?


Co dokáže PHP?

Cokoli. PHP je zaměřeno hlavně na skripty na straně serveru, takže dokáže to, co dokáží ostatní CGI programy, jako třeba sběr dat z formulářů, generování dynamického obsahu, nebo přijímat a odesílat cookies. Ale PHP dokáže víc...

Existují tři hlavní oblasti, v nichž jsou použity PHP skripty.

  • Skriptování na straně serveru. Toto je tradiční a hlavní oblast nasazení PHP. Pro správnou funkci potřebujete tři věci. Parser PHP (CGI nebo modul serveru), webový server a webový prohlížeč. Potřebujete spustit webserver s připojenou instalací PHP. Výstup z PHP programu můžete pak zobrazovat webovým prohlížečem, v němž otevřete stránku v PHP umístěnou na daném serveru. Pokud jen experimentujete s programováním v PHP, může to všechno běžet na vašem domácím počítači. Více informací najdete v sekci instrukce k instalaci.
  • Skriptování v příkazovém řádku. Můžete přinutit PHP skript, aby běžel bez serveru a browseru. Pro toto použití potřebujete pouze PHP parser. Tento typ použití je ideální pro skripty spouštěné pravidelně v cronu (na *nixu nebo Linuxu) nebo v Naplánovaných úlohách (ve Windows). Tyto skripty mohou být rovněž použity v úlohách pro zpracování textu. Více informací hledejte v sekci Použití PHP v příkazovém řádku.
  • Psaní desktopových aplikací. PHP pravděpodobně není ten nejlepší jazyk pro tvorbu desktopových aplikací s grafickým rozhraním, ale pokud znáte PHP velmi dobře a chcete využít jeho pokročilých vlastností v aplikacích na straně klienta, můžete takový program napsat pomocí PHP-GTK. Tímto způsobem můžete rovněž napsat aplikaci pro více platforem. PHP-GTK je rozšíření jazyka PHP, které není k dispozici v hlavní distribuci. Pokud se zajímáte o PHP-GTK, navštivte » jeho samostatnou stránku.

PHP lze použít ve všech rozšířených operačních systémech jako jsou Linux, mnoho variant Unixu (včetně HP-UXu, Solarisu a OpenBSD), Microsoft Windows, Mac OS X, RISC OS a pravděpodobně v dalších. PHP má v současné době podporu pro většinu webových serverů. Mimo jiné pro Apache, Microsoft Internet Information Server, Personal Web Server, servery Netscape a iPlanet, Oreilly Website Pro, Caudium, Xitami, OmniHTTPd. Pro většinu z nich ve formě PHP modulu, pro ty s podporou standardu CGI ve formě CGI procesoru.

Jak je vidět, s PHP máte svobodu zvolit si operační systém i webový server. Dále si můžete vybrat, zda použijete procedurální nebo objektově orientované programování, nebo směs obojího. Ačkoli v PHP 4 nejsou implementovány všechny standardní vlastnosti OOP, mnoho programových knihoven a rozsáhlých aplikací (včetně knihovny PEAR) je napsaných výhradně za použití technik OOP. PHP 5 opravuje nedostatky týkající se OOP a zavádí kompletní objektový model.

S PHP nejste omezeni pouze na výstup HTML. Schopnosti PHP zahrnují výstup obrázků, souborů PDF a dokonce Flash animací (použitím libswf a Ming) generovaných za běhu. Výstupem může být rovněž libovolný text jako třeba XHTML nebo jakýkoli jiný XML soubor. PHP umí tyto soubory nejen vypisovat, ale také automaticky generovat a ukládat je do souborového systému, čímž vznikne cache dynamického obsahu na straně serveru.

Jedna z nejsilnějších a nejvýznamnějších vlastností PHP je jeho podpora pro širokou škálu databází. Vytvoření webové stránky spolupracující s databází je neuvěřitelně jednoduché. V současné době jsou podporovány následující databáze:

Adabas D | InterBase | PostgreSQL
dBase | FrontBase | SQLite
Empress | mSQL | Solid
FilePro (read-only) | Direct MS-SQL | Sybase
Hyperwave | MySQL | Velocis
IBM DB2 | ODBC | Unix dbm
Informix | Oracle (OCI7 and OCI8)
Ingres | Ovrimos
Máme také abstraktní databázové rozšíření DBX, které vám umožní transparentně používat libovolnou databázi podporovanou tímto rozšířením. PHP navíc podporuje ODBC, standard Open Database Connection, takže se můžete připojit k jakékoli další databázi, která tento světový standard podporuje.

PHP má také podporu pro komunikaci s dalšími službami využitím protokolů jako LDAP, IMAP, SNMP, NNTP, POP3, HTTP, COM (ve Windows) a bezpočtu dalších. Kromě toho můžete otevřít syrový (angl. raw) síťový socket a komunikovat jakýmkoli jiným protokolem. PHP má podporu pro WDDX, což umožňuje komplexní výměnu dat mezi prakticky všemi webovými programovacími jazyky. Když už mluvíme o propojování, PHP má podporu pro vytváření instancí objektů jazyka Java a může je transparentně používat jako objekty PHP. Dále můžete použít rozhraní CORBA pro přístup ke vzdáleným objektům.

PHP disponuje extrémně užitečnými vlastnostmi pro zpracování textu, od regulárních výrazů převzatých z jazyka Perl nebo rozšířených regulárních výrazů až po zpracování XML dokumentů. PHP 4 podporuje standardy SAX a DOM pro zpracování a zpřístupnění XML dokumentů; pro transformaci XML dokumentů můžete použít rozšíření XSLT. PHP 5 standardizuje všechna XML rozšíření založená na libxml2 a rozšiřuje množinu vlastností přidáním podpory pro SimpleXML a XMLReader.

Při nasazení PHP na poli e-commerce najdete funkce pro online platby realizované prostřednictvím Cybercash, CyberMUT, VeriSign Payflow Pro a MCVE.

Konečně máme mnoho dalších zajímavých rozšíření jako funkce vyhledávacího enginu mnoGoSearch, funkce pro IRC bránu, mnoho kompresních nástrojů (gzip, bz2), převody mezi kalendáři, překlady, ...

Jak můžete vidět, tato stránka není ani schopna pojmout všechny vlastnosti a výhody, které PHP nabízí. Pokračujte čtením sekcí o instalaci PHP a navštivte část popis funkcí, kde jsou zdokumentována zde uvedená rozšíření.

Předcházející | Nahoru | Další
1. Úvod | Domů | 2. Stručný tutoriál


Kapitola 2. Stručný tutoriál

Obsah

Co potřebuji?
Vaše první stránka v PHP
Něco užitečného
Práce s formuláři
Použití starého kódu s novými verzemi PHP
A co dál?

Rádi bychom zde ukázali naprosté základy PHP v krátkém, jednoduchém tutoriálu. Tento text se zabývá jen dynamickým generování WWW stránek pomocí PHP, přestože PHP umí mnohem více než pouze toto. Více informací - viz sekce s názvem Co dokáže PHP.

S webovými stránkami s PHP se zachází jako s normálními HTML stránkami a můžete je vytvářet a upravovat stejným způsobem, jako když vytváříte běžné HTML stránky.

Co potřebuji?

V tomto tutoriálu se předpokládá, že váš server má aktivovánu podporu PHP a že všechny soubory končící na .php jsou obslouženy pomocí PHP. Na většině serverů je to výchozí nastavení pro PHP soubory, ale pro jistotu se zeptejte správce serveru. Podporuje-li váš server PHP, nebudete potřebovat nic dělat. Pouze vytvořte své .php soubory, vložte je do webového adresáře a server je bude pro vás automaticky parsovat. Není nutné cokoli kompilovat ani instalovat nějaké zvláštní nástroje. Uvažujte o PHP souborech jako o jednoduchých HTML souborech s celou novou rodinou magických značek, které umožňují dělat celou řadu věcí. Většina webových hostingů nabízí podporu PHP, ale pokud ten váš nikoli, zvažte přečtení sekce » PHP odkazů pro prostředky k nalezení vhodného hostingu.

Řekněme, že chcete ušetřit drahocenné přenosové pásmo a vyvíjet místně (na vašem počítači). V takovém případě budete chtít nainstalovat webserver, například » Apache, a samozřejmě » PHP. Většinou budete chtít instalovat také databázi, kupříkladu » MySQL.

Tyto můžete instalovat individuálně nebo zvolit jednodušší cestu. Náš manuál má instrukce pro instalaci PHP (předpokládající, že už máte nainstalován webserver). Máte-li problémy s instalací samotného PHP, doporučujeme položit otázku na našem » instalačním e-mailovém fóru. Zvolíte-li jednodušší cestu, potom » najděte předkonfigurovaný balíček pro váš operační systém, který na pár kliknutí myší všechno automaticky nainstaluje. Je snadné nainstalovat webserver s podporou PHP na jakýkoli operační systém, včetně Mac OS X, Linuxu a Windows. Na Linuxu mohou být k nalezení balíků užitečné » rpmfind a » PBone. Můžete také navštívit » apt-get pro nalezení balíků pro Debian.

Předcházející | Nahoru | Další
Co dokáže PHP? | Domů | Vaše první stránka v PHP


Vaše první stránka v PHP

Vytvořte soubor nazvaný hello.php a vložte ho do kořenového adresáře vašeho webserveru (DOCUMENT_ROOT). Soubor bude mít následující obsah:

Příklad 2.1. Náš první PHP skript: hello.php

<html>
 <head>
  <title>PHP Test</title>
 </head>
 <body>
 <?php echo '<p>Ahoj světe</p>'; ?>
 </body>
</html>

Pro přístupu k souboru použijte váš webový prohlížeč, zadejte do něj URL serveru zakončený "/hello.php" (odkazem na soubor). Vyvíjíte-li lokálně, bude URL něco jako http://localhost/hello.php nebo http://127.0.0.1/hello.php, ale záleží to na konfiguraci serveru. Je-li všechno nakonfigurováno správně, soubor bude parsován interpretem PHP a ten pošle do vašeho prohlížeče tato data:

<html>
 <head>
  <title>PHP Test</title>
 </head>
 <body>
 <p>Ahoj světe</p>
 </body>
</html>

Tento program je extrémně jednoduchý a k vytváření takových stránek opravdu nepotřebujete PHP. Vše, co to udělá, je zobrazení Ahoj světe za použití PHP příkazu echo(). Uvědomte si, že soubor nemusí být spustitelný ani jinak speciální. Server zjistí, že tento soubor má být interpretován prostřednictvím PHP, protože má příponu ".php", kterou má server nakonfigurovánu k předávání do PHP. Uvažujte o tom jako o normálním HTML souboru, který vám poskytuje sadu zvláštních značek dělajících mnoho zajímavých věcí.

Pokud byste vyzkoušeli tento příklad a nic by se nevypsalo, vyskočil by dialog na stažení souboru nebo by byl vidět obsah souboru jako text, znamená to, že server, na kterém to zkoušíte, nemá (zapnutou) podporu PHP nebo není správně nakonfigurován. Požádejte administrátora, aby podporu zapnul za pomoci kapitoly Instalace z tohoto manuálu. Vyvíjíte-li lokálně, také si přečtěte kapitolu o instalaci, abyste se ujistili, že je vše správně nakonfigurováno. Přesvědčte se, že soubor voláte protokolem HTTP ze serveru, který ho poskytuje. Pokud byste soubor volali přímo (přes souborový systém), nebyl by parsován PHP. Pokud problémy přesto přetrvají, nestyďte se použít některou z možností » PHP podpory.

Cílem příkladu je ukázat speciální formát PHP značek. V tomto příkladu používáme k označení začátku PHP značku <?php. Pak vložíme příkaz PHP a opustíme PHP režim přidáním zavírací značky ?>. V HTML souboru můžete skákat dovnitř a ven z PHP režimu kdykoli chcete. Pro detailnější informace si přečtěte manuálovou sekci základní syntaxe PHP.

Poznámka ke koncům řádků: Konce řádků mají v HTML malý význam, přesto je však dobré vytvářet HTML kód tak, aby vypadal pěkně a čistě, vkládáním konců řádků. Odřádkování následující bezprostředně po uzavírací značce ?> bude v PHP odstraněno. To může být extrémně užitečné, pokud vkládáte mnoho bloků PHP nebo inkludujete soubory obsahující s PHP kódem, které nejsou určeny ke generování výstupu. Současně to ale může být trochu matoucí. K vynucení odřádkování můžete za uzavírací ?> vložit mezeru, nebo přidat explicitní odřádkování do posledního echo/print v PHP bloku.

Poznámka k textovým editorům: Existuje mnoho textových editorů a integrovaných vývojových prostředí (IDE), které můžete používat k tvorbě, úpravám a správě PHP souborů. Částečný seznam těchto nástrojů je udržován na » Seznam editorů PHP. Přejete-li si doporučit editor, navštivte prosím výše uvedenou stránku a požádejte jejího správce, aby přidal editor do seznemu. Může být užitečné používat editor se zvýrazněním syntaxe.

Poznámka k textovým procesorům: Textové procesory jako StarOffice Writer, Microsoft Word a Abiword nejsou vhodné pro editaci PHP souborů. Přejete-li si použít některý z nich pro tento testovací skript, musíte se ujistit, že soubor ukládáte jako holý text, jinak PHP nedokáže přečíst a vykonat skript.

Poznámka k poznámkovému bloku na Windows: Píšete-li své PHP skripty v poznámkovém bloku Windows, musíte se ujistit, že soubory ukládáte s příponou ".php". (Pokud neprovedete některý z následujících kroků, poznámkový blok automaticky přidá příponu ".txt"). Ukládáte-li soubor a jste tázáni na jeho název, dejte tento název do uvozovek (např. "hello.php"). Alternativně můžete rozbalit seznam typů souborů v dialogu a změnit typ z "Textové dokumenty" na "Všechny soubory". Pak lze vložit název souboru bez uvozovek.

Nyní, když jste úspěšně vytvořili fungující PHP skript, je čas vytvořit nejoblíbenější PHP skript! Zavolejte funkci phpinfo() a uvidíte množství užitečných informací o vašem systému a jeho nastavení, jako jsou dostupné předdefinované proměnné, načtené moduly PHP a konfigurační nastavení. Udělejte si chvíli času a tyto důležité informace si prohlédněte.

Příklad 2.2. Získání systémových informací z PHP

<?php phpinfo(); ?>

Předcházející | Nahoru | Další
2. Stručný tutoriál | Domů | Něco užitečného


Něco užitečného

Nyní udělejme něco ještě užitečnějšího. Budeme zjišťovat, jaký druh prohlížeče návštěvník používá. K tomuto účelu použijeme řetězec identifikace uživatelského agenta (User-Agent), který prohlížeč posílá jako součást HTTP požadavku. Tato informace je uložena v proměnné. Proměnné v PHP vždy začínají znakem dolaru. Proměnná, která nás právě teď zajímá, je $_SERVER['HTTP_USER_AGENT'].

Poznámka: $_SERVER je speciální vyhrazená proměnná PHP, která obsahuje všechny informace z webového serveru. Je známá též jako autoglobální (nebo superglobální) proměnná. Pro více informací viz související manuálovou stránku o superglobálních proměnných. Tyto speciální proměnné byly přidány v PHP » 4.1.0. Předtím jsme namísto nich používali starší pole $HTTP_*_VARS, jako např. $HTTP_SERVER_VARS. Přestože jsou již zavržené, tyto starší proměnné stále existují. (Viz také poznámku o starém kódu.)

Pro zobrazení této proměnné jednoduše napište:

Příklad 2.3. Tisk proměnné (elementu pole)

<?php echo $_SERVER['HTTP_USER_AGENT']; ?>

Ukázkový výstup z tohoto skriptu může vypadat takto:

Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

V PHP existuje mnoho typů proměnných. Ve výše uvedeném příkladu jsme vytiskli element pole. Pole jsou velice užitečná.

$_SERVER je jen jedna z proměnných, které vám PHP automaticky zpřístupňuje. Seznam proměnných najdete v manuálové sekci Vyhrazené proměnné, úplný seznam pak ve výstupu funkce phpinfo() použité v příkladu v předchozí sekci.

Mezi PHP značky můžete vložit více PHP příkazů a vytvářet tak malé bloky kódu, které dělají víc než jen jednoduché echo. Pokud chcete například zjistit, zda uživatel používá Internet Explorer, můžete udělat toto:

Příklad 2.4. Example using control structures and functions

<?php
if (strpos($_SERVER['HTTP_USER_AGENT'], 'MSIE') !== FALSE) {
    echo 'You are using Internet Explorer.<br />';
}
?>

A sample output of this script may be:

You are using Internet Explorer.<br />

Here we introduce a couple of new concepts. We have an if statement. If you are familiar with the basic syntax used by the C language, this should look logical to you. Otherwise, you should probably pick up an introductory PHP book and read the first couple of chapters, or read the Language Reference part of the manual. You can find a list of PHP books at » http://www.php.net/books.php.

The second concept we introduced was the strpos() function call. strpos() is a function built into PHP which searches a string for another string. In this case we are looking for 'MSIE' (so-called needle) inside $_SERVER['HTTP_USER_AGENT'] (so-called haystack). If the needle is found inside the haystack, the function returns the position of the needle relative to the start of the haystack. Otherwise, it returns FALSE. If it does not return FALSE, the if expression evaluates to TRUE and the code within its {braces} is executed. Otherwise, the code is not run. Feel free to create similar examples, with if, else, and other functions such as strtoupper() and strlen(). Each related manual page contains examples too. If you are unsure how to use functions, you will want to read both the manual page on how to read a function definition and the section about PHP functions.

We can take this a step further and show how you can jump in and out of PHP mode even in the middle of a PHP block:

Příklad 2.5. Mixing both HTML and PHP modes

<?php
if (strpos($_SERVER['HTTP_USER_AGENT'], 'MSIE') !== FALSE) {
?>
<h3>strpos() must have returned non-false</h3>
<p>You are using Internet Explorer</p>
<?php
} else {
?>
<h3>strpos() must have returned false</h3>
<p>You are not using Internet Explorer</p>
<?php
}
?>

A sample output of this script may be:

<h3>strpos() must have returned non-false</h3>
<p>You are using Internet Explorer</p>

Instead of using a PHP echo statement to output something, we jumped out of PHP mode and just sent straight HTML. The important and powerful point to note here is that the logical flow of the script remains intact. Only one of the HTML blocks will end up getting sent to the viewer depending on the result of strpos(). In other words, it depends on whether the string MSIE was found or not.

Předcházející | Nahoru | Další
Vaše první stránka v PHP | Domů | Práce s formuláři


Práce s formuláři

One of the most powerful features of PHP is the way it handles HTML forms. The basic concept that is important to understand is that any form element will automatically be available to your PHP scripts. Please read the manual section on Variables from outside of PHP for more information and examples on using forms with PHP. Here is an example HTML form:

Příklad 2.6. A simple HTML form

<form action="action.php" method="post">
 <p>Your name: <input type="text" name="name" /></p>
 <p>Your age: <input type="text" name="age" /></p>
 <p><input type="submit" /></p>
</form>

There is nothing special about this form. It is a straight HTML form with no special tags of any kind. When the user fills in this form and hits the submit button, the action.php page is called. In this file you would write something like this:

Příklad 2.7. Printing data from our form

Hi <?php echo $_POST['name']; ?>.
You are <?php echo $_POST['age']; ?> years old.

A sample output of this script may be:

Hi Joe. You are 22 years old.

It should be obvious what this does. There is nothing more to it. The $_POST['name'] and $_POST['age'] variables are automatically set for you by PHP. Earlier we used the $_SERVER autoglobal; above we just introduced the $_POST autoglobal which contains all POST data. Notice how the method of our form is POST. If we used the method GET then our form information would live in the $_GET autoglobal instead. You may also use the $_REQUEST autoglobal, if you do not care about the source of your request data. It contains the merged information of GET, POST and COOKIE data. Also see the import_request_variables() function.

You can also deal with XForms input in PHP, although you will find yourself comfortable with the well supported HTML forms for quite some time. While working with XForms is not for beginners, you might be interested in them. We also have a short introduction to handling data received from XForms in our features section.

Předcházející | Nahoru | Další
Něco užitečného | Domů | Použití starého kódu s novými verzemi PHP


Použití starého kódu s novými verzemi PHP

Now that PHP has grown to be a popular scripting language, there are a lot of public repositories and libraries containing code you can reuse. The PHP developers have largely tried to preserve backwards compatibility, so a script written for an older version will run (ideally) without changes in a newer version of PHP. In practice, some changes will usually be needed.

Two of the most important recent changes that affect old code are:

  • The deprecation of the old $HTTP_*_VARS arrays (which need to be indicated as global when used inside a function or method). The following autoglobal arrays were introduced in PHP » 4.1.0. They are: $_GET, $_POST, $_COOKIE, $_SERVER, $_FILES, $_ENV, $_REQUEST, and $_SESSION. The older $HTTP_*_VARS arrays, such as $HTTP_POST_VARS, still exist as they have since PHP 3. Od PHP 5.0.0 mohou být dlouhá pole předdefinovaných proměnných deaktivována direktivou register_long_arrays.
  • External variables are no longer registered in the global scope by default. In other words, as of PHP » 4.2.0 the PHP directive register_globals is off by default in php.ini. The preferred method of accessing these values is via the autoglobal arrays mentioned above. Older scripts, books, and tutorials may rely on this directive being on. If it were on, for example, one could use $id from the URL http://www.example.com/foo.php?id=42. Whether on or off, $_GET['id'] is available.
For more details on these changes, see the section on predefined variables and links therein.

Předcházející | Nahoru | Další
Práce s formuláři | Domů | A co dál?


A co dál?

With your new knowledge you should be able to understand most of the manual and also the various example scripts available in the example archives. You can also find other examples on the php.net websites in the links section: » http://www.php.net/links.php.

To view various slide presentations that show more of what PHP can do, see the PHP Conference Material Sites: » http://conf.php.net/ and » http://talks.php.net/

Předcházející | Nahoru | Další
Použití starého kódu s novými verzemi PHP | Domů | II. Instalace a konfigurace


Část III. Reference jazyka

Obsah

10. Základní syntaxe
11. Types
12. Proměnné
13. Konstanty
14. Výrazy
15. Operátory
16. Řídicí struktury
17. Funkce
18. Classes and Objects (PHP 4)
19. Classes and Objects (PHP 5)
20. Namespaces
21. Exceptions
22. Vysvětlení referencí (odkazů)
Předcházející | Nahoru | Další
How to change configuration settings | Domů | 10. Základní syntaxe


Kapitola 10. Základní syntaxe

Obsah

Opuštění HTML
Oddělování instrukcí
Komentáře

Opuštění HTML

Jsou čtyři způsoby jak opustit HTML a vstoupit do "PHP módu":

Příklad 10.1. Způsoby opuštění HTML

1.  <? echo ("toto je nejjednodušší SGML zpracovatelská instrukce\n"); ?>

2.  <?php echo("pokud chcete zpracovávat XHTML nebo XML dokumenty, používejte toto\n"); ?>

3.  <script language="php">
        echo ("některé editory (například FrontPage) nemají zpracovatelské instrukce v lásce");
    </script>

4.  <% echo ("případně můžete používat ASP tagy"); %>
    <%= $variable; # toto je zkratka za "<%echo .." %>

První způsob je dostupný pouze, pokud jsou povoleny krátké tagy. To se dá udělat povolením konfigurační direktivy short_open_tag v konfiguračním souboru PHP, nebo kompilací PHP s configure volbou --enable-short-tags.

Obecně preferovanou metodou je druhý způsob, protože umožňuje snadnou implementaci dalšího generování XHTML z PHP.

Čtvrtý způsob je dostupný, pouze pokud byly povoleny ASP tagy pomocí konfigurační direktivy asp_tags.

Poznámka: Podpora ASP tagů byla přidána v 3.0.4.

Případná bezprostředně následující sekvence konce řádku je součástí uzavírajícího tagu.

Předcházející | Nahoru | Další
III. Reference jazyka | Domů | Oddělování instrukcí


Oddělování instrukcí

Instrukce se oddělují stejně jako v C nebo Perlu - ukončujte každý výraz středníkem.

Uzavírající tag (?>) také implikuje konec výrazu, takže následující ukázky jsou ekvivalentní:

<?php
    echo "Toto je test";
?>

<?php echo "Toto je test" ?>

Předcházející | Nahoru | Další
10. Základní syntaxe | Domů | Komentáře


Komentáře

PHP podporuje komentářové notace jazyků 'C', 'C++' a Unixového shellu. Například:

<?php
    echo "Toto je test"; // Toto je jednořádkový komentář typu C++
    /* Toto je víceřádkový komentář
       a ještě jeden komentář */
    echo "Toto je další test";
    echo "Poslední Test"; # Toto je komentář shellového typu
?>

Jednořádkové typy komentářů ve skutečnosti komentují do konce řádku nebo současného bloku PHP kódu, podle toho, co se vyskytuje dřív.

<h1>Toto je  <?php # echo "malý";?> příklad.</h1>
<p>Hlavička na předchozím řádku bude 'Toto je příklad'.

Měli byste si dát pozor na vnořování komentářů typu 'C++', ke kterému může dojít při zakomentování velkých bloků.

<?php
 /*
    echo "Toto je test"; /* Tento komentář způsobí problém */
 */
?>

Předcházející | Nahoru | Další
Oddělování instrukcí | Domů | 11. Types


Kapitola 11. Types

Obsah

Introduction
Booleans
Integers
Floating point numbers
Strings
Arrays
Objects
Resource
NULL
Pseudo-types and variables used in this documentation
Type Juggling

Introduction

PHP supports eight primitive types.

Four scalar types:

  • boolean
  • integer
  • float (floating-point number, aka 'double')
  • string
Two compound types:
  • array
  • object
And finally two special types:
  • resource
  • NULL
This manual also introduces some pseudo-types for readability reasons:
  • mixed
  • number
  • callback
And the pseudo-variable $....

You may also find some references to the type "double". Consider double the same as float, the two names exist only for historic reasons.

The type of a variable is usually not set by the programmer; rather, it is decided at runtime by PHP depending on the context in which that variable is used.

Poznámka: If you want to check out the type and value of a certain expression, use var_dump().

If you simply want a human-readable representation of the type for debugging, use gettype(). To check for a certain type, do not use gettype(), but use the is_type functions. Some examples:

<?php
$a_bool = TRUE;   // a boolean
$a_str  = "foo";  // a string
$a_str2 = 'foo';  // a string
$an_int = 12;     // an integer

echo gettype($a_bool); // prints out:  boolean
echo gettype($a_str);  // prints out:  string

// If this is an integer, increment it by four
if (is_int($an_int)) {
    $an_int += 4;
}

// If $bool is a string, print it out
// (does not print out anything)
if (is_string($a_bool)) {
    echo "String: $a_bool";
}
?>

If you would like to force a variable to be converted to a certain type, you may either cast the variable or use the settype() function on it.

Note that a variable may be evaluated with different values in certain situations, depending on what type it is at the time. For more information, see the section on Type Juggling. Also, you may be interested in viewing the type comparison tables, as they show examples of various type related comparisons.

Předcházející | Nahoru | Další
Komentáře | Domů | Booleans


Booleans

This is the easiest type. A boolean expresses a truth value. It can be either TRUE or FALSE.

Poznámka: The boolean type was introduced in PHP 4.

Syntax

To specify a boolean literal, use either the keyword TRUE or FALSE. Both are case-insensitive.

<?php
$foo = True; // assign the value TRUE to $foo
?>

Usually you use some kind of operator which returns a boolean value, and then pass it on to a control structure.

<?php
// == is an operator which test
// equality and returns a boolean
if ($action == "show_version") {
    echo "The version is 1.23";
}

// this is not necessary...
if ($show_separators == TRUE) {
    echo "<hr>\n";
}

// ...because you can simply type
if ($show_separators) {
    echo "<hr>\n";
}
?>

Converting to boolean

To explicitly convert a value to boolean, use either the (bool) or the (boolean) cast. However, in most cases you do not need to use the cast, since a value will be automatically converted if an operator, function or control structure requires a boolean argument.

See also Type Juggling.

When converting to boolean, the following values are considered FALSE:

  • the boolean FALSE itself
  • the integer 0 (zero)
  • the float 0.0 (zero)
  • the empty string, and the string "0"
  • an array with zero elements
  • an object with zero member variables (PHP 4 only)
  • the special type NULL (including unset variables)
  • SimpleXML objects created from empty tags
Every other value is considered TRUE (including any resource).
Varování

-1 is considered TRUE, like any other non-zero (whether negative or positive) number!

<?php
var_dump((bool) "");        // bool(false)
var_dump((bool) 1);         // bool(true)
var_dump((bool) -2);        // bool(true)
var_dump((bool) "foo");     // bool(true)
var_dump((bool) 2.3e5);     // bool(true)
var_dump((bool) array(12)); // bool(true)
var_dump((bool) array());   // bool(false)
var_dump((bool) "false");   // bool(true)
?>

Předcházející | Nahoru | Další
11. Types | Domů | Integers


Integers

An integer is a number of the set Z = {..., -2, -1, 0, 1, 2, ...}.

See also: Arbitrary length integer / GMP, Floating point numbers, and Arbitrary precision / BCMath

Syntax

Integers can be specified in decimal (10-based), hexadecimal (16-based) or octal (8-based) notation, optionally preceded by a sign (- or +).

If you use the octal notation, you must precede the number with a 0 (zero), to use hexadecimal notation precede the number with 0x.

Příklad 11.1. Integer literals

<?php
$a = 1234; // decimal number
$a = -123; // a negative number
$a = 0123; // octal number (equivalent to 83 decimal)
$a = 0x1A; // hexadecimal number (equivalent to 26 decimal)
?>

Formally the possible structure for integer literals is:

decimal     : [1-9][0-9]*
            | 0

hexadecimal : 0[xX][0-9a-fA-F]+

octal       : 0[0-7]+

integer     : [+-]?decimal
            | [+-]?hexadecimal
            | [+-]?octal
The size of an integer is platform-dependent, although a maximum value of about two billion is the usual value (that's 32 bits signed). PHP does not support unsigned integers. Integer size can be determined from PHP_INT_SIZE, maximum value from PHP_INT_MAX since PHP 4.4.0 and PHP 5.0.5.

Varování

If an invalid digit is passed to octal integer (i.e. 8 or 9), the rest of the number is ignored.

Příklad 11.2. Octal weirdness

<?php
var_dump(01090); // 010 octal = 8 decimal
?>

Integer overflow

If you specify a number beyond the bounds of the integer type, it will be interpreted as a float instead. Also, if you perform an operation that results in a number beyond the bounds of the integer type, a float will be returned instead.

<?php
$large_number =  2147483647;
var_dump($large_number);
// output: int(2147483647)

$large_number =  2147483648;
var_dump($large_number);
// output: float(2147483648)

// it's true also for hexadecimal specified integers between 2^31 and 2^32-1:
var_dump( 0xffffffff );
// output: float(4294967295)

// this doesn't go for hexadecimal specified integers above 2^32-1:
var_dump( 0x100000000 );
// output: int(2147483647)

$million = 1000000;
$large_number =  50000 * $million;
var_dump($large_number);
// output: float(50000000000)
?>
Varování

Unfortunately, there was a bug in PHP so that this does not always work correctly when there are negative numbers involved. For example: when you do -50000 * $million, the result will be -429496728. However, when both operands are positive there is no problem.

This is solved in PHP 4.1.0.

There is no integer division operator in PHP. 1/2 yields the float 0.5. You can cast the value to an integer to always round it downwards, or you can use the round() function.

<?php
var_dump(25/7);         // float(3.5714285714286)
var_dump((int) (25/7)); // int(3)
var_dump(round(25/7));  // float(4)
?>

Converting to integer

To explicitly convert a value to integer, use either the (int) or the (integer) cast. However, in most cases you do not need to use the cast, since a value will be automatically converted if an operator, function or control structure requires an integer argument. You can also convert a value to integer with the function intval().

See also type-juggling.

From booleans

FALSE will yield 0 (zero), and TRUE will yield 1 (one).

From floating point numbers

When converting from float to integer, the number will be rounded towards zero.

If the float is beyond the boundaries of integer (usually +/- 2.15e+9 = 2^31), the result is undefined, since the float hasn't got enough precision to give an exact integer result. No warning, not even a notice will be issued in this case!

Varování

Never cast an unknown fraction to integer, as this can sometimes lead to unexpected results.

<?php
echo (int) ( (0.1+0.7) * 10 ); // echoes 7!
?>
See for more information the warning about float-precision.

From strings

See String conversion to numbers

From other types

Výstraha

Behaviour of converting to integer is undefined for other types. Currently, the behaviour is the same as if the value was first converted to boolean. However, do not rely on this behaviour, as it can change without notice.

Předcházející | Nahoru | Další
Booleans | Domů | Floating point numbers


Floating point numbers

Floating point numbers (AKA "floats", "doubles" or "real numbers") can be specified using any of the following syntaxes:

<?php
$a = 1.234;
$b = 1.2e3;
$c = 7E-10;
?>
Formally:
LNUM          [0-9]+
DNUM          ([0-9]*[\.]{LNUM}) | ({LNUM}[\.][0-9]*)
EXPONENT_DNUM ( ({LNUM} | {DNUM}) [eE][+-]? {LNUM})
The size of a float is platform-dependent, although a maximum of ~1.8e308 with a precision of roughly 14 decimal digits is a common value (that's 64 bit IEEE format).

Floating point precision

It is quite usual that simple decimal fractions like 0.1 or 0.7 cannot be converted into their internal binary counterparts without a little loss of precision. This can lead to confusing results: for example, floor((0.1+0.7)*10) will usually return 7 instead of the expected 8 as the result of the internal representation really being something like 7.9999999999....

This is related to the fact that it is impossible to exactly express some fractions in decimal notation with a finite number of digits. For instance, 1/3 in decimal form becomes 0.3333333. . ..

So never trust floating number results to the last digit and never compare floating point numbers for equality. If you really need higher precision, you should use the arbitrary precision math functions or gmp functions instead.

Converting to float

For information on when and how strings are converted to floats, see the section titled String conversion to numbers. For values of other types, the conversion is the same as if the value would have been converted to integer and then to float. See the Converting to integer section for more information. As of PHP 5, notice is thrown if you try to convert object to float.

Předcházející | Nahoru | Další
Integers | Domů | Strings


Strings

A string is series of characters. In PHP, a character is the same as a byte, that is, there are exactly 256 different characters possible. This also implies that PHP has no native support of Unicode. See utf8_encode() and utf8_decode() for some Unicode support.

Poznámka: It is no problem for a string to become very large. There is no practical bound to the size of strings imposed by PHP, so there is no reason at all to worry about long strings.

Syntax

A string literal can be specified in three different ways.

  • single quoted
  • double quoted
  • heredoc syntax

Single quoted

The easiest way to specify a simple string is to enclose it in single quotes (the character ').

To specify a literal single quote, you will need to escape it with a backslash (\), like in many other languages. If a backslash needs to occur before a single quote or at the end of the string, you need to double it. Note that if you try to escape any other character, the backslash will also be printed! So usually there is no need to escape the backslash itself.

Poznámka: In PHP 3, a warning will be issued at the E_NOTICE level when this happens.

Poznámka: Unlike the two other syntaxes, variables and escape sequences for special characters will not be expanded when they occur in single quoted strings.

<?php
echo 'this is a simple string';

echo 'You can also have embedded newlines in
strings this way as it is
okay to do';

// Outputs: Arnold once said: "I'll be back"
echo 'Arnold once said: "I\'ll be back"';

// Outputs: You deleted C:\*.*?
echo 'You deleted C:\\*.*?';

// Outputs: You deleted C:\*.*?
echo 'You deleted C:\*.*?';

// Outputs: This will not expand: \n a newline
echo 'This will not expand: \n a newline';

// Outputs: Variables do not $expand $either
echo 'Variables do not $expand $either';
?>

Double quoted

If the string is enclosed in double-quotes ("), PHP understands more escape sequences for special characters:

Tabulka 11.1. Escaped characters

sequence | meaning
\n | linefeed (LF or 0x0A (10) in ASCII)
\r | carriage return (CR or 0x0D (13) in ASCII)
\t | horizontal tab (HT or 0x09 (9) in ASCII)
\v | vertical tab (VT or 0x0B (11) in ASCII) (since PHP 5.2.5)
\f | form feed (FF or 0x0C (12) in ASCII) (since PHP 5.2.5)
\\ | backslash
\$ | dollar sign
\" | double-quote
\[0-7]{1,3} | the sequence of characters matching the regular expression is a character in octal notation
\x[0-9A-Fa-f]{1,2} | the sequence of characters matching the regular expression is a character in hexadecimal notation

Again, if you try to escape any other character, the backslash will be printed too! Before PHP 5.1.1, backslash in \{$var} hasn't been printed.

But the most important feature of double-quoted strings is the fact that variable names will be expanded. See string parsing for details.

Heredoc

Another way to delimit strings is by using heredoc syntax ("<<<"). One should provide an identifier (followed by new line) after <<<, then the string, and then the same identifier to close the quotation.

The closing identifier must begin in the first column of the line. Also, the identifier used must follow the same naming rules as any other label in PHP: it must contain only alphanumeric characters and underscores, and must start with a non-digit character or underscore.

Varování

It is very important to note that the line with the closing identifier contains no other characters, except possibly a semicolon (;). That means especially that the identifier may not be indented, and there may not be any spaces or tabs after or before the semicolon. It's also important to realize that the first character before the closing identifier must be a newline as defined by your operating system. This is \r on Macintosh for example. Closing delimiter (possibly followed by a semicolon) must be followed by a newline too.

If this rule is broken and the closing identifier is not "clean" then it's not considered to be a closing identifier and PHP will continue looking for one. If in this case a proper closing identifier is not found then a parse error will result with the line number being at the end of the script.

It is not allowed to use heredoc syntax in initializing class members. Use other string syntaxes instead.

Příklad 11.3. Invalid example

<?php
class foo {
    public $bar = <<<EOT
bar
EOT;
}
?>

Heredoc text behaves just like a double-quoted string, without the double-quotes. This means that you do not need to escape quotes in your here docs, but you can still use the escape codes listed above. Variables are expanded, but the same care must be taken when expressing complex variables inside a heredoc as with strings.

Příklad 11.4. Heredoc string quoting example

<?php
$str = <<<EOD
Example of string
spanning multiple lines
using heredoc syntax.
EOD;

/* More complex example, with variables. */
class foo
{
    var $foo;
    var $bar;

    function foo()
    {
        $this->foo = 'Foo';
        $this->bar = array('Bar1', 'Bar2', 'Bar3');
    }
}

$foo = new foo();
$name = 'MyName';

echo <<<EOT
My name is "$name". I am printing some $foo->foo.
Now, I am printing some {$foo->bar[1]}.
This should print a capital 'A': \x41
EOT;
?>

Poznámka: Heredoc support was added in PHP 4.

Variable parsing

When a string is specified in double quotes or with heredoc, variables are parsed within it.

There are two types of syntax: a simple one and a complex one. The simple syntax is the most common and convenient. It provides a way to parse a variable, an array value, or an object property.

The complex syntax was introduced in PHP 4, and can be recognised by the curly braces surrounding the expression.

Simple syntax

If a dollar sign ($) is encountered, the parser will greedily take as many tokens as possible to form a valid variable name. Enclose the variable name in curly braces if you want to explicitly specify the end of the name.

<?php
$beer = 'Heineken';
echo "$beer's taste is great"; // works, "'" is an invalid character for varnames
echo "He drank some $beers";   // won't work, 's' is a valid character for varnames
echo "He drank some ${beer}s"; // works
echo "He drank some {$beer}s"; // works
?>

Similarly, you can also have an array index or an object property parsed. With array indices, the closing square bracket (]) marks the end of the index. For object properties the same rules apply as to simple variables, though with object properties there doesn't exist a trick like the one with variables.

<?php
// These examples are specific to using arrays inside of strings.
// When outside of a string, always quote your array string keys
// and do not use {braces} when outside of strings either.

// Let's show all errors
error_reporting(E_ALL);

$fruits = array('strawberry' => 'red', 'banana' => 'yellow');

// Works but note that this works differently outside string-quotes
echo "A banana is $fruits[banana].";

// Works
echo "A banana is {$fruits['banana']}.";

// Works but PHP looks for a constant named banana first
// as described below.
echo "A banana is {$fruits[banana]}.";

// Won't work, use braces.  This results in a parse error.
echo "A banana is $fruits['banana'].";

// Works
echo "A banana is " . $fruits['banana'] . ".";

// Works
echo "This square is $square->width meters broad.";

// Won't work. For a solution, see the complex syntax.
echo "This square is $square->width00 centimeters broad.";
?>

For anything more complex, you should use the complex syntax.

Complex (curly) syntax

This isn't called complex because the syntax is complex, but because you can include complex expressions this way.

In fact, you can include any value that is in the namespace in strings with this syntax. You simply write the expression the same way as you would outside the string, and then include it in { and }. Since you can't escape '{', this syntax will only be recognised when the $ is immediately following the {. (Use "{\$" to get a literal "{$"). Some examples to make it clear:

<?php
// Let's show all errors
error_reporting(E_ALL);

$great = 'fantastic';

// Won't work, outputs: This is { fantastic}
echo "This is { $great}";

// Works, outputs: This is fantastic
echo "This is {$great}";
echo "This is ${great}";

// Works
echo "This square is {$square->width}00 centimeters broad.";

// Works
echo "This works: {$arr[4][3]}";

// This is wrong for the same reason as $foo[bar] is wrong
// outside a string.  In other words, it will still work but
// because PHP first looks for a constant named foo, it will
// throw an error of level E_NOTICE (undefined constant).
echo "This is wrong: {$arr[foo][3]}";

// Works.  When using multi-dimensional arrays, always use
// braces around arrays when inside of strings
echo "This works: {$arr['foo'][3]}";

// Works.
echo "This works: " . $arr['foo'][3];

echo "You can even write {$obj->values[3]->name}";

echo "This is the value of the var named $name: {${$name}}";
?>

Poznámka: Functions and method calls work since PHP 5.

Poznámka: Parsing variables within strings uses more memory than string concatenation. When writing a PHP script in which memory usage is a concern, consider using the concatenation operator (.) rather than variable parsing.

String access and modification by character

Characters within strings may be accessed and modified by specifying the zero-based offset of the desired character after the string using square array-brackets like $str[42] so think of a string as an array of characters.

Poznámka: They may also be accessed using braces like $str{42} for the same purpose. However, using square array-brackets is preferred because the {braces} style is deprecated as of PHP 6.

Příklad 11.5. Some string examples

<?php
// Get the first character of a string
$str = 'This is a test.';
$first = $str[0];

// Get the third character of a string
$third = $str[2];

// Get the last character of a string.
$str = 'This is still a test.';
$last = $str[strlen($str)-1];

// Modify the last character of a string
$str = 'Look at the sea';
$str[strlen($str)-1] = 'e';

// Alternative method using {} is deprecated as of PHP 6
$third = $str{2};

?>

Poznámka: Accessing by [] or {} to variables of other type silently returns NULL.

Useful functions and operators

Strings may be concatenated using the '.' (dot) operator. Note that the '+' (addition) operator will not work for this. Please see String operators for more information.

There are a lot of useful functions for string modification.

See the string functions section for general functions, the regular expression functions for advanced find&replacing (in two tastes: Perl and POSIX extended).

There are also functions for URL-strings, and functions to encrypt/decrypt strings (mcrypt and mhash).

Finally, if you still didn't find what you're looking for, see also the character type functions.

Converting to string

You can convert a value to a string using the (string) cast, or the strval() function. String conversion is automatically done in the scope of an expression for you where a string is needed. This happens when you use the echo() or print() functions, or when you compare a variable value to a string. Reading the manual sections on Types and Type Juggling will make the following clearer. See also settype().

A boolean TRUE value is converted to the string "1", the FALSE value is represented as "" (empty string). This way you can convert back and forth between boolean and string values.

An integer or a floating point number (float) is converted to a string representing the number with its digits (including the exponent part for floating point numbers). Floating point numbers can be converted using the exponential notation (4.1E+6).

Poznámka: The decimal point character is defined in the script's locale (category LC_NUMERIC). See setlocale().

Arrays are always converted to the string "Array", so you cannot dump out the contents of an array with echo() or print() to see what is inside them. To view one element, you'd do something like echo $arr['foo']. See below for tips on dumping/viewing the entire contents.

Objects in PHP 4 are always converted to the string "Object". If you would like to print out the member variable values of an object for debugging reasons, read the paragraphs below. If you would like to find out the class name of which an object is an instance of, use get_class(). As of PHP 5, __toString() method is used if applicable.

Resources are always converted to strings with the structure "Resource id #1" where 1 is the unique number of the resource assigned by PHP during runtime. If you would like to get the type of the resource, use get_resource_type().

NULL is always converted to an empty string.

As you can see above, printing out the arrays, objects or resources does not provide you any useful information about the values themselves. Look at the functions print_r() and var_dump() for better ways to print out values for debugging.

You can also convert PHP values to strings to store them permanently. This method is called serialization, and can be done with the function serialize(). You can also serialize PHP values to XML structures, if you have WDDX support in your PHP setup.

String conversion to numbers

When a string is evaluated as a numeric value, the resulting value and type are determined as follows.

The string will evaluate as a float if it contains any of the characters '.', 'e', or 'E'. Otherwise, it will evaluate as an integer.

The value is given by the initial portion of the string. If the string starts with valid numeric data, this will be the value used. Otherwise, the value will be 0 (zero). Valid numeric data is an optional sign, followed by one or more digits (optionally containing a decimal point), followed by an optional exponent. The exponent is an 'e' or 'E' followed by one or more digits.

<?php
$foo = 1 + "10.5";                // $foo is float (11.5)
$foo = 1 + "-1.3e3";              // $foo is float (-1299)
$foo = 1 + "bob-1.3e3";           // $foo is integer (1)
$foo = 1 + "bob3";                // $foo is integer (1)
$foo = 1 + "10 Small Pigs";       // $foo is integer (11)
$foo = 4 + "10.2 Little Piggies"; // $foo is float (14.2)
$foo = "10.0 pigs " + 1;          // $foo is float (11)
$foo = "10.0 pigs " + 1.0;        // $foo is float (11)
?>

For more information on this conversion, see the Unix manual page for strtod(3).

If you would like to test any of the examples in this section, you can cut and paste the examples and insert the following line to see for yourself what's going on:

<?php
echo "\$foo==$foo; type is " . gettype ($foo) . "<br />\n";
?>

Do not expect to get the code of one character by converting it to integer (as you would do in C for example). Use the functions ord() and chr() to convert between charcodes and characters.

Předcházející | Nahoru | Další
Floating point numbers | Domů | Arrays


Arrays

An array in PHP is actually an ordered map. A map is a type that maps values to keys. This type is optimized in several ways, so you can use it as a real array, or a list (vector), hashtable (which is an implementation of a map), dictionary, collection, stack, queue and probably more. Because you can have another PHP array as a value, you can also quite easily simulate trees.

Explanation of those data structures is beyond the scope of this manual, but you'll find at least one example for each of them. For more information we refer you to external literature about this broad topic.

Syntax

Specifying with array()

An array can be created by the array() language-construct. It takes a certain number of comma-separated key => value pairs.

array(  key =>  value
     , ...
     )
// key may be an integer or string
// value may be any value

<?php
$arr = array("foo" => "bar", 12 => true);

echo $arr["foo"]; // bar
echo $arr[12];    // 1
?>

A key may be either an integer or a string. If a key is the standard representation of an integer, it will be interpreted as such (i.e. "8" will be interpreted as 8, while "08" will be interpreted as "08"). Floats in key are truncated to integer. There are no different indexed and associative array types in PHP; there is only one array type, which can both contain integer and string indices.

A value can be of any PHP type.

<?php
$arr = array("somearray" => array(6 => 5, 13 => 9, "a" => 42));

echo $arr["somearray"][6];    // 5
echo $arr["somearray"][13];   // 9
echo $arr["somearray"]["a"];  // 42
?>

If you do not specify a key for a given value, then the maximum of the integer indices is taken, and the new key will be that maximum value + 1. If you specify a key that already has a value assigned to it, that value will be overwritten.

<?php
// This array is the same as ...
array(5 => 43, 32, 56, "b" => 12);

// ...this array
array(5 => 43, 6 => 32, 7 => 56, "b" => 12);
?>

Varování

As of PHP 4.3.0, the index generation behaviour described above has changed. Now, if you append to an array in which the current maximum key is negative, then the next key created will be zero (0). Before, the new index would have been set to the largest existing key + 1, the same as positive indices are.

Using TRUE as a key will evaluate to integer 1 as key. Using FALSE as a key will evaluate to integer 0 as key. Using NULL as a key will evaluate to the empty string. Using the empty string as key will create (or overwrite) a key with the empty string and its value; it is not the same as using empty brackets.

You cannot use arrays or objects as keys. Doing so will result in a warning: Illegal offset type.

Creating/modifying with square-bracket syntax

You can also modify an existing array by explicitly setting values in it.

This is done by assigning values to the array while specifying the key in brackets. You can also omit the key, add an empty pair of brackets ("[]") to the variable name in that case.

$arr[key] = value;
$arr[] = value;
// key may be an integer or string
// value may be any value
If $arr doesn't exist yet, it will be created. So this is also an alternative way to specify an array. To change a certain value, just assign a new value to an element specified with its key. If you want to remove a key/value pair, you need to unset() it.
<?php
$arr = array(5 => 1, 12 => 2);

$arr[] = 56;    // This is the same as $arr[13] = 56;
                // at this point of the script

$arr["x"] = 42; // This adds a new element to
                // the array with key "x"

unset($arr[5]); // This removes the element from the array

unset($arr);    // This deletes the whole array
?>

Poznámka: As mentioned above, if you provide the brackets with no key specified, then the maximum of the existing integer indices is taken, and the new key will be that maximum value + 1 . If no integer indices exist yet, the key will be 0 (zero). If you specify a key that already has a value assigned to it, that value will be overwritten.

Varování

As of PHP 4.3.0, the index generation behaviour described above has changed. Now, if you append to an array in which the current maximum key is negative, then the next key created will be zero (0). Before, the new index would have been set to the largest existing key + 1, the same as positive indices are.

Note that the maximum integer key used for this need not currently exist in the array. It simply must have existed in the array at some time since the last time the array was re-indexed. The following example illustrates:

<?php
// Create a simple array.
$array = array(1, 2, 3, 4, 5);
print_r($array);

// Now delete every item, but leave the array itself intact:
foreach ($array as $i => $value) {
    unset($array[$i]);
}
print_r($array);

// Append an item (note that the new key is 5, instead of 0 as you
// might expect).
$array[] = 6;
print_r($array);

// Re-index:
$array = array_values($array);
$array[] = 7;
print_r($array);
?>

Výše uvedený příklad vypíše:

Array
(
    [0] => 1
    [1] => 2
    [2] => 3
    [3] => 4
    [4] => 5
)
Array
(
)
Array
(
    [5] => 6
)
Array
(
    [0] => 6
    [1] => 7
)

Useful functions

There are quite a few useful functions for working with arrays. See the array functions section.

Poznámka: The unset() function allows unsetting keys of an array. Be aware that the array will NOT be reindexed. If you only use "usual integer indices" (starting from zero, increasing by one), you can achieve the reindex effect by using array_values().

<?php
$a = array(1 => 'one', 2 => 'two', 3 => 'three');
unset($a[2]);
/* will produce an array that would have been defined as
   $a = array(1 => 'one', 3 => 'three');
   and NOT
   $a = array(1 => 'one', 2 =>'three');
*/

$b = array_values($a);
// Now $b is array(0 => 'one', 1 =>'three')
?>

The foreach control structure exists specifically for arrays. It provides an easy way to traverse an array.

Array do's and don'ts

Why is $foo[bar] wrong?

You should always use quotes around a string literal array index. For example, use $foo['bar'] and not $foo[bar]. But why is $foo[bar] wrong? You might have seen the following syntax in old scripts:

<?php
$foo[bar] = 'enemy';
echo $foo[bar];
// etc
?>
This is wrong, but it works. Then, why is it wrong? The reason is that this code has an undefined constant (bar) rather than a string ('bar' - notice the quotes), and PHP may in future define constants which, unfortunately for your code, have the same name. It works because PHP automatically converts a bare string (an unquoted string which does not correspond to any known symbol) into a string which contains the bare string. For instance, if there is no defined constant named bar, then PHP will substitute in the string 'bar' and use that.

Poznámka: This does not mean to always quote the key. You do not want to quote keys which are constants or variables, as this will prevent PHP from interpreting them.

<?php
error_reporting(E_ALL);
ini_set('display_errors', true);
ini_set('html_errors', false);
// Simple array:
$array = array(1, 2);
$count = count($array);
for ($i = 0; $i < $count; $i++) {
    echo "\nChecking $i: \n";
    echo "Bad: " . $array['$i'] . "\n";
    echo "Good: " . $array[$i] . "\n";
    echo "Bad: {$array['$i']}\n";
    echo "Good: {$array[$i]}\n";
}
?>

Výše uvedený příklad vypíše:

Checking 0:
Notice: Undefined index:  $i in /path/to/script.html on line 9
Bad:
Good: 1
Notice: Undefined index:  $i in /path/to/script.html on line 11
Bad:
Good: 1

Checking 1:
Notice: Undefined index:  $i in /path/to/script.html on line 9
Bad:
Good: 2
Notice: Undefined index:  $i in /path/to/script.html on line 11
Bad:
Good: 2

More examples to demonstrate this fact:

<?php
// Let's show all errors
error_reporting(E_ALL);

$arr = array('fruit' => 'apple', 'veggie' => 'carrot');

// Correct
print $arr['fruit'];  // apple
print $arr['veggie']; // carrot

// Incorrect.  This works but also throws a PHP error of
// level E_NOTICE because of an undefined constant named fruit
//
// Notice: Use of undefined constant fruit - assumed 'fruit' in...
print $arr[fruit];    // apple

// Let's define a constant to demonstrate what's going on.  We
// will assign value 'veggie' to a constant named fruit.
define('fruit', 'veggie');

// Notice the difference now
print $arr['fruit'];  // apple
print $arr[fruit];    // carrot

// The following is okay as it's inside a string.  Constants are not
// looked for within strings so no E_NOTICE error here
print "Hello $arr[fruit]";      // Hello apple

// With one exception, braces surrounding arrays within strings
// allows constants to be looked for
print "Hello {$arr[fruit]}";    // Hello carrot
print "Hello {$arr['fruit']}";  // Hello apple

// This will not work, results in a parse error such as:
// Parse error: parse error, expecting T_STRING' or T_VARIABLE' or T_NUM_STRING'
// This of course applies to using superglobals in strings as well
print "Hello $arr['fruit']";
print "Hello $_GET['foo']";

// Concatenation is another option
print "Hello " . $arr['fruit']; // Hello apple
?>

When you turn error_reporting() up to show E_NOTICE level errors (such as setting it to E_ALL) then you will see these errors. By default, error_reporting is turned down to not show them.

As stated in the syntax section, there must be an expression between the square brackets ('[' and ']'). That means that you can write things like this:

<?php
echo $arr[somefunc($bar)];
?>
This is an example of using a function return value as the array index. PHP also knows about constants, as you may have seen the E_* ones before.
<?php
$error_descriptions[E_ERROR]   = "A fatal error has occured";
$error_descriptions[E_WARNING] = "PHP issued a warning";
$error_descriptions[E_NOTICE]  = "This is just an informal notice";
?>
Note that E_ERROR is also a valid identifier, just like bar in the first example. But the last example is in fact the same as writing:
<?php
$error_descriptions[1] = "A fatal error has occured";
$error_descriptions[2] = "PHP issued a warning";
$error_descriptions[8] = "This is just an informal notice";
?>
because E_ERROR equals 1, etc.

As we already explained in the above examples, $foo[bar] still works but is wrong. It works, because bar is due to its syntax expected to be a constant expression. However, in this case no constant with the name bar exists. PHP now assumes that you meant bar literally, as the string "bar", but that you forgot to write the quotes.

So why is it bad then?

At some point in the future, the PHP team might want to add another constant or keyword, or you may introduce another constant into your application, and then you get in trouble. For example, you already cannot use the words empty and default this way, since they are special reserved keywords.

Poznámka: To reiterate, inside a double-quoted string, it's valid to not surround array indexes with quotes so "$foo[bar]" is valid. See the above examples for details on why as well as the section on variable parsing in strings.

Converting to array

For any of the types: integer, float, string, boolean and resource, if you convert a value to an array, you get an array with one element (with index 0), which is the scalar value you started with.

If you convert an object to an array, you get the properties (member variables) of that object as the array's elements. The keys are the member variable names with a few notable exceptions: private variables have the class name prepended to the variable name; protected variables have a '*' prepended to the variable name. These prepended values have null bytes on either side. This can result in some unexpected behaviour.

<?php

class A {
    private $A; // This will become '\0A\0A'
}

class B extends A {
    private $A; // This will become '\0B\0A'
    public $AA; // This will become 'AA'
}

var_dump((array) new B());
?>
The above will appear to have two keys named 'AA', although one of them is actually named '\0A\0A'.

If you convert a NULL value to an array, you get an empty array.

Comparing

It is possible to compare arrays by array_diff() and by Array operators.

Examples

The array type in PHP is very versatile, so here will be some examples to show you the full power of arrays.

<?php
// this
$a = array( 'color' => 'red',
            'taste' => 'sweet',
            'shape' => 'round',
            'name'  => 'apple',
                       4        // key will be 0
          );

// is completely equivalent with
$a['color'] = 'red';
$a['taste'] = 'sweet';
$a['shape'] = 'round';
$a['name']  = 'apple';
$a[]        = 4;        // key will be 0

$b[] = 'a';
$b[] = 'b';
$b[] = 'c';
// will result in the array array(0 => 'a' , 1 => 'b' , 2 => 'c'),
// or simply array('a', 'b', 'c')
?>

Příklad 11.6. Using array()

<?php
// Array as (property-)map
$map = array( 'version'    => 4,
              'OS'         => 'Linux',
              'lang'       => 'english',
              'short_tags' => true
            );

// strictly numerical keys
$array = array( 7,
                8,
                0,
                156,
                -10
              );
// this is the same as array(0 => 7, 1 => 8, ...)

$switching = array(         10, // key = 0
                    5    =>  6,
                    3    =>  7,
                    'a'  =>  4,
                            11, // key = 6 (maximum of integer-indices was 5)
                    '8'  =>  2, // key = 8 (integer!)
                    '02' => 77, // key = '02'
                    0    => 12  // the value 10 will be overwritten by 12
                  );

// empty array
$empty = array();
?>

Příklad 11.7. Collection

<?php
$colors = array('red', 'blue', 'green', 'yellow');

foreach ($colors as $color) {
    echo "Do you like $color?\n";
}

?>

Výše uvedený příklad vypíše:

Do you like red?
Do you like blue?
Do you like green?
Do you like yellow?

Changing values of the array directly is possible since PHP 5 by passing them as reference. Prior versions need workaround:

Příklad 11.8. Collection

<?php
// PHP 5
foreach ($colors as &$color) {
    $color = strtoupper($color);
}
unset($color); /* ensure that following writes to
$color will not modify the last array element */

// Workaround for older versions
foreach ($colors as $key => $color) {
    $colors[$key] = strtoupper($color);
}

print_r($colors);
?>

Výše uvedený příklad vypíše:

Array
(
    [0] => RED
    [1] => BLUE
    [2] => GREEN
    [3] => YELLOW
)

This example creates a one-based array.

Příklad 11.9. One-based index

<?php
$firstquarter  = array(1 => 'January', 'February', 'March');
print_r($firstquarter);
?>

Výše uvedený příklad vypíše:

Array
(
    [1] => 'January'
    [2] => 'February'
    [3] => 'March'
)

Příklad 11.10. Filling an array

<?php
// fill an array with all items from a directory
$handle = opendir('.');
while (false !== ($file = readdir($handle))) {
    $files[] = $file;
}
closedir($handle);
?>

Arrays are ordered. You can also change the order using various sorting functions. See the array functions section for more information. You can count the number of items in an array using the count() function.

Příklad 11.11. Sorting an array

<?php
sort($files);
print_r($files);
?>

Because the value of an array can be anything, it can also be another array. This way you can make recursive and multi-dimensional arrays.

Příklad 11.12. Recursive and multi-dimensional arrays

<?php
$fruits = array ( "fruits"  => array ( "a" => "orange",
                                       "b" => "banana",
                                       "c" => "apple"
                                     ),
                  "numbers" => array ( 1,
                                       2,
                                       3,
                                       4,
                                       5,
                                       6
                                     ),
                  "holes"   => array (      "first",
                                       5 => "second",
                                            "third"
                                     )
                );

// Some examples to address values in the array above
echo $fruits["holes"][5];    // prints "second"
echo $fruits["fruits"]["a"]; // prints "orange"
unset($fruits["holes"][0]);  // remove "first"

// Create a new multi-dimensional array
$juices["apple"]["green"] = "good";
?>

You should be aware that array assignment always involves value copying. It also means that the internal array pointer used by current() and similar functions is reset. You need to use the reference operator to copy an array by reference.

<?php
$arr1 = array(2, 3);
$arr2 = $arr1;
$arr2[] = 4; // $arr2 is changed,
             // $arr1 is still array(2, 3)

$arr3 = &$arr1;
$arr3[] = 4; // now $arr1 and $arr3 are the same
?>

Předcházející | Nahoru | Další
Strings | Domů | Objects


Objects

Object Initialization

To initialize an object, you use the new statement to instantiate the object to a variable.

<?php
class foo
{
    function do_foo()
    {
        echo "Doing foo.";
    }
}

$bar = new foo;
$bar->do_foo();
?>

For a full discussion, please read the section Classes and Objects.

Converting to object

If an object is converted to an object, it is not modified. If a value of any other type is converted to an object, a new instance of the stdClass built in class is created. If the value was NULL, the new instance will be empty. Array converts to an object with properties named by array keys and with corresponding values. For any other value, a member variable named scalar will contain the value.

<?php
$obj = (object) 'ciao';
echo $obj->scalar;  // outputs 'ciao'
?>

Předcházející | Nahoru | Další
Arrays | Domů | Resource


Resource

A resource is a special variable, holding a reference to an external resource. Resources are created and used by special functions. See the appendix for a listing of all these functions and the corresponding resource types.

Poznámka: The resource type was introduced in PHP 4

See also get_resource_type().

Converting to resource

As resource types hold special handlers to opened files, database connections, image canvas areas and the like, you cannot convert any value to a resource.

Freeing resources

Due to the reference-counting system introduced with PHP 4's Zend Engine, it is automatically detected when a resource is no longer referred to (just like Java). When this is the case, all resources that were in use for this resource are made free by the garbage collector. For this reason, it is rarely ever necessary to free the memory manually by using some free_result function.

Poznámka: Persistent database links are special, they are not destroyed by the garbage collector. See also the section about persistent connections.

Předcházející | Nahoru | Další
Objects | Domů | NULL


NULL

The special NULL value represents that a variable has no value. NULL is the only possible value of type NULL.

Poznámka: The null type was introduced in PHP 4.

A variable is considered to be NULL if

  • it has been assigned the constant NULL.

  • it has not been set to any value yet.

  • it has been unset().

Syntax

There is only one value of type NULL, and that is the case-insensitive keyword NULL.

<?php
$var = NULL;
?>

See also is_null() and unset().

Předcházející | Nahoru | Další
Resource | Domů | Pseudo-types and variables used in this documentation


Pseudo-types and variables used in this documentation

mixed

mixed indicates that a parameter may accept multiple (but not necessarily all) types.

gettype() for example will accept all PHP types, while str_replace() will accept strings and arrays.

number

number indicates that a parameter can be either integer or float.

callback

Some functions like call_user_func() or usort() accept user defined callback functions as a parameter. Callback functions can not only be simple functions but also object methods including static class methods.

A PHP function is simply passed by its name as a string. You can
pass any built-in or user defined function with the exception of
array(),
echo(),
empty(),
eval(),
exit(),
isset(),
list(),
print() and
unset().

A method of an instantiated object is passed as an array containing an object as the element with index 0 and a method name as the element with index 1.

Static class methods can also be passed without instantiating an object of that class by passing the class name instead of an object as the element with index 0.

Apart from common user-defined function, create_function() can be used to create an anonymous callback function.

Příklad 11.13. Callback function examples

<?php
// An example callback function
function my_callback_function() {
    echo 'hello world!';
}

// An example callback method
class MyClass {
    function myCallbackMethod() {
        echo 'Hello World!';
    }
}

// Type 1: Simple callback
call_user_func('my_callback_function');

// Type 2: Static class method call
call_user_func(array('MyClass', 'myCallbackMethod'));

// Type 3: Object method call
$obj = new MyClass();
call_user_func(array($obj, 'myCallbackMethod'));
?>

Poznámka: In PHP4, you will have to use a reference to create a callback that points to the actual object, and not a copy of it. For more details, see References Explained.

void

void in return type means that the return value is useless. void in parameters list means that the function doesn't accept any parameters.

...

$... in function prototypes means and so on. This variable name is used when a function can take an endless number of arguments.

Předcházející | Nahoru | Další
NULL | Domů | Type Juggling


Type Juggling

PHP does not require (or support) explicit type definition in variable declaration; a variable's type is determined by the context in which that variable is used. That is to say, if you assign a string value to variable $var, $var becomes a string. If you then assign an integer value to $var, it becomes an integer.

An example of PHP's automatic type conversion is the addition operator '+'. If any of the operands is a float, then all operands are evaluated as floats, and the result will be a float. Otherwise, the operands will be interpreted as integers, and the result will also be an integer. Note that this does NOT change the types of the operands themselves; the only change is in how the operands are evaluated.

<?php
$foo = "0";  // $foo is string (ASCII 48)
$foo += 2;   // $foo is now an integer (2)
$foo = $foo + 1.3;  // $foo is now a float (3.3)
$foo = 5 + "10 Little Piggies"; // $foo is integer (15)
$foo = 5 + "10 Small Pigs";     // $foo is integer (15)
?>

If the last two examples above seem odd, see String conversion to numbers.

If you wish to force a variable to be evaluated as a certain type, see the section on Type casting. If you wish to change the type of a variable, see settype().

If you would like to test any of the examples in this section, you can use the var_dump() function.

Poznámka: The behaviour of an automatic conversion to array is currently undefined.

Also, because PHP supports indexing into strings via offsets using the same syntax as array indexing, the following example holds true for all PHP versions:

<?php
$a    = 'car'; // $a is a string
$a[0] = 'b';   // $a is still a string
echo $a;       // bar
?>

See the section titled String access by character for more information.

Type Casting

Type casting in PHP works much as it does in C: the name of the desired type is written in parentheses before the variable which is to be cast.

<?php
$foo = 10;   // $foo is an integer
$bar = (boolean) $foo;   // $bar is a boolean
?>

The casts allowed are:

  • (int), (integer) - cast to integer
  • (bool), (boolean) - cast to boolean
  • (float), (double), (real) - cast to float
  • (string) - cast to string
  • (binary) - cast to binary string (PHP 6)
  • (array) - cast to array
  • (object) - cast to object

(binary) casting and b prefix forward support was added in PHP 5.2.1

Note that tabs and spaces are allowed inside the parentheses, so the following are functionally equivalent:

<?php
$foo = (int) $bar;
$foo = ( int ) $bar;
?>

Casting a literal strings and variables to binary strings:

<?php
$binary = (binary)$string;
$binary = b"binary string";
?>

Poznámka: Instead of casting a variable to string, you can also enclose the variable in double quotes.

<?php
$foo = 10;            // $foo is an integer
$str = "$foo";        // $str is a string
$fst = (string) $foo; // $fst is also a string

// This prints out that "they are the same"
if ($fst === $str) {
    echo "they are the same";
}
?>

It may not be obvious exactly what will happen when casting between certain types. For more info, see these sections:

  • Converting to boolean
  • Converting to integer
  • Converting to float
  • Converting to string
  • Converting to array
  • Converting to object
  • Converting to resource
  • The type comparison tables

Předcházející | Nahoru | Další
Pseudo-types and variables used in this documentation | Domů | 12. Proměnné


Kapitola 12. Proměnné

Obsah

Základy
Předdefinované proměnné
Kontext ("scope") proměnné
Proměnné s proměnnými názvy
Proměnné zvenčí PHP

Základy

Proměnné jsou v PHP reprezentovány znakem dolaru, následovaným názvem příslušné proměnné. V názvech proměnných se rozlišuje velikost písmen.

Názvy proměnných jsou podřízeny stejným pravidlům jako jiná návěští v PHP. Platný název proměnné začíná písmenem nebo podtržítkem, následovaným libovolným počtem písmen, číslic nebo potržítek. Jako regulární výraz to lze zapsat takto: '[a-zA-Z_\x7f-\xff][a-zA-Z0-9_\x7f-\xff]*'

Poznámka: Pro naše účely zde budeme za písmena považovat znaky a-z, A-Z a ASCII znaky od 127 do 255 (0x7f-0xff).

$var = "Bob";
$Var = "Joe";
echo "$var, $Var";      // vypíše "Bob, Joe"

$4site = 'not yet';     // neplatné; začíná číslicí
$_4site = 'not yet';    // platné; začíná podtržítkem
$täyte = 'mansikka';    // platné; 'ä' je ASCII 228.

V PHP 3 mají proměnné vždy přiřazenu hodnotu. To znamená, že když přiřadíte výraz do proměnné, celá hodnota původního výrazu se zkopíruje do cílové proměnné. Tedy, například, po přiřazení hodnoty jedné proměnné do druhé, změna jedné z nich se na druhé neprojeví. Více informací o tomto způsobu přiřazení viz Výrazy.

PHP nabízí jiný způsob přiřazení hodnot proměnným: přiřazení odkazu. To znamená, že nová proměnná jednoduše odkazuje (jinými slovy, "stává se aliasem" nebo "ukazuje na") na původní proměnnou. Změny na nové proměnné se projeví na té původní a naopak. To také znamená, že se nic nekopíruje; proto je přiřazení rychlejší. Avšak toto zrychlení bude zjistitelné pouze v těsných cyklech nebo při přiřazování velkých polí či objektů.

Pro přiřazení odkazu stačí jednoduše před proměnnou, která bude přiřazována (zdrojová proměnná), předřadit ampersand (&). Například následující kus kódu vypíše dvakrát 'Jmenuji se Bob':

<?php
$foo = 'Bob';              // Přiřadí hodnotu 'Bob' do $foo
$bar = &$foo;              // Odkaz $foo přes $bar.
$bar = "Jmenuji se $bar";  // Změna $bar...
echo $bar;
echo $foo;                 // $foo je také změněno.
?>

Jednou z důležitých věcí, které je třeba si uvědomit, je to, že přes odkazy lze přiřazovat pouze pojmenované proměnné.

<?php
$foo = 25;
$bar = &$foo;      // Toto je platné přiřazení.
$bar = &(24 * 7);  // Neplatné; odkazuje se nepojmenovaný výraz.

function test()
{
   return 25;
}

$bar = &test();    // Neplatné.
?>

Předcházející | Nahoru | Další
Type Juggling | Domů | Předdefinované proměnné


Předdefinované proměnné

PHP poskytuje velké množství předdefinovaných proměnných jakémukoli skriptu, který provádí. Mnoho těchto proměnných, bohužel, nemůže být plně zdokumentováno, protože závisejí na tom, na kterém serveru skript běží, na verzi a nastavení serveru a dalších faktorech. Některé z těchto proměnných nebudou dostupné, když PHP poběží z příkazové řádky. Seznam proměnných - viz sekce Předdefinované proměnné.

Varování

V PHP 4.2.0 a pozdějších se změnila implicitní sada předdefinovaných proměnných, které jsou globálně dostupné. Individuální vstupní a serverové proměnné se implicitně neumísťují do globálního kontextu; namísto toho jsou v následujících superglobálních polích.

Můžete však stále vynutit staré chování nastavením register_globals v souboru php.ini na 'On'.

Pro více informací a pozadí těchto změn prosím nahlédněte do » PHP 4.1.0 Release Announcement.

Od verze 4.1.0 poskytuje PHP sadu předdefinovaných polí, obsahujících proměnné WWW serveru (pokud to jde), prostředí a uživatelského vstupu. Tato nová pole mají tu zvláštnost, že jsou automaticky globální -- tedy např. automaticky dostupné v každém kontextu. Z tohoto důvodu jsou často známa jako "autoglobální" nebo "superglobální". (V PHP neexistuje mechanismus pro uživatelskou definici superglobálních proměnných). Superglobální proměnné jsou vypsány níže; pro seznam jejich obsahů a další diskusi o předdefinovaných proměnných v PHP a jejich charakteru však musíte nahlédnout do části Předdefinované proměnné.

PHP superglobals (superglobální proměnné)

$GLOBALS
Obsahuje odkaz na každou proměnnou, která je momentálně dostupná v globálním kontextu skriptu. Klíči tohoto pole jsou názvy globálních proměnných.
$_SERVER
Proměnné nastavované WWW serveru nebo jinak přímo spjaté s prováděcím prostředím aktuálního skriptu. Analogické starému poli $HTTP_SERVER_VARS (které je stále dostupné, ale zavržené).
$_GET
Proměnné poskytované skriptu přes HTTP GET. Analogické starému poli $HTTP_GET_VARS (které je stále dostupné, ale zavržené).
$_POST
Proměnné poskytované skriptu přes HTTP POST. Analogické starému poli $HTTP_POST_VARS (které je stále dostupné, ale zavržené).
$_COOKIE
Proměnné poskytované skriptu přes HTTP cookies. Analogické starému poli $HTTP_COOKIE_VARS (které je stále dostupné, ale zavržené).
$_FILES
Proměnné poskytované skriptu přes HTTP post uploady souborů. Analogické uploads. Analogické starému poli $HTTP_POST_FILES (které je stále dostupné, ale zavržené). Více informací - viz Upload metodou POST.
$_ENV
Proměnné poskytované skriptu z prostředí. Analogické starému poli $HTTP_ENV_VARS (které je stále dostupné, ale zavržené).
$_REQUEST
Proměnné poskytované skriptu přes libovolný vstupní mechanismus a kterým proto nelze důvěřovat. Pozn.: při běhu z příkazové řádky zde nebudou přítomny položky argv a argc; nacházejí se v poli $_SERVER. Přítomnost a pořadí proměnných v tomto poli se definuje podle konfigurační direktivy variables_order. Toto pole nemá přímou analogii ve verzích PHP před 4.1.0.
$_SESSION
Proměnné, které jsou momentálně registrovány v aktuální relaci skriptu. Analogické starému poli $HTTP_SESSION_VARS (které je stále dostupné, ale zavržené). Více informací - viz Funkce pro obsluhu sessions.
Předcházející | Nahoru | Další
12. Proměnné | Domů | Kontext ("scope") proměnné


Kontext ("scope") proměnné

Kontext proměnné je oblast, ve které je definována. Většina proměnných v PHP má pouze jediný kontext. Ten zahrnuje i soubory vložené pomocí "include" nebo "require". Například:

$a = 1;
include "b.inc";

Zde bude proměnná $a dostupná ve vloženém skriptu b.inc. Avšak uvnitř uživatelsky definovaných funkcí se zakládá jejich lokální kontext. Jakákoli proměnná použitá uvnitř funkce je implicitně omezena na tento místní kontext. Například:

$a = 1; /* globální kontext */

function Test()
{
    echo $a; /* odkaz na proměnnou v lokálním kontextu */
}

Test();

Tento skript nevyprodukuje žádný výstup, protože konstrukt "echo" odkazuje na lokální verzi proměnné $a, a ta nemá v tomto kontextu přiřazenu žádnou hodnotu. Můžete si všimnout, že to je trochu jiné než v jazyce C, kde jsou globální funkce automaticky dostupné ve funkcích, pokud nejsou specificky zastíněny lokální definicí. To může způsobit problémy tím, že člověk může nechtěně změnit globální proměnnou. V PHP musí být globální proměnné deklarovány uvnitř funkce jako globální, pokud se v ní mají používat. Příklad:

$a = 1;
$b = 2;

function Sum()
{
    global $a, $b;

    $b = $a + $b;
}

Sum();
echo $b;

Výše uvedený skript vytiskne "3". Deklarací $a a $b ve funkci jako globálních proměnných se dosáhne toho, že při odkazování na proměnné se pracuje s jejich globální verzí. Počet globálních proměnných, se kterými lze ve funkci manipulovat, není omezen.

Druhým způsobem, jak přistupovat k proměnným z globálního kontextu, je použití speciálního pole $GLOBALS, definovaného v PHP. Předchozí příklad lze přepsat:

$a = 1;
$b = 2;

function Sum()
{
    $GLOBALS["b"] = $GLOBALS["a"] + $GLOBALS["b"];
}

Sum();
echo $b;

Pole $GLOBALS je asociativní pole s názvem globální proměnné jako klíčem a obsahem příslušné proměnné jako obsahem elementu pole.

Jinou důležitou vlastností rozlišování kontextů proměnných je možnost používání static proměnných. Statická proměnná existuje pouze v lokálním kontextu funkce, ale neztrácí svoji hodnotu, pokud provádění programu tento kontext opustí. Uvažujme následující příklad:

function Test ()
{
    $a = 0;
    echo $a;
    $a++;
}

Tato funkce je poněkud neužitečná, neboť při každém volání nastavuje $a na 0 a tiskne "0". Konstrukt $a++, který inkrementuje proměnnou, nemá žádný význam, protože při skončení vykonávání funkce se obsah proměnné $a ztrácí. Aby měla funkce skutečný význam čítače a hodnota se neztrácela, deklaruje se proměnná $a jako statická:

function Test()
{
    static $a = 0;
    echo $a;
    $a++;
}

Nyní se při každém volání funkce Test() vytiskne hodnota proměnné $a a inkrementuje se.

Statické proměnné také poskytují způsob, jak řešit rekurzívní funkce. Rekurzívní funkce je taková funkce, která volá sama sebe. Psaní rekurzívních funkcí je třeba věnovat zvláštní péči, protože může vzniknout nekonečný cyklus volání. Musíte se ujistit, že máte rekurzi adekvátně ukončenu. Následující jednoduchá funkce rekurzívně počítá do 10 za použití statické proměnné $count ke zjištění okamžiku pro ukončení:

function Test()
{
    static $count = 0;

    $count++;
    echo $count;
    if ($count < 10) {
        Test ();
    }
    $count--;
}
Předcházející | Nahoru | Další
Předdefinované proměnné | Domů | Proměnné s proměnnými názvy


Proměnné s proměnnými názvy

Někdy je vhodné, aby se názvy proměnných mohly měnit, tj. aby mohly být dynamicky nastavovány a používány. Normální proměnná se nastavuje takovýmto příkazem:

$a = "ahoj";

Proměnná s proměnným názvem vezme hodnotu proměnné a použije ji jako název proměnné. Ve výše uvedeném příkladu, ahoj lze použít jako název proměnné uvedením dvou symbolů dolaru:

$$a = "světe";

V této chvíli byly definovány dvě proměnné a byly uloženy do stromu symbolů PHP: $a s obsahem "ahoj" a $ahoj s obsahem "světe". Proto příkaz:

echo "$a ${$a}";

provede přesně totéž jako:

echo "$a $ahoj";

tedy oba vyprodukují: ahoj světe.

Při použití proměnných s proměnnými názvy s poli musíte vyřešit problém víceznačnosti. Tj. když napíšete $$a[1], parser potřebuje vědět, máte-li na mysli použití $a[1] jako proměnné nebo chcete $$a jako proměnnou a potom index [1] v této proměnné. Syntaxe pro řešení této víceznačnosti je ${$a[1]} pro první případ a ${$a}[1] pro druhý.

Předcházející | Nahoru | Další
Kontext ("scope") proměnné | Domů | Proměnné zvenčí PHP


Proměnné zvenčí PHP

HTML formuláře (GET a POST)

Když se odešle formulář do PHP skriptu, jakékoli proměnné z tohoto formuláře budou automaticky dostupné v tomto skriptu. Je-li zapnuta konfigurační volba track_vars, budou tyto proměnné umístěny v asociativních polích $HTTP_POST_VARS, $HTTP_GET_VARS, a/nebo $HTTP_POST_FILES v závislosti na zdroji proměnných.

Pro více informací o těchto proměnných si laskavě přečtěte Předdefinované proměnné.

Příklad 12.1. Jednoduchá proměnná formuláře

<form action="foo.php" method="post">
    Name: <input type="text" name="username"><br>
    <input type="submit">
</form>

Když se výše uvedený formulář odešle, hodnota vstupního textu bude dostupná v $HTTP_POST_VARS['username']. Je-li zapnuta konfigurační direktiva register_globals, proměnná bude dostupná i jako $username v globálním kontextu.

Poznámka: The magic_quotes_gpc configuration directive affects Get, Post and Cookie values. If turned on, value (It's "PHP!") will automagically become (It\'s \"PHP!\"). Escaping is needed for DB insertion. Also see addslashes(), stripslashes() and magic_quotes_sybase.

PHP also understands arrays in the context of form variables (see the related faq). You may, for example, group related variables together, or use this feature to retrieve values from a multiple select input:

Příklad 12.2. More complex form variables

<form action="array.php" method="post">
    Name: <input type="text" name="personal[name]"><br>
    Email: <input type="text" name="personal[email]"><br>
    Beer: <br>
    <select multiple name="beer[]">
        <option value="warthog">Warthog
        <option value="guinness">Guinness
        <option value="stuttgarter">Stuttgarter Schwabenbräu
        </select>
    <input type="submit">
</form>

In PHP 3, the array form variable usage is limited to single-dimensional arrays. In PHP 4, no such restriction applies.

IMAGE SUBMIT variable names

When submitting a form, it is possible to use an image instead of the standard submit button with a tag like:

<input type="image" src="image.gif" name="sub">

When the user clicks somewhere on the image, the accompanying form will be transmitted to the server with two additional variables, sub_x and sub_y. These contain the coordinates of the user click within the image. The experienced may note that the actual variable names sent by the browser contains a period rather than an underscore, but PHP converts the period to an underscore automatically.

HTTP Cookies

PHP transparently supports HTTP cookies as defined by » Netscape's Spec. Cookies are a mechanism for storing data in the remote browser and thus tracking or identifying return users. You can set cookies using the setcookie() function. Cookies are part of the HTTP header, so the SetCookie function must be called before any output is sent to the browser. This is the same restriction as for the header() function. Any cookies sent to you from the client will automatically be turned into a PHP variable just like GET and POST method data.

If you wish to assign multiple values to a single cookie, just add [] to the cookie name. For example:

setcookie("MyCookie[]", "Testing", time()+3600);

Note that a cookie will replace a previous cookie by the same name in your browser unless the path or domain is different. So, for a shopping cart application you may want to keep a counter and pass this along. i.e.

Příklad 12.3. SetCookie Example

$Count++;
setcookie("Count", $Count, time()+3600);
setcookie("Cart[$Count]", $item, time()+3600);

Environment variables

PHP automatically makes environment variables available as normal PHP variables.

echo $HOME;  /* Shows the HOME environment variable, if set. */

Since information coming in via GET, POST and Cookie mechanisms also automatically create PHP variables, it is sometimes best to explicitly read a variable from the environment in order to make sure that you are getting the right version. The getenv() function can be used for this. You can also set an environment variable with the putenv() function.

Dots in incoming variable names

Typically, PHP does not alter the names of variables when they are passed into a script. However, it should be noted that the dot (period, full stop) is not a valid character in a PHP variable name. For the reason, look at it: $varname.ext;  /* invalid variable name */ Now, what the parser sees is a variable named $varname, followed by the string concatenation operator, followed by the barestring (i.e. unquoted string which doesn't match any known key or reserved words) 'ext'. Obviously, this doesn't have the intended result.

For this reason, it is important to note that PHP will automatically replace any dots in incoming variable names with underscores.

Determining variable types

Because PHP determines the types of variables and converts them (generally) as needed, it is not always obvious what type a given variable is at any one time. PHP includes several functions which find out what type a variable is. They are gettype(), is_array(), is_float(), is_int(), is_object(), and is_string().

Předcházející | Nahoru | Další
Proměnné s proměnnými názvy | Domů | 13. Konstanty


Kapitola 13. Konstanty

PHP definuje několik konstant a poskytuje mechanismus pro definici dalších za běhu. Konstanty se hodně podobají proměnným s výjimkou dvou skutečností: konstanty se musí definovat pomocí funkce define(), a nemohou později nabývat jiných hodnot.

Předdefinované konstanty (dostupné vždy) jsou:

__FILE__
Název souboru skriptu, který je právě čten. Pokud je použita v souboru, který byl vložen pomocí "include" nebo "require", obsahuje název vloženého souboru, nikoli rodičovského.
__LINE__
Číslo řádku ve skriptu, který je právě čten. Pokud je použita v souboru vloženého pomocí "include" nebo "require", obsahuje pozici v rámci tohoto souboru.
PHP_VERSION
Textové vyjádření verze běžícího PHP parseru, např. '3.0.8-dev'.
PHP_OS
Název operačního systému, na kterém PHP parser běží, např. 'Linux'.
TRUE
Pravdivá hodnota (logická jednička).
FALSE
Nepravdivá hodnota (logická nula).
E_ERROR
Označuje neošetřitelnou chybu jinou než "parse error".
E_WARNING
Označuje stav, kdy PHP ví, že je něco špatně, ale bude dál pokračovat. Tyto stavy se dají ošetřit v samotném skriptu. Příkladem by byl neplatný "regexp" (regulární výraz) ve funkci ereg().
E_PARSE
Chyba při syntaktické analýze skriptu (chybná syntaxe). Ošetření není možné.
E_NOTICE
Došlo k něčemu, co by mohlo být chybou. Provádění skriptu pokračuje. Mezi příklady patří textový index pole neopatřený uvozovkami nebo práce s proměnnou, která ještě nebyla definována.
E_ALL
Všechny E_* konstanty shrnuté do jedné. Při použití s funkcí error_reporting() způsobí hlášení úplně všech problému zaregistrovaných PHP.

E_* konstanty se typicky používají s funkcí error_reporting() nastavení hladiny hlášení chyb. Viz všechny tyto konstanty v Ošetření chyb.

Další konstanty můžete definovat pomocí funkce define().

Všimněte si, že toto jsou konstanty, ne céčkovská makra; konstanty mohou reprezentovat pouze platná skalární data.

Příklad 13.1. Definice konstant

<?php
define("CONSTANT", "Hello world.");
echo CONSTANT; // vytiskne "Hello world."
?>

Příklad 13.2. Použití __FILE__ a __LINE__

<?php
function report_error($file, $line, $message) {
    echo "Došlo k chybě v souboru $file na řádku $line: $message.";
}

report_error(__FILE__,__LINE__, "Něco je špatně!");
?>

Předcházející | Nahoru | Další
Proměnné zvenčí PHP | Domů | 14. Výrazy


Kapitola 14. Výrazy

Výrazy jsou nejdůležitějšími stavebními kameny PHP. V PHP je téměř vše, co napíšete, výraz. Nejjednodušší, a přece nejpřesnější definicí výrazu je "všechno, co má hodnotu".

Nejzákladnějšími formami výrazů jsou konstanty a proměnné. Když napíšete "$a = 5", přiřazujete '5' do $a. '5' má, pochopitelně, hodnotu 5, nebo jinými slovy, '5' je výraz s hodnotou 5 (v tomto případě je '5' celočíselnou konstantou).

Po tomto přiřazení budete očekávat, že hodnota $a bude 5, takže kdybyste napsali $b = $a, očekávali byste totéž, jako při napsání $b = 5. Jinými slovy, $a je tedy výraz s hodnotou 5. Pokud vše pracuje správně, přesně to se také stane.

O něco složitějším příkladem výrazů jsou funkce. Uvažujme např. tuto funkci:

function foo ()
{
    return 5;
}

Za předpokladu, že jste dobře seznámeni s konceptem funkcí (pokud ne, nahlédněte do kapitoly o funkcích), byste předpokládali, že napsání $c = foo() je v zásadě totéž jako $c = 5, a máte pravdu. Funkce jsou výrazy s hodnotou jejich návratové hodnoty. Funkce foo() vrací 5, tudíž hodnota výrazu 'foo()' je 5. Obvykle funkce nevracejí konstantní hodnotu, nýbrž něco vypočítávají.

Hodnoty v PHP samozřejmě nemusejí být pouze celá čísla, a velmi často také nejsou. PHP podporuje tři typy skalárních hodnot: celočíselné, reálné (pohyblivá řádová čárka) a řetězce (skalární hodnoty jsou hodnoty, které nejde "rozbít" na menší části, narozdíl např. od polí). PHP podporuje také dva kompozitní (neskalární) typy: pole a objekty. Každý z těchto typů hodnot může být přiřazen do proměnné nebo vracen z funkce.

Uživatelé PHP/FI 2 by neměli pocítit změnu. Ale PHP jde ve výrazech mnohem dále, stejně jako mnoho jiných programovacích jazyků. PHP je výrazově orientovaný jazyk, ve smyslu, že téměř vše je výraz. Uvažujme příklad, kterým jsme se již zabývali, '$a = 5'. Ihned vidíme, že jsou zde zahrnuty dvě hodnoty, celočíselná konstanta '5' a hodnota $a, která je aktualizována na 5. Ale je pravda, že je tu ještě jedna hodnota, je to hodnota samotného přiřazení. Přiřazení jako takové ohodnocuje přiřazovanou hodnotu, v tomto případě 5. V praxi to znamená, že '$a = 5', bez ohledu na to co dělá, je výraz s hodnotou 5. Proto je '$b = ($a = 5)' totéž jako '$a = 5; $b = 5;' (středník označuje konec výrazu). Protože přiřazení jsou parsována zprava doleva, můžete také napsat '$b = $a = 5'.

Jiným dobrým příkladem orientace na výrazy je pre- a post-inkrementace a dekrementace. Uživatelé PHP/FI 2 a mnoha jiných jazyků znají notaci proměnná++ a proměnná--. To jsou inkrementační a dekrementační operátory. V PHP/FI 2 nemělo '$a++' žádnou hodnotu (není to výraz), a proto nešlo přiřadit nebo jinak použít. PHP rozšiřuje schopnosti přeměnou těchto konstrukcí ve výrazy, jako v C. V PHP, stejně jako v C, existují dva typy inkrementace - pre-inkrementace a post-inkrementace. Oba ve své podstatě inkrementují proměnnou a efekt na tuto proměnnou je totožný. Rozdíl je v hodnotě inkrementačního výrazu. Pre-inkrementace, zapsaná jako '++$var', ohodnocuje výraz inkrementovanou hodnotou (PHP inkrementuje proměnnou dříve, než přečte její hodnotu, proto "pre-inkrementace"). Post-inkrementace, zapsaná jako '$var++', ohodnocuje výraz původní hodnotou proměnné $var, před inkrementací (PHP inkrementuje proměnnou po přečtení její hodnoty, proto "post-inkrement").

Velmi častým typem výrazů jsou výrazy porovnávací. Tyto výrazy se ohodnocují 0 a 1 ve významu FALSE, resp. TRUE. PHP podporuje > (větší než), >= (větší nebo rovno), == (rovná se), != (nerovná se), < (menší než) a <= (menší nebo rovno). Tyto výrazy se nejčastěji používají v podmínkách, jako je if.

Posledním příkladem výrazů, kterým se budeme zabývat, je kombinací přiřazení a operátorů. Již víte, že když chcete inkrementovat $a o jedničku, jednoduše napíšete '$a++' nebo '++$a'. Ale co když chcete hodnotu zvýšit o jiné číslo, např. o 3? Mohli byste napsat '$a++' víckrát za sebou, ale to samozřejmě není efektivní ani pohodlné. Mnohem praktičtější je napsat '$a = $a + 3'. Výraz '$a + 3' ohodnocuje hodnotu $a plus 3 a je přiřazen zpět do $a, což dává $a inkrementované o 3. V PHP, stejně jako v řadě jiných jazyků (jako je C), to můžete napsat kratším způsobem, který se časem stane jasnější i rychlejší k pochopení. Přičtení 3 k aktuální hodnotě $a lze zapsat jako '$a += 3'. Přesně to znamená "vezmi hodnotu $a, přičti k ní 3 a přiřaď zpět do $a". Kromě kratšího a přehlednějšího zápisu je výhodou také rychlejší provedení. Hodnota '$a += 3', jako hodnota regulérního přiřazení, je přiřazovaná hodnota. Uvědomte si, že to NENÍ 3, nýbrž $a plus 3 (což je hodnota výrazu přiřazovaného do $a). Takto lze použít jakýkoli binární operátor, například '$a -= 5' (odečti 5 od hodnoty $a), '$b *= 7' (vynásob hodnotu $b číslem 7) apod.

Je tu ještě jeden výraz, který se může zdát zvláštní, pokud jste ho ještě neviděli v jiných jazycích: ternární podmíněný operátor:

$prvni ? $druhy : $treti
Pokud hodnota prvního podvýrazu je TRUE (nenulová), je ohodnocen druhý podvýraz a je výsledkem celého podmíněného výrazu. Jinak je ohodnocen třetí podvýraz a je pak hodotou celého výrazu.

Následující příklad by měl pomoci lépe pochopit pre- a post-inkrementaci i výrazy obecně:

function double($i)
{
    return $i*2;
}
$b = $a = 5;        /* přiřaď hodnotu pět do proměnných $a a $b */
$c = $a++;          /* proveď post-inkrement, přiřaď původní hodnotu $a
                       (5) do $c */
$e = $d = ++$b;     /* proveď pre-inkrement, přiřaď inkrementovanou hodnotu
                       $b (6) do $d a $e */

/* nyní jsou hodnoty proměnných $d a $e rovny 6 */

$f = double($d++);  /* přiřaď dvakrát hodnotu $d <emphasis>před</emphasis>
                       inkrementací, 2*6 = 12, do $f */
$g = double(++$e);  /* přiřaď dvakrát hodnotu $e <emphasis>po</emphasis>
                       inkrementaci, 2*7 = 14 do $g */
$h = $g += 10;      /* nejdříve je $g inkrementováno o 10 má pak hodnotu 24.
                       Hodnota přiřazení (24) se přiřadí do $h a $h tím
                       získává také hodnotu 24. */

Na začátku kapitoly bylo řečeno, že si popíšeme různé typy příkazů, a jak bylo slíbeno, výrazy mohou být příkazy. V tomto případě mají y formát 'expr' ';', což znamená "výraz následovaný středníkem. V u '$b=$a=5;', je $a=5 platný výraz, ale samo o sobě to není .'$b=$a=5;' je i platný .

Poslední věcí, která si zaslouží zmínku, je pravdivostní hodnota výrazů. V mnoha případech, hlavně podmínkách a cyklech, vás nezajímá konkrétní hodnota výrazu, nýbrž pouze to, jestli je TRUE nebo FALSE. Konstanty TRUE a FALSE (malá/velká písmena nehrají roli) představují dvě možné boolovské (pravdivostní) hodnoty. V případě potřeby je výraz automaticky převeden na typ boolean. Detailnější informace o způsobu konverze - viz sekce o typové konverzi.

PHP poskytuje plnou a silnou implementaci výrazů a úplně je zdokumentovat přesahuje rozsah tohoto manuálu. Výše uvedené příklady by vám měli naznačit, co jsou vůbec výrazy a jak konstruovat užitečné výrazy. Ve zbývající části manuálu budeme psát expr jakožto jakýkoli platný PHP výraz.

Předcházející | Nahoru | Další
13. Konstanty | Domů | 15. Operátory


Kapitola 15. Operátory

Obsah

Aritmetické operátory
Operátory přiřazení
Bitové operátory
Operátory porovnání
Operátory řízení chyb
Prováděcí operátory
Inkrementační/Dekrementační operátory
Logické operátory
Priorita operátorů
Řetězcové operátory
Typové operátory

Aritmetické operátory

Vzpomínáte si na základní aritmetiku ze školy? Tohle je úplně stejné.

Tabulka 15.1. Aritmetické operátory

Příklad | Název | Výsledek
$a + $b | Sčítání | Součet $a a $b.
$a - $b | Odčítání | ROzdíl $a a $b.
$a * $b | Násobení | Součin $a a $b.
$a / $b | Dělení | Podíl $a a $b.
$a % $b | Zbytek | Zbytek po dělení $a a $b.

Operátor dělení ("/") vrací celočíselnou hodnotu (výsledek celočíselného dělení) právě tehdy, když oba operandy jsou celá čísla (nebo řetězce, které se dají převést na celá čísla) a podíl je celé číslo. Pokud některý z operandů celočíselný není nebo výsledek není celé číslo, vrátí se hodnota v plovoucí řádové čárce (float).

Předcházející | Nahoru | Další
14. Výrazy | Domů | Operátory přiřazení


Operátory přiřazení

Základním přiřazovacím operátorem je "=". Mohli byste si zprvu myslet, že se jedná o "rovná se". Nikoliv. Skutečně to znamená, že se levému operandu přiřadí hodnota výrazu vpravo (tj. "nastav na", "přiřaď do" atd.).

Hodnotou výrazu přiřazení je hodnota, která se přiřazuje. Tj. hodnotou "$a = 3" je číslo 3. To vám umožňuje provádět různé triky:

$a = ($b = 4) + 5; // $a se ted rovná 9, a $b bylo nastaveno na 4.

Kromě základního operátoru přiřazení existují ještě "kombinované operátory" pro všechny binární aritmetické a řetězové operátory, které umožňují použít hodnotu ve výrazu a pak hodnotu tohoto výrazu přiřadit zpět. Například:

$a = 3;
$a += 5; // nastaví $a na hodnotu 8, jako kdybychom řekli: $a = $a + 5;
$b = "Ahoj ";
$b .= "tam!"; // nastaví $b na "Ahoj tam!", přesně tak, jako $b = $b . "tam!";

Uvědomte si, že přiřazení zkopíruje hodnotu původní proměnné do nové proměnné (přiřazení hodnoty), takže změny jedné z nich se na druhé proměnné neprojeví. To může mít význam také tehdy, když potřebujete zkopírovat něco jako obrovské pole uvnitř krátkého cyklu. PHP 4 podporuje přiřazení odkazem použitím syntaxe $var = &$othervar;, ale v PHP 3 to provést nelze. "Přiřazení odkazem" znamená, že obě proměnné ukazují na tatáž data a nic se nikam nekopíruje. Chcete-li se o odkazech dozvědět více, čtěte prosím Vysvětlení referencí.

Předcházející | Nahoru | Další
15. Operátory | Domů | Bitové operátory


Bitové operátory

Bitové operátory umožňují "přehodit" konkrétní bit v celočíselné hodnotě (integer) na jedničku nebo nulu. Pokud jsou jak levý, tak pravý parametr řetězce, pracují bitové operátory na znacích v těchto řetezcích.

<?php
    echo 12 ^ 9; // Vypíše '5'

    echo "12" ^ "9"; // Vypíše znak Backspace (ascii 8)
                     // ('1' (ascii 49)) ^ ('9' (ascii 57)) = #8

    echo "hallo" ^ "hello"; // Vypíše ascii hodnoty #0 #4 #0 #0 #0
                            // 'a' ^ 'e' = #4
?>

Tabulka 15.2. Bitové operátory

Příklad | Název | Výsledek
$a & $b | And (log. součin) | Nastavují se bity, kde je jednička v $a i v $b.
$a | $b | Or(log. součet) | Nastavují se bity, kde je jednička v $a nebo v $b (i v obou současně).
$a ^ $b | Xor (exkluzívní log. součet) | Nastavují se bity, kde je jednička v $a nebo v $b, ale ne v obou současně.
~ $a | Not (negace) | Tam, kde je nula, bude jednička, a naopak.
$a << $b | Posun vlevo | Posune bity v $a o $b kroků (míst) vlevo (každý krok znamená "násobení dvěma").
$a >> $b | Posun vpravo | Posune bity v $a o $b kroků (míst) vpravo (každý krok znamená "dělení dvěma").

Předcházející | Nahoru | Další
Operátory přiřazení | Domů | Operátory porovnání


Operátory porovnání

Operátory porovnání, jak název napovídá, slouží k porovnání dvou hodnot.

Tabulka 15.3. Operátory porovnání

Příklad | Název | Výsledek
$a == $b | Rovnost | TRUE, právě když je $a rovno $b.
$a === $b | Identita | TRUE když je $a rovno $b a navíc tétož typu (pouze PHP 4).
$a != $b | Nerovnost | TRUE právě když $a není rovno $b.
$a <> $b | Nerovnost | TRUE právě když $a není rovno $b.
$a !== $b | Neidentita | TRUE když $a není rovno $b nebo nejsou téhož typu (pouze PHP 4).
$a < $b | Menší než | TRUE když je $a ostře menší než $b.
$a > $b | Větší než | TRUE když je $a ostře větší než $b.
$a <= $b | Menší nebo rovno | TRUE když je $a menší nebo rovno $b.
$a >= $b | Větší nebo rovno | TRUE když je $a větší nebo rovno $b.

Jiným podmínkovým operátorem je "?:" (ternární) operátor, který funguje stejně jako v C a mnohých jiných jazycích.

(expr1) ? (expr2) : (expr3);
Výraz je ohodnocen jako hodnota expr2 když má expr1 hodnotu TRUE, a expr3 když má expr1 hodnotu FALSE.

Předcházející | Nahoru | Další
Bitové operátory | Domů | Operátory řízení chyb


Operátory řízení chyb

PHP podporuje jeden operátor řízení chyb: znak at (@). Když ho předřadíte výrazu v PHP, jakékoli chybové zprávy, které se mohou generovat ve výrazu, budou ignorovány.

Pokud je zapnutotrack_errors, budou se všechny chybové zprávy generované výrazem ukládat do globální proměnné $php_errormsg. Tato proměnná bude přepsána při každé chybě, takže ji testujte vždy co nejdříve, pokud ji chcete používat.

<?php
/* Intentional file error */
$my_file = @file ('non_existent_file') or
    die ("Failed opening file: error was '$php_errormsg'");

// this works for any expression, not just functions:
$value = @$cache[$key];
// will not issue a notice if the index $key doesn't exist.

?>

Poznámka: Operátor @ pracuje pouze na výrazech. Platí jednoduché pravidlo: můžete-li získat hodnotu něčeho, můžete před to dát operátor @. To se týká například proměnných, funkcí, volání include() konstant a podobně. Nemůžete ho předřadit definicím funkcí nebo tříd a podmínkovým strukturám typu if nebo foreach.

Viz také error_reporting().

Varování

V současnosti předřazení operátoru řízení chyb "@" vyřadí i hlášení kritických chyb, které způsobí ukončení provádění skriptu. To mj. znamená, že pokud použijete "@" k potlačení chyb z nějaké funkce, a tato funkce není k dispozici nebo obsahuje chyby, skript zde skončí bez jakékoli indikace, co se stalo.

Předcházející | Nahoru | Další
Operátory porovnání | Domů | Prováděcí operátory


Prováděcí operátory

PHP podporuje jeden prováděcí operátor: obrácené apostrofy (``). Uvědomte si, že to nejsou obyčejné apostrofy! PHP se pokusí provést obsah uzavřený mezi těmito znaky jako příkaz shellu; výstup je vrácen (tzn. nebude pouze vypsán na výstupů může být přiřazen proměnné).

$output = `ls -al`;
echo "<pre>$output</pre>";

Poznámka: Operátor může být vyřazen, pokud je aktivní bezpečný režim nebo je vypnuto shell_exec().

Viz také escapeshellcmd(), exec(),
passthru(), popen(),
shell_exec(), a system().

Předcházející | Nahoru | Další
Operátory řízení chyb | Domů | Inkrementační/Dekrementační operátory


Inkrementační/Dekrementační operátory

PHP podporuje pre- a post inkrementační a dekrementační operátory ve stylu C.

Tabulka 15.4. Inkrementační/dekrementační operátory

Příklad | Název | Účinek
++$a | Pre-inkrementace | Inkrementuje $a o jedničku, potom vrátí $a.
$a++ | Post-inkrementace | Vrátí $a, potom inkrementuje $a o jedničku.
--$a | Pre-dekrementace | Dekrementuje $a o jedničku, potom vrátí $a.
$a-- | Post-dekrementace | Vrátí $a, potom dkrementuje $a o jedničku.

Zde je příklad jednoduchého skriptu:

<?php
echo "<h3&gt;Postinkrementace</h3&gt;";
$a = 5;
echo "Mělo by být 5: " . $a++ . "<br>\n";
echo "Mělo by být 6: " . $a . "<br>\n";

echo "<h3>Preinkrementace</h3>";
$a = 5;
echo "Mělo by být 6: " . ++$a . "<br>\n";
echo "Mělo by být 6: " . $a . "<br>\n";

echo "<h3>Postdekrementace</h3>";
$a = 5;
echo "Mělo by být 5: " . $a-- . "<br>\n";
echo "Mělo by být: " . $a . "<br>\n";

echo "<h3>Predekrementace</h3>";
$a = 5;
echo "Mělo by být 4: " . --$a . "<br>\n";
echo "Mělo by být 4: " . $a . "<br>\n";
?>

Předcházející | Nahoru | Další
Prováděcí operátory | Domů | Logické operátory


Logické operátory

Tabulka 15.5. Logické operátory

Příklad | Název | Výsledek
$a and $b | And | TRUE když $a i $b jsou TRUE.
$a or $b | Or | TRUE když $a nebo $b je TRUE.
$a xor $b | Xor | TRUE když $a nebo $b je TRUE, ale ne oba současně.
! $a | Not | TRUE když $a není TRUE.
$a && $b | And | TRUE když $a i $b jsou TRUE.
$a || $b | Or | TRUE když $a nebo $b je TRUE.

Důvodem pro dvě různé varianty operátorů "and" a "or" je to, že mají jinou prioritu. (Viz Priorita operátorů.)

Předcházející | Nahoru | Další
Inkrementační/Dekrementační operátory | Domů | Priorita operátorů


Priorita operátorů

Priorita operátoru specifikuje, jak "těsně" váže dva výrazy mezi sebou. Například výraz 1 + 5 * 3, výsledkem je 16 a nikoli 18, protože operátor násobení ("*") má vyšší prioritu než operátor sčítání ("+"). K vynucení priority můžeme v případě potřeby použít závorky. Kupř. (1 + 5) * 3 má hodnotu 18.

Následující tabulka ukazuje přehled operátorů vzestupně seřazených podle priority.

Tabulka 15.6. Priorita operátorů

Asociativita | Operátory
levá | ,
levá | or
levá | xor
levá | and
pravá | print
levá | = += -= *= /= .= %= &= |= ^= ~= <<= >>=
levá | ? :
levá | ||
levá | &&
levá | |
levá | ^
levá | &
bez asociativity | == != === !==
bez asociativity | < <= > >=
levá | << >>
levá | + - .
levá | * / %
pravá | ! ~ ++ -- (int) (double) (string) (array) (object) @
pravá | [
bez asociativity | new

Předcházející | Nahoru | Další
Logické operátory | Domů | Řetězcové operátory


Řetězcové operátory

Existují dva řetezcové operátory. Jedním je operátor spojení ('.'), který vrací spojení pravého a levého argumentu. Druhým je operátor spojujícího přiřazení ('.='), jenž připojí argument na pravé straně k argumentu na straně levé. Pro více informací si laskavě přečtěte Operátory přiřazení.

$a = "Ahoj ";
$b = $a . "světe!"; // nyní $b obsahuje "Ahoj světe!"

$a = "Ahoj ";
$a .= "světe!";     // nyní $a obsahuje "Ahoj světe!"

Předcházející | Nahoru | Další
Priorita operátorů | Domů | Typové operátory


Kapitola 16. Řídicí struktury

Obsah

if
else
elseif
Alternativní syntaxe řídicích struktur
while
do..while
for
foreach
break
continue
switch
declare
return
require
include
require_once
include_once

Jakýkoli PHP skript je složen ze série příkazů. Příkaz může být přiřazení, volání funkce, cyklus, podmínka, stejně jako příkaz, který nic nedělá (prázdný příkaz). Příkaz obvykle končí středníkem. Navíc lze příkazy seskupit do skupiny (bloku) uzavřené složenými závorkami. Tento blok je sám o sobě příkazem. V této kapitole jsou popsány různé typy příkazů.

if

Příkaz if je jedním z nejdůležitějších prvků v mnoha jazycích, včetně PHP. Umožňuje podmíněné provádění kusu kódu. Struktura if v PHP je podobná struktuře v C:

if (expr)
    statement

Jak je popsáno v sekci o výrazech, výraz expr je ohodnoce svou boolovskou hodnotou. Poku je expr ohodnocen jako TRUE, PHP provede statement; je-li ohodnocen jako FALSE, neprovede se nic. Více informací o to, jak se výrazy ohodnocují jako FALSE najdete v části 'Konverze na typ boolean'.

Následující příklad by vypsal a je větší než b, pokud $a je větší než $b:

if ($a > $b)
    print "a je větší než b";

Často byste chtěli, aby se podmíněně prováděl více než jeden příkaz. Není samozřejmě nutné každý příkaz zabalit do struktury if. Místo toho můžete seskupit více příkazů do bloku. Například tento kód by zobrazil a je větší než b, pokud $a je větší než $b a přiřadil by hodnotu $a do $b:

if ($a > $b) {
    print "a je větší než b";
    $b = $a;
}

Příkazy if mohou být libovolně vnořovány do jiných příkazů if, což poskytuje plnou flexibilitu podmíněného provádění různých částí programu.

Předcházející | Nahoru | Další
Typové operátory | Domů | else


Alternativní syntaxe řídicích struktur

PHP nabízí alternativní syntaxi pro některé z řídicích struktur, jmenovitě if, while, for, foreach, a switch. V každém z těchto případů je základním formátem alternativní syntaxe záměna otvírací závorky za dvojtečku (:) a uzavírací závorky za endif;, endwhile;, endfor;, endforeach;, resp. endswitch;.

<?php if ($a == 5): ?>
A se rovná 5
<?php endif; ?>

Ve výše uvedeném příkladu je HTML blok vnořen do příkazu if napsaném alternativní syntaxí. Tento HTML blok by se zobrazil pouze v případě, že je $a rovno 5.

Alternativní syntaxi lze použít i pro else a elseif. Následující příklad ukazuje strukturu if, elseif a else v alternativním formátu:

if ($a == 5):
    print "a se rovná 5";
    print "...";
elseif ($a == 6):
    print "a se rovná 6";
    print "!!!";
else:
    print "a není ani 5, ani 6";
endif;

Další příklady - viz také while, for, a if.

Předcházející | Nahoru | Další
elseif | Domů | while


return

Zavolán uvnitř funkce, příkaz return() okamžitě ukončí provádění této funkce a vrací svůj argument jako hodnotu volání funkce. return() také obdobně ukončí provádění příkazu eval() nebo celého skriptu.

Pokud se volá z globálního kontextu, provádění skriptu se ukončí. Byl-li aktuální skript vložen pomocí include() nebo require(), předá se řízení volajícímu souboru. Navíc, bylo-li použito include(), bude hodnota specifikovaná v return() vrácena jako hodnota volání include(). Pokud se return() zavolá z hlavního souboru skriptu, provádění skončí. Když se jedná o soubor specifikovaný pomocí konfiguračních voleb auto_prepend_file nebo auto_append_file v konfiguračním souboru, zpracování souboru končí.

Více informací - viz Návratové hodnoty.

Poznámka: Uvědomte si, že return() je jazykový příkaz, a nikoli funkce -- uzavření argumentů do závorek není nutné. Obvykle se vynechávají, ale nezáleží na tom, zda se použijí či nikoli.

Předcházející | Nahoru | Další
declare | Domů | require


Kapitola 17. Funkce

Obsah

Uživatelsky definované funkce
Argumenty funkcí
Návratové hodnoty
old_function
Funkce v proměnných

Uživatelsky definované funkce

Funkce může být definována pomocí syntaxe podobné této:

function foo ($arg_1, $arg_2, ..., $arg_n)
{
    echo "Ukázková funkce.\n";
    return $retval;
}

Do funkce může být vložen jakýkoli platný PHP kód, dokonce i definice jiných funkcí a tříd.

V PHP 3 musí být funkce definovány dříve, než je na ně odkazováno. V PHP už tento požadavek neplatí.

PHP nepodporuje přetěžování funkcí, není možné ani oddefinování nebo předefinovaná dříve deklarovaných funkcí.

PHP 3 nepodporuje proměnný počet argumentů funkcí, zatímco implicitní argumenty jsou podporovány (více informací - viz Implicitní hodnoty argumentů). PHP 4 podporuje obojí: více informací - viz Seznam argumentů proměnné délky a reference funkcí func_num_args(), func_get_arg(), a func_get_args().

Předcházející | Nahoru | Další
include_once | Domů | Argumenty funkcí


Argumenty funkcí

Informace mohou být do funkcí předávány přes seznam argumentů, což je seznam proměnných a/nebo konstant oddělených čárkou.

PHP podporuje předávání argumentů hodnotou (implicitní), předávání odkazem, a implicitní hodnoty argumentů. Proměnná délka seznamu argumentů je podporována pouze v PHP 4 a pozdějších; viz Seznam argumentů proměnné délky a reference funkcí func_num_args(), func_get_arg(), a func_get_args(). Podobný efekt může být v PHP 3 dosažen předáním pole argumentů do funkce:

function takes_array($input)
{
    echo "$input[0] + $input[1] = ", $input[0]+$input[1];
}

Předávání argumentů odkazem

Implicitně jsou argumenty funkcí předávány hodnotou (takže když změníte hodnotu argumentu ve funkci, nezmění se mimo funkci). Pokud chcete umožnit funkci modifikovat své argumenty, musíte je předávat odkazem.

Pokud chcete, aby byl argument do funkce předáván vždy odkazem, můžete před název argumentu v definici funkce předřadit ampersand (&):

function add_some_extra(&$string)
{
    $string .= 'a něco navíc.';
}
$str = 'Toto je řetězec ';
add_some_extra($str);
echo $str;    // vypíše 'Toto je řetězec a něco navíc.'

Implicitní hodnoty argumentů

Funkce může ve stylu C++ definovat implicitní hodnoty pro skalární argumenty takto:

function makecoffee ($type = "cappucina")
{
    return "Dělám šálek $type.\n";
}
echo makecoffee ();
echo makecoffee ("espressa");

Výstupem výše uvedeného kódu je:

Dělám šálek cappucina.
Dělám šálek espressa.

Implicitní hodnota musí být konstantní výraz, ne (například) proměnná nebo položka třídy.

Uvědomte si, že když používáte implicitní argumenty, jakékoli implicitní hodnoty by měly být na pravé staně neimplicitního argumentu; jinak to nebude pracovat podle očekávání. Uvažujme tento kus kódu:

function makeyogurt ($type = "acidophilus", $flavour)
{
    return "Dělám kelímek jogurtu $type $flavour.\n";
}

echo makeyogurt ("malina");   // nebude pracovat podle očekávání

Výstupem uvedeného příkladu bude:

Warning: Missing argument 2 in call to makeyogurt() in
/usr/local/etc/httpd/htdocs/php3test/functest.html on line 41
Dělám kelímek jogurtu malina.

A nyní to porovnejme s tímto:

function makeyogurt ($flavour, $type = "acidophilus")
{
    return "Dělám kelímek jogurtu $type $flavour.\n";
}

echo makeyogurt ("malina");   // pracuje podle očekávání

Příklad vytiskne:

Dělám kelímek jogurtu acidophilus malina.

Seznam argumentů proměnné délky

PHP 4 má podporu pro seznam argumentů proměnné délky v uživatelských
funkcích. Je to opravdu jednoduché, použitím funkcí
func_num_args(),
func_get_arg(), a
func_get_args().

Není třeba žádná zvláštní syntaxe, seznam argumentů může být stále explicitně poskytován definicemi funkcí a bude se chovat jako normálně.

Předcházející | Nahoru | Další
17. Funkce | Domů | Návratové hodnoty


Návratové hodnoty

Hodnoty jsou vraceny pomocí nepovinné klausule return. Může být vracen libovolný typ, včetně seznamů a objektů. Klasule způsobuje, že funkce okamžitě ukončí svůj běh a předá řízení zpět na řádek, odkud byla volána. Pro více informací viz return().

function square ($num)
{
    return $num * $num;
}
echo square (4);   // vypíše '16'.

Z funkce nemůžete vracet více hodnot, ale podobného výsledku může být dosaženo vrácením seznamu.

function small_numbers()
{
    return array (0, 1, 2);
}
list ($zero, $one, $two) = small_numbers();

K vrácení odkazu z funkce musíte použít referenční operátor & jak v deklaraci funkce, tak při přiřazování vrácené hodnoty do proměnné:

function &returns_reference()
{
    return $someref;
}

$newref =& returns_reference();

Pro další informace o odkazech se laskavě podívejte na Vysvětlení odkazů.

Předcházející | Nahoru | Další
Argumenty funkcí | Domů | old_function


Funkce v proměnných

PHP podporuje koncept funkcí v proměnných. To znamená, že když má název proměnné připojeny závorky, PHP bude hledat funkci se stejným názvem, jako má hodnota proměnné, a pokusí se ji provést. To lze mj. použít k implementací zpětných volání, tabulek funkcí atd.

Funkce v proměnných nebudou fungovat s jazykovými konstrukty jinými než print(), jako je echo(), unset(), isset() a empty(). To je jeden z velkých rozdílů mezi funkcemi PHP a jazykovými konstrukty.

Příklad 17.1. Příklad na funkce v proměnných

<?php
function foo()
{
    echo "V foo()<br>\n";
}

function bar($arg = '')
{
    echo "V bar(); byl argument '$arg'.<br>\n";
}

$func = 'foo';
$func();
$func = 'bar';
$func('test');
?>

Předcházející | Nahoru | Další
old_function | Domů | 18. Classes and Objects (PHP 4)


Kapitola 18. Classes and Objects (PHP 4)

Obsah

class
extends
Constructors
Scope Resolution Operator (::)
parent
Serializing objects - objects in sessions
The magic functions __sleep and __wakeup
References inside the constructor
Comparing objects

class

A class is a collection of variables and functions working with these variables. Variables are defined by var and functions by function. A class is defined using the following syntax:

<?php
class Cart {
    var $items;  // Items in our shopping cart

    // Add $num articles of $artnr to the cart

    function add_item($artnr, $num) {
        $this->items[$artnr] += $num;
    }

    // Take $num articles of $artnr out of the cart

    function remove_item($artnr, $num) {
        if ($this->items[$artnr] > $num) {
            $this->items[$artnr] -= $num;
            return true;
        } elseif ($this->items[$artnr] == $num) {
            unset($this->items[$artnr]);
            return true;
        } else {
            return false;
        }
    }
}
?>

This defines a class named Cart that consists of an associative array of articles in the cart and two functions to add and remove items from this cart.

Varování

You can NOT break up a class definition into multiple files. You also can NOT break a class definition into multiple PHP blocks, unless the break is within a method declaration. The following will not work:

<?php
class test {
?>
<?php
    function test() {
        print 'OK';
    }
}
?>

However, the following is allowed:

<?php
class test {
    function test() {
        ?>
        <?php
        print 'OK';
    }
}
?>

The following cautionary notes are valid for PHP 4.

Výstraha

The name stdClass is used internally by Zend and is reserved. You cannot have a class named stdClass in PHP.

Výstraha

The function names __sleep and __wakeup are magical in PHP classes. You cannot have functions with these names in any of your classes unless you want the magic functionality associated with them. See below for more information.

Výstraha

PHP reserves all function names starting with __ as magical. It is recommended that you do not use function names with __ in PHP unless you want some documented magic functionality.

In PHP 4, only constant initializers for var variables are allowed. To initialize variables with non-constant values, you need an initialization function which is called automatically when an object is being constructed from the class. Such a function is called a constructor (see below).

<?php
class Cart {
    /* None of these will work in PHP 4. */
    var $todays_date = date("Y-m-d");
    var $name = $firstname;
    var $owner = 'Fred ' . 'Jones';
    /* Arrays containing constant values will, though. */
    var $items = array("VCR", "TV");
}

/* This is how it should be done. */
class Cart {
    var $todays_date;
    var $name;
    var $owner;
    var $items = array("VCR", "TV");

    function Cart() {
        $this->todays_date = date("Y-m-d");
        $this->name = $GLOBALS['firstname'];
        /* etc. . . */
    }
}
?>

Classes are types, that is, they are blueprints for actual variables. You have to create a variable of the desired type with the new operator.

<?php
$cart = new Cart;
$cart->add_item("10", 1);

$another_cart = new Cart;
$another_cart->add_item("0815", 3);
?>

This creates the objects $cart and $another_cart, both of the class Cart. The function add_item() of the $cart object is being called to add 1 item of article number 10 to the $cart. 3 items of article number 0815 are being added to $another_cart.

Both, $cart and $another_cart, have functions add_item(), remove_item() and a variable items. These are distinct functions and variables. You can think of the objects as something similar to directories in a filesystem. In a filesystem you can have two different files README.TXT, as long as they are in different directories. Just like with directories where you'll have to type the full pathname in order to reach each file from the toplevel directory, you have to specify the complete name of the function you want to call: in PHP terms, the toplevel directory would be the global namespace, and the pathname separator would be ->. Thus, the names $cart->items and $another_cart->items name two different variables. Note that the variable is named $cart->items, not $cart->$items, that is, a variable name in PHP has only a single dollar sign.

<?php
// correct, single $
$cart->items = array("10" => 1);

// invalid, because $cart->$items becomes $cart->""
$cart->$items = array("10" => 1);

// correct, but may or may not be what was intended:
// $cart->$myvar becomes $cart->items
$myvar = 'items';
$cart->$myvar = array("10" => 1);
?>

Within a class definition, you do not know under which name the object will be accessible in your program: at the time the Cart class was written, it was unknown whether the object would be named $cart, $another_cart, or something else later. Thus, you cannot write $cart->items within the Cart class itself. Instead, in order to be able to access its own functions and variables from within a class, one can use the pseudo-variable $this which can be read as 'my own' or 'current object'. Thus, '$this->items[$artnr] += $num' can be read as 'add $num to the $artnr counter of my own items array' or 'add $num to the $artnr counter of the items array within the current object'.

Poznámka: The $this pseudo-variable is not usually defined if the method in which it is hosted is called statically. This is not, however, a strict rule: $this is defined if a method is called statically from within another object. In this case, the value of $this is that of the calling object. This is illustrated in the following example:

<?php
class A
{
    function foo()
    {
        if (isset($this)) {
            echo '$this is defined (';
            echo get_class($this);
            echo ")\n";
        } else {
            echo "\$this is not defined.\n";
        }
    }
}

class B
{
    function bar()
    {
        A::foo();
    }
}

$a = new A();
$a->foo();
A::foo();
$b = new B();
$b->bar();
B::bar();
?>

Výše uvedený příklad vypíše:

$this is defined (a)
$this is not defined.
$this is defined (b)
$this is not defined.

Poznámka: There are some nice functions to handle classes and objects. You might want to take a look at the Class/Object Functions.

Předcházející | Nahoru | Další
Funkce v proměnných | Domů | extends


Serializing objects - objects in sessions

Poznámka: In PHP 3, objects will lose their class association throughout the process of serialization and unserialization. The resulting variable is of type object, but has no class and no methods, thus it is pretty useless (it has become just like an array with a funny syntax).

Výstraha

The following information is valid for PHP >= 4 only.

serialize() returns a string containing a byte-stream representation of any value that can be stored in PHP. unserialize() can use this string to recreate the original variable values. Using serialize to save an object will save all variables in an object. The functions in an object will not be saved, only the name of the class.

In order to be able to unserialize() an object, the class of that object needs to be defined. That is, if you have an object $a of class A on page1.php and serialize this, you'll get a string that refers to class A and contains all values of variabled contained in $a. If you want to be able to unserialize this on page2.php, recreating $a of class A, the definition of class A must be present in page2.php. This can be done for example by storing the class definition of class A in an include file and including this file in both page1.php and page2.php.

<?php
// classa.inc:

  class A {
      var $one = 1;

      function show_one() {
          echo $this->one;
      }
  }

// page1.php:

  include("classa.inc");

  $a = new A;
  $s = serialize($a);
  // store $s somewhere where page2.php can find it.
  $fp = fopen("store", "w");
  fwrite($fp, $s);
  fclose($fp);

// page2.php:

  // this is needed for the unserialize to work properly.
  include("classa.inc");

  $s = implode("", @file("store"));
  $a = unserialize($s);

  // now use the function show_one() of the $a object.
  $a->show_one();
?>

If you are using sessions and use session_register() to register objects, these objects are serialized automatically at the end of each PHP page, and are unserialized automatically on each of the following pages. This basically means that these objects can show up on any of your pages once they become part of your session.

It is strongly recommended that you include the class definitions of all such registered objects on all of your pages, even if you do not actually use these classes on all of your pages. If you don't and an object is being unserialized without its class definition being present, it will lose its class association and become an object of class stdClass without any functions available at all, that is, it will become quite useless.

So if in the example above $a became part of a session by running session_register("a"), you should include the file classa.inc on all of your pages, not only page1.php and page2.php.

Předcházející | Nahoru | Další
parent | Domů | The magic functions __sleep and __wakeup


References inside the constructor

Creating references within the constructor can lead to confusing results. This tutorial-like section helps you to avoid problems.

<?php
class Foo {
    function Foo($name) {
        // create a reference inside the global array $globalref
        global $globalref;
        $globalref[] = &$this;
        // set name to passed value
        $this->setName($name);
        // and put it out
        $this->echoName();
    }

    function echoName() {
        echo "<br />", $this->name;
    }

    function setName($name) {
        $this->name = $name;
    }
}
?>

Let us check out if there is a difference between $bar1 which has been created using the copy = operator and $bar2 which has been created using the reference =& operator...

<?php
$bar1 = new Foo('set in constructor');
$bar1->echoName();
$globalref[0]->echoName();

/* output:
set in constructor
set in constructor
set in constructor */

$bar2 =& new Foo('set in constructor');
$bar2->echoName();
$globalref[1]->echoName();

/* output:
set in constructor
set in constructor
set in constructor */
?>

Apparently there is no difference, but in fact there is a very significant one: $bar1 and $globalref[0] are _NOT_ referenced, they are NOT the same variable. This is because "new" does not return a reference by default, instead it returns a copy.

Poznámka: There is no performance loss (since PHP 4 and up use reference counting) returning copies instead of references. On the contrary it is most often better to simply work with copies instead of references, because creating references takes some time where creating copies virtually takes no time (unless none of them is a large array or object and one of them gets changed and the other(s) one(s) subsequently, then it would be wise to use references to change them all concurrently).

To prove what is written above let us watch the code below.
<?php
// now we will change the name. what do you expect?
// you could expect that both $bar1 and $globalref[0] change their names...
$bar1->setName('set from outside');

// as mentioned before this is not the case.
$bar1->echoName();
$globalref[0]->echoName();

/* output:
set from outside
set in constructor */

// let us see what is different with $bar2 and $globalref[1]
$bar2->setName('set from outside');

// luckily they are not only equal, they are the same variable
// thus $bar2->name and $globalref[1]->name are the same too
$bar2->echoName();
$globalref[1]->echoName();

/* output:
set from outside
set from outside */
?>

Another final example, try to understand it.

<?php
class A {
    function A($i) {
        $this->value = $i;
        // try to figure out why we do not need a reference here
        $this->b = new B($this);
    }

    function createRef() {
        $this->c = new B($this);
    }

    function echoValue() {
        echo "<br />","class ",get_class($this),': ',$this->value;
    }
}

class B {
    function B(&$a) {
        $this->a = &$a;
    }

    function echoValue() {
        echo "<br />","class ",get_class($this),': ',$this->a->value;
    }
}

// try to understand why using a simple copy here would yield
// in an undesired result in the *-marked line
$a =& new A(10);
$a->createRef();

$a->echoValue();
$a->b->echoValue();
$a->c->echoValue();

$a->value = 11;

$a->echoValue();
$a->b->echoValue(); // *
$a->c->echoValue();

?>

Výše uvedený příklad vypíše:

class A: 10
class B: 10
class B: 10
class A: 11
class B: 11
class B: 11

Předcházející | Nahoru | Další
The magic functions __sleep and __wakeup | Domů | Comparing objects


Comparing objects

In PHP 4, objects are compared in a very simple manner, namely: Two object instances are equal if they have the same attributes and values, and are instances of the same class. Similar rules are applied when comparing two objects using the identity operator (===).

If we were to execute the code in the example below:

Příklad 18.1. Example of object comparison in PHP 4

<?php
function bool2str($bool) {
    if ($bool === false) {
            return 'FALSE';
    } else {
            return 'TRUE';
    }
}

function compareObjects(&$o1, &$o2) {
    echo 'o1 == o2 : '.bool2str($o1 == $o2)."\n";
    echo 'o1 != o2 : '.bool2str($o1 != $o2)."\n";
    echo 'o1 === o2 : '.bool2str($o1 === $o2)."\n";
    echo 'o1 !== o2 : '.bool2str($o1 !== $o2)."\n";
}

class Flag {
    var $flag;

    function Flag($flag=true) {
            $this->flag = $flag;
    }
}

class SwitchableFlag extends Flag {

    function turnOn() {
        $this->flag = true;
    }

    function turnOff() {
        $this->flag = false;
    }
}

$o = new Flag();
$p = new Flag(false);
$q = new Flag();

$r = new SwitchableFlag();

echo "Compare instances created with the same parameters\n";
compareObjects($o, $q);

echo "\nCompare instances created with different parameters\n";
compareObjects($o, $p);

echo "\nCompare an instance of a parent class with one from a subclass\n";
compareObjects($o, $r);
?>

Výše uvedený příklad vypíše:

Compare instances created with the same parameters
o1 == o2 : TRUE
o1 != o2 : FALSE
o1 === o2 : TRUE
o1 !== o2 : FALSE

Compare instances created with different parameters
o1 == o2 : FALSE
o1 != o2 : TRUE
o1 === o2 : FALSE
o1 !== o2 : TRUE

Compare an instance of a parent class with one from a subclass
o1 == o2 : FALSE
o1 != o2 : TRUE
o1 === o2 : FALSE
o1 !== o2 : TRUE

Which is the output we will expect to obtain given the comparison rules above. Only instances with the same values for their attributes and from the same class are considered equal and identical.

Even in the cases where we have object composition, the same comparison rules apply. In the example below we create a container class that stores an associative array of Flag objects.

Příklad 18.2. Compound object comparisons in PHP 4

<?php
class FlagSet {
    var $set;

    function FlagSet($flagArr = array()) {
        $this->set = $flagArr;
    }

    function addFlag($name, $flag) {
        $this->set[$name] = $flag;
    }

    function removeFlag($name) {
        if (array_key_exists($name, $this->set)) {
            unset($this->set[$name]);
        }
    }
}

$u = new FlagSet();
$u->addFlag('flag1', $o);
$u->addFlag('flag2', $p);
$v = new FlagSet(array('flag1'=>$q, 'flag2'=>$p));
$w = new FlagSet(array('flag1'=>$q));

echo "\nComposite objects u(o,p) and v(q,p)\n";
compareObjects($u, $v);

echo "\nu(o,p) and w(q)\n";
compareObjects($u, $w);
?>

Výše uvedený příklad vypíše:

Composite objects u(o,p) and v(q,p)
o1 == o2 : TRUE
o1 != o2 : FALSE
o1 === o2 : TRUE
o1 !== o2 : FALSE

u(o,p) and w(q)
o1 == o2 : FALSE
o1 != o2 : TRUE
o1 === o2 : FALSE
o1 !== o2 : TRUE

Předcházející | Nahoru | Další
References inside the constructor | Domů | 19. Classes and Objects (PHP 5)


Kapitola 19. Classes and Objects (PHP 5)

Obsah

Introduction
The Basics
Autoloading Objects
Constructors and Destructors
Visibility
Scope Resolution Operator (::)
Static Keyword
Class Constants
Class Abstraction
Object Interfaces
Overloading
Object Iteration
Patterns
Magic Methods
Final Keyword
Object cloning
Comparing objects
Reflection
Type Hinting
Late Static Bindings

Introduction

In PHP 5 there is a new Object Model. PHP's handling of objects has been completely rewritten, allowing for better performance and more features.

Tip

You may also want to take a look at the T – „Userland Naming Guide“.

Předcházející | Nahoru | Další
Comparing objects | Domů | The Basics


The Basics

class

Every class definition begins with the keyword class, followed by a class name, which can be any name that isn't a reserved word in PHP. Followed by a pair of curly braces, which contains the definition of the classes members and methods. A pseudo-variable, $this is available when a method is called from within an object context. $this is a reference to the calling object (usually the object to which the method belongs, but can be another object, if the method is called statically from the context of a secondary object). This is illustrated in the following examples:

Příklad 19.1. $this variable in object-oriented language

<?php
class A
{
    function foo()
    {
        if (isset($this)) {
            echo '$this is defined (';
            echo get_class($this);
            echo ")\n";
        } else {
            echo "\$this is not defined.\n";
        }
    }
}

class B
{
    function bar()
    {
        A::foo();
    }
}

$a = new A();
$a->foo();
A::foo();
$b = new B();
$b->bar();
B::bar();
?>

Výše uvedený příklad vypíše:

$this is defined (a)
$this is not defined.
$this is defined (b)
$this is not defined.

Příklad 19.2. Simple Class definition

<?php
class SimpleClass
{
    // member declaration
    public $var = 'a default value';

    // method declaration
    public function displayVar() {
        echo $this->var;
    }
}
?>

The default value must be a constant expression, not (for example) a variable, a class member or a function call.

Příklad 19.3. Class members' default value

<?php
class SimpleClass
{
    // invalid member declarations:
    public $var1 = 'hello '.'world';
    public $var2 = <<<EOD
hello world
EOD;
    public $var3 = 1+2;
    public $var4 = self::myStaticMethod();
    public $var5 = $myVar;

    // valid member declarations:
    public $var6 = myConstant;
    public $var7 = self::classConstant;
    public $var8 = array(true, false);

}
?>

Poznámka: There are some nice functions to handle classes and objects. You might want to take a look at the Class/Object Functions.

new

To create an instance of a class, a new object must be created and assigned to a variable. An object will always be assigned when creating a new object unless the object has a constructor defined that throws an exception on error. Classes should be defined before instantiation (and in some cases this is a requirement).

Příklad 19.4. Creating an instance

<?php
$instance = new SimpleClass();
?>

In the class context, it is possible to create a new object by new self and new parent.

When assigning an already created instance of a class to a new variable, the new variable will access the same instance as the object that was assigned. This behaviour is the same when passing instances to a function. A copy of an already created object can be made by cloning it.

Příklad 19.5. Object Assignment

<?php
$assigned   =  $instance;
$reference  =& $instance;

$instance->var = '$assigned will have this value';

$instance = null; // $instance and $reference become null

var_dump($instance);
var_dump($reference);
var_dump($assigned);
?>

Výše uvedený příklad vypíše:

NULL
NULL
object(SimpleClass)#1 (1) {
   ["var"]=>
     string(30) "$assigned will have this value"
}

extends

A class can inherit methods and members of another class by using the extends keyword in the declaration. It is not possible to extend multiple classes, a class can only inherit one base class.

The inherited methods and members can be overridden, unless the parent class has defined a method as final, by redeclaring them with the same name defined in the parent class. It is possible to access the overridden methods or static members by referencing them with parent::

Příklad 19.6. Simple Class Inheritance

<?php
class ExtendClass extends SimpleClass
{
    // Redefine the parent method
    function displayVar()
    {
        echo "Extending class\n";
        parent::displayVar();
    }
}

$extended = new ExtendClass();
$extended->displayVar();
?>

Výše uvedený příklad vypíše:

Extending class
a default value

Předcházející | Nahoru | Další
19. Classes and Objects (PHP 5) | Domů | Autoloading Objects


Autoloading Objects

Many developers writing object-oriented applications create one PHP source file per-class definition. One of the biggest annoyances is having to write a long list of needed includes at the beginning of each script (one for each class).

In PHP 5, this is no longer necessary. You may define an __autoload function which is automatically called in case you are trying to use a class which hasn't been defined yet. By calling this function the scripting engine is given a last chance to load the class before PHP fails with an error.

Poznámka: Exceptions thrown in __autoload function cannot be caught in the catch block and results in a fatal error.

Poznámka: Autoloading is not available if using PHP in CLI interactive mode.

Poznámka: If the class name is used e.g. in call_user_func() then it can contain some dangerous characters such as ../. It is recommended to not use the user-input in such functions or at least verify the input in __autoload().

Příklad 19.7. Autoload example

This example attempts to load the classes MyClass1 and MyClass2 from the files MyClass1.php and MyClass2.php respectively.

<?php
function __autoload($class_name) {
    require_once $class_name . '.php';
}

$obj  = new MyClass1();
$obj2 = new MyClass2();
?>

Předcházející | Nahoru | Další
The Basics | Domů | Constructors and Destructors


Constructors and Destructors

Constructor

void __construct ( [mixed $args [, $...]] )

PHP 5 allows developers to declare constructor methods for classes. Classes which have a constructor method call this method on each newly-created object, so it is suitable for any initialization that the object may need before it is used.

Poznámka: Parent constructors are not called implicitly if the child class defines a constructor. In order to run a parent constructor, a call to parent::__construct() within the child constructor is required.

Příklad 19.8. using new unified constructors

<?php
class BaseClass {
   function __construct() {
       print "In BaseClass constructor\n";
   }
}

class SubClass extends BaseClass {
   function __construct() {
       parent::__construct();
       print "In SubClass constructor\n";
   }
}

$obj = new BaseClass();
$obj = new SubClass();
?>

For backwards compatibility, if PHP 5 cannot find a __construct() function for a given class, it will search for the old-style constructor function, by the name of the class. Effectively, it means that the only case that would have compatibility issues is if the class had a method named __construct() which was used for different semantics.

Destructor

void __destruct ( void )

PHP 5 introduces a destructor concept similar to that of other object-oriented languages, such as C++. The destructor method will be called as soon as all references to a particular object are removed or when the object is explicitly destroyed or in any order in shutdown sequence.

Příklad 19.9. Destructor Example

<?php
class MyDestructableClass {
   function __construct() {
       print "In constructor\n";
       $this->name = "MyDestructableClass";
   }

   function __destruct() {
       print "Destroying " . $this->name . "\n";
   }
}

$obj = new MyDestructableClass();
?>

Like constructors, parent destructors will not be called implicitly by the engine. In order to run a parent destructor, one would have to explicitly call parent::__destruct() in the destructor body.

Poznámka: Destructors called during the script shutdown have HTTP headers already sent. The working directory in the script shutdown phase can be different with some SAPIs (e.g. Apache).

Poznámka: Attempting to throw an exception from a destructor (called in the time of script termination) causes a fatal error.

Předcházející | Nahoru | Další
Autoloading Objects | Domů | Visibility


Visibility

The visibility of a property or method can be defined by prefixing the declaration with the keywords: public, protected or private. Public declared items can be accessed everywhere. Protected limits access to inherited and parent classes (and to the class that defines the item). Private limits visibility only to the class that defines the item.

Members Visibility

Class members must be defined with public, private, or protected.

Příklad 19.10. Member declaration

<?php
/**
 * Define MyClass
 */
class MyClass
{
    public $public = 'Public';
    protected $protected = 'Protected';
    private $private = 'Private';

    function printHello()
    {
        echo $this->public;
        echo $this->protected;
        echo $this->private;
    }
}

$obj = new MyClass();
echo $obj->public; // Works
echo $obj->protected; // Fatal Error
echo $obj->private; // Fatal Error
$obj->printHello(); // Shows Public, Protected and Private

/**
 * Define MyClass2
 */
class MyClass2 extends MyClass
{
    // We can redeclare the public and protected method, but not private
    protected $protected = 'Protected2';

    function printHello()
    {
        echo $this->public;
        echo $this->protected;
        echo $this->private;
    }
}

$obj2 = new MyClass2();
echo $obj2->public; // Works
echo $obj2->private; // Undefined
echo $obj2->protected; // Fatal Error
$obj2->printHello(); // Shows Public, Protected2, Undefined

?>

Poznámka: The PHP 4 method of declaring a variable with the var keyword is still supported for compatibility reasons (as a synonym for the public keyword). In PHP 5 before 5.1.3, its usage would generate an E_STRICT warning.

Method Visibility

Class methods must be defined with public, private, or protected. Methods without any declaration are defined as public.

Příklad 19.11. Method Declaration

<?php
/**
 * Define MyClass
 */
class MyClass
{
    // Contructors must be public
    public function __construct() { }

    // Declare a public method
    public function MyPublic() { }

    // Declare a protected method
    protected function MyProtected() { }

    // Declare a private method
    private function MyPrivate() { }

    // This is public
    function Foo()
    {
        $this->MyPublic();
        $this->MyProtected();
        $this->MyPrivate();
    }
}

$myclass = new MyClass;
$myclass->MyPublic(); // Works
$myclass->MyProtected(); // Fatal Error
$myclass->MyPrivate(); // Fatal Error
$myclass->Foo(); // Public, Protected and Private work

/**
 * Define MyClass2
 */
class MyClass2 extends MyClass
{
    // This is public
    function Foo2()
    {
        $this->MyPublic();
        $this->MyProtected();
        $this->MyPrivate(); // Fatal Error
    }
}

$myclass2 = new MyClass2;
$myclass2->MyPublic(); // Works
$myclass2->Foo2(); // Public and Protected work, not Private

class Bar
{
    public function test() {
        $this->testPrivate();
        $this->testPublic();
    }

    public function testPublic() {
        echo "Bar::testPublic\n";
    }

    private function testPrivate() {
        echo "Bar::testPrivate\n";
    }
}

class Foo extends Bar
{
    public function testPublic() {
        echo "Foo::testPublic\n";
    }

    private function testPrivate() {
        echo "Foo::testPrivate\n";
    }
}

$myFoo = new foo();
$myFoo->test(); // Bar::testPrivate
                // Foo::testPublic
?>

Předcházející | Nahoru | Další
Constructors and Destructors | Domů | Scope Resolution Operator (::)


Scope Resolution Operator (::)

The Scope Resolution Operator (also called Paamayim Nekudotayim) or in simpler terms, the double colon, is a token that allows access to static, constant, and overridden members or methods of a class.

When referencing these items from outside the class definition, use the name of the class.

As of PHP 5.3.0, it's possible to reference the class using a variable. Keywords like self, parent or static are not allowed in dynamic class references.

Paamayim Nekudotayim would, at first, seem like a strange choice for naming a double-colon. However, while writing the Zend Engine 0.5 (which powers PHP 3), that's what the Zend team decided to call it. It actually does mean double-colon - in Hebrew!

Příklad 19.12. :: from outside the class definition

<?php
class MyClass {
    const CONST_VALUE = 'A constant value';
}

$classname = 'MyClass';
echo $classname::CONST_VALUE;

echo MyClass::CONST_VALUE;
?>

Two special keywords self and parent are used to access members or methods from inside the class definition.

Příklad 19.13. :: from inside the class definition

<?php
class OtherClass extends MyClass
{
    public static $my_static = 'static var';

    public static function doubleColon() {
        echo parent::CONST_VALUE . "\n";
        echo self::$my_static . "\n";
    }
}

$classname = 'OtherClass';
echo $classname::doubleColon();

OtherClass::doubleColon();
?>

When an extending class overrides the parents definition of a method, PHP will not call the parent's method. It's up to the extended class on whether or not the parent's method is called. This also applies to Constructors and Destructors, Overloading, and Magic method definitions.

Příklad 19.14. Calling a parent's method

<?php
class MyClass
{
    protected function myFunc() {
        echo "MyClass::myFunc()\n";
    }
}

class OtherClass extends MyClass
{
    // Override parent's definition
    public function myFunc()
    {
        // But still call the parent function
        parent::myFunc();
        echo "OtherClass::myFunc()\n";
    }
}

$class = new OtherClass();
$class->myFunc();
?>

Předcházející | Nahoru | Další
Visibility | Domů | Static Keyword


Static Keyword

Declaring class members or methods as static makes them accessible without needing an instantiation of the class. A member declared as static can not be accessed with an instantiated class object (though a static method can).

For compatibility with PHP 4, if no visibility declaration is used, then the member or method will be treated as if it was declared as public.

Because static methods are callable without an instance of the object created, the pseudo variable $this is not available inside the method declared as static.

Static properties cannot be accessed through the object using the arrow operator ->.

Calling non-static methods statically generates an E_STRICT level warning.

As of PHP 5.3.0, it's possible to reference the class using a variable. Keywords like self, parent or static are not allowed in dynamic class references.

Příklad 19.15. Static member example

<?php
class Foo
{
    public static $my_static = 'foo';

    public function staticValue() {
        return self::$my_static;
    }
}

class Bar extends Foo
{
    public function fooStatic() {
        return parent::$my_static;
    }
}

print Foo::$my_static . "\n";

$foo = new Foo();
print $foo->staticValue() . "\n";
print $foo->my_static . "\n";      // Undefined "Property" my_static

print $foo::$my_static . "\n";
$classname = 'Foo';
print $classname::$my_static . "\n";

print Bar::$my_static . "\n";
$bar = new Bar();
print $bar->fooStatic() . "\n";
?>

Příklad 19.16. Static method example

<?php
class Foo {
    public static function aStaticMethod() {
        // ...
    }
}

Foo::aStaticMethod();
$classname = 'Foo';
$classname::aStaticMethod();
?>

Předcházející | Nahoru | Další
Scope Resolution Operator (::) | Domů | Class Constants


Class Constants

It is possible to define constant values on a per-class basis remaining the same and unchangeable. Constants differ from normal variables in that you don't use the $ symbol to declare or use them.

The value must be a constant expression, not (for example) a variable, a class member, result of a mathematical operation or a function call.

As of PHP 5.3.0, it's possible to reference the class using a variable. Keywords like self, parent or static are not allowed in dynamic class references.

Příklad 19.17. Defining and using a constant

<?php
class MyClass
{
    const constant = 'constant value';

    function showConstant() {
        echo  self::constant . "\n";
    }
}

echo MyClass::constant . "\n";

$classname = "MyClass";
echo $classname::constant . "\n";

$class = new MyClass();
$class->showConstant();

echo $class::constant."\n";
?>

Předcházející | Nahoru | Další
Static Keyword | Domů | Class Abstraction


Class Abstraction

PHP 5 introduces abstract classes and methods. It is not allowed to create an instance of a class that has been defined as abstract. Any class that contains at least one abstract method must also be abstract. Methods defined as abstract simply declare the method's signature they cannot define the implementation.

When inheriting from an abstract class, all methods marked abstract in the parent's class declaration must be defined by the child; additionally, these methods must be defined with the same (or a less restricted) visibility. For example, if the abstract method is defined as protected, the function implementation must be defined as either protected or public, but not private.

Příklad 19.18. Abstract class example

<?php
abstract class AbstractClass
{
    // Force Extending class to define this method
    abstract protected function getValue();
    abstract protected function prefixValue($prefix);

    // Common method
    public function printOut() {
        print $this->getValue() . "\n";
    }
}

class ConcreteClass1 extends AbstractClass
{
    protected function getValue() {
        return "ConcreteClass1";
    }

    public function prefixValue($prefix) {
        return "{$prefix}ConcreteClass1";
    }
}

class ConcreteClass2 extends AbstractClass
{
    public function getValue() {
        return "ConcreteClass2";
    }

    public function prefixValue($prefix) {
        return "{$prefix}ConcreteClass2";
    }
}

$class1 = new ConcreteClass1;
$class1->printOut();
echo $class1->prefixValue('FOO_') ."\n";

$class2 = new ConcreteClass2;
$class2->printOut();
echo $class2->prefixValue('FOO_') ."\n";
?>

Výše uvedený příklad vypíše:

ConcreteClass1
FOO_ConcreteClass1
ConcreteClass2
FOO_ConcreteClass2

Old code that has no user-defined classes or functions named 'abstract' should run without modifications.

Předcházející | Nahoru | Další
Class Constants | Domů | Object Interfaces


Object Interfaces

Object interfaces allow you to create code which specifies which methods a class must implement, without having to define how these methods are handled.

Interfaces are defined using the interface keyword, in the same way as a standard class, but without any of the methods having their contents defined.

All methods declared in an interface must be public, this is the nature of an interface.

implements

To implement an interface, the implements operator is used. All methods in the interface must be implemented within a class; failure to do so will result in a fatal error. Classes may implement more than one interface if desired by separating each interface with a comma.

Poznámka: A class cannot implement two interfaces that share function names, since it would cause ambiguity.

Příklady

Příklad 19.19. Interface example

<?php
// Declare the interface 'iTemplate'
interface iTemplate
{
    public function setVariable($name, $var);
    public function getHtml($template);
}

// Implement the interface
// This will work
class Template implements iTemplate
{
    private $vars = array();

    public function setVariable($name, $var)
    {
        $this->vars[$name] = $var;
    }

    public function getHtml($template)
    {
        foreach($this->vars as $name => $value) {
            $template = str_replace('{' . $name . '}', $value, $template);
        }

        return $template;
    }
}

// This will not work
// Fatal error: Class BadTemplate contains 1 abstract methods
// and must therefore be declared abstract (iTemplate::getHtml)
class BadTemplate implements iTemplate
{
    private $vars = array();

    public function setVariable($name, $var)
    {
        $this->vars[$name] = $var;
    }
}

?>

See also the instanceof operator.

Předcházející | Nahoru | Další
Class Abstraction | Domů | Overloading


Overloading

Both method calls and member accesses can be overloaded via the __call, __get and __set methods. These methods will only be triggered when your object or inherited object doesn't contain the member or method you're trying to access. All overloading methods must not be defined as static. All overloading methods must be defined as public.

Since PHP 5.1.0 it is also possible to overload the isset() and unset() functions via the __isset and __unset methods respectively. Method __isset is called also with empty().

Member overloading

void __set ( string $name, mixed $value )
mixed __get ( string $name )
bool __isset ( string $name )
void __unset ( string $name )

Class members can be overloaded to run custom code defined in your class by defining these specially named methods. The $name parameter used is the name of the variable that should be set or retrieved. The __set() method's $value parameter specifies the value that the object should set the $name.

Poznámka: The __set() method cannot take arguments by reference.

Příklad 19.20. overloading with __get, __set, __isset and __unset example

<?php
class Setter
{
    public $n;
    private $x = array("a" => 1, "b" => 2, "c" => 3);

    public function __get($nm)
    {
        echo "Getting [$nm]\n";

        if (isset($this->x[$nm])) {
            $r = $this->x[$nm];
            print "Returning: $r\n";
            return $r;
        } else {
            echo "Nothing!\n";
        }
    }

    public function __set($nm, $val)
    {
        echo "Setting [$nm] to $val\n";

        if (isset($this->x[$nm])) {
            $this->x[$nm] = $val;
            echo "OK!\n";
        } else {
            echo "Not OK!\n";
        }
    }

    public function __isset($nm)
    {
        echo "Checking if $nm is set\n";

        return isset($this->x[$nm]);
    }

    public function __unset($nm)
    {
        echo "Unsetting $nm\n";

        unset($this->x[$nm]);
    }
}

$foo = new Setter();
$foo->n = 1;
$foo->a = 100;
$foo->a++;
$foo->z++;

var_dump(isset($foo->a)); //true
unset($foo->a);
var_dump(isset($foo->a)); //false

// this doesn't pass through the __isset() method
// because 'n' is a public property
var_dump(isset($foo->n));

var_dump($foo);
?>

Výše uvedený příklad vypíše:

Setting [a] to 100
OK!
Getting [a]
Returning: 100
Setting [a] to 101
OK!
Getting [z]
Nothing!
Setting [z] to 1
Not OK!

Checking if a is set
bool(true)
Unsetting a
Checking if a is set
bool(false)
bool(true)

object(Setter)#1 (2) {
  ["n"]=>
  int(1)
  ["x":"Setter":private]=>
  array(2) {
    ["b"]=>
    int(2)
    ["c"]=>
    int(3)
  }
}

Method overloading

mixed __call ( string $name, array $arguments )

The magic method __call() allows to capture invocation of non existing methods. That way __call() can be used to implement user defined method handling that depends on the name of the actual method being called. This is for instance useful for proxy implementations. The arguments that were passed in the function will be defined as an array in the $arguments parameter. The value returned from the __call() method will be returned to the caller of the method.

Příklad 19.21. overloading with __call example

<?php
class Caller
{
    private $x = array(1, 2, 3);

    public function __call($m, $a)
    {
        print "Method $m called:\n";
        var_dump($a);
        return $this->x;
    }
}

$foo = new Caller();
$a = $foo->test(1, "2", 3.4, true);
var_dump($a);
?>

Výše uvedený příklad vypíše:

Method test called:
array(4) {
    [0]=>
    int(1)
    [1]=>
    string(1) "2"
    [2]=>
    float(3.4)
    [3]=>
    bool(true)
}
array(3) {
    [0]=>
    int(1)
    [1]=>
    int(2)
    [2]=>
    int(3)
}

Předcházející | Nahoru | Další
Object Interfaces | Domů | Object Iteration


Object Iteration

PHP 5 provides a way for objects to be defined so it is possible to iterate through a list of items, with, for example a foreach statement. By default, all visible properties will be used for the iteration.

Příklad 19.22. Simple Object Iteration

<?php
class MyClass
{
    public $var1 = 'value 1';
    public $var2 = 'value 2';
    public $var3 = 'value 3';

    protected $protected = 'protected var';
    private   $private   = 'private var';

    function iterateVisible() {
       echo "MyClass::iterateVisible:\n";
       foreach($this as $key => $value) {
           print "$key => $value\n";
       }
    }
}

$class = new MyClass();

foreach($class as $key => $value) {
    print "$key => $value\n";
}
echo "\n";

$class->iterateVisible();

?>

Výše uvedený příklad vypíše:

var1 => value 1
var2 => value 2
var3 => value 3

MyClass::iterateVisible:
var1 => value 1
var2 => value 2
var3 => value 3
protected => protected var
private => private var

As the output shows, the foreach iterated through all visible variables that can be accessed. To take it a step further you can implement one of PHP 5's internal interface named Iterator. This allows the object to decide what and how the object will be iterated.

Příklad 19.23. Object Iteration implementing Iterator

<?php
class MyIterator implements Iterator
{
    private $var = array();

    public function __construct($array)
    {
        if (is_array($array)) {
            $this->var = $array;
        }
    }

    public function rewind() {
        echo "rewinding\n";
        reset($this->var);
    }

    public function current() {
        $var = current($this->var);
        echo "current: $var\n";
        return $var;
    }

    public function key() {
        $var = key($this->var);
        echo "key: $var\n";
        return $var;
    }

    public function next() {
        $var = next($this->var);
        echo "next: $var\n";
        return $var;
    }

    public function valid() {
        $var = $this->current() !== false;
        echo "valid: {$var}\n";
        return $var;
    }
}

$values = array(1,2,3);
$it = new MyIterator($values);

foreach ($it as $a => $b) {
    print "$a: $b\n";
}
?>

Výše uvedený příklad vypíše:

rewinding
current: 1
valid: 1
current: 1
key: 0
0: 1
next: 2
current: 2
valid: 1
current: 2
key: 1
1: 2
next: 3
current: 3
valid: 1
current: 3
key: 2
2: 3
next:
current:
valid:

You can also define your class so that it doesn't have to define all the Iterator functions by simply implementing the PHP 5 IteratorAggregate interface.

Příklad 19.24. Object Iteration implementing IteratorAggregate

<?php
class MyCollection implements IteratorAggregate
{
    private $items = array();
    private $count = 0;

    // Required definition of interface IteratorAggregate
    public function getIterator() {
        return new MyIterator($this->items);
    }

    public function add($value) {
        $this->items[$this->count++] = $value;
    }
}

$coll = new MyCollection();
$coll->add('value 1');
$coll->add('value 2');
$coll->add('value 3');

foreach ($coll as $key => $val) {
    echo "key/value: [$key -> $val]\n\n";
}
?>

Výše uvedený příklad vypíše:

rewinding
current: value 1
valid: 1
current: value 1
key: 0
key/value: [0 -> value 1]

next: value 2
current: value 2
valid: 1
current: value 2
key: 1
key/value: [1 -> value 2]

next: value 3
current: value 3
valid: 1
current: value 3
key: 2
key/value: [2 -> value 3]

next:
current:
valid:

Poznámka: For more examples of iterators, see the SPL Extension.

Předcházející | Nahoru | Další
Overloading | Domů | Patterns


Patterns

Patterns are ways to describe best practices and good designs. They show a flexible solution to common programming problems.

Factory

The Factory pattern allows for the instantiation of objects at runtime. It is called a Factory Pattern since it is responsible for "manufacturing" an object. A Parameterized Factory receives the name of the class to instantiate as argument.

Příklad 19.25. Parameterized Factory Method

<?php
class Example
{
    // The parameterized factory method
    public static function factory($type)
    {
        if (include_once 'Drivers/' . $type . '.php') {
            $classname = 'Driver_' . $type;
            return new $classname;
        } else {
            throw new Exception ('Driver not found');
        }
    }
}
?>

Defining this method in a class allows drivers to be loaded on the fly. If the Example class was a database abstraction class, loading a MySQL and SQLite driver could be done as follows:

<?php
// Load a MySQL Driver
$mysql = Example::factory('MySQL');

// Load a SQLite Driver
$sqlite = Example::factory('SQLite');
?>

Singleton

The Singleton pattern applies to situations in which there needs to be a single instance of a class. The most common example of this is a database connection. Implementing this pattern allows a programmer to make this single instance easily accessible by many other objects.

Příklad 19.26. Singleton Function

<?php
class Example
{
    // Hold an instance of the class
    private static $instance;

    // A private constructor; prevents direct creation of object
    private function __construct()
    {
        echo 'I am constructed';
    }

    // The singleton method
    public static function singleton()
    {
        if (!isset(self::$instance)) {
            $c = __CLASS__;
            self::$instance = new $c;
        }

        return self::$instance;
    }

    // Example method
    public function bark()
    {
        echo 'Woof!';
    }

    // Prevent users to clone the instance
    public function __clone()
    {
        trigger_error('Clone is not allowed.', E_USER_ERROR);
    }

}

?>

This allows a single instance of the Example class to be retrieved.

<?php
// This would fail because the constructor is private
$test = new Example;

// This will always retrieve a single instance of the class
$test = Example::singleton();
$test->bark();

// This will issue an E_USER_ERROR.
$test_clone = clone $test;

?>

Předcházející | Nahoru | Další
Object Iteration | Domů | Magic Methods


Magic Methods

The function names __construct, __destruct (see Constructors and Destructors), __call, __get, __set, __isset, __unset (see Overloading), __sleep, __wakeup, __toString, __set_state and __clone are magical in PHP classes. You cannot have functions with these names in any of your classes unless you want the magic functionality associated with them.

Výstraha

PHP reserves all function names starting with __ as magical. It is recommended that you do not use function names with __ in PHP unless you want some documented magic functionality.

__sleep and __wakeup

serialize() checks if your class has a function with the magic name __sleep. If so, that function is executed prior to any serialization. It can clean up the object and is supposed to return an array with the names of all variables of that object that should be serialized. If the method doesn't return anything then NULL is serialized and E_NOTICE is issued.

The intended use of __sleep is to commit pending data or perform similar cleanup tasks. Also, the function is useful if you have very large objects which do not need to be saved completely.

Conversely, unserialize() checks for the presence of a function with the magic name __wakeup. If present, this function can reconstruct any resources that the object may have.

The intended use of __wakeup is to reestablish any database connections that may have been lost during serialization and perform other reinitialization tasks.

Příklad 19.27. Sleep and wakeup

<?php
class Connection {
    protected $link;
    private $server, $username, $password, $db;

    public function __construct($server, $username, $password, $db)
    {
        $this->server = $server;
        $this->username = $username;
        $this->password = $password;
        $this->db = $db;
        $this->connect();
    }

    private function connect()
    {
        $this->link = mysql_connect($this->server, $this->username, $this->password);
        mysql_select_db($this->db, $this->link);
    }

    public function __sleep()
    {
        return array('server', 'username', 'password', 'db');
    }

    public function __wakeup()
    {
        $this->connect();
    }
}
?>

__toString

The __toString method allows a class to decide how it will react when it is converted to a string.

Příklad 19.28. Simple example

<?php
// Declare a simple class
class TestClass
{
    public $foo;

    public function __construct($foo) {
        $this->foo = $foo;
    }

    public function __toString() {
        return $this->foo;
    }
}

$class = new TestClass('Hello');
echo $class;
?>

Výše uvedený příklad vypíše:

Hello

It is worth noting that before PHP 5.2.0 the __toString method was only called when it was directly combined with echo() or print(). Since PHP 5.2.0, it is called in any string context (e.g. in printf() with %s modifier) but not in other types contexts (e.g. with %d modifier). Since PHP 5.2.0, converting objects without __toString method to string would cause E_RECOVERABLE_ERROR.

__set_state

This static method is called for classes exported by var_export() since PHP 5.1.0.

The only parameter of this method is an array containing exported properties in the form array('property' => value, ...).

Předcházející | Nahoru | Další
Patterns | Domů | Final Keyword


Final Keyword

PHP 5 introduces the final keyword, which prevents child classes from overriding a method by prefixing the definition with final. If the class itself is being defined final then it cannot be extended.

Příklad 19.29. Final methods example

<?php
class BaseClass {
   public function test() {
       echo "BaseClass::test() called\n";
   }

   final public function moreTesting() {
       echo "BaseClass::moreTesting() called\n";
   }
}

class ChildClass extends BaseClass {
   public function moreTesting() {
       echo "ChildClass::moreTesting() called\n";
   }
}
// Results in Fatal error: Cannot override final method BaseClass::moreTesting()
?>

Příklad 19.30. Final class example

<?php
final class BaseClass {
   public function test() {
       echo "BaseClass::test() called\n";
   }

   // Here it doesn't matter if you specify the function as final or not
   final public function moreTesting() {
       echo "BaseClass::moreTesting() called\n";
   }
}

class ChildClass extends BaseClass {
}
// Results in Fatal error: Class ChildClass may not inherit from final class (BaseClass)
?>

Předcházející | Nahoru | Další
Magic Methods | Domů | Object cloning


Object cloning

Creating a copy of an object with fully replicated properties is not always the wanted behavior. A good example of the need for copy constructors, is if you have an object which represents a GTK window and the object holds the resource of this GTK window, when you create a duplicate you might want to create a new window with the same properties and have the new object hold the resource of the new window. Another example is if your object holds a reference to another object which it uses and when you replicate the parent object you want to create a new instance of this other object so that the replica has its own separate copy.

An object copy is created by using the clone keyword (which calls the object's __clone() method if possible). An object's __clone() method cannot be called directly.

$copy_of_object = clone $object;

When an object is cloned, PHP 5 will perform a shallow copy of all of the object's properties. Any properties that are references to other variables, will remain references. If a __clone() method is defined, then the newly created object's __clone() method will be called, to allow any necessary properties that need to be changed.

Příklad 19.31. Cloning an object

<?php
class SubObject
{
    static $instances = 0;
    public $instance;

    public function __construct() {
        $this->instance = ++self::$instances;
    }

    public function __clone() {
        $this->instance = ++self::$instances;
    }
}

class MyCloneable
{
    public $object1;
    public $object2;

    function __clone()
    {
        // Force a copy of this->object, otherwise
        // it will point to same object.
        $this->object1 = clone $this->object1;
    }
}

$obj = new MyCloneable();

$obj->object1 = new SubObject();
$obj->object2 = new SubObject();

$obj2 = clone $obj;

print("Original Object:\n");
print_r($obj);

print("Cloned Object:\n");
print_r($obj2);

?>

Výše uvedený příklad vypíše:

Original Object:
MyCloneable Object
(
    [object1] => SubObject Object
        (
            [instance] => 1
        )

    [object2] => SubObject Object
        (
            [instance] => 2
        )

)
Cloned Object:
MyCloneable Object
(
    [object1] => SubObject Object
        (
            [instance] => 3
        )

    [object2] => SubObject Object
        (
            [instance] => 2
        )

)

Předcházející | Nahoru | Další
Final Keyword | Domů | Comparing objects


Comparing objects

In PHP 5, object comparison is more complicated than in PHP 4 and more in accordance to what one will expect from an Object Oriented Language (not that PHP 5 is such a language).

When using the comparison operator (==), object variables are compared in a simple manner, namely: Two object instances are equal if they have the same attributes and values, and are instances of the same class.

On the other hand, when using the identity operator (===), object variables are identical if and only if they refer to the same instance of the same class.

An example will clarify these rules.

Příklad 19.32. Example of object comparison in PHP 5

<?php
function bool2str($bool)
{
    if ($bool === false) {
        return 'FALSE';
    } else {
        return 'TRUE';
    }
}

function compareObjects(&$o1, &$o2)
{
    echo 'o1 == o2 : ' . bool2str($o1 == $o2) . "\n";
    echo 'o1 != o2 : ' . bool2str($o1 != $o2) . "\n";
    echo 'o1 === o2 : ' . bool2str($o1 === $o2) . "\n";
    echo 'o1 !== o2 : ' . bool2str($o1 !== $o2) . "\n";
}

class Flag
{
    public $flag;

    function Flag($flag = true) {
        $this->flag = $flag;
    }
}

class OtherFlag
{
    public $flag;

    function OtherFlag($flag = true) {
        $this->flag = $flag;
    }
}

$o = new Flag();
$p = new Flag();
$q = $o;
$r = new OtherFlag();

echo "Two instances of the same class\n";
compareObjects($o, $p);

echo "\nTwo references to the same instance\n";
compareObjects($o, $q);

echo "\nInstances of two different classes\n";
compareObjects($o, $r);
?>

Výše uvedený příklad vypíše:

Two instances of the same class
o1 == o2 : TRUE
o1 != o2 : FALSE
o1 === o2 : FALSE
o1 !== o2 : TRUE

Two references to the same instance
o1 == o2 : TRUE
o1 != o2 : FALSE
o1 === o2 : TRUE
o1 !== o2 : FALSE

Instances of two different classes
o1 == o2 : FALSE
o1 != o2 : TRUE
o1 === o2 : FALSE
o1 !== o2 : TRUE

Poznámka: Extensions can define own rules for their objects comparison.

Předcházející | Nahoru | Další
Object cloning | Domů | Reflection


Reflection

Table of Contents

Introduction
The Reflector interface
The ReflectionException class
The ReflectionFunction class
The ReflectionParameter class
The ReflectionClass class
The ReflectionObject class
The ReflectionMethod class
The ReflectionProperty class
The ReflectionExtension class
Extending the reflection classes

Introduction

PHP 5 comes with a complete reflection API that adds the ability to reverse-engineer classes, interfaces, functions and methods as well as extensions. Additionally, the reflection API also offers ways of retrieving doc comments for functions, classes and methods.

The reflection API is an object-oriented extension to the Zend Engine, consisting of the following classes:

<?php
class Reflection { }
interface Reflector { }
class ReflectionException extends Exception { }
class ReflectionFunction extends ReflectionFunctionAbstract implements Reflector { }
class ReflectionParameter implements Reflector { }
class ReflectionMethod extends ReflectionFunctionAbstract implements Reflector { }
class ReflectionClass implements Reflector { }
class ReflectionObject extends ReflectionClass { }
class ReflectionProperty implements Reflector { }
class ReflectionExtension implements Reflector { }
?>

Poznámka: For details on these classes, have a look at the next chapters.

If we were to execute the code in the example below:

Příklad 19.33. Basic usage of the reflection API

<?php
Reflection::export(new ReflectionClass('Exception'));
?>

Výše uvedený příklad vypíše:

Class [ <internal> class Exception ] {

  - Constants [0] {
  }

  - Static properties [0] {
  }

  - Static methods [0] {
  }

  - Properties [6] {
    Property [ <default> protected $message ]
    Property [ <default> private $string ]
    Property [ <default> protected $code ]
    Property [ <default> protected $file ]
    Property [ <default> protected $line ]
    Property [ <default> private $trace ]
  }

  - Methods [9] {
    Method [ <internal> final private method __clone ] {
    }

    Method [ <internal, ctor> public method __construct ] {

      - Parameters [2] {
        Parameter #0 [ <optional> $message ]
        Parameter #1 [ <optional> $code ]
      }
    }

    Method [ <internal> final public method getMessage ] {
    }

    Method [ <internal> final public method getCode ] {
    }

    Method [ <internal> final public method getFile ] {
    }

    Method [ <internal> final public method getLine ] {
    }

    Method [ <internal> final public method getTrace ] {
    }

    Method [ <internal> final public method getTraceAsString ] {
    }

    Method [ <internal> public method __toString ] {
    }
  }
}

Reflector

Reflector is an interface implemented by all exportable Reflection classes.

<?php
interface Reflector
{
    public string __toString()
    public static string export()
}
?>

ReflectionException

ReflectionException extends the standard Exception and is thrown by Reflection API. No specific methods or properties are introduced.

ReflectionFunction

The ReflectionFunction class lets you reverse-engineer functions.

<?php
class ReflectionFunction extends ReflectionFunctionAbstract implements Reflector
{
    final private __clone()
    public void __construct(string name)
    public string __toString()
    public static string export(string name, bool return)
    public string getName()
    public bool isInternal()
    public bool isDisabled()
    public bool isUserDefined()
    public string getFileName()
    public int getStartLine()
    public int getEndLine()
    public string getDocComment()
    public array getStaticVariables()
    public mixed invoke([mixed args [, ...]])
    public mixed invokeArgs(array args)
    public bool returnsReference()
    public ReflectionParameter[] getParameters()
    public int getNumberOfParameters()
    public int getNumberOfRequiredParameters()
}
?>

Parent class ReflectionFunctionAbstract has the
same methods except invoke(),
invokeArgs(), export() and
isDisabled().

Poznámka: getNumberOfParameters() and getNumberOfRequiredParameters() were added in PHP 5.0.3, while invokeArgs() was added in PHP 5.1.0.

To introspect a function, you will first have to create an instance of the ReflectionFunction class. You can then call any of the above methods on this instance.

Příklad 19.34. Using the ReflectionFunction class

<?php
/**
 * A simple counter
 *
 * @return    int
 */
function counter()
{
    static $c = 0;
    return $c++;
}

// Create an instance of the ReflectionFunction class
$func = new ReflectionFunction('counter');

// Print out basic information
printf(
    "===> The %s function '%s'\n".
    "     declared in %s\n".
    "     lines %d to %d\n",
    $func->isInternal() ? 'internal' : 'user-defined',
    $func->getName(),
    $func->getFileName(),
    $func->getStartLine(),
    $func->getEndline()
);

// Print documentation comment
printf("---> Documentation:\n %s\n", var_export($func->getDocComment(), 1));

// Print static variables if existant
if ($statics = $func->getStaticVariables())
{
    printf("---> Static variables: %s\n", var_export($statics, 1));
}

// Invoke the function
printf("---> Invokation results in: ");
var_dump($func->invoke());

// you may prefer to use the export() method
echo "\nReflectionFunction::export() results:\n";
echo ReflectionFunction::export('counter');
?>

Poznámka: The method invoke() accepts a variable number of arguments which are passed to the function just as in call_user_func().

ReflectionParameter

The ReflectionParameter class retrieves information about a function's or method's parameters.

<?php
class ReflectionParameter implements Reflector
{
    final private __clone()
    public void __construct(string function, string parameter)
    public string __toString()
    public static string export(mixed function, mixed parameter, bool return)
    public string getName()
    public bool isPassedByReference()
    public ReflectionClass getDeclaringClass()
    public ReflectionClass getClass()
    public bool isArray()
    public bool allowsNull()
    public bool isPassedByReference()
    public bool isOptional()
    public bool isDefaultValueAvailable()
    public mixed getDefaultValue()
}
?>

Poznámka:
     getDefaultValue(),
     isDefaultValueAvailable() and
     isOptional() were added in PHP 5.0.3,
     while isArray() was added in PHP 5.1.0.
     getDeclaringFunction() and
     getPosition() were added in PHP 5.2.3.

To introspect function parameters, you will first have to create an instance of the ReflectionFunction or ReflectionMethod classes and then use their getParameters() method to retrieve an array of parameters.

Příklad 19.35. Using the ReflectionParameter class

<?php
function foo($a, $b, $c) { }
function bar(Exception $a, &$b, $c) { }
function baz(ReflectionFunction $a, $b = 1, $c = null) { }
function abc() { }

// Create an instance of ReflectionFunction with the
// parameter given from the command line.
$reflect = new ReflectionFunction($argv[1]);

echo $reflect;

foreach ($reflect->getParameters() as $i => $param) {
    printf(
        "-- Parameter #%d: %s {\n".
        "   Class: %s\n".
        "   Allows NULL: %s\n".
        "   Passed to by reference: %s\n".
        "   Is optional?: %s\n".
        "}\n",
        $i,
        $param->getName(),
        var_export($param->getClass(), 1),
        var_export($param->allowsNull(), 1),
        var_export($param->isPassedByReference(), 1),
        $param->isOptional() ? 'yes' : 'no'
    );
}
?>

ReflectionClass

The ReflectionClass class lets you reverse-engineer classes and interfaces.

<?php
class ReflectionClass implements Reflector
{
    final private __clone()
    public void __construct(string name)
    public string __toString()
    public static string export(mixed class, bool return)
    public string getName()
    public bool isInternal()
    public bool isUserDefined()
    public bool isInstantiable()
    public bool hasConstant(string name)
    public bool hasMethod(string name)
    public bool hasProperty(string name)
    public string getFileName()
    public int getStartLine()
    public int getEndLine()
    public string getDocComment()
    public ReflectionMethod getConstructor()
    public ReflectionMethod getMethod(string name)
    public ReflectionMethod[] getMethods()
    public ReflectionProperty getProperty(string name)
    public ReflectionProperty[] getProperties()
    public array getConstants()
    public mixed getConstant(string name)
    public ReflectionClass[] getInterfaces()
    public bool isInterface()
    public bool isAbstract()
    public bool isFinal()
    public int getModifiers()
    public bool isInstance(stdclass object)
    public stdclass newInstance(mixed args)
    public stdclass newInstanceArgs(array args)
    public ReflectionClass getParentClass()
    public bool isSubclassOf(ReflectionClass class)
    public array getStaticProperties()
    public mixed getStaticPropertyValue(string name [, mixed default])
    public void setStaticPropertyValue(string name, mixed value)
    public array getDefaultProperties()
    public bool isIterateable()
    public bool implementsInterface(string name)
    public ReflectionExtension getExtension()
    public string getExtensionName()
}
?>

Poznámka: hasConstant(), hasMethod(), hasProperty(), getStaticPropertyValue() and setStaticPropertyValue() were added in PHP 5.1.0, while newInstanceArgs() was added in PHP 5.1.3.

To introspect a class, you will first have to create an instance of the ReflectionClass class. You can then call any of the above methods on this instance.

Příklad 19.36. Using the ReflectionClass class

<?php
interface Serializable
{
    // ...
}

class Object
{
    // ...
}

/**
 * A counter class
 */
class Counter extends Object implements Serializable
{
    const START = 0;
    private static $c = Counter::START;

    /**
     * Invoke counter
     *
     * @access  public
     * @return  int
     */
    public function count() {
        return self::$c++;
    }
}

// Create an instance of the ReflectionClass class
$class = new ReflectionClass('Counter');

// Print out basic information
printf(
    "===> The %s%s%s %s '%s' [extends %s]\n" .
    "     declared in %s\n" .
    "     lines %d to %d\n" .
    "     having the modifiers %d [%s]\n",
        $class->isInternal() ? 'internal' : 'user-defined',
        $class->isAbstract() ? ' abstract' : '',
        $class->isFinal() ? ' final' : '',
        $class->isInterface() ? 'interface' : 'class',
        $class->getName(),
        var_export($class->getParentClass(), 1),
        $class->getFileName(),
        $class->getStartLine(),
        $class->getEndline(),
        $class->getModifiers(),
        implode(' ', Reflection::getModifierNames($class->getModifiers()))
);

// Print documentation comment
printf("---> Documentation:\n %s\n", var_export($class->getDocComment(), 1));

// Print which interfaces are implemented by this class
printf("---> Implements:\n %s\n", var_export($class->getInterfaces(), 1));

// Print class constants
printf("---> Constants: %s\n", var_export($class->getConstants(), 1));

// Print class properties
printf("---> Properties: %s\n", var_export($class->getProperties(), 1));

// Print class methods
printf("---> Methods: %s\n", var_export($class->getMethods(), 1));

// If this class is instantiable, create an instance
if ($class->isInstantiable()) {
    $counter = $class->newInstance();

    echo '---> $counter is instance? ';
    echo $class->isInstance($counter) ? 'yes' : 'no';

    echo "\n---> new Object() is instance? ";
    echo $class->isInstance(new Object()) ? 'yes' : 'no';
}
?>

Poznámka: The method newInstance() accepts a variable number of arguments which are passed to the function just as in call_user_func().

Poznámka: $class = new ReflectionClass('Foo'); $class->isInstance($arg) is equivalent to $arg instanceof Foo or is_a($arg, 'Foo').

ReflectionObject

The ReflectionObject class lets you reverse-engineer objects.

<?php
class ReflectionObject extends ReflectionClass
{
    final private __clone()
    public void __construct(mixed object)
    public string __toString()
    public static string export(mixed object, bool return)
}
?>

ReflectionMethod

The ReflectionMethod class lets you reverse-engineer class methods.

<?php
class ReflectionMethod extends ReflectionFunctionAbstract implements Reflector
{
    public void __construct(mixed class, string name)
    public string __toString()
    public static string export(mixed class, string name, bool return)
    public mixed invoke(stdclass object [, mixed args [, ...]])
    public mixed invokeArgs(stdclass object, array args)
    public bool isFinal()
    public bool isAbstract()
    public bool isPublic()
    public bool isPrivate()
    public bool isProtected()
    public bool isStatic()
    public bool isConstructor()
    public bool isDestructor()
    public int getModifiers()
    public ReflectionClass getDeclaringClass()

    // Inherited from ReflectionFunctionAbstract
    final private __clone()
    public string getName()
    public bool isInternal()
    public bool isUserDefined()
    public string getFileName()
    public int getStartLine()
    public int getEndLine()
    public string getDocComment()
    public array getStaticVariables()
    public bool returnsReference()
    public ReflectionParameter[] getParameters()
    public int getNumberOfParameters()
    public int getNumberOfRequiredParameters()
}
?>

To introspect a method, you will first have to create an instance of the ReflectionMethod class. You can then call any of the above methods on this instance.

Příklad 19.37. Using the ReflectionMethod class

<?php
class Counter
{
    private static $c = 0;

    /**
     * Increment counter
     *
     * @final
     * @static
     * @access  public
     * @return  int
     */
    final public static function increment()
    {
        return ++self::$c;
    }
}

// Create an instance of the ReflectionMethod class
$method = new ReflectionMethod('Counter', 'increment');

// Print out basic information
printf(
    "===> The %s%s%s%s%s%s%s method '%s' (which is %s)\n" .
    "     declared in %s\n" .
    "     lines %d to %d\n" .
    "     having the modifiers %d[%s]\n",
        $method->isInternal() ? 'internal' : 'user-defined',
        $method->isAbstract() ? ' abstract' : '',
        $method->isFinal() ? ' final' : '',
        $method->isPublic() ? ' public' : '',
        $method->isPrivate() ? ' private' : '',
        $method->isProtected() ? ' protected' : '',
        $method->isStatic() ? ' static' : '',
        $method->getName(),
        $method->isConstructor() ? 'the constructor' : 'a regular method',
        $method->getFileName(),
        $method->getStartLine(),
        $method->getEndline(),
        $method->getModifiers(),
        implode(' ', Reflection::getModifierNames($method->getModifiers()))
);

// Print documentation comment
printf("---> Documentation:\n %s\n", var_export($method->getDocComment(), 1));

// Print static variables if existant
if ($statics= $method->getStaticVariables()) {
    printf("---> Static variables: %s\n", var_export($statics, 1));
}

// Invoke the method
printf("---> Invokation results in: ");
var_dump($method->invoke(NULL));
?>

Poznámka: Trying to invoke private, protected or abstract methods will result in an exception being thrown from the invoke() method.

Poznámka: For static methods as seen above, you should pass NULL as the first argument to invoke(). For non-static methods, pass an instance of the class.

ReflectionProperty

The ReflectionProperty class lets you reverse-engineer class properties.

<?php
class ReflectionProperty implements Reflector
{
    final private __clone()
    public void __construct(mixed class, string name)
    public string __toString()
    public static string export(mixed class, string name, bool return)
    public string getName()
    public bool isPublic()
    public bool isPrivate()
    public bool isProtected()
    public bool isStatic()
    public bool isDefault()
    public int getModifiers()
    public mixed getValue(stdclass object)
    public void setValue(stdclass object, mixed value)
    public ReflectionClass getDeclaringClass()
    public string getDocComment()
}
?>

Poznámka: getDocComment() was added in PHP 5.1.0.

To introspect a property, you will first have to create an instance of the ReflectionProperty class. You can then call any of the above methods on this instance.

Příklad 19.38. Using the ReflectionProperty class

<?php
class String
{
    public $length  = 5;
}

// Create an instance of the ReflectionProperty class
$prop = new ReflectionProperty('String', 'length');

// Print out basic information
printf(
    "===> The%s%s%s%s property '%s' (which was %s)\n" .
    "     having the modifiers %s\n",
        $prop->isPublic() ? ' public' : '',
        $prop->isPrivate() ? ' private' : '',
        $prop->isProtected() ? ' protected' : '',
        $prop->isStatic() ? ' static' : '',
        $prop->getName(),
        $prop->isDefault() ? 'declared at compile-time' : 'created at run-time',
        var_export(Reflection::getModifierNames($prop->getModifiers()), 1)
);

// Create an instance of String
$obj= new String();

// Get current value
printf("---> Value is: ");
var_dump($prop->getValue($obj));

// Change value
$prop->setValue($obj, 10);
printf("---> Setting value to 10, new value is: ");
var_dump($prop->getValue($obj));

// Dump object
var_dump($obj);
?>

Poznámka: Trying to get or set private or protected class property's values will result in an exception being thrown.

ReflectionExtension

The ReflectionExtension class lets you reverse-engineer extensions. You can retrieve all loaded extensions at runtime using the get_loaded_extensions().

<?php
class ReflectionExtension implements Reflector {
    final private __clone()
    public void __construct(string name)
    public string __toString()
    public static string export(string name, bool return)
    public string getName()
    public string getVersion()
    public ReflectionFunction[] getFunctions()
    public array getConstants()
    public array getINIEntries()
    public ReflectionClass[] getClasses()
    public array getClassNames()
    public string info()
}
?>

To introspect an extension, you will first have to create an instance of the ReflectionExtension class. You can then call any of the above methods on this instance.

Příklad 19.39. Using the ReflectionExtension class

<?php
// Create an instance of the ReflectionProperty class
$ext = new ReflectionExtension('standard');

// Print out basic information
printf(
    "Name        : %s\n" .
    "Version     : %s\n" .
    "Functions   : [%d] %s\n" .
    "Constants   : [%d] %s\n" .
    "INI entries : [%d] %s\n" .
    "Classes     : [%d] %s\n",
        $ext->getName(),
        $ext->getVersion() ? $ext->getVersion() : 'NO_VERSION',
        sizeof($ext->getFunctions()),
        var_export($ext->getFunctions(), 1),

        sizeof($ext->getConstants()),
        var_export($ext->getConstants(), 1),

        sizeof($ext->getINIEntries()),
        var_export($ext->getINIEntries(), 1),

        sizeof($ext->getClassNames()),
        var_export($ext->getClassNames(), 1)
);
?>

Extending the reflection classes

In case you want to create specialized versions of the built-in classes (say, for creating colorized HTML when being exported, having easy-access member variables instead of methods or having utility methods), you may go ahead and extend them.

Příklad 19.40. Extending the built-in classes

<?php
/**
 * My Reflection_Method class
 */
class My_Reflection_Method extends ReflectionMethod
{
    public $visibility = array();

    public function __construct($o, $m)
    {
        parent::__construct($o, $m);
        $this->visibility = Reflection::getModifierNames($this->getModifiers());
    }
}

/**
 * Demo class #1
 *
 */
class T {
    protected function x() {}
}

/**
 * Demo class #2
 *
 */
class U extends T {
    function x() {}
}

// Print out information
var_dump(new My_Reflection_Method('U', 'x'));
?>

Poznámka: Caution: If you're overwriting the constructor, remember to call the parent's constructor _before_ any code you insert. Failing to do so will result in the following: Fatal error: Internal error: Failed to retrieve the reflection object

Předcházející | Nahoru | Další
Comparing objects | Domů | Type Hinting


Type Hinting

PHP 5 introduces Type Hinting. Functions are now able to force parameters to be objects (by specifying the name of the class in the function prototype) or arrays (since PHP 5.1).

Příklad 19.41. Type Hinting examples

<?php
// An example class
class MyClass
{
    /**
     * A test function
     *
     * First parameter must be an object of type OtherClass
     */
    public function test(OtherClass $otherclass) {
        echo $otherclass->var;
    }

    /**
     * Another test function
     *
     * First parameter must be an array
     */
    public function test_array(array $input_array) {
        print_r($input_array);
    }
}

// Another example class
class OtherClass {
    public $var = 'Hello World';
}
?>

Failing to satisfy the type hint results in a catchable fatal error.

<?php
// An instance of each class
$myclass = new MyClass;
$otherclass = new OtherClass;

// Fatal Error: Argument 1 must be an object of class OtherClass
$myclass->test('hello');

// Fatal Error: Argument 1 must be an instance of OtherClass
$foo = new stdClass;
$myclass->test($foo);

// Fatal Error: Argument 1 must not be null
$myclass->test(null);

// Works: Prints Hello World
$myclass->test($otherclass);

// Fatal Error: Argument 1 must be an array
$myclass->test_array('a string');

// Works: Prints the array
$myclass->test_array(array('a', 'b', 'c'));
?>

Type hinting also works with functions:

<?php
// An example class
class MyClass {
    public $var = 'Hello World';
}

/**
 * A test function
 *
 * First parameter must be an object of type MyClass
 */
function MyFunction (MyClass $foo) {
    echo $foo->var;
}

// Works
$myclass = new MyClass;
MyFunction($myclass);
?>

Type Hints can only be of the object and array (since PHP 5.1) type. Traditional type hinting with int and string isn't supported.

Předcházející | Nahoru | Další
Reflection | Domů | Late Static Bindings


Kapitola 22. Vysvětlení referencí (odkazů)

Obsah

Co jsou reference
Co reference dělají
Co reference nejsou
Předávání referencí (odkazem)
Vracení referencí
Odnastavení odkazů
Další výskyt referencí

Co jsou reference

Reference (odkazy) jsou prostředek, jak v PHP přistupovat k témuž obsahu proměnné pod různými jmény. Nejsou to ukazatele (pointery) jako v C, jsou to aliasy v tabulce symbolů. Uvědomte si, že v PHP je rozdíl mezi názvem proměnné a jejím obsahem, takže stejný obsah může mít různé názvy. Nejbližší analogií jsou názvy souborů a soubory v UNIXu - názvy proměnných jsou položky adresáře, obsahy proměnných samotné soubory. Na reference může být nazíráno jako na hardlinky v UNIXovém systému souborů.

Předcházející | Nahoru | Další
21. Exceptions | Domů | Co reference dělají


Co reference dělají

PHP reference umožňují zajistit, aby dvě proměnné odkazovaly na tentýž obsah. Tzn. když provedete:

$a =& $b
znamená to, že $a a $b ukazují na stejnou proměnnou.

Poznámka: $a a $b jsou zde úplně ekvivalentní, tj. nikoliv že $a ukazuje na $b apod., nýbrž že $a a $b ukazují na stejné místo.

Stejná syntaxe se může použít s funkcemi, které vrací reference a s operátorem new (v PHP 4.0.4 a pozdějších):

$bar =& new fooclass();
$foo =& find_var ($bar);

Poznámka: Nepoužití operátoru & způsobí zkopírování objektu. Když ve třídě použijete $this, bude se pracovat s aktuální instancí třídy. Přiřazení bez & zkopíruje instanci (např. objektu) a $this bude pracovat s touto kopií, což není vždy to, co se požaduje. Většinou chcete mít jedinou instanci, s níž budete pracovat, kvůli rychlosti a alokaci paměti.

Druhou věcí, kterou reference dělají, je předávání proměnných odkazem. To se dělá vytvořením lokální proměnné ve funkci a proměnné v kontextu volajícího prostředí, kdy se odkazuje na tentýž obsah. Například:

function foo (&$var)
{
    $var++;
}

$a=5;
foo ($a);
nastaví do $a hodnotu 6. To proto, že ve funkci foo proměnná $var odkazuje tentýž obsah jako $a. Viz detailnější vysvětlení o předávání odkazem.

Třetí věcí, kterou mohou reference dělat, je vracení přes reference.

Předcházející | Nahoru | Další
22. Vysvětlení referencí (odkazů) | Domů | Co reference nejsou


Co reference nejsou

Jak již bylo řečeno, reference nejsou ukazatele. To znamená, že tento příkaz nebude dělat to, co očekáváte:

function foo (&$var)
{
    $var =& $GLOBALS["baz"];
}
foo($bar);

Nastane to, že $var ve funkci foo bude přiřazena $bar ve volajícím kontextu, avšak poté bude přiřazena $GLOBALS["baz"]. Není způsob, jak přiřadit $bar ve volajícím kontextu něčemu jinému za použití mechanismu referencí, protože $bar není ve funkci foo dostupná (je reprezentována $var, ale $var má pouze obsah a nikoli spojení názvu s hodnotou v tabulce symbolů).

Předcházející | Nahoru | Další
Co reference dělají | Domů | Předávání referencí (odkazem)


Předávání referencí (odkazem)

Můžete předávat proměnnou do funkce pomocí odkazu, takže funkce může modifikovat její argumenty. Syntaxe je následující:

function foo (&$var)
{
    $var++;
}

$a=5;
foo ($a);
// $a je teď 6
Všimněte si, že ve volání funkce není znak reference - pouze v její definici. Samotná definice funkce stačí na správné předávání argumentu odkazem.

Následující věci lze předávat referencí:

  • Proměnná, např. foo($a)
  • Konstrukt s new, např. foo(new foobar())

  • Reference, vracená z funkce, např.:

    function &bar()
    {
        $a = 5;
        return $a;
    }
    foo(bar());

    Viz také vysvětlení vracení přes reference.

Žádné jiné výrazy nemohou být předávány odkazem, výsledek tohoto není definován. Například, následující ukázky předávání odkazem jsou neplatné:

function bar() // Všimněte si chybějícího &
{
    $a = 5;
    return $a;
}
foo(bar());

foo($a = 5) // Výraz, nikoli proměnná
foo(5) // Konstanta, nikoli proměnná
Tyto požadavky platí pro PHP 4.0.4 a pozdější.

Předcházející | Nahoru | Další
Co reference nejsou | Domů | Vracení referencí


Vracení referencí

Vracení odkazem je užitečné, když chcete použít funkci k nalezení proměnné, která by měla být odkazu přiřazena. Při vracení referencí použijte tuto syntaxi:

function &find_var ($param)
{
    ...nějaký kód...
    return $found_var;
}

$foo =& find_var ($bar);
$foo->x = 2;
V tomto příkladu by bylo funkcí find_var nastaveno vlastnictví téhož objektu, nikoli jeho kopie, jak by se stalo bez použití syntaxe bez odkazů.

Poznámka: Narozdíl od předávání parametru, zde musíte & použít na obou místech - k indikaci, že vracíte odkaz a nikoli kopii jako obvykle, a k indikaci přiřazení reference do $foo namísto běžného přiřazení (hodnoty).

Předcházející | Nahoru | Další
Předávání referencí (odkazem) | Domů | Odnastavení odkazů


Odnastavení odkazů

Když odnastavíte referenci, přerušíte vazbu mezi názvem proměnné a jejím obsahem. To neznamená, že by obsah byl zničen. Například:

$a = 1;
$b =& $a;
unset ($a);
neodnastaví $b, nýbrž pouze $a.

Znovu je dobré si připomenout analogii s UNIXovým příkazem unlink.

Předcházející | Nahoru | Další
Vracení referencí | Domů | Další výskyt referencí


Další výskyt referencí

Mnoho jazykových konstruktů v PHP je implementováno přes odkazový mechanismus, takže vše, co bylo řečeno výše o přiřazování referencí, platí i na tyto konstrukty. Některé konstrukty, jako předávání a vracení přes odkazy, byly již zmíněny. Ostatní konstrukty používající reference jsou:

odkazy global

Když deklarujete proměnnou jako global $var, ve skutečnosti vytváříte odkaz na globální proměnnou. Tzn. je to totéž, jako:

$var =& $GLOBALS["var"];

To znamená, například, že odnastavení $var neodnastaví globální proměnnou.

$this

V metodě objektu je $this vždy odkazem na volající objekt.

Předcházející | Nahoru | Další
Odnastavení odkazů | Domů | IV. Bezpečnost


Část IV. Bezpečnost

Obsah

23. Úvod
24. Obecné úvahy
25. Installed as CGI binary
26. Instalace jako modul do Apache
27. Bezpečnost souborových systémů
28. Database Security
29. Hlášení chyb
30. Using Register Globals
31. User Submitted Data
32. Magic Quotes
33. Skrývání PHP
34. Aktualizace systému
Předcházející | Nahoru | Další
Další výskyt referencí | Domů | 23. Úvod


Kapitola 23. Úvod

PHP je silný mocný jazyk, a je interpret, ať již je v podobě modulu součástí webového serveru nebo se spouští jako samostatný CGI program, je schopen přistupovat k souborům, spouštět příkazy a otvírat síťová spojení na server. Tyto vlastnosti činí vše, co se na webovém serveru spouští, ve výchozím stavu nebezpečným. PHP je navrženo specificky, aby bylo bezpečnějším jazykem pro psaní CGI programů než Perl nebo C, a se správným výběrem kompilačních a provozních nastavení, a vhodnými praktikami psaní kódu, může poskytnout přesně takovou kombinaci svobody a bezpečnosti, jakou potřebujete.

Protože je mnoho různých způsobů využití PHP, je také mnoho konfiguračních voleb ovlivňujících jeho chování. Velký výběr voleb zaručuje, že můžete používat PHP pro mnoho účelů, ale také znamená, že existují kombinace těchto voleb a serverových konfigurací, které vedou k nebezpečnému nastavení.

Konfigurační flexibilita PHP je rovnocenným soupeřem flexibility psaní kódu. PHP lze použít k sestavení kompletních serverových aplikací s plnou silou standardního (shellového) uživatele, anebo pro jednoduché vložené kusy kódu s malým rizikem v přísně řízeném prostředí. Jak bude takové prostředí vystavěno, a jak bude bezpečné, záleží z většiny na samotném vývojáři.

Tato kapitola začíná obecným poučením o bezpečnosti, vysvětluje různé kombinace konfiguračních voleb a situací, ve kterých je lze bezpečně použít, a popisuje rozličné aspekty psaní kódu pro různé úrovně bezpečnosti.

Předcházející | Nahoru | Další
IV. Bezpečnost | Domů | 24. Obecné úvahy


Kapitola 24. Obecné úvahy

Úplně bezpečný systém je fikce, proto je přiblížením často používaným v oboru bezpečnosti vyvážení rizika a použitelnosti. Pokud by každá proměnná zasílaná uživatelem vyžadovala dvě formy biometrické validace (jako třeba sken oční sítnice a otisk prstu), měli byste systém s extrémně vysokou mírou odpovědnosti. Ale vyplnit i jen trochu složitější formulář by trvalo půl hodiny, proto by to vedlo k tomu, že by se uživatelé snažili hledat cesty, jak zabezpečení obejít.

Nejlepší zabezpečení je často dostatečně nenápadné, aby i když splňuje požadavky, nebránilo uživatelům v práci ani nezatěžovalo autora kódu nadměrnou složitostí. Skutečně, mnohé bezpečnostní útoky jsou pouhým prolomením příliš velkého zabezpečení, které má tendenci se časem rozpadat.

Fráze hodná zapamatování: Systém je jen tak dobrý, jako nejslabší článek řetězu. Jsou-li všechny transakce intenzivně zaznamenáványn včetně času, místa, druhu transakce apod., avšak uživatel je ověřován pouze na základě obyčejné cookie, platnost vazby uživatelů na transakční záznam je podstatně oslabena.

Při testování mějte na paměti, že ani pro nejjednodušší stránky nemůžete vyzkoušet všechny možnosti. Vstupní data, která můžete očekávat, nemají absolutně nic společného s těmi, která zadá nespokojení zaměstnanec, cracker s měsíci času k dispozici nebo kočka domácí pochodující přes klávesnici. To je důvod, proč se dívat na kód z logické perspektivy, abyste zjistili, kde mohou vstoupit neočekávaná data, a jak je jejich efekt následně měněn, redukován nebo zesilován.

Internet je plný lidí, kteří se snaží udělat si jméno tím, že budou prolamovat váš kód, shazovat váš server, posílat neodpovídající data nebo vám jinak zpříjemňovat den. Nezáleží na tom, zda máte malý nebo velký server, jste cílem prostě už jen proto, že jste online, že máte server, ke kterému se lze připojit. Mnoho crackerských programů nerozlišuje podle velikosti, prostě procházejí obrovské bloky IP adres a hledají oběti. Snažte se nestát se jednou z nich.

Předcházející | Nahoru | Další
23. Úvod | Domů | 25. Installed as CGI binary


Kapitola 25. Installed as CGI binary

Obsah

Possible attacks
Case 1: only public files served
Case 2: using --enable-force-cgi-redirect
Case 3: setting doc_root or user_dir
Case 4: PHP parser outside of web tree

Possible attacks

Using PHP as a CGI binary is an option for setups that for some reason do not wish to integrate PHP as a module into server software (like Apache), or will use PHP with different kinds of CGI wrappers to create safe chroot and setuid environments for scripts. This setup usually involves installing executable PHP binary to the web server cgi-bin directory. CERT advisory » CA-96.11 recommends against placing any interpreters into cgi-bin. Even if the PHP binary can be used as a standalone interpreter, PHP is designed to prevent the attacks this setup makes possible:

  • Accessing system files: http://my.host/cgi-bin/php?/etc/passwd

    The query information in a URL after the question mark (?) is passed as command line arguments to the interpreter by the CGI interface. Usually interpreters open and execute the file specified as the first argument on the command line.

    When invoked as a CGI binary, PHP refuses to interpret the command line arguments.

  • Accessing any web document on server: http://my.host/cgi-bin/php/secret/doc.html

    The path information part of the URL after the PHP binary name, /secret/doc.html is conventionally used to specify the name of the file to be opened and interpreted by the CGI program. Usually some web server configuration directives (Apache: Action) are used to redirect requests to documents like http://my.host/secret/script.php to the PHP interpreter. With this setup, the web server first checks the access permissions to the directory /secret, and after that creates the redirected request http://my.host/cgi-bin/php/secret/script.php. Unfortunately, if the request is originally given in this form, no access checks are made by web server for file /secret/script.php, but only for the /cgi-bin/php file. This way any user able to access /cgi-bin/php is able to access any protected document on the web server.

    In PHP, compile-time configuration option --enable-force-cgi-redirect and runtime configuration directives doc_root and user_dir can be used to prevent this attack, if the server document tree has any directories with access restrictions. See below for full the explanation of the different combinations.

Předcházející | Nahoru | Další
24. Obecné úvahy | Domů | Case 1: only public files served


Case 1: only public files served

If your server does not have any content that is not restricted by password or ip based access control, there is no need for these configuration options. If your web server does not allow you to do redirects, or the server does not have a way to communicate to the PHP binary that the request is a safely redirected request, you can specify the option --enable-force-cgi-redirect to the configure script. You still have to make sure your PHP scripts do not rely on one or another way of calling the script, neither by directly http://my.host/cgi-bin/php/dir/script.php nor by redirection http://my.host/dir/script.php.

Redirection can be configured in Apache by using AddHandler and Action directives (see below).

Předcházející | Nahoru | Další
25. Installed as CGI binary | Domů | Case 2: using --enable-force-cgi-redirect


Case 2: using --enable-force-cgi-redirect

This compile-time option prevents anyone from calling PHP directly with a URL like http://my.host/cgi-bin/php/secretdir/script.php. Instead, PHP will only parse in this mode if it has gone through a web server redirect rule.

Usually the redirection in the Apache configuration is done with the following directives:

Action php-script /cgi-bin/php
AddHandler php-script .php

This option has only been tested with the Apache web server, and relies on Apache to set the non-standard CGI environment variable REDIRECT_STATUS on redirected requests. If your web server does not support any way of telling if the request is direct or redirected, you cannot use this option and you must use one of the other ways of running the CGI version documented here.

Předcházející | Nahoru | Další
Case 1: only public files served | Domů | Case 3: setting doc_root or user_dir


Case 3: setting doc_root or user_dir

To include active content, like scripts and executables, in the web server document directories is sometimes considered an insecure practice. If, because of some configuration mistake, the scripts are not executed but displayed as regular HTML documents, this may result in leakage of intellectual property or security information like passwords. Therefore many sysadmins will prefer setting up another directory structure for scripts that are accessible only through the PHP CGI, and therefore always interpreted and not displayed as such.

Also if the method for making sure the requests are not redirected, as described in the previous section, is not available, it is necessary to set up a script doc_root that is different from web document root.

You can set the PHP script document root by the configuration directive doc_root in the configuration file, or you can set the environment variable PHP_DOCUMENT_ROOT. If it is set, the CGI version of PHP will always construct the file name to open with this doc_root and the path information in the request, so you can be sure no script is executed outside this directory (except for user_dir below).

Another option usable here is user_dir. When user_dir is unset, only thing controlling the opened file name is doc_root. Opening a URL like http://my.host/~user/doc.php does not result in opening a file under users home directory, but a file called ~user/doc.php under doc_root (yes, a directory name starting with a tilde [~]).

If user_dir is set to for example public_php, a request like http://my.host/~user/doc.php will open a file called doc.php under the directory named public_php under the home directory of the user. If the home of the user is /home/user, the file executed is /home/user/public_php/doc.php.

user_dir expansion happens regardless of the doc_root setting, so you can control the document root and user directory access separately.

Předcházející | Nahoru | Další
Case 2: using --enable-force-cgi-redirect | Domů | Case 4: PHP parser outside of web tree


Case 4: PHP parser outside of web tree

A very secure option is to put the PHP parser binary somewhere outside of the web tree of files. In /usr/local/bin, for example. The only real downside to this option is that you will now have to put a line similar to:

#!/usr/local/bin/php
as the first line of any file containing PHP tags. You will also need to make the file executable. That is, treat it exactly as you would treat any other CGI script written in Perl or sh or any other common scripting language which uses the #! shell-escape mechanism for launching itself.

To get PHP to handle PATH_INFO and PATH_TRANSLATED information correctly with this setup, the PHP parser should be compiled with the --enable-discard-path configure option.

Předcházející | Nahoru | Další
Case 3: setting doc_root or user_dir | Domů | 26. Instalace jako modul do Apache


Kapitola 26. Instalace jako modul do Apache

Je-li PHP nainstalováno jako modul do Apache, dědí práva uživatele, pod nímž Apache běží (typicky uživatele "nobody"). To má řadu dopadů na bezpečnost a autorizaci. Pokud například používáte PHP pro přístup k databázi, pokud tato nemá vlastní řízení přístupu, budete ji muset zpřístupnit uživateli "nobody". To znamená, že by škodlivý skript mohl přistupovat k databázi a měnit ji, a to i bez uživatelského jména a hesla. Je úplně klidně možné, že webový spider narazí na stránku databázového administrátora a zruší všechny vaše databáze. Můžete se proti tomu bránit autorizací prostředky Apache nebo navrhnout vlastní přístupový model za použití LDAP, souborů .htaccess atd. a vložit takový kód do svých PHP skriptů.

Často, když se zabezpečení provede v bodě, kde přístup uživatele PHP (v tomto případě uživatele Apache) nese jen velice malé riziko, se zjišťuje, že PHP najednou nemůže zapisovat do žádných souborů v uživatelských adresářích. Nebo mu je zabráněno přistupovat k databázím a měnit je. Rovná se to zabezpečení proti zápisu do dobrých i špatných souborů, nebo provádění dobrých i špatných databázových transakcí.

Častou chybou dělanou v tomto bodě je poskytnout serveru Apache rootovská práva nebo nějak jinak zvýšit jeho schopnosti.

Zvýšení práv uživatele, pod nímž běží Apache, na roota je extrémně nebezpečné a může zkompromitovat celý systém. Proto o příkazech jako sudo, chroot nebo něco jiného běžícího jako root, by neměl uvažovat nikdo, kdo není profesionál v oblasti bezpečnosti.

Existují jednodušší řešení. Pomocí open_basedir můžete určovat, které adresáře bude možno používat v PHP. Můžete též nastavit oblasti jen pro Apache, aby byly veškeré webové aktivity omezeny na soubory, které nejsou ani systémové, ani uživatelské.

Předcházející | Nahoru | Další
Case 4: PHP parser outside of web tree | Domů | 27. Bezpečnost souborových systémů


Kapitola 27. Bezpečnost souborových systémů

PHP pracuje se zabezpečením zabudovaným do většiny serverových systémů, které je založeno na oprávněních k souborům a adresářům. To vám umožňuje ovládat, které soubory v souborovém systému se smí číst. Pozornost je potřeba věnovat jakýmkoli souborům, které jsou čitelné všem uživatelům, kvůli tomu, zda je skutečně bezpečné, aby je směli číst všichni uživatelé, kteří mají k tomuto systému přístup.

Jelikož je PHP navrženo tak, aby umožňovalo přístup k filesystému na úrovni uživatele, je vcelku možné napsat PHP skript, který vám umožní číst systémové soubory, jako např. /etc/passwd, měnit konfiguraci ethernetu, posílat na tiskárnu obrovské tiskové úlohy apod. To má jasné důsledky v tom, že se musíte vždy ujistit, že soubory, které chcete číst nebo zapisovat, jsou skutečně ty správné.

Uvažujme následující skript, kde uživatel říká, že by chtěl smazat soubor ve svém domovském adresáři. To předpokládá situaci, kde se pro normální správu souborů používá webové rozhraní implementované pomocí PHP, a uživatel, pod nímž běží Apache, má právo mazat soubory v domovských adresářích uživatelů.

Příklad 27.1. Slabá kontrola proměnných vede k....

<?php
// odstraň soubor z domovského adresáře uživatele
$username = $_POST['user_submitted_name'];
$homedir = "/home/$username";
$file_to_delete = "$userfile";
unlink ("$homedir/$userfile");
echo "$file_to_delete byl smazán!";
?>

Jelikož se uživatelské jméno posílá z formuláře, může kdokoli poslat uživatelské jméno a soubor patřící někomu jinému a mazat cizí soubory. V takovém případě byste měli chtít používat nějakou formu autentizace. Uvažte, co by se mohlo stát, kdyby poslané proměnné obsahovaly "../etc/" a "passwd". Kód by pak mohl bez problémů číst:

Příklad 27.2. ...útoku na souborový systém

<?php
// Odstraní soubor odkudkoli na pevném disku, kam má uživatel PHP přístup.
// Má-li PHP rootovská práva:
$username = "../etc/";
$homedir = "/home/../etc/";
$file_to_delete = "passwd";
unlink ("/home/../etc/passwd");
echo "/home/../etc/passwd byl smazán!";
?>

Existují dvě důležité roviny, ve kterých byste se měli těmto problémům bránit.
  • Povolit programu PHP pouze omezená oprávnění.
  • Kontrolovat všechny zasílané proměnné.
Zde je vylepšený skript:

Příklad 27.3. Bezpečnější kontrola názvu souboru

<?php
// Odstraní soubor z pevného disku, kam má uživatel PHP přístup.
$username = $_SERVER['REMOTE_USER']; // použití autentizačního mechanismu

$homedir = "/home/$username";

$file_to_delete = basename("$userfile"); // odřízni cestu
unlink ($homedir/$file_to_delete);

$fp = fopen("/home/logging/filedelete.log","+a"); // zaznamenej smazání
$logstring = "$username $homedir $file_to_delete";
fwrite ($fp, $logstring);
fclose($fp);

echo "$file_to_delete byl smazán!";
?>

Ovšem ani toto není zcela neprůstřelné. Pokud by váš autentizační systém povoloval uživatelům vytvářet si vlastní uživatelská jména, a uživatel by si vybral "../etc/", systém by byl opět ohrožen. Z tohoto důvodu byste měli preferovat lépe přizpůsobenou kontrolu:

Příklad 27.4. Bezpečnější kontrola názvu souboru

<?php
$username = $_SERVER['REMOTE_USER']; // použití autentizačního mechanismu
$homedir = "/home/$username";

if (!ereg('^[^./][^/]*$', $userfile))
     die('bad filename'); // skonči, nezpracovávej

if (!ereg('^[^./][^/]*$', $username))
     die('bad username'); // skonči, nezpracovávej
// atd...
?>

V závislosti na operačním systému existuje celá široká škála souborů, o které bychom se měli zajímat, včetně souborů zařízení (/dev/ nebo COM1), konfiguračních souborů (soubory /etc/ a .ini), známé oblasti ukládání souborů (/home/, Dokumenty) atd. Proto je obvykle lepší ustanovit politiku, kde je zakázáno všechno kromě toho, co explicitně povolíte.

Předcházející | Nahoru | Další
26. Instalace jako modul do Apache | Domů | 28. Database Security


Kapitola 28. Database Security

Obsah

Designing Databases
Connecting to Database
Encrypted Storage Model
SQL Injection

Nowadays, databases are cardinal components of any web based application by enabling websites to provide varying dynamic content. Since very sensitive or secret information can be stored in a database, you should strongly consider protecting your databases.

To retrieve or to store any information you need to connect to the database, send a legitimate query, fetch the result, and close the connection. Nowadays, the commonly used query language in this interaction is the Structured Query Language (SQL). See how an attacker can tamper with an SQL query.

As you can surmise, PHP cannot protect your database by itself. The following sections aim to be an introduction into the very basics of how to access and manipulate databases within PHP scripts.

Keep in mind this simple rule: defense in depth. The more places you take action to increase the protection of your database, the less probability of an attacker succeeding in exposing or abusing any stored information. Good design of the database schema and the application deals with your greatest fears.

Designing Databases

The first step is always to create the database, unless you want to use one from a third party. When a database is created, it is assigned to an owner, who executed the creation statement. Usually, only the owner (or a superuser) can do anything with the objects in that database, and in order to allow other users to use it, privileges must be granted.

Applications should never connect to the database as its owner or a superuser, because these users can execute any query at will, for example, modifying the schema (e.g. dropping tables) or deleting its entire content.

You may create different database users for every aspect of your application with very limited rights to database objects. The most required privileges should be granted only, and avoid that the same user can interact with the database in different use cases. This means that if intruders gain access to your database using your applications credentials, they can only effect as many changes as your application can.

You are encouraged not to implement all the business logic in the web application (i.e. your script), instead do it in the database schema using views, triggers or rules. If the system evolves, new ports will be intended to open to the database, and you have to re-implement the logic in each separate database client. Over and above, triggers can be used to transparently and automatically handle fields, which often provides insight when debugging problems with your application or tracing back transactions.

Předcházející | Nahoru | Další
27. Bezpečnost souborových systémů | Domů | Connecting to Database


Connecting to Database

You may want to establish the connections over SSL to encrypt client/server communications for increased security, or you can use ssh to encrypt the network connection between clients and the database server. If either of these is used, then monitoring your traffic and gaining information about your database will be difficult for a would-be attacker.

Předcházející | Nahoru | Další
28. Database Security | Domů | Encrypted Storage Model


Encrypted Storage Model

SSL/SSH protects data travelling from the client to the server, SSL/SSH does not protect the persistent data stored in a database. SSL is an on-the-wire protocol.

Once an attacker gains access to your database directly (bypassing the webserver), the stored sensitive data may be exposed or misused, unless the information is protected by the database itself. Encrypting the data is a good way to mitigate this threat, but very few databases offer this type of data encryption.

The easiest way to work around this problem is to first create your own encryption package, and then use it from within your PHP scripts. PHP can assist you in this with several extensions, such as Mcrypt and Mhash, covering a wide variety of encryption algorithms. The script encrypts the data before inserting it into the database, and decrypts it when retrieving. See the references for further examples of how encryption works.

In case of truly hidden data, if its raw representation is not needed (i.e. not be displayed), hashing may also be taken into consideration. The well-known example for the hashing is storing the MD5 hash of a password in a database, instead of the password itself. See also crypt() and md5().

Příklad 28.1. Using hashed password field

<?php

// storing password hash
$query  = sprintf("INSERT INTO users(name,pwd) VALUES('%s','%s');",
            pg_escape_string($username), md5($password));
$result = pg_query($connection, $query);

// querying if user submitted the right password
$query = sprintf("SELECT 1 FROM users WHERE name='%s' AND pwd='%s';",
            pg_escape_string($username), md5($password));
$result = pg_query($connection, $query);

if (pg_num_rows($result) > 0) {
    echo 'Welcome, $username!';
} else {
    echo 'Authentication failed for $username.';
}

?>

Předcházející | Nahoru | Další
Connecting to Database | Domů | SQL Injection


SQL Injection

Many web developers are unaware of how SQL queries can be tampered with, and assume that an SQL query is a trusted command. It means that SQL queries are able to circumvent access controls, thereby bypassing standard authentication and authorization checks, and sometimes SQL queries even may allow access to host operating system level commands.

Direct SQL Command Injection is a technique where an attacker creates or alters existing SQL commands to expose hidden data, or to override valuable ones, or even to execute dangerous system level commands on the database host. This is accomplished by the application taking user input and combining it with static parameters to build a SQL query. The following examples are based on true stories, unfortunately.

Owing to the lack of input validation and connecting to the database on behalf of a superuser or the one who can create users, the attacker may create a superuser in your database.

Příklad 28.2. Splitting the result set into pages ... and making superusers (PostgreSQL)

<?php

$offset = $argv[0]; // beware, no input validation!
$query  = "SELECT id, name FROM products ORDER BY name LIMIT 20 OFFSET $offset;";
$result = pg_query($conn, $query);

?>

Normal users click on the 'next', 'prev' links where the $offset is encoded into the URL. The script expects that the incoming $offset is a decimal number. However, what if someone tries to break in by appending a urlencode()'d form of the following to the URL

0;
insert into pg_shadow(usename,usesysid,usesuper,usecatupd,passwd)
    select 'crack', usesysid, 't','t','crack'
    from pg_shadow where usename='postgres';
--
If it happened, then the script would present a superuser access to him. Note that 0; is to supply a valid offset to the original query and to terminate it.

Poznámka: It is common technique to force the SQL parser to ignore the rest of the query written by the developer with -- which is the comment sign in SQL.

A feasible way to gain passwords is to circumvent your search result pages. The only thing the attacker needs to do is to see if there are any submitted variables used in SQL statements which are not handled properly. These filters can be set commonly in a preceding form to customize WHERE, ORDER BY, LIMIT and OFFSET clauses in SELECT statements. If your database supports the UNION construct, the attacker may try to append an entire query to the original one to list passwords from an arbitrary table. Using encrypted password fields is strongly encouraged.

Příklad 28.3. Listing out articles ... and some passwords (any database server)

<?php

$query  = "SELECT id, name, inserted, size FROM products
                  WHERE size = '$size'
                  ORDER BY $order LIMIT $limit, $offset;";
$result = odbc_exec($conn, $query);

?>

The static part of the query can be combined with another SELECT statement which reveals all passwords:

'
union select '1', concat(uname||'-'||passwd) as name, '1971-01-01', '0' from usertable;
--
If this query (playing with the ' and --) were assigned to one of the variables used in $query, the query beast awakened.

SQL UPDATE's are also susceptible to attack. These queries are also threatened by chopping and appending an entirely new query to it. But the attacker might fiddle with the SET clause. In this case some schema information must be possessed to manipulate the query successfully. This can be acquired by examining the form variable names, or just simply brute forcing. There are not so many naming conventions for fields storing passwords or usernames.

Příklad 28.4. From resetting a password ... to gaining more privileges (any database server)

<?php
$query = "UPDATE usertable SET pwd='$pwd' WHERE uid='$uid';";
?>

But a malicious user sumbits the value ' or uid like'%admin%'; -- to $uid to change the admin's password, or simply sets $pwd to "hehehe', admin='yes', trusted=100 " (with a trailing space) to gain more privileges. Then, the query will be twisted:
<?php

// $uid == ' or uid like'%admin%'; --
$query = "UPDATE usertable SET pwd='...' WHERE uid='' or uid like '%admin%'; --";

// $pwd == "hehehe', admin='yes', trusted=100 "
$query = "UPDATE usertable SET pwd='hehehe', admin='yes', trusted=100 WHERE
...;";

?>

A frightening example how operating system level commands can be accessed on some database hosts.

Příklad 28.5. Attacking the database hosts operating system (MSSQL Server)

<?php

$query  = "SELECT * FROM products WHERE id LIKE '%$prod%'";
$result = mssql_query($query);

?>

If attacker submits the value a%' exec master..xp_cmdshell 'net user test testpass /ADD' -- to $prod, then the $query will be:
<?php

$query  = "SELECT * FROM products
                    WHERE id LIKE '%a%'
                    exec master..xp_cmdshell 'net user test testpass /ADD'--";
$result = mssql_query($query);

?>
MSSQL Server executes the SQL statements in the batch including a command to add a new user to the local accounts database. If this application were running as sa and the MSSQLSERVER service is running with sufficient privileges, the attacker would now have an account with which to access this machine.

Poznámka: Some of the examples above is tied to a specific database server. This does not mean that a similar attack is impossible against other products. Your database server may be similarly vulnerable in another manner.

Avoiding techniques

You may plead that the attacker must possess a piece of information about the database schema in most examples. You are right, but you never know when and how it can be taken out, and if it happens, your database may be exposed. If you are using an open source, or publicly available database handling package, which may belong to a content management system or forum, the intruders easily produce a copy of a piece of your code. It may be also a security risk if it is a poorly designed one.

These attacks are mainly based on exploiting the code not being written with security in mind. Never trust any kind of input, especially that which comes from the client side, even though it comes from a select box, a hidden input field or a cookie. The first example shows that such a blameless query can cause disasters.

  • Never connect to the database as a superuser or as the database owner. Use always customized users with very limited privileges.
  • Check if the given input has the expected data type. PHP has a wide range of input validating functions, from the simplest ones found in Variable Functions and in Character Type Functions (e.g. is_numeric(), ctype_digit() respectively) and onwards to the Perl compatible Regular Expressions support.

  • If the application waits for numerical input, consider verifying data with is_numeric(), or silently change its type using settype(), or use its numeric representation by sprintf().

    Příklad 28.6. A more secure way to compose a query for paging

    <?php

    settype    ($offset, 'integer');
    $query = "SELECT id, name FROM products ORDER BY name LIMIT 20 OFFSET $offset;";

    // please note %d in the format string, using %s would be meaningless
    $query = sprintf("SELECT id, name FROM products ORDER BY name LIMIT 20 OFFSET %d;",
                         $offset);

    ?>

  • Quote each non numeric user supplied value that is passed to the database with the database-specific string escape function (e.g. mysql_escape_string(), sql_escape_string(), etc.). If a database-specific string escape mechanism is not available, the addslashes() and str_replace() functions may be useful (depending on database type). See the first example. As the example shows, adding quotes to the static part of the query is not enough, making this query easily crackable.
  • Do not print out any database specific information, especially about the schema, by fair means or foul. See also Error Reporting and Error Handling and Logging Functions.
  • You may use stored procedures and previously defined cursors to abstract data access so that users do not directly access tables or views, but this solution has another impacts.

Besides these, you benefit from logging queries either within your script or by the database itself, if it supports logging. Obviously, the logging is unable to prevent any harmful attempt, but it can be helpful to trace back which application has been circumvented. The log is not useful by itself, but through the information it contains. More detail is generally better than less.

Předcházející | Nahoru | Další
Encrypted Storage Model | Domů | 29. Hlášení chyb


Kapitola 29. Hlášení chyb

U bezpečnosti PHP existují dvě stránky hlášení chyb. Jedna je prospěšná pro zvýšení bezpečnosti, druhá je naopak škodlivá.

Standardní taktika útoku zahrnuje zkoumání systému posílání špatných dat a kontrolu, jaké druhy chyb a v jakém kontextu systém vrací. To crackerovi umožňuje získávat informace o serveru s cílem určit jeho možné slabiny. Pokud útočník například posbíral informace o stránce na základě odeslaného formuláře, může se pokusit předefinovat nebo změnit hodnoty proměnných:

Příklad 29.1. Útok na proměnné pomocí vlastní HTML stránky

<form method="post" action="attacktarget?username=badfoo&amp;password=badfoo">
<input type="hidden" name="username" value="badfoo" />
<input type="hidden" name="password" value="badfoo" />
</form>

Chyby PHP, které se normálně vrací, mohou být užitečné vývojáři, který se snaží odladit skript, protože indikují takové věci, jako funkci nebo soubor, kde se chyba objevila. To vše jsou informace, které mohou být zneužity. Nebývá řídkým případem, že vývojář PHP používá show_source(), highlight_string() nebo highlight_file() jako ladicí nástroje, ale na provozním serveru lze takto odhalit skryté proměnné, nevhodnou syntaxi nebo jiné nebezpečné informace. Zvláště nebezpečné je spouštět kód ze známých zdrojů se zabudovanými ladicími handlery nebo s použitím běžných ladicích technik. Jestliže může útočník zjistit, jaká obecná technika se používá, může zkusit útok na stránku hrubou silou, posíláním různých běžných ladicích řetězců:

Příklad 29.2. Útok pomocí běžných ladicích řetězců

<form method="post" action="attacktarget?errors=Y&amp;showerrors=1&amp;debug=1">
<input type="hidden" name="errors" value="Y" />
<input type="hidden" name="showerrors" value="1" />
<input type="hidden" name="debug" value="1" />
</form>

Bez ohledu na metodu obsluhy chyb, schopnost zkoumat systém z hlediska chyb vede k tomu, že se útočníkovi poskytuje více informací.

Například už obecný styl chyb PHP signalizuje, že na systému běží PHP. Pokud by si útočník prohlížel .html stránku a chtěl prověřit back-end (s cílem najít známé slabiny v systému), posláním špatných dat může být schopen zjistit, že systém využívá PHP.

Chyba funkce může indikovat, zda by systém mohl běžet na určitém databázovém stroji, nebo poskytnout vodítka k tomu, jak je stránka naprogramována nebo navržena. To pak umožňuje hlubší pátrání v otevřených databázových portech nebo hledání konkrétních chyb nebo slabin ve stránce. Posíláním různých kusů špatných dat, například, může útočník zjistit pořadí autentizace ve skriptu (podle čísel řádků, kde nastaly chyby), stejně jako zkoumání děr na různých místech ve skriptu, které by mohly být využity k průniku.

Chyba souborového systému nebo obecná chyba PHP může indikovat, jaká oprávnění webový server má, a stejně tak i jaká je struktura a organizace souborů na serveru. Chybový kód napsaný vývojářem může tento problém ještě zhoršit a usnadnit odhalení dříve "skrytých" informací.

Existují tři velká řešení tohoto problému. První je pečlivě zkoumat všechny funkce a pokoušet se kompenzovat většinu chyb. Druhé je vypnout hlášení chyb pro veškerý běžící kód. A konečně třetí pak použít vlastní PHP funkce pro obsluhu chyb, a řešit tedy chyby vlastní cestou. V závislosti na bezpečnostní politice mohou být ve vaší situaci použitelné všechny tři cesty.

Jednou z cest, jak předem předejít zmíněmému problému, je nasadit vlastní mechanismus PHP error_reporting(), který vám pomůže zabezpečit váš kód a odhalit taková použití proměnných, která mohou být nebezpečná. Testováním kódu s E_ALL, před jeho nasazením do provozu, můžete rychle najít oblasti, kde mohou být vaše proměnné k dispozici pro "otrávení" nebo změny jinými cestami. V okamžiku, kdy jste připraveni pro ostré nasazení, byste však měli úplně vypnout hlášení chyb nastavením error_reporting() na 0 nebo vypnutím zobrazování chyb pomocí volby display_errors v souboru php.ini, aby byl kód uchráněn před zkoumáním. Zvolíte-li druhou možnost, měli byste také definovat cestu k logovacím souboru pomocí konfigurační direktivy error_log a zapnout volbu log_errors.

Příklad 29.3. Nalezení nebezpečných proměnných pomocí E_ALL

<?php
if ($username) {  // Bez inicializace nebo kontroly před použitím
    $good_login = 1;
}

// Pokud výše uvedený test selže, není inicializováno ani kontrolováno
if ($good_login == 1) {
    readfile ("/highly/sensitive/data/index.html");
}
?>

Předcházející | Nahoru | Další
SQL Injection | Domů | 30. Using Register Globals


Kapitola 30. Using Register Globals

Varování

This feature is DEPRECATED and REMOVED as of PHP 6.0.0. Relying on this feature is highly discouraged.

Perhaps the most controversial change in PHP is when the default value for the PHP directive register_globals went from ON to OFF in PHP » 4.2.0. Reliance on this directive was quite common and many people didn't even know it existed and assumed it's just how PHP works. This page will explain how one can write insecure code with this directive but keep in mind that the directive itself isn't insecure but rather it's the misuse of it.

When on, register_globals will inject your scripts with all sorts of variables, like request variables from HTML forms. This coupled with the fact that PHP doesn't require variable initialization means writing insecure code is that much easier. It was a difficult decision, but the PHP community decided to disable this directive by default. When on, people use variables yet really don't know for sure where they come from and can only assume. Internal variables that are defined in the script itself get mixed up with request data sent by users and disabling register_globals changes this. Let's demonstrate with an example misuse of register_globals:

Příklad 30.1. Example misuse with register_globals = on

<?php
// define $authorized = true only if user is authenticated
if (authenticated_user()) {
    $authorized = true;
}

// Because we didn't first initialize $authorized as false, this might be
// defined through register_globals, like from GET auth.php?authorized=1
// So, anyone can be seen as authenticated!
if ($authorized) {
    include "/highly/sensitive/data.php";
}
?>

When register_globals = on, our logic above may be compromised. When off, $authorized can't be set via request so it'll be fine, although it really is generally a good programming practice to initialize variables first. For example, in our example above we might have first done $authorized = false. Doing this first means our above code would work with register_globals on or off as users by default would be unauthorized.

Another example is that of sessions. When register_globals = on, we could also use $username in our example below but again you must realize that $username could also come from other means, such as GET (through the URL).

Příklad 30.2. Example use of sessions with register_globals on or off

<?php
// We wouldn't know where $username came from but do know $_SESSION is
// for session data
if (isset($_SESSION['username'])) {

    echo "Hello <b>{$_SESSION['username']}</b>";

} else {

    echo "Hello <b>Guest</b><br />";
    echo "Would you like to login?";

}
?>

It's even possible to take preventative measures to warn when forging is being attempted. If you know ahead of time exactly where a variable should be coming from, you can check to see if the submitted data is coming from an inappropriate kind of submission. While it doesn't guarantee that data has not been forged, it does require an attacker to guess the right kind of forging. If you don't care where the request data comes from, you can use $_REQUEST as it contains a mix of GET, POST and COOKIE data. See also the manual section on using variables from outside of PHP.

Příklad 30.3. Detecting simple variable poisoning

<?php
if (isset($_COOKIE['MAGIC_COOKIE'])) {

    // MAGIC_COOKIE comes from a cookie.
    // Be sure to validate the cookie data!

} elseif (isset($_GET['MAGIC_COOKIE']) || isset($_POST['MAGIC_COOKIE'])) {

   mail("admin@example.com", "Possible breakin attempt", $_SERVER['REMOTE_ADDR']);
   echo "Security violation, admin has been alerted.";
   exit;

} else {

   // MAGIC_COOKIE isn't set through this REQUEST

}
?>

Of course, simply turning off register_globals does not mean your code is secure. For every piece of data that is submitted, it should also be checked in other ways. Always validate your user data and initialize your variables! To check for uninitialized variables you may turn up error_reporting() to show E_NOTICE level errors.

For information about emulating register_globals being On or Off, see this FAQ.

dostupnost superglobálních proměnných : Od PHP 4.1.0 jsou k dispozici superglobální pole jako $_GET , $_POST a $_SERVER. Pro více informací viz část manuálu o superglobals

Předcházející | Nahoru | Další
29. Hlášení chyb | Domů | 31. User Submitted Data


Kapitola 31. User Submitted Data

The greatest weakness in many PHP programs is not inherent in the language itself, but merely an issue of code not being written with security in mind. For this reason, you should always take the time to consider the implications of a given piece of code, to ascertain the possible damage if an unexpected variable is submitted to it.

Příklad 31.1. Dangerous Variable Usage

<?php
// remove a file from the user's home directory... or maybe
// somebody else's?
unlink ($evil_var);

// Write logging of their access... or maybe an /etc/passwd entry?
fwrite ($fp, $evil_var);

// Execute something trivial.. or rm -rf *?
system ($evil_var);
exec ($evil_var);

?>

You should always carefully examine your code to make sure that any variables being submitted from a web browser are being properly checked, and ask yourself the following questions:

  • Will this script only affect the intended files?
  • Can unusual or undesirable data be acted upon?
  • Can this script be used in unintended ways?
  • Can this be used in conjunction with other scripts in a negative manner?
  • Will any transactions be adequately logged?

By adequately asking these questions while writing the script, rather than later, you prevent an unfortunate re-write when you need to increase your security. By starting out with this mindset, you won't guarantee the security of your system, but you can help improve it.

You may also want to consider turning off register_globals, magic_quotes, or other convenience settings which may confuse you as to the validity, source, or value of a given variable. Working with PHP in error_reporting(E_ALL) mode can also help warn you about variables being used before they are checked or initialized (so you can prevent unusual data from being operated upon).

Předcházející | Nahoru | Další
30. Using Register Globals | Domů | 32. Magic Quotes


Kapitola 32. Magic Quotes

Obsah

What are Magic Quotes
Why use Magic Quotes
Why not to use Magic Quotes
Disabling Magic Quotes
Varování

This feature is DEPRECATED and REMOVED as of PHP 6.0.0. Relying on this feature is highly discouraged.

Magic Quotes is a process that automagically escapes incoming data to the PHP script. It's preferred to code with magic quotes off and to instead escape the data at runtime, as needed.

What are Magic Quotes

When on, all ' (single-quote), " (double quote), \ (backslash) and NULL characters are escaped with a backslash automatically. This is identical to what addslashes() does.

There are three magic quote directives:

  • magic_quotes_gpc

    Affects HTTP Request data (GET, POST, and COOKIE). Cannot be set at runtime, and defaults to on in PHP.

    See also get_magic_quotes_gpc().

  • magic_quotes_runtime

    If enabled, most functions that return data from an external source, including databases and text files, will have quotes escaped with a backslash. Can be set at runtime, and defaults to off in PHP.

    See also set_magic_quotes_runtime() and get_magic_quotes_runtime().

  • magic_quotes_sybase

    If enabled, a single-quote is escaped with a single-quote instead of a backslash. If on, it completely overrides magic_quotes_gpc. Having both directives enabled means only single quotes are escaped as ''. Double quotes, backslashes and NULL's will remain untouched and unescaped.

    See also ini_get() for retrieving its value.

Předcházející | Nahoru | Další
31. User Submitted Data | Domů | Why use Magic Quotes


Why use Magic Quotes

  • Useful for beginners

    Magic quotes are implemented in PHP to help code written by beginners from being dangerous. Although SQL Injection is still possible with magic quotes on, the risk is reduced.

  • Convenience

    For inserting data into a database, magic quotes essentially runs addslashes() on all Get, Post, and Cookie data, and does so automagically.

Předcházející | Nahoru | Další
32. Magic Quotes | Domů | Why not to use Magic Quotes


Why not to use Magic Quotes

  • Portability

    Assuming it to be on, or off, affects portability. Use get_magic_quotes_gpc() to check for this, and code accordingly.

  • Performance

    Because not every piece of escaped data is inserted into a database, there is a performance loss for escaping all this data. Simply calling on the escaping functions (like addslashes()) at runtime is more efficient.

    Although php.ini-dist enables these directives by default, php.ini-recommended disables it. This recommendation is mainly due to performance reasons.

  • Inconvenience

    Because not all data needs escaping, it's often annoying to see escaped data where it shouldn't be. For example, emailing from a form, and seeing a bunch of \' within the email. To fix, this may require excessive use of stripslashes().

Předcházející | Nahoru | Další
Why use Magic Quotes | Domů | Disabling Magic Quotes


Disabling Magic Quotes

The magic_quotes_gpc directive may only be disabled at the system level, and not at runtime. In otherwords, use of ini_set() is not an option.

Příklad 32.1. Disabling magic quotes server side

An example that sets the value of these directives to Off in php.ini. For additional details, read the manual section titled How to change configuration settings.

; Magic quotes
;

; Magic quotes for incoming GET/POST/Cookie data.
magic_quotes_gpc = Off

; Magic quotes for runtime-generated data, e.g. data from SQL, from exec(), etc.
magic_quotes_runtime = Off

; Use Sybase-style magic quotes (escape ' with '' instead of \').
magic_quotes_sybase = Off

If access to the server configuration is unavailable, use of .htaccess is also an option. For example:

php_flag magic_quotes_gpc Off

In the interest of writing portable code (code that works in any environment), like if setting at the server level is not possible, here's an example to disable magic_quotes_gpc at runtime. This method is inefficient so it's preferred to instead set the appropriate directives elsewhere.

Příklad 32.2. Disabling magic quotes at runtime

<?php
if (get_magic_quotes_gpc()) {
    function stripslashes_deep($value)
    {
        $value = is_array($value) ?
                    array_map('stripslashes_deep', $value) :
                    stripslashes($value);

        return $value;
    }

    $_POST = array_map('stripslashes_deep', $_POST);
    $_GET = array_map('stripslashes_deep', $_GET);
    $_COOKIE = array_map('stripslashes_deep', $_COOKIE);
    $_REQUEST = array_map('stripslashes_deep', $_REQUEST);
}
?>

Předcházející | Nahoru | Další
Why not to use Magic Quotes | Domů | 33. Skrývání PHP


Kapitola 33. Skrývání PHP

Obecně je bezpečnost skrze utajení jednou z nejslabších forem zabezpečení. Ale v některých případech je ta trocha bezpečnosti navíc žádoucí.

Skrýt PHP pomůže několik jednoduchých technik, které mohou zbrzdit útočníka, pokoušejícího se objevit slabiny vašeho systému. Nastavením expose_php = off v souboru php.ini omezíte množství informací, které mu budou dostupné.

Jinou taktikou je je nakonfigurovat webový server, jako je Apache, aby různé typy souborů parsoval interpretem PHP - buď direktivou v .htaccess nebo přímo v konfiguraci Apache. Potom můžete používat matoucí přípony souborů:

Příklad 33.1. Skývání PHP vydáváním za jiný jazyk

# Udělej, aby PHP kód vypadal jako kód jiného typu
AddType application/x-httpd-php .asp .py .pl

Nebo ho úplně utajte:

Příklad 33.2. Používání neznámých typů pro přípony PHP souborů

# Udělej, aby PHP kód vypadal jako neznámý typ
AddType application/x-httpd-php .bop .foo .133t

Nebo ho skryjte jako HTML kód, což bude mít mírné dopady na výkon, protože veškerý HTML kód bude zpracovávat PHP interpret:

Příklad 33.3. Použití HTML typu pro přípony PHP souborů

# Udělej, aby PHP kód vypadal jako HTML
AddType application/x-httpd-php .htm .html

Aby to mělo efekt, musíte své PHP soubory přejmenovat tak, aby měly výše uvedené přípony. Ačkoli je to forma bezpečnosit skrze utajení, má určité preventivní účinky s malými nevýhodami.

Předcházející | Nahoru | Další
Disabling Magic Quotes | Domů | 34. Aktualizace systému


Kapitola 34. Aktualizace systému

PHP, jako každý jiný velký systém, je neustále zkoumáno a vylepšováno. Každá nová verze často zahrnuje velké i malé změny ke zlepšení bezpečnosti a opravy různých děr, konfiguračních omylů a jiných věcí, které mohou mít vliv na celkovou bezpečnost a stabilitu vašeho systému.

Jako jiné systémové skriptovací jazyky a programy, nejlepší cestou je často aktualizovat systém a udržovat v povědomí nejnovější verze a změny v nich obsažené.

Předcházející | Nahoru | Další
33. Skrývání PHP | Domů | V. Vlastnosti


Část V. Vlastnosti

Obsah

35. HTTP autentikace a PHP
36. Cookies
37. Sessions
38. Dealing with XForms
39. Zpracování uploadu souborů
40. Použití vzdálených souborů
41. Obsluha spojení
42. Persistentní databázová spojení
43. Bezpečný režim
44. Použití PHP z příkazové řádky
Předcházející | Nahoru | Další
34. Aktualizace systému | Domů | 35. HTTP autentikace a PHP


Kapitola 35. HTTP autentikace a PHP

Prostředky HTTP autentikace jsou v PHP přístupné pouze pokud PHP běží jako modul Apache, tudíž nejsou přístupné v CGI verzi. V PHP skriptu běžícím pod modulem Apache lze použít funkci header() k odeslání zprávy "Authentication Required" klientskému browseru, což vyvolá zobrazení dialogového okna pro vložení uživatelského jména a hesla. Jakmile uživatel zadá jméno a heslo, URL obsahující tento PHP skript se zavolá znovu s proměnnými $PHP_AUTH_USER, $PHP_AUTH_PW and $PHP_AUTH_TYPE obsahujícími jméno, heslo a typ autentikace. V současnosti je podporována pouze "Basic" autentikace. Více informací viz funkce header().

Následující fragment kódu může posloužit jako ukázka vyžádání autentikace uživatele na stránce:

Příklad 35.1. Ukázka HTTP Autentikace

<?php
  if(!isset($PHP_AUTH_USER)) {
    Header("WWW-Authenticate: Basic realm=\"My Realm\"");
    Header("HTTP/1.0 401 Unauthorized");
    echo "Text, který se odešle, pokud uživatel zmáčkne tlačítko Cancel\n";
    exit;
  } else {
    echo "Ahoj $PHP_AUTH_USER.<P>";
    echo "Jako heslo jsi zadal $PHP_AUTH_PW.<P>";
  }
?>

Místo protého vytištění $PHP_AUTH_USER a $PHP_AUTH_PW byste asi chtěli ověřit platnost zadaného jména a hesla. Například dotazem v databázi nebo vyhledáním uživatele v dbm souboru.

Pozor na chybové browsery Internet Explorer. Zdá se, že jsou velice vybíravé, pokud jde o pořadí hlaviček. Zdá se, že odeslání hlavičky WWW-Authenticate před hlavičkou HTTP/1.0 401 zabírá.

Aby se zabránilo psaní skriptů odhalujících hesla na stránkách autentikovaných některým z tradičních externích mechanismů, PHP_AUTH proměnné se nevytvoří, pokud je pro tu kterou stránku zapnuta externí autentikace. V takovém případě můžete k identifikaci externě autentikovaného uživatele použít proměnnou $REMOTE_USER.

Všimněte si nicméně, že výše uvedené nezabrání krádežím hesel z autentikovaných URL osobou, která ovládá neautentikovanou URL na stejném serveru.

Jak Netscape, tak Internet Explorer po přijetí response kódu 401 vyprázdní autentikační cache současného realmu. Tak můžete uživatele v podstatě "odlogovat". Někteří lidé toho využívají k "vypršení" přihlášení nebo tvorbě odhlašovacího tlačítka.

Příklad 35.2. Ukázka HTTP autentikace vyžadující nové jméno a heslo

<?php
  function authenticate() {
    Header( "WWW-Authenticate: Basic realm=\"Test Authentication System\"");
    Header( "HTTP/1.0 401 Unauthorized");
    echo "K přístupu na tento zdroj musíte zadat platné ID a heslo\n";
    exit;
  }

  if(!isset($PHP_AUTH_USER) || ($SeenBefore == 1 && !strcmp($OldAuth, $PHP_AUTH_USER)) ) {
   authenticate();
  }
  else {
   echo "Welcome: $PHP_AUTH_USER<BR>";
   echo "Old: $OldAuth";
   echo "<FORM ACTION=\"$PHP_SELF\" METHOD=POST>\n";
   echo "<INPUT TYPE=HIDDEN NAME=\"SeenBefore\" VALUE=\"1\">\n";
   echo "<INPUT TYPE=HIDDEN NAME=\"OldAuth\" VALUE=\"$PHP_AUTH_USER\">\n";
   echo "<INPUT TYPE=Submit VALUE=\"Re Authenticate\">\n";
   echo "</FORM>\n";
  }
?>

Podle standardu HTTP Basic authentication se toto chování nevyžaduje, takže byste na to nikdy neměli spoléhat. Pokusy s Lynxem ukázaly, že Lynx po přijetí response kódu 401 nevyprázdní autentikační údaje, takže po stisknutí back a forward se znovu ukáže požadovaný zdroj (pokud se nezměnily požadavky na údaje).

Dále si všimněte, že tato vlastnost při použití IIS serveru a CGI verze PHP díky omezením IIS nefunguje.

Předcházející | Nahoru | Další
V. Vlastnosti | Domů | 36. Cookies


Kapitola 36. Cookies

PHP transparentně podporuje HTTP cookies. Cookies jsou mechanismem na ukládání dat ve vzdáleném browseru a tudíž sledování nebo identifikaci vracejících se uživatelů. Cookies můžete nastavovat pomocí funkce setcookie(). Cookies jsou součástí HTTP hlavičky, tudíž setcookie() se musí volat před odesláním výstupu do browseru. To je stejné omezení, jako má funkce header().

Všechny cookies přijaté od klienta se automaticky stávají PHP proměnnou stejně jako u GET a POST dat. Pokud chcete přiřadit jednomu cookie více hodnot, přidejte [] na konec jména cookie. Více detailů viz funkce setcookie().

Předcházející | Nahoru | Další
35. HTTP autentikace a PHP | Domů | 37. Sessions


Kapitola 37. Sessions

Session support in PHP consists of a way to preserve certain data across subsequent accesses. This enables you to build more customized applications and increase the appeal of your web site. All information is in the Session reference section.

Předcházející | Nahoru | Další
36. Cookies | Domů | 38. Dealing with XForms


Kapitola 38. Dealing with XForms

» XForms defines a variation on traditional webforms which allows them to be used on a wider variety of platforms and browsers or even non-traditional media such as PDF documents.

The first key difference in XForms is how the form is sent to the client. » XForms for HTML Authors contains a detailed description of how to create XForms, for the purpose of this tutorial we'll only be looking at a simple example.

Příklad 38.1. A simple XForms search form

<h:html xmlns:h="http://www.w3.org/1999/xhtml"
        xmlns="http://www.w3.org/2002/xforms">
<h:head>
 <h:title>Search</h:title>
 <model>
  <submission action="http://example.com/search"
              method="post" id="s"/>
 </model>
</h:head>
<h:body>
 <h:p>
  <input ref="q"><label>Find</label></input>
  <submit submission="s"><label>Go</label></submit>
 </h:p>
</h:body>
</h:html>

The above form displays a text input box (named q), and a submit button. When the submit button is clicked, the form will be sent to the page referred to by action.

Here's where it starts to look different from your web application's point of view. In a normal HTML form, the data would be sent as application/x-www-form-urlencoded, in the XForms world however, this information is sent as XML formatted data.

If you're choosing to work with XForms then you probably want that data as XML, in that case, look in $HTTP_RAW_POST_DATA where you'll find the XML document generated by the browser which you can pass into your favorite XSLT engine or document parser.

If you're not interested in formatting and just want your data to be loaded into the traditional $_POST variable, you can instruct the client browser to send it as application/x-www-form-urlencoded by changing the method attribute to urlencoded-post.

Příklad 38.2. Using an XForm to populate $_POST

<h:html xmlns:h="http://www.w3.org/1999/xhtml"
        xmlns="http://www.w3.org/2002/xforms">
<h:head>
 <h:title>Search</h:title>
 <model>
  <submission action="http://example.com/search"
              method="urlencoded-post" id="s"/>
 </model>
</h:head>
<h:body>
 <h:p>
  <input ref="q"><label>Find</label></input>
  <submit submission="s"><label>Go</label></submit>
 </h:p>
</h:body>
</h:html>

Poznámka: As of this writing, many browsers do not support XForms. Check your browser version if the above examples fails.

Předcházející | Nahoru | Další
37. Sessions | Domů | 39. Zpracování uploadu souborů


Kapitola 39. Zpracování uploadu souborů

Obsah

Uploading metodou POST
Častá úskalí
Uploading více souborů
Podpora metody PUT

Uploading metodou POST

PHP umožňuje zpracování uploadu souborů z jakéhokoli prohlížeče vyhovujícího RFC-1867 (což zahrnuje mj. Netscape Navigator 3 a pozdější, Microsoft Internet Explorer 3 se záplatou od Microsoftu, nebo pozdější bez záplaty). Tato schopnost umožňuje lidem uploadovat textové i binární soubory. S autentizací poskytovanou PHP a s funkcemi pro manipulaci se soubory máte plnou kontrolu nad tím, kdo smí uploadovat a co se má udělat s uploadovaným souborem.

Nezapomeňte, že PHP podporuje také uploady metodou PUT tak, jak se používá v Netscape Composeru a v editoru Amaya od W3C. Pro bližší detaily viz Podpora metody PUT.

Obrazovka pro upload souboru může být tvořena speciálním formulářem, který vypadá podobně jako tento:

Příklad 39.1. Formulář pro upload souboru

<form enctype="multipart/form-data" action="_URL_" method="post">
<input type="hidden" name="MAX_FILE_SIZE" value="1000">
Send this file: <input name="userfile" type="file">
<input type="submit" value="Send File">
</form>

_URL_ by mělo označovat PHP soubor. Skryté pole MAX_FILE_SIZE musí předcházet pole pro vložení souboru a jeho hodnota specifikuje maximální akceptovanou velikost souboru. Hodnota je v bytech.
Varování

Hodnota MAX_FILE_SIZE je z hlediska prohlížeče pouze informativní. Je snadné ji obejít. Takže nepočítejte s tím, že prohlížeč se bude chovat tak, jak si přejete. Nastavení maximální velikosti v PHP však samozřejmě nemůže být obelstěno.

Proměnné definované pro uploadované soubory se liší v závislosti na verzi a konfiguraci PHP. Pokud je aktivní volba track_vars, bude inicializováno pole $HTTP_POST_FILES/$_FILES. Konečně, související proměnné mohou být inicializovány jako globální, pokud je zapnuta volba register_globals. Ovšem používání globálních proměnných není doporučeno. Po úspěšném uploadu budou v cílovém skriptu definovány následující proměnné:

Poznámka: track_vars je od PHP 4.0.3 vždy zapnuto. U PHP 4.1.0 a pozdějších může být použito $_FILES namísto $HTTP_POST_FILES. $_FILES je vždy globální proměnná, takže by se neměla používat specifikace global pro proměnnou $_FILES.

$HTTP_POST_FILES/$_FILES obsahuje informace o uploadovaném souboru.

Obsah $HTTP_POST_FILES je takovýto (uvědomte si, že se předpokládá použití názvu uploadovaného souboru 'userfile' tak, jako v příkladu výše):

$HTTP_POST_FILES['userfile']['name']

Originální název souboru na klientském počítači.

$HTTP_POST_FILES['userfile']['type']

MIME typ souboru, pokud prohlížeč tuto informaci poskytuje (např. "image/gif").

$HTTP_POST_FILES['userfile']['size']

Velikost uploadovaného souboru v bytech.

$HTTP_POST_FILES['userfile']['tmp_name']

Dočasný název souboru, pod nímž byl uploadovaný soubor uložen na server.

Poznámka: PHP 4.1.0 a pozdější podporují zkrácený název proměnné $_FILES. PHP 3 nepodporuje $HTTP_POST_FILES.

Obsah proměnnách v situaci, kdy je proměnná register_globals zapnuta nastavením v souboru php.ini (uvědomte si, že se předpokládá použití názvu uploadovaného souboru 'userfile' tak, jako v příkladu výše):

  • $userfile - Dočasný název souboru, pod kterým byl uploadovaný soubor uložen na server.
  • $userfile_name - Originální název souboru nebo cesta na odesílajícím systému.
  • $userfile_size - Velikost uploadovaného souboru v bytech.
  • $userfile_type - MIME typ souboru, pokud prohlížeč tuto informaci poskytuje (např. "image/gif").
Uvědomte si, že proměnná "$userfile" ve skutečnosti představuje název pole <input> se specifikací type="file" ve formuláři. Pro výše uvedený příklad jsme zvolili název "userfile".

Poznámka: Nastavení register_globals = On se nedoporučuje z bezpečnostních a výkonnostních důvodů.

Soubory se implicitně ukládají do systémového adresáře pro dočasné soubory, pokud nebylo direktivou upload_tmp_dir v souboru php.ini stanoveno jinak. Systémový adresář pro dočasné soubory může být změněn nastavení proměnné prostředí TMPDIR v prostředí, kde PHP běží. Nastavení za použití putenv() z PHP skriptu nebude fungovat. Tato proměnná prostředí může být také použita k ujištění se, že všechny ostatní operace pracují s uploadovanými soubory.

Příklad 39.2. Ověřování uploadu souboru

Následující příklady jsou pro verze PHP 4 vyšší než PHP 4.0.2. (viz funkce is_uploaded_file() a move_uploaded_file()).

<?php
// V PHP 4.1.0 a pozdějších by mělo být použito $_FILES namísto $HTTP_POST_FILES.
if (is_uploaded_file($HTTP_POST_FILES['userfile']['tmp_name'])) {
    copy($HTTP_POST_FILES['userfile']['tmp_name'], "/place/to/put/uploaded/file");
} else {
    echo "Possible file upload attack. Filename: " . $HTTP_POST_FILES['userfile']['name'];
}
/* ...or... */
move_uploaded_file($HTTP_POST_FILES['userfile']['tmp_name'], "/place/to/put/uploaded/file");
?>

PHP skript, který přijímá uploadované soubory, by měl implementovat veškerou logiku pro stanovení, co by se mělo udělat s uploadovaným souborem. Můžete např. použít proměnnou $HTTP_POST_FILES['userfile']['size'] pro zahození souborů, které jsou příliš malé nebo velké. Mohli byste použít také proměnnou $HTTP_POST_FILES['userfile']['type'] pro filtraci souborů podle MIME datového typu. Bez ohledu na řešení, soubor by měl být smazán nebo přesunut jinam.

Soubor bude automaticky smazán z dočasného adresáře na konci skriptu, pokud nebyl přesunut jinam nebo přejmenován.

Předcházející | Nahoru | Další
38. Dealing with XForms | Domů | Častá úskalí


Častá úskalí

MAX_FILE_SIZE nemůže specifikovat velikost souboru větší než je ta, která byla nastavena pomocí upload_max_filesize v konfiguraci PHP. Implicitně jsou to 2 MB.

Pokud je zapnut limit paměti, může být potřeba větší hodnota memory_limit. Ujistěte se, že je hodnota memory_limit dostatečně velká.

Pokud je nastavená hodnota max_execution_time příliš malá, doba provádění skriptu ji může překročit. Ujistěte se, že je hodnota max_execution_time dostatečně velká.

Pokud je nastavená hodnota post_max_size příliš malá, nemůže být uploadován větší soubor. Ujistěte se, že je hodnota post_max_size dostatečně velká.

Neověřování, se kterým souborem se pracuje, může znamenat, že se uživatelé mohou dostat k citlivým informacím v jiných adresářích.

Uvědomte si prosím, že server CERN httpd odstraňuje všechno, co počínaje první bílou mezerou (whitespace) v MIME hlavičce Content-Type obdrží od klienta. Za existence tohoto jevu nebude CERN httpd podporovat uploading souborů.

Předcházející | Nahoru | Další
39. Zpracování uploadu souborů | Domů | Uploading více souborů


Uploading více souborů

Více souborů může být uploadování za použití různých názvů name pro souborové pole input.

Je také možné uploadovat více souborů současně a nechat informace automaticky zorganizovat v polích. V takovém případě je třeba použít stejnou syntaxi v HTML formuláři jako pro vícenásobné výběry a zaškrtávací políčka (checkboxy).

Poznámka: Podpora pro upload více souborů byla přidána ve verzi 3.0.10.

Příklad 39.3. Uploading více souborů

<form action="file-upload.php" method="post" enctype="multipart/form-data">
  Send these files:<br>
  <input name="userfile[]" type="file"><br>
  <input name="userfile[]" type="file"><br>
  <input type="submit" value="Send files">
</form>

Pokud je výše uvedený formulář odeslán, pole $HTTP_POST_FILES['userfile'], $HTTP_POST_FILES['userfile']['name'], a $HTTP_POST_FILES['userfile']['size'] budou inicializována (jak $_FILES v PHP 4.1.0 a pozdějším, tak $HTTP_POST_VARS v PHP 3. Pokud je nastavení register_globals aktivní globální proměnné pro uploadované soubory jsou také inicializovány). Každé z nich bude číselně indexované pole odpovídajících hodnot pro odeslané soubory.

Kupříkladu předpokládejme, že se posílají soubory s názvy /home/test/review.html a /home/test/xwp.out. V tom případě by $HTTP_POST_FILES['userfile']['name'][0] obsahovalo hodnotu review.html a $HTTP_POST_FILES['userfile']['name'][1] hodnotu xwp.out. Podobně $HTTP_POST_FILES['userfile']['size'][0] by obsahovalo velikost review.html atd.

$HTTP_POST_FILES['userfile']['name'][0], $HTTP_POST_FILES['userfile']['tmp_name'][0], $HTTP_POST_FILES['userfile']['size'][0] a $HTTP_POST_FILES['userfile']['type'][0] budou rovněž nastaveny.

Předcházející | Nahoru | Další
Častá úskalí | Domů | Podpora metody PUT


Podpora metody PUT

PHP poskytuje podporu pro HTTP PUT metodu používanou klienty jako Netscape Composer nebo W3C Amaya. Požadavky s metodou PUT jsou mnohem jednodušší než upload souborů a vypadají přibližně takto:

PUT /path/filename.html HTTP/1.1

Toto by normálně znamenalo, že by chtěl klient uložit obsah, který následuje za názvem /path/filename.html, do svého webového stromu. To samozřejmě není dobrý nápad, aby Apache nebo PHP automaticky nechal kohokoli přepsat jakékoli soubory ve stromě. Takže, pro zpracování takového požadavku je třeba nejdřív řici vašemu WWW serveru, že chcete požadavek zpracovávat konkrétním PHP skriptem. U serveru Apache se to provede direktivou Script. Může být umístěna kdekoli v konfiguračním souboru Apache. Častými místy jsou bloky <Directory> a <Virtualhost>. Použije se k tomu řádek podobný tomuto:

Skript PUT /put.php

Toto řekne serveru Apache, aby všechny PUT požadavky na nějaký URI vyhovující kontextu posílal skriptu put.php. To pochopitelně předpokládá, že máte povoleno PHP pro příponu .php a PHP je aktivní.

V souboru put.php byste potom mohli napsat něco jako:

<?php copy($PHP_UPLOADED_FILE_NAME,$DOCUMENT_ROOT.$REQUEST_URI); ?>

Toto by mělo zkopírovat soubor na místo požadované vzdáleným klientem. Pravděpodobně byste chtěli provést nějaká ověření a/nebo autentizace uživatele před provedením tohoto zkopírování. Jediným použitelným trikem je, že PHP uloží přenesený soubor do dočasného adresáře podobně, jako při použití metody POST. Až skript skončí, dočasný soubor bude odstraněn. Takže váš PHP skipt pro zpracování PUT požadavků musí soubor zkopírovat jinam. Název souboru v dočasném umístění je uložen v proměnné $PHP_PUT_FILENAME a požadovaný název cílového souboru v proměnné $REQUEST_URI (může se lišit u serverů jiných než Apache). Toto cílové jméno je to jediné, co klient specifikoval. Nemusíte ho poslechnout. Mohli byste, například, kopírovat všechny uploadované soubory do speciálního uploadového adresáře.

Předcházející | Nahoru | Další
Uploading více souborů | Domů | 40. Použití vzdálených souborů


Kapitola 40. Použití vzdálených souborů

Pokud při konfiguraci PHP aktivujete podporu "URL fopen wrapper" (standardně je zapnutá, ledaže pro configure explicitně zadáte --disable-url-fopen-wrapper příznak (verze do 4.0.3), nebo (u novějších verzí) nastavíte allow_url_fopen v php.ini na off), můžete ve voláních většiny funkcí, které očekávají jako argument název souboru (včetně require() a include()) uvést HTTP nebo FTP URL.

Poznámka: Na Windows nelze používat vzdálené soubory v include() a require() výrazech.

Můžete například otevřít soubor na vzdáleném web serveru, vyseparovat z výstupu data, která potřebujete, a tato data potom použít v dotazu na databázi, nebo je prostě začlenit do výstupu stylem odpovídajícím zbytku vaší web site.

Příklad 40.1. Získání názvu vzdálené stránky

<?php
$file = fopen ("http://www.php.net/", "r");
if (!$file) {
    echo "<p>Nelze otevřít vzdálený soubor.\n";
    exit;
}
while (!feof ($file)) {
    $line = fgets ($file, 1024);
    /* Toto bude fungovat pouze pokud jsou tagy a název na jedné řádce */
    if (eregi ("<title>(.*)</title>", $line, $out)) {
        $title = $out[1];
        break;
    }
}
fclose($file);
?>

Pokud se připojíte jako uživatel s dostatečnými právy, a daný soubor už neexistuje, můžete data také ukládat po FTP. Pokud se chcete připojit jako jiný uživatel než 'anonymous', musíte v URL udat uživatelské jméno (a pravděpodobně i heslo), např. 'ftp://uzivatel:heslo@ftp.example.com/path/to/file'. (Pro přístup k souborům přes HTTP, které vyžadují Basic authentication, můžete použít stejnou syntaxi.)

Příklad 40.2. Uložení dat na vzdáleném serveru

<?php
$file = fopen ("ftp://ftp.php.net/incoming/outputfile", "w");
if (!$file) {
    echo "<p>Nelze otevřít vzdálený soubor pro zápis.\n";
    exit;
}
/* Zapíšeme data. */
fputs ($file, "$HTTP_USER_AGENT\n");
fclose ($file);
?>

Poznámka: Z výše uvedeného příkladu by vás mohlo napadnout využít tuto techniku k zápisu do vzdáleného logu, ale jak už bylo zmíněno výše, pomocí URL fopen() wrapperu můžete zapisovat pouze do nového souboru. Pokud máte zájem o distribuované logování, podívejte se na syslog().

Předcházející | Nahoru | Další
Podpora metody PUT | Domů | 41. Obsluha spojení


Kapitola 41. Obsluha spojení

Poznámka: Následující text platí pro verzi 3.0.7 a vyšší.

Stav spojení se v PHP interně sleduje. Jsou tři možné stavy:

  • 0 - NORMAL (normální)
  • 1 - ABORTED (zrušeno)
  • 2 - TIMEOUT (vypršel časový limit)

Při normálním běhu PHP skriptu je aktivní stav NORMAL. Pokud se klient odpojí, nastaví se příznak ABORTED. K odpojení vzdáleného klienta typicky dochází, když uživatel zmáčkne tlačítko STOP. Pokud se dosáhne časového limitu (viz set_time_limit()), nastaví se stavový příznak TIMEOUT.

Můžete se rozhodnout jestli chcete, aby odpojení klienta způsobilo předčasné ukončení vašeho skriptu. Někdy je užitečné nechat skripty doběhnout do konce, přestože není vzdáleného browseru, který by přijímal výstup. Výchozí chování je nicméně takové, že při odpojení vzdáleného klienta dojde k ukončení běhu skriptu. Toto chování se dá změnit skrze konfigurační direktivu ignore_user_abort v php3.ini, odpovídající direktivu php3_ignore_user_abort v .conf souboru Apache, či funkci ignore_user_abort(). Pokud nedáte PHP pokyn ignorovat odpojení uživatele a ten se odpojí, váš skript se ukončí. Výjimkou je, pokud máte pomocí register_shutdown_function() zaregistrovanou funkci pro provedení při ukončení skriptu. V tom případě, pokud vzdálený uživatel zmáčkne tlačítko STOP, při dalším pokusu tohoto skriptu odeslat výstup PHP detekuje, že spojení bylo zrušeno, a zavolá se funkce zaregistrovaná pro provedení při ukončení skriptu. Tato funkce se zavolá také na konci běhu skriptu končícím normálně, takže pokud chcete po zrušeném spojení udělat něco jiného, můžete použít connection_aborted(). Tato funkce vrátí TRUE, pokud bylo spojení zrušeno.

Váš skript může také ukončit vestavěný čítač času. Výchozí časový limit je 30 sekund. To se dá změnit max_execution_time direktivou v phpš.ini nebo odpovídající php3_max_execution_time direktivou v .conf souboru Apahe, či voláním funkce set_time_limit(). Když čítač času doběhne, skript se ukončí, a jako ve výše uvedeném případě uživatelského odpojení, pokud je zaregistrovaná funkce pro provedení při ukončení skriptu, tato se zavolá. Uvnitř této funkce můžte zkontrolovat, jestli její zavolání způsobilo doběhnutí čítače času zavoláním funkce connection_timeout(). Tato funkce vrátí TRUE, pokud volání funkce registrované pro provedení při ukončení skriptu způsobilo doběhnutí čítače času.

Skutečností hodnou povšimnutí je, že stavy ABORTED a TIMEOUT mohou být aktivní současně. Možné je to v případě, že nařídíte PHP ignorovat odpojení uživatee. PHP i tak bude vědět, že uživatel přerušil spojení, ale skript poběží dál. Pokud potom dosáhne časového limitu, bude ukončen, a zavolá se vaše funkce pro provedení při ukončení skriptu, pokud existuje. V tomto okamžiku zjistíte, že jak connection_timeout(), tak connection_aborted() vracejí TRUE. Oba stavy můžete zkontrolovat jediným voláním funkce connection_status(). Tato funkce vrací bitové pole aktivních stavů. Takže například, pokud jsou aktivní oba tyto stavy, vrátí 3.

Předcházející | Nahoru | Další
40. Použití vzdálených souborů | Domů | 42. Persistentní databázová spojení


Kapitola 42. Persistentní databázová spojení

Trvalá spojení jsou SQL spojení, která se nezavírají na konci průběhu skriptu. Při požadavku na trvalé spojení PHP nejdříve zkontroluje, jestli už neexistuje identické spojení (které zůstalo otevřeno z dřívějška) - a pokud existuje, použije ho. Pokud neexistuje, PHP ho otevře. "Identické" spojení je spojení, které bylo otevřeno se stejným serverem, uživatelským jménem a heslem (pokud je zadáte).

Poznámka: Existují i další rozšíření, která vytváří trvalá spojení, například Rozšíření IMAP.

Lidé, kteří nejsou důkladně obeznámeni se způsobem, jakým web servery fungují a distribuují zátěž, mohou pokládat trvalá spojení za něco čím nejsou. Zvláště neumožňují otvírání "uživatelských sessions" na stejném SQL spojení, neumožňují efektivní tvorbu transakcí, a neumožňují spoustu dalších věcí. Dokonce, aby o tom bylo opravdu a důkladně jasno, vám trvalá spojení nedají žádnou funkcionalitu, která by nebyla možná s jejich netrvalými protějšky.

Proč?

To je dáno způsobem, jakým fungují webové servery. Jsou tři způsoby, jakými váš web server může využít PHP ke generování webových stránek.

První metodou je použít PHP jako CGI "obal". V tomto režimu se vytváří a ničí jedna instance PHP interpretru pro každý požadavek (na PHP strnánku) na vašem web serveru. Protože je zničena po obsloužení požadavku, všechny zdroje, které získá (jako třeba spojení s databázovým serverem) jsou při jejím zničení zavřeny. V tomto případě pokusem o použití trvalých spojení nic nezískáte - prostě nevydrží.

Druhou, a nejpopulárnější, metodou, je provozovat PHP jako modul v multiprocesním web serveru, což je množina, která v současnosti obsahuje pouze Apache. Multiprocesní web server má typicky jeden proces (rodiče), který řídí skupinu procesů (svých dětí), které dělají vlastní práci - servírují stránky. Každý požadavek, který přijde od klienta, je obsloužen jedním z dětí, které právě neobsluhuje jiného klienta. To znamená, že když stejný klient vznese další požadavek na stejný server, tento může být obsloužen jiným dětským procesem než ten první. Trvalá spojení zajišťují, aby se každý dětský proces musel na váš SQL server přihlásit pouze při prvním odeslání stránky, která takové spojení využívá. Když spojení s SQL serverem vyžaduje další stránka, může použít spojení, které toto dítě otevřelo už dříve.

Poslední metodou je použít PHP jako plug-in v multivláknovém web serveru. Aktuálně PHP 4 má tuto podporu pro ISAPI, WSAPI a NSAPI (na Windows), což umožnuje používat PHP jako plug-in v multivláknových serverech jako Netscape FastTrack (iPlanet), Microsoft Internet Information Server (IIS), a O'Reilly's WebSite Pro. Chování je stejné jako u multiprocesním modelu popsaném dříve. Podpora pro SAPI není dostupná v PHP 3.

Pokud trvalá spojení neposkytují žádnou přidanou funkcionalitu, k čemu jsou dobrá?

Odpověď na tuto otázku je velmi jednoduchá - efektivita. Trvalá spojení jsou dobrá, pokud má tvorba spojení s vaším SQL serverem vysokou režii. Reálná výše této režie záleží na mnoha faktorech. Například jaký je to typ databáze, jestli sídlí na stejném počítači jako váš webserver, jak zatížený je stroj, na kterém váš SQL server běží a tak dále. Pointa je, že pokud je spojovací režie vysoká, trvalá spojení vám znatelně pomohou. Umožní dětskému procesu připojit se pouze jednou za celý jeho životní cyklus místo každého zpracování stránky, která vyžaduje spojení s SQL serverem. To znamená, že každé dítě, které otevřelo trvalé spojení, bude mít otevřené vlastní trvalé spojení se serverem. Pokud například máte 20 dětských procesů, které spustily skript, který otevřel trvalé spojení s vaším SQL serverem, máte 20 nezávislých spojení s SQL serverem, po jednom z každého dítěte.

Všimněte si nicméně, že to může mít nevýhody, pokud používate databázi s omezeným počtem připojení, který trvalá spojení dětí překročí. Pokud má vaše databáze limit 16 současných připojení, a v rušném okamžiku se pokusí připojit 17 dětských procesů, jednomu se to nepodaří. Pokud máte ve svých skriptech chyby, které brání zavírání spojení (např. nekonečné smyčky), databáze s pouhými 32 spojeními bude brzy zaplavena. Vyhledejte si v dokumentaci vaší databáze informace o obsluze opuštěných nebo nečinných spojení.

Varování

Zde je několik dodatečných námitek, které se usadily v mysli během používání trvalých spojení. Jedna z nich je, když používáte zamknuté tabulky při trvalém spojení a skript z jakéhokoli důvodu nemůže uvolnit zámek, pak následující skript, který používá stejné spojení, bude nejspíše na trvalo zablokován a možná bude nutné, abyste pokaždé restartovali http server nebo databázový server. Dále pak v případě použití transakcí se transakční blok přenese i do dalšího skriptu používajícího stejné spojení, pokud jeho vykonání končí dříve než transakční blok. V každém případě můžete použít register_shutdown_function() k registraci a jednoduchému vyčištění funkce pro odemknutí tabulek nebo zrušení běžící transakce (roll back). Nejlépe se problému vyvarujete úplně nepoužíváním trvalých spojení ve skriptech, ve kterých se zamykají tabulky nebo používají transakce (můžete je stále používat na mnohých dalších místech).

Důležitý souhrn. Trvalá spojení byla navržena tak, aby odpovídala jedna k jedné normálním spojením. To znamená, že byste vždy měli být schopni nahradit trvalá spojení netrvalými beze změny fungování vašeho skriptu. Může to (a pravděpodobně bude) mít vliv na efektivitu tohoto skriptu, ale ne jeho chování!

Dále také:
 fbsql_pconnect(),
ibase_pconnect(),  ifx_pconnect(),
imap_popen(), ingres_pconnect(),
msql_pconnect(), mssql_pconnect(),
mysql_pconnect(), OCIPLogon(),
odbc_pconnect(), Ora_pLogon(),
pfsockopen(), pg_pconnect() a
sybase_pconnect().

Předcházející | Nahoru | Další
41. Obsluha spojení | Domů | 43. Bezpečný režim


Kapitola 43. Bezpečný režim

Obsah

Funkce omezené/deaktivované v bezpečném režimu

Bezpečný režim PHP je pokus o řešení bezpečnosti sdílených serverů. Je architekturálně nekorektní pokoušet se řešit tento problém na úrovni PHP, ale protože řešení na úrovni webovského serveru a operačního systému nejsou příliš realistická, mnoho lidí, zvlaště ISP, používá nyní bezpečný režim.

Konfigurační direktivy, které ovládají bezpečný režim:

safe_mode boolean

safe_mode_gid boolean

safe_mode_include_dir string

safe_mode_exec_dir string

safe_mode_allowed_env_vars string

safe_mode_protected_env_vars string

open_basedir string

disable_functions string

disable_classes string

Pokud je safe_mode zapnutý, PHP kontroluje, je-li vlastník běžícího skriptu vlastníkem souboru, s nímž se má manipulovat. Například:

-rw-rw-r--    1 rasmus   rasmus       33 Jul  1 19:20 script.php
-rw-r--r--    1 root     root       1116 May 26 18:01 /etc/passwd
Spuštění skriptu script.php <?php
 readfile('/etc/passwd');
?> bude mít v bezpečném režimu za výsledek tuto chybu:

Warning: SAFE MODE Restriction in effect. The script whose uid is 500 is not
allowed to access /etc/passwd owned by uid 0 in /docroot/script.php on line 2

Pokud namísto safe_mode nastavíte adresář open_basedir, potom všechny operace se soubory budou omezeny pod specifikovaný adresář. Například (příklad Apache httpd.conf):

<Directory /docroot>
  php_admin_value open_basedir /docroot
</Directory>
Když spustíte tentýž soubor script.php s timto nastavením open_basedir, dostanete tento výsledek:

Warning: open_basedir restriction in effect. File is in wrong directory in
/docroot/script.php on line 2

Můžete také vypnout jednotlivé funkce. Pokud přidáme toto do souboru php.ini:

disable_functions readfile,system
získáme takovýto výstup:

Warning: readfile() has been disabled for security reasons in
/docroot/script.php on line 2

Funkce omezené/deaktivované v bezpečném režimu

Toto je pravděpodobně neúplný a možná nesprávný přehled funkcí omezených v bezpečném režimu.

Tabulka 43.1. Funkce omezené v bezpečném režimu

Funkce | Omezení
dbmopen() | Kontroluje, zda soubory/adresáře, se kterými pracujete, mají stejné UID jako spuštěný skript.
dbase_open() | Kontroluje, zda soubory/adresáře, se kterými pracujete, mají stejné UID jako spuštěný skript.
filepro() | Kontroluje, zda soubory/adresáře, se kterými pracujete, mají stejné UID jako spuštěný skript.
filepro_rowcount() | Kontroluje, zda soubory/adresáře, se kterými pracujete, mají stejné UID jako spuštěný skript.
filepro_retrieve() | Kontroluje, zda soubory/adresáře, se kterými pracujete, mají stejné UID jako spuštěný skript.
ifx_*() | sql_safe_mode restrictions, (!= safe mode)
ingres_*() | sql_safe_mode restrictions, (!= safe mode)
mysql_*() | sql_safe_mode restrictions, (!= safe mode)
pg_loimport() | Kontroluje, zda soubory/adresáře, se kterými pracujete, mají stejné UID jako spuštěný skript.
posix_mkfifo() | Kontroluje, zda adresář, ve kterém pracujete, má stejné UID jako spuštěný skript.
putenv() | Obeys the safe_mode_protected_env_vars and safe_mode_allowed_env_vars ini-directives. Viz také dokumentaci putenv()
move_uploaded_file() | Kontroluje, zda soubory/adresáře, se kterými pracujete, mají stejné UID jako spuštěný skript.
chdir() | Kontroluje, zda adresář, ve kterém pracujete, má stejné UID jako spuštěný skript.
dl() | Tyto funkce jsou v bezpečném režimu (safe-mode) deaktivovány.
backtick operátor | Tyto funkce jsou v bezpečném režimu (safe-mode) deaktivovány.
shell_exec() (funkční ekvivalent backticks) | Tyto funkce jsou v bezpečném režimu (safe-mode) deaktivovány.
exec() | Můžete spouštět programy pouze uvnitř adresáře safe_mode_exec_dir. Z praktických důvodů není momentálně možné mít v cestě k souboru s programem komponenty ...
system() | Můžete spouštět programy pouze uvnitř adresáře safe_mode_exec_dir. Z praktických důvodů není momentálně možné mít v cestě k souboru s programem komponenty ...
passthru() | Můžete spouštět programy pouze uvnitř adresáře safe_mode_exec_dir. Z praktických důvodů není momentálně možné mít v cestě k souboru s programem komponenty ...
popen() | Můžete spouštět programy pouze uvnitř adresáře safe_mode_exec_dir. Z praktických důvodů není momentálně možné mít v cestě k souboru s programem komponenty ...
mkdir() | Kontroluje, zda adresář, ve kterém pracujete, má stejné UID jako spuštěný skript.
rmdir() | Kontroluje, zda soubory/adresáře, se kterými pracujete, mají stejné UID jako spuštěný skript.
rename() | Kontroluje, zda soubory/adresáře, se kterými pracujete, mají stejné UID jako spuštěný skript. Kontroluje, zda adresář, ve kterém pracujete, má stejné UID jako spuštěný skript.
unlink() | Kontroluje, zda soubory/adresáře, se kterými pracujete, mají stejné UID jako spuštěný skript. Kontroluje, zda adresář, ve kterém pracujete, má stejné UID jako spuštěný skript.
copy() | Kontroluje, zda soubory/adresáře, se kterými pracujete, mají stejné UID jako spuštěný skript. Kontroluje, zda adresář, ve kterém pracujete, má stejné UID jako spuštěný skript. (pro source a target)
chgrp() | Kontroluje, zda soubory/adresáře, se kterými pracujete, mají stejné UID jako spuštěný skript.
chown() | Kontroluje, zda soubory/adresáře, se kterými pracujete, mají stejné UID jako spuštěný skript.
chmod() | Kontroluje, zda soubory/adresáře, se kterými pracujete, mají stejné UID jako spuštěný skript. Navíc nemůžete nastavovat SUID, SGID a sticky bit
touch() | Kontroluje, zda soubory/adresáře, se kterými pracujete, mají stejné UID jako spuštěný skript. Kontroluje, zda adresář, ve kterém pracujete, má stejné UID jako spuštěný skript.
symlink() | Kontroluje, zda soubory/adresáře, se kterými pracujete, mají stejné UID jako spuštěný skript. Kontroluje, zda adresář, ve kterém pracujete, má stejné UID jako spuštěný skript. (pozn.: testován je pouze cíl)
link() | Kontroluje, zda soubory/adresáře, se kterými pracujete, mají stejné UID jako spuštěný skript. Kontroluje, zda adresář, ve kterém pracujete, má stejné UID jako spuštěný skript. (pozn.: testován je pouze cíl)
getallheaders() | V bezpečném režimu nebudou hlavičky začínající 'authorization' (bez ohledu na velikost písmen) vraceny. Varování: toto nefunguje s aol-server implementací getallheaders()!
Jakékoli funkce které používají php4/main/fopen_wrappers.c | ??

Předcházející | Nahoru | Další
42. Persistentní databázová spojení | Domů | 44. Použití PHP z příkazové řádky


Kapitola 44. Použití PHP z příkazové řádky

Možnosti PHP při spouštění z příkazové řádky přinášejí mnoho užitku, pokud chcete ladit nebo testovat vaše nastavení PHP, hodí se však i pro případy, kdy byste rádi použili PHP pro jiné účely než WWW skriptování.

Uvědomte si, že můžete vždy směrovat výstup programu PHP do vnějšího souboru pomocí znaku >, takže php -q test.php > test.html vytiskne výstup test.php bez HTTP hlaviček do test.html ve stejném adresáři.

Možnosti příkazové řádky můžete využívat pouze tehdy, máte-li (spustitelný) program PHP. Pokud jste zkompilovali pouze modul do serveru a nemáte na počítači žádnou CGI verzi, nemůžete příkazovou řádku používat. Pro uživatele Windows je v binárním balíčku jak serverový modul, tak spustitelný soubor nazvaný php.exe.

Tento seznem voleb pro příkazovou řádku je konzistentní s PHP 4.0.6. Aktuální seznam včetně jednořádkových popisů můžete získat pomocí parametru -h. Výstup php -h by měl vypadat přibližně takto:

Usage: php [-q] [-h] [-s [-v] [-i] [-f <file>] |  {<file> [args...]}
  -q             Quiet-mode.  Suppress HTTP Header output.
  -s             Display colour syntax highlighted source.
  -f <file>      Parse <file>.  Implies `-q'
  -v             Version number
  -C             Do not chdir to the script's directory
  -c <path>      Look for php.ini file in this directory
  -d foo[=bar]   Define INI entry foo with value 'bar'
  -e             Generate extended information for debugger/profiler
  -z <file>      Load Zend extension <file>.
  -l             Syntax check only (lint)
  -m             Show compiled in modules
  -i             PHP information
  -h             This help

Zde uvádíme některé z nejdůležitějších voleb s detailním vysvětlením.

Tabulka 44.1. Volby pro příkazovou řádku

Volba | Popis
-q | Potlačí výstup HTTP hlaviček. Normálně PHP tiskne HTTP hlavičky pro volající program (typicky WWW server) k předání prohlížeči. Při použití pro aplikace spouštěné z příkazové řádky nemají hlavičky smysl.
-s | Zobrazí barevně vysvícený zdrojový soubor s daným názvem. Je to totéž, jako když se zdroj vytiskne pomocí funkce highlight_file() v PHP skriptu.
-f | Parsuje daný soubor a hledá syntaktické a fatální chyby. Tato volba implikuje -q. Použijte pro ladicí účely (debugging).
-v | Zavoláním PHP s tímto přepínačem si můžete vypsat číslo verze, např. 4.0.6.
-C | Za normálních okolností PHP mění pracovní adresář na ten, kde se nachází spouštěný skript. To například umožňuje otvírat soubory ve stejném adresáři určením pouhého názvu souboru (bez cesty). Pokud byste toto chtěli potlačit, použijte tuto volbu.
-c | Použitím tohoto argumentu můžete specifikovat alternativní umístění souboru php.ini, takže PHP bude hledat konfigurační soubor zde namísto implicitního umístění.
-d | Touto volbou můžete provést individuální nastavení php.ini během provádění skriptu.
-l | Otestuje daný soubor na syntaktické chyby. Tato volba implikuje -q. Použijte ji pro účely ladění. Nebudou se hledat fatální chyby (jako jsou nedefinované funkce). Pokud chcete hledat i fatální chyby, použijte -f.
-m | Použitím této volby PHP vypíše zabudované (a načtené) PHP a Zend moduly, čísla verzí PHP a Zend, a také krátkou informaci o autorských právech k jádru Zend.
-i | Tento přepínač zavolá funkci phpinfo() a vypíše její výsledek. Pokud PHP nepracuje správně, je dobré spustit php -i a podívat se, zda se nevypsala nějaká chybová hlášení před nebo uvnitř informačních tabulek.
-h | Touto volbou získáte informace o aktuálních volbách příkazové řádky a jednořádkové popisy o tom, co dělají.

Spustitelná verze PHP může být použita pro spouštění skriptů absolutně nezávisle na webovském serveru. Pokud jste na unixovém systému, můžete do PHP skriptu přidat speciální první řádek a udělat z něj spustitelný program - systém bude vědět, jaký program by měl skript zpracovávat. Na Windows můžete asociovat php.exe -q se souborovou příponou .php (pro spouštění dvojklikem), nebo můžete vytvořit dávkový soubor pro spuštění skriptu přes PHP. První řádek skriptu pro práci v Unixu nebude ve Windows vadit, takže tímto způsobem můžete psát programy pro více platforem. Jednoduchý příklad psaní PHP programu pro příkazovou řádku je uveden níže.

Příklad 44.1. Skript určený ke spouštění z příkazové řádky (script.php)

#!/usr/bin/php -q
<?php

if ($argc != 2 || in_array($argv[1], array('--help', '-help', '-h', '-?'))) {
?>

This is a command line PHP script with one option.

  Usage:
  <?php echo $argv[0]; ?> <option>

  <option> can be some word you would like
  to print out. With the --help, -help, -h,
  or -? options, you can get this help.

<?php
} else {
    echo $argv[1];
}
?>

Ve výše uvedeném skriptu jsme použili speciální první řádek k indikaci, že by tento soubor měl být spouštěn pomocí PHP a neměl by vypisovat HTTP hlavičky. Jsou zde dvě proměnné, které můžete použít při psaní aplikací pro PHP spouštěných z příkazové řádky: $argc a $argv. První z nich je počet argumentů + 1 (název běžícího skriptu). Druhá je pole obsahující argumenty, počínaje názvem skriptu jako číslo 0 ($argv[0]).

V ukázkovém programu se testuje, zda je argumentů více či méně než jeden. Pokud by argument byl --help, -help, -h nebo -?, vytiskne se nápověda k programu včetně skutečného názvu skriptu. Pokud by byly přidány nějaké další argumenty, vytisknou se na výstup.

Pokud byste chtěli spouštět uvedený skript pod Unixem, musíte ho udělat spustitelným (nastavit práva pro spouštění), a pak jednoduše napsat script.php vypis_tohle nebo script.php -h. Na Windows musíte pro tento úkol vytvořit dávkový soubor:

Příklad 44.2. Dávkový soubor pro spouštění PHP skriptu z příkazové řádky (script.bat)

@c:\php\php.exe -q script.php %1 %2 %3 %4

Za předpokladu, že jste výše uvedený program nazvali script.php a soubor php.exe máte uložený jako c:\php\php.exe, můžete tento dávkový soubor spouštět takto: script.bat echothis nebo script.bat -h.

Viz také dokumentaci rozšíření Readline, kde najdete více funkcí pro použití k aplikacím PHP spouštěných z příkazové řádky.

Předcházející | Nahoru | Další
43. Bezpečný režim | Domů | VI. Reference funkcí


Část VI. Reference funkcí

See also K – „Kategorizace rozšíření“.

Obsah

I. .NET Functions
II. Funkce specifické pro Apache
III. Alternative PHP Cache
IV. Advanced PHP debugger
V. Funkce pro práci s poli
VI. Aspell funkce [zastaralé]
VII. BBCode Functions
VIII. BCMath funkce pro výpočty s libovolnou přesností
IX. PHP bytecode Compiler
X. Kompresní funkce bzip2
XI. Kalendářové funkce
XII. CCVS API Functions
XIII. Funkce pro práci s třídami/objekty
XIV. Classkit Functions
XV. ClibPDF Functions [deprecated]
XVI. Funkce na podporu COM ve Windows
XVII. Crack Functions
XVIII. Character Type Functions
XIX. Funkce pro práci s CURL, Client URL Library
XX. Cybercash platební funkce
XXI. Credit Mutuel CyberMUT functions
XXII. Cyrus IMAP administration Functions
XXIII. Funkce pro datum a čas
XXIV. DB++ Functions
XXV. Database (dbm-style) Abstraction Layer Functions
XXVI. dBase Functions
XXVII. DBM Funkce [zastaralé]
XXVIII. dbx Functions
XXIX. Direct IO Functions
XXX. Adresářové funkce
XXXI. DOM Functions
XXXII. DOM XML Functions
XXXIII. enchant Functions
XXXIV. Error Handling and Logging Functions
XXXV. Exif Functions
XXXVI. Expect Functions
XXXVII. File Alteration Monitor Functions
XXXVIII. Forms Data Format Functions
XXXIX. Fileinfo Functions
XL. filePro funkce
XLI. Funkce filesystému
XLII. Filter Functions
XLIII. Firebird/InterBase Functions
XLIV. Firebird/Interbase Functions (PDO_FIREBIRD)
XLV. FriBiDi Functions
XLVI. FrontBase Functions
XLVII. FTP Functions
XLVIII. Funkce pro práci s funkcemi
XLIX. GeoIP Functions
L. Gettext
LI. GMP Functions
LII. gnupg Funkce
LIII. Net_Gopher
LIV. Haru PDF Functions
LV. hash Functions
LVI. HTTP
LVII. Hyperwave Functions
LVIII. Hyperwave API Functions
LIX. i18n Funkce
LX. IBM Functions (PDO_IBM)
LXI. IBM DB2, Cloudscape and Apache Derby Functions
LXII. iconv Functions
LXIII. ID3 Functions
LXIV. IIS Administration Functions
LXV. Image Functions
LXVI. Imagick Image Library
LXVII. IMAP, POP3 and NNTP Functions
LXVIII. Informix Functions
LXIX. Informix Functions (PDO_INFORMIX)
LXX. Ingres II Functions
LXXI. IRC Gateway Functions
LXXII. PHP / Java Integration
LXXIII. JSON Functions
LXXIV. KADM5
LXXV. LDAP Functions
LXXVI. libxml Functions
LXXVII. Lotus Notes Functions
LXXVIII. LZF Functions
LXXIX. Mailové funkce
LXXX. Mailparse Functions
LXXXI. Matematické funkce
LXXXII. MaxDB PHP Extension
LXXXIII. MCAL Functions
LXXXIV. Mcrypt Encryption Functions
LXXXV. MCVE (Monetra) Payment Functions
LXXXVI. Memcache Functions
LXXXVII. Mhash funkce
LXXXVIII. Mimetype Functions
LXXXIX. Ming functions for Flash
XC. Různé funkce
XCI. mnoGoSearch Functions
XCII. Microsoft SQL Server Functions
XCIII. Microsoft SQL Server and Sybase Functions (PDO_DBLIB)
XCIV. Mohawk Software Session Handler Functions
XCV. mSQL Functions
XCVI. Multibyte String Functions
XCVII. muscat Functions
XCVIII. MySQL funkce
XCIX. MySQL Functions (PDO_MYSQL)
C. MySQL Improved Extension
CI. Ncurses Terminal Screen Control Functions
CII. Síťové funkce
CIII. Newt Functions
CIV. NSAPI-specific Functions
CV. Object Aggregation/Composition Functions
CVI. Object property and method call overloading
CVII. Oracle Functions
CVIII. ODBC Functions (Unified)
CIX. ODBC and DB2 Functions (PDO_ODBC)
CX. oggvorbis
CXI. OpenAL Audio Bindings
CXII. OpenSSL funkce
CXIII. Oracle Functions [deprecated]
CXIV. Oracle Functions (PDO_OCI)
CXV. Funkce pro řízení výstupu
CXVI. Ovrimos SQL Functions
CXVII. Paradox File Access
CXVIII. Parsekit Functions
CXIX. Process Control Functions
CXX. Regular Expression Functions (Perl-Compatible)
CXXI. PDF funkce
CXXII. PDO Functions
CXXIII. Phar archive stream and classes
CXXIV. PHP volby a informace
CXXV. POSIX Functions
CXXVI. Regular Expression Functions (POSIX Extended)
CXXVII. PostgreSQL Functions
CXXVIII. PostgreSQL Functions (PDO_PGSQL)
CXXIX. Printer Functions
CXXX. Funkce spouštění programů
CXXXI. PostScript document creation
CXXXII. Pspell Functions
CXXXIII. qtdom Functions
CXXXIV. Radius
CXXXV. Rar Functions
CXXXVI. GNU Readline
CXXXVII. GNU Recode funkce
CXXXVIII. RPM Header Reading Funkce
CXXXIX. runkit Functions
CXL. SAM - Simple Asynchronous Messaging
CXLI. Satellite CORBA klient extenze
CXLII. SCA Functions
CXLIII. SDO Functions
CXLIV. SDO XML Data Access Service Functions
CXLV. SDO Relational Data Access Service Functions
CXLVI. Semaphore, Shared Memory and IPC Functions
CXLVII. SESAM Database Functions
CXLVIII. PostgreSQL Session Save Handler
CXLIX. Session Handling Functions
CL. Funkce pro práci se sdílenou pamětí
CLI. SimpleXML functions
CLII. SNMP Functions
CLIII. SOAP Functions
CLIV. Socket Functions
CLV. Standard PHP Library (SPL) Functions
CLVI. SQLite Functions
CLVII. SQLite Functions (PDO_SQLITE)
CLVIII. Secure Shell2 Functions
CLIX. Statistics Functions
CLX. Stream Functions
CLXI. Funkce pro práci s řetězci
CLXII. Subversion Funkce
CLXIII. Shockwave Flash Functions
CLXIV. Swish Functions
CLXV. Sybase Functions
CLXVI. TCP Wrappers Functions
CLXVII. Tidy Functions
CLXVIII. Tokenizer Functions
CLXIX. Unicode Functions
CLXX. URL funkce
CLXXI. Variable Handling Functions
CLXXII. Funkce pro práci s Verisign Payflow Pro
CLXXIII. vpopmail Functions
CLXXIV. W32api Functions
CLXXV. WDDX funkce
CLXXVI. win32ps Functions
CLXXVII. win32service Functions
CLXXVIII. xattr Functions
CLXXIX. xdiff Functions
CLXXX. XML Parser Functions
CLXXXI. XML-RPC Functions
CLXXXII. XMLReader functions
CLXXXIII. XMLWriter Functions
CLXXXIV. XSL functions
CLXXXV. XSLT funkce
CLXXXVI. YAZ Functions
CLXXXVII. Funkce pro práci s YP/NIS
CLXXXVIII. Zip File Functions
CLXXXIX. Zlib Compression Functions
Předcházející | Nahoru | Další
44. Použití PHP z příkazové řádky | Domů | I. .NET Functions


Funkce specifické pro Apache

Předcházející VI. Reference funkcí Další

II. Funkce specifické pro Apache

Úvod

Tyto funkce jsou k dispozici pouze pokud PHP běží jako modul Apache 1.x.

Instalace

Instalaci PHP v Apache 1.x viz část Apache kapitoly o instalaci.

Konfigurace běhu

The behaviour of the Apache PHP module is affected by settings in php.ini. Configuration settings from php.ini may be overridden by php_flag settings in the server configuration file or local .htaccess files.

Příklad 149. Turning off PHP parsing for a directory using .htaccess

php_flag engine off

Tabulka 11. Apache configuration options

Name | Default | Changeable | Changelog
engine | "1" | PHP_INI_ALL | Available since PHP 4.0.5.
child_terminate | "0" | PHP_INI_ALL | Available since PHP 4.0.5.
last_modified | "0" | PHP_INI_ALL | Available since PHP 4.0.5.
xbithack | "0" | PHP_INI_ALL | Available since PHP 4.0.5.

Pro další detaily a definice konstant PHP_INI_*, viz dokumentace k ini_set().

Zde je stručný popis konfiguračních direktiv.

engine boolean

Turns PHP parsing on or off. This directive is really only useful in the Apache module version of PHP. It is used by sites that would like to turn PHP parsing on and off on a per-directory or per-virtual server basis. By putting engine off in the appropriate places in the httpd.conf file, PHP can be enabled or disabled.

child_terminate boolean

Specify whether PHP scripts may request child process termination on end of request, see also apache_child_terminate().

last_modified boolean

Send PHP scripts modification date as Last-Modified: header for this request.

xbithack boolean

Parse files with executable bit set as PHP regardless of their file ending.

Typy prostředků

Toto rozšíření nemá definován žádný typ prostředku (resource).

Předdefinované konstanty

Toto rozšíření nemá definovány žádné konstanty.

Obsah

apache_child_terminate — Terminate apache process after this request
apache_get_modules — Get a list of loaded Apache modules
apache_get_version — Fetch Apache version
apache_getenv — Get an Apache subprocess_env variable
apache_lookup_uri — Provádí částečný požadavek na zadanou URI a vrací všechno info o ní
apache_note — Získává a nastavuje poznámky požadavku u Apache.
apache_request_headers — Fetch all HTTP request headers
apache_reset_timeout — Reset the Apache write timer
apache_response_headers — Fetch all HTTP response headers
apache_setenv — Set an Apache subprocess_env variable
ascii2ebcdic — Překládá řetězec z ASCII do EBCDIC
ebcdic2ascii — Překládá řetězec z EBCDIC do ASCII
getallheaders — Získává všechny hlavičky HTTP požadavku
virtual — Provádí sub-požadavek Apache
Předcházející | Nahoru | Další
dotnet_load | Domů | apache_child_terminate


apache_child_terminate

(PHP 4 >= 4.0.5, PHP 5)

apache_child_terminate — Terminate apache process after this request

Popis

bool apache_child_terminate ( void )

apache_child_terminate() will register the Apache process executing the current PHP request for termination once execution of PHP code it is completed. It may be used to terminate a process after a script with high memory consumption has been run as memory will usually only be freed internally but not given back to the operating system.

Návratové hodnoty

Returns TRUE if PHP is running as an Apache 1 module, the Apache version is non-multithreaded, and the child_terminate PHP directive is enabled (disabled by default). If these conditions are not met, FALSE is returned and an error of level E_WARNING is generated.

Poznámky

Poznámka: Tato funkce není implementována na platformách Windows.

Viz také

exit()

Předcházející | Nahoru | Další
II. Funkce specifické pro Apache | Domů | apache_get_modules


apache_get_modules

(PHP 4 >= 4.3.2, PHP 5)

apache_get_modules — Get a list of loaded Apache modules

Popis

array apache_get_modules ( void )

Get a list of loaded Apache modules.

Návratové hodnoty

An array of loaded Apache modules.

ChangeLog (záznam změn)

Verze | Popis
5.0.0 | Became available when using Apache 1, or the PHP Apache 2 filter API. Before this time, it was only available when using the Apache 2 handler API.

Příklady

Příklad 150. apache_get_modules() example

<?php
print_r(apache_get_modules());
?>

Výše uvedený příklad vypíše něco jako:

Array
(
    [0] => core
    [1] => http_core
    [2] => mod_so
    [3] => sapi_apache2
    [4] => mod_mime
    [5] => mod_rewrite
)

Předcházející | Nahoru | Další
apache_child_terminate | Domů | apache_get_version


apache_get_version

(PHP 4 >= 4.3.2, PHP 5)

apache_get_version — Fetch Apache version

Popis

string apache_get_version ( void )

Fetch the Apache version.

Návratové hodnoty

Returns the Apache version on success, or FALSE on failure.

ChangeLog (záznam změn)

Verze | Popis
4.3.4 | Became available with Apache 1.
5.0.0 | Became available with the Apache 2 filter API.

Příklady

Příklad 151. apache_get_version() example

<?php
$version = apache_get_version();
echo "$version\n";
?>

Výše uvedený příklad vypíše něco jako:

Apache/1.3.29 (Unix) PHP/4.3.4

Viz také

phpinfo()

Předcházející | Nahoru | Další
apache_get_modules | Domů | apache_getenv


apache_getenv

(PHP 4 >= 4.3.0, PHP 5)

apache_getenv — Get an Apache subprocess_env variable

Popis

string apache_getenv ( string $variable [, bool $walk_to_top] )

Get an Apache environment variable as specified by variable.

This function requires Apache 2 otherwise it's undefined.

Seznam parametrů

variable

The Apache environment variable

walk_to_top

Whether to get the top-level variable available to all Apache layers.

Návratové hodnoty

The value of the Apache environment variable on success, or FALSE on failure

Příklady

Příklad 152. apache_getenv() example

The example above shows how to retrieve the value of the Apache environment variable SERVER_ADDR.

<?php
$ret = apache_getenv("SERVER_ADDR");
echo $ret;
?>

Výše uvedený příklad vypíše něco jako:

42.24.42.240

Viz také

apache_setenv()
getenv()
Superglobals

Předcházející | Nahoru | Další
apache_get_version | Domů | apache_lookup_uri


apache_lookup_uri

(PHP 4, PHP 5)

apache_lookup_uri — Provádí částečný požadavek na zadanou URI a vrací všechno info o ní

Popis

object apache_lookup_uri ( string $filename )

Tato funkce provádí částečný požadavek na URI. Jde jen tak daleko, aby získala všechny důležité informace o daném zdroji a vrací tyto informace ve třídě. Vlastnosti této třídy jsou:
status
the_request
status_line
method
content_type
handler
uri
filename
path_info
args
boundary
no_cache
no_local_copy
allowed
send_bodyct
bytes_sent
byterange
clength
unparsed_uri
mtime
request_time

Poznámka: apache_lookup_uri() pouze, pokud je PHP nainstalováno jako modul Apache.

Předcházející | Nahoru | Další
apache_getenv | Domů | apache_note


apache_note

(PHP 4, PHP 5)

apache_note — Získává a nastavuje poznámky požadavku u Apache.

Popis

string apache_note ( string $note_name [, string $ note_value ] )

apache_note() je funkce specifická pro Apache, která získává a nastavuje hodnoty v tabulce poznámek požadavku. Při volání s jedním argumentem vrací současnou hodnotu poznámky note_name. Při volání se dvěma argumenty nastavuje hodnotu poznámky note_name na note_value, a vrací předchozí hodnotu poznámky note_name.

Předcházející | Nahoru | Další
apache_lookup_uri | Domů | apache_request_headers


apache_request_headers

(PHP 4 >= 4.3.0, PHP 5)

apache_request_headers — Fetch all HTTP request headers

Popis

array apache_request_headers ( void )

Fetches all HTTP requests from the current request.

Tato funkce je podporována jen v případě, že je PHP nainstalováno jako modul do Apache..

Návratové hodnoty

An associative array of all the HTTP headers in the current request, or FALSE on failure.

Příklady

Příklad 153. apache_request_headers() example

<?php
$headers = apache_request_headers();

foreach ($headers as $header => $value) {
    echo "$header: $value <br />\n";
}
?>

Výše uvedený příklad vypíše něco jako:

Accept: */*
Accept-Language: en-us
Accept-Encoding: gzip, deflate
User-Agent: Mozilla/4.0
Host: www.example.com
Connection: Keep-Alive

Poznámky

Poznámka:
    Prior to PHP 4.3.0, apache_request_headers() was
    called getallheaders().  After PHP 4.3.0,
    getallheaders() is an alias for
    apache_request_headers().

Poznámka: You can also get at the value of the common CGI variables by reading them from the environment, which works whether or not you are using PHP as an Apache module. Use phpinfo() to see a list of all of the available environment variables.

Poznámka: Od PHP 4.3.3 můžete používat tuto funkci serverového modulu NSAPI také v serverech Netscape/iPlanet/SunONE.

Viz také

apache_response_headers()

Předcházející | Nahoru | Další
apache_note | Domů | apache_reset_timeout


apache_response_headers

(PHP 4 >= 4.3.0, PHP 5)

apache_response_headers — Fetch all HTTP response headers

Popis

array apache_response_headers ( void )

Fetch all HTTP response headers.

Návratové hodnoty

An array of all Apache response headers on success, or FALSE on failure.

Příklady

Příklad 154. apache_response_headers() example

<?php
print_r(apache_response_headers());
?>

Výše uvedený příklad vypíše něco jako:

Array
(
    [Accept-Ranges] => bytes
    [X-Powered-By] => PHP/4.3.8
)

Poznámky

Poznámka: Od PHP 4.3.3 můžete používat tuto funkci serverového modulu NSAPI také v serverech Netscape/iPlanet/SunONE.

Viz také

apache_request_headers()
headers_sent()

Předcházející | Nahoru | Další
apache_reset_timeout | Domů | apache_setenv


apache_setenv

(PHP 4 >= 4.2.0, PHP 5)

apache_setenv — Set an Apache subprocess_env variable

Popis

bool apache_setenv ( string $variable, string $value [, bool $walk_to_top] )

apache_setenv() sets the value of the Apache environment variable specified by variable.

Poznámka: When setting an Apache environment variable, the corresponding $_SERVER variable is not changed.

Seznam parametrů

variable

The environment variable that's being set.

value

The new variable value.

walk_to_top

Whether to set the top-level variable available to all Apache layers.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 155. Setting an Apache environment variable using apache_setenv()

<?php
apache_setenv("EXAMPLE_VAR", "Example Value");
?>

Poznámky

Poznámka: apache_setenv() can be paired up with apache_getenv() across separate pages or for setting variables to pass to Server Side Includes (.shtml) that have been included in PHP scripts.

Viz také

apache_getenv()

Předcházející | Nahoru | Další
apache_response_headers | Domů | ascii2ebcdic


ascii2ebcdic

(No version information available, might be only in CVS)

ascii2ebcdic — Překládá řetězec z ASCII do EBCDIC

Popis

int ascii2ebcdic ( string $ascii_str )

ascii2ebcdic() je funkce specifická pro Apache dostupná pouze na operačních systémech založených na EBCDIC (OS/390, BS2000). Překládá (binárně bezpečně) řežězec v ASCII kódování ascii_str na jeho ekvivalentní EBCDIC reprezentaci, a vrací výsledek.

Viz také opačnou funkci ebcdic2ascii()

Předcházející | Nahoru | Další
apache_setenv | Domů | ebcdic2ascii


ebcdic2ascii

(No version information available, might be only in CVS)

ebcdic2ascii — Překládá řetězec z EBCDIC do ASCII

Popis

int ebcdic2ascii ( string $ebcdic_str )

ebcdic2ascii() je funkce specifická pro Apache dostupná pouze na operačních systémech založených na EBCDIC (OS/390, BS2000). Překládá (binárně bezpečně) řežězec v kódování EBCDIC ascii_str na jeho ekvivalentní ASCII reprezentaci, a vrací výsledek.

Viz také opačnou funkci ascii2ebcdic()

Předcházející | Nahoru | Další
ascii2ebcdic | Domů | getallheaders


getallheaders

(PHP 4, PHP 5)

getallheaders — Získává všechny hlavičky HTTP požadavku

Popis

array getallheaders ( void )

Tato funkce vrací asociativní pole všech HTTP hlaviček v současném požadavku.

Poznámka: Hodnotu běžných CGI proměnných můžete také získat tím, že je přečtete z prostředí, což funguje, ať používáte PHP jako modu Apache nebo ne. Pokud chcete vidět seznam všech systémových proměnných definovaných tímto způsobem, použijte phpinfo().

Příklad 156. getallheaders() Example

$headers = getallheaders();
while (list ($header, $value) = each ($headers)) {
    echo "$header: $value<br>\n";
}

Tento příklad zobrazí všechny hlavičky současného požadavku.

Poznámka: getallheaders() je v současnosti podporována jen když PHP běží jako modul Apache.

Předcházející | Nahoru | Další
ebcdic2ascii | Domů | virtual


virtual

(PHP 4, PHP 5)

virtual — Provádí sub-požadavek Apache

Popis

bool virtual ( string $filename )

virtual() je funkce specifická pro Apache ekvivalentní s <!--#include virtual...--> v mod_include. Provádí sub-požadavek Apache. Je užitečná pro vkládání CGI skriptů nebo .shtml souborů, nebo čehokoliv jiného, co má Apache parsovat. CGI skripty musí generovat platné CGI hlavičky. To znamená, že musí přinejmenším generovat Content-type hlavičku. Pro PHP soubory musíte použít include() nebo require(); virtual() se nedá použít k vložení dokumentu, který je sám PHP skriptem.

Předcházející | Nahoru | Další
getallheaders | Domů | III. Alternative PHP Cache


Advanced PHP debugger

Předcházející VI. Reference funkcí Další

IV. Advanced PHP debugger

Úvod

APD is the Advanced PHP Debugger. It was written to provide profiling and debugging capabilities for PHP code, as well as to provide the ability to print out a full stack backtrace. APD supports interactive debugging, but by default it writes data to trace files. It also offers event based logging so that varying levels of information (including function calls, arguments passed, timings, etc.) can be turned on or off for individual scripts.

Výstraha

APD is a Zend Extension, modifying the way the internals of PHP handle function calls, and thus may or may not be compatible with other Zend Extensions (for example Zend Optimizer).

Instalace

APD is currently available as a PECL extension from » http://pecl.php.net/package/apd. Make sure you have installed the CGI version of PHP and it is available in your current path along with the phpize script.

Run the following command to download, build, and install the latest stable version of APD:

pear install apd

This automatically installs the APD Zend module into your PHP extensions directory. It is not mandatory to keep it there; you can store the module in any directory PHP can read as long as you set the zend_extension parameter accordingly.

Windows users can download the extension dll php_apd.dll from » http://snaps.php.net/win32/PECL_STABLE/.

In your INI file, add the following lines:

zend_extension = /absolute/path/to/apd.so
apd.dumpdir = /absolute/path/to/trace/directory
apd.statement_tracing = 0

Depending on your PHP build, the zend_extension directive can be one of the following:

zend_extension              (non ZTS, non debug build)
zend_extension_ts           (    ZTS, non debug build)
zend_extension_debug        (non ZTS,     debug build)
zend_extension_debug_ts     (    ZTS,     debug build)

Building on Win32

To build APD under Windows you need a working PHP compilation environment as described on http://php.net/ -- basically, it requires you to have Microsoft Visual C++, win32build.zip, bison/flex, and some know how to get it to work. Also ensure that adp.dsp has DOS line endings; if it has unix line endings, Microsoft Visual C++ will complain about it.

Konfigurace běhu

Chování těchto funkcí je ovlivněno nastavením parametrů v php.ini.

Tabulka 13. APD Configuration Options

Name | Default | Changeable | Changelog
apd.dumpdir | NULL | PHP_INI_ALL |
apd.statement_tracing | "0" | PHP_INI_ALL | Available since apd 0.9.

Pro další detaily a definice konstant PHP_INI_*, viz dokumentace k ini_set().

Zde je stručný popis konfiguračních direktiv.

apd.dumpdir string

Sets the directory in which APD writes profile dump files. You can specify an absolute path or a relative path.

You can specify a different directory as an argument to apd_set_pprof_trace().

apd.statement_tracing boolean

Specfies whether or not to do per-line tracings. Turning this on (1) will impact the performance of your application.

Typy prostředků

Toto rozšíření nemá definován žádný typ prostředku (resource).

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

Tabulka 14. APD constants

Constant | Value | Description
FUNCTION_TRACE (integer) | 1 |
ARGS_TRACE (integer) | 2 |
ASSIGNMENT_TRACE (integer) | 4 |
STATEMENT_TRACE (integer) | 8 |
MEMORY_TRACE (integer) | 16 |
TIMING_TRACE (integer) | 32 |
SUMMARY_TRACE (integer) | 64 |
ERROR_TRACE (integer) | 128 |
PROF_TRACE (integer) | 256 |
APD_VERSION (string) | example: 1.0.2-dev |

How to use PHP-APD in your scripts

  1. As the first line of your PHP script, call the apd_set_pprof_trace() function to start the trace:

    apd_set_pprof_trace();

    You can insert the line anywhere in your script, but if you do not start tracing at the beginning of your script you discard profile data that might otherwise lead you to a performance bottleneck.

  2. Now run your script. The dump output will be written to apd.dumpdir/pprof_pid.ext.

    Tip

    If you're running the CGI version of PHP, you will need to add the '-e' flag to enable extended information for apd to work properly. For example: php -e -f script.php

  3. To display formatted profile data, issue the pprofp command with the sort and display options of your choice. The formatted output will look something like:

bash-2.05b$ pprofp -R /tmp/pprof.22141.0

Trace for /home/dan/testapd.php
Total Elapsed Time = 0.00
Total System Time  = 0.00
Total User Time    = 0.00

Real         User        System             secs/    cumm
%Time (excl/cumm)  (excl/cumm)  (excl/cumm) Calls    call    s/call  Memory Usage Name
--------------------------------------------------------------------------------------
100.0 0.00 0.00  0.00 0.00  0.00 0.00     1  0.0000   0.0009            0 main
56.9 0.00 0.00  0.00 0.00  0.00 0.00     1  0.0005   0.0005            0 apd_set_pprof_trace
28.0 0.00 0.00  0.00 0.00  0.00 0.00    10  0.0000   0.0000            0 preg_replace
14.3 0.00 0.00  0.00 0.00  0.00 0.00    10  0.0000   0.0000            0 str_replace

    The -R option used in this example sorts the profile table by the amount of real time the script spent executing a given function. The "cumm call" column reveals how many times each function was called, and the "s/call" column reveals how many seconds each call to the function required, on average.

  4. To generate a calltree file that you can import into the KCacheGrind profile analysis application, issue the pprof2calltree comand.

Contact information

If you have comments, bugfixes, enhancements or want to help developing this beast, you can send an mail to » apd@mail.communityconnect.com. Any help is very welcome.

Obsah

apd_breakpoint — Stops the interpreter and waits on a CR from the socket
apd_callstack — Returns the current call stack as an array
apd_clunk — Throw a warning and a callstack
apd_continue — Restarts the interpreter
apd_croak — Throw an error, a callstack and then exit
apd_dump_function_table — Outputs the current function table
apd_dump_persistent_resources — Return all persistent resources as an array
apd_dump_regular_resources — Return all current regular resources as an array
apd_echo — Echo to the debugging socket
apd_get_active_symbols — Get an array of the current variables names in the local scope
apd_set_pprof_trace — Starts the session debugging
apd_set_session_trace — Starts the session debugging
apd_set_session — Changes or sets the current debugging level
apd_set_socket_session_trace — Starts the remote session debugging
override_function — Overrides built-in functions
rename_function — Renames orig_name to new_name in the global function table
Předcházející | Nahoru | Další
apc_store | Domů | apd_breakpoint


apd_breakpoint

(PECL apd:0.2-1.0.1)

apd_breakpoint — Stops the interpreter and waits on a CR from the socket

Popis

bool apd_breakpoint ( int $debug_level )

This can be used to stop the running of your script, and await responses on the connected socket. To step the program, just send enter (a blank line), or enter a php command to be executed.

Seznam parametrů

debug_level

An integer which is formed by adding together the XXX_TRACE constants.

It is not recommended to use MEMORY_TRACE. It is very slow and does not appear to be accurate. ASSIGNMENT_TRACE is not implemented yet.

To turn on all functional traces (TIMING, FUNCTIONS, ARGS SUMMARY (like strace -c)) use the value 99

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 166. Typical session using tcplisten

bash#tcplisten localhost 7777

APD - Advanced PHP Debugger Trace File
---------------------------------------------------------------------------
Process Pid (6118)
Trace Begun at Sun Mar 10 23:13:12 2002
---------------------------------------------------------------------------
(  0.000000): apd_set_session_trace called at /home/alan/Projects/project2/test.
php:5
(  0.074824): apd_set_session_trace_socket() at /home/alan/Projects/project2/tes
t.php:5 returned.  Elapsed (0.074824)
(  0.074918): apd_breakpoint() /home/alan/Projects/project2/test.php:7
              ++ argv[0] $(??) = 9
apd_breakpoint() at /home/alan/Projects/project2/test.php:7 returned.  Elapsed (
-2089521468.1073275368)
>\n
statement: /home/alan/Projects/project2/test.php:8
>\n
statement: /home/alan/Projects/project2/test.php:8
>\n
statement: /home/alan/Projects/project2/test.php:10
>apd_echo($i);
EXEC: apd_echo($i);
0
>apd_echo(serialize(apd_get_active_symbols()));
EXEC:  apd_echo(serialize(apd_get_active_symbols()));
a:47:{i:0;s:4:"PWD";i:1;s:10:"COLORFGBG";i:2;s:11:"XAUTHORITY";i:3;s:14:"
COLORTERM_BCE";i:4;s:9:"WINDOWID";i:5;s:14:"ETERM_VERSION";i:6;s:16:"SE
SSION_MANAGER";i:7;s:4:"PS1";i:8;s:11:"GDMSESSION";i:9;s:5:"USER";i:10;s:5:"
MAIL";i:11;s:7:"OLDPWD";i:12;s:5:"LANG";i:13;s:10:"COLORTERM";i:14;s:8:"DISP
LAY";i:15;s:8:"LOGNAME";i:16;s:6:"
>apd_echo(system('ls /home/mydir'));
........
>apd_continue(0);

Předcházející | Nahoru | Další
IV. Advanced PHP debugger | Domů | apd_callstack


apd_callstack

(PECL apd:0.2-0.4)

apd_callstack — Returns the current call stack as an array

Popis

array apd_callstack ( void )

Returns the current call stack as an array

Návratové hodnoty

An array containing the current call stack.

Příklady

Příklad 167. apd_callstack() example

<?php
print_r(apd_callstack());
?>

Předcházející | Nahoru | Další
apd_breakpoint | Domů | apd_clunk


apd_clunk

(No version information available, might be only in CVS)

apd_clunk — Throw a warning and a callstack

Popis

void apd_clunk ( string $warning [, string $delimiter] )

Behaves like perl's Carp::cluck. Throw a warning and a callstack.

Seznam parametrů

warning

The warning to throw.

delimiter

The delimiter. Default to <BR />.

Návratové hodnoty

Nevrací se žádná hodnota.

Příklady

Příklad 168. apd_clunk() example

<?php
apd_clunk("Some Warning", "<br/>");
?>

Viz také

apd_croak()

Předcházející | Nahoru | Další
apd_callstack | Domů | apd_continue


apd_continue

(PECL apd:0.2-1.0.1)

apd_continue — Restarts the interpreter

Popis

bool apd_continue ( int $debug_level )

Usually sent via the socket to restart the interpreter.

Seznam parametrů

debug_level

An integer which is formed by adding together the XXX_TRACE constants.

It is not recommended to use MEMORY_TRACE. It is very slow and does not appear to be accurate. ASSIGNMENT_TRACE is not implemented yet.

To turn on all functional traces (TIMING, FUNCTIONS, ARGS SUMMARY (like strace -c)) use the value 99

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 169. apd_continue() example

<?php
apd_continue(0);
?>

Předcházející | Nahoru | Další
apd_clunk | Domů | apd_croak


apd_croak

(PECL apd:0.2-0.4)

apd_croak — Throw an error, a callstack and then exit

Popis

void apd_croak ( string $warning [, string $delimiter] )

Behaves like perl's Carp::croak. Throw an error, a callstack and then exit.

Seznam parametrů

warning

The warning to throw.

delimiter

The delimiter. Default to <BR />.

Návratové hodnoty

Nevrací se žádná hodnota.

Příklady

Příklad 170. apd_croak() example

<?php
apd_croak("Some Warning","<P>");
?>

Viz také

apd_clunk()

Předcházející | Nahoru | Další
apd_continue | Domů | apd_dump_function_table


apd_dump_function_table

(No version information available, might be only in CVS)

apd_dump_function_table — Outputs the current function table

Popis

void apd_dump_function_table ( void )

Outputs the current function table.

Návratové hodnoty

Nevrací se žádná hodnota.

Příklady

Příklad 171. apd_dump_function_table() example

<?php
apd_dump_function_table();
?>

Předcházející | Nahoru | Další
apd_croak | Domů | apd_dump_persistent_resources


apd_dump_persistent_resources

(PECL apd:0.2-0.4)

apd_dump_persistent_resources — Return all persistent resources as an array

Popis

array apd_dump_persistent_resources ( void )

Return all persistent resources as an array.

Návratové hodnoty

An array containing the current call stack.

Příklady

Příklad 172. apd_dump_persistent_resources() example

<?php
print_r(apd_dump_persistent_resources());
?>

Viz také

apd_dump_regular()

Předcházející | Nahoru | Další
apd_dump_function_table | Domů | apd_dump_regular_resources


apd_dump_regular_resources

(PECL apd:0.2-0.4)

apd_dump_regular_resources — Return all current regular resources as an array

Popis

array apd_dump_regular_resources ( void )

Return all current regular resources as an array.

Návratové hodnoty

An array containing the current regular resources.

Příklady

Příklad 173. apd_dump_regular_resources() example

<?php
print_r(apd_dump_regular_resources());
?>

Viz také

apd_dump_persistent_resources()

Předcházející | Nahoru | Další
apd_dump_persistent_resources | Domů | apd_echo


apd_echo

(PECL apd:0.2-1.0.1)

apd_echo — Echo to the debugging socket

Popis

bool apd_echo ( string $output )

Usually sent via the socket to request information about the running script.

Seznam parametrů

output

The debugged variable.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 174. apd_echo() example

<?php
apd_echo($i);
?>

Předcházející | Nahoru | Další
apd_dump_regular_resources | Domů | apd_get_active_symbols


apd_get_active_symbols

(PECL apd:0.2)

apd_get_active_symbols — Get an array of the current variables names in the local scope

Popis

array apd_get_active_symbols ( void )

Returns the names of all the variables defined in the active scope, (not their values).

Návratové hodnoty

A multidimensional array with all the variables.

Příklady

Příklad 175. apd_get_active_symbols() example

<?php
apd_echo(apd_get_active_symbols());
?>

Předcházející | Nahoru | Další
apd_echo | Domů | apd_set_pprof_trace


apd_set_pprof_trace

(PECL apd:0.2-1.0.1)

apd_set_pprof_trace — Starts the session debugging

Popis

string apd_set_pprof_trace ( [string $dump_directory [, string $fragment]] )

Starts debugging to pprof_{process_id} in the dump directory.

Seznam parametrů

dump_directory

The directory in which the profile dump file is written. If not set, the apd.dumpdir setting from the php.ini file is used.

fragment

Návratové hodnoty

Returns path of the destination file.

Příklady

Příklad 176. apd_set_pprof_trace() example

<?php
apd_set_pprof_trace();
?>

Viz také

apd_set_session_trace()

Předcházející | Nahoru | Další
apd_get_active_symbols | Domů | apd_set_session_trace


apd_set_session_trace

(PECL apd:0.2-0.4)

apd_set_session_trace — Starts the session debugging

Popis

void apd_set_session_trace ( int $debug_level [, string $dump_directory] )

Starts debugging to apd_dump_{process_id} in the dump directory.

Seznam parametrů

debug_level

An integer which is formed by adding together the XXX_TRACE constants.

It is not recommended to use MEMORY_TRACE. It is very slow and does not appear to be accurate. ASSIGNMENT_TRACE is not implemented yet.

To turn on all functional traces (TIMING, FUNCTIONS, ARGS SUMMARY (like strace -c)) use the value 99

dump_directory

The directory in which the profile dump file is written. If not set, the apd.dumpdir setting from the php.ini file is used.

Návratové hodnoty

Nevrací se žádná hodnota.

Příklady

Příklad 177. apd_set_session_trace() example

<?php
apd_set_session_trace(99);
?>

Předcházející | Nahoru | Další
apd_set_pprof_trace | Domů | apd_set_session


apd_set_session

(PECL apd:0.2-0.4)

apd_set_session — Changes or sets the current debugging level

Popis

void apd_set_session ( int $debug_level )

This can be used to increase or decrease debugging in a different area of your application.

Seznam parametrů

debug_level

An integer which is formed by adding together the XXX_TRACE constants.

It is not recommended to use MEMORY_TRACE. It is very slow and does not appear to be accurate. ASSIGNMENT_TRACE is not implemented yet.

To turn on all functional traces (TIMING, FUNCTIONS, ARGS SUMMARY (like strace -c)) use the value 99

Návratové hodnoty

Nevrací se žádná hodnota.

Příklady

Příklad 178. apd_set_session() example

<?php
apd_set_session(9);
?>

Předcházející | Nahoru | Další
apd_set_session_trace | Domů | apd_set_socket_session_trace


apd_set_socket_session_trace

(No version information available, might be only in CVS)

apd_set_socket_session_trace — Starts the remote session debugging

Popis

bool apd_set_socket_session_trace ( string $tcp_server, int $socket_type, int $port, int $debug_level )

Connects to the specified tcp_server (eg. tcplisten) and sends debugging data to the socket.

Seznam parametrů

tcp_server

IP or Unix Domain socket (like a file) of the TCP server.

socket_type

Can be AF_UNIX for file based sockets or APD_AF_INET for standard tcp/ip.

port

You can use any port, but higher numbers are better as most of the lower numbers may be used by other system services.

debug_level

An integer which is formed by adding together the XXX_TRACE constants.

It is not recommended to use MEMORY_TRACE. It is very slow and does not appear to be accurate. ASSIGNMENT_TRACE is not implemented yet.

To turn on all functional traces (TIMING, FUNCTIONS, ARGS SUMMARY (like strace -c)) use the value 99

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 179. apd_set_socket_session_trace() example

<?php
  apd_set_socket_session_trace("127.0.0.1",APD_AF_INET,7112,0);
?>

Předcházející | Nahoru | Další
apd_set_session | Domů | override_function


override_function

(PECL apd:0.2-1.0.1)

override_function — Overrides built-in functions

Popis

bool override_function ( string $function_name, string $function_args, string $function_code )

Overrides built-in functions by replacing them in the symbol table.

Seznam parametrů

function_name

The function to override.

function_args

The function arguments, as a coma separated string.

Usually you will want to pass this parameter, as well as the function_code parameter, as a single quote delimited string. The reason for using single quoted strings, is to protect the variable names from parsing, otherwise, if you use double quotes there will be a need to escape the variable names, e.g. \$your_var.

function_code

The new code for the function.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 180. override_function() example

<?php
override_function('test', '$a,$b', 'echo "DOING TEST"; return $a * $b;');
?>

Předcházející | Nahoru | Další
apd_set_socket_session_trace | Domů | rename_function


rename_function

(PECL apd:0.2-1.0.1)

rename_function — Renames orig_name to new_name in the global function table

Popis

bool rename_function ( string $original_name, string $new_name )

Renames a orig_name to new_name in the global function table. Useful for temporarily overriding built-in functions.

Seznam parametrů

original_name

The original function name.

new_name

The new name for the original_name function.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 181. rename_function() example

<?php
rename_function('mysql_connect', 'debug_mysql_connect' );
?>

Předcházející | Nahoru | Další
override_function | Domů | V. Funkce pro práci s poli


Funkce pro práci s poli

Předcházející VI. Reference funkcí Další

V. Funkce pro práci s poli

Úvod

Tyto funkce vám umožňují manipulovat a interagovat různými způsoby s poli. Pole jsou nezbytná pro ukládání a práci se sadami proměnných.

Podporována jsou jednoduchá a vícerozměrná pole; vytvářet se dají uživatelsky i jako výstup funkce. Existují databázové funkce na plnění polí výsledky databázových dotazů, a několik dalších funkcí vrací pole.

Viz také část manuálu pole pro detailní popis toho, jak jsou pole v PHP implementovány a jak se používají.

Požadavky

Tyto funkce jsou k dispozici jako součást standardního modulu, který je vždy dostupný.

Instalace

K používání těchto funkcí není třeba žádná instalace, jsou součástí jádra PHP.

Konfigurace běhu

Toto rozšíření nemá definováno žádné konfigurační direktivy.

Typy prostředků

Toto rozšíření nemá definován žádný typ prostředku (resource).

Předdefinované konstanty

Konstanty z tohoto seznamu jsou vždy dostupné jako součást jádra PHP.

CASE_LOWER (integer)
CASE_LOWER is used with array_change_key_case() and is used to convert array keys to lower case. This is also the default case for array_change_key_case().
CASE_UPPER (integer)
CASE_UPPER is used with array_change_key_case() and is used to convert array keys to upper case.

Sorting order flags:

SORT_ASC (integer)
SORT_ASC is used with array_multisort() to sort in ascending order.
SORT_DESC (integer)
SORT_DESC is used with array_multisort() to sort in descending order.

Sorting type flags: used by various sort functions

SORT_REGULAR (integer)
SORT_REGULAR is used to compare items normally.
SORT_NUMERIC (integer)
SORT_NUMERIC is used to compare items numerically.
SORT_STRING (integer)
SORT_STRING is used to compare items as strings.
SORT_LOCALE_STRING (integer)
SORT_LOCALE_STRING is used to compare items as strings, based on the current locale. Added in PHP 4.4.0 and 5.0.2.

COUNT_NORMAL (integer)
COUNT_RECURSIVE (integer)
EXTR_OVERWRITE (integer)
EXTR_SKIP (integer)
EXTR_PREFIX_SAME (integer)
EXTR_PREFIX_ALL (integer)
EXTR_PREFIX_INVALID (integer)
EXTR_PREFIX_IF_EXISTS (integer)
EXTR_IF_EXISTS (integer)
EXTR_REFS (integer)

Viz také

Viz také is_array(), explode(),
implode(), split(),
preg_split() a unset().

Obsah

array_change_key_case — Changes all keys in an array
array_chunk — Split an array into chunks
array_combine — Creates an array by using one array for keys and another for its values
array_count_values — Spočítat všechny hodnoty v poli
array_diff_assoc — Computes the difference of arrays with additional index check
array_diff_key — Computes the difference of arrays using keys for comparison
array_diff_uassoc — Computes the difference of arrays with additional index check which is performed by a user supplied callback function
array_diff_ukey — Computes the difference of arrays using a callback function on the keys for comparison
array_diff — Spočítat rozdíl polí
array_fill_keys — Fill an array with values, specifying keys
array_fill — Fill an array with values
array_filter — Filters elements of an array using a callback function
array_flip — Prohodit klíče a hodnoty pole
array_intersect_assoc — Computes the intersection of arrays with additional index check
array_intersect_key — Computes the intersection of arrays using keys for comparison
array_intersect_uassoc — Computes the intersection of arrays with additional index check, compares indexes by a callback function
array_intersect_ukey — Computes the intersection of arrays using a callback function on the keys for comparison
array_intersect — Spočítat průnik polí
array_key_exists — Checks if the given key or index exists in the array
array_keys — Vrátit všechny klíče pole
array_map — Applies the callback to the elements of the given arrays
array_merge_recursive — Rekurzivně sloučit dvě nebo více polí
array_merge — Sloučit dvě nebo více polí
array_multisort — Třídit více polí, nebo vícerozměrné pole
array_pad — Doplnit pole hodnotou na určenou délku
array_pop — Odstranit prvek z konce pole
array_product — Calculate the product of values in an array
array_push — Přidat jeden nebo více prvků na konec pole
array_rand — Vybrat náhodně jeden nebo více prvků pole
array_reduce — Iteratively reduce the array to a single value using a callback function
array_reverse — Vrátit pole s prvky v opačném pořadí
array_search — Searches the array for a given value and returns the corresponding key if successful
array_shift — Odstranit prvek ze začátku pole
array_slice — Vytáhnout část pole
array_splice — Odstranit část pole a nahradit ji něčím jiným
array_sum — Calculate the sum of values in an array
array_udiff_assoc — Computes the difference of arrays with additional index check, compares data by a callback function
array_udiff_uassoc — Computes the difference of arrays with additional index check, compares data and indexes by a callback function
array_udiff — Computes the difference of arrays by using a callback function for data comparison
array_uintersect_assoc — Computes the intersection of arrays with additional index check, compares data by a callback function
array_uintersect_uassoc — Computes the intersection of arrays with additional index check, compares data and indexes by a callback functions
array_uintersect — Computes the intersection of arrays, compares data by a callback function
array_unique — Odstranit z pole duplicitní hodnoty
array_unshift — Připojit jeden nebo více prvků na začátek pole
array_values — Vrátit všechny hodnoty v poli
array_walk_recursive — Apply a user function recursively to every member of an array
array_walk — Použít uživatelskou funkci na všechny prvky pole
array — Vytvořit pole
arsort — Třídit pole sestupně se zachováním klíčů
asort — Třídit pole se zachováním indexů
compact — Vytvořit pole obsahující proměnné a jejich hodnoty
count — Spočítat prvky v proměnné
current — Vrátit současný prvek pole
each — Vrací další klíč/hodnota pár z pole
end — Nastavit vnitřní ukazatel pole na jeho poslední prvek
extract — Importovat proměnné z pole do symbolové tabulky
in_array — Ověřit, zda v poli existuje daná hodnota
key — Fetch a key from an associative array
krsort — Třídit pole sestupně podle klíčů
ksort — Třídit pole podle klíčů
list — Přiřadit hodnoty přoměnným jako kdyby byly polem
natcasesort — Třídit pole s využitím algoritmu "přirozeného třídění" (case-insensitive)
natsort — Třídit pole s využitím algoritmu "přirozeného třídění"
next — Posunout interní ukazatel pole
pos — Získat současný prvek pole
prev — Rewind interní ukazatel pole
range — Vytvořit pole obsahující rozsah integerů
reset — Nastavit interní ukazatel pole na jeho první prvek
rsort — Třídit pole sestupně
shuffle — Zamíchat pole
sizeof — Zjistit počet prvků v poli
sort — Třídit pole
uasort — Třídit pole pomocí uživatelsky definované porovnávací funkce se zachováním klíčů
uksort — Třídit pole podle klíčů pomocí uživatelsky definovane porovnávací funkce
usort — Třídit pole podle hodnot pomocí uživatelsky definované porovnávací funkce
Předcházející | Nahoru | Další
rename_function | Domů | array_change_key_case


array_change_key_case

(PHP 4 >= 4.2.0, PHP 5)

array_change_key_case — Changes all keys in an array

Popis

array array_change_key_case ( array $input [, int $case] )

Returns an array with all keys from input lowercased or uppercased. Numbered indices are left as is.

Seznam parametrů

input

The array to work on

case

Either CASE_UPPER or CASE_LOWER (default)

Návratové hodnoty

Returns an array with its keys lower or uppercased, or false if input is not an array.

Errors/Exceptions

Throws E_WARNING if input is not an array.

Příklady

Příklad 182. array_change_key_case() example

<?php
$input_array = array("FirSt" => 1, "SecOnd" => 4);
print_r(array_change_key_case($input_array, CASE_UPPER));
?>

Výše uvedený příklad vypíše:

Array
(
    [FIRST] => 1
    [SECOND] => 4
)

Poznámky

Poznámka: If an array has indices that will be the same once run through this function (e.g. "keY" and "kEY"), the value that is later in the array will override other indices.

Předcházející | Nahoru | Další
V. Funkce pro práci s poli | Domů | array_chunk


array_chunk

(PHP 4 >= 4.2.0, PHP 5)

array_chunk — Split an array into chunks

Popis

array array_chunk ( array $input, int $size [, bool $preserve_keys] )

Chunks an array into size large chunks. The last chunk may contain less than size elements.

Seznam parametrů

input

The array to work on

size

The size of each chunk

preserve_keys

When set to TRUE keys will be preserved. Default is FALSE which will reindex the chunk numerically

Návratové hodnoty

Returns a multidimensional numerically indexed array, starting with zero, with each dimension containing size elements.

Errors/Exceptions

If size is less than 1 E_WARNING will be thrown and NULL returned.

Příklady

Příklad 183. array_chunk() example

<?php
$input_array = array('a', 'b', 'c', 'd', 'e');
print_r(array_chunk($input_array, 2));
print_r(array_chunk($input_array, 2, true));
?>

Výše uvedený příklad vypíše:

Array
(
    [0] => Array
        (
            [0] => a
            [1] => b
        )

    [1] => Array
        (
            [0] => c
            [1] => d
        )

    [2] => Array
        (
            [0] => e
        )

)
Array
(
    [0] => Array
        (
            [0] => a
            [1] => b
        )

    [1] => Array
        (
            [2] => c
            [3] => d
        )

    [2] => Array
        (
            [4] => e
        )

)

Předcházející | Nahoru | Další
array_change_key_case | Domů | array_combine


array_combine

(PHP 5)

array_combine — Creates an array by using one array for keys and another for its values

Popis

array array_combine ( array $keys, array $values )

Creates an array by using the values from the keys array as keys and the values from the values array as the corresponding values.

Seznam parametrů

keys

Array of keys to be used

values

Array of values to be used

Návratové hodnoty

Returns the combined array, FALSE if the number of elements for each array isn't equal or if the arrays are empty.

Errors/Exceptions

Throws E_WARNING if keys and values are either empty or the number of elements does not match.

Příklady

Příklad 184. A simple array_combine() example

<?php
$a = array('green', 'red', 'yellow');
$b = array('avocado', 'apple', 'banana');
$c = array_combine($a, $b);

print_r($c);
?>

Výše uvedený příklad vypíše:

Array
(
    [green]  => avocado
    [red]    => apple
    [yellow] => banana
)

Viz také

array_merge()
array_walk()
array_values()

Předcházející | Nahoru | Další
array_chunk | Domů | array_count_values


array_count_values

(PHP 4, PHP 5)

array_count_values — Spočítat všechny hodnoty v poli

Popis

array array_count_values ( array $input )

array_count_values() vrací pole používající hodnoty z input jako klíče a jejich četnosti v input jako hodnoty.

Příklad 185. Ukázka array_count_values()

$array = array (1, "hello", 1, "world", "hello");
array_count_values ($array); // vrací array(1=>2, "hello"=>2, "world"=>1)

Předcházející | Nahoru | Další
array_combine | Domů | array_diff_assoc


array_diff_assoc

(PHP 4 >= 4.3.0, PHP 5)

array_diff_assoc — Computes the difference of arrays with additional index check

Popis

array array_diff_assoc ( array $array1, array $array2 [, array $...] )

Compares array1 against array2 and returns the difference. Unlike array_diff() the array keys are used in the comparision.

Seznam parametrů

array1

The array to compare from

array2

An array to compare against

...

More arrays to compare against

Návratové hodnoty

Returns an array containing all the values from array1 that are not present in any of the other arrays.

Příklady

Příklad 186. array_diff_assoc() example

In this example you see the "a" => "green" pair is present in both arrays and thus it is not in the ouput from the function. Unlike this, the pair 0 => "red" is in the ouput because in the second argument "red" has key which is 1.

<?php
$array1 = array("a" => "green", "b" => "brown", "c" => "blue", "red");
$array2 = array("a" => "green", "yellow", "red");
$result = array_diff_assoc($array1, $array2);
print_r($result);
?>

Výše uvedený příklad vypíše:

Array
(
    [b] => brown
    [c] => blue
    [0] => red
)

Příklad 187. array_diff_assoc() example

Two values from key => value pairs are considered equal only if (string) $elem1 === (string) $elem2 . In other words a strict check takes place so the string representations must be the same.

<?php
$array1 = array(0, 1, 2);
$array2 = array("00", "01", "2");
$result = array_diff_assoc($array1, $array2);
print_r($result);
?>

Výše uvedený příklad vypíše:

Array
(
    [0] => 0
    [1] => 1
    )

Poznámky

Poznámka: This function only checks one dimension of a n-dimensional array. Of course you can check deeper dimensions by using, for example, array_diff_assoc($array1[0], $array2[0]);.

Viz také

array_diff()
array_intersect()
array_intersect_assoc()

Předcházející | Nahoru | Další
array_count_values | Domů | array_diff_key


array_diff_key

(PHP 5 >= 5.1.0)

array_diff_key — Computes the difference of arrays using keys for comparison

Popis

array array_diff_key ( array $array1, array $array2 [, array $...] )

Compares the keys from array1 against the keys from array2 and returns the difference. This function is like array_diff() except the comparison is done on the keys instead of the values.

Seznam parametrů

array1

The array to compare from

array2

An array to compare against

...

More arrays to compare against

Návratové hodnoty

Returns an array containing all the entries from array1 that are not present in any of the other arrays.

Příklady

Příklad 188. array_diff_key() example

The two keys from the key => value pairs are considered equal only if (string) $key1 === (string) $key2 . In other words a strict type check is executed so the string representation must be the same.

<?php
$array1 = array('blue'  => 1, 'red'  => 2, 'green'  => 3, 'purple' => 4);
$array2 = array('green' => 5, 'blue' => 6, 'yellow' => 7, 'cyan'   => 8);

var_dump(array_diff_key($array1, $array2));
?>

Výše uvedený příklad vypíše:

array(2) {
  ["red"]=>
  int(2)
  ["purple"]=>
  int(4)
}

Poznámky

Poznámka: This function only checks one dimension of a n-dimensional array. Of course you can check deeper dimensions by using array_diff_key($array1[0], $array2[0]);.

Viz také

array_diff()
array_udiff()
array_diff_assoc()
array_diff_uassoc()
array_udiff_assoc()
array_udiff_uassoc()
array_diff_ukey()
array_intersect()
array_intersect_assoc()
array_intersect_uassoc()
array_intersect_key()
array_intersect_ukey()

Předcházející | Nahoru | Další
array_diff_assoc | Domů | array_diff_uassoc


array_diff_uassoc

(PHP 5)

array_diff_uassoc — Computes the difference of arrays with additional index check which is performed by a user supplied callback function

Popis

array array_diff_uassoc ( array $array1, array $array2 [, array $..., callback $key_compare_func] )

Compares array1 against array2 and returns the difference. Unlike array_diff() the array keys are used in the comparision.

Unlike array_diff_assoc() an user supplied callback function is used for the indices comparision, not internal function.

Seznam parametrů

array1

The array to compare from

array2

An array to compare against

...

More arrays to compare against

key_compare_func

callback function to use. The callback function must return an integer less than, equal to, or greater than zero if the first argument is considered to be respectively less than, equal to, or greater than the second.

Návratové hodnoty

Returns an array containing all the entries from array1 that are not present in any of the other arrays.

Příklady

Příklad 189. array_diff_uassoc() example

The "a" => "green" pair is present in both arrays and thus it is not in the ouput from the function. Unlike this, the pair 0 => "red" is in the ouput because in the second argument "red" has key which is 1.

<?php
function key_compare_func($a, $b)
{
    if ($a === $b) {
        return 0;
    }
    return ($a > $b)? 1:-1;
}

$array1 = array("a" => "green", "b" => "brown", "c" => "blue", "red");
$array2 = array("a" => "green", "yellow", "red");
$result = array_diff_uassoc($array1, $array2, "key_compare_func");
print_r($result);
?>

Výše uvedený příklad vypíše:

Array
(
    [b] => brown
    [c] => blue
    [0] => red
)

The equality of 2 indices is checked by the user supplied callback function.

Poznámky

Poznámka: This function only checks one dimension of a n-dimensional array. Of course you can check deeper dimensions by using, for example, array_diff_uassoc($array1[0], $array2[0], "key_compare_func");.

Viz také

array_diff()
array_diff_assoc()
array_udiff()
array_udiff_assoc()
array_udiff_uassoc()
array_intersect()
array_intersect_assoc()
array_uintersect()
array_uintersect_assoc()
array_uintersect_uassoc()

Předcházející | Nahoru | Další
array_diff_key | Domů | array_diff_ukey


array_diff_ukey

(PHP 5 >= 5.1.0)

array_diff_ukey — Computes the difference of arrays using a callback function on the keys for comparison

Popis

array array_diff_ukey ( array $array1, array $array2 [, array $ ..., callback $key_compare_func] )

Compares the keys from array1 against the keys from array2 and returns the difference. This function is like array_diff() except the comparison is done on the keys instead of the values.

Unlike array_diff_key() an user supplied callback function is used for the indices comparision, not internal function.

Seznam parametrů

array1

The array to compare from

array2

An array to compare against

...

More arrays to compare against

key_compare_func

callback function to use. The callback function must return an integer less than, equal to, or greater than zero if the first argument is considered to be respectively less than, equal to, or greater than the second.

Návratové hodnoty

Returns an array containing all the entries from array1 that are not present in any of the other arrays.

Příklady

Příklad 190. array_diff_ukey() example

<?php
function key_compare_func($key1, $key2)
{
    if ($key1 == $key2)
        return 0;
    else if ($key1 > $key2)
        return 1;
    else
        return -1;
}

$array1 = array('blue'  => 1, 'red'  => 2, 'green'  => 3, 'purple' => 4);
$array2 = array('green' => 5, 'blue' => 6, 'yellow' => 7, 'cyan'   => 8);

var_dump(array_diff_ukey($array1, $array2, 'key_compare_func'));
?>

Výše uvedený příklad vypíše:

array(2) {
  ["red"]=>
  int(2)
  ["purple"]=>
  int(4)
}

Poznámky

Poznámka: This function only checks one dimension of a n-dimensional array. Of course you can check deeper dimensions by using array_diff_ukey($array1[0], $array2[0], 'callback_func');.

Viz také

array_diff()
array_udiff()
array_diff_assoc()
array_diff_uassoc()
array_udiff_assoc()
array_udiff_uassoc()
array_diff_key()
array_intersect()
array_intersect_assoc()
array_intersect_uassoc()
array_intersect_key()
array_intersect_ukey()

Předcházející | Nahoru | Další
array_diff_uassoc | Domů | array_diff


array_diff

(PHP 4 >= 4.0.1, PHP 5)

array_diff — Spočítat rozdíl polí

Popis

array array_diff ( array $array1, array $array2 [, array $ ...] )

array_diff() vrací pole obsahující všechny hodnoty z array1, které se nevyskytují v žádném z dalších argumentů. Klíče jsou zachovány.

Příklad 191. Ukázka array_diff()

$array1 = array ("a" => "green", "red", "blue");
$array2 = array ("b" => "green", "yellow", "red");
$result = array_diff ($array1, $array2);

$result obsahuje array ("blue");

Viz také: array_intersect().

Předcházející | Nahoru | Další
array_diff_ukey | Domů | array_fill_keys


array_fill

(PHP 4 >= 4.2.0, PHP 5)

array_fill — Fill an array with values

Popis

array array_fill ( int $start_index, int $num, mixed $value )

Fills an array with num entries of the value of the value parameter, keys starting at the start_index parameter.

Seznam parametrů

start_index

The first index of the returned array

num

Number of elements to insert

value

Values to use filling

Návratové hodnoty

Returns the filled array

Errors/Exceptions

Throws a E_WARNING if num is less than one.

Příklady

Příklad 193. array_fill() example

<?php
$a = array_fill(5, 6, 'banana');
print_r($a);
?>

Výše uvedený příklad vypíše:

Array
(
    [5]  => banana
    [6]  => banana
    [7]  => banana
    [8]  => banana
    [9]  => banana
    [10] => banana
)

Viz také

str_repeat()
range()

Předcházející | Nahoru | Další
array_fill_keys | Domů | array_filter


array_filter

(PHP 4 >= 4.0.6, PHP 5)

array_filter — Filters elements of an array using a callback function

Popis

array array_filter ( array $input [, callback $callback] )

Iterates over each value in the input array passing them to the callback function. If the callback function returns true, the current value from input is returned into the result array. Array keys are preserved.

Seznam parametrů

input

The array to iterate over

callback

The callback function to use

If no callback is supplied, all entries of input equal to FALSE (see converting to boolean) will be removed.

Návratové hodnoty

Returns the filtered array.

Příklady

Příklad 194. array_filter() example

<?php
function odd($var)
{
    return($var & 1);
}

function even($var)
{
    return(!($var & 1));
}

$array1 = array("a"=>1, "b"=>2, "c"=>3, "d"=>4, "e"=>5);
$array2 = array(6, 7, 8, 9, 10, 11, 12);

echo "Odd :\n";
print_r(array_filter($array1, "odd"));
echo "Even:\n";
print_r(array_filter($array2, "even"));
?>

Výše uvedený příklad vypíše:

Odd :
Array
(
    [a] => 1
    [c] => 3
    [e] => 5
)
Even:
Array
(
    [0] => 6
    [2] => 8
    [4] => 10
    [6] => 12
)

Příklad 195. array_filter() without callback

<?php

$entry = array(
             0 => 'foo',
             1 => false,
             2 => -1,
             3 => null,
             4 => ''
          );

print_r(array_filter($entry));
?>

Výše uvedený příklad vypíše:

Array
(
    [0] => foo
    [2] => -1
)

Poznámky

Výstraha

If the array is changed from the callback function (e.g. element added, deleted or unset) the behavior of this function is undefined.

Viz také

array_map()
array_reduce()
array_walk()

Předcházející | Nahoru | Další
array_fill | Domů | array_flip


array_flip

(PHP 4, PHP 5)

array_flip — Prohodit klíče a hodnoty pole

Popis

array array_flip ( array $trans )

array_flip() pole s prohozenými klíči a hodnotami.

Příklad 196. Ukázka array_flip()

$trans = array_flip ($trans);
$original = strtr ($str, $trans);

Předcházející | Nahoru | Další
array_filter | Domů | array_intersect_assoc


array_intersect_assoc

(PHP 4 >= 4.3.0, PHP 5)

array_intersect_assoc — Computes the intersection of arrays with additional index check

Popis

array array_intersect_assoc ( array $array1, array $array2 [, array $ ...] )

array_intersect_assoc() returns an array containing all the values of array1 that are present in all the arguments. Note that the keys are used in the comparison unlike in array_intersect().

Seznam parametrů

array1

The array with master values to check.

array2

An array to compare values against.

array

A variable list of arrays to compare.

Návratové hodnoty

Returns an associative array containing all the values in array1 that are present in all of the arguments.

Příklady

Příklad 197. array_intersect_assoc() example

<?php
$array1 = array("a" => "green", "b" => "brown", "c" => "blue", "red");
$array2 = array("a" => "green", "yellow", "red");
$result_array = array_intersect_assoc($array1, $array2);
print_r($result_array);
?>

Výše uvedený příklad vypíše:

Array
(
    [a] => green
)

In our example you see that only the pair "a" => "green" is present in both arrays and thus is returned. The value "red" is not returned because in $array1 its key is 0 while the key of "red" in $array2 is 1.

The two values from the key => value pairs are considered equal only if (string) $elem1 === (string) $elem2 . In other words a strict type check is executed so the string representation must be the same.

Viz také

array_intersect()
array_uintersect_assoc()
array_intersect_uassoc()
array_uintersect_uassoc()
array_diff()
array_diff_assoc()
Předcházející | Nahoru | Další
array_flip | Domů | array_intersect_key


array_intersect_key

(PHP 5 >= 5.1.0)

array_intersect_key — Computes the intersection of arrays using keys for comparison

Popis

array array_intersect_key ( array $array1, array $array2 [, array $ ...] )

array_intersect_key() returns an array containing all the values of array1 which have matching keys that are present in all the arguments.

Seznam parametrů

array1

The array with master keys to check.

array2

An array to compare keys against.

array

A variable list of arrays to compare.

Návratové hodnoty

Returns an associative array containing all the values of array1 which have matching keys that are present in all arguments.

Příklady

Příklad 198. array_intersect_key() example

<?php
$array1 = array('blue'  => 1, 'red'  => 2, 'green'  => 3, 'purple' => 4);
$array2 = array('green' => 5, 'blue' => 6, 'yellow' => 7, 'cyan'   => 8);

var_dump(array_intersect_key($array1, $array2));
?>

Výše uvedený příklad vypíše:

array(2) {
  ["blue"]=>
  int(1)
  ["green"]=>
  int(3)
}

In our example you see that only the keys 'blue' and 'green' are present in both arrays and thus returned. Also notice that the values for the keys 'blue' and 'green' differ between the two arrays. A match still occurs because only the keys are checked. The values returned are those of array1.

The two keys from the key => value pairs are considered equal only if (string) $key1 === (string) $key2 . In other words a strict type check is executed so the string representation must be the same.

Viz také

array_diff()
array_udiff()
array_diff_assoc()
array_diff_uassoc()
array_udiff_assoc()
array_udiff_uassoc()
array_diff_key()
array_diff_ukey()
array_intersect()
array_intersect_assoc()
array_intersect_uassoc()
array_intersect_ukey()

Předcházející | Nahoru | Další
array_intersect_assoc | Domů | array_intersect_uassoc


array_intersect_uassoc

(PHP 5)

array_intersect_uassoc — Computes the intersection of arrays with additional index check, compares indexes by a callback function

Popis

array array_intersect_uassoc ( array $array1, array $array2 [, array $ ..., callback $key_compare_func] )

array_intersect_uassoc() returns an array containing all the values of array1 that are present in all the arguments. Note that the keys are used in the comparison unlike in array_intersect().

The index comparison is done by a user supplied callback function. It must return an integer less than, equal to, or greater than zero if the first argument is considered to be respectively less than, equal to, or greater than the second.

Seznam parametrů

array1

Initial array for comparision of the arrays.

array2

First array to compare keys against.

array

Variable list of array arguments to compare values against.

key_compare_func

User supplied callback function to do the comparision.

Návratové hodnoty

Returns the values of array1 whose values exist in all of the arguments.

Příklady

Příklad 199. array_intersect_uassoc() example

<?php
$array1 = array("a" => "green", "b" => "brown", "c" => "blue", "red");
$array2 = array("a" => "GREEN", "B" => "brown", "yellow", "red");

print_r(array_intersect_uassoc($array1, $array2, "strcasecmp"));
?>

Výše uvedený příklad vypíše:

Array
(
    [b] => brown
)

Viz také

array_intersect()
array_intersect_assoc()
array_uintersect_assoc()
array_uintersect_uassoc()
array_intersect_key()
array_intersect_ukey()

Předcházející | Nahoru | Další
array_intersect_key | Domů | array_intersect_ukey


array_intersect_ukey

(PHP 5 >= 5.1.0)

array_intersect_ukey — Computes the intersection of arrays using a callback function on the keys for comparison

Popis

array array_intersect_ukey ( array $array1, array $array2 [, array $..., callback $key_compare_func] )

array_intersect_ukey() returns an array containing all the values of array1 which have matching keys that are present in all the arguments.

This comparison is done by a user supplied callback function. It must return an integer less than, equal to, or greater than zero if the first key is considered to be respectively less than, equal to, or greater than the second.

Seznam parametrů

array1

Initial array for comparision of the arrays.

array2

First array to compare keys against.

array

Variable list of array arguments to compare keys against.

key_compare_func

User supplied callback function to do the comparision.

Návratové hodnoty

Returns the values of array1 whose keys exist in all the arguments.

Příklady

Příklad 200. array_intersect_ukey() example

<?php
function key_compare_func($key1, $key2)
{
    if ($key1 == $key2)
        return 0;
    else if ($key1 > $key2)
        return 1;
    else
        return -1;
}

$array1 = array('blue'  => 1, 'red'  => 2, 'green'  => 3, 'purple' => 4);
$array2 = array('green' => 5, 'blue' => 6, 'yellow' => 7, 'cyan'   => 8);

var_dump(array_intersect_ukey($array1, $array2, 'key_compare_func'));
?>

Výše uvedený příklad vypíše:

array(2) {
  ["blue"]=>
  int(1)
  ["green"]=>
  int(3)
}

In our example you see that only the keys 'blue' and 'green' are present in both arrays and thus returned. Also notice that the values for the keys 'blue' and 'green' differ between the two arrays. A match still occurs because only the keys are checked. The values returned are those of array1.

Viz také

array_diff()
array_udiff()
array_diff_assoc()
array_diff_uassoc()
array_udiff_assoc()
array_udiff_uassoc()
array_diff_key()
array_diff_ukey()
array_intersect()
array_intersect_assoc()
array_intersect_uassoc()
array_intersect_key()

Předcházející | Nahoru | Další
array_intersect_uassoc | Domů | array_intersect


array_intersect

(PHP 4 >= 4.0.1, PHP 5)

array_intersect — Spočítat průnik polí

Popis

array array_intersect ( array $array1, array $array2 [, array $ ...] )

array_intersect() vrací pole obsahující všechny hodnoty z array1, které se vyskytují ve všech argumentech. Klíče jsou zachovány.

Příklad 201. Ukázka array_intersect()

$array1 = array ("a" => "green", "red", "blue");
$array2 = array ("b" => "green", "yellow", "red");
$result = array_intersect ($array1, $array2);

$result obsahuje array ("a" => "green", "red");

Viz také: array_diff().

Předcházející | Nahoru | Další
array_intersect_ukey | Domů | array_key_exists


array_key_exists

(PHP 4 >= 4.0.7, PHP 5)

array_key_exists — Checks if the given key or index exists in the array

Popis

bool array_key_exists ( mixed $key, array $search )

array_key_exists() returns TRUE if the given key is set in the array. key can be any value possible for an array index. array_key_exists() also works on objects.

Seznam parametrů

key

Value to check.

search

An array with keys to check.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 202. array_key_exists() example

<?php
$search_array = array('first' => 1, 'second' => 4);
if (array_key_exists('first', $search_array)) {
    echo "The 'first' element is in the array";
}
?>

Poznámka: The name of this function is key_exists() in PHP 4.0.6.

Příklad 203. array_key_exists() vs isset()

isset() does not return TRUE for array keys that correspond to a NULL value, while array_key_exists() does.

<?php
$search_array = array('first' => null, 'second' => 4);

// returns false
isset($search_array['first']);

// returns true
array_key_exists('first', $search_array);
?>

Viz také

isset()
array_keys()
in_array()

Předcházející | Nahoru | Další
array_intersect | Domů | array_keys


array_keys

(PHP 4, PHP 5)

array_keys — Vrátit všechny klíče pole

Popis

array array_keys ( array $input [, mixed $search_value [, bool $strict]] )

array_keys() vrací klíče, numerické i textové, z pole input.

Pokud je přítomen volitelný argument search_value, vrací pouze klíče této hodnoty. Jinak vrací všechny klíče z pole input.

Příklad 204. Ukázka array_keys()

$array = array (0 => 100, "color" => "red");
array_keys ($array);       // vrací array (0, "color")

$array = array ("blue", "red", "green", "blue", "blue");
array_keys ($array, "blue");  //  vrací array (0, 3, 4)

$array = array ("color" => array("blue", "red", "green"), "size" => array("small", "medium", "large"));
array_keys ($array);  //  vrací array ("color", "size")

Poznámka: Tato funkce byla přidána v PHP 4, dále je uvedena implementace pro ty, kteří stále používají PHP 3.

Příklad 205. Implementace array_keys() pro uživatele PHP 3

function array_keys ($arr, $term="") {
    $t = array();
    while (list($k,$v) = each($arr)) {
        if ($term && $v != $term)
            continue;
            $t[] = $k;
        }
        return $t;
}

Viz také: array_values().

Předcházející | Nahoru | Další
array_key_exists | Domů | array_map


array_map

(PHP 4 >= 4.0.6, PHP 5)

array_map — Applies the callback to the elements of the given arrays

Popis

array array_map ( callback $callback, array $arr1 [, array $...] )

array_map() returns an array containing all the elements of arr1 after applying the callback function to each one. The number of parameters that the callback function accepts should match the number of arrays passed to the array_map()

Seznam parametrů

callback

Callback function to run for each element in each array.

arr1

An array to run through the callback function.

array

Variable list of array arguments to run through the callback function.

Návratové hodnoty

Returns an array containing all the elements of arr1 after applying the callback function to each one.

Příklady

Příklad 206. array_map() example

<?php
function cube($n)
{
    return($n * $n * $n);
}

$a = array(1, 2, 3, 4, 5);
$b = array_map("cube", $a);
print_r($b);
?>

This makes $b have:

Array
(
    [0] => 1
    [1] => 8
    [2] => 27
    [3] => 64
    [4] => 125
)

Příklady

Příklad 207. array_map() - using more arrays

<?php
function show_Spanish($n, $m)
{
    return("The number $n is called $m in Spanish");
}

function map_Spanish($n, $m)
{
    return(array($n => $m));
}

$a = array(1, 2, 3, 4, 5);
$b = array("uno", "dos", "tres", "cuatro", "cinco");

$c = array_map("show_Spanish", $a, $b);
print_r($c);

$d = array_map("map_Spanish", $a , $b);
print_r($d);
?>

Výše uvedený příklad vypíše:

// printout of $c
Array
(
    [0] => The number 1 is called uno in Spanish
    [1] => The number 2 is called dos in Spanish
    [2] => The number 3 is called tres in Spanish
    [3] => The number 4 is called cuatro in Spanish
    [4] => The number 5 is called cinco in Spanish
)

// printout of $d
Array
(
    [0] => Array
        (
            [1] => uno
        )

    [1] => Array
        (
            [2] => dos
        )

    [2] => Array
        (
            [3] => tres
        )

    [3] => Array
        (
            [4] => cuatro
        )

    [4] => Array
        (
            [5] => cinco
        )

)

Usually when using two or more arrays, they should be of equal length because the callback function is applied in parallel to the corresponding elements. If the arrays are of unequal length, the shortest one will be extended with empty elements.

An interesting use of this function is to construct an array of arrays, which can be easily performed by using NULL as the name of the callback function

Příklad 208. Creating an array of arrays

<?php
$a = array(1, 2, 3, 4, 5);
$b = array("one", "two", "three", "four", "five");
$c = array("uno", "dos", "tres", "cuatro", "cinco");

$d = array_map(null, $a, $b, $c);
print_r($d);
?>

Výše uvedený příklad vypíše:

Array
(
    [0] => Array
        (
            [0] => 1
            [1] => one
            [2] => uno
        )

    [1] => Array
        (
            [0] => 2
            [1] => two
            [2] => dos
        )

    [2] => Array
        (
            [0] => 3
            [1] => three
            [2] => tres
        )

    [3] => Array
        (
            [0] => 4
            [1] => four
            [2] => cuatro
        )

    [4] => Array
        (
            [0] => 5
            [1] => five
            [2] => cinco
        )

)

Viz také

array_filter()
array_reduce()
array_walk()
create_function()
informace typu callback

Předcházející | Nahoru | Další
array_keys | Domů | array_merge_recursive


array_merge_recursive

(PHP 4 >= 4.0.1, PHP 5)

array_merge_recursive — Rekurzivně sloučit dvě nebo více polí

Popis

array array_merge_recursive ( array $array1 [, array $...] )

array_merge_recursive() sloučí prvky dvou nebo více polí tak, že hodnoty pole se připojí na konec předchozího pole. Vrací výsledné pole.

Pokud obsahují vstupní pole stejný textový klíč, hodnoty těchto klíčů se rekurzivně sloučí do pole tak, že pokud je jedna z hodnot sama pole, tato funkce ji také sloučí s odpovídající položkou z dalšího pole. Pokud ale tato pole mají stejný číselný klíč, pozdější hodnota nepřepíše tu dřívější, ale připojí se.

Příklad 209. Ukázka array_merge_recursive()

$ar1 = array ("color" => array ("favorite" => "red"), 5);
$ar2 = array (10, "color" => array ("favorite" => "green", "blue"));
$result = array_merge_recursive ($ar1, $ar2);

Výsledné pole bude array ("color" => array ("favorite" => array ("red", "green"), "blue"), 5, 10).

Viz také: array_merge().

Předcházející | Nahoru | Další
array_map | Domů | array_merge


array_merge

(PHP 4, PHP 5)

array_merge — Sloučit dvě nebo více polí

Popis

array array_merge ( array $array1 [, array $array2 [, array $...]] )

array_merge() sloučí prvky dvou nebo více polí dohromady tak, že hodnoty každého pole se připojí na konec předchozího. Vrací výsledné pole.

Pokud mají vstupní pole stejný textový klíč, pozdější hodnota přepíše dřívější hodnotu. Pokud ale mají stejný číselný klíč, pozdější hodnota tu púvodní nepřepíše, ale připojí se k ní.

Příklad 210. Ukázka array_merge()

$array1 = array ("color" => "red", 2, 4);
$array2 = array ("a", "b", "color" => "green", "shape" => "trapezoid", 4);
array_merge ($array1, $array2);

Výsledné pole bude array("color" => "green", 2, 4, "a", "b", "shape" => "trapezoid", 4).

Viz také: array_merge_recursive().

Předcházející | Nahoru | Další
array_merge_recursive | Domů | array_multisort


array_multisort

(PHP 4, PHP 5)

array_multisort — Třídit více polí, nebo vícerozměrné pole

Popis

bool array_multisort ( array $ar1 [, mixed $arg [, mixed $... [, array $...]]] )

array_multisort() se dá využít k třídění několika polí najednou nebo k třídění vícerozměrného pole XXX according by one of more dimensions. Při třídění udržuje asociace klíčů.

Vstupní pole jsou manipulována jako sloupce tabulky, která se má třídit podle řádků - připomíná to funkcionalitu SQL klauzule ORDER BY. První pole je to, podle kterého se bude třídit. Řádky (hodnoty) v tomto poli that compare the same are sorted by the next input array, and so on.

Struktura argumentů této funkce je trochu neobvyklá, ale pružná. První argument musí být pole. Každý další argument může být buď pole nebo jeden z příznak z následujících seznamů:

Příznaky směru třídění:

  • SORT_ASC - třídit vzestupně
  • SORT_DESC - třídit sestupně

Příznaky typu třídění:

  • SORT_REGULAR - porovnávat položky normálně
  • SORT_NUMERIC - porovnávat položky číselně
  • SORT_STRING - porovnávat položky jako řetězce

Po každém poli můžete specifikovat jeden příznak každého typu. Příznaky třídění specifikované po každém poli platí pouze pro toto pole - pro další pole se resetují na defaultní SORT_ASC a SORT_REGULAR.

Při úspěchu vrací TRUE, při selhání FALSE.

Příklad 211. Třídění více polí

$ar1 = array ("10", 100, 100, "a");
$ar2 = array (1, 3, "2", 1);
array_multisort ($ar1, $ar2);

V této ukázce bude po setřídění první pole obsahovat 10, "a", 100, 100. Druhé pole bude obsahovat 1, 1, 2, "3". Položky druhého pole odpovídající identickým položkám v prvním poli (100 a 100) byly také setříděny.

Příklad 212. Třídění vícerozměrného pole

$ar = array (array ("10", 100, 100, "a"), array (1, 3, "2", 1));
array_multisort ($ar[0], SORT_ASC, SORT_STRING,
                 $ar[1], SORT_NUMERIC, SORT_DESC);

V této ukázce bude po setřídění první pole obsahovat 10, 100, 100, "a" (bylo tříděno vzestupně jako řetězce) a druhé pole bude obsahovat 1, 3, "2", 1 (tříděno jako čísla, sestupně).

Předcházející | Nahoru | Další
array_merge | Domů | array_pad


array_pad

(PHP 4, PHP 5)

array_pad — Doplnit pole hodnotou na určenou délku

Popis

array array_pad ( array $input, int $pad_size, mixed $pad_value )

array_pad() vrací kopii pole input doplněnou na velikost pad_size hodnotou pad_value. Pokud je pad_size kladná, pole je doplněno zprava, pokud je negativní, zleva. Pokud je absolutní hodnota pad_size menší nebo rovna velikosti input, k doplnění nedojde.

Příklad 213. Ukázka array_pad()

$input = array (12, 10, 9);

$result = array_pad ($input, 5, 0);
// výsledek je array (12, 10, 9, 0, 0)

$result = array_pad ($input, -7, -1);
// výsledek je array (-1, -1, -1, -1, 12, 10, 9)

$result = array_pad ($input, 2, "noop");
// nedoplněno

Předcházející | Nahoru | Další
array_multisort | Domů | array_pop


array_pop

(PHP 4, PHP 5)

array_pop — Odstranit prvek z konce pole

Popis

mixed array_pop ( array &$array )

array_pop() odstraní a vrátí poslední hodnotu pole array, čímž ho zkrátí o jeden prvek.

Příklad 214. Ukázka array_pop()

$stack = array ("orange", "apple", "raspberry");
$fruit = array_pop ($stack);

$stack má teď pouze dva prvky: "orange" a "apple", a $fruit obsahuje "raspberry".

Viz také: array_push(),
array_shift() a
array_unshift().

Předcházející | Nahoru | Další
array_pad | Domů | array_product


array_push

(PHP 4, PHP 5)

array_push — Přidat jeden nebo více prvků na konec pole

Popis

int array_push ( array &$array, mixed $var [, mixed $...] )

array_push() připojuje předané proměnné na konec array. Délka array se zvětšuje o počet přidaných proměnných. Účinek je stejný jako: $array[] = $var; opakované pro každou var.

Vrací nový počet prvků v poli.

Příklad 216. Ukázka array_push()

$stack = array (1, 2);
array_push ($stack, "+", 3);

Výsledkem této ukázky by byl $stack obsahující 4 prvky: 1, 2, "+" a 3.

Viz také: array_pop(),
array_shift() a
array_unshift().

Předcházející | Nahoru | Další
array_product | Domů | array_rand


array_rand

(PHP 4, PHP 5)

array_rand — Vybrat náhodně jeden nebo více prvků pole

Popis

mixed array_rand ( array $input [, int $num_req] )

array_rand() je poměrně užitečná, když chcete z pole vybrat náhodně jednu nebo více hodnot. Přijímá pole input a volitelný argument num_req, který určuje, kolik položek chcete. Jeho defaultní hodnota je 1.

Pokud vybíráte pouze jednu položku, array_rand() vrací klíč náhodné položky. Jinak vrací pole klíčů náhodně vybraných položek. Takto můžete vybírat náhodně hodnoty i klíče.

Nezapomeňte inicializovat generátor náhodných čísel pomocí srand().

Příklad 217. Ukázka array_rand()

srand ((double) microtime() * 10000000);
$input = array ("Neo", "Morpheus", "Trinity", "Cypher", "Tank");
$rand_keys = array_rand ($input, 2);
print $input[$rand_keys[0]]."\n";
print $input[$rand_keys[1]]."\n";

Předcházející | Nahoru | Další
array_push | Domů | array_reduce


array_reduce

(PHP 4 >= 4.0.5, PHP 5)

array_reduce — Iteratively reduce the array to a single value using a callback function

Description

mixed array_reduce ( array $input, callback $function [, int $initial] )

array_reduce() applies iteratively the function function to the elements of the array input, so as to reduce the array to a single value. If the optional initial is available, it will be used at the beginning of the process, or as a final result in case the array is empty. If the array is empty and initial is not passed, array_reduce() returns NULL.

Příklad 218. array_reduce() example

<?php
function rsum($v, $w)
{
    $v += $w;
    return $v;
}

function rmul($v, $w)
{
    $v *= $w;
    return $v;
}

$a = array(1, 2, 3, 4, 5);
$x = array();
$b = array_reduce($a, "rsum");
$c = array_reduce($a, "rmul", 10);
$d = array_reduce($x, "rsum", 1);
?>

This will result in $b containing 15, $c containing 1200 (= 10*1*2*3*4*5), and $d containing 1.

See also array_filter(),
array_map(),
array_unique(), and
array_count_values().

Předcházející | Nahoru | Další
array_rand | Domů | array_reverse


array_reverse

(PHP 4, PHP 5)

array_reverse — Vrátit pole s prvky v opačném pořadí

Popis

array array_reverse ( array $array [, bool $preserve_keys] )

array_reverse() takes input array and returns a new array with the order of the elements reversed, preserving the keys if preserve_keys is TRUE.

Příklad 219. array_reverse() example

$input = array ("php", 4.0, array ("green", "red"));
$result = array_reverse ($input);
$result_keyed = array_reverse ($input, true);

$result teď obsahuje array (array ("green", "red"), 4.0, "php"). Ale $result2[0] je stále "php".

Poznámka: Druhý argument byl přidán v PHP 4.0.3.

Předcházející | Nahoru | Další
array_reduce | Domů | array_search


array_search

(PHP 4 >= 4.0.5, PHP 5)

array_search — Searches the array for a given value and returns the corresponding key if successful

Description

mixed array_search ( mixed $needle, array $haystack [, bool $strict] )

Searches haystack for needle and returns the key if it is found in the array, FALSE otherwise.

Poznámka: If needle is a string, the comparison is done in a case-sensitive manner.

Poznámka: Prior to PHP 4.2.0, array_search() returns NULL on failure instead of FALSE.

If the optional third parameter strict is set to TRUE then the array_search() will also check the types of the needle in the haystack.

If needle is found in haystack more than once, the first matching key is returned. To return the keys for all matching values, use array_keys() with the optional search_value parameter instead.

Příklad 220. array_search() example

<?php
$array = array(0 => 'blue', 1 => 'red', 2 => 'green', 3 => 'red');

$key = array_search('green', $array); // $key = 2;
$key = array_search('red', $array);   // $key = 1;
?>

Varování

Tato funkce může vracet booleovskou hodnotu FALSE, ale také nebooleovskou hodnotu odpovídající ohodnocení FALSE, například 0 nebo "". Čtěte prosím sekci o typu Boolean, kde najdete více informací. Pro testování návratové hodnoty této funkce použijte operátor ===.

See also array_keys(),
array_values(),
array_key_exists(), and
in_array().

Předcházející | Nahoru | Další
array_reverse | Domů | array_shift


array_shift

(PHP 4, PHP 5)

array_shift — Odstranit prvek ze začátku pole

Popis

mixed array_shift ( array &$array )

array_shift() vrací první položku array a odstraní ji, čímž zkrátí array o jeden prvek a ostatní posune dolů.

Příklad 221. Ukázka array_shift()

$args = array ("-v", "-f");
$opt = array_shift ($args);

$args teď má jeden prvek: "-f" a $opt je "-v".

Viz také: array_unshift(),
array_push() a
array_pop().

Předcházející | Nahoru | Další
array_search | Domů | array_slice


array_slice

(PHP 4, PHP 5)

array_slice — Vytáhnout část pole

Popis

array array_slice ( array $array, int $offset [, int $length [, bool $preserve_keys]] )

array_slice() vrací sekvenci prvků array určených argumenty offset a length.

Pokud je offset kladný, tato sekvence začne offset položek od začátku array. Pokud je offset záporný, tato sekvence začne tolik položek od konce array.

Pokud je length kladná, tato sekvence bude obsahovat tolik prvků. Pokud je length záporná, tato sekvence skončí tolik prvků od konce array. Pokud length vynecháte, tato sekvence bude obsahovat všechny prvky array od offset do konce.

Příklad 222. Ukázka array_slice()

$input = array ("a", "b", "c", "d", "e");

$output = array_slice ($input, 2);      // returns "c", "d", and "e"
$output = array_slice ($input, 2, -1);  // returns "c", "d"
$output = array_slice ($input, -2, 1);  // returns "d"
$output = array_slice ($input, 0, 3);   // returns "a", "b", and "c"

Viz také: array_splice().

Předcházející | Nahoru | Další
array_shift | Domů | array_splice


array_splice

(PHP 4, PHP 5)

array_splice — Odstranit část pole a nahradit ji něčím jiným

Popis

array array_splice ( array &$input, int $offset [, int $length [, array $replacement]] )

array_splice() odstraňuje prvky pole input určené argumenty offset a length, a případně je nahrazuje prvky volitelného argumentu (pole) replacement.

Pokud je offset kladný, tato odstraněná část začne offset položek od začátku array. Pokud je offset záporný, začne tolik položek od konce array.

Pokud vynecháte length, array_splice() odstraní všechno od offset do konce pole. Pokud je length kladná, odstraní se právě tolik prvků. Pokud je length záporná, konec odstraněné části bude právě tolik prvků od konce pole. Tip: k odstranění všech prvků od offset do konce pole při současně určeném argumentu replacement použijte jako length count($input).

Pokud zadáte replacement pole, odstraněné prvky se nahradí prvky tohoto pole. Pokud argumenty offset a length definovány tak, že se nic neodstraní, prvky pole replacement se vloží na místo určené argumentem offset. Tip: pokud je replacement jen jedna hodnota, není nutno ji umisťovat do array(), ledaže chcete, aby tato položka byla opravdu pole.

Následující volání jsou ekvivalentní:

array_push ($input, $x, $y)     array_splice ($input, count ($input), 0,
                                             array ($x, $y))
array_pop ($input)              array_splice ($input, -1)
array_shift ($input)            array_splice ($input, 0, 1)
array_unshift ($input, $x, $y)  array_splice ($input, 0, 0, array ($x, $y))
$a[$x] = $y                     array_splice ($input, $x, 1, $y)

Vrací pole odstraněných prvků.

Příklad 223. Ukázky array_splice()

$input = array ("red", "green", "blue", "yellow");

array_splice ($input, 2);      // $input is now array ("red", "green")
array_splice ($input, 1, -1);  // $input is now array ("red", "yellow")
array_splice ($input, 1, count($input), "orange");
                               // $input is now array ("red", "orange")
array_splice ($input, -1, 1, array("black", "maroon"));
                               // $input is now array ("red", "green",
                               //          "blue", "black", "maroon")

Viz také: array_slice().

Předcházející | Nahoru | Další
array_slice | Domů | array_sum


array_sum

(PHP 4 >= 4.0.4, PHP 5)

array_sum — Calculate the sum of values in an array

Description

number array_sum ( array $array )

array_sum() returns the sum of values in an array as an integer or float.

Příklad 224. array_sum() examples

<?php
$a = array(2, 4, 6, 8);
echo "sum(a) = " . array_sum($a) . "\n";

$b = array("a" => 1.2, "b" => 2.3, "c" => 3.4);
echo "sum(b) = " . array_sum($b) . "\n";
?>

Výše uvedený příklad vypíše:

sum(a) = 20
sum(b) = 6.9

Poznámka: PHP versions prior to 4.2.1 modified the passed array itself and converted strings to numbers (which most of the time converted them to zero, depending on their value).

Předcházející | Nahoru | Další
array_splice | Domů | array_udiff_assoc


array_udiff_assoc

(PHP 5)

array_udiff_assoc — Computes the difference of arrays with additional index check, compares data by a callback function

Description

array array_udiff_assoc ( array $array1, array $array2 [, array $ ..., callback $data_compare_func] )

array_udiff_assoc() returns an array containing all the values from array1 that are not present in any of the other arguments. Note that the keys are used in the comparison unlike array_diff() and array_udiff(). The comparison of arrays' data is performed by using an user-supplied callback. In this aspect the behaviour is opposite to the behaviour of array_diff_assoc() which uses internal function for comparison.

Příklad 225. array_udiff_assoc() example

<?php
class cr {
    private $priv_member;
    function cr($val)
    {
        $this->priv_member = $val;
    }

    function comp_func_cr($a, $b)
    {
        if ($a->priv_member === $b->priv_member) return 0;
        return ($a->priv_member > $b->priv_member)? 1:-1;
    }
}

$a = array("0.1" => new cr(9), "0.5" => new cr(12), 0 => new cr(23), 1=> new cr(4), 2 => new cr(-15),);
$b = array("0.2" => new cr(9), "0.5" => new cr(22), 0 => new cr(3), 1=> new cr(4), 2 => new cr(-15),);

$result = array_udiff_assoc($a, $b, array("cr", "comp_func_cr"));
print_r($result);
?>

Výše uvedený příklad vypíše:

Array
(
    [0.1] => cr Object
        (
            [priv_member:private] => 9
        )

    [0.5] => cr Object
        (
            [priv_member:private] => 12
        )

    [0] => cr Object
        (
            [priv_member:private] => 23
        )
)

In our example above you see the "1" => new cr(4) pair is present in both arrays and thus it is not in the ouput from the function.

For comparison is used the user supplied callback function. It must return an integer less than, equal to, or greater than zero if the first argument is considered to be respectively less than, equal to, or greater than the second.

Poznámka: Please note that this function only checks one dimension of a n-dimensional array. Of course you can check deeper dimensions by using, for example, array_udiff_assoc($array1[0], $array2[0], "some_comparison_func");.

See also
array_diff(),
array_diff_assoc(),
array_diff_uassoc(),
array_udiff(),
array_udiff_uassoc(),
array_intersect(),
array_intersect_assoc(),
array_uintersect(),
array_uintersect_assoc() and
array_uintersect_uassoc().

Předcházející | Nahoru | Další
array_sum | Domů | array_udiff_uassoc


array_udiff_uassoc

(PHP 5)

array_udiff_uassoc — Computes the difference of arrays with additional index check, compares data and indexes by a callback function

Description

array array_udiff_uassoc ( array $array1, array $array2 [, array $ ..., callback $data_compare_func, callback $key_compare_func] )

array_udiff_uassoc() returns an array containing all the values from array1 that are not present in any of the other arguments. Note that the keys are used in the comparison unlike array_diff() and array_udiff(). The comparison of arrays' data is performed by using an user-supplied callback : data_compare_func. In this aspect the behaviour is opposite to the behaviour of array_diff_assoc() which uses internal function for comparison. The comparison of keys (indices) is done also by the callback function key_compare_func. This behaviour is unlike what array_udiff_assoc() does, since the latter compares the indices by using an internal function.

Příklad 226. array_udiff_uassoc() example

<?php
class cr {
    private $priv_member;
    function cr($val)
    {
        $this->priv_member = $val;
    }

    function comp_func_cr($a, $b)
    {
        if ($a->priv_member === $b->priv_member) return 0;
        return ($a->priv_member > $b->priv_member)? 1:-1;
    }

    function comp_func_key($a, $b)
    {
        if ($a === $b) return 0;
        return ($a > $b)? 1:-1;
    }
}
$a = array("0.1" => new cr(9), "0.5" => new cr(12), 0 => new cr(23), 1=> new cr(4), 2 => new cr(-15),);
$b = array("0.2" => new cr(9), "0.5" => new cr(22), 0 => new cr(3), 1=> new cr(4), 2 => new cr(-15),);

$result = array_udiff_uassoc($a, $b, array("cr", "comp_func_cr"), array("cr", "comp_func_key"));
print_r($result);
?>

Výše uvedený příklad vypíše:

Array
(
    [0.1] => cr Object
        (
            [priv_member:private] => 9
        )

    [0.5] => cr Object
        (
            [priv_member:private] => 12
        )

    [0] => cr Object
        (
            [priv_member:private] => 23
        )
)

In our example above you see the "1" => new cr(4) pair is present in both arrays and thus it is not in the ouput from the function. Keep in mind that you have to supply 2 callback functions.

For comparison is used the user supplied callback function. It must return an integer less than, equal to, or greater than zero if the first argument is considered to be respectively less than, equal to, or greater than the second.

Poznámka: Please note that this function only checks one dimension of a n-dimensional array. Of course you can check deeper dimensions by using, for example, array_udiff_uassoc($array1[0], $array2[0], "data_compare_func", "key_compare_func");.

See also
array_diff(),
array_diff_assoc(),
array_diff_uassoc(),
array_udiff(),
array_udiff_assoc(),
array_intersect(),
array_intersect_assoc(),
array_uintersect(),
array_uintersect_assoc() and
array_uintersect_uassoc().

Předcházející | Nahoru | Další
array_udiff_assoc | Domů | array_udiff


array_udiff

(PHP 5)

array_udiff — Computes the difference of arrays by using a callback function for data comparison

Description

array array_udiff ( array $array1, array $array2 [, array $ ..., callback $data_compare_func] )

array_udiff() returns an array containing all the values of array1 that are not present in any of the other arguments. Note that keys are preserved. For the comparison of the data data_compare_func is used. It must return an integer less than, equal to, or greater than zero if the first argument is considered to be respectively less than, equal to, or greater than the second. This is unlike array_diff() which uses an internal function for comparing the data.

Příklad 227. array_udiff() example

<?php
class cr {
    private $priv_member;
    function cr($val)
    {
        $this->priv_member = $val;
    }

    function comp_func_cr($a, $b)
    {
        if ($a->priv_member === $b->priv_member) return 0;
        return ($a->priv_member > $b->priv_member)? 1:-1;
    }
}
$a = array("0.1" => new cr(9), "0.5" => new cr(12), 0 => new cr(23), 1=> new cr(4), 2 => new cr(-15),);
$b = array("0.2" => new cr(9), "0.5" => new cr(22), 0 => new cr(3), 1=> new cr(4), 2 => new cr(-15),);

$result = array_udiff($a, $b, array("cr", "comp_func_cr"));
print_r($result);
?>

Výše uvedený příklad vypíše:

Array
(
    [0.5] => cr Object
        (
            [priv_member:private] => 12
        )

    [0] => cr Object
        (
            [priv_member:private] => 23
        )

)

Poznámka: Please note that this function only checks one dimension of a n-dimensional array. Of course you can check deeper dimensions by using array_udiff($array1[0], $array2[0], "data_compare_func");.

See also
array_diff(),
array_diff_assoc(),
array_diff_uassoc(),
array_udiff_assoc(),
array_udiff_uassoc(),
array_intersect(),
array_intersect_assoc(),
array_uintersect(),
array_uintersect_assoc() and
array_uintersect_uassoc().

Předcházející | Nahoru | Další
array_udiff_uassoc | Domů | array_uintersect_assoc


array_uintersect_assoc

(PHP 5)

array_uintersect_assoc — Computes the intersection of arrays with additional index check, compares data by a callback function

Description

array array_uintersect_assoc ( array $array1, array $array2 [, array $ ..., callback $data_compare_func] )

array_uintersect_assoc() returns an array containing all the values of array1 that are present in all the arguments. Note that the keys are used in the comparison unlike in array_uintersect(). The data is compared by using a callback function.

Příklad 228. array_uintersect_assoc() example

<?php
$array1 = array("a" => "green", "b" => "brown", "c" => "blue", "red");
$array2 = array("a" => "GREEN", "B" => "brown", "yellow", "red");

print_r(array_uintersect_assoc($array1, $array2, "strcasecmp"));
?>

Výše uvedený příklad vypíše:

Array
(
    [a] => green
)

For comparison is used the user supplied callback function. It must return an integer less than, equal to, or greater than zero if the first argument is considered to be respectively less than, equal to, or greater than the second.

See also array_uintersect(),
array_intersect_assoc(),
array_intersect_uassoc() and
array_uintersect_uassoc().

Předcházející | Nahoru | Další
array_udiff | Domů | array_uintersect_uassoc


array_uintersect_uassoc

(PHP 5)

array_uintersect_uassoc — Computes the intersection of arrays with additional index check, compares data and indexes by a callback functions

Description

array array_uintersect_uassoc ( array $array1, array $array2 [, array $ ..., callback $data_compare_func, callback $key_compare_func] )

array_uintersect_uassoc() returns an array containing all the values of array1 that are present in all the arguments. Note that the keys are used in the comparison unlike in array_uintersect(). Both the data and the indexes are compared by using separate callback functions.

Příklad 229. array_uintersect_uassoc() example

<?php
$array1 = array("a" => "green", "b" => "brown", "c" => "blue", "red");
$array2 = array("a" => "GREEN", "B" => "brown", "yellow", "red");

print_r(array_uintersect_uassoc($array1, $array2, "strcasecmp", "strcasecmp"));
?>

Výše uvedený příklad vypíše:

Array
(
    [a] => green
    [b] => brown
)

For comparison is used the user supplied callback function. It must return an integer less than, equal to, or greater than zero if the first argument is considered to be respectively less than, equal to, or greater than the second.

See also array_uintersect(),
array_intersect_assoc(),
array_intersect_uassoc() and
array_uintersect_assoc().

Předcházející | Nahoru | Další
array_uintersect_assoc | Domů | array_uintersect


array_uintersect

(PHP 5)

array_uintersect — Computes the intersection of arrays, compares data by a callback function

Description

array array_uintersect ( array $array1, array $array2 [, array $ ..., callback $data_compare_func] )

array_uintersect() returns an array containing all the values of array1 that are present in all the arguments. The data is compared by using a callback function.

Příklad 230. array_uintersect() example

<?php
$array1 = array("a" => "green", "b" => "brown", "c" => "blue", "red");
$array2 = array("a" => "GREEN", "B" => "brown", "yellow", "red");

print_r(array_uintersect($array1, $array2, "strcasecmp"));
?>

Výše uvedený příklad vypíše:

Array
(
    [a] => green
    [b] => brown
    [0] => red
)

For comparison is used the user supplied callback function. It must return an integer less than, equal to, or greater than zero if the first argument is considered to be respectively less than, equal to, or greater than the second.

See also array_intersect(),
array_uintersect_assoc(),
array_intersect_uassoc() and
array_uintersect_uassoc().

Předcházející | Nahoru | Další
array_uintersect_uassoc | Domů | array_unique


array_unique

(PHP 4 >= 4.0.1, PHP 5)

array_unique — Odstranit z pole duplicitní hodnoty

Popis

array array_unique ( array $array )

array_unique() přijímá pole array a vrací nové pole bez duplicitních hodnot. Klíče jsou zachovány.

Příklad 231. Ukázka array_unique()

$input = array ("a" => "green", "red", "b" => "green", "blue", "red");
$result = array_unique ($input);

$result teď obsahuje array ("a" => "green", "red", "blue");.

Předcházející | Nahoru | Další
array_uintersect | Domů | array_unshift


array_unshift

(PHP 4, PHP 5)

array_unshift — Připojit jeden nebo více prvků na začátek pole

Popis

int array_unshift ( array &$array, mixed $var [, mixed $...] )

array_unshift() připojí předané prvky na začátek array. Všechny prvky jsou přidány jako celek, čili přidané prvky si zachovávají pořadí.

vrací nový počet prvků v array.

Příklad 232. Ukázka array_unshift()

$queue = array ("p1", "p3");
array_unshift ($queue, "p4", "p5", "p6");

$queue bude mít 5 prvků: "p4", "p5", "p6", "p1" a "p3".

Viz také: array_shift(),
array_push() a
array_pop().

Předcházející | Nahoru | Další
array_unique | Domů | array_values


array_values

(PHP 4, PHP 5)

array_values — Vrátit všechny hodnoty v poli

Popis

array array_values ( array $input )

array_values() vrací všechny hodnoty pole input v poli s číselnými indexy.

Příklad 233. Ukázka array_values()

<?php
$array = array("size" => "XL", "color" => "gold");
print_r(array_values($array));
?>

Výsledek:

Array
(
    [0] => XL
    [1] => gold
)

Viz také array_keys().

Předcházející | Nahoru | Další
array_unshift | Domů | array_walk_recursive


array_walk_recursive

(PHP 5)

array_walk_recursive — Apply a user function recursively to every member of an array

Description

bool array_walk_recursive ( array &$input, callback $funcname [, mixed $userdata] )

Applies the user-defined function funcname to each element of the input array. This function will recur into deeper arrays. Typically, funcname takes on two parameters. The input parameter's value being the first, and the key/index second. If the optional userdata parameter is supplied, it will be passed as the third parameter to the callback funcname.

Vrací TRUE při úspěchu, FALSE při selhání.

Poznámka: If funcname needs to be working with the actual values of the array, specify the first parameter of funcname as a reference. Then, any changes made to those elements will be made in the original array itself.

Příklad 234. array_walk_recursive() example

<?php
$sweet = array('a' => 'apple', 'b' => 'banana');
$fruits = array('sweet' => $sweet, 'sour' => 'lemon');

function test_print($item, $key)
{
    echo "$key holds $item\n";
}

array_walk_recursive($fruits, 'test_print');
?>

Výše uvedený příklad vypíše:

a holds apple
b holds banana
sour holds lemon

You may notice that the key 'sweet' is never displayed. Any key that holds an array will not be passed to the function.

See also array_walk(), and informace typu callback.

Předcházející | Nahoru | Další
array_values | Domů | array_walk


array_walk

(PHP 4, PHP 5)

array_walk — Použít uživatelskou funkci na všechny prvky pole

Popis

bool array_walk ( array &$array, callback $funcname [, mixed $userdata] )

Aplikuje funkci func na všechny prvky pole arr. Funkci func se jako první argument předá hodnota a jako druhý klíč. Pokud je přítomen argument userdata, bude uživatelské funkci předán jako třetí argument.

Pokud func vyžaduje více než dva nebo tři argumenty (v závislosti na userdata), pro každé volání func z array_walk() se vygeneruje varování. Tato varování se dají potlačit přidáním znaku '@' před volání array_walk() nebo pomocí error_reporting().

Poznámka: Pokud func potřebuje pracovat přímo s daným polem, první argument func se musí předávat odkazem. Všechny změny těchto hodnot se pak promítnou přímo v arr.

Poznámka: Druhý a třetí argument func byly přidány v PHP 4.0.

V PHP 4 je třeba volat podle potřeby reset(), protože array_walk() sama vstupní pole neresetuje.

Příklad 235. Ukázka array_walk()

$fruits = array ("d"=>"lemon", "a"=>"orange", "b"=>"banana", "c"=>"apple");

function test_alter (&$item1, $key, $prefix) {
    $item1 = "$prefix: $item1";
}

function test_print ($item2, $key) {
    echo "$key. $item2<br>\n";
}

array_walk ($fruits, 'test_print');
reset ($fruits);
array_walk ($fruits, 'test_alter', 'fruit');
reset ($fruits);
array_walk ($fruits, 'test_print');

Viz také: each() a list().

Předcházející | Nahoru | Další
array_walk_recursive | Domů | array


array

(PHP 4, PHP 5)

array — Vytvořit pole

Popis

array array ( [mixed $...] )

Vrací pole argumentů. Argumentům může být přiřazen index pomocí operátoru =>. Viz část o typu pole pro bližší vysvětlení toho, co to pole je.

Poznámka: array() je jazykový konstrukt používaný k reprezentaci polí, nikoliv běžná funkce.

Syntaxe "index => hodnota", s čárkou jako oddělovačem, definuje indexy a hodnoty. Index může být řetězec nebo číslo. Pokud se index vynechá, automaticky se generuje číselný index začínající na 0. Pokud je index integer, další generovaný index bude nejvyšší celočíselný index + 1. Pozn.: pokud jsou definovány dva identické indexy, první se přepíše posledním.

Následující ukázka demonstruje jak vytvořit dvourozměrné pole, jak určit klíče v asociativních polích, a jak přeskakovat číselné indexy v normálních polích.

Příklad 236. Ukázka array()

<?php
$ovoce = array (
    "fruits"  => array("a" => "pomeranč", "b" => "banán", "c" => "jablko"),
    "numbers" => array(1, 2, 3, 4, 5, 6),
    "holes"   => array("první", 5 => "druhý", "třetí")
)
?>

Příklad 237. Automatický index a array()

<?php
$array = array(1, 1, 1, 1,  1, 8 => 1,  4 => 1, 19, 3 => 13);
print_r($array);
?>

výstup bude následující:

Array
(
    [0] => 1
    [1] => 1
    [2] => 1
    [3] => 13
    [4] => 1
    [8] => 1
    [9] => 19
)
Index 3 je definován dvakrát, a podrží si poslední hodnotu 13. Index 4 je definován po indexu 8 a další generovaný index (hodnota 19) je 9, protože nejvyšší index byl 8.

Tato ukázka vytvoří pole číslované od 1.

Příklad 238. Index začínající 1 s array()

<?php
$prvni_kvartal = array(1 => 'leden', 'únor', 'březen');
print_r($prvni_kvartal);
?>

toto bude výstup:

Array
(
    [1] => leden
    [2] => únor
    [3] => březen
)

Viz také array_pad(), list(), foreach a range().

Předcházející | Nahoru | Další
array_walk | Domů | arsort


arsort

(PHP 4, PHP 5)

arsort — Třídit pole sestupně se zachováním klíčů

Popis

bool arsort ( array &$array [, int $sort_flags] )

arsort() třídí pole tak, že indexy pole si zachovávají korelace s prvky, se kterými jsou asociovány. Toto je užitečné hlavně při třídění asociativních polí, kde je pořadí prvků signifikantní.

Příklad 239. Ukázka arsort()

$fruits = array ("d"=>"lemon", "a"=>"orange", "b"=>"banana", "c"=>"apple");
arsort ($fruits);
reset ($fruits);
while (list ($key, $val) = each ($fruits)) {
    echo "$key = $val\n";
}

Tato ukázka zobrazí:

fruits[a] = orange
fruits[d] = lemon
fruits[b] = banana
fruits[c] = apple

Ovoce bylo sestupně setříděno podle abecedy, a indexy asociované s jednotlivými prvky byly zachovány.

Chování třídění můžete upravit pomocí volitelného argumentu sort_flags, detaily viz sort().

Viz také: asort(),
rsort(),
ksort() a
sort().

Předcházející | Nahoru | Další
array | Domů | asort


asort

(PHP 4, PHP 5)

asort — Třídit pole se zachováním indexů

Popis

bool asort ( array &$array [, int $sort_flags] )

asort() třídí pole tak, že si indexy zachovají corelace s prvky, se kterými jsou spojeny. To je užitečné hlavně při třídění asociativních polí, u kterých je pořadí prvků signifikantní.

Příklad 240. Ukázka asort()

$fruits = array ("d"=>"lemon", "a"=>"orange", "b"=>"banana", "c"=>"apple");
asort ($fruits);
reset ($fruits);
while (list ($key, $val) = each ($fruits)) {
    echo "$key = $val\n";
}

Tato ukázka zobrazí:

fruits[c] = apple
fruits[b] = banana
fruits[d] = lemon
fruits[a] = orange

Ovoce bylo setříděno podle abecedy a indexy spojené s jednotlivými prvky byly zachovány.

Chování třídění můžete upravit pomocí volitelného argumentu sort_flags, detaily viz sort().

Viz také: arsort(),
rsort(),
ksort() a
sort().

Předcházející | Nahoru | Další
arsort | Domů | compact


compact

(PHP 4, PHP 5)

compact — Vytvořit pole obsahující proměnné a jejich hodnoty

Popis

array compact ( mixed $varname [, mixed $...] )

compact() přijímá proměnný počet argumentů. Každý argument může být buď řetězec obsahující název proměnné nebo pole názvů proměnných. Toto pole může také obsahovat pole názvů proměnnýchů; compact() je rekurzivně zpracuje.

Pro každý z řetězců compact() vyhledá v aktivní symbolové tabulce proměnnou tohoto jména a přidá ji do výsledného pole tak, že název této proměnné se stane klíčem a obsah této proměnné hodnotou tohoto klíče. Stručně řečeno, dělá pravý opak toho, co extract(). Vrací pole obsahující všechny tyto proměnné.

Řetězce, které neobsahují názvy platných proměnných se přeskočí.

Příklad 241. Ukázka compact()

$city = "San Francisco";
$state = "CA";
$event = "SIGGRAPH";

$location_vars = array ("city", "state");

$result = compact ("event", "nothing_here", $location_vars);

$result bude array ("event" => "SIGGRAPH", "city" => "San Francisco", "state" => "CA").

Viz také: extract().

Předcházející | Nahoru | Další
asort | Domů | count


count

(PHP 4, PHP 5)

count — Spočítat prvky v proměnné

Popis

int count ( mixed $var [, int $mode] )

Vrací počet prvků v var, která je typicky pole (jelikož všechno ostatní má jeden prvek).

Vrací 1, pokud var není pole (výjimka: count(NULL) je 0).

Pokud je volitelný parametr mode nastaven na COUNT_RECURSIVE (nebo 1), tak funkce count() spočítá pole rekurzivně. To je obzvláště užitečné pro spočítání všech prvků vícerozměrného pole. Výchozí hodota parametru mode je 0.

Výstraha

count() vrací 0 pro proměnné, které nejsou inicializovány, ale vrací také 0 pro proměnné, které obsahují prázdné pole. Pokud potřebujete zjistit, jestli dotyčná proměnná existuje, použijte isset().

Bližší vysvětlení toho, jak jsou v PHP implementována a používána pole, najdete v části Pole

Příklad 242. Ukázka count()

<?php
$a[0] = 1;
$a[1] = 3;
$a[2] = 5;
$result = count($a);
// $result == 3

$b[0]  = 7;
$b[5]  = 9;
$b[10] = 11;
$result = count($b);
// $result == 3;
?>

Příklad 243. příklad na rekurzivní count() (PHP >= 4.2.0)

<?php
$jidlo = array('ovoce' => array('pomeranč', 'banán', 'jablko'),
              'zelenina' => array('mrkev', 'petržel', 'hrášek'));

// rekurzivní počet
echo count($jidlo, COUNT_RECURSIVE);  // vypíše 8

// normálí počet
echo count($jidlo);                  // vypíše 2

?>

Poznámka: Funkce sizeof() je alias funkce count().

Viz také is_array(),
isset() a
strlen().

Předcházející | Nahoru | Další
compact | Domů | current


current

(PHP 4, PHP 5)

current — Vrátit současný prvek pole

Popis

mixed current ( array &$array )

Každé pole má vnitřní ukazatel na jeho "současny" prvek, který se inicializuje na první prvek vložený do tohoto pole.

current() vrací prvek, na který tento interní ukazatel právě ukazuje. Nijak tento ukazatel nemění. Pokud teto vnitřní ukazatel ukazuje za konec seznamu prvků, current() returns FALSE.

Varování

Pokud toto pole obsahuje prázdné prvky (0 nebo "", prázdný řetězec), tato funkce pro tyto prvky také vrátí FALSE. Je proto nemožné určit pomocí current(), jestli jste opravdu na konci pole. To properly traverse an array that may contain empty elements, use the each() function.

Viz také: end(),
next(),
prev() a
reset().

Předcházející | Nahoru | Další
count | Domů | each


each

(PHP 4, PHP 5)

each — Vrací další klíč/hodnota pár z pole

Popis

array each ( array &$array )

Vrací současný klíč/hodnota pár z pole array a posune interní ukazatel pole. Tento pár se vrací jako pole čtyř prvků s klíči 0, 1, key a value. Prvky 0 a key obsahují název klíče tohoto prvku pole a 1 a value obsahují hodnotu.

Pokud interní ukazatel pole ukazuje za konec tohoto pole, each() vrací FALSE.

Příklad 244. Ukázky each()

$foo = array ("bob", "fred", "jussi", "jouni", "egon", "marliese");
$bar = each ($foo);

$bar teď obsahuje následující klíč/hodnota páry:

  • 0 => 0
  • 1 => 'bob'
  • key => 0
  • value => 'bob'

$foo = array ("Robert" => "Bob", "Seppo" => "Sepi");
$bar = each ($foo);

$bar teď obsahuje následující klíč/hodnota páry:

  • 0 => 'Robert'
  • 1 => 'Bob'
  • key => 'Robert'
  • value => 'Bob'

each() se většinou používa s list() k průchodu polem, např. $HTTP_POST_VARS:

Příklad 245. Průchod $HTTP_POST_VARS pomocí each()

echo "Hodnoty odeslané metodou POST:<br>";
reset ($HTTP_POST_VARS);
while (list ($key, $val) = each ($HTTP_POST_VARS)) {
    echo "$key => $val<br>";
}

Poté, co proběhne each(), se interní ukazatel pole posune na další prvek pole nebo zůstane na posledním prvku pole, pokud dojde na konec.

Viz také: key(),
list(),
current(),
reset(),
next() a
prev().

Předcházející | Nahoru | Další
current | Domů | end


end

(PHP 4, PHP 5)

end — Nastavit vnitřní ukazatel pole na jeho poslední prvek

Popis

mixed end ( array &$array )

end() posune vnitřní ukazatel pole array na jeho poslední prvek a vrací tento prvek.

Viz také: current(),
each(),
end(),
next() a
reset().

Předcházející | Nahoru | Další
each | Domů | extract


extract

(PHP 4, PHP 5)

extract — Importovat proměnné z pole do symbolové tabulky

Popis

int extract ( array $var_array [, int $extract_type [, string $prefix]] )

Tato funkce se používá k importu proměnných z pole do aktivní symbolové tabulky. Přijímá pole var_array; z klíčů vytváří názvy proměnných a z hodnot hodnoty těchto proměnných. Vytváří jednu proměnnou z každého klíč/hodnota páru (s ohledem na argumenty extract_type a prefix).

Poznámka: Od PHP 4.0.5 tato funkce vrací počet extrahovaných proměnných.

extract() ověřuje, jestli všechny klíče tvoří platné názvy proměnných, a také jestli nekolidují s proměnnými existujícími v aktivní symbolové tabulce. Způsob, jakým se nakládá s neplatnými/numerickými klíči a kolizemi závisí na extract_type. Ten může mít jednu z následujících hodnot.

EXTR_OVERWRITE
Pokud existuje kolize, přepsat existující proměnnou.
EXTR_SKIP
Pokud existuje kolize, nepřepsat existující proměnnou.
EXTR_PREFIX_SAME
Pokud existuje kolize, předřadit před název nové proměnné prefix.
EXTR_PREFIX_ALL
Opatřit prefixem prefix všechny názvy proměnných. Od PHP 4.0.5 toto zahrnuje i číselné indexy.
EXTR_PREFIX_INVALID
Prefixem prefix opatřit pouze neplatné/číselné názvy proměnných. Tento příznak byl přidán v PHP 4.0.5.

Defaultní extract_type je EXTR_OVERWRITE.

Pozn.: prefix se vyžaduje pouze pokud je extract_type EXTR_PREFIX_SAME, EXTR_PREFIX_ALL nebo EXTR_PREFIX_INVALID. Pokud výsledný název (vč. prefixu) není platný název proměnné, nenaimportuje se do symbolové tabulky.

extract() vrací počet proměnných úspěšně naimportovaných do symbolové tabulky.

Možné využití extract() je import proměnných do symbolové tabulky z asociativního pole vráceného wddx_deserialize().

Příklad 246. Ukázka extract()

<?php

/* Předpokládejme, že $var_array je pole vrácené
   z wddx_deserialize */

$size = "large";
$var_array = array ("color" => "blue",
                    "size"  => "medium",
                    "shape" => "sphere");
extract ($var_array, EXTR_PREFIX_SAME, "wddx");

print "$color, $size, $shape, $wddx_size\n";

?>

Výše uvedená ukázka vytiskne:

blue, large, sphere, medium

$size se nepřepsala, protože bylo specifikováno EXTR_PREFIX_SAME, tudíž se vytvořila proměnná $wddx_size. Pokud by bylo zadáno EXTR_SKIP, nevytvořila by se ani $wddx_size. EXTR_OVERWRITE by způsobilo přepsání hodnoty $size na "medium", a EXTR_PREFIX_ALL by vytvořilo nové proměnné pojmenované $wddx_color, $wddx_size a $wddx_shape.

U PHP verzí nižších než 4.0.5 musíte použít asociativní pole.

Viz také: compact().

Předcházející | Nahoru | Další
end | Domů | in_array


in_array

(PHP 4, PHP 5)

in_array — Ověřit, zda v poli existuje daná hodnota

Popis

bool in_array ( mixed $needle, array $haystack [, bool $strict] )

Hledá v haystack hodnotu needle a pokud ji najde, vrací TRUE, jinak FALSE.

Pokud je třetí argument strict nastaven na TRUE, tak funkce in_array() také kontroluje typ needle v haystack.

Poznámka: Pokud je needle řetězec, tak porovnání rozlišuje velká a malá písmena.

Poznámka: V PHP starších než 4.2.0 nemohl být parametr needle pole.

Příklad 247. Ukázka in_array()

<?php
$os = array("Mac", "NT", "Irix", "Linux");
if (in_array("Irix", $os)) {
    echo "Máme Irix";
}
if (in_array("mac", $os)) {
    echo "Máme mac";
}
?>

Druhá podmínka neuspěje, protože funkce in_array() rozlišuje velká a malá písmen, takže program vypíše:

Máme Irix

Příklad 248. Ukázka in_array() s parametrem strict

<?php
$a = array('1.10', 12.4, 1.13);

if (in_array('12.4', $a, true)) {
    echo "'12.4' bylo nalezeno s omezením strict\n";
}

if (in_array(1.13, $a, true)) {
    echo "1.13 bylo nalezeno s omezením strict\n";
}
?>

Vypíše:

1.13 bylo nalezeno s omezením strict

Příklad 249. in_array() při hledání pole

<?php
$a = array(array('p', 'h'), array('p', 'r'), 'o');

if (in_array(array('p', 'h'), $a)) {
    echo "'ph' nalezeno\n";
}

if (in_array(array('f', 'i'), $a)) {
    echo "'fi' nalezeno\n";
}

if (in_array('o', $a)) {
    echo "'o' nalezeno\n";
}
?>

Vypíše:

  'ph' nalezeno
  'o' nalezeno

Viz také array_search(),
array_key_exists() a
isset().

Předcházející | Nahoru | Další
extract | Domů | key


key

(PHP 4, PHP 5)

key — Fetch a key from an associative array

Popis

mixed key ( array &$array )

key() vrací index současného prvku pole.

Viz také: current() a next().

Předcházející | Nahoru | Další
in_array | Domů | krsort


krsort

(PHP 4, PHP 5)

krsort — Třídit pole sestupně podle klíčů

Popis

bool krsort ( array &$array [, int $sort_flags] )

Třídí pole sestupně podle klíčů se zachování asociací indexů. To je užitečné hlavně při práci s asociativními poli.

Příklad 250. krsort() example

$fruits = array ("d"=>"lemon", "a"=>"orange", "b"=>"banana", "c"=>"apple");
krsort ($fruits);
reset ($fruits);
while (list ($key, $val) = each ($fruits)) {
    echo "$key -> $val\n";
}

Tato ukázka vytiskne:

fruits[d] = lemon
fruits[c] = apple
fruits[b] = banana
fruits[a] = orange

Vlastnosti třídění lze upravit pomocí volitelného argumentu sort_flags, detaily viz sort().

Viz také: asort(),
arsort(),
ksort(),
sort(),
natsort() a
rsort().

Předcházející | Nahoru | Další
key | Domů | ksort


ksort

(PHP 4, PHP 5)

ksort — Třídit pole podle klíčů

Popis

bool ksort ( array &$array [, int $sort_flags] )

Třídí pole podle klíčů se zachování asociací indexů. To je užitečné hlavně při práci s asociativními poli.

Příklad 251. ksort() example

$fruits = array ("d"=>"lemon", "a"=>"orange", "b"=>"banana", "c"=>"apple");
ksort ($fruits);
reset ($fruits);
while (list ($key, $val) = each ($fruits)) {
    echo "$key -> $val\n";
}

Tato ukázka vytiskne:

fruits[a] = orange
fruits[b] = banana
fruits[c] = apple
fruits[d] = lemon

Vlastnosti třídění lze upravit pomocí volitelného argumentu sort_flags, detaily viz sort().

Viz také: asort(),
arsort(),
sort(),
natsort() a
rsort().

Poznámka: Druhý argument byl přidán v PHP 4.

Předcházející | Nahoru | Další
krsort | Domů | list


list

(PHP 4, PHP 5)

list — Přiřadit hodnoty přoměnným jako kdyby byly polem

Popis

void list ( mixed $varname, mixed $... )

Stejně jako array(), list() vlastně není funkce, ale jazykový konstrukt. Používá se k přiřazení hodnot více proměnným v jedné operaci.

Příklad 252. Ukázka list()

<table>
 <tr>
  <th>Employee name</th>
  <th>Salary</th>
 </tr>

<?php

$result = mysql ($conn, "SELECT id, name, salary FROM employees");
while (list ($id, $name, $salary) = mysql_fetch_row ($result)) {
    print (" <tr>\n".
           "  <td><a href=\"info.php3?id=$id\">$name</a></td>\n".
           "  <td>$salary</td>\n".
           " </tr>\n");
}

?>

</table>

Viz také: each() a array().

Předcházející | Nahoru | Další
ksort | Domů | natcasesort


natcasesort

(PHP 4, PHP 5)

natcasesort — Třídit pole s využitím algoritmu "přirozeného třídění" (case-insensitive)

Popis

bool natcasesort ( array &$array )

Tato funkce implementuje srovnávací algoritmus který třídí alfanumerické řetězce stejným způsobem jako člověk, toto se popisuje jako "přirozené třídění".

natcasesort() je case-insensitive verze natsort(). Ukázka rozdílu mezi tímto algoritmem a běžným počítačovým tříděním řetězců viz natsort().

Více informací viz stránka Martina Poola » Natural Order String Comparison.

Viz také: sort(),
natsort(),
strnatcmp() and
strnatcasecmp().

Předcházející | Nahoru | Další
list | Domů | natsort


natsort

(PHP 4, PHP 5)

natsort — Třídit pole s využitím algoritmu "přirozeného třídění"

Popis

bool natsort ( array &$array )

Tato funkce implementuje srovnávací algoritmus který třídí alfanumerické řetězce stejným způsobem jako člověk, toto se popisuje jako "přirozené třídění". Ukázka rozdílu mězi tímto algoritmem a běžnými počítačovými algoritmy pro řazení řetězců (např. sort()):

Příklad 253. Ukázka natsort()

$array1 = $array2 = array ("img12.png","img10.png","img2.png","img1.png");

sort($array1);
echo "Standardní třídění\n";
print_r($array1);

natsort($array2);
echo "\nPřirozené třídění\n";
print_r($array2);

Výše uvedený kód vygeneruje následující výstup:

Standardní třídění
Array
(
    [0] => img1.png
    [1] => img10.png
    [2] => img12.png
    [3] => img2.png
)

Přirozené třídění
Array
(
    [3] => img1.png
    [2] => img2.png
    [1] => img10.png
    [0] => img12.png
)
Více informací viz stránka Martina Poola » Natural Order String Comparison.

Viz také: natcasesort(),
strnatcmp() a
strnatcasecmp().

Předcházející | Nahoru | Další
natcasesort | Domů | next


next

(PHP 4, PHP 5, PECL axis2:0.1.0-0.1.1 xmlreader:1.0-1.0.1)

next — Posunout interní ukazatel pole

Popis

mixed next ( array &$array )

Vrací další prvek pole nebo FALSE, pokud prvky došly.

next() se chová jako current(), s jedním rozdílem: posouvá interní ukazatel pole o jeden prvek a vrací prvek, na který tento ukazatel ukazuje po posunu. To znamená, že vrací další prvek pole a posouvá interní ukazatel o jeden. Pokud by ukazatel po psunu ukazoval mimo pole, next() vrací FALSE.

Varování

Pokud toto pole obsahuje prázdné prvky, nebo prvky, jejichž index je 0, tato funkce vrátí FALSE i pro tyto prvky. Ke správnému průchodu polem, které může obsahovat prázdné prvky nebo prvky s indexem 0 použijte each().

Viz také:
current(),
end(),
prev() a
reset().

Předcházející | Nahoru | Další
natsort | Domů | pos


pos

(PHP 4, PHP 5)

pos — Získat současný prvek pole

Popis

mixed pos ( array $array )

Toto je alias k current().

Viz také: end(),
next(),
prev() a
reset().

Předcházející | Nahoru | Další
next | Domů | prev


prev

(PHP 4, PHP 5)

prev — Rewind interní ukazatel pole

Popis

mixed prev ( array &$array )

Vrací prvek pole před tím prvkem, na který ukazuje interní ukazatel pole, nebo FALSE, pokud prvky došly.

Varování

Pokud toto pole obsahuje prázdné prvky, tato funkce vrátí FALSE i pro tyto prvky. Ke správnému průchodu polem, které může obsahovat prázdné prvky použijte each().

prev() se chová stejně jako next(), ale posouvá interní ukazatel pole o jedno místo zpátky místo dopředu.

Viz také: current(),
end(),
next() a
reset().

Předcházející | Nahoru | Další
pos | Domů | range


range

(PHP 4, PHP 5)

range — Vytvořit pole obsahující rozsah integerů

Popis

array range ( mixed $low, mixed $high [, number $step] )

range() vrací pole integerů od low po high včetně.

Ukázka použití viz shuffle().

Předcházející | Nahoru | Další
prev | Domů | reset


reset

(PHP 4, PHP 5)

reset — Nastavit interní ukazatel pole na jeho první prvek

Popis

mixed reset ( array &$array )

reset() přetočí interní ukazatel pole array na jeho první prvek a vrátí hodnotu prvního prvku pole.

Příklad 254. Příklad funkce reset()

<?php

$array = array('krok jedna', 'krok dva', 'krok tři', 'krok čtyři');

// na začátku je ukazatel na prvním prvku
echo current($array) . "<br />\n"; // "krok jedna"

// přeskočit dva prvky
next($array);
next($array);
echo current($array) . "<br />\n"; // "krok tři"

// vynulovat ukazatel, začít znovu na prvním prvku
reset($array);
echo current($array) . "<br />\n"; // "krok jedna"

?>

Viz také current(),
each(), next()
a prev().

Předcházející | Nahoru | Další
range | Domů | rsort


rsort

(PHP 4, PHP 5)

rsort — Třídit pole sestupně

Popis

bool rsort ( array &$array [, int $sort_flags] )

Tato funkce sestupně třídí pole.

Příklad 255. Ukázka rsort()

$fruits = array ("lemon", "orange", "banana", "apple");
rsort ($fruits);
reset ($fruits);
while (list ($key, $val) = each ($fruits)) {
    echo "$key -> $val\n";
}

Tato ukázka zobrazí:

fruits[0] = orange
fruits[1] = lemon
fruits[2] = banana
fruits[3] = apple

Ovoce bylo setříděno podle abecedy sestupně.

Vlastnosti třídění lze upravit pomocí volitelného argumentu sort_flags, detaily viz sort().

Viz také: arsort(),
asort(),
ksort(),
sort() a
usort().

Předcházející | Nahoru | Další
reset | Domů | shuffle


shuffle

(PHP 4, PHP 5)

shuffle — Zamíchat pole

Popis

bool shuffle ( array &$array )

shuffle() zamíchá (náhodně změní pořadí prvků) pole. Musíte inicializovat generátor náhodných čísel pomocí srand().

Příklad 256. Ukázka shuffle()

$numbers = range (1,20);
srand ((double)microtime()*1000000);
shuffle ($numbers);
while (list (, $number) = each ($numbers)) {
    echo "$number ";
}

Viz také: arsort(),
asort(),
ksort(),
rsort(),
sort() a
usort().

Předcházející | Nahoru | Další
rsort | Domů | sizeof


sizeof

(PHP 4, PHP 5)

sizeof — Zjistit počet prvků v poli

Popis

int sizeof ( array $array )

Vrací počet prvků v poli.

Viz také: count().

Předcházející | Nahoru | Další
shuffle | Domů | sort


sort

(PHP 4, PHP 5)

sort — Třídit pole

Popis

bool sort ( array &$array [, int $sort_flags] )

sort() třídí pole. Prvky se uspořádají od nejmenšího k největšímu.

Poznámka: Tato funkce přiřadí prvkům pole nové klíče. Odstraní jakékoliv existující klíče. Nepřeuspořádá klíče, jak byste možná čekali.

Vrací TRUE při úspěchu, FALSE při selhání.

Příklad 257. Ukázka sort()

<?php

$ovoce = array("citrón", "pomeranč", "banán", "jablko");
sort($ovoce);
reset($ovoce);
while (list($key, $val) = each($ovoce)) {
    echo "ovoce[" . $key . "] = " . $val . "\n";
}

?>

Tato ukázka zobrazí:

fruits[0] = banán
fruits[1] = citrón
fruits[2] = jablko
fruits[3] = pomeranč

Ovoce bylo seřazeno podle abecedy.

Vlastnosti třídění lze upravit pomocí volitelného argumentu sort_flags, který může nabývat těchto hodnot:

Typy třídění:

  • SORT_REGULAR - normální porovnávání
  • SORT_NUMERIC - numerické porovnávání
  • SORT_STRING - textové porovnávání

Poznámka: Druhý parametr byl přidán v PHP 4.

Viz také arsort(),
asort(), ksort(),
natsort(), natcasesort(),
rsort(), usort(),
array_multisort() a
uksort().

Předcházející | Nahoru | Další
sizeof | Domů | uasort


uasort

(PHP 4, PHP 5)

uasort — Třídit pole pomocí uživatelsky definované porovnávací funkce se zachováním klíčů

Popis

bool uasort ( array &$array, callback $cmp_function )

Tato funkce třídí pole tak, že si indexy uchovávají spojení s hodnotami. To je užitečné hlavně při třídění asociativních polí, kde je důležité pořadí prvků. Srovnávací funkce je uživatelsky definována.

Poznámka: Ukázky uživatelsky definovaných porovnávacích funkcí viz usort() a uksort().

Viz také: usort(),
uksort(),
sort(),
asort(),
arsort(),
ksort() a
rsort().

Předcházející | Nahoru | Další
sort | Domů | uksort


uksort

(PHP 4, PHP 5)

uksort — Třídit pole podle klíčů pomocí uživatelsky definovane porovnávací funkce

Popis

bool uksort ( array &$array, callback $cmp_function )

Tato funkce třídí pole podle klíčů pomocí uživatelsky definované porovnávací funkce. Pokud potřebujete třídit pole podle komplikovanějších kritérií, měli byste použít tuto funkci.

Příklad 258. Ukázka uksort()

function cmp ($a, $b) {
    if ($a == $b) return 0;
    return ($a > $b) ? -1 : 1;
}

$a = array (4 => "four", 3 => "three", 20 => "twenty", 10 => "ten");

uksort ($a, "cmp");

while (list ($key, $value) = each ($a)) {
    echo "$key: $value\n";
}

Tato ukázka zobrazí:

20: twenty
10: ten
4: four
3: three

Viz také: usort(),
uasort(),
sort(),
asort(),
arsort(),
ksort(),
natsort() a
rsort().

Předcházející | Nahoru | Další
uasort | Domů | usort


usort

(PHP 4, PHP 5)

usort — Třídit pole podle hodnot pomocí uživatelsky definované porovnávací funkce

Popis

bool usort ( array &$array, callback $cmp_function )

Tato funkce třídí pole podle hodnot pomocí uživatelsky definované porovnávací funkce. Pokud potřebujete třídit pole podle komplikovanějších kritérií, měli byste použít tuto funkci.

Porovnávací funkce musí vrace integer menší než 0, 0, a větší než 0, pokud je první argument menší než, stejný, nebo větší než druhý argument. Pokud jsou dvě porovnávané hodnoty stejné, jejich pořadí v tříděném poli je nedefinováno.

Příklad 259. Ukázka usort()

function cmp ($a, $b) {
    if ($a == $b) return 0;
    return ($a > $b) ? -1 : 1;
}

$a = array (3, 2, 5, 6, 1);

usort ($a, "cmp");

while (list ($key, $value) = each ($a)) {
    echo "$key: $value\n";
}

Tato ukázka zobrazí:

0: 6
1: 5
2: 3
3: 2
4: 1

Poznámka: V tomto jednoduchém případě by pochopitelně bylo vhodnější použít rsort().

Příklad 260. Ukázka usort() s vícerozměrným polem

function cmp ($a, $b) {
    return strcmp($a["fruit"],$b["fruit"]);
}

$fruits[0]["fruit"] = "lemons";
$fruits[1]["fruit"] = "apples";
$fruits[2]["fruit"] = "grapes";

usort($fruits, "cmp");

while (list ($key, $value) = each ($fruits)) {
    echo "\$fruits[$key]: " . $value["fruit"] . "\n";
}

Při třídění vícerozměrného pole $a a $b obsahují reference na první index pole.

Tato ukázka zobrazí:

$fruits[0]: apples
$fruits[1]: grapes
$fruits[2]: lemons

Varování

Použitá quicksort funkce v některých C knihovnách (např. na systémech Solaris) může způsobit zhroucení PHP, pokud porovnávací funkce nevrací konsistentní hodnoty.

Viz také: uasort(),
uksort(),
sort(),
asort(),
arsort(),
ksort(),
natsort() a
rsort().

Předcházející | Nahoru | Další
uksort | Domů | VI. Aspell funkce [zastaralé]


Aspell funkce [zastaralé]

Předcházející VI. Reference funkcí Další

VI. Aspell funkce [zastaralé]

Úvod

aspell() funkce umožňují ověřit hláskování slova a nabídnout možné opravy.

Poznámka: Toto rozšíření bylo z PHP odebráno a od PHP 4.3.0 není k dispozici. Pokud chcete v PHP použít kontrolu hláskování, použijte místo toho pspell. Využívá pspell knihovnu, a pracuje s novějšími verzemi aspellu.

Požadavky

Rozšíření aspell funguje pouze s velmi starými (do přibližně .27.*) verzemi aspell knihovny. Tento modul, ani tyto verze aspell knihovny už nejsou podporovány. Budete potřebovat knihovnu aspell dostupnou na: » http://aspell.sourceforge.net/.

Instalace

In PHP 4, these functions are only available if PHP was configured with --with-aspell=[DIR].

Viz také

Viz také pspell.

Obsah

aspell_check_raw — Zkontrolovat slovo beze změny velikosti písmen nebo pokusů o ořezání
aspell_check — Zkontrolovat slovo
aspell_new — Načíst nový slovník
aspell_suggest — Nabídnout možné hláskování slova
Předcházející | Nahoru | Další
usort | Domů | aspell_check_raw


aspell_check_raw

(PHP 4 <= 4.2.3)

aspell_check_raw — Zkontrolovat slovo beze změny velikosti písmen nebo pokusů o ořezání

Popis

bool aspell_check_raw ( int $dictionary_link, string $word )

aspell_check_raw() zkontroluje hláskování slova beze změn velikosti písmen nebo pokusů ho jakýmkoliv způsobem ořezat, a vrátí TRUE, pokud je hláskování správné, a FALSE, pokud není.

Příklad 261. aspell_check_raw()

$aspell_link=aspell_new ("english");
if (aspell_check_raw ($aspell_link, "test")) {
    echo "Toto je platné hláskování";
} else {
    echo "Pardon, špatné hláskování";
}

Předcházející | Nahoru | Další
VI. Aspell funkce [zastaralé] | Domů | aspell_check


aspell_check

(PHP 4 <= 4.2.3)

aspell_check — Zkontrolovat slovo

Popis

bool aspell_check ( int $dictionary_link, string $word )

aspell_check() zkontroluje hláskování slova a vrátí TRUE, pokud je hláskování správné, a FALSE, pokud není.

Příklad 262. aspell_check()

$aspell_link=aspell_new ("english");
if (aspell_check ($aspell_link, "testt")) {
    echo "Toto je platné hláskování";
} else {
    echo "Pardon, špatné hláskování";
}

Předcházející | Nahoru | Další
aspell_check_raw | Domů | aspell_new


aspell_new

(PHP 4 <= 4.2.3)

aspell_new — Načíst nový slovník

Popis

int aspell_new ( string $master [, string $personal] )

aspell_new() otevře nový slovník, a vrátí identifikátor spojení na tento slovník využitelný s dalšími aspell funkcemi.

Příklad 263. aspell_new()

$aspell_link=aspell_new ("english");

Předcházející | Nahoru | Další
aspell_check | Domů | aspell_suggest


aspell_suggest

(PHP 4 <= 4.2.3)

aspell_suggest — Nabídnout možné hláskování slova

Popis

array aspell_suggest ( int $dictionary_link, string $word )

aspell_suggest() vrátí pole možných hláskování daného slova.

Příklad 264. aspell_suggest()

$aspell_link=aspell_new ("english");

if (!aspell_check ($aspell_link, "test")) {
    $suggestions=aspell_suggest ($aspell_link, "test");

    for ($i=0; $i < count ($suggestions); $i++) {
        echo "Možné hláskování: " . $suggestions[$i] . "<br>";
    }
}

Předcházející | Nahoru | Další
aspell_new | Domů | VII. BBCode Functions


BCMath funkce pro výpočty s libovolnou přesností

Předcházející VI. Reference funkcí Další

VIII. BCMath funkce pro výpočty s libovolnou přesností

Úvod

Pro práci s čísly libovolné přesnosti PHP nabízí Binary Calculator, který podporuje čísla libovolně velká a s libovolnou přesností, která jsou reprezentována jako řetězce.

Požadavky

Od PHP 4.0.4 je knihovna libbcmath dodávána s PHP. Pro toto rozšíření tedy nepotřebujete žádné externí knihovny.

Instalace

Tyto funkce jsou v PHP 4 dostupné pouze pokud bylo PHP zkonfigurováno s volbou --enable-bcmath. V PHP 3 jsou dostupné, pokud nebylo zkonfigurováno s volbou --disable-bcmath.

Verze PHP pro Windows má vestavěnou podporu pro toto rozšíření. K použití těchto funkcí není třeba načítat žádná další rozšíření.

Konfigurace běhu

Chování těchto funkcí je ovlivněno nastavením parametrů v php.ini.

Tabulka 15. BC math configuration options

Name | Default | Changeable | Changelog
bcmath.scale | "0" | PHP_INI_ALL |

Pro další detaily a definice konstant PHP_INI_*, viz dokumentace k ini_set().

Zde je stručný popis konfiguračních direktiv.

bcmath.scale integer

Number of decimal digits for all bcmath functions. See also bcscale().

Typy prostředků

Toto rozšíření nemá definován žádný typ prostředku (resource).

Předdefinované konstanty

Toto rozšíření nemá definovány žádné konstanty.

Obsah

bcadd — Sečíst dvě čísla s libovolnou přesností
bccomp — Porovnat dvě čísla s libovolnou přesností
bcdiv — Dělit dvě čísla s libovolnou přesností
bcmod — Získat modulus čísla s libovolnou přesností
bcmul — Vynásobit dvě čísla s libovolnou přesností
bcpow — Umocnit jedno číslo na jiné s libovolnou přesností
bcpowmod — Raise an arbitrary precision number to another, reduced by a specified modulus
bcscale — Nastavit výchozí škálu pro všechny bc math funkce
bcsqrt — Získat druhou odmocninu čísla s libovolnou přesností
bcsub — Odečíst jedno číslo od druhého s libovolnou přesností
Předcházející | Nahoru | Další
bbcode_set_flags | Domů | bcadd


bcadd

(PHP 4, PHP 5)

bcadd — Sečíst dvě čísla s libovolnou přesností

Popis

string bcadd ( string $left_operand, string $right_operand [, int $scale] )

Přičte left operand k right operand a vrátí součet v řetězci. Volitelný argument scale se používá k určení počtu desetinných míst ve výsledku.

Viz také bcsub().

Předcházející | Nahoru | Další
VIII. BCMath funkce pro výpočty s libovolnou přesností | Domů | bccomp


bccomp

(PHP 4, PHP 5)

bccomp — Porovnat dvě čísla s libovolnou přesností

Popis

int bccomp ( string $left_operand, string $right_operand [, int $scale] )

Porovná left operand s right operand a vrátí výsledek jako integer. Volitelný argument scale se používá k určení počtu desetinných míst použitých při porovnání. Návratová hodnota je 0, pokud jsou si oba operandy rovné. Pokud je left operand větší než right operand, návratová hodnota je +1, a pokud je left operand menší než right operand, návratová hodnota je -1.

Předcházející | Nahoru | Další
bcadd | Domů | bcdiv


bcdiv

(PHP 4, PHP 5)

bcdiv — Dělit dvě čísla s libovolnou přesností

Popis

string bcdiv ( string $left_operand, string $right_operand [, int $scale] )

Vydělí argument left operand argumentem right operand a vrátí výsledek. Volitelný argument scale se používá k určení počtu desetinných míst ve výsledku.

Viz také bcmul().

Předcházející | Nahoru | Další
bccomp | Domů | bcmod


bcmod

(PHP 4, PHP 5)

bcmod — Získat modulus čísla s libovolnou přesností

Popis

string bcmod ( string $left_operand, string $modulus )

Vrátí modulus argumentu left operand s použitím argumentu modulus.

Viz také bcdiv().

Předcházející | Nahoru | Další
bcdiv | Domů | bcmul


bcmul

(PHP 4, PHP 5)

bcmul — Vynásobit dvě čísla s libovolnou přesností

Popis

string bcmul ( string $left_operand, string $right_operand [, int $scale] )

Vynásobí argument left operand argumentem right operand a vrátí výsledek. Volitelný argument scale se používá k určení počtu desetinných míst ve výsledku.

Viz také bcdiv().

Předcházející | Nahoru | Další
bcmod | Domů | bcpow


bcpow

(PHP 4, PHP 5)

bcpow — Umocnit jedno číslo na jiné s libovolnou přesností

Popis

string bcpow ( string $x, string $y [, int $scale] )

Umocní x na y. Volitelný argument scale se používá k určení počtu desetinných míst ve výsledku.

Viz také bcsqrt().

Předcházející | Nahoru | Další
bcmul | Domů | bcpowmod


bcpowmod

(PHP 5)

bcpowmod — Raise an arbitrary precision number to another, reduced by a specified modulus

Popis

string bcpowmod ( string $left_operand, string $right_operand, string $modulus [, int $scale] )

Use the fast-exponentiation method to raise left_operand to the power right_operand with respect to the modulus modulus.

Seznam parametrů

left_operand

The left operand, as a string.

right_operand

The right operand, as a string.

modulus

The modulus, as a string.

scale

This optional parameter is used to set the number of digits after the decimal place in the result. You can also set the global default scale for all functions by using bcscale().

Návratové hodnoty

Returns the result as a string, or NULL if modulus is 0.

Poznámky

Poznámka: Because this method uses the modulus operation, non-natural numbers may give unexpected results. A natural number is any positive non-zero integer.

Příklady

The following two statements are functionally identical. The bcpowmod() version however, executes in less time and can accept larger parameters.

<?php
$a = bcpowmod($x, $y, $mod);

$b = bcmod(bcpow($x, $y), $mod);

// $a and $b are equal to each other.

?>

Viz také

bcpow()
bcmod()

Předcházející | Nahoru | Další
bcpow | Domů | bcscale


bcscale

(PHP 4, PHP 5)

bcscale — Nastavit výchozí škálu pro všechny bc math funkce

Popis

bool bcscale ( int $scale )

Tato funkce nastaví výchozí škálu pro všechna následná volání bc math funkcí, ktera neudávají explicitně škálu přesnosti.

Předcházející | Nahoru | Další
bcpowmod | Domů | bcsqrt


bcsqrt

(PHP 4, PHP 5)

bcsqrt — Získat druhou odmocninu čísla s libovolnou přesností

Popis

string bcsqrt ( string $operand [, int $scale] )

Vrátí druhou odmocninu argumentu operand. Volitelný argument scale se používá k určení počtu desetinných míst ve výsledku.

Viz také bcpow().

Předcházející | Nahoru | Další
bcscale | Domů | bcsub


bcsub

(PHP 4, PHP 5)

bcsub — Odečíst jedno číslo od druhého s libovolnou přesností

Popis

string bcsub ( string $left_operand, string $right_operand [, int $scale] )

Odečte argument right operand od argumentu left operand a vrátí výsledek v řetězci. Volitelný argument scale se používá k určení počtu desetinných míst ve výsledku.

Viz také bcadd().

Předcházející | Nahoru | Další
bcsqrt | Domů | IX. PHP bytecode Compiler


Kompresní funkce bzip2

Předcházející VI. Reference funkcí Další

X. Kompresní funkce bzip2

Úvod

Funkce bzip2 se používají k transparentnímu čtení a zápisu souborů komprimovaných algoritmem bzip2 (.bz2).

Požadavky

Tento modul používá funkce z knihovny » bzip2 od Juliana Sewarda. Tento modul vyžaduje bzip2/libbzip2 verze >= 1.0.x.

Instalace

Podpora bzip2 není v PHP implicitn? k dispozici. K aktivaci budete muset p?i kompilaci PHP pou 3/4 ít konfigura?ní volbu --with-bz2[=DIR].

Konfigurace běhu

Toto rozšíření nemá definováno žádné konfigurační direktivy.

Typy prostředků

Toto rozšíření definuje jeden typ prostředku: souborový ukazatel identifikující soubor bz2, nad kterým se pracuje.

Předdefinované konstanty

Toto rozšíření nemá definovány žádné konstanty.

Příklady

Tento příklad otevře dočasný soubor a zapíše do něj testovací řetezec; potom vypíše obsah souboru.

Příklad 281. Malý příklad na bzip2

<?php

$filename = "/tmp/testfile.bz2";
$str = "Toto je testovací řetězec.\n";

// otevři soubor pro zápis
$bz = bzopen($filename, "w");

// zapoš řetězec do souboru
bzwrite($bz, $str);

// zavři soubor
bzclose($bz);

// otevři soubor pro čtení
$bz = bzopen($filename, "r");

// přečti 10 znaků
print bzread($bz, 10);

// tiskni dokud není konec souboru (nebo následující 1024. znak) a zavři soubor
print bzread($bz);

bzclose($bz);

?>

Obsah

bzclose — Zavře ukazatel na soubor bzip2
bzcompress — Zkomprimuje řetězec algoritmem bzip2
bzdecompress — Dekomprimuje data komprimovaná pomocí bzip2
bzerrno — Vrací číslo chyby bzip2
bzerror — Vrací v poli číslo a popis chyby bzip2
bzerrstr — Vrací popis chyby bzip2
bzflush — Vynutí zápis všech bufferovaných dat
bzopen — Otevře soubor komprimovaný pomocí bzip2
bzread — Binárně bezpečné čtení ze souboru bzip2
bzwrite — Binárně bezpečný zápis do souboru bzip2
Předcházející | Nahoru | Další
bcompiler_write_included_filename | Domů | bzclose


bzclose

(PHP 4 >= 4.3.3, PHP 5, PECL bz2:1.0)

bzclose — Zavře ukazatel na soubor bzip2

Popis

int bzclose ( resource $bz )

Zavře soubor bzip2 odkazovaný ukazatelem bz.

Vrací TRUE při úspěchu, FALSE při selhání.

Ukazatel na soubor musí být platný a musí ukazovat na soubor úspěšně otevřený pomocí bzopen().

Viz také bzopen().

Předcházející | Nahoru | Další
X. Kompresní funkce bzip2 | Domů | bzcompress


bzcompress

(PHP 4 >= 4.3.3, PHP 5, PECL bz2:1.0)

bzcompress — Zkomprimuje řetězec algoritmem bzip2

Popis

mixed bzcompress ( string $source [, int $blocksize [, int $workfactor]] )

bzcompress() komprimuje řetězec source a vrací ho ve formě dat získaných pomocí algoritmu bzip2.

Nepovinný parametr blocksize specifikuje velikost bloku použitou při komprimaci; mělo by to být číslo od 1 do 9, kde 9 znamená nejúčinnější kompresi, ale s většími nároky na potřebné prostředky. Implicitní hodnota blocksize je 4.

Nepovinný parametr workfactor určuje, jak se kompresní mechanismus chová v případě nejhorších, velmi se opakujících, vstupnách dat. Může nabývat hodnot mezi 0 a 250; 0 představuje speciální případ, 30 je implicitní hodnota. Generovaný výstup je bez ohledu na workfactor vždy stejný.

Příklad 282. bzcompress() Příklad

<?php
$str = "zkušební data";
$bzstr = bzcompress($str, 9);
echo $bzstr;
?>

Viz také bzdecompress().

Předcházející | Nahoru | Další
bzclose | Domů | bzdecompress


bzdecompress

(PHP 4 >= 4.3.3, PHP 5, PECL bz2:1.0)

bzdecompress — Dekomprimuje data komprimovaná pomocí bzip2

Popis

mixed bzdecompress ( string $source [, int $small] )

bzdecompress() dekomprimuje řetězec source obsahující data komprimovaná pomocí algoritmu bzip2, a vrací je. Pokud má nepovinný parametr small hodnotu TRUE, použije se alternativní dekompresní algoritmus s nižšími nároky na paměť (maximální pamětové požadavky klesnou na cca 2300 KB), ale zhruba poloviční rychlostí. Více informací najdete v » dokumentaci k bzip2.

Příklad 283. bzdecompress()

<?php
$start_str = "Tohle není upřímný obličej?";
$bzstr = bzcompress($start_str);

echo "Komprimovaný řetězec: ";
echo $bzstr;
echo "\n<br>\n";

$str = bzdecompress($bzstr);
echo "Dekomprimovaný řetezec: ";
echo $str;
echo "\n<br>\n";
?>

Viz také bzcompress().

Předcházející | Nahoru | Další
bzcompress | Domů | bzerrno


bzerrno

(PHP 4 >= 4.3.3, PHP 5, PECL bz2:1.0)

bzerrno — Vrací číslo chyby bzip2

Popis

int bzerrno ( resource $bz )

Vrací chybové číslo jakékoli chyby bzip2 podle souborového ukazatele bz.

Vuz také bzerror() a bzerrstr().

Předcházející | Nahoru | Další
bzdecompress | Domů | bzerror


bzerror

(PHP 4 >= 4.3.3, PHP 5, PECL bz2:1.0)

bzerror — Vrací v poli číslo a popis chyby bzip2

Popis

array bzerror ( resource $bz )

Vrací číslo chyby a chybový řetězec (popis) v asociativním poli pro jakoukoli chybu bzip2 podle souborového ukazatele bz.

Příklad 284. Příklad - bzerror()

<?php
$error = bzerror($bz);

echo $error["errno"];
echo $error["errstr"];
?>

Viz také bzerrno() a bzerrstr().

Předcházející | Nahoru | Další
bzerrno | Domů | bzerrstr


bzerrstr

(PHP 4 >= 4.3.3, PHP 5, PECL bz2:1.0)

bzerrstr — Vrací popis chyby bzip2

Popis

string bzerrstr ( resource $bz )

Vrací chybový řetězec (popis) pro jakoukoli chybu bzip2 podle souborového ukazatele bz.

Viz také bzerrno() a bzerror().

Předcházející | Nahoru | Další
bzerror | Domů | bzflush


bzflush

(PHP 4 >= 4.3.3, PHP 5, PECL bz2:1.0)

bzflush — Vynutí zápis všech bufferovaných dat

Popis

int bzflush ( resource $bz )

Vynutí zápis všech bufferovaných dat pro souborový ukazatel bz.

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také bzread() a bzwrite().

Předcházející | Nahoru | Další
bzerrstr | Domů | bzopen


bzopen

(PHP 4 >= 4.3.3, PHP 5, PECL bz2:1.0)

bzopen — Otevře soubor komprimovaný pomocí bzip2

Popis

resource bzopen ( string $filename, string $mode )

Otevře soubor bzip2 (.bz2) pro čtení nebo zápis. filename je název otvíraného souboru. Parametr mode má podobný význam jako u funkce fopen() (`r' pro čtení, `w' pro zápis atd.).

Pokud otvírání selže, vrací funkce FALSE, jinak vrací ukazatel (deskriptor) na nově otevřený soubor.

Příklad 285. Příklad - bzopen()

<?php
$bz = bzopen("/tmp/foo.bz2", "r");
$decompressed_file = '';
while (!feof($bz)) {
    $decompressed_file .= bzread($bz, 4096);
}
bzclose($bz);

echo "Obsah souboru /tmp/foo.bz2 je: ";
echo "\n<br>\n";
echo $decompressed_file;
?>

Viz také bzclose().

Předcházející | Nahoru | Další
bzflush | Domů | bzread


bzread

(PHP 4 >= 4.3.3, PHP 5, PECL bz2:1.0)

bzread — Binárně bezpečné čtení ze souboru bzip2

Popis

string bzread ( resource $bz [, int $length] )

bzread() přečte nejvýše length bytů z bzip2 souboru odkazovaného pomocí bz. Čtení končí, je-li přečteno length (nekomprimovaných) bytů nebo se dosáhne konce souboru - podle toho, co nastane dřív. Není-li specifikován nepovinný parametr length, funkce bzread() přečte najednou 1024 (nekomprimovaných) bytů.

Příklad 286. Příklad - bzread()

<?php
$bz = bzopen("/tmp/foo.bz2", "r");
$str = bzread($bz, 2048);
echo $str;
?>

Viz také bzwrite() a bzopen().

Předcházející | Nahoru | Další
bzopen | Domů | bzwrite


bzwrite

(PHP 4 >= 4.3.3, PHP 5, PECL bz2:1.0)

bzwrite — Binárně bezpečný zápis do souboru bzip2

Popis

int bzwrite ( resource $bz, string $data [, int $length] )

bzwrite() zapíše obsah řetězce data do souboru bzip2 odkazovaného pomocí bz. Je-li přítomen nepovinný parametr length, zápis skončí poté, co bude zapsáno length (nekomprimovaných) bytů nebo bude dosaženo konce řetězce - podle toho, co nastane dřív.

Příklad 287. Příklad bzwrite()

<?php
$str = "nekomprimovaná data";
$bz = bzopen("/tmp/foo.bz2", "w");
bzwrite($bz, $str, strlen($str));
bzclose($bz);
?>

Viz také bzread() a bzopen().

Předcházející | Nahoru | Další
bzread | Domů | XI. Kalendářové funkce


Kalendářové funkce

Předcházející VI. Reference funkcí Další

XI. Kalendářové funkce

Úvod

Toto rozšíření představuje sadu funkcí určených ke zjednodušení převodů mezi různými kalendáři. Prostředníkem nebo standardem, na kterém je založena, je Julian Day Count. To je počet dní začínající daleko před jakýmkoli datem o které by se většina lidí zajímala (někde kolem 4000 př. n. l.). Pokud chcete převádět mezi kalendářovými systémy, musíte nejdřív převést na Julian Day Count, potom na kýžený kalendář. Julian Day Count se velmi liší od Juliánského kaledáře! Pro více informací o Julian Day Count viz » http://www.hermetic.ch/cal_stud/jdn.htm. Pro více informací o kalendářových systémech viz » http://www.fourmilab.ch/documents/calendar/. Tyto instrukce obsahují výňatky z této stránky (v uvozovkách).

Instalace

Pro práci tohoto rozšíření musíte PHP zkompilovat s volbou --enable-calendar.

Verze PHP pro Windows má vestavěnou podporu pro toto rozšíření. K použití těchto funkcí není třeba načítat žádná další rozšíření.

Konfigurace běhu

Toto rozšíření nemá definováno žádné konfigurační direktivy.

Typy prostředků

Toto rozšíření nemá definován žádný typ prostředku (resource).

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

CAL_GREGORIAN (integer)
CAL_JULIAN (integer)
CAL_JEWISH (integer)
CAL_FRENCH (integer)
CAL_NUM_CALS (integer)
CAL_DOW_DAYNO (integer)
CAL_DOW_SHORT (integer)
CAL_DOW_LONG (integer)
CAL_MONTH_GREGORIAN_SHORT (integer)
CAL_MONTH_GREGORIAN_LONG (integer)
CAL_MONTH_JULIAN_SHORT (integer)
CAL_MONTH_JULIAN_LONG (integer)
CAL_MONTH_JEWISH (integer)
CAL_MONTH_FRENCH (integer)

The following constants are available since PHP 4.3.0 :

CAL_EASTER_DEFAULT (integer)
CAL_EASTER_ROMAN (integer)
CAL_EASTER_ALWAYS_GREGORIAN (integer)
CAL_EASTER_ALWAYS_JULIAN (integer)

The following constants are available since PHP 5.0.0 :

CAL_JEWISH_ADD_ALAFIM_GERESH (integer)
CAL_JEWISH_ADD_ALAFIM (integer)
CAL_JEWISH_ADD_GERESHAYIM (integer)

Obsah

cal_days_in_month — Return the number of days in a month for a given year and calendar
cal_from_jd — Converts from Julian Day Count to a supported calendar
cal_info — Returns information about a particular calendar
cal_to_jd — Converts from a supported calendar to Julian Day Count
easter_date — Zjistit UNIXový timestamp Velikonoční půlnoci v daném roce
easter_days — Get number of days after March 21 on which Easter falls for a given year
FrenchToJD — Převést datum z Francouzského republikánského kalendáře na Julian Day Count
GregorianToJD — Převést Gregoriánské datum na Julian Day Count
JDDayOfWeek — Vrátit den v týdnu
JDMonthName — Vrátit název měsíce
JDToFrench — Převést Julian Day Count na Francouzský republikánský kalendář
JDToGregorian — Převést Julian Day Count na Gregoriánské datum
JDToJewish — Převést Julian Day Count na idovský kalendář
JDToJulian — Převést Julian Day Count na Juliánské datum
jdtounix — Převést Julian Day Count na UNIXový timestamp
JewishToJD — Převést datum podle idovského kalendáře na Julian Day Count
JulianToJD — Převést Juliánské datum na Julian Day Count
unixtojd — Převést UNIXový timestamp na Julian Day Count
Předcházející | Nahoru | Další
bzwrite | Domů | cal_days_in_month


cal_days_in_month

(PHP 4 >= 4.0.7, PHP 5)

cal_days_in_month — Return the number of days in a month for a given year and calendar

Popis

int cal_days_in_month ( int $calendar, int $month, int $year )

This function will return the number of days in the month of year for the specified calendar.

Seznam parametrů

calendar

Calendar to use for calculation

month

Month in the selected calendar

year

Year in the selected calendar

Návratové hodnoty

The length in days of the selected month in the given calendar

Příklady

Příklad 288. cal_days_in_month() example

<?php
$num = cal_days_in_month(CAL_GREGORIAN, 8, 2003); // 31
echo "There was $num days in August 2003";
?>

Předcházející | Nahoru | Další
XI. Kalendářové funkce | Domů | cal_from_jd


cal_from_jd

(PHP 4 >= 4.0.7, PHP 5)

cal_from_jd — Converts from Julian Day Count to a supported calendar

Popis

array cal_from_jd ( int $jd, int $calendar )

cal_from_jd() converts the Julian day given in jd into a date of the specified calendar. Supported calendar values are CAL_GREGORIAN, CAL_JULIAN, CAL_JEWISH and CAL_FRENCH.

Seznam parametrů

jd

Julian day as integer

calendar

Calendar to convert to

Návratové hodnoty

Returns an array containing calendar information like month, day, year, day of week, abbreviated and full names of weekday and month and the date in string form "month/day/year".

Příklady

Příklad 289. cal_from_jd() example

<?php
$today = unixtojd(mktime(0, 0, 0, 8, 16, 2003));
print_r(cal_from_jd($today, CAL_GREGORIAN));
?>

Výše uvedený příklad vypíše:

Array
(
    [date] => 8/16/2003
    [month] => 8
    [day] => 16
    [year] => 2003
    [dow] => 6
    [abbrevdayname] => Sat
    [dayname] => Saturday
    [abbrevmonth] => Aug
    [monthname] => August
)

Viz také

cal_to_jd()
jdtofrench()
jdtogregorian()
jdtojewish()
jdtojulian()
jdtounix()

Předcházející | Nahoru | Další
cal_days_in_month | Domů | cal_info


cal_info

(PHP 4 >= 4.0.7, PHP 5)

cal_info — Returns information about a particular calendar

Popis

array cal_info ( [int $calendar] )

cal_info() returns information on the specified calendar.

Calendar information is returned as an array containing the elements calname, calsymbol, month, abbrevmonth and maxdaysinmonth. The names of the different calendars which can be used as calendar are as follows:

  • 0 or CAL_GREGORIAN - Gregorian Calendar
  • 1 or CAL_JULIAN - Julian Calendar
  • 2 or CAL_JEWISH - Jewish Calendar
  • 3 or CAL_FRENCH - French Revolutionary Calendar

If no calendar is specified information on all supported calendars is returned as an array.

Seznam parametrů

calendar

Calendar to return information for. If no calendar is specified information about all calendars is returned.

Návratové hodnoty

ChangeLog (záznam změn)

Verze | Popis
Since 5.0 | The calendar parameter becomes optional and defaults to "all calendars" if omitted.

Příklady

Příklad 290. cal_info() example

<?php
$info = cal_info(0);
print_r($info);
?>

Výše uvedený příklad vypíše:

Array
(
    [months] => Array
        (
            [1] => January
            [2] => February
            [3] => March
            [4] => April
            [5] => May
            [6] => June
            [7] => July
            [8] => August
            [9] => September
            [10] => October
            [11] => November
            [12] => December
        )

    [abbrevmonths] => Array
        (
            [1] => Jan
            [2] => Feb
            [3] => Mar
            [4] => Apr
            [5] => May
            [6] => Jun
            [7] => Jul
            [8] => Aug
            [9] => Sep
            [10] => Oct
            [11] => Nov
            [12] => Dec
        )

    [maxdaysinmonth] => 31
    [calname] => Gregorian
    [calsymbol] => CAL_GREGORIAN
)

Předcházející | Nahoru | Další
cal_from_jd | Domů | cal_to_jd


cal_to_jd

(PHP 4 >= 4.0.7, PHP 5)

cal_to_jd — Converts from a supported calendar to Julian Day Count

Popis

int cal_to_jd ( int $calendar, int $month, int $day, int $year )

cal_to_jd() calculates the Julian day count for a date in the specified calendar. Supported calendars are CAL_GREGORIAN, CAL_JULIAN, CAL_JEWISH and CAL_FRENCH.

Seznam parametrů

calendar

Calendar to convert from, one of CAL_GREGORIAN, CAL_JULIAN, CAL_JEWISH or CAL_FRENCH.

month

The month as a number, the valid range depends on the calendar

day

The day as a number, the valid range depends on the calendar

year

The year as a number, the valid range depends on the calendar

Návratové hodnoty

A Julian Day number.

Viz také

cal_from_jd()
frenchtojd()
gregoriantojd()
jewishtojd()
juliantojd()
unixtojd()

Předcházející | Nahoru | Další
cal_info | Domů | easter_date


easter_date

(PHP 4, PHP 5)

easter_date — Zjistit UNIXový timestamp Velikonoční půlnoci v daném roce

Popis

int easter_date ( [int $year] )

Vrací UNIXový timestamp odpovídající Velikonoční půlnoci v daném roce. Default year je současný rok.

Varování: Tato funkce vygeneruje varování, pokud je year mimo rozsah UNIXových timestampů (tj. před 1970 nebo po 2037).

Příklad 291. Ukázka easter_date()

echo date ("M-d-Y", easter_date(1999));        /* "Apr-04-1999" */
echo date ("M-d-Y", easter_date(2000));        /* "Apr-23-2000" */
echo date ("M-d-Y", easter_date(2001));        /* "Apr-15-2001" */

Datum Velikonoc bylo definováno Nicaejským koncilem v r. 325 n. l. jako neděle po prvním úplňku který připadá na nebo po jarní rovnodennosti. Rovnodennost se vždy předpokládá na 21. března, takže se výpočet redukuje na určení data úplňku a data následující neděle. Zde použitý algoritmus byl poprvé použit kolem roku 532 Dionysiem Exiguem. V Juliánském kalendáři (pro léta před 1753) se na sledování fází Měsíce používal jednoduchý devatenáctiletý cyklus. V Gregoriánském kalendáři (pro léta po 1753 - navržen Claviem a Liliem a zaveden papežem Řehořem XIII v říjnu 1582, v Británii a jejích koloniích v září 1752) se přidávají dva faktory, které tento cyklus zpřesňují.

(Kód je založen na C programu od Simona Kershawa, <webmaster@ely.anglican.org>)

Výpočet Velikonoc před rokem 1970 nebo po roce 2037 viz easter_days().

Předcházející | Nahoru | Další
cal_to_jd | Domů | easter_days


easter_days

(PHP 4, PHP 5)

easter_days — Get number of days after March 21 on which Easter falls for a given year

Popis

int easter_days ( [int $year [, int $method]] )

Vrací počet dní od 21. března do Velikonoc v daném roce. Default year je současný rok.

Tato funkce je využitelná místo easter_date() na výpočty Velikonoc pro roky které spadají mimo rozsah UNIXových timestampů (tj. před rokem 1970 a po roce 2037).

Příklad 292. Ukázka easter_date()

echo easter_days (1999);        /* 14, i.e. April 4   */
echo easter_days (1492);        /* 32, i.e. April 22  */
echo easter_days (1913);        /*  2, i.e. March 23  */

Datum Velikonoc bylo definováno Nicaejským koncilem v r. 325 n. l. jako neděle po prvním úplňku který připadá na nebo po jarní rovnodennosti. Rovnodennost se vždy předpokládá na 21. března, takže se výpočet redukuje na určení data úplňku a data následující neděle. Zde použitý algoritmus byl poprvé použit kolem roku 532 Dionysiem Exiguem. V Juliánském kalendáři (pro léta před 1753) se na sledování fází Měsíce používal jednoduchý devatenáctiletý cyklus. V Gregoriánském kalendáři (pro léta po 1753 - navržen Claviem a Liliem a zaveden papežem Řehořem XIII v říjnu 1582, v Británii a jejích koloniích v září 1752) se přidávají dva faktory, které tento cyklus zpřesňují.

(Kód je založen na C programu od Simona Kershawa, <webmaster@ely.anglican.org>)

Viz také: easter_date().

Předcházející | Nahoru | Další
easter_date | Domů | FrenchToJD


FrenchToJD

(PHP 4, PHP 5)

FrenchToJD — Převést datum z Francouzského republikánského kalendáře na Julian Day Count

Popis

int frenchtojd ( int $month, int $day, int $year )

Převádí datum z Francouzského republikánského kalendáře na Julian Day Count.

Tyto rutiny konvertují pouze data v letech 1 až 14 (Gregoriánská data 22. září 1792 až 22. září 1806). To více než dostatečně pokrývá období, po které se tento kalendář používal.

Předcházející | Nahoru | Další
easter_days | Domů | GregorianToJD


GregorianToJD

(PHP 4, PHP 5)

GregorianToJD — Převést Gregoriánské datum na Julian Day Count

Popis

int gregoriantojd ( int $month, int $day, int $year )

Platný rozsah Gregoriánského kalendáře je 4714 př. n. l. až 9999 n. l.

Jakkoli tento software zvládá data až do 4714 př. n. l., takové použití asi nemá smysl. Gregoriánský kalendář byl založen až 15. října 1582 (5. října 1582 podle Juliánského kalendáře). Některé země ho přijaly mnohem později, Řecko až v r. 1923. Většina evropským států před Gregoriánským kalendářem používala Juliánský.

Příklad 293. Kalendářové funkce

<?php
$jd = GregorianToJD (10,11,1970);
echo "$jd\n";
$gregorian = JDToGregorian ($jd);
echo "$gregorian\n";
?>

Předcházející | Nahoru | Další
FrenchToJD | Domů | JDDayOfWeek


JDDayOfWeek

(PHP 4, PHP 5)

JDDayOfWeek — Vrátit den v týdnu

Popis

mixed jddayofweek ( int $julianday [, int $mode] )

Vrací den v týdnu. V závislosti na módu vrací řetězec nebo integer.

Tabulka 16. Kalendářové týdenní módy

Mód | Význam
0 | Vrací číslo dne jako integer (0=sunday, 1=monday, etc)
1 | Vrací řetězec obsahující název dne v týdnu (anglický gregoriánský)
2 | Vrací řetězec obsahující zkrácený název dne v týdnu (anglický gregoriánský)

Předcházející | Nahoru | Další
GregorianToJD | Domů | JDMonthName


JDMonthName

(PHP 4, PHP 5)

JDMonthName — Vrátit název měsíce

Popis

string jdmonthname ( int $julianday, int $mode )

Vrací řetězec obsahující název měsíce. mode určuje, na který kalendář se má Julian Day Count konvertovat a jaký typ jména se má vrátit.

Tabulka 17. Kalendářové módy

Mód | Význam
0 | Gregoriánský - zkrácený
1 | Gregoriánský
2 | Juliánský - zkrácený
3 | Juliánský
4 | idovský
5 | Francouzský republikánský

Předcházející | Nahoru | Další
JDDayOfWeek | Domů | JDToFrench


JDToFrench

(PHP 4, PHP 5)

JDToFrench — Převést Julian Day Count na Francouzský republikánský kalendář

Popis

string jdtofrench ( int $juliandaycount )

Převádí Julian Day Count na Francouzský republikánský kalendář.

Předcházející | Nahoru | Další
JDMonthName | Domů | JDToGregorian


JDToGregorian

(PHP 4, PHP 5)

JDToGregorian — Převést Julian Day Count na Gregoriánské datum

Popis

string jdtogregorian ( int $julianday )

Převádí Julian Day Count na řetězec obsahující Gregoriánské datum ve formátu "měsíc/den/rok".

Předcházející | Nahoru | Další
JDToFrench | Domů | JDToJewish


JDToJewish

(PHP 4, PHP 5)

JDToJewish — Převést Julian Day Count na idovský kalendář

Popis

string jdtojewish ( int $juliandaycount [, bool $hebrew [, int $fl]] )

Převádí Julian Day Count na idovský kalendář.

Předcházející | Nahoru | Další
JDToGregorian | Domů | JDToJulian


JDToJulian

(PHP 4, PHP 5)

JDToJulian — Převést Julian Day Count na Juliánské datum

Popis

string jdtojulian ( int $julianday )

Převádí Julian Day Count na řetězec obsahující Juliánské datum ve formátu "měsíc/den/rok".

Předcházející | Nahoru | Další
JDToJewish | Domů | jdtounix


jdtounix

(PHP 4, PHP 5)

jdtounix — Převést Julian Day Count na UNIXový timestamp

Popis

int jdtounix ( int $jday )

jdtounix() vrací UNIXový timestamp odpovídající Julian Day Countu danému v jday nebo FALSE, pokud je jday mimo UNIXovou epochu (Gregoriánské roky mezi 1970 a 2037, nebo-li 2440588 <= jday <= 2465342 )

Viz také: jdtounix().

Poznámka: Tato funkce byla přidána v PHP 4 RC2.

Předcházející | Nahoru | Další
JDToJulian | Domů | JewishToJD


JewishToJD

(PHP 4, PHP 5)

JewishToJD — Převést datum podle idovského kalendáře na Julian Day Count

Popis

int jewishtojd ( int $month, int $day, int $year )

Platný rozsah Jakkoli tento software zvládá data až do roku 1 (3761 př. n. l.), takové použití asi nemá smysl.

idovský kalendář se používá několik tisíc let, ale zpočátku neexistoval vzorec na určení začátku měsíce. Nový měsíc začínal, když byl poprvé spatřen nový Měsíc.

Předcházející | Nahoru | Další
jdtounix | Domů | JulianToJD


JulianToJD

(PHP 4, PHP 5)

JulianToJD — Převést Juliánské datum na Julian Day Count

Popis

int juliantojd ( int $month, int $day, int $year )

Platný rozsah pro Juliánský kalendář je 4713 př. n. l. až 9999 n. l.

Jakkoli tento software zvládá data až do 4713 př. n. l., takové použití asi nemá smysl. Tento kalendář byl vytvořen v roce 46 př. n. l., ale detaily se nestabilizovaly nejméně do 8 n. l., a možná až do konce 4. století. Navíc začátek roku se lišil od kultury ke kultuře - ne všechny přijímaly leden jako první měsíc roku.

Předcházející | Nahoru | Další
JewishToJD | Domů | unixtojd


unixtojd

(PHP 4, PHP 5)

unixtojd — Převést UNIXový timestamp na Julian Day Count

Popis

int unixtojd ( [int $timestamp] )

Vrací Julian Day Count pro UNIXový timestamp (sekundy od 1.1.1970), nebo pro aktuální den, pokud není dán timestamp.

Viz také: jdtounix().

Poznámka: Tato funkce byla přidána v PHP 4 RC2.

Předcházející | Nahoru | Další
JulianToJD | Domů | XII. CCVS API Functions


CCVS API Functions

Předcházející VI. Reference funkcí Další

XII. CCVS API Functions

Úvod

Tyto funkce představují interface k CCVS API, a umožnují tak přímo pracovat s CCVS z vašich PHP skriptů. CCVS je » RedHatí řešení "zprostředkovatele" ve zpracování kreditních karet. Umož%nuje vám oslovovat přímo zpracovatele kreditních karet přes váš *nix systém a modem. Pomocí CCVS modulu pro PHP můžete zpracovávat kreditní karty přes CCVS ve vašich PHP skriptech. Následující reference tento proces přiblíží.

Poznámka: CCVS bylo firmou RedHat pozastaveno a nemá v plánu vydávat další klíče nebo podporovat kontrakty. Pokud hledáte náhradu, zvažte » MCVE firmy Main Street Softworks jako možnou náhradu. Má podobný design a dokumentovanou podporu PHP!

Toto rozšíření bylo z PHP odstraněno a od verze 4.3.0 není k dispozici. Pokud chcete používat funkce pro zpracování kreditních karet, můžete místo toho použít rozšíření MCVE.

Instalace

Pokud chcete zapnout CCVS podporu v PHP, zjistěte si nejdříve instalační adresář CCVS. Potom budete muset PHP zkonfigurovat s --with-ccvs. Pokud toto použijete be udání cesty k vaší instalaci CCVS, PHP se pokusí podívat do defaultní instalační lokace CCVS (/usr/local/ccvs). Pokud je CCVS na nestandardním místě, spustěte configure s: --with-ccvs=$ccvs_path, kde $ccvs_path je cesta k vaší instalaci CVS. Pozn.: Podpora CCVS vyžaduje existenci $ccvs_path/lib a $ccvs_path/include, a přítomnost cv_api.h v adresáři include a libccvs.a v adresáři lib.

Dále je potřeba, aby běžel proces ccvsd. Navíc, PHP processy musí běžet pod stejným uživatelem, pod kterým běhá CCVS (např. pokud jste instalovali ccvs jako 'ccvs', vaše PHP procesy musí také běžet jako 'ccvs').

Viz také

RedHat přerušil podporu CCVS, přesto je mírně zastaralá dokumentace k dispozici na » http://www.redhat.com/docs/manuals/ccvs/.

Obsah

ccvs_add — Add data to a transaction
ccvs_auth — Perform credit authorization test on a transaction
ccvs_command — Performs a command which is peculiar to a single protocol, and thus is not available in the general CCVS API
ccvs_count — Find out how many transactions of a given type are stored in the system
ccvs_delete — Delete a transaction
ccvs_done — Terminate CCVS engine and do cleanup work
ccvs_init — Initialize CCVS for use
ccvs_lookup — Look up an item of a particular type in the database #
ccvs_new — Create a new, blank transaction
ccvs_report — Return the status of the background communication process
ccvs_return — Transfer funds from the merchant to the credit card holder
ccvs_reverse — Perform a full reversal on an already-processed authorization
ccvs_sale — Transfer funds from the credit card holder to the merchant
ccvs_status — Check the status of an invoice
ccvs_textvalue — Get text return value for previous function call
ccvs_void — Perform a full reversal on a completed transaction
Předcházející | Nahoru | Další
unixtojd | Domů | ccvs_add


ccvs_add

(PHP 4 >= 4.0.3)

ccvs_add — Add data to a transaction

Popis

string ccvs_add ( string $session, string $invoice, string $argtype, string $argval )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
XII. CCVS API Functions | Domů | ccvs_auth


ccvs_auth

(PHP 4 >= 4.0.3)

ccvs_auth — Perform credit authorization test on a transaction

Popis

string ccvs_auth ( string $session, string $invoice )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
ccvs_add | Domů | ccvs_command


ccvs_command

(PHP 4 >= 4.0.3)

ccvs_command — Performs a command which is peculiar to a single protocol, and thus is not available in the general CCVS API

Popis

string ccvs_command ( string $session, string $type, string $argval )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
ccvs_auth | Domů | ccvs_count


ccvs_count

(PHP 4 >= 4.0.3)

ccvs_count — Find out how many transactions of a given type are stored in the system

Popis

int ccvs_count ( string $session, string $type )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
ccvs_command | Domů | ccvs_delete


ccvs_delete

(PHP 4 >= 4.0.3)

ccvs_delete — Delete a transaction

Popis

string ccvs_delete ( string $session, string $invoice )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
ccvs_count | Domů | ccvs_done


ccvs_done

(PHP 4 >= 4.0.3)

ccvs_done — Terminate CCVS engine and do cleanup work

Popis

string ccvs_done ( string $sess )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
ccvs_delete | Domů | ccvs_init


ccvs_init

(PHP 4 >= 4.0.3)

ccvs_init — Initialize CCVS for use

Popis

string ccvs_init ( string $name )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
ccvs_done | Domů | ccvs_lookup


ccvs_lookup

(PHP 4 >= 4.0.3)

ccvs_lookup — Look up an item of a particular type in the database #

Popis

string ccvs_lookup ( string $session, string $invoice, int $inum )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
ccvs_init | Domů | ccvs_new


ccvs_new

(PHP 4 >= 4.0.3)

ccvs_new — Create a new, blank transaction

Popis

string ccvs_new ( string $session, string $invoice )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
ccvs_lookup | Domů | ccvs_report


ccvs_report

(PHP 4 >= 4.0.3)

ccvs_report — Return the status of the background communication process

Popis

string ccvs_report ( string $session, string $type )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
ccvs_new | Domů | ccvs_return


ccvs_return

(PHP 4 >= 4.0.3)

ccvs_return — Transfer funds from the merchant to the credit card holder

Popis

string ccvs_return ( string $session, string $invoice )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
ccvs_report | Domů | ccvs_reverse


ccvs_reverse

(PHP 4 >= 4.0.3)

ccvs_reverse — Perform a full reversal on an already-processed authorization

Popis

string ccvs_reverse ( string $session, string $invoice )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
ccvs_return | Domů | ccvs_sale


ccvs_sale

(PHP 4 >= 4.0.3)

ccvs_sale — Transfer funds from the credit card holder to the merchant

Popis

string ccvs_sale ( string $session, string $invoice )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
ccvs_reverse | Domů | ccvs_status


ccvs_status

(PHP 4 >= 4.0.3)

ccvs_status — Check the status of an invoice

Popis

string ccvs_status ( string $session, string $invoice )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
ccvs_sale | Domů | ccvs_textvalue


ccvs_textvalue

(PHP 4 >= 4.0.3)

ccvs_textvalue — Get text return value for previous function call

Popis

string ccvs_textvalue ( string $session )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
ccvs_status | Domů | ccvs_void


ccvs_void

(PHP 4 >= 4.0.3)

ccvs_void — Perform a full reversal on a completed transaction

Popis

string ccvs_void ( string $session, string $invoice )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
ccvs_textvalue | Domů | XIII. Funkce pro práci s třídami/objekty


Funkce na podporu COM ve Windows

Předcházející VI. Reference funkcí Další

XVI. Funkce na podporu COM ve Windows

Úvod

COM je technologie, která umožňuje znovupoužít kód napsaný v jakémkoliv jazyce za použití standardního volání a schováním implementačních detailů - jako na kterém počítači je komponenta uložena a který spustitelný soubor ji uchovává - za API. Lze si to představit jako rozšířený mechanismus vzdáleného volání procedur (RPC) se základy objektů. COM odděluje implementaci od rozhraní.

COM podporuje verzování, oddělení implementace od rozhraní a skrytí implementačních detailů jako je umístění spustitelného souboru a jazyku, který byl použit.

Požadavky

Tyto funkce jsou dostupné pouze ve Windows verzi PHP.

Instalace

K používání těchto funkcí není třeba žádná instalace, jsou součástí jádra PHP.

Verze PHP pro Windows má vestavěnou podporu pro toto rozšíření. K použití těchto funkcí není třeba načítat žádná další rozšíření.

Konfigurace běhu

Chování těchto funkcí je ovlivněno nastavením parametrů v php.ini.

Tabulka 18. Com configuration options

Name | Default | Changeable | Changelog
com.allow_dcom | "0" | PHP_INI_SYSTEM | Available since PHP 4.0.5.
com.autoregister_typelib | "0" | PHP_INI_ALL | PHP_INI_SYSTEM in PHP 4. Available since PHP 4.1.0.
com.autoregister_verbose | "0" | PHP_INI_ALL | PHP_INI_SYSTEM in PHP 4. Available since PHP 4.1.0.
com.autoregister_casesensitive | "1" | PHP_INI_ALL | PHP_INI_SYSTEM in PHP 4. Available since PHP 4.1.0.
com.code_page | "" | PHP_INI_ALL | Available since PHP 5.0.0.
com.typelib_file | "" | PHP_INI_SYSTEM | Available since PHP 4.0.5.

Pro další detaily a definice konstant PHP_INI_*, viz dokumentace k ini_set().

Zde je stručný popis konfiguračních direktiv.

com.allow_dcom

When this is turned on, PHP will be allowed to operate as a D-COM (Distributed COM) client and will allow the PHP script to instantiate COM objects on a remote server.

com.autoregister_typelib

When this is turned on, PHP will attempt to register constants from the typelibrary of objects that it instantiates, if those objects implement the interfaces required to obtain that information. The case sensitivity of the constants it registers is controlled by the com.autoregister_casesensitive configuration directive.

com.autoregister_verbose

When this is turned on, any problems with loading a typelibrary during object instantiation will be reported using the PHP error mechanism. The default is off, which does not emit any indication if there was an error finding or loading the type library.

com.autoregister_casesensitive

When this is turned on (the default), constants found in auto-loaded type libraries will be registered case sensitively. See com_load_typelib() for more details.

com.code_page

It controls the default character set code-page to use when passing strings to and from COM objects. If set to an empty string, PHP will assume that you want CP_ACP, which is the default system ANSI code page.

If the text in your scripts is encoded using a different encoding/character set by default, setting this directive will save you from having to pass the code page as a parameter to the COM class constructor. Please note that by using this directive (as with any PHP configuration directive), your PHP script becomes less portable; you should use the COM constructor parameter whenever possible.

Poznámka: This configuration directive was introduced with PHP 5.

com.typelib_file

When set, this should hold the path to a file that contains a list of typelibraries that should be loaded on startup. Each line of the file will be treated as the type library name and loaded as though you had called com_load_typelib(). The constants will be registered persistently, so that the library only needs to be loaded once. If a type library name ends with the string #cis or #case_insensitive, then the constants from that library will be registered case insensitively.

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

CLSCTX_INPROC_SERVER (integer)
CLSCTX_INPROC_HANDLER (integer)
CLSCTX_LOCAL_SERVER (integer)
CLSCTX_REMOTE_SERVER (integer)
CLSCTX_SERVER (integer)
CLSCTX_ALL (integer)
VT_NULL (integer)
VT_EMPTY (integer)
VT_UI1 (integer)
VT_I2 (integer)
VT_I4 (integer)
VT_R4 (integer)
VT_R8 (integer)
VT_BOOL (integer)
VT_ERROR (integer)
VT_CY (integer)
VT_DATE (integer)
VT_BSTR (integer)
VT_DECIMAL (integer)
VT_UNKNOWN (integer)
VT_DISPATCH (integer)
VT_VARIANT (integer)
VT_I1 (integer)
VT_UI2 (integer)
VT_UI4 (integer)
VT_INT (integer)
VT_UINT (integer)
VT_ARRAY (integer)
VT_BYREF (integer)
CP_ACP (integer)
CP_MACCP (integer)
CP_OEMCP (integer)
CP_UTF7 (integer)
CP_UTF8 (integer)
CP_SYMBOL (integer)
CP_THREAD_ACP (integer)
VARCMP_LT (integer)
VARCMP_EQ (integer)
VARCMP_GT (integer)
VARCMP_NULL (integer)
NORM_IGNORECASE (integer)
NORM_IGNORENONSPACE (integer)
NORM_IGNORESYMBOLS (integer)
NORM_IGNOREWIDTH (integer)
NORM_IGNOREKANATYPE (integer)
NORM_IGNOREKASHIDA (integer)
DISP_E_DIVBYZERO (integer)
DISP_E_OVERFLOW (integer)
MK_E_UNAVAILABLE (integer)

Viz také

Více informací o COM naleznete ve » specifikaci COM nebo se třeba podívejte na » Yet Another COM Library (YACL) Dona Boxe.

Obsah

COM — COM class
DOTNET — DOTNET class
VARIANT — VARIANT class
com_addref — Increases the components reference counter [deprecated]
com_create_guid — Generate a globally unique identifier (GUID)
com_event_sink — Connect events from a COM object to a PHP object
com_get_active_object — Returns a handle to an already running instance of a COM object
com_get — Získává hodnotu vlastnosti COM komponenty
com_invoke — Volá metodu COM komponenty.
com_isenum — Indicates if a COM object has an IEnumVariant interface for iteration [deprecated]
com_load_typelib — Loads a Typelib
com_load — Vytvoří nový odkaz na COM komponentu
com_message_pump — Process COM messages, sleeping for up to timeoutms milliseconds
com_print_typeinfo — Print out a PHP class definition for a dispatchable interface
com_propget — Získává hodnotu vlastnosti COM komponenty
com_propput — Přiřazuje hodnotu vlastnosti COM komponenty.
com_propset — Přiřazuje hodnotu vlastnosti COM komponenty.
com_release — Decreases the components reference counter [deprecated]
com_set — Přiřazuje hodnotu vlastnosti COM komponenty.
variant_abs — Returns the absolute value of a variant
variant_add — "Adds" two variant values together and returns the result
variant_and — performs a bitwise AND operation between two variants and returns the result
variant_cast — Convert a variant into a new variant object of another type
variant_cat — concatenates two variant values together and returns the result
variant_cmp — Compares two variants
variant_date_from_timestamp — Returns a variant date representation of a Unix timestamp
variant_date_to_timestamp — Converts a variant date/time value to Unix timestamp
variant_div — Returns the result from dividing two variants
variant_eqv — Performs a bitwise equivalence on two variants
variant_fix — Returns the integer portion ? of a variant
variant_get_type — Returns the type of a variant object
variant_idiv — Converts variants to integers and then returns the result from dividing them
variant_imp — Performs a bitwise implication on two variants
variant_int — Returns the integer portion of a variant
variant_mod — Divides two variants and returns only the remainder
variant_mul — multiplies the values of the two variants and returns the result
variant_neg — Performs logical negation on a variant
variant_not — Performs bitwise not negation on a variant
variant_or — Performs a logical disjunction on two variants
variant_pow — Returns the result of performing the power function with two variants
variant_round — Rounds a variant to the specified number of decimal places
variant_set_type — Convert a variant into another type "in-place"
variant_set — Assigns a new value for a variant object
variant_sub — subtracts the value of the right variant from the left variant value and returns the result
variant_xor — Performs a logical exclusion on two variants
Předcházející | Nahoru | Další
cpdf_translate | Domů | COM


COM

(No version information available, might be only in CVS)

COM — COM class

Přehled

$obj = new COM("Application.ID")

Description

The COM class allows you to instantiate an OLE compatible COM object and call its methods and access its properties.

Methods

com COM::COM ( string $module_name [, mixed $server_name [, int $codepage [, string $typelib]]] )

COM class constructor. The parameters have the following meanings:

module_name

Can be a ProgID, Class ID or Moniker that names the component to load.

A ProgID is typically the application or DLL name, followed by a period, followed by the object name. e.g: Word.Application.

A Class ID is the UUID that uniquely identifies a given class.

A Moniker is a special form of naming, similar in concept to a URL scheme, that identifies a resource and specifies how it should be loaded. As an example, you could load up Word and get an object representing a word document by specifying the full path to the word document as the module name, or you can use LDAP: as a moniker to use the ADSI interface to LDAP.

server_name

The name of the DCOM server on which the component should be loaded and run. If NULL, the object is run using the default for the application. The default is typically to run it on the local machine, although the administrator might have configured the application to launch on a different machine.

If you specify a non-NULL value for server, PHP will refuse to load the object unless the com.allow_dcom configuration option is set to TRUE.

If server_name is an array, it should contain the following elements (case sensitive!). Note that they are all optional (although you need to specify both Username and Password together); if you omit the Server setting, the default server will be used (as mentioned above), and the instantiation of the object will not be affected by the com.allow_dcom directive.

Tabulka 19. DCOM server name

server_name key | type | description
Server | string | The name of the server.
Username | string | The username to connect as.
Password | string | The password for Username.
Flags | integer | One or more of the following constants, logically OR'd together: CLSCTX_INPROC_SERVER, CLSCTX_INPROC_HANDLER, CLSCTX_LOCAL_SERVER, CLSCTX_REMOTE_SERVER, CLSCTX_SERVER and CLSCTX_ALL. The default value if not specified here is CLSCTX_SERVER if you also omit Server, or CLSCTX_REMOTE_SERVER if you do specify a server. You should consult the Microsoft documentation for CoCreateInstance for more information on the meaning of these constants; you will typically never have to use them.

codepage

Specifies the codepage that is used to convert strings to unicode-strings and vice versa. The conversion is applied whenever a PHP string is passed as a parameter or returned from a method of this COM object. The code page is sticky in PHP 5, which means that it will propagate to objects and variants returned from the object.

Possible values are CP_ACP (use system default ANSI code page - the default if this parameter is omitted), CP_MACCP, CP_OEMCP, CP_SYMBOL, CP_THREAD_ACP (use codepage/locale set for the current executing thread), CP_UTF7 and CP_UTF8. You may also use the number for a given codepage; consult the Microsoft documentation for more details on codepages and their numeric values.

Overloaded Methods

The returned object is an overloaded object, which means that PHP does not see any fixed methods as it does with regular classes; instead, any property or method accesses are passed through to COM.

Starting with PHP 5, PHP will automatically detect methods that accept parameters by reference, and will automatically convert regular PHP variables to a form that can be passed by reference. This means that you can call the method very naturally; you needn't go to any extra effort in your code.

In PHP 4, to pass parameters by reference you need to create an instance of the VARIANT class to wrap the byref parameters.

Pseudo Methods

In PHP versions prior to 5, a number of not very pleasant hacks meant that the following method names were not passed through to COM and were handled directly by PHP. PHP 5 eliminates these things; read the details below to determine how to fix your scripts. These magic method names are case insensitive.

void COM::AddRef ( void )

Artificially adds a reference count to the COM object.

Varování

You should never need to use this method. It exists as a logical complement to the Release() method below.

void COM::Release ( void )

Artificially removes a reference count from the COM object.

Varování

You should never need to use this method. Its existence in PHP is a bug designed to work around a bug that keeps COM objects running longer than they should.

Pseudo Methods for Iterating

These pseudo methods are only available if com_isenum() returns TRUE, in which case, they hide any methods with the same names that might otherwise be provided by the COM object. These methods have all been eliminated in PHP 5, and you should use com.foreach instead.

variant COM::All ( void )

Returns a variant representing a SafeArray that has 10 elements; each element will be an empty/null variant. This function was supposed to return an array containing all the elements from the iterator, but was never completed. Do not use.

variant COM::Next ( void )

Returns a variant representing the next element available from the iterator, or FALSE when there are no more elements.

variant COM::Prev ( void )

Returns a variant representing the previous element available from the iterator, or FALSE when there are no more elements.

void COM::Reset ( void )

Rewinds the iterator back to the start.

COM examples

Příklad 315. COM example (1)

<?php
// starting word
$word = new COM("word.application") or die("Unable to instantiate Word");
echo "Loaded Word, version {$word->Version}\n";

//bring it to front
$word->Visible = 1;

//open an empty document
$word->Documents->Add();

//do some weird stuff
$word->Selection->TypeText("This is a test...");
$word->Documents[1]->SaveAs("Useless test.doc");

//closing word
$word->Quit();

//free the object
$word = null;
?>

Příklad 316. COM example (2)

<?php

$conn = new COM("ADODB.Connection") or die("Cannot start ADO");
$conn->Open("Provider=SQLOLEDB; Data Source=localhost;
Initial Catalog=database; User ID=user; Password=password");

$rs = $conn->Execute("SELECT * FROM sometable");    // Recordset

$num_columns = $rs->Fields->Count();
echo $num_columns . "\n";

for ($i=0; $i < $num_columns; $i++) {
    $fld[$i] = $rs->Fields($i);
}

$rowcount = 0;
while (!$rs->EOF) {
    for ($i=0; $i < $num_columns; $i++) {
        echo $fld[$i]->value . "\t";
    }
    echo "\n";
    $rowcount++;            // increments rowcount
    $rs->MoveNext();
}

$rs->Close();
$conn->Close();

$rs = null;
$conn = null;

?>

Předcházející | Nahoru | Další
XVI. Funkce na podporu COM ve Windows | Domů | DOTNET


DOTNET

(No version information available, might be only in CVS)

DOTNET — DOTNET class

Přehled

$obj = new DOTNET("assembly", "classname")

Description

The DOTNET class allows you to instantiate a class from a .Net assembly and call its methods and access its properties.

Methods

string DOTNET::DOTNET ( string $assembly_name, string $class_name [, int $codepage] )

DOTNET class constructor. assembly_name specifies which assembly should be loaded, and class_name specifices which class in that assembly to instantiate. You may optionally specify a codepage to use for unicode string transformations; see the COM class for more details on code pages.

The returned object is an overloaded object, which means that PHP does not see any fixed methods as it does with regular classes; instead, any property or method accesses are passed through to COM and from there to DOTNET. In other words, the .Net object is mapped through the COM interoperability layer provided by the .Net runtime.

Once you have created a DOTNET object, PHP treats it identically to any other COM object; all the same rules apply.

Příklad 317. DOTNET example

<?php
  $stack = new DOTNET("mscorlib", "System.Collections.Stack");
  $stack->Push(".Net");
  $stack->Push("Hello ");
  echo $stack->Pop() . $stack->Pop();
?>

Poznámka: You need to install the .Net runtime on your web server to take advantage of this feature.

Předcházející | Nahoru | Další
COM | Domů | VARIANT


VARIANT

(No version information available, might be only in CVS)

VARIANT — VARIANT class

Přehled

$vVar = new VARIANT($var)

Description

The VARIANT is COM's equivalent of the PHP zval; it is a structure that can contain a value with a range of different possible types. The VARIANT class provided by the COM extension allows you to have more control over the way that PHP passes values to and from COM.

Methods

object VARIANT::VARIANT ( [mixed $value [, int $type [, int $codepage]]] )

VARIANT class constructor. Parameters:

value
initial value. if omitted, or set to NULL an VT_EMPTY object is created.
type

specifies the content type of the VARIANT object. Possible values are one of the VT_XXX „Předdefinované konstanty“.

In PHP versions prior to PHP 5, you could force PHP to pass a variant object by reference by OR'ing VT_BYREF with the type. In PHP 5, this hack is not supported; instead, PHP 5 can detect parameters passed by reference automatically; they do not even need to be passed as VARIANT objects.

Consult the MSDN library for additional information on the VARIANT type.

codepage
specifies the codepage that is used to convert strings to unicode. See the parameter of the same name in the COM class for more information.

PHP versions prior to PHP 5 define a number of (undocumented) virtual properties for instances of the VARIANT class; these properties have all been removed in PHP 5 in favour of its more natural syntax; these differences are best highlighted by example:

Příklad 318. Variant example, PHP 4.x style

<?php
$v = new VARIANT(42);
print "The type is " . $v->type . "<br/>";
print "The value is " . $v->value . "<br/>";
?>

Příklad 319. Variant example, PHP 5 style

<?php
$v = new VARIANT(42);
print "The type is " . variant_get_type($v) . "<br/>";
print "The value is " . $v . "<br/>";
?>

The reason for the change is that, internally, the COM extension sees VARIANT, COM and DOTNET classes as the same thing, and the design philosophy for these classes is that all property and member accesses are passed through to COM with no interference. The new syntax is more natural and less effort, and most of the removed virtual properties didn't make any sense in a PHP context in any case.

Poznámka: PHP 5 takes a much simpler approach to handling VARIANTs; when returning a value or fetching a variant property, the variant is converted to a PHP value only when there is a direct mapping between the types that would not result in a loss of information. In all other cases, the result is returned as an instance of the VARIANT class. You can force PHP to convert or evaluate the variant as a PHP native type by using a casting operator explicitly, or implicitly casting to a string by print()ing it. You may use the wide range of variant functions to perform arithmetic operations on variants without forcing a conversion or risking a loss of data.

See also variant_get_type().

Předcházející | Nahoru | Další
DOTNET | Domů | com_addref


com_addref

(PHP 4 >= 4.0.7)

com_addref — Increases the components reference counter [deprecated]

Description

void com_addref ( void )

Increases the components reference counter.

Varování

You should never need to use this function.

Předcházející | Nahoru | Další
VARIANT | Domů | com_create_guid


com_create_guid

(PHP 5)

com_create_guid — Generate a globally unique identifier (GUID)

Description

string com_create_guid ( void )

Generates a Globally Unique Identifier (GUID) and returns it as a string. A GUID is generated in the same way as DCE UUID's, except that the Microsoft convention is to enclose a GUID in curly braces.

See also uuid_create() in the PECL uuid extension.

Předcházející | Nahoru | Další
com_addref | Domů | com_event_sink


com_event_sink

(PHP 4 >= 4.2.0, PHP 5)

com_event_sink — Connect events from a COM object to a PHP object

Description

bool com_event_sink ( variant $comobject, object $sinkobject [, mixed $sinkinterface] )

Instructs COM to sink events generated by comobject into the PHP object sinkobject. PHP will attempt to use the default dispinterface type specified by the typelibrary associated with comobject, but you may override this choice by setting sinkinterface to the name of the dispinterface that you want to use.

sinkobject should be an instance of a class with methods named after those of the desired dispinterface; you may use com_print_typeinfo() to help generate a template class for this purpose.

Be careful how you use this feature; if you are doing something similar to the example below, then it doesn't really make sense to run it in a web server context.

Příklad 320. COM event sink example

<?php
class IEEventSinker {
  var $terminated = false;

  function ProgressChange($progress, $progressmax) {
    echo "Download progress: $progress / $progressmax\n";
  }

  function DocumentComplete(&$dom, $url) {
    echo "Document $url complete\n";
  }

  function OnQuit() {
    echo "Quit!\n";
    $this->terminated = true;
  }
}
$ie = new COM("InternetExplorer.Application");
// note that you don't need the & for PHP 5!
$sink =& new IEEventSinker();
com_event_sink($ie, $sink, "DWebBrowserEvents2");
$ie->Visible = true;
$ie->Navigate("http://www.php.net");
while(!$sink->terminated) {
  com_message_pump(4000);
}
$ie = null;
?>

See also com_print_typeinfo(), com_message_pump().

Předcházející | Nahoru | Další
com_create_guid | Domů | com_get_active_object


com_get_active_object

(PHP 5)

com_get_active_object — Returns a handle to an already running instance of a COM object

Description

variant com_get_active_object ( string $progid [, int $code_page] )

com_get_active_object() is similar to creating a new instance of a COM object, except that it will only return an object to your script if the object is already running. OLE applications use something known as the Running Object Table to allow well-known applications to be launched only once; this function exposes the COM library function GetActiveObject() to get a handle on a running instance.

progid must be either the ProgID or CLSID for the object that you want to access (for example Word.Application). code_page acts in precisely the same way that it does for the COM class.

If the requested object is running, it will be returned to your script just like any other COM object. Otherwise a com_exception will be raised. There are a variety of reasons why this function might fail, the most common being that the object is not already running. In that situation, the exception error code will be MK_E_UNAVAILABLE; you can use the getCode method of the exception object to check the exception code.

Varování

Using com_get_active_object() in a web server context is not always a smart idea. Most COM/OLE applications are not designed to handle more than one client concurrently, even (or especially!) Microsoft Office. You should read » Considerations for Server-Side Automation of Office for more information on the general issues involved.

Předcházející | Nahoru | Další
com_event_sink | Domů | com_get


com_get

(PHP 4)

com_get — Získává hodnotu vlastnosti COM komponenty

Popis

mixed com_get ( resource $com_object, string $property )

Vrací hodnotu property COM komponenty odkazované com_object. Při chybě vrací FALSE.

Předcházející | Nahoru | Další
com_get_active_object | Domů | com_invoke


com_invoke

(PHP 4)

com_invoke — Volá metodu COM komponenty.

Popis

mixed com_invoke ( resource $com_object, string $function_name [, mixed $function_parameters] )

com_invoke() volá metodu COM komponenty odkazované com_object. Pokud dojde k chybě, vrací FALSE, při úspěchu vrací návratovou hodnotu metody function_name.

Předcházející | Nahoru | Další
com_get | Domů | com_isenum


com_isenum

(PHP 4 >= 4.0.7)

com_isenum — Indicates if a COM object has an IEnumVariant interface for iteration [deprecated]

Description

bool com_isenum ( variant $com_module )

Checks to see if a COM object can be enumerated using the Next() method hack. Returns TRUE if it can, FALSE if it cannot. See COM class for more details on these methods.

Poznámka: This function does not exist in PHP 5; use the more natural foreach statement to iterate over the contents of COM objects. See com.foreach for more details.

Předcházející | Nahoru | Další
com_invoke | Domů | com_load_typelib


com_load_typelib

(PHP 4 >= 4.0.7, PHP 5)

com_load_typelib — Loads a Typelib

Description

bool com_load_typelib ( string $typelib_name [, bool $case_insensitive] )

Loads a type-library and registers its constants in the engine, as though they were defined using define(). The case_insensitive behaves in the same way as the parameter with the same name in the define() function.

typelib_name can be one of the following:

  • The filename of a .tlb file or the executable module that contains the type library.

  • The type library GUID, followed by its version number, for example {00000200-0000-0010-8000-00AA006D2EA4},2,0.

  • The type library name, e.g. Microsoft OLE DB ActiveX Data Objects 1.0 Library.

PHP will attempt to resolve the type library in this order, as the process gets more and more expensive as you progress down the list; searching for the type library by name is handled by physically enumerating the registry until we find a match.

Note that it is much more efficient to use the com.typelib_file configuration setting to pre-load and register the constants, although not so flexible.

If you have turned on com.autoregister_typelib , then PHP will attempt to automatically register the constants associated with a COM object when you instantiate it. This depends on the interfaces provided by the COM object itself, and may not always be possible.

Předcházející | Nahoru | Další
com_isenum | Domů | com_load


com_load

(PHP 4)

com_load — Vytvoří nový odkaz na COM komponentu

Popis

resource com_load ( string $module_name [, string $ server_name [, int $ codepage ]] )

com_load() vytváří novou COM komponentu a vrací odkaz na ni. Při neúspěchu vrací FALSE.

Předcházející | Nahoru | Další
com_load_typelib | Domů | com_message_pump


com_message_pump

(PHP 4 >= 4.2.0, PHP 5)

com_message_pump — Process COM messages, sleeping for up to timeoutms milliseconds

Description

bool com_message_pump ( [int $timeoutms] )

This function will sleep for up to timeoutms milliseconds, or until a message arrives in the queue. If a message or messages arrives before the timeout, they will be dispatched, and the function will return TRUE. If the timeout occurs and no messages were processed, the return value will be FALSE. If you do not specify a value for timeoutms, then 0 will be assumed. A 0 value means that no waiting will be performed; if there are messages pending they will be dispatched as before; if there are no messages pending, the function will return FALSE immediately without sleeping.

The purpose of this function is to route COM calls between apartments and handle various synchronization issues. This allows your script to wait efficiently for events to be triggered, while still handling other events or running other code in the background. You should use it in a loop, as demonstrated by the example in the com_event_sink() function, until you are finished using event bound COM objects.

Předcházející | Nahoru | Další
com_load | Domů | com_print_typeinfo


com_print_typeinfo

(PHP 4 >= 4.2.0, PHP 5)

com_print_typeinfo — Print out a PHP class definition for a dispatchable interface

Description

bool com_print_typeinfo ( object $comobject [, string $dispinterface [, bool $wantsink]] )

The purpose of this function is to help generate a skeleton class for use as an event sink. You may also use it to generate a dump of any COM object, provided that it supports enough of the introspection interfaces, and that you know the name of the interface you want to display.

comobject should be either an instance of a COM object, or be the name of a typelibrary (which will be resolved according to the rules set out in com_load_typelib()). dispinterface is the name of an IDispatch descendant interface that you want to display. If wantsink is TRUE, the corresponding sink interface will be displayed instead.

See also com_event_sink(), com_load_typelib().

Předcházející | Nahoru | Další
com_message_pump | Domů | com_propget


com_propget

(PHP 4)

com_propget — Získává hodnotu vlastnosti COM komponenty

Popis

mixed com_propget ( resource $com_object, string $property )

Tato funkce je alias k com_get().

Předcházející | Nahoru | Další
com_print_typeinfo | Domů | com_propput


com_propput

(PHP 4)

com_propput — Přiřazuje hodnotu vlastnosti COM komponenty.

Popis

void com_propput ( resource $com_object, string $property, mixed $value )

Tato funkce je alias ke com_set().

Předcházející | Nahoru | Další
com_propget | Domů | com_propset


com_propset

(PHP 4)

com_propset — Přiřazuje hodnotu vlastnosti COM komponenty.

Popis

void com_propset ( resource $com_object, string $property, mixed $value )

Tato funkce je alias ke com_set().

Předcházející | Nahoru | Další
com_propput | Domů | com_release


com_release

(PHP 4 >= 4.0.7)

com_release — Decreases the components reference counter [deprecated]

Description

void com_release ( void )

Decreases the components reference counter.

Varování

You should never need to use this function.

Poznámka: This function has gone away in PHP 5.

Předcházející | Nahoru | Další
com_propset | Domů | com_set


com_set

(PHP 4)

com_set — Přiřazuje hodnotu vlastnosti COM komponenty.

Popis

void com_set ( resource $com_object, string $property, mixed $value )

Nastavuje hodnotu vlastnosti property COM komponent odkazované com_object. Vrací TRUE, pokud je property nastaveno. Při chybě vrací FALSE.

Předcházející | Nahoru | Další
com_release | Domů | variant_abs


variant_abs

(PHP 5)

variant_abs — Returns the absolute value of a variant

Description

mixed variant_abs ( mixed $val )

Returns the absolute value of val.

See also abs().

Poznámka: As with all the variant arithmetic functions, the parameters for this function can be either a PHP native type (integer, string, floating point, boolean or NULL), or an instance of a COM, VARIANT or DOTNET class. PHP native types will be converted to variants using the same rules as found in the constructor for the VARIANT class. COM and DOTNET objects will have the value of their default property taken and used as the variant value.

The variant arithmetic functions are wrappers around the similarly named functions in the COM library; for more information on these functions, consult the MSDN library. The PHP functions are named slightly differently; for example variant_add() in PHP corresponds to VarAdd() in the MSDN documentation.

Předcházející | Nahoru | Další
com_set | Domů | variant_add


variant_add

(PHP 5)

variant_add — "Adds" two variant values together and returns the result

Description

mixed variant_add ( mixed $left, mixed $right )

Adds left to right using the following rules (taken from the MSDN library), which correspond to those of Visual Basic:

Tabulka 20. Variant Addition Rules

If | Then
Both expressions are of the string type | Concatenation
One expression is a string type and the other a character | Addition
One expression is numeric and the other is a string | Addition
Both expressions are numeric | Addition
Either expression is NULL | NULL is returned
Both expressions are empty | Integer subtype is returned

See also variant_sub().

Poznámka: As with all the variant arithmetic functions, the parameters for this function can be either a PHP native type (integer, string, floating point, boolean or NULL), or an instance of a COM, VARIANT or DOTNET class. PHP native types will be converted to variants using the same rules as found in the constructor for the VARIANT class. COM and DOTNET objects will have the value of their default property taken and used as the variant value.

The variant arithmetic functions are wrappers around the similarly named functions in the COM library; for more information on these functions, consult the MSDN library. The PHP functions are named slightly differently; for example variant_add() in PHP corresponds to VarAdd() in the MSDN documentation.

Předcházející | Nahoru | Další
variant_abs | Domů | variant_and


variant_and

(PHP 5)

variant_and — performs a bitwise AND operation between two variants and returns the result

Description

mixed variant_and ( mixed $left, mixed $right )

Performs a bitwise AND operation, according to the following truth table; note that this is slightly different from a regular AND operation.

Tabulka 21. Variant AND Rules

If left is | If right is | then the result is
TRUE | TRUE | TRUE
TRUE | FALSE | FALSE
TRUE | NULL | NULL
FALSE | TRUE | FALSE
FALSE | FALSE | FALSE
FALSE | NULL | FALSE
NULL | TRUE | NULL
NULL | FALSE | FALSE
NULL | NULL | NULL

See also variant_or().

Poznámka: As with all the variant arithmetic functions, the parameters for this function can be either a PHP native type (integer, string, floating point, boolean or NULL), or an instance of a COM, VARIANT or DOTNET class. PHP native types will be converted to variants using the same rules as found in the constructor for the VARIANT class. COM and DOTNET objects will have the value of their default property taken and used as the variant value.

The variant arithmetic functions are wrappers around the similarly named functions in the COM library; for more information on these functions, consult the MSDN library. The PHP functions are named slightly differently; for example variant_add() in PHP corresponds to VarAdd() in the MSDN documentation.

Předcházející | Nahoru | Další
variant_add | Domů | variant_cast


variant_cast

(PHP 5)

variant_cast — Convert a variant into a new variant object of another type

Description

variant variant_cast ( variant $variant, int $type )

This function makes a copy of variant and then performs a variant cast operation to force the copy to have the type given by type. type should be one of the VT_XXX constants.

This function wraps VariantChangeType() in the COM library; consult MSDN for more information.

See also variant_set_type().

Předcházející | Nahoru | Další
variant_and | Domů | variant_cat


variant_cat

(PHP 5)

variant_cat — concatenates two variant values together and returns the result

Description

mixed variant_cat ( mixed $left, mixed $right )

Concatenates left with right and returns the result.

See also „Řetězcové operátory“ for the string concatenation operator; this function is notionally equivalent to $left . $right.

Poznámka: As with all the variant arithmetic functions, the parameters for this function can be either a PHP native type (integer, string, floating point, boolean or NULL), or an instance of a COM, VARIANT or DOTNET class. PHP native types will be converted to variants using the same rules as found in the constructor for the VARIANT class. COM and DOTNET objects will have the value of their default property taken and used as the variant value.

The variant arithmetic functions are wrappers around the similarly named functions in the COM library; for more information on these functions, consult the MSDN library. The PHP functions are named slightly differently; for example variant_add() in PHP corresponds to VarAdd() in the MSDN documentation.

Předcházející | Nahoru | Další
variant_cast | Domů | variant_cmp


variant_cmp

(PHP 5)

variant_cmp — Compares two variants

Description

int variant_cmp ( mixed $left, mixed $right [, int $lcid [, int $flags]] )

Compares left with right and returns one of the following values:

Tabulka 22. Variant Comparision Results

value | meaning
VARCMP_LT | left is less than right
VARCMP_EQ | left is equal to right
VARCMP_GT | left is greater than right
VARCMP_NULL | Either left, right or both are NULL

This function will only compare scalar values, not arrays or variant records.

lcid is a valid Locale Identifier to use when comparing strings (this affects string collation). flags can be one or more of the following values OR'd together, and affects string comparisons:

Tabulka 23. Variant Comparision Flags

value | meaning
NORM_IGNORECASE | Compare case insensitively
NORM_IGNORENONSPACE | Ignore nonspacing characters
NORM_IGNORESYMBOLS | Ignore symbols
NORM_IGNOREWIDTH | Ignore string width
NORM_IGNOREKANATYPE | Ignore Kana type
NORM_IGNOREKASHIDA | Ignore Arabic kashida characters

Poznámka: As with all the variant arithmetic functions, the parameters for this function can be either a PHP native type (integer, string, floating point, boolean or NULL), or an instance of a COM, VARIANT or DOTNET class. PHP native types will be converted to variants using the same rules as found in the constructor for the VARIANT class. COM and DOTNET objects will have the value of their default property taken and used as the variant value.

The variant arithmetic functions are wrappers around the similarly named functions in the COM library; for more information on these functions, consult the MSDN library. The PHP functions are named slightly differently; for example variant_add() in PHP corresponds to VarAdd() in the MSDN documentation.

Předcházející | Nahoru | Další
variant_cat | Domů | variant_date_from_timestamp


variant_date_from_timestamp

(PHP 5)

variant_date_from_timestamp — Returns a variant date representation of a Unix timestamp

Description

variant variant_date_from_timestamp ( int $timestamp )

Converts timestamp from a unix timestamp value into a variant of type VT_DATE. This allows easier interopability between the unix-ish parts of PHP and COM.

See also variant_date_to_timestamp() for the inverse of this operation, mktime(), time().

Předcházející | Nahoru | Další
variant_cmp | Domů | variant_date_to_timestamp


variant_date_to_timestamp

(PHP 5)

variant_date_to_timestamp — Converts a variant date/time value to Unix timestamp

Description

int variant_date_to_timestamp ( variant $variant )

Converts variant from a VT_DATE (or similar) value into a Unix timestamp. This allows easier interopability between the Unix-ish parts of PHP and COM.

See also variant_date_from_timestamp() for the inverse of this operation, date(), strftime().

Předcházející | Nahoru | Další
variant_date_from_timestamp | Domů | variant_div


variant_div

(PHP 5)

variant_div — Returns the result from dividing two variants

Description

mixed variant_div ( mixed $left, mixed $right )

Divides left by right and returns the result, subject to the following rules:

Tabulka 24. Variant Division Rules

If | Then
Both expressions are of the string, date, character, boolean type | Double is returned
One expression is a string type and the other a character | Division and a double is returned
One expression is numeric and the other is a string | Division and a double is returned.
Both expressions are numeric | Division and a double is returned
Either expression is NULL | NULL is returned
right is empty and left is anything but empty | A com_exception with code DISP_E_DIVBYZERO is thrown
left is empty and right is anything but empty. | 0 as type double is returned
Both expressions are empty | A com_exception with code DISP_E_OVERFLOW is thrown

Poznámka: As with all the variant arithmetic functions, the parameters for this function can be either a PHP native type (integer, string, floating point, boolean or NULL), or an instance of a COM, VARIANT or DOTNET class. PHP native types will be converted to variants using the same rules as found in the constructor for the VARIANT class. COM and DOTNET objects will have the value of their default property taken and used as the variant value.

The variant arithmetic functions are wrappers around the similarly named functions in the COM library; for more information on these functions, consult the MSDN library. The PHP functions are named slightly differently; for example variant_add() in PHP corresponds to VarAdd() in the MSDN documentation.

Předcházející | Nahoru | Další
variant_date_to_timestamp | Domů | variant_eqv


variant_eqv

(PHP 5)

variant_eqv — Performs a bitwise equivalence on two variants

Description

mixed variant_eqv ( mixed $left, mixed $right )

If each bit in left is equal to the corresponding bit in right then TRUE is returned, otherwise FALSE is returned.

Poznámka: As with all the variant arithmetic functions, the parameters for this function can be either a PHP native type (integer, string, floating point, boolean or NULL), or an instance of a COM, VARIANT or DOTNET class. PHP native types will be converted to variants using the same rules as found in the constructor for the VARIANT class. COM and DOTNET objects will have the value of their default property taken and used as the variant value.

The variant arithmetic functions are wrappers around the similarly named functions in the COM library; for more information on these functions, consult the MSDN library. The PHP functions are named slightly differently; for example variant_add() in PHP corresponds to VarAdd() in the MSDN documentation.

Předcházející | Nahoru | Další
variant_div | Domů | variant_fix


variant_fix

(PHP 5)

variant_fix — Returns the integer portion ? of a variant

Description

mixed variant_fix ( mixed $variant )

If variant is negative, then the first negative integer greater than or equal to the variant is returned, otherwise returns the integer portion of the value of variant.

See also variant_int(),
variant_round(), floor(),
ceil(),
round().

Varování

This documentation is based on the MSDN documentation; it appears that this function is either the same as variant_int(), or that there is an error in the MSDN documentation.

Poznámka: As with all the variant arithmetic functions, the parameters for this function can be either a PHP native type (integer, string, floating point, boolean or NULL), or an instance of a COM, VARIANT or DOTNET class. PHP native types will be converted to variants using the same rules as found in the constructor for the VARIANT class. COM and DOTNET objects will have the value of their default property taken and used as the variant value.

The variant arithmetic functions are wrappers around the similarly named functions in the COM library; for more information on these functions, consult the MSDN library. The PHP functions are named slightly differently; for example variant_add() in PHP corresponds to VarAdd() in the MSDN documentation.

Předcházející | Nahoru | Další
variant_eqv | Domů | variant_get_type


variant_get_type

(PHP 5)

variant_get_type — Returns the type of a variant object

Description

int variant_get_type ( variant $variant )

This function returns an integer value that indicates the type of variant, which can be an instance of COM, DOTNET or VARIANT classes. The return value can be compared to one of the VT_XXX constants.

The return value for COM and DOTNET objects will usually be VT_DISPATCH; the only reason this function works for those classes is because COM and DOTNET are descendants of VARIANT.

In PHP versions prior to 5, you could obtain this information from instances of the VARIANT class ONLY, by reading a fake type property. See the VARIANT class for more information on this.

Předcházející | Nahoru | Další
variant_fix | Domů | variant_idiv


variant_idiv

(PHP 5)

variant_idiv — Converts variants to integers and then returns the result from dividing them

Description

mixed variant_idiv ( mixed $left, mixed $right )

Converts left and right to integer values, and then performs integer division according the following rules:

Tabulka 25. Variant Integer Division Rules

If | Then
Both expressions are of the string, date, character, boolean type | Division and integer is returned
One expression is a string type and the other a character | Division
One expression is numeric and the other is a string | Division
Both expressions are numeric | Division
Either expression is NULL | NULL is returned
Both expressions are empty | A com_exception with code DISP_E_DIVBYZERO is thrown

See also variant_div().

Poznámka: As with all the variant arithmetic functions, the parameters for this function can be either a PHP native type (integer, string, floating point, boolean or NULL), or an instance of a COM, VARIANT or DOTNET class. PHP native types will be converted to variants using the same rules as found in the constructor for the VARIANT class. COM and DOTNET objects will have the value of their default property taken and used as the variant value.

The variant arithmetic functions are wrappers around the similarly named functions in the COM library; for more information on these functions, consult the MSDN library. The PHP functions are named slightly differently; for example variant_add() in PHP corresponds to VarAdd() in the MSDN documentation.

Předcházející | Nahoru | Další
variant_get_type | Domů | variant_imp


variant_imp

(PHP 5)

variant_imp — Performs a bitwise implication on two variants

Description

mixed variant_imp ( mixed $left, mixed $right )

Performs a bitwise implication operation, according to the following truth table:

Tabulka 26. Variant Implication Table

If left is | If right is | then the result is
TRUE | TRUE | TRUE
TRUE | FALSE | TRUE
TRUE | NULL | TRUE
FALSE | TRUE | TRUE
FALSE | FALSE | TRUE
FALSE | NULL | TRUE
NULL | TRUE | TRUE
NULL | FALSE | NULL
NULL | NULL | NULL

Poznámka: As with all the variant arithmetic functions, the parameters for this function can be either a PHP native type (integer, string, floating point, boolean or NULL), or an instance of a COM, VARIANT or DOTNET class. PHP native types will be converted to variants using the same rules as found in the constructor for the VARIANT class. COM and DOTNET objects will have the value of their default property taken and used as the variant value.

The variant arithmetic functions are wrappers around the similarly named functions in the COM library; for more information on these functions, consult the MSDN library. The PHP functions are named slightly differently; for example variant_add() in PHP corresponds to VarAdd() in the MSDN documentation.

Předcházející | Nahoru | Další
variant_idiv | Domů | variant_int


variant_int

(PHP 5)

variant_int — Returns the integer portion of a variant

Description

mixed variant_int ( mixed $variant )

If variant is negative, then the first negative integer greater than or equal to the variant is returned, otherwise returns the integer portion of the value of variant.

See also variant_fix(),
variant_round(), floor(),
ceil(),
round().

Poznámka: As with all the variant arithmetic functions, the parameters for this function can be either a PHP native type (integer, string, floating point, boolean or NULL), or an instance of a COM, VARIANT or DOTNET class. PHP native types will be converted to variants using the same rules as found in the constructor for the VARIANT class. COM and DOTNET objects will have the value of their default property taken and used as the variant value.

The variant arithmetic functions are wrappers around the similarly named functions in the COM library; for more information on these functions, consult the MSDN library. The PHP functions are named slightly differently; for example variant_add() in PHP corresponds to VarAdd() in the MSDN documentation.

Předcházející | Nahoru | Další
variant_imp | Domů | variant_mod


variant_mod

(PHP 5)

variant_mod — Divides two variants and returns only the remainder

Description

mixed variant_mod ( mixed $left, mixed $right )

Divides left by right and returns the remainder.

See also variant_div(), variant_idiv().

Poznámka: As with all the variant arithmetic functions, the parameters for this function can be either a PHP native type (integer, string, floating point, boolean or NULL), or an instance of a COM, VARIANT or DOTNET class. PHP native types will be converted to variants using the same rules as found in the constructor for the VARIANT class. COM and DOTNET objects will have the value of their default property taken and used as the variant value.

The variant arithmetic functions are wrappers around the similarly named functions in the COM library; for more information on these functions, consult the MSDN library. The PHP functions are named slightly differently; for example variant_add() in PHP corresponds to VarAdd() in the MSDN documentation.

Předcházející | Nahoru | Další
variant_int | Domů | variant_mul


variant_mul

(PHP 5)

variant_mul — multiplies the values of the two variants and returns the result

Description

mixed variant_mul ( mixed $left, mixed $right )

Multiplies left by right and returns the result, subject to the following rules:

Tabulka 27. Variant Multiplication Rules

If | Then
Both expressions are of the string, date, character, boolean type | Multiplication
One expression is a string type and the other a character | Multiplication
One expression is numeric and the other is a string | Multiplication
Both expressions are numeric | Multiplication
Either expression is NULL | NULL is returned
Both expressions are empty | Empty string is returned

Boolean values are converted to -1 for FALSE and 0 for TRUE.

See also variant_div(), variant_idiv().

Poznámka: As with all the variant arithmetic functions, the parameters for this function can be either a PHP native type (integer, string, floating point, boolean or NULL), or an instance of a COM, VARIANT or DOTNET class. PHP native types will be converted to variants using the same rules as found in the constructor for the VARIANT class. COM and DOTNET objects will have the value of their default property taken and used as the variant value.

The variant arithmetic functions are wrappers around the similarly named functions in the COM library; for more information on these functions, consult the MSDN library. The PHP functions are named slightly differently; for example variant_add() in PHP corresponds to VarAdd() in the MSDN documentation.

Předcházející | Nahoru | Další
variant_mod | Domů | variant_neg


variant_neg

(PHP 5)

variant_neg — Performs logical negation on a variant

Description

mixed variant_neg ( mixed $variant )

Performs logical negation of variant and returns the result.

Poznámka: As with all the variant arithmetic functions, the parameters for this function can be either a PHP native type (integer, string, floating point, boolean or NULL), or an instance of a COM, VARIANT or DOTNET class. PHP native types will be converted to variants using the same rules as found in the constructor for the VARIANT class. COM and DOTNET objects will have the value of their default property taken and used as the variant value.

The variant arithmetic functions are wrappers around the similarly named functions in the COM library; for more information on these functions, consult the MSDN library. The PHP functions are named slightly differently; for example variant_add() in PHP corresponds to VarAdd() in the MSDN documentation.

Předcházející | Nahoru | Další
variant_mul | Domů | variant_not


variant_not

(PHP 5)

variant_not — Performs bitwise not negation on a variant

Description

mixed variant_not ( mixed $variant )

Performs bitwise not negation on variant and returns the result. If variant is NULL, the result will also be NULL.

Poznámka: As with all the variant arithmetic functions, the parameters for this function can be either a PHP native type (integer, string, floating point, boolean or NULL), or an instance of a COM, VARIANT or DOTNET class. PHP native types will be converted to variants using the same rules as found in the constructor for the VARIANT class. COM and DOTNET objects will have the value of their default property taken and used as the variant value.

The variant arithmetic functions are wrappers around the similarly named functions in the COM library; for more information on these functions, consult the MSDN library. The PHP functions are named slightly differently; for example variant_add() in PHP corresponds to VarAdd() in the MSDN documentation.

Předcházející | Nahoru | Další
variant_neg | Domů | variant_or


variant_or

(PHP 5)

variant_or — Performs a logical disjunction on two variants

Description

mixed variant_or ( mixed $left, mixed $right )

Performs a bitwise OR operation, according to the following truth table; note that this is slightly different from a regular OR operation.

Tabulka 28. Variant OR Rules

If left is | If right is | then the result is
TRUE | TRUE | TRUE
TRUE | FALSE | TRUE
TRUE | NULL | TRUE
FALSE | TRUE | TRUE
FALSE | FALSE | FALSE
FALSE | NULL | NULL
NULL | TRUE | TRUE
NULL | FALSE | NULL
NULL | NULL | NULL

See also variant_and(), variant_xor().

Poznámka: As with all the variant arithmetic functions, the parameters for this function can be either a PHP native type (integer, string, floating point, boolean or NULL), or an instance of a COM, VARIANT or DOTNET class. PHP native types will be converted to variants using the same rules as found in the constructor for the VARIANT class. COM and DOTNET objects will have the value of their default property taken and used as the variant value.

The variant arithmetic functions are wrappers around the similarly named functions in the COM library; for more information on these functions, consult the MSDN library. The PHP functions are named slightly differently; for example variant_add() in PHP corresponds to VarAdd() in the MSDN documentation.

Předcházející | Nahoru | Další
variant_not | Domů | variant_pow


variant_pow

(PHP 5)

variant_pow — Returns the result of performing the power function with two variants

Description

mixed variant_pow ( mixed $left, mixed $right )

Returns the result of left to the power of right.

See also pow().

Poznámka: As with all the variant arithmetic functions, the parameters for this function can be either a PHP native type (integer, string, floating point, boolean or NULL), or an instance of a COM, VARIANT or DOTNET class. PHP native types will be converted to variants using the same rules as found in the constructor for the VARIANT class. COM and DOTNET objects will have the value of their default property taken and used as the variant value.

The variant arithmetic functions are wrappers around the similarly named functions in the COM library; for more information on these functions, consult the MSDN library. The PHP functions are named slightly differently; for example variant_add() in PHP corresponds to VarAdd() in the MSDN documentation.

Předcházející | Nahoru | Další
variant_or | Domů | variant_round


variant_round

(PHP 5)

variant_round — Rounds a variant to the specified number of decimal places

Description

mixed variant_round ( mixed $variant, int $decimals )

Returns the value of variant rounded to decimals decimal places.

See also round().

Poznámka: As with all the variant arithmetic functions, the parameters for this function can be either a PHP native type (integer, string, floating point, boolean or NULL), or an instance of a COM, VARIANT or DOTNET class. PHP native types will be converted to variants using the same rules as found in the constructor for the VARIANT class. COM and DOTNET objects will have the value of their default property taken and used as the variant value.

The variant arithmetic functions are wrappers around the similarly named functions in the COM library; for more information on these functions, consult the MSDN library. The PHP functions are named slightly differently; for example variant_add() in PHP corresponds to VarAdd() in the MSDN documentation.

Předcházející | Nahoru | Další
variant_pow | Domů | variant_set_type


variant_set_type

(PHP 5)

variant_set_type — Convert a variant into another type "in-place"

Description

void variant_set_type ( variant $variant, int $type )

This function is similar to variant_cast() except that the variant is modified "in-place"; no new variant is created. The parameters for this function have identical meaning to those of variant_cast().

See also variant_cast().

Předcházející | Nahoru | Další
variant_round | Domů | variant_set


variant_set

(PHP 5)

variant_set — Assigns a new value for a variant object

Description

void variant_set ( variant $variant, mixed $value )

Converts value to a variant and assigns it to the variant object; no new variant object is created, and the old value of variant is freed/released.

Předcházející | Nahoru | Další
variant_set_type | Domů | variant_sub


variant_sub

(PHP 5)

variant_sub — subtracts the value of the right variant from the left variant value and returns the result

Description

mixed variant_sub ( mixed $left, mixed $right )

Subtracts right from left using the following rules:

Tabulka 29. Variant Subtraction Rules

If | Then
Both expressions are of the string type | Subtraction
One expression is a string type and the other a character | Subtraction
One expression is numeric and the other is a string | Subtraction.
Both expressions are numeric | Subtraction
Either expression is NULL | NULL is returned
Both expressions are empty | Empty string is returned

See also variant_add().

Poznámka: As with all the variant arithmetic functions, the parameters for this function can be either a PHP native type (integer, string, floating point, boolean or NULL), or an instance of a COM, VARIANT or DOTNET class. PHP native types will be converted to variants using the same rules as found in the constructor for the VARIANT class. COM and DOTNET objects will have the value of their default property taken and used as the variant value.

The variant arithmetic functions are wrappers around the similarly named functions in the COM library; for more information on these functions, consult the MSDN library. The PHP functions are named slightly differently; for example variant_add() in PHP corresponds to VarAdd() in the MSDN documentation.

Předcházející | Nahoru | Další
variant_set | Domů | variant_xor


variant_xor

(PHP 5)

variant_xor — Performs a logical exclusion on two variants

Description

mixed variant_xor ( mixed $left, mixed $right )

Performs a logical exclusion, according to the following truth table:

Tabulka 30. Variant XOR Rules

If left is | If right is | then the result is
TRUE | TRUE | FALSE
TRUE | FALSE | TRUE
FALSE | TRUE | TRUE
FALSE | FALSE | FALSE
NULL | NULL | NULL

See also variant_and(), variant_or().

Poznámka: As with all the variant arithmetic functions, the parameters for this function can be either a PHP native type (integer, string, floating point, boolean or NULL), or an instance of a COM, VARIANT or DOTNET class. PHP native types will be converted to variants using the same rules as found in the constructor for the VARIANT class. COM and DOTNET objects will have the value of their default property taken and used as the variant value.

The variant arithmetic functions are wrappers around the similarly named functions in the COM library; for more information on these functions, consult the MSDN library. The PHP functions are named slightly differently; for example variant_add() in PHP corresponds to VarAdd() in the MSDN documentation.

Předcházející | Nahoru | Další
variant_sub | Domů | XVII. Crack Functions


Classkit Functions

Předcházející VI. Reference funkcí Další

XIV. Classkit Functions

Úvod

These functions allow the dynamic manipulation of PHP classes, at runtime.

Poznámka: This extension has been replaced by runkit, which is not limited to class manipulation but has function manipulation, as well.

Instalace

Toto rozšíření » PECL není přibaleno k PHP.

Informace o instalaci tohoto PECL rozšíření lze najít v kapitole manuálu nazvané Instalace rozšíření PECL. Další informace, jako nové verze, soubory ke stažení, zdrojové soubory, správcovské informace a CHANGELOG, lze najít zde: » http://pecl.php.net/package/classkit.

Tuto DLL knihovnu pro rozšíření PECL můžete stahovat ze stránky » PHP Downloads nebo z » http://snaps.php.net/.

Konfigurace běhu

Toto rozšíření nemá definováno žádné konfigurační direktivy.

Typy prostředků

Toto rozšíření nemá definován žádný typ prostředku (resource).

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

CLASSKIT_ACC_PRIVATE (int)
Marks the method private
CLASSKIT_ACC_PROTECTED (int)
Marks the method protected
CLASSKIT_ACC_PUBLIC (int)
Marks the method public

Obsah

classkit_import — Import new class method definitions from a file
classkit_method_add — Dynamically adds a new method to a given class
classkit_method_copy — Copies a method from class to another
classkit_method_redefine — Dynamically changes the code of the given method
classkit_method_remove — Dynamically removes the given method
classkit_method_rename — Dynamically changes the name of the given method
Předcházející | Nahoru | Další
property_exists | Domů | classkit_import


classkit_import

(PECL classkit:0.3-0.4 runkit:0.7-0.9)

classkit_import — Import new class method definitions from a file

Popis

array classkit_import ( string $filename )

Poznámka: Tuto funkci nelze použít k manipulaci s aktuálně běžící metodou (nebo metodou v řetězu).

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Seznam parametrů

filename

The filename of the class method definitions to import

Návratové hodnoty

Associative array of imported methods

Příklady

Příklad 302. classkit_import() example

<?php
// file: newclass.php
class Example {
    function foo() {
        return "bar!\n";
    }
}
?> <?php
// requires newclass.php (see above)
class Example {
    function foo() {
        return "foo!\n";
    }
}

$e = new Example();

// output original
echo $e->foo();

// import replacement method
classkit_import('newclass.php');

// output imported
echo $e->foo();

?>

Výše uvedený příklad vypíše:

foo!
bar!

Viz také

classkit_method_add()
classkit_method_copy()

Předcházející | Nahoru | Další
XIV. Classkit Functions | Domů | classkit_method_add


classkit_method_add

(PECL classkit:0.1-0.4 runkit:0.7-0.9)

classkit_method_add — Dynamically adds a new method to a given class

Popis

bool classkit_method_add ( string $classname, string $methodname, string $args, string $code [, int $flags] )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Seznam parametrů

classname

The class to which this method will be added

methodname

The name of the method to add

args

Comma-delimited list of arguments for the newly-created method

code

The code to be evaluated when methodname is called

flags

The type of method to create, can be CLASSKIT_ACC_PUBLIC, CLASSKIT_ACC_PROTECTED or CLASSKIT_ACC_PRIVATE

Poznámka: This parameter is only used as of PHP 5, because, prior to this, all methods were public.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 303. classkit_method_add() example

<?php
class Example {
    function foo() {
        echo "foo!\n";
    }
}

// create an Example object
$e = new Example();

// Add a new public method
classkit_method_add(
    'Example',
    'add',
    '$num1, $num2',
    'return $num1 + $num2;',
    CLASSKIT_ACC_PUBLIC
);

// add 12 + 4
echo $e->add(12, 4);
?>

Výše uvedený příklad vypíše:

16

Viz také

classkit_method_copy()
classkit_method_redefine()
classkit_method_remove()
classkit_method_rename()
create_function()

Předcházející | Nahoru | Další
classkit_import | Domů | classkit_method_copy


classkit_method_copy

(PECL classkit:0.2-0.4 runkit:0.7-0.9)

classkit_method_copy — Copies a method from class to another

Popis

bool classkit_method_copy ( string $dClass, string $dMethod, string $sClass [, string $sMethod] )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Seznam parametrů

dClass

Destination class for copied method

dMethod

Destination method name

sClass

Source class of the method to copy

sMethod

Name of the method to copy from the source class. If this parameter is omitted, the value of dMethod is assumed.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 304. classkit_method_copy() example

<?php
class Foo {
    function example() {
        return "foo!\n";
    }
}

class Bar {
    // initially, no methods
}

// copy the example() method from the Foo class to the Bar class, as baz()
classkit_method_copy('Bar', 'baz', 'Foo', 'example');

// output copied function
echo Bar::baz();
?>

Výše uvedený příklad vypíše:

foo!

Viz také

classkit_method_add()
classkit_method_redefine()
classkit_method_remove()
classkit_method_rename()

Předcházející | Nahoru | Další
classkit_method_add | Domů | classkit_method_redefine


classkit_method_redefine

(PECL classkit:0.1-0.4 runkit:0.7-0.9)

classkit_method_redefine — Dynamically changes the code of the given method

Popis

bool classkit_method_redefine ( string $classname, string $methodname, string $args, string $code [, int $flags] )

Poznámka: Tuto funkci nelze použít k manipulaci s aktuálně běžící metodou (nebo metodou v řetězu).

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Seznam parametrů

classname

The class in which to redefine the method

methodname

The name of the method to redefine

args

Comma-delimited list of arguments for the redefined method

code

The new code to be evaluated when methodname is called

flags

The redefined method can be CLASSKIT_ACC_PUBLIC, CLASSKIT_ACC_PROTECTED or CLASSKIT_ACC_PRIVATE

Poznámka: This parameter is only used as of PHP 5, because, prior to this, all methods were public.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 305. classkit_method_redefine() example

<?php
class Example {
    function foo() {
        return "foo!\n";
    }
}

// create an Example object
$e = new Example();

// output Example::foo() (before redefine)
echo "Before: " . $e->foo();

// Redefine the 'foo' method
classkit_method_redefine(
    'Example',
    'foo',
    '',
    'return "bar!\n";',
    CLASSKIT_ACC_PUBLIC
);

// output Example::foo() (after redefine)
echo "After: " . $e->foo();
?>

Výše uvedený příklad vypíše:

Before: foo!
After: bar!

Viz také

classkit_method_add()
classkit_method_copy()
classkit_method_remove()
classkit_method_rename()

Předcházející | Nahoru | Další
classkit_method_copy | Domů | classkit_method_remove


classkit_method_remove

(PECL classkit:0.1-0.4 runkit:0.7-0.9)

classkit_method_remove — Dynamically removes the given method

Popis

bool classkit_method_remove ( string $classname, string $methodname )

Poznámka: Tuto funkci nelze použít k manipulaci s aktuálně běžící metodou (nebo metodou v řetězu).

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Seznam parametrů

classname

The class in which to remove the method

methodname

The name of the method to remove

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 306. classkit_method_remove() example

<?php
class Example {
    function foo() {
        return "foo!\n";
    }

    function bar() {
        return "bar!\n";
    }
}

// Remove the 'foo' method
classkit_method_remove(
    'Example',
    'foo'
);

echo implode(' ', get_class_methods('Example'));

?>

Výše uvedený příklad vypíše:

bar

Viz také

classkit_method_add()
classkit_method_copy()
classkit_method_redefine()
classkit_method_rename()

Předcházející | Nahoru | Další
classkit_method_redefine | Domů | classkit_method_rename


classkit_method_rename

(PECL classkit:0.1-0.4 runkit:0.7-0.9)

classkit_method_rename — Dynamically changes the name of the given method

Popis

bool classkit_method_rename ( string $classname, string $methodname, string $newname )

Poznámka: Tuto funkci nelze použít k manipulaci s aktuálně běžící metodou (nebo metodou v řetězu).

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Seznam parametrů

classname

The class in which to rename the method

methodname

The name of the method to rename

newname

The new name to give to the renamed method

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 307. classkit_method_rename() example

<?php
class Example {
    function foo() {
        return "foo!\n";
    }
}

// Rename the 'foo' method to 'bar'
classkit_method_rename(
    'Example',
    'foo',
    'bar'
);

// output renamed function
echo Example::bar();
?>

Výše uvedený příklad vypíše:

foo!

Viz také

classkit_method_add()
classkit_method_copy()
classkit_method_redefine()
classkit_method_remove()

Předcházející | Nahoru | Další
classkit_method_remove | Domů | XV. ClibPDF Functions [deprecated]


Funkce pro práci s třídami/objekty

Předcházející VI. Reference funkcí Další

XIII. Funkce pro práci s třídami/objekty

Úvod

Tyto funkce vám umožňují získávat informace o třídách a instancích. Můžete zjistit název třídy do které objekt patří nebo jeho proměnné a metody. Pomocí těchto funkcí můžete zjistit nejen příslušnost objektu k třídě, ale i jeho předka (tj. kterou třídu třída tohoto objektu rozšiřuje).

Požadavky

Tyto funkce jsou k dispozici jako součást standardního modulu, který je vždy dostupný.

Instalace

K používání těchto funkcí není třeba žádná instalace, jsou součástí jádra PHP.

Konfigurace běhu

Toto rozšíření nemá definováno žádné konfigurační direktivy.

Typy prostředků

Toto rozšíření nemá definován žádný typ prostředku (resource).

Předdefinované konstanty

Toto rozšíření nemá definovány žádné konstanty.

Příklady

V této ukázce nejdříve definujeme základní třídu a rozšíření této třídy. Základní třída popisuje obecnou zeleninu, ať už je jedlá nebo ne a bez ohledu na její barvu. Podtřída Spenat přidává metodu na uvaření této zeleniny a další, která zjistí, jestli je vařená.

Příklad 294. classes.inc

<?php

// základní třída s členskými proměnnými a metodami
class Zelenina {

    var $jedla;
    var $barva;

    function Zelenina( $jedla, $barva="green" ) {
        $this->jedla = $jedla;
        $this->barva = $barva;
    }

    function je_jedla() {
        return $this->jedla;
    }

    function jaka_barva() {
        return $this->barva;
    }

} // konec třídy Zelenina

// rozšiřuje základní třídu
class Spenat extends Zelenina {

    var $varena = false;

    function Spenat() {
        $this->Zelenina( true, "zelena" );
    }

    function cook_it() {
        $this->varena = true;
    }

    function je_varena() {
        return $this->varena;
    }

} // konec třídy Spenat

?>

Potom z těchto tříd vytvoříme 2 objekty a vytiskneme informace o nich, vč. rodičovských tříd. Také definujeme některé pomocné funkce, především kvůli pohodlnému tisku informací.

Příklad 295. test_script.php

<pre>
<?php

include "classes.inc";

// pomocné funkce

function vytiskni_promenne($obj) {
    $pole = get_object_vars($obj);
    while (list($vlastnost, $hodnota) = each($pole))
        echo "\t$vlastnost = $hodnota\n";
}

function vytiskni_metody($obj) {
    $pole = get_class_methods(get_class($obj));
    foreach ($pole as $metoda)
        echo "\tfunction $metoda()\n";
}

function class_parentage($obj, $class) {
    if (is_subclass_of($GLOBALS[$obj], $class)) {
        echo "Objekt $obj patří do třídy ".get_class($$obj);
        echo ", která je podtřídou $class\n";
    } else {
        echo "Objekt $obj nepatří do podtřídy třídy $class\n";
    }
}

// instancujeme 2 objekty

$zeleninka = new Zelenina(true,"modrá");
$listnaty = new Spenat();

// vytisknout informace o obou objektech
echo "zeleninka: CLASS ".get_class($zeleninka)."\n";
echo "listnatý: CLASS ".get_class($listnaty);
echo ", PARENT ".get_parent_class($listnaty)."\n";

// vytisknout vlastnosti zeleninky
echo "\nzeleninka: Vlastnosti\n";
vytiskni_promenne($zeleninka);

// a metody objektu listnatý
echo "\nlistnatý: Metody\n";
vytiskni_metody($listnaty);

echo "\nRodič:\n";
class_parentage("listnaty", "Spenat");
class_parentage("listnaty", "Zelenina");
?>
</pre>

Je třeba poznamenat, že ve výše uvedené ukázce je objekt $listnaty instancí třídy Spenat, která je podtřídou třídy Zelenina, a poslední část výše uvedeného skriptu tudíž vytiskne:

       [...]
Rodič:
Objekt listnaty nepatří do podtřídy třídy Spenat
Object listnaty patří do třídy Spenat, která je podtřídou Zelenina

Obsah

call_user_method_array — Call a user method given with an array of parameters [deprecated]
call_user_method — Zavolat uživatelsky definouvanou metodu určitého objektu
class_exists — Zjistit, jestli je třída definována
get_class_methods — Vrátit pole názvů metod třídy
get_class_vars — Vrátit pole defaultních vlastností třídy
get_class — Vrátit jméno třídy objektu
get_declared_classes — Vrátit pole názvů definovaných tříd
get_declared_interfaces — Returns an array of all declared interfaces
get_object_vars — Vrátit asociativní pole vlastností objektu
get_parent_class — Vrátit název rodičovské třídy objektu
interface_exists — Checks if the interface has been defined
is_a — Checks if the object is of this class or has this class as one of its parents
is_subclass_of — Zjistit, jestli objekt patří do podtřídy určité třídy
method_exists — Zjistit, jestli má třída určitou metodu
property_exists — Checks if the object or class has a property
Předcházející | Nahoru | Další
ccvs_void | Domů | call_user_method_array


call_user_method_array

(PHP 4 >= 4.0.5, PHP 5)

call_user_method_array — Call a user method given with an array of parameters [deprecated]

Popis

mixed call_user_method_array ( string $method_name, object &$obj, array $paramarr )
Varování

The call_user_method_array() function is deprecated as of PHP 4.1.0, use the call_user_func_array() variety with the array(&$obj, "method_name") syntax instead.

Viz také

call_user_func_array()
call_user_func()

Předcházející | Nahoru | Další
XIII. Funkce pro práci s třídami/objekty | Domů | call_user_method


call_user_method

(PHP 4, PHP 5)

call_user_method — Zavolat uživatelsky definouvanou metodu určitého objektu

Popis

mixed call_user_method ( string $method_name, object &$obj [, mixed $parameter [, mixed $...]] )

Zavolá metodu method_name objektu obj. Ukázka využití je níže, kde definujeme třídu, vytvoříme objekt a použijeme call_user_method() k nepřímému volání její print_info metody.

<?php
class Country {
    var $NAME;
    var $TLD;

    function Country($name, $tld) {
        $this->NAME = $name;
        $this->TLD = $tld;
    }

    function print_info($prestr="") {
        echo $prestr."Country: ".$this->NAME."\n";
        echo $prestr."Top Level Domain: ".$this->TLD."\n";
    }
}

$cntry = new Country("Peru","pe");

echo "* Calling the object method directly\n";
$cntry->print_info();

echo "\n* Calling the same method indirectly\n";
call_user_method ("print_info", $cntry, "\t");
?>

Viz také call_user_func().

Předcházející | Nahoru | Další
call_user_method_array | Domů | class_exists


class_exists

(PHP 4, PHP 5)

class_exists — Zjistit, jestli je třída definována

Popis

bool class_exists ( string $class_name [, bool $autoload] )

Tato funkce vrátí TRUE, pokud je třída class_name definována, jinak FALSE.

Předcházející | Nahoru | Další
call_user_method | Domů | get_class_methods


get_class_methods

(PHP 4, PHP 5)

get_class_methods — Vrátit pole názvů metod třídy

Popis

array get_class_methods ( mixed $class_name )

Tato funkce vrací pole názvů metod definovaných pro třídu specifikovanou argumentem class_name.

Viz také get_class_vars(), get_object_vars()

Předcházející | Nahoru | Další
class_exists | Domů | get_class_vars


get_class_vars

(PHP 4, PHP 5)

get_class_vars — Vrátit pole defaultních vlastností třídy

Popis

array get_class_vars ( string $class_name )

Tato funkce vrací pole defaultních vlastností třídy class_name.

Viz také get_class_methods(), get_object_vars()

Předcházející | Nahoru | Další
get_class_methods | Domů | get_class


get_class

(PHP 4, PHP 5)

get_class — Vrátit jméno třídy objektu

Popis

string get_class ( [object $obj] )

Tato funkce vrací název třídy jíž je objekt obj instancí.

Viz také get_parent_class(), is_subclass_of()

Předcházející | Nahoru | Další
get_class_vars | Domů | get_declared_classes


get_declared_classes

(PHP 4, PHP 5)

get_declared_classes — Vrátit pole názvů definovaných tříd

Popis

array get_declared_classes ( void )

Tato funkce vrací pole názvů tříd definovaných v současném skriptu.

Poznámka: V PHP 4.0.1pl2 jsou na začátku pole vráceny ještě tři další třídy: stdClass (definovaná v Zend/zend.c), OverloadedTestClass (definovaná v ext/standard/basic_functions.c) a Directory (definovaná v ext/standard/dir.c).

Předcházející | Nahoru | Další
get_class | Domů | get_declared_interfaces


get_declared_interfaces

(PHP 5)

get_declared_interfaces — Returns an array of all declared interfaces

Popis

array get_declared_interfaces ( void )

Gets the declared interfaces.

Návratové hodnoty

Returns an array of the names of the declared interfaces in the current script.

Příklady

Příklad 296. get_declared_interfaces() example

<?php
print_r(get_declared_interfaces());
?>

Výše uvedený příklad vypíše něco jako:

Array
(
    [0] => Traversable
    [1] => IteratorAggregate
    [2] => Iterator
    [3] => ArrayAccess
    [4] => reflector
    [5] => RecursiveIterator
    [6] => SeekableIterator
)

Viz také

get_declared_classes()

Předcházející | Nahoru | Další
get_declared_classes | Domů | get_object_vars


get_object_vars

(PHP 4, PHP 5)

get_object_vars — Vrátit asociativní pole vlastností objektu

Popis

array get_object_vars ( object $obj )

Tato funkce vrací asociativní pole definovaných vlastností objektu obj. Proměnným deklarovaným v třídě jíž je obj instancí, kterým nebyla přiřazena hodnota, nejsou ve vráceném poli obsaženy.

Příklad 297. Použití get_object_vars()

<?php
class Point2D {
    var $x, $y;
    var $label;

    function Point2D($x, $y) {
        $this->x = $x;
        $this->y = $y;
    }

    function setLabel($label) {
        $this->label = $label;
    }

    function getPoint() {
        return array("x" => $this->x,
                     "y" => $this->y,
                     "label" => $this->label);
    }
}

$p1 = new Point2D(1.233, 3.445);
print_r(get_object_vars($p1));
// "$label" is declared but not defined
// Array
// (
//     [x] => 1.233
//     [y] => 3.445
// )

$p1->setLabel("point #1");
print_r(get_object_vars($p1));
// Array
// (
//     [x] => 1.233
//     [y] => 3.445
//     [label] => point #1
// )

?>

Viz také get_class_methods(), get_class_vars()

Předcházející | Nahoru | Další
get_declared_interfaces | Domů | get_parent_class


get_parent_class

(PHP 4, PHP 5)

get_parent_class — Vrátit název rodičovské třídy objektu

Popis

string get_parent_class ( [mixed $obj] )

Tato funkce vrací název rodičovské třídy objektu obj.

Viz také get_class(), is_subclass_of()

Předcházející | Nahoru | Další
get_object_vars | Domů | interface_exists


interface_exists

(PHP 5 >= 5.0.2)

interface_exists — Checks if the interface has been defined

Popis

bool interface_exists ( string $interface_name [, bool $autoload] )

Checks if the given interface has been defined.

Seznam parametrů

interface_name

The interface name

autoload

Whether to call __autoload or not by default

Návratové hodnoty

Returns TRUE if the interface given by interface_name has been defined, FALSE otherwise.

Příklady

Příklad 298. interface_exists() example

<?php
// Check the interface exists before trying to use it
if (interface_exists('MyInterface')) {
    class MyClass implements MyInterface
    {
        // Methods
    }
}

?>

Viz také

class_exists()

Předcházející | Nahoru | Další
get_parent_class | Domů | is_a


is_a

(PHP 4 >= 4.2.0, PHP 5)

is_a — Checks if the object is of this class or has this class as one of its parents

Popis

bool is_a ( object $object, string $class_name )

Checks if the given object is of this class or has this class as one of its parents.

Poznámka: The is_a() function is deprecated as of PHP 5 in favor of the instanceof type operator.

Seznam parametrů

object

The tested object

class_name

The class name

Návratové hodnoty

Returns TRUE if the object is of this class or has this class as one of its parents, FALSE otherwise.

Příklady

Příklad 299. is_a() example

<?php
// define a class
class WidgetFactory
{
  var $oink = 'moo';
}

// create a new object
$WF = new WidgetFactory();

if (is_a($WF, 'WidgetFactory')) {
  echo "yes, \$WF is still a WidgetFactory\n";
}
?>

Příklad 300. Using the instanceof operator in PHP 5

<?php
if ($WF instanceof WidgetFactory) {
    echo 'Yes, $WF is a WidgetFactory';
}
?>

Viz také

get_class()
get_parent_class()
is_subclass_of()

Předcházející | Nahoru | Další
interface_exists | Domů | is_subclass_of


is_subclass_of

(PHP 4, PHP 5)

is_subclass_of — Zjistit, jestli objekt patří do podtřídy určité třídy

Popis

bool is_subclass_of ( mixed $object, string $class_name )

Tato funkce vrací TRUE, pokud je objekt obj instancí třídy, která je podtřídou superclass, jinak FALSE.

Viz také get_class(), get_parent_class()

Předcházející | Nahoru | Další
is_a | Domů | method_exists


method_exists

(PHP 4, PHP 5)

method_exists — Zjistit, jestli má třída určitou metodu

Popis

bool method_exists ( object $object, string $method_name )

Tato funkce vrací TRUE, pokud má object definovánu metodu method_name, jinak FALSE.

Předcházející | Nahoru | Další
is_subclass_of | Domů | property_exists


ClibPDF Functions [deprecated]

Předcházející VI. Reference funkcí Další

XV. ClibPDF Functions [deprecated]

Úvod

Varování

ClibPDF support is deprecated and users are strongly encouraged to use an alternative, like Haru, PDFlib, or one of the available PHP alternatives.

ClibPDF lets you create PDF documents with PHP. ClibPDF functionality and API are similar to PDFlib. This documentation should be read alongside the ClibPDF manual since it explains the library in much greater detail.

Many functions in the native ClibPDF and the PHP module, as well as in PDFlib, have the same name. All functions except for cpdf_open() take the handle for the document as their first parameter.

Currently this handle is not used internally since ClibPDF does not support the creation of several PDF documents at the same time. Actually, you should not even try it, the results are unpredictable. I can't oversee what the consequences in a multi threaded environment are. According to the author of ClibPDF this will change in one of the next releases (current version when this was written is 1.10). If you need this functionality use the pdflib module.

A nice feature of ClibPDF (and PDFlib) is the ability to create the pdf document completely in memory without using temporary files. It also provides the ability to pass coordinates in a predefined unit length. (This feature can also be simulated by pdf_translate() when using the PDFlib functions.)

Another nice feature of ClibPDF is the fact that any page can be modified at any time even if a new page has been already opened. The function cpdf_set_current_page() allows to leave the current page and presume modifying an other page.

Most of the functions are fairly easy to use. The most difficult part is probably creating a very simple PDF document at all. The following example should help you to get started. It creates a document with one page. The page contains the text "Times-Roman" in an outlined 30pt font. The text is underlined.

Poznámka: Toto rozšíření bylo přesunuto do repozitáře PECL a již nebude součástí balíku PHP.5.1.0.

Poznámka: If you're interested in alternative free PDF generators that do not utilize external PDF libraries, see this related FAQ.

Požadavky

In order to use the ClibPDF functions you need to install the ClibPDF package. It is available for download from » FastIO, but requires that you purchase a license for commercial use. PHP requires that you use cpdflib >= 2. The development of ClibPDF library has been discontinued thus FastIO website would be most probably inaccessible.

Instalace

To get these functions to work, you have to compile PHP with --with-cpdflib[=DIR]. DIR is the cpdflib install directory, defaults to /usr. In addition you can specify the jpeg library and the tiff library for ClibPDF to use. To do so add to your configure line the options --with-jpeg-dir[=DIR] --with-tiff-dir[=DIR].

Konfigurace běhu

Toto rozšíření nemá definováno žádné konfigurační direktivy.

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

CPDF_PM_NONE (integer)
CPDF_PM_OUTLINES (integer)
CPDF_PM_THUMBS (integer)
CPDF_PM_FULLSCREEN (integer)
CPDF_PL_SINGLE (integer)
CPDF_PL_1COLUMN (integer)
CPDF_PL_2LCOLUMN (integer)
CPDF_PL_2RCOLUMN (integer)

Příklady

Příklad 308. Simple ClibPDF Example

<?php
$cpdf = cpdf_open(0);
cpdf_page_init($cpdf, 1, 0, 595, 842, 1.0);
cpdf_add_outline($cpdf, 0, 0, 0, 1, "Page 1");
cpdf_begin_text($cpdf);
cpdf_set_font($cpdf, "Times-Roman", 30, "WinAnsiEncoding");
cpdf_set_text_rendering($cpdf, 1);
cpdf_text($cpdf, "Times Roman outlined", 50, 50);
cpdf_end_text($cpdf);
cpdf_moveto($cpdf, 50, 50);
cpdf_lineto($cpdf, 740, 330);
cpdf_stroke($cpdf);
cpdf_finalize_page($cpdf, 1);
cpdf_finalize($cpdf);
Header("Content-type: application/pdf");
cpdf_output_buffer($cpdf);
cpdf_close($cpdf);
?>

The pdflib distribution contains a more complex example which creates a series of pages with an analog clock. Here is that example converted into PHP using the ClibPDF extension:

Příklad 309. pdfclock example from pdflib 2.0 distribution

<?php
$radius = 200;
$margin = 20;
$pagecount = 40;

$pdf = cpdf_open(0);
cpdf_set_creator($pdf, "pdf_clock.php");
cpdf_set_title($pdf, "Analog Clock");

while ($pagecount-- > 0) {
  cpdf_page_init($pdf, $pagecount+1, 0, 2 * ($radius + $margin), 2 * ($radius + $margin), 1.0);

  cpdf_set_page_animation($pdf, 4, 0.5, 0, 0, 0);  /* wipe */

  cpdf_translate($pdf, $radius + $margin, $radius + $margin);
  cpdf_save($pdf);
  cpdf_setrgbcolor($pdf, 0.0, 0.0, 1.0);

  /* minute strokes */
  cpdf_setlinewidth($pdf, 2.0);
  for ($alpha = 0; $alpha < 360; $alpha += 6) {
    cpdf_rotate($pdf, 6.0);
    cpdf_moveto($pdf, $radius, 0.0);
    cpdf_lineto($pdf, $radius-$margin/3, 0.0);
    cpdf_stroke($pdf);
  }

  cpdf_restore($pdf);
  cpdf_save($pdf);

  /* 5 minute strokes */
  cpdf_setlinewidth($pdf, 3.0);
  for ($alpha = 0; $alpha < 360; $alpha += 30) {
    cpdf_rotate($pdf, 30.0);
    cpdf_moveto($pdf, $radius, 0.0);
    cpdf_lineto($pdf, $radius-$margin, 0.0);
    cpdf_stroke($pdf);
  }

  $ltime = getdate();

  /* draw hour hand */
  cpdf_save($pdf);
  cpdf_rotate($pdf, -(($ltime['minutes']/60.0) + $ltime['hours'] - 3.0) * 30.0);
  cpdf_moveto($pdf, -$radius/10, -$radius/20);
  cpdf_lineto($pdf, $radius/2, 0.0);
  cpdf_lineto($pdf, -$radius/10, $radius/20);
  cpdf_closepath($pdf);
  cpdf_fill($pdf);
  cpdf_restore($pdf);

  /* draw minute hand */
  cpdf_save($pdf);
  cpdf_rotate($pdf, -(($ltime['seconds']/60.0) + $ltime['minutes'] - 15.0) * 6.0);
  cpdf_moveto($pdf, -$radius/10, -$radius/20);
  cpdf_lineto($pdf, $radius * 0.8, 0.0);
  cpdf_lineto($pdf, -$radius/10, $radius/20);
  cpdf_closepath($pdf);
  cpdf_fill($pdf);
  cpdf_restore($pdf);

  /* draw second hand */
  cpdf_setrgbcolor($pdf, 1.0, 0.0, 0.0);
  cpdf_setlinewidth($pdf, 2);
  cpdf_save($pdf);
  cpdf_rotate($pdf, -(($ltime['seconds'] - 15.0) * 6.0));
  cpdf_moveto($pdf, -$radius/5, 0.0);
  cpdf_lineto($pdf, $radius, 0.0);
  cpdf_stroke($pdf);
  cpdf_restore($pdf);

  /* draw little circle at center */
  cpdf_circle($pdf, 0, 0, $radius/30);
  cpdf_fill($pdf);

  cpdf_restore($pdf);

  cpdf_finalize_page($pdf, $pagecount+1);
}

cpdf_finalize($pdf);
Header("Content-type: application/pdf");
cpdf_output_buffer($pdf);
cpdf_close($pdf);
?>

Viz také

See also the PDFlib extension documentation.

Obsah

cpdf_add_annotation — Adds annotation
cpdf_add_outline — Adds bookmark for current page
cpdf_arc — Draws an arc
cpdf_begin_text — Starts text section
cpdf_circle — Draw a circle
cpdf_clip — Clips to current path
cpdf_close — Closes the pdf document
cpdf_closepath_fill_stroke — Close, fill and stroke current path
cpdf_closepath_stroke — Close path and draw line along path
cpdf_closepath — Close path
cpdf_continue_text — Output text in next line
cpdf_curveto — Draws a curve
cpdf_end_text — Ends text section
cpdf_fill_stroke — Fill and stroke current path
cpdf_fill — Fill current path
cpdf_finalize_page — Ends page
cpdf_finalize — Ends document
cpdf_global_set_document_limits — Sets document limits for any pdf document
cpdf_import_jpeg — Opens a JPEG image
cpdf_lineto — Draws a line
cpdf_moveto — Sets current point
cpdf_newpath — Starts a new path
cpdf_open — Opens a new pdf document
cpdf_output_buffer — Outputs the pdf document in memory buffer
cpdf_page_init — Starts new page
cpdf_place_inline_image — Places an image on the page
cpdf_rect — Draw a rectangle
cpdf_restore — Restores formerly saved environment
cpdf_rlineto — Draws a line
cpdf_rmoveto — Sets current point
cpdf_rotate_text — Sets text rotation angle
cpdf_rotate — Sets rotation
cpdf_save_to_file — Writes the pdf document into a file
cpdf_save — Saves current environment
cpdf_scale — Sets scaling
cpdf_set_action_url — Sets hyperlink
cpdf_set_char_spacing — Sets character spacing
cpdf_set_creator — Sets the creator field in the pdf document
cpdf_set_current_page — Sets current page
cpdf_set_font_directories — Sets directories to search when using external fonts
cpdf_set_font_map_file — Sets fontname to filename translation map when using external fonts
cpdf_set_font — Select the current font face and size
cpdf_set_horiz_scaling — Sets horizontal scaling of text
cpdf_set_keywords — Sets the keywords field of the pdf document
cpdf_set_leading — Sets distance between text lines
cpdf_set_page_animation — Sets duration between pages
cpdf_set_subject — Sets the subject field of the pdf document
cpdf_set_text_matrix — Sets the text matrix
cpdf_set_text_pos — Sets text position
cpdf_set_text_rendering — Determines how text is rendered
cpdf_set_text_rise — Sets the text rise
cpdf_set_title — Sets the title field of the pdf document
cpdf_set_viewer_preferences — How to show the document in the viewer
cpdf_set_word_spacing — Sets spacing between words
cpdf_setdash — Sets dash pattern
cpdf_setflat — Sets flatness
cpdf_setgray_fill — Sets filling color to gray value
cpdf_setgray_stroke — Sets drawing color to gray value
cpdf_setgray — Sets drawing and filling color to gray value
cpdf_setlinecap — Sets linecap parameter
cpdf_setlinejoin — Sets linejoin parameter
cpdf_setlinewidth — Sets line width
cpdf_setmiterlimit — Sets miter limit
cpdf_setrgbcolor_fill — Sets filling color to rgb color value
cpdf_setrgbcolor_stroke — Sets drawing color to rgb color value
cpdf_setrgbcolor — Sets drawing and filling color to rgb color value
cpdf_show_xy — Output text at position
cpdf_show — Output text at current position
cpdf_stringwidth — Returns width of text in current font
cpdf_stroke — Draw line along path
cpdf_text — Output text with parameters
cpdf_translate — Sets origin of coordinate system
Předcházející | Nahoru | Další
classkit_method_rename | Domů | cpdf_add_annotation


cpdf_add_annotation

(PHP 4, PHP 5 <= 5.0.5)

cpdf_add_annotation — Adds annotation

Popis

bool cpdf_add_annotation ( int $pdf_document, float $llx, float $lly, float $urx, float $ury, string $title, string $content [, int $mode] )

Adds a note at the specified point.

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

llx

Lower left X

lly

Lower left Y

urx

Upper right X

ury

Upper right Y

title

The title of the annotation

text

The contents of the annotation

mode

The optional parameter mode determines the unit length. If it is 0 or omitted the default unit as specified for the page is used. Otherwise the coordinates are measured in postscript points disregarding the current unit.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
XV. ClibPDF Functions [deprecated] | Domů | cpdf_add_outline


cpdf_add_outline

(PHP 4, PHP 5 <= 5.0.5)

cpdf_add_outline — Adds bookmark for current page

Popis

int cpdf_add_outline ( int $pdf_document, int $lastoutline, int $sublevel, int $open, int $pagenr, string $text )

Adds a bookmark with text text that points to the current page.

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

lastoutline

sublevel

open

pagenr

text

The bookmark text

Příklady

Příklad 310. Adding a page outline

<?php
$cpdf = cpdf_open(0);
cpdf_page_init($cpdf, 1, 0, 595, 842);
cpdf_add_outline($cpdf, 0, 0, 0, 1, "Page 1");
// ...
// some drawing
// ...
cpdf_finalize($cpdf);
header("Content-type: application/pdf");
cpdf_output_buffer($cpdf);
cpdf_close($cpdf);
?>

Předcházející | Nahoru | Další
cpdf_add_annotation | Domů | cpdf_arc


cpdf_arc

(PHP 4, PHP 5 <= 5.0.5)

cpdf_arc — Draws an arc

Popis

bool cpdf_arc ( int $pdf_document, float $x_coor, float $y_coor, float $radius, float $start, float $end [, int $mode] )

Draws an arc.

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

x

The x-coordinate of the center

y

The y-coordinate of the center

radius

The arc radius

start

The starting angle, in degrees

end

The ending angle, in degrees

mode

The optional parameter mode determines the unit length. If it is 0 or omitted the default unit as specified for the page is used. Otherwise the coordinates are measured in postscript points disregarding the current unit.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

cpdf_circle()

Předcházející | Nahoru | Další
cpdf_add_outline | Domů | cpdf_begin_text


cpdf_begin_text

(PHP 4, PHP 5 <= 5.0.5)

cpdf_begin_text — Starts text section

Popis

bool cpdf_begin_text ( int $pdf_document )

Starts a text section.

The created text section must be ended with cpdf_end_text().

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 311. Text output

<?php
cpdf_begin_text($pdf);
cpdf_set_font($pdf, 16, "Helvetica", "WinAnsiEncoding");
cpdf_text($pdf, 100, 100, "Some text");
cpdf_end_text($pdf)
?>

Viz také

cpdf_end_text()

Předcházející | Nahoru | Další
cpdf_arc | Domů | cpdf_circle


cpdf_circle

(PHP 4, PHP 5 <= 5.0.5)

cpdf_circle — Draw a circle

Popis

bool cpdf_circle ( int $pdf_document, float $x_coor, float $y_coor, float $radius [, int $mode] )

Draws a circle.

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

x_coor

The x-coordinate of the center

y_coor

The y-coordinate of the center

radius

The circle radius

mode

The optional parameter mode determines the unit length. If it is 0 or omitted the default unit as specified for the page is used. Otherwise the coordinates are measured in postscript points disregarding the current unit.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

cpdf_arc()

Předcházející | Nahoru | Další
cpdf_begin_text | Domů | cpdf_clip


cpdf_clip

(PHP 4, PHP 5 <= 5.0.5)

cpdf_clip — Clips to current path

Popis

bool cpdf_clip ( int $pdf_document )

Clips all drawing to the current path.

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
cpdf_circle | Domů | cpdf_close


cpdf_close

(PHP 4, PHP 5 <= 5.0.5)

cpdf_close — Closes the pdf document

Popis

bool cpdf_close ( int $pdf_document )

Closes the PDF document.

This should be the last function called, even after cpdf_finalize(), cpdf_output_buffer() or cpdf_save_to_file().

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

cpdf_open()

Předcházející | Nahoru | Další
cpdf_clip | Domů | cpdf_closepath_fill_stroke


cpdf_closepath_fill_stroke

(PHP 4, PHP 5 <= 5.0.5)

cpdf_closepath_fill_stroke — Close, fill and stroke current path

Popis

bool cpdf_closepath_fill_stroke ( int $pdf_document )

Closes, fills the interior of the current path with the current fill color and draws current path.

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

cpdf_closepath()
cpdf_stroke()
cpdf_fill()
cpdf_setgray_fill()
cpdf_setgray()
cpdf_setrgbcolor_fill()
cpdf_setrgbcolor()

Předcházející | Nahoru | Další
cpdf_close | Domů | cpdf_closepath_stroke


cpdf_closepath_stroke

(PHP 4, PHP 5 <= 5.0.5)

cpdf_closepath_stroke — Close path and draw line along path

Popis

bool cpdf_closepath_stroke ( int $pdf_document )

Closes the current path and draws a line along it.

cpdf_closepath_stroke() is a combination of cpdf_closepath() and cpdf_stroke().

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

cpdf_closepath()
cpdf_stroke()

Předcházející | Nahoru | Další
cpdf_closepath_fill_stroke | Domů | cpdf_closepath


cpdf_closepath

(PHP 4, PHP 5 <= 5.0.5)

cpdf_closepath — Close path

Popis

bool cpdf_closepath ( int $pdf_document )

Closes the current path.

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
cpdf_closepath_stroke | Domů | cpdf_continue_text


cpdf_continue_text

(PHP 4, PHP 5 <= 5.0.5)

cpdf_continue_text — Output text in next line

Popis

bool cpdf_continue_text ( int $pdf_document, string $text )

Outputs the string in text in the next line.

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

text

The string to output

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

cpdf_show_xy()
cpdf_text()
cpdf_set_leading()
cpdf_set_text_pos()

Předcházející | Nahoru | Další
cpdf_closepath | Domů | cpdf_curveto


cpdf_curveto

(PHP 4, PHP 5 <= 5.0.5)

cpdf_curveto — Draws a curve

Popis

bool cpdf_curveto ( int $pdf_document, float $x1, float $y1, float $x2, float $y2, float $x3, float $y3 [, int $mode] )

Draws a Bezier curve from the current point to the point (x3, y3) using (x1, y1) and (x2, y2) as control points.

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

x1

x-coordinate for the first control point

y1

y-coordinate for the first control point

x2

x-coordinate for the second control point

y2

y-coordinate for the second control point

x3

x-coordinate for the target

y3

y-coordinate for the target

mode

The optional parameter mode determines the unit length. If it is 0 or omitted the default unit as specified for the page is used. Otherwise the coordinates are measured in postscript points disregarding the current unit.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

cpdf_moveto()
cpdf_rmoveto()
cpdf_rlineto()
cpdf_lineto()

Předcházející | Nahoru | Další
cpdf_continue_text | Domů | cpdf_end_text


cpdf_end_text

(PHP 4, PHP 5 <= 5.0.5)

cpdf_end_text — Ends text section

Popis

bool cpdf_end_text ( int $pdf_document )

Ends a text section which was started with cpdf_begin_text().

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 312. Text output

<?php
cpdf_begin_text($pdf);
cpdf_set_font($pdf, 16, "Helvetica", "WinAnsiEncoding");
cpdf_text($pdf, 100, 100, "Some text");
cpdf_end_text($pdf)
?>

Viz také

cpdf_begin_text()

Předcházející | Nahoru | Další
cpdf_curveto | Domů | cpdf_fill_stroke


cpdf_fill_stroke

(PHP 4, PHP 5 <= 5.0.5)

cpdf_fill_stroke — Fill and stroke current path

Popis

bool cpdf_fill_stroke ( int $pdf_document )

Fills the interior of the current path with the current fill color and draws current path.

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

cpdf_closepath()
cpdf_stroke()
cpdf_fill()
cpdf_setgray_fill()
cpdf_setgray()
cpdf_setrgbcolor_fill()
cpdf_setrgbcolor()

Předcházející | Nahoru | Další
cpdf_end_text | Domů | cpdf_fill


cpdf_fill

(PHP 4, PHP 5 <= 5.0.5)

cpdf_fill — Fill current path

Popis

bool cpdf_fill ( int $pdf_document )

Fills the interior of the current path with the current fill color.

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

cpdf_closepath()
cpdf_stroke()
cpdf_setgray_fill()
cpdf_setgray()
cpdf_setrgbcolor_fill()
cpdf_setrgbcolor()

Předcházející | Nahoru | Další
cpdf_fill_stroke | Domů | cpdf_finalize_page


cpdf_finalize_page

(PHP 4, PHP 5 <= 5.0.5)

cpdf_finalize_page — Ends page

Popis

bool cpdf_finalize_page ( int $pdf_document, int $page_number )

Ends the page which number is page_number.

This function is only used for saving memory. A finalized page takes less memory but cannot be modified anymore.

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

page_number

The page number

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

cpdf_page_init()

Předcházející | Nahoru | Další
cpdf_fill | Domů | cpdf_finalize


cpdf_finalize

(PHP 4, PHP 5 <= 5.0.5)

cpdf_finalize — Ends document

Popis

bool cpdf_finalize ( int $pdf_document )

Ends the PDF document.

You still have to call cpdf_close().

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

cpdf_close()

Předcházející | Nahoru | Další
cpdf_finalize_page | Domů | cpdf_global_set_document_limits


cpdf_global_set_document_limits

(PHP 4, PHP 5 <= 5.0.5)

cpdf_global_set_document_limits — Sets document limits for any pdf document

Popis

bool cpdf_global_set_document_limits ( int $maxpages, int $maxfonts, int $maximages, int $maxannotations, int $maxobjects )

Sets several document limits. This function has to be called before cpdf_open() to take effect. It sets the limits for any document open afterwards.

Seznam parametrů

maxPages

The maximum number of pages

maxFonts

The maximum number of fonts

maxImages

The maximum number of images

maxAnnots

The maximum number of annotations

maxObjects

The maximum number of objects

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

cpdf_open()

Předcházející | Nahoru | Další
cpdf_finalize | Domů | cpdf_import_jpeg


cpdf_import_jpeg

(PHP 4, PHP 5 <= 5.0.5)

cpdf_import_jpeg — Opens a JPEG image

Popis

bool cpdf_import_jpeg ( int $pdf_document, string $file_name, float $x_coor, float $y_coor, float $angle, float $width, float $height, float $x_scale, float $y_scale, int $gsave [, int $mode] )

Opens a JPEG image.

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

file_name

The path to the image file. The format of the image has to be JPEG

x_coor

The x-coordinate of the image

y_coor

The y-coordinate of the image

angle

The image rotation angle, in degrees

width

The image width

height

The image height

x_scale

y_scale

gsave

Should be non-zero to allow this function to operate correctly

mode

The optional parameter mode determines the unit length. If it is 0 or omitted the default unit as specified for the page is used. Otherwise the coordinates are measured in postscript points disregarding the current unit.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

cpdf_place_inline_image()

Předcházející | Nahoru | Další
cpdf_global_set_document_limits | Domů | cpdf_lineto


cpdf_lineto

(PHP 4, PHP 5 <= 5.0.5)

cpdf_lineto — Draws a line

Popis

bool cpdf_lineto ( int $pdf_document, float $x_coor, float $y_coor [, int $mode] )

The cpdf_lineto() function draws a line from the current point to the specified point.

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

x_coor

The x-coordinate of the destination point

y_coor

The y-coordinate of the destination point

mode

The optional parameter mode determines the unit length. If it is 0 or omitted the default unit as specified for the page is used. Otherwise the coordinates are measured in postscript points disregarding the current unit.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

cpdf_moveto()
cpdf_rmoveto()
cpdf_curveto()

Předcházející | Nahoru | Další
cpdf_import_jpeg | Domů | cpdf_moveto


cpdf_moveto

(PHP 4, PHP 5 <= 5.0.5)

cpdf_moveto — Sets current point

Popis

bool cpdf_moveto ( int $pdf_document, float $x_coor, float $y_coor [, int $mode] )

Sets the current point to the given coordinates.

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

x_coor

The x-coordinate

y_coor

The y-coordinate

mode

The optional parameter mode determines the unit length. If it is 0 or omitted the default unit as specified for the page is used. Otherwise the coordinates are measured in postscript points disregarding the current unit.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
cpdf_lineto | Domů | cpdf_newpath


cpdf_newpath

(PHP 4, PHP 5 <= 5.0.5)

cpdf_newpath — Starts a new path

Popis

bool cpdf_newpath ( int $pdf_document )

Starts a new path on the document.

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
cpdf_moveto | Domů | cpdf_open


cpdf_open

(PHP 4, PHP 5 <= 5.0.5)

cpdf_open — Opens a new pdf document

Popis

int cpdf_open ( int $compression [, string $filename [, array $doc_limits]] )

Opens a new PDF document.

Seznam parametrů

compression

If different from 0, document compression is turned on

filename

Sets the file in which the document is written. - is a synonym for stdout.

If omitted, the document is created in memory and can either be written into a file with cpdf_save_to_file() or written to standard output with cpdf_output_buffer().

Poznámka: Using stdout will not work if PHP is compiled as an apache module. You can solve this problem by skipping this parameter filename and using cpdf_output_buffer() later to output the PDF document.

doc_limits

An array defining the document limitation. See cpdf_global_set_document_limits() for more information

Návratové hodnoty

Returns a document handle, needed as the first parameter for all other functions of the library.

Viz také

cpdf_close()
cpdf_output_buffer()

Předcházející | Nahoru | Další
cpdf_newpath | Domů | cpdf_output_buffer


cpdf_output_buffer

(PHP 4, PHP 5 <= 5.0.5)

cpdf_output_buffer — Outputs the pdf document in memory buffer

Popis

bool cpdf_output_buffer ( int $pdf_document )

Outputs the pdf document to stdout.

The document has to be created in memory which is the case if cpdf_open() has been called without the file name parameter.

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

cpdf_open()

Předcházející | Nahoru | Další
cpdf_open | Domů | cpdf_page_init


cpdf_page_init

(PHP 4, PHP 5 <= 5.0.5)

cpdf_page_init — Starts new page

Popis

bool cpdf_page_init ( int $pdf_document, int $page_number, int $orientation, float $height, float $width [, float $unit] )

Starts a new page.

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

page_number

The page number

orientation

0 for portrait and 1 for landscape

height

The page height

width

The page width

unit

The unit for the coordinate system. The value should be the number of postscript points per unit. Since one inch is equal to 72 points, a value of 72 would set the unit to one inch. The default is also 72.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

cpdf_set_current_page()

Předcházející | Nahoru | Další
cpdf_output_buffer | Domů | cpdf_place_inline_image


cpdf_place_inline_image

(PHP 4, PHP 5 <= 5.0.5)

cpdf_place_inline_image — Places an image on the page

Popis

bool cpdf_place_inline_image ( int $pdf_document, int $image, float $x_coor, float $y_coor, float $angle, float $width, float $height, int $gsave [, int $mode] )

Places an image created with the PHP image functions on the page. The image can be scaled at the same time.

Poznámka: This function is only available if PHP was compiled with the GD Graphics Library 1.3. See the GD extension installation instructions for further information.

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

image

An image created with the PHP image functions

x_coor

The x-coordinate of the image

y_coor

The y-coordinate of the image

angle

The image rotation angle, in degrees

width

The image width

height

The image height

gsave

Should be non-zero to allow this function to operate correctly

mode

The optional parameter mode determines the unit length. If it is 0 or omitted the default unit as specified for the page is used. Otherwise the coordinates are measured in postscript points disregarding the current unit.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

cpdf_import_jpeg()

Předcházející | Nahoru | Další
cpdf_page_init | Domů | cpdf_rect


cpdf_rect

(PHP 4, PHP 5 <= 5.0.5)

cpdf_rect — Draw a rectangle

Popis

bool cpdf_rect ( int $pdf_document, float $x_coor, float $y_coor, float $width, float $height [, int $mode] )

Draws a rectangle.

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

x_coor

The x-coordinate of the lower left corner

y_coor

The y-coordinate of the lower left corner

width

The rectangle width

height

The rectangle height

mode

The optional parameter mode determines the unit length. If it is 0 or omitted the default unit as specified for the page is used. Otherwise the coordinates are measured in postscript points disregarding the current unit.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 313. Drawing a rectangle

<?php

$cpdf = cpdf_open(0);
cpdf_page_init($cpdf, 1, 0, 595, 842, 1.0);

// set the fill color to red
cpdf_setrgbcolor($cpdf, 1, 0, 0);

// draw a (180 * 100) rectangle
cpdf_rect($cpdf, 645, 400, 180, 100);

// fill the rectangle
cpdf_fill($cpdf);

cpdf_finalize($cpdf);
Header("Content-type: application/pdf");
cpdf_output_buffer($cpdf);
cpdf_close($cpdf);

?>

Předcházející | Nahoru | Další
cpdf_place_inline_image | Domů | cpdf_restore


cpdf_restore

(PHP 4, PHP 5 <= 5.0.5)

cpdf_restore — Restores formerly saved environment

Popis

bool cpdf_restore ( int $pdf_document )

Restores the environment saved with cpdf_save(). It works like the postscript command grestore. Very useful if you want to translate or rotate an object without effecting other objects.

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 314. Save/Restore

<?php
cpdf_save($pdf);
// do all kinds of rotations, transformations, ...
cpdf_restore($pdf)
?>

Viz také

cpdf_save()

Předcházející | Nahoru | Další
cpdf_rect | Domů | cpdf_rlineto


cpdf_rlineto

(PHP 4, PHP 5 <= 5.0.5)

cpdf_rlineto — Draws a line

Popis

bool cpdf_rlineto ( int $pdf_document, float $x_coor, float $y_coor [, int $mode] )

The cpdf_rlineto() function draws a line from the current point to the given relative point.

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

x_coor

The x-coordinate of the destination point

y_coor

The y-coordinate of the destination point

mode

The optional parameter mode determines the unit length. If it is 0 or omitted the default unit as specified for the page is used. Otherwise the coordinates are measured in postscript points disregarding the current unit.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

cpdf_moveto()
cpdf_rmoveto()
cpdf_curveto()

Předcházející | Nahoru | Další
cpdf_restore | Domů | cpdf_rmoveto


cpdf_rmoveto

(PHP 4, PHP 5 <= 5.0.5)

cpdf_rmoveto — Sets current point

Popis

bool cpdf_rmoveto ( int $pdf_document, float $x_coor, float $y_coor [, int $mode] )

Set the current point relative to the given coordinates.

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

x_coor

The x-coordinate of the destination point

y_coor

The y-coordinate of the destination point

mode

The optional parameter mode determines the unit length. If it is 0 or omitted the default unit as specified for the page is used. Otherwise the coordinates are measured in postscript points disregarding the current unit.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

cpdf_moveto()

Předcházející | Nahoru | Další
cpdf_rlineto | Domů | cpdf_rotate_text


cpdf_rotate_text

(PHP 4, PHP 5 <= 5.0.5)

cpdf_rotate_text — Sets text rotation angle

Popis

bool cpdf_rotate_text ( int $pdfdoc, float $angle )

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
cpdf_rmoveto | Domů | cpdf_rotate


cpdf_rotate

(PHP 4, PHP 5 <= 5.0.5)

cpdf_rotate — Sets rotation

Popis

bool cpdf_rotate ( int $pdf_document, float $angle )

Sets the rotation in degrees to angle.

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

angle

The angle, in degrees

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
cpdf_rotate_text | Domů | cpdf_save_to_file


cpdf_save_to_file

(PHP 4, PHP 5 <= 5.0.5)

cpdf_save_to_file — Writes the pdf document into a file

Popis

bool cpdf_save_to_file ( int $pdf_document, string $filename )

Outputs the PDF document into a file if it has been created in memory.

This function is not needed if the PDF document has been open by specifying a filename as a parameter of cpdf_open().

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

filename

The path to the saved PDF document

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

cpdf_output_buffer()
cpdf_open()

Předcházející | Nahoru | Další
cpdf_rotate | Domů | cpdf_save


cpdf_save

(PHP 4, PHP 5 <= 5.0.5)

cpdf_save — Saves current environment

Popis

bool cpdf_save ( int $pdf_document )

Saves the current environment. It works like the postscript command gsave. Very useful if you want to translate or rotate an object without effecting other objects.

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

cpdf_restore()

Předcházející | Nahoru | Další
cpdf_save_to_file | Domů | cpdf_scale


cpdf_scale

(PHP 4, PHP 5 <= 5.0.5)

cpdf_scale — Sets scaling

Popis

bool cpdf_scale ( int $pdf_document, float $x_scale, float $y_scale )

Sets the scaling factor in both directions.

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

x_scale

The X scale percent to set. Default to 0.0

y_scale

The Y scale percent to set. Default to 0.0

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
cpdf_save | Domů | cpdf_set_action_url


cpdf_set_action_url

(PHP 4, PHP 5 <= 5.0.5)

cpdf_set_action_url — Sets hyperlink

Popis

bool cpdf_set_action_url ( int $pdfdoc, float $xll, float $yll, float $xur, float $xur, string $url [, int $mode] )

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
cpdf_scale | Domů | cpdf_set_char_spacing


cpdf_set_char_spacing

(PHP 4, PHP 5 <= 5.0.5)

cpdf_set_char_spacing — Sets character spacing

Popis

bool cpdf_set_char_spacing ( int $pdf_document, float $space )

Sets the spacing between characters.

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

space

Distance between individual characters in a string.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

cpdf_set_word_spacing()
cpdf_set_leading()

Předcházející | Nahoru | Další
cpdf_set_action_url | Domů | cpdf_set_creator


cpdf_set_creator

(PHP 4, PHP 5 <= 5.0.5)

cpdf_set_creator — Sets the creator field in the pdf document

Popis

bool cpdf_set_creator ( int $pdf_document, string $creator )

Sets the creator of a PDF document.

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

creator

The creator of the document

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

cpdf_set_subject()
cpdf_set_title()
cpdf_set_keywords()

Předcházející | Nahoru | Další
cpdf_set_char_spacing | Domů | cpdf_set_current_page


cpdf_set_current_page

(PHP 4, PHP 5 <= 5.0.5)

cpdf_set_current_page — Sets current page

Popis

bool cpdf_set_current_page ( int $pdf_document, int $page_number )

Sets the page on which all operations are performed. One can switch between pages until a page is finished with cpdf_finalize_page().

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

page_number

The page number

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

cpdf_finalize_page()

Předcházející | Nahoru | Další
cpdf_set_creator | Domů | cpdf_set_font_directories


cpdf_set_font_directories

(PHP 4 >= 4.0.6, PHP 5 <= 5.0.5)

cpdf_set_font_directories — Sets directories to search when using external fonts

Popis

bool cpdf_set_font_directories ( int $pdfdoc, string $pfmdir, string $pfbdir )

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
cpdf_set_current_page | Domů | cpdf_set_font_map_file


cpdf_set_font_map_file

(PHP 4 >= 4.0.6, PHP 5 <= 5.0.5)

cpdf_set_font_map_file — Sets fontname to filename translation map when using external fonts

Popis

bool cpdf_set_font_map_file ( int $pdfdoc, string $filename )

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
cpdf_set_font_directories | Domů | cpdf_set_font


cpdf_set_font

(PHP 4, PHP 5 <= 5.0.5)

cpdf_set_font — Select the current font face and size

Popis

bool cpdf_set_font ( int $pdf_document, string $font_name, float $size, string $encoding )

Sets the current font face, font size and encoding.

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

font_name

The font name. Currently only the standard postscript fonts are supported.

See the ClibPDF Manual for more information, especially on how to support Asian fonts.

size

The font size

encoding

Can take the following values: MacRomanEncoding, MacExpertEncoding, WinAnsiEncoding, and NULL (the font's built-in encoding).

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
cpdf_set_font_map_file | Domů | cpdf_set_horiz_scaling


cpdf_set_horiz_scaling

(PHP 4, PHP 5 <= 5.0.5)

cpdf_set_horiz_scaling — Sets horizontal scaling of text

Popis

bool cpdf_set_horiz_scaling ( int $pdf_document, float $scale )

Sets the horizontal scaling to scale percent.

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

scale

The scale percent to set

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
cpdf_set_font | Domů | cpdf_set_keywords


cpdf_set_keywords

(PHP 4, PHP 5 <= 5.0.5)

cpdf_set_keywords — Sets the keywords field of the pdf document

Popis

bool cpdf_set_keywords ( int $pdf_document, string $keywords )

Sets the keywords of the PDF document.

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

keywords

The keywords to set on the document

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

cpdf_set_title()
cpdf_set_creator()
cpdf_set_subject()

Předcházející | Nahoru | Další
cpdf_set_horiz_scaling | Domů | cpdf_set_leading


cpdf_set_leading

(PHP 4, PHP 5 <= 5.0.5)

cpdf_set_leading — Sets distance between text lines

Popis

bool cpdf_set_leading ( int $pdf_document, float $distance )

Sets the distance between text lines. This will be used if text is output by cpdf_continue_text().

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

distance

The distance between text lines, as a float

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

cpdf_continue_text()

Předcházející | Nahoru | Další
cpdf_set_keywords | Domů | cpdf_set_page_animation


cpdf_set_page_animation

(PHP 4, PHP 5 <= 5.0.5)

cpdf_set_page_animation — Sets duration between pages

Popis

bool cpdf_set_page_animation ( int $pdf_document, int $transition, float $duration, float $direction, int $orientation, int $inout )

Sets the transition between following pages.

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

transition

The value of transition can be

0 for none,
1 for two lines sweeping across the screen reveal the page,
2 for multiple lines sweeping across the screen reveal the page,
3 for a box reveals the page,
4 for a single line sweeping across the screen reveals the page,
5 for the old page dissolves to reveal the page,
6 for the dissolve effect moves from one screen edge to another,
7 for the old page is simply replaced by the new page (default)

duration

The value of duration is the number of seconds between page flipping.

direction

orientation

inout

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
cpdf_set_leading | Domů | cpdf_set_subject


cpdf_set_subject

(PHP 4, PHP 5 <= 5.0.5)

cpdf_set_subject — Sets the subject field of the pdf document

Popis

bool cpdf_set_subject ( int $pdf_document, string $subject )

Sets the subject of the PDF document.

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

subject

The subject of the document

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

cpdf_set_title()
cpdf_set_creator()
cpdf_set_keywords()

Předcházející | Nahoru | Další
cpdf_set_page_animation | Domů | cpdf_set_text_matrix


cpdf_set_text_matrix

(PHP 4, PHP 5 <= 5.0.5)

cpdf_set_text_matrix — Sets the text matrix

Popis

bool cpdf_set_text_matrix ( int $pdf_document, array $matrix )

Sets a matrix which describes a transformation applied on the current text font.

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

matrix

An array of six elements describing the transformation

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

cpdf_set_text_rendering()
cpdf_set_text_rise()

Předcházející | Nahoru | Další
cpdf_set_subject | Domů | cpdf_set_text_pos


cpdf_set_text_pos

(PHP 4, PHP 5 <= 5.0.5)

cpdf_set_text_pos — Sets text position

Popis

bool cpdf_set_text_pos ( int $pdf_document, float $x_coor, float $y_coor [, int $mode] )

Sets the position of text for the next cpdf_show() call.

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

x_coor

The x-coordinate of the text position

y_coor

The y-coordinate of the text position

mode

The optional parameter mode determines the unit length. If it is 0 or omitted the default unit as specified for the page is used. Otherwise the coordinates are measured in postscript points disregarding the current unit.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

cpdf_show()
cpdf_text()

Předcházející | Nahoru | Další
cpdf_set_text_matrix | Domů | cpdf_set_text_rendering


cpdf_set_text_rendering

(PHP 4, PHP 5 <= 5.0.5)

cpdf_set_text_rendering — Determines how text is rendered

Popis

bool cpdf_set_text_rendering ( int $pdf_document, int $rendermode )

Determines how the text is rendered.

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

rendermode

The possible values for rendermode are 0=fill text, 1=stroke text, 2=fill and stroke text, 3=invisible, 4=fill text and add it to clipping path, 5=stroke text and add it to clipping path, 6=fill and stroke text and add it to clipping path, 7=add it to clipping path.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

cpdf_set_text_matrix()
cpdf_set_text_rise()

Předcházející | Nahoru | Další
cpdf_set_text_pos | Domů | cpdf_set_text_rise


cpdf_set_text_rise

(PHP 4, PHP 5 <= 5.0.5)

cpdf_set_text_rise — Sets the text rise

Popis

bool cpdf_set_text_rise ( int $pdf_document, float $value )

Sets the text rising to value units.

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

value

The text rising, as a float

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

cpdf_set_text_rendering()
cpdf_set_text_matrix()

Předcházející | Nahoru | Další
cpdf_set_text_rendering | Domů | cpdf_set_title


cpdf_set_title

(PHP 4, PHP 5 <= 5.0.5)

cpdf_set_title — Sets the title field of the pdf document

Popis

bool cpdf_set_title ( int $pdf_document, string $title )

Sets the title of a PDF document.

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

title

The title of the document

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

cpdf_set_subject()
cpdf_set_creator()
cpdf_set_keywords()

Předcházející | Nahoru | Další
cpdf_set_text_rise | Domů | cpdf_set_viewer_preferences


cpdf_set_viewer_preferences

(PHP 4, PHP 5 <= 5.0.5)

cpdf_set_viewer_preferences — How to show the document in the viewer

Popis

bool cpdf_set_viewer_preferences ( int $pdfdoc, array $preferences )

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
cpdf_set_title | Domů | cpdf_set_word_spacing


cpdf_set_word_spacing

(PHP 4, PHP 5 <= 5.0.5)

cpdf_set_word_spacing — Sets spacing between words

Popis

bool cpdf_set_word_spacing ( int $pdf_document, float $space )

Sets the spacing between words.

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

space

The spacing, as a float

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

cpdf_set_char_spacing()
cpdf_set_leading()

Předcházející | Nahoru | Další
cpdf_set_viewer_preferences | Domů | cpdf_setdash


cpdf_setdash

(PHP 4, PHP 5 <= 5.0.5)

cpdf_setdash — Sets dash pattern

Popis

bool cpdf_setdash ( int $pdf_document, float $white, float $black )

Sets the dash pattern to the given one. If both parameters are 0, a solid line is set.

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

white

White units, as a float

black

Black units, as a float

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
cpdf_set_word_spacing | Domů | cpdf_setflat


cpdf_setflat

(PHP 4, PHP 5 <= 5.0.5)

cpdf_setflat — Sets flatness

Popis

bool cpdf_setflat ( int $pdf_document, float $value )

Sets the flatness.

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

value

The flatness as a float, between 0 and 100

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
cpdf_setdash | Domů | cpdf_setgray_fill


cpdf_setgray_fill

(PHP 4, PHP 5 <= 5.0.5)

cpdf_setgray_fill — Sets filling color to gray value

Popis

bool cpdf_setgray_fill ( int $pdf_document, float $value )

Sets the current gray value to fill a path.

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

value

The gray value, as a float

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

cpdf_setrgbcolor_fill()

Předcházející | Nahoru | Další
cpdf_setflat | Domů | cpdf_setgray_stroke


cpdf_setgray_stroke

(PHP 4, PHP 5 <= 5.0.5)

cpdf_setgray_stroke — Sets drawing color to gray value

Popis

bool cpdf_setgray_stroke ( int $pdf_document, float $gray_value )

Sets the current drawing color to the given gray value.

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

gray_value

The gray value, as a float

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

cpdf_setrgbcolor_stroke()

Předcházející | Nahoru | Další
cpdf_setgray_fill | Domů | cpdf_setgray


cpdf_setgray

(PHP 4, PHP 5 <= 5.0.5)

cpdf_setgray — Sets drawing and filling color to gray value

Popis

bool cpdf_setgray ( int $pdf_document, float $gray_value )

Sets the current drawing and filling color to the given gray value.

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

gray_value

The gray value, as a float

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

cpdf_setrgbcolor_stroke()
cpdf_setrgbcolor_fill()

Předcházející | Nahoru | Další
cpdf_setgray_stroke | Domů | cpdf_setlinecap


cpdf_setlinecap

(PHP 4, PHP 5 <= 5.0.5)

cpdf_setlinecap — Sets linecap parameter

Popis

bool cpdf_setlinecap ( int $pdf_document, int $value )

Sets the linecap parameter.

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

value

0 = butt end, 1 = round, 2 = projecting square

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
cpdf_setgray | Domů | cpdf_setlinejoin


cpdf_setlinejoin

(PHP 4, PHP 5 <= 5.0.5)

cpdf_setlinejoin — Sets linejoin parameter

Popis

bool cpdf_setlinejoin ( int $pdf_document, int $value )

Set the linejoin parameter.

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

value

0 = miter, 1 = round, 2 = bevel

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
cpdf_setlinecap | Domů | cpdf_setlinewidth


cpdf_setlinewidth

(PHP 4, PHP 5 <= 5.0.5)

cpdf_setlinewidth — Sets line width

Popis

bool cpdf_setlinewidth ( int $pdf_document, float $width )

Set the line width.

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

width

The line width, as a float

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
cpdf_setlinejoin | Domů | cpdf_setmiterlimit


cpdf_setmiterlimit

(PHP 4, PHP 5 <= 5.0.5)

cpdf_setmiterlimit — Sets miter limit

Popis

bool cpdf_setmiterlimit ( int $pdf_document, float $value )

Sets the miter limit.

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

value

The miter limit. Must be greater or equal than 1

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
cpdf_setlinewidth | Domů | cpdf_setrgbcolor_fill


cpdf_setrgbcolor_fill

(PHP 4, PHP 5 <= 5.0.5)

cpdf_setrgbcolor_fill — Sets filling color to rgb color value

Popis

bool cpdf_setrgbcolor_fill ( int $pdf_document, float $red_value, float $green_value, float $blue_value )

Sets the current rgb color value to fill a path.

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

red_value

The red value, as a float between 0.0 (black) and 1.0 (red)

green_value

The green value, as a float between 0.0 (black) and 1.0 (green)

blue_value

The blue value, as a float between 0.0 (black) and 1.0 (blue)

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

cpdf_setrgbcolor_stroke()
cpdf_setrgbcolor()

Předcházející | Nahoru | Další
cpdf_setmiterlimit | Domů | cpdf_setrgbcolor_stroke


cpdf_setrgbcolor_stroke

(PHP 4, PHP 5 <= 5.0.5)

cpdf_setrgbcolor_stroke — Sets drawing color to rgb color value

Popis

bool cpdf_setrgbcolor_stroke ( int $pdf_document, float $red_value, float $green_value, float $blue_value )

Sets the current drawing color to the given rgb color value.

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

red_value

The red value, as a float between 0.0 (black) and 1.0 (red)

green_value

The green value, as a float between 0.0 (black) and 1.0 (green)

blue_value

The blue value, as a float between 0.0 (black) and 1.0 (blue)

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

cpdf_setrgbcolor()
cpdf_setrgbcolor_fill()

Předcházející | Nahoru | Další
cpdf_setrgbcolor_fill | Domů | cpdf_setrgbcolor


cpdf_setrgbcolor

(PHP 4, PHP 5 <= 5.0.5)

cpdf_setrgbcolor — Sets drawing and filling color to rgb color value

Popis

bool cpdf_setrgbcolor ( int $pdf_document, float $red_value, float $green_value, float $blue_value )

Sets the current drawing and filling color to the given rgb color value.

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

red_value

The red value, as a float between 0.0 (black) and 1.0 (red)

green_value

The green value, as a float between 0.0 (black) and 1.0 (green)

blue_value

The blue value, as a float between 0.0 (black) and 1.0 (blue)

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

cpdf_setrgbcolor_stroke()
cpdf_setrgbcolor_fill()

Předcházející | Nahoru | Další
cpdf_setrgbcolor_stroke | Domů | cpdf_show_xy


cpdf_show_xy

(PHP 4, PHP 5 <= 5.0.5)

cpdf_show_xy — Output text at position

Popis

bool cpdf_show_xy ( int $pdf_document, string $text, float $x_coor, float $y_coor [, int $mode] )

Outputs the string text at the given position.

Poznámka: The function cpdf_show_xy() is identical to cpdf_text() without the optional parameters.

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

text

The text

x_coor

The x-coordinate of the text position

y_coor

The y-coordinate of the text position

mode

The optional parameter mode determines the unit length. If it is 0 or omitted the default unit as specified for the page is used. Otherwise the coordinates are measured in postscript points disregarding the current unit.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

cpdf_text()

Předcházející | Nahoru | Další
cpdf_setrgbcolor | Domů | cpdf_show


cpdf_show

(PHP 4, PHP 5 <= 5.0.5)

cpdf_show — Output text at current position

Popis

bool cpdf_show ( int $pdf_document, string $text )

Outputs a text at the current position.

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

text

The text, as a string

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

cpdf_text()
cpdf_begin_text()
cpdf_end_text()

Předcházející | Nahoru | Další
cpdf_show_xy | Domů | cpdf_stringwidth


cpdf_stringwidth

(PHP 4, PHP 5 <= 5.0.5)

cpdf_stringwidth — Returns width of text in current font

Popis

float cpdf_stringwidth ( int $pdf_document, string $text )

Returns the width of the string in text.

This function requires a font to be set before.

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

text

The text, as a string

Návratové hodnoty

Returns the width of text.

Viz také

cpdf_set_font()

Předcházející | Nahoru | Další
cpdf_show | Domů | cpdf_stroke


cpdf_stroke

(PHP 4, PHP 5 <= 5.0.5)

cpdf_stroke — Draw line along path

Popis

bool cpdf_stroke ( int $pdf_document )

Draws a line along current path.

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

cpdf_closepath()
cpdf_closepath_stroke()

Předcházející | Nahoru | Další
cpdf_stringwidth | Domů | cpdf_text


cpdf_text

(PHP 4, PHP 5 <= 5.0.5)

cpdf_text — Output text with parameters

Popis

bool cpdf_text ( int $pdf_document, string $text [, float $x_coor, float $y_coor [, int $mode [, float $orientation [, int $alignmode]]]] )

Outputs the string text at the given position.

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

text

The text

x_coor

The x-coordinate of the text position

y_coor

The y-coordinate of the text position

mode

The optional parameter mode determines the unit length. If it is 0 or omitted the default unit as specified for the page is used. Otherwise the coordinates are measured in postscript points disregarding the current unit.

orientation

Rotation of the text in degrees

alignmode

Determines how the text is aligned. See the ClibPDF documentation for possible values.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

cpdf_show_xy()

Předcházející | Nahoru | Další
cpdf_stroke | Domů | cpdf_translate


cpdf_translate

(PHP 4, PHP 5 <= 5.0.5)

cpdf_translate — Sets origin of coordinate system

Popis

bool cpdf_translate ( int $pdf_document, float $x_coor, float $y_coor )

Sets the origin of coordinate system to the specified point.

Seznam parametrů

pdf_document

The document handle, returned by cpdf_open().

x_coor

The x-coordinate of the point

y_coor

The y-coordinate of the point

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
cpdf_text | Domů | XVI. Funkce na podporu COM ve Windows


Crack Functions

Předcházející VI. Reference funkcí Další

XVII. Crack Functions

Úvod

These functions allow you to use the CrackLib library to test the 'strength' of a password. The 'strength' of a password is tested by that checks length, use of upper and lower case and checked against the specified CrackLib dictionary. CrackLib will also give helpful diagnostic messages that will help 'strengthen' the password.

Poznámka: Toto rozšíření bylo přesunuto do repozitáře PECL a již nebude součástí balíku PHP.5.0.0.

Požadavky

More information regarding CrackLib along with the library can be found at » http://sourceforge.net/projects/cracklib.

Instalace

Toto rozšíření » PECL není přibaleno k PHP. Informace o instalaci tohoto PECL rozšíření lze najít v kapitole manuálu nazvané Instalace rozšíření PECL. Další informace, jako nové verze, soubory ke stažení, zdrojové soubory, správcovské informace a CHANGELOG, lze najít zde: » http://pecl.php.net/package/crack.

V PHP 4 lze zdroje k těmto rozšířením PECL najít v adresáři ext/ ve zdrojích PHP source or nebo přes výše uvedený odkaz na PECL. In order to use these functions you must compile PHP with Crack support by using the --with-crack[=DIR] configuration option.

Windows users will enable php_crack.dll inside of php.ini in order to use these functions. V PHP 4 je tato DLL knihovna umístěna v adresáři extensions/ v downloadu binárních souborů PHP pro Windows. Tuto DLL knihovnu pro rozšíření PECL můžete stahovat ze stránky » PHP Downloads nebo z » http://snaps.php.net/.

Konfigurace běhu

Chování těchto funkcí je ovlivněno nastavením parametrů v php.ini.

Tabulka 31. Crack configuration options

Name | Default | Changeable | Changelog
crack.default_dictionary | NULL | PHP_INI_PERDIR | PHP_INI_SYSTEM in crack <= 0.2. Available since PHP 4.0.5. Removed in PHP 5.0.0.

Pro další detaily a definice konstant PHP_INI_*, viz dokumentace k ini_set().

Typy prostředků

The CrackLib extension defines a dictionary resource identifier returned by crack_opendict().

Předdefinované konstanty

Toto rozšíření nemá definovány žádné konstanty.

Příklady

This example shows how to open a CrackLib dictionary, test a given password, retrieve any diagnostic messages, and close the dictionary.

Příklad 321. CrackLib example

<?php
// Open CrackLib Dictionary
$dictionary = crack_opendict('/usr/local/lib/pw_dict')
     or die('Unable to open CrackLib dictionary');

// Perform password check
$check = crack_check($dictionary, 'gx9A2s0x');

// Retrieve messages
$diag = crack_getlastmessage();
echo $diag; // 'strong password'

// Close dictionary
crack_closedict($dictionary);
?>

Poznámka: If crack_check() returns TRUE, crack_getlastmessage() will return 'strong password'.

Obsah

crack_check — Performs an obscure check with the given password
crack_closedict — Closes an open CrackLib dictionary
crack_getlastmessage — Returns the message from the last obscure check
crack_opendict — Opens a new CrackLib dictionary
Předcházející | Nahoru | Další
variant_xor | Domů | crack_check


crack_check

(PHP 4 >= 4.0.5, PECL crack:0.1-0.4)

crack_check — Performs an obscure check with the given password

Popis

bool crack_check ( resource $dictionary, string $password )
bool crack_check ( string $password )

Performs an obscure check with the given password on the specified dictionary.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Seznam parametrů

dictionary

The crack lib dictionary. If not specified, the last opened dictionary is used.

password

The tested password.

Návratové hodnoty

Returns TRUE if password is strong, or FALSE otherwise.

Předcházející | Nahoru | Další
XVII. Crack Functions | Domů | crack_closedict


crack_closedict

(PHP 4 >= 4.0.5, PECL crack:0.1-0.4)

crack_closedict — Closes an open CrackLib dictionary

Popis

bool crack_closedict ( [resource $dictionary] )

crack_closedict() closes the specified dictionary identifier.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Seznam parametrů

dictionary

The dictionary to close. If not specified, the current directory is closed.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

crack_opendict()

Předcházející | Nahoru | Další
crack_check | Domů | crack_getlastmessage


crack_getlastmessage

(PHP 4 >= 4.0.5, PECL crack:0.1-0.4)

crack_getlastmessage — Returns the message from the last obscure check

Popis

string crack_getlastmessage ( void )

crack_getlastmessage() returns the message from the last obscure check.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Návratové hodnoty

The message from the last obscure check or FALSE if there was no obscure checks made so far.

The returned message is one of:

  • it's WAY too short
  • it is too short
  • it does not contain enough DIFFERENT characters
  • it is all whitespace
  • it is too simplistic/systematic
  • it looks like a National Insurance number.
  • it is based on a dictionary word
  • it is based on a (reversed) dictionary word
  • strong password

Viz také

crack_check()

Předcházející | Nahoru | Další
crack_closedict | Domů | crack_opendict


crack_opendict

(PHP 4 >= 4.0.5, PECL crack:0.1-0.4)

crack_opendict — Opens a new CrackLib dictionary

Popis

resource crack_opendict ( string $dictionary )

crack_opendict() opens the specified CrackLib dictionary for use with crack_check().

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Poznámka: Only one dictionary may be open at a time.

Seznam parametrů

dictionary

The path to the Cracklib dictionary.

Návratové hodnoty

Returns a dictionary resource identifier on success, or FALSE on failure.

Viz také

crack_check()
crack_closedict()

Předcházející | Nahoru | Další
crack_getlastmessage | Domů | XVIII. Character Type Functions


Funkce pro práci s CURL, Client URL Library

Předcházející VI. Reference funkcí Další

XIX. Funkce pro práci s CURL, Client URL Library

Úvod

PHP podporuje libcurl, knihovnu vytvořenou Danielem Stenbergem, která umožňuje spojení a komunikaci s mnoha různými typy serverů v mnoha různých typech protokolů. libcurl v současné době podporuje http, https, ftp, gopher, telnet, dict, file a ldap protokoly. libcurl také podporuje HTTPS certifikáty, HTTP POST, HTTP PUT, FTP uploady (toto umožňuje i ftp extenze PHP), HTTP formulářové uploady, proxy, cookies a user+password autentikaci.

Tyto funkce byly přidány v PHP 4.0.2.

Požadavky

Pokud chcete používat CURL funkce, musíte nainstalovat » CURL. PHP vyžaduje použití CURL 7.0.2-beta nebo vyšší. S verzemi CURL staršími než 7.0.2-beta PHP nebude pracovat. V PHP 4.2.3 budete potřebovat CURL 7.9.0 nebo vyšší. Od PHP 4.3.0 budete potřebovat CURL 7.9.8 nebo vyšší. PHP 5.0.0 bude nejspíš potřebovat CURL verze větší než 7.10.5

Instalace

Dále musíte PHP zkompilovat s volbou --with-curl[=DIR], kde DIR je umístění adresáře obsahujícího lib a include adresáře. V "include" adresáři by měl být adresář pojmenovaný "curl", který by měl obsahovat soubory easy.h and curl.h. V adresáři "lib" by měl být soubor pojmenovaný "libcurl.a". Počínaje PHP 4.3.0 můžete PHP nakonfigurovat tak, aby požívalo CURL pro url-streamy pomocí direktivy --with-curlwrappers.

Poznámka pro Win32 uživatele: Pro zajištění funkce tohoto rozšíření ve Windows musíte zkopírovat knihovny libeay32.dll a ssleay32.dll z adresáře DLL distribuce PHP/Win32 do adresáře SYSTEM. (Např.: C:\WINNT\SYSTEM32 or C:\WINDOWS\SYSTEM)

Předdefinované konstanty

Viz také předdefinované konstanty cURL.

Příklady

Pokud máte PHP zkompilované s podporou CURL, můžete začít používat CURL funkce. Základní principem těchto funkcí je, že pomocí curl_init() inicializujete CURL session, potom pomocí curl_exec() nastavíte hodnoty přenosu a nakonec session zavřete pomocí curl_close(). Následuje ukázka, která využíva CURL funkce ke stažení homepage PHP do souboru:

Příklad 333. Použití CURL extenze ke stažení homepage PHP

<?php

$ch = curl_init ("http://www.example.com/");
$fp = fopen ("example_homepage.txt", "w");

curl_setopt ($ch, CURLOPT_FILE, $fp);
curl_setopt ($ch, CURLOPT_HEADER, 0);

curl_exec ($ch);
curl_close ($ch);
fclose ($fp);
?>

Obsah

curl_close — Zavřít CURL session
curl_copy_handle — Copy a cURL handle along with all of its preferences
curl_errno — Return the last error number
curl_error — Return a string containing the last error for the current session
curl_exec — Provést CURL session
curl_getinfo — Get information regarding a specific transfer
curl_init — Inicializovat CURL session
curl_multi_add_handle — Add a normal cURL handle to a cURL multi handle
curl_multi_close — Close a set of cURL handles
curl_multi_exec — Run the sub-connections of the current cURL handle
curl_multi_getcontent — Return the content of a cURL handle if CURLOPT_RETURNTRANSFER is set
curl_multi_info_read — Get information about the current transfers
curl_multi_init — Returns a new cURL multi handle
curl_multi_remove_handle — Remove a multi handle from a set of cURL handles
curl_multi_select — Get all the sockets associated with the cURL extension, which can then be "selected"
curl_setopt_array — Set multiple options for a cURL transfer
curl_setopt — Nastavit parametr CURL transferu
curl_version — Vrátit verzi CURL
Předcházející | Nahoru | Další
ctype_xdigit | Domů | curl_close


curl_close

(PHP 4 >= 4.0.2, PHP 5)

curl_close — Zavřít CURL session

Popis

void curl_close ( resource $ch )

Tato funkce zavře CURL session a uvolní všechny zdroje. CURL handle, ch, se také smaže.

Předcházející | Nahoru | Další
XIX. Funkce pro práci s CURL, Client URL Library | Domů | curl_copy_handle


curl_copy_handle

(PHP 5)

curl_copy_handle — Copy a cURL handle along with all of its preferences

Popis

resource curl_copy_handle ( resource $ch )

Copies a cURL handle keeping the same preferences.

Seznam parametrů

ch

A cURL handle returned by curl_init().

Návratové hodnoty

Returns a new cURL handle.

Příklady

Příklad 334. Copying a cURL handle

<?php
// create a new cURL resource
$ch = curl_init();

// set URL and other appropriate options
curl_setopt($ch, CURLOPT_URL, 'http://www.example.com/');
curl_setopt($ch, CURLOPT_HEADER, 0);

// copy the handle
$ch2 = curl_copy_handle($ch);

// grab URL (http://www.example.com/) and pass it to the browser
curl_exec($ch2);

// close cURL resources, and free up system resources
curl_close($ch2);
curl_close($ch);
?>

Předcházející | Nahoru | Další
curl_close | Domů | curl_errno


curl_errno

(PHP 4 >= 4.0.3, PHP 5)

curl_errno — Return the last error number

Popis

int curl_errno ( resource $ch )

Returns the error number for the last cURL operation.

Seznam parametrů

ch

A cURL handle returned by curl_init().

Návratové hodnoty

Returns the error number or 0 (zero) if no error occurred.

Viz také

curl_error()
» Curl error codes

Předcházející | Nahoru | Další
curl_copy_handle | Domů | curl_error


curl_error

(PHP 4 >= 4.0.3, PHP 5)

curl_error — Return a string containing the last error for the current session

Popis

string curl_error ( resource $ch )

Returns a clear text error message for the last cURL operation.

Seznam parametrů

ch

A cURL handle returned by curl_init().

Návratové hodnoty

Returns the error number or '' (the empty string) if no error occurred.

Viz také

curl_errno()
» Curl error codes

Předcházející | Nahoru | Další
curl_errno | Domů | curl_exec


curl_exec

(PHP 4 >= 4.0.2, PHP 5)

curl_exec — Provést CURL session

Popis

mixed curl_exec ( resource $ch )

Tuto funkci byste měli zavolat po inicializaci CURL session a nastavení všech jejích parametrů. Jejím účelem je provést předdefinovanou CURL session (určenou argumentem ch).

Předcházející | Nahoru | Další
curl_error | Domů | curl_getinfo


curl_getinfo

(PHP 4 >= 4.0.4, PHP 5)

curl_getinfo — Get information regarding a specific transfer

Popis

mixed curl_getinfo ( resource $ch [, int $opt] )

Gets information about the last transfer,

Seznam parametrů

ch

A cURL handle returned by curl_init().

opt

This may be one of the following constants:

  • CURLINFO_EFFECTIVE_URL - Last effective URL
  • CURLINFO_HTTP_CODE - Last received HTTP code
  • CURLINFO_FILETIME - Remote time of the retrieved document, if -1 is returned the time of the document is unknown
  • CURLINFO_TOTAL_TIME - Total transaction time in seconds for last transfer
  • CURLINFO_NAMELOOKUP_TIME - Time in seconds until name resolving was complete
  • CURLINFO_CONNECT_TIME - Time in seconds it took to establish the connection
  • CURLINFO_PRETRANSFER_TIME - Time in seconds from start until just before file transfer begins
  • CURLINFO_STARTTRANSFER_TIME - Time in seconds until the first byte is about to be transferred
  • CURLINFO_REDIRECT_TIME - Time in seconds of all redirection steps before final transaction was started
  • CURLINFO_SIZE_UPLOAD - Total number of bytes uploaded
  • CURLINFO_SIZE_DOWNLOAD - Total number of bytes downloaded
  • CURLINFO_SPEED_DOWNLOAD - Average download speed
  • CURLINFO_SPEED_UPLOAD - Average upload speed
  • CURLINFO_HEADER_SIZE - Total size of all headers received
  • CURLINFO_HEADER_OUT - The request string sent. Available since PHP 5.1.3
  • CURLINFO_REQUEST_SIZE - Total size of issued requests, currently only for HTTP requests
  • CURLINFO_SSL_VERIFYRESULT - Result of SSL certification verification requested by setting CURLOPT_SSL_VERIFYPEER
  • CURLINFO_CONTENT_LENGTH_DOWNLOAD - content-length of download, read from Content-Length: field
  • CURLINFO_CONTENT_LENGTH_UPLOAD - Specified size of upload
  • CURLINFO_CONTENT_TYPE - Content-type of downloaded object, NULL indicates server did not send valid Content-Type: header

Návratové hodnoty

If opt is given, returns its value as a string. Otherwise, returns an associative array with the following elements (which correspond to opt):

  • "url"
  • "content_type"
  • "http_code"
  • "header_size"
  • "request_size"
  • "filetime"
  • "ssl_verify_result"
  • "redirect_count"
  • "total_time"
  • "namelookup_time"
  • "connect_time"
  • "pretransfer_time"
  • "size_upload"
  • "size_download"
  • "speed_download"
  • "speed_upload"
  • "download_content_length"
  • "upload_content_length"
  • "starttransfer_time"
  • "redirect_time"

Předcházející | Nahoru | Další
curl_exec | Domů | curl_init


curl_init

(PHP 4 >= 4.0.2, PHP 5)

curl_init — Inicializovat CURL session

Popis

resource curl_init ( [string $url] )

curl_init() inicializuje novou session a vrací CURL handle pro použití s funkcemi curl_setopt(), curl_exec() a curl_close(). Pokud je přítomen volitelný argument url, CURLOPT_URL se nastaví na hodnotu tohoto argumentu. Můžete to udělat i ručně, pomocí funkce curl_setopt().

Příklad 335. Inicializace nové CURL session a stažení webové stránky

<?php
$ch = curl_init();

curl_setopt ($ch, CURLOPT_URL, "http://www.zend.com/");
curl_setopt ($ch, CURLOPT_HEADER, 0);

curl_exec ($ch);

curl_close ($ch);
?>

Viz také: curl_close(), curl_setopt()

Předcházející | Nahoru | Další
curl_getinfo | Domů | curl_multi_add_handle


curl_multi_add_handle

(PHP 5)

curl_multi_add_handle — Add a normal cURL handle to a cURL multi handle

Popis

int curl_multi_add_handle ( resource $mh, resource $ch )

Adds the ch handle to the multi handle mh

Seznam parametrů

mh

A cURL multi handle returned by curl_multi_init().

ch

A cURL handle returned by curl_init().

Návratové hodnoty

Returns 0 on success, or one of the CURLM_XXX errors code.

Příklady

Příklad 336. curl_multi_add_handle() example

This example will create two cURL handles, add them to a multi handle, and then run them in parallel.

<?php
// create both cURL resources
$ch1 = curl_init();
$ch2 = curl_init();

// set URL and other appropriate options
curl_setopt($ch1, CURLOPT_URL, "http://www.example.com/");
curl_setopt($ch1, CURLOPT_HEADER, 0);
curl_setopt($ch2, CURLOPT_URL, "http://www.php.net/");
curl_setopt($ch2, CURLOPT_HEADER, 0);

//create the multiple cURL handle
$mh = curl_multi_init();

//add the two handles
curl_multi_add_handle($mh,$ch1);
curl_multi_add_handle($mh,$ch2);

$running=null;
//execute the handles
do {
    curl_multi_exec($mh,$running);
} while($running > 0);

//close all the handles
curl_multi_remove_handle($ch1);
curl_multi_remove_handle($ch2);
curl_multi_close($mh);
?>

Viz také

curl_multi_remove_handle()
curl_multi_init()
curl_init()

Předcházející | Nahoru | Další
curl_init | Domů | curl_multi_close


curl_multi_close

(PHP 5)

curl_multi_close — Close a set of cURL handles

Popis

void curl_multi_close ( resource $mh )

Closes a set of cURL handles.

Seznam parametrů

mh

A cURL multi handle returned by curl_multi_init().

Návratové hodnoty

Nevrací se žádná hodnota.

Příklady

Příklad 337. curl_multi_close() example

This example will create two cURL handles, add them to a multi handle, and then run them in parallel.

<?php
// create both cURL resources
$ch1 = curl_init();
$ch2 = curl_init();

// set URL and other appropriate options
curl_setopt($ch1, CURLOPT_URL, "http://www.example.com/");
curl_setopt($ch1, CURLOPT_HEADER, 0);
curl_setopt($ch2, CURLOPT_URL, "http://www.php.net/");
curl_setopt($ch2, CURLOPT_HEADER, 0);

//create the multiple cURL handle
$mh = curl_multi_init();

//add the two handles
curl_multi_add_handle($mh,$ch1);
curl_multi_add_handle($mh,$ch2);

$running=null;
//execute the handles
do {
    curl_multi_exec($mh,$running);
} while ($running > 0)
//close the handles
curl_multi_remove_handle($ch1);
curl_multi_remove_handle($ch2);
curl_multi_close($mh);

?>

Viz také

curl_multi_init()
curl_close()

Předcházející | Nahoru | Další
curl_multi_add_handle | Domů | curl_multi_exec


curl_multi_exec

(PHP 5)

curl_multi_exec — Run the sub-connections of the current cURL handle

Popis

int curl_multi_exec ( resource $mh, int &$still_running )

Processes each of the handles in the stack. This method can be called whether or not a handle needs to read or write data.

Seznam parametrů

mh

A cURL multi handle returned by curl_multi_init().

still_running

A reference to a flag to tell whether the operations are still running.

Návratové hodnoty

A cURL code defined in the cURL Predefined Constants.

Poznámka: This only returns errors regarding the whole multi stack. There might still have occurred problems on individual transfers even when this function returns CURLM_OK.

Příklady

Příklad 338. curl_multi_exec() example

This example will create two cURL handles, add them to a multi handle, and then run them in parallel.

<?php
// create both cURL resources
$ch1 = curl_init();
$ch2 = curl_init();

// set URL and other appropriate options
curl_setopt($ch1, CURLOPT_URL, "http://www.example.com/");
curl_setopt($ch1, CURLOPT_HEADER, 0);
curl_setopt($ch2, CURLOPT_URL, "http://www.php.net/");
curl_setopt($ch2, CURLOPT_HEADER, 0);

//create the multiple cURL handle
$mh = curl_multi_init();

//add the two handles
curl_multi_add_handle($mh,$ch1);
curl_multi_add_handle($mh,$ch2);

$running=null;
//execute the handles
do {
    $mrc = curl_multi_exec($mh, $running);
} while ($mrc == CURLM_CALL_MULTI_PERFORM);

//close the handles
curl_multi_remove_handle($mh, $ch1);
curl_multi_remove_handle($mh, $ch2);
curl_multi_close($mh);

?>

Viz také

curl_multi_init()
curl_exec()

Předcházející | Nahoru | Další
curl_multi_close | Domů | curl_multi_getcontent


curl_multi_getcontent

(PHP 5)

curl_multi_getcontent — Return the content of a cURL handle if CURLOPT_RETURNTRANSFER is set

Popis

string curl_multi_getcontent ( resource $ch )

If CURLOPT_RETURNTRANSFER is an option that is set for a specific handle, then this function will return the content of that cURL handle in the form of a string.

Seznam parametrů

ch

A cURL handle returned by curl_init().

Návratové hodnoty

Return the content of a cURL handle if CURLOPT_RETURNTRANSFER is set.

Viz také

curl_multi_init()

Předcházející | Nahoru | Další
curl_multi_exec | Domů | curl_multi_info_read


curl_multi_info_read

(PHP 5)

curl_multi_info_read — Get information about the current transfers

Popis

array curl_multi_info_read ( resource $mh [, int $msgs_in_queue] )

Ask the multi handle if there are any messages/informationals from the individual transfers. Messages may include informationals such as an error code from the transfer or just the fact that a transfer is completed.

Repeated calls to this function will return a new result each time, until a FALSE is returned as a signal that there is no more to get at this point. The integer pointed to with msgs_in_queue will contain the number of remaining messages after this function was called.

Varování

The data the returned resource points to will not survive calling curl_multi_remove_handle().

Seznam parametrů

mh

A cURL multi handle returned by curl_multi_init().

msgs_in_queue

Number of messages that are still in the queue

Návratové hodnoty

On success, returns an associative array for the message, FALSE on failure.

ChangeLog (záznam změn)

Verze | Popis
5.2.0 | msgs_in_queue was added.

Viz také

curl_multi_init()

Předcházející | Nahoru | Další
curl_multi_getcontent | Domů | curl_multi_init


curl_multi_init

(PHP 5)

curl_multi_init — Returns a new cURL multi handle

Popis

resource curl_multi_init ( void )

Allows the processing of multiple cURL handles in parallel.

Seznam parametrů

mh

A cURL multi handle returned by curl_multi_init().

Návratové hodnoty

Returns a cURL on handle on success, FALSE on failure.

Příklady

Příklad 339. curl_multi_init() example

This example will create two cURL handles, add them to a multi handle, and then run them in parallel.

<?php
// create both cURL resources
$ch1 = curl_init();
$ch2 = curl_init();

// set URL and other appropriate options
curl_setopt($ch1, CURLOPT_URL, "http://www.example.com/");
curl_setopt($ch1, CURLOPT_HEADER, 0);
curl_setopt($ch2, CURLOPT_URL, "http://www.php.net/");
curl_setopt($ch2, CURLOPT_HEADER, 0);

//create the multiple cURL handle
$mh = curl_multi_init();

//add the two handles
curl_multi_add_handle($mh,$ch1);
curl_multi_add_handle($mh,$ch2);

$running=null;
//execute the handles
do {
    curl_multi_exec($mh,$running);
} while ($running > 0);

//close the handles
curl_multi_remove_handle($ch1);
curl_multi_remove_handle($ch2);
curl_multi_close($mh);

?>

Viz také

curl_init()
curl_multi_close()

Předcházející | Nahoru | Další
curl_multi_info_read | Domů | curl_multi_remove_handle


curl_multi_remove_handle

(PHP 5)

curl_multi_remove_handle — Remove a multi handle from a set of cURL handles

Popis

int curl_multi_remove_handle ( resource $mh, resource $ch )

Removes a given ch handle from the given mh handle. When the ch handle has been removed, it is again perfectly legal to run curl_exec() on this handle. Removing a handle while being used, will effectively halt all transfers in progress.

Seznam parametrů

mh

A cURL multi handle returned by curl_multi_init().

ch

A cURL handle returned by curl_init().

Návratové hodnoty

On success, returns a cURL handle, FALSE on failure.

Viz také

curl_init()
curl_multi_init()
curl_multi_add_handle()

Předcházející | Nahoru | Další
curl_multi_init | Domů | curl_multi_select


curl_multi_select

(PHP 5)

curl_multi_select — Get all the sockets associated with the cURL extension, which can then be "selected"

Popis

int curl_multi_select ( resource $mh [, float $timeout] )

Get all the sockets associated with the cURL extension, which can then be "selected".

Seznam parametrů

mh

A cURL multi handle returned by curl_multi_init().

timeout

Time, in seconds, to wait for a response.

Návratové hodnoty

On success, returns the number of descriptors contained in, the descriptor sets. On failure, this function will return FALSE.

Viz také

curl_multi_init()

Předcházející | Nahoru | Další
curl_multi_remove_handle | Domů | curl_setopt_array


curl_setopt

(PHP 4 >= 4.0.2, PHP 5)

curl_setopt — Nastavit parametr CURL transferu

Popis

bool curl_setopt ( resource $ch, int $option, mixed $value )

curl_setopt() nastavuje parametry CURL session ch. option je parametr, který chcete nastavit a value je hodnota, na kterou se má option nastavit.

Argument value by měl u následujících hodnot argumentu option obsahovat integer:

  • CURLOPT_INFILESIZE: Tento parametr by měl u uploadů obsahovat velikost uploadovaného souboru.
  • CURLOPT_VERBOSE: Pokud chcete, aby CURL podávala zprávy o všem co se děje, nastavte tento parametr na nenulovou hodnotu.
  • CURLOPT_HEADER: Pokud chcete, aby výstup obsahoval hlavičky, nastavte tento parametr na nenulovou hodnotu.

  • CURLOPT_NOPROGRESS: Pokud PHP nemá zobrazit měřidlo postupu CURL transferu, nastavte tento parametr na nenulovou hodnotu.

    Poznámka: PHP tento parametr automaticky nastavuje na nenulovou hodnotu, změna je vhodná pouze pro účely ladění.

  • CURLOPT_NOBODY: Pokud nechete, aby bylo ve výstupu zahrnuto tělo výstupu, nastavte tento parametr na nenulovou hodnotu.
  • CURLOPT_FAILONERROR: Pokud má PHP tiše ukončit transfer po přijetí HTTP server kódu většího než 300, nastavte tento parametr na nenulovou hodnotu. Defaultní chování je ignorovat návratový kód a normálně vrátit stránku.
  • CURLOPT_UPLOAD: Pokud chcete PHP připravit na upload, nastavte tento parametr na nenulovou hodnotu.
  • CURLOPT_POST: Pokud chcete, aby PHP provedl běžný HTTP POST pořadavek, nastavte tento parametr na nenulovou hodnotu. Jedná se o běžný application/x-www-from-urlencoded POST požadavek, který se většinou používá u HTML formulářů.
  • CURLOPT_FTPLISTONLY: Pokud chcete, aby PHP vypsalo názvy souborů v FTP adresáři, nastavte tento parametr na nenulovou hodnotu.
  • CURLOPT_FTPAPPEND: Pokud chcete, aby PHP místo přepsání vzdáleného souboru připojilo upload k jeho obsahu, nastavte tento parametr na nenulovou hodnotu.
  • CURLOPT_NETRC: Pokud má PHP ve vašem ~./netrc souboru hledat vaše uživatelské jméno a heslo pro server ke kterému se připojujete.
  • CURLOPT_FOLLOWLOCATION: Pokud má PHP provádět přesměrování u případných "Location: " hlaviček vrácených serverem. (Pozn.: rekurzivní, PHP provede přesměrování pro všechny "Location: " hlavičky, které přijme.)
  • CURLOPT_PUT: Pokud chcete uploadovat soubor pomocí HTTP metody PUT, nastavte tento parametr na nenulovou hodnotu. Uploadovaný soubor musí být určen parametry CURLOPT_INFILE a CURLOPT_INFILESIZE.
  • CURLOPT_MUTE: Pokud má být PHP naprosto tiché ohledně CURL funkcí, nastavte tento parametr na nenulovou hodnotu.
  • CURLOPT_TIMEOUT: Integer určující maximální čas ve vteřinách, který mohou CURL funkce zabrat.
  • CURLOPT_LOW_SPEED_LIMIT: Integer určující minimální rychlost přenosu v bytech za sekundu. Pokud rychlost přenosu klesne pod tento limit po dobu CURLOPT_LOW_SPEED_TIME sekund, PHP ukončí transfer.
  • CURLOPT_LOW_SPEED_TIME: Integer určující čas ve vteřinách. Pokud rychlost přenosu klesne na tuto dobu pod CURLOPT_LOW_SPEED_LIMIT, PHP zruší transfer.
  • CURLOPT_RESUME_FROM: Integer určující offset v bytech, na kterém má transfer začít.
  • CURLOPT_SSLVERSION: Integer určující, jaká verze SSL (2 nebo 3) se má použít. Defaultně se PHP pokusí určit verzi samo, ale v některých případech je nutno verzi určit manuálně.
  • CURLOPT_TIMECONDITION: Definující chování CURLOPT_TIMEVALUE. Tento parametr může nabýt buď hodnoty TIMECOND_IFMODSINCE nebo TIMECOND_ISUNMODSINCE. Funguje pouze u HTTP přenosů.
  • CURLOPT_TIMEVALUE: Integer určující počet vteřin od 1. ledna 1970. Tento čas se použije podle intervalu CURLOPT_TIMEVALUE, default je použití TIMECOND_IFMODSINCE.

Argument value by měl u následujících hodnot argumentu option obsahovat řetězec:

  • CURLOPT_URL: Toto je URL, kterou má PHP stáhnout. Tento parametr můžete také nastavit při inicializaci CURL session pomocí funkce curl_init().
  • CURLOPT_USERPWD: Řetězec ve tvaru [username]:[password] pro použití při spojení.
  • CURLOPT_PROXYUSERPWD: Řetězec ve tvaru [username]:[password] pro použití při spojení s HTTP proxy.
  • CURLOPT_RANGE: Pass the specified range you want. It should be in the "X-Y" format, where X or Y may be left out. The HTTP transfers also support several intervals, seperated with commas as in X-Y,N-M.
  • CURLOPT_POSTFIELDS: Řetězec obsahující kompletní data, která se mají odeslat v HTTP POST požadavku.
  • CURLOPT_REFERER: Řetězec obsahující "referer" hlavičku pro použití v HTTP požadavku.
  • CURLOPT_USERAGENT: Řetězec obsahující "user-agent" hlavičku pro použití v HTTP požadavku.
  • CURLOPT_FTPPORT: Řetězec, na jehož základě se získá IP adresa pro FTP "POST" instrukci. POST instrukce říká serveru, aby se připojil na danou IP adresu. Tento řetězec může obsahovat IP adresu, hostname, a network interface name (under UNIX) nebo '-' (použije se defaultní IP adresa systému).
  • CURLOPT_COOKIE: Řetězec obsahující cookie, který se má poslat v HTTP hlavičce tohoto přenosu.
  • CURLOPT_SSLCERT: Řetězec obsahující název souboru PEM certifikátu.
  • CURLOPT_SSLCERTPASSWD: Řetězec obsahující heslo vyžadované pro použití CURLOPT_SSLCERT certifikátu.
  • CURLOPT_COOKIEFILE: Řetězec obsahující název souboru obsahujícího cookie data. Cookie soubor může být buď v Netscape formátu nebo obsahovat HTTP hlavičky.

  • CURLOPT_CUSTOMREQUEST: Řetězec, který se má v HTTP požadavku použít místo GET nebo HEAD. Toto je užitečné při DELETE či jiných, obskurnějších HTTP požadavcích.

    Poznámka: Používejte pouze v případě, že váš server tento příkaz podporuje.

Následující parametry očekávají deskriptor vrácený funkcí fopen():

  • CURLOPT_FILE: Soubor, do kterého se má umístit výstup CURL transferu. Default je STDOUT.
  • CURLOPT_INFILE: Soubor, který obsahuje vstup CURL transferu.
  • CURLOPT_WRITEHEADER: Soubor, do kterého se mají zapsat hlavičky výstupu.
  • CURLOPT_STDERR: Soubor, do kterého se mají zapisovat chyby místo na STDERR.

Předcházející | Nahoru | Další
curl_setopt_array | Domů | curl_version


curl_version

(PHP 4 >= 4.0.2, PHP 5)

curl_version — Vrátit verzi CURL

Popis

array curl_version ( [int $version] )

curl_version() vrací řetězec obsahující použitou verzi CURL.

Předcházející | Nahoru | Další
curl_setopt | Domů | XX. Cybercash platební funkce


Cybercash platební funkce

Předcházející VI. Reference funkcí Další

XX. Cybercash platební funkce

Instalace

Tyto funkce jsou dostupné pouze pokud bylo PHP zkompilováno s volbou --with-cybercash=[DIR].

Tyto funkce byly v PHP 4.3.0 přesunuty do depozitíře » PECL.

Pokud máte dotazy k poslednímu stavu knihovny CyberCash, pomůže vám odkaz » CyberCash Faq. Ve zkratce lze říci, že CyberCash byl uveden firmou VeriSign a i když služby CyberCash nadále existují, VeriSign doporučuje uživatelům přechod. Pro bližší informace viz FAQ a odkaz na PECL.

Obsah

cybercash_base64_decode — base64 decode data for Cybercash
cybercash_base64_encode — base64 encode data for Cybercash
cybercash_decr — Cybercash dešifrování
cybercash_encr — Cybercash zašifrování
Předcházející | Nahoru | Další
curl_version | Domů | cybercash_base64_decode


cybercash_base64_decode

(PHP 4 <= 4.2.3, PECL cybercash:1.18)

cybercash_base64_decode — base64 decode data for Cybercash

Popis

string cybercash_base64_decode ( string $inbuff )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
XX. Cybercash platební funkce | Domů | cybercash_base64_encode


cybercash_base64_encode

(PHP 4 <= 4.2.3, PECL cybercash:1.18)

cybercash_base64_encode — base64 encode data for Cybercash

Popis

string cybercash_base64_encode ( string $inbuff )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
cybercash_base64_decode | Domů | cybercash_decr


cybercash_decr

(PHP 4 <= 4.2.3, PECL cybercash:1.18)

cybercash_decr — Cybercash dešifrování

Popis

array cybercash_decr ( string $wmk, string $sk, string $inbuff )

Tato funkce vrací asociativní pole s elementem "errcode", a pokud je "errcode" FALSE, "outbuff" (string), tak "outLth" (long) a "macbuff" (string).

Předcházející | Nahoru | Další
cybercash_base64_encode | Domů | cybercash_encr


cybercash_encr

(PHP 4 <= 4.2.3, PECL cybercash:1.18)

cybercash_encr — Cybercash zašifrování

Popis

array cybercash_encr ( string $wmk, string $sk, string $inbuff )

Tato funkce vrací asociativní pole s elementem "errcode", a pokud je "errcode" FALSE, tak "outbuff" (string), "outLth" (long) and "macbuff" (string).

Předcházející | Nahoru | Další
cybercash_decr | Domů | XXI. Credit Mutuel CyberMUT functions


Cyrus IMAP administration Functions

Předcházející VI. Reference funkcí Další

XXII. Cyrus IMAP administration Functions

Úvod

Poznámka: Toto rozšíření není k dispozici na platformách Windows.

Poznámka: Toto rozšíření bylo přesunuto do repozitáře PECL a již nebude součástí balíku PHP.5.0.0.

Instalace

To enable Cyrus IMAP support and to use these functions you have to compile PHP with the --with-cyrus option.

Varování

Rozšíření IMAP, recode, YAZ a Cyrus nelze používat současně, protože sdílejí stejný interní symbol.

Typy prostředků

This extension defines a Cyrus IMAP connection identifier returned by cyrus_connect().

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

CYRUS_CONN_NONSYNCLITERAL (integer)
CYRUS_CONN_INITIALRESPONSE (integer)
CYRUS_CALLBACK_NUMBERED (integer)
CYRUS_CALLBACK_NOLITERAL (integer)

Obsah

cyrus_authenticate — Authenticate against a Cyrus IMAP server
cyrus_bind — Bind callbacks to a Cyrus IMAP connection
cyrus_close — Close connection to a Cyrus IMAP server
cyrus_connect — Connect to a Cyrus IMAP server
cyrus_query — Send a query to a Cyrus IMAP server
cyrus_unbind — Unbind ...
Předcházející | Nahoru | Další
cybermut_testmac | Domů | cyrus_authenticate


cyrus_authenticate

(PHP 4 >= 4.0.7, PECL cyrus:1.0)

cyrus_authenticate — Authenticate against a Cyrus IMAP server

Popis

void cyrus_authenticate ( resource $connection [, string $mechlist [, string $service [, string $user [, int $minssf [, int $maxssf [, string $authname [, string $password]]]]]]] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
XXII. Cyrus IMAP administration Functions | Domů | cyrus_bind


cyrus_bind

(PHP 4 >= 4.0.7, PECL cyrus:1.0)

cyrus_bind — Bind callbacks to a Cyrus IMAP connection

Popis

bool cyrus_bind ( resource $connection, array $callbacks )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
cyrus_authenticate | Domů | cyrus_close


cyrus_close

(PHP 4 >= 4.0.7, PECL cyrus:1.0)

cyrus_close — Close connection to a Cyrus IMAP server

Popis

bool cyrus_close ( resource $connection )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
cyrus_bind | Domů | cyrus_connect


cyrus_connect

(PHP 4 >= 4.0.7, PECL cyrus:1.0)

cyrus_connect — Connect to a Cyrus IMAP server

Popis

resource cyrus_connect ( [string $host [, string $port [, int $flags]]] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
cyrus_close | Domů | cyrus_query


cyrus_query

(PHP 4 >= 4.0.7, PECL cyrus:1.0)

cyrus_query — Send a query to a Cyrus IMAP server

Popis

array cyrus_query ( resource $connection, string $query )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
cyrus_connect | Domů | cyrus_unbind


cyrus_unbind

(PHP 4 >= 4.0.7, PECL cyrus:1.0)

cyrus_unbind — Unbind ...

Popis

bool cyrus_unbind ( resource $connection, string $trigger_name )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
cyrus_query | Domů | XXIII. Funkce pro datum a čas


Character Type Functions

Předcházející VI. Reference funkcí Další

XVIII. Character Type Functions

Úvod

The functions provided by this extension check whether a character or string falls into a certain character class according to the current locale (see also setlocale()).

When called with an integer argument these functions behave exactly like their C counterparts from ctype.h. It means that if you pass an integer smaller than 256 it will use the ASCII value of it to see if it fits in the specified range (digits are in 0x30-0x39). If the number is between -128 and -1 inclusive then 256 will be added and the check will be done on that.

When called with a string argument they will check every character in the string and will only return TRUE if every character in the string matches the requested criteria. When called with an empty string the result will always be TRUE in PHP < 5.1 and FALSE since 5.1.

Passing anything else but a string or integer will return FALSE immediately.

It should be noted that ctype functions are always preferred over regular expressions, and even to some equivalent str_* and is_* functions. This is because of the fact that ctype uses a native C library and thus processes significantly faster.

Požadavky

None besides functions from the standard C library which are always available.

Instalace

Beginning with PHP 4.2.0 these functions are enabled by default. For older versions you have to configure and compile PHP with --enable-ctype. You can disable ctype support with --disable-ctype.

Verze PHP pro Windows má vestavěnou podporu pro toto rozšíření. K použití těchto funkcí není třeba načítat žádná další rozšíření.

Poznámka: Builtin support for ctype is available with PHP 4.3.0.

Konfigurace běhu

Toto rozšíření nemá definováno žádné konfigurační direktivy.

Typy prostředků

Toto rozšíření nemá definován žádný typ prostředku (resource).

Předdefinované konstanty

Toto rozšíření nemá definovány žádné konstanty.

Obsah

ctype_alnum — Check for alphanumeric character(s)
ctype_alpha — Check for alphabetic character(s)
ctype_cntrl — Check for control character(s)
ctype_digit — Check for numeric character(s)
ctype_graph — Check for any printable character(s) except space
ctype_lower — Check for lowercase character(s)
ctype_print — Check for printable character(s)
ctype_punct — Check for any printable character which is not whitespace or an alphanumeric character
ctype_space — Check for whitespace character(s)
ctype_upper — Check for uppercase character(s)
ctype_xdigit — Check for character(s) representing a hexadecimal digit
Předcházející | Nahoru | Další
crack_opendict | Domů | ctype_alnum


ctype_alnum

(PHP 4 >= 4.0.4, PHP 5)

ctype_alnum — Check for alphanumeric character(s)

Popis

bool ctype_alnum ( string $text )

Checks if all of the characters in the provided string, text, are alphanumeric. In the standard C locale letters are just [A-Za-z].

Seznam parametrů

text

The tested string.

Návratové hodnoty

Returns TRUE if every character in text is either a letter or a digit, FALSE otherwise.

Příklady

Příklad 322. A ctype_alnum() example (using the default locale)

<?php
$strings = array('AbCd1zyZ9', 'foo!#$bar');
foreach ($strings as $testcase) {
    if (ctype_alnum($testcase)) {
        echo "The string $testcase consists of all letters or digits.\n";
    } else {
        echo "The string $testcase does not consist of all letters or digits.\n";
    }
}
?>

Výše uvedený příklad vypíše:

The string AbCd1zyZ9 consists of all letters or digits.
The string foo!#$bar does not consist of all letters or digits.

Viz také

ctype_alpha()
ctype_digit()
setlocale()

Předcházející | Nahoru | Další
XVIII. Character Type Functions | Domů | ctype_alpha


ctype_alpha

(PHP 4 >= 4.0.4, PHP 5)

ctype_alpha — Check for alphabetic character(s)

Popis

bool ctype_alpha ( string $text )

Checks if all of the characters in the provided string, text, are alphabetic. In the standard C locale letters are just [A-Za-z] and ctype_alpha() is equivalent to (ctype_upper($text) || ctype_lower($text)) if $text is just a single character, but other languages have letters that are considered neither upper nor lower case.

Seznam parametrů

text

The tested string.

Návratové hodnoty

Returns TRUE if every character in text is a letter from the current locale, FALSE otherwise.

Příklady

Příklad 323. A ctype_alpha() example (using the default locale)

<?php
$strings = array('KjgWZC', 'arf12');
foreach ($strings as $testcase) {
    if (ctype_alpha($testcase)) {
        echo "The string $testcase consists of all letters.\n";
    } else {
        echo "The string $testcase does not consist of all letters.\n";
    }
}
?>

Výše uvedený příklad vypíše:

The string KjgWZC consists of all letters.
The string arf12 does not consist of all letters.

Viz také

ctype_upper()
ctype_lower()
setlocale()

Předcházející | Nahoru | Další
ctype_alnum | Domů | ctype_cntrl


ctype_cntrl

(PHP 4 >= 4.0.4, PHP 5)

ctype_cntrl — Check for control character(s)

Popis

bool ctype_cntrl ( string $text )

Checks if all of the characters in the provided string, text, are control characters. Control characters are e.g. line feed, tab, escape.

Seznam parametrů

text

The tested string.

Návratové hodnoty

Returns TRUE if every character in text is a control character from the current locale, FALSE otherwise.

Příklady

Příklad 324. A ctype_cntrl() example

<?php
$strings = array('string1' => "\n\r\t", 'string2' => 'arf12');
foreach ($strings as $name => $testcase) {
    if (ctype_cntrl($testcase)) {
        echo "The string '$name' consists of all control characters.\n";
    } else {
        echo "The string '$name' does not consist of all control characters.\n";
    }
}
?>

Výše uvedený příklad vypíše:

The string 'string1' consists of all control characters.
The string 'string2' does not consist of all control characters.

Viz také

ctype_print()

Předcházející | Nahoru | Další
ctype_alpha | Domů | ctype_digit


ctype_digit

(PHP 4 >= 4.0.4, PHP 5)

ctype_digit — Check for numeric character(s)

Popis

bool ctype_digit ( string $text )

Checks if all of the characters in the provided string, text, are numerical.

Seznam parametrů

text

The tested string.

Návratové hodnoty

Returns TRUE if every character in text is a decimal digit, FALSE otherwise.

Příklady

Příklad 325. A ctype_digit() example

<?php
$strings = array('1820.20', '10002', 'wsl!12');
foreach ($strings as $testcase) {
    if (ctype_digit($testcase)) {
        echo "The string $testcase consists of all digits.\n";
    } else {
        echo "The string $testcase does not consist of all digits.\n";
    }
}
?>

Výše uvedený příklad vypíše:

The string 1820.20 does not consist of all digits.
The string 10002 consists of all digits.
The string wsl!12 does not consist of all digits.

Viz také

ctype_alnum()
ctype_xdigit()

Předcházející | Nahoru | Další
ctype_cntrl | Domů | ctype_graph


ctype_graph

(PHP 4 >= 4.0.4, PHP 5)

ctype_graph — Check for any printable character(s) except space

Popis

bool ctype_graph ( string $text )

Checks if all of the characters in the provided string, text, creates visible output.

Seznam parametrů

text

The tested string.

Návratové hodnoty

Returns TRUE if every character in text is printable and actually creates visible output (no white space), FALSE otherwise.

Příklady

Příklad 326. A ctype_graph() example

<?php
$strings = array('string1' => "asdf\n\r\t", 'string2' => 'arf12', 'string3' => 'LKA#@%.54');
foreach ($strings as $name => $testcase) {
    if (ctype_graph($testcase)) {
        echo "The string '$name' consists of all (visibly) printable characters.\n";
    } else {
        echo "The string '$name' does not consist of all (visibly) printable characters.\n";
    }
}
?>

Výše uvedený příklad vypíše:

The string 'string1' does not consist of all (visibly) printable characters.
The string 'string2' consists of all (visibly) printable characters.
The string 'string3' consists of all (visibly) printable characters.

Viz také

ctype_alnum()
ctype_print()
ctype_punct()

Předcházející | Nahoru | Další
ctype_digit | Domů | ctype_lower


ctype_lower

(PHP 4 >= 4.0.4, PHP 5)

ctype_lower — Check for lowercase character(s)

Popis

bool ctype_lower ( string $text )

Checks if all of the characters in the provided string, text, are lowercase letters.

Seznam parametrů

text

The tested string.

Návratové hodnoty

Returns TRUE if every character in text is a lowercase letter in the current locale.

Příklady

Příklad 327. A ctype_lower() example (using the default locale)

<?php
$strings = array('aac123', 'qiutoas', 'QASsdks');
foreach ($strings as $testcase) {
    if (ctype_lower($testcase)) {
        echo "The string $testcase consists of all lowercase letters.\n";
    } else {
        echo "The string $testcase does not consist of all lowercase letters.\n";
    }
}
?>

Výše uvedený příklad vypíše:

The string aac123 does not consist of all lowercase letters.
The string qiutoas consists of all lowercase letters.
The string QASsdks does not consist of all lowercase letters.

Viz také

ctype_alpha()
ctype_upper()
setlocale()

Předcházející | Nahoru | Další
ctype_graph | Domů | ctype_print


ctype_print

(PHP 4 >= 4.0.4, PHP 5)

ctype_print — Check for printable character(s)

Popis

bool ctype_print ( string $text )

Checks if all of the characters in the provided string, text, are printable.

Seznam parametrů

text

The tested string.

Návratové hodnoty

Returns TRUE if every character in text will actually create output (including blanks). Returns FALSE if text contains control characters or characters that do not have any output or control function at all.

Příklady

Příklad 328. A ctype_print() example

<?php
$strings = array('string1' => "asdf\n\r\t", 'string2' => 'arf12', 'string3' => 'LKA#@%.54');
foreach ($strings as $name => $testcase) {
    if (ctype_print($testcase)) {
        echo "The string '$name' consists of all printable characters.\n";
    } else {
        echo "The string '$name' does not consist of all printable characters.\n";
    }
}
?>

Výše uvedený příklad vypíše:

The string 'string1' does not consist of all printable characters.
The string 'string2' consists of all printable characters.
The string 'string3' consists of all printable characters.

Viz také

ctype_cntrl()
ctype_graph()
ctype_punct()

Předcházející | Nahoru | Další
ctype_lower | Domů | ctype_punct


ctype_punct

(PHP 4 >= 4.0.4, PHP 5)

ctype_punct — Check for any printable character which is not whitespace or an alphanumeric character

Popis

bool ctype_punct ( string $text )

Checks if all of the characters in the provided string, text, are punctuation character.

Seznam parametrů

text

The tested string.

Návratové hodnoty

Returns TRUE if every character in text is printable, but neither letter, digit or blank, FALSE otherwise.

Příklady

Příklad 329. A ctype_punct() example

<?php
$strings = array('ABasdk!@!$#', '!@ # $', '*&$()');
foreach ($strings as $testcase) {
    if (ctype_punct($testcase)) {
        echo "The string $testcase consists of all punctuation.\n";
    } else {
        echo "The string $testcase does not consist of all punctuation.\n";
    }
}
?>

Výše uvedený příklad vypíše:

The string ABasdk!@!$# does not consist of all punctuation.
The string !@ # $ does not consist of all punctuation.
The string *&$() consists of all punctuation.

Viz také

ctype_cntrl()
ctype_graph()

Předcházející | Nahoru | Další
ctype_print | Domů | ctype_space


ctype_space

(PHP 4 >= 4.0.4, PHP 5)

ctype_space — Check for whitespace character(s)

Popis

bool ctype_space ( string $text )

Checks if all of the characters in the provided string, text, creates whitespace.

Seznam parametrů

text

The tested string.

Návratové hodnoty

Returns TRUE if every character in text creates some sort of white space, FALSE otherwise. Besides the blank character this also includes tab, vertical tab, line feed, carriage return and form feed characters.

Příklady

Příklad 330. A ctype_space() example

<?php
$strings = array('string1' => "\n\r\t", 'string2' => "\narf12", 'string3' => '\n\r\t');
foreach ($strings as $name => $testcase) {
    if (ctype_space($testcase)) {
        echo "The string '$name' consists of all whitespace characters.\n";
    } else {
        echo "The string '$name' does not consist of all whitespace characters.\n";
    }
}
?>

Výše uvedený příklad vypíše:

The string 'string1' consists of all whitespace characters.
The string 'string2' does not consist of all whitespace characters.
The string 'string3' does not consist of all whitespace characters.

Viz také

ctype_cntrl()
ctype_graph()
ctype_punct()

Předcházející | Nahoru | Další
ctype_punct | Domů | ctype_upper


ctype_upper

(PHP 4 >= 4.0.4, PHP 5)

ctype_upper — Check for uppercase character(s)

Popis

bool ctype_upper ( string $text )

Checks if all of the characters in the provided string, text, are uppercase characters.

Seznam parametrů

text

The tested string.

Návratové hodnoty

Returns TRUE if every character in text is an uppercase letter in the current locale.

Příklady

Příklad 331. A ctype_upper() example (using the default locale)

<?php
$strings = array('AKLWC139', 'LMNSDO', 'akwSKWsm');
foreach ($strings as $testcase) {
    if (ctype_upper($testcase)) {
        echo "The string $testcase consists of all uppercase letters.\n";
    } else {
        echo "The string $testcase does not consist of all uppercase letters.\n";
    }
}
?>

Výše uvedený příklad vypíše:

The string AKLWC139 does not consist of all uppercase letters.
The string LMNSDO consists of all uppercase letters.
The string akwSKWsm does not consist of all uppercase letters.

Viz také

ctype_alpha()
ctype_lower()
setlocale()

Předcházející | Nahoru | Další
ctype_space | Domů | ctype_xdigit


ctype_xdigit

(PHP 4 >= 4.0.4, PHP 5)

ctype_xdigit — Check for character(s) representing a hexadecimal digit

Popis

bool ctype_xdigit ( string $text )

Checks if all of the characters in the provided string, text, are hexadecimal 'digits'.

Seznam parametrů

text

The tested string.

Návratové hodnoty

Returns TRUE if every character in text is a hexadecimal 'digit', that is a decimal digit or a character from [A-Fa-f] , FALSE otherwise.

Příklady

Příklad 332. A ctype_xdigit() example

<?php
$strings = array('AB10BC99', 'AR1012', 'ab12bc99');
foreach ($strings as $testcase) {
    if (ctype_xdigit($testcase)) {
        echo "The string $testcase consists of all hexadecimal digits.\n";
    } else {
        echo "The string $testcase does not consist of all hexadecimal digits.\n";
    }
}
?>

Výše uvedený příklad vypíše:

The string AB10BC99 consists of all hexadecimal digits.
The string AR1012 does not consist of all hexadecimal digits.
The string ab12bc99 consists of all hexadecimal digits.

Viz také

ctype_digit()

Předcházející | Nahoru | Další
ctype_upper | Domů | XIX. Funkce pro práci s CURL, Client URL Library


Database (dbm-style) Abstraction Layer Functions

Předcházející VI. Reference funkcí Další

XXV. Database (dbm-style) Abstraction Layer Functions

Úvod

These functions build the foundation for accessing Berkeley DB style databases.

This is a general abstraction layer for several file-based databases. As such, functionality is limited to a common subset of features supported by modern databases such as » Sleepycat Software's DB2. (This is not to be confused with IBM's DB2 software, which is supported through the ODBC functions.)

Požadavky

The behaviour of various aspects depends on the implementation of the underlying database. Functions such as dba_optimize() and dba_sync() will do what they promise for one database and will do nothing for others. You have to download and install supported dba-Handlers.

Tabulka 40. List of DBA handlers

Handler | Notes
dbm | Dbm is the oldest (original) type of Berkeley DB style databases. You should avoid it, if possible. We do not support the compatibility functions built into DB2 and gdbm, because they are only compatible on the source code level, but cannot handle the original dbm format.
ndbm | Ndbm is a newer type and more flexible than dbm. It still has most of the arbitrary limits of dbm (therefore it is deprecated).
gdbm | Gdbm is the » GNU database manager.
db2 | DB2 is » Sleepycat Software's DB2. It is described as "a programmatic toolkit that provides high-performance built-in database support for both standalone and client/server applications.
db3 | DB3 is » Sleepycat Software's DB3.
db4 | DB4 is » Sleepycat Software's DB4. This is available since PHP 4.3.2.
cdb | Cdb is "a fast, reliable, lightweight package for creating and reading constant databases." It is from the author of qmail and can be found at » http://cr.yp.to/cdb.html. Since it is constant, we support only reading operations. And since PHP 4.3.0 we support writing (not updating) through the internal cdb library.
cdb_make | Since PHP 4.3.0 we support creation (not updating) of cdb files when the bundled cdb library is used.
flatfile | This is available since PHP 4.3.0 for compatibility with the deprecated dbm extension only and should be avoided. However you may use this where files were created in this format. That happens when configure could not find any external library.
inifile | This is available since PHP 4.3.3 to be able to modify php.ini files from within PHP scripts. When working with ini files you can pass arrays of the form array(0=>group,1=>value_name) or strings of the form "[group]value_name" where group is optional. As the functions dba_firstkey() and dba_nextkey() return string representations of the key there is a new function dba_key_split() available since PHP 5 which allows to convert the string keys into array keys without loosing FALSE.
qdbm | This is available since PHP 5.0.0. The qdbm library can be loaded from » http://qdbm.sourceforge.net.

When invoking the dba_open() or dba_popen() functions, one of the handler names must be supplied as an argument. The actually available list of handlers is displayed by invoking phpinfo() or dba_handlers().

Instalace

By using the --enable-dba=shared configuration option you can build a dynamic loadable module to enable PHP for basic support of dbm-style databases. You also have to add support for at least one of the following handlers by specifying the --with-XXXX configure switch to your PHP configure line.

Varování

After configuring and compiling PHP you must execute the following test from commandline: php run-tests.php ext/dba. This shows whether your combination of handlers works. Most problematic are dbm and ndbm which conflict with many installations. The reason for this is that on several systems these libraries are part of more than one other library. The configuration test only prevents you from configuring malfunctioning single handlers but not combinations.

Tabulka 41. Supported DBA handlers

Handler | Configure Switch
dbm

To enable support for dbm add --with-dbm[=DIR].

Poznámka: dbm normally is a wrapper which often results in failures. This means you should only use dbm if you are sure it works and if you really need this format.

ndbm

To enable support for ndbm add --with-ndbm[=DIR].

Poznámka: ndbm normally is a wrapper which often results in failures. This means you should only use ndbm if you are sure it works and if you really need this format.

gdbm | To enable support for gdbm add --with-gdbm[=DIR].
db2

To enable support for db2 add --with-db2[=DIR].

Poznámka: db2 conflicts with db3 and db4.

db3

To enable support for db3 add --with-db3[=DIR].

Poznámka: db3 conflicts with db2 and db4.

db4

To enable support for db4 add --with-db4[=DIR].

Poznámka: db4 conflicts with db2 and db3.

Poznámka: This was added in PHP 4.3.2. In earlier versions of PHP you need to use --with-db3=DIR with DIR being the path to db4 library. It is not possible to use db versions starting from 4.1 with PHP prior to version 4.3.0. Also, the db libraries with versions 4.1 through 4.1.24 cannot be used in any PHP version.

cdb

To enable support for cdb add --with-cdb[=DIR].

Poznámka: Since PHP 4.3.0 you can omit DIR to use the bundled cdb library that adds the cdb_make handler which allows creation of cdb files and allows to access cdb files on the network using PHP's streams.

flatfile

To enable support for flatfile add --with-flatfile.

Poznámka: This was added in PHP 4.3.0 to add compatibility with deprecated dbm extension. Use this handler only when you cannot install one of the libraries required by the other handlers and when you cannot use bundled cdb handler.

inifile

To enable support for inifile add --with-inifile.

Poznámka: This was added in PHP 5.0.0 and allows to read and set microsoft style .ini files (like the php.ini file).

qdbm

To enable support for qdbm add --with-qdbm[=DIR].

Poznámka: qdbm conflicts with dbm and gdbm.

Poznámka: This was added in PHP 5.0.0. The qdbm library can be loaded from » http://qdbm.sourceforge.net.

Poznámka: Up to PHP 4.3.0 you are able to add both db2 and db3 handler but only one of them can be used internally. That means that you cannot have both file formats. Starting with PHP 5.0.0 there is a configuration check avoid such misconfigurations.

Konfigurace běhu

Toto rozšíření nemá definováno žádné konfigurační direktivy.

Typy prostředků

The functions dba_open() and dba_popen() return a handle to the specified database file to access which is used by all other dba-function calls.

Předdefinované konstanty

Toto rozšíření nemá definovány žádné konstanty.

Příklady

Příklad 369. DBA example

<?php

$id = dba_open("/tmp/test.db", "n", "db2");

if (!$id) {
    echo "dba_open failed\n";
    exit;
}

dba_replace("key", "This is an example!", $id);

if (dba_exists("key", $id)) {
    echo dba_fetch("key", $id);
    dba_delete("key", $id);
}

dba_close($id);
?>

DBA is binary safe and does not have any arbitrary limits. However, it inherits all limits set by the underlying database implementation.

All file-based databases must provide a way of setting the file mode of a new created database, if that is possible at all. The file mode is commonly passed as the fourth argument to dba_open() or dba_popen().

You can access all entries of a database in a linear way by using the dba_firstkey() and dba_nextkey() functions. You may not change the database while traversing it.

Příklad 370. Traversing a database

<?php

// ...open database...

$key = dba_firstkey($id);

while ($key != false) {
    if (true) {          // remember the key to perform some action later
        $handle_later[] = $key;
    }
    $key = dba_nextkey($id);
}

foreach ($handle_later as $val) {
    dba_delete($val, $id);
}

?>

Obsah

dba_close — Close a DBA database
dba_delete — Delete DBA entry specified by key
dba_exists — Check whether key exists
dba_fetch — Fetch data specified by key
dba_firstkey — Fetch first key
dba_handlers — List all the handlers available
dba_insert — Insert entry
dba_key_split — Splits a key in string representation into array representation
dba_list — List all open database files
dba_nextkey — Fetch next key
dba_open — Open database
dba_optimize — Optimize database
dba_popen — Open database persistently
dba_replace — Replace or insert entry
dba_sync — Synchronize database
Předcházející | Nahoru | Další
dbplus_xunlockrel | Domů | dba_close


dba_close

(PHP 4, PHP 5)

dba_close — Close a DBA database

Popis

void dba_close ( resource $handle )

dba_close() closes the established database and frees all resources of the specified database handle.

Seznam parametrů

handle

The database handler, returned by dba_open() or dba_popen().

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

dba_open()
dba_popen()

Předcházející | Nahoru | Další
XXV. Database (dbm-style) Abstraction Layer Functions | Domů | dba_delete


dba_delete

(PHP 4, PHP 5)

dba_delete — Delete DBA entry specified by key

Popis

bool dba_delete ( string $key, resource $handle )

dba_delete() deletes the specified entry from the database.

Seznam parametrů

key

The key of the entry which is deleted.

handle

The database handler, returned by dba_open() or dba_popen().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

dba_exists()
dba_fetch()
dba_insert()
dba_replace()

Předcházející | Nahoru | Další
dba_close | Domů | dba_exists


dba_exists

(PHP 4, PHP 5)

dba_exists — Check whether key exists

Popis

bool dba_exists ( string $key, resource $handle )

dba_exists() checks whether the specified key exists in the database.

Seznam parametrů

key

The key the check is performed for.

handle

The database handler, returned by dba_open() or dba_popen().

Návratové hodnoty

Returns TRUE if the key exists, FALSE otherwise.

Viz také

dba_delete()
dba_fetch()
dba_insert()
dba_replace()

Předcházející | Nahoru | Další
dba_delete | Domů | dba_fetch


dba_fetch

(PHP 4, PHP 5)

dba_fetch — Fetch data specified by key

Popis

string dba_fetch ( string $key, resource $handle )
string dba_fetch ( string $key, int $skip, resource $handle )

dba_fetch() fetches the data specified by key from the database specified with handle.

Seznam parametrů

key

The key the data is specified by.

Poznámka: When working with inifiles this function accepts arrays as keys where index 0 is the group and index 1 is the value name. See: dba_key_split().

skip

The number of key-value pairs to ignore when using cdb databases. This value is ignored for all other databases which do not support multiple keys with the same name.

handle

The database handler, returned by dba_open() or dba_popen().

Návratové hodnoty

Returns the associated string if the key/data pair is found, FALSE otherwise.

ChangeLog (záznam změn)

Verze | Popis
4.3 | The skip parameter is available to support cdb's capability of multiple keys having the same name.

Viz také

dba_exists()
dba_delete()
dba_insert()
dba_replace()
dba_key_split()

Předcházející | Nahoru | Další
dba_exists | Domů | dba_firstkey


dba_firstkey

(PHP 4, PHP 5)

dba_firstkey — Fetch first key

Popis

string dba_firstkey ( resource $handle )

dba_firstkey() returns the first key of the database and resets the internal key pointer. This permits a linear search through the whole database.

Seznam parametrů

handle

The database handler, returned by dba_open() or dba_popen().

Návratové hodnoty

Returns the key on success, or FALSE on failure.

Viz také

dba_nextkey()
dba_key_split()
Example 2 in the DBA examples

Předcházející | Nahoru | Další
dba_fetch | Domů | dba_handlers


dba_handlers

(PHP 4 >= 4.3.0, PHP 5)

dba_handlers — List all the handlers available

Popis

array dba_handlers ( [bool $full_info] )

dba_handlers() list all the handlers supported by this extension.

Seznam parametrů

full_info

Turns on/off full information display in the result. The default is FALSE.

Návratové hodnoty

Returns an array of database handlers. If full_info is set to TRUE, the array will be associative with the handlers names as keys, and their version information as value. Otherwise, the result will be an indexed array of handlers names.

Poznámka: When the internal cdb library is used you will see cdb and cdb_make.

Příklady

Příklad 371. dba_handlers() Example

<?php

echo "Available DBA handlers:\n";
foreach (dba_handlers(true) as $handler_name => $handler_version) {
  // clean the versions
  $handler_version = str_replace('$', '', $handler_version);
  echo " - $handler_name: $handler_version\n";
}

?>

Výše uvedený příklad vypíše něco jako:

Available DBA handlers:
 - cdb: 0.75, Revision: 1.3.2.3
 - cdb_make: 0.75, Revision: 1.2.2.4
 - db2: Sleepycat Software: Berkeley DB 2.7.7: (08/20/99)
 - inifile: 1.0, Revision: 1.6.2.3
 - flatfile: 1.0, Revision: 1.5.2.4

Předcházející | Nahoru | Další
dba_firstkey | Domů | dba_insert


dba_insert

(PHP 4, PHP 5)

dba_insert — Insert entry

Popis

bool dba_insert ( string $key, string $value, resource $handle )

dba_insert() inserts the entry described with key and value into the database.

Seznam parametrů

key

The key of the entry to be inserted. If this key already exist in the database, this function will fail. Use dba_replace() if you need to replace an existent key.

value

The value to be inserted.

handle

The database handler, returned by dba_open() or dba_popen().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

dba_exists()
dba_delete()
dba_fetch()
dba_replace()

Předcházející | Nahoru | Další
dba_handlers | Domů | dba_key_split


dba_key_split

(PHP 5)

dba_key_split — Splits a key in string representation into array representation

Popis

mixed dba_key_split ( mixed $key )

dba_key_split() splits a key (string representation) into an array representation.

Seznam parametrů

key

The key in string representation.

Návratové hodnoty

Returns an array of the form array(0 => group, 1 => value_name). This function will return FALSE if key is NULL or FALSE.

Viz také

dba_firstkey()
dba_nextkey()
dba_fetch()

Předcházející | Nahoru | Další
dba_insert | Domů | dba_list


dba_list

(PHP 4 >= 4.3.0, PHP 5)

dba_list — List all open database files

Popis

array dba_list ( void )

dba_list() list all open database files.

Návratové hodnoty

An associative array, in the form resourceid => filename.

Předcházející | Nahoru | Další
dba_key_split | Domů | dba_nextkey


dba_nextkey

(PHP 4, PHP 5)

dba_nextkey — Fetch next key

Popis

string dba_nextkey ( resource $handle )

dba_nextkey() returns the next key of the database and advances the internal key pointer.

Seznam parametrů

handle

The database handler, returned by dba_open() or dba_popen().

Návratové hodnoty

Returns the key on success, or FALSE on failure.

Viz také

dba_firstkey()
dba_key_split()
Example 2 in the DBA examples

Předcházející | Nahoru | Další
dba_list | Domů | dba_open


dba_open

(PHP 4, PHP 5)

dba_open — Open database

Popis

resource dba_open ( string $path, string $mode [, string $handler [, mixed $...]] )

dba_open() establishes a database instance for path with mode using handler.

Seznam parametrů

path

Commonly a regular path in your filesystem.

mode

It is r for read access, w for read/write access to an already existing database, c for read/write access and database creation if it doesn't currently exist, and n for create, truncate and read/write access.

Additionally you can set the database lock method with the next char. Use l to lock the database with a .lck file or d to lock the databasefile itself. It is important that all of your applications do this consistently.

If you want to test the access and do not want to wait for the lock you can add t as third character. When you are absolutely sure that you do not require database locking you can do so by using - instead of l or d. When none of d, l or - is used, dba will lock on the database file as it would with d.

Poznámka: There can only be one writer for one database file. When you use dba on a web server and more than one request requires write operations they can only be done one after another. Also read during write is not allowed. The dba extension uses locks to prevent this. See the following table:

Tabulka 42. DBA locking

already open | mode = "rl" | mode = "rlt" | mode = "wl" | mode = "wlt" | mode = "rd" | mode = "rdt" | mode = "wd" | mode = "wdt"
not open | ok | ok | ok | ok | ok | ok | ok | ok
mode = "rl" | ok | ok | wait | false | illegal | illegal | illegal | illegal
mode = "wl" | wait | false | wait | false | illegal | illegal | illegal | illegal
mode = "rd" | illegal | illegal | illegal | illegal | ok | ok | wait | false
mode = "wd" | illegal | illegal | illegal | illegal | wait | false | wait | false

ok: the second call will be successfull.
wait: the second call waits until dba_close() is called for the first.
false: the second call returns false.
illegal: you must not mix "l" and "d" modifiers for mode parameter.

handler

The name of the handler which shall be used for accessing path. It is passed all optional parameters given to dba_open() and can act on behalf of them.

Návratové hodnoty

Returns a positive handle on success, or FALSE on failure.

ChangeLog (záznam změn)

Verze | Popis
4.3.0 | It's possible to open database files over network connection. However in cases a socket connection will be used (as with http or ftp) the connection will be locked instead of the resource itself. This is important to know since in such cases locking is simply ignored on the resource and other solutions have to be found.
4.3.0 | Locking and the mode modifiers "l", "d", "-" and "t" were added. In previous PHP versions, you must use semaphores to guard against simultaneous database access for any database handler with the exception of GDBM. See System V semaphore support.
before 4.3.5 | open mode 'c' is broken for several internal handlers and truncates the database instead of appending data to an existent database. Also dbm and ndbm fail on mode 'c' in typical configurations (this cannot be fixed).

Viz také

dba_popen()
dba_close()

Předcházející | Nahoru | Další
dba_nextkey | Domů | dba_optimize


dba_optimize

(PHP 4, PHP 5)

dba_optimize — Optimize database

Popis

bool dba_optimize ( resource $handle )

dba_optimize() optimizes the underlying database.

Seznam parametrů

handle

The database handler, returned by dba_open() or dba_popen().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

dba_sync()

Předcházející | Nahoru | Další
dba_open | Domů | dba_popen


dba_popen

(PHP 4, PHP 5)

dba_popen — Open database persistently

Popis

resource dba_popen ( string $path, string $mode [, string $handler [, mixed $...]] )

dba_popen() establishes a persistent database instance for path with mode using handler.

Seznam parametrů

path

Commonly a regular path in your filesystem.

mode

It is r for read access, w for read/write access to an already existing database, c for read/write access and database creation if it doesn't currently exist, and n for create, truncate and read/write access.

handler

The name of the handler which shall be used for accessing path. It is passed all optional parameters given to dba_popen() and can act on behalf of them.

Návratové hodnoty

Returns a positive handle on success, or FALSE on failure.

Viz také

dba_open()
dba_close()

Předcházející | Nahoru | Další
dba_optimize | Domů | dba_replace


dba_replace

(PHP 4, PHP 5)

dba_replace — Replace or insert entry

Popis

bool dba_replace ( string $key, string $value, resource $handle )

dba_replace() replaces or inserts the entry described with key and value into the database specified by handle.

Seznam parametrů

key

The key of the entry to be replaced.

value

The value to be replaced.

handle

The database handler, returned by dba_open() or dba_popen().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

dba_exists()
dba_delete()
dba_fetch()
dba_insert()

Předcházející | Nahoru | Další
dba_popen | Domů | dba_sync


dba_sync

(PHP 4, PHP 5)

dba_sync — Synchronize database

Popis

bool dba_sync ( resource $handle )

dba_sync() synchronizes the database. This will probably trigger a physical write to the disk, if supported.

Seznam parametrů

handle

The database handler, returned by dba_open() or dba_popen().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

dba_optimize()

Předcházející | Nahoru | Další
dba_replace | Domů | XXVI. dBase Functions


Funkce pro datum a čas

Předcházející VI. Reference funkcí Další

XXIII. Funkce pro datum a čas

Úvod

Tyto funkce vám umožňují získat datum a čas ze serveru, na kterém běží PHP skripty. Lze je použít k formátování zápisu času a data mnoha různými způsoby.

Poznámka: Uvědomte si prosím, že tyto funkce závisí na národním nastavení vašeho serveru. Zvláštní pozornost věnujte letnímu času a přestupným rokům!

Požadavky

Tyto funkce jsou k dispozici jako součást standardního modulu, který je vždy dostupný.

Instalace

K používání těchto funkcí není třeba žádná instalace, jsou součástí jádra PHP.

Konfigurace běhu

Chování těchto funkcí je ovlivněno nastavením parametrů v php.ini.

Tabulka 32. Date/Time Configuration Options

Name | Default | Changeable | Changelog
date.default_latitude | "31.7667" | PHP_INI_ALL | Available since PHP 5.0.0.
date.default_longitude | "35.2333" | PHP_INI_ALL | Available since PHP 5.0.0.
date.sunrise_zenith | "90.583333" | PHP_INI_ALL | Available since PHP 5.0.0.
date.sunset_zenith | "90.583333" | PHP_INI_ALL | Available since PHP 5.0.0.
date.timezone | "" | PHP_INI_ALL | Available since PHP 5.1.0.

Pro další detaily a definice konstant PHP_INI_*, viz dokumentace k ini_set().

Zde je stručný popis konfiguračních direktiv.

date.default_latitude float

The default latitude.

date.default_longitude float

The default longitude.

date.sunrise_zenith float

The default sunrise zenith.

date.sunset_zenith float

The default sunset zenith.

date.timezone string

The default timezone used by all date/time functions if the TZ environment variable isn't set. The precedence order is described in the date_default_timezone_get() page. See J – „List of Supported Timezones“ for a list of supported timezones.

Poznámka: The first four configuration options are currently only used by date_sunrise() and date_sunset().

Typy prostředků

Toto rozšíření nemá definován žádný typ prostředku (resource).

Předdefinované konstanty

The following constants are defined since PHP 5.1.1 and they offer standard date representations, which can be used along with the date format functions (like date()).

DATE_ATOM (string)
Atom (example: 2005-08-15T15:52:01+00:00)
DATE_COOKIE (string)
HTTP Cookies (example: Monday, 15-Aug-05 15:52:01 UTC)
DATE_ISO8601 (string)
ISO-8601 (example: 2005-08-15T15:52:01+0000)
DATE_RFC822 (string)
RFC 822 (example: Mon, 15 Aug 05 15:52:01 +0000)
DATE_RFC850 (string)
RFC 850 (example: Monday, 15-Aug-05 15:52:01 UTC)
DATE_RFC1036 (string)
RFC 1036 (example: Mon, 15 Aug 05 15:52:01 +0000)
DATE_RFC1123 (string)
RFC 1123 (example: Mon, 15 Aug 2005 15:52:01 +0000)
DATE_RFC2822 (string)
RFC 2822 (Mon, 15 Aug 2005 15:52:01 +0000)
DATE_RFC3339 (string)
Same as DATE_ATOM (since PHP 5.1.3)
DATE_RSS (string)
RSS (Mon, 15 Aug 2005 15:52:01 +0000)
DATE_W3C (string)
World Wide Web Consortium (example: 2005-08-15T15:52:01+00:00)

Following constants exists since PHP 5.1.2 and specify a format returned by functions date_sunrise() and date_sunset().

SUNFUNCS_RET_TIMESTAMP (integer)
Timestamp
SUNFUNCS_RET_STRING (integer)
Hours:minutes (example: 08:02)
SUNFUNCS_RET_DOUBLE (integer)
Hours as floating point number (example 8.75)

Obsah

checkdate — Zkontroluje gregoriánské datum
date_create — Returns new DateTime object
date_date_set — Sets the date
date_default_timezone_get — Gets the default timezone used by all date/time functions in a script
date_default_timezone_set — Sets the default timezone used by all date/time functions in a script
date_format — Returns date formatted according to given format
date_isodate_set — Sets the ISO date
date_modify — Alters the timestamp
date_offset_get — Returns the daylight saving time offset
date_parse — Returns associative array with detailed info about given date
date_sun_info — Returns an array with information about sunset/sunrise and twilight begin/end
date_sunrise — Returns time of sunrise for a given day and location
date_sunset — Returns time of sunset for a given day and location
date_time_set — Sets the time
date_timezone_get — Return time zone relative to given DateTime
date_timezone_set — Sets the time zone for the DateTime object
date — Formátuje místní datum/čas
getdate — Vrací informaci o datu/čase
gettimeofday — Vrací aktuální čas
gmdate — Formátuje datum/čas GMT/UTC
gmmktime — Vrací UNIXové časové razítko pro datum/čas v GMT
gmstrftime — Formátuje datum/čas v GMT/UTC vzhledem k národnímu nastavení
idate — Format a local time/date as integer
localtime — Vrací místní čas
microtime — Vrací aktuální UNIXové časové razítko s mikrosekundami
mktime — Vrací UNIXové časové razítko pro datum/čas
strftime — Formátuje místní čas/datum s ohledem na nastavení národních specifik
strptime — Parse a time/date generated with strftime()
strtotime — Parse about any English textual datetime description into a Unix timestamp
time — Return current Unix timestamp
timezone_abbreviations_list — Returns associative array containing dst, offset and the timezone name
timezone_identifiers_list — Returns numerically index array with all timezone identifiers
timezone_name_from_abbr — Returns the timezone name from abbrevation
timezone_name_get — Returns the name of the timezone
timezone_offset_get — Returns the timezone offset from GMT
timezone_open — Returns new DateTimeZone object
timezone_transitions_get — Returns all transitions for the timezone
Předcházející | Nahoru | Další
cyrus_unbind | Domů | checkdate


checkdate

(PHP 4, PHP 5)

checkdate — Zkontroluje gregoriánské datum

Popis

bool checkdate ( int $month, int $day, int $year )

Vrací TRUE, je-li dané datum platné; v ostatních případech FALSE. Platnost se ověřuje u data složeného z hodnot v argumentech. Datum je ohodnoceno jako platné, pokud:

  • rok je mezi 1 a 32767 včetně
  • měsíc je mezi 1 a 12 včetně
  • Den day je v mezích povoleného počtu dnů pro daný měsíc month. Přestupné roky jsou brány v úvahu.

Viz také mktime() a strtotime().

Předcházející | Nahoru | Další
XXIII. Funkce pro datum a čas | Domů | date_create


date_sunrise

(PHP 5)

date_sunrise — Returns time of sunrise for a given day and location

Popis

mixed date_sunrise ( int $timestamp [, int $format [, float $latitude [, float $longitude [, float $zenith [, float $gmt_offset]]]]] )

date_sunrise() returns the sunrise time for a given day (specified as a timestamp) and location.

Seznam parametrů

timestamp

The timestamp of the day from which the sunrise time is taken.

format

Tabulka 33. format constants

constant | description | example
SUNFUNCS_RET_STRING | returns the result as string | 16:46
SUNFUNCS_RET_DOUBLE | returns the result as float | 16.78243132
SUNFUNCS_RET_TIMESTAMP | returns the result as integer (timestamp) | 1095034606

latitude

Defaults to North, pass in a negative value for South. See also: date.default_latitude

longitude

Defaults to East, pass in a negative value for West. See also: date.default_longitude

zenith

Default: date.sunrise_zenith

gmtoffset

Specified in hours.

Návratové hodnoty

Returns the sunrise time in a specified format on success, or FALSE on failure.

Errors/Exceptions

Every call to a date/time function will generate a E_NOTICE if the time zone is not valid, and/or a E_STRICT message if using the system settings or the TZ environment variable. See also date_default_timezone_set()

ChangeLog (záznam změn)

Verze | Popis
5.1.0 | Now issues the E_STRICT and E_NOTICE time zone errors.

Příklady

Příklad 345. date_sunrise() example

<?php

/* calculate the sunrise time for Lisbon, Portugal
Latitude: 38.4 North
Longitude: 9 West
Zenith ~= 90
offset: +1 GMT
*/

echo date("D M d Y"). ', sunrise time : ' .date_sunrise(time(), SUNFUNCS_RET_STRING, 38.4, -9, 90, 1);

?>

Výše uvedený příklad vypíše něco jako:

Mon Dec 20 2004, sunrise time : 08:54

Viz také

date_sunset()

Předcházející | Nahoru | Další
date_sun_info | Domů | date_sunset


date_sunset

(PHP 5)

date_sunset — Returns time of sunset for a given day and location

Popis

mixed date_sunset ( int $timestamp [, int $format [, float $latitude [, float $longitude [, float $zenith [, float $gmt_offset]]]]] )

date_sunset() returns the sunset time for a given day (specified as a timestamp) and location.

Seznam parametrů

timestamp

The timestamp of the day from which the sunset time is taken.

format

Tabulka 34. format constants

constant | description | example
SUNFUNCS_RET_STRING | returns the result as string | 16:46
SUNFUNCS_RET_DOUBLE | returns the result as float | 16.78243132
SUNFUNCS_RET_TIMESTAMP | returns the result as integer (timestamp) | 1095034606

latitude

Defaults to North, pass in a negative value for South. See also: date.default_latitude

longitude

Defaults to East, pass in a negative value for West. See also: date.default_longitude

zenith

Default: date.sunrise_zenith

gmtoffset

Specified in hours.

Errors/Exceptions

Every call to a date/time function will generate a E_NOTICE if the time zone is not valid, and/or a E_STRICT message if using the system settings or the TZ environment variable. See also date_default_timezone_set()

ChangeLog (záznam změn)

Verze | Popis
5.1.0 | Now issues the E_STRICT and E_NOTICE time zone errors.

Návratové hodnoty

Returns the sunset time in a specified format on success, or FALSE on failure.

Příklady

Příklad 346. date_sunset() example

<?php

/* calculate the sunset time for Lisbon, Portugal
Latitude: 38.4 North
Longitude: 9 West
Zenith ~= 90
offset: +1 GMT
*/

echo date("D M d Y"). ', sunset time : ' .date_sunset(time(), SUNFUNCS_RET_STRING, 38.4, -9, 90, 1);

?>

Výše uvedený příklad vypíše něco jako:

Mon Dec 20 2004, sunset time : 18:13

Viz také

date_sunrise()

Předcházející | Nahoru | Další
date_sunrise | Domů | date_time_set


date

(PHP 4, PHP 5)

date — Formátuje místní datum/čas

Popis

string date ( string $format [, int $timestamp ] )

Vrací řetězec formátovaný podle daného formátovacího řetězce s použitím daného celočíselného časového razítka timestamp nebo aktuálního místního času (není-li časové razítko zadáno). Jinými slovy, parametr timestamp je nepovinný a jeho výchozí hodnota je výsledek funkce time().

Poznámka: Platný rozsah pro časové razítko je typicky od pátku 13.12.1901 20:45:54 GMT do úterý 19.1.2038 03:14:07 GMT. (Tyto hodnoty odpovídají minimální a maximální hodnotě 32-bitového celého čísla se znaménkem). Na Windows je tento rozsah omezen na období 1.1.1970 až 19.1.2038.

K vygenerování časového razítka z řetězce reprezentujícího datum lze použít funkci strtotime(). Navíc některé databáze mají funkce, které konvertují jejich datové formáty na časová razítka (např. funce » UNIX_TIMESTAMP v MySQL).

Tabulka 35. Ve formátovacím řetězci lze používat tyto znaky:

znak parametru format | Popis | Ukázka vracených hodnot
a | Příznak dopoledne/odpoledne malými písmeny | am nebo pm
A | Příznak dopoledne/odpoledne velkými písmeny | AM nebo PM
B | Internetový čas Swatch | 000 až 999
d | Den měsíce, dvě číslice s úvodními nulami | 01 až 31
D | Textová reprezentace dne, tři znaky | Mon až Sun
F | Plná textová reprezentace měsíce typu January nebo March | January až December
g | 12-hodinový formát hodiny bez úvodních nul | 1 až 12
G | 24-hodinový formát hodiny bez úvodních nul | 0 až 23
h | 12-hodinový formát hodiny s úvodními nulami | 01 až 12
H | 24-hodinový formát hodiny s úvodními nulami | 00 až 23
i | Minuty s úvodními nulami | 00 až 59
I (velké i) | Zjištění, zda je letní čas | 1 pokud je letní čas, 0 jinak.
j | Den měsíce bez úvodních nul | 1 až 31
l (malé 'L') | Plná textová reprezentace dne v týdnu | Sunday až Saturday
L | Zjištění, zda je rok přestupný | 1 pokud je přestupný rok, 0 jinak.
m | Číselná reprezentace měsíce s úvodními nulami | 01 až 12
M | Krátká textová reprezentace měsíce, tři znaky | Jan až Dec
n | Číselná reprezentace měsíce bez úvodních nul | 1 až 12
O | Odchylka od Greenwichského času (GMT) v hodinách | Příklad: +0200
r | Datum formátované podle RFC 822 | Příklad: Thu, 21 Dec 2000 16:01:07 +0200
s | Sekundy s úvodními nulami | 00 až 59
S | Anglická pořadová přípona dne v měsíci, 2 znaky | st, nd, rd nebo th. Dobře funguje s j
t | Počet dní v daném měsíci | 28 až 31
T | Nastavení časového pásma na tomto počítači | Příklady: EST, MDT ...
U | Sekundy od počátku éry Unix (1. ledna 1970 00:00:00 GMT) | Viz také time()
w | Číselná reprezentace dne v týdnu | 0 (pro neděli) až 6 (pro sobotu)
W | Číslo týdne podle ISO-8601, týdny začínají v pondělí (doplněno v PHP 4.1.0) | Příklad: 42 (42. týden v roce)
Y | Plná číselná reprezentace roku, 4 číslice | Příklady: 1999 nebo 2003
y | Dvouciferná reprezentace roku | Příklady: 99 nebo 03
z | Den v roce | 0 až 365
Z | Posun časového pásma v sekundách. Posun časových pásem západně od UTC je vždy záporný, východně od UTC je vždy kladný. | -43200 až 43200

Nerozpoznané znaky ve formátovacím řetězci se vytiskou tak, jak jsou. Při použití gmdate() má formát Z vždy hodnotu 0.

Příklad 347. Příklady - date()

<?php
// Vytiskne něco jako: Wednesday
echo date("l");

// Vytiskne něco jako: Wednesday 15th of January 2003 05:51:38 AM
echo date ("l dS of F Y h:i:s A");

// Vytiskne: July 1, 2000 is on a Saturday
echo "July 1, 2000 is on a " . date ("l", mktime(0,0,0,7,1,2000));
?>

Rozpoznávané znaky ve formátovacím řetězci můžete ochránit před zpracováním tak, že jim předřadíte obrácené lomítko. Pokud už má znak s obráceným lomítkem speciální význam, je třeba před něj přidat ještě jedno obrácené lomítko.

Příklad 348. Ochrana znaků ve funkci date()

<?php
// vytiskne něco jako 'Saturday the 8th'
echo date("l \\t\h\e jS");
?>

Je možné použít společně date() a mktime() k nalezení dat v budoucnosti či v minulosti.

Příklad 349. Příklad - date() a mktime()

<?php
$tomorrow  = mktime (0,0,0,date("m")  ,date("d")+1,date("Y"));
$lastmonth = mktime (0,0,0,date("m")-1,date("d"),  date("Y"));
$nextyear  = mktime (0,0,0,date("m"),  date("d"),  date("Y")+1);
?>

Poznámka: Toto může být spolehlivější než prosté přičítání nebo odčítání sekund ve dni nebo měsíci (kvůli letnímu času).

Několik příkladů formátování pomocí date(). Nezapomeňte, že byste měli předřadit obrácené lomítko všem ostatním znakům, protože ty, které mají nyní speciální význam, budou způsobovat neočekávané výsledky, a ostatním může být přiřazen význam v budoucích verzích PHP. Ve všech takových případech také musíte používat apostrofy (k ohraničení řetězce), abyste zabránili znakům jako \n v odřádkování.

Příklad 350. Formátování pomocí date()

<?php
// Předpokládejme, že dnes je 10. března 2001, 17:16:18
$today = date("F j, Y, g:i a");                 // March 10, 2001, 5:16 pm
$today = date("m.d.y");                         // 03.10.01
$today = date("j, n, Y");                       // 10, 3, 2001
$today = date("Ymd");                           // 20010310
$today = date('h-i-s, j-m-y, it is w Day z ');  // 05-16-17, 10-03-01, 1631 1618 6 Fripm01
$today = date('\i\t \i\s \t\h\e jS \d\a\y.');   // It is the 10th day.
$today = date("D M j G:i:s T Y");               // Sat Mar 10 15:16:08 MST 2001
$today = date('H:m:s \m \i\s\ \m\o\n\t\h');     // 17:03:17 m is month
$today = date("H:i:s");                         // 17:16:17
?>

Pro formátování dat v jiných jazycích je třeba použít funkce setlocale() a strftime().

Viz také getlastmod(), gmdate(),
mktime(), strftime()
a time().

Předcházející | Nahoru | Další
date_timezone_set | Domů | getdate


getdate

(PHP 4, PHP 5)

getdate — Vrací informaci o datu/čase

Popis

array getdate ( [int $timestamp] )

Vrací asociativní pole obsahující informaci o datu (čase) v argumentu timestamp nebo aktuální místní čas (pokud není argument přítomen), jako tyto elementy:

Tabulka 36. Klíče vráceného asociativního pole

Klíč | Popis | Ukázka vracených hodnot
"seconds" | Číselná reprezentace sekund | 0 až 59
"minutes" | Číselná reprezentace minut | 0 až 59
"hours" | Číselná reprezentace hodin | 0 až 23
"mday" | Číselná reprezentace dne v měsíci | 1 až 31
"wday" | Číselná reprezentace dne v týdnu | 0 (pro neděli) až 6 (pro sobotu)
"mon" | Číselná reprezentace měsíce | 1 až 12
"year" | Plná číselná reprezentace roku, 4 číslice | Příklady: 1999 nebo 2003
"yday" | Číselná reprezentace dne v roce | 0 až 366
"weekday" | Plná textová reprezentace dne v týdnu | Sunday až Saturday
"month" | Plná textová reprezentace měsíce | January až December
0 | Sekundy éry Unixu, obdobně jako hodnoty vracené funkcí time() a používané funkcí date(). | Závislé na systému, typicky -2147483648 až 2147483647.

Příklad 351. Příklad - getdate()

<?php
$today = getdate();
print_r($today);
?>

Výstup bude vypadat zhruba takto:

Array
(
    [seconds] => 40
    [minutes] => 58
    [hours]   => 21
    [mday]    => 17
    [wday]    => 2
    [mon]     => 6
    [year]    => 2003
    [yday]    => 167
    [weekday] => Tuesday
    [month]   => June
    [0]       => 1055901520
)

Viz také date(),
time() a
setlocale().

Předcházející | Nahoru | Další
date | Domů | gettimeofday


gettimeofday

(PHP 4, PHP 5)

gettimeofday — Vrací aktuální čas

Popis

mixed gettimeofday ( [bool $return_float] )

Toto je rozhraní k volání gettimeofday(2). Vrací asociativní pole obsahující data vrácená tímto systémovým voláním.

  • "sec" - sekundy
  • "usec" - mikrosekundy
  • "minuteswest" - minuty západně od Greenwiche
  • "dsttime" - typ korekce letního času

Předcházející | Nahoru | Další
getdate | Domů | gmdate


gmdate

(PHP 4, PHP 5)

gmdate — Formátuje datum/čas GMT/UTC

Popis

string gmdate ( string $format [, int $timestamp] )

Identické k funkci date() kromě toho, že vrácený čas je Greenwich Mean Time (GMT). Například při spuštění ve Finsku (GMT +0200) vypíše první níže uvedený řádek "Jan 01 1998 00:00:00", zatímco druhý "Dec 31 1997 22:00:00".

Příklad 352. Příklad - gmdate()

<?php
echo date ("M d Y H:i:s", mktime (0,0,0,1,1,1998));
echo gmdate ("M d Y H:i:s", mktime (0,0,0,1,1,1998));
?>

Poznámka: V operačním systému Microsoft Windows jsou systémové knihovny implementující tuto funkci poškozené, takže funkce gmdate() nepodporuje negativní hodnoty parametru timestamp. Blíže viz bug-reporty: » #22620, » #22457 a » #14391.

K tomuto problému nedochází v operačních systémech Unix/Linux, kde se systémové knihovny chovají podle očekávání.

PHP nemá moc opravit poškozené systémové knihovny. Kontaktujte prodejce svého OS, aby tento a podobné problémy opravil.

Viz také date(), mktime(), gmmktime() a strftime().

Předcházející | Nahoru | Další
gettimeofday | Domů | gmmktime


gmmktime

(PHP 4, PHP 5)

gmmktime — Vrací UNIXové časové razítko pro datum/čas v GMT

Popis

int gmmktime ( [int $hour [, int $minute [, int $second [, int $month [, int $day [, int $year [, int $is_dst]]]]]]] )

Identické k mktime(), kromě toho, že parametry reprezentují datum/čas v GMT.

Podobně jako u funkce mktime() mohou být parametry vynechány v pořadí zprava doleva. Neuvedené parametry budou nastaveny na odpovídající hodnotu současného GMT.

Předcházející | Nahoru | Další
gmdate | Domů | gmstrftime


gmstrftime

(PHP 4, PHP 5)

gmstrftime — Formátuje datum/čas v GMT/UTC vzhledem k národnímu nastavení

Popis

string gmstrftime ( string $format [, int $timestamp] )

Chová se stejně jako strftime(), avšak vrácený čas je v Greenwich Mean Time (GMT). Například při spuštění v čase EST (východní standardní čas, GMT -0500) vypíše první níže uvedený řádek "Dec 31 1998 20:00:00", zatímco druhý "Jan 01 1999 01:00:00".

Příklad 353. gmstrftime() example

<?php
setlocale (LC_TIME, 'en_US');
echo strftime ("%b %d %Y %H:%M:%S", mktime (20,0,0,12,31,98))."\n";
echo gmstrftime ("%b %d %Y %H:%M:%S", mktime (20,0,0,12,31,98))."\n";
?>

Viz také strftime().

Předcházející | Nahoru | Další
gmmktime | Domů | idate


idate

(PHP 5)

idate — Format a local time/date as integer

Popis

int idate ( string $format [, int $timestamp] )

Returns a number formatted according to the given format string using the given integer timestamp or the current local time if no timestamp is given. In other words, timestamp is optional and defaults to the value of time().

Unlike the function date(), idate() accepts just one char in the format parameter.

Seznam parametrů

format

Tabulka 37. The following characters are recognized in the format parameter string

format character | Description
B | Swatch Beat/Internet Time
d | Day of the month
h | Hour (12 hour format)
H | Hour (24 hour format)
i | Minutes
I | returns 1 if DST is activated, 0 otherwise
L | returns 1 for leap year, 0 otherwise
m | Month number
s | Seconds
t | Days in current month
U | Seconds since the Unix Epoch - January 1 1970 00:00:00 GMT - this is the same as time()
w | Day of the week (0 on Sunday)
W | ISO-8601 week number of year, weeks starting on Monday
y | Year (1 or 2 digits - check note below)
Y | Year (4 digits)
z | Day of the year
Z | Timezone offset in seconds

timestamp

The optional timestamp parameter is an integer Unix timestamp that defaults to the current local time if a timestamp is not given. In other words, it defaults to the value of time().

Návratové hodnoty

Returns an integer.

As idate() always returns an integer and as they can't start with a "0", idate() may return fewer digits than you would expect. See the example below.

Errors/Exceptions

Every call to a date/time function will generate a E_NOTICE if the time zone is not valid, and/or a E_STRICT message if using the system settings or the TZ environment variable. See also date_default_timezone_set()

ChangeLog (záznam změn)

Verze | Popis
5.1.0 | Now issues the E_STRICT and E_NOTICE time zone errors.

Příklady

Příklad 354. idate() example

<?php
$timestamp = strtotime('1st January 2004'); //1072915200

// this prints the year in a two digit format
// however, as this would start with a "0", it
// only prints "4"
echo idate('y', $timestamp);
?>

Viz také

date()
time()

Předcházející | Nahoru | Další
gmstrftime | Domů | localtime


localtime

(PHP 4, PHP 5)

localtime — Vrací místní čas

Popis

array localtime ( [int $ timestamp [, bool $ is_associative ]] )

Funkce localtime() vrací pole strukturálně identické k návratové hodnotě volání v C. První argument funkce localtime() je časové razítko; není-li dáno, použije se aktuální čas, který vrátí funkce time(). Druhý argument localtime() je is_associative, který (nastavením na nulu) signalizuje, že vracené pole je obyčejné, číselně indexované pole. Je-li argument nastaven na 1, potom localtime() vrací asociativní pole obsahující všechny elementy struktury vrácené příslušným funkčním voláním v C. Názvy klíčů tohoto pole jsou následující:

  • "tm_sec" - sekunda
  • "tm_min" - minuta
  • "tm_hour" - hodina
  • "tm_mday" - den v měsíci
  • "tm_mon" - měsíc v roce, počínaje 0 (leden)
  • "tm_year" - roky od 1900
  • "tm_wday" - den v týdnu
  • "tm_yday" - den v roce
  • "tm_isdst" - platí letní čas

Předcházející | Nahoru | Další
idate | Domů | microtime


microtime

(PHP 4, PHP 5)

microtime — Vrací aktuální UNIXové časové razítko s mikrosekundami

Popis

mixed microtime ( [bool $get_as_float] )

Vrací řetězec "msec sec", kde sec je aktuální čas měřený počtem sekund od Unix Epoch (0:00:00 January 1, 1970 GMT) a msec je mikrosekundová část. Tato funkce je dostupná pouze na operačních systémech, které podporují systémové volání gettimeofday().

Obě části řetězce jsou vráceny v jednotkách sekund.

Příklad 355. Příklad - microtime()

<?php
function getmicrotime(){
    list($usec, $sec) = explode(" ",microtime());
    return ((float)$usec + (float)$sec);
    }

$time_start = getmicrotime();

for ($i=0; $i < 1000; $i++){
    // nic nedělej, 1000krát
    }

$time_end = getmicrotime();
$time = $time_end - $time_start;

echo "Nic se nedělalo $time sekund";
?>

Viz také time().

Předcházející | Nahoru | Další
localtime | Domů | mktime


mktime

(PHP 4, PHP 5)

mktime — Vrací UNIXové časové razítko pro datum/čas

Popis

int mktime ( [int $hour [, int $minute [, int $second [, int $month [, int $day [, int $year [, int $is_dst]]]]]]] )

Varování: Mějte na paměti podivné pořadí argumentů, které se liší od pořadí argumentů v běžném UNIXovém volání mktime() a které se příliš nehodí k vynechávání parametrů zprava doleva (viz níže). Je častou chybou míchat ve skriptu tyto hodnoty.

Vrací UNIXové časové razítko odpovídající daným argumentům. Toto časové razítko je typu "long integer" a odpovídá počtu sekund mezi Unix Epoch (1.1.1970) a specifikovaným časem.

Argumenty mohou být vynechávány zprava doleva; každý vynechaný argument bude nastaven na aktuální hodnotu podle místního data a času.

is_dst může být 1, patří-li daný čas do doby platnosti letního času, 0, pokud nepatří, anebo -1 (implicitní hodnota), nelze-li zjistit, zda daný čas patří do období letního času (v tomto případě se PHP pokusí tuto hodnotu dosadit; to může způsobit neočekávané - ale nikoli chybné - výsledky).

Poznámka: Parametr is_dst byl přidán v PHP 3.0.10.

Funkce mktime() je užitečná pro aritmetiku a validaci časových údajů, neboť automaticky vypočítá správnou hodnotu pro vstupní data mimo povolený rozsah. Například každý z následujících řádků vypíše "Jan-01-1998".

Příklad 356. Příklad - mktime()

<?php
echo date ("M-d-Y", mktime (0,0,0,12,32,1997));
echo date ("M-d-Y", mktime (0,0,0,13,1,1997));
echo date ("M-d-Y", mktime (0,0,0,1,1,1998));
echo date ("M-d-Y", mktime (0,0,0,1,1,98));
?>

Year může být hodnota se dvěma nebo čtyřmi číslicemi, s hodnotami 0-69 mapovanými na 2000-2069 a 70-99 na 1970-1999 (na systémech, kde time_t je 32bitové celé číslo se znaménkem, jak je dnes obvyklé, budou platné hodnoty pro year někde mezi 1901 a 2038).

Windows: Záporné časové značky nejsou podporovány v žádné známé verzi Windows. Platné rozmezí roků je proto pouze 1970 až 2038.

Poslední den daného měsíce může být vyjádřen jako den "0" měsíce příštího, nikoliv den -1. Oba následující příklady vypíší řetězec "The last day in Feb 2000 is: 29".

Příklad 357. Poslední den měsíce

<?php
$lastday = mktime (0,0,0,3,0,2000);
echo strftime ("Last day in Feb 2000 is: %d", $lastday);

$lastday = mktime (0,0,0,4,-31,2000);
echo strftime ("Last day in Feb 2000 is: %d", $lastday);
?>

Datum s rokem, měsícem, a dnem rovnými nule je považováno za neplatné (odpovídalo by 30.11.1999, což je poněkud podivné chování).

Viz také date() a time().

Předcházející | Nahoru | Další
microtime | Domů | strftime


strftime

(PHP 4, PHP 5)

strftime — Formátuje místní čas/datum s ohledem na nastavení národních specifik

Popis

string strftime ( string $format [, int $ timestamp ] )

Vrací řetězec formátovaný podle daného formátovacího řetězce, s použitím daného časového razítka timestamp, nebo aktuálního místního času, není-li razítko dáno. Název měsíce, dne v týdnu a další jazykově závislé řetězce respektují národní specifika nastavená pomocí setlocale().

Ve formátovacím řetězci se rozlišují tyto konverzní specifikátory:

  • %a - zkrácený název dne v týdnu (podle národního nastavení)
  • %A - úplný název dne v týdnu (podle národního nastavení)
  • %b - zkrácený název měsíce (podle národního nastavení)
  • %B - úplný název měsíce (podle národního nastavení)
  • %c - reprezentace času a data preferovaná aktuálním národním nastavením
  • %C - číslo století (rok dělený 100 a zkrácený na celé číslo, od 00 do 99)
  • %d - den v měsíci jako desítkové číslo (01 až 31)
  • %D - totéž jako %m/%d/%y
  • %e - den v měsíci jako desítkové číslo, jedné samotné číslici (čísla 1 až 9) předchází mezera (' 1' až '31')
  • %g - jako %G, ale bez století
  • %G - čtyřčíslicově reprezentovaný rok odpovídající týdnu podle ISO (viz %V). Má tentýž formát a hodnotu jako %Y, kromě toho, že pokud číslo týdne podle ISO patří předchozímu nebo následujícímu roku, bude tento odlišný rok použit.
  • %h - totéž jako %b
  • %H - hodina jako desítkové číslo ve 24-hodinovém formátu (00 až 23)
  • %I - hodina jako desítkové číslo ve 12-hodinovém formátu (01 až 12)
  • %j - den v roce jako desítkové číslo (001 až 366)
  • %m - měsíc jako desítkové číslo (01 až 12)
  • %M - minuta jako desítkové číslo
  • %n - znak odřádkování
  • %p - `am' nebo `pm' v závislosti na hodnotě času, resp. odpovídající řetězec podle národního nastavení
  • %r - čas v notaci a.m. a p.m. (12-hodinové)
  • %R - čas ve 24-hodinové notaci
  • %S - sekunda jako desítkové číslo
  • %t - znak tabulátoru
  • %T - aktuální čas, totéž jako %H:%M:%S

  • %u - den v týdnu jako desítkové číslo [1,7], 1 reprezentuje pondělí

    Varování

    Na počítačích Sun Solaris se vyskytuje neděle jako první den v týdnu, přestože ISO 9889:1999 (aktuální C standard) jasně specifikuje, že by to mělo být pondělí.

  • %U - týden v aktuálním roce jako desítkové číslo, počínaje první nedělí jako prvním dnem prvního týdne
  • %V - týden v aktuálním roce podle ISO 8601:1988 jako desítkové číslo, v rozsahu od 01 do 53, kde 1 je první týden s alespoň 4 dny v tomto roce, a s pondělkem jako prvním dnem v týdnu. (Odpovídající rok lze získat pomocí %G nebo %g.)
  • %W - týden v aktuálním roce jako desítkové číslo, počínaje prvním pondělkem jako prvním dnem prvního týdne
  • %w - den v týdnu jako desítkové číslo, neděle odpovídá 0
  • %x - preferovaná reprezentace data (bez času) pro aktuální národní nastavení
  • %X - preferovaná reprezentace času (bez data) pro aktuální národní nastavení
  • %y - rok jako desítkové číslo bez století (00 až 99)
  • %Y - rok jako desítkové číslo včetně století
  • %Z - časová zóna, její název nebo zkratka
  • %% - znak `%' (procento)

Poznámka: Všechny konverzní specifikátory nemusí být podporovány vaší C knihovnou, potom nebudou podporovány ani funkcí strftime() v PHP. Kromě toho také ne všechny platformy podporují práci s negativními časovými značkami, takže rozsah možných datumů může být omezen začátkem éry Unixu. To znamená, že např. %e, %T, %R a %D (a případně i další) a datumy předcházející 1.1.1970 nebudou fungovat pod Windows, některými distribucemi Linuxu a několika dalšími operačními systémy. Pro Windows lze kompletní přehled podporovaných konverzních specifikátorů najít na » webových stránkách MSDN.

Příklad 358. strftime() - místní příklady

<?php
setlocale(LC_TIME, "C");
echo strftime("%A");
setlocale(LC_TIME, "fi_FI");
echo strftime(" je ve finštině %A,");
setlocale(LC_TIME, "fr_FR");
echo strftime(" ve francouzštině %A a");
setlocale(LC_TIME, "de_DE");
echo strftime(" v němčině %A.\n");
?>

Tento příklad bude fungovat jen tehdy, máte-li daná národní specifika nainstalována v systému.

Poznámka: %G a %V, které jsou založeny na normě ISO 8601:1988, mohou vrátit neočekávané (a přesto správné) výsledky, pokud nemáte v číslovacím systému zcela jasno. Viz %V výše a příklad níže.

Příklad 359. Příklad čísel týdnů podle ISO 8601:1988

<?php
/*     December 2002 / January 2003
ISOWk  M   Tu  W   Thu F   Sa  Su
----- ----------------------------
51     16  17  18  19  20  21  22
52     23  24  25  26  27  28  29
1      30  31   1   2   3   4   5
2       6   7   8   9  10  11  12
3      13  14  15  16  17  18  19   */

// Vypíše: 28.12.2002 - %V,%G,%Y = 52,2002,2002
echo "28.12.2002 - %V,%G,%Y = " . strftime("%V,%G,%Y",strtotime("12/28/2002")) . "\n";

// Vypíše: 30.12.2002 - %V,%G,%Y = 1,2003,2002
echo "30.12.2002 - %V,%G,%Y = " . strftime("%V,%G,%Y",strtotime("12/30/2002")) . "\n";

// Vypíše: 3.1.2003 - %V,%G,%Y = 1,2003,2003
echo "3.1.2003 - %V,%G,%Y = " . strftime("%V,%G,%Y",strtotime("1/3/2003")) . "\n";

// Vypíše: 10.1.2003 - %V,%G,%Y = 2,2003,2003
echo "10.1.2003 - %V,%G,%Y = " . strftime("%V,%G,%Y",strtotime("1/10/2003")) . "\n";

/*     December 2004 / January 2005
ISOWk  M   Tu  W   Thu F   Sa  Su
----- ----------------------------
51     13  14  15  16  17  18  19
52     20  21  22  23  24  25  26
53     27  28  29  30  31   1   2
1       3   4   5   6   7   8   9
2      10  11  12  13  14  15  16   */

// Vypíše: 23.12.2004 - %V,%G,%Y = 52,2004,2004
echo "23.12.2004 - %V,%G,%Y = " . strftime("%V,%G,%Y",strtotime("12/23/2004")) . "\n";

// Vypíše: 31.12.2004 - %V,%G,%Y = 53,2004,2004
echo "31.12.2004 - %V,%G,%Y = " . strftime("%V,%G,%Y",strtotime("12/31/2004")) . "\n";

// Vypíše: 2.1.2005 - %V,%G,%Y = 53,2004,2005
echo "2.1.2005 - %V,%G,%Y = " . strftime("%V,%G,%Y",strtotime("1/2/2005")) . "\n";

// Vypíše: 3.1.2005 - %V,%G,%Y = 1,2005,2005
echo "3.1.2005 - %V,%G,%Y = " . strftime("%V,%G,%Y",strtotime("1/3/2005")) . "\n";

?>

Viz také setlocale(), mktime() a » specifikaci Open Group strftime().

Předcházející | Nahoru | Další
mktime | Domů | strptime


strptime

(PHP 5 >= 5.1.0)

strptime — Parse a time/date generated with strftime()

Popis

array strptime ( string $date, string $format )

strptime() returns an array with the date parsed, or FALSE on error.

Month and weekday names and other language dependent strings respect the current locale set with setlocale() (LC_TIME).

Poznámka: Tato funkce není implementována na platformách Windows.

Seznam parametrů

date (string)

The string to parse (e.g. returned from strftime())

format (string)

The format used in date (e.g. the same as used in strftime()).

For more information about the format options, read the strftime() page.

Návratové hodnoty

Returns an array, or FALSE on failure.

Tabulka 38. The following parameters are returned in the array

parameters | Description
tm_sec | Seconds after the minute (0-61)
tm_min | Minutes after the hour (0-59)
tm_hour | Hour since midnight (0-23)
tm_mday | Day of the month (1-31)
tm_mon | Months since January (0-11)
tm_year | Years since 1900
tm_wday | Days since Sunday (0-6)
tm_yday | Days since January 1 (0-365)
unparsed | the date part which was not recognized using the specified format

Příklady

Příklad 360. strptime() example

<?php
$format = '%d/%m/%Y %H:%M:%S';
$strf = strftime($format);

echo "$strf\n";

print_r(strptime($strf, $format));
?>

Výše uvedený příklad vypíše něco jako:

03/10/2004 15:54:19

Array
(
    [tm_sec] => 19
    [tm_min] => 54
    [tm_hour] => 15
    [tm_mday] => 3
    [tm_mon] => 9
    [tm_year] => 104
    [tm_wday] => 0
    [tm_yday] => 276
    [unparsed] =>
)

Viz také

strftime()

Předcházející | Nahoru | Další
strftime | Domů | strtotime


strtotime

(PHP 4, PHP 5)

strtotime — Parse about any English textual datetime description into a Unix timestamp

Popis

int strtotime ( string $time [, int $now] )

The function expects to be given a string containing a US English date format and will try to parse that format into a Unix timestamp (the number of seconds since January 1 1970 00:00:00 GMT), relative to the timestamp given in now, or the current time if now is not supplied.

This function will use the TZ environment variable (if available) to calculate the timestamp. Since PHP 5.1.0 there are easier ways to define the timezone that is used across all date/time functions. That process is explained in the date_default_timezone_get() function page.

Poznámka: If the number of the year is specified in a two digit format, the values between 00-69 are mapped to 2000-2069 and 70-99 to 1970-1999.

Seznam parametrů

time

The string to parse, according to the GNU » Date Input Formats syntax. Before PHP 5.0.0, microseconds weren't allowed in the time, since PHP 5.0.0 they are allowed but ignored.

now

The timestamp used to calculate the returned value.

Návratové hodnoty

Returns a timestamp on success, FALSE otherwise. Previous to PHP 5.1.0, this function would return -1 on failure.

Errors/Exceptions

Every call to a date/time function will generate a E_NOTICE if the time zone is not valid, and/or a E_STRICT message if using the system settings or the TZ environment variable. See also date_default_timezone_set()

ChangeLog (záznam změn)

Verze | Popis
5.1.0 | It now returns FALSE on failure, instead of -1.
5.1.0 | Now issues the E_STRICT and E_NOTICE time zone errors.

Příklady

Příklad 361. A strtotime() example

<?php
echo strtotime("now"), "\n";
echo strtotime("10 September 2000"), "\n";
echo strtotime("+1 day"), "\n";
echo strtotime("+1 week"), "\n";
echo strtotime("+1 week 2 days 4 hours 2 seconds"), "\n";
echo strtotime("next Thursday"), "\n";
echo strtotime("last Monday"), "\n";
?>

Příklad 362. Checking for failure

<?php
$str = 'Not Good';

// previous to PHP 5.1.0 you would compare with -1, instead of false
if (($timestamp = strtotime($str)) === false) {
    echo "The string ($str) is bogus";
} else {
    echo "$str == " . date('l dS \o\f F Y h:i:s A', $timestamp);
}
?>

Poznámky

Varování

In PHP 5 up to 5.0.2, "now" and other relative times are wrongly computed from today's midnight. It differs from other versions where it is correctly computed from current time.

Varování

In PHP versions prior to 4.4.0, "next" is incorrectly computed as +2. A typical solution to this is to use "+1".

Poznámka: The valid range of a timestamp is typically from Fri, 13 Dec 1901 20:45:54 GMT to Tue, 19 Jan 2038 03:14:07 GMT. (These are the dates that correspond to the minimum and maximum values for a 32-bit signed integer.) Additionally, not all platforms support negative timestamps, therefore your date range may be limited to no earlier than the Unix epoch. This means that e.g. dates prior to Jan 1, 1970 will not work on Windows, some Linux distributions, and a few other operating systems. PHP 5.1.0 and newer versions overcome this limitation though.

Viz také

strptime()

Předcházející | Nahoru | Další
strptime | Domů | time


time

(PHP 4, PHP 5)

time — Return current Unix timestamp

Popis

int time ( void )

Returns the current time measured in the number of seconds since the Unix Epoch (January 1 1970 00:00:00 GMT).

Příklady

Příklad 363. time() example

<?php
$nextWeek = time() + (7 * 24 * 60 * 60);
                   // 7 days; 24 hours; 60 mins; 60secs
echo 'Now:       '. date('Y-m-d') ."\n";
echo 'Next Week: '. date('Y-m-d', $nextWeek) ."\n";
// or using strtotime():
echo 'Next Week: '. date('Y-m-d', strtotime('+1 week')) ."\n";
?>

Výše uvedený příklad vypíše něco jako:

Now:       2005-03-30
Next Week: 2005-04-06
Next Week: 2005-04-06

Poznámky

Tip

Timestamp of the start of the request is available in $_SERVER['REQUEST_TIME'] since PHP 5.1.

Viz také

date()
microtime()

Předcházející | Nahoru | Další
strtotime | Domů | timezone_abbreviations_list


dBase Functions

Předcházející VI. Reference funkcí Další

XXVI. dBase Functions

Úvod

These functions allow you to access records stored in dBase-format (dbf) databases.

dBase files are simple sequential files of fixed length records. Records are appended to the end of the file and delete records are kept until you call dbase_pack().

The types of dBase fields available are:

Tabulka 43. Available types of fields

Field | dBase Type | Format | Additional information
M | Memo | n/a | This type is not supported by PHP, such field will be ignored
D | Date | YYYYMMDD | The field length is limited to 8
N | Number | A number | You must declare a length and a precision (the number of digits after the decimal point)
C | String | A string | You must declare a length. When retrieving data, the string will be right-padded with spaces to fit the declared length.
L | Boolean | T or Y for TRUE, F or N for FALSE | Stored and returned as an integer (1 or 0)
F | Float | A float number | Support for this type of field was added in PHP 5.2.0

Varování

There is no support for indexes or memo fields. There is no support for locking, too. Two concurrent web server processes modifying the same dBase file will very likely ruin your database.

We recommend that you do not use dBase files as your production database. Choose any real SQL server instead; » MySQL or » Postgres are common choices with PHP. dBase support is here to allow you to import and export data to and from your web database, because the file format is commonly understood by Windows spreadsheets and organizers.

Instalace

In order to enable the bundled dbase library and to use these functions, you must compile PHP with the --enable-dbase option.

Konfigurace běhu

Toto rozšíření nemá definováno žádné konfigurační direktivy.

Typy prostředků

Toto rozšíření nemá definován žádný typ prostředku (resource).

Příklady

Many examples in this reference require a dBase database. We will use /tmp/test.dbf that will be created in the example of dbase_create().

Předdefinované konstanty

Toto rozšíření nemá definovány žádné konstanty.

Obsah

dbase_add_record — Adds a record to a database
dbase_close — Closes a database
dbase_create — Creates a database
dbase_delete_record — Deletes a record from a database
dbase_get_header_info — Gets the header info of a database
dbase_get_record_with_names — Gets a record from a database as an associative array
dbase_get_record — Gets a record from a database as an indexed array
dbase_numfields — Gets the number of fields of a database
dbase_numrecords — Gets the number of records in a database
dbase_open — Opens a database
dbase_pack — Packs a database
dbase_replace_record — Replaces a record in a database
Předcházející | Nahoru | Další
dba_sync | Domů | dbase_add_record


dbase_add_record

(PHP 4, PHP 5)

dbase_add_record — Adds a record to a database

Popis

bool dbase_add_record ( int $dbase_identifier, array $record )

Adds the given data to the database.

Seznam parametrů

dbase_identifier

The database link identifier, returned by dbase_open() or dbase_create().

record

An indexed array of data. The number of items must be equal to the number of fields in the database, otherwise dbase_add_record() will fail.

Poznámka: If you're using dbase_get_record() return value for this parameter, remember to reset the key named deleted.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 372. Inserting a record in a dBase database

<?php

// open in read-write mode
$db = dbase_open('/tmp/test.dbf', 2);

if ($db) {
  dbase_add_record($db, array(
      date('Ymd'),
      'Maxim Topolov',
      '23',
      'max@example.com',
      'T'));
  dbase_close($db);
}

?>

Viz také

dbase_delete_record()
dbase_replace_record()

Předcházející | Nahoru | Další
XXVI. dBase Functions | Domů | dbase_close


dbase_close

(PHP 4, PHP 5)

dbase_close — Closes a database

Popis

bool dbase_close ( int $dbase_identifier )

Closes the given database link identifier.

Seznam parametrů

dbase_identifier

The database link identifier, returned by dbase_open() or dbase_create().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 373. Closing a dBase database file

<?php

// open in read-only mode
$db = dbase_open('/tmp/test.dbf', 0);

if ($db) {
  // read some data ..

  dbase_close($db);
}

?>

Viz také

dbase_open()
dbase_create()

Předcházející | Nahoru | Další
dbase_add_record | Domů | dbase_create


dbase_create

(PHP 4, PHP 5)

dbase_create — Creates a database

Popis

int dbase_create ( string $filename, array $fields )

dbase_create() creates a dBase database with the given definition.

Poznámka: Pokud je zapnut bezpečný režim (safe-mode), PHP kontroluje, zda soubory/adresáře, se kterými pracujete, mají stejné UID jako spuštěný skript.

Poznámka: Tato funkce není ovlivněna open_basedir.

Seznam parametrů

filename

The name of the database. It can be a relative or absolute path to the file where dBase will store your data.

fields

An array of arrays, each array describing the format of one field of the database. Each field consists of a name, a character indicating the field type, and optionally, a length, and a precision.

Poznámka: The fieldnames are limited in length and must not exceed 10 chars.

Návratové hodnoty

Returns a database link identifier if the database is successfully created, or FALSE if an error occurred.

Příklady

Příklad 374. Creating a dBase database file

<?php

// database "definition"
$def = array(
  array("date",     "D"),
  array("name",     "C",  50),
  array("age",      "N",   3, 0),
  array("email",    "C", 128),
  array("ismember", "L")
);

// creation
if (!dbase_create('/tmp/test.dbf', $def)) {
  echo "Error, can't create the database\n";
}

?>

Viz také

dbase_open()
dbase_close()

Předcházející | Nahoru | Další
dbase_close | Domů | dbase_delete_record


dbase_delete_record

(PHP 4, PHP 5)

dbase_delete_record — Deletes a record from a database

Popis

bool dbase_delete_record ( int $dbase_identifier, int $record_number )

Marks the given record to be deleted from the database.

Poznámka: To actually remove the record from the database, you must also call dbase_pack().

Seznam parametrů

dbase_identifier

The database link identifier, returned by dbase_open() or dbase_create().

record_number

An integer which spans from 1 to the number of records in the database (as returned by dbase_numrecords()).

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

dbase_add_record()
dbase_replace_record()

Předcházející | Nahoru | Další
dbase_create | Domů | dbase_get_header_info


dbase_get_header_info

(PHP 5)

dbase_get_header_info — Gets the header info of a database

Popis

array dbase_get_header_info ( int $dbase_identifier )

Returns information on the column structure of the given database link identifier.

Seznam parametrů

dbase_identifier

The database link identifier, returned by dbase_open() or dbase_create().

Návratové hodnoty

An indexed array with an entry for each column in the database. The array index starts at 0.

Each array element contains an associative array of column information, as described here:

name
The name of the column
type
The human-readable name for the dbase type of the column (i.e. date, boolean, etc.)
length
The number of bytes this column can hold
precision
The number of digits of decimal precision for the column
format
A suggested printf() format specifier for the column
offset
The byte offset of the column from the start of the row

If the database header information cannot be read, FALSE is returned.

Příklady

Příklad 375. Showing header information for a dBase database file

<?php
// Path to dbase file
$db_path = "/tmp/test.dbf";

// Open dbase file
$dbh = dbase_open($db_path, 0)
  or die("Error! Could not open dbase database file '$db_path'.");

// Get column information
$column_info = dbase_get_header_info($dbh);

// Display information
print_r($column_info);
?>

Předcházející | Nahoru | Další
dbase_delete_record | Domů | dbase_get_record_with_names


dbase_get_record_with_names

(PHP 4, PHP 5)

dbase_get_record_with_names — Gets a record from a database as an associative array

Popis

array dbase_get_record_with_names ( int $dbase_identifier, int $record_number )

Gets a record from a dBase database as an associative array.

Seznam parametrů

dbase_identifier

The database link identifier, returned by dbase_open() or dbase_create().

record_number

The index of the record.

Návratové hodnoty

An associative array with the record. This will also include a key named deleted which is set to 1 if the record has been marked for deletion (see dbase_delete_record()).

Each field is converted to the appropriate PHP type, except:

  • Dates are left as strings.
  • Integers that would have caused an overflow (> 32 bits) are returned as strings.

On error, dbase_get_record_with_names() will return FALSE.

Příklady

Příklad 376. Listing all the registered members in the database

<?php
// open in read-only mode
$db = dbase_open('/tmp/test.dbf', 0);

if ($db) {
  $record_numbers = dbase_numrecords($db);
  for ($i = 1; $i <= $record_numbers; $i++) {
      $row = dbase_get_record_with_names($db, $i);
      if ($row['ismember'] == 1) {
          echo "Member #$i: " . trim($row['name']) . "\n";
      }
  }
}
?>

Viz také

dbase_get_record()

Předcházející | Nahoru | Další
dbase_get_header_info | Domů | dbase_get_record


dbase_get_record

(PHP 4, PHP 5)

dbase_get_record — Gets a record from a database as an indexed array

Popis

array dbase_get_record ( int $dbase_identifier, int $record_number )

Gets a record from a database as an indexed array.

Seznam parametrů

dbase_identifier

The database link identifier, returned by dbase_open() or dbase_create().

record_number

The index of the record.

Návratové hodnoty

An indexed array with the record. This array will also include an associative key named deleted which is set to 1 if the record has been marked for deletion (see dbase_delete_record()).

Each field is converted to the appropriate PHP type, except:

  • Dates are left as strings.
  • Integers that would have caused an overflow (> 32 bits) are returned as strings.

On error, dbase_get_record() will return FALSE.

Viz také

dbase_get_record_with_names()

Předcházející | Nahoru | Další
dbase_get_record_with_names | Domů | dbase_numfields


dbase_numfields

(PHP 4, PHP 5)

dbase_numfields — Gets the number of fields of a database

Popis

int dbase_numfields ( int $dbase_identifier )

Gets the number of fields (columns) in the specified database.

Poznámka: Field numbers are between 0 and dbase_numfields($db)-1, while record numbers are between 1 and dbase_numrecords($db).

Seznam parametrů

dbase_identifier

The database link identifier, returned by dbase_open() or dbase_create().

Návratové hodnoty

The number of fields in the database, or FALSE if an error occurs.

Příklady

Příklad 377. dbase_numfields() Example

<?php

$rec = dbase_get_record($db, $recno);
$nf  = dbase_numfields($db);
for ($i = 0; $i < $nf; $i++) {
  echo $rec[$i], "\n";
}

?>

Viz také

dbase_numrecords()

Předcházející | Nahoru | Další
dbase_get_record | Domů | dbase_numrecords


dbase_numrecords

(PHP 4, PHP 5)

dbase_numrecords — Gets the number of records in a database

Popis

int dbase_numrecords ( int $dbase_identifier )

Gets the number of records (rows) in the specified database.

Poznámka: Record numbers are between 1 and dbase_numrecords($db), while field numbers are between 0 and dbase_numfields($db)-1.

Seznam parametrů

dbase_identifier

The database link identifier, returned by dbase_open() or dbase_create().

Návratové hodnoty

The number of records in the database, or FALSE if an error occurs.

Příklady

Příklad 378. Looping over all the records of the database

<?php

// open in read-only mode
$db = dbase_open('/tmp/test.dbf', 0);

if ($db) {
  $record_numbers = dbase_numrecords($db);
  for ($i = 1; $i <= $record_numbers; $i++) {
      // do something here, for each record
  }
}

?>

Viz také

dbase_num_fields()

Předcházející | Nahoru | Další
dbase_numfields | Domů | dbase_open


dbase_open

(PHP 4, PHP 5)

dbase_open — Opens a database

Popis

int dbase_open ( string $filename, int $mode )

dbase_open() opens a dBase database with the given access mode.

Poznámka: Pokud je zapnut bezpečný režim (safe-mode), PHP kontroluje, zda soubory/adresáře, se kterými pracujete, mají stejné UID jako spuštěný skript.

Poznámka: Tato funkce není ovlivněna open_basedir.

Seznam parametrů

filename

The name of the database. It can be a relative or absolute path to the file where dBase will store your data.

mode

An integer which correspond to those for the open() system call (Typically 0 means read-only, 1 means write-only, and 2 means read and write).

Poznámka: You can't open a dBase file in write-only mode as the function will fail to read the headers information and thus you can't use 1 as mode.

Příklady

Příklad 379. Opening a dBase database file

<?php

// open in read-only mode
$db = dbase_open('/tmp/test.dbf', 0);

if ($db) {
  // read some data ..

  dbase_close($db);
}

?>

Návratové hodnoty

Returns a database link identifier if the database is successfully opened, or FALSE if an error occurred.

Viz také

dbase_create()
dbase_close()

Předcházející | Nahoru | Další
dbase_numrecords | Domů | dbase_pack


dbase_pack

(PHP 4, PHP 5)

dbase_pack — Packs a database

Popis

bool dbase_pack ( int $dbase_identifier )

Packs the specified database by permanently deleting all records marked for deletion using dbase_delete_record().

Seznam parametrů

dbase_identifier

The database link identifier, returned by dbase_open() or dbase_create().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 380. Emptying a dBase database

<?php

// open in read-write mode
$db = dbase_open('/tmp/test.dbf', 2);

if ($db) {
  $record_numbers = dbase_numrecords($db);
  for ($i = 1; $i <= $record_numbers; $i++) {
      dbase_delete_record($db, $i);
  }
  // expunge the database
  dbase_pack($db);
}

?>

Viz také

dbase_delete_record()

Předcházející | Nahoru | Další
dbase_open | Domů | dbase_replace_record


dbase_replace_record

(PHP 4, PHP 5)

dbase_replace_record — Replaces a record in a database

Popis

bool dbase_replace_record ( int $dbase_identifier, array $record, int $record_number )

Replaces the given record in the database with the given data.

Seznam parametrů

dbase_identifier

The database link identifier, returned by dbase_open() or dbase_create().

record

An indexed array of data. The number of items must be equal to the number of fields in the database, otherwise dbase_add_record() will fail.

Poznámka: If you're using dbase_get_record() return value for this parameter, remember to reset the key named deleted.

record_number

An integer which spans from 1 to the number of records in the database (as returned by dbase_numrecords()).

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 381. Updating a record in the database

<?php

// open in read-write mode
$db = dbase_open('/tmp/test.dbf', 2);

if ($db) {
  // gets the old row
  $row = dbase_get_record_with_names($db, 1);

  // remove the 'deleted' entry
  unset($row['deleted']);

  // Update the date field with the current timestamp
  $row['date'] = date('Ymd');

  // Replace the record
  dbase_replace_record($db, $row, 1);
  dbase_close($db);
}

?>

Viz také

dbase_add_record()
dbase_delete_record()

Předcházející | Nahoru | Další
dbase_pack | Domů | XXVII. DBM Funkce [zastaralé]


DBM Funkce [zastaralé]

Předcházející VI. Reference funkcí Další

XXVII. DBM Funkce [zastaralé]

Úvod

Tyto funkce vám umožňují ukládat záznamy do databází typu dbm. Tento typ databází (podporovaný Berkeley DB, GDBM, některými systémovými knihovnami, a také vestavěnou flatfile knihovnou) ukládá klíč/hodnota páry (oproti plnohodnotným relačním databázím).

Poznámka: Podpora dbm je nicméně zavržena a doporučujeme vám použít místo toho funkce databázové abstrakční vrstvy (dbm-styl)

Požadavky

K použití tohoto rozšíření musíte PHP zkompilovat s podporou použité databáze. Viz seznam podporovaných databází.

Instalace

In order to use these functions, you must compile PHP with dbm support by using the --with-db option. In addition you must ensure support for an underlying database or you can use some system libraries.

Konfigurace běhu

Toto rozšíření nemá definováno žádné konfigurační direktivy.

Typy prostředků

Funkce dbmopen() vrací identifikátor databáze, který používají ostatní dbm-funkce.

Předdefinované konstanty

Toto rozšíření nemá definovány žádné konstanty.

Příklady

Příklad 382. DBM - příklad

<?php

$dbm = dbmopen ("lastseen", "w");
if (dbmexists ($dbm, $userid)) {
    $last_seen = dbmfetch ($dbm, $userid);
} else {
    dbminsert ($dbm, $userid, time());
}
do_stuff();
dbmreplace ($dbm, $userid, time());
dbmclose ($dbm);

?>

Obsah

dblist — Získat název používané DBM-kompatibilní knihovny
dbmclose — Zavřít dbm databázi
dbmdelete — Smazat v DMB databázi hodnotu spojenou s určitým klíčem
dbmexists — Zjistí, jestli pro zadaný klíč existuje v DBM databázi hodnota
dbmfetch — Získat z DBM databáze hodnotu spojenou s určitým klíčem
dbmfirstkey — Získat z DBM databáze první klíč
dbminsert — Vložit do DBM databáze hodnotu a klíč
dbmnextkey — Získat další klíč z DBM databáze
dbmopen — Otevřít DBM databázi
dbmreplace — Nahredit v DBM databázi hodnotu s určitým klíčem
Předcházející | Nahoru | Další
dbase_replace_record | Domů | dblist


dblist

(PHP 4)

dblist — Získat název používané DBM-kompatibilní knihovny

Popis

string dblist ( void )
Předcházející | Nahoru | Další
XXVII. DBM Funkce [zastaralé] | Domů | dbmclose


dbmclose

(PHP 4)

dbmclose — Zavřít dbm databázi

Popis

bool dbmclose ( resource $dbm_identifier )

Odemkne a zavře určenou databázi.

Předcházející | Nahoru | Další
dblist | Domů | dbmdelete


dbmdelete

(PHP 4)

dbmdelete — Smazat v DMB databázi hodnotu spojenou s určitým klíčem

Popis

bool dbmdelete ( resource $dbm_identifier, string $key )

Vymaže z databáze hodnotu s klíčem key.

Pokud tento klíč v databázi neexistuje, vrací FALSE.

Předcházející | Nahoru | Další
dbmclose | Domů | dbmexists


dbmexists

(PHP 4)

dbmexists — Zjistí, jestli pro zadaný klíč existuje v DBM databázi hodnota

Popis

bool dbmexists ( resource $dbm_identifier, string $key )

Vrací TRUE, pokud existuje hodnota spojená s key.

Předcházející | Nahoru | Další
dbmdelete | Domů | dbmfetch


dbmfetch

(PHP 4)

dbmfetch — Získat z DBM databáze hodnotu spojenou s určitým klíčem

Popis

string dbmfetch ( resource $dbm_identifier, string $key )

Vrací hodnotu spojenou s key.

Předcházející | Nahoru | Další
dbmexists | Domů | dbmfirstkey


dbmfirstkey

(PHP 4)

dbmfirstkey — Získat z DBM databáze první klíč

Popis

string dbmfirstkey ( resource $dbm_identifier )

Vrací první klíč v databázi. Pozn.: Není zaručeno žádné pořadí, protože databáze může být vytvořena pomocí hash tabulky, což nezaručuje žádné řazení.

Předcházející | Nahoru | Další
dbmfetch | Domů | dbminsert


dbminsert

(PHP 4)

dbminsert — Vložit do DBM databáze hodnotu a klíč

Popis

int dbminsert ( resource $dbm_identifier, string $key, string $value )

Přidá do databáze hodnotu s určeným klíčem.

Vrací -1, pokud byla databáze otevřena pouze pro čtení, 0, pokud bylo vložení úspěšné, a 1, pokud už určený klíč existuje. (K nahražení hodnoty použijte dbmreplace().)

Předcházející | Nahoru | Další
dbmfirstkey | Domů | dbmnextkey


dbmnextkey

(PHP 4)

dbmnextkey — Získat další klíč z DBM databáze

Popis

string dbmnextkey ( resource $dbm_identifier, string $key )

Vrací klíč násůedující po key. Zavoláním dbmfirstkey() následovaným postupným voláním dbmnextkey() se dají získat všechny key/value páry v DBM databázi. Například:

Příklad 383. Získání všech key/value párů v DBM databázi

$key = dbmfirstkey ($dbm_id);
while ($key) {
    echo "$key = " . dbmfetch ($dbm_id, $key) . "\n";
    $key = dbmnextkey ($dbm_id, $key);
}

Předcházející | Nahoru | Další
dbminsert | Domů | dbmopen


dbmopen

(PHP 4)

dbmopen — Otevřít DBM databázi

Popis

resource dbmopen ( string $filename, string $flags )

První argument je název DBM souboru (plná cesta), který se má otevřít, druhý argument je jedno z "r" (pouze pro čtení), "n" (nový, implikuje čtení/zápis, a nejspíš smaže existující databázi stejného jména), "c" (vytvořit, implikuje čtení/zápis, a nesmaže existující databázi stejného jména) nebo "w" (čtení/zápis).

Při úspěchu vrací identifikátor, který se předává dalším DBM funkcím success, jinak FALSE.

Pokud používáte NDBM, NDBM ve skutečnosti vytváří soubory soubor.dir a soubor.pag. GDBM používá pouze jeden soubr, stejně jako interní flatfile podpora, a Berkeley DB vytváří soubor filename.db. Pozn.: Vedle případného zamykání souborů vlastní DBM knihovnou provádí PHP svoje vlastní zamykání souborů. PHP nemaže .lck soubory, které vytváří. Používá tyto soubory jako pevné inodes, na kterých provádí zamykání souborů. Více informací o DBM souborech viz vaše Unixové man stránky, nebo si stáhněte » GNU GDBM.

Předcházející | Nahoru | Další
dbmnextkey | Domů | dbmreplace


dbmreplace

(PHP 4)

dbmreplace — Nahredit v DBM databázi hodnotu s určitým klíčem

Popis

int dbmreplace ( resource $dbm_identifier, string $key, string $value )

Nahradí v databázi hodnotu spojenou s určeným klíčem.

Pokud tento klíče v databázi neexistuje, přidá ho.

Předcházející | Nahoru | Další
dbmopen | Domů | XXVIII. dbx Functions


dbx Functions

Předcházející VI. Reference funkcí Další

XXVIII. dbx Functions

Úvod

The dbx module is a database abstraction layer (db 'X', where 'X' is a supported database). The dbx functions allow you to access all supported databases using a single calling convention. The dbx-functions themselves do not interface directly to the databases, but interface to the modules that are used to support these databases.

Poznámka: Toto rozšíření bylo přesunuto do repozitáře PECL a již nebude součástí balíku PHP.5.1.0.

Požadavky

To be able to use a database with the dbx-module, the module must be either linked or loaded into PHP, and the database module must be supported by the dbx-module. Currently, the following databases are supported, but others will follow:

  • FrontBase (available from PHP 4.1.0).
  • Microsoft SQL Server
  • MySQL
  • ODBC
  • PostgreSQL
  • Sybase-CT (available from PHP 4.2.0).
  • Oracle (oci8) (available from PHP 4.3.0).
  • SQLite (PHP 5).

Documentation for adding additional database support to dbx can be found at » http://www.guidance.nl/php/dbx/doc/.

Instalace

In order to have these functions available, you must compile PHP with dbx support by using the --enable-dbx option and all options for the databases that will be used, e.g. for MySQL you must also specify --with-mysql=[DIR]. To get other supported databases to work with the dbx-module refer to their specific documentation.

Konfigurace běhu

Chování těchto funkcí je ovlivněno nastavením parametrů v php.ini.

Tabulka 44. DBX Configuration Options

Name | Default | Changeable | Changelog
dbx.colnames_case | "unchanged" | PHP_INI_SYSTEM | Available since PHP 4.3.0. Removed in PHP 5.1.0.

Pro další detaily a definice konstant PHP_INI_*, viz dokumentace k ini_set().

Zde je stručný popis konfiguračních direktiv.

dbx.colnames_case string

Columns names can be returned "unchanged" or converted to "uppercase" or "lowercase". This directive can be overridden with a flag to dbx_query().

Typy prostředků

There are two resource types used in the dbx module. The first one is the link-object for a database connection, the second a result-object which holds the result of a query.

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

DBX_MYSQL (integer)
DBX_ODBC (integer)
DBX_PGSQL (integer)
DBX_MSSQL (integer)
DBX_FBSQL (integer)
DBX_OCI8 (integer) (available from PHP 4.3.0)
DBX_SYBASECT (integer)
DBX_SQLITE (integer) (PHP 5)
DBX_PERSISTENT (integer)
DBX_RESULT_INFO (integer)
DBX_RESULT_INDEX (integer)
DBX_RESULT_ASSOC (integer)
DBX_RESULT_UNBUFFERED (integer) (PHP 5)
DBX_COLNAMES_UNCHANGED (integer) (available from PHP 4.3.0)
DBX_COLNAMES_UPPERCASE (integer) (available from PHP 4.3.0)
DBX_COLNAMES_LOWERCASE (integer) (available from PHP 4.3.0)
DBX_CMP_NATIVE (integer)
DBX_CMP_TEXT (integer)
DBX_CMP_NUMBER (integer)
DBX_CMP_ASC (integer)
DBX_CMP_DESC (integer)

Obsah

dbx_close — Close an open connection/database
dbx_compare — Compare two rows for sorting purposes
dbx_connect — Open a connection/database
dbx_error — Report the error message of the latest function call in the module
dbx_escape_string — Escape a string so it can safely be used in an sql-statement
dbx_fetch_row — Fetches rows from a query-result that had the DBX_RESULT_UNBUFFERED flag set
dbx_query — Send a query and fetch all results (if any)
dbx_sort — Sort a result from a dbx_query by a custom sort function
Předcházející | Nahoru | Další
dbmreplace | Domů | dbx_close


dbx_close

(PHP 4 >= 4.0.6, PHP 5 <= 5.0.5, PECL dbx:1.1.0)

dbx_close — Close an open connection/database

Popis

int dbx_close ( object $link_identifier )

Seznam parametrů

link_identifier

The DBX link object to close.

Návratové hodnoty

Returns 1 on success and 0 on errors.

Příklady

Příklad 384. dbx_close() example

<?php
$link = dbx_connect(DBX_MYSQL, "localhost", "db", "username", "password")
    or die("Could not connect");

echo "Connected successfully";
dbx_close($link);
?>

Poznámky

Poznámka: Always refer to the module-specific documentation as well.

Viz také

dbx_connect()

Předcházející | Nahoru | Další
XXVIII. dbx Functions | Domů | dbx_compare


dbx_compare

(PHP 4 >= 4.0.7, PHP 5 <= 5.0.5, PECL dbx:1.1.0)

dbx_compare — Compare two rows for sorting purposes

Popis

int dbx_compare ( array $row_a, array $row_b, string $column_key [, int $flags] )

dbx_compare() is a helper function for dbx_sort() to ease the make and use of the custom sorting function.

Seznam parametrů

row_a

First row

row_b

Second row

column_key

The compared column

flags

The flags can be set to specify comparison direction:

  • DBX_CMP_ASC - ascending order
  • DBX_CMP_DESC - descending order

and the preferred comparison type:

  • DBX_CMP_NATIVE - no type conversion
  • DBX_CMP_TEXT - compare items as strings
  • DBX_CMP_NUMBER - compare items numerically

One of the direction and one of the type constant can be combined with bitwise OR operator (|). The default value for the flags parameter is DBX_CMP_ASC | DBX_CMP_NATIVE.

Návratové hodnoty

Returns 0 if the row_a[$column_key] is equal to row_b[$column_key], and 1 or -1 if the former is greater or is smaller than the latter one, respectively, or vice versa if the flag is set to DBX_CMP_DESC.

Příklady

Příklad 385. dbx_compare() example

<?php
function user_re_order($a, $b)
{
    $rv = dbx_compare($a, $b, "parentid", DBX_CMP_DESC);
    if (!$rv) {
        $rv = dbx_compare($a, $b, "id", DBX_CMP_NUMBER);
    }
    return $rv;
}

$link   = dbx_connect(DBX_ODBC, "", "db", "username", "password")
    or die("Could not connect");

$result = dbx_query($link, "SELECT id, parentid, description FROM table ORDER BY id");
    // data in $result is now ordered by id

dbx_sort($result, "user_re_order");
    // date in $result is now ordered by parentid (descending), then by id

dbx_close($link);
?>

Viz také

dbx_sort()

Předcházející | Nahoru | Další
dbx_close | Domů | dbx_connect


dbx_connect

(PHP 4 >= 4.0.6, PHP 5 <= 5.0.5, PECL dbx:1.1.0)

dbx_connect — Open a connection/database

Popis

object dbx_connect ( mixed $module, string $host, string $database, string $username, string $password [, int $persistent] )

Opens a connection to a database.

Seznam parametrů

module

The module parameter can be either a string or a constant, though the latter form is preferred. The possible values are given below, but keep in mind that they only work if the module is actually loaded.

  • DBX_MYSQL or "mysql"
  • DBX_ODBC or "odbc"
  • DBX_PGSQL or "pgsql"
  • DBX_MSSQL or "mssql"
  • DBX_FBSQL or "fbsql" (available from PHP 4.1.0)
  • DBX_SYBASECT or "sybase_ct" (available from PHP 4.2.0)
  • DBX_OCI8 or "oci8" (available from PHP 4.3.0)
  • DBX_SQLITE or "sqlite" (PHP 5)

host

The SQL server host

database

The database name

username

The username

password

The password

persistent

The persistent parameter can be set to DBX_PERSISTENT, if so, a persistent connection will be created.

The host, database, username and password parameters are expected, but not always used depending on the connect functions for the abstracted module.

Návratové hodnoty

Returns an object on success, FALSE on error. If a connection has been made but the database could not be selected, the connection is closed and FALSE is returned.

The returned object has three properties:

database
It is the name of the currently selected database.
handle

It is a valid handle for the connected database, and as such it can be used in module-specific functions (if required).

<?php
$link = dbx_connect(DBX_MYSQL, "localhost", "db", "username", "password");
mysql_close($link->handle); // dbx_close($link) would be better here
?>

module
It is used internally by dbx only, and is actually the module number mentioned above.

Příklady

Příklad 386. dbx_connect() example

<?php
$link = dbx_connect(DBX_ODBC, "", "db", "username", "password", DBX_PERSISTENT)
    or die("Could not connect");

echo "Connected successfully";
dbx_close($link);
?>

Poznámky

Poznámka: Always refer to the module-specific documentation as well.

Viz také

dbx_close()

Předcházející | Nahoru | Další
dbx_compare | Domů | dbx_error


dbx_error

(PHP 4 >= 4.0.6, PHP 5 <= 5.0.5, PECL dbx:1.1.0)

dbx_error — Report the error message of the latest function call in the module

Popis

string dbx_error ( object $link_identifier )

dbx_error() returns the last error message.

Seznam parametrů

link_identifier

The DBX link object returned by dbx_connect()

Návratové hodnoty

Returns a string containing the error message from the last function call of the abstracted module (e.g. mysql module). If there are multiple connections in the same module, just the last error is given. If there are connections on different modules, the latest error is returned for the module specified by the link_identifier parameter.

Příklady

Příklad 387. dbx_error() example

<?php
$link   = dbx_connect(DBX_MYSQL, "localhost", "db", "username", "password")
    or die("Could not connect");

$result = dbx_query($link, "select id from non_existing_table");
if ($result == 0) {
    echo dbx_error($link);
}
dbx_close($link);
?>

Poznámky

Poznámka: Always refer to the module-specific documentation as well.

The error message for Microsoft SQL Server is actually the result of the mssql_get_last_message() function.

The error message for Oracle (oci8) is not implemented yet.

Předcházející | Nahoru | Další
dbx_connect | Domů | dbx_escape_string


dbx_escape_string

(PHP 4 >= 4.3.0, PHP 5 <= 5.0.5, PECL dbx:1.1.0)

dbx_escape_string — Escape a string so it can safely be used in an sql-statement

Popis

string dbx_escape_string ( object $link_identifier, string $text )

Escape the given string so that it can safely be used in an sql-statement.

Seznam parametrů

link_identifier

The DBX link object returned by dbx_connect()

text

The string to escape.

Návratové hodnoty

Returns the text, escaped where necessary (such as quotes, backslashes etc). On error, NULL is returned.

Příklady

Příklad 388. dbx_escape_string() example

<?php
$link   = dbx_connect(DBX_MYSQL, "localhost", "db", "username", "password")
    or die("Could not connect");

$text = dbx_escape_string($link, "It\'s quoted and backslashed (\\).");
$result = dbx_query($link, "insert into tbl (txt) values ('" . $text . "')");
if ($result == 0) {
    echo dbx_error($link);
}
dbx_close($link);
?>

Viz také

dbx_query()

Předcházející | Nahoru | Další
dbx_error | Domů | dbx_fetch_row


dbx_fetch_row

(PHP 5 <= 5.0.5, PECL dbx:1.1.0)

dbx_fetch_row — Fetches rows from a query-result that had the DBX_RESULT_UNBUFFERED flag set

Popis

mixed dbx_fetch_row ( object $result_identifier )

dbx_fetch_row() fetches rows from a result identifier that had the DBX_RESULT_UNBUFFERED flag set.

When the DBX_RESULT_UNBUFFERED is not set in the query, dbx_fetch_row() will fail as all rows have already been fetched into the results data property.

As a side effect, the rows property of the query-result object is incremented for each successful call to dbx_fetch_row().

Seznam parametrů

result_identifier

A result set returned by dbx_query().

Návratové hodnoty

Returns an object on success that contains the same information as any row would have in the dbx_query() result data property, including columns accessible by index or fieldname when the flags for dbx_query() were set that way.

Upon failure, returns 0 (e.g. when no more rows are available).

Příklady

Příklad 389. How to handle the returned value

<?php
$result = dbx_query($link, 'SELECT id, parentid, description FROM table', DBX_RESULT_UNBUFFERED);

echo "<table>\n";
while ($row = dbx_fetch_row($result)) {
    echo "<tr>\n";
    foreach ($row as $field) {
        echo "<td>$field</td>";
    }
    echo "</tr>\n";
}
echo "</table>\n";
?>

Viz také

dbx_query()

Předcházející | Nahoru | Další
dbx_escape_string | Domů | dbx_query


dbx_query

(PHP 4 >= 4.0.6, PHP 5 <= 5.0.5, PECL dbx:1.1.0)

dbx_query — Send a query and fetch all results (if any)

Popis

mixed dbx_query ( object $link_identifier, string $sql_statement [, int $flags] )

Sends a query and fetch all results.

Seznam parametrů

link_identifier

The DBX link object returned by dbx_connect()

sql_statement

SQL statement.

flags

The flags parameter is used to control the amount of information that is returned. It may be any combination of the following constants with the bitwise OR operator (|). The DBX_COLNAMES_* flags override the dbx.colnames_case setting from php.ini.

DBX_RESULT_INDEX

It is always set, that is, the returned object has a data property which is a 2 dimensional array indexed numerically. For example, in the expression data[2][3] 2 stands for the row (or record) number and 3 stands for the column (or field) number. The first row and column are indexed at 0.

If DBX_RESULT_ASSOC is also specified, the returning object contains the information related to DBX_RESULT_INFO too, even if it was not specified.

DBX_RESULT_INFO
It provides info about columns, such as field names and field types.
DBX_RESULT_ASSOC

It effects that the field values can be accessed with the respective column names used as keys to the returned object's data property.

Associated results are actually references to the numerically indexed data, so modifying data[0][0] causes that data[0]['field_name_for_first_column'] is modified as well.

DBX_RESULT_UNBUFFERED (PHP 5)

This flag will not create the data property, and the rows property will initially be 0. Use this flag for large datasets, and use dbx_fetch_row() to retrieve the results row by row.

The dbx_fetch_row() function will return rows that are conformant to the flags set with this query. Incidentally, it will also update the rows each time it is called.

DBX_COLNAMES_UNCHANGED (available from PHP 4.3.0)
The case of the returned column names will not be changed.
DBX_COLNAMES_UPPERCASE (available from PHP 4.3.0)
The case of the returned column names will be changed to uppercase.
DBX_COLNAMES_LOWERCASE (available from PHP 4.3.0)
The case of the returned column names will be changed to lowercase.

Note that DBX_RESULT_INDEX is always used, regardless of the actual value of flags parameter. This means that only the following combinations are effective:

  • DBX_RESULT_INDEX
  • DBX_RESULT_INDEX | DBX_RESULT_INFO
  • DBX_RESULT_INDEX | DBX_RESULT_INFO | DBX_RESULT_ASSOC - this is the default, if flags is not specified.

Návratové hodnoty

dbx_query() returns an object or 1 on success, and 0 on failure. The result object is returned only if the query given in sql_statement produces a result set (i.e. a SELECT query, even if the result set is empty).

The returned object has four or five properties depending on flags:

handle

It is a valid handle for the connected database, and as such it can be used in module specific functions (if required).

<?php
$result = dbx_query($link, "SELECT id FROM table");
mysql_field_len($result->handle, 0);
?>

cols and rows

These contain the number of columns (or fields) and rows (or records) respectively.

<?php
$result = dbx_query($link, 'SELECT id FROM table');
echo $result->rows; // number of records
echo $result->cols; // number of fields
?>

info (optional)

It is returned only if either DBX_RESULT_INFO or DBX_RESULT_ASSOC is specified in the flags parameter. It is a 2 dimensional array, that has two named rows (name and type) to retrieve column information.

Příklad 390. lists each field's name and type

<?php
$result = dbx_query($link, 'SELECT id FROM table',
                     DBX_RESULT_INDEX | DBX_RESULT_INFO);

for ($i = 0; $i < $result->cols; $i++ ) {
    echo $result->info['name'][$i] . "\n";
    echo $result->info['type'][$i] . "\n";
}
?>

data

This property contains the actual resulting data, possibly associated with column names as well depending on flags. If DBX_RESULT_ASSOC is set, it is possible to use $result->data[2]["field_name"].

Příklad 391. outputs the content of data property into HTML table

<?php
$result = dbx_query($link, 'SELECT id, parentid, description FROM table');

echo "<table>\n";
foreach ($result->data as $row) {
    echo "<tr>\n";
    foreach ($row as $field) {
        echo "<td>$field</td>";
    }
    echo "</tr>\n";
}
echo "</table>\n";
?>

Příklad 392. How to handle UNBUFFERED queries

<?php

$result = dbx_query ($link, 'SELECT id, parentid, description FROM table', DBX_RESULT_UNBUFFERED);

echo "<table>\n";
while ($row = dbx_fetch_row($result)) {
    echo "<tr>\n";
    foreach ($row as $field) {
        echo "<td>$field</td>";
    }
    echo "</tr>\n";
}
echo "</table>\n";

?>

Příklady

Příklad 393. How to handle the returned value

<?php
$link   = dbx_connect(DBX_ODBC, "", "db", "username", "password")
    or die("Could not connect");

$result = dbx_query($link, 'SELECT id, parentid, description FROM table');

if (is_object($result) ) {
    // ... do some stuff here, see detailed examples below ...
    // first, print out field names and types
    // then, draw a table filled with the returned field values
} else {
    exit("Query failed");
}

dbx_close($link);
?>

Poznámky

Poznámka: Always refer to the module-specific documentation as well.

Column names for queries on an Oracle database are returned in lowercase.

Viz také

dbx_escape_string()
dbx_fetch_row()
dbx_connect()

Předcházející | Nahoru | Další
dbx_fetch_row | Domů | dbx_sort


dbx_sort

(PHP 4 >= 4.0.6, PHP 5 <= 5.0.5, PECL dbx:1.1.0)

dbx_sort — Sort a result from a dbx_query by a custom sort function

Popis

bool dbx_sort ( object $result, string $user_compare_function )

Sort a result from a dbx_query() call with a custom sort function.

Seznam parametrů

result

A result set returned by dbx_query().

user_compare_function

The user-defined comparison function. It must accept two arguments and return an integer less than, equal to, or greater than zero if the first argument is considered to be respectively less than, equal to, or greater than the second.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 394. dbx_sort() example

<?php
function user_re_order($a, $b)
{
    $rv = dbx_compare($a, $b, "parentid", DBX_CMP_DESC);
    if (!$rv) {
        $rv = dbx_compare($a, $b, "id", DBX_CMP_NUMBER);
    }
    return $rv;
}

$link   = dbx_connect(DBX_ODBC, "", "db", "username", "password")
    or die("Could not connect");

$result = dbx_query($link, "SELECT id, parentid, description FROM tbl ORDER BY id");
    // data in $result is now ordered by id

dbx_sort($result, "user_re_order");
    // data in $result is now ordered by parentid (descending), then by id

dbx_close($link);
?>

Poznámky

Poznámka: It is always better to use ORDER BY SQL clause instead of dbx_sort() if possible.

Viz také

dbx_compare()

Předcházející | Nahoru | Další
dbx_query | Domů | XXIX. Direct IO Functions


DB++ Functions

Předcházející VI. Reference funkcí Další

XXIV. DB++ Functions

Varování

Toto rozšíření je EXPERIMENTÁLNÍ. Chování tohoto rozšíření, názvy funkcí a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může bez ohlášení změnit. Berte to v úvahu a používejte tento modul na vlastní nebezpečí.

Úvod

db++, made by the German company » Concept asa, is a relational database system with high performance and low memory and disk usage in mind. While providing SQL as an additional language interface, it is not really a SQL database in the first place but provides its own AQL query language which is much more influenced by the relational algebra than SQL is.

Concept asa always had an interest in supporting open source languages, db++ has had Perl and Tcl call interfaces for years now and uses Tcl as its internal stored procedure language.

Požadavky

This extension relies on external client libraries so you have to have a db++ client installed on the system you want to use this extension on.

» Concept asa provides » db++ Demo versions and » documentation for Linux, some other Unix versions. There is also a Windows version of db++, but this extension doesn't support it (yet).

Instalace

In order to build this extension yourself you need the db++ client libraries and header files to be installed on your system (these are included in the db++ installation archives by default). You have to run configure with option --with-dbplus to build this extension.

configure looks for the client libraries and header files under the default paths /usr/dbplus, /usr/local/dbplus and /opt/dblus. If you have installed db++ in a different place you have add the installation path to the configure option like this: --with-dbplus=/your/installation/path.

Konfigurace běhu

Toto rozšíření nemá definováno žádné konfigurační direktivy.

Typy prostředků

dbplus_relation

Most db++ functions operate on or return dbplus_relation resources. A dbplus_relation is a handle to a stored relation or a relation generated as the result of a query.

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

db++ error codes

Tabulka 39. DB++ Error Codes

PHP Constant | db++ constant | meaning
DBPLUS_ERR_NOERR (integer) | ERR_NOERR | Null error condition
DBPLUS_ERR_DUPLICATE (integer) | ERR_DUPLICATE | Tried to insert a duplicate tuple
DBPLUS_ERR_EOSCAN (integer) | ERR_EOSCAN | End of scan from rget()
DBPLUS_ERR_EMPTY (integer) | ERR_EMPTY | Relation is empty (server)
DBPLUS_ERR_CLOSE (integer) | ERR_CLOSE | The server can't close
DBPLUS_ERR_WLOCKED (integer) | ERR_WLOCKED | The record is write locked
DBPLUS_ERR_LOCKED (integer) | ERR_LOCKED | Relation was already locked
DBPLUS_ERR_NOLOCK (integer) | ERR_NOLOCK | Relation cannot be locked
DBPLUS_ERR_READ (integer) | ERR_READ | Read error on relation
DBPLUS_ERR_WRITE (integer) | ERR_WRITE | Write error on relation
DBPLUS_ERR_CREATE (integer) | ERR_CREATE | Create() system call failed
DBPLUS_ERR_LSEEK (integer) | ERR_LSEEK | Lseek() system call failed
DBPLUS_ERR_LENGTH (integer) | ERR_LENGTH | Tuple exceeds maximum length
DBPLUS_ERR_OPEN (integer) | ERR_OPEN | Open() system call failed
DBPLUS_ERR_WOPEN (integer) | ERR_WOPEN | Relation already opened for writing
DBPLUS_ERR_MAGIC (integer) | ERR_MAGIC | File is not a relation
DBPLUS_ERR_VERSION (integer) | ERR_VERSION | File is a very old relation
DBPLUS_ERR_PGSIZE (integer) | ERR_PGSIZE | Relation uses a different page size
DBPLUS_ERR_CRC (integer) | ERR_CRC | Invalid crc in the superpage
DBPLUS_ERR_PIPE (integer) | ERR_PIPE | Piped relation requires lseek()
DBPLUS_ERR_NIDX (integer) | ERR_NIDX | Too many secondary indices
DBPLUS_ERR_MALLOC (integer) | ERR_MALLOC | Malloc() call failed
DBPLUS_ERR_NUSERS (integer) | ERR_NUSERS | Error use of max users
DBPLUS_ERR_PREEXIT (integer) | ERR_PREEXIT | Caused by invalid usage
DBPLUS_ERR_ONTRAP (integer) | ERR_ONTRAP | Caused by a signal
DBPLUS_ERR_PREPROC (integer) | ERR_PREPROC | Error in the preprocessor
DBPLUS_ERR_DBPARSE (integer) | ERR_DBPARSE | Error in the parser
DBPLUS_ERR_DBRUNERR (integer) | ERR_DBRUNERR | Run error in db
DBPLUS_ERR_DBPREEXIT (integer) | ERR_DBPREEXIT | Exit condition caused by prexit() * procedure
DBPLUS_ERR_WAIT (integer) | ERR_WAIT | Wait a little (Simple only)
DBPLUS_ERR_CORRUPT_TUPLE (integer) | ERR_CORRUPT_TUPLE | A client sent a corrupt tuple
DBPLUS_ERR_WARNING0 (integer) | ERR_WARNING0 | The Simple routines encountered a non fatal error which was corrected
DBPLUS_ERR_PANIC (integer) | ERR_PANIC | The server should not really die but after a disaster send ERR_PANIC to all its clients
DBPLUS_ERR_FIFO (integer) | ERR_FIFO | Can't create a fifo
DBPLUS_ERR_PERM (integer) | ERR_PERM | Permission denied
DBPLUS_ERR_TCL (integer) | ERR_TCL | TCL_error
DBPLUS_ERR_RESTRICTED (integer) | ERR_RESTRICTED | Only two users
DBPLUS_ERR_USER (integer) | ERR_USER | An error in the use of the library by an application programmer
DBPLUS_ERR_UNKNOWN (integer) | ERR_UNKNOWN |

Obsah

dbplus_add — Add a tuple to a relation
dbplus_aql — Perform AQL query
dbplus_chdir — Get/Set database virtual current directory
dbplus_close — Close a relation
dbplus_curr — Get current tuple from relation
dbplus_errcode — Get error string for given errorcode or last error
dbplus_errno — Get error code for last operation
dbplus_find — Set a constraint on a relation
dbplus_first — Get first tuple from relation
dbplus_flush — Flush all changes made on a relation
dbplus_freealllocks — Free all locks held by this client
dbplus_freelock — Release write lock on tuple
dbplus_freerlocks — Free all tuple locks on given relation
dbplus_getlock — Get a write lock on a tuple
dbplus_getunique — Get an id number unique to a relation
dbplus_info — Get information about a relation
dbplus_last — Get last tuple from relation
dbplus_lockrel — Request write lock on relation
dbplus_next — Get next tuple from relation
dbplus_open — Open relation file
dbplus_prev — Get previous tuple from relation
dbplus_rchperm — Change relation permissions
dbplus_rcreate — Creates a new DB++ relation
dbplus_rcrtexact — Creates an exact but empty copy of a relation including indices
dbplus_rcrtlike — Creates an empty copy of a relation with default indices
dbplus_resolve — Resolve host information for relation
dbplus_restorepos — Restore position
dbplus_rkeys — Specify new primary key for a relation
dbplus_ropen — Open relation file local
dbplus_rquery — Perform local (raw) AQL query
dbplus_rrename — Rename a relation
dbplus_rsecindex — Create a new secondary index for a relation
dbplus_runlink — Remove relation from filesystem
dbplus_rzap — Remove all tuples from relation
dbplus_savepos — Save position
dbplus_setindex — Set index
dbplus_setindexbynumber — Set index by number
dbplus_sql — Perform SQL query
dbplus_tcl — Execute TCL code on server side
dbplus_tremove — Remove tuple and return new current tuple
dbplus_undo — Undo
dbplus_undoprepare — Prepare undo
dbplus_unlockrel — Give up write lock on relation
dbplus_unselect — Remove a constraint from relation
dbplus_update — Update specified tuple in relation
dbplus_xlockrel — Request exclusive lock on relation
dbplus_xunlockrel — Free exclusive lock on relation
Předcházející | Nahoru | Další
timezone_transitions_get | Domů | dbplus_add


dbplus_add

(PHP 4 >= 4.0.7, PECL dbplus:0.9)

dbplus_add — Add a tuple to a relation

Popis

int dbplus_add ( resource $relation, array $tuple )

Adds a tuple to a relation.

Seznam parametrů

relation

tuple

An array of attribute/value pairs to be inserted into the given relation.

After successful execution this array will contain the complete data of the newly created tuple, including all implicitly set domain fields like sequences.

Návratové hodnoty

The function will return DBPLUS_ERR_NOERR on success or a db++ error code on failure.

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Viz také

dbplus_errcode()

Předcházející | Nahoru | Další
XXIV. DB++ Functions | Domů | dbplus_aql


dbplus_aql

(PHP 4 >= 4.0.7, PECL dbplus:0.9)

dbplus_aql — Perform AQL query

Popis

resource dbplus_aql ( string $query [, string $server [, string $dbpath]] )

Executes an AQL query on the given server and dbpath.

Seznam parametrů

query

The AQL query to be executed. Further information on the AQL A... Query Language is provided in the original db++ manual.

server

dbpath

Návratové hodnoty

Returns a relation handle on success. The result data may be fetched from this relation by calling dbplus_next() and dbplus_current(). Other relation access functions will not work on a result relation.

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
dbplus_add | Domů | dbplus_chdir


dbplus_chdir

(PHP 4 >= 4.0.7, PECL dbplus:0.9)

dbplus_chdir — Get/Set database virtual current directory

Popis

string dbplus_chdir ( [string $newdir] )

Changes the virtual current directory where relation files will be looked for by dbplus_open().

Seznam parametrů

newdir

The new directory for relation files. You can omit this parameter to query the current working directory.

Návratové hodnoty

Returns the absolute path of the current directory.

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
dbplus_aql | Domů | dbplus_close


dbplus_close

(PHP 4 >= 4.0.7, PECL dbplus:0.9)

dbplus_close — Close a relation

Popis

mixed dbplus_close ( resource $relation )

Closes a relation previously opened by dbplus_open().

Seznam parametrů

relation

A relation opened by dbplus_open().

Návratové hodnoty

Returns TRUE on success or DBPLUS_ERR_UNKNOWN on failure.

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
dbplus_chdir | Domů | dbplus_curr


dbplus_curr

(PHP 4 >= 4.0.7, PECL dbplus:0.9)

dbplus_curr — Get current tuple from relation

Popis

int dbplus_curr ( resource $relation, array &$tuple )

Reads the data for the current tuple for the given relation.

Seznam parametrů

relation

A relation opened by dbplus_open().

tuple

The data will be passed back in this parameter, as an associative array.

Návratové hodnoty

The function will return zero (aka. DBPLUS_ERR_NOERR) on success or a db++ error code on failure.

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Viz také

dbplus_first()
dbplus_prev()
dbplus_next()
dbplus_last()
dbplus_errcode()

Předcházející | Nahoru | Další
dbplus_close | Domů | dbplus_errcode


dbplus_errcode

(PHP 4 >= 4.0.7, PECL dbplus:0.9)

dbplus_errcode — Get error string for given errorcode or last error

Popis

string dbplus_errcode ( [int $errno] )

Returns a clear error string for the given error code.

Seznam parametrů

errno

The error code. If not provided, the result code of the last db++ operation is assumed.

Návratové hodnoty

Returns the error message.

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
dbplus_curr | Domů | dbplus_errno


dbplus_errno

(PHP 4 >= 4.0.7, PECL dbplus:0.9)

dbplus_errno — Get error code for last operation

Popis

int dbplus_errno ( void )

Returns the error code returned by the last db++ operation.

Návratové hodnoty

Returns the error code, as an integer.

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Viz také

dbplus_errcode()

Předcházející | Nahoru | Další
dbplus_errcode | Domů | dbplus_find


dbplus_find

(PHP 4 >= 4.0.7, PECL dbplus:0.9)

dbplus_find — Set a constraint on a relation

Popis

int dbplus_find ( resource $relation, array $constraints, mixed $tuple )

Places a constraint on the given relation.

Further calls to functions like dbplus_curr() or dbplus_next() will only return tuples matching the given constraints.

Seznam parametrů

relation

A relation opened by dbplus_open().

constraints

Constraints are triplets of strings containing of a domain name, a comparison operator and a comparison value. The constraints parameter array may consist of a collection of string arrays, each of which contains a domain, an operator and a value, or of a single string array containing a multiple of three elements.

The comparison operator may be one of the following strings: '==', '>', '>=', '<', '<=', '!=', '~' for a regular expression match and 'BAND' or 'BOR' for bitwise operations.

tuple

Návratové hodnoty

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Viz také

dbplus_unselect()

Předcházející | Nahoru | Další
dbplus_errno | Domů | dbplus_first


dbplus_first

(PHP 4 >= 4.0.7, PECL dbplus:0.9)

dbplus_first — Get first tuple from relation

Popis

int dbplus_first ( resource $relation, array &$tuple )

Reads the data for the first tuple for the given relation, makes it the current tuple and pass it back as an associative array in tuple.

Seznam parametrů

relation

A relation opened by dbplus_open().

tuple

Návratové hodnoty

Returns DBPLUS_ERR_NOERR on success or a db++ error code on failure.

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Viz také

dbplus_curr()
dbplus_prev()
dbplus_next()
dbplus_last()
dbplus_errcode()

Předcházející | Nahoru | Další
dbplus_find | Domů | dbplus_flush


dbplus_flush

(PHP 4 >= 4.0.7, PECL dbplus:0.9)

dbplus_flush — Flush all changes made on a relation

Popis

int dbplus_flush ( resource $relation )

Writes all changes applied to relation since the last flush to disk.

Seznam parametrů

relation

A relation opened by dbplus_open().

Návratové hodnoty

Returns DBPLUS_ERR_NOERR on success or a db++ error code on failure.

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Viz také

dbplus_errcode()

Předcházející | Nahoru | Další
dbplus_first | Domů | dbplus_freealllocks


dbplus_freealllocks

(PHP 4 >= 4.0.7, PECL dbplus:0.9)

dbplus_freealllocks — Free all locks held by this client

Popis

int dbplus_freealllocks ( void )

Frees all tuple locks held by this client.

Návratové hodnoty

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Viz také

dbplus_getlock()
dbplus_freelock()
dbplus_freerlocks()

Předcházející | Nahoru | Další
dbplus_flush | Domů | dbplus_freelock


dbplus_freelock

(PHP 4 >= 4.0.7, PECL dbplus:0.9)

dbplus_freelock — Release write lock on tuple

Popis

int dbplus_freelock ( resource $relation, string $tuple )

Releases a write lock on the given tuple previously obtained by dbplus_getlock().

Seznam parametrů

relation

A relation opened by dbplus_open().

tuple

Návratové hodnoty

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Viz také

dbplus_getlock()
dbplus_freerlocks()
dbplus_freealllocks()

Předcházející | Nahoru | Další
dbplus_freealllocks | Domů | dbplus_freerlocks


dbplus_freerlocks

(PHP 4 >= 4.0.7, PECL dbplus:0.9)

dbplus_freerlocks — Free all tuple locks on given relation

Popis

int dbplus_freerlocks ( resource $relation )

Frees all tuple locks held on the given relation.

Seznam parametrů

relation

A relation opened by dbplus_open().

Návratové hodnoty

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Viz také

dbplus_getlock()
dbplus_freelock()
dbplus_freealllocks()

Předcházející | Nahoru | Další
dbplus_freelock | Domů | dbplus_getlock


dbplus_getlock

(PHP 4 >= 4.0.7, PECL dbplus:0.9)

dbplus_getlock — Get a write lock on a tuple

Popis

int dbplus_getlock ( resource $relation, string $tuple )

Requests a write lock on the specified tuple.

Seznam parametrů

relation

A relation opened by dbplus_open().

tuple

Návratové hodnoty

Returns zero on success or a non-zero error code, especially DBPLUS_ERR_WLOCKED on failure.

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Viz také

dbplus_freelock()
dbplus_freerlocks()
dbplus_freealllocks()

Předcházející | Nahoru | Další
dbplus_freerlocks | Domů | dbplus_getunique


dbplus_getunique

(PHP 4 >= 4.0.7, PECL dbplus:0.9)

dbplus_getunique — Get an id number unique to a relation

Popis

int dbplus_getunique ( resource $relation, int $uniqueid )

Obtains a number guaranteed to be unique for the given relation and will pass it back in the variable given as uniqueid.

Seznam parametrů

relation

A relation opened by dbplus_open().

uniqueid

Návratové hodnoty

Returns DBPLUS_ERR_NOERR on success or a db++ error code on failure.

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
dbplus_getlock | Domů | dbplus_info


dbplus_info

(PHP 4 >= 4.0.7, PECL dbplus:0.9)

dbplus_info — Get information about a relation

Popis

int dbplus_info ( resource $relation, string $key, array &$result )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

relation

A relation opened by dbplus_open().

key

result

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
dbplus_getunique | Domů | dbplus_last


dbplus_last

(PHP 4 >= 4.0.7, PECL dbplus:0.9)

dbplus_last — Get last tuple from relation

Popis

int dbplus_last ( resource $relation, array &$tuple )

Reads the data for the last tuple for the given relation, makes it the current tuple and pass it back as an associative array in tuple.

Seznam parametrů

relation

A relation opened by dbplus_open().

tuple

Návratové hodnoty

Returns DBPLUS_ERR_NOERR on success or a db++ error code on failure.

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Viz také

dbplus_first()
dbplus_curr()
dbplus_prev()
dbplus_next()

Předcházející | Nahoru | Další
dbplus_info | Domů | dbplus_lockrel


dbplus_lockrel

(PHP 4 >= 4.0.7, PECL dbplus:0.9)

dbplus_lockrel — Request write lock on relation

Popis

int dbplus_lockrel ( resource $relation )

Requests a write lock on the given relation.

Other clients may still query the relation, but can't alter it while it is locked.

Seznam parametrů

relation

A relation opened by dbplus_open().

Návratové hodnoty

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
dbplus_last | Domů | dbplus_next


dbplus_next

(PHP 4 >= 4.0.7, PECL dbplus:0.9)

dbplus_next — Get next tuple from relation

Popis

int dbplus_next ( resource $relation, array &$tuple )

Reads the data for the next tuple for the given relation, makes it the current tuple and will pass it back as an associative array in tuple.

Seznam parametrů

relation

A relation opened by dbplus_open().

tuple

Návratové hodnoty

Returns DBPLUS_ERR_NOERR on success or a db++ error code on failure.

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Viz také

dbplus_first()
dbplus_curr()
dbplus_prev()
dbplus_last()

Předcházející | Nahoru | Další
dbplus_lockrel | Domů | dbplus_open


dbplus_open

(PHP 4 >= 4.0.7, PECL dbplus:0.9)

dbplus_open — Open relation file

Popis

resource dbplus_open ( string $name )

Opens the given relation file.

Seznam parametrů

name

Can be either a file name or a relative or absolute path name. This will be mapped in any case to an absolute relation file path on a specific host machine and server.

Návratové hodnoty

On success a relation file resource (cursor) is returned which must be used in any subsequent commands referencing the relation. Failure leads to a zero return value, the actual error code may be asked for by calling dbplus_errno().

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
dbplus_next | Domů | dbplus_prev


dbplus_prev

(PHP 4 >= 4.0.7, PECL dbplus:0.9)

dbplus_prev — Get previous tuple from relation

Popis

int dbplus_prev ( resource $relation, array &$tuple )

Reads the data for the previous tuple for the given relation, makes it the current tuple and will pass it back as an associative array in tuple.

Seznam parametrů

relation

A relation opened by dbplus_open().

tuple

Návratové hodnoty

Returns DBPLUS_ERR_NOERR on success or a db++ error code on failure.

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Viz také

dbplus_first()
dbplus_curr()
dbplus_next()
dbplus_last()

Předcházející | Nahoru | Další
dbplus_open | Domů | dbplus_rchperm


dbplus_rchperm

(PHP 4 >= 4.0.7, PECL dbplus:0.9)

dbplus_rchperm — Change relation permissions

Popis

int dbplus_rchperm ( resource $relation, int $mask, string $user, string $group )

Changes access permissions as specified by mask, user and group. The values for these are operating system specific.

Seznam parametrů

relation

A relation opened by dbplus_open().

mask

user

group

Návratové hodnoty

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
dbplus_prev | Domů | dbplus_rcreate


dbplus_rcreate

(PHP 4 >= 4.0.7, PECL dbplus:0.9)

dbplus_rcreate — Creates a new DB++ relation

Popis

resource dbplus_rcreate ( string $name, mixed $domlist [, bool $overwrite] )

Creates a new relation. Any existing relation sharing the same name will be overwritten if the relation is currently not in use and overwrite is set to TRUE.

Seznam parametrů

name

domlist

A combination of domains. May be passed as a single domain name string or as an array of domain names.

This parameter should contain the domain specification for the new relation within an array of domain description strings. A domain description string consists of a domain name unique to this relation, a slash and a type specification character. See the db++ documentation, especially the dbcreate(1) manpage, for a description of available type specifiers and their meanings.

Poznámka: This function will also accept a string with space delimited domain description strings, but it is recommended to use an array

overwrite

Návratové hodnoty

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
dbplus_rchperm | Domů | dbplus_rcrtexact


dbplus_rcrtexact

(PHP 4 >= 4.0.7, PECL dbplus:0.9)

dbplus_rcrtexact — Creates an exact but empty copy of a relation including indices

Popis

mixed dbplus_rcrtexact ( string $name, resource $relation [, bool $overwrite] )

dbplus_rcrtexact() will create an exact but empty copy of the given relation under a new name.

Seznam parametrů

name

relation

The copied relation, opened by dbplus_open().

overwrite

An existing relation by the same name will only be overwritten if this parameter is set to TRUE and no other process is currently using the relation.

Návratové hodnoty

Returns resource on success or DBPLUS_ERR_UNKNOWN on failure.

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
dbplus_rcreate | Domů | dbplus_rcrtlike


dbplus_rcrtlike

(PHP 4 >= 4.0.7, PECL dbplus:0.9)

dbplus_rcrtlike — Creates an empty copy of a relation with default indices

Popis

mixed dbplus_rcrtlike ( string $name, resource $relation [, int $overwrite] )

dbplus_rcrtexact() will create an empty copy of the given relation under a new name, but with default indices.

Seznam parametrů

name

relation

The copied relation, opened by dbplus_open().

overwrite

An existing relation by the same name will only be overwritten if this parameter is set to TRUE and no other process is currently using the relation.

Návratové hodnoty

Returns resource on success or DBPLUS_ERR_UNKNOWN on failure.

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
dbplus_rcrtexact | Domů | dbplus_resolve


dbplus_resolve

(PHP 4 >= 4.0.7, PECL dbplus:0.9)

dbplus_resolve — Resolve host information for relation

Popis

array dbplus_resolve ( string $relation_name )

dbplus_resolve() will try to resolve the given relation_name and find out internal server id, real hostname and the database path on this host.

Seznam parametrů

relation_name

The relation name.

Návratové hodnoty

Returns an array containing these values under the keys sid, host and host_path or FALSE on error.

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Viz také

dbplus_tcl()

Předcházející | Nahoru | Další
dbplus_rcrtlike | Domů | dbplus_restorepos


dbplus_restorepos

(PHP 4 >= 4.0.7, PECL dbplus:0.9)

dbplus_restorepos — Restore position

Popis

int dbplus_restorepos ( resource $relation, array $tuple )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

relation

A relation opened by dbplus_open().

tuple

Návratové hodnoty

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
dbplus_resolve | Domů | dbplus_rkeys


dbplus_rkeys

(PHP 4 >= 4.0.7, PECL dbplus:0.9)

dbplus_rkeys — Specify new primary key for a relation

Popis

mixed dbplus_rkeys ( resource $relation, mixed $domlist )

dbplus_rkeys() will replace the current primary key for relation with the combination of domains specified by domlist.

Seznam parametrů

relation

A relation opened by dbplus_open().

domlist

A combination of domains. May be passed as a single domain name string or as an array of domain names.

Návratové hodnoty

Returns resource on success or DBPLUS_ERR_UNKNOWN on failure.

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
dbplus_restorepos | Domů | dbplus_ropen


dbplus_ropen

(PHP 4 >= 4.0.7, PECL dbplus:0.9)

dbplus_ropen — Open relation file local

Popis

resource dbplus_ropen ( string $name )

dbplus_ropen() will open the relation file locally for quick access without any client/server overhead. Access is read only and only dbplus_current() and dbplus_next() may be applied to the returned relation.

Seznam parametrů

name

Návratové hodnoty

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
dbplus_rkeys | Domů | dbplus_rquery


dbplus_rquery

(PHP 4 >= 4.0.7, PECL dbplus:0.9)

dbplus_rquery — Perform local (raw) AQL query

Popis

resource dbplus_rquery ( string $query [, string $dbpath] )

dbplus_rquery() performs a local (raw) AQL query using an AQL interpreter embedded into the db++ client library. dbplus_rquery() is faster than dbplus_aql() but will work on local data only.

Seznam parametrů

query

dbpath

Návratové hodnoty

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
dbplus_ropen | Domů | dbplus_rrename


dbplus_rrename

(PHP 4 >= 4.0.7, PECL dbplus:0.9)

dbplus_rrename — Rename a relation

Popis

int dbplus_rrename ( resource $relation, string $name )

dbplus_rrename() will change the name of relation to name.

Seznam parametrů

relation

A relation opened by dbplus_open().

name

Návratové hodnoty

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
dbplus_rquery | Domů | dbplus_rsecindex


dbplus_rsecindex

(PHP 4 >= 4.0.7, PECL dbplus:0.9)

dbplus_rsecindex — Create a new secondary index for a relation

Popis

mixed dbplus_rsecindex ( resource $relation, mixed $domlist, int $type )

dbplus_rsecindex() will create a new secondary index for relation with consists of the domains specified by domlist and is of type type

Seznam parametrů

relation

A relation opened by dbplus_open().

domlist

A combination of domains. May be passed as a single domain name string or as an array of domain names.

type

Návratové hodnoty

Returns resource on success or DBPLUS_ERR_UNKNOWN on failure.

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
dbplus_rrename | Domů | dbplus_runlink


dbplus_runlink

(PHP 4 >= 4.0.7, PECL dbplus:0.9)

dbplus_runlink — Remove relation from filesystem

Popis

int dbplus_runlink ( resource $relation )

dbplus_unlink() will close and remove the relation.

Seznam parametrů

relation

A relation opened by dbplus_open().

Návratové hodnoty

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
dbplus_rsecindex | Domů | dbplus_rzap


dbplus_rzap

(PHP 4 >= 4.0.7, PECL dbplus:0.9)

dbplus_rzap — Remove all tuples from relation

Popis

int dbplus_rzap ( resource $relation )

dbplus_rzap() will remove all tuples from relation.

Seznam parametrů

relation

A relation opened by dbplus_open().

Návratové hodnoty

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
dbplus_runlink | Domů | dbplus_savepos


dbplus_savepos

(PHP 4 >= 4.0.7, PECL dbplus:0.9)

dbplus_savepos — Save position

Popis

int dbplus_savepos ( resource $relation )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

relation

A relation opened by dbplus_open().

Návratové hodnoty

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
dbplus_rzap | Domů | dbplus_setindex


dbplus_setindex

(PHP 4 >= 4.0.7, PECL dbplus:0.9)

dbplus_setindex — Set index

Popis

int dbplus_setindex ( resource $relation, string $idx_name )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

relation

A relation opened by dbplus_open().

idx_name

Návratové hodnoty

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
dbplus_savepos | Domů | dbplus_setindexbynumber


dbplus_setindexbynumber

(PHP 4 >= 4.0.7, PECL dbplus:0.9)

dbplus_setindexbynumber — Set index by number

Popis

int dbplus_setindexbynumber ( resource $relation, int $idx_number )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

relation

A relation opened by dbplus_open().

idx_number

Návratové hodnoty

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
dbplus_setindex | Domů | dbplus_sql


dbplus_sql

(PHP 4 >= 4.0.7, PECL dbplus:0.9)

dbplus_sql — Perform SQL query

Popis

resource dbplus_sql ( string $query [, string $server [, string $dbpath]] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

query

server

dbpath

Návratové hodnoty

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
dbplus_setindexbynumber | Domů | dbplus_tcl


dbplus_tcl

(PHP 4 >= 4.0.7, PECL dbplus:0.9)

dbplus_tcl — Execute TCL code on server side

Popis

string dbplus_tcl ( int $sid, string $script )

A db++ server will prepare a TCL interpreter for each client connection. This interpreter will enable the server to execute TCL code provided by the client as a sort of stored procedures to improve the performance of database operations by avoiding client/server data transfers and context switches.

dbplus_tcl() needs to pass the client connection id the TCL script code should be executed by. dbplus_resolve() will provide this connection id. The function will return whatever the TCL code returns or a TCL error message if the TCL code fails.

Seznam parametrů

sid

script

Návratové hodnoty

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Viz také

dbplus_resolve()

Předcházející | Nahoru | Další
dbplus_sql | Domů | dbplus_tremove


dbplus_tremove

(PHP 4 >= 4.0.7, PECL dbplus:0.9)

dbplus_tremove — Remove tuple and return new current tuple

Popis

int dbplus_tremove ( resource $relation, array $tuple [, array &$current] )

dbplus_tremove() removes tuple from relation if it perfectly matches a tuple within the relation. current, if given, will contain the data of the new current tuple after calling dbplus_tremove().

Seznam parametrů

relation

A relation opened by dbplus_open().

tuple

current

Návratové hodnoty

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
dbplus_tcl | Domů | dbplus_undo


dbplus_undo

(PHP 4 >= 4.0.7, PECL dbplus:0.9)

dbplus_undo — Undo

Popis

int dbplus_undo ( resource $relation )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

relation

A relation opened by dbplus_open().

Návratové hodnoty

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
dbplus_tremove | Domů | dbplus_undoprepare


dbplus_undoprepare

(PHP 4 >= 4.0.7, PECL dbplus:0.9)

dbplus_undoprepare — Prepare undo

Popis

int dbplus_undoprepare ( resource $relation )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

relation

A relation opened by dbplus_open().

Návratové hodnoty

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
dbplus_undo | Domů | dbplus_unlockrel


dbplus_unlockrel

(PHP 4 >= 4.0.7, PECL dbplus:0.9)

dbplus_unlockrel — Give up write lock on relation

Popis

int dbplus_unlockrel ( resource $relation )

Release a write lock previously obtained by dbplus_lockrel().

Seznam parametrů

relation

A relation opened by dbplus_open().

Návratové hodnoty

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
dbplus_undoprepare | Domů | dbplus_unselect


dbplus_unselect

(PHP 4 >= 4.0.7, PECL dbplus:0.9)

dbplus_unselect — Remove a constraint from relation

Popis

int dbplus_unselect ( resource $relation )

Calling dbplus_unselect() will remove a constraint previously set by dbplus_find() on relation.

Seznam parametrů

relation

A relation opened by dbplus_open().

Návratové hodnoty

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
dbplus_unlockrel | Domů | dbplus_update


dbplus_update

(PHP 4 >= 4.0.7, PECL dbplus:0.9)

dbplus_update — Update specified tuple in relation

Popis

int dbplus_update ( resource $relation, array $old, array $new )

dbplus_update() replaces the old tuple with the data from the new one, only if the old completely matches a tuple within relation.

Seznam parametrů

relation

A relation opened by dbplus_open().

old

The old tuple.

new

The new tuple.

Návratové hodnoty

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
dbplus_unselect | Domů | dbplus_xlockrel


dbplus_xlockrel

(PHP 4 >= 4.0.7, PECL dbplus:0.9)

dbplus_xlockrel — Request exclusive lock on relation

Popis

int dbplus_xlockrel ( resource $relation )

Request an exclusive lock on relation preventing even read access from other clients.

Seznam parametrů

relation

A relation opened by dbplus_open().

Návratové hodnoty

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Viz také

dbplus_xunlockrel()

Předcházející | Nahoru | Další
dbplus_update | Domů | dbplus_xunlockrel


dbplus_xunlockrel

(PHP 4 >= 4.0.7, PECL dbplus:0.9)

dbplus_xunlockrel — Free exclusive lock on relation

Popis

int dbplus_xunlockrel ( resource $relation )

Releases an exclusive lock previously obtained by dbplus_xlockrel().

Seznam parametrů

relation

A relation opened by dbplus_open().

Návratové hodnoty

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
dbplus_xlockrel | Domů | XXV. Database (dbm-style) Abstraction Layer Functions


Direct IO Functions

Předcházející VI. Reference funkcí Další

XXIX. Direct IO Functions

Úvod

PHP supports the direct io functions as described in the Posix Standard (Section 6) for performing I/O functions at a lower level than the C-Language stream I/O functions (fopen(), fread(),..). The use of the DIO functions should be considered only when direct control of a device is needed. In all other cases, the standard filesystem functions are more than adequate.

Poznámka: Toto rozšíření bylo přesunuto do repozitáře PECL a již nebude součástí balíku PHP.5.1.0.

This extension is only available on Windows Platforms as of PHP 5.0.0

Požadavky

Tyto funkce jsou k dispozici jako součást standardního modulu, který je vždy dostupný.

Instalace

To get these functions to work, you have to configure PHP with --enable-dio.

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

c (integer)

F_DUPFD (integer)

F_GETFD (integer)

F_GETFL (integer)

F_GETLK (integer)

F_GETOWN (integer)

F_RDLCK (integer)

F_SETFL (integer)

F_SETLK (integer)

F_SETLKW (integer)

F_SETOWN (integer)

F_UNLCK (integer)

F_WRLCK (integer)

O_APPEND (integer)

O_ASYNC (integer)

O_CREAT (integer)

O_EXCL (integer)

O_NDELAY (integer)

O_NOCTTY (integer)

O_NONBLOCK (integer)

O_RDONLY (integer)

O_RDWR (integer)

O_SYNC (integer)

O_TRUNC (integer)

O_WRONLY (integer)

S_IRGRP (integer)

S_IROTH (integer)

S_IRUSR (integer)

S_IRWXG (integer)

S_IRWXO (integer)

S_IRWXU (integer)

S_IWGRP (integer)

S_IWOTH (integer)

S_IWUSR (integer)

S_IXGRP (integer)

S_IXOTH (integer)

S_IXUSR (integer)

Konfigurace běhu

Toto rozšíření nemá definováno žádné konfigurační direktivy.

Typy prostředků

One resource type is defined by this extension: a file descriptor returned by dio_open().

Obsah

dio_close — Closes the file descriptor given by fd
dio_fcntl — Performs a c library fcntl on fd
dio_open — Opens a new filename with specified permissions of flags and creation permissions of mode
dio_read — Reads bytes from a file descriptor
dio_seek — Seeks to pos on fd from whence
dio_stat — Gets stat information about the file descriptor fd
dio_tcsetattr — Sets terminal attributes and baud rate for a serial port
dio_truncate — Truncates file descriptor fd to offset bytes
dio_write — Writes data to fd with optional truncation at length
Předcházející | Nahoru | Další
dbx_sort | Domů | dio_close


dio_close

(PHP 4 >= 4.2.0, PHP 5 <= 5.0.5)

dio_close — Closes the file descriptor given by fd

Popis

void dio_close ( resource $fd )

The function dio_close() closes the file descriptor fd.

Seznam parametrů

fd

The file descriptor returned by dio_open().

Návratové hodnoty

Nevrací se žádná hodnota.

Příklady

Příklad 395. Closing an open file descriptor

<?php
$fd = dio_open('/dev/ttyS0', O_RDWR);

dio_close($fd);
?>

Viz také

dio_open()

Předcházející | Nahoru | Další
XXIX. Direct IO Functions | Domů | dio_fcntl


dio_fcntl

(PHP 4 >= 4.2.0, PHP 5 <= 5.0.5)

dio_fcntl — Performs a c library fcntl on fd

Popis

mixed dio_fcntl ( resource $fd, int $cmd [, mixed $args] )

The dio_fcntl() function performs the operation specified by cmd on the file descriptor fd. Some commands require additional arguments args to be supplied.

Poznámka: Tato funkce není implementována na platformách Windows.

Seznam parametrů

fd

The file descriptor returned by dio_open().

cmd

Can be one of the following operations:

  • F_SETLK - Lock is set or cleared. If the lock is held by someone else dio_fcntl() returns -1.

  • F_SETLKW - like F_SETLK, but in case the lock is held by someone else, dio_fcntl() waits until the lock is released.

  • F_GETLK - dio_fcntl() returns an associative array (as described above) if someone else prevents lock. If there is no obstruction key "type" will set to F_UNLCK.

  • F_DUPFD - finds the lowest numbered available file descriptor greater than or equal to args and returns them.

  • F_SETFL - Sets the file descriptors flags to the value specified by args, which can be O_APPEND, O_NONBLOCK or O_ASYNC. To use O_ASYNC you will need to use the PCNTL extension.

args

args is an associative array, when cmd is F_SETLK or F_SETLLW, with the following keys:

  • "start" - offset where lock begins

  • "length" - size of locked area. zero means to end of file

  • "wenth" - Where l_start is relative to: can be SEEK_SET, SEEK_END and SEEK_CUR

  • "type" - type of lock: can be F_RDLCK (read lock), F_WRLCK (write lock) or F_UNLCK (unlock)

Návratové hodnoty

Returns the result of the C call.

Příklady

Příklad 396. Setting and clearing a lock

<?php

$fd = dio_open('/dev/ttyS0', O_RDWR);

if (dio_fcntl($fd, F_SETLK, Array("type"=>F_WRLCK)) == -1) {
   // the file descriptor appears locked
   echo "The lock can not be cleared. It is held by someone else.";
} else {
   echo "Lock succesfully set/cleared";
}

dio_close($fd);
?>

Předcházející | Nahoru | Další
dio_close | Domů | dio_open


dio_open

(PHP 4 >= 4.2.0, PHP 5 <= 5.0.5)

dio_open — Opens a new filename with specified permissions of flags and creation permissions of mode

Popis

resource dio_open ( string $filename, int $flags [, int $mode] )

dio_open() opens a file and returns a new file descriptor for it.

Seznam parametrů

filename

The opened file.

flags

The flags parameter can also include any combination of the following flags:

  • O_CREAT - creates the file, if it doesn't already exist.

  • O_EXCL - if both, O_CREAT and O_EXCL are set, dio_open() fails, if the file already exists.

  • O_TRUNC - if the file exists, and its opened for write access, the file will be truncated to zero length.

  • O_APPEND - write operations write data at the end of the file.

  • O_NONBLOCK - sets non blocking mode.

mode

If flags is O_CREAT, mode will set the mode of the file (creation permissions).

  • O_RDONLY - opens the file for read access.

  • O_WRONLY - opens the file for write access.

  • O_RDWR - opens the file for both reading and writing.

Návratové hodnoty

A file descriptor or FALSE on error.

Příklady

Příklad 397. Opening a file descriptor

<?php

$fd = dio_open('/dev/ttyS0', O_RDWR | O_NOCTTY | O_NONBLOCK);

dio_close($fd);
?>

Viz také

dio_close()

Předcházející | Nahoru | Další
dio_fcntl | Domů | dio_read


dio_read

(PHP 4 >= 4.2.0, PHP 5 <= 5.0.5)

dio_read — Reads bytes from a file descriptor

Popis

string dio_read ( resource $fd [, int $len] )

The function dio_read() reads and returns len bytes from file with descriptor fd.

Seznam parametrů

fd

The file descriptor returned by dio_open().

len

The number of bytes to read. If not specified, dio_read() reads 1K sized block.

Návratové hodnoty

The bytes read from fd.

Viz také

dio_write()

Předcházející | Nahoru | Další
dio_open | Domů | dio_seek


dio_seek

(PHP 4 >= 4.2.0, PHP 5 <= 5.0.5)

dio_seek — Seeks to pos on fd from whence

Popis

int dio_seek ( resource $fd, int $pos [, int $whence] )

The function dio_seek() is used to change the file position of the given file descriptor.

Seznam parametrů

fd

The file descriptor returned by dio_open().

pos

The new position.

whence

Specifies how the position pos should be interpreted:

  • SEEK_SET (default) - specifies that pos is specified from the beginning of the file.

  • SEEK_CUR - Specifies that pos is a count of characters from the current file position. This count may be positive or negative.

  • SEEK_END - Specifies that pos is a count of characters from the end of the file. A negative count specifies a position within the current extent of the file; a positive count specifies a position past the current end. If you set the position past the current end, and actually write data, you will extend the file with zeros up to that position.

Návratové hodnoty

Příklady

Příklad 398. Positioning in a file

<?php

$fd = dio_open('/dev/ttyS0', O_RDWR);

dio_seek($fd, 10, SEEK_SET);
// position is now at 10 characters from the start of the file

dio_seek($fd, -2, SEEK_CUR);
// position is now at 8 characters from the start of the file

dio_seek($fd, -5, SEEK_END);
// position is now at 5 characters from the end of the file

dio_seek($fd, 10, SEEK_END);
// position is now at 10 characters past the end of the file.
// The 10 characters between the end of the file and the current
// position are filled with zeros.

dio_close($fd);
?>

Předcházející | Nahoru | Další
dio_read | Domů | dio_stat


dio_stat

(PHP 4 >= 4.2.0, PHP 5 <= 5.0.5)

dio_stat — Gets stat information about the file descriptor fd

Popis

array dio_stat ( resource $fd )

dio_stat() returns information about the given file descriptor.

Seznam parametrů

fd

The file descriptor returned by dio_open().

Návratové hodnoty

Returns an associative array with the following keys:

  • "device" - device

  • "inode" - inode

  • "mode" - mode

  • "nlink" - number of hard links

  • "uid" - user id

  • "gid" - group id

  • "device_type" - device type (if inode device)

  • "size" - total size in bytes

  • "blocksize" - blocksize

  • "blocks" - number of blocks allocated

  • "atime" - time of last access

  • "mtime" - time of last modification

  • "ctime" - time of last change

On error dio_stat() returns NULL.

Předcházející | Nahoru | Další
dio_seek | Domů | dio_tcsetattr


dio_tcsetattr

(PHP 4 >= 4.3.0, PHP 5 <= 5.0.5)

dio_tcsetattr — Sets terminal attributes and baud rate for a serial port

Popis

bool dio_tcsetattr ( resource $fd, array $options )

dio_tcsetattr() sets the terminal attributes and baud rate of the open fd.

Poznámka: Tato funkce není implementována na platformách Windows.

Seznam parametrů

fd

The file descriptor returned by dio_open().

options

The currently available options are:

  • 'baud' - baud rate of the port - can be 38400,19200,9600,4800,2400,1800, 1200,600,300,200,150,134,110,75 or 50, default value is 9600.

  • 'bits' - data bits - can be 8,7,6 or 5. Default value is 8.

  • 'stop' - stop bits - can be 1 or 2. Default value is 1.

  • 'parity' - can be 0,1 or 2. Default value is 0.

Návratové hodnoty

Nevrací se žádná hodnota.

Příklady

Příklad 399. Setting the baud rate on a serial port

<?php

$fd = dio_open('/dev/ttyS0', O_RDWR | O_NOCTTY | O_NONBLOCK);

dio_fcntl($fd, F_SETFL, O_SYNC);

dio_tcsetattr($fd, array(
  'baud' => 9600,
  'bits' => 8,
  'stop'  => 1,
  'parity' => 0
));

while (1) {

  $data = dio_read($fd, 256);

  if ($data) {
      echo $data;
  }
}

?>

Předcházející | Nahoru | Další
dio_stat | Domů | dio_truncate


dio_truncate

(PHP 4 >= 4.2.0, PHP 5 <= 5.0.5)

dio_truncate — Truncates file descriptor fd to offset bytes

Popis

bool dio_truncate ( resource $fd, int $offset )

dio_truncate() truncates a file to at most offset bytes in size.

If the file previously was larger than this size, the extra data is lost. If the file previously was shorter, it is unspecified whether the file is left unchanged or is extended. In the latter case the extended part reads as zero bytes.

Poznámka: Tato funkce není implementována na platformách Windows.

Seznam parametrů

fd

The file descriptor returned by dio_open().

offset

The offset in bytes.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
dio_tcsetattr | Domů | dio_write


dio_write

(PHP 4 >= 4.2.0, PHP 5 <= 5.0.5)

dio_write — Writes data to fd with optional truncation at length

Popis

int dio_write ( resource $fd, string $data [, int $len] )

dio_write() writes up to len bytes from data to file fd.

Seznam parametrů

fd

The file descriptor returned by dio_open().

data

The written data.

len

The length of data to write in bytes. If not specified, the function writes all the data to the specified file.

Návratové hodnoty

Returns the number of bytes written to fd.

Viz také

dio_read()

Předcházející | Nahoru | Další
dio_truncate | Domů | XXX. Adresářové funkce


Adresářové funkce

Předcházející VI. Reference funkcí Další

XXX. Adresářové funkce

Úvod

Požadavky

Tyto funkce jsou k dispozici jako součást standardního modulu, který je vždy dostupný.

Instalace

K používání těchto funkcí není třeba žádná instalace, jsou součástí jádra PHP.

Konfigurace běhu

Toto rozšíření nemá definováno žádné konfigurační direktivy.

Typy prostředků

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

DIRECTORY_SEPARATOR (string)
PATH_SEPARATOR (string)

Poznámka: The PATH_SEPARATOR was introduced with PHP 4.3.0-RC2.

Viz také

Pro příbuzné funkce jako dirname(),
is_dir(), mkdir() a
rmdir(), viz sekci
Filesystem.

Obsah

chdir — change directory
chroot — Change the root directory
dir — directory class
closedir — Zavírá otevřený adresář
getcwd — Získává aktuální pracovní adresář
opendir — Otevře adresář
readdir — Přečte položku z deskriptoru adresáře
rewinddir — návrat na začátek adresáře
scandir — List files and directories inside the specified path
Předcházející | Nahoru | Další
dio_write | Domů | chdir


chdir

(PHP 4, PHP 5)

chdir — change directory

Popis

bool chdir ( string $directory )

Mění aktuální adresář PHP na directory. Pokud se nepodařilo změnít adresář, vrací FALSE, jinak TRUE.

Předcházející | Nahoru | Další
XXX. Adresářové funkce | Domů | chroot


chroot

(PHP 4 >= 4.0.5, PHP 5)

chroot — Change the root directory

Popis

bool chroot ( string $directory )

Changes the root directory of the current process to directory.

This function is only available if your system supports it and you're using the CLI, CGI or Embed SAPI. Also, this function requires root privileges.

Seznam parametrů

directory

The new directory

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Poznámky

Poznámka: Tato funkce není implementována na platformách Windows.

Předcházející | Nahoru | Další
chdir | Domů | dir


dir

(PHP 4, PHP 5)

dir — directory class

Popis

string read ( void )
void rewind ( void )
void close ( void )

Pseudo-objektově orientovaný mechanismus pro čtení adresáře. Otevře zadaný directory. Po otevření adresáře jsou přístupné dvě vlastnosti. Vlastnost handle je použitelná s jinými adresářovými funkcemi jako readdir(), rewinddir() a closedir(). Hodnotou vlastnosti path je cesta k otevřenému adresáři. Dále jsou přístupné tři metody: read, rewind a close.

Příklad 400. dir() příklad

$d = dir("/etc");
echo "Handle: ".$d->handle."<br>\n";
echo "Path: ".$d->path."<br>\n";
while($entry=$d->read()) {
    echo $entry."<br>\n";
}
$d->close();

Předcházející | Nahoru | Další
chroot | Domů | closedir


closedir

(PHP 4, PHP 5)

closedir — Zavírá otevřený adresář

Popis

void closedir ( resource $dir_handle )

Zavírá proud z adresáře specifikovaný v dir_handle. Proud musí pocházet z funkce opendir().

Předcházející | Nahoru | Další
dir | Domů | getcwd


getcwd

(PHP 4, PHP 5)

getcwd — Získává aktuální pracovní adresář

Popis

string getcwd ( void )

Vrací aktuální pracovní adresář.

Předcházející | Nahoru | Další
closedir | Domů | opendir


opendir

(PHP 4, PHP 5)

opendir — Otevře adresář

Popis

resource opendir ( string $path [, resource $context] )

Vrací deskriptor adresáře použitelný v následných voláních closedir(), readdir(), a rewinddir().

Předcházející | Nahoru | Další
getcwd | Domů | readdir


readdir

(PHP 4, PHP 5)

readdir — Přečte položku z deskriptoru adresáře

Popis

string readdir ( resource $dir_handle )

Vrací název dalšího souboru v adresáři. Názvy souborů nejsou nijak tříděny.

Příklad 401. Vypiš všechny soubory v adresáři

// Note that !== did not exist until 4.0.0-RC2
<?php
$handle=opendir('.');
echo "Directory handle: $handle\n";
echo "Files:\n";
while (($file = readdir($handle))!==false) {
    echo "$file\n";
}
closedir($handle);
?>

Všimněte si, že readdir() vrací také . a .. položky (odkaz na sebe sama a na nadřazený adresář. Pokud je nechcete, můžete je snadno vynechat:

Příklad 402. Vypiš všechny soubory v adresáři a vynech . a ..

<?php
$handle=opendir('.');
while (false!==($file = readdir($handle))) {
    if ($file != "." && $file != "..") {
        echo "$file\n";
    }
}
closedir($handle);
?>

Předcházející | Nahoru | Další
opendir | Domů | rewinddir


rewinddir

(PHP 4, PHP 5)

rewinddir — návrat na začátek adresáře

Popis

void rewinddir ( resource $dir_handle )

Vrací adresářový proud odkazovaný deskriptorem dir_handle na začátek adresáře.

Předcházející | Nahoru | Další
readdir | Domů | scandir


scandir

(PHP 5)

scandir — List files and directories inside the specified path

Popis

array scandir ( string $directory [, int $sorting_order [, resource $context]] )

Returns an array of files and directories from the directory.

Seznam parametrů

directory

The directory that will be scanned.

sorting_order

By default, the sorted order is alphabetical in ascending order. If the optional sorting_order is used (set to 1), then the sort order is alphabetical in descending order.

context

For a description of the context parameter, refer to the streams section of the manual.

Návratové hodnoty

Returns an array of filenames on success, or FALSE on failure. If directory is not a directory, then boolean FALSE is returned, and an error of level E_WARNING is generated.

Příklady

Příklad 403. A simple scandir() example

<?php
$dir    = '/tmp';
$files1 = scandir($dir);
$files2 = scandir($dir, 1);

print_r($files1);
print_r($files2);
?>

Výše uvedený příklad vypíše něco jako:

Array
(
    [0] => .
    [1] => ..
    [2] => bar.php
    [3] => foo.txt
    [4] => somedir
)
Array
(
    [0] => somedir
    [1] => foo.txt
    [2] => bar.php
    [3] => ..
    [4] => .
)

Příklad 404. PHP 4 alternatives to scandir()

<?php
$dir = "/tmp";
$dh  = opendir($dir);
while (false !== ($filename = readdir($dh))) {
    $files[] = $filename;
}

sort($files);

print_r($files);

rsort($files);

print_r($files);

?>

Výše uvedený příklad vypíše něco jako:

Array
(
    [0] => .
    [1] => ..
    [2] => bar.php
    [3] => foo.txt
    [4] => somedir
)
Array
(
    [0] => somedir
    [1] => foo.txt
    [2] => bar.php
    [3] => ..
    [4] => .
)

Poznámky

Tip

S touto funkcí můžete používat URL jako název souboru, pokud je zapnuta volba "fopen wrappers". Pro více detailů o tom, jak specifikovat název souboru, a O – „List of Supported Protocols/Wrappers“pro seznam porporovaných URL protokolů, viz fopen().

Viz také

opendir()
readdir()
glob()
is_dir()
sort()

Předcházející | Nahoru | Další
rewinddir | Domů | XXXI. DOM Functions


DOM Functions

Předcházející VI. Reference funkcí Další

XXXI. DOM Functions

Úvod

The DOM extension allows you to operate on XML documents through the DOM API with PHP 5.

For PHP 4, use DOM XML.

Poznámka: DOM extension uses UTF-8 encoding. Use utf8_encode() and utf8_decode() to work with texts in ISO-8859-1 encoding or Iconv for other encodings.

Instalace

K používání těchto funkcí není třeba žádná instalace, jsou součástí jádra PHP.

Předdefinované třídy

The API of the module follows the » DOM Level 3 standard as closely as possible. Consequently, the API is fully object-oriented. It is a good idea to have the DOM standard available when using this module.

This module defines a number of classes, which are explained in the following tables. Classes with an equivalent in the DOM standard are named DOMxxx.

DOMAttr

Extends DOMNode. The DOMAttr interface represents an attribute in an DOMElement object.

Konstruktory

  • DOMAttr->__construct() - construct a new DOMAttr object

Metody

  • DOMAttr->isId() - Checks if attribute is a defined ID

Vlastnosti

Tabulka 45.

Name | Type | Read-only | Description
name | string | yes | The name of the attribute
ownerElement | DOMElement | yes | The element which contains the attribute
schemaTypeInfo | bool | yes | Not implemented yet, always return NULL
specified | bool | yes | Not implemented yet, always return NULL
value | string | no | The value of the attribute

DOMCharacterData

Extends DOMNode.

Metody

  • DOMCharacterData->appendData() - Append a string to the end of the character data of the node

  • DOMCharacterData->deleteData() - Remove a range of characters from the node

  • DOMCharacterData->insertData() - Insert a string at the specified 16-bit unit offset

  • DOMCharacterData->replaceData() - Replace a substring within the DOMCharacterData node

  • DOMCharacterData->substringData() - Extracts a range of data from the node

Vlastnosti

Tabulka 46.

Name | Type | Read-only | Description
data | string | no | The contents of the node
length | int | yes | The length of the contents

DOMComment

Extends DOMCharacterData.

Konstruktory

  • DOMComment->__construct() - construct a new DOMComment object

DOMDocument

Extends DOMNode.

Konstruktory

  • DOMDocument->__construct() - construct a new DOMDocument object

Metody

  • DOMDocument->createAttribute() - Create new attribute

  • DOMDocument->createAttributeNS() - Create new attribute node with an associated namespace

  • DOMDocument->createCDATASection() - Create new cdata node

  • DOMDocument->createComment() - Create new comment node

  • DOMDocument->createDocumentFragment() - Create new document fragment

  • DOMDocument->createElement() - Create new element node

  • DOMDocument->createElementNS() - Create new element node with an associated namespace

  • DOMDocument->createEntityReference() - Create new entity reference node

  • DOMDocument->createProcessingInstruction() - Creates new PI node

  • DOMDocument->createTextNode() - Create new text node

  • DOMDocument->getElementById() - Searches for an element with a certain id

  • DOMDocument->getElementsByTagName() - Searches for all elements with given tag name

  • DOMDocument->getElementsByTagNameNS() - Searches for all elements with given tag name in specified namespace

  • DOMDocument->importNode() - Import node into current document

  • DOMDocument->load() - Load XML from a file

  • DOMDocument->loadHTML() - Load HTML from a string

  • DOMDocument->loadHTMLFile() - Load HTML from a file

  • DOMDocument->loadXML() - Load XML from a string

  • DOMDocument->normalizeDocument() - Normalizes the document

  • DOMDocument->relaxNGValidate() - Performs relaxNG validation on the document

  • DOMDocument->relaxNGValidateSource() - Performs relaxNG validation on the document

  • DOMDocument->registerNodeClass() - Register extended class used to create base node type (not DOM standard)

  • DOMDocument->save() - Dumps the internal XML tree back into a file

  • DOMDocument->saveHTML() - Dumps the internal document into a string using HTML formatting

  • DOMDocument->saveHTMLFile() - Dumps the internal document back into a file using HTML formatting

  • DOMDocument->saveXML() - Dumps the internal XML tree back into a string

  • DOMDocument->schemaValidate() - Validates a document based on a schema

  • DOMDocument->schemaValidateSource() - Validates a document based on a schema

  • DOMDocument->validate() - Validates the document based on its DTD

  • DOMDocument->xinclude() - Substitutes XIncludes in a DOMDocument Object

Vlastnosti

Tabulka 47.

Name | Type | Read-only | Description
actualEncoding | string | yes |
config | DOMConfiguration | yes |
doctype | DOMDocumentType | yes | The Document Type Declaration associated with this document.
documentElement | DOMElement | yes | This is a convenience attribute that allows direct access to the child node that is the document element of the document.
documentURI | string | no | The location of the document or NULL if undefined.
encoding | string | no |
formatOutput | bool | no |
implementation | DOMImplementation | yes | The DOMImplementation object that handles this document.
preserveWhiteSpace | bool | no | Do not remove redundant white space. Default to TRUE.
recover | bool | no |
resolveExternals | bool | no | Set it to TRUE to load external entities from a doctype declaration. This is useful for including character entities in your XML document.
standalone | bool | no |
strictErrorChecking | bool | no | Throws DOMException on errors. Default to TRUE.
substituteEntities | bool | no |
validateOnParse | bool | no | Loads and validates against the DTD. Default to FALSE.
version | string | no |
xmlEncoding | string | yes | An attribute specifying, as part of the XML declaration, the encoding of this document. This is NULL when unspecified or when it is not known, such as when the Document was created in memory.
xmlStandalone | bool | no | An attribute specifying, as part of the XML declaration, whether this document is standalone. This is FALSE when unspecified.
xmlVersion | string | no | An attribute specifying, as part of the XML declaration, the version number of this document. If there is no declaration and if this document supports the "XML" feature, the value is "1.0".

DOMDocumentFragment

Extends DOMNode.

Metody

  • DOMDocumentFragment->appendXML() - Append raw XML data (not DOM standard)

DOMDocumentType

Extends DOMNode

Each DOMDocument has a doctype attribute whose value is either NULL or a DOMDocumentType object.

Vlastnosti

Tabulka 48.

Name | Type | Read-only | Description
publicId | string | yes | The public identifier of the external subset.
systemId | string | yes | The system identifier of the external subset. This may be an absolute URI or not.
name | string | yes | The name of DTD; i.e., the name immediately following the DOCTYPE keyword.
entities | DOMNamedNodeMap | yes | A DOMNamedNodeMap containing the general entities, both external and internal, declared in the DTD.
notations | DOMNamedNodeMap | yes | A DOMNamedNodeMap containing the notations declared in the DTD.
internalSubset | string | yes | The internal subset as a string, or null if there is none. This is does not contain the delimiting square brackets.

DOMElement

Extends DOMNode.

Konstruktory

  • DOMElement->__construct() - construct a new DOMElement object

Metody

  • DOMElement->getAttribute() - Returns value of attribute

  • DOMElement->getAttributeNode() - Returns attribute node

  • DOMElement->getAttributeNodeNS() - Returns attribute node

  • DOMElement->getAttributeNS() - Returns value of attribute

  • DOMElement->getElementsByTagName() - Gets elements by tagname

  • DOMElement->getElementsByTagNameNS() - Get elements by namespaceURI and localName

  • DOMElement->hasAttribute() - Checks to see if attribute exists

  • DOMElement->hasAttributeNS() - Checks to see if attribute exists

  • DOMElement->removeAttribute() - Removes attribute

  • DOMElement->removeAttributeNode() - Removes attribute

  • DOMElement->removeAttributeNS() - Removes attribute

  • DOMElement->setAttribute() - Adds new attribute

  • DOMElement->setAttributeNode() - Adds new attribute node to element

  • DOMElement->setAttributeNodeNS() - Adds new attribute node to element

  • DOMElement->setAttributeNS() - Adds new attribute

  • DOMElement->setIdAttribute() - Declares the ID attribute

  • DOMElement->setIdAttributeNode() - Declares the ID attribute

  • DOMElement->setIdAttributeNS() - Declares the ID attribute

Vlastnosti

Tabulka 49.

Name | Type | Read-only | Description
schemaTypeInfo | bool | yes | Not implemented yet, always return NULL
tagName | string | yes | The element name

DOMEntity

Extends DOMNode

This interface represents a known entity, either parsed or unparsed, in an XML document.

Vlastnosti

Tabulka 50.

Name | Type | Read-only | Description
publicId | string | yes | The public identifier associated with the entity if specified, and NULL otherwise.
systemId | string | yes | The system identifier associated with the entity if specified, and NULL otherwise. This may be an absolute URI or not.
notationName | string | yes | For unparsed entities, the name of the notation for the entity. For parsed entities, this is NULL.
actualEncoding | string | no | An attribute specifying the encoding used for this entity at the time of parsing, when it is an external parsed entity. This is NULL if it an entity from the internal subset or if it is not known.
encoding | string | yes | An attribute specifying, as part of the text declaration, the encoding of this entity, when it is an external parsed entity. This is NULL otherwise.
version | string | yes | An attribute specifying, as part of the text declaration, the version number of this entity, when it is an external parsed entity. This is NULL otherwise.

DOMEntityReference

Extends DOMNode.

Konstruktory

  • DOMEntityReference->__construct() - construct a new DOMEntityReference object

DOMException

DOM operations raise exceptions under particular circumstances, i.e., when an operation is impossible to perform for logical reasons.

See also 21 – „Exceptions“.

Vlastnosti

Tabulka 51.

Name | Type | Read-only | Description
code | int | yes | An integer indicating the type of error generated

DOMImplementation

The DOMImplementation interface provides a number of methods for performing operations that are independent of any particular instance of the document object model.

Konstruktory

  • DOMImplementation->__construct() - construct a new DOMImplementation object

Metody

  • DOMImplementation->createDocument() - Creates a DOM Document object of the specified type with its document element

  • DOMImplementation->createDocumentType() - Creates an empty DOMDocumentType object

  • DOMImplementation->hasFeature() - Test if the DOM implementation implements a specific feature

DOMNamedNodeMap

Metody

  • DOMNamedNodeMap->getNamedItem() - Retrieves a node specified by name

  • DOMNamedNodeMap->getNamedItemNS() - Retrieves a node specified by local name and namespace URI

  • DOMNamedNodeMap->item() - Retrieves a node specified by index

DOMNode

Metody

  • DOMNode->appendChild() - Adds new child at the end of the children

  • DOMNode->cloneNode() - Clones a node

  • DOMNode->hasAttributes() - Checks if node has attributes

  • DOMNode->hasChildNodes() - Checks if node has children

  • DOMNode->insertBefore() - Adds a new child before a reference node

  • DOMNode->isDefaultNamespace() - Checks if the specified namespaceURI is the default namespace

  • DOMNode->isSameNode() - Indicates if two nodes are the same node

  • DOMNode->isSupported() - Checks if feature is supported for specified version

  • DOMNode->lookupNamespaceURI() - Returns namespace URI of the node based on the prefix

  • DOMNode->lookupPrefix() - Returns name space prefix of the node based on namespaceURI

  • DOMNode->normalize() - Normalizes the node

  • DOMNode->removeChild() - Removes child from list of children

  • DOMNode->replaceChild() - Replaces a child

Vlastnosti

Tabulka 52.

Name | Type | Read-only | Description
nodeName | string | yes | Returns the most accurate name for the current node type
nodeValue | string | no | The value of this node, depending on its type.
nodeType | int | yes | Gets the type of the node. One of the predefined XML_xxx_NODE constants
parentNode | DOMNode | yes | The parent of this node.
childNodes | DOMNodeList | yes | A DOMNodeList that contains all children of this node. If there are no children, this is an empty DOMNodeList.
firstChild | DOMNode | yes | The first child of this node. If there is no such node, this returns NULL.
lastChild | DOMNode | yes | The last child of this node. If there is no such node, this returns NULL.
previousSibling | DOMNode | yes | The node immediately preceding this node. If there is no such node, this returns NULL.
nextSibling | DOMNode | yes | The node immediately following this node. If there is no such node, this returns NULL.
attributes | DOMNamedNodeMap | yes | A DOMNamedNodeMap containing the attributes of this node (if it is a DOMElement) or NULL otherwise.
ownerDocument | DOMDocument | yes | The DOMDocument object associated with this node.
namespaceURI | string | yes | The namespace URI of this node, or NULL if it is unspecified.
prefix | string | no | The namespace prefix of this node, or NULL if it is unspecified.
localName | string | yes | Returns the local part of the qualified name of this node.
baseURI | string | yes | The absolute base URI of this node or NULL if the implementation wasn't able to obtain an absolute URI.
textContent | string | no | This attribute returns the text content of this node and its descendants.

DOMNodeList

Metody

  • DOMNodelist->item() - Retrieves a node specified by index

Vlastnosti

Tabulka 53.

Name | Type | Read-only | Description
length | int | yes | The number of nodes in the list. The range of valid child node indices is 0 to length - 1 inclusive.

DOMNotation

Extends DOMNode

Vlastnosti

Tabulka 54.

Name | Type | Read-only | Description
publicId | string | yes |
systemId | string | yes |

DOMProcessingInstruction

Extends DOMNode.

Konstruktory

  • DOMProcessingInstruction->__construct() - construct a new DOMProcessingInstruction object

Vlastnosti

Tabulka 55.

Name | Type | Read-only | Description
target | string | yes |
data | string | no |

DOMText

Extends DOMCharacterData.

Konstruktory

  • DOMText->__construct() - construct a new DOMText object

Metody

  • DOMText->isWhitespaceInElementContent() - Indicates whether this text node contains whitespace

  • DOMText->splitText() - Breaks the node into two nodes at the specified offset

Vlastnosti

Tabulka 56.

Name | Type | Read-only | Description
wholeText | string | yes |

DOMXPath

Konstruktory

  • DOMXPath->__construct() - construct a new DOMXPath object

Metody

  • DOMXPath->registerNamespace() - Registers the namespace with the DOMXpath object

  • DOMXPath->evaluate() - Evaluates the given XPath expression and returns a typed result if possible

  • DOMXPath->query() - Evaluates the given XPath expression

Vlastnosti

Tabulka 57.

Name | Type | Read-only | Description
document | DOMDocument |  |

Příklady

Many examples in this reference require an XML file. We will use book.xml that contains the following:

Příklad 405. book.xml

<?xml version="1.0" encoding="iso-8859-1" ?>
<!DOCTYPE book PUBLIC "-//OASIS//DTD DocBook XML V4.1.2//EN"
"http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd" [
]>
<book id="listing">
<title>My lists</title>
<chapter id="books">
<title>My books</title>
<para>
<informaltable>
<tgroup cols="4">
<thead>
<row>
<entry>Title</entry>
<entry>Author</entry>
<entry>Language</entry>
<entry>ISBN</entry>
</row>
</thead>
<tbody>
<row>
<entry>The Grapes of Wrath</entry>
<entry>John Steinbeck</entry>
<entry>en</entry>
<entry>0140186409</entry>
</row>
<row>
<entry>The Pearl</entry>
<entry>John Steinbeck</entry>
<entry>en</entry>
<entry>014017737X</entry>
</row>
<row>
<entry>Samarcande</entry>
<entry>Amine Maalouf</entry>
<entry>fr</entry>
<entry>2253051209</entry>
</row>
<!-- TODO: I have a lot of remaining books to add.. -->
</tbody>
</tgroup>
</informaltable>
</para>
</chapter>
</book>

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

Tabulka 58. XML constants

Constant | Value | Description
XML_ELEMENT_NODE (integer) | 1 | Node is a DOMElement
XML_ATTRIBUTE_NODE (integer) | 2 | Node is a DOMAttr
XML_TEXT_NODE (integer) | 3 | Node is a DOMText
XML_CDATA_SECTION_NODE (integer) | 4 | Node is a DOMCharacterData
XML_ENTITY_REF_NODE (integer) | 5 | Node is a DOMEntityReference
XML_ENTITY_NODE (integer) | 6 | Node is a DOMEntity
XML_PI_NODE (integer) | 7 | Node is a DOMProcessingInstruction
XML_COMMENT_NODE (integer) | 8 | Node is a DOMComment
XML_DOCUMENT_NODE (integer) | 9 | Node is a DOMDocument
XML_DOCUMENT_TYPE_NODE (integer) | 10 | Node is a DOMDocumentType
XML_DOCUMENT_FRAG_NODE (integer) | 11 | Node is a DOMDocumentFragment
XML_NOTATION_NODE (integer) | 12 | Node is a DOMNotation
XML_HTML_DOCUMENT_NODE (integer) | 13 |
XML_DTD_NODE (integer) | 14 |
XML_ELEMENT_DECL_NODE (integer) | 15 |
XML_ATTRIBUTE_DECL_NODE (integer) | 16 |
XML_ENTITY_DECL_NODE (integer) | 17 |
XML_NAMESPACE_DECL_NODE (integer) | 18 |
XML_ATTRIBUTE_CDATA (integer) | 1 |
XML_ATTRIBUTE_ID (integer) | 2 |
XML_ATTRIBUTE_IDREF (integer) | 3 |
XML_ATTRIBUTE_IDREFS (integer) | 4 |
XML_ATTRIBUTE_ENTITY (integer) | 5 |
XML_ATTRIBUTE_NMTOKEN (integer) | 7 |
XML_ATTRIBUTE_NMTOKENS (integer) | 8 |
XML_ATTRIBUTE_ENUMERATION (integer) | 9 |
XML_ATTRIBUTE_NOTATION (integer) | 10 |

Tabulka 59. DOMException constants

Constant | Value | Description
DOM_INDEX_SIZE_ERR (integer) | 1 | If index or size is negative, or greater than the allowed value.
DOMSTRING_SIZE_ERR (integer) | 2 | If the specified range of text does not fit into a DOMString.
DOM_HIERARCHY_REQUEST_ERR (integer) | 3 | If any node is inserted somewhere it doesn't belong
DOM_WRONG_DOCUMENT_ERR (integer) | 4 | If a node is used in a different document than the one that created it.
DOM_INVALID_CHARACTER_ERR (integer) | 5 | If an invalid or illegal character is specified, such as in a name.
DOM_NO_DATA_ALLOWED_ERR (integer) | 6 | If data is specified for a node which does not support data.
DOM_NO_MODIFICATION_ALLOWED_ERR (integer) | 7 | If an attempt is made to modify an object where modifications are not allowed.
DOM_NOT_FOUND_ERR (integer) | 8 | If an attempt is made to reference a node in a context where it does not exist.
DOM_NOT_SUPPORTED_ERR (integer) | 9 | If the implementation does not support the requested type of object or operation.
DOM_INUSE_ATTRIBUTE_ERR (integer) | 10 | If an attempt is made to add an attribute that is already in use elsewhere.
DOM_INVALID_STATE_ERR (integer) | 11 | If an attempt is made to use an object that is not, or is no longer, usable.
DOM_SYNTAX_ERR (integer) | 12 | If an invalid or illegal string is specified.
DOM_INVALID_MODIFICATION_ERR (integer) | 13 | If an attempt is made to modify the type of the underlying object.
DOM_NAMESPACE_ERR (integer) | 14 | If an attempt is made to create or change an object in a way which is incorrect with regard to namespaces.
DOM_INVALID_ACCESS_ERR (integer) | 15 | If a parameter or an operation is not supported by the underlying object.
DOM_VALIDATION_ERR (integer) | 16 | If a call to a method such as insertBefore or removeChild would make the Node invalid with respect to "partial validity", this exception would be raised and the operation would not be done.

Obsah

DOMAttr->__construct() — Creates a new DOMAttr object
DOMAttr->isId() — Checks if attribute is a defined ID
DOMCharacterData->appendData() — Append the string to the end of the character data of the node
DOMCharacterData->deleteData() — Remove a range of characters from the node
DOMCharacterData->insertData() — Insert a string at the specified 16-bit unit offset
DOMCharacterData->replaceData() — Replace a substring within the DOMCharacterData node
DOMCharacterData->substringData() — Extracts a range of data from the node
DOMComment->__construct() — Creates a new DOMComment object
DOMDocument->__construct() — Creates a new DOMDocument object
DOMDocument->createAttribute() — Create new attribute
DOMDocument->createAttributeNS() — Create new attribute node with an associated namespace
DOMDocument->createCDATASection() — Create new cdata node
DOMDocument->createComment() — Create new comment node
DOMDocument->createDocumentFragment() — Create new document fragment
DOMDocument->createElement() — Create new element node
DOMDocument->createElementNS() — Create new element node with an associated namespace
DOMDocument->createEntityReference() — Create new entity reference node
DOMDocument->createProcessingInstruction() — Creates new PI node
DOMDocument->createTextNode() — Create new text node
DOMDocument->getElementById() — Searches for an element with a certain id
DOMDocument->getElementsByTagName() — Searches for all elements with given tag name
DOMDocument->getElementsByTagNameNS() — Searches for all elements with given tag name in specified namespace
DOMDocument->importNode() — Import node into current document
DOMDocument->load() — Load XML from a file
DOMDocument->loadHTML() — Load HTML from a string
DOMDocument->loadHTMLFile() — Load HTML from a file
DOMDocument->loadXML() — Load XML from a string
DOMDocument->normalizeDocument() — Normalizes the document
DOMDocument->registerNodeClass() — Register extended class used to create base node type
DOMDocument->relaxNGValidate() — Performs relaxNG validation on the document
DOMDocument->relaxNGValidateSource() — Performs relaxNG validation on the document
DOMDocument->save() — Dumps the internal XML tree back into a file
DOMDocument->saveHTML() — Dumps the internal document into a string using HTML formatting
DOMDocument->saveHTMLFile() — Dumps the internal document into a file using HTML formatting
DOMDocument->saveXML() — Dumps the internal XML tree back into a string
DOMDocument->schemaValidate() — Validates a document based on a schema
DOMDocument->schemaValidateSource() — Validates a document based on a schema
DOMDocument->validate() — Validates the document based on its DTD
DOMDocument->xinclude() — Substitutes XIncludes in a DOMDocument Object
DOMDocumentFragment->appendXML() — Append raw XML data
DOMElement->__construct() — Creates a new DOMElement object
DOMElement->getAttribute() — Returns value of attribute
DOMElement->getAttributeNode() — Returns attribute node
DOMElement->getAttributeNodeNS() — Returns attribute node
DOMElement->getAttributeNS() — Returns value of attribute
DOMElement->getElementsByTagName() — Gets elements by tagname
DOMElement->getElementsByTagNameNS() — Get elements by namespaceURI and localName
DOMElement->hasAttribute() — Checks to see if attribute exists
DOMElement->hasAttributeNS() — Checks to see if attribute exists
DOMElement->removeAttribute() — Removes attribute
DOMElement->removeAttributeNode() — Removes attribute
DOMElement->removeAttributeNS() — Removes attribute
DOMElement->setAttribute() — Adds new attribute
DOMElement->setAttributeNode() — Adds new attribute node to element
DOMElement->setAttributeNodeNS() — Adds new attribute node to element
DOMElement->setAttributeNS() — Adds new attribute
DOMElement->setIdAttribute() — Declares the attribute specified by name to be of type ID
DOMElement->setIdAttributeNode() — Declares the attribute specified by node to be of type ID
DOMElement->setIdAttributeNS() — Declares the attribute specified by local name and namespace URI to be of type ID
DOMEntityReference->__construct() — Creates a new DOMEntityReference object
DOMImplementation->__construct() — Creates a new DOMImplementation object
DOMImplementation->createDocument() — Creates a DOMDocument object of the specified type with its document element
DOMImplementation->createDocumentType() — Creates an empty DOMDocumentType object
DOMImplementation->hasFeature() — Test if the DOM implementation implements a specific feature
DOMNamedNodeMap->getNamedItem() — Retrieves a node specified by name
DOMNamedNodeMap->getNamedItemNS() — Retrieves a node specified by local name and namespace URI
DOMNamedNodeMap->item() — Retrieves a node specified by index
DOMNode->appendChild() — Adds new child at the end of the children
DOMNode->cloneNode() — Clones a node
DOMNode->hasAttributes() — Checks if node has attributes
DOMNode->hasChildNodes() — Checks if node has children
DOMNode->insertBefore() — Adds a new child before a reference node
DOMNode->isDefaultNamespace() — Checks if the specified namespaceURI is the default namespace or not
DOMNode->isSameNode() — Indicates if two nodes are the same node
DOMNode->isSupported() — Checks if feature is supported for specified version
DOMNode->lookupNamespaceURI() — Gets the namespace URI of the node based on the prefix
DOMNode->lookupPrefix() — Gets the namespace prefix of the node based on the namespace URI
DOMNode->normalize() — Normalizes the node
DOMNode->removeChild() — Removes child from list of children
DOMNode->replaceChild() — Replaces a child
DOMNodelist->item() — Retrieves a node specified by index
DOMProcessingInstruction->__construct() — Creates a new DOMProcessingInstruction object
DOMText->__construct() — Creates a new DOMText object
DOMText->isWhitespaceInElementContent() — Indicates whether this text node contains whitespace
DOMText->splitText() — Breaks this node into two nodes at the specified offset
DOMXPath->__construct() — Creates a new DOMXPath object
DOMXPath->evaluate() — Evaluates the given XPath expression and returns a typed result if possible.
DOMXPath->query() — Evaluates the given XPath expression
DOMXPath->registerNamespace() — Registers the namespace with the DOMXPath object
dom_import_simplexml — Gets a DOMElement object from a SimpleXMLElement object
Předcházející | Nahoru | Další
scandir | Domů | DOMAttr->__construct()


DOMAttr->isId()

(No version information available, might be only in CVS)

DOMAttr->isId() — Checks if attribute is a defined ID

Popis

class DOMAttr {
bool isId ( void )
}

This function checks if the attribute is a defined ID.

According to the DOM standard this requires a DTD which defines the attribute ID to be of type ID. You need to validate your document with DOMDocument->validate() or DOMDocument::validateOnParse before using this function.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 407. DOMAttr->isId() Example

<?php

$doc = new DomDocument;

// We need to validate our document before refering to the id
$doc->validateOnParse = true;
$doc->Load('book.xml');

// We retrieve the attribute named id of the chapter element
$attr = $doc->getElementsByTagName('chapter')->item(0)->getAttributeNode('id');

var_dump($attr->isId()); // bool(true)

?>

Předcházející | Nahoru | Další
DOMAttr->__construct() | Domů | DOMCharacterData->appendData()


DOMCharacterData->appendData()

(No version information available, might be only in CVS)

DOMCharacterData->appendData() — Append the string to the end of the character data of the node

Popis

class DOMCharacterData {
void appendData ( string $data )
}

Append the string data to the end of the character data of the node.

Seznam parametrů

data

The string to append.

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

DOMCharacterData->deleteData()
DOMCharacterData->insertData()
DOMCharacterData->replaceData()
DOMCharacterData->substringData()

Předcházející | Nahoru | Další
DOMAttr->isId() | Domů | DOMCharacterData->deleteData()


DOMCharacterData->deleteData()

(No version information available, might be only in CVS)

DOMCharacterData->deleteData() — Remove a range of characters from the node

Popis

class DOMCharacterData {
void deleteData ( int $offset, int $count )
}

Deletes count characters starting from position offset.

Seznam parametrů

offset

The offset from which to start removing.

count

The number of characters to delete. If the sum of offset and count exceeds the length, then all characters to the end of the data are deleted.

Návratové hodnoty

Nevrací se žádná hodnota.

Errors/Exceptions

DOM_INDEX_SIZE_ERR

Raised if offset is negative or greater than the number of 16-bit units in data, or if count is negative.

Viz také

DOMCharacterData->appendData()
DOMCharacterData->insertData()
DOMCharacterData->replaceData()
DOMCharacterData->substringData()

Předcházející | Nahoru | Další
DOMCharacterData->appendData() | Domů | DOMCharacterData->insertData()


DOMCharacterData->insertData()

(No version information available, might be only in CVS)

DOMCharacterData->insertData() — Insert a string at the specified 16-bit unit offset

Popis

class DOMCharacterData {
void insertData ( int $offset, string $data )
}

Inserts string data at position offset.

Seznam parametrů

offset

The character offset at which to insert.

data

The string to insert.

Návratové hodnoty

Nevrací se žádná hodnota.

Errors/Exceptions

DOM_INDEX_SIZE_ERR

Raised if offset is negative or greater than the number of 16-bit units in data.

Viz také

DOMCharacterData->appendData()
DOMCharacterData->deleteData()
DOMCharacterData->replaceData()
DOMCharacterData->substringData()

Předcházející | Nahoru | Další
DOMCharacterData->deleteData() | Domů | DOMCharacterData->replaceData()


DOMCharacterData->replaceData()

(No version information available, might be only in CVS)

DOMCharacterData->replaceData() — Replace a substring within the DOMCharacterData node

Popis

class DOMCharacterData {
void replaceData ( int $offset, int $count, string $data )
}

Replace count characters starting from position offset with data.

Seznam parametrů

offset

The offset from which to start replacing.

count

The number of characters to replace. If the sum of offset and count exceeds the length, then all characters to the end of the data are replaced.

data

The string with which the range must be replaced.

Návratové hodnoty

Nevrací se žádná hodnota.

Errors/Exceptions

DOM_INDEX_SIZE_ERR

Raised if offset is negative or greater than the number of 16-bit units in data, or if count is negative.

Viz také

DOMCharacterData->appendData()
DOMCharacterData->deleteData()
DOMCharacterData->insertData()
DOMCharacterData->substringData()

Předcházející | Nahoru | Další
DOMCharacterData->insertData() | Domů | DOMCharacterData->substringData()


DOMCharacterData->substringData()

(No version information available, might be only in CVS)

DOMCharacterData->substringData() — Extracts a range of data from the node

Popis

class DOMCharacterData {
string substringData ( int $offset, int $count )
}

Returns the specified substring.

Seznam parametrů

offset

Start offset of substring to extract.

count

The number of characters to extract.

Návratové hodnoty

The specified substring. If the sum of offset and count exceeds the length, then all 16-bit units to the end of the data are returned.

Errors/Exceptions

DOM_INDEX_SIZE_ERR

Raised if offset is negative or greater than the number of 16-bit units in data, or if count is negative.

Viz také

DOMCharacterData->appendData()
DOMCharacterData->deleteData()
DOMCharacterData->insertData()
DOMCharacterData->replaceData()

Předcházející | Nahoru | Další
DOMCharacterData->replaceData() | Domů | DOMComment->__construct()


DOMDocument->createAttribute()

(No version information available, might be only in CVS)

DOMDocument->createAttribute() — Create new attribute

Popis

class DOMDocument {
DOMAttr createAttribute ( string $name )
}

This function creates a new instance of class DOMAttr. Tento uzel se v dokumentu neobjeví, nebyl-li přidán např. funkcí DOMNode->appendChild().

Seznam parametrů

name

The name of the attribute.

Návratové hodnoty

The new DOMAttr or FALSE if an error occured.

Errors/Exceptions

DOM_INVALID_CHARACTER_ERR

Raised if name contains an invalid character.

Viz také

DOMNode->appendChild()
DOMDocument->createAttributeNS()
DOMDocument->createCDATASection()
DOMDocument->createComment()
DOMDocument->createDocumentFragment()
DOMDocument->createElement()
DOMDocument->createElementNS()
DOMDocument->createEntityReference()
DOMDocument->createProcessingInstruction()
DOMDocument->createTextNode()

Předcházející | Nahoru | Další
DOMDocument->__construct() | Domů | DOMDocument->createAttributeNS()


DOMDocument->createAttributeNS()

(No version information available, might be only in CVS)

DOMDocument->createAttributeNS() — Create new attribute node with an associated namespace

Popis

class DOMDocument {
DOMAttr createAttributeNS ( string $namespaceURI, string $qualifiedName )
}

This function creates a new instance of class DOMAttr. Tento uzel se v dokumentu neobjeví, nebyl-li přidán např. funkcí DOMNode->appendChild().

Seznam parametrů

namespaceURI

The URI of the namespace.

qualifiedName

The tag name and prefix of the attribute, as prefix:tagname.

Návratové hodnoty

The new DOMAttr or FALSE if an error occured.

Errors/Exceptions

DOM_INVALID_CHARACTER_ERR

Raised if qualifiedName contains an invalid character.

DOM_NAMESPACE_ERR

Raised if qualifiedName is a malformed qualified name, or if qualifiedName has a prefix and namespaceURI is NULL.

Viz také

DOMNode->appendChild()
DOMDocument->createAttribute()
DOMDocument->createCDATASection()
DOMDocument->createComment()
DOMDocument->createDocumentFragment()
DOMDocument->createElement()
DOMDocument->createElementNS()
DOMDocument->createEntityReference()
DOMDocument->createProcessingInstruction()
DOMDocument->createTextNode()

Předcházející | Nahoru | Další
DOMDocument->createAttribute() | Domů | DOMDocument->createCDATASection()


DOMDocument->createCDATASection()

(No version information available, might be only in CVS)

DOMDocument->createCDATASection() — Create new cdata node

Popis

class DOMDocument {
DOMCDATASection createCDATASection ( string $data )
}

This function creates a new instance of class DOMCDATASection. Tento uzel se v dokumentu neobjeví, nebyl-li přidán např. funkcí DOMNode->appendChild().

Seznam parametrů

data

The content of the cdata.

Návratové hodnoty

The new DOMCDATASection or FALSE if an error occured.

Viz také

DOMNode->appendChild()
DOMDocument->createAttribute()
DOMDocument->createAttributeNS()
DOMDocument->createComment()
DOMDocument->createDocumentFragment()
DOMDocument->createElement()
DOMDocument->createElementNS()
DOMDocument->createEntityReference()
DOMDocument->createProcessingInstruction()
DOMDocument->createTextNode()

Předcházející | Nahoru | Další
DOMDocument->createAttributeNS() | Domů | DOMDocument->createComment()


DOMDocument->createComment()

(No version information available, might be only in CVS)

DOMDocument->createComment() — Create new comment node

Popis

class DOMDocument {
DOMComment createComment ( string $data )
}

This function creates a new instance of class DOMComment. Tento uzel se v dokumentu neobjeví, nebyl-li přidán např. funkcí DOMNode->appendChild().

Seznam parametrů

data

The content of the comment.

Návratové hodnoty

The new DOMComment or FALSE if an error occured.

Viz také

DOMNode->appendChild()
DOMDocument->createAttribute()
DOMDocument->createAttributeNS()
DOMDocument->createCDATASection()
DOMDocument->createDocumentFragment()
DOMDocument->createElement()
DOMDocument->createElementNS()
DOMDocument->createEntityReference()
DOMDocument->createProcessingInstruction()
DOMDocument->createTextNode()

Předcházející | Nahoru | Další
DOMDocument->createCDATASection() | Domů | DOMDocument->createDocumentFragment()


DOMDocument->createDocumentFragment()

(No version information available, might be only in CVS)

DOMDocument->createDocumentFragment() — Create new document fragment

Popis

class DOMDocument {
DOMDocumentFragment createDocumentFragment ( void )
}

This function creates a new instance of class DOMDocumentFragment. Tento uzel se v dokumentu neobjeví, nebyl-li přidán např. funkcí DOMNode->appendChild().

Návratové hodnoty

The new DOMDocumentFragment or FALSE if an error occured.

Viz také

DOMNode->appendChild()
DOMDocument->createAttribute()
DOMDocument->createAttributeNS()
DOMDocument->createCDATASection()
DOMDocument->createComment()
DOMDocument->createElement()
DOMDocument->createElementNS()
DOMDocument->createEntityReference()
DOMDocument->createProcessingInstruction()
DOMDocument->createTextNode()

Předcházející | Nahoru | Další
DOMDocument->createComment() | Domů | DOMDocument->createElement()


DOMDocument->createElement()

(No version information available, might be only in CVS)

DOMDocument->createElement() — Create new element node

Popis

class DOMDocument {
DOMElement createElement ( string $name [, string $value] )
}

This function creates a new instance of class DOMElement. Tento uzel se v dokumentu neobjeví, nebyl-li přidán např. funkcí DOMNode->appendChild().

Seznam parametrů

name

The tag name of the element.

value

The value of the element. By default, an empty element will be created. You can also set the value later with DOMElement->nodeValue.

Návratové hodnoty

Returns a new instance of class DOMElement or FALSE if an error occured.

Errors/Exceptions

DOM_INVALID_CHARACTER_ERR

Raised if name contains an invalid character.

Příklady

Příklad 410. Creating a new element and inserting it as root

<?php

$dom = new DOMDocument('1.0', 'iso-8859-1');

$element = $dom->createElement('test', 'This is the root element!');

// We insert the new element as root (child of the document)
$dom->appendChild($element);

echo $dom->saveXML();
?>

Výše uvedený příklad vypíše:

<?xml version="1.0" encoding="iso-8859-1" ?>
<test>This is the root element!</test>

Viz také

DOMNode->appendChild()
DOMDocument->createAttribute()
DOMDocument->createAttributeNS()
DOMDocument->createCDATASection()
DOMDocument->createComment()
DOMDocument->createDocumentFragment()
DOMDocument->createElementNS()
DOMDocument->createEntityReference()
DOMDocument->createProcessingInstruction()
DOMDocument->createTextNode()

Předcházející | Nahoru | Další
DOMDocument->createDocumentFragment() | Domů | DOMDocument->createElementNS()


DOMDocument->createElementNS()

(No version information available, might be only in CVS)

DOMDocument->createElementNS() — Create new element node with an associated namespace

Popis

class DOMDocument {
DOMElement createElementNS ( string $namespaceURI, string $qualifiedName [, string $value] )
}

This function creates a new element node with an associated namespace. Tento uzel se v dokumentu neobjeví, nebyl-li přidán např. funkcí DOMNode->appendChild().

Seznam parametrů

namespaceURI

The URI of the namespace.

qualifiedName

The qualified name of the element, as prefix:tagname.

value

The value of the element. By default, an empty element will be created. You can also set the value later with DOMElement->nodeValue.

Návratové hodnoty

The new DOMElement or FALSE if an error occured.

Errors/Exceptions

DOM_INVALID_CHARACTER_ERR

Raised if qualifiedName contains an invalid character.

DOM_NAMESPACE_ERR

Raised if qualifiedName is a maformed qualified name.

Příklady

Příklad 411. Creating a new element and inserting it as root

<?php

$dom = new DOMDocument('1.0', 'iso-8859-1');

$element = $dom->createElementNS('http://www.example.com/XFoo', 'xfoo:test', 'This is the root element!');

// We insert the new element as root (child of the document)
$dom->appendChild($element);

echo $dom->saveXML();
?>

Výše uvedený příklad vypíše:

<?xml version="1.0" encoding="iso-8859-1" ?>
<xfoo:test xmlns:xfoo="http://www.example.com/XFoo">This is the root element!</xfoo:test>

Viz také

DOMNode->appendChild()
DOMDocument->createAttribute()
DOMDocument->createAttributeNS()
DOMDocument->createCDATASection()
DOMDocument->createComment()
DOMDocument->createDocumentFragment()
DOMDocument->createElement()
DOMDocument->createEntityReference()
DOMDocument->createProcessingInstruction()
DOMDocument->createTextNode()

Předcházející | Nahoru | Další
DOMDocument->createElement() | Domů | DOMDocument->createEntityReference()


DOMDocument->createEntityReference()

(No version information available, might be only in CVS)

DOMDocument->createEntityReference() — Create new entity reference node

Popis

class DOMDocument {
DOMEntityReference createEntityReference ( string $name )
}

This function creates a new instance of class DOMEntityReference. Tento uzel se v dokumentu neobjeví, nebyl-li přidán např. funkcí DOMNode->appendChild().

Seznam parametrů

name

The content of the entity reference, e.g. the entity reference minus the leading & and the trailing ; characters.

Návratové hodnoty

The new DOMEntityReference or FALSE if an error occured.

Errors/Exceptions

DOM_INVALID_CHARACTER_ERR

Raised if name contains an invalid character.

Viz také

DOMNode->appendChild()
DOMDocument->createAttribute()
DOMDocument->createAttributeNS()
DOMDocument->createCDATASection()
DOMDocument->createComment()
DOMDocument->createDocumentFragment()
DOMDocument->createElement()
DOMDocument->createElementNS()
DOMDocument->createProcessingInstruction()
DOMDocument->createTextNode()

Předcházející | Nahoru | Další
DOMDocument->createElementNS() | Domů | DOMDocument->createProcessingInstruction()


DOMDocument->createProcessingInstruction()

(No version information available, might be only in CVS)

DOMDocument->createProcessingInstruction() — Creates new PI node

Popis

class DOMDocument {
DOMProcessingInstruction createProcessingInstruction ( string $target [, string $data] )
}

This function creates a new instance of class DOMProcessingInstruction. Tento uzel se v dokumentu neobjeví, nebyl-li přidán např. funkcí DOMNode->appendChild().

Seznam parametrů

target

The target of the processing instruction.

data

The content of the processing instruction.

Návratové hodnoty

The new DOMProcessingInstruction or FALSE if an error occured.

Errors/Exceptions

DOM_INVALID_CHARACTER_ERR

Raised if target contains an invalid character.

Viz také

DOMNode->appendChild()
DOMDocument->createAttribute()
DOMDocument->createAttributeNS()
DOMDocument->createCDATASection()
DOMDocument->createComment()
DOMDocument->createDocumentFragment()
DOMDocument->createElement()
DOMDocument->createElementNS()
DOMDocument->createEntityReference()
DOMDocument->createTextNode()

Předcházející | Nahoru | Další
DOMDocument->createEntityReference() | Domů | DOMDocument->createTextNode()


DOMDocument->createTextNode()

(No version information available, might be only in CVS)

DOMDocument->createTextNode() — Create new text node

Popis

class DOMDocument {
DOMText createTextNode ( string $content )
}

This function creates a new instance of class DOMText. Tento uzel se v dokumentu neobjeví, nebyl-li přidán např. funkcí DOMNode->appendChild().

Seznam parametrů

content

The content of the text.

Návratové hodnoty

The new DOMText or FALSE if an error occured.

Viz také

DOMNode->appendChild()
DOMDocument->createAttribute()
DOMDocument->createAttributeNS()
DOMDocument->createCDATASection()
DOMDocument->createComment()
DOMDocument->createDocumentFragment()
DOMDocument->createElement()
DOMDocument->createElementNS()
DOMDocument->createEntityReference()
DOMDocument->createProcessingInstruction()

Předcházející | Nahoru | Další
DOMDocument->createProcessingInstruction() | Domů | DOMDocument->getElementById()


DOMDocument->getElementById()

(No version information available, might be only in CVS)

DOMDocument->getElementById() — Searches for an element with a certain id

Popis

class DOMDocument {
DOMElement getElementById ( string $elementId )
}

This function is similar to DOMDocument->getElementsByTagName() but searches for an element with a given id.

For this function to work, you will need either to set some ID attributes with DOMElement->setIdAttribute() or a DTD which defines an attribute to be of type ID. In the later case, you will need to validate your document with DOMDocument->validate() or DOMDocument->validateOnParse before using this function.

Seznam parametrů

elementId

The unique id value for an element.

Návratové hodnoty

Returns the DOMElement or NULL if the element is not found.

Příklady

Příklad 412. DOMDocument->getElementById() Example

<?php

$doc = new DomDocument;

// We need to validate our document before refering to the id
$doc->validateOnParse = true;
$doc->Load('book.xml');

echo "The element whose id is books is: " . $doc->getElementById('books')->tagName . "\n";

?>

Výše uvedený příklad vypíše:

The element whose id is books is: chapter

Viz také

DOMDocument->getElementsByTagName()

Předcházející | Nahoru | Další
DOMDocument->createTextNode() | Domů | DOMDocument->getElementsByTagName()


DOMDocument->getElementsByTagName()

(No version information available, might be only in CVS)

DOMDocument->getElementsByTagName() — Searches for all elements with given tag name

Popis

class DOMDocument {
DOMNodeList getElementsByTagName ( string $name )
}

This function returns a new instance of class DOMNodeList containing the elements with a given tag name.

Seznam parametrů

name

The name of the tag to match on. The special value * matches all tags.

Návratové hodnoty

A new DOMNodeList object containing all the matched elements.

Viz také

DOMDocument->getElementsByTagNameNS()

Předcházející | Nahoru | Další
DOMDocument->getElementById() | Domů | DOMDocument->getElementsByTagNameNS()


DOMDocument->getElementsByTagNameNS()

(No version information available, might be only in CVS)

DOMDocument->getElementsByTagNameNS() — Searches for all elements with given tag name in specified namespace

Popis

class DOMDocument {
DOMNodeList getElementsByTagNameNS ( string $namespaceURI, string $localName )
}

Returns a DOMNodeList of all elements with a given local name and a namespace URI.

Seznam parametrů

namespaceURI

The namespace URI of the elements to match on. The special value * matches all namespaces.

localName

The local name of the elements to match on. The special value * matches all local names.

Návratové hodnoty

A new DOMNodeList object containing all the matched elements.

Příklady

Příklad 413. Get all the XInclude elements

<?php

$xml = <<<EOD
<?xml version="1.0" ?>
<chapter xmlns:xi="http://www.w3.org/2001/XInclude">
<title>Books of the other guy..</title>
<para>
 <xi:include href="book.xml">
  <xi:fallback>
   <error>xinclude: book.xml not found</error>
  </xi:fallback>
 </xi:include>
 <include>
  This is another namespace
 </include>
</para>
</chapter>
EOD;
$dom = new DOMDocument;

// load the XML string defined above
$dom->loadXML($xml);

foreach ($dom->getElementsByTagNameNS('http://www.w3.org/2001/XInclude', '*') as $element) {
    echo 'local name: ', $element->localName, ', prefix: ', $element->prefix, "\n";
}
?>

Výše uvedený příklad vypíše:

local name: include, prefix: xi
local name: fallback, prefix: xi

Viz také

DOMDocument->getElementsByTagName()

Předcházející | Nahoru | Další
DOMDocument->getElementsByTagName() | Domů | DOMDocument->importNode()


DOMDocument->importNode()

(No version information available, might be only in CVS)

DOMDocument->importNode() — Import node into current document

Popis

class DOMDocument {
DOMNode importNode ( DOMNode $importedNode [, bool $deep] )
}

This function returns a copy of the node to import and associates it with the current document.

Seznam parametrů

importedNode

The node to import.

deep

If set to TRUE, this method will recursively import the subtree under the importedNode.

Návratové hodnoty

The copied node.

Errors/Exceptions

DOMException is thrown if node cannot be imported.

Předcházející | Nahoru | Další
DOMDocument->getElementsByTagNameNS() | Domů | DOMDocument->load()


DOMDocument->load()

(No version information available, might be only in CVS)

DOMDocument->load() — Load XML from a file

Popis

class DOMDocument {
mixed load ( string $filename [, int $options] )
}

Loads an XML document from a file.

Seznam parametrů

filename

The path to the XML document.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání. If called statically, returns a DOMDocument but also causes an E_STRICT warning.

Errors/Exceptions

If an empty string is passed as the filename or an empty file is named, a warning will be generated. This warning is not generated by libxml and cannot be handled using libxml's error handling functions.

Příklady

Příklad 414. Creating a Document

<?php
$doc = new DOMDocument();
$doc->load('book.xml');
echo $doc->saveXML();
?>

Viz také

DOMDocument->loadXML()
DOMDocument->save()
DOMDocument->saveXML()

Předcházející | Nahoru | Další
DOMDocument->importNode() | Domů | DOMDocument->loadHTML()


DOMDocument->loadHTML()

(No version information available, might be only in CVS)

DOMDocument->loadHTML() — Load HTML from a string

Popis

class DOMDocument {
bool loadHTML ( string $source )
}

The function parses the HTML contained in the string source. Unlike loading XML, HTML does not have to be well-formed to load. This function may also be called statically to load and create a DOMDocument object. The static invocation may be used when no DOMDocument properties need to be set prior to loading.

Seznam parametrů

source

The HTML string.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Errors/Exceptions

If an empty string is passed as the source, a warning will be generated. This warning is not generated by libxml and cannot be handled using libxml's error handling functions.

Příklady

Příklad 415. Creating a Document

<?php
$doc = new DOMDocument();
$doc->loadHTML("<html><body>Test<br></body></html>");
echo $doc->saveHTML();
?>

Viz také

DOMDocument->loadHTMLFile()
DOMDocument->saveHTML()
DOMDocument->saveHTMLFile()

Předcházející | Nahoru | Další
DOMDocument->load() | Domů | DOMDocument->loadHTMLFile()


DOMDocument->loadHTMLFile()

(No version information available, might be only in CVS)

DOMDocument->loadHTMLFile() — Load HTML from a file

Popis

class DOMDocument {
bool loadHTMLFile ( string $filename )
}

The function parses the HTML document in the file named filename. Unlike loading XML, HTML does not have to be well-formed to load.

This function may also be called statically to load and create a DOMDocument object. The static invocation may be used when no DOMDocument properties need to be set prior to loading.

Seznam parametrů

filename

The path to the HTML file.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Errors/Exceptions

If an empty string is passed as the filename or an empty file is named, a warning will be generated. This warning is not generated by libxml and cannot be handled using libxml's error handling functions.

Příklady

Příklad 416. Creating a Document

<?php
$doc = new DOMDocument();
$doc->loadHTMLFile("filename.html");
echo $doc->saveHTML();
?>

Viz také

DOMDocument->loadHTML()
DOMDocument->saveHTML()
DOMDocument->saveHTMLFile()

Předcházející | Nahoru | Další
DOMDocument->loadHTML() | Domů | DOMDocument->loadXML()


DOMDocument->loadXML()

(No version information available, might be only in CVS)

DOMDocument->loadXML() — Load XML from a string

Popis

class DOMDocument {
mixed loadXML ( string $source [, int $options] )
}

Loads an XML document from a string.

This method may also be called statically to load and create a DOMDocument object. The static invocation may be used when no DOMDocument properties need to be set prior to loading.

Seznam parametrů

source

The string containing the XML.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání. If called statically, returns a DOMDocument.

Errors/Exceptions

If an empty string is passed as the source, a warning will be generated. This warning is not generated by libxml and cannot be handled using libxml's error handling functions.

Příklady

Příklad 417. Creating a Document

<?php
$doc = new DOMDocument();
$doc->loadXML('<root><node/></root>');
echo $doc->saveXML();
?>

Příklad 418. Static invocation of loadXML

<?php
$doc = DOMDocument::loadXML('<root><node/></root>');
echo $doc->saveXML();
?>

Viz také

DOMDocument->load()
DOMDocument->save()
DOMDocument->saveXML()

Předcházející | Nahoru | Další
DOMDocument->loadHTMLFile() | Domů | DOMDocument->normalizeDocument()


DOMDocument->relaxNGValidate()

(No version information available, might be only in CVS)

DOMDocument->relaxNGValidate() — Performs relaxNG validation on the document

Popis

class DOMDocument {
bool relaxNGValidate ( string $filename )
}

Performs » relaxNG validation on the document based on the given RNG schema.

Seznam parametrů

filename

The RNG file.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

DOMDocument->relaxNGValidateSource()
DOMDocument->schemaValidate()
DOMDocument->schemaValidateSource()
DOMDocument->validate()

Předcházející | Nahoru | Další
DOMDocument->registerNodeClass() | Domů | DOMDocument->relaxNGValidateSource()


DOMDocument->relaxNGValidateSource()

(No version information available, might be only in CVS)

DOMDocument->relaxNGValidateSource() — Performs relaxNG validation on the document

Popis

class DOMDocument {
bool relaxNGValidateSource ( string $source )
}

Performs » relaxNG validation on the document based on the given RNG source.

Seznam parametrů

source

A string containing the RNG schema.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

DOMDocument->relaxNGValidate()
DOMDocument->schemaValidate()
DOMDocument->schemaValidateSource()
DOMDocument->validate()

Předcházející | Nahoru | Další
DOMDocument->relaxNGValidate() | Domů | DOMDocument->save()


DOMDocument->save()

(No version information available, might be only in CVS)

DOMDocument->save() — Dumps the internal XML tree back into a file

Popis

class DOMDocument {
mixed save ( string $filename [, int $options] )
}

Creates an XML document from the DOM representation. This function is usually called after building a new dom document from scratch as in the example below.

Seznam parametrů

filename

The path to the saved XML document.

options

Additional Options. Currently only LIBXML_NOEMPTYTAG is supported.

Návratové hodnoty

Returns the number of bytes written or FALSE if an error occurred.

ChangeLog (záznam změn)

Verze | Popis
5.1.0 | Added the options parameter

Příklady

Příklad 420. Saving a DOM tree into a file

<?php

$doc = new DOMDocument('1.0');
// we want a nice output
$doc->formatOutput = true;

$root = $doc->createElement('book');
$root = $doc->appendChild($root);

$title = $doc->createElement('title');
$title = $root->appendChild($title);

$text = $doc->createTextNode('This is the title');
$text = $title->appendChild($text);

echo 'Wrote: ' . $doc->save("/tmp/test.xml") . ' bytes'; // Wrote: 72 bytes

?>

Viz také

DOMDocument->saveXML()
DOMDocument->load()
DOMDocument->loadXML()

Předcházející | Nahoru | Další
DOMDocument->relaxNGValidateSource() | Domů | DOMDocument->saveHTML()


DOMDocument->saveHTML()

(No version information available, might be only in CVS)

DOMDocument->saveHTML() — Dumps the internal document into a string using HTML formatting

Popis

class DOMDocument {
string saveHTML ( void )
}

Creates an HTML document from the DOM representation. This function is usually called after building a new dom document from scratch as in the example below.

Návratové hodnoty

Returns the HTML, or FALSE if an error occurred.

Příklady

Příklad 421. Saving a HTML tree into a string

<?php

$doc = new DOMDocument('1.0');

$root = $doc->createElement('html');
$root = $doc->appendChild($root);

$head = $doc->createElement('head');
$head = $root->appendChild($head);

$title = $doc->createElement('title');
$title = $head->appendChild($title);

$text = $doc->createTextNode('This is the title');
$text = $title->appendChild($text);

echo $doc->saveHTML();

?>

Viz také

DOMDocument->saveHTMLFile()
DOMDocument->loadHTML()
DOMDocument->loadHTMLFile()

Předcházející | Nahoru | Další
DOMDocument->save() | Domů | DOMDocument->saveHTMLFile()


DOMDocument->saveHTMLFile()

(No version information available, might be only in CVS)

DOMDocument->saveHTMLFile() — Dumps the internal document into a file using HTML formatting

Popis

class DOMDocument {
int saveHTMLFile ( string $filename )
}

Creates an HTML document from the DOM representation. This function is usually called after building a new dom document from scratch as in the example below.

Seznam parametrů

filename

The path to the saved HTML document.

Návratové hodnoty

Returns the number of bytes written or FALSE if an error occurred.

Příklady

Příklad 422. Saving a HTML tree into a file

<?php

$doc = new DOMDocument('1.0');
// we want a nice output
$doc->formatOutput = true;

$root = $doc->createElement('html');
$root = $doc->appendChild($root);

$head = $doc->createElement('head');
$head = $root->appendChild($head);

$title = $doc->createElement('title');
$title = $head->appendChild($title);

$text = $doc->createTextNode('This is the title');
$text = $title->appendChild($text);

echo 'Wrote: ' . $doc->saveHTMLFile("/tmp/test.html") . ' bytes'; // Wrote: 129 bytes

?>

Viz také

DOMDocument->saveHTML()
DOMDocument->loadHTML()
DOMDocument->loadHTMLFile()

Předcházející | Nahoru | Další
DOMDocument->saveHTML() | Domů | DOMDocument->saveXML()


DOMDocument->saveXML()

(No version information available, might be only in CVS)

DOMDocument->saveXML() — Dumps the internal XML tree back into a string

Popis

class DOMDocument {
string saveXML ( [DOMNode $node [, int $options]] )
}

Creates an XML document from the DOM representation. This function is usually called after building a new dom document from scratch as in the example below.

Seznam parametrů

node

Use this parameter to output only a specific node without XML declaration rather than the entire document.

options

Additional Options. Currently only LIBXML_NOEMPTYTAG is supported.

Návratové hodnoty

Returns the XML, or FALSE if an error occurred.

Errors/Exceptions

DOM_WRONG_DOCUMENT_ERR

Raised if node is from another document.

ChangeLog (záznam změn)

Verze | Popis
5.1.0 | Added the options parameter

Příklady

Příklad 423. Saving a DOM tree into a string

<?php

$doc = new DOMDocument('1.0');
// we want a nice output
$doc->formatOutput = true;

$root = $doc->createElement('book');
$root = $doc->appendChild($root);

$title = $doc->createElement('title');
$title = $root->appendChild($title);

$text = $doc->createTextNode('This is the title');
$text = $title->appendChild($text);

echo "Saving all the document:\n";
echo $doc->saveXML() . "\n";

echo "Saving only the title part:\n";
echo $doc->saveXML($title);

?>

Výše uvedený příklad vypíše:

Saving all the document:
<?xml version="1.0"?>
<book>
  <title>This is the title</title>
</book>

Saving only the title part:
<title>This is the title</title>

Viz také

DOMDocument->save()
DOMDocument->load()
DOMDocument->loadXML()

Předcházející | Nahoru | Další
DOMDocument->saveHTMLFile() | Domů | DOMDocument->schemaValidate()


DOMDocument->schemaValidate()

(No version information available, might be only in CVS)

DOMDocument->schemaValidate() — Validates a document based on a schema

Popis

class DOMDocument {
bool schemaValidate ( string $filename )
}

Validates a document based on the given schema file.

Seznam parametrů

filename

The path to the schema.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

DOMDocument->schemaValidateSource()
DOMDocument->relaxNGValidate()
DOMDocument->relaxNGValidateSource()
DOMDocument->validate()

Předcházející | Nahoru | Další
DOMDocument->saveXML() | Domů | DOMDocument->schemaValidateSource()


DOMDocument->schemaValidateSource()

(No version information available, might be only in CVS)

DOMDocument->schemaValidateSource() — Validates a document based on a schema

Popis

class DOMDocument {
bool schemaValidateSource ( string $source )
}

Validates a document based on a schema defined in the given string.

Seznam parametrů

source

A string containing the schema.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

DOMDocument->schemaValidate()
DOMDocument->relaxNGValidate()
DOMDocument->relaxNGValidateSource()
DOMDocument->validate()

Předcházející | Nahoru | Další
DOMDocument->schemaValidate() | Domů | DOMDocument->validate()


DOMDocument->validate()

(No version information available, might be only in CVS)

DOMDocument->validate() — Validates the document based on its DTD

Popis

class DOMDocument {
bool validate ( void )
}

Validates the document based on its DTD.

You can also use the validateOnParse property of DOMDocument to make a DTD validation.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání. If the document have no DTD attached, this method will return FALSE.

Příklady

Příklad 424. Example of DTD validation

<?php
$dom = new DOMDocument;
$dom->Load('book.xml');
if ($dom->validate()) {
    echo "This document is valid!\n";
}
?>

You can also validate your XML file while loading it:

<?php
$dom = new DOMDocument;
$dom->validateOnParse = true;
$dom->Load('book.xml');
?>

Viz také

DOMDocument->schemaValidate()
DOMDocument->schemaValidateSource()
DOMDocument->relaxNGValidate()
DOMDocument->relaxNGValidateSource()

Předcházející | Nahoru | Další
DOMDocument->schemaValidateSource() | Domů | DOMDocument->xinclude()


DOMDocument->xinclude()

(No version information available, might be only in CVS)

DOMDocument->xinclude() — Substitutes XIncludes in a DOMDocument Object

Popis

class DOMDocument {
int xinclude ( [int $options] )
}

This method substitutes » XIncludes in a DOMDocument object.

Poznámka: Due to libxml2 automatically resolving entities, this method will produce unexpected results if the included XML file have an attached DTD.

Seznam parametrů

options

libxml parameters. Available since PHP 5.1.0 and Libxml 2.6.7.

Návratové hodnoty

Returns the number of XIncludes in the document.

Příklady

Příklad 425. DOMDocument->xinclude() example

<?php

$xml = <<<EOD
<?xml version="1.0" ?>
<chapter xmlns:xi="http://www.w3.org/2001/XInclude">
 <title>Books of the other guy..</title>
 <para>
  <xi:include href="book.xml">
   <xi:fallback>
    <error>xinclude: book.xml not found</error>
   </xi:fallback>
  </xi:include>
 </para>
</chapter>
EOD;

$dom = new DOMDocument;

// let's have a nice output
$dom->preserveWhiteSpace = false;
$dom->formatOutput = true;

// load the XML string defined above
$dom->loadXML($xml);

// substitute xincludes
$dom->xinclude();

echo $dom->saveXML();

?>

Výše uvedený příklad vypíše něco jako:

<?xml version="1.0" ?>
<chapter xmlns:xi="http://www.w3.org/2001/XInclude">
<title>Books of the other guy..</title>
<para>
<row xml:base="/home/didou/book.xml">
<entry>The Grapes of Wrath</entry>
<entry>John Steinbeck</entry>
<entry>en</entry>
<entry>0140186409</entry>
</row>
<row xml:base="/home/didou/book.xml">
<entry>The Pearl</entry>
<entry>John Steinbeck</entry>
<entry>en</entry>
<entry>014017737X</entry>
</row>
<row xml:base="/home/didou/book.xml">
<entry>Samarcande</entry>
<entry>Amine Maalouf</entry>
<entry>fr</entry>
<entry>2253051209</entry>
</row>
</para>
</chapter>

Předcházející | Nahoru | Další
DOMDocument->validate() | Domů | DOMDocumentFragment->appendXML()


DOMElement->getAttribute()

(No version information available, might be only in CVS)

DOMElement->getAttribute() — Returns value of attribute

Popis

class DOMElement {
string getAttribute ( string $name )
}

Gets the value of the attribute with name name for the current node.

Seznam parametrů

name

The name of the attribute.

Návratové hodnoty

The value of the attribute, or an empty string if no attribute with the given name is found.

Viz také

DOMElement->hasAttribute()
DOMElement->setAttribute()
DOMElement->removeAttribute()

Předcházející | Nahoru | Další
DOMElement->__construct() | Domů | DOMElement->getAttributeNode()


DOMElement->getAttributeNode()

(No version information available, might be only in CVS)

DOMElement->getAttributeNode() — Returns attribute node

Popis

class DOMElement {
DOMAttr getAttributeNode ( string $name )
}

Returns the attribute node with name name for the current element.

Seznam parametrů

name

The name of the attribute.

Návratové hodnoty

The attribute node.

Viz také

DOMElement->hasAttribute()
DOMElement->setAttributeNode()
DOMElement->removeAttributeNode()

Předcházející | Nahoru | Další
DOMElement->getAttribute() | Domů | DOMElement->getAttributeNodeNS()


DOMElement->getAttributeNodeNS()

(No version information available, might be only in CVS)

DOMElement->getAttributeNodeNS() — Returns attribute node

Popis

class DOMElement {
DOMAttr getAttributeNodeNS ( string $namespaceURI, string $localName )
}

Returns the attribute node in namespace namespaceURI with local name localName for the current node.

Seznam parametrů

namespaceURI

The namespace URI.

localName

The local name.

Návratové hodnoty

The attribute node.

Viz také

DOMElement->hasAttributeNS()
DOMElement->setAttributeNodeNS()
DOMElement->removeAttributeNode()

Předcházející | Nahoru | Další
DOMElement->getAttributeNode() | Domů | DOMElement->getAttributeNS()


DOMElement->getAttributeNS()

(No version information available, might be only in CVS)

DOMElement->getAttributeNS() — Returns value of attribute

Popis

class DOMElement {
string getAttributeNS ( string $namespaceURI, string $localName )
}

Gets the value of the attribute in namespace namespaceURI with local name localName for the current node.

Seznam parametrů

namespaceURI

The namespace URI.

localName

The local name.

Návratové hodnoty

The value of the attribute, or an empty string if no attribute with the given localName and namespaceURI is found.

Viz také

DOMElement->hasAttributeNS()
DOMElement->setAttributeNS()
DOMElement->removeAttributeNS()

Předcházející | Nahoru | Další
DOMElement->getAttributeNodeNS() | Domů | DOMElement->getElementsByTagName()


DOMElement->getElementsByTagName()

(No version information available, might be only in CVS)

DOMElement->getElementsByTagName() — Gets elements by tagname

Popis

class DOMElement {
DOMNodeList getElementsByTagName ( string $name )
}

This function returns a new instance of the class DOMNodeList of all descendant elements with a given tag name, in the order in which they are encountered in a preorder traversal of this element tree.

Seznam parametrů

name

The tag name. Use * to return all elements within the element tree.

Návratové hodnoty

This function returns a new instance of the class DOMNodeList of all matched elements.

Viz také

DOMElement->getElementsByTagNameNS()

Předcházející | Nahoru | Další
DOMElement->getAttributeNS() | Domů | DOMElement->getElementsByTagNameNS()


DOMElement->getElementsByTagNameNS()

(No version information available, might be only in CVS)

DOMElement->getElementsByTagNameNS() — Get elements by namespaceURI and localName

Popis

class DOMElement {
DOMNodeList getElementsByTagNameNS ( string $namespaceURI, string $localName )
}

This function fetch all the descendant elements with a given localName and namespaceURI.

Seznam parametrů

namespaceURI

The namespace URI.

localName

The local name. Use * to return all elements within the element tree.

Návratové hodnoty

This function returns a new instance of the class DOMNodeList of all matched elements in the order in which they are encountered in a preorder traversal of this element tree.

Viz také

DOMElement->getElementsByTagName()

Předcházející | Nahoru | Další
DOMElement->getElementsByTagName() | Domů | DOMElement->hasAttribute()


DOMElement->hasAttribute()

(No version information available, might be only in CVS)

DOMElement->hasAttribute() — Checks to see if attribute exists

Popis

class DOMElement {
bool hasAttribute ( string $name )
}

Indicates whether attribute named name exists as a member of the element.

Seznam parametrů

name

The attribute name.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

DOMElement->hasAttributeNS()
DOMElement->getAttribute()
DOMElement->setAttribute()
DOMElement->removeAttribute()

Předcházející | Nahoru | Další
DOMElement->getElementsByTagNameNS() | Domů | DOMElement->hasAttributeNS()


DOMElement->hasAttributeNS()

(No version information available, might be only in CVS)

DOMElement->hasAttributeNS() — Checks to see if attribute exists

Popis

class DOMElement {
bool hasAttributeNS ( string $namespaceURI, string $localName )
}

Indicates whether attribute in namespace namespaceURI named localName exists as a member of the element.

Seznam parametrů

namespaceURI

The namespace URI.

localName

The local name.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

DOMElement->hasAttribute()
DOMElement->getAttributeNS()
DOMElement->setAttributeNS()
DOMElement->removeAttributeNS()

Předcházející | Nahoru | Další
DOMElement->hasAttribute() | Domů | DOMElement->removeAttribute()


DOMElement->removeAttribute()

(No version information available, might be only in CVS)

DOMElement->removeAttribute() — Removes attribute

Popis

class DOMElement {
bool removeAttribute ( string $name )
}

Removes attribute named name from the element.

Seznam parametrů

name

The name of the attribute.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Errors/Exceptions

DOM_NO_MODIFICATION_ALLOWED_ERR

Raised if the node is readonly.

Viz také

DOMElement->hasAttribute()
DOMElement->getAttribute()
DOMElement->setAttribute()

Předcházející | Nahoru | Další
DOMElement->hasAttributeNS() | Domů | DOMElement->removeAttributeNode()


DOMElement->removeAttributeNode()

(No version information available, might be only in CVS)

DOMElement->removeAttributeNode() — Removes attribute

Popis

class DOMElement {
bool removeAttributeNode ( DOMAttr $oldnode )
}

Removes attribute oldnode from the element.

Seznam parametrů

oldnode

The attribute node.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Errors/Exceptions

DOM_NO_MODIFICATION_ALLOWED_ERR

Raised if the node is readonly.

DOM_NOT_FOUND_ERROR

Raised if oldnode is not an attribute of the element.

Viz také

DOMElement->hasAttribute()
DOMElement->getAttributeNode()
DOMElement->setAttributeNode()

Předcházející | Nahoru | Další
DOMElement->removeAttribute() | Domů | DOMElement->removeAttributeNS()


DOMElement->removeAttributeNS()

(No version information available, might be only in CVS)

DOMElement->removeAttributeNS() — Removes attribute

Popis

class DOMElement {
bool removeAttributeNS ( string $namespaceURI, string $localName )
}

Removes attribute is namespace namespaceURI named localName from the element.

Seznam parametrů

namespaceURI

The namespace URI.

localName

The local name.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Errors/Exceptions

DOM_NO_MODIFICATION_ALLOWED_ERR

Raised if the node is readonly.

Viz také

DOMElement->hasAttributeNS()
DOMElement->getAttributeNS()
DOMElement->setAttributeNS()

Předcházející | Nahoru | Další
DOMElement->removeAttributeNode() | Domů | DOMElement->setAttribute()


DOMElement->setAttribute()

(No version information available, might be only in CVS)

DOMElement->setAttribute() — Adds new attribute

Popis

class DOMElement {
bool setAttribute ( string $name, string $value )
}

Sets an attribute with name name to the given value. If the attribute does not exist, it will be created.

Seznam parametrů

name

The name of the attribute.

value

The value of the attribute.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Errors/Exceptions

DOM_NO_MODIFICATION_ALLOWED_ERR

Raised if the node is readonly.

Příklady

Příklad 428. Setting an attribute

<?php
$doc = new DOMDocument("1.0");
$node = $doc->createElement("para");
$newnode = $doc->appendChild($node);
$newnode->setAttribute("align", "left");
?>

Viz také

DOMElement->hasAttribute()
DOMElement->getAttribute()
DOMElement->removeAttribute()

Předcházející | Nahoru | Další
DOMElement->removeAttributeNS() | Domů | DOMElement->setAttributeNode()


DOMElement->setAttributeNode()

(No version information available, might be only in CVS)

DOMElement->setAttributeNode() — Adds new attribute node to element

Popis

class DOMElement {
DOMAttr setAttributeNode ( DOMAttr $attr )
}

Adds new attribute node attr to element.

Seznam parametrů

attr

The attribute node.

Návratové hodnoty

Returns old node if the attribute has been replaced or NULL.

Errors/Exceptions

DOM_NO_MODIFICATION_ALLOWED_ERR

Raised if the node is readonly.

Viz také

DOMElement->hasAttribute()
DOMElement->getAttributeNode()
DOMElement->removeAttributeNode()

Předcházející | Nahoru | Další
DOMElement->setAttribute() | Domů | DOMElement->setAttributeNodeNS()


DOMElement->setAttributeNodeNS()

(No version information available, might be only in CVS)

DOMElement->setAttributeNodeNS() — Adds new attribute node to element

Popis

class DOMElement {
DOMAttr setAttributeNodeNS ( DOMAttr $attr )
}

Adds new attribute node attr to element.

Seznam parametrů

name

The attribute node.

Návratové hodnoty

Returns the old node if the attribute has been replaced.

Errors/Exceptions

DOM_NO_MODIFICATION_ALLOWED_ERR

Raised if the node is readonly.

Viz také

DOMElement->hasAttributeNS()
DOMElement->getAttributeNodeNS()
DOMElement->removeAttributeNode()

Předcházející | Nahoru | Další
DOMElement->setAttributeNode() | Domů | DOMElement->setAttributeNS()


DOMElement->setAttributeNS()

(No version information available, might be only in CVS)

DOMElement->setAttributeNS() — Adds new attribute

Popis

class DOMElement {
void setAttributeNS ( string $namespaceURI, string $qualifiedName, string $value )
}

Sets an attribute with namespace namespaceURI and name name to the given value. If the attribute does not exist, it will be created.

Seznam parametrů

namespaceURI

The namespace URI.

qualifiedName

The qualified name of the attribute, as prefix:tagname.

value

The value of the attribute.

Návratové hodnoty

Nevrací se žádná hodnota.

Errors/Exceptions

DOM_NO_MODIFICATION_ALLOWED_ERR

Raised if the node is readonly.

DOM_NAMESPACE_ERR

Raised if qualifiedName is a malformed qualified name, or if qualifiedName has a prefix and namespaceURI is NULL.

Viz také

DOMElement->hasAttributeNS()
DOMElement->getAttributeNS()
DOMElement->removeAttributeNS()

Předcházející | Nahoru | Další
DOMElement->setAttributeNodeNS() | Domů | DOMElement->setIdAttribute()


DOMImplementation->createDocument()

(No version information available, might be only in CVS)

DOMImplementation->createDocument() — Creates a DOMDocument object of the specified type with its document element

Popis

class DOMImplementation {
DOMDocument createDocument ( [string $namespaceURI [, string $qualifiedName [, DOMDocumentType $doctype]]] )
}

Creates a DOMDocument object of the specified type with its document element.

Seznam parametrů

namespaceURI

The namespace URI of the document element to create.

qualifiedName

The qualified name of the document element to create.

doctype

The type of document to create or NULL.

Návratové hodnoty

A new DOMDocument object. If namespaceURI, qualifiedName, and doctype are null, the returned DOMDocument is empty with no document element

Errors/Exceptions

DOM_WRONG_DOCUMENT_ERR

Raised if doctype has already been used with a different document or was created from a different implementation.

DOM_NAMESPACE_ERR

Raised if there is an error with the namespace, as determined by namespaceURI and qualifiedName.

Viz také

DOMDocument->__construct()
DOMImplementation->createDocumentType()

Předcházející | Nahoru | Další
DOMImplementation->__construct() | Domů | DOMImplementation->createDocumentType()


DOMImplementation->createDocumentType()

(No version information available, might be only in CVS)

DOMImplementation->createDocumentType() — Creates an empty DOMDocumentType object

Popis

class DOMImplementation {
DOMDocumentType createDocumentType ( [string $qualifiedName [, string $publicId [, string $systemId]]] )
}

Creates an empty DOMDocumentType object. Entity declarations and notations are not made available. Entity reference expansions and default attribute additions do not occur.

Seznam parametrů

qualifiedName

The qualified name of the document type to create.

publicId

The external subset public identifier.

systemId

The external subset system identifier.

Návratové hodnoty

A new DOMDocumentType node with its ownerDocument set to NULL.

Příklady

Příklad 430. Creating a document with an attached DTD

<?php

// Creates an instance of the DOMImplementation class
$imp = new DOMImplementation;

// Creates a DOMDocumentType instance
$dtd = $imp->createDocumentType('graph', '', 'graph.dtd');

// Creates a DOMDocument instance
$dom = $imp->createDocument("", "", $dtd);

// Set other properties
$dom->encoding = 'UTF-8';
$dom->standalone = false;

// Create an empty element
$element = $dom->createElement('graph');

// Append the element
$dom->appendChild($element);

// Retrieve and print the document
echo $dom->saveXML();

?>

Výše uvedený příklad vypíše:

<?xml version="1.0" encoding="UTF-8" standalone="no" ?>
<!DOCTYPE graph SYSTEM "graph.dtd">
<graph/>

Errors/Exceptions

DOM_NAMESPACE_ERR

Raised if there is an error with the namespace, as determined by qualifiedName.

Viz také

DOMImplementation->createDocument()

Předcházející | Nahoru | Další
DOMImplementation->createDocument() | Domů | DOMImplementation->hasFeature()


DOMImplementation->hasFeature()

(No version information available, might be only in CVS)

DOMImplementation->hasFeature() — Test if the DOM implementation implements a specific feature

Popis

class DOMImplementation {
bool hasFeature ( string $feature, string $version )
}

Test if the DOM implementation implements a specific feature.

You can find a list of all features in the » Conformance section of the DOM specification.

Seznam parametrů

feature

The feature to test.

version

The version number of the feature to test. In level 2, this can be either 2.0 or 1.0.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 431. Testing your DOM Implementation

<?php

$features = array(
  'Core'           => 'Core module',
  'XML'            => 'XML module',
  'HTML'           => 'HTML module',
  'Views'          => 'Views module',
  'Stylesheets'    => 'Style Sheets module',
  'CSS'            => 'CSS module',
  'CSS2'           => 'CSS2 module',
  'Events'         => 'Events module',
  'UIEvents'       => 'User interface Events module',
  'MouseEvents'    => 'Mouse Events module',
  'MutationEvents' => 'Mutation Events module',
  'HTMLEvents'     => 'HTML Events module',
  'Range'          => 'Range module',
  'Traversal'      => 'Traversal module'
);

foreach ($features as $key => $name) {
  if (DOMImplementation::hasFeature($key, '2.0')) {
    echo "Has feature $name\n";
  } else {
    echo "Missing feature $name\n";
  }
}

?>

Viz také

DOMNode->isSupported()

Předcházející | Nahoru | Další
DOMImplementation->createDocumentType() | Domů | DOMNamedNodeMap->getNamedItem()


DOMNamedNodeMap->getNamedItem()

(No version information available, might be only in CVS)

DOMNamedNodeMap->getNamedItem() — Retrieves a node specified by name

Popis

class DOMNamedNodeMap {
DOMNode getNamedItem ( string $name )
}

Retrieves a node specified by its nodeName.

Seznam parametrů

name

The nodeName of the node to retrieve.

Návratové hodnoty

A node (of any type) with the specified nodeName, or NULL if no node is found.

Viz také

DOMNamedNodeMap->getNamedItemNS()

Předcházející | Nahoru | Další
DOMImplementation->hasFeature() | Domů | DOMNamedNodeMap->getNamedItemNS()


DOMNamedNodeMap->getNamedItemNS()

(No version information available, might be only in CVS)

DOMNamedNodeMap->getNamedItemNS() — Retrieves a node specified by local name and namespace URI

Popis

class DOMNamedNodeMap {
DOMNode getNamedItemNS ( string $namespaceURI, string $localName )
}

Retrieves a node specified by localName and namespaceURI.

Seznam parametrů

namespaceURI

The namespace URI of the node to retrieve.

localName

The local name of the node to retrieve.

Návratové hodnoty

A node (of any type) with the specified local name and namespace URI, or NULL if no node is found.

Viz také

DOMNamedNodeMap->getNamedItem()

Předcházející | Nahoru | Další
DOMNamedNodeMap->getNamedItem() | Domů | DOMNamedNodeMap->item()


DOMNamedNodeMap->item()

(No version information available, might be only in CVS)

DOMNamedNodeMap->item() — Retrieves a node specified by index

Popis

class DOMNamedNodeMap {
DOMNode item ( int $index )
}

Retrieves a node specified by index within the DOMNamedNodeMap object.

Seznam parametrů

index

Index into this map.

Návratové hodnoty

The node at the indexth position in the map, or NULL if that is not a valid index (greater than or equal to the number of nodes in this map).

Předcházející | Nahoru | Další
DOMNamedNodeMap->getNamedItemNS() | Domů | DOMNode->appendChild()


DOMNode->appendChild()

(No version information available, might be only in CVS)

DOMNode->appendChild() — Adds new child at the end of the children

Popis

class DOMNode {
DOMNode appendChild ( DOMNode $newnode )
}

This functions appends a child to an existing list of children or creates a new list of children. The child can be created with e.g. DOMDocument->createElement(), DOMDocument->createTextNode() etc. or simply by using any other node.

Seznam parametrů

newnode

The appended child.

Návratové hodnoty

The node added.

Errors/Exceptions

DOM_NO_MODIFICATION_ALLOWED_ERR

Raised if this node is readonly or if the previous parent of the node being inserted is readonly.

DOM_HIERARCHY_REQUEST_ERR

Raised if this node is of a type that does not allow children of the type of the newnode node, or if the node to append is one of this node's ancestors or this node itself.

DOM_WRONG_DOCUMENT_ERR

Raised if newnode was created from a different document than the one that created this node.

Příklady

The following example will add a new element node to a fresh document.

Příklad 432. Adding a child

<?php

$doc = new DOMDocument;

$node = $doc->createElement("para");
$newnode = $doc->appendChild($node);

echo $doc->saveXML();
?>

Viz také

DOMNode->removeChild()
DOMNode->replaceChild()

Předcházející | Nahoru | Další
DOMNamedNodeMap->item() | Domů | DOMNode->cloneNode()


DOMNode->cloneNode()

(No version information available, might be only in CVS)

DOMNode->cloneNode() — Clones a node

Popis

class DOMNode {
DOMNode cloneNode ( [bool $deep] )
}

Creates a copy of the node.

Seznam parametrů

deep

Indicates whether to copy all descendant nodes. This parameter is defaulted to FALSE.

Návratové hodnoty

The cloned node.

Předcházející | Nahoru | Další
DOMNode->appendChild() | Domů | DOMNode->hasAttributes()


DOMNode->hasAttributes()

(No version information available, might be only in CVS)

DOMNode->hasAttributes() — Checks if node has attributes

Popis

class DOMNode {
bool hasAttributes ( void )
}

This method checks if the node has attributes. The tested node have to be an XML_ELEMENT_NODE.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

DOMNode->hasChildNodes()

Předcházející | Nahoru | Další
DOMNode->cloneNode() | Domů | DOMNode->hasChildNodes()


DOMNode->hasChildNodes()

(No version information available, might be only in CVS)

DOMNode->hasChildNodes() — Checks if node has children

Popis

class DOMNode {
bool hasChildNodes ( void )
}

This function checks if the node has children.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

DOMNode->hasAttributes()

Předcházející | Nahoru | Další
DOMNode->hasAttributes() | Domů | DOMNode->insertBefore()


DOMNode->insertBefore()

(No version information available, might be only in CVS)

DOMNode->insertBefore() — Adds a new child before a reference node

Popis

class DOMNode {
DOMNode insertBefore ( DOMNode $newnode [, DOMNode $refnode] )
}

This function inserts a new node right before the reference node. If you plan to do further modifications on the appended child you must use the returned node.

Seznam parametrů

newnode

The new node.

refnode

The reference node. If not supplied, newnode is appended to the children.

Návratové hodnoty

The inserted node.

Errors/Exceptions

DOM_NO_MODIFICATION_ALLOWED_ERR

Raised if this node is readonly or if the previous parent of the node being inserted is readonly.

DOM_HIERARCHY_REQUEST_ERR

Raised if this node is of a type that does not allow children of the type of the newnode node, or if the node to append is one of this node's ancestors or this node itself.

DOM_WRONG_DOCUMENT_ERR

Raised if newnode was created from a different document than the one that created this node.

DOM_NOT_FOUND

Raised if refnode is not a child of this node.

Předcházející | Nahoru | Další
DOMNode->hasChildNodes() | Domů | DOMNode->isDefaultNamespace()


DOMNode->isSameNode()

(No version information available, might be only in CVS)

DOMNode->isSameNode() — Indicates if two nodes are the same node

Popis

class DOMNode {
bool isSameNode ( DOMNode $node )
}

This function indicates if two nodes are the same node. The comparison is not based on content

Seznam parametrů

node

The compared node.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
DOMNode->isDefaultNamespace() | Domů | DOMNode->isSupported()


DOMNode->isSupported()

(No version information available, might be only in CVS)

DOMNode->isSupported() — Checks if feature is supported for specified version

Popis

class DOMNode {
bool isSupported ( string $feature, string $version )
}

Checks if the asked feature is supported for the specified version.

Seznam parametrů

feature

The feature to test. See the example of DOMImplementation->hasFeature() for a list of features.

version

The version number of the feature to test.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

DOMImplementation->hasFeature()

Předcházející | Nahoru | Další
DOMNode->isSameNode() | Domů | DOMNode->lookupNamespaceURI()


DOMNode->lookupNamespaceURI()

(No version information available, might be only in CVS)

DOMNode->lookupNamespaceURI() — Gets the namespace URI of the node based on the prefix

Popis

class DOMNode {
string lookupNamespaceURI ( string $prefix )
}

Gets the namespace URI of the node based on the prefix.

Seznam parametrů

prefix

The prefix of the namespace.

Návratové hodnoty

The namespace URI of the node.

Viz také

DOMNode->lookupPrefix()

Předcházející | Nahoru | Další
DOMNode->isSupported() | Domů | DOMNode->lookupPrefix()


DOMNode->lookupPrefix()

(No version information available, might be only in CVS)

DOMNode->lookupPrefix() — Gets the namespace prefix of the node based on the namespace URI

Popis

class DOMNode {
string lookupPrefix ( string $namespaceURI )
}

Gets the namespace prefix of the node based on the namespace URI.

Seznam parametrů

namespaceURI

The namespace URI.

Návratové hodnoty

The prefix of the namespace.

Viz také

DOMNode->lookupNamespaceURI()

Předcházející | Nahoru | Další
DOMNode->lookupNamespaceURI() | Domů | DOMNode->normalize()


DOMNode->normalize()

(No version information available, might be only in CVS)

DOMNode->normalize() — Normalizes the node

Popis

class DOMNode {
void normalize ( void )
}

Normalizes the node.

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

» The DOM Specification
DOMDocument->normalizeDocument()

Předcházející | Nahoru | Další
DOMNode->lookupPrefix() | Domů | DOMNode->removeChild()


DOMNode->removeChild()

(No version information available, might be only in CVS)

DOMNode->removeChild() — Removes child from list of children

Popis

class DOMNode {
DOMNode removeChild ( DOMNode $oldnode )
}

This functions removes a child from a list of children.

Seznam parametrů

oldnode

The removed child.

Návratové hodnoty

If the child could be removed the functions returns the old child.

Errors/Exceptions

DOM_NO_MODIFICATION_ALLOWED_ERR

Raised if this node is readonly.

DOM_NOT_FOUND

Raised if oldnode is not a child of this node.

Příklady

The following example will delete the chapter element of our XML document.

Příklad 433. Removing a child

<?php

$doc = new DOMDocument;
$doc->load('book.xml');

$book = $doc->documentElement;

// we retrieve the chapter and remove it from the book
$chapter = $book->getElementsByTagName('chapter')->item(0);
$oldchapter = $book->removeChild($chapter);

echo $doc->saveXML();
?>

Výše uvedený příklad vypíše:

<?xml version="1.0" encoding="iso-8859-1" ?>
<!DOCTYPE book PUBLIC "-//OASIS//DTD DocBook XML V4.1.2//EN"
"http://www.oasis-open.org/docbook/xml/4.1.2/docbookx.dtd">
<book id="listing">
<title>My lists</title>

</book>

Viz také

DOMNode->appendChild()
DOMNode->replaceChild()

Předcházející | Nahoru | Další
DOMNode->normalize() | Domů | DOMNode->replaceChild()


DOMNode->replaceChild()

(No version information available, might be only in CVS)

DOMNode->replaceChild() — Replaces a child

Popis

class DOMNode {
DOMNode replaceChild ( DOMNode $newnode, DOMNode $oldnode )
}

This function replaces the child oldnode with the passed new node. If the new node is already a child it will not be added a second time. If the replacement succeeds the old node is returned.

Seznam parametrů

newnode

The new node. It must be a member of the target document, i.e. created by one of the DOMDocument->createXXX() methods or imported in the document by DOMDocument->importNode().

oldnode

The old node.

Návratové hodnoty

The old node or FALSE if an error occur.

Errors/Exceptions

DOM_NO_MODIFICATION_ALLOWED_ERR

Raised if this node is readonly or if the previous parent of the node being inserted is readonly.

DOM_HIERARCHY_REQUEST_ERR

Raised if this node is of a type that does not allow children of the type of the newnode node, or if the node to put in is one of this node's ancestors or this node itself.

DOM_WRONG_DOCUMENT_ERR

Raised if newnode was created from a different document than the one that created this node.

DOM_NOT_FOUND

Raised if oldnode is not a child of this node.

Viz také

DOMNode->appendChild()
DOMNode->removeChild()

Předcházející | Nahoru | Další
DOMNode->removeChild() | Domů | DOMNodelist->item()


DOMNodelist->item()

(No version information available, might be only in CVS)

DOMNodelist->item() — Retrieves a node specified by index

Popis

class DOMNodeList {
DOMNode item ( int $index )
}

Retrieves a node specified by index within the DOMNodeList object.

Tip

If you need to know the number of nodes in the collection, use the length property of the DOMNodeList object.

Seznam parametrů

index

Index of the node into the collection.

Návratové hodnoty

The node at the indexth position in the DOMNodeList, or NULL if that is not a valid index.

Příklady

Příklad 434. Traversing all the entries of the table

<?php

$doc = new DOMDocument;
$doc->load('book.xml');

$items = $doc->getElementsByTagName('entry');

for ($i = 0; $i < $items->length; $i++) {
    echo $items->item($i)->nodeValue . "\n";
}

?>

Alternatively, you can use foreach, which is a much more convenient way:

<?php

foreach ($items as $item) {
    echo $item->nodeValue . "\n";
}

?>

Výše uvedený příklad vypíše:

Title
Author
Language
ISBN
The Grapes of Wrath
John Steinbeck
en
0140186409
The Pearl
John Steinbeck
en
014017737X
Samarcande
Amine Maalouf
fr
2253051209

Předcházející | Nahoru | Další
DOMNode->replaceChild() | Domů | DOMProcessingInstruction->__construct()


DOMText->isWhitespaceInElementContent()

(No version information available, might be only in CVS)

DOMText->isWhitespaceInElementContent() — Indicates whether this text node contains whitespace

Popis

class DOMText {
bool isWhitespaceInElementContent ( void )
}

Indicates whether this text node contains whitespace. The text node is determined to contain whitespace in element content during the load of the document.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
DOMText->__construct() | Domů | DOMText->splitText()


DOMText->splitText()

(No version information available, might be only in CVS)

DOMText->splitText() — Breaks this node into two nodes at the specified offset

Popis

class DOMText {
DOMText splitText ( int $offset )
}

Breaks this node into two nodes at the specified offset, keeping both in the tree as siblings.

After being split, this node will contain all the content up to the offset. If the original node had a parent node, the new node is inserted as the next sibling of the original node. When the offset is equal to the length of this node, the new node has no data.

Seznam parametrů

offset

The offset at which to split, starting from 0.

Návratové hodnoty

The new node of the same type, which contains all the content at and after the offset.

Předcházející | Nahoru | Další
DOMText->isWhitespaceInElementContent() | Domů | DOMXPath->__construct()


DOMXPath->query()

(No version information available, might be only in CVS)

DOMXPath->query() — Evaluates the given XPath expression

Popis

class DOMXPath {
DOMNodeList query ( string $expression [, DOMNode $contextnode] )
}

Executes the given XPath expression.

Seznam parametrů

expression

The XPath expression to execute.

contextnode

The optional contextnode can be specified for doing relative XPath queries. By default, the queries are relative to the root element.

Návratové hodnoty

Returns a DOMNodeList containing all nodes matching the given XPath expression. Any expression which do not return nodes will return an empty DOMNodeList.

Příklady

Příklad 438. Getting all the english books

<?php

$doc = new DOMDocument;

// We don't want to bother with white spaces
$doc->preserveWhiteSpace = false;

$doc->Load('book.xml');

$xpath = new DOMXPath($doc);

// We starts from the root element
$query = '//book/chapter/para/informaltable/tgroup/tbody/row/entry[. = "en"]';

$entries = $xpath->query($query);

foreach ($entries as $entry) {
    echo "Found {$entry->previousSibling->previousSibling->nodeValue}," .
         " by {$entry->previousSibling->nodeValue}\n";
}
?>

Výše uvedený příklad vypíše:

Found The Grapes of Wrath, by John Steinbeck
Found The Pearl, by John Steinbeck

We can also use the contextnode parameter to shorten our expression:

<?php

$doc = new DOMDocument;
$doc->preserveWhiteSpace = false;

$doc->load('book.xml');

$xpath = new DOMXPath($doc);

$tbody = $doc->getElementsByTagName('tbody')->item(0);

// our query is relative to the tbody node
$query = 'row/entry[. = "en"]';

$entries = $xpath->query($query, $tbody);

foreach ($entries as $entry) {
    echo "Found {$entry->previousSibling->previousSibling->nodeValue}," .
         " by {$entry->previousSibling->nodeValue}\n";
}
?>

Viz také

DOMXPath->evaluate()

Předcházející | Nahoru | Další
DOMXPath->evaluate() | Domů | DOMXPath->registerNamespace()


DOMXPath->registerNamespace()

(No version information available, might be only in CVS)

DOMXPath->registerNamespace() — Registers the namespace with the DOMXPath object

Popis

class DOMXPath {
bool registerNamespace ( string $prefix, string $namespaceURI )
}

Registers the namespaceURI and prefix with the DOMXPath object.

Seznam parametrů

prefix

The prefix.

namespaceURI

The URI of the namespace.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
DOMXPath->query() | Domů | dom_import_simplexml


dom_import_simplexml

(PHP 5)

dom_import_simplexml — Gets a DOMElement object from a SimpleXMLElement object

Popis

DOMElement dom_import_simplexml ( SimpleXMLElement $node )

This function takes the node node of class SimpleXML and makes it into a DOMElement node. This new object can then be used as a native DOMElement node.

Seznam parametrů

node

The SimpleXMLElement node.

Návratové hodnoty

The DOMElement node added or FALSE if any errors occur.

Příklady

Příklad 439. Import SimpleXML into DOM with dom_import_simplexml()

<?php

$sxe = simplexml_load_string('<books><book><title>blah</title></book></books>');

if ($sxe === false) {
    echo 'Error while parsing the document';
    exit;
}

$dom_sxe = dom_import_simplexml($sxe);
if (!$dom_sxe) {
    echo 'Error while converting XML';
    exit;
}

$dom = new DOMDocument('1.0');
$dom_sxe = $dom->importNode($dom_sxe, true);
$dom_sxe = $dom->appendChild($dom_sxe);

echo $dom->saveXML();

?>

Viz také

simplexml_import_dom()

Předcházející | Nahoru | Další
DOMXPath->registerNamespace() | Domů | XXXII. DOM XML Functions


DOM XML Functions

Předcházející VI. Reference funkcí Další

XXXII. DOM XML Functions

Úvod

The DOM XML extension has been overhauled in PHP 4.3.0 to better comply with the DOM standard. The extension still contains many old functions, but they should no longer be used. In particular, functions that are not object-oriented should be avoided.

The extension allows you to operate on an XML document with the DOM API. It also provides a function domxml_xmltree() to turn the complete XML document into a tree of PHP objects. Currently, this tree should be considered read-only - you can modify it, but this would not make any sense since DomDocument_dump_mem() cannot be applied to it. Therefore, if you want to read an XML file and write a modified version, use DomDocument_create_element(), DomDocument_create_text_node(), set_attribute(), etc. and finally the DomDocument_dump_mem() function.

Poznámka: Toto rozšíření bylo přesunuto do repozitáře PECL a již nebude součástí balíku PHP.5.0.0.

Poznámka: This extension is no longer marked experimental. It will, however, never be released with PHP 5, and will only be distributed with PHP 4. If you need DOM XML support with PHP 5 you can use the DOM extension. This domxml extension is not compatible with the DOM extension.

Požadavky

This extension makes use of the » GNOME XML library. Download and install this library. You will need at least libxml-2.4.14. To use DOM XSLT features you can use the » libxslt library and EXSLT enhancements from » http://www.exslt.org/. Download and install these libraries if you plan to use (enhanced) XSLT features. You will need at least libxslt-1.0.18.

Instalace

Toto rozšíření » PECL není přibaleno k PHP. Informace o instalaci tohoto PECL rozšíření lze najít v kapitole manuálu nazvané Instalace rozšíření PECL. Další informace, jako nové verze, soubory ke stažení, zdrojové soubory, správcovské informace a CHANGELOG, lze najít zde: » http://pecl.php.net/package/domxml.

V PHP 4 lze zdroje k těmto rozšířením PECL najít v adresáři ext/ ve zdrojích PHP source or nebo přes výše uvedený odkaz na PECL. This extension is only available if PHP was configured with --with-dom[=DIR]. Add --with-dom-xslt[=DIR] to include DOM XSLT support. DIR is the libxslt install directory. Add --with-dom-exslt[=DIR] to include DOM EXSLT support, where DIR is the libexslt install directory.

Windows users will enable php_domxml.dll inside of php.ini in order to use these functions. V PHP 4 je tato DLL knihovna umístěna v adresáři extensions/ v downloadu binárních souborů PHP pro Windows. Tuto DLL knihovnu pro rozšíření PECL můžete stahovat ze stránky » PHP Downloads nebo z » http://snaps.php.net/. Also, there is one additional DLL that must be made available to your system's PATH in order for this extension to work. In PHP 4 this is in the dlls/ directory. It's name: For PHP <= 4.2.0, it's libxml2.dll. For PHP >= 4.3.0, it's iconv.dll. And as of PHP 5.0.0, iconv is compiled into your Windows PHP binaries by default so no extra DLL is needed.

Deprecated functions

There are quite a few functions that do not fit into the DOM standard and should no longer be used. These functions are listed in the following table. The function DomNode_append_child() has changed its behaviour. It now adds a child and not a sibling. If this breaks your application, use the non-DOM function DomNode_append_sibling().

Tabulka 60. Deprecated functions and their replacements

Old function | New function
xmldoc | domxml_open_mem()
xmldocfile | domxml_open_file()
domxml_new_xmldoc | domxml_new_doc()
domxml_dump_mem | DomDocument_dump_mem()
domxml_dump_mem_file | DomDocument_dump_file()
DomDocument_dump_mem_file | DomDocument_dump_file()
DomDocument_add_root | DomDocument_create_element() followed by DomNode_append_child()
DomDocument_dtd | DomDocument_doctype()
DomDocument_root | DomDocument_document_element()
DomDocument_children | DomNode_child_nodes()
DomDocument_imported_node | No replacement.
DomNode_add_child | Create a new node with e.g. DomDocument_create_element() and add it with DomNode_append_child().
DomNode_children | DomNode_child_nodes()
DomNode_parent | DomNode_parent_node()
DomNode_new_child | Create a new node with e.g. DomDocument_create_element() and add it with DomNode_append_child().
DomNode_set_content | Create a new node with e.g. DomDocument_create_text_node() and add it with DomNode_append_child().
DomNode_get_content | Content is just a text node and can be accessed with DomNode_child_nodes().
DomNode_set_content | Content is just a text node and can be added with DomNode_append_child().

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

Tabulka 61. XML konstanty

Konstanta | Hodnota | Popis
XML_ELEMENT_NODE (integer) | 1 | Uzel je element
XML_ATTRIBUTE_NODE (integer) | 2 | Uzel je atribut
XML_TEXT_NODE (integer) | 3 | Uzel je kus textu
XML_CDATA_SECTION_NODE (integer) | 4 |
XML_ENTITY_REF_NODE (integer) | 5 |
XML_ENTITY_NODE (integer) | 6 | Uzel je entita jako &nbsp;
XML_PI_NODE (integer) | 7 | Uzel je instrukce zpracování
XML_COMMENT_NODE (integer) | 8 | Uzel je komentář
XML_DOCUMENT_NODE (integer) | 9 | Uzel je dokument
XML_DOCUMENT_TYPE_NODE (integer) | 10 |
XML_DOCUMENT_FRAG_NODE (integer) | 11 |
XML_NOTATION_NODE (integer) | 12 |
XML_GLOBAL_NAMESPACE (integer) | 1 |
XML_LOCAL_NAMESPACE (integer) | 2 |
XML_HTML_DOCUMENT_NODE (integer) |  |
XML_DTD_NODE (integer) |  |
XML_ELEMENT_DECL_NODE (integer) |  |
XML_ATTRIBUTE_DECL_NODE (integer) |  |
XML_ENTITY_DECL_NODE (integer) |  |
XML_NAMESPACE_DECL_NODE (integer) |  |
XML_ATTRIBUTE_CDATA (integer) |  |
XML_ATTRIBUTE_ID (integer) |  |
XML_ATTRIBUTE_IDREF (integer) |  |
XML_ATTRIBUTE_IDREFS (integer) |  |
XML_ATTRIBUTE_ENTITY (integer) |  |
XML_ATTRIBUTE_NMTOKEN (integer) |  |
XML_ATTRIBUTE_NMTOKENS (integer) |  |
XML_ATTRIBUTE_ENUMERATION (integer) |  |
XML_ATTRIBUTE_NOTATION (integer) |  |
XPATH_UNDEFINED (integer) |  |
XPATH_NODESET (integer) |  |
XPATH_BOOLEAN (integer) |  |
XPATH_NUMBER (integer) |  |
XPATH_STRING (integer) |  |
XPATH_POINT (integer) |  |
XPATH_RANGE (integer) |  |
XPATH_LOCATIONSET (integer) |  |
XPATH_USERS (integer) |  |
XPATH_NUMBER (integer) |  |

Classes

The API of the module follows the DOM Level 2 standard as closely as possible. Consequently, the API is fully object-oriented. It is a good idea to have the DOM standard available when using this module. Though the API is object-oriented, there are many functions which can be called in a non-object-oriented way by passing the object to operate on as the first argument. These functions are mainly to retain compatibility to older versions of the extension, and should not be used when creating new scripts.

This API differs from the official DOM API in two ways. First, all class attributes are implemented as functions with the same name. Secondly, the function names follow the PHP naming convention. This means that a DOM function lastChild() will be written as last_child().

This module defines a number of classes, which are listed - including their method - in the following tables. Classes with an equivalent in the DOM standard are named DOMxxx.

Tabulka 62. List of classes

Class name | Parent classes
DomAttribute | DomNode
DomCData | DomNode
DomComment | DomCData : DomNode
DomDocument | DomNode
DomDocumentType | DomNode
DomElement | DomNode
DomEntity | DomNode
DomEntityReference | DomNode
DomProcessingInstruction | DomNode
DomText | DomCData : DomNode
Parser | Currently still called DomParser
XPathContext |

Tabulka 63. DomDocument class (DomDocument : DomNode)

Method name | Function name | Remark
doctype | DomDocument_doctype() |
document_element | DomDocument_document_element() |
create_element | DomDocument_create_element() |
create_text_node | DomDocument_create_text_node() |
create_comment | DomDocument_create_comment() |
create_cdata_section | DomDocument_create_cdata_section() |
create_processing_instruction | DomDocument_create_processing_instruction() |
create_attribute | DomDocument_create_attribute() |
create_entity_reference | DomDocument_create_entity_reference() |
get_elements_by_tagname | DomDocument_get_elements_by_tagname() |
get_element_by_id | DomDocument_get_element_by_id() |
dump_mem | DomDocument_dump_mem() | not DOM standard
dump_file | DomDocument_dump_file() | not DOM standard
html_dump_mem | DomDocument_html_dump_mem() | not DOM standard
xpath_init | xpath_init | not DOM standard
xpath_new_context | xpath_new_context | not DOM standard
xptr_new_context | xptr_new_context | not DOM standard

Tabulka 64. DomElement class (DomElement : DomNode)

Method name | Function name | Remark
tagname | DomElement_tagname() |
get_attribute | DomElement_get_attribute() |
set_attribute | DomElement_set_attribute() |
remove_attribute | DomElement_remove_attribute() |
get_attribute_node | DomElement_get_attribute_node() |
set_attribute_node | DomElement_set_attribute_node() |
get_elements_by_tagname | DomElement_get_elements_by_tagname() |
has_attribute | DomElement_has_attribute() |

Tabulka 65. DomNode class

Method name | Remark
DomNode_node_name() |
DomNode_node_value() |
DomNode_node_type() |
DomNode_last_child() |
DomNode_first_child() |
DomNode_child_nodes() |
DomNode_previous_sibling() |
DomNode_next_sibling() |
DomNode_parent_node() |
DomNode_owner_document() |
DomNode_insert_before() |
DomNode_append_child() |
DomNode_append_sibling() | Not in DOM standard. This function emulates the former behaviour of DomNode_append_child().
DomNode_remove_child() |
DomNode_has_child_nodes() |
DomNode_has_attributes() |
DomNode_clone_node() |
DomNode_attributes() |
DomNode_unlink_node() | Not in DOM standard
DomNode_replace_node() | Not in DOM standard
DomNode_set_content() | Not in DOM standard, deprecated
DomNode_get_content() | Not in DOM standard, deprecated
DomNode_dump_node() | Not in DOM standard
DomNode_is_blank_node() | Not in DOM standard

Tabulka 66. DomAttribute class (DomAttribute : DomNode)

Method name |  | Remark
name | DomAttribute_name() |
value | DomAttribute_value() |
specified | DomAttribute_specified() |

Tabulka 67. DomProcessingInstruction class (DomProcessingInstruction : DomNode)

Method name | Function name | Remark
target | DomProcessingInstruction_target() |
data | DomProcessingInstruction_data() |

Tabulka 68. Parser class

Method name | Function name | Remark
add_chunk | Parser_add_chunk() |
end | Parser_end() |

Tabulka 69. XPathContext class

Method name | Function name | Remark
eval | XPathContext_eval() |
eval_expression | XPathContext_eval_expression() |
register_ns | XPathContext_register_ns() |

Tabulka 70. DomDocumentType class (DomDocumentType : DomNode)

Method name | Function name | Remark
name | DomDocumentType_name() |
entities | DomDocumentType_entities() |
notations | DomDocumentType_notations() |
public_id | DomDocumentType_public_id() |
system_id | DomDocumentType_system_id() |
internal_subset | DomDocumentType_internal_subset() |

The classes DomDtd is derived from DomNode. DomComment is derived from DomCData.

Příklady

Many examples in this reference require an XML string. Instead of repeating this string in every example, it will be put into a file which will be included by each example. This include file is shown in the following example section. Alternatively, you could create an XML document and read it with DomDocument_open_file().

Příklad 440. Include file example.inc with XML string

<?php
$xmlstr = "<?xml version='1.0' standalone='yes'?>
<!DOCTYPE chapter SYSTEM '/share/sgml/Norman_Walsh/db3xml10/db3xml10.dtd'
[ <!ENTITY sp \"spanish\">
]>
<!-- lsfj  -->
<chapter language='en'><title language='en'>Title</title>
 <para language='ge'>
  &sp;
  <!-- comment -->
  <informaltable ID='findme' language='&sp;'>
   <tgroup cols='3'>
    <tbody>
     <row><entry>a1</entry><entry
morerows='1'>b1</entry><entry>c1</entry></row>
<row><entry>a2</entry><entry>c2</entry></row>
     <row><entry>a3</entry><entry>b3</entry><entry>c3</entry></row>
    </tbody>
   </tgroup>
  </informaltable>
 </para>
</chapter>";
?>

Obsah

DomAttribute->name — Returns the name of attribute
DomAttribute->set_value — Sets the value of an attribute
DomAttribute->specified — Checks if attribute is specified
DomAttribute->value — Returns value of attribute
DomDocument->add_root — Adds a root node [deprecated]
DomDocument->create_attribute — Create new attribute
DomDocument->create_cdata_section — Create new cdata node
DomDocument->create_comment — Create new comment node
DomDocument->create_element_ns — Create new element node with an associated namespace
DomDocument->create_element — Create new element node
DomDocument->create_entity_reference — Create an entity reference
DomDocument->create_processing_instruction — Creates new PI node
DomDocument->create_text_node — Create new text node
DomDocument->doctype — Returns the document type
DomDocument->document_element — Returns root element node
DomDocument->dump_file — Dumps the internal XML tree back into a file
DomDocument->dump_mem — Dumps the internal XML tree back into a string
DomDocument->get_element_by_id — Searches for an element with a certain id
DomDocument->get_elements_by_tagname — Returns array with nodes with given tagname in document or empty array, if not found
DomDocument->html_dump_mem — Dumps the internal XML tree back into a string as HTML
DomDocument->xinclude — Substitutes XIncludes in a DomDocument Object
DomDocumentType->entities() — Returns list of entities
DomDocumentType->internal_subset() — Returns internal subset
DomDocumentType->name() — Returns name of document type
DomDocumentType->notations() — Returns list of notations
DomDocumentType->public_id() — Returns public id of document type
DomDocumentType->system_id() — Returns the system id of document type
DomElement->get_attribute_node() — Returns the node of the given attribute
DomElement->get_attribute() — Returns the value of the given attribute
DomElement->get_elements_by_tagname() — Gets elements by tagname
DomElement->has_attribute() — Checks to see if an attribute exists in the current node
DomElement->remove_attribute() — Removes attribute
DomElement->set_attribute_node() — Adds new attribute
DomElement->set_attribute() — Sets the value of an attribute
DomElement->tagname() — Returns the name of the current element
DomNode->add_namespace — Adds a namespace declaration to a node
DomNode->append_child — Adds a new child at the end of the children
DomNode->append_sibling — Adds new sibling to a node
DomNode->attributes — Returns list of attributes
DomNode->child_nodes — Returns children of node
DomNode->clone_node — Clones a node
DomNode->dump_node — Dumps a single node
DomNode->first_child — Returns first child of node
DomNode->get_content — Gets content of node
DomNode->has_attributes — Checks if node has attributes
DomNode->has_child_nodes — Checks if node has children
DomNode->insert_before — Inserts new node as child
DomNode->is_blank_node — Checks if node is blank
DomNode->last_child — Returns last child of node
DomNode->next_sibling — Returns the next sibling of node
DomNode->node_name — Returns name of node
DomNode->node_type — Returns type of node
DomNode->node_value — Returns value of a node
DomNode->owner_document — Returns the document this node belongs to
DomNode->parent_node — Returns the parent of the node
DomNode->prefix — Returns name space prefix of node
DomNode->previous_sibling — Returns the previous sibling of node
DomNode->remove_child — Removes child from list of children
DomNode->replace_child — Replaces a child
DomNode->replace_node — Replaces node
DomNode->set_content — Sets content of node
DomNode->set_name — Sets name of node
DomNode->set_namespace — Sets namespace of a node
DomNode->unlink_node — Deletes node
DomProcessingInstruction->data — Returns the data of ProcessingInstruction node
DomProcessingInstruction->target — Returns the target of a ProcessingInstruction node
DomXsltStylesheet->process() — Applies the XSLT-Transformation on a DomDocument Object
DomXsltStylesheet->result_dump_file() — Dumps the result from a XSLT-Transformation into a file
DomXsltStylesheet->result_dump_mem() — Dumps the result from a XSLT-Transformation back into a string
domxml_new_doc — Creates new empty XML document
domxml_open_file — Vytvořit DOM objekt z XML souboru
domxml_open_mem — Vytvořit DOM objekt z XML dokumentu
domxml_version — Gets the XML library version
domxml_xmltree — Vytvořit strom PHP objektů z XML dokumentu
domxml_xslt_stylesheet_doc — Creates a DomXsltStylesheet Object from a DomDocument Object
domxml_xslt_stylesheet_file — Creates a DomXsltStylesheet Object from an XSL document in a file
domxml_xslt_stylesheet — Creates a DomXsltStylesheet object from an XSL document in a string
domxml_xslt_version — Gets the XSLT library version
xpath_eval_expression — Evaluates the XPath Location Path in the given string
xpath_eval — Evaluates the XPath Location Path in the given string
xpath_new_context — Creates new xpath context
xpath_register_ns_auto — Register the given namespace in the passed XPath context
xpath_register_ns — Register the given namespace in the passed XPath context
xptr_eval — Evaluate the XPtr Location Path in the given string
xptr_new_context — Create new XPath Context
Předcházející | Nahoru | Další
dom_import_simplexml | Domů | DomAttribute->name


DomAttribute->name

(No version information available, might be only in CVS)

DomAttribute->name — Returns the name of attribute

Popis

class DomAttribute {
string name ( void )
}

Gets the name of the attribute.

Návratové hodnoty

Returns the name of the attribute.

Migrating to PHP 5

Use the name property of DOMAttr.

Viz také

DomAttribute->value for an example

Předcházející | Nahoru | Další
XXXII. DOM XML Functions | Domů | DomAttribute->set_value


DomAttribute->specified

(No version information available, might be only in CVS)

DomAttribute->specified — Checks if attribute is specified

Popis

class DomAttribute {
bool specified ( void )
}

Checks if the attribute was explicitly given a value in the original document.

Poznámka: This method is not implemented yet.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

The definition of » specified in the DOM Recommendations

Předcházející | Nahoru | Další
DomAttribute->set_value | Domů | DomAttribute->value


DomAttribute->value

(No version information available, might be only in CVS)

DomAttribute->value — Returns value of attribute

Popis

class DomAttribute {
string value ( void )
}

This function returns the value of the attribute.

Příklady

Příklad 441. Getting all the attributes of a node

<?php

include("example.inc");

if (!$dom = domxml_open_mem($xmlstr)) {
     echo "Error while parsing the document\n";
     exit;
}

$root = $dom->document_element();
$attrs = $root->attributes();

echo 'Attributes of ' . $root->node_name() . "\n";
foreach ($attrs as $attribute) {
     echo ' - ' . $attribute->name . ' : ' . $attribute->value . "\n";
}

?>

Výše uvedený příklad vypíše:

Attributes of chapter
 - language : en

Návratové hodnoty

Returns the value of the attribute.

Migrating to PHP 5

Use the value property of DOMAttr.

Viz také

DomAttribute->set_value
DomAttribute->name

Předcházející | Nahoru | Další
DomAttribute->specified | Domů | DomDocument->add_root


DomDocument->add_root

(No version information available, might be only in CVS)

DomDocument->add_root — Adds a root node [deprecated]

Popis

domelement DomDocument->add_root ( string $name )

Adds a root element node to a dom document and returns the new node. The element name is given in the passed parameter.

Příklad 442. Creating a simple HTML document header

<?php
$doc = domxml_new_doc("1.0");
$root = $doc->add_root("html");
$head = $root->new_child("head", "");
$head->new_child("title", "Hier der Titel");
echo htmlentities($doc->dump_mem());
?>

Předcházející | Nahoru | Další
DomAttribute->value | Domů | DomDocument->create_attribute


DomDocument->create_attribute

(No version information available, might be only in CVS)

DomDocument->create_attribute — Create new attribute

Popis

domattribute DomDocument->create_attribute ( string $name, string $value )

This function returns a new instance of class DomAttribute. The name of the attribute is the value of the first parameter. The value of the attribute is the value of the second parameter. Tento uzel se v dokumentu neobjeví, nebyl-li přidán např. funkcí domnode_append_child().

The return value is FALSE if an error occurred.

See also domnode_append_child(),
domdocument_create_element(),
domdocument_create_text(),
domdocument_create_cdata_section(),
domdocument_create_processing_instruction(),
domdocument_create_entity_reference(), and
domnode_insert_before().

Předcházející | Nahoru | Další
DomDocument->add_root | Domů | DomDocument->create_cdata_section


DomDocument->create_cdata_section

(No version information available, might be only in CVS)

DomDocument->create_cdata_section — Create new cdata node

Popis

domcdata DomDocument->create_cdata_section ( string $content )

This function returns a new instance of class DomCData. The content of the cdata is the value of the passed parameter. Tento uzel se v dokumentu neobjeví, nebyl-li přidán např. funkcí domnode_append_child().

The return value is FALSE if an error occurred.

See also domnode_append_child(),
domdocument_create_element(),
domdocument_create_text(),
domdocument_create_attribute(),
domdocument_create_processing_instruction(),
domdocument_create_entity_reference(), and
domnode_insert_before().

Předcházející | Nahoru | Další
DomDocument->create_attribute | Domů | DomDocument->create_comment


DomDocument->create_comment

(No version information available, might be only in CVS)

DomDocument->create_comment — Create new comment node

Popis

domcomment DomDocument->create_comment ( string $content )

This function returns a new instance of class DomComment. The content of the comment is the value of the passed parameter. Tento uzel se v dokumentu neobjeví, nebyl-li přidán např. funkcí domnode_append_child().

The return value is FALSE if an error occurred.

See also domnode_append_child(),
domdocument_create_element(),
domdocument_create_text(),
domdocument_create_attribute(),
domdocument_create_processing_instruction(),
domdocument_create_entity_reference(), and
domnode_insert_before().

Předcházející | Nahoru | Další
DomDocument->create_cdata_section | Domů | DomDocument->create_element_ns


DomDocument->create_element_ns

(No version information available, might be only in CVS)

DomDocument->create_element_ns — Create new element node with an associated namespace

Popis

domelement DomDocument->create_element_ns ( string $uri, string $name [, string $prefix] )

This function returns a new instance of class DomElement. The tag name of the element is the value of the passed parameter name. The URI of the namespace is the value of the passed parameter uri. If there is already a namespace declaration with the same uri in the root-node of the document, the prefix of this is taken, otherwise it will take the one provided in the optional parameter prefix or generate a random one. Tento uzel se v dokumentu neobjeví, nebyl-li přidán např. funkcí domnode_append_child().

The return value is FALSE if an error occurred.

See also domdocument_create_element_ns(),
domnode_add_namespace(),
domnode_set_namespace(),
domnode_append_child(),
domdocument_create_text(),
domdocument_create_comment(),
domdocument_create_attribute(),
domdocument_create_processing_instruction(),
domdocument_create_entity_reference(), and
domnode_insert_before().

Předcházející | Nahoru | Další
DomDocument->create_comment | Domů | DomDocument->create_element


DomDocument->create_element

(No version information available, might be only in CVS)

DomDocument->create_element — Create new element node

Popis

domelement DomDocument->create_element ( string $name )

This function returns a new instance of class DomElement. The tag name of the element is the value of the passed parameter. Tento uzel se v dokumentu neobjeví, nebyl-li přidán např. funkcí domnode_append_child().

The return value is FALSE if an error occurred.

See also domdocument_create_element_ns(),
domnode_append_child(),
domdocument_create_text(),
domdocument_create_comment(),
domdocument_create_attribute(),
domdocument_create_processing_instruction(),
domdocument_create_entity_reference(), and
domnode_insert_before().

Předcházející | Nahoru | Další
DomDocument->create_element_ns | Domů | DomDocument->create_entity_reference


DomDocument->create_entity_reference

(No version information available, might be only in CVS)

DomDocument->create_entity_reference — Create an entity reference

Popis

domentityreference DomDocument->create_entity_reference ( string $content )

This function returns a new instance of class DomEntityReference. The content of the entity reference is the value of the passed parameter. Tento uzel se v dokumentu neobjeví, nebyl-li přidán např. funkcí domnode_append_child().

The return value is FALSE if an error occurred.

See also domnode_append_child(),
domdocument_create_element(),
domdocument_create_text(),
domdocument_create_cdata_section(),
domdocument_create_processing_instruction(),
domdocument_create_attribute(), and
domnode_insert_before().

Předcházející | Nahoru | Další
DomDocument->create_element | Domů | DomDocument->create_processing_instruction


DomDocument->create_processing_instruction

(No version information available, might be only in CVS)

DomDocument->create_processing_instruction — Creates new PI node

Popis

domprocessinginstruction DomDocument->create_processing_instruction ( string $content )

This function returns a new instance of class DomCData. The content of the pi is the value of the passed parameter. Tento uzel se v dokumentu neobjeví, nebyl-li přidán např. funkcí domnode_append_child().

The return value is FALSE if an error occurred.

See also domnode_append_child(),
domdocument_create_element(),
domdocument_create_text(),
domdocument_create_cdata_section(),
domdocument_create_attribute(),
domdocument_create_entity_reference(), and
domnode_insert_before().

Předcházející | Nahoru | Další
DomDocument->create_entity_reference | Domů | DomDocument->create_text_node


DomDocument->create_text_node

(No version information available, might be only in CVS)

DomDocument->create_text_node — Create new text node

Popis

domtext DomDocument->create_text_node ( string $content )

This function returns a new instance of class DomText. The content of the text is the value of the passed parameter. Tento uzel se v dokumentu neobjeví, nebyl-li přidán např. funkcí domnode_append_child().

The return value is FALSE if an error occurred.

See also domnode_append_child(),
domdocument_create_element(),
domdocument_create_comment(),
domdocument_create_text(),
domdocument_create_attribute(),
domdocument_create_processing_instruction(),
domdocument_create_entity_reference(), and
domnode_insert_before().

Předcházející | Nahoru | Další
DomDocument->create_processing_instruction | Domů | DomDocument->doctype


DomDocument->doctype

(No version information available, might be only in CVS)

DomDocument->doctype — Returns the document type

Popis

domdocumenttype DomDocument->doctype ( void )

This function returns an object of class DomDocumentType. In versions of PHP before 4.3 this has been the class Dtd, but the DOM Standard does not know such a class.

See also the methods of class DomDocumentType.

Předcházející | Nahoru | Další
DomDocument->create_text_node | Domů | DomDocument->document_element


DomDocument->document_element

(No version information available, might be only in CVS)

DomDocument->document_element — Returns root element node

Popis

domelement DomDocument->document_element ( void )

This function returns the root element node of a document.

The following example returns just the element with name CHAPTER and prints it. The other node -- the comment -- is not returned.

Příklad 443. Retrieving root element

<?php
include("example.inc");

if (!$dom = domxml_open_mem($xmlstr)) {
  echo "Error while parsing the document\n";
  exit;
}

$root = $dom->document_element();
print_r($root);
?>

Výše uvedený příklad vypíše:

domelement Object
(
    [type] => 1
    [tagname] => chapter
    [0] => 6
    [1] => 137960648
)

Předcházející | Nahoru | Další
DomDocument->doctype | Domů | DomDocument->dump_file


DomDocument->dump_file

(No version information available, might be only in CVS)

DomDocument->dump_file — Dumps the internal XML tree back into a file

Popis

string DomDocument->dump_file ( string $filename [, bool $compressionmode [, bool $format]] )

Creates an XML document from the dom representation. This function usually is called after building a new dom document from scratch as in the example below. The format specifies whether the output should be neatly formatted, or not. The first parameter specifies the name of the filename and the second parameter, whether it should be compressed or not.

Příklad 444. Creating a simple HTML document header

<?php
$doc = domxml_new_doc("1.0");
$root = $doc->create_element("HTML");
$root = $doc->append_child($root);
$head = $doc->create_element("HEAD");
$head = $root->append_child($head);
$title = $doc->create_element("TITLE");
$title = $head->append_child($title);
$text = $doc->create_text_node("This is the title");
$text = $title->append_child($text);
$doc->dump_file("/tmp/test.xml", false, true);
?>

See also domdocument_dump_mem(), and domdocument_html_dump_mem().

Předcházející | Nahoru | Další
DomDocument->document_element | Domů | DomDocument->dump_mem


DomDocument->dump_mem

(No version information available, might be only in CVS)

DomDocument->dump_mem — Dumps the internal XML tree back into a string

Popis

string DomDocument->dump_mem ( [bool $format [, string $encoding]] )

Creates an XML document from the dom representation. This function usually is called after building a new dom document from scratch as in the example below. The format specifies whether the output should be neatly formatted, or not.

Příklad 445. Creating a simple HTML document header

<?php
$doc = domxml_new_doc("1.0");
$root = $doc->create_element("HTML");
$root = $doc->append_child($root);
$head = $doc->create_element("HEAD");
$head = $root->append_child($head);
$title = $doc->create_element("TITLE");
$title = $head->append_child($title);
$text = $doc->create_text_node("This is the title");
$text = $title->append_child($text);
echo "<PRE>";
echo htmlentities($doc->dump_mem(true));
echo "</PRE>";
?>

Poznámka: The first parameter was added in PHP 4.3.0.

See also domdocument_dump_file(), and domdocument_html_dump_mem().

Předcházející | Nahoru | Další
DomDocument->dump_file | Domů | DomDocument->get_element_by_id


DomDocument->get_element_by_id

(No version information available, might be only in CVS)

DomDocument->get_element_by_id — Searches for an element with a certain id

Popis

domelement DomDocument->get_element_by_id ( string $id )

This function is similar to domdocument_get_elements_by_tagname() but searches for an element with a given id. According to the DOM standard this requires a DTD which defines the attribute ID to be of type ID, though the current implementation simply does an xpath search for "//*[@ID = '%s']". This does not comply to the DOM standard which requires to return null if it is not known which attribute is of type id. This behaviour is likely to be fixed, so do not rely on the current behaviour.

See also domdocument_get_elements_by_tagname()

Předcházející | Nahoru | Další
DomDocument->dump_mem | Domů | DomDocument->get_elements_by_tagname


DomDocument->get_elements_by_tagname

(No version information available, might be only in CVS)

DomDocument->get_elements_by_tagname — Returns array with nodes with given tagname in document or empty array, if not found

Popis

array DomDocument->get_elements_by_tagname ( string $name )

See also domdocument_add_root()

Předcházející | Nahoru | Další
DomDocument->get_element_by_id | Domů | DomDocument->html_dump_mem


DomDocument->html_dump_mem

(No version information available, might be only in CVS)

DomDocument->html_dump_mem — Dumps the internal XML tree back into a string as HTML

Popis

string DomDocument->html_dump_mem ( void )

Creates an HTML document from the dom representation. This function usually is called after building a new dom document from scratch as in the example below.

Příklad 446. Creating a simple HTML document header

<?php

// Creates the document
$doc = domxml_new_doc("1.0");

$root = $doc->create_element("html");
$root = $doc->append_child($root);

$head = $doc->create_element("head");
$head = $root->append_child($head);

$title = $doc->create_element("title");
$title = $head->append_child($title);

$text = $doc->create_text_node("This is the title");
$text = $title->append_child($text);

echo $doc->html_dump_mem();
?>

Výše uvedený příklad vypíše:

<html><head><title>This is the title</title></head></html>

See also domdocument_dump_file(), and domdocument_html_dump_mem().

Předcházející | Nahoru | Další
DomDocument->get_elements_by_tagname | Domů | DomDocument->xinclude


DomDocument->xinclude

(No version information available, might be only in CVS)

DomDocument->xinclude — Substitutes XIncludes in a DomDocument Object

Popis

int DomDocument->xinclude ( void )

This function substitutes » XIncludes in a DomDocument object.

Příklad 447. Substituting Xincludes

<?php

// include.xml contains :
// <child>test</child>

$xml = '<?xml version="1.0"?>
<root xmlns:xi="http://www.w3.org/2001/XInclude">
  <xi:include href="include.xml">
    <xi:fallback>
      <error>xinclude: include.xml not found</error>
    </xi:fallback>
  </xi:include>
</root>';

$domxml = domxml_open_mem($xml);
$domxml->xinclude();

echo $domxml->dump_mem();

?>

Výše uvedený příklad vypíše:

<?xml version="1.0" ?>
<root xmlns:xi="http://www.w3.org/2001/XInclude">
<child>test</child>
</root>

If include.xml doesn't exist, you'll see:

<?xml version="1.0" ?>
<root xmlns:xi="http://www.w3.org/2001/XInclude">
<error>xinclude:dom.xml not found</error>
</root>

Předcházející | Nahoru | Další
DomDocument->html_dump_mem | Domů | DomDocumentType->entities()


DomDocumentType->entities()

(No version information available, might be only in CVS)

DomDocumentType->entities() — Returns list of entities

Popis

class DomDocumentType {
array entities ( void )
}

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Migrating to PHP 5

Use the entities property of the DOMDocumentType object.

Předcházející | Nahoru | Další
DomDocument->xinclude | Domů | DomDocumentType->internal_subset()


DomDocumentType->internal_subset()

(No version information available, might be only in CVS)

DomDocumentType->internal_subset() — Returns internal subset

Popis

class DomDocumentType {
bool internal_subset ( void )
}

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Migrating to PHP 5

Use the internalSubset property of the DOMDocumentType object.

Předcházející | Nahoru | Další
DomDocumentType->entities() | Domů | DomDocumentType->name()


DomDocumentType->name()

(No version information available, might be only in CVS)

DomDocumentType->name() — Returns name of document type

Popis

class DomDocumentType {
string name ( void )
}

This function returns the name of the document type.

Návratové hodnoty

Returns the name of the DomDocumentType, as a string.

Příklady

Příklad 448. Getting the document type's name

<?php

include("example.inc");

if (!$dom = domxml_open_mem($xmlstr)) {
    echo "Error while parsing the document\n";
    exit;
}

$doctype = $dom->doctype();
echo $doctype->name(); // chapter

?>

Migrating to PHP 5

Use the name property of the DOMDocumentType object.

Předcházející | Nahoru | Další
DomDocumentType->internal_subset() | Domů | DomDocumentType->notations()


DomDocumentType->notations()

(No version information available, might be only in CVS)

DomDocumentType->notations() — Returns list of notations

Popis

class DomDocumentType {
array notations ( void )
}

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Migrating to PHP 5

Use the notations property of the DOMDocumentType object.

Předcházející | Nahoru | Další
DomDocumentType->name() | Domů | DomDocumentType->public_id()


DomDocumentType->public_id()

(No version information available, might be only in CVS)

DomDocumentType->public_id() — Returns public id of document type

Popis

class DomDocumentType {
string public_id ( void )
}

This function returns the public id of the document type.

Návratové hodnoty

Returns the public id of the DomDocumentType, as a string.

Příklady

The following example echos nothing.

Příklad 449. Retrieving the public id

<?php
include("example.inc");

if (!$dom = domxml_open_mem($xmlstr)) {
  echo "Error while parsing the document\n";
  exit;
}

$doctype = $dom->doctype();
echo $doctype->public_id();
?>

Migrating to PHP 5

Use the publicId property of the DOMDocumentType object.

Předcházející | Nahoru | Další
DomDocumentType->notations() | Domů | DomDocumentType->system_id()


DomDocumentType->system_id()

(No version information available, might be only in CVS)

DomDocumentType->system_id() — Returns the system id of document type

Popis

class DomDocumentType {
string system_id ( void )
}

Returns the system id of the document type.

Návratové hodnoty

Returns the system id of the DomDocumentType, as a string.

Příklady

Příklad 450. Retrieving the system id

<?php
include("example.inc");

if (!$dom = domxml_open_mem($xmlstr)) {
  echo "Error while parsing the document\n";
  exit;
}

$doctype = $dom->doctype();
echo $doctype->system_id();
?>

Výše uvedený příklad vypíše:

/share/sgml/Norman_Walsh/db3xml10/db3xml10.dtd

Migrating to PHP 5

Use the systemId property of the DOMDocumentType object.

Předcházející | Nahoru | Další
DomDocumentType->public_id() | Domů | DomElement->get_attribute_node()


DomElement->get_attribute_node()

(No version information available, might be only in CVS)

DomElement->get_attribute_node() — Returns the node of the given attribute

Popis

class DomElement {
DomAttribute get_attribute_node ( string $name )
}

Returns the node of the given attribute in the current element.

Seznam parametrů

name

The name of the seeked attribute. This parameter is case sensitive.

Návratové hodnoty

Returns the node of the attribute as a DomAttribute or FALSE if no attribute with the given name is found.

Příklady

Příklad 451. Getting an attribute node

<?php

include("example.inc");

if (!$dom = domxml_open_mem($xmlstr)) {
    echo "Error while parsing the document\n";
    exit;
}

$root = $dom->document_element();
if ($attribute = $root->get_attribute_node('language')) {
    echo 'Language is: ' . $attribute->value() . "\n";
}

?>

Migrating to PHP 5

Use DOMElement->getAttributeNode().

Viz také

DomElement->get_attribute()
DomElement->set_attribute()

Předcházející | Nahoru | Další
DomDocumentType->system_id() | Domů | DomElement->get_attribute()


DomElement->get_attribute()

(No version information available, might be only in CVS)

DomElement->get_attribute() — Returns the value of the given attribute

Popis

class DomElement {
string get_attribute ( string $name )
}

Returns the value of the given attribute in the current element.

Since PHP 4.3, if no attribute with given name is found, an empty string is returned.

Seznam parametrů

name

The name of the seeked attribute. This parameter is case sensitive.

Návratové hodnoty

Returns the name of the attribute as a string or an empty string if no attribute with the given name is found.

Příklady

Příklad 452. Getting the value of an attribute

<?php

include("example.inc");

if (!$dom = domxml_open_mem($xmlstr)) {
    echo "Error while parsing the document\n";
    exit;
}

// get chapter
$root = $dom->document_element();
echo $root->get_attribute('language'); // en

?>

Migrating to PHP 5

Use DOMElement->getAttribute().

Viz také

DomElement->get_attribute_node()
DomElement->set_attribute()

Předcházející | Nahoru | Další
DomElement->get_attribute_node() | Domů | DomElement->get_elements_by_tagname()


DomElement->get_elements_by_tagname()

(No version information available, might be only in CVS)

DomElement->get_elements_by_tagname() — Gets elements by tagname

Popis

class DomElement {
array get_elements_by_tagname ( string $name )
}

Gets all the sub elements with the specific name within the current element.

Seznam parametrů

name

The name of the seeked element.

Návratové hodnoty

Returns an array of DomElement objects.

Příklady

Příklad 453. Getting a content

<?php
if (!$dom = domxml_open_mem($xmlstr)) {
  echo "Error while parsing the document\n";
  exit;
}

$root = $dom->document_element();

$node_array = $root->get_elements_by_tagname('element');

foreach ($node_array as $node) {
    echo ' - ' . $node->get_content() . "\n";
}

?>

Migrating to PHP 5

Use DOMElement->getElementsByTagName().

Předcházející | Nahoru | Další
DomElement->get_attribute() | Domů | DomElement->has_attribute()


DomElement->has_attribute()

(No version information available, might be only in CVS)

DomElement->has_attribute() — Checks to see if an attribute exists in the current node

Popis

class DomElement {
bool has_attribute ( string $name )
}

This functions checks to see if an attribute named name exists in the current node.

Seznam parametrů

name

The name of the tested attribute.

Návratové hodnoty

Returns TRUE if the asked attribute exists, FALSE otherwise.

Příklady

Příklad 454. Testing the existence of an attribute

<?php

include("example.inc");

if (!$dom = domxml_open_mem($xmlstr)) {
    echo "Error while parsing the document\n";
    exit;
}

$root = $dom->document_element();

$buffer = '<html';
if ($root->has_attribute('language')) {
    $buffer .= 'lang="' . $root->get_attribute('language') . '"';
}
$buffer .= '>';

?>

Migrating to PHP 5

Use DOMElement->hasAttribute().

Předcházející | Nahoru | Další
DomElement->get_elements_by_tagname() | Domů | DomElement->remove_attribute()


DomElement->remove_attribute()

(No version information available, might be only in CVS)

DomElement->remove_attribute() — Removes attribute

Popis

class DomElement {
bool remove_attribute ( string $name )
}

Removes an attribute from the current DomElement node.

Seznam parametrů

name

The name of the attribute to remove.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Migrating to PHP 5

Use DOMElement->removeAttribute().

Předcházející | Nahoru | Další
DomElement->has_attribute() | Domů | DomElement->set_attribute_node()


DomElement->set_attribute()

(No version information available, might be only in CVS)

DomElement->set_attribute() — Sets the value of an attribute

Popis

class DomElement {
DomAttribute set_attribute ( string $name, string $value )
}

Sets an attribute with name name to the given value.

Seznam parametrů

name

The name of the attribute. If this attribute doesn't exist, it will be created.

value

The value of the attribute.

Návratové hodnoty

Returns the old DomAttribute node, or the new one if you are creating the attribute for the first time.

Příklady

Příklad 455. Setting an attribute

<?php
$doc = domxml_new_doc("1.0");
$node = $doc->create_element("para");
$newnode = $doc->append_child($node);
$newnode->set_attribute("align", "left");
?>

Migrating to PHP 5

Use DOMElement->setAttribute().

Viz také

DomElement->get_attribute_node()
DomElement->get_attribute()

Předcházející | Nahoru | Další
DomElement->set_attribute_node() | Domů | DomElement->tagname()


DomElement->tagname()

(No version information available, might be only in CVS)

DomElement->tagname() — Returns the name of the current element

Popis

class DomElement {
string tagname ( void )
}

Returns the name of the current node. Calling this function is the same as accessing the tagname property, or calling DomNode->node_name on the current node.

Návratové hodnoty

Returns the name of the current DomElement node.

Příklady

Příklad 456. Getting the node name

<?php

include("example.inc");

if (!$dom = domxml_open_mem($xmlstr)) {
    echo "Error while parsing the document\n";
    exit;
}

$root = $dom->document_element();
echo $root->tagname();   // chapter
echo $root->tagname;     // chapter
echo $root->node_name(); // chapter

?>

Migrating to PHP 5

Use the tagName property of the DOMElement object.

Předcházející | Nahoru | Další
DomElement->set_attribute() | Domů | DomNode->add_namespace


DomNode->add_namespace

(No version information available, might be only in CVS)

DomNode->add_namespace — Adds a namespace declaration to a node

Popis

class DOMNode {
bool add_namespace ( string $uri, string $prefix )
}

This method adds a namespace declaration to a node.

Poznámka: This method is not part of the DOM specification.

Seznam parametrů

uri

The namespace URI of the node.

prefix

The namespace prefix of the node.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Migrating to PHP 5

You can set the namespace URI and prefix of a DOMElement or a DOMAttr at creation time by using DOMDocument->createElementNS() or DOMDocument->createAttributeNS().

Poznámka: Remember the an attribute does not inherit its namespace from the element it is attached to.

Viz také

DomDocument->create_element_ns
DomNode->set_namespace

Předcházející | Nahoru | Další
DomElement->tagname() | Domů | DomNode->append_child


DomNode->append_child

(No version information available, might be only in CVS)

DomNode->append_child — Adds a new child at the end of the children

Popis

class DOMNode {
DOMNode append_child ( DOMNode $newnode )
}

This functions appends a child to an existing list of children or creates a new list of children.

Seznam parametrů

newnode

The node being appended. It can be created with e.g. DomDocument->create_element, DomDocument->create_text_node etc. or simply by using any other node.

Poznámka: You can not append a DOMAttribute using this method. Use DomElement->set_attribute() instead.

Návratové hodnoty

Returns the appended node on success or FALSE on failure.

ChangeLog (záznam změn)

Verze | Popis
4.3.0 | You are not allowed anymore to insert a node from another document.
4.3.0 | Prior to PHP 4.3.0, the new child is duplicated before being appended. Therefore the new child is a completely new copy which can be modified without changing the node which was passed to this function. If the node passed has children itself, they will be duplicated as well, which makes it quite easy to duplicate large parts of an XML document. The return value is the appended child. If you plan to do further modifications on the appended child you must use the returned node.
4.3.0 and 4.3.1 | The new child newnode is first unlinked from its existing context, if it's already a child of DomNode. Therefore the newnode is moved and not copies anymore. This is the behaviour according to the W3C specifications. If you need the old behaviour, use DomNode->clone_node before appending.
4.3.2 | The new child newnode is first unlinked from its existing context, if it's already in the tree. Same rules apply.

Příklady

The following example adds a new element node to a fresh document and sets the attribute align to left.

Příklad 457. Adding a child

<?php
$doc = domxml_new_doc("1.0");
$node = $doc->create_element("para");
$newnode = $doc->append_child($node);
$newnode->set_attribute("align", "left");
?>

The above example could also be written as the following:

Příklad 458. Adding a child

<?php
$doc = domxml_new_doc("1.0");
$node = $doc->create_element("para");
$node->set_attribute("align", "left");
$newnode = $doc->append_child($node);
?>

A more complex example is the one below. It first searches for a certain element, duplicates it including its children and adds it as a sibling. Finally a new attribute is added to one of the children of the new sibling and the whole document is dumped.

Příklad 459. Adding a child

<?php
include("example.inc");

if (!$dom = domxml_open_mem($xmlstr)) {
  echo "Error while parsing the document\n";
  exit;
}

$elements = $dom->get_elements_by_tagname("informaltable");
print_r($elements);
$element = $elements[0];

$parent = $element->parent_node();
$newnode = $parent->append_child($element);
$children = $newnode->children();
$attr = $children[1]->set_attribute("align", "left");

$xmlfile = $dom->dump_mem();
echo htmlentities($xmlfile);
?>

The above example could also be done with DomNode->insert_before instead of DomNode->append_child.

Migrating to PHP 5

You should use DOMNode->appendChild().

Viz také

DomNode->insert_before
DomNode->clone_node

Předcházející | Nahoru | Další
DomNode->add_namespace | Domů | DomNode->append_sibling


DomNode->append_sibling

(No version information available, might be only in CVS)

DomNode->append_sibling — Adds new sibling to a node

Popis

domelement DomNode->append_sibling ( domelement $newnode )

This functions appends a sibling to an existing node. The child can be created with e.g. domdocument_create_element(), domdocument_create_text() etc. or simply by using any other node.

Before a new sibling is added it is first duplicated. Therefore the new child is a completely new copy which can be modified without changing the node which was passed to this function. If the node passed has children itself, they will be duplicated as well, which makes it quite easy to duplicate large parts of an XML document. The return value is the added sibling. If you plan to do further modifications on the added sibling you must use the returned node.

This function has been added to provide the behaviour of domnode_append_child() as it works till PHP 4.2.

See also domnode_append_before().

Předcházející | Nahoru | Další
DomNode->append_child | Domů | DomNode->attributes


DomNode->attributes

(No version information available, might be only in CVS)

DomNode->attributes — Returns list of attributes

Popis

array DomNode->attributes ( void )

This function only returns an array of attributes if the node is of type XML_ELEMENT_NODE.

(PHP >= 4.3 only) If no attributes are found, NULL is returned.

Předcházející | Nahoru | Další
DomNode->append_sibling | Domů | DomNode->child_nodes


DomNode->child_nodes

(No version information available, might be only in CVS)

DomNode->child_nodes — Returns children of node

Popis

array DomNode->child_nodes ( void )

Returns all children of the node.

See also domnode_next_sibling(), and domnode_previous_sibling().

Předcházející | Nahoru | Další
DomNode->attributes | Domů | DomNode->clone_node


DomNode->clone_node

(No version information available, might be only in CVS)

DomNode->clone_node — Clones a node

Popis

domelement DomNode->clone_node ( void )

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
DomNode->child_nodes | Domů | DomNode->dump_node


DomNode->dump_node

(No version information available, might be only in CVS)

DomNode->dump_node — Dumps a single node

Popis

string DomNode->dump_node ( void )

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

See also domdocument_dump_mem().

Předcházející | Nahoru | Další
DomNode->clone_node | Domů | DomNode->first_child


DomNode->first_child

(No version information available, might be only in CVS)

DomNode->first_child — Returns first child of node

Popis

domelement DomNode->first_child ( void )

Returns the first child of the node.

(PHP >= 4.3 only) If no first child is found, NULL is returned.

See also domnode_last_child(), and
domnode_next_sibling(),
domnode_previous_sibling().

Předcházející | Nahoru | Další
DomNode->dump_node | Domů | DomNode->get_content


DomNode->get_content

(No version information available, might be only in CVS)

DomNode->get_content — Gets content of node

Popis

string DomNode->get_content ( void )

This function returns the content of the actual node.

Příklad 460. Getting a content

<?php
if (!$dom = domxml_open_mem($xmlstr)) {
  echo "Error while parsing the document\n";
  exit;
}

$root = $dom->document_element();

$node_array = $root->get_elements_by_tagname("element");

for ($i = 0; $i<count($node_array); $i++) {
    $node = $node_array[$i];
    echo "The element[$i] is: " . $node->get_content();
}

?>

Předcházející | Nahoru | Další
DomNode->first_child | Domů | DomNode->has_attributes


DomNode->has_attributes

(No version information available, might be only in CVS)

DomNode->has_attributes — Checks if node has attributes

Popis

bool DomNode->has_attributes ( void )

This function checks if the node has attributes.

See also domnode_has_child_nodes().

Předcházející | Nahoru | Další
DomNode->get_content | Domů | DomNode->has_child_nodes


DomNode->has_child_nodes

(No version information available, might be only in CVS)

DomNode->has_child_nodes — Checks if node has children

Popis

bool DomNode->has_child_nodes ( void )

This function checks if the node has children.

See also domnode_child_nodes().

Předcházející | Nahoru | Další
DomNode->has_attributes | Domů | DomNode->insert_before


DomNode->insert_before

(No version information available, might be only in CVS)

DomNode->insert_before — Inserts new node as child

Popis

domelement DomNode->insert_before ( domelement $newnode, domelement $refnode )

This function inserts the new node newnode right before the node refnode. The return value is the inserted node. If you plan to do further modifications on the appended child you must use the returned node.

(PHP >= 4.3 only) If newnode already is part of a document, it will be first unlinked from its existing context. If refnode is NULL, then newnode will be inserted at the end of the list of children.

domnode_insert_before() is very similar to domnode_append_child() as the following example shows which does the same as the example at domnode_append_child().

Příklad 461. Adding a child

<?php
include("example.inc");

if (!$dom = domxml_open_mem($xmlstr)) {
  echo "Error while parsing the document\n";
  exit;
}

$elements = $dom->get_elements_by_tagname("informaltable");
print_r($elements);
$element = $elements[0];

$newnode = $element->insert_before($element, $element);
$children = $newnode->children();
$attr = $children[1]->set_attribute("align", "left");

echo "<pre>";
$xmlfile = $dom->dump_mem();
echo htmlentities($xmlfile);
echo "</pre>";
?>

See also domnode_append_child().

Předcházející | Nahoru | Další
DomNode->has_child_nodes | Domů | DomNode->is_blank_node


DomNode->is_blank_node

(No version information available, might be only in CVS)

DomNode->is_blank_node — Checks if node is blank

Popis

bool DomNode->is_blank_node ( void )

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
DomNode->insert_before | Domů | DomNode->last_child


DomNode->last_child

(No version information available, might be only in CVS)

DomNode->last_child — Returns last child of node

Popis

domelement DomNode->last_child ( void )

Returns the last child of the node.

(PHP >= 4.3 only) If no last child is found, NULL is returned.

See also domnode_first_child(), and
domnode_next_sibling(),
domnode_previous_sibling().

Předcházející | Nahoru | Další
DomNode->is_blank_node | Domů | DomNode->next_sibling


DomNode->next_sibling

(No version information available, might be only in CVS)

DomNode->next_sibling — Returns the next sibling of node

Popis

domelement DomNode->next_sibling ( void )

This function returns the next sibling of the current node. If there is no next sibling it returns FALSE (< 4.3) or null (>= 4.3). You can use this function to iterate over all children of a node as shown in the example.

Příklad 462. Iterate over children

<?php
include("example.inc");

if (!$dom = domxml_open_mem($xmlstr)) {
  echo "Error while parsing the document\n";
  exit;
}

$elements = $dom->get_elements_by_tagname("tbody");
$element = $elements[0];
$child = $element->first_child();

while ($child) {
   print_r($child);
   $child = $child->next_sibling();
}
?>

See also domnode_previous_sibling().

Předcházející | Nahoru | Další
DomNode->last_child | Domů | DomNode->node_name


DomNode->node_name

(No version information available, might be only in CVS)

DomNode->node_name — Returns name of node

Popis

string DomNode->node_name ( void )

Returns name of the node. The name has different meanings for the different types of nodes as illustrated in the following table.

Tabulka 71. Meaning of value

Type | Meaning
DomAttribute | value of attribute
DomAttribute |
DomCDataSection | #cdata-section
DomComment | #comment
DomDocument | #document
DomDocumentType | document type name
DomElement | tag name
DomEntity | name of entity
DomEntityReference | name of entity reference
DomNotation | notation name
DomProcessingInstruction | target
DomText | #text

Předcházející | Nahoru | Další
DomNode->next_sibling | Domů | DomNode->node_type


DomNode->node_type

(No version information available, might be only in CVS)

DomNode->node_type — Returns type of node

Popis

int DomNode->node_type ( void )

Returns the type of the node. All possible types are listed in the table in the introduction.

Příklad 463.

<?php

include 'example.inc';

$dom = domxml_open_mem($xmlstr);

$chapter = $dom->document_element();

// Let's see the elements contained in chapter
foreach($chapter->child_nodes() as $node) {
  if ($node->node_type() == XML_ELEMENT_NODE) {
    echo $node->node_name() . "\n";
  }
}

?>

Výše uvedený příklad vypíše:

title
para

Předcházející | Nahoru | Další
DomNode->node_name | Domů | DomNode->node_value


DomNode->node_value

(No version information available, might be only in CVS)

DomNode->node_value — Returns value of a node

Popis

string DomNode->node_value ( void )

Returns value of the node. The value has different meanings for the different types of nodes as illustrated in the following table.

Tabulka 72. Meaning of value

Type | Meaning
DomAttribute | value of attribute
DomAttribute |
DomCDataSection | content
DomComment | content of comment
DomDocument | null
DomDocumentType | null
DomElement | null
DomEntity | null
DomEntityReference | null
DomNotation | null
DomProcessingInstruction | entire content without target
DomText | content of text

Předcházející | Nahoru | Další
DomNode->node_type | Domů | DomNode->owner_document


DomNode->owner_document

(No version information available, might be only in CVS)

DomNode->owner_document — Returns the document this node belongs to

Popis

domdocument DomNode->owner_document ( void )

This function returns the document the current node belongs to.

The following example will create two identical lists of children.

Příklad 464. Finding the document of a node

<?php
$doc = domxml_new_doc("1.0");
$node = $doc->create_element("para");
$node = $doc->append_child($node);
$children = $doc->children();
print_r($children);

$doc2 = $node->owner_document();
$children = $doc2->children();
print_r($children);
?>

See also domnode_insert_before().

Předcházející | Nahoru | Další
DomNode->node_value | Domů | DomNode->parent_node


DomNode->parent_node

(No version information available, might be only in CVS)

DomNode->parent_node — Returns the parent of the node

Popis

domnode DomNode->parent_node ( void )

This function returns the parent node.

(PHP >= 4.3 only) If no parent is found, NULL is returned.

The following example will show two identical lists of children.

Příklad 465. Finding the document of a node

<?php
$doc = domxml_new_doc("1.0");
$node = $doc->create_element("para");
$node = $doc->append_child($node);
$children = $doc->children();
print_r($children);

$doc2 = $node->parent_node();
$children = $doc2->children();
print_r($children);
?>

Předcházející | Nahoru | Další
DomNode->owner_document | Domů | DomNode->prefix


DomNode->prefix

(No version information available, might be only in CVS)

DomNode->prefix — Returns name space prefix of node

Popis

string DomNode->prefix ( void )

Returns the name space prefix of the node.

Předcházející | Nahoru | Další
DomNode->parent_node | Domů | DomNode->previous_sibling


DomNode->previous_sibling

(No version information available, might be only in CVS)

DomNode->previous_sibling — Returns the previous sibling of node

Popis

domelement DomNode->previous_sibling ( void )

This function returns the previous sibling of the current node. If there is no previous sibling it returns FALSE (< 4.3) or NULL (>= 4.3). You can use this function to iterate over all children of a node as shown in the example.

See also domnode_next_sibling().

Předcházející | Nahoru | Další
DomNode->prefix | Domů | DomNode->remove_child


DomNode->remove_child

(No version information available, might be only in CVS)

DomNode->remove_child — Removes child from list of children

Popis

domtext DomNode->remove_child ( domtext $oldchild )

This functions removes a child from a list of children. If child cannot be removed or is not a child the function will return FALSE. If the child could be removed the functions returns the old child.

Příklad 466. Removing a child

<?php
include("example.inc");

if (!$dom = domxml_open_mem($xmlstr)) {
  echo "Error while parsing the document\n";
  exit;
}

$elements = $dom->get_elements_by_tagname("tbody");
$element = $elements[0];
$children = $element->child_nodes();
$child = $element->remove_child($children[0]);

echo "<PRE>";
$xmlfile = $dom->dump_mem(true);
echo htmlentities($xmlfile);
echo "</PRE>";
?>

See also domnode_append_child().

Předcházející | Nahoru | Další
DomNode->previous_sibling | Domů | DomNode->replace_child


DomNode->replace_child

(No version information available, might be only in CVS)

DomNode->replace_child — Replaces a child

Popis

domelement DomNode->replace_child ( domelement $newnode, domelement $oldnode )

(PHP 4.2) This function replaces the child oldnode with the passed new node. If the new node is already a child it will not be added a second time. If the old node cannot be found the function returns FALSE. If the replacement succeeds the old node is returned.

(PHP 4.3) This function replaces the child oldnode with the passed newnode, even if the new node already is a child of the DomNode. If newnode was already inserted in the document it is first unlinked from its existing context. If the old node cannot be found the function returns FALSE. If the replacement succeeds the old node is returned. (This behaviour is according to the W3C specs).

See also domnode_append_child()

Předcházející | Nahoru | Další
DomNode->remove_child | Domů | DomNode->replace_node


DomNode->replace_node

(No version information available, might be only in CVS)

DomNode->replace_node — Replaces node

Popis

domelement DomNode->replace_node ( domelement $newnode )

(PHP 4.2) This function replaces an existing node with the passed new node. Before the replacement newnode is copied if it has a parent to make sure a node which is already in the document will not be inserted a second time. This behaviour enforces doing all modifications on the node before the replacement or to refetch the inserted node afterwards with functions like domnode_first_child(), domnode_child_nodes() etc..

(PHP 4.3) This function replaces an existing node with the passed new node. It is not copied anymore. If newnode was already inserted in the document it is first unlinked from its existing context. If the replacement succeeds the old node is returned.

See also domnode_append_child()

Předcházející | Nahoru | Další
DomNode->replace_child | Domů | DomNode->set_content


DomNode->set_content

(No version information available, might be only in CVS)

DomNode->set_content — Sets content of node

Popis

bool DomNode->set_content ( string $content )

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
DomNode->replace_node | Domů | DomNode->set_name


DomNode->set_name

(No version information available, might be only in CVS)

DomNode->set_name — Sets name of node

Popis

bool DomNode->set_name ( void )

Sets name of node.

See also domnode_node_name().

Předcházející | Nahoru | Další
DomNode->set_content | Domů | DomNode->set_namespace


DomNode->set_namespace

(No version information available, might be only in CVS)

DomNode->set_namespace — Sets namespace of a node

Popis

void DomNode->set_namespace ( string $uri [, string $prefix] )

Sets the namespace of a node to uri. If there is already a namespace declaration with the same uri in one of the parent nodes of the node, the prefix of this is taken, otherwise it will take the one provided in the optional parameter prefix or generate a random one.

See also domdocument_create_element_ns(), and domnode_add_namespace()

Předcházející | Nahoru | Další
DomNode->set_name | Domů | DomNode->unlink_node


DomNode->unlink_node

(No version information available, might be only in CVS)

DomNode->unlink_node — Deletes node

Popis

void DomNode->unlink_node ( void )

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
DomNode->set_namespace | Domů | DomProcessingInstruction->data


DomProcessingInstruction->data

(No version information available, might be only in CVS)

DomProcessingInstruction->data — Returns the data of ProcessingInstruction node

Popis

class DomProcessingInstruction {
string data ( void )
}

This method gets the data of the ProcessingInstruction node.

Návratové hodnoty

Returns the data of the Processing Instruction.

Migrating to PHP 5

Use the data property of DOMProcessingInstruction.

Předcházející | Nahoru | Další
DomNode->unlink_node | Domů | DomProcessingInstruction->target


DomProcessingInstruction->target

(No version information available, might be only in CVS)

DomProcessingInstruction->target — Returns the target of a ProcessingInstruction node

Popis

class DomProcessingInstruction {
string target ( void )
}

This method gets the target of the ProcessingInstruction node.

Návratové hodnoty

Returns the target of the Processing Instruction.

Migrating to PHP 5

Use the target property of DOMProcessingInstruction.

Předcházející | Nahoru | Další
DomProcessingInstruction->data | Domů | DomXsltStylesheet->process()


DomXsltStylesheet->process()

(No version information available, might be only in CVS)

DomXsltStylesheet->process() — Applies the XSLT-Transformation on a DomDocument Object

Popis

class DomXsltStylesheet {
DomDocument process ( DomDocument $xml_doc [, array $xslt_params [, bool $is_xpath_param [, string $profile_filename]]] )
}

Applies an XSLT Transformation on the given DomDocument object.

Seznam parametrů

xml_doc

The XML document being transformed, as a DomDocument object.

xslt_params

An associative array that takes pairs of parameter names and values.

is_xpath_param

If set to FALSE the values of the xslt_params will be quoted. This is the default behavior. It allows you to pass the values as PHP strings.

Poznámka: If your strings contains both single and double quotes, you must take care of quoting all the values by yourself and set this parameter to TRUE.

profile_filename

Set this to the path of a filename, if you want profiling information.

Návratové hodnoty

Returns the result of the processing, as a DomDocument object.

Migrating to PHP 5

Use XSLTProcessor::setParameter and XSLTProcessor::transformToDoc.

ChangeLog (záznam změn)

Verze | Popis
4.3.0 | The profile_filename parameter was added.

Viz také

domxml_xslt_stylesheet()
domxml_xslt_stylesheet_file()
domxml_xslt_stylesheet_doc()

Předcházející | Nahoru | Další
DomProcessingInstruction->target | Domů | DomXsltStylesheet->result_dump_file()


DomXsltStylesheet->result_dump_file()

(No version information available, might be only in CVS)

DomXsltStylesheet->result_dump_file() — Dumps the result from a XSLT-Transformation into a file

Popis

class DomXsltStylesheet {
string result_dump_file ( DomDocument $xmldoc, string $filename )
}

Since DomXsltStylesheet->process() always returns a well-formed XML DomDocument, no matter what output method was declared in <xsl:output> and similar attributes/elements, it's of not much use, if you want to output HTML 4 or text data.

This function on the contrary honors <xsl:output method="html|text"> and other output control directives. See the example for instruction on how to use it.

Příklady

Příklad 467. Saving the result of a XSLT transformation in a file

<?php
$filename = "stylesheet.xsl";
$xmldoc = domxml_open_file("data.xml");
$xsldoc = domxml_xslt_stylesheet_file($filename);
$result =  $xsldoc->process($xmldoc);
echo $xsldoc->result_dump_file($result, "filename");
?>

Viz také

DomXsltStylesheet->result_dump_mem()
DomXsltStylesheet->process()

Předcházející | Nahoru | Další
DomXsltStylesheet->process() | Domů | DomXsltStylesheet->result_dump_mem()


DomXsltStylesheet->result_dump_mem()

(No version information available, might be only in CVS)

DomXsltStylesheet->result_dump_mem() — Dumps the result from a XSLT-Transformation back into a string

Popis

class DomXsltStylesheet {
string result_dump_mem ( DomDocument $xmldoc )
}

Since DomXsltStylesheet->process() always returns a well-formed XML DomDocument, no matter what output method was declared in <xsl:output> and similar attributes/elements, it's of not much use, if you want to output HTML 4 or text data.

This function on the contrary honors <xsl:output method="html|text"> and other output control directives. See the example for instruction on how to use it.

Příklady

Příklad 468. Outputting the result of a XSLT transformation

<?php
$filename = "stylesheet.xsl";
$xmldoc = domxml_open_file("data.xml");
$xsldoc = domxml_xslt_stylesheet_file($filename);
$result =  $xsldoc->process($xmldoc);
echo $xsldoc->result_dump_mem($result);
?>

Viz také

DomXsltStylesheet->result_dump_file()
DomXsltStylesheet->process()

Předcházející | Nahoru | Další
DomXsltStylesheet->result_dump_file() | Domů | domxml_new_doc


domxml_new_doc

(PHP 4 >= 4.2.0)

domxml_new_doc — Creates new empty XML document

Popis

DomDocument domxml_new_doc ( string $version )

Creates a new Dom document from scratch and returns it.

Seznam parametrů

version

The XML version number of the document.

Návratové hodnoty

Returns a new DomDocument instance.

Předcházející | Nahoru | Další
DomXsltStylesheet->result_dump_mem() | Domů | domxml_open_file


domxml_open_file

(PHP 4 >= 4.2.0)

domxml_open_file — Vytvořit DOM objekt z XML souboru

Popis

DomDocument domxml_open_file ( string $filename [, int $mode [, array &$error]] )

Parsuje XML dokument v souboru pojmenovaném filename a vrací objekt třídy "Dom document", který má vlastnosti "doc" (resource), "version" (string).

Předcházející | Nahoru | Další
domxml_new_doc | Domů | domxml_open_mem


domxml_open_mem

(PHP 4 >= 4.2.0)

domxml_open_mem — Vytvořit DOM objekt z XML dokumentu

Popis

DomDocument domxml_open_mem ( string $str [, int $mode [, array &$error]] )

Tato funkce parsuje XML dokument v str a vrací objekt třídy "Dom document", který má valstnosti "doc" (resource), "version" (string) and "type" (long).

Předcházející | Nahoru | Další
domxml_open_file | Domů | domxml_version


domxml_version

(PHP 4 >= 4.0.7)

domxml_version — Gets the XML library version

Popis

string domxml_version ( void )

Gets the version of the XML library currently used.

Návratové hodnoty

The version of the XML library, as a string.

Příklady

Příklad 469. domxml_version() Example

<?php

echo domxml_version();

?>

Výše uvedený příklad vypíše něco jako:

20607

Předcházející | Nahoru | Další
domxml_open_mem | Domů | domxml_xmltree


domxml_xmltree

(PHP 4 >= 4.2.0)

domxml_xmltree — Vytvořit strom PHP objektů z XML dokumentu

Popis

DomDocument domxml_xmltree ( string $str )

Parsuje XML dokument v str a vrací strom PHP objektů.

Předcházející | Nahoru | Další
domxml_version | Domů | domxml_xslt_stylesheet_doc


domxml_xslt_stylesheet_doc

(PHP 4 >= 4.2.0)

domxml_xslt_stylesheet_doc — Creates a DomXsltStylesheet Object from a DomDocument Object

Popis

DomXsltStylesheet domxml_xslt_stylesheet_doc ( DomDocument $xsl_doc )

Creates a DomXsltStylesheet object from the given XSL document.

Seznam parametrů

xsl_doc

The XSL document, as a DomDocument object.

Návratové hodnoty

Returns a new instance of DomXsltStylesheet.

Migrating to PHP 5

Call XSLTProcessor::importStylesheet with the xsl_doc parameter.

Viz také

DomXsltStylesheet->process()
domxml_xslt_stylesheet()
domxml_xslt_stylesheet_file()

Předcházející | Nahoru | Další
domxml_xmltree | Domů | domxml_xslt_stylesheet_file


domxml_xslt_stylesheet_file

(PHP 4 >= 4.2.0)

domxml_xslt_stylesheet_file — Creates a DomXsltStylesheet Object from an XSL document in a file

Popis

DomXsltStylesheet domxml_xslt_stylesheet_file ( string $xsl_file )

Creates a DomXsltStylesheet object from the given XSL file.

Seznam parametrů

xsl_file

The path to the XSL document, as a string.

Návratové hodnoty

Returns a new instance of DomXsltStylesheet.

Migrating to PHP 5

Call XSLTProcessor::importStylesheet with DOMDocument::load($xsl_file) as parameter.

Viz také

DomXsltStylesheet->process()
domxml_xslt_stylesheet()
domxml_xslt_stylesheet_doc()

Předcházející | Nahoru | Další
domxml_xslt_stylesheet_doc | Domů | domxml_xslt_stylesheet


domxml_xslt_stylesheet

(PHP 4 >= 4.2.0)

domxml_xslt_stylesheet — Creates a DomXsltStylesheet object from an XSL document in a string

Popis

DomXsltStylesheet domxml_xslt_stylesheet ( string $xsl_buf )

Creates a DomXsltStylesheet object from the given XSL buffer.

Seznam parametrů

xsl_buf

The XSL document, as a string.

Návratové hodnoty

Returns a new instance of DomXsltStylesheet.

Migrating to PHP 5

Call XSLTProcessor::importStylesheet with DOMDocument::loadXML($xsl_buf) as parameter.

Viz také

DomXsltStylesheet->process()
domxml_xslt_stylesheet_file()
domxml_xslt_stylesheet_doc()

Předcházející | Nahoru | Další
domxml_xslt_stylesheet_file | Domů | domxml_xslt_version


xpath_eval_expression

(PHP 4 >= 4.0.4)

xpath_eval_expression — Evaluates the XPath Location Path in the given string

Popis

class XPathContext {
XPathObject xpath_eval_expression ( string $expression [, domnode $contextnode] )
} XPathObject xpath_eval_expression ( XPathContext $xpath_context, string $expression [, domnode $contextnode] )

Příklad 471. xpath_eval_expression() Example

<?php

include("example.inc");

if (!$dom = domxml_open_mem($xmlstr)) {
    echo "Error while parsing the document\n";
    exit;
}

$xpath = xpath_new_context($dom);
var_dump(xpath_eval_expression($xpath, '/chapter/@language'));

?>

Výše uvedený příklad vypíše:

object(XPathObject)(2) {
   ["type"]=>
   int(1)
   ["nodeset"]=>
   array(1) {
     [0]=>
     object(domattribute)(5) {
       ["type"]=>
       int(2)
       ["name"]=>
       string(8) "language"
       ["value"]=>
       string(2) "en"
       [0]=>
       int(7)
       [1]=>
       int(138004256)
     }
  }
}

See also xpath_eval().

Předcházející | Nahoru | Další
domxml_xslt_version | Domů | xpath_eval


xpath_eval

(PHP 4 >= 4.0.4)

xpath_eval — Evaluates the XPath Location Path in the given string

Popis

class XPathContext {
XPathObject xpath_eval ( string $xpath_expression [, domnode $contextnode] )
} XPathObject xpath_eval ( XPathContext $xpath_context, string $xpath_expression [, domnode $contextnode] )

The optional contextnode can be specified for doing relative XPath queries.

See also xpath_new_context().

Předcházející | Nahoru | Další
xpath_eval_expression | Domů | xpath_new_context


xpath_new_context

(PHP 4 >= 4.0.4)

xpath_new_context — Creates new xpath context

Popis

XPathContext xpath_new_context ( domdocument $dom_document )

See also xpath_eval().

Předcházející | Nahoru | Další
xpath_eval | Domů | xpath_register_ns_auto


xptr_eval

(PHP 4 >= 4.0.4)

xptr_eval — Evaluate the XPtr Location Path in the given string

Popis

class XPathContext {
int xptr_eval ( string $eval_str [, domnode $contextnode] )
} int xptr_eval ( XPathContext $xpath_context, string $eval_str [, domnode $contextnode] )

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
xpath_register_ns | Domů | xptr_new_context


xptr_new_context

(PHP 4 >= 4.0.4)

xptr_new_context — Create new XPath Context

Popis

XPathContext xptr_new_context ( void )

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
xptr_eval | Domů | XXXIII. enchant Functions


.NET Functions

Předcházející VI. Reference funkcí Další

I. .NET Functions

Úvod

Varování

Toto rozšíření je EXPERIMENTÁLNÍ. Chování tohoto rozšíření, názvy funkcí a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může bez ohlášení změnit. Berte to v úvahu a používejte tento modul na vlastní nebezpečí.

Obsah

dotnet_load — Loads a DOTNET module
Předcházející | Nahoru | Další
VI. Reference funkcí | Domů | dotnet_load


dotnet_load

(No version information available, might be only in CVS)

dotnet_load — Loads a DOTNET module

Popis

int dotnet_load ( string $assembly_name [, string $datatype_name [, int $codepage]] )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

ChangeLog (záznam změn)

Verze | Popis
4.1.0 | The codepage parameter was added

Předcházející | Nahoru | Další
I. .NET Functions | Domů | II. Funkce specifické pro Apache


Error Handling and Logging Functions

Předcházející VI. Reference funkcí Další

XXXIV. Error Handling and Logging Functions

Úvod

These are functions dealing with error handling and logging. They allow you to define your own error handling rules, as well as modify the way the errors can be logged. This allows you to change and enhance error reporting to suit your needs.

With the logging functions, you can send messages directly to other machines, to an email (or email to pager gateway!), to system logs, etc., so you can selectively log and monitor the most important parts of your applications and websites.

The error reporting functions allow you to customize what level and kind of error feedback is given, ranging from simple notices to customized functions returned during errors.

Požadavky

Tyto funkce jsou k dispozici jako součást standardního modulu, který je vždy dostupný.

Instalace

K používání těchto funkcí není třeba žádná instalace, jsou součástí jádra PHP.

Konfigurace běhu

Chování těchto funkcí je ovlivněno nastavením parametrů v php.ini.

Tabulka 73. Errors and Logging Configuration Options

Name | Default | Changeable | Changelog
error_reporting | NULL | PHP_INI_ALL |
display_errors | "1" | PHP_INI_ALL |
display_startup_errors | "0" | PHP_INI_ALL | Available since PHP 4.0.3.
log_errors | "0" | PHP_INI_ALL |
log_errors_max_len | "1024" | PHP_INI_ALL | Available since PHP 4.3.0.
ignore_repeated_errors | "0" | PHP_INI_ALL | Available since PHP 4.3.0.
ignore_repeated_source | "0" | PHP_INI_ALL | Available since PHP 4.3.0.
report_memleaks | "1" | PHP_INI_ALL | Available since PHP 4.3.0.
track_errors | "0" | PHP_INI_ALL |
html_errors | "1" | PHP_INI_ALL | PHP_INI_SYSTEM in PHP <= 4.2.3. Available since PHP 4.0.2.
docref_root | "" | PHP_INI_ALL | Available since PHP 4.3.0.
docref_ext | "" | PHP_INI_ALL | Available since PHP 4.3.2.
error_prepend_string | NULL | PHP_INI_ALL |
error_append_string | NULL | PHP_INI_ALL |
error_log | NULL | PHP_INI_ALL |
warn_plus_overloading | NULL |  | This option is no longer available as of PHP 4.0.0

Pro další detaily a definice konstant PHP_INI_*, viz dokumentace k ini_set().

Zde je stručný popis konfiguračních direktiv.

error_reporting integer

Set the error reporting level. The parameter is either an integer representing a bit field, or named constants. The error_reporting levels and constants are described in Predefined Constants, and in php.ini. To set at runtime, use the error_reporting() function. See also the display_errors directive.

In PHP 4 and PHP 5 the default value is E_ALL & ~E_NOTICE. This setting does not show E_NOTICE level errors. You may want to show them during development.

Poznámka: Enabling E_NOTICE during development has some benefits. For debugging purposes: NOTICE messages will warn you about possible bugs in your code. For example, use of unassigned values is warned. It is extremely useful to find typos and to save time for debugging. NOTICE messages will warn you about bad style. For example, $arr[item] is better to be written as $arr['item'] since PHP tries to treat "item" as constant. If it is not a constant, PHP assumes it is a string index for the array.

Poznámka: In PHP 5 a new error level E_STRICT is available. As E_STRICT is not included within E_ALL you have to explicitly enable this kind of error level. Enabling E_STRICT during development has some benefits. STRICT messages will help you to use the latest and greatest suggested method of coding, for example warn you about using deprecated functions.

PHP Constants outside of PHP: Using PHP Constants outside of PHP, like in httpd.conf, will have no useful meaning so in such cases the integer values are required. And since error levels will be added over time, the maximum value (for E_ALL) will likely change. So in place of E_ALL consider using a larger value to cover all bit fields from now and well into the future, a numeric value like 2147483647.

In PHP 3, the default setting is (E_ERROR | E_WARNING | E_PARSE), meaning the same thing. Note, however, that since constants are not supported in PHP 3's php3.ini, the error_reporting setting there must be numeric; hence, it is 7.

display_errors string

This determines whether errors should be printed to the screen as part of the output or if they should be hidden from the user.

Value "stderr" sends the errors to stderr instead of stdout. The value is available as of PHP 5.2.4. In earlier versions, this directive was of type boolean.

Poznámka: This is a feature to support your development and should never be used on production systems (e.g. systems connected to the internet).

Poznámka: Although display_errors may be set at runtime (with ini_set()), it won't have any affect if the script has fatal errors. This is because the desired runtime action does not get executed.

display_startup_errors boolean

Even when display_errors is on, errors that occur during PHP's startup sequence are not displayed. It's strongly recommended to keep display_startup_errors off, except for debugging.

log_errors boolean

Tells whether script error messages should be logged to the server's error log or error_log. This option is thus server-specific.

Poznámka: You're strongly advised to use error logging in place of error displaying on production web sites.

log_errors_max_len integer

Set the maximum length of log_errors in bytes. In error_log information about the source is added. The default is 1024 and 0 allows to not apply any maximum length at all. This length is applied to logged errors, displayed errors and also to $php_errormsg.

Připoužítí typu integer je hodnota měřena v bytech. Můžete také použít zkrácenou notaci, jak je popsáno tomto FAQ.

ignore_repeated_errors boolean

Do not log repeated messages. Repeated errors must occur in the same file on the same line until ignore_repeated_source is set true.

ignore_repeated_source boolean

Ignore source of message when ignoring repeated messages. When this setting is On you will not log errors with repeated messages from different files or sourcelines.

report_memleaks boolean

If this parameter is set to Off, then memory leaks will not be shown (on stdout or in the log). This has only effect in a debug compile, and if error_reporting includes E_WARNING in the allowed list

track_errors boolean

If enabled, the last error message will always be present in the variable $php_errormsg.

html_errors boolean

Turn off HTML tags in error messages. The new format for HTML errors produces clickable messages that direct the user to a page describing the error or function in causing the error. These references are affected by docref_root and docref_ext.

docref_root string

The new error format contains a reference to a page describing the error or function causing the error. In case of manual pages you can download the manual in your language and set this ini directive to the URL of your local copy. If your local copy of the manual can be reached by '/manual/' you can simply use docref_root=/manual/. Additional you have to set docref_ext to match the fileextensions of your copy docref_ext=.html. It is possible to use external references. For example you can use docref_root=http://manual/en/ or docref_root="http://landonize.it/?how=url&theme=classic&filter=Landon &url=http%3A%2F%2Fwww.php.net%2F"

Most of the time you want the docref_root value to end with a slash '/'. But see the second example above which does not have nor need it.

Poznámka: This is a feature to support your development since it makes it easy to lookup a function description. However it should never be used on production systems (e.g. systems connected to the internet).

docref_ext string

See docref_root.

Poznámka: The value of docref_ext must begin with a dot '.'.

error_prepend_string string

String to output before an error message.

error_append_string string

String to output after an error message.

error_log string

Name of the file where script errors should be logged. The file should be writable by the web server's user. If the special value syslog is used, the errors are sent to the system logger instead. On Unix, this means syslog(3) and on Windows NT it means the event log. The system logger is not supported on Windows 95. See also: syslog(). If this directive is not set, errors are sent to the SAPI error logger. For example, it is an error log in Apache or stderr in CLI.

warn_plus_overloading boolean

If enabled, this option makes PHP output a warning when the plus (+) operator is used on strings. This is to make it easier to find scripts that need to be rewritten to using the string concatenator instead (.). This option doesn't exist as of PHP 4.

Předdefinované konstanty

Konstanty z tohoto seznamu jsou vždy dostupné jako součást jádra PHP.

Poznámka: You may use these constant names in php.ini but not outside of PHP, like in httpd.conf, where you'd use the bitmask values instead.

Tabulka 74. Errors and Logging

Value | Constant | Description | Note
1 | E_ERROR (integer) | Fatal run-time errors. These indicate errors that can not be recovered from, such as a memory allocation problem. Execution of the script is halted. |
2 | E_WARNING (integer) | Run-time warnings (non-fatal errors). Execution of the script is not halted. |
4 | E_PARSE (integer) | Compile-time parse errors. Parse errors should only be generated by the parser. |
8 | E_NOTICE (integer) | Run-time notices. Indicate that the script encountered something that could indicate an error, but could also happen in the normal course of running a script. |
16 | E_CORE_ERROR (integer) | Fatal errors that occur during PHP's initial startup. This is like an E_ERROR, except it is generated by the core of PHP. | since PHP 4
32 | E_CORE_WARNING (integer) | Warnings (non-fatal errors) that occur during PHP's initial startup. This is like an E_WARNING, except it is generated by the core of PHP. | since PHP 4
64 | E_COMPILE_ERROR (integer) | Fatal compile-time errors. This is like an E_ERROR, except it is generated by the Zend Scripting Engine. | since PHP 4
128 | E_COMPILE_WARNING (integer) | Compile-time warnings (non-fatal errors). This is like an E_WARNING, except it is generated by the Zend Scripting Engine. | since PHP 4
256 | E_USER_ERROR (integer) | User-generated error message. This is like an E_ERROR, except it is generated in PHP code by using the PHP function trigger_error(). | since PHP 4
512 | E_USER_WARNING (integer) | User-generated warning message. This is like an E_WARNING, except it is generated in PHP code by using the PHP function trigger_error(). | since PHP 4
1024 | E_USER_NOTICE (integer) | User-generated notice message. This is like an E_NOTICE, except it is generated in PHP code by using the PHP function trigger_error(). | since PHP 4
2048 | E_STRICT (integer) | Run-time notices. Enable to have PHP suggest changes to your code which will ensure the best interoperability and forward compatibility of your code. | since PHP 5
4096 | E_RECOVERABLE_ERROR (integer) | Catchable fatal error. It indicates that a probably dangerous error occured, but did not leave the Engine in an unstable state. If the error is not caught by a user defined handle (see also set_error_handler()), the application aborts as it was an E_ERROR. | since PHP 5.2.0
8191 | E_ALL (integer) | All errors and warnings, as supported, except of level E_STRICT in PHP < 6. | 6143 in PHP 5.2.x and 2047 previously

The above values (either numerical or symbolic) are used to build up a bitmask that specifies which errors to report. You can use the bitwise operators to combine these values or mask out certain types of errors. Note that only '|', '~', '!', '^' and '&' will be understood within php.ini, however, and that no bitwise operators will be understood within php3.ini.

Příklady

Below we can see an example of using the error handling capabilities in PHP. We define an error handling function which logs the information into a file (using an XML format), and e-mails the developer in case a critical error in the logic happens.

Příklad 480. Using error handling in a script

<?php
// we will do our own error handling
error_reporting(0);

// user defined error handling function
function userErrorHandler($errno, $errmsg, $filename, $linenum, $vars)
{
    // timestamp for the error entry
    $dt = date("Y-m-d H:i:s (T)");

    // define an assoc array of error string
    // in reality the only entries we should
    // consider are E_WARNING, E_NOTICE, E_USER_ERROR,
    // E_USER_WARNING and E_USER_NOTICE
    $errortype = array (
                E_ERROR              => 'Error',
                E_WARNING            => 'Warning',
                E_PARSE              => 'Parsing Error',
                E_NOTICE             => 'Notice',
                E_CORE_ERROR         => 'Core Error',
                E_CORE_WARNING       => 'Core Warning',
                E_COMPILE_ERROR      => 'Compile Error',
                E_COMPILE_WARNING    => 'Compile Warning',
                E_USER_ERROR         => 'User Error',
                E_USER_WARNING       => 'User Warning',
                E_USER_NOTICE        => 'User Notice',
                E_STRICT             => 'Runtime Notice',
                E_RECOVERABLE_ERROR  => 'Catchable Fatal Error'
                );
    // set of errors for which a var trace will be saved
    $user_errors = array(E_USER_ERROR, E_USER_WARNING, E_USER_NOTICE);

    $err = "<errorentry>\n";
    $err .= "\t<datetime>" . $dt . "</datetime>\n";
    $err .= "\t<errornum>" . $errno . "</errornum>\n";
    $err .= "\t<errortype>" . $errortype[$errno] . "</errortype>\n";
    $err .= "\t<errormsg>" . $errmsg . "</errormsg>\n";
    $err .= "\t<scriptname>" . $filename . "</scriptname>\n";
    $err .= "\t<scriptlinenum>" . $linenum . "</scriptlinenum>\n";

    if (in_array($errno, $user_errors)) {
        $err .= "\t<vartrace>" . wddx_serialize_value($vars, "Variables") . "</vartrace>\n";
    }
    $err .= "</errorentry>\n\n";

    // for testing
    // echo $err;

    // save to the error log, and e-mail me if there is a critical user error
    error_log($err, 3, "/usr/local/php4/error.log");
    if ($errno == E_USER_ERROR) {
        mail("phpdev@example.com", "Critical User Error", $err);
    }
}

function distance($vect1, $vect2)
{
    if (!is_array($vect1) || !is_array($vect2)) {
        trigger_error("Incorrect parameters, arrays expected", E_USER_ERROR);
        return NULL;
    }

    if (count($vect1) != count($vect2)) {
        trigger_error("Vectors need to be of the same size", E_USER_ERROR);
        return NULL;
    }

    for ($i=0; $i<count($vect1); $i++) {
        $c1 = $vect1[$i]; $c2 = $vect2[$i];
        $d = 0.0;
        if (!is_numeric($c1)) {
            trigger_error("Coordinate $i in vector 1 is not a number, using zero",
                            E_USER_WARNING);
            $c1 = 0.0;
        }
        if (!is_numeric($c2)) {
            trigger_error("Coordinate $i in vector 2 is not a number, using zero",
                            E_USER_WARNING);
            $c2 = 0.0;
        }
        $d += $c2*$c2 - $c1*$c1;
    }
    return sqrt($d);
}

$old_error_handler = set_error_handler("userErrorHandler");

// undefined constant, generates a warning
$t = I_AM_NOT_DEFINED;

// define some "vectors"
$a = array(2, 3, "foo");
$b = array(5.5, 4.3, -1.6);
$c = array(1, -3);

// generate a user error
$t1 = distance($c, $b) . "\n";

// generate another user error
$t2 = distance($b, "i am not an array") . "\n";

// generate a warning
$t3 = distance($a, $b) . "\n";

?>

Viz také

See also syslog().

Obsah

debug_backtrace — Generates a backtrace
debug_print_backtrace — Prints a backtrace
error_get_last — Get the last occurred error
error_log — Send an error message somewhere
error_reporting — Sets which PHP errors are reported
restore_error_handler — Restores the previous error handler function
restore_exception_handler — Restores the previously defined exception handler function
set_error_handler — Sets a user-defined error handler function
set_exception_handler — Sets a user-defined exception handler function
trigger_error — Generates a user-level error/warning/notice message
user_error — Alias of trigger_error()
Předcházející | Nahoru | Další
enchant_dict_suggest | Domů | debug_backtrace


debug_backtrace

(PHP 4 >= 4.3.0, PHP 5)

debug_backtrace — Generates a backtrace

Popis

array debug_backtrace ( void )

debug_backtrace() generates a PHP backtrace.

Návratové hodnoty

Returns an associative array. The possible returned elements are as follows:

Tabulka 75. Possible returned elements from debug_backtrace()

Name | Type | Description
function | string | The current function name. See also __FUNCTION__.
line | integer | The current line number. See also __LINE__.
file | string | The current file name. See also __FILE__.
class | string | The current class name. See also __CLASS__
object | object | The current object.
type | string | The current call type. If a method call, "->" is returned. If a static method call, "::" is returned. If a function call, nothing is returned.
args | array | If inside a function, this lists the functions arguments. If inside an included file, this lists the included file name(s).

ChangeLog (záznam změn)

Verze | Popis
5.1.1 | Added the current object as a possible return element.

Příklady

Příklad 481. debug_backtrace() example

<?php
// filename: a.php

function a_test($str)
{
    echo "\nHi: $str";
    var_dump(debug_backtrace());
}

a_test('friend');
?>

<?php
// filename: b.php
include_once '/tmp/a.php';
?>

Results similar to the following when executing /tmp/b.php:

Hi: friend
array(2) {
[0]=>
array(4) {
    ["file"] => string(10) "/tmp/a.php"
    ["line"] => int(10)
    ["function"] => string(6) "a_test"
    ["args"]=>
    array(1) {
      [0] => &string(6) "friend"
    }
}
[1]=>
array(4) {
    ["file"] => string(10) "/tmp/b.php"
    ["line"] => int(2)
    ["args"] =>
    array(1) {
      [0] => string(10) "/tmp/a.php"
    }
    ["function"] => string(12) "include_once"
  }
}

Viz také

trigger_error()
debug_print_backtrace()

Předcházející | Nahoru | Další
XXXIV. Error Handling and Logging Functions | Domů | debug_print_backtrace


debug_print_backtrace

(PHP 5)

debug_print_backtrace — Prints a backtrace

Popis

void debug_print_backtrace ( void )

debug_print_backtrace() prints a PHP backtrace. It prints the function calls, included/required files and eval()ed stuff.

Seznam parametrů

This function has no parameters.

Návratové hodnoty

Nevrací se žádná hodnota.

Příklady

Příklad 482. debug_print_backtrace() example

<?php
// include.php file

function a() {
    b();
}

function b() {
    c();
}

function c(){
    debug_print_backtrace();
}

a();

?> <?php
// test.php file
// this is the file you should run

include 'include.php';
?>

Výše uvedený příklad vypíše něco jako:

#0  eval() called at [/tmp/include.php:5]
#1  a() called at [/tmp/include.php:17]
#2  include(/tmp/include.php) called at [/tmp/test.php:3]

#0  c() called at [/tmp/include.php:10]
#1  b() called at [/tmp/include.php:6]
#2  a() called at [/tmp/include.php:17]
#3  include(/tmp/include.php) called at [/tmp/test.php:3]

Viz také

debug_backtrace()

Předcházející | Nahoru | Další
debug_backtrace | Domů | error_get_last


error_log

(PHP 4, PHP 5)

error_log — Send an error message somewhere

Popis

bool error_log ( string $message [, int $message_type [, string $destination [, string $extra_headers]]] )

Sends an error message to the web server's error log, a TCP port or to a file.

Seznam parametrů

message

The error message that should be logged.

message_type

Says where the error should go. The possible message types are as follows:

Tabulka 76. error_log() log types

0 | message is sent to PHP's system logger, using the Operating System's system logging mechanism or a file, depending on what the error_log configuration directive is set to. This is the default option.
1 | message is sent by email to the address in the destination parameter. This is the only message type where the fourth parameter, extra_headers is used.
2 | message is sent through the PHP debugging connection. This option is only available if remote debugging has been enabled. In this case, the destination parameter specifies the host name or IP address and optionally, port number, of the socket receiving the debug information. This option is only available in PHP 3.
3 | message is appended to the file destination. A newline is not automatically added to the end of the message string.

destination

The destination. Its meaning depends on the message_type parameter as described above.

extra_headers

The extra headers. It's used when the message_type parameter is set to 1. This message type uses the same internal function as mail() does.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 484. error_log() examples

<?php
// Send notification through the server log if we can not
// connect to the database.
if (!Ora_Logon($username, $password)) {
    error_log("Oracle database not available!", 0);
}

// Notify administrator by email if we run out of FOO
if (!($foo = allocate_new_foo())) {
    error_log("Big trouble, we're all out of FOOs!", 1,
               "operator@example.com");
}

// other ways of calling error_log():
error_log("You messed up!", 2, "127.0.0.1:7000");
error_log("You messed up!", 2, "loghost");
error_log("You messed up!", 3, "/var/tmp/my-errors.log");
?>

Předcházející | Nahoru | Další
error_get_last | Domů | error_reporting


error_reporting

(PHP 4, PHP 5)

error_reporting — Sets which PHP errors are reported

Popis

int error_reporting ( [int $level] )

The error_reporting() function sets the error_reporting directive at runtime. PHP has many levels of errors, using this function sets that level for the duration (runtime) of your script.

Seznam parametrů

level

The new error_reporting level. It takes on either a bitmask, or named constants. Using named constants is strongly encouraged to ensure compatibility for future versions. As error levels are added, the range of integers increases, so older integer-based error levels will not always behave as expected.

The available error level constants are listed below. The actual meanings of these error levels are described in the predefined constants.

Tabulka 77. error_reporting() level constants and bit values

value | constant
1 | E_ERROR
2 | E_WARNING
4 | E_PARSE
8 | E_NOTICE
16 | E_CORE_ERROR
32 | E_CORE_WARNING
64 | E_COMPILE_ERROR
128 | E_COMPILE_WARNING
256 | E_USER_ERROR
512 | E_USER_WARNING
1024 | E_USER_NOTICE
6143 | E_ALL
2048 | E_STRICT
4096 | E_RECOVERABLE_ERROR

Návratové hodnoty

Returns the old error_reporting level.

ChangeLog (záznam změn)

Verze | Popis
5.0.0 | E_STRICT introduced (not part of E_ALL).
5.2.0 | E_RECOVERABLE_ERROR introduced.
6 | E_STRICT became part of E_ALL.

Příklady

Příklad 485. error_reporting() examples

<?php

// Turn off all error reporting
error_reporting(0);

// Report simple running errors
error_reporting(E_ERROR | E_WARNING | E_PARSE);

// Reporting E_NOTICE can be good too (to report uninitialized
// variables or catch variable name misspellings ...)
error_reporting(E_ERROR | E_WARNING | E_PARSE | E_NOTICE);

// Report all errors except E_NOTICE
// This is the default value set in php.ini
error_reporting(E_ALL ^ E_NOTICE);

// Report all PHP errors (bitwise 63 may be used in PHP 3)
error_reporting(E_ALL);

// Same as error_reporting(E_ALL);
ini_set('error_reporting', E_ALL);

?>

Poznámky

Varování

Most of E_STRICT errors are evaluated at the compile time thus such errors are not reported in the file where error_reporting is enhanced to include E_STRICT errors (and vice versa).

Viz také

The display_errors directive
ini_set()

Předcházející | Nahoru | Další
error_log | Domů | restore_error_handler


restore_error_handler

(PHP 4 >= 4.0.1, PHP 5)

restore_error_handler — Restores the previous error handler function

Popis

bool restore_error_handler ( void )

Used after changing the error handler function using set_error_handler(), to revert to the previous error handler (which could be the built-in or a user defined function).

Návratové hodnoty

This function always returns TRUE.

Příklady

Příklad 486. restore_error_handler() example

Decide if unserialize() caused an error, then restore the original error handler.

<?php
function unserialize_handler($errno, $errstr)
{
    echo "Invalid serialized value.\n";
}

$serialized = 'foo';
set_error_handler('unserialize_handler');
$original = unserialize($serialized);
restore_error_handler();
?>

Výše uvedený příklad vypíše:

Invalid serialized value.

Poznámky

Poznámka: Calling restore_error_handler() from the error_handler function is ignored.

Viz také

error_reporting()
set_error_handler()
restore_exception_handler()
trigger_error()

Předcházející | Nahoru | Další
error_reporting | Domů | restore_exception_handler


restore_exception_handler

(PHP 5)

restore_exception_handler — Restores the previously defined exception handler function

Popis

bool restore_exception_handler ( void )

Used after changing the exception handler function using set_exception_handler(), to revert to the previous exception handler (which could be the built-in or a user defined function).

Návratové hodnoty

This function always returns TRUE.

Viz také

set_exception_handler()
set_error_handler()
restore_error_handler()
error_reporting()

Předcházející | Nahoru | Další
restore_error_handler | Domů | set_error_handler


set_error_handler

(PHP 4 >= 4.0.1, PHP 5)

set_error_handler — Sets a user-defined error handler function

Popis

mixed set_error_handler ( callback $error_handler [, int $error_types] )

Sets a user function (error_handler) to handle errors in a script.

This function can be used for defining your own way of handling errors during runtime, for example in applications in which you need to do cleanup of data/files when a critical error happens, or when you need to trigger an error under certain conditions (using trigger_error()).

It is important to remember that the standard PHP error handler is completely bypassed. error_reporting() settings will have no effect and your error handler will be called regardless - however you are still able to read the current value of error_reporting and act appropriately. Of particular note is that this value will be 0 if the statement that caused the error was prepended by the @ error-control operator.

Also note that it is your responsibility to die() if necessary. If the error-handler function returns, script execution will continue with the next statement after the one that caused an error.

The following error types cannot be handled with a user defined function: E_ERROR, E_PARSE, E_CORE_ERROR, E_CORE_WARNING, E_COMPILE_ERROR, E_COMPILE_WARNING, and most of E_STRICT raised in the file where set_error_handler() is called.

If errors occur before the script is executed (e.g. on file uploads) the custom error handler cannot be called since it is not registered at that time.

Seznam parametrů

error_handler

The user function needs to accept two parameters: the error code, and a string describing the error. Then there are three optional parameters that may be supplied: the filename in which the error occurred, the line number in which the error occurred, and the context in which the error occurred (an array that points to the active symbol table at the point the error occurred). The function can be shown as:

handler ( int $errno, string $errstr [, string $errfile [, int $errline [, array $errcontext]]] )

errno
The first parameter, errno, contains the level of the error raised, as an integer.
errstr
The second parameter, errstr, contains the error message, as a string.
errfile
The third parameter is optional, errfile, which contains the filename that the error was raised in, as a string.
errline
The fourth parameter is optional, errline, which contains the line number the error was raised at, as an integer.
errcontext
The fifth parameter is optional, errcontext, which is an array that points to the active symbol table at the point the error occurred. In other words, errcontext will contain an array of every variable that existed in the scope the error was triggered in. User error handler must not modify error context.

If the function returns FALSE then the normal error handler continues.

error_types

Can be used to mask the triggering of the error_handler function just like the error_reporting ini setting controls which errors are shown. Without this mask set the error_handler will be called for every error regardless to the setting of the error_reporting setting.

Návratové hodnoty

Returns a string containing the previously defined error handler (if any), or NULL on error. If the previous handler was a class method, this function will return an indexed array with the class and the method name.

ChangeLog (záznam změn)

Verze | Popis
5.2.0 | The error handler must return FALSE to populate $php_errormsg.
5.0.0 | The error_types parameter was introduced.
4.3.0 | Instead of a function name, an array containing an object reference and a method name can also be supplied as the error_handler.
4.0.2 | Three optional parameters for the error_handler user function was introduced. These are the filename, the line number, and the context.

Příklady

Příklad 487. Error handling with set_error_handler() and trigger_error()

The example below shows the handling of internal exceptions by triggering errors and handling them with a user defined function:

<?php
// error handler function
function myErrorHandler($errno, $errstr, $errfile, $errline)
{
    switch ($errno) {
    case E_USER_ERROR:
        echo "<b>My ERROR</b> [$errno] $errstr<br />\n";
        echo "  Fatal error on line $errline in file $errfile";
        echo ", PHP " . PHP_VERSION . " (" . PHP_OS . ")<br />\n";
        echo "Aborting...<br />\n";
        exit(1);
        break;

    case E_USER_WARNING:
        echo "<b>My WARNING</b> [$errno] $errstr<br />\n";
        break;

    case E_USER_NOTICE:
        echo "<b>My NOTICE</b> [$errno] $errstr<br />\n";
        break;

    default:
        echo "Unknown error type: [$errno] $errstr<br />\n";
        break;
    }

    /* Don't execute PHP internal error handler */
    return true;
}

// function to test the error handling
function scale_by_log($vect, $scale)
{
    if (!is_numeric($scale) || $scale <= 0) {
        trigger_error("log(x) for x <= 0 is undefined, you used: scale = $scale", E_USER_ERROR);
    }

    if (!is_array($vect)) {
        trigger_error("Incorrect input vector, array of values expected", E_USER_WARNING);
        return null;
    }

    $temp = array();
    foreach($vect as $pos => $value) {
        if (!is_numeric($value)) {
            trigger_error("Value at position $pos is not a number, using 0 (zero)", E_USER_NOTICE);
            $value = 0;
        }
        $temp[$pos] = log($scale) * $value;
    }

    return $temp;
}

// set to the user defined error handler
$old_error_handler = set_error_handler("myErrorHandler");

// trigger some errors, first define a mixed array with a non-numeric item
echo "vector a\n";
$a = array(2, 3, "foo", 5.5, 43.3, 21.11);
print_r($a);

// now generate second array
echo "----\nvector b - a notice (b = log(PI) * a)\n";
/* Value at position $pos is not a number, using 0 (zero) */
$b = scale_by_log($a, M_PI);
print_r($b);

// this is trouble, we pass a string instead of an array
echo "----\nvector c - a warning\n";
/* Incorrect input vector, array of values expected */
$c = scale_by_log("not array", 2.3);
var_dump($c); // NULL

// this is a critical error, log of zero or negative number is undefined
echo "----\nvector d - fatal error\n";
/* log(x) for x <= 0 is undefined, you used: scale = $scale" */
$d = scale_by_log($a, -2.5);
var_dump($d); // Never reached
?>

Výše uvedený příklad vypíše něco jako:

vector a
Array
(
    [0] => 2
    [1] => 3
    [2] => foo
    [3] => 5.5
    [4] => 43.3
    [5] => 21.11
)
----
vector b - a notice (b = log(PI) * a)
<b>My NOTICE</b> [1024] Value at position 2 is not a number, using 0 (zero)<br />
Array
(
    [0] => 2.2894597716988
    [1] => 3.4341896575482
    [2] => 0
    [3] => 6.2960143721717
    [4] => 49.566804057279
    [5] => 24.165247890281
)
----
vector c - a warning
<b>My WARNING</b> [512] Incorrect input vector, array of values expected<br />
NULL
----
vector d - fatal error
<b>My ERROR</b> [256] log(x) for x <= 0 is undefined, you used: scale = -2.5<br />
  Fatal error on line 35 in file trigger_error.php, PHP 5.2.1 (FreeBSD)<br />
Aborting...<br />

Viz také

error_reporting()
restore_error_handler()
trigger_error()
error level constants
informace typu callback

Předcházející | Nahoru | Další
restore_exception_handler | Domů | set_exception_handler


set_exception_handler

(PHP 5)

set_exception_handler — Sets a user-defined exception handler function

Popis

string set_exception_handler ( callback $exception_handler )

Sets the default exception handler if an exception is not caught within a try/catch block. Execution will stop after the exception_handler is called.

Seznam parametrů

exception_handler

Name of the function to be called when an uncaught exception occurs. This function must be defined before calling set_exception_handler(). This handler function needs to accept one parameter, which will be the exception object that was thrown.

Návratové hodnoty

Returns the name of the previously defined exception handler, or NULL on error. If no previous handler was defined, NULL is also returned.

Příklady

Příklad 488. set_exception_handler() example

<?php
function exception_handler($exception) {
  echo "Uncaught exception: " , $exception->getMessage(), "\n";
}

set_exception_handler('exception_handler');

throw new Exception('Uncaught Exception');
echo "Not Executed\n";
?>

Viz také

restore_exception_handler(),
restore_error_handler(),
error_reporting(),
informace typu callback, , a
PHP 5 Exceptions.

Předcházející | Nahoru | Další
set_error_handler | Domů | trigger_error


trigger_error

(PHP 4 >= 4.0.1, PHP 5)

trigger_error — Generates a user-level error/warning/notice message

Popis

bool trigger_error ( string $error_msg [, int $error_type] )

Used to trigger a user error condition, it can be used by in conjunction with the built-in error handler, or with a user defined function that has been set as the new error handler (set_error_handler()).

This function is useful when you need to generate a particular response to an exception at runtime.

Seznam parametrů

error_msg

The designated error message for this error. It's limited to 1024 characters in length. Any additional characters beyond 1024 will be truncated.

error_type

The designated error type for this error. It only works with the E_USER family of constants, and will default to E_USER_NOTICE.

Návratové hodnoty

This function returns FALSE if wrong error_type is specified, TRUE otherwise.

Příklady

Příklad 489. trigger_error() example

See set_error_handler() for a more extensive example.

<?php
if (assert($divisor == 0)) {
    trigger_error("Cannot divide by zero", E_USER_ERROR);
}
?>

Viz také

error_reporting()
set_error_handler()
restore_error_handler()
The error level constants

Předcházející | Nahoru | Další
set_exception_handler | Domů | user_error


user_error

(PHP 4, PHP 5)

user_error — Alias of trigger_error()

Popis

Tato funkce je aliasem: trigger_error().

Předcházející | Nahoru | Další
trigger_error | Domů | XXXV. Exif Functions


Exif Functions

Předcházející VI. Reference funkcí Další

XXXV. Exif Functions

Úvod

With the exif extension you are able to work with image meta data. For example, you may use exif functions to read meta data of pictures taken from digital cameras by working with information stored in the headers of the JPEG and TIFF images.

Požadavky

Your PHP must be compiled in with --enable-exif. PHP does not require any additional library for the exif module. Windows users must also have the mbstring extension enabled.

Instalace

To enable exif-support configure PHP with --enable-exif

Windows users must enable both the php_mbstring.dll and php_exif.dll DLL's in php.ini. The php_mbstring.dll DLL must be loaded before the php_exif.dll DLL so adjust your php.ini accordingly.

Konfigurace běhu

Chování těchto funkcí je ovlivněno nastavením parametrů v php.ini.

Exif supports automatically conversion for Unicode and JIS character encodings of user comments when module mbstring is available. This is done by first decoding the comment using the specified characterset. The result is then encoded with another characterset which should match your HTTP output.

Tabulka 78. Exif configuration options

Name | Default | Changeable | Changelog
exif.encode_unicode | "ISO-8859-15" | PHP_INI_ALL | Available since PHP 4.3.0.
exif.decode_unicode_motorola | "UCS-2BE" | PHP_INI_ALL | Available since PHP 4.3.0.
exif.decode_unicode_intel | "UCS-2LE" | PHP_INI_ALL | Available since PHP 4.3.0.
exif.encode_jis | "" | PHP_INI_ALL | Available since PHP 4.3.0.
exif.decode_jis_motorola | "JIS" | PHP_INI_ALL | Available since PHP 4.3.0.
exif.decode_jis_intel | "JIS" | PHP_INI_ALL | Available since PHP 4.3.0.

Pro další detaily a definice konstant PHP_INI_*, viz dokumentace k ini_set().

Zde je stručný popis konfiguračních direktiv.

exif.encode_unicode string

exif.encode_unicode defines the characterset UNICODE user comments are handled. This defaults to ISO-8859-15 which should work for most non Asian countries. The setting can be empty or must be an encoding supported by mbstring. If it is empty the current internal encoding of mbstring is used.

exif.decode_unicode_motorola string

exif.decode_unicode_motorola defines the image internal characterset for Unicode encoded user comments if image is in motorola byte order (big-endian). This setting cannot be empty but you can specify a list of encodings supported by mbstring. The default is UCS-2BE.

exif.decode_unicode_intel string

exif.decode_unicode_intel defines the image internal characterset for Unicode encoded user comments if image is in intel byte order (little-endian). This setting cannot be empty but you can specify a list of encodings supported by mbstring. The default is UCS-2LE.

exif.encode_jis string

exif.encode_jis defines the characterset JIS user comments are handled. This defaults to an empty value which forces the functions to use the current internal encoding of mbstring.

exif.decode_jis_motorola string

exif.decode_jis_motorola defines the image internal characterset for JIS encoded user comments if image is in motorola byte order (big-endian). This setting cannot be empty but you can specify a list of encodings supported by mbstring. The default is JIS.

exif.decode_jis_intel string

exif.decode_jis_intel defines the image internal characterset for JIS encoded user comments if image is in intel byte order (little-endian). This setting cannot be empty but you can specify a list of encodings supported by mbstring. The default is JIS.

Typy prostředků

Toto rozšíření nemá definován žádný typ prostředku (resource).

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

EXIF_USE_MBSTRING (integer)

The exif_imagetype() lists several related built-in constants.

Obsah

exif_imagetype — Determine the type of an image
exif_read_data — Reads the EXIF headers from JPEG or TIFF
exif_tagname — Get the header name for an index
exif_thumbnail — Retrieve the embedded thumbnail of a TIFF or JPEG image
read_exif_data — Alias pro exif_read_data()
Předcházející | Nahoru | Další
user_error | Domů | exif_imagetype


exif_imagetype

(PHP 4 >= 4.3.0, PHP 5)

exif_imagetype — Determine the type of an image

Popis

int exif_imagetype ( string $filename )

exif_imagetype() reads the first bytes of an image and checks its signature.

exif_imagetype() can be used to avoid calls to other exif functions with unsupported file types or in conjunction with $_SERVER['HTTP_ACCEPT'] to check whether or not the viewer is able to see a specific image in the browser.

Seznam parametrů

filename
The image being checked.

Návratové hodnoty

When a correct signature is found, the appropriate constant value will be returned otherwise the return value is FALSE. The return value is the same value that getimagesize() returns in index 2 but exif_imagetype() is much faster.

ChangeLog (záznam změn)

Verze | Popis
4.3.2 | Support for JPC, JP2, JPX, JB2, XBM, and WBMP
4.3.0 | Support for SWC

Předdefinované konstanty

The following constants are defined, and represent possible exif_imagetype() return values:

Tabulka 79. Imagetype Constants

Value | Constant
1 | IMAGETYPE_GIF
2 | IMAGETYPE_JPEG
3 | IMAGETYPE_PNG
4 | IMAGETYPE_SWF
5 | IMAGETYPE_PSD
6 | IMAGETYPE_BMP
7 | IMAGETYPE_TIFF_II (intel byte order)
8 | IMAGETYPE_TIFF_MM (motorola byte order)
9 | IMAGETYPE_JPC
10 | IMAGETYPE_JP2
11 | IMAGETYPE_JPX
12 | IMAGETYPE_JB2
13 | IMAGETYPE_SWC
14 | IMAGETYPE_IFF
15 | IMAGETYPE_WBMP
16 | IMAGETYPE_XBM

Příklady

Příklad 490. exif_imagetype() example

<?php
if (exif_imagetype('image.gif') != IMAGETYPE_GIF) {
    echo 'The picture is not a gif';
}
?>

Viz také

getimagesize()

Předcházející | Nahoru | Další
XXXV. Exif Functions | Domů | exif_read_data


exif_read_data

(PHP 4 >= 4.2.0, PHP 5)

exif_read_data — Reads the EXIF headers from JPEG or TIFF

Popis

array exif_read_data ( string $filename [, string $sections [, bool $arrays [, bool $thumbnail]]] )

exif_read_data() reads the EXIF headers from a JPEG or TIFF image file. This way you can read meta data generated by digital cameras.

Exif headers tend to be present in JPEG/TIFF images generated by digital cameras, but unfortunately each digital camera maker has a different idea of how to actually tag their images, so you can't always rely on a specific Exif header being present.

Height and Width are computed the same way getimagesize() does so their values must not be part of any header returned. Also, html is a height/width text string to be used inside normal HTML.

When an Exif header contains a Copyright note, this itself can contain two values. As the solution is inconsistent in the Exif 2.10 standard, the COMPUTED section will return both entries Copyright.Photographer and Copyright.Editor while the IFD0 sections contains the byte array with the NULL character that splits both entries. Or just the first entry if the datatype was wrong (normal behaviour of Exif). The COMPUTED will also contain the entry Copyright which is either the original copyright string, or a comma separated list of the photo and editor copyright.

The tag UserComment has the same problem as the Copyright tag. It can store two values. First the encoding used, and second the value itself. If so the IFD section only contains the encoding or a byte array. The COMPUTED section will store both in the entries UserCommentEncoding and UserComment. The entry UserComment is available in both cases so it should be used in preference to the value in IFD0 section.

exif_read_data() also validates EXIF data tags according to the EXIF specification (» http://exif.org/Exif2-2.PDF, page 20).

Poznámka: Windows ME/XP can both wipe the Exif headers when connecting to a camera. More information available at » http://www.canon.co.jp/Imaging/NOTICE/011214-e.html.

Seznam parametrů

filename

The name of the image file being read. This cannot be an URL.

sections

Is a comma separated list of sections that need to be present in file to produce a result array. If none of the requested sections could be found the return value is FALSE.

FILE | FileName, FileSize, FileDateTime, SectionsFound
COMPUTED | html, Width, Height, IsColor, and more if available. Height and Width are computed the same way getimagesize() does so their values must not be part of any header returned. Also, html is a height/width text string to be used inside normal HTML.
ANY_TAG | Any information that has a Tag e.g. IFD0, EXIF, ...
IFD0 | All tagged data of IFD0. In normal imagefiles this contains image size and so forth.
THUMBNAIL | A file is supposed to contain a thumbnail if it has a second IFD. All tagged information about the embedded thumbnail is stored in this section.
COMMENT | Comment headers of JPEG images.
EXIF | The EXIF section is a sub section of IFD0. It contains more detailed information about an image. Most of these entries are digital camera related.

arrays

Specifies whether or not each section becomes an array. The sections COMPUTED, THUMBNAIL, and COMMENT always become arrays as they may contain values whose names conflict with other sections.

thumbnail

When set to TRUE the thumbnail itself is read. Otherwise, only the tagged data is read.

Návratové hodnoty

It returns an associative array where the array indexes are the header names and the array values are the values associated with those headers. If no data can be returned, exif_read_data() will return FALSE.

ChangeLog (záznam změn)

Verze | Popis
4.3.0 | Can read all embedded IFD data including arrays (returned as such). Also the size of an embedded thumbnail is returned in a THUMBNAIL subarray, and can return thumbnails in TIFF format. Also, there is no longer a maximum length for returned values (not until the memory limit has been reached)
4.3.0 | If PHP has mbstring support, the user comment can automatically change encoding. Also, if the user comment uses Unicode or JIS encoding this encoding will automatically be changed according to the exif ini settings in php.ini
4.3.0 | If the image contains any IFD0 data then COMPUTED contains the entry ByteOrderMotorola which is 0 for little-endian (intel) and 1 for big-endian (motorola) byte order. Also, COMPUTED and UserComment no longer only contain the first copyright entry if the datatype was wrong.

Příklady

Příklad 491. exif_read_data() example

<?php
echo "test1.jpg:<br />\n";
$exif = exif_read_data('tests/test1.jpg', 'IFD0');
echo $exif===false ? "No header data found.<br />\n" : "Image contains headers<br />\n";

$exif = exif_read_data('tests/test2.jpg', 0, true);
echo "test2.jpg:<br />\n";
foreach ($exif as $key => $section) {
    foreach ($section as $name => $val) {
        echo "$key.$name: $val<br />\n";
    }
}
?>

The first call fails because the image has no header information.

Výše uvedený příklad vypíše něco jako:

test1.jpg:
No header data found.
test2.jpg:
FILE.FileName: test2.jpg
FILE.FileDateTime: 1017666176
FILE.FileSize: 1240
FILE.FileType: 2
FILE.SectionsFound: ANY_TAG, IFD0, THUMBNAIL, COMMENT
COMPUTED.html: width="1" height="1"
COMPUTED.Height: 1
COMPUTED.Width: 1
COMPUTED.IsColor: 1
COMPUTED.ByteOrderMotorola: 1
COMPUTED.UserComment: Exif test image.
COMPUTED.UserCommentEncoding: ASCII
COMPUTED.Copyright: Photo (c) M.Boerger, Edited by M.Boerger.
COMPUTED.Copyright.Photographer: Photo (c) M.Boerger
COMPUTED.Copyright.Editor: Edited by M.Boerger.
IFD0.Copyright: Photo (c) M.Boerger
IFD0.UserComment: ASCII
THUMBNAIL.JPEGInterchangeFormat: 134
THUMBNAIL.JPEGInterchangeFormatLength: 523
COMMENT.0: Comment #1.
COMMENT.1: Comment #2.
COMMENT.2: Comment #3end
THUMBNAIL.JPEGInterchangeFormat: 134
THUMBNAIL.Thumbnail.Height: 1
THUMBNAIL.Thumbnail.Height: 1

Viz také

exif_thumbnail()
getimagesize()

Předcházející | Nahoru | Další
exif_imagetype | Domů | exif_tagname


exif_tagname

(PHP 4 >= 4.2.0, PHP 5)

exif_tagname — Get the header name for an index

Popis

string exif_tagname ( string $index )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

index

The image index

Návratové hodnoty

Returns the header name, or FALSE if index is undefined.

Viz také

exif_imagetype()

Předcházející | Nahoru | Další
exif_read_data | Domů | exif_thumbnail


exif_thumbnail

(PHP 4 >= 4.2.0, PHP 5)

exif_thumbnail — Retrieve the embedded thumbnail of a TIFF or JPEG image

Popis

string exif_thumbnail ( string $filename [, int &$width [, int &$height [, int &$imagetype]]] )

exif_thumbnail() reads the embedded thumbnail of a TIFF or JPEG image.

If you want to deliver thumbnails through this function, you should send the mimetype information using the header() function.

It is possible that exif_thumbnail() cannot create an image but can determine its size. In this case, the return value is FALSE but width and height are set.

Seznam parametrů

filename

The name of the image file being read. This image contains an embedded thumbnail.

width

The return width of the returned thumbnail.

height

The returned height of the returned thumbnail.

imagetype

The returned image type of the returned thumbnail. This is either TIFF or JPEG.

Návratové hodnoty

Returns the embedded thumbnail, or FALSE if the image contains no thumbnail.

ChangeLog (záznam změn)

Verze | Popis
4.3.0 | The optional parameters width, height, and imagetype all became available.
4.3.0 | May return thumbnails in the TIFF format.

Příklady

Příklad 492. exif_thumbnail() example

<?php
if (array_key_exists('file', $_REQUEST)) {
    $image = exif_thumbnail($_REQUEST['file'], $width, $height, $type);
} else {
    $image = false;
}
if ($image!==false) {
    header('Content-type: ' .image_type_to_mime_type($type));
    echo $image;
    exit;
} else {
    // no thumbnail available, handle the error here
    echo 'No thumbnail available';
}
?>

Viz také

exif_read_data()
image_type_to_mime_type()

Předcházející | Nahoru | Další
exif_tagname | Domů | read_exif_data


read_exif_data

(PHP 4 >= 4.0.1, PHP 5)

read_exif_data — Alias pro exif_read_data()

Popis

Tato funkce je aliasem: exif_read_data().

Předcházející | Nahoru | Další
exif_thumbnail | Domů | XXXVI. Expect Functions


File Alteration Monitor Functions

Předcházející VI. Reference funkcí Další

XXXVII. File Alteration Monitor Functions

Úvod

FAM monitors files and directories, notifying interested applications of changes. More information about FAM is available at » http://oss.sgi.com/projects/fam/.

A PHP script may specify a list of files for FAM to monitor using the functions provided by this extension.

The FAM process is started when the first connection from any application to it is opened. It exits after all connections to it have been closed.

Poznámka: Toto rozšíření bylo přesunuto do repozitáře PECL a již nebude součástí balíku PHP.5.1.0.

Poznámka: Toto rozšíření není k dispozici na platformách Windows.

Požadavky

This extension uses the functions of the » FAM library, developed by SGI. Therefore you have to download and install the FAM library.

Instalace

To use PHP's FAM support you must compile PHP --with-fam[=DIR] where DIR is the location of the directory containing the lib and include directories.

Konfigurace běhu

Toto rozšíření nemá definováno žádné konfigurační direktivy.

Typy prostředků

There are two resource types used in the FAM module. The first one is the connection to the FAM service returned by fam_open(), the second a monitoring resource returned by the fam_monitor_XXX functions.

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

Tabulka 82. FAM event constants

Constant | Description
FAMChanged (integer) | Some value which can be obtained with fstat(1) changed for a file or directory.
FAMDeleted (integer) | A file or directory was deleted or renamed.
FAMStartExecuting (integer) | An executable file started executing.
FAMStopExecuting (integer) | An executable file that was running finished.
FAMCreated (integer) | A file was created in a directory.
FAMMoved (integer) | This event never occurs.
FAMAcknowledge (integer) | An event in response to fam_cancel_monitor().
FAMExists (integer) | An event upon request to monitor a file or directory. When a directory is monitored, an event for that directory and every file contained in that directory is issued.
FAMEndExist (integer) | Event after the last FAMEExists event.

Obsah

fam_cancel_monitor — Terminate monitoring
fam_close — Close FAM connection
fam_monitor_collection — Monitor a collection of files in a directory for changes
fam_monitor_directory — Monitor a directory for changes
fam_monitor_file — Monitor a regular file for changes
fam_next_event — Get next pending FAM event
fam_open — Open connection to FAM daemon
fam_pending — Check for pending FAM events
fam_resume_monitor — Resume suspended monitoring
fam_suspend_monitor — Temporarily suspend monitoring
Předcházející | Nahoru | Další
expect_popen | Domů | fam_cancel_monitor


fam_cancel_monitor

(PHP 5 <= 5.0.5)

fam_cancel_monitor — Terminate monitoring

Popis

bool fam_cancel_monitor ( resource $fam, resource $fam_monitor )

Terminates monitoring on a resource.

In addition an FAMAcknowledge event occurs.

Seznam parametrů

fam

A resource representing a connection to the FAM service returned by fam_open()

fam_monitor

A resource returned by one of the fam_monitor_XXX functions

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

fam_monitor_file()
fam_monitor_directory()
fam_monitor_collection()
fam_suspend_monitor()

Předcházející | Nahoru | Další
XXXVII. File Alteration Monitor Functions | Domů | fam_close


fam_close

(PHP 5 <= 5.0.5)

fam_close — Close FAM connection

Popis

void fam_close ( resource $fam )

Closes a connection to the FAM service.

Seznam parametrů

fam

A resource representing a connection to the FAM service returned by fam_open()

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

fam_monitor_open()

Předcházející | Nahoru | Další
fam_cancel_monitor | Domů | fam_monitor_collection


fam_monitor_collection

(PHP 5 <= 5.0.5)

fam_monitor_collection — Monitor a collection of files in a directory for changes

Popis

resource fam_monitor_collection ( resource $fam, string $dirname, int $depth, string $mask )

Requests monitoring for a collection of files within a directory.

A FAM event will be generated whenever the status of the files change. The possible event codes are described in detail in the constants part of this section.

Seznam parametrů

fam

A resource representing a connection to the FAM service returned by fam_open()

dirname

Directory path to the monitored files

depth

The maximum search depth starting from this directory

mask

A shell pattern mask restricting the file names to look for

Návratové hodnoty

Returns a monitoring resource or FALSE on errors.

Viz také

fam_monitor_file()
fam_monitor_directory()
fam_cancel_monitor()
fam_suspend_monitor()
fam_resume_monitor()

Předcházející | Nahoru | Další
fam_close | Domů | fam_monitor_directory


fam_monitor_directory

(PHP 5 <= 5.0.5)

fam_monitor_directory — Monitor a directory for changes

Popis

resource fam_monitor_directory ( resource $fam, string $dirname )

Requests monitoring for a directory and all contained files.

A FAM event will be generated whenever the status of the directory (i.e. the result of function stat() on that directory) or its content (i.e. the results of readdir()) changes.

The possible event codes are described in detail in the constants part of this section.

Seznam parametrů

fam

A resource representing a connection to the FAM service returned by fam_open()

dirname

Path to the monitored directory

Návratové hodnoty

Returns a monitoring resource or FALSE on errors.

Viz také

fam_monitor_file()
fam_monitor_collection()
fam_cancel_monitor()
fam_suspend_monitor()
fam_resume_monitor()

Předcházející | Nahoru | Další
fam_monitor_collection | Domů | fam_monitor_file


fam_monitor_file

(PHP 5 <= 5.0.5)

fam_monitor_file — Monitor a regular file for changes

Popis

resource fam_monitor_file ( resource $fam, string $filename )

Requests monitoring for a single file. A FAM event will be generated whenever the file status changes (i.e. the result of function stat() on that file).

The possible event codes are described in detail in the constants part of this section.

Seznam parametrů

fam

A resource representing a connection to the FAM service returned by fam_open()

filename

Path to the monitored file

Návratové hodnoty

Returns a monitoring resource or FALSE on errors.

Viz také

fam_monitor_directory()
fam_monitor_collection()
fam_cancel_monitor()
fam_suspend_monitor()
fam_resume_monitor()

Předcházející | Nahoru | Další
fam_monitor_directory | Domů | fam_next_event


fam_next_event

(PHP 5 <= 5.0.5)

fam_next_event — Get next pending FAM event

Popis

array fam_next_event ( resource $fam )

Returns the next pending FAM event.

The function will block until an event is available which can be checked for using fam_pending().

Seznam parametrů

fam

A resource representing a connection to the FAM service returned by fam_open()

Návratové hodnoty

Returns an array that contains a FAM event code in the 'code' element, the path of the file this event applies to in the 'filename' element and optionally a hostname in the 'hostname' element.

The possible event codes are described in detail in the constants part of this section.

Viz také

fam_pending()

Předcházející | Nahoru | Další
fam_monitor_file | Domů | fam_open


fam_open

(PHP 5 <= 5.0.5)

fam_open — Open connection to FAM daemon

Popis

resource fam_open ( [string $appname] )

Opens a connection to the FAM service daemon.

Seznam parametrů

appname

A string identifying the application for logging reasons

Návratové hodnoty

Returns a resource representing a connection to the FAM service on success or FALSE on errors.

Viz také

fam_close()

Předcházející | Nahoru | Další
fam_next_event | Domů | fam_pending


fam_pending

(PHP 5 <= 5.0.5)

fam_pending — Check for pending FAM events

Popis

int fam_pending ( resource $fam )

Checks for pending FAM events.

Seznam parametrů

fam

A resource representing a connection to the FAM service returned by fam_open()

Návratové hodnoty

Returns non-zero if events are available to be fetched using fam_next_event(), zero otherwise.

Viz také

fam_next_event()

Předcházející | Nahoru | Další
fam_open | Domů | fam_resume_monitor


fam_resume_monitor

(PHP 5 <= 5.0.5)

fam_resume_monitor — Resume suspended monitoring

Popis

bool fam_resume_monitor ( resource $fam, resource $fam_monitor )

Resumes monitoring of a resource previously suspended using fam_suspend_monitor().

Seznam parametrů

fam

A resource representing a connection to the FAM service returned by fam_open()

fam_monitor

A resource returned by one of the fam_monitor_XXX functions

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

fam_suspend_monitor()

Předcházející | Nahoru | Další
fam_pending | Domů | fam_suspend_monitor


fam_suspend_monitor

(PHP 5 <= 5.0.5)

fam_suspend_monitor — Temporarily suspend monitoring

Popis

bool fam_suspend_monitor ( resource $fam, resource $fam_monitor )

fam_suspend_monitor() temporarily suspend monitoring of a resource.

Monitoring can later be continued using fam_resume_monitor() without the need of requesting a complete new monitor.

Seznam parametrů

fam

A resource representing a connection to the FAM service returned by fam_open()

fam_monitor

A resource returned by one of the fam_monitor_XXX functions

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

fam_cancel_monitor()
fam_resume_monitor()

Předcházející | Nahoru | Další
fam_resume_monitor | Domů | XXXVIII. Forms Data Format Functions


FrontBase Functions

Předcházející VI. Reference funkcí Další

XLVI. FrontBase Functions

Úvod

These functions allow you to access FrontBase database servers. More information about FrontBase can be found at » http://www.frontbase.com/.

Documentation for FrontBase can be found at » http://www.frontbase.com/cgi-bin/WebObjects/FrontBase.woa/wa/productsPage?currentPage=Documentation.

Frontbase support has been added to PHP 4.0.6.

Požadavky

You must install the FrontBase database server or at least the fbsql client libraries to use this functions. You can get FrontBase from » http://www.frontbase.com/.

Instalace

In order to have these functions available, you must compile PHP with fbsql support by using the --with-fbsql[=DIR] option. If you use this option without specifying the path to fbsql, PHP will search for the fbsql client libraries in the default installation location for the platform. Users who installed FrontBase in a non standard directory should always specify the path to fbsql: --with-fbsql=/path/to/fbsql. This will force PHP to use the client libraries installed by FrontBase, avoiding any conflicts.

Konfigurace běhu

Chování těchto funkcí je ovlivněno nastavením parametrů v php.ini.

Tabulka 91. FrontBase configuration options

Name | Default | Changeable | Changelog
fbsql.allow_persistent | "1" | PHP_INI_SYSTEM | Available since PHP 4.2.0.
fbsql.generate_warnings | "0" | PHP_INI_SYSTEM | Available since PHP 4.0.6.
fbsql.autocommit | "1" | PHP_INI_SYSTEM | Available since PHP 4.0.6.
fbsql.max_persistent | "-1" | PHP_INI_SYSTEM | Available since PHP 4.0.6.
fbsql.max_links | "128" | PHP_INI_SYSTEM | Available since PHP 4.0.6.
fbsql.max_connections | "128" | PHP_INI_SYSTEM | Available since PHP 4.0.6.
fbsql.max_results | "128" | PHP_INI_SYSTEM | Available since PHP 4.0.6.
fbsql.batchSize | "1000" | PHP_INI_SYSTEM | Available since PHP 4.2.0. Removed in PHP 5.1.0.
fbsql.default_host | NULL | PHP_INI_SYSTEM | Available since PHP 4.0.6.
fbsql.default_user | "_SYSTEM" | PHP_INI_SYSTEM | Available since PHP 4.0.6.
fbsql.default_password | "" | PHP_INI_SYSTEM | Available since PHP 4.0.6.
fbsql.default_database | "" | PHP_INI_SYSTEM | Available since PHP 4.0.6.
fbsql.default_database_password | "" | PHP_INI_SYSTEM | Available since PHP 4.0.6.

Pro další detaily a definice konstant PHP_INI_*, viz dokumentace k ini_set().

Typy prostředků

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

FBSQL_ASSOC (integer)
FBSQL_NUM (integer)
FBSQL_BOTH (integer)
FBSQL_LOCK_DEFERRED (integer)
FBSQL_LOCK_OPTIMISTIC (integer)
FBSQL_LOCK_PESSIMISTIC (integer)
FBSQL_ISO_READ_UNCOMMITTED (integer)
FBSQL_ISO_READ_COMMITTED (integer)
FBSQL_ISO_REPEATABLE_READ (integer)
FBSQL_ISO_SERIALIZABLE (integer)
FBSQL_ISO_VERSIONED (integer)
FBSQL_UNKNOWN (integer)
FBSQL_STOPPED (integer)
FBSQL_STARTING (integer)
FBSQL_RUNNING (integer)
FBSQL_STOPPING (integer)
FBSQL_NOEXEC (integer)
FBSQL_LOB_DIRECT (integer)
FBSQL_LOB_HANDLE (integer)

Obsah

fbsql_affected_rows — Get number of affected rows in previous FrontBase operation
fbsql_autocommit — Enable or disable autocommit
fbsql_blob_size — Get the size of a BLOB
fbsql_change_user — Change logged in user of the active connection
fbsql_clob_size — Get the size of a CLOB
fbsql_close — Close FrontBase connection
fbsql_commit — Commits a transaction to the database
fbsql_connect — Open a connection to a FrontBase Server
fbsql_create_blob — Create a BLOB
fbsql_create_clob — Create a CLOB
fbsql_create_db — Create a FrontBase database
fbsql_data_seek — Move internal result pointer
fbsql_database_password — Sets or retrieves the password for a FrontBase database
fbsql_database — Get or set the database name used with a connection
fbsql_db_query — Send a FrontBase query
fbsql_db_status — Get the status for a given database
fbsql_drop_db — Drop (delete) a FrontBase database
fbsql_errno — Returns the error number from previous operation
fbsql_error — Returns the error message from previous operation
fbsql_fetch_array — Fetch a result row as an associative array, a numeric array, or both
fbsql_fetch_assoc — Fetch a result row as an associative array
fbsql_fetch_field — Get column information from a result and return as an object
fbsql_fetch_lengths — Get the length of each output in a result
fbsql_fetch_object — Fetch a result row as an object
fbsql_fetch_row — Get a result row as an enumerated array
fbsql_field_flags — Get the flags associated with the specified field in a result
fbsql_field_len — Returns the length of the specified field
fbsql_field_name — Get the name of the specified field in a result
fbsql_field_seek — Set result pointer to a specified field offset
fbsql_field_table — Get name of the table the specified field is in
fbsql_field_type — Get the type of the specified field in a result
fbsql_free_result — Free result memory
fbsql_get_autostart_info
fbsql_hostname — Get or set the host name used with a connection
fbsql_insert_id — Get the id generated from the previous INSERT operation
fbsql_list_dbs — List databases available on a FrontBase server
fbsql_list_fields — List FrontBase result fields
fbsql_list_tables — List tables in a FrontBase database
fbsql_next_result — Move the internal result pointer to the next result
fbsql_num_fields — Get number of fields in result
fbsql_num_rows — Get number of rows in result
fbsql_password — Get or set the user password used with a connection
fbsql_pconnect — Open a persistent connection to a FrontBase Server
fbsql_query — Send a FrontBase query
fbsql_read_blob — Read a BLOB from the database
fbsql_read_clob — Read a CLOB from the database
fbsql_result — Get result data
fbsql_rollback — Rollback a transaction to the database
fbsql_rows_fetched — Get the number of rows affected by the last statement
fbsql_select_db — Select a FrontBase database
fbsql_set_characterset — Change input/output character set
fbsql_set_lob_mode — Set the LOB retrieve mode for a FrontBase result set
fbsql_set_password — Change the password for a given user
fbsql_set_transaction — Set the transaction locking and isolation
fbsql_start_db — Start a database on local or remote server
fbsql_stop_db — Stop a database on local or remote server
fbsql_table_name — Get table name of field
fbsql_tablename — Alias pro of fbsql_table_name()
fbsql_username — Get or set the username for the connection
fbsql_warnings — Enable or disable FrontBase warnings
Předcházející | Nahoru | Další
fribidi_log2vis | Domů | fbsql_affected_rows


fbsql_affected_rows

(PHP 4 >= 4.0.6, PHP 5)

fbsql_affected_rows — Get number of affected rows in previous FrontBase operation

Popis

int fbsql_affected_rows ( [resource $link_identifier] )

fbsql_affected_rows() returns the number of rows affected by the last INSERT, UPDATE or DELETE query associated with link_identifier.

Poznámka: If you are using transactions, you need to call fbsql_affected_rows() after your INSERT, UPDATE, or DELETE query, not after the commit.

If the last query was a DELETE query with no WHERE clause, all of the records will have been deleted from the table but this function will return zero.

Poznámka: When using UPDATE, FrontBase will not update columns where the new value is the same as the old value. This creates the possibility that fbsql_affected_rows() may not actually equal the number of rows matched, only the number of rows that were literally affected by the query.

Seznam parametrů

link_identifier

A FrontBase link identifier returned by fbsql_connect() or fbsql_pconnect().

If optional and not specified, the function will try to find an open link to the FrontBase server and if no such link is found it will try to create one as if fbsql_connect() was called with no arguments

Návratové hodnoty

If the last query failed, this function will return -1.

Viz také

fbsql_num_rows()

Předcházející | Nahoru | Další
XLVI. FrontBase Functions | Domů | fbsql_autocommit


fbsql_autocommit

(PHP 4 >= 4.0.6, PHP 5)

fbsql_autocommit — Enable or disable autocommit

Popis

bool fbsql_autocommit ( resource $link_identifier [, bool $OnOff] )

Returns the current autocommit status.

Seznam parametrů

link_identifier

A FrontBase link identifier returned by fbsql_connect() or fbsql_pconnect().

If optional and not specified, the function will try to find an open link to the FrontBase server and if no such link is found it will try to create one as if fbsql_connect() was called with no arguments

OnOff

If this optional parameter is given the auto commit status will be changed.

With OnOff set to TRUE each statement will be committed automatically, if no errors was found.

With OnOff set to FALSE the user must commit or rollback the transaction using either fbsql_commit() or fbsql_rollback().

Návratové hodnoty

Returns the current autocommit status, as a boolean.

Viz také

fbsql_commit()
fbsql_rollback()

Předcházející | Nahoru | Další
fbsql_affected_rows | Domů | fbsql_blob_size


fbsql_blob_size

(PHP 4 >= 4.2.0, PHP 5)

fbsql_blob_size — Get the size of a BLOB

Popis

int fbsql_blob_size ( string $blob_handle [, resource $link_identifier] )

Returns the size of the given BLOB.

Seznam parametrů

blob_handle

A BLOB handle, returned by fbsql_create_blob().

link_identifier

A FrontBase link identifier returned by fbsql_connect() or fbsql_pconnect().

If optional and not specified, the function will try to find an open link to the FrontBase server and if no such link is found it will try to create one as if fbsql_connect() was called with no arguments

Návratové hodnoty

Returns the BLOB size as an integer, or FALSE on error.

Viz také

fbsql_clob_size()

Předcházející | Nahoru | Další
fbsql_autocommit | Domů | fbsql_change_user


fbsql_change_user

(PHP 4 >= 4.0.6, PHP 5)

fbsql_change_user — Change logged in user of the active connection

Popis

bool fbsql_change_user ( string $user, string $password [, string $database [, resource $link_identifier]] )

fbsql_change_user() changes the logged in user of the specified connection. If the new user and password authorization fails, the current connected user stays active.

Seznam parametrů

user

The new user name.

password

The new user password.

database

If specified, this will be the default or current database after the user has been changed.

link_identifier

A FrontBase link identifier returned by fbsql_connect() or fbsql_pconnect().

If optional and not specified, the function will try to find an open link to the FrontBase server and if no such link is found it will try to create one as if fbsql_connect() was called with no arguments

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
fbsql_blob_size | Domů | fbsql_clob_size


fbsql_clob_size

(PHP 4 >= 4.2.0, PHP 5)

fbsql_clob_size — Get the size of a CLOB

Popis

int fbsql_clob_size ( string $clob_handle [, resource $link_identifier] )

Returns the size of the given CLOB.

Seznam parametrů

clob_handle

A CLOB handle, returned by fbsql_create_clob().

link_identifier

A FrontBase link identifier returned by fbsql_connect() or fbsql_pconnect().

If optional and not specified, the function will try to find an open link to the FrontBase server and if no such link is found it will try to create one as if fbsql_connect() was called with no arguments

Návratové hodnoty

Returns the CLOB size as an integer, or FALSE on error.

Viz také

fbsql_blob_size()

Předcházející | Nahoru | Další
fbsql_change_user | Domů | fbsql_close


fbsql_close

(PHP 4 >= 4.0.6, PHP 5)

fbsql_close — Close FrontBase connection

Popis

bool fbsql_close ( [resource $link_identifier] )

Closes the connection to the FrontBase server that's associated with the specified link identifier.

Using fbsql_close() isn't usually necessary, as non-persistent open links are automatically closed at the end of the script's execution.

Seznam parametrů

link_identifier

A FrontBase link identifier returned by fbsql_connect() or fbsql_pconnect().

If optional and not specified, the function will try to find an open link to the FrontBase server and if no such link is found it will try to create one as if fbsql_connect() was called with no arguments

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 548. fbsql_close() example

<?php
$link = fbsql_connect("localhost", "_SYSTEM", "secret")
    or die("Could not connect");
echo "Connected successfully";
fbsql_close($link);
?>

Viz také

fbsql_connect()
fbsql_pconnect()

Předcházející | Nahoru | Další
fbsql_clob_size | Domů | fbsql_commit


fbsql_commit

(PHP 4 >= 4.0.6, PHP 5)

fbsql_commit — Commits a transaction to the database

Popis

bool fbsql_commit ( [resource $link_identifier] )

Ends the current transaction by writing all inserts, updates and deletes to the disk and unlocking all row and table locks held by the transaction. This command is only needed if autocommit is set to false.

Seznam parametrů

link_identifier

A FrontBase link identifier returned by fbsql_connect() or fbsql_pconnect().

If optional and not specified, the function will try to find an open link to the FrontBase server and if no such link is found it will try to create one as if fbsql_connect() was called with no arguments

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

fbsql_autocommit()
fbsql_rollback()

Předcházející | Nahoru | Další
fbsql_close | Domů | fbsql_connect


fbsql_connect

(PHP 4 >= 4.0.6, PHP 5)

fbsql_connect — Open a connection to a FrontBase Server

Popis

resource fbsql_connect ( [string $hostname [, string $username [, string $password]]] )

fbsql_connect() establishes a connection to a FrontBase server.

If a second call is made to fbsql_connect() with the same arguments, no new link will be established, but instead, the link identifier of the already opened link will be returned.

The link to the server will be closed as soon as the execution of the script ends, unless it's closed earlier by explicitly calling fbsql_close().

Seznam parametrů

hostname

The server host name. Defaults to 'NULL'.

username

The user name for the connection. Defaults to _SYSTEM.

password

The password for the connection. Defaults to the empty string.

Návratové hodnoty

Returns a positive FrontBase link identifier on success, or FALSE on errors.

Příklady

Příklad 549. fbsql_connect() example

<?php

$link = fbsql_connect("localhost", "_SYSTEM", "secret")
    or die("Could not connect");
echo "Connected successfully";
fbsql_close($link);

?>

Viz také

fbsql_pconnect()
fbsql_close()

Předcházející | Nahoru | Další
fbsql_commit | Domů | fbsql_create_blob


fbsql_create_blob

(PHP 4 >= 4.2.0, PHP 5)

fbsql_create_blob — Create a BLOB

Popis

string fbsql_create_blob ( string $blob_data [, resource $link_identifier] )

Creates a BLOB from the given data.

Seznam parametrů

blob_data

The BLOB data.

link_identifier

A FrontBase link identifier returned by fbsql_connect() or fbsql_pconnect().

If optional and not specified, the function will try to find an open link to the FrontBase server and if no such link is found it will try to create one as if fbsql_connect() was called with no arguments

Návratové hodnoty

Returns a resource handle to the newly created BLOB, which can be used with insert and update commands to store the BLOB in the database.

Příklady

Příklad 550. fbsql_create_blob() example

<?php
$link = fbsql_pconnect("localhost", "_SYSTEM", "secret")
    or die("Could not connect");
$filename = "blobfile.bin";
$fp = fopen($filename, "rb");
$blobdata = fread($fp, filesize($filename));
fclose($fp);

$blobHandle = fbsql_create_blob($blobdata, $link);

$sql = "INSERT INTO BLOB_TABLE (BLOB_COLUMN) VALUES ($blobHandle);";
$rs = fbsql_query($sql, $link);
?>

Viz také

fbsql_create_clob()
fbsql_read_blob()
fbsql_read_clob()
fbsql_set_lob_mode()

Předcházející | Nahoru | Další
fbsql_connect | Domů | fbsql_create_clob


fbsql_create_clob

(PHP 4 >= 4.2.0, PHP 5)

fbsql_create_clob — Create a CLOB

Popis

string fbsql_create_clob ( string $clob_data [, resource $link_identifier] )

Creates a CLOB from the given data.

Seznam parametrů

clob_data

The CLOB data.

link_identifier

A FrontBase link identifier returned by fbsql_connect() or fbsql_pconnect().

If optional and not specified, the function will try to find an open link to the FrontBase server and if no such link is found it will try to create one as if fbsql_connect() was called with no arguments

Návratové hodnoty

Returns a resource handle to the newly created CLOB, which can be used with insert and update commands to store the CLOB in the database.

Příklady

Příklad 551. fbsql_create_clob() example

<?php
$link = fbsql_pconnect("localhost", "_SYSTEM", "secret")
    or die("Could not connect");
$filename = "clob_file.txt";
$fp = fopen($filename, "rb");
$clobdata = fread($fp, filesize($filename));
fclose($fp);

$clobHandle = fbsql_create_clob($clobdata, $link);

$sql = "INSERT INTO CLOB_TABLE (CLOB_COLUMN) VALUES ($clobHandle);";
$rs = fbsql_query($sql, $link);
?>

Viz také

fbsql_create_blob()
fbsql_read_blob()
fbsql_read_clob()
fbsql_set_lob_mode()

Předcházející | Nahoru | Další
fbsql_create_blob | Domů | fbsql_create_db


fbsql_create_db

(PHP 4 >= 4.0.6, PHP 5)

fbsql_create_db — Create a FrontBase database

Popis

bool fbsql_create_db ( string $database_name [, resource $link_identifier [, string $database_options]] )

Attempts to create a new database on the specied server.

Seznam parametrů

database_name

The database name, as a string.

link_identifier

A FrontBase link identifier returned by fbsql_connect() or fbsql_pconnect().

If optional and not specified, the function will try to find an open link to the FrontBase server and if no such link is found it will try to create one as if fbsql_connect() was called with no arguments

database_options

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 552. fbsql_create_db() example

<?php
$link = fbsql_pconnect("localhost", "_SYSTEM", "secret")
    or die("Could not connect");
if (fbsql_create_db("my_db")) {
    echo "Database created successfully\n";
} else {
    printf("Error creating database: %s\n", fbsql_error());
}
?>

Viz také

fbsql_drop_db()

Předcházející | Nahoru | Další
fbsql_create_clob | Domů | fbsql_data_seek


fbsql_data_seek

(PHP 4 >= 4.0.6, PHP 5)

fbsql_data_seek — Move internal result pointer

Popis

bool fbsql_data_seek ( resource $result, int $row_number )

Moves the internal row pointer of the FrontBase result associated with the specified result identifier to point to the specified row number.

The next call to fbsql_fetch_row() would return that row.

Seznam parametrů

result

A result identifier returned by fbsql_query() or fbsql_db_query().

row_number

The row number. Starts at 0.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 553. fbsql_data_seek() example

<?php
$link = fbsql_pconnect("localhost", "_SYSTEM", "secret")
    or die("Could not connect");

fbsql_select_db("samp_db")
    or die("Could not select database");

$query = "SELECT last_name, first_name FROM friends;";
$result = fbsql_query($query)
    or die("Query failed");

// fetch rows in reverse order

for ($i = fbsql_num_rows($result) - 1; $i >=0; $i--) {
    if (!fbsql_data_seek($result, $i)) {
        printf("Cannot seek to row %d\n", $i);
        continue;
    }

    if (!($row = fbsql_fetch_object($result)))
        continue;

    echo $row->last_name . $row->first_name . "<br />\n";
}

fbsql_free_result($result);
?>

Předcházející | Nahoru | Další
fbsql_create_db | Domů | fbsql_database_password


fbsql_database_password

(PHP 4 >= 4.0.6, PHP 5)

fbsql_database_password — Sets or retrieves the password for a FrontBase database

Popis

string fbsql_database_password ( resource $link_identifier [, string $database_password] )

Sets and retrieves the database password used by the connection. If a database is protected by a database password, the user must call this function before calling fbsql_select_db().

If no link is open, the function will try to establish a link as if fbsql_connect() was called, and use it.

This function does not change the database password in the database nor can it be used to retrieve the database password for a database.

Seznam parametrů

link_identifier

A FrontBase link identifier returned by fbsql_connect() or fbsql_pconnect().

If optional and not specified, the function will try to find an open link to the FrontBase server and if no such link is found it will try to create one as if fbsql_connect() was called with no arguments

database_password

The database password, as a string. If given, the function sets the database password for the specified link identifier.

Návratové hodnoty

Returns the database password associated with the link identifier.

Příklady

Příklad 554. fbsql_create_clob() example

<?php
$link = fbsql_pconnect("localhost", "_SYSTEM", "secret")
    or die("Could not connect");
fbsql_database_password($link, "secret db password");
fbsql_select_db($database, $link);
?>

Viz také

fbsql_connect()
fbsql_pconnect()
fbsql_select_db()

Předcházející | Nahoru | Další
fbsql_data_seek | Domů | fbsql_database


fbsql_database

(PHP 4 >= 4.0.6, PHP 5)

fbsql_database — Get or set the database name used with a connection

Popis

string fbsql_database ( resource $link_identifier [, string $database] )

Get or set the database name used with the connection.

Seznam parametrů

link_identifier

A FrontBase link identifier returned by fbsql_connect() or fbsql_pconnect().

If optional and not specified, the function will try to find an open link to the FrontBase server and if no such link is found it will try to create one as if fbsql_connect() was called with no arguments

database

The database name. If given, the default database of the connexion will be changed to database.

Návratové hodnoty

Returns the name of the database used with this connection.

Předcházející | Nahoru | Další
fbsql_database_password | Domů | fbsql_db_query


fbsql_db_query

(PHP 4 >= 4.0.6, PHP 5)

fbsql_db_query — Send a FrontBase query

Popis

resource fbsql_db_query ( string $database, string $query [, resource $link_identifier] )

Selects a database and executes a query on it.

Seznam parametrů

database

The database to be selected.

query

The SQL query to be executed.

Poznámka: The query string shall always end with a semicolon.

link_identifier

A FrontBase link identifier returned by fbsql_connect() or fbsql_pconnect().

If optional and not specified, the function will try to find an open link to the FrontBase server and if no such link is found it will try to create one as if fbsql_connect() was called with no arguments

Návratové hodnoty

Returns a positive FrontBase result identifier to the query result, or FALSE on error.

Viz také

fbsql_query()
fbsql_connect()

Předcházející | Nahoru | Další
fbsql_database | Domů | fbsql_db_status


fbsql_db_status

(PHP 4 >= 4.0.7, PHP 5)

fbsql_db_status — Get the status for a given database

Popis

int fbsql_db_status ( string $database_name [, resource $link_identifier] )

Gets the current status of the specified database.

Seznam parametrů

database_name

The database name.

link_identifier

A FrontBase link identifier returned by fbsql_connect() or fbsql_pconnect().

If optional and not specified, the function will try to find an open link to the FrontBase server and if no such link is found it will try to create one as if fbsql_connect() was called with no arguments

Návratové hodnoty

Returns an integer value with the current status. This can be one of the following constants:

  • FALSE - The exec handler for the host was invalid. This error will occur when the link_identifier connects directly to a database by using a port number. FBExec can be available on the server but no connection has been made for it.
  • FBSQL_UNKNOWN - The Status is unknown.
  • FBSQL_STOPPED - The database is not running. Use fbsql_start_db() to start the database.
  • FBSQL_STARTING - The database is starting.
  • FBSQL_RUNNING - The database is running and can be used to perform SQL operations.
  • FBSQL_STOPPING - The database is stopping.
  • FBSQL_NOEXEC - FBExec is not running on the server and it is not possible to get the status of the database.

Viz také

fbsql_start_db()
fbsql_stop_db()

Předcházející | Nahoru | Další
fbsql_db_query | Domů | fbsql_drop_db


fbsql_drop_db

(PHP 4 >= 4.0.6, PHP 5)

fbsql_drop_db — Drop (delete) a FrontBase database

Popis

bool fbsql_drop_db ( string $database_name [, resource $link_identifier] )

fbsql_drop_db() attempts to drop (remove) an entire database from the server associated with the specified link identifier.

Seznam parametrů

database_name

The database name, as a string.

link_identifier

A FrontBase link identifier returned by fbsql_connect() or fbsql_pconnect().

If optional and not specified, the function will try to find an open link to the FrontBase server and if no such link is found it will try to create one as if fbsql_connect() was called with no arguments

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

fbsql_create_db()

Předcházející | Nahoru | Další
fbsql_db_status | Domů | fbsql_errno


fbsql_errno

(PHP 4 >= 4.0.6, PHP 5)

fbsql_errno — Returns the error number from previous operation

Popis

int fbsql_errno ( [resource $link_identifier] )

Returns the numerical value of the error message from previous FrontBase operation.

Errors coming back from the fbsql database backend don't issue warnings. Instead, use fbsql_errno() to retrieve the error code. Note that this function only returns the error code from the most recently executed fbsql function (not including fbsql_error() and fbsql_errno()), so if you want to use it, make sure you check the value before calling another fbsql function.

Seznam parametrů

link_identifier

A FrontBase link identifier returned by fbsql_connect() or fbsql_pconnect().

If optional and not specified, the function will try to find an open link to the FrontBase server and if no such link is found it will try to create one as if fbsql_connect() was called with no arguments

Návratové hodnoty

Returns the error number from the last fbsql function, or 0 (zero) if no error occurred.

Příklady

Příklad 555. fbsql_errno() Example

<?php
fbsql_connect("marliesle");
echo fbsql_errno() . ": " . fbsql_error() . "<br />";
fbsql_select_db("nonexistentdb");
echo fbsql_errno() . ": " . fbsql_error() . "<br />";
$conn = fbsql_query("SELECT * FROM nonexistenttable;");
echo fbsql_errno() . ": " . fbsql_error() . "<br />";
?>

Viz také

fbsql_error()
fbsql_warnings()

Předcházející | Nahoru | Další
fbsql_drop_db | Domů | fbsql_error


fbsql_error

(PHP 4 >= 4.0.6, PHP 5)

fbsql_error — Returns the error message from previous operation

Popis

string fbsql_error ( [resource $link_identifier] )

Returns the error message from previous FrontBase operation.

Errors coming back from the fbsql database backend don't issue warnings. Instead, use fbsql_error() to retrieve the error text. Note that this function only returns the error code from the most recently executed fbsql function (not including fbsql_error() and fbsql_errno()), so if you want to use it, make sure you check the value before calling another fbsql function.

Seznam parametrů

link_identifier

A FrontBase link identifier returned by fbsql_connect() or fbsql_pconnect().

If optional and not specified, the function will try to find an open link to the FrontBase server and if no such link is found it will try to create one as if fbsql_connect() was called with no arguments

Návratové hodnoty

Returns the error text from the last fbsql function, or '' (the empty string) if no error occurred.

Příklady

Příklad 556. fbsql_error() Example

<?php
fbsql_connect("marliesle");
echo fbsql_errno() . ": " . fbsql_error() . "<br />";
fbsql_select_db("nonexistentdb");
echo fbsql_errno() . ": " . fbsql_error() . "<br />";
$conn = fbsql_query("SELECT * FROM nonexistenttable;");
echo fbsql_errno() . ": " . fbsql_error() . "<br />";
?>

Viz také

fbsql_errno()
fbsql_warnings()

Předcházející | Nahoru | Další
fbsql_errno | Domů | fbsql_fetch_array


fbsql_fetch_array

(PHP 4 >= 4.0.6, PHP 5)

fbsql_fetch_array — Fetch a result row as an associative array, a numeric array, or both

Popis

array fbsql_fetch_array ( resource $result [, int $result_type] )

fbsql_fetch_array() is a combination of
fbsql_fetch_row() and
fbsql_fetch_assoc().

An important thing to note is that using fbsql_fetch_array() is NOT significantly slower than using fbsql_fetch_row(), while it provides a significant added value.

Seznam parametrů

result

A result identifier returned by fbsql_query() or fbsql_db_query().

result_type

A constant and can take the following values: FBSQL_ASSOC, FBSQL_NUM, or FBSQL_BOTH.

When using FBSQL_BOTH, in addition to storing the data in the numeric indices of the result array, it also stores the data in associative indices, using the field names as keys.

Návratové hodnoty

Returns an array that corresponds to the fetched row, or FALSE if there are no more rows.

If two or more columns of the result have the same field names, the last column will take precedence. To access the other column(s) of the same name, you must the numeric index of the column or make an alias for the column.

select t1.f1 as foo t2.f1 as bar from t1, t2

Příklady

Příklad 557. fbsql_fetch_array() example

<?php
fbsql_connect($host, $user, $password);
$result = fbsql_db_query("database", "select user_id, fullname from table");
while ($row = fbsql_fetch_array($result)) {
    echo "user_id: " . $row["user_id"] . "<br />\n";
    echo "user_id: " . $row[0] . "<br />\n";
    echo "fullname: " . $row["fullname"] . "<br />\n";
    echo "fullname: " . $row[1] . "<br />\n";
}
fbsql_free_result($result);
?>

Viz také

fbsql_fetch_row()
fbsql_fetch_assoc()
fbsql_fetch_object()

Předcházející | Nahoru | Další
fbsql_error | Domů | fbsql_fetch_assoc


fbsql_fetch_assoc

(PHP 4 >= 4.0.6, PHP 5)

fbsql_fetch_assoc — Fetch a result row as an associative array

Popis

array fbsql_fetch_assoc ( resource $result )

Calling fbsql_fetch_assoc() is equivalent to calling fbsql_fetch_array() with FBSQL_ASSOC as second parameter. It only returns an associative array.

This is the way fbsql_fetch_array() originally worked. If you need the numeric indices as well as the associative, use fbsql_fetch_array().

An important thing to note is that using fbsql_fetch_assoc() is NOT significantly slower than using fbsql_fetch_row(), while it provides a significant added value.

Seznam parametrů

result

A result identifier returned by fbsql_query() or fbsql_db_query().

Návratové hodnoty

Returns an associative array that corresponds to the fetched row, or FALSE if there are no more rows.

If two or more columns of the result have the same field names, the last column will take precedence. To access the other column(s) of the same name, you must use fbsql_fetch_array() and have it return the numeric indices as well.

Příklady

Příklad 558. fbsql_fetch_assoc() example

<?php
fbsql_connect($host, $user, $password);
$result = fbsql_db_query("database", "select * from table");
while ($row = fbsql_fetch_assoc($result)) {
    echo $row["user_id"];
    echo $row["fullname"];
}
fbsql_free_result($result);
?>

Viz také

fbsql_fetch_row()
fbsql_fetch_array()
fbsql_fetch_object()

Předcházející | Nahoru | Další
fbsql_fetch_array | Domů | fbsql_fetch_field


fbsql_fetch_field

(PHP 4 >= 4.0.6, PHP 5)

fbsql_fetch_field — Get column information from a result and return as an object

Popis

object fbsql_fetch_field ( resource $result [, int $field_offset] )

Used in order to obtain information about fields in a certain query result.

Seznam parametrů

result

A result identifier returned by fbsql_query() or fbsql_db_query().

field_offset

The numerical offset of the field. The field index starts at 0. If not specified, the next field that wasn't yet retrieved by fbsql_fetch_field() is retrieved.

Návratové hodnoty

Returns an object containing field information, or FALSE on errors.

The properties of the object are:

  • name - column name
  • table - name of the table the column belongs to
  • max_length - maximum length of the column
  • not_null - 1 if the column cannot be NULL
  • type - the type of the column

Příklady

Příklad 559. fbsql_fetch_field() example

<?php
fbsql_connect($host, $user, $password)
    or die("Could not connect");
$result = fbsql_db_query("database", "select * from table")
    or die("Query failed");
# get column metadata
$i = 0;
while ($i < fbsql_num_fields($result)) {
    echo "Information for column $i:<br />\n";
    $meta = fbsql_fetch_field($result);
    if (!$meta) {
        echo "No information available<br />\n";
    }
    echo "<pre>
max_length:   $meta->max_length
name:         $meta->name
not_null:     $meta->not_null
table:        $meta->table
type:         $meta->type
</pre>";
    $i++;
}
fbsql_free_result($result);
?>

Viz také

fbsql_field_seek()

Předcházející | Nahoru | Další
fbsql_fetch_assoc | Domů | fbsql_fetch_lengths


fbsql_fetch_lengths

(PHP 4 >= 4.0.6, PHP 5)

fbsql_fetch_lengths — Get the length of each output in a result

Popis

array fbsql_fetch_lengths ( resource $result )

Stores the lengths of each result column in the last row returned by
fbsql_fetch_row(),
fbsql_fetch_array() and
fbsql_fetch_object() in an array.

Seznam parametrů

result

A result identifier returned by fbsql_query() or fbsql_db_query().

Návratové hodnoty

Returns an array, starting at offset 0, that corresponds to the lengths of each field in the last row fetched by fbsql_fetch_row(), or FALSE on error.

Viz také

fbsql_fetch_row()

Předcházející | Nahoru | Další
fbsql_fetch_field | Domů | fbsql_fetch_object


fbsql_fetch_object

(PHP 4 >= 4.0.6, PHP 5)

fbsql_fetch_object — Fetch a result row as an object

Popis

object fbsql_fetch_object ( resource $result )

fbsql_fetch_object() is similar to fbsql_fetch_array(), with one difference - an object is returned, instead of an array. Indirectly, that means that you can only access the data by the field names, and not by their offsets (numbers are illegal property names).

Speed-wise, the function is identical to fbsql_fetch_array(), and almost as quick as fbsql_fetch_row() (the difference is insignificant).

Seznam parametrů

result

A result identifier returned by fbsql_query() or fbsql_db_query().

Návratové hodnoty

Returns an object with properties that correspond to the fetched row, or FALSE if there are no more rows.

Příklady

Příklad 560. fbsql_fetch_object() example

<?php
fbsql_connect($host, $user, $password);
$result = fbsql_db_query("database", "select * from table");
while ($row = fbsql_fetch_object($result)) {
    echo $row->user_id;
    echo $row->fullname;
}
fbsql_free_result($result);
?>

Viz také

fbsql_fetch_array()
fbsql_fetch_row()
fbsql_fetch_assoc()

Předcházející | Nahoru | Další
fbsql_fetch_lengths | Domů | fbsql_fetch_row


fbsql_fetch_row

(PHP 4 >= 4.0.6, PHP 5)

fbsql_fetch_row — Get a result row as an enumerated array

Popis

array fbsql_fetch_row ( resource $result )

fbsql_fetch_row() fetches one row of data from the result associated with the specified result identifier.

Subsequent call to fbsql_fetch_row() would return the next row in the result set, or FALSE if there are no more rows.

Seznam parametrů

result

A result identifier returned by fbsql_query() or fbsql_db_query().

Návratové hodnoty

Returns an array that corresponds to the fetched row where each result column is stored in an offset, starting at offset 0, or FALSE if there are no more rows.

Viz také

fbsql_fetch_array()
fbsql_fetch_assoc()
fbsql_fetch_object()
fbsql_data_seek()
fbsql_fetch_lengths()
fbsql_result()

Předcházející | Nahoru | Další
fbsql_fetch_object | Domů | fbsql_field_flags


fbsql_field_flags

(PHP 4 >= 4.0.6, PHP 5)

fbsql_field_flags — Get the flags associated with the specified field in a result

Popis

string fbsql_field_flags ( resource $result [, int $field_offset] )

Gets the flags associated with the specified field in a result.

Seznam parametrů

result

A result pointer returned by fbsql_list_fields().

field_offset

The numerical offset of the field. The field index starts at 0.

Návratové hodnoty

Returns the field flags of the specified field as a single word per flag separated by a single space, so that you can split the returned value using explode().

Předcházející | Nahoru | Další
fbsql_fetch_row | Domů | fbsql_field_len


fbsql_field_len

(PHP 4 >= 4.0.6, PHP 5)

fbsql_field_len — Returns the length of the specified field

Popis

int fbsql_field_len ( resource $result [, int $field_offset] )

Returns the length of the specified field.

Seznam parametrů

result

A result pointer returned by fbsql_list_fields().

field_offset

The numerical offset of the field. The field index starts at 0.

Návratové hodnoty

Returns the length of the specified field.

Předcházející | Nahoru | Další
fbsql_field_flags | Domů | fbsql_field_name


fbsql_field_name

(PHP 4 >= 4.0.6, PHP 5)

fbsql_field_name — Get the name of the specified field in a result

Popis

string fbsql_field_name ( resource $result [, int $field_index] )

Returns the name of the specified field index.

Seznam parametrů

result

A result pointer returned by fbsql_list_fields().

field_index

The numerical offset of the field. The field index starts at 0.

Návratové hodnoty

Returns the name as a string, or FALSE if the field doesn't exist.

Příklady

Příklad 561. fbsql_field_name() example

<?php
// The users table consists of three fields:
//   user_id
//   username
//   password.

$res = fbsql_db_query("users", "select * from users", $link);

echo fbsql_field_name($res, 0) . "\n";
echo fbsql_field_name($res, 2);
?>

Výše uvedený příklad vypíše:

user_id
password

Viz také

fbsql_field_type()

Předcházející | Nahoru | Další
fbsql_field_len | Domů | fbsql_field_seek


fbsql_field_seek

(PHP 4 >= 4.0.6, PHP 5)

fbsql_field_seek — Set result pointer to a specified field offset

Popis

bool fbsql_field_seek ( resource $result [, int $field_offset] )

Seeks to the specified field offset. If the next call to fbsql_fetch_field() doesn't include a field offset, the field offset specified in fbsql_field_seek() will be returned.

Seznam parametrů

result

A result identifier returned by fbsql_query() or fbsql_db_query().

field_offset

The numerical offset of the field. The field index starts at 0.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

fbsql_fetch_field()

Předcházející | Nahoru | Další
fbsql_field_name | Domů | fbsql_field_table


fbsql_field_table

(PHP 4 >= 4.0.6, PHP 5)

fbsql_field_table — Get name of the table the specified field is in

Popis

string fbsql_field_table ( resource $result [, int $field_offset] )

Returns the name of the table that the specified field is in.

Seznam parametrů

result

A result identifier returned by fbsql_query() or fbsql_db_query().

field_offset

The numerical offset of the field. The field index starts at 0.

Návratové hodnoty

Returns the name of the table, as a string.

Předcházející | Nahoru | Další
fbsql_field_seek | Domů | fbsql_field_type


fbsql_field_type

(PHP 4 >= 4.0.6, PHP 5)

fbsql_field_type — Get the type of the specified field in a result

Popis

string fbsql_field_type ( resource $result [, int $field_offset] )

fbsql_field_type() is similar to the fbsql_field_name() function, but the field type is returned instead.

Seznam parametrů

result

A result identifier returned by fbsql_query() or fbsql_db_query().

field_offset

The numerical offset of the field. The field index starts at 0.

Návratové hodnoty

Returns the field type, as a string.

This can be one of int, real, string, blob, and others as detailed in the » FrontBase documentation.

Příklady

Příklad 562. fbsql_field_type() example

<?php

fbsql_connect("localhost", "_SYSTEM", "");
fbsql_select_db("wisconsin");
$result = fbsql_query("SELECT * FROM onek;");
$fields = fbsql_num_fields($result);
$rows   = fbsql_num_rows($result);
$i = 0;
$table = fbsql_field_table($result, $i);
echo "Your '" . $table . "' table has " . $fields . " fields and " . $rows . " records <br />";
echo "The table has the following fields <br />";
while ($i < $fields) {
    $type  = fbsql_field_type($result, $i);
    $name  = fbsql_field_name($result, $i);
    $len   = fbsql_field_len($result, $i);
    $flags = fbsql_field_flags($result, $i);
    echo $type . " " . $name . " " . $len . " " . $flags . "<br />";
    $i++;
}
fbsql_close();

?>

Viz také

fbsql_field_name()

Předcházející | Nahoru | Další
fbsql_field_table | Domů | fbsql_free_result


fbsql_free_result

(PHP 4 >= 4.0.6, PHP 5)

fbsql_free_result — Free result memory

Popis

bool fbsql_free_result ( resource $result )

Frees all memory associated with the given result identifier.

fbsql_free_result() only needs to be called if you are concerned about how much memory is being used for queries that return large result sets. All associated result memory is automatically freed at the end of the script's execution.

Seznam parametrů

result

A result identifier returned by fbsql_query() or fbsql_db_query().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
fbsql_field_type | Domů | fbsql_get_autostart_info


fbsql_get_autostart_info

(PHP 4 >= 4.0.7, PHP 5)

fbsql_get_autostart_info

Popis

array fbsql_get_autostart_info ( [resource $link_identifier] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

link_identifier

A FrontBase link identifier returned by fbsql_connect() or fbsql_pconnect().

If optional and not specified, the function will try to find an open link to the FrontBase server and if no such link is found it will try to create one as if fbsql_connect() was called with no arguments

Předcházející | Nahoru | Další
fbsql_free_result | Domů | fbsql_hostname


fbsql_hostname

(PHP 4 >= 4.0.6, PHP 5)

fbsql_hostname — Get or set the host name used with a connection

Popis

string fbsql_hostname ( resource $link_identifier [, string $host_name] )

Gets or sets the host name used with a connection.

Seznam parametrů

link_identifier

A FrontBase link identifier returned by fbsql_connect() or fbsql_pconnect().

If optional and not specified, the function will try to find an open link to the FrontBase server and if no such link is found it will try to create one as if fbsql_connect() was called with no arguments

host_name

If provided, this will be the new connection host name.

Návratové hodnoty

Returns the current host name used for the connection.

Viz také

fbsql_username()
fbsql_password()

Předcházející | Nahoru | Další
fbsql_get_autostart_info | Domů | fbsql_insert_id


fbsql_insert_id

(PHP 4 >= 4.0.6, PHP 5)

fbsql_insert_id — Get the id generated from the previous INSERT operation

Popis

int fbsql_insert_id ( [resource $link_identifier] )

Gets the id generated from the previous INSERT operation which created a DEFAULT UNIQUE value.

Poznámka: The value of the FrontBase SQL function fbsql_insert_id() always contains the most recently generated DEFAULT UNIQUE value, and is not reset between queries.

Seznam parametrů

link_identifier

A FrontBase link identifier returned by fbsql_connect() or fbsql_pconnect().

If optional and not specified, the function will try to find an open link to the FrontBase server and if no such link is found it will try to create one as if fbsql_connect() was called with no arguments

Návratové hodnoty

Returns the ID generated from the previous INSERT query, or 0 if the previous query does not generate an DEFAULT UNIQUE value.

If you need to save the value for later, be sure to call this function immediately after the query that generates the value.

Viz také

fbsql_affected_rows()

Předcházející | Nahoru | Další
fbsql_hostname | Domů | fbsql_list_dbs


fbsql_list_dbs

(PHP 4 >= 4.0.6, PHP 5)

fbsql_list_dbs — List databases available on a FrontBase server

Popis

resource fbsql_list_dbs ( [resource $link_identifier] )

Return a result pointer containing the databases available from the current fbsql daemon. Use the fbsql_tablename() to traverse this result pointer.

Seznam parametrů

link_identifier

A FrontBase link identifier returned by fbsql_connect() or fbsql_pconnect().

If optional and not specified, the function will try to find an open link to the FrontBase server and if no such link is found it will try to create one as if fbsql_connect() was called with no arguments

Návratové hodnoty

Returns a result pointer or FALSE on error.

Příklady

Příklad 563. fbsql_list_dbs() example

$link = fbsql_connect('localhost', 'myname', 'secret');
$db_list = fbsql_list_dbs($link);

while ($row = fbsql_fetch_object($db_list)) {
    echo $row->Database . "\n";
}

Výše uvedený příklad vypíše něco jako:

database1
database2
database3
...

Poznámka: The above code would just as easily work with fbsql_fetch_row() or other similar functions.

Viz také

fbsql_list_fields()
fbsql_list_tables()

Předcházející | Nahoru | Další
fbsql_insert_id | Domů | fbsql_list_fields


fbsql_list_fields

(PHP 4 >= 4.0.6, PHP 5)

fbsql_list_fields — List FrontBase result fields

Popis

resource fbsql_list_fields ( string $database_name, string $table_name [, resource $link_identifier] )

Retrieves information about the given table.

Seznam parametrů

database_name

The database name.

table_name

The table name.

link_identifier

A FrontBase link identifier returned by fbsql_connect() or fbsql_pconnect().

If optional and not specified, the function will try to find an open link to the FrontBase server and if no such link is found it will try to create one as if fbsql_connect() was called with no arguments

Návratové hodnoty

Returns a result pointer which can be used with the fbsql_field_xxx functions, or FALSE on error.

Errors/Exceptions

A string describing the error will be placed in $phperrmsg, and unless the function was called as @fbsql() then this error string will also be printed out.

Příklady

Příklad 564. fbsql_list_fields() example

<?php
$link = fbsql_connect('localhost', 'myname', 'secret');

$fields = fbsql_list_fields("database1", "table1", $link);
$columns = fbsql_num_fields($fields);

for ($i = 0; $i < $columns; $i++) {
    echo fbsql_field_name($fields, $i) . "\n";;
}
?>

Výše uvedený příklad vypíše něco jako:

field1
field2
field3
...

Viz také

fbsql_field_len()
fbsql_field_name()
fbsql_field_type()
fbsql_field_flags()

Předcházející | Nahoru | Další
fbsql_list_dbs | Domů | fbsql_list_tables


fbsql_list_tables

(PHP 4 >= 4.0.6, PHP 5)

fbsql_list_tables — List tables in a FrontBase database

Popis

resource fbsql_list_tables ( string $database [, resource $link_identifier] )

Returns a result pointer describing the database.

Seznam parametrů

database

The database name.

link_identifier

A FrontBase link identifier returned by fbsql_connect() or fbsql_pconnect().

If optional and not specified, the function will try to find an open link to the FrontBase server and if no such link is found it will try to create one as if fbsql_connect() was called with no arguments

Návratové hodnoty

Returns a result pointer which can be used with the fbsql_tablename() function to read the actual table names, or FALSE on error.

Viz také

fbsql_list_fields()
fbsql_list_dbs()

Předcházející | Nahoru | Další
fbsql_list_fields | Domů | fbsql_next_result


fbsql_next_result

(PHP 4 >= 4.0.6, PHP 5)

fbsql_next_result — Move the internal result pointer to the next result

Popis

bool fbsql_next_result ( resource $result )

When sending more than one SQL statement to the server or executing a stored procedure with multiple results will cause the server to return multiple result sets. This function will test for additional results available form the server. If an additional result set exists it will free the existing result set and prepare to fetch the words from the new result set.

Seznam parametrů

result

A result identifier returned by fbsql_query() or fbsql_db_query().

Návratové hodnoty

Returns TRUE if an additional result set was available or FALSE otherwise.

Příklady

Příklad 565. fbsql_next_result() example

<?php
$link = fbsql_connect("localhost", "_SYSTEM", "secret");
fbsql_select_db("MyDB", $link);
$SQL = "Select * from table1; select * from table2;";
$rs = fbsql_query($SQL, $link);
do {
    while ($row = fbsql_fetch_row($rs)) {
    }
} while (fbsql_next_result($rs));
fbsql_free_result($rs);
fbsql_close($link);
?>

Předcházející | Nahoru | Další
fbsql_list_tables | Domů | fbsql_num_fields


fbsql_num_fields

(PHP 4 >= 4.0.6, PHP 5)

fbsql_num_fields — Get number of fields in result

Popis

int fbsql_num_fields ( resource $result )

Returns the number of fields in the given result set.

Seznam parametrů

result

A result identifier returned by fbsql_query() or fbsql_db_query().

Návratové hodnoty

Returns the number of fields, as an integer.

Viz také

fbsql_db_query()
fbsql_query()
fbsql_fetch_field()
fbsql_num_rows()

Předcházející | Nahoru | Další
fbsql_next_result | Domů | fbsql_num_rows


fbsql_num_rows

(PHP 4 >= 4.0.6, PHP 5)

fbsql_num_rows — Get number of rows in result

Popis

int fbsql_num_rows ( resource $result )

Gets the number of rows in the given result set.

This function is only valid for SELECT statements. To retrieve the number of rows returned from a INSERT, UPDATE or DELETE query, use fbsql_affected_rows().

Seznam parametrů

result

A result identifier returned by fbsql_query() or fbsql_db_query().

Návratové hodnoty

Returns the number of rows returned by the last SELECT statement.

Příklady

Příklad 566. fbsql_num_rows() example

<?php

$link = fbsql_connect("localhost", "username", "password");
fbsql_select_db("database", $link);

$result = fbsql_query("SELECT * FROM table1;", $link);
$num_rows = fbsql_num_rows($result);

echo "$num_rows Rows\n";

?>

Viz také

fbsql_affected_rows()
fbsql_connect()
fbsql_select_db()
fbsql_query()

Předcházející | Nahoru | Další
fbsql_num_fields | Domů | fbsql_password


fbsql_password

(PHP 4 >= 4.0.6, PHP 5)

fbsql_password — Get or set the user password used with a connection

Popis

string fbsql_password ( resource $link_identifier [, string $password] )

Get or set the user password used with a connection.

Seznam parametrů

link_identifier

A FrontBase link identifier returned by fbsql_connect() or fbsql_pconnect().

If optional and not specified, the function will try to find an open link to the FrontBase server and if no such link is found it will try to create one as if fbsql_connect() was called with no arguments

password

If provided, this will be the new connection password.

Návratové hodnoty

Returns the current password used for the connection.

Viz také

fbsql_username()
fbsql_hostname()

Předcházející | Nahoru | Další
fbsql_num_rows | Domů | fbsql_pconnect


fbsql_pconnect

(PHP 4 >= 4.0.6, PHP 5)

fbsql_pconnect — Open a persistent connection to a FrontBase Server

Popis

resource fbsql_pconnect ( [string $hostname [, string $username [, string $password]]] )

Establishes a persistent connection to a FrontBase server.

To set the server port number, use fbsql_select_db().

fbsql_pconnect() acts very much like fbsql_connect() with two major differences:

First, when connecting, the function would first try to find a (persistent) link that's already open with the same host, username and password. If one is found, an identifier for it will be returned instead of opening a new connection.

Second, the connection to the SQL server will not be closed when the execution of the script ends. Instead, the link will remain open for future use.

This type of links is therefore called 'persistent'.

Seznam parametrů

hostname

The server host name. Defaults to localhost.

username

The user name for the connection. Defaults to _SYSTEM.

password

The password for the connection. Defaults to the empty string.

Návratové hodnoty

Returns a positive FrontBase persistent link identifier on success, or FALSE on error.

Viz také

fbsql_connect()

Předcházející | Nahoru | Další
fbsql_password | Domů | fbsql_query


fbsql_query

(PHP 4 >= 4.0.6, PHP 5)

fbsql_query — Send a FrontBase query

Popis

resource fbsql_query ( string $query [, resource $link_identifier [, int $batch_size]] )

Sends a query to the currently active database on the server.

If the query succeeds, you can call fbsql_num_rows() to find out how many rows were returned for a SELECT statement or fbsql_affected_rows() to find out how many rows were affected by a DELETE, INSERT, REPLACE, or UPDATE statement.

Seznam parametrů

query

The SQL query to be executed.

Poznámka: The query string shall always end with a semicolon.

link_identifier

A FrontBase link identifier returned by fbsql_connect() or fbsql_pconnect().

If optional and not specified, the function will try to find an open link to the FrontBase server and if no such link is found it will try to create one as if fbsql_connect() was called with no arguments

batch_size

Návratové hodnoty

fbsql_query() returns TRUE (non-zero) or FALSE to indicate whether or not the query succeeded. A return value of TRUE means that the query was legal and could be executed by the server. It does not indicate anything about the number of rows affected or returned. It is perfectly possible for a query to succeed but affect no rows or return no rows.

For SELECT statements, fbsql_query() returns a new result identifier that you can pass to fbsql_result().

fbsql_query() will also fail and return FALSE if you don't have permission to access the table(s) referenced by the query.

Příklady

The following query is syntactically invalid, so fbsql_query() fails and returns FALSE:

Příklad 567. fbsql_query() example

<?php
$result = fbsql_query("SELECT * WHERE 1=1")
    or die ("Invalid query");
?>

The following query is semantically invalid if my_col is not a column in the table my_tbl, so fbsql_query() fails and returns FALSE:

Příklad 568. fbsql_query() example

<?php
$result = fbsql_query ("SELECT my_col FROM my_tbl;")
    or die ("Invalid query");
?>

Viz také

fbsql_affected_rows()
fbsql_db_query()
fbsql_free_result()
fbsql_result()
fbsql_select_db()
fbsql_connect()

Předcházející | Nahoru | Další
fbsql_pconnect | Domů | fbsql_read_blob


fbsql_read_blob

(PHP 4 >= 4.2.0, PHP 5)

fbsql_read_blob — Read a BLOB from the database

Popis

string fbsql_read_blob ( string $blob_handle [, resource $link_identifier] )

Reads BLOB data from the database.

If a select statement contains BLOB and/or CLOB columns FrontBase will return the data directly when data is fetched. This default behavior can be changed with fbsql_set_lob_mode() so the fetch functions will return handles to BLOB and CLOB data. If a handle is fetched a user must call fbsql_read_blob() to get the actual BLOB data from the database.

Seznam parametrů

blob_handle

A BLOB handle, returned by fbsql_create_blob().

link_identifier

A FrontBase link identifier returned by fbsql_connect() or fbsql_pconnect().

If optional and not specified, the function will try to find an open link to the FrontBase server and if no such link is found it will try to create one as if fbsql_connect() was called with no arguments

Návratové hodnoty

Returns a string containing the specified BLOB data.

Příklady

Příklad 569. fbsql_read_blob() example

<?php
$link = fbsql_pconnect("localhost", "_SYSTEM", "secret")
    or die("Could not connect");
$sql = "SELECT BLOB_COLUMN FROM BLOB_TABLE;";
$rs = fbsql_query($sql, $link);
$row_data = fbsql_fetch_row($rs);
// $row_data[0] will now contain the blob data for the first row
fbsql_free_result($rs);

$rs = fbsql_query($sql, $link);
fbsql_set_lob_mode($rs, FBSQL_LOB_HANDLE);
$row_data = fbsql_fetch_row($rs);
// $row_data[0] will now contain a handle to the BLOB data in the first row
$blob_data = fbsql_read_blob($row_data[0]);
fbsql_free_result($rs);

?>

Viz také

fbsql_create_blob()
fbsql_read_clob()
fbsql_set_lob_mode()

Předcházející | Nahoru | Další
fbsql_query | Domů | fbsql_read_clob


fbsql_read_clob

(PHP 4 >= 4.2.0, PHP 5)

fbsql_read_clob — Read a CLOB from the database

Popis

string fbsql_read_clob ( string $clob_handle [, resource $link_identifier] )

Reads CLOB data from the database.

If a select statement contains BLOB and/or CLOB columns FrontBase will return the data directly when data is fetched. This default behavior can be changed with fbsql_set_lob_mode() so the fetch functions will return handles to BLOB and CLOB data. If a handle is fetched a user must call fbsql_read_clob() to get the actual CLOB data from the database.

Seznam parametrů

clob_handle

A CLOB handle, returned by fbsql_create_clob().

link_identifier

A FrontBase link identifier returned by fbsql_connect() or fbsql_pconnect().

If optional and not specified, the function will try to find an open link to the FrontBase server and if no such link is found it will try to create one as if fbsql_connect() was called with no arguments

Návratové hodnoty

Returns a string containing the specified CLOB data.

Příklady

Příklad 570. fbsql_read_clob() example

<?php
$link = fbsql_pconnect("localhost", "_SYSTEM", "secret")
    or die("Could not connect");
$sql = "SELECT CLOB_COLUMN FROM CLOB_TABLE;";
$rs = fbsql_query($sql, $link);
$row_data = fbsql_fetch_row($rs);
// $row_data[0] will now contain the clob data for the first row
fbsql_free_result($rs);

$rs = fbsql_query($sql, $link);
fbsql_set_lob_mode($rs, FBSQL_LOB_HANDLE);
$row_data = fbsql_fetch_row($rs);
// $row_data[0] will now contain a handle to the CLOB data in the first row
$clob_data = fbsql_read_clob($row_data[0]);
fbsql_free_result($rs);

?>

Viz také

fbsql_create_clob()
fbsql_read_blob()
fbsql_set_lob_mode()

Předcházející | Nahoru | Další
fbsql_read_blob | Domů | fbsql_result


fbsql_result

(PHP 4 >= 4.0.6, PHP 5)

fbsql_result — Get result data

Popis

mixed fbsql_result ( resource $result [, int $row [, mixed $field]] )

Returns the contents of one cell from a FrontBase result set.

When working on large result sets, you should consider using one of the functions that fetch an entire row (specified below). As these functions return the contents of multiple cells in one function call, they're MUCH quicker than fbsql_result().

Calls to fbsql_result() should not be mixed with calls to other functions that deal with the result set.

Seznam parametrů

result

A result identifier returned by fbsql_query() or fbsql_db_query().

row

field

Can be the field's offset, or the field's name, or the field's table dot field's name (tabledname.fieldname).

If the column name has been aliased ('select foo as bar from...'), use the alias instead of the column name.

Poznámka: Specifying a numeric offset for the field argument is much quicker than specifying a fieldname or tablename.fieldname argument.

Návratové hodnoty

Viz také

Recommended high-performance alternatives:
fbsql_fetch_row()
fbsql_fetch_array()
fbsql_fetch_assoc()
fbsql_fetch_object()

Předcházející | Nahoru | Další
fbsql_read_clob | Domů | fbsql_rollback


fbsql_rollback

(PHP 4 >= 4.0.6, PHP 5)

fbsql_rollback — Rollback a transaction to the database

Popis

bool fbsql_rollback ( [resource $link_identifier] )

Ends the current transaction by rolling back all statements issued since last commit.

This command is only needed if autocommit is set to false.

Seznam parametrů

link_identifier

A FrontBase link identifier returned by fbsql_connect() or fbsql_pconnect().

If optional and not specified, the function will try to find an open link to the FrontBase server and if no such link is found it will try to create one as if fbsql_connect() was called with no arguments

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

fbsql_autocommit()
fbsql_commit()

Předcházející | Nahoru | Další
fbsql_result | Domů | fbsql_rows_fetched


fbsql_select_db

(PHP 4 >= 4.0.6, PHP 5)

fbsql_select_db — Select a FrontBase database

Popis

bool fbsql_select_db ( [string $database_name [, resource $link_identifier]] )

Sets the current active database on the given link identifier.

The client contacts FBExec to obtain the port number to use for the connection to the database. If the database name is a number the system will use that as a port number and it will not ask FBExec for the port number. The FrontBase server can be stared as FRontBase -FBExec=No -port=<port number> <database name>.

Every subsequent call to fbsql_query() will be made on the active database.

Seznam parametrů

database_name

The name of the database to be selected.

If the database is protected with a database password, the you must call fbsql_database_password() before selecting the database.

link_identifier

A FrontBase link identifier returned by fbsql_connect() or fbsql_pconnect().

If optional and not specified, the function will try to find an open link to the FrontBase server and if no such link is found it will try to create one as if fbsql_connect() was called with no arguments

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

fbsql_connect()
fbsql_pconnect()
fbsql_database_password()
fbsql_query()

Předcházející | Nahoru | Další
fbsql_rows_fetched | Domů | fbsql_set_characterset


fbsql_set_lob_mode

(PHP 4 >= 4.2.0, PHP 5)

fbsql_set_lob_mode — Set the LOB retrieve mode for a FrontBase result set

Popis

bool fbsql_set_lob_mode ( resource $result, int $lob_mode )

Sets the mode for retrieving LOB data from the database.

When BLOB and CLOB data is retrieved in FrontBase it can be retrieved direct or indirect. Direct retrieved LOB data will always be fetched no matter the setting of the lob mode. If the LOB data is less than 512 bytes it will always be retrieved directly.

Seznam parametrů

result

A result identifier returned by fbsql_query() or fbsql_db_query().

lob_mode

Can be one of:

  • FBSQL_LOB_DIRECT - LOB data is retrieved directly. When data is fetched from the database with fbsql_fetch_row(), and other fetch functions, all CLOB and BLOB columns will be returned as ordinary columns. This is the default value on a new FrontBase result.
  • FBSQL_LOB_HANDLE - LOB data is retrieved as handles to the data. When data is fetched from the database with fbsql_fetch_row(), and other fetch functions, LOB data will be returned as a handle to the data if the data is stored indirect or the data if it is stored direct. If a handle is returned it will be a 27 byte string formatted as @'000000000000000000000000'.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

fbsql_create_blob()
fbsql_create_clob()
fbsql_read_blob()
fbsql_read_clob()

Předcházející | Nahoru | Další
fbsql_set_characterset | Domů | fbsql_set_password


fbsql_set_password

(PHP 5)

fbsql_set_password — Change the password for a given user

Popis

bool fbsql_set_password ( resource $link_identifier, string $user, string $password, string $old_password )

Changes the password for the given user.

Seznam parametrů

link_identifier

A FrontBase link identifier returned by fbsql_connect() or fbsql_pconnect().

If optional and not specified, the function will try to find an open link to the FrontBase server and if no such link is found it will try to create one as if fbsql_connect() was called with no arguments

user

The user name.

password

The new password to be set.

old_password

The old password to be replaced.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
fbsql_set_lob_mode | Domů | fbsql_set_transaction


fbsql_set_transaction

(PHP 4 >= 4.2.0, PHP 5)

fbsql_set_transaction — Set the transaction locking and isolation

Popis

void fbsql_set_transaction ( resource $link_identifier, int $locking, int $isolation )

Sets the transaction locking and isolation.

Seznam parametrů

link_identifier

A FrontBase link identifier returned by fbsql_connect() or fbsql_pconnect().

If optional and not specified, the function will try to find an open link to the FrontBase server and if no such link is found it will try to create one as if fbsql_connect() was called with no arguments

locking

The type of locking to be set. It can be one of the following constants: FBSQL_LOCK_DEFERRED, FBSQL_LOCK_OPTIMISTIC, or FBSQL_LOCK_PESSIMISTIC.

isolation

The type of isolation to be set. It can be one of the following constants: FBSQL_ISO_READ_UNCOMMITTED, FBSQL_ISO_READ_COMMITTED, FBSQL_ISO_REPEATABLE_READ, FBSQL_ISO_SERIALIZABLE, or FBSQL_ISO_VERSIONED.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
fbsql_set_password | Domů | fbsql_start_db


fbsql_start_db

(PHP 4 >= 4.0.6, PHP 5)

fbsql_start_db — Start a database on local or remote server

Popis

bool fbsql_start_db ( string $database_name [, resource $link_identifier [, string $database_options]] )

Start a database on local or remote server.

Seznam parametrů

database_name

The database name.

link_identifier

A FrontBase link identifier returned by fbsql_connect() or fbsql_pconnect().

If optional and not specified, the function will try to find an open link to the FrontBase server and if no such link is found it will try to create one as if fbsql_connect() was called with no arguments

database_options

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

fbsql_db_status()
fbsql_stop_db()

Předcházející | Nahoru | Další
fbsql_set_transaction | Domů | fbsql_stop_db


fbsql_stop_db

(PHP 4 >= 4.0.6, PHP 5)

fbsql_stop_db — Stop a database on local or remote server

Popis

bool fbsql_stop_db ( string $database_name [, resource $link_identifier] )

Stops a database on local or remote server.

Seznam parametrů

database_name

The database name.

link_identifier

A FrontBase link identifier returned by fbsql_connect() or fbsql_pconnect().

If optional and not specified, the function will try to find an open link to the FrontBase server and if no such link is found it will try to create one as if fbsql_connect() was called with no arguments

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

fbsql_db_status()
fbsql_start_db()

Předcházející | Nahoru | Další
fbsql_start_db | Domů | fbsql_table_name


fbsql_tablename

(PHP 4 >= 4.2.0, PHP 5)

fbsql_tablename — Alias pro of fbsql_table_name()

Popis

Tato funkce je aliasem: fbsql_table_name().

Předcházející | Nahoru | Další
fbsql_table_name | Domů | fbsql_username


fbsql_username

(PHP 4 >= 4.0.6, PHP 5)

fbsql_username — Get or set the username for the connection

Popis

string fbsql_username ( resource $link_identifier [, string $username] )

Get or set the username used for the connection.

Seznam parametrů

link_identifier

A FrontBase link identifier returned by fbsql_connect() or fbsql_pconnect().

If optional and not specified, the function will try to find an open link to the FrontBase server and if no such link is found it will try to create one as if fbsql_connect() was called with no arguments

username

If provided, this is the new username to set.

Návratové hodnoty

Returns the current username used with the connection, as a string.

Viz také

fbsql_password()
fbsql_hostname()

Předcházející | Nahoru | Další
fbsql_tablename | Domů | fbsql_warnings


fbsql_warnings

(PHP 4 >= 4.0.6, PHP 5)

fbsql_warnings — Enable or disable FrontBase warnings

Popis

bool fbsql_warnings ( [bool $OnOff] )

Enables or disables FrontBase warnings.

Seznam parametrů

OnOff

Whether to enable warnings or no.

Návratové hodnoty

Returns TRUE if warnings is turned on, FALSE otherwise.

Viz také

fbsql_errno()
fbsql_error()

Předcházející | Nahoru | Další
fbsql_username | Domů | XLVII. FTP Functions


filePro funkce

Předcházející VI. Reference funkcí Další

XL. filePro funkce

Úvod

Tyto funkce umožňují read-only (pouze pro čtení) přístup k datům uloženým ve filePro databázích.

filePro je registrovaná obchodní značka fP Technologies, Inc. Více informací o filePro najdete na » http://www.fptech.com/.

Instalace

filePro support in PHP is not enabled by default. To enable the bundled read-only filePro support you need to use the--enable-filepro configuration option when compiling PHP.

Obsah

filepro_fieldcount — Zjistit, kolik sloupců je ve filePro databázi
filepro_fieldname — Zjistit název sloupce
filepro_fieldtype — Zjistit typ sloupce
filepro_fieldwidth — Zjistit šířku sloupce
filepro_retrieve — Získat data z filePro databáze
filepro_rowcount — Zjistit, kolik řádků je ve filePro databázi
filepro — Přečíst a ověřit mapový soubor
Předcházející | Nahoru | Další
finfo_set_flags | Domů | filepro_fieldcount


filepro_fieldcount

(PHP 4, PHP 5 <= 5.1.6)

filepro_fieldcount — Zjistit, kolik sloupců je ve filePro databázi

Popis

int filepro_fieldcount ( void )

Vrátí počet polí (sloupců) v otevřené filePro databázi.

Viz také filepro().

Předcházející | Nahoru | Další
XL. filePro funkce | Domů | filepro_fieldname


filepro_fieldname

(PHP 4, PHP 5 <= 5.1.6)

filepro_fieldname — Zjistit název sloupce

Popis

string filepro_fieldname ( int $field_number )

Vrátí název sloupce odpovídajícího field_number.

Předcházející | Nahoru | Další
filepro_fieldcount | Domů | filepro_fieldtype


filepro_fieldtype

(PHP 4, PHP 5 <= 5.1.6)

filepro_fieldtype — Zjistit typ sloupce

Popis

string filepro_fieldtype ( int $field_number )

Vrátí editační typ sloupce odpovídajícího field_number.

Předcházející | Nahoru | Další
filepro_fieldname | Domů | filepro_fieldwidth


filepro_fieldwidth

(PHP 4, PHP 5 <= 5.1.6)

filepro_fieldwidth — Zjistit šířku sloupce

Popis

int filepro_fieldwidth ( int $field_number )

Vrátí šířku sloupce odpovídajícího field_number.

Předcházející | Nahoru | Další
filepro_fieldtype | Domů | filepro_retrieve


filepro_retrieve

(PHP 4, PHP 5 <= 5.1.6)

filepro_retrieve — Získat data z filePro databáze

Popis

string filepro_retrieve ( int $row_number, int $field_number )

Vrátí data z určeného místa v databázi.

Předcházející | Nahoru | Další
filepro_fieldwidth | Domů | filepro_rowcount


filepro_rowcount

(PHP 4, PHP 5 <= 5.1.6)

filepro_rowcount — Zjistit, kolik řádků je ve filePro databázi

Popis

int filepro_rowcount ( void )

Vrátí počet řádků v otevřené filePro databázi.

Viz také filepro().

Předcházející | Nahoru | Další
filepro_retrieve | Domů | filepro


filepro

(PHP 4, PHP 5 <= 5.1.6)

filepro — Přečíst a ověřit mapový soubor

Popis

bool filepro ( string $directory )

Přečte a ověří mapový soubor a uloží počet sloupců a info.

Nedochází k zamykání, takže byste se měli vyhnout úpravám vaší filePro databáze, pokud může být otevřena v PHP.

Předcházející | Nahoru | Další
filepro_rowcount | Domů | XLI. Funkce filesystému


Funkce filesystému

Předcházející VI. Reference funkcí Další

XLI. Funkce filesystému

Úvod

Požadavky

Pro toto rozšíření nejsou třeba žádné externí knihovny, ale jestliže chcete, aby PHP na Linuxu podporovalo LFS (velké soubory), potřebujete aktuální knihovnu glibc a musíte PHP zkompilovat s těmito přepínači překladače: -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64.

Instalace

K používání těchto funkcí není třeba žádná instalace, jsou součástí jádra PHP.

Konfigurace běhu

Chování těchto funkcí je ovlivněno nastavením parametrů v php.ini.

Tabulka 83. Filesystem and Streams Configuration Options

Name | Default | Changeable | Changelog
allow_url_fopen | "1" | PHP_INI_ALL | PHP_INI_ALL in PHP <= 4.3.4. PHP_INI_SYSTEM in PHP < 6. Available since PHP 4.0.4.
allow_url_include | "0" | PHP_INI_ALL | PHP_INI_SYSTEM in PHP 5. Available since PHP 5.2.0.
user_agent | NULL | PHP_INI_ALL | Available since PHP 4.3.0.
default_socket_timeout | "60" | PHP_INI_ALL | Available since PHP 4.3.0.
from | "" | PHP_INI_ALL |
auto_detect_line_endings | "0" | PHP_INI_ALL | Available since PHP 4.3.0.

Zde je stručný popis konfiguračních direktiv.

allow_url_fopen boolean

This option enables the URL-aware fopen wrappers that enable accessing URL object like files. Default wrappers are provided for the access of remote files using the ftp or http protocol, some extensions like zlib may register additional wrappers.

Poznámka: This setting can only be set in php.ini due to security reasons.

Poznámka: This option was introduced immediately after the release of version 4.0.3. For versions up to and including 4.0.3 you can only disable this feature at compile time by using the configuration switch --disable-url-fopen-wrapper.

Varování

On Windows versions prior to PHP 4.3.0, the following functions do not
support remote file accessing: include(),
include_once(), require(),
require_once() and the imagecreatefromXXX
functions in the Image extension.

allow_url_include boolean

This option allows the use of URL-aware fopen wrappers with the following functions: include(), include_once(), require(), require_once().

Poznámka: This setting requires allow_url_fopen to be on.

user_agent string

Define the user agent for PHP to send.

default_socket_timeout integer

Default timeout (in seconds) for socket based streams.

Poznámka: This configuration option was introduced in PHP 4.3.0

from string

Define the anonymous ftp password (your email address).

auto_detect_line_endings boolean

When turned on, PHP will examine the data read by fgets() and file() to see if it is using Unix, MS-Dos or Macintosh line-ending conventions.

This enables PHP to interoperate with Macintosh systems, but defaults to Off, as there is a very small performance penalty when detecting the EOL conventions for the first line, and also because people using carriage-returns as item separators under Unix systems would experience non-backwards-compatible behaviour.

Poznámka: This configuration option was introduced in PHP 4.3.0

Typy prostředků

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

GLOB_BRACE (integer)
GLOB_ONLYDIR (integer)
GLOB_MARK (integer)
GLOB_NOSORT (integer)
GLOB_NOCHECK (integer)
GLOB_NOESCAPE (integer)
PATHINFO_DIRNAME (integer)
PATHINFO_BASENAME (integer)
PATHINFO_EXTENSION (integer)
PATHINFO_FILENAME (integer)
Since PHP 5.2.0.
FILE_USE_INCLUDE_PATH (integer)
Search for filename in include_path (since PHP 5).
FILE_APPEND (integer)
Append content to existing file.
FILE_IGNORE_NEW_LINES (integer)
Strip EOL characters (since PHP 5).
FILE_SKIP_EMPTY_LINES (integer)
Skip empty lines (since PHP 5).
FILE_BINARY (integer)
Binary mode (since PHP 6).
FILE_TEXT (integer)
Text mode (since PHP 6).

Viz také

Pro příbuzné funkce viz také sekce Adresáře a Spouštění programů.

Pro seznam a vysvětlení různých URL wrapperů, které mohou být použity jako vzdálené soubory, viz také sekci O – „List of Supported Protocols/Wrappers“.

Obsah

basename — Vrátí část cesty obsahující název souboru
chgrp — Změnit skupinu souboru
chmod — Změnit mód souboru
chown — Změní vlastníka souboru
clearstatcache — Vymaže cache stavu souborů
copy — Zkopíruje soubor
delete — Falešná položka manuálu
dirname — Vrací část cesty obsahující název adresáře
disk_free_space — Returns available space in directory
disk_total_space — Returns the total size of a directory
diskfreespace — Vrátí diskový prostor dostupný v adresáři
fclose — Zavře otevřený deskriptor souboru
feof — Test na konec souboru
fflush — Zapíše obsah výstupního bufferu
fgetc — Načte 1 znak ze souboru
fgetcsv — Načte řádek ze souboru a parsuje ho na CSV hodnoty
fgets — Přečte řádek ze souboru
fgetss — Přečte řádek ze souboru a odstraní HTML značky
file_exists — Zjistí, zda soubor nebo adresář existuje
file_get_contents — Reads entire file into a string
file_put_contents — Write a string to a file
file — Načte celý soubor do pole
fileatime — Vrací čas posledního přístupu k souboru
filectime — Vrací čas změny inodu souboru
filegroup — Vrací skupinu pro soubor
fileinode — Vrací inode souboru
filemtime — Vrací čas změny souboru
fileowner — Vrací vlastníka souboru
fileperms — Vrací přístupová práva k souboru
filesize — Vrací velikost souboru
filetype — Vrací typ souboru
flock — Jednotné "portable advisory" zamykání souboru
fnmatch — Match filename against a pattern
fopen — Otevře soubor nebo URL
fpassthru — Vypíše všechna zbývající data v souboru
fputcsv — Format line as CSV and write to file pointer
fputs — Zapíše do souboru
fread — Binárně bezpečné čtení ze souboru
fscanf — Parsuje vstup ze souboru podle formátu
fseek — Posouvá ukazatel v souboru
fstat — Vrací informace o otevřeném souboru
ftell — Vrací pozici v souboru
ftruncate — Zkrátí soubor na danou délku
fwrite — Binárně bezpečný zápis do souboru
glob — Find pathnames matching a pattern
is_dir — Zjistí, zda je daný soubor adresářem
is_executable — Zjistí, zda je soubor spustitelný
is_file — Zjistí, zda se jedná o obyčejný (regular) soubor
is_link — Zjistí, zda se jedná o symbolický odkaz (link)
is_readable — Zjistí, zda lze ze souboru číst
is_uploaded_file — Zjistí, zda byl soubor uploadován pomocí HTTP POST
is_writable — Zjistí, zda lze do souboru zapisovat
is_writeable — Alias pro is_writable()
lchgrp — Changes group ownership of symlink
lchown — Changes user ownership of symlink
link — Vytvoří hard link
linkinfo — Vrací informaci o odkazu (linku)
lstat — Zjišťuje informace o souboru nebo symbolickém odkazu
mkdir — Vytvoří adresář
move_uploaded_file — Přesune uploadovaný soubor na nové místo
parse_ini_file — Parse a configuration file
pathinfo — Returns information about a file path
pclose — Zavře procesový soubor (rouru)
popen — Otevře procesový soubor (rouru)
readfile — Vypíše soubor
readlink — Vrací cíl symbolického odkazu
realpath — Vrátí absolutní cestu v kanonickém tvaru
rename — Přejmenuje soubor
rewind — Vrátí ukazatel v souboru na začátek
rmdir — Odstraní adresář
set_file_buffer — Nastaví buffer pro soubor
stat — Zjišťuje informace o souboru
symlink — Vytvoří symbolický odkaz
tempnam — Vytvoří soubor s unikátním názvem
tmpfile — Vytvoří dočasný soubor
touch — Nastavit čas změny souboru
umask — Změní současné nastavení umask
unlink — Smazat soubor
Předcházející | Nahoru | Další
filepro | Domů | basename


basename

(PHP 4, PHP 5)

basename — Vrátí část cesty obsahující název souboru

Popis

string basename ( string $path [, string $suffix] )

Přijímá řetězec obsahující cestu na soubor, vrací název souboru.

Na Windows se jako oddělovač cesty dá použít jak lomítko (/), tak zpětné lomítko (\). V ostatních prostředích je to normální lomítko (/).

Příklad 510. Ukázka basename()

$path = '/home/httpd/html/index.php3' ;
$file = basename( $path ) ; // $file má hodnotu "index.php3"

Viz také dirname()

Předcházející | Nahoru | Další
XLI. Funkce filesystému | Domů | chgrp


chgrp

(PHP 4, PHP 5)

chgrp — Změnit skupinu souboru

Popis

bool chgrp ( string $filename, mixed $group )

Pokusí se nastavit skupinu souboru filename na group. Pouze superuživatel může libovolně změnit skupinu souboru; ostatní uživatelé mohou změnit skupinu souboru na jinou skupinu, jíž jsou členy.

Při úspěchu vrací TRUE; jinak FALSE.

Viz také chown() a chmod().

Poznámka: Tato funkce nefunguje na Windows systémech.

Předcházející | Nahoru | Další
basename | Domů | chmod


chmod

(PHP 4, PHP 5)

chmod — Změnit mód souboru

Popis

bool chmod ( string $filename, int $mode )

Pokusí se změnit mód souboru filename na mode.

Pozn.: mode se nepovažuje automaticky za oktalovou hodnotu, takže řetězce (jako "g+w") nebudou správně fungovat. Pokud si chcete zajistit očekávané chování, musíte na začátek mode přidat nulu (0):

chmod ("/somedir/somefile", 755);   // desitkove cislo; zrejme nespravne
chmod ("/somedir/somefile", "u+rwx,go+rx"); // retezec; nespravny
chmod ("/somedir/somefile", 0755);  // oktal; spravna hodnota modu

Při úspěchu vrací TRUE, jinak FALSE.

Viz také chown() a chgrp().

Poznámka: Tato funkce nefunguje na Windows systémech

Předcházející | Nahoru | Další
chgrp | Domů | chown


chown

(PHP 4, PHP 5)

chown — Změní vlastníka souboru

Popis

bool chown ( string $filename, mixed $user )

Pokusí se změnit vlastníka souboru na user. Pouze superuživatel může změnit majitele souboru.

Při úspěchu vrací TRUE, jinak FALSE.

Viz také chown() a chmod().

Poznámka: Tato funkce nefunguje na Windows systémech

Předcházející | Nahoru | Další
chmod | Domů | clearstatcache


clearstatcache

(PHP 4, PHP 5)

clearstatcache — Vymaže cache stavu souborů

Popis

void clearstatcache ( void )

Volání systémových funkcí stat či lstat má poměrně velkou režii. Tudíž se výsledek posledního volání všech stavových funkcí (viz seznam níže) ukládá pro použití při dalším takovém volání používajícím stejný název souboru. Pokud chcete vynutit novou kontrolu stavu, např. pokud je soubor kontrolován mnohokrát a může se změnit nebo zmizet, použijte tuto funkci k uvolnění výsledků posledního volání z paměti.

Tato hodnota se cachuje pouze po dobu běhu skriptu.

Ovlivněné funkce:
stat(),
lstat(),
file_exists(),
is_writable(),
is_readable(),
is_executable(),
is_file(),
is_dir(),
is_link(),
filectime(),
fileatime(),
filemtime(),
fileinode(),
filegroup(),
fileowner(),
filesize(),
filetype(), a
fileperms().

Předcházející | Nahoru | Další
chown | Domů | copy


copy

(PHP 4, PHP 5)

copy — Zkopíruje soubor

Popis

bool copy ( string $source, string $dest )

Vytvoří kopii souboru. Vrací TRUE pokud se kopírování zdařilo, jinak FALSE.

Příklad 511. Ukázka copy()

if (!copy($file, $file.'.bak')) {
    print ("failed to copy $file...<br>\n");
}

Viz také rename().

Předcházející | Nahoru | Další
clearstatcache | Domů | delete


delete

(PECL zip:1.1.0-1.4.1)

delete — Falešná položka manuálu

Popis

void delete ( string $file )

Toto je falešná položka manuálu, která by měla pomoci lidem, kteří hledají unlink() nebo unset() na špatném místě.

Viz také unlink() (mazání souborů), unset() (mazání proměnných).

Předcházející | Nahoru | Další
copy | Domů | dirname


dirname

(PHP 4, PHP 5)

dirname — Vrací část cesty obsahující název adresáře

Popis

string dirname ( string $path )

Přijímá řetězec obsahující cestu na soubor a vrací název adresáře.

Na Windows se jako oddělovač sesty dají používat jak lomítko (/), tak zpětné lomítko (\). Na ostatních systémech je to lomítko (/).

Příklad 512. Ukázka dirname()

$path = "/etc/passwd";
$file = dirname ($path); // $file obsahuje "/etc"

Viz také basename()

Předcházející | Nahoru | Další
delete | Domů | disk_free_space


disk_free_space

(PHP 4 >= 4.0.7, PHP 5)

disk_free_space — Returns available space in directory

Popis

float disk_free_space ( string $directory )

Given a string containing a directory, this function will return the number of bytes available on the corresponding filesystem or disk partition.

Seznam parametrů

directory

A directory of the filesystem or disk partition.

Poznámka: Given a file name instead of a directory, the behaviour of the function is unspecified and may differ between operating systems and PHP versions.

Návratové hodnoty

Returns the number of available bytes as a float.

Příklady

Příklad 513. disk_free_space() example

<?php
// $df contains the number of bytes available on "/"
$df = disk_free_space("/");

// On Windows:
disk_free_space("C:");
disk_free_space("D:");
?>

Poznámky

Poznámka: Tato funkce nebude pracovat se vzdálenými soubory, protože zkoumaný soubor musí být dostupný přes filesystém serveru.

Viz také

disk_total_space()

Předcházející | Nahoru | Další
dirname | Domů | disk_total_space


disk_total_space

(PHP 4 >= 4.0.7, PHP 5)

disk_total_space — Returns the total size of a directory

Popis

float disk_total_space ( string $directory )

Given a string containing a directory, this function will return the total number of bytes on the corresponding filesystem or disk partition.

Seznam parametrů

directory

A directory of the filesystem or disk partition.

Návratové hodnoty

Returns the total number of bytes as a float.

Příklady

Příklad 514. disk_total_space() example

<?php
// $df contains the total number of bytes available on "/"
$df = disk_total_space("/");

// On Windows:
disk_total_space("C:");
disk_total_space("D:");
?>

Poznámky

Poznámka: Tato funkce nebude pracovat se vzdálenými soubory, protože zkoumaný soubor musí být dostupný přes filesystém serveru.

Viz také

disk_free_space()

Předcházející | Nahoru | Další
disk_free_space | Domů | diskfreespace


diskfreespace

(PHP 4, PHP 5)

diskfreespace — Vrátí diskový prostor dostupný v adresáři

Popis

float diskfreespace ( string $directory )

Přijímá řetězec obsahující cestu na adresář, vrací počet bytů dostupných na odpovídajícím filesystému nebo oddílu.

Příklad 515. Ukázka diskfreespace()

$df = diskfreespace("/"); // $df obsahuje pocet bytu
                          // dostupnych na "/"

Předcházející | Nahoru | Další
disk_total_space | Domů | fclose


fclose

(PHP 4, PHP 5)

fclose — Zavře otevřený deskriptor souboru

Popis

bool fclose ( resource $handle )

Soubor, na který fp ukazuje, se zavře.

Vrací TRUE při úspěchu a FALSE při selhání.

Deskriptor souboru musí být platný, a musí ukazovat na soubor úspěšně otevřený pomocí fopen() nebo fsockopen().

Předcházející | Nahoru | Další
diskfreespace | Domů | feof


feof

(PHP 4, PHP 5)

feof — Test na konec souboru

Popis

bool feof ( resource $handle )

Vrací TRUE, pokud je konec souboru (EOF) nebo nastala chyba, jinak FALSE.

Deskriptor souboru musí být platný a musí ukazovat na soubor úspěšně otevřený pomocí fopen(), popen(), nebo fsockopen().

Předcházející | Nahoru | Další
fclose | Domů | fflush


fflush

(PHP 4 >= 4.0.1, PHP 5)

fflush — Zapíše obsah výstupního bufferu

Popis

bool fflush ( resource $handle )

Funkce vynutí okamžitý zápis veškerých dat uložených ve výstupním bufferu do souboru odkazovaného pomocí deskriptoru fp. Vrací TRUE při úspěchu, jinak FALSE.

Deskriptor souboru musí být platný a musí ukazovat na soubor úspěšně otevřený pomocí fopen(), popen(), nebo fsockopen().

Předcházející | Nahoru | Další
feof | Domů | fgetc


fgetc

(PHP 4, PHP 5)

fgetc — Načte 1 znak ze souboru

Popis

string fgetc ( resource $handle )

Vrátí řetězec obsahující jediný znak přečtený ze souboru odkazovaného pomocí deskriptoru fp. Je-li konec souboru (EOF), vrací FALSE.

Deskriptor souboru musí být platný a musí ukazovat na soubor úspěšně otevřený pomocí fopen(), popen(), nebo fsockopen().

Viz také fread(), fopen(),
popen(), fsockopen(), a
fgets().

Předcházející | Nahoru | Další
fflush | Domů | fgetcsv


fgetcsv

(PHP 4, PHP 5)

fgetcsv — Načte řádek ze souboru a parsuje ho na CSV hodnoty

Popis

array fgetcsv ( resource $handle [, int $length [, string $delimiter [, string $enclosure]]] )

Podobné jako fgets() s výjimkou toho. že fgetcsv() parsuje přečtený řádek podle CSV formátu a vrací pole obsahující získané hodnoty. Oddělovačem je čárka, pokud nespecifikujete jiný oddělovač jako nepovinný třetí parametr.

Fp musí být platný deskriptor souboru úspěšně otevřeného pomocí fopen(), popen(), nebo fsockopen()

Délka length musí být větší než nejdelší řádek, vyskytující se v souboru (nepočítaje v to znak konce řádku).

fgetcsv() vrací FALSE při chybě včetně konce souboru (EOF).

N.B. Prázdný řádek v CSV souboru bude vrácen jako pole s jediným NULL polem, aniž by to bylo vyhodnoceno jako chyba.

Příklad 516. fgetcsv() příklad - Čtení a tisk celého CVS souboru

$row = 1;
$fp = fopen ("test.csv","r");
while ($data = fgetcsv ($fp, 1000, ",")) {
    $num = count ($data);
    print "<p> $num fields in line $row: <br>";
    $row++;
    for ($c=0; $c<$num; $c++) {
        print $data[$c] . "<br>";
    }
}
fclose ($fp);

Předcházející | Nahoru | Další
fgetc | Domů | fgets


fgets

(PHP 4, PHP 5)

fgets — Přečte řádek ze souboru

Popis

string fgets ( resource $handle [, int $length] )

Vrací řádek o délce max. length - 1 byte přečtený ze souboru. Čtení končí, pokud bylo přečteno length - 1 bytů, nastal konec řádku nebo konec souboru (podle toho, co přijde první).

Při výskytu chyby vrací FALSE.

Nejčastější úskalí:

Lidé, kteří používali 'C' sémantiku funkce fgets, by si měli uvědomit rozdíl v tom, jak je vrácen konec souboru.

Deskriptor souboru musí být platný a musí ukazovat na soubor úspěšně otevřený pomocí fopen(), popen(), nebo fsockopen().

Jednoduchý příklad:

Příklad 517. Čtení souboru řádek po řádku

$fd = fopen ("/tmp/inputfile.txt", "r");
while (!feof ($fd)) {
    $buffer = fgets($fd, 4096);
    echo $buffer;
}
fclose ($fd);

Viz také fread(), fopen(),
popen(), fgetc(),
fsockopen(), a
socket_set_timeout().

Předcházející | Nahoru | Další
fgetcsv | Domů | fgetss


fgetss

(PHP 4, PHP 5)

fgetss — Přečte řádek ze souboru a odstraní HTML značky

Popis

string fgetss ( resource $handle [, int $length [, string $allowable_tags]] )

Identické s fgets(), ale jsou zde z přečteného textu odstraňovány HTML a PHP značky.

Jako nepovinný třetí parametr můžete specifikovat značky, které nebudou odstraňovány.

Poznámka: allowable_tags - přidáno v PHP 3.0.13, PHP4B3.

Viz také fgets(), fopen(),
fsockopen(), popen(), a
strip_tags().

Předcházející | Nahoru | Další
fgets | Domů | file_exists


file_exists

(PHP 4, PHP 5)

file_exists — Zjistí, zda soubor nebo adresář existuje

Popis

bool file_exists ( string $filename )

Vrací TRUE, pokud soubor specifikovaný pomocí filename existuje, jinak FALSE.

file_exists() nefunguje na vzdálených souborech; soubor k ověření musí být přístupný prostřednictvím filesystému serveru.

Výsledek této funkce je cachován. Více informací - viz clearstatcache().

Předcházející | Nahoru | Další
fgetss | Domů | file_get_contents


file_get_contents

(PHP 4 >= 4.3.0, PHP 5)

file_get_contents — Reads entire file into a string

Popis

string file_get_contents ( string $filename [, int $flags [, resource $context [, int $offset [, int $maxlen]]]] )

This function is similar to file(), except that file_get_contents() returns the file in a string, starting at the specified offset up to maxlen bytes. On failure, file_get_contents() will return FALSE.

file_get_contents() is the preferred way to read the contents of a file into a string. It will use memory mapping techniques if supported by your OS to enhance performance.

Poznámka: If you're opening a URI with special characters, such as spaces, you need to encode the URI with urlencode().

Seznam parametrů

filename

Name of the file to read.

flags
Varování

For all versions prior to PHP 6, this parameter is called use_include_path and is a bool. The flags parameter is only available since PHP 6. If you use an older version and want to search for filename in the include path, this parameter must be TRUE. Since PHP 6, you have to use the FILE_USE_INCLUDE_PATH flag instead.

The value of flags can be any combination of the following flags (with some restrictions), joined with the binary OR (|) operator.

Tabulka 84. Available flags

Flag | Description
FILE_USE_INCLUDE_PATH | Search for filename in the include directory. See include_path for more information.
FILE_TEXT | If unicode semantics are enabled, the default encoding of the read data is UTF-8. You can specify a different encoding by creating a custom context or by changing the default using stream_default_encoding(). This flag cannot be used with FILE_BINARY.
FILE_BINARY | With this flag, the file is read in binary mode. This is the default setting and cannot be used with FILE_TEXT.

context

A valid context resource created with stream_context_create(). If you don't need to use a custom context, you can skip this parameter by NULL.

offset

The offset where the reading starts.

maxlen

Maximum length of data read.

Návratové hodnoty

The function returns the read data or FALSE on failure.

ChangeLog (záznam změn)

Verze | Popis
5.0.0 | Added context support.
5.1.0 | Added the offset and maxlen parameters.
6.0.0 | The use_include_path parameter was replaced by the flags parameter.

Poznámky

Poznámka: Tato funkce je binárně bezpečná.

Tip

S touto funkcí můžete používat URL jako název souboru, pokud je zapnuta volba "fopen wrappers". Pro více detailů o tom, jak specifikovat název souboru, a O – „List of Supported Protocols/Wrappers“pro seznam porporovaných URL protokolů, viz fopen().

Varování

Server Microsoft IIS porušuje při používání SSL komunikační protokol tím, že uzavře spojení bez odeslání indikátoru close_notify. PHP to ohlásí jako "SSL: Fatal Protocol Error", když dosáhne konce toku dat. K vyřešení této situace byste mělo snížit úroveň hlášení chyb (error_reporting) tak, aby nezahrnovala varování. PHP 4.3.7 a vyšší dokáže detekovat chybný software IIS, otevřete-li stream za použití wrapperu https:// a bude automaticky potlačovat příslušná varování. Použijete-li však k vytvoření ssl:// socketu funkci fsockopen(), zůstáváte odpovědni za detekci a potlačení varování.

Viz také

file()
fgets()
fread()
readfile()
file_put_contents()
stream_get_contents()
stream_context_create()

Předcházející | Nahoru | Další
file_exists | Domů | file_put_contents


file_put_contents

(PHP 5)

file_put_contents — Write a string to a file

Popis

int file_put_contents ( string $filename, mixed $data [, int $flags [, resource $context]] )

This function is identical to calling fopen(), fwrite() and fclose() successively to write data to a file.

If filename does not exist, the file is created. Otherwise, the existing file is overwritten, unless the FILE_APPEND flags is set.

Seznam parametrů

filename

Path to the file where to write the data.

data

The data to write. Can be either a string, an array or a stream resource (explained above).

If data is a stream resource, the remaining buffer of that stream will be copied to the specified file. This is similar with using stream_copy_to_stream().

You can also specify the data parameter as a single dimension array. This is equivalent to file_put_contents($filename, implode('', $array)).

flags

The value of flags can be any combination of the following flags (with some restrictions), joined with the binary OR (|) operator.

Tabulka 85. Available flags

Flag | Description
FILE_USE_INCLUDE_PATH | Search for filename in the include directory. See include_path for more information.
FILE_APPEND | If file filename already exists, append the data to the file instead of overwriting it.
LOCK_EX | Acquire an exclusive lock on the file while proceeding to the writing.
FILE_TEXT | data is written in text mode. If unicode semantics are enabled, the default encoding is UTF-8. You can specify a different encoding by creating a custom context or by using the stream_default_encoding() to change the default. This flag cannot be used with FILE_BINARY. This flag is only available since PHP 6.
FILE_BINARY | data will be written in binary mode. This is the default setting and cannot be used with FILE_TEXT. This flag is only available since PHP 6.

context

A valid context resource created with stream_context_create().

Návratové hodnoty

The function returns the amount of bytes that were written to the file, or FALSE on failure.

ChangeLog (záznam změn)

Verze | Popis
5.0.0 | Added context support
5.1.0 | Added support for LOCK_EX and the ability to pass a stream resource to the data parameter
6.0.0 | Added support for the FILE_TEXT and FILE_BINARY flags

Poznámky

Poznámka: Tato funkce je binárně bezpečná.

Tip

S touto funkcí můžete používat URL jako název souboru, pokud je zapnuta volba "fopen wrappers". Pro více detailů o tom, jak specifikovat název souboru, a O – „List of Supported Protocols/Wrappers“pro seznam porporovaných URL protokolů, viz fopen().

Viz také

fopen()
fwrite()
file_get_contents()
stream_context_create()

Předcházející | Nahoru | Další
file_get_contents | Domů | file


file

(PHP 4, PHP 5)

file — Načte celý soubor do pole

Popis

array file ( string $filename [, int $use_include_path [, resource $context]] )

Identické s readfile(), soubor je však vrácen v podobě pole. Každý element pole odpovídá jednomu řádku v souboru včetně znaku konce řádku.

Můžete použít nepovinný druhý parametr a nastavit ho na "1", pokud chcete hledat soubor také v include_path.

<?php
// načti WWW stránku do pole a vytiskni ji
$fcontents = file ('http://www.php.net');
while (list ($line_num, $line) = each ($fcontents)) {
    echo "<b>Line $line_num:</b> " . htmlspecialchars ($line) . "<br>\n";
}

// načti WWW stránku do řetězce
$fcontents = join ('', file ('http://www.php.net'));
?>

Viz také readfile(),
fopen(), fsockopen(), a
popen().

Předcházející | Nahoru | Další
file_put_contents | Domů | fileatime


fileatime

(PHP 4, PHP 5)

fileatime — Vrací čas posledního přístupu k souboru

Popis

int fileatime ( string $filename )

Vrací čas posledního přístupu k souboru, při chybě FALSE. Čas je vrácen jako Unix timestamp.

Výsledek této funkce je cachován. Více informací - viz clearstatcache().

Pozn.: Atime (čas posl. přístupu) souboru se obvykle mění při čtení datových bloků ze souboru. To se může značně negativně projevit na výkonu systému, pokud aplikace přistupuje k velkému počtu souborů nebo adresářů. Některé Unixové filesystémy mohou mít atime deaktivován za účelem zvýšení výkonu pro takové aplikace; takovým případem jsou USENET news spools. Tehdy je tato funkce bezpředmětná.

Předcházející | Nahoru | Další
file | Domů | filectime


filectime

(PHP 4, PHP 5)

filectime — Vrací čas změny inodu souboru

Popis

int filectime ( string $filename )

Vrací čas poslední změny inodu souboru, při chybě FALSE. Čas je vracen jako Unix timestamp.

Výsledek této funkce je cachován. Více informací - viz clearstatcache().

Pozn.: Na většině unixových filesystémů platí, že soubor je považován za změněný, pokud jsou změněna data v Inodu, tj. přístupová práva, vlastník, skupina nebo jiná metadata jsou zapsána do Inodu. filemtime() (toto je to, co chcete použít, když chcete vytvořit údaj "Poslední změna" na WWW stránce) a fileatime().

Pozn.: Na některých Unixech je ctime považován za čas vytvoření souboru. To je chyba. Na většině unixových filesystémů neexistuje žádný čas vytvoření unixových souborů.

Předcházející | Nahoru | Další
fileatime | Domů | filegroup


filegroup

(PHP 4, PHP 5)

filegroup — Vrací skupinu pro soubor

Popis

int filegroup ( string $filename )

Vrací ID skupiny vlastníka souboru, při chybě FALSE. Skupinové ID je v číselném tvaru, použijte posix_getgrgid() pro získání názvu skupiny.

Výsledek této funkce je cachován. Více informací - viz clearstatcache().

Poznámka: Tato funkce nefunguje na Windows systémech

Předcházející | Nahoru | Další
filectime | Domů | fileinode


fileinode

(PHP 4, PHP 5)

fileinode — Vrací inode souboru

Popis

int fileinode ( string $filename )

Vrací inode číslo souboru, při chybě FALSE.

Výsledek této funkce je cachován. Více informací - viz clearstatcache().

Poznámka: Tato funkce nefunguje na Windows systémech

Předcházející | Nahoru | Další
filegroup | Domů | filemtime


filemtime

(PHP 4, PHP 5)

filemtime — Vrací čas změny souboru

Popis

int filemtime ( string $filename )

Vrací čas poslední změny souboru, při chybě FALSE. Čas je vracen jako Unix timestamp.

Výsledek této funkce je cachován. Více informací - viz clearstatcache().

Tato funkce vrací čas, kdy byly zapsány datové bloky, tj. čas poslední změny obsahu souboru. Použijte funkci date() na výsledek této funkce k získání formátovaného tvaru data pro použití na WWW stránkách.

Předcházející | Nahoru | Další
fileinode | Domů | fileowner


fileowner

(PHP 4, PHP 5)

fileowner — Vrací vlastníka souboru

Popis

int fileowner ( string $filename )

Vrací ID uživatele (UID), vlastnícího soubor; při chybě FALSE. Hodnota je v číselném tvaru, použijte funkci posix_getpwuid() k získání uživatelského jména.

Výsledek této funkce je cachován. Více informací - viz clearstatcache().

Poznámka: Tato funkce nefunguje na Windows systémech

Předcházející | Nahoru | Další
filemtime | Domů | fileperms


fileperms

(PHP 4, PHP 5)

fileperms — Vrací přístupová práva k souboru

Popis

int fileperms ( string $filename )

Vrací přístupová práva (permissions) k souboru, při chybě FALSE.

Výsledek této funkce je cachován. Více informací - viz clearstatcache().

Předcházející | Nahoru | Další
fileowner | Domů | filesize


filesize

(PHP 4, PHP 5)

filesize — Vrací velikost souboru

Popis

int filesize ( string $filename )

Vrací velikost souboru, při chybě FALSE.

Výsledek této funkce je cachován. Více informací - viz clearstatcache().

Předcházející | Nahoru | Další
fileperms | Domů | filetype


filetype

(PHP 4, PHP 5)

filetype — Vrací typ souboru

Popis

string filetype ( string $filename )

Vrací typ souboru. Možné hodnoty jsou fifo, char, dir, block, link, file a unknown.

Při chybě vrací FALSE.

Výsledek této funkce je cachován. Více informací - viz clearstatcache().

Předcházející | Nahoru | Další
filesize | Domů | flock


flock

(PHP 4, PHP 5)

flock — Jednotné "portable advisory" zamykání souboru

Popis

bool flock ( resource $handle, int $operation [, int &$wouldblock] )

PHP podporuje "portable" způsob zamykání celých souborů na základě jednotného "advisory" principu (tzn. všechny přistupující programy musí používat tentýž systém zamykání, jinak to nebude fungovat).

flock() funguje na deskriptoru fp, který musí patřit otevřenému souboru. operation je jedna z následujících hodnot:

  • K získání sdíleného (shared) zámku (čtení) nastavte operation na LOCK_SH (resp. 1 u verzí do PHP 4.0.1).
  • K získání výhradního zámku (zápis) nastavte operation na LOCK_EX (resp. 2 u verzí do PHP 4.0.1).
  • K uvolnění zámku (sdíleného nebo výhradního) nastavte operation na LOCK_UN (resp. 3 u verzí do PHP 4.0.1).
  • Pokud nechcete, aby funkce flock() blokovala během zamykání, přidejte k operation hodnotu LOCK_NB (4 pro verze do PHP 4.0.1).

flock() umožnuje jednoduchý model čtení/zápis použitelný teoreticky na všech platformách (včetně většiny Unixů a nejspíš i Windows). Nepovinný třetí argument se nastaví na TRUE, pokud by zámek měl blokovat (EWOULDBLOCK errno podmínka).

flock() vrací TRUE při úspěchu, FALSE při chybě (např. když nelze vytvořit zámek).

Varování

Na většině operačních systémů je funkce flock() implementována na úrovni procesů. Při použití multithreadového serverového API (jako je ISAPI) nemůžete spoléhat na ochranu souborů proti jiným PHP skriptům běžícím v paralelních vláknech stejné instance serveru!

Předcházející | Nahoru | Další
filetype | Domů | fnmatch


fnmatch

(PHP 4 >= 4.3.0, PHP 5)

fnmatch — Match filename against a pattern

Popis

bool fnmatch ( string $pattern, string $string [, int $flags] )

fnmatch() checks if the passed string would match the given shell wildcard pattern.

Seznam parametrů

pattern

The shell wildcard pattern.

string

The tested string. This function is especially useful for filenames, but may also be used on regular strings.

The average user may be used to shell patterns or at least in their simplest form to '?' and '*' wildcards so using fnmatch() instead of ereg() or preg_match() for frontend search expression input may be way more convenient for non-programming users.

flags

See the Unix manpage on fnmatch(3) for flag names (as long as they are not documented here).

Návratové hodnoty

Returns TRUE if there is a match, FALSE otherwise.

Příklady

Příklad 518. Checking a color name against a shell wildcard pattern

<?php
if (fnmatch("*gr[ae]y", $color)) {
  echo "some form of gray ...";
}
?>

Poznámky

Varování

For now this function is not available on Windows or other non-POSIX compliant systems.

Viz také

glob()
ereg()
preg_match()
sscanf()
printf()
sprintf()

Předcházející | Nahoru | Další
flock | Domů | fopen


fopen

(PHP 4, PHP 5)

fopen — Otevře soubor nebo URL

Popis

resource fopen ( string $filename, string $mode [, bool $use_include_path [, resource $context]] )

Jestliže filename začíná "http://" (velkými nebo malými písmeny), je otevřeno spojení na příslušný server protokolem HTTP 1.0 a je vrácen deskriptor ukazující na začátek těla dokumentu. Posílá se hlavička 'Host:' pro přístup k virtuálním serverům založeným na jméně.

Nezpracovává HTTP přesměrování, je třeba vložit koncové lomítko za název adresáře.

Když filename začíná "ftp://" (velká či malá písmena), je otevřena FTP relace na příslušný server a vrácen deskriptor na požadovaný soubor. Pokud server nepodporuje pasivní režim FTP komunikace, selže to. Můžete přes FTP otvírat soubory pro čtení i zápis, ale ne pro obojí najednou.

Když filename je buď "php://stdin", "php://stdout", nebo "php://stderr", bude otevřen standardní vstup/výstup (stdio). (To platí od verze PHP 3.0.13; v dřívějších verzích se musí použít názvy jako "/dev/stdin" nebo "/dev/fd/0".)

Když filename začíná čímkoli jiným, bude otevřen obyčejný soubor (z filesystému) a vrácen jeho deskriptor.

Pokud otvírání selže, funkce vrátí FALSE.

mode může být kterýkoli z těchto:

  • 'r' - Otevřít pouze pro čtení; nastaví ukazatel na začátek souboru.
  • 'r+' - Otevřít pro čtení a zápis; nastaví ukazatel na začátek souboru.
  • 'w' - Otevřít pouze pro zápis; nastaví ukazatel na začátek souboru a zkrátí soubor na nulovou délku. Pokud soubor neexistuje, pokusí se ho vytvořit.
  • 'w+' - Otevřít pro čtení a zápis; nastaví ukazatel na začátek souboru a zkrátí soubor na nulovou délku. Pokud soubor neexistuje, pokusí se ho vytvořit.
  • 'a' - Otevřít pouze pro zápis; nastaví ukazatel na konec souboru, Pokud soubor neexistuje, pokusí se ho vytvořit.
  • 'a+' -Otevřít pro čtení a zápis; nastaví ukazatel na konec souboru. Pokud soubor neexistuje, pokusí se ho vytvořit.
mode může obsahovat písmeno 'b'. To je užitečné pouze na systémech které rozlišují mezi binárními a textovými soubory (nikoli např. na Unixu). Pokud není zapotřebí, je ignorován.

Můžete použít nepovinný třetí parametr a nastavit ho na "1", pokud chcete hledat soubor také v include_path.

Příklad 519. fopen() příklad

$fp = fopen ("/home/rasmus/file.txt", "r");
$fp = fopen ("/home/rasmus/file.gif", "wb");
$fp = fopen ("http://www.php.net/", "r");
$fp = fopen ("ftp://user:password@example.com/", "w");

Pokud jste zaznamenali problémy se čtením a zápisem do souborů a používáte PHP jako modul do serveru, nezapomeňte zajistit, aby soubory a adresáře, které používáte, byly přístupné pro serverový proces.

Na Windows je třeba oescapovat všechna zpětná lomítka ve specifikaci cesty k souboru nebo používat obyčejná (dopředná) lomítka.

$fp = fopen ("c:\\data\\info.txt", "r");

Viz také fclose(),
fsockopen(),
socket_set_timeout(), a
popen().

Předcházející | Nahoru | Další
fnmatch | Domů | fpassthru


fpassthru

(PHP 4, PHP 5)

fpassthru — Vypíše všechna zbývající data v souboru

Popis

int fpassthru ( resource $handle )

Čte až do dosažení konce souboru specifikovaného deskriptorem a načtené přepisuje na standardní výstup.

Pokud nastane chyba, funkce fpassthru() vrací FALSE.

Deskriptor souboru musí být platný a musí ukazovat na soubor úspěšně otevřený pomocí fopen(), popen(), nebo fsockopen(). Až funkce fpassthru() ukončí čtení, zavře soubor (deskriptor fp tím ztrácí smysl).

Když chcete vypsat obsah souboru na standardní výstup (stdout), můžete použí funkci readfile(), která vás ušetří volání funkce fopen().

Viz také readfile(),
fopen(), popen(), a
fsockopen()

Předcházející | Nahoru | Další
fopen | Domů | fputcsv


fputcsv

(PHP 5 >= 5.1.0)

fputcsv — Format line as CSV and write to file pointer

Popis

int fputcsv ( resource $handle, array $fields [, string $delimiter [, string $enclosure]] )

fputcsv() formats a line (passed as a fields array) as CSV and write it (terminated by a newline) to the specified file handle.

Seznam parametrů

handle

Ukazatel na soubor musí být platný a musí ukazovat na soubor úspěšně otevřený pomocí fopen() nebo fsockopen() (a dosud nezavřený pomocí fclose()).

fields

An array of values.

delimiter

The optional delimiter parameter sets the field delimiter (one character only). Defaults as a comma: ,.

enclosure

The optional enclosure parameter sets the field enclosure (one character only) and defaults to a double quotation mark: ".

Návratové hodnoty

Returns the length of the written string, or FALSE on failure.

Příklady

Příklad 520. fputcsv() example

<?php

$list = array (
    'aaa,bbb,ccc,dddd',
    '123,456,789',
    '"aaa","bbb"'
);

$fp = fopen('file.csv', 'w');

foreach ($list as $line) {
    fputcsv($fp, split(',', $line));
}

fclose($fp);
?>

Poznámky

Poznámka: Máte-li problémy s tím, že PHP nerozpoznává konce řádků při čtení souborů pocházejících z počítačů Macintosh, budete muset zapnout konfigurační parametr auto_detect_line_endings.

Viz také

fgetcsv()

Předcházející | Nahoru | Další
fpassthru | Domů | fputs


fputs

(PHP 4, PHP 5)

fputs — Zapíše do souboru

Popis

int fputs ( int $fp, string $str [, int $ length ] )

Funkce fputs() je alias k fwrite() a je s ní tedy naprosto identická. Uvědomte si, že parametr length je nepovinný a pokud není specifikován, zapíše se celý řetezec.

Předcházející | Nahoru | Další
fputcsv | Domů | fread


fread

(PHP 4, PHP 5)

fread — Binárně bezpečné čtení ze souboru

Popis

string fread ( resource $handle, int $length )

fread() přečte nejvýše length bytů ze souboru specifikovaného deskriptorem fp. Čtení končí, pokud je přečteno length bytů nebo je dosažen konec souboru (podle toho, co přijde dřív).

// nacte obsah souboru do retezce
$filename = "/usr/local/something.txt";
$fd = fopen ($filename, "r");
$contents = fread ($fd, filesize ($filename));
fclose ($fd);

Viz také fwrite(), fopen(),
fsockopen(), popen(),
fgets(), fgetss(),
fscanf(), file(), a
fpassthru().

Předcházející | Nahoru | Další
fputs | Domů | fscanf


fscanf

(PHP 4 >= 4.0.1, PHP 5)

fscanf — Parsuje vstup ze souboru podle formátu

Popis

mixed fscanf ( resource $handle, string $format [, mixed &$...] )

Funkce fscanf() je podobná sscanf(), ale načítá ze souboru specifikovaného handle a interpretuje vstupní data podle specifikovaného formátu format. Pokud má funkce pouze dva parametry, parsované hodnoty bude vráceny jako pole. Jinak, když jsou použity nepovinné parametry, funkce vrací určitý počet asignovaných hodnot. Nepovinné parametry musí být vloženy odkazem.

Příklad 521. fscanf() Příklad

$fp = fopen ("users.txt","r");
while ($userinfo = fscanf ($fp, "%s\t%s\t%s\n")) {
    list ($name, $profession, $countrycode) = $userinfo;
    //... udelej neco s hodnotami
}
fclose($fp);

Příklad 522. users.txt

javier  argonaut        pe
hiroshi sculptor        jp
robert  slacker us
luigi   florist it

Viz také fread(), fgets(),
fgetss(), sscanf(),
printf(), a sprintf().

Předcházející | Nahoru | Další
fread | Domů | fseek


fseek

(PHP 4, PHP 5)

fseek — Posouvá ukazatel v souboru

Popis

int fseek ( resource $handle, int $offset [, int $whence] )

Nastaví ukazatel pozice v souboru specifikované pomocí deskriptoru fp. Nová pozice, měřená počtem bytů od začátku souboru, je získána přičtením hodnoty offset k pozici specifikované pomocí whence, jehož hodnota je definovanána:
SEEK_SET - Nastav na pozici rovnu offset bytů.
SEEK_CUR - Nastav pozici na současnou plus počet bytů v offset.
SEEK_END - Nastav na konec souboru plus offset bytů.

Pokud není parametr whence specifikován, použije se SEEK_SET.

Při úspěchu vrací 0, jinak -1. Pozn.: přesun za konec souboru není považován za chybu.

Nelze použít na deskriptor souboru vrácený funkcí fopen(), jestliže byl použit formát "http://" nebo "ftp://".

Poznámka: Argument whence byl přidán po verzi PHP 4.0 RC1.

Viz také ftell() a rewind().

Předcházející | Nahoru | Další
fscanf | Domů | fstat


fstat

(PHP 4, PHP 5)

fstat — Vrací informace o otevřeném souboru

Popis

array fstat ( resource $handle )

Sbírá statistiky otevřeného souboru specifikovaném deskriptorem fp. Tato funkce je podobná funkci stat(), pracuje však s deskriptorem, nikoli názvem souboru.

Vrací pole se statistikami souboru s těmito elementy:

  1. device
  2. inode
  3. number of links
  4. user id of owner
  5. group id owner
  6. device type if inode device *
  7. size in bytes
  8. time of last access
  9. time of last modification
  10. time of last change
  11. blocksize for filesystem I/O *
  12. number of blocks allocated
* - platné pouze na systémech s podporou typu st_blksize -- jinde (např. na Windows) vrací -1

Výsledek této funkce je cachován. Více detailů - viz clearstatcache().

Předcházející | Nahoru | Další
fseek | Domů | ftell


ftell

(PHP 4, PHP 5)

ftell — Vrací pozici v souboru

Popis

int ftell ( resource $handle )

Vrací pozici v souboru odkazovaném deskriptorem fp; typicky offset ve streamu.

Pokud nastane chyba, vrací FALSE.

Deskriptor souboru musí být platný a musí ukazovat na soubor úspěšně otevřený pomocí fopen(), popen(), nebo fsockopen().

Viz také fopen(), popen(), fseek() a rewind().

Předcházející | Nahoru | Další
fstat | Domů | ftruncate


ftruncate

(PHP 4, PHP 5)

ftruncate — Zkrátí soubor na danou délku

Popis

bool ftruncate ( resource $handle, int $size )

Vezme soubor specifikovaný pomocí fp a zkrátí ho na délku size. Vrací TRUE při úspěchu a FALSE při chybě.

Předcházející | Nahoru | Další
ftell | Domů | fwrite


fwrite

(PHP 4, PHP 5)

fwrite — Binárně bezpečný zápis do souboru

Popis

int fwrite ( resource $handle, string $string [, int $length] )

fwrite() zapíše obsah řetězce string do souboru specifikovaného pomocí fp. Pokud je zde argument length, zápis skončí po zapsání length bytů nebo při dosažení konce řetězce string, podle toho, co přijde dřív.

Pozn.: pokud je dán argument length, volba magic_quotes_runtime v konfiguraci bude ignorována a nebudou odstraňována žádná lomítka z řetězce string.

Viz také fread(), fopen(),
fsockopen(), popen(), a
fputs().

Předcházející | Nahoru | Další
ftruncate | Domů | glob


glob

(PHP 4 >= 4.3.0, PHP 5)

glob — Find pathnames matching a pattern

Popis

array glob ( string $pattern [, int $flags] )

The glob() function searches for all the pathnames matching pattern according to the rules used by the libc glob() function, which is similar to the rules used by common shells.

Seznam parametrů

pattern

The pattern. No tilde expansion or parameter substitution is done.

flags

Valid flags:

  • GLOB_MARK - Adds a slash to each item returned
  • GLOB_NOSORT - Return files as they appear in the directory (no sorting)
  • GLOB_NOCHECK - Return the search pattern if no files matching it were found
  • GLOB_NOESCAPE - Backslashes do not quote metacharacters
  • GLOB_BRACE - Expands {a,b,c} to match 'a', 'b', or 'c'
  • GLOB_ONLYDIR - Return only directory entries which match the pattern
  • GLOB_ERR - Stop on read errors (like unreadable directories), by default errors are ignored.

Návratové hodnoty

Returns an array containing the matched files/directories, an empty array if no file matched or FALSE on error.

ChangeLog (záznam změn)

Verze | Popis
5.1.0 | GLOB_ERR was added
4.3.3 | GLOB_ONLYDIR became available on Windows and other systems not using the GNU C library

Příklady

Příklad 523. Convenient way how glob() can replace opendir() and friends.

<?php
foreach (glob("*.txt") as $filename) {
    echo "$filename size " . filesize($filename) . "\n";
}
?>

Výše uvedený příklad vypíše něco jako:

funclist.txt size 44686
funcsummary.txt size 267625
quickref.txt size 137820

Poznámky

Poznámka: Tato funkce nebude pracovat se vzdálenými soubory, protože zkoumaný soubor musí být dostupný přes filesystém serveru.

Poznámka: This function isn't available on some systems (e.g. old Sun OS).

Poznámka: The GLOB_BRACE flag is not available on some non GNU systems, like Solaris.

Viz také

opendir()
readdir()
closedir()
fnmatch()

Předcházející | Nahoru | Další
fwrite | Domů | is_dir


is_dir

(PHP 4, PHP 5)

is_dir — Zjistí, zda je daný soubor adresářem

Popis

bool is_dir ( string $filename )

Vrací TRUE když soubor existuje a jedná se o adresář.

Výsledek této funkce je cachován. Více detailů - viz clearstatcache().

Viz také is_file() a is_link().

Předcházející | Nahoru | Další
glob | Domů | is_executable


is_executable

(PHP 4, PHP 5)

is_executable — Zjistí, zda je soubor spustitelný

Popis

bool is_executable ( string $filename )

Vrací TRUE, když soubor existuje a je spustitelný (proveditelný)

Výsledek této funkce je cachován. Více detailů - viz clearstatcache().

Viz také is_file() a is_link().

Předcházející | Nahoru | Další
is_dir | Domů | is_file


is_file

(PHP 4, PHP 5)

is_file — Zjistí, zda se jedná o obyčejný (regular) soubor

Popis

bool is_file ( string $filename )

Vrací TRUE, když soubor existuje a jedná se o obyčejný (regular) soubor

Výsledek této funkce je cachován. Více detailů - viz clearstatcache().

Viz také is_dir() a is_link().

Předcházející | Nahoru | Další
is_executable | Domů | is_link


is_link

(PHP 4, PHP 5)

is_link — Zjistí, zda se jedná o symbolický odkaz (link)

Popis

bool is_link ( string $filename )

Vrací TRUE, když soubor existuje a jedná se o symbolický odkaz (link).

Výsledek této funkce je cachován. Více detailů - viz clearstatcache().

Viz také is_dir() a is_file().

Poznámka: Tato funkce nefunguje na Windows systémech

Předcházející | Nahoru | Další
is_file | Domů | is_readable


is_readable

(PHP 4, PHP 5)

is_readable — Zjistí, zda lze ze souboru číst

Popis

bool is_readable ( string $filename )

Vrací TRUE, když soubor existuje a lze z něj číst.

Mějte na paměti, že PHP může přistupovat k souboru s právy, kterými disponuje WWW server (obvykle 'nobody'). Omezení bezpečného režimu (safe mode limitations) are not taken into account.

Výsledek této funkce je cachován. Více detailů - viz clearstatcache().

Viz také is_writable().

Předcházející | Nahoru | Další
is_link | Domů | is_uploaded_file


is_uploaded_file

(PHP 4 >= 4.0.3, PHP 5)

is_uploaded_file — Zjistí, zda byl soubor uploadován pomocí HTTP POST

Popis

bool is_uploaded_file ( string $filename )

Tato funkce je dostupná pouze na verzích PHP 3 od 3.0.16 a na verzích PHP 4 od 4.0.2.

Vrací TRUE, pokud soubor nazvaný filename byl uploadován pomocí HTTP POST. To je užitečné k ujištění se, zda se neukázněný uživatel nepokusil upravit skript tak, aby pracoval se soubory, se kterými by pracovat neměl -- například /etc/passwd.

Tento druh testů je zvláště důležitý, je-li možnost, že akce na uploadovaných souborech může zpřístupnit jejich obsah uživateli nebo jiným uživatekům tohoto systému.

Viz také move_uploaded_file(), a sekce Handling file uploads, kde je příklad jednoduchého použití.

Předcházející | Nahoru | Další
is_readable | Domů | is_writable


is_writable

(PHP 4, PHP 5)

is_writable — Zjistí, zda lze do souboru zapisovat

Popis

bool is_writable ( string $filename )

Vrací TRUE, když soubor existuje a lze do něj zapisovat. Název souboru (argument filename) může být název adresáře, potom se zjišťuje, zda lze do adresáře zapisovat.

Mějte na paměti, že PHP může přistupovat k souboru s právy, kterými disponuje WWW server (obvykle 'nobody'). Omezení bezpečného režimu (safe mode limitations) are not taken into account.

Výsledek této funkce je cachován. Více detailů - viz clearstatcache().

Viz také is_readable().

Předcházející | Nahoru | Další
is_uploaded_file | Domů | is_writeable


is_writeable

(PHP 4, PHP 5)

is_writeable — Alias pro is_writable()

Popis

Tato funkce je aliasem: is_writable().

Předcházející | Nahoru | Další
is_writable | Domů | lchgrp


link

(PHP 4, PHP 5)

link — Vytvoří hard link

Popis

bool link ( string $target, string $link )

link() vytvoří hard link.

Viz také symlink() pro vytváření symbolických linků a readlink() spolu s linkinfo().

Poznámka: Tato funkce nefunguje na Windows systémech

Předcházející | Nahoru | Další
lchown | Domů | linkinfo


linkinfo

(PHP 4, PHP 5)

linkinfo — Vrací informaci o odkazu (linku)

Popis

int linkinfo ( string $path )

linkinfo() vrací položku st_dev field struktury UNIX C stat získanou systémovým voláním lstat. Tato funkce se používá pro ověření, zda odkaz (specifikovaný pomocí path) opravdu existuje (používá se tatáž metoda jako je makro S_ISLNK definovaní v stat.h). Vrací 0, v případě chybyFALSE.

Viz také symlink(), link(), a readlink().

Poznámka: Tato funkce nefunguje na Windows systémech

Předcházející | Nahoru | Další
link | Domů | lstat


lstat

(PHP 4, PHP 5)

lstat — Zjišťuje informace o souboru nebo symbolickém odkazu

Popis

array lstat ( string $filename )

Sbírá statistiky o souboru nebo symbolickém odkazu (linku) identifikovaném pomocí názvu filename. Tato funkce je identická s funkcí stat(), s výjimkou situace, kdy parametrem filename je symbolický odkaz -- tehdy jsou vráceny informace o odkazu, nikoli o souboru, na který ukazuje.

Vrací pole se statistikami souboru s těmito elementy:

  1. device
  2. inode
  3. inode protection mode
  4. number of links
  5. user id of owner
  6. group id owner
  7. device type if inode device *
  8. size in bytes
  9. time of last access
  10. time of last modification
  11. time of last change
  12. blocksize for filesystem I/O *
  13. number of blocks allocated
* - platné pouze na systémechs podporou typu st_blksize -- jinde (např. na Windows) vrátí -1

Výsledek této funkce je cachován. Více informací - viz clearstatcache().

Předcházející | Nahoru | Další
linkinfo | Domů | mkdir


mkdir

(PHP 4, PHP 5)

mkdir — Vytvoří adresář

Popis

bool mkdir ( string $pathname [, int $mode [, bool $recursive [, resource $context]]] )

Pokusí se vytvořit adresář specifikovaný svým názvem.

Pozn.: Pravděpodobně chcete specifikovat mód jako oktalové číslo, potom by však mělo začínat nulou.

mkdir ("/path/to/my/dir", 0700);

Vrací TRUE při úspěchu a FALSE při chybě.

Viz také rmdir().

Předcházející | Nahoru | Další
lstat | Domů | move_uploaded_file


move_uploaded_file

(PHP 4 >= 4.0.3, PHP 5)

move_uploaded_file — Přesune uploadovaný soubor na nové místo

Popis

bool move_uploaded_file ( string $filename, string $destination )

tato fuknce je dostupná pouze ve verzích PHP 3 od 3.0.16 a ve verzích PHP 4 od 4.0.2.

Tato si ověřuje, zda soubor identifikovaný názvem filename je platným uploadovaným souborem (prostřednictvím HTTP POST mechanismu poskytovaného PHP). Pokud je soubor platný, je přesunut/přejmenován na destination.

Pokud filename není platný uploadovaný soubor, funkce move_uploaded_file() nic neprovede a vrátí FALSE.

Pokud filename je platný uploadovaný soubor, ale z nějakého důvodu nemůže být přesunut, funkce move_uploaded_file() nic neprovede a vrátí FALSE. Navíc je vygenerováno varování (warning).

Tento druh testů je zvláště důležitý, je-li možnost, že akce na uploadovaných souborech může zpřístupnit jejich obsah uživateli nebo jiným uživatekům tohoto systému.

Viz také is_uploaded_file(), a sekce Handling file uploads, kde je příklad jednoduchého použití.

Předcházející | Nahoru | Další
mkdir | Domů | parse_ini_file


parse_ini_file

(PHP 4, PHP 5)

parse_ini_file — Parse a configuration file

Popis

array parse_ini_file ( string $filename [, bool $process_sections] )

parse_ini_file() loads in the ini file specified in filename, and returns the settings in it in an associative array.

The structure of the ini file is the same as the php.ini's.

Seznam parametrů

filename

The filename of the ini file being parsed.

process_sections

By setting the last process_sections parameter to TRUE, you get a multidimensional array, with the section names and settings included. The default for process_sections is FALSE

Návratové hodnoty

The settings are returned as an associative array.

ChangeLog (záznam změn)

Verze | Popis
5.2.4 | Keys and section names consisting of numbers are now evaluated as PHP integers thus numbers starting by 0 are evaluated as octals and numbers starting by 0x are evaluated as hexadecimals.
5.0.0 | Values enclosed in double quotes can contain new lines.
4.2.1 | This function is now affected by bezpečný režim and open_basedir.

Příklady

Příklad 524. Contents of sample.ini

; This is a sample configuration file
; Comments start with ';', as in php.ini

[first_section]
one = 1
five = 5
animal = BIRD

[second_section]
path = "/usr/local/bin"
URL = "http://www.example.com/~username"

Příklad 525. parse_ini_file() example

Constants may also be parsed in the ini file so if you define a constant as an ini value before running parse_ini_file(), it will be integrated into the results. Only ini values are evaluated. For example:

<?php

define('BIRD', 'Dodo bird');

// Parse without sections
$ini_array = parse_ini_file("sample.ini");
print_r($ini_array);

// Parse with sections
$ini_array = parse_ini_file("sample.ini", true);
print_r($ini_array);

?>

Výše uvedený příklad vypíše něco jako:

Array
(
    [one] => 1
    [five] => 5
    [animal] => Dodo bird
    [path] => /usr/local/bin
    [URL] => http://www.example.com/~username
)
Array
(
    [first_section] => Array
        (
            [one] => 1
            [five] => 5
            [animal] = Dodo bird
        )

    [second_section] => Array
        (
            [path] => /usr/local/bin
            [URL] => http://www.example.com/~username
        )

)

Poznámky

Poznámka: This function has nothing to do with the php.ini file. It is already processed, the time you run your script. This function can be used to read in your own application's configuration files.

Poznámka: If a value in the ini file contains any non-alphanumeric characters it needs to be enclosed in double-quotes (").

Poznámka: There are reserved words which must not be used as keys for ini files. These include: null, yes, no, true, and false. Values null, no and false results in "", yes and true results in "1". Characters {}|&~![()" must not be used anywhere in the key and have a special meaning in the value.

Předcházející | Nahoru | Další
move_uploaded_file | Domů | pathinfo


pathinfo

(PHP 4 >= 4.0.3, PHP 5)

pathinfo — Returns information about a file path

Popis

mixed pathinfo ( string $path [, int $options] )

pathinfo() returns an associative array containing information about path.

Seznam parametrů

path

The path being checked.

options

You can specify which elements are returned with optional parameter options. It composes from PATHINFO_DIRNAME, PATHINFO_BASENAME, PATHINFO_EXTENSION and PATHINFO_FILENAME. It defaults to return all elements.

Návratové hodnoty

The following associative array elements are returned: dirname, basename extension (if any), and filename.

If options is used, this function will return a string if not all elements are requested.

ChangeLog (záznam změn)

Verze | Popis
5.2.0 | The PATHINFO_FILENAME constant was added.

Příklady

Příklad 526. pathinfo() Example

<?php
$path_parts = pathinfo('/www/htdocs/index.html');

echo $path_parts['dirname'], "\n";
echo $path_parts['basename'], "\n";
echo $path_parts['extension'], "\n";
echo $path_parts['filename'], "\n"; // since PHP 5.2.0
?>

Výše uvedený příklad vypíše:

/www/htdocs
index.html
html
index

Poznámky

Poznámka: For information on retrieving the current path info, read the section on predefined reserved variables.

Viz také

dirname()
basename()
parse_url()
realpath()

Předcházející | Nahoru | Další
parse_ini_file | Domů | pclose


pclose

(PHP 4, PHP 5)

pclose — Zavře procesový soubor (rouru)

Popis

int pclose ( resource $handle )

Zavře rouru otevřenou pomocí funkce popen().

Deskriptor souboru musí být platný a musí ukazovat na rouru úspěšně otevřenou pomocí popen().

Vrací návratový kód procesu, který na rouře běžel.

Viz také popen().

Předcházející | Nahoru | Další
pathinfo | Domů | popen


popen

(PHP 4, PHP 5)

popen — Otevře procesový soubor (rouru)

Popis

resource popen ( string $command, string $mode )

Otevře rouru do procesu spuštěného rozštěpením stávajícího procesu následným a spuštěním programu specifikovaného parametrem command.

Vrací deskriptor souboru identický s tím, který vrací funkce fopen(), je však vždy pouze jednosměrný (může být otevřen pro čtení nebo zápis, nikoli současně) a na závěr musí být zavřen pomocí pclose(). Tento deskriptor může být použit funkcemi fgets(), fgetss(), a fputs().

Nastane-li chyba, vrací FALSE.

$fp = popen ("/bin/ls", "r");

Viz také pclose().

Předcházející | Nahoru | Další
pclose | Domů | readfile


readfile

(PHP 4, PHP 5)

readfile — Vypíše soubor

Popis

int readfile ( string $filename [, bool $use_include_path [, resource $context]] )

Přečte soubor a vypíše ho na standardní výstup.

Vrací počet bytů přečtených ze souboru. Pokud nastane chyba, vrátí FALSE a pokud nebyla použita notace @readfile, vypíše se chybové hlášení.

Když filename začíná "http://" (velkými nebo malými písmeny), otevře se spojení na příslušný server protokolem HTTP 1.0 a získaný dokument se vypíše na standardní výstup.

Nezpracovává HTTP přesměrování, je třeba vložit koncové lomítko za název adresáře.

Když filename začíná "ftp://" (velká či malá písmena), je otevřena FTP relace na příslušný server a dokument se vypíše na standardní výstup. Pokud server nepodporuje pasivní režim FTP komunikace, selže to.

Když filename začíná čímkoli jiným, bude otevřen obyčejný soubor (z filesystému) a jeho obsah vypsán na standardní výstup.

Můžete použít nepovinný třetí parametr a nastavit ho na "1", pokud chcete hledat soubor také v include_path.

Viz také fpassthru(),
file(), fopen(),
include(), require(), a
virtual().

Předcházející | Nahoru | Další
popen | Domů | readlink


readlink

(PHP 4, PHP 5)

readlink — Vrací cíl symbolického odkazu

Popis

string readlink ( string $path )

readlink() provádí totéž jako funkce readlink v C a vrací název souboru, na který symbolický odkaz (link) ukazuje. Při chybě vrací 0.

Viz také symlink(),
readlink() a
linkinfo().

Poznámka: Tato funkce nefunguje na Windows systémech

Předcházející | Nahoru | Další
readfile | Domů | realpath


realpath

(PHP 4, PHP 5)

realpath — Vrátí absolutní cestu v kanonickém tvaru

Popis

string realpath ( string $path )

realpath() zpracuje všechny symbolické odkazy a vyhodnotí odkazy na '/./', '/../' a samostatné znaky '/' v parametru path a vrací absolutní cestu v kanonickém tvaru. Tato výsledná cesta neobsahuje symbolické odkazy a komponenty typu '/./' or '/../'.

Příklad 527. realpath() příklad

$real_path = realpath ("../../index.php");

Předcházející | Nahoru | Další
readlink | Domů | rename


rename

(PHP 4, PHP 5, PECL zip:1.1.0-1.4.1)

rename — Přejmenuje soubor

Popis

bool rename ( string $oldname, string $newname [, resource $context] )

Pokusí se přejmenovat soubor oldname na newname.

Vrací TRUE při úspěchu a FALSE při chybě.

Předcházející | Nahoru | Další
realpath | Domů | rewind


rewind

(PHP 4, PHP 5)

rewind — Vrátí ukazatel v souboru na začátek

Popis

bool rewind ( resource $handle )

Nastaví pozici ukazatele v souboru specifikované deskriptorem fp na začátek tohoto souboru.

Nastane-li chyba, vrací 0.

Deskriptor souboru musí být platný a musí ukazovat na soubor úspěšně otevřený pomocí fopen().

Viz také fseek() a ftell().

Předcházející | Nahoru | Další
rename | Domů | rmdir


rmdir

(PHP 4, PHP 5)

rmdir — Odstraní adresář

Popis

bool rmdir ( string $dirname [, resource $context] )

Pokusí se odstranit adresář specifikovaný svým názvem. Adresář musí být prázdný a mít nastavena odpovídající oprávnění.

Nastane-li chyba, vrací 0.

Viz také mkdir().

Předcházející | Nahoru | Další
rewind | Domů | set_file_buffer


set_file_buffer

(PHP 4, PHP 5)

set_file_buffer — Nastaví buffer pro soubor

Popis

int set_file_buffer ( int $fp, int $buffer )

Výstup pomocí fwrite() je implicitně bufferován do bufferu o velikosti 8 KB. To znamená, že když chtějí dva procesy zapisovat do téhož streamu (souboru), každý je vždy po 8 KB přerušen, aby ten druhý mohl zapisovat. Funkce set_file_buffer() nastavuje buffering pro zápis přes daný deskriptor fp na buffer bytů. Pokud je buffer roven 0, zápisy nejsou bufferovány. To zajišťuje, že všechny zápisy jsou dokončeny dřív, než ostatní procesy mohou do souboru zapisovat.

Funkce vrací 0 při úspěchu nebo EOF (konec souboru) pokud požadavek nemůže být uskutečněn.

Následující příklad demonstruje, jak používat funkci set_file_buffer() k vytvoření nebufferovaného streamu.

Příklad 528. set_file_buffer() example

$fp=fopen($file, "w");
if($fp){
  set_file_buffer($fp, 0);
  fputs($fp, $output);
  fclose($fp);
}

Viz také fopen(), fwrite().

Předcházející | Nahoru | Další
rmdir | Domů | stat


stat

(PHP 4, PHP 5, PECL maxdb:7.5.00.24-7.6.00.38)

stat — Zjišťuje informace o souboru

Popis

array stat ( string $filename )

Sbírá statistiky o souboru indentifikovaném názvem filename.

Vrací pole se statistikami souboru s těmito elementy:

  1. device
  2. inode
  3. inode protection mode
  4. number of links
  5. user id of owner
  6. group id owner
  7. device type if inode device *
  8. size in bytes
  9. time of last access
  10. time of last modification
  11. time of last change
  12. blocksize for filesystem I/O *
  13. number of blocks allocated
* - platné pouze na systémechs podporou typu st_blksize -- jinde (např. na Windows) vrátí -1

Výsledek této funkce je cachován. Více informací - viz clearstatcache().

Předcházející | Nahoru | Další
set_file_buffer | Domů | symlink


symlink

(PHP 4, PHP 5)

symlink — Vytvoří symbolický odkaz

Popis

bool symlink ( string $target, string $link )

symlink() vytvoří symbolický odkaz (link) k existujícímu souboru target a nazve ho link.

Viz také link() -- vytváření hard linků, a readlink() společně s linkinfo().

Poznámka: Tato funkce nefunguje na Windows systémech.

Předcházející | Nahoru | Další
stat | Domů | tempnam


tempnam

(PHP 4, PHP 5)

tempnam — Vytvoří soubor s unikátním názvem

Popis

string tempnam ( string $dir, string $prefix )

Ve specifikovaném adresáři vytvoří dočasný soubor s unikátním názvem. Pokud adresář neexistuje, tempnam() může vytvořit soubor v systémovém adresáři pro dočasné soubory a vrátí název tohoto souboru.

Až do verze PHP 4.0.6 záviselo chování funkce tempnam() na operačním systému. Na Windows měla systémová proměnná TMP přednost před parametrem dir, na Linuxu měla předost proměnná TMPDIR a SVR4 vždy použilo parametr dir, pokud tento adresář existoval. V případě pochybností se podívejte do dokumentace k vašemu systému na funkci tempnam(3).

Poznámka: Pokud PHP nemůže vytvořit soubor v adresáři zadaném parametrem dir, použije výchozí nastavení systému.

Vrátí název nového dočasného souboru, při chybě pak FALSE.

Příklad 529. tempnam() example

<?php
$tmpfname = tempnam("/tmp", "FOO");

$handle = fopen($tmpfname, "w");
fwrite($handle, "zapisuji do dočasného souboru");
fclose($handle);

// tady dělej, co chceš

unlink($tmpfname);
?>

Poznámka: Chování této funkce bylo změněno ve verzi 4.0.3. Dočasný soubor je nyní funkcí rovněž vytvořen, protože předtím se mohlo omylem předpokládat, že soubor v souborovém systému neexistuje hned po vytvoření řetězce s jeho názvem - tedy dříve, než se skript dostal k tomu jej skutečně vytvořit. Všimněte si, že soubor musíte odstranit, pokud ho již nepotřebujete. Automaticky se tak nestane.

Viz také tmpfile() and unlink().

Předcházející | Nahoru | Další
symlink | Domů | tmpfile


tmpfile

(PHP 4, PHP 5)

tmpfile — Vytvoří dočasný soubor

Popis

resource tmpfile ( void )

Vytvoří dočasný soubor s unikátním názvem, v módu zápisu, a vrací deskriptor tohoto souboru podobně jako fopen(). Soubor se při zavření (pomocí fclose()) nebo při ukončení skriptu automaticky smaže.

Detaily viz systémová dokumentace k funkci tmpfile(3) a soubor stdio.h.

Viz také tempnam().

Předcházející | Nahoru | Další
tempnam | Domů | touch


touch

(PHP 4, PHP 5)

touch — Nastavit čas změny souboru

Popis

bool touch ( string $filename [, int $time [, int $atime]] )

Pokusí se nastavit čas změnu souboru filename na time. Pokud filename není přítomen, použije se aktuální čas.

Pokud tento soubor neexistuje, vytvoří se.

Při úspěchu vrací TRUE, jinak FALSE.

Příklad 530. Ukázka touch()

if (touch ($FileName)) {
    print "$FileName modification time has been
           changed to todays date and time";
} else {
    print "Sorry Could Not change modification time of $FileName";
}

Předcházející | Nahoru | Další
tmpfile | Domů | umask


umask

(PHP 4, PHP 5)

umask — Změní současné nastavení umask

Popis

int umask ( [int $mask] )

umask() nastaví umask PHP na & 0777 a vrátí staré nastavení umask. Pokud PHP běží jako modul serveru, je staré nastavení obnoveno po ukončení každého HTTP požadavku.

umask() bez parametrů vrací současné nastavení umask.

Poznámka: Tato funkce nemusí na Windows fungovat

Předcházející | Nahoru | Další
touch | Domů | unlink


unlink

(PHP 4, PHP 5)

unlink — Smazat soubor

Popis

bool unlink ( string $filename [, resource $context] )

Smaže filename. Podobná Unixové C funkci unlink().

Při chybě vrací 0 nebo FALSE.

Viz také rmdir() pro mazání adresářů.

Poznámka: Tato funkce nemusí na Windows fungovat

Předcházející | Nahoru | Další
umask | Domů | XLII. Filter Functions


Forms Data Format Functions

Předcházející VI. Reference funkcí Další

XXXVIII. Forms Data Format Functions

Úvod

Forms Data Format (FDF) is a format for handling forms within PDF documents. You should read the documentation at » http://partners.adobe.com/asn/acrobat/forms.jsp for more information on what FDF is and how it is used in general.

The general idea of FDF is similar to HTML forms. The difference is basically the format how data is transmitted to the server when the submit button is pressed (this is actually the Form Data Format) and the format of the form itself (which is the Portable Document Format, PDF). Processing the FDF data is one of the features provided by the fdf functions. But there is more. One may as well take an existing PDF form and populated the input fields with data without modifying the form itself. In such a case one would create a FDF document (fdf_create()) set the values of each input field (fdf_set_value()) and associate it with a PDF form (fdf_set_file()). Finally it has to be sent to the browser with MimeType application/vnd.fdf. The Acrobat reader plugin of your browser recognizes the MimeType, reads the associated PDF form and fills in the data from the FDF document.

If you look at an FDF-document with a text editor you will find a catalogue object with the name FDF. Such an object may contain a number of entries like Fields, F, Status etc.. The most commonly used entries are Fields which points to a list of input fields, and F which contains the filename of the PDF-document this data belongs to. Those entries are referred to in the FDF documentation as /F-Key or /Status-Key. Modifying this entries is done by functions like fdf_set_file() and fdf_set_status(). Fields are modified with fdf_set_value(), fdf_set_opt() etc..

Požadavky

You need the FDF toolkit SDK available from » http://partners.adobe.com/asn/acrobat/forms.jsp. As of PHP 4.3.0 you need at least SDK version 5.0. The FDF toolkit library is available in binary form only, platforms supported by Adobe are Win32, Linux, Solaris and AIX.

Instalace

You must compile PHP with --with-fdftk[=DIR].

Poznámka: If you run into problems configuring PHP with fdftk support, check whether the header file fdftk.h and the library libfdftk.so are at the right place. The configure script supports both the directory structure of the FDF SDK distribution and the usual DIR/include / DIR/lib layout, so you can point it either directly to the unpacked distribution directory or put the header file and the appropriate library for your platform into e.g. /usr/local/include and /usr/local/lib and configure with --with-fdftk=/usr/local.

Note to Win32 Users: In order for this extension to work, there are DLL files that must be available to the Windows system PATH. See the FAQ titled "How do I add my PHP directory to the PATH on Windows" for information on how to do this. Although copying DLL files from the PHP folder into the Windows system directory also works (because the system directory is by default in the systems PATH), it is not recommended. This extension requires the following files to be in the PATH: fdftk.dll

Konfigurace běhu

Toto rozšíření nemá definováno žádné konfigurační direktivy.

Typy prostředků

fdf

Most fdf functions require a fdf resource as their first parameter. A fdf resource is a handle to an opened fdf file. fdf resources may be obtained using fdf_create(), fdf_open() and fdf_open_string().

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

FDFValue (integer)
FDFStatus (integer)
FDFFile (integer)
FDFID (integer)
FDFFf (integer)
FDFSetFf (integer)
FDFClearFf (integer)
FDFFlags (integer)
FDFSetF (integer)
FDFClrF (integer)
FDFAP (integer)
FDFAS (integer)
FDFAction (integer)
FDFAA (integer)
FDFAPRef (integer)
FDFIF (integer)
FDFEnter (integer)
FDFExit (integer)
FDFDown (integer)
FDFUp (integer)
FDFFormat (integer)
FDFValidate (integer)
FDFKeystroke (integer)
FDFCalculate (integer)
FDFNormalAP (integer)
FDFRolloverAP (integer)
FDFDownAP (integer)

Příklady

The following examples shows just the evaluation of form data.

Příklad 497. Evaluating a FDF document

<?php
// Open fdf from input string provided by the extension
// The pdf form contained several input text fields with the names
// volume, date, comment, publisher, preparer, and two checkboxes
// show_publisher and show_preparer.
$fdf = fdf_open_string($HTTP_FDF_DATA);
$volume = fdf_get_value($fdf, "volume");
echo "The volume field has the value '<b>$volume</b>'<br />";

$date = fdf_get_value($fdf, "date");
echo "The date field has the value '<b>$date</b>'<br />";

$comment = fdf_get_value($fdf, "comment");
echo "The comment field has the value '<b>$comment</b>'<br />";

if (fdf_get_value($fdf, "show_publisher") == "On") {
  $publisher = fdf_get_value($fdf, "publisher");
  echo "The publisher field has the value '<b>$publisher</b>'<br />";
} else
  echo "Publisher shall not be shown.<br />";

if (fdf_get_value($fdf, "show_preparer") == "On") {
  $preparer = fdf_get_value($fdf, "preparer");
  echo "The preparer field has the value '<b>$preparer</b>'<br />";
} else
  echo "Preparer shall not be shown.<br />";
fdf_close($fdf);
?>

Obsah

fdf_add_doc_javascript — Adds javascript code to the FDF document
fdf_add_template — Adds a template into the FDF document
fdf_close — Close an FDF document
fdf_create — Create a new FDF document
fdf_enum_values — Call a user defined function for each document value
fdf_errno — Return error code for last fdf operation
fdf_error — Return error description for FDF error code
fdf_get_ap — Get the appearance of a field
fdf_get_attachment — Extracts uploaded file embedded in the FDF
fdf_get_encoding — Get the value of the /Encoding key
fdf_get_file — Get the value of the /F key
fdf_get_flags — Gets the flags of a field
fdf_get_opt — Gets a value from the opt array of a field
fdf_get_status — Get the value of the /STATUS key
fdf_get_value — Get the value of a field
fdf_get_version — Gets version number for FDF API or file
fdf_header — Sets FDF-specific output headers
fdf_next_field_name — Get the next field name
fdf_open_string — Read a FDF document from a string
fdf_open — Open a FDF document
fdf_remove_item — Sets target frame for form
fdf_save_string — Returns the FDF document as a string
fdf_save — Save a FDF document
fdf_set_ap — Set the appearance of a field
fdf_set_encoding — Sets FDF character encoding
fdf_set_file — Set PDF document to display FDF data in
fdf_set_flags — Sets a flag of a field
fdf_set_javascript_action — Sets an javascript action of a field
fdf_set_on_import_javascript — Adds javascript code to be executed when Acrobat opens the FDF
fdf_set_opt — Sets an option of a field
fdf_set_status — Set the value of the /STATUS key
fdf_set_submit_form_action — Sets a submit form action of a field
fdf_set_target_frame — Set target frame for form display
fdf_set_value — Set the value of a field
fdf_set_version — Sets version number for a FDF file
Předcházející | Nahoru | Další
fam_suspend_monitor | Domů | fdf_add_doc_javascript


fdf_add_doc_javascript

(PHP 4 >= 4.3.0, PHP 5)

fdf_add_doc_javascript — Adds javascript code to the FDF document

Popis

bool fdf_add_doc_javascript ( resource $fdf_document, string $script_name, string $script_code )

Adds a script to the FDF, which Acrobat then adds to the doc-level scripts of a document, once the FDF is imported into it.

Seznam parametrů

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

script_name

The script name.

script_code

The script code. It is strongly suggested to use \r for linebreaks within the script code.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 498. Adding JavaScript code to a FDF

<?php
$fdf = fdf_create();
fdf_add_doc_javascript($fdf, "PlusOne", "function PlusOne(x)\r{\r  return x+1;\r}\r");
fdf_save($fdf);
?>

will create a FDF like this:

%FDF-1.2
%â??Ó
1 0 obj
<<
/FDF << /JavaScript << /Doc [ (PlusOne)(function PlusOne\(x\)\r{\r  return x+1;\r}\r)] >> >>
>>
endobj
trailer
<<
/Root 1 0 R

>>
%%EOF

Předcházející | Nahoru | Další
XXXVIII. Forms Data Format Functions | Domů | fdf_add_template


fdf_add_template

(PHP 4, PHP 5)

fdf_add_template — Adds a template into the FDF document

Popis

bool fdf_add_template ( resource $fdf_document, int $newpage, string $filename, string $template, int $rename )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
fdf_add_doc_javascript | Domů | fdf_close


fdf_close

(PHP 4, PHP 5)

fdf_close — Close an FDF document

Popis

void fdf_close ( resource $fdf_document )

Closes the FDF document.

Seznam parametrů

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

fdf_open()

Předcházející | Nahoru | Další
fdf_add_template | Domů | fdf_create


fdf_create

(PHP 4, PHP 5)

fdf_create — Create a new FDF document

Popis

resource fdf_create ( void )

Creates a new FDF document.

This function is needed if one would like to populate input fields in a PDF document with data.

Návratové hodnoty

Returns a FDF document handle, or FALSE on error.

Příklady

Příklad 499. Populating a PDF document

<?php
$outfdf = fdf_create();
fdf_set_value($outfdf, "volume", $volume, 0);

fdf_set_file($outfdf, "http:/testfdf/resultlabel.pdf");
fdf_save($outfdf, "outtest.fdf");
fdf_close($outfdf);
Header("Content-type: application/vnd.fdf");
$fp = fopen("outtest.fdf", "r");
fpassthru($fp);
unlink("outtest.fdf");
?>

Viz také

fdf_close()
fdf_save()
fdf_open()

Předcházející | Nahoru | Další
fdf_close | Domů | fdf_enum_values


fdf_enum_values

(PHP 4 >= 4.3.0, PHP 5)

fdf_enum_values — Call a user defined function for each document value

Popis

bool fdf_enum_values ( resource $fdf_document, callback $function [, mixed $userdata] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
fdf_create | Domů | fdf_errno


fdf_errno

(PHP 4 >= 4.3.0, PHP 5)

fdf_errno — Return error code for last fdf operation

Popis

int fdf_errno ( void )

Gets the error code set by the last FDF function call.

A textual description of the error may be obtained using with fdf_error().

Návratové hodnoty

Returns the error code as an integer, or zero if there was no errors.

Viz také

fdf_error()

Předcházející | Nahoru | Další
fdf_enum_values | Domů | fdf_error


fdf_error

(PHP 4 >= 4.3.0, PHP 5)

fdf_error — Return error description for FDF error code

Popis

string fdf_error ( [int $error_code] )

Gets a textual description for the FDF error code given in error_code.

Seznam parametrů

error_code

An error code obtained with fdf_errno(). If not provided, this function uses the internal error code set by the last operation.

Návratové hodnoty

Returns the error message as a string, or the string no error if nothing went wrong.

Viz také

fdf_errno()

Předcházející | Nahoru | Další
fdf_errno | Domů | fdf_get_ap


fdf_get_ap

(PHP 4 >= 4.3.0, PHP 5)

fdf_get_ap — Get the appearance of a field

Popis

bool fdf_get_ap ( resource $fdf_document, string $field, int $face, string $filename )

Gets the appearance of a field (i.e. the value of the /AP key) and stores it in a file.

Seznam parametrů

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

field

face

The possible values are FDFNormalAP, FDFRolloverAP and FDFDownAP.

filename

The appearance will be stored in this parameter.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
fdf_error | Domů | fdf_get_attachment


fdf_get_attachment

(PHP 4 >= 4.3.0, PHP 5)

fdf_get_attachment — Extracts uploaded file embedded in the FDF

Popis

array fdf_get_attachment ( resource $fdf_document, string $fieldname, string $savepath )

Extracts a file uploaded by means of the "file selection" field fieldname and stores it under savepath.

Seznam parametrů

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

fieldname

savepath

May be the name of a plain file or an existing directory in which the file is to be created under its original name. Any existing file under the same name will be overwritten.

Poznámka: There seems to be no other way to find out the original filename but to store the file using a directory as savepath and check for the basename it was stored under.

Návratové hodnoty

The returned array contains the following fields:

  • path - path were the file got stored
  • size - size of the stored file in bytes
  • type - mimetype if given in the FDF

Příklady

Příklad 500. Storing an uploaded file

<?php
  $fdf = fdf_open_string($HTTP_FDF_DATA);
  $data = fdf_get_attachment($fdf, "filename", "/tmpdir");
  echo "The uploaded file is stored in $data[path]";
?>

Předcházející | Nahoru | Další
fdf_get_ap | Domů | fdf_get_encoding


fdf_get_encoding

(PHP 4 >= 4.3.0, PHP 5)

fdf_get_encoding — Get the value of the /Encoding key

Popis

string fdf_get_encoding ( resource $fdf_document )

Gets the value of the /Encoding key.

Seznam parametrů

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

Návratové hodnoty

Returns the encoding as a string. An empty string is returned if the default PDFDocEncoding/Unicode scheme is used.

Viz také

fdf_set_encoding()

Předcházející | Nahoru | Další
fdf_get_attachment | Domů | fdf_get_file


fdf_get_file

(PHP 4, PHP 5)

fdf_get_file — Get the value of the /F key

Popis

string fdf_get_file ( resource $fdf_document )

Gets the value of the /F key.

Seznam parametrů

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

Návratové hodnoty

Returns the key value, as a string.

Viz také

fdf_set_file()

Předcházející | Nahoru | Další
fdf_get_encoding | Domů | fdf_get_flags


fdf_get_flags

(PHP 4 >= 4.3.0, PHP 5)

fdf_get_flags — Gets the flags of a field

Popis

int fdf_get_flags ( resource $fdf_document, string $fieldname, int $whichflags )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
fdf_get_file | Domů | fdf_get_opt


fdf_get_opt

(PHP 4 >= 4.3.0, PHP 5)

fdf_get_opt — Gets a value from the opt array of a field

Popis

mixed fdf_get_opt ( resource $fdf_document, string $fieldname [, int $element] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
fdf_get_flags | Domů | fdf_get_status


fdf_get_status

(PHP 4, PHP 5)

fdf_get_status — Get the value of the /STATUS key

Popis

string fdf_get_status ( resource $fdf_document )

Gets the value of the /STATUS key.

Seznam parametrů

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

Návratové hodnoty

Returns the key value, as a string.

Viz také

fdf_set_status()

Předcházející | Nahoru | Další
fdf_get_opt | Domů | fdf_get_value


fdf_get_value

(PHP 4, PHP 5)

fdf_get_value — Get the value of a field

Popis

mixed fdf_get_value ( resource $fdf_document, string $fieldname [, int $which] )

Gets the value for the requested field.

Seznam parametrů

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

fieldname

Name of the FDF field, as a string.

which

Elements of an array field can be retrieved by passing this optional parameter, starting at zero. For non-array fields, this parameter will be ignored.

Návratové hodnoty

Returns the field value.

ChangeLog (záznam změn)

Verze | Popis
4.3.0 | Support for arrays and the which parameter were added.

Viz také

fdf_set_value()

Předcházející | Nahoru | Další
fdf_get_status | Domů | fdf_get_version


fdf_get_version

(PHP 4 >= 4.3.0, PHP 5)

fdf_get_version — Gets version number for FDF API or file

Popis

string fdf_get_version ( [resource $fdf_document] )

Return the FDF version for the given document, or the toolkit API version number if no parameter is given.

Seznam parametrů

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

Návratové hodnoty

Returns the version as a string. For the current FDF toolkit 5.0 the API version number is 5.0 and the document version number is either 1.2, 1.3 or 1.4.

Viz také

fdf_set_version()

Předcházející | Nahoru | Další
fdf_get_value | Domů | fdf_header


fdf_header

(PHP 4 >= 4.3.0, PHP 5)

fdf_header — Sets FDF-specific output headers

Popis

void fdf_header ( void )

This is a convenience function to set appropriate HTTP headers for FDF output. It sets the Content-type: to application/vnd.fdf.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
fdf_get_version | Domů | fdf_next_field_name


fdf_next_field_name

(PHP 4, PHP 5)

fdf_next_field_name — Get the next field name

Popis

string fdf_next_field_name ( resource $fdf_document [, string $fieldname] )

Gets the name of the field after the given field. This name can be used with several functions.

Seznam parametrů

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

fieldname

Name of the FDF field, as a string. If not given, the first field will be assumed.

Návratové hodnoty

Returns the field name as a string.

Příklady

Příklad 501. Detecting all fieldnames in a FDF

<?php
$fdf = fdf_open($HTTP_FDF_DATA);
for ($field = fdf_next_field_name($fdf);
    $field != "";
    $field = fdf_next_field_name($fdf, $field)) {
    echo "field: $field\n";
}
?>

Viz také

fdf_get_value()

Předcházející | Nahoru | Další
fdf_header | Domů | fdf_open_string


fdf_open_string

(PHP 4 >= 4.3.0, PHP 5)

fdf_open_string — Read a FDF document from a string

Popis

resource fdf_open_string ( string $fdf_data )

Reads form data from a string.

You can use fdf_open_string() together with $HTTP_FDF_DATA to process FDF form input from a remote client.

Seznam parametrů

fdf_data

The data as returned from a PDF form or created using fdf_create() and fdf_save_string().

Návratové hodnoty

Returns a FDF document handle, or FALSE on error.

Příklady

Příklad 502. Accessing the form data

<?php
$fdf = fdf_open_string($HTTP_FDF_DATA);
/* ... */
fdf_close($fdf);
?>

Viz také

fdf_open()
fdf_close()
fdf_create()
fdf_save_string()

Předcházející | Nahoru | Další
fdf_next_field_name | Domů | fdf_open


fdf_open

(PHP 4, PHP 5)

fdf_open — Open a FDF document

Popis

resource fdf_open ( string $filename )

Opens a file with form data.

You can also use fdf_open_string() to process the results of a PDF form POST request.

Seznam parametrů

filename

Path to the FDF file. This file must contain the data as returned from a PDF form or created using fdf_create() and fdf_save().

Návratové hodnoty

Returns a FDF document handle, or FALSE on error.

Příklady

Příklad 503. Accessing the form data

<?php
// Save the FDF data into a temp file
$fdffp = fopen("test.fdf", "w");
fwrite($fdffp, $HTTP_FDF_DATA, strlen($HTTP_FDF_DATA));
fclose($fdffp);

// Open temp file and evaluate data
$fdf = fdf_open("test.fdf");
/* ... */
fdf_close($fdf);
?>

Viz také

fdf_open_string()
fdf_close()
fdf_create()
fdf_save()

Předcházející | Nahoru | Další
fdf_open_string | Domů | fdf_remove_item


fdf_remove_item

(PHP 4 >= 4.3.0, PHP 5)

fdf_remove_item — Sets target frame for form

Popis

bool fdf_remove_item ( resource $fdf_document, string $fieldname, int $item )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
fdf_open | Domů | fdf_save_string


fdf_save_string

(PHP 4 >= 4.3.0, PHP 5)

fdf_save_string — Returns the FDF document as a string

Popis

string fdf_save_string ( resource $fdf_document )

Returns the FDF document as a string.

Seznam parametrů

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

Návratové hodnoty

Returns the document as a string, or FALSE on error.

Příklady

Příklad 504. Retrieving FDF as a string

<?php
$fdf = fdf_create();
fdf_set_value($fdf, "foo", "bar");
$str = fdf_save_string($fdf);
fdf_close($fdf);
echo $str;
?>

Výše uvedený příklad vypíše:

%FDF-1.2
%â??Ó
1 0 obj
<<
/FDF << /Fields 2 0 R >>
>>
endobj
2 0 obj
[
<< /T (foo)/V (bar)>>
]
endobj
trailer
<<
/Root 1 0 R

>>
%%EOF

Viz také

fdf_open_string()
fdf_close()
fdf_create()
fdf_save()

Předcházející | Nahoru | Další
fdf_remove_item | Domů | fdf_save


fdf_save

(PHP 4, PHP 5)

fdf_save — Save a FDF document

Popis

bool fdf_save ( resource $fdf_document [, string $filename] )

Saves a FDF document.

Seznam parametrů

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

filename

If provided, the resulting FDF will be written in this parameter. Otherwise, this function will write the FDF to the default PHP output stream.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

fdf_close()
fdf_create()
fdf_save_string()

Předcházející | Nahoru | Další
fdf_save_string | Domů | fdf_set_ap


fdf_set_ap

(PHP 4, PHP 5)

fdf_set_ap — Set the appearance of a field

Popis

bool fdf_set_ap ( resource $fdf_document, string $field_name, int $face, string $filename, int $page_number )

Sets the appearance of a field (i.e. the value of the /AP key).

Seznam parametrů

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

field_name

face

The possible values FDFNormalAP, FDFRolloverAP and FDFDownAP.

filename

page_number

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
fdf_save | Domů | fdf_set_encoding


fdf_set_encoding

(PHP 4 >= 4.0.7, PHP 5)

fdf_set_encoding — Sets FDF character encoding

Popis

bool fdf_set_encoding ( resource $fdf_document, string $encoding )

Sets the character encoding for the FDF document.

Seznam parametrů

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

encoding

The encoding name. The following values are supported: "Shift-JIS", "UHC", "GBK" and "BigFive".

An empty string resets the encoding to the default PDFDocEncoding/Unicode scheme.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
fdf_set_ap | Domů | fdf_set_file


fdf_set_file

(PHP 4, PHP 5)

fdf_set_file — Set PDF document to display FDF data in

Popis

bool fdf_set_file ( resource $fdf_document, string $url [, string $target_frame] )

Selects a different PDF document to display the form results in then the form it originated from.

Seznam parametrů

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

url

Should be given as an absolute URL.

target_frame

Use this parameter to specify the frame in which the document will be displayed. You can also set the default value for this parameter using fdf_set_target_frame().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 505. Passing FDF data to a second form

<?php
  /* set content type for Adobe FDF */
  fdf_header();

  /* start new fdf */
  $fdf = fdf_create();

  /* set field "foo" to value "bar" */
  fdf_set_value($fdf, "foo", "bar");

  /* tell client to display FDF data using "fdf_form.pdf" */
  fdf_set_file($fdf, "http://www.example.com/fdf_form.pdf");

  /* output fdf */
  fdf_save($fdf);

  /* clean up */
  fdf_close($fdf);
?>

Viz také

fdf_get_file()
fdf_set_target_frame()

Předcházející | Nahoru | Další
fdf_set_encoding | Domů | fdf_set_flags


fdf_set_flags

(PHP 4 >= 4.0.2, PHP 5)

fdf_set_flags — Sets a flag of a field

Popis

bool fdf_set_flags ( resource $fdf_document, string $fieldname, int $whichFlags, int $newFlags )

Sets certain flags of the given field.

Seznam parametrů

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

fieldname

Name of the FDF field, as a string.

whichFlags

newFlags

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

fdf_set_opt()

Předcházející | Nahoru | Další
fdf_set_file | Domů | fdf_set_javascript_action


fdf_set_javascript_action

(PHP 4 >= 4.0.2, PHP 5)

fdf_set_javascript_action — Sets an javascript action of a field

Popis

bool fdf_set_javascript_action ( resource $fdf_document, string $fieldname, int $trigger, string $script )

Sets a javascript action for the given field.

Seznam parametrů

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

fieldname

Name of the FDF field, as a string.

trigger

script

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

fdf_set_submit_form_action()

Předcházející | Nahoru | Další
fdf_set_flags | Domů | fdf_set_on_import_javascript


fdf_set_on_import_javascript

(PHP 4 >= 4.3.0, PHP 5)

fdf_set_on_import_javascript — Adds javascript code to be executed when Acrobat opens the FDF

Popis

bool fdf_set_on_import_javascript ( resource $fdf_document, string $script, bool $before_data_import )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Viz také

fdf_add_doc_javascript()
fdf_set_javascript_action()

Předcházející | Nahoru | Další
fdf_set_javascript_action | Domů | fdf_set_opt


fdf_set_opt

(PHP 4 >= 4.0.2, PHP 5)

fdf_set_opt — Sets an option of a field

Popis

bool fdf_set_opt ( resource $fdf_document, string $fieldname, int $element, string $str1, string $str2 )

Sets options of the given field.

Seznam parametrů

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

fieldname

Name of the FDF field, as a string.

element

str1

str2

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

fdf_set_flags()

Předcházející | Nahoru | Další
fdf_set_on_import_javascript | Domů | fdf_set_status


fdf_set_status

(PHP 4, PHP 5)

fdf_set_status — Set the value of the /STATUS key

Popis

bool fdf_set_status ( resource $fdf_document, string $status )

Sets the value of the /STATUS key. When a client receives a FDF with a status set it will present the value in an alert box.

Seznam parametrů

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

status

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

fdf_get_status()

Předcházející | Nahoru | Další
fdf_set_opt | Domů | fdf_set_submit_form_action


fdf_set_submit_form_action

(PHP 4 >= 4.0.2, PHP 5)

fdf_set_submit_form_action — Sets a submit form action of a field

Popis

bool fdf_set_submit_form_action ( resource $fdf_document, string $fieldname, int $trigger, string $script, int $flags )

Sets a submit form action for the given field.

Seznam parametrů

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

fieldname

Name of the FDF field, as a string.

trigger

script

flags

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

fdf_set_javascript_action()

Předcházející | Nahoru | Další
fdf_set_status | Domů | fdf_set_target_frame


fdf_set_target_frame

(PHP 4 >= 4.3.0, PHP 5)

fdf_set_target_frame — Set target frame for form display

Popis

bool fdf_set_target_frame ( resource $fdf_document, string $frame_name )

Sets the target frame to display a result PDF defined with fdf_save_file() in.

Seznam parametrů

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

frame_name

The frame name, as a string.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

fdf_save_file()

Předcházející | Nahoru | Další
fdf_set_submit_form_action | Domů | fdf_set_value


fdf_set_value

(PHP 4, PHP 5)

fdf_set_value — Set the value of a field

Popis

bool fdf_set_value ( resource $fdf_document, string $fieldname, mixed $value [, int $isName] )

Sets the value for the given field.

Seznam parametrů

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

fieldname

Name of the FDF field, as a string.

value

This parameter will be stored as a string unless it is an array. In this case all array elements will be stored as a value array.

isName

Poznámka: In older versions of the FDF toolkit last parameter determined if the field value was to be converted to a PDF Name (= 1) or set to a PDF String (= 0).

The value is no longer used in the current toolkit version 5.0. For compatibility reasons it is still supported as an optional parameter beginning with PHP 4.3, but ignored internally.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

ChangeLog (záznam změn)

Verze | Popis
4.3.0 | Support for arrays in the value parameter was added.

Viz také

fdf_get_value()
fdf_remove_item()

Předcházející | Nahoru | Další
fdf_set_target_frame | Domů | fdf_set_version


fdf_set_version

(PHP 4 >= 4.3.0, PHP 5)

fdf_set_version — Sets version number for a FDF file

Popis

bool fdf_set_version ( resource $fdf_document, string $version )

Sets the FDF version for the given document.

Some features supported by this extension are only available in newer FDF versions.

Seznam parametrů

fdf_document

The FDF document handle, returned by fdf_create(), fdf_open() or fdf_open_string().

version

The version number. For the current FDF toolkit 5.0, this may be either 1.2, 1.3 or 1.4.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

fdf_get_version()

Předcházející | Nahoru | Další
fdf_set_value | Domů | XXXIX. Fileinfo Functions


FriBiDi Functions

Předcházející VI. Reference funkcí Další

XLV. FriBiDi Functions

Úvod

FriBiDi is a free implementation of the » Unicode Bidirectional Algorithm.

Požadavky

You must download and install the » FriBiDi package.

Instalace

Toto rozšíření » PECL není přibaleno k PHP. Informace o instalaci tohoto PECL rozšíření lze najít v kapitole manuálu nazvané Instalace rozšíření PECL. Další informace, jako nové verze, soubory ke stažení, zdrojové soubory, správcovské informace a CHANGELOG, lze najít zde: » http://pecl.php.net/package/fribidi.

In order to use these functions you must compile PHP with Fribidi support by using the --with-fribidi[=DIR] configure option.

Windows users will enable php_fribidi.dll inside of php.ini in order to use these functions. Tuto DLL knihovnu pro rozšíření PECL můžete stahovat ze stránky » PHP Downloads nebo z » http://snaps.php.net/.

Konfigurace běhu

Typy prostředků

Toto rozšíření nemá definován žádný typ prostředku (resource).

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

FRIBIDI_CHARSET_UTF8 (integer)
Unicode
FRIBIDI_CHARSET_8859_6 (integer)
Arabic
FRIBIDI_CHARSET_8859_8 (integer)
Hebrew
FRIBIDI_CHARSET_CP1255 (integer)
Hebrew/Yiddish
FRIBIDI_CHARSET_CP1256 (integer)
Arabic
FRIBIDI_CHARSET_ISIRI_3342 (integer)
Persian
FRIBIDI_CHARSET_CAP_RTL (integer)
Used for test purposes, will treat CAPS as non-English letters
FRIBIDI_RTL (integer)
Right to left
FRIBIDI_LTR (integer)
Left to right
FRIBIDI_AUTO (integer)
Autodetect the base direction

Obsah

fribidi_log2vis — Convert a logical string to a visual one
Předcházející | Nahoru | Další
PDO_FIREBIRD DSN | Domů | fribidi_log2vis


fribidi_log2vis

(PHP 4 >= 4.0.4, PECL fribidi:1.0)

fribidi_log2vis — Convert a logical string to a visual one

Popis

string fribidi_log2vis ( string $str, string $direction, int $charset )

Converts a logical string to a visual one.

Seznam parametrů

str

The logical string.

direction

One of FRIBIDI_RTL, FRIBIDI_LTR or FRIBIDI_AUTO.

charset

One of the FRIBIDI_CHARSET_XXX constants.

Návratové hodnoty

Returns the visual string on success, or FALSE on failure.

Předcházející | Nahoru | Další
XLV. FriBiDi Functions | Domů | XLVI. FrontBase Functions


FTP Functions

Předcházející VI. Reference funkcí Další

XLVII. FTP Functions

Úvod

The functions in this extension implement client access to file servers speaking the File Transfer Protocol (FTP) as defined in » http://www.faqs.org/rfcs/rfc959. This extension is meant for detailed access to an FTP server providing a wide range of control to the executing script. If you only wish to read from or write to a file on an FTP server, consider using the ftp:// wrapper with the filesystem functions which provide a simpler and more intuitive interface.

Požadavky

Tyto funkce jsou k dispozici jako součást standardního modulu, který je vždy dostupný.

Instalace

In order to use FTP functions with your PHP configuration, you should add the --enable-ftp option when installing PHP 4 or greater or --with-ftp when using PHP 3.

Verze PHP pro Windows má vestavěnou podporu pro toto rozšíření. K použití těchto funkcí není třeba načítat žádná další rozšíření.

Konfigurace běhu

Toto rozšíření nemá definováno žádné konfigurační direktivy.

Typy prostředků

This extension uses one resource type, which is the link identifier of the FTP connection, returned by ftp_connect() or ftp_ssl_connect().

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

FTP_ASCII (integer)

FTP_TEXT (integer)

FTP_BINARY (integer)

FTP_IMAGE (integer)

FTP_TIMEOUT_SEC (integer)

See ftp_set_option() for information.

The following constants were introduced in PHP 4.3.0.

FTP_AUTOSEEK (integer)

See ftp_set_option() for information.

FTP_AUTORESUME (integer)

Automatically determine resume position and start position for GET and PUT requests (only works if FTP_AUTOSEEK is enabled)

FTP_FAILED (integer)

Asynchronous transfer has failed

FTP_FINISHED (integer)

Asynchronous transfer has finished

FTP_MOREDATA (integer)

Asynchronous transfer is still active

Příklady

Příklad 572. FTP example

<?php
// set up basic connection
$conn_id = ftp_connect($ftp_server);

// login with username and password
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// check connection
if ((!$conn_id) || (!$login_result)) {
        echo "FTP connection has failed!";
        echo "Attempted to connect to $ftp_server for user $ftp_user_name";
        exit;
    } else {
        echo "Connected to $ftp_server, for user $ftp_user_name";
    }

// upload the file
$upload = ftp_put($conn_id, $destination_file, $source_file, FTP_BINARY);

// check upload status
if (!$upload) {
        echo "FTP upload has failed!";
    } else {
        echo "Uploaded $source_file to $ftp_server as $destination_file";
    }

// close the FTP stream
ftp_close($conn_id);
?>

Obsah

ftp_alloc — Allocates space for a file to be uploaded
ftp_cdup — Changes to the parent directory
ftp_chdir — Changes the current directory on a FTP server
ftp_chmod — Set permissions on a file via FTP
ftp_close — Closes an FTP connection
ftp_connect — Opens an FTP connection
ftp_delete — Deletes a file on the FTP server
ftp_exec — Requests execution of a command on the FTP server
ftp_fget — Downloads a file from the FTP server and saves to an open file
ftp_fput — Uploads from an open file to the FTP server
ftp_get_option — Retrieves various runtime behaviours of the current FTP stream
ftp_get — Downloads a file from the FTP server
ftp_login — Logs in to an FTP connection
ftp_mdtm — Returns the last modified time of the given file
ftp_mkdir — Creates a directory
ftp_nb_continue — Continues retrieving/sending a file (non-blocking)
ftp_nb_fget — Retrieves a file from the FTP server and writes it to an open file (non-blocking)
ftp_nb_fput — Stores a file from an open file to the FTP server (non-blocking)
ftp_nb_get — Retrieves a file from the FTP server and writes it to a local file (non-blocking)
ftp_nb_put — Stores a file on the FTP server (non-blocking)
ftp_nlist — Returns a list of files in the given directory
ftp_pasv — Turns passive mode on or off
ftp_put — Uploads a file to the FTP server
ftp_pwd — Returns the current directory name
ftp_quit — Alias pro ftp_close()
ftp_raw — Sends an arbitrary command to an FTP server
ftp_rawlist — Returns a detailed list of files in the given directory
ftp_rename — Renames a file or a directory on the FTP server
ftp_rmdir — Removes a directory
ftp_set_option — Set miscellaneous runtime FTP options
ftp_site — Sends a SITE command to the server
ftp_size — Returns the size of the given file
ftp_ssl_connect — Opens an Secure SSL-FTP connection
ftp_systype — Returns the system type identifier of the remote FTP server
Předcházející | Nahoru | Další
fbsql_warnings | Domů | ftp_alloc


ftp_alloc

(PHP 5)

ftp_alloc — Allocates space for a file to be uploaded

Popis

bool ftp_alloc ( resource $ftp_stream, int $filesize [, string &$result] )

Sends an ALLO command to the remote FTP server to allocate space for a file to be uploaded.

Poznámka: Many FTP servers do not support this command. These servers may return a failure code (FALSE) indicating the command is not supported or a success code (TRUE) to indicate that pre-allocation is not necessary and the client should continue as though the operation were successful. Because of this, it may be best to reserve this function for servers which explicitly require preallocation.

Seznam parametrů

ftp_stream

The link identifier of the FTP connection.

filezise

The number of bytes to allocate.

return

A textual representation of the servers response will be returned by reference in result if a variable is provided.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 573. ftp_alloc() example

<?php

$file = "/home/user/myfile";

/* connect to the server */
$conn_id = ftp_connect('ftp.example.com');
$login_result = ftp_login($conn_id, 'anonymous', 'user@example.com');

if (ftp_alloc($conn_id, filesize($file), $result)) {
  echo "Space successfully allocated on server.  Sending $file.\n";
  ftp_put($conn_id, '/incomming/myfile', $file, FTP_BINARY);
} else {
  echo "Unable to allocate space on server.  Server said: $result\n";
}

ftp_close($conn_id);

?>

Viz také

ftp_put()
ftp_fput()

Předcházející | Nahoru | Další
XLVII. FTP Functions | Domů | ftp_cdup


ftp_cdup

(PHP 4, PHP 5)

ftp_cdup — Changes to the parent directory

Popis

bool ftp_cdup ( resource $ftp_stream )

Changes to the parent directory.

Seznam parametrů

ftp_stream

The link identifier of the FTP connection.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 574. ftp_cdup() example

<?php
// set up basic connection
$conn_id = ftp_connect($ftp_server);

// login with username and password
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// change the current directory to html
ftp_chdir($conn_id, 'html');

echo ftp_pwd($conn_id); // /html

// return to the parent directory
if (ftp_cdup($conn_id)) {
  echo "cdup successful\n";
} else {
  echo "cdup not successful\n";
}

echo ftp_pwd($conn_id); // /

ftp_close($conn_id);
?>

Viz také

ftp_chdir()
ftp_pwd()

Předcházející | Nahoru | Další
ftp_alloc | Domů | ftp_chdir


ftp_chdir

(PHP 4, PHP 5)

ftp_chdir — Changes the current directory on a FTP server

Popis

bool ftp_chdir ( resource $ftp_stream, string $directory )

Changes the current directory to the specified one.

Seznam parametrů

ftp_stream

The link identifier of the FTP connection.

directory

The target directory.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání. If changing directory fails, PHP will also throw a warning.

Příklady

Příklad 575. ftp_chdir() example

<?php

// set up basic connection
$conn_id = ftp_connect($ftp_server);

// login with username and password
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// check connection
if ((!$conn_id) || (!$login_result)) {
    die("FTP connection has failed !");
}

echo "Current directory: " . ftp_pwd($conn_id) . "\n";

// try to change the directory to somedir
if (ftp_chdir($conn_id, "somedir")) {
    echo "Current directory is now: " . ftp_pwd($conn_id) . "\n";
} else {
    echo "Couldn't change directory\n";
}

// close the connection
ftp_close($conn_id);
?>

Viz také

ftp_cdup()
ftp_pwd()

Předcházející | Nahoru | Další
ftp_cdup | Domů | ftp_chmod


ftp_chmod

(PHP 5)

ftp_chmod — Set permissions on a file via FTP

Popis

int ftp_chmod ( resource $ftp_stream, int $mode, string $filename )

Sets the permissions on the specified remote file to mode.

Seznam parametrů

ftp_stream

The link identifier of the FTP connection.

mode

The new permissions, given as an octal value.

filename

The remote file.

Návratové hodnoty

Returns the new file permissions on success or FALSE on error.

Příklady

Příklad 576. ftp_chmod() example

<?php
$file = 'public_html/index.php';

// set up basic connection
$conn_id = ftp_connect($ftp_server);

// login with username and password
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// try to chmod $file to 644
if (ftp_chmod($conn_id, 0644, $file) !== false) {
 echo "$file chmoded successfully to 644\n";
} else {
 echo "could not chmod $file\n";
}

// close the connection
ftp_close($conn_id);
?>

Viz také

chmod()

Předcházející | Nahoru | Další
ftp_chdir | Domů | ftp_close


ftp_close

(PHP 4 >= 4.2.0, PHP 5)

ftp_close — Closes an FTP connection

Popis

bool ftp_close ( resource $ftp_stream )

ftp_close() closes the given link identifier and releases the resource.

Poznámka: After calling this function, you can no longer use the FTP connection and must create a new one with ftp_connect().

Seznam parametrů

ftp_stream

The link identifier of the FTP connection.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 577. ftp_close() example

<?php

// set up basic connection
$conn_id = ftp_connect($ftp_server);

// login with username and password
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// print the current directory
echo ftp_pwd($conn_id); // /

// close this connection
ftp_close($conn_id);
?>

Viz také

ftp_connect()

Předcházející | Nahoru | Další
ftp_chmod | Domů | ftp_connect


ftp_connect

(PHP 4, PHP 5)

ftp_connect — Opens an FTP connection

Popis

resource ftp_connect ( string $host [, int $port [, int $timeout]] )

ftp_connect() opens an FTP connection to the specified host.

Seznam parametrů

host

The FTP server address. This parameter shouldn't have any trailing slashes and shouldn't be prefixed with ftp://.

port

This parameter specifies an alternate port to connect to. If it is omitted or set to zero, then the default FTP port, 21, will be used.

timeout

This parameter specifies the timeout for all subsequent network operations. If omitted, the default value is 90 seconds. The timeout can be changed and queried at any time with ftp_set_option() and ftp_get_option().

Návratové hodnoty

Returns a FTP stream on success or FALSE on error.

Příklady

Příklad 578. ftp_connect() example

<?php

$ftp_server = "ftp.example.com";

// set up a connection or die
$conn_id = ftp_connect($ftp_server) or die("Couldn't connect to $ftp_server");

?>

ChangeLog (záznam změn)

Verze | Popis
4.2.0 | timeout was added.

Viz také

ftp_close()
ftp_ssl_connect()

Předcházející | Nahoru | Další
ftp_close | Domů | ftp_delete


ftp_delete

(PHP 4, PHP 5)

ftp_delete — Deletes a file on the FTP server

Popis

bool ftp_delete ( resource $ftp_stream, string $path )

ftp_delete() deletes the file specified by path from the FTP server.

Seznam parametrů

ftp_stream

The link identifier of the FTP connection.

path

The file to delete.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 579. ftp_delete() example

<?php
$file = 'public_html/old.txt';

// set up basic connection
$conn_id = ftp_connect($ftp_server);

// login with username and password
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// try to delete $file
if (ftp_delete($conn_id, $file)) {
 echo "$file deleted successful\n";
} else {
 echo "could not delete $file\n";
}

// close the connection
ftp_close($conn_id);
?>

Předcházející | Nahoru | Další
ftp_connect | Domů | ftp_exec


ftp_exec

(PHP 4 >= 4.0.3, PHP 5)

ftp_exec — Requests execution of a command on the FTP server

Popis

bool ftp_exec ( resource $ftp_stream, string $command )

Sends a SITE EXEC command request to the FTP server.

Seznam parametrů

ftp_stream

The link identifier of the FTP connection.

command

The command to execute.

Návratové hodnoty

Returns TRUE if the command was successful (server sent response code: 200); otherwise returns FALSE.

Příklady

Příklad 580. ftp_exec() example

<?php

// variable initialization
$command = 'ls -al >files.txt';

// set up basic connection
$conn_id = ftp_connect($ftp_server);

// login with username and password
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// execute command
if (ftp_exec($conn_id, $command)) {
    echo "$command executed successfully\n";
} else {
    echo "could not execute $command\n";
}

// close the connection
ftp_close($conn_id);

?>

Viz také

ftp_raw()

Předcházející | Nahoru | Další
ftp_delete | Domů | ftp_fget


ftp_fget

(PHP 4, PHP 5)

ftp_fget — Downloads a file from the FTP server and saves to an open file

Popis

bool ftp_fget ( resource $ftp_stream, resource $handle, string $remote_file, int $mode [, int $resumepos] )

ftp_fget() retrieves remote_file from the FTP server, and writes it to the given file pointer.

Seznam parametrů

ftp_stream

The link identifier of the FTP connection.

handle

An open file pointer in which we store the data.

remote_file

The remote file path.

mode

The transfer mode. Must be either FTP_ASCII or FTP_BINARY.

resumepos

The position in the remote file to start downloading from.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 581. ftp_fget() example

<?php

// path to remote file
$remote_file = 'somefile.txt';
$local_file = 'localfile.txt';

// open some file to write to
$handle = fopen($local_file, 'w');

// set up basic connection
$conn_id = ftp_connect($ftp_server);

// login with username and password
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// try to download $remote_file and save it to $handle
if (ftp_fget($conn_id, $handle, $remote_file, FTP_ASCII, 0)) {
 echo "successfully written to $local_file\n";
} else {
 echo "There was a problem while downloading $remote_file to $local_file\n";
}

// close the connection and the file handler
ftp_close($conn_id);
fclose($handle);
?>

ChangeLog (záznam změn)

Verze | Popis
4.3.0 | resumepos was added.

Viz také

ftp_get()
ftp_nb_get()
ftp_nb_fget()

Předcházející | Nahoru | Další
ftp_exec | Domů | ftp_fput


ftp_fput

(PHP 4, PHP 5)

ftp_fput — Uploads from an open file to the FTP server

Popis

bool ftp_fput ( resource $ftp_stream, string $remote_file, resource $handle, int $mode [, int $startpos] )

ftp_fput() uploads the data from a file pointer to a remote file on the FTP server.

Seznam parametrů

ftp_stream

The link identifier of the FTP connection.

remote_file

The remote file path.

handle

An open file pointer on the local file. Reading stops at end of file.

mode

The transfer mode. Must be either FTP_ASCII or FTP_BINARY.

startpos

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 582. ftp_fput() example

<?php

// open some file for reading
$file = 'somefile.txt';
$fp = fopen($file, 'r');

// set up basic connection
$conn_id = ftp_connect($ftp_server);

// login with username and password
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// try to upload $file
if (ftp_fput($conn_id, $file, $fp, FTP_ASCII)) {
    echo "Successfully uploaded $file\n";
} else {
    echo "There was a problem while uploading $file\n";
}

// close the connection and the file handler
ftp_close($conn_id);
fclose($fp);

?>

ChangeLog (záznam změn)

Verze | Popis
4.3.0 | startpos was added.

Viz také

ftp_put()
ftp_nb_fput()
ftp_nb_put()

Předcházející | Nahoru | Další
ftp_fget | Domů | ftp_get_option


ftp_get_option

(PHP 4 >= 4.2.0, PHP 5)

ftp_get_option — Retrieves various runtime behaviours of the current FTP stream

Popis

mixed ftp_get_option ( resource $ftp_stream, int $option )

This function returns the value for the requested option from the specified FTP connection.

Seznam parametrů

ftp_stream

The link identifier of the FTP connection.

option

Currently, the following options are supported:

Tabulka 92. Supported runtime FTP options

FTP_TIMEOUT_SEC | Returns the current timeout used for network related operations.
FTP_AUTOSEEK | Returns TRUE if this option is on, FALSE otherwise.

Návratové hodnoty

Returns the value on success or FALSE if the given option is not supported. In the latter case, a warning message is also thrown.

Příklady

Příklad 583. ftp_get_option() example

<?php
// Get the timeout of the given FTP stream
$timeout = ftp_get_option($conn_id, FTP_TIMEOUT_SEC);
?>

Viz také

ftp_set_option()

Předcházející | Nahoru | Další
ftp_fput | Domů | ftp_get


ftp_get

(PHP 4, PHP 5)

ftp_get — Downloads a file from the FTP server

Popis

bool ftp_get ( resource $ftp_stream, string $local_file, string $remote_file, int $mode [, int $resumepos] )

ftp_get() retrieves a remote file from the FTP server, and saves it into a local file.

Seznam parametrů

ftp_stream

The link identifier of the FTP connection.

local_file

The local file path (will be overwritten if the file already exists).

remote_file

The remote file path.

mode

The transfer mode. Must be either FTP_ASCII or FTP_BINARY.

resumepos

The position in the remote file to start downloading from.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 584. ftp_get() example

<?php

// define some variables
$local_file = 'local.zip';
$server_file = 'server.zip';

// set up basic connection
$conn_id = ftp_connect($ftp_server);

// login with username and password
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// try to download $server_file and save to $local_file
if (ftp_get($conn_id, $local_file, $server_file, FTP_BINARY)) {
    echo "Successfully written to $local_file\n";
} else {
    echo "There was a problem\n";
}

// close the connection
ftp_close($conn_id);

?>

ChangeLog (záznam změn)

Verze | Popis
4.3.0 | resumepos was added.

Viz také

ftp_pasv()
ftp_fget()
ftp_nb_get()
ftp_nb_fget()

Předcházející | Nahoru | Další
ftp_get_option | Domů | ftp_login


ftp_login

(PHP 4, PHP 5)

ftp_login — Logs in to an FTP connection

Popis

bool ftp_login ( resource $ftp_stream, string $username, string $password )

Logs in to the given FTP stream.

Seznam parametrů

ftp_stream

The link identifier of the FTP connection.

username

The username (USER).

password

The password (PASS).

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání. If login fails, PHP will also throw a warning.

Příklady

Příklad 585. ftp_login() example

<?php

$ftp_server = "ftp.example.com";
$ftp_user = "foo";
$ftp_pass = "bar";

// set up a connection or die
$conn_id = ftp_connect($ftp_server) or die("Couldn't connect to $ftp_server");

// try to login
if (@ftp_login($conn_id, $ftp_user, $ftp_pass)) {
    echo "Connected as $ftp_user@$ftp_server\n";
} else {
    echo "Couldn't connect as $ftp_user\n";
}

// close the connection
ftp_close($conn_id);
?>

Předcházející | Nahoru | Další
ftp_get | Domů | ftp_mdtm


ftp_mdtm

(PHP 4, PHP 5)

ftp_mdtm — Returns the last modified time of the given file

Popis

int ftp_mdtm ( resource $ftp_stream, string $remote_file )

ftp_mdtm() gets the last modified time for a remote file.

Poznámka: Not all servers support this feature!

Poznámka: ftp_mdtm() does not work with directories.

Seznam parametrů

ftp_stream

The link identifier of the FTP connection.

remote_file

The file from which to extract the last modification time.

Návratové hodnoty

Returns the last modified time as a Unix timestamp on success, or -1 on error.

Příklady

Příklad 586. ftp_mdtm() example

<?php

$file = 'somefile.txt';

// set up basic connection
$conn_id = ftp_connect($ftp_server);

// login with username and password
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

//  get the last modified time
$buff = ftp_mdtm($conn_id, $file);

if ($buff != -1) {
    // somefile.txt was last modified on: March 26 2003 14:16:41.
    echo "$file was last modified on : " . date("F d Y H:i:s.", $buff);
} else {
    echo "Couldn't get mdtime";
}

// close the connection
ftp_close($conn_id);

?>

Předcházející | Nahoru | Další
ftp_login | Domů | ftp_mkdir


ftp_mkdir

(PHP 4, PHP 5)

ftp_mkdir — Creates a directory

Popis

string ftp_mkdir ( resource $ftp_stream, string $directory )

Creates the specified directory on the FTP server.

Seznam parametrů

ftp_stream

The link identifier of the FTP connection.

directory

The name of the directory that will be created.

Návratové hodnoty

Returns the newly created directory name on success or FALSE on error.

Příklady

Příklad 587. ftp_mkdir() example

<?php

$dir = 'www';

// set up basic connection
$conn_id = ftp_connect($ftp_server);

// login with username and password
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// try to create the directory $dir
if (ftp_mkdir($conn_id, $dir)) {
 echo "successfully created $dir\n";
} else {
 echo "There was a problem while creating $dir\n";
}

// close the connection
ftp_close($conn_id);
?>

Viz také

ftp_rmdir()

Předcházející | Nahoru | Další
ftp_mdtm | Domů | ftp_nb_continue


ftp_nb_continue

(PHP 4 >= 4.3.0, PHP 5)

ftp_nb_continue — Continues retrieving/sending a file (non-blocking)

Popis

int ftp_nb_continue ( resource $ftp_stream )

Continues retrieving/sending a file non-blocking.

Seznam parametrů

ftp_stream

The link identifier of the FTP connection.

Návratové hodnoty

Returns FTP_FAILED or FTP_FINISHED or FTP_MOREDATA.

Příklady

Příklad 588. ftp_nb_continue() example

<?php

// Initate the download
$ret = ftp_nb_get($my_connection, "test", "README", FTP_BINARY);
while ($ret == FTP_MOREDATA) {

   // Continue downloading...
   $ret = ftp_nb_continue($my_connection);
}
if ($ret != FTP_FINISHED) {
   echo "There was an error downloading the file...";
   exit(1);
}
?>

Předcházející | Nahoru | Další
ftp_mkdir | Domů | ftp_nb_fget


ftp_nb_fget

(PHP 4 >= 4.3.0, PHP 5)

ftp_nb_fget — Retrieves a file from the FTP server and writes it to an open file (non-blocking)

Popis

int ftp_nb_fget ( resource $ftp_stream, resource $handle, string $remote_file, int $mode [, int $resumepos] )

ftp_nb_fget() retrieves a remote file from the FTP server.

The difference between this function and ftp_fget() is that this function retrieves the file asynchronously, so your program can perform other operations while the file is being downloaded.

Seznam parametrů

ftp_stream

The link identifier of the FTP connection.

handle

An open file pointer in which we store the data.

remote_file

The remote file path.

mode

The transfer mode. Must be either FTP_ASCII or FTP_BINARY.

resumepos

Návratové hodnoty

Returns FTP_FAILED or FTP_FINISHED or FTP_MOREDATA.

Příklady

Příklad 589. ftp_nb_fget() example

<?php

// open some file for reading
$file = 'index.php';
$fp = fopen($file, 'w');

$conn_id = ftp_connect($ftp_server);

$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// Initate the download
$ret = ftp_nb_fget($conn_id, $fp, $file, FTP_BINARY);
while ($ret == FTP_MOREDATA) {

   // Do whatever you want
   echo ".";

   // Continue downloading...
   $ret = ftp_nb_continue($conn_id);
}
if ($ret != FTP_FINISHED) {
   echo "There was an error downloading the file...";
   exit(1);
}

// close filepointer
fclose($fp);
?>

Viz také

ftp_nb_get()
ftp_nb_continue()
ftp_fget()
ftp_get()

Předcházející | Nahoru | Další
ftp_nb_continue | Domů | ftp_nb_fput


ftp_nb_fput

(PHP 4 >= 4.3.0, PHP 5)

ftp_nb_fput — Stores a file from an open file to the FTP server (non-blocking)

Popis

int ftp_nb_fput ( resource $ftp_stream, string $remote_file, resource $handle, int $mode [, int $startpos] )

ftp_nb_fput() uploads the data from a file pointer to a remote file on the FTP server.

The difference between this function and the ftp_fput() is that this function uploads the file asynchronously, so your program can perform other operations while the file is being uploaded.

Seznam parametrů

ftp_stream

The link identifier of the FTP connection.

remote_file

The remote file path.

handle

An open file pointer on the local file. Reading stops at end of file.

mode

The transfer mode. Must be either FTP_ASCII or FTP_BINARY.

startpos

Návratové hodnoty

Returns FTP_FAILED or FTP_FINISHED or FTP_MOREDATA.

Příklady

Příklad 590. ftp_nb_fput() example

<?php

$file = 'index.php';

$fp = fopen($file, 'r');

$conn_id = ftp_connect($ftp_server);

$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// Initate the upload
$ret = ftp_nb_fput($conn_id, $file, $fp, FTP_BINARY);
while ($ret == FTP_MOREDATA) {

   // Do whatever you want
   echo ".";

   // Continue upload...
   $ret = ftp_nb_continue($conn_id);
}
if ($ret != FTP_FINISHED) {
   echo "There was an error uploading the file...";
   exit(1);
}

fclose($fp);
?>

Viz také

ftp_nb_put()
ftp_nb_continue()
ftp_put()
ftp_fput()

Předcházející | Nahoru | Další
ftp_nb_fget | Domů | ftp_nb_get


ftp_nb_get

(PHP 4 >= 4.3.0, PHP 5)

ftp_nb_get — Retrieves a file from the FTP server and writes it to a local file (non-blocking)

Popis

int ftp_nb_get ( resource $ftp_stream, string $local_file, string $remote_file, int $mode [, int $resumepos] )

ftp_nb_get() retrieves a remote file from the FTP server, and saves it into a local file.

The difference between this function and ftp_get() is that this function retrieves the file asynchronously, so your program can perform other operations while the file is being downloaded.

Seznam parametrů

ftp_stream

The link identifier of the FTP connection.

local_file

The local file path (will be overwritten if the file already exists).

remote_file

The remote file path.

mode

The transfer mode. Must be either FTP_ASCII or FTP_BINARY.

resumepos

Návratové hodnoty

Returns FTP_FAILED or FTP_FINISHED or FTP_MOREDATA.

Příklady

Příklad 591. ftp_nb_get() example

<?php

// Initate the download
$ret = ftp_nb_get($my_connection, "test", "README", FTP_BINARY);
while ($ret == FTP_MOREDATA) {

   // Do whatever you want
   echo ".";

   // Continue downloading...
   $ret = ftp_nb_continue($my_connection);
}
if ($ret != FTP_FINISHED) {
   echo "There was an error downloading the file...";
   exit(1);
}
?>

Příklad 592. Resuming a download with ftp_nb_get()

<?php

// Initate
$ret = ftp_nb_get($my_connection, "test", "README", FTP_BINARY,
                      filesize("test"));
// OR: $ret = ftp_nb_get($my_connection, "test", "README",
//                           FTP_BINARY, FTP_AUTORESUME);
while ($ret == FTP_MOREDATA) {

   // Do whatever you want
   echo ".";

   // Continue downloading...
   $ret = ftp_nb_continue($my_connection);
}
if ($ret != FTP_FINISHED) {
   echo "There was an error downloading the file...";
   exit(1);
}
?>

Příklad 593. Resuming a download at position 100 to a new file with ftp_nb_get()

<?php

// Disable Autoseek
ftp_set_option($my_connection, FTP_AUTOSEEK, false);

// Initiate
$ret = ftp_nb_get($my_connection, "newfile", "README", FTP_BINARY, 100);
while ($ret == FTP_MOREDATA) {

   /* ... */

   // Continue downloading...
   $ret = ftp_nb_continue($my_connection);
}
?>

In the example above, newfile is 100 bytes smaller than README on the FTP server because we started reading at offset 100. If we didn't disable FTP_AUTOSEEK, the first 100 bytes of newfile would be '\0'.

Viz také

ftp_nb_fget()
ftp_nb_continue()
ftp_fget()
ftp_get()

Předcházející | Nahoru | Další
ftp_nb_fput | Domů | ftp_nb_put


ftp_nb_put

(PHP 4 >= 4.3.0, PHP 5)

ftp_nb_put — Stores a file on the FTP server (non-blocking)

Popis

int ftp_nb_put ( resource $ftp_stream, string $remote_file, string $local_file, int $mode [, int $startpos] )

ftp_nb_put() stores a local file on the FTP server.

The difference between this function and the ftp_put() is that this function uploads the file asynchronously, so your program can perform other operations while the file is being uploaded.

Seznam parametrů

ftp_stream

The link identifier of the FTP connection.

remote_file

The remote file path.

local_file

The local file path.

mode

The transfer mode. Must be either FTP_ASCII or FTP_BINARY.

startpos

Návratové hodnoty

Returns FTP_FAILED or FTP_FINISHED or FTP_MOREDATA.

Příklady

Příklad 594. ftp_nb_put() example

<?php

// Initiate the Upload
$ret = ftp_nb_put($my_connection, "test.remote", "test.local", FTP_BINARY);
while ($ret == FTP_MOREDATA) {

   // Do whatever you want
   echo ".";

   // Continue uploading...
   $ret = ftp_nb_continue($my_connection);
}
if ($ret != FTP_FINISHED) {
   echo "There was an error uploading the file...";
   exit(1);
}
?>

Příklad 595. Resuming an upload with ftp_nb_put()

<?php

// Initiate
$ret = ftp_nb_put($my_connection, "test.remote", "test.local",
                      FTP_BINARY, ftp_size("test.remote"));
// OR: $ret = ftp_nb_put($my_connection, "test.remote", "test.local",
//                           FTP_BINARY, FTP_AUTORESUME);

while ($ret == FTP_MOREDATA) {

   // Do whatever you want
   echo ".";

   // Continue uploading...
   $ret = ftp_nb_continue($my_connection);
}
if ($ret != FTP_FINISHED) {
   echo "There was an error uploading the file...";
   exit(1);
}
?>

Viz také

ftp_nb_fput()
ftp_nb_continue()
ftp_put()
ftp_fput()

Předcházející | Nahoru | Další
ftp_nb_get | Domů | ftp_nlist


ftp_nlist

(PHP 4, PHP 5)

ftp_nlist — Returns a list of files in the given directory

Popis

array ftp_nlist ( resource $ftp_stream, string $directory )

Seznam parametrů

ftp_stream

The link identifier of the FTP connection.

directory

The directory to be listed. This parameter can also include arguments, eg. ftp_nlist($conn_id, "-la /your/dir"); Note that this parameter isn't escaped so there may be some issues with filenames containing spaces and other characters.

Návratové hodnoty

Returns an array of filenames from the specified directory on success or FALSE on error.

Příklady

Příklad 596. ftp_nlist() example

<?php

// set up basic connection
$conn_id = ftp_connect($ftp_server);

// login with username and password
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// get contents of the current directory
$contents = ftp_nlist($conn_id, ".");

// output $contents
var_dump($contents);

?>

Výše uvedený příklad vypíše něco jako:

array(3) {
  [0]=>
  string(11) "public_html"
  [1]=>
  string(10) "public_ftp"
  [2]=>
  string(3) "www"

Viz také

ftp_rawlist()

Předcházející | Nahoru | Další
ftp_nb_put | Domů | ftp_pasv


ftp_pasv

(PHP 4, PHP 5)

ftp_pasv — Turns passive mode on or off

Popis

bool ftp_pasv ( resource $ftp_stream, bool $pasv )

ftp_pasv() turns on or off passive mode. In passive mode, data connections are initiated by the client, rather than by the server. It may be needed if the client is behind firewall.

Please note that ftp_pasv() can only be called after a successfull login or otherwise it will fail.

Seznam parametrů

ftp_stream

The link identifier of the FTP connection.

pasv

If TRUE, the passive mode is turned on, else it's turned off.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 597. ftp_pasv() example

<?php
$file = 'somefile.txt';
$remote_file = 'readme.txt';

// set up basic connection
$conn_id = ftp_connect($ftp_server);

// login with username and password
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// turn passive mode on
ftp_pasv($conn_id, true);

// upload a file
if (ftp_put($conn_id, $remote_file, $file, FTP_ASCII)) {
 echo "successfully uploaded $file\n";
} else {
 echo "There was a problem while uploading $file\n";
}

// close the connection
ftp_close($conn_id);
?>

Předcházející | Nahoru | Další
ftp_nlist | Domů | ftp_put


ftp_put

(PHP 4, PHP 5)

ftp_put — Uploads a file to the FTP server

Popis

bool ftp_put ( resource $ftp_stream, string $remote_file, string $local_file, int $mode [, int $startpos] )

ftp_put() stores a local file on the FTP server.

Seznam parametrů

ftp_stream

The link identifier of the FTP connection.

remote_file

The remote file path.

local_file

The local file path.

mode

The transfer mode. Must be either FTP_ASCII or FTP_BINARY.

startpos

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 598. ftp_put() example

<?php
$file = 'somefile.txt';
$remote_file = 'readme.txt';

// set up basic connection
$conn_id = ftp_connect($ftp_server);

// login with username and password
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// upload a file
if (ftp_put($conn_id, $remote_file, $file, FTP_ASCII)) {
 echo "successfully uploaded $file\n";
} else {
 echo "There was a problem while uploading $file\n";
}

// close the connection
ftp_close($conn_id);
?>

ChangeLog (záznam změn)

Verze | Popis
4.3.0 | startpos was added.

Viz také

ftp_pasv()
ftp_fput()
ftp_nb_fput()
ftp_nb_put()

Předcházející | Nahoru | Další
ftp_pasv | Domů | ftp_pwd


ftp_pwd

(PHP 4, PHP 5)

ftp_pwd — Returns the current directory name

Popis

string ftp_pwd ( resource $ftp_stream )

Seznam parametrů

ftp_stream

The link identifier of the FTP connection.

Návratové hodnoty

Returns the current directory name or FALSE on error.

Příklady

Příklad 599. ftp_pwd() example

<?php

// set up basic connection
$conn_id = ftp_connect($ftp_server);

// login with username and password
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// change directory to public_html
ftp_chdir($conn_id, 'public_html');

// print current directory
echo ftp_pwd($conn_id); // /public_html

// close the connection
ftp_close($conn_id);
?>

Viz také

ftp_chdir()
ftp_cdup()

Předcházející | Nahoru | Další
ftp_put | Domů | ftp_quit


ftp_quit

(PHP 4, PHP 5)

ftp_quit — Alias pro ftp_close()

Popis

Tato funkce je aliasem: ftp_close().

Předcházející | Nahoru | Další
ftp_pwd | Domů | ftp_raw


ftp_raw

(PHP 5)

ftp_raw — Sends an arbitrary command to an FTP server

Popis

array ftp_raw ( resource $ftp_stream, string $command )

Sends an arbitrary command to the FTP server.

Seznam parametrů

ftp_stream

The link identifier of the FTP connection.

command

The command to execute.

Návratové hodnoty

Returns the server's response as an array of strings. No parsing is performed on the response string, nor does ftp_raw() determine if the command succeeded.

Příklady

Příklad 600. Using ftp_raw() to login to an FTP server manually.

<?php
$fp = ftp_connect("ftp.example.com");

/* This is the same as:
   ftp_login($fp, "joeblow", "secret"); */
ftp_raw($fp, "USER joeblow");
ftp_raw($fp, "PASS secret");
?>

Viz také

ftp_exec()

Předcházející | Nahoru | Další
ftp_quit | Domů | ftp_rawlist


ftp_rawlist

(PHP 4, PHP 5)

ftp_rawlist — Returns a detailed list of files in the given directory

Popis

array ftp_rawlist ( resource $ftp_stream, string $directory [, bool $recursive] )

ftp_rawlist() executes the FTP LIST command, and returns the result as an array.

Seznam parametrů

ftp_stream

The link identifier of the FTP connection.

directory

The directory path.

recursive

If set to TRUE, the issued command will be LIST -R.

Návratové hodnoty

Returns an array where each element corresponds to one line of text.

The output is not parsed in any way. The system type identifier returned by ftp_systype() can be used to determine how the results should be interpreted.

Příklady

Příklad 601. ftp_rawlist() example

<?php

// set up basic connection
$conn_id = ftp_connect($ftp_server);

// login with username and password
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// get the file list for /
$buff = ftp_rawlist($conn_id, '/');

// close the connection
ftp_close($conn_id);

// output the buffer
var_dump($buff);
?>

Výše uvedený příklad vypíše něco jako:

array(3) {
  [0]=>
  string(65) "drwxr-x---   3 vincent  vincent      4096 Jul 12 12:16 public_ftp"
  [1]=>
  string(66) "drwxr-x---  15 vincent  vincent      4096 Nov  3 21:31 public_html"
  [2]=>
  string(73) "lrwxrwxrwx   1 vincent  vincent        11 Jul 12 12:16 www -> public_html"
}

ChangeLog (záznam změn)

Verze | Popis
4.3.0 | recursive was added.

Viz také

ftp_nlist()

Předcházející | Nahoru | Další
ftp_raw | Domů | ftp_rename


ftp_rename

(PHP 4, PHP 5)

ftp_rename — Renames a file or a directory on the FTP server

Popis

bool ftp_rename ( resource $ftp_stream, string $oldname, string $newname )

ftp_rename() renames a file or a directory on the FTP server.

Seznam parametrů

ftp_stream

The link identifier of the FTP connection.

oldname

The old file/directory name.

newname

The new name.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 602. ftp_rename() example

<?php
$old_file = 'somefile.txt.bak';
$new_file = 'somefile.txt';

// set up basic connection
$conn_id = ftp_connect($ftp_server);

// login with username and password
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// try to rename $old_file to $new_file
if (ftp_rename($conn_id, $old_file, $new_file)) {
 echo "successfully renamed $old_file to $new_file\n";
} else {
 echo "There was a problem while renaming $old_file to $new_file\n";
}

// close the connection
ftp_close($conn_id);
?>

Předcházející | Nahoru | Další
ftp_rawlist | Domů | ftp_rmdir


ftp_rmdir

(PHP 4, PHP 5)

ftp_rmdir — Removes a directory

Popis

bool ftp_rmdir ( resource $ftp_stream, string $directory )

Removes the specified directory on the FTP server.

Seznam parametrů

ftp_stream

The link identifier of the FTP connection.

directory

The directory to delete. This must be either an absolute or relative path to an empty directory.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 603. ftp_rmdir() example

<?php

$dir = 'www/';

// set up basic connection
$conn_id = ftp_connect($ftp_server);

// login with username and password
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// try to delete the directory $dir
if (ftp_rmdir($conn_id, $dir)) {
    echo "Successfully deleted $dir\n";
} else {
    echo "There was a problem while deleting $dir\n";
}

ftp_close($conn_id);

?>

Viz také

ftp_mkdir()

Předcházející | Nahoru | Další
ftp_rename | Domů | ftp_set_option


ftp_set_option

(PHP 4 >= 4.2.0, PHP 5)

ftp_set_option — Set miscellaneous runtime FTP options

Popis

bool ftp_set_option ( resource $ftp_stream, int $option, mixed $value )

This function controls various runtime options for the specified FTP stream.

Seznam parametrů

ftp_stream

The link identifier of the FTP connection.

option

Currently, the following options are supported:

Tabulka 93. Supported runtime FTP options

FTP_TIMEOUT_SEC | Changes the timeout in seconds used for all network related functions. value must be an integer that is greater than 0. The default timeout is 90 seconds.
FTP_AUTOSEEK | When enabled, GET or PUT requests with a resumepos or startpos parameter will first seek to the requested position within the file. This is enabled by default.

value

This parameter depends on which option is chosen to be altered.

Návratové hodnoty

Returns TRUE if the option could be set; FALSE if not. A warning message will be thrown if the option is not supported or the passed value doesn't match the expected value for the given option.

Příklady

Příklad 604. ftp_set_option() example

<?php
// Set the network timeout to 10 seconds
ftp_set_option($conn_id, FTP_TIMEOUT_SEC, 10);
?>

Viz také

ftp_get_option()

Předcházející | Nahoru | Další
ftp_rmdir | Domů | ftp_site


ftp_site

(PHP 4, PHP 5)

ftp_site — Sends a SITE command to the server

Popis

bool ftp_site ( resource $ftp_stream, string $command )

ftp_site() sends the given SITE command to the FTP server.

SITE commands are not standardized, and vary from server to server. They are useful for handling such things as file permissions and group membership.

Seznam parametrů

ftp_stream

The link identifier of the FTP connection.

command

The SITE command. Note that this parameter isn't escaped so there may be some issues with filenames containing spaces and other characters.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 605. Sending a SITE command to an ftp server

<?php
/* Connect to FTP server */
$conn = ftp_connect('ftp.example.com');
if (!$conn) die('Unable to connect to ftp.example.com');

/* Login as "user" with password "pass" */
if (!ftp_login($conn, 'user', 'pass')) die('Error logging into ftp.example.com');

/* Issue: "SITE CHMOD 0600 /home/user/privatefile" command to ftp server */
if (ftp_site($conn, 'CHMOD 0600 /home/user/privatefile')) {
   echo "Command executed successfully.\n";
} else {
   die('Command failed.');
}
?>

Viz také

ftp_raw()

Předcházející | Nahoru | Další
ftp_set_option | Domů | ftp_size


ftp_size

(PHP 4, PHP 5)

ftp_size — Returns the size of the given file

Popis

int ftp_size ( resource $ftp_stream, string $remote_file )

ftp_size() returns the size of the given file in bytes.

Poznámka: Not all servers support this feature.

Seznam parametrů

ftp_stream

The link identifier of the FTP connection.

remote_file

The remote file.

Návratové hodnoty

Returns the file size on success, or -1 on error.

Příklady

Příklad 606. ftp_size() example

<?php

$file = 'somefile.txt';

// set up basic connection
$conn_id = ftp_connect($ftp_server);

// login with username and password
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

// get the size of $file
$res = ftp_size($conn_id, $file);

if ($res != -1) {
    echo "size of $file is $res bytes";
} else {
    echo "couldn't get the size";
}

// close the connection
ftp_close($conn_id);

?>

Viz také

ftp_rawlist()

Předcházející | Nahoru | Další
ftp_site | Domů | ftp_ssl_connect


ftp_ssl_connect

(PHP 4 >= 4.3.0, PHP 5)

ftp_ssl_connect — Opens an Secure SSL-FTP connection

Popis

resource ftp_ssl_connect ( string $host [, int $port [, int $timeout]] )

ftp_ssl_connect() opens a SSL-FTP connection to the specified host.

Why this function may not exist: ftp_ssl_connect() is only available if OpenSSL support is enabled into your version of PHP. If it's undefined and you've compiled FTP support then this is why. For Windows you must compile your own PHP binaries to support this function.

Seznam parametrů

host

The FTP server address. This parameter shouldn't have any trailing slashes and shouldn't be prefixed with ftp://.

port

This parameter specifies an alternate port to connect to. If it is omitted or set to zero, then the default FTP port, 21, will be used.

timeout

This parameter specifies the timeout for all subsequent network operations. If omitted, the default value is 90 seconds. The timeout can be changed and queried at any time with ftp_set_option() and ftp_get_option().

Návratové hodnoty

Returns a SSL-FTP stream on success or FALSE on error.

ChangeLog (záznam změn)

Verze | Popis
5.2.2 | The function was changed to return FALSE when it can't use an SSL connection, instead of fallbacking to a non-SSL one as previously.

Příklady

Příklad 607. ftp_ssl_connect() example

<?php

// set up basic ssl connection
$conn_id = ftp_ssl_connect($ftp_server);

// login with username and password
$login_result = ftp_login($conn_id, $ftp_user_name, $ftp_user_pass);

echo ftp_pwd($conn_id); // /

// close the ssl connection
ftp_close($conn_id);
?>

Viz také

ftp_connect()

Předcházející | Nahoru | Další
ftp_size | Domů | ftp_systype


ftp_systype

(PHP 4, PHP 5)

ftp_systype — Returns the system type identifier of the remote FTP server

Popis

string ftp_systype ( resource $ftp_stream )

Returns the system type identifier of the remote FTP server.

Seznam parametrů

ftp_stream

The link identifier of the FTP connection.

Návratové hodnoty

Returns the remote system type, or FALSE on error.

Příklady

Příklad 608. ftp_systype() example

<?php

// ftp connection
$ftp = ftp_connect('ftp.example.com');
ftp_login($ftp, 'user', 'password');

// get the system type
if ($type = ftp_systype($ftp)) {
    echo "Example.com is powered by $type\n";
} else {
    echo "Couldn't get the systype";
}

?>

Výše uvedený příklad vypíše něco jako:

Example.com is powered by UNIX

Předcházející | Nahoru | Další
ftp_ssl_connect | Domů | XLVIII. Funkce pro práci s funkcemi


Funkce pro práci s funkcemi

Předcházející VI. Reference funkcí Další

XLVIII. Funkce pro práci s funkcemi

Úvod

Všechny tyto funkce pokrývají různé aspekty práce s funkcemi.

Požadavky

Tyto funkce jsou k dispozici jako součást standardního modulu, který je vždy dostupný.

Instalace

K používání těchto funkcí není třeba žádná instalace, jsou součástí jádra PHP.

Konfigurace běhu

Toto rozšíření nemá definováno žádné konfigurační direktivy.

Předdefinované konstanty

Toto rozšíření nemá definovány žádné konstanty.

Obsah

call_user_func_array — Call a user function given with an array of parameters
call_user_func — Zavolat uživatelskou funkci určenou prvním argumentem
create_function — Vytvořit anonymní (lambda-style) funkci
func_get_arg — Vrátit položku ze seznamu argumentů
func_get_args — Vrátit pole obsahující seznam argumentů funkce
func_num_args — Vrátit počet argumentů předaných funkci
function_exists — Vrátit TRUE, pokud je daná funkce definována
get_defined_functions — Returns an array of all defined functions
register_shutdown_function — Zaregistrovat funkci pro provedení při ukončení běhu
register_tick_function — Register a function for execution on each tick
unregister_tick_function — De-register a function for execution on each tick
Předcházející | Nahoru | Další
ftp_systype | Domů | call_user_func_array


call_user_func_array

(PHP 4 >= 4.0.4, PHP 5)

call_user_func_array — Call a user function given with an array of parameters

Popis

mixed call_user_func_array ( callback $function, array $param_arr )

Call a user defined function with the parameters in param_arr.

Seznam parametrů

function

The function to be called.

param_arr

The parameters to be passed to the function, as an indexed array.

Návratové hodnoty

Returns the function result, or FALSE on error.

Příklady

Příklad 609. call_user_func_array() example

<?php
function debug($var, $val)
{
    echo "***DEBUGGING\nVARIABLE: $var\nVALUE:";
    if (is_array($val) || is_object($val) || is_resource($val)) {
        print_r($val);
    } else {
        echo "\n$val\n";
    }
    echo "***\n";
}

$c = mysql_connect();
$host = $_SERVER["SERVER_NAME"];

call_user_func_array('debug', array("host", $host));
call_user_func_array('debug', array("c", $c));
call_user_func_array('debug', array("_POST", $_POST));
?>

Poznámky

Poznámka: Referenced variables in param_arr are passed to the function by a reference, others are passed by a value. In other words, it does not depend on the function signature whether the parameter is passed by a value or by a reference.

Viz také

call_user_func()
informace typu callback

Předcházející | Nahoru | Další
XLVIII. Funkce pro práci s funkcemi | Domů | call_user_func


call_user_func

(PHP 4, PHP 5)

call_user_func — Zavolat uživatelskou funkci určenou prvním argumentem

Popis

mixed call_user_func ( callback $function [, mixed $parameter [, mixed $...]] )

Zavolá uživatelsky definouvanou funkci určenou argumentem function_name. Zvažte následující ukázku:

function barber ($type) {
    print "You wanted a $type haircut, no problem";
}
call_user_func ('barber', "mushroom");
call_user_func ('barber', "shave");

Předcházející | Nahoru | Další
call_user_func_array | Domů | create_function


create_function

(PHP 4 >= 4.0.1, PHP 5)

create_function — Vytvořit anonymní (lambda-style) funkci

Popis

string create_function ( string $args, string $code )

Z předaných argumentů vytvoří anonymní funkci, a vrátí unikátní název této funkce. args se obvykle předává jako string v jednoduchých uvozovkách, a doporučujeme to i pro code. Důvodem pro jednoduché uvozovky je ochrana názvů proměnných před parsováním, pokud použijete dvojité uvozovky, budete muset oescapovat názvy proměnných, např. \$avar.

Tuto funkci můžete (například) použít k vytvoření funkce z dat shromážděných za běhu programu:

Příklad 610. Vytvoření anonymní funkce pomocí create_function()

$newfunc = create_function('$a,$b','return "ln($a) + ln($b) = ".log($a * $b);');
echo "New anonymous function: $newfunc\n";
echo $newfunc(2,M_E)."\n";
// výstup
// New anonymous function: lambda_1
// ln(2) + ln(2.718281828459) = 1.6931471805599

Nebo třeba k vytvoření obecného handleru, který na předané argumenty aplikuje sadu operací:

Příklad 611. Vytvoření obecné zpracující funkce pomocí create_function()

function process($var1, $var2, $farr) {
    for ($f=0; $f < count($farr); $f++)
    echo $farr[$f]($var1,$var2)."\n";
}

// create a bunch of math functions
$f1 = 'if ($a >=0) {return "b*a^2 = ".$b*sqrt($a);} else {return false;}';
$f2 = "return \"min(b^2+a, a^2,b) = \".min(\$a*\$a+\$b,\$b*\$b+\$a);";
$f3 = 'if ($a > 0 && $b != 0) {return "ln(a)/b = ".log($a)/$b;} else {return false;}';
$farr = array(
    create_function('$x,$y', 'return "some trig: ".(sin($x) + $x*cos($y));'),
    create_function('$x,$y', 'return "a hypotenuse: ".sqrt($x*$x + $y*$y);'),
    create_function('$a,$b', $f1),
    create_function('$a,$b', $f2),
    create_function('$a,$b', $f3)
    );

echo "\nUsing the first array of anonymous functions\n";
echo "parameters: 2.3445, M_PI\n";
process(2.3445, M_PI, $farr);

// now make a bunch of string processing functions
$garr = array(
    create_function('$b,$a','if (strncmp($a,$b,3) == 0) return "** \"$a\" '.
    'and \"$b\"\n** Look the same to me! (looking at the first 3 chars)";'),
    create_function('$a,$b','; return "CRCs: ".crc32($a)." , ".crc32(b);'),
    create_function('$a,$b','; return "similar(a,b) = ".similar_text($a,$b,&$p)."($p%)";')
    );
echo "\nUsing the second array of anonymous functions\n";
process("Twas brilling and the slithy toves", "Twas the night", $garr);

když spustíte výšeuvedený kód, výstup bude:
Using the first array of anonymous functions
parameters: 2.3445, M_PI
some trig: -1.6291725057799
a hypotenuse: 3.9199852871011
b*a^2 = 4.8103313314525
min(b^2+a, a^2,b) = 8.6382729035898
ln(a/b) = 0.27122299212594

Using the second array of anonymous functions
** "Twas the night" and "Twas brilling and the slithy toves"
** Look the same to me! (looking at the first 3 chars)
CRCs: -725381282 , 1908338681
similar(a,b) = 11(45.833333333333%)
Ale zřejmě nejběžnějším využitím lambda-style (anonymních) funkcí je tvorba callback funkcí, např. pro použití v array_walk() nebo usort()

Příklad 612. Využití anonymních funkcí jako callback funkcí

$av = array("the ","a ","that ","this ");
array_walk($av, create_function('&$v,$k','$v = $v."mango";'));
print_r($av);  // for PHP 3 use var_dump()
// outputs:
// Array
// (
//   [0] => the mango
//   [1] => a mango
//   [2] => that mango
//   [3] => this mango
// )

// an array of strings ordered from shorter to longer
$sv = array("small","larger","a big string","it is a string thing");
print_r($sv);
// outputs:
// Array
// (
//   [0] => small
//   [1] => larger
//   [2] => a big string
//   [3] => it is a string thing
// )

// sort it from longer to shorter
usort($sv, create_function('$a,$b','return strlen($b) - strlen($a);'));
print_r($sv);
// outputs:
// Array
// (
//   [0] => it is a string thing
//   [1] => a big string
//   [2] => larger
//   [3] => small
// )

Předcházející | Nahoru | Další
call_user_func | Domů | func_get_arg


func_get_arg

(PHP 4, PHP 5)

func_get_arg — Vrátit položku ze seznamu argumentů

Popis

mixed func_get_arg ( int $arg_num )

Vrací argument, který je na arg_num-té pozici v seznamu argumentů užiavtelsky definované funkce. Argumenty funkcí se počítají od nuly. func_get_arg() při volání mimo definici funkce generuje varování.

Pokud je arg_num větší než počet skutečně předaných argumentů, vygeneruje varování a vrátí FALSE.

<?php
function foo() {
     $numargs = func_num_args();
     echo "Number of arguments: $numargs<br>\n";
     if ($numargs >= 2) {
     echo "Second argument is: " . func_get_arg (1) . "<br>\n";
     }
}

foo (1, 2, 3);
?>

func_get_arg() se dá použít ve spojení s func_num_args() a func_get_args() k tvorbě uživatelsky definovaných funkcí, které přijímají proměnný počet argumentů.

Poznámka: Tato funkce byla přidána v PHP 4.

Předcházející | Nahoru | Další
create_function | Domů | func_get_args


func_get_args

(PHP 4, PHP 5)

func_get_args — Vrátit pole obsahující seznam argumentů funkce

Popis

array func_get_args ( void )

Vrací pole, jehož každý prvek je odpovídající položkou seznamu argumentů současné uživatelsky definované funkce. func_get_args() při volání mimo definici funkce generuje varování.

<?php
function foo() {
    $numargs = func_num_args();
    echo "Number of arguments: $numargs<br>\n";
    if ($numargs >= 2) {
    echo "Second argument is: " . func_get_arg (1) . "<br>\n";
    }
    $arg_list = func_get_args();
    for ($i = 0; $i < $numargs; $i++) {
    echo "Argument $i is: " . $arg_list[$i] . "<br>\n";
    }
}

foo (1, 2, 3);
?>

func_get_args() se dá použít ve spojení s func_num_args() a func_get_arg() k tvorbě uživatelsky definovaných funkcí, které přijímají proměnny počet argumentů.

Poznámka: Tato funkce byla přidána v PHP 4.

Předcházející | Nahoru | Další
func_get_arg | Domů | func_num_args


func_num_args

(PHP 4, PHP 5)

func_num_args — Vrátit počet argumentů předaných funkci

Popis

int func_num_args ( void )

Vrací počet argumentů předaných současné uživatelsky definované funkci. func_num_args() pri volání mimo definici funkce generuje warning. definition.

<?php
function foo() {
    $numargs = func_num_args();
    echo "Number of arguments: $numargs\n";
}

foo (1, 2, 3);    // Prints 'Number of arguments: 3'
?>

func_num_args() se dá použit ve spojení s func_get_arg() a func_get_args() k tvorbě uživatelsky definovaných funkcí, které přijímají proměnný počet argumentů.

Poznámka: Tato funkce byla přidána v PHP 4.

Předcházející | Nahoru | Další
func_get_args | Domů | function_exists


function_exists

(PHP 4, PHP 5)

function_exists — Vrátit TRUE, pokud je daná funkce definována

Popis

bool function_exists ( string $function_name )

Ověří přítomnost funkce function_name v seznamu definovaných funkcí. Pokud daná funkce existuje, vrací TRUE, jinak FALSE.

if (function_exists('imap_open')) {
    echo "IMAP functions are available.<br>\n";
} else {
    echo "IMAP functions are not available.<br>\n";
}
Pozn.: název funkce může existovat i v případě, že je samotná funkce nepoužitelná kvůli konfiguraci nebo volbám zadaným při kompilaci.

Viz také method_exists().

Předcházející | Nahoru | Další
func_num_args | Domů | get_defined_functions


get_defined_functions

(PHP 4 >= 4.0.4, PHP 5)

get_defined_functions — Returns an array of all defined functions

Popis

array get_defined_functions ( void )

Gets an array of all defined functions.

Návratové hodnoty

Returns an multidimensional array containing a list of all defined functions, both built-in (internal) and user-defined. The internal functions will be accessible via $arr["internal"], and the user defined ones using $arr["user"] (see example below).

Příklady

Příklad 613. get_defined_functions() example

<?php
function myrow($id, $data)
{
    return "<tr><th>$id</th><td>$data</td></tr>\n";
}

$arr = get_defined_functions();

print_r($arr);
?>

Výše uvedený příklad vypíše něco jako:

Array
(
    [internal] => Array
        (
            [0] => zend_version
            [1] => func_num_args
            [2] => func_get_arg
            [3] => func_get_args
            [4] => strlen
            [5] => strcmp
            [6] => strncmp
            ...
            [750] => bcscale
            [751] => bccomp
        )

    [user] => Array
        (
            [0] => myrow
        )

)

Viz také

function_exists()
get_defined_vars()
get_defined_constants()

Předcházející | Nahoru | Další
function_exists | Domů | register_shutdown_function


register_shutdown_function

(PHP 4, PHP 5)

register_shutdown_function — Zaregistrovat funkci pro provedení při ukončení běhu

Popis

void register_shutdown_function ( callback $function [, mixed $parameter [, mixed $...]] )

Zaregistruje funkci udanou v func pro provedení po dokončení běhu skriptu.

Běžné problémy:

Jelikož tato funkce nemůže poslat browseru žádný výstup, nebudete ji moci debugovat pomocí příkazů jako print() nebo echo().

Předcházející | Nahoru | Další
get_defined_functions | Domů | register_tick_function


register_tick_function

(PHP 4 >= 4.0.3, PHP 5)

register_tick_function — Register a function for execution on each tick

Popis

bool register_tick_function ( callback $function [, mixed $arg [, mixed $...]] )

Registers the given function to be executed when a tick is called.

Seznam parametrů

function

The function name as a string, or an array consisting of an object and a method.

arg

...

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 614. register_tick_function() example

<?php
// using a function as the callback
register_tick_function('my_function', true);

// using an object->method
$object = new my_class();
register_tick_function(array(&$object, 'my_method'), true);
?>

Poznámky

Varování

register_tick_function() should not be used with threaded web server modules. Ticks are not working in ZTS mode and may crash your web server.

Viz také

declare
unregister_tick_function()

Předcházející | Nahoru | Další
register_shutdown_function | Domů | unregister_tick_function


unregister_tick_function

(PHP 4 >= 4.0.3, PHP 5)

unregister_tick_function — De-register a function for execution on each tick

Popis

void unregister_tick_function ( string $function_name )

De-registers the function named by function_name so it is no longer executed when a tick is called.

Seznam parametrů

function_name

The function name, as a string.

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

register_tick_function()

Předcházející | Nahoru | Další
register_tick_function | Domů | XLIX. GeoIP Functions


Gettext

Předcházející VI. Reference funkcí Další

L. Gettext

Úvod

Gettext funkce implementují NLS (Native Language Support) API, které se dá použít k internacionalizaci vašich PHP aplikací. Důkladné vysvětlení těchto funkcí viz dokumentaci Gettext na vašem systému nebo na » http://www.gnu.org/software/gettext/manual/gettext.html.

Požadavky

Aby se daly tyto funkce použít, musíte stáhnout a nainstalovat GNU gettext z » http://www.gnu.org/software/gettext/gettext.html.

Instalace

Pro podporu GNU Gettext v PHP musíte přidat volbu --with-gettext[=DIR], kde DIR je instalační adresář Gettext, ve výchozím nastavení to je /usr/local.

Poznámka pro uživatele Win32: Abyste mohli tento modul používat pod Windows, musíte zkopírovat soubor gnu_gettext.dll z adresáře DLL disribučního archivu PHP/Win32 do adresáře SYSTEM32 vašich Windows. (Např.: C:\WINNT\SYSTEM32 nebo C:\WINDOWS\SYSTEM32). Počínaje PHP 4.2.3 se jméno souboru změnilo na libintl-1.dll, který vyžaduje, aby byl zkopírován i soubor iconv.dll.

Konfigurace běhu

Toto rozšíření nemá definováno žádné konfigurační direktivy.

Typy prostředků

Toto rozšíření nemá definován žádný typ prostředku (resource).

Předdefinované konstanty

Toto rozšíření nemá definovány žádné konstanty.

Obsah

bind_textdomain_codeset — Specify the character encoding in which the messages from the DOMAIN message catalog will be returned
bindtextdomain — Nastavit cestu pro doménu
dcgettext — Změnit doménu pro jediné vyhledání
dcngettext — Plural version of dcgettext
dgettext — Změnit současnou doménu
dngettext — Plural version of dgettext
gettext — Vyhledat zprávu v současné doméně
ngettext — Plural version of gettext
textdomain — Nastavit výchozí doménu
Předcházející | Nahoru | Další
geoip_region_by_name | Domů | bind_textdomain_codeset


bind_textdomain_codeset

(PHP 4 >= 4.2.0, PHP 5)

bind_textdomain_codeset — Specify the character encoding in which the messages from the DOMAIN message catalog will be returned

Popis

string bind_textdomain_codeset ( string $domain, string $codeset )

With bind_textdomain_codeset(), you can set in which encoding will be messages from domain returned by gettext() and similar functions.

Seznam parametrů

domain

The domain

codeset

The code set

Návratové hodnoty

A string on success.

Předcházející | Nahoru | Další
L. Gettext | Domů | bindtextdomain


bindtextdomain

(PHP 4, PHP 5)

bindtextdomain — Nastavit cestu pro doménu

Popis

string bindtextdomain ( string $domain, string $directory )

Funkce bindtextdomain() nastaví cestu pro doménu.

Předcházející | Nahoru | Další
bind_textdomain_codeset | Domů | dcgettext


dcgettext

(PHP 4, PHP 5)

dcgettext — Změnit doménu pro jediné vyhledání

Popis

string dcgettext ( string $domain, string $message, int $category )

Tato funkce vám umožní zmenit současnou doménu pro jediné vyhledání zprávy. Umožňuje také specifikovat kategorii.

Předcházející | Nahoru | Další
bindtextdomain | Domů | dcngettext


dcngettext

(PHP 4 >= 4.2.0, PHP 5)

dcngettext — Plural version of dcgettext

Popis

string dcngettext ( string $domain, string $msgid1, string $msgid2, int $n, int $category )

This function allows you to override the current domain for a single plural message lookup.

Seznam parametrů

domain

The domain

msgid1

msgid2

n

category

Návratové hodnoty

A string on success.

Viz také

ngettext()

Předcházející | Nahoru | Další
dcgettext | Domů | dgettext


dgettext

(PHP 4, PHP 5)

dgettext — Změnit současnou doménu

Popis

string dgettext ( string $domain, string $message )

Funkce dgettext() umožňuje změnit současnou doménu pro jediné vyhledání zprávy.

Předcházející | Nahoru | Další
dcngettext | Domů | dngettext


dngettext

(PHP 4 >= 4.2.0, PHP 5)

dngettext — Plural version of dgettext

Popis

string dngettext ( string $domain, string $msgid1, string $msgid2, int $n )

The dngettext() function allows you to override the current domain for a single plural message lookup.

Seznam parametrů

domain

The domain

msgid1

msgid2

n

Návratové hodnoty

A string on success.

Viz také

ngettext()

Předcházející | Nahoru | Další
dgettext | Domů | gettext


gettext

(PHP 4, PHP 5, PECL axis2:0.1.0-0.1.1)

gettext — Vyhledat zprávu v současné doméně

Popis

string gettext ( string $message )

Tato funkce vrátí přeložený řetězec, pokud jej najde v překladové tabulce, nebo předaný řetězec, pokud jej nenajde. Jako alias k této funkci můžete použít podtržítko.

Příklad 628. gettext()-check

<?php
// Set language to German
putenv ("LANG=de");

// Specify location of translation tables
bindtextdomain ("myPHPApp", "./locale");

// Choose domain
textdomain ("myPHPApp");

// Print a test message
print (gettext ("Vítejte v mé PHP Aplikaci"));
?>

Předcházející | Nahoru | Další
dngettext | Domů | ngettext


ngettext

(PHP 4 >= 4.2.0, PHP 5)

ngettext — Plural version of gettext

Popis

string ngettext ( string $msgid1, string $msgid2, int $n )

The plural version of gettext(). Some languages have more than one form for plural messages dependent on the count.

Seznam parametrů

msgid1

msgid2

n

Návratové hodnoty

Returns correct plural form of message identified by msgid1 and msgid2 for count n.

Příklady

Příklad 629. ngettext() example

<?php

setlocale(LC_ALL, 'cs_CZ');
printf(ngettext("%d window", "%d windows", 1), 1); // 1 okno
printf(ngettext("%d window", "%d windows", 2), 2); // 2 okna
printf(ngettext("%d window", "%d windows", 5), 5); // 5 oken

?>

Předcházející | Nahoru | Další
gettext | Domů | textdomain


textdomain

(PHP 4, PHP 5)

textdomain — Nastavit výchozí doménu

Popis

string textdomain ( string $text_domain )

Tato funkce nastaví doménu pro vyhledávání při volání funkce gettext(), obvykle pojmenovanou podle aplikace. Vrátí předchozí výchozí doménu. Při volání bez argumentů vrátí současné nastavení, aniž by jej měnila.

Předcházející | Nahoru | Další
ngettext | Domů | LI. GMP Functions


GMP Functions

Předcházející VI. Reference funkcí Další

LI. GMP Functions

Úvod

These functions allow you to work with arbitrary-length integers using the GNU MP library.

These functions have been added in PHP 4.0.4.

Poznámka: Most GMP functions accept GMP number arguments, defined as resource below. However, most of these functions will also accept numeric and string arguments, given that it is possible to convert the latter to a number. Also, if there is a faster function that can operate on integer arguments, it would be used instead of the slower function when the supplied arguments are integers. This is done transparently, so the bottom line is that you can use integers in every function that expects GMP number. See also the gmp_init() function.

Varování

If you want to explicitly specify a large integer, specify it as a string. If you don't do that, PHP will interpret the integer-literal first, possibly resulting in loss of precision, even before GMP comes into play.

Poznámka: This extension is available on Windows platforms since PHP 5.1.0.

Požadavky

You can download the GMP library from » http://www.swox.com/gmp/. This site also has the GMP manual available.

You will need GMP version 2 or better to use these functions. Some functions may require more recent version of the GMP library.

Instalace

In order to have these functions available, you must compile PHP with GMP support by using the --with-gmp option.

Konfigurace běhu

Toto rozšíření nemá definováno žádné konfigurační direktivy.

Typy prostředků

Most GPM functions operate on or return GMP number resources.

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

GMP_ROUND_ZERO (integer)
GMP_ROUND_PLUSINF (integer)
GMP_ROUND_MINUSINF (integer)
GMP_VERSION (string)
The GMP library version

Příklady

Příklad 630. Factorial function using GMP

<?php
function fact($x)
{
    $return = 1;
    for ($i=2; $i < $x; $i++) {
        $return = gmp_mul($return, $i);
    }
    return $return;
}

echo gmp_strval(fact(1000)) . "\n";
?>

This will calculate factorial of 1000 (pretty big number) very fast.

Viz také

More mathematical functions can be found in the sections BCMath Arbitrary Precision Mathematics Functions and Mathematical Functions.

Obsah

gmp_abs — Absolute value
gmp_add — Add numbers
gmp_and — Logical AND
gmp_clrbit — Clear bit
gmp_cmp — Compare numbers
gmp_com — Calculates one's complement
gmp_div_q — Divide numbers
gmp_div_qr — Divide numbers and get quotient and remainder
gmp_div_r — Remainder of the division of numbers
gmp_div — Alias pro gmp_div_q()
gmp_divexact — Exact division of numbers
gmp_fact — Factorial
gmp_gcd — Calculate GCD
gmp_gcdext — Calculate GCD and multipliers
gmp_hamdist — Hamming distance
gmp_init — Create GMP number
gmp_intval — Convert GMP number to integer
gmp_invert — Inverse by modulo
gmp_jacobi — Jacobi symbol
gmp_legendre — Legendre symbol
gmp_mod — Modulo operation
gmp_mul — Multiply numbers
gmp_neg — Negate number
gmp_nextprime — Find next prime number
gmp_or — Logical OR
gmp_perfect_square — Perfect square check
gmp_popcount — Population count
gmp_pow — Raise number into power
gmp_powm — Raise number into power with modulo
gmp_prob_prime — Check if number is "probably prime"
gmp_random — Random number
gmp_scan0 — Scan for 0
gmp_scan1 — Scan for 1
gmp_setbit — Set bit
gmp_sign — Sign of number
gmp_sqrt — Calculate square root
gmp_sqrtrem — Square root with remainder
gmp_strval — Convert GMP number to string
gmp_sub — Subtract numbers
gmp_testbit — Tests if a bit is set
gmp_xor — Logical XOR
Předcházející | Nahoru | Další
textdomain | Domů | gmp_abs


gmp_abs

(PHP 4 >= 4.0.4, PHP 5)

gmp_abs — Absolute value

Popis

resource gmp_abs ( resource $a )

Get the absolute value of a number.

Seznam parametrů

a

It can be either a GMP number resource, or a numeric string given that it is possible to convert the latter to a number.

Návratové hodnoty

Returns the absolute value of a, as a GMP number.

Příklady

Příklad 631. gmp_abs() example

<?php
$abs1 = gmp_abs("274982683358");
$abs2 = gmp_abs("-274982683358");

echo gmp_strval($abs1) . "\n";
echo gmp_strval($abs2) . "\n";
?>

Výše uvedený příklad vypíše:

274982683358
274982683358

Předcházející | Nahoru | Další
LI. GMP Functions | Domů | gmp_add


gmp_add

(PHP 4 >= 4.0.4, PHP 5)

gmp_add — Add numbers

Popis

resource gmp_add ( resource $a, resource $b )

Add two numbers.

Seznam parametrů

a

A number that will be added.

It can be either a GMP number resource, or a numeric string given that it is possible to convert the latter to a number.

b

A number that will be added.

It can be either a GMP number resource, or a numeric string given that it is possible to convert the latter to a number.

Návratové hodnoty

A GMP number representing the sum of the arguments.

Příklady

Příklad 632. gmp_add() example

<?php
$sum = gmp_add("123456789012345", "76543210987655");
echo gmp_strval($sum) . "\n";
?>

Výše uvedený příklad vypíše:

200000000000000

Předcházející | Nahoru | Další
gmp_abs | Domů | gmp_and


gmp_and

(PHP 4 >= 4.0.4, PHP 5)

gmp_and — Logical AND

Popis

resource gmp_and ( resource $a, resource $b )

Calculates logical AND of two GMP numbers.

Seznam parametrů

a

It can be either a GMP number resource, or a numeric string given that it is possible to convert the latter to a number.

b

It can be either a GMP number resource, or a numeric string given that it is possible to convert the latter to a number.

Návratové hodnoty

A GMP number representing the logical AND comparison.

Příklady

Příklad 633. gmp_and() example

<?php
$and1 = gmp_and("0xfffffffff4", "0x4");
$and2 = gmp_and("0xfffffffff4", "0x8");
echo gmp_strval($and1) . "\n";
echo gmp_strval($and2) . "\n";
?>

Výše uvedený příklad vypíše:

4
0

Předcházející | Nahoru | Další
gmp_add | Domů | gmp_clrbit


gmp_clrbit

(PHP 4 >= 4.0.4, PHP 5)

gmp_clrbit — Clear bit

Popis

void gmp_clrbit ( resource &$a, int $index )

Clears (sets to 0) bit index in a. The index starts at 0.

Seznam parametrů

a

It can be either a GMP number resource, or a numeric string given that it is possible to convert the latter to a number.

index

It can be either a GMP number resource, or a numeric string given that it is possible to convert the latter to a number.

Návratové hodnoty

A GMP number resource.

Příklady

Příklad 634. gmp_clrbit() example

<?php
$a = gmp_init("0xff");
gmp_clrbit($a, 0); // index starts at 0, least significant bit
echo gmp_strval($a) . "\n";
?>

Výše uvedený příklad vypíše:

254

Poznámky

Poznámka: Unlike most of the other GMP functions, gmp_clrbit() must be called with a GMP resource that already exists (using gmp_init() for example). One will not be automatically created.

Viz také

gmp_setbit()
gmp_testbit()

Předcházející | Nahoru | Další
gmp_and | Domů | gmp_cmp


gmp_cmp

(PHP 4 >= 4.0.4, PHP 5)

gmp_cmp — Compare numbers

Popis

int gmp_cmp ( resource $a, resource $b )

Compares two numbers.

Seznam parametrů

a

It can be either a GMP number resource, or a numeric string given that it is possible to convert the latter to a number.

b

It can be either a GMP number resource, or a numeric string given that it is possible to convert the latter to a number.

Návratové hodnoty

Returns a positive value if a > b, zero if a = b and a negative value if a < b.

Příklady

Příklad 635. gmp_cmp() example

<?php
$cmp1 = gmp_cmp("1234", "1000"); // greater than
$cmp2 = gmp_cmp("1000", "1234"); // less than
$cmp3 = gmp_cmp("1234", "1234"); // equal to

echo "$cmp1 $cmp2 $cmp3\n";
?>

Výše uvedený příklad vypíše:

1 -1 0

Předcházející | Nahoru | Další
gmp_clrbit | Domů | gmp_com


gmp_com

(PHP 4 >= 4.0.4, PHP 5)

gmp_com — Calculates one's complement

Popis

resource gmp_com ( resource $a )

Returns the one's complement of a.

Seznam parametrů

a

It can be either a GMP number resource, or a numeric string given that it is possible to convert the latter to a number.

Návratové hodnoty

Returns the one's complement of a, as a GMP number.

Příklady

Příklad 636. gmp_com() example

<?php
$com = gmp_com("1234");
echo gmp_strval($com) . "\n";
?>

Výše uvedený příklad vypíše:

-1235

Předcházející | Nahoru | Další
gmp_cmp | Domů | gmp_div_q


gmp_div_q

(PHP 4 >= 4.0.4, PHP 5)

gmp_div_q — Divide numbers

Popis

resource gmp_div_q ( resource $a, resource $b [, int $round] )

Divides a by b and returns the integer result.

Seznam parametrů

a

The number being divided.

It can be either a GMP number resource, or a numeric string given that it is possible to convert the latter to a number.

b

The number that a is being divided by.

It can be either a GMP number resource, or a numeric string given that it is possible to convert the latter to a number.

round

The result rounding is defined by the round, which can have the following values:

  • GMP_ROUND_ZERO: The result is truncated towards 0.
  • GMP_ROUND_PLUSINF: The result is rounded towards +infinity.
  • GMP_ROUND_MINUSINF: The result is rounded towards -infinity.

It can be either a GMP number resource, or a numeric string given that it is possible to convert the latter to a number.

Návratové hodnoty

A GMP number resource.

Příklady

Příklad 637. gmp_div_q() example

<?php
$div1 = gmp_div_q("100", "5");
echo gmp_strval($div1) . "\n";

$div2 = gmp_div_q("1", "3");
echo gmp_strval($div2) . "\n";

$div3 = gmp_div_q("1", "3", GMP_ROUND_PLUSINF);
echo gmp_strval($div3) . "\n";

$div4 = gmp_div_q("-1", "4", GMP_ROUND_PLUSINF);
echo gmp_strval($div4) . "\n";

$div5 = gmp_div_q("-1", "4", GMP_ROUND_MINUSINF);
echo gmp_strval($div5) . "\n";
?>

Výše uvedený příklad vypíše:

20
0
1
0
-1

Poznámky

Poznámka: This function can also be called as gmp_div().

Viz také

gmp_div_r()
gmp_div_qr()

Předcházející | Nahoru | Další
gmp_com | Domů | gmp_div_qr


gmp_div_qr

(PHP 4 >= 4.0.4, PHP 5)

gmp_div_qr — Divide numbers and get quotient and remainder

Popis

array gmp_div_qr ( resource $n, resource $d [, int $round] )

The function divides n by d.

Seznam parametrů

n

The number being divided.

It can be either a GMP number resource, or a numeric string given that it is possible to convert the latter to a number.

d

The number that n is being divided by.

It can be either a GMP number resource, or a numeric string given that it is possible to convert the latter to a number.

round

See the gmp_div_q() function for description of the round argument.

Návratové hodnoty

Returns an array, with the first element being [n/d] (the integer result of the division) and the second being (n - [n/d] * d) (the remainder of the division).

Příklady

Příklad 638. Division of GMP numbers

<?php
$a = gmp_init("0x41682179fbf5");
$res = gmp_div_qr($a, "0xDEFE75");
printf("Result is: q - %s, r - %s",
       gmp_strval($res[0]), gmp_strval($res[1]));
?>

Viz také

gmp_div_q()
gmp_div_r()

Předcházející | Nahoru | Další
gmp_div_q | Domů | gmp_div_r


gmp_div_r

(PHP 4 >= 4.0.4, PHP 5)

gmp_div_r — Remainder of the division of numbers

Popis

resource gmp_div_r ( resource $n, resource $d [, int $round] )

Calculates remainder of the integer division of n by d. The remainder has the sign of the n argument, if not zero.

Seznam parametrů

n

The number being divided.

It can be either a GMP number resource, or a numeric string given that it is possible to convert the latter to a number.

d

The number that n is being divided by.

It can be either a GMP number resource, or a numeric string given that it is possible to convert the latter to a number.

round

See the gmp_div_q() function for description of the round argument.

Návratové hodnoty

The remainder, as a GMP number.

Příklady

Příklad 639. gmp_div_r() example

<?php
$div = gmp_div_r("105", "20");
echo gmp_strval($div) . "\n";
?>

Výše uvedený příklad vypíše:

5

Viz také

gmp_div_q()
gmp_div_qr()

Předcházející | Nahoru | Další
gmp_div_qr | Domů | gmp_div


gmp_div

(PHP 4 >= 4.0.4, PHP 5)

gmp_div — Alias pro gmp_div_q()

Popis

Tato funkce je aliasem: gmp_div_q().

Předcházející | Nahoru | Další
gmp_div_r | Domů | gmp_divexact


gmp_divexact

(PHP 4 >= 4.0.4, PHP 5)

gmp_divexact — Exact division of numbers

Popis

resource gmp_divexact ( resource $n, resource $d )

Divides n by d, using fast "exact division" algorithm. This function produces correct results only when it is known in advance that d divides n.

Seznam parametrů

n

The number being divided.

It can be either a GMP number resource, or a numeric string given that it is possible to convert the latter to a number.

d

The number that a is being divided by.

It can be either a GMP number resource, or a numeric string given that it is possible to convert the latter to a number.

Návratové hodnoty

A GMP number resource.

Příklady

Příklad 640. gmp_divexact() example

<?php
$div1 = gmp_divexact("10", "2");
echo gmp_strval($div1) . "\n";

$div2 = gmp_divexact("10", "3"); // bogus result
echo gmp_strval($div2) . "\n";
?>

Výše uvedený příklad vypíše:

5
2863311534

Předcházející | Nahoru | Další
gmp_div | Domů | gmp_fact


gmp_fact

(PHP 4 >= 4.0.4, PHP 5)

gmp_fact — Factorial

Popis

resource gmp_fact ( int $a )

Calculates factorial (a!) of a.

Seznam parametrů

a

The factorial number.

It can be either a GMP number resource, or a numeric string given that it is possible to convert the latter to a number.

Návratové hodnoty

A GMP number resource.

Příklady

Příklad 641. gmp_fact() example

<?php
$fact1 = gmp_fact(5); // 5 * 4 * 3 * 2 * 1
echo gmp_strval($fact1) . "\n";

$fact2 = gmp_fact(50); // 50 * 49 * 48, ... etc
echo gmp_strval($fact2) . "\n";
?>

Výše uvedený příklad vypíše:

120
30414093201713378043612608166064768844377641568960512000000000000

Předcházející | Nahoru | Další
gmp_divexact | Domů | gmp_gcd


gmp_gcd

(PHP 4 >= 4.0.4, PHP 5)

gmp_gcd — Calculate GCD

Popis

resource gmp_gcd ( resource $a, resource $b )

Calculate greatest common divisor of a and b. The result is always positive even if either of, or both, input operands are negative.

Seznam parametrů

a

It can be either a GMP number resource, or a numeric string given that it is possible to convert the latter to a number.

b

It can be either a GMP number resource, or a numeric string given that it is possible to convert the latter to a number.

Návratové hodnoty

A positive GMP number that divides into both a and b.

Příklady

Příklad 642. gmp_gcd() example

<?php
$gcd = gmp_gcd("12", "21");
echo gmp_strval($gcd) . "\n";
?>

Výše uvedený příklad vypíše:

3

Předcházející | Nahoru | Další
gmp_fact | Domů | gmp_gcdext


gmp_gcdext

(PHP 4 >= 4.0.4, PHP 5)

gmp_gcdext — Calculate GCD and multipliers

Popis

array gmp_gcdext ( resource $a, resource $b )

Calculates g, s, and t, such that a*s + b*t = g = gcd(a,b), where gcd is the greatest common divisor. Returns an array with respective elements g, s and t.

This function can be used to solve linear Diophantine equations in two variables. These are equations that allow only integer solutions and have the form: a*x + b*y = c. For more information, go to the » "Diophantine Equation" page at MathWorld

Seznam parametrů

a

It can be either a GMP number resource, or a numeric string given that it is possible to convert the latter to a number.

b

It can be either a GMP number resource, or a numeric string given that it is possible to convert the latter to a number.

Návratové hodnoty

An array of GMP numbers.

Příklady

Příklad 643. Solving a linear Diophantine equation

<?php
// Solve the equation a*s + b*t = g
// where a = 12, b = 21, g = gcd(12, 21) = 3
$a = gmp_init(12);
$b = gmp_init(21);
$g = gmp_gcd($a, $b);
$r = gmp_gcdext($a, $b);

$check_gcd = (gmp_strval($g) == gmp_strval($r['g']));
$eq_res = gmp_add(gmp_mul($a, $r['s']), gmp_mul($b, $r['t']));
$check_res = (gmp_strval($g) == gmp_strval($eq_res));

if ($check_gcd && $check_res) {
    $fmt = "Solution: %d*%d + %d*%d = %d\n";
    printf($fmt, gmp_strval($a), gmp_strval($r['s']), gmp_strval($b),
    gmp_strval($r['t']), gmp_strval($r['g']));
} else {
    echo "Error while solving the equation\n";
}

// output: Solution: 12*2 + 21*-1 = 3
?>

Předcházející | Nahoru | Další
gmp_gcd | Domů | gmp_hamdist


gmp_hamdist

(PHP 4 >= 4.0.4, PHP 5)

gmp_hamdist — Hamming distance

Popis

int gmp_hamdist ( resource $a, resource $b )

Returns the hamming distance between a and b. Both operands should be non-negative.

Seznam parametrů

a

It can be either a GMP number resource, or a numeric string given that it is possible to convert the latter to a number.

It should be positive.

b

It can be either a GMP number resource, or a numeric string given that it is possible to convert the latter to a number.

It should be positive.

Návratové hodnoty

A GMP number resource.

Příklady

Příklad 644. gmp_hamdist() example

<?php
$ham1 = gmp_init("1001010011", 2);
$ham2 = gmp_init("1011111100", 2);
echo gmp_hamdist($ham1, $ham2) . "\n";

/* hamdist is equivilent to: */
echo gmp_popcount(gmp_xor($ham1, $ham2)) . "\n";
?>

Výše uvedený příklad vypíše:

6
6

Viz také

gmp_popcount()
gmp_xor()

Předcházející | Nahoru | Další
gmp_gcdext | Domů | gmp_init


gmp_init

(PHP 4 >= 4.0.4, PHP 5)

gmp_init — Create GMP number

Popis

resource gmp_init ( mixed $number [, int $base] )

Creates a GMP number from an integer or string.

Seznam parametrů

number

An integer or a string. The string representation can be decimal, hexadecimal or octal.

base

The base. Defaults to 0.

The base may vary from 2 to 36. If base is 0 (default value), the actual base is determined from the leading characters: if the first two characters are 0x or 0X, hexadecimal is assumed, otherwise if the first character is "0", octal is assumed, otherwise decimal is assumed.

Návratové hodnoty

A GMP number resource.

ChangeLog (záznam změn)

Verze | Popis
4.1.0 | The optional base parameter was added.

Příklady

Příklad 645. Creating GMP number

<?php
$a = gmp_init(123456);
$b = gmp_init("0xFFFFDEBACDFEDF7200");
?>

Poznámky

Poznámka: It is not necessary to call this function if you want to use integer or string in place of GMP number in GMP functions, like gmp_add(). Function arguments are automatically converted to GMP numbers, if such conversion is possible and needed, using the same rules as gmp_init().

Předcházející | Nahoru | Další
gmp_hamdist | Domů | gmp_intval


gmp_intval

(PHP 4 >= 4.0.4, PHP 5)

gmp_intval — Convert GMP number to integer

Popis

int gmp_intval ( resource $gmpnumber )

This function allows to convert GMP number to integer.

Seznam parametrů

gmpnumber

A GMP number.

Návratové hodnoty

An integer value of gmpnumber.

Příklady

Příklad 646. gmp_intval() example

<?php
// displays correct result
echo gmp_intval("2147483647") . "\n";

// displays wrong result, above PHP integer limit
echo gmp_intval("2147483648") . "\n";

// displays correct result
echo gmp_strval("2147483648") . "\n";
?>

Výše uvedený příklad vypíše:

2147483647
2147483647
2147483648

Poznámky

Varování

This function returns a useful result only if the number actually fits the PHP integer (i.e., signed long type). If you want just to print the GMP number, use gmp_strval().

Předcházející | Nahoru | Další
gmp_init | Domů | gmp_invert


gmp_invert

(PHP 4 >= 4.0.4, PHP 5)

gmp_invert — Inverse by modulo

Popis

resource gmp_invert ( resource $a, resource $b )

Computes the inverse of a modulo b.

Seznam parametrů

a

It can be either a GMP number resource, or a numeric string given that it is possible to convert the latter to a number.

b

It can be either a GMP number resource, or a numeric string given that it is possible to convert the latter to a number.

Návratové hodnoty

A GMP number on success or FALSE if an inverse does not exist.

Příklady

Příklad 647. gmp_invert() example

<?php
echo gmp_invert("5", "10"); // no inverse, outputs nothing, result is FALSE
$invert = gmp_invert("5", "11");
echo gmp_strval($invert) . "\n";
?>

Výše uvedený příklad vypíše:

9

Předcházející | Nahoru | Další
gmp_intval | Domů | gmp_jacobi


gmp_jacobi

(PHP 4 >= 4.0.4, PHP 5)

gmp_jacobi — Jacobi symbol

Popis

int gmp_jacobi ( resource $a, resource $p )

Computes » Jacobi symbol of a and p. p should be odd and must be positive.

Seznam parametrů

a

It can be either a GMP number resource, or a numeric string given that it is possible to convert the latter to a number.

p

It can be either a GMP number resource, or a numeric string given that it is possible to convert the latter to a number.

Should be odd and must be positive.

Návratové hodnoty

A GMP number resource.

Příklady

Příklad 648. gmp_jacobi() example

<?php
echo gmp_jacobi("1", "3") . "\n";
echo gmp_jacobi("2", "3") . "\n";
?>

Výše uvedený příklad vypíše:

1
0

Předcházející | Nahoru | Další
gmp_invert | Domů | gmp_legendre


gmp_legendre

(PHP 4 >= 4.0.4, PHP 5)

gmp_legendre — Legendre symbol

Popis

int gmp_legendre ( resource $a, resource $p )

Compute the » Legendre symbol of a and p. p should be odd and must be positive.

Seznam parametrů

a

It can be either a GMP number resource, or a numeric string given that it is possible to convert the latter to a number.

p

It can be either a GMP number resource, or a numeric string given that it is possible to convert the latter to a number.

Should be odd and must be positive.

Návratové hodnoty

A GMP number resource.

Příklady

Příklad 649. gmp_legendre() example

<?php
echo gmp_legendre("1", "3") . "\n";
echo gmp_legendre("2", "3") . "\n";
?>

Výše uvedený příklad vypíše:

1
0

Předcházející | Nahoru | Další
gmp_jacobi | Domů | gmp_mod


gmp_mod

(PHP 4 >= 4.0.4, PHP 5)

gmp_mod — Modulo operation

Popis

resource gmp_mod ( resource $n, resource $d )

Calculates n modulo d. The result is always non-negative, the sign of d is ignored.

Seznam parametrů

n

It can be either a GMP number resource, or a numeric string given that it is possible to convert the latter to a number.

d

The modulo that is being evaluated.

It can be either a GMP number resource, or a numeric string given that it is possible to convert the latter to a number.

Návratové hodnoty

A GMP number resource.

Příklady

Příklad 650. gmp_mod() example

<?php
$mod = gmp_mod("8", "3");
echo gmp_strval($mod) . "\n";
?>

Výše uvedený příklad vypíše:

2

Předcházející | Nahoru | Další
gmp_legendre | Domů | gmp_mul


gmp_mul

(PHP 4 >= 4.0.4, PHP 5)

gmp_mul — Multiply numbers

Popis

resource gmp_mul ( resource $a, resource $b )

Multiplies a by b and returns the result.

Seznam parametrů

a

A number that will be multiplied by b.

It can be either a GMP number resource, or a numeric string given that it is possible to convert the latter to a number.

b

A number that will be multiplied by a.

It can be either a GMP number resource, or a numeric string given that it is possible to convert the latter to a number.

Návratové hodnoty

A GMP number resource.

Příklady

Příklad 651. gmp_mul() example

<?php
$mul = gmp_mul("12345678", "2000");
echo gmp_strval($mul) . "\n";
?>

Výše uvedený příklad vypíše:

24691356000

Předcházející | Nahoru | Další
gmp_mod | Domů | gmp_neg


gmp_neg

(PHP 4 >= 4.0.4, PHP 5)

gmp_neg — Negate number

Popis

resource gmp_neg ( resource $a )

Returns the negative value of a number.

Seznam parametrů

a

It can be either a GMP number resource, or a numeric string given that it is possible to convert the latter to a number.

Návratové hodnoty

Returns -a, as a GMP number.

Příklady

Příklad 652. gmp_neg() example

<?php
$neg1 = gmp_neg("1");
echo gmp_strval($neg1) . "\n";
$neg2 = gmp_neg("-1");
echo gmp_strval($neg2) . "\n";
?>

Výše uvedený příklad vypíše:

-1
1

Předcházející | Nahoru | Další
gmp_mul | Domů | gmp_nextprime


gmp_or

(PHP 4 >= 4.0.4, PHP 5)

gmp_or — Logical OR

Popis

resource gmp_or ( resource $a, resource $b )

Calculates logical inclusive OR of two GMP numbers.

Seznam parametrů

a

It can be either a GMP number resource, or a numeric string given that it is possible to convert the latter to a number.

b

It can be either a GMP number resource, or a numeric string given that it is possible to convert the latter to a number.

Návratové hodnoty

A GMP number resource.

Příklady

Příklad 654. gmp_or() example

<?php
$or1 = gmp_or("0xfffffff2", "4");
echo gmp_strval($or1, 16) . "\n";
$or2 = gmp_or("0xfffffff2", "2");
echo gmp_strval($or2, 16) . "\n";
?>

Výše uvedený příklad vypíše:

fffffff6
fffffff2

Předcházející | Nahoru | Další
gmp_nextprime | Domů | gmp_perfect_square


gmp_perfect_square

(PHP 4 >= 4.0.4, PHP 5)

gmp_perfect_square — Perfect square check

Popis

bool gmp_perfect_square ( resource $a )

Check if a number is a perfect square.

Seznam parametrů

a

The number being checked as a perfect square.

It can be either a GMP number resource, or a numeric string given that it is possible to convert the latter to a number.

Návratové hodnoty

Returns TRUE if a is a perfect square, FALSE otherwise.

Příklady

Příklad 655. gmp_perfect_square() example

<?php
// 3 * 3, perfect square
var_dump(gmp_perfect_square("9"));

// not a perfect square
var_dump(gmp_perfect_square("7"));

// 1234567890 * 1234567890, perfect square
var_dump(gmp_perfect_square("1524157875019052100"));
?>

Výše uvedený příklad vypíše:

bool(true)
bool(false)
bool(true)

Viz také

gmp_sqrt()
gmp_sqrtrem()

Předcházející | Nahoru | Další
gmp_or | Domů | gmp_popcount


gmp_popcount

(PHP 4 >= 4.0.4, PHP 5)

gmp_popcount — Population count

Popis

int gmp_popcount ( resource $a )

Get the population count.

Seznam parametrů

a

It can be either a GMP number resource, or a numeric string given that it is possible to convert the latter to a number.

Návratové hodnoty

The population count of a, as an integer.

Příklady

Příklad 656. gmp_popcount() example

<?php
$pop1 = gmp_init("10000101", 2); // 3 1's
echo gmp_popcount($pop1) . "\n";
$pop2 = gmp_init("11111110", 2); // 7 1's
echo gmp_popcount($pop2) . "\n";
?>

Výše uvedený příklad vypíše:

3
7

Předcházející | Nahoru | Další
gmp_perfect_square | Domů | gmp_pow


gmp_pow

(PHP 4 >= 4.0.4, PHP 5)

gmp_pow — Raise number into power

Popis

resource gmp_pow ( resource $base, int $exp )

Raise base into power exp.

Seznam parametrů

base

The base number.

It can be either a GMP number resource, or a numeric string given that it is possible to convert the latter to a number.

exp

The positive power to raise the base.

Návratové hodnoty

The new (raised) number, as a GMP number. The case of 0^0 yields 1.

Příklady

Příklad 657. gmp_pow() example

<?php
$pow1 = gmp_pow("2", 31);
echo gmp_strval($pow1) . "\n";
$pow2 = gmp_pow("0", 0);
echo gmp_strval($pow2) . "\n";
$pow3 = gmp_pow("2", -1); // Negative exp, generates warning
echo gmp_strval($pow3) . "\n";
?>

Výše uvedený příklad vypíše:

2147483648
1

Předcházející | Nahoru | Další
gmp_popcount | Domů | gmp_powm


gmp_powm

(PHP 4 >= 4.0.4, PHP 5)

gmp_powm — Raise number into power with modulo

Popis

resource gmp_powm ( resource $base, resource $exp, resource $mod )

Calculate (base raised into power exp) modulo mod. If exp is negative, result is undefined.

Seznam parametrů

base

The base number.

It can be either a GMP number resource, or a numeric string given that it is possible to convert the latter to a number.

exp

The positive power to raise the base.

It can be either a GMP number resource, or a numeric string given that it is possible to convert the latter to a number.

mod

The modulo.

It can be either a GMP number resource, or a numeric string given that it is possible to convert the latter to a number.

Návratové hodnoty

The new (raised) number, as a GMP number.

Příklady

Příklad 658. gmp_powm() example

<?php
$pow1 = gmp_powm("2", "31", "2147483649");
echo gmp_strval($pow1) . "\n";
?>

Výše uvedený příklad vypíše:

2147483648

Předcházející | Nahoru | Další
gmp_pow | Domů | gmp_prob_prime


gmp_prob_prime

(PHP 4 >= 4.0.4, PHP 5)

gmp_prob_prime — Check if number is "probably prime"

Popis

int gmp_prob_prime ( resource $a [, int $reps] )

The function uses Miller-Rabin's probabilistic test to check if a number is a prime.

Seznam parametrů

a

The number being checked as a prime.

It can be either a GMP number resource, or a numeric string given that it is possible to convert the latter to a number.

reps

Reasonable values of reps vary from 5 to 10 (default being 10); a higher value lowers the probability for a non-prime to pass as a "probable" prime.

It can be either a GMP number resource, or a numeric string given that it is possible to convert the latter to a number.

Návratové hodnoty

If this function returns 0, a is definitely not prime. If it returns 1, then a is "probably" prime. If it returns 2, then a is surely prime.

Příklady

Příklad 659. gmp_prob_prime() example

<?php
// definitely not a prime
echo gmp_prob_prime("6") . "\n";

// probably a prime
echo gmp_prob_prime("1111111111111111111") . "\n";

// definitely a prime
echo gmp_prob_prime("11") . "\n";
?>

Výše uvedený příklad vypíše:

0
1
2

Předcházející | Nahoru | Další
gmp_powm | Domů | gmp_random


gmp_random

(PHP 4 >= 4.0.4, PHP 5)

gmp_random — Random number

Popis

resource gmp_random ( int $limiter )

Generate a random number. The number will be between zero and the number of bits per limb multiplied by limiter. If limiter is negative, negative numbers are generated.

A limb is an internal GMP mechanism. The number of bits in a limb is not static, and can vary from system to system. Generally, the number of bits in a limb is either 16 or 32, but this is not guaranteed.

Seznam parametrů

limiter

The limiter.

It can be either a GMP number resource, or a numeric string given that it is possible to convert the latter to a number.

Návratové hodnoty

A random GMP number.

Příklady

Příklad 660. gmp_random() example

<?php
$rand1 = gmp_random(1); // random number from 0 to 1 * bits per limb
$rand2 = gmp_random(2); // random number from 0 to 2 * bits per limb

echo gmp_strval($rand1) . "\n";
echo gmp_strval($rand2) . "\n";
?>

Výše uvedený příklad vypíše:

1915834968
8642564075890328087

Předcházející | Nahoru | Další
gmp_prob_prime | Domů | gmp_scan0


gmp_scan0

(PHP 4 >= 4.0.4, PHP 5)

gmp_scan0 — Scan for 0

Popis

int gmp_scan0 ( resource $a, int $start )

Scans a, starting with bit start, towards more significant bits, until the first clear bit is found.

Seznam parametrů

a

The number to scan.

It can be either a GMP number resource, or a numeric string given that it is possible to convert the latter to a number.

start

The starting bit.

Návratové hodnoty

Returns the index of the found bit, as an integer. The index starts from 0.

Příklady

Příklad 661. gmp_scan0() example

<?php
// "0" bit is found at position 3. index starts at 0
$s1 = gmp_init("10111", 2);
echo gmp_scan0($s1, 0) . "\n";

// "0" bit is found at position 7. index starts at 5
$s2 = gmp_init("101110000", 2);
echo gmp_scan0($s2, 5) . "\n";
?>

Výše uvedený příklad vypíše:

3
7

Předcházející | Nahoru | Další
gmp_random | Domů | gmp_scan1


gmp_scan1

(PHP 4 >= 4.0.4, PHP 5)

gmp_scan1 — Scan for 1

Popis

int gmp_scan1 ( resource $a, int $start )

Scans a, starting with bit start, towards more significant bits, until the first set bit is found.

Seznam parametrů

a

The number to scan.

It can be either a GMP number resource, or a numeric string given that it is possible to convert the latter to a number.

start

The starting bit.

Návratové hodnoty

Returns the index of the found bit, as an integer. If no set bit is found, -1 is returned.

Příklady

Příklad 662. gmp_scan1() example

<?php
// "1" bit is found at position 3. index starts at 0
$s1 = gmp_init("01000", 2);
echo gmp_scan1($s1, 0) . "\n";

// "1" bit is found at position 9. index starts at 5
$s2 = gmp_init("01000001111", 2);
echo gmp_scan1($s2, 5) . "\n";
?>

Výše uvedený příklad vypíše:

3
9

Předcházející | Nahoru | Další
gmp_scan0 | Domů | gmp_setbit


gmp_setbit

(PHP 4 >= 4.0.4, PHP 5)

gmp_setbit — Set bit

Popis

void gmp_setbit ( resource &$a, int $index [, bool $set_clear] )

Sets bit index in a.

Seznam parametrů

a

The number being set to.

It can be either a GMP number resource, or a numeric string given that it is possible to convert the latter to a number.

index

The set bit.

set_clear

Defines if the bit is set to 0 or 1. By default the bit is set to 1. Index starts at 0.

Návratové hodnoty

A GMP number resource.

Příklady

Příklad 663. gmp_setbit() example

<?php
$a = gmp_init("0xfd");
gmp_setbit($a, 1); // index starts at 0
echo gmp_strval($a) . "\n";
?>

Výše uvedený příklad vypíše:

255

Poznámky

Poznámka: Unlike most of the other GMP functions, gmp_setbit() must be called with a GMP resource that already exists (using gmp_init() for example). One will not be automatically created.

Viz také

gmp_clrbit()
gmp_testbit()

Předcházející | Nahoru | Další
gmp_scan1 | Domů | gmp_sign


gmp_sign

(PHP 4 >= 4.0.4, PHP 5)

gmp_sign — Sign of number

Popis

int gmp_sign ( resource $a )

Checks the sign of a number.

Seznam parametrů

a

It can be either a GMP number resource, or a numeric string given that it is possible to convert the latter to a number.

Návratové hodnoty

Returns 1 if a is positive, -1 if a is negative, and 0 if a is zero.

Příklady

Příklad 664. gmp_sign() example

<?php
// positive
echo gmp_sign("500") . "\n";

// negative
echo gmp_sign("-500") . "\n";

// zero
echo gmp_sign("0") . "\n";
?>

Výše uvedený příklad vypíše:

1
-1
0

Předcházející | Nahoru | Další
gmp_setbit | Domů | gmp_sqrt


gmp_sqrt

(PHP 4 >= 4.0.4, PHP 5)

gmp_sqrt — Calculate square root

Popis

resource gmp_sqrt ( resource $a )

Calculates square root of a.

Seznam parametrů

a

It can be either a GMP number resource, or a numeric string given that it is possible to convert the latter to a number.

Návratové hodnoty

The integer portion of the square root, as a GMP number.

Příklady

Příklad 665. gmp_sqrt() example

<?php
$sqrt1 = gmp_sqrt("9");
$sqrt2 = gmp_sqrt("7");
$sqrt3 = gmp_sqrt("1524157875019052100");

echo gmp_strval($sqrt1) . "\n";
echo gmp_strval($sqrt2) . "\n";
echo gmp_strval($sqrt3) . "\n";
?>

Výše uvedený příklad vypíše:

3
2
1234567890

Předcházející | Nahoru | Další
gmp_sign | Domů | gmp_sqrtrem


gmp_sqrtrem

(PHP 4 >= 4.0.4, PHP 5)

gmp_sqrtrem — Square root with remainder

Popis

array gmp_sqrtrem ( resource $a )

Calculate the square root of a number, with remainder.

Seznam parametrů

a

The number being square rooted.

It can be either a GMP number resource, or a numeric string given that it is possible to convert the latter to a number.

Návratové hodnoty

Returns array where first element is the integer square root of a and the second is the remainder (i.e., the difference between a and the first element squared).

Příklady

Příklad 666. gmp_sqrtrem() example

<?php
list($sqrt1, $sqrt1rem) = gmp_sqrtrem("9");
list($sqrt2, $sqrt2rem) = gmp_sqrtrem("7");
list($sqrt3, $sqrt3rem) = gmp_sqrtrem("1048576");

echo gmp_strval($sqrt1) . ", " . gmp_strval($sqrt1rem) . "\n";
echo gmp_strval($sqrt2) . ", " . gmp_strval($sqrt2rem) . "\n";
echo gmp_strval($sqrt3) . ", " . gmp_strval($sqrt3rem) . "\n";
?>

Výše uvedený příklad vypíše:

3, 0
2, 3
1024, 0

Předcházející | Nahoru | Další
gmp_sqrt | Domů | gmp_strval


gmp_strval

(PHP 4 >= 4.0.4, PHP 5)

gmp_strval — Convert GMP number to string

Popis

string gmp_strval ( resource $gmpnumber [, int $base] )

Convert GMP number to string representation in base base. The default base is 10.

Seznam parametrů

gmpnumber

The GMP number that will be converted to a string.

It can be either a GMP number resource, or a numeric string given that it is possible to convert the latter to a number.

base

The base of the returned number. The default base is 10. Allowed values for the base are from 2 to 36.

Návratové hodnoty

The number, as a string.

Příklady

Příklad 667. Converting a GMP number to a string

<?php
$a = gmp_init("0x41682179fbf5");
printf("Decimal: %s, 36-based: %s", gmp_strval($a), gmp_strval($a,36));
?>

Předcházející | Nahoru | Další
gmp_sqrtrem | Domů | gmp_sub


gmp_sub

(PHP 4 >= 4.0.4, PHP 5)

gmp_sub — Subtract numbers

Popis

resource gmp_sub ( resource $a, resource $b )

Subtracts b from a and returns the result.

Seznam parametrů

a

The number being subtracted from.

It can be either a GMP number resource, or a numeric string given that it is possible to convert the latter to a number.

b

The number subtracted from a.

It can be either a GMP number resource, or a numeric string given that it is possible to convert the latter to a number.

Návratové hodnoty

A GMP number resource.

Příklady

Příklad 668. gmp_sub() example

<?php
$sub = gmp_sub("281474976710656", "4294967296"); // 2^48 - 2^32
echo gmp_strval($sub) . "\n";
?>

Výše uvedený příklad vypíše:

281470681743360

Předcházející | Nahoru | Další
gmp_strval | Domů | gmp_testbit


gmp_xor

(PHP 4 >= 4.0.4, PHP 5)

gmp_xor — Logical XOR

Popis

resource gmp_xor ( resource $a, resource $b )

Calculates logical exclusive OR (XOR) of two GMP numbers.

Seznam parametrů

a

It can be either a GMP number resource, or a numeric string given that it is possible to convert the latter to a number.

b

It can be either a GMP number resource, or a numeric string given that it is possible to convert the latter to a number.

Návratové hodnoty

A GMP number resource.

Příklady

Příklad 670. gmp_xor() example

<?php
$xor1 = gmp_init("1101101110011101", 2);
$xor2 = gmp_init("0110011001011001", 2);

$xor3 = gmp_xor($xor1, $xor2);

echo gmp_strval($xor3, 2) . "\n";
?>

Výše uvedený příklad vypíše:

1011110111000100

Předcházející | Nahoru | Další
gmp_testbit | Domů | LII. gnupg Funkce


HTTP

Předcházející VI. Reference funkcí Další

LVI. HTTP

Úvod

This HTTP extension aims to provide a convenient and powerful set of functionality for one of PHPs major applications.

It eases handling of HTTP URLs, dates, redirects, headers and messages, provides means for negotiation of clients preferred language and charset, as well as a convenient way to send any arbitrary data with caching and resuming capabilities.

It provides powerful request functionality, if built with CURL support. Parallel requests are available for PHP 5 and greater.

Additionally to the API reference in this manual you can find information about how to install and configure as well as which global constants are predefined in the following sections:

Installation
Configuration
Global Constants
Resource Types

Classes

Tyto třídy jsou definovány rozšířením a budou dostupné pouze v případě, že PHP bude zkompilováno s tímto rozšířením nebo bude rozšíření zavedeno dynamicky za běhu.

The HttpResponse class requires at least PHP v5.1. Any other class is available as of PHP v5.0.

Poznámka: Be aware though, that some methods are not available with PHP v5.0.

HttpMessage
HttpQueryString
HttpDeflateStream
HttpInflateStream
HttpRequest
HttpRequestPool
HttpResponse

Functions

Built-in Functions

Built-in HTTP related functions previously listed on this page can be found in the networking category.

The following functions do not need the HTTP module to be present: header(), headers_list(), headers_sent(), setcookie() , a setrawcookie().

Caching

http_cache_etag()
http_cache_last_modified()

Encodings

http_chunked_decode()
http_deflate()
http_inflate()

Miscellaneous

http_build_cookie()
http_date()
http_get_request_body_stream()
http_get_request_body()
http_get_request_headers()
http_match_etag()
http_match_modified()
http_match_request_header()
http_support()

Negotiation

http_negotiate_charset()
http_negotiate_content_type()
http_negotiate_language()

Outputhandlers

ob_deflatehandler()
ob_etaghandler()
ob_inflatehandler()

Parsers

http_parse_cookie()
http_parse_headers()
http_parse_message()
http_parse_params()

Requests

http_get()
http_head()
http_post_data()
http_post_fields()
http_put_data()
http_put_file()
http_put_stream()
http_request_body_encode()
http_request_method_exists()
http_request_method_name()
http_request_method_register()
http_request_method_unregister()
http_request()

Responses

http_redirect()
http_send_content_disposition()
http_send_content_type()
http_send_data()
http_send_file()
http_send_last_modified()
http_send_status()
http_send_stream()
http_throttle()

URLs

http_build_str()
http_build_url()

Persistent Handles

http_persistent_handles_count()
http_persistent_handles_ident()
http_persistent_handles_clean()

Obsah

Installation — Installing the HTTP extension
Configuration — http module configuration directives
Resources — Resources created by the HTTP extension
Constants — predefined http module constants
Request Options — options usable with the HttpRequest class and request functions
HttpMessage — HTTP Message Class
HttpMessage::__construct — HttpMessage constructor
HttpMessage::factory — Create HttpMessage from string
HttpMessage::fromEnv — Create HttpMessage from environment
HttpMessage::fromString — Create HttpMessage from string
HttpMessage::toString — Get string representation
HttpMessage::toMessageTypeObject — Create HTTP object regarding message type
HttpMessage::guessContentType — Guess content type
HttpMessage::detach — Detach HttpMessage
HttpMessage::prepend — Prepend message(s)
HttpMessage::reverse — Reverse message chain
HttpMessage::send — Send message
HttpMessage::getParentMessage — Get parent message
HttpMessage::getType — Get message type
HttpMessage::setType — Set message type
HttpMessage::getHttpVersion — Get HTTP version
HttpMessage::setHttpVersion — Set HTTP version
HttpMessage::getHeaders — Get message headers
HttpMessage::getHeader — Get header
HttpMessage::addHeaders — Add headers
HttpMessage::setHeaders — Set headers
HttpMessage::getBody — Get message body
HttpMessage::setBody — Set message body
HttpMessage::getRequestMethod — Get request method
HttpMessage::setRequestMethod — Set request method
HttpMessage::getRequestUrl — Get request URL
HttpMessage::setRequestUrl — Set request URL
HttpMessage::getResponseCode — Get response code
HttpMessage::setResponseCode — Set response code
HttpMessage::getResponseStatus — Get response status
HttpMessage::setResponseStatus — Set response status
HttpQueryString — HTTP Query String Class
HttpQueryString::__construct — HttpQueryString constructor
HttpQueryString::singleton — HttpQueryString singleton
HttpQueryString::get — Get (part of) query string
HttpQueryString::mod — Modifiy query string copy
HttpQueryString::set — Set query string params
HttpQueryString::toArray — Get query string as array
HttpQueryString::toString — Get query string
HttpQueryString::xlate — Change query strings charset
HttpDeflateStream — HTTP Deflate Stream Class
HttpDeflateStream::factory — HttpDeflateStream class factory
HttpDeflateStream::__construct — HttpDeflateStream class constructor
HttpDeflateStream::update — Update deflate stream
HttpDeflateStream::flush — Flush deflate stream
HttpDeflateStream::finish — Finalize deflate stream
HttpInflateStream — HTTP Inflate Stream
HttpInflateStream::factory — HttpInflateStream class factory
HttpInflateStream::__construct — HttpInflateStream class constructor
HttpInflateStream::update — Update inflate stream
HttpInflateStream::flush — Flush inflate stream
HttpInflateStream::finish — Finalize inflate stream
HttpRequest — HTTP Request Class
HttpRequest::addCookies — Add cookies
HttpRequest::addHeaders — Add headers
HttpRequest::addPostFields — Add post fields
HttpRequest::addPostFile — Add post file
HttpRequest::addPutData — Add put data
HttpRequest::addQueryData — Add query data
HttpRequest::addRawPostData — Add raw post data
HttpRequest::addSslOptions — Add ssl options
HttpRequest::clearHistory — Clear history
HttpRequest::__construct — HttpRequest constructor
HttpRequest::enableCookies — Enable cookies
HttpRequest::getContentType — Get content type
HttpRequest::getCookies — Get cookies
HttpRequest::getHeaders — Get headers
HttpRequest::getHistory — Get history
HttpRequest::getMethod — Get method
HttpRequest::getOptions — Get options
HttpRequest::getPostFields — Get post fields
HttpRequest::getPostFiles — Get post files
HttpRequest::getPutData — Get put data
HttpRequest::getPutFile — Get put file
HttpRequest::getQueryData — Get query data
HttpRequest::getRawPostData — Get raw post data
HttpRequest::getRawRequestMessage — Get raw request message
HttpRequest::getRawResponseMessage — Get raw response message
HttpRequest::getRequestMessage — Get request message
HttpRequest::getResponseBody — Get response body
HttpRequest::getResponseCode — Get response code
HttpRequest::getResponseCookies — Get response cookie(s)
HttpRequest::getResponseData — Get response data
HttpRequest::getResponseHeader — Get response header(s)
HttpRequest::getResponseInfo — Get response info
HttpRequest::getResponseMessage — Get response message
HttpRequest::getResponseStatus — Get response status
HttpRequest::getSslOptions — Get ssl options
HttpRequest::getUrl — Get url
HttpRequest::resetCookies — Reset cookies
HttpRequest::send — Send request
HttpRequest::setContentType — Set content type
HttpRequest::setCookies — Set cookies
HttpRequest::setHeaders — Set headers
HttpRequest::setMethod — Set method
HttpRequest::setOptions — Set options
HttpRequest::setPostFields — Set post fields
HttpRequest::setPostFiles — Set post files
HttpRequest::setPutData — Set put data
HttpRequest::setPutFile — Set put file
HttpRequest::setQueryData — Set query data
HttpRequest::setRawPostData — Set raw post data
HttpRequest::setSslOptions — Set ssl options
HttpRequest::setUrl — Set URL
HttpRequestPool — HTTP Request Pool Class
HttpRequestPool::attach — Attach HttpRequest
HttpRequestPool::__construct — HttpRequestPool constructor
HttpRequestPool::__destruct — HttpRequestPool destructor
HttpRequestPool::detach — Detach HttpRequest
HttpRequestPool::getAttachedRequests — Get attached requests
HttpRequestPool::getFinishedRequests — Get finished requests
HttpRequestPool::reset — Reset request pool
HttpRequestPool::send — Send all requests
HttpRequestPool::socketPerform — Perform socket actions
HttpRequestPool::socketSelect — Perform socket select
HttpResponse — HTTP Response Class
HttpResponse::capture — Capture script output
HttpResponse::getBufferSize — Get buffer size
HttpResponse::getCacheControl — Get cache control
HttpResponse::getCache — Get cache
HttpResponse::getContentDisposition — Get content disposition
HttpResponse::getContentType — Get content type
HttpResponse::getData — Get data
HttpResponse::getETag — Get ETag
HttpResponse::getFile — Get file
HttpResponse::getGzip — Get gzip
HttpResponse::getHeader — Get header
HttpResponse::getLastModified — Get last modified
HttpResponse::getStream — Get Stream
HttpResponse::getThrottleDelay — Get throttle delay
HttpResponse::getRequestBody — Get request body
HttpResponse::getRequestBodyStream — Get request body stream
HttpResponse::getRequestHeaders — Get request headers
HttpResponse::guessContentType — Guess content type
HttpResponse::redirect — Redirect
HttpResponse::send — Send response
HttpResponse::setBufferSize — Set buffer size
HttpResponse::setCacheControl — Set cache control
HttpResponse::setCache — Set cache
HttpResponse::setContentDisposition — Set content disposition
HttpResponse::setContentType — Set content type
HttpResponse::setData — Set data
HttpResponse::setETag — Set ETag
HttpResponse::setFile — Set file
HttpResponse::setGzip — Set gzip
HttpResponse::setHeader — Set header
HttpResponse::setLastModified — Set last modified
HttpResponse::setStream — Set stream
HttpResponse::setThrottleDelay — Set throttle delay
HttpResponse::status — Send HTTP response status
http_cache_etag — Caching by ETag
http_cache_last_modified — Caching by last modification
http_chunked_decode — Decode chunked-encoded data
http_deflate — Deflate data
http_inflate — Inflate data
http_get_request_body_stream — Get request body as stream
http_get_request_body — Get request body as string
http_get_request_headers — Get request headers as array
http_date — Compose HTTP RFC compliant date
http_support — Check built-in HTTP support
http_match_etag — Match ETag
http_match_modified — Match last modification
http_match_request_header — Match any header
http_build_cookie — Build cookie string
http_negotiate_charset — Negotiate clients preferred character set
http_negotiate_content_type — Negotiate clients preferred content type
http_negotiate_language — Negotiate clients preferred language
ob_deflatehandler — Deflate output handler
ob_etaghandler — ETag output handler
ob_inflatehandler — Inflate output handler
http_parse_cookie — Parse HTTP cookie
http_parse_headers — Parse HTTP headers
http_parse_message — Parse HTTP messages
http_parse_params — Parse parameter list
http_persistent_handles_count — Stat persistent handles
http_persistent_handles_ident — Get/set ident of persistent handles
http_persistent_handles_clean — Clean up persistent handles
http_get — Perform GET request
http_head — Perform HEAD request
http_post_data — Perform POST request with pre-encoded data
http_post_fields — Perform POST request with data to be encoded
http_put_data — Perform PUT request with data
http_put_file — Perform PUT request with file
http_put_stream — Perform PUT request with stream
http_request_method_exists — Check whether request method exists
http_request_method_name — Get request method name
http_request_method_register — Register request method
http_request_method_unregister — Unregister request method
http_request — Perform custom request
http_request_body_encode — Encode request body
http_redirect — Issue HTTP redirect
http_send_content_disposition — Send Content-Disposition
http_send_content_type — Send Content-Type
http_send_data — Send arbitrary data
http_send_file — Send file
http_send_last_modified — Send Last-Modified
http_send_status — Send HTTP response status
http_send_stream — Send stream
http_throttle — HTTP throttling
http_build_str — Build query string
http_build_url — Build an URL
Předcházející | Nahoru | Další
hash | Domů | Installation


header

(PHP 4, PHP 5)

header — Poslat HTTP hlavičku

Popis

int header ( string $string [, bool $replace [, int $http_response_code]] )

Funkce header() se používá na začátku HTML souboru k odeslání HTTP hlaviček. Více informací o HTTP hlavičkách viz » Specifikace HTTP 1.1. Poznámka: Pamatujte, že funkce header() musí být volána dříve než se odešle jakýkoliv normální výstup, ať už normálními HTML tagy, nebo z PHP. Velmi obvyklou chybou je načítat kód pomocí include() nebo auto_prepend a mít v tomto kódu prázdné řádky, které způsobí odeslání výstupu před voláním funkce header().

Existují dva zvláštní případy volání funkce header(). Prvním je hlavička "Location". Ta nejenže odešle hlavičku browseru, ale navíc i vrátí Apachi stavový kód REDIRECT. Z pohledu autora skriptu by to nemělo být důležité, ale je to důležité pro lidi, kteří rozumí vnitřnostem Apache.

header ("Location: http://www.php.net"); /* Přesměrujeme browser
                                            na web site PHP */
exit;                 /* Pojistíme si, že se další kód nevykoná po
                         přesměrování. */

Druhým zvláštním případem jsou všechny hlavičky začínající řetězcem "HTTP/" (velikost písmen nehraje roli). Například, pokud direktiva ErrorDocument 404 vašeho Apache ukazuje na PHP skript, nebylo by od věci, kdyby skutečně generoval 404. První věcí, kterou byste v tomto skriptu měli udělat tudíz bude:

header ("HTTP/1.0 404 Not Found");

PHP skripty často generují dynamické HTML, které nesmí být cachováno uživatelským browserem, ani žýdnými proxynami mezi serverem a uživatelským browserem. Mnoho proxyn a klientů se dá donutit k vypnutí cachování s pomocí

header ("Expires: Mon, 26 Jul 1997 05:00:00 GMT");    // datum v minulosti
header ("Last-Modified: " . gmdate("D, d M Y H:i:s") . " GMT");
                                                      // vždy upraven
header ("Cache-Control: no-cache, must-revalidate");  // HTTP/1.1
header ("Pragma: no-cache");                          // HTTP/1.0

Viz také headers_sent()

Předcházející | Nahoru | Další
getservbyport | Domů | headers_list


headers_list

(PHP 5)

headers_list — Returns a list of response headers sent (or ready to send)

Popis

array headers_list ( void )

headers_list() will return a list of headers to be sent to the browser / client. To determine whether or not these headers have been sent yet, use headers_sent().

Návratové hodnoty

Returns a numerically indexed array of headers.

Příklady

Příklad 1410. Examples using headers_list()

<?php

/* setcookie() will add a response header on its own */
setcookie('foo', 'bar');

/* Define a custom response header
   This will be ignored by most clients */
header("X-Sample-Test: foo");

/* Specify plain text content in our response */
header('Content-type: text/plain');

/* What headers are going to be sent? */
var_dump(headers_list());

?>

Výše uvedený příklad vypíše:

array(4) {
  [0]=>
  string(23) "X-Powered-By: PHP/5.1.3"
  [1]=>
  string(19) "Set-Cookie: foo=bar"
  [2]=>
  string(18) "X-Sample-Test: foo"
  [3]=>
  string(24) "Content-type: text/plain"
}

Viz také

headers_sent()
header()
setcookie()

Předcházející | Nahoru | Další
header | Domů | headers_sent


headers_sent

(PHP 4, PHP 5)

headers_sent — Vrátit TRUE, pokud byly odeslány hlavičky

Popis

boolean headers_sent ( $void )

Tato funkce vrátí TRUE, pokud už byly HTTP hlavičky odeslány, jinak FALSE.

Viz také header()

Předcházející | Nahoru | Další
headers_list | Domů | inet_ntop


setcookie

(PHP 4, PHP 5)

setcookie — Poslat cookie

Popis

bool setcookie ( string $name [, string $value [, int $expire [, string $path [, string $domain [, int $secure]]]]] )

setcookie() definuje cookie, která se pošle spolu s ostatními HTTP hlavičkami. Podobně jako ostatní hlavičky, cookies se musí odeslat před jakýmkoliv výstupem vašeho skriptu (jedná se o omezení protokolu). Je tedy třeba, abyste všechna volání této funkce umístili před jakýkoliv výstup, včetně značek <html> a <head> a také před jakékoliv bílé znaky. Když je při volání této funkce už něco na výstupu, setcookie() neuspěje a vrátí FALSE. Když setcookie() proběhne v pořádku, vrátí TRUE. To však neříká nic o tom, zda byla cookie přijata klientem.

Poznámka: V PHP 4 lze k poslání výstupu před voláním této funkce použít output buffering, ovšem s tou režií, že všechen výstup pro prohlížeč bude pozdržen na serveru, dokud ho nepošlete. Lze to zařídit voláním funkcí ob_start() a ob_end_flush() nebo nastavením konfigurační direktivy output_buffering v php.ini nebo konfiguračních souborech serveru.

Všechny argumenty kromě argumentu name jsou nepovinné. Pokud je přítomný pouze argument name, u klienta se smaže cookie tohoto jména. Kterýkoliv argument můžete také nahradit prázdným řetězcem (""), čímž tento argument přeskočíte. Argumenty expire a secure jsou celočíselné a nedají se přeskočit prázdným řetězcem. Místo toho použijte nulu (0). Argument expire je běžné Unixové celočíselné vyjádření času, jak je vrací funkce time() či mktime(). Argument secure indikuje, že by se tato cookie měla přenášet pouze po zabezpečeném HTTPS spojení.

Běžné zádrhele:

  • Cookies jsou přístupné až při dalším načtení stránky, na které přístupné být mají.
  • Cookies se musí mazat se stejnými parametry, se kterými byly odeslány.

V PHP 3 se vícenásobná volání setcookie() v jednom skriptu provedou v opačném pořadí. Pokud se pokoušíte smazat jeden cookie pře odesláním jiného, měli byste umístit vložení před smazání. V PHP 4 se vícenásobná volání setcookie() provedou v tom pořadí, jak jsou volána.

Několik příkladů, jak posílat cookies:

Příklad 1415. Ukázky odeslání cookies pomocí setcookie()

setcookie ("TestCookie", "Zkušební hodnota");
setcookie ("TestCookie", $value,time()+3600);  /* vyprší za hodinu */
setcookie ("TestCookie", $value,time()+3600, "/~rasmus/", ".utoronto.ca", 1);

Následují příklady mazání cookies z předchozí ukázky:

Příklad 1416. Ukázky mazání cookies pomocí setcookie()

setcookie ("TestCookie");
// nastaví dobu vypršení na čas před hodinou
setcookie ("TestCookie", "", time() - 3600);
setcookie ("TestCookie", "", time() - 3600, "/~rasmus/", ".utoronto.ca", 1);

Při mazání cookie byste se měli ujistit, že je doba vypršení v minulosti, čímž se v browseru zapne mechanismus odstranění cookie.

Všimněte si, že hodnotová část cookie se při odeslání cookie automaticky url-zakóduje, a při přijetí se automaticky dekóduje a přiřadí proměnné stejného jména, jako je jméno cookie. Pokud chcete vidět obsah našeho zkušebního cookie, použijte některý z následujících příkladů:

echo $TestCookie;
echo $HTTP_COOKIE_VARS["TestCookie"];

Cookies obsahující pole můžete také odeslat tak, že za název cookie napíšete hranaté závorky. Účinkem tohoto je odeslání tolika cookies, kolik má vaše pole prvků, ale když váš skript tyto cookies přijme, hodnoty se umístí v poli stejného jména, jako jsou vaše cookies:

setcookie ("cookie[three]", "cookiethree");
setcookie ("cookie[two]", "cookietwo");
setcookie ("cookie[one]", "cookieone");
if (isset ($cookie)) {
    while (list ($name, $value) = each ($cookie)) {
        echo "$name == $value<br>\n";
    }
}

Více informací o cookies viz specifikace cookies na » http://wp.netscape.com/newsref/std/cookie_spec.html.

Microsoft Internet Explorer 4 se Service Packem 1 zpracovává chybně cookies, které mají nastavený argument path.

Netscape Communicator 4.05 a Microsoft Internet Explorer 3.x zřejmě nezpracují cookies správně, pokud nejsou nastaveny argumenty path a time.

Předcházející | Nahoru | Další
pfsockopen | Domů | setrawcookie


setrawcookie

(PHP 5)

setrawcookie — Send a cookie without urlencoding the cookie value

Popis

bool setrawcookie ( string $name [, string $value [, int $expire [, string $path [, string $domain [, bool $secure [, bool $httponly]]]]]] )

setrawcookie() is exactly the same as setcookie() except that the cookie value will not be automatically urlencoded when sent to the browser.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

ChangeLog (záznam změn)

Verze | Popis
5.2.0 | The httponly parameter was added.

Viz také

setcookie()

Předcházející | Nahoru | Další
setcookie | Domů | socket_get_status


Hyperwave Functions

Předcházející VI. Reference funkcí Další

LVII. Hyperwave Functions

Úvod

Hyperwave has been developed at » IICM in Graz. It started with the name Hyper-G and changed to Hyperwave when it was commercialised (in 1996).

Hyperwave is not free software. The current version, 5.5 is available at » http://www.hyperwave.com/. A time limited version can be ordered for free (30 days).

See also the Hyperwave API module.

Hyperwave is an information system similar to a database (HIS, Hyperwave Information Server). Its focus is the storage and management of documents. A document can be any possible piece of data that may as well be stored in file. Each document is accompanied by its object record. The object record contains meta data for the document. The meta data is a list of attributes which can be extended by the user. Certain attributes are always set by the Hyperwave server, other may be modified by the user. An attribute is a name/value pair of the form name=value. The complete object record contains as many of those pairs as the user likes. The name of an attribute does not have to be unique, e.g. a title may appear several times within an object record. This makes sense if you want to specify a title in several languages. In such a case there is a convention, that each title value is preceded by the two letter language abbreviation followed by a colon, e.g. 'en:Title in English' or 'ge:Titel in deutsch'. Other attributes like a description or keywords are potential candidates. You may also replace the language abbreviation by any other string as long as it separated by colon from the rest of the attribute value.

Each object record has native a string representation with each name/value pair separated by a newline. The Hyperwave extension also knows a second representation which is an associated array with the attribute name being the key. Multilingual attribute values itself form another associated array with the key being the language abbreviation. Actually any multiple attribute forms an associated array with the string left to the colon in the attribute value being the key. (This is not fully implemented. Only the attributes Title, Description and Keyword are treated properly yet.)

Besides the documents, all hyper links contained in a document are stored as object records as well. Hyper links which are in a document will be removed from it and stored as individual objects, when the document is inserted into the database. The object record of the link contains information about where it starts and where it ends. In order to gain the original document you will have to retrieve the plain document without the links and the list of links and reinsert them. The functions hw_pipedocument() and hw_gettext() do this for you. The advantage of separating links from the document is obvious. Once a document to which a link is pointing to changes its name, the link can easily be modified accordingly. The document containing the link is not affected at all. You may even add a link to a document without modifying the document itself.

Saying that hw_pipedocument() and hw_gettext() do the link insertion automatically is not as simple as it sounds. Inserting links implies a certain hierarchy of the documents. On a web server this is given by the file system, but Hyperwave has its own hierarchy and names do not reflect the position of an object in that hierarchy. Therefore creation of links first of all requires a mapping from the Hyperwave hierarchy and namespace into a web hierarchy respective web namespace. The fundamental difference between Hyperwave and the web is the clear distinction between names and hierarchy in Hyperwave. The name does not contain any information about the objects position in the hierarchy. In the web the name also contains the information on where the object is located in the hierarchy. This leads to two possibles ways of mapping. Either the Hyperwave hierarchy and name of the Hyperwave object is reflected in the URL or the name only. To make things simple the second approach is used. Hyperwave object with name my_object is mapped to http://host/my_object disregarding where it resides in the Hyperwave hierarchy. An object with name parent/my_object could be the child of my_object in the Hyperwave hierarchy, though in a web namespace it appears to be just the opposite and the user might get confused. This can only be prevented by selecting reasonable object names.

Having made this decision a second problem arises. How do you involve PHP? The URL http://host/my_object will not call any PHP script unless you tell your web server to rewrite it to e.g. http://host/php_script/my_object and the script php_script evaluates the $PATH_INFO variable and retrieves the object with name my_object from the Hyperwave server. Their is just one little drawback which can be fixed easily. Rewriting any URL would not allow any access to other document on the web server. A PHP script for searching in the Hyperwave server would be impossible. Therefore you will need at least a second rewriting rule to exclude certain URLs like all e.g. starting with http://host/Hyperwave This is basically sharing of a namespace by the web and Hyperwave server.

Based on the above mechanism links are insert into documents.

It gets more complicated if PHP is not run as a server module or CGI script but as a standalone application e.g. to dump the content of the Hyperwave server on a CD-ROM. In such a case it makes sense to retain the Hyperwave hierarchy and map in onto the file system. This conflicts with the object names if they reflect its own hierarchy (e.g. by choosing names including '/'). Therefore '/' has to be replaced by another character, e.g. '_'.

The network protocol to communicate with the Hyperwave server is called » HG-CSP (Hyper-G Client/Server Protocol). It is based on messages to initiate certain actions, e.g. get object record. In early versions of the Hyperwave Server two native clients (Harmony, Amadeus) were provided for communication with the server. Those two disappeared when Hyperwave was commercialised. As a replacement a so called wavemaster was provided. The wavemaster is like a protocol converter from HTTP to HG-CSP. The idea is to do all the administration of the database and visualisation of documents by a web interface. The wavemaster implements a set of placeholders for certain actions to customise the interface. This set of placeholders is called the PLACE Language. PLACE lacks a lot of features of a real programming language and any extension to it only enlarges the list of placeholders. This has led to the use of JavaScript which IMO does not make life easier.

Adding Hyperwave support to PHP should fill in the gap of a missing programming language for interface customisation. It implements all the messages as defined by the HG-CSP but also provides more powerful commands to e.g. retrieve complete documents.

Hyperwave has its own terminology to name certain pieces of information. This has widely been taken over and extended. Almost all functions operate on one of the following data types.

  • object ID: A unique integer value for each object in the Hyperwave server. It is also one of the attributes of the object record (ObjectID). Object ids are often used as an input parameter to specify an object.
  • object record: A string with attribute-value pairs of the form attribute=value. The pairs are separated by a carriage return from each other. An object record can easily be converted into an object array with hw_object2array(). Several functions return object records. The names of those functions end with obj.
  • object array: An associative array with all attributes of an object. The keys are the attribute names. If an attribute occurs more than once in an object record it will result in another indexed or associative array. Attributes which are language depended (like the title, keyword, description) will form an associative array with the keys set to the language abbreviations. All other multiple attributes will form an indexed array. PHP functions never return object arrays.
  • hw_document: This is a complete new data type which holds the actual document, e.g. HTML, PDF etc. It is somewhat optimized for HTML documents but may be used for any format.

Several functions which return an array of object records do also return an associative array with statistical information about them. The array is the last element of the object record array. The statistical array contains the following entries:

Hidden
Number of object records with attribute PresentationHints set to Hidden.
CollectionHead
Number of object records with attribute PresentationHints set to CollectionHead.
FullCollectionHead
Number of object records with attribute PresentationHints set to FullCollectionHead.
CollectionHeadNr
Index in array of object records with attribute PresentationHints set to CollectionHead.
FullCollectionHeadNr
Index in array of object records with attribute PresentationHints set to FullCollectionHead.
Total
Total: Number of object records.

Požadavky

This extension needs a Hyperwave server downloadable from » http://www.hyperwave.com/.

Instalace

Toto rozšíření » PECL není přibaleno k PHP.

In order to use these functions you must compile PHP with Hyperwave support by using the --with-hyperwave[=DIR] configure option.

Windows users will enable php_hyperwave.dll inside of php.ini in order to use these functions. Tuto DLL knihovnu pro rozšíření PECL můžete stahovat ze stránky » PHP Downloads nebo z » http://snaps.php.net/.

Integration with Apache

The Hyperwave extension is best used when PHP is compiled as an Apache module. In such a case the underlying Hyperwave server can be hidden from users almost completely if Apache uses its rewriting engine. The following instructions will explain this.

Since PHP with Hyperwave support built into Apache is intended to replace the native Hyperwave solution based on Wavemaster, we will assume that the Apache server will only serve as a Hyperwave web interface for these examples. This is not necessary but it simplifies the configuration. The concept is quite simple. First of all you need a PHP script which evaluates the $_ENV['PATH_INFO'] variable and treats its value as the name of a Hyperwave object. Let's call this script 'Hyperwave'. The URL http://your.hostname/Hyperwave/name_of_object would than return the Hyperwave object with the name 'name_of_object'. Depending on the type of the object the script has to react accordingly. If it is a collection, it will probably return a list of children. If it is a document it will return the mime type and the content. A slight improvement can be achieved if the Apache rewriting engine is used. From the users point of view it would be more straight forward if the URL http://your.hostname/name_of_object would return the object. The rewriting rule is quite easy:

RewriteRule ^/(.*) /usr/local/apache/htdocs/HyperWave/$1 [L]
Now every URL relates to an object in the Hyperwave server. This causes a simple to solve problem. There is no way to execute a different script, e.g. for searching, than the 'Hyperwave' script. This can be fixed with another rewriting rule like the following:

RewriteRule ^/hw/(.*) /usr/local/apache/htdocs/hw/$1 [L]
This will reserve the directory /usr/local/apache/htdocs/hw for additional scripts and other files. Just make sure this rule is evaluated before the one above. There is just a little drawback: all Hyperwave objects whose name starts with 'hw/' will be shadowed. So, make sure you don't use such names. If you need more directories, e.g. for images just add more rules or place them all in one directory. Before you put those instructions, don't forget to turn on the rewriting engine with

RewriteEngine on
You will need scripts:
  • to return the object itself
  • to allow searching
  • to identify yourself
  • to set your profile
  • one for each additional function like to show the object attributes, to show information about users, to show the status of the server, etc.

As an alternative to the Rewrite Engine, you can also consider using the Apache ErrorDocument directive, but be aware, that ErrorDocument redirected pages cannot receive POST data.

Konfigurace běhu

Chování těchto funkcí je ovlivněno nastavením parametrů v php.ini.

Tabulka 113. Hyperwave configuration options

Name | Default | Changeable | Changelog
hyperwave.allow_persistent | "0" | PHP_INI_SYSTEM | Available since PHP 4.3.2. Removed in PHP 5.0.0.
hyperwave.default_port | "418" | PHP_INI_ALL | Removed in PHP 5.0.0.

Pro další detaily a definice konstant PHP_INI_*, viz dokumentace k ini_set().

Typy prostředků

Toto rozšíření nemá definován žádný typ prostředku (resource).

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

HW_ATTR_LANG (integer)
HW_ATTR_NR (integer)
HW_ATTR_NONE (integer)

Todo

There are still some things to do:

  • The hw_InsertDocument has to be split into hw_insertobject() and hw_putdocument().
  • The names of several functions are not fixed, yet.
  • Most functions require the current connection as its first parameter. This leads to a lot of typing, which is quite often not necessary if there is just one open connection. A default connection will improve this.
  • Conversion form object record into object array needs to handle any multiple attribute.

Obsah

hw_Array2Objrec — Convert attributes from object array to object record
hw_changeobject — Changes attributes of an object (obsolete)
hw_Children — Object ids of children
hw_ChildrenObj — Object records of children
hw_Close — Closes the Hyperwave connection
hw_Connect — Opens a connection
hw_connection_info — Prints information about the connection to Hyperwave server
hw_cp — Copies objects
hw_Deleteobject — Deletes object
hw_DocByAnchor — Object id object belonging to anchor
hw_DocByAnchorObj — Object record object belonging to anchor
hw_Document_Attributes — Object record of hw_document
hw_Document_BodyTag — Body tag of hw_document
hw_Document_Content — Returns content of hw_document
hw_Document_SetContent — Sets/replaces content of hw_document
hw_Document_Size — Size of hw_document
hw_dummy — Hyperwave dummy function
hw_EditText — Retrieve text document
hw_Error — Error number
hw_ErrorMsg — Returns error message
hw_Free_Document — Frees hw_document
hw_GetAnchors — Object ids of anchors of document
hw_GetAnchorsObj — Object records of anchors of document
hw_GetAndLock — Return object record and lock object
hw_GetChildColl — Object ids of child collections
hw_GetChildCollObj — Object records of child collections
hw_GetChildDocColl — Object ids of child documents of collection
hw_GetChildDocCollObj — Object records of child documents of collection
hw_GetObject — Object record
hw_GetObjectByQuery — Search object
hw_GetObjectByQueryColl — Search object in collection
hw_GetObjectByQueryCollObj — Search object in collection
hw_GetObjectByQueryObj — Search object
hw_GetParents — Object ids of parents
hw_GetParentsObj — Object records of parents
hw_getrellink — Get link from source to dest relative to rootid
hw_GetRemote — Gets a remote document
hw_getremotechildren — Gets children of remote document
hw_GetSrcByDestObj — Returns anchors pointing at object
hw_GetText — Retrieve text document
hw_getusername — Name of currently logged in user
hw_Identify — Identifies as user
hw_InCollections — Check if object ids in collections
hw_Info — Info about connection
hw_InsColl — Insert collection
hw_InsDoc — Insert document
hw_insertanchors — Inserts only anchors into text
hw_InsertDocument — Upload any document
hw_InsertObject — Inserts an object record
hw_mapid — Maps global id on virtual local id
hw_Modifyobject — Modifies object record
hw_mv — Moves objects
hw_New_Document — Create new document
hw_objrec2array — Convert attributes from object record to object array
hw_Output_Document — Prints hw_document
hw_pConnect — Make a persistent database connection
hw_PipeDocument — Retrieve any document
hw_Root — Root object id
hw_setlinkroot — Set the id to which links are calculated
hw_stat — Returns status string
hw_Unlock — Unlock object
hw_Who — List of currently logged in users
Předcházející | Nahoru | Další
http_build_url | Domů | hw_Array2Objrec


hw_Array2Objrec

(PHP 4)

hw_Array2Objrec — Convert attributes from object array to object record

Description

string hw_array2objrec ( array $object_array )

Converts an object_array into an object record. Multiple attributes like 'Title' in different languages are treated properly.

See also hw_objrec2array().

Předcházející | Nahoru | Další
LVII. Hyperwave Functions | Domů | hw_changeobject


hw_changeobject

(PHP 4)

hw_changeobject — Changes attributes of an object (obsolete)

Description

bool hw_changeobject ( int $link, int $objid, array $attributes )

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
hw_Array2Objrec | Domů | hw_Children


hw_Children

(PHP 4)

hw_Children — Object ids of children

Description

array hw_children ( int $connection, int $objectID )

Returns an array of object ids. Each id belongs to a child of the collection with ID objectID. The array contains all children both documents and collections.

Předcházející | Nahoru | Další
hw_changeobject | Domů | hw_ChildrenObj


hw_ChildrenObj

(PHP 4)

hw_ChildrenObj — Object records of children

Description

array hw_childrenobj ( int $connection, int $objectID )

Returns an array of object records. Each object record belongs to a child of the collection with ID objectID. The array contains all children both documents and collections.

Předcházející | Nahoru | Další
hw_Children | Domů | hw_Close


hw_Close

(PHP 4)

hw_Close — Closes the Hyperwave connection

Description

bool hw_close ( int $connection )

Returns FALSE if connection is not a valid connection index, otherwise TRUE. Closes down the connection to a Hyperwave server with the given connection index.

Předcházející | Nahoru | Další
hw_ChildrenObj | Domů | hw_Connect


hw_Connect

(PHP 4)

hw_Connect — Opens a connection

Description

int hw_connect ( string $host, int $port [, string $username, string $password] )

Opens a connection to a Hyperwave server and returns a connection index on success, or FALSE if the connection could not be made. Each of the arguments should be a quoted string, except for the port number. The username and password arguments are optional and can be left out. In such a case no identification with the server will be done. It is similar to identify as user anonymous. This function returns a connection index that is needed by other Hyperwave functions. You can have multiple connections open at once. Keep in mind, that the password is not encrypted.

See also hw_pconnect().

Předcházející | Nahoru | Další
hw_Close | Domů | hw_connection_info


hw_connection_info

(PHP 4)

hw_connection_info — Prints information about the connection to Hyperwave server

Description

void hw_connection_info ( int $link )

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
hw_Connect | Domů | hw_cp


hw_cp

(PHP 4)

hw_cp — Copies objects

Description

int hw_cp ( int $connection, array $object_id_array, int $destination_id )

Copies the objects with object ids as specified in the second parameter to the collection with the id destination id.

The value return is the number of copied objects.

See also hw_mv().

Předcházející | Nahoru | Další
hw_connection_info | Domů | hw_Deleteobject


hw_Deleteobject

(PHP 4)

hw_Deleteobject — Deletes object

Description

bool hw_deleteobject ( int $connection, int $object_to_delete )

Deletes the object with the given object id in the second parameter. It will delete all instances of the object.

Returns TRUE if no error occurs otherwise FALSE.

See also hw_mv().

Předcházející | Nahoru | Další
hw_cp | Domů | hw_DocByAnchor


hw_DocByAnchor

(PHP 4)

hw_DocByAnchor — Object id object belonging to anchor

Description

int hw_docbyanchor ( int $connection, int $anchorID )

Returns an th object id of the document to which anchorID belongs.

Předcházející | Nahoru | Další
hw_Deleteobject | Domů | hw_DocByAnchorObj


hw_DocByAnchorObj

(PHP 4)

hw_DocByAnchorObj — Object record object belonging to anchor

Description

string hw_docbyanchorobj ( int $connection, int $anchorID )

Returns an th object record of the document to which anchorID belongs.

Předcházející | Nahoru | Další
hw_DocByAnchor | Domů | hw_Document_Attributes


hw_Document_Attributes

(PHP 4)

hw_Document_Attributes — Object record of hw_document

Description

string hw_document_attributes ( int $hw_document )

Returns the object record of the document.

For backward compatibility, hw_documentattributes() is also accepted. This is deprecated, however.

See also hw_document_bodytag(), and hw_document_size().

Předcházející | Nahoru | Další
hw_DocByAnchorObj | Domů | hw_Document_BodyTag


hw_Document_BodyTag

(PHP 4)

hw_Document_BodyTag — Body tag of hw_document

Description

string hw_document_bodytag ( int $hw_document [, string $prefix] )

Returns the BODY tag of the document. If the document is an HTML document the BODY tag should be printed before the document.

See also hw_document_attributes(), and hw_document_size().

For backward compatibility, hw_documentbodytag() is also accepted. This is deprecated, however.

Předcházející | Nahoru | Další
hw_Document_Attributes | Domů | hw_Document_Content


hw_Document_Content

(PHP 4)

hw_Document_Content — Returns content of hw_document

Description

string hw_document_content ( int $hw_document )

Returns the content of the document. If the document is an HTML document the content is everything after the BODY tag. Information from the HEAD and BODY tag is in the stored in the object record.

See also hw_document_attributes(),
hw_document_size(),
and hw_document_setcontent().

Předcházející | Nahoru | Další
hw_Document_BodyTag | Domů | hw_Document_SetContent


hw_Document_SetContent

(PHP 4)

hw_Document_SetContent — Sets/replaces content of hw_document

Description

bool hw_document_setcontent ( int $hw_document, string $content )

Sets or replaces the content of the document. If the document is an HTML document the content is everything after the BODY tag. Information from the HEAD and BODY tag is in the stored in the object record. If you provide this information in the content of the document too, the Hyperwave server will change the object record accordingly when the document is inserted. Probably not a very good idea. If this functions fails the document will retain its old content.

See also hw_document_attributes(),
hw_document_size(),
and hw_document_content().

Předcházející | Nahoru | Další
hw_Document_Content | Domů | hw_Document_Size


hw_Document_Size

(PHP 4)

hw_Document_Size — Size of hw_document

Description

int hw_document_size ( int $hw_document )

Returns the size in bytes of the document.

See also hw_document_bodytag(), and hw_document_attributes().

For backward compatibility, hw_documentsize() is also accepted. This is deprecated, however.

Předcházející | Nahoru | Další
hw_Document_SetContent | Domů | hw_dummy


hw_dummy

(PHP 4)

hw_dummy — Hyperwave dummy function

Description

string hw_dummy ( int $link, int $id, int $msgid )

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
hw_Document_Size | Domů | hw_EditText


hw_EditText

(PHP 4)

hw_EditText — Retrieve text document

Description

bool hw_edittext ( int $connection, int $hw_document )

Uploads the text document to the server. The object record of the document may not be modified while the document is edited. This function will only works for pure text documents. It will not open a special data connection and therefore blocks the control connection during the transfer.

See also hw_pipedocument(),
hw_free_document(),
hw_document_bodytag(),
hw_document_size(),
hw_output_document(), and
hw_gettext().

Předcházející | Nahoru | Další
hw_dummy | Domů | hw_Error


hw_Error

(PHP 4)

hw_Error — Error number

Description

int hw_error ( int $connection )

Returns the last error number. If the return value is 0 no error has occurred. The error relates to the last command.

Předcházející | Nahoru | Další
hw_EditText | Domů | hw_ErrorMsg


hw_ErrorMsg

(PHP 4)

hw_ErrorMsg — Returns error message

Description

string hw_errormsg ( int $connection )

Returns a string containing the last error message or 'No Error'. If FALSE is returned, this function failed. The message relates to the last command.

Předcházející | Nahoru | Další
hw_Error | Domů | hw_Free_Document


hw_Free_Document

(PHP 4)

hw_Free_Document — Frees hw_document

Description

bool hw_free_document ( int $hw_document )

Frees the memory occupied by the Hyperwave document.

Předcházející | Nahoru | Další
hw_ErrorMsg | Domů | hw_GetAnchors


hw_GetAnchors

(PHP 4)

hw_GetAnchors — Object ids of anchors of document

Description

array hw_getanchors ( int $connection, int $objectID )

Returns an array of object ids with anchors of the document with object ID objectID.

Předcházející | Nahoru | Další
hw_Free_Document | Domů | hw_GetAnchorsObj


hw_GetAnchorsObj

(PHP 4)

hw_GetAnchorsObj — Object records of anchors of document

Description

array hw_getanchorsobj ( int $connection, int $objectID )

Returns an array of object records with anchors of the document with object ID objectID.

Předcházející | Nahoru | Další
hw_GetAnchors | Domů | hw_GetAndLock


hw_GetAndLock

(PHP 4)

hw_GetAndLock — Return object record and lock object

Description

string hw_getandlock ( int $connection, int $objectID )

Returns the object record for the object with ID objectID. It will also lock the object, so other users cannot access it until it is unlocked.

See also hw_unlock(), and hw_getobject().

Předcházející | Nahoru | Další
hw_GetAnchorsObj | Domů | hw_GetChildColl


hw_GetChildColl

(PHP 4)

hw_GetChildColl — Object ids of child collections

Description

array hw_getchildcoll ( int $connection, int $objectID )

Returns an array of object ids. Each object ID belongs to a child collection of the collection with ID objectID. The function will not return child documents.

See also hw_children(), and hw_getchilddoccoll().

Předcházející | Nahoru | Další
hw_GetAndLock | Domů | hw_GetChildCollObj


hw_GetChildCollObj

(PHP 4)

hw_GetChildCollObj — Object records of child collections

Description

array hw_getchildcollobj ( int $connection, int $objectID )

Returns an array of object records. Each object records belongs to a child collection of the collection with ID objectID. The function will not return child documents.

See also hw_childrenobj(), and hw_getchilddoccollobj().

Předcházející | Nahoru | Další
hw_GetChildColl | Domů | hw_GetChildDocColl


hw_GetChildDocColl

(PHP 4)

hw_GetChildDocColl — Object ids of child documents of collection

Description

array hw_getchilddoccoll ( int $connection, int $objectID )

Returns array of object ids for child documents of a collection.

See also hw_children(), and hw_getchildcoll().

Předcházející | Nahoru | Další
hw_GetChildCollObj | Domů | hw_GetChildDocCollObj


hw_GetChildDocCollObj

(PHP 4)

hw_GetChildDocCollObj — Object records of child documents of collection

Description

array hw_getchilddoccollobj ( int $connection, int $objectID )

Returns an array of object records for child documents of a collection.

See also hw_childrenobj(), and hw_getchildcollobj().

Předcházející | Nahoru | Další
hw_GetChildDocColl | Domů | hw_GetObject


hw_GetObject

(PHP 4)

hw_GetObject — Object record

Description

mixed hw_getobject ( int $connection, mixed $objectID [, string $query] )

Returns the object record for the object with ID objectID if the second parameter is an integer. If the second parameter is an array of integer the function will return an array of object records. In such a case the last parameter is also evaluated which is a query string.

The query string has the following syntax:

<expr> ::= "(" <expr> ")" |

"!" <expr> | /* NOT */

<expr> "||" <expr> | /* OR */

<expr> "&&" <expr> | /* AND */

<attribute> <operator> <value>

<attribute> ::= /* any attribute name (Title, Author, DocumentType ...) */

<operator> ::= "=" | /* equal */

"<" | /* less than (string compare) */

">" | /* greater than (string compare) */

"~" /* regular expression matching */

The query allows to further select certain objects from the list of given objects. Unlike the other query functions, this query may use not indexed attributes. How many object records are returned depends on the query and if access to the object is allowed.

See also hw_getandlock(), and hw_getobjectbyquery().

Předcházející | Nahoru | Další
hw_GetChildDocCollObj | Domů | hw_GetObjectByQuery


hw_GetObjectByQuery

(PHP 4)

hw_GetObjectByQuery — Search object

Description

array hw_getobjectbyquery ( int $connection, string $query, int $max_hits )

Searches for objects on the whole server and returns an array of object ids. The maximum number of matches is limited to max_hits. If max_hits is set to -1 the maximum number of matches is unlimited.

The query will only work with indexed attributes.

See also hw_getobjectbyqueryobj().

Předcházející | Nahoru | Další
hw_GetObject | Domů | hw_GetObjectByQueryColl


hw_GetObjectByQueryColl

(PHP 4)

hw_GetObjectByQueryColl — Search object in collection

Description

array hw_getobjectbyquerycoll ( int $connection, int $objectID, string $query, int $max_hits )

Searches for objects in collection with ID objectID and returns an array of object ids. The maximum number of matches is limited to max_hits. If max_hits is set to -1 the maximum number of matches is unlimited.

The query will only work with indexed attributes.

See also hw_getobjectbyquerycollobj().

Předcházející | Nahoru | Další
hw_GetObjectByQuery | Domů | hw_GetObjectByQueryCollObj


hw_GetObjectByQueryCollObj

(PHP 4)

hw_GetObjectByQueryCollObj — Search object in collection

Description

array hw_getobjectbyquerycollobj ( int $connection, int $objectID, string $query, int $max_hits )

Searches for objects in collection with ID objectID and returns an array of object records. The maximum number of matches is limited to max_hits. If max_hits is set to -1 the maximum number of matches is unlimited.

The query will only work with indexed attributes.

See also hw_getobjectbyquerycoll().

Předcházející | Nahoru | Další
hw_GetObjectByQueryColl | Domů | hw_GetObjectByQueryObj


hw_GetObjectByQueryObj

(PHP 4)

hw_GetObjectByQueryObj — Search object

Description

array hw_getobjectbyqueryobj ( int $connection, string $query, int $max_hits )

Searches for objects on the whole server and returns an array of object records. The maximum number of matches is limited to max_hits. If max_hits is set to -1 the maximum number of matches is unlimited.

The query will only work with indexed attributes.

See also hw_getobjectbyquery().

Předcházející | Nahoru | Další
hw_GetObjectByQueryCollObj | Domů | hw_GetParents


hw_GetParents

(PHP 4)

hw_GetParents — Object ids of parents

Description

array hw_getparents ( int $connection, int $objectID )

Returns an indexed array of object ids. Each object id belongs to a parent of the object with ID objectID.

Předcházející | Nahoru | Další
hw_GetObjectByQueryObj | Domů | hw_GetParentsObj


hw_GetParentsObj

(PHP 4)

hw_GetParentsObj — Object records of parents

Description

array hw_getparentsobj ( int $connection, int $objectID )

Returns an indexed array of object records plus an associated array with statistical information about the object records. The associated array is the last entry of the returned array. Each object record belongs to a parent of the object with ID objectID.

Předcházející | Nahoru | Další
hw_GetParents | Domů | hw_getrellink


hw_getrellink

(PHP 4)

hw_getrellink — Get link from source to dest relative to rootid

Description

string hw_getrellink ( int $link, int $rootid, int $sourceid, int $destid )

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
hw_GetParentsObj | Domů | hw_GetRemote


hw_GetRemote

(PHP 4)

hw_GetRemote — Gets a remote document

Description

int hw_getremote ( int $connection, int $objectID )

Returns a remote document. Remote documents in Hyperwave notation are documents retrieved from an external source. Common remote documents are for example external web pages or queries in a database. In order to be able to access external sources through remote documents Hyperwave introduces the HGI (Hyperwave Gateway Interface) which is similar to the CGI. Currently, only ftp, http-servers and some databases can be accessed by the HGI. Calling hw_getremote() returns the document from the external source. If you want to use this function you should be very familiar with HGIs. You should also consider to use PHP instead of Hyperwave to access external sources. Adding database support by a Hyperwave gateway should be more difficult than doing it in PHP.

See also hw_getremotechildren().

Předcházející | Nahoru | Další
hw_getrellink | Domů | hw_getremotechildren


hw_getremotechildren

(PHP 4)

hw_getremotechildren — Gets children of remote document

Description

mixed hw_getremotechildren ( int $connection, string $object_record )

Returns the children of a remote document. Children of a remote document are remote documents itself. This makes sense if a database query has to be narrowed and is explained in Hyperwave Programmers' Guide. If the number of children is 1 the function will return the document itself formatted by the Hyperwave Gateway Interface (HGI). If the number of children is greater than 1 it will return an array of object record with each maybe the input value for another call to hw_getremotechildren(). Those object records are virtual and do not exist in the Hyperwave server, therefore they do not have a valid object ID. How exactly such an object record looks like is up to the HGI. If you want to use this function you should be very familiar with HGIs. You should also consider to use PHP instead of Hyperwave to access external sources. Adding database support by a Hyperwave gateway should be more difficult than doing it in PHP.

See also hw_getremote().

Předcházející | Nahoru | Další
hw_GetRemote | Domů | hw_GetSrcByDestObj


hw_GetSrcByDestObj

(PHP 4)

hw_GetSrcByDestObj — Returns anchors pointing at object

Description

array hw_getsrcbydestobj ( int $connection, int $objectID )

Returns the object records of all anchors pointing to the object with ID objectID. The object can either be a document or an anchor of type destination.

See also hw_getanchors().

Předcházející | Nahoru | Další
hw_getremotechildren | Domů | hw_GetText


hw_GetText

(PHP 4)

hw_GetText — Retrieve text document

Description

int hw_gettext ( int $connection, int $objectID [, mixed $ rootID/prefix ] )

Returns the document with object ID objectID. If the document has anchors which can be inserted, they will be inserted already. The optional parameter rootID/prefix can be a string or an integer. If it is an integer it determines how links are inserted into the document. The default is 0 and will result in links that are constructed from the name of the link's destination object. This is useful for web applications. If a link points to an object with name 'internet_movie' the HTML link will be <A HREF="/internet_movie">. The actual location of the source and destination object in the document hierarchy is disregarded. You will have to set up your web browser, to rewrite that URL to for example '/my_script.php3/internet_movie'. 'my_script.php3' will have to evaluate $PATH_INFO and retrieve the document. All links will have the prefix '/my_script.php3/'. If you do not want this you can set the optional parameter rootID/prefix to any prefix which is used instead. Is this case it has to be a string.

If rootID/prefix is an integer and unequal to 0 the link is constructed from all the names starting at the object with the id rootID/prefix separated by a slash relative to the current object. If for example the above document 'internet_movie' is located at 'a-b-c-internet_movie' with '-' being the separator between hierarchy levels on the Hyperwave server and the source document is located at 'a-b-d-source' the resulting HTML link would be: <A HREF="../c/internet_movie">. This is useful if you want to download the whole server content onto disk and map the document hierarchy onto the file system.

This function will only work for pure text documents. It will not open a special data connection and therefore blocks the control connection during the transfer.

See also hw_pipedocument(),
hw_free_document(),
hw_document_bodytag(),
hw_document_size(),
and hw_output_document().

Předcházející | Nahoru | Další
hw_GetSrcByDestObj | Domů | hw_getusername


hw_getusername

(PHP 4)

hw_getusername — Name of currently logged in user

Description

string hw_getusername ( int $connection )

Returns the username of the connection.

Předcházející | Nahoru | Další
hw_GetText | Domů | hw_Identify


hw_Identify

(PHP 4)

hw_Identify — Identifies as user

Description

string hw_identify ( int $link, string $username, string $password )

Identifies as user with username and password. Identification is only valid for the current session. I do not think this function will be needed very often. In most cases it will be easier to identify with the opening of the connection.

See also hw_connect().

Předcházející | Nahoru | Další
hw_getusername | Domů | hw_InCollections


hw_InCollections

(PHP 4)

hw_InCollections — Check if object ids in collections

Description

array hw_incollections ( int $connection, array $object_id_array, array $collection_id_array, int $return_collections )

Checks whether a set of objects (documents or collections) specified by the object_id_array is part of the collections listed in collection_id_array. When the fourth parameter return_collections is 0, the subset of object ids that is part of the collections (i.e., the documents or collections that are children of one or more collections of collection ids or their subcollections, recursively) is returned as an array. When the fourth parameter is 1, however, the set of collections that have one or more objects of this subset as children are returned as an array. This option allows a client to, e.g., highlight the part of the collection hierarchy that contains the matches of a previous query, in a graphical overview.

Předcházející | Nahoru | Další
hw_Identify | Domů | hw_Info


hw_Info

(PHP 4)

hw_Info — Info about connection

Description

string hw_info ( int $connection )

Returns information about the current connection. The returned string has the following format: <Serverstring>, <Host>, <Port>, <Username>, <Port of Client>, <Byte swapping>

Předcházející | Nahoru | Další
hw_InCollections | Domů | hw_InsColl


hw_InsColl

(PHP 4)

hw_InsColl — Insert collection

Description

int hw_inscoll ( int $connection, int $objectID, array $object_array )

Inserts a new collection with attributes as in object_array into collection with object ID objectID.

Předcházející | Nahoru | Další
hw_Info | Domů | hw_InsDoc


hw_InsDoc

(PHP 4)

hw_InsDoc — Insert document

Description

int hw_insdoc ( resource $connection, int $parentID, string $object_record [, string $text] )

Inserts a new document with attributes as in object_record into collection with object ID parentID. This function inserts either an object record only or an object record and a pure ascii text in text if text is given. If you want to insert a general document of any kind use hw_insertdocument() instead.

See also hw_insertdocument(), and hw_inscoll().

Předcházející | Nahoru | Další
hw_InsColl | Domů | hw_insertanchors


hw_insertanchors

(PHP 4 >= 4.0.4)

hw_insertanchors — Inserts only anchors into text

Description

bool hw_insertanchors ( int $hwdoc, array $anchorecs, array $dest [, array $urlprefixes] )

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
hw_InsDoc | Domů | hw_InsertDocument


hw_InsertDocument

(PHP 4)

hw_InsertDocument — Upload any document

Description

int hw_insertdocument ( int $connection, int $parent_id, int $hw_document )

Uploads a document into the collection with parent_id. The document has to be created before with hw_new_document(). Make sure that the object record of the new document contains at least the attributes: Type, DocumentType, Title and Name. Possibly you also want to set the MimeType. The functions returns the object id of the new document or FALSE.

See also hw_pipedocument().

Předcházející | Nahoru | Další
hw_insertanchors | Domů | hw_InsertObject


hw_InsertObject

(PHP 4)

hw_InsertObject — Inserts an object record

Description

int hw_insertobject ( int $connection, string $object_rec, string $parameter )

Inserts an object into the server. The object can be any valid hyperwave object. See the HG-CSP documentation for a detailed information on how the parameters have to be.

Note: If you want to insert an Anchor, the attribute Position has always been set either to a start/end value or to 'invisible'. Invisible positions are needed if the annotation has no corresponding link in the annotation text.

See also hw_pipedocument(),
hw_insertdocument(),
hw_insdoc(),
and hw_inscoll().

Předcházející | Nahoru | Další
hw_InsertDocument | Domů | hw_mapid


hw_mapid

(PHP 4)

hw_mapid — Maps global id on virtual local id

Description

int hw_mapid ( int $connection, int $server_id, int $object_id )

Maps a global object id on any hyperwave server, even those you did not connect to with hw_connect(), onto a virtual object id. This virtual object id can then be used as any other object id, e.g. to obtain the object record with hw_getobject(). The server id is the first part of the global object id (GOid) of the object which is actually the IP number as an integer.

Note: In order to use this function you will have to set the F_DISTRIBUTED flag, which can currently only be set at compile time in hg_comm.c. It is not set by default. Read the comment at the beginning of hg_comm.c

Předcházející | Nahoru | Další
hw_InsertObject | Domů | hw_Modifyobject


hw_Modifyobject

(PHP 4)

hw_Modifyobject — Modifies object record

Description

bool hw_modifyobject ( int $connection, int $object_to_change, array $remove, array $add [, int $mode] )

This command allows to remove, add, or modify individual attributes of an object record. The object is specified by the Object ID object_to_change. The first array remove is a list of attributes to remove. The second array add is a list of attributes to add. In order to modify an attribute one will have to remove the old one and add a new one. hw_modifyobject() will always remove the attributes before it adds attributes unless the value of the attribute to remove is not a string or array.

The last parameter determines if the modification is performed recursively. 1 means recursive modification. If some of the objects cannot be modified they will be skipped without notice. hw_error() may not indicate an error though some of the objects could not be modified.

The keys of both arrays are the attributes name. The value of each array element can either be an array, a string or anything else. If it is an array each attribute value is constructed by the key of each element plus a colon and the value of each element. If it is a string it is taken as the attribute value. An empty string will result in a complete removal of that attribute. If the value is neither a string nor an array but something else, e.g. an integer, no operation at all will be performed on the attribute. This is necessary if you want to add a completely new attribute not just a new value for an existing attribute. If the remove array contained an empty string for that attribute, the attribute would be tried to be removed which would fail since it doesn't exist. The following addition of a new value for that attribute would also fail. Setting the value for that attribute to e.g. 0 would not even try to remove it and the addition will work.

If you would like to change the attribute 'Name' with the current value 'books' into 'articles' you will have to create two arrays and call hw_modifyobject().

Příklad 752. modifying an attribute

<?php
       // $connect is an existing connection to the Hyperwave server
       // $objid is the ID of the object to modify
       $remarr = array("Name" => "books");
       $addarr = array("Name" => "articles");
       $hw_modifyobject($connect, $objid, $remarr, $addarr);
?>

In order to delete/add a name=value pair from/to the object record just pass the remove/add array and set the last/third parameter to an empty array. If the attribute is the first one with that name to add, set attribute value in the remove array to an integer.

Příklad 753. adding a completely new attribute

<?php
       // $connect is an existing connection to the Hyperwave server
       // $objid is the ID of the object to modify
       $remarr = array("Name" => 0);
       $addarr = array("Name" => "articles");
       $hw_modifyobject($connect, $objid, $remarr, $addarr);
?>

Poznámka: Multilingual attributes, e.g. 'Title', can be modified in two ways. Either by providing the attributes value in its native form 'language':'title' or by providing an array with elements for each language as described above. The above example would than be:

Příklad 754. modifying Title attribute

<?php
       $remarr = array("Title" => "en:Books");
       $addarr = array("Title" => "en:Articles");
       $hw_modifyobject($connect, $objid, $remarr, $addarr);
?>

or

Příklad 755. modifying Title attribute

<?php
       $remarr = array("Title" => array("en" => "Books"));
       $addarr = array("Title" => array("en" => "Articles", "ge"=>"Artikel"));
       $hw_modifyobject($connect, $objid, $remarr, $addarr);
?>

This removes the English title 'Books' and adds the English title 'Articles' and the German title 'Artikel'.

Příklad 756. removing attribute

<?php
       $remarr = array("Title" => "");
       $addarr = array("Title" => "en:Articles");
       $hw_modifyobject($connect, $objid, $remarr, $addarr);
?>

Poznámka: This will remove all attributes with the name 'Title' and adds a new 'Title' attribute. This comes in handy if you want to remove attributes recursively.

Poznámka: If you need to delete all attributes with a certain name you will have to pass an empty string as the attribute value.

Poznámka: Only the attributes 'Title', 'Description' and 'Keyword' will properly handle the language prefix. If those attributes don't carry a language prefix, the prefix 'xx' will be assigned.

Poznámka: The 'Name' attribute is somewhat special. In some cases it cannot be complete removed. You will get an error message 'Change of base attribute' (not clear when this happens). Therefore you will always have to add a new Name first and than remove the old one.

Poznámka: You may not surround this function by calls to hw_getandlock() and hw_unlock(). hw_modifyobject() does this internally.

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
hw_mapid | Domů | hw_mv


hw_mv

(PHP 4)

hw_mv — Moves objects

Description

int hw_mv ( int $connection, array $object_id_array, int $source_id, int $destination_id )

Moves the objects with object ids as specified in the second parameter from the collection with id source_id to the collection with the id destination_id. If the destination id is 0 the objects will be unlinked from the source collection. If this is the last instance of that object it will be deleted. If you want to delete all instances at once, use hw_deleteobject().

The value returned is the number of moved objects.

See also hw_cp(), and hw_deleteobject().

Předcházející | Nahoru | Další
hw_Modifyobject | Domů | hw_New_Document


hw_New_Document

(PHP 4)

hw_New_Document — Create new document

Description

int hw_new_document ( string $object_record, string $document_data, int $document_size )

Returns a new Hyperwave document with document data set to document_data and object record set to object_record. The length of the document_data has to passed in document_sizeThis function does not insert the document into the Hyperwave server.

See also hw_free_document(),
hw_document_size(),
hw_document_bodytag(),
hw_output_document(),
and hw_insertdocument().

Předcházející | Nahoru | Další
hw_mv | Domů | hw_objrec2array


hw_objrec2array

(PHP 4)

hw_objrec2array — Convert attributes from object record to object array

Description

array hw_objrec2array ( string $object_record [, array $ format ] )

Converts an object_record into an object array. The keys of the resulting array are the attributes names. Multi-value attributes like 'Title' in different languages form its own array. The keys of this array are the left part to the colon of the attribute value. This left part must be two characters long. Other multi-value attributes without a prefix form an indexed array. If the optional parameter is missing the attributes 'Title', 'Description' and 'Keyword' are treated as language attributes and the attributes 'Group', 'Parent' and 'HtmlAttr' as non-prefixed multi-value attributes. By passing an array holding the type for each attribute you can alter this behaviour. The array is an associated array with the attribute name as its key and the value being one of HW_ATTR_LANG or HW_ATTR_NONE.

See also hw_array2objrec().

Předcházející | Nahoru | Další
hw_New_Document | Domů | hw_Output_Document


hw_Output_Document

(PHP 4)

hw_Output_Document — Prints hw_document

Description

bool hw_output_document ( int $hw_document )

Prints the document without the BODY tag.

For backward compatibility, hw_outputdocument() is also accepted. This is deprecated, however.

Předcházející | Nahoru | Další
hw_objrec2array | Domů | hw_pConnect


hw_pConnect

(PHP 4)

hw_pConnect — Make a persistent database connection

Description

int hw_pconnect ( string $host, int $port [, string $username, string $password] )

Returns a connection index on success, or FALSE if the connection could not be made. Opens a persistent connection to a Hyperwave server. Each of the arguments should be a quoted string, except for the port number. The username and password arguments are optional and can be left out. In such a case no identification with the server will be done. It is similar to identify as user anonymous. This function returns a connection index that is needed by other Hyperwave functions. You can have multiple persistent connections open at once.

See also hw_connect().

Předcházející | Nahoru | Další
hw_Output_Document | Domů | hw_PipeDocument


hw_PipeDocument

(PHP 4)

hw_PipeDocument — Retrieve any document

Description

int hw_pipedocument ( int $connection, int $objectID [, array $url_prefixes] )

Returns the Hyperwave document with object ID objectID. If the document has anchors which can be inserted, they will have been inserted already. The document will be transferred via a special data connection which does not block the control connection.

See also hw_gettext() for more on link insertion,
hw_free_document(),
hw_document_size(),
hw_document_bodytag(),
and hw_output_document().

Předcházející | Nahoru | Další
hw_pConnect | Domů | hw_Root


hw_Root

(PHP 4)

hw_Root — Root object id

Description

int hw_root ( $ )

Returns the object ID of the hyperroot collection. Currently this is always 0. The child collection of the hyperroot is the root collection of the connected server.

Předcházející | Nahoru | Další
hw_PipeDocument | Domů | hw_setlinkroot


hw_setlinkroot

(PHP 4)

hw_setlinkroot — Set the id to which links are calculated

Description

int hw_setlinkroot ( int $link, int $rootid )

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
hw_Root | Domů | hw_stat


hw_stat

(PHP 4)

hw_stat — Returns status string

Description

string hw_stat ( int $link )

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
hw_setlinkroot | Domů | hw_Unlock


hw_Unlock

(PHP 4)

hw_Unlock — Unlock object

Description

bool hw_unlock ( int $connection, int $objectID )

Unlocks a document, so other users regain access.

See also hw_getandlock().

Předcházející | Nahoru | Další
hw_stat | Domů | hw_Who


hw_Who

(PHP 4)

hw_Who — List of currently logged in users

Description

array hw_who ( int $connection )

Returns an array of users currently logged into the Hyperwave server. Each entry in this array is an array itself containing the elements id, name, system, onSinceDate, onSinceTime, TotalTime and self. 'self' is 1 if this entry belongs to the user who initiated the request.

Předcházející | Nahoru | Další
hw_Unlock | Domů | LVIII. Hyperwave API Functions


Hyperwave API Functions

Předcházející VI. Reference funkcí Další

LVIII. Hyperwave API Functions

Úvod

Hyperwave has been developed at » IICM in Graz. It started with the name Hyper-G and changed to Hyperwave when it was commercialised (in 1996).

Hyperwave is not free software. The current version, 5.5, is available at » http://www.hyperwave.com/. A time limited version can be ordered for free (30 days).

See also the Hyperwave module.

Hyperwave is an information system similar to a database (HIS, Hyperwave Information Server). Its focus is the storage and management of documents. A document can be any possible piece of data that may as well be stored in file. Each document is accompanied by its object record. The object record contains meta data for the document. The meta data is a list of attributes which can be extended by the user. Certain attributes are always set by the Hyperwave server, other may be modified by the user.

Poznámka: Toto rozšíření bylo přesunuto do repozitáře PECL a již nebude součástí balíku PHP.5.2.0.

Požadavky

Since 2001 there is a Hyperwave SDK available. It supports Java, JavaScript and C++. This PHP Extension is based on the C++ interface. In order to activate the hwapi support in PHP you will have to install the Hyperwave SDK first.

Instalace

After installing the Hyperwave SDK, configure PHP with --with-hwapi[=DIR].

Integration with Apache

The integration with Apache and possible other servers is already described in the Hyperwave module which has been the first extension to connect a Hyperwave Server.

Konfigurace běhu

Chování těchto funkcí je ovlivněno nastavením parametrů v php.ini.

Tabulka 114. Hyperwave API configuration options

Name | Default | Changeable | Changelog
hwapi.allow_persistent | "0" | PHP_INI_SYSTEM |

Pro další detaily a definice konstant PHP_INI_*, viz dokumentace k ini_set().

Typy prostředků

Toto rozšíření nemá definován žádný typ prostředku (resource).

Předdefinované konstanty

Toto rozšíření nemá definovány žádné konstanty.

Classes

The API provided by the HW_API extension is fully object oriented. It is very similar to the C++ interface of the Hyperwave SDK. It consist of the following classes.

  • HW_API
  • HW_API_Object
  • HW_API_Attribute
  • HW_API_Error
  • HW_API_Content
  • HW_API_Reason
Some basic classes like HW_API_String, HW_API_String_Array, etc., which exist in the Hyperwave SDK have not been implemented since PHP has powerful replacements for them.

Each class has certain method, whose names are identical to its counterparts in the Hyperwave SDK. Passing arguments to this function differs from all the other PHP extensions but is close to the C++ API of the HW SDK. Instead of passing several parameters they are all put into an associated array and passed as one parameter. The names of the keys are identical to those documented in the HW SDK. The common parameters are listed below. If other parameters are required they will be documented if needed.

  • objectIdentifier The name or id of an object, e.g. "rootcollection", "0x873A8768 0x00000002".
  • parentIdentifier The name or id of an object which is considered to be a parent.
  • object An instance of class HW_API_Object.
  • parameters An instance of class HW_API_Object.
  • version The version of an object.
  • mode An integer value determine the way an operation is executed.
  • attributeSelector Any array of strings, each containing a name of an attribute. This is used if you retrieve the object record and want to include certain attributes.
  • objectQuery A query to select certain object out of a list of objects. This is used to reduce the number of objects which was delivered by a function like hw_api->children() or hw_api->find().

Poznámka: Methods returning boolean can return TRUE, FALSE or HW_API_Error object.

Obsah

hw_api_attribute->key — Returns key of the attribute
hw_api_attribute->langdepvalue — Returns value for a given language
hw_api_attribute->value — Returns value of the attribute
hw_api_attribute->values — Returns all values of the attribute
hw_api_attribute — Creates instance of class hw_api_attribute
hw_api->checkin — Checks in an object
hw_api->checkout — Checks out an object
hw_api->children — Returns children of an object
hw_api_content->mimetype — Returns mimetype
hw_api_content->read — Read content
hw_api->content — Returns content of an object
hw_api->copy — Copies physically
hw_api->dbstat — Returns statistics about database server
hw_api->dcstat — Returns statistics about document cache server
hw_api->dstanchors — Returns a list of all destination anchors
hw_api->dstofsrcanchor — Returns destination of a source anchor
hw_api_error->count — Returns number of reasons
hw_api_error->reason — Returns reason of error
hw_api->find — Search for objects
hw_api->ftstat — Returns statistics about fulltext server
hwapi_hgcsp — Returns object of class hw_api
hw_api->hwstat — Returns statistics about Hyperwave server
hw_api->identify — Log into Hyperwave Server
hw_api->info — Returns information about server configuration
hw_api->insert — Inserts a new object
hw_api->insertanchor — Inserts a new object of type anchor
hw_api->insertcollection — Inserts a new object of type collection
hw_api->insertdocument — Inserts a new object of type document
hw_api->link — Creates a link to an object
hw_api->lock — Locks an object
hw_api->move — Moves object between collections
hw_api_content — Create new instance of class hw_api_content
hw_api_object->assign — Clones object
hw_api_object->attreditable — Checks whether an attribute is editable
hw_api_object->count — Returns number of attributes
hw_api_object->insert — Inserts new attribute
hw_api_object — Creates a new instance of class hw_api_object
hw_api_object->remove — Removes attribute
hw_api_object->title — Returns the title attribute
hw_api_object->value — Returns value of attribute
hw_api->object — Retrieve attribute information
hw_api->objectbyanchor — Returns the object an anchor belongs to
hw_api->parents — Returns parents of an object
hw_api_reason->description — Returns description of reason
hw_api_reason->type — Returns type of reason
hw_api->remove — Delete an object
hw_api->replace — Replaces an object
hw_api->setcommittedversion — Commits version other than last version
hw_api->srcanchors — Returns a list of all source anchors
hw_api->srcsofdst — Returns source of a destination object
hw_api->unlock — Unlocks a locked object
hw_api->user — Returns the own user object
hw_api->userlist — Returns a list of all logged in users
Předcházející | Nahoru | Další
hw_Who | Domů | hw_api_attribute->key


hw_api_attribute->key

(No version information available, might be only in CVS)

hw_api_attribute->key — Returns key of the attribute

Popis

class hw_api_attribute {
string key ( void )
}

Returns the name of the attribute.

Návratové hodnoty

Returns the name of the attribute as a string.

Viz také

hw_api_attribute->value

Předcházející | Nahoru | Další
LVIII. Hyperwave API Functions | Domů | hw_api_attribute->langdepvalue


hw_api_attribute->langdepvalue

(No version information available, might be only in CVS)

hw_api_attribute->langdepvalue — Returns value for a given language

Popis

class hw_api_attribute {
string langdepvalue ( string $language )
}

Returns the value in the given language of the attribute.

Seznam parametrů

language

Návratové hodnoty

Returns the value of the attribute as a string.

Viz také

hw_api_attribute->value

Předcházející | Nahoru | Další
hw_api_attribute->key | Domů | hw_api_attribute->value


hw_api_attribute->value

(No version information available, might be only in CVS)

hw_api_attribute->value — Returns value of the attribute

Popis

class hw_api_attribute {
string value ( void )
}

Gets the value of the attribute.

Návratové hodnoty

Returns the value, as a string.

Viz také

hw_api_attribute->key
hw_api_attribute->values

Předcházející | Nahoru | Další
hw_api_attribute->langdepvalue | Domů | hw_api_attribute->values


hw_api_attribute->values

(No version information available, might be only in CVS)

hw_api_attribute->values — Returns all values of the attribute

Popis

class hw_api_attribute {
array values ( void )
}

Gets all values of the attribute.

Návratové hodnoty

Returns an array of attribute values.

Viz také

hw_api_attribute->value

Předcházející | Nahoru | Další
hw_api_attribute->value | Domů | hw_api_attribute


hw_api_attribute

(No version information available, might be only in CVS)

hw_api_attribute — Creates instance of class hw_api_attribute

Popis

HW_API_Attribute hw_api_attribute ( [string $name [, string $value]] )

Creates a new instance of hw_api_attribute with the given name and value.

Seznam parametrů

name

The attribute name.

value

The attribute value.

Návratové hodnoty

Returns an instance of hw_api_attribute.

Předcházející | Nahoru | Další
hw_api_attribute->values | Domů | hw_api->checkin


hw_api->checkin

(No version information available, might be only in CVS)

hw_api->checkin — Checks in an object

Popis

class hw_api {
bool checkin ( array $parameter )
}

This function checks in an object or a whole hierarchy of objects. The parameters array contains the required element 'objectIdentifier' and the optional element 'version', 'comment', 'mode' and 'objectQuery'. 'version' sets the version of the object. It consists of the major and minor version separated by a period. If the version is not set, the minor version is incremented. 'mode' can be one of the following values:

HW_API_CHECKIN_NORMAL
Checks in and commits the object. The object must be a document.
HW_API_CHECKIN_RECURSIVE
If the object to check in is a collection, all children will be checked in recursively if they are documents. Trying to check in a collection would result in an error.
HW_API_CHECKIN_FORCE_VERSION_CONTROL
Checks in an object even if it is not under version control.
HW_API_CHECKIN_REVERT_IF_NOT_CHANGED
Check if the new version is different from the last version. Unless this is the case the object will be checked in.
HW_API_CHECKIN_KEEP_TIME_MODIFIED
Keeps the time modified from the most recent object.
HW_API_CHECKIN_NO_AUTO_COMMIT
The object is not automatically committed on check-in.

Seznam parametrů

parameter

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

hw_api->checkout

Předcházející | Nahoru | Další
hw_api_attribute | Domů | hw_api->checkout


hw_api->checkout

(No version information available, might be only in CVS)

hw_api->checkout — Checks out an object

Popis

class hw_api {
bool checkout ( array $parameter )
}

This function checks out an object or a whole hierarchy of objects.

Seznam parametrů

parameter

The parameters array contains the required element 'objectIdentifier' and the optional element 'version', 'mode' and 'objectQuery'. 'mode' can be one of the following values:

HW_API_CHECKIN_NORMAL
Checks out an object. The object must be a document.
HW_API_CHECKIN_RECURSIVE
If the object to check out is a collection, all children will be checked out recursively if they are documents. Trying to check out a collection would result in an error.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

hw_api->checkin

Předcházející | Nahoru | Další
hw_api->checkin | Domů | hw_api->children


hw_api->children

(No version information available, might be only in CVS)

hw_api->children — Returns children of an object

Popis

class hw_api {
array children ( array $parameter )
}

Retrieves the children of a collection or the attributes of a document. The children can be further filtered by specifying an object query.

Seznam parametrů

parameter

The parameter array contains the required elements 'objectIdentifier' and the optional elements 'attributeSelector' and 'objectQuery'.

Návratové hodnoty

The return value is an array of objects of type HW_API_Object or HW_API_Error.

Viz také

hw_api->parents

Předcházející | Nahoru | Další
hw_api->checkout | Domů | hw_api_content->mimetype


hw_api_content->mimetype

(No version information available, might be only in CVS)

hw_api_content->mimetype — Returns mimetype

Popis

class hw_api_content {
string mimetype ( void )
}

Returns the mimetype of the content.

Návratové hodnoty

Returns the mimetype as a string.

Předcházející | Nahoru | Další
hw_api->children | Domů | hw_api_content->read


hw_api_content->read

(No version information available, might be only in CVS)

hw_api_content->read — Read content

Popis

class hw_api_content {
string read ( string $buffer, int $len )
}

Reads len bytes from the content into the given buffer.

Seznam parametrů

buffer

len

Number of bytes to read.

Návratové hodnoty

Předcházející | Nahoru | Další
hw_api_content->mimetype | Domů | hw_api->content


hw_api->content

(No version information available, might be only in CVS)

hw_api->content — Returns content of an object

Popis

class hw_api {
HW_API_Content content ( array $parameter )
}

This function returns the content of a document as an object of type hw_api_content.

Seznam parametrů

parameter

The parameter array contains the required elements 'objectidentifier' and the optional element 'mode'. The mode can be one of the constants HW_API_CONTENT_ALLLINKS, HW_API_CONTENT_REACHABLELINKS or HW_API_CONTENT_PLAIN.

HW_API_CONTENT_ALLLINKS means to insert all anchors even if the destination is not reachable.

HW_API_CONTENT_REACHABLELINKS tells this method to insert only reachable links and HW_API_CONTENT_PLAIN will lead to document without any links.

Návratové hodnoty

Returns an instance of hw_api_content.

Předcházející | Nahoru | Další
hw_api_content->read | Domů | hw_api->copy


hw_api->copy

(No version information available, might be only in CVS)

hw_api->copy — Copies physically

Popis

class hw_api {
hw_api_content copy ( array $parameter )
}

This function will make a physical copy including the content if it exists and returns the new object or an error object.

Seznam parametrů

parameter

The parameter array contains the required elements 'objectIdentifier' and 'destinationParentIdentifier'. The optional parameter is 'attributeSelector'`

Návratové hodnoty

Returns the copied object.

Viz také

hw_api->move
hw_api->link

Předcházející | Nahoru | Další
hw_api->content | Domů | hw_api->dbstat


hw_api->dbstat

(No version information available, might be only in CVS)

hw_api->dbstat — Returns statistics about database server

Popis

class hw_api {
hw_api_object dbstat ( array $parameter )
}

Returns statistics about database server.

Seznam parametrů

parameter

Návratové hodnoty

Viz také

hw_api->dcstat
hw_api->hwstat
hw_api->ftstat

Předcházející | Nahoru | Další
hw_api->copy | Domů | hw_api->dcstat


hw_api->dcstat

(No version information available, might be only in CVS)

hw_api->dcstat — Returns statistics about document cache server

Popis

class hw_api {
hw_api_object dcstat ( array $parameter )
}

Returns statistics about document cache server.

Seznam parametrů

parameter

Návratové hodnoty

Viz také

hw_api->dbstat
hw_api->hwstat
hw_api->ftstat

Předcházející | Nahoru | Další
hw_api->dbstat | Domů | hw_api->dstanchors


hw_api->dstanchors

(No version information available, might be only in CVS)

hw_api->dstanchors — Returns a list of all destination anchors

Popis

class hw_api {
array dstanchors ( array $parameter )
}

Retrieves all destination anchors of an object.

Seznam parametrů

parameter

The parameter array contains the required element 'objectIdentifier' and the optional elements 'attributeSelector' and 'objectQuery'.

Návratové hodnoty

Viz také

hw_api->srcanchors

Předcházející | Nahoru | Další
hw_api->dcstat | Domů | hw_api->dstofsrcanchor


hw_api->dstofsrcanchor

(No version information available, might be only in CVS)

hw_api->dstofsrcanchor — Returns destination of a source anchor

Popis

class hw_api {
hw_api_object dstofsrcanchor ( array $parameter )
}

Retrieves the destination object pointed by the specified source anchors. The destination object can either be a destination anchor or a whole document.

Seznam parametrů

parameter

The parameters array contains the required element 'objectIdentifier' and the optional element 'attributeSelector'.

Návratové hodnoty

Viz také

hw_api->srcanchors
hw_api->dstanchors
hw_api->objectbyanchor

Předcházející | Nahoru | Další
hw_api->dstanchors | Domů | hw_api_error->count


hw_api_error->count

(No version information available, might be only in CVS)

hw_api_error->count — Returns number of reasons

Popis

class hw_api_error {
int count ( void )
}

Returns the number of error reasons.

Návratové hodnoty

Returns the number of errors, as an integer.

Viz také

hw_api_error->reason

Předcházející | Nahoru | Další
hw_api->dstofsrcanchor | Domů | hw_api_error->reason


hw_api_error->reason

(No version information available, might be only in CVS)

hw_api_error->reason — Returns reason of error

Popis

class hw_api_error {
HW_API_Reason reason ( void )
}

Returns the first error reason.

Návratové hodnoty

Viz také

hw_api_error->count

Předcházející | Nahoru | Další
hw_api_error->count | Domů | hw_api->find


hw_api->find

(No version information available, might be only in CVS)

hw_api->find — Search for objects

Popis

class hw_api {
array find ( array $parameter )
}

This functions searches for objects either by executing a key or/and full text query. The found objects can further be filtered by an optional object query. They are sorted by their importance. The second search operation is relatively slow and its result can be limited to a certain number of hits. This allows to perform an incremental search, each returning just a subset of all found documents, starting at a given index.

Seznam parametrů

parameter

The parameter array contains the 'keyquery' or/and 'fulltextquery' depending on who you would like to search. Optional parameters are 'objectquery', 'scope', 'languages' and 'attributeselector'. In case of an incremental search the optional parameters 'startIndex', 'numberOfObjectsToGet' and 'exactMatchUnit' can be passed.

Návratové hodnoty

Předcházející | Nahoru | Další
hw_api_error->reason | Domů | hw_api->ftstat


hw_api->ftstat

(No version information available, might be only in CVS)

hw_api->ftstat — Returns statistics about fulltext server

Popis

class hw_api {
hw_api_object ftstat ( array $parameter )
}

Returns statistics about fulltext server.

Seznam parametrů

parameter

Návratové hodnoty

Viz také

hw_api->dcstat
hw_api->dbstat
hw_api->hwstat

Předcházející | Nahoru | Další
hw_api->find | Domů | hwapi_hgcsp


hwapi_hgcsp

(No version information available, might be only in CVS)

hwapi_hgcsp — Returns object of class hw_api

Popis

HW_API hwapi_hgcsp ( string $hostname [, int $port] )

Opens a connection to the Hyperwave server on host hostname. The protocol used is HGCSP.

Seznam parametrů

hostname

The host name.

port

If you do not pass a port number, 418 is used.

Návratové hodnoty

Returns an instance of HW_API.

Předcházející | Nahoru | Další
hw_api->ftstat | Domů | hw_api->hwstat


hw_api->hwstat

(No version information available, might be only in CVS)

hw_api->hwstat — Returns statistics about Hyperwave server

Popis

class hw_api {
hw_api_object hwstat ( array $parameter )
}

Returns statistics about Hyperwave server.

Seznam parametrů

parameter

Návratové hodnoty

Viz také

hw_api->dcstat
hw_api->dbstat
hw_api->ftstat

Předcházející | Nahoru | Další
hwapi_hgcsp | Domů | hw_api->identify


hw_api->identify

(No version information available, might be only in CVS)

hw_api->identify — Log into Hyperwave Server

Popis

class hw_api {
bool identify ( array $parameter )
}

Logs into the Hyperwave Server.

Seznam parametrů

parameter

The parameter array must contain the elements 'username' and 'password'.

Návratové hodnoty

Returns an object of typeHW_API_Error if identification failed or TRUE if it was successful.

Předcházející | Nahoru | Další
hw_api->hwstat | Domů | hw_api->info


hw_api->info

(No version information available, might be only in CVS)

hw_api->info — Returns information about server configuration

Popis

class hw_api {
array info ( array $parameter )
}

Returns information about server configuration.

Seznam parametrů

parameter

Návratové hodnoty

Viz také

hw_api->dcstat
hw_api->dbstat
hw_api->ftstat
hw_api->hwstat

Předcházející | Nahoru | Další
hw_api->identify | Domů | hw_api->insert


hw_api->insert

(No version information available, might be only in CVS)

hw_api->insert — Inserts a new object

Popis

class hw_api {
hw_api_object insert ( array $parameter )
}

Insert a new object. The object type can be user, group, document or anchor. Depending on the type other object attributes has to be set.

Seznam parametrů

parameter

The parameter array contains the required elements 'object' and 'content' (if the object is a document) and the optional parameters 'parameters', 'mode' and 'attributeSelector'. The 'object' must contain all attributes of the object. 'parameters' is an object as well holding further attributes like the destination (attribute key is 'Parent'). 'content' is the content of the document. 'mode' can be a combination of the following flags:

HW_API_INSERT_NORMAL
The object in inserted into the server.
HW_API_INSERT_FORCE_VERSION_CONTROL
HW_API_INSERT_AUTOMATIC_CHECKOUT
HW_API_INSERT_PLAIN
HW_API_INSERT_KEEP_TIME_MODIFIED
HW_API_INSERT_DELAY_INDEXING

Návratové hodnoty

Viz také

hw_api->replace

Předcházející | Nahoru | Další
hw_api->info | Domů | hw_api->insertanchor


hw_api->insertanchor

(No version information available, might be only in CVS)

hw_api->insertanchor — Inserts a new object of type anchor

Popis

class hw_api {
hw_api_object insertanchor ( array $parameter )
}

This function is a shortcut for hwapi_insert(). It inserts an object of type anchor and sets some of the attributes required for an anchor.

Seznam parametrů

parameter

The parameter array contains the required elements 'object' and 'documentIdentifier' and the optional elements 'destinationIdentifier', 'parameter', 'hint' and 'attributeSelector'. The 'documentIdentifier' specifies the document where the anchor shall be inserted. The target of the anchor is set in 'destinationIdentifier' if it already exists. If the target does not exists the element 'hint' has to be set to the name of object which is supposed to be inserted later. Once it is inserted the anchor target is resolved automatically.

Návratové hodnoty

Viz také

hw_api->insert
hw_api->insertdocument
hw_api->insertcollection

Předcházející | Nahoru | Další
hw_api->insert | Domů | hw_api->insertcollection


hw_api->insertcollection

(No version information available, might be only in CVS)

hw_api->insertcollection — Inserts a new object of type collection

Popis

class hw_api {
hw_api_object insertcollection ( array $parameter )
}

This function is a shortcut for hwapi_insert(). It inserts an object of type collection and sets some of the attributes required for a collection.

Seznam parametrů

parameter

The parameter array contains the required elements 'object' and 'parentIdentifier' and the optional elements 'parameter' and 'attributeSelector'. See hwapi_insert() for the meaning of each element.

Návratové hodnoty

Viz také

hw_api->insert
hw_api->insertdocument
hw_api->insertanchor

Předcházející | Nahoru | Další
hw_api->insertanchor | Domů | hw_api->insertdocument


hw_api->insertdocument

(No version information available, might be only in CVS)

hw_api->insertdocument — Inserts a new object of type document

Popis

class hw_api {
hw_api_object insertdocument ( array $parameter )
}

This function is a shortcut for hwapi_insert(). It inserts an object with content and sets some of the attributes required for a document.

Seznam parametrů

parameter

The parameter array contains the required elements 'object', 'parentIdentifier' and 'content' and the optional elements 'mode', 'parameter' and 'attributeSelector'.

See hwapi_insert() for the meaning of each element.

Návratové hodnoty

Viz také

hw_api->insert
hw_api->insertcollection
hw_api->insertanchor

Předcházející | Nahoru | Další
hw_api->insertcollection | Domů | hw_api->link


hw_api->link

(No version information available, might be only in CVS)

hw_api->link — Creates a link to an object

Popis

class hw_api {
bool link ( array $parameter )
}

Creates a link to an object. Accessing this link is like accessing the object to links points to.

Seznam parametrů

parameter

The parameter array contains the required elements 'objectIdentifier' and 'destinationParentIdentifier'. 'destinationParentIdentifier' is the target collection.

Návratové hodnoty

The function returns TRUE on success or an error object.

Viz také

hw_api->copy

Předcházející | Nahoru | Další
hw_api->insertdocument | Domů | hw_api->lock


hw_api->lock

(No version information available, might be only in CVS)

hw_api->lock — Locks an object

Popis

class hw_api {
bool lock ( array $parameter )
}

Locks an object for exclusive editing by the user calling this function. The object can be only unlocked by this user or the system user.

Seznam parametrů

parameter

The parameter array contains the required element 'objectIdentifier' and the optional parameters 'mode' and 'objectquery'.

'mode' determines how an object is locked. HW_API_LOCK_NORMAL means, an object is locked until it is unlocked. HW_API_LOCK_RECURSIVE is only valid for collection and locks all objects within the collection and possible subcollections. HW_API_LOCK_SESSION means, an object is locked only as long as the session is valid.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

hw_api->unlock

Předcházející | Nahoru | Další
hw_api->link | Domů | hw_api->move


hw_api->move

(No version information available, might be only in CVS)

hw_api->move — Moves object between collections

Popis

class hw_api {
bool move ( array $parameter )
}

Moves object between collections.

Seznam parametrů

parameter

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

hw_objrec2array()

Předcházející | Nahoru | Další
hw_api->lock | Domů | hw_api_content


hw_api_content

(No version information available, might be only in CVS)

hw_api_content — Create new instance of class hw_api_content

Popis

HW_API_Content hw_api_content ( string $content, string $mimetype )

Creates a new content object from the string content.

Seznam parametrů

content

mimetype

The mimetype for the contents.

Návratové hodnoty

Předcházející | Nahoru | Další
hw_api->move | Domů | hw_api_object->assign


hw_api_object->assign

(No version information available, might be only in CVS)

hw_api_object->assign — Clones object

Popis

class hw_api_object {
bool assign ( array $parameter )
}

Clones the attributes of an object.

Seznam parametrů

parameter

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
hw_api_content | Domů | hw_api_object->attreditable


hw_api_object->attreditable

(No version information available, might be only in CVS)

hw_api_object->attreditable — Checks whether an attribute is editable

Popis

class hw_api_object {
bool attreditable ( array $parameter )
}

Checks whether an attribute is editable.

Seznam parametrů

parameter

Návratové hodnoty

Returns TRUE if the attribute is editable, FALSE otherwise.

Předcházející | Nahoru | Další
hw_api_object->assign | Domů | hw_api_object->count


hw_api_object->count

(No version information available, might be only in CVS)

hw_api_object->count — Returns number of attributes

Popis

class hw_api_object {
int count ( array $parameter )
}

Returns the number of attributes.

Seznam parametrů

parameter

Návratové hodnoty

Returns the number as an integer.

Předcházející | Nahoru | Další
hw_api_object->attreditable | Domů | hw_api_object->insert


hw_api_object->insert

(No version information available, might be only in CVS)

hw_api_object->insert — Inserts new attribute

Popis

class hw_api_object {
bool insert ( HW_API_Attribute $attribute )
}

Adds an attribute to the object.

Seznam parametrů

attribute

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

hw_api_object->remove

Předcházející | Nahoru | Další
hw_api_object->count | Domů | hw_api_object


hw_api_object

(No version information available, might be only in CVS)

hw_api_object — Creates a new instance of class hw_api_object

Popis

hw_api_object hw_api_object ( array $parameter )

Creates a new instance of the class hw_api_object.

Seznam parametrů

parameter

Návratové hodnoty

Viz také

hw_api->lock

Předcházející | Nahoru | Další
hw_api_object->insert | Domů | hw_api_object->remove


hw_api_object->remove

(No version information available, might be only in CVS)

hw_api_object->remove — Removes attribute

Popis

class hw_api_object {
bool remove ( string $name )
}

Removes the attribute with the given name.

Seznam parametrů

name

The attribute name.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

hw_api_object->insert

Předcházející | Nahoru | Další
hw_api_object | Domů | hw_api_object->title


hw_api_object->title

(No version information available, might be only in CVS)

hw_api_object->title — Returns the title attribute

Popis

class hw_api_object {
string title ( array $parameter )
}

Returns the title attribute.

Seznam parametrů

parameter

Návratové hodnoty

Returns the title as a string.

Předcházející | Nahoru | Další
hw_api_object->remove | Domů | hw_api_object->value


hw_api_object->value

(No version information available, might be only in CVS)

hw_api_object->value — Returns value of attribute

Popis

class hw_api_object {
string value ( string $name )
}

Returns value of an attribute.

Seznam parametrů

name

The attribute name.

Návratové hodnoty

Returns the value of the attribute with the given name or FALSE if an error occurred.

Předcházející | Nahoru | Další
hw_api_object->title | Domů | hw_api->object


hw_api->object

(No version information available, might be only in CVS)

hw_api->object — Retrieve attribute information

Popis

class hw_api {
hw_api_object object ( array $parameter )
}

This function retrieves the attribute information of an object of any version. It will not return the document content.

Seznam parametrů

parameter

The parameter array contains the required elements 'objectIdentifier' and the optional elements 'attributeSelector' and 'version'.

Návratové hodnoty

The returned object is an instance of class HW_API_Object on success or HW_API_Error if an error occurred.

Příklady

This simple example retrieves an object and checks for errors.

Příklad 757. Retrieve an object

<?php
function handle_error($error)
{
  $reason = $error->reason(0);
  echo "Type: <b>";
  switch ($reason->type()) {
    case 0:
      echo "Error";
      break;
    case 1:
      echo "Warning";
      break;
    case 2:
      echo "Message";
      break;
  }
  echo "</b><br />\n";
  echo "Description: " . $reason->description("en") . "<br />\n";
}

function list_attr($obj)
{
  echo "<table>\n";
  $count = $obj->count();
  for ($i=0; $i<$count; $i++) {
    $attr = $obj->attribute($i);
    printf("<tr><td align=\"right\" bgcolor=\"#c0c0c0\"><b>%s</b></td><td bgcolor=\"#F0F0F0\">%s</td></tr>\n",
             $attr->key(), $attr->value());
  }
  echo "</table>\n";
}

$hwapi = hwapi_hgcsp($g_config[HOSTNAME]);
$parms = array("objectIdentifier"=>"rootcollection", "attributeSelector"=>array("Title", "Name", "DocumentType"));
$root = $hwapi->object($parms);
if (get_class($root) == "HW_API_Error") {
  handle_error($root);
  exit;
}
list_attr($root);
?>

Viz také

hw_api->content

Předcházející | Nahoru | Další
hw_api_object->value | Domů | hw_api->objectbyanchor


hw_api->objectbyanchor

(No version information available, might be only in CVS)

hw_api->objectbyanchor — Returns the object an anchor belongs to

Popis

class hw_api {
hw_api_object objectbyanchor ( array $parameter )
}

This function retrieves an object the specified anchor belongs to.

Seznam parametrů

parameter

The parameter array contains the required element 'objectIdentifier' and the optional element 'attributeSelector'.

Návratové hodnoty

Viz také

hw_api->dstofsrcanchor
hw_api->srcanchors
hw_api->dstanchors

Předcházející | Nahoru | Další
hw_api->object | Domů | hw_api->parents


hw_api->parents

(No version information available, might be only in CVS)

hw_api->parents — Returns parents of an object

Popis

class hw_api {
array parents ( array $parameter )
}

Retrieves the parents of an object. The parents can be further filtered by specifying an object query.

Seznam parametrů

parameter

The parameter array contains the required elements 'objectidentifier' and the optional elements 'attributeselector' and 'objectquery'.

Návratové hodnoty

The return value is an array of objects of type HW_API_Object or HW_API_Error.

Viz také

hw_api->children

Předcházející | Nahoru | Další
hw_api->objectbyanchor | Domů | hw_api_reason->description


hw_api_reason->description

(No version information available, might be only in CVS)

hw_api_reason->description — Returns description of reason

Popis

class hw_api_reason {
string description ( void )
}

Returns the description of a reason

Návratové hodnoty

Returns the description, as a string.

Předcházející | Nahoru | Další
hw_api->parents | Domů | hw_api_reason->type


hw_api_reason->type

(No version information available, might be only in CVS)

hw_api_reason->type — Returns type of reason

Popis

class hw_api_reason {
HW_API_Reason type ( void )
}

Returns the type of a reason.

Návratové hodnoty

Returns an instance of HW_API_Reason.

Předcházející | Nahoru | Další
hw_api_reason->description | Domů | hw_api->remove


hw_api->remove

(No version information available, might be only in CVS)

hw_api->remove — Delete an object

Popis

class hw_api {
bool remove ( array $parameter )
}

Removes an object from the specified parent. Collections will be removed recursively.

Seznam parametrů

parameter

You can pass an optional object query to remove only those objects which match the query. An object will be deleted physically if it is the last instance.

The parameter array contains the required elements 'objectidentifier' and 'parentidentifier'. If you want to remove a user or group 'parentidentifier' can be skipped.

The optional parameter 'mode' determines how the deletion is performed. In normal mode the object will not be removed physically until all instances are removed. In physical mode all instances of the object will be deleted immediately. In removelinks mode all references to and from the objects will be deleted as well. In nonrecursive the deletion is not performed recursive. Removing a collection which is not empty will cause an error.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

hw_api->move

Předcházející | Nahoru | Další
hw_api_reason->type | Domů | hw_api->replace


hw_api->replace

(No version information available, might be only in CVS)

hw_api->replace — Replaces an object

Popis

class hw_api {
hw_api_object replace ( array $parameter )
}

Replaces the attributes and the content of an object.

Seznam parametrů

parameter

The parameter array contains the required elements 'objectIdentifier' and 'object' and the optional parameters 'content', 'parameters', 'mode' and 'attributeSelector'. 'objectIdentifier' contains the object to be replaced. 'object' contains the new object. 'content' contains the new content. 'parameters' contain extra information for HTML documents. HTML_Language is the letter abbreviation of the language of the title. HTML_Base sets the base attribute of the HTML document.

'mode' can be a combination of the following flags:

HW_API_REPLACE_NORMAL
The object on the server is replace with the object passed.
HW_API_REPLACE_FORCE_VERSION_CONTROL
HW_API_REPLACE_AUTOMATIC_CHECKOUT
HW_API_REPLACE_AUTOMATIC_CHECKIN
HW_API_REPLACE_PLAIN
HW_API_REPLACE_REVERT_IF_NOT_CHANGED
HW_API_REPLACE_KEEP_TIME_MODIFIED

Návratové hodnoty

Viz také

hw_api->insert

Předcházející | Nahoru | Další
hw_api->remove | Domů | hw_api->setcommittedversion


hw_api->setcommittedversion

(No version information available, might be only in CVS)

hw_api->setcommittedversion — Commits version other than last version

Popis

class hw_api {
hw_api_object setcommittedversion ( array $parameter )
}

Commits a version of a document. The committed version is the one which is visible to users with read access. By default the last version is the committed version.

Seznam parametrů

parameter

Návratové hodnoty

Viz také

hw_api->checkin
hw_api->checkout

Předcházející | Nahoru | Další
hw_api->replace | Domů | hw_api->srcanchors


hw_api->srcanchors

(No version information available, might be only in CVS)

hw_api->srcanchors — Returns a list of all source anchors

Popis

class hw_api {
array srcanchors ( array $parameter )
}

Retrieves all source anchors of an object.

Seznam parametrů

parameter

The parameter array contains the required element 'objectIdentifier' and the optional elements 'attributeSelector' and 'objectQuery'.

Návratové hodnoty

Viz také

hw_api->dstanchors

Předcházející | Nahoru | Další
hw_api->setcommittedversion | Domů | hw_api->srcsofdst


hw_api->srcsofdst

(No version information available, might be only in CVS)

hw_api->srcsofdst — Returns source of a destination object

Popis

class hw_api {
array srcsofdst ( array $parameter )
}

Retrieves all the source anchors pointing to the specified destination. The destination object can either be a destination anchor or a whole document.

Seznam parametrů

parameter

The parameters array contains the required element 'objectIdentifier' and the optional element 'attributeSelector' and 'objectQuery'. The function returns an array of objects or an error.

Návratové hodnoty

Viz také

hw_api->dstofsrcanchor

Předcházející | Nahoru | Další
hw_api->srcanchors | Domů | hw_api->unlock


hw_api->unlock

(No version information available, might be only in CVS)

hw_api->unlock — Unlocks a locked object

Popis

class hw_api {
bool unlock ( array $parameter )
}

Unlocks a locked object. Only the user who has locked the object and the system user may unlock an object.

Seznam parametrů

parameter

The parameter array contains the required element 'objectIdentifier' and the optional parameters 'mode' and 'objectquery'. The meaning of 'mode' is the same as in function hwapi_lock().

Návratové hodnoty

Returns TRUE on success or an object of class HW_API_Error.

Viz také

hw_api->lock

Předcházející | Nahoru | Další
hw_api->srcsofdst | Domů | hw_api->user


hw_api->user

(No version information available, might be only in CVS)

hw_api->user — Returns the own user object

Popis

class hw_api {
hw_api_object user ( array $parameter )
}

Returns the own user object.

Seznam parametrů

parameter

Návratové hodnoty

Viz také

hw_api->userlist

Předcházející | Nahoru | Další
hw_api->unlock | Domů | hw_api->userlist


hw_api->userlist

(No version information available, might be only in CVS)

hw_api->userlist — Returns a list of all logged in users

Popis

class hw_api {
array userlist ( array $parameter )
}

Returns a list of all logged in users.

Seznam parametrů

parameter

Návratové hodnoty

Viz také

hw_api->user

Předcházející | Nahoru | Další
hw_api->user | Domů | LIX. i18n Funkce


iconv Functions

Předcházející VI. Reference funkcí Další

LXII. iconv Functions

Úvod

This module contains an interface to iconv character set conversion facility. With this module, you can turn a string represented by a local character set into the one represented by another character set, which may be the Unicode character set. Supported character sets depend on the iconv implementation of your system. Note that the iconv function on some systems may not work as you expect. In such case, it'd be a good idea to install the » GNU libiconv library. It will most likely end up with more consistent results.

Since PHP 5.0.0, this extension comes with various utility functions that help you to write multilingual scripts. Let's have a look at the following sections to explore the new features.

Požadavky

You will need nothing if the system you are using is one of the recent POSIX-compliant systems because standard C libraries that are supplied in them must provide iconv facility. Otherwise, you have to get the » libiconv library installed in your system.

Instalace

To use functions provided by this module, the PHP binary must be built with the following configure line: --with-iconv[=DIR].

Note to Windows® Users: In order to enable this module on a Windows® environment, you need to put a DLL file named iconv.dll or iconv-1.3.dll (prior to 4.2.1) which is bundled with the PHP/Win32 binary package into a directory specified by the PATH environment variable or one of the system directories of your Windows® installation.

This module is part of PHP as of PHP 5 thus iconv.dll and php_iconv.dll is not needed anymore.

Konfigurace běhu

Chování těchto funkcí je ovlivněno nastavením parametrů v php.ini.

Tabulka 120. Iconv configuration options

Name | Default | Changeable | Changelog
iconv.input_encoding | "ISO-8859-1" | PHP_INI_ALL | Available since PHP 4.0.5.
iconv.output_encoding | "ISO-8859-1" | PHP_INI_ALL | Available since PHP 4.0.5.
iconv.internal_encoding | "ISO-8859-1" | PHP_INI_ALL | Available since PHP 4.0.5.

Pro další detaily a definice konstant PHP_INI_*, viz dokumentace k ini_set().

Varování

Some systems (like IBM AIX) use "ISO8859-1" instead of "ISO-8859-1" so this value has to be used in configuration options and function parameters.

Poznámka: Configuration option iconv.input_encoding is currently not used for anything.

Typy prostředků

Toto rozšíření nemá definován žádný typ prostředku (resource).

Předdefinované konstanty

Since PHP 4.3.0 it is possible to identify at runtime which iconv implementation is adopted by this extension.

Tabulka 121. iconv constants

Name | Type | Description
ICONV_IMPL | string | The implementation name
ICONV_VERSION | string | The implementation version

Poznámka: Writing implementation-dependent scripts with these constants is strongly discouraged.

Since PHP 5.0.0, the following constants are also available:

Tabulka 122. iconv constants available since PHP 5.0.0

Name | Type | Description
ICONV_MIME_DECODE_STRICT | integer | A bitmask used for iconv_mime_decode()
ICONV_MIME_DECODE_CONTINUE_ON_ERROR | integer | A bitmask used for iconv_mime_decode()

Viz také

See also GNU Recode functions.

Obsah

iconv_get_encoding — Retrieve internal configuration variables of iconv extension
iconv_mime_decode_headers — Decodes multiple MIME header fields at once
iconv_mime_decode — Decodes a MIME header field
iconv_mime_encode — Composes a MIME header field
iconv_set_encoding — Set current setting for character encoding conversion
iconv_strlen — Returns the character count of string
iconv_strpos — Finds position of first occurrence of a needle within a haystack
iconv_strrpos — Finds the last occurrence of a needle within a haystack
iconv_substr — Cut out part of a string
iconv — Convert string to requested character encoding
ob_iconv_handler — Convert character encoding as output buffer handler
Předcházející | Nahoru | Další
db2_tables | Domů | iconv_get_encoding


iconv_get_encoding

(PHP 4 >= 4.0.5, PHP 5)

iconv_get_encoding — Retrieve internal configuration variables of iconv extension

Popis

mixed iconv_get_encoding ( [string $type] )

Retrieve internal configuration variables of iconv extension.

Seznam parametrů

type

The value of the optional type can be:

all
input_encoding
output_encoding
internal_encoding

Návratové hodnoty

Returns the current value of the internal configuration variable if successful, or FALSE on failure.

If type is omitted or set to "all", iconv_get_encoding() returns an array that stores all these variables.

Příklady

Příklad 812. iconv_get_encoding() example

<pre>
<?php
iconv_set_encoding("internal_encoding", "UTF-8");
iconv_set_encoding("output_encoding", "ISO-8859-1");
var_dump(iconv_get_encoding('all'));
?>
</pre>

Výše uvedený příklad vypíše:

Array
(
    [input_encoding] => ISO-8859-1
    [output_encoding] => ISO-8859-1
    [internal_encoding] => UTF-8
)

Viz také

iconv_set_encoding()
ob_iconv_handler()

Předcházející | Nahoru | Další
LXII. iconv Functions | Domů | iconv_mime_decode_headers


iconv_mime_decode_headers

(PHP 5)

iconv_mime_decode_headers — Decodes multiple MIME header fields at once

Popis

array iconv_mime_decode_headers ( string $encoded_headers [, int $mode [, string $charset]] )

Returns an associative array that holds a whole set of MIME header fields specified by encoded_headers on success, or FALSE if an error occurs during the decoding.

Each key of the return value represents an individual field name and the corresponding element represents a field value. If more than one field of the same name are present, iconv_mime_decode_headers() automatically incorporates them into a numerically indexed array in the order of occurrence.

Seznam parametrů

encoded_headers

The encoded headers, as a string.

mode

mode determines the behaviour in the event iconv_mime_decode_headers() encounters a malformed MIME header field. You can specify any combination of the following bitmasks.

Tabulka 123. Bitmasks acceptable to iconv_mime_decode_headers()

Value | Constant | Description
1 | ICONV_MIME_DECODE_STRICT | If set, the given header is decoded in full conformance with the standards defined in » RFC2047. This option is disabled by default because there are a lot of broken mail user agents that don't follow the specification and don't produce correct MIME headers.
2 | ICONV_MIME_DECODE_CONTINUE_ON_ERROR | If set, iconv_mime_decode_headers() attempts to ignore any grammatical errors and continue to process a given header.

charset

The optional charset parameter specifies the character set to represent the result by. If omitted, iconv.internal_encoding will be used.

Příklady

Příklad 813. iconv_mime_decode_headers() example

<?php
$headers_string = <<<EOF
Subject: =?UTF-8?B?UHLDvGZ1bmcgUHLDvGZ1bmc=?=
To: example@example.com
Date: Thu, 1 Jan 1970 00:00:00 +0000
Message-Id: <example@example.com>
Received: from localhost (localhost [127.0.0.1]) by localhost
    with SMTP id example for <example@example.com>;
    Thu, 1 Jan 1970 00:00:00 +0000 (UTC)
    (envelope-from example-return-0000-example=example.com@example.com)
Received: (qmail 0 invoked by uid 65534); 1 Thu 2003 00:00:00 +0000

EOF;

$headers =  iconv_mime_decode_headers($headers_string, 0, "ISO-8859-1");
print_r($headers);
?>

Výše uvedený příklad vypíše:

Array
(
    [Subject] => Prüfung Prüfung
    [To] => example@example.com
    [Date] => Thu, 1 Jan 1970 00:00:00 +0000
    [Message-Id] => <example@example.com>
    [Received] => Array
        (
            [0] => from localhost (localhost [127.0.0.1]) by localhost with SMTP id example for <example@example.com>; Thu, 1 Jan 1970 00:00:00 +0000 (UTC) (envelope-from example-return-0000-example=example.com@example.com)
            [1] => (qmail 0 invoked by uid 65534); 1 Thu 2003 00:00:00 +0000
        )

)

Viz také

iconv_mime_decode()
mb_decode_mimeheader()
imap_mime_header_decode()
imap_base64()
imap_qprint()

Předcházející | Nahoru | Další
iconv_get_encoding | Domů | iconv_mime_decode


iconv_mime_decode

(PHP 5)

iconv_mime_decode — Decodes a MIME header field

Popis

string iconv_mime_decode ( string $encoded_header [, int $mode [, string $charset]] )

Decodes a MIME header field.

Seznam parametrů

encoded_header

The encoded header, as a string.

mode

mode determines the behaviour in the event iconv_mime_decode() encounters a malformed MIME header field. You can specify any combination of the following bitmasks.

Tabulka 124. Bitmasks acceptable to iconv_mime_decode()

Value | Constant | Description
1 | ICONV_MIME_DECODE_STRICT | If set, the given header is decoded in full conformance with the standards defined in » RFC2047. This option is disabled by default because there are a lot of broken mail user agents that don't follow the specification and don't produce correct MIME headers.
2 | ICONV_MIME_DECODE_CONTINUE_ON_ERROR | If set, iconv_mime_decode_headers() attempts to ignore any grammatical errors and continue to process a given header.

charset

The optional charset parameter specifies the character set to represent the result by. If omitted, iconv.internal_encoding will be used.

Návratové hodnoty

Returns a decoded MIME field on success, or FALSE if an error occurs during the decoding.

Příklady

Příklad 814. iconv_mime_decode() example

<?php
// This yields "Subject: Prüfung Prüfung"
echo iconv_mime_decode("Subject: =?UTF-8?B?UHLDvGZ1bmcgUHLDvGZ1bmc=?=",
                       0, "ISO-8859-1");
?>

Viz také

iconv_mime_decode_headers()
mb_decode_mimeheader()
imap_mime_header_decode()
imap_base64()
imap_qprint()

Předcházející | Nahoru | Další
iconv_mime_decode_headers | Domů | iconv_mime_encode


iconv_mime_encode

(PHP 5)

iconv_mime_encode — Composes a MIME header field

Popis

string iconv_mime_encode ( string $field_name, string $field_value [, array $preferences] )

Composes and returns a string that represents a valid MIME header field, which looks like the following:

Subject: =?ISO-8859-1?Q?Pr=FCfung_f=FCr?= Entwerfen von einer MIME kopfzeile
In the above example, "Subject" is the field name and the portion that begins with "=?ISO-8859-1?..." is the field value.

Seznam parametrů

field_name

The field name.

field_value

The field value.

preferences

You can control the behaviour of iconv_mime_encode() by specifying an associative array that contains configuration items to the optional third parameter preferences. The items supported by iconv_mime_encode() are listed below. Note that item names are treated case-sensitive.

Tabulka 125. Configuration items supported by iconv_mime_encode()

Item | Type | Description | Default value | Example
scheme | string | Specifies the method to encode a field value by. The value of this item may be either "B" or "Q", where "B" stands for base64 encoding scheme and "Q" stands for quoted-printable encoding scheme. | B | B
input-charset | string | Specifies the character set in which the first parameter field_name and the second parameter field_value are presented. If not given, iconv_mime_encode() assumes those parameters are presented to it in the iconv.internal_encoding ini setting. | iconv.internal_encoding | ISO-8859-1
output-charset | string | Specifies the character set to use to compose the MIME header. If not given, the same value as input-charset will be used. | iconv.internal_encoding | UTF-8
line-length | integer | Specifies the maximum length of the header lines. The resulting header is "folded" to a set of multiple lines in case the resulting header field would be longer than the value of this parameter, according to » RFC2822 - Internet Message Format. If not given, the length will be limited to 76 characters. | 76 | 996
line-break-chars | string | Specifies the sequence of characters to append to each line as an end-of-line sign when "folding" is performed on a long header field. If not given, this defaults to "\r\n" (CR LF). Note that this parameter is always treated as an ASCII string regardless of the value of input-charset. | \r\n | \n

Návratové hodnoty

Returns an encoded MIME field on success, or FALSE if an error occurs during the encoding.

Příklady

Příklad 815. iconv_mime_encode() example

<?php
$preferences = array(
    "input-charset" => "ISO-8859-1",
    "output-charset" => "UTF-8",
    "line-length" => 76,
    "line-break-chars" => "\n"
);
$preferences["scheme"] = "Q";
// This yields "Subject: =?UTF-8?Q?Pr=C3=BCfung_Pr=C3=BCfung?="
echo iconv_mime_encode("Subject", "Prüfung Prüfung", $preferences);

$preferences["scheme"] = "B";
// This yields "Subject: =?UTF-8?B?UHLDvGZ1bmcgUHLDvGZ1bmc=?="
echo iconv_mime_encode("Subject", "Prüfung Prüfung", $preferences);
?>

Viz také

imap_binary()
mb_encode_mimeheader()
imap_8bit()

Předcházející | Nahoru | Další
iconv_mime_decode | Domů | iconv_set_encoding


iconv_set_encoding

(PHP 4 >= 4.0.5, PHP 5)

iconv_set_encoding — Set current setting for character encoding conversion

Popis

bool iconv_set_encoding ( string $type, string $charset )

Changes the value of the internal configuration variable specified by type to charset.

Seznam parametrů

type

The value of type can be any one of those:

input_encoding
output_encoding
internal_encoding

charset

The character set.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 816. iconv_set_encoding() example

<?php
iconv_set_encoding("internal_encoding", "UTF-8");
iconv_set_encoding("output_encoding", "ISO-8859-1");
?>

Viz také

iconv_get_encoding()
ob_iconv_handler()

Předcházející | Nahoru | Další
iconv_mime_encode | Domů | iconv_strlen


iconv_strlen

(PHP 5)

iconv_strlen — Returns the character count of string

Popis

int iconv_strlen ( string $str [, string $charset] )

In contrast to strlen(), iconv_strlen() counts the occurrences of characters in the given byte sequence str on the basis of the specified character set, the result of which is not necessarily identical to the length of the string in byte.

Seznam parametrů

str

The string.

charset

If charset parameter is omitted, str is assumed to be encoded in iconv.internal_encoding.

Návratové hodnoty

Returns the character count of str, as an integer.

Viz také

strlen()
mb_strlen()

Předcházející | Nahoru | Další
iconv_set_encoding | Domů | iconv_strpos


iconv_strpos

(PHP 5)

iconv_strpos — Finds position of first occurrence of a needle within a haystack

Popis

int iconv_strpos ( string $haystack, string $needle [, int $offset [, string $charset]] )

Finds position of first occurrence of a needle within a haystack.

In contrast to strpos(), the return value of iconv_strpos() is the number of characters that appear before the needle, rather than the offset in bytes to the position where the needle has been found. The characters are counted on the basis of the specified character set charset.

Seznam parametrů

haystack

The entire string.

needle

The searched substring.

offset

The optional offset parameter specifies the position from which the search should be performed.

charset

If charset parameter is omitted, string are assumed to be encoded in iconv.internal_encoding.

If haystack or needle is not a string, it is converted to a string and applied as the ordinal value of a character.

Návratové hodnoty

Returns the numeric position of the first occurrence of needle in haystack.

If needle is not found, iconv_strpos() will return FALSE.

Varování

Tato funkce může vracet booleovskou hodnotu FALSE, ale také nebooleovskou hodnotu odpovídající ohodnocení FALSE, například 0 nebo "". Čtěte prosím sekci o typu Boolean, kde najdete více informací. Pro testování návratové hodnoty této funkce použijte operátor ===.

Viz také

strpos()
iconv_strrpos()
mb_strpos()

Předcházející | Nahoru | Další
iconv_strlen | Domů | iconv_strrpos


iconv_strrpos

(PHP 5)

iconv_strrpos — Finds the last occurrence of a needle within a haystack

Popis

int iconv_strrpos ( string $haystack, string $needle [, string $charset] )

In contrast to strpos(), the return value of iconv_strrpos() is the number of characters that appear before the needle, rather than the offset in bytes to the position where the needle has been found.

Seznam parametrů

haystack

The entire string.

needle

The searched substring.

charset

If charset parameter is omitted, string are assumed to be encoded in iconv.internal_encoding.

If haystack or needle is not a string, it is converted to a string and applied as the ordinal value of a character.

Návratové hodnoty

Returns the numeric position of the last occurrence of needle in haystack. The characters are counted on the basis of the specified character set charset.

If needle is not found, iconv_strrpos() will return FALSE.

Varování

Tato funkce může vracet booleovskou hodnotu FALSE, ale také nebooleovskou hodnotu odpovídající ohodnocení FALSE, například 0 nebo "". Čtěte prosím sekci o typu Boolean, kde najdete více informací. Pro testování návratové hodnoty této funkce použijte operátor ===.

Viz také

strrpos()
iconv_strpos()
mb_strrpos()

Předcházející | Nahoru | Další
iconv_strpos | Domů | iconv_substr


iconv_substr

(PHP 5)

iconv_substr — Cut out part of a string

Popis

string iconv_substr ( string $str, int $offset [, int $length [, string $charset]] )

Cuts a portion of str specified by the offset and length parameters.

Seznam parametrů

str

The original string.

offset

If offset is non-negative, iconv_substr() cuts the portion out of str beginning at offset'th character, counting from zero.

If offset is negative, iconv_substr() cuts out the portion beginning at the position, offset characters away from the end of str.

length

If length is given and is positive, the return value will contain at most length characters of the portion that begins at offset (depending on the length of string).

If negative length is passed, iconv_substr() cuts the portion out of str from the offset'th character up to the character that is length characters away from the end of the string. In case offset is also negative, the start position is calculated beforehand according to the rule explained above.

charset

If charset parameter is omitted, string are assumed to be encoded in iconv.internal_encoding.

Note that offset and length parameters are always deemed to represent offsets that are calculated on the basis of the character set determined by charset, whilst the counterpart substr() always takes these for byte offsets.

Návratové hodnoty

Returns the portion of str specified by the offset and length parameters.

If str is shorter than offset characters long, FALSE will be returned.

Viz také

substr()
mb_substr()
mb_strcut()

Předcházející | Nahoru | Další
iconv_strrpos | Domů | iconv


iconv

(PHP 4 >= 4.0.5, PHP 5)

iconv — Convert string to requested character encoding

Popis

string iconv ( string $in_charset, string $out_charset, string $str )

Performs a character set conversion on the string str from in_charset to out_charset.

Seznam parametrů

in_charset

The input charset.

out_charset

The output charset.

If you append the string //TRANSLIT to out_charset transliteration is activated. This means that when a character can't be represented in the target charset, it can be approximated through one or several similarly looking characters. If you append the string //IGNORE, characters that cannot be represented in the target charset are silently discarded. Otherwise, str is cut from the first illegal character.

str

The string to be converted.

Návratové hodnoty

Returns the converted string or FALSE on failure.

Příklady

Příklad 817. iconv() example

<?php
echo iconv("ISO-8859-1", "UTF-8", "This is a test.");
?>

Předcházející | Nahoru | Další
iconv_substr | Domů | ob_iconv_handler


ob_iconv_handler

(PHP 4 >= 4.0.5, PHP 5)

ob_iconv_handler — Convert character encoding as output buffer handler

Popis

string ob_iconv_handler ( string $contents, int $status )

Converts the string encoded in internal_encoding to output_encoding.

internal_encoding and output_encoding should be defined in the php.ini file or in iconv_set_encoding().

Seznam parametrů

See ob_start() for information about this handler parameters.

Návratové hodnoty

See ob_start() for information about this handler return values.

Příklady

Příklad 818. ob_iconv_handler() example:

<?php
iconv_set_encoding("internal_encoding", "UTF-8");
iconv_set_encoding("output_encoding", "ISO-8859-1");
ob_start("ob_iconv_handler"); // start output buffering
?>

Viz také

iconv_get_encoding()
iconv_set_encoding()
output-control functions

Předcházející | Nahoru | Další
iconv | Domů | LXIII. ID3 Functions


Image Functions

Předcházející VI. Reference funkcí Další

LXV. Image Functions

Úvod

PHP is not limited to creating just HTML output. It can also be used to create and manipulate image files in a variety of different image formats, including gif, png, jpg, wbmp, and xpm. Even more convenient, PHP can output image streams directly to a browser. You will need to compile PHP with the GD library of image functions for this to work. GD and PHP may also require other libraries, depending on which image formats you want to work with.

You can use the image functions in PHP to get the size of JPEG, GIF, PNG, SWF, TIFF and JPEG2000 images.

With the exif extension, you are able to work with information stored in headers of JPEG and TIFF images. This way you can read meta data generated by digital cameras. The exif functions do not require the GD library.

Poznámka: Read the requirements section about how to expand image capabilities to read, write and modify images. To read meta data of pictures taken by digital cameras you need the above mentioned exif extension.

Požadavky

If you have the GD library (available at » http://www.libgd.org/) you will also be able to create and manipulate images.

The format of images you are able to manipulate depend on the version of GD you install, and any other libraries GD might need to access those image formats. Versions of GD older than gd-1.6 support GIF format images, and do not support PNG, where versions greater than gd-1.6 and less than gd-2.0.28 support PNG, not GIF. GIF support was re-enabled in gd-2.0.28.

Poznámka: Since PHP 4.3 there is a bundled version of the GD lib. This bundled version has some additional features like alpha blending, and should be used in preference to the external library since its codebase is better maintained and more stable.

Poznámka: Support for GD 1.x has been removed as of PHP 6.0.0, which requires GD 2.0.33 or later.

You may wish to enhance GD to handle more image formats.

Tabulka 127. Supported image formats

Image format | Library to download | Notes
gif |  | Only supported in GD versions older than gd-1.6 and newer than gd-2.0.28. Read-only GIF support is available with PHP 4.3.0 and the bundled GD-library. Write support is available since PHP 4.3.9 and PHP 5.0.1.
jpeg-6b | » ftp://ftp.uu.net/graphics/jpeg/ | When buliding the jpeg-v6b library (prior to building PHP) you must use the --enable-shared option in the configure step. If you do not, you will receive an error saying libjpeg.(a|so) not found when you get to the configure step of building PHP.
png | » http://www.libpng.org/pub/png/libpng.html | Only supported in GD versions greater than gd-1.6.
xpm | » ftp://metalab.unc.edu/pub/Linux/libs/X/!INDEX.html | It's likely you have this library already available, if your system has an installed X-Environment.

You may wish to enhance GD to deal with different fonts. The following font libraries are supported:

Tabulka 128. Supported font libraries

Font library | Download | Notes
FreeType 1.x | » http://www.freetype.org/ | Support removed as of PHP 6.0.0
FreeType 2 | » http://www.freetype.org/ |
T1lib | » ftp://sunsite.unc.edu/pub/Linux/libs/graphics/) | Support for Postscript Type 1 fonts.

Instalace

To enable GD-support configure PHP --with-gd[=DIR], where DIR is the GD base install directory. To use the recommended bundled version of the GD library (which was first bundled in PHP 4.3.0), use the configure option --with-gd. GD library requires libpng and libjpeg to compile.

In Windows, you'll include the GD2 DLL php_gd2.dll as an extension in php.ini. The GD1 DLL php_gd.dll was removed in PHP 4.3.2. Also note that the preferred truecolor image functions, such as imagecreatetruecolor(), require GD2.

To disable GD support in PHP 3 add --without-gd to your configure line.

Enhance the capabilities of GD to handle more image formats by specifying the --with-XXXX configure switch to your PHP configure line.

Tabulka 129. Supported image formats

Image Format | Configure Switch
jpeg-6b | To enable support for jpeg-6b add --with-jpeg-dir=DIR.
png | To enable support for png add --with-png-dir=DIR. Note, libpng requires the zlib library, therefore add --with-zlib-dir[=DIR] to your configure line.
xpm | To enable support for xpm add --with-xpm-dir=DIR. If configure is not able to find the required libraries, you may add the path to your X11 libraries.

Poznámka: When compiling PHP with libpng, you must use the same version that was linked with the GD library.

Enhance the capabilities of GD to deal with different fonts by specifying the --with-XXXX configure switch to your PHP configure line.

Tabulka 130. Supported font libraries

Font library | Configure Switch
FreeType 1.x | To enable support for FreeType 1.x add --with-ttf[=DIR].
FreeType 2 | To enable support for FreeType 2 add --with-freetype-dir=DIR.
T1lib | To enable support for T1lib (Postscript Type 1 fonts) add --with-t1lib[=DIR].
Native TrueType string function | To enable support for native TrueType string function add --enable-gd-native-ttf.

Konfigurace běhu

Chování těchto funkcí je ovlivněno nastavením parametrů v php.ini.

Tabulka 131. Image Konfigurační volby

Jméno | Výchozí | Měnitelné | Changelog
gd.jpeg_ignore_warning | "0" | PHP_INI_ALL | Available since PHP 5.1.3.

Pro další detaily a definice konstant PHP_INI_*, viz dokumentace k ini_set().

Zde je stručný popis konfiguračních direktiv.

gd.jpeg_ignore_warning bool

Ignore warnings created by jpeg2wbmp() and imagecreatefromjpeg()

See also the exif configuration directives.

Varování

Image functions are very memory intensive. Be sure to set memory_limit high enough.

Typy prostředků

This extension defines two resource types: an image identifier and a font identifier.

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

GD_VERSION (string)
The GD version PHP was compiled against. (Available as of PHP 5.2.4)
GD_MAJOR_VERSION (integer)
The GD major version PHP was compiled against. (Available as of PHP 5.2.4)
GD_MINOR_VERSION (integer)
The GD minor version PHP was compiled against. (Available as of PHP 5.2.4)
GD_RELEASE_VERSION (integer)
The GD release version PHP was compiled against. (Available as of PHP 5.2.4)
GD_EXTRA_VERSION (string)
The GD "extra" version (beta/rc..) PHP was compiled against. (Available as of PHP 5.2.4)
IMG_GIF (integer)
Used as a return value by imagetypes()
IMG_JPG (integer)
Used as a return value by imagetypes()
IMG_JPEG (integer)

Used as a return value by imagetypes()

Poznámka: This constant has the same value as IMAGE_JPG

IMG_PNG (integer)
Used as a return value by imagetypes()
IMG_WBMP (integer)
Used as a return value by imagetypes()
IMG_XPM (integer)
Used as a return value by imagetypes()
IMG_COLOR_TILED (integer)
Special color option which can be used in stead of color allocated with imagecolorallocate() or imagecolorallocatealpha()
IMG_COLOR_STYLED (integer)
Special color option which can be used in stead of color allocated with imagecolorallocate() or imagecolorallocatealpha()
IMG_COLOR_BRUSHED (integer)
Special color option which can be used in stead of color allocated with imagecolorallocate() or imagecolorallocatealpha()
IMG_COLOR_STYLEDBRUSHED (integer)
Special color option which can be used in stead of color allocated with imagecolorallocate() or imagecolorallocatealpha()
IMG_COLOR_TRANSPARENT (integer)
Special color option which can be used in stead of color allocated with imagecolorallocate() or imagecolorallocatealpha()
IMG_ARC_ROUNDED (integer)

A style constant used by the imagefilledarc() function.

Poznámka: This constant has the same value as IMG_ARC_PIE

IMG_ARC_PIE (integer)
A style constant used by the imagefilledarc() function.
IMG_ARC_CHORD (integer)
A style constant used by the imagefilledarc() function.
IMG_ARC_NOFILL (integer)
A style constant used by the imagefilledarc() function.
IMG_ARC_EDGED (integer)
A style constant used by the imagefilledarc() function.
IMG_GD2_RAW (integer)
A type constant used by the imagegd2() function.
IMG_GD2_COMPRESSED (integer)
A type constant used by the imagegd2() function.
IMG_EFFECT_REPLACE (integer)
Alpha blending effect used by the imagelayereffect() function.
IMG_EFFECT_ALPHABLEND (integer)
Alpha blending effect used by the imagelayereffect() function.
IMG_EFFECT_NORMAL (integer)
Alpha blending effect used by the imagelayereffect() function.
IMG_EFFECT_OVERLAY (integer)
Alpha blending effect used by the imagelayereffect() function.
IMG_FILTER_NEGATE (integer)
Special GD filter used by the imagefilter() function.
IMG_FILTER_GRAYSCALE (integer)
Special GD filter used by the imagefilter() function.
IMG_FILTER_BRIGHTNESS (integer)
Special GD filter used by the imagefilter() function.
IMG_FILTER_CONTRAST (integer)
Special GD filter used by the imagefilter() function.
IMG_FILTER_COLORIZE (integer)
Special GD filter used by the imagefilter() function.
IMG_FILTER_EDGEDETECT (integer)
Special GD filter used by the imagefilter() function.
IMG_FILTER_GAUSSIAN_BLUR (integer)
Special GD filter used by the imagefilter() function.
IMG_FILTER_SELECTIVE_BLUR (integer)
Special GD filter used by the imagefilter() function.
IMG_FILTER_EMBOSS (integer)
Special GD filter used by the imagefilter() function.
IMG_FILTER_MEAN_REMOVAL (integer)
Special GD filter used by the imagefilter() function.
IMG_FILTER_SMOOTH (integer)
Special GD filter used by the imagefilter() function.
IMAGETYPE_GIF (integer)
Image type constant used by the image_type_to_mime_type() and image_type_to_extension() functions.
IMAGETYPE_JPEG (integer)
Image type constant used by the image_type_to_mime_type() and image_type_to_extension() functions.
IMAGETYPE_PNG (integer)
Image type constant used by the image_type_to_mime_type() and image_type_to_extension() functions.
IMAGETYPE_SWF (integer)
Image type constant used by the image_type_to_mime_type() and image_type_to_extension() functions.
IMAGETYPE_PSD (integer)
Image type constant used by the image_type_to_mime_type() and image_type_to_extension() functions.
IMAGETYPE_BMP (integer)
Image type constant used by the image_type_to_mime_type() and image_type_to_extension() functions.
IMAGETYPE_WBMP (integer)
Image type constant used by the image_type_to_mime_type() and image_type_to_extension() functions.
IMAGETYPE_XBM (integer)
Image type constant used by the image_type_to_mime_type() and image_type_to_extension() functions.
IMAGETYPE_TIFF_II (integer)
Image type constant used by the image_type_to_mime_type() and image_type_to_extension() functions.
IMAGETYPE_TIFF_MM (integer)
Image type constant used by the image_type_to_mime_type() and image_type_to_extension() functions.
IMAGETYPE_IFF (integer)
Image type constant used by the image_type_to_mime_type() and image_type_to_extension() functions.
IMAGETYPE_JB2 (integer)
Image type constant used by the image_type_to_mime_type() and image_type_to_extension() functions.
IMAGETYPE_JPC (integer)
Image type constant used by the image_type_to_mime_type() and image_type_to_extension() functions.
IMAGETYPE_JP2 (integer)
Image type constant used by the image_type_to_mime_type() and image_type_to_extension() functions.
IMAGETYPE_JPX (integer)
Image type constant used by the image_type_to_mime_type() and image_type_to_extension() functions.
IMAGETYPE_SWC (integer)
Image type constant used by the image_type_to_mime_type() and image_type_to_extension() functions.
IMAGETYPE_ICO (integer)
Image type constant used by the image_type_to_mime_type() and image_type_to_extension() functions. (Available as of PHP 5.3.0)
PNG_NO_FILTER (integer)
A special PNG filter, used by the imagepng() function.
PNG_FILTER_NONE (integer)
A special PNG filter, used by the imagepng() function.
PNG_FILTER_SUB (integer)
A special PNG filter, used by the imagepng() function.
PNG_FILTER_UP (integer)
A special PNG filter, used by the imagepng() function.
PNG_FILTER_AVG (integer)
A special PNG filter, used by the imagepng() function.
PNG_FILTER_PAETH (integer)
A special PNG filter, used by the imagepng() function.
PNG_ALL_FILTERS (integer)
A special PNG filter, used by the imagepng() function.

Příklady

Příklad 829. PNG creation with PHP

<?php

header("Content-type: image/png");
$string = $_GET['text'];
$im     = imagecreatefrompng("images/button1.png");
$orange = imagecolorallocate($im, 220, 210, 60);
$px     = (imagesx($im) - 7.5 * strlen($string)) / 2;
imagestring($im, 3, $px, 9, $string, $orange);
imagepng($im);
imagedestroy($im);

?>

This example would be called from a page with a tag like: <img src="button.php?text=text">. The above button.php script then takes this "text" string and overlays it on top of a base image which in this case is "images/button1.png" and outputs the resulting image. This is a very convenient way to avoid having to draw new button images every time you want to change the text of a button. With this method they are dynamically generated.

Obsah

gd_info — Retrieve information about the currently installed GD library
getimagesize — Get the size of an image
image_type_to_extension — Get file extension for image type
image_type_to_mime_type — Get Mime-Type for image-type returned by getimagesize, exif_read_data, exif_thumbnail, exif_imagetype
image2wbmp — Output image to browser or file
imagealphablending — Set the blending mode for an image
imageantialias — Should antialias functions be used or not
imagearc — Draws an arc
imagechar — Draw a character horizontally
imagecharup — Draw a character vertically
imagecolorallocate — Allocate a color for an image
imagecolorallocatealpha — Allocate a color for an image
imagecolorat — Get the index of the color of a pixel
imagecolorclosest — Get the index of the closest color to the specified color
imagecolorclosestalpha — Get the index of the closest color to the specified color + alpha
imagecolorclosesthwb — Get the index of the color which has the hue, white and blackness nearest to the given color
imagecolordeallocate — De-allocate a color for an image
imagecolorexact — Get the index of the specified color
imagecolorexactalpha — Get the index of the specified color + alpha
imagecolormatch — Makes the colors of the palette version of an image more closely match the true color version
imagecolorresolve — Get the index of the specified color or its closest possible alternative
imagecolorresolvealpha — Get the index of the specified color + alpha or its closest possible alternative
imagecolorset — Set the color for the specified palette index
imagecolorsforindex — Get the colors for an index
imagecolorstotal — Find out the number of colors in an image's palette
imagecolortransparent — Define a color as transparent
imageconvolution — Apply a 3x3 convolution matrix, using coefficient and offset
imagecopy — Copy part of an image
imagecopymerge — Copy and merge part of an image
imagecopymergegray — Copy and merge part of an image with gray scale
imagecopyresampled — Copy and resize part of an image with resampling
imagecopyresized — Copy and resize part of an image
imagecreate — Create a new palette based image
imagecreatefromgd2 — Create a new image from GD2 file or URL
imagecreatefromgd2part — Create a new image from a given part of GD2 file or URL
imagecreatefromgd — Create a new image from GD file or URL
imagecreatefromgif — Create a new image from file or URL
imagecreatefromjpeg — Create a new image from file or URL
imagecreatefrompng — Create a new image from file or URL
imagecreatefromstring — Create a new image from the image stream in the string
imagecreatefromwbmp — Create a new image from file or URL
imagecreatefromxbm — Create a new image from file or URL
imagecreatefromxpm — Create a new image from file or URL
imagecreatetruecolor — Create a new true color image
imagedashedline — Draw a dashed line
imagedestroy — Destroy an image
imageellipse — Draw an ellipse
imagefill — Flood fill
imagefilledarc — Draw a partial ellipse and fill it
imagefilledellipse — Draw a filled ellipse
imagefilledpolygon — Draw a filled polygon
imagefilledrectangle — Draw a filled rectangle
imagefilltoborder — Flood fill to specific color
imagefilter — Applies a filter to an image
imagefontheight — Get font height
imagefontwidth — Get font width
imageftbbox — Give the bounding box of a text using fonts via freetype2
imagefttext — Write text to the image using fonts using FreeType 2
imagegammacorrect — Apply a gamma correction to a GD image
imagegd2 — Output GD2 image to browser or file
imagegd — Output GD image to browser or file
imagegif — Output image to browser or file
imagegrabscreen — Captures the whole screen
imagegrabwindow — Captures a window
imageinterlace — Enable or disable interlace
imageistruecolor — Finds whether an image is a truecolor image
imagejpeg — Output image to browser or file
imagelayereffect — Set the alpha blending flag to use the bundled libgd layering effects
imageline — Draw a line
imageloadfont — Load a new font
imagepalettecopy — Copy the palette from one image to another
imagepng — Output a PNG image to either the browser or a file
imagepolygon — Draws a polygon
imagepsbbox — Give the bounding box of a text rectangle using PostScript Type1 fonts
imagepsencodefont — Change the character encoding vector of a font
imagepsextendfont — Extend or condense a font
imagepsfreefont — Free memory used by a PostScript Type 1 font
imagepsloadfont — Load a PostScript Type 1 font from file
imagepsslantfont — Slant a font
imagepstext — Draws a text over an image using PostScript Type1 fonts
imagerectangle — Draw a rectangle
imagerotate — Rotate an image with a given angle
imagesavealpha — Set the flag to save full alpha channel information (as opposed to single-color transparency) when saving PNG images
imagesetbrush — Set the brush image for line drawing
imagesetpixel — Set a single pixel
imagesetstyle — Set the style for line drawing
imagesetthickness — Set the thickness for line drawing
imagesettile — Set the tile image for filling
imagestring — Draw a string horizontally
imagestringup — Draw a string vertically
imagesx — Get image width
imagesy — Get image height
imagetruecolortopalette — Convert a true color image to a palette image
imagettfbbox — Give the bounding box of a text using TrueType fonts
imagettftext — Write text to the image using TrueType fonts
imagetypes — Return the image types supported by this PHP build
imagewbmp — Output image to browser or file
imagexbm — Output XBM image to browser or file
iptcembed — Embed binary IPTC data into a JPEG image
iptcparse — Parsuje binární IPTC » http://www.iptc.org/ blok do jednotlivých tagů.
jpeg2wbmp — Convert JPEG image file to WBMP image file
png2wbmp — Convert PNG image file to WBMP image file
Předcházející | Nahoru | Další
iis_stop_service | Domů | gd_info


gd_info

(PHP 4 >= 4.3.0, PHP 5)

gd_info — Retrieve information about the currently installed GD library

Popis

array gd_info ( void )

Gets information about the version and capabilities of the installed GD library.

Návratové hodnoty

Returns an associative array.

Tabulka 132. Elements of array returned by gd_info()

Attribute | Meaning
GD Version | string value describing the installed libgd version.
Freetype Support | boolean value. TRUE if Freetype Support is installed.
Freetype Linkage | string value describing the way in which Freetype was linked. Expected values are: 'with freetype', 'with TTF library', and 'with unknown library'. This element will only be defined if Freetype Support evaluated to TRUE.
T1Lib Support | boolean value. TRUE if T1Lib support is included.
GIF Read Support | boolean value. TRUE if support for reading GIF images is included.
GIF Create Support | boolean value. TRUE if support for creating GIF images is included.
JPG Support | boolean value. TRUE if JPG support is included.
PNG Support | boolean value. TRUE if PNG support is included.
WBMP Support | boolean value. TRUE if WBMP support is included.
XBM Support | boolean value. TRUE if XBM support is included.

Příklady

Příklad 830. Using gd_info()

<?php
var_dump(gd_info());
?>

Výše uvedený příklad vypíše něco jako:

array(9) {
  ["GD Version"]=>
  string(24) "bundled (2.0 compatible)"
  ["FreeType Support"]=>
  bool(false)
  ["T1Lib Support"]=>
  bool(false)
  ["GIF Read Support"]=>
  bool(true)
  ["GIF Create Support"]=>
  bool(false)
  ["JPG Support"]=>
  bool(false)
  ["PNG Support"]=>
  bool(true)
  ["WBMP Support"]=>
  bool(true)
  ["XBM Support"]=>
  bool(false)
}

Viz také

imagepng()
imagejpeg()
imagegif()
imagewbmp()
imagetypes()

Předcházející | Nahoru | Další
LXV. Image Functions | Domů | getimagesize


getimagesize

(PHP 4, PHP 5)

getimagesize — Get the size of an image

Popis

array getimagesize ( string $filename [, array &$imageinfo] )

The getimagesize() function will determine the size of any given image file and return the dimensions along with the file type and a height/width text string to be used inside a normal HTML IMG tag and the correspondant HTTP content type.

getimagesize() can also return some more information in imageinfo parameter.

Poznámka: Note that JPC and JP2 are capable of having components with different bit depths. In this case, the value for "bits" is the highest bit depth encountered. Also, JP2 files may contain multiple JPEG 2000 codestreams. In this case, getimagesize() returns the values for the first codestream it encounters in the root of the file.

Poznámka: The information about icons are retreived from the icon with the highest bitrate.

Seznam parametrů

filename

This parameter specifies the file you wish to retrieve information about. It can reference a local file or (configuration permitting) a remote file using one of the supported streams.

imageinfo

This optional parameter allows you to extract some extended information from the image file. Currently, this will return the different JPG APP markers as an associative array. Some programs use these APP markers to embed text information in images. A very common one is to embed » IPTC information in the APP13 marker. You can use the iptcparse() function to parse the binary APP13 marker into something readable.

Návratové hodnoty

Returns an array with 5 elements.

Index 0 and 1 contains respectively the width and the height of the image.

Poznámka: Some formats may contain no image or may contain multiple images. In these cases, getimagesize() might not be able to properly determine the image size. getimagesize() will return zero for width and height in these cases.

Index 2 is one of the IMAGETYPE_XXX constants indicating the type of the image.

Index 3 is a text string with the correct height="yyy" width="xxx" string that can be used directly in an IMG tag.

mime is the correspondant MIME type of the image. This information can be used to deliver images with correct the HTTP Content-type header:

Příklad 831. getimagesize() and MIME types

<?php
$size = getimagesize($filename);
$fp = fopen($filename, "rb");
if ($size && $fp) {
    header("Content-type: {$size['mime']}");
    fpassthru($fp);
    exit;
} else {
    // error
}
?>

channels will be 3 for RGB pictures and 4 for CMYK pictures. bits is the number of bits for each color. However, for some image types, the presence of these values can be a bit confusing. As an example, GIF always uses 3 channels per pixel, but the number of bits per pixel cannot be calculated for an animated GIF with a global color table.

On failure, FALSE is returned.

Errors/Exceptions

If accessing the filename image is impossible, or if it isn't a valid picture, getimagesize() will generate an error of level E_WARNING. On read error, getimagesize() will generate an error of level E_NOTICE.

ChangeLog (záznam změn)

Verze | Popis
5.3.0 | Added icon support.
5.2.3 | Read errors generated by this function downgraded to E_NOTICE from E_WARNING.
4.3.2 | Support for JPC, JP2, JPX, JB2, XBM, and WBMP became available.
4.3.2 | JPEG 2000 support was added for the imageinfo parameter.
4.3.0 | bits and channels are present for other image types, too.
4.3.0 | mime was added.
4.3.0 | Support for SWC was added.
4.2.0 | Support for TIFF was added.
4.0.5 | URL support was added.

Příklady

Příklad 832. getimagesize (file)

<?php
list($width, $height, $type, $attr) = getimagesize("img/flag.jpg");
echo "<img src=\"img/flag.jpg\" $attr alt=\"getimagesize() example\" />";
?>

Příklad 833. getimagesize (URL)

<?php
$size = getimagesize("http://www.example.com/gifs/logo.gif");

// if the file name has space in it, encode it properly
$size = getimagesize("http://www.example.com/gifs/lo%20go.gif");

?>

Příklad 834. getimagesize() returning IPTC

<?php
$size = getimagesize("testimg.jpg", $info);
if (isset($info["APP13"])) {
    $iptc = iptcparse($info["APP13"]);
    var_dump($iptc);
}
?>

Poznámky

Poznámka: The getimagesize() function does not require the GD image library.

Viz také

image_type_to_mime_type()
exif_imagetype()
exif_read_data()
exif_thumbnail()

Předcházející | Nahoru | Další
gd_info | Domů | image_type_to_extension


image_type_to_extension

(PHP 5)

image_type_to_extension — Get file extension for image type

Popis

string image_type_to_extension ( int $imagetype [, bool $include_dot] )

Returns the extension for the given IMAGETYPE_XXX constant.

Seznam parametrů

imagetype

One of the IMAGETYPE_XXX constant.

include_dot

Whether to prepend a dot to the extension or not. Default to TRUE.

Návratové hodnoty

A string with the extension corresponding to the given image type.

Předcházející | Nahoru | Další
getimagesize | Domů | image_type_to_mime_type


image_type_to_mime_type

(PHP 4 >= 4.3.0, PHP 5)

image_type_to_mime_type — Get Mime-Type for image-type returned by getimagesize, exif_read_data, exif_thumbnail, exif_imagetype

Popis

string image_type_to_mime_type ( int $imagetype )

The image_type_to_mime_type() function will determine the Mime-Type for an IMAGETYPE constant.

Seznam parametrů

imagetype

One of the IMAGETYPE_XXX constants

Návratové hodnoty

The returned values are as follows

Tabulka 133. Returned values Constants

imagetype | Returned value
IMAGETYPE_GIF | image/gif
IMAGETYPE_JPEG | image/jpeg
IMAGETYPE_PNG | image/png
IMAGETYPE_SWF | application/x-shockwave-flash
IMAGETYPE_PSD | image/psd
IMAGETYPE_BMP | image/bmp
IMAGETYPE_TIFF_II (intel byte order) | image/tiff
IMAGETYPE_TIFF_MM (motorola byte order) | image/tiff
IMAGETYPE_JPC | application/octet-stream
IMAGETYPE_JP2 | image/jp2
IMAGETYPE_JPX | application/octet-stream
IMAGETYPE_JB2 | application/octet-stream
IMAGETYPE_SWC | application/x-shockwave-flash
IMAGETYPE_IFF | image/iff
IMAGETYPE_WBMP | image/vnd.wap.wbmp
IMAGETYPE_XBM | image/xbm
IMAGETYPE_ICO | image/vnd.microsoft.icon

Příklady

Příklad 835. image_type_to_mime_type (file)

<?php
header("Content-type: " . image_type_to_mime_type(IMAGETYPE_PNG));
?>

Poznámky

Poznámka: This function does not require the GD image library.

Viz také

getimagesize()
exif_imagetype()
exif_read_data()
exif_thumbnail()

Předcházející | Nahoru | Další
image_type_to_extension | Domů | image2wbmp


image2wbmp

(PHP 4 >= 4.0.5, PHP 5)

image2wbmp — Output image to browser or file

Popis

bool image2wbmp ( resource $image [, string $filename [, int $threshold]] )

image2wbmp() outputs or save a WBMP version of the given image.

Seznam parametrů

image

An image resource, returned by one of the image creation functions, such as imagecreatetruecolor().

filename

Path to the saved file. If not given, the raw image stream will be outputed directly.

threshold

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 836. image2wbmp() example

<?php

$file = 'php.png';
$image = imagecreatefrompng($file);

header('Content-type: ' . image_type_to_mime_type(IMAGETYPE_WBMP));
image2wbmp($image); // output the stream directly

?>

Poznámky

Poznámka: WBMP support is only available if PHP was compiled against GD-1.8 or later.

Viz také

imagewbmp()

Předcházející | Nahoru | Další
image_type_to_mime_type | Domů | imagealphablending


imagealphablending

(PHP 4 >= 4.0.6, PHP 5)

imagealphablending — Set the blending mode for an image

Popis

bool imagealphablending ( resource $image, bool $blendmode )

imagealphablending() allows for two different modes of drawing on truecolor images. In blending mode, the alpha channel component of the color supplied to all drawing function, such as imagesetpixel() determines how much of the underlying color should be allowed to shine through. As a result, gd automatically blends the existing color at that point with the drawing color, and stores the result in the image. The resulting pixel is opaque. In non-blending mode, the drawing color is copied literally with its alpha channel information, replacing the destination pixel. Blending mode is not available when drawing on palette images.

Seznam parametrů

image

An image resource, returned by one of the image creation functions, such as imagecreatetruecolor().

blendmode

Whether to enable the blending mode or not. Default to FALSE.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Poznámky

Poznámka: Tato funkce vyžaduje GD 2.0.1 nebo novější (doporučena verze 2.0.28 nebo novější).

Předcházející | Nahoru | Další
image2wbmp | Domů | imageantialias


imageantialias

(PHP 4 >= 4.3.2, PHP 5)

imageantialias — Should antialias functions be used or not

Popis

bool imageantialias ( resource $image, bool $on )

Activate the fast drawing antialiased methods for lines and wired polygons. It does not support alpha components. It works using a direct blend operation. It works only with truecolor images.

Thickness and styled are not supported.

Using antialiased primitives with transparent background color can end with some unexpected results. The blend method uses the background color as any other colors. The lack of alpha component support does not allow an alpha based antialiasing method.

Seznam parametrů

image

An image resource, returned by one of the image creation functions, such as imagecreatetruecolor().

on

Whether to enable antialiasing or not.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Poznámky

Poznámka: Tato funce je k dispozici jen tehdy, bylo-li PHP zkompilováno s přibalenou verzí knihovny GD.

Viz také

imagecreatetruecolor()

Předcházející | Nahoru | Další
imagealphablending | Domů | imagearc


imagearc

(PHP 4, PHP 5)

imagearc — Draws an arc

Popis

bool imagearc ( resource $image, int $cx, int $cy, int $width, int $height, int $start, int $end, int $color )

imagearc() draws an arc of circle centered at the given coordinates.

Seznam parametrů

image

An image resource, returned by one of the image creation functions, such as imagecreatetruecolor().

cx

x-coordinate of the center

cy

y-coordinate of the center

width

The arc width

height

The arc height

start

The arc start angle, in degrees.

end

The arc end angle, in degrees. 0° is located at the three-o'clock position, and the arc is drawn clockwise.

color

A color identifier created with imagecolorallocate()

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 837. Drawing a circle with imagearc()

<?php

// create a 200*200 image
$img = imagecreatetruecolor(200, 200);

// allocate some colors
$white = imagecolorallocate($img, 255, 255, 255);
$red   = imagecolorallocate($img, 255,   0,   0);
$green = imagecolorallocate($img,   0, 255,   0);
$blue  = imagecolorallocate($img,   0,   0, 255);

// draw the head
imagearc($img, 100, 100, 200, 200,  0, 360, $white);
// mouth
imagearc($img, 100, 100, 150, 150, 25, 155, $red);
// left and then the right eye
imagearc($img,  60,  75,  50,  50,  0, 360, $green);
imagearc($img, 140,  75,  50,  50,  0, 360, $blue);

// output image in the browser
header("Content-type: image/png");
imagepng($img);

// free memory
imagedestroy($img);

?>

Výše uvedený příklad vypíše něco jako:

Viz také

imagefilledarc()
imageellipse()
imagefilledellipse()

Předcházející | Nahoru | Další
imageantialias | Domů | imagechar


imagechar

(PHP 4, PHP 5)

imagechar — Draw a character horizontally

Popis

bool imagechar ( resource $image, int $font, int $x, int $y, string $c, int $color )

imagechar() draws the first character of c in the image identified by image with its upper-left at x,y (top left is 0, 0) with the color color.

Seznam parametrů

image

An image resource, returned by one of the image creation functions, such as imagecreatetruecolor().

font

Can be 1, 2, 3, 4, 5 for built-in fonts in latin2 encoding (where higher numbers corresponding to larger fonts) or any of your own font identifiers registered with imageloadfont().

x

x-coordinate of the start

y

y-coordinate of the start

c

The character to draw

color

A color identifier created with imagecolorallocate()

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 838. imagechar() example

<?php

$im = imagecreate(100, 100);

$string = 'PHP';

$bg = imagecolorallocate($im, 255, 255, 255);
$black = imagecolorallocate($im, 0, 0, 0);

// prints a black "P" in the top left corner
imagechar($im, 1, 0, 0, $string, $black);

header('Content-type: image/png');
imagepng($im);

?>

Výše uvedený příklad vypíše něco jako:

Viz také

imagecharup()
imageloadfont()

Předcházející | Nahoru | Další
imagearc | Domů | imagecharup


imagecharup

(PHP 4, PHP 5)

imagecharup — Draw a character vertically

Popis

bool imagecharup ( resource $image, int $font, int $x, int $y, string $c, int $color )

Draws the character c vertically at the specified coordinate on the given image.

Seznam parametrů

image

An image resource, returned by one of the image creation functions, such as imagecreatetruecolor().

font

Can be 1, 2, 3, 4, 5 for built-in fonts in latin2 encoding (where higher numbers corresponding to larger fonts) or any of your own font identifiers registered with imageloadfont().

x

x-coordinate of the start

y

y-coordinate of the start

c

The character to draw

color

A color identifier created with imagecolorallocate()

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 839. imagecharup() example

<?php

$im = imagecreate(100, 100);

$string = 'Note that the first letter is a N';

$bg = imagecolorallocate($im, 255, 255, 255);
$black = imagecolorallocate($im, 0, 0, 0);

// prints a black "Z" on a white background
imagecharup($im, 3, 10, 10, $string, $black);

header('Content-type: image/png');
imagepng($im);

?>

Výše uvedený příklad vypíše něco jako:

Viz také

imagechar()
imageloadfont()

Předcházející | Nahoru | Další
imagechar | Domů | imagecolorallocate


imagecolorallocate

(PHP 4, PHP 5)

imagecolorallocate — Allocate a color for an image

Popis

int imagecolorallocate ( resource $image, int $red, int $green, int $blue )

Returns a color identifier representing the color composed of the given RGB components.

imagecolorallocate() must be called to create each color that is to be used in the image represented by image.

Poznámka: The first call to imagecolorallocate() fills the background color in palette-based images - images created using imagecreate().

Seznam parametrů

image

An image resource, returned by one of the image creation functions, such as imagecreatetruecolor().

red

Value of red component

green

Value of green component

blue

Value of blue component

These parameters are integers between 0 and 255 or hexadecimals between 0x00 and 0xFF.

Návratové hodnoty

A color identifier or FALSE if the allocation failed.

ChangeLog (záznam změn)

Verze | Popis
Prior to 5.1.3 | Returns -1 if the allocation failed.

Příklady

Příklad 840. imagecolorallocate() example

<?php

$im = imagecreate(100, 100);

// sets background to red
$background = imagecolorallocate($im, 255, 0, 0);

// sets some colors
$white = imagecolorallocate($im, 255, 255, 255);
$black = imagecolorallocate($im, 0, 0, 0);

// hexadecimal way
$white = imagecolorallocate($im, 0xFF, 0xFF, 0xFF);
$black = imagecolorallocate($im, 0x00, 0x00, 0x00);

?>

Viz také

imagecolorallocatealpha()
imagecolordeallocate()

Předcházející | Nahoru | Další
imagecharup | Domů | imagecolorallocatealpha


imagecolorallocatealpha

(PHP 4 >= 4.3.2, PHP 5)

imagecolorallocatealpha — Allocate a color for an image

Popis

int imagecolorallocatealpha ( resource $image, int $red, int $green, int $blue, int $alpha )

imagecolorallocatealpha() behaves identically to imagecolorallocate() with the addition of the transparency parameter alpha.

Seznam parametrů

image

An image resource, returned by one of the image creation functions, such as imagecreatetruecolor().

red

Value of red component

green

Value of green component

blue

Value of blue component

alpha

A value between 0 and 127. 0 indicates completely opaque while 127 indicates completely transparent.

The colors parameters are integers between 0 and 255 or hexadecimals between 0x00 and 0xFF.

Návratové hodnoty

A color identifier or FALSE if the allocation failed.

ChangeLog (záznam změn)

Verze | Popis
Prior to 5.1.3 | Returns -1 if the allocation failed.

Příklady

Příklad 841. Example of using imagecolorallocatealpha()

<?php
$size = 300;
$image=imagecreatetruecolor($size, $size);

// something to get a white background with black border
$back = imagecolorallocate($image, 255, 255, 255);
$border = imagecolorallocate($image, 0, 0, 0);
imagefilledrectangle($image, 0, 0, $size - 1, $size - 1, $back);
imagerectangle($image, 0, 0, $size - 1, $size - 1, $border);

$yellow_x = 100;
$yellow_y = 75;
$red_x    = 120;
$red_y    = 165;
$blue_x   = 187;
$blue_y   = 125;
$radius   = 150;

// allocate colors with alpha values
$yellow = imagecolorallocatealpha($image, 255, 255, 0, 75);
$red    = imagecolorallocatealpha($image, 255, 0, 0, 75);
$blue   = imagecolorallocatealpha($image, 0, 0, 255, 75);

// drawing 3 overlapped circle
imagefilledellipse($image, $yellow_x, $yellow_y, $radius, $radius, $yellow);
imagefilledellipse($image, $red_x, $red_y, $radius, $radius, $red);
imagefilledellipse($image, $blue_x, $blue_y, $radius, $radius, $blue);

// don't forget to output a correct header!
header('Content-type: image/png');

// and finally, output the result
imagepng($image);
imagedestroy($image);
?>

Výše uvedený příklad vypíše něco jako:

Poznámky

Poznámka: Tato funkce vyžaduje GD 2.0.1 nebo novější (doporučena verze 2.0.28 nebo novější).

Viz také

imagecolorallocate()
imagecolordeallocate()

Předcházející | Nahoru | Další
imagecolorallocate | Domů | imagecolorat


imagecolorat

(PHP 4, PHP 5)

imagecolorat — Get the index of the color of a pixel

Popis

int imagecolorat ( resource $image, int $x, int $y )

Returns the index of the color of the pixel at the specified location in the image specified by image.

If PHP is compiled against GD library 2.0 or higher and the image is a truecolor image, this function returns the RGB value of that pixel as integer. Use bitshifting and masking to access the distinct red, green and blue component values:

Seznam parametrů

image

An image resource, returned by one of the image creation functions, such as imagecreatetruecolor().

x

x-coordinate of the point

y

y-coordinate of the point

Návratové hodnoty

Returns the index of the color.

Příklady

Příklad 842. Access distinct RGB values

<?php
$im = imagecreatefrompng("php.png");
$rgb = imagecolorat($im, 10, 15);
$r = ($rgb >> 16) & 0xFF;
$g = ($rgb >> 8) & 0xFF;
$b = $rgb & 0xFF;
?>

Výše uvedený příklad vypíše něco jako:

int(119)
int(123)
int(180)

Viz také

imagecolorset()
imagecolorsforindex()

Předcházející | Nahoru | Další
imagecolorallocatealpha | Domů | imagecolorclosest


imagecolorclosest

(PHP 4, PHP 5)

imagecolorclosest — Get the index of the closest color to the specified color

Popis

int imagecolorclosest ( resource $image, int $red, int $green, int $blue )

Returns the index of the color in the palette of the image which is "closest" to the specified RGB value.

The "distance" between the desired color and each color in the palette is calculated as if the RGB values represented points in three-dimensional space.

If you created the image from a file, only colors used in the image are resolved. Colors present only in the pallete are not resolved.

Seznam parametrů

image

An image resource, returned by one of the image creation functions, such as imagecreatetruecolor().

red

Value of red component

green

Value of green component

blue

Value of blue component

The colors parameters are integers between 0 and 255 or hexadecimals between 0x00 and 0xFF.

Návratové hodnoty

Returns the index of the closest color, in the palette of the image, to the specified one

Viz také

imagecolorexact()

Předcházející | Nahoru | Další
imagecolorat | Domů | imagecolorclosestalpha


imagecolorclosestalpha

(PHP 4 >= 4.0.6, PHP 5)

imagecolorclosestalpha — Get the index of the closest color to the specified color + alpha

Popis

int imagecolorclosestalpha ( resource $image, int $red, int $green, int $blue, int $alpha )

Returns the index of the color in the palette of the image which is "closest" to the specified RGB value and alpha level.

Seznam parametrů

image

An image resource, returned by one of the image creation functions, such as imagecreatetruecolor().

red

Value of red component

green

Value of green component

blue

Value of blue component

alpha

A value between 0 and 127. 0 indicates completely opaque while 127 indicates completely transparent.

The colors parameters are integers between 0 and 255 or hexadecimals between 0x00 and 0xFF.

Návratové hodnoty

Returns the index of the closest color in the palette.

Poznámky

Poznámka: Tato funkce vyžaduje GD 2.0.1 nebo novější (doporučena verze 2.0.28 nebo novější).

Viz také

imagecolorexactalpha()

Předcházející | Nahoru | Další
imagecolorclosest | Domů | imagecolorclosesthwb


imagecolorclosesthwb

(PHP 4 >= 4.0.1, PHP 5)

imagecolorclosesthwb — Get the index of the color which has the hue, white and blackness nearest to the given color

Popis

int imagecolorclosesthwb ( resource $image, int $red, int $green, int $blue )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

image

An image resource, returned by one of the image creation functions, such as imagecreatetruecolor().

red

Value of red component

green

Value of green component

blue

Value of blue component

Předcházející | Nahoru | Další
imagecolorclosestalpha | Domů | imagecolordeallocate


imagecolordeallocate

(PHP 4, PHP 5)

imagecolordeallocate — De-allocate a color for an image

Popis

bool imagecolordeallocate ( resource $image, int $color )

De-allocates a color previously allocated with imagecolorallocate() or imagecolorallocatealpha().

Seznam parametrů

image

An image resource, returned by one of the image creation functions, such as imagecreatetruecolor().

color

The color identifier

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 843. Using imagecolordeallocate()

<?php
$white = imagecolorallocate($im, 255, 255, 255);
imagecolordeallocate($im, $white);
?>

Viz také

imagecolorallocate()
imagecolorallocatealpha()

Předcházející | Nahoru | Další
imagecolorclosesthwb | Domů | imagecolorexact


imagecolorexact

(PHP 4, PHP 5)

imagecolorexact — Get the index of the specified color

Popis

int imagecolorexact ( resource $image, int $red, int $green, int $blue )

Returns the index of the specified color in the palette of the image.

If you created the image from a file, only colors used in the image are resolved. Colors present only in the pallete are not resolved.

Seznam parametrů

image

An image resource, returned by one of the image creation functions, such as imagecreatetruecolor().

red

Value of red component

green

Value of green component

blue

Value of blue component

Návratové hodnoty

Returns the index of the specified color in the palette, or -1 if the color does not exist.

Viz také

imagecolorclosest()

Předcházející | Nahoru | Další
imagecolordeallocate | Domů | imagecolorexactalpha


imagecolorexactalpha

(PHP 4 >= 4.0.6, PHP 5)

imagecolorexactalpha — Get the index of the specified color + alpha

Popis

int imagecolorexactalpha ( resource $image, int $red, int $green, int $blue, int $alpha )

Returns the index of the specified color+alpha in the palette of the image.

Seznam parametrů

image

An image resource, returned by one of the image creation functions, such as imagecreatetruecolor().

red

Value of red component

green

Value of green component

blue

Value of blue component

alpha

A value between 0 and 127. 0 indicates completely opaque while 127 indicates completely transparent.

The colors parameters are integers between 0 and 255 or hexadecimals between 0x00 and 0xFF.

Návratové hodnoty

Returns the index of the specified color+alpha in the palette of the image, or -1 if the color does not exist in the image's palette.

Poznámky

Poznámka: Tato funkce vyžaduje GD 2.0.1 nebo novější (doporučena verze 2.0.28 nebo novější).

Viz také

imagecolorclosestalpha()

Předcházející | Nahoru | Další
imagecolorexact | Domů | imagecolormatch


imagecolormatch

(PHP 4 >= 4.3.0, PHP 5)

imagecolormatch — Makes the colors of the palette version of an image more closely match the true color version

Popis

bool imagecolormatch ( resource $image1, resource $image2 )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

image1

A truecolor image link resource

image2

A palette image link resource pointing to an image that has the same size as image1

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Poznámky

Poznámka: Tato funce je k dispozici jen tehdy, bylo-li PHP zkompilováno s přibalenou verzí knihovny GD.

Poznámka: Tato funkce vyžaduje GD 2.0.1 nebo novější (doporučena verze 2.0.28 nebo novější).

Viz také

imagecreatetruecolor()

Předcházející | Nahoru | Další
imagecolorexactalpha | Domů | imagecolorresolve


imagecolorresolve

(PHP 4, PHP 5)

imagecolorresolve — Get the index of the specified color or its closest possible alternative

Popis

int imagecolorresolve ( resource $image, int $red, int $green, int $blue )

This function is guaranteed to return a color index for a requested color, either the exact color or the closest possible alternative.

If you created the image from a file, only colors used in the image are resolved. Colors present only in the pallete are not resolved.

Seznam parametrů

image

An image resource, returned by one of the image creation functions, such as imagecreatetruecolor().

red

Value of red component

green

Value of green component

blue

Value of blue component

Návratové hodnoty

Returns a color index.

Viz také

imagecolorclosest()

Předcházející | Nahoru | Další
imagecolormatch | Domů | imagecolorresolvealpha


imagecolorresolvealpha

(PHP 4 >= 4.0.6, PHP 5)

imagecolorresolvealpha — Get the index of the specified color + alpha or its closest possible alternative

Popis

int imagecolorresolvealpha ( resource $image, int $red, int $green, int $blue, int $alpha )

This function is guaranteed to return a color index for a requested color, either the exact color or the closest possible alternative.

Seznam parametrů

image

An image resource, returned by one of the image creation functions, such as imagecreatetruecolor().

red

Value of red component

green

Value of green component

blue

Value of blue component

alpha

A value between 0 and 127. 0 indicates completely opaque while 127 indicates completely transparent.

The colors parameters are integers between 0 and 255 or hexadecimals between 0x00 and 0xFF.

Návratové hodnoty

Returns a color index.

Poznámky

Poznámka: Tato funkce vyžaduje GD 2.0.1 nebo novější (doporučena verze 2.0.28 nebo novější).

Viz také

imagecolorclosestalpha()

Předcházející | Nahoru | Další
imagecolorresolve | Domů | imagecolorset


imagecolorset

(PHP 4, PHP 5)

imagecolorset — Set the color for the specified palette index

Popis

void imagecolorset ( resource $image, int $index, int $red, int $green, int $blue )

This sets the specified index in the palette to the specified color. This is useful for creating flood-fill-like effects in palleted images without the overhead of performing the actual flood-fill.

Seznam parametrů

image

An image resource, returned by one of the image creation functions, such as imagecreatetruecolor().

index

An index in the palette

red

Value of red component

green

Value of green component

blue

Value of blue component

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

imagecolorat()

Předcházející | Nahoru | Další
imagecolorresolvealpha | Domů | imagecolorsforindex


imagecolorsforindex

(PHP 4, PHP 5)

imagecolorsforindex — Get the colors for an index

Popis

array imagecolorsforindex ( resource $image, int $index )

Gets the color for a specified index.

Seznam parametrů

image

An image resource, returned by one of the image creation functions, such as imagecreatetruecolor().

index

Návratové hodnoty

Returns an associative array with red, green, blue and alpha keys that contain the appropriate values for the specified color index.

Příklady

Příklad 844. imagecolorsforindex() example

<?php

// open an image
$im = imagecreatefrompng('nexen.png');

// get a color
$start_x = 40;
$start_y = 50;
$color_index = imagecolorat($im, $start_x, $start_y);

// make it human readable
$color_tran = imagecolorsforindex($im, $color_index);

// what is it ?
print_r($color_tran);

?>

Výše uvedený příklad vypíše něco jako:

Array
(
   [red] => 226
   [green] => 222
   [blue] => 252
   [alpha] => 0
)

Viz také

imagecolorat()
imagecolorexact()

Předcházející | Nahoru | Další
imagecolorset | Domů | imagecolorstotal


imagecolorstotal

(PHP 4, PHP 5)

imagecolorstotal — Find out the number of colors in an image's palette

Popis

int imagecolorstotal ( resource $image )

Returns the number of colors in an image palette.

Seznam parametrů

image

An image resource, returned by one of the image creation functions, such as imagecreatetruecolor().

Návratové hodnoty

Returns the number of colors in the specified image's palette or 0 for truecolor images.

Viz také

imagecolorat()
imagecolorsforindex()
imageistruecolor()

Předcházející | Nahoru | Další
imagecolorsforindex | Domů | imagecolortransparent


imagecolortransparent

(PHP 4, PHP 5)

imagecolortransparent — Define a color as transparent

Popis

int imagecolortransparent ( resource $image [, int $color] )

Sets the transparent color in the given image.

Seznam parametrů

image

An image resource, returned by one of the image creation functions, such as imagecreatetruecolor().

color

A color identifier created with imagecolorallocate()

Návratové hodnoty

The identifier of the new (or current, if none is specified) transparent color is returned.

Poznámky

Poznámka: Transparency is copied only with imagecopymerge() and true color images, not with imagecopy() or pallete images.

Poznámka: The transparent color is a property of the image, transparency is not a property of the color. Once you have set a color to be the transparent color, any regions of the image in that color that were drawn previously will be transparent.

Předcházející | Nahoru | Další
imagecolorstotal | Domů | imageconvolution


imagecopy

(PHP 4, PHP 5)

imagecopy — Copy part of an image

Popis

bool imagecopy ( resource $dst_im, resource $src_im, int $dst_x, int $dst_y, int $src_x, int $src_y, int $src_w, int $src_h )

Copy a part of src_im onto dst_im starting at the x,y coordinates src_x, src_y with a width of src_w and a height of src_h. The portion defined will be copied onto the x,y coordinates, dst_x and dst_y.

Seznam parametrů

dst_im

Destination image link resource

src_im

Source image link resource

dst_x

x-coordinate of destination point

dst_y

y-coordinate of destination point

src_x

x-coordinate of source point

src_y

y-coordinate of source point

src_w

Source width

src_h

Source height

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
imageconvolution | Domů | imagecopymerge


imagecopymerge

(PHP 4 >= 4.0.1, PHP 5)

imagecopymerge — Copy and merge part of an image

Popis

bool imagecopymerge ( resource $dst_im, resource $src_im, int $dst_x, int $dst_y, int $src_x, int $src_y, int $src_w, int $src_h, int $pct )

Copy a part of src_im onto dst_im starting at the x,y coordinates src_x, src_y with a width of src_w and a height of src_h. The portion defined will be copied onto the x,y coordinates, dst_x and dst_y.

Seznam parametrů

dst_im

Destination image link resource

src_im

Source image link resource

dst_x

x-coordinate of destination point

dst_y

y-coordinate of destination point

src_x

x-coordinate of source point

src_y

y-coordinate of source point

src_w

Source width

src_h

Source height

pct

The two images will be merged according to pct which can range from 0 to 100. When pct = 0, no action is taken, when 100 this function behaves identically to imagecopy() for pallete images, while it implements alpha transparency for true colour images.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
imagecopy | Domů | imagecopymergegray


imagecopymergegray

(PHP 4 >= 4.0.6, PHP 5)

imagecopymergegray — Copy and merge part of an image with gray scale

Popis

bool imagecopymergegray ( resource $dst_im, resource $src_im, int $dst_x, int $dst_y, int $src_x, int $src_y, int $src_w, int $src_h, int $pct )

imagecopymergegray() copy a part of src_im onto dst_im starting at the x,y coordinates src_x, src_y with a width of src_w and a height of src_h. The portion defined will be copied onto the x,y coordinates, dst_x and dst_y.

This function is identical to imagecopymerge() except that when merging it preserves the hue of the source by converting the destination pixels to gray scale before the copy operation.

Seznam parametrů

dst_im

Destination image link resource

src_im

Source image link resource

dst_x

x-coordinate of destination point

dst_y

y-coordinate of destination point

src_x

x-coordinate of source point

src_y

y-coordinate of source point

src_w

Source width

src_h

Source height

pct

The two images will be merged according to pct which can range from 0 to 100. When pct = 0, no action is taken, when 100 this function behaves identically to imagecopy() for pallete images, while it implements alpha transparency for true colour images.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
imagecopymerge | Domů | imagecopyresampled


imagecopyresampled

(PHP 4 >= 4.0.6, PHP 5)

imagecopyresampled — Copy and resize part of an image with resampling

Popis

bool imagecopyresampled ( resource $dst_image, resource $src_image, int $dst_x, int $dst_y, int $src_x, int $src_y, int $dst_w, int $dst_h, int $src_w, int $src_h )

imagecopyresampled() copies a rectangular portion of one image to another image, smoothly interpolating pixel values so that, in particular, reducing the size of an image still retains a great deal of clarity.

If the source and destination coordinates and width and heights differ, appropriate stretching or shrinking of the image fragment will be performed. The coordinates refer to the upper left corner. This function can be used to copy regions within the same image (if dst_image is the same as src_image) but if the regions overlap the results will be unpredictable.

Seznam parametrů

dst_im

Destination image link resource

src_im

Source image link resource

dst_x

x-coordinate of destination point

dst_y

y-coordinate of destination point

src_x

x-coordinate of source point

src_y

y-coordinate of source point

dst_w

Destination width

dst_h

Destination height

src_w

Source width

src_h

Source height

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 847. Simple example

This example will resample an image to half its original size.

<?php
// The file
$filename = 'test.jpg';
$percent = 0.5;

// Content type
header('Content-type: image/jpeg');

// Get new dimensions
list($width, $height) = getimagesize($filename);
$new_width = $width * $percent;
$new_height = $height * $percent;

// Resample
$image_p = imagecreatetruecolor($new_width, $new_height);
$image = imagecreatefromjpeg($filename);
imagecopyresampled($image_p, $image, 0, 0, 0, 0, $new_width, $new_height, $width, $height);

// Output
imagejpeg($image_p, null, 100);
?>

Výše uvedený příklad vypíše něco jako:

Příklad 848. Resampling an image proportionally

This example will display an image with the maximum width, or height, of 200 pixels.

<?php
// The file
$filename = 'test.jpg';

// Set a maximum height and width
$width = 200;
$height = 200;

// Content type
header('Content-type: image/jpeg');

// Get new dimensions
list($width_orig, $height_orig) = getimagesize($filename);

$ratio_orig = $width_orig/$height_orig;

if ($width/$height > $ratio_orig) {
   $width = $height*$ratio_orig;
} else {
   $height = $width/$ratio_orig;
}

// Resample
$image_p = imagecreatetruecolor($width, $height);
$image = imagecreatefromjpeg($filename);
imagecopyresampled($image_p, $image, 0, 0, 0, 0, $width, $height, $width_orig, $height_orig);

// Output
imagejpeg($image_p, null, 100);
?>

Výše uvedený příklad vypíše něco jako:

Poznámky

Poznámka: There is a problem due to palette image limitations (255+1 colors). Resampling or filtering an image commonly needs more colors than 255, a kind of approximation is used to calculate the new resampled pixel and its color. With a palette image we try to allocate a new color, if that failed, we choose the closest (in theory) computed color. This is not always the closest visual color. That may produce a weird result, like blank (or visually blank) images. To skip this problem, please use a truecolor image as a destination image, such as one created by imagecreatetruecolor().

Viz také

imagecopyresized()

Předcházející | Nahoru | Další
imagecopymergegray | Domů | imagecopyresized


imagecopyresized

(PHP 4, PHP 5)

imagecopyresized — Copy and resize part of an image

Popis

bool imagecopyresized ( resource $dst_image, resource $src_image, int $dst_x, int $dst_y, int $src_x, int $src_y, int $dst_w, int $dst_h, int $src_w, int $src_h )

imagecopyresized() copies a rectangular portion of one image to another image. dst_image is the destination image, src_image is the source image identifier. If the source and destination coordinates and width and heights differ, appropriate stretching or shrinking of the image fragment will be performed. The coordinates refer to the upper left corner. This function can be used to copy regions within the same image (if dst_image is the same as src_image) but if the regions overlap the results will be unpredictable.

Seznam parametrů

dst_im

Destination image link resource

src_im

Source image link resource

dst_x

x-coordinate of destination point

dst_y

y-coordinate of destination point

src_x

x-coordinate of source point

src_y

y-coordinate of source point

dst_w

Destination width

dst_h

Destination height

src_w

Source width

src_h

Source height

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 849. Resizing an image

This example will display the image at half size.

<?php
// File and new size
$filename = 'test.jpg';
$percent = 0.5;

// Content type
header('Content-type: image/jpeg');

// Get new sizes
list($width, $height) = getimagesize($filename);
$newwidth = $width * $percent;
$newheight = $height * $percent;

// Load
$thumb = imagecreatetruecolor($newwidth, $newheight);
$source = imagecreatefromjpeg($filename);

// Resize
imagecopyresized($thumb, $source, 0, 0, 0, 0, $newwidth, $newheight, $width, $height);

// Output
imagejpeg($thumb);
?>

Výše uvedený příklad vypíše něco jako:

The image will be output at half size, though better quality could be obtained using imagecopyresampled().

Poznámky

Poznámka: There is a problem due to palette image limitations (255+1 colors). Resampling or filtering an image commonly needs more colors than 255, a kind of approximation is used to calculate the new resampled pixel and its color. With a palette image we try to allocate a new color, if that failed, we choose the closest (in theory) computed color. This is not always the closest visual color. That may produce a weird result, like blank (or visually blank) images. To skip this problem, please use a truecolor image as a destination image, such as one created by imagecreatetruecolor().

Viz také

imagecopyresampled()

Předcházející | Nahoru | Další
imagecopyresampled | Domů | imagecreate


imagecreate

(PHP 4, PHP 5)

imagecreate — Create a new palette based image

Popis

resource imagecreate ( int $width, int $height )

imagecreate() returns an image identifier representing a blank image of specified size.

We recommend the use of imagecreatetruecolor().

Seznam parametrů

width

The image width

height

The image height

Návratové hodnoty

Returns an image resource identifier on success, FALSE on errors.

Příklady

Příklad 850. Creating a new GD image stream and outputting an image.

<?php
header("Content-type: image/png");
$im = @imagecreate(110, 20)
    or die("Cannot Initialize new GD image stream");
$background_color = imagecolorallocate($im, 0, 0, 0);
$text_color = imagecolorallocate($im, 233, 14, 91);
imagestring($im, 1, 5, 5,  "A Simple Text String", $text_color);
imagepng($im);
imagedestroy($im);
?>

Výše uvedený příklad vypíše něco jako:

Viz také

imagedestroy()
imagecreatetruecolor()

Předcházející | Nahoru | Další
imagecopyresized | Domů | imagecreatefromgd2


imagecreatefromgd2

(PHP 4 >= 4.0.7, PHP 5)

imagecreatefromgd2 — Create a new image from GD2 file or URL

Popis

resource imagecreatefromgd2 ( string $filename )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Tip

S touto funkcí můžete používat URL jako název souboru, pokud je zapnuta volba "fopen wrappers". Pro více detailů o tom, jak specifikovat název souboru, a O – „List of Supported Protocols/Wrappers“pro seznam porporovaných URL protokolů, viz fopen().

Seznam parametrů

filename

Poznámky

Poznámka: Tato funkce vyžaduje GD 2.0.1 nebo novější (doporučena verze 2.0.28 nebo novější).

Varování

Verze PHP pro Windows starší než 4.3.0 nepodporuje pro tuto funkci dálkový přístup k souborům, a to ani když je aktivní volba allow_url_fopen.

Předcházející | Nahoru | Další
imagecreate | Domů | imagecreatefromgd2part


imagecreatefromgd2part

(PHP 4 >= 4.0.7, PHP 5)

imagecreatefromgd2part — Create a new image from a given part of GD2 file or URL

Popis

resource imagecreatefromgd2part ( string $filename, int $srcX, int $srcY, int $width, int $height )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Tip

S touto funkcí můžete používat URL jako název souboru, pokud je zapnuta volba "fopen wrappers". Pro více detailů o tom, jak specifikovat název souboru, a O – „List of Supported Protocols/Wrappers“pro seznam porporovaných URL protokolů, viz fopen().

Seznam parametrů

filename

srcX

srcY

width

height

Poznámky

Poznámka: Tato funkce vyžaduje GD 2.0.1 nebo novější (doporučena verze 2.0.28 nebo novější).

Varování

Verze PHP pro Windows starší než 4.3.0 nepodporuje pro tuto funkci dálkový přístup k souborům, a to ani když je aktivní volba allow_url_fopen.

Předcházející | Nahoru | Další
imagecreatefromgd2 | Domů | imagecreatefromgd


imagecreatefromgd

(PHP 4 >= 4.0.7, PHP 5)

imagecreatefromgd — Create a new image from GD file or URL

Popis

resource imagecreatefromgd ( string $filename )

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Tip

S touto funkcí můžete používat URL jako název souboru, pokud je zapnuta volba "fopen wrappers". Pro více detailů o tom, jak specifikovat název souboru, a O – „List of Supported Protocols/Wrappers“pro seznam porporovaných URL protokolů, viz fopen().

Seznam parametrů

filename

Poznámky

Varování

Verze PHP pro Windows starší než 4.3.0 nepodporuje pro tuto funkci dálkový přístup k souborům, a to ani když je aktivní volba allow_url_fopen.

Předcházející | Nahoru | Další
imagecreatefromgd2part | Domů | imagecreatefromgif


imagecreatefromgif

(PHP 4, PHP 5)

imagecreatefromgif — Create a new image from file or URL

Popis

resource imagecreatefromgif ( string $filename )

imagecreatefromgif() returns an image identifier representing the image obtained from the given filename.

To ease debugging the following example will produce an error GIF:

Příklad 851. Example to handle an error during creation

<?php
function LoadGif ($imgname)
{
    $im = @imagecreatefromgif ($imgname); /* Attempt to open */
    if (!$im) { /* See if it failed */
        $im = imagecreatetruecolor (150, 30); /* Create a blank image */
        $bgc = imagecolorallocate ($im, 255, 255, 255);
        $tc = imagecolorallocate ($im, 0, 0, 0);
        imagefilledrectangle ($im, 0, 0, 150, 30, $bgc);
        /* Output an errmsg */
        imagestring ($im, 1, 5, 5, "Error loading $imgname", $tc);
    }
    return $im;
}
header("Content-Type: image/gif");
$img = LoadGif("bogus.image");
imagegif($img);
?>

Výše uvedený příklad vypíše něco jako:

Tip

S touto funkcí můžete používat URL jako název souboru, pokud je zapnuta volba "fopen wrappers". Pro více detailů o tom, jak specifikovat název souboru, a O – „List of Supported Protocols/Wrappers“pro seznam porporovaných URL protokolů, viz fopen().

Seznam parametrů

filename

Path to the GIF image

Návratové hodnoty

Returns an image resource identifier on success, FALSE on errors.

Poznámky

Poznámka: GIF support was removed from the GD library in Version 1.6, and added back in Version 2.0.28. This function is not available between these versions.

Varování

Verze PHP pro Windows starší než 4.3.0 nepodporuje pro tuto funkci dálkový přístup k souborům, a to ani když je aktivní volba allow_url_fopen.

Předcházející | Nahoru | Další
imagecreatefromgd | Domů | imagecreatefromjpeg


imagecreatefromjpeg

(PHP 4, PHP 5)

imagecreatefromjpeg — Create a new image from file or URL

Popis

resource imagecreatefromjpeg ( string $filename )

imagecreatefromjpeg() returns an image identifier representing the image obtained from the given filename.

On failure imagecreatefromjpeg() outputs an error message, which unfortunately displays as a broken link in a browser. To ease debugging the following example will produce an error JPEG:

Příklad 852. Example to handle an error during creation

<?php
function LoadJpeg($imgname)
{
    $im = @imagecreatefromjpeg($imgname); /* Attempt to open */
    if (!$im) { /* See if it failed */
        $im  = imagecreatetruecolor(150, 30); /* Create a black image */
        $bgc = imagecolorallocate($im, 255, 255, 255);
        $tc  = imagecolorallocate($im, 0, 0, 0);
        imagefilledrectangle($im, 0, 0, 150, 30, $bgc);
        /* Output an errmsg */
        imagestring($im, 1, 5, 5, "Error loading $imgname", $tc);
    }
    return $im;
}
header("Content-Type: image/jpeg");
$img = LoadJpeg("bogus.image");
imagejpeg($img);
?>

Výše uvedený příklad vypíše něco jako:

Tip

S touto funkcí můžete používat URL jako název souboru, pokud je zapnuta volba "fopen wrappers". Pro více detailů o tom, jak specifikovat název souboru, a O – „List of Supported Protocols/Wrappers“pro seznam porporovaných URL protokolů, viz fopen().

Seznam parametrů

filename

Path to the JPEG image

Návratové hodnoty

Returns an image resource identifier on success, FALSE on errors.

Poznámky

Poznámka: Podpora formátu JPEG je k dispozici jen v případě, že bylo PHP zkompilováno s GD-1.8 nebo novější.

Varování

Verze PHP pro Windows starší než 4.3.0 nepodporuje pro tuto funkci dálkový přístup k souborům, a to ani když je aktivní volba allow_url_fopen.

Předcházející | Nahoru | Další
imagecreatefromgif | Domů | imagecreatefrompng


imagecreatefrompng

(PHP 4, PHP 5)

imagecreatefrompng — Create a new image from file or URL

Popis

resource imagecreatefrompng ( string $filename )

imagecreatefrompng() returns an image identifier representing the image obtained from the given filename.

imagecreatefrompng() returns an empty string on failure. It also outputs an error message, which unfortunately displays as a broken link in a browser. To ease debugging the following example will produce an error PNG:

Příklad 853. Example to handle an error during creation

<?php
function LoadPNG($imgname)
{
    $im = @imagecreatefrompng($imgname); /* Attempt to open */
    if (!$im) { /* See if it failed */
        $im  = imagecreatetruecolor(150, 30); /* Create a blank image */
        $bgc = imagecolorallocate($im, 255, 255, 255);
        $tc  = imagecolorallocate($im, 0, 0, 0);
        imagefilledrectangle($im, 0, 0, 150, 30, $bgc);
        /* Output an errmsg */
        imagestring($im, 1, 5, 5, "Error loading $imgname", $tc);
    }
    return $im;
}
header("Content-Type: image/png");
$img = LoadPNG("bogus.image");
imagepng($img);
?>

Výše uvedený příklad vypíše něco jako:

Tip

S touto funkcí můžete používat URL jako název souboru, pokud je zapnuta volba "fopen wrappers". Pro více detailů o tom, jak specifikovat název souboru, a O – „List of Supported Protocols/Wrappers“pro seznam porporovaných URL protokolů, viz fopen().

Seznam parametrů

filename

Path to the PNG image

Návratové hodnoty

Returns an image resource identifier on success, FALSE on errors.

Poznámky

Varování

Verze PHP pro Windows starší než 4.3.0 nepodporuje pro tuto funkci dálkový přístup k souborům, a to ani když je aktivní volba allow_url_fopen.

Předcházející | Nahoru | Další
imagecreatefromjpeg | Domů | imagecreatefromstring


imagecreatefromstring

(PHP 4 >= 4.0.4, PHP 5)

imagecreatefromstring — Create a new image from the image stream in the string

Popis

resource imagecreatefromstring ( string $data )

imagecreatefromstring() returns an image identifier representing the image obtained from the given data These types will be automatically detected if your build of PHP supports them: JPEG, PNG, GIF, WBMP, and GD2.

Seznam parametrů

image

A string containing the image data

Návratové hodnoty

An image resource will be returned on success. FALSE is returned if the image type is unsupported, the data is not in a recognised format, or the image is corrupt and cannot be loaded.

Příklady

Příklad 854. imagecreatefromstring() example

<?php
$data = 'iVBORw0KGgoAAAANSUhEUgAAABwAAAASCAMAAAB/2U7WAAAABl'
       . 'BMVEUAAAD///+l2Z/dAAAASUlEQVR4XqWQUQoAIAxC2/0vXZDr'
       . 'EX4IJTRkb7lobNUStXsB0jIXIAMSsQnWlsV+wULF4Avk9fLq2r'
       . '8a5HSE35Q3eO2XP1A1wQkZSgETvDtKdQAAAABJRU5ErkJggg==';
$data = base64_decode($data);

$im = imagecreatefromstring($data);
if ($im !== false) {
    header('Content-Type: image/png');
    imagepng($im);
}
else {
    echo 'An error occurred.';
}
?>

Výše uvedený příklad vypíše něco jako:

Viz také

imagecreatefromjpeg()
imagecreatefrompng()
imagecreatefromgif()
imagecreatetruecolor()

Předcházející | Nahoru | Další
imagecreatefrompng | Domů | imagecreatefromwbmp


imagecreatefromwbmp

(PHP 4 >= 4.0.1, PHP 5)

imagecreatefromwbmp — Create a new image from file or URL

Popis

resource imagecreatefromwbmp ( string $filename )

imagecreatefromwbmp() returns an image identifier representing the image obtained from the given filename.

imagecreatefromwbmp() returns an empty string on failure. It also outputs an error message, which unfortunately displays as a broken link in a browser. To ease debugging the following example will produce an error WBMP:

Příklad 855. Example to handle an error during creation

<?php
function LoadWBMP($imgname)
{
    $im = @imagecreatefromwbmp($imgname); /* Attempt to open */
    if (!$im) { /* See if it failed */
        $im  = imagecreatetruecolor (20, 20); /* Create a blank image */
        $bgc = imagecolorallocate($im, 255, 255, 255);
        $tc  = imagecolorallocate($im, 0, 0, 0);
        imagefilledrectangle($im, 0, 0, 10, 10, $bgc);
        /* Output an errmsg */
        imagestring($im, 1, 5, 5, "Error loading $imgname", $tc);
    }
    return $im;
}
?>

Tip

S touto funkcí můžete používat URL jako název souboru, pokud je zapnuta volba "fopen wrappers". Pro více detailů o tom, jak specifikovat název souboru, a O – „List of Supported Protocols/Wrappers“pro seznam porporovaných URL protokolů, viz fopen().

Seznam parametrů

filename

Path to the WBMP image

Návratové hodnoty

Returns an image resource identifier on success, FALSE on errors.

Poznámky

Poznámka: Podpora formátu WBMP je k dispozici jen v případě, že bylo PHP zkompilováno s GD-1.8 nebo novější.

Varování

Verze PHP pro Windows starší než 4.3.0 nepodporuje pro tuto funkci dálkový přístup k souborům, a to ani když je aktivní volba allow_url_fopen.

Předcházející | Nahoru | Další
imagecreatefromstring | Domů | imagecreatefromxbm


imagecreatefromxbm

(PHP 4 >= 4.0.1, PHP 5)

imagecreatefromxbm — Create a new image from file or URL

Popis

resource imagecreatefromxbm ( string $filename )

imagecreatefromxbm() returns an image identifier representing the image obtained from the given filename.

Tip

S touto funkcí můžete používat URL jako název souboru, pokud je zapnuta volba "fopen wrappers". Pro více detailů o tom, jak specifikovat název souboru, a O – „List of Supported Protocols/Wrappers“pro seznam porporovaných URL protokolů, viz fopen().

Varování

Verze PHP pro Windows starší než 4.3.0 nepodporuje pro tuto funkci dálkový přístup k souborům, a to ani když je aktivní volba allow_url_fopen.

Seznam parametrů

filename

Path to the XBM image

Návratové hodnoty

Returns an image resource identifier on success, FALSE on errors.

Předcházející | Nahoru | Další
imagecreatefromwbmp | Domů | imagecreatefromxpm


imagecreatefromxpm

(PHP 4 >= 4.0.1, PHP 5)

imagecreatefromxpm — Create a new image from file or URL

Popis

resource imagecreatefromxpm ( string $filename )

imagecreatefromxpm() returns an image identifier representing the image obtained from the given filename.

Tip

S touto funkcí můžete používat URL jako název souboru, pokud je zapnuta volba "fopen wrappers". Pro více detailů o tom, jak specifikovat název souboru, a O – „List of Supported Protocols/Wrappers“pro seznam porporovaných URL protokolů, viz fopen().

Seznam parametrů

filename

Path to the XPM image

Návratové hodnoty

Returns an image resource identifier on success, FALSE on errors.

Návratové hodnoty

Poznámka: Tato funce je k dispozici jen tehdy, bylo-li PHP zkompilováno s přibalenou verzí knihovny GD.

Varování

Verze PHP pro Windows starší než 4.3.0 nepodporuje pro tuto funkci dálkový přístup k souborům, a to ani když je aktivní volba allow_url_fopen.

Předcházející | Nahoru | Další
imagecreatefromxbm | Domů | imagecreatetruecolor


imagecreatetruecolor

(PHP 4 >= 4.0.6, PHP 5)

imagecreatetruecolor — Create a new true color image

Popis

resource imagecreatetruecolor ( int $width, int $height )

imagecreatetruecolor() returns an image identifier representing a black image of the specified size.

Depending on your PHP and GD versions this function is defined or not. With PHP 4.0.6 through 4.1.x this function always exists if the GD module is loaded, but calling it without GD2 being installed PHP will issue a fatal error and exit. With PHP 4.2.x this behaviour is different in issuing a warning instead of an error. Other versions only define this function, if the correct GD version is installed.

Seznam parametrů

width

Image width

height

Image height

Návratové hodnoty

Returns an image resource identifier on success, FALSE on errors.

Příklady

Příklad 856. Creating a new GD image stream and outputting an image.

<?php
header ("Content-type: image/png");
$im = @imagecreatetruecolor(120, 20)
      or die("Cannot Initialize new GD image stream");
$text_color = imagecolorallocate($im, 233, 14, 91);
imagestring($im, 1, 5, 5,  "A Simple Text String", $text_color);
imagepng($im);
imagedestroy($im);
?>

Výše uvedený příklad vypíše něco jako:

Poznámky

Poznámka: Tato funkce vyžaduje GD 2.0.1 nebo novější (doporučena verze 2.0.28 nebo novější).

Poznámka: This function will not work with GIF file formats.

Viz také

imagedestroy()
imagecreate()

Předcházející | Nahoru | Další
imagecreatefromxpm | Domů | imagedashedline


imagedashedline

(PHP 4, PHP 5)

imagedashedline — Draw a dashed line

Popis

bool imagedashedline ( resource $image, int $x1, int $y1, int $x2, int $y2, int $color )

This function is deprecated. Use combination of imagesetstyle() and imageline() instead.

Předcházející | Nahoru | Další
imagecreatetruecolor | Domů | imagedestroy


imagedestroy

(PHP 4, PHP 5)

imagedestroy — Destroy an image

Popis

bool imagedestroy ( resource $image )

imagedestroy() frees any memory associated with image image.

Seznam parametrů

image

An image resource, returned by one of the image creation functions, such as imagecreatetruecolor().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
imagedashedline | Domů | imageellipse


imageellipse

(PHP 4 >= 4.0.6, PHP 5)

imageellipse — Draw an ellipse

Popis

bool imageellipse ( resource $image, int $cx, int $cy, int $width, int $height, int $color )

Draws an ellipse centered at the specified coordinates.

Seznam parametrů

image

An image resource, returned by one of the image creation functions, such as imagecreatetruecolor().

cx

x-coordinate of the center

cy

y-coordinate of the center

width

The ellipse width

height

The ellipse height

color

The color of the ellipse. A color identifier created with imagecolorallocate()

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 857. imageellipse() example

<?php

// create a blank image
$image = imagecreatetruecolor(400, 300);

// fill the background color
$bg = imagecolorallocate($image, 0, 0, 0);

// choose a color for the ellipse
$col_ellipse = imagecolorallocate($image, 255, 255, 255);

// draw the ellipse
imageellipse($image, 200, 150, 300, 200, $col_ellipse);

// output the picture
header("Content-type: image/png");
imagepng($image);

?>

Výše uvedený příklad vypíše něco jako:

Poznámky

Poznámka: This function requires GD 2.0.2 or later.

Viz také

imagefilledellipse()
imagearc()

Předcházející | Nahoru | Další
imagedestroy | Domů | imagefill


imagefill

(PHP 4, PHP 5)

imagefill — Flood fill

Popis

bool imagefill ( resource $image, int $x, int $y, int $color )

Performs a flood fill starting at the given coordinate (top left is 0, 0) with the given color in the image.

Seznam parametrů

image

An image resource, returned by one of the image creation functions, such as imagecreatetruecolor().

x

x-coordinate of start point

y

y-coordinate of start point

color

The fill color. A color identifier created with imagecolorallocate()

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 858. imagefill() example

<?php

$im = imagecreatetruecolor(100, 100);

// sets background to red
$red = imagecolorallocate($im, 255, 0, 0);
imagefill($im, 0, 0, $red);

header('Content-type: image/png');
imagepng($im);
imagedestroy($im);
?>

Výše uvedený příklad vypíše něco jako:

Viz také

imagecolorallocate()

Předcházející | Nahoru | Další
imageellipse | Domů | imagefilledarc


imagefilledarc

(PHP 4 >= 4.0.6, PHP 5)

imagefilledarc — Draw a partial ellipse and fill it

Popis

bool imagefilledarc ( resource $image, int $cx, int $cy, int $width, int $height, int $start, int $end, int $color, int $style )

Draws a partial ellipse centered at the specified coordinate in the given image.

Seznam parametrů

image

An image resource, returned by one of the image creation functions, such as imagecreatetruecolor().

cx

x-coordinate of the center

cy

y-coordinate of the center

width

The arc width

height

The arc height

start

The arc start angle, in degrees.

end

The arc end angle, in degrees. 0° is located at the three-o'clock position, and the arc is drawn clockwise.

color

A color identifier created with imagecolorallocate()

style

A bitwise OR of the following possibilities:

  1. IMG_ARC_PIE
  2. IMG_ARC_CHORD
  3. IMG_ARC_NOFILL
  4. IMG_ARC_EDGED

IMG_ARC_PIE and IMG_ARC_CHORD are mutually exclusive; IMG_ARC_CHORD just connects the starting and ending angles with a straight line, while IMG_ARC_PIE produces a rounded edge. IMG_ARC_NOFILL indicates that the arc or chord should be outlined, not filled. IMG_ARC_EDGED, used together with IMG_ARC_NOFILL, indicates that the beginning and ending angles should be connected to the center - this is a good way to outline (rather than fill) a 'pie slice'.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 859. Creating a 3D looking pie

<?php

// create image
$image = imagecreatetruecolor(100, 100);

// allocate some solors
$white    = imagecolorallocate($image, 0xFF, 0xFF, 0xFF);
$gray     = imagecolorallocate($image, 0xC0, 0xC0, 0xC0);
$darkgray = imagecolorallocate($image, 0x90, 0x90, 0x90);
$navy     = imagecolorallocate($image, 0x00, 0x00, 0x80);
$darknavy = imagecolorallocate($image, 0x00, 0x00, 0x50);
$red      = imagecolorallocate($image, 0xFF, 0x00, 0x00);
$darkred  = imagecolorallocate($image, 0x90, 0x00, 0x00);

// make the 3D effect
for ($i = 60; $i > 50; $i--) {
   imagefilledarc($image, 50, $i, 100, 50, 0, 45, $darknavy, IMG_ARC_PIE);
   imagefilledarc($image, 50, $i, 100, 50, 45, 75 , $darkgray, IMG_ARC_PIE);
   imagefilledarc($image, 50, $i, 100, 50, 75, 360 , $darkred, IMG_ARC_PIE);
}

imagefilledarc($image, 50, 50, 100, 50, 0, 45, $navy, IMG_ARC_PIE);
imagefilledarc($image, 50, 50, 100, 50, 45, 75 , $gray, IMG_ARC_PIE);
imagefilledarc($image, 50, 50, 100, 50, 75, 360 , $red, IMG_ARC_PIE);

// flush image
header('Content-type: image/png');
imagepng($image);
imagedestroy($image);
?>

Výše uvedený příklad vypíše něco jako:

Poznámky

Poznámka: Tato funkce vyžaduje GD 2.0.1 nebo novější (doporučena verze 2.0.28 nebo novější).

Předcházející | Nahoru | Další
imagefill | Domů | imagefilledellipse


imagefilledellipse

(PHP 4 >= 4.0.6, PHP 5)

imagefilledellipse — Draw a filled ellipse

Popis

bool imagefilledellipse ( resource $image, int $cx, int $cy, int $width, int $height, int $color )

Draws an ellipse centered at the specified coordinate on the given image.

Seznam parametrů

image

An image resource, returned by one of the image creation functions, such as imagecreatetruecolor().

cx

x-coordinate of the center

cy

y-coordinate of the center

width

The arc width

height

The arc height

color

The fill color. A color identifier created with imagecolorallocate()

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 860. imagefilledellipse() example

<?php

// create a blank image
$image = imagecreatetruecolor(400, 300);

// fill the background color
$bg = imagecolorallocate($image, 0, 0, 0);

// choose a color for the ellipse
$col_ellipse = imagecolorallocate($image, 255, 255, 255);

// draw the white ellipse
imagefilledellipse($image, 200, 150, 300, 200, $col_ellipse);

// output the picture
header("Content-type: image/png");
imagepng($image);

?>

Výše uvedený příklad vypíše něco jako:

Poznámky

Poznámka: Tato funkce vyžaduje GD 2.0.1 nebo novější (doporučena verze 2.0.28 nebo novější).

Viz také

imageellipse()
imagefilledarc()

Předcházející | Nahoru | Další
imagefilledarc | Domů | imagefilledpolygon


imagefilledpolygon

(PHP 4, PHP 5)

imagefilledpolygon — Draw a filled polygon

Popis

bool imagefilledpolygon ( resource $image, array $points, int $num_points, int $color )

imagefilledpolygon() creates a filled polygon in the given image.

Seznam parametrů

image

An image resource, returned by one of the image creation functions, such as imagecreatetruecolor().

points

An array containing the x and y coordinates of the polygons vertices consecutively

num_points

Total number of vertices, which must be bigger than 3

color

A color identifier created with imagecolorallocate()

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 861. imagefilledpolygon() example

<?php
// set up array of points for polygon
$values = array(
            40,  50,  // Point 1 (x, y)
            20,  240, // Point 2 (x, y)
            60,  60,  // Point 3 (x, y)
            240, 20,  // Point 4 (x, y)
            50,  40,  // Point 5 (x, y)
            10,  10   // Point 6 (x, y)
            );

// create image
$image = imagecreatetruecolor(250, 250);

// some colors
$bg   = imagecolorallocate($image, 200, 200, 200);
$blue = imagecolorallocate($image, 0, 0, 255);

// draw a polygon
imagefilledpolygon($image, $values, 6, $blue);

// flush image
header('Content-type: image/png');
imagepng($image);
imagedestroy($image);
?>

Výše uvedený příklad vypíše něco jako:

Předcházející | Nahoru | Další
imagefilledellipse | Domů | imagefilledrectangle


imagefilledrectangle

(PHP 4, PHP 5)

imagefilledrectangle — Draw a filled rectangle

Popis

bool imagefilledrectangle ( resource $image, int $x1, int $y1, int $x2, int $y2, int $color )

Creates a rectangle filled with color in the given image starting at point 1 and ending at point 2. 0, 0 is the top left corner of the image.

Seznam parametrů

image

An image resource, returned by one of the image creation functions, such as imagecreatetruecolor().

x1

x-coordinate for point 1

y1

y-coordinate for point 1

x2

x-coordinate for point 2

y2

y-coordinate for point 2

color

The fill color. A color identifier created with imagecolorallocate()

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
imagefilledpolygon | Domů | imagefilltoborder


imagefilltoborder

(PHP 4, PHP 5)

imagefilltoborder — Flood fill to specific color

Popis

bool imagefilltoborder ( resource $image, int $x, int $y, int $border, int $color )

imagefilltoborder() performs a flood fill whose border color is defined by border. The starting point for the fill is x, y (top left is 0, 0) and the region is filled with color color.

Seznam parametrů

image

An image resource, returned by one of the image creation functions, such as imagecreatetruecolor().

x

x-coordinate of start

y

y-coordinate of start

border

The border color. A color identifier created with imagecolorallocate()

color

The fill color. A color identifier created with imagecolorallocate()

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
imagefilledrectangle | Domů | imagefilter


imagefilter

(PHP 5)

imagefilter — Applies a filter to an image

Popis

bool imagefilter ( resource $image, int $filtertype [, int $arg1 [, int $arg2 [, int $arg3 [, int $arg4]]]] )

imagefilter() applies the given filter filtertype on the image.

Seznam parametrů

image

An image resource, returned by one of the image creation functions, such as imagecreatetruecolor().

filtertype

filtertype can be one of the following:

  • IMG_FILTER_NEGATE: Reverses all colors of the image.
  • IMG_FILTER_GRAYSCALE: Converts the image into grayscale.
  • IMG_FILTER_BRIGHTNESS: Changes the brightness of the image. Use arg1 to set the level of brightness.
  • IMG_FILTER_CONTRAST: Changes the contrast of the image. Use arg1 to set the level of contrast.
  • IMG_FILTER_COLORIZE: Like IMG_FILTER_GRAYSCALE, except you can specify the color. Use arg1, arg2 and arg3 in the form of red, blue, green and arg4 for the alpha channel. The range for each color is 0 to 255.
  • IMG_FILTER_EDGEDETECT: Uses edge detection to highlight the edges in the image.
  • IMG_FILTER_EMBOSS: Embosses the image.
  • IMG_FILTER_GAUSSIAN_BLUR: Blurs the image using the Gaussian method.
  • IMG_FILTER_SELECTIVE_BLUR: Blurs the image.
  • IMG_FILTER_MEAN_REMOVAL: Uses mean removal to achieve a "sketchy" effect.
  • IMG_FILTER_SMOOTH: Makes the image smoother. Use arg1 to set the level of smoothness.

arg1

arg2

arg3

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

ChangeLog (záznam změn)

Verze | Popis
5.2.5 | Alpha support for IMG_FILTER_COLORIZE was added.

Příklady

Příklad 862. imagefilter() grayscale example

<?php
$im = imagecreatefrompng('dave.png');
if ($im && imagefilter($im, IMG_FILTER_GRAYSCALE)) {
    echo 'Image converted to grayscale.';
    imagepng($im, 'dave.png');
} else {
    echo 'Conversion to grayscale failed.';
}

imagedestroy($im);
?>

Příklad 863. imagefilter() brightness example

<?php
$im = imagecreatefrompng('sean.png');
if ($im && imagefilter($im, IMG_FILTER_BRIGHTNESS, 20)) {
    echo 'Image brightness changed.';
    imagepng($im, 'sean.png');
} else {
    echo 'Image brightness change failed.';
}

imagedestroy($im);
?>

Příklad 864. imagefilter() colorize example

<?php
$im = imagecreatefrompng('philip.png');

/* R, G, B, so 0, 255, 0 is green */
if ($im && imagefilter($im, IMG_FILTER_COLORIZE, 0, 255, 0)) {
    echo 'Image successfully shaded green.';
    imagepng($im, 'philip.png');
} else {
    echo 'Green shading failed.';
}

imagedestroy($im);
?>

Poznámky

Poznámka: Tato funce je k dispozici jen tehdy, bylo-li PHP zkompilováno s přibalenou verzí knihovny GD.

Viz také

imageconvolution()

Předcházející | Nahoru | Další
imagefilltoborder | Domů | imagefontheight


imagefontheight

(PHP 4, PHP 5)

imagefontheight — Get font height

Popis

int imagefontheight ( int $font )

Returns the pixel height of a character in the specified font.

Seznam parametrů

font

Can be 1, 2, 3, 4, 5 for built-in fonts in latin2 encoding (where higher numbers corresponding to larger fonts) or any of your own font identifiers registered with imageloadfont().

Návratové hodnoty

Returns the height of the pixel.

Viz také

imagefontwidth()
imageloadfont()

Předcházející | Nahoru | Další
imagefilter | Domů | imagefontwidth


imagefontwidth

(PHP 4, PHP 5)

imagefontwidth — Get font width

Popis

int imagefontwidth ( int $font )

Returns the pixel width of a character in font.

Seznam parametrů

font

Can be 1, 2, 3, 4, 5 for built-in fonts in latin2 encoding (where higher numbers corresponding to larger fonts) or any of your own font identifiers registered with imageloadfont().

Návratové hodnoty

Returns the width of the pixel

Viz také

imagefontheight()
imageloadfont()

Předcházející | Nahoru | Další
imagefontheight | Domů | imageftbbox


imageftbbox

(PHP 4 >= 4.0.7, PHP 5)

imageftbbox — Give the bounding box of a text using fonts via freetype2

Popis

array imageftbbox ( float $size, float $angle, string $font_file, string $text [, array $extrainfo] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

size

angle

font_file

text

extrainfo

Návratové hodnoty

Poznámky

Poznámka: Tato funkce vyžaduje GD 2.0.1 nebo novější (doporučena verze 2.0.28 nebo novější).

Poznámka: This function is only available if PHP is compiled with freetype support (--with-freetype-dir=DIR)

ChangeLog (záznam změn)

Verze | Popis
4.3.5 | extrainfo was made optional.

Předcházející | Nahoru | Další
imagefontwidth | Domů | imagefttext


imagefttext

(PHP 4 >= 4.0.7, PHP 5)

imagefttext — Write text to the image using fonts using FreeType 2

Popis

array imagefttext ( resource $image, float $size, float $angle, int $x, int $y, int $color, string $font_file, string $text [, array $extrainfo] )

Seznam parametrů

image

An image resource, returned by one of the image creation functions, such as imagecreatetruecolor().

size

The font size to use in points

angle

The angle in degrees, with 0 degrees being left-to-right reading text. Higher values represent a counter-clockwise rotation. For example, a value of 90 would result in bottom-to-top reading text.

x

The coordinates given by x and y will define the basepoint of the first character (roughly the lower-left corner of the character). This is different from the imagestring(), where x and y define the upper-left corner of the first character. For example, "top left" is 0, 0.

y

The y-ordinate. This sets the position of the fonts baseline, not the very bottom of the character.

color

The index of the desired color for the text, see iamgecolorexact()

font_file

The full path to the font being used.

text

Text to be inserted into image.

extrainfo

Návratové hodnoty

This function returns an array defining the four points of the box, starting in the lower left and moving counter-clockwise:

0 | lower left x-coordinate
1 | lower left y-coordinate
2 | lower right x-coordinate
3 | lower right y-coordinate
4 | upper right x-coordinate
5 | upper right y-coordinate
6 | upper left x-coordinate
7 | upper left y-coordinate

Poznámky

Poznámka: Tato funkce vyžaduje GD 2.0.1 nebo novější (doporučena verze 2.0.28 nebo novější).

Poznámka: This function is only available if PHP is compiled with freetype support (--with-freetype-dir=DIR)

ChangeLog (záznam změn)

Verze | Popis
4.3.5 | extrainfo was made optional.

Předcházející | Nahoru | Další
imageftbbox | Domů | imagegammacorrect


imagegammacorrect

(PHP 4, PHP 5)

imagegammacorrect — Apply a gamma correction to a GD image

Popis

bool imagegammacorrect ( resource $image, float $inputgamma, float $outputgamma )

Applies gamma correction to the given gd image given an input and an output gamma.

Seznam parametrů

image

An image resource, returned by one of the image creation functions, such as imagecreatetruecolor().

inputgamma

The input gamma

outputgamma

The output gamma

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
imagefttext | Domů | imagegd2


imagegd2

(PHP 4 >= 4.0.7, PHP 5)

imagegd2 — Output GD2 image to browser or file

Popis

bool imagegd2 ( resource $image [, string $filename [, int $chunk_size [, int $type]]] )

Outputs a GD2 image to the given filename.

Seznam parametrů

image

An image resource, returned by one of the image creation functions, such as imagecreatetruecolor().

filename

The path to save the file to. If not set or NULL, the raw image stream will be outputted directly.

chunk_size

type

Either IMG_GD2_RAW or IMG_GD2_COMPRESSED. Default is IMG_GD2_RAW.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Poznámky

Poznámka: Tato funkce vyžaduje GD 2.0.1 nebo novější (doporučena verze 2.0.28 nebo novější).

Poznámka: The GD2 format is commonly used to allow fast loading of parts of images. Note that the GD2 format is only usable in GD2-compatible applications.

ChangeLog (záznam změn)

Verze | Popis
4.3.2 | chunk_size and type were added.

Viz také

imagegd()

Předcházející | Nahoru | Další
imagegammacorrect | Domů | imagegd


imagegd

(PHP 4 >= 4.0.7, PHP 5)

imagegd — Output GD image to browser or file

Popis

bool imagegd ( resource $image [, string $filename] )

Outputs a GD image to the given filename.

Seznam parametrů

image

An image resource, returned by one of the image creation functions, such as imagecreatetruecolor().

filename

The path to save the file to. If not set or NULL, the raw image stream will be outputted directly.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Poznámky

Poznámka: The GD format is commonly used to allow fast loading of parts of images. Note that the GD format is only usable in GD-compatible applications.

Viz také

imagegd2()

Předcházející | Nahoru | Další
imagegd2 | Domů | imagegif


imagegif

(PHP 4, PHP 5)

imagegif — Output image to browser or file

Popis

bool imagegif ( resource $image [, string $filename] )

imagegif() creates the GIF file in filename from the image image. The image argument is the return from the imagecreate() or imagecreatefrom* function.

The image format will be GIF87a unless the image has been made transparent with imagecolortransparent(), in which case the image format will be GIF89a.

Seznam parametrů

image

An image resource, returned by one of the image creation functions, such as imagecreatetruecolor().

filename

The path to save the file to. If not set or NULL, the raw image stream will be outputted directly.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Poznámky

Poznámka: Since all GIF support was removed from the GD library in version 1.6, this function is not available if you are using that version of the GD library. Support is expected to return in a version subsequent to the rerelease of GIF support in the GD library in mid 2004. For more information, see the » GD Project site.

The following code snippet allows you to write more portable PHP applications by auto-detecting the type of GD support which is available. Replace the sequence header ("Content-type: image/gif"); imagegif ($im); by the more flexible sequence:

<?php
if (function_exists("imagegif")) {
    header("Content-type: image/gif");
    imagegif($im);
} elseif (function_exists("imagejpeg")) {
    header("Content-type: image/jpeg");
    imagejpeg($im, "", 0.5);
} elseif (function_exists("imagepng")) {
    header("Content-type: image/png");
    imagepng($im);
} elseif (function_exists("imagewbmp")) {
    header("Content-type: image/vnd.wap.wbmp");
    imagewbmp($im);
} else {
    die("No image support in this PHP server");
}
?>

Poznámka: As of version 3.0.18 and 4.0.2 you can use the function imagetypes() in place of function_exists() for checking the presence of the various supported image formats:

<?php
if (imagetypes() & IMG_GIF) {
    header ("Content-type: image/gif");
    imagegif ($im);
} elseif (imagetypes() & IMG_JPG) {
    /* ... etc. */
}
?>

Viz také

imagepng()
imagewbmp()
imagejpeg()
imagetypes()

Předcházející | Nahoru | Další
imagegd | Domů | imagegrabscreen


imageinterlace

(PHP 4, PHP 5)

imageinterlace — Enable or disable interlace

Popis

int imageinterlace ( resource $image [, int $interlace] )

imageinterlace() turns the interlace bit on or off.

If the interlace bit is set and the image is used as a JPEG image, the image is created as a progressive JPEG.

Seznam parametrů

image

An image resource, returned by one of the image creation functions, such as imagecreatetruecolor().

interlace

If non-zero, the image will be interlaced, else the interlace bit is turned off.

Návratové hodnoty

Returns 1 if the interlace bit is set for the image, 0 otherwise.

Předcházející | Nahoru | Další
imagegrabwindow | Domů | imageistruecolor


imageistruecolor

(PHP 4 >= 4.3.2, PHP 5)

imageistruecolor — Finds whether an image is a truecolor image

Popis

bool imageistruecolor ( resource $image )

imageistruecolor() finds whether the image image is a truecolor image.

Seznam parametrů

image

An image resource, returned by one of the image creation functions, such as imagecreatetruecolor().

Návratové hodnoty

Returns TRUE if the image is truecolor, FALSE otherwise.

Poznámky

Poznámka: Tato funkce vyžaduje GD 2.0.1 nebo novější (doporučena verze 2.0.28 nebo novější).

Viz také

imagecreatetruecolor()

Předcházející | Nahoru | Další
imageinterlace | Domů | imagejpeg


imagejpeg

(PHP 4, PHP 5)

imagejpeg — Output image to browser or file

Popis

bool imagejpeg ( resource $image [, string $filename [, int $quality]] )

imagejpeg() creates a JPEG file from the given image.

Seznam parametrů

image

An image resource, returned by one of the image creation functions, such as imagecreatetruecolor().

filename

The path to save the file to. If not set or NULL, the raw image stream will be outputted directly.

To skip this argument in order to provide the quality parameter, use NULL.

quality

quality is optional, and ranges from 0 (worst quality, smaller file) to 100 (best quality, biggest file). The default is the default IJG quality value (about 75).

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Poznámky

Poznámka: Podpora formátu JPEG je k dispozici jen v případě, že bylo PHP zkompilováno s GD-1.8 nebo novější.

Poznámka: If you want to output Progressive JPEGs, you need to set interlacing on with imageinterlace().

Viz také

imagepng()
imagegif()
imagewbmp()
imageinterlace()
imagetypes()

Předcházející | Nahoru | Další
imageistruecolor | Domů | imagelayereffect


imagelayereffect

(PHP 4 >= 4.3.0, PHP 5)

imagelayereffect — Set the alpha blending flag to use the bundled libgd layering effects

Popis

bool imagelayereffect ( resource $image, int $effect )

Set the alpha blending flag to use the bundled libgd layering effects.

Seznam parametrů

image

An image resource, returned by one of the image creation functions, such as imagecreatetruecolor().

effect

One of the following constants:

IMG_EFFECT_REPLACE
Use pixel replacement (equivalent of passing TRUE to imagealphablending())
IMG_EFFECT_ALPHABLEND
Use normal pixel blending (equivalent of passing FALSE to imagealphablending())
IMG_EFFECT_NORMAL
Same as IMG_EFFECT_ALPHABLEND.
IMG_EFFECT_OVERLAY
Overlay has the effect that black background pixels will remain black, white background pixels will remain white, but grey background pixels will take the colour of the foreground pixel.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Poznámky

Poznámka: Tato funce je k dispozici jen tehdy, bylo-li PHP zkompilováno s přibalenou verzí knihovny GD.

Poznámka: Tato funkce vyžaduje GD 2.0.1 nebo novější (doporučena verze 2.0.28 nebo novější).

Předcházející | Nahoru | Další
imagejpeg | Domů | imageline


imageline

(PHP 4, PHP 5)

imageline — Draw a line

Popis

bool imageline ( resource $image, int $x1, int $y1, int $x2, int $y2, int $color )

imageline() draws a line between the two given points.

Seznam parametrů

image

An image resource, returned by one of the image creation functions, such as imagecreatetruecolor().

x1

x-coordinate for first point

y1

y-coordinate for first point

x2

x-coordinate for second point

y2

y-coordinate for second point

color

The line color. A color identifier created with imagecolorallocate()

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 867. Drawing a thick line

<?php

function imagelinethick($image, $x1, $y1, $x2, $y2, $color, $thick = 1)
{
    /* this way it works well only for orthogonal lines
    imagesetthickness($image, $thick);
    return imageline($image, $x1, $y1, $x2, $y2, $color);
    */
    if ($thick == 1) {
        return imageline($image, $x1, $y1, $x2, $y2, $color);
    }
    $t = $thick / 2 - 0.5;
    if ($x1 == $x2 || $y1 == $y2) {
        return imagefilledrectangle($image, round(min($x1, $x2) - $t), round(min($y1, $y2) - $t), round(max($x1, $x2) + $t), round(max($y1, $y2) + $t), $color);
    }
    $k = ($y2 - $y1) / ($x2 - $x1); //y = kx + q
    $a = $t / sqrt(1 + pow($k, 2));
    $points = array(
        round($x1 - (1+$k)*$a), round($y1 + (1-$k)*$a),
        round($x1 - (1-$k)*$a), round($y1 - (1+$k)*$a),
        round($x2 + (1+$k)*$a), round($y2 - (1-$k)*$a),
        round($x2 + (1-$k)*$a), round($y2 + (1+$k)*$a),
    );
    imagefilledpolygon($image, $points, 4, $color);
    return imagepolygon($image, $points, 4, $color);
}

?>

Viz také

imagecreatetruecolor()
imagecolorallocate()

Předcházející | Nahoru | Další
imagelayereffect | Domů | imageloadfont


imageloadfont

(PHP 4, PHP 5)

imageloadfont — Load a new font

Popis

int imageloadfont ( string $file )

imageloadfont() loads a user-defined bitmap and returns its identifier.

Seznam parametrů

file

The font file format is currently binary and architecture dependent. This means you should generate the font files on the same type of CPU as the machine you are running PHP on.

Tabulka 134. Font file format

byte position | C data type | description
byte 0-3 | int | number of characters in the font
byte 4-7 | int | value of first character in the font (often 32 for space)
byte 8-11 | int | pixel width of each character
byte 12-15 | int | pixel height of each character
byte 16- | char | array with character data, one byte per pixel in each character, for a total of (nchars*width*height) bytes.

Návratové hodnoty

The font identifier which is always bigger than 5 to avoid conflicts with built-in fonts or FALSE on errors.

Příklady

Příklad 868. Using imageloadfont

<?php
header("Content-type: image/png");
$im = imagecreatetruecolor(50, 20);
$black = imagecolorallocate($im, 0, 0, 0);
$white = imagecolorallocate($im, 255, 255, 255);
imagefilledrectangle($im, 0, 0, 49, 19, $white);
$font = imageloadfont("04b.gdf");
imagestring($im, $font, 0, 0, "Hello", $black);
imagepng($im);
?>

Viz také

imagefontwidth()
imagefontheight()

Předcházející | Nahoru | Další
imageline | Domů | imagepalettecopy


imagepalettecopy

(PHP 4 >= 4.0.1, PHP 5)

imagepalettecopy — Copy the palette from one image to another

Popis

void imagepalettecopy ( resource $destination, resource $source )

imagepalettecopy() copies the palette from the source image to the destination image.

Seznam parametrů

destination

The destination image resource

source

The source image resource

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
imageloadfont | Domů | imagepng


imagepng

(PHP 4, PHP 5)

imagepng — Output a PNG image to either the browser or a file

Popis

bool imagepng ( resource $image [, string $filename [, int $quality [, int $filters]]] )

Outputs or saves a PNG image from the given image.

Seznam parametrů

image

An image resource, returned by one of the image creation functions, such as imagecreatetruecolor().

filename

The path to save the file to. If not set or NULL, the raw image stream will be outputted directly.

Poznámka: NULL is invalid if the quality and filters arguments are not used.

quality

Compression level: from 0 (no compression) to 9.

filters

Allows reducing the PNG file size. It is a bitmask field which may be set to any combination of the PNG_FILTER_XXX constants. PNG_NO_FILTER or PNG_ALL_FILTERS may also be used to respectively disable or activate all filters.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

ChangeLog (záznam změn)

Verze | Popis
5.1.3 | Added the filters parameter.
5.1.2 | Added the quality parameter.

Příklady

<?php
$im = imagecreatefrompng("test.png");
imagepng($im);
?>

Viz také

imagegif()
imagewbmp()
imagejpeg()
imagetypes()

Předcházející | Nahoru | Další
imagepalettecopy | Domů | imagepolygon


imagepolygon

(PHP 4, PHP 5)

imagepolygon — Draws a polygon

Popis

bool imagepolygon ( resource $image, array $points, int $num_points, int $color )

imagepolygon() creates a polygon in the given image.

Seznam parametrů

image

An image resource, returned by one of the image creation functions, such as imagecreatetruecolor().

points

An array containing the polygon's vertices, i.e. points[0] = x0, points[1] = y0, points[2] = x1, points[3] = y1, etc.

num_points

Total number of points (vertices)

color

A color identifier created with imagecolorallocate()

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 869. imagepolygon() example

<?php
// create a blank image
$image = imagecreatetruecolor(400, 300);

// fill the background color
$bg = imagecolorallocate($image, 0, 0, 0);

// choose a color for the polygon
$col_poly = imagecolorallocate($image, 255, 255, 255);

// draw the polygon
imagepolygon($image, array (
        0,   0,
        100, 200,
        300, 200
    ),
    3,
    $col_poly);

// output the picture
header("Content-type: image/png");
imagepng($image);

?>

Výše uvedený příklad vypíše něco jako:

Viz také

imagecreate()
imagecreatetruecolor()

Předcházející | Nahoru | Další
imagepng | Domů | imagepsbbox


imagepsbbox

(PHP 4, PHP 5)

imagepsbbox — Give the bounding box of a text rectangle using PostScript Type1 fonts

Popis

array imagepsbbox ( string $text, int $font, int $size [, int $space, int $tightness, float $angle] )

Gives the bounding box of a text rectangle using PostScript Type1 fonts.

The bounding box is calculated using information available from character metrics, and unfortunately tends to differ slightly from the results achieved by actually rasterizing the text. If the angle is 0 degrees, you can expect the text to need 1 pixel more to every direction.

Seznam parametrů

text

font

Can be 1, 2, 3, 4, 5 for built-in fonts in latin2 encoding (where higher numbers corresponding to larger fonts) or any of your own font identifiers registered with imageloadfont().

size

size is expressed in pixels.

space

Allows you to change the default value of a space in a font. This amount is added to the normal value and can also be negative. Expressed in character space units, where 1 unit is 1/1000th of an em-square.

tightness

tightness allows you to control the amount of white space between characters. This amount is added to the normal character width and can also be negative. Expressed in character space units, where 1 unit is 1/1000th of an em-square.

angle

angle is in degrees.

Návratové hodnoty

Returns an array containing the following elements:

0 | left x-coordinate
1 | upper y-coordinate
2 | right x-coordinate
3 | lower y-coordinate

Poznámky

Poznámka: Tato funkce je k dispozici pouze v případě, že PHP bylo zkompilováno s přepínačem --enable-t1lib.

Viz také

imagepstext()

Předcházející | Nahoru | Další
imagepolygon | Domů | imagepsencodefont


imagepsencodefont

(PHP 4, PHP 5)

imagepsencodefont — Change the character encoding vector of a font

Popis

bool imagepsencodefont ( resource $font_index, string $encodingfile )

Loads a character encoding vector from a file and changes the fonts encoding vector to it. As a PostScript fonts default vector lacks most of the character positions above 127, you'll definitely want to change this if you use an other language than English.

If you find yourself using this function all the time, a much better way to define the encoding is to set ps.default_encoding in the configuration file to point to the right encoding file and all fonts you load will automatically have the right encoding.

Seznam parametrů

font_index

encodingfile

The exact format of this file is described in T1libs documentation. T1lib comes with two ready-to-use files, IsoLatin1.enc and IsoLatin2.enc.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Poznámky

Poznámka: Tato funkce je k dispozici pouze v případě, že PHP bylo zkompilováno s přepínačem --enable-t1lib.

Předcházející | Nahoru | Další
imagepsbbox | Domů | imagepsextendfont


imagepsextendfont

(PHP 4, PHP 5)

imagepsextendfont — Extend or condense a font

Popis

bool imagepsextendfont ( int $font_index, float $extend )

Extend or condense a font (font_index), if the value of the extend parameter is less than one you will be condensing the font.

Seznam parametrů

font_index

extend

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Poznámky

Poznámka: Tato funkce je k dispozici pouze v případě, že PHP bylo zkompilováno s přepínačem --enable-t1lib.

Předcházející | Nahoru | Další
imagepsencodefont | Domů | imagepsfreefont


imagepsfreefont

(PHP 4, PHP 5)

imagepsfreefont — Free memory used by a PostScript Type 1 font

Popis

bool imagepsfreefont ( resource $fontindex )

imagepsfreefont() frees memory used by a PostScript Type 1 font.

Seznam parametrů

fontindex

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Poznámky

Poznámka: Tato funkce je k dispozici pouze v případě, že PHP bylo zkompilováno s přepínačem --enable-t1lib.

Viz také

imagepsloadfont()

Předcházející | Nahoru | Další
imagepsextendfont | Domů | imagepsloadfont


imagepsloadfont

(PHP 4, PHP 5)

imagepsloadfont — Load a PostScript Type 1 font from file

Popis

resource imagepsloadfont ( string $filename )

Load a PostScript Type 1 font from the given filename.

Seznam parametrů

filename

Návratové hodnoty

In the case everything went right, a valid font index will be returned and can be used for further purposes. Otherwise the function returns FALSE.

Příklady

Příklad 870. imagepsloadfont() example

<?php
header("Content-type: image/png");
$im = imagecreatetruecolor(350, 45);
$black = imagecolorallocate($im, 0, 0, 0);
$white = imagecolorallocate($im, 255, 255, 255);
imagefilledrectangle($im, 0, 0, 349, 44, $white);
$font = imagepsloadfont("bchbi.pfb"); // or locate your .pfb files on your machine
imagepstext($im, "Testing... It worked!", $font, 32, $white, $black, 32, 32);
imagepsfreefont($font);
imagepng($im);
imagedestroy($im);
?>

Poznámky

Poznámka: Tato funkce je k dispozici pouze v případě, že PHP bylo zkompilováno s přepínačem --enable-t1lib.

Viz také

imagepsfreefont()

Předcházející | Nahoru | Další
imagepsfreefont | Domů | imagepsslantfont


imagepsslantfont

(PHP 4, PHP 5)

imagepsslantfont — Slant a font

Popis

bool imagepsslantfont ( resource $font_index, float $slant )

Slant a given font given.

Seznam parametrů

font_index

slant

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Poznámky

Poznámka: Tato funkce je k dispozici pouze v případě, že PHP bylo zkompilováno s přepínačem --enable-t1lib.

Předcházející | Nahoru | Další
imagepsloadfont | Domů | imagepstext


imagepstext

(PHP 4, PHP 5)

imagepstext — Draws a text over an image using PostScript Type1 fonts

Popis

array imagepstext ( resource $image, string $text, resource $font, int $size, int $foreground, int $background, int $x, int $y [, int $space [, int $tightness [, float $angle [, int $antialias_steps]]]] )

Draws a text on an image using PostScript Type1 fonts.

Refer to PostScript documentation about fonts and their measuring system if you have trouble understanding how this works.

Seznam parametrů

image

An image resource, returned by one of the image creation functions, such as imagecreatetruecolor().

text

The text to be written.

font

Can be 1, 2, 3, 4, 5 for built-in fonts in latin2 encoding (where higher numbers corresponding to larger fonts) or any of your own font identifiers registered with imageloadfont().

size

size is expressed in pixels.

foreground

The color in which the text will be painted.

background

The color to which the text will try to fade in with antialiasing. No pixels with the color background are actually painted, so the background image does not need to be of solid color.

x

x-coordinate for the lower-left corner of the first character

y

y-coordinate for the lower-left corner of the first character

space

Allows you to change the default value of a space in a font. This amount is added to the normal value and can also be negative. Expressed in character space units, where 1 unit is 1/1000th of an em-square.

tightness

tightness allows you to control the amount of white space between characters. This amount is added to the normal character width and can also be negative. Expressed in character space units, where 1 unit is 1/1000th of an em-square.

angle

angle is in degrees.

antialias_steps

Allows you to control the number of colours used for antialiasing text. Allowed values are 4 and 16. The higher value is recommended for text sizes lower than 20, where the effect in text quality is quite visible. With bigger sizes, use 4. It's less computationally intensive.

Návratové hodnoty

This function returns an array containing the following elements:

0 | lower left x-coordinate
1 | lower left y-coordinate
2 | upper right x-coordinate
3 | upper right y-coordinate

Poznámky

Poznámka: Tato funkce je k dispozici pouze v případě, že PHP bylo zkompilováno s přepínačem --enable-t1lib.

Viz také

imagepsbbox()

Předcházející | Nahoru | Další
imagepsslantfont | Domů | imagerectangle


imagerectangle

(PHP 4, PHP 5)

imagerectangle — Draw a rectangle

Popis

bool imagerectangle ( resource $image, int $x1, int $y1, int $x2, int $y2, int $color )

imagerectangle() creates a rectangle starting at the specified coordinates.

Seznam parametrů

image

An image resource, returned by one of the image creation functions, such as imagecreatetruecolor().

x1

Upper left x coordinate

y1

Upper left y coordinate 0, 0 is the top left corner of the image.

x2

Bottom right x coordinate

y2

Bottom right y coordinate

color

A color identifier created with imagecolorallocate()

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
imagepstext | Domů | imagerotate


imagerotate

(PHP 4 >= 4.3.0, PHP 5)

imagerotate — Rotate an image with a given angle

Popis

resource imagerotate ( resource $source_image, float $angle, int $bgd_color [, int $ignore_transparent] )

Rotates the source_image image using the given angle in degrees.

The center of rotation is the center of the image, and the rotated image is scaled down so that the whole rotated image fits in the destination image - the edges are not clipped.

Seznam parametrů

source_image

The source image link

angle

Rotation angle, in degrees.

bgd_color

Specifies the color of the uncovered zone after the rotation

ignore_transparent

If set and non-zero, transparent colors are ignored (otherwise kept).

Návratové hodnoty

ChangeLog (záznam změn)

Verze | Popis
5.1.0 | ignore_transparent was added.

Příklady

Příklad 871. Rotate an image 180 degrees

This example rotates an image 180 degrees - upside down.

<?php
// File and rotation
$filename = 'test.jpg';
$degrees = 180;

// Content type
header('Content-type: image/jpeg');

// Load
$source = imagecreatefromjpeg($filename);

// Rotate
$rotate = imagerotate($source, $degrees, 0);

// Output
imagejpeg($rotate);
?>

Výše uvedený příklad vypíše něco jako:

Poznámky

Poznámka: Tato funce je k dispozici jen tehdy, bylo-li PHP zkompilováno s přibalenou verzí knihovny GD.

Předcházející | Nahoru | Další
imagerectangle | Domů | imagesavealpha


imagesavealpha

(PHP 4 >= 4.3.2, PHP 5)

imagesavealpha — Set the flag to save full alpha channel information (as opposed to single-color transparency) when saving PNG images

Popis

bool imagesavealpha ( resource $image, bool $saveflag )

imagesavealpha() sets the flag to attempt to save full alpha channel information (as opposed to single-color transparency) when saving PNG images.

You have to unset alphablending (imagealphablending($im, false)), to use it.

Alpha channel is not supported by all browsers, if you have problem with your browser, try to load your script with an alpha channel compliant browser, e.g. latest Mozilla.

Seznam parametrů

image

An image resource, returned by one of the image creation functions, such as imagecreatetruecolor().

saveflag

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Poznámky

Poznámka: Tato funkce vyžaduje GD 2.0.1 nebo novější (doporučena verze 2.0.28 nebo novější).

Viz také

imagealphablending()

Předcházející | Nahoru | Další
imagerotate | Domů | imagesetbrush


imagesetbrush

(PHP 4 >= 4.0.6, PHP 5)

imagesetbrush — Set the brush image for line drawing

Popis

bool imagesetbrush ( resource $image, resource $brush )

imagesetbrush() sets the brush image to be used by all line drawing functions (such as imageline() and imagepolygon()) when drawing with the special colors IMG_COLOR_BRUSHED or IMG_COLOR_STYLEDBRUSHED.

Seznam parametrů

image

An image resource, returned by one of the image creation functions, such as imagecreatetruecolor().

brush

An image resource

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Poznámky

Poznámka: You need not take special action when you are finished with a brush, but if you destroy the brush image, you must not use the IMG_COLOR_BRUSHED or IMG_COLOR_STYLEDBRUSHED colors until you have set a new brush image!

Předcházející | Nahoru | Další
imagesavealpha | Domů | imagesetpixel


imagesetpixel

(PHP 4, PHP 5)

imagesetpixel — Set a single pixel

Popis

bool imagesetpixel ( resource $image, int $x, int $y, int $color )

imagesetpixel() draws a pixel at the specified coordinate.

Seznam parametrů

image

An image resource, returned by one of the image creation functions, such as imagecreatetruecolor().

x

x-coordinate

y

y-coordinate

color

A color identifier created with imagecolorallocate()

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 872. imagesetpixel() example

A random drawing that ends with a regular picture.

<?php

$x = 200;
$y = 200;

$gd = imagecreatetruecolor($x, $y);

$corners[0] = array('x' => 100, 'y' =>  10);
$corners[1] = array('x' =>   0, 'y' => 190);
$corners[2] = array('x' => 200, 'y' => 190);

$red = imagecolorallocate($gd, 255, 0, 0);

for ($i = 0; $i < 100000; $i++) {
  imagesetpixel($gd, round($x),round($y), $red);
  $a = rand(0, 2);
  $x = ($x + $corners[$a]['x']) / 2;
  $y = ($y + $corners[$a]['y']) / 2;
}

header('Content-Type: image/png');
imagepng($gd);

?>

Výše uvedený příklad vypíše něco jako:

Viz také

imagecreatetruecolor()
imagecolorallocate()

Předcházející | Nahoru | Další
imagesetbrush | Domů | imagesetstyle


imagesetstyle

(PHP 4 >= 4.0.6, PHP 5)

imagesetstyle — Set the style for line drawing

Popis

bool imagesetstyle ( resource $image, array $style )

imagesetstyle() sets the style to be used by all line drawing functions (such as imageline() and imagepolygon()) when drawing with the special color IMG_COLOR_STYLED or lines of images with color IMG_COLOR_STYLEDBRUSHED.

Seznam parametrů

image

An image resource, returned by one of the image creation functions, such as imagecreatetruecolor().

style

An array of pixel colors. You can use the IMG_COLOR_TRANSPARENT constant to add a transparent pixel.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Following example script draws a dashed line from upper left to lower right corner of the canvas:

Příklad 873. imagesetstyle() example

<?php
header("Content-type: image/jpeg");
$im  = imagecreatetruecolor(100, 100);
$w   = imagecolorallocate($im, 255, 255, 255);
$red = imagecolorallocate($im, 255, 0, 0);

/* Draw a dashed line, 5 red pixels, 5 white pixels */
$style = array($red, $red, $red, $red, $red, $w, $w, $w, $w, $w);
imagesetstyle($im, $style);
imageline($im, 0, 0, 100, 100, IMG_COLOR_STYLED);

/* Draw a line of happy faces using imagesetbrush() with imagesetstyle */
$style = array($w, $w, $w, $w, $w, $w, $w, $w, $w, $w, $w, $w, $red);
imagesetstyle($im, $style);

$brush = imagecreatefrompng("http://www.libpng.org/pub/png/images/smile.happy.png");
$w2 = imagecolorallocate($brush, 255, 255, 255);
imagecolortransparent($brush, $w2);
imagesetbrush($im, $brush);
imageline($im, 100, 0, 0, 100, IMG_COLOR_STYLEDBRUSHED);

imagejpeg($im);
imagedestroy($im);
?>

Výše uvedený příklad vypíše něco jako:

Viz také

imagesetbrush()
imageline()

Předcházející | Nahoru | Další
imagesetpixel | Domů | imagesetthickness


imagesetthickness

(PHP 4 >= 4.0.6, PHP 5)

imagesetthickness — Set the thickness for line drawing

Popis

bool imagesetthickness ( resource $image, int $thickness )

imagesetthickness() sets the thickness of the lines drawn when drawing rectangles, polygons, ellipses etc. etc. to thickness pixels.

Seznam parametrů

image

An image resource, returned by one of the image creation functions, such as imagecreatetruecolor().

thickness

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Poznámky

Poznámka: Tato funkce vyžaduje GD 2.0.1 nebo novější (doporučena verze 2.0.28 nebo novější).

Předcházející | Nahoru | Další
imagesetstyle | Domů | imagesettile


imagesettile

(PHP 4 >= 4.0.6, PHP 5)

imagesettile — Set the tile image for filling

Popis

bool imagesettile ( resource $image, resource $tile )

imagesettile() sets the tile image to be used by all region filling functions (such as imagefill() and imagefilledpolygon()) when filling with the special color IMG_COLOR_TILED.

A tile is an image used to fill an area with a repeated pattern. Any GD image can be used as a tile, and by setting the transparent color index of the tile image with imagecolortransparent(), a tile allows certain parts of the underlying area to shine through can be created.

Poznámka: You need not take special action when you are finished with a tile, but if you destroy the tile image, you must not use the IMG_COLOR_TILED color until you have set a new tile image!

Seznam parametrů

image

An image resource, returned by one of the image creation functions, such as imagecreatetruecolor().

tile

The image resource to be used as a tile

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
imagesetthickness | Domů | imagestring


imagestring

(PHP 4, PHP 5)

imagestring — Draw a string horizontally

Popis

bool imagestring ( resource $image, int $font, int $x, int $y, string $string, int $color )

Draws a string at the given coordinates.

Seznam parametrů

image

An image resource, returned by one of the image creation functions, such as imagecreatetruecolor().

font

Can be 1, 2, 3, 4, 5 for built-in fonts in latin2 encoding (where higher numbers corresponding to larger fonts) or any of your own font identifiers registered with imageloadfont().

x

x-coordinate of the upper left corner

y

y-coordinate of the upper left corner

string

The string to be written

color

A color identifier created with imagecolorallocate()

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 874. imagestring() example

<?php
// create a 100*30 image
$im = imagecreate(100, 30);

// white background and blue text
$bg = imagecolorallocate($im, 255, 255, 255);
$textcolor = imagecolorallocate($im, 0, 0, 255);

// write the string at the top left
imagestring($im, 5, 0, 0, "Hello world!", $textcolor);

// output the image
header("Content-type: image/png");
imagepng($im);
?>

Výše uvedený příklad vypíše něco jako:

Viz také

imageloadfont()
imagettftext()

Předcházející | Nahoru | Další
imagesettile | Domů | imagestringup


imagestringup

(PHP 4, PHP 5)

imagestringup — Draw a string vertically

Popis

bool imagestringup ( resource $image, int $font, int $x, int $y, string $string, int $color )

Draws a string vertically at the given coordinates.

Seznam parametrů

image

An image resource, returned by one of the image creation functions, such as imagecreatetruecolor().

font

Can be 1, 2, 3, 4, 5 for built-in fonts in latin2 encoding (where higher numbers corresponding to larger fonts) or any of your own font identifiers registered with imageloadfont().

x

x-coordinate of the upper left corner

y

y-coordinate of the upper left corner

sring

The string to be written

color

A color identifier created with imagecolorallocate()

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

imageloadfont()

Předcházející | Nahoru | Další
imagestring | Domů | imagesx


imagesx

(PHP 4, PHP 5)

imagesx — Get image width

Popis

int imagesx ( resource $image )

Returns the width of the given image resource.

Seznam parametrů

image

An image resource, returned by one of the image creation functions, such as imagecreatetruecolor().

Návratové hodnoty

Return the width of the image or FALSE on errors.

Příklady

Příklad 875. Using imagesx()

<?php

// create a 300*200 image
$img = imagecreatetruecolor(300, 200);

echo imagesx($img); // 300

?>

Viz také

imagecreatetruecolor()
getimagesize()
imagesy()

Předcházející | Nahoru | Další
imagestringup | Domů | imagesy


imagesy

(PHP 4, PHP 5)

imagesy — Get image height

Popis

int imagesy ( resource $image )

Returns the height of the given image resource.

Seznam parametrů

image

An image resource, returned by one of the image creation functions, such as imagecreatetruecolor().

Návratové hodnoty

Return the height of the image or FALSE on errors.

Příklady

Příklad 876. Using imagesy()

<?php

// create a 300*200 image
$img = imagecreatetruecolor(300, 200);

echo imagesy($img); // 200

?>

Viz také

imagecreatetruecolor()
getimagesize()
imagesx()

Předcházející | Nahoru | Další
imagesx | Domů | imagetruecolortopalette


imagetruecolortopalette

(PHP 4 >= 4.0.6, PHP 5)

imagetruecolortopalette — Convert a true color image to a palette image

Popis

bool imagetruecolortopalette ( resource $image, bool $dither, int $ncolors )

imagetruecolortopalette() converts a truecolor image to a palette image. The code for this function was originally drawn from the Independent JPEG Group library code, which is excellent. The code has been modified to preserve as much alpha channel information as possible in the resulting palette, in addition to preserving colors as well as possible. This does not work as well as might be hoped. It is usually best to simply produce a truecolor output image instead, which guarantees the highest output quality.

Seznam parametrů

image

An image resource, returned by one of the image creation functions, such as imagecreatetruecolor().

dither

Indicates if the image should be dithered - if it is TRUE then dithering will be used which will result in a more speckled image but with better color approximation.

ncolors

Sets the maximum number of colors that should be retained in the palette.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Poznámky

Poznámka: Tato funkce vyžaduje GD 2.0.1 nebo novější (doporučena verze 2.0.28 nebo novější).

Předcházející | Nahoru | Další
imagesy | Domů | imagettfbbox


imagettfbbox

(PHP 4, PHP 5)

imagettfbbox — Give the bounding box of a text using TrueType fonts

Popis

array imagettfbbox ( float $size, float $angle, string $fontfile, string $text )

This function calculates and returns the bounding box in pixels for a TrueType text.

Seznam parametrů

size

The font size in pixels

angle

Angle in degrees in which text will be measured

fontfile

The name of the TrueType font file (can be a URL). Depending on which version of the GD library that PHP is using, it may attempt to search for files that do not begin with a leading '/' by appending '.ttf' to the filename and searching along a library-defined font path

text

The string to be measured

Návratové hodnoty

imagettfbbox() returns an array with 8 elements representing four points making the bounding box of the text:

0 | lower left corner, X position
1 | lower left corner, Y position
2 | lower right corner, X position
3 | lower right corner, Y position
4 | upper right corner, X position
5 | upper right corner, Y position
6 | upper left corner, X position
7 | upper left corner, Y position

The points are relative to the text regardless of the angle, so "upper left" means in the top left-hand corner seeing the text horizontally.

Viz také

Poznámka: This function requires both the GD library and the » FreeType library.

Viz také

imagettftext()

Předcházející | Nahoru | Další
imagetruecolortopalette | Domů | imagettftext


imagettftext

(PHP 4, PHP 5)

imagettftext — Write text to the image using TrueType fonts

Popis

array imagettftext ( resource $image, float $size, float $angle, int $x, int $y, int $color, string $fontfile, string $text )

Writes the given text into the image using TrueType fonts.

Seznam parametrů

image

An image resource, returned by one of the image creation functions, such as imagecreatetruecolor().

size

The font size. Depending on your version of GD, this should be specified as the pixel size (GD1) or point size (GD2)

angle

The angle in degrees, with 0 degrees being left-to-right reading text. Higher values represent a counter-clockwise rotation. For example, a value of 90 would result in bottom-to-top reading text.

x

The coordinates given by x and y will define the basepoint of the first character (roughly the lower-left corner of the character). This is different from the imagestring(), where x and y define the upper-left corner of the first character. For example, "top left" is 0, 0.

y

The y-ordinate. This sets the position of the fonts baseline, not the very bottom of the character.

color

The color index. Using the negative of a color index has the effect of turning off antialiasing. See imagecolorallocate()

fontfile

The path to the TrueType font you wish to use.

Depending on which version of the GD library PHP is using, when fontfile does not begin with a leading / then .ttf will be appended to the filename and the library will attempt to search for that filename along a library-defined font path.

When using versions of the GD library lower than 2.0.18, a space character, rather than a semicolon, was used as the 'path separator' for different font files. Unintentional use of this feature will result in the warning message: Warning: Could not find/open font. For these affected versions, the only solution is moving the font to a path which does not contain spaces.

In many cases where a font resides in the same directory as the script using it the following trick will alleviate any include problems. <?php
// Set the enviroment variable for GD
putenv('GDFONTPATH=' . realpath('.'));
       The y-ordinate. This sets the position of the fonts baseline, not
       the very bottom of the character.
// Name the font to be used (note the lack of the .ttf extension)
$font = 'SomeFont';
?>

text

The text string in UTF-8 encoding.

May include decimal numeric character references (of the form: &#8364;) to access characters in a font beyond position 127. The hexadecimal format (like &#xA9;) is supported as of PHP 5.2.0. Strings in UTF-8 encoding can be passed directly.

Named entities, such as &copy;, are not supported. Consider using html_entity_decode() to decode these named entities into UTF-8 strings (html_entity_decode() supports this as of PHP 5.0.0).

If a character is used in the string which is not supported by the font, a hollow rectangle will replace the character.

Návratové hodnoty

Returns an array with 8 elements representing four points making the bounding box of the text. The order of the points is lower left, lower right, upper right, upper left. The points are relative to the text regardless of the angle, so "upper left" means in the top left-hand corner when you see the text horizontally.

Příklady

Příklad 877. imagettftext() example

This example script will produce a white PNG 400x30 pixels, with the words "Testing..." in black (with grey shadow), in the font Arial.

<?php
// Set the content-type
header("Content-type: image/png");

// Create the image
$im = imagecreatetruecolor(400, 30);

// Create some colors
$white = imagecolorallocate($im, 255, 255, 255);
$grey = imagecolorallocate($im, 128, 128, 128);
$black = imagecolorallocate($im, 0, 0, 0);
imagefilledrectangle($im, 0, 0, 399, 29, $white);

// The text to draw
$text = 'Testing...';
// Replace path by your own font path
$font = 'arial.ttf';

// Add some shadow to the text
imagettftext($im, 20, 0, 11, 21, $grey, $font, $text);

// Add the text
imagettftext($im, 20, 0, 10, 20, $black, $font, $text);

// Using imagepng() results in clearer text compared with imagejpeg()
imagepng($im);
imagedestroy($im);
?>

Výše uvedený příklad vypíše něco jako:

Poznámky

Poznámka: This function requires both the GD library and the » FreeType library.

Viz také

imagettfbbox()

Předcházející | Nahoru | Další
imagettfbbox | Domů | imagetypes


imagetypes

(PHP 4 >= 4.0.2, PHP 5)

imagetypes — Return the image types supported by this PHP build

Popis

int imagetypes ( void )

Returns the image types supported by the current PHP installation.

Návratové hodnoty

Returns a bit-field corresponding to the image formats supported by the version of GD linked into PHP. The following bits are returned, IMG_GIF | IMG_JPG | IMG_PNG | IMG_WBMP | IMG_XPM.

Příklady

Příklad 878. Checking for PNG support

<?php
if (imagetypes() & IMG_PNG) {
    echo "PNG Support is enabled";
}
?>

Předcházející | Nahoru | Další
imagettftext | Domů | imagewbmp


imagewbmp

(PHP 4 >= 4.0.1, PHP 5)

imagewbmp — Output image to browser or file

Popis

bool imagewbmp ( resource $image [, string $filename [, int $foreground]] )

imagewbmp() outputs or save a WBMP version of the given image.

Seznam parametrů

image

An image resource, returned by one of the image creation functions, such as imagecreatetruecolor().

filename

The path to save the file to. If not set or NULL, the raw image stream will be outputted directly.

foreground

You can set the foreground color with this parameter by setting an identifier obtained from imagecolorallocate(). The default foreground color is black.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Poznámky

Poznámka: WBMP support is only available if PHP was compiled against GD-1.8 or later.

Viz také

image2wbmp()
imagepng()
imagegif()
imagejpeg()
imagetypes()

Předcházející | Nahoru | Další
imagetypes | Domů | imagexbm


imagexbm

(PHP 5)

imagexbm — Output XBM image to browser or file

Popis

bool imagexbm ( resource $image, string $filename [, int $foreground] )

Outputs or save an XBM version of the given image.

Seznam parametrů

image

An image resource, returned by one of the image creation functions, such as imagecreatetruecolor().

filename

The path to save the file to. If not set or NULL, the raw image stream will be outputted directly.

foreground

You can set the foreground color with this parameter by setting an identifier obtained from imagecolorallocate(). The default foreground color is black.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Poznámky

Poznámka: Tato funce je k dispozici jen tehdy, bylo-li PHP zkompilováno s přibalenou verzí knihovny GD.

Předcházející | Nahoru | Další
imagewbmp | Domů | iptcembed


iptcembed

(PHP 4, PHP 5)

iptcembed — Embed binary IPTC data into a JPEG image

Popis

mixed iptcembed ( string $iptcdata, string $jpeg_file_name [, int $spool] )

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

iptcdata

jpeg_file_name

spool

Předcházející | Nahoru | Další
imagexbm | Domů | iptcparse


iptcparse

(PHP 4, PHP 5)

iptcparse — Parsuje binární IPTC » http://www.iptc.org/ blok do jednotlivých tagů.

Popis

array iptcparse ( string $iptcblock )

Tato funkce parsuje binární IPTC blok do jeho jednotlivých tagů. Vrací pole, které používá tagmarker jako index, a jeho hodnotu jako hodnotu. Vrací FALSE při chybě, nebo pokud nenajde žádná IPTC data. Příklad viz GetImageSize().

Předcházející | Nahoru | Další
iptcembed | Domů | jpeg2wbmp


jpeg2wbmp

(PHP 4 >= 4.0.5, PHP 5)

jpeg2wbmp — Convert JPEG image file to WBMP image file

Popis

bool jpeg2wbmp ( string $jpegname, string $wbmpname, int $dest_height, int $dest_width, int $threshold )

Converts a JPEG file into a WBMP file.

Seznam parametrů

jpegname

Path to JPEG file

wbmpname

Path to destination WBMP file

dest_height

Destination image height

dest_width

Destination image width

threshold

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Poznámky

Poznámka: Podpora formátu WBMP je k dispozici jen v případě, že bylo PHP zkompilováno s GD-1.8 nebo novější.

Poznámka: Podpora formátu JPEG je k dispozici jen v případě, že bylo PHP zkompilováno s GD-1.8 nebo novější.

Viz také

png2wbmp()

Předcházející | Nahoru | Další
iptcparse | Domů | png2wbmp


png2wbmp

(PHP 4 >= 4.0.5, PHP 5)

png2wbmp — Convert PNG image file to WBMP image file

Popis

bool png2wbmp ( string $pngname, string $wbmpname, int $dest_height, int $dest_width, int $threshold )

Converts a PNG file into a WBMP file.

Seznam parametrů

pngname

Path to PNG file

wbmpname

Path to destination WBMP file

dest_height

Destination image height

dest_width

Destination image width

threshold

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Poznámky

Poznámka: Podpora formátu WBMP je k dispozici jen v případě, že bylo PHP zkompilováno s GD-1.8 nebo novější.

Viz také

jpeg2wbmp()

Předcházející | Nahoru | Další
jpeg2wbmp | Domů | LXVI. Imagick Image Library


IMAP, POP3 and NNTP Functions

Předcházející VI. Reference funkcí Další

LXVII. IMAP, POP3 and NNTP Functions

Úvod

These functions enable you to operate with the IMAP protocol, as well as the NNTP, POP3 and local mailbox access methods.

Be warned however, that some of IMAP functions will not work correctly with the POP protocol.

Požadavky

This extension requires the c-client library to be installed. Grab the latest version from » ftp://ftp.cac.washington.edu/imap/ and compile it.

It's important that you do not copy the IMAP source files directly into the system include directory as there may be conflicts. Instead, create a new directory inside the system include directory, such as /usr/local/imap-2000b/ (location and name depend on your setup and IMAP version), and inside this new directory create additional directories named lib/ and include/. From the c-client directory from your IMAP source tree, copy all the *.h files into include/ and all the *.c files into lib/. Additionally when you compiled IMAP, a file named c-client.a was created. Also put this in the lib/ directory but rename it as libc-client.a.

Poznámka: To build the c-client library with SSL or/and Kerberos support read the docs supplied with the package.

Poznámka: In Mandrake Linux, the IMAP library (libc-client.a) is compiled without Kerberos support. A separate version with SSL (client-PHP4.a) is installed. The library must be recompiled in order to add Kerberos support.

Instalace

To get these functions to work, you have to compile PHP with --with-imap[=DIR], where DIR is the c-client install prefix. From our example above, you would use --with-imap=/usr/local/imap-2000b. This location depends on where you created this directory according to the description above. Windows users may include the php_imap.dll DLL in php.ini. IMAP is not supported on systems earlier that Windows 2000. This is because it uses encryption functions in order to enable SSL connections to the mail servers.

Poznámka: Depending how the c-client was configured, you might also need to add --with-imap-ssl=/path/to/openssl/ and/or --with-kerberos=/path/to/kerberos into the PHP configure line.

Varování

Rozšíření IMAP, recode, YAZ a Cyrus nelze používat současně, protože sdílejí stejný interní symbol.

Konfigurace běhu

Toto rozšíření nemá definováno žádné konfigurační direktivy.

Typy prostředků

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

NIL (integer)
OP_DEBUG (integer)
OP_READONLY (integer)
Open mailbox read-only
OP_ANONYMOUS (integer)
Don't use or update a .newsrc for news (NNTP only)
OP_SHORTCACHE (integer)
OP_SILENT (integer)
OP_PROTOTYPE (integer)
OP_HALFOPEN (integer)
For IMAP and NNTP names, open a connection but don't open a mailbox.
OP_EXPUNGE (integer)
OP_SECURE (integer)
CL_EXPUNGE (integer)
silently expunge the mailbox before closing when calling imap_close()
FT_UID (integer)
The parameter is a UID
FT_PEEK (integer)
Do not set the \Seen flag if not already set
FT_NOT (integer)
FT_INTERNAL (integer)
The return string is in internal format, will not canonicalize to CRLF.
FT_PREFETCHTEXT (integer)
ST_UID (integer)
The sequence argument contains UIDs instead of sequence numbers
ST_SILENT (integer)
ST_SET (integer)
CP_UID (integer)
the sequence numbers contain UIDS
CP_MOVE (integer)
Delete the messages from the current mailbox after copying with imap_mail_copy()
SE_UID (integer)
Return UIDs instead of sequence numbers
SE_FREE (integer)
SE_NOPREFETCH (integer)
Don't prefetch searched messages
SO_FREE (integer)
SO_NOSERVER (integer)
SA_MESSAGES (integer)
SA_RECENT (integer)
SA_UNSEEN (integer)
SA_UIDNEXT (integer)
SA_UIDVALIDITY (integer)
SA_ALL (integer)
LATT_NOINFERIORS (integer)
This mailbox has no "children" (there are no mailboxes below this one).
LATT_NOSELECT (integer)
This is only a container, not a mailbox - you cannot open it.
LATT_MARKED (integer)
This mailbox is marked. Only used by UW-IMAPD.
LATT_UNMARKED (integer)
This mailbox is not marked. Only used by UW-IMAPD.
SORTDATE (integer)
Sort criteria for imap_sort(): message Date
SORTARRIVAL (integer)
Sort criteria for imap_sort(): arrival date
SORTFROM (integer)
Sort criteria for imap_sort(): mailbox in first From address
SORTSUBJECT (integer)
Sort criteria for imap_sort(): message subject
SORTTO (integer)
Sort criteria for imap_sort(): mailbox in first To address
SORTCC (integer)
Sort criteria for imap_sort(): mailbox in first cc address
SORTSIZE (integer)
Sort criteria for imap_sort(): size of message in octets
TYPETEXT (integer)
TYPEMULTIPART (integer)
TYPEMESSAGE (integer)
TYPEAPPLICATION (integer)
TYPEAUDIO (integer)
TYPEIMAGE (integer)
TYPEVIDEO (integer)
TYPEOTHER (integer)
ENC7BIT (integer)
ENC8BIT (integer)
ENCBINARY (integer)
ENCBASE64 (integer)
ENCQUOTEDPRINTABLE (integer)
ENCOTHER (integer)
IMAP_OPENTIMEOUT (integer)
IMAP_READTIMEOUT (integer)
IMAP_WRITETIMEOUT (integer)
IMAP_CLOSETIMEOUT (integer)
LATT_REFERRAL (integer)
LATT_HASCHILDREN (integer)
LATT_HASNOCHILDREN (integer)
TYPEMODEL (integer)

Viz také

This document can't go into detail on all the topics touched by the provided functions. Further information is provided by the documentation of the c-client library source (docs/internal.txt). and the following RFC documents:

  • » RFC2821: Simple Mail Transfer Protocol (SMTP).
  • » RFC2822: Standard for ARPA internet text messages.
  • » RFC2060: Internet Message Access Protocol (IMAP) Version 4rev1.
  • » RFC1939: Post Office Protocol Version 3 (POP3).
  • » RFC977: Network News Transfer Protocol (NNTP).
  • » RFC2076: Common Internet Message Headers.
  • » RFC2045 , » RFC2046 , » RFC2047 , » RFC2048 & » RFC2049: Multipurpose Internet Mail Extensions (MIME).
A detailed overview is also available in the books » Programming Internet Email by David Wood and » Managing IMAP by Dianna Mullet & Kevin Mullet.

Obsah

imap_8bit — Convert an 8bit string to a quoted-printable string
imap_alerts — Returns all IMAP alert messages that have occurred
imap_append — Append a string message to a specified mailbox
imap_base64 — Decode BASE64 encoded text
imap_binary — Convert an 8bit string to a base64 string
imap_body — Read the message body
imap_bodystruct — Read the structure of a specified body section of a specific message
imap_check — Check current mailbox
imap_clearflag_full — Clears flags on messages
imap_close — Close an IMAP stream
imap_createmailbox — Create a new mailbox
imap_delete — Mark a message for deletion from current mailbox
imap_deletemailbox — Delete a mailbox
imap_errors — Returns all of the IMAP errors that have occured
imap_expunge — Delete all messages marked for deletion
imap_fetch_overview — Read an overview of the information in the headers of the given message
imap_fetchbody — Fetch a particular section of the body of the message
imap_fetchheader — Returns header for a message
imap_fetchstructure — Read the structure of a particular message
imap_get_quota — Retrieve the quota level settings, and usage statics per mailbox
imap_get_quotaroot — Retrieve the quota settings per user
imap_getacl — Gets the ACL for a given mailbox
imap_getmailboxes — Read the list of mailboxes, returning detailed information on each one
imap_getsubscribed — List all the subscribed mailboxes
imap_header — Alias pro imap_headerinfo()
imap_headerinfo — Read the header of the message
imap_headers — Returns headers for all messages in a mailbox
imap_last_error — Gets the last IMAP error that occurred during this page request
imap_list — Read the list of mailboxes
imap_listmailbox — Alias pro imap_list()
imap_listscan — Returns the list of mailboxes that matches the given text
imap_listsubscribed — Alias pro imap_lsub()
imap_lsub — List all the subscribed mailboxes
imap_mail_compose — Create a MIME message based on given envelope and body sections
imap_mail_copy — Copy specified messages to a mailbox
imap_mail_move — Move specified messages to a mailbox
imap_mail — Send an email message
imap_mailboxmsginfo — Get information about the current mailbox
imap_mime_header_decode — Decode MIME header elements
imap_msgno — Gets the message sequence number for the given UID
imap_num_msg — Gets the number of messages in the current mailbox
imap_num_recent — Gets the number of recent messages in current mailbox
imap_open — Open an IMAP stream to a mailbox
imap_ping — Check if the IMAP stream is still active
imap_qprint — Convert a quoted-printable string to an 8 bit string
imap_renamemailbox — Rename an old mailbox to new mailbox
imap_reopen — Reopen IMAP stream to new mailbox
imap_rfc822_parse_adrlist — Parses an address string
imap_rfc822_parse_headers — Parse mail headers from a string
imap_rfc822_write_address — Returns a properly formatted email address given the mailbox, host, and personal info
imap_savebody — Save a specific body section to a file
imap_scanmailbox — Alias pro imap_listscan()
imap_search — This function returns an array of messages matching the given search criteria
imap_set_quota — Sets a quota for a given mailbox
imap_setacl — Sets the ACL for a giving mailbox
imap_setflag_full — Sets flags on messages
imap_sort — Gets and sort messages
imap_status — Returns status information on a mailbox
imap_subscribe — Subscribe to a mailbox
imap_thread — Returns a tree of threaded message
imap_timeout — Set or fetch imap timeout
imap_uid — This function returns the UID for the given message sequence number
imap_undelete — Unmark the message which is marked deleted
imap_unsubscribe — Unsubscribe from a mailbox
imap_utf7_decode — Decodes a modified UTF-7 encoded string
imap_utf7_encode — Converts ISO-8859-1 string to modified UTF-7 text
imap_utf8 — Converts MIME-encoded text to UTF-8
Předcházející | Nahoru | Další
ImagickPixelIterator::syncIterator | Domů | imap_8bit


imap_8bit

(PHP 4, PHP 5)

imap_8bit — Convert an 8bit string to a quoted-printable string

Popis

string imap_8bit ( string $string )

Convert an 8bit string to a quoted-printable string (according to » RFC2045, section 6.7).

Seznam parametrů

string

The 8bit string to convert

Návratové hodnoty

Returns a quoted-printable string.

Viz také

imap_qprint()

Předcházející | Nahoru | Další
LXVII. IMAP, POP3 and NNTP Functions | Domů | imap_alerts


imap_alerts

(PHP 4, PHP 5)

imap_alerts — Returns all IMAP alert messages that have occurred

Popis

array imap_alerts ( void )

Returns all of the IMAP alert messages generated since the last imap_alerts() call, or the beginning of the page.

When imap_alerts() is called, the alert stack is subsequently cleared. The IMAP specification requires that these messages be passed to the user.

Návratové hodnoty

Returns an array of all of the IMAP alert messages generated or FALSE if no alert messages are available.

Viz také

imap_errors()

Předcházející | Nahoru | Další
imap_8bit | Domů | imap_append


imap_append

(PHP 4, PHP 5)

imap_append — Append a string message to a specified mailbox

Popis

bool imap_append ( resource $imap_stream, string $mailbox, string $message [, string $options] )

Appends a string message to the specified mailbox.

Seznam parametrů

imap_stream

An IMAP stream returned by imap_open().

mailbox

The mailbox name, see imap_open() for more information

message

The message to be append, as a string

When talking to the Cyrus IMAP server, you must use "\r\n" as your end-of-line terminator instead of "\n" or the operation will fail

options

If provided, the options will also be written to the mailbox

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 895. imap_append() example

<?php
$stream = imap_open("{imap.example.org}INBOX.Drafts", "username", "password");

$check = imap_check($stream);
echo "Msg Count before append: ". $check->Nmsgs . "\n";

imap_append($stream, "{imap.example.org}INBOX.Drafts"
                   , "From: me@example.com\r\n"
                   . "To: you@example.com\r\n"
                   . "Subject: test\r\n"
                   . "\r\n"
                   . "this is a test message, please ignore\r\n"
                   );

$check = imap_check($stream);
echo "Msg Count after append : ". $check->Nmsgs . "\n";

imap_close($stream);
?>

Předcházející | Nahoru | Další
imap_alerts | Domů | imap_base64


imap_base64

(PHP 4, PHP 5)

imap_base64 — Decode BASE64 encoded text

Popis

string imap_base64 ( string $text )

Decodes the given BASE-64 encoded text.

Seznam parametrů

text

The encoded text

Návratové hodnoty

Returns the decoded message as a string.

Viz také

imap_binary()
base64_encode()
base64_decode()
» RFC2045, Section 6.8

Předcházející | Nahoru | Další
imap_append | Domů | imap_binary


imap_binary

(PHP 4, PHP 5)

imap_binary — Convert an 8bit string to a base64 string

Popis

string imap_binary ( string $string )

Convert an 8bit string to a base64 string according to » RFC2045, Section 6.8.

Seznam parametrů

string

The 8bit string

Návratové hodnoty

Returns a base64 encoded string.

Viz také

imap_base64()

Předcházející | Nahoru | Další
imap_base64 | Domů | imap_body


imap_body

(PHP 4, PHP 5)

imap_body — Read the message body

Popis

string imap_body ( resource $imap_stream, int $msg_number [, int $options] )

imap_body() returns the body of the message, numbered msg_number in the current mailbox.

imap_body() will only return a verbatim copy of the message body. To extract single parts of a multipart MIME-encoded message you have to use imap_fetchstructure() to analyze its structure and imap_fetchbody() to extract a copy of a single body component.

Seznam parametrů

imap_stream

An IMAP stream returned by imap_open().

msg_number

The message number

options

The optional options are a bit mask with one or more of the following:

  • FT_UID - The msg_number is a UID
  • FT_PEEK - Do not set the \Seen flag if not already set
  • FT_INTERNAL - The return string is in internal format, will not canonicalize to CRLF.

Návratové hodnoty

Returns the body of the specified message, as a string.

Předcházející | Nahoru | Další
imap_binary | Domů | imap_bodystruct


imap_bodystruct

(PHP 4, PHP 5)

imap_bodystruct — Read the structure of a specified body section of a specific message

Popis

object imap_bodystruct ( resource $imap_stream, int $msg_number, string $section )

Read the structure of a specified body section of a specific message.

Seznam parametrů

imap_stream

An IMAP stream returned by imap_open().

msg_number

The message number

section

The body section to read

Návratové hodnoty

Returns the information in an object, for a detailed description of the object structure and properties see imap_fetchstructure().

Viz také

imap_fetchstructure()

Předcházející | Nahoru | Další
imap_body | Domů | imap_check


imap_check

(PHP 4, PHP 5)

imap_check — Check current mailbox

Popis

object imap_check ( resource $imap_stream )

Checks information about the current mailbox.

Seznam parametrů

imap_stream

An IMAP stream returned by imap_open().

Návratové hodnoty

Returns the information in an object with following properties:

  • Date - current system time formatted according to » RFC2822
  • Driver - protocol used to access this mailbox: POP3, IMAP, NNTP
  • Mailbox - the mailbox name
  • Nmsgs - number of messages in the mailbox
  • Recent - number of recent messages in the mailbox

Returns FALSE on failure.

Příklady

Příklad 896. imap_check() example

<?php

$imap_obj = imap_check($imap_stream);
var_dump($imap_obj);

?>

Výše uvedený příklad vypíše něco jako:

object(stdClass)(5) {
  ["Date"]=>
  string(37) "Wed, 10 Dec 2003 17:56:54 +0100 (CET)"
  ["Driver"]=>
  string(4) "imap"
  ["Mailbox"]=>
  string(54)
  "{www.example.com:143/imap/user="foo@example.com"}INBOX"
  ["Nmsgs"]=>
  int(1)
  ["Recent"]=>
  int(0)
}

Předcházející | Nahoru | Další
imap_bodystruct | Domů | imap_clearflag_full


imap_clearflag_full

(PHP 4, PHP 5)

imap_clearflag_full — Clears flags on messages

Popis

bool imap_clearflag_full ( resource $imap_stream, string $sequence, string $flag [, string $options] )

This function causes a store to delete the specified flag to the flags set for the messages in the specified sequence.

Seznam parametrů

imap_stream

An IMAP stream returned by imap_open().

sequence

A sequence of message numbers. You can enumerate desired messages with the X,Y syntax, or retrieve all messages within an interval with the X:Y syntax

flag

The flags which you can unset are "\\Seen", "\\Answered", "\\Flagged", "\\Deleted", and "\\Draft" (as defined by » RFC2060)

options

options are a bit mask and may contain the single option:

  • ST_UID - The sequence argument contains UIDs instead of sequence numbers

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

imap_setflag_full()

Předcházející | Nahoru | Další
imap_check | Domů | imap_close


imap_close

(PHP 4, PHP 5)

imap_close — Close an IMAP stream

Popis

bool imap_close ( resource $imap_stream [, int $flag] )

Closes the imap stream.

Seznam parametrů

imap_stream

An IMAP stream returned by imap_open().

flag

If set to CL_EXPUNGE, the function will silently expunge the mailbox before closing, removing all messages marked for deletion. You can achieve the same thing by using imap_expunge()

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

imap_open()

Předcházející | Nahoru | Další
imap_clearflag_full | Domů | imap_createmailbox


imap_createmailbox

(PHP 4, PHP 5)

imap_createmailbox — Create a new mailbox

Popis

bool imap_createmailbox ( resource $imap_stream, string $mailbox )

Creates a new mailbox specified by mailbox.

Seznam parametrů

imap_stream

An IMAP stream returned by imap_open().

mailbox

The mailbox name, see imap_open() for more information. Names containing international characters should be encoded by imap_utf7_encode()

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 897. imap_createmailbox() example

<?php
$mbox = imap_open("{imap.example.org}", "username", "password", OP_HALFOPEN)
     or die("can't connect: " . imap_last_error());

$name1 = "phpnewbox";
$name2 = imap_utf7_encode("phpnewb&ouml;x");

$newname = $name1;

echo "Newname will be '$name1'<br />\n";

// we will now create a new mailbox "phptestbox" in your inbox folder,
// check its status after creation and finaly remove it to restore
// your inbox to its initial state

if (@imap_createmailbox($mbox, imap_utf7_encode("{imap.example.org}INBOX.$newname"))) {
    $status = @imap_status($mbox, "{imap.example.org}INBOX.$newname", SA_ALL);
    if ($status) {
        echo "your new mailbox '$name1' has the following status:<br />\n";
        echo "Messages:   " . $status->messages    . "<br />\n";
        echo "Recent:     " . $status->recent      . "<br />\n";
        echo "Unseen:     " . $status->unseen      . "<br />\n";
        echo "UIDnext:    " . $status->uidnext     . "<br />\n";
        echo "UIDvalidity:" . $status->uidvalidity . "<br />\n";

        if (imap_renamemailbox($mbox, "{imap.example.org}INBOX.$newname", "{imap.example.org}INBOX.$name2")) {
            echo "renamed new mailbox from '$name1' to '$name2'<br />\n";
            $newname = $name2;
        } else {
            echo "imap_renamemailbox on new mailbox failed: " . imap_last_error() . "<br />\n";
        }
    } else {
        echo "imap_status on new mailbox failed: " . imap_last_error() . "<br />\n";
    }

    if (@imap_deletemailbox($mbox, "{imap.example.org}INBOX.$newname")) {
        echo "new mailbox removed to restore initial state<br />\n";
    } else {
        echo "imap_deletemailbox on new mailbox failed: " . implode("<br />\n", imap_errors()) . "<br />\n";
    }

} else {
    echo "could not create new mailbox: " . implode("<br />\n", imap_errors()) . "<br />\n";
}

imap_close($mbox);
?>

Viz také

imap_renamemailbox()
imap_deletemailbox()

Předcházející | Nahoru | Další
imap_close | Domů | imap_delete


imap_delete

(PHP 4, PHP 5)

imap_delete — Mark a message for deletion from current mailbox

Popis

bool imap_delete ( int $imap_stream, int $msg_number [, int $options] )

Marks messages listed in msg_number for deletion. Messages marked for deletion will stay in the mailbox until either imap_expunge() is called or imap_close() is called with the optional parameter CL_EXPUNGE.

Seznam parametrů

imap_stream

An IMAP stream returned by imap_open().

msg_number

The message number

options

You can set the FT_UID which tells the function to treat the msg_number argument as an UID.

Návratové hodnoty

Returns TRUE.

Příklady

Příklad 898. imap_delete() example

<?php

$mbox = imap_open("{imap.example.org}INBOX", "username", "password")
    or die("Can't connect: " . imap_last_error());

$check = imap_mailboxmsginfo($mbox);
echo "Messages before delete: " . $check->Nmsgs . "<br />\n";

imap_delete($mbox, 1);

$check = imap_mailboxmsginfo($mbox);
echo "Messages after  delete: " . $check->Nmsgs . "<br />\n";

imap_expunge($mbox);

$check = imap_mailboxmsginfo($mbox);
echo "Messages after expunge: " . $check->Nmsgs . "<br />\n";

imap_close($mbox);
?>

Poznámky

Poznámka: POP3 mailboxes do not have their message flags saved between connections, so imap_expunge() must be called during the same connection in order for messages marked for deletion to actually be purged.

Viz také

imap_undelete()
imap_expunge()
imap_close()

Předcházející | Nahoru | Další
imap_createmailbox | Domů | imap_deletemailbox


imap_deletemailbox

(PHP 4, PHP 5)

imap_deletemailbox — Delete a mailbox

Popis

bool imap_deletemailbox ( resource $imap_stream, string $mailbox )

Deletes the specified mailbox.

Seznam parametrů

imap_stream

An IMAP stream returned by imap_open().

mailbox

The mailbox name, see imap_open() for more information

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

imap_createmailbox()
imap_renamemailbox()
imap_open() for the format of mbox

Předcházející | Nahoru | Další
imap_delete | Domů | imap_errors


imap_errors

(PHP 4, PHP 5)

imap_errors — Returns all of the IMAP errors that have occured

Popis

array imap_errors ( void )

Gets all of the IMAP errors (if any) that have occurred during this page request or since the error stack was reset.

When imap_errors() is called, the error stack is subsequently cleared.

Návratové hodnoty

This function returns an array of all of the IMAP error messages generated since the last imap_errors() call, or the beginning of the page. Returns FALSE if no error messages are available.

Viz také

imap_last_error()
imap_alerts()

Předcházející | Nahoru | Další
imap_deletemailbox | Domů | imap_expunge


imap_expunge

(PHP 4, PHP 5)

imap_expunge — Delete all messages marked for deletion

Popis

bool imap_expunge ( resource $imap_stream )

Deletes all the messages marked for deletion by imap_delete(), imap_mail_move(), or imap_setflag_full().

Seznam parametrů

imap_stream

An IMAP stream returned by imap_open().

Návratové hodnoty

Returns TRUE.

Předcházející | Nahoru | Další
imap_errors | Domů | imap_fetch_overview


imap_fetch_overview

(PHP 4, PHP 5)

imap_fetch_overview — Read an overview of the information in the headers of the given message

Popis

array imap_fetch_overview ( resource $imap_stream, string $sequence [, int $options] )

This function fetches mail headers for the given sequence and returns an overview of their contents.

Seznam parametrů

imap_stream

An IMAP stream returned by imap_open().

sequence

A message sequence description. You can enumerate desired messages with the X,Y syntax, or retrieve all messages within an interval with the X:Y syntax

options

sequence will contain a sequence of message indices or UIDs, if this parameter is set to FT_UID.

Návratové hodnoty

Returns an array of objects describing one message header each. The object will only define a property if it exists. The possible properties are:

  • subject - the messages subject
  • from - who sent it
  • to - recipient
  • date - when was it sent
  • message_id - Message-ID
  • references - is a reference to this message id
  • in_reply_to - is a reply to this message id
  • size - size in bytes
  • uid - UID the message has in the mailbox
  • msgno - message sequence number in the mailbox
  • recent - this message is flagged as recent
  • flagged - this message is flagged
  • answered - this message is flagged as answered
  • deleted - this message is flagged for deletion
  • seen - this message is flagged as already read
  • draft - this message is flagged as being a draft

Příklady

Příklad 899. imap_fetch_overview() example

<?php
$mbox = imap_open("{imap.example.org:143}INBOX", "username", "password")
     or die("can't connect: " . imap_last_error());

$MC = imap_check($mbox);

// Fetch an overview for all messages in INBOX
$result = imap_fetch_overview($mbox,"1:{$MC->Nmsgs}",0);
foreach ($result as $overview) {
    echo "#{$overview->msgno} ({$overview->date}) - From: {$overview->from}
    {$overview->subject}\n";
}
imap_close($mbox);
?>

Viz také

imap_fetchheader()

Předcházející | Nahoru | Další
imap_expunge | Domů | imap_fetchbody


imap_fetchbody

(PHP 4, PHP 5)

imap_fetchbody — Fetch a particular section of the body of the message

Popis

string imap_fetchbody ( resource $imap_stream, int $msg_number, string $part_number [, int $options] )

Fetch of a particular section of the body of the specified messages. Body parts are not decoded by this function.

Seznam parametrů

imap_stream

An IMAP stream returned by imap_open().

msg_number

The message number

part_number

The part number. It is a string of integers delimited by period which index into a body part list as per the IMAP4 specification

options

A bitmask with one or more of the following:

  • FT_UID - The msg_number is a UID
  • FT_PEEK - Do not set the \Seen flag if not already set
  • FT_INTERNAL - The return string is in internal format, will not canonicalize to CRLF.

Návratové hodnoty

Returns a particular section of the body of the specified messages as a text string.

Viz také

imap_savebody()
imap_fetchstructure()

Předcházející | Nahoru | Další
imap_fetch_overview | Domů | imap_fetchheader


imap_fetchheader

(PHP 4, PHP 5)

imap_fetchheader — Returns header for a message

Popis

string imap_fetchheader ( resource $imap_stream, int $msg_number [, int $options] )

This function causes a fetch of the complete, unfiltered » RFC2822 format header of the specified message.

Seznam parametrů

imap_stream

An IMAP stream returned by imap_open().

msg_number

The message number

options

The possible options are:

  • FT_UID - The msgno argument is a UID
  • FT_INTERNAL - The return string is in "internal" format, without any attempt to canonicalize to CRLF newlines
  • FT_PREFETCHTEXT - The RFC822.TEXT should be pre-fetched at the same time. This avoids an extra RTT on an IMAP connection if a full message text is desired (e.g. in a "save to local file" operation)

Návratové hodnoty

Returns the header of the specified message as a text string.

Viz také

imap_fetch_overview()

Předcházející | Nahoru | Další
imap_fetchbody | Domů | imap_fetchstructure


imap_fetchstructure

(PHP 4, PHP 5)

imap_fetchstructure — Read the structure of a particular message

Popis

object imap_fetchstructure ( resource $imap_stream, int $msg_number [, int $options] )

Fetches all the structured information for a given message.

Seznam parametrů

imap_stream

An IMAP stream returned by imap_open().

msg_number

The message number

options

This optional parameter only has a single option, FT_UID, which tells the function to treat the msg_number argument as a UID.

Návratové hodnoty

Returns an object includes the envelope, internal date, size, flags and body structure along with a similar object for each mime attachment. The structure of the returned objects is as follows:

Tabulka 136. Returned Objects for imap_fetchstructure()

type | Primary body type
encoding | Body transfer encoding
ifsubtype | TRUE if there is a subtype string
subtype | MIME subtype
ifdescription | TRUE if there is a description string
description | Content description string
ifid | TRUE if there is an identification string
id | Identification string
lines | Number of lines
bytes | Number of bytes
ifdisposition | TRUE if there is a disposition string
disposition | Disposition string
ifdparameters | TRUE if the dparameters array exists
dparameters | An array of objects where each object has an "attribute" and a "value" property corresponding to the parameters on the Content-disposition MIMEheader.
ifparameters | TRUE if the parameters array exists
parameters | An array of objects where each object has an "attribute" and a "value" property.
parts | An array of objects identical in structure to the top-level object, each of which corresponds to a MIME body part.

Tabulka 137. Primary body type

0 | text
1 | multipart
2 | message
3 | application
4 | audio
5 | image
6 | video
7 | other

Tabulka 138. Transfer encodings

0 | 7BIT
1 | 8BIT
2 | BINARY
3 | BASE64
4 | QUOTED-PRINTABLE
5 | OTHER

Viz také

imap_fetchbody()
imap_bodystruct()

Předcházející | Nahoru | Další
imap_fetchheader | Domů | imap_get_quota


imap_get_quota

(PHP 4 >= 4.0.5, PHP 5)

imap_get_quota — Retrieve the quota level settings, and usage statics per mailbox

Popis

array imap_get_quota ( resource $imap_stream, string $quota_root )

Retrieve the quota level settings, and usage statics per mailbox.

For a non-admin user version of this function, please see the imap_get_quotaroot() function of PHP.

Seznam parametrů

imap_stream

An IMAP stream returned by imap_open().

quota_root

quota_root should normally be in the form of user.name where name is the mailbox you wish to retrieve information about.

Návratové hodnoty

Returns an array with integer values limit and usage for the given mailbox. The value of limit represents the total amount of space allowed for this mailbox. The usage value represents the mailboxes current level of capacity. Will return FALSE in the case of failure.

As of PHP 4.3, the function more properly reflects the functionality as dictated by the » RFC2087. The array return value has changed to support an unlimited number of returned resources (i.e. messages, or sub-folders) with each named resource receiving an individual array key. Each key value then contains an another array with the usage and limit values within it.

For backwards compatibility reasons, the original access methods are still available for use, although it is suggested to update.

Příklady

Příklad 900. imap_get_quota() example

<?php
$mbox = imap_open("{imap.example.org}", "mailadmin", "password", OP_HALFOPEN)
      or die("can't connect: " . imap_last_error());

$quota_value = imap_get_quota($mbox, "user.kalowsky");
if (is_array($quota_value)) {
    echo "Usage level is: " . $quota_value['usage'];
    echo "Limit level is: " . $quota_value['limit'];
}

imap_close($mbox);
?>

Příklad 901. imap_get_quota() 4.3 or greater example

<?php
$mbox = imap_open("{imap.example.org}", "mailadmin", "password", OP_HALFOPEN)
      or die("can't connect: " . imap_last_error());

$quota_values = imap_get_quota($mbox, "user.kalowsky");
if (is_array($quota_values)) {
   $storage = $quota_values['STORAGE'];
   echo "STORAGE usage level is: " .  $storage['usage'];
   echo "STORAGE limit level is: " .  $storage['limit'];

   $message = $quota_values['MESSAGE'];
   echo "MESSAGE usage level is: " .  $message['usage'];
   echo "MESSAGE limit is: " .  $message['limit'];

   /* ...  */
}

imap_close($mbox);
?>

Poznámky

This function is currently only available to users of the c-client2000 or greater library.

The given imap_stream must be opened as the mail administrator, other wise this function will fail.

Viz také

imap_open()
imap_set_quota()
imap_get_quotaroot()

Předcházející | Nahoru | Další
imap_fetchstructure | Domů | imap_get_quotaroot


imap_get_quotaroot

(PHP 4 >= 4.3.0, PHP 5)

imap_get_quotaroot — Retrieve the quota settings per user

Popis

array imap_get_quotaroot ( resource $imap_stream, string $quota_root )

Retrieve the quota settings per user. The limit value represents the total amount of space allowed for this user's total mailbox usage. The usage value represents the user's current total mailbox capacity.

Seznam parametrů

imap_stream

An IMAP stream returned by imap_open().

quota_root

quota_root should normally be in the form of which mailbox (i.e. INBOX).

Návratové hodnoty

Returns an array of integer values pertaining to the specified user mailbox. All values contain a key based upon the resource name, and a corresponding array with the usage and limit values within.

This function will return FALSE in the case of call failure, and an array of information about the connection upon an un-parsable response from the server.

Příklady

Příklad 902. imap_get_quotaroot() example

<?php
$mbox = imap_open("{imap.example.org}", "kalowsky", "password", OP_HALFOPEN)
      or die("can't connect: " . imap_last_error());

$quota = imap_get_quotaroot($mbox, "INBOX");
if (is_array($quota)) {
   $storage = $quota_values['STORAGE'];
   echo "STORAGE usage level is: " .  $storage['usage'];
   echo "STORAGE limit level is: " .  $storage['limit'];

   $message = $quota_values['MESSAGE'];
   echo "MESSAGE usage level is: " .  $message['usage'];
   echo "MESSAGE limit level is: " .  $message['limit'];

   /* ...  */

}

imap_close($mbox);
?>

Poznámky

This function is currently only available to users of the c-client2000 or greater library.

The imap_stream should be opened as the user whose mailbox you wish to check.

Viz také

imap_open()
imap_set_quota()
imap_get_quota()

Předcházející | Nahoru | Další
imap_get_quota | Domů | imap_getacl


imap_getacl

(PHP 5)

imap_getacl — Gets the ACL for a given mailbox

Popis

array imap_getacl ( resource $imap_stream, string $mailbox )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

imap_stream

An IMAP stream returned by imap_open().

mailbox

The mailbox name, see imap_open() for more information

Poznámky

This function is currently only available to users of the c-client2000 or greater library.

Viz také

imap_setacl()

Předcházející | Nahoru | Další
imap_get_quotaroot | Domů | imap_getmailboxes


imap_getmailboxes

(PHP 4, PHP 5)

imap_getmailboxes — Read the list of mailboxes, returning detailed information on each one

Popis

array imap_getmailboxes ( resource $imap_stream, string $ref, string $pattern )

Gets information on the mailboxes.

Seznam parametrů

imap_stream

An IMAP stream returned by imap_open().

ref

ref should normally be just the server specification as described in imap_open()

pattern

Specifies where in the mailbox hierarchy to start searching.

There are two special characters you can pass as part of the pattern: '*' and '%'. '*' means to return all mailboxes. If you pass pattern as '*', you will get a list of the entire mailbox hierarchy. '%' means to return the current level only. '%' as the pattern parameter will return only the top level mailboxes; '~/mail/%' on UW_IMAPD will return every mailbox in the ~/mail directory, but none in subfolders of that directory.

Návratové hodnoty

Returns an array of objects containing mailbox information. Each object has the attributes name, specifying the full name of the mailbox; delimiter, which is the hierarchy delimiter for the part of the hierarchy this mailbox is in; and attributes. Attributes is a bitmask that can be tested against:

  • LATT_NOINFERIORS - This mailbox has no "children" (there are no mailboxes below this one).
  • LATT_NOSELECT - This is only a container, not a mailbox - you cannot open it.
  • LATT_MARKED - This mailbox is marked. Only used by UW-IMAPD.
  • LATT_UNMARKED - This mailbox is not marked. Only used by UW-IMAPD.

Příklady

Příklad 903. imap_getmailboxes() example

<?php
$mbox = imap_open("{imap.example.org}", "username", "password", OP_HALFOPEN)
      or die("can't connect: " . imap_last_error());

$list = imap_getmailboxes($mbox, "{imap.example.org}", "*");
if (is_array($list)) {
    foreach ($list as $key => $val) {
        echo "($key) ";
        echo imap_utf7_decode($val->name) . ",";
        echo "'" . $val->delimiter . "',";
        echo $val->attributes . "<br />\n";
    }
} else {
    echo "imap_getmailboxes failed: " . imap_last_error() . "\n";
}

imap_close($mbox);
?>

Viz také

imap_getsubscribed()

Předcházející | Nahoru | Další
imap_getacl | Domů | imap_getsubscribed


imap_getsubscribed

(PHP 4, PHP 5)

imap_getsubscribed — List all the subscribed mailboxes

Popis

array imap_getsubscribed ( resource $imap_stream, string $ref, string $pattern )

Gets information on the subscribeds mailboxes.

Identical to imap_getmailboxes(), except that it only returns mailboxes that the user is subscribed to.

Seznam parametrů

imap_stream

An IMAP stream returned by imap_open().

ref

ref should normally be just the server specification as described in imap_open()

pattern

Specifies where in the mailbox hierarchy to start searching.

There are two special characters you can pass as part of the pattern: '*' and '%'. '*' means to return all mailboxes. If you pass pattern as '*', you will get a list of the entire mailbox hierarchy. '%' means to return the current level only. '%' as the pattern parameter will return only the top level mailboxes; '~/mail/%' on UW_IMAPD will return every mailbox in the ~/mail directory, but none in subfolders of that directory.

Návratové hodnoty

Returns an array of objects containing mailbox information. Each object has the attributes name, specifying the full name of the mailbox; delimiter, which is the hierarchy delimiter for the part of the hierarchy this mailbox is in; and attributes. Attributes is a bitmask that can be tested against:

  • LATT_NOINFERIORS - This mailbox has no "children" (there are no mailboxes below this one).
  • LATT_NOSELECT - This is only a container, not a mailbox - you cannot open it.
  • LATT_MARKED - This mailbox is marked. Only used by UW-IMAPD.
  • LATT_UNMARKED - This mailbox is not marked. Only used by UW-IMAPD.

Předcházející | Nahoru | Další
imap_getmailboxes | Domů | imap_header


imap_header

(PHP 4, PHP 5)

imap_header — Alias pro imap_headerinfo()

Popis

Tato funkce je aliasem: imap_headerinfo().

Předcházející | Nahoru | Další
imap_getsubscribed | Domů | imap_headerinfo


imap_headerinfo

(PHP 4, PHP 5)

imap_headerinfo — Read the header of the message

Popis

object imap_headerinfo ( resource $imap_stream, int $msg_number [, int $fromlength [, int $subjectlength [, string $defaulthost]]] )

Gets information about the given message number by reading its headers.

Seznam parametrů

imap_stream

An IMAP stream returned by imap_open().

msg_number

The message number

fromlength

Number of characters for the fetchfrom property. Must be greater than or equal to zero.

subjectlength

Number of characters for the fetchsubject property Must be greater than or equal to zero.

defaulthost

Návratové hodnoty

Returns the information in an object with following properties:

  • toaddress - full to: line, up to 1024 characters
  • to - an array of objects from the To: line, with the following properties: personal, adl, mailbox, and host
  • fromaddress - full from: line, up to 1024 characters
  • from - an array of objects from the From: line, with the following properties: personal, adl, mailbox, and host
  • ccaddress - full cc: line, up to 1024 characters
  • cc - an array of objects from the Cc: line, with the following properties: personal, adl, mailbox, and host
  • bccaddress - full bcc: line, up to 1024 characters
  • bcc - an array of objects from the Bcc: line, with the following properties: personal, adl, mailbox, and host
  • reply_toaddress - full Reply-To: line, up to 1024 characters
  • reply_to - an array of objects from the Reply-To: line, with the following properties: personal, adl, mailbox, and host
  • senderaddress - full sender: line, up to 1024 characters
  • sender - an array of objects from the Sender: line, with the following properties: personal, adl, mailbox, and host
  • return_pathaddress - full Return-Path: line, up to 1024 characters
  • return_path - an array of objects from the Return-Path: line, with the following properties: personal, adl, mailbox, and host
  • remail -
  • date - The message date as found in its headers
  • Date - Same as date
  • subject - The message subject
  • Subject - Same a subject
  • in_reply_to -
  • message_id -
  • newsgroups -
  • followup_to -
  • references -
  • Recent - R if recent and seen, N if recent and not seen, ' ' if not recent.
  • Unseen - U if not seen AND not recent, ' ' if seen OR not seen and recent
  • Flagged - F if flagged, ' ' if not flagged
  • Answered - A if answered, ' ' if unanswered
  • Deleted - D if deleted, ' ' if not deleted
  • Draft - X if draft, ' ' if not draft
  • Msgno - The message number
  • MailDate -
  • Size - The message size
  • udate - mail message date in Unix time
  • fetchfrom - from line formatted to fit fromlength characters
  • fetchsubject - subject line formatted to fit subjectlength characters

Viz také

imap_fetch_overview()

Předcházející | Nahoru | Další
imap_header | Domů | imap_headers


imap_headers

(PHP 4, PHP 5)

imap_headers — Returns headers for all messages in a mailbox

Popis

array imap_headers ( resource $imap_stream )

Returns headers for all messages in a mailbox.

Seznam parametrů

imap_stream

An IMAP stream returned by imap_open().

Návratové hodnoty

Returns an array of string formatted with header info. One element per mail message.

Předcházející | Nahoru | Další
imap_headerinfo | Domů | imap_last_error


imap_last_error

(PHP 4, PHP 5)

imap_last_error — Gets the last IMAP error that occurred during this page request

Popis

string imap_last_error ( void )

Gets the full text of the last IMAP error message that occurred on the current page. The error stack is untouched; calling imap_last_error() subsequently, with no intervening errors, will return the same error.

Návratové hodnoty

Returns the full text of the last IMAP error message that occurred on the current page. Returns FALSE if no error messages are available.

Viz také

imap_errors()

Předcházející | Nahoru | Další
imap_headers | Domů | imap_list


imap_list

(PHP 4, PHP 5)

imap_list — Read the list of mailboxes

Popis

array imap_list ( resource $imap_stream, string $ref, string $pattern )

Read the list of mailboxes.

Seznam parametrů

imap_stream

An IMAP stream returned by imap_open().

ref

ref should normally be just the server specification as described in imap_open().

pattern

Specifies where in the mailbox hierarchy to start searching.

There are two special characters you can pass as part of the pattern: '*' and '%'. '*' means to return all mailboxes. If you pass pattern as '*', you will get a list of the entire mailbox hierarchy. '%' means to return the current level only. '%' as the pattern parameter will return only the top level mailboxes; '~/mail/%' on UW_IMAPD will return every mailbox in the ~/mail directory, but none in subfolders of that directory.

Návratové hodnoty

Returns an array containing the names of the mailboxes.

Příklady

Příklad 904. imap_list() example

<?php
$mbox = imap_open("{imap.example.org}", "username", "password", OP_HALFOPEN)
      or die("can't connect: " . imap_last_error());

$list = imap_list($mbox, "{imap.example.org}", "*");
if (is_array($list)) {
    foreach ($list as $val) {
        echo imap_utf7_decode($val) . "\n";
    }
} else {
    echo "imap_list failed: " . imap_last_error() . "\n";
}

imap_close($mbox);
?>

Viz také

imap_getmailboxes()
imap_lsub()

Předcházející | Nahoru | Další
imap_last_error | Domů | imap_listmailbox


imap_listmailbox

(PHP 4, PHP 5)

imap_listmailbox — Alias pro imap_list()

Popis

Tato funkce je aliasem: imap_list().

Předcházející | Nahoru | Další
imap_list | Domů | imap_listscan


imap_listscan

(No version information available, might be only in CVS)

imap_listscan — Returns the list of mailboxes that matches the given text

Popis

array imap_listscan ( resource $imap_stream, string $ref, string $pattern, string $content )

Returns an array containing the names of the mailboxes that have content in the text of the mailbox.

This function is similar to imap_listmailbox(), but it will additionally check for the presence of the string content inside the mailbox data.

Seznam parametrů

imap_stream

An IMAP stream returned by imap_open().

ref

ref should normally be just the server specification as described in imap_open()

pattern

Specifies where in the mailbox hierarchy to start searching.

There are two special characters you can pass as part of the pattern: '*' and '%'. '*' means to return all mailboxes. If you pass pattern as '*', you will get a list of the entire mailbox hierarchy. '%' means to return the current level only. '%' as the pattern parameter will return only the top level mailboxes; '~/mail/%' on UW_IMAPD will return every mailbox in the ~/mail directory, but none in subfolders of that directory

content

The searched string

Návratové hodnoty

Returns an array containing the names of the mailboxes that have content in the text of the mailbox.

Viz také

imap_listmailbox()
imap_search()

Předcházející | Nahoru | Další
imap_listmailbox | Domů | imap_listsubscribed


imap_listsubscribed

(PHP 4, PHP 5)

imap_listsubscribed — Alias pro imap_lsub()

Popis

Tato funkce je aliasem: imap_lsub().

Předcházející | Nahoru | Další
imap_listscan | Domů | imap_lsub


imap_lsub

(PHP 4, PHP 5)

imap_lsub — List all the subscribed mailboxes

Popis

array imap_lsub ( resource $imap_stream, string $ref, string $pattern )

Gets an array of all the mailboxes that you have subscribed.

Seznam parametrů

imap_stream

An IMAP stream returned by imap_open().

ref

ref should normally be just the server specification as described in imap_open()

pattern

Specifies where in the mailbox hierarchy to start searching.

There are two special characters you can pass as part of the pattern: '*' and '%'. '*' means to return all mailboxes. If you pass pattern as '*', you will get a list of the entire mailbox hierarchy. '%' means to return the current level only. '%' as the pattern parameter will return only the top level mailboxes; '~/mail/%' on UW_IMAPD will return every mailbox in the ~/mail directory, but none in subfolders of that directory.

Návratové hodnoty

Returns an array of all the subscribed mailboxes.

Viz také

imap_list()
imap_getmailboxes()

Předcházející | Nahoru | Další
imap_listsubscribed | Domů | imap_mail_compose


imap_mail_compose

(PHP 4, PHP 5)

imap_mail_compose — Create a MIME message based on given envelope and body sections

Popis

string imap_mail_compose ( array $envelope, array $body )

Create a MIME message based on the given envelope and body sections.

Seznam parametrů

envelope

An associative array of headers fields

body

An indexed array of bodies

A body is an associative array which can consist of the following keys: "type", "encoding", "subtype", "description" and "contents.data"

Návratové hodnoty

Returns the MIME message.

Příklady

Příklad 905. imap_mail_compose() example

<?php

$envelope["from"]= "joe@example.com";
$envelope["to"]  = "foo@example.com";
$envelope["cc"]  = "bar@example.com";

$part1["type"] = TYPEMULTIPART;
$part1["subtype"] = "mixed";

$filename = "/tmp/imap.c.gz";
$fp = fopen($filename, "r");
$contents = fread($fp, filesize($filename));
fclose($fp);

$part2["type"] = TYPEAPPLICATION;
$part2["encoding"] = ENCBINARY;
$part2["subtype"] = "octet-stream";
$part2["description"] = basename($filename);
$part2["contents.data"] = $contents;

$part3["type"] = TYPETEXT;
$part3["subtype"] = "plain";
$part3["description"] = "description3";
$part3["contents.data"] = "contents.data3\n\n\n\t";

$body[1] = $part1;
$body[2] = $part2;
$body[3] = $part3;

echo nl2br(imap_mail_compose($envelope, $body));

?>

Předcházející | Nahoru | Další
imap_lsub | Domů | imap_mail_copy


imap_mail_copy

(PHP 4, PHP 5)

imap_mail_copy — Copy specified messages to a mailbox

Popis

bool imap_mail_copy ( resource $imap_stream, string $msglist, string $mailbox [, int $options] )

Copies mail messages specified by msglist to specified mailbox.

Seznam parametrů

imap_stream

An IMAP stream returned by imap_open().

msglist

msglist is a range not just message numbers (as described in » RFC2060).

mailbox

The mailbox name, see imap_open() for more information

options

options is a bitmask of one or more of

  • CP_UID - the sequence numbers contain UIDS
  • CP_MOVE - Delete the messages from the current mailbox after copying

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

imap_mail_move()

Předcházející | Nahoru | Další
imap_mail_compose | Domů | imap_mail_move


imap_mail_move

(PHP 4, PHP 5)

imap_mail_move — Move specified messages to a mailbox

Popis

bool imap_mail_move ( resource $imap_stream, string $msglist, string $mailbox [, int $options] )

Moves mail messages specified by msglist to the specified mailbox.

Seznam parametrů

imap_stream

An IMAP stream returned by imap_open().

msglist

msglist is a range not just message numbers (as described in » RFC2060).

mailbox

The mailbox name, see imap_open() for more information

options

options is a bitmask and may contain the single option:

  • CP_UID - the sequence numbers contain UIDS

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

imap_mail_copy()

Předcházející | Nahoru | Další
imap_mail_copy | Domů | imap_mail


imap_mail

(PHP 4, PHP 5)

imap_mail — Send an email message

Popis

bool imap_mail ( string $to, string $subject, string $message [, string $additional_headers [, string $cc [, string $bcc [, string $rpath]]]] )

This function allows sending of emails with correct handling of Cc and Bcc receivers.

The parameters to, cc and bcc are all strings and are all parsed as » RFC822 address lists.

Seznam parametrů

to

The receiver

subject

The mail subject

message

The mail body

additional_headers

As string with additional headers to be set on the mail

cc

bcc

The receivers specified in bcc will get the mail, but are excluded from the headers.

rpath

Use this parameter to specify return path upon mail delivery failure. This is useful when using PHP as a mail client for multiple users.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

mail()

Předcházející | Nahoru | Další
imap_mail_move | Domů | imap_mailboxmsginfo


imap_mailboxmsginfo

(PHP 4, PHP 5)

imap_mailboxmsginfo — Get information about the current mailbox

Popis

object imap_mailboxmsginfo ( resource $imap_stream )

Checks the current mailbox status on the server. It is similar to imap_status(), but will additionally sum up the size of all messages in the mailbox, which will take some additional time to execute.

Seznam parametrů

imap_stream

An IMAP stream returned by imap_open().

Návratové hodnoty

Returns the information in an object with following properties:

Tabulka 139. Mailbox properties

Date | date of last change
Driver | driver
Mailbox | name of the mailbox
Nmsgs | number of messages
Recent | number of recent messages
Unread | number of unread messages
Deleted | number of deleted messages
Size | mailbox size

Returns FALSE on failure.

Příklady

Příklad 906. imap_mailboxmsginfo() example

<?php

$mbox = imap_open("{imap.example.org}INBOX", "username", "password")
      or die("can't connect: " . imap_last_error());

$check = imap_mailboxmsginfo($mbox);

if ($check) {
    echo "Date: "     . $check->Date    . "<br />\n" ;
    echo "Driver: "   . $check->Driver  . "<br />\n" ;
    echo "Mailbox: "  . $check->Mailbox . "<br />\n" ;
    echo "Messages: " . $check->Nmsgs   . "<br />\n" ;
    echo "Recent: "   . $check->Recent  . "<br />\n" ;
    echo "Unread: "   . $check->Unread  . "<br />\n" ;
    echo "Deleted: "  . $check->Deleted . "<br />\n" ;
    echo "Size: "     . $check->Size    . "<br />\n" ;
} else {
    echo "imap_check() failed: " . imap_last_error() . "<br />\n";
}

imap_close($mbox);

?>

Předcházející | Nahoru | Další
imap_mail | Domů | imap_mime_header_decode


imap_mime_header_decode

(PHP 4, PHP 5)

imap_mime_header_decode — Decode MIME header elements

Popis

array imap_mime_header_decode ( string $text )

Decodes MIME message header extensions that are non ASCII text (see » RFC2047).

Seznam parametrů

text

The MIME text

Návratové hodnoty

The decoded elements are returned in an array of objects, where each object has two properties, charset and text.

If the element hasn't been encoded, and in other words is in plain US-ASCII, the charset property of that element is set to default.

Příklady

Příklad 907. imap_mime_header_decode() example

<?php
$text = "=?ISO-8859-1?Q?Keld_J=F8rn_Simonsen?= <keld@example.com>";

$elements = imap_mime_header_decode($text);
for ($i=0; $i<count($elements); $i++) {
    echo "Charset: {$elements[$i]->charset}\n";
    echo "Text: {$elements[$i]->text}\n\n";
}
?>

Výše uvedený příklad vypíše:

Charset: ISO-8859-1
Text: Keld J?rn Simonsen

Charset: default
Text:  <keld@example.com>

In the above example we would have two elements, whereas the first element had previously been encoded with ISO-8859-1, and the second element would be plain US-ASCII.

Viz také

imap_utf8()

Předcházející | Nahoru | Další
imap_mailboxmsginfo | Domů | imap_msgno


imap_msgno

(PHP 4, PHP 5)

imap_msgno — Gets the message sequence number for the given UID

Popis

int imap_msgno ( resource $imap_stream, int $uid )

Returns the message sequence number for the given uid.

This function is the inverse of imap_uid().

Seznam parametrů

imap_stream

An IMAP stream returned by imap_open().

uid

The message UID

Návratové hodnoty

Returns the message sequence number for the given uid.

Viz také

imap_uid()

Předcházející | Nahoru | Další
imap_mime_header_decode | Domů | imap_num_msg


imap_num_msg

(PHP 4, PHP 5)

imap_num_msg — Gets the number of messages in the current mailbox

Popis

int imap_num_msg ( resource $imap_stream )

Gets the number of messages in the current mailbox.

Seznam parametrů

imap_stream

An IMAP stream returned by imap_open().

Návratové hodnoty

Return the number of messages in the current mailbox, as an integer.

Viz také

imap_num_recent()
imap_status()

Předcházející | Nahoru | Další
imap_msgno | Domů | imap_num_recent


imap_num_recent

(PHP 4, PHP 5)

imap_num_recent — Gets the number of recent messages in current mailbox

Popis

int imap_num_recent ( resource $imap_stream )

Gets the number of recent messages in the current mailbox.

Seznam parametrů

imap_stream

An IMAP stream returned by imap_open().

Návratové hodnoty

Returns the number of recent messages in the current mailbox, as an integer.

Viz také

imap_num_msg()
imap_status()

Předcházející | Nahoru | Další
imap_num_msg | Domů | imap_open


imap_open

(PHP 4, PHP 5)

imap_open — Open an IMAP stream to a mailbox

Popis

resource imap_open ( string $mailbox, string $username, string $password [, int $options [, int $n_retries]] )

Opens an IMAP stream to a mailbox.

This function can also be used to open streams to POP3 and NNTP servers, but some functions and features are only available on IMAP servers.

Seznam parametrů

mailbox

A mailbox name consists of a server and a mailbox path on this server. The special name INBOX stands for the current users personal mailbox. Mailbox names that contain international characters besides those in the printable ASCII space have to be encoded width imap_utf7_encode().

The server part, which is enclosed in '{' and '}', consists of the servers name or ip address, an optional port (prefixed by ':'), and an optional protocol specification (prefixed by '/').

The server part is mandatory in all mailbox parameters.

All names which start with { are remote names, and are in the form "{" remote_system_name [":" port] [flags] "}" [mailbox_name] where:

  • remote_system_name - Internet domain name or bracketed IP address of server.
  • port - optional TCP port number, default is the default port for that service
  • flags - optional flags, see following table.
  • mailbox_name - remote mailbox name, default is INBOX

Tabulka 140. Optional flags for names

Flag | Description
/service=service | mailbox access service, default is "imap"
/user=user | remote user name for login on the server
/authuser=user | remote authentication user; if specified this is the user name whose password is used (e.g. administrator)
/anonymous | remote access as anonymous user
/debug | record protocol telemetry in application's debug log
/secure | do not transmit a plaintext password over the network
/imap, /imap2, /imap2bis, /imap4, /imap4rev1 | equivalent to /service=imap
/pop3 | equivalent to /service=pop3
/nntp | equivalent to /service=nntp
/norsh | do not use rsh or ssh to establish a preauthenticated IMAP session
/ssl | use the Secure Socket Layer to encrypt the session
/validate-cert | validate certificates from TLS/SSL server (this is the default behavior)
/novalidate-cert | do not validate certificates from TLS/SSL server, needed if server uses self-signed certificates
/tls | force use of start-TLS to encrypt the session, and reject connection to servers that do not support it
/notls | do not do start-TLS to encrypt the session, even with servers that support it
/readonly | request read-only mailbox open (IMAP only; ignored on NNTP, and an error with SMTP and POP3)

username

The user name

password

The password associated with the username

options

The options are a bit mask with one or more of the following:

  • OP_READONLY - Open mailbox read-only
  • OP_ANONYMOUS - Don't use or update a .newsrc for news (NNTP only)
  • OP_HALFOPEN - For IMAP and NNTP names, open a connection but don't open a mailbox.
  • CL_EXPUNGE - Expunge mailbox automatically upon mailbox close (see also imap_delete() and imap_expunge())
  • OP_DEBUG - Debug protocol negotiations
  • OP_SHORTCACHE - Short (elt-only) caching
  • OP_SILENT - Don't pass up events (internal use)
  • OP_PROTOTYPE - Return driver prototype
  • OP_SECURE - Don't do non-secure authentication

n_retries

Number of maximum connect attempts

Návratové hodnoty

Returns an IMAP stream on success or FALSE on error.

ChangeLog (záznam změn)

Verze | Popis
5.2.0 | n_retries added

Příklady

Příklad 908. Different use of imap_open()

<?php
// To connect to an IMAP server running on port 143 on the local machine,
// do the following:
$mbox = imap_open("{localhost:143}INBOX", "user_id", "password");

// To connect to a POP3 server on port 110 on the local server, use:
$mbox = imap_open ("{localhost:110/pop3}INBOX", "user_id", "password");

// To connect to an SSL IMAP or POP3 server, add /ssl after the protocol
// specification:
$mbox = imap_open ("{localhost:993/imap/ssl}INBOX", "user_id", "password");

// To connect to an SSL IMAP or POP3 server with a self-signed certificate,
// add /ssl/novalidate-cert after the protocol specification:
$mbox = imap_open ("{localhost:995/pop3/ssl/novalidate-cert}", "user_id", "password");

// To connect to an NNTP server on port 119 on the local server, use:
$nntp = imap_open ("{localhost:119/nntp}comp.test", "", "");
// To connect to a remote server replace "localhost" with the name or the
// IP address of the server you want to connect to.
?>

Příklad 909. imap_open() example

<?php
$mbox = imap_open("{imap.example.org:143}", "username", "password");

echo "<h1>Mailboxes</h1>\n";
$folders = imap_listmailbox($mbox, "{imap.example.org:143}", "*");

if ($folders == false) {
    echo "Call failed<br />\n";
} else {
    foreach ($folders as $val) {
        echo $val . "<br />\n";
    }
}

echo "<h1>Headers in INBOX</h1>\n";
$headers = imap_headers($mbox);

if ($headers == false) {
    echo "Call failed<br />\n";
} else {
    foreach ($headers as $val) {
        echo $val . "<br />\n";
    }
}

imap_close($mbox);
?>

Viz také

imap_close()

Předcházející | Nahoru | Další
imap_num_recent | Domů | imap_ping


imap_ping

(PHP 4, PHP 5)

imap_ping — Check if the IMAP stream is still active

Popis

bool imap_ping ( resource $imap_stream )

imap_ping() pings the stream to see if it's still active. It may discover new mail; this is the preferred method for a periodic "new mail check" as well as a "keep alive" for servers which have inactivity timeout.

Seznam parametrů

imap_stream

An IMAP stream returned by imap_open().

Návratové hodnoty

Returns TRUE if the stream is still alive, FALSE otherwise.

Příklady

Příklad 910. imap_ping() Example

<?php

$imap = imap_open("{imap.example.org}", "mailadmin", "password");

// after some sleeping
if (!imap_ping($imap)) {
    // do some stuff to reconnect
}

?>

Předcházející | Nahoru | Další
imap_open | Domů | imap_qprint


imap_qprint

(PHP 4, PHP 5)

imap_qprint — Convert a quoted-printable string to an 8 bit string

Popis

string imap_qprint ( string $string )

Convert a quoted-printable string to an 8 bit string according to » RFC2045, section 6.7.

Seznam parametrů

string

A quoted-printable string

Návratové hodnoty

Returns an 8 bits string.

Viz také

imap_8bit()

Předcházející | Nahoru | Další
imap_ping | Domů | imap_renamemailbox


imap_renamemailbox

(PHP 4, PHP 5)

imap_renamemailbox — Rename an old mailbox to new mailbox

Popis

bool imap_renamemailbox ( resource $imap_stream, string $old_mbox, string $new_mbox )

This function renames on old mailbox to new mailbox (see imap_open() for the format of mbox names).

Seznam parametrů

imap_stream

An IMAP stream returned by imap_open().

old_mbox

The old mailbox name, see imap_open() for more information

new_mbox

The new mailbox name, see imap_open() for more information

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

imap_createmailbox()
imap_deletemailbox()

Předcházející | Nahoru | Další
imap_qprint | Domů | imap_reopen


imap_reopen

(PHP 4, PHP 5)

imap_reopen — Reopen IMAP stream to new mailbox

Popis

bool imap_reopen ( resource $imap_stream, string $mailbox [, int $options [, int $n_retries]] )

Reopens the specified stream to a new mailbox on an IMAP or NNTP server.

Seznam parametrů

imap_stream

An IMAP stream returned by imap_open().

mailbox

The mailbox name, see imap_open() for more information

options

The options are a bit mask with one or more of the following:

  • OP_READONLY - Open mailbox read-only
  • OP_ANONYMOUS - Don't use or update a .newsrc for news (NNTP only)
  • OP_HALFOPEN - For IMAP and NNTP names, open a connection but don't open a mailbox.
  • OP_EXPUNGE - Silently expunge recycle stream
  • CL_EXPUNGE - Expunge mailbox automatically upon mailbox close (see also imap_delete() and imap_expunge())

n_retries

Number of maximum connect attempts

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

ChangeLog (záznam změn)

Verze | Popis
5.2.0 | n_retries added

Příklady

Příklad 911. imap_reopen() example

<?php
$mbox = imap_open("{imap.example.org:143}INBOX", "username", "password") or die(implode(", ", imap_errors()));
// ...
imap_reopen($mbox, "{imap.example.org:143}INBOX.Sent") or die(implode(", ", imap_errors()));
// ..
?>

Předcházející | Nahoru | Další
imap_renamemailbox | Domů | imap_rfc822_parse_adrlist


imap_rfc822_parse_adrlist

(PHP 4, PHP 5)

imap_rfc822_parse_adrlist — Parses an address string

Popis

array imap_rfc822_parse_adrlist ( string $address, string $default_host )

Parses the address string as defined in » RFC2822 and for each address.

Seznam parametrů

address

A string containing addresses

default_host

The default host name

Návratové hodnoty

Returns an array of objects. The objects properties are:

  • mailbox - the mailbox name (username)
  • host - the host name
  • personal - the personal name
  • adl - at domain source route

Příklady

Příklad 912. imap_rfc822_parse_adrlist() example

<?php

$address_string = "Joe Doe <doe@example.com>, postmaster@example.com, root";
$address_array  = imap_rfc822_parse_adrlist($address_string, "example.com");
if (!is_array($address_array) || count($address_array) < 1) {
    die("something is wrong\n");
}

foreach ($address_array as $id => $val) {
    echo "# $id\n";
    echo "  mailbox : " . $val->mailbox . "\n";
    echo "  host    : " . $val->host . "\n";
    echo "  personal: " . $val->personal . "\n";
    echo "  adl     : " . $val->adl . "\n";
}
?>

Výše uvedený příklad vypíše:

# 0
  mailbox : doe
  host    : example.com
  personal: Joe Doe
  adl     :
# 1
  mailbox : postmaster
  host    : example.com
  personal:
  adl     :
# 2
  mailbox : root
  host    : example.com
  personal:
  adl     :

Viz také

imap_rfc822_parse_headers()

Předcházející | Nahoru | Další
imap_reopen | Domů | imap_rfc822_parse_headers


imap_rfc822_parse_headers

(PHP 4, PHP 5)

imap_rfc822_parse_headers — Parse mail headers from a string

Popis

object imap_rfc822_parse_headers ( string $headers [, string $defaulthost] )

Gets an object of various header elements, similar to imap_header().

Seznam parametrů

headers

The parsed headers data

defaulthost

The default host name

Návratové hodnoty

Returns an object similar to the one returned by imap_header(), except for the flags and other properties that come from the IMAP server.

Viz také

imap_rfc822_parse_adrlist()

Předcházející | Nahoru | Další
imap_rfc822_parse_adrlist | Domů | imap_rfc822_write_address


imap_rfc822_write_address

(PHP 4, PHP 5)

imap_rfc822_write_address — Returns a properly formatted email address given the mailbox, host, and personal info

Popis

string imap_rfc822_write_address ( string $mailbox, string $host, string $personal )

Returns a properly formatted email address as defined in » RFC2822 given the needed information.

Seznam parametrů

mailbox

The mailbox name, see imap_open() for more information

host

The email host part

personal

The name of the account owner

Návratové hodnoty

Returns a string properly formatted email address as defined in » RFC2822.

Příklady

Příklad 913. imap_rfc822_write_address() example

<?php
echo imap_rfc822_write_address("hartmut", "example.com", "Hartmut Holzgraefe");
?>

Výše uvedený příklad vypíše:

Hartmut Holzgraefe <hartmut@example.com>

Předcházející | Nahoru | Další
imap_rfc822_parse_headers | Domů | imap_savebody


imap_scanmailbox

(PHP 4, PHP 5)

imap_scanmailbox — Alias pro imap_listscan()

Popis

Tato funkce je aliasem: imap_listscan().

Předcházející | Nahoru | Další
imap_savebody | Domů | imap_search


imap_search

(PHP 4, PHP 5)

imap_search — This function returns an array of messages matching the given search criteria

Popis

array imap_search ( resource $imap_stream, string $criteria [, int $options [, string $charset]] )

This function performs a search on the mailbox currently opened in the given imap stream.

For example, to match all unanswered messages sent by Mom, you'd use: "UNANSWERED FROM mom". Searches appear to be case insensitive. This list of criteria is from a reading of the UW c-client source code and may be incomplete or inaccurate (see also » RFC2060, section 6.4.4).

Seznam parametrů

imap_stream

An IMAP stream returned by imap_open().

criteria

A string, delimited by spaces, in which the following keywords are allowed. Any multi-word arguments (e.g. FROM "joey smith") must be quoted.

  • ALL - return all messages matching the rest of the criteria
  • ANSWERED - match messages with the \\ANSWERED flag set
  • BCC "string" - match messages with "string" in the Bcc: field
  • BEFORE "date" - match messages with Date: before "date"
  • BODY "string" - match messages with "string" in the body of the message
  • CC "string" - match messages with "string" in the Cc: field
  • DELETED - match deleted messages
  • FLAGGED - match messages with the \\FLAGGED (sometimes referred to as Important or Urgent) flag set
  • FROM "string" - match messages with "string" in the From: field
  • KEYWORD "string" - match messages with "string" as a keyword
  • NEW - match new messages
  • OLD - match old messages
  • ON "date" - match messages with Date: matching "date"
  • RECENT - match messages with the \\RECENT flag set
  • SEEN - match messages that have been read (the \\SEEN flag is set)
  • SINCE "date" - match messages with Date: after "date"
  • SUBJECT "string" - match messages with "string" in the Subject:
  • TEXT "string" - match messages with text "string"
  • TO "string" - match messages with "string" in the To:
  • UNANSWERED - match messages that have not been answered
  • UNDELETED - match messages that are not deleted
  • UNFLAGGED - match messages that are not flagged
  • UNKEYWORD "string" - match messages that do not have the keyword "string"
  • UNSEEN - match messages which have not been read yet

options

Valid values for options are SE_UID, which causes the returned array to contain UIDs instead of messages sequence numbers.

charset

Návratové hodnoty

Returns an array of message numbers or UIDs.

Return FALSE if it does not understand the search criteria or no messages have been found.

ChangeLog (záznam změn)

Verze | Popis
4.3.3 | The charset parameter was added

Viz také

imap_listscan()

Předcházející | Nahoru | Další
imap_scanmailbox | Domů | imap_set_quota


imap_set_quota

(PHP 4 >= 4.0.5, PHP 5)

imap_set_quota — Sets a quota for a given mailbox

Popis

bool imap_set_quota ( resource $imap_stream, string $quota_root, int $quota_limit )

Sets an upper limit quota on a per mailbox basis.

Seznam parametrů

imap_stream

An IMAP stream returned by imap_open().

quota_root

The mailbox to have a quota set. This should follow the IMAP standard format for a mailbox: user.name.

quota_limit

The maximum size (in KB) for the quota_root

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 914. imap_set_quota() example

<?php
$mbox = imap_open("{imap.example.org:143}", "mailadmin", "password");

if (!imap_set_quota($mbox, "user.kalowsky", 3000)) {
    echo "Error in setting quota\n";
    return;
}

imap_close($mbox);
?>

Poznámky

This function is currently only available to users of the c-client2000 or greater library.

The given imap_stream must be opened as the mail administrator, other wise this function will fail.

Viz také

imap_open()
imap_get_quota()

Předcházející | Nahoru | Další
imap_search | Domů | imap_setacl


imap_setacl

(PHP 4 >= 4.0.7, PHP 5)

imap_setacl — Sets the ACL for a giving mailbox

Popis

bool imap_setacl ( resource $imap_stream, string $mailbox, string $id, string $rights )

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

imap_stream

An IMAP stream returned by imap_open().

mailbox

The mailbox name, see imap_open() for more information

id

rights

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Poznámky

This function is currently only available to users of the c-client2000 or greater library.

Viz také

imap_getacl()

Předcházející | Nahoru | Další
imap_set_quota | Domů | imap_setflag_full


imap_setflag_full

(PHP 4, PHP 5)

imap_setflag_full — Sets flags on messages

Popis

bool imap_setflag_full ( resource $imap_stream, string $sequence, string $flag [, int $options] )

Causes a store to add the specified flag to the flags set for the messages in the specified sequence.

Seznam parametrů

imap_stream

An IMAP stream returned by imap_open().

sequence

A sequence of message numbers. You can enumerate desired messages with the X,Y syntax, or retrieve all messages within an interval with the X:Y syntax

flag

The flags which you can set are \\Seen, \\Answered, \\Flagged, \\Deleted, and \\Draft as defined by » RFC2060.

options

A bit mask that may contain the single option:

  • ST_UID - The sequence argument contains UIDs instead of sequence numbers

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 915. imap_setflag_full() example

<?php
$mbox = imap_open("{imap.example.org:143}", "username", "password")
     or die("can't connect: " . imap_last_error());

$status = imap_setflag_full($mbox, "2,5", "\\Seen \\Flagged");

echo gettype($status) . "\n";
echo $status . "\n";

imap_close($mbox);
?>

Viz také

imap_clearflag_full()

Předcházející | Nahoru | Další
imap_setacl | Domů | imap_sort


imap_sort

(PHP 4, PHP 5)

imap_sort — Gets and sort messages

Popis

array imap_sort ( resource $imap_stream, int $criteria, int $reverse [, int $options [, string $search_criteria [, string $charset]]] )

Gets and sorts message numbers by the given parameters.

Seznam parametrů

imap_stream

An IMAP stream returned by imap_open().

criteria

Criteria can be one (and only one) of the following:

  • SORTDATE - message Date
  • SORTARRIVAL - arrival date
  • SORTFROM - mailbox in first From address
  • SORTSUBJECT - message subject
  • SORTTO - mailbox in first To address
  • SORTCC - mailbox in first cc address
  • SORTSIZE - size of message in octets

reverse

Set this to 1 for reverse sorting

options

The options are a bitmask of one or more of the following:

  • SE_UID - Return UIDs instead of sequence numbers
  • SE_NOPREFETCH - Don't prefetch searched messages

search_criteria

charset

Návratové hodnoty

Returns an array of message numbers sorted by the given parameters.

ChangeLog (záznam změn)

Verze | Popis
4.3.3 | The charset parameter was added

Předcházející | Nahoru | Další
imap_setflag_full | Domů | imap_status


imap_status

(PHP 4, PHP 5)

imap_status — Returns status information on a mailbox

Popis

object imap_status ( resource $imap_stream, string $mailbox, int $options )

Gets status information about the given mailbox.

Seznam parametrů

imap_stream

An IMAP stream returned by imap_open().

mailbox

The mailbox name, see imap_open() for more information

options

Valid flags are:

  • SA_MESSAGES - set status->messages to the number of messages in the mailbox
  • SA_RECENT - set status->recent to the number of recent messages in the mailbox
  • SA_UNSEEN - set status->unseen to the number of unseen (new) messages in the mailbox
  • SA_UIDNEXT - set status->uidnext to the next uid to be used in the mailbox
  • SA_UIDVALIDITY - set status->uidvalidity to a constant that changes when uids for the mailbox may no longer be valid
  • SA_ALL - set all of the above

Návratové hodnoty

This function returns an object containing status information. The object has the following properties: messages, recent, unseen, uidnext, and uidvalidity.

flags is also set, which contains a bitmask which can be checked against any of the above constants.

Příklady

Příklad 916. imap_status() example

<?php
$mbox = imap_open("{imap.example.com}", "username", "password", OP_HALFOPEN)
      or die("can't connect: " . imap_last_error());

$status = imap_status($mbox, "{imap.example.org}INBOX", SA_ALL);
if ($status) {
  echo "Messages:   " . $status->messages    . "<br />\n";
  echo "Recent:     " . $status->recent      . "<br />\n";
  echo "Unseen:     " . $status->unseen      . "<br />\n";
  echo "UIDnext:    " . $status->uidnext     . "<br />\n";
  echo "UIDvalidity:" . $status->uidvalidity . "<br />\n";
} else {
  echo "imap_status failed: " . imap_last_error() . "\n";
}

imap_close($mbox);
?>

Předcházející | Nahoru | Další
imap_sort | Domů | imap_subscribe


imap_subscribe

(PHP 4, PHP 5)

imap_subscribe — Subscribe to a mailbox

Popis

bool imap_subscribe ( resource $imap_stream, string $mailbox )

Subscribe to a new mailbox.

Seznam parametrů

imap_stream

An IMAP stream returned by imap_open().

mailbox

The mailbox name, see imap_open() for more information

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

imap_unsubscribe()

Předcházející | Nahoru | Další
imap_status | Domů | imap_thread


imap_thread

(PHP 4 >= 4.0.7, PHP 5)

imap_thread — Returns a tree of threaded message

Popis

array imap_thread ( resource $imap_stream [, int $options] )

Gets a tree of a threaded message.

Seznam parametrů

imap_stream

An IMAP stream returned by imap_open().

options

Návratové hodnoty

imap_thread() returns an associative array containing a tree of messages threaded by REFERENCES, or FALSE on error.

Every message in the current mailbox will be represented by three entries in the resulting array:

  • $thread["XX.num"] - current message number

  • $thread["XX.next"]

  • $thread["XX.branch"]

Příklady

Příklad 917. imap_thread() Example

<?php

// Here we're outputting the threads of a newsgroup, in HTML

$nntp = imap_open('{news.example.com:119/nntp}some.newsgroup', '', '');
$threads = imap_thread($nntp);

foreach ($threads as $key => $val) {
  $tree = explode('.', $key);
  if ($tree[1] == 'num') {
    $header = imap_headerinfo($nntp, $val);
    echo "<ul>\n\t<li>" . $header->fromaddress . "\n";
  } elseif ($tree[1] == 'branch') {
    echo "\t</li>\n</ul>\n";
  }
}

imap_close($nntp);

?>

Předcházející | Nahoru | Další
imap_subscribe | Domů | imap_timeout


imap_timeout

(PHP 4 >= 4.3.3, PHP 5)

imap_timeout — Set or fetch imap timeout

Popis

mixed imap_timeout ( int $timeout_type [, int $timeout] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
imap_thread | Domů | imap_uid


imap_uid

(PHP 4, PHP 5)

imap_uid — This function returns the UID for the given message sequence number

Popis

int imap_uid ( resource $imap_stream, int $msg_number )

This function returns the UID for the given message sequence number. An UID is a unique identifier that will not change over time while a message sequence number may change whenever the content of the mailbox changes.

This function is the inverse of imap_msgno().

Seznam parametrů

imap_stream

An IMAP stream returned by imap_open().

msg_number

The message number.

Návratové hodnoty

The UID of the given message.

Poznámky

Poznámka: This function is not supported by POP3 mailboxes.

Viz také

imap_msgno()

Předcházející | Nahoru | Další
imap_timeout | Domů | imap_undelete


imap_undelete

(PHP 4, PHP 5)

imap_undelete — Unmark the message which is marked deleted

Popis

bool imap_undelete ( resource $imap_stream, int $msg_number [, int $flags] )

Removes the deletion flag for a specified message, which is set by imap_delete() or imap_mail_move().

Seznam parametrů

imap_stream

An IMAP stream returned by imap_open().

msg_number

The message number

flags

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

imap_delete()
imap_mail_move()

Předcházející | Nahoru | Další
imap_uid | Domů | imap_unsubscribe


imap_unsubscribe

(PHP 4, PHP 5)

imap_unsubscribe — Unsubscribe from a mailbox

Popis

bool imap_unsubscribe ( string $imap_stream, string $mailbox )

Unsubscribe from the specified mailbox.

Seznam parametrů

imap_stream

An IMAP stream returned by imap_open().

mailbox

The mailbox name, see imap_open() for more information

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

imap_subscribe()

Předcházející | Nahoru | Další
imap_undelete | Domů | imap_utf7_decode


imap_utf7_decode

(PHP 4, PHP 5)

imap_utf7_decode — Decodes a modified UTF-7 encoded string

Popis

string imap_utf7_decode ( string $text )

Decodes modified UTF-7 text into ISO-8859-1 string.

This function is needed to decode mailbox names that contain certain characters which are not in range of printable ASCII characters.

Seznam parametrů

text

A modified UTF-7 encoding string, as defined in » RFC 2060, section 5.1.3 (original UTF-7 was defined in » RFC1642).

Návratové hodnoty

Returns a string that is encoded in ISO-8859-1 and consists of the same sequence of characters in text, or FALSE if text contains invalid modified UTF-7 sequence or text contains a character that is not part of ISO-8859-1 character set.

Viz také

imap_utf7_encode()

Předcházející | Nahoru | Další
imap_unsubscribe | Domů | imap_utf7_encode


imap_utf7_encode

(PHP 4, PHP 5)

imap_utf7_encode — Converts ISO-8859-1 string to modified UTF-7 text

Popis

string imap_utf7_encode ( string $data )

Converts data to modified UTF-7 text.

This is needed to encode mailbox names that contain certain characters which are not in range of printable ASCII characters.

Seznam parametrů

data

An ISO-8859-1 string.

Návratové hodnoty

Returns data encoded with the modified UTF-7 encoding as defined in » RFC 2060, section 5.1.3 (original UTF-7 was defined in » RFC1642).

Viz také

imap_utf7_decode()

Předcházející | Nahoru | Další
imap_utf7_decode | Domů | imap_utf8


imap_utf8

(PHP 4, PHP 5)

imap_utf8 — Converts MIME-encoded text to UTF-8

Popis

string imap_utf8 ( string $mime_encoded_text )

Converts the given mime_encoded_text to UTF-8.

Seznam parametrů

mime_encoded_text

A MIME encoded string. MIME encoding method and the UTF-8 specification are described in » RFC2047 and » RFC2044 respectively.

Návratové hodnoty

Returns an UTF-8 encoded string.

Viz také

imap_mime_header_decode()

Předcházející | Nahoru | Další
imap_utf7_encode | Domů | LXVIII. Informix Functions


Informix Functions

Předcházející VI. Reference funkcí Další

LXVIII. Informix Functions

Úvod

The Informix driver for Informix (IDS) 7.x, SE 7.x, Universal Server (IUS) 9.x and IDS 2000 is implemented in "ifx.ec" and "php3_ifx.h" in the informix extension directory. IDS 7.x support is fairly complete, with full support for BYTE and TEXT columns. IUS 9.x support is partly finished: the new data types are there, but SLOB and CLOB support is still under construction.

Poznámka: Toto rozšíření bylo přesunuto do repozitáře PECL a již nebude součástí balíku PHP.5.2.1.

Požadavky

Configuration notes: You need a version of ESQL/C to compile the PHP Informix driver. ESQL/C versions from 7.2x on should be OK. ESQL/C is now part of the Informix Client SDK.

Make sure that the "INFORMIXDIR" variable has been set, and that $INFORMIXDIR/bin is in your PATH before you run the "configure" script.

Instalace

To be able to use the functions defined in this module you must compile your PHP interpreter using the configure line --with-informix[=DIR], where DIR is the Informix base install directory, defaults to nothing.

Konfigurace běhu

Chování těchto funkcí je ovlivněno nastavením parametrů v php.ini.

Poznámka: Make sure that the Informix environment variables INFORMIXDIR and INFORMIXSERVER are available to the PHP ifx driver, and that the INFORMIX bin directory is in the PATH. Check this by running a script that contains a call to phpinfo() before you start testing. The phpinfo() output should list these environment variables. This is true for both CGI php and Apache mod_php. You may have to set these environment variables in your Apache startup script.

The Informix shared libraries should also be available to the loader (check LD_LIBRARY_PATH or ld.so.conf/ldconfig).

Some notes on the use of BLOBs (TEXT and BYTE columns) : BLOBs are normally addressed by BLOB identifiers. Select queries return a "blob id" for every BYTE and TEXT column. You can get at the contents with "string_var = ifx_get_blob($blob_id);" if you choose to get the BLOBs in memory (with: "ifx_blobinfile(0);"). If you prefer to receive the content of BLOB columns in a file, use "ifx_blobinfile(1);", and "ifx_get_blob($blob_id);" will get you the filename. Use normal file I/O to get at the blob contents.

For insert/update queries you must create these "blob id's" yourself with "ifx_create_blob();". You then plug the blob id's into an array, and replace the blob columns with a question mark (?) in the query string. For updates/inserts, you are responsible for setting the blob contents with ifx_update_blob().

The behaviour of BLOB columns can be altered by configuration variables that also can be set at runtime:

configuration variable: ifx.textasvarchar

configuration variable: ifx.byteasvarchar

runtime functions:

ifx_textasvarchar(0): use blob id's for select queries with TEXT columns

ifx_byteasvarchar(0): use blob id's for select queries with BYTE columns

ifx_textasvarchar(1): return TEXT columns as if they were VARCHAR columns, so that you don't need to use blob id's for select queries.

ifx_byteasvarchar(1): return BYTE columns as if they were VARCHAR columns, so that you don't need to use blob id's for select queries.

configuration variable: ifx.blobinfile

runtime function:

ifx_blobinfile_mode(0): return BYTE columns in memory, the blob id lets you get at the contents.

ifx_blobinfile_mode(1): return BYTE columns in a file, the blob id lets you get at the file name.

If you set ifx_text/byteasvarchar to 1, you can use TEXT and BYTE columns in select queries just like normal (but rather long) VARCHAR fields. Since all strings are "counted" in PHP, this remains "binary safe". It is up to you to handle this correctly. The returned data can contain anything, you are responsible for the contents.

If you set ifx_blobinfile to 1, use the file name returned by ifx_get_blob(..) to get at the blob contents. Note that in this case YOU ARE RESPONSIBLE FOR DELETING THE TEMPORARY FILES CREATED BY INFORMIX when fetching the row. Every new row fetched will create new temporary files for every BYTE column.

The location of the temporary files can be influenced by the environment variable "blobdir", default is "." (the current directory). Something like: putenv(blobdir=tmpblob"); will ease the cleaning up of temp files accidentally left behind (their names all start with "blb").

Automatically trimming "char" (SQLCHAR and SQLNCHAR) data: This can be set with the configuration variable

ifx.charasvarchar: if set to 1 trailing spaces will be automatically trimmed, to save you some "chopping".

NULL values: The configuration variable ifx.nullformat (and the runtime function ifx_nullformat()) when set to TRUE will return NULL columns as the string "NULL", when set to FALSE they return the empty string. This allows you to discriminate between NULL columns and empty columns.

Tabulka 141. Informix configuration options

Name | Default | Changeable | Changelog
ifx.allow_persistent | "1" | PHP_INI_SYSTEM | Removed in PHP 5.2.1.
ifx.max_persistent | "-1" | PHP_INI_SYSTEM | Removed in PHP 5.2.1.
ifx.max_links | "-1" | PHP_INI_SYSTEM | Removed in PHP 5.2.1.
ifx.default_host | NULL | PHP_INI_SYSTEM | Removed in PHP 5.2.1.
ifx.default_user | NULL | PHP_INI_SYSTEM | Removed in PHP 5.2.1.
ifx.default_password | NULL | PHP_INI_SYSTEM | Removed in PHP 5.2.1.
ifx.blobinfile | "1" | PHP_INI_ALL | Removed in PHP 5.2.1.
ifx.textasvarchar | "0" | PHP_INI_ALL | Removed in PHP 5.2.1.
ifx.byteasvarchar | "0" | PHP_INI_ALL | Removed in PHP 5.2.1.
ifx.charasvarchar | "0" | PHP_INI_ALL | Removed in PHP 5.2.1.
ifx.nullformat | "0" | PHP_INI_ALL | Removed in PHP 5.2.1.

Pro další detaily a definice konstant PHP_INI_*, viz dokumentace k ini_set().

Zde je stručný popis konfiguračních direktiv.

ifx.allow_persistent boolean

Whether to allow persistent Informix connections.

ifx.max_persistent integer

The maximum number of persistent Informix connections per process.

ifx.max_links integer

The maximum number of Informix connections per process, including persistent connections.

ifx.default_host string

The default host to connect to when no host is specified in ifx_connect() or ifx_pconnect(). Doesn't apply in bezpečný režim.

ifx.default_user string

The default user id to use when none is specified in ifx_connect() or ifx_pconnect(). Doesn't apply in bezpečný režim.

ifx.default_password string

The default password to use when none is specified in ifx_connect() or ifx_pconnect(). Doesn't apply in bezpečný režim.

ifx.blobinfile boolean

Set to TRUE if you want to return blob columns in a file, FALSE if you want them in memory. You can override the setting at runtime with ifx_blobinfile_mode().

ifx.textasvarchar boolean

Set to TRUE if you want to return TEXT columns as normal strings in select statements, FALSE if you want to use blob id parameters. You can override the setting at runtime with ifx_textasvarchar().

ifx.byteasvarchar boolean

Set to TRUE if you want to return BYTE columns as normal strings in select queries, FALSE if you want to use blob id parameters. You can override the setting at runtime with ifx_textasvarchar().

ifx.charasvarchar boolean

Set to TRUE if you want to trim trailing spaces from CHAR columns when fetching them.

ifx.nullformat boolean

Set to TRUE if you want to return NULL columns as the literal string "NULL", FALSE if you want them returned as the empty string "". You can override this setting at runtime with ifx_nullformat().

Typy prostředků

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

IFX_SCROLL (integer)
IFX_HOLD (integer)
IFX_LO_RDONLY (integer)
IFX_LO_WRONLY (integer)
IFX_LO_APPEND (integer)
IFX_LO_RDWR (integer)
IFX_LO_BUFFER (integer)
IFX_LO_NOBUFFER (integer)

Obsah

ifx_affected_rows — Get number of rows affected by a query
ifx_blobinfile_mode — Set the default blob mode for all select queries
ifx_byteasvarchar — Set the default byte mode
ifx_close — Close Informix connection
ifx_connect — Open Informix server connection
ifx_copy_blob — Duplicates the given blob object
ifx_create_blob — Creates an blob object
ifx_create_char — Creates an char object
ifx_do — Execute a previously prepared SQL-statement
ifx_error — Returns error code of last Informix call
ifx_errormsg — Returns error message of last Informix call
ifx_fetch_row — Get row as an associative array
ifx_fieldproperties — List of SQL fieldproperties
ifx_fieldtypes — List of Informix SQL fields
ifx_free_blob — Deletes the blob object
ifx_free_char — Deletes the char object
ifx_free_result — Releases resources for the query
ifx_get_blob — Return the content of a blob object
ifx_get_char — Return the content of the char object
ifx_getsqlca — Get the contents of sqlca.sqlerrd[0..5] after a query
ifx_htmltbl_result — Formats all rows of a query into a HTML table
ifx_nullformat — Sets the default return value on a fetch row
ifx_num_fields — Returns the number of columns in the query
ifx_num_rows — Count the rows already fetched from a query
ifx_pconnect — Open persistent Informix connection
ifx_prepare — Prepare an SQL-statement for execution
ifx_query — Send Informix query
ifx_textasvarchar — Set the default text mode
ifx_update_blob — Updates the content of the blob object
ifx_update_char — Updates the content of the char object
ifxus_close_slob — Deletes the slob object
ifxus_create_slob — Creates an slob object and opens it
ifxus_free_slob — Deletes the slob object
ifxus_open_slob — Opens an slob object
ifxus_read_slob — Reads nbytes of the slob object
ifxus_seek_slob — Sets the current file or seek position
ifxus_tell_slob — Returns the current file or seek position
ifxus_write_slob — Writes a string into the slob object
Předcházející | Nahoru | Další
imap_utf8 | Domů | ifx_affected_rows


ifx_affected_rows

(No version information available, might be only in CVS)

ifx_affected_rows — Get number of rows affected by a query

Popis

int ifx_affected_rows ( resource $result_id )

Returns the number of rows affected by a query associated with result_id.

For inserts, updates and deletes the number is the real number (sqlerrd[2]) of affected rows. For selects it is an estimate (sqlerrd[0]). Don't rely on it. The database server can never return the actual number of rows that will be returned by a SELECT because it has not even begun fetching them at this stage (just after the "PREPARE" when the optimizer has determined the query plan).

Useful after ifx_prepare() to limit queries to reasonable result sets.

Seznam parametrů

result_id

A valid result id returned by ifx_query() or ifx_prepare().

Návratové hodnoty

Returns the number of rows as an integer.

Příklady

Příklad 918. Informix affected rows

<?php
$rid = ifx_prepare("select * from emp
                     where name like " . $name, $connid);
if (! $rid) {
    /* ... error ... */
}
$rowcount = ifx_affected_rows($rid);
if ($rowcount > 1000) {
    printf ("Too many rows in result set (%d)\n<br />", $rowcount);
    die ("Please restrict your query<br />\n");
}
?>

Viz také

ifx_num_rows()

Předcházející | Nahoru | Další
LXVIII. Informix Functions | Domů | ifx_blobinfile_mode


ifx_blobinfile_mode

(No version information available, might be only in CVS)

ifx_blobinfile_mode — Set the default blob mode for all select queries

Popis

bool ifx_blobinfile_mode ( int $mode )

Set the default blob mode for all select queries.

Seznam parametrů

mode

Mode "0" means save Byte-Blobs in memory, and mode "1" means save Byte-Blobs in a file.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
ifx_affected_rows | Domů | ifx_byteasvarchar


ifx_byteasvarchar

(No version information available, might be only in CVS)

ifx_byteasvarchar — Set the default byte mode

Popis

bool ifx_byteasvarchar ( int $mode )

Sets the default byte mode for all select-queries.

Seznam parametrů

mode

Mode "0" will return a blob id, and mode "1" will return a varchar with text content.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ifx_textasvarchar()

Předcházející | Nahoru | Další
ifx_blobinfile_mode | Domů | ifx_close


ifx_close

(No version information available, might be only in CVS)

ifx_close — Close Informix connection

Popis

bool ifx_close ( [resource $link_identifier] )

ifx_close() closes the link to an Informix database that's associated with the specified link identifier.

Note that this isn't usually necessary, as non-persistent open links are automatically closed at the end of the script's execution.

ifx_close() will not close persistent links generated by ifx_pconnect().

Seznam parametrů

link_identifier

The link identifier. If not specified, the last opened link is assumed.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 919. Closing a Informix connection

<?php
$conn_id = ifx_connect ("mydb@ol_srv", "itsme", "mypassword");
/* ... some queries and stuff ... */
ifx_close($conn_id);
?>

Viz také

ifx_connect()
ifx_pconnect()

Předcházející | Nahoru | Další
ifx_byteasvarchar | Domů | ifx_connect


ifx_connect

(No version information available, might be only in CVS)

ifx_connect — Open Informix server connection

Popis

resource ifx_connect ( [string $database [, string $userid [, string $password]]] )

ifx_connect() establishes a connection to an Informix server.

In case a second call is made to ifx_connect() with the same arguments, no new link will be established, but instead, the link identifier of the already opened link will be returned.

The link to the server will be closed as soon as the execution of the script ends, unless it's closed earlier by explicitly calling ifx_close().

Seznam parametrů

All of the arguments are optional, and if they're missing, defaults are taken from values supplied in php.ini (ifx.default_host for the host (Informix libraries will use INFORMIXSERVER environment value if not defined), ifx.default_user for user, ifx.default_password for the password (none if not defined).

database

The database name, as a string.

userid

The username, as a string.

password

The password, as a string.

Návratové hodnoty

Returns a connection identifier on success, or FALSE on error.

Příklady

Příklad 920. Connect to a Informix database

<?php
$conn_id = ifx_connect ("mydb@ol_srv1", "imyself", "mypassword");
?>

Viz také

ifx_pconnect()
ifx_close()

Předcházející | Nahoru | Další
ifx_close | Domů | ifx_copy_blob


ifx_copy_blob

(No version information available, might be only in CVS)

ifx_copy_blob — Duplicates the given blob object

Popis

int ifx_copy_blob ( int $bid )

Duplicates the given blob object.

Seznam parametrů

bid

A BLOB identifier.

Návratové hodnoty

Returns the new blob object-id, or FALSE on errors.

Viz také

ifx_create_blob()
ifx_free_blob()

Předcházející | Nahoru | Další
ifx_connect | Domů | ifx_create_blob


ifx_create_blob

(No version information available, might be only in CVS)

ifx_create_blob — Creates an blob object

Popis

int ifx_create_blob ( int $type, int $mode, string $param )

Creates a blob object.

Seznam parametrů

type

1 = TEXT, 0 = BYTE

mode

0 = blob-object holds the content in memory, 1 = blob-object holds the content in file.

param

if mode = 0: pointer to the content, if mode = 1: pointer to the filestring.

Návratové hodnoty

Returns the new BLOB object-id, or FALSE on errors.

Viz také

ifx_copy_blob()
ifx_free_blob()

Předcházející | Nahoru | Další
ifx_copy_blob | Domů | ifx_create_char


ifx_create_char

(No version information available, might be only in CVS)

ifx_create_char — Creates an char object

Popis

int ifx_create_char ( string $param )

Creates an char object.

Seznam parametrů

param

The char content.

Návratové hodnoty

Returns the new char object id, or FALSE on errors.

Viz také

ifx_free_char()

Předcházející | Nahoru | Další
ifx_create_blob | Domů | ifx_do


ifx_do

(No version information available, might be only in CVS)

ifx_do — Execute a previously prepared SQL-statement

Popis

bool ifx_do ( resource $result_id )

Executes a previously prepared query or opens a cursor for it.

Does NOT free result_id on error.

Also sets the real number of ifx_affected_rows() for non-select statements for retrieval by ifx_affected_rows().

Seznam parametrů

result_id

result_id is a valid resultid returned by ifx_query() or ifx_prepare() (select type queries only!).

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

Příklad 921. ifx_do() Example

<?php
$conn = fx_connect( "db", "user", "password" );
$result = ifx_prepare("SELECT customer_num, company FROM customer", $conn);
ifx_do($result);
?>

Viz také

ifx_prepare()

Předcházející | Nahoru | Další
ifx_create_char | Domů | ifx_error


ifx_error

(No version information available, might be only in CVS)

ifx_error — Returns error code of last Informix call

Popis

string ifx_error ( [resource $link_identifier] )

Returns in a string one character describing the general results of a statement and both SQLSTATE and SQLCODE associated with the most recent SQL statement executed.

Seznam parametrů

link_identifier

The link identifier.

Návratové hodnoty

The Informix error codes (SQLSTATE & SQLCODE) formatted as x [SQLSTATE = aa bbb SQLCODE=cccc].

where x = space : no error

E : error

N : no more data

W : warning

? : undefined

If the "x" character is anything other than space, SQLSTATE and SQLCODE describe the error in more detail.

See the Informix manual for the description of SQLSTATE and SQLCODE

Viz také

ifx_errormsg()

Předcházející | Nahoru | Další
ifx_do | Domů | ifx_errormsg


ifx_errormsg

(No version information available, might be only in CVS)

ifx_errormsg — Returns error message of last Informix call

Popis

string ifx_errormsg ( [int $errorcode] )

Returns the Informix error message associated with the most recent Informix error.

Seznam parametrů

errorcode

If specified, the function will return the message corresponding to the specified code.

Návratové hodnoty

Return the error message, as a string.

Příklady

Příklad 922. ifx_errormsg() example

printf("%s\n&lt;br>", ifx_errormsg(-201));

Viz také

ifx_error()

Předcházející | Nahoru | Další
ifx_error | Domů | ifx_fetch_row


ifx_fetch_row

(No version information available, might be only in CVS)

ifx_fetch_row — Get row as an associative array

Popis

array ifx_fetch_row ( resource $result_id [, mixed $position] )

Fetches one row of data from the result associated with the specified result identifier.

Subsequent calls to ifx_fetch_row() would return the next row in the result set, or FALSE if there are no more rows.

Seznam parametrů

result_id

result_id is a valid resultid returned by ifx_query() or ifx_prepare() (select type queries only!).

position

An optional parameter for a "fetch" operation on "scroll" cursors: NEXT, PREVIOUS, CURRENT, FIRST, LAST or a number. If you specify a number, an "absolute" row fetch is executed. This parameter is optional, and only valid for SCROLL cursors.

Návratové hodnoty

Returns an associative array that corresponds to the fetched row, or FALSE if there are no more rows.

Blob columns are returned as integer blob id values for use in ifx_get_blob() unless you have used ifx_textasvarchar(1) or ifx_byteasvarchar(1), in which case blobs are returned as string values.

Příklady

Příklad 923. Informix fetch rows

<?php
$rid = ifx_prepare ("select * from emp where name like " . $name,
                     $connid, IFX_SCROLL);
if (! $rid) {
    /* ... error ... */
}
$rowcount = ifx_affected_rows($rid);
if ($rowcount > 1000) {
    printf ("Too many rows in result set (%d)\n<br />", $rowcount);
    die ("Please restrict your query<br />\n");
}
if (! ifx_do ($rid)) {
   /* ... error ... */
}
$row = ifx_fetch_row ($rid, "NEXT");
while (is_array($row)) {
    for (reset($row); $fieldname=key($row); next($row)) {
        $fieldvalue = $row[$fieldname];
        printf ("%s = %s,", $fieldname, $fieldvalue);
    }
    printf("\n<br />");
    $row = ifx_fetch_row($rid, "NEXT");
}
ifx_free_result ($rid);
?>

Předcházející | Nahoru | Další
ifx_errormsg | Domů | ifx_fieldproperties


ifx_fieldproperties

(No version information available, might be only in CVS)

ifx_fieldproperties — List of SQL fieldproperties

Popis

array ifx_fieldproperties ( resource $result_id )

Returns the Informix SQL fieldproperties of every field in the query as an associative array. Properties are encoded as: "SQLTYPE;length;precision;scale;ISNULLABLE" where SQLTYPE = the Informix type like "SQLVCHAR" etc. and ISNULLABLE = "Y" or "N".

Seznam parametrů

result_id

result_id is a valid resultid returned by ifx_query() or ifx_prepare() (select type queries only!).

Návratové hodnoty

Returns an associative array with fieldnames as key and the SQL fieldproperties as data for a query with result_id. Returns FALSE on errors.

Příklady

Příklad 924. Informix SQL fieldproperties

<?php
$properties = ifx_fieldproperties($resultid);
if (!isset($properties)) {
    /* ... error ... */
}
foreach ($properties as $fname => $val) {
    echo "$fname:\t property = $val\n";
}
?>

Viz také

ifx_fieldtypes()

Předcházející | Nahoru | Další
ifx_fetch_row | Domů | ifx_fieldtypes


ifx_fieldtypes

(No version information available, might be only in CVS)

ifx_fieldtypes — List of Informix SQL fields

Popis

array ifx_fieldtypes ( resource $result_id )

Returns an associative array with fieldnames as key and the SQL fieldtypes as data for the query associated with result_id.

Seznam parametrů

result_id

result_id is a valid resultid returned by ifx_query() or ifx_prepare() (select type queries only!).

Návratové hodnoty

Returns an associative array with fieldnames as key and the SQL fieldtypes as data for query with result_id. Returns FALSE on error.

Příklady

Příklad 925. Fieldnames and SQL fieldtypes

<?php
$types = ifx_fieldtypes($resultid);
if (is_array($types)) {
    foreach ($types as $fname => $val) {
        echo "$fname:\t type = $val\n";
    }
}
?>

Viz také

ifx_fieldproperties()

Předcházející | Nahoru | Další
ifx_fieldproperties | Domů | ifx_free_blob


ifx_free_blob

(No version information available, might be only in CVS)

ifx_free_blob — Deletes the blob object

Popis

bool ifx_free_blob ( int $bid )

Deletes the blobobject for the given blob object-id.

Seznam parametrů

bid

The BLOB object id.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ifx_create_blob()

Předcházející | Nahoru | Další
ifx_fieldtypes | Domů | ifx_free_char


ifx_free_char

(No version information available, might be only in CVS)

ifx_free_char — Deletes the char object

Popis

bool ifx_free_char ( int $bid )

Deletes the charobject for the given char object-id.

Seznam parametrů

bid

The char object id.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ifx_create_char()

Předcházející | Nahoru | Další
ifx_free_blob | Domů | ifx_free_result


ifx_free_result

(No version information available, might be only in CVS)

ifx_free_result — Releases resources for the query

Popis

bool ifx_free_result ( resource $result_id )

Releases resources for the query associated with result_id.

Seznam parametrů

result_id

result_id is a valid resultid returned by ifx_query() or ifx_prepare() (select type queries only!).

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ifx_do()

Předcházející | Nahoru | Další
ifx_free_char | Domů | ifx_get_blob


ifx_get_blob

(No version information available, might be only in CVS)

ifx_get_blob — Return the content of a blob object

Popis

string ifx_get_blob ( int $bid )

Returns the content of the blob object.

Seznam parametrů

bid

The BLOB object id.

Návratové hodnoty

The contents of the BLOB as a string, or FALSE on errors.

Viz také

ifx_get_char()

Předcházející | Nahoru | Další
ifx_free_result | Domů | ifx_get_char


ifx_get_char

(No version information available, might be only in CVS)

ifx_get_char — Return the content of the char object

Popis

string ifx_get_char ( int $bid )

Returns the content of the char object.

Seznam parametrů

bid

The char object-id.

Návratové hodnoty

Returns the contents as a string, or FALSE on errors.

Viz také

ifx_get_blob()

Předcházející | Nahoru | Další
ifx_get_blob | Domů | ifx_getsqlca


ifx_getsqlca

(No version information available, might be only in CVS)

ifx_getsqlca — Get the contents of sqlca.sqlerrd[0..5] after a query

Popis

array ifx_getsqlca ( resource $result_id )

Returns a pseudo-row with sqlca.sqlerrd[0] ... sqlca.sqlerrd[5] after the query associated with result_id.

For inserts, updates and deletes the values returned are those as set by the server after executing the query. This gives access to the number of affected rows and the serial insert value. For SELECTs the values are those saved after the PREPARE statement. This gives access to the *estimated* number of affected rows. The use of this function saves the overhead of executing a SELECT dbinfo('sqlca.sqlerrdx') query, as it retrieves the values that were saved by the ifx driver at the appropriate moment.

Seznam parametrů

result_id

result_id is a valid result id returned by ifx_query() or ifx_prepare() (select type queries only!).

Návratové hodnoty

Returns an associative array with the following entries: sqlerrd0, sqlerrd1, sqlerrd2, sqlerrd3, sqlerrd4 and sqlerrd5.

Příklady

Příklad 926. Retrieve Informix sqlca.sqlerrd[x] values

<?php
/* assume the first column of 'sometable' is a serial */
$qid = ifx_query("insert into sometable
                  values (0, '2nd column', 'another column') ", $connid);
if (!$qid) {
    /* ... error ... */
}
$sqlca = ifx_getsqlca($qid);
$serial_value = $sqlca["sqlerrd1"];
echo "The serial value of the inserted row is : $serial_value<br />\n";
?>

Předcházející | Nahoru | Další
ifx_get_char | Domů | ifx_htmltbl_result


ifx_htmltbl_result

(No version information available, might be only in CVS)

ifx_htmltbl_result — Formats all rows of a query into a HTML table

Popis

int ifx_htmltbl_result ( resource $result_id [, string $html_table_options] )

Formats and prints all rows of the result_id query into a HTML table.

Seznam parametrů

result_id

result_id is a valid resultid returned by ifx_query() or ifx_prepare() (select type queries only!).

html_table_options

This optional argument is a string of <table> tag options.

Návratové hodnoty

Returns the number of fetched rows, or FALSE on errors.

Příklady

Příklad 927. Informix results as HTML table

<?php
$rid = ifx_prepare ("select * from emp where name like " . $name,
                     $connid, IFX_SCROLL);
if (! $rid) {
    /* ... error ... */
}
$rowcount = ifx_affected_rows ($rid);
if ($rowcount > 1000) {
    printf ("Too many rows in result set (%d)\n<br />", $rowcount);
    die ("Please restrict your query<br />\n");
}
if (! ifx_do($rid)) {
    /* ... error ... */
}

ifx_htmltbl_result ($rid, "border=\"2\"");

ifx_free_result($rid);
?>

Předcházející | Nahoru | Další
ifx_getsqlca | Domů | ifx_nullformat


ifx_nullformat

(No version information available, might be only in CVS)

ifx_nullformat — Sets the default return value on a fetch row

Popis

bool ifx_nullformat ( int $mode )

Sets the default return value of a NULL-value on a fetch row.

Seznam parametrů

mode

Mode "0" returns "", and mode "1" returns "NULL".

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
ifx_htmltbl_result | Domů | ifx_num_fields


ifx_num_fields

(No version information available, might be only in CVS)

ifx_num_fields — Returns the number of columns in the query

Popis

int ifx_num_fields ( resource $result_id )

After preparing or executing a query, this call gives you the number of columns in the query.

Seznam parametrů

result_id

result_id is a valid resultid returned by ifx_query() or ifx_prepare() (select type queries only!).

Návratové hodnoty

Returns the number of columns in query for result_id, or FALSE on errors.

Příklady

Příklad 928. ifx_num_fields() Example

<?php
$conn_id = ifx_connect("db", "user", "password");
$res_id = ifx_query("select * from systables", $conn_id);
echo ifx_num_fields($res_id);
?>

Viz také

ifx_num_rows()

Předcházející | Nahoru | Další
ifx_nullformat | Domů | ifx_num_rows


ifx_num_rows

(No version information available, might be only in CVS)

ifx_num_rows — Count the rows already fetched from a query

Popis

int ifx_num_rows ( resource $result_id )

Gives the number of rows fetched so far for a query with result_id after a ifx_query() or ifx_do() query.

Seznam parametrů

result_id

result_id is a valid resultid returned by ifx_query() or ifx_prepare() (select type queries only!).

Návratové hodnoty

Returns the number of fetched rows or FALSE on errors.

Viz také

ifx_num_fields()

Předcházející | Nahoru | Další
ifx_num_fields | Domů | ifx_pconnect


ifx_pconnect

(No version information available, might be only in CVS)

ifx_pconnect — Open persistent Informix connection

Popis

resource ifx_pconnect ( [string $database [, string $userid [, string $password]]] )

ifx_pconnect() acts very much like ifx_connect() with two major differences.

First, when connecting, the function would first try to find a (persistent) link that's already open with the same host, username and password. If one is found, an identifier for it will be returned instead of opening a new connection.

Second, the connection to the SQL server will not be closed when the execution of the script ends. Instead, the link will remain open for future use (ifx_close() will not close links established by ifx_pconnect()).

This type of links is therefore called 'persistent'.

Seznam parametrů

All of the arguments are optional, and if they're missing, defaults are taken from values supplied in php.ini (ifx.default_host for the host (Informix libraries will use INFORMIXSERVER environment value if not defined), ifx.default_user for user, ifx.default_password for the password (none if not defined).

database

The database name, as a string.

userid

The username, as a string.

password

The password, as a string.

Návratové hodnoty

Returns: valid Informix persistent link identifier on success, or FALSE on errors.

Viz také

ifx_connect()

Předcházející | Nahoru | Další
ifx_num_rows | Domů | ifx_prepare


ifx_prepare

(No version information available, might be only in CVS)

ifx_prepare — Prepare an SQL-statement for execution

Popis

resource ifx_prepare ( string $query, resource $link_identifier [, int $cursor_def, mixed $blobidarray] )

Prepares a query for later use with ifx_do().

For "select-type" queries a cursor is declared and opened. Non-select queries are "execute immediate".

For either query type the number of (estimated or real) affected rows is saved for retrieval by ifx_affected_rows().

If the contents of the TEXT (or BYTE) column allow it, you can also use ifx_textasvarchar(1) and ifx_byteasvarchar(1). This allows you to treat TEXT (or BYTE) columns just as if they were ordinary (but long) VARCHAR columns for select queries, and you don't need to bother with blob id's.

With ifx_textasvarchar(0) or ifx_byteasvarchar(0) (the default situation), select queries will return BLOB columns as blob id's (integer value). You can get the value of the blob as a string or file with the blob functions (see below).

Seznam parametrů

query

The query string.

link_identifier

The link identifier.

cursor_def

This optional parameter allows you to make this a scroll and/or hold cursor. It's a bitmask and can be either IFX_SCROLL, IFX_HOLD, or both or'ed together.

blobidarray

If you have BLOB (BYTE or TEXT) columns in the query, you can add a blobidarray parameter containing the corresponding "blob ids", and you should replace those columns with a "?" in the query text.

Návratové hodnoty

Returns a valid result identifier for use by ifx_do(), or FALSE on errors.

Viz také

ifx_do()

Předcházející | Nahoru | Další
ifx_pconnect | Domů | ifx_query


ifx_query

(No version information available, might be only in CVS)

ifx_query — Send Informix query

Popis

resource ifx_query ( string $query, resource $link_identifier [, int $cursor_type [, mixed $blobidarray]] )

Sends a query to the currently active database on the server that's associated with the specified link identifier.

For "select-type" queries a cursor is declared and opened. Non-select queries are "execute immediate".

For either query type the number of (estimated or real) affected rows is saved for retrieval by ifx_affected_rows().

If the contents of the TEXT (or BYTE) column allow it, you can also use ifx_textasvarchar(1) and ifx_byteasvarchar(1). This allows you to treat TEXT (or BYTE) columns just as if they were ordinary (but long) VARCHAR columns for select queries, and you don't need to bother with blob id's.

With ifx_textasvarchar(0) or ifx_byteasvarchar(0) (the default situation), select queries will return BLOB columns as blob id's (integer value). You can get the value of the blob as a string or file with the blob functions (see below).

Seznam parametrů

query

The query string.

link_identifier

The link identifier.

cursor_def

This optional parameter allows you to make this a scroll and/or hold cursor. It's a bitmask and can be either IFX_SCROLL, IFX_HOLD, or both or'ed together. I you omit this parameter the cursor is a normal sequential cursor.

blobidarray

If you have BLOB (BYTE or TEXT) columns in the query, you can add a blobidarray parameter containing the corresponding "blob ids", and you should replace those columns with a "?" in the query text.

Návratové hodnoty

Returns valid Informix result identifier on success, or FALSE on errors.

Příklady

Příklad 929. Show all rows of the "orders" table as a HTML table

<?php
ifx_textasvarchar(1);      // use "text mode" for blobs
$res_id = ifx_query("select * from orders", $conn_id);
if (! $res_id) {
    printf("Can't select orders : %s\n<br />%s<br />\n", ifx_error(), ifx_errormsg());
    die;
}
ifx_htmltbl_result($res_id, "border=\"1\"");
ifx_free_result($res_id);
?>

Příklad 930. Insert some values into the "catalog" table

<?php

// create blob id's for a byte and text column
$textid = ifx_create_blob(0, 0, "Text column in memory");
$byteid = ifx_create_blob(1, 0, "Byte column in memory");

// store blob id's in a blobid array
$blobidarray[] = $textid;
$blobidarray[] = $byteid;

// launch query
$query = "insert into catalog (stock_num, manu_code, " .
         "cat_descr,cat_picture) values(1,'HRO',?,?)";
$res_id = ifx_query($query, $conn_id, $blobidarray);
if (! $res_id) {
    /* ... error ... */
}

// free result id
ifx_free_result($res_id);
?>

Viz také

ifx_connect()

Předcházející | Nahoru | Další
ifx_prepare | Domů | ifx_textasvarchar


ifx_textasvarchar

(No version information available, might be only in CVS)

ifx_textasvarchar — Set the default text mode

Popis

bool ifx_textasvarchar ( int $mode )

Sets the default text mode for all select-queries.

Seznam parametrů

mode

Mode "0" will return a blob id, and mode "1" will return a varchar with text content.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ifx_bytesasvarchar()

Předcházející | Nahoru | Další
ifx_query | Domů | ifx_update_blob


ifx_update_blob

(No version information available, might be only in CVS)

ifx_update_blob — Updates the content of the blob object

Popis

bool ifx_update_blob ( int $bid, string $content )

Updates the content of the blob object for the given blob object bid.

Seznam parametrů

bid

A BLOB object identifier.

content

The new data, as a string.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ifx_update_char()

Předcházející | Nahoru | Další
ifx_textasvarchar | Domů | ifx_update_char


ifx_update_char

(No version information available, might be only in CVS)

ifx_update_char — Updates the content of the char object

Popis

bool ifx_update_char ( int $bid, string $content )

Updates the content of the char object for the given char object bid.

Seznam parametrů

bid

A char object identifier.

content

The new data, as a string.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ifx_update_blob()

Předcházející | Nahoru | Další
ifx_update_blob | Domů | ifxus_close_slob


ifxus_close_slob

(No version information available, might be only in CVS)

ifxus_close_slob — Deletes the slob object

Popis

bool ifxus_close_slob ( int $bid )

Deletes the slob object on the given slob object-id bid.

Seznam parametrů

bid

An existing slob id.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ifxus_open_slob()

Předcházející | Nahoru | Další
ifx_update_char | Domů | ifxus_create_slob


ifxus_create_slob

(No version information available, might be only in CVS)

ifxus_create_slob — Creates an slob object and opens it

Popis

int ifxus_create_slob ( int $mode )

Creates an slob object and opens it.

Seznam parametrů

mode

A combination of IFX_LO_RDONLY, IFX_LO_WRONLY, IFX_LO_APPEND IFX_LO_RDWR, IFX_LO_BUFFER, IFX_LO_NOBUFFER.

Návratové hodnoty

Return the new slob object-id, or FALSE on errors.

Viz také

ifxus_close_slob()
ifxus_free_slob()

Předcházející | Nahoru | Další
ifxus_close_slob | Domů | ifxus_free_slob


ifxus_free_slob

(No version information available, might be only in CVS)

ifxus_free_slob — Deletes the slob object

Popis

bool ifxus_free_slob ( int $bid )

Deletes the slob object.

Seznam parametrů

bid

An existing slob id.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ifxus_close_slob()

Předcházející | Nahoru | Další
ifxus_create_slob | Domů | ifxus_open_slob


ifxus_open_slob

(No version information available, might be only in CVS)

ifxus_open_slob — Opens an slob object

Popis

int ifxus_open_slob ( int $bid, int $mode )

Opens an slob object. bid should be an existing slob id.

Seznam parametrů

bid

An existing slob id.

mode

A combination of IFX_LO_RDONLY, IFX_LO_WRONLY, IFX_LO_APPEND IFX_LO_RDWR, IFX_LO_BUFFER, IFX_LO_NOBUFFER.

Návratové hodnoty

Returns the new slob object-id, or FALSE on errors.

Viz také

ifxus_close_slob()
ifxus_free_slob()

Předcházející | Nahoru | Další
ifxus_free_slob | Domů | ifxus_read_slob


ifxus_read_slob

(No version information available, might be only in CVS)

ifxus_read_slob — Reads nbytes of the slob object

Popis

string ifxus_read_slob ( int $bid, int $nbytes )

Reads nbytes of the slob object.

Seznam parametrů

bid

An existing slob id.

nbytes

The number of bytes to read.

Návratové hodnoty

Returns the slob contents as a string, or FALSE on errors.

Viz také

ifxus_write_slob()

Předcházející | Nahoru | Další
ifxus_open_slob | Domů | ifxus_seek_slob


ifxus_seek_slob

(No version information available, might be only in CVS)

ifxus_seek_slob — Sets the current file or seek position

Popis

int ifxus_seek_slob ( int $bid, int $mode, int $offset )

Sets the current file or seek position of an open slob object.

Seznam parametrů

bid

An existing slob id.

mode

0 = LO_SEEK_SET, 1 = LO_SEEK_CUR, 2 = LO_SEEK_END.

offset

A byte offset.

Návratové hodnoty

Returns the seek position as an integer, or FALSE on errors.

Viz také

ifxus_tell_slob()

Předcházející | Nahoru | Další
ifxus_read_slob | Domů | ifxus_tell_slob


ifxus_tell_slob

(No version information available, might be only in CVS)

ifxus_tell_slob — Returns the current file or seek position

Popis

int ifxus_tell_slob ( int $bid )

Returns the current file or seek position of an open slob object

Seznam parametrů

bid

An existing slob id.

Návratové hodnoty

Returns the seek position as an integer, or FALSE on errors.

Viz také

ifxus_seek_slob()

Předcházející | Nahoru | Další
ifxus_seek_slob | Domů | ifxus_write_slob


ifxus_write_slob

(No version information available, might be only in CVS)

ifxus_write_slob — Writes a string into the slob object

Popis

int ifxus_write_slob ( int $bid, string $content )

Writes a string into the slob object.

Seznam parametrů

bid

An existing slob id.

content

The content to write, as a string.

Návratové hodnoty

Returns the bytes written as an integer, or FALSE on errors.

Viz také

ifxus_read_slob()

Předcházející | Nahoru | Další
ifxus_tell_slob | Domů | LXIX. Informix Functions (PDO_INFORMIX)


Firebird/InterBase Functions

Předcházející VI. Reference funkcí Další

XLIII. Firebird/InterBase Functions

Úvod

Firebird/InterBase is a relational database offering many ANSI SQL-92 features that runs on Linux, Windows, and a variety of Unix platforms. Firebird/InterBase offers excellent concurrency, high performance, and powerful language support for stored procedures and triggers. It has been used in production systems, under a variety of names since 1981.

InterBase is the name of the closed-source variant of this RDBMS that was developed by Borland/Inprise. More information about InterBase is available at » http://www.borland.com/interbase/.

Firebird is a commercially independent project of C and C++ programmers, technical advisors and supporters developing and enhancing a multi-platform relational database management system based on the source code released by Inprise Corp (now known as Borland Software Corp) under the InterBase Public License v.1.0 on 25 July, 2000. More information about Firebird is available at » http://www.firebirdsql.org/.

Poznámka: This extension supports InterBase versions 5 and up and all versions of Firebird. Support for InterBase version 5.x will be dropped in PHP 5.

This database uses a single quote (') character for escaping, a behavior similar to the Sybase database, add to your php.ini the following directive:

magic_quotes_sybase = On

Požadavky

Instalace

To enable InterBase support configure PHP --with-interbase[=DIR], where DIR is the InterBase base install directory, which defaults to /usr/interbase.

Note to Win32 Users: In order for this extension to work, there are DLL files that must be available to the Windows system PATH. See the FAQ titled "How do I add my PHP directory to the PATH on Windows" for information on how to do this. Although copying DLL files from the PHP folder into the Windows system directory also works (because the system directory is by default in the systems PATH), it is not recommended. This extension requires the following files to be in the PATH: gds32.dll

In case you installed the InterBase database server on the same machine PHP is running on, you will have this DLL already. Therefore you don't need to worry because gds32.dll will already be in the PATH.

Konfigurace běhu

Chování těchto funkcí je ovlivněno nastavením parametrů v php.ini.

Tabulka 88. InterBase configuration options

Name | Default | Changeable | Changelog
ibase.allow_persistent | "1" | PHP_INI_SYSTEM |
ibase.max_persistent | "-1" | PHP_INI_SYSTEM |
ibase.max_links | "-1" | PHP_INI_SYSTEM |
ibase.default_db | NULL | PHP_INI_SYSTEM | Available since PHP 5.0.0.
ibase.default_user | NULL | PHP_INI_ALL |
ibase.default_password | NULL | PHP_INI_ALL |
ibase.default_charset | NULL | PHP_INI_ALL | Available since PHP 5.0.0.
ibase.timestampformat | "%Y-%m-%d %H:%M:%S" | PHP_INI_ALL |
ibase.dateformat | "%Y-%m-%d" | PHP_INI_ALL |
ibase.timeformat | "%H:%M:%S" | PHP_INI_ALL |

Pro další detaily a definice konstant PHP_INI_*, viz dokumentace k ini_set().

Zde je stručný popis konfiguračních direktiv.

ibase.allow_persistent boolean

Whether to allow persistent connections to Firebird/InterBase.

ibase.max_persistent integer

The maximum number of persistent Firebird/InterBase connections per process. New connections created with ibase_pconnect() will be non-persistent if this number would be exceeded.

ibase.max_links integer

The maximum number of Firebird/InterBase connections per process, including persistent connections.

ibase.default_db string

The default database to connect to when ibase_[p]connect() is called without specifying a database name. If this value is set and SQL safe mode is enabled, no other connections than to this database will be allowed.

ibase.default_user string

The user name to use when connecting to a database if no user name is specified.

ibase.default_password string

The password to use when connecting to a database if no password is specified.

ibase.default_charset string

The character set to use when connecting to a database if no character set is specified.

ibase.timestampformat string

ibase.dateformat string

ibase.timeformat string

These directives are used to set the date and time formats that are used when returning dates and times from a result set, or when binding arguments to date and time parameters.

Typy prostředků

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

The following constants can be passed to ibase_trans() to specify transaction behaviour.

Tabulka 89. Firebird/InterBase transaction flags

Constant | Description
IBASE_DEFAULT | The default transaction settings are to be used. This default is determined by the client library, which defines it as IBASE_WRITE|IBASE_CONCURRENCY|IBASE_WAIT in most cases.
IBASE_READ | Starts a read-only transaction.
IBASE_WRITE | Starts a read-write transaction.
IBASE_CONSISTENCY | Starts a transaction with the isolation level set to 'consistency', which means the transaction cannot read from tables that are being modified by other concurrent transactions.
IBASE_CONCURRENCY | Starts a transaction with the isolation level set to 'concurrency' (or 'snapshot'), which means the transaction has access to all tables, but cannot see changes that were committed by other transactions after the transaction was started.
IBASE_COMMITTED | Starts a transaction with the isolation level set to 'read committed'. This flag should be combined with either IBASE_REC_VERSION or IBASE_REC_NO_VERSION. This isolation level allows access to changes that were committed after the transaction was started. If IBASE_REC_NO_VERSION was specified, only the latest version of a row can be read. If IBASE_REC_VERSION was specified, a row can even be read when a modification to it is pending in a concurrent transaction.
IBASE_WAIT | Indicated that a transaction should wait and retry when a conflict occurs.
IBASE_NOWAIT | Indicated that a transaction should fail immediately when a conflict occurs.

The following constants can be passed to ibase_fetch_row(), ibase_fetch_assoc() or ibase_fetch_object() to specify fetch behaviour.

Tabulka 90. Firebird/InterBase fetch flags

Constant | Description
IBASE_FETCH_BLOBS | Also available as IBASE_TEXTfor backward compatibility. Causes BLOB contents to be fetched inline, instead of being fetched as BLOB identifiers.
IBASE_FETCH_ARRAYS | Causes arrays to be fetched inline. Otherwise, array identifiers are returned. Array identifiers can only be used as arguments to INSERT operations, as no functions to handle array identifiers are currently available.
IBASE_UNIXTIME | Causes date and time fields not to be returned as strings, but as UNIX timestamps (the number of seconds since the epoch, which is 1-Jan-1970 0:00 UTC). Might be problematic if used with dates before 1970 on some systems.

The following constants are used to pass requests and options to the service
API functions (ibase_server_info(), ibase_db_info(),
ibase_backup(), ibase_restore()
and ibase_maintain_db()). Please refer to
the Firebird/InterBase manuals for the meaning of these options.

IBASE_BKP_IGNORE_CHECKSUMS
IBASE_BKP_IGNORE_LIMBO
IBASE_BKP_METADATA_ONLY
IBASE_BKP_NO_GARBAGE_COLLECT
IBASE_BKP_OLD_DESCRIPTIONS
IBASE_BKP_NON_TRANSPORTABLE
IBASE_BKP_CONVERT
Options to ibase_backup()
IBASE_RES_DEACTIVATE_IDX
IBASE_RES_NO_SHADOW
IBASE_RES_NO_VALIDITY
IBASE_RES_ONE_AT_A_TIME
IBASE_RES_REPLACE
IBASE_RES_CREATE
IBASE_RES_USE_ALL_SPACE
Options to ibase_restore()
IBASE_PRP_PAGE_BUFFERS
IBASE_PRP_SWEEP_INTERVAL
IBASE_PRP_SHUTDOWN_DB
IBASE_PRP_DENY_NEW_TRANSACTIONS
IBASE_PRP_DENY_NEW_ATTACHMENTS
IBASE_PRP_RESERVE_SPACE
IBASE_PRP_RES_USE_FULL
IBASE_PRP_RES
IBASE_PRP_WRITE_MODE
IBASE_PRP_WM_ASYNC
IBASE_PRP_WM_SYNC
IBASE_PRP_ACCESS_MODE
IBASE_PRP_AM_READONLY
IBASE_PRP_AM_READWRITE
IBASE_PRP_SET_SQL_DIALECT
IBASE_PRP_ACTIVATE
IBASE_PRP_DB_ONLINE
IBASE_RPR_CHECK_DB
IBASE_RPR_IGNORE_CHECKSUM
IBASE_RPR_KILL_SHADOWS
IBASE_RPR_MEND_DB
IBASE_RPR_VALIDATE_DB
IBASE_RPR_FULL
IBASE_RPR_SWEEP_DB
Options to ibase_maintain_db()
IBASE_STS_DATA_PAGES
IBASE_STS_DB_LOG
IBASE_STS_HDR_PAGES
IBASE_STS_IDX_PAGES
IBASE_STS_SYS_RELATIONS
Options to ibase_db_info()
IBASE_SVC_SERVER_VERSION
IBASE_SVC_IMPLEMENTATION
IBASE_SVC_GET_ENV
IBASE_SVC_GET_ENV_LOCK
IBASE_SVC_GET_ENV_MSG
IBASE_SVC_USER_DBPATH
IBASE_SVC_SVR_DB_INFO
IBASE_SVC_GET_USERS
Options to ibase_server_info()

Obsah

ibase_add_user — Add a user to a security database (only for IB6 or later)
ibase_affected_rows — Return the number of rows that were affected by the previous query
ibase_backup — Initiates a backup task in the service manager and returns immediately
ibase_blob_add — Add data into a newly created blob
ibase_blob_cancel — Cancel creating blob
ibase_blob_close — Close blob
ibase_blob_create — Create a new blob for adding data
ibase_blob_echo — Output blob contents to browser
ibase_blob_get — Get len bytes data from open blob
ibase_blob_import — Create blob, copy file in it, and close it
ibase_blob_info — Return blob length and other useful info
ibase_blob_open — Open blob for retrieving data parts
ibase_close — Close a connection to an InterBase database
ibase_commit_ret — Commit a transaction without closing it
ibase_commit — Commit a transaction
ibase_connect — Open a connection to an InterBase database
ibase_db_info — Request statistics about a database
ibase_delete_user — Delete a user from a security database (only for IB6 or later)
ibase_drop_db — Drops a database
ibase_errcode — Return an error code
ibase_errmsg — Return error messages
ibase_execute — Execute a previously prepared query
ibase_fetch_assoc — Fetch a result row from a query as an associative array
ibase_fetch_object — Get an object from a InterBase database
ibase_fetch_row — Fetch a row from an InterBase database
ibase_field_info — Get information about a field
ibase_free_event_handler — Cancels a registered event handler
ibase_free_query — Free memory allocated by a prepared query
ibase_free_result — Free a result set
ibase_gen_id — Increments the named generator and returns its new value
ibase_maintain_db — Execute a maintenance command on the database server
ibase_modify_user — Modify a user to a security database (only for IB6 or later)
ibase_name_result — Assigns a name to a result set
ibase_num_fields — Get the number of fields in a result set
ibase_num_params — Return the number of parameters in a prepared query
ibase_param_info — Return information about a parameter in a prepared query
ibase_pconnect — Open a persistent connection to an InterBase database
ibase_prepare — Prepare a query for later binding of parameter placeholders and execution
ibase_query — Execute a query on an InterBase database
ibase_restore — Initiates a restore task in the service manager and returns immediately
ibase_rollback_ret — Roll back a transaction without closing it
ibase_rollback — Roll back a transaction
ibase_server_info — Request information about a database server
ibase_service_attach — Connect to the service manager
ibase_service_detach — Disconnect from the service manager
ibase_set_event_handler — Register a callback function to be called when events are posted
ibase_timefmt — Sets the format of timestamp, date and time type columns returned from queries
ibase_trans — Begin a transaction
ibase_wait_event — Wait for an event to be posted by the database
Předcházející | Nahoru | Další
filter_var | Domů | ibase_add_user


ibase_add_user

(PHP 4 >= 4.2.0, PHP 5)

ibase_add_user — Add a user to a security database (only for IB6 or later)

Popis

bool ibase_add_user ( resource $service_handle, string $user_name, string $password [, string $first_name [, string $middle_name [, string $last_name]]] )

PHP 4 uses server, dba_user_name and dba_user_password instead of service_handle parameter.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ibase_modify_user()
ibase_delete_user()

Předcházející | Nahoru | Další
XLIII. Firebird/InterBase Functions | Domů | ibase_affected_rows


ibase_affected_rows

(PHP 5)

ibase_affected_rows — Return the number of rows that were affected by the previous query

Popis

int ibase_affected_rows ( [resource $link_identifier] )

This function returns the number of rows that were affected by the previous query (INSERT, UPDATE or DELETE) that was executed from within the specified transaction context.

Seznam parametrů

link_identifier

A transaction context. If link_identifier is a connection resource, its default transaction is used.

Návratové hodnoty

Returns the number of rows as an integer.

Viz také

ibase_query()
ibase_execute()

Předcházející | Nahoru | Další
ibase_add_user | Domů | ibase_backup


ibase_backup

(PHP 5)

ibase_backup — Initiates a backup task in the service manager and returns immediately

Popis

mixed ibase_backup ( resource $service_handle, string $source_db, string $dest_file [, int $options [, bool $verbose]] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
ibase_affected_rows | Domů | ibase_blob_add


ibase_blob_add

(PHP 4, PHP 5)

ibase_blob_add — Add data into a newly created blob

Popis

void ibase_blob_add ( resource $blob_handle, string $data )

ibase_blob_add() adds data into a blob created with ibase_blob_create().

Seznam parametrů

blob_handle

A blob handle opened with ibase_blob_create().

data

The data to be added.

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

ibase_blob_cancel()
ibase_blob_close()
ibase_blob_create()
ibase_blob_import()

Předcházející | Nahoru | Další
ibase_backup | Domů | ibase_blob_cancel


ibase_blob_cancel

(PHP 4, PHP 5)

ibase_blob_cancel — Cancel creating blob

Popis

bool ibase_blob_cancel ( resource $blob_handle )

This function will discard a BLOB if it has not yet been closed by ibase_blob_close().

Seznam parametrů

blob_handle

A BLOB handle opened with ibase_create_blob().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ibase_blob_close()
ibase_blob_create()
ibase_blob_import()

Předcházející | Nahoru | Další
ibase_blob_add | Domů | ibase_blob_close


ibase_blob_close

(PHP 4, PHP 5)

ibase_blob_close — Close blob

Popis

mixed ibase_blob_close ( resource $blob_handle )

This function closes a BLOB that has either been opened for reading by ibase_open_blob() or has been opened for writing by ibase_create_blob().

Seznam parametrů

blob_handle

A BLOB handle opened with ibase_create_blob() or ibase_open_blob().

Návratové hodnoty

If the BLOB was being read, this function returns TRUE on success, if the BLOB was being written to, this function returns a string containing the BLOB id that has been assigned to it by the database. On failure, this function returns FALSE.

Viz také

ibase_blob_cancel()
ibase_blob_open()

Předcházející | Nahoru | Další
ibase_blob_cancel | Domů | ibase_blob_create


ibase_blob_create

(PHP 4, PHP 5)

ibase_blob_create — Create a new blob for adding data

Popis

resource ibase_blob_create ( [resource $link_identifier] )

ibase_blob_create() creates a new BLOB for filling with data.

Seznam parametrů

link_identifier

An InterBase link identifier. If omitted, the last opened link is assumed.

Návratové hodnoty

Returns a BLOB handle for later use with ibase_blob_add() or FALSE on failure.

Viz také

ibase_blob_add()
ibase_blob_cancel()
ibase_blob_close()
ibase_blob_import()

Předcházející | Nahoru | Další
ibase_blob_close | Domů | ibase_blob_echo


ibase_blob_echo

(PHP 4, PHP 5)

ibase_blob_echo — Output blob contents to browser

Popis

bool ibase_blob_echo ( [resource $link_identifier, string $blob_id] )

This function opens a BLOB for reading and sends its contents directly to standard output (the browser, in most cases).

Seznam parametrů

link_identifier

An InterBase link identifier. If omitted, the last opened link is assumed.

blob_id

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ibase_blob_open()
ibase_blob_close()
ibase_blob_get()

Předcházející | Nahoru | Další
ibase_blob_create | Domů | ibase_blob_get


ibase_blob_get

(PHP 4, PHP 5)

ibase_blob_get — Get len bytes data from open blob

Popis

string ibase_blob_get ( resource $blob_handle, int $len )

This function returns at most len bytes from a BLOB that has been opened for reading by ibase_blob_open().

Poznámka: It is not possible to read from a BLOB that has been opened for writing by ibase_blob_create().

Seznam parametrů

blob_handle

A BLOB handle opened with ibase_blob_open().

len

Size of returned data.

Návratové hodnoty

Returns at most len bytes from the BLOB, or FALSE on failure.

Příklady

Příklad 536. ibase_blob_get() example

<?php
$result    = ibase_query("SELECT blob_value FROM table");
$data      = ibase_fetch_object($result);
$blob_data = ibase_blob_info($data->BLOB_VALUE);
$blob_hndl = ibase_blob_open($data->BLOB_VALUE);
echo         ibase_blob_get($blob_hndl, $blob_data[0]);
?>

Whilst this example doesn't do much more than a 'ibase_blob_echo($data->BLOB_VALUE)' would do, it does show you how to get information into a $variable to manipulate as you please.

Viz také

ibase_blob_open()
ibase_blob_close()
ibase_blob_echo()

Předcházející | Nahoru | Další
ibase_blob_echo | Domů | ibase_blob_import


ibase_blob_import

(PHP 4, PHP 5)

ibase_blob_import — Create blob, copy file in it, and close it

Popis

string ibase_blob_import ( resource $link_identifier, resource $file_handle )
string ibase_blob_import ( resource $file_handle )

This function creates a BLOB, reads an entire file into it, closes it and returns the assigned BLOB id.

Seznam parametrů

link_identifier

An InterBase link identifier. If omitted, the last opened link is assumed.

file_handle

The file handle is a handle returned by fopen().

Návratové hodnoty

Returns the BLOB id on success, or FALSE on error.

Příklady

Příklad 537. ibase_blob_import() example

<?php
$dbh = ibase_connect($host, $username, $password);
$filename = '/tmp/bar';

$fd = fopen($filename, 'r');
if ($fd) {

    $blob = ibase_blob_import($dbh, $fd);
    fclose($fd);

    if (!is_string($blob)) {
        // import failed
    } else {
        $query = "INSERT INTO foo (name, data) VALUES ('$filename', ?)";
        $prepared = ibase_prepare($dbh, $query);
        if (!ibase_execute($prepared, $blob)) {
            // record insertion failed
        }
    }
} else {
    // unable to open the data file
}
?>

Viz také

ibase_blob_add()
ibase_blob_cancel()
ibase_blob_close()
ibase_blob_create()

Předcházející | Nahoru | Další
ibase_blob_get | Domů | ibase_blob_info


ibase_blob_info

(PHP 4, PHP 5)

ibase_blob_info — Return blob length and other useful info

Popis

array ibase_blob_info ( resource $link_identifier, string $blob_id )
array ibase_blob_info ( string $blob_id )

Returns the BLOB length and other useful information.

Seznam parametrů

link_identifier

An InterBase link identifier. If omitted, the last opened link is assumed.

blob_id

A BLOB id.

Návratové hodnoty

Returns an array containing information about a BLOB. The information returned consists of the length of the BLOB, the number of segments it contains, the size of the largest segment, and whether it is a stream BLOB or a segmented BLOB.

Předcházející | Nahoru | Další
ibase_blob_import | Domů | ibase_blob_open


ibase_blob_open

(PHP 4, PHP 5)

ibase_blob_open — Open blob for retrieving data parts

Popis

resource ibase_blob_open ( resource $link_identifier, string $blob_id )
resource ibase_blob_open ( string $blob_id )

Opens an existing BLOB for reading.

Seznam parametrů

link_identifier

An InterBase link identifier. If omitted, the last opened link is assumed.

blob_id

A BLOB id.

Návratové hodnoty

Returns a BLOB handle for later use with ibase_blob_get() or FALSE on failure.

Viz také

ibase_blob_close()
ibase_blob_echo()
ibase_blob_get()

Předcházející | Nahoru | Další
ibase_blob_info | Domů | ibase_close


ibase_close

(PHP 4, PHP 5)

ibase_close — Close a connection to an InterBase database

Popis

bool ibase_close ( [resource $connection_id] )

Closes the link to an InterBase database that's associated with a connection id returned from ibase_connect(). Default transaction on link is committed, other transactions are rolled back.

Seznam parametrů

connection_id

An InterBase link identifier returned from ibase_connect(). If omitted, the last opened link is assumed.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ibase_connect()
ibase_pconnect()

Předcházející | Nahoru | Další
ibase_blob_open | Domů | ibase_commit_ret


ibase_commit_ret

(PHP 5)

ibase_commit_ret — Commit a transaction without closing it

Popis

bool ibase_commit_ret ( [resource $link_or_trans_identifier] )

Commits a transaction without closing it.

Seznam parametrů

link_or_trans_identifier

If called without an argument, this function commits the default transaction of the default link. If the argument is a connection identifier, the default transaction of the corresponding connection will be committed. If the argument is a transaction identifier, the corresponding transaction will be committed. The transaction context will be retained, so statements executed from within this transaction will not be invalidated.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
ibase_close | Domů | ibase_commit


ibase_commit

(PHP 4, PHP 5)

ibase_commit — Commit a transaction

Popis

bool ibase_commit ( [resource $link_or_trans_identifier] )

Commits a transaction.

Seznam parametrů

link_or_trans_identifier

If called without an argument, this function commits the default transaction of the default link. If the argument is a connection identifier, the default transaction of the corresponding connection will be committed. If the argument is a transaction identifier, the corresponding transaction will be committed.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
ibase_commit_ret | Domů | ibase_connect


ibase_connect

(PHP 4, PHP 5)

ibase_connect — Open a connection to an InterBase database

Popis

resource ibase_connect ( [string $database [, string $username [, string $password [, string $charset [, int $buffers [, int $dialect [, string $role [, int $sync]]]]]]]] )

Establishes a connection to an InterBase server.

In case a second call is made to ibase_connect() with the same arguments, no new link will be established, but instead, the link identifier of the already opened link will be returned. The link to the server will be closed as soon as the execution of the script ends, unless it's closed earlier by explicitly calling ibase_close().

Seznam parametrů

database

The database argument has to be a valid path to database file on the server it resides on. If the server is not local, it must be prefixed with either 'hostname:' (TCP/IP), '//hostname/' (NetBEUI) or 'hostname@' (IPX/SPX), depending on the connection protocol used.

username

The user name. Can be set with the ibase.default_user php.ini directive.

password

The password for username. Can be set with the ibase.default_password php.ini directive.

charset

charset is the default character set for a database.

buffers

buffers is the number of database buffers to allocate for the server-side cache. If 0 or omitted, server chooses its own default.

dialect

dialect selects the default SQL dialect for any statement executed within a connection, and it defaults to the highest one supported by client libraries. Functional only with InterBase 6 and up.

role

Functional only with InterBase 5 and up.

sync

Návratové hodnoty

Returns an InterBase link identifier on success, or FALSE on error.

Errors/Exceptions

If you get some error like "arithmetic exception, numeric overflow, or string truncation. Cannot transliterate character between character sets" (this occurs when you try use some character with accents) when using this and after ibase_query() you must set the character set (i.e. ISO8859_1 or your current character set).

ChangeLog (záznam změn)

Verze | Popis
4.0.0 | The buffers, dialect and role parameters were added

Příklady

Příklad 538. ibase_connect() example

<?php
$host = 'localhost:/path/to/your.gdb';

$dbh = ibase_connect($host, $username, $password);
$stmt = 'SELECT * FROM tblname';
$sth = ibase_query($dbh, $stmt);
while ($row = ibase_fetch_object($sth)) {
    echo $row->email, "\n";
}
ibase_free_result($sth);
ibase_close($dbh);
?>

Viz také

ibase_pconnect()
ibase_close()

Předcházející | Nahoru | Další
ibase_commit | Domů | ibase_db_info


ibase_db_info

(PHP 5)

ibase_db_info — Request statistics about a database

Popis

string ibase_db_info ( resource $service_handle, string $db, int $action [, int $argument] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
ibase_connect | Domů | ibase_delete_user


ibase_delete_user

(PHP 4 >= 4.2.0, PHP 5)

ibase_delete_user — Delete a user from a security database (only for IB6 or later)

Popis

bool ibase_delete_user ( resource $service_handle, string $user_name )

PHP 4 uses server, dba_user_name and dba_user_password instead of service_handle parameter.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ibase_add_user()
ibase_modify_user()

Předcházející | Nahoru | Další
ibase_db_info | Domů | ibase_drop_db


ibase_drop_db

(PHP 5)

ibase_drop_db — Drops a database

Popis

bool ibase_drop_db ( [resource $connection] )

This functions drops a database that was opened by either ibase_connect() or ibase_pconnect(). The database is closed and deleted from the server.

Seznam parametrů

connection

An InterBase link identifier. If omitted, the last opened link is assumed.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ibase_connect()
ibase_pconnect()

Předcházející | Nahoru | Další
ibase_delete_user | Domů | ibase_errcode


ibase_errcode

(PHP 5)

ibase_errcode — Return an error code

Popis

int ibase_errcode ( void )

Returns the error code that resulted from the most recent InterBase function call.

Návratové hodnoty

Returns the error code as an integer, or FALSE if no error occured.

Viz také

ibase_errmsg()

Předcházející | Nahoru | Další
ibase_drop_db | Domů | ibase_errmsg


ibase_errmsg

(PHP 4, PHP 5)

ibase_errmsg — Return error messages

Popis

string ibase_errmsg ( void )

Returns the error message that resulted from the most recent InterBase function call.

Návratové hodnoty

Returns the error message as a string, or FALSE if no error occured.

Viz také

ibase_errcode()

Předcházející | Nahoru | Další
ibase_errcode | Domů | ibase_execute


ibase_execute

(PHP 4, PHP 5)

ibase_execute — Execute a previously prepared query

Popis

resource ibase_execute ( resource $query [, mixed $bind_arg [, mixed $...]] )

Execute a query prepared by ibase_prepare().

This is a lot more effective than using ibase_query() if you are repeating a same kind of query several times with only some parameters changing.

Seznam parametrů

query

An InterBase query prepared by ibase_prepare().

bind_arg

...

Návratové hodnoty

If the query raises an error, returns FALSE. If it is successful and there is a (possibly empty) result set (such as with a SELECT query), returns a result identifier. If the query was successful and there were no results, returns TRUE.

Poznámka: In PHP 5.0.0 and up, this function returns the number of rows affected by the query (if > 0 and applicable to the statement type). A query that succeeded, but did not affect any rows (e.g. an UPDATE of a non-existent record) will return TRUE.

Příklady

Příklad 539. ibase_execute() example

<?php

$dbh = ibase_connect($host, $username, $password);

$updates = array(
    1 => 'Eric',
    5 => 'Filip',
    7 => 'Larry'
);

$query = ibase_prepare($dbh, "UPDATE FOO SET BAR = ? WHERE BAZ = ?");

foreach ($updates as $baz => $bar) {
    ibase_execute($query, $bar, $baz);
}

?>

Viz také

ibase_query()

Předcházející | Nahoru | Další
ibase_errmsg | Domů | ibase_fetch_assoc


ibase_fetch_assoc

(PHP 4 >= 4.3.0, PHP 5)

ibase_fetch_assoc — Fetch a result row from a query as an associative array

Popis

array ibase_fetch_assoc ( resource $result [, int $fetch_flag] )

Fetch a result row from a query as an associative array.

ibase_fetch_assoc() fetches one row of data from the result. If two or more columns of the result have the same field names, the last column will take precedence. To access the other column(s) of the same name, you either need to access the result with numeric indices by using ibase_fetch_row() or use alias names in your query.

Seznam parametrů

result

The result handle.

fetch_flag

fetch_flag is a combination of the constants IBASE_TEXT and IBASE_UNIXTIME ORed together. Passing IBASE_TEXT will cause this function to return BLOB contents instead of BLOB ids. Passing IBASE_UNIXTIME will cause this function to return date/time values as Unix timestamps instead of as formatted strings.

Návratové hodnoty

Returns an associative array that corresponds to the fetched row. Subsequent calls will return the next row in the result set, or FALSE if there are no more rows.

Viz také

ibase_fetch_row()
ibase_fetch_object()

Předcházející | Nahoru | Další
ibase_execute | Domů | ibase_fetch_object


ibase_fetch_object

(PHP 4, PHP 5)

ibase_fetch_object — Get an object from a InterBase database

Popis

object ibase_fetch_object ( resource $result_id [, int $fetch_flag] )

Fetches a row as a pseudo-object from a given result identifier.

Subsequent calls to ibase_fetch_object() return the next row in the result set.

Seznam parametrů

result_id

An InterBase result identifier obtained either by ibase_query() or ibase_execute().

fetch_flag

fetch_flag is a combination of the constants IBASE_TEXT and IBASE_UNIXTIME ORed together. Passing IBASE_TEXT will cause this function to return BLOB contents instead of BLOB ids. Passing IBASE_UNIXTIME will cause this function to return date/time values as Unix timestamps instead of as formatted strings.

Návratové hodnoty

Returns an object with the next row information, or FALSE if there are no more rows.

Příklady

Příklad 540. ibase_fetch_object() example

<?php
$dbh = ibase_connect($host, $username, $password);
$stmt = 'SELECT * FROM tblname';
$sth = ibase_query($dbh, $stmt);
while ($row = ibase_fetch_object($sth)) {
    echo $row->email . "\n";
}
ibase_close($dbh);
?>

Viz také

ibase_fetch_row()
ibase_fetch_assoc()

Předcházející | Nahoru | Další
ibase_fetch_assoc | Domů | ibase_fetch_row


ibase_fetch_row

(PHP 4, PHP 5)

ibase_fetch_row — Fetch a row from an InterBase database

Popis

array ibase_fetch_row ( resource $result_identifier [, int $fetch_flag] )

ibase_fetch_row() fetches one row of data from the given result set.

Subsequent calls to ibase_fetch_row() return the next row in the result set, or FALSE if there are no more rows.

Seznam parametrů

result_identifier

An InterBase result identifier.

fetch_flag

fetch_flag is a combination of the constants IBASE_TEXT and IBASE_UNIXTIME ORed together. Passing IBASE_TEXT will cause this function to return BLOB contents instead of BLOB ids. Passing IBASE_UNIXTIME will cause this function to return date/time values as Unix timestamps instead of as formatted strings.

Návratové hodnoty

Returns an array that corresponds to the fetched row, or FALSE if there are no more rows. Each result column is stored in an array offset, starting at offset 0.

Viz také

ibase_fetch_assoc()
ibase_fetch_object()

Předcházející | Nahoru | Další
ibase_fetch_object | Domů | ibase_field_info


ibase_field_info

(PHP 4, PHP 5)

ibase_field_info — Get information about a field

Popis

array ibase_field_info ( resource $result, int $field_number )

Returns an array with information about a field after a select query has been run.

Seznam parametrů

result

An InterBase result identifier.

field_number

Field offset.

Návratové hodnoty

Returns an array with the following keys: name, alias, relation, length and type.

Příklady

Příklad 541. ibase_field_info() example

<?php
$rs = ibase_query("SELECT * FROM tablename");
$coln = ibase_num_fields($rs);
for ($i = 0; $i < $coln; $i++) {
    $col_info = ibase_field_info($rs, $i);
    echo "name: ". $col_info['name']. "\n";
    echo "alias: ". $col_info['alias']. "\n";
    echo "relation: ". $col_info['relation']. "\n";
    echo "length: ". $col_info['length']. "\n";
    echo "type: ". $col_info['type']. "\n";
}
?>

Viz také

ibase_num_fields()

Předcházející | Nahoru | Další
ibase_fetch_row | Domů | ibase_free_event_handler


ibase_free_event_handler

(PHP 5)

ibase_free_event_handler — Cancels a registered event handler

Popis

bool ibase_free_event_handler ( resource $event )

This function causes the registered event handler specified by event to be cancelled. The callback function will no longer be called for the events it was registered to handle.

Seznam parametrů

event

An event resource, created by ibase_set_event_handler().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ibase_set_event_handler()

Předcházející | Nahoru | Další
ibase_field_info | Domů | ibase_free_query


ibase_free_query

(PHP 4, PHP 5)

ibase_free_query — Free memory allocated by a prepared query

Popis

bool ibase_free_query ( resource $query )

Frees a prepared query.

Seznam parametrů

query

A query prepared with ibase_prepare().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
ibase_free_event_handler | Domů | ibase_free_result


ibase_free_result

(PHP 4, PHP 5)

ibase_free_result — Free a result set

Popis

bool ibase_free_result ( resource $result_identifier )

Frees a result set.

Seznam parametrů

result_identifier

A result set created by ibase_query() or ibase_execute().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
ibase_free_query | Domů | ibase_gen_id


ibase_gen_id

(PHP 5)

ibase_gen_id — Increments the named generator and returns its new value

Popis

mixed ibase_gen_id ( string $generator [, int $increment [, resource $link_identifier]] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Návratové hodnoty

Returns new generator value as integer, or as string if the value is too big.

Předcházející | Nahoru | Další
ibase_free_result | Domů | ibase_maintain_db


ibase_maintain_db

(PHP 5)

ibase_maintain_db — Execute a maintenance command on the database server

Popis

bool ibase_maintain_db ( resource $service_handle, string $db, int $action [, int $argument] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
ibase_gen_id | Domů | ibase_modify_user


ibase_modify_user

(PHP 4 >= 4.2.0, PHP 5)

ibase_modify_user — Modify a user to a security database (only for IB6 or later)

Popis

bool ibase_modify_user ( resource $service_handle, string $user_name, string $password [, string $first_name [, string $middle_name [, string $last_name]]] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

PHP 4 uses server, dba_user_name and dba_user_password instead of service_handle parameter.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ibase_add_user()
ibase_delete_user()

Předcházející | Nahoru | Další
ibase_maintain_db | Domů | ibase_name_result


ibase_name_result

(PHP 5)

ibase_name_result — Assigns a name to a result set

Popis

bool ibase_name_result ( resource $result, string $name )

This function assigns a name to a result set. This name can be used later in UPDATE|DELETE ... WHERE CURRENT OF name statements.

Seznam parametrů

result

An InterBase result set.

name

Tbe name to be assigned.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 542. ibase_name_result() example

<?php
$result = ibase_query("SELECT field1,field2 FROM table FOR UPDATE");
ibase_name_result($result, "my_cursor");

$updateqry = ibase_prepare("UPDATE table SET field2 = ? WHERE CURRENT OF my_cursor");

for ($i = 0; ibase_fetch_row($result); ++$i) {
    ibase_execute($updateqry, $i);
}
?>

Viz také

ibase_prepare()
ibase_execute()

Předcházející | Nahoru | Další
ibase_modify_user | Domů | ibase_num_fields


ibase_num_fields

(PHP 4, PHP 5)

ibase_num_fields — Get the number of fields in a result set

Popis

int ibase_num_fields ( resource $result_id )

Get the number of fields in a result set.

Seznam parametrů

result_id

An InterBase result identifier.

Návratové hodnoty

Returns the number of fields as an integer.

Příklady

Příklad 543. ibase_num_fields() example

<?php
$rs = ibase_query("SELECT * FROM tablename");
$coln = ibase_num_fields($rs);
for ($i = 0; $i < $coln; $i++) {
    $col_info = ibase_field_info($rs, $i);
    echo "name: " . $col_info['name'] . "\n";
    echo "alias: " . $col_info['alias'] . "\n";
    echo "relation: " . $col_info['relation'] . "\n";
    echo "length: " . $col_info['length'] . "\n";
    echo "type: " . $col_info['type'] . "\n";
}
?>

Viz také

ibase_field_info()

Předcházející | Nahoru | Další
ibase_name_result | Domů | ibase_num_params


ibase_num_params

(PHP 5)

ibase_num_params — Return the number of parameters in a prepared query

Popis

int ibase_num_params ( resource $query )

This function returns the number of parameters in the prepared query specified by query. This is the number of binding arguments that must be present when calling ibase_execute().

Seznam parametrů

query

The prepared query handle.

Návratové hodnoty

Returns the number of parameters as an integer.

Viz také

ibase_prepare()
ibase_param_info()

Předcházející | Nahoru | Další
ibase_num_fields | Domů | ibase_param_info


ibase_param_info

(PHP 5)

ibase_param_info — Return information about a parameter in a prepared query

Popis

array ibase_param_info ( resource $query, int $param_number )

Returns an array with information about a parameter after a query has been prepared.

Seznam parametrů

query

An InterBase prepared query handle.

param_number

Parameter offset.

Návratové hodnoty

Returns an array with the following keys: name, alias, relation, length and type.

Viz také

ibase_field_info()
ibase_num_params()

Předcházející | Nahoru | Další
ibase_num_params | Domů | ibase_pconnect


ibase_pconnect

(PHP 4, PHP 5)

ibase_pconnect — Open a persistent connection to an InterBase database

Popis

resource ibase_pconnect ( [string $database [, string $username [, string $password [, string $charset [, int $buffers [, int $dialect [, string $role [, int $sync]]]]]]]] )

Opens a persistent connection to an InterBase database.

ibase_pconnect() acts very much like ibase_connect() with two major differences.

First, when connecting, the function will first try to find a (persistent) link that's already opened with the same parameters. If one is found, an identifier for it will be returned instead of opening a new connection.

Second, the connection to the InterBase server will not be closed when the execution of the script ends. Instead, the link will remain open for future use (ibase_close() will not close links established by ibase_pconnect()). This type of link is therefore called 'persistent'.

Seznam parametrů

database

The database argument has to be a valid path to database file on the server it resides on. If the server is not local, it must be prefixed with either 'hostname:' (TCP/IP), '//hostname/' (NetBEUI) or 'hostname@' (IPX/SPX), depending on the connection protocol used.

username

The user name. Can be set with the ibase.default_user php.ini directive.

password

The password for username. Can be set with the ibase.default_password php.ini directive.

charset

charset is the default character set for a database.

buffers

buffers is the number of database buffers to allocate for the server-side cache. If 0 or omitted, server chooses its own default.

dialect

dialect selects the default SQL dialect for any statement executed within a connection, and it defaults to the highest one supported by client libraries. Functional only with InterBase 6 and up.

role

Functional only with InterBase 5 and up.

sync

Návratové hodnoty

Returns an InterBase link identifier on success, or FALSE on error.

ChangeLog (záznam změn)

Verze | Popis
4.0.0 | The buffers, dialect and role parameters were added

Viz také

ibase_close()
ibase_connect()

Předcházející | Nahoru | Další
ibase_param_info | Domů | ibase_prepare


ibase_prepare

(PHP 4, PHP 5)

ibase_prepare — Prepare a query for later binding of parameter placeholders and execution

Popis

resource ibase_prepare ( string $query )
resource ibase_prepare ( resource $link_identifier, string $query )
resource ibase_prepare ( resource $link_identifier, string $trans, string $query )

Prepare a query for later binding of parameter placeholders and execution (via ibase_execute()).

Seznam parametrů

query

An InterBase query.

Návratové hodnoty

Returns a prepared query handle, or FALSE on error.

Předcházející | Nahoru | Další
ibase_pconnect | Domů | ibase_query


ibase_query

(PHP 4, PHP 5)

ibase_query — Execute a query on an InterBase database

Popis

resource ibase_query ( [resource $link_identifier, string $query [, int $bind_args]] )

Performs a query on an InterBase database.

Seznam parametrů

link_identifier

An InterBase link identifier. If omitted, the last opened link is assumed.

query

An InterBase query.

bind_args

Návratové hodnoty

If the query raises an error, returns FALSE. If it is successful and there is a (possibly empty) result set (such as with a SELECT query), returns a result identifier. If the query was successful and there were no results, returns TRUE.

Poznámka: In PHP 5.0.0 and up, this function will return the number of rows affected by the query for INSERT, UPDATE and DELETE statements. In order to retain backward compatibility, it will return TRUE for these statements if the query succeeded without affecting any rows.

Errors/Exceptions

If you get some error like "arithmetic exception, numeric overflow, or string truncation. Cannot transliterate character between character sets" (this occurs when you try use some character with accents) when using this and after ibase_query() you must set the character set (i.e. ISO8859_1 or your current character set).

Příklady

Příklad 544. ibase_query() example

<?php

$host = 'localhost:/path/to/your.gdb';

$dbh = ibase_connect($host, $username, $password);
$stmt = 'SELECT * FROM tblname';

$sth = ibase_query($dbh, $stmt) or die(ibase_errmsg());

?>

Viz také

ibase_errmsg()
ibase_fetch_row()
ibase_fetch_object()
ibase_free_result()

Předcházející | Nahoru | Další
ibase_prepare | Domů | ibase_restore


ibase_restore

(PHP 5)

ibase_restore — Initiates a restore task in the service manager and returns immediately

Popis

mixed ibase_restore ( resource $service_handle, string $source_file, string $dest_db [, int $options [, bool $verbose]] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
ibase_query | Domů | ibase_rollback_ret


ibase_rollback_ret

(PHP 5)

ibase_rollback_ret — Roll back a transaction without closing it

Popis

bool ibase_rollback_ret ( [resource $link_or_trans_identifier] )

Rolls back a transaction without closing it.

Seznam parametrů

link_or_trans_identifier

If called without an argument, this function rolls back the default transaction of the default link. If the argument is a connection identifier, the default transaction of the corresponding connection will be rolled back. If the argument is a transaction identifier, the corresponding transaction will be rolled back. The transaction context will be retained, so statements executed from within this transaction will not be invalidated.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
ibase_restore | Domů | ibase_rollback


ibase_rollback

(PHP 4, PHP 5)

ibase_rollback — Roll back a transaction

Popis

bool ibase_rollback ( [resource $link_or_trans_identifier] )

Rolls back a transaction.

Seznam parametrů

link_or_trans_identifier

If called without an argument, this function rolls back the default transaction of the default link. If the argument is a connection identifier, the default transaction of the corresponding connection will be rolled back. If the argument is a transaction identifier, the corresponding transaction will be rolled back.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
ibase_rollback_ret | Domů | ibase_server_info


ibase_server_info

(PHP 5)

ibase_server_info — Request information about a database server

Popis

string ibase_server_info ( resource $service_handle, int $action )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
ibase_rollback | Domů | ibase_service_attach


ibase_service_attach

(PHP 5)

ibase_service_attach — Connect to the service manager

Popis

resource ibase_service_attach ( string $host, string $dba_username, string $dba_password )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
ibase_server_info | Domů | ibase_service_detach


ibase_service_detach

(PHP 5)

ibase_service_detach — Disconnect from the service manager

Popis

bool ibase_service_detach ( resource $service_handle )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
ibase_service_attach | Domů | ibase_set_event_handler


ibase_set_event_handler

(PHP 5)

ibase_set_event_handler — Register a callback function to be called when events are posted

Popis

resource ibase_set_event_handler ( callback $event_handler, string $event_name1 [, string $event_name2 [, string $...]] )
resource ibase_set_event_handler ( resource $connection, callback $event_handler, string $event_name1 [, string $event_name2 [, string $...]] )

This function registers a PHP user function as event handler for the specified events.

Seznam parametrů

event_handler

The callback is called with the event name and the link resource as arguments whenever one of the specified events is posted by the database.

The callback must return FALSE if the event handler should be canceled. Any other return value is ignored. This function accepts up to 15 event arguments.

event_name1

An event name.

event_name2

...

Návratové hodnoty

The return value is an event resource. This resource can be used to free the event handler using ibase_free_event_handler().

Příklady

Příklad 545. ibase_set_event_handler() example

<?php

function event_handler($event_name, $link)
{
    if ($event_name == "NEW ORDER") {
        // process new order
        ibase_query($link, "UPDATE orders SET status='handled'");
    } else if ($event_name == "DB_SHUTDOWN") {
        // free event handler
        return false;
    }
}

ibase_set_event_handler($link, "event_handler", "NEW_ORDER", "DB_SHUTDOWN");
?>

Viz také

ibase_free_event_handler()
ibase_wait_event()

Předcházející | Nahoru | Další
ibase_service_detach | Domů | ibase_timefmt


ibase_timefmt

(PHP 4)

ibase_timefmt — Sets the format of timestamp, date and time type columns returned from queries

Popis

bool ibase_timefmt ( string $format [, int $columntype] )

Sets the format of timestamp, date or time type columns returned from queries.

You can set defaults for these formats with the PHP configuration directives ibase.timestampformat, ibase.dateformat and ibase.timeformat.

Poznámka: This function has been removed from PHP 5, use ini_set() instead.

Seznam parametrů

format

Internally, the columns are formatted by c-function strftime(), so refer to its documentation regarding to the format of the string.

columntype

columntype is one of the constants IBASE_TIMESTAMP, IBASE_DATE and IBASE_TIME. If omitted, defaults to IBASE_TIMESTAMP for backwards compatibility.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 546. ibase_timefmt() example

<?php
/* InterBase 6 TIME-type columns will be returned in
 * the form '05 hours 37 minutes'. */
ibase_timefmt("%H hours %M minutes", IBASE_TIME);
?>

Předcházející | Nahoru | Další
ibase_set_event_handler | Domů | ibase_trans


ibase_trans

(PHP 4, PHP 5)

ibase_trans — Begin a transaction

Popis

resource ibase_trans ( [int $trans_args [, resource $link_identifier]] )

Begins a transaction.

Poznámka: The behaviour of this function has been changed in PHP 5.0.0. The first call to ibase_trans() will not return the default transaction of a connection. All transactions started by ibase_trans() will be rolled back at the end of the script if they were not committed or rolled back by either ibase_commit() or ibase_rollback().

Poznámka: In PHP 5.0.0. and up, this function will accept multiple trans_args and link_identifier arguments. This allows transactions over multiple database connections, which are committed using a 2-phase commit algorithm. This means you can rely on the updates to either succeed in every database, or fail in every database. It does NOT mean you can use tables from different databases in the same query!

If you use transactions over multiple databases, you will have to specify both the link_id and transaction_id in calls to ibase_query() and ibase_prepare().

Seznam parametrů

trans_args

trans_args can be a combination of IBASE_READ, IBASE_WRITE, IBASE_COMMITTED, IBASE_CONSISTENCY, IBASE_CONCURRENCY, IBASE_REC_VERSION, IBASE_REC_NO_VERSION, IBASE_WAIT and IBASE_NOWAIT.

link_identifier

An InterBase link identifier. If omitted, the last opened link is assumed.

Návratové hodnoty

Returns a transaction handle, or FALSE on error.

Předcházející | Nahoru | Další
ibase_timefmt | Domů | ibase_wait_event


ibase_wait_event

(PHP 5)

ibase_wait_event — Wait for an event to be posted by the database

Popis

string ibase_wait_event ( string $event_name1 [, string $event_name2 [, string $...]] )
string ibase_wait_event ( resource $connection, string $event_name1 [, string $event_name2 [, string $...]] )

This function suspends execution of the script until one of the specified events is posted by the database. The name of the event that was posted is returned. This function accepts up to 15 event arguments.

Seznam parametrů

event_name1

The event name.

event_name2

...

Návratové hodnoty

Returns the name of the event that was posted.

Viz také

ibase_set_event_handler()
ibase_free_event_handler()

Předcházející | Nahoru | Další
ibase_trans | Domů | XLIV. Firebird/Interbase Functions (PDO_FIREBIRD)


ID3 Functions

Předcházející VI. Reference funkcí Další

LXIII. ID3 Functions

Úvod

These functions let you read and manipulate ID3 tags. ID3 tags are used in MP3 files to store title of the song, as well as information about the artist, album, genre, year and track number.

Since version 0.2 it is also possible to extract text frames from ID3 v2.2+ tags.

Požadavky

Tyto funkce jsou k dispozici jako součást standardního modulu, který je vždy dostupný.

Instalace

id3 is part of PECL and can be installed using the PEAR installer. To compile PHP with id3 support, download the sourcecode, put it in php-src/ext/id3 and compile PHP using --enable-id3.

Konfigurace běhu

Toto rozšíření nemá definováno žádné konfigurační direktivy.

Typy prostředků

Toto rozšíření nemá definován žádný typ prostředku (resource).

Predefined Constants

Most of the id3 functions either let you specify or return a tag version. In order to specify the version please use on of these constants.

ID3_V1_0 (integer)
ID3_V1_0 is used if you are working with ID3 V1.0 tags. These tags may contain the fields title, artist, album, genre, year and comment.
ID3_V1_1 (integer)
ID3_V1_1 is used if you are working with ID3 V1.1 tags. These tags may all information contained in v1.0 tags plus the track number.
ID3_V2_1 (integer)
ID3_V2_1 is used if you are working with ID3 V2.1 tags.
ID3_V2_2 (integer)
ID3_V2_2 is used if you are working with ID3 V2.2 tags.
ID3_V2_3 (integer)
ID3_V2_3 is used if you are working with ID3 V2.3 tags.
ID3_V2_4 (integer)
ID3_V2_4 is used if you are working with ID3 V2.4 tags.
ID3_BEST (integer)
ID3_BEST is used if would like to let the id3 functions determine which tag version should be used.

Obsah

id3_get_frame_long_name — Get the long name of an ID3v2 frame
id3_get_frame_short_name — Get the short name of an ID3v2 frame
id3_get_genre_id — Get the id for a genre
id3_get_genre_list — Get all possible genre values
id3_get_genre_name — Get the name for a genre id
id3_get_tag — Get all information stored in an ID3 tag
id3_get_version — Get version of an ID3 tag
id3_remove_tag — Remove an existing ID3 tag
id3_set_tag — Update information stored in an ID3 tag
Předcházející | Nahoru | Další
ob_iconv_handler | Domů | id3_get_frame_long_name


id3_get_genre_id

(PECL id3:0.1-0.2)

id3_get_genre_id — Get the id for a genre

Popis

int id3_get_genre_id ( string $genre )

id3_get_genre_id() returns the id for a genre.

Seznam parametrů

genre

An integer ranging from 0 to 147

Návratové hodnoty

The genre id or FALSE on errors.

Příklady

Příklad 821. id3_get_genre_id() example

<?php
$id = id3_get_genre_id("Alternative");
echo $id;
?>

Výše uvedený příklad vypíše:

20

Viz také

id3_get_genre_name()
id3_get_genre_list()

Předcházející | Nahoru | Další
id3_get_frame_short_name | Domů | id3_get_genre_list


id3_get_genre_list

(PECL id3:0.1-0.2)

id3_get_genre_list — Get all possible genre values

Popis

array id3_get_genre_list ( void )

id3_get_genre_list() returns an array containing all possible genres that may be stored in an ID3 tag. This list has been created by Eric Kemp and later extended by WinAmp.

This function is useful to provide you users a list of genres from which they may choose one. When updating the ID3 tag you will always have to specify the genre as an integer ranging from 0 to 147.

Návratové hodnoty

Returns an array containing all possible genres that may be stored in an ID3 tag.

Příklady

Příklad 822. id3_get_genre_list() example

<?php
$genres = id3_get_genre_list();
print_r($genres);
?>

Výše uvedený příklad vypíše:

Array
(
    [0] => Blues
    [1] => Classic Rock
    [2] => Country
    [3] => Dance
    [4] => Disco
    [5] => Funk
    [6] => Grunge
    [7] => Hip-Hop
    [8] => Jazz
    [9] => Metal
    [10] => New Age
    [11] => Oldies
    [12] => Other
    [13] => Pop
    [14] => R&B
    [15] => Rap
    [16] => Reggae
    [17] => Rock
    [18] => Techno
    [19] => Industrial
    [20] => Alternative
    [21] => Ska
    [22] => Death Metal
    [23] => Pranks
    [24] => Soundtrack
    [25] => Euro-Techno
    [26] => Ambient
    [27] => Trip-Hop
    [28] => Vocal
    [29] => Jazz+Funk
    [30] => Fusion
    [31] => Trance
    [32] => Classical
    [33] => Instrumental
    [34] => Acid
    [35] => House
    [36] => Game
    [37] => Sound Clip
    [38] => Gospel
    [39] => Noise
    [40] => Alternative Rock
    [41] => Bass
    [42] => Soul
    [43] => Punk
    [44] => Space
    [45] => Meditative
    [46] => Instrumental Pop
    [47] => Instrumental Rock
    [48] => Ethnic
    [49] => Gothic
    [50] => Darkwave
    [51] => Techno-Industrial
    [52] => Electronic
    [53] => Pop-Folk
    [54] => Eurodance
    [55] => Dream
    [56] => Southern Rock
    [57] => Comedy
    [58] => Cult
    [59] => Gangsta
    [60] => Top 40
    [61] => Christian Rap
    [62] => Pop/Funk
    [63] => Jungle
    [64] => Native US
    [65] => Cabaret
    [66] => New Wave
    [67] => Psychadelic
    [68] => Rave
    [69] => Showtunes
    [70] => Trailer
    [71] => Lo-Fi
    [72] => Tribal
    [73] => Acid Punk
    [74] => Acid Jazz
    [75] => Polka
    [76] => Retro
    [77] => Musical
    [78] => Rock & Roll
    [79] => Hard Rock
    [80] => Folk
    [81] => Folk-Rock
    [82] => National Folk
    [83] => Swing
    [84] => Fast Fusion
    [85] => Bebob
    [86] => Latin
    [87] => Revival
    [88] => Celtic
    [89] => Bluegrass
    [90] => Avantgarde
    [91] => Gothic Rock
    [92] => Progressive Rock
    [93] => Psychedelic Rock
    [94] => Symphonic Rock
    [95] => Slow Rock
    [96] => Big Band
    [97] => Chorus
    [98] => Easy Listening
    [99] => Acoustic
    [100] => Humour
    [101] => Speech
    [102] => Chanson
    [103] => Opera
    [104] => Chamber Music
    [105] => Sonata
    [106] => Symphony
    [107] => Booty Bass
    [108] => Primus
    [109] => Porn Groove
    [110] => Satire
    [111] => Slow Jam
    [112] => Club
    [113] => Tango
    [114] => Samba
    [115] => Folklore
    [116] => Ballad
    [117] => Power Ballad
    [118] => Rhytmic Soul
    [119] => Freestyle
    [120] => Duet
    [121] => Punk Rock
    [122] => Drum Solo
    [123] => Acapella
    [124] => Euro-House
    [125] => Dance Hall
    [126] => Goa
    [127] => Drum & Bass
    [128] => Club-House
    [129] => Hardcore
    [130] => Terror
    [131] => Indie
    [132] => BritPop
    [133] => Negerpunk
    [134] => Polsk Punk
    [135] => Beat
    [136] => Christian Gangsta
    [137] => Heavy Metal
    [138] => Black Metal
    [139] => Crossover
    [140] => Contemporary C
    [141] => Christian Rock
    [142] => Merengue
    [143] => Salsa
    [144] => Thrash Metal
    [145] => Anime
    [146] => JPop
    [147] => SynthPop
)

Viz také

id3_get_genre_name()
id3_get_genre_id()

Předcházející | Nahoru | Další
id3_get_genre_id | Domů | id3_get_genre_name


id3_get_genre_name

(PECL id3:0.1-0.2)

id3_get_genre_name — Get the name for a genre id

Popis

string id3_get_genre_name ( int $genre_id )

id3_get_genre_name() returns the name for a genre id.

Seznam parametrů

genre_id

An integer ranging from 0 to 147

Návratové hodnoty

Returns the name as a string.

Příklady

Příklad 823. id3_get_genre_name() example

<?php
$genre = id3_get_genre_name(20);
echo $genre;
?>

Výše uvedený příklad vypíše:

Alternative

Viz také

id3_get_genre_list()
id3_get_genre_id()

Předcházející | Nahoru | Další
id3_get_genre_list | Domů | id3_get_tag


id3_get_tag

(PECL id3:0.1-0.2)

id3_get_tag — Get all information stored in an ID3 tag

Popis

array id3_get_tag ( string $filename [, int $version] )

id3_get_tag() is used to get all information stored in the id3 tag of the specified file.

Seznam parametrů

filename

The path to the MP3 file

Instead of a filename you may also pass a valid stream resource

version

Allows you to specify the version of the tag as MP3 files may contain both, version 1.x and version 2.x tags

Since version 0.2 id3_get_tag() also supports ID3 tags of version 2.2, 2.3 and 2.4. To extract information from these tags, pass one of the constants ID3_V2_2, ID3_V2_3 or ID3_V2_4 as the second parameter. ID3 v2.x tags can contain a lot more information about the MP3 file than ID3 v1.x tags.

Návratové hodnoty

Returns an associative array with various keys like: title, artist, ..

The key genre will contain an integer between 0 and 147. You may use id3_get_genre_name() to convert it to a human readable string.

Příklady

Příklad 824. id3_get_tag() example

<?php
$tag = id3_get_tag( "path/to/example.mp3" );
print_r($tag);
?>

Výše uvedený příklad vypíše něco jako:

Array
(
    [title] => DN-38416
    [artist] => Re:\Legion
    [album] => Reflections
    [year] => 2004
    [genre] => 19
)

Příklad 825. id3_get_tag() example

<?php
$tag = id3_get_tag( "path/to/example2.mp3", ID3_V2_3 );
print_r($tag);
?>

Výše uvedený příklad vypíše něco jako:

Array
(
    [copyright] => Dirty Mac
    [originalArtist] => Dirty Mac
    [composer] => Marcus Götze
    [artist] => Dirty Mac
    [title] => Little Big Man
    [album] => Demo-Tape
    [track] => 5/12
    [genre] => (17)Rock
    [year] => 2001
)

Viz také

id3_set_tag()
id3_remove_tag()
id3_get_version()

Předcházející | Nahoru | Další
id3_get_genre_name | Domů | id3_get_version


id3_get_version

(PECL id3:0.1-0.2)

id3_get_version — Get version of an ID3 tag

Popis

int id3_get_version ( string $filename )

id3_get_version() retrieves the version(s) of the ID3 tag(s) in the MP3 file.

If a file contains an ID3 v1.1 tag, it always contains a 1.0 tag, as version 1.1 is just an extension of 1.0.

Seznam parametrů

filename

The path to the MP3 file

Instead of a filename you may also pass a valid stream resource

Návratové hodnoty

Returns the version number of the ID3 tag of the file. As a tag can contain ID3 v1.x and v2.x tags, the return value of this function should be bitwise compared with the predefined constants ID3_V1_0, ID3_V1_1 and ID3_V2.

Příklady

Příklad 826. id3_get_version() example

<?php
$version = id3_get_version( "path/to/example.mp3" );
if ($version & ID3_V1_0) {
    echo "Contains a 1.x tag\n";
}
if ($version & ID3_V1_1) {
    echo "Contains a 1.1 tag\n";
}
if ($version & ID3_V2) {
    echo "Contains a 2.x tag\n";
}
?>

Výše uvedený příklad vypíše něco jako:

Contains a 1.x tag
Contains a 1.1 tag

Viz také

id3_set_tag()
id3_get_tag()
id3_remove_tag()

Předcházející | Nahoru | Další
id3_get_tag | Domů | id3_remove_tag


id3_remove_tag

(PECL id3:0.1-0.2)

id3_remove_tag — Remove an existing ID3 tag

Popis

bool id3_remove_tag ( string $filename [, int $version] )

id3_remove_tag() is used to remove the information stored of an ID3 tag.

Seznam parametrů

filename

The path to the MP3 file

Instead of a filename you may also pass a valid stream resource

version

Allows you to specify the version of the tag as MP3 files may contain both, version 1.x and version 2.x tags.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 827. id3_remove_tag() example

<?php
$result = id3_remove_tag( "path/to/example.mp3", ID3_V1_0 );
if ($result === true) {
    echo "Tag succesfully removed\n";
}
?>

If the file is writable and contained a 1.0 tag, this will output:

Tag succesfully removed

Poznámky

Poznámka: Currently id3_remove_tag() only supports version 1.0 and 1.1. If you choose to remove a 1.0 tag and the file contains a 1.1 tag, this tag will be removed, as v1.1 is only an extension of 1.0.

Viz také

id3_set_tag()
id3_get_tag()
id3_get_version()

Předcházející | Nahoru | Další
id3_get_version | Domů | id3_set_tag


id3_set_tag

(PECL id3:0.1-0.2)

id3_set_tag — Update information stored in an ID3 tag

Popis

bool id3_set_tag ( string $filename, array $tag [, int $version] )

id3_set_tag() is used to change the information stored of an ID3 tag. If no tag has been present, it will be added to the file.

Seznam parametrů

filename

The path to the MP3 file

Instead of a filename you may also pass a valid stream resource

tag

An associative array of tag keys and values

The following keys may be used in the associative array:

Tabulka 126. Keys in the associative array

key | possible value | available in version
title | string with maximum of 30 characters | v1.0, v1.1
artist | string with maximum of 30 characters | v1.0, v1.1
album | string with maximum of 30 characters | v1.0, v1.1
year | 4 digits | v1.0, v1.1
genre | integer value between 0 and 147 | v1.0, v1.1
comment | string with maximum of 30 characters (28 in v1.1) | v1.0, v1.1
track | integer between 0 and 255 | v1.1

version

Allows you to specify the version of the tag as MP3 files may contain both, version 1.x and version 2.x tags

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 828. id3_set_tag() example

<?php
$data = array(
              "title" => "Re:Start",
              "artist" => "Re:\Legion",
              "comment" => "A nice track"
             );
$result = id3_set_tag( "path/to/example.mp3", $data, ID3_V1_0 );
if ($result === true) {
    echo "Tag succesfully updated\n";
}
?>

If the file is writable, this will output:

Tag succesfully updated

Poznámky

Poznámka: Currently id3_remove_tag() only supports version 1.0 and 1.1.

Viz také

id3_remove_tag()
id3_get_tag()
id3_get_version()

Předcházející | Nahoru | Další
id3_remove_tag | Domů | LXIV. IIS Administration Functions


Ingres II Functions

Předcházející VI. Reference funkcí Další

LXX. Ingres II Functions

Úvod

These functions allow you to access Ingres II database servers.

Poznámka: If you already used PHP extensions to access other database servers, note that Ingres doesn't allow concurrent queries and/or transaction over one connection, thus you won't find any result or transaction handle in this extension. The result of a query must be treated before sending another query, and a transaction must be committed or rolled back before opening another transaction (which is automatically done when sending the first query).

Požadavky

To compile PHP with Ingres support, you need the Ingres OpenAPI library and header files.

Instalace

Toto rozšíření » PECL není přibaleno k PHP. Informace o instalaci tohoto PECL rozšíření lze najít v kapitole manuálu nazvané Instalace rozšíření PECL. Další informace, jako nové verze, soubory ke stažení, zdrojové soubory, správcovské informace a CHANGELOG, lze najít zde: » http://pecl.php.net/package/ingres.

In order to have these functions available, you must compile PHP with Ingres support by using the --with-ingres[=DIR] option, where DIR is the Ingres base directory, which defaults to /II/ingres. If the II_SYSTEM environment variable isn't correctly set you may have to use --with-ingres=DIR to specify your Ingres installation directory.

When using this extension with Apache, if Apache does not start and complains with "PHP Fatal error: Unable to start ingres_ii module in Unknown on line 0" then make sure the environment variable II_SYSTEM is correctly set. Adding "export II_SYSTEM="/home/ingres/II" in the script that starts Apache, just before launching httpd, should be fine.

Konfigurace běhu

Chování těchto funkcí je ovlivněno nastavením parametrů v php.ini.

Tabulka 142. Ingres configuration options

Name | Default | Changeable | Changelog
ingres.allow_persistent | "1" | PHP_INI_SYSTEM | Available since PHP 4.0.2. Removed in PHP 5.1.0.
ingres.max_persistent | "-1" | PHP_INI_SYSTEM | Available since PHP 4.0.2. Removed in PHP 5.1.0.
ingres.max_links | "-1" | PHP_INI_SYSTEM | Available since PHP 4.0.2. Removed in PHP 5.1.0.
ingres.default_database | NULL | PHP_INI_ALL | Available since PHP 4.0.2. Removed in PHP 5.1.0.
ingres.default_user | NULL | PHP_INI_ALL | Available since PHP 4.0.2. Removed in PHP 5.1.0.
ingres.default_password | NULL | PHP_INI_ALL | Available since PHP 4.0.2. Removed in PHP 5.1.0.
ingres.report_db_warnings | "1" | PHP_INI_ALL | Available since ingres 1.1.
ingres.cursor_mode | "0" | PHP_INI_ALL | Available since ingres 1.1.
ingres.blob_segment_length | "4096" | PHP_INI_ALL | Available since ingres 1.2.0.
ingres.trace_connect | "0" | PHP_INI_ALL | Available since ingres 1.2.1.
ingres.timeout | "-1" | PHP_INI_ALL | Available since ingres 1.4.0.
ingres.array_index_start | "1" | PHP_INI_ALL | Available since ingres 1.4.0.

Pro další detaily a definice konstant PHP_INI_*, viz dokumentace k ini_set().

Typy prostředků

ingres_connect() and ingres_pconnect() return an Ingres II link identifier.

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

INGRES_ASSOC (integer)
Columns are returned into the array having the fieldname as the array index.
INGRES_NUM (integer)
Columns are returned into the array having a numerical index to the fields. This index starts with 1, the first field in the result.
INGRES_BOTH (integer)
Columns are returned into the array having both a numerical index and the fieldname as the array index.
INGRES_EXT_VERSION (string)
Specifies the version of the Ingres Extension. Available since version 1.2.0 of the PECL extension.
INGRES_API_VERSION (integer)
Specifies the version of Ingres OpenAPI the extension was built against. Available since version 1.2.0 of the PECL extension.
INGRES_CURSOR_READONLY (integer)
Specifies that Ingres cursors should be opened in 'readonly' mode. Available since version 1.2.0 of the PECL extension.
INGRES_CURSOR_UPDATE (integer)
Specifies that Ingres cursors should be opened 'for update'. Available since version 1.2.0 of the PECL extension.
INGRES_DATE_MULTINATIONAL (integer)
Equivalent to the II_DATE_FORMAT setting of MULTINATIONAL. Available since version 1.2.0 of the PECL extension.
INGRES_DATE_MULTINATIONAL4 (integer)
Equivalent to the II_DATE_FORMAT setting of MULTINATIONAL4. Available since version 1.2.0 of the PECL extension.
INGRES_DATE_FINNISH (integer)
Equivalent to the II_DATE_FORMAT setting of FINNISH. Available since version 1.2.0 of the PECL extension.
INGRES_DATE_ISO (integer)
Equivalent to the II_DATE_FORMAT setting of ISO. Available since version 1.2.0 of the PECL extension.
INGRES_DATE_ISO4 (integer)
Equivalent to the II_DATE_FORMAT setting of ISO4. Available since version 1.2.0 of the PECL extension.
INGRES_DATE_GERMAN (integer)
Equivalent to the II_DATE_FORMAT setting of GERMAN. Available since version 1.2.0 of the PECL extension.
INGRES_DATE_MDY (integer)
Equivalent to the II_DATE_FORMAT setting of MDY. Available since version 1.2.0 of the PECL extension.
INGRES_DATE_DMY (integer)
Equivalent to the II_DATE_FORMAT setting of DMY. Available since version 1.2.0 of the PECL extension.
INGRES_DATE_YMD (integer)
Equivalent to the II_DATE_FORMAT setting of YMD. Available since version 1.2.0 of the PECL extension.
INGRES_MONEY_LEADING (integer)
Specifies the currency character that should be placed at the start of a money value. Equivalent to setting II_MONEY_FORMAT to 'L:'. Available since version 1.2.0 of the PECL extension.
INGRES_MONEY_TRAILING (integer)
Specifies the currency character that should be placed at the end of a money value. Equivalent to setting II_MONEY_FORMAT to 'T:'. Available since version 1.2.0 of the PECL extension.
INGRES_STRUCTURE_BTREE (integer)
Specifies the default table or index structure to BTREE when used in combination with the table_structure or index_structure option when connecting. Available since version 1.4.0 of the PECL extension.
INGRES_STRUCTURE_CBTREE (integer)
Specifies the default table or index structure to COMPRESSED BTREE when used in combination with the table_structure or index_structure option when connecting. Available since version 1.4.0 of the PECL extension.
INGRES_STRUCTURE_HASH (integer)
Specifies the default table or index structure to HASH when used in combination with the table_structure or index_structure option when connecting. Available since version 1.4.0 of the PECL extension.
INGRES_STRUCTURE_CHASH (integer)
Specifies the default table or index structure to COMPRESSED HASH when used in combination with the table_structure or index_structure option when connecting. Available since version 1.4.0 of the PECL extension.
INGRES_STRUCTURE_HEAP (integer)
Specifies the default table structure to HEAP when used in combination with the table_structure option when connecting. Available since version 1.4.0 of the PECL extension.
INGRES_STRUCTURE_CHEAP (integer)
Specifies the default table structure to COMPRESSED HEAP when used in combination with the table_structure option when connecting. Available since version 1.4.0 of the PECL extension.
INGRES_STRUCTURE_ISAM (integer)
Specifies the default table or index structure to ISAM when used in combination with the table_structure or index_structure option when connecting. Available since version 1.4.0 of the PECL extension.
INGRES_STRUCTURE_CISAM (integer)
Specifies the default table or index structure to COMPRESSED ISAM when used in combination with the table_structure or index_structure option when connecting. Available since version 1.4.0 of the PECL extension.

Příklady

This simple example shows how to connect, execute a query, print resulting rows and disconnect from an Ingres database.

Příklad 933. Simple Ingres Example

<?php
// Connecting, selecting database
$link = ingres_connect('database', 'user', 'password')
    or die('Could not connect: ' . ingres_error($link));
echo 'Connected successfully';

// Select from a table that exists in all Ingres databases
$query = 'SELECT * FROM iirelation';
$returncode = ingres_query($query,$link) or die('Query failed: ' .
ingres_error($link));

// Print results in HTML
// relid - table name
// relowner - table owner
echo "<table>\n";
while ($iirelation = ingres_fetch_object(INGRES_BOTH, $link)) {
    echo "\t<tr>\n";
    echo "\t\t<td>" . $iirelation->relid . "</td>\n";
    echo "\t\t<td>" . $iirelation->relowner . "</td>\n";
    echo "\t</tr>\n";
}
echo "</table>\n";

// Commit transaction
ingres_commit($link);
// Closing connection
ingres_close($link);
?>

Obsah

ingres_autocommit — Switch autocommit on or off
ingres_close — Close an Ingres II database connection
ingres_commit — Commit a transaction
ingres_connect — Open a connection to an Ingres database
ingres_cursor — Gets a cursor name for a given link resource
ingres_errno — Gets the last ingres error number generated
ingres_error — Gets a meaningful error message for the last error generated
ingres_errsqlstate — Gets the last SQLSTATE error code generated
ingres_fetch_array — Fetch a row of result into an array
ingres_fetch_object — Fetch a row of result into an object
ingres_fetch_row — Fetch a row of result into an enumerated array
ingres_field_length — Get the length of a field
ingres_field_name — Get the name of a field in a query result
ingres_field_nullable — Test if a field is nullable
ingres_field_precision — Get the precision of a field
ingres_field_scale — Get the scale of a field
ingres_field_type — Get the type of a field in a query result
ingres_num_fields — Get the number of fields returned by the last query
ingres_num_rows — Get the number of rows affected or returned by the last query
ingres_pconnect — Open a persistent connection to an Ingres II database
ingres_query — Send a SQL query to Ingres II
ingres_rollback — Roll back a transaction
Předcházející | Nahoru | Další
PDO_INFORMIX DSN | Domů | ingres_autocommit


ingres_autocommit

(PHP 4 >= 4.0.2, PHP 5 <= 5.0.5, PECL ingres:1.0-1.4.3)

ingres_autocommit — Switch autocommit on or off

Popis

bool ingres_autocommit ( [resource $link] )

ingres_autocommit() is called before opening a transaction (before the first call to ingres_query() or just after a call to ingres_rollback() or ingres_commit()) to switch the "autocommit" mode of the server on or off (when the script begins the autocommit mode is off).

When the autocommit mode is on, every query is automatically committed by the server, as if ingres_commit() was called after every call to ingres_query().

Seznam parametrů

link

The connection link identifier. If not specified, the last opened link is used.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ingres_query()
ingres_rollback()
ingres_commit()

Předcházející | Nahoru | Další
LXX. Ingres II Functions | Domů | ingres_close


ingres_close

(PHP 4 >= 4.0.2, PHP 5 <= 5.0.5, PECL ingres:1.0-1.4.3)

ingres_close — Close an Ingres II database connection

Popis

bool ingres_close ( [resource $link] )

ingres_close() closes the connection to the Ingres server that's associated with the specified link.

ingres_close() isn't usually necessary, as it won't close persistent connections and all non-persistent connections are automatically closed at the end of the script.

Seznam parametrů

link

The connection link identifier. If not specified, the last opened link is used.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ingres_connect()
ingres_pconnect()

Předcházející | Nahoru | Další
ingres_autocommit | Domů | ingres_commit


ingres_commit

(PHP 4 >= 4.0.2, PHP 5 <= 5.0.5, PECL ingres:1.0-1.4.3)

ingres_commit — Commit a transaction

Popis

bool ingres_commit ( [resource $link] )

ingres_commit() commits the currently open transaction, making all changes made to the database permanent.

This closes the transaction. A new one can be open by sending a query with ingres_query().

You can also have the server commit automatically after every query by calling ingres_autocommit() before opening the transaction.

Seznam parametrů

link

The connection link identifier. If not specified, the last opened link is used.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ingres_query()
ingres_rollback()
ingres_autocommit()

Předcházející | Nahoru | Další
ingres_close | Domů | ingres_connect


ingres_connect

(PHP 4 >= 4.0.2, PHP 5 <= 5.0.5, PECL ingres:1.0-1.4.3)

ingres_connect — Open a connection to an Ingres database

Popis

resource ingres_connect ( [string $database [, string $username [, string $password [, array $options]]]] )

ingres_connect() opens a connection with the given Ingres database.

The connection is closed when the script ends or when ingres_close() is called on this link.

All the other ingres functions use the last opened link as a default, so you need to store the returned value only if you use more than one link at a time.

Seznam parametrů

If some parameters are missing, ingres_connect() uses the values in php.ini for ingres.default_database, ingres.default_user and ingres.default_password.

database

The database name. Must follows the syntax [node_id::]dbname[/svr_class].

username

The Ingres user name.

password

The password associated with username.

options

ingres_connect() options

Option name | Description
date_century_boundary | The threshold by which a 2 digit year is determined to be in the current century or in the next century. Equivalent to II_DATE_CENTURY_BOUNDARY.
group | Speficfies the group ID of the user, equivalent to the '-G' flag
role | The role ID of the application. If a role password is required, the parameter value should be specified as "role/password"
effective_user | The ingres user account being impersonated, equivalent to the '-u' flag
dbms_password | The internal database password for the user connecting to Ingres
table_structure

The default structure for new tables. Valid values for table_structure are:

  • INGRES_STRUCTURE_BTREE
  • INGRES_STRUCTURE_HASH
  • INGRES_STRUCTURE_HEAP
  • INGRES_STRUCTURE_ISAM
  • INGRES_STRUCTURE_CBTREE
  • INGRES_STRUCTURE_CISAM
  • INGRES_STRUCTURE_CHASH
  • INGRES_STRUCTURE_CHEAP

index_structure

The default structure for new secondary indexes. Valid values for index_structure are:

  • INGRES_STRUCTURE_CBTREE
  • INGRES_STRUCTURE_CISAM
  • INGRES_STRUCTURE_CHASH
  • INGRES_STRUCTURE_BTREE
  • INGRES_STRUCTURE_HASH
  • INGRES_STRUCTURE_ISAM

login_local | Determines how the connection user ID and password are used when a VNODE is included in the target database string. If set to TRUE, the user ID and password are used to locally access the VNODE and the VNODE login information is used to establish the DBMS connection. If set to FALSE, the process user ID is used to access the VNODE and the connection user ID and password are used in place of the VNODE login information to establish the DBMS connection. This parameter is ignored if no VNODE is included in the target database string. The default is FALSE.
timezone | Controls the timezone of the session. If not set it will default the the value defined by II_TIMEZONE_NAME. If II_TIMEZONE_NAME is not defined the NA-PACIFIC (GMT-8 with Daylight Savings) is used.
date_format

Sets the allowable input and output format for Ingres dates. Defaults to the value defined by II_DATE_FORMAT. If II_DATE_FORMAT is not set the default date format is US, e.g. mm/dd/yy. Valid values for date_format are:

  • INGRES_DATE_DMY
  • INGRES_DATE_FINISH
  • INGRES_DATE_GERMAN
  • INGRES_DATE_ISO
  • INGRES_DATE_ISO4
  • INGRES_DATE_MDY
  • INGRES_DATE_MULTINATIONAL
  • INGRES_DATE_MULTINATIONAL4
  • INGRES_DATE_YMD
  • INGRES_DATE_US

decimal_separator | The character identifier for decimal data
money_lort

Leading or trailing currency sign. Valid values for money_lort are:

  • INGRES_MONEY_LEADING
  • INGRES_MONEY_TRAILING

money_sign | The currency symbol to be used with the MONEY datatype
money_precision | The precision of the MONEY datatype
float4_precision | Precision of the FLOAT4 datatype
float8_precision | Precision of the FLOAT8 data
blob_segment_length | The amount of data in bytes to fetch at a time when retrieving BLOB/CLOB data, defaults to 4096 bytes when not explicitly set.

Návratové hodnoty

Returns a Ingres link resource on success, or FALSE on failure.

Příklady

Příklad 934. ingres_connect() example

<?php
$link = ingres_connect("mydb", "user", "pass")
    or die("Could not connect");
echo "Connected successfully";
ingres_close($link);
?>

Příklad 935. ingres_connect() example using default link

<?php
ingres_connect("mydb", "user", "pass")
    or die("Could not connect");
echo "Connected successfully";
ingres_close();
?>

Viz také

ingres_pconnect()
ingres_close()

Předcházející | Nahoru | Další
ingres_commit | Domů | ingres_cursor


ingres_fetch_array

(PHP 4 >= 4.0.2, PHP 5 <= 5.0.5, PECL ingres:1.0-1.4.3)

ingres_fetch_array — Fetch a row of result into an array

Popis

array ingres_fetch_array ( [int $result_type [, resource $link]] )

This function is an extended version of ingres_fetch_row(). In addition to storing the data in the numeric indices of the result array, it also stores the data in associative indices, using the field names as keys.

If two or more columns of the result have the same field names, the last column will take precedence. To access the other column(s) of the same name, you must use the numeric index of the column or make an alias for the column.

<?php

ingres_query("select t1.f1 as foo t2.f1 as bar from t1, t2");
$result = ingres_fetch_array();
$foo = $result["foo"];
$bar = $result["bar"];

?>

Speed-wise, the function is identical to ingres_fetch_object(), and almost as quick as ingres_fetch_row() (the difference is insignificant).

Seznam parametrů

result_type

result_type can be INGRES_NUM for enumerated array, INGRES_ASSOC for associative array, or INGRES_BOTH (default).

link

The connection link identifier. If not specified, the last opened link is used.

Návratové hodnoty

Returns an array that corresponds to the fetched row, or FALSE if there are no more rows.

Příklady

Příklad 940. ingres_fetch_array() example

<?php
ingres_connect($database, $user, $password);

ingres_query("select * from table");
while ($row = ingres_fetch_array()) {
    echo $row["user_id"];  // using associative array
    echo $row["fullname"];
    echo $row[1];          // using enumerated array
    echo $row[2];
}
?>

Viz také

ingres_query()
ingres_num_fields()
ingres_field_name()
ingres_fetch_object()
ingres_fetch_row()

Předcházející | Nahoru | Další
ingres_errsqlstate | Domů | ingres_fetch_object


ingres_fetch_object

(PHP 4 >= 4.0.2, PHP 5 <= 5.0.5, PECL ingres:1.0-1.4.3)

ingres_fetch_object — Fetch a row of result into an object

Popis

object ingres_fetch_object ( [int $result_type [, resource $link]] )

This function is similar to ingres_fetch_array(), with one difference - an object is returned, instead of an array. Indirectly, that means that you can only access the data by the field names, and not by their offsets (numbers are illegal property names).

Speed-wise, the function is identical to ingres_fetch_array(), and almost as quick as ingres_fetch_row() (the difference is insignificant).

Seznam parametrů

result_type

The optional argument result_type is a constant and can take the following values: INGRES_ASSOC, INGRES_NUM, and INGRES_BOTH.

link

The connection link identifier. If not specified, the last opened link is used.

Návratové hodnoty

Returns an object that corresponds to the fetched row, or FALSE if there are no more rows.

Příklady

Příklad 941. ingres_fetch_object() example

<?php
ingres_connect($database, $user, $password);
ingres_query("select * from table");
while ($row = ingres_fetch_object()) {
    echo $row->user_id;
    echo $row->fullname;
}
?>

Viz také

ingres_query()
ingres_num_fields()
ingres_field_name()
ingres_fetch_array()
ingres_fetch_row()

Předcházející | Nahoru | Další
ingres_fetch_array | Domů | ingres_fetch_row


ingres_fetch_row

(PHP 4 >= 4.0.2, PHP 5 <= 5.0.5, PECL ingres:1.0-1.4.3)

ingres_fetch_row — Fetch a row of result into an enumerated array

Popis

array ingres_fetch_row ( [resource $link] )

ingres_fetch_row() returns an array that corresponds to the fetched row, or FALSE if there are no more rows. Each result column is stored in an array offset, starting at offset 1.

Subsequent call to ingres_fetch_row() would return the next row in the result set, or FALSE if there are no more rows.

Seznam parametrů

link

The connection link identifier. If not specified, the last opened link is used.

Návratové hodnoty

Returns an array that corresponds to the fetched row, or FALSE if there are no more rows.

Příklady

Příklad 942. ingres_fetch_row() example

<?php
ingres_connect($database, $user, $password);

ingres_query("select * from table");
while ($row = ingres_fetch_row()) {
    echo $row[1];
    echo $row[2];
}
?>

Viz také

ingres_num_fields()
ingres_query()
ingres_fetch_array()
ingres_fetch_object()

Předcházející | Nahoru | Další
ingres_fetch_object | Domů | ingres_field_length


ingres_field_length

(PHP 4 >= 4.0.2, PHP 5 <= 5.0.5, PECL ingres:1.0-1.4.3)

ingres_field_length — Get the length of a field

Popis

int ingres_field_length ( int $index [, resource $link] )

ingres_field_length() returns the length of a field. This is the number of bytes used by the server to store the field. For detailed information, see the Ingres/OpenAPI User Guide - Appendix C.

Seznam parametrů

index

index is the number of the field and must be between 1 and the value given by ingres_num_fields().

link

The connection link identifier. If not specified, the last opened link is used.

Návratové hodnoty

Returns the length of a field.

Viz také

ingres_query()
ingres_fetch_array()
ingres_fetch_object()
ingres_fetch_row()

Předcházející | Nahoru | Další
ingres_fetch_row | Domů | ingres_field_name


ingres_field_name

(PHP 4 >= 4.0.2, PHP 5 <= 5.0.5, PECL ingres:1.0-1.4.3)

ingres_field_name — Get the name of a field in a query result

Popis

string ingres_field_name ( int $index [, resource $link] )

ingres_field_name() returns the name of a field in a query result.

Seznam parametrů

index

index is the number of the field and must be between 1 and the value given by ingres_num_fields().

link

The connection link identifier. If not specified, the last opened link is used.

Návratové hodnoty

Returns the name of a field in a query result, or FALSE on failure.

Viz také

ingres_query()
ingres_fetch_array()
ingres_fetch_object()
ingres_fetch_row()

Předcházející | Nahoru | Další
ingres_field_length | Domů | ingres_field_nullable


ingres_field_nullable

(PHP 4 >= 4.0.2, PHP 5 <= 5.0.5, PECL ingres:1.0-1.4.3)

ingres_field_nullable — Test if a field is nullable

Popis

bool ingres_field_nullable ( int $index [, resource $link] )

Test if a field is nullable.

Seznam parametrů

index

index is the number of the field and must be between 1 and the value given by ingres_num_fields().

link

The connection link identifier. If not specified, the last opened link is used.

Návratové hodnoty

ingres_field_nullable() returns TRUE if the field can be set to the NULL value and FALSE if it can't.

Viz také

ingres_query()
ingres_fetch_array()
ingres_fetch_object()
ingres_fetch_row()

Předcházející | Nahoru | Další
ingres_field_name | Domů | ingres_field_precision


ingres_field_precision

(PHP 4 >= 4.0.2, PHP 5 <= 5.0.5, PECL ingres:1.0-1.4.3)

ingres_field_precision — Get the precision of a field

Popis

int ingres_field_precision ( int $index [, resource $link] )

ingres_field_precision() returns the precision of a field. This value is used only for decimal, float and money SQL data types. For detailed information, see the Ingres/OpenAPI User Guide - Appendix C.

Seznam parametrů

index

index is the number of the field and must be between 1 and the value given by ingres_num_fields().

link

The connection link identifier. If not specified, the last opened link is used.

Návratové hodnoty

Returns the field precision as an integer.

Viz také

ingres_query()
ingres_fetch_array()
ingres_fetch_object()
ingres_fetch_row()

Předcházející | Nahoru | Další
ingres_field_nullable | Domů | ingres_field_scale


ingres_field_scale

(PHP 4 >= 4.0.2, PHP 5 <= 5.0.5, PECL ingres:1.0-1.4.3)

ingres_field_scale — Get the scale of a field

Popis

int ingres_field_scale ( int $index [, resource $link] )

ingres_field_scale() returns the scale of a field. This value is used only for the decimal SQL data type. For detailed information, see the Ingres/OpenAPI User Guide - Appendix C.

Seznam parametrů

index

index is the number of the field and must be between 1 and the value given by ingres_num_fields().

link

The connection link identifier. If not specified, the last opened link is used.

Návratové hodnoty

Returns the scale of the field, as an integer.

Viz také

ingres_query()
ingres_fetch_array()
ingres_fetch_object()
ingres_fetch_row()

Předcházející | Nahoru | Další
ingres_field_precision | Domů | ingres_field_type


ingres_field_type

(PHP 4 >= 4.0.2, PHP 5 <= 5.0.5, PECL ingres:1.0-1.4.3)

ingres_field_type — Get the type of a field in a query result

Popis

string ingres_field_type ( int $index [, resource $link] )

Get the type of a field in a query result.

Seznam parametrů

index

index is the number of the field and must be between 1 and the value given by ingres_num_fields().

link

The connection link identifier. If not specified, the last opened link is used.

Návratové hodnoty

ingres_field_type() returns the type of a field in a query result, or FALSE on failure. Examples of types returned are "IIAPI_BYTE_TYPE", "IIAPI_CHA_TYPE", "IIAPI_DTE_TYPE", "IIAPI_FLT_TYPE", "IIAPI_INT_TYPE", "IIAPI_VCH_TYPE". Some of these types can map to more than one SQL type depending on the length of the field (see ingres_field_length()). For example "IIAPI_FLT_TYPE" can be a float4 or a float8. For detailed information, see the Ingres/OpenAPI User Guide - Appendix C.

Viz také

ingres_query()
ingres_fetch_array()
ingres_fetch_object()
ingres_fetch_row()

Předcházející | Nahoru | Další
ingres_field_scale | Domů | ingres_num_fields


ingres_num_fields

(PHP 4 >= 4.0.2, PHP 5 <= 5.0.5, PECL ingres:1.0-1.4.3)

ingres_num_fields — Get the number of fields returned by the last query

Popis

int ingres_num_fields ( [resource $link] )

ingres_num_fields() returns the number of fields in the results returned by the Ingres server after a call to ingres_query()

Seznam parametrů

link

The connection link identifier. If not specified, the last opened link is used.

Návratové hodnoty

Returns the number of fields.

Viz také

ingres_query()
ingres_fetch_array()
ingres_fetch_object()
ingres_fetch_row()

Předcházející | Nahoru | Další
ingres_field_type | Domů | ingres_num_rows


ingres_num_rows

(PHP 4 >= 4.0.2, PHP 5 <= 5.0.5, PECL ingres:1.0-1.4.3)

ingres_num_rows — Get the number of rows affected or returned by the last query

Popis

int ingres_num_rows ( [resource $link] )

This function is mainly meant to get the number of rows modified in the database. If this function is called before using ingres_fetch_array(), ingres_fetch_object() or ingres_fetch_row() the server will delete the result's data and the script won't be able to get them.

You should instead retrieve the result's data using one of these fetch functions in a loop until it returns FALSE, indicating that no more results are available.

Seznam parametrů

link

The connection link identifier. If not specified, the last opened link is used.

Návratové hodnoty

For delete, insert or update queries, ingres_num_rows() returns the number of rows affected by the query. For other queries, ingres_num_rows() returns the number of rows in the query's result.

Viz také

ingres_query()
ingres_fetch_array()
ingres_fetch_object()
ingres_fetch_row()

Předcházející | Nahoru | Další
ingres_num_fields | Domů | ingres_pconnect


ingres_pconnect

(PHP 4 >= 4.0.2, PHP 5 <= 5.0.5, PECL ingres:1.0-1.4.3)

ingres_pconnect — Open a persistent connection to an Ingres II database

Popis

resource ingres_pconnect ( [string $database [, string $username [, string $password]]] )

Open a persistent connection to an Ingres II database.

There are only 2 differences between this function and ingres_connect() : First, when connecting, the function will first try to find a (persistent) link that's already opened with the same parameters. If one is found, an identifier for it will be returned instead of opening a new connection. Second, the connection to the Ingres server will not be closed when the execution of the script ends. Instead, the link will remain open for future use (ingres_close() will not close links established by ingres_pconnect()). This type of link is therefore called 'persistent'.

Seznam parametrů

database

The database name. Must follows the syntax [node_id::]dbname[/svr_class].

username

The Ingres user name.

password

The password associated with username.

Návratové hodnoty

Returns a Ingres II link resource on success, or FALSE on failure.

Viz také

ingres_connect()
ingres_close()

Předcházející | Nahoru | Další
ingres_num_rows | Domů | ingres_query


ingres_query

(PHP 4 >= 4.0.2, PHP 5 <= 5.0.5, PECL ingres:1.0-1.4.3)

ingres_query — Send a SQL query to Ingres II

Popis

bool ingres_query ( string $query [, resource $link] )

ingres_query() sends the given query to the Ingres server.

The query becomes part of the currently open transaction. If there is no open transaction, ingres_query() opens a new transaction. To close the transaction, you can either call ingres_commit() to commit the changes made to the database or ingres_rollback() to cancel these changes. When the script ends, any open transaction is rolled back (by calling ingres_rollback()). You can also use ingres_autocommit() before opening a new transaction to have every SQL query immediately committed.

Seznam parametrů

query

A valid SQL query (see the Ingres SQL reference guide).

Some types of SQL queries can't be sent with this function:

  • close (see ingres_close())
  • commit (see ingres_commit())
  • connect (see ingres_connect())
  • disconnect (see ingres_close())
  • get dbevent
  • prepare to commit
  • rollback (see ingres_rollback())
  • savepoint
  • set autocommit (see ingres_autocommit())
  • all cursor related queries are unsupported

link

The connection link identifier. If not specified, the last opened link is used.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 943. ingres_query() example

<?php
ingres_connect($database, $user, $password);

ingres_query("select * from table");
while ($row = ingres_fetch_row()) {
    echo $row[1];
    echo $row[2];
}
?>

Viz také

ingres_fetch_array()
ingres_fetch_object()
ingres_fetch_row()
ingres_commit()
ingres_rollback()
ingres_autocommit()

Předcházející | Nahoru | Další
ingres_pconnect | Domů | ingres_rollback


ingres_rollback

(PHP 4 >= 4.0.2, PHP 5 <= 5.0.5, PECL ingres:1.0-1.4.3)

ingres_rollback — Roll back a transaction

Popis

bool ingres_rollback ( [resource $link] )

ingres_rollback() rolls back the currently open transaction, actually canceling all changes made to the database during the transaction.

This closes the transaction. A new one can be open by sending a query with ingres_query().

Seznam parametrů

link

The connection link identifier. If not specified, the last opened link is used.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ingres_query()
ingres_commit()
ingres_autocommit()

Předcházející | Nahoru | Další
ingres_query | Domů | LXXI. IRC Gateway Functions


IRC Gateway Functions

Předcházející VI. Reference funkcí Další

LXXI. IRC Gateway Functions

Úvod

With IRCG you can rapidly stream XML data to thousands of concurrently connected users. This can be used to build powerful, extensible interactive platforms such as online games and webchats. IRCG also features support for a non-streaming mode where a helper application reformats incoming data and supplies static file snippets in special formats such as cHTML (i-mode) or WML (WAP). These static files are then delivered by the high-performance web server.

Up to v4, IRCG runs under these platforms:

  • AIX

  • FreeBSD

  • HP-UX

  • Irix

  • Linux

  • Solaris

  • Tru64

  • Windows

Poznámka: Toto rozšíření bylo přesunuto do repozitáře PECL a již nebude součástí balíku PHP.5.1.0.

Instalace

Detailed installation instructions can be found at » http://www.schumann.cx/ircg/. We urge you to use the provided installation script.

It is not recommended, but you can try enable IRCG support yourself. Provide the path to the ircg-config script, --with-ircg-config=path/to/irc-config and in addition add --with-ircg to your configure line.

Konfigurace běhu

Toto rozšíření nemá definováno žádné konfigurační direktivy.

Typy prostředků

Předdefinované konstanty

Toto rozšíření nemá definovány žádné konstanty.

Obsah

ircg_channel_mode — Set channel mode flags for user
ircg_disconnect — Close connection to server
ircg_eval_ecmascript_params — Decodes a list of JS-encoded parameters
ircg_fetch_error_msg — Returns the error from previous IRCG operation
ircg_get_username — Get username for connection
ircg_html_encode — Encodes HTML preserving output
ircg_ignore_add — Add a user to your ignore list on a server
ircg_ignore_del — Remove a user from your ignore list on a server
ircg_invite — Invites nickname to channel
ircg_is_conn_alive — Check connection status
ircg_join — Join a channel on a connected server
ircg_kick — Kick a user out of a channel on server
ircg_list — List topic/user count of channel(s)
ircg_lookup_format_messages — Check for the existence of a format message set
ircg_lusers — IRC network statistics
ircg_msg — Send message to channel or user on server
ircg_names — Query visible usernames
ircg_nick — Change nickname on server
ircg_nickname_escape — Encode special characters in nickname to be IRC-compliant
ircg_nickname_unescape — Decodes encoded nickname
ircg_notice — Send a notice to a user on server
ircg_oper — Elevates privileges to IRC OPER
ircg_part — Leave a channel on server
ircg_pconnect — Connect to an IRC server
ircg_register_format_messages — Register a format message set
ircg_set_current — Set current connection for output
ircg_set_file — Set logfile for connection
ircg_set_on_die — Set action to be executed when connection dies
ircg_topic — Set topic for channel on server
ircg_who — Queries server for WHO information
ircg_whois — Query server for user information
Předcházející | Nahoru | Další
ingres_rollback | Domů | ircg_channel_mode


ircg_channel_mode

(PHP 4 >= 4.0.5, PHP 5 <= 5.0.5)

ircg_channel_mode — Set channel mode flags for user

Popis

bool ircg_channel_mode ( resource $connection, string $channel, string $mode_spec, string $nick )

Set channel mode flags for channel on server connected to by connection. Mode flags are passed in mode_spec and are applied to the user specified by nick.

Seznam parametrů

connection

A connection resource handle returned by ircg_pconnect().

channel

The channel name as #name.

mode_spec

The mode to be applied on nick.

Mode flags are set or cleared by specifying a mode character and prepending it with a plus or minus character, respectively. E.g. operator mode is granted by '+o' and revoked by '-o', as passed as mode_spec.

nick

The user on which to apply the given mode.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
LXXI. IRC Gateway Functions | Domů | ircg_disconnect


ircg_disconnect

(PHP 4 >= 4.0.4, PHP 5 <= 5.0.5)

ircg_disconnect — Close connection to server

Popis

bool ircg_disconnect ( resource $connection, string $reason )

ircg_disconnect() will close a connection to a server previously established with ircg_pconnect().

Seznam parametrů

connection

A connection resource handle returned by ircg_pconnect().

reason

A message for the disconnection.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ircg_pconnect()

Předcházející | Nahoru | Další
ircg_channel_mode | Domů | ircg_eval_ecmascript_params


ircg_eval_ecmascript_params

(PHP 4 >= 4.3.0, PHP 5 <= 5.0.5)

ircg_eval_ecmascript_params — Decodes a list of JS-encoded parameters

Popis

array ircg_eval_ecmascript_params ( string $params )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

   From the ircg_eval_ecmascript_params source file:
   /*
    * State 0: Looking for ' or digit
    * State 1: Assembling parameter inside '..'
    * State 2: After escape sign: Copies single char verbatim, go to 1
    * State 3: Assembling numeric para, no quotation
    * State 4: Looking for ",", skipping whitespace
    */

Viz také

ircg_lookup_format_messages()

Předcházející | Nahoru | Další
ircg_disconnect | Domů | ircg_fetch_error_msg


ircg_fetch_error_msg

(PHP 4 >= 4.0.7, PHP 5 <= 5.0.5)

ircg_fetch_error_msg — Returns the error from previous IRCG operation

Popis

array ircg_fetch_error_msg ( resource $connection )

ircg_fetch_error_msg() returns the error from a failed connection.

Seznam parametrů

connection

A connection resource handle returned by ircg_pconnect().

Návratové hodnoty

Returns an indexed array where the error code is stored in first element, and the error text in second.

The error code is equivalent to IRC reply codes as defined by RFC 2812.

Příklady

Příklad 944. ircg_fetch_error_msg() example

<?php
if (!ircg_join ($id, "#php")) {
    $error = ircg_fetch_error_msg($id);
    echo "Can't join channel #php. Error code:
          $error[0] Description: $error[1]";
}
?>

Předcházející | Nahoru | Další
ircg_eval_ecmascript_params | Domů | ircg_get_username


ircg_get_username

(PHP 4 >= 4.0.7, PHP 5 <= 5.0.5)

ircg_get_username — Get username for connection

Popis

string ircg_get_username ( resource $connection )

ircg_get_username() returns the username for the specified connection connection.

Seznam parametrů

connection

A connection resource handle returned by ircg_pconnect().

Návratové hodnoty

Returns the username, or FALSE on error.

Předcházející | Nahoru | Další
ircg_fetch_error_msg | Domů | ircg_html_encode


ircg_html_encode

(PHP 4 >= 4.0.5, PHP 5 <= 5.0.5)

ircg_html_encode — Encodes HTML preserving output

Popis

string ircg_html_encode ( string $html_string [, bool $auto_links [, bool $conv_br]] )

Encodes a HTML string html_string for output. This exposes the interface which the IRCG extension uses internally to reformat data coming from an IRC link. The function causes IRC color/font codes to be encoded in HTML and escapes certain entities.

Seznam parametrů

html_string

The HTML string to be encoded.

auto_links

conv_br

Návratové hodnoty

Returns the encoded HTML string.

Předcházející | Nahoru | Další
ircg_get_username | Domů | ircg_ignore_add


ircg_ignore_add

(PHP 4 >= 4.0.5, PHP 5 <= 5.0.5)

ircg_ignore_add — Add a user to your ignore list on a server

Popis

void ircg_ignore_add ( resource $connection, string $nick )

This function adds user nick to the ignore list of the connection. Afterwards, IRCG will suppress all messages from this user through the associated connection.

Seznam parametrů

connection

A connection resource handle returned by ircg_pconnect().

nick

The user to be ignored.

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

ircg_ignore_del()

Předcházející | Nahoru | Další
ircg_html_encode | Domů | ircg_ignore_del


ircg_ignore_del

(PHP 4 >= 4.0.5, PHP 5 <= 5.0.5)

ircg_ignore_del — Remove a user from your ignore list on a server

Popis

bool ircg_ignore_del ( resource $connection, string $nick )

This function removes user nick from the IRCG ignore list associated with connection.

Seznam parametrů

connection

A connection resource handle returned by ircg_pconnect().

nick

The user nick name.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ircg_ignore_add()

Předcházející | Nahoru | Další
ircg_ignore_add | Domů | ircg_invite


ircg_invite

(PHP 4 >= 4.3.3, PHP 5 <= 5.0.5)

ircg_invite — Invites nickname to channel

Popis

bool ircg_invite ( resource $connection, string $channel, string $nickname )

ircg_invite() will send an invitation to the user nickname, prompting him to join the given channel.

Seznam parametrů

connection

A connection resource handle returned by ircg_pconnect().

channel

The channel name as #name.

nickname

The user nick name.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
ircg_ignore_del | Domů | ircg_is_conn_alive


ircg_is_conn_alive

(PHP 4 >= 4.0.5, PHP 5 <= 5.0.5)

ircg_is_conn_alive — Check connection status

Popis

bool ircg_is_conn_alive ( resource $connection )

ircg_is_conn_alive() checks the connection status.

Seznam parametrů

connection

A connection resource handle returned by ircg_pconnect().

Návratové hodnoty

Returns TRUE if connection is still alive and working or FALSE, if the connection has died for some reason.

Předcházející | Nahoru | Další
ircg_invite | Domů | ircg_join


ircg_join

(PHP 4 >= 4.0.4, PHP 5 <= 5.0.5)

ircg_join — Join a channel on a connected server

Popis

bool ircg_join ( resource $connection, string $channel [, string $key] )

Join the channel channel on the server connected to by connection.

Seznam parametrů

connection

A connection resource handle returned by ircg_pconnect().

channel

The channel name as #name.

key

An optional password for the room.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
ircg_is_conn_alive | Domů | ircg_kick


ircg_kick

(PHP 4 >= 4.0.5, PHP 5 <= 5.0.5)

ircg_kick — Kick a user out of a channel on server

Popis

bool ircg_kick ( resource $connection, string $channel, string $nick, string $reason )

Kick user nick from channel on server connected to by connection.

Seznam parametrů

connection

A connection resource handle returned by ircg_pconnect().

channel

The channel name as #name.

nick

The user to be kicked.

reason

reason should give a short message describing why this action was performed.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
ircg_join | Domů | ircg_list


ircg_list

(PHP 4 >= 4.3.3, PHP 5 <= 5.0.5)

ircg_list — List topic/user count of channel(s)

Popis

bool ircg_list ( resource $connection, string $channel )

ircg_list() will request a list of users in the channel. The answer is sent to the output defined by ircg_set_file() or ircg_set_current().

Seznam parametrů

connection

A connection resource handle returned by ircg_pconnect().

channel

The channel name as #name.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 945. ircg_list() example

<?php

// connect to server
$id = ircg_pconnect($nickname, $ip, $port);

// set to output to a file
ircg_set_file($id, 'irc_output.html');

// try to join a channel
if (!ircg_join($id, $channel)) {
    echo "Cannot /join $channel<br />";
}

// send list command
ircg_list($id, $channel);

// wait for output to arrive
sleep(5);

// disconnect
ircg_disconnect($id,'Bye World');

// output everything
readfile('irc_output.html');

?>

Výše uvedený příklad vypíše něco jako:

...
Channel #channel has n users and the topic is 'Topic'
End of LIST
...

Viz také

ircg_set_file()
ircg_set_current()
ircg_who()

Předcházející | Nahoru | Další
ircg_kick | Domů | ircg_lookup_format_messages


ircg_lookup_format_messages

(PHP 4 >= 4.0.5, PHP 5 <= 5.0.5)

ircg_lookup_format_messages — Check for the existence of a format message set

Popis

bool ircg_lookup_format_messages ( string $name )

Check for the existence of the format message set name. Sets may be registered with ircg_register_format_messages(), a default set named ircg is always available.

Seznam parametrů

name

The format message set name.

Návratové hodnoty

Returns TRUE if the set exists, FALSE otherwise.

Viz také

ircg_register_format_messages()

Předcházející | Nahoru | Další
ircg_list | Domů | ircg_lusers


ircg_lusers

(PHP 4 >= 4.3.3, PHP 5 <= 5.0.5)

ircg_lusers — IRC network statistics

Popis

bool ircg_lusers ( resource $connection )

ircg_lusers() will request a statistical breakdown of users on the network connected to on connection. The answer is sent to the output defined by ircg_set_file() or ircg_set_current().

Seznam parametrů

connection

A connection resource handle returned by ircg_pconnect().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ircg_set_file()
ircg_set_current()
ircg_who()

Předcházející | Nahoru | Další
ircg_lookup_format_messages | Domů | ircg_msg


ircg_msg

(PHP 4 >= 4.0.4, PHP 5 <= 5.0.5)

ircg_msg — Send message to channel or user on server

Popis

bool ircg_msg ( resource $connection, string $recipient, string $message [, bool $suppress] )

ircg_msg() will send the message to a channel or user on the server.

Seznam parametrů

connection

A connection resource handle returned by ircg_pconnect().

recipient

A recipient starting with # or & will send the message to a channel, anything else will be interpreted as a username.

message

The message to be sent.

suppress

Setting the optional parameter suppress to a TRUE value will suppress output of your message to your own connection. This so-called loopback is necessary, because the IRC server does not echo PRIVMSG commands back to us.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
ircg_lusers | Domů | ircg_names


ircg_names

(PHP 4 >= 4.3.3, PHP 5 <= 5.0.5)

ircg_names — Query visible usernames

Popis

bool ircg_names ( int $connection, string $channel [, string $target] )

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

connection

A connection resource handle returned by ircg_pconnect().

channel

The channel name as #name.

target

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ircg_get_username()
ircg_lusers()

Předcházející | Nahoru | Další
ircg_msg | Domů | ircg_nick


ircg_nick

(PHP 4 >= 4.0.5, PHP 5 <= 5.0.5)

ircg_nick — Change nickname on server

Popis

bool ircg_nick ( resource $connection, string $nick )

Change your nickname on the given connection to the specified one, if possible.

Seznam parametrů

connection

A connection resource handle returned by ircg_pconnect().

nick

The new nick name for the current user.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
ircg_names | Domů | ircg_nickname_escape


ircg_nickname_escape

(PHP 4 >= 4.0.6, PHP 5 <= 5.0.5)

ircg_nickname_escape — Encode special characters in nickname to be IRC-compliant

Popis

string ircg_nickname_escape ( string $nick )

Function ircg_nickname_escape() returns an encoded nickname specified by nick which is IRC-compliant.

Seznam parametrů

nick

Návratové hodnoty

An IRC-compliant nick name.

Viz také

ircg_nickname_unescape()

Předcházející | Nahoru | Další
ircg_nick | Domů | ircg_nickname_unescape


ircg_nickname_unescape

(PHP 4 >= 4.0.6, PHP 5 <= 5.0.5)

ircg_nickname_unescape — Decodes encoded nickname

Popis

string ircg_nickname_unescape ( string $nick )

Function ircg_nickname_unescape() returns a decoded nickname, which is specified in nick.

Seznam parametrů

nick

The encoded nick name.

Návratové hodnoty

Returns the decoded nick name.

Viz také

ircg_nickname_escape()

Předcházející | Nahoru | Další
ircg_nickname_escape | Domů | ircg_notice


ircg_notice

(PHP 4 >= 4.0.5, PHP 5 <= 5.0.5)

ircg_notice — Send a notice to a user on server

Popis

bool ircg_notice ( resource $connection, string $nick, string $message )

This function will send the message text to the user nick on the server connected to by connection. IRC servers and other software will not automatically generate replies to NOTICEs in contrast to other message types.

Seznam parametrů

connection

A connection resource handle returned by ircg_pconnect().

nick

The destination user.

message

The message contents.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
ircg_nickname_unescape | Domů | ircg_oper


ircg_oper

(PHP 4 >= 4.3.3, PHP 5 <= 5.0.5)

ircg_oper — Elevates privileges to IRC OPER

Popis

bool ircg_oper ( resource $connection, string $name, string $password )

ircg_oper() will authenticate the logged in user on connection as an IRC operator.

Seznam parametrů

connection

A connection resource handle returned by ircg_pconnect().

name

The operator account name. Must be a registered IRC account.

password

The password associated with name.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
ircg_notice | Domů | ircg_part


ircg_part

(PHP 4 >= 4.0.4, PHP 5 <= 5.0.5)

ircg_part — Leave a channel on server

Popis

bool ircg_part ( resource $connection, string $channel )

Leave the channel channel on the server connected to by connection.

Seznam parametrů

connection

A connection resource handle returned by ircg_pconnect().

channel

The channel name as #name.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
ircg_oper | Domů | ircg_pconnect


ircg_pconnect

(PHP 4 >= 4.0.4, PHP 5 <= 5.0.5)

ircg_pconnect — Connect to an IRC server

Popis

resource ircg_pconnect ( string $username [, string $server_ip [, int $server_port [, string $msg_format [, array $ctcp_messages [, array $user_settings [, bool $bailout_on_trivial]]]]]] )

ircg_pconnect() will try to establish a connection to an IRC server.

Seznam parametrů

username

The initial nickname on the server.

server_ip

The IRC server address.

server_ip must be an IP address in numerical form. DNS lookups are expensive and should be done in the context of IRCG. Default to 127.0.0.1.

server_port

The server port number. Default to 6667.

msg_format

You can customize the output of IRC messages and events by selecting a format message set previously created with ircg_register_format_messages() by specifying the set's name in msg_format.

ctcp_messages

If you want to handle CTCP messages such as ACTION (/me), you need to define a mapping from CTCP type (e.g. ACTION) to a custom format string. Do this by passing an associative array as ctcp_messages. The keys of the array are the CTCP type and the respective value is the format message.

user_settings

You can define "ident", "password", and "realname" tokens which are sent to the IRC server by setting these in this associative array.

bailout_on_trivial

Návratové hodnoty

Returns a connection resource handle for further use, or FALSE on error.

Viz také

ircg_disconnect()
ircg_is_conn_alive()
ircg_register_format_messages()

Předcházející | Nahoru | Další
ircg_part | Domů | ircg_register_format_messages


ircg_register_format_messages

(PHP 4 >= 4.0.5, PHP 5 <= 5.0.5)

ircg_register_format_messages — Register a format message set

Popis

bool ircg_register_format_messages ( string $name, array $messages )

With ircg_register_format_messages() you can customize the way your IRC output looks like or which script functions are invoked on the client side.

Seznam parametrů

name

messages

  • Plain channel message
  • Private message received
  • Private message sent
  • Some user leaves channel
  • Some user enters channel
  • Some user was kicked from the channel
  • Topic has been changed
  • Error
  • Fatal error
  • Join list end(?)
  • Self part(?)
  • Some user changes his nick
  • Some user quits his connection
  • Mass join begin
  • Mass join element
  • Mass join end
  • Whois user
  • Whois server
  • Whois idle
  • Whois channel
  • Whois end
  • Voice status change on user
  • Operator status change on user
  • Banlist
  • Banlist end

  • %f - from
  • %t - to
  • %c - channel
  • %r - plain message
  • %m - encoded message
  • %j - js encoded message

  • 1 - mod encode
  • 2 - nickname decode

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ircg_lookup_format_messages()

Předcházející | Nahoru | Další
ircg_pconnect | Domů | ircg_set_current


ircg_set_current

(PHP 4 >= 4.0.4, PHP 5 <= 5.0.5)

ircg_set_current — Set current connection for output

Popis

bool ircg_set_current ( resource $connection )

Select the current HTTP connection for output in this execution context. Every output sent from the server connected to by connection will be copied to standard output while using default formatting or a format message set specified by ircg_register_format_messages().

Seznam parametrů

connection

A connection resource handle returned by ircg_pconnect().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ircg_register_format_messages()

Předcházející | Nahoru | Další
ircg_register_format_messages | Domů | ircg_set_file


ircg_set_file

(PHP 4 >= 4.2.0, PHP 5 <= 5.0.5)

ircg_set_file — Set logfile for connection

Popis

bool ircg_set_file ( resource $connection, string $path )

ircg_set_file() specifies a logfile in which all output from the current connection will be logged.

Seznam parametrů

connection

A connection resource handle returned by ircg_pconnect().

path

Path to the logfile.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
ircg_set_current | Domů | ircg_set_on_die


ircg_set_on_die

(PHP 4 >= 4.2.0, PHP 5 <= 5.0.5)

ircg_set_on_die — Set action to be executed when connection dies

Popis

bool ircg_set_on_die ( resource $connection, string $host, int $port, string $data )

In case of the termination of the connection, IRCG will connect to the specified host, send data to the new host connection and will wait until the remote part closes connection. This can be used to trigger a PHP script for example.

Seznam parametrů

connection

A connection resource handle returned by ircg_pconnect().

host

This must be an IPv4 address as IRCG does not resolve host-names due to blocking issues.

port

The port number.

data

The data to be sent before closing the connection.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Poznámky

Poznámka: This feature requires IRCG 3.

Předcházející | Nahoru | Další
ircg_set_file | Domů | ircg_topic


ircg_topic

(PHP 4 >= 4.0.5, PHP 5 <= 5.0.5)

ircg_topic — Set topic for channel on server

Popis

bool ircg_topic ( resource $connection, string $channel, string $new_topic )

Change the topic for the channel.

Seznam parametrů

connection

A connection resource handle returned by ircg_pconnect().

channel

The channel name as #name.

new_topic

The new topic to be set.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
ircg_set_on_die | Domů | ircg_who


ircg_who

(PHP 4 >= 4.3.3, PHP 5 <= 5.0.5)

ircg_who — Queries server for WHO information

Popis

bool ircg_who ( resource $connection, string $mask [, bool $ops_only] )

ircg_who() will request a list of users whose nickname is matching the given mask.

The answer is sent to the output defined by ircg_set_file() or ircg_set_current().

Seznam parametrů

connection

A connection resource handle returned by ircg_pconnect().

mask

A mask for the nickname.

ops_only

The optional parameter ops_only will shrink the list to server operators only.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ircg_set_file()
ircg_set_current()

Předcházející | Nahoru | Další
ircg_topic | Domů | ircg_whois


ircg_whois

(PHP 4 >= 4.0.5, PHP 5 <= 5.0.5)

ircg_whois — Query server for user information

Popis

bool ircg_whois ( resource $connection, string $nick )

Sends a query to ask for information about the specified user.

Seznam parametrů

connection

A connection resource handle returned by ircg_pconnect().

nick

The user nick name.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
ircg_who | Domů | LXXII. PHP / Java Integration


PHP / Java Integration

Předcházející VI. Reference funkcí Další

LXXII. PHP / Java Integration

Úvod

There are two possible ways to bridge PHP and Java: you can either integrate PHP into a Java Servlet environment, which is the more stable and efficient solution, or integrate Java support into PHP. The former is provided by a SAPI module that interfaces with the Servlet server, the latter by this Java extension.

The Java extension provides a simple and effective means for creating and invoking methods on Java objects from PHP. The JVM is created using JNI, and everything runs in-process.

Varování

Toto rozšíření je EXPERIMENTÁLNÍ. Chování tohoto rozšíření, názvy funkcí a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může bez ohlášení změnit. Berte to v úvahu a používejte tento modul na vlastní nebezpečí.

Požadavky

You need a Java VM installed on your machine to use this extension.

Instalace

Toto rozšíření » PECL není přibaleno k PHP.

V PHP 4 lze zdroje k těmto rozšířením PECL najít v adresáři ext/ ve zdrojích PHP source or nebo přes výše uvedený odkaz na PECL. In order to use these functions you must compile PHP with Java support by using the --with-java[=DIR] where DIR points to the base install directory of your JDK. This extension can only be built as a shared extension. Additional build extensions can be found in php-src/ext/java/README.

Windows users will enable php_java.dll inside of php.ini in order to use these functions. V PHP 4 je tato DLL knihovna umístěna v adresáři extensions/ v downloadu binárních souborů PHP pro Windows. Tuto DLL knihovnu pro rozšíření PECL můžete stahovat ze stránky » PHP Downloads nebo z » http://snaps.php.net/.

Poznámka: In order to enable this module on a Windows environment with PHP <= 4.0.6, you must make jvm.dll available to your systems PATH. No additional DLL is needed for PHP versions > 4.0.6.

Konfigurace běhu

Chování těchto funkcí je ovlivněno nastavením parametrů v php.ini.

Tabulka 143. Java configuration options

Name | Default | Changeable | Changelog
java.class.path | NULL | PHP_INI_ALL |
java.home | NULL | PHP_INI_ALL |
java.library.path | NULL | PHP_INI_ALL |
java.library | JAVALIB | PHP_INI_ALL |

Pro další detaily a definice konstant PHP_INI_*, viz dokumentace k ini_set().

Typy prostředků

Toto rozšíření nemá definován žádný typ prostředku (resource).

Předdefinované konstanty

Toto rozšíření nemá definovány žádné konstanty.

Příklady

Příklad 946. Java Example

<?php
// get instance of Java class java.lang.System in PHP
$system = new Java('java.lang.System');

// demonstrate property access
echo 'Java version=' . $system->getProperty('java.version') . '<br />';
echo 'Java vendor=' . $system->getProperty('java.vendor') . '<br />';
echo 'OS=' . $system->getProperty('os.name') . ' ' .
             $system->getProperty('os.version') . ' on ' .
             $system->getProperty('os.arch') . ' <br />';

// java.util.Date example
$formatter = new Java('java.text.SimpleDateFormat',
                      "EEEE, MMMM dd, yyyy 'at' h:mm:ss a zzzz");

echo $formatter->format(new Java('java.util.Date'));
?>

Příklad 947. AWT Example

<?php
// This example is only intended to be run as a CGI.

$frame  = new Java('java.awt.Frame', 'PHP');
$button = new Java('java.awt.Button', 'Hello Java World!');

$frame->add('North', $button);
$frame->validate();
$frame->pack();
$frame->visible = True;

$thread = new Java('java.lang.Thread');
$thread->sleep(10000);

$frame->dispose();
?>

Notes:
  • new Java() will create an instance of a class if a suitable constructor is available. If no parameters are passed and the default constructor is useful as it provides access to classes like java.lang.System which expose most of their functionallity through static methods.
  • Accessing a member of an instance will first look for bean properties then public fields. In other words, print $date.time will first attempt to be resolved as $date.getTime(), then as $date.time.
  • Both static and instance members can be accessed on an object with the same syntax. Furthermore, if the java object is of type java.lang.Class, then static members of the class (fields and methods) can be accessed.

  • Exceptions raised result in PHP warnings, and NULL results. The warnings may be eliminated by prefixing the method call with an "@" sign. The following APIs may be used to retrieve and reset the last error:

    • java_last_exception_get()
    • java_last_exception_clear()

  • Overload resolution is in general a hard problem given the differences in types between the two languages. The PHP Java extension employs a simple, but fairly effective, metric for determining which overload is the best match.

    Additionally, method names in PHP are not case sensitive, potentially increasing the number of overloads to select from.

    Once a method is selected, the parameters are coerced if necessary, possibly with a loss of data (example: double precision floating point numbers will be converted to boolean).

  • In the tradition of PHP, arrays and hashtables may pretty much be used interchangably. Note that hashtables in PHP may only be indexed by integers or strings; and that arrays of primitive types in Java can not be sparse. Also note that these constructs are passed by value, so may be expensive in terms of memory and time.

Java Servlet SAPI

The Java Servlet SAPI builds upon the mechanism defined by the Java extension to enable the entire PHP processor to be run as a servlet. The primary advantage of this from a PHP perspective is that web servers which support servlets typically take great care in pooling and reusing JVMs. Build instructions for the Servlet SAPI module can be found in php4/sapi/README. Notes:

  • While this code is intended to be able to run on any servlet engine, it has only been tested on Apache's Jakarta/tomcat to date. Bug reports, success stories and/or patches required to get this code to run on other engines would be appreciated.
  • PHP has a habit of changing the working directory. sapi/servlet will eventually change it back, but while PHP is running the servlet engine may not be able to load any classes from the CLASSPATH which are specified using a relative directory syntax, or find the work directory used for administration and JSP compilation tasks.

Obsah

java_last_exception_clear — Clear last Java exception
java_last_exception_get — Get last Java exception
Předcházející | Nahoru | Další
ircg_whois | Domů | java_last_exception_clear


java_last_exception_clear

(PHP 4 >= 4.0.2)

java_last_exception_clear — Clear last Java exception

Popis

void java_last_exception_clear ( void )

Clears last Java exception.

Návratové hodnoty

Nevrací se žádná hodnota.

Příklady

See java_last_exception_get() for an example.

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
LXXII. PHP / Java Integration | Domů | java_last_exception_get


java_last_exception_get

(PHP 4 >= 4.0.2)

java_last_exception_get — Get last Java exception

Popis

object java_last_exception_get ( void )

Gets last Java exception.

Návratové hodnoty

Returns an exception object.

Příklady

The following example demonstrates the usage of Java's exception handler from within PHP:

Příklad 948. Java exception handler

<?php
$stack = new Java('java.util.Stack');
$stack->push(1);

// This should succeed
$result = $stack->pop();
$ex = java_last_exception_get();
if (!$ex) {
  echo "$result\n";
}

// This should fail (error suppressed by @)
$result = @$stack->pop();
$ex = java_last_exception_get();
if ($ex) {
  echo $ex->toString();
}

// Clear last exception
java_last_exception_clear();
?>

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
java_last_exception_clear | Domů | LXXIII. JSON Functions


LDAP Functions

Předcházející VI. Reference funkcí Další

LXXV. LDAP Functions

Úvod

LDAP is the Lightweight Directory Access Protocol, and is a protocol used to access "Directory Servers". The Directory is a special kind of database that holds information in a tree structure.

The concept is similar to your hard disk directory structure, except that in this context, the root directory is "The world" and the first level subdirectories are "countries". Lower levels of the directory structure contain entries for companies, organisations or places, while yet lower still we find directory entries for people, and perhaps equipment or documents.

To refer to a file in a subdirectory on your hard disk, you might use something like:

/usr/local/myapp/docs

The forwards slash marks each division in the reference, and the sequence is read from left to right.

The equivalent to the fully qualified file reference in LDAP is the "distinguished name", referred to simply as "dn". An example dn might be:

cn=John Smith,ou=Accounts,o=My Company,c=US

The comma marks each division in the reference, and the sequence is read from right to left. You would read this dn as:

country = US
organization = My Company
organizationalUnit = Accounts
commonName = John Smith

In the same way as there are no hard rules about how you organise the directory structure of a hard disk, a directory server manager can set up any structure that is meaningful for the purpose. However, there are some conventions that are used. The message is that you can not write code to access a directory server unless you know something about its structure, any more than you can use a database without some knowledge of what is available.

Lots of information about LDAP can be found at

  • » Mozilla

  • » OpenLDAP Project

The Netscape SDK contains a helpful » Programmer's Guide in HTML format.

Požadavky

You will need to get and compile LDAP client libraries from either » OpenLDAP or » Bind9.net in order to compile PHP with LDAP support.

Instalace

LDAP support in PHP is not enabled by default. You will need to use the --with-ldap[=DIR] configuration option when compiling PHP to enable LDAP support. DIR is the LDAP base install directory. To enable SASL support, be sure --with-ldap-sasl[=DIR] is used, and that sasl.h exists on the system.

Note to Win32 Users: In order for this extension to work, there are DLL files that must be available to the Windows system PATH. See the FAQ titled "How do I add my PHP directory to the PATH on Windows" for information on how to do this. Although copying DLL files from the PHP folder into the Windows system directory also works (because the system directory is by default in the systems PATH), it is not recommended. This extension requires the following files to be in the PATH: libeay32.dll and ssleay32.dll

Versions before PHP 4.3.0 additionally require libsasl.dll.

In order to use Oracle LDAP libraries, proper Oracle environment has to be set.

Konfigurace běhu

Chování těchto funkcí je ovlivněno nastavením parametrů v php.ini.

Tabulka 146. LDAP configuration options

Name | Default | Changeable | Changelog
ldap.max_links | "-1" | PHP_INI_SYSTEM |

Pro další detaily a definice konstant PHP_INI_*, viz dokumentace k ini_set().

Typy prostředků

Most LDAP functions operate on or return resources (e.g. ldap_connect() returns a positive LDAP link identifier required by most LDAP functions).

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

LDAP_DEREF_NEVER (integer)
LDAP_DEREF_SEARCHING (integer)
LDAP_DEREF_FINDING (integer)
LDAP_DEREF_ALWAYS (integer)
LDAP_OPT_DEREF (integer)
LDAP_OPT_SIZELIMIT (integer)
LDAP_OPT_TIMELIMIT (integer)
LDAP_OPT_NETWORK_TIMEOUT (integer)
Option for ldap_set_option() to allow setting network timeout. (Available as of PHP 5.3.0)
LDAP_OPT_PROTOCOL_VERSION (integer)
LDAP_OPT_ERROR_NUMBER (integer)
LDAP_OPT_REFERRALS (integer)
LDAP_OPT_RESTART (integer)
LDAP_OPT_HOST_NAME (integer)
LDAP_OPT_ERROR_STRING (integer)
LDAP_OPT_MATCHED_DN (integer)
LDAP_OPT_SERVER_CONTROLS (integer)
LDAP_OPT_CLIENT_CONTROLS (integer)
LDAP_OPT_DEBUG_LEVEL (integer)
GSLC_SSL_NO_AUTH (integer)
GSLC_SSL_ONEWAY_AUTH (integer)
GSLC_SSL_TWOWAY_AUTH (integer)

Příklady

Retrieve information for all entries where the surname starts with "S" from a directory server, displaying an extract with name and email address.

Příklad 960. LDAP search example

<?php
// basic sequence with LDAP is connect, bind, search, interpret search
// result, close connection

echo "<h3>LDAP query test</h3>";
echo "Connecting ...";
$ds=ldap_connect("localhost");  // must be a valid LDAP server!
echo "connect result is " . $ds . "<br />";

if ($ds) {
    echo "Binding ...";
    $r=ldap_bind($ds);     // this is an "anonymous" bind, typically
                           // read-only access
    echo "Bind result is " . $r . "<br />";

    echo "Searching for (sn=S*) ...";
    // Search surname entry
    $sr=ldap_search($ds, "o=My Company, c=US", "sn=S*");
    echo "Search result is " . $sr . "<br />";

    echo "Number of entires returned is " . ldap_count_entries($ds, $sr) . "<br />";

    echo "Getting entries ...<p>";
    $info = ldap_get_entries($ds, $sr);
    echo "Data for " . $info["count"] . " items returned:<p>";

    for ($i=0; $i<$info["count"]; $i++) {
        echo "dn is: " . $info[$i]["dn"] . "<br />";
        echo "first cn entry is: " . $info[$i]["cn"][0] . "<br />";
        echo "first email entry is: " . $info[$i]["mail"][0] . "<br /><hr />";
    }

    echo "Closing connection";
    ldap_close($ds);

} else {
    echo "<h4>Unable to connect to LDAP server</h4>";
}
?>

Using the PHP LDAP calls

Before you can use the LDAP calls you will need to know ..

  • The name or address of the directory server you will use

  • The "base dn" of the server (the part of the world directory that is held on this server, which could be "o=My Company,c=US")

  • Whether you need a password to access the server (many servers will provide read access for an "anonymous bind" but require a password for anything else)

The typical sequence of LDAP calls you will make in an application will follow this pattern:

ldap_connect() // establish connection to server
|
ldap_bind() // anonymous or authenticated "login"
|
do something like search or update the directory
and display the results
|
ldap_close() // "logout"

Obsah

ldap_8859_to_t61 — Translate 8859 characters to t61 characters
ldap_add — Add entries to LDAP directory
ldap_bind — Bind to LDAP directory
ldap_close — Alias pro ldap_unbind()
ldap_compare — Compare value of attribute found in entry specified with DN
ldap_connect — Connect to an LDAP server
ldap_count_entries — Count the number of entries in a search
ldap_delete — Delete an entry from a directory
ldap_dn2ufn — Convert DN to User Friendly Naming format
ldap_err2str — Convert LDAP error number into string error message
ldap_errno — Return the LDAP error number of the last LDAP command
ldap_error — Return the LDAP error message of the last LDAP command
ldap_explode_dn — Splits DN into its component parts
ldap_first_attribute — Return first attribute
ldap_first_entry — Return first result id
ldap_first_reference — Return first reference
ldap_free_result — Free result memory
ldap_get_attributes — Get attributes from a search result entry
ldap_get_dn — Get the DN of a result entry
ldap_get_entries — Get all result entries
ldap_get_option — Get the current value for given option
ldap_get_values_len — Get all binary values from a result entry
ldap_get_values — Get all values from a result entry
ldap_list — Single-level search
ldap_mod_add — Add attribute values to current attributes
ldap_mod_del — Delete attribute values from current attributes
ldap_mod_replace — Replace attribute values with new ones
ldap_modify — Modify an LDAP entry
ldap_next_attribute — Get the next attribute in result
ldap_next_entry — Get next result entry
ldap_next_reference — Get next reference
ldap_parse_reference — Extract information from reference entry
ldap_parse_result — Extract information from result
ldap_read — Read an entry
ldap_rename — Modify the name of an entry
ldap_sasl_bind — Bind to LDAP directory using SASL
ldap_search — Search LDAP tree
ldap_set_option — Set the value of the given option
ldap_set_rebind_proc — Set a callback function to do re-binds on referral chasing
ldap_sort — Sort LDAP result entries
ldap_start_tls — Start TLS
ldap_t61_to_8859 — Translate t61 characters to 8859 characters
ldap_unbind — Unbind from LDAP directory
Předcházející | Nahoru | Další
kadm5_modify_principal | Domů | ldap_8859_to_t61


ldap_8859_to_t61

(PHP 4 >= 4.0.2, PHP 5)

ldap_8859_to_t61 — Translate 8859 characters to t61 characters

Popis

string ldap_8859_to_t61 ( string $value )

Translate ISO-8859 characters to t61 characters.

This function is useful if you have to talk to a legacy LDAPv2 server.

Seznam parametrů

value

The text to be translated.

Návratové hodnoty

Return the t61 translation of value.

Viz také

ldap_t61_to_8859()

Předcházející | Nahoru | Další
LXXV. LDAP Functions | Domů | ldap_add


ldap_add

(PHP 4, PHP 5)

ldap_add — Add entries to LDAP directory

Popis

bool ldap_add ( resource $link_identifier, string $dn, array $entry )

Add entries in the LDAP directory.

Seznam parametrů

link_identifier

An LDAP link identifier, returned by ldap_connect().

dn

The distinguished name of an LDAP entity.

entry

An array that specifies the information about the entry. The values in the entries are indexed by individual attributes. In case of multiple values for an attribute, they are indexed using integers starting with 0.

<?php
$entree["attribut1"] = "value";
$entree["attribut2"][0] = "value1";
$entree["attribut2"][1] = "value2";
?>

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 961. Complete example with authenticated bind

<?php
$ds = ldap_connect("localhost");  // assuming the LDAP server is on this host

if ($ds) {
    // bind with appropriate dn to give update access
    $r = ldap_bind($ds, "cn=root, o=My Company, c=US", "secret");

    // prepare data
    $info["cn"] = "John Jones";
    $info["sn"] = "Jones";
    $info["mail"] = "jonj@example.com";
    $info["objectclass"] = "person";

    // add data to directory
    $r = ldap_add($ds, "cn=John Jones, o=My Company, c=US", $info);

    ldap_close($ds);
} else {
    echo "Unable to connect to LDAP server";
}
?>

Poznámky

Poznámka: Tato funkce je binárně bezpečná.

Viz také

ldap_delete()

Předcházející | Nahoru | Další
ldap_8859_to_t61 | Domů | ldap_bind


ldap_bind

(PHP 4, PHP 5)

ldap_bind — Bind to LDAP directory

Popis

bool ldap_bind ( resource $link_identifier [, string $bind_rdn [, string $bind_password]] )

Binds to the LDAP directory with specified RDN and password.

Seznam parametrů

link_identifier

An LDAP link identifier, returned by ldap_connect().

bind_rdn

bind_password

If bind_rdn and bind_password are not specified, an anonymous bind is attempted.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 962. Using LDAP Bind

<?php

// using ldap bind
$ldaprdn  = 'uname';     // ldap rdn or dn
$ldappass = 'password';  // associated password

// connect to ldap server
$ldapconn = ldap_connect("ldap.example.com")
    or die("Could not connect to LDAP server.");

if ($ldapconn) {

    // binding to ldap server
    $ldapbind = ldap_bind($ldapconn, $ldaprdn, $ldappass);

    // verify binding
    if ($ldapbind) {
        echo "LDAP bind successful...";
    } else {
        echo "LDAP bind failed...";
    }

}

?>

Příklad 963. Using LDAP Bind Anonymously

<?php

//using ldap bind anonymously

// connect to ldap server
$ldapconn = ldap_connect("ldap.example.com")
    or die("Could not connect to LDAP server.");

if ($ldapconn) {

    // binding anonymously
    $ldapbind = ldap_bind($ldapconn);

    if ($ldapbind) {
        echo "LDAP bind anonymous successful...";
    } else {
        echo "LDAP bind anonymous failed...";
    }

}

?>

Viz také

ldap_unbind()

Předcházející | Nahoru | Další
ldap_add | Domů | ldap_close


ldap_close

(PHP 4, PHP 5)

ldap_close — Alias pro ldap_unbind()

Popis

Tato funkce je aliasem: ldap_unbind().

Předcházející | Nahoru | Další
ldap_bind | Domů | ldap_compare


ldap_compare

(PHP 4 >= 4.0.2, PHP 5)

ldap_compare — Compare value of attribute found in entry specified with DN

Popis

mixed ldap_compare ( resource $link_identifier, string $dn, string $attribute, string $value )

Compare value of attribute with value of same attribute in an LDAP directory entry.

Seznam parametrů

link_identifier

An LDAP link identifier, returned by ldap_connect().

dn

The distinguished name of an LDAP entity.

attribute

The attribute name.

value

The compared value.

Návratové hodnoty

Returns TRUE if value matches otherwise returns FALSE. Returns -1 on error.

Příklady

The following example demonstrates how to check whether or not given password matches the one defined in DN specified entry.

Příklad 964. Complete example of password check

<?php

$ds=ldap_connect("localhost");  // assuming the LDAP server is on this host

if ($ds) {

    // bind
    if (ldap_bind($ds)) {

        // prepare data
        $dn = "cn=Matti Meikku, ou=My Unit, o=My Company, c=FI";
        $value = "secretpassword";
        $attr = "password";

        // compare value
        $r=ldap_compare($ds, $dn, $attr, $value);

        if ($r === -1) {
            echo "Error: " . ldap_error($ds);
        } elseif ($r === true) {
            echo "Password correct.";
        } elseif ($r === false) {
            echo "Wrong guess! Password incorrect.";
        }

    } else {
        echo "Unable to bind to LDAP server.";
    }

    ldap_close($ds);

} else {
    echo "Unable to connect to LDAP server.";
}
?>

Poznámky

Varování

ldap_compare() can NOT be used to compare BINARY values!

Předcházející | Nahoru | Další
ldap_close | Domů | ldap_connect


ldap_connect

(PHP 4, PHP 5)

ldap_connect — Connect to an LDAP server

Popis

resource ldap_connect ( [string $hostname [, int $port]] )

Establishes a connection to a LDAP server on a specified hostname and port.

Seznam parametrů

hostname

If you are using OpenLDAP 2.x.x you can specify a URL instead of the hostname. To use LDAP with SSL, compile OpenLDAP 2.x.x with SSL support, configure PHP with SSL, and set this parameter as ldaps://hostname/.

port

The port to connect to. Not used when using URLs. Defaults to 389.

Návratové hodnoty

Returns a positive LDAP link identifier on success, or FALSE on error. When OpenLDAP 2.x.x is used, ldap_connect() will always return a resource as it does not actually connect but just initializes the connecting parameters. The actual connect happens with the next calls to ldap_* funcs, usually with ldap_bind().

If no arguments are specified then the link identifier of the already opened link will be returned.

ChangeLog (záznam změn)

Verze | Popis
4.0.4 | URL and SSL support was added.

Příklady

Příklad 965. Example of connecting to LDAP server.

<?php

// LDAP variables
$ldaphost = "ldap.example.com";  // your ldap servers
$ldapport = 389;                 // your ldap server's port number

// Connecting to LDAP
$ldapconn = ldap_connect($ldaphost, $ldapport)
          or die("Could not connect to $ldaphost");

?>

Příklad 966. Example of connecting securely to LDAP server.

<?php

// make sure your host is the correct one
// that you issued your secure certificate to
$ldaphost = "ldaps://ldap.example.com/";

// Connecting to LDAP
$ldapconn = ldap_connect($ldaphost)
          or die("Could not connect to {$ldaphost}");

?>

Viz také

ldap_bind()

Předcházející | Nahoru | Další
ldap_compare | Domů | ldap_count_entries


ldap_count_entries

(PHP 4, PHP 5)

ldap_count_entries — Count the number of entries in a search

Popis

int ldap_count_entries ( resource $link_identifier, resource $result_identifier )

Returns the number of entries stored in the result of previous search operations.

Seznam parametrů

link_identifier

An LDAP link identifier, returned by ldap_connect().

result_identifier

The internal LDAP result.

Návratové hodnoty

Returns number of entries in the result or FALSE on error.

Předcházející | Nahoru | Další
ldap_connect | Domů | ldap_delete


ldap_delete

(PHP 4, PHP 5)

ldap_delete — Delete an entry from a directory

Popis

bool ldap_delete ( resource $link_identifier, string $dn )

Deletes a particular entry in LDAP directory.

Seznam parametrů

link_identifier

An LDAP link identifier, returned by ldap_connect().

dn

The distinguished name of an LDAP entity.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ldap_add()

Předcházející | Nahoru | Další
ldap_count_entries | Domů | ldap_dn2ufn


ldap_dn2ufn

(PHP 4, PHP 5)

ldap_dn2ufn — Convert DN to User Friendly Naming format

Popis

string ldap_dn2ufn ( string $dn )

Turns the specified dn, into a more user-friendly form, stripping off type names.

Seznam parametrů

dn

The distinguished name of an LDAP entity.

Návratové hodnoty

Returns the user friendly name.

Předcházející | Nahoru | Další
ldap_delete | Domů | ldap_err2str


ldap_err2str

(PHP 4, PHP 5)

ldap_err2str — Convert LDAP error number into string error message

Popis

string ldap_err2str ( int $errno )

Returns the string error message explaining the error number errno. While LDAP errno numbers are standardized, different libraries return different or even localized textual error messages. Never check for a specific error message text, but always use an error number to check.

Seznam parametrů

errno

The error number.

Návratové hodnoty

Returns the error message, as a string.

Příklady

Příklad 967. Enumerating all LDAP error messages

<?php
  for ($i=0; $i<100; $i++) {
    printf("Error $i: %s<br />\n", ldap_err2str($i));
  }
?>

Viz také

ldap_errno()
ldap_error()

Předcházející | Nahoru | Další
ldap_dn2ufn | Domů | ldap_errno


ldap_errno

(PHP 4, PHP 5)

ldap_errno — Return the LDAP error number of the last LDAP command

Popis

int ldap_errno ( resource $link_identifier )

Returns the standardized error number returned by the last LDAP command. This number can be converted into a textual error message using ldap_err2str().

Seznam parametrů

link_identifier

An LDAP link identifier, returned by ldap_connect().

Návratové hodnoty

Return the LDAP error number of the last LDAP command for this link.

Příklady

Unless you lower your warning level in your php.ini sufficiently or prefix your LDAP commands with @ (at) characters to suppress warning output, the errors generated will also show up in your HTML output.

Příklad 968. Generating and catching an error

<?php
// This example contains an error, which we will catch.
$ld = ldap_connect("localhost");
$bind = ldap_bind($ld);
// syntax error in filter expression (errno 87),
// must be "objectclass=*" to work.
$res =  @ldap_search($ld, "o=Myorg, c=DE", "objectclass");
if (!$res) {
    echo "LDAP-Errno: " . ldap_errno($ld) . "<br />\n";
    echo "LDAP-Error: " . ldap_error($ld) . "<br />\n";
    die("Argh!<br />\n");
}
$info = ldap_get_entries($ld, $res);
echo $info["count"] . " matching entries.<br />\n";
?>

Viz také

ldap_err2str()
ldap_error()

Předcházející | Nahoru | Další
ldap_err2str | Domů | ldap_error


ldap_error

(PHP 4, PHP 5)

ldap_error — Return the LDAP error message of the last LDAP command

Popis

string ldap_error ( resource $link_identifier )

Returns the string error message explaining the error generated by the last LDAP command for the given link_identifier. While LDAP errno numbers are standardized, different libraries return different or even localized textual error messages. Never check for a specific error message text, but always use an error number to check.

Unless you lower your warning level in your php.ini sufficiently or prefix your LDAP commands with @ (at) characters to suppress warning output, the errors generated will also show up in your HTML output.

Seznam parametrů

link_identifier

An LDAP link identifier, returned by ldap_connect().

Návratové hodnoty

Returns string error message.

Viz také

ldap_err2str()
ldap_errno()

Předcházející | Nahoru | Další
ldap_errno | Domů | ldap_explode_dn


ldap_explode_dn

(PHP 4, PHP 5)

ldap_explode_dn — Splits DN into its component parts

Popis

array ldap_explode_dn ( string $dn, int $with_attrib )

Splits the DN returned by ldap_get_dn() and breaks it up into its component parts. Each part is known as Relative Distinguished Name, or RDN.

Seznam parametrů

dn

The distinguished name of an LDAP entity.

with_attrib

Used to request if the RDNs are returned with only values or their attributes as well. To get RDNs with the attributes (i.e. in attribute=value format) set with_attrib to 0 and to get only values set it to 1.

Návratové hodnoty

Returns an array of all DN components.

Předcházející | Nahoru | Další
ldap_error | Domů | ldap_first_attribute


ldap_first_attribute

(PHP 4, PHP 5)

ldap_first_attribute — Return first attribute

Popis

string ldap_first_attribute ( resource $link_identifier, resource $result_entry_identifier )

Gets the first attribute in the given entry. Remaining attributes are retrieved by calling ldap_next_attribute() successively.

Similar to reading entries, attributes are also read one by one from a particular entry.

Seznam parametrů

link_identifier

An LDAP link identifier, returned by ldap_connect().

result_entry_identifier

ber_identifier

ber_identifier is the identifier to internal memory location pointer. It is passed by reference. The same ber_identifier is passed to ldap_next_attribute() , which modifies that pointer.

Poznámka: This parameter is no longer used as this is now handled automatically by PHP. For backwards compatibility PHP will not throw an error if this parameter is passed.

Návratové hodnoty

Returns the first attribute in the entry on success and FALSE on error.

ChangeLog (záznam změn)

Verze | Popis
5.2.4 | The ber_identifier was removed. This is now handled automatically by PHP.

Viz také

ldap_next_attribute()
ldap_get_attributes()

Předcházející | Nahoru | Další
ldap_explode_dn | Domů | ldap_first_entry


ldap_first_entry

(PHP 4, PHP 5)

ldap_first_entry — Return first result id

Popis

resource ldap_first_entry ( resource $link_identifier, resource $result_identifier )

Returns the entry identifier for first entry in the result. This entry identifier is then supplied to ldap_next_entry() routine to get successive entries from the result.

Entries in the LDAP result are read sequentially using the ldap_first_entry() and ldap_next_entry() functions.

Seznam parametrů

link_identifier

An LDAP link identifier, returned by ldap_connect().

result_identifier

Návratové hodnoty

Returns the result entry identifier for the first entry on success and FALSE on error.

Viz také

ldap_get_entries()

Předcházející | Nahoru | Další
ldap_first_attribute | Domů | ldap_first_reference


ldap_first_reference

(PHP 4 >= 4.0.5, PHP 5)

ldap_first_reference — Return first reference

Popis

resource ldap_first_reference ( resource $link, resource $result )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
ldap_first_entry | Domů | ldap_free_result


ldap_free_result

(PHP 4, PHP 5)

ldap_free_result — Free result memory

Popis

bool ldap_free_result ( resource $result_identifier )

Frees up the memory allocated internally to store the result. All result memory will be automatically freed when the script terminates.

Typically all the memory allocated for the LDAP result gets freed at the end of the script. In case the script is making successive searches which return large result sets, ldap_free_result() could be called to keep the runtime memory usage by the script low.

Seznam parametrů

result_identifier

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
ldap_first_reference | Domů | ldap_get_attributes


ldap_get_attributes

(PHP 4, PHP 5)

ldap_get_attributes — Get attributes from a search result entry

Popis

array ldap_get_attributes ( resource $link_identifier, resource $result_entry_identifier )

Reads attributes and values from an entry in the search result.

Having located a specific entry in the directory, you can find out what information is held for that entry by using this call. You would use this call for an application which "browses" directory entries and/or where you do not know the structure of the directory entries. In many applications you will be searching for a specific attribute such as an email address or a surname, and won't care what other data is held.

return_value["count"] = number of attributes in the entry
return_value[0] = first attribute
return_value[n] = nth attribute

return_value["attribute"]["count"] = number of values for attribute
return_value["attribute"][0] = first value of the attribute
return_value["attribute"][i] = (i+1)th value of the attribute

Seznam parametrů

link_identifier

An LDAP link identifier, returned by ldap_connect().

result_entry_identifier

Návratové hodnoty

Returns a complete entry information in a multi-dimensional array on success and FALSE on error.

Příklady

Příklad 969. Show the list of attributes held for a particular directory entry

<?php
// $ds is the link identifier for the directory

// $sr is a valid search result from a prior call to
// one of the ldap directory search calls

$entry = ldap_first_entry($ds, $sr);

$attrs = ldap_get_attributes($ds, $entry);

echo $attrs["count"] . " attributes held for this entry:<p>";

for ($i=0; $i < $attrs["count"]; $i++) {
    echo $attrs[$i] . "<br />";
}
?>

Viz také

ldap_first_attribute()
ldap_next_attribute()

Předcházející | Nahoru | Další
ldap_free_result | Domů | ldap_get_dn


ldap_get_dn

(PHP 4, PHP 5)

ldap_get_dn — Get the DN of a result entry

Popis

string ldap_get_dn ( resource $link_identifier, resource $result_entry_identifier )

Finds out the DN of an entry in the result.

Seznam parametrů

link_identifier

An LDAP link identifier, returned by ldap_connect().

result_entry_identifier

Návratové hodnoty

Returns the DN of the result entry and FALSE on error.

Předcházející | Nahoru | Další
ldap_get_attributes | Domů | ldap_get_entries


ldap_get_entries

(PHP 4, PHP 5)

ldap_get_entries — Get all result entries

Popis

array ldap_get_entries ( resource $link_identifier, resource $result_identifier )

Reads multiple entries from the given result, and then reading the attributes and multiple values.

Seznam parametrů

link_identifier

An LDAP link identifier, returned by ldap_connect().

result_identifier

Návratové hodnoty

Returns a complete result information in a multi-dimensional array on success and FALSE on error.

The structure of the array is as follows. The attribute index is converted to lowercase. (Attributes are case-insensitive for directory servers, but not when used as array indices.)

return_value["count"] = number of entries in the result
return_value[0] : refers to the details of first entry

return_value[i]["dn"] =  DN of the ith entry in the result

return_value[i]["count"] = number of attributes in ith entry
return_value[i][j] = jth attribute in the ith entry in the result

return_value[i]["attribute"]["count"] = number of values for
                                        attribute in ith entry
return_value[i]["attribute"][j] = jth value of attribute in ith entry

Viz také

ldap_first_entry()
ldap_next_entry()

Předcházející | Nahoru | Další
ldap_get_dn | Domů | ldap_get_option


ldap_get_option

(PHP 4 >= 4.0.4, PHP 5)

ldap_get_option — Get the current value for given option

Popis

bool ldap_get_option ( resource $link_identifier, int $option, mixed &$retval )

Sets retval to the value of the specified option.

Seznam parametrů

link_identifier

An LDAP link identifier, returned by ldap_connect().

option

The parameter option can be one of:

Option | Type
LDAP_OPT_DEREF | integer
LDAP_OPT_SIZELIMIT | integer
LDAP_OPT_TIMELIMIT | integer
LDAP_OPT_NETWORK_TIMEOUT | integer
LDAP_OPT_PROTOCOL_VERSION | integer
LDAP_OPT_ERROR_NUMBER | integer
LDAP_OPT_REFERRALS | bool
LDAP_OPT_RESTART | bool
LDAP_OPT_HOST_NAME | string
LDAP_OPT_ERROR_STRING | string
LDAP_OPT_MATCHED_DN | string
LDAP_OPT_SERVER_CONTROLS | array
LDAP_OPT_CLIENT_CONTROLS | array

retval

This will be set to the option value.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 970. Check protocol version

<?php
// $ds is a valid link identifier for a directory server
if (ldap_get_option($ds, LDAP_OPT_PROTOCOL_VERSION, $version)) {
    echo "Using protocol version $version\n";
} else {
    echo "Unable to determine protocol version\n";
}
?>

Poznámky

Poznámka: This function is only available when using OpenLDAP 2.x.x OR Netscape Directory SDK x.x.

Viz také

ldap_set_option()

Předcházející | Nahoru | Další
ldap_get_entries | Domů | ldap_get_values_len


ldap_get_values_len

(PHP 4, PHP 5)

ldap_get_values_len — Get all binary values from a result entry

Popis

array ldap_get_values_len ( resource $link_identifier, resource $result_entry_identifier, string $attribute )

Reads all the values of the attribute in the entry in the result.

This function is used exactly like ldap_get_values() except that it handles binary data and not string data.

Seznam parametrů

link_identifier

An LDAP link identifier, returned by ldap_connect().

result_entry_identifier

attribute

Návratové hodnoty

Returns an array of values for the attribute on success and FALSE on error. Individual values are accessed by integer index in the array. The first index is 0. The number of values can be found by indexing "count" in the resultant array.

Viz také

ldap_get_values()

Předcházející | Nahoru | Další
ldap_get_option | Domů | ldap_get_values


ldap_get_values

(PHP 4, PHP 5)

ldap_get_values — Get all values from a result entry

Popis

array ldap_get_values ( resource $link_identifier, resource $result_entry_identifier, string $attribute )

Reads all the values of the attribute in the entry in the result.

This call needs a result_entry_identifier, so needs to be preceded by one of the ldap search calls and one of the calls to get an individual entry.

You application will either be hard coded to look for certain attributes (such as "surname" or "mail") or you will have to use the ldap_get_attributes() call to work out what attributes exist for a given entry.

Seznam parametrů

link_identifier

An LDAP link identifier, returned by ldap_connect().

result_entry_identifier

attribute

Návratové hodnoty

Returns an array of values for the attribute on success and FALSE on error. The number of values can be found by indexing "count" in the resultant array. Individual values are accessed by integer index in the array. The first index is 0.

LDAP allows more than one entry for an attribute, so it can, for example, store a number of email addresses for one person's directory entry all labeled with the attribute "mail"

return_value["count"] = number of values for attribute
return_value[0] = first value of attribute
return_value[i] = ith value of attribute

Příklady

Příklad 971. List all values of the "mail" attribute for a directory entry

<?php
// $ds is a valid link identifier for a directory server

// $sr is a valid search result from a prior call to
//     one of the ldap directory search calls

// $entry is a valid entry identifier from a prior call to
//        one of the calls that returns a directory entry

$values = ldap_get_values($ds, $entry, "mail");

echo $values["count"] . " email addresses for this entry.<br />";

for ($i=0; $i < $values["count"]; $i++) {
    echo $values[$i] . "<br />";
}
?>

Viz také

ldap_get_values_len()

Předcházející | Nahoru | Další
ldap_get_values_len | Domů | ldap_list


ldap_list

(PHP 4, PHP 5)

ldap_list — Single-level search

Popis

resource ldap_list ( resource $link_identifier, string $base_dn, string $filter [, array $attributes [, int $attrsonly [, int $sizelimit [, int $timelimit [, int $deref]]]]] )

Performs the search for a specified filter on the directory with the scope LDAP_SCOPE_ONELEVEL.

LDAP_SCOPE_ONELEVEL means that the search should only return information that is at the level immediately below the base_dn given in the call. (Equivalent to typing "ls" and getting a list of files and folders in the current working directory.)

Seznam parametrů

link_identifier

An LDAP link identifier, returned by ldap_connect().

base_dn

The base DN for the directory.

filter

attributes

An array of the required attributes, e.g. array("mail", "sn", "cn"). Note that the "dn" is always returned irrespective of which attributes types are requested.

Using this parameter is much more efficient than the default action (which is to return all attributes and their associated values). The use of this parameter should therefore be considered good practice.

attrsonly

Should be set to 1 if only attribute types are wanted. If set to 0 both attributes types and attribute values are fetched which is the default behaviour.

sizelimit

Enables you to limit the count of entries fetched. Setting this to 0 means no limit.

Poznámka: This parameter can NOT override server-side preset sizelimit. You can set it lower though.

Some directory server hosts will be configured to return no more than a preset number of entries. If this occurs, the server will indicate that it has only returned a partial results set. This also occurs if you use this parameter to limit the count of fetched entries.

timelimit

Sets the number of seconds how long is spend on the search. Setting this to 0 means no limit.

Poznámka: This parameter can NOT override server-side preset timelimit. You can set it lower though.

deref

Specifies how aliases should be handled during the search. It can be one of the following:

  • LDAP_DEREF_NEVER - (default) aliases are never dereferenced.
  • LDAP_DEREF_SEARCHING - aliases should be dereferenced during the search but not when locating the base object of the search.
  • LDAP_DEREF_FINDING - aliases should be dereferenced when locating the base object but not during the search.
  • LDAP_DEREF_ALWAYS - aliases should be dereferenced always.

Návratové hodnoty

Returns a search result identifier or FALSE on error.

ChangeLog (záznam změn)

Verze | Popis
4.0.5 | Parallel searches support was added. See ldap_search() for details.
4.0.2 | The attrsonly, sizelimit, timelimit and deref were added.

Příklady

Příklad 972. Produce a list of all organizational units of an organization

// $ds is a valid link identifier for a directory server

$basedn = "o=My Company, c=US";
$justthese = array("ou");

$sr=ldap_list($ds, $basedn, "ou=*", $justthese);

$info = ldap_get_entries($ds, $sr);

for ($i=0; $i<$info["count"]; $i++) {
    echo $info[$i]["ou"][0] ;
}

Viz také

ldap_search()

Předcházející | Nahoru | Další
ldap_get_values | Domů | ldap_mod_add


ldap_mod_add

(PHP 4, PHP 5)

ldap_mod_add — Add attribute values to current attributes

Popis

bool ldap_mod_add ( resource $link_identifier, string $dn, array $entry )

Adds one or more attributes to the specified dn. It performs the modification at the attribute level as opposed to the object level. Object-level additions are done by the ldap_add() function.

Seznam parametrů

link_identifier

An LDAP link identifier, returned by ldap_connect().

dn

The distinguished name of an LDAP entity.

entry

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Poznámky

Poznámka: Tato funkce je binárně bezpečná.

Viz také

ldap_mod_del()
ldap_mod_replace()

Předcházející | Nahoru | Další
ldap_list | Domů | ldap_mod_del


ldap_mod_del

(PHP 4, PHP 5)

ldap_mod_del — Delete attribute values from current attributes

Popis

bool ldap_mod_del ( resource $link_identifier, string $dn, array $entry )

Removes one or more attributes from the specified dn. It performs the modification at the attribute level as opposed to the object level. Object-level deletions are done by the ldap_delete() function.

Seznam parametrů

link_identifier

An LDAP link identifier, returned by ldap_connect().

dn

The distinguished name of an LDAP entity.

entry

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ldap_mod_add()
ldap_mod_replace()

Předcházející | Nahoru | Další
ldap_mod_add | Domů | ldap_mod_replace


ldap_mod_replace

(PHP 4, PHP 5)

ldap_mod_replace — Replace attribute values with new ones

Popis

bool ldap_mod_replace ( resource $link_identifier, string $dn, array $entry )

Replaces one or more attributes from the specified dn. It performs the modification at the attribute level as opposed to the object level. Object-level modifications are done by the ldap_modify() function.

Seznam parametrů

link_identifier

An LDAP link identifier, returned by ldap_connect().

dn

The distinguished name of an LDAP entity.

entry

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Poznámky

Poznámka: Tato funkce je binárně bezpečná.

Viz také

ldap_mod_del()
ldap_mod_add()

Předcházející | Nahoru | Další
ldap_mod_del | Domů | ldap_modify


ldap_modify

(PHP 4, PHP 5)

ldap_modify — Modify an LDAP entry

Popis

bool ldap_modify ( resource $link_identifier, string $dn, array $entry )

Modify the existing entries in the LDAP directory. The structure of the entry is same as in ldap_add().

Seznam parametrů

link_identifier

An LDAP link identifier, returned by ldap_connect().

dn

The distinguished name of an LDAP entity.

entry

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Poznámky

Poznámka: Tato funkce je binárně bezpečná.

Viz také

ldap_rename()

Předcházející | Nahoru | Další
ldap_mod_replace | Domů | ldap_next_attribute


ldap_next_attribute

(PHP 4, PHP 5)

ldap_next_attribute — Get the next attribute in result

Popis

string ldap_next_attribute ( resource $link_identifier, resource $result_entry_identifier )

Retrieves the attributes in an entry. The first call to ldap_next_attribute() is made with the result_entry_identifier returned from ldap_first_attribute().

Seznam parametrů

link_identifier

An LDAP link identifier, returned by ldap_connect().

result_entry_identifier

ber_identifier

The internal state of the pointer is maintained by this parameter.

Poznámka: This parameter is no longer used as this is now handled automatically by PHP. For backwards compatibility PHP will not throw an error if this parameter is passed.

Návratové hodnoty

Returns the next attribute in an entry on success and FALSE on error.

ChangeLog (záznam změn)

Verze | Popis
5.2.4 | The ber_identifier was removed. This is now handled automatically by PHP.

Viz také

ldap_get_attributes()

Předcházející | Nahoru | Další
ldap_modify | Domů | ldap_next_entry


ldap_next_entry

(PHP 4, PHP 5)

ldap_next_entry — Get next result entry

Popis

resource ldap_next_entry ( resource $link_identifier, resource $result_entry_identifier )

Retrieve the entries stored in the result. Successive calls to the ldap_next_entry() return entries one by one till there are no more entries. The first call to ldap_next_entry() is made after the call to ldap_first_entry() with the result_entry_identifier as returned from the ldap_first_entry().

Seznam parametrů

link_identifier

An LDAP link identifier, returned by ldap_connect().

result_entry_identifier

Návratové hodnoty

Returns entry identifier for the next entry in the result whose entries are being read starting with ldap_first_entry(). If there are no more entries in the result then it returns FALSE.

Viz také

ldap_get_entries()

Předcházející | Nahoru | Další
ldap_next_attribute | Domů | ldap_next_reference


ldap_next_reference

(PHP 4 >= 4.0.5, PHP 5)

ldap_next_reference — Get next reference

Popis

resource ldap_next_reference ( resource $link, resource $entry )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
ldap_next_entry | Domů | ldap_parse_reference


ldap_parse_reference

(PHP 4 >= 4.0.5, PHP 5)

ldap_parse_reference — Extract information from reference entry

Popis

bool ldap_parse_reference ( resource $link, resource $entry, array &$referrals )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
ldap_next_reference | Domů | ldap_parse_result


ldap_parse_result

(PHP 4 >= 4.0.5, PHP 5)

ldap_parse_result — Extract information from result

Popis

bool ldap_parse_result ( resource $link, resource $result, int &$errcode [, string &$matcheddn [, string &$errmsg [, array &$referrals]]] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
ldap_parse_reference | Domů | ldap_read


ldap_read

(PHP 4, PHP 5)

ldap_read — Read an entry

Popis

resource ldap_read ( resource $link_identifier, string $base_dn, string $filter [, array $attributes [, int $attrsonly [, int $sizelimit [, int $timelimit [, int $deref]]]]] )

Performs the search for a specified filter on the directory with the scope LDAP_SCOPE_BASE. So it is equivalent to reading an entry from the directory.

Seznam parametrů

link_identifier

An LDAP link identifier, returned by ldap_connect().

base_dn

The base DN for the directory.

filter

An empty filter is not allowed. If you want to retrieve absolutely all information for this entry, use a filter of objectClass=*. If you know which entry types are used on the directory server, you might use an appropriate filter such as objectClass=inetOrgPerson.

attributes

An array of the required attributes, e.g. array("mail", "sn", "cn"). Note that the "dn" is always returned irrespective of which attributes types are requested.

Using this parameter is much more efficient than the default action (which is to return all attributes and their associated values). The use of this parameter should therefore be considered good practice.

attrsonly

Should be set to 1 if only attribute types are wanted. If set to 0 both attributes types and attribute values are fetched which is the default behaviour.

sizelimit

Enables you to limit the count of entries fetched. Setting this to 0 means no limit.

Poznámka: This parameter can NOT override server-side preset sizelimit. You can set it lower though.

Some directory server hosts will be configured to return no more than a preset number of entries. If this occurs, the server will indicate that it has only returned a partial results set. This also occurs if you use this parameter to limit the count of fetched entries.

timelimit

Sets the number of seconds how long is spend on the search. Setting this to 0 means no limit.

Poznámka: This parameter can NOT override server-side preset timelimit. You can set it lower though.

deref

Specifies how aliases should be handled during the search. It can be one of the following:

  • LDAP_DEREF_NEVER - (default) aliases are never dereferenced.
  • LDAP_DEREF_SEARCHING - aliases should be dereferenced during the search but not when locating the base object of the search.
  • LDAP_DEREF_FINDING - aliases should be dereferenced when locating the base object but not during the search.
  • LDAP_DEREF_ALWAYS - aliases should be dereferenced always.

Návratové hodnoty

Returns a search result identifier or FALSE on error.

ChangeLog (záznam změn)

Verze | Popis
4.0.5 | Parallel searches support was added. See ldap_search() for details.
4.0.2 | The attrsonly, sizelimit, timelimit and deref were added.

Předcházející | Nahoru | Další
ldap_parse_result | Domů | ldap_rename


ldap_rename

(PHP 4 >= 4.0.5, PHP 5)

ldap_rename — Modify the name of an entry

Popis

bool ldap_rename ( resource $link_identifier, string $dn, string $newrdn, string $newparent, bool $deleteoldrdn )

The entry specified by dn is renamed/moved.

Seznam parametrů

link_identifier

An LDAP link identifier, returned by ldap_connect().

dn

The distinguished name of an LDAP entity.

newrdn

The new RDN.

newparent

The new parent/superior entry.

deleteoldrdn

If TRUE the old RDN value(s) is removed, else the old RDN value(s) is retained as non-distinguished values of the entry.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Poznámky

Poznámka: This function currently only works with LDAPv3. You may have to use ldap_set_option() prior to binding to use LDAPv3. This function is only available when using OpenLDAP 2.x.x OR Netscape Directory SDK x.x.

Viz také

ldap_modify()

Předcházející | Nahoru | Další
ldap_read | Domů | ldap_sasl_bind


ldap_sasl_bind

(PHP 5)

ldap_sasl_bind — Bind to LDAP directory using SASL

Popis

bool ldap_sasl_bind ( resource $link [, string $binddn [, string $password [, string $sasl_mech [, string $sasl_realm [, string $sasl_authz_id [, string $props]]]]]] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Poznámky

Requirement: ldap_sasl_bind() requires SASL support (sasl.h). Be sure --with-ldap-sasl is used when configuring PHP otherwise this function will be undefined.

Předcházející | Nahoru | Další
ldap_rename | Domů | ldap_search


ldap_search

(PHP 4, PHP 5)

ldap_search — Search LDAP tree

Popis

resource ldap_search ( resource $link_identifier, string $base_dn, string $filter [, array $attributes [, int $attrsonly [, int $sizelimit [, int $timelimit [, int $deref]]]]] )

Performs the search for a specified filter on the directory with the scope of LDAP_SCOPE_SUBTREE. This is equivalent to searching the entire directory.

From 4.0.5 on it's also possible to do parallel searches. To do this you use an array of link identifiers, rather than a single identifier, as the first argument. If you don't want the same base DN and the same filter for all the searches, you can also use an array of base DNs and/or an array of filters. Those arrays must be of the same size as the link identifier array since the first entries of the arrays are used for one search, the second entries are used for another, and so on. When doing parallel searches an array of search result identifiers is returned, except in case of error, then the entry corresponding to the search will be FALSE. This is very much like the value normally returned, except that a result identifier is always returned when a search was made. There are some rare cases where the normal search returns FALSE while the parallel search returns an identifier.

Seznam parametrů

link_identifier

An LDAP link identifier, returned by ldap_connect().

base_dn

The base DN for the directory.

filter

The search filter can be simple or advanced, using boolean operators in the format described in the LDAP documentation (see the » Netscape Directory SDK for full information on filters).

attributes

An array of the required attributes, e.g. array("mail", "sn", "cn"). Note that the "dn" is always returned irrespective of which attributes types are requested.

Using this parameter is much more efficient than the default action (which is to return all attributes and their associated values). The use of this parameter should therefore be considered good practice.

attrsonly

Should be set to 1 if only attribute types are wanted. If set to 0 both attributes types and attribute values are fetched which is the default behaviour.

sizelimit

Enables you to limit the count of entries fetched. Setting this to 0 means no limit.

Poznámka: This parameter can NOT override server-side preset sizelimit. You can set it lower though.

Some directory server hosts will be configured to return no more than a preset number of entries. If this occurs, the server will indicate that it has only returned a partial results set. This also occurs if you use this parameter to limit the count of fetched entries.

timelimit

Sets the number of seconds how long is spend on the search. Setting this to 0 means no limit.

Poznámka: This parameter can NOT override server-side preset timelimit. You can set it lower though.

deref

Specifies how aliases should be handled during the search. It can be one of the following:

  • LDAP_DEREF_NEVER - (default) aliases are never dereferenced.
  • LDAP_DEREF_SEARCHING - aliases should be dereferenced during the search but not when locating the base object of the search.
  • LDAP_DEREF_FINDING - aliases should be dereferenced when locating the base object but not during the search.
  • LDAP_DEREF_ALWAYS - aliases should be dereferenced always.

Návratové hodnoty

Returns a search result identifier or FALSE on error.

ChangeLog (záznam změn)

Verze | Popis
4.0.5 | Parallel searches support was added.
4.0.2 | The attrsonly, sizelimit, timelimit and deref were added.

Příklady

The example below retrieves the organizational unit, surname, given name and email address for all people in "My Company" where the surname or given name contains the substring $person. This example uses a boolean filter to tell the server to look for information in more than one attribute.

Příklad 973. LDAP search

<?php
// $ds is a valid link identifier for a directory server

// $person is all or part of a person's name, eg "Jo"

$dn = "o=My Company, c=US";
$filter="(|(sn=$person*)(givenname=$person*))";
$justthese = array("ou", "sn", "givenname", "mail");

$sr=ldap_search($ds, $dn, $filter, $justthese);

$info = ldap_get_entries($ds, $sr);

echo $info["count"]." entries returned\n";
?>

Předcházející | Nahoru | Další
ldap_sasl_bind | Domů | ldap_set_option


ldap_set_option

(PHP 4 >= 4.0.4, PHP 5)

ldap_set_option — Set the value of the given option

Popis

bool ldap_set_option ( resource $link_identifier, int $option, mixed $newval )

Sets the value of the specified option to be newval.

Seznam parametrů

link_identifier

An LDAP link identifier, returned by ldap_connect().

option

The parameter option can be one of:

Option | Type
LDAP_OPT_DEREF | integer
LDAP_OPT_SIZELIMIT | integer
LDAP_OPT_TIMELIMIT | integer
LDAP_OPT_NETWORK_TIMEOUT | integer
LDAP_OPT_PROTOCOL_VERSION | integer
LDAP_OPT_ERROR_NUMBER | integer
LDAP_OPT_REFERRALS | bool
LDAP_OPT_RESTART | bool
LDAP_OPT_HOST_NAME | string
LDAP_OPT_ERROR_STRING | string
LDAP_OPT_MATCHED_DN | string
LDAP_OPT_SERVER_CONTROLS | array
LDAP_OPT_CLIENT_CONTROLS | array

LDAP_OPT_SERVER_CONTROLS and LDAP_OPT_CLIENT_CONTROLS require a list of controls, this means that the value must be an array of controls. A control consists of an oid identifying the control, an optional value, and an optional flag for criticality. In PHP a control is given by an array containing an element with the key oid and string value, and two optional elements. The optional elements are key value with string value and key iscritical with boolean value. iscritical defaults to FALSE if not supplied. See » draft-ietf-ldapext-ldap-c-api-xx.txt for details. See also the second example below.

newval

The new value for the specified option.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 974. Set protocol version

<?php
// $ds is a valid link identifier for a directory server
if (ldap_set_option($ds, LDAP_OPT_PROTOCOL_VERSION, 3)) {
    echo "Using LDAPv3";
} else {
    echo "Failed to set protocol version to 3";
}
?>

Příklad 975. Set server controls

<?php
// $ds is a valid link identifier for a directory server
// control with no value
$ctrl1 = array("oid" => "1.2.752.58.10.1", "iscritical" => true);
// iscritical defaults to FALSE
$ctrl2 = array("oid" => "1.2.752.58.1.10", "value" => "magic");
// try to set both controls
if (!ldap_set_option($ds, LDAP_OPT_SERVER_CONTROLS, array($ctrl1, $ctrl2))) {
    echo "Failed to set server controls";
}
?>

Poznámky

Poznámka: This function is only available when using OpenLDAP 2.x.x OR Netscape Directory SDK x.x.

Viz také

ldap_get_option()

Předcházející | Nahoru | Další
ldap_search | Domů | ldap_set_rebind_proc


ldap_set_rebind_proc

(PHP 4 >= 4.2.0, PHP 5)

ldap_set_rebind_proc — Set a callback function to do re-binds on referral chasing

Popis

bool ldap_set_rebind_proc ( resource $link, callback $callback )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
ldap_set_option | Domů | ldap_sort


ldap_sort

(PHP 4 >= 4.2.0, PHP 5)

ldap_sort — Sort LDAP result entries

Popis

bool ldap_sort ( resource $link, resource $result, string $sortfilter )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
ldap_set_rebind_proc | Domů | ldap_start_tls


ldap_start_tls

(PHP 4 >= 4.2.0, PHP 5)

ldap_start_tls — Start TLS

Popis

bool ldap_start_tls ( resource $link )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
ldap_sort | Domů | ldap_t61_to_8859


ldap_t61_to_8859

(PHP 4 >= 4.0.2, PHP 5)

ldap_t61_to_8859 — Translate t61 characters to 8859 characters

Popis

string ldap_t61_to_8859 ( string $value )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
ldap_start_tls | Domů | ldap_unbind


ldap_unbind

(PHP 4, PHP 5)

ldap_unbind — Unbind from LDAP directory

Popis

bool ldap_unbind ( resource $link_identifier )

Unbinds from the LDAP directory.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ldap_bind()

Předcházející | Nahoru | Další
ldap_t61_to_8859 | Domů | LXXVI. libxml Functions


LZF Functions

Předcházející VI. Reference funkcí Další

LXXVIII. LZF Functions

Úvod

LZF is a very fast compression algorithm, ideal for saving space with only slight speed cost. It can be optimized for speed or space at the time of compilation.

Instalace

Toto rozšíření » PECL není přibaleno k PHP. Informace o instalaci tohoto PECL rozšíření lze najít v kapitole manuálu nazvané Instalace rozšíření PECL. Další informace, jako nové verze, soubory ke stažení, zdrojové soubory, správcovské informace a CHANGELOG, lze najít zde: » http://pecl.php.net/package/lzf.

In order to use these functions you must compile PHP with lzf support by using the --with-lzf[=DIR] configure option. You may also pass --enable-lzf-better-compression to optimize LZF for space rather then speed.

Windows users will enable php_lzf.dll inside of php.ini in order to use these functions. Tuto DLL knihovnu pro rozšíření PECL můžete stahovat ze stránky » PHP Downloads nebo z » http://snaps.php.net/.

Obsah

lzf_compress — LZF compression
lzf_decompress — LZF decompression
lzf_optimized_for — Determines what LZF extension was optimized for
Předcházející | Nahoru | Další
notes_version | Domů | lzf_compress


lzf_compress

(PECL lzf:0.1-1.4)

lzf_compress — LZF compression

Popis

string lzf_compress ( string $data )

lzf_compress() compresses the given data.

Seznam parametrů

data

The string to compress.

Návratové hodnoty

Returns the compressed data or FALSE if an error occurred.

Viz také

lzf_decompress()

Předcházející | Nahoru | Další
LXXVIII. LZF Functions | Domů | lzf_decompress


lzf_decompress

(PECL lzf:0.1-1.4)

lzf_decompress — LZF decompression

Popis

string lzf_decompress ( string $data )

lzf_compress() decompresses the given data.

Seznam parametrů

data

The compressed string.

Návratové hodnoty

Returns the decompressed data or FALSE if an error occurred.

Viz také

lzf_compress()

Předcházející | Nahoru | Další
lzf_compress | Domů | lzf_optimized_for


lzf_optimized_for

(PECL lzf:1.0-1.4)

lzf_optimized_for — Determines what LZF extension was optimized for

Popis

int lzf_optimized_for ( void )

Determines for what the LZF extension was optimised.

Návratové hodnoty

Returns 1 if LZF was optimized for speed, 0 for compression.

Předcházející | Nahoru | Další
lzf_decompress | Domů | LXXIX. Mailové funkce


Mailové funkce

Předcházející VI. Reference funkcí Další

LXXIX. Mailové funkce

Úvod

Funkce mail() umožňuje odesílat maily.

Požadavky

Aby byly tyto funkce dostupné, musí mít PHP při kompilaci přístup ke spustitelnému souboru sendmail na vašem systému. Pokud používáte jiný program, jako qmail nebo postfix, použijte odpovídající náhradu za sendmail, které je v daném programu k dispozici. PHP bude sendmail hledat nejprve v cestě PATH a pak zde: /usr/bin:/usr/sbin:/usr/etc:/etc:/usr/ucblib:/usr/lib. Vřele doporučujeme mít sendmail dostupný z cesty PATH. Uživatel, který PHP zkompiloval, také musí mít právo přístupu ke spustitelnému souboru sendmail.

Instalace

K používání těchto funkcí není třeba žádná instalace, jsou součástí jádra PHP.

Konfigurace běhu

Chování těchto funkcí je ovlivněno nastavením parametrů v php.ini.

Tabulka 147. Konfigurační volby rozšíření Mail

Název | Výchozí | Měnitelné
SMTP | "localhost" | PHP_INI_ALL
smtp_port | "25" | PHP_INI_ALL
sendmail_from | NULL | PHP_INI_ALL
sendmail_path | DEFAULT_SENDMAIL_PATH | PHP_INI_SYSTEM

Bližší vysvětlení a definici PHP_INI_* konstant viz funkci ini_set().

Zde je stručný popis konfiguračních direktiv.

SMTP string

Používá se pouze pod Windows: DNS jméno nebo IP adresa SMTP serveru, který PHP použije pro posílání e-mailů ve funkci mail().

smtp_port int

Používá se pouze pod Windows: Číslo portu na serveru určeném v direktivě SMTP, na který se má připojit při posílání e-mailů ve funkci mail(). Výchozí je číslo 25. K dispozici pouze od PHP 4.3.0.

sendmail_from string

Jaká adresa "From:" se má použít při posílání e-mailu z PHP pod Windows.

sendmail_path string

Kde lze najít program sendmail, obvykle /usr/sbin/sendmail nebo /usr/lib/sendmail. Příkaz configure se pokusí tento soubor nalézt a nastavit, ale když neuspěje, můžete ho nastavit zde.

Na systémech, na kterých se nepoužívá sendmail, by měla být tato direktiva nastavena na náhradu příkazu sendmail, kterou poskytuje daný systém (pokud existuje). Například uživatelé systému » Qmail mohou tuto direktivu za normálních okolností nastavit na /var/qmail/bin/sendmail nebo na /var/qmail/bin/qmail-inject.

Příkaz qmail-inject nepotřebuje žádné přepínače, aby e-maily korektně zpracoval.

Typy prostředků

Toto rozšíření nemá definován žádný typ prostředku (resource).

Předdefinované konstanty

Toto rozšíření nemá definovány žádné konstanty.

Obsah

ezmlm_hash — Počítá hash hodnotu potřebnou pro EZMLM
mail — send mail
Předcházející | Nahoru | Další
lzf_optimized_for | Domů | ezmlm_hash


ezmlm_hash

(PHP 4 >= 4.0.2, PHP 5)

ezmlm_hash — Počítá hash hodnotu potřebnou pro EZMLM

Popis

int ezmlm_hash ( string $addr )

ezmlm_hash() Počítá hash hodnotu, která je potřeba pro uchovávání EZMLM mailing listů v MySQL databázi.

Příklad 979. Výpočet hashe a přihlášení uživatele

$user = "kris@koehntopp.de";
$hash = ezmlm_hash ($user);
$query = sprintf ("INSERT INTO sample VALUES (%s, '%s')", $hash, $user);
$db->query($query); // použito databázové rozhraní PHPLIB

Předcházející | Nahoru | Další
LXXIX. Mailové funkce | Domů | mail


mail

(PHP 4, PHP 5)

mail — send mail

Popis

bool mail ( string $to, string $subject, string $message [, string $additional_headers [, string $additional_parameters]] )

mail() automaticky odmailuje vzkaz specifikovaný v message příjemci specifikovanému v to. Přidáním čárky mezi adresami v to můžete specifikovat více příjemců.

Příklad 980. Odeslání mailu.

mail("rasmus@lerdorf.on.ca", "Muj predmet", "Radek 1\nRadek 2\nRadek 3");

Pokud je předán čtvrtý argument, jeho hodnota se vloží na konec hlaviček. Toto se obvykle používá k přidání extra hlaviček. Vícenásobné hlavičky se oddělují zařádkováním.

Příklad 981. Odeslání mailu s extra hlavičkami.

mail("nobody@aol.com", "predmet", $message,
     "From: webmaster@$SERVER_NAME\nReply-To: webmaster@$SERVER_NAME\nX-Mailer: PHP/" . phpversion());

K vytvoření komplexních emailů můžete také použít poměrně jednoduché techniky pro tvorbu řetězců.

Příklad 982. Odeslání komplexního emailu

/* recipients */
$recipient .= "Mary <mary@u.college.edu>" . ", " ; //všimněte si čárky
$recipient .= "Kelly <kelly@u.college.edu>" . ", ";
$recipient .= "ronabop@php.net";

/* subject */
$subject = "Birthday Reminders for August";

/* message */
$message .= "Následující email obsahuje formátovanou ASCII tabulku\n";
$message .= "Day \t\tMonth \t\tYear\n";
$message .= "3rd \t\tAug \t\t1970\n";
$message .= "17rd\t\tAug \t\t1973\n";

/* můžete přidat signaturu */
$message .= "-- \r\n"; //oddělovač signatury
$message .= "Birthday reminder copylefted by public domain";

/* dodatečné hlavičky pro chyby, From, cc, bcc, atd */

$headers .= "From: Birthday Reminder <birthday@php.net>\n";
$headers .= "X-Sender: <birthday@php.net>\n";
$headers .= "X-Mailer: PHP\n"; // mailový klient
$headers .= "X-Priority: 1\n"; // Urgentní vzkaz!
$headers .= "Return-Path: <birthday@php.net>\n";  // Návratová cesta pro chyby

/* Pokud chcete poslat HTML email, odkomentujte následující řádek */
// $headers .= "Content-Type: text/html; charset=iso-8859-1\n"; // Mime typ

$headers .= "cc:birthdayarchive@php.net\n"; // CC
$headers .= "bcc:birthdaycheck@php.net, birthdaygifts@php.net\n"; // BCC

/* a teď to odešleme */
mail($recipient, $subject, $message, $headers);

Předcházející | Nahoru | Další
ezmlm_hash | Domů | LXXX. Mailparse Functions


Mailparse Functions

Předcházející VI. Reference funkcí Další

LXXX. Mailparse Functions

Úvod

Mailparse is an extension for parsing and working with email messages. It can deal with » RFC 822 and » RFC 2045 (MIME) compliant messages.

Mailparse is stream based, which means that it does not keep in-memory copies of the files it processes - so it is very resource efficient when dealing with large messages.

Poznámka: Mailparse requires the mbstring extension, and mbstring must be loaded before mailparse.

Toto rozšíření bylo přesunuto do repozitáře PECL a již nebude součástí balíku PHP.4.2.0.

Instalace

Toto rozšíření » PECL není přibaleno k PHP. Informace o instalaci tohoto PECL rozšíření lze najít v kapitole manuálu nazvané Instalace rozšíření PECL. Další informace, jako nové verze, soubory ke stažení, zdrojové soubory, správcovské informace a CHANGELOG, lze najít zde: » http://pecl.php.net/package/mailparse.

In order to use these functions you must compile PHP with mailparse support by using the --enable-mailparse configure option.

Windows users will enable php_mailparse.dll inside of php.ini in order to use these functions. Tuto DLL knihovnu pro rozšíření PECL můžete stahovat ze stránky » PHP Downloads nebo z » http://snaps.php.net/.

Konfigurace běhu

Chování těchto funkcí je ovlivněno nastavením parametrů v php.ini.

Tabulka 148. Mailparse configuration options

Name | Default | Changeable | Changelog
mailparse.def_charset | "us-ascii" | PHP_INI_ALL | Available since PHP 4.1.0. Removed in PHP 4.2.0.

Pro další detaily a definice konstant PHP_INI_*, viz dokumentace k ini_set().

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

MAILPARSE_EXTRACT_OUTPUT (integer)
MAILPARSE_EXTRACT_STREAM (integer)
MAILPARSE_EXTRACT_RETURN (integer)

Obsah

mailparse_determine_best_xfer_encoding — Gets the best way of encoding
mailparse_msg_create — Create a mime mail resource
mailparse_msg_extract_part_file — Extracts/decodes a message section
mailparse_msg_extract_part — Extracts/decodes a message section
mailparse_msg_extract_whole_part_file — Extracts a message section including headers without decoding the transfer encoding
mailparse_msg_free — Frees a MIME resource
mailparse_msg_get_part_data — Returns an associative array of info about the message
mailparse_msg_get_part — Returns a handle on a given section in a mimemessage
mailparse_msg_get_structure — Returns an array of mime section names in the supplied message
mailparse_msg_parse_file — Parses a file
mailparse_msg_parse — Incrementally parse data into buffer
mailparse_rfc822_parse_addresses — Parse RFC 822 compliant addresses
mailparse_stream_encode — Streams data from source file pointer, apply encoding and write to destfp
mailparse_uudecode_all — Scans the data from fp and extract each embedded uuencoded file
Předcházející | Nahoru | Další
mail | Domů | mailparse_determine_best_xfer_encoding


mailparse_determine_best_xfer_encoding

(PHP 4 >= 4.0.7, PECL mailparse:0.9-2.1.1)

mailparse_determine_best_xfer_encoding — Gets the best way of encoding

Popis

string mailparse_determine_best_xfer_encoding ( resource $fp )

Figures out the best way of encoding the content read from the given file pointer.

Seznam parametrů

fp

A valid file pointer, which must be seek-able.

Návratové hodnoty

Returns one of the character encodings supported by the mbstring module.

Příklady

Příklad 983. mailparse_determine_best_xfer_encoding() example

<?php

$fp = fopen('somemail.eml', 'r');
echo 'Best encoding: ' . mailparse_determine_best_xfer_encoding($fp);

?>

Výše uvedený příklad vypíše něco jako:

Best encoding: 7bit

Předcházející | Nahoru | Další
LXXX. Mailparse Functions | Domů | mailparse_msg_create


mailparse_msg_create

(PHP 4 >= 4.0.7, PECL mailparse:0.9-2.1.1)

mailparse_msg_create — Create a mime mail resource

Popis

resource mailparse_msg_create ( void )

Create a MIME mail resource.

Návratové hodnoty

Returns a handle that can be used to parse a message.

Viz také

mailparse_msg_free()
mailparse_msg_parse_file()

Předcházející | Nahoru | Další
mailparse_determine_best_xfer_encoding | Domů | mailparse_msg_extract_part_file


mailparse_msg_extract_part_file

(PHP 4 >= 4.0.7, PECL mailparse:0.9-2.1.1)

mailparse_msg_extract_part_file — Extracts/decodes a message section

Popis

string mailparse_msg_extract_part_file ( resource $mimemail, mixed $filename [, callback $callbackfunc] )

Extracts/decodes a message section from the supplied filename.

The contents of the section will be decoded according to their transfer encoding - base64, quoted-printable and uuencoded text are supported.

Seznam parametrů

mimemail

A valid MIME resource, created with mailparse_msg_create().

filename

Can be a file name or a valid stream resource.

callbackfunc

If set, this must be either a valid callback that will be passed the extracted section, or NULL to make this function return the extracted section.

If not specified, the contents will be sent to "stdout".

Návratové hodnoty

If callbackfunc is not NULL returns TRUE on success.

If callbackfunc is set to NULL, returns the extracted section as a string.

Returns FALSE on error.

Viz také

mailparse_msg_extract_part()
mailparse_msg_extract_whole_part_file()

Předcházející | Nahoru | Další
mailparse_msg_create | Domů | mailparse_msg_extract_part


mailparse_msg_extract_part

(PHP 4 >= 4.0.7, PECL mailparse:0.9-2.1.1)

mailparse_msg_extract_part — Extracts/decodes a message section

Popis

void mailparse_msg_extract_part ( resource $mimemail, string $msgbody [, callback $callbackfunc] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

mimemail

A valid MIME resource.

msgbody

callbackfunc

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

mailparse_msg_extract_part_file()
mailparse_msg_extract_whole_part_file()

Předcházející | Nahoru | Další
mailparse_msg_extract_part_file | Domů | mailparse_msg_extract_whole_part_file


mailparse_msg_free

(PHP 4 >= 4.0.7, PECL mailparse:0.9-2.1.1)

mailparse_msg_free — Frees a MIME resource

Popis

bool mailparse_msg_free ( resource $mimemail )

Frees a MIME resource.

Seznam parametrů

mimemail

A valid MIME resource allocated by mailparse_msg_create() or mailparse_msg_parse_file().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

mailparse_msg_create()
mailparse_msg_parse_file()

Předcházející | Nahoru | Další
mailparse_msg_extract_whole_part_file | Domů | mailparse_msg_get_part_data


mailparse_msg_get_part_data

(PHP 4 >= 4.0.7, PECL mailparse:0.9-2.1.1)

mailparse_msg_get_part_data — Returns an associative array of info about the message

Popis

array mailparse_msg_get_part_data ( resource $mimemail )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

mimemail

A valid MIME resource.

Předcházející | Nahoru | Další
mailparse_msg_free | Domů | mailparse_msg_get_part


mailparse_msg_get_part

(PHP 4 >= 4.0.7, PECL mailparse:0.9-2.1.1)

mailparse_msg_get_part — Returns a handle on a given section in a mimemessage

Popis

resource mailparse_msg_get_part ( resource $mimemail, string $mimesection )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

mimemail

A valid MIME resource.

mimesection

Předcházející | Nahoru | Další
mailparse_msg_get_part_data | Domů | mailparse_msg_get_structure


mailparse_msg_get_structure

(PHP 4 >= 4.0.7, PECL mailparse:0.9-2.1.1)

mailparse_msg_get_structure — Returns an array of mime section names in the supplied message

Popis

array mailparse_msg_get_structure ( resource $mimemail )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

mimemail

A valid MIME resource.

Předcházející | Nahoru | Další
mailparse_msg_get_part | Domů | mailparse_msg_parse_file


mailparse_msg_parse_file

(PHP 4 >= 4.0.7, PECL mailparse:0.9-2.1.1)

mailparse_msg_parse_file — Parses a file

Popis

resource mailparse_msg_parse_file ( string $filename )

Parses a file. This is the optimal way of parsing a mail file that you have on disk.

Seznam parametrů

filename

Path to the file holding the message. The file is opened and streamed through the parser.

Návratové hodnoty

Returns a MIME resource representing the structure, or FALSE on error.

Viz také

mailparse_msg_free()
mailparse_msg_create()

Předcházející | Nahoru | Další
mailparse_msg_get_structure | Domů | mailparse_msg_parse


mailparse_msg_parse

(PHP 4 >= 4.0.7, PECL mailparse:0.9-2.1.1)

mailparse_msg_parse — Incrementally parse data into buffer

Popis

bool mailparse_msg_parse ( resource $mimemail, string $data )

Incrementally parse data into the supplied mime mail resource.

This function allow you to stream portions of a file at a time, rather than read and parse the whole thing.

Seznam parametrů

mimemail

A valid MIME resource.

data

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
mailparse_msg_parse_file | Domů | mailparse_rfc822_parse_addresses


mailparse_rfc822_parse_addresses

(PHP 4 >= 4.0.7, PECL mailparse:0.9-2.1.1)

mailparse_rfc822_parse_addresses — Parse RFC 822 compliant addresses

Popis

array mailparse_rfc822_parse_addresses ( string $addresses )

Parses a » RFC 822 compliant recipient list, such as that found in the To: header.

Seznam parametrů

addresses

A string containing addresses, like in: Wez Furlong <wez@example.com>, doe@example.com

Poznámka: This string must not include the header name.

Návratové hodnoty

Returns an array of associative arrays with the following keys for each recipient:

display | The recipient name, for display purpose. If this part is not set for a recipient, this key will hold the same value as address.
address | The email address
is_group | TRUE if the recipient is a newsgroup, FALSE otherwise.

Příklady

Příklad 984. mailparse_rfc822_parse_addresses() example

<?php

$to = 'Wez Furlong <wez@example.com>, doe@example.com';
var_dump(mailparse_rfc822_parse_addresses($to));

?>

Výše uvedený příklad vypíše:

array(2) {
  [0]=>
  array(3) {
    ["display"]=>
    string(11) "Wez Furlong"
    ["address"]=>
    string(15) "wez@example.com"
    ["is_group"]=>
    bool(false)
  }
  [1]=>
  array(3) {
    ["display"]=>
    string(15) "doe@example.com"
    ["address"]=>
    string(15) "doe@example.com"
    ["is_group"]=>
    bool(false)
  }
}

Předcházející | Nahoru | Další
mailparse_msg_parse | Domů | mailparse_stream_encode


mailparse_stream_encode

(PHP 4 >= 4.0.7, PECL mailparse:0.9-2.1.1)

mailparse_stream_encode — Streams data from source file pointer, apply encoding and write to destfp

Popis

bool mailparse_stream_encode ( resource $sourcefp, resource $destfp, string $encoding )

Streams data from the source file pointer, apply encoding and write to the destination file pointer.

Seznam parametrů

sourcefp

A valid file handle. The file is streamed through the parser.

destfp

The destination file handle in which the encoded data will be written.

encoding

One of the character encodings supported by the mbstring module.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 985. mailparse_stream_encode() example

<?php

// email.eml contents: hello, this is some text=hello.
$fp = fopen('email.eml', 'r');

$dest = tmpfile();

mailparse_stream_encode($fp, $dest, "quoted-printable");

rewind($dest);

// Display new file contents
fpassthru($dest);

?>

Výše uvedený příklad vypíše:

hello, this is some text=3Dhello.

Předcházející | Nahoru | Další
mailparse_rfc822_parse_addresses | Domů | mailparse_uudecode_all


mailparse_uudecode_all

(PECL mailparse:0.9-2.1.1)

mailparse_uudecode_all — Scans the data from fp and extract each embedded uuencoded file

Popis

array mailparse_uudecode_all ( resource $fp )

Scans the data from the given file pointer and extract each embedded uuencoded file into a temporary file.

Seznam parametrů

fp

A valid file pointer.

Návratové hodnoty

Returns an array of associative arrays listing filename information.

filename | Path to the temporary file name created
origfilename | The original filename, for uuencoded parts only
The first filename entry is the message body. The next entries are the decoded uuencoded files.

Příklady

Příklad 986. mailparse_uudecode_all() example

<?php

$text = <<<EOD
To: fred@example.com

hello, this is some text hello.
blah blah blah.

begin 644 test.txt
/=&AI<R!I<R!A('1E<W0*
`
end

EOD;

$fp = tmpfile();
fwrite($fp, $text);

$data = mailparse_uudecode_all($fp);

echo "BODY\n";
readfile($data[0]["filename"]);
echo "UUE ({$data[1]['origfilename']})\n";
readfile($data[1]["filename"]);

// Clean up
unlink($data[0]["filename"]);
unlink($data[1]["filename"]);

?>

Výše uvedený příklad vypíše:

BODY
To: fred@example.com

hello, this is some text hello.
blah blah blah.

UUE (test.txt)
this is a test

Předcházející | Nahoru | Další
mailparse_stream_encode | Domů | LXXXI. Matematické funkce


Matematické funkce

Předcházející VI. Reference funkcí Další

LXXXI. Matematické funkce

Úvod

Tyto matematické funkce pracují pouze s hodnotami v rozmezí typů integer a float (v současnosti odpovídají typům long resp. double jazyka C). Pokud potřebujete pracovat s většími čísly, použijte funkce pro práci s libovolně přesnými čísly.

Podívejte se také na aritmetické operátory.

Požadavky

Tyto funkce jsou k dispozici jako součást standardního modulu, který je vždy dostupný.

Instalace

K používání těchto funkcí není třeba žádná instalace, jsou součástí jádra PHP.

Konfigurace běhu

Toto rozšíření nemá definováno žádné konfigurační direktivy.

Typy prostředků

Toto rozšíření nemá definován žádný typ prostředku (resource).

Předdefinované konstanty

Konstanty z tohoto seznamu jsou vždy dostupné jako součást jádra PHP.

Tabulka 149. Matematické konstanty

Konstanta | Hodnota | Popis
M_PI | 3.14159265358979323846 | Pí
M_E | 2.7182818284590452354 | e
M_LOG2E | 1.4426950408889634074 | log_2 e
M_LOG10E | 0.43429448190325182765 | log_10 e
M_LN2 | 0.69314718055994530942 | log_e 2
M_LN10 | 2.30258509299404568402 | log_e 10
M_PI_2 | 1.57079632679489661923 | pi/2
M_PI_4 | 0.78539816339744830962 | pi/4
M_1_PI | 0.31830988618379067154 | 1/pi
M_2_PI | 0.63661977236758134308 | 2/pi
M_SQRTPI | 1.77245385090551602729 | sqrt(pi) [4.0.2]
M_2_SQRTPI | 1.12837916709551257390 | 2/sqrt(pi)
M_SQRT2 | 1.41421356237309504880 | sqrt(2)
M_SQRT3 | 1.73205080756887729352 | sqrt(3) [4.0.2]
M_SQRT1_2 | 0.70710678118654752440 | 1/sqrt(2)
M_LNPI | 1.14472988584940017414 | log_e(pi) [4.0.2]
M_EULER | 0.57721566490153286061 | Eulerova konstanta [4.0.2]

Ve verzi 4.0.0 a starších byla k dispozici pouze konstanta M_PI. Ostatní konstanty byly k dispozici od této verze. Konstanty označené [4.0.2] byly přidány v PHP 4.0.2.

Obsah

abs — Absolutní hodnota
acos — Arcus cosinus
acosh — Inversní hyperbolický cosinus
asin — Arcus sinus
asinh — Inversní hyperbolický sinus
atan2 — Arcus tangens dvou proměnných
atan — Arcus tangens
atanh — Inversní hyperbolický tangens
base_convert — Převod čísla mezi různými soustavami
bindec — Binární na desítkové
ceil — Zaokrouhlení zlomků nahoru
cos — Cosinus
cosh — Hyperbolický cosinus
decbin — Desítkové na binární
dechex — Desítkové na hexadecimální
decoct — Desítkové na osmičkové
deg2rad — Převod čísla ve stupních na radiány
exp — Vypočtení mocniny čísla e (základ přirozeného logaritmu)
expm1 — Vrátí exp(number) - 1 vypočítaný způsobem, který je přesný i v případě, že je hodonota parametru blízká nule
floor — Zaokrouhlení zlomků dolů
fmod — Neceločíselný zbytek dělení (modulus) dvou parametrů
getrandmax — Zjištění největšího možného náhodného čísla
hexdec — Hexadecimální na desítkové
hypot — Vrátí sqrt( num1*num1 + num2*num2)
is_finite — Zjištění, zda je hodnota konečné číslo
is_infinite — Zjištění, zda je hodnota nekonečné číslo
is_nan — Zjištění, zda hodnota není číslo
lcg_value — Kombinovaný lineární kongruenční generátor
log10 — Base-10 logarithm
log1p — Returns log(1 + number), computed in a way that is accurate even when the value of number is close to zero
log — Natural logarithm
max — Nalezení největší hodnoty
min — Nalezení nejmenší hodnoty
mt_getrandmax — Zjištění největšího možného náhodného čísla
mt_rand — Generování lepšího náhodného čísla
mt_srand — Inicializace lepšího generátoru náhodných čísel
octdec — Osmičkové na desítkové
pi — Získání hodnoty pí
pow — Mocnina
rad2deg — Převod čísla v radiánech na stupně
rand — Generování náhodného čísla
round — Zaokrouhlení čísla
sin — Sinus
sinh — Hyperbolický sinus
sqrt — Odmocnina
srand — Inicializace generátoru náhodných čísel
tan — Tangens
tanh — Hyperbolický tangens
Předcházející | Nahoru | Další
mailparse_uudecode_all | Domů | abs


abs

(PHP 4, PHP 5)

abs — Absolutní hodnota

Popis

number abs ( mixed $number )

Vrátí absolutní hodnotu parametru number. Pokud je parametr number typu float, návratová hodnota je také typu float, jinak je typu integer (protože float má obvykle větší rozmezí hodnot než integer).

Příklad 987. abs() - příklad

<?php
$abs = abs(-4.2); // $abs = 4.2; (double/float)
$abs2 = abs(5);   // $abs2 = 5; (integer)
$abs3 = abs(-5);  // $abs3 = 5; (integer)
?>

Předcházející | Nahoru | Další
LXXXI. Matematické funkce | Domů | acos


acos

(PHP 4, PHP 5)

acos — Arcus cosinus

Popis

float acos ( float $arg )

Vrání arcus cosinus parametru arg v radiánech. acos() je inverzní k funkci cos(), což znamená, že a==cos(acos(a)) pro každou hodnotu z definičního oboru funkce acos().

Viz také acosh(), asin() a atan().

Předcházející | Nahoru | Další
abs | Domů | acosh


acosh

(PHP 4 >= 4.0.7, PHP 5)

acosh — Inversní hyperbolický cosinus

Popis

float acosh ( float $arg )

Vrátí inversní hyperbolický cosinus parametru arg, což je hodnota, jejíž hyperbolický cosinus je arg.

Poznámka: Tato funkce není implementována na platformách Windows.

Viz také acos(), asinh() a atanh().

Předcházející | Nahoru | Další
acos | Domů | asin


asin

(PHP 4, PHP 5)

asin — Arcus sinus

Popis

float asin ( float $arg )

Vrátí arcus sinus parametru arg v radiánech. asin() je inverzní k funkci sin(), což znamená, že a==sin(asin(a)) pro každou hodnotu z definičního oboru funkce asin().

Viz také asinh(), acos() a atan().

Předcházející | Nahoru | Další
acosh | Domů | asinh


asinh

(PHP 4 >= 4.0.7, PHP 5)

asinh — Inversní hyperbolický sinus

Popis

float asinh ( float $arg )

Vrátí inversní hyperbolický sinus parametru arg, což je hodnota, jejíž hyperbolický sinus je arg.

Poznámka: Tato funkce není implementována na platformách Windows.

Viz také asin(), acosh() a atanh().

Předcházející | Nahoru | Další
asin | Domů | atan2


atan2

(PHP 4, PHP 5)

atan2 — Arcus tangens dvou proměnných

Popis

float atan2 ( float $y, float $x )

Tato funkce spočítá arcus tangens dvou proměnných x a y. Je to skoro totéž jako spočítání arcus tangens z hodnoty y / x s tím rozdílem, že podle znamének obou argumentů je určen kvadrant výsledku.

Tato funkce vrací výsledek v radiánech, v rozmezí -PI a PI (včetně).

Viz také acos() a atan().

Předcházející | Nahoru | Další
asinh | Domů | atan


atan

(PHP 4, PHP 5)

atan — Arcus tangens

Popis

float atan ( float $arg )

Vrátí arcus tangens parametru arg v radiánech. atan() je inverzní k funkci tan(), což znamená, že a==tan(atan(a)) pro každou hodnotu z definičního oboru funkce atan().

Viz také atanh(), asin() a acos().

Předcházející | Nahoru | Další
atan2 | Domů | atanh


atanh

(PHP 4 >= 4.0.7, PHP 5)

atanh — Inversní hyperbolický tangens

Popis

float atanh ( float $arg )

Vrátí inversní hyperbolický tangens parametru arg, což je hodnota, jejíž hyperbolický tangens je arg.

Poznámka: Tato funkce není implementována na platformách Windows.

Viz také atan(), asinh() a acosh().

Předcházející | Nahoru | Další
atan | Domů | base_convert


base_convert

(PHP 4, PHP 5)

base_convert — Převod čísla mezi různými soustavami

Popis

string base_convert ( string $number, int $frombase, int $tobase )

Vrátí řetězec obsahující parametr number reprezentovaný v soustavě tobase. Soustava, ve které je parametr number je určena v parametru frombase. Oba parametry frombase a tobase musí být mezi 2 a 36 včetně. Číslice v soustavách se základem větším než 10 budou reprezentovány znaky a-z s tím, že a znamená 10, b znamená 11 až z znamená 35.

Příklad 988. base_convert()

<?php
$hexadecimal = 'A37334';
echo base_convert($hexadecimal, 16, 2);
?>

Výsledek:

101000110111001100110100

Předcházející | Nahoru | Další
atanh | Domů | bindec


bindec

(PHP 4, PHP 5)

bindec — Binární na desítkové

Popis

number bindec ( string $binary_string )

Vrátí desítkové číslo ekvivalentní binárnímu číslu uvedenému v parametru binary_string.

bindec() převádí binární číslo na typ integer. Největší číslo, které lze převést, je 31 bitů jediček neboli 2147483647 desítkově.

Viz také decbin(), octdec(), hexdec() a base_convert().

Předcházející | Nahoru | Další
base_convert | Domů | ceil


ceil

(PHP 4, PHP 5)

ceil — Zaokrouhlení zlomků nahoru

Popis

float ceil ( float $value )

Vrátí první větší celé číslo získané případným zaokrouhlením parametru value nahoru. Návratová hodnota funkce ceil() je typu float, protože typ float umožňuje uložit větší hodnoty než typ integer.

Příklad 989. ceil() - příklad

<?php
echo ceil(4.3);    // 5
echo ceil(9.999);  // 10
?>

Viz také floor() a round().

Předcházející | Nahoru | Další
bindec | Domů | cos


cos

(PHP 4, PHP 5)

cos — Cosinus

Popis

float cos ( float $arg )

cos() vrátí cosinus parametru arg. Parametr arg je v radiánech.

Příklad 990. cos() - příklad

<?php

echo cos(M_PI); // -1

?>

Viz také acos(), sin(), tan() a deg2rad().

Předcházející | Nahoru | Další
ceil | Domů | cosh


cosh

(PHP 4 >= 4.0.7, PHP 5)

cosh — Hyperbolický cosinus

Popis

float cosh ( float $arg )

Vrátí hyperbolický cosinus parametru arg, který je definován jako (exp(arg) + exp(-arg))/2.

Viz také cos(), acosh(), sin() a tan().

Předcházející | Nahoru | Další
cos | Domů | decbin


decbin

(PHP 4, PHP 5)

decbin — Desítkové na binární

Popis

string decbin ( int $number )

Vrátí řetězec obsahující binární reprezentaci čísla předaného v parametru number. Největší převoditelné číslo je 4294967295 desítkově, které se převede na 32 jedniček.

Viz také bindec(), decoct(), dechex() a base_convert().

Předcházející | Nahoru | Další
cosh | Domů | dechex


dechex

(PHP 4, PHP 5)

dechex — Desítkové na hexadecimální

Popis

string dechex ( int $number )

Vrátí řetězec obsahující hexadecimální reprezentaci čísla předaného v parametru number. Největší převoditelné číslo je 2147483647 desítkově, které se převede na "7fffffff".

Viz také hexdec(), decbin(), decoct() a base_convert().

Předcházející | Nahoru | Další
decbin | Domů | decoct


decoct

(PHP 4, PHP 5)

decoct — Desítkové na osmičkové

Popis

string decoct ( int $number )

Vrátí řetězec obsahující osmičkovou reprezentaci čísla předaného v parametru number. Největší převoditelné číslo je 2147483647 desítkově, které se převede na "17777777777".

Viz také octdec(), decbin(), dechex() a base_convert().

Předcházející | Nahoru | Další
dechex | Domů | deg2rad


deg2rad

(PHP 4, PHP 5)

deg2rad — Převod čísla ve stupních na radiány

Popis

float deg2rad ( float $number )

Tato funkce převede parametr number ve stupních na odpovídající hodnotu v radiánech.

Příklad 991. deg2rad() - příklad

<?php

echo deg2rad(45); // 0.785398163397
var_dump(deg2rad(45) === M_PI_4); // bool(true)

?>

Viz také rad2deg().

Předcházející | Nahoru | Další
decoct | Domů | exp


exp

(PHP 4, PHP 5)

exp — Vypočtení mocniny čísla e (základ přirozeného logaritmu)

Popis

float exp ( float $arg )

Vrátí e umocněné na hodnotu parametru arg.

Viz také log() a pow().

Předcházející | Nahoru | Další
deg2rad | Domů | expm1


expm1

(PHP 4 >= 4.0.7, PHP 5)

expm1 — Vrátí exp(number) - 1 vypočítaný způsobem, který je přesný i v případě, že je hodonota parametru blízká nule

Popis

float expm1 ( float $number )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
exp | Domů | floor


floor

(PHP 4, PHP 5)

floor — Zaokrouhlení zlomků dolů

Popis

float floor ( float $value )

Vrátí první menší celé číslo získané případným zaokrouhlením parametru value dolů. Návratová hodnota funkce ceil() je typu float, protože typ float umožňuje uložit větší hodnoty než typ integer.

Příklad 992. floor() - příklad

<?php
echo floor(4.3);   // 4
echo floor(9.999); // 9
?>

Viz také ceil() a round().

Předcházející | Nahoru | Další
expm1 | Domů | fmod


fmod

(PHP 4 >= 4.2.0, PHP 5)

fmod — Neceločíselný zbytek dělení (modulus) dvou parametrů

Popis

float fmod ( float $x, float $y )

Vrátí neceločíselný zbytek dělení dělence (x) dělitelem (y). Zbytek (r) je definován jako: x = i * y + r, pro nějaké celé číslo i. Pokud je parametr y nenulový, má výsledek r znaménko podle parametru x a absolutní hodnotu menší než parametr y.

Příklad 993. Použití funkce fmod()

<?php
$x = 5.7;
$y = 1.3;
$r = fmod($x, $y);
// $r equals 0.5, because 4 * 1.3 + 0.5 = 5.7
?>

Předcházející | Nahoru | Další
floor | Domů | getrandmax


getrandmax

(PHP 4, PHP 5)

getrandmax — Zjištění největšího možného náhodného čísla

Popis

int getrandmax ( void )

Vrátí největší hodnotu, kterou může vrátit funkce rand().

Viz také rand(), srand() a mt_getrandmax().

Předcházející | Nahoru | Další
fmod | Domů | hexdec


hexdec

(PHP 4, PHP 5)

hexdec — Hexadecimální na desítkové

Popis

number hexdec ( string $hex_string )

Vrátí desítkové číslo ekvivalentní hexadecimálnímu číslu uvedenému v parametru hex_string. hexdec() převádí hexadecimální číslo na typ integer. Největší číslo, které lze převést, je 7fffffff neboli 2147483647 desítkově.

hexdec() zamění všechny nehexadecimální znaky číslicí 0. V tomto případě jsou nuly vlevo ignorovány, ale nuly vpravo jsou započítány.

Příklad 994. hexdec() - příklad

<?php
var_dump(hexdec("See"));
var_dump(hexdec("ee"));
// both print "int(238)"

var_dump(hexdec("that"));
var_dump(hexdec("a0"));
// both print int(160)
?>

Viz také dechex(), bindec(), octdec() a base_convert().

Předcházející | Nahoru | Další
getrandmax | Domů | hypot


hypot

(PHP 4 >= 4.0.7, PHP 5)

hypot — Vrátí sqrt( num1*num1 + num2*num2)

Popis

float hypot ( float $x, float $y )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
hexdec | Domů | is_finite


is_finite

(PHP 4 >= 4.2.0, PHP 5)

is_finite — Zjištění, zda je hodnota konečné číslo

Popis

bool is_finite ( float $val )

Vrátí TRUE, pokud je parametr val konečné číslo v rozsahu povoleném v PHP pro typ float na dané platformě.

Viz také is_infinite() a is_nan().

Předcházející | Nahoru | Další
hypot | Domů | is_infinite


is_infinite

(PHP 4 >= 4.2.0, PHP 5)

is_infinite — Zjištění, zda je hodnota nekonečné číslo

Popis

bool is_infinite ( float $val )

Vrátí TRUE, pokud je parametr val nekonečné číslo (kladné nebo záporné), t.j. například výsledek log(0) nebo libovolná hodnota příliš velká pro typ float na dané platformě.

Viz také is_finite() a is_nan().

Předcházející | Nahoru | Další
is_finite | Domů | is_nan


is_nan

(PHP 4 >= 4.2.0, PHP 5)

is_nan — Zjištění, zda hodnota není číslo

Popis

bool is_nan ( float $val )

Vrátí TRUE, pokud je parametr val 'nečíslo', t.j. například výsledek acos(1.01).

Viz také is_finite() a is_infinite().

Předcházející | Nahoru | Další
is_infinite | Domů | lcg_value


lcg_value

(PHP 4, PHP 5)

lcg_value — Kombinovaný lineární kongruenční generátor

Popis

float lcg_value ( void )

lcg_value() vrátí pseudonáhodné číslo v rozmezí (0, 1). Funkce kombinuje dva kongruenční generátory s periodou 2^31 - 85 a 2^31 - 249. Perioda této funkce odpovídá součinu obou prvočísel.

Předcházející | Nahoru | Další
is_nan | Domů | log10


log10

(PHP 4, PHP 5)

log10 — Base-10 logarithm

Popis

float log10 ( float $arg )

Returns the base-10 logarithm of arg.

Seznam parametrů

arg

The argument to process

Návratové hodnoty

The base-10 logaritm of arg

Viz také

log()

Předcházející | Nahoru | Další
lcg_value | Domů | log1p


log1p

(PHP 4 >= 4.0.7, PHP 5)

log1p — Returns log(1 + number), computed in a way that is accurate even when the value of number is close to zero

Popis

float log1p ( float $number )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

log1p() returns log(1 + number) computed in a way that is accurante even when the value of number is close to zero. log() might only return log(1) in this case due to lack of precision.

Poznámka: Tato funkce není implementována na platformách Windows.

Seznam parametrů

number

The argument to process

Návratové hodnoty

log(1 + number)

Viz také

expm1()
log()
log10()

Předcházející | Nahoru | Další
log10 | Domů | log


log

(PHP 4, PHP 5)

log — Natural logarithm

Popis

float log ( float $arg [, float $base] )

If the optional base parameter is specified, log() returns logbase arg, otherwise log() returns the natural logarithm of arg.

Seznam parametrů

arg

The value to calculate the logarithm for

base

The optinal logarithmic base to use (defaults to 'e' and so to the natural logarithm).

Návratové hodnoty

The logarithm of arg to base, if given, or the natural logarithm.

ChangeLog (záznam změn)

Verze | Popis
Since 4.3.0 | The optinal parameter base became available. For older versions you can calculate the logarithm in base b of a number n, but using the mathematical identity: logb(n) = log(n)/log(b), where log is the neperian (or natural) logarithm.

Viz také

log10()
exp()
pow()

Předcházející | Nahoru | Další
log1p | Domů | max


max

(PHP 4, PHP 5)

max — Nalezení největší hodnoty

Popis

mixed max ( number $arg1, number $arg2 [, number $...] )
mixed max ( array $numbers )

Funkce max() vrátí číselně největší hodnotu z předaných parametrů.

Pokud je první a jediný parametr pole, vrátí funkce max() největší hodnotu z tohoto pole. Pokud je první parametr číslo, řetězec nebo desetinné číslo, je nutné funkci zavolat alespoň s dvěmi parametry. Funkce max() v tomto případě vrátí hodnotu největšího parametru. Lze porovnat neomezené množství hodnot.

Poznámka: PHP pracuje s nečíselným parametrem typu string jako s hodnotou 0, ale pokud bude tato hodnota shledána největší, vrátí funkce předaný řetězec. Pokud se jako 0 vyhodnotí více parametrů, pracuje funkce max() s parametrem, který je uveden jako první (nejvíce vlevo).

Příklad 995. Příklady použití funkce max()

<?php
echo max(1, 3, 5, 6, 7);  // 7
echo max(array(2, 4, 5)); // 5

echo max(0, 'hello');     // 0
echo max('hello', 0);     // hello
echo max(-1, 'hello');    // hello

// S více poli porovnává funkce max prvky zleva doprava
// v našem případě tedy: 2 == 2, ale 4 < 5
$val = max(array(2, 4, 8), array(2, 5, 7)); // array(2, 5, 7)

// Když jsou předané parametry typu pole i jiných typů,
// je pole vždy vyhodnoceno jako největší
$val = max('string', array(2, 5, 7), 42);   // array(2, 5, 7)
?>

Viz také min() a count().

Předcházející | Nahoru | Další
log | Domů | min


min

(PHP 4, PHP 5)

min — Nalezení nejmenší hodnoty

Popis

mixed min ( number $arg1, number $arg2 [, number $...] )
mixed min ( array $numbers )

Funkce min() vrátí číselně nejmenší hodnotu z předaných parametrů.

Pokud je první a jediný parametr pole, vrátí funkce min() nejmenší hodnotu z tohoto pole. Pokud je první parametr číslo, řetězec nebo desetinné číslo, je nutné funkci zavolat alespoň s dvěmi parametry. Funkce min() v tomto případě vrátí hodnotu nejmenšího parametru. Lze porovnat neomezené množství hodnot.

Poznámka: PHP pracuje s nečíselným parametrem typu string jako s hodnotou 0, ale pokud bude tato hodnota shledána nejmenší, vrátí funkce předaný řetězec. Pokud se jako 0 vyhodnotí více parametrů, pracuje funkce min() s parametrem, který je uveden jako první (nejvíce vlevo).

Příklad 996. Example uses of min()

<?php
echo min(2, 3, 1, 6, 7);  // 1
echo min(array(2, 4, 5)); // 2

echo min(0, 'hello');     // 0
echo min('hello', 0);     // hello
echo min('hello', -1);    // -1

// S více poli porovnává funkce min prvky zleva doprava
// v našem případě tedy: 2 == 2, ale 4 < 5
$val = min(array(2, 4, 8), array(2, 5, 1)); // array(2, 4, 8)

// Když jsou předané parametry typu pole i jiných typů, není
// pole nikdy vráceno, protože je vyhodnoceno jako největší
$val = min('string', array(2, 5, 7), 42);   // string
?>

Viz také max() a count().

Předcházející | Nahoru | Další
max | Domů | mt_getrandmax


mt_getrandmax

(PHP 4, PHP 5)

mt_getrandmax — Zjištění největšího možného náhodného čísla

Popis

int mt_getrandmax ( void )

Vrátí největší hodnotu, kterou může vrátit funkce mt_rand().

Viz také mt_rand(), mt_srand() a getrandmax().

Předcházející | Nahoru | Další
min | Domů | mt_rand


mt_rand

(PHP 4, PHP 5)

mt_rand — Generování lepšího náhodného čísla

Popis

int mt_rand ( [int $min, int $max] )

Řada generátorů náhodných čísel ze starších knihoven libc má podezřelé nebo neznámé charakteristiky a je pomalá. PHP standardně používá ve funkci rand() generátor náhodných čísel knihovny libc. Funkce mt_rand() tuto funkci plně nahrazuje. Používá generátor náhodných čísel známých charakteristik » Mersenne Twister, který generuje náhodná čísla použitelná pro různé obory kryptografie (detaily viz na domácí stránce). Také je průměrně čtyřikrát rychlejší než funkce z knihovny libc.

Pokud je funkce mt_rand() zavolána bez nepovinných parametrů min a max, vrátí pseudonáhodné číslo v rozmezí 0 až RAND_MAX. Pokud chcete například náhodné číslo v rozmezí 5 a 15 (včetně), použijte mt_rand (5, 15).

Poznámka: Od PHP 4.2.0 není třeba inicializovat generátor náhodných čísel funkcí srand() nebo mt_srand(), protože se tak nyní stane automaticky.

Poznámka: Parametr max odpovídal v PHP starších než 3.0.7 významu range. Pro získání náhodného čísla v rozmezí 5 až 15 zavolejte v těchto verzích mt_rand (5, 11).

Viz také mt_srand(),
mt_getrandmax() a
rand().

Předcházející | Nahoru | Další
mt_getrandmax | Domů | mt_srand


mt_srand

(PHP 4, PHP 5)

mt_srand — Inicializace lepšího generátoru náhodných čísel

Popis

void mt_srand ( [int $seed] )

Inicializuje generátor náhodných čísel parametrem seed. Parametr seed je od PHP 4.2.0 nepovinný. Pokud není uveden, je vygenerována co nejnáhodnější inicializace.

<?php
// inicializace mikrosekundami
function make_seed() {
    list($usec, $sec) = explode(' ', microtime());
    return (float) $sec + ((float) $usec * 100000);
}
mt_srand(make_seed());
$randval = mt_rand();
?>

Poznámka: Od PHP 4.2.0 není třeba inicializovat generátor náhodných čísel funkcí srand() nebo mt_srand(), protože se tak nyní stane automaticky.

Viz také mt_rand(), mt_getrandmax() a srand().

Předcházející | Nahoru | Další
mt_rand | Domů | octdec


octdec

(PHP 4, PHP 5)

octdec — Osmičkové na desítkové

Popis

number octdec ( string $octal_string )

Vrátí desítkové číslo ekvivalentní osmičkovému číslu uvedenému v parametru binary_string. Největší číslo, které lze převést, je 17777777777 neboli 2147483647 desítkově.

Viz také decoct(), bindec(), hexdec() a base_convert().

Předcházející | Nahoru | Další
mt_srand | Domů | pi


pi

(PHP 4, PHP 5)

pi — Získání hodnoty pí

Popis

float pi ( void )

Vrátí přibližnou hodnotu pí. Vrácená hodnota typu float má přesnost v závislosti na nastavení direktivy precision z php.ini, jejíž výchozí nastavení je 14. Kromě toho lze také použít konstantu M_PI, jejíž hodnota je stejná jako návratová hodnota funkce pi().

<?php
echo pi(); // 3.1415926535898
echo M_PI; // 3.1415926535898
?>

Předcházející | Nahoru | Další
octdec | Domů | pow


pow

(PHP 4, PHP 5)

pow — Mocnina

Popis

number pow ( number $base, number $exp )

Vrátí parametr base umocněný hodnotou parametru exp. Pokud je to možné, vrátí tato funkce integer.

Pokud mocninu nelze vypočítat, vyvolá funkce pow() varování a vrátí FALSE.

Příklad 997. Příklady použití funkce pow()

<?php

var_dump( pow(2,8) ); // int(256)
echo pow(-1,20); // 1
echo pow(0, 0); // 1

echo pow(-1, 5.5); // chyba

?>

Varování

V PHP 4.0.6 a starších byla návratová hodnota funkce pow() vždy typu float a funkce nevyvolávala varování.

Viz také exp() a sqrt().

Předcházející | Nahoru | Další
pi | Domů | rad2deg


rad2deg

(PHP 4, PHP 5)

rad2deg — Převod čísla v radiánech na stupně

Popis

float rad2deg ( float $number )

Tato funkce převede parametr number v radiánech na odpovídající hodnotu ve stupních.

Příklad 998. rad2deg() - příklad

<?php

echo rad2deg(M_PI_4); // 45

?>

Viz také deg2rad().

Předcházející | Nahoru | Další
pow | Domů | rand


rand

(PHP 4, PHP 5)

rand — Generování náhodného čísla

Popis

int rand ( [int $min, int $max] )

Pokud je funkce rand() zavolána bez nepovinných parametrů min a max, vrátí pseudonáhodné číslo v rozmezí 0 až RAND_MAX. Pokud chcete například náhodné číslo v rozmezí 5 a 15 (včetně), použijte rand (5, 15).

Poznámka: Na některých platformách (např. Windows) je RAND_MAX pouze 32768. Pokud potřebujete rozsah větší než 32768, použijte místo této funkce raději funkci mt_rand().

Poznámka: Od PHP 4.2.0 není třeba inicializovat generátor náhodných čísel funkcí srand() nebo mt_srand(), protože se tak nyní stane automaticky.

Poznámka: Parametr max odpovídal v PHP starších než 3.0.7 významu range. Pro získání náhodného čísla v rozmezí 5 až 15 zavolejte v těchto verzích rand (5, 11).

Viz také srand(),
getrandmax() a
mt_rand().

Předcházející | Nahoru | Další
rad2deg | Domů | round


round

(PHP 4, PHP 5)

round — Zaokrouhlení čísla

Popis

float round ( float $val [, int $precision] )

Vrátí hodnotu parametru val zaokrouhlenou podle parametru precision (počet čísel za desetinnou tečkou). Parametr precision může být také záporný nebo nulový (výchozí).

Příklad 999. round() - příklady

<?php
echo round(3.4);         // 3
echo round(3.5);         // 4
echo round(3.6);         // 4
echo round(3.6, 0);      // 4
echo round(1.95583, 2);  // 1.96
echo round(1241757, -3); // 1242000
echo round(5.045, 2);    // 5.04
echo round(5.055, 2);    // 5.06
?>

Poznámka: PHP ve výchozím nastavení nepřevádí správně řetězce ve tvaru "12,300.2". Viz převod z řetězců.

Poznámka: Parametr precision je k dispozici od PHP 4.

Viz také ceil(),
floor() a
number_format().

Předcházející | Nahoru | Další
rand | Domů | sin


sin

(PHP 4, PHP 5)

sin — Sinus

Popis

float sin ( float $arg )

Funkce sin() vrátí sinus parametru arg. Parametr arg je v radiánech.

<?php

// Přesnost závisí na direktivě precision
print sin(deg2rad(60));  //  0.866025403 ...
print sin(60);           // -0.304810621 ...

?>

Viz také asin(), cos(), tan() a deg2rad().

Předcházející | Nahoru | Další
round | Domů | sinh


sinh

(PHP 4 >= 4.0.7, PHP 5)

sinh — Hyperbolický sinus

Popis

float sinh ( float $arg )

Vrátí hyperbolický sinus parametru arg, který je definován jako (exp(arg) - exp(-arg))/2.

Viz také sin(), asinh(), cos() a tan().

Předcházející | Nahoru | Další
sin | Domů | sqrt


sqrt

(PHP 4, PHP 5)

sqrt — Odmocnina

Popis

float sqrt ( float $arg )

Vrátí odmocninu parametru arg.

<?php
// Přesnost závisí na direktivě precision
echo sqrt(9); // 3
echo sqrt(10); // 3.16227766 ...
?>

Viz také pow().

Předcházející | Nahoru | Další
sinh | Domů | srand


srand

(PHP 4, PHP 5)

srand — Inicializace generátoru náhodných čísel

Popis

void srand ( [int $seed] )

Inicializuje generátor náhodných čísel parametrem seed. Parametr seed je od PHP 4.2.0 nepovinný. Pokud není uveden, je vygenerována co nejnáhodnější inicializace.

<?php
// inicializace mikrosekundami
function make_seed() {
    list($usec, $sec) = explode(' ', microtime());
    return (float) $sec + ((float) $usec * 100000);
}
srand(make_seed());
$randval = rand();
?>

Poznámka: Od PHP 4.2.0 není třeba inicializovat generátor náhodných čísel funkcí srand() nebo mt_srand(), protože se tak nyní stane automaticky.

Viz také rand(),
getrandmax() a
mt_srand().

Předcházející | Nahoru | Další
sqrt | Domů | tan


tan

(PHP 4, PHP 5)

tan — Tangens

Popis

float tan ( float $arg )

Funkce tan() vrátí tangens parametru arg. Parametr arg je v radiánech.

Příklad 1000. tan() - příklad

<?php

echo tan(M_PI_2); // 1

?>

Viz také atan(), sin(), cos() a deg2rad().

Předcházející | Nahoru | Další
srand | Domů | tanh


tanh

(PHP 4 >= 4.0.7, PHP 5)

tanh — Hyperbolický tangens

Popis

float tanh ( float $arg )

Vrátí hyperbolický tangens parametru arg, který je definován jako sinh(arg)/cosh(arg).

Viz také tan(), atanh(), sin() a cos().

Předcházející | Nahoru | Další
tan | Domů | LXXXII. MaxDB PHP Extension


Multibyte String Functions

Předcházející VI. Reference funkcí Další

XCVI. Multibyte String Functions

Úvod

While there are many languages in which every necessary character can be represented by a one-to-one mapping to an 8-bit value, there are also several languages which require so many characters for written communication that they cannot be contained within the range a mere byte can code (A byte is made up of eight bits. Each bit can contain only two distinct values, one or zero. Because of this, a byte can only represent 256 unique values (two to the power of eight)). Multibyte character encoding schemes were developed to express more than 256 characters in the regular bytewise coding system.

When you manipulate (trim, split, splice, etc.) strings encoded in a multibyte encoding, you need to use special functions since two or more consecutive bytes may represent a single character in such encoding schemes. Otherwise, if you apply a non-multibyte-aware string function to the string, it probably fails to detect the beginning or ending of the multibyte character and ends up with a corrupted garbage string that most likely loses its original meaning.

mbstring provides multibyte specific string functions that help you deal with multibyte encodings in PHP. In addition to that, mbstring handles character encoding conversion between the possible encoding pairs. mbstring is designed to handle Unicode-based encodings such as UTF-8 and UCS-2 and many single-byte encodings for convenience (listed below).

PHP Character Encoding Requirements

Encodings of the following types are safely used with PHP.

  • A singlebyte encoding,

    • which has ASCII-compatible (ISO646 compatible) mappings for the characters in range of 00h to 7fh.

  • A multibyte encoding,

    • which has ASCII-compatible mappings for the characters in range of 00h to 7fh.
    • which don't use ISO2022 escape sequences.
    • which don't use a value from 00h to 7fh in any of the compounded bytes that represents a single character.

These are examples of character encodings that are unlikely to work with PHP.

JIS, SJIS, ISO-2022-JP, BIG-5

Although PHP scripts written in any of those encodings might not work, especially in the case where encoded strings appear as identifiers or literals in the script, you can almost avoid using these encodings by setting up the mbstring's transparent encoding filter function for incoming HTTP queries.

Poznámka: It's highly discouraged to use SJIS, BIG5, CP936, CP949 and GB18030 for the internal encoding unless you are familiar with the parser, the scanner and the character encoding.

Poznámka: If you are connecting to a database with PHP, it is recommended that you use the same character encoding for both the database and the internal encoding for ease of use and better performance.

If you are using PostgreSQL, the character encoding used in the database and the one used in PHP may differ as it supports automatic character set conversion between the backend and the frontend.

Instalace

mbstring is a non-default extension. This means it is not enabled by default. You must explicitly enable the module with the configure option. See the Install section for details.

The following configure options are related to the mbstring module.

  • --enable-mbstring: Enable mbstring functions. This option is required to use mbstring functions.

    libmbfl is necesarry for mbstring. libmbfl is bundled with mbstring. If libmbfl is already installed on the system, --with-libmbfl[=DIR] can be specified to use the installed library.

    As of PHP 4.3.0, mbstring extension provides enhanced support for Simplified Chinese, Traditional Chinese, Korean, and Russian in addition to Japanese.

    For PHP 4.3.3 or before,
To enable that feature, you will have to supply either one of the
following options to the LANG parameter
of --enable-mbstring=LANG;
--enable-mbstring=cn for Simplified Chinese support,
--enable-mbstring=tw for Traditional Chinese support,
--enable-mbstring=kr for Korean support,
--enable-mbstring=ru for Russian support, and
--enable-mbstring=ja for Japanese support (default).
 To enable all supported encoding, use --enable-mbstring=all.

    Poznámka: As of PHP 4.3.4, all supported encoding by libmbfl is enabled with --enable-mbstring.

  • --enable-mbstr-enc-trans : Enable HTTP input character encoding conversion using mbstring conversion engine. If this feature is enabled, HTTP input character encoding may be converted to mbstring.internal_encoding automatically.

    Poznámka: As of PHP 4.3.0, the option --enable-mbstr-enc-trans was eliminated and replaced with the runtime setting mbstring.encoding_translation. HTTP input character encoding conversion is enabled when this is set to On (the default is Off).

  • --disable-mbregex: Disable regular expression functions with multibyte character support.

Konfigurace běhu

Chování těchto funkcí je ovlivněno nastavením parametrů v php.ini.

Tabulka 167. mbstring configuration options

Name | Default | Changeable | Changelog
mbstring.language | "neutral" | PHP_INI_PERDIR | Available since PHP 4.3.0.
mbstring.detect_order | NULL | PHP_INI_ALL | Available since PHP 4.0.6.
mbstring.http_input | "pass" | PHP_INI_ALL | Available since PHP 4.0.6.
mbstring.http_output | "pass" | PHP_INI_ALL | Available since PHP 4.0.6.
mbstring.internal_encoding | NULL | PHP_INI_ALL | Available since PHP 4.0.6.
mbstring.script_encoding | NULL | PHP_INI_ALL | Available since PHP 4.3.0.
mbstring.substitute_character | NULL | PHP_INI_ALL | Available since PHP 4.0.6.
mbstring.func_overload | "0" | PHP_INI_PERDIR | PHP_INI_SYSTEM in PHP <= 4.2.3. Available since PHP 4.2.0.
mbstring.encoding_translation | "0" | PHP_INI_PERDIR | Available since PHP 4.3.0.
mbstring.strict_detection | "0" | PHP_INI_ALL | Available since PHP 5.1.2.

For the definition of the PHP_INI_* constants, please refer to ini_set().

Zde je stručný popis konfiguračních direktiv.

mbstring.language string

The default national language setting (NLS) used in mbstring. Note that this option automagically defines mbstring.internal_encoding and mbstring.internal_encoding should be placed after mbstring.language in php.ini

mbstring.encoding_translation boolean

Enables the transparent character encoding filter for the incoming HTTP queries, which performs detection and conversion of the input encoding to the internal character encoding.

mbstring.internal_encoding string

Defines the default internal character encoding.

mbstring.http_input string

Defines the default HTTP input character encoding.

mbstring.http_output string

Defines the default HTTP output character encoding.

mbstring.detect_order string

Defines default character code detection order. See also mb_detect_order().

mbstring.substitute_character string

Defines character to substitute for invalid character encoding.

mbstring.func_overload string

Overloads a set of single byte functions by the mbstring counterparts. See Function overloading for more information.

mbstring.strict_detection boolean

Enables the strict encoding detection.

According to the » HTML 4.01 specification, Web browsers are allowed to encode a form being submitted with a character encoding different from the one used for the page. See mb_http_input() to detect character encoding used by browsers.

Although popular browsers are capable of giving a reasonably accurate guess to the character encoding of a given HTML document, it would be better to set the charset parameter in the Content-Type HTTP header to the appropriate value by header() or default_charset ini setting.

Příklad 1217. php.ini setting examples

; Set default language
mbstring.language        = Neutral; Set default language to Neutral(UTF-8) (default)
mbstring.language        = English; Set default language to English
mbstring.language        = Japanese; Set default language to Japanese

;; Set default internal encoding
;; Note: Make sure to use character encoding works with PHP
mbstring.internal_encoding    = UTF-8  ; Set internal encoding to UTF-8

;; HTTP input encoding translation is enabled.
mbstring.encoding_translation = On

;; Set default HTTP input character encoding
;; Note: Script cannot change http_input setting.
mbstring.http_input           = pass    ; No conversion.
mbstring.http_input           = auto    ; Set HTTP input to auto
                                ; "auto" is expanded to "ASCII,JIS,UTF-8,EUC-JP,SJIS"
mbstring.http_input           = SJIS    ; Set HTTP2 input to  SJIS
mbstring.http_input           = UTF-8,SJIS,EUC-JP ; Specify order

;; Set default HTTP output character encoding
mbstring.http_output          = pass    ; No conversion
mbstring.http_output          = UTF-8   ; Set HTTP output encoding to UTF-8

;; Set default character encoding detection order
mbstring.detect_order         = auto    ; Set detect order to auto
mbstring.detect_order         = ASCII,JIS,UTF-8,SJIS,EUC-JP ; Specify order

;; Set default substitute character
mbstring.substitute_character = 12307   ; Specify Unicode value
mbstring.substitute_character = none    ; Do not print character
mbstring.substitute_character = long    ; Long Example: U+3000,JIS+7E7E

Příklad 1218. php.ini setting for EUC-JP users

;; Disable Output Buffering
output_buffering      = Off

;; Set HTTP header charset
default_charset       = EUC-JP

;; Set default language to Japanese
mbstring.language = Japanese

;; HTTP input encoding translation is enabled.
mbstring.encoding_translation = On

;; Set HTTP input encoding conversion to auto
mbstring.http_input   = auto

;; Convert HTTP output to EUC-JP
mbstring.http_output  = EUC-JP

;; Set internal encoding to EUC-JP
mbstring.internal_encoding = EUC-JP

;; Do not print invalid characters
mbstring.substitute_character = none

Příklad 1219. php.ini setting for SJIS users

;; Enable Output Buffering
output_buffering     = On

;; Set mb_output_handler to enable output conversion
output_handler       = mb_output_handler

;; Set HTTP header charset
default_charset      = Shift_JIS

;; Set default language to Japanese
mbstring.language = Japanese

;; Set http input encoding conversion to auto
mbstring.http_input  = auto

;; Convert to SJIS
mbstring.http_output = SJIS

;; Set internal encoding to EUC-JP
mbstring.internal_encoding = EUC-JP

;; Do not print invalid characters
mbstring.substitute_character = none

Typy prostředků

Toto rozšíření nemá definován žádný typ prostředku (resource).

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

MB_OVERLOAD_MAIL (integer)
MB_OVERLOAD_STRING (integer)
MB_OVERLOAD_REGEX (integer)
MB_CASE_UPPER (integer)
MB_CASE_LOWER (integer)
MB_CASE_TITLE (integer)

HTTP Input and Output

HTTP input/output character encoding conversion may convert binary data also. Users are supposed to control character encoding conversion if binary data is used for HTTP input/output.

Poznámka: In PHP 4.3.2 or earlier versions, there was a limitation in this functionality that mbstring does not perform character encoding conversion in POST data if the enctype attribute in the form element is set to multipart/form-data. So you have to convert the incoming data by yourself in this case if necessary.

Beginning with PHP 4.3.3, if enctype for HTML form is set to multipart/form-data and mbstring.encoding_translation is set to On in php.ini the POST'ed variables and the names of uploaded files will be converted to the internal character encoding as well. However, the conversion isn't applied to the query keys.

  • HTTP Input

    There is no way to control HTTP input character conversion from a PHP script. To disable HTTP input character conversion, it has to be done in php.ini.

    Příklad 1220. Disable HTTP input conversion in php.ini

    ;; Disable HTTP Input conversion
    mbstring.http_input = pass
    ;; Disable HTTP Input conversion (PHP 4.3.0 or higher)
    mbstring.encoding_translation = Off

    When using PHP as an Apache module, it is possible to override those settings in each Virtual Host directive in httpd.conf or per directory with .htaccess. Refer to the Configuration section and Apache Manual for details.

  • HTTP Output

    There are several ways to enable output character encoding conversion. One is using php.ini, another is using ob_start() with mb_output_handler() as the ob_start callback function.

    Poznámka: PHP3-i18n users should note that mbstring's output conversion differs from PHP3-i18n. Character encoding is converted using an output buffer.

Příklad 1221. php.ini setting example

;; Enable output character encoding conversion for all PHP pages

;; Enable Output Buffering
output_buffering    = On

;; Set mb_output_handler to enable output conversion
output_handler      = mb_output_handler

Příklad 1222. Script example

<?php

// Enable output character encoding conversion only for this page

// Set HTTP output character encoding to SJIS
mb_http_output('SJIS');

// Start buffering and specify "mb_output_handler" as
// callback function
ob_start('mb_output_handler');

?>

Supported Character Encodings

Currently the following character encodings are supported by the mbstring module. Any of those Character encodings can be specified in the encoding parameter of mbstring functions.

The following character encodings are supported in this PHP extension:

  • UCS-4
  • UCS-4BE
  • UCS-4LE
  • UCS-2
  • UCS-2BE
  • UCS-2LE
  • UTF-32
  • UTF-32BE
  • UTF-32LE
  • UTF-16
  • UTF-16BE
  • UTF-16LE
  • UTF-7
  • UTF7-IMAP
  • UTF-8
  • ASCII
  • EUC-JP
  • SJIS
  • eucJP-win
  • SJIS-win
  • ISO-2022-JP
  • JIS
  • ISO-8859-1
  • ISO-8859-2
  • ISO-8859-3
  • ISO-8859-4
  • ISO-8859-5
  • ISO-8859-6
  • ISO-8859-7
  • ISO-8859-8
  • ISO-8859-9
  • ISO-8859-10
  • ISO-8859-13
  • ISO-8859-14
  • ISO-8859-15
  • byte2be
  • byte2le
  • byte4be
  • byte4le
  • BASE64
  • HTML-ENTITIES
  • 7bit
  • 8bit
  • EUC-CN
  • CP936
  • HZ
  • EUC-TW
  • CP950
  • BIG-5
  • EUC-KR
  • UHC (CP949)
  • ISO-2022-KR
  • Windows-1251 (CP1251)
  • Windows-1252 (CP1252)
  • CP866 (IBM866)
  • KOI8-R

Any php.ini entry which accepts an encoding name can also use the values "auto" and "pass". mbstring functions which accept an encoding name can also use the value "auto".

If "pass" is set, no character encoding conversion is performed.

If "auto" is set, it is expanded to the list of encodings defined per the NLS. For instance, if the NLS is set to Japanese, the value is assumed to be "ASCII,JIS,UTF-8,EUC-JP,SJIS".

See also mb_detect_order()

Function Overloading Feature

You might often find it difficult to get an existing PHP application to work in a given multibyte environment. This happens because most PHP applications out there are written with the standard string functions such as substr(), which are known to not properly handle multibyte-encoded strings.

mbstring supports a 'function overloading' feature which enables you to add multibyte awareness to such an application without code modification by overloading multibyte counterparts on the standard string functions. For example, mb_substr() is called instead of substr() if function overloading is enabled. This feature makes it easy to port applications that only support single-byte encodings to a multibyte environment in many cases.

To use function overloading, set mbstring.func_overload in php.ini to a positive value that represents a combination of bitmasks specifying the categories of functions to be overloaded. It should be set to 1 to overload the mail() function. 2 for string functions, 4 for regular expression functions. For example, if it is set to 7, mail, strings and regular expression functions will be overloaded. The list of overloaded functions are shown below.

Tabulka 168. Functions to be overloaded

value of mbstring.func_overload | original function | overloaded function
1 | mail() | mb_send_mail()
2 | strlen() | mb_strlen()
2 | strpos() | mb_strpos()
2 | strrpos() | mb_strrpos()
2 | substr() | mb_substr()
2 | strtolower() | mb_strtolower()
2 | strtoupper() | mb_strtoupper()
2 | substr_count() | mb_substr_count()
4 | ereg() | mb_ereg()
4 | eregi() | mb_eregi()
4 | ereg_replace() | mb_ereg_replace()
4 | eregi_replace() | mb_eregi_replace()
4 | split() | mb_split()

Poznámka: It is not recommended to use the function overloading option in the per-directory context, because it's not confirmed yet to be stable enough in a production environment and may lead to undefined behaviour.

Basics of Japanese multi-byte encodings

Japanese characters can only be represented by multibyte encodings, and multiple encoding standards are used depending on platform and text purpose. To make matters worse, these encoding standards differ slightly from one another. In order to create a web application which would be usable in a Japanese environment, a developer has to keep these complexities in mind to ensure that the proper character encodings are used.

  • Storage for a character can be up to six bytes
  • Most Japanese multibyte characters appear twice as wide as single-byte characters. These characters are called "zen-kaku" in Japanese, which means "full width". Other, narrower, characters are called "han-kaku", which means "half width". The graphical properties of the characters, however, depends upon the type faces used to display them.
  • Some character encodings use shift(escape) sequences defined in ISO-2022 to switch the code map of the specific code area (00h to 7fh).
  • ISO-2022-JP should be used in SMTP/NNTP, and headers and entities should be reencoded as per RFC requirements. Although those are not requisites, it's still a good idea because several popular user agents cannot recognize any other encoding methods.
  • Web pages created for mobile phone services such as » i-mode, » Vodafone live!, or » EZweb are supposed to use Shift_JIS.

References

Multibyte character encoding schemes and their related issues are fairly complicated, and are beyond the scope of this documentation. Please refer to the following URLs and other resources for further information regarding these topics.

  • Unicode materials

    » http://www.unicode.org/

  • Japanese/Korean/Chinese character information

    » http://examples.oreilly.com/cjkvinfo/doc/cjk.inf

Summaries of supported encodings

Summaries of supported encodings
Name in the IANA character set registry: ISO-10646-UCS-4
Underlying character set: ISO 10646
Description: The Universal Character Set with 31-bit code space, standardized as UCS-4 by ISO/IEC 10646. It is kept synchronized with the latest version of the Unicode code map.
Additional note: If this name is used in the encoding conversion facility, the converter attempts to identify by the preceding BOM (byte order mark)in which endian the subsequent bytes are represented.
Name in the IANA character set registry: ISO-10646-UCS-4
Underlying character set: UCS-4
Description: See above.
Additional note: In contrast to UCS-4, strings are always assumed to be in big endian form.
Name in the IANA character set registry: ISO-10646-UCS-4
Underlying character set: UCS-4
Description: See above.
Additional note: In contrast to UCS-4, strings are always assumed to be in little endian form.
Name in the IANA character set registry: ISO-10646-UCS-2
Underlying character set: UCS-2
Description: The Universal Character Set with 16-bit code space, standardized as UCS-2 by ISO/IEC 10646. It is kept synchronized with the latest version of the unicode code map.
Additional note: If this name is used in the encoding conversion facility, the converter attempts to identify by the preceding BOM (byte order mark)in which endian the subsequent bytes are represented.
Name in the IANA character set registry: ISO-10646-UCS-2
Underlying character set: UCS-2
Description: See above.
Additional note: In contrast to UCS-2, strings are always assumed to be in big endian form.
Name in the IANA character set registry: ISO-10646-UCS-2
Underlying character set: UCS-2
Description: See above.
Additional note: In contrast to UCS-2, strings are always assumed to be in little endian form.
Name in the IANA character set registry: UTF-32
Underlying character set: Unicode
Description: Unicode Transformation Format of 32-bit unit width, whose encoding space refers to the Unicode's codeset standard. This encoding scheme wasn't identical to UCS-4 because the code space of Unicode were limited to a 21-bit value.
Additional note: If this name is used in the encoding conversion facility, the converter attempts to identify by the preceding BOM (byte order mark)in which endian the subsequent bytes are represented.
Name in the IANA character set registry: UTF-32BE
Underlying character set: Unicode
Description: See above
Additional note: In contrast to UTF-32, strings are always assumed to be in big endian form.
Name in the IANA character set registry: UTF-32LE
Underlying character set: Unicode
Description: See above
Additional note: In contrast to UTF-32, strings are always assumed to be in little endian form.
Name in the IANA character set registry: UTF-16
Underlying character set: Unicode
Description: Unicode Transformation Format of 16-bit unit width. It's worth a note that UTF-16 is no longer the same specification as UCS-2 because the surrogate mechanism has been introduced since Unicode 2.0 and UTF-16 now refers to a 21-bit code space.
Additional note: If this name is used in the encoding conversion facility, the converter attempts to identify by the preceding BOM (byte order mark)in which endian the subsequent bytes are represented.
Name in the IANA character set registry: UTF-16BE
Underlying character set: Unicode
Description: See above.
Additional note: In contrast to UTF-16, strings are always assumed to be in big endian form.
Name in the IANA character set registry: UTF-16LE
Underlying character set: Unicode
Description: See above.
Additional note: In contrast to UTF-16, strings are always assumed to be in little endian form.
Name in the IANA character set registry: UTF-8
Underlying character set: Unicode / UCS
Description: Unicode Transformation Format of 8-bit unit width.
Additional note: none
Name in the IANA character set registry: UTF-7
Underlying character set: Unicode
Description: A mail-safe transformation format of Unicode, specified in » RFC2152.
Additional note: none
Name in the IANA character set registry: (none)
Underlying character set: Unicode
Description: A variant of UTF-7 which is specialized for use in the » IMAP protocol.
Additional note: none
Name in the IANA character set registry: US-ASCII (preferred MIME name) / iso-ir-6 / ANSI_X3.4-1986 / ISO_646.irv:1991 / ASCII / ISO646-US / us / IBM367 / CP367 / csASCII
Underlying character set: ASCII / ISO 646
Description: American Standard Code for Information Interchange is a commonly-used 7-bit encoding. Also standardized as an international standard, ISO 646.
Additional note: (none)
Name in the IANA character set registry: EUC-JP (preferred MIME name) / Extended_UNIX_Code_Packed_Format_for_Japanese / csEUCPkdFmtJapanese
Underlying character set: Compound of US-ASCII / JIS X0201:1997 (hankaku kana part) / JIS X0208:1990 / JIS X0212:1990
Description: As you see the name is derived from an abbreviation of Extended UNIX Code Packed Format for Japanese, this encoding is mostly used on UNIX or alike platforms. The original encoding scheme, Extended UNIX Code, is designed on the basis of ISO 2022.
Additional note: The character set referred to by EUC-JP is different to IBM932 / CP932, which are used by OS/2® and Microsoft® Windows®. For information interchange with those platforms, use EUCJP-WIN instead.
Name in the IANA character set registry: Shift_JIS (preferred MIME name) / MS_Kanji / csShift_JIS
Underlying character set: Compound of JIS X0201:1997 / JIS X0208:1997
Description: Shift_JIS was developed in early 80's, at the time personal Japanese word processors were brought into the market, in order to maintain compatiblities with the legacy encoding scheme JIS X 0201:1976. According to the IANA definition the codeset of Shift_JIS is slightly different to IBM932 / CP932. However, the names "SJIS" / "Shift_JIS" are often wrongly used to refer to these codesets.
Additional note: For the CP932 codemap, use SJIS-WIN instead.
Name in the IANA character set registry: (none)
Underlying character set: Compound of JIS X0201:1997 / JIS X0208:1997 / IBM extensions / NEC extensions
Description: While this "encoding" uses the same encoding scheme as EUC-JP, the underlying character set is different. That is, some code points map to different characters than EUC-JP.
Additional note: none
Name in the IANA character set registry: Windows-31J / csWindows31J
Underlying character set: Compound of JIS X0201:1997 / JIS X0208:1997 / IBM extensions / NEC extensions
Description: While this "encoding" uses the same encoding scheme as Shift_JIS, the underlying character set is different. That means some code points map to different characters than Shift_JIS.
Additional note: (none)
Name in the IANA character set registry: ISO-2022-JP (preferred MIME name) / csISO2022JP
Underlying character set: US-ASCII / JIS X0201:1976 / JIS X0208:1978 / JIS X0208:1983
Description: » RFC1468
Additional note: (none)
Name in the IANA character set registry: JIS
Underlying character set:
Description:
Additional note:
Name in the IANA character set registry: ISO-8859-1
Underlying character set:
Description:
Additional note:
Name in the IANA character set registry: ISO-8859-2
Underlying character set:
Description:
Additional note:
Name in the IANA character set registry: ISO-8859-3
Underlying character set:
Description:
Additional note:
Name in the IANA character set registry: ISO-8859-4
Underlying character set:
Description:
Additional note:
Name in the IANA character set registry: ISO-8859-5
Underlying character set:
Description:
Additional note:
Name in the IANA character set registry: ISO-8859-6
Underlying character set:
Description:
Additional note:
Name in the IANA character set registry: ISO-8859-7
Underlying character set:
Description:
Additional note:
Name in the IANA character set registry: ISO-8859-8
Underlying character set:
Description:
Additional note:
Name in the IANA character set registry: ISO-8859-9
Underlying character set:
Description:
Additional note:
Name in the IANA character set registry: ISO-8859-10
Underlying character set:
Description:
Additional note:
Name in the IANA character set registry: ISO-8859-13
Underlying character set:
Description:
Additional note:
Name in the IANA character set registry: ISO-8859-14
Underlying character set:
Description:
Additional note:
Name in the IANA character set registry: ISO-8859-15
Underlying character set:
Description:
Additional note:
Name in the IANA character set registry: byte2be
Underlying character set:
Description:
Additional note:
Name in the IANA character set registry: byte2le
Underlying character set:
Description:
Additional note:
Name in the IANA character set registry: byte4be
Underlying character set:
Description:
Additional note:
Name in the IANA character set registry: byte4le
Underlying character set:
Description:
Additional note:
Name in the IANA character set registry: BASE64
Underlying character set:
Description:
Additional note:
Name in the IANA character set registry: HTML-ENTITIES
Underlying character set:
Description:
Additional note:
Name in the IANA character set registry: 7bit
Underlying character set:
Description:
Additional note:
Name in the IANA character set registry: 8bit
Underlying character set:
Description:
Additional note:
Name in the IANA character set registry: EUC-CN
Underlying character set:
Description:
Additional note:
Name in the IANA character set registry: CP936
Underlying character set:
Description:
Additional note:
Name in the IANA character set registry: HZ
Underlying character set:
Description:
Additional note:
Name in the IANA character set registry: EUC-TW
Underlying character set:
Description:
Additional note:
Name in the IANA character set registry: CP950
Underlying character set:
Description:
Additional note:
Name in the IANA character set registry: BIG-5
Underlying character set:
Description:
Additional note:
Name in the IANA character set registry: EUC-KR
Underlying character set:
Description:
Additional note:
Name in the IANA character set registry: UHC (CP949)
Underlying character set:
Description:
Additional note:
Name in the IANA character set registry: ISO-2022-KR
Underlying character set:
Description:
Additional note:
Name in the IANA character set registry: Windows-1251 (CP1251)
Underlying character set:
Description:
Additional note:
Name in the IANA character set registry: Windows-1252 (CP1252)
Underlying character set:
Description:
Additional note:
Name in the IANA character set registry: CP866 (IBM866)
Underlying character set:
Description:
Additional note:
Name in the IANA character set registry: KOI8-R
Underlying character set:
Description:
Additional note:

Obsah

mb_check_encoding — Check if the string is valid for the specified encoding
mb_convert_case — Perform case folding on a string
mb_convert_encoding — Convert character encoding
mb_convert_kana — Convert "kana" one from another ("zen-kaku", "han-kaku" and more)
mb_convert_variables — Convert character code in variable(s)
mb_decode_mimeheader — Decode string in MIME header field
mb_decode_numericentity — Decode HTML numeric string reference to character
mb_detect_encoding — Detect character encoding
mb_detect_order — Set/Get character encoding detection order
mb_encode_mimeheader — Encode string for MIME header
mb_encode_numericentity — Encode character to HTML numeric string reference
mb_ereg_match — Regular expression match for multibyte string
mb_ereg_replace — Replace regular expression with multibyte support
mb_ereg_search_getpos — Returns start point for next regular expression match
mb_ereg_search_getregs — Retrieve the result from the last multibyte regular expression match
mb_ereg_search_init — Setup string and regular expression for multibyte regularexpression match
mb_ereg_search_pos — Return position and length of matched part of multibyte regular expression for predefined multibyte string
mb_ereg_search_regs — Returns the matched part of multibyte regular expression
mb_ereg_search_setpos — Set start point of next regular expression match
mb_ereg_search — Multibyte regular expression match for predefined multibyte string
mb_ereg — Regular expression match with multibyte support
mb_eregi_replace — Replace regular expression with multibyte support ignoring case
mb_eregi — Regular expression match ignoring case with multibyte support
mb_get_info — Get internal settings of mbstring
mb_http_input — Detect HTTP input character encoding
mb_http_output — Set/Get HTTP output character encoding
mb_internal_encoding — Set/Get internal character encoding
mb_language — Set/Get current language
mb_output_handler — Callback function converts character encoding in output buffer
mb_parse_str — Parse GET/POST/COOKIE data and set global variable
mb_preferred_mime_name — Get MIME charset string
mb_regex_encoding — Returns current encoding for multibyte regex as string
mb_regex_set_options — Set/Get the default options for mbregex functions
mb_send_mail — Send encoded mail
mb_split — Split multibyte string using regular expression
mb_strcut — Get part of string
mb_strimwidth — Get truncated string with specified width
mb_stripos — Finds position of first occurrence of a string within another, case insensitive
mb_stristr — Finds first occurrence of a string within another, case insensitive
mb_strlen — Get string length
mb_strpos — Find position of first occurrence of string in a string
mb_strrchr — Finds the last occurrence of a character in a string within another
mb_strrichr — Finds the last occurrence of a character in a string within another, case insensitive
mb_strripos — Finds position of last occurrence of a string within another, case insensitive
mb_strrpos — Find position of last occurrence of a string in a string
mb_strstr — Finds first occurrence of a string within another
mb_strtolower — Make a string lowercase
mb_strtoupper — Make a string uppercase
mb_strwidth — Return width of string
mb_substitute_character — Set/Get substitution character
mb_substr_count — Count the number of substring occurrences
mb_substr — Get part of string
Předcházející | Nahoru | Další
msql | Domů | mb_check_encoding


mb_convert_case

(PHP 4 >= 4.3.0, PHP 5)

mb_convert_case — Perform case folding on a string

Popis

string mb_convert_case ( string $str, int $mode [, string $encoding] )

mb_convert_case() returns case folded version of string converted in the way specified by mode.

mode can be one of MB_CASE_UPPER, MB_CASE_LOWER or MB_CASE_TITLE.

encoding specifies the encoding of str; if omitted, the internal character encoding value will be used.

The return value is str with the appropriate case folding applied.

By contrast to the standard case folding functions such as strtolower() and strtoupper(), case folding is performed on the basis of the Unicode character properties. Thus the behaviour of this function is not affected by locale settings and it can convert any characters that have 'alphabetic' property, such as A-umlaut (Ä).

For more information about the Unicode properties, please see » http://www.unicode.org/unicode/reports/tr21/.

Příklad 1223. mb_convert_case() example

<?php
$str = "mary had a Little lamb and she loved it so";
$str = mb_convert_case($str, MB_CASE_UPPER, "UTF-8");
echo $str; // Prints MARY HAD A LITTLE LAMB AND SHE LOVED IT SO
$str = mb_convert_case($str, MB_CASE_TITLE, "UTF-8");
echo $str; // Prints Mary Had A Little Lamb And She Loved It So
?>

See also mb_strtolower(),
mb_strtoupper(),
strtolower(),
strtoupper(),
ucfirst(), a
ucwords()

Předcházející | Nahoru | Další
mb_check_encoding | Domů | mb_convert_encoding


mb_convert_encoding

(PHP 4 >= 4.0.6, PHP 5)

mb_convert_encoding — Convert character encoding

Popis

string mb_convert_encoding ( string $str, string $to_encoding [, mixed $from_encoding] )

mb_convert_encoding() converts character encoding of string str from from_encoding to to_encoding.

str : String to be converted.

from_encoding is specified by character code name before conversion. it can be array or string - comma separated enumerated list. If it is not specified, the internal encoding will be used.

Příklad 1224. mb_convert_encoding() example

<?php
/* Convert internal character encoding to SJIS */
$str = mb_convert_encoding($str, "SJIS");

/* Convert EUC-JP to UTF-7 */
$str = mb_convert_encoding($str, "UTF-7", "EUC-JP");

/* Auto detect encoding from JIS, eucjp-win, sjis-win, then convert str to UCS-2LE */
$str = mb_convert_encoding($str, "UCS-2LE", "JIS, eucjp-win, sjis-win");

/* "auto" is expanded to "ASCII,JIS,UTF-8,EUC-JP,SJIS" */
$str = mb_convert_encoding($str, "EUC-JP", "auto");
?>

See also mb_detect_order().

Předcházející | Nahoru | Další
mb_convert_case | Domů | mb_convert_kana


mb_convert_kana

(PHP 4 >= 4.0.6, PHP 5)

mb_convert_kana — Convert "kana" one from another ("zen-kaku", "han-kaku" and more)

Popis

string mb_convert_kana ( string $str [, string $option [, string $encoding]] )

mb_convert_kana() performs "han-kaku" - "zen-kaku" conversion for string str. It returns converted string. This function is only useful for Japanese.

option is conversion option. Default value is "KV".

encoding is character encoding. If it is omitted, internal character encoding is used.

Specify with combination of following options. Default value is KV.

Tabulka 169. Applicable Conversion Options

Option | Meaning
r | Convert "zen-kaku" alphabets to "han-kaku"
R | Convert "han-kaku" alphabets to "zen-kaku"
n | Convert "zen-kaku" numbers to "han-kaku"
N | Convert "han-kaku" numbers to "zen-kaku"
a | Convert "zen-kaku" alphabets and numbers to "han-kaku"
A | Convert "han-kaku" alphabets and numbers to "zen-kaku" (Characters included in "a", "A" options are U+0021 - U+007E excluding U+0022, U+0027, U+005C, U+007E)
s | Convert "zen-kaku" space to "han-kaku" (U+3000 -> U+0020)
S | Convert "han-kaku" space to "zen-kaku" (U+0020 -> U+3000)
k | Convert "zen-kaku kata-kana" to "han-kaku kata-kana"
K | Convert "han-kaku kata-kana" to "zen-kaku kata-kana"
h | Convert "zen-kaku hira-gana" to "han-kaku kata-kana"
H | Convert "han-kaku kata-kana" to "zen-kaku hira-gana"
c | Convert "zen-kaku kata-kana" to "zen-kaku hira-gana"
C | Convert "zen-kaku hira-gana" to "zen-kaku kata-kana"
V | Collapse voiced sound notation and convert them into a character. Use with "K","H"

Příklad 1225. mb_convert_kana() example

<?php
/* Convert all "kana" to "zen-kaku" "kata-kana" */
$str = mb_convert_kana($str, "KVC");

/* Convert "han-kaku" "kata-kana" to "zen-kaku" "kata-kana"
   and "zen-kaku" alpha-numeric to "han-kaku" */
$str = mb_convert_kana($str, "KVa");
?>

Předcházející | Nahoru | Další
mb_convert_encoding | Domů | mb_convert_variables


mb_convert_variables

(PHP 4 >= 4.0.6, PHP 5)

mb_convert_variables — Convert character code in variable(s)

Popis

string mb_convert_variables ( string $to_encoding, mixed $from_encoding, mixed &$vars [, mixed &$...] )

mb_convert_variables() convert character encoding of variables vars in encoding from_encoding to encoding to_encoding. It returns character encoding before conversion for success, FALSE for failure.

mb_convert_variables() join strings in Array or Object to detect encoding, since encoding detection tends to fail for short strings. Therefore, it is impossible to mix encoding in single array or object.

It from_encoding is specified by array or comma separated string, it tries to detect encoding from from-coding. When encoding is omitted, detect_order is used.

vars (3rd and larger) is reference to variable to be converted. String, Array and Object are accepted. mb_convert_variables() assumes all parameters have the same encoding.

Příklad 1226. mb_convert_variables() example

<?php
/* Convert variables $post1, $post2 to internal encoding */
$interenc = mb_internal_encoding();
$inputenc = mb_convert_variables($interenc, "ASCII,UTF-8,SJIS-win", $post1, $post2);
?>

Předcházející | Nahoru | Další
mb_convert_kana | Domů | mb_decode_mimeheader


mb_decode_mimeheader

(PHP 4 >= 4.0.6, PHP 5)

mb_decode_mimeheader — Decode string in MIME header field

Popis

string mb_decode_mimeheader ( string $str )

mb_decode_mimeheader() decodes encoded-word string str in MIME header.

It returns decoded string in internal character encoding.

See also mb_encode_mimeheader().

Předcházející | Nahoru | Další
mb_convert_variables | Domů | mb_decode_numericentity


mb_decode_numericentity

(PHP 4 >= 4.0.6, PHP 5)

mb_decode_numericentity — Decode HTML numeric string reference to character

Popis

string mb_decode_numericentity ( string $str, array $convmap [, string $encoding] )

Convert numeric string reference of string str in specified block to character. It returns converted string.

convmap is array to specifies code area to convert.

encoding is character encoding. If it is omitted, internal character encoding is used.

Příklad 1227. convmap example

$convmap = array (
   int start_code1, int end_code1, int offset1, int mask1,
   int start_code2, int end_code2, int offset2, int mask2,
   ........
   int start_codeN, int end_codeN, int offsetN, int maskN );
// Specify Unicode value for start_codeN and end_codeN
// Add offsetN to value and take bit-wise 'AND' with maskN,
// then convert value to numeric string reference.

See also mb_encode_numericentity().

Předcházející | Nahoru | Další
mb_decode_mimeheader | Domů | mb_detect_encoding


mb_detect_encoding

(PHP 4 >= 4.0.6, PHP 5)

mb_detect_encoding — Detect character encoding

Popis

string mb_detect_encoding ( string $str [, mixed $encoding_list [, bool $strict]] )

mb_detect_encoding() detects character encoding in string str. It returns detected character encoding.

encoding_list is list of character encoding. Encoding order may be specified by array or comma separated list string.

If encoding_list is omitted, detect_order is used.

strict specifies whether to use the strict encoding detection or not. Default is FALSE.

Příklad 1228. mb_detect_encoding() example

<?php
/* Detect character encoding with current detect_order */
echo mb_detect_encoding($str);

/* "auto" is expanded to "ASCII,JIS,UTF-8,EUC-JP,SJIS" */
echo mb_detect_encoding($str, "auto");

/* Specify encoding_list character encoding by comma separated list */
echo mb_detect_encoding($str, "JIS, eucjp-win, sjis-win");

/* Use array to specify encoding_list  */
$ary[] = "ASCII";
$ary[] = "JIS";
$ary[] = "EUC-JP";
echo mb_detect_encoding($str, $ary);
?>

See also mb_detect_order().

Předcházející | Nahoru | Další
mb_decode_numericentity | Domů | mb_detect_order


mb_detect_order

(PHP 4 >= 4.0.6, PHP 5)

mb_detect_order — Set/Get character encoding detection order

Popis

mixed mb_detect_order ( [mixed $encoding_list] )

mb_detect_order() sets automatic character encoding detection order to encoding_list. It returns TRUE for success, FALSE for failure.

encoding_list is array or comma separated list of character encoding. ("auto" is expanded to "ASCII, JIS, UTF-8, EUC-JP, SJIS")

If encoding_list is omitted, it returns current character encoding detection order as array.

This setting affects mb_detect_encoding() and mb_send_mail().

Poznámka: mbstring currently implements following encoding detection filters. If there is an invalid byte sequence for following encoding, encoding detection will fail.

UTF-8, UTF-7, ASCII, EUC-JP,SJIS, eucJP-win, SJIS-win, JIS, ISO-2022-JP

For ISO-8859-*, mbstring always detects as ISO-8859-*.

For UTF-16, UTF-32, UCS2 and UCS4, encoding detection will fail always.

Příklad 1229. Useless detect order example

; Always detect as ISO-8859-1
detect_order = ISO-8859-1, UTF-8

; Always detect as UTF-8, since ASCII/UTF-7 values are
; valid for UTF-8
detect_order = UTF-8, ASCII, UTF-7

Příklad 1230. mb_detect_order() examples

<?php
/* Set detection order by enumerated list */
mb_detect_order("eucjp-win,sjis-win,UTF-8");

/* Set detection order by array */
$ary[] = "ASCII";
$ary[] = "JIS";
$ary[] = "EUC-JP";
mb_detect_order($ary);

/* Display current detection order */
echo implode(", ", mb_detect_order());
?>

See also mb_internal_encoding(),
mb_http_input(),
mb_http_output() and
mb_send_mail().

Předcházející | Nahoru | Další
mb_detect_encoding | Domů | mb_encode_mimeheader


mb_encode_mimeheader

(PHP 4 >= 4.0.6, PHP 5)

mb_encode_mimeheader — Encode string for MIME header

Popis

string mb_encode_mimeheader ( string $str [, string $charset [, string $transfer_encoding [, string $linefeed [, int $indent]]]] )

mb_encode_mimeheader() encodes a given string str by the MIME header encoding scheme. Returns a converted version of the string represented in ASCII.

charset specifies the name of the character set in which str is represented in. The default value is determined by the current NLS setting (mbstring.language).

transfer_encoding specifies the scheme of MIME encoding. It should be either "B" (Base64) or "Q" (Quoted-Printable). Falls back to "B" if not given.

linefeed specifies the EOL (end-of-line) marker with which mb_encode_mimeheader() performs line-folding (a » RFC term, the act of breaking a line longer than a certain length into multiple lines. The length is currently hard-coded to 74 characters). Falls back to "\r\n" (CRLF) if not given.

Příklad 1231. mb_encode_mimeheader() example

<?php
$name = ""; // kanji
$mbox = "kru";
$doma = "gtinn.mon";
$addr = mb_encode_mimeheader($name, "UTF-7", "Q") . " <" . $mbox . "@" . $doma . ">";
echo $addr;
?>

Poznámka: This function isn't designed to break lines at higher-level contextual break points (word boundaries, etc.). This behaviour may clutter up the original string with unexpected spaces.

The indent was added as of PHP 5.

See also mb_decode_mimeheader().

Předcházející | Nahoru | Další
mb_detect_order | Domů | mb_encode_numericentity


mb_encode_numericentity

(PHP 4 >= 4.0.6, PHP 5)

mb_encode_numericentity — Encode character to HTML numeric string reference

Popis

string mb_encode_numericentity ( string $str, array $convmap [, string $encoding] )

mb_encode_numericentity() converts specified character codes in string str from HTML numeric character reference to character code. It returns converted string.

convmap is array specifies code area to convert.

encoding is character encoding.

Příklad 1232. convmap example

$convmap = array (
 int start_code1, int end_code1, int offset1, int mask1,
 int start_code2, int end_code2, int offset2, int mask2,
 ........
 int start_codeN, int end_codeN, int offsetN, int maskN );
// Specify Unicode value for start_codeN and end_codeN
// Add offsetN to value and take bit-wise 'AND' with maskN, then
// it converts value to numeric string reference.

Příklad 1233. mb_encode_numericentity() example

<?php
/* Convert Left side of ISO-8859-1 to HTML numeric character reference */
$convmap = array(0x80, 0xff, 0, 0xff);
$str = mb_encode_numericentity($str, $convmap, "ISO-8859-1");

/* Convert user defined SJIS-win code in block 95-104 to numeric
   string reference */
$convmap = array(
       0xe000, 0xe03e, 0x1040, 0xffff,
       0xe03f, 0xe0bb, 0x1041, 0xffff,
       0xe0bc, 0xe0fa, 0x1084, 0xffff,
       0xe0fb, 0xe177, 0x1085, 0xffff,
       0xe178, 0xe1b6, 0x10c8, 0xffff,
       0xe1b7, 0xe233, 0x10c9, 0xffff,
       0xe234, 0xe272, 0x110c, 0xffff,
       0xe273, 0xe2ef, 0x110d, 0xffff,
       0xe2f0, 0xe32e, 0x1150, 0xffff,
       0xe32f, 0xe3ab, 0x1151, 0xffff );
$str = mb_encode_numericentity($str, $convmap, "sjis-win");
?>

See also mb_decode_numericentity().

Předcházející | Nahoru | Další
mb_encode_mimeheader | Domů | mb_ereg_match


mb_ereg_match

(PHP 4 >= 4.2.0, PHP 5)

mb_ereg_match — Regular expression match for multibyte string

Popis

bool mb_ereg_match ( string $pattern, string $string [, string $option] )

mb_ereg_match() returns TRUE if string matches regular expression pattern, FALSE if not.

The internal encoding or the character encoding specified in mb_regex_encoding() will be used as character encoding.

See also: mb_regex_encoding(), mb_ereg().

Předcházející | Nahoru | Další
mb_encode_numericentity | Domů | mb_ereg_replace


mb_ereg_replace

(PHP 4 >= 4.2.0, PHP 5)

mb_ereg_replace — Replace regular expression with multibyte support

Popis

string mb_ereg_replace ( string $pattern, string $replacement, string $string [, string $option] )

mb_ereg_replace() scans string for matches to pattern, then replaces the matched text with replacement and returns the result string or FALSE on error. Multibyte character can be used in pattern.

Matching condition can be set by option parameter. If i is specified for this parameter, the case will be ignored. If x is specified, white space will be ignored. If m is specified, match will be executed in multiline mode and line break will be included in '.'. If p is specified, match will be executed in POSIX mode, line break will be considered as normal character. If e is specified, replacement string will be evaluated as PHP expression.

The internal encoding or the character encoding specified in mb_regex_encoding() will be used as character encoding.

See also: mb_regex_encoding(), mb_eregi_replace().

Předcházející | Nahoru | Další
mb_ereg_match | Domů | mb_ereg_search_getpos


mb_ereg_search_getpos

(PHP 4 >= 4.2.0, PHP 5)

mb_ereg_search_getpos — Returns start point for next regular expression match

Popis

int mb_ereg_search_getpos ( void )

mb_ereg_search_getpos() returns
the point to start regular expression match for
mb_ereg_search(),
mb_ereg_search_pos(),
mb_ereg_search_regs(). The position is
represented by bytes from the head of string.

The internal encoding or the character encoding specified in mb_regex_encoding() will be used as character encoding.

See also: mb_regex_encoding(), mb_ereg_search_setpos().

Předcházející | Nahoru | Další
mb_ereg_replace | Domů | mb_ereg_search_getregs


mb_ereg_search_getregs

(PHP 4 >= 4.2.0, PHP 5)

mb_ereg_search_getregs — Retrieve the result from the last multibyte regular expression match

Popis

array mb_ereg_search_getregs ( void )

mb_ereg_search_getregs() returns an array including the sub-string of matched part by last mb_ereg_search(), mb_ereg_search_pos(), mb_ereg_search_regs(). If there are some matches, the first element will have the matched sub-string, the second element will have the first part grouped with brackets, the third element will have the second part grouped with brackets, and so on. It returns FALSE on error;

The internal encoding or the character encoding specified in mb_regex_encoding() will be used as character encoding.

See also: mb_regex_encoding(), mb_ereg_search_init().

Předcházející | Nahoru | Další
mb_ereg_search_getpos | Domů | mb_ereg_search_init


mb_ereg_search_init

(PHP 4 >= 4.2.0, PHP 5)

mb_ereg_search_init — Setup string and regular expression for multibyte regularexpression match

Popis

bool mb_ereg_search_init ( string $string [, string $pattern [, string $option]] )

mb_ereg_search_init() sets string and pattern for multibyte regular expression. These values are used for mb_ereg_search(), mb_ereg_search_pos(), mb_ereg_search_regs(). It returns TRUE for success, FALSE for error.

The internal encoding or the character encoding specified in mb_regex_encoding() will be used as character encoding.

See also: mb_regex_encoding(), mb_ereg_search_regs().

Předcházející | Nahoru | Další
mb_ereg_search_getregs | Domů | mb_ereg_search_pos


mb_ereg_search_pos

(PHP 4 >= 4.2.0, PHP 5)

mb_ereg_search_pos — Return position and length of matched part of multibyte regular expression for predefined multibyte string

Popis

array mb_ereg_search_pos ( [string $pattern [, string $option]] )

mb_ereg_search_pos() returns an array including position of matched part for multibyte regular expression. The first element of the array will be the beginning of matched part, the second element will be length (bytes) of matched part. It returns FALSE on error.

The string for match is specified by mb_ereg_search_init(). If it is not specified, the previous one will be used.

The internal encoding or the character encoding specified in mb_regex_encoding() will be used as character encoding.

See also: mb_regex_encoding(), mb_ereg_search_init().

Předcházející | Nahoru | Další
mb_ereg_search_init | Domů | mb_ereg_search_regs


mb_ereg_search_regs

(PHP 4 >= 4.2.0, PHP 5)

mb_ereg_search_regs — Returns the matched part of multibyte regular expression

Popis

array mb_ereg_search_regs ( [string $pattern [, string $option]] )

mb_ereg_search_regs() executes the multibyte regular expression match, and if there are some matched part, it returns an array including substring of matched part as first element, the first grouped part with brackets as second element, the second grouped part as third element, and so on. It returns FALSE on error.

The internal encoding or the character encoding specified in mb_regex_encoding() will be used as character encoding.

See also: mb_regex_encoding(), mb_ereg_search_init().

Předcházející | Nahoru | Další
mb_ereg_search_pos | Domů | mb_ereg_search_setpos


mb_ereg_search_setpos

(PHP 4 >= 4.2.0, PHP 5)

mb_ereg_search_setpos — Set start point of next regular expression match

Popis

bool mb_ereg_search_setpos ( int $position )

mb_ereg_search_setpos() sets the starting point of match for mb_ereg_search().

The internal encoding or the character encoding specified in mb_regex_encoding() will be used as character encoding.

See also: mb_regex_encoding(), mb_ereg_search_init().

Předcházející | Nahoru | Další
mb_ereg_search_regs | Domů | mb_ereg_search


mb_ereg_search

(PHP 4 >= 4.2.0, PHP 5)

mb_ereg_search — Multibyte regular expression match for predefined multibyte string

Popis

bool mb_ereg_search ( [string $pattern [, string $option]] )

mb_ereg_search() returns TRUE if the multibyte string matches with the regular expression, FALSE for otherwise. The string for matching is set by mb_ereg_search_init(). If pattern is not specified, the previous one is used.

The internal encoding or the character encoding specified in mb_regex_encoding() will be used as character encoding.

See also: mb_regex_encoding(), mb_ereg_search_init().

Předcházející | Nahoru | Další
mb_ereg_search_setpos | Domů | mb_ereg


mb_ereg

(PHP 4 >= 4.2.0, PHP 5)

mb_ereg — Regular expression match with multibyte support

Popis

int mb_ereg ( string $pattern, string $string [, array $regs] )

mb_ereg() executes the regular expression match with multibyte support, and returns 1 if matches are found. If the optional third parameter was specified, the function returns the byte length of matched part, and the array regs will contain the substring of matched string. The functions returns 1 if it matches with the empty string. If no matches found or error happend, FALSE will be returned.

The internal encoding or the character encoding specified in mb_regex_encoding() will be used as character encoding.

See also: mb_regex_encoding(), mb_eregi()

Předcházející | Nahoru | Další
mb_ereg_search | Domů | mb_eregi_replace


mb_eregi_replace

(PHP 4 >= 4.2.0, PHP 5)

mb_eregi_replace — Replace regular expression with multibyte support ignoring case

Popis

string mb_eregi_replace ( string $pattern, string $replace, string $string [, string $option] )

mb_ereg_replace() scans string for matches to pattern, then replaces the matched text with replacement and returns the result string or FALSE on error. Multibyte character can be used in pattern. The case will be ignored. option has the same meaning as in mb_ereg_replace().

The internal encoding or the character encoding specified in mb_regex_encoding() will be used as character encoding.

See also: mb_regex_encoding(), mb_ereg_replace().

Předcházející | Nahoru | Další
mb_ereg | Domů | mb_eregi


mb_eregi

(PHP 4 >= 4.2.0, PHP 5)

mb_eregi — Regular expression match ignoring case with multibyte support

Popis

int mb_eregi ( string $pattern, string $string [, array $regs] )

mb_eregi() executes the regular expression match with multibyte support, and returns 1 if matches are found. This function ignore case. If the optional third parameter was specified, the function returns the byte length of matched part, and the array regs will contain the substring of matched string. The functions returns 1 if it matches with the empty string. If no matches found or error happend, FALSE will be returned.

The internal encoding or the character encoding specified in mb_regex_encoding() will be used as character encoding.

See also: mb_regex_encoding(), mb_ereg().

Předcházející | Nahoru | Další
mb_eregi_replace | Domů | mb_get_info


mb_get_info

(PHP 4 >= 4.2.0, PHP 5)

mb_get_info — Get internal settings of mbstring

Popis

mixed mb_get_info ( [string $type] )

mb_get_info() returns internal setting parameter of mbstring.

If type isn't specified or is specified to "all", an array having the elements "internal_encoding", "http_output", "http_input", "func_overload", "mail_charset", "mail_header_encoding", "mail_body_encoding" will be returned. The last three elements are available since PHP 5.1.3.

If type is specified for "http_output", "http_input", "internal_encoding", "func_overload", the specified setting parameter will be returned.

See also mb_internal_encoding(), mb_http_output().

Předcházející | Nahoru | Další
mb_eregi | Domů | mb_http_input


mb_http_input

(PHP 4 >= 4.0.6, PHP 5)

mb_http_input — Detect HTTP input character encoding

Popis

mixed mb_http_input ( [string $type] )

mb_http_input() returns result of HTTP input character encoding detection.

type: Input string specifies input type. "G" for GET, "P" for POST, "C" for COOKIE, "S" for string, "L" for list, "I" for whole list (will return array). If type is omitted, it returns last input type processed.

Return Value: Character encoding name. If mb_http_input() does not process specified HTTP input, it returns FALSE.

See also mb_internal_encoding(),
mb_http_output(),
mb_detect_order().

Předcházející | Nahoru | Další
mb_get_info | Domů | mb_http_output


mb_http_output

(PHP 4 >= 4.0.6, PHP 5)

mb_http_output — Set/Get HTTP output character encoding

Popis

mixed mb_http_output ( [string $encoding] )

If encoding is set, mb_http_output() sets HTTP output character encoding to encoding. Output after this function is converted to encoding. mb_http_output() returns TRUE for success and FALSE for failure.

If encoding is omitted, mb_http_output() returns current HTTP output character encoding.

See also mb_internal_encoding(),
mb_http_input(),
mb_detect_order().

Předcházející | Nahoru | Další
mb_http_input | Domů | mb_internal_encoding


mb_internal_encoding

(PHP 4 >= 4.0.6, PHP 5)

mb_internal_encoding — Set/Get internal character encoding

Popis

mixed mb_internal_encoding ( [string $encoding] )

mb_internal_encoding() sets internal character encoding to encoding If parameter is omitted, it returns current internal encoding.

encoding is used for HTTP input character encoding conversion, HTTP output character encoding conversion and default character encoding for string functions defined by mbstring module.

encoding: Character encoding name

Return Value: If encoding is set,mb_internal_encoding() returns TRUE for success, otherwise returns FALSE. If encoding is omitted, it returns current character encoding name.

Příklad 1234. mb_internal_encoding() example

<?php
/* Set internal character encoding to UTF-8 */
mb_internal_encoding("UTF-8");

/* Display current internal character encoding */
echo mb_internal_encoding();
?>

See also mb_http_input(),
mb_http_output() and
mb_detect_order().

Předcházející | Nahoru | Další
mb_http_output | Domů | mb_language


mb_language

(PHP 4 >= 4.0.6, PHP 5)

mb_language — Set/Get current language

Popis

mixed mb_language ( [string $language] )

mb_language() sets language. If language is omitted, it returns current language as string.

language setting is used for encoding e-mail messages. Valid languages are "Japanese", "ja","English","en" and "uni" (UTF-8). mb_send_mail() uses this setting to encode e-mail.

Language and its setting is ISO-2022-JP/Base64 for Japanese, UTF-8/Base64 for uni, ISO-8859-1/quoted printable for English.

Return Value: If language is set and language is valid, it returns TRUE. Otherwise, it returns FALSE. When language is omitted, it returns language name as string. If no language is set previously, it returns FALSE.

See also mb_send_mail().

Předcházející | Nahoru | Další
mb_internal_encoding | Domů | mb_output_handler


mb_output_handler

(PHP 4 >= 4.0.6, PHP 5)

mb_output_handler — Callback function converts character encoding in output buffer

Popis

string mb_output_handler ( string $contents, int $status )

mb_output_handler() is
ob_start() callback
function. mb_output_handler() converts
characters in output buffer from internal character encoding to
HTTP output character encoding.

4.1.0 or later version, this handler adds charset HTTP header when following conditions are met:

  • Does not set Content-Type by header()
  • Default MIME type begins with text/
  • http_output setting is other than pass

contents : Output buffer contents

status : Output buffer status

Return Value: String converted

Příklad 1235. mb_output_handler() example

<?php
mb_http_output("UTF-8");
ob_start("mb_output_handler");
?>

Poznámka: If you want to output some binary data such as image from PHP script with PHP 4.3.0 or later, Content-Type: header must be send using header() before any binary data was send to client (e.g. header("Content-Type: image/png")). If Content-Type: header was send, output character encoding conversion will not be performed.

Note that if 'Content-Type: text/*' was send using header(), the sending data is regarded as text, encoding conversion will be performed using character encoding settings.

If you want to output some binary data such as image from PHP script with PHP 4.2.x or earlier, you must set output encoding to "pass" using mb_http_output().

See also ob_start().

Předcházející | Nahoru | Další
mb_language | Domů | mb_parse_str


mb_parse_str

(PHP 4 >= 4.0.6, PHP 5)

mb_parse_str — Parse GET/POST/COOKIE data and set global variable

Popis

bool mb_parse_str ( string $encoded_string [, array &$result] )

mb_parse_str() parses GET/POST/COOKIE data and sets global variables. Since PHP does not provide raw POST/COOKIE data, it can only used for GET data for now. It preses URL encoded data, detects encoding, converts coding to internal encoding and set values to result array or global variables.

encoded_string: URL encoded data.

result: Array contains decoded and character encoding converted values.

Return Value: It returns TRUE for success or FALSE for failure.

See also mb_detect_order(), mb_internal_encoding().

Předcházející | Nahoru | Další
mb_output_handler | Domů | mb_preferred_mime_name


mb_preferred_mime_name

(PHP 4 >= 4.0.6, PHP 5)

mb_preferred_mime_name — Get MIME charset string

Popis

string mb_preferred_mime_name ( string $encoding )

mb_preferred_mime_name() returns MIME charset string for character encoding encoding. It returns charset string.

Příklad 1236. mb_preferred_mime_string() example

<?php
$outputenc = "sjis-win";
mb_http_output($outputenc);
ob_start("mb_output_handler");
header("Content-Type: text/html; charset=" . mb_preferred_mime_name($outputenc));
?>

Předcházející | Nahoru | Další
mb_parse_str | Domů | mb_regex_encoding


mb_regex_encoding

(PHP 4 >= 4.2.0, PHP 5)

mb_regex_encoding — Returns current encoding for multibyte regex as string

Popis

mixed mb_regex_encoding ( [string $encoding] )

mb_regex_encoding() returns the character encoding used by multibyte regex functions.

If the optional parameter encoding is specified, it is set to the character encoding for multibyte regex. The default value is the internal character encoding.

See also: mb_internal_encoding(), mb_ereg()

Předcházející | Nahoru | Další
mb_preferred_mime_name | Domů | mb_regex_set_options


mb_regex_set_options

(PHP 4 >= 4.3.0, PHP 5)

mb_regex_set_options — Set/Get the default options for mbregex functions

Popis

string mb_regex_set_options ( [string $options] )

mb_regex_set_options() sets the default options described by options for multibyte regex functions.

Returns the previous options. If options is omitted, it returns the string that describes the current options.

See also
mb_split(),
mb_ereg() and
mb_eregi()

Předcházející | Nahoru | Další
mb_regex_encoding | Domů | mb_send_mail


mb_send_mail

(PHP 4 >= 4.0.6, PHP 5)

mb_send_mail — Send encoded mail

Popis

bool mb_send_mail ( string $to, string $subject, string $message [, string $additional_headers [, string $additional_parameter]] )

mb_send_mail() sends email. Headers and
message are converted and encoded according to
mb_language() setting.
mb_send_mail() is wrapper
function of mail(). See
mail() for details.

to is mail addresses send to. Multiple recipients can be specified by putting a comma between each address in to. This parameter is not automatically encoded.

subject is subject of mail.

message is mail message.

additional_headers is inserted at the end of the header. This is typically used to add extra headers. Multiple extra headers are separated with a newline ("\n").

Poznámka: Content-Type and Content-Transfer-Encoding headers can be redefined as of PHP 5.0.0. In PHP 4, values defined by mb_language() are always used.

additional_parameter is a MTA command line parameter. It is useful when setting the correct Return-Path header when using sendmail.

Vrací TRUE při úspěchu, FALSE při selhání.

See also mail(),
mb_encode_mimeheader(), and
mb_language().

Předcházející | Nahoru | Další
mb_regex_set_options | Domů | mb_split


mb_split

(PHP 4 >= 4.2.0, PHP 5)

mb_split — Split multibyte string using regular expression

Popis

array mb_split ( string $pattern, string $string [, int $limit] )

mb_split() split multibyte string using regular expression pattern and returns the result as an array.

If optional parameter limit is specified, it will be split in limit elements as maximum.

The internal encoding or the character encoding specified in mb_regex_encoding() will be used as character encoding.

See also: mb_regex_encoding(), mb_ereg().

Předcházející | Nahoru | Další
mb_send_mail | Domů | mb_strcut


mb_strcut

(PHP 4 >= 4.0.6, PHP 5)

mb_strcut — Get part of string

Popis

string mb_strcut ( string $str, int $start [, int $length [, string $encoding]] )

mb_strcut() returns the portion of str specified by the start and length parameters.

mb_strcut() performs equivalent operation as mb_substr() with different method. If start position is multi-byte character's second byte or larger, it starts from first byte of multi-byte character.

It subtracts string from str that is shorter than length AND character that is not part of multi-byte string or not being middle of shift sequence.

encoding is character encoding. If it is not set, internal character encoding is used.

See also mb_substr(), mb_internal_encoding().

Předcházející | Nahoru | Další
mb_split | Domů | mb_strimwidth


mb_strimwidth

(PHP 4 >= 4.0.6, PHP 5)

mb_strimwidth — Get truncated string with specified width

Popis

string mb_strimwidth ( string $str, int $start, int $width [, string $trimmarker [, string $encoding]] )

mb_strimwidth() truncates string str to specified width. It returns truncated string.

If trimmarker is set, trimmarker is appended to return value.

start is start position offset. Number of characters from the beginning of string. (First character is 0)

trimmarker is string that is added to the end of string when string is truncated.

encoding is character encoding. If it is omitted, internal encoding is used.

Příklad 1237. mb_strimwidth() example

<?php
$str = mb_strimwidth($str, 0, 40, "..>");
?>

See also mb_strwidth() and mb_internal_encoding().

Předcházející | Nahoru | Další
mb_strcut | Domů | mb_stripos


mb_strlen

(PHP 4 >= 4.0.6, PHP 5)

mb_strlen — Get string length

Popis

int mb_strlen ( string $str [, string $encoding] )

mb_strlen() returns number of characters in string str having character encoding encoding. A multi-byte character is counted as 1.

encoding is character encoding for str. If encoding is omitted, internal character encoding is used.

See also mb_internal_encoding(), strlen().

Předcházející | Nahoru | Další
mb_stristr | Domů | mb_strpos


mb_strpos

(PHP 4 >= 4.0.6, PHP 5)

mb_strpos — Find position of first occurrence of string in a string

Popis

int mb_strpos ( string $haystack, string $needle [, int $offset [, string $encoding]] )

mb_strpos() returns the numeric position of the first occurrence of needle in the haystack string. If needle is not found, it returns FALSE.

mb_strpos() performs multi-byte safe strpos() operation based on number of characters. needle position is counted from the beginning of the haystack. First character's position is 0. Second character position is 1, and so on.

If encoding is omitted, internal character encoding is used.

offset is search offset. If it is not specified, 0 is used.

encoding is character encoding name. If it is omitted, internal character encoding is used.

See also mb_strrpos(),
mb_internal_encoding(),
strpos()

Předcházející | Nahoru | Další
mb_strlen | Domů | mb_strrchr


mb_strrpos

(PHP 4 >= 4.0.6, PHP 5)

mb_strrpos — Find position of last occurrence of a string in a string

Popis

int mb_strrpos ( string $haystack, string $needle [, int $offset [, string $encoding]] )

mb_strrpos() returns the numeric position of the last occurrence of needle in the haystack string. If needle is not found, it returns FALSE.

mb_strrpos() performs multi-byte safe strrpos() operation based on number of characters. needle position is counted from the beginning of haystack. First character's position is 0. Second character position is 1.

If encoding is omitted, internal encoding is assumed.

encoding is character encoding. If it is not specified, internal character encoding is used.

Poznámka: As of PHP 5.2.0 offset may be specified to begin searching an arbitrary number of characters into the string. Negative values will stop searching at an arbitrary point prior to the end of the string.

Poznámka: The encoding parameter was moved from the third position to the fourth in PHP 5.2.0. For backward compatibility, encoding can be specified as the third parameter, but doing so is deprecated and will be removed in the future.

ChangeLog (záznam změn)

Verze | Popis
5.2.0 | Added the optional parameter offset.

Viz také

mb_strpos()
mb_internal_encoding()
strrpos()

Předcházející | Nahoru | Další
mb_strripos | Domů | mb_strstr


mb_strtolower

(PHP 4 >= 4.3.0, PHP 5)

mb_strtolower — Make a string lowercase

Popis

string mb_strtolower ( string $str [, string $encoding] )

mb_strtolower() returns str with all alphabetic characters converted to lowercase.

encoding specifies the encoding of str; if omitted, the internal character encoding value will be used.

For more information about the Unicode properties, please see » http://www.unicode.org/unicode/reports/tr21/.

By contrast to strtolower(), 'alphabetic' is determined by the Unicode character properties. Thus the behaviour of this function is not affected by locale settings and it can convert any characters that have 'alphabetic' property, such as A-umlaut (Ä).

Příklad 1238. mb_strtolower() example

<?php
$str = "Mary Had A Little Lamb and She LOVED It So";
$str = mb_strtolower($str);
echo $str; // Prints mary had a little lamb and she loved it so
?>

See also strtolower(),
mb_strtoupper() and
mb_convert_case().

Předcházející | Nahoru | Další
mb_strstr | Domů | mb_strtoupper


mb_strtoupper

(PHP 4 >= 4.3.0, PHP 5)

mb_strtoupper — Make a string uppercase

Popis

string mb_strtoupper ( string $str [, string $encoding] )

mb_strtoupper() returns str with all alphabetic characters converted to uppercase.

encoding specifies the encoding of str; if omitted, the internal character encoding value will be used.

By contrast to strtoupper(), 'alphabetic' is determined by the Unicode character properties. Thus the behaviour of this function is not affected by locale settings and it can convert any characters that have 'alphabetic' property, such as a-umlaut (ä).

For more information about the Unicode properties, please see » http://www.unicode.org/unicode/reports/tr21/.

Příklad 1239. mb_strtoupper() example

<?php
$str = "Mary Had A Little Lamb and She LOVED It So";
$str = mb_strtoupper($str);
echo $str; // Prints MARY HAD A LITTLE LAMB AND SHE LOVED IT SO
?>

See also strtoupper(),
mb_strtolower() and
mb_convert_case().

Předcházející | Nahoru | Další
mb_strtolower | Domů | mb_strwidth


mb_strwidth

(PHP 4 >= 4.0.6, PHP 5)

mb_strwidth — Return width of string

Popis

int mb_strwidth ( string $str [, string $encoding] )

mb_strwidth() returns width of string str.

Multi-byte character usually twice of width compare to single byte character.

Tabulka 170. Characters width

Chars | Width
U+0000 - U+0019 | 0
U+0020 - U+1FFF | 1
U+2000 - U+FF60 | 2
U+FF61 - U+FF9F | 1
U+FFA0 - | 2

encoding is character encoding. If it is omitted, internal encoding is used.

See also: mb_strimwidth(), mb_internal_encoding().

Předcházející | Nahoru | Další
mb_strtoupper | Domů | mb_substitute_character


mb_substitute_character

(PHP 4 >= 4.0.6, PHP 5)

mb_substitute_character — Set/Get substitution character

Popis

mixed mb_substitute_character ( [mixed $substrchar] )

mb_substitute_character() specifies substitution character when input character encoding is invalid or character code is not exist in output character encoding. Invalid characters may be substituted NULL(no output), string or integer value (Unicode character code value).

This setting affects mb_convert_encoding(),
mb_convert_variables(),
mb_output_handler(),
and mb_send_mail().

substchar : Specify Unicode value as integer or specify as string as follows

  • "none" : no output
  • "long" : Output character code value (Example: U+3000,JIS+7E7E)

Return Value: If substchar is set, it returns TRUE for success, otherwise returns FALSE. If substchar is not set, it returns Unicode value or "none"/"long".

Příklad 1240. mb_substitute_character() example

<?php
/* Set with Unicode U+3013 (GETA MARK) */
mb_substitute_character(0x3013);

/* Set hex format */
mb_substitute_character("long");

/* Display current setting */
echo mb_substitute_character();
?>

Předcházející | Nahoru | Další
mb_strwidth | Domů | mb_substr_count


mb_substr_count

(PHP 4 >= 4.3.0, PHP 5)

mb_substr_count — Count the number of substring occurrences

Popis

int mb_substr_count ( string $haystack, string $needle [, string $encoding] )

mb_substr_count() returns the number of times the needle substring occurs in the haystack string.

encoding specifies the encoding for needle and haystack. If omitted, internal character encoding is used.

Příklad 1241. mb_substr_count() example

<?php
echo mb_substr_count("This is a test", "is"); // prints out 2
?>

See also substr_count(), mb_strpos(), mb_substr().

Předcházející | Nahoru | Další
mb_substitute_character | Domů | mb_substr


mb_substr

(PHP 4 >= 4.0.6, PHP 5)

mb_substr — Get part of string

Popis

string mb_substr ( string $str, int $start [, int $length [, string $encoding]] )

mb_substr() returns the portion of str specified by the start and length parameters.

mb_substr() performs multi-byte safe substr() operation based on number of characters. Position is counted from the beginning of str. First character's position is 0. Second character position is 1, and so on.

If encoding is omitted, internal encoding is assumed.

encoding is character encoding. If it is omitted, internal character encoding is used.

See also mb_strcut(), mb_internal_encoding().

Předcházející | Nahoru | Další
mb_substr_count | Domů | XCVII. muscat Functions


MCAL Functions

Předcházející VI. Reference funkcí Další

LXXXIII. MCAL Functions

Úvod

MCAL stands for Modular Calendar Access Library.

Libmcal is a C library for accessing calendars. It's written to be very modular, with pluggable drivers. MCAL is the calendar equivalent of the IMAP module for mailboxes.

With mcal support, a calendar stream can be opened much like the mailbox stream with the IMAP support. Calendars can be local file stores, remote ICAP servers, or other formats that are supported by the mcal library.

Calendar events can be pulled up, queried, and stored. There is also support for calendar triggers (alarms) and recurring events.

With libmcal, central calendar servers can be accessed, removing the need for any specific database or local file programming.

Most of the functions use an internal event structure that is unique for each stream. This alleviates the need to pass around large objects between functions. There are convenience functions for setting, initializing, and retrieving the event structure values.

Poznámka: Toto rozšíření bylo přesunuto do repozitáře PECL a již nebude součástí balíku PHP.5.0.0.

Poznámka: PHP had an ICAP extension previously, but the original library and the PHP extension is not supported anymore. The suggested replacement is MCAL.

Poznámka: Toto rozšíření není k dispozici na platformách Windows.

Požadavky

This extension requires the mcal library to be installed. Grab the latest version from » http://mcal.chek.com/ and compile and install it.

Instalace

After you installed the mcal library, to get these functions to work, you have to compile PHP -with-mcal[=DIR].

Konfigurace běhu

Toto rozšíření nemá definováno žádné konfigurační direktivy.

Typy prostředků

Toto rozšíření nemá definován žádný typ prostředku (resource).

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

MCAL_SUNDAY (integer)
MCAL_MONDAY (integer)
MCAL_TUESDAY (integer)
MCAL_WEDNESDAY (integer)
MCAL_THURSDAY (integer)
MCAL_FRIDAY (integer)
MCAL_SATURDAY (integer)
MCAL_JANUARY (integer)
MCAL_FEBRUARY (integer)
MCAL_MARCH (integer)
MCAL_APRIL (integer)
MCAL_MAY (integer)
MCAL_JUNE (integer)
MCAL_JULY (integer)
MCAL_AUGUST (integer)
MCAL_SEPTEMBER (integer)
MCAL_OCTOBER (integer)
MCAL_NOVEMBER (integer)
MCAL_DECEMBER (integer)
MCAL_RECUR_NONE (integer)
MCAL_RECUR_DAILY (integer)
MCAL_RECUR_WEEKLY (integer)
MCAL_RECUR_MONTHLY_MDAY (integer)
MCAL_RECUR_MONTHLY_WDAY (integer)
MCAL_RECUR_YEARLY (integer)
MCAL_M_SUNDAY (integer)
MCAL_M_MONDAY (integer)
MCAL_M_TUESDAY (integer)
MCAL_M_WEDNESDAY (integer)
MCAL_M_THURSDAY (integer)
MCAL_M_FRIDAY (integer)
MCAL_M_SATURDAY (integer)
MCAL_M_WEEKDAYS (integer)
MCAL_M_WEEKEND (integer)
MCAL_M_ALLDAYS (integer)

Obsah

mcal_append_event — Store a new event into an MCAL calendar
mcal_close — Close an MCAL stream
mcal_create_calendar — Create a new MCAL calendar
mcal_date_compare — Compares two dates
mcal_date_valid — Returns TRUE if the given year, month, day is a valid date
mcal_day_of_week — Returns the day of the week of the given date
mcal_day_of_year — Returns the day of the year of the given date
mcal_days_in_month — Returns the number of days in a month
mcal_delete_calendar — Delete an MCAL calendar
mcal_delete_event — Delete an event from an MCAL calendar
mcal_event_add_attribute — Adds an attribute and a value to the streams global event structure
mcal_event_init — Initializes a streams global event structure
mcal_event_set_alarm — Sets the alarm of the streams global event structure
mcal_event_set_category — Sets the category of the streams global event structure
mcal_event_set_class — Sets the class of the streams global event structure
mcal_event_set_description — Sets the description of the streams global event structure
mcal_event_set_end — Sets the end date and time of the streams global event structure
mcal_event_set_recur_daily — Sets the recurrence of the streams global event structure
mcal_event_set_recur_monthly_mday — Sets the recurrence of the streams global event structure
mcal_event_set_recur_monthly_wday — Sets the recurrence of the streams global event structure
mcal_event_set_recur_none — Sets the recurrence of the streams global event structure
mcal_event_set_recur_weekly — Sets the recurrence of the streams global event structure
mcal_event_set_recur_yearly — Sets the recurrence of the streams global event structure
mcal_event_set_start — Sets the start date and time of the streams global event structure
mcal_event_set_title — Sets the title of the streams global event structure
mcal_expunge — Deletes all events marked for being expunged
mcal_fetch_current_stream_event — Returns an object containing the current streams event structure
mcal_fetch_event — Fetches an event from the calendar stream
mcal_is_leap_year — Returns if the given year is a leap year or not
mcal_list_alarms — Return a list of events that has an alarm triggered at the given datetime
mcal_list_events — Return a list of IDs for a date or a range of dates
mcal_next_recurrence — Returns the next recurrence of the event
mcal_open — Opens up an MCAL connection
mcal_popen — Opens up a persistent MCAL connection
mcal_rename_calendar — Rename an MCAL calendar
mcal_reopen — Reopens an MCAL connection
mcal_snooze — Turn off an alarm for an event
mcal_store_event — Modify an existing event in an MCAL calendar
mcal_time_valid — Returns TRUE if the given hour, minutes and seconds is a valid time
mcal_week_of_year — Returns the week number of the given date
Předcházející | Nahoru | Další
maxdb_warning_count | Domů | mcal_append_event


mcal_append_event

(PHP 4)

mcal_append_event — Store a new event into an MCAL calendar

Description

int mcal_append_event ( int $mcal_stream )

mcal_append_event() stores the global event into an MCAL calendar for the stream mcal_stream.

Returns the id of the newly inserted event.

Předcházející | Nahoru | Další
LXXXIII. MCAL Functions | Domů | mcal_close


mcal_close

(PHP 4)

mcal_close — Close an MCAL stream

Description

bool mcal_close ( int $mcal_stream [, int $flags] )

Closes the given mcal stream.

Předcházející | Nahoru | Další
mcal_append_event | Domů | mcal_create_calendar


mcal_create_calendar

(PHP 4)

mcal_create_calendar — Create a new MCAL calendar

Description

bool mcal_create_calendar ( int $stream, string $calendar )

Creates a new calendar named calendar.

Předcházející | Nahoru | Další
mcal_close | Domů | mcal_date_compare


mcal_date_compare

(PHP 4)

mcal_date_compare — Compares two dates

Description

int mcal_date_compare ( int $a_year, int $a_month, int $a_day, int $b_year, int $b_month, int $b_day )

mcal_date_compare() Compares the two given dates, returns <0, 0, >0 if a<b, a==b, a>b respectively.

Předcházející | Nahoru | Další
mcal_create_calendar | Domů | mcal_date_valid


mcal_date_valid

(PHP 4)

mcal_date_valid — Returns TRUE if the given year, month, day is a valid date

Description

bool mcal_date_valid ( int $year, int $month, int $day )

mcal_date_valid() Returns TRUE if the given year, month and day is a valid date, FALSE if not.

Předcházející | Nahoru | Další
mcal_date_compare | Domů | mcal_day_of_week


mcal_day_of_week

(PHP 4)

mcal_day_of_week — Returns the day of the week of the given date

Description

int mcal_day_of_week ( int $year, int $month, int $day )

mcal_day_of_week() returns the day of the week of the given date. Possible return values range from 0 for Sunday through 6 for Saturday.

Předcházející | Nahoru | Další
mcal_date_valid | Domů | mcal_day_of_year


mcal_day_of_year

(PHP 4)

mcal_day_of_year — Returns the day of the year of the given date

Description

int mcal_day_of_year ( int $year, int $month, int $day )

mcal_day_of_year() returns the day of the year of the given date.

Předcházející | Nahoru | Další
mcal_day_of_week | Domů | mcal_days_in_month


mcal_days_in_month

(PHP 4)

mcal_days_in_month — Returns the number of days in a month

Description

int mcal_days_in_month ( int $month, int $leap_year )

mcal_days_in_month() returns the number of days in the month month, taking into account if the considered year is a leap year or not.

Předcházející | Nahoru | Další
mcal_day_of_year | Domů | mcal_delete_calendar


mcal_delete_calendar

(PHP 4)

mcal_delete_calendar — Delete an MCAL calendar

Description

bool mcal_delete_calendar ( int $stream, string $calendar )

Deletes the calendar named calendar.

Předcházející | Nahoru | Další
mcal_days_in_month | Domů | mcal_delete_event


mcal_delete_event

(PHP 4)

mcal_delete_event — Delete an event from an MCAL calendar

Description

bool mcal_delete_event ( int $mcal_stream, int $event_id )

mcal_delete_event() deletes the calendar event specified by the event_id.

Returns TRUE.

Předcházející | Nahoru | Další
mcal_delete_calendar | Domů | mcal_event_add_attribute


mcal_event_add_attribute

(PHP 4)

mcal_event_add_attribute — Adds an attribute and a value to the streams global event structure

Description

bool mcal_event_add_attribute ( int $stream, string $attribute, string $value )

mcal_event_add_attribute() adds an attribute to the stream's global event structure with the value given by "value".

Předcházející | Nahoru | Další
mcal_delete_event | Domů | mcal_event_init


mcal_event_init

(PHP 4)

mcal_event_init — Initializes a streams global event structure

Description

void mcal_event_init ( int $stream )

mcal_event_init() initializes a streams global event structure. this effectively sets all elements of the structure to 0, or the default settings.

Předcházející | Nahoru | Další
mcal_event_add_attribute | Domů | mcal_event_set_alarm


mcal_event_set_alarm

(PHP 4)

mcal_event_set_alarm — Sets the alarm of the streams global event structure

Description

void mcal_event_set_alarm ( int $stream, int $alarm )

mcal_event_set_alarm() sets the streams global event structure's alarm to the given minutes before the event.

Předcházející | Nahoru | Další
mcal_event_init | Domů | mcal_event_set_category


mcal_event_set_category

(PHP 4)

mcal_event_set_category — Sets the category of the streams global event structure

Description

void mcal_event_set_category ( int $stream, string $category )

mcal_event_set_category() sets the streams global event structure's category to the given string.

Předcházející | Nahoru | Další
mcal_event_set_alarm | Domů | mcal_event_set_class


mcal_event_set_class

(PHP 4)

mcal_event_set_class — Sets the class of the streams global event structure

Description

void mcal_event_set_class ( int $stream, int $class )

mcal_event_set_class() sets the streams global event structure's class to the given value. The class is either 1 for public, or 0 for private.

Předcházející | Nahoru | Další
mcal_event_set_category | Domů | mcal_event_set_description


mcal_event_set_description

(PHP 4)

mcal_event_set_description — Sets the description of the streams global event structure

Description

void mcal_event_set_description ( int $stream, string $description )

mcal_event_set_description() sets the streams global event structure's description to the given string.

Předcházející | Nahoru | Další
mcal_event_set_class | Domů | mcal_event_set_end


mcal_event_set_end

(PHP 4)

mcal_event_set_end — Sets the end date and time of the streams global event structure

Description

void mcal_event_set_end ( int $stream, int $year, int $month, int $day [, int $hour [, int $min [, int $sec]]] )

mcal_event_set_end() sets the streams global event structure's end date and time to the given values.

Předcházející | Nahoru | Další
mcal_event_set_description | Domů | mcal_event_set_recur_daily


mcal_event_set_recur_daily

(PHP 4)

mcal_event_set_recur_daily — Sets the recurrence of the streams global event structure

Description

void mcal_event_set_recur_daily ( int $stream, int $year, int $month, int $day, int $interval )

mcal_event_set_recur_daily() sets the streams global event structure's recurrence to the given value to be reoccurring on a daily basis, ending at the given date.

Předcházející | Nahoru | Další
mcal_event_set_end | Domů | mcal_event_set_recur_monthly_mday


mcal_event_set_recur_monthly_mday

(PHP 4)

mcal_event_set_recur_monthly_mday — Sets the recurrence of the streams global event structure

Description

void mcal_event_set_recur_monthly_mday ( int $stream, int $year, int $month, int $day, int $interval )

mcal_event_set_recur_monthly_mday() sets the streams global event structure's recurrence to the given value to be reoccurring on a monthly by month day basis, ending at the given date.

Předcházející | Nahoru | Další
mcal_event_set_recur_daily | Domů | mcal_event_set_recur_monthly_wday


mcal_event_set_recur_monthly_wday

(PHP 4)

mcal_event_set_recur_monthly_wday — Sets the recurrence of the streams global event structure

Description

void mcal_event_set_recur_monthly_wday ( int $stream, int $year, int $month, int $day, int $interval )

mcal_event_set_recur_monthly_wday() sets the streams global event structure's recurrence to the given value to be reoccurring on a monthly by week basis, ending at the given date.

Předcházející | Nahoru | Další
mcal_event_set_recur_monthly_mday | Domů | mcal_event_set_recur_none


mcal_event_set_recur_none

(PHP 4)

mcal_event_set_recur_none — Sets the recurrence of the streams global event structure

Description

void mcal_event_set_recur_none ( int $stream )

mcal_event_set_recur_none() sets the streams global event structure to not recur (event->recur_type is set to MCAL_RECUR_NONE).

Předcházející | Nahoru | Další
mcal_event_set_recur_monthly_wday | Domů | mcal_event_set_recur_weekly


mcal_event_set_recur_weekly

(PHP 4)

mcal_event_set_recur_weekly — Sets the recurrence of the streams global event structure

Description

void mcal_event_set_recur_weekly ( int $stream, int $year, int $month, int $day, int $interval, int $weekdays )

mcal_event_set_recur_weekly() sets the streams global event structure's recurrence to the given value to be reoccurring on a weekly basis, ending at the given date.

Předcházející | Nahoru | Další
mcal_event_set_recur_none | Domů | mcal_event_set_recur_yearly


mcal_event_set_recur_yearly

(PHP 4)

mcal_event_set_recur_yearly — Sets the recurrence of the streams global event structure

Description

void mcal_event_set_recur_yearly ( int $stream, int $year, int $month, int $day, int $interval )

mcal_event_set_recur_yearly() sets the streams global event structure's recurrence to the given value to be reoccurring on a yearly basis,ending at the given date.

Předcházející | Nahoru | Další
mcal_event_set_recur_weekly | Domů | mcal_event_set_start


mcal_event_set_start

(PHP 4)

mcal_event_set_start — Sets the start date and time of the streams global event structure

Description

void mcal_event_set_start ( int $stream, int $year, int $month, int $day [, int $hour [, int $min [, int $sec]]] )

mcal_event_set_start() sets the streams global event structure's start date and time to the given values.

Předcházející | Nahoru | Další
mcal_event_set_recur_yearly | Domů | mcal_event_set_title


mcal_event_set_title

(PHP 4)

mcal_event_set_title — Sets the title of the streams global event structure

Description

void mcal_event_set_title ( int $stream, string $title )

mcal_event_set_title() sets the streams global event structure's title to the given string.

Předcházející | Nahoru | Další
mcal_event_set_start | Domů | mcal_expunge


mcal_expunge

(PHP 4)

mcal_expunge — Deletes all events marked for being expunged

Description

bool mcal_expunge ( int $stream )

mcal_expunge() deletes all events which have been previously marked for deletion.

Předcházející | Nahoru | Další
mcal_event_set_title | Domů | mcal_fetch_current_stream_event


mcal_fetch_current_stream_event

(PHP 4)

mcal_fetch_current_stream_event — Returns an object containing the current streams event structure

Description

object mcal_fetch_current_stream_event ( int $stream )

mcal_fetch_current_stream_event() returns the current stream's event structure as an object containing:

  • int id - ID of that event.
  • int public - TRUE if the event if public, FALSE if it is private.
  • string category - Category string of the event.
  • string title - Title string of the event.
  • string description - Description string of the event.
  • int alarm - number of minutes before the event to send an alarm/reminder.
  • object start - Object containing a datetime entry.
  • object end - Object containing a datetime entry.
  • int recur_type - recurrence type
  • int recur_interval - recurrence interval
  • datetime recur_enddate - recurrence end date
  • int recur_data - recurrence data
All datetime entries consist of an object that contains:
  • int year - year
  • int month - month
  • int mday - day of month
  • int hour - hour
  • int min - minutes
  • int sec - seconds
  • int alarm - minutes before event to send an alarm

Předcházející | Nahoru | Další
mcal_expunge | Domů | mcal_fetch_event


mcal_fetch_event

(PHP 4)

mcal_fetch_event — Fetches an event from the calendar stream

Description

object mcal_fetch_event ( int $mcal_stream, int $event_id [, int $options] )

mcal_fetch_event() fetches an event from the calendar stream specified by id.

Returns an event object consisting of:

  • int id - ID of that event.
  • int public - TRUE if the event if public, FALSE if it is private.
  • string category - Category string of the event.
  • string title - Title string of the event.
  • string description - Description string of the event.
  • int alarm - number of minutes before the event to send an alarm/reminder.
  • object start - Object containing a datetime entry.
  • object end - Object containing a datetime entry.
  • int recur_type - recurrence type
  • int recur_interval - recurrence interval
  • datetime recur_enddate - recurrence end date
  • int recur_data - recurrence data
All datetime entries consist of an object that contains:
  • int year - year
  • int month - month
  • int mday - day of month
  • int hour - hour
  • int min - minutes
  • int sec - seconds
  • int alarm - minutes before event to send an alarm
The possible values for recur_type are:
  • 0 - Indicates that this event does not recur
  • 1 - This event recurs daily
  • 2 - This event recurs on a weekly basis
  • 3 - This event recurs monthly on a specific day of the month (e.g. the 10th of the month)
  • 4 - This event recurs monthly on a sequenced day of the week (e.g. the 3rd Saturday)
  • 5 - This event recurs on an annual basis

Předcházející | Nahoru | Další
mcal_fetch_current_stream_event | Domů | mcal_is_leap_year


mcal_is_leap_year

(PHP 4)

mcal_is_leap_year — Returns if the given year is a leap year or not

Description

bool mcal_is_leap_year ( int $year )

mcal_is_leap_year() returns 1 if the given year is a leap year, 0 if not.

Předcházející | Nahoru | Další
mcal_fetch_event | Domů | mcal_list_alarms


mcal_list_alarms

(PHP 4)

mcal_list_alarms — Return a list of events that has an alarm triggered at the given datetime

Description

array mcal_list_alarms ( int $mcal_stream [, int $begin_year, int $begin_month, int $begin_day, int $end_year, int $end_month, int $end_day] )

Returns an array of event ID's that has an alarm going off between the start and end dates, or if just a stream is given, uses the start and end dates in the global event structure.

mcal_list_events() function takes in an optional beginning date and an end date for a calendar stream. An array of event id's that are between the given dates or the internal event dates are returned.

Předcházející | Nahoru | Další
mcal_is_leap_year | Domů | mcal_list_events


mcal_list_events

(PHP 4)

mcal_list_events — Return a list of IDs for a date or a range of dates

Description

array mcal_list_events ( int $mcal_stream [, int $begin_year, int $begin_month, int $begin_day, int $end_year, int $end_month, int $end_day] )

Returns an array of ID's that are between the start and end dates, or if just a stream is given, uses the start and end dates in the global event structure.

mcal_list_events() takes in an beginning date and an optional end date for a calendar stream. An array of event id's that are between the given dates or the internal event dates are returned.

Předcházející | Nahoru | Další
mcal_list_alarms | Domů | mcal_next_recurrence


mcal_next_recurrence

(PHP 4)

mcal_next_recurrence — Returns the next recurrence of the event

Description

object mcal_next_recurrence ( int $stream, int $weekstart, array $next )

mcal_next_recurrence() returns an object filled with the next date the event occurs, on or after the supplied date. Returns empty date field if event does not occur or something is invalid. Uses weekstart to determine what day is considered the beginning of the week.

Předcházející | Nahoru | Další
mcal_list_events | Domů | mcal_open


mcal_open

(PHP 4)

mcal_open — Opens up an MCAL connection

Description

int mcal_open ( string $calendar, string $username, string $password [, int $options] )

Returns an MCAL stream on success, FALSE on error.

mcal_open() opens up an MCAL connection to the specified calendar store. If the optional options is specified, passes the options to that mailbox also. The streams internal event structure is also initialized upon connection.

Předcházející | Nahoru | Další
mcal_next_recurrence | Domů | mcal_popen


mcal_popen

(PHP 4)

mcal_popen — Opens up a persistent MCAL connection

Description

int mcal_popen ( string $calendar, string $username, string $password [, int $options] )

Returns an MCAL stream on success, FALSE on error.

mcal_popen() opens up an MCAL connection to the specified calendar store. If the optional options is specified, passes the options to that mailbox also. The streams internal event structure is also initialized upon connection.

Předcházející | Nahoru | Další
mcal_open | Domů | mcal_rename_calendar


mcal_rename_calendar

(PHP 4)

mcal_rename_calendar — Rename an MCAL calendar

Description

bool mcal_rename_calendar ( int $stream, string $old_name, string $new_name )

Renames the calendar old_name to new_name.

Předcházející | Nahoru | Další
mcal_popen | Domů | mcal_reopen


mcal_reopen

(PHP 4)

mcal_reopen — Reopens an MCAL connection

Description

bool mcal_reopen ( int $mcal_stream, string $calendar [, int $options] )

Reopens an MCAL stream to a new calendar.

mcal_reopen() reopens an MCAL connection to the specified calendar store. If the optional options is specified, passes the options to that mailbox also.

Předcházející | Nahoru | Další
mcal_rename_calendar | Domů | mcal_snooze


mcal_snooze

(PHP 4)

mcal_snooze — Turn off an alarm for an event

Description

bool mcal_snooze ( int $stream_id, int $event_id )

mcal_snooze() turns off an alarm for a calendar event specified by the stream_id and event_id.

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
mcal_reopen | Domů | mcal_store_event


mcal_store_event

(PHP 4)

mcal_store_event — Modify an existing event in an MCAL calendar

Description

int mcal_store_event ( int $mcal_stream )

mcal_store_event() stores the modifications to the current global event for the given stream.

Returns the event id of the modified event on success and FALSE on error.

Předcházející | Nahoru | Další
mcal_snooze | Domů | mcal_time_valid


mcal_time_valid

(PHP 4)

mcal_time_valid — Returns TRUE if the given hour, minutes and seconds is a valid time

Description

bool mcal_time_valid ( int $hour, int $minutes, int $seconds )

mcal_time_valid() Returns TRUE if the given hour, minutes and seconds is a valid time, FALSE if not.

Předcházející | Nahoru | Další
mcal_store_event | Domů | mcal_week_of_year


mcal_week_of_year

(PHP 4)

mcal_week_of_year — Returns the week number of the given date

Description

int mcal_week_of_year ( int $day, int $month, int $year )

mcal_week_of_year() returns the week number of the given date.

Předcházející | Nahoru | Další
mcal_time_valid | Domů | LXXXIV. Mcrypt Encryption Functions


Mcrypt Encryption Functions

Předcházející VI. Reference funkcí Další

LXXXIV. Mcrypt Encryption Functions

Úvod

This is an interface to the mcrypt library, which supports a wide variety of block algorithms such as DES, TripleDES, Blowfish (default), 3-WAY, SAFER-SK64, SAFER-SK128, TWOFISH, TEA, RC2 and GOST in CBC, OFB, CFB and ECB cipher modes. Additionally, it supports RC6 and IDEA which are considered "non-free".

Požadavky

These functions work using » mcrypt. To use it, download libmcrypt-x.x.tar.gz from » http://mcrypt.sourceforge.net/ and follow the included installation instructions. Windows users will find all the needed compiled mcrypt binaries at » http://files.edin.dk/php/win32/mcrypt/.

As of PHP 5.0.0 you will need libmcrypt Version 2.5.6 or greater.

If you linked against libmcrypt 2.4.x or higher, the following additional block algorithms are supported: CAST, LOKI97, RIJNDAEL, SAFERPLUS, SERPENT and the following stream ciphers: ENIGMA (crypt), PANAMA, RC4 and WAKE. With libmcrypt 2.4.x or higher another cipher mode is also available; nOFB.

Instalace

You need to compile PHP with the --with-mcrypt[=DIR] parameter to enable this extension. DIR is the mcrypt install directory. Make sure you compile libmcrypt with the option --disable-posix-threads.

Konfigurace běhu

Chování těchto funkcí je ovlivněno nastavením parametrů v php.ini.

Tabulka 160. Mcrypt configuration options

Name | Default | Changeable | Changelog
mcrypt.algorithms_dir | NULL | PHP_INI_ALL | Available since PHP 4.0.2.
mcrypt.modes_dir | NULL | PHP_INI_ALL | Available since PHP 4.0.2.

Pro další detaily a definice konstant PHP_INI_*, viz dokumentace k ini_set().

Typy prostředků

mcrypt_module_open() returns an encryption descriptor.

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

Mcrypt can operate in four block cipher modes (CBC, OFB, CFB, and ECB). If linked against libmcrypt-2.4.x or higher the functions can also operate in the block cipher mode nOFB and in STREAM mode. Below you find a list with all supported encryption modes together with the constants that are defines for the encryption mode. For a more complete reference and discussion see Applied Cryptography by Schneier (ISBN 0-471-11709-9).

  • MCRYPT_MODE_ECB (electronic codebook) is suitable for random data, such as encrypting other keys. Since data there is short and random, the disadvantages of ECB have a favorable negative effect.
  • MCRYPT_MODE_CBC (cipher block chaining) is especially suitable for encrypting files where the security is increased over ECB significantly.
  • MCRYPT_MODE_CFB (cipher feedback) is the best mode for encrypting byte streams where single bytes must be encrypted.
  • MCRYPT_MODE_OFB (output feedback, in 8bit) is comparable to CFB, but can be used in applications where error propagation cannot be tolerated. It's insecure (because it operates in 8bit mode) so it is not recommended to use it.
  • MCRYPT_MODE_NOFB (output feedback, in nbit) is comparable to OFB, but more secure because it operates on the block size of the algorithm.
  • MCRYPT_MODE_STREAM is an extra mode to include some stream algorithms like WAKE or RC4.

Some other mode and random device constants:

MCRYPT_ENCRYPT (integer)
MCRYPT_DECRYPT (integer)
MCRYPT_DEV_RANDOM (integer)
MCRYPT_DEV_URANDOM (integer)
MCRYPT_RAND (integer)

Mcrypt ciphers

Here is a list of ciphers which are currently supported by the mcrypt extension. For a complete list of supported ciphers, see the defines at the end of mcrypt.h. The general rule with the mcrypt-2.2.x API is that you can access the cipher from PHP with MCRYPT_ciphername. With the libmcrypt-2.4.x and libmcrypt-2.5.x API these constants also work, but it is possible to specify the name of the cipher as a string with a call to mcrypt_module_open().

  • MCRYPT_3DES
  • MCRYPT_ARCFOUR_IV (libmcrypt > 2.4.x only)
  • MCRYPT_ARCFOUR (libmcrypt > 2.4.x only)
  • MCRYPT_BLOWFISH
  • MCRYPT_CAST_128
  • MCRYPT_CAST_256
  • MCRYPT_CRYPT
  • MCRYPT_DES
  • MCRYPT_DES_COMPAT (libmcrypt 2.2.x only)
  • MCRYPT_ENIGMA (libmcrypt > 2.4.x only, alias for MCRYPT_CRYPT)
  • MCRYPT_GOST
  • MCRYPT_IDEA (non-free)
  • MCRYPT_LOKI97 (libmcrypt > 2.4.x only)
  • MCRYPT_MARS (libmcrypt > 2.4.x only, non-free)
  • MCRYPT_PANAMA (libmcrypt > 2.4.x only)
  • MCRYPT_RIJNDAEL_128 (libmcrypt > 2.4.x only)
  • MCRYPT_RIJNDAEL_192 (libmcrypt > 2.4.x only)
  • MCRYPT_RIJNDAEL_256 (libmcrypt > 2.4.x only)
  • MCRYPT_RC2
  • MCRYPT_RC4 (libmcrypt 2.2.x only)
  • MCRYPT_RC6 (libmcrypt > 2.4.x only)
  • MCRYPT_RC6_128 (libmcrypt 2.2.x only)
  • MCRYPT_RC6_192 (libmcrypt 2.2.x only)
  • MCRYPT_RC6_256 (libmcrypt 2.2.x only)
  • MCRYPT_SAFER64
  • MCRYPT_SAFER128
  • MCRYPT_SAFERPLUS (libmcrypt > 2.4.x only)
  • MCRYPT_SERPENT(libmcrypt > 2.4.x only)
  • MCRYPT_SERPENT_128 (libmcrypt 2.2.x only)
  • MCRYPT_SERPENT_192 (libmcrypt 2.2.x only)
  • MCRYPT_SERPENT_256 (libmcrypt 2.2.x only)
  • MCRYPT_SKIPJACK (libmcrypt > 2.4.x only)
  • MCRYPT_TEAN (libmcrypt 2.2.x only)
  • MCRYPT_THREEWAY
  • MCRYPT_TRIPLEDES (libmcrypt > 2.4.x only)
  • MCRYPT_TWOFISH (for older mcrypt 2.x versions, or mcrypt > 2.4.x )
  • MCRYPT_TWOFISH128 (TWOFISHxxx are available in newer 2.x versions, but not in the 2.4.x versions)
  • MCRYPT_TWOFISH192
  • MCRYPT_TWOFISH256
  • MCRYPT_WAKE (libmcrypt > 2.4.x only)
  • MCRYPT_XTEA (libmcrypt > 2.4.x only)

You must (in CFB and OFB mode) or can (in CBC mode) supply an initialization vector (IV) to the respective cipher function. The IV must be unique and must be the same when decrypting/encrypting. With data which is stored encrypted, you can take the output of a function of the index under which the data is stored (e.g. the MD5 key of the filename). Alternatively, you can transmit the IV together with the encrypted data (see chapter 9.3 of Applied Cryptography by Schneier (ISBN 0-471-11709-9) for a discussion of this topic).

Příklady

Mcrypt can be used to encrypt and decrypt using the above mentioned ciphers. If you linked against libmcrypt-2.2.x, the four important mcrypt commands (mcrypt_cfb(), mcrypt_cbc(), mcrypt_ecb(), and mcrypt_ofb()) can operate in both modes which are named MCRYPT_ENCRYPT and MCRYPT_DECRYPT, respectively.

Příklad 1125. Encrypt an input value with TripleDES under 2.2.x in ECB mode

<?php
$key = "this is a secret key";
$input = "Let us meet at 9 o'clock at the secret place.";

$encrypted_data = mcrypt_ecb (MCRYPT_3DES, $key, $input, MCRYPT_ENCRYPT);
?>

This example will give you the encrypted data as a string in $encrypted_data.

If you linked against libmcrypt 2.4.x or 2.5.x, these functions are still available, but it is recommended that you use the advanced functions.

Příklad 1126. Encrypt an input value with TripleDES under 2.4.x and higher in ECB mode

<?php
    $key = "this is a secret key";
    $input = "Let us meet at 9 o'clock at the secret place.";

    $td = mcrypt_module_open('tripledes', '', 'ecb', '');
    $iv = mcrypt_create_iv (mcrypt_enc_get_iv_size($td), MCRYPT_RAND);
    mcrypt_generic_init($td, $key, $iv);
    $encrypted_data = mcrypt_generic($td, $input);
    mcrypt_generic_deinit($td);
    mcrypt_module_close($td);
?>

This example will give you the encrypted data as a string in $encrypted_data. For a full example see mcrypt_module_open().

Obsah

mcrypt_cbc — Encrypt/decrypt data in CBC mode
mcrypt_cfb — Encrypt/decrypt data in CFB mode
mcrypt_create_iv — Create an initialization vector (IV) from a random source
mcrypt_decrypt — Decrypts crypttext with given parameters
mcrypt_ecb — Deprecated: Encrypt/decrypt data in ECB mode
mcrypt_enc_get_algorithms_name — Returns the name of the opened algorithm
mcrypt_enc_get_block_size — Returns the blocksize of the opened algorithm
mcrypt_enc_get_iv_size — Returns the size of the IV of the opened algorithm
mcrypt_enc_get_key_size — Returns the maximum supported keysize of the opened mode
mcrypt_enc_get_modes_name — Returns the name of the opened mode
mcrypt_enc_get_supported_key_sizes — Returns an array with the supported keysizes of the opened algorithm
mcrypt_enc_is_block_algorithm_mode — Checks whether the encryption of the opened mode works on blocks
mcrypt_enc_is_block_algorithm — Checks whether the algorithm of the opened mode is a block algorithm
mcrypt_enc_is_block_mode — Checks whether the opened mode outputs blocks
mcrypt_enc_self_test — This function runs a self test on the opened module
mcrypt_encrypt — Encrypts plaintext with given parameters
mcrypt_generic_deinit — This function deinitializes an encryption module
mcrypt_generic_end — This function terminates encryption
mcrypt_generic_init — This function initializes all buffers needed for encryption
mcrypt_generic — This function encrypts data
mcrypt_get_block_size — Get the block size of the specified cipher
mcrypt_get_cipher_name — Get the name of the specified cipher
mcrypt_get_iv_size — Returns the size of the IV belonging to a specific cipher/mode combination
mcrypt_get_key_size — Get the key size of the specified cipher
mcrypt_list_algorithms — Get an array of all supported ciphers
mcrypt_list_modes — Get an array of all supported modes
mcrypt_module_close — Close the mcrypt module
mcrypt_module_get_algo_block_size — Returns the blocksize of the specified algorithm
mcrypt_module_get_algo_key_size — Returns the maximum supported keysize of the opened mode
mcrypt_module_get_supported_key_sizes — Returns an array with the supported keysizes of the opened algorithm
mcrypt_module_is_block_algorithm_mode — Returns if the specified module is a block algorithm or not
mcrypt_module_is_block_algorithm — This function checks whether the specified algorithm is a block algorithm
mcrypt_module_is_block_mode — Returns if the specified mode outputs blocks or not
mcrypt_module_open — Opens the module of the algorithm and the mode to be used
mcrypt_module_self_test — This function runs a self test on the specified module
mcrypt_ofb — Encrypt/decrypt data in OFB mode
mdecrypt_generic — Decrypt data
Předcházející | Nahoru | Další
mcal_week_of_year | Domů | mcrypt_cbc


mcrypt_cbc

(PHP 4, PHP 5)

mcrypt_cbc — Encrypt/decrypt data in CBC mode

Description

string mcrypt_cbc ( int $cipher, string $key, string $data, int $mode [, string $iv] )
string mcrypt_cbc ( string $cipher, string $key, string $data, int $mode [, string $iv] )

The first prototype is when linked against libmcrypt 2.2.x, the second when linked against libmcrypt 2.4.x or higher. The mode should be either MCRYPT_ENCRYPT or MCRYPT_DECRYPT.

This function should not be used anymore, see mcrypt_generic() and mdecrypt_generic() for replacements.

Předcházející | Nahoru | Další
LXXXIV. Mcrypt Encryption Functions | Domů | mcrypt_cfb


mcrypt_cfb

(PHP 4, PHP 5)

mcrypt_cfb — Encrypt/decrypt data in CFB mode

Description

string mcrypt_cfb ( int $cipher, string $key, string $data, int $mode, string $iv )
string mcrypt_cfb ( string $cipher, string $key, string $data, int $mode [, string $iv] )

The first prototype is when linked against libmcrypt 2.2.x, the second when linked against libmcrypt 2.4.x or higher. The mode should be either MCRYPT_ENCRYPT or MCRYPT_DECRYPT.

This function should not be used anymore, see mcrypt_generic() and mdecrypt_generic() for replacements.

Předcházející | Nahoru | Další
mcrypt_cbc | Domů | mcrypt_create_iv


mcrypt_create_iv

(PHP 4, PHP 5)

mcrypt_create_iv — Create an initialization vector (IV) from a random source

Description

string mcrypt_create_iv ( int $size [, int $source] )

mcrypt_create_iv() is used to create an IV.

Parameter size determines the size of the IV, parameter source (defaults to random value) specifies the source of the IV.

The source can be MCRYPT_RAND (system random number generator), MCRYPT_DEV_RANDOM (read data from /dev/random) and MCRYPT_DEV_URANDOM (read data from /dev/urandom). MCRYPT_RAND is the only one supported on Windows because Windows (of course) doesn't have /dev/random or /dev/urandom.

Poznámka: When using MCRYPT_RAND, remember to call srand() before mcrypt_create_iv() to initialize the random number generator; it is not seeded automatically like rand() is.

Příklad 1127. mcrypt_create_iv() example

<?php
    $size = mcrypt_get_iv_size(MCRYPT_CAST_256, MCRYPT_MODE_CFB);
    $iv = mcrypt_create_iv($size, MCRYPT_DEV_RANDOM);
?>

The IV is only meant to give an alternative seed to the encryption routines. This IV does not need to be secret at all, though it can be desirable. You even can send it along with your ciphertext without losing security.

More information can be found at » http://www.ciphersbyritter.com/GLOSSARY.HTM#IV, » http://fn2.freenet.edmonton.ab.ca/~jsavard/crypto/co0409.htm and in chapter 9.3 of Applied Cryptography by Schneier (ISBN 0-471-11709-9) for a discussion of this topic.

Předcházející | Nahoru | Další
mcrypt_cfb | Domů | mcrypt_decrypt


mcrypt_decrypt

(PHP 4 >= 4.0.2, PHP 5)

mcrypt_decrypt — Decrypts crypttext with given parameters

Description

string mcrypt_decrypt ( string $cipher, string $key, string $data, string $mode [, string $iv] )

mcrypt_decrypt() decrypts the data and returns the unencrypted data.

Cipher is one of the MCRYPT_ciphername constants of the name of the algorithm as string.

Key is the key with which the data is encrypted. If it's smaller that the required keysize, it is padded with '\0'.

Data is the data that will be decrypted with the given cipher and mode. If the size of the data is not n * blocksize, the data will be padded with '\0'.

Mode is one of the MCRYPT_MODE_modename constants of one of "ecb", "cbc", "cfb", "ofb", "nofb" or "stream".

The IV parameter is used for the initialisation in CBC, CFB, OFB modes, and in some algorithms in STREAM mode. If you do not supply an IV, while it is needed for an algorithm, the function issues a warning and uses an IV with all bytes set to '\0'.

Předcházející | Nahoru | Další
mcrypt_create_iv | Domů | mcrypt_ecb


mcrypt_ecb

(PHP 4, PHP 5)

mcrypt_ecb — Deprecated: Encrypt/decrypt data in ECB mode

Description

string mcrypt_ecb ( int $cipher, string $key, string $data, int $mode )
string mcrypt_ecb ( string $cipher, string $key, string $data, int $mode [, string $iv] )

The first prototype is when linked against libmcrypt 2.2.x, the second when linked against libmcrypt 2.4.x or higher. The mode should be either MCRYPT_ENCRYPT or MCRYPT_DECRYPT.

This function is deprecated and should not be used anymore, see mcrypt_generic() and mdecrypt_generic() for replacements.

Předcházející | Nahoru | Další
mcrypt_decrypt | Domů | mcrypt_enc_get_algorithms_name


mcrypt_enc_get_algorithms_name

(PHP 4 >= 4.0.2, PHP 5)

mcrypt_enc_get_algorithms_name — Returns the name of the opened algorithm

Description

string mcrypt_enc_get_algorithms_name ( resource $td )

This function returns the name of the algorithm.

Příklad 1128. mcrypt_enc_get_algorithms_name() example

<?php
$td = mcrypt_module_open(MCRYPT_CAST_256, '', MCRYPT_MODE_CFB, '');
echo mcrypt_enc_get_algorithms_name($td). "\n";

$td = mcrypt_module_open('cast-256', '', MCRYPT_MODE_CFB, '');
echo mcrypt_enc_get_algorithms_name($td). "\n";
?>

Výše uvedený příklad vypíše:

CAST-256
CAST-256

Předcházející | Nahoru | Další
mcrypt_ecb | Domů | mcrypt_enc_get_block_size


mcrypt_enc_get_block_size

(PHP 4 >= 4.0.2, PHP 5)

mcrypt_enc_get_block_size — Returns the blocksize of the opened algorithm

Description

int mcrypt_enc_get_block_size ( resource $td )

This function returns the block size of the algorithm specified by the encryption descriptor td in bytes.

Předcházející | Nahoru | Další
mcrypt_enc_get_algorithms_name | Domů | mcrypt_enc_get_iv_size


mcrypt_enc_get_iv_size

(PHP 4 >= 4.0.2, PHP 5)

mcrypt_enc_get_iv_size — Returns the size of the IV of the opened algorithm

Description

int mcrypt_enc_get_iv_size ( resource $td )

This function returns the size of the iv of the algorithm specified by the encryption descriptor in bytes. If it returns '0' then the IV is ignored in the algorithm. An IV is used in cbc, cfb and ofb modes, and in some algorithms in stream mode.

Předcházející | Nahoru | Další
mcrypt_enc_get_block_size | Domů | mcrypt_enc_get_key_size


mcrypt_enc_get_key_size

(PHP 4 >= 4.0.2, PHP 5)

mcrypt_enc_get_key_size — Returns the maximum supported keysize of the opened mode

Description

int mcrypt_enc_get_key_size ( resource $td )

This function returns the maximum supported key size of the algorithm specified by the encryption descriptor td in bytes.

Předcházející | Nahoru | Další
mcrypt_enc_get_iv_size | Domů | mcrypt_enc_get_modes_name


mcrypt_enc_get_modes_name

(PHP 4 >= 4.0.2, PHP 5)

mcrypt_enc_get_modes_name — Returns the name of the opened mode

Description

string mcrypt_enc_get_modes_name ( resource $td )

This function returns the name of the mode.

Příklad 1129. mcrypt_enc_get_modes_name() example

<?php
    $td = mcrypt_module_open (MCRYPT_CAST_256, '', MCRYPT_MODE_CFB, '');
    echo mcrypt_enc_get_modes_name($td). "\n";

    $td = mcrypt_module_open ('cast-256', '', 'ecb', '');
    echo mcrypt_enc_get_modes_name($td). "\n";
?>

Prints:

CFB
ECB

Předcházející | Nahoru | Další
mcrypt_enc_get_key_size | Domů | mcrypt_enc_get_supported_key_sizes


mcrypt_enc_get_supported_key_sizes

(PHP 4 >= 4.0.2, PHP 5)

mcrypt_enc_get_supported_key_sizes — Returns an array with the supported keysizes of the opened algorithm

Description

array mcrypt_enc_get_supported_key_sizes ( resource $td )

Returns an array with the key sizes supported by the algorithm specified by the encryption descriptor. If it returns an empty array then all key sizes between 1 and mcrypt_enc_get_key_size() are supported by the algorithm.

Příklad 1130. mcrypt_enc_get_supported_key_sizes() example

<?php
    $td = mcrypt_module_open('rijndael-256', '', 'ecb', '');
    var_dump(mcrypt_enc_get_supported_key_sizes($td));
?>

This will print:

array(3) {
  [0]=>
  int(16)
  [1]=>
  int(24)
  [2]=>
  int(32)
}

Předcházející | Nahoru | Další
mcrypt_enc_get_modes_name | Domů | mcrypt_enc_is_block_algorithm_mode


mcrypt_enc_is_block_algorithm_mode

(PHP 4 >= 4.0.2, PHP 5)

mcrypt_enc_is_block_algorithm_mode — Checks whether the encryption of the opened mode works on blocks

Description

bool mcrypt_enc_is_block_algorithm_mode ( resource $td )

This function returns TRUE if the mode is for use with block algorithms, otherwise it returns FALSE. (e.g. FALSE for stream, and TRUE for cbc, cfb, ofb).

Předcházející | Nahoru | Další
mcrypt_enc_get_supported_key_sizes | Domů | mcrypt_enc_is_block_algorithm


mcrypt_enc_is_block_algorithm

(PHP 4 >= 4.0.2, PHP 5)

mcrypt_enc_is_block_algorithm — Checks whether the algorithm of the opened mode is a block algorithm

Description

bool mcrypt_enc_is_block_algorithm ( resource $td )

This function returns TRUE if the algorithm is a block algorithm, or FALSE if it is a stream algorithm.

Předcházející | Nahoru | Další
mcrypt_enc_is_block_algorithm_mode | Domů | mcrypt_enc_is_block_mode


mcrypt_enc_is_block_mode

(PHP 4 >= 4.0.2, PHP 5)

mcrypt_enc_is_block_mode — Checks whether the opened mode outputs blocks

Description

bool mcrypt_enc_is_block_mode ( resource $td )

This function returns TRUE if the mode outputs blocks of bytes or FALSE if it outputs bytes. (e.g. TRUE for cbc and ecb, and FALSE for cfb and stream).

Předcházející | Nahoru | Další
mcrypt_enc_is_block_algorithm | Domů | mcrypt_enc_self_test


mcrypt_enc_self_test

(PHP 4 >= 4.0.2, PHP 5)

mcrypt_enc_self_test — This function runs a self test on the opened module

Description

int mcrypt_enc_self_test ( resource $td )

This function runs the self test on the algorithm specified by the descriptor td. If the self test succeeds it returns FALSE. In case of an error, it returns TRUE.

Předcházející | Nahoru | Další
mcrypt_enc_is_block_mode | Domů | mcrypt_encrypt


mcrypt_encrypt

(PHP 4 >= 4.0.2, PHP 5)

mcrypt_encrypt — Encrypts plaintext with given parameters

Description

string mcrypt_encrypt ( string $cipher, string $key, string $data, string $mode [, string $iv] )

mcrypt_encrypt() encrypts the data and returns the encrypted data.

Cipher is one of the MCRYPT_ciphername constants of the name of the algorithm as string.

Key is the key with which the data will be encrypted. If it's smaller that the required keysize, it is padded with '\0'. It is better not to use ASCII strings for keys. It is recommended to use the mhash functions to create a key from a string.

Data is the data that will be encrypted with the given cipher and mode. If the size of the data is not n * blocksize, the data will be padded with '\0'. The returned crypttext can be larger that the size of the data that is given by data.

Mode is one of the MCRYPT_MODE_modename constants of one of "ecb", "cbc", "cfb", "ofb", "nofb" or "stream".

The IV parameter is used for the initialisation in CBC, CFB, OFB modes, and in some algorithms in STREAM mode. If you do not supply an IV, while it is needed for an algorithm, the function issues a warning and uses an IV with all bytes set to '\0'.

Příklad 1131. mcrypt_encrypt() Example

<?php
    $iv_size = mcrypt_get_iv_size(MCRYPT_RIJNDAEL_256, MCRYPT_MODE_ECB);
    $iv = mcrypt_create_iv($iv_size, MCRYPT_RAND);
    $key = "This is a very secret key";
    $text = "Meet me at 11 o'clock behind the monument.";
    echo strlen($text) . "\n";

    $crypttext = mcrypt_encrypt(MCRYPT_RIJNDAEL_256, $key, $text, MCRYPT_MODE_ECB, $iv);
    echo strlen($crypttext) . "\n";
?>

Výše uvedený příklad vypíše:

42
64

See also mcrypt_module_open() for a more advanced API and an example.

Předcházející | Nahoru | Další
mcrypt_enc_self_test | Domů | mcrypt_generic_deinit


mcrypt_generic_deinit

(PHP 4 >= 4.0.7, PHP 5)

mcrypt_generic_deinit — This function deinitializes an encryption module

Description

bool mcrypt_generic_deinit ( resource $td )

This function terminates encryption specified by the encryption descriptor (td). It clears all buffers, but does not close the module. You need to call mcrypt_module_close() yourself. (But PHP does this for you at the end of the script.) Returns FALSE on error, or TRUE on success.

See for an example mcrypt_module_open() and the entry on mcrypt_generic_init().

Předcházející | Nahoru | Další
mcrypt_encrypt | Domů | mcrypt_generic_end


mcrypt_generic_end

(PHP 4 >= 4.0.2, PHP 5 <= 5.1.6)

mcrypt_generic_end — This function terminates encryption

Description

bool mcrypt_generic_end ( resource $td )

Varování

This function is deprecated, use mcrypt_generic_deinit() instead. It can cause crashes when used with mcrypt_module_close() due to multiple buffer frees.

This function terminates encryption specified by the encryption descriptor (td). Actually it clears all buffers, and closes all the modules used. Returns FALSE on error, or TRUE on success.

Předcházející | Nahoru | Další
mcrypt_generic_deinit | Domů | mcrypt_generic_init


mcrypt_generic_init

(PHP 4 >= 4.0.2, PHP 5)

mcrypt_generic_init — This function initializes all buffers needed for encryption

Description

int mcrypt_generic_init ( resource $td, string $key, string $iv )

The maximum length of the key should be the one obtained by calling mcrypt_enc_get_key_size() and every value smaller than this is legal. The IV should normally have the size of the algorithms block size, but you must obtain the size by calling mcrypt_enc_get_iv_size(). IV is ignored in ECB. IV MUST exist in CFB, CBC, STREAM, nOFB and OFB modes. It needs to be random and unique (but not secret). The same IV must be used for encryption/decryption. If you do not want to use it you should set it to zeros, but this is not recommended.

The function returns a negative value on error, -3 when the key length was incorrect, -4 when there was a memory allocation problem and any other return value is an unknown error. If an error occurs a warning will be displayed accordingly. FALSE is returned if incorrect parameters were passed.

You need to call this function before every call to mcrypt_generic() or mdecrypt_generic().

See for an example mcrypt_module_open().

Předcházející | Nahoru | Další
mcrypt_generic_end | Domů | mcrypt_generic


mcrypt_generic

(PHP 4 >= 4.0.2, PHP 5)

mcrypt_generic — This function encrypts data

Description

string mcrypt_generic ( resource $td, string $data )

This function encrypts data. The data is padded with "\0" to make sure the length of the data is n * blocksize. This function returns the encrypted data. Note that the length of the returned string can in fact be longer then the input, due to the padding of the data.

If you want to store the encrypted data in a database make sure to store the entire string as returned by mcrypt_generic, or the string will not entirely decrypt properly. If your original string is 10 characters long and the block size is 8 (use mcrypt_enc_get_block_size() to determine the blocksize), you would need at least 16 characters in your database field. Note the string returned by mdecrypt_generic() will be 16 characters as well...use rtrim()($str, "\0") to remove the padding.

If you are for example storing the data in a MySQL database remember that varchar fields automatically have trailing spaces removed during insertion. As encrypted data can end in a space (ASCII 32), the data will be damaged by this removal. Store data in a tinyblob/tinytext (or larger) field instead.

The encryption handle should always be initialized with mcrypt_generic_init() with a key and an IV before calling this function. Where the encryption is done, you should free the encryption buffers by calling mcrypt_generic_deinit(). See mcrypt_module_open() for an example.

See also mdecrypt_generic(),
mcrypt_generic_init(), and
mcrypt_generic_deinit().

Předcházející | Nahoru | Další
mcrypt_generic_init | Domů | mcrypt_get_block_size


mcrypt_get_block_size

(PHP 4, PHP 5)

mcrypt_get_block_size — Get the block size of the specified cipher

Description

int mcrypt_get_block_size ( int $cipher )
int mcrypt_get_block_size ( string $cipher, string $module )

The first prototype is when linked against libmcrypt 2.2.x, the second when linked against libmcrypt 2.4.x or 2.5.x.

mcrypt_get_block_size() is used to get the size of a block of the specified cipher (in combination with an encryption mode).

It is more useful to use the mcrypt_enc_get_block_size() function as this uses the resource returned by mcrypt_module_open().

This example shows how to use this function when linked against libmcrypt 2.4.x and 2.5.x.

Příklad 1132. mcrypt_get_block_size() example

<?php
    echo mcrypt_get_block_size('tripledes', 'ecb');
?>

Prints:
8

See also: mcrypt_get_key_size(),
mcrypt_enc_get_block_size() and
mcrypt_encrypt().

Předcházející | Nahoru | Další
mcrypt_generic | Domů | mcrypt_get_cipher_name


mcrypt_get_cipher_name

(PHP 4, PHP 5)

mcrypt_get_cipher_name — Get the name of the specified cipher

Description

string mcrypt_get_cipher_name ( int $cipher )
string mcrypt_get_cipher_name ( string $cipher )

mcrypt_get_cipher_name() is used to get the name of the specified cipher.

mcrypt_get_cipher_name() takes the cipher number as an argument (libmcrypt 2.2.x) or takes the cipher name as an argument (libmcrypt 2.4.x or higher) and returns the name of the cipher or FALSE, if the cipher does not exist.

Příklad 1133. mcrypt_get_cipher_name() Example

<?php
   $cipher = MCRYPT_TripleDES;

   echo mcrypt_get_cipher_name($cipher);
?>

Výše uvedený příklad vypíše:

3DES

Předcházející | Nahoru | Další
mcrypt_get_block_size | Domů | mcrypt_get_iv_size


mcrypt_get_iv_size

(PHP 4 >= 4.0.2, PHP 5)

mcrypt_get_iv_size — Returns the size of the IV belonging to a specific cipher/mode combination

Description

int mcrypt_get_iv_size ( string $cipher, string $mode )

mcrypt_get_iv_size() returns the size of the Initialisation Vector (IV) in bytes. On error the function returns FALSE. If the IV is ignored in the specified cipher/mode combination zero is returned.

cipher is one of the MCRYPT_ciphername constants of the name of the algorithm as string.

mode is one of the MCRYPT_MODE_modename constants or one of "ecb", "cbc", "cfb", "ofb", "nofb" or "stream". The IV is ignored in ECB mode as this mode does not require it. You will need to have the same IV (think: starting point) both at encryption and decryption stages, otherwise your encryption will fail.

It is more useful to use the mcrypt_enc_get_iv_size() function as this uses the resource returned by mcrypt_module_open().

Příklad 1134. mcrypt_get_iv_size() example

<?php
    echo mcrypt_get_iv_size(MCRYPT_CAST_256, MCRYPT_MODE_CFB) . "\n";

    echo mcrypt_get_iv_size('des', 'ecb') . "\n";
?>

See also
mcrypt_get_block_size(),
mcrypt_enc_get_iv_size() and
mcrypt_create_iv().

Předcházející | Nahoru | Další
mcrypt_get_cipher_name | Domů | mcrypt_get_key_size


mcrypt_get_key_size

(PHP 4, PHP 5)

mcrypt_get_key_size — Get the key size of the specified cipher

Description

int mcrypt_get_key_size ( int $cipher )
int mcrypt_get_key_size ( string $cipher, string $module )

The first prototype is when linked against libmcrypt 2.2.x, the second when linked against libmcrypt 2.4.x or 2.5.x.

mcrypt_get_key_size() is used to get the size of a key of the specified cipher (in combination with an encryption mode).

This example shows how to use this function when linked against libmcrypt 2.4.x and 2.5.x. It is more useful to use the mcrypt_enc_get_key_size() function as this uses the resource returned by mcrypt_module_open().

Příklad 1135. mcrypt_get_block_size() example

<?php
    echo mcrypt_get_key_size('tripledes', 'ecb');
?>

Prints:
24

See also: mcrypt_get_block_size(),
mcrypt_end_get_key_size() and
mcrypt_encrypt().

Předcházející | Nahoru | Další
mcrypt_get_iv_size | Domů | mcrypt_list_algorithms


mcrypt_list_algorithms

(PHP 4 >= 4.0.2, PHP 5)

mcrypt_list_algorithms — Get an array of all supported ciphers

Description

array mcrypt_list_algorithms ( [string $lib_dir] )

mcrypt_list_algorithms() is used to get an array of all supported algorithms in the lib_dir parameter.

mcrypt_list_algorithms() takes an optional lib_dir parameter which specifies the directory where all algorithms are located. If not specifies, the value of the mcrypt.algorithms_dir php.ini directive is used.

Příklad 1136. mcrypt_list_algorithms() Example

<?php
    $algorithms = mcrypt_list_algorithms("/usr/local/lib/libmcrypt");

    foreach ($algorithms as $cipher) {
        echo "$cipher<br />\n";
    }
?>

The above example will produce a list with all supported algorithms in the "/usr/local/lib/libmcrypt" directory.

Předcházející | Nahoru | Další
mcrypt_get_key_size | Domů | mcrypt_list_modes


mcrypt_list_modes

(PHP 4 >= 4.0.2, PHP 5)

mcrypt_list_modes — Get an array of all supported modes

Description

array mcrypt_list_modes ( [string $lib_dir] )

mcrypt_list_modes() is used to get an array of all supported modes in the lib_dir.

mcrypt_list_modes() takes as optional parameter a directory which specifies the directory where all modes are located. If not specifies, the value of the mcrypt.modes_dir php.ini directive is used.

Příklad 1137. mcrypt_list_modes() Example

<?php
    $modes = mcrypt_list_modes();

    foreach ($modes as $mode) {
        echo "$mode <br />\n";
    }
?>

The above example will produce a list with all supported algorithms in the default mode directory. If it is not set with the ini directive mcrypt.modes_dir, the default directory of mcrypt is used (which is /usr/local/lib/libmcrypt).

Předcházející | Nahoru | Další
mcrypt_list_algorithms | Domů | mcrypt_module_close


mcrypt_module_close

(PHP 4 >= 4.0.2, PHP 5)

mcrypt_module_close — Close the mcrypt module

Description

bool mcrypt_module_close ( resource $td )

This function closes the specified encryption handle.

See mcrypt_module_open() for an example.

Předcházející | Nahoru | Další
mcrypt_list_modes | Domů | mcrypt_module_get_algo_block_size


mcrypt_module_get_algo_block_size

(PHP 4 >= 4.0.2, PHP 5)

mcrypt_module_get_algo_block_size — Returns the blocksize of the specified algorithm

Description

int mcrypt_module_get_algo_block_size ( string $algorithm [, string $lib_dir] )

This function returns the block size of the algorithm specified in bytes. The optional lib_dir parameter can contain the location where the mode module is on the system.

Předcházející | Nahoru | Další
mcrypt_module_close | Domů | mcrypt_module_get_algo_key_size


mcrypt_module_get_algo_key_size

(PHP 4 >= 4.0.2, PHP 5)

mcrypt_module_get_algo_key_size — Returns the maximum supported keysize of the opened mode

Description

int mcrypt_module_get_algo_key_size ( string $algorithm [, string $lib_dir] )

This function returns the maximum supported key size of the algorithm specified in bytes. The optional lib_dir parameter can contain the location where the mode module is on the system.

Předcházející | Nahoru | Další
mcrypt_module_get_algo_block_size | Domů | mcrypt_module_get_supported_key_sizes


mcrypt_module_get_supported_key_sizes

(PHP 4 >= 4.0.2, PHP 5)

mcrypt_module_get_supported_key_sizes — Returns an array with the supported keysizes of the opened algorithm

Description

array mcrypt_module_get_supported_key_sizes ( string $algorithm [, string $lib_dir] )

Returns an array with the key sizes supported by the specified algorithm. If it returns an empty array then all key sizes between 1 and mcrypt_module_get_algo_key_size() are supported by the algorithm. The optional lib_dir parameter can contain the location where the mode module is on the system.

See also mcrypt_enc_get_supported_key_sizes() which is used on open encryption modules.

Předcházející | Nahoru | Další
mcrypt_module_get_algo_key_size | Domů | mcrypt_module_is_block_algorithm_mode


mcrypt_module_is_block_algorithm_mode

(PHP 4 >= 4.0.2, PHP 5)

mcrypt_module_is_block_algorithm_mode — Returns if the specified module is a block algorithm or not

Description

bool mcrypt_module_is_block_algorithm_mode ( string $mode [, string $lib_dir] )

This function returns TRUE if the mode is for use with block algorithms, otherwise it returns FALSE. (e.g. FALSE for stream, and TRUE for cbc, cfb, ofb). The optional lib_dir parameter can contain the location where the mode module is on the system.

Předcházející | Nahoru | Další
mcrypt_module_get_supported_key_sizes | Domů | mcrypt_module_is_block_algorithm


mcrypt_module_is_block_algorithm

(PHP 4 >= 4.0.2, PHP 5)

mcrypt_module_is_block_algorithm — This function checks whether the specified algorithm is a block algorithm

Description

bool mcrypt_module_is_block_algorithm ( string $algorithm [, string $lib_dir] )

This function returns TRUE if the specified algorithm is a block algorithm, or FALSE is it is a stream algorithm. The optional lib_dir parameter can contain the location where the algorithm module is on the system.

Předcházející | Nahoru | Další
mcrypt_module_is_block_algorithm_mode | Domů | mcrypt_module_is_block_mode


mcrypt_module_is_block_mode

(PHP 4 >= 4.0.2, PHP 5)

mcrypt_module_is_block_mode — Returns if the specified mode outputs blocks or not

Description

bool mcrypt_module_is_block_mode ( string $mode [, string $lib_dir] )

This function returns TRUE if the mode outputs blocks of bytes or FALSE if it outputs just bytes. (e.g. TRUE for cbc and ecb, and FALSE for cfb and stream). The optional lib_dir parameter can contain the location where the mode module is on the system.

Předcházející | Nahoru | Další
mcrypt_module_is_block_algorithm | Domů | mcrypt_module_open


mcrypt_module_open

(PHP 4 >= 4.0.2, PHP 5)

mcrypt_module_open — Opens the module of the algorithm and the mode to be used

Description

resource mcrypt_module_open ( string $algorithm, string $algorithm_directory, string $mode, string $mode_directory )

This function opens the module of the algorithm and the mode to be used. The name of the algorithm is specified in algorithm, e.g. "twofish" or is one of the MCRYPT_ciphername constants. The module is closed by calling mcrypt_module_close(). Normally it returns an encryption descriptor, or FALSE on error.

The algorithm_directory and mode_directory are used to locate the encryption modules. When you supply a directory name, it is used. When you set one of these to the empty string (""), the value set by the mcrypt.algorithms_dir or mcrypt.modes_dir ini-directive is used. When these are not set, the default directories that are used are the ones that were compiled in into libmcrypt (usually /usr/local/lib/libmcrypt).

Příklad 1138. mcrypt_module_open() examples

<?php
    $td = mcrypt_module_open(MCRYPT_DES, '',
        MCRYPT_MODE_ECB, '/usr/lib/mcrypt-modes');

    $td = mcrypt_module_open('rijndael-256', '', 'ofb', '');
?>

The first line in the example above will try to open the DES cipher from the default directory and the EBC mode from the directory /usr/lib/mcrypt-modes. The second example uses strings as name for the cipher and mode, this only works when the extension is linked against libmcrypt 2.4.x or 2.5.x.

Příklad 1139. Using mcrypt_module_open() in encryption

<?php
    /* Open the cipher */
    $td = mcrypt_module_open('rijndael-256', '', 'ofb', '');

    /* Create the IV and determine the keysize length, use MCRYPT_RAND
     * on Windows instead */
    $iv = mcrypt_create_iv(mcrypt_enc_get_iv_size($td), MCRYPT_DEV_RANDOM);
    $ks = mcrypt_enc_get_key_size($td);

    /* Create key */
    $key = substr(md5('very secret key'), 0, $ks);

    /* Intialize encryption */
    mcrypt_generic_init($td, $key, $iv);

    /* Encrypt data */
    $encrypted = mcrypt_generic($td, 'This is very important data');

    /* Terminate encryption handler */
    mcrypt_generic_deinit($td);

    /* Initialize encryption module for decryption */
    mcrypt_generic_init($td, $key, $iv);

    /* Decrypt encrypted string */
    $decrypted = mdecrypt_generic($td, $encrypted);

    /* Terminate decryption handle and close module */
    mcrypt_generic_deinit($td);
    mcrypt_module_close($td);

    /* Show string */
    echo trim($decrypted) . "\n";
?>

See also
mcrypt_module_close(),
mcrypt_generic(),
mdecrypt_generic(),
mcrypt_generic_init(), and
mcrypt_generic_deinit().

Předcházející | Nahoru | Další
mcrypt_module_is_block_mode | Domů | mcrypt_module_self_test


mcrypt_module_self_test

(PHP 4 >= 4.0.2, PHP 5)

mcrypt_module_self_test — This function runs a self test on the specified module

Description

bool mcrypt_module_self_test ( string $algorithm [, string $lib_dir] )

This function runs the self test on the algorithm specified. The optional lib_dir parameter can contain the location of where the algorithm module is on the system.

The function returns TRUE if the self test succeeds, or FALSE when if fails.

Příklad 1140. mcrypt_module_self_test() example

<?php
var_dump(mcrypt_module_self_test(MCRYPT_RIJNDAEL_128)) . "\n";
var_dump(mcrypt_module_self_test(MCRYPT_BOGUS_CYPHER));
?>

Výše uvedený příklad vypíše:

bool(true)
bool(false)

Předcházející | Nahoru | Další
mcrypt_module_open | Domů | mcrypt_ofb


mcrypt_ofb

(PHP 4, PHP 5)

mcrypt_ofb — Encrypt/decrypt data in OFB mode

Description

string mcrypt_ofb ( int $cipher, string $key, string $data, int $mode, string $iv )
string mcrypt_ofb ( string $cipher, string $key, string $data, int $mode [, string $iv] )

The first prototype is when linked against libmcrypt 2.2.x, the second when linked against libmcrypt 2.4.x or higher. The mode should be either MCRYPT_ENCRYPT or MCRYPT_DECRYPT.

This function should not be used anymore, see mcrypt_generic() and mdecrypt_generic() for replacements.

Předcházející | Nahoru | Další
mcrypt_module_self_test | Domů | mdecrypt_generic


mdecrypt_generic

(PHP 4 >= 4.0.2, PHP 5)

mdecrypt_generic — Decrypt data

Description

string mdecrypt_generic ( resource $td, string $data )

This function decrypts data. Note that the length of the returned string can in fact be longer then the unencrypted string, due to the padding of the data.

Příklad 1141. mdecrypt_generic() example

<?php
    /* Data */
    $key = 'this is a very long key, even too long for the cipher';
    $plain_text = 'very important data';

    /* Open module, and create IV */
    $td = mcrypt_module_open('des', '', 'ecb', '');
    $key = substr($key, 0, mcrypt_enc_get_key_size($td));
    $iv_size = mcrypt_enc_get_iv_size($td);
    $iv = mcrypt_create_iv($iv_size, MCRYPT_RAND);

    /* Initialize encryption handle */
    if (mcrypt_generic_init($td, $key, $iv) != -1) {

        /* Encrypt data */
        $c_t = mcrypt_generic($td, $plain_text);
        mcrypt_generic_deinit($td);

        /* Reinitialize buffers for decryption */
        mcrypt_generic_init($td, $key, $iv);
        $p_t = mdecrypt_generic($td, $c_t);

        /* Clean up */
        mcrypt_generic_deinit($td);
        mcrypt_module_close($td);
    }

    if (strncmp($p_t, $plain_text, strlen($plain_text)) == 0) {
        echo "ok\n";
    } else {
        echo "error\n";
    }
?>

The above example shows how to check if the data before the encryption is the same as the data after the decryption. It is very important to reinitialize the encryption buffer with mcrypt_generic_init() before you try to decrypt the data.

The decryption handle should always be initialized with mcrypt_generic_init() with a key and an IV before calling this function. Where the encryption is done, you should free the encryption buffers by calling mcrypt_generic_deinit(). See mcrypt_module_open() for an example.

See also mcrypt_generic(),
mcrypt_generic_init(), and
mcrypt_generic_deinit().

Předcházející | Nahoru | Další
mcrypt_ofb | Domů | LXXXV. MCVE (Monetra) Payment Functions


MCVE (Monetra) Payment Functions

Předcházející VI. Reference funkcí Další

LXXXV. MCVE (Monetra) Payment Functions

Úvod

These functions interface the MCVE (Monetra) API (libmonetra, formerly known as libmcve), allowing you to work directly with MCVE/Monetra from your PHP scripts. MCVE/Monetra is Main Street Softworks' solution to direct credit/debit/gift card processing for Linux/Unix/MacOSX/Windows ( » http://www.mainstreetsoftworks.com/ ). It lets you directly address the credit card clearing houses via your *nix box, modem and/or internet connection (bypassing the need for an additional service such as Authorize.Net or Pay Flow Pro). Using the MCVE/Monetra module for PHP, you can process credit cards directly through MCVE/Monetra via your PHP scripts. The following references will outline the process.

Poznámka: MCVE/Monetra is the replacement for RedHat's CCVS. They contracted with RedHat in late 2001 to migrate all existing clientele to the MCVE platform.

Poznámka: Toto rozšíření bylo přesunuto do repozitáře PECL a již nebude součástí balíku PHP.5.1.0.

Poznámka: Toto rozšíření není k dispozici na platformách Windows.

Instalace

To enable MCVE (Monetra) Support in PHP, first verify your LibMonetra (formerly libmcve) installation directory. If you are compiling MCVE/Monetra support directly into PHP, you will then need to configure PHP with the --with-mcve option. If you use this option without specifying the path to your libmonetra installation, PHP will attempt to look in the default LibMonetra Install location (/usr/local). If Monetra (MCVE) is in a non-standard location, run configure with: --with-mcve=$mcve_path, where $mcve_path is the path to your MCVE/Monetra installation. Please note that MCVE/Monetra support requires that $mcve_path/lib and $mcve_path/include exist, and include mcve.h or monetra.h under the include directory and libmcve.so and/or libmcve.a and/or libmonetra.so and/or libmonetra.a under the lib directory.

If you want to install MCVE/Monetra support as a module, you can do so by using the PECL repository, and issuing the 'pecl install mcve' command if you are running a PEAR version of at least 1.4.0.

Since MCVE/Monetra has true server/client separation, there are no additional requirements for running PHP with MCVE support. To test your MCVE/Monetra extension in PHP, you may connect to testbox.monetra.com on port 8333 for IP, or port 8444 for SSL using the MCVE/Monetra PHP API. Use 'vitale' for your username, and 'test' for your password. Additional information about test facilities are available at » http://www.mainstreetsoftworks.com/.

Viz také

Additional documentation about MCVE/Monetra's PHP API can be found at » http://www.mainstreetsoftworks.com/documentation.html. Main Street's documentation is complete and should be the primary reference for functions.

Typy prostředků

This extension defines a MCVE_CONN resource returned by m_initconn().

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

M_PENDING (integer)
M_DONE (integer)
M_ERROR (integer)
M_FAIL (integer)
M_SUCCESS (integer)

Obsah

m_checkstatus — Check to see if a transaction has completed
m_completeauthorizations — Number of complete authorizations in queue, returning an array of their identifiers
m_connect — Establish the connection to MCVE
m_connectionerror — Get a textual representation of why a connection failed
m_deletetrans — Delete specified transaction from MCVE_CONN structure
m_destroyconn — Destroy the connection and MCVE_CONN structure
m_destroyengine — Free memory associated with IP/SSL connectivity
m_getcell — Get a specific cell from a comma delimited response by column name
m_getcellbynum — Get a specific cell from a comma delimited response by column number
m_getcommadelimited — Get the RAW comma delimited data returned from MCVE
m_getheader — Get the name of the column in a comma-delimited response
m_initconn — Create and initialize an MCVE_CONN structure
m_initengine — Ready the client for IP/SSL Communication
m_iscommadelimited — Checks to see if response is comma delimited
m_maxconntimeout — The maximum amount of time the API will attempt a connection to MCVE
m_monitor — Perform communication with MCVE (send/receive data) Non-blocking
m_numcolumns — Number of columns returned in a comma delimited response
m_numrows — Number of rows returned in a comma delimited response
m_parsecommadelimited — Parse the comma delimited response so m_getcell, etc will work
m_responsekeys — Returns array of strings which represents the keys that can be used for response parameters on this transaction
m_responseparam — Get a custom response parameter
m_returnstatus — Check to see if the transaction was successful
m_setblocking — Set blocking/non-blocking mode for connection
m_setdropfile — Set the connection method to Drop-File
m_setip — Set the connection method to IP
m_setssl_cafile — Set SSL CA (Certificate Authority) file for verification of server certificate
m_setssl_files — Set certificate key files and certificates if server requires client certificate verification
m_setssl — Set the connection method to SSL
m_settimeout — Set maximum transaction time (per trans)
m_sslcert_gen_hash — Generate hash for SSL client certificate verification
m_transactionssent — Check to see if outgoing buffer is clear
m_transinqueue — Number of transactions in client-queue
m_transkeyval — Add key/value pair to a transaction. Replaces deprecated transparam()
m_transnew — Start a new transaction
m_transsend — Finalize and send the transaction
m_uwait — Wait x microsecs
m_validateidentifier — Whether or not to validate the passed identifier on any transaction it is passed to
m_verifyconnection — Set whether or not to PING upon connect to verify connection
m_verifysslcert — Set whether or not to verify the server ssl certificate
Předcházející | Nahoru | Další
mdecrypt_generic | Domů | m_checkstatus


Memcache Functions

Předcházející VI. Reference funkcí Další

LXXXVI. Memcache Functions

Úvod

Memcache module provides handy procedural and object oriented interface to memcached, highly effective caching daemon, which was especially designed to decrease database load in dynamic web applications.

The Memcache module also provides a session handler (memcache).

More information about memcached can be found at » http://www.danga.com/memcached/.

Požadavky

This module uses functions of » zlib to support on-the-fly data compression. Zlib is required to install this module.

PHP 4.3.3 or newer is required to use the memcache extension.

Instalace

Toto rozšíření » PECL není přibaleno k PHP. Informace o instalaci tohoto PECL rozšíření lze najít v kapitole manuálu nazvané Instalace rozšíření PECL. Další informace, jako nové verze, soubory ke stažení, zdrojové soubory, správcovské informace a CHANGELOG, lze najít zde: » http://pecl.php.net/package/memcache.

In order to use these functions you must compile PHP with Memcache support by using the --enable-memcache[=DIR] option. You may optionally disable memcache session handler support by specifying --disable-memcache-session.

Windows users will enable php_memcache.dll inside of php.ini in order to use these functions. Tuto DLL knihovnu pro rozšíření PECL můžete stahovat ze stránky » PHP Downloads nebo z » http://snaps.php.net/.

Konfigurace běhu

Chování těchto funkcí je ovlivněno nastavením parametrů v php.ini.

Tabulka 161. Memcache Configuration Options

Name | Default | Changeable | Changelog
memcache.allow_failover | "1" | PHP_INI_ALL | Available since memcache 2.0.2.
memcache.max_failover_attempts | "20" | PHP_INI_ALL | Available since memcache 2.1.0.
memcache.chunk_size | "8192" | PHP_INI_ALL | Available since memcache 2.0.2.
memcache.default_port | "11211" | PHP_INI_ALL | Available since memcache 2.0.2.
memcache.hash_strategy | "standard" | PHP_INI_ALL | Available since memcache 2.2.0.
memcache.hash_function | "crc32" | PHP_INI_ALL | Available since memcache 2.2.0.
session.save_handler | "files" | PHP_INI_ALL | Supported since memcache 2.1.2
session.save_path | "" | PHP_INI_ALL | Supported since memcache 2.1.2

Pro další detaily a definice konstant PHP_INI_*, viz dokumentace k ini_set().

Zde je stručný popis konfiguračních direktiv.

memcache.allow_failover boolean

Whether to transparently failover to other servers on errors.

memcache.max_failover_attempts integer

Defines how many servers to try when setting and getting data. Used only in conjunction with memcache.allow_failover.

memcache.chunk_size integer

Data will be transferred in chunks of this size, setting the value lower requires more network writes. Try increasing this value to 32768 if noticing otherwise inexplicable slowdowns.

memcache.default_port string

The default TCP port number to use when connecting to the memcached server if no other port is specified.

memcache.hash_strategy string

Controls which strategy to use when mapping keys to servers. Set this value to consistent to enable consistent hashing which allows servers to be added or removed from the pool without causing keys to be remapped. Setting this value to standard results in the old strategy being used.

memcache.hash_function string

Controls which hash function to apply when mapping keys to servers, crc32 uses the standard CRC32 hash while fnv uses FNV-1a.

session.save_handler string

Use memcache as a session handler by setting this value to memcache.

session.save_path string

Defines a comma separated of server urls to use for session storage, for example "tcp://host1:11211, tcp://host2:11211".

Each url may contain parameters which are applied to that server, they are the same as for the Memcache::addServer() method. For example "tcp://host1:11211?persistent=1&weight=1&timeout=1&retry_interval=15"

Typy prostředků

There is only one resource type used in memcache module - it's the link identifier for a cache server connection.

Předdefinované konstanty

Tabulka 162. Memcache Constants

Name | Description
MEMCACHE_COMPRESSED (integer) | Used to turn on-the-fly data compression on with Memcache::set(), Memcache::add(), a Memcache::replace().
MEMCACHE_HAVE_SESSION (integer) | 1 if this Memcache session handler is available, 0 otherwise.

Příklady

Příklad 1142. memcache extension overview example

In this example, an object is being saved in the cache and then retrieved back. Object and other non-scalar types are serialized before saving, so it's impossible to store resources (i.e. connection identifiers and others) in the cache.

<?php

$memcache = new Memcache;
$memcache->connect('localhost', 11211) or die ("Could not connect");

$version = $memcache->getVersion();
echo "Server's version: ".$version."<br/>\n";

$tmp_object = new stdClass;
$tmp_object->str_attr = 'test';
$tmp_object->int_attr = 123;

$memcache->set('key', $tmp_object, false, 10) or die ("Failed to save data at the server");
echo "Store data in the cache (data will expire in 10 seconds)<br/>\n";

$get_result = $memcache->get('key');
echo "Data from the cache:<br/>\n";

var_dump($get_result);

?>

Příklad 1143. Using memcache session handler

<?php

$session_save_path = "tcp://$host:$port?persistent=1&weight=2&timeout=2&retry_interval=10,  ,tcp://$host:$port  ";
ini_set('session.save_handler', 'memcache');
ini_set('session.save_path', $session_save_path);

?>

Obsah

Memcache::add — Add an item to the server
Memcache::addServer — Add a memcached server to connection pool
Memcache::close — Close memcached server connection
Memcache::connect — Open memcached server connection
memcache_debug — Turn debug output on/off
Memcache::decrement — Decrement item's value
Memcache::delete — Delete item from the server
Memcache::flush — Flush all existing items at the server
Memcache::get — Retrieve item from the server
Memcache::getExtendedStats — Get statistics from all servers in pool
Memcache::getServerStatus — Returns server status
Memcache::getStats — Get statistics of the server
Memcache::getVersion — Return version of the server
Memcache::increment — Increment item's value
Memcache::pconnect — Open memcached server persistent connection
Memcache::replace — Replace value of the existing item
Memcache::set — Store data at the server
Memcache::setCompressThreshold — Enable automatic compression of large values
Memcache::setServerParams — Changes server parameters and status at runtime
Předcházející | Nahoru | Další
m_verifysslcert | Domů | Memcache::add


Memcache::add

(No version information available, might be only in CVS)

Memcache::add — Add an item to the server

Popis

bool Memcache::add ( string $key, mixed $var [, int $flag [, int $expire]] )

Memcache::add() stores variable var with key only if such key doesn't exist at the server yet. Also you can use memcache_add() function.

Seznam parametrů

key

The key that will be associated with the item.

var

The variable to store. Strings and integers are stored as is, other types are stored serialized.

flag

Use MEMCACHE_COMPRESSED to store the item compressed (uses zlib).

expire

Expiration time of the item. If it's equal to zero, the item will never expire. You can also use Unix timestamp or a number of seconds starting from current time, but in the latter case the number of seconds may not exceed 2592000 (30 days).

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání. Returns FALSE if such key already exist. For the rest Memcache::add() behaves similarly to Memcache::set().

Příklady

Příklad 1144. Memcache::add() example

<?php

$memcache_obj = memcache_connect("localhost", 11211);

/* procedural API */
memcache_add($memcache_obj, 'var_key', 'test variable', false, 30);

/* OO API */
$memcache_obj->add('var_key', 'test variable', false, 30);

?>

Viz také

Memcache::set()
Memcache::replace()

Předcházející | Nahoru | Další
LXXXVI. Memcache Functions | Domů | Memcache::addServer


Memcache::close

(No version information available, might be only in CVS)

Memcache::close — Close memcached server connection

Popis

bool Memcache::close ( void )

Memcache::close() closes connection to memcached server. This function doesn't close persistent connections, which are closed only during web-server shutdown/restart. Also you can use memcache_close() function.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1146. Memcache::close() example

<?php

/* procedural API */
$memcache_obj = memcache_connect('memcache_host', 11211);
/*
do something here ..
*/
memcache_close($memcache_obj);

/* OO API */
$memcache_obj = new Memcache;
$memcache_obj->connect('memcache_host', 11211);
/*
do something here ..
*/
$memcache_obj->close();

?>

Viz také

Memcache::connect()
Memcache::pconnect()

Předcházející | Nahoru | Další
Memcache::addServer | Domů | Memcache::connect


Memcache::connect

(No version information available, might be only in CVS)

Memcache::connect — Open memcached server connection

Popis

bool Memcache::connect ( string $host [, int $port [, int $timeout]] )

Memcache::connect() establishes a connection to the memcached server. The connection, which was opened using Memcache::connect() will be automatically closed at the end of script execution. Also you can close it with Memcache::close(). Also you can use memcache_connect() function.

Seznam parametrů

host

Point to the host where memcached is listening for connections. This parameter may also specify other transports like unix:///path/to/memcached.sock to use UNIX domain sockets, in this case port must also be set to 0.

port

Point to the port where memcached is listening for connections. Set this parameter to 0 when using UNIX domain sockets.

timeout

Value in seconds which will be used for connecting to the daemon. Think twice before changing the default value of 1 second - you can lose all the advantages of caching if your connection is too slow.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1147. Memcache::connect() example

<?php

/* procedural API */

$memcache_obj = memcache_connect('memcache_host', 11211);

/* OO API */

$memcache = new Memcache;
$memcache->connect('memcache_host', 11211);

?>

Viz také

Memcache::pconnect()
Memcache::close()

Předcházející | Nahoru | Další
Memcache::close | Domů | memcache_debug


memcache_debug

(PECL memcache:0.2-2.1.2)

memcache_debug — Turn debug output on/off

Popis

bool memcache_debug ( bool $on_off )

memcache_debug() turns on debug output if parameter on_off is equal to TRUE and turns off if it's FALSE.

Poznámka: memcache_debug() is accessible only if PHP was built with --enable-debug option and always returns TRUE in this case. Otherwise, this function has no effect and always returns FALSE.

Seznam parametrů

on_off

Turns debug output on if equals to TRUE. Turns debug output off if equals to FALSE.

Návratové hodnoty

Returns TRUE if PHP was built with --enable-debug option, otherwise returns FALSE.

Předcházející | Nahoru | Další
Memcache::connect | Domů | Memcache::decrement


Memcache::decrement

(No version information available, might be only in CVS)

Memcache::decrement — Decrement item's value

Popis

int Memcache::decrement ( string $key [, int $value] )

Memcache::decrement() decrements value of the item by value. Similarly to Memcache::increment(), current value of the item is being converted to numerical and after that value is substracted.

Poznámka: New item's value will not be less than zero.

Poznámka: Do not use Memcache::decrement() with item, which was stored compressed, because consequent call to Memcache::get() will fail.

Memcache::decrement() does not create an item if it didn't exist. Also you can use memcache_decrement() function.

Seznam parametrů

key

Key of the item do decrement.

value

Decrement the item by value. Optional and defaults to 1.

Návratové hodnoty

Returns item's new value on success or FALSE on failure.

Příklady

Příklad 1148. Memcache::decrement() example

<?php

/* procedural API */
$memcache_obj = memcache_connect('memcache_host', 11211);
/* decrement item by 2 */
$new_value = memcache_decrement($memcache_obj, 'test_item', 2);

/* OO API */
$memcache_obj = new Memcache;
$memcache_obj->connect('memcache_host', 11211);
/* decrement item by 3 */
$new_value = $memcache_obj->decrement('test_item', 3);
?>

Viz také

Memcache::increment()
Memcache::replace()

Předcházející | Nahoru | Další
memcache_debug | Domů | Memcache::delete


Memcache::delete

(No version information available, might be only in CVS)

Memcache::delete — Delete item from the server

Popis

bool Memcache::delete ( string $key [, int $timeout] )

Memcache::delete() deletes item with the key. If parameter timeout is specified, the item will expire after timeout seconds. Also you can use memcache_delete() function.

Seznam parametrů

key

timeout

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1149. Memcache::delete() example

<?php

/* procedural API */
$memcache_obj = memcache_connect('memcache_host', 11211);

/* after 10 seconds item will be deleted by the server */
memcache_delete($memcache_obj, 'key_to_delete', 10);

/* OO API */
$memcache_obj = new Memcache;
$memcache_obj->connect('memcache_host', 11211);

$memcache_obj->delete('key_to_delete', 10);

?>

Viz také

Memcache::set()
Memcache::replace()

Předcházející | Nahoru | Další
Memcache::decrement | Domů | Memcache::flush


Memcache::flush

(No version information available, might be only in CVS)

Memcache::flush — Flush all existing items at the server

Popis

bool Memcache::flush ( void )

Memcache::flush() immediately invalidates all existing items. Memcache::flush() doesn't actually free any resources, it only marks all the items as expired, so occupied memory will be overwritten by new items. Also you can use memcache_flush() function.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1150. Memcache::flush() example

<?php

/* procedural API */
$memcache_obj = memcache_connect('memcache_host', 11211);

memcache_flush($memcache_obj);

/* OO API */

$memcache_obj = new Memcache;
$memcache_obj->connect('memcache_host', 11211);

$memcache_obj->flush();

?>

Předcházející | Nahoru | Další
Memcache::delete | Domů | Memcache::get


Memcache::get

(No version information available, might be only in CVS)

Memcache::get — Retrieve item from the server

Popis

string Memcache::get ( string $key [, int &$flags] )
array Memcache::get ( array $keys [, array &$flags] )

Memcache::get() returns previously stored data if an item with such key exists on the server at this moment.

You can pass array of keys to Memcache::get() to get array of values. The result array will contain only found key-value pairs.

Seznam parametrů

key

The key or array of keys to fetch.

flags

If present, flags fetched along with the values will be written to this parameter. These flags are the same as the ones given to for example Memcache::set(). The lowest byte of the int is reserved for pecl/memcache internal usage (e.g. to indicate compression and serialization status).

Návratové hodnoty

Returns the string associated with the key or FALSE on failure or if such key was not found.

Příklady

Příklad 1151. Memcache::get() example

<?php

/* procedural API */
$memcache_obj = memcache_connect('memcache_host', 11211);
$var = memcache_get($memcache_obj, 'some_key');

/* OO API */
$memcache_obj = new Memcache;
$memcache_obj->connect('memcache_host', 11211);
$var = $memcache_obj->get('some_key');

/*
You also can use array of keys as a parameter.
If such item wasn't found at the server, the result
array simply will not include such key.
*/

/* procedural API */
$memcache_obj = memcache_connect('memcache_host', 11211);
$var = memcache_get($memcache_obj, Array('some_key', 'another_key'));

/* OO API */
$memcache_obj = new Memcache;
$memcache_obj->connect('memcache_host', 11211);
$var = $memcache_obj->get(Array('some_key', 'second_key'));

?>

Předcházející | Nahoru | Další
Memcache::flush | Domů | Memcache::getExtendedStats


Memcache::getStats

(No version information available, might be only in CVS)

Memcache::getStats — Get statistics of the server

Popis

array Memcache::getStats ( [string $type [, int $slabid [, int $limit]]] )

Memcache::getStats() returns an associative array with server's statistics. Array keys correspond to stats parameters and values to parameter's values. Also you can use memcache_get_stats() function.

Seznam parametrů

type

The type of statistics to fetch. Valid values are {reset, malloc, maps, cachedump, slabs, items, sizes}. According to the memcached protocol spec these additional arguments "are subject to change for the convenience of memcache developers".

slabid

Used in conjunction with type set to cachedump to identify the slab to dump from. The cachedump command ties up the server and is strictly to be used for debugging purposes.

limit

Used in conjunction with type set to cachedump to limit the number of entries to dump. Default value is 100.

Návratové hodnoty

Returns an associative array of server statistics or FALSE on failure.

Viz také

Memcache::getVersion()
Memcache::getExtendedStats()

Předcházející | Nahoru | Další
Memcache::getServerStatus | Domů | Memcache::getVersion


Memcache::getVersion

(No version information available, might be only in CVS)

Memcache::getVersion — Return version of the server

Popis

string Memcache::getVersion ( void )

Memcache::getVersion() returns a string with server's version number. Also you can use memcache_get_version() function.

Návratové hodnoty

Returns a string of server version number or FALSE on failure.

Příklady

Příklad 1154. Memcache::getVersion() example

<?php

/* OO API */
$memcache = new Memcache;
$memcache->connect('memcache_host', 11211);
echo $memcache->getVersion();

/* procedural API */
$memcache = memcache_connect('memcache_host', 11211);
echo memcache_get_version($memcache);

?>

Viz také

Memcache::getExtendedStats()
Memcache::getStats()

Předcházející | Nahoru | Další
Memcache::getStats | Domů | Memcache::increment


Memcache::increment

(No version information available, might be only in CVS)

Memcache::increment — Increment item's value

Popis

int Memcache::increment ( string $key [, int $value] )

Memcache::increment() increments value of the item on the specified value. If item with key key was not numeric and cannot be converted to number, it will change it's value to value. Memcache::increment() does not create an item if it didn't exist.

Poznámka: Do not use Memcache::increment() with item, which was stored compressed, because consequent call to Memcache::get() will fail.

Also you can use memcache_increment() function.

Seznam parametrů

key

Key of the item to increment.

value

Increment the item by value. Optional and defaults to 1.

Návratové hodnoty

Returns new item's value on success or FALSE on failure.

Příklady

Příklad 1155. Memcache::increment() example

<?php

/* procedural API */
$memcache_obj = memcache_connect('memcache_host', 11211);
/* increment counter by 2 */
$current_value = memcache_increment($memcache_obj, 'counter', 2);

/* OO API */
$memcache_obj = new Memcache;
$memcache_obj->connect('memcache_host', 11211);
/* increment counter by 3 */
$current_value = $memcache_obj->increment('counter', 3);

?>

Viz také

Memcache::decrement()
Memcache::replace()

Předcházející | Nahoru | Další
Memcache::getVersion | Domů | Memcache::pconnect


Memcache::pconnect

(No version information available, might be only in CVS)

Memcache::pconnect — Open memcached server persistent connection

Popis

bool Memcache::pconnect ( string $host [, int $port [, int $timeout]] )

Memcache::pconnect() is similar to Memcache::connect() with the difference, that the connection it establishes is persistent. This connection is not closed after the end of script execution and by Memcache::close() function. Also you can use memcache_pconnect() function.

Seznam parametrů

host

Point to the host where memcached is listening for connections. This parameter may also specify other transports like unix:///path/to/memcached.sock to use UNIX domain sockets, in this case port must also be set to 0.

port

Point to the port where memcached is listening for connections. Set this parameter to 0 when using UNIX domain sockets.

timeout

Value in seconds which will be used for connecting to the daemon. Think twice before changing the default value of 1 second - you can lose all the advantages of caching if your connection is too slow.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1156. Memcache::pconnect() example

<?php

/* procedural API */
$memcache_obj = memcache_pconnect('memcache_host', 11211);

/* OO API */

$memcache_obj = new Memcache;
$memcache_obj->pconnect('memcache_host', 11211);

?>

Viz také

Memcache::connect()

Předcházející | Nahoru | Další
Memcache::increment | Domů | Memcache::replace


Memcache::replace

(No version information available, might be only in CVS)

Memcache::replace — Replace value of the existing item

Popis

bool Memcache::replace ( string $key, mixed $var [, int $flag [, int $expire]] )

Memcache::replace() should be used to replace value of
existing item with key. In case if item with such
key doesn't exists, Memcache::replace() returns
FALSE. For the rest Memcache::replace() behaves
similarly to Memcache::set().
Also you can use memcache_replace() function.

Seznam parametrů

key

The key that will be associated with the item.

var

The variable to store. Strings and integers are stored as is, other types are stored serialized.

flag

Use MEMCACHE_COMPRESSED to store the item compressed (uses zlib).

expire

Expiration time of the item. If it's equal to zero, the item will never expire. You can also use Unix timestamp or a number of seconds starting from current time, but in the latter case the number of seconds may not exceed 2592000 (30 days).

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1157. Memcache::replace() example

<?php

$memcache_obj = memcache_connect('memcache_host', 11211);

/* procedural API */
memcache_replace($memcache_obj, "test_key", "some variable", false, 30);

/* OO API */
$memcache_obj->replace("test_key", "some variable", false, 30);

?>

Viz také

Memcache::set()
Memcache::add()

Předcházející | Nahoru | Další
Memcache::pconnect | Domů | Memcache::set


Memcache::set

(No version information available, might be only in CVS)

Memcache::set — Store data at the server

Popis

bool Memcache::set ( string $key, mixed $var [, int $flag [, int $expire]] )

Memcache::set() stores an item var with key on the memcached server. Parameter expire is expiration time in seconds. If it's 0, the item never expires (but memcached server doesn't guarantee this item to be stored all the time, it could be deleted from the cache to make place for other items). You can use MEMCACHE_COMPRESSED constant as flag value if you want to use on-the-fly compression (uses zlib).

Poznámka: Remember that resource variables (i.e. file and connection descriptors) cannot be stored in the cache, because they cannot be adequately represented in serialized state.

Also you can use memcache_set() function.

Seznam parametrů

key

The key that will be associated with the item.

var

The variable to store. Strings and integers are stored as is, other types are stored serialized.

flag

Use MEMCACHE_COMPRESSED to store the item compressed (uses zlib).

expire

Expiration time of the item. If it's equal to zero, the item will never expire. You can also use Unix timestamp or a number of seconds starting from current time, but in the latter case the number of seconds may not exceed 2592000 (30 days).

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1158. Memcache::set() example

<?php
/* procedural API */

/* connect to memcached server */
$memcache_obj = memcache_connect('memcache_host', 11211);

/*
set value of item with key 'var_key'
using 0 as flag value, compression is not used
expire time is 30 seconds
*/
memcache_set($memcache_obj, 'var_key', 'some variable', 0, 30);

echo memcache_get($memcache_obj, 'var_key');

?>

Příklad 1159. Memcache::set() example

<?php
/* OO API */

$memcache_obj = new Memcache;

/* connect to memcached server */
$memcache_obj->connect('memcache_host', 11211);

/*
set value of item with key 'var_key', using on-the-fly compression
expire time is 50 seconds
*/
$memcache_obj->set('var_key', 'some really big variable', MEMCACHE_COMPRESSED, 50);

echo $memcache_obj->get('var_key');

?>

Viz také

Memcache::add()
Memcache::replace()

Předcházející | Nahoru | Další
Memcache::replace | Domů | Memcache::setCompressThreshold


Mhash funkce

Předcházející VI. Reference funkcí Další

LXXXVII. Mhash funkce

Úvod

Tyto funkce jsou určeny pro práci s » mhash. Mhash lze použít pro vytvoření kontrolních součtů, otisků zpráv, autentizačních kódů zpráv atd.

Toto je rozhraní ke knihovně mhash. mhash podporuje širokou škálu hash algoritmů jako např. MD5, SHA1, GOST a mnoho jiných. Kompletní seznam podporovaných hash algoritmů naleznete v dokumentaci knohovny mhash. Obecné pravidlo je, že k hash algoritmu lze z PHP přistupovat přes MHASH_NÁZEVHASHE. Například pro hash TIGER použijte PHP konstantu MHASH_TIGER.

Požadavky

Pokud chcete tyto funkce používat, stáhněte si mhash distribuci z » jeho webových stránek a postupujte podle přiložených instrukcí k instalaci.

Instalace

K aktivaci tohoto modulu budete muset zkompilovat PHP s volbou --with-mhash. DIR je instalační adresář mhash.

Konfigurace běhu

Toto rozšíření nemá definováno žádné konfigurační direktivy.

Typy prostředků

Toto rozšíření nemá definován žádný typ prostředku (resource).

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

Zde je seznam hashů podporovaných mhashem v současné době. Pokud zde není některý hash jmenován, ale v dokumentaci mhashe je uveden jako podporovaný, můžete bezpečně předpokládat, že je tato dokumentace zastaralá.

  • MHASH_MD5
  • MHASH_SHA1
  • MHASH_HAVAL256
  • MHASH_HAVAL192
  • MHASH_HAVAL160
  • MHASH_HAVAL128
  • MHASH_RIPEMD160
  • MHASH_GOST
  • MHASH_TIGER
  • MHASH_CRC32
  • MHASH_CRC32B

Příklady

Příklad 1162. Vypočítat MD5 otisk a hmac a vypsat je v hexadecimálním tvaru

<?php
$input = "what do ya want for nothing?";
$hash = mhash (MHASH_MD5, $input);
print "Hash je ".bin2hex ($hash)."<br />\n";
$hash = mhash (MHASH_MD5, $input, "Jefe");
print "Hmac je ".bin2hex ($hash)."<br />\n";
?>

This will produce:

Hash je d03cb659cbf9192dcd066272249f8412
Hmac je 750c783e6ab0b503eaa86e310a5db738

Obsah

mhash_count — Získat nejvyšší dostupné hash id
mhash_get_block_size — Získat velikost bloku určeného hashe
mhash_get_hash_name — Získat název zadaného hashe
mhash_keygen_s2k — Vygenerovat klíč
mhash — Spočítat hash
Předcházející | Nahoru | Další
Memcache::setServerParams | Domů | mhash_count


mhash_count

(PHP 4, PHP 5)

mhash_count — Získat nejvyšší dostupné hash id

Popis

int mhash_count ( void )

mhash_count() vrací nejvyšší dostupné hash id. Hashe jsou číslované od 0 po toto hash id.

Příklad 1163. Traversing all hashes

<?php

$nr = mhash_count();

for ($i = 0; $i <= $nr; $i++) {
    echo sprintf ("The blocksize of %s is %d\n",
        mhash_get_hash_name ($i),
        mhash_get_block_size ($i));
}
?>

Předcházející | Nahoru | Další
LXXXVII. Mhash funkce | Domů | mhash_get_block_size


mhash_get_block_size

(PHP 4, PHP 5)

mhash_get_block_size — Získat velikost bloku určeného hashe

Popis

int mhash_get_block_size ( int $hash )

mhash_get_block_size() se používá ke zjištění velikosti bloku argumentu hash.

mhash_get_block_size() přijímá jeden argument, hash a vrací velikost v bytech nebo FALSE, pokud hash neexistuje.

Předcházející | Nahoru | Další
mhash_count | Domů | mhash_get_hash_name


mhash_get_hash_name

(PHP 4, PHP 5)

mhash_get_hash_name — Získat název zadaného hashe

Popis

string mhash_get_hash_name ( int $hash )

mhash_get_hash_name() se používá ke zjištění názvu zadaného hashe.

mhash_get_hash_name() přijímá id hashe jako argument a vrací název tohoto hashe nebo FALSE, pokud tento hash neexistuje.

Příklad 1164. Ukázka mhash_get_hash_name()

<?php
$hash = MHASH_MD5;

print mhash_get_hash_name ($hash);
?>

Výše uvedená ukázka vytiskne:
MD5

Předcházející | Nahoru | Další
mhash_get_block_size | Domů | mhash_keygen_s2k


mhash_keygen_s2k

(PHP 4 >= 4.0.4, PHP 5)

mhash_keygen_s2k — Vygenerovat klíč

Popis

string mhash_keygen_s2k ( int $hash, string $password, string $salt, int $bytes )

mhash_keygen_s2k() generuje klíč, který je bytes dlouhý, z předaného hesla. Toto je Salted S2K algoritmus specifikovaný v OpenPGP dokumentu (RFC 2440). Tento algoritmus použije k vytvoření klíče hash algoritmus. salt musí být pro každý generovaný klíč jiný a dostatečně náhodný, aby vytvořil různé klíče. Salt musí být při kontrole klíčů znám, tudíž je dobrý nápad ho připojit ke klíči. Salt ma pevnou délku 8 bytů a pokud dodáte méně bytů, bude doplněn nulami. Pamatujte, že uživatelsky určená hesla nejsou vhodná k použití jako klíče, protože uživatelé obvykle volí klíče, které mohou napsat na klávesnici. Tato hesla využívají pouze 6 až 7 bytů na znak (nebo méně). Je velmi vhodné na uživateli určené klíče použít nějakou transformaci (jako je tato funkce).

Předcházející | Nahoru | Další
mhash_get_hash_name | Domů | mhash


mhash

(PHP 4, PHP 5)

mhash — Spočítat hash

Popis

string mhash ( int $hash, string $data [, string $key] )

mhash() aplikuje hash funkci určenou argumentem hash na data a vrací výsledný hash (také nazývaný digest). Pokud je předán key, vrací výsledný HMAC. HMAC is keyed hashing for message authentication, or simply a message digest that depends on the specified key. Not all algorithms supported in mhash can be used in HMAC mode. In case of an error returns FALSE.

Předcházející | Nahoru | Další
mhash_keygen_s2k | Domů | LXXXVIII. Mimetype Functions


Mimetype Functions

Předcházející VI. Reference funkcí Další

LXXXVIII. Mimetype Functions

Úvod

Varování

This extension has been deprecated as the PECL extension Fileinfo provides the same functionality (and more) in a much cleaner way.

The functions in this module try to guess the content type and encoding of a file by looking for certain magic byte sequences at specific positions within the file. While this is not a bullet proof approach the heuristics used do a very good job.

This extension is derived from Apache mod_mime_magic, which is itself based on the file command maintained by Ian F. Darwin. See the source code for further historic and copyright information.

Požadavky

Tyto funkce jsou k dispozici jako součást standardního modulu, který je vždy dostupný.

Instalace

You must compile PHP with the configure switch --with-mime-magic to get support for mime-type functions. The extension needs a copy of the simplified magic file that is distributed with the Apache httpd.

Poznámka: The configure option has been changed from --enable-mime-magic to --with-mime-magic since PHP 4.3.2

Poznámka: This extension is not capable of handling the fully decorated magic file that generally comes with standard Linux distro's and is supposed to be used with recent versions of file command.

Note to Win32 Users: In order to use this module on a Windows environment, you must set the path to the bundled magic.mime file in your php.ini.

Příklad 1165. Setting the path to magic.mime

mime_magic.magicfile = "$PHP_INSTALL_DIR\magic.mime"

Remember to substitute the $PHP_INSTALL_DIR for your actual path to PHP in the above example. e.g. c:\php

Konfigurace běhu

Chování těchto funkcí je ovlivněno nastavením parametrů v php.ini.

Tabulka 163. Mimetype configuration options

Name | Default | Changeable | Changelog
mime_magic.debug | "0" | PHP_INI_SYSTEM | Available since PHP 5.0.0.
mime_magic.magicfile | "/path/to/php/magic.mime" | PHP_INI_SYSTEM | Available since PHP 4.3.0.

Pro další detaily a definice konstant PHP_INI_*, viz dokumentace k ini_set().

Zde je stručný popis konfiguračních direktiv.

mime_magic.debug bool

Enable/disable debugging.

mime_magic.magicfile string

The path to the magic.mime file.

Typy prostředků

Toto rozšíření nemá definován žádný typ prostředku (resource).

Předdefinované konstanty

Toto rozšíření nemá definovány žádné konstanty.

Obsah

mime_content_type — Detect MIME Content-type for a file (deprecated)
Předcházející | Nahoru | Další
mhash | Domů | mime_content_type


mime_content_type

(PHP 4 >= 4.3.0, PHP 5)

mime_content_type — Detect MIME Content-type for a file (deprecated)

Popis

string mime_content_type ( string $filename )

Returns the MIME content type for a file as determined by using information from the magic.mime file.

Seznam parametrů

filename

Path to the tested file.

Návratové hodnoty

Returns the content type in MIME format, like text/plain or application/octet-stream.

Poznámky

Varování

This function has been deprecated as the PECL extension Fileinfo provides the same functionality (and more) in a much cleaner way.

Příklady

Příklad 1166. mime_content_type() Example

<?php
echo mime_content_type('php.gif') . "\n";
echo mime_content_type('test.php');
?>

Výše uvedený příklad vypíše:

image/gif
text/plain

Viz také

Fileinfo for a replacement

Předcházející | Nahoru | Další
LXXXVIII. Mimetype Functions | Domů | LXXXIX. Ming functions for Flash


Microsoft SQL Server Functions

Předcházející VI. Reference funkcí Další

XCII. Microsoft SQL Server Functions

Úvod

These functions allow you to access MS SQL Server database.

Požadavky

Requirements for Win32 platforms.

The extension requires the MS SQL Client Tools to be installed on the system where PHP is installed. The Client Tools can be installed from the MS SQL Server CD or by copying ntwdblib.dll from \winnt\system32 on the server to \winnt\system32 on the PHP box. Copying ntwdblib.dll will only provide access through named pipes. Configuration of the client will require installation of all the tools.

Requirements for Unix/Linux platforms.

To use the MSSQL extension on Unix/Linux, you first need to build and install the FreeTDS library. Source code and installation instructions are available at the FreeTDS home page: » http://www.freetds.org/

Poznámka: In Windows, the DBLIB from Microsoft is used. Functions that return a column name are based on the dbcolname() function in DBLIB. DBLIB was developed for SQL Server 6.x where the max identifier length is 30. For this reason, the maximum column length is 30 characters. On platforms where FreeTDS is used (Linux), this is not a problem.

Instalace

The MSSQL extension is enabled by adding extension=php_mssql.dll to php.ini.

To get these functions to work, you have to compile PHP with --with-mssql[=DIR], where DIR is the FreeTDS install prefix. And FreeTDS should be compiled using --enable-msdblib.

Konfigurace běhu

Chování těchto funkcí je ovlivněno nastavením parametrů v php.ini.

Tabulka 165. MS SQL Server configuration options

Name | Default | Changeable | Changelog
mssql.allow_persistent | "1" | PHP_INI_SYSTEM |
mssql.max_persistent | "-1" | PHP_INI_SYSTEM |
mssql.max_links | "-1" | PHP_INI_SYSTEM |
mssql.min_error_severity | "10" | PHP_INI_ALL |
mssql.min_message_severity | "10" | PHP_INI_ALL |
mssql.compatability_mode | "0" | PHP_INI_ALL |
mssql.connect_timeout | "5" | PHP_INI_ALL |
mssql.timeout | "60" | PHP_INI_ALL | Available since PHP 4.1.0.
mssql.textsize | "-1" | PHP_INI_ALL |
mssql.textlimit | "-1" | PHP_INI_ALL |
mssql.batchsize | "0" | PHP_INI_ALL | Available since PHP 4.0.4.
mssql.datetimeconvert | "1" | PHP_INI_ALL | Available since PHP 4.2.0.
mssql.secure_connection | "0" | PHP_INI_SYSTEM | Available since PHP 4.3.0.
mssql.max_procs | "-1" | PHP_INI_ALL | Available since PHP 4.3.0.

Pro další detaily a definice konstant PHP_INI_*, viz dokumentace k ini_set().

Typy prostředků

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

MSSQL_ASSOC (integer)
MSSQL_NUM (integer)
MSSQL_BOTH (integer)
SQLTEXT (integer)
SQLVARCHAR (integer)
SQLCHAR (integer)
SQLINT1 (integer)
SQLINT2 (integer)
SQLINT4 (integer)
SQLBIT (integer)
SQLFLT8 (integer)

Obsah

mssql_bind — Adds a parameter to a stored procedure or a remote stored procedure
mssql_close — Close MS SQL Server connection
mssql_connect — Open MS SQL server connection
mssql_data_seek — Moves internal row pointer
mssql_execute — Executes a stored procedure on a MS SQL server database
mssql_fetch_array — Fetch a result row as an associative array, a numeric array, or both
mssql_fetch_assoc — Returns an associative array of the current row in the result
mssql_fetch_batch — Returns the next batch of records
mssql_fetch_field — Get field information
mssql_fetch_object — Fetch row as object
mssql_fetch_row — Get row as enumerated array
mssql_field_length — Get the length of a field
mssql_field_name — Get the name of a field
mssql_field_seek — Seeks to the specified field offset
mssql_field_type — Gets the type of a field
mssql_free_result — Free result memory
mssql_free_statement — Free statement memory
mssql_get_last_message — Returns the last message from the server
mssql_guid_string — Converts a 16 byte binary GUID to a string
mssql_init — Initializes a stored procedure or a remote stored procedure
mssql_min_error_severity — Sets the lower error severity
mssql_min_message_severity — Sets the lower message severity
mssql_next_result — Move the internal result pointer to the next result
mssql_num_fields — Gets the number of fields in result
mssql_num_rows — Gets the number of rows in result
mssql_pconnect — Open persistent MS SQL connection
mssql_query — Send MS SQL query
mssql_result — Get result data
mssql_rows_affected — Returns the number of records affected by the query
mssql_select_db — Select MS SQL database
Předcházející | Nahoru | Další
udm_set_agent_param | Domů | mssql_bind


mssql_bind

(PHP 4 >= 4.0.7, PHP 5, PECL odbtp:1.1.1-1.1.4)

mssql_bind — Adds a parameter to a stored procedure or a remote stored procedure

Popis

bool mssql_bind ( resource $stmt, string $param_name, mixed &$var, int $type [, int $is_output [, int $is_null [, int $maxlen]]] )

Binds a parameter to a stored procedure or a remote stored procedure.

Seznam parametrů

stmt

Statement resource, obtained with mssql_init().

param_name

The parameter name, as a string.

Poznámka: You have to include the @ character, like in the T-SQL syntax. See the explanation included in mssql_execute().

var

The PHP variable you'll bind the MSSQL parameter to. You can pass it by value, or by reference, to retrieve OUTPUT and RETVAL values after the procedure execution.

type

One of: SQLTEXT, SQLVARCHAR, SQLCHAR, SQLINT1, SQLINT2, SQLINT4, SQLBIT, SQLFLT4, SQLFLT8, SQLFLTN.

is_output

Whether the value is an OUTPUT parameter or not. If it's an OUTPUT parameter and you don't mention it, it will be treated as a normal input parameter and no error will be thrown.

is_null

Whether the parameter is NULL or not. Passing the NULL value as var will not do the job.

maxlen

Used with char/varchar values. You have to indicate the length of the data so if the parameter is a varchar(50), the type must be SQLVARCHAR and this value 50.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1207. mssql_bind() Example

<?php

$cn = mssql_connect($DBSERVER, $DBUSER, $DBPASS);
mssql_select_db($DB, $cn);

$sp = mssql_init("WDumpAdd"); // stored proc name

mssql_bind($sp, "@productname", stripslashes($newproduct), SQLVARCHAR, false, false, 150);
mssql_bind($sp, "@quantity", stripslashes($newquantity), SQLVARCHAR, false, false, 50);

mssql_execute($sp);
mssql_close($cn);

?>

Viz také

mssql_execute()
mssql_free_statement()
mssql_init()

Předcházející | Nahoru | Další
XCII. Microsoft SQL Server Functions | Domů | mssql_close


mssql_close

(PHP 4, PHP 5, PECL odbtp:1.1.1-1.1.4)

mssql_close — Close MS SQL Server connection

Popis

bool mssql_close ( [resource $link_identifier] )

Closes the link to a MS SQL Server database that's associated with the specified link identifier. If the link identifier isn't specified, the last opened link is assumed.

Note that this isn't usually necessary, as non-persistent open links are automatically closed at the end of the script's execution.

Seznam parametrů

link_identifier

A MS SQL link identifier, returned by mssql_connect().

This function will not close persistent links generated by mssql_pconnect().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

mssql_connect()
mssql_pconnect()

Předcházející | Nahoru | Další
mssql_bind | Domů | mssql_connect


mssql_connect

(PHP 4, PHP 5, PECL odbtp:1.1.1-1.1.4)

mssql_connect — Open MS SQL server connection

Popis

resource mssql_connect ( [string $servername [, string $username [, string $password [, bool $new_link]]]] )

mssql_connect() establishes a connection to a MS SQL server. The servername argument has to be a valid servername that is defined in the 'interfaces' file.

The link to the server will be closed as soon as the execution of the script ends, unless it's closed earlier by explicitly calling mssql_close().

Seznam parametrů

servername

The MS SQL server. It can also include a port number. e.g. hostname,port.

username

The username.

password

The password.

new_link

If a second call is made to mssql_connect() with the same arguments, no new link will be established, but instead, the link identifier of the already opened link will be returned. This parameter modifies this behavior and makes mssql_connect() always open a new link, even if mssql_connect() was called before with the same parameters.

Návratové hodnoty

Returns a MS SQL link identifier on success, or FALSE on error.

ChangeLog (záznam změn)

Verze | Popis
4.4.1 and 5.1.0 | The new_link parameter was added

Viz také

mssql_close()
mssql_pconnect()

Předcházející | Nahoru | Další
mssql_close | Domů | mssql_data_seek


mssql_data_seek

(PHP 4, PHP 5, PECL odbtp:1.1.1-1.1.4)

mssql_data_seek — Moves internal row pointer

Popis

bool mssql_data_seek ( resource $result_identifier, int $row_number )

mssql_data_seek() moves the internal row pointer of the MS SQL result associated with the specified result identifier to point to the specified row number, first row being number 0. The next call to mssql_fetch_row() would return that row.

Seznam parametrů

result_identifier

The result resource that is being evaluated.

row_number

The desired row number of the new result pointer.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
mssql_connect | Domů | mssql_execute


mssql_execute

(PHP 4 >= 4.0.7, PHP 5, PECL odbtp:1.1.1-1.1.4)

mssql_execute — Executes a stored procedure on a MS SQL server database

Popis

mixed mssql_execute ( resource $stmt [, bool $skip_results] )

Executes a stored procedure on a MS SQL server database

Seznam parametrů

stmt

Statement handle obtained with mssql_init().

skip_results

Poznámky

Poznámka: If the stored procedure returns parameters or a return value these will be available after the call to mssql_execute() unless the stored procedure returns more than one result set. In that case use mssql_next_result() to shift through the results. When the last result has been processed the output parameters and return values will be available.

Viz také

mssql_bind()
mssql_free_statement()
mssql_init()

Předcházející | Nahoru | Další
mssql_data_seek | Domů | mssql_fetch_array


mssql_fetch_array

(PHP 4, PHP 5, PECL odbtp:1.1.1-1.1.4)

mssql_fetch_array — Fetch a result row as an associative array, a numeric array, or both

Popis

array mssql_fetch_array ( resource $result [, int $result_type] )

mssql_fetch_array() is an extended version of mssql_fetch_row(). In addition to storing the data in the numeric indices of the result array, it also stores the data in associative indices, using the field names as keys.

An important thing to note is that using mssql_fetch_array() is NOT significantly slower than using mssql_fetch_row(), while it provides a significant added value.

Seznam parametrů

result

The result resource that is being evaluated. This result comes from a call to mssql_query().

result_type

The type of array that is to be fetched. It's a constant and can take the following values: MSSQL_ASSOC, MSSQL_NUM, and the default value of MSSQL_BOTH.

Návratové hodnoty

Returns an array that corresponds to the fetched row, or FALSE if there are no more rows.

Poznámky

Poznámka: Názvy polí vrácené touto funkcí rozlišují velikost písmen.

Poznámka: Tato funkce nastavuje pole s hodnotou NULL na hodnotu PHP NULL.

Viz také

mssql_fetch_row()

Předcházející | Nahoru | Další
mssql_execute | Domů | mssql_fetch_assoc


mssql_fetch_assoc

(PHP 4 >= 4.2.0, PHP 5, PECL odbtp:1.1.1-1.1.4)

mssql_fetch_assoc — Returns an associative array of the current row in the result

Popis

array mssql_fetch_assoc ( resource $result_id )

Returns an associative array that corresponds to the fetched row and moves the internal data pointer ahead. mssql_fetch_assoc() is equivalent to calling mssql_fetch_array() with MSSQL_ASSOC for the optional second parameter.

Seznam parametrů

result_id

The result resource that is being evaluated. This result comes from a call to mssql_query().

Návratové hodnoty

Returns an associative array that corresponds to the fetched row, or FALSE if there are no more rows.

Předcházející | Nahoru | Další
mssql_fetch_array | Domů | mssql_fetch_batch


mssql_fetch_batch

(PHP 4 >= 4.0.4, PHP 5, PECL odbtp:1.1.1-1.1.4)

mssql_fetch_batch — Returns the next batch of records

Popis

int mssql_fetch_batch ( resource $result )

Returns the next batch of records

Seznam parametrů

result

The result resource that is being evaluated. This result comes from a call to mssql_query().

Návratové hodnoty

Returns the batch number as an integer.

Příklady

Příklad 1208. mssql_fetch_batch() Example

<?php
$resDb = mssql_connect('localhost', 'user', 'name');
$result = mssql_query('SELECT * FROM MYTABLE', $resDb, 10000);

$intNumRows = mssql_num_rows($result);

while ($intNumRows > 0) {
    while ($arrRow = mssql_fetch_assoc($result)) {
        // Do stuff ...
    }
    $intNumRows = mssql_fetch_batch($result);
}
?>

Předcházející | Nahoru | Další
mssql_fetch_assoc | Domů | mssql_fetch_field


mssql_fetch_field

(PHP 4, PHP 5, PECL odbtp:1.1.1-1.1.4)

mssql_fetch_field — Get field information

Popis

object mssql_fetch_field ( resource $result [, int $field_offset] )

mssql_fetch_field() can be used in order to obtain information about fields in a certain query result.

Seznam parametrů

result

The result resource that is being evaluated. This result comes from a call to mssql_query().

field_offset

The numerical field offset. If the field offset is not specified, the next field that was not yet retrieved by this function is retrieved. The field_offset starts at 0.

Návratové hodnoty

Returns an object containing field information.

The properties of the object are:

  • name - column name. if the column is a result of a function, this property is set to computed#N, where #N is a serial number.
  • column_source - the table from which the column was taken
  • max_length - maximum length of the column
  • numeric - 1 if the column is numeric
  • type - the column type.

Viz také

mssql_field_seek()

Předcházející | Nahoru | Další
mssql_fetch_batch | Domů | mssql_fetch_object


mssql_fetch_object

(PHP 4, PHP 5, PECL odbtp:1.1.1-1.1.4)

mssql_fetch_object — Fetch row as object

Popis

object mssql_fetch_object ( resource $result )

mssql_fetch_object() is similar to mssql_fetch_array(), with one difference - an object is returned, instead of an array. Indirectly, that means that you can only access the data by the field names, and not by their offsets (numbers are illegal property names).

Speed-wise, the function is identical to mssql_fetch_array(), and almost as quick as mssql_fetch_row() (the difference is insignificant).

Seznam parametrů

result

The result resource that is being evaluated. This result comes from a call to mssql_query().

Návratové hodnoty

Returns an object with properties that correspond to the fetched row, or FALSE if there are no more rows.

Poznámky

Poznámka: Názvy polí vrácené touto funkcí rozlišují velikost písmen.

Poznámka: Tato funkce nastavuje pole s hodnotou NULL na hodnotu PHP NULL.

Viz také

mssql_fetch_array()
mssql_fetch_row()

Předcházející | Nahoru | Další
mssql_fetch_field | Domů | mssql_fetch_row


mssql_fetch_row

(PHP 4, PHP 5, PECL odbtp:1.1.1-1.1.4)

mssql_fetch_row — Get row as enumerated array

Popis

array mssql_fetch_row ( resource $result )

mssql_fetch_row() fetches one row of data from the result associated with the specified result identifier. The row is returned as an array. Each result column is stored in an array offset, starting at offset 0.

Subsequent call to mssql_fetch_row() would return the next row in the result set, or FALSE if there are no more rows.

Seznam parametrů

result

The result resource that is being evaluated. This result comes from a call to mssql_query().

Návratové hodnoty

Returns an array that corresponds to the fetched row, or FALSE if there are no more rows.

Poznámky

Poznámka: Tato funkce nastavuje pole s hodnotou NULL na hodnotu PHP NULL.

Viz také

mssql_fetch_array()
mssql_fetch_object()
mssql_data_seek()
mssql_result()

Předcházející | Nahoru | Další
mssql_fetch_object | Domů | mssql_field_length


mssql_field_length

(PHP 4, PHP 5, PECL odbtp:1.1.1-1.1.4)

mssql_field_length — Get the length of a field

Popis

int mssql_field_length ( resource $result [, int $offset] )

Returns the length of field no. offset in result.

Seznam parametrů

result

The result resource that is being evaluated. This result comes from a call to mssql_query().

offset

The field offset, starts at 0. If omitted, the current field is used.

Návratové hodnoty

The length of the specified field index on success, or FALSE on failure.

Poznámky

Note to Win32 Users: Due to a limitation in the underlying API used by PHP (MS DbLib C API), the length of VARCHAR fields is limited to 255. If you need to store more data, use a TEXT field instead.

Viz také

mssql_field_name()
mssql_field_type()

Předcházející | Nahoru | Další
mssql_fetch_row | Domů | mssql_field_name


mssql_field_name

(PHP 4, PHP 5, PECL odbtp:1.1.1-1.1.4)

mssql_field_name — Get the name of a field

Popis

string mssql_field_name ( resource $result [, int $offset] )

Returns the name of field no. offset in result.

Seznam parametrů

result

The result resource that is being evaluated. This result comes from a call to mssql_query().

offset

The field offset, starts at 0. If omitted, the current field is used.

Návratové hodnoty

The name of the specified field index on success, or FALSE on failure.

Viz také

mssql_field_length()
mssql_field_type()

Předcházející | Nahoru | Další
mssql_field_length | Domů | mssql_field_seek


mssql_field_seek

(PHP 4, PHP 5, PECL odbtp:1.1.1-1.1.4)

mssql_field_seek — Seeks to the specified field offset

Popis

bool mssql_field_seek ( resource $result, int $field_offset )

Seeks to the specified field offset. If the next call to mssql_fetch_field() won't include a field offset, this field would be returned.

Seznam parametrů

result

The result resource that is being evaluated. This result comes from a call to mssql_query().

field_offset

The field offset, starts at 0.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

mssql_fetch_field()

Předcházející | Nahoru | Další
mssql_field_name | Domů | mssql_field_type


mssql_field_type

(PHP 4, PHP 5, PECL odbtp:1.1.1-1.1.4)

mssql_field_type — Gets the type of a field

Popis

string mssql_field_type ( resource $result [, int $offset] )

Returns the type of field no. offset in result.

Seznam parametrů

result

The result resource that is being evaluated. This result comes from a call to mssql_query().

offset

The field offset, starts at 0. If omitted, the current field is used.

Návratové hodnoty

The type of the specified field index on success, or FALSE on failure.

Viz také

mssql_field_length()
mssql_field_name()

Předcházející | Nahoru | Další
mssql_field_seek | Domů | mssql_free_result


mssql_free_result

(PHP 4, PHP 5, PECL odbtp:1.1.1-1.1.4)

mssql_free_result — Free result memory

Popis

bool mssql_free_result ( resource $result )

mssql_free_result() only needs to be called if you are worried about using too much memory while your script is running. All result memory will automatically be freed when the script ends. You may call mssql_free_result() with the result identifier as an argument and the associated result memory will be freed.

Seznam parametrů

result

The result resource that is being freed. This result comes from a call to mssql_query().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
mssql_field_type | Domů | mssql_free_statement


mssql_free_statement

(PHP 4 >= 4.3.2, PHP 5, PECL odbtp:1.1.1-1.1.4)

mssql_free_statement — Free statement memory

Popis

bool mssql_free_statement ( resource $stmt )

mssql_free_statement() only needs to be called if you are worried about using too much memory while your script is running. All statement memory will automatically be freed when the script ends. You may call mssql_free_statement() with the statement identifier as an argument and the associated statement memory will be freed.

Seznam parametrů

stmt

Statement resource, obtained with mssql_init().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

mssql_bind()
mssql_execute()
mssql_init()

Předcházející | Nahoru | Další
mssql_free_result | Domů | mssql_get_last_message


mssql_get_last_message

(PHP 4, PHP 5, PECL odbtp:1.1.1-1.1.4)

mssql_get_last_message — Returns the last message from the server

Popis

string mssql_get_last_message ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
mssql_free_statement | Domů | mssql_guid_string


mssql_guid_string

(PHP 4 >= 4.0.7, PHP 5, PECL odbtp:1.1.1-1.1.4)

mssql_guid_string — Converts a 16 byte binary GUID to a string

Popis

string mssql_guid_string ( string $binary [, int $short_format] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
mssql_get_last_message | Domů | mssql_init


mssql_init

(PHP 4 >= 4.0.7, PHP 5, PECL odbtp:1.1.1-1.1.4)

mssql_init — Initializes a stored procedure or a remote stored procedure

Popis

resource mssql_init ( string $sp_name [, resource $link_identifier] )

Initializes a stored procedure or a remote stored procedure.

Seznam parametrů

sp_name

Stored procedure name, like ownew.sp_name or otherdb.owner.sp_name.

link_identifier

A MS SQL link identifier, returned by mssql_connect().

Návratové hodnoty

Returns a resource identifier "statement", used in subsequent calls to mssql_bind() and mssql_execute(), or FALSE on errors.

Viz také

mssql_bind()
mssql_execute()
mssql_free_statement()

Předcházející | Nahoru | Další
mssql_guid_string | Domů | mssql_min_error_severity


mssql_min_error_severity

(PHP 4, PHP 5, PECL odbtp:1.1.1-1.1.4)

mssql_min_error_severity — Sets the lower error severity

Popis

void mssql_min_error_severity ( int $severity )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

severity

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
mssql_init | Domů | mssql_min_message_severity


mssql_min_message_severity

(PHP 4, PHP 5, PECL odbtp:1.1.1-1.1.4)

mssql_min_message_severity — Sets the lower message severity

Popis

void mssql_min_message_severity ( int $severity )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

severity

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
mssql_min_error_severity | Domů | mssql_next_result


mssql_next_result

(PHP 4 >= 4.0.5, PHP 5, PECL odbtp:1.1.1-1.1.4)

mssql_next_result — Move the internal result pointer to the next result

Popis

bool mssql_next_result ( resource $result_id )

When sending more than one SQL statement to the server or executing a stored procedure with multiple results, it will cause the server to return multiple result sets. This function will test for additional results available form the server. If an additional result set exists it will free the existing result set and prepare to fetch the rows from the new result set.

Seznam parametrů

result_id

The result resource that is being evaluated. This result comes from a call to mssql_query().

Návratové hodnoty

Returns TRUE if an additional result set was available or FALSE otherwise.

Příklady

Příklad 1209. mssql_next_result() example

<?php
$link = mssql_connect("localhost", "userid", "secret");
mssql_select_db("MyDB", $link);
$sql = "Select * from table1 select * from table2";
$rs = mssql_query($sql, $link);
do {
    while ($row = mssql_fetch_row($rs)) {
    }
} while (mssql_next_result($rs));
mssql_free_result($rs);
mssql_close($link);
?>

Předcházející | Nahoru | Další
mssql_min_message_severity | Domů | mssql_num_fields


mssql_num_fields

(PHP 4, PHP 5, PECL odbtp:1.1.1-1.1.4)

mssql_num_fields — Gets the number of fields in result

Popis

int mssql_num_fields ( resource $result )

mssql_num_fields() returns the number of fields in a result set.

Seznam parametrů

result

The result resource that is being evaluated. This result comes from a call to mssql_query().

Návratové hodnoty

Returns the number of fields, as an integer.

Viz také

mssql_query()
mssql_fetch_field()
mssql_num_rows()

Předcházející | Nahoru | Další
mssql_next_result | Domů | mssql_num_rows


mssql_num_rows

(PHP 4, PHP 5, PECL odbtp:1.1.1-1.1.4)

mssql_num_rows — Gets the number of rows in result

Popis

int mssql_num_rows ( resource $result )

mssql_num_rows() returns the number of rows in a result set.

Seznam parametrů

result

The result resource that is being evaluated. This result comes from a call to mssql_query().

Návratové hodnoty

Returns the number of rows, as an integer.

Viz také

mssql_query()
mssql_fetch_row()

Předcházející | Nahoru | Další
mssql_num_fields | Domů | mssql_pconnect


mssql_pconnect

(PHP 4, PHP 5, PECL odbtp:1.1.1-1.1.4)

mssql_pconnect — Open persistent MS SQL connection

Popis

resource mssql_pconnect ( [string $servername [, string $username [, string $password [, bool $new_link]]]] )

mssql_pconnect() acts very much like mssql_connect() with two major differences.

First, when connecting, the function would first try to find a (persistent) link that's already open with the same host, username and password. If one is found, an identifier for it will be returned instead of opening a new connection.

Second, the connection to the SQL server will not be closed when the execution of the script ends. Instead, the link will remain open for future use (mssql_close() will not close links established by mssql_pconnect()).

This type of links is therefore called 'persistent'.

Seznam parametrů

servername

The MS SQL server. It can also include a port number. e.g. hostname:port.

username

The username.

password

The password.

new_link

If a second call is made to mssql_pconnect() with the same arguments, no new link will be established, but instead, the link identifier of the already opened link will be returned. This parameter modifies this behavior and makes mssql_pconnect() always open a new link, even if mssql_pconnect() was called before with the same parameters.

Návratové hodnoty

Returns a positive MS SQL persistent link identifier on success, or FALSE on error.

Předcházející | Nahoru | Další
mssql_num_rows | Domů | mssql_query


mssql_query

(PHP 4, PHP 5, PECL odbtp:1.1.1-1.1.4)

mssql_query — Send MS SQL query

Popis

mixed mssql_query ( string $query [, resource $link_identifier [, int $batch_size]] )

mssql_query() sends a query to the currently active database on the server that's associated with the specified link identifier.

Seznam parametrů

query

A SQL query.

link_identifier

A MS SQL link identifier, returned by mssql_connect() or mssql_pconnect().

If the link identifier isn't specified, the last opened link is assumed. If no link is open, the function tries to establish a link as if mssql_connect() was called, and use it.

batch_size

The number of records to batch in the buffer.

Návratové hodnoty

Returns a MS SQL result resource on success, TRUE if no rows were returned, or FALSE on error.

Poznámky

Poznámka: If the query returns multiple results then it is necessary to fetch all results by mssql_next_result() or free the results by mssql_free_result() before executing next query.

Viz také

mssql_select_db()
mssql_connect()

Předcházející | Nahoru | Další
mssql_pconnect | Domů | mssql_result


mssql_result

(PHP 4, PHP 5, PECL odbtp:1.1.1-1.1.4)

mssql_result — Get result data

Popis

string mssql_result ( resource $result, int $row, mixed $field )

mssql_result() returns the contents of one cell from a MS SQL result set.

Seznam parametrů

result

The result resource that is being evaluated. This result comes from a call to mssql_query().

row

The row number.

field

Can be the field's offset, the field's name or the field's table dot field's name (tablename.fieldname). If the column name has been aliased ('select foo as bar from...'), it uses the alias instead of the column name.

Poznámka: Specifying a numeric offset for the field argument is much quicker than specifying a fieldname or tablename.fieldname argument.

Návratové hodnoty

Returns the contents of the specified cell.

Poznámky

Poznámka: When working on large result sets, you should consider using one of the functions that fetch an entire row (specified below). As these functions return the contents of multiple cells in one function call, they're MUCH quicker than mssql_result().

Viz také

Recommended high-performance alternatives:
mssql_fetch_row()
mssql_fetch_array()
mssql_fetch_object()

Předcházející | Nahoru | Další
mssql_query | Domů | mssql_rows_affected


mssql_rows_affected

(PHP 4 >= 4.0.4, PHP 5, PECL odbtp:1.1.1-1.1.4)

mssql_rows_affected — Returns the number of records affected by the query

Popis

int mssql_rows_affected ( resource $link_identifier )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

link_identifier

A MS SQL link identifier, returned by mssql_connect() or mssql_pconnect().

Předcházející | Nahoru | Další
mssql_result | Domů | mssql_select_db


mssql_select_db

(PHP 4, PHP 5, PECL odbtp:1.1.1-1.1.4)

mssql_select_db — Select MS SQL database

Popis

bool mssql_select_db ( string $database_name [, resource $link_identifier] )

mssql_select_db() sets the current active database on the server that's associated with the specified link identifier.

Every subsequent call to mssql_query() will be made on the active database.

Seznam parametrů

database_name

The database name.

To escape the name of a database that contains spaces, hyphens ("-"), or any other exceptional characters, the database name must be enclosed in brackets, as is shown in the example, below. This technique must also be applied when selecting a database name that is also a reserved word (such as primary).

link_identifier

A MS SQL link identifier, returned by mssql_connect() or mssql_pconnect().

If no link identifier is specified, the last opened link is assumed. If no link is open, the function will try to establish a link as if mssql_connect() was called, and use it.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1210. mssql_select_db() example

<?php
$conn = mssql_connect('MYSQLSERVER', 'sa', 'password');
mssql_select_db('[my data-base]', $conn);
?>

Viz také

mssql_connect()
mssql_pconnect()
mssql_query()

Předcházející | Nahoru | Další
mssql_rows_affected | Domů | XCIII. Microsoft SQL Server and Sybase Functions (PDO_DBLIB)


Ming functions for Flash

Předcházející VI. Reference funkcí Další

LXXXIX. Ming functions for Flash

Varování

Toto rozšíření je EXPERIMENTÁLNÍ. Chování tohoto rozšíření, názvy funkcí a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může bez ohlášení změnit. Berte to v úvahu a používejte tento modul na vlastní nebezpečí.

Úvod

First of all: Ming is not an acronym. Ming is an open-source (LGPL) library which allows you to create SWF ("Flash") format movies. Ming supports almost all of Flash 4's features, including: shapes, gradients, bitmaps (pngs and jpegs), morphs ("shape tweens"), text, buttons, actions, sprites ("movie clips"), streaming mp3, and color transforms --the only thing that's missing is sound events.

Note that all values specifying length, distance, size, etc. are in "twips", twenty units per pixel. That's pretty much arbitrary, though, since the player scales the movie to whatever pixel size is specified in the embed/object tag, or the entire frame if not embedded.

Ming offers a number of advantages over the existing PHP/libswf module. You can use Ming anywhere you can compile the code, whereas libswf is closed-source and only available for a few platforms, Windows not one of them. Ming provides some insulation from the mundane details of the SWF file format, wrapping the movie elements in PHP objects. Also, Ming is still being maintained; if there's a feature that you want to see, just let us know at » http://ming.sourceforge.net/.

Ming was added in PHP 4.0.5.

Požadavky

To use Ming with PHP, you first need to build and install the Ming library. Source code and installation instructions are available at the Ming home page: » http://ming.sourceforge.net/ along with examples, a small tutorial, and the latest news.

Download the ming archive. Unpack the archive. Go in the Ming directory. make. make install.

This will build libming.so and install it into /usr/lib/, and copy ming.h into /usr/include/. Edit the PREFIX= line in the Makefile to change the installation directory.

Instalace

Příklad 1167. built into PHP (Unix)

mkdir <phpdir>/ext/ming
cp php_ext/* <phpdir>/ext/ming
cd <phpdir>
./buildconf
./configure --with-ming <other config options>

Build and install PHP as usual, restart web server if necessary.

Now either just add extension=php_ming.so to your php.ini file, or put dl('php_ming.so'); at the head of all of your Ming scripts.

Konfigurace běhu

Toto rozšíření nemá definováno žádné konfigurační direktivy.

Typy prostředků

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

MING_NEW (integer)
MING_ZLIB (integer)
SWFBUTTON_HIT (integer)
SWFBUTTON_DOWN (integer)
SWFBUTTON_OVER (integer)
SWFBUTTON_UP (integer)
SWFBUTTON_MOUSEUPOUTSIDE (integer)
SWFBUTTON_DRAGOVER (integer)
SWFBUTTON_DRAGOUT (integer)
SWFBUTTON_MOUSEUP (integer)
SWFBUTTON_MOUSEDOWN (integer)
SWFBUTTON_MOUSEOUT (integer)
SWFBUTTON_MOUSEOVER (integer)
SWFFILL_RADIAL_GRADIENT (integer)
SWFFILL_LINEAR_GRADIENT (integer)
SWFFILL_TILED_BITMAP (integer)
SWFFILL_CLIPPED_BITMAP (integer)
SWFTEXTFIELD_HASLENGTH (integer)
SWFTEXTFIELD_NOEDIT (integer)
SWFTEXTFIELD_PASSWORD (integer)
SWFTEXTFIELD_MULTILINE (integer)
SWFTEXTFIELD_WORDWRAP (integer)
SWFTEXTFIELD_DRAWBOX (integer)
SWFTEXTFIELD_NOSELECT (integer)
SWFTEXTFIELD_HTML (integer)
SWFTEXTFIELD_ALIGN_LEFT (integer)
SWFTEXTFIELD_ALIGN_RIGHT (integer)
SWFTEXTFIELD_ALIGN_CENTER (integer)
SWFTEXTFIELD_ALIGN_JUSTIFY (integer)
SWFACTION_ONLOAD (integer)
SWFACTION_ENTERFRAME (integer)
SWFACTION_UNLOAD (integer)
SWFACTION_MOUSEMOVE (integer)
SWFACTION_MOUSEDOWN (integer)
SWFACTION_MOUSEUP (integer)
SWFACTION_KEYDOWN (integer)
SWFACTION_KEYUP (integer)
SWFACTION_DATA (integer)

Předdefinované třídy

Tyto třídy jsou definovány rozšířením a budou dostupné pouze v případě, že PHP bude zkompilováno s tímto rozšířením nebo bude rozšíření zavedeno dynamicky za běhu.

Classes

SWFAction
SWFBitmap
SWFButton
SWFDisplayItem
SWFFill
SWFFont
SWFFontChar
SWFGradient
SWFMorph
SWFMovie
SWFPrebuiltClip
SWFShape
SWFSound
SWFSoundInstance
SWFSprite
SWFText
SWFTextField
SWFVideoStream

Obsah

SWFAction — SWFAction Class
SWFAction->__construct() — Creates a new SWFAction
SWFBitmap — SWFBitmap Class
SWFBitmap->__construct() — Loads Bitmap object
SWFBitmap->getHeight() — Returns the bitmap's height
SWFBitmap->getWidth() — Returns the bitmap's width
SWFButton — SWFButton Class
SWFButton->__construct() — Creates a new Button
SWFButton->addAction() — Adds an action
SWFButton->addASound() — Associates a sound with a button transition
SWFButton->addShape() — Adds a shape to a button
SWFButton->setAction() — Sets the action
SWFButton->setDown() — Alias for addShape(shape, SWFBUTTON_DOWN)
SWFButton->setHit() — Alias for addShape(shape, SWFBUTTON_HIT)
SWFButton->setMenu() — enable track as menu button behaviour
SWFButton->setOver() — Alias for addShape(shape, SWFBUTTON_OVER)
SWFButton->setUp() — Alias for addShape(shape, SWFBUTTON_UP)
SWFDisplayItem — SWFDisplayItem Class
SWFDisplayItem->addAction() — Adds this SWFAction to the given SWFSprite instance
SWFDisplayItem->addColor() — Adds the given color to this item's color transform
SWFDisplayItem->endMask() — Another way of defining a MASK layer
SWFDisplayItem->getRot()
SWFDisplayItem->getX()
SWFDisplayItem->getXScale()
SWFDisplayItem->getXSkew()
SWFDisplayItem->getY()
SWFDisplayItem->getYScale()
SWFDisplayItem->getYSkew()
SWFDisplayItem->move() — Moves object in relative coordinates
SWFDisplayItem->moveTo() — Moves object in global coordinates
SWFDisplayItem->multColor() — Multiplies the item's color transform
SWFDisplayItem->remove() — Removes the object from the movie
SWFDisplayItem->rotate() — Rotates in relative coordinates
SWFDisplayItem->rotateTo() — Rotates the object in global coordinates
SWFDisplayItem->scale() — Scales the object in relative coordinates
SWFDisplayItem->scaleTo() — Scales the object in global coordinates
SWFDisplayItem->setDepth() — Sets z-order
SWFDisplayItem->setMaskLevel() — Defines a MASK layer at level
SWFDisplayItem->setMatrix() — Sets the item's transform matrix
SWFDisplayItem->setName() — Sets the object's name
SWFDisplayItem->setRatio() — Sets the object's ratio
SWFDisplayItem->skewX() — Sets the X-skew
SWFDisplayItem->skewXTo() — Sets the X-skew
SWFDisplayItem->skewY() — Sets the Y-skew
SWFDisplayItem->skewYTo() — Sets the Y-skew
SWFFill — SWFFill Class
SWFFill->moveTo() — Moves fill origin
SWFFill->rotateTo() — Sets fill's rotation
SWFFill->scaleTo() — Sets fill's scale
SWFFill->skewXTo() — Sets fill x-skew
SWFFill->skewYTo() — Sets fill y-skew
SWFFont — SWFFont Class
SWFFont->__construct() — Loads a font definition
SWFFont->getAscent() — Returns the ascent of the font, or 0 if not available
SWFFont->getDescent() — Returns the descent of the font, or 0 if not available
SWFFont->getLeading() — Returns the leading of the font, or 0 if not available
SWFFont->getShape() — Returns the glyph shape of a char as a text string
SWFFont->getUTF8Width() — Calculates the width of the given string in this font at full height
SWFFont->getWidth() — Returns the string's width
SWFFontChar — SWFFontChar Class
SWFFontChar->addChars() — Adds characters to a font for exporting font
SWFFontChar->addUTF8Chars() — Adds characters to a font for exporting font
SWFGradient — SWFGradient Class
SWFGradient->__construct() — Creates a gradient object
SWFGradient->addEntry() — Adds an entry to the gradient list
SWFMorph — SWFMorph Class
SWFMorph->__construct() — Creates a new SWFMorph object
SWFMorph->getShape1() — Gets a handle to the starting shape
SWFMorph->getShape2() — Gets a handle to the ending shape
SWFMovie — SWFMovie Class
SWFMovie->__construct() — Creates a new movie object, representing an SWF version 4 movie
SWFMovie->add() — Adds any type of data to a movie
SWFMovie->addExport()
SWFMovie->addFont()
SWFMovie->importChar()
SWFMovie->importFont()
SWFMovie->labelFrame() — Labels a frame
SWFMovie->nextFrame() — Moves to the next frame of the animation
SWFMovie->output() — Dumps your lovingly prepared movie out
SWFMovie->remove() — Removes the object instance from the display list
SWFMovie->save() — Saves the SWF movie in a file
SWFMovie->saveToFile()
SWFMovie->setbackground() — Sets the background color
SWFMovie->setDimension() — Sets the movie's width and height
SWFMovie->setFrames() — Sets the total number of frames in the animation
SWFMovie->setRate() — Sets the animation's frame rate
SWFMovie->startSound()
SWFMovie->stopSound()
SWFMovie->streamMP3() — Streams a MP3 file
SWFMovie->writeExports()
SWFPrebuiltClip — SWFPrebuiltClip Class
SWFPrebuiltClip->__construct() — Returns a SWFPrebuiltClip object
SWFShape — SWFShape Class
SWFShape->__construct() — Creates a new shape object
SWFShape->addFill() — Adds a solid fill to the shape
SWFShape->drawArc() — Draws an arc of radius r centered at the current location, from angle startAngle to angle endAngle measured clockwise from 12 o'clock
SWFShape->drawCircle() — Draws a circle of radius r centered at the current location, in a counter-clockwise fashion
SWFShape->drawCubic() — Draws a cubic bezier curve using the current position and the three given points as control points
SWFShape->drawCubicTo() — Draws a cubic bezier curve using the current position and the three given points as control points
SWFShape->drawCurve() — Draws a curve (relative)
SWFShape->drawCurveTo() — Draws a curve
SWFShape->drawGlyph() — Draws the first character in the given string into the shape using the glyph definition from the given font
SWFShape->drawLine() — Draws a line (relative)
SWFShape->drawLineTo() — Draws a line
SWFShape->movePen() — Moves the shape's pen (relative)
SWFShape->movePenTo() — Moves the shape's pen
SWFShape->setLeftFill() — Sets left rasterizing color
SWFShape->setLine() — Sets the shape's line style
SWFShape->setRightFill() — Sets right rasterizing color
SWFSound — SWFSound Class
SWFSound — Returns a new SWFSound object from given file
SWFSoundInstance — SWFSoundInstance Class
SWFSoundInstance->loopCount()
SWFSoundInstance->loopInPoint()
SWFSoundInstance->loopOutPoint()
SWFSoundInstance->noMultiple()
SWFSprite — SWFSprite Class
SWFSprite->__construct() — Creates a movie clip (a sprite)
SWFSprite->add() — Adds an object to a sprite
SWFSprite->labelFrame() — Labels frame
SWFSprite->nextFrame() — Moves to the next frame of the animation
SWFSprite->remove() — Removes an object to a sprite
SWFSprite->setFrames() — Sets the total number of frames in the animation
SWFSprite->startSound()
SWFSprite->stopSound()
SWFText — SWFText Class
SWFText->__construct() — Creates a new SWFText object
SWFText->addString() — Draws a string
SWFText->addUTF8String() — Writes the given text into this SWFText object at the current pen position, using the current font, height, spacing, and color
SWFText->getAscent() — Returns the ascent of the current font at its current size, or 0 if not available
SWFText->getDescent() — Returns the descent of the current font at its current size, or 0 if not available
SWFText->getLeading() — Returns the leading of the current font at its current size, or 0 if not available
SWFText->getUTF8Width() — calculates the width of the given string in this text objects current font and size
SWFText->getWidth() — Computes string's width
SWFText->moveTo() — Moves the pen
SWFText->setColor() — Sets the current text color
SWFText->setFont() — Sets the current font
SWFText->setHeight() — Sets the current font height
SWFText->setSpacing() — Sets the current font spacing
SWFTextField — SWFTextField Class
SWFTextField->__construct() — Creates a text field object
SWFTextField->addChars() — adds characters to a font that will be available within a textfield
SWFTextField->addString() — Concatenates the given string to the text field
SWFTextField->align() — Sets the text field alignment
SWFTextField->setBounds() — Sets the text field width and height
SWFTextField->setColor() — Sets the color of the text field
SWFTextField->setFont() — Sets the text field font
SWFTextField->setHeight() — Sets the font height of this text field font
SWFTextField->setIndentation() — Sets the indentation of the first line
SWFTextField->setLeftMargin() — Sets the left margin width of the text field
SWFTextField->setLineSpacing() — Sets the line spacing of the text field
SWFTextField->setMargins() — Sets the margins width of the text field
SWFTextField->setName() — Sets the variable name
SWFTextField->setPadding() — Sets the padding of this textfield
SWFTextField->setRightMargin() — Sets the right margin width of the text field
SWFVideoStream — SWFVideoStream Class
SWFVideoStream->__construct() — Returns a SWFVideoStream object
SWFVideoStream->getNumFrames()
SWFVideoStream->setDimension()
ming_keypress — Returns the action flag for keyPress(char)
ming_setcubicthreshold — Set cubic threshold
ming_setscale — Set scale
ming_setswfcompression — Sets the SWF output compression
ming_useconstants — Use constant pool
ming_useswfversion — Sets the SWF version
Předcházející | Nahoru | Další
mime_content_type | Domů | SWFAction


ming_setcubicthreshold

(PHP 4 >= 4.0.5, PHP 5)

ming_setcubicthreshold — Set cubic threshold

Popis

void ming_setcubicthreshold ( int $threshold )

Sets the threshold error for drawing cubic beziers.

Seznam parametrů

threshold

The Threshold. Lower is more accurate, hence larger file size.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ming_keypress | Domů | ming_setscale


ming_setscale

(PHP 4 >= 4.0.5, PHP 5)

ming_setscale — Set scale

Popis

void ming_setscale ( int $scale )

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ming_setcubicthreshold | Domů | ming_setswfcompression


ming_useswfversion

(PHP 4 >= 4.2.0, PHP 5)

ming_useswfversion — Sets the SWF version

Popis

void ming_useswfversion ( int $version )

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ming_useconstants | Domů | XC. Různé funkce


SWFBitmap->getHeight()

(PHP 5)

SWFBitmap->getHeight() — Returns the bitmap's height

Popis

class SWFBitmap {
float getHeight ( void )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the bitmap's height.

Návratové hodnoty

Returns the bitmap height in pixels.

Viz také

SWFBitmap->getWidth()

Předcházející | Nahoru | Další
SWFBitmap->__construct() | Domů | SWFBitmap->getWidth()


SWFBitmap->getWidth()

(PHP 5)

SWFBitmap->getWidth() — Returns the bitmap's width

Popis

class SWFBitmap {
float getWidth ( void )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the bitmap's width.

Návratové hodnoty

Returns the bitmap width in pixels.

Viz také

SWFBitmap->getHeight()

Předcházející | Nahoru | Další
SWFBitmap->getHeight() | Domů | SWFButton


SWFButton->addAction()

(PHP 5)

SWFButton->addAction() — Adds an action

Popis

class SWFButton {
void addAction ( SWFAction $action, int $flags )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Adds the given action to the button for the given conditions.

Seznam parametrů

action

An SWFAction, returned by SWFAction->__construct().

flags

The following flags are valid: SWFBUTTON_MOUSEOVER, SWFBUTTON_MOUSEOUT, SWFBUTTON_MOUSEUP, SWFBUTTON_MOUSEUPOUTSIDE, SWFBUTTON_MOUSEDOWN, SWFBUTTON_DRAGOUT and SWFBUTTON_DRAGOVER.

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

SWFButton->addShape()
SWFAction

Předcházející | Nahoru | Další
SWFButton->__construct() | Domů | SWFButton->addASound()


SWFButton->addShape()

(PHP 5)

SWFButton->addShape() — Adds a shape to a button

Popis

class SWFButton {
void addShape ( SWFShape $shape, int $flags )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Adds the given shape to the button.

Seznam parametrů

shape

An SWFShape instance

flags

The following flags are valid: SWFBUTTON_UP, SWFBUTTON_OVER, SWFBUTTON_DOWN and SWFBUTTON_HIT.

SWFBUTTON_HIT isn't ever displayed, it defines the hit region for the button. That is, everywhere the hit shape would be drawn is considered a "touchable" part of the button.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
SWFButton->addASound() | Domů | SWFButton->setAction()


SWFButton->setAction()

(PHP 5)

SWFButton->setAction() — Sets the action

Popis

class SWFButton {
void setAction ( SWFAction $action )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the action to be performed when the button is clicked.

This is a shortcut for SWFButton->addAction() called with the SWFBUTTON_MOUSEUP flag.

Seznam parametrů

action

An SWFAction, returned by SWFAction->__construct().

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

SWFButton->addAction()
SWFAction

Předcházející | Nahoru | Další
SWFButton->addShape() | Domů | SWFButton->setDown()


SWFButton->setDown()

(PHP 5)

SWFButton->setDown() — Alias for addShape(shape, SWFBUTTON_DOWN)

Popis

class SWFButton {
void setDown ( SWFShape $shape )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

swfbutton->setdown() alias for addShape(shape, SWFBUTTON_DOWN).

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

SWFButton->addShape()
SWFAction

Předcházející | Nahoru | Další
SWFButton->setAction() | Domů | SWFButton->setHit()


SWFButton->setHit()

(PHP 5)

SWFButton->setHit() — Alias for addShape(shape, SWFBUTTON_HIT)

Popis

class SWFButton {
void setHit ( SWFShape $shape )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

swfbutton->sethit() alias for addShape(shape, SWFBUTTON_HIT).

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

SWFButton->addShape()
SWFAction

Předcházející | Nahoru | Další
SWFButton->setDown() | Domů | SWFButton->setMenu()


SWFButton->setOver()

(PHP 5)

SWFButton->setOver() — Alias for addShape(shape, SWFBUTTON_OVER)

Popis

class SWFButton {
void setOver ( SWFShape $shape )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

swfbutton->setover() alias for addShape(shape, SWFBUTTON_OVER).

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

SWFButton->addShape()
SWFAction

Předcházející | Nahoru | Další
SWFButton->setMenu() | Domů | SWFButton->setUp()


SWFButton->setUp()

(PHP 5)

SWFButton->setUp() — Alias for addShape(shape, SWFBUTTON_UP)

Popis

class SWFButton {
void setUp ( SWFShape $shape )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

swfbutton->setup() alias for addShape(shape, SWFBUTTON_UP).

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

SWFButton->addShape()
SWFAction

Předcházející | Nahoru | Další
SWFButton->setOver() | Domů | SWFDisplayItem


SWFDisplayItem->addColor()

(PHP 5)

SWFDisplayItem->addColor() — Adds the given color to this item's color transform

Popis

class SWFDisplayItem {
void addColor ( int $red, int $green, int $blue [, int $a] )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

swfdisplayitem->addcolor() adds the color to this item's color transform. The color is given in its RGB form.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie->add().

Návratové hodnoty

Nevrací se žádná hodnota.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
SWFDisplayItem->addAction() | Domů | SWFDisplayItem->endMask()


SWFDisplayItem->move()

(PHP 5)

SWFDisplayItem->move() — Moves object in relative coordinates

Popis

class SWFDisplayItem {
void move ( int $dx, int $dy )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

swfdisplayitem->move() moves the current object by (dx,dy) from its current position.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie->add().

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

SWFDisplayItem->moveTo()

Předcházející | Nahoru | Další
SWFDisplayItem->getYSkew() | Domů | SWFDisplayItem->moveTo()


SWFDisplayItem->moveTo()

(PHP 5)

SWFDisplayItem->moveTo() — Moves object in global coordinates

Popis

class SWFDisplayItem {
void moveTo ( int $x, int $y )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

swfdisplayitem->moveto() moves the current object to (x,y) in global coordinates.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie->add().

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

SWFDisplayItem->move()

Předcházející | Nahoru | Další
SWFDisplayItem->move() | Domů | SWFDisplayItem->multColor()


SWFDisplayItem->multColor()

(PHP 5)

SWFDisplayItem->multColor() — Multiplies the item's color transform

Popis

class SWFDisplayItem {
void multColor ( int $red, int $green, int $blue [, int $a] )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

swfdisplayitem->multcolor() multiplies the item's color transform by the given values.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie->add().

Seznam parametrů

These parameters are integers between 0 and 255 or hexadecimals between 0x00 and 0xFF:

red

Value of red component

green

Value of green component

blue

Value of blue component

a

Value of alpha component

Návratové hodnoty

Nevrací se žádná hodnota.

Příklady

This simple example will modify your picture's atmosphere to Halloween (use a landscape or bright picture).

Příklad 1175. swfdisplayitem->multcolor() example

<?php

$b = new SWFBitmap(file_get_contents("backyard.jpg"));
// note use your own picture :-)
$s = new SWFShape();
$s->setRightFill($s->addFill($b));
$s->drawLine($b->getWidth(), 0);
$s->drawLine(0, $b->getHeight());
$s->drawLine(-$b->getWidth(), 0);
$s->drawLine(0, -$b->getHeight());

$m = new SWFMovie();
$m->setDimension($b->getWidth(), $b->getHeight());

$i = $m->add($s);

for ($n=0; $n<=20; ++$n) {
  $i->multColor(1.0-$n/10, 1.0, 1.0);
  $i->addColor(0xff*$n/20, 0, 0);
  $m->nextFrame();
}

header('Content-type: application/x-shockwave-flash');
$m->output();
?>

Předcházející | Nahoru | Další
SWFDisplayItem->moveTo() | Domů | SWFDisplayItem->remove()


SWFDisplayItem->remove()

(No version information available, might be only in CVS)

SWFDisplayItem->remove() — Removes the object from the movie

Popis

class SWFDisplayItem {
void remove ( void )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

swfdisplayitem->remove() removes this object from the movie's display list.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie->add().

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

SWFMovie->add()

Předcházející | Nahoru | Další
SWFDisplayItem->multColor() | Domů | SWFDisplayItem->rotate()


SWFDisplayItem->rotate()

(PHP 5)

SWFDisplayItem->rotate() — Rotates in relative coordinates

Popis

class SWFDisplayItem {
void rotate ( float $angle )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

swfdisplayitem->rotate() rotates the current object by angle degrees from its current rotation.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie->add().

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

SWFDisplayItem->rotateTo()

Předcházející | Nahoru | Další
SWFDisplayItem->remove() | Domů | SWFDisplayItem->rotateTo()


SWFDisplayItem->rotateTo()

(PHP 5)

SWFDisplayItem->rotateTo() — Rotates the object in global coordinates

Popis

class SWFDisplayItem {
void rotateTo ( float $angle )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

swfdisplayitem->rotateto() set the current object rotation to angle degrees in global coordinates.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie->add().

Návratové hodnoty

Nevrací se žádná hodnota.

Příklady

This example bring three rotating string from the background to the foreground. Pretty nice.

Příklad 1176. swfdisplayitem->rotateto() example

<?php
$thetext =  "ming!";

$f = new SWFFont("Bauhaus 93.fdb");

$m = new SWFMovie();
$m->setRate(24.0);
$m->setDimension(2400, 1600);
$m->setBackground(0xff, 0xff, 0xff);

// functions with huge numbers of arbitrary
// arguments are always a good idea!  Really!

function text($r, $g, $b, $a, $rot, $x, $y, $scale, $string)
{
  global $f, $m;

  $t = new SWFText();
  $t->setFont($f);
  $t->setColor($r, $g, $b, $a);
  $t->setHeight(960);
  $t->moveTo(-($f->getWidth($string))/2, $f->getAscent()/2);
  $t->addString($string);

  // we can add properties just like a normal PHP var,
  // as long as the names aren't already used.
  // e.g., we can't set $i->scale, because that's a function

  $i = $m->add($t);
  $i->x = $x;
  $i->y = $y;
  $i->rot = $rot;
  $i->s = $scale;
  $i->rotateTo($rot);
  $i->scale($scale, $scale);

  // but the changes are local to the function, so we have to
  // return the changed object.  kinda weird..

  return $i;
}

function step($i)
{
  $oldrot = $i->rot;
  $i->rot = 19*$i->rot/20;
  $i->x = (19*$i->x + 1200)/20;
  $i->y = (19*$i->y + 800)/20;
  $i->s = (19*$i->s + 1.0)/20;

  $i->rotateTo($i->rot);
  $i->scaleTo($i->s, $i->s);
  $i->moveTo($i->x, $i->y);

  return $i;
}

// see?  it sure paid off in legibility:

$i1 = text(0xff, 0x33, 0x33, 0xff, 900, 1200, 800, 0.03, $thetext);
$i2 = text(0x00, 0x33, 0xff, 0x7f, -560, 1200, 800, 0.04, $thetext);
$i3 = text(0xff, 0xff, 0xff, 0x9f, 180, 1200, 800, 0.001, $thetext);

for ($i=1; $i<=100; ++$i) {
  $i1 = step($i1);
  $i2 = step($i2);
  $i3 = step($i3);

  $m->nextFrame();
}

header('Content-type: application/x-shockwave-flash');
$m->output();
?>

Viz také

SWFDisplayItem->rotate()

Předcházející | Nahoru | Další
SWFDisplayItem->rotate() | Domů | SWFDisplayItem->scale()


SWFDisplayItem->scale()

(PHP 5)

SWFDisplayItem->scale() — Scales the object in relative coordinates

Popis

class SWFDisplayItem {
void scale ( int $dx, int $dy )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

swfdisplayitem->scale() scales the current object by (dx,dy) from its current size.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie->add().

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

SWFDisplayItem->scaleTo()

Předcházející | Nahoru | Další
SWFDisplayItem->rotateTo() | Domů | SWFDisplayItem->scaleTo()


SWFDisplayItem->scaleTo()

(PHP 5)

SWFDisplayItem->scaleTo() — Scales the object in global coordinates

Popis

class SWFDisplayItem {
void scaleTo ( int $x [, int $y] )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

swfdisplayitem->scaleto() scales the current object to (x,y) in global coordinates.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie->add().

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

SWFDisplayItem->scale()

Předcházející | Nahoru | Další
SWFDisplayItem->scale() | Domů | SWFDisplayItem->setDepth()


SWFDisplayItem->setDepth()

(PHP 5)

SWFDisplayItem->setDepth() — Sets z-order

Popis

class SWFDisplayItem {
void setDepth ( float $depth )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

swfdisplayitem->setdepth() sets the object's z-order to depth. Depth defaults to the order in which instances are created (by adding a shape/text to a movie)- newer ones are on top of older ones. If two objects are given the same depth, only the later-defined one can be moved.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie->add().

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
SWFDisplayItem->scaleTo() | Domů | SWFDisplayItem->setMaskLevel()


SWFDisplayItem->setName()

(PHP 5)

SWFDisplayItem->setName() — Sets the object's name

Popis

class SWFDisplayItem {
void setName ( string $name )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

swfdisplayitem->setname() sets the object's name to name, for targetting with action script. Only useful on sprites.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie->add().

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
SWFDisplayItem->setMatrix() | Domů | SWFDisplayItem->setRatio()


SWFDisplayItem->setRatio()

(PHP 5)

SWFDisplayItem->setRatio() — Sets the object's ratio

Popis

class SWFDisplayItem {
void setRatio ( float $ratio )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

swfdisplayitem->setratio() sets the object's ratio to ratio. Obviously only useful for morphs.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie->add().

Návratové hodnoty

Nevrací se žádná hodnota.

Příklady

This simple example will morph nicely three concentric circles.

Příklad 1177. swfdisplayitem->setname() example

<?php

$p = new SWFMorph();

$g = new SWFGradient();
$g->addEntry(0.0, 0, 0, 0);
$g->addEntry(0.16, 0xff, 0xff, 0xff);
$g->addEntry(0.32, 0, 0, 0);
$g->addEntry(0.48, 0xff, 0xff, 0xff);
$g->addEntry(0.64, 0, 0, 0);
$g->addEntry(0.80, 0xff, 0xff, 0xff);
$g->addEntry(1.00, 0, 0, 0);

$s = $p->getShape1();
$f = $s->addFill($g, SWFFILL_RADIAL_GRADIENT);
$f->scaleTo(0.05);
$s->setLeftFill($f);
$s->movePenTo(-160, -120);
$s->drawLine(320, 0);
$s->drawLine(0, 240);
$s->drawLine(-320, 0);
$s->drawLine(0, -240);

$g = new SWFGradient();
$g->addEntry(0.0, 0, 0, 0);
$g->addEntry(0.16, 0xff, 0, 0);
$g->addEntry(0.32, 0, 0, 0);
$g->addEntry(0.48, 0, 0xff, 0);
$g->addEntry(0.64, 0, 0, 0);
$g->addEntry(0.80, 0, 0, 0xff);
$g->addEntry(1.00, 0, 0, 0);

$s = $p->getShape2();
$f = $s->addFill($g, SWFFILL_RADIAL_GRADIENT);
$f->scaleTo(0.05);
$f->skewXTo(1.0);
$s->setLeftFill($f);
$s->movePenTo(-160, -120);
$s->drawLine(320, 0);
$s->drawLine(0, 240);
$s->drawLine(-320, 0);
$s->drawLine(0, -240);

$m = new SWFMovie();
$m->setDimension(320, 240);
$i = $m->add($p);
$i->moveTo(160, 120);

for ($n=0; $n<=1.001; $n+=0.01) {
    $i->setRatio($n);
    $m->nextFrame();
}

header('Content-type: application/x-shockwave-flash');
$m->output();
?>

Předcházející | Nahoru | Další
SWFDisplayItem->setName() | Domů | SWFDisplayItem->skewX()


SWFDisplayItem->skewX()

(PHP 5)

SWFDisplayItem->skewX() — Sets the X-skew

Popis

class SWFDisplayItem {
void skewX ( float $ddegrees )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

swfdisplayitem->skewx() adds ddegrees to current x-skew.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie->add().

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

SWFDisplayItem->skewXTo()
SWFDisplayItem->skewY()
SWFDisplayItem->skewYTo()

Předcházející | Nahoru | Další
SWFDisplayItem->setRatio() | Domů | SWFDisplayItem->skewXTo()


SWFDisplayItem->skewXTo()

(PHP 5)

SWFDisplayItem->skewXTo() — Sets the X-skew

Popis

class SWFDisplayItem {
void skewXTo ( float $degrees )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

swfdisplayitem->skewxto() sets the x-skew to degrees. For degrees is 1.0, it means a 45-degree forward slant. More is more forward, less is more backward.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie->add().

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

SWFDisplayItem->skewX()
SWFDisplayItem->skewY()
SWFDisplayItem->skewYTo()

Předcházející | Nahoru | Další
SWFDisplayItem->skewX() | Domů | SWFDisplayItem->skewY()


SWFDisplayItem->skewY()

(PHP 5)

SWFDisplayItem->skewY() — Sets the Y-skew

Popis

class SWFDisplayItem {
void skewY ( float $ddegrees )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

swfdisplayitem->skewy() adds ddegrees to current y-skew.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie->add().

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

SWFDisplayItem->skewYTo()
SWFDisplayItem->skewX()
SWFDisplayItem->skewXTo()

Předcházející | Nahoru | Další
SWFDisplayItem->skewXTo() | Domů | SWFDisplayItem->skewYTo()


SWFDisplayItem->skewYTo()

(PHP 5)

SWFDisplayItem->skewYTo() — Sets the Y-skew

Popis

class SWFDisplayItem {
void skewYTo ( float $degrees )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

swfdisplayitem->skewyto() sets the y-skew to degrees. For degrees is 1.0, it means a 45-degree forward slant. More is more upward, less is more downward.

The object may be a swfshape(), a swfbutton(), a swftext() or a swfsprite() object. It must have been added using the swfmovie->add().

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

SWFDisplayItem->skewY()
SWFDisplayItem->skewX()
SWFDisplayItem->skewXTo()

Předcházející | Nahoru | Další
SWFDisplayItem->skewY() | Domů | SWFFill


SWFFill->moveTo()

(PHP 5)

SWFFill->moveTo() — Moves fill origin

Popis

class SWFFill {
void moveTo ( int $x, int $y )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Moves the fill origin to the given global coordinates.

Seznam parametrů

x

X-coordinate

y

Y-coordinate

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
SWFFill | Domů | SWFFill->rotateTo()


SWFFill->rotateTo()

(PHP 5)

SWFFill->rotateTo() — Sets fill's rotation

Popis

class SWFFill {
void rotateTo ( float $angle )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the fill rotation to the given angle.

Seznam parametrů

angle

The rotation angle, in degreess.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
SWFFill->moveTo() | Domů | SWFFill->scaleTo()


SWFFill->scaleTo()

(PHP 5)

SWFFill->scaleTo() — Sets fill's scale

Popis

class SWFFill {
void scaleTo ( int $x [, int $y] )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the fill scale to the given coordinates.

Seznam parametrů

x

X-coordinate

y

Y-coordinate

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
SWFFill->rotateTo() | Domů | SWFFill->skewXTo()


SWFFill->skewXTo()

(PHP 5)

SWFFill->skewXTo() — Sets fill x-skew

Popis

class SWFFill {
void skewXTo ( float $x )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the fill x-skew to x.

Seznam parametrů

x

When x is 1.0, it is a 45-degree forward slant. More is more forward, less is more backward.

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

SWFFill->skewYTo()

Předcházející | Nahoru | Další
SWFFill->scaleTo() | Domů | SWFFill->skewYTo()


SWFFill->skewYTo()

(PHP 5)

SWFFill->skewYTo() — Sets fill y-skew

Popis

class SWFFill {
void skewYTo ( float $y )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the fill y-skew to y.

Seznam parametrů

y

When y is 1.0, it is a 45-degree upward slant. More is more upward, less is more downward.

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

SWFFill->skewXTo()

Předcházející | Nahoru | Další
SWFFill->skewXTo() | Domů | SWFFont


SWFFont->getWidth()

(PHP 5)

SWFFont->getWidth() — Returns the string's width

Popis

class SWFFont {
float getWidth ( string $string )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

swffont->getwidth() returns the string string's width, using font's default scaling. You'll probably want to use the swftext() version of this method which uses the text object's scale.

Viz také

SWFFont->getUTF8Width()

Předcházející | Nahoru | Další
SWFFont->getUTF8Width() | Domů | SWFFontChar


SWFGradient->addEntry()

(PHP 5)

SWFGradient->addEntry() — Adds an entry to the gradient list

Popis

class SWFGradient {
void addEntry ( float $ratio, int $red, int $green, int $blue [, int $a] )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

swfgradient->addentry() adds an entry to the gradient list. ratio is a number between 0 and 1 indicating where in the gradient this color appears. Thou shalt add entries in order of increasing ratio.

red, green, blue is a color (RGB mode). Last parameter a is optional.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
SWFGradient->__construct() | Domů | SWFMorph


SWFMorph->getShape1()

(PHP 5)

SWFMorph->getShape1() — Gets a handle to the starting shape

Popis

class SWFMorph {
SWFShape getShape1 ( void )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Gets the morph's starting shape.

Návratové hodnoty

Returns a SWFShape object.

Viz také

SWFMorph->getShape2()

Předcházející | Nahoru | Další
SWFMorph->__construct() | Domů | SWFMorph->getShape2()


SWFMorph->getShape2()

(PHP 5)

SWFMorph->getShape2() — Gets a handle to the ending shape

Popis

class SWFMorph {
SWFShape getShape2 ( void )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Gets the morph's ending shape.

Návratové hodnoty

Returns a SWFShape object.

Viz také

SWFMorph->getShape1()

Předcházející | Nahoru | Další
SWFMorph->getShape1() | Domů | SWFMovie


SWFMovie->add()

(PHP 5)

SWFMovie->add() — Adds any type of data to a movie

Popis

class SWFMovie {
mixed add ( object $instance )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Adds an SWF object instance to the current movie.

Seznam parametrů

instance

Any type of object instance, like SWFShape, SWFText, SWFFont.

Návratové hodnoty

For displayable types (shape, text, button, sprite), this returns an SWFDisplayItem, a handle to the object in a display list. Thus, you can add the same shape to a movie multiple times and get separate handles back for each separate instance.

Viz také

SWFMovie->remove()

Předcházející | Nahoru | Další
SWFMovie->__construct() | Domů | SWFMovie->addExport()


SWFMovie->nextFrame()

(PHP 5)

SWFMovie->nextFrame() — Moves to the next frame of the animation

Popis

class SWFMovie {
void nextFrame ( void )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Moves to the next frame of the animation.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
SWFMovie->labelFrame() | Domů | SWFMovie->output()


SWFMovie->output()

(PHP 5)

SWFMovie->output() — Dumps your lovingly prepared movie out

Popis

class SWFMovie {
int output ( [int $compression] )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Dumps the SWFMovie.

Don't forget to send the Content-Type HTTP header file before using this function, in order to display the movie in a browser.

Seznam parametrů

compression

The compression level can be a value between 0 and 9, defining the SWF compression similar to gzip compression.

This parameter is only available as of Flash MX (6).

Návratové hodnoty

Return the number of bytes written or FALSE on error.

Příklady

Příklad 1180. Displaying your $movie in a browser

<?php
header('Content-type: application/x-shockwave-flash');
$movie->output();
?>

Viz také

SWFMovie->save()
SWFMovie->saveToFile()

Předcházející | Nahoru | Další
SWFMovie->nextFrame() | Domů | SWFMovie->remove()


SWFMovie->remove()

(PHP 5 >= 5.2.1)

SWFMovie->remove() — Removes the object instance from the display list

Popis

class SWFMovie {
void remove ( object $instance )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Removes the given object instance from the display list.

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

SWFMovie->add()

Předcházející | Nahoru | Další
SWFMovie->output() | Domů | SWFMovie->save()


SWFMovie->save()

(PHP 5)

SWFMovie->save() — Saves the SWF movie in a file

Popis

class SWFMovie {
int save ( string $filename [, int $compression] )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Saves the SWF movie to the specified filename.

Seznam parametrů

filename

The path to the saved SWF document.

compression

The compression level can be a value between 0 and 9, defining the SWF compression similar to gzip compression.

This parameter is only available as of Flash MX (6).

Návratové hodnoty

Return the number of bytes written or FALSE on error.

Viz také

SWFMovie->output()
SWFMovie->saveToFile()

Předcházející | Nahoru | Další
SWFMovie->remove() | Domů | SWFMovie->saveToFile()


SWFMovie->setbackground()

(PHP 5)

SWFMovie->setbackground() — Sets the background color

Popis

class SWFMovie {
void setbackground ( int $red, int $green, int $blue )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the background color.

Why is there no rgba version? Think about it, you might want to let the HTML background show through. There's a way to do that, but it only works on IE4. Search the » http://www.macromedia.com/ site for details.

Seznam parametrů

These parameters are integers between 0 and 255 or hexadecimals between 0x00 and 0xFF:

red

Value of red component

green

Value of green component

blue

Value of blue component

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
SWFMovie->saveToFile() | Domů | SWFMovie->setDimension()


SWFMovie->setDimension()

(PHP 5)

SWFMovie->setDimension() — Sets the movie's width and height

Popis

class SWFMovie {
void setDimension ( int $width, int $height )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the movie's dimension to the specified width and height.

Seznam parametrů

width

The movie width.

height

The movie height.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
SWFMovie->setbackground() | Domů | SWFMovie->setFrames()


SWFMovie->setFrames()

(PHP 5)

SWFMovie->setFrames() — Sets the total number of frames in the animation

Popis

class SWFMovie {
void setFrames ( int $number )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the total number of frames in the animation to the given number.

Seznam parametrů

number

The number of frames.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
SWFMovie->setDimension() | Domů | SWFMovie->setRate()


SWFMovie->setRate()

(PHP 5)

SWFMovie->setRate() — Sets the animation's frame rate

Popis

class SWFMovie {
void setRate ( int $rate )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the frame rate to the specified rate.

Animation will slow down if the player can't render frames fast enough- unless there's a streaming sound, in which case display frames are sacrificed to keep sound from skipping.

Seznam parametrů

rate

The frame rate, in frame per seconds.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
SWFMovie->setFrames() | Domů | SWFMovie->startSound()


SWFMovie->streamMP3()

(PHP 5)

SWFMovie->streamMP3() — Streams a MP3 file

Popis

class SWFMovie {
int streamMP3 ( mixed $mp3file [, float $skip] )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Streams the given MP3 file mp3file.

This method is not very robust in dealing with oddities (can skip over an initial ID3 tag, but that's about it).

Note that the movie isn't smart enough to put enough frames in to contain the entire mp3 stream- you'll have to add (length of song * frames per second) frames to get the entire stream in.

Seznam parametrů

mp3file

Can be a file pointer returned by fopen() or the MP3 data, as a binary string.

skip

Number of seconds to skip.

Návratové hodnoty

Return number of frames.

ChangeLog (záznam změn)

Verze | Popis
5.2.0 | skip added

Příklady

Příklad 1181. Streaming example

<?php
$m = new SWFMovie();
$m->setRate(12.0);
$m->streamMp3(file_get_contents("distortobass.mp3"));
// use your own MP3

// The file is 11.85 seconds at 12.0 fps = 142 frames
$m->setFrames(142);

header('Content-type: application/x-shockwave-flash');
$m->output();
?>

Předcházející | Nahoru | Další
SWFMovie->stopSound() | Domů | SWFMovie->writeExports()


SWFShape->addFill()

(PHP 5)

SWFShape->addFill() — Adds a solid fill to the shape

Popis

class SWFShape {
SWFFill addFill ( int $red, int $green, int $blue [, int $a] )
SWFFill addFill ( SWFBitmap $bitmap [, int $flags] )
SWFFill addFill ( SWFGradient $gradient [, int $flags] )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

SWFShape->addFill() adds a solid fill to the shape's list of fill styles. SWFShape->addFill() accepts three different types of arguments.

red, green, blue is a color (RGB mode). Last parameter a is optional.

The bitmap argument is an SWFBitmap() object. The flags argument can be one of the following values: SWFFILL_CLIPPED_BITMAP, SWFFILL_TILED_BITMAP, SWFFILL_LINEAR_GRADIENT or SWFFILL_RADIAL_GRADIENT. Default is SWFFILL_TILED_BITMAP for SWFBitmap and SWFFILL_LINEAR_GRADIENT for SWFGradient.

The gradient argument is an SWFGradient() object. The flags argument can be one of the following values : SWFFILL_RADIAL_GRADIENT or SWFFILL_LINEAR_GRADIENT. Default is SWFFILL_LINEAR_GRADIENT. I'm sure about this one. Really.

SWFShape->addFill() returns an SWFFill()
object for use with the SWFShape->setLeftFill()
and SWFShape->setRightFill() functions
described below.

Příklady

This simple example will draw a frame on a bitmap. Ah, here's another buglet in the flash player- it doesn't seem to care about the second shape's bitmap's transformation in a morph. According to spec, the bitmap should stretch along with the shape in this example..

Příklad 1183. SWFShape->addFill() example

<?php

$p = new SWFMorph();

$b = new SWFBitmap(file_get_contents("alphafill.jpg"));
// use your own bitmap
$width = $b->getWidth();
$height = $b->getHeight();

$s = $p->getShape1();
$f = $s->addFill($b, SWFFILL_TILED_BITMAP);
$f->moveTo(-$width/2, -$height/4);
$f->scaleTo(1.0, 0.5);
$s->setLeftFill($f);
$s->movePenTo(-$width/2, -$height/4);
$s->drawLine($width, 0);
$s->drawLine(0, $height/2);
$s->drawLine(-$width, 0);
$s->drawLine(0, -$height/2);

$s = $p->getShape2();
$f = $s->addFill($b, SWFFILL_TILED_BITMAP);

// these two have no effect!
$f->moveTo(-$width/4, -$height/2);
$f->scaleTo(0.5, 1.0);

$s->setLeftFill($f);
$s->movePenTo(-$width/4, -$height/2);
$s->drawLine($width/2, 0);
$s->drawLine(0, $height);
$s->drawLine(-$width/2, 0);
$s->drawLine(0, -$height);

$m = new SWFMovie();
$m->setDimension($width, $height);
$i = $m->add($p);
$i->moveTo($width/2, $height/2);

for ($n=0; $n<1.001; $n+=0.03) {
    $i->setRatio($n);
    $m->nextFrame();
}

header('Content-type: application/x-shockwave-flash');
$m->output();
?>

Viz také

SWFShape->setLeftFill()
SWFShape->setRightFill()

Předcházející | Nahoru | Další
SWFShape->__construct() | Domů | SWFShape->drawArc()


SWFShape->drawCurve()

(PHP 5)

SWFShape->drawCurve() — Draws a curve (relative)

Popis

class SWFShape {
int drawCurve ( int $controldx, int $controldy, int $anchordx, int $anchordy [, int $targetdx, int $targetdy] )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

swfshape->drawcurve() draws a quadratic curve (using the current line style,set by swfshape->setline()) from the current pen position to the relative position (anchorx,anchory) using relative control point (controlx,controly). That is, head towards the control point, then smoothly turn to the anchor point.

With 6 parameters, it draws a cubic bezier to point (x+targetdx, x+targetdy) with control points (x+controldx, y+controldy) and (x+anchordx, y+anchordy).

Viz také

SWFShape->drawCurve()

Předcházející | Nahoru | Další
SWFShape->drawCubicTo() | Domů | SWFShape->drawCurveTo()


SWFShape->drawCurveTo()

(PHP 5)

SWFShape->drawCurveTo() — Draws a curve

Popis

class SWFShape {
int drawCurveTo ( int $controlx, int $controly, int $anchorx, int $anchory [, int $targetx, int $targety] )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

swfshape->drawcurveto() draws a quadratic curve (using the current line style, set by swfshape->setline()) from the current pen position to (anchorx,anchory) using (controlx,controly) as a control point. That is, head towards the control point, then smoothly turn to the anchor point.

With 6 parameters, it draws a cubic bezier to point (targetx, targety) with control points (controlx, controly) and (anchorx, anchory).

Viz také

SWFShape->drawCurveTo()

Předcházející | Nahoru | Další
SWFShape->drawCurve() | Domů | SWFShape->drawGlyph()


SWFShape->drawLine()

(PHP 5)

SWFShape->drawLine() — Draws a line (relative)

Popis

class SWFShape {
void drawLine ( int $dx, int $dy )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

swfshape->drawline() draws a line (using the current line style set by swfshape->setline()) from the current pen position to displacement (dx,dy).

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

SWFShape->drawLineTo()

Předcházející | Nahoru | Další
SWFShape->drawGlyph() | Domů | SWFShape->drawLineTo()


SWFShape->drawLineTo()

(PHP 5)

SWFShape->drawLineTo() — Draws a line

Popis

class SWFShape {
void drawLineTo ( int $x, int $y )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

swfshape->setrightfill() draws a line (using the current line style, set by swfshape->setline()) from the current pen position to point (x,y) in the shape's coordinate space.

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

SWFShape->drawLine()

Předcházející | Nahoru | Další
SWFShape->drawLine() | Domů | SWFShape->movePen()


SWFShape->movePen()

(PHP 5)

SWFShape->movePen() — Moves the shape's pen (relative)

Popis

class SWFShape {
void movePen ( int $dx, int $dy )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

swfshape->setrightfill() move the shape's pen from coordinates (current x,current y) to (current x + dx, current y + dy) in the shape's coordinate space.

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

SWFShape->movePenTo()

Předcházející | Nahoru | Další
SWFShape->drawLineTo() | Domů | SWFShape->movePenTo()


SWFShape->movePenTo()

(PHP 5)

SWFShape->movePenTo() — Moves the shape's pen

Popis

class SWFShape {
void movePenTo ( int $x, int $y )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

swfshape->setrightfill() move the shape's pen to (x,y) in the shape's coordinate space.

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

SWFShape->movePen()

Předcházející | Nahoru | Další
SWFShape->movePen() | Domů | SWFShape->setLeftFill()


SWFShape->setLeftFill()

(PHP 5)

SWFShape->setLeftFill() — Sets left rasterizing color

Popis

class SWFShape {
void setLeftFill ( SWFGradient $fill )
void setLeftFill ( int $red, int $green, int $blue [, int $a] )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

What this nonsense is about is, every edge segment borders at most two fills. When rasterizing the object, it's pretty handy to know what those fills are ahead of time, so the swf format requires these to be specified.

swfshape->setleftfill() sets the fill on the left side of the edge- that is, on the interior if you're defining the outline of the shape in a counter-clockwise fashion. The fill object is an SWFFill object returned from one of the addFill functions above.

This seems to be reversed when you're defining a shape in a morph, though. If your browser crashes, just try setting the fill on the other side.

Shortcut for swfshape->setleftfill($s->addfill($r, $g, $b [, $a]));.

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

SWFShape->setRightFill()

Předcházející | Nahoru | Další
SWFShape->movePenTo() | Domů | SWFShape->setLine()


SWFShape->setLine()

(PHP 5)

SWFShape->setLine() — Sets the shape's line style

Popis

class SWFShape {
void setLine ( SWFShape $shape )
void setLine ( int $width, int $red, int $green, int $blue [, int $a] )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

swfshape->setline() sets the shape's line style. width is the line's width. If width is 0, the line's style is removed (then, all other arguments are ignored). If width > 0, then line's color is set to red, green, blue. Last parameter a is optional.

You must declare all line styles before you use them (see example).

Návratové hodnoty

Nevrací se žádná hodnota.

Příklady

This simple example will draw a big "!#%*@", in funny colors and gracious style.

Příklad 1184. swfshape->setline() example

<?php
$s = new SWFShape();
$f1 = $s->addFill(0xff, 0, 0);
$f2 = $s->addFill(0xff, 0x7f, 0);
$f3 = $s->addFill(0xff, 0xff, 0);
$f4 = $s->addFill(0, 0xff, 0);
$f5 = $s->addFill(0, 0, 0xff);

// bug: have to declare all line styles before you use them
$s->setLine(40, 0x7f, 0, 0);
$s->setLine(40, 0x7f, 0x3f, 0);
$s->setLine(40, 0x7f, 0x7f, 0);
$s->setLine(40, 0, 0x7f, 0);
$s->setLine(40, 0, 0, 0x7f);

$f = new SWFFont('Techno.fdb');

$s->setRightFill($f1);
$s->setLine(40, 0x7f, 0, 0);
$s->drawGlyph($f, '!');
$s->movePen($f->getWidth('!'), 0);

$s->setRightFill($f2);
$s->setLine(40, 0x7f, 0x3f, 0);
$s->drawGlyph($f, '#');
$s->movePen($f->getWidth('#'), 0);

$s->setRightFill($f3);
$s->setLine(40, 0x7f, 0x7f, 0);
$s->drawGlyph($f, '%');
$s->movePen($f->getWidth('%'), 0);

$s->setRightFill($f4);
$s->setLine(40, 0, 0x7f, 0);
$s->drawGlyph($f, '*');
$s->movePen($f->getWidth('*'), 0);

$s->setRightFill($f5);
$s->setLine(40, 0, 0, 0x7f);
$s->drawGlyph($f, '@');

$m = new SWFMovie();
$m->setDimension(3000,2000);
$m->setRate(12.0);
$i = $m->add($s);
$i->moveTo(1500-$f->getWidth("!#%*@")/2, 1000+$f->getAscent()/2);

header('Content-type: application/x-shockwave-flash');
$m->output();
?>

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
SWFShape->setLeftFill() | Domů | SWFShape->setRightFill()


SWFShape->setRightFill()

(No version information available, might be only in CVS)

SWFShape->setRightFill() — Sets right rasterizing color

Popis

class SWFShape {
void setRightFill ( SWFGradient $fill )
void setRightFill ( int $red, int $green, int $blue [, int $a] )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Shortcut for swfshape->setrightfill($s->addfill($r, $g, $b [, $a]));.

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

SWFShape->setLeftFill()

Předcházející | Nahoru | Další
SWFShape->setLine() | Domů | SWFSound


SWFSprite->add()

(PHP 5)

SWFSprite->add() — Adds an object to a sprite

Popis

class SWFSprite {
void add ( object $object )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

swfsprite->add() adds a swfshape(), a
swfbutton(), a swftext(),
a swfaction() or a swfsprite() object.

For displayable types (swfshape(),
swfbutton(), swftext(),
swfaction() or swfsprite()),
this returns a handle  to the object in a display list.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
SWFSprite->__construct() | Domů | SWFSprite->labelFrame()


SWFSprite->nextFrame()

(PHP 5)

SWFSprite->nextFrame() — Moves to the next frame of the animation

Popis

class SWFSprite {
void nextFrame ( void )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

swfsprite->setframes() moves to the next frame of the animation.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
SWFSprite->labelFrame() | Domů | SWFSprite->remove()


SWFSprite->remove()

(PHP 5)

SWFSprite->remove() — Removes an object to a sprite

Popis

class SWFSprite {
void remove ( object $object )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

swfsprite->remove() remove a swfshape(), a
swfbutton(), a swftext(),
a swfaction() or a swfsprite() object
from the sprite.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
SWFSprite->nextFrame() | Domů | SWFSprite->setFrames()


SWFSprite->setFrames()

(PHP 5)

SWFSprite->setFrames() — Sets the total number of frames in the animation

Popis

class SWFSprite {
void setFrames ( int $number )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

swfsprite->setframes() sets the total number of frames in the animation to numberofframes.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
SWFSprite->remove() | Domů | SWFSprite->startSound()


SWFText->addString()

(PHP 5)

SWFText->addString() — Draws a string

Popis

class SWFText {
void addString ( string $string )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

swftext->addstring() draws the string string at the current pen (cursor) location. Pen is at the baseline of the text; i.e., ascending text is in the -y direction.

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

SWFText->addUTF8String()

Předcházející | Nahoru | Další
SWFText->__construct() | Domů | SWFText->addUTF8String()


SWFText->getWidth()

(PHP 5)

SWFText->getWidth() — Computes string's width

Popis

class SWFText {
float getWidth ( string $string )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the rendered width of the string at the text object's current font, scale, and spacing settings.

Viz také

SWFText->getUTF8Width()

Předcházející | Nahoru | Další
SWFText->getUTF8Width() | Domů | SWFText->moveTo()


SWFText->moveTo()

(PHP 5)

SWFText->moveTo() — Moves the pen

Popis

class SWFText {
void moveTo ( int $x, int $y )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

swftext->moveto() moves the pen (or cursor, if that makes more sense) to (x,y) in text object's coordinate space. If either is zero, though, value in that dimension stays the same. Annoying, should be fixed.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
SWFText->getWidth() | Domů | SWFText->setColor()


SWFText->setColor()

(PHP 5)

SWFText->setColor() — Sets the current text color

Popis

class SWFText {
void setColor ( int $red, int $green, int $blue [, int $a] )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Changes the current text color.

Seznam parametrů

These parameters are integers between 0 and 255 or hexadecimals between 0x00 and 0xFF:

red

Value of red component

green

Value of green component

blue

Value of blue component

a

Value of alpha component

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
SWFText->moveTo() | Domů | SWFText->setFont()


SWFText->setFont()

(PHP 5)

SWFText->setFont() — Sets the current font

Popis

class SWFText {
void setFont ( string $font )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

swftext->setfont() sets the current font to font.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
SWFText->setColor() | Domů | SWFText->setHeight()


SWFText->setHeight()

(PHP 5)

SWFText->setHeight() — Sets the current font height

Popis

class SWFText {
void setHeight ( int $height )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

swftext->setheight() sets the current font height to height. Default is 240.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
SWFText->setFont() | Domů | SWFText->setSpacing()


SWFText->setSpacing()

(PHP 5)

SWFText->setSpacing() — Sets the current font spacing

Popis

class SWFText {
void setSpacing ( float $spacing )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

swftext->setspacing() sets the current font spacing to spacing. Default is 1.0. 0 is all of the letters written at the same point. This doesn't really work that well because it inflates the advance across the letter, doesn't add the same amount of spacing between the letters. I should try and explain that better, prolly. Or just fix the damn thing to do constant spacing. This was really just a way to figure out how letter advances work, anyway.. So nyah.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
SWFText->setHeight() | Domů | SWFTextField


SWFTextField->addString()

(PHP 5)

SWFTextField->addString() — Concatenates the given string to the text field

Popis

class SWFTextField {
void addString ( string $string )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

swftextfield->setname() concatenates the string string to the text field.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
SWFTextField->addChars() | Domů | SWFTextField->align()


SWFTextField->align()

(PHP 5)

SWFTextField->align() — Sets the text field alignment

Popis

class SWFTextField {
void align ( int $alignement )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

swftextfield->align() sets the text field alignment to alignement. Valid values for alignement are : SWFTEXTFIELD_ALIGN_LEFT, SWFTEXTFIELD_ALIGN_RIGHT, SWFTEXTFIELD_ALIGN_CENTER and SWFTEXTFIELD_ALIGN_JUSTIFY.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
SWFTextField->addString() | Domů | SWFTextField->setBounds()


SWFTextField->setBounds()

(PHP 5)

SWFTextField->setBounds() — Sets the text field width and height

Popis

class SWFTextField {
void setBounds ( int $width, int $height )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

swftextfield->setbounds() sets the text field width to width and height to height. If you don't set the bounds yourself, Ming makes a poor guess at what the bounds are.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
SWFTextField->align() | Domů | SWFTextField->setColor()


SWFTextField->setColor()

(PHP 5)

SWFTextField->setColor() — Sets the color of the text field

Popis

class SWFTextField {
void setColor ( int $red, int $green, int $blue [, int $a] )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

swftextfield->setcolor() sets the color of the text field. Default is fully opaque black. Color is represented using RGB system.

Seznam parametrů

These parameters are integers between 0 and 255 or hexadecimals between 0x00 and 0xFF:

red

Value of red component

green

Value of green component

blue

Value of blue component

a

Value of alpha component

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
SWFTextField->setBounds() | Domů | SWFTextField->setFont()


SWFTextField->setFont()

(PHP 5)

SWFTextField->setFont() — Sets the text field font

Popis

class SWFTextField {
void setFont ( string $font )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

swftextfield->setfont() sets the text field font to the [browser-defined?] font font.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
SWFTextField->setColor() | Domů | SWFTextField->setHeight()


SWFTextField->setHeight()

(PHP 5)

SWFTextField->setHeight() — Sets the font height of this text field font

Popis

class SWFTextField {
void setHeight ( int $height )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

swftextfield->setheight() sets the font height of this text field font to the given height height. Default is 240.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
SWFTextField->setFont() | Domů | SWFTextField->setIndentation()


SWFTextField->setIndentation()

(PHP 5)

SWFTextField->setIndentation() — Sets the indentation of the first line

Popis

class SWFTextField {
void setIndentation ( int $width )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

swftextfield->setindentation() sets the indentation of the first line in the text field, to width.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
SWFTextField->setHeight() | Domů | SWFTextField->setLeftMargin()


SWFTextField->setLeftMargin()

(PHP 5)

SWFTextField->setLeftMargin() — Sets the left margin width of the text field

Popis

class SWFTextField {
void setLeftMargin ( int $width )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

swftextfield->setleftmargin() sets the left margin width of the text field to width. Default is 0.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
SWFTextField->setIndentation() | Domů | SWFTextField->setLineSpacing()


SWFTextField->setLineSpacing()

(PHP 5)

SWFTextField->setLineSpacing() — Sets the line spacing of the text field

Popis

class SWFTextField {
void setLineSpacing ( int $height )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

swftextfield->setlinespacing() sets the line spacing of the text field to the height of height. Default is 40.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
SWFTextField->setLeftMargin() | Domů | SWFTextField->setMargins()


SWFTextField->setMargins()

(PHP 5)

SWFTextField->setMargins() — Sets the margins width of the text field

Popis

class SWFTextField {
void setMargins ( int $left, int $right )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

swftextfield->setmargins() set both margins at once, for the man on the go.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
SWFTextField->setLineSpacing() | Domů | SWFTextField->setName()


SWFTextField->setName()

(PHP 5)

SWFTextField->setName() — Sets the variable name

Popis

class SWFTextField {
void setName ( string $name )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

swftextfield->setname() sets the variable name of this text field to name, for form posting and action scripting purposes.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
SWFTextField->setMargins() | Domů | SWFTextField->setPadding()


SWFTextField->setRightMargin()

(PHP 5)

SWFTextField->setRightMargin() — Sets the right margin width of the text field

Popis

class SWFTextField {
void setRightMargin ( int $width )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

swftextfield->setrightmargin() sets the right margin width of the text field to width. Default is 0.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
SWFTextField->setPadding() | Domů | SWFVideoStream


Různé funkce

Předcházející VI. Reference funkcí Další

XC. Různé funkce

Úvod

Tyto funkce byly umístěny zde, protože nespadají do žádné jiné kategorie.

Požadavky

Tyto funkce jsou k dispozici jako součást standardního modulu, který je vždy dostupný.

Instalace

K používání těchto funkcí není třeba žádná instalace, jsou součástí jádra PHP.

Konfigurace běhu

Chování těchto funkcí je ovlivněno nastavením parametrů v php.ini.

Tabulka 164. Misc. Configuration Options

Name | Default | Changeable | Changelog
ignore_user_abort | "0" | PHP_INI_ALL |
highlight.string | "#DD0000" | PHP_INI_ALL |
highlight.comment | "#FF8000" | PHP_INI_ALL |
highlight.keyword | "#007700" | PHP_INI_ALL |
highlight.bg | "#FFFFFF" | PHP_INI_ALL | Removed in PHP 6.0.0.
highlight.default | "#0000BB" | PHP_INI_ALL |
highlight.html | "#000000" | PHP_INI_ALL |
browscap | NULL | PHP_INI_SYSTEM |

Pro další detaily a definice konstant PHP_INI_*, viz dokumentace k ini_set().

Zde je stručný popis konfiguračních direktiv.

ignore_user_abort boolean

FALSE by default. If changed to TRUE scripts will not be terminated after a client has aborted their connection.

See also ignore_user_abort().

highlight.bg string , highlight.comment string , highlight.default string , highlight.html string , highlight.keyword string , highlight.string string

Colors for Syntax Highlighting mode. Anything that's acceptable in <font color="??????"> would work.

browscap string

Name (e.g.: browscap.ini) and location of browser capabilities file. See also get_browser().

Typy prostředků

Toto rozšíření nemá definován žádný typ prostředku (resource).

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

CONNECTION_ABORTED (integer)
CONNECTION_NORMAL (integer)
CONNECTION_TIMEOUT (integer)
__COMPILER_HALT_OFFSET__ (integer)
Added in PHP 5.1.

Obsah

connection_aborted — Vrací TRUE, pokud se klient odpojil
connection_status — Vrací bitové pole stavu spojení
connection_timeout — Return TRUE if script timed out
constant — Returns the value of a constant
define — Definuje pojmenovanou konstantu.
defined — Zkontroluje, jestli existuje daná pojmenovaná konstanta
die — Vytiskne vzkaz a ukončí současný skript
eval — Vyhodnotí řetězec jako PHP kód
exit — Ukončí současný skript
get_browser — Určuje schopnosti uživatelova browseru
__halt_compiler — Halts the compiler execution
highlight_file — Zvýrazní syntaxi souboru
highlight_string — Zvýraznění syntaxe řetězce
ignore_user_abort — Nastavuje, jestli má ukončení spojení klientem přerušit vykonávání skriptu
pack — Sbalí data do binárního řetězce.
php_check_syntax — Check the PHP syntax of (and execute) the specified file
php_strip_whitespace — Return source with stripped comments and whitespace
show_source — Zvýrazní syntaxi souboru
sleep — Odloží provedení
sys_getloadavg — Gets system load average
time_nanosleep — Delay for a number of seconds and nanoseconds
time_sleep_until — Make the script sleep until the specified time
uniqid — Generatuje unikátní id
unpack — Rozbalí data z binárního řetězce
usleep — Odloží provedení v mikrosekundách
Předcházející | Nahoru | Další
ming_useswfversion | Domů | connection_aborted


connection_aborted

(PHP 4, PHP 5)

connection_aborted — Vrací TRUE, pokud se klient odpojil

Popis

int connection_aborted ( void )

Vrátí TRUE, pokud se klient odpojil. Úplné vysvětlení viz popis v Obsluha spojení v kapitole Vlastnosti.

Předcházející | Nahoru | Další
XC. Různé funkce | Domů | connection_status


connection_status

(PHP 4, PHP 5)

connection_status — Vrací bitové pole stavu spojení

Popis

int connection_status ( void )

Vrací bitové pole stavu spojení. Úplné vysvětlení viz popis v Obsluha spojení v kapitole Vlastnosti.

Předcházející | Nahoru | Další
connection_aborted | Domů | connection_timeout


connection_timeout

(PHP 4 <= 4.0.4)

connection_timeout — Return TRUE if script timed out

Popis

bool connection_timeout ( void )

Returns TRUE if script timed out. Úplné vysvětlení viz popis v Obsluha spojení v kapitole Vlastnosti.

Předcházející | Nahoru | Další
connection_status | Domů | constant


constant

(PHP 4 >= 4.0.4, PHP 5)

constant — Returns the value of a constant

Popis

mixed constant ( string $name )

Return the value of the constant indicated by name.

constant() is useful if you need to retrieve the value of a constant, but do not know its name. I.e. it is stored in a variable or returned by a function.

This function works also with class constants.

Seznam parametrů

name

The constant name.

Návratové hodnoty

Returns the value of the constant, or NULL if the constant is not defined.

Příklady

Příklad 1187. constant() example

<?php

define("MAXSIZE", 100);

echo MAXSIZE;
echo constant("MAXSIZE"); // same thing as the previous line

?>

Viz také

define()
defined()
The section on Constants

Předcházející | Nahoru | Další
connection_timeout | Domů | define


define

(PHP 4, PHP 5)

define — Definuje pojmenovanou konstantu.

Popis

bool define ( string $name, mixed $value [, bool $case_insensitive] )

Definuje pojmenovanou konstantu, která je podobná proměnné s výjimkou toho, že:

  • Konstanty nemají znak dolaru ('$') před jménem;
  • Konstanty jsou dostupné odkudkoliv bez ohledu na pravidla rozsahu platnosti proměnných;
  • Konstanty se nedají předefinovávat a rušit; a
  • Konstanty se mohou nabývat pouze skalárních hodnot.

Název konstanty je dán argumentem name; hodnota je dána argumentem value.

Dále je dostupný volitelní třetí argument case_insensitive. Pokud má hodnotu 1, konstanta bude definována case-insensitive. Výchozí chování je case-sensitive; tj. CONSTANT and Constant reprezentují různé hodnoty.

Příklad 1188. Definování konstant

<?php
define ("CONSTANT", "Hello world.");
echo CONSTANT; // výstup je "Hello world."
?>

define() vrací TRUE při úspěchu a FALSE pokud dojde k chybě.

Viz také defined() a sekci Konstanty.

Předcházející | Nahoru | Další
constant | Domů | defined


defined

(PHP 4, PHP 5)

defined — Zkontroluje, jestli existuje daná pojmenovaná konstanta

Popis

bool defined ( string $name )

Vrací TRUE, pokud byla definována pojmenovaná konstanta daná argumentem name, jinak FALSE.

Příklad 1189. Kontrola konstant

<?php
if (defined("CONSTANT")){ // název konstanty by měl být v uvozovkách
    echo CONSTANT; //
    }
?>

Viz také define() a sekci Konstanty.

Předcházející | Nahoru | Další
define | Domů | die


die

(PHP 4, PHP 5)

die — Vytiskne vzkaz a ukončí současný skript

Popis

void die ( string $message )

Tento jazykový konstrukt vytiskne vzkaz a ukončí parsování skriptu. Nemá návratovou hodnotu.

Příklad 1190. die example

<?php
$filename = '/path/to/data-file';
$file = fopen ($filename, 'r')
    or die("nepodařilo se otevřít soubor ($filename)");
?>

Viz také exit().

Předcházející | Nahoru | Další
defined | Domů | eval


eval

(PHP 4, PHP 5)

eval — Vyhodnotí řetězec jako PHP kód

Popis

mixed eval ( string $code_str )

eval() vyhodnotí řetězec předaný v code_str jako PHP kód. Kromě jiného se dá využít na ukládání kódu v textovém sloupci databáze pro pozdější vykonání.

Při používání eval() byste měli mít na paměti několik faktorů. Pamatujte si, že předávaný řetězec musí být platný PHP kód, včetně věcí jako ukončování výrazů středníkem, aby parser nezemřel na řádku po eval(), a řádné escapování v code_str.

Také pamatujte, ze hodnoty přiřazené proměnným v eval() těmto proměnným zůstanou i v hlavním skriptu.

Výraz return okamžitě ukončí vyhodnocování předaného řetězce. V PHP 4 můžete použít return k vrácení hodnoty, která se stane výsledkem eval() funkce, zatímco v PHP 3 byl eval() typu void nic nevracel.

Příklad 1191. eval() příklad - jednoduché spojení textů

<?php
$string = 'cup';
$name = 'coffee';
$str = 'This is a $string with my $name in it.<br>';
echo $str;
eval ("\$str = \"$str\";");
echo $str;
?>

Výše uvedený příklad ukáže:

This is a $string with my $name in it.
This is a cup with my coffee in it.

Předcházející | Nahoru | Další
die | Domů | exit


exit

(PHP 4, PHP 5)

exit — Ukončí současný skript

Popis

void exit ( [string $status] )
void exit ( int $status )

Tento jazykový konstrkut ukončí parsování skriptu. Nevrací žádnou hodnotu.

Viz také die().

Předcházející | Nahoru | Další
eval | Domů | get_browser


get_browser

(PHP 4, PHP 5)

get_browser — Určuje schopnosti uživatelova browseru

Popis

mixed get_browser ( [string $user_agent [, bool $return_array]] )

get_browser() se pokusí určit schopnosti uživatelova browseru. Toho je dosaženo vyhledáním informací o browseru v souboru browscap.ini. Standardne se použije $HTTP_USER_AGENT; nicméně, můžete to změnit (tj. vyhledat informace o jiném browseru) předáním volitelného argumentu user_agent.

Informace se vracejí jako objekt, který obsahuje různé datové elementy, které reprezentují například hlavní a vedlejší číslo verze a ID řetězec; TRUE/false hodnoty vlastností jako podpora rámců, JavaScript a cookies, atd.

Jakkoli browscap.ini obsahuje informace o mnoha browserech, aktuálnost databáze závisí na uživatelských updatech. Formát souboru je poměrně snadno pochopitelný.

Následující příklad ukazuje, jak by se daly vypsat všechny informace získané o uživatelově browseru.

Příklad 1192. get_browser() příklad

<?php
function list_array ($array) {
    while (list ($key, $value) = each ($array)) {
    $str .= "<b>$key:</b> $value<br>\n";
    }
    return $str;
}
echo "$HTTP_USER_AGENT<hr>\n";
$browser = get_browser();
echo list_array ((array) $browser);
?>

Výstup z výše uvedeného skriptu by vypadal asi takto:

Mozilla/4.5 [en] (X11; U; Linux 2.2.9 i586)<hr>
<b>browser_name_pattern:</b> Mozilla/4\.5.*<br>
<b>parent:</b> Netscape 4.0<br>
<b>platform:</b> Unknown<br>
<b>majorver:</b> 4<br>
<b>minorver:</b> 5<br>
<b>browser:</b> Netscape<br>
<b>version:</b> 4<br>
<b>frames:</b> 1<br>
<b>tables:</b> 1<br>
<b>cookies:</b> 1<br>
<b>backgroundsounds:</b> <br>
<b>vbscript:</b> <br>
<b>javascript:</b> 1<br>
<b>javaapplets:</b> 1<br>
<b>activexcontrols:</b> <br>
<b>beta:</b> <br>
<b>crawler:</b> <br>
<b>authenticodeupdate:</b> <br>
<b>msn:</b> <br>

Aby to fungovalo, browscap direktiva ve vašem konfiguračním souboru musí ukazovat na platné umístění browscap.ini souboru.

Pro další informace (včetně lokací na kterých můžete získat browscap.ini soubor) viz PHP FAQ na » http://www.php.net/manual/faq.php.

Předcházející | Nahoru | Další
exit | Domů | __halt_compiler


highlight_file

(PHP 4, PHP 5)

highlight_file — Zvýrazní syntaxi souboru

Popis

mixed highlight_file ( string $filename [, bool $return] )

Funkce highlight_file() vytiskne barevně zvýrazněnou syntaxi kódu obsaženého ve filename s použitím barev definovaných ve zvýrazňovači syntaxe zabudovaném v PHP. Vrací TRUE při úspěchu, jinak FALSE (PHP 4).

Příklad 1194. Tvorba URL zvyrazňující syntaxi

K vytvoření URL, která zvýrazní syntaxi jakéhokoliv skriptu, který jí předáte využijeme "ForceType" direktivu Apache k vytvoření hezkého vzorce URL, and pomocí funkce highlight_file() vypíšeme hezky vypadající výpis kódu.

Do svého httpd.conf přidejte následující:

<Location /source>
    ForceType application/x-httpd-php
</Location>

A potom vytvořte soubor pojmenovaný "source", a umístěte ho do svého web root adresáře.

<HTML>
<HEAD>
<TITLE>Zobrazení zdroje</TITLE>
</HEAD>
<BODY BGCOLOR="white">
<?php
    $script = getenv ("PATH_TRANSLATED");
    if(!$script) {
    echo "<BR><B>CHYBA: Je potřeba název skriptu!</B><BR>";
    } else {
    if (ereg("(\.php|\.inc)$",$script)) {
    echo "<H1>Zdroj souboru: $PATH_INFO</H1>\n<HR>\n";
    highlight_file($script);
    } else {
    echo "<H1>CHYBA: Povoleny jsou pouze soubory s příponou .php nebo .inc!</H1>";
    }
    }
    echo "<HR>Zpracováno: ".date("Y/M/d H:i:s",time());
?>
</BODY>
</HTML>

Potom můžete použít URL jako je ta níže k zobrazení obarvené verze skriptu umístěné v "/path/to/script.php" na vašem webu.

http://your.server.com/source/path/to/script.php

Viz také highlight_string(), show_source().

Předcházející | Nahoru | Další
__halt_compiler | Domů | highlight_string


highlight_string

(PHP 4, PHP 5)

highlight_string — Zvýraznění syntaxe řetězce

Popis

mixed highlight_string ( string $str [, bool $return] )

Funkce highlight_string() vytiskne barevně zvýrazněnou verzi str s použitím barev definovaných ve zvýrazňovači syntaxe zabudovaném v PHP. Vrací TRUE při úspěchu, jinak FALSE (PHP 4).

Viz také highlight_file(), show_source().

Předcházející | Nahoru | Další
highlight_file | Domů | ignore_user_abort


ignore_user_abort

(PHP 4, PHP 5)

ignore_user_abort — Nastavuje, jestli má ukončení spojení klientem přerušit vykonávání skriptu

Popis

int ignore_user_abort ( [bool $setting] )

Tato funkce nastavuje, jestli má odpojení klienta způsobit ukončení skriptu. Vrací předchozí nastavení, a při zavolání bez argumentu současné nastavení nemění, pouze ho vrací. Úplné vysvětlení viz popis v sekci Obsluha spojení v kapitole Vlastnosti

Předcházející | Nahoru | Další
highlight_string | Domů | pack


pack

(PHP 4, PHP 5)

pack — Sbalí data do binárního řetězce.

Popis

string pack ( string $format [, mixed $args [, mixed $...]] )

Sbalí předané argumenty do binárního řetězce podle argumentu format. Vrací binární řetězec obsahující předaná data.

Nápad na tuto funkci byl převzat z Perlu, a všechny formátovací kódy fungují stejně jako tam, nicméně, některé formátovací kódy chybí, jako například Perlovský formátovací kód "u". Formátovací řetězec sestává z formátovacích kódu následovaných volitelným opakovacím argumentem. Opakovací argument může být buď celočíselná hodnota, nebo * pro opakování do konce vstupních dat. U a, A, h, H počet opakování určuje, kolik znaků se vezme z jednoho datového argumentu, u @ je to absolutní pozice, kde se mají umístit další data, u všeho ostatního počet opakování určuje, kolik datových argumentů se spotřebuje a sbalí do výsledného binárního řetězce. V současnosti jsou implementovány

  • a řetězec doplněný NUL hodnotami
  • A řetězec doplněný SPACE hodnotami
  • h Hex řetězec, spodní slabika první
  • H Hex řetězec, horní slabika první
  • c signed char
  • C unsigned char
  • s signed short (vždy 16 bitů, machine byte order)
  • S unsigned short (vždy 16 bitů, machine byte order)
  • n unsigned short (vždy 16 bitů, big endian byte order)
  • v unsigned short (vždy 16 bitů, little endian byte order)
  • i signed integer (velikost a pořadí bytů závislá na systému)
  • I unsigned integer (velikost a pořadí bytů závislá na systému)
  • l signed long (vždy 32 bitů, machine byte order)
  • L unsigned long (vždy 32 bitů, machine byte order)
  • N unsigned long (vždy 32 bitů, big endian byte order)
  • V unsigned long (vždy 32 bitů, little endian byte order)
  • f float (velikost a reprezentace závislá na systému)
  • d double (velikost a reprezentace závislá na systému)
  • x NUL byte
  • X Back up one byte
  • @ NUL-fill to absolute position

Příklad 1195. pack() formátovací řetězec

$binarydata = pack ("nvc*", 0x1234, 0x5678, 65, 66);

Výsledný binární řetězec bude 6 bytů dlouhý, a bude obsahovat bytovou sekvenci 0x12, 0x34, 0x78, 0x56, 0x41, 0x42.

Všimněte si, že rozdíl mezi hodnotami se znaménkem a bez znaménka ovlivňuje pouze funkci unpack(), zatímco funkce pack() dává stejný výsledek pro formátovací kódy se znaménkem i bez znaménka.

Dále si všimněte, že PHP interně ukládá celočíselné hodnoty jako hodnoty se znaménkem o velikosti závislé na systému. Pokud zadáte hodnotu bez znaménka, která bude příliš velká, než aby se dala takto uložit, převede se na double, což často vytváří nežádoucí výsledky.

Předcházející | Nahoru | Další
ignore_user_abort | Domů | php_check_syntax


php_check_syntax

(PHP 5 <= 5.0.4)

php_check_syntax — Check the PHP syntax of (and execute) the specified file

Popis

bool php_check_syntax ( string $filename [, string &$error_message] )

Performs a syntax (lint) check on the specified filename testing for scripting errors.

This is similar to using php -l from the commandline except that this function will execute (but not output) the checked filename.

For example, if a function is defined in filename, this defined function will be available to the file that executed php_check_syntax(), but output from filename will be suppressed.

Poznámka: For technical reasons, this function is deprecated and removed from PHP. Instead, use php -l somefile.php from the commandline.

Seznam parametrů

filename

The name of the file being checked.

error_message

If the error_message parameter is used, it will contain the error message generated by the syntax check. error_message is passed by reference.

Návratové hodnoty

Returns TRUE if the lint check passed, and FALSE if the link check failed or if filename cannot be opened.

ChangeLog (záznam změn)

Verze | Popis
5.0.5 | This function was removed from PHP.
5.0.3 | Calling exit() after php_check_syntax() resulted in a Segfault.
5.0.1 | error_message is passed by reference.

Příklady

php -l somefile.php

Výše uvedený příklad vypíše něco jako:

PHP Parse error: unexpected T_STRING in /tmp/somefile.php on line 81

Viz také

include()
is_readable()

Předcházející | Nahoru | Další
pack | Domů | php_strip_whitespace


php_strip_whitespace

(PHP 5)

php_strip_whitespace — Return source with stripped comments and whitespace

Popis

string php_strip_whitespace ( string $filename )

Returns the PHP source code in filename with PHP comments and whitespace removed. This may be useful for determining the amount of actual code in your scripts compared with the amount of comments. This is similar to using php -w from the commandline.

Seznam parametrů

filename

Path to the PHP file.

Návratové hodnoty

The stripped source code will be returned on success, or an empty string on failure.

Poznámka: This function works as described as of PHP 5.0.1. Before this it would only return an empty string. For more information on this bug and its prior behavior, see bug report » #29606.

Příklady

Příklad 1196. php_strip_whitespace() example

<?php
// PHP comment here

/*
 * Another PHP comment
 */

echo        php_strip_whitespace(__FILE__);
// Newlines are considered whitespace, and are removed too:
do_nothing();
?>

Výše uvedený příklad vypíše:

<?php
 echo php_strip_whitespace(__FILE__); do_nothing(); ?>

Notice the PHP comments are gone, as are the whitespace and newline after the first echo statement.

Předcházející | Nahoru | Další
php_check_syntax | Domů | show_source


show_source

(PHP 4, PHP 5)

show_source — Zvýrazní syntaxi souboru

Popis

boolean show_source ( string $filename )

Funkce show_source() vytiskne barevně zvýrazněnou syntaxi kódu obsaženého ve filename s použitím barev definovaných ve zvýrazňovači syntaxe zabudovaném v PHP. Vrací TRUE při úspěchu, jinak FALSE (PHP 4).

Poznámka: Tato funkce je alias funkce highlight_file()

Viz také highlight_string(), highlight_file().

Předcházející | Nahoru | Další
php_strip_whitespace | Domů | sleep


sleep

(PHP 4, PHP 5)

sleep — Odloží provedení

Popis

int sleep ( int $seconds )

Funkce sleep odkládá provedení programu o počet sekund předaný v argumentu seconds.

Viz také usleep().

Předcházející | Nahoru | Další
show_source | Domů | sys_getloadavg


time_nanosleep

(PHP 5)

time_nanosleep — Delay for a number of seconds and nanoseconds

Popis

mixed time_nanosleep ( int $seconds, int $nanoseconds )

Delays program execution for the given number of seconds and nanoseconds.

Seznam parametrů

seconds

Must be a positive integer.

nanoseconds

Must be a positive integer less than 1 billion.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

If the delay was interrupted by a signal, an associative array will be returned with the components:

  • seconds - number of seconds remaining in the delay
  • nanoseconds - number of nanoseconds remaining in the delay

Příklady

Příklad 1198. time_nanosleep() example

<?php
// Careful! This won't work as expected if an array is returned
if (time_nanosleep(0, 500000000)) {
    echo "Slept for half a second.\n";
}

// This is better:
if (time_nanosleep(0, 500000000) === true) {
    echo "Slept for half a second.\n";
}

// And this is the best:
$nano = time_nanosleep(2, 100000);

if ($nano === true) {
    echo "Slept for 2 seconds, 100 milliseconds.\n";
} elseif ($nano === false) {
    echo "Sleeping failed.\n";
} elseif (is_array($nano)) {
    $seconds = $nano['seconds'];
    $nanoseconds = $nano['nanoseconds'];
    echo "Interrupted by a signal.\n";
    echo "Time remaining: $seconds seconds, $nanoseconds nanoseconds.";
}
?>

Poznámky

Poznámka: Tato funkce není implementována na platformách Windows.

Viz také

sleep(),
usleep(),
set_time_limit()

Předcházející | Nahoru | Další
sys_getloadavg | Domů | time_sleep_until


uniqid

(PHP 4, PHP 5)

uniqid — Generatuje unikátní id

Popis

string uniqid ( [string $prefix [, bool $more_entropy]] )

uniqid() vrací unikátní identifikátor založený na současném čase v mikrosekundách, opatřený prefixem. Prefix může být užitečný například pokud generujete identifikátory na několika serverech současně, které by mohly vygenerovat identifikátor ve stejnou mikrosekundu. Prefix může být až 114 znaků dlouhý.

Pokud je volitelný argument lcg TRUE, uniqid() přidá dodatečnou "kombinovanou LCG" entropii na konec své návratové hodnoty, což by mělo učinit výsledky ještě unikátnějšími.

Pokud je prefix prázdný, vrácený řetěec bude 13 znaků dlouhý. Pokud je lcg TRUE, bude dlouhý 23 znaků.

Poznámka: lcg argument je přístupný pouze v PHP 4 and PHP 3.0.13 a vyšších.

Pokud potřebujete unikátní identifikátor nebo symbol, a zamýšlíte předat tento symbol uživateli po síti (např. session cookies), doporučujeme použít něco jako

$token = md5 (uniqid ("")); // no random portion
$better_token = md5 (uniqid (rand())); // better, difficult to guess

Toto vytvoří 32znakový identifikátor (128bitové hexa číslo), které se extrémně težko předpovídá.

Předcházející | Nahoru | Další
time_sleep_until | Domů | unpack


unpack

(PHP 4, PHP 5)

unpack — Rozbalí data z binárního řetězce

Popis

array unpack ( string $format, string $data )

unpack() rozbalí data z binárního řetězce do pole podle format. Vrací pole obsahující rozbalené prvky binárního řetězce.

unpack() funguje trochu jinak než v Perlu, jelikož rozbalená data jsou uložena v asociativním poli. Toho dosáhnete tak, že vyjmenujete různé formátovací kódy a oddělíte je lomítkem /.

Příklad 1200. unpack() format string

$array = unpack ("c2chars/nint", $binarydata);

Výsledné pole obsahuej položky "chars1", "chars2" and "int".

Vysvětlení formátovacích kódů viz také: pack()

Všimněte si, že PHP interně ukládá celočíselné hodnoty se znaménkem. Pokud rozbalíte velkou celočíselnou hodnotu bez znaménka a ta má stejnou velikost jako hodnoty interně ukládané PHP, výsledkem bude negativní číslo, i když bylo zadáno rozbalování bez znaménka.

Předcházející | Nahoru | Další
uniqid | Domů | usleep


usleep

(PHP 4, PHP 5)

usleep — Odloží provedení v mikrosekundách

Popis

void usleep ( int $micro_seconds )

Funkce usleep() odloží provedení skriptu o daný počet micro_seconds.

Viz také sleep().

Poznámka: Tato funkce nefunguje na Windows systémech.

Předcházející | Nahoru | Další
unpack | Domů | XCI. mnoGoSearch Functions


mnoGoSearch Functions

Předcházející VI. Reference funkcí Další

XCI. mnoGoSearch Functions

Úvod

These functions allow you to access the mnoGoSearch (former UdmSearch) free search engine. mnoGoSearch is a full-featured search engine software for intranet and internet servers, distributed under the GNU license. mnoGoSearch has a number of unique features, which makes it appropriate for a wide range of applications from search within your site to a specialized search system such as cooking recipes or newspaper search, FTP archive search, news articles search, etc. It offers full-text indexing and searching for HTML, PDF, and text documents. mnoGoSearch consists of two parts. The first is an indexing mechanism (indexer). The purpose of the indexer is to walk through HTTP, FTP, NEWS servers or local files, recursively grabbing all the documents and storing meta-data about that documents in a SQL database in a smart and effective manner. After every document is referenced by its corresponding URL, meta-data is collected by the indexer for later use in a search process. The search is performed via Web interface. C, CGI, PHP and Perl search front ends are included.

More information about mnoGoSearch can be found at » http://www.mnogosearch.org/.

Poznámka: Toto rozšíření bylo přesunuto do repozitáře PECL a již nebude součástí balíku PHP.5.1.0.

Poznámka: Toto rozšíření není k dispozici na platformách Windows.

Požadavky

Download mnoGosearch from » http://www.mnogosearch.org/ and install it on your system. You need at least version 3.1.10 of mnoGoSearch installed to use these functions.

Instalace

In order to have these functions available, you must compile PHP with mnoGosearch support by using the --with-mnogosearch option. If you use this option without specifying the path to mnoGosearch, PHP will look for mnoGosearch under /usr/local/mnogosearch path by default. If you installed mnoGosearch at a different location you should specify it: --with-mnogosearch=DIR.

Informace o instalaci tohoto PECL rozšíření lze najít v kapitole manuálu nazvané Instalace rozšíření PECL. Další informace, jako nové verze, soubory ke stažení, zdrojové soubory, správcovské informace a CHANGELOG, lze najít zde: » http://pecl.php.net/package/mnogosearch.

Poznámka: PHP contains built-in MySQL access library, which can be used to access MySQL. It is known that mnoGoSearch is not compatible with this built-in library and can work only with generic MySQL libraries. Thus, if you use mnoGoSearch with MySQL, during PHP configuration you have to indicate the directory of your MySQL installation, that was used during mnoGoSearch configuration, i.e. for example: --with-mnogosearch --with-mysql=/usr.

Konfigurace běhu

Toto rozšíření nemá definováno žádné konfigurační direktivy.

Typy prostředků

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

UDM_FIELD_URLID (integer)
UDM_FIELD_URL (integer)
UDM_FIELD_CONTENT (integer)
UDM_FIELD_TITLE (integer)
UDM_FIELD_KEYWORDS (integer)
UDM_FIELD_DESC (integer)
UDM_FIELD_DESCRIPTION (integer)
UDM_FIELD_TEXT (integer)
UDM_FIELD_SIZE (integer)
UDM_FIELD_RATING (integer)
UDM_FIELD_SCORE (integer)
UDM_FIELD_MODIFIED (integer)
UDM_FIELD_ORDER (integer)
UDM_FIELD_CRC (integer)
UDM_FIELD_CATEGORY (integer)
UDM_FIELD_LANG (integer)
UDM_FIELD_CHARSET (integer)
UDM_PARAM_PAGE_SIZE (integer)
UDM_PARAM_PAGE_NUM (integer)
UDM_PARAM_SEARCH_MODE (integer)
UDM_PARAM_CACHE_MODE (integer)
UDM_PARAM_TRACK_MODE (integer)
UDM_PARAM_PHRASE_MODE (integer)
UDM_PARAM_CHARSET (integer)
UDM_PARAM_LOCAL_CHARSET (integer)
UDM_PARAM_BROWSER_CHARSET (integer)
UDM_PARAM_STOPTABLE (integer)
UDM_PARAM_STOP_TABLE (integer)
UDM_PARAM_STOPFILE (integer)
UDM_PARAM_STOP_FILE (integer)
UDM_PARAM_WEIGHT_FACTOR (integer)
UDM_PARAM_WORD_MATCH (integer)
UDM_PARAM_MAX_WORD_LEN (integer)
UDM_PARAM_MAX_WORDLEN (integer)
UDM_PARAM_MIN_WORD_LEN (integer)
UDM_PARAM_MIN_WORDLEN (integer)
UDM_PARAM_ISPELL_PREFIXES (integer)
UDM_PARAM_ISPELL_PREFIX (integer)
UDM_PARAM_PREFIXES (integer)
UDM_PARAM_PREFIX (integer)
UDM_PARAM_CROSS_WORDS (integer)
UDM_PARAM_CROSSWORDS (integer)
UDM_PARAM_VARDIR (integer)
UDM_PARAM_DATADIR (integer)
UDM_PARAM_HLBEG (integer)
UDM_PARAM_HLEND (integer)
UDM_PARAM_SYNONYM (integer)
UDM_PARAM_SEARCHD (integer)
UDM_PARAM_QSTRING (integer)
UDM_PARAM_REMOTE_ADDR (integer)
UDM_LIMIT_CAT (integer)
UDM_LIMIT_URL (integer)
UDM_LIMIT_TAG (integer)
UDM_LIMIT_LANG (integer)
UDM_LIMIT_DATE (integer)
UDM_PARAM_FOUND (integer)
UDM_PARAM_NUM_ROWS (integer)
UDM_PARAM_WORDINFO (integer)
UDM_PARAM_WORD_INFO (integer)
UDM_PARAM_SEARCHTIME (integer)
UDM_PARAM_SEARCH_TIME (integer)
UDM_PARAM_FIRST_DOC (integer)
UDM_PARAM_LAST_DOC (integer)
UDM_MODE_ALL (integer)
UDM_MODE_ANY (integer)
UDM_MODE_BOOL (integer)
UDM_MODE_PHRASE (integer)
UDM_CACHE_ENABLED (integer)
UDM_CACHE_DISABLED (integer)
UDM_TRACK_ENABLED (integer)
UDM_TRACK_DISABLED (integer)
UDM_PHRASE_ENABLED (integer)
UDM_PHRASE_DISABLED (integer)
UDM_CROSS_WORDS_ENABLED (integer)
UDM_CROSSWORDS_ENABLED (integer)
UDM_CROSS_WORDS_DISABLED (integer)
UDM_CROSSWORDS_DISABLED (integer)
UDM_PREFIXES_ENABLED (integer)
UDM_PREFIX_ENABLED (integer)
UDM_ISPELL_PREFIXES_ENABLED (integer)
UDM_ISPELL_PREFIX_ENABLED (integer)
UDM_PREFIXES_DISABLED (integer)
UDM_PREFIX_DISABLED (integer)
UDM_ISPELL_PREFIXES_DISABLED (integer)
UDM_ISPELL_PREFIX_DISABLED (integer)
UDM_ISPELL_TYPE_AFFIX (integer)
UDM_ISPELL_TYPE_SPELL (integer)
UDM_ISPELL_TYPE_DB (integer)
UDM_ISPELL_TYPE_SERVER (integer)
UDM_MATCH_WORD (integer)
UDM_MATCH_BEGIN (integer)
UDM_MATCH_SUBSTR (integer)
UDM_MATCH_END (integer)

Obsah

udm_add_search_limit — Add various search limits
udm_alloc_agent_array — Allocate mnoGoSearch session
udm_alloc_agent — Allocate mnoGoSearch session
udm_api_version — Get mnoGoSearch API version
udm_cat_list — Get all the categories on the same level with the current one
udm_cat_path — Get the path to the current category
udm_check_charset — Check if the given charset is known to mnogosearch
udm_check_stored — Check connection to stored
udm_clear_search_limits — Clear all mnoGoSearch search restrictions
udm_close_stored — Close connection to stored
udm_crc32 — Return CRC32 checksum of given string
udm_errno — Get mnoGoSearch error number
udm_error — Get mnoGoSearch error message
udm_find — Perform search
udm_free_agent — Free mnoGoSearch session
udm_free_ispell_data — Free memory allocated for ispell data
udm_free_res — Free mnoGoSearch result
udm_get_doc_count — Get total number of documents in database
udm_get_res_field — Fetch a result field
udm_get_res_param — Get mnoGoSearch result parameters
udm_hash32 — Return Hash32 checksum of gived string
udm_load_ispell_data — Load ispell data
udm_open_stored — Open connection to stored
udm_set_agent_param — Set mnoGoSearch agent session parameters
Předcházející | Nahoru | Další
usleep | Domů | udm_add_search_limit


udm_add_search_limit

(PHP 4 >= 4.0.5, PHP 5 <= 5.0.5, PECL mnogosearch:1.0.0)

udm_add_search_limit — Add various search limits

Popis

bool udm_add_search_limit ( resource $agent, int $var, string $val )

udm_add_search_limit() adds search restrictions.

Seznam parametrů

agent

A link to Agent, received after call to udm_alloc_agent().

var

Defines the parameter, indicating limits. Possible var values:

  • UDM_LIMIT_URL - defines document URL limitations to limit the search through subsection of the database. It supports SQL % and _ LIKE wildcards, where % matches any number of characters, even zero characters, and _ matches exactly one character. E.g. http://www.example.___/catalog may stand for http://www.example.com/catalog and http://www.example.net/catalog.
  • UDM_LIMIT_TAG - defines site TAG limitations. In indexer-conf you can assign specific TAGs to various sites and parts of a site. Tags in mnoGoSearch 3.1.x are lines, that may contain metasymbols % and _. Metasymbols allow searching among groups of tags. E.g. there are links with tags ABCD and ABCE, and search restriction is by ABC_ - the search will be made among both of the tags.
  • UDM_LIMIT_LANG - defines document language limitations.
  • UDM_LIMIT_CAT - defines document category limitations. Categories are similar to tag feature, but nested. So you can have one category inside another and so on. You have to use two characters for each level. Use a hex number going from 0-F or a 36 base number going from 0-Z. Therefore a top-level category like 'Auto' would be 01. If it has a subcategory like 'Ford', then it would be 01 (the parent category) and then 'Ford' which we will give 01. Put those together and you get 0101. If 'Auto' had another subcategory named 'VW', then it's id would be 01 because it belongs to the 'Ford' category and then 02 because it's the next category. So it's id would be 0102. If VW had a sub category called 'Engine' then it's id would start at 01 again and it would get the 'VW' id 02 and 'Auto' id of 01, making it 010201. If you want to search for sites under that category then you pass it cat=010201 in the URL.

  • UDM_LIMIT_DATE - defines limitation by date the document was modified.

    Format of parameter value: a string with first character < or >, then with no space - date in unixtime format, for example:

    Příklad 1201.

    <?php
    udm_add_search_limit    ($udm, UDM_LIMIT_DATE, "&lt;908012006");
    ?>

    If > character is used, then the search will be restricted to those documents having a modification date greater than entered, if <, then smaller.

val

Defines the value of the current parameter.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
XCI. mnoGoSearch Functions | Domů | udm_alloc_agent_array


udm_alloc_agent_array

(PHP 4 >= 4.3.3, PHP 5 <= 5.0.5, PECL mnogosearch:1.0.0)

udm_alloc_agent_array — Allocate mnoGoSearch session

Popis

resource udm_alloc_agent_array ( array $databases )

udm_alloc_agent_array() will create an agent with multiple database connections.

Seznam parametrů

databases

The array databases must contain one database URL per element, analog to the first parameter of udm_alloc_agent().

Návratové hodnoty

Returns a resource link identifier on success, or FALSE on failure.

Viz také

udm_alloc_agent()

Předcházející | Nahoru | Další
udm_add_search_limit | Domů | udm_alloc_agent


udm_alloc_agent

(PHP 4 >= 4.0.5, PHP 5 <= 5.0.5, PECL mnogosearch:1.0.0)

udm_alloc_agent — Allocate mnoGoSearch session

Popis

resource udm_alloc_agent ( string $dbaddr [, string $dbmode] )

Allocate a mnoGoSearch session.

Seznam parametrů

dbaddr

dbaddr - URL-style database description, with options (type, host, database name, port, user and password) to connect to SQL database. Do not matter for built-in text files support. Format for dbaddr: DBType:[//[DBUser[:DBPass]@]DBHost[:DBPort]]/DBName/. Currently supported DBType values are: mysql, pgsql, msql, solid, mssql, oracle, and ibase. Actually, it does not matter for native libraries support, but ODBC users should specify one of the supported values. If your database type is not supported, you may use unknown instead.

dbmode

dbmode - You may select the SQL database mode of words storage. Possible values of dbmode are: single, multi, crc, or crc-multi. When single is specified, all words are stored in the same table. If multi is selected, words will be located in different tables depending of their lengths. "multi" mode is usually faster, but requires more tables in the database. If "crc" mode is selected, mnoGoSearch will store 32 bit integer word IDs calculated by CRC32 algorithm instead of words. This mode requires less disk space and it is faster comparing with "single" and "multi" modes. crc-multi uses the same storage structure with the "crc" mode, but also stores words in different tables depending on words lengths like in "multi" mode.

Poznámka: dbaddr and dbmode must match those used during indexing.

Návratové hodnoty

Returns a mnogosearch agent identifier on success, FALSE on failure. This function creates a session with database parameters.

Poznámky

Poznámka: In fact this function does not open a connection to the database and thus does not check the entered login and password. Establishing a connection to the database and login/password verification is done by udm_find().

Předcházející | Nahoru | Další
udm_alloc_agent_array | Domů | udm_api_version


udm_api_version

(PHP 4 >= 4.0.5, PHP 5 <= 5.0.5, PECL mnogosearch:1.0.0)

udm_api_version — Get mnoGoSearch API version

Popis

int udm_api_version ( void )

Gets the mnoGoSearch API version.

This function allows the user to identify which API functions are available, e.g. udm_get_doc_count() function is only available in mnoGoSearch 3.1.11 or later.

Návratové hodnoty

udm_api_version() returns the mnoGoSearch API version number. E.g. if mnoGoSearch 3.1.10 API is used, this function will return 30110.

Příklady

Příklad 1202. udm_api_version() example

<?php
if (udm_api_version() >= 30111) {
    echo  "Total number of URLs in database: " . udm_get_doc_count($udm) . "<br />\n";
}
?>

Předcházející | Nahoru | Další
udm_alloc_agent | Domů | udm_cat_list


udm_cat_list

(PHP 4 >= 4.0.6, PHP 5 <= 5.0.5, PECL mnogosearch:1.0.0)

udm_cat_list — Get all the categories on the same level with the current one

Popis

array udm_cat_list ( resource $agent, string $category )

Gets all the categories on the same level with the current one.

The function can be useful for developing categories tree browser.

Seznam parametrů

agent

A link to Agent, received after call to udm_alloc_agent().

category

Návratové hodnoty

Returns an array listing all categories of the same level as the current category in the categories tree.

The returned array consists of pairs. Elements with even index numbers contain the category paths, odd elements contain the corresponding category names.

  $array[0] will contain '020300'
  $array[1] will contain 'Audi'
  $array[2] will contain '020301'
  $array[3] will contain 'BMW'
  $array[4] will contain '020302'
  $array[5] will contain 'Opel'
  ...
 etc.

Příklady

Following is an example of displaying links of the current level in format:

  Audi
  BMW
  Opel
  ...

Příklad 1203. udm_cat_list()example

<?php
 $cat_list_arr = udm_cat_list($udm_agent, $cat);
 $cat_list = '';
 for ($i=0; $i<count($cat_list_arr); $i+=2) {
    $path = $cat_list_arr[$i];
    $name = $cat_list_arr[$i+1];
    $cat_list .= "<a href=\"$_SERVER[PHP_SELF]?cat=$path\">$name</a><br />";
 }
?>

Viz také

udm_cat_path()

Předcházející | Nahoru | Další
udm_api_version | Domů | udm_cat_path


udm_cat_path

(PHP 4 >= 4.0.6, PHP 5 <= 5.0.5, PECL mnogosearch:1.0.0)

udm_cat_path — Get the path to the current category

Popis

array udm_cat_path ( resource $agent, string $category )

Returns an array describing the path in the categories tree from the tree root to the current one, specified by category.

Seznam parametrů

agent

A link to Agent, received after call to udm_alloc_agent().

category

Návratové hodnoty

The returned array consists of pairs. Elements with even index numbers contain the category paths, odd elements contain the corresponding category names.

For example, the call $array=udm_cat_path($agent, '02031D'); may return the following array:

 $array[0] will contain ''
 $array[1] will contain 'Root'
 $array[2] will contain '02'
 $array[3] will contain 'Sport'
 $array[4] will contain '0203'
 $array[5] will contain 'Auto'
 $array[4] will contain '02031D'
 $array[5] will contain 'Ferrari'

Příklady

Příklad 1204. Specifying path to the current category in the following format: '> Root > Sport > Auto > Ferrari'

<?php
  $cat_path_arr = udm_cat_path($udm_agent, $cat);
  $cat_path = '';
  for ($i=0; $i<count($cat_path_arr); $i+=2) {
    $path = $cat_path_arr[$i];
    $name = $cat_path_arr[$i+1];
    $cat_path .= " > <a href=\"$_SERVER[PHP_SELF]?cat=$path\">$name</a> ";
  }
?>

Viz také

udm_cat_list()

Předcházející | Nahoru | Další
udm_cat_list | Domů | udm_check_charset


udm_check_charset

(PHP 4 >= 4.2.0, PHP 5 <= 5.0.5, PECL mnogosearch:1.0.0)

udm_check_charset — Check if the given charset is known to mnogosearch

Popis

bool udm_check_charset ( resource $agent, string $charset )

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
udm_cat_path | Domů | udm_check_stored


udm_check_stored

(PHP 4 >= 4.2.0)

udm_check_stored — Check connection to stored

Popis

int udm_check_stored ( resource $agent, int $link, string $doc_id )

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
udm_check_charset | Domů | udm_clear_search_limits


udm_clear_search_limits

(PHP 4 >= 4.0.5, PHP 5 <= 5.0.5, PECL mnogosearch:1.0.0)

udm_clear_search_limits — Clear all mnoGoSearch search restrictions

Popis

bool udm_clear_search_limits ( resource $agent )

udm_clear_search_limits() resets defined search limitations.

Seznam parametrů

agent

A link to Agent, received after call to udm_alloc_agent().

Návratové hodnoty

Returns TRUE.

Viz také

udm_add_search_limit()

Předcházející | Nahoru | Další
udm_check_stored | Domů | udm_close_stored


udm_close_stored

(PHP 4 >= 4.2.0)

udm_close_stored — Close connection to stored

Popis

int udm_close_stored ( resource $agent, int $link )

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
udm_clear_search_limits | Domů | udm_crc32


udm_crc32

(PHP 4 >= 4.2.0, PHP 5 <= 5.0.5, PECL mnogosearch:1.0.0)

udm_crc32 — Return CRC32 checksum of given string

Popis

int udm_crc32 ( resource $agent, string $str )

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
udm_close_stored | Domů | udm_errno


udm_errno

(PHP 4 >= 4.0.5, PHP 5 <= 5.0.5, PECL mnogosearch:1.0.0)

udm_errno — Get mnoGoSearch error number

Popis

int udm_errno ( resource $agent )

Receiving numeric agent error code.

Seznam parametrů

agent

A link to Agent, received after call to udm_alloc_agent().

Návratové hodnoty

Returns the mnoGoSearch error number, zero if no error.

Předcházející | Nahoru | Další
udm_crc32 | Domů | udm_error


udm_error

(PHP 4 >= 4.0.5, PHP 5 <= 5.0.5, PECL mnogosearch:1.0.0)

udm_error — Get mnoGoSearch error message

Popis

string udm_error ( resource $agent )

Gets the agent error message.

Seznam parametrů

agent

A link to Agent, received after call to udm_alloc_agent().

Návratové hodnoty

udm_error() returns mnoGoSearch error message, empty string if no error.

Předcházející | Nahoru | Další
udm_errno | Domů | udm_find


udm_find

(PHP 4 >= 4.0.5, PHP 5 <= 5.0.5, PECL mnogosearch:1.0.0)

udm_find — Perform search

Popis

resource udm_find ( resource $agent, string $query )

Performs a search.

The search itself. The first argument - session, the next one - query itself. To find something just type words you want to find and press SUBMIT button. For example, "mysql odbc". You should not use quotes " in query, they are written here only to divide a query from other text. mnoGoSearch will find all documents that contain word "mysql" and/or word "odbc". Best documents having bigger weights will be displayed first. If you use search mode ALL, search will return documents that contain both (or more) words you entered. In case you use mode ANY, the search will return list of documents that contain any of the words you entered. If you want more advanced results you may use query language. You should select "bool" match mode in the search from.

Seznam parametrů

agent

A link to Agent, received after call to udm_alloc_agent().

query

mnoGoSearch understands the following boolean operators:

& - logical AND. For example, "mysql & odbc". mnoGoSearch will find any URLs that contain both "mysql" and "odbc".

| - logical OR. For example "mysql|odbc". mnoGoSearch will find any URLs, that contain word "mysql" or word "odbc".

~ - logical NOT. For example "mysql & ~odbc". mnoGoSearch will find URLs that contain word "mysql" and do not contain word "odbc" at the same time. Note that ~ just excludes given word from results. Query "~odbc" will find nothing!

() - group command to compose more complex queries. For example "(mysql | msql) & ~postgres". Query language is simple and powerful at the same time. Just consider query as usual boolean expression.

Návratové hodnoty

Returns a result link identifier on success, or FALSE on failure.

Předcházející | Nahoru | Další
udm_error | Domů | udm_free_agent


udm_free_agent

(PHP 4 >= 4.0.5, PHP 5 <= 5.0.5, PECL mnogosearch:1.0.0)

udm_free_agent — Free mnoGoSearch session

Popis

int udm_free_agent ( resource $agent )

Freeing up memory allocated for agent session.

Seznam parametrů

agent

A link to Agent, received after call to udm_alloc_agent().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
udm_find | Domů | udm_free_ispell_data


udm_free_ispell_data

(PHP 4 >= 4.0.5, PHP 5 <= 5.0.5, PECL mnogosearch:1.0.0)

udm_free_ispell_data — Free memory allocated for ispell data

Popis

bool udm_free_ispell_data ( int $agent )

Frees the memory allocated for ispell data.

Seznam parametrů

agent

A link to Agent, received after call to udm_alloc_agent().

Návratové hodnoty

udm_free_ispell_data() always returns TRUE.

Poznámky

Poznámka: This function is supported beginning from version 3.1.12 of mnoGoSearch and it does not do anything in previous versions.

Předcházející | Nahoru | Další
udm_free_agent | Domů | udm_free_res


udm_free_res

(PHP 4 >= 4.0.5, PHP 5 <= 5.0.5, PECL mnogosearch:1.0.0)

udm_free_res — Free mnoGoSearch result

Popis

bool udm_free_res ( resource $res )

Freeing up memory allocated for results.

Seznam parametrů

res

A link to a result identifier, received after call to udm_find().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
udm_free_ispell_data | Domů | udm_get_doc_count


udm_get_doc_count

(PHP 4 >= 4.0.5, PHP 5 <= 5.0.5, PECL mnogosearch:1.0.0)

udm_get_doc_count — Get total number of documents in database

Popis

int udm_get_doc_count ( resource $agent )

udm_get_doc_count() returns the number of documents in the database.

Seznam parametrů

agent

A link to Agent, received after call to udm_alloc_agent().

Návratové hodnoty

Returns the number of document.

Poznámky

Poznámka: This function is supported only in mnoGoSearch 3.1.11 or later.

Předcházející | Nahoru | Další
udm_free_res | Domů | udm_get_res_field


udm_get_res_field

(PHP 4 >= 4.0.5, PHP 5 <= 5.0.5, PECL mnogosearch:1.0.0)

udm_get_res_field — Fetch a result field

Popis

string udm_get_res_field ( resource $res, int $row, int $field )

Fetch a mnoGoSearch result field.

Seznam parametrů

res

res - a link to result identifier, received after call to udm_find().

row

row - the number of the link on the current page. May have values from 0 to UDM_PARAM_NUM_ROWS-1.

field

field - field identifier, may have the following values:

  • UDM_FIELD_URL - document URL field
  • UDM_FIELD_CONTENT - document Content-type field (for example, text/html).
  • UDM_FIELD_CATEGORY - document category field. Use udm_cat_path() to get full path to current category from the categories tree root. (This parameter is available only in PHP 4.0.6 or later).
  • UDM_FIELD_TITLE - document title field.
  • UDM_FIELD_KEYWORDS - document keywords field (from META KEYWORDS tag).
  • UDM_FIELD_DESC - document description field (from META DESCRIPTION tag).
  • UDM_FIELD_TEXT - document body text (the first couple of lines to give an idea of what the document is about).
  • UDM_FIELD_SIZE - document size.
  • UDM_FIELD_URLID - unique URL ID of the link.
  • UDM_FIELD_RATING - page rating (as calculated by mnoGoSearch).
  • UDM_FIELD_MODIFIED - last-modified field in unixtime format.
  • UDM_FIELD_ORDER - the number of the current document in set of found documents.
  • UDM_FIELD_CRC - document CRC.

Návratové hodnoty

udm_get_res_field() returns result field value on success, FALSE on error.

Předcházející | Nahoru | Další
udm_get_doc_count | Domů | udm_get_res_param


udm_get_res_param

(PHP 4 >= 4.0.5, PHP 5 <= 5.0.5, PECL mnogosearch:1.0.0)

udm_get_res_param — Get mnoGoSearch result parameters

Popis

string udm_get_res_param ( resource $res, int $param )

Gets the mnoGoSearch result parameters.

Seznam parametrů

res

res - a link to result identifier, received after call to udm_find().

param

param - parameter identifier, may have the following values:

  • UDM_PARAM_NUM_ROWS - number of received found links on the current page. It is equal to UDM_PARAM_PAGE_SIZE for all search pages, on the last page - the rest of links.
  • UDM_PARAM_FOUND - total number of results matching the query.
  • UDM_PARAM_WORDINFO - information on the words found. E.g. search for "a good book" will return "a: stopword, good:5637, book: 120"
  • UDM_PARAM_SEARCHTIME - search time in seconds.
  • UDM_PARAM_FIRST_DOC - the number of the first document displayed on current page.
  • UDM_PARAM_LAST_DOC - the number of the last document displayed on current page.

Návratové hodnoty

udm_get_res_param() returns result parameter value on success, FALSE on error.

Předcházející | Nahoru | Další
udm_get_res_field | Domů | udm_hash32


udm_hash32

(PHP 4 >= 4.3.3, PHP 5 <= 5.0.5, PECL mnogosearch:1.0.0)

udm_hash32 — Return Hash32 checksum of gived string

Popis

int udm_hash32 ( resource $agent, string $str )

udm_hash32() will take a string str and return a quite unique 32-bit hash number from it.

Seznam parametrů

agent

A link to Agent, received after call to udm_alloc_agent().

str

The input string.

Návratové hodnoty

Returns a 32-bit hash number.

Viz také

udm_alloc_agent()

Předcházející | Nahoru | Další
udm_get_res_param | Domů | udm_load_ispell_data


udm_load_ispell_data

(PHP 4 >= 4.0.5, PHP 5 <= 5.0.5, PECL mnogosearch:1.0.0)

udm_load_ispell_data — Load ispell data

Popis

bool udm_load_ispell_data ( resource $agent, int $var, string $val1, string $val2, int $flag )

udm_load_ispell_data() loads ispell data.

After using this function to free memory allocated for ispell data, please use udm_free_ispell_data(), even if you use UDM_ISPELL_TYPE_SERVER mode.

Seznam parametrů

agent

A link to Agent, received after call to udm_alloc_agent().

var

Indicates the source for ispell data. May have the following values:

  • UDM_ISPELL_TYPE_DB - indicates that ispell data should be loaded from SQL. In this case, parameters val1 and val2 are ignored and should be left blank. flag should be equal to 1.

    Poznámka: flag indicates that after loading ispell data from defined source it should be sorted (it is necessary for correct functioning of ispell). In case of loading ispell data from files there may be several calls to udm_load_ispell_data(), and there is no sense to sort data after every call, but only after the last one. Since in db mode all the data is loaded by one call, this parameter should have the value 1. In this mode in case of error, e.g. if ispell tables are absent, the function will return FALSE and code and error message will be accessible through udm_error() and udm_errno().

  • UDM_ISPELL_TYPE_AFFIX - indicates that ispell data should be loaded from file and initiates loading affixes file. In this case val1 defines double letter language code for which affixes are loaded, and val2 - file path. Please note, that if a relative path entered, the module looks for the file not in UDM_CONF_DIR, but in relation to current path, i.e. to the path where the script is executed. In case of error in this mode, e.g. if file is absent, the function will return FALSE, and an error message will be displayed. Error message text cannot be accessed through udm_error() and udm_errno(), since those functions can only return messages associated with SQL. Please, see flag parameter description in UDM_ISPELL_TYPE_DB.

    Příklad 1205. udm_load_ispell_data() example

    <?php
    if ((! udm_load_ispell_data($udm, UDM_ISPELL_TYPE_AFFIX, 'en', '/opt/ispell/en.aff', 0)) ||
        (!     udm_load_ispell_data($udm, UDM_ISPELL_TYPE_AFFIX, 'ru', '/opt/ispell/ru.aff', 0)) ||
        (!     udm_load_ispell_data($udm, UDM_ISPELL_TYPE_SPELL, 'en', '/opt/ispell/en.dict', 0)) ||
        (!     udm_load_ispell_data($udm, UDM_ISPELL_TYPE_SPELL, 'ru', '/opt/ispell/ru.dict', 1))) {
        exit;
    }
    ?>

    Poznámka: flag is equal to 1 only in the last call.

  • UDM_ISPELL_TYPE_SPELL - indicates that ispell data should be loaded from file and initiates loading of ispell dictionary file. In this case val1 defines double letter language code for which affixes are loaded, and val2 - file path. Please note, that if a relative path entered, the module looks for the file not in UDM_CONF_DIR, but in relation to current path, i.e. to the path where the script is executed. In case of error in this mode, e.g. if file is absent, the function will return FALSE, and an error message will be displayed. Error message text cannot be accessed through udm_error() and udm_errno(), since those functions can only return messages associated with SQL. Please, see flag parameter description in UDM_ISPELL_TYPE_DB.

    <?php
    if ((! udm_load_ispell_data($udm, UDM_ISPELL_TYPE_AFFIX, 'en', '/opt/ispell/en.aff', 0)) ||
       (!     udm_load_ispell_data($udm, UDM_ISPELL_TYPE_AFFIX, 'ru', '/opt/ispell/ru.aff', 0)) ||
       (!     udm_load_ispell_data($udm, UDM_ISPELL_TYPE_SPELL, 'en', '/opt/ispell/en.dict', 0)) ||
       (!     udm_load_ispell_data($udm, UDM_ISPELL_TYPE_SPELL, 'ru', '/opt/ispell/ru.dict', 1))) {
     exit;
     }
    ?>

    Poznámka: flag is equal to 1 only in the last call.

  • UDM_ISPELL_TYPE_SERVER - enables spell server support. val1 parameter indicates address of the host running spell server. val2 ` is not used yet, but in future releases it is going to indicate number of port used by spell server. flag parameter in this case is not needed since ispell data is stored on spellserver already sorted.

    Spelld server reads spell-data from a separate configuration file (/usr/local/mnogosearch/etc/spelld.conf by default), sorts it and stores in memory. With clients server communicates in two ways: to indexer all the data is transferred (so that indexer starts faster), from search.cgi server receives word to normalize and then passes over to client (search.cgi) list of normalized word forms. This allows fastest, compared to db and text modes processing of search queries (by omitting loading and sorting all the spell data).

    udm_load_ispell_data() function in UDM_ISPELL_TYPE_SERVER mode does not actually load ispell data, but only defines server address. In fact, server is automatically used by udm_find() function when performing search. In case of errors, e.g. if spellserver is not running or invalid host indicated, there are no messages returned and ispell conversion does not work.

    Poznámka: This function is available in mnoGoSearch 3.1.12 or later.

    Example:

    <?php
    if (!udm_load_ispell_data($udm, UDM_ISPELL_TYPE_SERVER, '', '', 1)) {
        echo     "Error loading ispell data from server<br />\n";
        exit;
    }
    ?>

The fastest mode is UDM_ISPELL_TYPE_SERVER. UDM_ISPELL_TYPE_TEXT is slower and UDM_ISPELL_TYPE_DB is the slowest. The above pattern is TRUE for mnoGoSearch 3.1.10 - 3.1.11. It is planned to speed up DB mode in future versions and it is going to be faster than TEXT mode.

val1

val2

flag

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1206. udm_load_ispell_data() example

<?php
if (! udm_load_ispell_data($udm, UDM_ISPELL_TYPE_DB, '', '', 1)) {
  printf("Error #%d: '%s'\n", udm_errno($udm), udm_error($udm));
  exit;
}
?>

Předcházející | Nahoru | Další
udm_hash32 | Domů | udm_open_stored


udm_open_stored

(PHP 4 >= 4.2.0)

udm_open_stored — Open connection to stored

Popis

int udm_open_stored ( resource $agent, string $storedaddr )

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
udm_load_ispell_data | Domů | udm_set_agent_param


udm_set_agent_param

(PHP 4 >= 4.0.5, PHP 5 <= 5.0.5, PECL mnogosearch:1.0.0)

udm_set_agent_param — Set mnoGoSearch agent session parameters

Popis

bool udm_set_agent_param ( resource $agent, int $var, string $val )

Defines mnoGoSearch session parameters.

Seznam parametrů

agent

A link to Agent, received after call to udm_alloc_agent().

var

The following parameters and their values are available:

  • UDM_PARAM_PAGE_NUM - used to choose search results page number (results are returned by pages beginning from 0, with UDM_PARAM_PAGE_SIZE results per page).
  • UDM_PARAM_PAGE_SIZE - number of search results displayed on one page.
  • UDM_PARAM_SEARCH_MODE - search mode. The following values available: UDM_MODE_ALL - search for all words; UDM_MODE_ANY - search for any word; UDM_MODE_PHRASE - phrase search; UDM_MODE_BOOL - boolean search. See udm_find() for details on boolean search.
  • UDM_PARAM_CACHE_MODE - turns on or off search result cache mode. When enabled, the search engine will store search results to disk. In case a similar search is performed later, the engine will take results from the cache for faster performance. Available values: UDM_CACHE_ENABLED, UDM_CACHE_DISABLED.
  • UDM_PARAM_TRACK_MODE - turns on or off trackquery mode. Since version 3.1.2 mnoGoSearch has a query tracking support. Note that tracking is implemented in SQL version only and not available in built-in database. To use tracking, you have to create tables for tracking support. For MySQL, use create/mysql/track.txt. When doing a search, front-end uses those tables to store query words, a number of found documents and current Unix timestamp in seconds. Available values: UDM_TRACK_ENABLED, UDM_TRACK_DISABLED.

  • UDM_PARAM_PHRASE_MODE - defines whether index database using phrases ("phrase" parameter in indexer.conf). Possible values: UDM_PHRASE_ENABLED and UDM_PHRASE_DISABLED. Please note, that if phrase search is enabled (UDM_PHRASE_ENABLED), it is still possible to do search in any mode (ANY, ALL, BOOL or PHRASE). In 3.1.10 version of mnoGoSearch phrase search is supported only in sql and built-in database modes, while beginning with 3.1.11 phrases are supported in cachemode as well.

    Examples of phrase search:

    "Arizona desert" - This query returns all indexed documents that contain "Arizona desert" as a phrase. Notice that you need to put double quotes around the phrase

  • UDM_PARAM_CHARSET - defines local charset. Available values: set of charsets supported by mnoGoSearch, e.g. koi8-r, cp1251, ...
  • UDM_PARAM_STOPFILE - Defines name and path to stopwords file. (There is a small difference with mnoGoSearch - while in mnoGoSearch if relative path or no path entered, it looks for this file in relation to UDM_CONF_DIR, the module looks for the file in relation to current path, i.e. to the path where the PHP script is executed.)
  • UDM_PARAM_STOPTABLE - Load stop words from the given SQL table. You may use several StopwordTable commands. This command has no effect when compiled without SQL database support.

  • UDM_PARAM_WEIGHT_FACTOR - represents weight factors for specific document parts. Currently body, title, keywords, description, url are supported. To activate this feature please use degrees of 2 in *Weight commands of the indexer.conf. Let's imagine that we have these weights:

    URLWeight 1
    BodyWeight 2
    TitleWeight 4
    KeywordWeight 8
    DescWeight 16

    As far as indexer uses bit OR operation for word weights when some word presents several time in the same document, it is possible at search time to detect word appearance in different document parts. Word which appears only in the body will have 00000010 aggregate weight (in binary notation). Word used in all document parts will have 00011111 aggregate weight.

    This parameter's value is a string of hex digits ABCDE. Each digit is a factor for corresponding bit in word weight. For the given above weights configuration:

    E is a factor for weight 1 (URL Weight bit)
    D is a factor for weight 2 (BodyWeight bit)
    C is a factor for weight 4 (TitleWeight bit)
    B is a factor for weight 8 (KeywordWeight bit)
    A is a factor for weight 16 (DescWeight bit)

    Examples:

    UDM_PARAM_WEIGHT_FACTOR=00001 will search through URLs only.

    UDM_PARAM_WEIGHT_FACTOR=00100 will search through Titles only.

    UDM_PARAM_WEIGHT_FACTOR=11100 will search through Title,Keywords,Description but not through URL and Body.

    UDM_PARAM_WEIGHT_FACTOR=F9421 will search through:

    Description with factor 15 (F hex)
    Keywords with factor 9
    Title with factor 4
    Body with factor 2
    URL with factor 1

    If UDM_PARAM_WEIGHT_FACTOR variable is omitted, original weight value is taken to sort results. For a given above weight configuration it means that document description has a most big weight 16.

  • UDM_PARAM_WORD_MATCH - word match. You may use this parameter to choose word match type. This feature works only in "single" and "multi" modes using SQL based and built-in database. It does not work in cachemode and other modes since they use word CRC and do not support substring search. Available values:

    UDM_MATCH_BEGIN - word beginning match;

    UDM_MATCH_END - word ending match;

    UDM_MATCH_WORD - whole word match;

    UDM_MATCH_SUBSTR - word substring match.

  • UDM_PARAM_MIN_WORD_LEN - defines minimal word length. Any word shorter this limit is considered to be a stopword. Please note that this parameter value is inclusive, i.e. if UDM_PARAM_MIN_WORD_LEN=3, a word 3 characters long will not be considered a stopword, while a word 2 characters long will be. Default value is 1.
  • UDM_PARAM_ISPELL_PREFIXES - Possible values: UDM_PREFIXES_ENABLED and UDM_PREFIXES_DISABLED, that respectively enable or disable using prefixes. E.g. if a word "tested" is in search query, also words like "test", "testing", etc. Only suffixes are supported by default. Prefixes usually change word meanings, for example if somebody is searching for the word "tested" one hardly wants "untested" to be found. Prefixes support may also be found useful for site's spelling checking purposes. In order to enable ispell, you have to load ispell data with udm_load_ispell_data().

  • UDM_PARAM_CROSS_WORDS - enables or disables crosswords support. Possible values: UDM_CROSS_WORDS_ENABLED and UDM_CROSS_WORDS_DISABLED.

    The crosswords feature allows to assign words between <a href="xxx"> and </a> also to a document this link leads to. It works in SQL database mode and is not supported in built-in database and Cachemode.

  • UDM_PARAM_VARDIR - specifies a custom path to directory where indexer stores data when using built-in database and in cache mode. By default /var directory of mnoGoSearch installation is used. Can have only string values.

val

ChangeLog (záznam změn)

Verze | Popis
4.1.0 | UDM_PARAM_VARDIR was added.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Poznámky

Poznámka: Crosswords are supported only in mnoGoSearch 3.1.11 or later.

Předcházející | Nahoru | Další
udm_open_stored | Domů | XCII. Microsoft SQL Server Functions


mSQL Functions

Předcházející VI. Reference funkcí Další

XCV. mSQL Functions

Úvod

These functions allow you to access mSQL database servers. More information about mSQL can be found at » http://www.hughes.com.au/.

Instalace

In order to have these functions available, you must compile PHP with msql support by using the --with-msql[=DIR] option. DIR is the mSQL base install directory, defaults to /usr/local/msql3.

Note to Win32 Users: In order for this extension to work, there are DLL files that must be available to the Windows system PATH. See the FAQ titled "How do I add my PHP directory to the PATH on Windows" for information on how to do this. Although copying DLL files from the PHP folder into the Windows system directory also works (because the system directory is by default in the systems PATH), it is not recommended. This extension requires the following files to be in the PATH: msql.dll

Konfigurace běhu

Chování těchto funkcí je ovlivněno nastavením parametrů v php.ini.

Tabulka 166. mSQL configuration options

Name | Default | Changeable | Changelog
msql.allow_persistent | "1" | PHP_INI_ALL |
msql.max_persistent | "-1" | PHP_INI_ALL |
msql.max_links | "-1" | PHP_INI_ALL |

Pro další detaily a definice konstant PHP_INI_*, viz dokumentace k ini_set().

Zde je stručný popis konfiguračních direktiv.

msql.allow_persistent boolean

Whether to allow persistent mSQL connections.

msql.max_persistent integer

The maximum number of persistent mSQL connections per process.

msql.max_links integer

The maximum number of mSQL connections per process, including persistent connections.

Typy prostředků

There are two resource types used in the mSQL module. The first one is the link identifier for a database connection, the second a resource which holds the result of a query.

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

MSQL_ASSOC (integer)
MSQL_NUM (integer)
MSQL_BOTH (integer)

Příklady

This simple example shows how to connect, execute a query, print resulting rows and disconnect from a mSQL database.

Příklad 1212. mSQL usage example

<?php
/* Connecting, selecting database */
$link = msql_connect('localhost', 'username', 'password')
    or die('Could not connect : ' . msql_error($link));

msql_select_db('database', $link)
    or die('Could not select database');

/* Issue SQL query */
$query = 'SELECT * FROM my_table';
$result = msql_query($query, $link) or die('Query failed : ' . msql_error());

/* Printing results in HTML */
echo "<table>\n";
while ($row = msql_fetch_array($result, MSQL_ASSOC)) {
    echo "\t<tr>\n";
    foreach ($row as $col_value) {
        echo "\t\t<td>$col_value</td>\n";
    }
    echo "\t</tr>\n";
}
echo "</table>\n";

/* Free result set */
msql_free_result($result);

/* Close connection */
msql_close($link);
?>

Obsah

msql_affected_rows — Returns number of affected rows
msql_close — Close mSQL connection
msql_connect — Open mSQL connection
msql_create_db — Create mSQL database
msql_createdb — Alias pro msql_create_db()
msql_data_seek — Move internal row pointer
msql_db_query — Send mSQL query
msql_dbname — Alias pro msql_result()
msql_drop_db — Drop (delete) mSQL database
msql_error — Returns error message of last msql call
msql_fetch_array — Fetch row as array
msql_fetch_field — Get field information
msql_fetch_object — Fetch row as object
msql_fetch_row — Get row as enumerated array
msql_field_flags — Get field flags
msql_field_len — Get field length
msql_field_name — Get the name of the specified field in a result
msql_field_seek — Set field offset
msql_field_table — Get table name for field
msql_field_type — Get field type
msql_fieldflags — Alias of msql_field_flags()
msql_fieldlen — Alias of msql_field_len()
msql_fieldname — Alias of msql_field_name()
msql_fieldtable — Alias of msql_field_table()
msql_fieldtype — Alias of msql_field_type()
msql_free_result — Free result memory
msql_list_dbs — List mSQL databases on server
msql_list_fields — List result fields
msql_list_tables — List tables in an mSQL database
msql_num_fields — Get number of fields in result
msql_num_rows — Get number of rows in result
msql_numfields — Alias of msql_num_fields()
msql_numrows — Alias of msql_num_rows()
msql_pconnect — Open persistent mSQL connection
msql_query — Send mSQL query
msql_regcase — Alias of sql_regcase()
msql_result — Get result data
msql_select_db — Select mSQL database
msql_tablename — Alias of msql_result()
msql — Alias of msql_db_query()
Předcházející | Nahoru | Další
msession_unlock | Domů | msql_affected_rows


msql_affected_rows

(PHP 4, PHP 5)

msql_affected_rows — Returns number of affected rows

Popis

int msql_affected_rows ( resource $result )

Returns number of affected rows by the last SELECT, UPDATE or DELETE query associated with result.

Seznam parametrů

result

Výsledek resource, který se ověřuje. Tento výsledek se získá voláním msql_query().

Návratové hodnoty

Returns the number of affected rows on success, or FALSE on error.

Viz také

msql_query()

Předcházející | Nahoru | Další
XCV. mSQL Functions | Domů | msql_close


msql_close

(PHP 4, PHP 5)

msql_close — Close mSQL connection

Popis

bool msql_close ( [resource $link_identifier] )

msql_close() closes the non-persistent connection to the mSQL server that's associated with the specified link identifier.

Using msql_close() isn't usually necessary, as non-persistent open links are automatically closed at the end of the script's execution. See also freeing resources.

Seznam parametrů

link_identifier

Připojení na mSQL. Není-li specifikováno jinak, předpokládá se poslední připojení otevřené pomocí msql_connect(). Nebylo-li toto připojení nalezeno, funkce se pokusí vytvořit nové, jako kdyby se zavolala funkce msql_connect(), a použije ho.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

msql_connect()
msql_pconnect()

Předcházející | Nahoru | Další
msql_affected_rows | Domů | msql_connect


msql_connect

(PHP 4, PHP 5)

msql_connect — Open mSQL connection

Popis

resource msql_connect ( [string $hostname] )

msql_connect() establishes a connection to a mSQL server.

In case a second call is made to msql_connect() with the same arguments, no new link will be established, but instead, the link identifier of the already opened link will be returned.

The link to the server will be closed as soon as the execution of the script ends, unless it's closed earlier by explicitly calling msql_close().

Seznam parametrů

hostname

The hostname can also include a port number. e.g. hostname,port.

If not specified, the connection is established by the means of a Unix domain socket, being then more efficient then a localhost TCP socket connection.

Poznámka: While this function will accept a colon (:) as a host/port separator, a comma (,) is the preferred method.

Návratové hodnoty

Returns a positive mSQL link identifier on success, or FALSE on error.

Viz také

msql_pconnect()
msql_close()

Předcházející | Nahoru | Další
msql_close | Domů | msql_create_db


msql_create_db

(PHP 4, PHP 5)

msql_create_db — Create mSQL database

Popis

bool msql_create_db ( string $database_name [, resource $link_identifier] )

msql_create_db() attempts to create a new database on the mSQL server.

Seznam parametrů

database_name

The name of the mSQL database.

link_identifier

Připojení na mSQL. Není-li specifikováno jinak, předpokládá se poslední připojení otevřené pomocí msql_connect(). Nebylo-li toto připojení nalezeno, funkce se pokusí vytvořit nové, jako kdyby se zavolala funkce msql_connect(), a použije ho.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

msql_drop_db()

Předcházející | Nahoru | Další
msql_connect | Domů | msql_createdb


msql_createdb

(PHP 4, PHP 5)

msql_createdb — Alias pro msql_create_db()

Popis

Tato funkce je aliasem: msql_create_db().

Předcházející | Nahoru | Další
msql_create_db | Domů | msql_data_seek


msql_data_seek

(PHP 4, PHP 5)

msql_data_seek — Move internal row pointer

Popis

bool msql_data_seek ( resource $result, int $row_number )

msql_data_seek() moves the internal row pointer of the mSQL result associated with the specified query identifier to point to the specified row number. The next call to msql_fetch_row() would return that row.

Seznam parametrů

result

Výsledek resource, který se ověřuje. Tento výsledek se získá voláním msql_query().

row_number

The seeked row number.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

msql_fetch_array()
msql_fetch_object()
msql_fetch_row()
msql_result()

Předcházející | Nahoru | Další
msql_createdb | Domů | msql_db_query


msql_db_query

(PHP 4, PHP 5)

msql_db_query — Send mSQL query

Popis

resource msql_db_query ( string $database, string $query [, resource $link_identifier] )

msql_db_query() selects a database and executes a query on it.

Seznam parametrů

database

The name of the mSQL database.

query

The SQL query.

link_identifier

Připojení na mSQL. Není-li specifikováno jinak, předpokládá se poslední připojení otevřené pomocí msql_connect(). Nebylo-li toto připojení nalezeno, funkce se pokusí vytvořit nové, jako kdyby se zavolala funkce msql_connect(), a použije ho.

Návratové hodnoty

Returns a positive mSQL query identifier to the query result, or FALSE on error.

Viz také

msql_query()

Předcházející | Nahoru | Další
msql_data_seek | Domů | msql_dbname


msql_dbname

(PHP 4, PHP 5)

msql_dbname — Alias pro msql_result()

Popis

Tato funkce je aliasem: msql_result().

Předcházející | Nahoru | Další
msql_db_query | Domů | msql_drop_db


msql_drop_db

(PHP 4, PHP 5)

msql_drop_db — Drop (delete) mSQL database

Popis

bool msql_drop_db ( string $database_name [, resource $link_identifier] )

msql_drop_db() attempts to drop (remove) a database from the mSQL server.

Seznam parametrů

database_name

The name of the database.

link_identifier

Připojení na mSQL. Není-li specifikováno jinak, předpokládá se poslední připojení otevřené pomocí msql_connect(). Nebylo-li toto připojení nalezeno, funkce se pokusí vytvořit nové, jako kdyby se zavolala funkce msql_connect(), a použije ho.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

msql_create_db()

Předcházející | Nahoru | Další
msql_dbname | Domů | msql_error


msql_error

(PHP 4, PHP 5)

msql_error — Returns error message of last msql call

Popis

string msql_error ( void )

msql_error() returns the last issued error by the mSQL server. Note that only the last error message is accessible with msql_error().

Návratové hodnoty

The last error message or an empty string if no error was issued.

Předcházející | Nahoru | Další
msql_drop_db | Domů | msql_fetch_array


msql_fetch_array

(PHP 4, PHP 5)

msql_fetch_array — Fetch row as array

Popis

array msql_fetch_array ( resource $result [, int $result_type] )

msql_fetch_array() is an extended version of msql_fetch_row(). In addition to storing the data in the numeric indices of the result array, it also stores the data in associative indices, using the field names as keys.

An important thing to note is that using msql_fetch_array() is NOT significantly slower than using msql_fetch_row(), while it provides a significant added value.

Seznam parametrů

result

Výsledek resource, který se ověřuje. Tento výsledek se získá voláním msql_query().

result_type

A constant that can take the following values: MSQL_ASSOC, MSQL_NUM, and MSQL_BOTH with MSQL_BOTH being the default.

Návratové hodnoty

Returns an array that corresponds to the fetched row, or FALSE if there are no more rows.

Příklady

Příklad 1213. msql_fetch_array() example

<?php
$con = msql_connect();
if (!$con) {
    die('Server connection problem: ' . msql_error());
}

if (!msql_select_db('test', $con)) {
    die('Database connection problem: ' . msql_error());
}

$result = msql_query('SELECT id, name FROM people', $con);
if (!$result) {
    die('Query execution problem: ' . msql_error());
}

while ($row = msql_fetch_array($result, MSQL_ASSOC)) {
    echo $row['id'] . ': ' . $row['name'] . "\n";
}

msql_free_result($result);
?>

ChangeLog (záznam změn)

Verze | Popis
4.3.11 and 5.0.4 | A bug was fixed when retrieving data from columns containing NULL values. Such columns were not placed into the resulting array.

Viz také

msql_fetch_row()
msql_fetch_object()
msql_data_seek()
msql_result()

Předcházející | Nahoru | Další
msql_error | Domů | msql_fetch_field


msql_fetch_field

(PHP 4, PHP 5)

msql_fetch_field — Get field information

Popis

object msql_fetch_field ( resource $result [, int $field_offset] )

msql_fetch_field() can be used in order to obtain information about fields in a certain query result.

Seznam parametrů

result

Výsledek resource, který se ověřuje. Tento výsledek se získá voláním msql_query().

field_offset

The field offset. If not specified, the next field that wasn't yet retrieved by msql_fetch_field() is retrieved.

Návratové hodnoty

Returns an object containing field information. The properties of the object are:

  • name - column name

  • table - name of the table the column belongs to

  • not_null - 1 if the column cannot be NULL

  • unique - 1 if the column is a unique key

  • type - the type of the column

Viz také

msql_field_seek()

Předcházející | Nahoru | Další
msql_fetch_array | Domů | msql_fetch_object


msql_fetch_object

(PHP 4, PHP 5)

msql_fetch_object — Fetch row as object

Popis

object msql_fetch_object ( resource $result )

msql_fetch_object() is similar to msql_fetch_array(), with one difference - an object is returned, instead of an array. Indirectly, that means that you can only access the data by the field names, and not by their offsets (numbers are illegal property names).

Speed-wise, the function is identical to msql_fetch_array(), and almost as quick as msql_fetch_row() (the difference is insignificant).

Seznam parametrů

result

Výsledek resource, který se ověřuje. Tento výsledek se získá voláním msql_query().

Návratové hodnoty

Returns an object with properties that correspond to the fetched row, or FALSE if there are no more rows.

Příklady

Příklad 1214. msql_fetch_object() example

<?php
$con = msql_connect();
if (!$con) {
    die('Server connection problem: ' . msql_error());
}

if (!msql_select_db('test', $con)) {
    die('Database connection problem: ' . msql_error());
}

$result = msql_query('SELECT id, name FROM people', $con);
if (!$result) {
    die('Query execution problem: ' . msql_error());
}

while ($row = msql_fetch_object($result, MSQL_ASSOC)) {
    echo $row->id . ': ' . $row->name . "\n";
}

msql_free_result($result);
?>

ChangeLog (záznam změn)

Verze | Popis
4.3.11 and 5.0.4 | A bug was fixed when retrieving data from columns containing NULL values. Such columns were not placed into the resulting array.

Viz také

msql_fetch_array()
msql_fetch_row()
msql_data_seek()
msql_result()

Předcházející | Nahoru | Další
msql_fetch_field | Domů | msql_fetch_row


msql_fetch_row

(PHP 4, PHP 5)

msql_fetch_row — Get row as enumerated array

Popis

array msql_fetch_row ( resource $result )

msql_fetch_row() fetches one row of data from the result associated with the specified query identifier. The row is returned as an array. Each result column is stored in an array offset, starting at offset 0.

Subsequent call to msql_fetch_row() would return the next row in the result set, or FALSE if there are no more rows.

Seznam parametrů

result

Výsledek resource, který se ověřuje. Tento výsledek se získá voláním msql_query().

Návratové hodnoty

Returns an array that corresponds to the fetched row, or FALSE if there are no more rows.

Příklady

Příklad 1215. msql_fetch_row() example

<?php
$con = msql_connect();
if (!$con) {
    die('Server connection problem: ' . msql_error());
}

if (!msql_select_db('test', $con)) {
    die('Database connection problem: ' . msql_error());
}

$result = msql_query('SELECT id, name FROM people', $con);
if (!$result) {
    die('Query execution problem: ' . msql_error());
}

while ($row = msql_fetch_row($result)) {
    echo $row[0] . ': ' . $row[1] . "\n";
}

msql_free_result($result);
?>

ChangeLog (záznam změn)

Verze | Popis
4.3.11 and 5.0.4 | A bug was fixed when retrieving data from columns containing NULL values. Such columns were not placed into the resulting array.

Viz také

msql_fetch_array()
msql_fetch_object()
msql_data_seek()
msql_result()

Předcházející | Nahoru | Další
msql_fetch_object | Domů | msql_field_flags


msql_field_flags

(PHP 4, PHP 5)

msql_field_flags — Get field flags

Popis

string msql_field_flags ( resource $result, int $field_offset )

msql_field_flags() returns the field flags of the specified field.

Seznam parametrů

result

Výsledek resource, který se ověřuje. Tento výsledek se získá voláním msql_query().

field_offset

Číselný offset pole. field_offset začíná na 1.

Návratové hodnoty

Returns a string containing the field flags of the specified key. This can be: primary key not null, not null, primary key, unique not null or unique.

Předcházející | Nahoru | Další
msql_fetch_row | Domů | msql_field_len


msql_field_len

(PHP 4, PHP 5)

msql_field_len — Get field length

Popis

int msql_field_len ( resource $result, int $field_offset )

msql_field_len() returns the length of the specified field.

Seznam parametrů

result

Výsledek resource, který se ověřuje. Tento výsledek se získá voláním msql_query().

field_offset

Číselný offset pole. field_offset začíná na 1.

Návratové hodnoty

Returns the length of the specified field or FALSE on error.

Předcházející | Nahoru | Další
msql_field_flags | Domů | msql_field_name


msql_field_name

(PHP 4, PHP 5)

msql_field_name — Get the name of the specified field in a result

Popis

string msql_field_name ( resource $result, int $field_offset )

msql_field_name() gets the name of the specified field index.

Seznam parametrů

result

Výsledek resource, který se ověřuje. Tento výsledek se získá voláním msql_query().

field_offset

Číselný offset pole. field_offset začíná na 1.

Návratové hodnoty

The name of the field or FALSE on failure.

Viz také

msql_field_len()

Předcházející | Nahoru | Další
msql_field_len | Domů | msql_field_seek


msql_field_seek

(PHP 4, PHP 5)

msql_field_seek — Set field offset

Popis

bool msql_field_seek ( resource $result, int $field_offset )

Seeks to the specified field offset. If the next call to msql_fetch_field() won't include a field offset, this field would be returned.

Seznam parametrů

result

Výsledek resource, který se ověřuje. Tento výsledek se získá voláním msql_query().

field_offset

Číselný offset pole. field_offset začíná na 1.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

msql_fetch_field()

Předcházející | Nahoru | Další
msql_field_name | Domů | msql_field_table


msql_field_table

(PHP 4, PHP 5)

msql_field_table — Get table name for field

Popis

int msql_field_table ( resource $result, int $field_offset )

Returns the name of the table that the specified field is in.

Seznam parametrů

result

Výsledek resource, který se ověřuje. Tento výsledek se získá voláním msql_query().

field_offset

Číselný offset pole. field_offset začíná na 1.

Návratové hodnoty

The name of the table on success, or FALSE on failure.

Předcházející | Nahoru | Další
msql_field_seek | Domů | msql_field_type


msql_field_type

(PHP 4, PHP 5)

msql_field_type — Get field type

Popis

string msql_field_type ( resource $result, int $field_offset )

msql_field_type() gets the type of the specified field index.

Seznam parametrů

result

Výsledek resource, který se ověřuje. Tento výsledek se získá voláním msql_query().

field_offset

Číselný offset pole. field_offset začíná na 1.

Návratové hodnoty

The type of the field. One of int, char, real, ident, null or unknown. This functions will return FALSE on failure.

Předcházející | Nahoru | Další
msql_field_table | Domů | msql_fieldflags


msql_fieldflags

(PHP 4, PHP 5)

msql_fieldflags — Alias of msql_field_flags()

Popis

This function is an alias of msql_field_flags().

Předcházející | Nahoru | Další
msql_field_type | Domů | msql_fieldlen


msql_fieldlen

(PHP 4, PHP 5)

msql_fieldlen — Alias of msql_field_len()

Popis

This function is an alias of msql_field_len().

Předcházející | Nahoru | Další
msql_fieldflags | Domů | msql_fieldname


msql_fieldname

(PHP 4, PHP 5)

msql_fieldname — Alias of msql_field_name()

Popis

This function is an alias of msql_field_name().

Předcházející | Nahoru | Další
msql_fieldlen | Domů | msql_fieldtable


msql_fieldtable

(PHP 4, PHP 5)

msql_fieldtable — Alias of msql_field_table()

Popis

This function is an alias of msql_field_table().

Předcházející | Nahoru | Další
msql_fieldname | Domů | msql_fieldtype


msql_fieldtype

(PHP 4, PHP 5)

msql_fieldtype — Alias of msql_field_type()

Popis

This function is an alias of msql_field_type().

Předcházející | Nahoru | Další
msql_fieldtable | Domů | msql_free_result


msql_free_result

(PHP 4, PHP 5)

msql_free_result — Free result memory

Popis

bool msql_free_result ( resource $result )

msql_free_result() frees the memory associated with query_identifier. When PHP completes a request, this memory is freed automatically, so you only need to call this function when you want to make sure you don't use too much memory while the script is running.

Seznam parametrů

result

Výsledek resource, který se ověřuje. Tento výsledek se získá voláním msql_query().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
msql_fieldtype | Domů | msql_list_dbs


msql_list_dbs

(PHP 4, PHP 5)

msql_list_dbs — List mSQL databases on server

Popis

resource msql_list_dbs ( [resource $link_identifier] )

msql_list_tables() lists the databases available on the specified link_identifier.

Seznam parametrů

link_identifier

Připojení na mSQL. Není-li specifikováno jinak, předpokládá se poslední připojení otevřené pomocí msql_connect(). Nebylo-li toto připojení nalezeno, funkce se pokusí vytvořit nové, jako kdyby se zavolala funkce msql_connect(), a použije ho.

Návratové hodnoty

Returns a result set which may be traversed with any function that fetches result sets, such as msql_fetch_array(). On failure, this function will return FALSE.

Viz také

msql_list_tables()
msql_list_fields()

Předcházející | Nahoru | Další
msql_free_result | Domů | msql_list_fields


msql_list_fields

(PHP 4, PHP 5)

msql_list_fields — List result fields

Popis

resource msql_list_fields ( string $database, string $tablename [, resource $link_identifier] )

msql_list_fields() returns information about the given table.

Seznam parametrů

database

The name of the database.

tablename

The name of the table.

link_identifier

Připojení na mSQL. Není-li specifikováno jinak, předpokládá se poslední připojení otevřené pomocí msql_connect(). Nebylo-li toto připojení nalezeno, funkce se pokusí vytvořit nové, jako kdyby se zavolala funkce msql_connect(), a použije ho.

Návratové hodnoty

Returns a result set which may be traversed with any function that fetches result sets, such as msql_fetch_array(). On failure, this function will return FALSE.

Viz také

msql_list_tables()
msql_list_dbs()

Předcházející | Nahoru | Další
msql_list_dbs | Domů | msql_list_tables


msql_list_tables

(PHP 4, PHP 5)

msql_list_tables — List tables in an mSQL database

Popis

resource msql_list_tables ( string $database [, resource $link_identifier] )

msql_list_tables() lists the tables on the specified database.

Seznam parametrů

database

The name of the database.

link_identifier

Připojení na mSQL. Není-li specifikováno jinak, předpokládá se poslední připojení otevřené pomocí msql_connect(). Nebylo-li toto připojení nalezeno, funkce se pokusí vytvořit nové, jako kdyby se zavolala funkce msql_connect(), a použije ho.

Návratové hodnoty

Returns a result set which may be traversed with any function that fetches result sets, such as msql_fetch_array(). On failure, this function will return FALSE.

Viz také

msql_list_fields()
msql_list_dbs()

Předcházející | Nahoru | Další
msql_list_fields | Domů | msql_num_fields


msql_num_fields

(PHP 4, PHP 5)

msql_num_fields — Get number of fields in result

Popis

int msql_num_fields ( resource $result )

msql_num_fields() returns the number of fields in a result set.

Seznam parametrů

result

Výsledek resource, který se ověřuje. Tento výsledek se získá voláním msql_query().

Návratové hodnoty

Returns the number of fields in the result set.

Viz také

msql_query()
msql_fetch_field()
msql_num_rows()

Předcházející | Nahoru | Další
msql_list_tables | Domů | msql_num_rows


msql_num_rows

(PHP 4, PHP 5)

msql_num_rows — Get number of rows in result

Popis

int msql_num_rows ( resource $query_identifier )

msql_num_rows() returns the number of rows in a result set.

Seznam parametrů

result

Výsledek resource, který se ověřuje. Tento výsledek se získá voláním msql_query().

Návratové hodnoty

Returns the number of rows in the result set.

Viz také

msql_num_fields()

Předcházející | Nahoru | Další
msql_num_fields | Domů | msql_numfields


msql_numfields

(PHP 4, PHP 5)

msql_numfields — Alias of msql_num_fields()

Popis

This function is an alias of msql_num_fields().

Předcházející | Nahoru | Další
msql_num_rows | Domů | msql_numrows


msql_numrows

(PHP 4, PHP 5)

msql_numrows — Alias of msql_num_rows()

Popis

This function is an alias of msql_num_rows().

Předcházející | Nahoru | Další
msql_numfields | Domů | msql_pconnect


msql_pconnect

(PHP 4, PHP 5)

msql_pconnect — Open persistent mSQL connection

Popis

resource msql_pconnect ( [string $hostname] )

msql_pconnect() acts very much like msql_connect() with two major differences.

First, when connecting, the function would first try to find a (persistent) link that's already open with the same host. If one is found, an identifier for it will be returned instead of opening a new connection.

Second, the connection to the SQL server will not be closed when the execution of the script ends. Instead, the link will remain open for future use (msql_close() will not close links established by this function).

Seznam parametrů

hostname

The hostname can also include a port number. e.g. hostname,port.

If not specified, the connection is established by the means of a Unix domain socket, being then more efficient then a localhost TCP socket connection.

Poznámka: While this function will accept a colon (:) as a host/port separator, a comma (,) is the preferred method.

Návratové hodnoty

Returns a positive mSQL link identifier on success, or FALSE on error.

Viz také

msql_connect()
msql_close()

Předcházející | Nahoru | Další
msql_numrows | Domů | msql_query


msql_query

(PHP 4, PHP 5)

msql_query — Send mSQL query

Popis

resource msql_query ( string $query [, resource $link_identifier] )

msql_query() sends a query to the currently active database on the server that's associated with the specified link identifier.

Seznam parametrů

query

The SQL query.

link_identifier

Připojení na mSQL. Není-li specifikováno jinak, předpokládá se poslední připojení otevřené pomocí msql_connect(). Nebylo-li toto připojení nalezeno, funkce se pokusí vytvořit nové, jako kdyby se zavolala funkce msql_connect(), a použije ho.

Návratové hodnoty

Returns a positive mSQL query identifier on success, or FALSE on error.

Příklady

Příklad 1216. msql_query() example

<?php
$link = msql_connect("dbserver")
   or die("unable to connect to msql server: " . msql_error());
msql_select_db("db", $link)
   or die("unable to select database 'db': " . msql_error());

$result = msql_query("SELECT * FROM table WHERE id=1", $link);
if (!$result) {
   die("query failed: " . msql_error());
}

while ($row = msql_fetch_array($result)) {
    echo $row["id"];
}
?>

Viz také

msql_db_query()
msql_select_db()
msql_connect()

Předcházející | Nahoru | Další
msql_pconnect | Domů | msql_regcase


msql_regcase

(PHP 4, PHP 5)

msql_regcase — Alias of sql_regcase()

Popis

This function is an alias of sql_regcase().

Předcházející | Nahoru | Další
msql_query | Domů | msql_result


msql_result

(PHP 4, PHP 5)

msql_result — Get result data

Popis

string msql_result ( resource $result, int $row [, mixed $field] )

msql_result() returns the contents of one cell from a mSQL result set.

When working on large result sets, you should consider using one of the functions that fetch an entire row (specified below). As these functions return the contents of multiple cells in one function call, they are often much quicker than msql_result().

Recommended high-performance alternatives:
msql_fetch_row(),
msql_fetch_array(), and
msql_fetch_object().

Seznam parametrů

result

Výsledek resource, který se ověřuje. Tento výsledek se získá voláním msql_query().

row

The row offset.

field

Can be the field's offset, or the field's name, or the field's table dot field's name (tablename.fieldname.). If the column name has been aliased ('select foo as bar from ...'), use the alias instead of the column name.

Poznámka: Specifying a numeric field offset is much quicker than specifying a fieldname or tablename.fieldname.

Návratové hodnoty

Returns the contents of the cell at the row and offset in the specified mSQL result set.

Předcházející | Nahoru | Další
msql_regcase | Domů | msql_select_db


msql_select_db

(PHP 4, PHP 5)

msql_select_db — Select mSQL database

Popis

bool msql_select_db ( string $database_name [, resource $link_identifier] )

msql_select_db() sets the current active database on the server that's associated with the specified link_identifier.

Subsequent calls to msql_query() will be made on the active database.

Seznam parametrů

database_name

The database name.

link_identifier

Připojení na mSQL. Není-li specifikováno jinak, předpokládá se poslední připojení otevřené pomocí msql_connect(). Nebylo-li toto připojení nalezeno, funkce se pokusí vytvořit nové, jako kdyby se zavolala funkce msql_connect(), a použije ho.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

msql_connect()
msql_pconnect()
msql_query()

Předcházející | Nahoru | Další
msql_result | Domů | msql_tablename


msql_tablename

(PHP 4, PHP 5)

msql_tablename — Alias of msql_result()

Popis

This function is an alias of msql_result().

Předcházející | Nahoru | Další
msql_select_db | Domů | msql


msql

(PHP 4, PHP 5)

msql — Alias of msql_db_query()

Popis

This function is an alias of msql_db_query().

Předcházející | Nahoru | Další
msql_tablename | Domů | XCVI. Multibyte String Functions


MySQL funkce

Předcházející VI. Reference funkcí Další

XCVIII. MySQL funkce

Úvod

Tyto funkce zprostředkovávají přístup na MySQL databázový server. Více informací o MySQL lze nalézt na » http://www.mysql.com/.

Dokumentace k MySQL je dostupná na » http://dev.mysql.com/doc/.

Požadavky

Aby byly tyto funkce dostupné, musí být PHP zkompilováno s podporou MySQL.

Instalace

Použitím konfigurační volby --with-mysql[=DIR] povolíte PHP přistupovat k MySQL databázím.

V PHP 4 je volba --with-mysql ve výchozím nastavení povolena. Pro zakázání MySQL můžete použít volbu --without-mysql. Pokud v PHP 4 povolíte MySQL bez zadání cesty k MySQL, PHP použije přibalené klientské knihovny MySQL. Pod Windows není potřeba žádné DLL, je přímo obsaženo v PHP 4. Uživatelé, kteří používají jiné aplikace, které používají MySQL (například auth-mysql) by neměli použít přibalené knihovny, ale měli by raději určit cestu k instalačnímu adresáři MySQL, např.: --with-mysql=/path/to/mysql. To přinutí PHP používat klientské knihovny instalované MySQL, čímž se vyhnete případným konfliktům.

V PHP 5 není ve výchozím nastavení MySQL nadále zapnuto ani nejsou k dispozici přibalené knihovny MySQL. Přečtěte si tuto FAQ s vysvětlením důvodů.

Toto MySQL rozšíření nebude pracovat s MySQL verzemi většími než 4.1.0. Pro tyto verze použijte MySQLi.

Varování

Padání a problémy při startu PHP mohou nastat, pokud nahráváte toto rozšíření spolu s rozšířením recode. Viz rozšíření recode pro bližší informace.

Poznámka: Pokud potřebujete kódové stránky jiné než latin (výchozí), musíte nainstalovat externí (ne přibalenou) knihovnu se zakompilovanou podporou kódových stránek.

Konfigurace běhu

Chování těchto funkcí je ovlivněno nastavením parametrů v php.ini.

Tabulka 171. Možnosti nastavení MySQL

Jméno | Výchozí | Změnitelné
mysql.allow_persistent | "On" | PHP_INI_SYSTEM
mysql.max_persistent | "-1" | PHP_INI_SYSTEM
mysql.max_links | "-1" | PHP_INI_SYSTEM
mysql.default_port | NULL | PHP_INI_ALL
mysql.default_socket | NULL | PHP_INI_ALL
mysql.default_host | NULL | PHP_INI_ALL
mysql.default_user | NULL | PHP_INI_ALL
mysql.default_password | NULL | PHP_INI_ALL
mysql.connect_timeout | "0" | PHP_INI_SYSTEM

Podrobný popis a definice konstant PHP_INI_* naleznete v ini_set().

Zde je stručný popis konfiguračních direktiv.

mysql.allow_persistent boolean

Má-li být povoleno persistentní (trvalá) spojení s MySQL.

mysql.max_persistent integer

Maximální počet persistentních spojení na jeden proces.

mysql.max_links integer

Maximální počet spojení s MySQL na jeden proces včetně persistentních spojení.

mysql.default_port string

Číslo výchozího TCP portu pro spojení s databázovým serverem, pokud není port zadán. Není-li výchozí port zadán, použije se port uvedený v proměnné prostředí MYSQL_TCP_PORT, záznam mysql-tcp v /etc/services nebo "compile-time" konstanta MYSQL_PORT, v tomto pořadí. Win32 používá pouze konstantu MYSQL_PORT.

mysql.default_socket string

Výchozí jméno socketu pro připojení k lokálnímu databázovému serveru, není-li jiný socket specifikován.

mysql.default_host string

Výchozí server pro spojení s databázovým serverem, není-li uveden jiný. Nelze použít při bezpečném režimu (safe mode).

mysql.default_user string

Výchozí uživatel pro spojení s databázovým serverem, není-li uveden jiný uživatel. Nelze použít při bezpečném režimu (safe mode).

mysql.default_password string

Výchozí heslo pro spojení s databázovým serverem, není-li uvedeno jiné heslo. Nelze použít při bezpečném režimu (safe mode).

mysql.connect_timeout integer

Timeout připojení v sekundách. Na Linuxu je tento timeout použit také pro čekání na první odpověď serveru.

Typy prostředků

V MySQL modulu jsou použity dva typy zdrojů. První je identifikátor spojení pro připojení k databázi a druhý uchovává výsledek dotazu.

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

Od PHP 4.3.0 je možné nastavit klienta doplňujícími parametry pro funkce mysql_connect() a mysql_pconnect() Jsou definovány následující konstanty:

Tabulka 172. MySQL klientské konstanty

Konstanta | Popis
MYSQL_CLIENT_COMPRESS | Použije kompresní protokol
MYSQL_CLIENT_IGNORE_SPACE | Povolí mezeru za názvy funkcí
MYSQL_CLIENT_INTERACTIVE | Povolí interactive_timeout sekundy (namísto wait_timeout) neaktivity před uzavřením spojení.

Funkce mysql_fetch_array() používá konstanty pro různé typy výsledkových polí. Jsou definovány následující konstanty:

Tabulka 173. MySQL fetch konstanty

Konstanta | Popis
MYSQL_ASSOC | Sloupce jsou vraceny do pole jehož klíčemi jsou názvy sloupců.
MYSQL_BOTH | Sloupce jsou vráceny do pole majícího číslené i textové klíče, určující pořadí sloupce v tabulce, respektive jeho jméno.
MYSQL_NUM | Vrací sloupec do pole s číselnými klíči reprezentujícími pořadí sloupce v tabulce. První sloupec tabulky začíná klíčem 0.

Příklady

Tento jednoduchý příklad ukazuje jak se připojit, provést dotaz, zobrazit výsledné řádky a odpojit se z MySQL databáze.

Příklad 1242. Ukázkový příklad použití MySQL

<?php
    /* Připojení, výběr databáze */
    $link = mysql_connect("mysql_host", "mysql_user", "mysql_password")
        or die("Nelze se připojit: " . mysql_error());
    print "Připojeno úspěšně";
    mysql_select_db("my_database") or die("Nelze vybrat databázi");

    /* Příprava SQL dotazu */
    $query = "SELECT * FROM my_table";
    $result = mysql_query($query) or die("Dotaz nelze provést: " . mysql_error());

    /* Zobrazení výsledku v HTML */
    print "<table>\n";
    while ($line = mysql_fetch_array($result, MYSQL_ASSOC)) {
        print "\t<tr>\n";
        foreach ($line as $col_value) {
            print "\t\t<td>$col_value</td>\n";
        }
        print "\t</tr>\n";
    }
    print "</table>\n";

    /* Uvolnit výsledek */
    mysql_free_result($result);

    /* Odpojení od databáze */
    mysql_close($link);
?>

Obsah

mysql_affected_rows — Vrátí počet ovlivněných (změněných) záznamů v MySQL po posledním dotazu
mysql_change_user — Změní přihlášeného uživatele v současném spojení
mysql_client_encoding — Vrátí název znakové sady
mysql_close — Ukončí (zavře) MySQL spojení
mysql_connect — Vytvoří spojení s MySQL Serverem
mysql_create_db — Vytvoří MySQL databázi
mysql_data_seek — Přesune ukazatel na aktuální záznam
mysql_db_name — Vrátí seznam všech databází
mysql_db_query — Pošle MySQL dotaz
mysql_drop_db — Vymaže (odstraní) MySQL databázi
mysql_errno — Vrátí číslenou hodnotu chybové hlášky předchozího MySQL příkazu.
mysql_error — Vrátí text chybové zprávy předchozího MySQL příkazu.
mysql_escape_string — Upraví řetězec pro bezpečné použití v mysql_query.
mysql_fetch_array — Načte výsledný řádek do asociativního, čísleného pole nebo obojího.
mysql_fetch_assoc — Načte výsledný řádek do asociativního pole
mysql_fetch_field — Načte informace o sloupci z výsledku do proměnné objektu
mysql_fetch_lengths — Zjistí délku všech položek aktuálního výstupu
mysql_fetch_object — Načte výsledný záznam do proměnné objektu
mysql_fetch_row — Načte výsledný záznam do pole
mysql_field_flags — Načte příznaky sloupce tabulky
mysql_field_len — Vrací délku sloupce tabulky
mysql_field_name — Načte název sloupce tabulky
mysql_field_seek — Nastaví ukazatel na zadaný sloupec
mysql_field_table — Zjistí jméno tabulky, v níž se nachází uvedený sloupec
mysql_field_type — Vrací typ specifikovaného sloupce.
mysql_free_result — Uvolní výsledek z paměti
mysql_get_client_info — Načte verzi klientské knihovny MySQL
mysql_get_host_info — Načte informaci o hostu
mysql_get_proto_info — Načte informaci o protokolu MySQL
mysql_get_server_info — Načte informace o serveru MySQL
mysql_info — Vrací informace o posledním dotazu
mysql_insert_id — Vrací generovanou hodnotu id posledního příkazu INSERT
mysql_list_dbs — Načte všechny dostupné databáze na MySQL serveru
mysql_list_fields — Načte výsledek s obsahem sloupce
mysql_list_processes — List MySQL processes
mysql_list_tables — Načte všechny tabulky v MySQL databázi
mysql_num_fields — Vrací počet sloupců ve výsledku
mysql_num_rows — Vrací počet záznamů ve výsledku
mysql_pconnect — Otevře persistentní spojení s MySQL serverem
mysql_ping — Ověří spojení se serverem, případně, není-li spojení dostupné, pokusí se připojit znovu.
mysql_query — Pošle MySQL dotaz
mysql_real_escape_string — Upraví řetězec pro bezpečné použití v mysql_query.
mysql_result — Načte obsah jednoho sloupce tabulky
mysql_select_db — Nastaví MySQL databázi
mysql_set_charset — Sets the client character set
mysql_stat — Vrací aktuální stav systému
mysql_tablename — Načte jméno tabulky
mysql_thread_id — Vrací id aktuálního vlákna
mysql_unbuffered_query — Pošle SQL dotaz bez načtení a bufferování výsledných záznamů
Předcházející | Nahoru | Další
muscat_setup | Domů | mysql_affected_rows


mysql_affected_rows

(PHP 4, PHP 5, PECL mysql:1.0)

mysql_affected_rows — Vrátí počet ovlivněných (změněných) záznamů v MySQL po posledním dotazu

Popis

int mysql_affected_rows ( [resource $link_identifier] )

mysql_affected_rows() vrátí počet záznamů ovlivněných posledním použitím dotazu INSERT, UPDATE nebo DELETE, kterému odpovídá spojeni. Není-li identifikátor spojení uveden, použije se poslední spojení otevřené pomocí mysql_connect().

Poznámka: Používáte-li transakce, je nutné mysql_affected_rows() volat hned po dotazu INSERT, UPDATE nebo DELETE, nikoli až po potvrzení transakce.

Byl-li poslední dotaz DELETE bez části WHERE, budou smázany všechny záznamy z tabulky, ale tato funce vrátí nulu.

Poznámka: Při použití UPDATE, MySQL neuloží sloupce, ve kterých je nová hodnota shodná s původní. Toto může způsobit, že mysql_affected_rows() nemusí vždy přesně souhlasit se skutečným počtem ovlivněných řádků.

mysql_affected_rows() nelze použít s dotazy SELECT, ale jen s takovými, které mění záznamy. K zjištění počtu řádků vrácených dotazem SELECT použijte funkci mysql_num_rows().

Je-li poslední dotaz chybný, funkce vrátí -1.

Příklad 1243. Dotaz typu DELETE (mazání)

<?php
    /* připojení k databázi */
    mysql_pconnect("localhost", "mysql_uziv", "mysql_heslo") or
        die ("Nelze se připojit: " . mysql_error());

    /* tohle vrátí správný počet smazaných záznamů */
    mysql_query("DELETE FROM moje_tabulka WHERE id < 10");
    printf ("Smazáno záznamů: %d\n", mysql_affected_rows());

    /* bez použití klauzule where v dotazu typu DELETE, bude vrácena 0 */
    mysql_query("DELETE FROM moje_tabulka");
    printf ("Smazáno záznamů: %d\n", mysql_affected_rows());
?>

Předchozí příklad by měl následující výstup:

Smazáno záznamů: 10
Smazáno záznamů: 0

Příklad 1244. Dotaz typu UPDATE (změna)

<?php
    /* připojení k databázi */
    mysql_pconnect("localhost", "mysql_uziv", "mysql_heslo") or
        die ("Nelze se připojit: " . mysql_error());

    /* Změna záznamů */
    mysql_query("UPDATE moje_tabulka SET used=1 WHERE id < 10");
    printf ("Změněno záznamů: %d\n", mysql_affected_rows());
    mysql_query("COMMIT");
?>

Předchozí příklad by měl následující výstup:

Změněno záznamů: 10

Dále také: mysql_num_rows(), mysql_info().

Předcházející | Nahoru | Další
XCVIII. MySQL funkce | Domů | mysql_change_user


mysql_change_user

(No version information available, might be only in CVS)

mysql_change_user — Změní přihlášeného uživatele v současném spojení

Popis

int mysql_change_user ( string $user, string $password [, string $database [, resource $link_identifier]] )

mysql_change_user() změní přihlášeného uživatele současného aktivního spojení nebo spojení definované nepovinným parametrem spojeni. Je-li uveden parameter databaze nastaví se tato databáze jako výchozí, v opačném případě zůstane aktivní současná databáze definovaná ve změněném spojení. Vrací TRUE při úspěchu, FALSE při selhání.

Poznámka: Tato funkce byla přidána v PHP 3.0.13 a vyžaduje použití MySQL 3.23.3 nebo vyšší. Není dostupná v PHP 4.

Předcházející | Nahoru | Další
mysql_affected_rows | Domů | mysql_client_encoding


mysql_client_encoding

(PHP 4 >= 4.3.0, PHP 5, PECL mysql:1.0)

mysql_client_encoding — Vrátí název znakové sady

Popis

string mysql_client_encoding ( [resource $link_identifier] )

mysql_client_encoding() vrátí výchozí název znakové sady pro aktuální spojení.

Příklad 1245. mysql_client_encoding() p?íklad

<?php
$link = mysql_connect('localhost', 'mysql_uziv', 'mysql_heslo');
$charset = mysql_client_encoding($link);
printf ("aktuální znaková sada je %s\n", $charset);
?>

P?edchozí p?íklad m? 3/4 e mít následující výstup:

aktuální znaková sada je latin1

Viz. také: mysql_real_escape_string()

Předcházející | Nahoru | Další
mysql_change_user | Domů | mysql_close


mysql_close

(PHP 4, PHP 5, PECL mysql:1.0)

mysql_close — Ukončí (zavře) MySQL spojení

Popis

bool mysql_close ( [resource $link_identifier] )

Vrací TRUE při úspěchu, FALSE při selhání.

Funkce mysql_close() uzavře spojení s MySQL serverem, které je asociováno se určitým identikátorem spojení Pokud spojeni není zadán uzavře poslední otevřené spojení.

Použití mysql_close() není obvykle nutné, protože nepersistentní (netrvalá) otevřená spojení jsou zavřena automaticky po zpracování scriptu. Dále viz. uvolnění zdrojů.

Poznámka: mysql_close() neuzavře persistentní spojení otevřené pomocí mysql_pconnect().

Příklad 1246. Příklad k MySQL close

<?php
    $link = mysql_connect("kraemer", "marliesle", "tajne")
        or die("Nelze se připojit: " . mysql_error());
    print ("Spojení navázáno");
    mysql_close($link);
?>

Viz. také: mysql_connect(), a mysql_pconnect().

Předcházející | Nahoru | Další
mysql_client_encoding | Domů | mysql_connect


mysql_connect

(PHP 4, PHP 5, PECL mysql:1.0)

mysql_connect — Vytvoří spojení s MySQL Serverem

Popis

resource mysql_connect ( [string $server [, string $username [, string $password [, bool $new_link [, int $client_flags]]]]] )

Je-li spojení úspěšné vrátí identifikátor spojení v opačném případě FALSE.

mysql_connect() vytvoří spojení s MySQL serverem.
Nejsou-li zadány nepovinné parametry, použijí se následující hodnoty:
server = 'localhost:3306',
uziv_jmeno = jméno uživatele, pod kterým běží právě spuštěný skript a
heslo = bez hesla.

Parametr server může obsahovat číslo portu ve tvaru "hostname:port" nebo cestu k socketu ve tvaru ":/cesta/k/socketu" pro localhost.

Poznámka: Vždy když uvedete "localhost" nebo "localhost:port" jako server, klientská knihovna MySQL na toto nebude brát zřetel a pokusí se připojit na místní soket ("named pipe" na Windows). Ccete-li použít TCP/IP, uvedte "127.0.0.1" namísto "localhost". Pokud se klientská knihovna MySQL pokouší připojovat na špatný soket, měli byste nastavit správnou cestu jako mysql.default_host ve vaší PHP konfiguraci a nechat pole server prázdné.

Podpora pro ":port" byla přidána v PHP 3.0B4.

Podpora pro ":/cesta/k/socketu" byla přidána v PHP 3.0.10.

Chybovou hlášku lze potlačit přidáním @ před jméno funkce.

Bude-li funkce mysql_connect() zavolána podruhé se stejnými parametry, nebude vytvořeno nové spojení, ale použije se stávající a je vrácen i stejný identifikátor spojení. Nepovinný parametr nove_spojeni toto chování upravuje a každé volání mysql_connect() vytvoří vždy nové spojení v případě, že funkce mysql_connect() byla volána znovu se stejnými parametry. Parametr nastaveni_klienta může být kombinace konstant MYSQL_CLIENT_COMPRESS, MYSQL_CLIENT_IGNORE_SPACE a MYSQL_CLIENT_INTERACTIVE.

Poznámka: Parametr nove_spojeni byl přidán v PHP 4.2.0

Parametr nastaveni_klienta byl přidán v PHP 4.3.0

Spojení se serverem bude ukončeno automaticky po skončení běhu skriptu nebude-li dříve zavolána funkce mysql_close()

Příklad 1247. MySQL příklad spojení

<?php
    $link = mysql_connect("localhost", "uziv_jmeno", "tajne")
        or die("Nelze se připojit");
    print ("Spojení navázáno");
    mysql_close($link);
?>

Viz. také mysql_pconnect() a mysql_close().

Předcházející | Nahoru | Další
mysql_close | Domů | mysql_create_db


mysql_create_db

(PHP 4, PHP 5, PECL mysql:1.0)

mysql_create_db — Vytvoří MySQL databázi

Popis

bool mysql_create_db ( string $database_name [, resource $link_identifier] )

mysql_create_db() vytvoří na serveru identifikovaném parametrem spojení novou databázi.

Vrací TRUE při úspěchu, FALSE při selhání.

Příklad 1248. MySQL příklad vytvoření nové databáze

<?php
    $link = mysql_pconnect("kron", "jutta", "geheim")
        or exit("Nelze se připojit");
    if (mysql_create_db("moje_db")) {
        print ("Databáze byla vytvořena\n");
    } else {
        printf ("Chyba při vytváření databáze: %s\n", mysql_error ());
    }
?>

Kvůli zpětné kompatibilitě je možné použít i mysql_createdb(). Není to však doporučeno.

Poznámka: Také používání mysql_create_db() bylo zavrhnuto. K zakládání nových databází používejte funkci mysql_query() společně s příkazem SQL CREATE DATABASE.

Varování

Tato funkce není dostupná, pokud je modul MySQL zkompilován s MySQL 4.x klientskou knihovnou.

Viz také: mysql_drop_db(), mysql_query().

Předcházející | Nahoru | Další
mysql_connect | Domů | mysql_data_seek


mysql_data_seek

(PHP 4, PHP 5, PECL mysql:1.0)

mysql_data_seek — Přesune ukazatel na aktuální záznam

Popis

bool mysql_data_seek ( resource $result, int $row_number )

Vrací TRUE při úspěchu, FALSE při selhání.

mysql_data_seek() přesune interní ukazatel výsledku MySQL na záznam specifikovaný číslem záznamu. Následné volání funkce mysql_fetch_row() načte požadovaný záznam.

Není-li zadáno cislo_zaznamu začíná se od 0. Parametr cislo_zaznamu by mělo být číslo mezi 0 a (mysql_num_rows - 1).

Poznámka: Funkce mysql_data_seek() může být použita pouze ve spolupráci s mysql_query(), ne s mysql_unbuffered_query().

Příklad 1249. MySQL příklad přesunutí ukazatele

<?php
    $link = mysql_pconnect("kron", "jutta", "geheim")
        or die("Nelze se připojit");

    mysql_select_db("samp_db")
        or exit("Nelze vybrat databázi");

    $query = "SELECT last_name, first_name FROM friends";
    $result = mysql_query($query)
        or die("Chyba dotazu");

    // načtení záznamů v obráceném pořadí

    for ($i = mysql_num_rows($result) - 1; $i >=0; $i--) {
        if (!mysql_data_seek($result, $i)) {
            echo "Nelze nalézt záznam $i\n";
            continue;
        }

        if(!($row = mysql_fetch_object($result)))
            continue;

        echo "$row->last_name $row->first_name<br />\n";
    }

    mysql_free_result($result);
?>

Viz také: mysql_query(), mysql_num_rows().

Předcházející | Nahoru | Další
mysql_create_db | Domů | mysql_db_name


mysql_db_name

(PHP 4, PHP 5, PECL mysql:1.0)

mysql_db_name — Vrátí seznam všech databází

Popis

string mysql_db_name ( resource $result, int $row [, mixed $field] )

První parametr funkce mysql_db_name() obsahuje identifikátor volání mysql_list_dbs(). Parametr záznam určuje pořadí databáze ve výsledku.

Nastane-li chyba vrací FALSE. Použitím mysql_errno() a mysql_error() zjistíte chybovou hlášku.

Příklad 1250. mysql_db_name() příklad

<?php
error_reporting(E_ALL);

mysql_connect('dbhost', 'uziv_jmeno', 'heslo');
$db_list = mysql_list_dbs();

$i = 0;
$cnt = mysql_num_rows($db_list);
while ($i < $cnt) {
    echo mysql_db_name($db_list, $i) . "\n";
    $i++;
}
?>

Kvůli zpětné kompatibilitě lze použít i mysql_dbname(). Není to však doporučeno.

Předcházející | Nahoru | Další
mysql_data_seek | Domů | mysql_db_query


mysql_db_query

(PHP 4, PHP 5, PECL mysql:1.0)

mysql_db_query — Pošle MySQL dotaz

Popis

resource mysql_db_query ( string $database, string $query [, resource $link_identifier] )

Vrátí kladný identifikátor výsledku dotazu do určené databáze nebo FALSE nastane-li chyba. Funkce dále vrací TRUE/FALSE pro dotazy INSERT/UPDATE/DELETE pro indikace úspěch/chyba.

mysql_db_query() provede dotaz v databázi specifikované parametrem database. Není-li identifikátor databáze uveden, funkce se pokusí nalézt již otevřené spojení s MySQL serverem. Pokud není žádné aktivní spojení nalezeno, pokusí se vytvořit nové spojení s výchozími hodnotami funkce mysql_connect()

Uvědomte si, že tato funkce NEPŘEPÍNÁ zpět na databázi, ke které jste byli připojeni předtím. Jinými slovy, tuto funkci nemůžete použít k dočasnému spuštění sql dotazu nad jinou databázi, museli byste se přepnout zpět na tu původní. Uživatelům se namísto této funkce vřele doporučuje použití database.table syntaxe v sql dotazech.

Viz. také mysql_connect() a mysql_query().

Poznámka: Tato funkce není od verze PHP 4.0.6 podporována. Místo této funkce použijtemysql_select_db() a mysql_query().

Předcházející | Nahoru | Další
mysql_db_name | Domů | mysql_drop_db


mysql_drop_db

(PHP 4, PHP 5, PECL mysql:1.0)

mysql_drop_db — Vymaže (odstraní) MySQL databázi

Popis

bool mysql_drop_db ( string $database_name [, resource $link_identifier] )

mysql_drop_db() odstraní ze serveru databázi uvedeného jména pod specifikovaným identifikátorem spojení.

Vrací TRUE při úspěchu, FALSE při selhání.

Kvůli zpětné kompatibilitě se můžete setkat i s mysql_dropdb(). Nedoporučujeme však používat. Tento zápis nemusí být v příštích verzích PHP podporován.

Poznámka: Namísto používání funkce mysql_drop_db() se doporučuje ke smazání databáze upřednostnit funkci mysql_query(), do níž je vložen SQL dotaz s příkazem DROP DATABASE.

Viz. také: mysql_create_db() a mysql_query().

Předcházející | Nahoru | Další
mysql_db_query | Domů | mysql_errno


mysql_errno

(PHP 4, PHP 5, PECL mysql:1.0)

mysql_errno — Vrátí číslenou hodnotu chybové hlášky předchozího MySQL příkazu.

Popis

int mysql_errno ( [resource $link_identifier] )

Vrátí číselnou hodnotu chybové hlášky vyvolané poslední MySQL funkcí nebo 0 (nulu), pokud nenastala žádná chyba.

Chyby vrácené MySQL již nezpůsobují upozorňující chybové hlášení (warning). Potřebujete-li zjistit číselný kód chyby, použijte mysql_errno(), případně mysql_error() k zjištění textu chyby. Pamatujte, že tato funkce vrací chybový kód pouze naposledy vykonané MySQL funkce (netýká se mysql_error() a mysql_errno()), pokud ji tedy budete používat, musíte kontrolovat hodnotu ještě před voláním další MySQL funkce.

Příklad 1251. mysql_errno() example

<?php
    mysql_connect("localhost", "mysql_uziv", "mysql_heslo");

    mysql_select_db("neexististujicidb");
    echo mysql_errno() . ": " . mysql_error(). "\n";

    mysql_select_db("kossu");
    mysql_query("SELECT * FROM neexististujicitabulka");
    echo mysql_errno() . ": " . mysql_error() . "\n";
?>

Předchozí příklad by zobrazil následující výstup:

1049: Unknown database 'neexististujicidb'
1146: Table 'kossu.neexististujicitabulka' doesn't exist

Poznámka: Je-li jako volitelný parametr uveden i identifikátor spojení, použije se k vrácení chybového kódu. V opačném případě je použito poslední otevřené spojení.

Viz. také: mysql_error()

Předcházející | Nahoru | Další
mysql_drop_db | Domů | mysql_error


mysql_error

(PHP 4, PHP 5, PECL mysql:1.0)

mysql_error — Vrátí text chybové zprávy předchozího MySQL příkazu.

Popis

string mysql_error ( [resource $link_identifier] )

Vrátí text chybové zprávy posledního MySQL příkazu nebo '' (prázdný řetězec) pokud žádná chyba nenastala.

Chyby vrácené MySQL již nezpůsobují upozorňující chybové hlášení (warning). Potřebujete-li zjistit text chyby, použijte mysql_error(), případně mysql_errno() k zjištění čísleného kódu chyby. Pamatujte, že tato funkce vrací chybový kód pouze naposledy vykonané MySQL funkce (netýká se mysql_error() a mysql_errno()), pokud ji tedy budete používat, musíte kontrolovat hodnotu ještě před voláním další MySQL funkce.

Příklad 1252. mysql_errno() example

<?php
    mysql_connect("localhost", "mysql_uziv", "mysql_heslo");

    mysql_select_db("neexististujicidb");
    echo mysql_errno() . ": " . mysql_error(). "\n";

    mysql_select_db("kossu");
    mysql_query("SELECT * FROM neexististujicitabulka");
    echo mysql_errno() . ": " . mysql_error() . "\n";
?>

Předchozí příklad by zobrazil následující výstup:

1049: Unknown database 'neexististujicidb'
1146: Table 'kossu.neexististujicitabulka' doesn't exist

Poznámka: Je-li jako volitelný parametr uveden i identifikátor spojení, použije se k vrácení chybového kódu. V opačném případě je použito poslední otevřené spojení.

Viz. také: mysql_errno()

Předcházející | Nahoru | Další
mysql_errno | Domů | mysql_escape_string


mysql_escape_string

(PHP 4 >= 4.0.3, PHP 5, PECL mysql:1.0)

mysql_escape_string — Upraví řetězec pro bezpečné použití v mysql_query.

Popis

string mysql_escape_string ( string $unescaped_string )

Tato funkce opatří speciální znaky v neupraveny_retezec zpětným lomítkem pro bezpečné použití v mysql_query() (konce řádků jsou nahrazeny značkou \n atd.).

Poznámka: mysql_escape_string() nepřidává zpětná lomítka před znaky % a _.

Funkce je téměř identická s mysql_real_escape_string(). Vyjma toho, že mysql_real_escape_string() upraví řetězec podle nastavené znakové sady v aktuálním identifikátoru spojení. mysql_escape_string() nepoužívá identifikátor spojení a ani nebere v potaz aktuální znakovou sadu.

Příklad 1253. mysql_escape_string() příklad

<?php
    $item = "Zak's Laptop";
    $escaped_item = mysql_escape_string($item);
    printf ("Escaped string: %s\n", $escaped_item);
?>

Předchozí příklad by zobrazil následující výstup:

Escaped string: Zak\'s Laptop

Dále také: mysql_real_escape_string(), addslashes() a magic_quotes_gpc directive.

Předcházející | Nahoru | Další
mysql_error | Domů | mysql_fetch_array


mysql_fetch_array

(PHP 4, PHP 5, PECL mysql:1.0)

mysql_fetch_array — Načte výsledný řádek do asociativního, čísleného pole nebo obojího.

Popis

array mysql_fetch_array ( resource $result [, int $result_type] )

Funkce vrací pole hodnot načteného záznamu nebo FALSE, není-li žádný další řádek.

mysql_fetch_array() je rozšířenou verzí mysql_fetch_row(). Navíc jsou zde data uložena v poli nejen pod číselnými klíči, ale také pod asociativními textovými klíči jmenujícími se podle názvu sloupce sql tabulky.

Pokud dva nebo více sloupců mají stejný název, bude dostupná hodnota pouze toho posledního. Chcete-li přistupovat i k hodnotám ostatních sloupců, musíte k nim v sql dotazu vytvořit aliasy. Název klíče sloupce, k němuž je vytvořem alias, je vždy jméno aliasu a proto není možné použít originální jméno sloupce v sql tabulce (viz. 'sloupec' v následujícím příkladu).

Příklad 1254. Dotaz se zdvojenými názvy polí

select tabulka1.sloupec as sloupec1, tabulka2.sloupec as sloupec2
from tabulka1, tabulka2

Důležité ovšem je, že použití mysql_fetch_array() není nijak významně pomalejší než použití mysql_fetch_row(), pokud je její použití přidanou hodnotou.

Nepovinný druhý parametr result_type v mysql_fetch_array() je komstanta, která může nabývat následujících hodnot: MYSQL_ASSOC, MYSQL_NUM, a MYSQL_BOTH. Tato vlastnost byla přidána v PHP 3.0.7. Výchozí hodnota je MYSQL_BOTH.

Použitím MYSQL_BOTH získáte pole s asociativními i číselnými klíči. Použitím MYSQL_ASSOC získáte pole pouze s asociativními klíči (stejně funguje mysql_fetch_assoc()) a použitím MYSQL_NUM, pole obsahovat pouze číselné klíče (tak funguje mysql_fetch_row()).

Příklad 1255. mysql_fetch_array s MYSQL_NUM

<?php
    mysql_connect("localhost", "mysql_uziv", "mysql_heslo") or
        die("Nelze se spojit");
    mysql_select_db("mojedb");

    $result = mysql_query("SELECT id, jmeno FROM moje_tabulka");

    while ($row = mysql_fetch_array($result, MYSQL_NUM)) {
        printf ("ID: %s  Jméno: %s", $row[0], $row[1]);
    }

    mysql_free_result($result);
?>

Příklad 1256. mysql_fetch_array s MYSQL_ASSOC

<?php
    mysql_connect("localhost", "mysql_uziv", "mysql_heslo") or
        die("Nelze se spojit");
    mysql_select_db("mojedb");

    $result = mysql_query("SELECT id, jmeno FROM moje_table");

    while ($row = mysql_fetch_array($result, MYSQL_ASSOC)) {
        printf ("ID: %s  Jméno: %s", $row["id"], $row["jmeno"]);
    }

    mysql_free_result($result);
?>

Příklad 1257. mysql_fetch_array s MYSQL_BOTH

<?php
    mysql_connect("localhost", "mysql_uziv", "mysql_heslo") or
        die("Nelze se spojit");
    mysql_select_db("mojedb");

    $result = mysql_query("SELECT id, jmeno FROM moje_table");

    while ($row = mysql_fetch_array($result, MYSQL_BOTH)) {
        printf ("ID: %s  Jméno: %s", $row[0], $row["jmeno"]);
    }

    mysql_free_result($result);
?>

Viz také mysql_fetch_row() a mysql_fetch_assoc().

Předcházející | Nahoru | Další
mysql_escape_string | Domů | mysql_fetch_assoc


mysql_fetch_assoc

(PHP 4 >= 4.0.3, PHP 5, PECL mysql:1.0)

mysql_fetch_assoc — Načte výsledný řádek do asociativního pole

Popis

array mysql_fetch_assoc ( resource $result )

Funkce vrací asociativní pole hodnot vráceného záznamu nebo FALSE, není-li žádný další záznam.

mysql_fetch_assoc() je akvalentem k mysql_fetch_array() s nepovinným druhým parametrem MYSQL_ASSOC, což vrací pouze asociativní pole. Pokud potřebujete používat číselné indexy spolu s asociativními, použijte mysql_fetch_array().

Pokud dva nebo více sloupců mají stejný název, bude dostupná hodnota pouze toho posledního. Chcete-li přistupovat i k hodnotám ostatních sloupců, musíte k nim v sql dotazu vytvořit aliasy. Název klíče sloupce, k němuž je vytvořem alias, je vždy jméno aliasu a proto není možné použít originální jméno sloupce v sql tabulce. Podívejte se na vysvětlení použití aliasů v příkladu u mysql_fetch_array().

Důležité ovšem je, že použití mysql_fetch_assoc() není nijak významně pomalejší než použití mysql_fetch_row(), pokud je její použití přidanou hodnotou.

Příklad 1258. Rozšířený příklad mysql_fetch_assoc()

<?php

    $conn = mysql_connect("localhost", "mysql_user", "mysql_password");

    if (!$conn) {
        echo "Nelze se spojit s DB: " . mysql_error();
        exit;
    }

    if (!mysql_select_db("mydbname")) {
        echo "Nelze vybrat mydbname: " . mysql_error();
        exit;
    }

    $sql = "SELECT id as userid, fullname, userstatus
            FROM   sometable
            WHERE  userstatus = 1";

    $result = mysql_query($sql);

    if (!$result) {
        echo "Zpracování dotazu nebylo úspěšné ($sql) na DB: " . mysql_error();
        exit;
    }

    if (mysql_num_rows($result) == 0) {
        echo "Nenalezeny žádné řádky, nic k zobrazení, takže končím.";
        exit;
    }

    // Pokud nějaké záznamy dat existují, vlozží každý záznam do asociativního pole $row.
    // Tip: Očekáváte-li pouze jeden záznam, můžete vynechat smyčku.
    // Tip: Přidáte-li do následující smyčky extract($row);, vytvoří se rovnou proměnné $userid, $fullname a $userstatus
    while ($row = mysql_fetch_assoc($result)) {
        echo $row["userid"];
        echo $row["fullname"];
        echo $row["userstatus"];
    }

    mysql_free_result($result);

?>

Pro další detaily viz. také
mysql_fetch_row(),
mysql_fetch_array(),
mysql_query() a
mysql_error().

Předcházející | Nahoru | Další
mysql_fetch_array | Domů | mysql_fetch_field


mysql_fetch_field

(PHP 4, PHP 5, PECL mysql:1.0)

mysql_fetch_field — Načte informace o sloupci z výsledku do proměnné objektu

Popis

object mysql_fetch_field ( resource $result [, int $field_offset] )

Vrátí objekt obsahující informace o sloupci z výsledku.

mysql_fetch_field() můžete použít v případě, že potřebujete získat informace o sloupci z určitého výsledku. Není-li specifikováno pořadí sloupce (počítáno do nuly), funkce načte informace o prvním následujícím ještě nenačteném sloupci.

Vlastnosti objektu jsou:

  • name - název sloupce
  • table - název tabulky, v níž se tento sloupec nachází
  • max_length - maximální délka sloupce ve znacích
  • not_null - 1 pokud sloupec nemůže být NULL
  • primary_key - 1 pokud je sloupec primární klíč
  • unique_key - 1 pokud je sloupec unikátní klíč
  • multiple_key - 1 pokud je sloupec jiný než unikátní klíč
  • numeric - 1 pokud je sloupec číslo
  • blob - 1 pokud je sloupec BLOB
  • type - typ sloupce
  • unsigned - 1 pokud je sloupec bez znaménka
  • zerofill - 1 pokud je sloupec dolpněn nulami na svou velikost

Příklad 1259. mysql_fetch_field()

<?php
mysql_connect('localhost:3306', $user, $password)
    or die ("Nelze se připojit: " . mysql_error());
mysql_select_db("databaze");
$result = mysql_query("select * from tabulka")
    or die("Chyba dotazu: " . mysql_error());
# vrátí informace o sloupci
$i = 0;
while ($i < mysql_num_fields($result)) {
    echo "Informace pro sloupec $i:<br />\n";
    $meta = mysql_fetch_field($result);
    if (!$meta) {
        echo "Nejsou dostupné žádné informace<br />\n";
    }
    echo "<pre>
blob:         $meta->blob
max_length:   $meta->max_length
multiple_key: $meta->multiple_key
name:         $meta->name
not_null:     $meta->not_null
numeric:      $meta->numeric
primary_key:  $meta->primary_key
table:        $meta->table
type:         $meta->type
unique_key:   $meta->unique_key
unsigned:     $meta->unsigned
zerofill:     $meta->zerofill
</pre>";
    $i++;
}
mysql_free_result($result);
?>

Viz. také mysql_field_seek().

Předcházející | Nahoru | Další
mysql_fetch_assoc | Domů | mysql_fetch_lengths


mysql_fetch_lengths

(PHP 4, PHP 5, PECL mysql:1.0)

mysql_fetch_lengths — Zjistí délku všech položek aktuálního výstupu

Popis

array mysql_fetch_lengths ( resource $result )

Vrácí pole obsahující délku každého sloupce v posledně načteném záznamu pomocí mysql_fetch_row(), nebo FALSE dojde-li k chybě.

     mysql_fetch_lengths() obsahuje délky hodnot všech
vrácených sloupců posledního načteného záznamu pomocí
mysql_fetch_row(),
mysql_fetch_array(), a
mysql_fetch_object() v poli, začínajícího klíčem 0.

Viz. také: mysql_fetch_row().

Předcházející | Nahoru | Další
mysql_fetch_field | Domů | mysql_fetch_object


mysql_fetch_object

(PHP 4, PHP 5, PECL mysql:1.0)

mysql_fetch_object — Načte výsledný záznam do proměnné objektu

Popis

object mysql_fetch_object ( resource $result [, string $class_name [, array $params]] )

Vrácí objekt, jehož proměnné obsahují hodnoty načteného záznamu nebo FALSE není-li žádný další záznam.

mysql_fetch_object() je obdobou mysql_fetch_array(), s jedním rozdílem - narozdíl od pole, je vrácen objekt. Což znamená, že k hodnotám výsledku lze přistupovat pouze přes názvy sloupců a nikoli přes jejich číselné klíče (název vlastnosti nemůže být číslo).

<?php

/* tohle je správný zápis */
echo $row->field;
/* a toto je chybný zápis */
echo $row->0;

?>

Rychlostně je tato funkce identická s mysql_fetch_array(), a téměr tak rychlá jako mysql_fetch_row() (rozdíl je nevýznamný).

Příklad 1260. mysql_fetch_object() příklad

<?php
mysql_connect("localhost", "mysql_uziv", "mysql_heslo");
mysql_select_db($db);
$result = mysql_query("select uziv_id, celejmeno from tabulka");
while ($row = mysql_fetch_object($result)) {
    echo $row->uziv_id;
    echo $row->celejmeno;
}
mysql_free_result($result);
?>

Viz. také: mysql_fetch_array() a mysql_fetch_row().

Předcházející | Nahoru | Další
mysql_fetch_lengths | Domů | mysql_fetch_row


mysql_fetch_row

(PHP 4, PHP 5, PECL mysql:1.0)

mysql_fetch_row — Načte výsledný záznam do pole

Popis

array mysql_fetch_row ( resource $result )

Funkce vrací číslené pole hodnot načteného záznamu nebo FALSE, není-li žádný další záznam.

mysql_fetch_row() načte jeden záznam výsledku do pole s číslenými klíči. Každá hodnota sloupce je samostatná hodnota pole; klíče jsou číslovány od 0.

Další volání mysql_fetch_row() vrátí následující záznam výsledku, nebo FALSE není-li žádný další záznam.

Viz. také: mysql_fetch_array(),
mysql_fetch_object(),
mysql_data_seek(),
mysql_fetch_lengths() a
mysql_result().

Předcházející | Nahoru | Další
mysql_fetch_object | Domů | mysql_field_flags


mysql_field_flags

(PHP 4, PHP 5, PECL mysql:1.0)

mysql_field_flags — Načte příznaky sloupce tabulky

Popis

string mysql_field_flags ( resource $result, int $field_offset )

mysql_field_flags() vrací další informace o uvedeném sloupci tabulky. Každý příznak je reprezentován jedním slovem a jsou od sebe odděleny mezerou tak, že lze výstup snadno rozdělit pomocí funkce explode().

Vrácené příznaky mohou být následující (jestliže je vaše verze MySQL podporuje): "not_null", "primary_key", "unique_key", "multiple_key", "blob", "unsigned", "zerofill", "binary", "enum", "auto_increment", "timestamp".

Z důvodů zpětné kompatibility můžete také narazit na funkci mysql_fieldflags(). Tuto funkci však nedoporučujeme používat, neboť nemusí být již v dalších verzích PHP podporována.

Předcházející | Nahoru | Další
mysql_fetch_row | Domů | mysql_field_len


mysql_field_len

(PHP 4, PHP 5, PECL mysql:1.0)

mysql_field_len — Vrací délku sloupce tabulky

Popis

int mysql_field_len ( resource $result, int $field_offset )

mysql_field_len() vrací délku uvedeného sloupce v tabulce.

Z důvodů zpětné kompatibility můžete také narazit na funkci mysql_fieldlen(). Tuto funkci však nedoporučujeme používat, neboť nemusí být již v dalších verzích PHP podporována.

Předcházející | Nahoru | Další
mysql_field_flags | Domů | mysql_field_name


mysql_field_name

(PHP 4, PHP 5, PECL mysql:1.0)

mysql_field_name — Načte název sloupce tabulky

Popis

string mysql_field_name ( resource $result, int $field_offset )

mysql_field_name() vrací jméno uvedeného sloupce v tabulce. výsledek musí být platný identifikátor spojení a číslo_sloupce je pořadí sloupce v tabulce.

Poznámka: číslo_sloupce začíná nulou.

Např. pořadí třetího sloupce tabulky bude číslo 2, čtvrtý sloupec v tabulce má číslo 3, atd.

Příklad 1261. mysql_field_name() příklad

/* Tabulka &quot;uzivatele&quot; má následující tři sloupce::
 *   uziv_id
 *   jmeno
 *   heslo.
 */
 $link = mysql_connect('localhost', $uzivatel, "tajne");
mysql_select_db($dbjmeno, $link)
    or die("Nelze se spojit s$dbjmeno: " . mysql_error());
$res = mysql_query("select * from uzivatele", $link);

echo mysql_field_name($res, 0) . "\n";
echo mysql_field_name($res, 2);

Předchozí příklad by zobrazil následující výstup:

uziv_id
heslo

Z důvodů zpětné kompatibility můžete také narazit na funkci mysql_fieldname(). Tuto funkci však nedoporučujeme používat, neboť nemusí být již v dalších verzích PHP podporována.

Předcházející | Nahoru | Další
mysql_field_len | Domů | mysql_field_seek


mysql_field_seek

(PHP 4, PHP 5, PECL mysql:1.0)

mysql_field_seek — Nastaví ukazatel na zadaný sloupec

Popis

bool mysql_field_seek ( resource $result, int $field_offset )

Nastaví ukazatel na určený sloupec. Pokud následující volání funkce mysql_fetch_field() nemá zadán druhý parametr (číselné pořadí sloupce), vrátí informace o sloupci určeném právě v mysql_field_seek().

Viz. také: mysql_fetch_field().

Předcházející | Nahoru | Další
mysql_field_name | Domů | mysql_field_table


mysql_field_table

(PHP 4, PHP 5, PECL mysql:1.0)

mysql_field_table — Zjistí jméno tabulky, v níž se nachází uvedený sloupec

Popis

string mysql_field_table ( resource $result, int $field_offset )

Vrácí jméno tabulky, která obsahuje uvedený sloupec.

Z důvodů zpětné kompatibility můžete také narazit na funkci mysql_fieldtable(). Tuto funkci však nedoporučujeme používat, neboť nemusí být již v dalších verzích PHP podporována.

Předcházející | Nahoru | Další
mysql_field_seek | Domů | mysql_field_type


mysql_field_type

(PHP 4, PHP 5, PECL mysql:1.0)

mysql_field_type — Vrací typ specifikovaného sloupce.

Popis

string mysql_field_type ( resource $result, int $field_offset )

mysql_field_type() je podobná funkci mysql_field_name(). Argumenty jsou totožné, pouze namísto jméno vrací typ sloupce. Sloupec může být typu: "int", "real", "string", "blob", a další detailně popsané v » MySQL dokumentaci.

Příklad 1262. MySQL typy sloupců

<?php
    mysql_connect("localhost", "mysql_uziv", "mysql_heslo");
    mysql_select_db("mysql");
    $result = mysql_query("SELECT * FROM func");
    $fields = mysql_num_fields($result);
    $rows   = mysql_num_rows($result);
    $table = mysql_field_table($result, 0);
    echo "Tvá tabulka '".$table."' má ".$fields." sloupců a ".$rows." záznam(ů)\n";
    echo "Tabulka má následující sloupce:\n";
    for ($i=0; $i < $fields; $i++) {
        $type  = mysql_field_type($result, $i);
        $name  = mysql_field_name($result, $i);
        $len   = mysql_field_len($result, $i);
        $flags = mysql_field_flags($result, $i);
        echo $type." ".$name." ".$len." ".$flags."\n";
    }
mysql_free_result($result);
mysql_close();

?>

Předchozí příklad by mohl mít následující výstup:

Tvá tabulka 'func' má 4 sloupců a 1 záznam(ů)
Tabulka má následující sloupce:
string jmeno 64 not_null primary_key binary
int cislo 1 not_null
string poznamka 128 not_null
string typ 9 not_null enum

Z důvodů zpětné kompatibility můžete také narazit na funkci mysql_fieldtype(). Tuto funkci však nedoporučujeme používat, neboť nemusí být již v dalších verzích PHP podporována.

Předcházející | Nahoru | Další
mysql_field_table | Domů | mysql_free_result


mysql_free_result

(PHP 4, PHP 5, PECL mysql:1.0)

mysql_free_result — Uvolní výsledek z paměti

Popis

bool mysql_free_result ( resource $result )

mysql_free_result() uvolní pamět obsazenou výsledkem definovaným identifikátorem spojení vysledek.

mysql_free_result() je vhodné používat pouze v případě, kdy vám záleží na tom, jak moc paměti je v průběhu skriptu použíto pro vykonaný dotaz a když výsledek dotazu je příliš velký. Všechna paměť obsazená výsledky spojení bude jinak automaticky ulovněna až s koncem běhu skriptu.

Vrací TRUE při úspěchu, FALSE při selhání.

Z důvodů zpětné kompatibility můžete také narazit na funkci mysql_freeresult(). Tuto funkci však nedoporučujeme používat, neboť nemusí být již v dalších verzích PHP podporována.

Předcházející | Nahoru | Další
mysql_field_type | Domů | mysql_get_client_info


mysql_get_client_info

(PHP 4 >= 4.0.5, PHP 5, PECL mysql:1.0)

mysql_get_client_info — Načte verzi klientské knihovny MySQL

Popis

string mysql_get_client_info ( void )

mysql_get_client_info() vrací řetězec obsahující verzi používané klientské knihovny MySQL.

Příklad 1263. mysql_get_client_info Příklad

<?php
    printf ("MySQL klient info: %s\n", mysql_get_client_info());
?>

TPředchozí příklad by mohl mít následující výstup:

MySQL klient info: 3.23.39

Dále také: mysql_get_host_info(),
          mysql_get_proto_info() z
          mysql_get_server_info().

Předcházející | Nahoru | Další
mysql_free_result | Domů | mysql_get_host_info


mysql_get_host_info

(PHP 4 >= 4.0.5, PHP 5, PECL mysql:1.0)

mysql_get_host_info — Načte informaci o hostu

Popis

string mysql_get_host_info ( [resource $link_identifier] )

mysql_get_host_info() vrací řetězec popisující použitý typ spojení v spojeni, obsahující server host name. Pokud je spojeni vynecháno, použije posledně otevřené spojení.

Příklad 1264. mysql_get_host_info Příklad

<?php
    mysql_connect("localhost", "mysql_uziv", "mysql_heslod") or
        die("Nelze se spojit: " . mysql_error());
    printf ("MySQL host info: %s\n", mysql_get_host_info());
?>

Předchozí příklad by mohl mít následující výstup:

MySQL host info: Localhost via UNIX socket

Dále také: mysql_get_client_info(),
          mysql_get_proto_info() and
          mysql_get_server_info().

Předcházející | Nahoru | Další
mysql_get_client_info | Domů | mysql_get_proto_info


mysql_get_proto_info

(PHP 4 >= 4.0.5, PHP 5, PECL mysql:1.0)

mysql_get_proto_info — Načte informaci o protokolu MySQL

Popis

int mysql_get_proto_info ( [resource $link_identifier] )

mysql_get_proto_info() vrací číslo verze protokolu v použitém spojeni. Je-li spojeni vynecháno, použije se posledně otevřené spojení.

Příklad 1265. mysql_get_proto_info Příklad

<?php
    mysql_connect("localhost", "mysql_uziv", "mysql_heslo") or
        die("Nelze se spojit: " . mysql_error());
    printf ("Verze protokolu MySQL: %s\n", mysql_get_proto_info());
?>

Předchozí příklad by mohl mít následující výstup:

Verze protokolu MySQL: 10

Dále také: mysql_get_client_info(),
          mysql_get_host_info() a
          mysql_get_server_info().

Předcházející | Nahoru | Další
mysql_get_host_info | Domů | mysql_get_server_info


mysql_get_server_info

(PHP 4 >= 4.0.5, PHP 5, PECL mysql:1.0)

mysql_get_server_info — Načte informace o serveru MySQL

Popis

string mysql_get_server_info ( [resource $link_identifier] )

mysql_get_server_info() vrací verzi serveru v použitém spojeni. Pokud je spojeni vynecháno, použije se posledně otevřené spojení.

Příklad 1266. mysql_get_server_info Příklad

<?php
    mysql_connect("localhost", "mysql_uziv", "mysql_heslo") or
        die("Nelze se spojit: " . mysql_error());
    printf ("Verze MySQL serveru: %s\n", mysql_get_server_info());
?>

Předchozí příklad by mohl mít následující výstup:

Verze MySQL serveru: 4.0.1-alpha

Dále také: mysql_get_client_info(),
          mysql_get_host_info() a
          mysql_get_proto_info().

Předcházející | Nahoru | Další
mysql_get_proto_info | Domů | mysql_info


mysql_info

(PHP 4 >= 4.3.0, PHP 5, PECL mysql:1.0)

mysql_info — Vrací informace o posledním dotazu

Popis

string mysql_info ( [resource $link_identifier] )

mysql_info() vrací detailní informace o posledním dotazu v použitém spojeni. Pokud spojeni není uvedeno, použije se poslední otevřené spojení.

mysql_info() vrací řetezec z všemi dotazy vylistovanými níže. Pro všechny ostatní FALSE. Formát řetězce je závislý na použitém typu dotazu.

Příklad 1267. Příslušné MySQL dotazy

INSERT INTO ... SELECT ...
String format: Records: 23 Duplicates: 0 Warnings: 0
INSERT INTO ... VALUES (...),(...),(...)...
String format: Records: 37 Duplicates: 0 Warnings: 0
LOAD DATA INFILE ...
String format: Records: 42 Deleted: 0 Skipped: 0 Warnings: 0
ALTER TABLE
String format: Records: 60 Duplicates: 0 Warnings: 0
UPDATE
String format: Rows matched: 65 Changed: 65 Warnings: 0

Čísla uvedená v příkladu jsou jen pro ilustraci; jejich hodnoty budou shodné s výsledkem dotazu.

Poznámka: mysql_info() vrací hodnotu jinou než FALSE v případě dotazu INSERT ... VALUES, ve kterém jsou uvedeny hodnoty pro zápis více záznamů najednou.

Dále také: mysql_affected_rows()

Předcházející | Nahoru | Další
mysql_get_server_info | Domů | mysql_insert_id


mysql_insert_id

(PHP 4, PHP 5, PECL mysql:1.0)

mysql_insert_id — Vrací generovanou hodnotu id posledního příkazu INSERT

Popis

int mysql_insert_id ( [resource $link_identifier] )

mysql_insert_id() vrací hodnotu ID vygenerovanou pro sloupec AUTO_INCREMENT předchozím dotazem typu INSERT indetifikovaným parametrem spojeni. Pokud je spojeni vynecháno, použije se posledně otevřené spojení.

mysql_insert_id() vrací 0 pokud pro předchozí dotaz nebyla vygenerována žádná hodnota pomocí AUTO_INCREMENT. I v případě, že potřebujete hodnotu použít později, dbejte na to, abyste funkci mysql_insert_id() volali okamžitě po dotazu, pro nějž byla vygenerována hodnota pomocí AUTO_INCREMENT.

Poznámka: Hodnota MySQL SQL funkce LAST_INSERT_ID() vždy obsahuje nejvyšší posledně vygenerovanou hodnotu AUTO_INCREMENT a není mezi dalšími dotazy vynulována.

Varování

mysql_insert_id() převádí typ vrácený nativní MySQL C API funkcí mysql_insert_id() z typu long (ekvivalent v PHP int). Pokud je sloupec AUTO_INCREMENT typu BIGINT, hodnota vrácená mysql_insert_id() bude nesprávná (pouze v případě, že i samotná hodnota bude mít velikost BIGINT). Místo toho použijte vnitřní MySQL SQL funkci LAST_INSERT_ID() přímo v SQL dotazu.

Příklad 1268. mysql_insert_id Příklad

<?php
    mysql_connect("localhost", "mysql_uziv", "mysql_heslo") or
        die("Nelze se spojit: " . mysql_error());
    mysql_select_db("mojedb");

    mysql_query("INSERT INTO mojetabulka (produkt) values ('kosa')");
    printf ("Posledně vložený záznam má id: %d\n", mysql_insert_id());
?>

Dále také: mysql_query().

Předcházející | Nahoru | Další
mysql_info | Domů | mysql_list_dbs


mysql_list_dbs

(PHP 4, PHP 5, PECL mysql:1.0)

mysql_list_dbs — Načte všechny dostupné databáze na MySQL serveru

Popis

resource mysql_list_dbs ( [resource $link_identifier] )

mysql_list_dbs() vrací ukazatel výsledku obsahující databáze dostupné na aktuálním mysql démonovi. Lze použít například společně s funkcí mysql_tablename() k získání názvů tabulek, případně jiných funkcích k získání záznamů z tabulkek jako například mysql_fetch_array().

Příklad 1269. mysql_list_dbs() příklad

<?php
$link = mysql_connect('localhost', 'mojejmeno', 'tajne');
$db_list = mysql_list_dbs($link);

while ($row = mysql_fetch_object($db_list)) {
    echo $row->Database . "\n";
}
?>

Předchozí příklad by měl následující výstup:

databaze1
databaze2
databaze3
...

Poznámka: Předchozí kód by tak snadno pracoval i s mysql_fetch_row() či podobnými funkcemi.

Z důvodů zpětné kompatibility můžete také narazit na funkci mysql_listdbs(). Tuto funkci však nedoporučujeme používat, neboť nemusí být již v dalších verzích PHP podporována.

Viz. také mysql_db_name().

Předcházející | Nahoru | Další
mysql_insert_id | Domů | mysql_list_fields


mysql_list_fields

(PHP 4, PHP 5, PECL mysql:1.0)

mysql_list_fields — Načte výsledek s obsahem sloupce

Popis

resource mysql_list_fields ( string $database_name, string $table_name [, resource $link_identifier] )

     mysql_list_fields() vrací ukazatel výsledku o sloupcích
uvedené tabulky. Argumentu jsou jméno databáze a jméno tabulky.
Vrácený ukazatel výsledku může být použit spolu s funkcemi
mysql_field_flags(),
mysql_field_len(),
mysql_field_name(), a
mysql_field_type().

Příklad 1270. mysql_list_fields() příklad

<?php
$link = mysql_connect('localhost', 'mojejmeno', 'tajne');

$fields = mysql_list_fields("databaze1", "tabulka1", $link);
$columns = mysql_num_fields($fields);

for ($i = 0; $i < $columns; $i++) {
    echo mysql_field_name($fields, $i) . "\n";
}
?>

Předchozí příklad by mohl mít následující výstup:

sloupec1
sloupec2
sloupec3
...

Z důvodů zpětné kompatibility můžete také narazit na funkci mysql_listfields(). Tuto funkci však nedoporučujeme používat, neboť nemusí být již v dalších verzích PHP podporována.

Předcházející | Nahoru | Další
mysql_list_dbs | Domů | mysql_list_processes


mysql_list_processes

(PHP 4 >= 4.3.0, PHP 5, PECL mysql:1.0)

mysql_list_processes — List MySQL processes

Popis

resource mysql_list_processes ( [resource $link_identifier] )

mysql_list_processes() vrací ukazatel popisující aktuální vlákna serveru.

Příklad 1271. mysql_list_processes() příklad

<?php
$link = mysql_connect('localhost', 'mysql_jmeno', 'mysql_heslo');

$result = mysql_list_processes($link);
while ($row = mysql_fetch_row($result)){
    printf("%s %s %s %s %s\n", $row["Id"], $row["Host"], $row["db"],
       $row["Command"], $row["Time"]);
}
mysql_free_result ($result);
?>

Předchozí příklad by zobrazit následující výstup:

1 localhost test Processlist 0
4 localhost mysql sleep 5

Dále také: mysql_thread_id()

Předcházející | Nahoru | Další
mysql_list_fields | Domů | mysql_list_tables


mysql_list_tables

(PHP 4, PHP 5, PECL mysql:1.0)

mysql_list_tables — Načte všechny tabulky v MySQL databázi

Popis

resource mysql_list_tables ( string $database [, resource $link_identifier] )

mysql_list_tables() Na základě jména databáze vrací ukazatel výsledku na tabulky přesně tak jako mysql_db_query(). Použítím funkce mysql_tablename() můžete zjistit jména všech tabulek z ukazatele výsledku nebo použít jiné funkce k zjištění dalších informací jako např. mysql_fetch_array().

Parametr database je název databáze, z které se mají číst jména tabulky. Dojde-li k chybě, mysql_list_tables() vrací FALSE.

Z důvodů zpětné kompatibility můžete také narazit na funkci mysql_listtables(). Tuto funkci však nedoporučujeme používat, neboť nemusí být již v dalších verzích PHP podporována.

Poznámka: Tato funkce byla zavržena, dále ji nepoužívejte. Používejte místo ní příkaz SHOW TABLES FROM DATABASE.

Příklad 1272. mysql_list_tables Příklad

<?php
    $dbname = 'mysql_dbjmeno';

    if (!mysql_connect('mysql_host', 'mysql_uziv', 'mysql_heslo')) {
        print 'Nelze se spojit';
        exit;
    }

    $result = mysql_list_tables($dbname);

    if (!$result) {
        print "Chyba DB, nelze číst tabulky\n";
        print 'MySQL chyba: ' . mysql_error();
        exit;
    }

    while ($row = mysql_fetch_row($result)) {
        print "Tabulka: $row[0]\n";
    }

    mysql_free_result($result);
?>

Dále také: mysql_list_dbs(), a mysql_tablename().

Předcházející | Nahoru | Další
mysql_list_processes | Domů | mysql_num_fields


mysql_num_fields

(PHP 4, PHP 5, PECL mysql:1.0)

mysql_num_fields — Vrací počet sloupců ve výsledku

Popis

int mysql_num_fields ( resource $result )

mysql_num_fields() vrací počet sloupců získaných sql dotazem ve výsledku výsledek

Viz. také:
mysql_db_query(),
mysql_query(),
mysql_fetch_field() a
mysql_num_rows().

Příklad 1273. mysql_num_fields() příklad

<?php
$r = mysql_query("SELECT sloupec1, sloupec2, sloupec3 FROM tabulka";
$pocet_sloupcu = mysql_num_fields($r);
echo "Počet sloupců ve výsledku: " . $pocet_sloupcu;

Předchozí příklad by měl následující výstup:

Počet sloupců ve výsledku: 3

Z důvodů zpětné kompatibility můžete také narazit na funkci mysql_numfields(). Tuto funkci však nedoporučujeme používat, neboť nemusí být již v dalších verzích PHP podporována.

Předcházející | Nahoru | Další
mysql_list_tables | Domů | mysql_num_rows


mysql_num_rows

(PHP 4, PHP 5, PECL mysql:1.0)

mysql_num_rows — Vrací počet záznamů ve výsledku

Popis

int mysql_num_rows ( resource $result )

mysql_num_rows() vrací počet záznamů ve výsledku dotazu. Tento příkaz je použitelný pouze pro dotaz typu SELECT. Potřebujete-li získat počet záznamů ovlivněných dotazy INSERT, UPDATE nebo DELETE, použijte mysql_affected_rows().

Příklad 1274. mysql_num_rows() příklad

<?php

$link = mysql_connect("localhost", "mysql_uziv", "mysql_heslo");
mysql_select_db("databaze", $link);

$result = mysql_query("SELECT * FROM tabulka1", $link);
$num_rows = mysql_num_rows($result);

echo "Řádků: $num_rows\n";

?>

Poznámka: Používáte-li mysql_unbuffered_query(), mysql_num_rows() nebude vracet správnou hodnotu dokud nebudou přijaty všechny záznamy ve výsledku.

Dále také:
mysql_affected_rows(),
mysql_connect(),
mysql_data_seek(),
mysql_select_db() a
mysql_query().

Z důvodů zpětné kompatibility můžete také narazit na funkci mysql_numrows(). Tuto funkci však nedoporučujeme používat, neboť nemusí být již v dalších verzích PHP podporována.

Předcházející | Nahoru | Další
mysql_num_fields | Domů | mysql_pconnect


mysql_pconnect

(PHP 4, PHP 5, PECL mysql:1.0)

mysql_pconnect — Otevře persistentní spojení s MySQL serverem

Popis

resource mysql_pconnect ( [string $server [, string $username [, string $password [, int $client_flags]]]] )

Vytvoří persistentní (trvalé) spojení s MySQL serverem a vrací identifikátor spojení. Při neúspěšném pokusu o spojení vrací FALSE.

mysql_pconnect() otevře spojení s MySQL server. Je-li funkce volána bez nepovinných paramtrů, jsou u nich předpokládány následující výchozí hodnoty: server = 'localhost:3306', jmeno = jméno vlastníka procesu a heslo = prázdné heslo. Parametr nastaveni_klienta může být kombinací konstant MYSQL_CLIENT_COMPRESS, MYSQL_CLIENT_IGNORE_SPACE nebo MYSQL_CLIENT_INTERACTIVE.

Parametr server může obsahovat číslo portu ve stylu "hostname:port" nebo cestu k soketu ve stylu ":/cesta/k/soketu" pro localhost.

Poznámka: Podpora pro ":port" byla přidána v PHP 3.0B4.

Podpora pro ":/cesta/k/soketu" byla přidána v PHP 3.0.10.

Funkce mysql_pconnect() je velmi podobná funkci mysql_connect() s dvěma hlavními rozdíly.

Za prvé, funkce se nejprve pokusí nalézt již existující (persistentní) spojení otevřené na stejném portu pod stejným jménem a heslem. Je-li takové spojení nalezeno, použije se namísto vytváření nového.

Za druhé, spojení s SQL serverem nebude uzavřeno při ukončení běhu skriptu. Zůstane otevřeno pro použití v dalších skriptech, které teprve budou spouštěny (mysql_close() neuzavře persistentní spojení vytvořené pomocí mysql_pconnect()).

Nepovinný parametr nastaveni_klientabyl přidán v PHP 4.3.0.

Proto je tento typ spojení nazýván jako 'persistentní' - trvalý.

Poznámka: Persistentní spojení funguje pouze v případě, kdy je PHP spuštěno jako modul (nikoli CGI). Více o této problematice naleznete v sekci Persistentní databázová spojení.

Varování

Používání persistetního spojení může vyžadovat malou úpravu v konfiguraci Apache a MySQL k zajištění nepřekročení maximálního limitu povolených připojení k MySQL.

Předcházející | Nahoru | Další
mysql_num_rows | Domů | mysql_ping


mysql_ping

(PHP 4 >= 4.3.0, PHP 5, PECL mysql:1.0)

mysql_ping — Ověří spojení se serverem, případně, není-li spojení dostupné, pokusí se připojit znovu.

Popis

bool mysql_ping ( [resource $link_identifier] )

mysql_ping() zkouší, zda je či není spojení se serverem. V případě, že spojení je ztraceno, automaticky se pokusí vytvořit nové spojení. Tato funkce může být použita ve scriptech, které zůstávají dlouho dobu nečinné k zjištění, zda je sepojení se serverem již zavřeno a v případě nutnosti navážou automaticky spojení nové. mysql_ping() vrací TRUE pokud je spojení navázáno, jinak FALSE.

Dále také: mysql_thread_id(), mysql_list_processes().

Předcházející | Nahoru | Další
mysql_pconnect | Domů | mysql_query


mysql_query

(PHP 4, PHP 5, PECL mysql:1.0)

mysql_query — Pošle MySQL dotaz

Popis

resource mysql_query ( string $query [, resource $link_identifier] )

mysql_query() Provede dotaz na aktuálním spojení v aktivní databázi na serveru a vrátí identifikátor výsledku. Není-li parametr spojeni uveden, použije posledně otevřené spojení. Pokud není žádné otevřené spojení nalezeno, funkce se ho pokusí vytvořit za použití výchozích hodnot funkce mysql_connect() (jakoby byla volána bez parametrů).

Poznámka: Řetězec dotazu by neměl končit středníkem.

Pouze při použití dotazu typu SELECT je vrácen identifikátor výsledku či FALSE pokud při vykonávání dotazu došlo k chybě. Při ostatních typech dotazů mysql_query() vrací TRUE při úspěšném dotazu nebo FALSE dojde-li k chybě. Ne-FALSE vrácená hodnota znamená, že dotaz byl vykonán serverem bez chyb. Tato funkce nezaznamenává žádné údaje o počtu ovlivněných nebo vrácených řádků. Lze pouze zjistit, zda dotaz proběhl v pořádku.

Následující dotaz je syntakticky nesprávný, takže jeho vykonávání v mysql_query() selže a vrátí FALSE:

Příklad 1275. mysql_query()

<php
$result = mysql_query("SELECT * WHERE 1=1")
    or die("Špatný dotaz: " . mysql_error());
?>

Následující dotaz je významově nesprávný my_col není sloupec v tabulce my_tbl, takže mysql_query() selže a vrátí FALSE:

Příklad 1276. mysql_query()

<?php
$result = mysql_query("SELECT my_col FROM my_tbl")
    or exit ("Špatný dotaz: " . mysql_error());
?>

mysql_query() také vždy selže a vrátí FALSE jestliže nemáte dostatečné oprávnění přístupu do tabulky (tabulek) uvedených v dotazu.

Potřebujete-li zjistit počet záznamů vrácených dotazem typu SELECT, použijte následně funkci mysql_num_rows() či případně funkci mysql_affected_rows(), pokud potřebujete zjistit počet všech ovlivněných záznamů dotazy typů DELETE, INSERT, REPLACE nebo UPDATE.

Pouze při dotazech SELECT, SHOW, DESCRIBE nebo EXPLAIN mysql_query() vrací nový identifikátor dotazu, který lze použít například pro volání funkce mysql_fetch_array() a dalších funkcí pro zpracování výsledků dotazu. Nepotřebujete-li již obsah výsledku dotazu, můžete uvolnit pamět voláním funkce mysql_free_result(). Nicméně pamět bude stejně uvolněna automaticky na konci běhu skriptu.

Viz. také: mysql_num_rows()
mysql_affected_rows(),
mysql_unbuffered_query(),
mysql_free_result(),
mysql_fetch_array(),
mysql_fetch_row(),
mysql_fetch_assoc(),
mysql_result(),
mysql_select_db(), a
mysql_connect().

Předcházející | Nahoru | Další
mysql_ping | Domů | mysql_real_escape_string


mysql_real_escape_string

(PHP 4 >= 4.3.0, PHP 5, PECL mysql:1.0)

mysql_real_escape_string — Upraví řetězec pro bezpečné použití v mysql_query.

Popis

string mysql_real_escape_string ( string $unescaped_string [, resource $link_identifier] )

Tato funkce opatří speciální znaky v neupraveny_retezec zpětným lomítkem pro bezpečné použití v mysql_query() v závislosti na aktuální znakové sadě spojení (konce řádků jsou nahrazeny značkou \n atd.).

Poznámka: mysql_real_escape_string() nepřidává zpětná lomítka před % and _.

Příklad 1277. mysql_real_escape_string() příklad

<?php
$link = mysql_connect('localhost', 'mysql_user', 'mysql_password');
$item = "Zak's and Derick's Laptop";
$escaped_item = mysql_real_escape_string($item);
printf ("Escaped string: %s\n", $escaped_item);
?>

Předchozí příklad by zobrazil následující výstup:

Escaped string: Zak\'s and Derick\'s Laptop

Dále také: mysql_escape_string(), mysql_character_set_name().

Předcházející | Nahoru | Další
mysql_query | Domů | mysql_result


mysql_result

(PHP 4, PHP 5, PECL mysql:1.0)

mysql_result — Načte obsah jednoho sloupce tabulky

Popis

string mysql_result ( resource $result, int $row [, mixed $field] )

mysql_result() vrací záznamy jednoho sloupce z výsledku MySQL. Argumenty mohou být číslo sloupce, jméno sloupce, jméno tabulky nebo jméno tabulky tečka jméno sloupce (tabulka.sloupec). Má-li některý sloupec jmenný alias (SELECT muj_sloupec as tvuj_sloupec FROM ...), používejte alias namísto jméno sloupce.

Pokud pracujete s velkými záznamy, měli byste uvážit použití jedné z funkcí, které vrací úplně celý záznam (všechny sloupce specifikované v dotazu SELECT najednou), protože tyto funkce vrací celý výsledek v jednom volání funkce a jsou proto MNOHEM rychlejší než mysql_result(). Dále je nutné podotknout, že jako argument sloupce je mnohem rychlejší uvést číselný identifikátor než jméno sloupce či zápis tabulka.sloupec.

Volání funkce mysql_result() by nemělo být mícháno s voláním jiných funkcí, protože by došlo k dělení záznamů z výsledku.

Doporučené mnohem výkonější alternativy:
mysql_fetch_row(),
mysql_fetch_array() a
mysql_fetch_object().

Předcházející | Nahoru | Další
mysql_real_escape_string | Domů | mysql_select_db


mysql_select_db

(PHP 4, PHP 5, PECL mysql:1.0)

mysql_select_db — Nastaví MySQL databázi

Popis

bool mysql_select_db ( string $database_name [, resource $link_identifier] )

Vrací TRUE při úspěchu, FALSE při selhání.

mysql_select_db() nastaví aktuální databázi na serveru a asocijuje ji s uvedeným identifikátorem spojení. Není-li identifikátor spojení uveden, použije posledně otevřené spojení. Není-li žádné spojení otevřeno, funkce se jej pokusí vytvořit tak, jakoby byla volána funkce mysql_connect() bez parametrů.

Každé další volání mysql_query() bude vytvořeno už na platnou databázi.

Viz. také:
    mysql_connect(),
    mysql_pconnect() a
    mysql_query().

Z důvodů zpětné kompatibility můžete také narazit na funkci mysql_selectdb(). Tuto funkci však nedoporučujeme používat, neboť nemusí být již v dalších verzích PHP podporována.

Předcházející | Nahoru | Další
mysql_result | Domů | mysql_set_charset


mysql_stat

(PHP 4 >= 4.3.0, PHP 5, PECL mysql:1.0)

mysql_stat — Vrací aktuální stav systému

popis

string mysql_stat ( [resource $link_identifier] )

mysql_stat() vrací aktuální stav systému.

Poznámka: mysql_stat() vrací hodnoty stavů pouze pro čas od startu MySQL serveru, vlákna, pomalé dotazy, otevřené tabulky, flush tabulky a dotazy za sekundu. Pro kompletní výpis stavů dalších proměnných musíte použít sql dotaz SHOW STATUS.

Příklad 1278. mysql_stat() příklad

<?php
$link = mysql_connect('localhost', "mysql_uziv", "mysql_heslo");
$status = explode('  ', mysql_stat($link));
print_r($status);
?>

předchozí příklad by zobrazil následující výstup:

Array
(
    [0] => Uptime: 5380
    [1] => Threads: 2
    [2] => Questions: 1321299
    [3] => Slow queries: 0
    [4] => Opens: 26
    [5] => Flush tables: 1
    [6] => Open tables: 17
    [7] => Queries per second avg: 245.595
)

Předcházející | Nahoru | Další
mysql_set_charset | Domů | mysql_tablename


mysql_tablename

(PHP 4, PHP 5, PECL mysql:1.0)

mysql_tablename — Načte jméno tabulky

Popis

string mysql_tablename ( resource $result, int $i )

mysql_tablename() přijímá identifikátor výsledku vrácený funkcí mysql_list_tables() a celočíslený index a vrací jméno tabulky. K určení celočísleného indexu může být použita funkce mysql_num_rows(). Návratovou hodnotu funkce mysql_tablename() můžete projít pomocí funkce mysql_tablename nebo libovolné jiné funkce pro zpracování výsledků dotazů, např. mysql_fetch_array().

Příklad 1279. mysql_tablename() příklad

<?php
    mysql_connect("localhost", "mysql_uziv", "mysql_heslo");
    $result = mysql_list_tables("mojedb");

    for ($i = 0; $i < mysql_num_rows($result); $i++)
        printf ("Tabulka: %s\n", mysql_tablename($result, $i));

    mysql_free_result($result);
?>

Dále také: mysql_list_tables().

Předcházející | Nahoru | Další
mysql_stat | Domů | mysql_thread_id


mysql_thread_id

(PHP 4 >= 4.3.0, PHP 5, PECL mysql:1.0)

mysql_thread_id — Vrací id aktuálního vlákna

Popis

int mysql_thread_id ( [resource $link_identifier] )

mysql_thread_id() Vrátí id aktuálního vlákna. Je-li spojení ztraceno a znovu navázáno pomocí mysql_ping(), id vlánka se změní. To znamená, že byste neměli načítat ID vlákna dopředu pro pozdější použití, ale teprve tehdy, když jej potřebujete.

Příklad 1280. mysql_thread_id() příklad

<?php
$link = mysql_connect('localhost', 'mysql_uziv', 'mysql_heslo');
$thread_id = mysql_thread_id($link);
if ($thread_id){
    printf ("id aktuálního vlákna je %d\n", $thread_id);
}
?>

Předchozí příklad by zobrazil následující výstup:

id aktuálního vlákna je 73

Dále také: mysql_ping(), mysql_list_processes().

Předcházející | Nahoru | Další
mysql_tablename | Domů | mysql_unbuffered_query


mysql_unbuffered_query

(PHP 4 >= 4.0.6, PHP 5, PECL mysql:1.0)

mysql_unbuffered_query — Pošle SQL dotaz bez načtení a bufferování výsledných záznamů

Popis

resource mysql_unbuffered_query ( string $query [, resource $link_identifier] )

mysql_unbuffered_query() pošle SQL dotaz dotaz do MySQL bez načtení a bufferování výsledných záznamů automaticky, jako to dělá funkce mysql_query(). Na jednu stranu toto chování ušetří značné množství použité paměti u SQL dotazů, které vytvářejí rozsáhlé výsledky. Na druhou stranu můžete začít pracovat na výsledku okamžitě po prvním záznamu, který byl vrácen; tj. nemusíte čekat dokud nebude proveden celý SQL dotaz. Použijete-li přepínač DB-connects, můžete zadat volitelný parametr spojeni.

Poznámka: každá výhoda mysql_unbuffered_query() něco stojí: Nemůžete používat funkci mysql_num_rows() k zjištění počtu záznamů vrácených pomocí mysql_unbuffered_query(). Dále také musíte načíst všechny záznamy vracené nebufferovaným dotazem předtím, než pošlete nový SQL dotaz do MySQL.

Viz. také: mysql_query().

Předcházející | Nahoru | Další
mysql_thread_id | Domů | XCIX. MySQL Functions (PDO_MYSQL)


MySQL Improved Extension

Předcházející VI. Reference funkcí Další

C. MySQL Improved Extension

Úvod

The mysqli extension allows you to access the functionality provided by MySQL 4.1 and above. More information about the MySQL Database server can be found at » http://www.mysql.com/

Documentation for MySQL can be found at » http://dev.mysql.com/doc/.

Parts of this documentation included from MySQL manual with permissions of MySQL AB.

Požadavky

In order to have these functions available, you must compile PHP with support for the mysqli extension.

Poznámka: The mysqli extension is designed to work with the version 4.1.3 or above of MySQL. For previous versions, please see the MySQL extension documentation.

Instalace

To install the mysqli extension for PHP, use the --with-mysqli=mysql_config_path/mysql_config configuration option where mysql_config_path represents the location of the mysql_config program that comes with MySQL versions greater than 4.1.

If you would like to install the mysql extension along with the mysqli extension you have to use the same client library to avoid any conflicts.

Installation on Windows Systems

MySQLi is not enabled by default, so the php_mysqli.dll DLL must be enabled inside of php.ini. Also, PHP needs access to the MySQL client library. A file named libmysql.dll is included in the Windows PHP distribution and in order for PHP to talk to MySQL this file needs to be available to the Windows systems PATH. See the FAQ titled "How do I add my PHP directory to the PATH on Windows" for information on how to do this. Although copying libmysql.dll to the Windows system directory also works (because the system directory is by default in the system's PATH), it's not recommended.

Poznámka: For connecting to MySQL 5, it is recommended to download binaries from » http://dev.mysql.com/downloads/connector/php/.

As with enabling any PHP extension (such as php_mysqli.dll), the PHP directive extension_dir should be set to the directory where the PHP extensions are located. See also the Manual Windows Installation Instructions. An example extension_dir value for PHP 5 is c:\php\ext

Poznámka: If when starting the web server an error similar to the following occurs: "Unable to load dynamic library './php_mysqli.dll'", this is because php_mysqli.dll and/or libmysql.dll cannot be found by the system.

Konfigurace běhu

Chování těchto funkcí je ovlivněno nastavením parametrů v php.ini.

Tabulka 174. MySQLi Configuration Options

Name | Default | Changeable | Changelog
mysqli.max_links | "-1" | PHP_INI_SYSTEM | Available since PHP 5.0.0.
mysqli.default_port | "3306" | PHP_INI_ALL | Available since PHP 5.0.0.
mysqli.default_socket | NULL | PHP_INI_ALL | Available since PHP 5.0.0.
mysqli.default_host | NULL | PHP_INI_ALL | Available since PHP 5.0.0.
mysqli.default_user | NULL | PHP_INI_ALL | Available since PHP 5.0.0.
mysqli.default_pw | NULL | PHP_INI_ALL | Available since PHP 5.0.0.

For further details and definitions of the above PHP_INI_* constants, see the chapter on configuration changes.

Zde je stručný popis konfiguračních direktiv.

mysqli.max_links integer

The maximum number of MySQL connections per process.

mysqli.default_port string

The default TCP port number to use when connecting to the database server if no other port is specified. If no default is specified, the port will be obtained from the MYSQL_TCP_PORT environment variable, the mysql-tcp entry in /etc/services or the compile-time MYSQL_PORT constant, in that order. Win32 will only use the MYSQL_PORT constant.

mysqli.default_socket string

The default socket name to use when connecting to a local database server if no other socket name is specified.

mysqli.default_host string

The default server host to use when connecting to the database server if no other host is specified. Doesn't apply in safe mode.

mysqli.default_user string

The default user name to use when connecting to the database server if no other name is specified. Doesn't apply in safe mode.

mysqli.default_pw string

The default password to use when connecting to the database server if no other password is specified. Doesn't apply in safe mode.

Předdefinované třídy

mysqli

Represents a connection between PHP and a MySQL database.

Konstruktory

  • mysqli - construct a new mysqli object

Metody

  • autocommit - turns on or off auto-commiting database modifications

  • change_user - changes the user of the specified database connection

  • character_set_name - returns the default character set for the database connection

  • close - closes a previously opened connection

  • commit - commits the current transaction

  • connect - opens a new connection to MySQL database server

  • debug - performs debugging operations

  • dump_debug_info - dumps debug information

  • get_client_info - returns client version

  • get_host_info - returns type of connection used

  • get_server_info - returns version of the MySQL server

  • get_server_version - returns version of the MySQL server

  • init - initializes mysqli object

  • info - retrieves information about the most recently executed query

  • kill - asks the server to kill a mysql thread

  • multi_query - performs multiple queries

  • more_results - check if more results exist from currently executed multi-query

  • next_result - reads next result from currently executed multi-query

  • options - set options

  • ping - pings a server connection or reconnects if there is no connection

  • prepare - prepares a SQL query

  • query - performs a query

  • real_connect - attempts to open a connection to MySQL database server

  • escape_string - escapes special characters in a string for use in a SQL statement, taking into account the current charset of the connection

  • rollback - rolls back the current transaction

  • select_db - selects the default database

  • set_charset - sets the default client character set

  • ssl_set - sets ssl parameters

  • stat - gets the current system status

  • stmt_init- initializes a statement for use with mysqli_stmt_prepare

  • store_result - transfers a resultset from last query

  • thread_safe - returns whether thread safety is given or not

  • use_result - transfers an unbuffered resultset from last query

Vlastnosti

  • affected_rows - gets the number of affected rows in a previous MySQL operation

  • client_info - returns the MySQL client version as a string

  • client_version - returns the MySQL client version as an integer

  • errno - returns the error code for the most recent function call

  • error - returns the error string for the most recent function call

  • field_count - returns the number of columns for the most recent query

  • host_info - returns a string representing the type of connection used

  • info - retrieves information about the most recently executed query

  • insert_id - returns the auto generated id used in the last query

  • protocol_version - returns the version of the MySQL protocol used

  • server_info - returns a string that represents the server version number

  • server_version - returns the version number of the server as an integer

  • sqlstate - returns a string containing the SQLSTATE error code for the last error

  • thread_id - returns the thread ID for the current connection

  • warning_count - returns the number of warnings generated during execution of the previous SQL statement

mysqli_stmt

Represents a prepared statement.

Metody

  • bind_param - binds variables to a prepared statement

  • bind_result - binds variables to a prepared statement for result storage

  • close - closes a prepared statement

  • data_seek - seeks to an arbitrary row in a statement result set

  • execute - executes a prepared statement

  • fetch - fetches result from a prepared statement into bound variables

  • free_result - frees stored result memory for the given statement handle

  • prepare - prepares a SQL query

  • reset - resets a prepared statement

  • result_metadata - retrieves a resultset from a prepared statement for metadata information

  • send_long_data - sends data in chunks

  • store_result - buffers complete resultset from a prepared statement

Vlastnosti

  • affected_rows - returns affected rows from last statement execution

  • errno - returns errorcode for last statement function

  • error - returns errormessage for last statement function

  • field_count - returns the number of columns in a result set

  • id - returns the statement identifier

  • insert_id - returns the value generated for an AUTO_INCREMENT column by the prepared statement

  • num_rows - returns the number of rows in the result set

  • param_count - returns number of parameter for a given prepare statement

  • sqlstate - returns a string containing the SQLSTATE error code for the last statement function

mysqli_result

Represents the result set obtained from a query against the database.

Metody

  • close - closes resultset

  • data_seek - moves internal result pointer

  • fetch_array - fetches a result row as an associative array, a numeric array, or both.

  • fetch_assoc - fetches a result row as an associative array

  • fetch_field - gets column information from a resultset

  • fetch_fields - gets information for all columns from a resulset

  • fetch_field_direct - gets column information for specified column

  • fetch_object - fetches a result row as an object

  • fetch_row - gets a result row as an enumerated array

  • field_seek - set result pointer to a specified field offset

  • free_result - frees result memory

Vlastnosti

  • current_field - returns offset of current fieldpointer

  • field_count - returns number of fields in resultset

  • lengths - returns an array of columnlengths

  • num_rows - returns number of rows in resultset

  • type - returns MYSQLI_STORE_RESULT or MYSQLI_USE_RESULT

Předdefinované konstanty

Tabulka 175. MySQLi Constants

Name | Description
MYSQLI_READ_DEFAULT_GROUP (integer) | Read options from the named group from `my.cnf' or the file specified with MYSQLI_READ_DEFAULT_FILE
MYSQLI_READ_DEFAULT_FILE (integer) | Read options from the named option file instead of from my.cnf
MYSQLI_OPT_CONNECT_TIMEOUT (integer) | Connect timeout in seconds
MYSQLI_OPT_LOCAL_INFILE (integer) | Enables command LOAD LOCAL INFILE
MYSQLI_INIT_COMMAND (integer) | Command to execute when connecting to MySQL server. Will automatically be re-executed when reconnecting.
MYSQLI_CLIENT_SSL (integer) | Use SSL (encrypted protocol). This option should not be set by application programs; it is set internally in the MySQL client library
MYSQLI_CLIENT_COMPRESS (integer) | Use compression protocol
MYSQLI_CLIENT_INTERACTIVE (integer) | Allow interactive_timeout seconds (instead of wait_timeout seconds) of inactivity before closing the connection. The client's session wait_timeout variable will be set to the value of the session interactive_timeout variable.
MYSQLI_CLIENT_IGNORE_SPACE (integer) | Allow spaces after function names. Makes all functions names reserved words.
MYSQLI_CLIENT_NO_SCHEMA (integer) | Don't allow the db_name.tbl_name.col_name syntax.
MYSQLI_CLIENT_MULTI_QUERIES (integer) |
MYSQLI_STORE_RESULT (integer) | For using buffered resultsets
MYSQLI_USE_RESULT (integer) | For using unbuffered resultsets
MYSQLI_ASSOC (integer) | Columns are returned into the array having the fieldname as the array index.
MYSQLI_NUM (integer) | Columns are returned into the array having an enumerated index.
MYSQLI_BOTH (integer) | Columns are returned into the array having both a numerical index and the fieldname as the associative index.
MYSQLI_NOT_NULL_FLAG (integer) | Indicates that a field is defined as NOT NULL
MYSQLI_PRI_KEY_FLAG (integer) | Field is part of a primary index
MYSQLI_UNIQUE_KEY_FLAG (integer) | Field is part of a unique index.
MYSQLI_MULTIPLE_KEY_FLAG (integer) | Field is part of an index.
MYSQLI_BLOB_FLAG (integer) | Field is defined as BLOB
MYSQLI_UNSIGNED_FLAG (integer) | Field is defined as UNSIGNED
MYSQLI_ZEROFILL_FLAG (integer) | Field is defined as ZEROFILL
MYSQLI_AUTO_INCREMENT_FLAG (integer) | Field is defined as AUTO_INCREMENT
MYSQLI_TIMESTAMP_FLAG (integer) | Field is defined as TIMESTAMP
MYSQLI_SET_FLAG (integer) | Field is defined as SET
MYSQLI_NUM_FLAG (integer) | Field is defined as NUMERIC
MYSQLI_PART_KEY_FLAG (integer) | Field is part of an multi-index
MYSQLI_GROUP_FLAG (integer) | Field is part of GROUP BY
MYSQLI_TYPE_DECIMAL (integer) | Field is defined as DECIMAL
MYSQLI_TYPE_NEWDECIMAL (integer) | Precision math DECIMAL or NUMERIC field (MySQL 5.0.3 and up)
MYSQLI_TYPE_BIT (integer) | Field is defined as BIT (MySQL 5.0.3 and up)
MYSQLI_TYPE_TINY (integer) | Field is defined as TINYINT
MYSQLI_TYPE_SHORT (integer) | Field is defined as INT
MYSQLI_TYPE_LONG (integer) | Field is defined as INT
MYSQLI_TYPE_FLOAT (integer) | Field is defined as FLOAT
MYSQLI_TYPE_DOUBLE (integer) | Field is defined as DOUBLE
MYSQLI_TYPE_NULL (integer) | Field is defined as DEFAULT NULL
MYSQLI_TYPE_TIMESTAMP (integer) | Field is defined as TIMESTAMP
MYSQLI_TYPE_LONGLONG (integer) | Field is defined as BIGINT
MYSQLI_TYPE_INT24 (integer) | Field is defined as MEDIUMINT
MYSQLI_TYPE_DATE (integer) | Field is defined as DATE
MYSQLI_TYPE_TIME (integer) | Field is defined as TIME
MYSQLI_TYPE_DATETIME (integer) | Field is defined as DATETIME
MYSQLI_TYPE_YEAR (integer) | Field is defined as YEAR
MYSQLI_TYPE_NEWDATE (integer) | Field is defined as DATE
MYSQLI_TYPE_ENUM (integer) | Field is defined as ENUM
MYSQLI_TYPE_SET (integer) | Field is defined as SET
MYSQLI_TYPE_TINY_BLOB (integer) | Field is defined as TINYBLOB
MYSQLI_TYPE_MEDIUM_BLOB (integer) | Field is defined as MEDIUMBLOB
MYSQLI_TYPE_LONG_BLOB (integer) | Field is defined as LONGBLOB
MYSQLI_TYPE_BLOB (integer) | Field is defined as BLOB
MYSQLI_TYPE_VAR_STRING (integer) | Field is defined as VARCHAR
MYSQLI_TYPE_STRING (integer) | Field is defined as CHAR
MYSQLI_TYPE_GEOMETRY (integer) | Field is defined as GEOMETRY
MYSQLI_NEED_DATA (integer) | More data available for bind variable
MYSQLI_NO_DATA (integer) | No more data available for bind variable
MYSQLI_DATA_TRUNCATED (integer) | Data truncation occurred. Available since PHP 5.1.0 and MySQL 5.0.5.

Examples

All Examples in the MySQLI documentation use the world database from MySQL AB. The world database can be found at » http://dev.mysql.com/get/Downloads/Manual/world.sql.gz/from/pick

Obsah

mysqli_affected_rows — Gets the number of affected rows in a previous MySQL operation
mysqli_autocommit — Turns on or off auto-commiting database modifications
mysqli_bind_param — Alias for mysqli_stmt_bind_param()
mysqli_bind_result — Alias for mysqli_stmt_bind_result()
mysqli_change_user — Changes the user of the specified database connection
mysqli_character_set_name — Returns the default character set for the database connection
mysqli_client_encoding — Alias of mysqli_character_set_name()
mysqli_close — Closes a previously opened database connection
mysqli_commit — Commits the current transaction
mysqli_connect_errno — Returns the error code from last connect call
mysqli_connect_error — Returns a string description of the last connect error
mysqli_connect — Open a new connection to the MySQL server
mysqli_data_seek — Adjusts the result pointer to an arbitary row in the result
mysqli_debug — Performs debugging operations
mysqli_disable_reads_from_master — Disable reads from master
mysqli_disable_rpl_parse — Disable RPL parse
mysqli_dump_debug_info — Dump debugging information into the log
mysqli_embedded_server_end
mysqli_embedded_server_start
mysqli_enable_reads_from_master — Enable reads from master
mysqli_enable_rpl_parse — Enable RPL parse
mysqli_errno — Returns the error code for the most recent function call
mysqli_error — Returns a string description of the last error
mysqli_escape_string — Alias of mysqli_real_escape_string()
mysqli_execute — Alias for mysqli_stmt_execute()
mysqli_fetch_array — Fetch a result row as an associative, a numeric array, or both
mysqli_fetch_assoc — Fetch a result row as an associative array
mysqli_fetch_field_direct — Fetch meta-data for a single field
mysqli_fetch_field — Returns the next field in the result set
mysqli_fetch_fields — Returns an array of objects representing the fields in a result set
mysqli_fetch_lengths — Returns the lengths of the columns of the current row in the result set
mysqli_fetch_object — Returns the current row of a result set as an object
mysqli_fetch_row — Get a result row as an enumerated array
mysqli_fetch — Alias for mysqli_stmt_fetch()
mysqli_field_count — Returns the number of columns for the most recent query
mysqli_field_seek — Set result pointer to a specified field offset
mysqli_field_tell — Get current field offset of a result pointer
mysqli_free_result — Frees the memory associated with a result
mysqli_get_charset — Returns a character set object
mysqli_get_client_info — Returns the MySQL client version as a string
mysqli_get_client_version — Get MySQL client info
mysqli_get_host_info — Returns a string representing the type of connection used
mysqli_get_metadata — Alias for mysqli_stmt_result_metadata()
mysqli_get_proto_info — Returns the version of the MySQL protocol used
mysqli_get_server_info — Returns the version of the MySQL server
mysqli_get_server_version — Returns the version of the MySQL server as an integer
mysqli_get_warnings
mysqli_info — Retrieves information about the most recently executed query
mysqli_init — Initializes MySQLi and returns a resource for use with mysqli_real_connect()
mysqli_insert_id — Returns the auto generated id used in the last query
mysqli_kill — Asks the server to kill a MySQL thread
mysqli_master_query — Enforce execution of a query on the master in a master/slave setup
mysqli_more_results — Check if there are any more query results from a multi query
mysqli_multi_query — Performs a query on the database
mysqli_next_result — Prepare next result from multi_query
mysqli_num_fields — Get the number of fields in a result
mysqli_num_rows — Gets the number of rows in a result
mysqli_options — Set options
mysqli_param_count — Alias for mysqli_stmt_param_count()
mysqli_ping — Pings a server connection, or tries to reconnect if the connection has gone down
mysqli_prepare — Prepare a SQL statement for execution
mysqli_query — Performs a query on the database
mysqli_real_connect — Opens a connection to a mysql server
mysqli_real_escape_string — Escapes special characters in a string for use in a SQL statement, taking into account the current charset of the connection
mysqli_real_query — Execute an SQL query
mysqli_report — Enables or disables internal report functions
mysqli_rollback — Rolls back current transaction
mysqli_rpl_parse_enabled — Check if RPL parse is enabled
mysqli_rpl_probe — RPL probe
mysqli_rpl_query_type — Returns RPL query type
mysqli_select_db — Selects the default database for database queries
mysqli_send_long_data — Alias for mysqli_stmt_send_long_data()
mysqli_send_query — Send the query and return
mysqli_server_end — Shut down the embedded server
mysqli_server_init — Initialize embedded server
mysqli_set_charset — Sets the default client character set
mysqli_set_local_infile_default — Unsets user defined handler for load local infile command
mysqli_set_local_infile_handler — Set callback functions for LOAD DATA LOCAL INFILE command
mysqli_set_opt — Alias of mysqli_options()
mysqli_slave_query — Force execution of a query on a slave in a master/slave setup
mysqli_sqlstate — Returns the SQLSTATE error from previous MySQL operation
mysqli_ssl_set — Used for establishing secure connections using SSL
mysqli_stat — Gets the current system status
mysqli_stmt_affected_rows — Returns the total number of rows changed, deleted, or inserted by the last executed statement
mysqli_stmt_attr_get
mysqli_stmt_attr_set
mysqli_stmt_bind_param — Binds variables to a prepared statement as parameters
mysqli_stmt_bind_result — Binds variables to a prepared statement for result storage
mysqli_stmt_close — Closes a prepared statement
mysqli_stmt_data_seek — Seeks to an arbitray row in statement result set
mysqli_stmt_errno — Returns the error code for the most recent statement call
mysqli_stmt_error — Returns a string description for last statement error
mysqli_stmt_execute — Executes a prepared Query
mysqli_stmt_fetch — Fetch results from a prepared statement into the bound variables
mysqli_stmt_field_count — Returns the number of field in the given statement
mysqli_stmt_free_result — Frees stored result memory for the given statement handle
mysqli_stmt_get_warnings
mysqli_stmt_init — Initializes a statement and returns an object for use with mysqli_stmt_prepare
mysqli_stmt_insert_id — Get the ID generated from the previous INSERT operation
mysqli_stmt_num_rows — Return the number of rows in statements result set
mysqli_stmt_param_count — Returns the number of parameter for the given statement
mysqli_stmt_prepare — Prepare a SQL statement for execution
mysqli_stmt_reset — Resets a prepared statement
mysqli_stmt_result_metadata — Returns result set metadata from a prepared statement
mysqli_stmt_send_long_data — Send data in blocks
mysqli_stmt_sqlstate — Returns SQLSTATE error from previous statement operation
mysqli_stmt_store_result — Transfers a result set from a prepared statement
mysqli_store_result — Transfers a result set from the last query
mysqli_thread_id — Returns the thread ID for the current connection
mysqli_thread_safe — Returns whether thread safety is given or not
mysqli_use_result — Initiate a result set retrieval
mysqli_warning_count — Returns the number of warnings from the last query for the given link
Předcházející | Nahoru | Další
PDO_MYSQL DSN | Domů | mysqli_affected_rows


mysqli_affected_rows

Předcházející C. MySQL Improved Extension Další

mysqli_affected_rows,

(PHP 5)

mysqli_affected_rows, mysqli->affected_rows — Gets the number of affected rows in a previous MySQL operation

Popis

Procedural style:

int mysqli_affected_rows ( mysqli $link )

Object oriented style (property):

class mysqli {
int affected_rows
}

Returns the number of rows affected by the last INSERT, UPDATE, REPLACE or DELETE query.

For SELECT statements mysqli_affected_rows() works like mysqli_num_rows().

Seznam parametrů

link

Procedural style only: A link identifier returned by mysqli_connect() or mysqli_init()

Návratové hodnoty

An integer greater than zero indicates the number of rows affected or retrieved. Zero indicates that no records where updated for an UPDATE statement, no rows matched the WHERE clause in the query or that no query has yet been executed. -1 indicates that the query returned an error.

Poznámka: If the number of affected rows is greater than maximal int value, the number of affected rows will be returned as a string.

Příklady

Příklad 1283. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* Insert rows */
$mysqli->query("CREATE TABLE Language SELECT * from CountryLanguage");
printf("Affected rows (INSERT): %d\n", $mysqli->affected_rows);

$mysqli->query("ALTER TABLE Language ADD Status int default 0");

/* update rows */
$mysqli->query("UPDATE Language SET Status=1 WHERE Percentage > 50");
printf("Affected rows (UPDATE): %d\n", $mysqli->affected_rows);

/* delete rows */
$mysqli->query("DELETE FROM Language WHERE Percentage < 50");
printf("Affected rows (DELETE): %d\n", $mysqli->affected_rows);

/* select all rows */
$result = $mysqli->query("SELECT CountryCode FROM Language");
printf("Affected rows (SELECT): %d\n", $mysqli->affected_rows);

$result->close();

/* Delete table Language */
$mysqli->query("DROP TABLE Language");

/* close connection */
$mysqli->close();
?>

Příklad 1284. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

if (!$link) {
    printf("Can't connect to localhost. Error: %s\n", mysqli_connect_error());
    exit();
}

/* Insert rows */
mysqli_query($link, "CREATE TABLE Language SELECT * from CountryLanguage");
printf("Affected rows (INSERT): %d\n", mysqli_affected_rows($link));

mysqli_query($link, "ALTER TABLE Language ADD Status int default 0");

/* update rows */
mysqli_query($link, "UPDATE Language SET Status=1 WHERE Percentage > 50");
printf("Affected rows (UPDATE): %d\n", mysqli_affected_rows($link));

/* delete rows */
mysqli_query($link, "DELETE FROM Language WHERE Percentage < 50");
printf("Affected rows (DELETE): %d\n", mysqli_affected_rows($link));

/* select all rows */
$result = mysqli_query($link, "SELECT CountryCode FROM Language");
printf("Affected rows (SELECT): %d\n", mysqli_affected_rows($link));

mysqli_free_result($result);

/* Delete table Language */
mysqli_query($link, "DROP TABLE Language");

/* close connection */
mysqli_close($link);
?>

Výše uvedený příklad vypíše:

Affected rows (INSERT): 984
Affected rows (UPDATE): 168
Affected rows (DELETE): 815
Affected rows (SELECT): 169

Viz také

mysqli_num_rows()
mysqli_info()

Předcházející | Nahoru | Další
C. MySQL Improved Extension | Domů | mysqli_autocommit


mysqli_autocommit

Předcházející C. MySQL Improved Extension Další

mysqli_autocommit,

(PHP 5)

mysqli_autocommit, mysqli->autocommit() — Turns on or off auto-commiting database modifications

Popis

Procedural style:

bool mysqli_autocommit ( mysqli $link, bool $mode )

Object oriented style (method)

class mysqli {
bool autocommit ( bool $mode )
}

Turns on or off auto-commit mode on queries for the database connection.

To determine the current state of autocommit use the SQL command SELECT @@autocommit.

Seznam parametrů

link

Procedural style only: A link identifier returned by mysqli_connect() or mysqli_init()

mode

Whether to turn on auto-commit or not.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Poznámky

Poznámka: This function doesn't work with non transactional table types (like MyISAM or ISAM).

Příklady

Příklad 1285. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* turn autocommit on */
$mysqli->autocommit(TRUE);

if ($result = $mysqli->query("SELECT @@autocommit")) {
    $row = $result->fetch_row();
    printf("Autocommit is %s\n", $row[0]);
    $result->free();
}

/* close connection */
$mysqli->close();
?>

Příklad 1286. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

if (!$link) {
    printf("Can't connect to localhost. Error: %s\n", mysqli_connect_error());
    exit();
}

/* turn autocommit on */
mysqli_autocommit($link, TRUE);

if ($result = mysqli_query($link, "SELECT @@autocommit")) {
    $row = mysqli_fetch_row($result);
    printf("Autocommit is %s\n", $row[0]);
    mysqli_free_result($result);
}

/* close connection */
mysqli_close($link);
?>

Výše uvedený příklad vypíše:

Autocommit is 1

Viz také

mysqli_commit()
mysqli_rollback()

Předcházející | Nahoru | Další
mysqli_affected_rows | Domů | mysqli_bind_param


mysqli_bind_param

(PHP 5)

mysqli_bind_param — Alias for mysqli_stmt_bind_param()

Popis

This function is an alias of mysqli_stmt_bind_param().

Poznámky

Poznámka: mysqli_bind_param() is deprecated and will be removed.

Viz také

mysqli_stmt_bind_param()

Předcházející | Nahoru | Další
mysqli_autocommit | Domů | mysqli_bind_result


mysqli_bind_result

(PHP 5)

mysqli_bind_result — Alias for mysqli_stmt_bind_result()

Popis

This function is an alias of mysqli_stmt_bind_result().

Poznámky

Poznámka: mysqli_bind_result() is deprecated and will be removed.

Viz také

mysqli_stmt_bind_result()

Předcházející | Nahoru | Další
mysqli_bind_param | Domů | mysqli_change_user


mysqli_change_user

Předcházející C. MySQL Improved Extension Další

mysqli_change_user,

(PHP 5)

mysqli_change_user, mysqli->change_user() — Changes the user of the specified database connection

Popis

Procedural style:

bool mysqli_change_user ( mysqli $link, string $user, string $password, string $database )

Object oriented style (method):

class mysqli {
bool change_user ( string $user, string $password, string $database )
}

Changes the user of the specified database connection and sets the current database.

In order to successfully change users a valid username and password parameters must be provided and that user must have sufficient permissions to access the desired database. If for any reason authorization fails, the current user authentication will remain.

Seznam parametrů

link

Procedural style only: A link identifier returned by mysqli_connect() or mysqli_init()

user

The MySQL user name.

password

The MySQL password.

database

The database to change to.

If desired, the NULL value may be passed resulting in only changing the user and not selecting a database. To select a database in this case use the mysqli_select_db() function.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Poznámky

Poznámka: Using this command will always cause the current database connection to behave as if was a completely new database connection, regardless of if the operation was completed successfully. This reset includes performing a rollback on any active transactions, closing all temporary tables, and unlocking all locked tables.

Příklady

Příklad 1287. Object oriented style

<?php

/* connect database test */
$mysqli = new mysqli("localhost", "my_user", "my_password", "test");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* Set Variable a */
$mysqli->query("SET @a:=1");

/* reset all and select a new database */
$mysqli->change_user("my_user", "my_password", "world");

if ($result = $mysqli->query("SELECT DATABASE()")) {
    $row = $result->fetch_row();
    printf("Default database: %s\n", $row[0]);
    $result->close();
}

if ($result = $mysqli->query("SELECT @a")) {
    $row = $result->fetch_row();
    if ($row[0] === NULL) {
        printf("Value of variable a is NULL\n");
    }
    $result->close();
}

/* close connection */
$mysqli->close();
?>

Příklad 1288. Procedural style

<?php
/* connect database test */
$link = mysqli_connect("localhost", "my_user", "my_password", "test");

/* check connection */
if (!$link) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* Set Variable a */
mysqli_query($link, "SET @a:=1");

/* reset all and select a new database */
mysqli_change_user($link, "my_user", "my_password", "world");

if ($result = mysqli_query($link, "SELECT DATABASE()")) {
    $row = mysqli_fetch_row($result);
    printf("Default database: %s\n", $row[0]);
    mysqli_free_result($result);
}

if ($result = mysqli_query($link, "SELECT @a")) {
    $row = mysqli_fetch_row($result);
    if ($row[0] === NULL) {
        printf("Value of variable a is NULL\n");
    }
    mysqli_free_result($result);
}

/* close connection */
mysqli_close($link);
?>

Výše uvedený příklad vypíše:

Default database: world
Value of variable a is NULL

Viz také

mysqli_connect()
mysqli_select_db()

Předcházející | Nahoru | Další
mysqli_bind_result | Domů | mysqli_character_set_name


mysqli_character_set_name

Předcházející C. MySQL Improved Extension Další

mysqli_character_set_name,

(PHP 5)

mysqli_character_set_name, mysqli->character_set_name() — Returns the default character set for the database connection

Popis

Procedural style:

string mysqli_character_set_name ( mysqli $link )

Object oriented style (method):

class mysqli {
string character_set_name ( void )
}

Returns the current character set for the database connection.

Seznam parametrů

link

Procedural style only: A link identifier returned by mysqli_connect() or mysqli_init()

Návratové hodnoty

The default character set for the current connection

Příklady

Příklad 1289. Object oriented style

<?php
/* Open a connection */
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* Print current character set */
$charset = $mysqli->character_set_name();
printf ("Current character set is %s\n", $charset);

$mysqli->close();
?>

Příklad 1290. Procedural style

<?php
/* Open a connection */
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (!$link) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* Print current character set */
$charset = mysqli_character_set_name($link);
printf ("Current character set is %s\n",$charset);

/* close connection */
mysqli_close($link);
?>

Výše uvedený příklad vypíše:

Current character set is latin1_swedish_ci

Viz také

mysqli_client_encoding()
mysqli_real_escape_string()

Předcházející | Nahoru | Další
mysqli_change_user | Domů | mysqli_client_encoding


mysqli_client_encoding

(PHP 5)

mysqli_client_encoding — Alias of mysqli_character_set_name()

Popis

This function is an alias of mysqli_character_set_name().

Viz také

mysqli_real_escape_string()

Předcházející | Nahoru | Další
mysqli_character_set_name | Domů | mysqli_close


mysqli_close

Předcházející C. MySQL Improved Extension Další

mysqli_close,

(PHP 5)

mysqli_close, mysqli->close() — Closes a previously opened database connection

Popis

Procedural style:

bool mysqli_close ( mysqli $link )

Object oriented style (method):

class mysqli {
bool close ( void )
}

Closes a previously opened database connection.

Seznam parametrů

link

Procedural style only: A link identifier returned by mysqli_connect() or mysqli_init()

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

mysqli_connect()
mysqli_init()
mysqli_real_connect()

Předcházející | Nahoru | Další
mysqli_client_encoding | Domů | mysqli_commit


mysqli_commit

Předcházející C. MySQL Improved Extension Další

mysqli_commit,

(PHP 5)

mysqli_commit, mysqli->commit() — Commits the current transaction

Popis

Procedural style:

bool mysqli_commit ( mysqli $link )

Object oriented style (method)

class mysqli {
bool commit ( void )
}

Commits the current transaction for the database connection.

Seznam parametrů

link

Procedural style only: A link identifier returned by mysqli_connect() or mysqli_init()

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1291. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$mysqli->query("CREATE TABLE Language LIKE CountryLanguage Type=InnoDB");

/* set autocommit to off */
$mysqli->autocommit(FALSE);

/* Insert some values */
$mysqli->query("INSERT INTO Language VALUES ('DEU', 'Bavarian', 'F', 11.2)");
$mysqli->query("INSERT INTO Language VALUES ('DEU', 'Swabian', 'F', 9.4)");

/* commit transaction */
$mysqli->commit();

/* drop table */
$mysqli->query("DROP TABLE Language");

/* close connection */
$mysqli->close();
?>

Příklad 1292. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "test");

/* check connection */
if (!$link) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* set autocommit to off */
mysqli_autocommit($link, FALSE);

mysqli_query($link, "CREATE TABLE Language LIKE CountryLanguage Type=InnoDB");

/* Insert some values */
mysqli_query($link, "INSERT INTO Language VALUES ('DEU', 'Bavarian', 'F', 11.2)");
mysqli_query($link, "INSERT INTO Language VALUES ('DEU', 'Swabian', 'F', 9.4)");

/* commit transaction */
mysqli_commit($link);

/* close connection */
mysqli_close($link);
?>

Viz také

mysqli_autocommit()
mysqli_rollback()

Předcházející | Nahoru | Další
mysqli_close | Domů | mysqli_connect_errno


mysqli_connect_errno

(PHP 5)

mysqli_connect_errno — Returns the error code from last connect call

Popis

int mysqli_connect_errno ( void )

Returns the last error code number from the last call to mysqli_connect().

Poznámka: Client error message numbers are listed in the MySQL errmsg.h header file, server error message numbers are listed in mysqld_error.h. In the MySQL source distribution you can find a complete list of error messages and error numbers in the file Docs/mysqld_error.txt.

Návratové hodnoty

An error code value for the last call to mysqli_connect(), if it failed. zero means no error occurred.

Příklady

Příklad 1293. mysqli_connect_errno() example

<?php

$link = @mysqli_connect("localhost", "nonexisting_user", "");

if (!$link) {
    printf("Can't connect to localhost. Errorcode: %d\n", mysqli_connect_errno());
}
?>

Viz také

mysqli_connect()
mysqli_connect_error()
mysqli_errno()
mysqli_error()
mysqli_sqlstate()

Předcházející | Nahoru | Další
mysqli_commit | Domů | mysqli_connect_error


mysqli_connect_error

(PHP 5)

mysqli_connect_error — Returns a string description of the last connect error

Popis

string mysqli_connect_error ( void )

Returns the last error message string from the last call to mysqli_connect().

Návratové hodnoty

A string that describes the error. An empty string if no error occurred.

Příklady

Příklad 1294. mysqli_connect_error() example

<?php

$link = @mysqli_connect("localhost", "nonexisting_user", "");

if (!$link) {
    printf("Can't connect to localhost. Error: %s\n", mysqli_connect_error());
}
?>

Viz také

mysqli_connect()
mysqli_connect_errno()
mysqli_errno()
mysqli_error()
mysqli_sqlstate()

Předcházející | Nahoru | Další
mysqli_connect_errno | Domů | mysqli_connect


mysqli_connect

Předcházející C. MySQL Improved Extension Další

mysqli_connect,

(PHP 5)

mysqli_connect, mysqli->__construct() — Open a new connection to the MySQL server

Popis

Procedural style

mysqli mysqli_connect ( [string $host [, string $username [, string $passwd [, string $dbname [, int $port [, string $socket]]]]]] )

Object oriented style (constructor):

class mysqli {
__construct ( [string $host [, string $username [, string $passwd [, string $dbname [, int $port [, string $socket]]]]]] )
}

Opens a connection to the MySQL Server running on.

Seznam parametrů

host

Can be either a host name or an IP address. Passing the NULL value or the string "localhost" to this parameter, the local host is assumed. When possible, pipes will be used instead of the TCP/IP protocol.

username

The MySQL user name.

passwd

If not provided or NULL, the MySQL server will attempt to authenticate the user against those user records which have no password only. This allows one username to be used with different permissions (depending on if a password as provided or not).

dbname

If provided will specify the default database to be used when performing queries.

port

Specifies the port number to attempt to connect to the MySQL server.

socket

Specifies the socket or named pipe that should be used.

Poznámka: Specifying the socket parameter will not explicitly determine the type of connection to be used when connecting to the MySQL server. How the connection is made to the MySQL database is determined by the host parameter.

Návratové hodnoty

Returns a object which represents the connection to a MySQL Server or FALSE if the connection failed.

Příklady

Příklad 1295. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

printf("Host information: %s\n", $mysqli->host_info);

/* close connection */
$mysqli->close();
?>

Příklad 1296. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (!$link) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

printf("Host information: %s\n", mysqli_get_host_info($link));

/* close connection */
mysqli_close($link);
?>

Výše uvedený příklad vypíše:

Host information: Localhost via UNIX socket

Poznámky

Poznámka: Error "Can't create TCP/IP socket (10106)" usually means that the variables_order configure directive doesn't contain character E. On Windows, if the environment is not copied the SYSTEMROOT environment variable won't be available and PHP will have problems loading Winsock.

Předcházející | Nahoru | Další
mysqli_connect_error | Domů | mysqli_data_seek


mysqli_data_seek

Předcházející C. MySQL Improved Extension Další

mysqli_data_seek,

(PHP 5)

mysqli_data_seek, result->data_seek() — Adjusts the result pointer to an arbitary row in the result

Popis

Procedural style:

bool mysqli_data_seek ( mysqli_result $result, int $offset )

Object oriented style (method):

class mysqli_result {
bool data_seek ( int $offset )
}

The mysqli_data_seek() function seeks to an arbitrary result pointer specified by the offset in the result set.

Seznam parametrů

result

Procedural style only: A result set identifier returned by mysqli_query(), mysqli_store_result() or mysqli_use_result().

offset

The field offset. Must be between zero and the total number of rows minus one (0..mysqli_num_rows() - 1).

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Poznámky

Poznámka: This function can only be used with buffered results attained from the use of the mysqli_store_result() or mysqli_query() functions.

Příklady

Příklad 1297. Object oriented style

<?php
/* Open a connection */
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER BY Name";
if ($result = $mysqli->query( $query)) {

    /* seek to row no. 400 */
    $result->data_seek(399);

    /* fetch row */
    $row = $result->fetch_row();

    printf ("City: %s  Countrycode: %s\n", $row[0], $row[1]);

    /* free result set*/
    $result->close();
}

/* close connection */
$mysqli->close();
?>

Příklad 1298. Procedural style

<?php
/* Open a connection */
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (!$link) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER BY Name";

if ($result = mysqli_query($link, $query)) {

    /* seek to row no. 400 */
    mysqli_data_seek($result, 399);

    /* fetch row */
    $row = mysqli_fetch_row($result);

    printf ("City: %s  Countrycode: %s\n", $row[0], $row[1]);

    /* free result set*/
    mysqli_free_result($result);
}

/* close connection */
mysqli_close($link);
?>

Výše uvedený příklad vypíše:

City: Benin City  Countrycode: NGA

Viz také

mysqli_store_result()
mysqli_fetch_row()
mysqli_fetch_array()
mysqli_fetch_assoc()
mysqli_fetch_object()
mysqli_query()
mysqli_num_rows()

Předcházející | Nahoru | Další
mysqli_connect | Domů | mysqli_debug


mysqli_debug

Předcházející C. MySQL Improved Extension Další

mysqli_debug,

(PHP 5)

mysqli_debug, mysqli->debug() — Performs debugging operations

Popis

Procedural style:

bool mysqli_debug ( string $message )

Object oriented style (method):

class mysqli {
bool debug ( string $message )
}

Performs debugging operations using the Fred Fish debugging library.

Seznam parametrů

message

A string representing the debugging operation to perform

Návratové hodnoty

Returns TRUE.

Poznámky

Poznámka: To use the mysqli_debug() function you must complile the MySQL client library to support debugging.

Příklady

Příklad 1299. Generating a Trace File

<?php

/* Create a trace file in '/tmp/client.trace' on the local (client) machine: */
mysqli_debug("d:t:0,/tmp/client.trace");

?>

Viz také

mysqli_dump_debug_info()
mysqli_report()

Předcházející | Nahoru | Další
mysqli_data_seek | Domů | mysqli_disable_reads_from_master


mysqli_disable_reads_from_master

Předcházející C. MySQL Improved Extension Další

mysqli_disable_reads_from_master,

(PHP 5)

mysqli_disable_reads_from_master, mysqli->disable_reads_from_master() — Disable reads from master

Popis

Procedural style:

bool mysqli_disable_reads_from_master ( mysqli $link )

Object oriented style (method):

class mysqli {
void disable_reads_from_master ( void )
}
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
mysqli_debug | Domů | mysqli_disable_rpl_parse


mysqli_disable_rpl_parse

(PHP 5)

mysqli_disable_rpl_parse — Disable RPL parse

Popis

bool mysqli_disable_rpl_parse ( mysqli $link )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
mysqli_disable_reads_from_master | Domů | mysqli_dump_debug_info


mysqli_dump_debug_info

Předcházející C. MySQL Improved Extension Další

mysqli_dump_debug_info,

(PHP 5)

mysqli_dump_debug_info, mysqli->dump_debug_info() — Dump debugging information into the log

Popis

Procedural style:

bool mysqli_dump_debug_info ( mysqli $link )

Object oriented style (method):

class mysqli {
bool dump_debug_info ( void )
}

This function is designed to be executed by an user with the SUPER privilege and is used to dump debugging information into the log for the MySQL Server relating to the connection.

Seznam parametrů

link

Procedural style only: A link identifier returned by mysqli_connect() or mysqli_init()

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

mysqli_debug()

Předcházející | Nahoru | Další
mysqli_disable_rpl_parse | Domů | mysqli_embedded_server_end


mysqli_enable_reads_from_master

(PHP 5)

mysqli_enable_reads_from_master — Enable reads from master

Popis

bool mysqli_enable_reads_from_master ( mysqli $link )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
mysqli_embedded_server_start | Domů | mysqli_enable_rpl_parse


mysqli_enable_rpl_parse

(PHP 5)

mysqli_enable_rpl_parse — Enable RPL parse

Popis

bool mysqli_enable_rpl_parse ( mysqli $link )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
mysqli_enable_reads_from_master | Domů | mysqli_errno


mysqli_errno

Předcházející C. MySQL Improved Extension Další

mysqli_errno,

(PHP 5)

mysqli_errno, mysqli->errno — Returns the error code for the most recent function call

Popis

Procedural style:

int mysqli_errno ( mysqli $link )

Object oriented style (property):

class mysqli {
int errno
}

Returns the last error code for the most recent MySQLi function call that can succeed or fail.

Client error message numbers are listed in the MySQL errmsg.h header file, server error message numbers are listed in mysqld_error.h. In the MySQL source distribution you can find a complete list of error messages and error numbers in the file Docs/mysqld_error.txt.

Seznam parametrů

link

Procedural style only: A link identifier returned by mysqli_connect() or mysqli_init()

Návratové hodnoty

An error code value for the last call, if it failed. zero means no error occurred.

Příklady

Příklad 1300. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

if (!$mysqli->query("SET a=1")) {
    printf("Errorcode: %d\n", $mysqli->errno);
}

/* close connection */
$mysqli->close();
?>

Příklad 1301. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

if (!mysqli_query($link, "SET a=1")) {
    printf("Errorcode: %d\n", mysqli_errno($link));
}

/* close connection */
mysqli_close($link);
?>

Výše uvedený příklad vypíše:

Errorcode: 1193

Viz také

mysqli_connect_errno()
mysqli_connect_error()
mysqli_error()
mysqli_sqlstate()

Předcházející | Nahoru | Další
mysqli_enable_rpl_parse | Domů | mysqli_error


mysqli_error

Předcházející C. MySQL Improved Extension Další

mysqli_error,

(PHP 5)

mysqli_error, mysqli->error — Returns a string description of the last error

Popis

Procedural style:

string mysqli_error ( mysqli $link )

Object oriented style (property):

class mysqli {
string error
}

Returns the last error message for the most recent MySQLi function call that can succeed or fail.

Seznam parametrů

link

Procedural style only: A link identifier returned by mysqli_connect() or mysqli_init()

Návratové hodnoty

A string that describes the error. An empty string if no error occurred.

Příklady

Příklad 1302. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

if (!$mysqli->query("SET a=1")) {
    printf("Errormessage: %s\n", $mysqli->error);
}

/* close connection */
$mysqli->close();
?>

Příklad 1303. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

if (!mysqli_query($link, "SET a=1")) {
    printf("Errormessage: %s\n", mysqli_error($link));
}

/* close connection */
mysqli_close($link);
?>

Výše uvedený příklad vypíše:

Errormessage: Unknown system variable 'a'

Viz také

mysqli_connect_errno()
mysqli_connect_error()
mysqli_errno()
mysqli_sqlstate()

Předcházející | Nahoru | Další
mysqli_errno | Domů | mysqli_escape_string


mysqli_escape_string

(PHP 5)

mysqli_escape_string — Alias of mysqli_real_escape_string()

Popis

This function is an alias of mysqli_real_escape_string().

Viz také

mysqli_real_escape_string()

Předcházející | Nahoru | Další
mysqli_error | Domů | mysqli_execute


mysqli_execute

(PHP 5)

mysqli_execute — Alias for mysqli_stmt_execute()

Popis

This function is an alias of mysqli_stmt_execute().

Poznámky

Poznámka: mysqli_execute() is deprecated and will be removed.

Viz také

mysqli_stmt_execute()

Předcházející | Nahoru | Další
mysqli_escape_string | Domů | mysqli_fetch_array


mysqli_fetch_array

Předcházející C. MySQL Improved Extension Další

mysqli_fetch_array,

(PHP 5)

mysqli_fetch_array, result->fetch_array() — Fetch a result row as an associative, a numeric array, or both

Popis

Procedural style:

mixed mysqli_fetch_array ( mysqli_result $result [, int $resulttype] )

Object oriented style (method):

class mysqli_result {
mixed fetch_array ( [int $resulttype] )
}

Returns an array that corresponds to the fetched row or NULL if there are no more rows for the resultset represented by the result parameter.

mysqli_fetch_array() is an extended version of the mysqli_fetch_row() function. In addition to storing the data in the numeric indices of the result array, the mysqli_fetch_array() function can also store the data in associative indices, using the field names of the result set as keys.

Poznámka: Názvy polí vrácené touto funkcí rozlišují velikost písmen.

Poznámka: Tato funkce nastavuje pole s hodnotou NULL na hodnotu PHP NULL.

If two or more columns of the result have the same field names, the last column will take precedence and overwrite the earlier data. In order to access multiple columns with the same name, the numerically indexed version of the row must be used.

Seznam parametrů

result

Procedural style only: A result set identifier returned by mysqli_query(), mysqli_store_result() or mysqli_use_result().

resulttype

This optional parameter is a constant indicating what type of array should be produced from the current row data. The possible values for this parameter are the constants MYSQLI_ASSOC, MYSQLI_NUM, or MYSQLI_BOTH. Defaults to MYSQLI_BOTH.

By using the MYSQLI_ASSOC constant this function will behave identically to the mysqli_fetch_assoc(), while MYSQLI_NUM will behave identically to the mysqli_fetch_row() function. The final option MYSQLI_BOTH will create a single array with the attributes of both.

Návratové hodnoty

Returns an array of strings that corresponds to the fetched row or NULL if there are no more rows in resultset.

Příklady

Příklad 1304. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER by ID LIMIT 3";
$result = $mysqli->query($query);

/* numeric array */
$row = $result->fetch_array(MYSQLI_NUM);
printf ("%s (%s)\n", $row[0], $row[1]);

/* associative array */
$row = $result->fetch_array(MYSQLI_ASSOC);
printf ("%s (%s)\n", $row["Name"], $row["CountryCode"]);

/* associative and numeric array */
$row = $result->fetch_array(MYSQLI_BOTH);
printf ("%s (%s)\n", $row[0], $row["CountryCode"]);

/* free result set */
$result->close();

/* close connection */
$mysqli->close();
?>

Příklad 1305. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER by ID LIMIT 3";
$result = mysqli_query($link, $query);

/* numeric array */
$row = mysqli_fetch_array($result, MYSQLI_NUM);
printf ("%s (%s)\n", $row[0], $row[1]);

/* associative array */
$row = mysqli_fetch_array($result, MYSQLI_ASSOC);
printf ("%s (%s)\n", $row["Name"], $row["CountryCode"]);

/* associative and numeric array */
$row = mysqli_fetch_array($result, MYSQLI_BOTH);
printf ("%s (%s)\n", $row[0], $row["CountryCode"]);

/* free result set */
mysqli_free_result($result);

/* close connection */
mysqli_close($link);
?>

Výše uvedený příklad vypíše:

Kabul (AFG)
Qandahar (AFG)
Herat (AFG)

Viz také

mysqli_fetch_assoc()
mysqli_fetch_row()
mysqli_fetch_object()
mysqli_query()
mysqli_data_seek()

Předcházející | Nahoru | Další
mysqli_execute | Domů | mysqli_fetch_assoc


mysqli_fetch_assoc

Předcházející C. MySQL Improved Extension Další

mysqli_fetch_assoc,

(PHP 5)

mysqli_fetch_assoc, mysqli->fetch_assoc() — Fetch a result row as an associative array

Popis

Procedural style:

array mysqli_fetch_assoc ( mysqli_result $result )

Object oriented style (method):

class mysqli_result {
array fetch_assoc ( void )
}

Returns an associative array that corresponds to the fetched row or NULL if there are no more rows.

Poznámka: Názvy polí vrácené touto funkcí rozlišují velikost písmen.

Poznámka: Tato funkce nastavuje pole s hodnotou NULL na hodnotu PHP NULL.

Seznam parametrů

result

Procedural style only: A result set identifier returned by mysqli_query(), mysqli_store_result() or mysqli_use_result().

Návratové hodnoty

Returns an associative array of strings representing the fetched row in the result set, where each key in the array represents the name of one of the result set's columns or NULL if there are no more rows in resultset.

If two or more columns of the result have the same field names, the last column will take precedence. To access the other column(s) of the same name, you either need to access the result with numeric indices by using mysqli_fetch_row() or add alias names.

Příklady

Příklad 1306. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER by ID DESC LIMIT 50,5";

if ($result = $mysqli->query($query)) {

    /* fetch associative array */
    while ($row = $result->fetch_assoc()) {
        printf ("%s (%s)\n", $row["Name"], $row["CountryCode"]);
    }

    /* free result set */
    $result->close();
}

/* close connection */
$mysqli->close();
?>

Příklad 1307. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER by ID DESC LIMIT 50,5";

if ($result = mysqli_query($link, $query)) {

    /* fetch associative array */
    while ($row = mysqli_fetch_assoc($result)) {
        printf ("%s (%s)\n", $row["Name"], $row["CountryCode"]);
    }

    /* free result set */
    mysqli_free_result($result);
}

/* close connection */
mysqli_close($link);
?>

Výše uvedený příklad vypíše:

Pueblo (USA)
Arvada (USA)
Cape Coral (USA)
Green Bay (USA)
Santa Clara (USA)

Viz také

mysqli_fetch_array()
mysqli_fetch_row()
mysqli_fetch_object()
mysqli_query()
mysqli_data_seek()

Předcházející | Nahoru | Další
mysqli_fetch_array | Domů | mysqli_fetch_field_direct


mysqli_fetch_field_direct

Předcházející C. MySQL Improved Extension Další

mysqli_fetch_field_direct,

(PHP 5)

mysqli_fetch_field_direct, result->fetch_field_direct() — Fetch meta-data for a single field

Popis

Procedural style:

object mysqli_fetch_field_direct ( mysqli_result $result, int $fieldnr )

Object oriented style (method):

class mysqli_result {
object fetch_field_direct ( int $fieldnr )
}

Returns an object which contains field definition informations from specified resultset.

Seznam parametrů

result

Procedural style only: A result set identifier returned by mysqli_query(), mysqli_store_result() or mysqli_use_result().

fieldnr

The field number. This value must be in the range from 0 to number of fields - 1.

Návratové hodnoty

Returns an object which contains field definition information or FALSE if no field information for specified fieldnr is available.

Tabulka 176. Object attributes

Attribute | Description
name | The name of the column
orgname | Original column name if an alias was specified
table | The name of the table this field belongs to (if not calculated)
orgtable | Original table name if an alias was specified
def | The default value for this field, represented as a string
max_length | The maximum width of the field for the result set.
length | The width of the field, as specified in the tabl definition.
charsetnr | The character set number for the field.
flags | An integer representing the bit-flags for the field.
type | The data type used for this field
decimals | The number of decimals used (for integer fields)

Příklady

Příklad 1308. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, SurfaceArea from Country ORDER BY Name LIMIT 5";

if ($result = $mysqli->query($query)) {

    /* Get field information for column 'SurfaceArea' */
    $finfo = $result->fetch_field_direct(1);

    printf("Name:     %s\n", $finfo->name);
    printf("Table:    %s\n", $finfo->table);
    printf("max. Len: %d\n", $finfo->max_length);
    printf("Flags:    %d\n", $finfo->flags);
    printf("Type:     %d\n", $finfo->type);

    $result->close();
}

/* close connection */
$mysqli->close();
?>

Příklad 1309. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, SurfaceArea from Country ORDER BY Name LIMIT 5";

if ($result = mysqli_query($link, $query)) {

    /* Get field information for column 'SurfaceArea' */
    $finfo = mysqli_fetch_field_direct($result, 1);

    printf("Name:     %s\n", $finfo->name);
    printf("Table:    %s\n", $finfo->table);
    printf("max. Len: %d\n", $finfo->max_length);
    printf("Flags:    %d\n", $finfo->flags);
    printf("Type:     %d\n", $finfo->type);

    mysqli_free_result($result);
}

/* close connection */
mysqli_close($link);
?>

Výše uvedený příklad vypíše:

Name:     SurfaceArea
Table:    Country
max. Len: 10
Flags:    32769
Type:     4

Viz také

mysqli_num_fields()
mysqli_fetch_field()
mysqli_fetch_fields()

Předcházející | Nahoru | Další
mysqli_fetch_assoc | Domů | mysqli_fetch_field


mysqli_fetch_field

Předcházející C. MySQL Improved Extension Další

mysqli_fetch_field,

(PHP 5)

mysqli_fetch_field, result->fetch_field() — Returns the next field in the result set

Popis

Procedural style:

object mysqli_fetch_field ( mysqli_result $result )

Object oriented style (method):

class mysqli_result {
object fetch_field ( void )
}

Returns the definition of one column of a result set as an object. Call this function repeatedly to retrieve information about all columns in the result set.

Seznam parametrů

result

Procedural style only: A result set identifier returned by mysqli_query(), mysqli_store_result() or mysqli_use_result().

Návratové hodnoty

Returns an object which contains field definition information or FALSE if no field information is available.

Tabulka 177. Object properties

Property | Description
name | The name of the column
orgname | Original column name if an alias was specified
table | The name of the table this field belongs to (if not calculated)
orgtable | Original table name if an alias was specified
def | The default value for this field, represented as a string
max_length | The maximum width of the field for the result set.
length | The width of the field, as specified in the table definition.
charsetnr | The character set number for the field.
flags | An integer representing the bit-flags for the field.
type | The data type used for this field
decimals | The number of decimals used (for integer fields)

Příklady

Příklad 1310. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, SurfaceArea from Country ORDER BY Code LIMIT 5";

if ($result = $mysqli->query($query)) {

    /* Get field information for all columns */
    while ($finfo = $result->fetch_field()) {

        printf("Name:     %s\n", $finfo->name);
        printf("Table:    %s\n", $finfo->table);
        printf("max. Len: %d\n", $finfo->max_length);
        printf("Flags:    %d\n", $finfo->flags);
        printf("Type:     %d\n\n", $finfo->type);
    }
    $result->close();
}

/* close connection */
$mysqli->close();
?>

Příklad 1311. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, SurfaceArea from Country ORDER BY Code LIMIT 5";

if ($result = mysqli_query($link, $query)) {

    /* Get field information for all fields */
    while ($finfo = mysqli_fetch_field($result)) {

        printf("Name:     %s\n", $finfo->name);
        printf("Table:    %s\n", $finfo->table);
        printf("max. Len: %d\n", $finfo->max_length);
        printf("Flags:    %d\n", $finfo->flags);
        printf("Type:     %d\n\n", $finfo->type);
    }
    mysqli_free_result($result);
}

/* close connection */
mysqli_close($link);
?>

Výše uvedený příklad vypíše:

Name:     Name
Table:    Country
max. Len: 11
Flags:    1
Type:     254

Name:     SurfaceArea
Table:    Country
max. Len: 10
Flags:    32769
Type:     4

Viz také

mysqli_num_fields()
mysqli_fetch_field_direct()
mysqli_fetch_fields()
mysqli_field_seek()

Předcházející | Nahoru | Další
mysqli_fetch_field_direct | Domů | mysqli_fetch_fields


mysqli_fetch_fields

Předcházející C. MySQL Improved Extension Další

mysqli_fetch_fields,

(PHP 5)

mysqli_fetch_fields, result->fetch_fields() — Returns an array of objects representing the fields in a result set

Popis

Procedural Style:

array mysqli_fetch_fields ( mysqli_result $result )

Object oriented style (method):

class mysqli_result {
array fetch_fields ( void )
}

This function serves an identical purpose to the mysqli_fetch_field() function with the single difference that, instead of returning one object at a time for each field, the columns are returned as an array of objects.

Seznam parametrů

result

Procedural style only: A result set identifier returned by mysqli_query(), mysqli_store_result() or mysqli_use_result().

Návratové hodnoty

Returns an array of objects which contains field definition information or FALSE if no field information is available.

Tabulka 178. Object properties

Property | Description
name | The name of the column
orgname | Original column name if an alias was specified
table | The name of the table this field belongs to (if not calculated)
orgtable | Original table name if an alias was specified
def | The default value for this field, represented as a string
max_length | The maximum width of the field for the result set.
length | The width of the field, as specified in the table definition.
charsetnr | The character set number for the field.
flags | An integer representing the bit-flags for the field.
type | The data type used for this field
decimals | The number of decimals used (for integer fields)

Příklady

Příklad 1312. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, SurfaceArea from Country ORDER BY Code LIMIT 5";

if ($result = $mysqli->query($query)) {

    /* Get field information for all columns */
    $finfo = $result->fetch_fields();

    foreach ($finfo as $val) {
        printf("Name:     %s\n", $val->name);
        printf("Table:    %s\n", $val->table);
        printf("max. Len: %d\n", $val->max_length);
        printf("Flags:    %d\n", $val->flags);
        printf("Type:     %d\n\n", $val->type);
    }
    $result->close();
}

/* close connection */
$mysqli->close();
?>

Příklad 1313. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, SurfaceArea from Country ORDER BY Code LIMIT 5";

if ($result = mysqli_query($link, $query)) {

    /* Get field information for all columns */
    $finfo = mysqli_fetch_fields($result);

    foreach ($finfo as $val) {
        printf("Name:     %s\n", $val->name);
        printf("Table:    %s\n", $val->table);
        printf("max. Len: %d\n", $val->max_length);
        printf("Flags:    %d\n", $val->flags);
        printf("Type:     %d\n\n", $val->type);
    }
    mysqli_free_result($result);
}

/* close connection */
mysqli_close($link);
?>

Výše uvedený příklad vypíše:

Name:     Name
Table:    Country
max. Len: 11
Flags:    1
Type:     254

Name:     SurfaceArea
Table:    Country
max. Len: 10
Flags:    32769
Type:     4

Viz také

mysqli_num_fields()
mysqli_fetch_field_direct()
mysqli_fetch_field()

Předcházející | Nahoru | Další
mysqli_fetch_field | Domů | mysqli_fetch_lengths


mysqli_fetch_lengths

Předcházející C. MySQL Improved Extension Další

mysqli_fetch_lengths,

(PHP 5)

mysqli_fetch_lengths, result->lengths() — Returns the lengths of the columns of the current row in the result set

Popis

Procedural style:

array mysqli_fetch_lengths ( mysqli_result $result )

Object oriented style (property):

class mysqli_result {
array lengths
}

The mysqli_fetch_lengths() function returns an array containing the lengths of every column of the current row within the result set.

Seznam parametrů

result

Procedural style only: A result set identifier returned by mysqli_query(), mysqli_store_result() or mysqli_use_result().

Návratové hodnoty

An array of integers representing the size of each column (not including any terminating null characters). FALSE if an error occurred.

mysqli_fetch_lengths() is valid only for the current row of the result set. It returns FALSE if you call it before calling mysqli_fetch_row/array/object or after retrieving all rows in the result.

Příklady

Příklad 1314. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT * from Country ORDER BY Code LIMIT 1";

if ($result = $mysqli->query($query)) {

    $row = $result->fetch_row();

    /* display column lengths */
    foreach ($result->lengths as $i => $val) {
        printf("Field %2d has Length %2d\n", $i+1, $val);
    }
    $result->close();
}

/* close connection */
$mysqli->close();
?>

Příklad 1315. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT * from Country ORDER BY Code LIMIT 1";

if ($result = mysqli_query($link, $query)) {

    $row = mysqli_fetch_row($result);

    /* display column lengths */
    foreach (mysqli_fetch_lengths($result) as $i => $val) {
        printf("Field %2d has Length %2d\n", $i+1, $val);
    }
    mysqli_free_result($result);
}

/* close connection */
mysqli_close($link);
?>

Výše uvedený příklad vypíše:

Field  1 has Length  3
Field  2 has Length  5
Field  3 has Length 13
Field  4 has Length  9
Field  5 has Length  6
Field  6 has Length  1
Field  7 has Length  6
Field  8 has Length  4
Field  9 has Length  6
Field 10 has Length  6
Field 11 has Length  5
Field 12 has Length 44
Field 13 has Length  7
Field 14 has Length  3
Field 15 has Length  2

Předcházející | Nahoru | Další
mysqli_fetch_fields | Domů | mysqli_fetch_object


mysqli_fetch_object

Předcházející C. MySQL Improved Extension Další

mysqli_fetch_object,

(PHP 5)

mysqli_fetch_object, result->fetch_object() — Returns the current row of a result set as an object

Popis

Procedural style:

object mysqli_fetch_object ( mysqli_result $result [, string $class_name [, array $params]] )

Object oriented style (method):

class mysqli_result {
object fetch_object ( [string $class_name [, array $params]] )
}

The mysqli_fetch_object() will return the current row result set as an object where the attributes of the object represent the names of the fields found within the result set.

Seznam parametrů

result

Procedural style only: A result set identifier returned by mysqli_query(), mysqli_store_result() or mysqli_use_result().

class_name

params

Návratové hodnoty

Returns an object with string properties that corresponds to the fetched row or NULL if there are no more rows in resultset.

Poznámka: Názvy polí vrácené touto funkcí rozlišují velikost písmen.

Poznámka: Tato funkce nastavuje pole s hodnotou NULL na hodnotu PHP NULL.

ChangeLog (záznam změn)

Verze | Popis
5.0.0 | Added the ability to return as a different object.

Příklady

Příklad 1316. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER by ID DESC LIMIT 50,5";

if ($result = $mysqli->query($query)) {

    /* fetch object array */
    while ($obj = $result->fetch_object()) {
        printf ("%s (%s)\n", $obj->Name, $obj->CountryCode);
    }

    /* free result set */
    $result->close();
}

/* close connection */
$mysqli->close();
?>

Příklad 1317. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER by ID DESC LIMIT 50,5";

if ($result = mysqli_query($link, $query)) {

    /* fetch associative array */
    while ($obj = mysqli_fetch_object($result)) {
        printf ("%s (%s)\n", $obj->Name, $obj->CountryCode);
    }

    /* free result set */
    mysqli_free_result($result);
}

/* close connection */
mysqli_close($link);
?>

Výše uvedený příklad vypíše:

Pueblo (USA)
Arvada (USA)
Cape Coral (USA)
Green Bay (USA)
Santa Clara (USA)

Viz také

mysqli_fetch_array()
mysqli_fetch_assoc()
mysqli_fetch_row()
mysqli_query()
mysqli_data_seek()

Předcházející | Nahoru | Další
mysqli_fetch_lengths | Domů | mysqli_fetch_row


mysqli_fetch_row

Předcházející C. MySQL Improved Extension Další

mysqli_fetch_row,

(PHP 5)

mysqli_fetch_row, result->fetch_row() — Get a result row as an enumerated array

Popis

Procedural style:

mixed mysqli_fetch_row ( mysqli_result $result )

Object oriented style (method):

class mysqli_result {
mixed fetch_row ( void )
}

Fetches one row of data from the result set and returns it as an enumerated array, where each column is stored in an array offset starting from 0 (zero). Each subsequent call to this function will return the next row within the result set, or NULL if there are no more rows.

Seznam parametrů

result

Procedural style only: A result set identifier returned by mysqli_query(), mysqli_store_result() or mysqli_use_result().

Návratové hodnoty

mysqli_fetch_row() returns an array of strings that corresponds to the fetched row or NULL if there are no more rows in result set.

Poznámka: Tato funkce nastavuje pole s hodnotou NULL na hodnotu PHP NULL.

Příklady

Příklad 1318. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER by ID DESC LIMIT 50,5";

if ($result = $mysqli->query($query)) {

    /* fetch object array */
    while ($row = $result->fetch_row()) {
        printf ("%s (%s)\n", $row[0], $row[1]);
    }

    /* free result set */
    $result->close();
}

/* close connection */
$mysqli->close();
?>

Příklad 1319. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER by ID DESC LIMIT 50,5";

if ($result = mysqli_query($link, $query)) {

    /* fetch associative array */
    while ($row = mysqli_fetch_row($result)) {
        printf ("%s (%s)\n", $row[0], $row[1]);
    }

    /* free result set */
    mysqli_free_result($result);
}

/* close connection */
mysqli_close($link);
?>

Výše uvedený příklad vypíše:

Pueblo (USA)
Arvada (USA)
Cape Coral (USA)
Green Bay (USA)
Santa Clara (USA)

Viz také

mysqli_fetch_array()
mysqli_fetch_assoc()
mysqli_fetch_object()
mysqli_query()
mysqli_data_seek()

Předcházející | Nahoru | Další
mysqli_fetch_object | Domů | mysqli_fetch


mysqli_fetch

(PHP 5)

mysqli_fetch — Alias for mysqli_stmt_fetch()

Popis

This function is an alias of mysqli_stmt_fetch().

Poznámky

Poznámka: mysqli_fetch() is deprecated and will be removed.

Viz také

mysqli_stmt_fetch()

Předcházející | Nahoru | Další
mysqli_fetch_row | Domů | mysqli_field_count


mysqli_field_count

Předcházející C. MySQL Improved Extension Další

mysqli_field_count,

(PHP 5)

mysqli_field_count, mysqli->field_count — Returns the number of columns for the most recent query

Popis

Procedural style:

int mysqli_field_count ( mysqli $link )

Object oriented style (property):

class mysqli_result {
int field_count
}

Returns the number of columns for the most recent query on the connection represented by the link parameter. This function can be useful when using the mysqli_store_result() function to determine if the query should have produced a non-empty result set or not without knowing the nature of the query.

Seznam parametrů

link

Procedural style only: A link identifier returned by mysqli_connect() or mysqli_init()

Návratové hodnoty

An integer representing the number of fields in a result set.

Příklady

Příklad 1320. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "test");

$mysqli->query( "DROP TABLE IF EXISTS friends");
$mysqli->query( "CREATE TABLE friends (id int, name varchar(20))");

$mysqli->query( "INSERT INTO friends VALUES (1,'Hartmut'), (2, 'Ulf')");

$mysqli->real_query($HTTP_POST_VARS['query']);

if ($mysqli->field_count) {
    /* this was a select/show or describe query */
    $result = $mysqli->store_result();

    /* process resultset */
    $row = $result->fetch_row();

    /* free resultset */
    $result->close();
}

/* close connection */
$mysqli->close();
?>

Příklad 1321. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "test");

mysqli_query($link, "DROP TABLE IF EXISTS friends");
mysqli_query($link, "CREATE TABLE friends (id int, name varchar(20))");

mysqli_query($link, "INSERT INTO friends VALUES (1,'Hartmut'), (2, 'Ulf')");

mysqli_real_query($link, $HTTP_POST_VARS['query']);

if (mysqli_field_count($link)) {
    /* this was a select/show or describe query */
    $result = mysqli_store_result($link);

    /* process resultset */
    $row = mysqli_fetch_row($result);

    /* free resultset */
    mysqli_free_result($result);
}

/* close connection */
mysqli_close($link);
?>

Předcházející | Nahoru | Další
mysqli_fetch | Domů | mysqli_field_seek


mysqli_field_seek

Předcházející C. MySQL Improved Extension Další

mysqli_field_seek,

(PHP 5)

mysqli_field_seek, result->field_seek() — Set result pointer to a specified field offset

Popis

Procedural style:

bool mysqli_field_seek ( mysqli_result $result, int $fieldnr )

Object oriented style (method):

class mysqli_result {
bool field_seek ( int $fieldnr )
}

Sets the field cursor to the given offset. The next call to mysqli_fetch_field() will retrieve the field definition of the column associated with that offset.

Poznámka: To seek to the beginning of a row, pass an offset value of zero.

Seznam parametrů

result

Procedural style only: A result set identifier returned by mysqli_query(), mysqli_store_result() or mysqli_use_result().

fieldnr

The field number. This value must be in the range from 0 to number of fields - 1.

Návratové hodnoty

Returns the previous value of field cursor.

Příklady

Příklad 1322. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, SurfaceArea from Country ORDER BY Code LIMIT 5";

if ($result = $mysqli->query($query)) {

    /* Get field information for 2nd column */
    $result->field_seek(1);
    $finfo = $result->fetch_field();

    printf("Name:     %s\n", $finfo->name);
    printf("Table:    %s\n", $finfo->table);
    printf("max. Len: %d\n", $finfo->max_length);
    printf("Flags:    %d\n", $finfo->flags);
    printf("Type:     %d\n\n", $finfo->type);

    $result->close();
}

/* close connection */
$mysqli->close();
?>

Příklad 1323. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, SurfaceArea from Country ORDER BY Code LIMIT 5";

if ($result = mysqli_query($link, $query)) {

    /* Get field information for 2nd column */
    mysqli_field_seek($result, 1);
    $finfo = mysqli_fetch_field($result);

    printf("Name:     %s\n", $finfo->name);
    printf("Table:    %s\n", $finfo->table);
    printf("max. Len: %d\n", $finfo->max_length);
    printf("Flags:    %d\n", $finfo->flags);
    printf("Type:     %d\n\n", $finfo->type);

    mysqli_free_result($result);
}

/* close connection */
mysqli_close($link);
?>

Výše uvedený příklad vypíše:

Name:     SurfaceArea
Table:    Country
max. Len: 10
Flags:    32769
Type:     4

Viz také

mysqli_fetch_field()

Předcházející | Nahoru | Další
mysqli_field_count | Domů | mysqli_field_tell


mysqli_field_tell

Předcházející C. MySQL Improved Extension Další

mysqli_field_tell,

(PHP 5)

mysqli_field_tell, result->current_field — Get current field offset of a result pointer

Popis

Procedural style:

int mysqli_field_tell ( mysqli_result $result )

Object oriented style (property):

class mysqli_result {
int current_field
}

Returns the position of the field cursor used for the last mysqli_fetch_field() call. This value can be used as an argument to mysqli_field_seek().

Seznam parametrů

result

Procedural style only: A result set identifier returned by mysqli_query(), mysqli_store_result() or mysqli_use_result().

Návratové hodnoty

Returns current offset of field cursor.

Příklady

Příklad 1324. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, SurfaceArea from Country ORDER BY Code LIMIT 5";

if ($result = $mysqli->query($query)) {

    /* Get field information for all columns */
    while ($finfo = $result->fetch_field()) {

        /* get fieldpointer offset */
        $currentfield = $result->current_field;

        printf("Column %d:\n", $currentfield);
        printf("Name:     %s\n", $finfo->name);
        printf("Table:    %s\n", $finfo->table);
        printf("max. Len: %d\n", $finfo->max_length);
        printf("Flags:    %d\n", $finfo->flags);
        printf("Type:     %d\n\n", $finfo->type);
    }
    $result->close();
}

/* close connection */
$mysqli->close();
?>

Příklad 1325. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, SurfaceArea from Country ORDER BY Code LIMIT 5";

if ($result = mysqli_query($link, $query)) {

    /* Get field information for all fields */
    while ($finfo = mysqli_fetch_field($result)) {

        /* get fieldpointer offset */
        $currentfield = mysqli_field_tell($result);

        printf("Column %d:\n", $currentfield);
        printf("Name:     %s\n", $finfo->name);
        printf("Table:    %s\n", $finfo->table);
        printf("max. Len: %d\n", $finfo->max_length);
        printf("Flags:    %d\n", $finfo->flags);
        printf("Type:     %d\n\n", $finfo->type);
    }
    mysqli_free_result($result);
}

/* close connection */
mysqli_close($link);
?>

Výše uvedený příklad vypíše:

Column 1:
Name:     Name
Table:    Country
max. Len: 11
Flags:    1
Type:     254

Column 2:
Name:     SurfaceArea
Table:    Country
max. Len: 10
Flags:    32769
Type:     4

Viz také

mysqli_fetch_field()
mysqli_field_seek()

Předcházející | Nahoru | Další
mysqli_field_seek | Domů | mysqli_free_result


mysqli_free_result

Předcházející C. MySQL Improved Extension Další

mysqli_free_result,

(PHP 5)

mysqli_free_result, result->free() — Frees the memory associated with a result

Popis

Procedural style:

void mysqli_free_result ( mysqli_result $result )

Object oriented style (all methods are equivalent):

class mysqli_result {
void free ( void )
void close ( void )
void free_result ( void )
}

Frees the memory associated with the result.

Poznámka: You should always free your result with mysqli_free_result(), when your result object is not needed anymore.

Seznam parametrů

result

Procedural style only: A result set identifier returned by mysqli_query(), mysqli_store_result() or mysqli_use_result().

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

mysqli_query()
mysqli_stmt_store_result()
mysqli_store_result()
mysqli_use_result()

Předcházející | Nahoru | Další
mysqli_field_tell | Domů | mysqli_get_charset


mysqli_get_client_info

(PHP 5)

mysqli_get_client_info — Returns the MySQL client version as a string

Popis

string mysqli_get_client_info ( void )

The mysqli_get_client_info() function is used to return a string representing the client version being used in the MySQLi extension.

Návratové hodnoty

A string that represents the MySQL client library version

Příklady

Příklad 1326. mysqli_get_client_info

<?php

/* We don't need a connection to determine
   the version of mysql client library */

printf("Client library version: %s\n", mysqli_get_client_info());
?>

Viz také

mysqli_get_client_version()
mysqli_get_server_info()
mysqli_get_server_version()

Předcházející | Nahoru | Další
mysqli_get_charset | Domů | mysqli_get_client_version


mysqli_get_client_version

(PHP 5)

mysqli_get_client_version — Get MySQL client info

Popis

int mysqli_get_client_version ( void )

Returns client version number as an integer.

Návratové hodnoty

A number that represents the MySQL client library version in format: main_version*10000 + minor_version *100 + sub_version. For example, 4.1.0 is returned as 40100.

This is useful to quickly determine the version of the client library to know if some capability exits.

Příklady

Příklad 1327. mysqli_get_client_version

<?php

/* We don't need a connection to determine
   the version of mysql client library */

printf("Client library version: %d\n", mysqli_get_client_version());
?>

Viz také

mysqli_get_client_info()
mysqli_get_server_info()
mysqli_get_server_version()

Předcházející | Nahoru | Další
mysqli_get_client_info | Domů | mysqli_get_host_info


mysqli_get_host_info

Předcházející C. MySQL Improved Extension Další

mysqli_get_host_info,

(PHP 5)

mysqli_get_host_info, mysqli->host_info — Returns a string representing the type of connection used

Popis

Procdural style:

string mysqli_get_host_info ( mysqli $link )

Object oriented style (property):

class mysqli {
string host_info
}

The mysqli_get_host_info() function returns a string describing the connection represented by the link parameter is using (including the server host name).

Seznam parametrů

link

Procedural style only: A link identifier returned by mysqli_connect() or mysqli_init()

Návratové hodnoty

A character string representing the server hostname and the connection type.

Příklady

Příklad 1328. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* print host information */
printf("Host info: %s\n", $mysqli->host_info);

/* close connection */
$mysqli->close();
?>

Příklad 1329. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* print host information */
printf("Host info: %s\n", mysqli_get_host_info($link));

/* close connection */
mysqli_close($link);
?>

Výše uvedený příklad vypíše:

Host info: Localhost via UNIX socket

Viz také

mysqli_get_proto_info()

Předcházející | Nahoru | Další
mysqli_get_client_version | Domů | mysqli_get_metadata


mysqli_get_metadata

(PHP 5)

mysqli_get_metadata — Alias for mysqli_stmt_result_metadata()

Popis

This function is an alias of mysqli_stmt_result_metadata().

Poznámky

Poznámka: mysqli_get_metadata() is deprecated and will be removed.

Viz také

mysqli_stmt_result_metadata()

Předcházející | Nahoru | Další
mysqli_get_host_info | Domů | mysqli_get_proto_info


mysqli_get_proto_info

Předcházející C. MySQL Improved Extension Další

mysqli_get_proto_info,

(PHP 5)

mysqli_get_proto_info, mysqli->protocol_version — Returns the version of the MySQL protocol used

Popis

Procedural style:

int mysqli_get_proto_info ( mysqli $link )

Object oriented style (property):

class mysqli {
string protocol_version
}

Returns an integer representing the MySQL protocol version used by the connection represented by the link parameter.

Seznam parametrů

link

Procedural style only: A link identifier returned by mysqli_connect() or mysqli_init()

Návratové hodnoty

Returns an integer representing the protocol version.

Příklady

Příklad 1330. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* print protocol version */
printf("Protocol version: %d\n", $mysqli->protocol_version);

/* close connection */
$mysqli->close();
?>

Příklad 1331. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* print protocol version */
printf("Protocol version: %d\n", mysqli_get_proto_info($link));

/* close connection */
mysqli_close($link);
?>

Výše uvedený příklad vypíše:

Protocol version: 10

Viz také

mysqli_get_host_info()

Předcházející | Nahoru | Další
mysqli_get_metadata | Domů | mysqli_get_server_info


mysqli_get_server_info

Předcházející C. MySQL Improved Extension Další

mysqli_get_server_info,

(PHP 5)

mysqli_get_server_info, mysqli->server_info — Returns the version of the MySQL server

Popis

Procedural style:

string mysqli_get_server_info ( mysqli $link )

Object oriented style (property):

class mysqli {
string server_info
}

Returns a string representing the version of the MySQL server that the MySQLi extension is connected to.

Seznam parametrů

link

Procedural style only: A link identifier returned by mysqli_connect() or mysqli_init()

Návratové hodnoty

A character string representing the server version.

Příklady

Příklad 1332. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* print server version */
printf("Server version: %s\n", $mysqli->server_info);

/* close connection */
$mysqli->close();
?>

Příklad 1333. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* print server version */
printf("Server version: %s\n", mysqli_get_server_info($link));

/* close connection */
mysqli_close($link);
?>

Výše uvedený příklad vypíše:

Server version: 4.1.2-alpha-debug

Viz také

mysqli_get_client_info()
mysqli_get_client_version()
mysqli_get_server_version()

Předcházející | Nahoru | Další
mysqli_get_proto_info | Domů | mysqli_get_server_version


mysqli_get_server_version

Předcházející C. MySQL Improved Extension Další

mysqli_get_server_version,

(PHP 5)

mysqli_get_server_version, mysqli->server_version — Returns the version of the MySQL server as an integer

Popis

Procedural style:

int mysqli_get_server_version ( mysqli $link )

Object oriented style (property):

class mysqli {
int server_version
}

The mysqli_get_server_version() function returns the version of the server connected to (represented by the link parameter) as an integer.

Seznam parametrů

link

Procedural style only: A link identifier returned by mysqli_connect() or mysqli_init()

Návratové hodnoty

An integer representing the server version.

The form of this version number is main_version * 10000 + minor_version * 100 + sub_version (i.e. version 4.1.0 is 40100).

Příklady

Příklad 1334. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* print server version */
printf("Server version: %d\n", $mysqli->server_version);

/* close connection */
$mysqli->close();
?>

Příklad 1335. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* print server version */
printf("Server version: %d\n", mysqli_get_server_version($link));

/* close connection */
mysqli_close($link);
?>

Výše uvedený příklad vypíše:

Server version: 40102

Viz také

mysqli_get_client_info()
mysqli_get_client_version()
mysqli_get_server_info()

Předcházející | Nahoru | Další
mysqli_get_server_info | Domů | mysqli_get_warnings


mysqli_info

Předcházející C. MySQL Improved Extension Další

mysqli_info,

(PHP 5)

mysqli_info, mysqli->info — Retrieves information about the most recently executed query

Popis

Procedural style:

string mysqli_info ( mysqli $link )

Object oriented style (property)

class mysqli {
string info
}

The mysqli_info() function returns a string providing information about the last query executed. The nature of this string is provided below:

Tabulka 179. Possible mysqli_info return values

Query type | Example result string
INSERT INTO...SELECT... | Records: 100 Duplicates: 0 Warnings: 0
INSERT INTO...VALUES (...),(...),(...) | Records: 3 Duplicates: 0 Warnings: 0
LOAD DATA INFILE ... | Records: 1 Deleted: 0 Skipped: 0 Warnings: 0
ALTER TABLE ... | Records: 3 Duplicates: 0 Warnings: 0
UPDATE ... | Rows matched: 40 Changed: 40 Warnings: 0

Poznámka: Queries which do not fall into one of the above formats are not supported. In these situations, mysqli_info() will return an empty string.

Seznam parametrů

link

Procedural style only: A link identifier returned by mysqli_connect() or mysqli_init()

Návratové hodnoty

A character string representing additional information about the most recently executed query.

Příklady

Příklad 1336. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$mysqli->query("CREATE TEMPORARY TABLE t1 LIKE City");

/* INSERT INTO .. SELECT */
$mysqli->query("INSERT INTO t1 SELECT * FROM City ORDER BY ID LIMIT 150");
printf("%s\n", $mysqli->info);

/* close connection */
$mysqli->close();
?>

Příklad 1337. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

mysqli_query($link, "CREATE TEMPORARY TABLE t1 LIKE City");

/* INSERT INTO .. SELECT */
mysqli_query($link, "INSERT INTO t1 SELECT * FROM City ORDER BY ID LIMIT 150");
printf("%s\n", mysqli_info($link));

/* close connection */
mysqli_close($link);
?>

Výše uvedený příklad vypíše:

Records: 150  Duplicates: 0  Warnings: 0

Viz také

mysqli_affected_rows()
mysqli_warning_count()
mysqli_num_rows()

Předcházející | Nahoru | Další
mysqli_get_warnings | Domů | mysqli_init


mysqli_init

(PHP 5)

mysqli_init — Initializes MySQLi and returns a resource for use with mysqli_real_connect()

Popis

Procedural style:

mysqli mysqli_init ( void )

Object oriented style (method):

class mysqli {
mysqli init ( void )
}

Allocates or initializes a MYSQL object suitable for mysqli_options() and mysqli_real_connect().

Poznámka: Any subsequent calls to any mysqli function (except mysqli_options()) will fail until mysqli_real_connect() was called.

Návratové hodnoty

Returns an object.

Viz také

mysqli_options()
mysqli_close()
mysqli_real_connect()
mysqli_connect()

Předcházející | Nahoru | Další
mysqli_info | Domů | mysqli_insert_id


mysqli_insert_id

Předcházející C. MySQL Improved Extension Další

mysqli_insert_id,

(PHP 5)

mysqli_insert_id, mysqli->insert_id — Returns the auto generated id used in the last query

Popis

Procedural style:

int mysqli_insert_id ( mysqli $link )

Object oriented style (property):

class mysqli {
int insert_id
}

The mysqli_insert_id() function returns the ID generated by a query on a table with a column having the AUTO_INCREMENT attribute. If the last query wasn't an INSERT or UPDATE statement or if the modified table does not have a column with the AUTO_INCREMENT attribute, this function will return zero.

Poznámka: Performing an INSERT or UPDATE statement using the LAST_INSERT_ID() function will also modify the value returned by the mysqli_insert_id() function.

Seznam parametrů

link

Procedural style only: A link identifier returned by mysqli_connect() or mysqli_init()

Návratové hodnoty

The value of the AUTO_INCREMENT field that was updated by the previous query. Returns zero if there was no previous query on the connection or if the query did not update an AUTO_INCREMENT value.

Poznámka: If the number is greater than maximal int value, mysqli_insert_id() will return a string.

Příklady

Příklad 1338. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$mysqli->query("CREATE TABLE myCity LIKE City");

$query = "INSERT INTO myCity VALUES (NULL, 'Stuttgart', 'DEU', 'Stuttgart', 617000)";
$mysqli->query($query);

printf ("New Record has id %d.\n", $mysqli->insert_id);

/* drop table */
$mysqli->query("DROP TABLE myCity");

/* close connection */
$mysqli->close();
?>

Příklad 1339. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

mysqli_query($link, "CREATE TABLE myCity LIKE City");

$query = "INSERT INTO myCity VALUES (NULL, 'Stuttgart', 'DEU', 'Stuttgart', 617000)";
mysqli_query($link, $query);

printf ("New Record has id %d.\n", mysqli_insert_id($link));

/* drop table */
mysqli_query($link, "DROP TABLE myCity");

/* close connection */
mysqli_close($link);
?>

Výše uvedený příklad vypíše:

New Record has id 1.

Předcházející | Nahoru | Další
mysqli_init | Domů | mysqli_kill


mysqli_kill

Předcházející C. MySQL Improved Extension Další

mysqli_kill,

(PHP 5)

mysqli_kill, mysqli->kill() — Asks the server to kill a MySQL thread

Popis

Procedural style:

bool mysqli_kill ( mysqli $link, int $processid )

Object oriented style (method)

class mysqli {
bool kill ( int $processid )
}

This function is used to ask the server to kill a MySQL thread specified by the processid parameter. This value must be retrieved by calling the mysqli_thread_id() function.

To stop a running query you should use the SQL command KILL QUERY processid.

Seznam parametrů

link

Procedural style only: A link identifier returned by mysqli_connect() or mysqli_init()

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1340. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* determine our thread id */
$thread_id = $mysqli->thread_id;

/* Kill connection */
$mysqli->kill($thread_id);

/* This should produce an error */
if (!$mysqli->query("CREATE TABLE myCity LIKE City")) {
    printf("Error: %s\n", $mysqli->error);
    exit;
}

/* close connection */
$mysqli->close();
?>

Příklad 1341. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* determine our thread id */
$thread_id = mysqli_thread_id($link);

/* Kill connection */
mysqli_kill($link, $thread_id);

/* This should produce an error */
if (!mysqli_query($link, "CREATE TABLE myCity LIKE City")) {
    printf("Error: %s\n", mysqli_error($link));
    exit;
}

/* close connection */
mysqli_close($link);
?>

Výše uvedený příklad vypíše:

Error: MySQL server has gone away

Viz také

mysqli_thread_id()

Předcházející | Nahoru | Další
mysqli_insert_id | Domů | mysqli_master_query


mysqli_master_query

(PHP 5)

mysqli_master_query — Enforce execution of a query on the master in a master/slave setup

Popis

bool mysqli_master_query ( mysqli $link, string $query )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
mysqli_kill | Domů | mysqli_more_results


mysqli_more_results

Předcházející C. MySQL Improved Extension Další

mysqli_more_results,

(PHP 5)

mysqli_more_results, mysqli->more_results — Check if there are any more query results from a multi query

Popis

bool mysqli_more_results ( mysqli $link )

Indicates if one or more result sets are available from a previous call to mysqli_multi_query().

Seznam parametrů

link

Procedural style only: A link identifier returned by mysqli_connect() or mysqli_init()

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

See mysqli_multi_query().

Viz také

mysqli_multi_query()
mysqli_next_result()
mysqli_store_result()
mysqli_use_result()

Předcházející | Nahoru | Další
mysqli_master_query | Domů | mysqli_multi_query


mysqli_multi_query

Předcházející C. MySQL Improved Extension Další

mysqli_multi_query,

(PHP 5)

mysqli_multi_query, mysqli->multi_query() — Performs a query on the database

Popis

Procedural style:

bool mysqli_multi_query ( mysqli $link, string $query )

Object oriented style (method):

class mysqli {
bool multi_query ( string $query )
}

Executes one or multiple queries which are concatenated by a semicolon.

To retrieve the resultset from the first query you can use mysqli_use_result() or mysqli_store_result(). All subsequent query results can be processed using mysqli_more_results() and mysqli_next_result().

Seznam parametrů

link

Procedural style only: A link identifier returned by mysqli_connect() or mysqli_init()

query

The query, as a string.

Návratové hodnoty

Returns FALSE if the first statement failed. To retrieve subsequent errors from other statements you have to call mysqli_next_result() first.

Příklady

Příklad 1342. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query  = "SELECT CURRENT_USER();";
$query .= "SELECT Name FROM City ORDER BY ID LIMIT 20, 5";

/* execute multi query */
if ($mysqli->multi_query($query)) {
    do {
        /* store first result set */
        if ($result = $mysqli->store_result()) {
            while ($row = $result->fetch_row()) {
                printf("%s\n", $row[0]);
            }
            $result->close();
        }
        /* print divider */
        if ($mysqli->more_results()) {
            printf("-----------------\n");
        }
    } while ($mysqli->next_result());
}

/* close connection */
$mysqli->close();
?>

Příklad 1343. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query  = "SELECT CURRENT_USER();";
$query .= "SELECT Name FROM City ORDER BY ID LIMIT 20, 5";

/* execute multi query */
if (mysqli_multi_query($link, $query)) {
    do {
        /* store first result set */
        if ($result = mysqli_store_result($link)) {
            while ($row = mysqli_fetch_row($result)) {
                printf("%s\n", $row[0]);
            }
            mysqli_free_result($result);
        }
        /* print divider */
        if (mysqli_more_results($link)) {
            printf("-----------------\n");
        }
    } while (mysqli_next_result($link));
}

/* close connection */
mysqli_close($link);
?>

Výše uvedený příklad vypíše něco jako:

my_user@localhost
-----------------
Amersfoort
Maastricht
Dordrecht
Leiden
Haarlemmermeer

Viz také

mysqli_use_result()
mysqli_store_result()
mysqli_next_result()
mysqli_more_results()

Předcházející | Nahoru | Další
mysqli_more_results | Domů | mysqli_next_result


mysqli_next_result

Předcházející C. MySQL Improved Extension Další

mysqli_next_result,

(PHP 5)

mysqli_next_result, mysqli->next_result() — Prepare next result from multi_query

Popis

bool mysqli_next_result ( mysqli $link )

Prepares next result set from a previous call to
mysqli_multi_query() which can be retrieved by
mysqli_store_result() or
mysqli_use_result().

Seznam parametrů

link

Procedural style only: A link identifier returned by mysqli_connect() or mysqli_init()

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

See mysqli_multi_query().

Viz také

mysqli_multi_query()
mysqli_more_results()
mysqli_store_result()
mysqli_use_result()

Předcházející | Nahoru | Další
mysqli_multi_query | Domů | mysqli_num_fields


mysqli_num_fields

Předcházející C. MySQL Improved Extension Další

mysqli_num_fields,

(PHP 5)

mysqli_num_fields, result->field_count — Get the number of fields in a result

Popis

Procedural style:

int mysqli_num_fields ( mysqli_result $result )

Object oriented style (property):

class mysqli_result {
int field_count
}

Returns the number of fields from specified result set.

Seznam parametrů

result

Procedural style only: A result set identifier returned by mysqli_query(), mysqli_store_result() or mysqli_use_result().

Návratové hodnoty

The number of fields from a result set.

Příklady

Příklad 1344. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

if ($result = $mysqli->query("SELECT * FROM City ORDER BY ID LIMIT 1")) {

    /* determine number of fields in result set */
    $field_cnt = $result->field_count;

    printf("Result set has %d fields.\n", $field_cnt);

    /* close result set */
    $result->close();
}

/* close connection */
$mysqli->close();
?>

Příklad 1345. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

if ($result = mysqli_query($link, "SELECT * FROM City ORDER BY ID LIMIT 1")) {

    /* determine number of fields in result set */
    $field_cnt = mysqli_num_fields($result);

    printf("Result set has %d fields.\n", $field_cnt);

    /* close result set */
    mysqli_free_result($result);
}

/* close connection */
mysqli_close($link);
?>

Výše uvedený příklad vypíše:

Result set has 5 fields.

Viz také

mysqli_fetch_field()

Předcházející | Nahoru | Další
mysqli_next_result | Domů | mysqli_num_rows


mysqli_num_rows

Předcházející C. MySQL Improved Extension Další

mysqli_num_rows,

(PHP 5)

mysqli_num_rows, result->num_rows — Gets the number of rows in a result

Popis

Procedural style:

int mysqli_num_rows ( mysqli_result $result )

Object oriented style (property):

class mysqli_result {
int num_rows
}

Returns the number of rows in the result set.

The use of mysqli_num_rows() depends on whether you use buffered or unbuffered result sets. In case you use unbuffered resultsets mysqli_num_rows() will not correct the correct number of rows until all the rows in the result have been retrieved.

Seznam parametrů

result

Procedural style only: A result set identifier returned by mysqli_query(), mysqli_store_result() or mysqli_use_result().

Návratové hodnoty

Returns number of rows in the result set.

Poznámka: If the number of rows is greater than maximal int value, the number will be returned as a string.

Příklady

Příklad 1346. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

if ($result = $mysqli->query("SELECT Code, Name FROM Country ORDER BY Name")) {

    /* determine number of rows result set */
    $row_cnt = $result->num_rows;

    printf("Result set has %d rows.\n", $row_cnt);

    /* close result set */
    $result->close();
}

/* close connection */
$mysqli->close();
?>

Příklad 1347. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

if ($result = mysqli_query($link, "SELECT Code, Name FROM Country ORDER BY Name")) {

    /* determine number of rows result set */
    $row_cnt = mysqli_num_rows($result);

    printf("Result set has %d rows.\n", $row_cnt);

    /* close result set */
    mysqli_free_result($result);
}

/* close connection */
mysqli_close($link);
?>

Výše uvedený příklad vypíše:

Result set has 239 rows.

Viz také

mysqli_affected_rows()
mysqli_store_result()
mysqli_use_result()
mysqli_query()

Předcházející | Nahoru | Další
mysqli_num_fields | Domů | mysqli_options


mysqli_options

Předcházející C. MySQL Improved Extension Další

mysqli_options,

(PHP 5)

mysqli_options, mysqli->options() — Set options

Popis

Procedural style:

bool mysqli_options ( mysqli $link, int $option, mixed $value )

Object oriented style (method)

class mysqli {
bool options ( int $option, mixed $value )
}

Used to set extra connect options and affect behavior for a connection.

This function may be called multiple times to set several options.

mysqli_options() should be called after
mysqli_init() and before
mysqli_real_connect().

Seznam parametrů

link

Procedural style only: A link identifier returned by mysqli_connect() or mysqli_init()

option

The option that you want to set. It can be one of the following values:

Tabulka 180. Valid options

Name | Description
MYSQLI_OPT_CONNECT_TIMEOUT | connection timeout in seconds
MYSQLI_OPT_LOCAL_INFILE | enable/disable use of LOAD LOCAL INFILE
MYSQLI_INIT_COMMAND | command to execute after when connecting to MySQL server
MYSQLI_READ_DEFAULT_FILE | Read options from named option file instead of my.cnf
MYSQLI_READ_DEFAULT_GROUP | Read options from the named group from my.cnf or the file specified with MYSQL_READ_DEFAULT_FILE.

value

The value for the option.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

See mysqli_real_connect().

Viz také

mysqli_init()
mysqli_real_connect()

Předcházející | Nahoru | Další
mysqli_num_rows | Domů | mysqli_param_count


mysqli_param_count

(PHP 5)

mysqli_param_count — Alias for mysqli_stmt_param_count()

Popis

This function is an alias of mysqli_stmt_param_count().

Poznámky

Poznámka: mysqli_param_count() is deprecated and will be removed.

Viz také

mysqli_stmt_param_count()

Předcházející | Nahoru | Další
mysqli_options | Domů | mysqli_ping


mysqli_ping

Předcházející C. MySQL Improved Extension Další

mysqli_ping,

(PHP 5)

mysqli_ping, mysqli->ping() — Pings a server connection, or tries to reconnect if the connection has gone down

Popis

Procedural style:

bool mysqli_ping ( mysqli $link )

Object oriented style (method):

class mysqli {
bool ping ( void )
}

Checks whether the connection to the server is working. If it has gone down, and global option mysqli.reconnect is enabled an automatic reconnection is attempted.

This function can be used by clients that remain idle for a long while, to check whether the server has closed the connection and reconnect if necessary.

Seznam parametrů

link

Procedural style only: A link identifier returned by mysqli_connect() or mysqli_init()

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1348. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* check if server is alive */
if ($mysqli->ping()) {
    printf ("Our connection is ok!\n");
} else {
    printf ("Error: %s\n", $mysqli->error);
}

/* close connection */
$mysqli->close();
?>

Příklad 1349. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* check if server is alive */
if (mysqli_ping($link)) {
    printf ("Our connection is ok!\n");
} else {
    printf ("Error: %s\n", mysqli_error($link));
}

/* close connection */
mysqli_close($link);
?>

Výše uvedený příklad vypíše:

Our connection is ok!

Předcházející | Nahoru | Další
mysqli_param_count | Domů | mysqli_prepare


mysqli_prepare

Předcházející C. MySQL Improved Extension Další

mysqli_prepare,

(PHP 5)

mysqli_prepare, mysqli->prepare() — Prepare a SQL statement for execution

Popis

Procedure style:

mysqli_stmt mysqli_prepare ( mysqli $link, string $query )

Object oriented style (method)

class mysqli {
mysqli_stmt prepare ( string $query )
}

Prepares the SQL query pointed to by the null-terminated string query, and returns a statement handle to be used for further operations on the statement. The query must consist of a single SQL statement.

The parameter markers must be bound to application variables using mysqli_stmt_bind_param() and/or mysqli_stmt_bind_result() before executing the statement or fetching rows.

Seznam parametrů

link

Procedural style only: A link identifier returned by mysqli_connect() or mysqli_init()

query

The query, as a string.

Poznámka: You should not add a terminating semicolon or \g to the statement.

This parameter can include one or more parameter markers in the SQL statement by embedding question mark (?) characters at the appropriate positions.

Poznámka: The markers are legal only in certain places in SQL statements. For example, they are allowed in the VALUES() list of an INSERT statement (to specify column values for a row), or in a comparison with a column in a WHERE clause to specify a comparison value.

However, they are not allowed for identifiers (such as table or column names), in the select list that names the columns to be returned by a SELECT statement, or to specify both operands of a binary operator such as the = equal sign. The latter restriction is necessary because it would be impossible to determine the parameter type. It's not allowed to compare marker with NULL by ? IS NULL too. In general, parameters are legal only in Data Manipulation Languange (DML) statements, and not in Data Defination Language (DDL) statements.

Návratové hodnoty

mysqli_prepare() returns a statement object or FALSE if an error occured.

Příklady

Příklad 1350. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$city = "Amersfoort";

/* create a prepared statement */
if ($stmt = $mysqli->prepare("SELECT District FROM City WHERE Name=?")) {

    /* bind parameters for markers */
    $stmt->bind_param("s", $city);

    /* execute query */
    $stmt->execute();

    /* bind result variables */
    $stmt->bind_result($district);

    /* fetch value */
    $stmt->fetch();

    printf("%s is in district %s\n", $city, $district);

    /* close statement */
    $stmt->close();
}

/* close connection */
$mysqli->close();
?>

Příklad 1351. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$city = "Amersfoort";

/* create a prepared statement */
if ($stmt = mysqli_prepare($link, "SELECT District FROM City WHERE Name=?")) {

    /* bind parameters for markers */
    mysqli_stmt_bind_param($stmt, "s", $city);

    /* execute query */
    mysqli_stmt_execute($stmt);

    /* bind result variables */
    mysqli_stmt_bind_result($stmt, $district);

    /* fetch value */
    mysqli_stmt_fetch($stmt);

    printf("%s is in district %s\n", $city, $district);

    /* close statement */
    mysqli_stmt_close($stmt);
}

/* close connection */
mysqli_close($link);
?>

Výše uvedený příklad vypíše:

Amersfoort is in district Utrecht

Viz také

mysqli_stmt_execute()
mysqli_stmt_fetch()
mysqli_stmt_bind_param()
mysqli_stmt_bind_result()
mysqli_stmt_close()

Předcházející | Nahoru | Další
mysqli_ping | Domů | mysqli_query


mysqli_query

Předcházející C. MySQL Improved Extension Další

mysqli_query,

(PHP 5)

mysqli_query, mysqli->query() — Performs a query on the database

Popis

Procedural style:

mixed mysqli_query ( mysqli $link, string $query [, int $resultmode] )

Object oriented style (method):

class mysqli {
mixed query ( string $query [, int $resultmode] )
}

Performs a query against the database.

Functionally, using this function is identical to calling
mysqli_real_query() followed either by
mysqli_use_result() or
mysqli_store_result().

Seznam parametrů

link

Procedural style only: A link identifier returned by mysqli_connect() or mysqli_init()

query

The query string.

resultmode

Either the constant MYSQLI_USE_RESULT or MYSQLI_STORE_RESULT depending on the desired behavior. By default, MYSQLI_STORE_RESULT is used.

If you use MYSQLI_USE_RESULT all subsequent calls will return error Commands out of sync unless you call mysqli_free_result()

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání. For SELECT, SHOW, DESCRIBE or EXPLAIN mysqli_query() will return a result object.

Příklady

Příklad 1352. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* Create table doesn't return a resultset */
if ($mysqli->query("CREATE TEMPORARY TABLE myCity LIKE City") === TRUE) {
    printf("Table myCity successfully created.\n");
}

/* Select queries return a resultset */
if ($result = $mysqli->query("SELECT Name FROM City LIMIT 10")) {
    printf("Select returned %d rows.\n", $result->num_rows);

    /* free result set */
    $result->close();
}

/* If we have to retrieve large amount of data we use MYSQLI_USE_RESULT */
if ($result = $mysqli->query("SELECT * FROM City", MYSQLI_USE_RESULT)) {

    /* Note, that we can't execute any functions which interact with the
       server until result set was closed. All calls will return an
       'out of sync' error */
    if (!$mysqli->query("SET @a:='this will not work'")) {
        printf("Error: %s\n", $mysqli->error);
    }
    $result->close();
}

$mysqli->close();
?>

Příklad 1353. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* Create table doesn't return a resultset */
if (mysqli_query($link, "CREATE TEMPORARY TABLE myCity LIKE City") === TRUE) {
    printf("Table myCity successfully created.\n");
}

/* Select queries return a resultset */
if ($result = mysqli_query($link, "SELECT Name FROM City LIMIT 10")) {
    printf("Select returned %d rows.\n", mysqli_num_rows($result));

    /* free result set */
    mysqli_free_result($result);
}

/* If we have to retrieve large amount of data we use MYSQLI_USE_RESULT */
if ($result = mysqli_query($link, "SELECT * FROM City", MYSQLI_USE_RESULT)) {

    /* Note, that we can't execute any functions which interact with the
       server until result set was closed. All calls will return an
       'out of sync' error */
    if (!mysqli_query($link, "SET @a:='this will not work'")) {
        printf("Error: %s\n", mysqli_error($link));
    }
    mysqli_free_result($result);
}

mysqli_close($link);
?>

Výše uvedený příklad vypíše:

Table myCity successfully created.
Select returned 10 rows.
Error: Commands out of sync;  You can't run this command now

Viz také

mysqli_real_query()
mysqli_multi_query()
mysqli_free_result()

Předcházející | Nahoru | Další
mysqli_prepare | Domů | mysqli_real_connect


mysqli_real_connect

Předcházející C. MySQL Improved Extension Další

mysqli_real_connect,

(PHP 5)

mysqli_real_connect, mysqli->real_connect() — Opens a connection to a mysql server

Popis

Procedural style

bool mysqli_real_connect ( mysqli $link [, string $host [, string $username [, string $passwd [, string $dbname [, int $port [, string $socket [, int $flags]]]]]]] )

Object oriented style (method)

class mysqli {
bool real_connect ( [string $host [, string $username [, string $passwd [, string $dbname [, int $port [, string $socket [, int $flags]]]]]]] )
}

Establish a connection to a MySQL database engine.

This function differs from mysqli_connect():

  • mysqli_real_connect() needs a valid object which has to be created by function mysqli_init().

  • With function mysqli_options() you can set various options for connection.

  • There is a flags parameter.

Seznam parametrů

link

Procedural style only: A link identifier returned by mysqli_connect() or mysqli_init()

host

Can be either a host name or an IP address. Passing the NULL value or the string "localhost" to this parameter, the local host is assumed. When possible, pipes will be used instead of the TCP/IP protocol.

username

The MySQL user name.

passwd

If provided or NULL, the MySQL server will attempt to authenticate the user against those user records which have no password only. This allows one username to be used with different permissions (depending on if a password as provided or not).

dbname

If provided will specify the default database to be used when performing queries.

port

Specifies the port number to attempt to connect to the MySQL server.

socket

Specifies the socket or named pipe that should be used.

Poznámka: Specifying the socket parameter will not explicitly determine the type of connection to be used when connecting to the MySQL server. How the connection is made to the MySQL database is determined by the host parameter.

flags

With the parameter flags you can set different connection options:

Tabulka 181. Supported flags

Name | Description
MYSQLI_CLIENT_COMPRESS | Use compression protocol
MYSQLI_CLIENT_FOUND_ROWS | return number of matched rows, not the number of affected rows
MYSQLI_CLIENT_IGNORE_SPACE | Allow spaces after function names. Makes all function names reserved words.
MYSQLI_CLIENT_INTERACTIVE | Allow interactive_timeout seconds (instead of wait_timeout seconds) of inactivity before closing the connection
MYSQLI_CLIENT_SSL | Use SSL (encryption)

Poznámka: For security reasons the MULTI_STATEMENT flag is not supported in PHP. If you want to execute multiple queries use the mysqli_multi_query() function.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1354. Object oriented style

<?php

/* create a connection object which is not connected */
$mysqli = mysqli_init();

/* set connection options */
$mysqli->options(MYSQLI_INIT_COMMAND, "SET AUTOCOMMIT=0");
$mysqli->options(MYSQLI_OPT_CONNECT_TIMEOUT, 5);

/* connect to server */
$mysqli->real_connect('localhost', 'my_user', 'my_password', 'world');

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

printf ("Connection: %s\n.", $mysqli->host_info);

$mysqli->close();
?>

Příklad 1355. Procedural style

<?php

/* create a connection object which is not connected */
$link = mysqli_init();

/* set connection options */
mysqli_options($link, MYSQLI_INIT_COMMAND, "SET AUTOCOMMIT=0");
mysqli_options($link, MYSQLI_OPT_CONNECT_TIMEOUT, 5);

/* connect to server */
mysqli_real_connect($link, 'localhost', 'my_user', 'my_password', 'world');

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

printf ("Connection: %s\n.", mysqli_get_host_info($link));

mysqli_close($link);
?>

Výše uvedený příklad vypíše:

Connection: Localhost via UNIX socket

Viz také

mysqli_connect()
mysqli_init()
mysqli_options()
mysqli_ssl_set()
mysqli_close()

Předcházející | Nahoru | Další
mysqli_query | Domů | mysqli_real_escape_string


mysqli_real_escape_string

Předcházející C. MySQL Improved Extension Další

mysqli_real_escape_string,

(PHP 5)

mysqli_real_escape_string, mysqli->real_escape_string() — Escapes special characters in a string for use in a SQL statement, taking into account the current charset of the connection

Popis

Procedural style:

string mysqli_real_escape_string ( mysqli $link, string $escapestr )

Object oriented style (both methods are equivalent):

class mysqli {
string escape_string ( string $escapestr )
string real_escape_string ( string $escapestr )
}

This function is used to create a legal SQL string that you can use in an SQL statement. The given string is encoded to an escaped SQL string, taking into account the current character set of the connection.

Seznam parametrů

link

Procedural style only: A link identifier returned by mysqli_connect() or mysqli_init()

escapestr

The string to be escaped.

Characters encoded are NUL (ASCII 0), \n, \r, \, ', ", and Control-Z.

Návratové hodnoty

Returns an escaped string.

Příklady

Příklad 1356. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$mysqli->query("CREATE TEMPORARY TABLE myCity LIKE City");

$city = "'s Hertogenbosch";

/* this query will fail, cause we didn't escape $city */
if (!$mysqli->query("INSERT into myCity (Name) VALUES ('$city')")) {
    printf("Error: %s\n", $mysqli->sqlstate);
}

$city = $mysqli->real_escape_string($city);

/* this query with escaped $city will work */
if ($mysqli->query("INSERT into myCity (Name) VALUES ('$city')")) {
    printf("%d Row inserted.\n", $mysqli->affected_rows);
}

$mysqli->close();
?>

Příklad 1357. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

mysqli_query($link, "CREATE TEMPORARY TABLE myCity LIKE City");

$city = "'s Hertogenbosch";

/* this query will fail, cause we didn't escape $city */
if (!mysqli_query($link, "INSERT into myCity (Name) VALUES ('$city')")) {
    printf("Error: %s\n", mysqli_sqlstate($link));
}

$city = mysqli_real_escape_string($link, $city);

/* this query with escaped $city will work */
if (mysqli_query($link, "INSERT into myCity (Name) VALUES ('$city')")) {
    printf("%d Row inserted.\n", mysqli_affected_rows($link));
}

mysqli_close($link);
?>

Výše uvedený příklad vypíše:

Error: 42000
1 Row inserted.

Viz také

mysqli_character_set_name()

Předcházející | Nahoru | Další
mysqli_real_connect | Domů | mysqli_real_query


mysqli_real_query

Předcházející C. MySQL Improved Extension Další

mysqli_real_query,

(PHP 5)

mysqli_real_query, mysqli->real_query() — Execute an SQL query

Popis

Procedural style

bool mysqli_real_query ( mysqli $link, string $query )

Object oriented style (method):

class mysqli {
bool real_query ( string $query )
}

Executes a single query against the database whose result can then be retrieved or stored using the mysqli_store_result() or mysqli_use_result() functions.

In order to determine if a given query should return a result set or not, see mysqli_field_count().

Seznam parametrů

link

Procedural style only: A link identifier returned by mysqli_connect() or mysqli_init()

query

The query, as a string.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

mysqli_query()
mysqli_store_result()
mysqli_use_result()

Předcházející | Nahoru | Další
mysqli_real_escape_string | Domů | mysqli_report


mysqli_report

(PHP 5)

mysqli_report — Enables or disables internal report functions

Popis

bool mysqli_report ( int $flags )

mysqli_report() is a powerful function to improve your queries and code during development and testing phase. Depending on the flags it reports errors from mysqli function calls or queries which don't use an index (or use a bad index).

Seznam parametrů

flags

Tabulka 182. Supported flags

Name | Description
MYSQLI_REPORT_OFF | Turns reporting off
MYSQLI_REPORT_ERROR | Report errors from mysqli function calls
MYSQLI_REPORT_STRICT | Report warnings from mysqli function calls
MYSQLI_REPORT_INDEX | Report if no index or bad index was used in a query
MYSQLI_REPORT_ALL | Set all options (report all)

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1358. Object oriented style

<?php
/* activate reporting */
mysqli_report(MYSQLI_REPORT_ALL);

$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* this query should report an error */
$result = $mysqli->query("SELECT Name FROM Nonexistingtable WHERE population > 50000");

/* this query should report a warning */
$result = $mysqli->query("SELECT Name FROM City WHERE population > 50000");
$result->close();

$mysqli->close();
?>

Viz také

mysqli_debug()
mysqli_dump_debug_info()

Předcházející | Nahoru | Další
mysqli_real_query | Domů | mysqli_rollback


mysqli_rollback

Předcházející C. MySQL Improved Extension Další

mysqli_rollback,

(PHP 5)

mysqli_rollback, mysqli->rollback() — Rolls back current transaction

Popis

bool mysqli_rollback ( mysqli $link )
class mysqli {
bool rollback ( void )
}

Rollbacks the current transaction for the database.

Seznam parametrů

link

Procedural style only: A link identifier returned by mysqli_connect() or mysqli_init()

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1359. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* disable autocommit */
$mysqli->autocommit(FALSE);

$mysqli->query("CREATE TABLE myCity LIKE City");
$mysqli->query("ALTER TABLE myCity Type=InnoDB");
$mysqli->query("INSERT INTO myCity SELECT * FROM City LIMIT 50");

/* commit insert */
$mysqli->commit();

/* delete all rows */
$mysqli->query("DELETE FROM myCity");

if ($result = $mysqli->query("SELECT COUNT(*) FROM myCity")) {
    $row = $result->fetch_row();
    printf("%d rows in table myCity.\n", $row[0]);
    /* Free result */
    $result->close();
}

/* Rollback */
$mysqli->rollback();

if ($result = $mysqli->query("SELECT COUNT(*) FROM myCity")) {
    $row = $result->fetch_row();
    printf("%d rows in table myCity (after rollback).\n", $row[0]);
    /* Free result */
    $result->close();
}

/* Drop table myCity */
$mysqli->query("DROP TABLE myCity");

$mysqli->close();
?>

Příklad 1360. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* disable autocommit */
mysqli_autocommit($link, FALSE);

mysqli_query($link, "CREATE TABLE myCity LIKE City");
mysqli_query($link, "ALTER TABLE myCity Type=InnoDB");
mysqli_query($link, "INSERT INTO myCity SELECT * FROM City LIMIT 50");

/* commit insert */
mysqli_commit($link);

/* delete all rows */
mysqli_query($link, "DELETE FROM myCity");

if ($result = mysqli_query($link, "SELECT COUNT(*) FROM myCity")) {
    $row = mysqli_fetch_row($result);
    printf("%d rows in table myCity.\n", $row[0]);
    /* Free result */
    mysqli_free_result($result);
}

/* Rollback */
mysqli_rollback($link);

if ($result = mysqli_query($link, "SELECT COUNT(*) FROM myCity")) {
    $row = mysqli_fetch_row($result);
    printf("%d rows in table myCity (after rollback).\n", $row[0]);
    /* Free result */
    mysqli_free_result($result);
}

/* Drop table myCity */
mysqli_query($link, "DROP TABLE myCity");

mysqli_close($link);
?>

Výše uvedený příklad vypíše:

0 rows in table myCity.
50 rows in table myCity (after rollback).

Viz také

mysqli_commit()
mysqli_autocommit()

Předcházející | Nahoru | Další
mysqli_report | Domů | mysqli_rpl_parse_enabled


mysqli_rpl_parse_enabled

(PHP 5)

mysqli_rpl_parse_enabled — Check if RPL parse is enabled

Popis

int mysqli_rpl_parse_enabled ( mysqli $link )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
mysqli_rollback | Domů | mysqli_rpl_probe


mysqli_rpl_probe

(PHP 5)

mysqli_rpl_probe — RPL probe

Popis

bool mysqli_rpl_probe ( mysqli $link )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
mysqli_rpl_parse_enabled | Domů | mysqli_rpl_query_type


mysqli_rpl_query_type

Předcházející C. MySQL Improved Extension Další

mysqli_rpl_query_type,

(PHP 5)

mysqli_rpl_query_type, mysqli->rpl_query_type() — Returns RPL query type

Popis

Procedural style:

int mysqli_rpl_query_type ( mysqli $link, string $query )

Object oriented style (method)

class mysqli {
int rpl_query_type ( string $query )
}

Returns MYSQLI_RPL_MASTER, MYSQLI_RPL_SLAVE or MYSQLI_RPL_ADMIN depending on a query type. INSERT, UPDATE and similar are master queries, SELECT is slave, and FLUSH, REPAIR and similar are admin.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
mysqli_rpl_probe | Domů | mysqli_select_db


mysqli_select_db

Předcházející C. MySQL Improved Extension Další

mysqli_select_db,

(PHP 5)

mysqli_select_db, mysqli->select_db() — Selects the default database for database queries

Popis

Procedural style:

bool mysqli_select_db ( mysqli $link, string $dbname )

Object oriented style (method):

class mysqli {
bool select_db ( string $dbname )
}

Selects the default database to be used when performing queries against the database connection.

Poznámka: This function should only be used to change the default database for the connection. You can select the default database with 4th parameter in mysqli_connect().

Seznam parametrů

link

Procedural style only: A link identifier returned by mysqli_connect() or mysqli_init()

dbname

The database name.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1361. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "test");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* return name of current default database */
if ($result = $mysqli->query("SELECT DATABASE()")) {
    $row = $result->fetch_row();
    printf("Default database is %s.\n", $row[0]);
    $result->close();
}

/* change db to world db */
$mysqli->select_db("world");

/* return name of current default database */
if ($result = $mysqli->query("SELECT DATABASE()")) {
    $row = $result->fetch_row();
    printf("Default database is %s.\n", $row[0]);
    $result->close();
}

$mysqli->close();
?>

Příklad 1362. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "test");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* return name of current default database */
if ($result = mysqli_query($link, "SELECT DATABASE()")) {
    $row = mysqli_fetch_row($result);
    printf("Default database is %s.\n", $row[0]);
    mysqli_free_result($result);
}

/* change db to world db */
mysqli_select_db($link, "world");

/* return name of current default database */
if ($result = mysqli_query($link, "SELECT DATABASE()")) {
    $row = mysqli_fetch_row($result);
    printf("Default database is %s.\n", $row[0]);
    mysqli_free_result($result);
}

mysqli_close($link);
?>

Výše uvedený příklad vypíše:

Default database is test.
Default database is world.

Viz také

mysqli_connect()
mysqli_real_connect()

Předcházející | Nahoru | Další
mysqli_rpl_query_type | Domů | mysqli_send_long_data


mysqli_send_long_data

(PHP 5)

mysqli_send_long_data — Alias for mysqli_stmt_send_long_data()

Popis

This function is an alias of mysqli_stmt_send_long_data().

Poznámky

Poznámka: mysqli_send_long_data() is deprecated and will be removed.

Viz také

mysqli_stmt_send_long_data()

Předcházející | Nahoru | Další
mysqli_select_db | Domů | mysqli_send_query


mysqli_send_query

Předcházející C. MySQL Improved Extension Další

mysqli_send_query,

(PHP 5)

mysqli_send_query, mysqli->send_query() — Send the query and return

Popis

Procedural style:

bool mysqli_send_query ( mysqli $link, string $query )

Object oriented style (method)

class mysqli {
bool send_query ( string $query )
}
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
mysqli_send_long_data | Domů | mysqli_server_end


mysqli_server_end

(PHP 5 <= 5.0.5)

mysqli_server_end — Shut down the embedded server

Popis

void mysqli_server_end ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
mysqli_send_query | Domů | mysqli_server_init


mysqli_server_init

(PHP 5 <= 5.0.5)

mysqli_server_init — Initialize embedded server

Popis

bool mysqli_server_init ( [array $server [, array $groups]] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
mysqli_server_end | Domů | mysqli_set_charset


mysqli_set_opt

(PHP 5)

mysqli_set_opt — Alias of mysqli_options()

Popis

This function is an alias of mysqli_options().

Předcházející | Nahoru | Další
mysqli_set_local_infile_handler | Domů | mysqli_slave_query


mysqli_sqlstate

Předcházející C. MySQL Improved Extension Další

mysqli_sqlstate,

(PHP 5)

mysqli_sqlstate, mysqli->sqlstate — Returns the SQLSTATE error from previous MySQL operation

Popis

Procedural style:

string mysqli_sqlstate ( mysqli $link )

Object oriented style (property):

class mysqli {
string sqlstate
}

Returns a string containing the SQLSTATE error code for the last error. The error code consists of five characters. '00000' means no error. The values are specified by ANSI SQL and ODBC. For a list of possible values, see » http://dev.mysql.com/doc/mysql/en/error-handling.html.

Poznámka: Note that not all MySQL errors are yet mapped to SQLSTATE's. The value HY000 (general error) is used for unmapped errors.

Seznam parametrů

link

Procedural style only: A link identifier returned by mysqli_connect() or mysqli_init()

Návratové hodnoty

Returns a string containing the SQLSTATE error code for the last error. The error code consists of five characters. '00000' means no error.

Příklady

Příklad 1365. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* Table City already exists, so we should get an error */
if (!$mysqli->query("CREATE TABLE City (ID INT, Name VARCHAR(30))")) {
    printf("Error - SQLSTATE %s.\n", $mysqli->sqlstate);
}

$mysqli->close();
?>

Příklad 1366. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* Table City already exists, so we should get an error */
if (!mysqli_query($link, "CREATE TABLE City (ID INT, Name VARCHAR(30))")) {
    printf("Error - SQLSTATE %s.\n", mysqli_sqlstate($link));
}

mysqli_close($link);
?>

Výše uvedený příklad vypíše:

Error - SQLSTATE 42S01.

Viz také

mysqli_errno()
mysqli_error()

Předcházející | Nahoru | Další
mysqli_slave_query | Domů | mysqli_ssl_set


mysqli_ssl_set

Předcházející C. MySQL Improved Extension Další

mysqli_ssl_set,

(PHP 5)

mysqli_ssl_set, mysqli->ssl_set() — Used for establishing secure connections using SSL

Popis

Procedural style:

bool mysqli_ssl_set ( mysqli $link, string $key, string $cert, string $ca, string $capath, string $cipher )

Object oriented style (method):

class mysqli {
bool ssl_set ( string $key, string $cert, string $ca, string $capath, string $cipher )
}

Used for establishing secure connections using SSL. It must be called before mysqli_real_connect(). This function does nothing unless OpenSSL support is enabled.

Seznam parametrů

link

Procedural style only: A link identifier returned by mysqli_connect() or mysqli_init()

key

The path name to the key file.

cert

The path name to the certificate file.

ca

The path name to the certificate authority file.

capath

The pathname to a directory that contains trusted SSL CA certificates in PEM format.

cipher

A list of allowable ciphers to use for SSL encryption.

Any unused SSL parameters may be given as NULL

Návratové hodnoty

This function always returns TRUE value. If SSL setup is incorrect mysqli_real_connect() will return an error when you attempt to connect.

Viz také

mysqli_options()
mysqli_real_connect()

Předcházející | Nahoru | Další
mysqli_sqlstate | Domů | mysqli_stat


mysqli_stat

Předcházející C. MySQL Improved Extension Další

mysqli_stat,

(PHP 5)

mysqli_stat, mysqli->stat() — Gets the current system status

Popis

Procedural style:

string mysqli_stat ( mysqli $link )

Object oriented style (method):

class mysqli {
string stat ( void )
}

mysqli_stat() returns a string containing information similar to that provided by the 'mysqladmin status' command. This includes uptime in seconds and the number of running threads, questions, reloads, and open tables.

Seznam parametrů

link

Procedural style only: A link identifier returned by mysqli_connect() or mysqli_init()

Návratové hodnoty

A string describing the server status. FALSE if an error occurred.

Příklady

Příklad 1367. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

printf ("System status: %s\n", $mysqli->stat());

$mysqli->close();
?>

Příklad 1368. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

printf("System status: %s\n", mysqli_stat($link));

mysqli_close($link);
?>

Výše uvedený příklad vypíše:

System status: Uptime: 272  Threads: 1  Questions: 5340  Slow queries: 0
Opens: 13  Flush tables: 1  Open tables: 0  Queries per second avg: 19.632
Memory in use: 8496K  Max memory used: 8560K

Viz také

mysqli_get_server_info()

Předcházející | Nahoru | Další
mysqli_ssl_set | Domů | mysqli_stmt_affected_rows


mysqli_stmt_affected_rows

Předcházející C. MySQL Improved Extension Další

mysqli_stmt_affected_rows,

(PHP 5)

mysqli_stmt_affected_rows, mysqli_stmt->affected_rows — Returns the total number of rows changed, deleted, or inserted by the last executed statement

Popis

Procedural style :

int mysqli_stmt_affected_rows ( mysqli_stmt $stmt )

Object oriented style (property):

class mysqli_stmt {
int affected_rows
}

Returns the number of rows affected by INSERT, UPDATE, or DELETE query.

This function only works with queries which update a table. In order to get the number of rows from a SELECT query, use mysqli_stmt_num_rows() instead.

Seznam parametrů

stmt

Procedural style only: A statement identifier returned by mysqli_stmt_init().

Návratové hodnoty

An integer greater than zero indicates the number of rows affected or retrieved. Zero indicates that no records where updated for an UPDATE/DELETE statement, no rows matched the WHERE clause in the query or that no query has yet been executed. -1 indicates that the query has returned an error.

Poznámka: If the number of affected rows is greater than maximal PHP int value, the number of affected rows will be returned as a string value.

Příklady

Příklad 1369. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* create temp table */
$mysqli->query("CREATE TEMPORARY TABLE myCountry LIKE Country");

$query = "INSERT INTO myCountry SELECT * FROM Country WHERE Code LIKE ?";

/* prepare statement */
if ($stmt = $mysqli->prepare($query)) {

    /* Bind variable for placeholder */
    $code = 'A%';
    $stmt->bind_param("s", $code);

    /* execute statement */
    $stmt->execute();

    printf("rows inserted: %d\n", $stmt->affected_rows);

    /* close statement */
    $stmt->close();
}

/* close connection */
$mysqli->close();
?>

Příklad 1370. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* create temp table */
mysqli_query($link, "CREATE TEMPORARY TABLE myCountry LIKE Country");

$query = "INSERT INTO myCountry SELECT * FROM Country WHERE Code LIKE ?";

/* prepare statement */
if ($stmt = mysqli_prepare($link, $query)) {

    /* Bind variable for placeholder */
    $code = 'A%';
    mysqli_stmt_bind_param($stmt, "s", $code);

    /* execute statement */
    mysqli_stmt_execute($stmt);

    printf("rows inserted: %d\n", mysqli_stmt_affected_rows($stmt));

    /* close statement */
    mysqli_stmt_close($stmt);
}

/* close connection */
mysqli_close($link);
?>

Výše uvedený příklad vypíše:

rows inserted: 17

Viz také

mysqli_stmt_num_rows()
mysqli_prepare()

Předcházející | Nahoru | Další
mysqli_stat | Domů | mysqli_stmt_attr_get


mysqli_stmt_bind_param

Předcházející C. MySQL Improved Extension Další

mysqli_stmt_bind_param,

(PHP 5)

mysqli_stmt_bind_param, stmt->bind_param() — Binds variables to a prepared statement as parameters

Popis

Procedural style:

bool mysqli_stmt_bind_param ( mysqli_stmt $stmt, string $types, mixed &$var1 [, mixed &$...] )

Object oriented style (method):

class mysqli_stmt {
bool bind_param ( string $types, mixed &$var1 [, mixed &$...] )
}

Bind variables for the parameter markers in the SQL statement that was passed to mysqli_prepare().

Poznámka: If data size of a variable exceeds max. allowed packet size (max_allowed_packet), you have to specify b in types and use mysqli_stmt_send_long_data() to send the data in packets.

Seznam parametrů

stmt

Procedural style only: A statement identifier returned by mysqli_stmt_init().

types

A string that contains one or more characters which specify the types for the corresponding bind variables:

Tabulka 183. Type specification chars

Character | Description
i | corresponding variable has type integer
d | corresponding variable has type double
s | corresponding variable has type string
b | corresponding variable is a blob and will be sent in packets

var1

The number of variables and length of string types must match the parameters in the statement.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1371. Object oriented style

<?php
$mysqli = new mysqli('localhost', 'my_user', 'my_password', 'world');

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$stmt = $mysqli->prepare("INSERT INTO CountryLanguage VALUES (?, ?, ?, ?)");
$stmt->bind_param('sssd', $code, $language, $official, $percent);

$code = 'DEU';
$language = 'Bavarian';
$official = "F";
$percent = 11.2;

/* execute prepared statement */
$stmt->execute();

printf("%d Row inserted.\n", $stmt->affected_rows);

/* close statement and connection */
$stmt->close();

/* Clean up table CountryLanguage */
$mysqli->query("DELETE FROM CountryLanguage WHERE Language='Bavarian'");
printf("%d Row deleted.\n", $mysqli->affected_rows);

/* close connection */
$mysqli->close();
?>

Příklad 1372. Procedural style

<?php
$link = mysqli_connect('localhost', 'my_user', 'my_password', 'world');

/* check connection */
if (!$link) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$stmt = mysqli_prepare($link, "INSERT INTO CountryLanguage VALUES (?, ?, ?, ?)");
mysqli_stmt_bind_param($stmt, 'sssd', $code, $language, $official, $percent);

$code = 'DEU';
$language = 'Bavarian';
$official = "F";
$percent = 11.2;

/* execute prepared statement */
mysqli_stmt_execute($stmt);

printf("%d Row inserted.\n", mysqli_stmt_affected_rows($stmt));

/* close statement and connection */
mysqli_stmt_close($stmt);

/* Clean up table CountryLanguage */
mysqli_query($link, "DELETE FROM CountryLanguage WHERE Language='Bavarian'");
printf("%d Row deleted.\n", mysqli_affected_rows($link));

/* close connection */
mysqli_close($link);
?>

Výše uvedený příklad vypíše:

1 Row inserted.
1 Row deleted.

Viz také

mysqli_stmt_bind_result()
mysqli_stmt_execute()
mysqli_stmt_fetch()
mysqli_prepare()
mysqli_stmt_send_long_data()
mysqli_stmt_errno()
mysqli_stmt_error()

Předcházející | Nahoru | Další
mysqli_stmt_attr_set | Domů | mysqli_stmt_bind_result


mysqli_stmt_bind_result

Předcházející C. MySQL Improved Extension Další

mysqli_stmt_bind_result,

(PHP 5)

mysqli_stmt_bind_result, stmt->bind_result() — Binds variables to a prepared statement for result storage

Popis

Procedural style:

bool mysqli_stmt_bind_result ( mysqli_stmt $stmt, mixed &$var1 [, mixed &$...] )

Object oriented style (method):

class mysqli_stmt {
bool bind_result ( mixed &$var1 [, mixed &$...] )
}

Binds columns in the result set to variables.

When mysqli_stmt_fetch() is called to fetch data, the MySQL client/server protocol places the data for the bound columns into the specified variables var1, ....

Poznámka: Note that all columns must be bound after mysqli_stmt_execute() and prior to calling mysqli_stmt_fetch(). Depending on column types bound variables can silently change to the corresponding PHP type.

A column can be bound or rebound at any time, even after a result set has been partially retrieved. The new binding takes effect the next time mysqli_stmt_fetch() is called.

Seznam parametrů

stmt

Procedural style only: A statement identifier returned by mysqli_stmt_init().

var1

The variable to be bound.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1373. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* prepare statement */
if ($stmt = $mysqli->prepare("SELECT Code, Name FROM Country ORDER BY Name LIMIT 5")) {
    $stmt->execute();

    /* bind variables to prepared statement */
    $stmt->bind_result($col1, $col2);

    /* fetch values */
    while ($stmt->fetch()) {
        printf("%s %s\n", $col1, $col2);
    }

    /* close statement */
    $stmt->close();
}
/* close connection */
$mysqli->close();

?>

Příklad 1374. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (!$link) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* prepare statement */
if ($stmt = mysqli_prepare($link, "SELECT Code, Name FROM Country ORDER BY Name LIMIT 5")) {
    mysqli_stmt_execute($stmt);

    /* bind variables to prepared statement */
    mysqli_stmt_bind_result($stmt, $col1, $col2);

    /* fetch values */
    while (mysqli_stmt_fetch($stmt)) {
        printf("%s %s\n", $col1, $col2);
    }

    /* close statement */
    mysqli_stmt_close($stmt);
}

/* close connection */
mysqli_close($link);
?>

Výše uvedený příklad vypíše:

AFG Afghanistan
ALB Albania
DZA Algeria
ASM American Samoa
AND Andorra

Viz také

mysqli_stmt_bind_param()
mysqli_stmt_execute()
mysqli_stmt_fetch()
mysqli_prepare()
mysqli_stmt_prepare()
mysqli_stmt_init()
mysqli_stmt_errno()
mysqli_stmt_error()

Předcházející | Nahoru | Další
mysqli_stmt_bind_param | Domů | mysqli_stmt_close


mysqli_stmt_close

Předcházející C. MySQL Improved Extension Další

mysqli_stmt_close,

(PHP 5)

mysqli_stmt_close, mysqli_stmt->close() — Closes a prepared statement

Popis

Procedural style:

bool mysqli_stmt_close ( mysqli_stmt $stmt )

Object oriented style (method):

class mysqli_stmt {
bool close ( void )
}

Closes a prepared statement. mysqli_stmt_close() also deallocates the statement handle. If the current statement has pending or unread results, this function cancels them so that the next query can be executed.

Seznam parametrů

stmt

Procedural style only: A statement identifier returned by mysqli_stmt_init().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

mysqli_prepare()

Předcházející | Nahoru | Další
mysqli_stmt_bind_result | Domů | mysqli_stmt_data_seek


mysqli_stmt_data_seek

Předcházející C. MySQL Improved Extension Další

mysqli_stmt_data_seek,

(PHP 5)

mysqli_stmt_data_seek, stmt->data_seek() — Seeks to an arbitray row in statement result set

Popis

Procedural style:

void mysqli_stmt_data_seek ( mysqli_stmt $stmt, int $offset )

Object oriented style (method):

class mysqli_stmt {
void data_seek ( int $offset )
}

Seeks to an arbitrary result pointer in the statement result set.

Seznam parametrů

stmt

Procedural style only: A statement identifier returned by mysqli_stmt_init().

offset

Must be between zero and the total number of rows minus one (0.. mysqli_stmt_num_rows() - 1).

Návratové hodnoty

Nevrací se žádná hodnota.

Příklady

Příklad 1375. Object oriented style

<?php
/* Open a connection */
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER BY Name";
if ($stmt = $mysqli->prepare($query)) {

    /* execute query */
    $stmt->execute();

    /* bind result variables */
    $stmt->bind_result($name, $code);

    /* store result */
    $stmt->store_result();

    /* seek to row no. 400 */
    $stmt->data_seek(399);

    /* fetch values */
    $stmt->fetch();

    printf ("City: %s  Countrycode: %s\n", $name, $code);

    /* close statement */
    $stmt->close();
}

/* close connection */
$mysqli->close();
?>

Příklad 1376. Procedural style

<?php
/* Open a connection */
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER BY Name";
if ($stmt = mysqli_prepare($link, $query)) {

    /* execute query */
    mysqli_stmt_execute($stmt);

    /* bind result variables */
    mysqli_stmt_bind_result($stmt, $name, $code);

    /* store result */
    mysqli_stmt_store_result($stmt);

    /* seek to row no. 400 */
    mysqli_stmt_data_seek($stmt, 399);

    /* fetch values */
    mysqli_stmt_fetch($stmt);

    printf ("City: %s  Countrycode: %s\n", $name, $code);

    /* close statement */
    mysqli_stmt_close($stmt);
}

/* close connection */
mysqli_close($link);
?>

Výše uvedený příklad vypíše:

City: Benin City  Countrycode: NGA

Viz také

mysqli_prepare()

Předcházející | Nahoru | Další
mysqli_stmt_close | Domů | mysqli_stmt_errno


mysqli_stmt_errno

Předcházející C. MySQL Improved Extension Další

mysqli_stmt_errno,

(PHP 5)

mysqli_stmt_errno, mysqli_stmt->errno — Returns the error code for the most recent statement call

Popis

Procedural style :

int mysqli_stmt_errno ( mysqli_stmt $stmt )

Object oriented style (property):

class mysqli_stmt {
int errno
}

Returns the error code for the most recently invoked statement function that can succeed or fail.

Client error message numbers are listed in the MySQL errmsg.h header file, server error message numbers are listed in mysqld_error.h. In the MySQL source distribution you can find a complete list of error messages and error numbers in the file Docs/mysqld_error.txt.

Seznam parametrů

stmt

Procedural style only: A statement identifier returned by mysqli_stmt_init().

Návratové hodnoty

An error code value. Zero means no error occurred.

Příklady

Příklad 1377. Object oriented style

<?php
/* Open a connection */
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$mysqli->query("CREATE TABLE myCountry LIKE Country");
$mysqli->query("INSERT INTO myCountry SELECT * FROM Country");

$query = "SELECT Name, Code FROM myCountry ORDER BY Name";
if ($stmt = $mysqli->prepare($query)) {

    /* drop table */
    $mysqli->query("DROP TABLE myCountry");

    /* execute query */
    $stmt->execute();

    printf("Error: %d.\n", $stmt->errno);

    /* close statement */
    $stmt->close();
}

/* close connection */
$mysqli->close();
?>

Příklad 1378. Procedural style

<?php
/* Open a connection */
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

mysqli_query($link, "CREATE TABLE myCountry LIKE Country");
mysqli_query($link, "INSERT INTO myCountry SELECT * FROM Country");

$query = "SELECT Name, Code FROM myCountry ORDER BY Name";
if ($stmt = mysqli_prepare($link, $query)) {

    /* drop table */
    mysqli_query($link, "DROP TABLE myCountry");

    /* execute query */
    mysqli_stmt_execute($stmt);

    printf("Error: %d.\n", mysqli_stmt_errno($stmt));

    /* close statement */
    mysqli_stmt_close($stmt);
}

/* close connection */
mysqli_close($link);
?>

Výše uvedený příklad vypíše:

Error: 1146.

Viz také

mysqli_stmt_error()
mysqli_stmt_sqlstate()

Předcházející | Nahoru | Další
mysqli_stmt_data_seek | Domů | mysqli_stmt_error


mysqli_stmt_error

Předcházející C. MySQL Improved Extension Další

mysqli_stmt_error,

(PHP 5)

mysqli_stmt_error, mysqli_stmt->error — Returns a string description for last statement error

Popis

Procedural style:

string mysqli_stmt_error ( mysqli_stmt $stmt )

Object oriented style (property):

class mysqli_stmt {
string error
}

Returns a containing the error message for the most recently invoked statement function that can succeed or fail.

Seznam parametrů

stmt

Procedural style only: A statement identifier returned by mysqli_stmt_init().

Návratové hodnoty

A string that describes the error. An empty string if no error occurred.

Příklady

Příklad 1379. Object oriented style

<?php
/* Open a connection */
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$mysqli->query("CREATE TABLE myCountry LIKE Country");
$mysqli->query("INSERT INTO myCountry SELECT * FROM Country");

$query = "SELECT Name, Code FROM myCountry ORDER BY Name";
if ($stmt = $mysqli->prepare($query)) {

    /* drop table */
    $mysqli->query("DROP TABLE myCountry");

    /* execute query */
    $stmt->execute();

    printf("Error: %s.\n", $stmt->error);

    /* close statement */
    $stmt->close();
}

/* close connection */
$mysqli->close();
?>

Příklad 1380. Procedural style

<?php
/* Open a connection */
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

mysqli_query($link, "CREATE TABLE myCountry LIKE Country");
mysqli_query($link, "INSERT INTO myCountry SELECT * FROM Country");

$query = "SELECT Name, Code FROM myCountry ORDER BY Name";
if ($stmt = mysqli_prepare($link, $query)) {

    /* drop table */
    mysqli_query($link, "DROP TABLE myCountry");

    /* execute query */
    mysqli_stmt_execute($stmt);

    printf("Error: %s.\n", mysqli_stmt_error($stmt));

    /* close statement */
    mysqli_stmt_close($stmt);
}

/* close connection */
mysqli_close($link);
?>

Výše uvedený příklad vypíše:

Error: Table 'world.myCountry' doesn't exist.

Viz také

mysqli_stmt_errno()
mysqli_stmt_sqlstate()

Předcházející | Nahoru | Další
mysqli_stmt_errno | Domů | mysqli_stmt_execute


mysqli_stmt_execute

Předcházející C. MySQL Improved Extension Další

mysqli_stmt_execute,

(PHP 5)

mysqli_stmt_execute, stmt->execute() — Executes a prepared Query

Popis

Procedural style:

bool mysqli_stmt_execute ( mysqli_stmt $stmt )

Object oriented style (method):

class mysqli_stmt {
bool execute ( void )
}

Executes a query that has been previously prepared using the mysqli_prepare() function. When executed any parameter markers which exist will automatically be replaced with the appropiate data.

If the statement is UPDATE, DELETE, or INSERT, the total number of affected rows can be determined by using the mysqli_stmt_affected_rows() function. Likewise, if the query yields a result set the mysqli_stmt_fetch() function is used.

Poznámka: When using mysqli_stmt_execute(), the mysqli_stmt_fetch() function must be used to fetch the data prior to performing any additional queries.

Seznam parametrů

stmt

Procedural style only: A statement identifier returned by mysqli_stmt_init().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1381. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$mysqli->query("CREATE TABLE myCity LIKE City");

/* Prepare an insert statement */
$query = "INSERT INTO myCity (Name, CountryCode, District) VALUES (?,?,?)";
$stmt = $mysqli->prepare($query);

$stmt->bind_param("sss", $val1, $val2, $val3);

$val1 = 'Stuttgart';
$val2 = 'DEU';
$val3 = 'Baden-Wuerttemberg';

/* Execute the statement */
$stmt->execute();

$val1 = 'Bordeaux';
$val2 = 'FRA';
$val3 = 'Aquitaine';

/* Execute the statement */
$stmt->execute();

/* close statement */
$stmt->close();

/* retrieve all rows from myCity */
$query = "SELECT Name, CountryCode, District FROM myCity";
if ($result = $mysqli->query($query)) {
    while ($row = $result->fetch_row()) {
        printf("%s (%s,%s)\n", $row[0], $row[1], $row[2]);
    }
    /* free result set */
    $result->close();
}

/* remove table */
$mysqli->query("DROP TABLE myCity");

/* close connection */
$mysqli->close();
?>

Příklad 1382. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

mysqli_query($link, "CREATE TABLE myCity LIKE City");

/* Prepare an insert statement */
$query = "INSERT INTO myCity (Name, CountryCode, District) VALUES (?,?,?)";
$stmt = mysqli_prepare($link, $query);

mysqli_stmt_bind_param($stmt, "sss", $val1, $val2, $val3);

$val1 = 'Stuttgart';
$val2 = 'DEU';
$val3 = 'Baden-Wuerttemberg';

/* Execute the statement */
mysqli_stmt_execute($stmt);

$val1 = 'Bordeaux';
$val2 = 'FRA';
$val3 = 'Aquitaine';

/* Execute the statement */
mysqli_stmt_execute($stmt);

/* close statement */
mysqli_stmt_close($stmt);

/* retrieve all rows from myCity */
$query = "SELECT Name, CountryCode, District FROM myCity";
if ($result = mysqli_query($link, $query)) {
    while ($row = mysqli_fetch_row($result)) {
        printf("%s (%s,%s)\n", $row[0], $row[1], $row[2]);
    }
    /* free result set */
    mysqli_free_result($result);
}

/* remove table */
mysqli_query($link, "DROP TABLE myCity");

/* close connection */
mysqli_close($link);
?>

Výše uvedený příklad vypíše:

Stuttgart (DEU,Baden-Wuerttemberg)
Bordeaux (FRA,Aquitaine)

Viz také

mysqli_prepare()
mysqli_stmt_bind_param()

Předcházející | Nahoru | Další
mysqli_stmt_error | Domů | mysqli_stmt_fetch


mysqli_stmt_fetch

Předcházející C. MySQL Improved Extension Další

mysqli_stmt_fetch,

(PHP 5)

mysqli_stmt_fetch, stmt->fetch() — Fetch results from a prepared statement into the bound variables

Popis

Procedural style:

bool mysqli_stmt_fetch ( mysqli_stmt $stmt )

Object oriented style (method):

class mysqli_stmt {
bool fetch ( void )
}

Fetch the result from a prepared statement into the variables bound by mysqli_stmt_bind_result().

Poznámka: Note that all columns must be bound by the application before calling mysqli_stmt_fetch().

Seznam parametrů

stmt

Procedural style only: A statement identifier returned by mysqli_stmt_init().

Návratové hodnoty

Tabulka 184. Návratové hodnoty

Value | Description
TRUE | Success. Data has been fetched
FALSE | Error occured
NULL | No more rows/data exists or data truncation occurred

Příklady

Příklad 1383. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER by ID DESC LIMIT 150,5";

if ($stmt = $mysqli->prepare($query)) {

    /* execute statement */
    $stmt->execute();

    /* bind result variables */
    $stmt->bind_result($name, $code);

    /* fetch values */
    while ($stmt->fetch()) {
        printf ("%s (%s)\n", $name, $code);
    }

    /* close statement */
    $stmt->close();
}

/* close connection */
$mysqli->close();
?>

Příklad 1384. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER by ID DESC LIMIT 150,5";

if ($stmt = mysqli_prepare($link, $query)) {

    /* execute statement */
    mysqli_stmt_execute($stmt);

    /* bind result variables */
    mysqli_stmt_bind_result($stmt, $name, $code);

    /* fetch values */
    while (mysqli_stmt_fetch($stmt)) {
        printf ("%s (%s)\n", $name, $code);
    }

    /* close statement */
    mysqli_stmt_close($stmt);
}

/* close connection */
mysqli_close($link);
?>

Výše uvedený příklad vypíše:

Rockford (USA)
Tallahassee (USA)
Salinas (USA)
Santa Clarita (USA)
Springfield (USA)

Viz také

mysqli_prepare()
mysqli_stmt_errno()
mysqli_stmt_error()
mysqli_stmt_bind_result()

Předcházející | Nahoru | Další
mysqli_stmt_execute | Domů | mysqli_stmt_field_count


mysqli_stmt_free_result

Předcházející C. MySQL Improved Extension Další

mysqli_stmt_free_result,

(PHP 5)

mysqli_stmt_free_result, stmt->free_result() — Frees stored result memory for the given statement handle

Popis

Procedural style:

void mysqli_stmt_free_result ( mysqli_stmt $stmt )

Object oriented style (method):

class mysqli_stmt {
void free_result ( void )
}

Frees the result memory associated with the statement, which was allocated by mysqli_stmt_store_result().

Seznam parametrů

stmt

Procedural style only: A statement identifier returned by mysqli_stmt_init().

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

mysqli_stmt_store_result()

Předcházející | Nahoru | Další
mysqli_stmt_field_count | Domů | mysqli_stmt_get_warnings


mysqli_stmt_init

Předcházející C. MySQL Improved Extension Další

mysqli_stmt_init,

(PHP 5)

mysqli_stmt_init, mysqli->stmt_init() — Initializes a statement and returns an object for use with mysqli_stmt_prepare

Popis

Procedural style :

mysqli_stmt mysqli_stmt_init ( mysqli $link )

Object oriented style (property):

class mysqli {
mysqli_stmt stmt_init ( void )
}

Allocates and initializes a statement object suitable for mysqli_stmt_prepare().

Poznámka: Any subsequent calls to any mysqli_stmt function will fail until mysqli_stmt_prepare() was called.

Seznam parametrů

link

Procedural style only: A link identifier returned by mysqli_connect() or mysqli_init()

Návratové hodnoty

Returns an object.

Viz také

mysqli_stmt_prepare()

Předcházející | Nahoru | Další
mysqli_stmt_get_warnings | Domů | mysqli_stmt_insert_id


mysqli_stmt_num_rows

Předcházející C. MySQL Improved Extension Další

mysqli_stmt_num_rows,

(PHP 5)

mysqli_stmt_num_rows, stmt->num_rows — Return the number of rows in statements result set

Popis

Procedural style :

int mysqli_stmt_num_rows ( mysqli_stmt $stmt )

Object oriented style (property):

class mysqli_stmt {
int num_rows
}

Returns the number of rows in the result set. The use of mysqli_stmt_num_rows() depends on whether or not you used mysqli_stmt_store_result() to buffer the entire result set in the statement handle.

If you use mysqli_stmt_store_result(), mysqli_stmt_num_rows() may be called immediately.

Seznam parametrů

stmt

Procedural style only: A statement identifier returned by mysqli_stmt_init().

Návratové hodnoty

An integer representing the number of rows in result set.

Příklady

Příklad 1385. Object oriented style

<?php
/* Open a connection */
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER BY Name LIMIT 20";
if ($stmt = $mysqli->prepare($query)) {

    /* execute query */
    $stmt->execute();

    /* store result */
    $stmt->store_result();

    printf("Number of rows: %d.\n", $stmt->num_rows);

    /* close statement */
    $stmt->close();
}

/* close connection */
$mysqli->close();
?>

Příklad 1386. Procedural style

<?php
/* Open a connection */
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER BY Name LIMIT 20";
if ($stmt = mysqli_prepare($link, $query)) {

    /* execute query */
    mysqli_stmt_execute($stmt);

    /* store result */
    mysqli_stmt_store_result($stmt);

    printf("Number of rows: %d.\n", mysqli_stmt_num_rows($stmt));

    /* close statement */
    mysqli_stmt_close($stmt);
}

/* close connection */
mysqli_close($link);
?>

Výše uvedený příklad vypíše:

Number of rows: 20.

Viz také

mysqli_stmt_affected_rows()
mysqli_prepare()
mysqli_stmt_store_result()

Předcházející | Nahoru | Další
mysqli_stmt_insert_id | Domů | mysqli_stmt_param_count


mysqli_stmt_param_count

Předcházející C. MySQL Improved Extension Další

mysqli_stmt_param_count,

(PHP 5)

mysqli_stmt_param_count, stmt->param_count — Returns the number of parameter for the given statement

Popis

Procedural style:

int mysqli_stmt_param_count ( mysqli_stmt $stmt )

Object oriented style (property):

class mysqli_stmt {
int param_count
}

Returns the number of parameter markers present in the prepared statement.

Seznam parametrů

stmt

Procedural style only: A statement identifier returned by mysqli_stmt_init().

Návratové hodnoty

Returns an integer representing the number of parameters.

Příklady

Příklad 1387. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

if ($stmt = $mysqli->prepare("SELECT Name FROM Country WHERE Name=? OR Code=?")) {

    $marker = $stmt->param_count;
    printf("Statement has %d markers.\n", $marker);

    /* close statement */
    $stmt->close();
}

/* close connection */
$mysqli->close();
?>

Příklad 1388. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

if ($stmt = mysqli_prepare($link, "SELECT Name FROM Country WHERE Name=? OR Code=?")) {

    $marker = mysqli_stmt_param_count($stmt);
    printf("Statement has %d markers.\n", $marker);

    /* close statement */
    mysqli_stmt_close($stmt);
}

/* close connection */
mysqli_close($link);
?>

Výše uvedený příklad vypíše:

Statement has 2 markers.

Viz také

mysqli_prepare()

Předcházející | Nahoru | Další
mysqli_stmt_num_rows | Domů | mysqli_stmt_prepare


mysqli_stmt_prepare

Předcházející C. MySQL Improved Extension Další

mysqli_stmt_prepare,

(PHP 5)

mysqli_stmt_prepare, stmt->prepare() — Prepare a SQL statement for execution

Popis

Procedure style:

bool mysqli_stmt_prepare ( mysqli_stmt $stmt, string $query )

Object oriented style (method)

class mysqli_stmt {
mixed prepare ( string $query )
}

Prepares the SQL query pointed to by the null-terminated string query.

The parameter markers must be bound to application variables using mysqli_stmt_bind_param() and/or mysqli_stmt_bind_result() before executing the statement or fetching rows.

Seznam parametrů

stmt

Procedural style only: A statement identifier returned by mysqli_stmt_init().

query

The query, as a string. It must consist of a single SQL statement.

You can include one or more parameter markers in the SQL statement by embedding question mark (?) characters at the appropriate positions.

Poznámka: You should not add a terminating semicolon or \g to the statement.

Poznámka: The markers are legal only in certain places in SQL statements. For example, they are allowed in the VALUES() list of an INSERT statement (to specify column values for a row), or in a comparison with a column in a WHERE clause to specify a comparison value.

However, they are not allowed for identifiers (such as table or column names), in the select list that names the columns to be returned by a SELECT statement), or to specify both operands of a binary operator such as the = equal sign. The latter restriction is necessary because it would be impossible to determine the parameter type. In general, parameters are legal only in Data Manipulation Languange (DML) statements, and not in Data Defination Language (DDL) statements.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1389. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$city = "Amersfoort";

/* create a prepared statement */
$stmt =  $mysqli->stmt_init();
if ($stmt->prepare("SELECT District FROM City WHERE Name=?")) {

    /* bind parameters for markers */
    $stmt->bind_param("s", $city);

    /* execute query */
    $stmt->execute();

    /* bind result variables */
    $stmt->bind_result($district);

    /* fetch value */
    $stmt->fetch();

    printf("%s is in district %s\n", $city, $district);

    /* close statement */
    $stmt->close();
}

/* close connection */
$mysqli->close();
?>

Příklad 1390. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$city = "Amersfoort";

/* create a prepared statement */
$stmt = mysqli_stmt_init($link);
if (mysqli_stmt_prepare($stmt, 'SELECT District FROM City WHERE Name=?')) {

    /* bind parameters for markers */
    mysqli_stmt_bind_param($stmt, "s", $city);

    /* execute query */
    mysqli_stmt_execute($stmt);

    /* bind result variables */
    mysqli_stmt_bind_result($stmt, $district);

    /* fetch value */
    mysqli_stmt_fetch($stmt);

    printf("%s is in district %s\n", $city, $district);

    /* close statement */
    mysqli_stmt_close($stmt);
}

/* close connection */
mysqli_close($link);
?>

Výše uvedený příklad vypíše:

Amersfoort is in district Utrecht

Viz také

mysqli_stmt_init(),
mysqli_stmt_execute(),
mysqli_stmt_fetch(),
mysqli_stmt_bind_param(),
mysqli_stmt_bind_result()
mysqli_stmt_close().

Předcházející | Nahoru | Další
mysqli_stmt_param_count | Domů | mysqli_stmt_reset


mysqli_stmt_reset

Předcházející C. MySQL Improved Extension Další

mysqli_stmt_reset,

(PHP 5)

mysqli_stmt_reset, stmt->reset() — Resets a prepared statement

Popis

Procedural style:

bool mysqli_stmt_reset ( mysqli_stmt $stmt )

Object oriented style (method):

class mysqli_stmt {
bool reset ( void )
}

Resets a prepared statement on client and server to state after prepare.

For now this is mainly used to reset data sent with mysqli_stmt_send_long_data().

To prepare a statement with another query use function mysqli_stmt_prepare().

Seznam parametrů

stmt

Procedural style only: A statement identifier returned by mysqli_stmt_init().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

mysqli_prepare()

Předcházející | Nahoru | Další
mysqli_stmt_prepare | Domů | mysqli_stmt_result_metadata


mysqli_stmt_result_metadata

Předcházející C. MySQL Improved Extension Další

mysqli_stmt_result_metadata,

(PHP 5)

mysqli_stmt_result_metadata, stmt->result_metadata() — Returns result set metadata from a prepared statement

Popis

Procedural style:

mysqli_result mysqli_stmt_result_metadata ( mysqli_stmt $stmt )

Object oriented style (method):

class mysqli_stmt {
mysqli_result result_metadata ( void )
}

If a statement passed to mysqli_prepare() is one that produces a result set, mysqli_stmt_result_metadata() returns the result object that can be used to process the meta information such as total number of fields and individual field information.

Poznámka: This result set pointer can be passed as an argument to any of the field-based functions that process result set metadata, such as:

  • mysqli_num_fields()

  • mysqli_fetch_field()

  • mysqli_fetch_field_direct()

  • mysqli_fetch_fields()

  • mysqli_field_count()

  • mysqli_field_seek()

  • mysqli_field_tell()

  • mysqli_free_result()

The result set structure should be freed when you are done with it, which you can do by passing it to mysqli_free_result()

Poznámka: The result set returned by mysqli_stmt_result_metadata() contains only metadata. It does not contain any row results. The rows are obtained by using the statement handle with mysqli_stmt_fetch().

Seznam parametrů

stmt

Procedural style only: A statement identifier returned by mysqli_stmt_init().

Návratové hodnoty

Returns a result object or FALSE if an error occured.

Příklady

Příklad 1391. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "test");

$mysqli->query("DROP TABLE IF EXISTS friends");
$mysqli->query("CREATE TABLE friends (id int, name varchar(20))");

$mysqli->query("INSERT INTO friends VALUES (1,'Hartmut'), (2, 'Ulf')");

$stmt = $mysqli->prepare("SELECT id, name FROM friends");
$stmt->execute();

/* get resultset for metadata */
$result = $stmt->result_metadata();

/* retrieve field information from metadata result set */
$field = $result->fetch_field();

printf("Fieldname: %s\n", $field->name);

/* close resultset */
$result->close();

/* close connection */
$mysqli->close();
?>

Příklad 1392. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "test");

mysqli_query($link, "DROP TABLE IF EXISTS friends");
mysqli_query($link, "CREATE TABLE friends (id int, name varchar(20))");

mysqli_query($link, "INSERT INTO friends VALUES (1,'Hartmut'), (2, 'Ulf')");

$stmt = mysqli_prepare($link, "SELECT id, name FROM friends");
mysqli_stmt_execute($stmt);

/* get resultset for metadata */
$result = mysqli_stmt_result_metadata($stmt);

/* retrieve field information from metadata result set */
$field = mysqli_fetch_field($result);

printf("Fieldname: %s\n", $field->name);

/* close resultset */
mysqli_free_result($result);

/* close connection */
mysqli_close($link);
?>

Viz také

mysqli_prepare()
mysqli_free_result()

Předcházející | Nahoru | Další
mysqli_stmt_reset | Domů | mysqli_stmt_send_long_data


mysqli_stmt_send_long_data

Předcházející C. MySQL Improved Extension Další

mysqli_stmt_send_long_data,

(PHP 5)

mysqli_stmt_send_long_data, stmt->send_long_data() — Send data in blocks

Popis

Procedural style:

bool mysqli_stmt_send_long_data ( mysqli_stmt $stmt, int $param_nr, string $data )

Object oriented style (method)

class mysqli_stmt {
bool send_long_data ( int $param_nr, string $data )
}

Allows to send parameter data to the server in pieces (or chunks), e.g. if the size of a blob exceeds the size of max_allowed_packet. This function can be called multiple times to send the parts of a character or binary data value for a column, which must be one of the TEXT or BLOB datatypes.

Seznam parametrů

stmt

Procedural style only: A statement identifier returned by mysqli_stmt_init().

param_nr

Indicates which parameter to associate the data with. Parameters are numbered beginning with 0.

data

A string containing data to be sent.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1393. Object oriented style

<?php
$stmt = $mysqli->prepare("INSERT INTO messages (message) VALUES (?)");
$null = NULL;
$stmt->bind_param("b", $null);
$fp = fopen("messages.txt", "r");
while (!feof($fp)) {
    $stmt->send_long_data(0, fread($fp, 8192));
}
fclose($fp);
$stmt->execute();
?>

Viz také

mysqli_prepare()
mysqli_stmt_bind_param()

Předcházející | Nahoru | Další
mysqli_stmt_result_metadata | Domů | mysqli_stmt_sqlstate


mysqli_stmt_sqlstate

Předcházející C. MySQL Improved Extension Další

mysqli_stmt_sqlstate,

(PHP 5)

mysqli_stmt_sqlstate, mysqli_stmt->sqlstate() — Returns SQLSTATE error from previous statement operation

Popis

string mysqli_stmt_sqlstate ( mysqli_stmt $stmt )

Object oriented style (property):

class mysqli_stmt {
string sqlstate
}

Returns a string containing the SQLSTATE error code for the most recently invoked prepared statement function that can succeed or fail. The error code consists of five characters. '00000' means no error. The values are specified by ANSI SQL and ODBC. For a list of possible values, see » http://dev.mysql.com/doc/mysql/en/error-handling.html.

Seznam parametrů

stmt

Procedural style only: A statement identifier returned by mysqli_stmt_init().

Návratové hodnoty

Returns a string containing the SQLSTATE error code for the last error. The error code consists of five characters. '00000' means no error.

Poznámky

Poznámka: Note that not all MySQL errors are yet mapped to SQLSTATE's. The value HY000 (general error) is used for unmapped errors.

Příklady

Příklad 1394. Object oriented style

<?php
/* Open a connection */
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$mysqli->query("CREATE TABLE myCountry LIKE Country");
$mysqli->query("INSERT INTO myCountry SELECT * FROM Country");

$query = "SELECT Name, Code FROM myCountry ORDER BY Name";
if ($stmt = $mysqli->prepare($query)) {

    /* drop table */
    $mysqli->query("DROP TABLE myCountry");

    /* execute query */
    $stmt->execute();

    printf("Error: %s.\n", $stmt->sqlstate);

    /* close statement */
    $stmt->close();
}

/* close connection */
$mysqli->close();
?>

Příklad 1395. Procedural style

<?php
/* Open a connection */
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

mysqli_query($link, "CREATE TABLE myCountry LIKE Country");
mysqli_query($link, "INSERT INTO myCountry SELECT * FROM Country");

$query = "SELECT Name, Code FROM myCountry ORDER BY Name";
if ($stmt = mysqli_prepare($link, $query)) {

    /* drop table */
    mysqli_query($link, "DROP TABLE myCountry");

    /* execute query */
    mysqli_stmt_execute($stmt);

    printf("Error: %s.\n", mysqli_stmt_sqlstate($stmt));

    /* close statement */
    mysqli_stmt_close($stmt);
}

/* close connection */
mysqli_close($link);
?>

Výše uvedený příklad vypíše:

Error: 42S02.

Viz také

mysqli_stmt_errno()
mysqli_stmt_error()

Předcházející | Nahoru | Další
mysqli_stmt_send_long_data | Domů | mysqli_stmt_store_result


mysqli_stmt_store_result

Předcházející C. MySQL Improved Extension Další

mysqli_stmt_store_result,

(PHP 5)

mysqli_stmt_store_result, mysqli_stmt->store_result() — Transfers a result set from a prepared statement

Popis

Procedural style:

bool mysqli_stmt_store_result ( mysqli_stmt $stmt )

Object oriented style (method):

class mysqli_stmt {
bool store_result ( void )
}

You must call mysqli_stmt_store_result() for every query that successfully produces a result set (SELECT, SHOW, DESCRIBE, EXPLAIN), and only if you want to buffer the complete result set by the client, so that the subsequent mysqli_stmt_fetch() call returns buffered data.

Poznámka: It is unnecessary to call mysqli_stmt_store_result() for other queries, but if you do, it will not harm or cause any notable performance in all cases. You can detect whether the query produced a result set by checking if mysqli_stmt_result_metadata() returns NULL.

Seznam parametrů

stmt

Procedural style only: A statement identifier returned by mysqli_stmt_init().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1396. Object oriented style

<?php
/* Open a connection */
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER BY Name LIMIT 20";
if ($stmt = $mysqli->prepare($query)) {

    /* execute query */
    $stmt->execute();

    /* store result */
    $stmt->store_result();

    printf("Number of rows: %d.\n", $stmt->num_rows);

    /* free result */
    $stmt->free_result();

    /* close statement */
    $stmt->close();
}

/* close connection */
$mysqli->close();
?>

Příklad 1397. Procedural style

<?php
/* Open a connection */
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query = "SELECT Name, CountryCode FROM City ORDER BY Name LIMIT 20";
if ($stmt = mysqli_prepare($link, $query)) {

    /* execute query */
    mysqli_stmt_execute($stmt);

    /* store result */
    mysqli_stmt_store_result($stmt);

    printf("Number of rows: %d.\n", mysqli_stmt_num_rows($stmt));

    /* free result */
    mysqli_stmt_free_result($stmt);

    /* close statement */
    mysqli_stmt_close($stmt);
}

/* close connection */
mysqli_close($link);
?>

Výše uvedený příklad vypíše:

Number of rows: 20.

Viz také

mysqli_prepare()
mysqli_stmt_result_metadata()
mysqli_stmt_fetch()

Předcházející | Nahoru | Další
mysqli_stmt_sqlstate | Domů | mysqli_store_result


mysqli_store_result

Předcházející C. MySQL Improved Extension Další

mysqli_store_result,

(PHP 5)

mysqli_store_result, mysqli->store_result() — Transfers a result set from the last query

Popis

Procedural style:

mysqli_result mysqli_store_result ( mysqli $link )

Object oriented style (method):

class mysqli {
mysqli_result store_result ( void )
}

Transfers the result set from the last query on the database connection represented by the link parameter to be used with the mysqli_data_seek() function.

Seznam parametrů

link

Procedural style only: A link identifier returned by mysqli_connect() or mysqli_init()

Návratové hodnoty

Returns a buffered result object or FALSE if an error occurred.

Poznámka: mysqli_store_result() returns FALSE in case the query didn't return a result set (if the query was, for example an INSERT statement). This function also returns FALSE if the reading of the result set failed. You can check if you have got an error by checking if mysqli_error() doesn't return an empty string, if mysqli_errno() returns a non zero value, or if mysqli_field_count() returns a non zero value. Also possible reason for this function returning FALSE after successfull call to mysqli_query() can be too large result set (memory for it cannot be allocated). If mysqli_field_count() returns a non-zero value, the statement should have produced a non-empty result set.

Poznámky

Poznámka: Although it is always good practice to free the memory used by the result of a query using the mysqli_free_result() function, when transfering large result sets using the mysqli_store_result() this becomes particularly important.

Příklady

See mysqli_multi_query().

Viz také

mysqli_real_query()
mysqli_use_result()

Předcházející | Nahoru | Další
mysqli_stmt_store_result | Domů | mysqli_thread_id


mysqli_thread_id

Předcházející C. MySQL Improved Extension Další

mysqli_thread_id,

(PHP 5)

mysqli_thread_id, mysqli->thread_id — Returns the thread ID for the current connection

Popis

Procedural style:

int mysqli_thread_id ( mysqli $link )

Object oriented style (property):

class mysqli {
int thread_id
}

The mysqli_thread_id() function returns the thread ID for the current connection which can then be killed using the mysqli_kill() function. If the connection is lost and you reconnect with mysqli_ping(), the thread ID will be other. Therefore you should get the thread ID only when you need it.

Poznámka: The thread ID is assigned on a connection-by-connection basis. Hence, if the connection is broken and then re-established a new thread ID will be assigned.

To kill a running query you can use the SQL command KILL QUERY processid.

Seznam parametrů

link

Procedural style only: A link identifier returned by mysqli_connect() or mysqli_init()

Návratové hodnoty

Returns the Thread ID for the current connection.

Příklady

Příklad 1398. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* determine our thread id */
$thread_id = $mysqli->thread_id;

/* Kill connection */
$mysqli->kill($thread_id);

/* This should produce an error */
if (!$mysqli->query("CREATE TABLE myCity LIKE City")) {
    printf("Error: %s\n", $mysqli->error);
    exit;
}

/* close connection */
$mysqli->close();
?>

Příklad 1399. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* determine our thread id */
$thread_id = mysqli_thread_id($link);

/* Kill connection */
mysqli_kill($link, $thread_id);

/* This should produce an error */
if (!mysqli_query($link, "CREATE TABLE myCity LIKE City")) {
    printf("Error: %s\n", mysqli_error($link));
    exit;
}

/* close connection */
mysqli_close($link);
?>

Výše uvedený příklad vypíše:

Error: MySQL server has gone away

Viz také

mysqli_kill()

Předcházející | Nahoru | Další
mysqli_store_result | Domů | mysqli_thread_safe


mysqli_thread_safe

(PHP 5)

mysqli_thread_safe — Returns whether thread safety is given or not

Popis

Procedural style:

bool mysqli_thread_safe ( void )

Tells whether the client library is compiled as thread-safe.

Návratové hodnoty

TRUE if the client library is thread-safe, otherwise FALSE.

Předcházející | Nahoru | Další
mysqli_thread_id | Domů | mysqli_use_result


mysqli_use_result

Předcházející C. MySQL Improved Extension Další

mysqli_use_result,

(PHP 5)

mysqli_use_result, mysqli->use_result() — Initiate a result set retrieval

Popis

Procedural style:

mysqli_result mysqli_use_result ( mysqli $link )

Object oriented style (method):

class mysqli {
mysqli_result use_result ( void )
}

Used to initiate the retrieval of a result set from the last query executed using the mysqli_real_query() function on the database connection.

Either this or the mysqli_store_result() function must be called before the results of a query can be retrieved, and one or the other must be called to prevent the next query on that database connection from failing.

Poznámka: The mysqli_use_result() function does not transfer the entire result set from the database and hence cannot be used functions such as mysqli_data_seek() to move to a particular row within the set. To use this functionality, the result set must be stored using mysqli_store_result(). One should not use mysqli_use_result() if a lot of processing on the client side is performed, since this will tie up the server and prevent other threads from updating any tables from which the data is being fetched.

Návratové hodnoty

Returns an unbuffered result object or FALSE if an error occurred.

Příklady

Příklad 1400. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query  = "SELECT CURRENT_USER();";
$query .= "SELECT Name FROM City ORDER BY ID LIMIT 20, 5";

/* execute multi query */
if ($mysqli->multi_query($query)) {
    do {
        /* store first result set */
        if ($result = $mysqli->use_result()) {
            while ($row = $result->fetch_row()) {
                printf("%s\n", $row[0]);
            }
            $result->close();
        }
        /* print divider */
        if ($mysqli->more_results()) {
            printf("-----------------\n");
        }
    } while ($mysqli->next_result());
}

/* close connection */
$mysqli->close();
?>

Příklad 1401. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$query  = "SELECT CURRENT_USER();";
$query .= "SELECT Name FROM City ORDER BY ID LIMIT 20, 5";

/* execute multi query */
if (mysqli_multi_query($link, $query)) {
    do {
        /* store first result set */
        if ($result = mysqli_use_result($link)) {
            while ($row = mysqli_fetch_row($result)) {
                printf("%s\n", $row[0]);
            }
            mysqli_free_result($result);
        }
        /* print divider */
        if (mysqli_more_results($link)) {
            printf("-----------------\n");
        }
    } while (mysqli_next_result($link));
}

/* close connection */
mysqli_close($link);
?>

Výše uvedený příklad vypíše:

my_user@localhost
-----------------
Amersfoort
Maastricht
Dordrecht
Leiden
Haarlemmermeer

Viz také

mysqli_real_query()
mysqli_store_result()

Předcházející | Nahoru | Další
mysqli_thread_safe | Domů | mysqli_warning_count


mysqli_warning_count

Předcházející C. MySQL Improved Extension Další

mysqli_warning_count,

(PHP 5)

mysqli_warning_count, mysqli->warning_count — Returns the number of warnings from the last query for the given link

Popis

Procedural style:

int mysqli_warning_count ( mysqli $link )

Object oriented style (property):

class mysqli {
int warning_count
}

Returns the number of warnings from the last query in the connection.

Poznámka: For retrieving warning messages you can use the SQL command SHOW WARNINGS [limit row_count].

Seznam parametrů

link

Procedural style only: A link identifier returned by mysqli_connect() or mysqli_init()

Návratové hodnoty

Number of warnings or zero if there are no warnings.

Příklady

Příklad 1402. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

$mysqli->query("CREATE TABLE myCity LIKE City");

/* a remarkable city in Wales */
$query = "INSERT INTO myCity (CountryCode, Name) VALUES('GBR',
        'Llanfairpwllgwyngyllgogerychwyrndrobwllllantysiliogogogoch')";

$mysqli->query($query);

if ($mysqli->warning_count) {
    if ($result = $mysqli->query("SHOW WARNINGS")) {
        $row = $result->fetch_row();
        printf("%s (%d): %s\n", $row[0], $row[1], $row[2]);
        $result->close();
    }
}

/* close connection */
$mysqli->close();
?>

Příklad 1403. Procedural style

<?php
$link = mysqli_connect("localhost", "my_user", "my_password", "world");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

mysqli_query($link, "CREATE TABLE myCity LIKE City");

/* a remarkable long city name in Wales */
$query = "INSERT INTO myCity (CountryCode, Name) VALUES('GBR',
        'Llanfairpwllgwyngyllgogerychwyrndrobwllllantysiliogogogoch')";

mysqli_query($link, $query);

if (mysqli_warning_count($link)) {
    if ($result = mysqli_query($link, "SHOW WARNINGS")) {
        $row = mysqli_fetch_row($result);
        printf("%s (%d): %s\n", $row[0], $row[1], $row[2]);
        mysqli_free_result($result);
    }
}

/* close connection */
mysqli_close($link);
?>

Výše uvedený příklad vypíše:

Warning (1264): Data truncated for column 'Name' at row 1

Viz také

mysqli_errno()
mysqli_error()
mysqli_sqlstate()

Předcházející | Nahoru | Další
mysqli_use_result | Domů | CI. Ncurses Terminal Screen Control Functions


Mohawk Software Session Handler Functions

Předcházející VI. Reference funkcí Další

XCIV. Mohawk Software Session Handler Functions

Úvod

msession is an interface to a high speed session daemon which can run either locally or remotely. It is designed to provide consistent session management for a PHP web farm. More Information about msession and the session server software itself can be found at » http://www.mohawksoft.org/?q=node/8.

Poznámka: Toto rozšíření není k dispozici na platformách Windows.

Poznámka: Toto rozšíření bylo přesunuto do repozitáře PECL a již nebude součástí balíku PHP.5.1.3.

Požadavky

Instalace

To enable Msession support configure PHP --with-msession[=DIR], where DIR is the Msession install directory.

Konfigurace běhu

Typy prostředků

Předdefinované konstanty

Obsah

msession_connect — Connect to msession server
msession_count — Get session count
msession_create — Create a session
msession_destroy — Destroy a session
msession_disconnect — Close connection to msession server
msession_find — Find all sessions with name and value
msession_get_array — Get array of msession variables
msession_get_data — Get data session unstructured data
msession_get — Get value from session
msession_inc — Increment value in session
msession_list — List all sessions
msession_listvar — List sessions with variable
msession_lock — Lock a session
msession_plugin — Call an escape function within the msession personality plugin
msession_randstr — Get random string
msession_set_array — Set msession variables from an array
msession_set_data — Set data session unstructured data
msession_set — Set value in session
msession_timeout — Set/get session timeout
msession_uniq — Get unique id
msession_unlock — Unlock a session
Předcházející | Nahoru | Další
PDO_DBLIB DSN | Domů | msession_connect


msession_connect

(PHP 4 >= 4.2.0, PHP 5 <= 5.1.2)

msession_connect — Connect to msession server

Popis

bool msession_connect ( string $host, string $port )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
XCIV. Mohawk Software Session Handler Functions | Domů | msession_count


msession_count

(PHP 4 >= 4.2.0, PHP 5 <= 5.1.2)

msession_count — Get session count

Popis

int msession_count ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
msession_connect | Domů | msession_create


msession_create

(PHP 4 >= 4.2.0, PHP 5 <= 5.1.2)

msession_create — Create a session

Popis

bool msession_create ( string $session, string $classname, string $data )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
msession_count | Domů | msession_destroy


msession_destroy

(PHP 4 >= 4.2.0, PHP 5 <= 5.1.2)

msession_destroy — Destroy a session

Popis

bool msession_destroy ( string $name )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
msession_create | Domů | msession_disconnect


msession_disconnect

(PHP 4 >= 4.2.0, PHP 5 <= 5.1.2)

msession_disconnect — Close connection to msession server

Popis

void msession_disconnect ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
msession_destroy | Domů | msession_find


msession_find

(PHP 4 >= 4.2.0, PHP 5 <= 5.1.2)

msession_find — Find all sessions with name and value

Popis

array msession_find ( string $name, string $value )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
msession_disconnect | Domů | msession_get_array


msession_get_array

(PHP 4 >= 4.2.0, PHP 5 <= 5.1.2)

msession_get_array — Get array of msession variables

Popis

array msession_get_array ( string $session )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
msession_find | Domů | msession_get_data


msession_get_data

(PHP 4 >= 4.2.0, PHP 5 <= 5.1.2)

msession_get_data — Get data session unstructured data

Popis

string msession_get_data ( string $session )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
msession_get_array | Domů | msession_get


msession_get

(PHP 4 >= 4.2.0, PHP 5 <= 5.1.2)

msession_get — Get value from session

Popis

string msession_get ( string $session, string $name, string $value )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
msession_get_data | Domů | msession_inc


msession_inc

(PHP 4 >= 4.2.0, PHP 5 <= 5.1.2)

msession_inc — Increment value in session

Popis

string msession_inc ( string $session, string $name )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
msession_get | Domů | msession_list


msession_list

(PHP 4 >= 4.2.0, PHP 5 <= 5.1.2)

msession_list — List all sessions

Popis

array msession_list ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
msession_inc | Domů | msession_listvar


msession_listvar

(PHP 4 >= 4.2.0, PHP 5 <= 5.1.2)

msession_listvar — List sessions with variable

Popis

array msession_listvar ( string $name )

Used for searching sessions with common attributes.

Návratové hodnoty

Returns an associative array of value/session for all sessions with a variable named name.

Předcházející | Nahoru | Další
msession_list | Domů | msession_lock


msession_lock

(PHP 4 >= 4.2.0, PHP 5 <= 5.1.2)

msession_lock — Lock a session

Popis

int msession_lock ( string $name )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
msession_listvar | Domů | msession_plugin


msession_plugin

(PHP 4 >= 4.2.0, PHP 5 <= 5.1.2)

msession_plugin — Call an escape function within the msession personality plugin

Popis

string msession_plugin ( string $session, string $val [, string $param] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
msession_lock | Domů | msession_randstr


msession_randstr

(PHP 4 >= 4.2.0, PHP 5 <= 5.1.2)

msession_randstr — Get random string

Popis

string msession_randstr ( int $param )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
msession_plugin | Domů | msession_set_array


msession_set_array

(PHP 4 >= 4.2.0, PHP 5 <= 5.1.2)

msession_set_array — Set msession variables from an array

Popis

void msession_set_array ( string $session, array $tuples )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
msession_randstr | Domů | msession_set_data


msession_set_data

(PHP 4 >= 4.2.0, PHP 5 <= 5.1.2)

msession_set_data — Set data session unstructured data

Popis

bool msession_set_data ( string $session, string $value )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
msession_set_array | Domů | msession_set


msession_set

(PHP 4 >= 4.2.0, PHP 5 <= 5.1.2)

msession_set — Set value in session

Popis

bool msession_set ( string $session, string $name, string $value )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
msession_set_data | Domů | msession_timeout


msession_timeout

(PHP 4 >= 4.2.0, PHP 5 <= 5.1.2)

msession_timeout — Set/get session timeout

Popis

int msession_timeout ( string $session [, int $param] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
msession_set | Domů | msession_uniq


msession_uniq

(PHP 4 >= 4.2.0, PHP 5 <= 5.1.2)

msession_uniq — Get unique id

Popis

string msession_uniq ( int $param, string $classname, string $data )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
msession_timeout | Domů | msession_unlock


msession_unlock

(PHP 4 >= 4.2.0, PHP 5 <= 5.1.2)

msession_unlock — Unlock a session

Popis

int msession_unlock ( string $session, int $key )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
msession_uniq | Domů | XCV. mSQL Functions


muscat Functions

Předcházející VI. Reference funkcí Další

XCVII. muscat Functions

Úvod

This extension provides an interface to the Muscat 3.6 search system. Muscat doesn't exist anymore, but the » Xapian project may provide you with a good alternative.

Varování

Toto rozšíření je EXPERIMENTÁLNÍ. Chování tohoto rozšíření, názvy funkcí a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může bez ohlášení změnit. Berte to v úvahu a používejte tento modul na vlastní nebezpečí.

Instalace

These functions are only available if PHP was configured with --with-muscat[=DIR].

Typy prostředků

This extension defines a Muscat session handler returned by muscat_setup_net() and muscat_setup().

Obsah

muscat_close — Shuts down the muscat session
muscat_get — Gets a line back from the core muscat API
muscat_give — Sends string to the core muscat API
muscat_setup_net — Creates a new muscat session
muscat_setup — Creates a new local muscat session
Předcházející | Nahoru | Další
mb_substr | Domů | muscat_close


muscat_close

(PHP 4 >= 4.0.5)

muscat_close — Shuts down the muscat session

Popis

void muscat_close ( resource $muscat_handle )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Shuts down the muscat session and releases any memory back to PHP.

Seznam parametrů

muscat_handle

A muscat session handler, returned by muscat_setup() or muscat_setup_net().

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

muscat_setup()
muscat_setup_net()

Předcházející | Nahoru | Další
XCVII. muscat Functions | Domů | muscat_get


muscat_get

(PHP 4 >= 4.0.5)

muscat_get — Gets a line back from the core muscat API

Popis

string muscat_get ( resource $muscat_handle )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Gets a line back from the core muscat API.

Seznam parametrů

muscat_handle

A muscat session handler, returned by muscat_setup() or muscat_setup_net().

Návratové hodnoty

Returns the muscat response, as a string.

Varování

Tato funkce může vracet booleovskou hodnotu FALSE, ale také nebooleovskou hodnotu odpovídající ohodnocení FALSE, například 0 nebo "". Čtěte prosím sekci o typu Boolean, kde najdete více informací. Pro testování návratové hodnoty této funkce použijte operátor ===.

Viz také

muscat_give()

Předcházející | Nahoru | Další
muscat_close | Domů | muscat_give


muscat_give

(PHP 4 >= 4.0.5)

muscat_give — Sends string to the core muscat API

Popis

void muscat_give ( resource $muscat_handle, string $string )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sends a string to the core muscat API.

Seznam parametrů

muscat_handle

A muscat session handler, returned by muscat_setup() or muscat_setup_net().

string

The string to be sent

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

muscat_get()

Předcházející | Nahoru | Další
muscat_get | Domů | muscat_setup_net


muscat_setup_net

(PHP 4 >= 4.0.5)

muscat_setup_net — Creates a new muscat session

Popis

resource muscat_setup_net ( resource $socket )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Creates a new muscat session.

Seznam parametrů

socket

Socket handle

Návratové hodnoty

Returns a session handler or FALSE on error.

Viz také

muscat_setup()
muscat_close()

Předcházející | Nahoru | Další
muscat_give | Domů | muscat_setup


muscat_setup

(PHP 4 >= 4.0.5)

muscat_setup — Creates a new local muscat session

Popis

resource muscat_setup ( int $size [, string $muscat_dir] )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Creates a new local muscat session.

Seznam parametrů

size

The amount of memory in bytes to allocate for muscat

muscat_dir

The muscat installation dir e.g. "/usr/local/empower", it defaults to the compile time muscat directory.

Návratové hodnoty

Returns a session handler or FALSE on error.

Viz také

muscat_setup_net()
muscat_close()

Předcházející | Nahoru | Další
muscat_setup_net | Domů | XCVIII. MySQL funkce


Síťové funkce

Předcházející VI. Reference funkcí Další

CII. Síťové funkce

Úvod

Požadavky

Tyto funkce jsou k dispozici jako součást standardního modulu, který je vždy dostupný.

Instalace

K používání těchto funkcí není třeba žádná instalace, jsou součástí jádra PHP.

Konfigurace běhu

Chování těchto funkcí je ovlivněno nastavením parametrů v php.ini.

Tabulka 188. Síť - konfigurační volby

Název | Výchozí hodnota | Lze změnit v
define_syslog_variables | "0" | PHP_INI_ALL

Bližší informace o PHP_INI_* konstantách naleznete v části ini_set().

Zde je stručný popis konfiguračních direktiv.

define_syslog_variables boolean

Určuje, zda definovat různé proměnné funkce syslog (např. $LOG_PID, $LOG_CRON, atd.). Vypnutí těchto proměnných je užitečné pro výkonnost. Za běhu můžete tyto proměnné definovat funkcí define_syslog_variables().

Typy prostředků

Toto rozšíření nemá definován žádný typ prostředku (resource).

Předdefinované konstanty

Konstanty z tohoto seznamu jsou vždy dostupné jako součást jádra PHP.

Tabulka 189. openlog() - parametr option

Konstanta | Popis
LOG_CONS | pokud nastane chyba při zápisu do systémového logu, zapíše přímo na systémovou konzoli
LOG_NDELAY | otevřít připojení k loggeru ihned
LOG_ODELAY | (výchozí) vyčkat s otevřením spojení do prvního záznamu
LOG_NOWAIT |
LOG_PERROR | vypsat zprávy logu také na chybový výstup
LOG_PID | ke každé zprávě přidat PID

Tabulka 190. openlog() - parametr facility

Konstanta | Popis
LOG_AUTH | bezpečnostní/autorizační zprávy (na systémech, kde je definována konstanta LOG_AUTHPRIV, použijte raději tu)
LOG_AUTHPRIV | bezpečnostní/autorizační zprávy (soukromé)
LOG_CRON | clock daemon (cron a at)
LOG_DAEMON | jiné systémové daemony
LOG_KERN | zprávy kernelu
LOG_LOCAL0 ... LOG_LOCAL7 | vyhrazeno pro místní použití, nejsou k dispozici pod Windows
LOG_LPR | subsystém tiskárny
LOG_MAIL | subsystém e-mailu
LOG_NEWS | subsystém USENET news
LOG_SYSLOG | zprávy interně generované daemonem syslogd
LOG_USER | obecné zprávy na uživatelské úrovni
LOG_UUCP | subsystém UUCP

Tabulka 191. syslog() - parametr priority

Konstanta | Popis
LOG_EMERG | systém je nepoužitelný
LOG_ALERT | zásah musí proběhnout ihned
LOG_CRIT | kritické okolnosti
LOG_ERR | chybové okolnosti
LOG_WARNING | varovné okolnosti
LOG_NOTICE | normální, ale důležité okolnosti
LOG_INFO | informační zpráva
LOG_DEBUG | ladící zpráva

Tabulka 192. dns_get_record() - parametr option

Konstanta | Popis
DNS_A | IPv4 Address Resource
DNS_MX | Mail Exchanger Resource
DNS_CNAME | Alias (Canonical Name) Resource
DNS_NS | Authoritative Name Server Resource
DNS_PTR | Pointer Resource
DNS_HINFO | Host Info Resource (Viz odkaz organizace IANA » Operating System Names pro význam těchto hodnot
DNS_SOA | Start of Authority Resource
DNS_TXT | Text Resource
DNS_ANY | Any Resource Record. Na většině systémů vrátí všechny záznamy, ale mělo by se používat pouze za krizových okolností. Raději použijte DNS_ALL.
DNS_AAAA | IPv6 Address Resource
DNS_ALL | Postupně se dotáže name-serveru na všechny dostupné typy záznamů.

Obsah

checkdnsrr — Ověří DNS záznamy odpovídající danému názvu počítače na Internetu nebo jeho IP adrese.
closelog — Zavře spojení do systémového protokolu
debugger_off — Vypne vnitřní PHP debugger
debugger_on — Zapne vnitřní PHP debugger
define_syslog_variables — Inicializuje všechny konstanty související se systémovým protokolem
dns_check_record — Alias pro checkdnsrr()
dns_get_mx — Alias pro getmxrr()
dns_get_record — Fetch DNS Resource Records associated with a hostname
fsockopen — Otevře socketové spojení v internetové nebo unixové doméně.
gethostbyaddr — Vrací internetové jméno počítače, odpovídající dané IP adrese
gethostbyname — Vrací IP adresu odpovídající danému internetovému jménu počítače
gethostbynamel — Vracé seznam IP adres odpovídajících danému internetovému jménu počítače
getmxrr — Vrací MX záznamy odpovídající dané internetové jmenné adrese
getprotobyname — Vrací číslo protokolu podle názvu tohoto protokolu
getprotobynumber — Vrací název protokolu podle čísla tohoto protokolu
getservbyname — Vrací číslo portu podle internetové služby a protokolu
getservbyport — Vrací internetovou službu odpovídající specifikovanému portu a protokolu
header — Poslat HTTP hlavičku
headers_list — Returns a list of response headers sent (or ready to send)
headers_sent — Vrátit TRUE, pokud byly odeslány hlavičky
inet_ntop — Converts a packed internet address to a human readable representation
inet_pton — Converts a human readable IP address to its packed in_addr representation
ip2long — Převede řetězec obsahující internetovou (IPv4) adresu v tečkové notaci na odpovídající adresu.
long2ip — Převede internetovou (IPv4) adresu na řetězec ve standardním tečkovém formátu
openlog — Otevře spojení do systémového protokolu
pfsockopen — Otevře perzistentní (přetrvávající) socketové spojení v internetové nebo unixové doméně
setcookie — Poslat cookie
setrawcookie — Send a cookie without urlencoding the cookie value
socket_get_status — Vrací informace o existujícím socketovém proudu
socket_set_blocking — Nastavuje blokující/neblokující režim socketu
socket_set_timeout — Nastaví časový limit (timeout) socketu
syslog — Vygeneruje zprávu do systémového protokolu
Předcházející | Nahoru | Další
ncurses_wvline | Domů | checkdnsrr


checkdnsrr

(PHP 4, PHP 5)

checkdnsrr — Ověří DNS záznamy odpovídající danému názvu počítače na Internetu nebo jeho IP adrese.

Popis

int checkdnsrr ( string $host [, string $type] )

Prohledá DNS na záznamy typu type, odpovídající názvu host. Vrací TRUE, pokud najde nějaké záznamy a FALSE, pokud nic nenajde nebo nastane chyba.

type může být jeden z těchto: A, MX, NS, SOA, PTR, CNAME, or ANY. Implicitní je MX.

Host může být jak IP adresa (v "tečkové" notaci), tak název stroje.

Poznámka: Tato funkce není implementována na platformách Windows.

Viz také getmxrr(),
gethostbyaddr(),
gethostbyname(),
gethostbynamel(), a manuálovou stránku named(8).

Předcházející | Nahoru | Další
CII. Síťové funkce | Domů | closelog


closelog

(PHP 4, PHP 5)

closelog — Zavře spojení do systémového protokolu

Popis

bool closelog ( void )

closelog() zavře deskriptor použitý k zápisu do systémového protokolu. Použití closelog() je nepovinné.

Viz také define_syslog_variables(),
syslog() a
openlog().

Předcházející | Nahoru | Další
checkdnsrr | Domů | debugger_off


debugger_off

(No version information available, might be only in CVS)

debugger_off — Vypne vnitřní PHP debugger

Popis

int debugger_off ( void )

Vypne vnitřní PHP debugger. Na debuggeru stále probíhá vývoj.

Předcházející | Nahoru | Další
closelog | Domů | debugger_on


debugger_on

(No version information available, might be only in CVS)

debugger_on — Zapne vnitřní PHP debugger

Popis

int debugger_on ( string $address )

Zapne vnitřní PHP debugger s připojením na address. Na debuggeru stále probíhá vývoj.

Předcházející | Nahoru | Další
debugger_off | Domů | define_syslog_variables


define_syslog_variables

(PHP 4, PHP 5)

define_syslog_variables — Inicializuje všechny konstanty související se systémovým protokolem

Popis

void define_syslog_variables ( void )

Inicializuje všechny konstanty použité ve funkcích systémového protokolu.

Viz také openlog(),
syslog() a
closelog().

Předcházející | Nahoru | Další
debugger_on | Domů | dns_check_record


dns_check_record

(PHP 5)

dns_check_record — Alias pro checkdnsrr()

Popis

Tato funkce je aliasem: checkdnsrr().

Předcházející | Nahoru | Další
define_syslog_variables | Domů | dns_get_mx


dns_get_mx

(PHP 5)

dns_get_mx — Alias pro getmxrr()

Popis

Tato funkce je aliasem: getmxrr().

Předcházející | Nahoru | Další
dns_check_record | Domů | dns_get_record


dns_get_record

(PHP 5)

dns_get_record — Fetch DNS Resource Records associated with a hostname

Popis

array dns_get_record ( string $hostname [, int $type [, array &$authns, array &$addtl]] )

Fetch DNS Resource Records associated with the given hostname.

Seznam parametrů

hostname

hostname should be a valid DNS hostname such as "www.example.com". Reverse lookups can be generated using in-addr.arpa notation, but gethostbyaddr() is more suitable for the majority of reverse lookups.

Poznámka: Per DNS standards, email addresses are given in user.host format (for example: hostmaster.example.com as opposed to hostmaster@example.com), be sure to check this value and modify if necessary before using it with a functions such as mail().

type

By default, dns_get_record() will search for any resource records associated with hostname. To limit the query, specify the optional type parameter. May be any one of the following: DNS_A, DNS_CNAME, DNS_HINFO, DNS_MX, DNS_NS, DNS_PTR, DNS_SOA, DNS_TXT, DNS_AAAA, DNS_SRV, DNS_NAPTR, DNS_A6, DNS_ALL or DNS_ANY. The default is DNS_ANY.

Poznámka: Because of eccentricities in the performance of libresolv between platforms, DNS_ANY will not always return every record, the slower DNS_ALL will collect all records more reliably.

authns

Passed by reference and, if given, will be populated with Resource Records for the Authoritative Name Servers.

addtl

Passed by reference and, if given, will be populated with any Additional Records.

Návratové hodnoty

This function returns an array of associative arrays. Each associative array contains at minimum the following keys:

Tabulka 193. Basic DNS attributes

Attribute | Meaning
host | The record in the DNS namespace to which the rest of the associated data refers.
class | dns_get_record() only returns Internet class records and as such this parameter will always return IN.
type | String containing the record type. Additional attributes will also be contained in the resulting array dependant on the value of type. See table below.
ttl | Time To Live remaining for this record. This will not equal the record's original ttl, but will rather equal the original ttl minus whatever length of time has passed since the authoritative name server was queried.

Tabulka 194. Other keys in associative arrays dependant on 'type'

Type | Extra Columns
A | ip: An IPv4 addresses in dotted decimal notation.
MX | pri: Priority of mail exchanger. Lower numbers indicate greater priority. target: FQDN of the mail exchanger. See also dns_get_mx().
CNAME | target: FQDN of location in DNS namespace to which the record is aliased.
NS | target: FQDN of the name server which is authoritative for this hostname.
PTR | target: Location within the DNS namespace to which this record points.
TXT | txt: Arbitrary string data associated with this record.
HINFO | cpu: IANA number designating the CPU of the machine referenced by this record. os: IANA number designating the Operating System on the machine referenced by this record. See IANA's » Operating System Names for the meaning of these values.
SOA | mname: FQDN of the machine from which the resource records originated. rname: Email address of the administrative contain for this domain. serial: Serial # of this revision of the requested domain. refresh: Refresh interval (seconds) secondary name servers should use when updating remote copies of this domain. retry: Length of time (seconds) to wait after a failed refresh before making a second attempt. expire: Maximum length of time (seconds) a secondary DNS server should retain remote copies of the zone data without a successful refresh before discarding. minimum-ttl: Minimum length of time (seconds) a client can continue to use a DNS resolution before it should request a new resolution from the server. Can be overridden by individual resource records.
AAAA | ipv6: IPv6 address
A6(PHP >= 5.1.0) | masklen: Length (in bits) to inherit from the target specified by chain. ipv6: Address for this specific record to merge with chain. chain: Parent record to merge with ipv6 data.
SRV | pri: (Priority) lowest priorities should be used first. weight: Ranking to weight which of commonly prioritized targets should be chosen at random. target and port: hostname and port where the requested service can be found. For additional information see: » RFC 2782
NAPTR | order and pref: Equivalent to pri and weight above. flags, services, regex, and replacement: Parameters as defined by » RFC 2915.

Příklady

Příklad 1406. Using dns_get_record()

<?php
$result = dns_get_record("php.net");
print_r($result);
?>

Výše uvedený příklad vypíše něco jako:

Array
(
    [0] => Array
        (
            [host] => php.net
            [type] => MX
            [pri] => 5
            [target] => pair2.php.net
            [class] => IN
            [ttl] => 6765
        )

    [1] => Array
        (
            [host] => php.net
            [type] => A
            [ip] => 64.246.30.37
            [class] => IN
            [ttl] => 8125
        )

)

Příklad 1407. Using dns_get_record() and DNS_ANY

Since it's very common to want the IP address of a mail server once the MX record has been resolved, dns_get_record() also returns an array in addtl which contains associate records. authns is returned as well containing a list of authoritative name servers.

<?php
/* Request "ANY" record for php.net,
   and create $authns and $addtl arrays
   containing list of name servers and
   any additional records which go with
   them */
$result = dns_get_record("php.net", DNS_ANY, $authns, $addtl);
echo "Result = ";
print_r($result);
echo "Auth NS = ";
print_r($authns);
echo "Additional = ";
print_r($addtl);
?>

Výše uvedený příklad vypíše něco jako:

Result = Array
(
    [0] => Array
        (
            [host] => php.net
            [type] => MX
            [pri] => 5
            [target] => pair2.php.net
            [class] => IN
            [ttl] => 6765
        )

    [1] => Array
        (
            [host] => php.net
            [type] => A
            [ip] => 64.246.30.37
            [class] => IN
            [ttl] => 8125
        )

)
Auth NS = Array
(
    [0] => Array
        (
            [host] => php.net
            [type] => NS
            [target] => remote1.easydns.com
            [class] => IN
            [ttl] => 10722
        )

    [1] => Array
        (
            [host] => php.net
            [type] => NS
            [target] => remote2.easydns.com
            [class] => IN
            [ttl] => 10722
        )

    [2] => Array
        (
            [host] => php.net
            [type] => NS
            [target] => ns1.easydns.com
            [class] => IN
            [ttl] => 10722
        )

    [3] => Array
        (
            [host] => php.net
            [type] => NS
            [target] => ns2.easydns.com
            [class] => IN
            [ttl] => 10722
        )

)
Additional = Array
(
    [0] => Array
        (
            [host] => pair2.php.net
            [type] => A
            [ip] => 216.92.131.5
            [class] => IN
            [ttl] => 6766
        )

    [1] => Array
        (
            [host] => remote1.easydns.com
            [type] => A
            [ip] => 64.39.29.212
            [class] => IN
            [ttl] => 100384
        )

    [2] => Array
        (
            [host] => remote2.easydns.com
            [type] => A
            [ip] => 212.100.224.80
            [class] => IN
            [ttl] => 81241
        )

    [3] => Array
        (
            [host] => ns1.easydns.com
            [type] => A
            [ip] => 216.220.40.243
            [class] => IN
            [ttl] => 81241
        )

    [4] => Array
        (
            [host] => ns2.easydns.com
            [type] => A
            [ip] => 216.220.40.244
            [class] => IN
            [ttl] => 81241
        )

)

Poznámky

Poznámka: This function is not implemented on Windows platforms, nor does it (currently) work on *BSD systems (including Mac). Try the » PEAR class » Net_DNS.

Viz také

dns_get_mx()
dns_check_record()

Předcházející | Nahoru | Další
dns_get_mx | Domů | fsockopen


fsockopen

(PHP 4, PHP 5)

fsockopen — Otevře socketové spojení v internetové nebo unixové doméně.

Popis

resource fsockopen ( string $target [, int $port [, int &$errno [, string &$errstr [, float $timeout]]]] )

Iniciuje proudové spojení v internetové (AF_INET, za použití TCP nebo UDP) nebo unixové (AF_UNIX) doméně. Pro internetovou doménu otevře TCP kanál na stroj hostname na port port. hostname v takovém případě může být plně určené doménové jméno nebo IP adresa. Pro spojení UDP musíte explicitně specifikovat protokol předřazením 'udp://' před hostname. V unixové doméně se hostname použije jako cesta k socketu port se pak musí nastavit na 0. Nepovinný parametr timeout se může použít k nastavení time-outu pro systémové volání connect.

Od PHP 4.3.0, pokud jste PHP zkompilovali s podporou OpenSSL, můžete před hostname předřadit 'ssl://' nebo 'tls://' pro použití SSL nebo TSL spojení na vzdálený stroj přes TCP/IP.

fsockopen() vrací deskriptor souboru, který lze
použít s jinými souborovými funkcemi (např.
fgets(), fgetss(),
fputs(), fclose() a
feof()).

Pokud volání selže, vrací funkce FALSE, a pokud jsou přítomny nepovinné parametry errno a errstr, budou nastaveny na aktuální chybovou úroveň v systémovém volání connect(). Je-li vrácená hodnota v errno rovna 0 a funkce vrátila FALSE, znamená to, že chyba nastala před voláním connect(). Nejčastěji je to kvůli problému při inicializaci socketu. Uvědomte si, že argumenty errno a errstr se vždy předávají odkazem.

V závislosti na prostředí nemusí být k dispozici unixová doména nebo volitelný parametr timeout.

Socket se implicitně otevře v blokujícím režimu. Do neblokujícího režimu ho můžete přepnout použitím socket_set_blocking().

Příklad 1408. fsockopen() Příklad

<?php
$fp = fsockopen ("www.example.com", 80, $errno, $errstr, 30);
if (!$fp) {
    echo "$errstr ($errno)<br>\n";
} else {
    fputs ($fp, "GET / HTTP/1.0\r\nHost: www.example.com\r\n\r\n");
    while (!feof($fp)) {
        echo fgets ($fp,128);
    }
    fclose ($fp);
}
?>

Další (níže uvedený) příklad ukazuje, jak získat datum a čas z UDP služby "daytime" (port 13) na vašem vlastním počítači.

Příklad 1409. Použití UDP spojení

<?php
$fp = fsockopen("udp://127.0.0.1", 13, $errno, $errstr);
if (!$fp) {
    echo "CHYBA: $errno - $errstr<br>\n";
} else {
    fwrite($fp,"\n");
    echo fread($fp, 26);
    fclose($fp);
}
?>

Poznámka: Parametr timeout by zaveden v PHP 3.0.9 a podpora UDP v PHP 4.

Viz také pfsockopen(), socket_set_blocking(), socket_set_timeout(), fgets(), fgetss(), fputs(), fclose(), feof() a rozšíření Curl.

Předcházející | Nahoru | Další
dns_get_record | Domů | gethostbyaddr


gethostbyaddr

(PHP 4, PHP 5)

gethostbyaddr — Vrací internetové jméno počítače, odpovídající dané IP adrese

Popis

string gethostbyaddr ( string $ip_address )

Vrací internetové doménové jméno počítače specifikované pomocí ip_address. Vyskytne-li se chyba, vrací ip_address.

Viz také gethostbyname().

Předcházející | Nahoru | Další
fsockopen | Domů | gethostbyname


gethostbyname

(PHP 4, PHP 5)

gethostbyname — Vrací IP adresu odpovídající danému internetovému jménu počítače

Popis

string gethostbyname ( string $hostname )

Vrací IP adresu počítače v síti Internet specifikovaného pomocí hostname.

Viz také gethostbyaddr().

Předcházející | Nahoru | Další
gethostbyaddr | Domů | gethostbynamel


gethostbynamel

(PHP 4, PHP 5)

gethostbynamel — Vracé seznam IP adres odpovídajících danému internetovému jménu počítače

Popis

array gethostbynamel ( string $hostname )

Vrací seznam IP adres, které odpovídají počítači v síti Internet specifikovanému pomocí hostname.

Viz také gethostbyname(),
gethostbyaddr(),
checkdnsrr(), getmxrr()
a manuálovou stránku named(8).

Předcházející | Nahoru | Další
gethostbyname | Domů | getmxrr


getmxrr

(PHP 4, PHP 5)

getmxrr — Vrací MX záznamy odpovídající dané internetové jmenné adrese

Popis

bool getmxrr ( string $hostname, array &$mxhosts [, array &$weight] )

Prohledá DNS na MX záznamy odpovídající hodnotě hostname. Vrací TRUE, pokud najde nějaké záznamy; FALSE, nenajde-li nic nebo dojde k chybě.

Seznam MX záznamů je vrácen v poli mxhosts. Je-li specifikováno také pole weight, bude naplněno získanými informacemi o vahách jednotlivých Mail Exchangerů.

Viz také checkdnsrr(),
gethostbyname(),
gethostbynamel(),
gethostbyaddr() a manuálovou stránku
named(8).

Předcházející | Nahoru | Další
gethostbynamel | Domů | getprotobyname


getprotobyname

(PHP 4, PHP 5)

getprotobyname — Vrací číslo protokolu podle názvu tohoto protokolu

Popis

int getprotobyname ( string $name )

getprotobyname() vrací číslo protokolu podle jeho názvu (parametr name), jak je specifikováno v /etc/protocols.

Viz také: getprotobynumber().

Předcházející | Nahoru | Další
getmxrr | Domů | getprotobynumber


getprotobynumber

(PHP 4, PHP 5)

getprotobynumber — Vrací název protokolu podle čísla tohoto protokolu

Popis

string getprotobynumber ( int $number )

getprotobynumber() vrací název protokolu podle jeho čísla (parametr number), jak je specifikováno v /etc/protocols.

Viz také: getprotobyname().

Předcházející | Nahoru | Další
getprotobyname | Domů | getservbyname


getservbyname

(PHP 4, PHP 5)

getservbyname — Vrací číslo portu podle internetové služby a protokolu

Popis

int getservbyname ( string $service, string $protocol )

getservbyname() vrací internetový port, odpovídající službě service pro specifikovaný protokol (protocol). Vychází se ze souboru /etc/services, protocol je buď "tcp", nebo "udp" (malými písmeny).

Viz také: getservbyport().

Předcházející | Nahoru | Další
getprotobynumber | Domů | getservbyport


getservbyport

(PHP 4, PHP 5)

getservbyport — Vrací internetovou službu odpovídající specifikovanému portu a protokolu

Popis

string getservbyport ( int $port, string $protocol )

getservbyport() vrací internetovou službu podle parametrů port a protocol, jak je specifikována v /etc/services. protocol je "tcp" nebo "udp" (malými písmeny).

Viz také: getservbyname().

Předcházející | Nahoru | Další
getservbyname | Domů | header


inet_ntop

(PHP 5 >= 5.1.0)

inet_ntop — Converts a packed internet address to a human readable representation

Popis

string inet_ntop ( string $in_addr )

This function converts a 32bit IPv4, or 128bit IPv6 address (if PHP was built with IPv6 support enabled) into an address family appropriate string representation.

Seznam parametrů

in_addr

A 32bit IPv4, or 128bit IPv6 address.

Návratové hodnoty

Returns a string representation of the address or FALSE on failure.

Příklady

Příklad 1411. inet_ntop() Example

<?php
$packed = chr(127) . chr(0) . chr(0) . chr(1);
$expanded = inet_ntop($packed);

/* Outputs: 127.0.0.1 */
echo $expanded;

$packed = str_repeat(chr(0), 15) . chr(1);
$expanded = inet_ntop($packed);

/* Outputs: ::1 */
echo $expanded;
?>

Poznámky

Poznámka: Tato funkce není implementována na platformách Windows.

Viz také

long2ip()
ip2long()
inet_pton()

Předcházející | Nahoru | Další
headers_sent | Domů | inet_pton


inet_pton

(PHP 5 >= 5.1.0)

inet_pton — Converts a human readable IP address to its packed in_addr representation

Popis

string inet_pton ( string $address )

This function converts a human readable IPv4 or IPv6 address (if PHP was built with IPv6 support enabled) into an address family appropriate 32bit or 128bit binary structure.

Seznam parametrů

address

A human readable IPv4 or IPv6 address.

Návratové hodnoty

Returns the in_addr representation of the given address

Příklady

Příklad 1412. inet_pton() Example

<?php
 $in_addr = inet_pton('127.0.0.1');

 $in6_addr = inet_pton('::1');

 ?>

Poznámky

Poznámka: Tato funkce není implementována na platformách Windows.

Viz také

ip2long()
long2ip()
inet_ntop()

Předcházející | Nahoru | Další
inet_ntop | Domů | ip2long


ip2long

(PHP 4, PHP 5)

ip2long — Převede řetězec obsahující internetovou (IPv4) adresu v tečkové notaci na odpovídající adresu.

Popis

int ip2long ( string $ip_address )

Funkce ip2long() generuje síťovou IPv4 adresu ze standardního internetového formátu (čísla oddělená tečkami).

Příklad 1413. ip2long() Příklad

<?php
$ip = gethostbyname("www.example.com");
$out = "Následující URL jsou ekvivalentní:<br>\n";
$out .= "http://www.example.com/, http://".$ip."/, and http://".sprintf("%u",ip2long($ip))."/<br>\n";
echo $out;
?>

Poznámka: Protože celé číslo (integer) v PHP obsahuje znaménko a mnoho IP adres vyjde jako záporné, musíte k získání správné (nezáporné) hodnoty použít funkce sprintf() nebo printf() vždy s formátovačem %u.

Tento druhý příklad ukazuje, jak tiskout zkonvertovanou adresu funkcí printf():

Příklad 1414. Zobrazení IP adresy

<?php
$ip = gethostbyname("www.example.com");
printf("%u\n", ip2long($ip));
echo $out;
?>

Viz také: long2ip()

Předcházející | Nahoru | Další
inet_pton | Domů | long2ip


long2ip

(PHP 4, PHP 5)

long2ip — Převede internetovou (IPv4) adresu na řetězec ve standardním tečkovém formátu

Popis

string long2ip ( int $proper_address )

Funkce long2ip() generuje internetovou adresu v tečkovém formátu (např. aaa.bbb.ccc.ddd) z číselné reprezentace adresy.

Viz také: ip2long()

Předcházející | Nahoru | Další
ip2long | Domů | openlog


openlog

(PHP 4, PHP 5)

openlog — Otevře spojení do systémového protokolu

Popis

bool openlog ( string $ident, int $option, int $facility )

openlog() otevře pro program spojení do systémového protokolu. Do každé zprávy se přidá řetězec ident. Hodnoty pro option a facility jsou uvedeny níže. Parametr option se používá k určení, které volby budou při generování zprávy použity. Argument facility specifikuje, jaký typ programu zaznamenává zprávu. To umožňuje specifikovat (v konfiguraci systémového protokolu na vašem počítači), jak budou zprávy přicházející z různých zdrojů obsluhovány. Použití openlog() není povinné. Volá se automaticky ze syslog() v případě potřeby; v takovém případě bude ident implicitně FALSE.

Tabulka 195. openlog() Volby

Konstanta | Popis
LOG_CONS | při chybě během posílání dat do protokolu zapisuj přímo na systémovou konzoli
LOG_NDELAY | ihned otevři spojení do protokolu
LOG_ODELAY | (implicitní) otevři spojení až v okamžiku zápisu první zprávy
LOG_PERROR | tiskni zprávy také na standardní chybový výstup (stderr)
LOG_PID | do každé zprávy přidej PID

Můžete použít jednu nebo více voleb. V případě použití více voleb je musíte spojit pomocí OR, tedy např. "otevři spojení ihned, zapisuj na konzoli a přidej PID" bude vypadat: LOG_CONS | LOG_NDELAY | LOG_PID

Tabulka 196. openlog() Charaktery

Konstanta | Popis
LOG_AUTH | bezpečnostní/autorizační zprávy (použijte raději LOG_AUTHPRIV na systémech, kde je tato konstanta definována)
LOG_AUTHPRIV | bezpečnostní/autorizační zprávy (soukromé)
LOG_CRON | časový démon (cron a at)
LOG_DAEMON | ostatní démoni systému
LOG_KERN | zprávy jádra
LOG_LOCAL0 ... LOG_LOCAL7 | vyhrazeno pro místní použití
LOG_LPR | subsystém tiskárny
LOG_MAIL | poštovní subsystém
LOG_NEWS | subsystém USENET news
LOG_SYSLOG | zprávy generované vnitřně démonem syslogd
LOG_USER | generické uživatelské zprávy
LOG_UUCP | subsystém UUCP

Viz také define_syslog_variables(),
syslog() a
closelog().

Předcházející | Nahoru | Další
long2ip | Domů | pfsockopen


pfsockopen

(PHP 4, PHP 5)

pfsockopen — Otevře perzistentní (přetrvávající) socketové spojení v internetové nebo unixové doméně

Popis

resource pfsockopen ( string $hostname [, int $port [, int &$errno [, string &$errstr [, float $timeout]]]] )

Tato funkce se chová naprosto stejně jako fsockopen(), s tím rozdílem, že spojení se po skončení skriptu neuzavře. Je to perzistentní verze fsockopen().

Předcházející | Nahoru | Další
openlog | Domů | setcookie


socket_get_status

(PHP 4, PHP 5)

socket_get_status — Vrací informace o existujícím socketovém proudu

Popis

array socket_get_status ( resource $socketstream )

Vrací informace o existujícím socketovém streamu. Tato funkce pracuje pouze na socketu vytvořeném pomocí fsockopen(), pfsockopen() a síťových socketech vrácených funkcí fopen() s URL jako parametrem. NEFUNGUJE se sockety ze Socketového rozšíření. Ve výsledkovém poli v současné době vrací čtyři položky:

  • timed_out (bool) - Vypršel časový limit pro čekání na data

  • blocked (bool) - Socket byl zablokován

  • eof (bool) - Indikuje konec souboru (EOF)

  • unread_bytes (int) - Počet bytů zbývajících v bufferu socketu

Viz také: Socketové rozšíření.

Předcházející | Nahoru | Další
setrawcookie | Domů | socket_set_blocking


socket_set_blocking

(PHP 4, PHP 5)

socket_set_blocking — Nastavuje blokující/neblokující režim socketu

Popis

int socket_set_blocking ( int $socket descriptor, int $mode )

Pokud má mode hodnotu FALSE, příslušný deskriptor socketu se přepne do neblokujícího režimu; je-li TRUE, přepne se do blokujícího režimu. To má vliv na volání jako je fgets(), která čtou ze socketu. V neblokujícím režimu volání funkce fgets() vždy předává řízení zpět, zatímco v blokujícím režimu bude čekat na to, až budou na socketu dostupná data.

Tato funkce se dříve jmenovala set_socket_blocking(), ale tento název je nyní zavržený.

Předcházející | Nahoru | Další
socket_get_status | Domů | socket_set_timeout


socket_set_timeout

(PHP 4, PHP 5)

socket_set_timeout — Nastaví časový limit (timeout) socketu

Popis

bool socket_set_timeout ( int $socket descriptor, int $seconds, int $microseconds )

Nastavuje velikost časového limitu socketu daného hodnotou socket descriptor, ve formě součtu sekund (seconds) a mikrosekund (microseconds).

Příklad 1417. socket_set_timeout() Příklad

<?php
$fp = fsockopen("www.example.com", 80);
if(!$fp) {
    echo "Nelze otevřít\n";
} else {
    fputs($fp,"GET / HTTP/1.0\n\n");
    $start = time();
    socket_set_timeout($fp, 2);
    $res = fread($fp, 2000);
    var_dump(socket_get_status($fp));
    fclose($fp);
    print $res;
}
?>

Tato funkce se dříve jmenovala set_socket_timeout(), ale tento název je nyní zavržený.

Viz také: fsockopen() a fopen().

Předcházející | Nahoru | Další
socket_set_blocking | Domů | syslog


syslog

(PHP 4, PHP 5)

syslog — Vygeneruje zprávu do systémového protokolu

Popis

bool syslog ( int $priority, string $message )

syslog() vygeneruje zprávu do protokolu, která se distribuuje prostřednictvím démona systémového protokolu. priority představuje kombinaci charakteru a úrovně zprávy; hodnoty popisuje následující sekce. Zbývající argument je zpráva, která se má odeslat. Dva znaky ve zprávě (%m) se však nahradí řetězcem chybové zprávy (strerror) odpovídající aktuální hodnotě errno.

Tabulka 197. syslog() Priority (v klesajícím pořádku)

Konstanta | Popis
LOG_EMERG | systém je nepoužitelný
LOG_ALERT | je nutný okamžitý zásah
LOG_CRIT | kritická situace
LOG_ERR | chyba
LOG_WARNING | varování
LOG_NOTICE | normální, avšak významná, zpráva
LOG_INFO | informativní zpráva
LOG_DEBUG | ladicí zpráva

Příklad 1418. Použití syslog()

<?php
define_syslog_variables();
// otevře syslog, vloží ID procesu a odešle také na standardní chybový
// výstup; použije uživatelsky definovaný protokolovací mechanismus
openlog("myScripLog", LOG_PID | LOG_PERROR, LOG_LOCAL0);

// nějaký kód

if (authorized_client()) {
    // něco udělej
} else {
    // neautorizovaný klient!
    // zaznamenej pokus o přístup
    $access = date("Y/m/d H:i:s");
    syslog(LOG_WARNING,"Neautorizovaný klient: $access $REMOTE_ADDR ($HTTP_USER_AGENT)");
}

closelog();
?>

Více informací o nastavení uživatelské obsluhy protokolování -- viz unixovou manuálovou stránku syslog.conf(5). Více informací o možnostech a volbách mechanismu syslog najdete (na unixových strojích) v manuálových stránkách pro syslog(3).

Na Windows NT je služba syslog emulována pomocí služby Event Log.

Viz také define_syslog_variables(),
openlog() a
closelog().

Předcházející | Nahoru | Další
socket_set_timeout | Domů | CIII. Newt Functions


Ncurses Terminal Screen Control Functions

Předcházející VI. Reference funkcí Další

CI. Ncurses Terminal Screen Control Functions

Úvod

ncurses (new curses) is a free software emulation of curses in System V Rel 4.0 (and above). It uses terminfo format, supports pads, colors, multiple highlights, form characters and function key mapping. Because of the interactive nature of this library, it will be of little use for writing Web applications, but may be useful when writing scripts meant using PHP from the command line.

Varování

Toto rozšíření je EXPERIMENTÁLNÍ. Chování tohoto rozšíření, názvy funkcí a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může bez ohlášení změnit. Berte to v úvahu a používejte tento modul na vlastní nebezpečí.

Ncurses is available for the following platforms:

  • AIX

  • BeOS

  • Cygwin

  • Digital Unix (aka OSF1)

  • FreeBSD

  • GNU/Linux

  • HPUX

  • IRIX

  • OS/2

  • SCO OpenServer

  • Solaris

  • SunOS

Poznámka: Toto rozšíření bylo přesunuto do repozitáře PECL a již nebude součástí balíku PHP.6.0.0

Požadavky

You need the ncurses libraries and headerfiles. Download the latest version from the » ftp://ftp.gnu.org/pub/gnu/ncurses/ or from an other GNU-Mirror.

Instalace

To get these functions to work, you have to compile the CGI or CLI version of PHP with --with-ncurses[=DIR].

Konfigurace běhu

Toto rozšíření nemá definováno žádné konfigurační direktivy.

Typy prostředků

This extension defines window, panel and pad resources.

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

Error codes

On error ncurses functions return NCURSES_ERR.

Colors

Tabulka 185. ncurses color constants

constant | meaning
NCURSES_COLOR_BLACK | no color (black)
NCURSES_COLOR_WHITE | white
NCURSES_COLOR_RED | red - supported when terminal is in color mode
NCURSES_COLOR_GREEN | green - supported when terminal is in color mode
NCURSES_COLOR_YELLOW | yellow - supported when terminal is in color mode
NCURSES_COLOR_BLUE | blue - supported when terminal is in color mode
NCURSES_COLOR_CYAN | cyan - supported when terminal is in color mode
NCURSES_COLOR_MAGENTA | magenta - supported when terminal is in color mode

Keys

Tabulka 186. ncurses key constants

constant | meaning
NCURSES_KEY_F0 - NCURSES_KEY_F64 | function keys F1 - F64
NCURSES_KEY_DOWN | down arrow
NCURSES_KEY_UP | up arrow
NCURSES_KEY_LEFT | left arrow
NCURSES_KEY_RIGHT | right arrow
NCURSES_KEY_HOME | home key (upward+left arrow)
NCURSES_KEY_BACKSPACE | backspace
NCURSES_KEY_DL | delete line
NCURSES_KEY_IL | insert line
NCURSES_KEY_DC | delete character
NCURSES_KEY_IC | insert char or enter insert mode
NCURSES_KEY_EIC | exit insert char mode
NCURSES_KEY_CLEAR | clear screen
NCURSES_KEY_EOS | clear to end of screen
NCURSES_KEY_EOL | clear to end of line
NCURSES_KEY_SF | scroll one line forward
NCURSES_KEY_SR | scroll one line backward
NCURSES_KEY_NPAGE | next page
NCURSES_KEY_PPAGE | previous page
NCURSES_KEY_STAB | set tab
NCURSES_KEY_CTAB | clear tab
NCURSES_KEY_CATAB | clear all tabs
NCURSES_KEY_SRESET | soft (partial) reset
NCURSES_KEY_RESET | reset or hard reset
NCURSES_KEY_PRINT | print
NCURSES_KEY_LL | lower left
NCURSES_KEY_A1 | upper left of keypad
NCURSES_KEY_A3 | upper right of keypad
NCURSES_KEY_B2 | center of keypad
NCURSES_KEY_C1 | lower left of keypad
NCURSES_KEY_C3 | lower right of keypad
NCURSES_KEY_BTAB | back tab
NCURSES_KEY_BEG | beginning
NCURSES_KEY_CANCEL | cancel
NCURSES_KEY_CLOSE | close
NCURSES_KEY_COMMAND | cmd (command)
NCURSES_KEY_COPY | copy
NCURSES_KEY_CREATE | create
NCURSES_KEY_END | end
NCURSES_KEY_EXIT | exit
NCURSES_KEY_FIND | find
NCURSES_KEY_HELP | help
NCURSES_KEY_MARK | mark
NCURSES_KEY_MESSAGE | message
NCURSES_KEY_MOVE | move
NCURSES_KEY_NEXT | next
NCURSES_KEY_OPEN | open
NCURSES_KEY_OPTIONS | options
NCURSES_KEY_PREVIOUS | previous
NCURSES_KEY_REDO | redo
NCURSES_KEY_REFERENCE | ref (reference)
NCURSES_KEY_REFRESH | refresh
NCURSES_KEY_REPLACE | replace
NCURSES_KEY_RESTART | restart
NCURSES_KEY_RESUME | resume
NCURSES_KEY_SAVE | save
NCURSES_KEY_SBEG | shiftet beg (beginning)
NCURSES_KEY_SCANCEL | shifted cancel
NCURSES_KEY_SCOMMAND | shifted command
NCURSES_KEY_SCOPY | shifted copy
NCURSES_KEY_SCREATE | shifted create
NCURSES_KEY_SDC | shifted delete char
NCURSES_KEY_SDL | shifted delete line
NCURSES_KEY_SELECT | select
NCURSES_KEY_SEND | shifted end
NCURSES_KEY_SEOL | shifted end of line
NCURSES_KEY_SEXIT | shifted exit
NCURSES_KEY_SFIND | shifted find
NCURSES_KEY_SHELP | shifted help
NCURSES_KEY_SHOME | shifted home
NCURSES_KEY_SIC | shifted input
NCURSES_KEY_SLEFT | shifted left arrow
NCURSES_KEY_SMESSAGE | shifted message
NCURSES_KEY_SMOVE | shifted move
NCURSES_KEY_SNEXT | shifted next
NCURSES_KEY_SOPTIONS | shifted options
NCURSES_KEY_SPREVIOUS | shifted previous
NCURSES_KEY_SPRINT | shifted print
NCURSES_KEY_SREDO | shifted redo
NCURSES_KEY_SREPLACE | shifted replace
NCURSES_KEY_SRIGHT | shifted right arrow
NCURSES_KEY_SRSUME | shifted resume
NCURSES_KEY_SSAVE | shifted save
NCURSES_KEY_SSUSPEND | shifted suspend
NCURSES_KEY_UNDO | undo
NCURSES_KEY_MOUSE | mouse event has occurred
NCURSES_KEY_MAX | maximum key value

Mouse

Tabulka 187. mouse constants

Constant | meaning
NCURSES_BUTTON1_RELEASED - NCURSES_BUTTON4_RELEASED | button (1-4) released
NCURSES_BUTTON1_PRESSED - NCURSES_BUTTON4_PRESSED | button (1-4) pressed
NCURSES_BUTTON1_CLICKED - NCURSES_BUTTON4_CLICKED | button (1-4) clicked
NCURSES_BUTTON1_DOUBLE_CLICKED - NCURSES_BUTTON4_DOUBLE_CLICKED | button (1-4) double clicked
NCURSES_BUTTON1_TRIPLE_CLICKED - NCURSES_BUTTON4_TRIPLE_CLICKED | button (1-4) triple clicked
NCURSES_BUTTON_CTRL | ctrl pressed during click
NCURSES_BUTTON_SHIFT | shift pressed during click
NCURSES_BUTTON_ALT | alt pressed during click
NCURSES_ALL_MOUSE_EVENTS | report all mouse events
NCURSES_REPORT_MOUSE_POSITION | report mouse position

Obsah

ncurses_addch — Add character at current position and advance cursor
ncurses_addchnstr — Add attributed string with specified length at current position
ncurses_addchstr — Add attributed string at current position
ncurses_addnstr — Add string with specified length at current position
ncurses_addstr — Output text at current position
ncurses_assume_default_colors — Define default colors for color 0
ncurses_attroff — Turn off the given attributes
ncurses_attron — Turn on the given attributes
ncurses_attrset — Set given attributes
ncurses_baudrate — Returns baudrate of terminal
ncurses_beep — Let the terminal beep
ncurses_bkgd — Set background property for terminal screen
ncurses_bkgdset — Control screen background
ncurses_border — Draw a border around the screen using attributed characters
ncurses_bottom_panel — Moves a visible panel to the bottom of the stack
ncurses_can_change_color — Check if we can change terminals colors
ncurses_cbreak — Switch of input buffering
ncurses_clear — Clear screen
ncurses_clrtobot — Clear screen from current position to bottom
ncurses_clrtoeol — Clear screen from current position to end of line
ncurses_color_content — Gets the RGB value for color
ncurses_color_set — Set fore- and background color
ncurses_curs_set — Set cursor state
ncurses_def_prog_mode — Saves terminals (program) mode
ncurses_def_shell_mode — Saves terminals (shell) mode
ncurses_define_key — Define a keycode
ncurses_del_panel — Remove panel from the stack and delete it (but not the associated window)
ncurses_delay_output — Delay output on terminal using padding characters
ncurses_delch — Delete character at current position, move rest of line left
ncurses_deleteln — Delete line at current position, move rest of screen up
ncurses_delwin — Delete a ncurses window
ncurses_doupdate — Write all prepared refreshes to terminal
ncurses_echo — Activate keyboard input echo
ncurses_echochar — Single character output including refresh
ncurses_end — Stop using ncurses, clean up the screen
ncurses_erase — Erase terminal screen
ncurses_erasechar — Returns current erase character
ncurses_filter — Set LINES for iniscr() and newterm() to 1
ncurses_flash — Flash terminal screen (visual bell)
ncurses_flushinp — Flush keyboard input buffer
ncurses_getch — Read a character from keyboard
ncurses_getmaxyx — Returns the size of a window
ncurses_getmouse — Reads mouse event
ncurses_getyx — Returns the current cursor position for a window
ncurses_halfdelay — Put terminal into halfdelay mode
ncurses_has_colors — Check if terminal has colors
ncurses_has_ic — Check for insert- and delete-capabilities
ncurses_has_il — Check for line insert- and delete-capabilities
ncurses_has_key — Check for presence of a function key on terminal keyboard
ncurses_hide_panel — Remove panel from the stack, making it invisible
ncurses_hline — Draw a horizontal line at current position using an attributed character and max. n characters long
ncurses_inch — Get character and attribute at current position
ncurses_init_color — Set new RGB value for color
ncurses_init_pair — Allocate a color pair
ncurses_init — Initialize ncurses
ncurses_insch — Insert character moving rest of line including character at current position
ncurses_insdelln — Insert lines before current line scrolling down (negative numbers delete and scroll up)
ncurses_insertln — Insert a line, move rest of screen down
ncurses_insstr — Insert string at current position, moving rest of line right
ncurses_instr — Reads string from terminal screen
ncurses_isendwin — Ncurses is in endwin mode, normal screen output may be performed
ncurses_keyok — Enable or disable a keycode
ncurses_keypad — Turns keypad on or off
ncurses_killchar — Returns current line kill character
ncurses_longname — Returns terminals description
ncurses_meta — Enables/Disable 8-bit meta key information
ncurses_mouse_trafo — Transforms coordinates
ncurses_mouseinterval — Set timeout for mouse button clicks
ncurses_mousemask — Sets mouse options
ncurses_move_panel — Moves a panel so that its upper-left corner is at [startx, starty]
ncurses_move — Move output position
ncurses_mvaddch — Move current position and add character
ncurses_mvaddchnstr — Move position and add attributed string with specified length
ncurses_mvaddchstr — Move position and add attributed string
ncurses_mvaddnstr — Move position and add string with specified length
ncurses_mvaddstr — Move position and add string
ncurses_mvcur — Move cursor immediately
ncurses_mvdelch — Move position and delete character, shift rest of line left
ncurses_mvgetch — Move position and get character at new position
ncurses_mvhline — Set new position and draw a horizontal line using an attributed character and max. n characters long
ncurses_mvinch — Move position and get attributed character at new position
ncurses_mvvline — Set new position and draw a vertical line using an attributed character and max. n characters long
ncurses_mvwaddstr — Add string at new position in window
ncurses_napms — Sleep
ncurses_new_panel — Create a new panel and associate it with window
ncurses_newpad — Creates a new pad (window)
ncurses_newwin — Create a new window
ncurses_nl — Translate newline and carriage return / line feed
ncurses_nocbreak — Switch terminal to cooked mode
ncurses_noecho — Switch off keyboard input echo
ncurses_nonl — Do not translate newline and carriage return / line feed
ncurses_noqiflush — Do not flush on signal characters
ncurses_noraw — Switch terminal out of raw mode
ncurses_pair_content — Gets the RGB value for color
ncurses_panel_above — Returns the panel above panel
ncurses_panel_below — Returns the panel below panel
ncurses_panel_window — Returns the window associated with panel
ncurses_pnoutrefresh — Copies a region from a pad into the virtual screen
ncurses_prefresh — Copies a region from a pad into the virtual screen
ncurses_putp — Apply padding information to the string and output it
ncurses_qiflush — Flush on signal characters
ncurses_raw — Switch terminal into raw mode
ncurses_refresh — Refresh screen
ncurses_replace_panel — Replaces the window associated with panel
ncurses_reset_prog_mode — Resets the prog mode saved by def_prog_mode
ncurses_reset_shell_mode — Resets the shell mode saved by def_shell_mode
ncurses_resetty — Restores saved terminal state
ncurses_savetty — Saves terminal state
ncurses_scr_dump — Dump screen content to file
ncurses_scr_init — Initialize screen from file dump
ncurses_scr_restore — Restore screen from file dump
ncurses_scr_set — Inherit screen from file dump
ncurses_scrl — Scroll window content up or down without changing current position
ncurses_show_panel — Places an invisible panel on top of the stack, making it visible
ncurses_slk_attr — Returns current soft label key attribute
ncurses_slk_attroff — Turn off the given attributes for soft function-key labels
ncurses_slk_attron — Turn on the given attributes for soft function-key labels
ncurses_slk_attrset — Set given attributes for soft function-key labels
ncurses_slk_clear — Clears soft labels from screen
ncurses_slk_color — Sets color for soft label keys
ncurses_slk_init — Initializes soft label key functions
ncurses_slk_noutrefresh — Copies soft label keys to virtual screen
ncurses_slk_refresh — Copies soft label keys to screen
ncurses_slk_restore — Restores soft label keys
ncurses_slk_set — Sets function key labels
ncurses_slk_touch — Forces output when ncurses_slk_noutrefresh is performed
ncurses_standend — Stop using 'standout' attribute
ncurses_standout — Start using 'standout' attribute
ncurses_start_color — Start using colors
ncurses_termattrs — Returns a logical OR of all attribute flags supported by terminal
ncurses_termname — Returns terminals (short)-name
ncurses_timeout — Set timeout for special key sequences
ncurses_top_panel — Moves a visible panel to the top of the stack
ncurses_typeahead — Specify different filedescriptor for typeahead checking
ncurses_ungetch — Put a character back into the input stream
ncurses_ungetmouse — Pushes mouse event to queue
ncurses_update_panels — Refreshes the virtual screen to reflect the relations between panels in the stack
ncurses_use_default_colors — Assign terminal default colors to color id -1
ncurses_use_env — Control use of environment information about terminal size
ncurses_use_extended_names — Control use of extended names in terminfo descriptions
ncurses_vidattr — Display the string on the terminal in the video attribute mode
ncurses_vline — Draw a vertical line at current position using an attributed character and max. n characters long
ncurses_waddch — Adds character at current position in a window and advance cursor
ncurses_waddstr — Outputs text at current postion in window
ncurses_wattroff — Turns off attributes for a window
ncurses_wattron — Turns on attributes for a window
ncurses_wattrset — Set the attributes for a window
ncurses_wborder — Draws a border around the window using attributed characters
ncurses_wclear — Clears window
ncurses_wcolor_set — Sets windows color pairings
ncurses_werase — Erase window contents
ncurses_wgetch — Reads a character from keyboard (window)
ncurses_whline — Draws a horizontal line in a window at current position using an attributed character and max. n characters long
ncurses_wmouse_trafo — Transforms window/stdscr coordinates
ncurses_wmove — Moves windows output position
ncurses_wnoutrefresh — Copies window to virtual screen
ncurses_wrefresh — Refresh window on terminal screen
ncurses_wstandend — End standout mode for a window
ncurses_wstandout — Enter standout mode for a window
ncurses_wvline — Draws a vertical line in a window at current position using an attributed character and max. n characters long
Předcházející | Nahoru | Další
mysqli_warning_count | Domů | ncurses_addch


ncurses_addch

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_addch — Add character at current position and advance cursor

Popis

int ncurses_addch ( int $ch )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

ch

Předcházející | Nahoru | Další
CI. Ncurses Terminal Screen Control Functions | Domů | ncurses_addchnstr


ncurses_addchnstr

(PHP 4 >= 4.2.0, PHP 5, PECL ncurses:1.0.0)

ncurses_addchnstr — Add attributed string with specified length at current position

Popis

int ncurses_addchnstr ( string $s, int $n )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

s

n

Předcházející | Nahoru | Další
ncurses_addch | Domů | ncurses_addchstr


ncurses_addchstr

(PHP 4 >= 4.2.0, PHP 5, PECL ncurses:1.0.0)

ncurses_addchstr — Add attributed string at current position

Popis

int ncurses_addchstr ( string $s )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

s

Předcházející | Nahoru | Další
ncurses_addchnstr | Domů | ncurses_addnstr


ncurses_addnstr

(PHP 4 >= 4.2.0, PHP 5, PECL ncurses:1.0.0)

ncurses_addnstr — Add string with specified length at current position

Popis

int ncurses_addnstr ( string $s, int $n )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

s

n

Předcházející | Nahoru | Další
ncurses_addchstr | Domů | ncurses_addstr


ncurses_addstr

(PHP 4 >= 4.2.0, PHP 5, PECL ncurses:1.0.0)

ncurses_addstr — Output text at current position

Popis

int ncurses_addstr ( string $text )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

text

Předcházející | Nahoru | Další
ncurses_addnstr | Domů | ncurses_assume_default_colors


ncurses_assume_default_colors

(PHP 4 >= 4.2.0, PHP 5, PECL ncurses:1.0.0)

ncurses_assume_default_colors — Define default colors for color 0

Popis

int ncurses_assume_default_colors ( int $fg, int $bg )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

fg

bg

Předcházející | Nahoru | Další
ncurses_addstr | Domů | ncurses_attroff


ncurses_attroff

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_attroff — Turn off the given attributes

Popis

int ncurses_attroff ( int $attributes )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

attributes

Předcházející | Nahoru | Další
ncurses_assume_default_colors | Domů | ncurses_attron


ncurses_attron

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_attron — Turn on the given attributes

Popis

int ncurses_attron ( int $attributes )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

attributes

Předcházející | Nahoru | Další
ncurses_attroff | Domů | ncurses_attrset


ncurses_attrset

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_attrset — Set given attributes

Popis

int ncurses_attrset ( int $attributes )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

attributes

Předcházející | Nahoru | Další
ncurses_attron | Domů | ncurses_baudrate


ncurses_baudrate

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_baudrate — Returns baudrate of terminal

Popis

int ncurses_baudrate ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
ncurses_attrset | Domů | ncurses_beep


ncurses_beep

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_beep — Let the terminal beep

Popis

int ncurses_beep ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

ncurses_beep() sends an audible alert (bell) and if its not possible flashes the screen.

Viz také

ncurses_flash()

Předcházející | Nahoru | Další
ncurses_baudrate | Domů | ncurses_bkgd


ncurses_bkgd

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_bkgd — Set background property for terminal screen

Popis

int ncurses_bkgd ( int $attrchar )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

attrchar

Předcházející | Nahoru | Další
ncurses_beep | Domů | ncurses_bkgdset


ncurses_bkgdset

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_bkgdset — Control screen background

Popis

void ncurses_bkgdset ( int $attrchar )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

attrchar

Předcházející | Nahoru | Další
ncurses_bkgd | Domů | ncurses_border


ncurses_border

(PHP 4 >= 4.2.0, PHP 5, PECL ncurses:1.0.0)

ncurses_border — Draw a border around the screen using attributed characters

Popis

int ncurses_border ( int $left, int $right, int $top, int $bottom, int $tl_corner, int $tr_corner, int $bl_corner, int $br_corner )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Draws the specified lines and corners around the main window.

Use ncurses_wborder() for borders around subwindows!

Seznam parametrů

Every parameter expects 0 to draw a line or 1 to skip it.

left

right

top

bottom

tl_corner

Top left corner

tr_corner

Top right corner

bl_corner

Bottom left corner

br_corner

Bottom right corner

Viz také

ncurses_wborder()

Předcházející | Nahoru | Další
ncurses_bkgdset | Domů | ncurses_bottom_panel


ncurses_bottom_panel

(PHP 4 >= 4.3.0, PHP 5, PECL ncurses:1.0.0)

ncurses_bottom_panel — Moves a visible panel to the bottom of the stack

Popis

int ncurses_bottom_panel ( resource $panel )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

panel

Předcházející | Nahoru | Další
ncurses_border | Domů | ncurses_can_change_color


ncurses_can_change_color

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_can_change_color — Check if we can change terminals colors

Popis

bool ncurses_can_change_color ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Tells whether the terminal has color capabilities and whether the programmer can change the colors.

Návratové hodnoty

Return TRUE if the terminal has color capabilities and you can change the colors, FALSE otherwise.

Předcházející | Nahoru | Další
ncurses_bottom_panel | Domů | ncurses_cbreak


ncurses_cbreak

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_cbreak — Switch of input buffering

Popis

bool ncurses_cbreak ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Disables line buffering and character processing (interrupt and flow control characters are unaffected), making characters typed by the user immediately available to the program.

Návratové hodnoty

Returns TRUE or NCURSES_ERR if any error occurred.

Viz také

ncurses_nocbreak()

Předcházející | Nahoru | Další
ncurses_can_change_color | Domů | ncurses_clear


ncurses_clear

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_clear — Clear screen

Popis

bool ncurses_clear ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Clears the screen completely without setting blanks.

Note: ncurses_clear() clears the screen without setting blanks, which have the current background rendition. To clear screen with blanks, use ncurses_erase().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ncurses_erase()

Předcházející | Nahoru | Další
ncurses_cbreak | Domů | ncurses_clrtobot


ncurses_clrtobot

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_clrtobot — Clear screen from current position to bottom

Popis

bool ncurses_clrtobot ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Erases all lines from cursor to end of screen and creates blanks. Blanks created by ncurses_clrtobot() have the current background rendition.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ncurses_clear()
ncurses_clrtoeol()

Předcházející | Nahoru | Další
ncurses_clear | Domů | ncurses_clrtoeol


ncurses_clrtoeol

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_clrtoeol — Clear screen from current position to end of line

Popis

bool ncurses_clrtoeol ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Erases the current line from cursor position to the end. Blanks created by ncurses_clrtoeol() have the current background rendition.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ncurses_clear()
ncurses_clrtobot()

Předcházející | Nahoru | Další
ncurses_clrtobot | Domů | ncurses_color_content


ncurses_color_content

(PHP 4 >= 4.3.0, PHP 5, PECL ncurses:1.0.0)

ncurses_color_content — Gets the RGB value for color

Popis

int ncurses_color_content ( int $color, int &$r, int &$g, int &$b )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

color

r

g

b

Předcházející | Nahoru | Další
ncurses_clrtoeol | Domů | ncurses_color_set


ncurses_color_set

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_color_set — Set fore- and background color

Popis

int ncurses_color_set ( int $pair )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

pair

Předcházející | Nahoru | Další
ncurses_color_content | Domů | ncurses_curs_set


ncurses_curs_set

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_curs_set — Set cursor state

Popis

int ncurses_curs_set ( int $visibility )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

visibility

Předcházející | Nahoru | Další
ncurses_color_set | Domů | ncurses_def_prog_mode


ncurses_def_prog_mode

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_def_prog_mode — Saves terminals (program) mode

Popis

bool ncurses_def_prog_mode ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Saves the current terminal modes for program (in curses) for use by ncurses_reset_prog_mode().

Návratové hodnoty

Returns FALSE on success, otherwise TRUE.

Viz také

ncurses_reset_prog_mode()

Předcházející | Nahoru | Další
ncurses_curs_set | Domů | ncurses_def_shell_mode


ncurses_def_shell_mode

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_def_shell_mode — Saves terminals (shell) mode

Popis

bool ncurses_def_shell_mode ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Saves the current terminal modes for shell (not in curses) for use by ncurses_reset_shell_mode().

Návratové hodnoty

Returns FALSE on success, TRUE otherwise.

Viz také

ncurses_reset_shell_mode()

Předcházející | Nahoru | Další
ncurses_def_prog_mode | Domů | ncurses_define_key


ncurses_define_key

(PHP 4 >= 4.2.0, PHP 5, PECL ncurses:1.0.0)

ncurses_define_key — Define a keycode

Popis

int ncurses_define_key ( string $definition, int $keycode )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

definition

keycode

Předcházející | Nahoru | Další
ncurses_def_shell_mode | Domů | ncurses_del_panel


ncurses_del_panel

(PHP 4 >= 4.3.0, PHP 5, PECL ncurses:1.0.0)

ncurses_del_panel — Remove panel from the stack and delete it (but not the associated window)

Popis

bool ncurses_del_panel ( resource $panel )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

panel

Předcházející | Nahoru | Další
ncurses_define_key | Domů | ncurses_delay_output


ncurses_delay_output

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_delay_output — Delay output on terminal using padding characters

Popis

int ncurses_delay_output ( int $milliseconds )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

milliseconds

Předcházející | Nahoru | Další
ncurses_del_panel | Domů | ncurses_delch


ncurses_delch

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_delch — Delete character at current position, move rest of line left

Popis

bool ncurses_delch ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Deletes the character under the cursor. All characters to the right of the cursor on the same line are moved to the left one position and the last character on the line is filled with a blank. The cursor position does not change.

Návratové hodnoty

Returns FALSE on success, TRUE otherwise.

Viz také

ncurses_deleteln()

Předcházející | Nahoru | Další
ncurses_delay_output | Domů | ncurses_deleteln


ncurses_deleteln

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_deleteln — Delete line at current position, move rest of screen up

Popis

bool ncurses_deleteln ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Deletes the current line under cursorposition. All lines below the current line are moved up one line. The bottom line of window is cleared. Cursor position does not change.

Návratové hodnoty

Returns FALSE on success, otherwise TRUE.

Viz také

ncurses_delch()

Předcházející | Nahoru | Další
ncurses_delch | Domů | ncurses_delwin


ncurses_delwin

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_delwin — Delete a ncurses window

Popis

bool ncurses_delwin ( resource $window )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

window

Předcházející | Nahoru | Další
ncurses_deleteln | Domů | ncurses_doupdate


ncurses_doupdate

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_doupdate — Write all prepared refreshes to terminal

Popis

bool ncurses_doupdate ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Compares the virtual screen to the physical screen and updates the physical screen. This way is more effective than using multiple refresh calls.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
ncurses_delwin | Domů | ncurses_echo


ncurses_echo

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_echo — Activate keyboard input echo

Popis

bool ncurses_echo ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Enables echo mode. All characters typed by user are echoed by ncurses_getch().

Návratové hodnoty

Returns FALSE on success, TRUE if any error occurred.

Viz také

ncurses_noecho() to disable echo mode

Předcházející | Nahoru | Další
ncurses_doupdate | Domů | ncurses_echochar


ncurses_echochar

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_echochar — Single character output including refresh

Popis

int ncurses_echochar ( int $character )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

character

Předcházející | Nahoru | Další
ncurses_echo | Domů | ncurses_end


ncurses_end

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_end — Stop using ncurses, clean up the screen

Popis

int ncurses_end ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
ncurses_echochar | Domů | ncurses_erase


ncurses_erase

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_erase — Erase terminal screen

Popis

bool ncurses_erase ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Fills the terminal screen with blanks.

Created blanks have the current background rendition, set by ncurses_bkgd().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ncurses_bkgd()
ncurses_clear()

Předcházející | Nahoru | Další
ncurses_end | Domů | ncurses_erasechar


ncurses_erasechar

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_erasechar — Returns current erase character

Popis

string ncurses_erasechar ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the current erase character.

Návratové hodnoty

The current erase char, as a string.

Viz také

ncurses_killchar()

Předcházející | Nahoru | Další
ncurses_erase | Domů | ncurses_filter


ncurses_filter

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_filter — Set LINES for iniscr() and newterm() to 1

Popis

void ncurses_filter ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
ncurses_erasechar | Domů | ncurses_flash


ncurses_flash

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_flash — Flash terminal screen (visual bell)

Popis

bool ncurses_flash ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Flashes the screen, and if its not possible, sends an audible alert (bell).

Návratové hodnoty

Returns FALSE on success, otherwise TRUE.

Viz také

ncurses_beep()

Předcházející | Nahoru | Další
ncurses_filter | Domů | ncurses_flushinp


ncurses_flushinp

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_flushinp — Flush keyboard input buffer

Popis

bool ncurses_flushinp ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Throws away any typeahead that has been typed and has not yet been read by your program.

Návratové hodnoty

Returns FALSE on success, otherwise TRUE.

Předcházející | Nahoru | Další
ncurses_flash | Domů | ncurses_getch


ncurses_getch

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_getch — Read a character from keyboard

Popis

int ncurses_getch ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
ncurses_flushinp | Domů | ncurses_getmaxyx


ncurses_getmaxyx

(PHP 4 >= 4.3.0, PHP 5, PECL ncurses:1.0.0)

ncurses_getmaxyx — Returns the size of a window

Popis

void ncurses_getmaxyx ( resource $window, int &$y, int &$x )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Gets the horizontal and vertical size of the given window into the given variables.

Variables must be passed as reference, so they are updated when the user changes the terminal size.

Seznam parametrů

window

The measured window

x

This will be set to the window width

y

This will be set to the window height

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ncurses_getch | Domů | ncurses_getmouse


ncurses_getmouse

(PHP 4 >= 4.2.0, PHP 5, PECL ncurses:1.0.0)

ncurses_getmouse — Reads mouse event

Popis

bool ncurses_getmouse ( array &$mevent )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

ncurses_getmouse() reads mouse event out of queue.

Seznam parametrů

mevent

Event options will be delivered in this parameter which has to be an array, passed by reference (see example below).

On success an associative array with following keys will be delivered:

  • "id" : Id to distinguish multiple devices

  • "x" : screen relative x-position in character cells

  • "y" : screen relative y-position in character cells

  • "z" : currently not supported

  • "mmask" : Mouse action

Návratové hodnoty

Returns FALSE if a mouse event is actually visible in the given window, otherwise returns TRUE.

Příklady

Příklad 1404. ncurses_getmouse() example

<?php
switch (ncurses_getch()){
  case NCURSES_KEY_MOUSE:
    if (!ncurses_getmouse(&$mevent)){
      if ($mevent["mmask"] & NCURSES_MOUSE_BUTTON1_PRESSED){
        $mouse_x = $mevent["x"]; // Save mouse position
        $mouse_y = $mevent["y"];
      }
    }
  break;

  default:
    /* .... */
}
?>

Viz také

ncurses_ungetmouse()

Předcházející | Nahoru | Další
ncurses_getmaxyx | Domů | ncurses_getyx


ncurses_getyx

(PHP 4 >= 4.3.0, PHP 5, PECL ncurses:1.0.0)

ncurses_getyx — Returns the current cursor position for a window

Popis

void ncurses_getyx ( resource $window, int &$y, int &$x )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

window

y

x

Předcházející | Nahoru | Další
ncurses_getmouse | Domů | ncurses_halfdelay


ncurses_halfdelay

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_halfdelay — Put terminal into halfdelay mode

Popis

int ncurses_halfdelay ( int $tenth )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

tenth

Předcházející | Nahoru | Další
ncurses_getyx | Domů | ncurses_has_colors


ncurses_has_colors

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_has_colors — Check if terminal has colors

Popis

bool ncurses_has_colors ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Checks whether the terminal has color capacities.

Návratové hodnoty

Return TRUE if the terminal has color capacities, FALSE otherwise.

Viz také

ncurses_can_change_color()

Předcházející | Nahoru | Další
ncurses_halfdelay | Domů | ncurses_has_ic


ncurses_has_ic

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_has_ic — Check for insert- and delete-capabilities

Popis

bool ncurses_has_ic ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Checks whether the terminal has insert and delete capabilities.

Návratové hodnoty

Returns TRUE if the terminal has insert/delete-capabilities, FALSE otherwise.

Viz také

ncurses_has_il()

Předcházející | Nahoru | Další
ncurses_has_colors | Domů | ncurses_has_il


ncurses_has_il

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_has_il — Check for line insert- and delete-capabilities

Popis

bool ncurses_has_il ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Checks whether the terminal has insert- and delete-line-capabilities.

Návratové hodnoty

Returns TRUE if the terminal has insert/delete-line capabilities, FALSE otherwise.

Viz také

ncurses_has_ic()

Předcházející | Nahoru | Další
ncurses_has_ic | Domů | ncurses_has_key


ncurses_has_key

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_has_key — Check for presence of a function key on terminal keyboard

Popis

int ncurses_has_key ( int $keycode )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

keycode

Předcházející | Nahoru | Další
ncurses_has_il | Domů | ncurses_hide_panel


ncurses_hide_panel

(PHP 4 >= 4.3.0, PHP 5, PECL ncurses:1.0.0)

ncurses_hide_panel — Remove panel from the stack, making it invisible

Popis

int ncurses_hide_panel ( resource $panel )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

panel

Předcházející | Nahoru | Další
ncurses_has_key | Domů | ncurses_hline


ncurses_hline

(PHP 4 >= 4.2.0, PHP 5, PECL ncurses:1.0.0)

ncurses_hline — Draw a horizontal line at current position using an attributed character and max. n characters long

Popis

int ncurses_hline ( int $charattr, int $n )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

charattr

n

Předcházející | Nahoru | Další
ncurses_hide_panel | Domů | ncurses_inch


ncurses_inch

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_inch — Get character and attribute at current position

Popis

string ncurses_inch ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the character from the current position.

Návratové hodnoty

Returns the character, as a string.

Předcházející | Nahoru | Další
ncurses_hline | Domů | ncurses_init_color


ncurses_init_color

(PHP 4 >= 4.2.0, PHP 5, PECL ncurses:1.0.0)

ncurses_init_color — Set new RGB value for color

Popis

int ncurses_init_color ( int $color, int $r, int $g, int $b )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

color

r

g

b

Předcházející | Nahoru | Další
ncurses_inch | Domů | ncurses_init_pair


ncurses_init_pair

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_init_pair — Allocate a color pair

Popis

int ncurses_init_pair ( int $pair, int $fg, int $bg )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

pair

fg

bg

Předcházející | Nahoru | Další
ncurses_init_color | Domů | ncurses_init


ncurses_init

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_init — Initialize ncurses

Popis

void ncurses_init ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Initializes the ncurses interface and must be used before any other ncurses function call.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ncurses_init_pair | Domů | ncurses_insch


ncurses_insch

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_insch — Insert character moving rest of line including character at current position

Popis

int ncurses_insch ( int $character )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

character

Předcházející | Nahoru | Další
ncurses_init | Domů | ncurses_insdelln


ncurses_insdelln

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_insdelln — Insert lines before current line scrolling down (negative numbers delete and scroll up)

Popis

int ncurses_insdelln ( int $count )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

count

Předcházející | Nahoru | Další
ncurses_insch | Domů | ncurses_insertln


ncurses_insertln

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_insertln — Insert a line, move rest of screen down

Popis

int ncurses_insertln ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Inserts a new line above the current line. The bottom line will be lost.

Předcházející | Nahoru | Další
ncurses_insdelln | Domů | ncurses_insstr


ncurses_insstr

(PHP 4 >= 4.2.0, PHP 5, PECL ncurses:1.0.0)

ncurses_insstr — Insert string at current position, moving rest of line right

Popis

int ncurses_insstr ( string $text )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

text

Předcházející | Nahoru | Další
ncurses_insertln | Domů | ncurses_instr


ncurses_instr

(PHP 4 >= 4.2.0, PHP 5, PECL ncurses:1.0.0)

ncurses_instr — Reads string from terminal screen

Popis

int ncurses_instr ( string &$buffer )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Reads a string from the terminal screen and returns the number of characters read from the current character position until end of line.

Seznam parametrů

buffer

The characters. Attributes will be stripped.

Návratové hodnoty

Returns the number of characters.

Předcházející | Nahoru | Další
ncurses_insstr | Domů | ncurses_isendwin


ncurses_isendwin

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_isendwin — Ncurses is in endwin mode, normal screen output may be performed

Popis

bool ncurses_isendwin ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Checks if ncurses is in endwin mode.

Návratové hodnoty

Returns TRUE, if ncurses_endwin() has been called without any subsequent calls to ncurses_wrefresh(), FALSE otherwise.

Viz také

ncurses_endwin()
ncurses_wrefresh()

Předcházející | Nahoru | Další
ncurses_instr | Domů | ncurses_keyok


ncurses_keyok

(PHP 4 >= 4.2.0, PHP 5, PECL ncurses:1.0.0)

ncurses_keyok — Enable or disable a keycode

Popis

int ncurses_keyok ( int $keycode, bool $enable )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

keycode

enable

Předcházející | Nahoru | Další
ncurses_isendwin | Domů | ncurses_keypad


ncurses_keypad

(PHP 4 >= 4.2.0, PHP 5, PECL ncurses:1.0.0)

ncurses_keypad — Turns keypad on or off

Popis

int ncurses_keypad ( resource $window, bool $bf )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

window

bf

Předcházející | Nahoru | Další
ncurses_keyok | Domů | ncurses_killchar


ncurses_killchar

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_killchar — Returns current line kill character

Popis

string ncurses_killchar ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the current line kill character.

Návratové hodnoty

Returns the kill character, as a string.

Viz také

ncurses_erasechar()

Předcházející | Nahoru | Další
ncurses_keypad | Domů | ncurses_longname


ncurses_longname

(PHP 4 >= 4.2.0, PHP 5, PECL ncurses:1.0.0)

ncurses_longname — Returns terminals description

Popis

string ncurses_longname ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns a verbose description of the terminal.

Návratové hodnoty

Returns the description, as a string truncated to 128 characters. On errors, returns NULL.

Viz také

ncurses_termname()

Předcházející | Nahoru | Další
ncurses_killchar | Domů | ncurses_meta


ncurses_meta

(PHP 4 >= 4.3.0, PHP 5, PECL ncurses:1.0.0)

ncurses_meta — Enables/Disable 8-bit meta key information

Popis

int ncurses_meta ( resource $window, bool $8bit )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

window

8bit

Předcházející | Nahoru | Další
ncurses_longname | Domů | ncurses_mouse_trafo


ncurses_mouse_trafo

(PHP 4 >= 4.2.0, PHP 5, PECL ncurses:1.0.0)

ncurses_mouse_trafo — Transforms coordinates

Popis

bool ncurses_mouse_trafo ( int &$y, int &$x, bool $toscreen )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

y

x

toscreen

Předcházející | Nahoru | Další
ncurses_meta | Domů | ncurses_mouseinterval


ncurses_mouseinterval

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_mouseinterval — Set timeout for mouse button clicks

Popis

int ncurses_mouseinterval ( int $milliseconds )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

milliseconds

Předcházející | Nahoru | Další
ncurses_mouse_trafo | Domů | ncurses_mousemask


ncurses_mousemask

(PHP 4 >= 4.2.0, PHP 5, PECL ncurses:1.0.0)

ncurses_mousemask — Sets mouse options

Popis

int ncurses_mousemask ( int $newmask, int &$oldmask )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets mouse events to be reported. By default no mouse events will be reported.

Mouse events are represented by NCURSES_KEY_MOUSE in the ncurses_wgetch() input stream. To read the event data and pop the event of queue, call ncurses_getmouse().

Seznam parametrů

newmask

Mouse mask options can be set with the following predefined constants:

  • NCURSES_BUTTON1_PRESSED

  • NCURSES_BUTTON1_RELEASED

  • NCURSES_BUTTON1_CLICKED

  • NCURSES_BUTTON1_DOUBLE_CLICKED

  • NCURSES_BUTTON1_TRIPLE_CLICKED

  • NCURSES_BUTTON2_PRESSED

  • NCURSES_BUTTON2_RELEASED

  • NCURSES_BUTTON2_CLICKED

  • NCURSES_BUTTON2_DOUBLE_CLICKED

  • NCURSES_BUTTON2_TRIPLE_CLICKED

  • NCURSES_BUTTON3_PRESSED

  • NCURSES_BUTTON3_RELEASED

  • NCURSES_BUTTON3_CLICKED

  • NCURSES_BUTTON3_DOUBLE_CLICKED

  • NCURSES_BUTTON3_TRIPLE_CLICKED

  • NCURSES_BUTTON4_PRESSED

  • NCURSES_BUTTON4_RELEASED

  • NCURSES_BUTTON4_CLICKED

  • NCURSES_BUTTON4_DOUBLE_CLICKED

  • NCURSES_BUTTON4_TRIPLE_CLICKED

  • NCURSES_BUTTON_SHIFT>

  • NCURSES_BUTTON_CTRL

  • NCURSES_BUTTON_ALT

  • NCURSES_ALL_MOUSE_EVENTS

  • NCURSES_REPORT_MOUSE_POSITION

As a side effect, setting a zero mousemask in newmask turns off the mouse pointer. Setting a non zero value turns mouse pointer on.

oldmask

This will be set to the previous value of the mouse event mask.

Návratové hodnoty

Returns a mask to indicated which of the in parameter newmask specified mouse events can be reported. On complete failure, it returns 0.

Příklady

Příklad 1405. ncurses_mousemask() example

<?php
$newmask = NCURSES_BUTTON1_CLICKED + NCURSES_BUTTON1_RELEASED;
$mask = ncurses_mousemask($newmask, &$oldmask);
if ($mask & $newmask){
    printf("All specified mouse options will be supported\n");
}
?>

Viz také

ncurses_getmouse()
ncurses_ungetmouse()
ncurese_getch()

Předcházející | Nahoru | Další
ncurses_mouseinterval | Domů | ncurses_move_panel


ncurses_move_panel

(PHP 4 >= 4.3.0, PHP 5, PECL ncurses:1.0.0)

ncurses_move_panel — Moves a panel so that its upper-left corner is at [startx, starty]

Popis

int ncurses_move_panel ( resource $panel, int $startx, int $starty )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

panel

startx

starty

Předcházející | Nahoru | Další
ncurses_mousemask | Domů | ncurses_move


ncurses_move

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_move — Move output position

Popis

int ncurses_move ( int $y, int $x )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

y

x

Předcházející | Nahoru | Další
ncurses_move_panel | Domů | ncurses_mvaddch


ncurses_mvaddch

(PHP 4 >= 4.2.0, PHP 5, PECL ncurses:1.0.0)

ncurses_mvaddch — Move current position and add character

Popis

int ncurses_mvaddch ( int $y, int $x, int $c )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

y

x

c

Předcházející | Nahoru | Další
ncurses_move | Domů | ncurses_mvaddchnstr


ncurses_mvaddchnstr

(PHP 4 >= 4.2.0, PHP 5, PECL ncurses:1.0.0)

ncurses_mvaddchnstr — Move position and add attributed string with specified length

Popis

int ncurses_mvaddchnstr ( int $y, int $x, string $s, int $n )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

y

x

s

n

Předcházející | Nahoru | Další
ncurses_mvaddch | Domů | ncurses_mvaddchstr


ncurses_mvaddchstr

(PHP 4 >= 4.2.0, PHP 5, PECL ncurses:1.0.0)

ncurses_mvaddchstr — Move position and add attributed string

Popis

int ncurses_mvaddchstr ( int $y, int $x, string $s )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

y

x

s

Předcházející | Nahoru | Další
ncurses_mvaddchnstr | Domů | ncurses_mvaddnstr


ncurses_mvaddnstr

(PHP 4 >= 4.2.0, PHP 5, PECL ncurses:1.0.0)

ncurses_mvaddnstr — Move position and add string with specified length

Popis

int ncurses_mvaddnstr ( int $y, int $x, string $s, int $n )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

y

x

s

n

Předcházející | Nahoru | Další
ncurses_mvaddchstr | Domů | ncurses_mvaddstr


ncurses_mvaddstr

(PHP 4 >= 4.2.0, PHP 5, PECL ncurses:1.0.0)

ncurses_mvaddstr — Move position and add string

Popis

int ncurses_mvaddstr ( int $y, int $x, string $s )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

y

x

s

Předcházející | Nahoru | Další
ncurses_mvaddnstr | Domů | ncurses_mvcur


ncurses_mvcur

(PHP 4 >= 4.2.0, PHP 5, PECL ncurses:1.0.0)

ncurses_mvcur — Move cursor immediately

Popis

int ncurses_mvcur ( int $old_y, int $old_x, int $new_y, int $new_x )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

old_y

old_x

new_y

new_x

Předcházející | Nahoru | Další
ncurses_mvaddstr | Domů | ncurses_mvdelch


ncurses_mvdelch

(PHP 4 >= 4.2.0, PHP 5, PECL ncurses:1.0.0)

ncurses_mvdelch — Move position and delete character, shift rest of line left

Popis

int ncurses_mvdelch ( int $y, int $x )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

y

x

Předcházející | Nahoru | Další
ncurses_mvcur | Domů | ncurses_mvgetch


ncurses_mvgetch

(PHP 4 >= 4.2.0, PHP 5, PECL ncurses:1.0.0)

ncurses_mvgetch — Move position and get character at new position

Popis

int ncurses_mvgetch ( int $y, int $x )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

y

x

Předcházející | Nahoru | Další
ncurses_mvdelch | Domů | ncurses_mvhline


ncurses_mvhline

(PHP 4 >= 4.2.0, PHP 5, PECL ncurses:1.0.0)

ncurses_mvhline — Set new position and draw a horizontal line using an attributed character and max. n characters long

Popis

int ncurses_mvhline ( int $y, int $x, int $attrchar, int $n )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

y

x

attrchar

n

Předcházející | Nahoru | Další
ncurses_mvgetch | Domů | ncurses_mvinch


ncurses_mvinch

(PHP 4 >= 4.2.0, PHP 5, PECL ncurses:1.0.0)

ncurses_mvinch — Move position and get attributed character at new position

Popis

int ncurses_mvinch ( int $y, int $x )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

y

x

Předcházející | Nahoru | Další
ncurses_mvhline | Domů | ncurses_mvvline


ncurses_mvvline

(PHP 4 >= 4.2.0, PHP 5, PECL ncurses:1.0.0)

ncurses_mvvline — Set new position and draw a vertical line using an attributed character and max. n characters long

Popis

int ncurses_mvvline ( int $y, int $x, int $attrchar, int $n )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

y

x

attrchar

n

Předcházející | Nahoru | Další
ncurses_mvinch | Domů | ncurses_mvwaddstr


ncurses_mvwaddstr

(PHP 4 >= 4.2.0, PHP 5, PECL ncurses:1.0.0)

ncurses_mvwaddstr — Add string at new position in window

Popis

int ncurses_mvwaddstr ( resource $window, int $y, int $x, string $text )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

window

y

x

text

Předcházející | Nahoru | Další
ncurses_mvvline | Domů | ncurses_napms


ncurses_napms

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_napms — Sleep

Popis

int ncurses_napms ( int $milliseconds )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

milliseconds

Předcházející | Nahoru | Další
ncurses_mvwaddstr | Domů | ncurses_new_panel


ncurses_new_panel

(PHP 4 >= 4.3.0, PHP 5, PECL ncurses:1.0.0)

ncurses_new_panel — Create a new panel and associate it with window

Popis

resource ncurses_new_panel ( resource $window )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

window

Předcházející | Nahoru | Další
ncurses_napms | Domů | ncurses_newpad


ncurses_newpad

(PHP 4 >= 4.3.0, PHP 5, PECL ncurses:1.0.0)

ncurses_newpad — Creates a new pad (window)

Popis

resource ncurses_newpad ( int $rows, int $cols )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

rows

cols

Předcházející | Nahoru | Další
ncurses_new_panel | Domů | ncurses_newwin


ncurses_newwin

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_newwin — Create a new window

Popis

resource ncurses_newwin ( int $rows, int $cols, int $y, int $x )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Creates a new window to draw elements in.

When creating additional windows, remember to use ncurses_getmaxyx() to check for available space, as terminal size is individual and may vary.

Seznam parametrů

rows

Number of rows

cols

Number of columns

y

y-ccordinate of the origin

x

x-ccordinate of the origin

Návratové hodnoty

Returns a resource ID for the new window.

Předcházející | Nahoru | Další
ncurses_newpad | Domů | ncurses_nl


ncurses_nl

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_nl — Translate newline and carriage return / line feed

Popis

bool ncurses_nl ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
ncurses_newwin | Domů | ncurses_nocbreak


ncurses_nocbreak

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_nocbreak — Switch terminal to cooked mode

Popis

bool ncurses_nocbreak ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns terminal to normal (cooked) mode. Initially the terminal may or may not in cbreak mode as the mode is inherited. Therefore a program should call ncurses_cbreak() and ncurses_nocbreak() explicitly.

Návratové hodnoty

Returns TRUE if any error occurred, otherwise FALSE.

Viz také

ncurses_cbreak()

Předcházející | Nahoru | Další
ncurses_nl | Domů | ncurses_noecho


ncurses_noecho

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_noecho — Switch off keyboard input echo

Popis

bool ncurses_noecho ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Prevents echoing of user typed characters.

Návratové hodnoty

Returns TRUE if any error occurred, FALSE otherwise.

Viz také

ncurses_echo()
ncurses_getch()

Předcházející | Nahoru | Další
ncurses_nocbreak | Domů | ncurses_nonl


ncurses_nonl

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_nonl — Do not translate newline and carriage return / line feed

Popis

bool ncurses_nonl ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
ncurses_noecho | Domů | ncurses_noqiflush


ncurses_noqiflush

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_noqiflush — Do not flush on signal characters

Popis

void ncurses_noqiflush ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
ncurses_nonl | Domů | ncurses_noraw


ncurses_noraw

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_noraw — Switch terminal out of raw mode

Popis

bool ncurses_noraw ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Switches the terminal out of raw mode. Raw mode is similar to cbreak mode, in that characters typed are immediately passed through to the user program. The differences that are that in raw mode, the interrupt, quit, suspend and flow control characters are all passed through uninterpreted, instead of generating a signal.

Návratové hodnoty

Returns TRUE if any error occurred, otherwise FALSE.

Viz také

ncurses_raw()
ncurses_cbreak()
ncurses_nocbreak()

Předcházející | Nahoru | Další
ncurses_noqiflush | Domů | ncurses_pair_content


ncurses_pair_content

(PHP 4 >= 4.3.0, PHP 5, PECL ncurses:1.0.0)

ncurses_pair_content — Gets the RGB value for color

Popis

int ncurses_pair_content ( int $pair, int &$f, int &$b )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

pair

f

b

Předcházející | Nahoru | Další
ncurses_noraw | Domů | ncurses_panel_above


ncurses_panel_above

(PHP 4 >= 4.3.0, PHP 5, PECL ncurses:1.0.0)

ncurses_panel_above — Returns the panel above panel

Popis

resource ncurses_panel_above ( resource $panel )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

panel

Návratové hodnoty

If panel is null, returns the bottom panel in the stack.

Předcházející | Nahoru | Další
ncurses_pair_content | Domů | ncurses_panel_below


ncurses_panel_below

(PHP 4 >= 4.3.0, PHP 5, PECL ncurses:1.0.0)

ncurses_panel_below — Returns the panel below panel

Popis

resource ncurses_panel_below ( resource $panel )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

panel

Seznam parametrů

If panel is null, returns the top panel in the stack.

Předcházející | Nahoru | Další
ncurses_panel_above | Domů | ncurses_panel_window


ncurses_panel_window

(PHP 4 >= 4.3.0, PHP 5, PECL ncurses:1.0.0)

ncurses_panel_window — Returns the window associated with panel

Popis

resource ncurses_panel_window ( resource $panel )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

panel

Předcházející | Nahoru | Další
ncurses_panel_below | Domů | ncurses_pnoutrefresh


ncurses_pnoutrefresh

(PHP 4 >= 4.3.0, PHP 5, PECL ncurses:1.0.0)

ncurses_pnoutrefresh — Copies a region from a pad into the virtual screen

Popis

int ncurses_pnoutrefresh ( resource $pad, int $pminrow, int $pmincol, int $sminrow, int $smincol, int $smaxrow, int $smaxcol )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

pad

pminrow

pmincol

sminrow

smincol

smaxrow

smaxcol

Předcházející | Nahoru | Další
ncurses_panel_window | Domů | ncurses_prefresh


ncurses_prefresh

(PHP 4 >= 4.3.0, PHP 5, PECL ncurses:1.0.0)

ncurses_prefresh — Copies a region from a pad into the virtual screen

Popis

int ncurses_prefresh ( resource $pad, int $pminrow, int $pmincol, int $sminrow, int $smincol, int $smaxrow, int $smaxcol )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

pad

pminrow

pmincol

sminrow

smincol

smaxrow

smaxcol

Předcházející | Nahoru | Další
ncurses_pnoutrefresh | Domů | ncurses_putp


ncurses_putp

(PHP 4 >= 4.2.0, PHP 5, PECL ncurses:1.0.0)

ncurses_putp — Apply padding information to the string and output it

Popis

int ncurses_putp ( string $text )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

text

Předcházející | Nahoru | Další
ncurses_prefresh | Domů | ncurses_qiflush


ncurses_qiflush

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_qiflush — Flush on signal characters

Popis

void ncurses_qiflush ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
ncurses_putp | Domů | ncurses_raw


ncurses_raw

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_raw — Switch terminal into raw mode

Popis

bool ncurses_raw ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Places the terminal in raw mode. Raw mode is similar to cbreak mode, in that characters typed are immediately passed through to the user program. The differences that are that in raw mode, the interrupt, quit, suspend and flow control characters are all passed through uninterpreted, instead of generating a signal.

Návratové hodnoty

Returns TRUE if any error occurred, otherwise FALSE.

Viz také

ncurses_noraw()
ncurses_cbreak()
ncurses_nocbreak()

Předcházející | Nahoru | Další
ncurses_qiflush | Domů | ncurses_refresh


ncurses_refresh

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_refresh — Refresh screen

Popis

int ncurses_refresh ( int $ch )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

ch

Předcházející | Nahoru | Další
ncurses_raw | Domů | ncurses_replace_panel


ncurses_replace_panel

(PHP 4 >= 4.3.0, PHP 5, PECL ncurses:1.0.0)

ncurses_replace_panel — Replaces the window associated with panel

Popis

int ncurses_replace_panel ( resource $panel, resource $window )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

panel

window

Předcházející | Nahoru | Další
ncurses_refresh | Domů | ncurses_reset_prog_mode


ncurses_reset_prog_mode

(PHP 4 >= 4.3.0, PHP 5, PECL ncurses:1.0.0)

ncurses_reset_prog_mode — Resets the prog mode saved by def_prog_mode

Popis

int ncurses_reset_prog_mode ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
ncurses_replace_panel | Domů | ncurses_reset_shell_mode


ncurses_reset_shell_mode

(PHP 4 >= 4.3.0, PHP 5, PECL ncurses:1.0.0)

ncurses_reset_shell_mode — Resets the shell mode saved by def_shell_mode

Popis

int ncurses_reset_shell_mode ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
ncurses_reset_prog_mode | Domů | ncurses_resetty


ncurses_resetty

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_resetty — Restores saved terminal state

Popis

bool ncurses_resetty ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Restores the terminal state, which was previously saved by calling ncurses_savetty().

Návratové hodnoty

Always returns FALSE.

Viz také

ncurses_savetty()

Předcházející | Nahoru | Další
ncurses_reset_shell_mode | Domů | ncurses_savetty


ncurses_savetty

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_savetty — Saves terminal state

Popis

bool ncurses_savetty ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Saves the current terminal state. The saved terminal state can be restored with ncurses_resetty().

Návratové hodnoty

Always returns FALSE.

Viz také

ncurses_resetty()

Předcházející | Nahoru | Další
ncurses_resetty | Domů | ncurses_scr_dump


ncurses_scr_dump

(PHP 4 >= 4.2.0, PHP 5, PECL ncurses:1.0.0)

ncurses_scr_dump — Dump screen content to file

Popis

int ncurses_scr_dump ( string $filename )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

filename

Předcházející | Nahoru | Další
ncurses_savetty | Domů | ncurses_scr_init


ncurses_scr_init

(PHP 4 >= 4.2.0, PHP 5, PECL ncurses:1.0.0)

ncurses_scr_init — Initialize screen from file dump

Popis

int ncurses_scr_init ( string $filename )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

filename

Předcházející | Nahoru | Další
ncurses_scr_dump | Domů | ncurses_scr_restore


ncurses_scr_restore

(PHP 4 >= 4.2.0, PHP 5, PECL ncurses:1.0.0)

ncurses_scr_restore — Restore screen from file dump

Popis

int ncurses_scr_restore ( string $filename )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

filename

Předcházející | Nahoru | Další
ncurses_scr_init | Domů | ncurses_scr_set


ncurses_scr_set

(PHP 4 >= 4.2.0, PHP 5, PECL ncurses:1.0.0)

ncurses_scr_set — Inherit screen from file dump

Popis

int ncurses_scr_set ( string $filename )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

filename

Předcházející | Nahoru | Další
ncurses_scr_restore | Domů | ncurses_scrl


ncurses_scrl

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_scrl — Scroll window content up or down without changing current position

Popis

int ncurses_scrl ( int $count )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

count

Předcházející | Nahoru | Další
ncurses_scr_set | Domů | ncurses_show_panel


ncurses_show_panel

(PHP 4 >= 4.3.0, PHP 5, PECL ncurses:1.0.0)

ncurses_show_panel — Places an invisible panel on top of the stack, making it visible

Popis

int ncurses_show_panel ( resource $panel )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

panel

Předcházející | Nahoru | Další
ncurses_scrl | Domů | ncurses_slk_attr


ncurses_slk_attr

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_slk_attr — Returns current soft label key attribute

Popis

int ncurses_slk_attr ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the current soft label key attribute.

Návratové hodnoty

The attribute, as an integer.

Předcházející | Nahoru | Další
ncurses_show_panel | Domů | ncurses_slk_attroff


ncurses_slk_attroff

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_slk_attroff — Turn off the given attributes for soft function-key labels

Popis

int ncurses_slk_attroff ( int $intarg )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

intarg

Předcházející | Nahoru | Další
ncurses_slk_attr | Domů | ncurses_slk_attron


ncurses_slk_attron

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_slk_attron — Turn on the given attributes for soft function-key labels

Popis

int ncurses_slk_attron ( int $intarg )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

intarg

Předcházející | Nahoru | Další
ncurses_slk_attroff | Domů | ncurses_slk_attrset


ncurses_slk_attrset

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_slk_attrset — Set given attributes for soft function-key labels

Popis

int ncurses_slk_attrset ( int $intarg )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

intarg

Předcházející | Nahoru | Další
ncurses_slk_attron | Domů | ncurses_slk_clear


ncurses_slk_clear

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_slk_clear — Clears soft labels from screen

Popis

bool ncurses_slk_clear ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

The function ncurses_slk_clear() clears soft label keys from screen.

Návratové hodnoty

Returns TRUE on errors, FALSE otherwise.

Předcházející | Nahoru | Další
ncurses_slk_attrset | Domů | ncurses_slk_color


ncurses_slk_color

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_slk_color — Sets color for soft label keys

Popis

int ncurses_slk_color ( int $intarg )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

intarg

Předcházející | Nahoru | Další
ncurses_slk_clear | Domů | ncurses_slk_init


ncurses_slk_init

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_slk_init — Initializes soft label key functions

Popis

bool ncurses_slk_init ( int $format )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Initializes soft label key functions

This function must be called before ncurses_initscr() or ncurses_newterm() is called.

Seznam parametrů

format

If ncurses_initscr() eventually uses a line from stdscr to emulate the soft labels, then this parameter determines how the labels are arranged of the screen.

0 indicates a 3-2-3 arrangement of the labels, 1 indicates a 4-4 arrangement and 2 indicates the PC like 4-4-4 mode, but in addition an index line will be created.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
ncurses_slk_color | Domů | ncurses_slk_noutrefresh


ncurses_slk_noutrefresh

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_slk_noutrefresh — Copies soft label keys to virtual screen

Popis

bool ncurses_slk_noutrefresh ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
ncurses_slk_init | Domů | ncurses_slk_refresh


ncurses_slk_refresh

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_slk_refresh — Copies soft label keys to screen

Popis

int ncurses_slk_refresh ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Copies soft label keys from virtual screen to physical screen.

Předcházející | Nahoru | Další
ncurses_slk_noutrefresh | Domů | ncurses_slk_restore


ncurses_slk_restore

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_slk_restore — Restores soft label keys

Popis

int ncurses_slk_restore ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Restores the soft label keys after ncurses_slk_clear() has been performed.

Předcházející | Nahoru | Další
ncurses_slk_refresh | Domů | ncurses_slk_set


ncurses_slk_set

(PHP 4 >= 4.2.0, PHP 5, PECL ncurses:1.0.0)

ncurses_slk_set — Sets function key labels

Popis

bool ncurses_slk_set ( int $labelnr, string $label, int $format )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

labelnr

label

format

Předcházející | Nahoru | Další
ncurses_slk_restore | Domů | ncurses_slk_touch


ncurses_slk_touch

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_slk_touch — Forces output when ncurses_slk_noutrefresh is performed

Popis

int ncurses_slk_touch ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Forces all the soft labels to be output the next time a ncurses_slk_noutrefresh() is performed.

Předcházející | Nahoru | Další
ncurses_slk_set | Domů | ncurses_standend


ncurses_standend

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_standend — Stop using 'standout' attribute

Popis

int ncurses_standend ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
ncurses_slk_touch | Domů | ncurses_standout


ncurses_standout

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_standout — Start using 'standout' attribute

Popis

int ncurses_standout ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
ncurses_standend | Domů | ncurses_start_color


ncurses_start_color

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_start_color — Start using colors

Popis

int ncurses_start_color ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
ncurses_standout | Domů | ncurses_termattrs


ncurses_termattrs

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_termattrs — Returns a logical OR of all attribute flags supported by terminal

Popis

bool ncurses_termattrs ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
ncurses_start_color | Domů | ncurses_termname


ncurses_termname

(PHP 4 >= 4.2.0, PHP 5, PECL ncurses:1.0.0)

ncurses_termname — Returns terminals (short)-name

Popis

string ncurses_termname ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns terminals shortname.

Návratové hodnoty

Returns the shortname of the terminal, truncated to 14 characters. On errors, returns NULL.

Viz také

ncurses_longname()

Předcházející | Nahoru | Další
ncurses_termattrs | Domů | ncurses_timeout


ncurses_timeout

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_timeout — Set timeout for special key sequences

Popis

void ncurses_timeout ( int $millisec )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

millisec

Předcházející | Nahoru | Další
ncurses_termname | Domů | ncurses_top_panel


ncurses_top_panel

(PHP 4 >= 4.3.0, PHP 5, PECL ncurses:1.0.0)

ncurses_top_panel — Moves a visible panel to the top of the stack

Popis

int ncurses_top_panel ( resource $panel )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

panel

Předcházející | Nahoru | Další
ncurses_timeout | Domů | ncurses_typeahead


ncurses_typeahead

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_typeahead — Specify different filedescriptor for typeahead checking

Popis

int ncurses_typeahead ( int $fd )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

fd

Předcházející | Nahoru | Další
ncurses_top_panel | Domů | ncurses_ungetch


ncurses_ungetch

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_ungetch — Put a character back into the input stream

Popis

int ncurses_ungetch ( int $keycode )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

keycode

Předcházející | Nahoru | Další
ncurses_typeahead | Domů | ncurses_ungetmouse


ncurses_ungetmouse

(PHP 4 >= 4.2.0, PHP 5, PECL ncurses:1.0.0)

ncurses_ungetmouse — Pushes mouse event to queue

Popis

bool ncurses_ungetmouse ( array $mevent )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Pushes a KEY_MOUSE event onto the unput queue and associates with this event the given state sata and screen-relative character cell coordinates, specified in mevent.

Seznam parametrů

mevent

An associative array specifying the event options:

  • "id" : Id to distinguish multiple devices

  • "x" : screen relative x-position in character cells

  • "y" : screen relative y-position in character cells

  • "z" : currently not supported

  • "mmask" : Mouse action

Návratové hodnoty

Returns FALSE on success, TRUE otherwise.

Viz také

ncurses_getmouse()

Předcházející | Nahoru | Další
ncurses_ungetch | Domů | ncurses_update_panels


ncurses_update_panels

(PHP 4 >= 4.3.0, PHP 5, PECL ncurses:1.0.0)

ncurses_update_panels — Refreshes the virtual screen to reflect the relations between panels in the stack

Popis

void ncurses_update_panels ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
ncurses_ungetmouse | Domů | ncurses_use_default_colors


ncurses_use_default_colors

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_use_default_colors — Assign terminal default colors to color id -1

Popis

bool ncurses_use_default_colors ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
ncurses_update_panels | Domů | ncurses_use_env


ncurses_use_env

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_use_env — Control use of environment information about terminal size

Popis

void ncurses_use_env ( bool $flag )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

flag

Předcházející | Nahoru | Další
ncurses_use_default_colors | Domů | ncurses_use_extended_names


ncurses_use_extended_names

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_use_extended_names — Control use of extended names in terminfo descriptions

Popis

int ncurses_use_extended_names ( bool $flag )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

flag

Předcházející | Nahoru | Další
ncurses_use_env | Domů | ncurses_vidattr


ncurses_vidattr

(PHP 4 >= 4.0.7, PHP 5, PECL ncurses:1.0.0)

ncurses_vidattr — Display the string on the terminal in the video attribute mode

Popis

int ncurses_vidattr ( int $intarg )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

intarg

Předcházející | Nahoru | Další
ncurses_use_extended_names | Domů | ncurses_vline


ncurses_vline

(PHP 4 >= 4.2.0, PHP 5, PECL ncurses:1.0.0)

ncurses_vline — Draw a vertical line at current position using an attributed character and max. n characters long

Popis

int ncurses_vline ( int $charattr, int $n )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

charattr

n

Předcházející | Nahoru | Další
ncurses_vidattr | Domů | ncurses_waddch


ncurses_waddch

(PHP 4 >= 4.3.0, PHP 5, PECL ncurses:1.0.0)

ncurses_waddch — Adds character at current position in a window and advance cursor

Popis

int ncurses_waddch ( resource $window, int $ch )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

window

ch

Předcházející | Nahoru | Další
ncurses_vline | Domů | ncurses_waddstr


ncurses_waddstr

(PHP 4 >= 4.2.0, PHP 5, PECL ncurses:1.0.0)

ncurses_waddstr — Outputs text at current postion in window

Popis

int ncurses_waddstr ( resource $window, string $str [, int $n] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

window

str

n

Předcházející | Nahoru | Další
ncurses_waddch | Domů | ncurses_wattroff


ncurses_wattroff

(PHP 4 >= 4.3.0, PHP 5, PECL ncurses:1.0.0)

ncurses_wattroff — Turns off attributes for a window

Popis

int ncurses_wattroff ( resource $window, int $attrs )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

window

attrs

Předcházející | Nahoru | Další
ncurses_waddstr | Domů | ncurses_wattron


ncurses_wattron

(PHP 4 >= 4.3.0, PHP 5, PECL ncurses:1.0.0)

ncurses_wattron — Turns on attributes for a window

Popis

int ncurses_wattron ( resource $window, int $attrs )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

window

attrs

Předcházející | Nahoru | Další
ncurses_wattroff | Domů | ncurses_wattrset


ncurses_wattrset

(PHP 4 >= 4.3.0, PHP 5, PECL ncurses:1.0.0)

ncurses_wattrset — Set the attributes for a window

Popis

int ncurses_wattrset ( resource $window, int $attrs )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

window

attrs

Předcházející | Nahoru | Další
ncurses_wattron | Domů | ncurses_wborder


ncurses_wborder

(PHP 4 >= 4.3.0, PHP 5, PECL ncurses:1.0.0)

ncurses_wborder — Draws a border around the window using attributed characters

Popis

int ncurses_wborder ( resource $window, int $left, int $right, int $top, int $bottom, int $tl_corner, int $tr_corner, int $bl_corner, int $br_corner )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Draws the specified lines and corners around the passed window.

Use ncurses_border() for borders around the main window.

Seznam parametrů

Each parameter expects 0 to draw a line and 1 to skip it.

window

The window on which we operate

left

right

top

bottom

tl_corner

Top left corner

tr_corner

Top right corner

bl_corner

Bottom left corner

br_corner

Bottom right corner

Viz také

ncurses_border()

Předcházející | Nahoru | Další
ncurses_wattrset | Domů | ncurses_wclear


ncurses_wclear

(PHP 4 >= 4.2.0, PHP 5, PECL ncurses:1.0.0)

ncurses_wclear — Clears window

Popis

int ncurses_wclear ( resource $window )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

window

Předcházející | Nahoru | Další
ncurses_wborder | Domů | ncurses_wcolor_set


ncurses_wcolor_set

(PHP 4 >= 4.2.0, PHP 5, PECL ncurses:1.0.0)

ncurses_wcolor_set — Sets windows color pairings

Popis

int ncurses_wcolor_set ( resource $window, int $color_pair )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

window

color_pair

Předcházející | Nahoru | Další
ncurses_wclear | Domů | ncurses_werase


ncurses_werase

(PHP 4 >= 4.3.0, PHP 5, PECL ncurses:1.0.0)

ncurses_werase — Erase window contents

Popis

int ncurses_werase ( resource $window )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

window

Předcházející | Nahoru | Další
ncurses_wcolor_set | Domů | ncurses_wgetch


ncurses_wgetch

(PHP 4 >= 4.2.0, PHP 5, PECL ncurses:1.0.0)

ncurses_wgetch — Reads a character from keyboard (window)

Popis

int ncurses_wgetch ( resource $window )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

window

Předcházející | Nahoru | Další
ncurses_werase | Domů | ncurses_whline


ncurses_whline

(PHP 4 >= 4.3.0, PHP 5, PECL ncurses:1.0.0)

ncurses_whline — Draws a horizontal line in a window at current position using an attributed character and max. n characters long

Popis

int ncurses_whline ( resource $window, int $charattr, int $n )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

window

charattr

n

Předcházející | Nahoru | Další
ncurses_wgetch | Domů | ncurses_wmouse_trafo


ncurses_wmouse_trafo

(PHP 4 >= 4.2.0, PHP 5, PECL ncurses:1.0.0)

ncurses_wmouse_trafo — Transforms window/stdscr coordinates

Popis

bool ncurses_wmouse_trafo ( resource $window, int &$y, int &$x, bool $toscreen )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

window

x

y

toscreen

Předcházející | Nahoru | Další
ncurses_whline | Domů | ncurses_wmove


ncurses_wmove

(PHP 4 >= 4.2.0, PHP 5, PECL ncurses:1.0.0)

ncurses_wmove — Moves windows output position

Popis

int ncurses_wmove ( resource $window, int $y, int $x )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

window

y

x

Předcházející | Nahoru | Další
ncurses_wmouse_trafo | Domů | ncurses_wnoutrefresh


ncurses_wnoutrefresh

(PHP 4 >= 4.2.0, PHP 5, PECL ncurses:1.0.0)

ncurses_wnoutrefresh — Copies window to virtual screen

Popis

int ncurses_wnoutrefresh ( resource $window )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

window

Předcházející | Nahoru | Další
ncurses_wmove | Domů | ncurses_wrefresh


ncurses_wrefresh

(PHP 4 >= 4.2.0, PHP 5, PECL ncurses:1.0.0)

ncurses_wrefresh — Refresh window on terminal screen

Popis

int ncurses_wrefresh ( resource $window )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

window

Předcházející | Nahoru | Další
ncurses_wnoutrefresh | Domů | ncurses_wstandend


ncurses_wstandend

(PHP 4 >= 4.3.0, PHP 5, PECL ncurses:1.0.0)

ncurses_wstandend — End standout mode for a window

Popis

int ncurses_wstandend ( resource $window )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

window

Předcházející | Nahoru | Další
ncurses_wrefresh | Domů | ncurses_wstandout


ncurses_wstandout

(PHP 4 >= 4.3.0, PHP 5, PECL ncurses:1.0.0)

ncurses_wstandout — Enter standout mode for a window

Popis

int ncurses_wstandout ( resource $window )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

window

Předcházející | Nahoru | Další
ncurses_wstandend | Domů | ncurses_wvline


ncurses_wvline

(PHP 4 >= 4.3.0, PHP 5, PECL ncurses:1.0.0)

ncurses_wvline — Draws a vertical line in a window at current position using an attributed character and max. n characters long

Popis

int ncurses_wvline ( resource $window, int $charattr, int $n )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

window

charattr

n

Předcházející | Nahoru | Další
ncurses_wstandout | Domů | CII. Síťové funkce


Lotus Notes Functions

Předcházející VI. Reference funkcí Další

LXXVII. Lotus Notes Functions

Úvod

Varování

Toto rozšíření je EXPERIMENTÁLNÍ. Chování tohoto rozšíření, názvy funkcí a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může bez ohlášení změnit. Berte to v úvahu a používejte tento modul na vlastní nebezpečí.

Poznámka: Toto rozšíření bylo přesunuto do repozitáře PECL a již nebude součástí balíku PHP.5.0.0. Informace o instalaci tohoto PECL rozšíření lze najít v kapitole manuálu nazvané Instalace rozšíření PECL. Další informace, jako nové verze, soubory ke stažení, zdrojové soubory, správcovské informace a CHANGELOG, lze najít zde: » http://pecl.php.net/package/notes.

Varování

This extension is currently not supported, thus looking for a maintainer.

Obsah

notes_body — Open the message msg_number in the specified mailbox on the specified server (leave serv
notes_copy_db — Copy a Lotus Notes database
notes_create_db — Create a Lotus Notes database
notes_create_note — Create a note using form form_name
notes_drop_db — Drop a Lotus Notes database
notes_find_note — Returns a note id found in database_name
notes_header_info — Open the message msg_number in the specified mailbox on the specified server (leave serv
notes_list_msgs — Returns the notes from a selected database_name
notes_mark_read — Mark a note_id as read for the User user_name
notes_mark_unread — Mark a note_id as unread for the User user_name
notes_nav_create — Create a navigator name, in database_name
notes_search — Find notes that match keywords in database_name
notes_unread — Returns the unread note id's for the current User user_name
notes_version — Get the version Lotus Notes
Předcházející | Nahoru | Další
libxml_use_internal_errors | Domů | notes_body


notes_body

(PHP 4 >= 4.0.5)

notes_body — Open the message msg_number in the specified mailbox on the specified server (leave serv

Popis

array notes_body ( string $server, string $mailbox, int $msg_number )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
LXXVII. Lotus Notes Functions | Domů | notes_copy_db


notes_copy_db

(PHP 4 >= 4.0.5)

notes_copy_db — Copy a Lotus Notes database

Popis

bool notes_copy_db ( string $from_database_name, string $to_database_name )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
notes_body | Domů | notes_create_db


notes_create_db

(PHP 4 >= 4.0.5)

notes_create_db — Create a Lotus Notes database

Popis

bool notes_create_db ( string $database_name )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
notes_copy_db | Domů | notes_create_note


notes_create_note

(PHP 4 >= 4.0.5)

notes_create_note — Create a note using form form_name

Popis

bool notes_create_note ( string $database_name, string $form_name )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
notes_create_db | Domů | notes_drop_db


notes_drop_db

(PHP 4 >= 4.0.5)

notes_drop_db — Drop a Lotus Notes database

Popis

bool notes_drop_db ( string $database_name )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
notes_create_note | Domů | notes_find_note


notes_find_note

(PHP 4 >= 4.0.5)

notes_find_note — Returns a note id found in database_name

Popis

int notes_find_note ( string $database_name, string $name [, string $type] )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
notes_drop_db | Domů | notes_header_info


notes_header_info

(PHP 4 >= 4.0.5)

notes_header_info — Open the message msg_number in the specified mailbox on the specified server (leave serv

Popis

object notes_header_info ( string $server, string $mailbox, int $msg_number )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
notes_find_note | Domů | notes_list_msgs


notes_list_msgs

(PHP 4 >= 4.0.5)

notes_list_msgs — Returns the notes from a selected database_name

Popis

bool notes_list_msgs ( string $db )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
notes_header_info | Domů | notes_mark_read


notes_mark_read

(PHP 4 >= 4.0.5)

notes_mark_read — Mark a note_id as read for the User user_name

Popis

bool notes_mark_read ( string $database_name, string $user_name, string $note_id )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
notes_list_msgs | Domů | notes_mark_unread


notes_mark_unread

(PHP 4 >= 4.0.5)

notes_mark_unread — Mark a note_id as unread for the User user_name

Popis

bool notes_mark_unread ( string $database_name, string $user_name, string $note_id )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
notes_mark_read | Domů | notes_nav_create


notes_nav_create

(PHP 4 >= 4.0.5)

notes_nav_create — Create a navigator name, in database_name

Popis

bool notes_nav_create ( string $database_name, string $name )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
notes_mark_unread | Domů | notes_search


notes_search

(PHP 4 >= 4.0.5)

notes_search — Find notes that match keywords in database_name

Popis

array notes_search ( string $database_name, string $keywords )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
notes_nav_create | Domů | notes_unread


notes_unread

(PHP 4 >= 4.0.5)

notes_unread — Returns the unread note id's for the current User user_name

Popis

array notes_unread ( string $database_name, string $user_name )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
notes_search | Domů | notes_version


notes_version

(PHP 4 >= 4.0.5)

notes_version — Get the version Lotus Notes

Popis

float notes_version ( string $database_name )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
notes_unread | Domů | LXXVIII. LZF Functions


NSAPI-specific Functions

Předcházející VI. Reference funkcí Další

CIV. NSAPI-specific Functions

Úvod

These functions are only available when running PHP as a NSAPI module in Netscape/iPlanet/Sun webservers.

Instalace

For PHP installation on Netscape/iPlanet/Sun webservers see the NSAPI section (UNIX, Windows) in the installation chapter.

Konfigurace běhu

The behaviour of the NSAPI PHP module is affected by settings in php.ini. Configuration settings from php.ini may be overridden by additional parameters to the php4_execute call in obj.conf

Tabulka 213. NSAPI configuration options

Name | Default | Changeable | Changelog
nsapi.read_timeout | "60" | PHP_INI_ALL | Available since PHP 4.3.3.

Pro další detaily a definice konstant PHP_INI_*, viz dokumentace k ini_set().

Zde je stručný popis konfiguračních direktiv.

nsapi.read_timeout integer

Sets the time in seconds the plugin is waiting for POST data from the client.

Typy prostředků

Toto rozšíření nemá definován žádný typ prostředku (resource).

Předdefinované konstanty

Toto rozšíření nemá definovány žádné konstanty.

Viz také

NSAPI implements a subset of the functions from the Apache module for maximum compatibility.

Tabulka 214. Apache functions implemented by NSAPI

Apache function (only as alias) | NSAPI function | Description
apache_request_headers() | nsapi_request_headers() | Fetch all HTTP request headers
apache_response_headers() | nsapi_response_headers() | Fetch all HTTP response headers
getallheaders() | nsapi_request_headers() | Fetch all HTTP request headers
virtual() | nsapi_virtual() | Make NSAPI sub-request

Obsah

nsapi_request_headers — Fetch all HTTP request headers
nsapi_response_headers — Fetch all HTTP response headers
nsapi_virtual — Perform an NSAPI sub-request
Předcházející | Nahoru | Další
newt_win_ternary | Domů | nsapi_request_headers


nsapi_request_headers

(PHP 4 >= 4.3.3, PHP 5)

nsapi_request_headers — Fetch all HTTP request headers

Popis

array nsapi_request_headers ( void )

nsapi_request_headers() gets all the HTTP headers in the current request. This is only supported when PHP runs as a NSAPI module.

Poznámka: Prior to PHP 4.3.3, getallheaders() was only available for the Apache servers. After PHP 4.3.3, getallheaders() is an alias for nsapi_request_headers() if you use the NSAPI module.

Poznámka: You can also get at the value of the common CGI variables by reading them from the $_SERVER superglobal, which works whether or not you are using PHP as a NSAPI module.

Návratové hodnoty

Returns an associative array with all the HTTP headers.

Příklady

Příklad 1427. nsapi_request_headers() example

<?php
$headers = nsapi_request_headers();

foreach ($headers as $header => $value) {
  echo "$header: $value <br />\n";
}
?>

Předcházející | Nahoru | Další
CIV. NSAPI-specific Functions | Domů | nsapi_response_headers


nsapi_response_headers

(PHP 4 >= 4.3.3, PHP 5)

nsapi_response_headers — Fetch all HTTP response headers

Popis

array nsapi_response_headers ( void )

Gets all the NSAPI response headers.

Návratové hodnoty

Returns an associative array with all the NSAPI response headers.

Viz také

nsapi_request_headers()
headers_sent()

Předcházející | Nahoru | Další
nsapi_request_headers | Domů | nsapi_virtual


nsapi_virtual

(PHP 4 >= 4.3.3, PHP 5)

nsapi_virtual — Perform an NSAPI sub-request

Popis

bool nsapi_virtual ( string $uri )

nsapi_virtual() is an NSAPI-specific function which is equivalent to <!--#include virtual...--> in SSI (.shtml files). It does an NSAPI sub-request. It is useful for including CGI scripts or .shtml files, or anything else that you'd parse through webserver.

To run the sub-request, all buffers are terminated and flushed to the browser, pending headers are sent too.

You cannot make recursive requests with this function to other PHP scripts. If you want to include PHP scripts, use include() or require().

Poznámka: This function depends on a undocumented feature of the Netscape/iPlanet/Sun webservers. Use phpinfo() to determine if it is available. In the Unix environment it should always work, in Windows it depends on the name of a ns-httpdXX.dll file.

Read the note about subrequests in the NSAPI section (UNIX, Windows) if you experience this problem.

Seznam parametrů

uri

The URI of the script.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
nsapi_response_headers | Domů | CV. Object Aggregation/Composition Functions


ODBC Functions (Unified)

Předcházející VI. Reference funkcí Další

CVIII. ODBC Functions (Unified)

Úvod

In addition to normal ODBC support, the Unified ODBC functions in PHP allow you to access several databases that have borrowed the semantics of the ODBC API to implement their own API. Instead of maintaining multiple database drivers that were all nearly identical, these drivers have been unified into a single set of ODBC functions.

The following databases are supported by the Unified ODBC functions: » Adabas D, » IBM DB2, » iODBC, » Solid, and » Sybase SQL Anywhere.

Poznámka: With the exception of iODBC, there is no ODBC involved when connecting to the above databases. The functions that you use to speak natively to them just happen to share the same names and syntax as the ODBC functions. However, building PHP with iODBC support enables you to use any ODBC-compliant drivers with your PHP applications. More information on iODBC, is available at » www.iodbc.org with the alternative unixODBC available at » www.unixodbc.org.

Požadavky

To access any of the supported databases you need to have the required libraries installed.

Instalace

--with-adabas[=DIR]

Include Adabas D support. DIR is the Adabas base install directory, defaults to /usr/local.

--with-sapdb[=DIR]

Include SAP DB support. DIR is SAP DB base install directory, defaults to /usr/local.

--with-solid[=DIR]

Include Solid support. DIR is the Solid base install directory, defaults to /usr/local/solid.

--with-ibm-db2[=DIR]

Include IBM DB2 support. DIR is the DB2 base install directory, defaults to /home/db2inst1/sqllib.

--with-empress[=DIR]

Include Empress support. DIR is the Empress base install directory, defaults to $EMPRESSPATH. From PHP 4, this option only supports Empress Version 8.60 and above.

--with-empress-bcs[=DIR]

Include Empress Local Access support. DIR is the Empress base install directory, defaults to $EMPRESSPATH. From PHP 4, this option only supports Empress Version 8.60 and above.

--with-birdstep[=DIR]

Include Birdstep support. DIR is the Birdstep base install directory, defaults to /usr/local/birdstep.

--with-custom-odbc[=DIR]

Include a user defined ODBC support. The DIR is ODBC install base directory, which defaults to /usr/local. Make sure to define CUSTOM_ODBC_LIBS and have some odbc.h in your include dirs. E.g., you should define following for Sybase SQL Anywhere 5.5.00 on QNX, prior to run configure script: CPPFLAGS="-DODBC_QNX -DSQLANY_BUG" LDFLAGS=-lunix CUSTOM_ODBC_LIBS="-ldblib -lodbc".

--with-iodbc[=DIR]

Include iODBC support. DIR is the iODBC base install directory, defaults to /usr/local.

--with-esoob[=DIR]

Include Easysoft OOB support. DIR is the OOB base install directory, defaults to /usr/local/easysoft/oob/client.

--with-unixODBC[=DIR]

Include unixODBC support. DIR is the unixODBC base install directory, defaults to /usr/local.

--with-openlink[=DIR]

Include OpenLink ODBC support. DIR is the OpenLink base install directory, defaults to /usr/local. This is the same as iODBC.

--with-dbmaker[=DIR]

Include DBMaker support. DIR is the DBMaker base install directory, defaults to where the latest version of DBMaker is installed (such as /home/dbmaker/3.6).

To disable unified ODBC support in PHP 3 add --disable-unified-odbc to your configure line. Only applicable if iODBC, Adabas, Solid, Velocis or a custom ODBC interface is enabled.

Verze PHP pro Windows má vestavěnou podporu pro toto rozšíření. K použití těchto funkcí není třeba načítat žádná další rozšíření.

Konfigurace běhu

Chování těchto funkcí je ovlivněno nastavením parametrů v php.ini.

Tabulka 218. Unified ODBC Configuration Options

Name | Default | Changeable | Changelog
odbc.default_db * | NULL | PHP_INI_ALL |
odbc.default_user * | NULL | PHP_INI_ALL |
odbc.default_pw * | NULL | PHP_INI_ALL |
odbc.allow_persistent | "1" | PHP_INI_SYSTEM |
odbc.check_persistent | "1" | PHP_INI_SYSTEM |
odbc.max_persistent | "-1" | PHP_INI_SYSTEM |
odbc.max_links | "-1" | PHP_INI_SYSTEM |
odbc.defaultlrl | "4096" | PHP_INI_ALL |
odbc.defaultbinmode | "1" | PHP_INI_ALL |

Poznámka: Entries marked with * are not implemented yet.

Pro další detaily a definice konstant PHP_INI_*, viz dokumentace k ini_set().

Zde je stručný popis konfiguračních direktiv.

odbc.default_db string

ODBC data source to use if none is specified in odbc_connect() or odbc_pconnect().

odbc.default_user string

User name to use if none is specified in odbc_connect() or odbc_pconnect().

odbc.default_pw string

Password to use if none is specified in odbc_connect() or odbc_pconnect().

odbc.allow_persistent boolean

Whether to allow persistent ODBC connections.

odbc.check_persistent boolean

Check that a connection is still valid before reuse.

odbc.max_persistent integer

The maximum number of persistent ODBC connections per process.

odbc.max_links integer

The maximum number of ODBC connections per process, including persistent connections.

odbc.defaultlrl integer

Handling of LONG fields. Specifies the number of bytes returned to variables.

Připoužítí typu integer je hodnota měřena v bytech. Můžete také použít zkrácenou notaci, jak je popsáno tomto FAQ.

odbc.defaultbinmode integer

Handling of binary data.

Typy prostředků

This extension defines two resource types: an ODBC connection identifier and an ODBC result identifier.

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

ODBC_TYPE (integer)
ODBC_BINMODE_PASSTHRU (integer)
ODBC_BINMODE_RETURN (integer)
ODBC_BINMODE_CONVERT (integer)
SQL_ODBC_CURSORS (integer)
SQL_CUR_USE_DRIVER (integer)
SQL_CUR_USE_IF_NEEDED (integer)
SQL_CUR_USE_ODBC (integer)
SQL_CONCURRENCY (integer)
SQL_CONCUR_READ_ONLY (integer)
SQL_CONCUR_LOCK (integer)
SQL_CONCUR_ROWVER (integer)
SQL_CONCUR_VALUES (integer)
SQL_CURSOR_TYPE (integer)
SQL_CURSOR_FORWARD_ONLY (integer)
SQL_CURSOR_KEYSET_DRIVEN (integer)
SQL_CURSOR_DYNAMIC (integer)
SQL_CURSOR_STATIC (integer)
SQL_KEYSET_SIZE (integer)
SQL_CHAR (integer)
SQL_VARCHAR (integer)
SQL_LONGVARCHAR (integer)
SQL_DECIMAL (integer)
SQL_NUMERIC (integer)
SQL_BIT (integer)
SQL_TINYINT (integer)
SQL_SMALLINT (integer)
SQL_INTEGER (integer)
SQL_BIGINT (integer)
SQL_REAL (integer)
SQL_FLOAT (integer)
SQL_DOUBLE (integer)
SQL_BINARY (integer)
SQL_VARBINARY (integer)
SQL_LONGVARBINARY (integer)
SQL_DATE (integer)
SQL_TIME (integer)
SQL_TIMESTAMP (integer)
SQL_TYPE_DATE (integer)
SQL_TYPE_TIME (integer)
SQL_TYPE_TIMESTAMP (integer)
SQL_BEST_ROWID (integer)
SQL_ROWVER (integer)
SQL_SCOPE_CURROW (integer)
SQL_SCOPE_TRANSACTION (integer)
SQL_SCOPE_SESSION (integer)
SQL_NO_NULLS (integer)
SQL_NULLABLE (integer)
SQL_INDEX_UNIQUE (integer)
SQL_INDEX_ALL (integer)
SQL_ENSURE (integer)
SQL_QUICK (integer)

Obsah

odbc_autocommit — Toggle autocommit behaviour
odbc_binmode — Handling of binary column data
odbc_close_all — Close all ODBC connections
odbc_close — Close an ODBC connection
odbc_columnprivileges — Returns a result identifier that can be used to fetch a list of columns and associated privileges
odbc_columns — Lists the column names in specified tables
odbc_commit — Commit an ODBC transaction
odbc_connect — Connect to a datasource
odbc_cursor — Get cursorname
odbc_data_source — Returns information about a current connection
odbc_do — Synonym for odbc_exec()
odbc_error — Get the last error code
odbc_errormsg — Get the last error message
odbc_exec — Prepare and execute a SQL statement
odbc_execute — Execute a prepared statement
odbc_fetch_array — Fetch a result row as an associative array
odbc_fetch_into — Fetch one result row into array
odbc_fetch_object — Fetch a result row as an object
odbc_fetch_row — Fetch a row
odbc_field_len — Get the length (precision) of a field
odbc_field_name — Get the columnname
odbc_field_num — Return column number
odbc_field_precision — Synonym for odbc_field_len()
odbc_field_scale — Get the scale of a field
odbc_field_type — Datatype of a field
odbc_foreignkeys — Returns a list of foreign keys in the specified table or a list of foreign keys in other tables that refer to the primary key in the specified table
odbc_free_result — Free resources associated with a result
odbc_gettypeinfo — Returns a result identifier containing information about data types supported by the data source
odbc_longreadlen — Handling of LONG columns
odbc_next_result — Checks if multiple results are available
odbc_num_fields — Number of columns in a result
odbc_num_rows — Number of rows in a result
odbc_pconnect — Open a persistent database connection
odbc_prepare — Prepares a statement for execution
odbc_primarykeys — Returns a result identifier that can be used to fetch the column names that comprise the primary key for a table
odbc_procedurecolumns — Retrieve information about parameters to procedures
odbc_procedures — Get the list of procedures stored in a specific data source
odbc_result_all — Print result as HTML table
odbc_result — Get result data
odbc_rollback — Rollback a transaction
odbc_setoption — Adjust ODBC settings
odbc_specialcolumns — Returns either the optimal set of columns that uniquely identifies a row in the table or columns that are automatically updated when any value in the row is updated by a transaction
odbc_statistics — Retrieve statistics about a table
odbc_tableprivileges — Lists tables and the privileges associated with each table
odbc_tables — Get the list of table names stored in a specific data source
Předcházející | Nahoru | Další
ociwritetemporarylob | Domů | odbc_autocommit


odbc_autocommit

(PHP 4, PHP 5)

odbc_autocommit — Toggle autocommit behaviour

Description

mixed odbc_autocommit ( resource $connection_id [, bool $OnOff] )

Without the OnOff parameter, this function returns auto-commit status for connection_id. Non-zero is returned if auto-commit is on, 0 if it is off, or FALSE if an error occurs.

If OnOff is TRUE, auto-commit is enabled, if it is FALSE auto-commit is disabled. Returns TRUE on success, FALSE on failure.

By default, auto-commit is on for a connection. Disabling auto-commit is equivalent with starting a transaction.

See also odbc_commit() and odbc_rollback().

Předcházející | Nahoru | Další
CVIII. ODBC Functions (Unified) | Domů | odbc_binmode


odbc_binmode

(PHP 4, PHP 5)

odbc_binmode — Handling of binary column data

Description

bool odbc_binmode ( resource $result_id, int $mode )

(ODBC SQL types affected: BINARY, VARBINARY, LONGVARBINARY)

  • ODBC_BINMODE_PASSTHRU: Passthru BINARY data
  • ODBC_BINMODE_RETURN: Return as is
  • ODBC_BINMODE_CONVERT: Convert to char and return

When binary SQL data is converted to character C data, each byte (8 bits) of source data is represented as two ASCII characters. These characters are the ASCII character representation of the number in its hexadecimal form. For example, a binary 00000001 is converted to "01" and a binary 11111111 is converted to "FF".

Tabulka 219. LONGVARBINARY handling

binmode | longreadlen | result
ODBC_BINMODE_PASSTHRU | 0 | passthru
ODBC_BINMODE_RETURN | 0 | passthru
ODBC_BINMODE_CONVERT | 0 | passthru
ODBC_BINMODE_PASSTHRU | 0 | passthru
ODBC_BINMODE_PASSTHRU | >0 | passthru
ODBC_BINMODE_RETURN | >0 | return as is
ODBC_BINMODE_CONVERT | >0 | return as char

If odbc_fetch_into() is used, passthru means that an empty string is returned for these columns.

If result_id is 0, the settings apply as default for new results.

Poznámka: Default for longreadlen is 4096 and binmode defaults to ODBC_BINMODE_RETURN. Handling of binary long columns is also affected by odbc_longreadlen()

Předcházející | Nahoru | Další
odbc_autocommit | Domů | odbc_close_all


odbc_close_all

(PHP 4, PHP 5)

odbc_close_all — Close all ODBC connections

Description

void odbc_close_all ( void )

odbc_close_all() will close down all connections to database server(s).

Poznámka: This function will fail if there are open transactions on a connection. This connection will remain open in this case.

Předcházející | Nahoru | Další
odbc_binmode | Domů | odbc_close


odbc_close

(PHP 4, PHP 5)

odbc_close — Close an ODBC connection

Description

void odbc_close ( resource $connection_id )

odbc_close() will close down the connection to the database server associated with the given connection identifier.

Poznámka: This function will fail if there are open transactions on this connection. The connection will remain open in this case.

Předcházející | Nahoru | Další
odbc_close_all | Domů | odbc_columnprivileges


odbc_columnprivileges

(PHP 4, PHP 5)

odbc_columnprivileges — Returns a result identifier that can be used to fetch a list of columns and associated privileges

Description

resource odbc_columnprivileges ( resource $connection_id, string $qualifier, string $owner, string $table_name, string $column_name )

Lists columns and associated privileges for the given table. Returns an ODBC result identifier or FALSE on failure.

The result set has the following columns:

  • TABLE_QUALIFIER
  • TABLE_OWNER
  • TABLE_NAME
  • GRANTOR
  • GRANTEE
  • PRIVILEGE
  • IS_GRANTABLE

The result set is ordered by TABLE_QUALIFIER, TABLE_OWNER and TABLE_NAME.

The column_name argument accepts search patterns ('%' to match zero or more characters and '_' to match a single character).

Předcházející | Nahoru | Další
odbc_close | Domů | odbc_columns


odbc_columns

(PHP 4, PHP 5)

odbc_columns — Lists the column names in specified tables

Description

resource odbc_columns ( resource $connection_id [, string $qualifier [, string $schema [, string $table_name [, string $column_name]]]] )

Lists all columns in the requested range. Returns an ODBC result identifier containing the information or FALSE on failure.

The result set has the following columns:

  • TABLE_QUALIFIER
  • TABLE_SCHEM
  • TABLE_NAME
  • COLUMN_NAME
  • DATA_TYPE
  • TYPE_NAME
  • PRECISION
  • LENGTH
  • SCALE
  • RADIX
  • NULLABLE
  • REMARKS

The result set is ordered by TABLE_QUALIFIER, TABLE_SCHEM and TABLE_NAME.

The schema, table_name and column_name arguments accept search patterns ('%' to match zero or more characters and '_' to match a single character).

See also odbc_columnprivileges() to retrieve associated privileges.

Předcházející | Nahoru | Další
odbc_columnprivileges | Domů | odbc_commit


odbc_commit

(PHP 4, PHP 5)

odbc_commit — Commit an ODBC transaction

Description

bool odbc_commit ( resource $connection_id )

odbc_commit() commits all pending transactions on the connection_id connection. Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
odbc_columns | Domů | odbc_connect


odbc_connect

(PHP 4, PHP 5)

odbc_connect — Connect to a datasource

Description

resource odbc_connect ( string $dsn, string $user, string $password [, int $cursor_type] )

Returns an ODBC connection id or 0 (FALSE) on error.

The connection id returned by this functions is needed by other ODBC functions. You can have multiple connections open at once as long as they either use different db or different credentials. The optional fourth parameter sets the type of cursor to be used for this connection. This parameter is not normally needed, but can be useful for working around problems with some ODBC drivers.

With some ODBC drivers, executing a complex stored procedure may fail with an error similar to: "Cannot open a cursor on a stored procedure that has anything other than a single select statement in it". Using SQL_CUR_USE_ODBC may avoid that error. Also, some drivers don't support the optional row_number parameter in odbc_fetch_row(). SQL_CUR_USE_ODBC might help in that case, too.

The following constants are defined for cursortype:

  • SQL_CUR_USE_IF_NEEDED
  • SQL_CUR_USE_ODBC
  • SQL_CUR_USE_DRIVER
  • SQL_CUR_DEFAULT

For persistent connections see odbc_pconnect().

Předcházející | Nahoru | Další
odbc_commit | Domů | odbc_cursor


odbc_cursor

(PHP 4, PHP 5)

odbc_cursor — Get cursorname

Description

string odbc_cursor ( resource $result_id )

odbc_cursor will return a cursorname for the given result_id.

Předcházející | Nahoru | Další
odbc_connect | Domů | odbc_data_source


odbc_data_source

(PHP 4 >= 4.3.0, PHP 5)

odbc_data_source — Returns information about a current connection

Description

array odbc_data_source ( resource $connection_id, int $fetch_type )

Returns FALSE on error, and an array upon success.

This function will return the list of available DNS (after calling it several times). The connection_id is required to be a valid ODBC connection. The fetch_type can be one of two constant types: SQL_FETCH_FIRST, SQL_FETCH_NEXT. Use SQL_FETCH_FIRST the first time this function is called, thereafter use the SQL_FETCH_NEXT.

Předcházející | Nahoru | Další
odbc_cursor | Domů | odbc_do


odbc_do

(PHP 4, PHP 5)

odbc_do — Synonym for odbc_exec()

Description

resource odbc_do ( resource $conn_id, string $query )

odbc_do() will execute a query on the given connection.

Předcházející | Nahoru | Další
odbc_data_source | Domů | odbc_error


odbc_error

(PHP 4 >= 4.0.5, PHP 5)

odbc_error — Get the last error code

Description

string odbc_error ( [resource $connection_id] )

Returns a six-digit ODBC state, or an empty string if there has been no errors. If connection_id is specified, the last state of that connection is returned, else the last state of any connection is returned.

This function returns meaningful value only if last odbc query failed (i.e. odbc_exec() returned FALSE).

See also: odbc_errormsg() and odbc_exec().

Předcházející | Nahoru | Další
odbc_do | Domů | odbc_errormsg


odbc_errormsg

(PHP 4 >= 4.0.5, PHP 5)

odbc_errormsg — Get the last error message

Description

string odbc_errormsg ( [resource $connection_id] )

Returns a string containing the last ODBC error message, or an empty string if there has been no errors. If connection_id is specified, the last state of that connection is returned, else the last state of any connection is returned.

This function returns meaningful value only if last odbc query failed (i.e. odbc_exec() returned FALSE).

See also: odbc_error() and odbc_exec().

Předcházející | Nahoru | Další
odbc_error | Domů | odbc_exec


odbc_exec

(PHP 4, PHP 5)

odbc_exec — Prepare and execute a SQL statement

Description

resource odbc_exec ( resource $connection_id, string $query_string [, int $flags] )

Returns FALSE on error. Returns an ODBC result identifier if the SQL command was executed successfully.

odbc_exec() will send an SQL statement to the database server specified by connection_id. This parameter must be a valid identifier returned by odbc_connect() or odbc_pconnect().

See also: odbc_prepare() and odbc_execute() for multiple execution of SQL statements.

Předcházející | Nahoru | Další
odbc_errormsg | Domů | odbc_execute


odbc_execute

(PHP 4, PHP 5)

odbc_execute — Execute a prepared statement

Description

bool odbc_execute ( resource $result_id [, array $parameters_array] )

Executes a statement prepared with odbc_prepare().Vrací TRUE při úspěchu, FALSE při selhání. The array parameters_array only needs to be given if you really have parameters in your statement.

Parameters in parameter_array will be substituted for placeholders in the prepared statement in order. Elements of this array will be converted to strings by calling this function.

Any parameters in parameter_array which start and end with single quotes will be taken as the name of a file to read and send to the database server as the data for the appropriate placeholder.

Poznámka: As of PHP 4.1.1, this file reading functionality has the following restrictions:

  • File reading is not subject to any bezpečný režim or open-basedir restrictions. This is fixed in PHP 4.2.0.
  • Remote files are not supported.
  • If you wish to store a string which actually begins and ends with single quotes, you must add a space or other non-single-quote character to the beginning or end of the parameter, which will prevent the parameter from being taken as a file name. If this is not an option, then you must use another mechanism to store the string, such as executing the query directly with odbc_exec()).

Předcházející | Nahoru | Další
odbc_exec | Domů | odbc_fetch_array


odbc_fetch_array

(PHP 4 >= 4.0.2, PHP 5)

odbc_fetch_array — Fetch a result row as an associative array

Popis

array odbc_fetch_array ( resource $result [, int $rownumber] )

Fetch an associative array from an ODBC query. See the changelog below for when this function is available.

Seznam parametrů

result

The result resource from odbc_exec().

rownumber

Optionally choose which row number to retrieve.

Návratové hodnoty

Returns an array that corresponds to the fetched row, or FALSE if there are no more rows.

ChangeLog (záznam změn)

Verze | Popis
4.3.3 | This function exists when compiled with IBM DB2 or UnixODBC support.
4.3.2 | This function exists when compiled for Windows.
4.0.2 | This function exists when compiled with DBMaker support.

Viz také

odbc_fetch_row()
odbc_fetch_object()
odbc_num_rows()

Předcházející | Nahoru | Další
odbc_execute | Domů | odbc_fetch_into


odbc_fetch_into

(PHP 4, PHP 5)

odbc_fetch_into — Fetch one result row into array

Description

int odbc_fetch_into ( resource $result_id, array &$result_array [, int $rownumber] )
bool odbc_fetch_into ( resource $result_id [, int $rownumber, array &$result_array] )

Returns the number of columns in the result; FALSE on error. result_array must be passed by reference, but it can be of any type since it will be converted to type array. The array will contain the column values starting at array index 0.

As of PHP 4.0.5 the result_array does not need to be passed by reference any longer.

As of PHP 4.0.6 the rownumber cannot be passed as a constant, but rather as a variable.

As of PHP 4.2.0 the result_array and rownumber have been swapped. This allows the rownumber to be a constant again. This change will also be the last one to this function.

Příklad 1465. odbc_fetch_into() pre 4.0.6 example

<?php
$rc = odbc_fetch_into($res_id, $my_array);
?>

or

<?php
$rc = odbc_fetch_into($res_id, $row, $my_array);

$rc = odbc_fetch_into($res_id, 1, $my_array);
?>

Příklad 1466. odbc_fetch_into() 4.0.6 example

<?php
$rc = odbc_fetch_into($res_id, $my_array);
?>

or

<?php
$row = 1;
$rc = odbc_fetch_into($res_id, $row, $my_array);
?>

Příklad 1467. odbc_fetch_into() 4.2.0 example

<?php
$rc = odbc_fetch_into($res_id, $my_array);
?>

or

<?php
$rc = odbc_fetch_into($res_id, $my_array, 2);
?>

Předcházející | Nahoru | Další
odbc_fetch_array | Domů | odbc_fetch_object


odbc_fetch_object

(PHP 4 >= 4.0.2, PHP 5)

odbc_fetch_object — Fetch a result row as an object

Popis

object odbc_fetch_object ( resource $result [, int $rownumber] )

Fetch an object from an ODBC query. See the changelog below for when this function is available.

Seznam parametrů

result

The result resource from odbc_exec().

rownumber

Optionally choose which row number to retrieve.

Návratové hodnoty

Returns an object that corresponds to the fetched row, or FALSE if there are no more rows.

ChangeLog (záznam změn)

Verze | Popis
4.3.3 | This function exists when compiled with IBM DB2 or UnixODBC support.
4.3.2 | This function exists when compiled for Windows.
4.0.2 | This function exists when compiled with DBMaker support.

Viz také

odbc_fetch_row()
odbc_fetch_array()
odbc_num_rows()

Předcházející | Nahoru | Další
odbc_fetch_into | Domů | odbc_fetch_row


odbc_fetch_row

(PHP 4, PHP 5)

odbc_fetch_row — Fetch a row

Description

bool odbc_fetch_row ( resource $result_id [, int $row_number] )

If odbc_fetch_row() was successful (there was a row), TRUE is returned. If there are no more rows, FALSE is returned.

odbc_fetch_row() fetches a row of the data that was returned by odbc_do() / odbc_exec(). After odbc_fetch_row() is called, the fields of that row can be accessed with odbc_result().

If row_number is not specified, odbc_fetch_row() will try to fetch the next row in the result set. Calls to odbc_fetch_row() with and without row_number can be mixed.

To step through the result more than once, you can call odbc_fetch_row() with row_number 1, and then continue doing odbc_fetch_row() without row_number to review the result. If a driver doesn't support fetching rows by number, the row_number parameter is ignored.

Předcházející | Nahoru | Další
odbc_fetch_object | Domů | odbc_field_len


odbc_field_len

(PHP 4, PHP 5)

odbc_field_len — Get the length (precision) of a field

Description

int odbc_field_len ( resource $result_id, int $field_number )

odbc_field_len() will return the length of the field referenced by number in the given ODBC result identifier. Field numbering starts at 1.

See also: odbc_field_scale() to get the scale of a floating point number.

Předcházející | Nahoru | Další
odbc_fetch_row | Domů | odbc_field_name


odbc_field_name

(PHP 4, PHP 5)

odbc_field_name — Get the columnname

Description

string odbc_field_name ( resource $result_id, int $field_number )

odbc_field_name() will return the name of the field occupying the given column number in the given ODBC result identifier. Field numbering starts at 1. FALSE is returned on error.

Předcházející | Nahoru | Další
odbc_field_len | Domů | odbc_field_num


odbc_field_num

(PHP 4, PHP 5)

odbc_field_num — Return column number

Description

int odbc_field_num ( resource $result_id, string $field_name )

odbc_field_num() will return the number of the column slot that corresponds to the named field in the given ODBC result identifier. Field numbering starts at 1. FALSE is returned on error.

Předcházející | Nahoru | Další
odbc_field_name | Domů | odbc_field_precision


odbc_field_precision

(PHP 4, PHP 5)

odbc_field_precision — Synonym for odbc_field_len()

Description

int odbc_field_precision ( resource $result_id, int $field_number )

odbc_field_precision() will return the precision of the field referenced by number in the given ODBC result identifier.

See also: odbc_field_scale() to get the scale of a floating point number.

Předcházející | Nahoru | Další
odbc_field_num | Domů | odbc_field_scale


odbc_field_scale

(PHP 4, PHP 5)

odbc_field_scale — Get the scale of a field

Description

int odbc_field_scale ( resource $result_id, int $field_number )

odbc_field_scale() will return the scale of the field referenced by number in the given ODBC result identifier.

Předcházející | Nahoru | Další
odbc_field_precision | Domů | odbc_field_type


odbc_field_type

(PHP 4, PHP 5)

odbc_field_type — Datatype of a field

Description

string odbc_field_type ( resource $result_id, int $field_number )

odbc_field_type() will return the SQL type of the field referenced by number in the given ODBC result identifier. Field numbering starts at 1.

Předcházející | Nahoru | Další
odbc_field_scale | Domů | odbc_foreignkeys


odbc_foreignkeys

(PHP 4, PHP 5)

odbc_foreignkeys — Returns a list of foreign keys in the specified table or a list of foreign keys in other tables that refer to the primary key in the specified table

Description

resource odbc_foreignkeys ( resource $connection_id, string $pk_qualifier, string $pk_owner, string $pk_table, string $fk_qualifier, string $fk_owner, string $fk_table )

odbc_foreignkeys() retrieves information about foreign keys. Returns an ODBC result identifier or FALSE on failure.

The result set has the following columns:

  • PKTABLE_QUALIFIER
  • PKTABLE_OWNER
  • PKTABLE_NAME
  • PKCOLUMN_NAME
  • FKTABLE_QUALIFIER
  • FKTABLE_OWNER
  • FKTABLE_NAME
  • FKCOLUMN_NAME
  • KEY_SEQ
  • UPDATE_RULE
  • DELETE_RULE
  • FK_NAME
  • PK_NAME

If pk_table contains a table name, odbc_foreignkeys() returns a result set containing the primary key of the specified table and all of the foreign keys that refer to it.

If fk_table contains a table name, odbc_foreignkeys() returns a result set containing all of the foreign keys in the specified table and the primary keys (in other tables) to which they refer.

If both pk_table and fk_table contain table names, odbc_foreignkeys() returns the foreign keys in the table specified in fk_table that refer to the primary key of the table specified in pk_table. This should be one key at most.

Předcházející | Nahoru | Další
odbc_field_type | Domů | odbc_free_result


odbc_free_result

(PHP 4, PHP 5)

odbc_free_result — Free resources associated with a result

Description

bool odbc_free_result ( resource $result_id )

Always returns TRUE.

odbc_free_result() only needs to be called if you are worried about using too much memory while your script is running. All result memory will automatically be freed when the script is finished. But, if you are sure you are not going to need the result data anymore in a script, you may call odbc_free_result(), and the memory associated with result_id will be freed.

Poznámka: If auto-commit is disabled (see odbc_autocommit()) and you call odbc_free_result() before committing, all pending transactions are rolled back.

Předcházející | Nahoru | Další
odbc_foreignkeys | Domů | odbc_gettypeinfo


odbc_gettypeinfo

(PHP 4, PHP 5)

odbc_gettypeinfo — Returns a result identifier containing information about data types supported by the data source

Description

resource odbc_gettypeinfo ( resource $connection_id [, int $data_type] )

Retrieves information about data types supported by the data source. Returns an ODBC result identifier or FALSE on failure. The optional argument data_type can be used to restrict the information to a single data type.

The result set has the following columns:

  • TYPE_NAME
  • DATA_TYPE
  • PRECISION
  • LITERAL_PREFIX
  • LITERAL_SUFFIX
  • CREATE_PARAMS
  • NULLABLE
  • CASE_SENSITIVE
  • SEARCHABLE
  • UNSIGNED_ATTRIBUTE
  • MONEY
  • AUTO_INCREMENT
  • LOCAL_TYPE_NAME
  • MINIMUM_SCALE
  • MAXIMUM_SCALE

The result set is ordered by DATA_TYPE and TYPE_NAME.

Předcházející | Nahoru | Další
odbc_free_result | Domů | odbc_longreadlen


odbc_longreadlen

(PHP 4, PHP 5)

odbc_longreadlen — Handling of LONG columns

Description

bool odbc_longreadlen ( resource $result_id, int $length )

(ODBC SQL types affected: LONG, LONGVARBINARY) The number of bytes returned to PHP is controlled by the parameter length. If it is set to 0, Long column data is passed through to the client.

Poznámka: Handling of LONGVARBINARY columns is also affected by odbc_binmode().

Předcházející | Nahoru | Další
odbc_gettypeinfo | Domů | odbc_next_result


odbc_next_result

(PHP 4 >= 4.0.5, PHP 5)

odbc_next_result — Checks if multiple results are available

Description

bool odbc_next_result ( resource $result_id )

odbc_next_result() returns TRUE if there are more result sets available as well as allowing access to the next result set via odbc_fetch_array(), odbc_fetch_row(), odbc_result(), etc.

This function returns FALSE on error.

The argument is a valid result identifier returned by odbc_exec().

Příklad 1468. odbc_next_result()

<?php
$r_Connection = odbc_connect($dsn, $username, $password);

$s_SQL = <<<END_SQL
SELECT 'A'
SELECT 'B'
SELECT 'C'
END_SQL;

$r_Results = odbc_exec($r_Connection, $s_SQL);

$a_Row1 = odbc_fetch_array($r_Results);
$a_Row2 = odbc_fetch_array($r_Results);
echo "Dump first result set";
var_dump($a_Row1, $a_Row2);

echo "Get second results set ";
var_dump(odbc_next_result($r_Results));

$a_Row1 = odbc_fetch_array($r_Results);
$a_Row2 = odbc_fetch_array($r_Results);
echo "Dump second result set ";
var_dump($a_Row1, $a_Row2);

echo "Get third results set ";
var_dump(odbc_next_result($r_Results));

$a_Row1 = odbc_fetch_array($r_Results);
$a_Row2 = odbc_fetch_array($r_Results);
echo "Dump third result set ";
var_dump($a_Row1, $a_Row2);

echo "Try for a fourth result set ";
var_dump(odbc_next_result($r_Results));
?>

Výše uvedený příklad vypíše:

Dump first result set array(1) {
  ["A"]=>
  string(1) "A"
}
bool(false)
Get second results set bool(true)
Dump second result set array(1) {
  ["B"]=>
  string(1) "B"
}
bool(false)
Get third results set bool(true)
Dump third result set array(1) {
  ["C"]=>
  string(1) "C"
}
bool(false)
Try for a fourth result set bool(false)

Předcházející | Nahoru | Další
odbc_longreadlen | Domů | odbc_num_fields


odbc_num_fields

(PHP 4, PHP 5)

odbc_num_fields — Number of columns in a result

Description

int odbc_num_fields ( resource $result_id )

odbc_num_fields() will return the number of fields (columns) in an ODBC result. This function will return -1 on error. The argument is a valid result identifier returned by odbc_exec().

Předcházející | Nahoru | Další
odbc_next_result | Domů | odbc_num_rows


odbc_num_rows

(PHP 4, PHP 5)

odbc_num_rows — Number of rows in a result

Description

int odbc_num_rows ( resource $result_id )

odbc_num_rows() will return the number of rows in an ODBC result. This function will return -1 on error. For INSERT, UPDATE and DELETE statements odbc_num_rows() returns the number of rows affected. For a SELECT clause this can be the number of rows available.

Note: Using odbc_num_rows() to determine the number of rows available after a SELECT will return -1 with many drivers.

Předcházející | Nahoru | Další
odbc_num_fields | Domů | odbc_pconnect


odbc_pconnect

(PHP 4, PHP 5)

odbc_pconnect — Open a persistent database connection

Description

resource odbc_pconnect ( string $dsn, string $user, string $password [, int $cursor_type] )

Returns an ODBC connection id or 0 (FALSE) on error. This function is much like odbc_connect(), except that the connection is not really closed when the script has finished. Future requests for a connection with the same dsn, user, password combination (via odbc_connect() and odbc_pconnect()) can reuse the persistent connection.

Poznámka: Persistent connections have no effect if PHP is used as a CGI program.

For information about the optional cursor_type parameter see the odbc_connect() function. For more information on persistent connections, refer to the PHP FAQ.

Předcházející | Nahoru | Další
odbc_num_rows | Domů | odbc_prepare


odbc_prepare

(PHP 4, PHP 5)

odbc_prepare — Prepares a statement for execution

Description

resource odbc_prepare ( resource $connection_id, string $query_string )

Returns FALSE on error.

Returns an ODBC result identifier if the SQL command was prepared successfully. The result identifier can be used later to execute the statement with odbc_execute().

Some databases (such as IBM DB2, MS SQL Server, and Oracle) support stored procedures that accept parameters of type IN, INOUT, and OUT as defined by the ODBC specification. However, the Unified ODBC driver currently only supports parameters of type IN to stored procedures.

In the following code, $res will only be valid if all three parameters to myproc are IN parameters: <?php
$a = 1;
$b = 2;
$c = 3;
$stmt = odbc_prepare($conn, 'CALL myproc(?,?,?)');
$res = odbc_execute($stmt, array($a, $b, $c));
?> If you need to call a stored procedure using INOUT or OUT parameters, the recommended workaround is to use a native extension for your database (for example, mssql for MS SQL Server, or oci8 for Oracle).

Předcházející | Nahoru | Další
odbc_pconnect | Domů | odbc_primarykeys


odbc_primarykeys

(PHP 4, PHP 5)

odbc_primarykeys — Returns a result identifier that can be used to fetch the column names that comprise the primary key for a table

Description

resource odbc_primarykeys ( resource $connection_id, string $qualifier, string $owner, string $table )

Returns the column names that comprise the primary key for a table. Returns an ODBC result identifier or FALSE on failure.

The result set has the following columns:

  • TABLE_QUALIFIER
  • TABLE_OWNER
  • TABLE_NAME
  • COLUMN_NAME
  • KEY_SEQ
  • PK_NAME

Předcházející | Nahoru | Další
odbc_prepare | Domů | odbc_procedurecolumns


odbc_procedurecolumns

(PHP 4, PHP 5)

odbc_procedurecolumns — Retrieve information about parameters to procedures

Description

resource odbc_procedurecolumns ( resource $connection_id [, string $qualifier, string $owner, string $proc, string $column] )

Returns the list of input and output parameters, as well as the columns that make up the result set for the specified procedures. Returns an ODBC result identifier or FALSE on failure.

The result set has the following columns:

  • PROCEDURE_QUALIFIER
  • PROCEDURE_OWNER
  • PROCEDURE_NAME
  • COLUMN_NAME
  • COLUMN_TYPE
  • DATA_TYPE
  • TYPE_NAME
  • PRECISION
  • LENGTH
  • SCALE
  • RADIX
  • NULLABLE
  • REMARKS

The result set is ordered by PROCEDURE_QUALIFIER, PROCEDURE_OWNER, PROCEDURE_NAME and COLUMN_TYPE.

The owner, proc and column arguments accept search patterns ('%' to match zero or more characters and '_' to match a single character).

Předcházející | Nahoru | Další
odbc_primarykeys | Domů | odbc_procedures


odbc_procedures

(PHP 4, PHP 5)

odbc_procedures — Get the list of procedures stored in a specific data source

Description

resource odbc_procedures ( resource $connection_id [, string $qualifier, string $owner, string $name] )

Lists all procedures in the requested range. Returns an ODBC result identifier containing the information or FALSE on failure.

The result set has the following columns:

  • PROCEDURE_QUALIFIER
  • PROCEDURE_OWNER
  • PROCEDURE_NAME
  • NUM_INPUT_PARAMS
  • NUM_OUTPUT_PARAMS
  • NUM_RESULT_SETS
  • REMARKS
  • PROCEDURE_TYPE

The owner and name arguments accept search patterns ('%' to match zero or more characters and '_' to match a single character).

Předcházející | Nahoru | Další
odbc_procedurecolumns | Domů | odbc_result_all


odbc_result_all

(PHP 4, PHP 5)

odbc_result_all — Print result as HTML table

Description

int odbc_result_all ( resource $result_id [, string $format] )

Returns the number of rows in the result or FALSE on error.

odbc_result_all() will print all rows from a result identifier produced by odbc_exec(). The result is printed in HTML table format. With the optional string argument format, additional overall table formatting can be done.

Předcházející | Nahoru | Další
odbc_procedures | Domů | odbc_result


odbc_result

(PHP 4, PHP 5)

odbc_result — Get result data

Description

mixed odbc_result ( resource $result_id, mixed $field )

Returns the string contents of the field, FALSE on error, NULL for NULL data, or TRUE for binary data.

field can either be an integer containing the column number of the field you want; or it can be a string containing the name of the field. For example:

<?php
$item_3 = odbc_result($Query_ID, 3);
$item_val = odbc_result($Query_ID, "val");
?>

The first call to odbc_result() returns the value of the third field in the current record of the query result. The second function call to odbc_result() returns the value of the field whose field name is "val" in the current record of the query result. An error occurs if a column number parameter for a field is less than one or exceeds the number of columns (or fields) in the current record. Similarly, an error occurs if a field with a name that is not one of the fieldnames of the table(s) that is(are) being queried.

Field indices start from 1. Regarding the way binary or long column data is returned refer to odbc_binmode() and odbc_longreadlen().

Předcházející | Nahoru | Další
odbc_result_all | Domů | odbc_rollback


odbc_rollback

(PHP 4, PHP 5)

odbc_rollback — Rollback a transaction

Description

bool odbc_rollback ( resource $connection_id )

Rolls back all pending statements on connection_id. Returns TRUE on success, FALSE on failure.

Předcházející | Nahoru | Další
odbc_result | Domů | odbc_setoption


odbc_setoption

(PHP 4, PHP 5)

odbc_setoption — Adjust ODBC settings

Description

bool odbc_setoption ( resource $id, int $function, int $option, int $param )

This function allows fiddling with the ODBC options for a particular connection or query result. It was written to help find work around to problems in quirky ODBC drivers. You should probably only use this function if you are an ODBC programmer and understand the effects the various options will have. You will certainly need a good ODBC reference to explain all the different options and values that can be used. Different driver versions support different options.

Because the effects may vary depending on the ODBC driver, use of this function in scripts to be made publicly available is strongly discouraged. Also, some ODBC options are not available to this function because they must be set before the connection is established or the query is prepared. However, if on a particular job it can make PHP work so your boss doesn't tell you to use a commercial product, that's all that really matters.

Vrací TRUE při úspěchu, FALSE při selhání.

id is a connection id or result id on which to change the settings.For SQLSetConnectOption(), this is a connection id. For SQLSetStmtOption(), this is a result id.

Function is the ODBC function to use. The value should be 1 for SQLSetConnectOption() and 2 for SQLSetStmtOption().

Parameter option is the option to set.

Parameter param is the value for the given option.

Příklad 1469. ODBC Setoption Examples

<?php
// 1. Option 102 of SQLSetConnectOption() is SQL_AUTOCOMMIT.
//    Value 1 of SQL_AUTOCOMMIT is SQL_AUTOCOMMIT_ON.
//    This example has the same effect as
//    odbc_autocommit($conn, true);

odbc_setoption($conn, 1, 102, 1);

// 2. Option 0 of SQLSetStmtOption() is SQL_QUERY_TIMEOUT.
//    This example sets the query to timeout after 30 seconds.

$result = odbc_prepare($conn, $sql);
odbc_setoption($result, 2, 0, 30);
odbc_execute($result);
?>

Předcházející | Nahoru | Další
odbc_rollback | Domů | odbc_specialcolumns


odbc_specialcolumns

(PHP 4, PHP 5)

odbc_specialcolumns — Returns either the optimal set of columns that uniquely identifies a row in the table or columns that are automatically updated when any value in the row is updated by a transaction

Description

resource odbc_specialcolumns ( resource $connection_id, int $type, string $qualifier, string $owner, string $table, int $scope, int $nullable )

When the type argument is SQL_BEST_ROWID, odbc_specialcolumns() returns the column or columns that uniquely identify each row in the table.

When the type argument is SQL_ROWVER, odbc_specialcolumns() returns the column or columns in the specified table, if any, that are automatically updated by the data source when any value in the row is updated by any transaction.

Returns an ODBC result identifier or FALSE on failure.

The result set has the following columns:

  • SCOPE
  • COLUMN_NAME
  • DATA_TYPE
  • TYPE_NAME
  • PRECISION
  • LENGTH
  • SCALE
  • PSEUDO_COLUMN

The result set is ordered by SCOPE.

Předcházející | Nahoru | Další
odbc_setoption | Domů | odbc_statistics


odbc_statistics

(PHP 4, PHP 5)

odbc_statistics — Retrieve statistics about a table

Description

resource odbc_statistics ( resource $connection_id, string $qualifier, string $owner, string $table_name, int $unique, int $accuracy )

Get statistics about a table and its indexes. Returns an ODBC result identifier or FALSE on failure.

The result set has the following columns:

  • TABLE_QUALIFIER
  • TABLE_OWNER
  • TABLE_NAME
  • NON_UNIQUE
  • INDEX_QUALIFIER
  • INDEX_NAME
  • TYPE
  • SEQ_IN_INDEX
  • COLUMN_NAME
  • COLLATION
  • CARDINALITY
  • PAGES
  • FILTER_CONDITION

The result set is ordered by NON_UNIQUE, TYPE, INDEX_QUALIFIER, INDEX_NAME and SEQ_IN_INDEX.

Předcházející | Nahoru | Další
odbc_specialcolumns | Domů | odbc_tableprivileges


odbc_tableprivileges

(PHP 4, PHP 5)

odbc_tableprivileges — Lists tables and the privileges associated with each table

Description

resource odbc_tableprivileges ( resource $connection_id, string $qualifier, string $owner, string $name )

Lists tables in the requested range and the privileges associated with each table. Returns an ODBC result identifier or FALSE on failure.

The result set has the following columns:

  • TABLE_QUALIFIER
  • TABLE_OWNER
  • TABLE_NAME
  • GRANTOR
  • GRANTEE
  • PRIVILEGE
  • IS_GRANTABLE

The result set is ordered by TABLE_QUALIFIER, TABLE_OWNER and TABLE_NAME.

The owner and name arguments accept search patterns ('%' to match zero or more characters and '_' to match a single character).

Předcházející | Nahoru | Další
odbc_statistics | Domů | odbc_tables


odbc_tables

(PHP 4, PHP 5)

odbc_tables — Get the list of table names stored in a specific data source

Description

resource odbc_tables ( resource $connection_id [, string $qualifier [, string $owner [, string $name [, string $types]]]] )

Lists all tables in the requested range. Returns an ODBC result identifier containing the information or FALSE on failure.

The result set has the following columns:

  • TABLE_QUALIFIER
  • TABLE_OWNER
  • TABLE_NAME
  • TABLE_TYPE
  • REMARKS

The result set is ordered by TABLE_TYPE, TABLE_QUALIFIER, TABLE_OWNER and TABLE_NAME.

The owner and name arguments accept search patterns ('%' to match zero or more characters and '_' to match a single character).

To support enumeration of qualifiers, owners, and table types, the following special semantics for the qualifier, owner, name, and table_type are available:

  • If qualifier is a single percent character (%) and owner and name are empty strings, then the result set contains a list of valid qualifiers for the data source. (All columns except the TABLE_QUALIFIER column contain NULLs.)
  • If owner is a single percent character (%) and qualifier and name are empty strings, then the result set contains a list of valid owners for the data source. (All columns except the TABLE_OWNER column contain NULLs.)
  • If table_type is a single percent character (%) and qualifier, owner and name are empty strings, then the result set contains a list of valid table types for the data source. (All columns except the TABLE_TYPE column contain NULLs.)

If table_type is not an empty string, it must contain a list of comma-separated values for the types of interest; each value may be enclosed in single quotes (') or unquoted. For example, "'TABLE','VIEW'" or "TABLE, VIEW". If the data source does not support a specified table type, odbc_tables() does not return any results for that type.

See also odbc_tableprivileges() to retrieve associated privileges.

Předcházející | Nahoru | Další
odbc_tableprivileges | Domů | CIX. ODBC and DB2 Functions (PDO_ODBC)


Object Aggregation/Composition Functions

Předcházející VI. Reference funkcí Další

CV. Object Aggregation/Composition Functions

Varování

Toto rozšíření je EXPERIMENTÁLNÍ. Chování tohoto rozšíření, názvy funkcí a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může bez ohlášení změnit. Berte to v úvahu a používejte tento modul na vlastní nebezpečí.

Úvod

In Object Oriented Programming, it is common to see the composition of simple classes (and/or instances) into a more complex one. This is a flexible strategy for building complicated objects and object hierarchies and can function as a dynamic alternative to multiple inheritance. There are two ways to perform class (and/or object) composition depending on the relationship between the composed elements: Association and Aggregation.

An Association is a composition of independently constructed and externally visible parts. When we associate classes or objects, each one keeps a reference to the ones it is associated with. When we associate classes statically, one class will contain a reference to an instance of the other class. For example:

Příklad 1428. Class association

<?php
class DateTime {

   function DateTime()
   {
       // empty constructor
   }

   function now()
   {
       return date("Y-m-d H:i:s");
   }
}

class Report {
   var $_dt;
   // more properties ...

   function Report()
   {
       $this->_dt = new DateTime();
       // initialization code ...
   }

   function generateReport()
   {
       $dateTime = $this->_dt->now();
       // more code ...
   }

   // more methods ...
}

$rep = new Report();
?>

We can also associate instances at runtime by passing a reference in a constructor (or any other method), which allow us to dynamically change the association relationship between objects. We will modify the example above to illustrate this point:

Příklad 1429. Object association

<?php
class DateTime {
   // same as previous example
}

class DateTimePlus {
   var $_format;

   function DateTimePlus($format="Y-m-d H:i:s")
   {
       $this->_format = $format;
   }

   function now()
   {
       return date($this->_format);
   }
}

class Report {
   var $_dt;    // we'll keep the reference to DateTime here
   // more properties ...

   function Report()
   {
       // do some initialization
   }

   function setDateTime(&$dt)
   {
       $this->_dt =& $dt;
   }

   function generateReport()
   {
       $dateTime = $this->_dt->now();
       // more code ...
   }

   // more methods ...
}

$rep = new Report();
$dt = new DateTime();
$dtp = new DateTimePlus("l, F j, Y (h:i:s a, T)");

// generate report with simple date for web display
$rep->setDateTime(&$dt);
echo $rep->generateReport();

// later on in the code ...

// generate report with fancy date
$rep->setDateTime(&$dtp);
$output = $rep->generateReport();
// save $output in database
// ... etc ...
?>

Aggregation, on the other hand, implies encapsulation (hidding) of the parts of the composition. We can aggregate classes by using a (static) inner class (PHP does not yet support inner classes), in this case the aggregated class definition is not accessible, except through the class that contains it. The aggregation of instances (object aggregation) involves the dynamic creation of subobjects inside an object, in the process, expanding the properties and methods of that object.

Object aggregation is a natural way of representing a whole-part relationship, (for example, molecules are aggregates of atoms), or can be used to obtain an effect equivalent to multiple inheritance, without having to permanently bind a subclass to two or more parent classes and their interfaces. In fact object aggregation can be more flexible, in which we can select what methods or properties to "inherit" in the aggregated object.

Příklady

We define 3 classes, each implementing a different storage method:

Příklad 1430. storage_classes.inc

<?php
class FileStorage {
    var $data;

    function FileStorage($data)
    {
        $this->data = $data;
    }

    function write($name)
    {
        $fp = fopen(name, "w");
        fwrite($fp, $this->data);
        fclose($data);
    }
}

class WDDXStorage {
    var $data;
    var $version = "1.0";
    var $_id; // "private" variable

    function WDDXStorage($data)
    {
        $this->data = $data;
        $this->_id = $this->_genID();
    }

    function store()
    {
        if ($this->_id) {
            $pid = wddx_packet_start($this->_id);
            wddx_add_vars($pid, "this->data");
            $packet = wddx_packet_end($pid);
        } else {
            $packet = wddx_serialize_value($this->data);
        }
        $dbh = dba_open("varstore", "w", "gdbm");
        dba_insert(md5(uniqid("", true)), $packet, $dbh);
        dba_close($dbh);
    }

    // a private method
    function _genID()
    {
        return md5(uniqid(rand(), true));
    }
}

class DBStorage {
    var $data;
    var $dbtype = "mysql";

    function DBStorage($data)
    {
        $this->data = $data;
    }

    function save()
    {
        $dbh = mysql_connect();
        mysql_select_db("storage", $dbh);
        $serdata = serialize($this->data);
        mysql_query("insert into vars ('$serdata',now())", $dbh);
        mysql_close($dbh);
    }
}

?>

We then instantiate a couple of objects from the defined classes, and perform some aggregations and deaggregations, printing some object information along the way:

Příklad 1431. test_aggregation.php

<?php
include "storageclasses.inc";

// some utilty functions

function p_arr($arr)
{
    foreach ($arr as $k => $v)
        $out[] = "\t$k => $v";
    return implode("\n", $out);
}

function object_info($obj)
{
    $out[] = "Class: " . get_class($obj);
    foreach (get_object_vars($obj) as $var=>$val) {
        if (is_array($val)) {
            $out[] = "property: $var (array)\n" . p_arr($val);
        } else {
            $out[] = "property: $var = $val";
        }
    }
    foreach (get_class_methods($obj) as $method) {
        $out[] = "method: $method";
    }
    return implode("\n", $out);
}

$data = array(M_PI, "kludge != cruft");

// we create some basic objects
$fs = new FileStorage($data);
$ws = new WDDXStorage($data);

// print information on the objects
echo "\$fs object\n";
echo object_info($fs) . "\n";
echo "\n\$ws object\n";
echo object_info($ws) . "\n";

// do some aggregation

echo "\nLet's aggregate \$fs to the WDDXStorage class\n";
aggregate($fs, "WDDXStorage");
echo "\$fs object\n";
echo object_info($fs) . "\n";

echo "\nNow let us aggregate it to the DBStorage class\n";
aggregate($fs, "DBStorage");
echo "\$fs object\n";
echo object_info($fs) . "\n";

echo "\nAnd finally deaggregate WDDXStorage\n";
deaggregate($fs, "WDDXStorage");
echo "\$fs object\n";
echo object_info($fs) . "\n";

?>

We will now consider the output to understand some of the side-effects and limitation of object aggregation in PHP. First, the newly created $fs and $ws objects give the expected output (according to their respective class declaration). Note that for the purposes of object aggregation, private elements of a class/object begin with an underscore character ("_"), even though there is not real distinction between public and private class/object elements in PHP.

$fs object
Class: filestorage
property: data (array)
    0 => 3.1415926535898
    1 => kludge != cruft
method: filestorage
method: write

$ws object
Class: wddxstorage
property: data (array)
    0 => 3.1415926535898
    1 => kludge != cruft
property: version = 1.0
property: _id = ID::9bb2b640764d4370eb04808af8b076a5
method: wddxstorage
method: store
method: _genid

We then aggregate $fs with the WDDXStorage class, and print out the object information. We can see now that even though nominally the $fs object is still of FileStorage, it now has the property $version, and the method store(), both defined in WDDXStorage. One important thing to note is that it has not aggregated the private elements defined in the class, which are present in the $ws object. Also absent is the constructor from WDDXStorage, which will not be logical to aggegate.

Let's aggregate $fs to the WDDXStorage class
$fs object
Class: filestorage
property: data (array)
    0 => 3.1415926535898
    1 => kludge != cruft
property: version = 1.0
method: filestorage
method: write
method: store

The process of aggregation is cumulative, so when we aggregate $fs with the class DBStorage, generating an object that can use the storage methods of all the defined classes.

Now let us aggregate it to the DBStorage class
$fs object
Class: filestorage
property: data (array)
    0 => 3.1415926535898
    1 => kludge != cruft
property: version = 1.0
property: dbtype = mysql
method: filestorage
method: write
method: store
method: save

Finally, the same way we aggregated properties and methods dynamically, we can also deaggregate them from the object. So, if we deaggregate the class WDDXStorage from $fs, we will obtain:

And deaggregate the WDDXStorage methods and properties
$fs object
Class: filestorage
property: data (array)
    0 => 3.1415926535898
    1 => kludge != cruft
property: dbtype = mysql
method: filestorage
method: write
method: save

One point that we have not mentioned above, is that the process of aggregation will not override existing properties or methods in the objects. For example, the class FileStorage defines a $data property, and the class WDDXStorage also defines a similar property which will not override the one in the object acquired during instantiation from the class FileStorage.

Obsah

aggregate_info — Gets aggregation information for a given object
aggregate_methods_by_list — Selective dynamic class methods aggregation to an object
aggregate_methods_by_regexp — Selective class methods aggregation to an object using a regular expression
aggregate_methods — Dynamic class and object aggregation of methods
aggregate_properties_by_list — Selective dynamic class properties aggregation to an object
aggregate_properties_by_regexp — Selective class properties aggregation to an object using a regular expression
aggregate_properties — Dynamic aggregation of class properties to an object
aggregate — Dynamic class and object aggregation of methods and properties
aggregation_info — Alias pro aggregate_info()
deaggregate — Removes the aggregated methods and properties from an object
Předcházející | Nahoru | Další
nsapi_virtual | Domů | aggregate_info


aggregate_info

(No version information available, might be only in CVS)

aggregate_info — Gets aggregation information for a given object

Popis

array aggregate_info ( object $object )

Gets the aggregation information for the given object.

Seznam parametrů

object

Návratové hodnoty

Returns the aggregation information as an associative array of arrays of methods and properties. The key for the main array is the name of the aggregated class.

Příklady

Příklad 1432. Using aggregate_info()

<?php

class Slicer {
    var $vegetable;

    function Slicer($vegetable)
    {
        $this->vegetable = $vegetable;
    }

    function slice_it($num_cuts)
    {
        echo "Doing some simple slicing\n";
        for ($i=0; $i < $num_cuts; $i++) {
            // do some slicing
        }
    }
}

class Dicer {
    var $vegetable;
    var $rotation_angle = 90;   // degrees

    function Dicer($vegetable)
    {
        $this->vegetable = $vegetable;
    }

    function dice_it($num_cuts)
    {
        echo "Cutting in one direction\n";
        for ($i=0; $i < $num_cuts; $i++) {
            // do some cutting
        }
        $this->rotate($this->rotation_angle);
        echo "Cutting in a second direction\n";
        for ($i=0; $i < $num_cuts; $i++) {
            // do some more cutting
        }
    }

    function rotate($deg)
    {
        echo "Now rotating {$this->vegetable} {$deg} degrees\n";
    }

    function _secret_super_dicing($num_cuts)
    {
        // so secret we cannot show you ;-)
    }
}

$obj = new Slicer('onion');
aggregate($obj, 'Dicer');
print_r(aggregate_info($obj));
?>

Výše uvedený příklad vypíše:

Array
(
    [dicer] => Array
        (
            [methods] => Array
                (
                    [0] => dice_it
                    [1] => rotate
                )

            [properties] => Array
                (
                    [0] => rotation_angle
                )

        )

)

As you can see, all properties and methods of the Dicer class have been aggregated into our new object, with the exception of the class constructor and the method _secret_super_dicing

Viz také

aggregate()
aggregate_methods()
aggregate_methods_by_list()
aggregate_methods_by_regexp()
aggregate_properties()
aggregate_properties_by_list()
aggregate_properties_by_regexp()
deaggregate()

Předcházející | Nahoru | Další
CV. Object Aggregation/Composition Functions | Domů | aggregate_methods_by_list


aggregate_methods_by_list

(PHP 4 >= 4.2.0)

aggregate_methods_by_list — Selective dynamic class methods aggregation to an object

Popis

void aggregate_methods_by_list ( object $object, string $class_name, array $methods_list [, bool $exclude] )

Aggregates methods from a class to an existing object using a list of method names.

The class constructor or methods whose names start with an underscore character (_), which are considered private to the aggregated class, are always excluded.

Seznam parametrů

object

class_name

methods_list

exclude

The optional parameter exclude is used to decide whether the list contains the names of methods to include in the aggregation (i.e. exclude is FALSE, which is the default value), or to exclude from the aggregation (exclude is TRUE).

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

aggregate()
aggregate_info()
aggregate_methods()
aggregate_methods_by_regexp()
aggregate_properties()
aggregate_properties_by_list()
aggregate_properties_by_regexp()
deaggregate()

Předcházející | Nahoru | Další
aggregate_info | Domů | aggregate_methods_by_regexp


aggregate_methods_by_regexp

(PHP 4 >= 4.2.0)

aggregate_methods_by_regexp — Selective class methods aggregation to an object using a regular expression

Popis

void aggregate_methods_by_regexp ( object $object, string $class_name, string $regexp [, bool $exclude] )

Aggregates methods from a class to an existing object using a regular expression to match method names.

The class constructor or methods whose names start with an underscore character (_), which are considered private to the aggregated class, are always excluded.

Seznam parametrů

object

class_name

regexp

exclude

The optional parameter exclude is used to decide whether the regular expression will select the names of methods to include in the aggregation (i.e. exclude is FALSE, which is the default value), or to exclude from the aggregation (exclude is TRUE).

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

aggregate()
aggregate_info()
aggregate_methods()
aggregate_methods_by_list()
aggregate_properties()
aggregate_properties_by_list()
aggregate_properties_by_regexp()
deaggregate()

Předcházející | Nahoru | Další
aggregate_methods_by_list | Domů | aggregate_methods


aggregate_methods

(PHP 4 >= 4.2.0)

aggregate_methods — Dynamic class and object aggregation of methods

Popis

void aggregate_methods ( object $object, string $class_name )

Aggregates all methods defined in a class to an existing object, except for the class constructor, or methods whose names start with an underscore character (_) which are considered private to the aggregated class.

Seznam parametrů

object

class_name

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

aggregate()
aggregate_info()
aggregate_methods_by_list()
aggregate_methods_by_regexp()
aggregate_properties()
aggregate_properties_by_list()
aggregate_properties_by_regexp()
deaggregate()

Předcházející | Nahoru | Další
aggregate_methods_by_regexp | Domů | aggregate_properties_by_list


aggregate_properties_by_list

(PHP 4 >= 4.2.0)

aggregate_properties_by_list — Selective dynamic class properties aggregation to an object

Popis

void aggregate_properties_by_list ( object $object, string $class_name, array $properties_list [, bool $exclude] )

Aggregates properties from a class to an existing object using a list of property names.

The properties whose names start with an underscore character (_), which are considered private to the aggregated class, are always excluded.

Seznam parametrů

object

class_name

properties_list

exclude

The optional parameter exclude is used to decide whether the list contains the names of class properties to include in the aggregation (i.e. exclude is FALSE, which is the default value), or to exclude from the aggregation (exclude is TRUE).

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

aggregate()
aggregate_methods()
aggregate_methods_by_list()
aggregate_methods_by_regexp()
aggregate_properties()
aggregate_properties_by_regexp()
aggregate_info()
deaggregate()

Předcházející | Nahoru | Další
aggregate_methods | Domů | aggregate_properties_by_regexp


aggregate_properties_by_regexp

(PHP 4 >= 4.2.0)

aggregate_properties_by_regexp — Selective class properties aggregation to an object using a regular expression

Popis

void aggregate_properties_by_regexp ( object $object, string $class_name, string $regexp [, bool $exclude] )

Aggregates properties from a class to an existing object using a regular expression to match their names.

The properties whose names start with an underscore character (_), which are considered private to the aggregated class, are always excluded.

Seznam parametrů

object

class_name

regexp

exclude

The optional parameter exclude is used to decide whether the regular expression will select the names of class properties to include in the aggregation (i.e. exclude is FALSE, which is the default value), or to exclude from the aggregation (exclude is TRUE).

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

aggregate()
aggregate_methods()
aggregate_methods_by_list()
aggregate_methods_by_regexp()
aggregate_properties()
aggregate_properties_by_list()
aggregate_info()
deaggregate()

Předcházející | Nahoru | Další
aggregate_properties_by_list | Domů | aggregate_properties


aggregate_properties

(PHP 4 >= 4.2.0)

aggregate_properties — Dynamic aggregation of class properties to an object

Popis

void aggregate_properties ( object $object, string $class_name )

Aggregates all properties defined in a class to an existing object, except for properties whose names start with an underscore character (_) which are considered private to the aggregated class.

Seznam parametrů

object

class_name

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

aggregate()
aggregate_methods()
aggregate_methods_by_list()
aggregate_methods_by_regexp()
aggregate_properties()
aggregate_properties_by_list()
aggregate_properties_by_regexp()
deaggregate()

Předcházející | Nahoru | Další
aggregate_properties_by_regexp | Domů | aggregate


aggregate

(PHP 4 >= 4.2.0)

aggregate — Dynamic class and object aggregation of methods and properties

Popis

void aggregate ( object $object, string $class_name )

Aggregates methods and properties defined in a class to an existing object. Methods and properties with names starting with an underscore character (_) are considered private to the aggregated class and are not used, constructors are also excluded from the aggregation procedure.

Seznam parametrů

object

class_name

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

aggregate_info()
aggregate_methods()
aggregate_methods_by_list()
aggregate_methods_by_regexp()
aggregate_properties()
aggregate_properties_by_list()
aggregate_properties_by_regexp()
deaggregate()

Předcházející | Nahoru | Další
aggregate_properties | Domů | aggregation_info


aggregation_info

(PHP 4 >= 4.2.0)

aggregation_info — Alias pro aggregate_info()

Popis

Tato funkce je aliasem: aggregate_info().

Předcházející | Nahoru | Další
aggregate | Domů | deaggregate


deaggregate

(PHP 4 >= 4.2.0)

deaggregate — Removes the aggregated methods and properties from an object

Popis

void deaggregate ( object $object [, string $class_name] )

Removes the methods and properties from classes that were aggregated to an object.

Seznam parametrů

object

class_name

If the optional class_name parameters is passed, only those methods and properties defined in that class are removed, otherwise all aggregated methods and properties are eliminated.

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

aggregate()
aggregate_methods()
aggregate_methods_by_list()
aggregate_methods_by_regexp()
aggregate_properties()
aggregate_properties_by_list()
aggregate_properties_by_regexp()
deaggregate()

Předcházející | Nahoru | Další
aggregation_info | Domů | CVI. Object property and method call overloading


Oracle Functions

Předcházející VI. Reference funkcí Další

CVII. Oracle Functions

Úvod

These functions allow you to access Oracle 10, Oracle 9, Oracle 8 and Oracle 7 databases using the Oracle Call Interface (OCI). They support binding of PHP variables to Oracle placeholders, have full LOB, FILE and ROWID support, and allow you to use user-supplied define variables.

Požadavky

You will need the Oracle client libraries to use this extension. Windows users will need libraries with version at least 10 to use the php_oci8.dll.

Poznámka: This extension does not support Oracle 8 client libraries anymore. Though you still can connect to Oracle 8 servers as long as the client library (v.9+) supports this.

The most convenient way to install all the required files is to use Oracle Instant Client, which is available from here: » http://www.oracle.com/technology/tech/oci/instantclient/instantclient.html. To work with OCI8 module "basic" version of Oracle Instant Client is enough. Instant Client does not need ORACLE_SID or ORACLE_HOME environment variables set. You still may need to set LD_LIBRARY_PATH and NLS_LANG, though.

Before using this extension, make sure that you have set up your Oracle environment variables properly for the Oracle user, as well as your web daemon user. These variables should be set up before you start your web-server. The variables you might need to set are as follows:

  • ORACLE_HOME
  • ORACLE_SID
  • LD_PRELOAD
  • LD_LIBRARY_PATH
  • NLS_LANG
For less frequently used Oracle environment variables such as TNS_ADMIN, TWO_TASK, ORA_TZFILE, and the various Oracle globalization settings like ORA_NLS33, ORA_NLS10 and the NLS_* variables refer to Oracle documentation.

After setting up the environment variables for your web server user, be sure to also add the web server user (nobody, www) to the oracle group.

If your web server doesn't start or crashes at startup: Check that Apache is linked with the pthread library:

# ldd /www/apache/bin/httpd
    libpthread.so.0 => /lib/libpthread.so.0 (0x4001c000)
    libm.so.6 => /lib/libm.so.6 (0x4002f000)
    libcrypt.so.1 => /lib/libcrypt.so.1 (0x4004c000)
    libdl.so.2 => /lib/libdl.so.2 (0x4007a000)
    libc.so.6 => /lib/libc.so.6 (0x4007e000)
    /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)

If the libpthread is not listed you have to reinstall Apache:

# cd /usr/src/apache_1.3.xx
# make clean
# LIBS=-lpthread ./config.status
# make
# make install

Please note that on some systems, like UnixWare it is libthread instead of libpthread. PHP and Apache have to be configured with EXTRA_LIBS=-lthread.

Konfigurace běhu

Chování těchto funkcí je ovlivněno nastavením parametrů v php.ini.

Tabulka 215. OCI8 Configuration Options

Name | Default | Changeable | Changelog
oci8.privileged_connect | "0" | PHP_INI_SYSTEM | Available since PHP 5.1.2.
oci8.max_persistent | "-1" | PHP_INI_SYSTEM | Available since PHP 5.1.2.
oci8.persistent_timeout | "-1" | PHP_INI_SYSTEM | Available since PHP 5.1.2.
oci8.ping_interval | "60" | PHP_INI_SYSTEM | Available since PHP 5.1.2.
oci8.statement_cache_size | "20" | PHP_INI_SYSTEM | Available since PHP 5.1.2.
oci8.default_prefetch | "10" | PHP_INI_SYSTEM | Available since PHP 5.1.2.
oci8.old_oci_close_semantics | "0" | PHP_INI_SYSTEM | Available since PHP 5.1.2.

Zde je stručný popis konfiguračních direktiv.

oci8.privileged_connect boolean

This option enables privileged connections using external credentials (OCI_SYSOPER, OCI_SYSDBA).

oci8.max_persistent int

The maximum number of persistent OCI8 connections per process. Setting this option to -1 means that there is no limit.

oci8.persistent_timeout int

The maximum length of time (in seconds) that a given process is allowed to maintain an idle persistent connection. Setting this option to -1 means that idle persistent connections will be maintained forever.

oci8.ping_interval int

The length of time (in seconds) that must pass before issuing a ping during oci_pconnect(). When set to 0, persistent connections will be pinged every time they are reused. To disable pings completely, set this option to -1.

Poznámka: Disabling pings will cause oci_pconnect() calls to operate at the highest efficiency, but may cause PHP to not detect faulty connections, such as those caused by network partitions, or if the Oracle server has gone down since PHP connected, until later in the script. Consult the oci_pconnect() documentation for more information.

oci8.statement_cache_size int

This option enables statement caching, and specifies how many statements to cache. To disable statement caching just set this option to 0.

Poznámka: A larger cache can result in improved performance, at the cost of increased memory usage.

oci8.default_prefetch int

This option enables statement prefetching and sets the default number of rows that will be fetched automatically after statement execution.

Poznámka: A larger prefetch can result in improved performance, at the cost of increased memory usage.

oci8.old_oci_close_semantics boolean

This option controls oci_close() behaviour. Enabling it means that oci_close() will do nothing; the connection will not be closed until the end of the script. This is for backward compatibility only. If you find that you need to enable this setting, you are strongly encouraged to remove the oci_close() calls from your application instead of enabling this option.

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

OCI_DEFAULT (integer)
Statement execution mode. Statement is not committed automatically when using this mode.
OCI_DESCRIBE_ONLY (integer)
Statement execution mode. Use this mode if you don't want to execute the query, but get the select-list's description.
OCI_COMMIT_ON_SUCCESS (integer)
Statement execution mode. Statement is automatically committed after oci_execute() call.
OCI_EXACT_FETCH (integer)
Statement fetch mode. Used when the application knows in advance exactly how many rows it will be fetching. This mode turns prefetching off for Oracle release 8 or later mode. Cursor is cancelled after the desired rows are fetched and may result in reduced server-side resource usage.
OCI_SYSDATE (integer)
OCI_B_BFILE (integer)
Used with oci_bind_by_name() when binding BFILEs.
OCI_B_CFILEE (integer)
Used with oci_bind_by_name() when binding CFILEs.
OCI_B_CLOB (integer)
Used with oci_bind_by_name() when binding CLOBs.
OCI_B_BLOB (integer)
Used with oci_bind_by_name() when binding BLOBs.
OCI_B_ROWID (integer)
Used with oci_bind_by_name() when binding ROWIDs.
OCI_B_CURSOR (integer)
Used with oci_bind_by_name() when binding cursors, previously allocated with oci_new_descriptor().
OCI_B_NTY (integer)
Used with oci_bind_by_name() when binding named data types. Note: in PHP < 5.0 it was called OCI_B_SQLT_NTY.
OCI_B_BIN (integer)
SQLT_BFILEE (integer)
The same as OCI_B_BFILE.
SQLT_CFILEE (integer)
The same as OCI_B_CFILEE.
SQLT_CLOB (integer)
The same as OCI_B_CLOB.
SQLT_BLOB (integer)
The same as OCI_B_BLOB.
SQLT_RDD (integer)
The same as OCI_B_ROWID.
SQLT_NTY (integer)
The same as OCI_B_NTY.
SQLT_LNG (integer)
Used with oci_bind_by_name() to bind LONG values.
SQLT_LBI (integer)
Used with oci_bind_by_name() to bind LONG RAW values.
SQLT_BIN (integer)
Used with oci_bind_by_name() to bind RAW values.
SQLT_NUM (integer)
Used with oci_bind_array_by_name() to bind arrays of NUMBER.
SQLT_INT (integer)
Used with oci_bind_array_by_name() to bind arrays of INTEGER.
SQLT_AFC (integer)
Used with oci_bind_array_by_name() to bind arrays of CHAR.
SQLT_CHR (integer)
Used with oci_bind_array_by_name() to bind arrays of VARCHAR2. Also used with oci_bind_by_name().
SQLT_VCS (integer)
Used with oci_bind_array_by_name() to bind arrays of VARCHAR.
SQLT_AVC (integer)
Used with oci_bind_array_by_name() to bind arrays of CHARZ.
SQLT_STR (integer)
Used with oci_bind_array_by_name() to bind arrays of STRING.
SQLT_LVC (integer)
Used with oci_bind_array_by_name() to bind arrays of LONG VARCHAR.
SQLT_FLT (integer)
Used with oci_bind_array_by_name() to bind arrays of FLOAT.
SQLT_ODT (integer)
Used with oci_bind_array_by_name() to bind arrays of LONG.
SQLT_BDOUBLE (integer)
SQLT_BFLOAT (integer)
OCI_FETCHSTATEMENT_BY_COLUMN (integer)
Default mode of oci_fetch_all().
OCI_FETCHSTATEMENT_BY_ROW (integer)
Alternative mode of oci_fetch_all().
OCI_ASSOC (integer)
Used with oci_fetch_all() and oci_fetch_array() to get an associative array as a result.
OCI_NUM (integer)
Used with oci_fetch_all() and oci_fetch_array() to get an enumerated array as a result.
OCI_BOTH (integer)
Used with oci_fetch_all() and oci_fetch_array() to get an array with both associative and number indices.
OCI_RETURN_NULLS (integer)
Used with oci_fetch_array() to get empty array elements if field's value is NULL.
OCI_RETURN_LOBS (integer)
Used with oci_fetch_array() to get value of LOB instead of the descriptor.
OCI_DTYPE_FILE (integer)
This flag tells oci_new_descriptor() to initialize new FILE descriptor.
OCI_DTYPE_LOB (integer)
This flag tells oci_new_descriptor() to initialize new LOB descriptor.
OCI_DTYPE_ROWID (integer)
This flag tells oci_new_descriptor() to initialize new ROWID descriptor.
OCI_D_FILE (integer)
The same as OCI_DTYPE_FILE.
OCI_D_LOB (integer)
The same as OCI_DTYPE_LOB.
OCI_D_ROWID (integer)
The same as OCI_DTYPE_ROWID.
OCI_SYSOPER (integer)
Used with oci_connect() to connect as SYSOPER using external credentials (oci8.privileged_connect should be enabled for this).
OCI_SYSDBA (integer)
Used with oci_connect() to connect as SYSDBA using external credentials (oci8.privileged_connect should be enabled for this).
OCI_LOB_BUFFER_FREE (integer)
Used with OCI-Lob->flush to free buffers used.
OCI_TEMP_CLOB (integer)
Used with OCI-Lob->writeTemporary to indicate explicilty that temporary CLOB should be created.
OCI_TEMP_BLOB (integer)
Used with OCI-Lob->writeTemporary to indicate explicilty that temporary BLOB should be created.

Příklady

Příklad 1434. Basic query

<?php

  $conn = oci_connect('hr', 'hr', 'orcl');
  if (!$conn) {
    $e = oci_error();
    print htmlentities($e['message']);
    exit;
  }

  $query = 'SELECT * FROM DEPARTMENTS';

  $stid = oci_parse($conn, $query);
  if (!$stid) {
    $e = oci_error($conn);
    print htmlentities($e['message']);
    exit;
  }

  $r = oci_execute($stid, OCI_DEFAULT);
  if (!$r) {
    $e = oci_error($stid);
    echo htmlentities($e['message']);
    exit;
  }

  print '<table border="1">';
  while ($row = oci_fetch_array($stid, OCI_RETURN_NULLS)) {
    print '<tr>';
       foreach ($row as $item) {
         print '<td>'.($item?htmlentities($item):'&nbsp;').'</td>';
       }
       print '</tr>';
  }
  print '</table>';

  oci_close($conn);
?>

Příklad 1435. Insert with bind variables

<?php

  // Before running, create the table:
  //   CREATE TABLE MYTABLE (mid NUMBER, myd VARCHAR2(20));

  $conn = oci_connect('scott', 'tiger', 'orcl');

  $query = 'INSERT INTO MYTABLE VALUES(:myid, :mydata)';

  $stid = oci_parse($conn, $query);

  $id = 60;
  $data = 'Some data';

  oci_bind_by_name($stid, ':myid', $id);
  oci_bind_by_name($stid, ':mydata', $data);

  $r = oci_execute($stid);

  if ($r)
    print "One row inserted";

  oci_close($conn);

?>

Příklad 1436. Inserting data into a CLOB column

<?php

// Before running, create the table:
//     CREATE TABLE MYTABLE (mykey NUMBER, myclob CLOB);

$conn = oci_connect('scott', 'tiger', 'orcl');

$mykey = 12343;  // arbitrary key for this example;

$sql = "INSERT INTO mytable (mykey, myclob)
        VALUES (:mykey, EMPTY_CLOB())
        RETURNING myclob INTO :myclob";

$stid = oci_parse($conn, $sql);
$clob = oci_new_descriptor($conn, OCI_D_LOB);
oci_bind_by_name($stid, ":mykey", $mykey, 5);
oci_bind_by_name($stid, ":myclob", $clob, -1, OCI_B_CLOB);
oci_execute($stid, OCI_DEFAULT);
$clob->save("A very long string");

oci_commit($conn);

// Fetching CLOB data

$query = 'SELECT myclob FROM mytable WHERE mykey = :mykey';

$stid = oci_parse ($conn, $query);
oci_bind_by_name($stid, ":mykey", $mykey, 5);
oci_execute($stid, OCI_DEFAULT);

print '<table border="1">';
while ($row = oci_fetch_array($stid, OCI_ASSOC)) {
  $result = $row['MYCLOB']->load();
  print '<tr><td>'.$result.'</td></tr>';
}
print '</table>';

?>

You can easily access stored procedures in the same way as you would from the command line.

Příklad 1437. Using Stored Procedures

<?php
// by webmaster at remoterealty dot com
$sth = oci_parse($dbh, "begin sp_newaddress( :address_id, '$firstname',
 '$lastname', '$company', '$address1', '$address2', '$city', '$state',
 '$postalcode', '$country', :error_code );end;");

// This calls stored procedure sp_newaddress, with :address_id being an
// in/out variable and :error_code being an out variable.
// Then you do the binding:

   oci_bind_by_name($sth, ":address_id", $addr_id, 10);
   oci_bind_by_name($sth, ":error_code", $errorcode, 10);
   oci_execute($sth);

?>

Connecting Handling

The oci8 extension provides you with 3 different functions for connecting to Oracle. It is up to you to use the most appropriate function for your application, and the information in this section is intended to help you make an informed choice.

Connecting to an Oracle server is a reasonably expensive operation, in terms of the time that it takes to complete. The oci_pconnect() function uses a persistent cache of connections that can be re-used across different script requests. This means that you will typically only incur the connection overhead once per php process (or apache child).

If your application connects to Oracle using a different set of credentials for each web user, the persistent cache employed by oci_pconnect() will become less useful as the number of concurrent users increases, to the point where it may start to adversely affect the overall performance of your Oracle server due to maintaining too many idle connections. If your application is structured in this way, it is recommended that you either tune your application using the oci8.max_persistent and oci8.persistent_timeout configuration settings (these will give you control over the persistent connection cache size and lifetime) or use oci_connect() instead.

Both oci_connect() and oci_pconnect() employ a connection cache; if you make multiple calls to oci_connect(), using the same parameters, in a given script, the second and subsequent calls return the existing connection handle. The cache used by oci_connect() is cleaned up at the end of the script run, or when you explicitly close the connection handle. oci_pconnect() has similar behaviour, although its cache is maintained separately and survives between requests.

This caching feature is important to remember, because it gives the appearance that the two handles are not transactionally isolated (they are in fact the same connection handle, so there is no isolation of any kind). If your application needs two separate, transactionally isolated connections, you should use oci_new_connect().

oci_new_connect() always creates a new connection to the Oracle server, regardless of what other connections might already exist. High traffic web applications should try to avoid using oci_new_connect(), especially in the busiest sections of the application.

Datatypes supported by the driver

Tabulka 216. The driver supports the following types when binding parameters using oci_bind_by_name() function:

Type | Mapping
SQLT_NTY | Maps a native collection type from a PHP collection object, such as those created by oci_new_collection().
SQLT_BFILEE | Maps a native descriptor, such as those created by oci_new_descriptor().
SQLT_CFILEE | Maps a native descriptor, such as those created by oci_new_descriptor().
SQLT_CLOB | Maps a native descriptor, such as those created by oci_new_descriptor().
SQLT_BLOB | Maps a native descriptor, such as those created by oci_new_descriptor().
SQLT_RDD | Maps a native descriptor, such as those created by oci_new_descriptor().
SQLT_NUM | Converts the PHP parameter to a 'C' long type, and binds to that value.
SQLT_RSET | Maps a native statement handle, such as those created by oci_parse() or those retrieved from other OCI queries.
SQLT_CHR and any other type | Converts the PHP parameter to a string type and binds as a string.

Tabulka 217. The following types are supported when retrieving columns from a result set:

Type | Mapping
SQLT_RSET | Creates an oci statement resource to represent the the cursor.
SQLT_RDD | Creates a ROWID object.
SQLT_BLOB | Creates a LOB object.
SQLT_CLOB | Creates a LOB object.
SQLT_BFILE | Creates a LOB object.
SQLT_LNG | Bound as SQLT_CHR, returned as a string
SQLT_LBI | Bound as SQLT_BIN, returned as a string
Any other type | Bound as SQLT_CHR, returned as a string

Obsah

oci_bind_array_by_name — Binds PHP array to Oracle PL/SQL array by name
oci_bind_by_name — Binds the PHP variable to the Oracle placeholder
oci_cancel — Cancels reading from cursor
oci_close — Closes Oracle connection
OCI-Collection->append — Appends element to the collection
OCI-Collection->assign — Assigns a value to the collection from another existing collection
OCI-Collection->assignElem — Assigns a value to the element of the collection
OCI-Collection->free — Frees the resources associated with the collection object
OCI-Collection->getElem — Returns value of the element
OCI-Collection->max — Returns the maximum number of elements in the collection
OCI-Collection->size — Returns size of the collection
OCI-Collection->trim — Trims elements from the end of the collection
oci_commit — Commits outstanding statements
oci_connect — Establishes a connection to the Oracle server
oci_define_by_name — Uses a PHP variable for the define-step during a SELECT
oci_error — Returns the last error found
oci_execute — Executes a statement
oci_fetch_all — Fetches all rows of result data into an array
oci_fetch_array — Returns the next row from the result data as an associative or numeric array, or both
oci_fetch_assoc — Returns the next row from the result data as an associative array
oci_fetch_object — Returns the next row from the result data as an object
oci_fetch_row — Returns the next row from the result data as a numeric array
oci_fetch — Fetches the next row into result-buffer
oci_field_is_null — Checks if the field is NULL
oci_field_name — Returns the name of a field from the statement
oci_field_precision — Tell the precision of a field
oci_field_scale — Tell the scale of the field
oci_field_size — Returns field's size
oci_field_type_raw — Tell the raw Oracle data type of the field
oci_field_type — Returns field's data type
oci_free_statement — Frees all resources associated with statement or cursor
oci_internal_debug — Enables or disables internal debug output
OCI-Lob->append — Appends data from the large object to another large object
OCI-Lob->close — Closes LOB descriptor
oci_lob_copy — Copies large object
OCI-Lob->eof — Tests for end-of-file on a large object's descriptor
OCI-Lob->erase — Erases a specified portion of the internal LOB data
OCI-Lob->export — Exports LOB's contents to a file
OCI-Lob->flush — Flushes/writes buffer of the LOB to the server
OCI-Lob->free — Frees resources associated with the LOB descriptor
OCI-Lob->getBuffering — Returns current state of buffering for the large object
OCI-Lob->import — Imports file data to the LOB
oci_lob_is_equal — Compares two LOB/FILE locators for equality
OCI-Lob->load — Returns large object's contents
OCI-Lob->read — Reads part of the large object
OCI-Lob->rewind — Moves the internal pointer to the beginning of the large object
OCI-Lob->save — Saves data to the large object
OCI-Lob->saveFile — Alias pro oci_lob_import()
OCI-Lob->seek — Sets the internal pointer of the large object
OCI-Lob->setBuffering — Changes current state of buffering for the large object
OCI-Lob->size — Returns size of large object
OCI-Lob->tell — Returns current position of internal pointer of large object
OCI-Lob->truncate — Truncates large object
OCI-Lob->write — Writes data to the large object
OCI-Lob->writeTemporary — Writes temporary large object
OCI-Lob->writeToFile — Alias pro oci_lob_export()
oci_new_collection — Allocates new collection object
oci_new_connect — Establishes a new connection to the Oracle server
oci_new_cursor — Allocates and returns a new cursor (statement handle)
oci_new_descriptor — Initializes a new empty LOB or FILE descriptor
oci_num_fields — Returns the number of result columns in a statement
oci_num_rows — Returns number of rows affected during statement execution
oci_parse — Prepares Oracle statement for execution
oci_password_change — Changes password of Oracle's user
oci_pconnect — Connect to an Oracle database using a persistent connection
oci_result — Returns field's value from the fetched row
oci_rollback — Rolls back outstanding transaction
oci_server_version — Returns server version
oci_set_prefetch — Sets number of rows to be prefetched
oci_statement_type — Returns the type of an OCI statement
ocibindbyname — Alias pro oci_bind_by_name()
ocicancel — Alias pro oci_cancel()
ocicloselob — Alias pro OCI-Lob->close
ocicollappend — Alias pro OCI-Collection->append
ocicollassign — Alias pro OCI-Collection->assign
ocicollassignelem — Alias pro OCI-Collection->assignElem
ocicollgetelem — Alias pro OCI-Collection->getElem
ocicollmax — Alias pro OCI-Collection->max
ocicollsize — Alias pro OCI-Collection->size
ocicolltrim — Alias pro OCI-Collection->trim
ocicolumnisnull — Alias pro oci_field_is_null()
ocicolumnname — Alias pro oci_field_name()
ocicolumnprecision — Alias pro oci_field_precision()
ocicolumnscale — Alias pro oci_field_scale()
ocicolumnsize — Alias pro oci_field_size()
ocicolumntype — Alias pro oci_field_type()
ocicolumntyperaw — Alias pro oci_field_type_raw()
ocicommit — Alias pro oci_commit()
ocidefinebyname — Alias pro oci_define_by_name()
ocierror — Alias pro oci_error()
ociexecute — Alias pro oci_execute()
ocifetch — Alias pro oci_fetch()
ocifetchinto — Fetches the next row into an array (deprecated)
ocifetchstatement — Alias pro oci_fetch_all()
ocifreecollection — Alias pro OCI-Collection->free
ocifreecursor — Alias pro oci_free_statement()
ocifreedesc — Alias pro OCI-Lob->free
ocifreestatement — Alias pro oci_free_statement()
ociinternaldebug — Alias pro oci_internal_debug()
ociloadlob — Alias pro OCI-Lob->load
ocilogoff — Alias pro oci_close()
ocilogon — Alias pro oci_connect()
ocinewcollection — Alias pro oci_new_collection()
ocinewcursor — Alias pro oci_new_cursor()
ocinewdescriptor — Alias pro oci_new_descriptor()
ocinlogon — Alias pro oci_new_connect()
ocinumcols — Alias pro oci_num_fields()
ociparse — Alias pro oci_parse()
ociplogon — Alias pro oci_pconnect()
ociresult — Alias pro oci_result()
ocirollback — Alias pro oci_rollback()
ocirowcount — Alias pro oci_num_rows()
ocisavelob — Alias pro OCI-Lob->save
ocisavelobfile — Alias pro OCI-Lob->import
ociserverversion — Alias pro oci_server_version()
ocisetprefetch — Alias pro oci_set_prefetch()
ocistatementtype — Alias pro oci_statement_type()
ociwritelobtofile — Alias pro OCI-Lob->export
ociwritetemporarylob — Alias pro OCI-Lob->writeTemporary
Předcházející | Nahoru | Další
overload | Domů | oci_bind_array_by_name


oci_bind_by_name

(PHP 5, PECL oci8:1.1-1.2.4)

oci_bind_by_name — Binds the PHP variable to the Oracle placeholder

Popis

bool oci_bind_by_name ( resource $statement, string $ph_name, mixed &$variable [, int $maxlength [, int $type]] )

Binds the PHP variable variable to the Oracle placeholder ph_name. Whether it will be used for input or output will be determined at run-time and the necessary storage space will be allocated.

Seznam parametrů

statement

An OCI statement.

ph_name

The placeholder.

variable

The PHP variable.

maxlength

Sets the maximum length for the bind. If you set it to -1, this function will use the current length of variable to set the maximum length.

type

If you need to bind an abstract datatype (LOB/ROWID/BFILE) you need to allocate it first using the oci_new_descriptor() function. The length is not used for abstract datatypes and should be set to -1. The type parameter tells Oracle which descriptor is used. Possible values are:

  • SQLT_FILE - for BFILEs;

  • SQLT_CFILE - for CFILEs;

  • SQLT_CLOB - for CLOBs;

  • SQLT_BLOB - for BLOBs;

  • SQLT_RDD - for ROWIDs;

  • SQLT_NTY - for named datatypes;

  • SQLT_INT - for integers;

  • SQLT_CHR - for VARCHARs;

  • SQLT_BIN - for RAW columns;

  • SQLT_LNG - for LONG columns;

  • SQLT_LBI - for LONG RAW columns;

  • SQLT_RSET - for cursors, that were created before with oci_new_cursor().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1439. oci_bind_by_name() example

<?php
/* oci_bind_by_name example thies at thieso dot net (980221)
  inserts 3 records into emp, and uses the ROWID for updating the
  records just after the insert.
*/

$conn = oci_connect("scott", "tiger");

$stmt = oci_parse($conn, "
                          INSERT INTO
                                     emp (empno, ename)
                               VALUES
                                     (:empno,:ename)
                            RETURNING
                                     ROWID
                                 INTO
                                     :rid
                         ");

$data = array(
              1111 => "Larry",
              2222 => "Bill",
              3333 => "Jim"
             );

$rowid = oci_new_descriptor($conn, OCI_D_ROWID);

oci_bind_by_name($stmt, ":empno", $empno, 32);
oci_bind_by_name($stmt, ":ename", $ename, 32);
oci_bind_by_name($stmt, ":rid",   $rowid, -1, OCI_B_ROWID);

$update = oci_parse($conn, "
                            UPDATE
                                  emp
                               SET
                                  sal = :sal
                             WHERE
                                  ROWID = :rid
                           ");
oci_bind_by_name($update, ":rid", $rowid, -1, OCI_B_ROWID);
oci_bind_by_name($update, ":sal", $sal,   32);

$sal = 10000;

foreach ($data as $empno => $ename) {
    oci_execute($stmt);
    oci_execute($update);
}

$rowid->free();

oci_free_statement($update);
oci_free_statement($stmt);

$stmt = oci_parse($conn, "
                          SELECT
                                *
                            FROM
                                emp
                           WHERE
                                empno
                              IN
                                (1111,2222,3333)
                         ");
oci_execute($stmt);

while ($row = oci_fetch_assoc($stmt)) {
    var_dump($row);
}

oci_free_statement($stmt);

/* delete our "junk" from the emp table.... */
$stmt = oci_parse($conn, "
                          DELETE FROM
                                     emp
                                WHERE
                                     empno
                                   IN
                                     (1111,2222,3333)
                         ");
oci_execute($stmt);
oci_free_statement($stmt);

oci_close($conn);
?>

Remember, this function strips trailing whitespaces. See the following example:

Příklad 1440. oci_bind_by_name() example

<?php
    $connection = oci_connect('apelsin','kanistra');
    $query = "INSERT INTO test_table VALUES(:id, :text)";

    $statement = oci_parse($query);
    oci_bind_by_name($statement, ":id", 1);
    oci_bind_by_name($statement, ":text", "trailing spaces follow     ");
    oci_execute($statement);
    /*
     This code will insert into DB string 'trailing spaces follow', without
     trailing spaces
    */
?>

Příklad 1441. oci_bind_by_name() example

<?php
    $connection = oci_connect('apelsin','kanistra');
    $query = "INSERT INTO test_table VALUES(:id, 'trailing spaces follow      ')";

    $statement = oci_parse($query);
    oci_bind_by_name($statement, ":id", 1);
    oci_execute($statement);
    /*
     And this code will add 'trailing spaces follow      ', preserving
     trailing whitespaces
    */
?>

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Poznámky

Varování

Do not use magic_quotes_gpc or addslashes() and oci_bind_by_name() simultaneously as no quoting is needed and any magically applied quotes will be written into your database as oci_bind_by_name() is not able to distinguish magically added quotings from those added intentionally.

Poznámka: In PHP versions before 5.0.0 you must use ocibindbyname() instead. This name still can be used, it was left as alias of oci_bind_by_name() for downwards compatability. This, however, is deprecated and not recommended.

Předcházející | Nahoru | Další
oci_bind_array_by_name | Domů | oci_cancel


oci_cancel

(PHP 5, PECL oci8:1.1-1.2.4)

oci_cancel — Cancels reading from cursor

Popis

bool oci_cancel ( resource $statement )

Invalidates a cursor, freeing all associated resources and cancels the ability to read from it.

Seznam parametrů

statement

An OCI statement.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
oci_bind_by_name | Domů | oci_close


oci_close

(PHP 5, PECL oci8:1.1-1.2.4)

oci_close — Closes Oracle connection

Popis

bool oci_close ( resource $connection )

Closes the Oracle connection.

Seznam parametrů

connection

An Oracle connection identifier, returned by oci_connect().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Poznámky

Poznámka: Starting from the version 1.1 oci_close() correctly closes the Oracle connection. Use oci8.old_oci_close_semantics option to restore old behaviour of this function.

Předcházející | Nahoru | Další
oci_cancel | Domů | OCI-Collection->append


OCI-Collection->append

(No version information available, might be only in CVS)

OCI-Collection->append — Appends element to the collection

Popis

class OCI-Collection {
bool append ( mixed $value )
}

Appends element to the end of the collection.

Seznam parametrů

value

The value to be added to the collection. Can be a string or a number.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

OCI-Collection->assign

Předcházející | Nahoru | Další
oci_close | Domů | OCI-Collection->assign


OCI-Collection->assign

(No version information available, might be only in CVS)

OCI-Collection->assign — Assigns a value to the collection from another existing collection

Popis

class OCI-Collection {
bool assign ( OCI-Collection $from )
}

Assigns a value to the collection from another, previously created collection. Both collections must be created with oci_new_collection() prior to using them.

Seznam parametrů

from

An instance of OCI-Collection.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

OCI-Collection->append

Předcházející | Nahoru | Další
OCI-Collection->append | Domů | OCI-Collection->assignElem


OCI-Collection->free

(No version information available, might be only in CVS)

OCI-Collection->free — Frees the resources associated with the collection object

Popis

class OCI-Collection {
bool free ( void )
}

Frees the resources associated with the collection object.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

oci_new_collection

Předcházející | Nahoru | Další
OCI-Collection->assignElem | Domů | OCI-Collection->getElem


OCI-Collection->max

(No version information available, might be only in CVS)

OCI-Collection->max — Returns the maximum number of elements in the collection

Popis

class OCI-Collection {
int max ( void )
}

Returns the maximum number of elements in the collection.

Návratové hodnoty

Returns the maximum number as an integer, or FALSE on errors.

If the returned value is 0, then the number of elements is not limited.

Viz také

OCI-Collection->size

Předcházející | Nahoru | Další
OCI-Collection->getElem | Domů | OCI-Collection->size


OCI-Collection->size

(No version information available, might be only in CVS)

OCI-Collection->size — Returns size of the collection

Popis

class OCI-Collection {
int size ( void )
}

Returns the size of the collection.

Návratové hodnoty

Returns the number of elements in the collection or FALSE on error.

Viz také

OCI-Collection->max

Předcházející | Nahoru | Další
OCI-Collection->max | Domů | OCI-Collection->trim


OCI-Collection->trim

(No version information available, might be only in CVS)

OCI-Collection->trim — Trims elements from the end of the collection

Popis

class OCI-Collection {
bool trim ( int $num )
}

Trims num of elements from the end of the collection.

Seznam parametrů

num

The number of elements to be trimmed.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

OCI-Collection->size

Předcházející | Nahoru | Další
OCI-Collection->size | Domů | oci_commit


oci_commit

(PHP 5, PECL oci8:1.1-1.2.4)

oci_commit — Commits outstanding statements

Popis

bool oci_commit ( resource $connection )

Commits all outstanding statements for the active transaction on the Oracle connection.

Seznam parametrů

connection

An Oracle connection identifier, returned by oci_connect() or oci_pconnect().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1442. oci_commit() example

<?php
// Login to Oracle server
$conn = oci_connect('scott', 'tiger');

// Parse SQL
$stmt = oci_parse($conn, "
                          INSERT INTO
                                     employees (name, surname)
                               VALUES
                                     ('Maxim', 'Maletsky')
                         ");

/* Execute statement
   OCI_DEFAULT tells oci_execute()
   not to commit statement immediately */
oci_execute($stmt, OCI_DEFAULT);

/*
....
Parsing and executing other statements here ...
....
*/

// Commit transaction
$committed = oci_commit($conn);

// Test whether commit was successful. If error occurred, return error message
if (!$committed) {
    $error = oci_error($conn);
    echo 'Commit failed. Oracle reports: ' . $error['message'];
}

?>

Poznámky

Poznámka: Transactions are automatically rolled back when you close the connection, or when the script ends, whichever is soonest. You need to explicitly call oci_commit() to commit the transaction, or oci_rollback() to abort it.

Viz také

oci_rollback()
oci_execute()

Předcházející | Nahoru | Další
OCI-Collection->trim | Domů | oci_connect


oci_connect

(PHP 5, PECL oci8:1.1-1.2.4)

oci_connect — Establishes a connection to the Oracle server

Popis

resource oci_connect ( string $username, string $password [, string $db [, string $charset [, int $session_mode]]] )

Returns a connection identifier needed for most other OCI calls.

Seznam parametrů

username

The Oracle user name.

password

The password for username.

db

This optional parameter can either contain the name of the local Oracle instance or the name of the entry in tnsnames.ora.

If the not specified, PHP uses environment variables ORACLE_SID and TWO_TASK to determine the name of local Oracle instance and location of tnsnames.ora accordingly.

charset

Při použití serveru Oracle verze 9.2 a novější, můžete indikovat parametr charset, který se použije pro nové spojení. Používáte-li server Oracle < 9.2, tento parametr se bude ignorovat a místo něho se použije proměnná prostředí NLS_LANG.

session_mode

This parameter is available since version 1.1 and accepts the following values: OCI_DEFAULT, OCI_SYSOPER and OCI_SYSDBA. If either OCI_SYSOPER or OCI_SYSDBA were specified, this function will try to establish privileged connection using external credentials. Privileged connections are disabled by default. To enable them you need to set oci8.privileged_connect to On.

Návratové hodnoty

Returns a connection identifier or FALSE on error.

Příklady

Příklad 1443. oci_connect() example

<?php
echo "<pre>";
$db = "";

$c1 = oci_connect("scott", "tiger", $db);
$c2 = oci_connect("scott", "tiger", $db);

function create_table($conn)
{
  $stmt = oci_parse($conn, "create table scott.hallo (test varchar2(64))");
  oci_execute($stmt);
  echo $conn . " created table\n\n";
}

function drop_table($conn)
{
  $stmt = oci_parse($conn, "drop table scott.hallo");
  oci_execute($stmt);
  echo $conn . " dropped table\n\n";
}

function insert_data($conn)
{
  $stmt = oci_parse($conn, "insert into scott.hallo
            values('$conn' || ' ' || to_char(sysdate,'DD-MON-YY HH24:MI:SS'))");
  oci_execute($stmt, OCI_DEFAULT);
  echo $conn . " inserted hallo\n\n";
}

function delete_data($conn)
{
  $stmt = oci_parse($conn, "delete from scott.hallo");
  oci_execute($stmt, OCI_DEFAULT);
  echo $conn . " deleted hallo\n\n";
}

function commit($conn)
{
  oci_commit($conn);
  echo $conn . " committed\n\n";
}

function rollback($conn)
{
  oci_rollback($conn);
  echo $conn . " rollback\n\n";
}

function select_data($conn)
{
  $stmt = oci_parse($conn, "select * from scott.hallo");
  oci_execute($stmt, OCI_DEFAULT);
  echo $conn."----selecting\n\n";
  while (oci_fetch($stmt)) {
    echo $conn . " [" . oci_result($stmt, "TEST") . "]\n\n";
  }
  echo $conn . "----done\n\n";
}

create_table($c1);
insert_data($c1);   // Insert a row using c1
insert_data($c2);   // Insert a row using c2

select_data($c1);   // Results of both inserts are returned
select_data($c2);

rollback($c1);      // Rollback using c1

select_data($c1);   // Both inserts have been rolled back
select_data($c2);

insert_data($c2);   // Insert a row using c2
commit($c2);        // Commit using c2

select_data($c1);   // Result of c2 insert is returned

delete_data($c1);   // Delete all rows in table using c1
select_data($c1);   // No rows returned
select_data($c2);   // No rows returned
commit($c1);        // Commit using c1

select_data($c1);   // No rows returned
select_data($c2);   // No rows returned

drop_table($c1);
echo "</pre>";
?>

Poznámky

Poznámka: If you're using PHP with Oracle Instant Client, you can use easy connect naming method described here: » http://download-west.oracle.com/docs/cd/B12037_01/network.101/b10775/naming.htm#i498306. Basically this means you can specify "//db_host[:port]/database_name" as database name. But if you want to use the old way of naming you must set either ORACLE_HOME or TNS_ADMIN.

Poznámka: The second and subsequent calls to oci_connect() with the same parameters will return the connection handle returned from the first call. This means that queries issued against one handle are also applied to the other handles, because they are the same handle. This behaviour is demonstrated in Example 1 below. If you require two handles to be transactionally isolated from each other, you should use oci_new_connect() instead.

Poznámka: In PHP versions before 5.0.0 you must use ocilogon() instead. This name still can be used, it was left as the alias of oci_connect() for downwards compatability. This, however, is deprecated and not recommended.

Viz také

oci_pconnect()
oci_new_connect()
oci_close()

Předcházející | Nahoru | Další
oci_commit | Domů | oci_define_by_name


oci_define_by_name

(PHP 5, PECL oci8:1.1-1.2.4)

oci_define_by_name — Uses a PHP variable for the define-step during a SELECT

Popis

bool oci_define_by_name ( resource $statement, string $column_name, mixed &$variable [, int $type] )

Defines PHP variables for fetches of SQL-Columns.

Seznam parametrů

statement

A valid OCI statement identifier.

column_name

The column name. Must be uppercased.

Take into consideration that Oracle uses ALL-UPPERCASE column names, whereby in your select you can also use lowercase. If you define a variable that doesn't exists in your select statement, no error will be issued.

variable

The PHP variable.

type

If you need to define an abstract datatype (LOB/ROWID/BFILE) you must allocate it first using oci_new_descriptor(). See also the oci_bind_by_name() function.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1444. oci_define_by_name() example

<?php
/* oci_define_by_name example - thies at thieso dot net (980219) */

$conn = oci_connect("scott", "tiger");

$stmt = oci_parse($conn, "SELECT empno, ename FROM emp");

/* the define MUST be done BEFORE oci_execute! */

oci_define_by_name($stmt, "EMPNO", $empno);
oci_define_by_name($stmt, "ENAME", $ename);

oci_execute($stmt);

while (oci_fetch($stmt)) {
    echo "empno:" . $empno . "\n";
    echo "ename:" . $ename . "\n";
}

oci_free_statement($stmt);
oci_close($conn);
?>

Poznámky

Poznámka: In PHP versions before 5.0.0 you must use ocidefinebyname() instead. This name still can be used, it was left as alias of oci_define_by_name() for downwards compatability. This, however, is deprecated and not recommended.

Předcházející | Nahoru | Další
oci_connect | Domů | oci_error


oci_error

(PHP 5, PECL oci8:1.1-1.2.4)

oci_error — Returns the last error found

Popis

array oci_error ( [resource $source] )

Returns the last error found.

Seznam parametrů

source

For most errors, the parameter is the most appropriate resource
handle. For connection errors with oci_connect(),
oci_new_connect() or
oci_pconnect() do not pass a parameter.

Návratové hodnoty

If no error is found, oci_error() returns FALSE. oci_error() returns the error as an associative array. In this array, code consists the oracle error code and message the oracle error string.

ChangeLog (záznam změn)

Verze | Popis
4.3 | offset and sqltext will also be included in the return array to indicate the location of the error and the original SQL text which caused it.

Příklady

Příklad 1445. Displaying the Oracle error message after a connection error

$conn = @oci_connect("scott", "tiger", "mydb");
if (!$conn) {
  $e = oci_error();   // For oci_connect errors pass no handle
  echo htmlentities($e['message']);
}

Příklad 1446. Displaying the Oracle error message after a parsing error

$stmt = @oci_parse($conn, "select ' from dual");  // note mismatched quote
if (!$stmt) {
  $e = oci_error($conn);  // For oci_parse errors pass the connection handle
  echo htmlentities($e['message']);
}

Příklad 1447. Displaying the Oracle error message and problematic statement after an execution error

$r = oci_execute($stmt);
if (!$r) {
  $e = oci_error($stmt); // For oci_execute errors pass the statementhandle
  echo htmlentities($e['message']);
  echo "<pre>";
  echo htmlentities($e['sqltext']);
  printf("\n%".($e['offset']+1)."s", "^");
  echo "</pre>";
}

Poznámky

Poznámka: In PHP versions before 5.0.0 you must use ocierror() instead. This name still can be used, it was left as alias of oci_error() for downwards compatability. This, however, is deprecated and not recommended.

Předcházející | Nahoru | Další
oci_define_by_name | Domů | oci_execute


oci_execute

(PHP 5, PECL oci8:1.1-1.2.4)

oci_execute — Executes a statement

Popis

bool oci_execute ( resource $statement [, int $mode] )

Executes a previously parsed statement.

Seznam parametrů

statement

A valid OCI statement identifier.

mode

Allows you to specify the execution mode (default is OCI_COMMIT_ON_SUCCESS).

If you don't want statements to be committed automatically, you should specify OCI_DEFAULT as your mode.

When using OCI_DEFAULT mode, you're creating a transaction. Transactions are automatically rolled back when you close the connection, or when the script ends, whichever is soonest. You need to explicitly call oci_commit() to commit the transaction, or oci_rollback() to abort it.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Poznámky

Poznámka: In PHP versions before 5.0.0 you must use ociexecute() instead. This name still can be used, it was left as alias of oci_execute() for downwards compatability. This, however, is deprecated and not recommended.

Viz také

oci_parse()

Předcházející | Nahoru | Další
oci_error | Domů | oci_fetch_all


oci_fetch_all

(PHP 5, PECL oci8:1.1-1.2.4)

oci_fetch_all — Fetches all rows of result data into an array

Popis

int oci_fetch_all ( resource $statement, array &$output [, int $skip [, int $maxrows [, int $flags]]] )

Fetches all the rows from a result into a user-defined array.

Pro detaily o mapování datových typů prováděném ovladačem oci8 viz datové typy podporované ovladačem

Seznam parametrů

statement

A valid OCI statement identifier.

output

Poznámka: Tato funkce nastavuje pole s hodnotou NULL na hodnotu PHP NULL.

skip

The number of initial rows to ignore when fetching the result (default value of 0, to start at the first line).

maxrows

The number of rows to read, starting at the skipth row (default to -1, meaning all the rows).

flags

Parameter flags can be any combination of the following:

OCI_FETCHSTATEMENT_BY_ROW
OCI_FETCHSTATEMENT_BY_COLUMN (default value)
OCI_NUM
OCI_ASSOC

Návratové hodnoty

Returns the number of rows fetched or FALSE in case of an error.

Příklady

Příklad 1448. oci_fetch_all() example

<?php
/* oci_fetch_all example mbritton at verinet dot com (990624) */

$conn = oci_connect("scott", "tiger");

$stmt = oci_parse($conn, "select * from emp");

oci_execute($stmt);

$nrows = oci_fetch_all($stmt, $results);
if ($nrows > 0) {
   echo "<table border=\"1\">\n";
   echo "<tr>\n";
   foreach ($results as $key => $val) {
      echo "<th>$key</th>\n";
   }
   echo "</tr>\n";

   for ($i = 0; $i < $nrows; $i++) {
      echo "<tr>\n";
      foreach ($results as $data) {
         echo "<td>$data[$i]</td>\n";
      }
      echo "</tr>\n";
   }
   echo "</table>\n";
} else {
   echo "No data found<br />\n";
}
echo "$nrows Records Selected<br />\n";

oci_free_statement($stmt);
oci_close($conn);
?>

Poznámky

Poznámka: In PHP versions before 5.0.0 you must use ocifetchstatement() instead. This name still can be used, it was left as alias of oci_fetch_all() for downwards compatability. This, however, is deprecated and not recommended.

Předcházející | Nahoru | Další
oci_execute | Domů | oci_fetch_array


oci_fetch_array

(PHP 5, PECL oci8:1.1-1.2.4)

oci_fetch_array — Returns the next row from the result data as an associative or numeric array, or both

Popis

array oci_fetch_array ( resource $statement [, int $mode] )

Returns an array, which corresponds to the next result row.

Pro detaily o mapování datových typů prováděném ovladačem oci8 viz datové typy podporované ovladačem

It should be mentioned here, that oci_fetch_array() is insignificantly slower, than oci_fetch_row(), but much more handy.

Seznam parametrů

statement

A valid OCI statement identifier.

statement

An optional second parameter can be any combination of the following constants:

OCI_BOTH - return an array with both associative and numeric indices (the same as OCI_ASSOC + OCI_NUM). This is the default behavior.
OCI_ASSOC - return an associative array (as oci_fetch_assoc() works).
OCI_NUM - return a numeric array, (as oci_fetch_row() works).
OCI_RETURN_NULLS - create empty elements for the NULL fields.
OCI_RETURN_LOBS - return the value of a LOB of the descriptor.

Default mode is OCI_BOTH.

Návratové hodnoty

Returns an array with both associative and numeric indices, or FALSE if there are no more rows in the statement.

Poznámka: Tato funkce nastavuje pole s hodnotou NULL na hodnotu PHP NULL.

Poznámka: Oracle returns all field names in uppercase and associative indices in the result array will be uppercased too.

Příklady

Příklad 1449. oci_fetch_array() with OCI_BOTH example

<?php
$connection = oci_connect("apelsin", "kanistra");

$query = "SELECT id, name FROM fruits";

$statement = oci_parse ($connection, $query);
oci_execute ($statement);

while ($row = oci_fetch_array ($statement, OCI_BOTH)) {
    echo $row[0]." and ".$row['ID']." is the same<br>";
    echo $row[1]." and ".$row['NAME']." is the same<br>";
}
?>

Příklad 1450. oci_fetch_array() with OCI_NUM example

<?php
$connection = oci_connect("user", "password");

$query = "SELECT id, name, lob_field FROM fruits";

$statement = oci_parse ($connection, $query);
oci_execute ($statement);

while ($row = oci_fetch_array ($statement, OCI_NUM)) {
    echo $row[0]."<br>";
    echo $row[1]."<br>";
    echo $row[2]->read(100)."<br>";  //this will output first 100 bytes from LOB
}
?>

Příklad 1451. oci_fetch_array() with OCI_ASSOC example

<?php
$connection = oci_connect("user", "password");

$query = "SELECT id, name, lob_field FROM fruits";

$statement = oci_parse ($connection, $query);
oci_execute ($statement);

while ($row = oci_fetch_array ($statement, OCI_ASSOC)) {
    echo $row['ID']."<br>";
    echo $row['NAME']."<br>";
    echo $row['LOB_FIELD']."<br>";  //this will output "Object id #1"
}
?>

Příklad 1452. oci_fetch_array() with OCI_RETURN_LOBS example

<?php
$connection = oci_connect("user", "password");

$query = "SELECT id, name, lob_field FROM fruits";

$statement = oci_parse ($connection, $query);
oci_execute ($statement);

while ($row = oci_fetch_array ($statement, (OCI_NUM+OCI_RETURN_LOBS))) {
    echo $row[0]."<br>";
    echo $row[1]."<br>";
    echo $row['LOB_FIELD']."<br>";  //this will output LOB's content
}
?>

Viz také

oci_fetch_assoc()
oci_fetch_object()
oci_fetch_row()
oci_fetch_all()

Předcházející | Nahoru | Další
oci_fetch_all | Domů | oci_fetch_assoc


oci_fetch_assoc

(PHP 5, PECL oci8:1.1-1.2.4)

oci_fetch_assoc — Returns the next row from the result data as an associative array

Popis

array oci_fetch_assoc ( resource $statement )

Returns the next row from the result data as an associative array.

Calling oci_fetch_assoc() is identical to calling oci_fetch_array() with OCI_ASSOC.

A subsequent call to oci_fetch_assoc() will return the next row or FALSE if there are no more rows.

Pro detaily o mapování datových typů prováděném ovladačem oci8 viz datové typy podporované ovladačem

Seznam parametrů

statement

A valid OCI statement identifier.

Návratové hodnoty

Returns an associative array, or FALSE if there are no more rows in the statement.

Poznámka: Tato funkce nastavuje pole s hodnotou NULL na hodnotu PHP NULL.

Poznámka: Oracle returns all field names in uppercase and associative indices in the result array will be uppercased too.

Viz také

oci_fetch_array()
oci_fetch_object()
oci_fetch_row()
oci_fetch_all()

Předcházející | Nahoru | Další
oci_fetch_array | Domů | oci_fetch_object


oci_fetch_object

(PHP 5, PECL oci8:1.1-1.2.4)

oci_fetch_object — Returns the next row from the result data as an object

Popis

object oci_fetch_object ( resource $statement )

Returns the next row from the result data as an object.

Subsequent calls to oci_fetch_object() will return the next row from the result or FALSE if there are no more rows.

Pro detaily o mapování datových typů prováděném ovladačem oci8 viz datové typy podporované ovladačem

Seznam parametrů

statement

A valid OCI statement identifier.

Návratové hodnoty

Returns an object, which attributes correspond to fields in statement, or FALSE if there are no more rows in the statement.

Poznámka: Tato funkce nastavuje pole s hodnotou NULL na hodnotu PHP NULL.

Poznámka: Oracle returns all field names in uppercase and associative indices in the result object will be uppercased too.

Viz také

oci_fetch_array()
oci_fetch_assoc()
oci_fetch_row()
oci_fetch_all()

Předcházející | Nahoru | Další
oci_fetch_assoc | Domů | oci_fetch_row


oci_fetch_row

(PHP 5, PECL oci8:1.1-1.2.4)

oci_fetch_row — Returns the next row from the result data as a numeric array

Popis

array oci_fetch_row ( resource $statement )

Returns the next row from the result data as an indexed array.

Calling oci_fetch_row() is identical to calling oci_fetch_array() with OCI_NUM.

Subsequent calls to oci_fetch_row() will return the next row from the result data or FALSE if there are no more rows.

Pro detaily o mapování datových typů prováděném ovladačem oci8 viz datové typy podporované ovladačem

Seznam parametrů

statement

A valid OCI statement identifier.

Návratové hodnoty

Returns an indexed array with the field information, or FALSE if there are no more rows in the statement.

Poznámka: Tato funkce nastavuje pole s hodnotou NULL na hodnotu PHP NULL.

Viz také

oci_fetch_array()
oci_fetch_assoc()
oci_fetch_object()
oci_fetch_all()

Předcházející | Nahoru | Další
oci_fetch_object | Domů | oci_fetch


oci_fetch

(PHP 5, PECL oci8:1.1-1.2.4)

oci_fetch — Fetches the next row into result-buffer

Popis

bool oci_fetch ( resource $statement )

Fetches the next row (for SELECT statements) into the internal result-buffer.

Pro detaily o mapování datových typů prováděném ovladačem oci8 viz datové typy podporované ovladačem

Seznam parametrů

statement

A valid OCI statement identifier.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Poznámky

Poznámka: In PHP versions before 5.0.0 you must use ocifetch() instead. This name still can be used, it was left as alias of oci_fetch() for downwards compatability. This, however, is deprecated and not recommended.

Předcházející | Nahoru | Další
oci_fetch_row | Domů | oci_field_is_null


oci_field_is_null

(PHP 5, PECL oci8:1.1-1.2.4)

oci_field_is_null — Checks if the field is NULL

Popis

bool oci_field_is_null ( resource $statement, mixed $field )

Checks if the given field from the statement is NULL.

Seznam parametrů

statement

A valid OCI statement identifier.

field

Can be a field's index or a field's name (uppercased).

Návratové hodnoty

Returns TRUE if field is NULL, FALSE otherwise.

Poznámky

Poznámka: In PHP versions before 5.0.0 you must use ocicolumnisnull() instead. This name still can be used, it was left as alias of oci_field_is_null() for downwards compatability. This, however, is deprecated and not recommended.

Předcházející | Nahoru | Další
oci_fetch | Domů | oci_field_name


oci_field_name

(PHP 5, PECL oci8:1.1-1.2.4)

oci_field_name — Returns the name of a field from the statement

Popis

string oci_field_name ( resource $statement, int $field )

Returns the name of the field.

Seznam parametrů

statement

A valid OCI statement identifier.

field

Can be the field's index (1-based) or name.

Návratové hodnoty

Returns the name as a string, or FALSE on errors.

Příklady

Příklad 1453. oci_field_name() example

<?php
$conn = oci_connect("scott", "tiger");
$stmt = oci_parse($conn, "SELECT * FROM emp");
oci_execute($stmt);

echo "<table border=\"1\">";
echo "<tr>";
echo "<th>Name</th>";
echo "<th>Type</th>";
echo "<th>Length</th>";
echo "</tr>";

$ncols = oci_num_fields($stmt);

for ($i = 1; $i <= $ncols; $i++) {
    $column_name  = oci_field_name($stmt, $i);
    $column_type  = oci_field_type($stmt, $i);
    $column_size  = oci_field_size($stmt, $i);

    echo "<tr>";
    echo "<td>$column_name</td>";
    echo "<td>$column_type</td>";
    echo "<td>$column_size</td>";
    echo "</tr>";
}

echo "</table>\n";
oci_free_statement($stmt);
oci_close($conn);
?>

Poznámky

Poznámka: In PHP versions before 5.0.0 you must use ocicolumnname() instead. This name still can be used, it was left as alias of oci_field_name() for downwards compatability. This, however, is deprecated and not recommended.

Viz také

oci_num_fields()
oci_field_type()
oci_field_size()

Předcházející | Nahoru | Další
oci_field_is_null | Domů | oci_field_precision


oci_field_precision

(PHP 5, PECL oci8:1.1-1.2.4)

oci_field_precision — Tell the precision of a field

Popis

int oci_field_precision ( resource $statement, int $field )

Returns precision of the field.

For FLOAT columns, precision is nonzero and scale is -127. If precision is 0, then column is NUMBER. Else it's NUMBER(precision, scale).

Seznam parametrů

statement

A valid OCI statement identifier.

field

Can be the field's index (1-based) or name.

Návratové hodnoty

Returns the precision as an integer, or FALSE on errors.

Poznámky

Poznámka: In PHP versions before 5.0.0 you must use ocicolumnprecision() instead. This name still can be used, it was left as alias of oci_field_precision() for downwards compatability. This, however, is deprecated and not recommended.

Viz také

oci_field_scale()
oci_field_type()

Předcházející | Nahoru | Další
oci_field_name | Domů | oci_field_scale


oci_field_scale

(PHP 5, PECL oci8:1.1-1.2.4)

oci_field_scale — Tell the scale of the field

Popis

int oci_field_scale ( resource $statement, int $field )

Returns the scale of the column with field index.

For FLOAT columns, precision is nonzero and scale is -127. If precision is 0, then column is NUMBER. Else it's NUMBER(precision, scale).

Seznam parametrů

statement

A valid OCI statement identifier.

field

Can be the field's index (1-based) or name.

Návratové hodnoty

Returns the scale as an integer, or FALSE on errors.

Poznámky

Poznámka: In PHP versions before 5.0.0 you must use ocicolumnscale() instead. This name still can be used, it was left as alias of oci_field_scale() for downwards compatability. This, however, is deprecated and not recommended.

Viz také

oci_field_precision()
oci_field_type()

Předcházející | Nahoru | Další
oci_field_precision | Domů | oci_field_size


oci_field_size

(PHP 5, PECL oci8:1.1-1.2.4)

oci_field_size — Returns field's size

Popis

int oci_field_size ( resource $statement, mixed $field )

Returns the size of a field.

Seznam parametrů

statement

A valid OCI statement identifier.

field

Can be the field's index (1-based) or name.

Návratové hodnoty

Returns the size of a field in bytes, or FALSE on errors.

Příklady

Příklad 1454. oci_field_size() example

<?php
$conn = oci_connect("scott", "tiger");
$stmt = oci_parse($conn, "SELECT * FROM emp");
oci_execute($stmt);

echo "<table border=\"1\">";
echo "<tr>";
echo "<th>Name</th>";
echo "<th>Type</th>";
echo "<th>Length</th>";
echo "</tr>";

$ncols = oci_num_fields($stmt);

for ($i = 1; $i <= $ncols; $i++) {
    $column_name  = oci_field_name($stmt, $i);
    $column_type  = oci_field_type($stmt, $i);
    $column_size  = oci_field_size($stmt, $i);
    echo "<tr>";
    echo "<td>$column_name</td>";
    echo "<td>$column_type</td>";
    echo "<td>$column_size</td>";
    echo "</tr>";
}

echo "</table>";

oci_free_statement($stmt);
oci_close($conn);
?>

Poznámky

Poznámka: In PHP versions before 5.0.0 you must use ocicolumnsize() instead. This name still can be used, it was left as alias of oci_field_size() for downwards compatability. This, however, is deprecated and not recommended.

Viz také

oci_num_fields()
oci_field_name()

Předcházející | Nahoru | Další
oci_field_scale | Domů | oci_field_type_raw


oci_field_type_raw

(PHP 5, PECL oci8:1.1-1.2.4)

oci_field_type_raw — Tell the raw Oracle data type of the field

Popis

int oci_field_type_raw ( resource $statement, int $field )

Returns Oracle's raw data type of the field.

However, if you want to get field's type, then oci_field_type() will suit you better.

Seznam parametrů

statement

A valid OCI statement identifier.

field

Can be the field's index (1-based) or name.

Návratové hodnoty

Returns Oracle's raw data type as a string, or FALSE on errors.

Poznámky

Poznámka: In PHP versions before 5.0.0 you must use ocicolumntyperaw() instead. This name still can be used, it was left as alias of oci_field_type_raw() for downwards compatability. This, however, is deprecated and not recommended.

Předcházející | Nahoru | Další
oci_field_size | Domů | oci_field_type


oci_field_type

(PHP 5, PECL oci8:1.1-1.2.4)

oci_field_type — Returns field's data type

Popis

mixed oci_field_type ( resource $statement, int $field )

Returns a field's data type.

Seznam parametrů

statement

A valid OCI statement identifier.

field

Can be the field's index (1-based) or name.

Návratové hodnoty

Returns the field data type as a string, or FALSE on errors.

Návratové hodnoty

Příklad 1455. oci_field_type() example

<?php
$conn = oci_connect("scott", "tiger");
$stmt = oci_parse($conn, "SELECT * FROM emp");
oci_execute($stmt);

echo "<table border=\"1\">";
echo "<tr>";
echo "<th>Name</th>";
echo "<th>Type</th>";
echo "<th>Length</th>";
echo "</tr>";

$ncols = oci_num_fields($stmt);

for ($i = 1; $i <= $ncols; $i++) {
    $column_name  = oci_field_name($stmt, $i);
    $column_type  = oci_field_type($stmt, $i);
    $column_size  = oci_field_size($stmt, $i);

    echo "<tr>";
    echo "<td>$column_name</td>";
    echo "<td>$column_type</td>";
    echo "<td>$column_size</td>";
    echo "</tr>";
}

echo "</table>\n";

oci_free_statement($stmt);
oci_close($conn);
?>

Poznámky

Poznámka: In PHP versions before 5.0.0 you must use ocicolumntype() instead. This name still can be used, it was left as alias of oci_field_type() for downwards compatability. This, however, is deprecated and not recommended.

Viz také

oci_num_fields()
oci_field_name()
oci_field_size()

Předcházející | Nahoru | Další
oci_field_type_raw | Domů | oci_free_statement


oci_free_statement

(PHP 5, PECL oci8:1.1-1.2.4)

oci_free_statement — Frees all resources associated with statement or cursor

Popis

bool oci_free_statement ( resource $statement )

Frees resources associated with Oracle's cursor or statement, which was received from as a result of oci_parse() or obtained from Oracle.

Seznam parametrů

statement

A valid OCI statement identifier.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
oci_field_type | Domů | oci_internal_debug


oci_internal_debug

(PHP 5, PECL oci8:1.1-1.2.4)

oci_internal_debug — Enables or disables internal debug output

Popis

void oci_internal_debug ( bool $onoff )

Enables or disables internal debug output.

Seznam parametrů

onoff

Set this to FALSE to turn debug output off or TRUE to turn it on.

Návratové hodnoty

Nevrací se žádná hodnota.

Poznámky

Poznámka: In PHP versions before 5.0.0 you must use ociinternaldebug() instead. This name still can be used, it was left as alias of oci_internal_debug() for downwards compatability. This, however, is deprecated and not recommended.

Předcházející | Nahoru | Další
oci_free_statement | Domů | OCI-Lob->append


OCI-Lob->append

(No version information available, might be only in CVS)

OCI-Lob->append — Appends data from the large object to another large object

Popis

class OCI-Lob {
bool append ( OCI-Lob $lob_from )
}

Appends data from the large object to the end of another large object.

Writing to the large object with this method will fail if buffering was previously enabled. You must disable buffering before appending. You may need to flush buffers with OCI-Lob->flush before disabling buffering.

Seznam parametrů

lob_from

The copied LOB.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

OCI-Lob->flush
OCI-Lob->setBuffering
OCI-Lob->getBuffering

Předcházející | Nahoru | Další
oci_internal_debug | Domů | OCI-Lob->close


OCI-Lob->close

(No version information available, might be only in CVS)

OCI-Lob->close — Closes LOB descriptor

Popis

class OCI-Lob {
bool close ( void )
}

Closes descriptor of LOB or FILE. This function should be used only with OCI-Lob->writeTemporary.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

OCI-Lob->writeTemporary

Předcházející | Nahoru | Další
OCI-Lob->append | Domů | oci_lob_copy


oci_lob_copy

(PHP 5, PECL oci8:1.1-1.2.4)

oci_lob_copy — Copies large object

Popis

bool oci_lob_copy ( OCI-Lob $lob_to, OCI-Lob $lob_from [, int $length] )

Copies a large object or a part of a large object to another large object. Old LOB-recipient data will be overwritten.

If you need to copy a particular part of a LOB to a particular position of a LOB, use oci_lob_seek() to move LOB internal pointers.

Seznam parametrů

lob_to

The destination LOB.

lob_from

The copied LOB.

length

Indicates the length of data to be copied.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
OCI-Lob->close | Domů | OCI-Lob->eof


OCI-Lob->eof

(No version information available, might be only in CVS)

OCI-Lob->eof — Tests for end-of-file on a large object's descriptor

Popis

class OCI-Lob {
bool eof ( void )
}

Tells whether the internal pointer of large object is at the end of LOB.

Návratové hodnoty

Returns TRUE if internal pointer of large object is at the end of LOB. Otherwise returns FALSE.

Viz také

OCI-Lob->size

Předcházející | Nahoru | Další
oci_lob_copy | Domů | OCI-Lob->erase


OCI-Lob->erase

(No version information available, might be only in CVS)

OCI-Lob->erase — Erases a specified portion of the internal LOB data

Popis

class OCI-Lob {
int erase ( [int $offset [, int $length]] )
}

Erases a specified portion of the internal LOB data starting at a specified offset. If called without parameters, it erases all LOB data.

For BLOBs, erasing means that the existing LOB value is overwritten with zero-bytes. For CLOBs, the existing LOB value is overwritten with spaces.

Seznam parametrů

offset

length

Návratové hodnoty

Returns the actual number of characters/bytes erased or FALSE in case of error.

Viz také

OCI-Lob->truncate

Předcházející | Nahoru | Další
OCI-Lob->eof | Domů | OCI-Lob->export


OCI-Lob->export

(No version information available, might be only in CVS)

OCI-Lob->export — Exports LOB's contents to a file

Popis

class OCI-Lob {
bool export ( string $filename [, int $start [, int $length]] )
}

Exports LOB contents to a file.

Seznam parametrů

filename

Path to the file.

start

Indicates from where to start exporting.

length

Indicates the length of data to be exported.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

OCI-Lob->import

Předcházející | Nahoru | Další
OCI-Lob->erase | Domů | OCI-Lob->flush


OCI-Lob->flush

(No version information available, might be only in CVS)

OCI-Lob->flush — Flushes/writes buffer of the LOB to the server

Popis

class OCI-Lob {
bool flush ( [int $flag] )
}

OCI-Lob->flush() actually writes data to the server.

Seznam parametrů

flag

By default, resources are not freed, but using flag OCI_LOB_BUFFER_FREE you can do it explicitly. Be sure you know what you're doing - next read/write operation to the same part of LOB will involve a round-trip to the server and initialize new buffer resources. It is recommended to use OCI_LOB_BUFFER_FREE flag only when you are not going to work with the LOB anymore.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Returns FALSE if buffering was not enabled or an error occurred.

Viz také

OCI-Lob->getBuffering
OCI-Lob->setBuffering

Předcházející | Nahoru | Další
OCI-Lob->export | Domů | OCI-Lob->free


OCI-Lob->import

(No version information available, might be only in CVS)

OCI-Lob->import — Imports file data to the LOB

Popis

class OCI-Lob {
bool import ( string $filename )
}

Writes data from the filename in to the current position of large object.

Seznam parametrů

filename

Path to the file.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

OCI-Lob->export
OCI-Lob->write

Předcházející | Nahoru | Další
OCI-Lob->getBuffering | Domů | oci_lob_is_equal


oci_lob_is_equal

(PHP 5, PECL oci8:1.1-1.2.4)

oci_lob_is_equal — Compares two LOB/FILE locators for equality

Popis

bool oci_lob_is_equal ( OCI-Lob $lob1, OCI-Lob $lob2 )

Compares two LOB/FILE locators.

Seznam parametrů

lob1

A LOB identifier.

lob2

A LOB identifier.

Návratové hodnoty

Returns TRUE if these objects are equal, FALSE otherwise.

Předcházející | Nahoru | Další
OCI-Lob->import | Domů | OCI-Lob->load


OCI-Lob->load

(No version information available, might be only in CVS)

OCI-Lob->load — Returns large object's contents

Popis

class OCI-Lob {
string load ( void )
}

Returns large object's contents. As script execution is terminated when the memory_limit is reached, ensure that the LOB does not exceed this limit. In most cases it's recommended to use OCI-Lob->read instead.

Návratové hodnoty

Returns the contents of the object, or FALSE on errors.

Viz také

OCI-Lob->read

Předcházející | Nahoru | Další
oci_lob_is_equal | Domů | OCI-Lob->read


OCI-Lob->read

(No version information available, might be only in CVS)

OCI-Lob->read — Reads part of the large object

Popis

class OCI-Lob {
string read ( int $length )
}

Reads length bytes from the current position of LOB's internal pointer.

Reading stops when length bytes have been read or end of the large object is reached. Internal pointer of the large object will be shifted on the amount of bytes read.

Seznam parametrů

length

The length of data to read, in bytes.

Návratové hodnoty

Returns the contents as a string, or FALSE in case of error.

Viz také

OCI-Lob->load
OCI-Lob->write

Předcházející | Nahoru | Další
OCI-Lob->load | Domů | OCI-Lob->rewind


OCI-Lob->rewind

(No version information available, might be only in CVS)

OCI-Lob->rewind — Moves the internal pointer to the beginning of the large object

Popis

class OCI-Lob {
bool rewind ( void )
}

Sets the internal pointer to the beginning of the large object.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

OCI-Lob->seek
OCI-Lob->tell

Předcházející | Nahoru | Další
OCI-Lob->read | Domů | OCI-Lob->save


OCI-Lob->save

(No version information available, might be only in CVS)

OCI-Lob->save — Saves data to the large object

Popis

class OCI-Lob {
bool save ( string $data [, int $offset] )
}

Saves data to the large object.

Seznam parametrů

data

The data to be saved.

offset

Can be used to indicate offset from the beginning of the large object.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

OCI-Lob->write
OCI-Lob->import

Předcházející | Nahoru | Další
OCI-Lob->rewind | Domů | OCI-Lob->saveFile


OCI-Lob->seek

(No version information available, might be only in CVS)

OCI-Lob->seek — Sets the internal pointer of the large object

Popis

class OCI-Lob {
bool seek ( int $offset [, int $whence] )
}

Sets the internal pointer of the large object.

Seznam parametrů

offset

Indicates the amount of bytes, on which internal pointer should be moved from the position, pointed by whence.

whence

May be one of:

OCI_SEEK_SET - sets the position equal to offset
OCI_SEEK_CUR - adds offset bytes to the current position
OCI_SEEK_END - adds offset bytes to the end of large object (use negative value to move to a position before the end of large object)

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

OCI-Lob->rewind
OCI-Lob->tell
OCI-Lob->eof

Předcházející | Nahoru | Další
OCI-Lob->saveFile | Domů | OCI-Lob->setBuffering


OCI-Lob->size

(No version information available, might be only in CVS)

OCI-Lob->size — Returns size of large object

Popis

class OCI-Lob {
int size ( void )
}

Gets the size of the large object.

Návratové hodnoty

Returns length of large object value or FALSE in case of error. Empty objects have zero length.

Předcházející | Nahoru | Další
OCI-Lob->setBuffering | Domů | OCI-Lob->tell


OCI-Lob->tell

(No version information available, might be only in CVS)

OCI-Lob->tell — Returns current position of internal pointer of large object

Popis

class OCI-Lob {
int tell ( void )
}

Gets the current position of a LOB's internal pointer.

Návratové hodnoty

Returns current position of a LOB's internal pointer or FALSE if an error occurred.

Viz také

OCI-Lob->rewind
OCI-Lob->size
OCI-Lob->eof

Předcházející | Nahoru | Další
OCI-Lob->size | Domů | OCI-Lob->truncate


OCI-Lob->truncate

(No version information available, might be only in CVS)

OCI-Lob->truncate — Truncates large object

Popis

class OCI-Lob {
bool truncate ( [int $length] )
}

Truncates the LOB.

Seznam parametrů

length

If provided, this method will truncate the LOB to length bytes. Otherwise, it will completrely purge the LOB.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

OCI-Lob->erase

Předcházející | Nahoru | Další
OCI-Lob->tell | Domů | OCI-Lob->write


OCI-Lob->write

(No version information available, might be only in CVS)

OCI-Lob->write — Writes data to the large object

Popis

class OCI-Lob {
int write ( string $data [, int $length] )
}

Writes data from the parameter data into the current position of LOB's internal pointer.

Seznam parametrů

data

The data to write in the LOB.

length

If this parameter is given, writing will stop after length bytes have been written or the end of data is reached, whichever comes first.

Návratové hodnoty

Returns the number of bytes written or FALSE in case of error.

Viz také

OCI-Lob->read

Předcházející | Nahoru | Další
OCI-Lob->truncate | Domů | OCI-Lob->writeTemporary


oci_new_collection

(PHP 5, PECL oci8:1.1-1.2.4)

oci_new_collection — Allocates new collection object

Popis

OCI-Collection oci_new_collection ( resource $connection, string $tdo [, string $schema] )

Allocates a new collection object.

Seznam parametrů

connection

An Oracle connection identifier, returned by oci_connect() or oci_pconnect().

tdo

Should be a valid named type (uppercase).

schema

Should point to the scheme, where the named type was created. The name of the current user is the default value.

Návratové hodnoty

Returns a new OCICollection object or FALSE on error.

Poznámky

Poznámka: In PHP versions before 5.0.0 you must use ocinewcollection() instead. This name still can be used, it was left as alias of oci_new_collection() for downwards compatability. This, however, is deprecated and not recommended.

Předcházející | Nahoru | Další
OCI-Lob->writeToFile | Domů | oci_new_connect


oci_new_connect

(PHP 5, PECL oci8:1.1-1.2.4)

oci_new_connect — Establishes a new connection to the Oracle server

Popis

resource oci_new_connect ( string $username, string $password [, string $db [, string $charset [, int $session_mode]]] )

Establishes a new connection to an Oracle server and logs on.

Unlike oci_connect() and oci_pconnect(), oci_new_connect() does not cache connections and will always return a brand-new freshly opened connection handle. This is useful if your application needs transactional isolation between two sets of queries.

Seznam parametrů

username

The Oracle user name.

password

The password for username.

db

This optional parameter can either contain the name of the local Oracle instance or the name of the entry in tnsnames.ora.

If the not specified, PHP uses environment variables ORACLE_SID and TWO_TASK to determine the name of local Oracle instance and location of tnsnames.ora accordingly.

charset

Při použití serveru Oracle verze 9.2 a novější, můžete indikovat parametr charset, který se použije pro nové spojení. Používáte-li server Oracle < 9.2, tento parametr se bude ignorovat a místo něho se použije proměnná prostředí NLS_LANG.

session_mode

This parameter is available since version 1.1 and accepts the following values: OCI_DEFAULT, OCI_SYSOPER and OCI_SYSDBA. If either OCI_SYSOPER or OCI_SYSDBA were specified, this function will try to establish privileged connection using external credentials. Privileged connections are disabled by default. To enable them you need to set oci8.privileged_connect to On.

Návratové hodnoty

Returns a connection identifier or FALSE on error.

Příklady

The following demonstrates how you can separate connections.

Příklad 1456. oci_new_connect() example

<?php
echo "<html><pre>";
$db = "";

$c1 = oci_connect("scott", "tiger", $db);
$c2 = oci_new_connect("scott", "tiger", $db);

function create_table($conn)
{
  $stmt = oci_parse($conn, "create table scott.hallo (test
varchar2(64))");
  oci_execute($stmt);
  echo $conn . " created table\n\n";
}

function drop_table($conn)
{
  $stmt = oci_parse($conn, "drop table scott.hallo");
  oci_execute($stmt);
  echo $conn . " dropped table\n\n";
}

function insert_data($conn)
{
  $stmt = oci_parse($conn, "insert into scott.hallo
            values('$conn' || ' ' || to_char(sysdate,'DD-MON-YY HH24:MI:SS'))");
  oci_execute($stmt, OCI_DEFAULT);
  echo $conn . " inserted hallo\n\n";
}

function delete_data($conn)
{
  $stmt = oci_parse($conn, "delete from scott.hallo");
  oci_execute($stmt, OCI_DEFAULT);
  echo $conn . " deleted hallo\n\n";
}

function commit($conn)
{
  oci_commit($conn);
  echo $conn . " committed\n\n";
}

function rollback($conn)
{
  oci_rollback($conn);
  echo $conn . " rollback\n\n";
}

function select_data($conn)
{
  $stmt = oci_parse($conn, "select * from scott.hallo");
  oci_execute($stmt, OCI_DEFAULT);
  echo $conn . "----selecting\n\n";
  while (oci_fetch($stmt)) {
    echo $conn . " <" . oci_result($stmt, "TEST") . ">\n\n";
  }
  echo $conn . "----done\n\n";
}

create_table($c1);
insert_data($c1);

select_data($c1);
select_data($c2);

rollback($c1);

select_data($c1);
select_data($c2);

insert_data($c2);
commit($c2);

select_data($c1);

delete_data($c1);
select_data($c1);
select_data($c2);
commit($c1);

select_data($c1);
select_data($c2);

drop_table($c1);
echo "</pre></html>";
?>

Poznámky

Poznámka: If you're using PHP with Oracle Instant Client, you can use easy connect naming method described here: » http://download-west.oracle.com/docs/cd/B12037_01/network.101/b10775/naming.htm#i498306. Basically this means you can specify "//db_host[:port]/database_name" as database name. But if you want to use the old way of naming you must set either ORACLE_HOME or TNS_ADMIN.

Poznámka: In PHP versions before 5.0.0 you must use ocinlogon() instead. This name still can be used, it was left as alias of oci_new_connect() for downwards compatability. This, however, is deprecated and not recommended.

Viz také

oci_connect()
oci_pconnect()

Předcházející | Nahoru | Další
oci_new_collection | Domů | oci_new_cursor


oci_new_cursor

(PHP 5, PECL oci8:1.1-1.2.4)

oci_new_cursor — Allocates and returns a new cursor (statement handle)

Popis

resource oci_new_cursor ( resource $connection )

Allocates a new statement handle on the specified connection.

Seznam parametrů

connection

An Oracle connection identifier, returned by oci_connect() or oci_pconnect().

Návratové hodnoty

Returns a new statement handle, or FALSE on error.

Příklady

Příklad 1457. Using REF CURSOR in an Oracle's stored procedure

<?php
// suppose your stored procedure info.output returns a ref cursor in :data

$conn = oci_connect("scott", "tiger");
$curs = oci_new_cursor($conn);
$stmt = oci_parse($conn, "begin info.output(:data); end;");

oci_bind_by_name($stmt, "data", $curs, -1, OCI_B_CURSOR);
oci_execute($stmt);
oci_execute($curs);

while ($data = oci_fetch_row($curs)) {
    var_dump($data);
}

oci_free_statement($stmt);
oci_free_statement($curs);
oci_close($conn);
?>

Příklad 1458. Using REF CURSOR in an Oracle's select statement

<?php
echo "<html><body>";
$conn = oci_connect("scott", "tiger");
$count_cursor = "CURSOR(select count(empno) num_emps from emp " .
                "where emp.deptno = dept.deptno) as EMPCNT from dept";
$stmt = oci_parse($conn, "select deptno,dname,$count_cursor");

oci_execute($stmt);
echo "<table border=\"1\">";
echo "<tr>";
echo "<th>DEPT NAME</th>";
echo "<th>DEPT #</th>";
echo "<th># EMPLOYEES</th>";
echo "</tr>";

while ($data = oci_fetch_assoc($stmt)) {
    echo "<tr>";
    $dname  = $data["DNAME"];
    $deptno = $data["DEPTNO"];
    echo "<td>$dname</td>";
    echo "<td>$deptno</td>";
    oci_execute($data["EMPCNT"]);
    while ($subdata = oci_fetch_assoc($data["EMPCNT"])) {
        $num_emps = $subdata["NUM_EMPS"];
        echo  "<td>$num_emps</td>";
    }
    echo "</tr>";
}
echo "</table>";
echo "</body></html>";
oci_free_statement($stmt);
oci_close($conn);
?>

Poznámky

Poznámka: In PHP versions before 5.0.0 you must use ocinewcursor() instead. This name still can be used, it was left as alias of oci_new_cursor() for downwards compatability. This, however, is deprecated and not recommended.

Předcházející | Nahoru | Další
oci_new_connect | Domů | oci_new_descriptor


oci_new_descriptor

(PHP 5, PECL oci8:1.1-1.2.4)

oci_new_descriptor — Initializes a new empty LOB or FILE descriptor

Popis

OCI-Lob oci_new_descriptor ( resource $connection [, int $type] )

Allocates resources to hold descriptor or LOB locator.

Seznam parametrů

connection

An Oracle connection identifier, returned by oci_connect() or oci_pconnect().

type

Valid values for type are: OCI_D_FILE, OCI_D_LOB and OCI_D_ROWID.

Návratové hodnoty

Returns a new LOB or FILE descriptor on success, FALSE on error.

Příklady

Příklad 1459. oci_new_descriptor() example

<?php
/* This script is designed to be called from a HTML form.
* It expects $user, $password, $table, $where, and $commitsize
* to be passed in from the form.  The script then deletes
* the selected rows using the ROWID and commits after each
* set of $commitsize rows. (Use with care, there is no rollback)
*/
$conn = oci_connect($user, $password);
$stmt = oci_parse($conn, "select rowid from $table $where");
$rowid = oci_new_descriptor($conn, OCI_D_ROWID);
oci_define_by_name($stmt, "ROWID", $rowid);
oci_execute($stmt);
while (oci_fetch($stmt)) {
$nrows = oci_num_rows($stmt);
$delete = oci_parse($conn, "delete from $table where ROWID = :rid");
oci_bind_by_name($delete, ":rid", $rowid, -1, OCI_B_ROWID);
oci_execute($delete);
echo "$nrows\n";
if (($nrows % $commitsize) == 0) {
oci_commit($conn);
}
}
$nrows = oci_num_rows($stmt);
echo "$nrows deleted...\n";
oci_free_statement($stmt);
oci_close($conn);
?>

<?php
/* This script demonstrates file upload to LOB columns
* The formfield used for this example looks like this
* <form action="upload.php" method="post" enctype="multipart/form-data">
* <input type="file" name="lob_upload" />
* ...
*/
if (!isset($lob_upload) || $lob_upload == 'none'){
?>
<form action="upload.php" method="post" enctype="multipart/form-data">
Upload file: <input type="file" name="lob_upload" /><br />
<input type="submit" value="Upload" /> - <input type="reset" value="Reset" />
</form>
<?php
} else {

// $lob_upload contains the temporary filename of the uploaded file

// see also the features section on file upload,
// if you would like to use secure uploads

$conn = oci_connect($user, $password);
$lob = oci_new_descriptor($conn, OCI_D_LOB);
$stmt = oci_parse($conn, "insert into $table (id, the_blob)
values(my_seq.NEXTVAL, EMPTY_BLOB()) returning the_blob into :the_blob");
oci_bind_by_name($stmt, ':the_blob', $lob, -1, OCI_B_BLOB);
oci_execute($stmt, OCI_DEFAULT);
if ($lob->savefile($lob_upload)){
oci_commit($conn);
echo "Blob successfully uploaded\n";
}else{
echo "Couldn't upload Blob\n";
}
oci_free_descriptor($lob);
oci_free_statement($stmt);
oci_close($conn);
}
?>

Příklad 1460. oci_new_descriptor() example

<?php
/* Calling PL/SQL stored procedures which contain clobs as input
 * parameters (PHP 4 >= 4.0.6).
 * Example PL/SQL stored procedure signature is:
 *
 * PROCEDURE save_data
 *   Argument Name                  Type                    In/Out Default?
 *   ------------------------------ ----------------------- ------ --------
 *   KEY                            NUMBER(38)              IN
 *   DATA                           CLOB                    IN
 *
 */

$conn = oci_connect($user, $password);
$stmt = oci_parse($conn, "begin save_data(:key, :data); end;");
$clob = oci_new_descriptor($conn, OCI_D_LOB);
oci_bind_by_name($stmt, ':key', $key);
oci_bind_by_name($stmt, ':data', $clob, -1, OCI_B_CLOB);
$clob->write($data);
oci_execute($stmt, OCI_DEFAULT);
oci_commit($conn);
$clob->free();
oci_free_statement($stmt);
?>

Poznámky

Poznámka: In PHP versions before 5.0.0 you must use ocinewdescriptor() instead. This name still can be used, it was left as alias of oci_new_descriptor() for downwards compatability. This, however, is deprecated and not recommended.

Předcházející | Nahoru | Další
oci_new_cursor | Domů | oci_num_fields


oci_num_fields

(PHP 5, PECL oci8:1.1-1.2.4)

oci_num_fields — Returns the number of result columns in a statement

Popis

int oci_num_fields ( resource $statement )

Gets the number of columns in the given statement.

Seznam parametrů

statement

A valid OCI statement identifier.

Návratové hodnoty

Returns the number of columns as an integer, or FALSE on errors.

Příklady

Příklad 1461. oci_num_fields() example

<?php
$conn = oci_connect("scott", "tiger");
$stmt = oci_parse($conn, "select * from emp");

oci_execute($stmt);

while (oci_fetch($stmt)) {
    echo "\n";
    $ncols = oci_num_fields($stmt);
    for ($i = 1; $i <= $ncols; $i++) {
        $column_name  = oci_field_name($stmt, $i);
        $column_value = oci_result($stmt, $i);
        echo $column_name . ': ' . $column_value . "\n";
    }
    echo "\n";
}

oci_free_statement($stmt);
oci_close($conn);
?>

Poznámky

Poznámka: In PHP versions before 5.0.0 you must use ocinumcols() instead. This name still can be used, it was left as alias of oci_num_fields() for downwards compatability. This, however, is deprecated and not recommended.

Předcházející | Nahoru | Další
oci_new_descriptor | Domů | oci_num_rows


oci_num_rows

(PHP 5, PECL oci8:1.1-1.2.4)

oci_num_rows — Returns number of rows affected during statement execution

Popis

int oci_num_rows ( resource $statement )

Gets the number of rows affected during statement execution.

Seznam parametrů

statement

A valid OCI statement identifier.

Návratové hodnoty

Returns the number of rows affected as an integer, or FALSE on errors.

Příklady

Příklad 1462. oci_num_rows() example

<?php
$conn = oci_connect("scott", "tiger");

$stmt = oci_parse($conn, "create table emp2 as select * from emp");
oci_execute($stmt);
echo oci_num_rows($stmt) . " rows inserted.<br />";
oci_free_statement($stmt);

$stmt = oci_parse($conn, "delete from emp2");
oci_execute($stmt, OCI_DEFAULT);
echo oci_num_rows($stmt) . " rows deleted.<br />";
oci_commit($conn);
oci_free_statement($stmt);

$stmt = oci_parse($conn, "drop table emp2");
oci_execute($stmt);
oci_free_statement($stmt);

oci_close($conn);
?>

Poznámky

Poznámka: This function does not return number of rows selected! For SELECT statements this function will return the number of rows, that were fetched to the buffer with oci_fetch*() functions.

Poznámka: In PHP versions before 5.0.0 you must use ocirowcount() instead. This name still can be used, it was left as alias of oci_num_rows() for downwards compatability. This, however, is deprecated and not recommended.

Předcházející | Nahoru | Další
oci_num_fields | Domů | oci_parse


oci_parse

(PHP 5, PECL oci8:1.1-1.2.4)

oci_parse — Prepares Oracle statement for execution

Popis

resource oci_parse ( resource $connection, string $query )

Prepares the queryusing connection and returns the statement identifier, which can be used with oci_bind_by_name(), oci_execute() and other functions.

Seznam parametrů

connection

An Oracle connection identifier, returned by oci_connect() or oci_pconnect().

query

The SQL query.

Návratové hodnoty

Returns a statement handler on success, or FALSE on error.

Poznámky

Poznámka: This function does not validate query. The only way to find out if query is valid SQL or PL/SQL statement - is to execute it.

Poznámka: In PHP versions before 5.0.0 you must use ociparse() instead. This name still can be used, it was left as alias of oci_parse() for downwards compatability. This, however, is deprecated and not recommended.

Předcházející | Nahoru | Další
oci_num_rows | Domů | oci_password_change


oci_password_change

(PHP 5, PECL oci8:1.1-1.2.4)

oci_password_change — Changes password of Oracle's user

Popis

bool oci_password_change ( resource $connection, string $username, string $old_password, string $new_password )
resource oci_password_change ( string $dbname, string $username, string $old_password, string $new_password )

Changes password for user with username.

Seznam parametrů

connection

An Oracle connection identifier, returned by oci_connect() or oci_pconnect().

username

The Oracle user name.

old_password

The old password.

new_password

The new password to be set.

dbname

The database name.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Poznámky

Poznámka: The second oci_password_change() syntax is available since version 1.1.

Poznámka: In PHP versions before 5.0.0 you must use ocipasswordchange() instead. This name still can be used, it was left as alias of oci_password_change() for downwards compatability. This, however, is deprecated and not recommended.

Předcházející | Nahoru | Další
oci_parse | Domů | oci_pconnect


oci_pconnect

(PHP 5, PECL oci8:1.1-1.2.4)

oci_pconnect — Connect to an Oracle database using a persistent connection

Popis

resource oci_pconnect ( string $username, string $password [, string $db [, string $charset [, int $session_mode]]] )

Creates a persistent connection to an Oracle server and logs on.

Persistent connections are cached and re-used between requests, resulting in reduced overhead on each page load; a typical PHP application will have a single persistent connection open against an Oracle server per Apache child process (or PHP FastCGI/CGI process). See the Persistent Database Connections section for more information.

Seznam parametrů

username

The Oracle user name.

password

The password for username.

db

This optional parameter can either contain the name of the local Oracle instance or the name of the entry in tnsnames.ora.

If the not specified, PHP uses environment variables ORACLE_SID and TWO_TASK to determine the name of local Oracle instance and location of tnsnames.ora accordingly.

charset

Při použití serveru Oracle verze 9.2 a novější, můžete indikovat parametr charset, který se použije pro nové spojení. Používáte-li server Oracle < 9.2, tento parametr se bude ignorovat a místo něho se použije proměnná prostředí NLS_LANG.

session_mode

This parameter is available since version 1.1 and accepts the following values: OCI_DEFAULT, OCI_SYSOPER and OCI_SYSDBA. If either OCI_SYSOPER or OCI_SYSDBA were specified, this function will try to establish privileged connection using external credentials. Privileged connections are disabled by default. To enable them you need to set oci8.privileged_connect to On.

Návratové hodnoty

Returns a connection identifier or FALSE on error.

Poznámky

Poznámka: Starting with version 1.1 of the oci8 extension, the lifetime and maximum amount of persistent Oracle connections can be tuned by setting the following configuration values: oci8.persistent_timeout, oci8.ping_interval and oci8.max_persistent.

Poznámka: If you're using PHP with Oracle Instant Client, you can use easy connect naming method described here: » http://download-west.oracle.com/docs/cd/B12037_01/network.101/b10775/naming.htm#i498306. Basically this means you can specify "//db_host[:port]/database_name" as database name. But if you want to use the old way of naming you must set either ORACLE_HOME or TNS_ADMIN.

Poznámka: In PHP versions before 5.0.0 you must use ociplogon() instead. This name still can be used, it was left as alias of oci_pconnect() for downwards compatability. This, however, is deprecated and not recommended.

Viz také

oci_connect()
oci_new_connect()

Předcházející | Nahoru | Další
oci_password_change | Domů | oci_result


oci_result

(PHP 5, PECL oci8:1.1-1.2.4)

oci_result — Returns field's value from the fetched row

Popis

mixed oci_result ( resource $statement, mixed $field )

Returns the data from field in the current row, fetched by oci_fetch().

Pro detaily o mapování datových typů prováděném ovladačem oci8 viz datové typy podporované ovladačem

Seznam parametrů

statement

field

Can be either use the column number (1-based) or the column name (in uppercase).

Návratové hodnoty

Returns everything as strings except for abstract types (ROWIDs, LOBs and FILEs). Returns FALSE on error.

Poznámky

Poznámka: In PHP versions before 5.0.0 you must use ociresult() instead. This name still can be used, it was left as alias of oci_result() for downwards compatability. This, however, is deprecated and not recommended.

Viz také

oci_fetch_array()
oci_fetch_assoc()
oci_fetch_object()
oci_fetch_row()
oci_fetch_all()

Předcházející | Nahoru | Další
oci_pconnect | Domů | oci_rollback


oci_rollback

(PHP 5, PECL oci8:1.1-1.2.4)

oci_rollback — Rolls back outstanding transaction

Popis

bool oci_rollback ( resource $connection )

Rolls back all outstanding statements for the Oracle connection.

Seznam parametrů

connection

An Oracle connection identifier, returned by oci_connect() or oci_pconnect().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Poznámky

Poznámka: Transactions are automatically rolled back when you close the connection, or when the script ends, whichever is soonest. You need to explicitly call oci_commit() to commit the transaction, or oci_rollback() to abort it.

Poznámka: In PHP versions before 5.0.0 you must use ocirollback() instead. This name still can be used, it was left as alias of oci_rollback() for downwards compatability. This, however, is deprecated and not recommended.

Viz také

oci_commit()

Předcházející | Nahoru | Další
oci_result | Domů | oci_server_version


oci_server_version

(PHP 5, PECL oci8:1.1-1.2.4)

oci_server_version — Returns server version

Popis

string oci_server_version ( resource $connection )

Returns a string with version information of the Oracle server, which uses the provided connection.

Seznam parametrů

connection

Návratové hodnoty

Returns the version information as a string or FALSE on error.

Příklady

Příklad 1463. oci_server_version() example

<?php
    $conn = oci_connect("scott", "tiger");
    echo "Server Version: " . oci_server_version($conn);
    oci_close($conn);
?>

Poznámky

Poznámka: In PHP versions before 5.0.0 you must use ociserverversion() instead. This name still can be used, it was left as alias of oci_server_version() for downwards compatability. This, however, is deprecated and not recommended.

Předcházející | Nahoru | Další
oci_rollback | Domů | oci_set_prefetch


oci_set_prefetch

(PHP 5, PECL oci8:1.1-1.2.4)

oci_set_prefetch — Sets number of rows to be prefetched

Popis

bool oci_set_prefetch ( resource $statement, int $rows )

Sets the number of rows to be prefetched after successful call to oci_execute().

Seznam parametrů

statement

rows

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Poznámky

Poznámka: In PHP versions before 5.0.0 you must use ocisetprefetch() instead. This name still can be used, it was left as alias of oci_set_prefetch() for downwards compatability. This, however, is deprecated and not recommended.

Viz také

oci8_.default_prefetch ini option

Předcházející | Nahoru | Další
oci_server_version | Domů | oci_statement_type


oci_statement_type

(PHP 5, PECL oci8:1.1-1.2.4)

oci_statement_type — Returns the type of an OCI statement

Popis

string oci_statement_type ( resource $statement )

Returns the type of the provided OCI statement.

Seznam parametrů

statement

A valid OCI statement identifier.

Návratové hodnoty

Returns the query type ofstatement as one of the following values:

  1. SELECT
  2. UPDATE
  3. DELETE
  4. INSERT
  5. CREATE
  6. DROP
  7. ALTER
  8. BEGIN
  9. DECLARE
  10. CALL (since PHP 5.2.1 and OCI8 1.2.3)
  11. UNKNOWN
Returns FALSE on error.

Příklady

Příklad 1464. oci_statement_type() example

<?php
    $conn = oci_connect("scott", "tiger");
    $sql  = "delete from emp where deptno = 10";

    $stmt = oci_parse($conn, $sql);
    if (oci_statement_type($stmt) == "DELETE") {
        die("You are not allowed to delete from this table<br />");
    }

    oci_close($conn);
?>

Poznámky

Poznámka: In PHP versions before 5.0.0 you must use ocistatementtype() instead. This name still can be used, it was left as alias of oci_statement_type() for downwards compatability. This, however, is deprecated and not recommended.

Předcházející | Nahoru | Další
oci_set_prefetch | Domů | ocibindbyname


ocibindbyname

(PHP 4, PHP 5, PECL oci8:1.0-1.2.4)

ocibindbyname — Alias pro oci_bind_by_name()

Popis

Tato funkce je aliasem: oci_bind_by_name().

Předcházející | Nahoru | Další
oci_statement_type | Domů | ocicancel


ocicancel

(PHP 4, PHP 5, PECL oci8:1.0-1.2.4)

ocicancel — Alias pro oci_cancel()

Popis

Tato funkce je aliasem: oci_cancel().

Předcházející | Nahoru | Další
ocibindbyname | Domů | ocicloselob


ocicloselob

(PHP 4 >= 4.0.6, PECL oci8:1.0)

ocicloselob — Alias pro OCI-Lob->close

Popis

Tato funkce je aliasem: OCI-Lob->close.

Předcházející | Nahoru | Další
ocicancel | Domů | ocicollappend


ocicollappend

(PHP 4 >= 4.0.6, PHP 5, PECL oci8:1.0-1.2.4)

ocicollappend — Alias pro OCI-Collection->append

Popis

Tato funkce je aliasem: OCI-Collection->append.

Předcházející | Nahoru | Další
ocicloselob | Domů | ocicollassign


ocicollassign

(PHP 4 >= 4.0.6, PECL oci8:1.0)

ocicollassign — Alias pro OCI-Collection->assign

Popis

Tato funkce je aliasem: OCI-Collection->assign.

Předcházející | Nahoru | Další
ocicollappend | Domů | ocicollassignelem


ocicollassignelem

(PHP 4 >= 4.0.6, PHP 5, PECL oci8:1.0-1.2.4)

ocicollassignelem — Alias pro OCI-Collection->assignElem

Popis

Tato funkce je aliasem: OCI-Collection->assignElem.

Předcházející | Nahoru | Další
ocicollassign | Domů | ocicollgetelem


ocicollgetelem

(PHP 4 >= 4.0.6, PHP 5, PECL oci8:1.0-1.2.4)

ocicollgetelem — Alias pro OCI-Collection->getElem

Popis

Tato funkce je aliasem: OCI-Collection->getElem.

Předcházející | Nahoru | Další
ocicollassignelem | Domů | ocicollmax


ocicollmax

(PHP 4 >= 4.0.6, PHP 5, PECL oci8:1.0-1.2.4)

ocicollmax — Alias pro OCI-Collection->max

Popis

Tato funkce je aliasem: OCI-Collection->max.

Předcházející | Nahoru | Další
ocicollgetelem | Domů | ocicollsize


ocicollsize

(PHP 4 >= 4.0.6, PHP 5, PECL oci8:1.0-1.2.4)

ocicollsize — Alias pro OCI-Collection->size

Popis

Tato funkce je aliasem: OCI-Collection->size.

Předcházející | Nahoru | Další
ocicollmax | Domů | ocicolltrim


ocicolltrim

(PHP 4 >= 4.0.6, PHP 5, PECL oci8:1.0-1.2.4)

ocicolltrim — Alias pro OCI-Collection->trim

Popis

Tato funkce je aliasem: OCI-Collection->trim.

Předcházející | Nahoru | Další
ocicollsize | Domů | ocicolumnisnull


ocicolumnisnull

(PHP 4, PHP 5, PECL oci8:1.0-1.2.4)

ocicolumnisnull — Alias pro oci_field_is_null()

Popis

Tato funkce je aliasem: oci_field_is_null().

Předcházející | Nahoru | Další
ocicolltrim | Domů | ocicolumnname


ocicolumnname

(PHP 4, PHP 5, PECL oci8:1.0-1.2.4)

ocicolumnname — Alias pro oci_field_name()

Popis

Tato funkce je aliasem: oci_field_name().

Předcházející | Nahoru | Další
ocicolumnisnull | Domů | ocicolumnprecision


ocicolumnprecision

(PHP 4, PHP 5, PECL oci8:1.0-1.2.4)

ocicolumnprecision — Alias pro oci_field_precision()

Popis

Tato funkce je aliasem: oci_field_precision().

Předcházející | Nahoru | Další
ocicolumnname | Domů | ocicolumnscale


ocicolumnscale

(PHP 4, PHP 5, PECL oci8:1.0-1.2.4)

ocicolumnscale — Alias pro oci_field_scale()

Popis

Tato funkce je aliasem: oci_field_scale().

Předcházející | Nahoru | Další
ocicolumnprecision | Domů | ocicolumnsize


ocicolumnsize

(PHP 4, PHP 5, PECL oci8:1.0-1.2.4)

ocicolumnsize — Alias pro oci_field_size()

Popis

Tato funkce je aliasem: oci_field_size().

Předcházející | Nahoru | Další
ocicolumnscale | Domů | ocicolumntype


ocicolumntype

(PHP 4, PHP 5, PECL oci8:1.0-1.2.4)

ocicolumntype — Alias pro oci_field_type()

Popis

Tato funkce je aliasem: oci_field_type().

Předcházející | Nahoru | Další
ocicolumnsize | Domů | ocicolumntyperaw


ocicolumntyperaw

(PHP 4, PHP 5, PECL oci8:1.0-1.2.4)

ocicolumntyperaw — Alias pro oci_field_type_raw()

Popis

Tato funkce je aliasem: oci_field_type_raw().

Předcházející | Nahoru | Další
ocicolumntype | Domů | ocicommit


ocicommit

(PHP 4, PHP 5, PECL oci8:1.0-1.2.4)

ocicommit — Alias pro oci_commit()

Popis

Tato funkce je aliasem: oci_commit().

Předcházející | Nahoru | Další
ocicolumntyperaw | Domů | ocidefinebyname


ocidefinebyname

(PHP 4, PHP 5, PECL oci8:1.0-1.2.4)

ocidefinebyname — Alias pro oci_define_by_name()

Popis

Tato funkce je aliasem: oci_define_by_name().

Předcházející | Nahoru | Další
ocicommit | Domů | ocierror


ocierror

(PHP 4, PHP 5, PECL oci8:1.0-1.2.4)

ocierror — Alias pro oci_error()

Popis

Tato funkce je aliasem: oci_error().

Předcházející | Nahoru | Další
ocidefinebyname | Domů | ociexecute


ociexecute

(PHP 4, PHP 5, PECL oci8:1.0-1.2.4)

ociexecute — Alias pro oci_execute()

Popis

Tato funkce je aliasem: oci_execute().

Předcházející | Nahoru | Další
ocierror | Domů | ocifetch


ocifetch

(PHP 4, PHP 5, PECL oci8:1.0-1.2.4)

ocifetch — Alias pro oci_fetch()

Popis

Tato funkce je aliasem: oci_fetch().

Předcházející | Nahoru | Další
ociexecute | Domů | ocifetchinto


ocifetchinto

(PHP 4, PHP 5, PECL oci8:1.0-1.2.4)

ocifetchinto — Fetches the next row into an array (deprecated)

Popis

int ocifetchinto ( resource $statement, array &$result [, int $mode] )

This function is deprecated. Recommended alternatives:
oci_fetch_array(), oci_fetch_object(),
oci_fetch_assoc() and
oci_fetch_row().

Předcházející | Nahoru | Další
ocifetch | Domů | ocifetchstatement


ocifetchstatement

(PHP 4, PHP 5, PECL oci8:1.0-1.2.4)

ocifetchstatement — Alias pro oci_fetch_all()

Popis

Tato funkce je aliasem: oci_fetch_all().

Předcházející | Nahoru | Další
ocifetchinto | Domů | ocifreecollection


ocifreecollection

(PHP 4 >= 4.0.7, PHP 5, PECL oci8:1.0-1.2.4)

ocifreecollection — Alias pro OCI-Collection->free

Popis

Tato funkce je aliasem: OCI-Collection->free.

Předcházející | Nahoru | Další
ocifetchstatement | Domů | ocifreecursor


ocifreecursor

(PHP 4, PHP 5, PECL oci8:1.0-1.2.4)

ocifreecursor — Alias pro oci_free_statement()

Popis

Tato funkce je aliasem: oci_free_statement().

Předcházející | Nahoru | Další
ocifreecollection | Domů | ocifreedesc


ocifreedesc

(PHP 4, PHP 5, PECL oci8:1.0-1.2.4)

ocifreedesc — Alias pro OCI-Lob->free

Popis

Tato funkce je aliasem: OCI-Lob->free.

Předcházející | Nahoru | Další
ocifreecursor | Domů | ocifreestatement


ocifreestatement

(PHP 4, PHP 5, PECL oci8:1.0-1.2.4)

ocifreestatement — Alias pro oci_free_statement()

Popis

Tato funkce je aliasem: oci_free_statement().

Předcházející | Nahoru | Další
ocifreedesc | Domů | ociinternaldebug


ociinternaldebug

(PHP 4, PHP 5, PECL oci8:1.0-1.2.4)

ociinternaldebug — Alias pro oci_internal_debug()

Popis

Tato funkce je aliasem: oci_internal_debug().

Předcházející | Nahoru | Další
ocifreestatement | Domů | ociloadlob


ociloadlob

(PHP 4, PHP 5, PECL oci8:1.0-1.2.4)

ociloadlob — Alias pro OCI-Lob->load

Popis

Tato funkce je aliasem: OCI-Lob->load.

Předcházející | Nahoru | Další
ociinternaldebug | Domů | ocilogoff


ocilogoff

(PHP 4, PHP 5, PECL oci8:1.0-1.2.4)

ocilogoff — Alias pro oci_close()

Popis

Tato funkce je aliasem: oci_close().

Předcházející | Nahoru | Další
ociloadlob | Domů | ocilogon


ocilogon

(PHP 4, PHP 5, PECL oci8:1.0-1.2.4)

ocilogon — Alias pro oci_connect()

Popis

Tato funkce je aliasem: oci_connect().

Předcházející | Nahoru | Další
ocilogoff | Domů | ocinewcollection


ocinewcollection

(PHP 4 >= 4.0.6, PHP 5, PECL oci8:1.0-1.2.4)

ocinewcollection — Alias pro oci_new_collection()

Popis

Tato funkce je aliasem: oci_new_collection().

Předcházející | Nahoru | Další
ocilogon | Domů | ocinewcursor


ocinewcursor

(PHP 4, PHP 5, PECL oci8:1.0-1.2.4)

ocinewcursor — Alias pro oci_new_cursor()

Popis

Tato funkce je aliasem: oci_new_cursor().

Předcházející | Nahoru | Další
ocinewcollection | Domů | ocinewdescriptor


ocinewdescriptor

(PHP 4, PHP 5, PECL oci8:1.0-1.2.4)

ocinewdescriptor — Alias pro oci_new_descriptor()

Popis

Tato funkce je aliasem: oci_new_descriptor().

Předcházející | Nahoru | Další
ocinewcursor | Domů | ocinlogon


ocinlogon

(PHP 4, PHP 5, PECL oci8:1.0-1.2.4)

ocinlogon — Alias pro oci_new_connect()

Popis

Tato funkce je aliasem: oci_new_connect().

Předcházející | Nahoru | Další
ocinewdescriptor | Domů | ocinumcols


ocinumcols

(PHP 4, PHP 5, PECL oci8:1.0-1.2.4)

ocinumcols — Alias pro oci_num_fields()

Popis

Tato funkce je aliasem: oci_num_fields().

Předcházející | Nahoru | Další
ocinlogon | Domů | ociparse


ociparse

(PHP 4, PHP 5, PECL oci8:1.0-1.2.4)

ociparse — Alias pro oci_parse()

Popis

Tato funkce je aliasem: oci_parse().

Předcházející | Nahoru | Další
ocinumcols | Domů | ociplogon


ociplogon

(PHP 4, PHP 5, PECL oci8:1.0-1.2.4)

ociplogon — Alias pro oci_pconnect()

Popis

Tato funkce je aliasem: oci_pconnect().

Předcházející | Nahoru | Další
ociparse | Domů | ociresult


ociresult

(PHP 4, PHP 5, PECL oci8:1.0-1.2.4)

ociresult — Alias pro oci_result()

Popis

Tato funkce je aliasem: oci_result().

Předcházející | Nahoru | Další
ociplogon | Domů | ocirollback


ocirollback

(PHP 4, PHP 5, PECL oci8:1.0-1.2.4)

ocirollback — Alias pro oci_rollback()

Popis

Tato funkce je aliasem: oci_rollback().

Předcházející | Nahoru | Další
ociresult | Domů | ocirowcount


ocirowcount

(PHP 4, PHP 5, PECL oci8:1.0-1.2.4)

ocirowcount — Alias pro oci_num_rows()

Popis

Tato funkce je aliasem: oci_num_rows().

Předcházející | Nahoru | Další
ocirollback | Domů | ocisavelob


ocisavelob

(PHP 4, PHP 5, PECL oci8:1.0-1.2.4)

ocisavelob — Alias pro OCI-Lob->save

Popis

Tato funkce je aliasem: OCI-Lob->save.

Předcházející | Nahoru | Další
ocirowcount | Domů | ocisavelobfile


ocisavelobfile

(PHP 4, PHP 5, PECL oci8:1.0-1.2.4)

ocisavelobfile — Alias pro OCI-Lob->import

Popis

Tato funkce je aliasem: OCI-Lob->import.

Předcházející | Nahoru | Další
ocisavelob | Domů | ociserverversion


ociserverversion

(PHP 4, PHP 5, PECL oci8:1.0-1.2.4)

ociserverversion — Alias pro oci_server_version()

Popis

Tato funkce je aliasem: oci_server_version().

Předcházející | Nahoru | Další
ocisavelobfile | Domů | ocisetprefetch


ocisetprefetch

(PHP 4, PHP 5, PECL oci8:1.0-1.2.4)

ocisetprefetch — Alias pro oci_set_prefetch()

Popis

Tato funkce je aliasem: oci_set_prefetch().

Předcházející | Nahoru | Další
ociserverversion | Domů | ocistatementtype


ocistatementtype

(PHP 4, PHP 5, PECL oci8:1.0-1.2.4)

ocistatementtype — Alias pro oci_statement_type()

Popis

Tato funkce je aliasem: oci_statement_type().

Předcházející | Nahoru | Další
ocisetprefetch | Domů | ociwritelobtofile


ociwritelobtofile

(PHP 4, PHP 5, PECL oci8:1.0-1.2.4)

ociwritelobtofile — Alias pro OCI-Lob->export

Popis

Tato funkce je aliasem: OCI-Lob->export.

Předcházející | Nahoru | Další
ocistatementtype | Domů | ociwritetemporarylob


ociwritetemporarylob

(PHP 4 >= 4.0.6, PECL oci8:1.0)

ociwritetemporarylob — Alias pro OCI-Lob->writeTemporary

Popis

Tato funkce je aliasem: OCI-Lob->writeTemporary.

Předcházející | Nahoru | Další
ociwritelobtofile | Domů | CVIII. ODBC Functions (Unified)


OpenAL Audio Bindings

Předcházející VI. Reference funkcí Další

CXI. OpenAL Audio Bindings

Úvod

Platform independent audio bindings. Requires the » OpenAL library.

Instalace

Toto rozšíření » PECL není přibaleno k PHP.

Informace o instalaci tohoto PECL rozšíření lze najít v kapitole manuálu nazvané Instalace rozšíření PECL. Další informace, jako nové verze, soubory ke stažení, zdrojové soubory, správcovské informace a CHANGELOG, lze najít zde: » http://pecl.php.net/package/openal.

Tuto DLL knihovnu pro rozšíření PECL můžete stahovat ze stránky » PHP Downloads nebo z » http://snaps.php.net/.

Konfigurace běhu

Toto rozšíření nemá definováno žádné konfigurační direktivy.

Typy prostředků

This extension defines four resource types:
Open AL(Device) - Returned by openal_device_open(),
Open AL(Context) - Returned by openal_context_create(),
Open AL(Buffer) - Returned by openal_buffer_create(),
and Open AL(Source) - Returned by openal_source_create().

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

ALC_FREQUENCY (integer)
Context Attribute
ALC_REFRESH (integer)
Context Attribute
ALC_SYNC (integer)
Context Attribute
AL_FREQUENCY (integer)
Buffer Setting
AL_BITS (integer)
Buffer Setting
AL_CHANNELS (integer)
Buffer Setting
AL_SIZE (integer)
Buffer Setting
AL_BUFFER (integer)
Source/Listener Setting (Integer)
AL_SOURCE_RELATIVE (integer)
Source/Listener Setting (Integer)
AL_SOURCE_STATE (integer)
Source/Listener Setting (Integer)
AL_PITCH (integer)
Source/Listener Setting (Float)
AL_GAIN (integer)
Source/Listener Setting (Float)
AL_MIN_GAIN (integer)
Source/Listener Setting (Float)
AL_MAX_GAIN (integer)
Source/Listener Setting (Float)
AL_MAX_DISTANCE (integer)
Source/Listener Setting (Float)
AL_ROLLOFF_FACTOR (integer)
Source/Listener Setting (Float)
AL_CONE_OUTER_GAIN (integer)
Source/Listener Setting (Float)
AL_CONE_INNER_ANGLE (integer)
Source/Listener Setting (Float)
AL_CONE_OUTER_ANGLE (integer)
Source/Listener Setting (Float)
AL_REFERENCE_DISTANCE (integer)
Source/Listener Setting (Float)
AL_POSITION (integer)
Source/Listener Setting (Float Vector)
AL_VELOCITY (integer)
Source/Listener Setting (Float Vector)
AL_DIRECTION (integer)
Source/Listener Setting (Float Vector)
AL_ORIENTATION (integer)
Source/Listener Setting (Float Vector)
AL_FORMAT_MONO8 (integer)
PCM Format
AL_FORMAT_MONO16 (integer)
PCM Format
AL_FORMAT_STEREO8 (integer)
PCM Format
AL_FORMAT_STEREO16 (integer)
PCM Format
AL_INITIAL (integer)
Source State
AL_PLAYING (integer)
Source State
AL_PAUSED (integer)
Source State
AL_STOPPED (integer)
Source State
AL_LOOPING (integer)
Source State
AL_TRUE (integer)
Boolean value recognized by OpenAL
AL_FALSE (integer)
Boolean value recognized by OpenAL

Obsah

openal_buffer_create — Generate OpenAL buffer
openal_buffer_data — Load a buffer with data
openal_buffer_destroy — Destroys an OpenAL buffer
openal_buffer_get — Retrieve an OpenAL buffer property
openal_buffer_loadwav — Load a .wav file into a buffer
openal_context_create — Create an audio processing context
openal_context_current — Make the specified context current
openal_context_destroy — Destroys a context
openal_context_process — Process the specified context
openal_context_suspend — Suspend the specified context
openal_device_close — Close an OpenAL device
openal_device_open — Initialize the OpenAL audio layer
openal_listener_get — Retrieve a listener property
openal_listener_set — Set a listener property
openal_source_create — Generate a source resource
openal_source_destroy — Destroy a source resource
openal_source_get — Retrieve an OpenAL source property
openal_source_pause — Pause the source
openal_source_play — Start playing the source
openal_source_rewind — Rewind the source
openal_source_set — Set source property
openal_source_stop — Stop playing the source
openal_stream — Begin streaming on a source
Předcházející | Nahoru | Další
Usage | Domů | openal_buffer_create


openal_buffer_create

(PECL openal:0.1)

openal_buffer_create — Generate OpenAL buffer

Popis

resource openal_buffer_create ( void )

Návratové hodnoty

Returns an Open AL(Buffer) resource on success or FALSE on failure.

Viz také

openal_buffer_loadwav()
openal_buffer_data()

Předcházející | Nahoru | Další
CXI. OpenAL Audio Bindings | Domů | openal_buffer_data


openal_buffer_data

(PECL openal:0.1)

openal_buffer_data — Load a buffer with data

Popis

bool openal_buffer_data ( resource $buffer, int $format, string $data, int $freq )

Seznam parametrů

buffer

An Open AL(Buffer) resource (previously created by openal_buffer_create()).

format

Format of data, one of: AL_FORMAT_MONO8, AL_FORMAT_MONO16, AL_FORMAT_STEREO8, a AL_FORMAT_STEREO16

data

Block of binary audio data in the format and freq specified.

freq

Frequency of data given in Hz.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

openal_buffer_loadwav()
openal_stream()

Předcházející | Nahoru | Další
openal_buffer_create | Domů | openal_buffer_destroy


openal_buffer_destroy

(PECL openal:0.1)

openal_buffer_destroy — Destroys an OpenAL buffer

Popis

bool openal_buffer_destroy ( resource $buffer )

Seznam parametrů

buffer

An Open AL(Buffer) resource (previously created by openal_buffer_create()).

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

openal_buffer_create()

Předcházející | Nahoru | Další
openal_buffer_data | Domů | openal_buffer_get


openal_buffer_get

(PECL openal:0.1)

openal_buffer_get — Retrieve an OpenAL buffer property

Popis

int openal_buffer_get ( resource $buffer, int $property )

Seznam parametrů

buffer

An Open AL(Buffer) resource (previously created by openal_buffer_create()).

property

Specific property, one of: AL_FREQUENCY, AL_BITS, AL_CHANNELS, a AL_SIZE.

Návratové hodnoty

Returns an integer value appropriate to the property requested or FALSE on failure.

Viz také

openal_buffer_create()

Předcházející | Nahoru | Další
openal_buffer_destroy | Domů | openal_buffer_loadwav


openal_buffer_loadwav

(PECL openal:0.1)

openal_buffer_loadwav — Load a .wav file into a buffer

Popis

bool openal_buffer_loadwav ( resource $buffer, string $wavfile )

Seznam parametrů

buffer

An Open AL(Buffer) resource (previously created by openal_buffer_create()).

wavfile

Path to .WAV file on local file system.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

openal_buffer_data()
openal_stream()

Předcházející | Nahoru | Další
openal_buffer_get | Domů | openal_context_create


openal_context_create

(PECL openal:0.1)

openal_context_create — Create an audio processing context

Popis

resource openal_context_create ( resource $device )

Seznam parametrů

device

An Open AL(Device) resource (previously created by openal_device_open()).

Návratové hodnoty

Returns an Open AL(Context) resource on success or FALSE on failure.

Viz také

openal_device_open()
openal_context_destroy()

Předcházející | Nahoru | Další
openal_buffer_loadwav | Domů | openal_context_current


openal_context_current

(PECL openal:0.1)

openal_context_current — Make the specified context current

Popis

bool openal_context_current ( resource $context )

Seznam parametrů

context

An Open AL(Context) resource (previously created by openal_context_create()).

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

openal_context_create()

Předcházející | Nahoru | Další
openal_context_create | Domů | openal_context_destroy


openal_context_destroy

(PECL openal:0.1)

openal_context_destroy — Destroys a context

Popis

bool openal_context_destroy ( resource $context )

Seznam parametrů

context

An Open AL(Context) resource (previously created by openal_context_create()).

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

openal_context_create()

Předcházející | Nahoru | Další
openal_context_current | Domů | openal_context_process


openal_context_process

(PECL openal:0.1)

openal_context_process — Process the specified context

Popis

bool openal_context_process ( resource $context )

Seznam parametrů

context

An Open AL(Context) resource (previously created by openal_context_create()).

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

openal_context_create()
openal_context_current()
openal_context_suspend()

Předcházející | Nahoru | Další
openal_context_destroy | Domů | openal_context_suspend


openal_context_suspend

(PECL openal:0.1)

openal_context_suspend — Suspend the specified context

Popis

bool openal_context_suspend ( resource $context )

Seznam parametrů

context

An Open AL(Context) resource (previously created by openal_context_create()).

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

openal_context_create()
openal_context_current()
openal_context_process()

Předcházející | Nahoru | Další
openal_context_process | Domů | openal_device_close


openal_device_close

(PECL openal:0.1)

openal_device_close — Close an OpenAL device

Popis

bool openal_device_close ( resource $device )

Seznam parametrů

device

An Open AL(Device) resource (previously created by openal_device_open()) to be closed.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

openal_device_open()

Předcházející | Nahoru | Další
openal_context_suspend | Domů | openal_device_open


openal_device_open

(PECL openal:0.1)

openal_device_open — Initialize the OpenAL audio layer

Popis

resource openal_device_open ( [string $device_desc] )

Seznam parametrů

device_desc

Open an audio device optionally specified by device_desc. If device_desc is not specified the first available audio device will be used.

Návratové hodnoty

Returns an Open AL(Device) resource on success or FALSE on failure.

Viz také

openal_device_close()
openal_context_create()

Předcházející | Nahoru | Další
openal_device_close | Domů | openal_listener_get


openal_listener_get

(PECL openal:0.1)

openal_listener_get — Retrieve a listener property

Popis

mixed openal_listener_get ( int $property )

Seznam parametrů

property

Property to retrieve, one of:
AL_GAIN (float),
AL_POSITION (array(float,float,float)),
AL_VELOCITY (array(float,float,float)), a
AL_ORIENTATION (array(float,float,float)).

Návratové hodnoty

Returns a float or array of floats (as appropriate), or FALSE on failure.

Viz také

openal_listener_set()

Předcházející | Nahoru | Další
openal_device_open | Domů | openal_listener_set


openal_listener_set

(PECL openal:0.1)

openal_listener_set — Set a listener property

Popis

bool openal_listener_set ( int $property, mixed $setting )

Seznam parametrů

property

Property to set, one of:
AL_GAIN (float),
AL_POSITION (array(float,float,float)),
AL_VELOCITY (array(float,float,float)), a
AL_ORIENTATION (array(float,float,float)).

setting

Value to set, either float, or an array of floats as appropriate.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

openal_listener_get()

Předcházející | Nahoru | Další
openal_listener_get | Domů | openal_source_create


openal_source_create

(PECL openal:0.1)

openal_source_create — Generate a source resource

Popis

resource openal_source_create ( void )

Návratové hodnoty

Returns an Open AL(Source) resource on success or FALSE on failure.

Viz také

openal_source_set()
openal_source_play()
openal_source_destroy()

Předcházející | Nahoru | Další
openal_listener_set | Domů | openal_source_destroy


openal_source_destroy

(PECL openal:0.1)

openal_source_destroy — Destroy a source resource

Popis

bool openal_source_destroy ( resource $source )

Seznam parametrů

source

An Open AL(Source) resource (previously created by openal_source_create()).

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

openal_source_create()

Předcházející | Nahoru | Další
openal_source_create | Domů | openal_source_get


openal_source_get

(PECL openal:0.1)

openal_source_get — Retrieve an OpenAL source property

Popis

mixed openal_source_get ( resource $source, int $property )

Seznam parametrů

source

An Open AL(Source) resource (previously created by openal_source_create()).

property

Property to get, one of: AL_SOURCE_RELATIVE (int), AL_SOURCE_STATE (int), AL_PITCH (float), AL_GAIN (float), AL_MIN_GAIN (float), AL_MAX_GAIN (float), AL_MAX_DISTANCE (float), AL_ROLLOFF_FACTOR (float), AL_CONE_OUTER_GAIN (float), AL_CONE_INNER_ANGLE (float), AL_CONE_OUTER_ANGLE (float), AL_REFERENCE_DISTANCE (float), AL_POSITION (array(float,float,float)), AL_VELOCITY (array(float,float,float)), AL_DIRECTION (array(float,float,float)).

Návratové hodnoty

Returns the type associated with the property being retrieved or FALSE on failure.

Viz také

openal_source_create()
openal_source_set()
openal_source_play()

Předcházející | Nahoru | Další
openal_source_destroy | Domů | openal_source_pause


openal_source_pause

(PECL openal:0.1)

openal_source_pause — Pause the source

Popis

bool openal_source_pause ( resource $source )

Seznam parametrů

source

An Open AL(Source) resource (previously created by openal_source_create()).

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

openal_source_stop()
openal_source_play()
openal_source_rewind()

Předcházející | Nahoru | Další
openal_source_get | Domů | openal_source_play


openal_source_play

(PECL openal:0.1)

openal_source_play — Start playing the source

Popis

bool openal_source_play ( resource $source )

Seznam parametrů

source

An Open AL(Source) resource (previously created by openal_source_create()).

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

openal_source_stop()
openal_source_pause()
openal_source_rewind()

Předcházející | Nahoru | Další
openal_source_pause | Domů | openal_source_rewind


openal_source_rewind

(PECL openal:0.1)

openal_source_rewind — Rewind the source

Popis

bool openal_source_rewind ( resource $source )

Seznam parametrů

source

An Open AL(Source) resource (previously created by openal_source_create()).

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

openal_source_stop()
openal_source_pause()
openal_source_play()

Předcházející | Nahoru | Další
openal_source_play | Domů | openal_source_set


openal_source_set

(PECL openal:0.1)

openal_source_set — Set source property

Popis

bool openal_source_set ( resource $source, int $property, mixed $setting )

Seznam parametrů

source

An Open AL(Source) resource (previously created by openal_source_create()).

property

Property to set, one of: AL_BUFFER (OpenAL(Source)), AL_LOOPING (bool), AL_SOURCE_RELATIVE (int), AL_SOURCE_STATE (int), AL_PITCH (float), AL_GAIN (float), AL_MIN_GAIN (float), AL_MAX_GAIN (float), AL_MAX_DISTANCE (float), AL_ROLLOFF_FACTOR (float), AL_CONE_OUTER_GAIN (float), AL_CONE_INNER_ANGLE (float), AL_CONE_OUTER_ANGLE (float), AL_REFERENCE_DISTANCE (float), AL_POSITION (array(float,float,float)), AL_VELOCITY (array(float,float,float)), AL_DIRECTION (array(float,float,float)).

setting

Value to assign to specified property. Refer to the description of property for a description of the value(s) expected.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

openal_source_create()
openal_source_get()
openal_source_play()

Předcházející | Nahoru | Další
openal_source_rewind | Domů | openal_source_stop


openal_source_stop

(PECL openal:0.1)

openal_source_stop — Stop playing the source

Popis

bool openal_source_stop ( resource $source )

Seznam parametrů

source

An Open AL(Source) resource (previously created by openal_source_create()).

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

openal_source_play()
openal_source_pause()
openal_source_rewind()

Předcházející | Nahoru | Další
openal_source_set | Domů | openal_stream


openal_stream

(PECL openal:0.1)

openal_stream — Begin streaming on a source

Popis

resource openal_stream ( resource $source, int $format, int $rate )

Seznam parametrů

source

An Open AL(Source) resource (previously created by openal_source_create()).

format

Format of data, one of: AL_FORMAT_MONO8, AL_FORMAT_MONO16, AL_FORMAT_STEREO8, a AL_FORMAT_STEREO16

rate

Frequency of data to stream given in Hz.

Návratové hodnoty

Returns a stream resource on success, or FALSE on failure.

Viz také

openal_source_create()
fwrite()

Předcházející | Nahoru | Další
openal_source_stop | Domů | CXII. OpenSSL funkce


OpenSSL funkce

Předcházející VI. Reference funkcí Další

CXII. OpenSSL funkce

Úvod

Toto rozšíření využívá funkce » OpenSSL pro tvorbu a ověřování podpisů a pečetění (kódování) a otvírání (dekódování) dat. OpenSSL nabízí mnoho vlastností, které tato extenze v současnosti nepodporuje. Některé z nich mohou být v budoucnu přidány.

Požadavky

Abyste mohli používat tyto funkce, musíte nainstalovat » OpenSSL. PHP-4.0.4pl1 potřebuje OpenSSL >= 0.9.6, ale PHP-4.0.5 a vyšší budou pracovat i s OpenSSL >= 0.9.5.

Instalace

Abyste v PHP mohli používat funkce OpenSSL, musíte PHP zkompilovat s volbou --with-openssl[=DIR].

Poznámka pro uživatele Win32: Aby toto rozšíření fungovalo ve Windows, musíte zkopírovat soubor libeay32.dll z adresáře DLL Win32 distribuce do adresáře SYSTEM32. (Např.: C:\WINNT\SYSTEM32 nebo C:\WINDOWS\SYSTEM32)

Navíc, pokud máte v úmyslu používat funkce generování klíčů a podepisování certifikátů, musíte na váš systém nainstalovat platný openssl.cnf. Do PHP 4.3.0 jsme připojili ukázkový konfigurační soubor do adresáře openssl Win32 distribuce. Pokud používáte 4.2.0 nebo novější a tento soubor vám chybí, můžete ho stáhnout z » domácí stránky OpenSSL nebo stáhněte PHP 4.3.0 a použijte konfigurační souboru z něj.

PHP bude hledat openssl.cnf tímto postupem:

  • Proměnná prostředí OPENSSL_CONF, pokud je nastavena, bude použita jako cesta (včetně názvu souboru) konfiguračního souboru.
  • Proměnná prostředí SSLEAY_CONF, pokud je nastavena, bude použita jako cesta (včetně názvu souboru) konfiguračního souboru.
  • Bude se předpokládat, že soubor openssl.cnf bude nalezen ve výchozí oblasti certifikátů, která byla zkonfigurována při kompilaci DLL knihovny openssl. To obvykle znamená, že výchozí název souboru je c:\usr\local\ssl\openssl.cnf.

Ve své instalaci se musíte rozhodnout, zda nainstalujete konfigurační soubor do c:\usr\local\ssl\openssl.cnf nebo zda ho nainstalujete někam jinam a pro nalezení konfiguračního souboru použijete proměnnou prostředí (pravděpodpobně jako per-virtual-host). Vemte na vědomí, že výchozí cestu lze změnit v parametru configargs funkcí, které potřebují konfigurační soubor.

Konfigurace běhu

Toto rozšíření nemá definováno žádné konfigurační direktivy.

Typy prostředků

Parametry s klíči/certifikáty

Několik openssl funkcí potřebuje parametr s klíčem nebo certifikátem. PHP 4.0.5 a starší musí pro klíč a certifikát používat resource vrácený některou z funkcí openssl_get_xxx. Pozdější verzi mohou používat libovolnou z těchto metod:

  • Certifikáty

    1. X.509 zdroj vrácený funkcí openssl_x509_read()
    2. Řetězec ve formátu file://path/to/cert.pem; uvedený soubor musí obsahovat PEM-zakódovaný certifikát
    3. Řetězec obsahující PEM-zakódovaný certifikát

  • Veřejné a soukromé klíče

    1. Zdroj klíče vrácený funkcí openssl_get_publickey() nebo openssl_get_privatekey()
    2. Pouze veřejné klíče: zdroj X.509
    3. Řetězec ve formátu file://path/to/file.pem - uvedený soubor musí obsahovat PEM-zakódovaný certifikát / veřejný klíč (může obsahovat oba)
    4. Řetězec obsahující obsah certifikátu / klíče, PEM-zakódovaný
    5. Pro soukromé klíče lze také použít syntaxi array($key, $heslo) kde $key reprezentuje klíč zadaný pomocí file:// nebo textového uvedení zmíněného výše a $heslo reprezentuje řetězec obsahující heslo pro tento soukromý klíč

Ověření certifikátu

Když voláte funkci, která ověřuje podpis / certifikát, parametr cainfo je pole obsahující názvy souborů a adresářů, které určují umístění souborů důvěryhodných CA. Pokud je zadán adresář, musí to být správně uspořádaný adresář s hashi tak, jak ho používá příkaz openssl.

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

Přepínače ověření účelu

X509_PURPOSE_SSL_CLIENT (integer)
X509_PURPOSE_SSL_SERVER (integer)
X509_PURPOSE_NS_SSL_SERVER (integer)
X509_PURPOSE_SMIME_SIGN (integer)
X509_PURPOSE_SMIME_ENCRYPT (integer)
X509_PURPOSE_CRL_SIGN (integer)
X509_PURPOSE_ANY (integer)

Přepínače vycpávky

OPENSSL_PKCS1_PADDING (integer)
OPENSSL_SSLV23_PADDING (integer)
OPENSSL_NO_PADDING (integer)
OPENSSL_PKCS1_OAEP_PADDING (integer)

Typy klíčů

OPENSSL_KEYTYPE_RSA (integer)
OPENSSL_KEYTYPE_DSA (integer)
OPENSSL_KEYTYPE_DH (integer)

Přepínače / konstanty PKCS7

S/MIME funkce používají přepínače, kterou jsou specifikovány jako bitové pole, které může obsahovat jednu nebo více následujících hodnot:

Tabulka 223. PKCS7 konstanty

Konstanta | Popis
PKCS7_TEXT | přidá "text/plain content type" hlavičky k zakódovaným/podepsaným zprávám. Při dekódování nebo ověřování odstraní tyto hlavičky z výstupu - když není rozkódovaná nebo ověřená zpráva MIME typu text/plain, dojde k chybě.
PKCS7_BINARY | za normálních okolností je zdrojová zpráva převedená do "kanonického" formátu, který používá pro konce řádků používá CR a LF: tak, jak to požaduje S/MIME specifikace. Když je zapnuta tato volba, nedojde k žádnému převodu. To se hodí v případě manipulace s binárními daty, která nemusí být v MIME formátu.
PKCS7_NOINTERN | při ověřování zprávy jsou za normálních okolností certifikáty obsažené ve zprávě (pokud nějaké existují) prohledávané na výskyt podpisového certifikátu. S touto volbou se použijí pouze certifikáty zadané v parametru extracerts funkce openssl_pkcs7_verify(). Zadané certifikáty ale stále mohou být použity jako nedůvěryhodné CA.
PKCS7_NOVERIFY | neověřovat certifikát podepisovatele podepsané zprávy.
PKCS7_NOCHAIN | nespojovat ověření podepisovatelových certifikátů: to znamená nepoužívat certifikáty v podepsané zprávě jako nedůvěryhodné CA.
PKCS7_NOCERTS | při podepisování zprávy je za normálních okolností připojen certifikát podepisovatele - s touto volbou tomu tak není. To způsobí snížení velikosti podepsané zprávy, ale ověřovatel musí mít kopii podepisovatelova certifikátu k dispozici lokálně (například předanou v parametru extracerts funkce openssl_pkcs7_verify()).
PKCS7_NOATTR | Pokud je zpráva podepsána za normálních okolností, je připojena sada atributů obsahující čas podpisu a podporované symetrické algoritmy. S touto volbou není připojena.
PKCS7_DETACHED | Při podpisu zprávy použije podpis čitelného text spolu s MIME typem multipart/signed. To je výchozí nastavení, pokud ve funkci openssl_pkcs7_sign() nezadáte parametr flags. Pokud tuto volbu vypnete, bude zpráva podepsána za použití neprůhledného podepsání, které je více odolné vůči překladům e-mailových bran, ale nelze přečíst klienty, kteří nepodporují S/MIME.
PKCS7_NOSIGS | Nezkoušet a neověřovat podpisy zprávy

Poznámka: Tyto konstanty byly přidány ve verzi 4.0.6.

Obsah

openssl_csr_export_to_file — Exports a CSR to a file
openssl_csr_export — Exports a CSR as a string
openssl_csr_get_public_key — Returns the public key of a CERT
openssl_csr_get_subject — Returns the subject of a CERT
openssl_csr_new — Generates a CSR
openssl_csr_sign — Sign a CSR with another certificate (or itself) and generate a certificate
openssl_error_string — Return openSSL error message
openssl_free_key — Uvolnit prostředky klíče
openssl_get_privatekey — Připravit soukromý PEM klíč k použití
openssl_get_publickey — Získat z certifikátu veřejný klíč a připravit ho k použití
openssl_open — Otevřít zapečetěná data
openssl_pkcs12_export_to_file — Exports a PKCS#12 Compatible Certificate Store File
openssl_pkcs12_export — Exports a PKCS#12 Compatible Certificate Store File to variable.
openssl_pkcs12_read — Parse a PKCS#12 Certificate Store into an array
openssl_pkcs7_decrypt — Decrypts an S/MIME encrypted message
openssl_pkcs7_encrypt — Encrypt an S/MIME message
openssl_pkcs7_sign — Sign an S/MIME message
openssl_pkcs7_verify — Verifies the signature of an S/MIME signed message
openssl_pkey_export_to_file — Gets an exportable representation of a key into a file
openssl_pkey_export — Gets an exportable representation of a key into a string
openssl_pkey_free — Frees a private key
openssl_pkey_get_details — Returns an array with the key details
openssl_pkey_get_private — Get a private key
openssl_pkey_get_public — Extract public key from certificate and prepare it for use
openssl_pkey_new — Generates a new private key
openssl_private_decrypt — Decrypts data with private key
openssl_private_encrypt — Encrypts data with private key
openssl_public_decrypt — Decrypts data with public key
openssl_public_encrypt — Encrypts data with public key
openssl_seal — Zapečetit (zakódovat) data
openssl_sign — Generate signature
openssl_verify — Ověřit podpis
openssl_x509_check_private_key — Checks if a private key corresponds to a certificate
openssl_x509_checkpurpose — Verifies if a certificate can be used for a particular purpose
openssl_x509_export_to_file — Exports a certificate to file
openssl_x509_export — Exports a certificate as a string
openssl_x509_free — Free certificate resource
openssl_x509_parse — Parse an X509 certificate and return the information as an array
openssl_x509_read — Parse an X.509 certificate and return a resource identifier for it
Předcházející | Nahoru | Další
openal_stream | Domů | openssl_csr_export_to_file


openssl_csr_export_to_file

(PHP 4 >= 4.2.0, PHP 5)

openssl_csr_export_to_file — Exports a CSR to a file

Popis

bool openssl_csr_export_to_file ( resource $csr, string $outfilename [, bool $notext] )

openssl_csr_export_to_file() takes the Certificate Signing Request represented by csr and saves it as ascii-armoured text into the file named by outfilename.

Seznam parametrů

csr

outfilename

Path to the output file.

notext

The optional parameter notext affects the verbosity of the output; if it is FALSE then additional human-readable information is included in the output. The default value of notext is TRUE.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

openssl_csr_export()
openssl_csr_new()
openssl_csr_sign()

Předcházející | Nahoru | Další
CXII. OpenSSL funkce | Domů | openssl_csr_export


openssl_csr_export

(PHP 4 >= 4.2.0, PHP 5)

openssl_csr_export — Exports a CSR as a string

Popis

bool openssl_csr_export ( resource $csr, string &$out [, bool $notext] )

openssl_csr_export() takes the Certificate Signing Request represented by csr and stores it as ascii-armoured text into out, which is passed by reference.

Seznam parametrů

csr

out

notext

The optional parameter notext affects the verbosity of the output; if it is FALSE then additional human-readable information is included in the output. The default value of notext is TRUE.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

openssl_csr_export_to_file()
openssl_csr_new()
openssl_csr_sign()

Předcházející | Nahoru | Další
openssl_csr_export_to_file | Domů | openssl_csr_get_public_key


openssl_csr_new

(PHP 4 >= 4.2.0, PHP 5)

openssl_csr_new — Generates a CSR

Popis

mixed openssl_csr_new ( array $dn, resource &$privkey [, array $configargs [, array $extraattribs]] )

openssl_csr_new() generates a new CSR (Certificate Signing Request) based on the information provided by dn, which represents the Distinguished Name to be used in the certificate.

Poznámka: You need to have a valid openssl.cnf installed for this function to operate correctly. See the notes under the installation section for more information.

Seznam parametrů

dn

The Distinguished Name to be used in the certificate.

privkey

privkey should be set to a private key that was previously generated by openssl_pkey_new() (or otherwise obtained from the other openssl_pkey family of functions). The corresponding public portion of the key will be used to sign the CSR.

configargs

By default, the information in your system openssl.conf is used to initialize the request; you can specify a configuration file section by setting the config_section_section key of configargs. You can also specify an alternative openssl configuration file by setting the value of the config key to the path of the file you want to use. The following keys, if present in configargs behave as their equivalents in the openssl.conf, as listed in the table below.

Tabulka 224. Configuration overrides

configargs key | type | openssl.conf equivalent | description
digest_alg | string | default_md | Selects which digest method to use
x509_extensions | string | x509_extensions | Selects which extensions should be used when creating an x509 certificate
req_extensions | string | req_extensions | Selects which extensions should be used when creating a CSR
private_key_bits | integer | default_bits | Specifies how many bits should be used to generate a private key
private_key_type | integer | none | Specifies the type of private key to create. This can be one of OPENSSL_KEYTYPE_DSA, OPENSSL_KEYTYPE_DH or OPENSSL_KEYTYPE_RSA. The default value is OPENSSL_KEYTYPE_RSA which is currently the only supported key type.
encrypt_key | boolean | encrypt_key | Should an exported key (with passphrase) be encrypted?

extraattribs

extraattribs is used to specify additional configuration options for the CSR. Both dn and extraattribs are associative arrays whose keys are converted to OIDs and applied to the relevant part of the request.

Návratové hodnoty

Returns the CSR.

Příklady

Příklad 1475. Creating a self-signed-certificate

<?php
// Fill in data for the distinguished name to be used in the cert
// You must change the values of these keys to match your name and
// company, or more precisely, the name and company of the person/site
// that you are generating the certificate for.
// For SSL certificates, the commonName is usually the domain name of
// that will be using the certificate, but for S/MIME certificates,
// the commonName will be the name of the individual who will use the
// certificate.
$dn = array(
    "countryName" => "UK",
    "stateOrProvinceName" => "Somerset",
    "localityName" => "Glastonbury",
    "organizationName" => "The Brain Room Limited",
    "organizationalUnitName" => "PHP Documentation Team",
    "commonName" => "Wez Furlong",
    "emailAddress" => "wez@example.com"
);

// Generate a new private (and public) key pair
$privkey = openssl_pkey_new();

// Generate a certificate signing request
$csr = openssl_csr_new($dn, $privkey);

// You will usually want to create a self-signed certificate at this
// point until your CA fulfills your request.
// This creates a self-signed cert that is valid for 365 days
$sscert = openssl_csr_sign($csr, null, $privkey, 365);

// Now you will want to preserve your private key, CSR and self-signed
// cert so that they can be installed into your web server, mail server
// or mail client (depending on the intended use of the certificate).
// This example shows how to get those things into variables, but you
// can also store them directly into files.
// Typically, you will send the CSR on to your CA who will then issue
// you with the "real" certificate.
openssl_csr_export($csr, $csrout) and var_dump($csrout);
openssl_x509_export($sscert, $certout) and var_dump($certout);
openssl_pkey_export($privkey, $pkeyout, "mypassword") and var_dump($pkeyout);

// Show any errors that occurred here
while (($e = openssl_error_string()) !== false) {
    echo $e . "\n";
}
?>

Předcházející | Nahoru | Další
openssl_csr_get_subject | Domů | openssl_csr_sign


openssl_csr_sign

(PHP 4 >= 4.2.0, PHP 5)

openssl_csr_sign — Sign a CSR with another certificate (or itself) and generate a certificate

Popis

resource openssl_csr_sign ( mixed $csr, mixed $cacert, mixed $priv_key, int $days [, array $configargs [, int $serial]] )

openssl_csr_sign() generates an x509 certificate resource from the given CSR.

Poznámka: You need to have a valid openssl.cnf installed for this function to operate correctly. See the notes under the installation section for more information.

Seznam parametrů

csr

A CSR previously generated by openssl_csr_new(). It can also be the path to a PEM encoded CSR when specified as file://path/to/csr or an exported string generated by openssl_csr_export().

cacert

The generated certificate will be signed by cacert. If cacert is NULL, the generated certificate will be a self-signed certificate.

priv_key

priv_key is the private key that corresponds to cacert.

days

days specifies the length of time for which the generated certificate will be valid, in days.

configargs

You can finetune the CSR signing by configargs. See openssl_csr_new() for more information about configargs.

serial

An optional the serial number of issued certificate. If not specified it will default to 0.

Návratové hodnoty

Returns an x509 certificate resource on success, FALSE on failure.

ChangeLog (záznam změn)

Verze | Popis
4.3.3 | The serial parameter was added.

Příklady

Příklad 1476. openssl_csr_sign() example - signing a CSR (how to implement your own CA)

<?php
// Let's assume that this script is set to receive a CSR that has
// been pasted into a textarea from another page
$csrdata = $_POST["CSR"];

// We will sign the request using our own "certificate authority"
// certificate.  You can use any certificate to sign another, but
// the process is worthless unless the signing certificate is trusted
// by the software/users that will deal with the newly signed certificate

// We need our CA cert and its private key
$cacert = "file://path/to/ca.crt";
$privkey = array("file://path/to/ca.key", "your_ca_key_passphrase");

$userscert = openssl_csr_sign($csrdata, $cacert, $privkey, 365);

// Now display the generated certificate so that the user can
// copy and paste it into their local configuration (such as a file
// to hold the certificate for their SSL server)
openssl_x509_export($usercert, $certout);
echo $certout;

// Show any errors that occurred here
while (($e = openssl_error_string()) !== false) {
    echo $e . "\n";
}
?>

Předcházející | Nahoru | Další
openssl_csr_new | Domů | openssl_error_string


openssl_error_string

(PHP 4 >= 4.0.6, PHP 5)

openssl_error_string — Return openSSL error message

Popis

string openssl_error_string ( void )

openssl_error_string() returns the last error from the openSSL library. Error messages are stacked, so this function should be called multiple times to collect all of the information.

Návratové hodnoty

Returns an error message string, or FALSE if there are no more error messages to return.

Příklady

Příklad 1477. openssl_error_string() example

<?php
// lets assume you just called an openssl function that failed
while ($msg = openssl_error_string())
    echo $msg . "<br />\n";
?>

Předcházející | Nahoru | Další
openssl_csr_sign | Domů | openssl_free_key


openssl_free_key

(PHP 4 >= 4.0.4, PHP 5)

openssl_free_key — Uvolnit prostředky klíče

Popis

void openssl_free_key ( resource $key_identifier )

openssl_free_key() uvolní klíč asociovaný s předaným key_identifier z paměti.

Předcházející | Nahoru | Další
openssl_error_string | Domů | openssl_get_privatekey


openssl_get_privatekey

(PHP 4 >= 4.0.4, PHP 5)

openssl_get_privatekey — Připravit soukromý PEM klíč k použití

Popis

int openssl_get_privatekey ( string $key [, string $passphrase] )

Pri úspěchu vrací klíč, při chybě FALSE.

openssl_get_privatekey() rozparsuje sourkomý PEM klíč key a připraví ho k použití v dalších funkcích. Volitelný argument passphrase musí být předán, pokud je tento klíč zakódován (chráněn heslem).

Předcházející | Nahoru | Další
openssl_free_key | Domů | openssl_get_publickey


openssl_get_publickey

(PHP 4 >= 4.0.4, PHP 5)

openssl_get_publickey — Získat z certifikátu veřejný klíč a připravit ho k použití

Popis

int openssl_get_publickey ( string $certificate )

Při úspěchu vrací identifikátor klíče, při chybě FALSE.

openssl_get_publickey() z X.509 certifikátu certificate vyextrahuje veřejný klíč a připraví ho k použití v dalších funkcích.

Předcházející | Nahoru | Další
openssl_get_privatekey | Domů | openssl_open


openssl_open

(PHP 4 >= 4.0.4, PHP 5)

openssl_open — Otevřít zapečetěná data

Popis

bool openssl_open ( string $sealed_data, string &$open_data, string $env_key, mixed $priv_key_id )

Při úspěchu vrací TRUE, při chybě FALSE. Úspěšně otevřená data se umístí do argumentu open_data.

openssl_open() otevře (dekóduje) sealed_data pomocí soukromého klíče asociovaného s identifikátorem priv_key_id a obálkou env_key. Tato obálka se generuje při pečetění dat a je použitelná pouze s jedním utčitým soukromým klíčem. Více informací viz openssl_seal().

Příklad 1478. Ukázka openssl_open()

// $sealed a $env_key obsahují zapečetěná data a obálku
// obojí nám bylo dáno tím, kdo data zapečetil

// získat ze souboru soukromý klíč a připravit ho
$fp = fopen("/src/openssl-0.9.6/demos/sign/key.pem", "r");
$priv_key = fread($fp, 8192);
fclose($fp);
$pkeyid = openssl_get_privatekey($priv_key);

// dekódovat data a uložit je v $open
if (openssl_open($sealed, $open, $env_key, $pkeyid))
    echo "tady jsou otevřená data: ", $open;
else
    echo "nepodařilo se otevřít data";

// uvolnit klíč z paměti
openssl_free_key($pkeyid);

Viz také openssl_seal().

Předcházející | Nahoru | Další
openssl_get_publickey | Domů | openssl_pkcs12_export_to_file


openssl_pkcs7_decrypt

(PHP 4 >= 4.0.6, PHP 5)

openssl_pkcs7_decrypt — Decrypts an S/MIME encrypted message

Popis

bool openssl_pkcs7_decrypt ( string $infilename, string $outfilename, mixed $recipcert [, mixed $recipkey] )

Decrypts the S/MIME encrypted message contained in the file specified by infilename using the certificate and its associated private key specified by recipcert and recipkey.

Seznam parametrů

infilename

outfilename

The decrypted message is written to the file specified by outfilename.

recipcert

recipkey

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1479. openssl_pkcs7_decrypt() example

<?php
// $cert and $key are assumed to contain your personal certificate and private
// key pair, and that you are the recipient of an S/MIME message
$infilename = "encrypted.msg";  // this file holds your encrypted message
$outfilename = "decrypted.msg"; // make sure you can write to this file

if (openssl_pkcs7_decrypt($infilename, $outfilename, $cert, $key)) {
    echo "decrypted!";
} else {
    echo "failed to decrypt!";
}
?>

Předcházející | Nahoru | Další
openssl_pkcs12_read | Domů | openssl_pkcs7_encrypt


openssl_pkcs7_encrypt

(PHP 4 >= 4.0.6, PHP 5)

openssl_pkcs7_encrypt — Encrypt an S/MIME message

Popis

bool openssl_pkcs7_encrypt ( string $infile, string $outfile, mixed $recipcerts, array $headers [, int $flags [, int $cipherid]] )

openssl_pkcs7_encrypt() takes the contents of the file named infile and encrypts them using an RC2 40-bit cipher so that they can only be read by the intended recipients specified by recipcerts.

Seznam parametrů

infile

outfile

recipcerts

Either a lone X.509 certificate, or an array of X.509 certificates.

headers

headers is an array of headers that will be prepended to the data after it has been encrypted.

headers can be either an associative array keyed by header name, or an indexed array, where each element contains a single header line.

flags

flags can be used to specify options that affect the encoding process - see PKCS7 constants.

cipherid

Cipher can be selected with cipherid.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

ChangeLog (záznam změn)

Verze | Popis
5.0.0 | The cipherid parameter was added.

Příklady

Příklad 1480. openssl_pkcs7_encrypt() example

<?php
// the message you want to encrypt and send to your secret agent
// in the field, known as nighthawk.  You have his certificate
// in the file nighthawk.pem
$data = <<<EOD
Nighthawk,

Top secret, for your eyes only!

The enemy is closing in! Meet me at the cafe at 8.30am
to collect your forged passport!

HQ
EOD;

// load key
$key = file_get_contents("nighthawk.pem");

// save message to file
$fp = fopen("msg.txt", "w");
fwrite($fp, $data);
fclose($fp);

// encrypt it
if (openssl_pkcs7_encrypt("msg.txt", "enc.txt", $key,
    array("To" => "nighthawk@example.com", // keyed syntax
          "From: HQ <hq@example.com>", // indexed syntax
          "Subject" => "Eyes only"))) {
    // message encrypted - send it!
    exec(ini_get("sendmail_path") . " < enc.txt");
}
?>

Předcházející | Nahoru | Další
openssl_pkcs7_decrypt | Domů | openssl_pkcs7_sign


openssl_pkcs7_sign

(PHP 4 >= 4.0.6, PHP 5)

openssl_pkcs7_sign — Sign an S/MIME message

Popis

bool openssl_pkcs7_sign ( string $infilename, string $outfilename, mixed $signcert, mixed $privkey, array $headers [, int $flags [, string $extracerts]] )

openssl_pkcs7_sign() takes the contents of the file named infilename and signs them using the certificate and its matching private key specified by signcert and privkey parameters.

Seznam parametrů

infilename

outfilename

signcert

privkey

headers

headers is an array of headers that will be prepended to the data after it has been signed (see openssl_pkcs7_encrypt() for more information about the format of this parameter.

flags

flags can be used to alter the output - see PKCS7 constants - if not specified, it defaults to PKCS7_DETACHED.

extracerts

extracerts specifies the name of a file containing a bunch of extra certificates to include in the signature which can for example be used to help the recipient to verify the certificate that you used.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1481. openssl_pkcs7_sign() example

<?php
// the message you want to sign so that recipient can be sure it was you that
// sent it
$data = <<<EOD

You have my authorization to spend $10,000 on dinner expenses.

The CEO
EOD;
// save message to file
$fp = fopen("msg.txt", "w");
fwrite($fp, $data);
fclose($fp);
// encrypt it
if (openssl_pkcs7_sign("msg.txt", "signed.txt", "mycert.pem",
    array("file://mycert.pem", "mypassphrase"),
    array("To" => "joes@example.com", // keyed syntax
          "From: HQ <ceo@example.com>", // indexed syntax
          "Subject" => "Eyes only")
    )) {
    // message signed - send it!
    exec(ini_get("sendmail_path") . " < signed.txt");
}
?>

Předcházející | Nahoru | Další
openssl_pkcs7_encrypt | Domů | openssl_pkcs7_verify


openssl_pkcs7_verify

(PHP 4 >= 4.0.6, PHP 5)

openssl_pkcs7_verify — Verifies the signature of an S/MIME signed message

Popis

mixed openssl_pkcs7_verify ( string $filename, int $flags [, string $outfilename [, array $cainfo [, string $extracerts [, string $content]]]] )

openssl_pkcs7_verify() reads the S/MIME message contained in the given file and examines the digital signature.

Seznam parametrů

filename

Path to the message.

flags

flags can be used to affect how the signature is verified - see PKCS7 constants for more information.

outfilename

If the outfilename is specified, it should be a string holding the name of a file into which the certificates of the persons that signed the messages will be stored in PEM format.

cainfo

If the cainfo is specified, it should hold information about the trusted CA certificates to use in the verification process - see certificate verification for more information about this parameter.

extracerts

If the extracerts is specified, it is the filename of a file containing a bunch of certificates to use as untrusted CAs.

content

You can specify a filename with content that will be filled with the verified data, but with the signature information stripped.

Návratové hodnoty

Returns TRUE if the signature is verified, FALSE if it is not correct (the message has been tampered with, or the signing certificate is invalid), or -1 on error.

ChangeLog (záznam změn)

Verze | Popis
5.1.0 | The content parameter was added.

Předcházející | Nahoru | Další
openssl_pkcs7_sign | Domů | openssl_pkey_export_to_file


openssl_pkey_export_to_file

(PHP 4 >= 4.2.0, PHP 5)

openssl_pkey_export_to_file — Gets an exportable representation of a key into a file

Popis

bool openssl_pkey_export_to_file ( mixed $key, string $outfilename [, string $passphrase [, array $configargs]] )

openssl_pkey_export_to_file() saves an ascii-armoured (PEM encoded) rendition of key into the file named by outfilename.

Poznámka: You need to have a valid openssl.cnf installed for this function to operate correctly. See the notes under the installation section for more information.

Seznam parametrů

key

outfilename

Path to the output file.

passphrase

The key can be optionally protected by a passphrase.

configargs

configargs can be used to fine-tune the export process by specifying and/or overriding options for the openssl configuration file. See openssl_csr_new() for more information about configargs.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
openssl_pkcs7_verify | Domů | openssl_pkey_export


openssl_pkey_export

(PHP 4 >= 4.2.0, PHP 5)

openssl_pkey_export — Gets an exportable representation of a key into a string

Popis

bool openssl_pkey_export ( mixed $key, string &$out [, string $passphrase [, array $configargs]] )

openssl_pkey_export() exports key as a PEM encoded string and stores it into out (which is passed by reference).

Poznámka: You need to have a valid openssl.cnf installed for this function to operate correctly. See the notes under the installation section for more information.

Seznam parametrů

key

out

passphrase

The key is optionally protected by passphrase.

configargs

configargs can be used to fine-tune the export process by specifying and/or overriding options for the openssl configuration file. See openssl_csr_new() for more information about configargs.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
openssl_pkey_export_to_file | Domů | openssl_pkey_free


openssl_pkey_get_private

(PHP 4 >= 4.2.0, PHP 5)

openssl_pkey_get_private — Get a private key

Popis

resource openssl_pkey_get_private ( mixed $key [, string $passphrase] )

openssl_get_privatekey() parses key and prepares it for use by other functions.

Seznam parametrů

key

key can be one of the following:

  1. a string having the format file://path/to/file.pem. The named file must contain a PEM encoded certificate/private key (it may contain both).
  2. A PEM formatted private key.

passphrase

The optional parameter passphrase must be used if the specified key is encrypted (protected by a passphrase).

Návratové hodnoty

Returns a positive key resource identifier on success, or FALSE on error.

Předcházející | Nahoru | Další
openssl_pkey_get_details | Domů | openssl_pkey_get_public


openssl_pkey_get_public

(PHP 4 >= 4.2.0, PHP 5)

openssl_pkey_get_public — Extract public key from certificate and prepare it for use

Popis

resource openssl_pkey_get_public ( mixed $certificate )

openssl_get_publickey() extracts the public key from certificate and prepares it for use by other functions.

Seznam parametrů

certificate

certificate can be one of the following:

  1. an X.509 certificate resource
  2. a string having the format file://path/to/file.pem. The named file must contain a PEM encoded certificate/private key (it may contain both).
  3. A PEM formatted private key.

Návratové hodnoty

Returns a positive key resource identifier on success, or FALSE on error.

Předcházející | Nahoru | Další
openssl_pkey_get_private | Domů | openssl_pkey_new


openssl_pkey_new

(PHP 4 >= 4.2.0, PHP 5)

openssl_pkey_new — Generates a new private key

Popis

resource openssl_pkey_new ( [array $configargs] )

openssl_pkey_new() generates a new private and public key pair. The public component of the key can be obtained using openssl_pkey_get_public().

Poznámka: You need to have a valid openssl.cnf installed for this function to operate correctly. See the notes under the installation section for more information.

Seznam parametrů

configargs

You can finetune the key generation (such as specifying the number of bits) using configargs. See openssl_csr_new() for more information about configargs.

Návratové hodnoty

Returns a resource identifier for the pkey on success, or FALSE on error.

Předcházející | Nahoru | Další
openssl_pkey_get_public | Domů | openssl_private_decrypt


openssl_private_decrypt

(PHP 4 >= 4.0.6, PHP 5)

openssl_private_decrypt — Decrypts data with private key

Popis

bool openssl_private_decrypt ( string $data, string &$decrypted, mixed $key [, int $padding] )

openssl_private_decrypt() decrypts data that was previous encrypted via openssl_public_encrypt() and stores the result into decrypted.

You can use this function e.g. to decrypt data which were supposed only to you.

Seznam parametrů

data

decrypted

key

key must be the private key corresponding that was used to encrypt the data.

padding

padding defaults to OPENSSL_PKCS1_PADDING, but can also be one of OPENSSL_SSLV23_PADDING, OPENSSL_PKCS1_OAEP_PADDING, OPENSSL_NO_PADDING.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

openssl_public_encrypt()
openssl_public_decrypt()

Předcházející | Nahoru | Další
openssl_pkey_new | Domů | openssl_private_encrypt


openssl_private_encrypt

(PHP 4 >= 4.0.6, PHP 5)

openssl_private_encrypt — Encrypts data with private key

Popis

bool openssl_private_encrypt ( string $data, string &$crypted, mixed $key [, int $padding] )

openssl_private_encrypt() encrypts data with private key and stores the result into crypted. Encrypted data can be decrypted via openssl_public_decrypt().

This function can be used e.g. to sign data (or its hash) to prove that it is not written by someone else.

Seznam parametrů

data

crypted

key

padding

padding defaults to OPENSSL_PKCS1_PADDING, but can also be OPENSSL_NO_PADDING.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

openssl_public_encrypt()
openssl_public_decrypt()

Předcházející | Nahoru | Další
openssl_private_decrypt | Domů | openssl_public_decrypt


openssl_public_decrypt

(PHP 4 >= 4.0.6, PHP 5)

openssl_public_decrypt — Decrypts data with public key

Popis

bool openssl_public_decrypt ( string $data, string &$decrypted, mixed $key [, int $padding] )

openssl_public_decrypt() decrypts data that was previous encrypted via openssl_private_encrypt() and stores the result into decrypted.

You can use this function e.g. to check if the message was written by the owner of the private key.

Seznam parametrů

data

decrypted

key

key must be the public key corresponding that was used to encrypt the data.

padding

padding defaults to OPENSSL_PKCS1_PADDING, but can also be OPENSSL_NO_PADDING.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

openssl_private_encrypt()
openssl_private_decrypt()

Předcházející | Nahoru | Další
openssl_private_encrypt | Domů | openssl_public_encrypt


openssl_public_encrypt

(PHP 4 >= 4.0.6, PHP 5)

openssl_public_encrypt — Encrypts data with public key

Popis

bool openssl_public_encrypt ( string $data, string &$crypted, mixed $key [, int $padding] )

openssl_public_encrypt() encrypts data with public key and stores the result into crypted. Encrypted data can be decrypted via openssl_private_decrypt().

This function can be used e.g. to encrypt message which can be then read only by owner of the private key. It can be also used to store secure data in database.

Seznam parametrů

data

crypted

This will hold the result of the encryption.

key

The public key.

padding

padding defaults to OPENSSL_PKCS1_PADDING, but can also be one of OPENSSL_SSLV23_PADDING, OPENSSL_PKCS1_OAEP_PADDING, OPENSSL_NO_PADDING.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

openssl_private_encrypt()
openssl_private_decrypt()

Předcházející | Nahoru | Další
openssl_public_decrypt | Domů | openssl_seal


openssl_seal

(PHP 4 >= 4.0.4, PHP 5)

openssl_seal — Zapečetit (zakódovat) data

Popis

int openssl_seal ( string $data, string &$sealed_data, array &$env_keys, array $pub_key_ids )

Při úspěchu vrací délku zapečetěných dat, při chybě FALSE. Úspěšně zapečetěná data se umístí do argumentu sealed_data, a obálka do env_keys.

openssl_seal() zapečetí (zakóduje) data pomocí RC4 s náhodně generovaným tajným klíčem. Tento klíč se zakóduje všemi veřejnými klíči asociovanými s identifikátory v pub_key_ids a zakódované klíče se vrátí v env_keys. To znamená, že lze poslat zapečetěná data více příjemcům (za předpokladu, že máme jejích veřejné klíče). Každý z příjemců musí obdržet zapečetěná data a obálku, která byla zakódována jeho veřejným klíčem.

Příklad 1482. Ukázka openssl_seal()

// $data obsahuje data určená k zapečetění

// získat veřejné klíče našich příjemců a připravit je
$fp = fopen("/src/openssl-0.9.6/demos/maurice/cert.pem", "r");
$cert = fread($fp, 8192);
fclose($fp);
$pk1 = openssl_get_publickey($cert);
// opakovat prodruhého příjemce
$fp = fopen("/src/openssl-0.9.6/demos/sign/cert.pem", "r");
$cert = fread($fp, 8192);
fclose($fp);
$pk2 = openssl_get_publickey($cert);

// zapečetit zprávu, pouze majitelé $pk1 a $pk2 mohou dekódovat $sealed pomocí
// $ekeys[0] a $ekeys[1].
openssl_seal($data, $sealed, $ekeys, array($pk1,$pk2));

// uvolnit klíče z paměti
openssl_free_key($pk1);
openssl_free_key($pk2);

Viz také openssl_open().

Předcházející | Nahoru | Další
openssl_public_encrypt | Domů | openssl_sign


openssl_sign

(PHP 4 >= 4.0.4, PHP 5)

openssl_sign — Generate signature

Popis

bool openssl_sign ( string $data, string &$signature, mixed $priv_key_id [, int $signature_alg] )

Při úspěchu vrací TRUE, při chybě FALSE. Úspěšně vytvořený podpis se umístí v signature.

openssl_sign() vypočítá podpis pro daná specified data pomocí SHA1 hashe a následně jej zakóduje soukromým klíčem asociovaným s priv_key_id. Pozn.: samotná data nejsou kódována.

Příklad 1483. openssl_sign() example

// $data obsahuje data určená k podpisu

// získat ze souboru soukromý klíč a připravit ho
$fp = fopen("/src/openssl-0.9.6/demos/sign/key.pem", "r");
$priv_key = fread($fp, 8192);
fclose($fp);
$pkeyid = openssl_get_privatekey($priv_key);

// vytvořit podpis
openssl_sign($data, $signature, $pkeyid);

// uvolnit klíč z paměti
openssl_free_key($pkeyid);

Viz také openssl_verify().

Předcházející | Nahoru | Další
openssl_seal | Domů | openssl_verify


openssl_verify

(PHP 4 >= 4.0.4, PHP 5)

openssl_verify — Ověřit podpis

Popis

int openssl_verify ( string $data, string $signature, mixed $pub_key_id [, int $signature_alg] )

Vrací 1, pokud je podpis správný, 0, pokud je nesprávný, a -1 při chybě.

openssl_verify() ověřuje, zda je signature správný pro data pomocí veřejného klíče asociovaného s pub_key_id. Musí to být veřejný klíč odpovídající soukromému klíči použitému k podpisu.

Příklad 1484. Ukázka openssl_verify()

// $data a $signature obsahují data a podpis

// získat z certifikátu veřejný klíč a připravit ho
$fp = fopen("/src/openssl-0.9.6/demos/sign/cert.pem", "r");
$cert = fread($fp, 8192);
fclose($fp);
$pubkeyid = openssl_get_publickey($cert);

// zjistit, jestli je podpis v pořádku
$ok = openssl_verify($data, $signature, $pubkeyid);
if ($ok == 1)
    echo "dobře";
elseif ($ok == 0)
    echo "špatně";
else
    echo "nejhůř, při kontrole podpisu došlo k chybě";

// uvolnit klíč z paměti
openssl_free_key($pubkeyid);

Viz také openssl_sign().

Předcházející | Nahoru | Další
openssl_sign | Domů | openssl_x509_check_private_key


openssl_x509_check_private_key

(PHP 4 >= 4.2.0, PHP 5)

openssl_x509_check_private_key — Checks if a private key corresponds to a certificate

Popis

bool openssl_x509_check_private_key ( mixed $cert, mixed $key )

Checks whether the given key is the private key that corresponds to cert.

Seznam parametrů

cert

The certificate.

key

The private key.

Návratové hodnoty

Returns TRUE if key is the private key that corresponds to cert, or FALSE otherwise.

Předcházející | Nahoru | Další
openssl_verify | Domů | openssl_x509_checkpurpose


openssl_x509_checkpurpose

(PHP 4 >= 4.0.6, PHP 5)

openssl_x509_checkpurpose — Verifies if a certificate can be used for a particular purpose

Popis

int openssl_x509_checkpurpose ( mixed $x509cert, int $purpose [, array $cainfo [, string $untrustedfile]] )

openssl_x509_checkpurpose() examines a certificate to see if it can be used for the specified purpose.

Seznam parametrů

x509cert

The examined certificate.

purpose

Tabulka 225. openssl_x509_checkpurpose() purposes

Constant | Description
X509_PURPOSE_SSL_CLIENT | Can the certificate be used for the client side of an SSL connection?
X509_PURPOSE_SSL_SERVER | Can the certificate be used for the server side of an SSL connection?
X509_PURPOSE_NS_SSL_SERVER | Can the cert be used for Netscape SSL server?
X509_PURPOSE_SMIME_SIGN | Can the cert be used to sign S/MIME email?
X509_PURPOSE_SMIME_ENCRYPT | Can the cert be used to encrypt S/MIME email?
X509_PURPOSE_CRL_SIGN | Can the cert be used to sign a certificate revocation list (CRL)?
X509_PURPOSE_ANY | Can the cert be used for Any/All purposes?

These options are not bitfields - you may specify one only!

cainfo

cainfo should be an array of trusted CA files/dirs as described in Certificate Verification. It defaults to an empty array.

untrustedfile

If specified, this should be the name of a PEM encoded file holding certificates that can be used to help verify the certificate, although no trust in placed in the certificates that come from that file.

Návratové hodnoty

Returns TRUE if the certificate can be used for the intended purpose, FALSE if it cannot, or -1 on error.

Předcházející | Nahoru | Další
openssl_x509_check_private_key | Domů | openssl_x509_export_to_file


openssl_x509_export_to_file

(PHP 4 >= 4.2.0, PHP 5)

openssl_x509_export_to_file — Exports a certificate to file

Popis

bool openssl_x509_export_to_file ( mixed $x509, string $outfilename [, bool $notext] )

openssl_x509_export_to_file() stores x509 into a file named by outfilename in a PEM encoded format.

Seznam parametrů

x509

outfilename

Path to the output file.

notext

The optional parameter notext affects the verbosity of the output; if it is FALSE then additional human-readable information is included in the output. The default value of notext is TRUE.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
openssl_x509_checkpurpose | Domů | openssl_x509_export


openssl_x509_export

(PHP 4 >= 4.2.0, PHP 5)

openssl_x509_export — Exports a certificate as a string

Popis

bool openssl_x509_export ( mixed $x509, string &$output [, bool $notext] )

openssl_x509_export() stores x509 into a string named by output in a PEM encoded format.

Seznam parametrů

x509

output

On success, this will hold the PEM.

notext

The optional parameter notext affects the verbosity of the output; if it is FALSE then additional human-readable information is included in the output. The default value of notext is TRUE.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
openssl_x509_export_to_file | Domů | openssl_x509_free


openssl_x509_free

(PHP 4 >= 4.0.6, PHP 5)

openssl_x509_free — Free certificate resource

Popis

void openssl_x509_free ( resource $x509cert )

openssl_x509_free() frees the certificate associated with the specified x509cert resource from memory.

Seznam parametrů

x509cert

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
openssl_x509_export | Domů | openssl_x509_parse


openssl_x509_parse

(PHP 4 >= 4.0.6, PHP 5)

openssl_x509_parse — Parse an X509 certificate and return the information as an array

Popis

array openssl_x509_parse ( mixed $x509cert [, bool $shortnames] )

openssl_x509_parse() returns information about the supplied x509cert, including fields such as subject name, issuer name, purposes, valid from and valid to dates etc.

Seznam parametrů

x509cert

shortnames

shortnames controls how the data is indexed in the array - if shortnames is TRUE (the default) then fields will be indexed with the short name form, otherwise, the long name form will be used - e.g.: CN is the shortname form of commonName.

Návratové hodnoty

The structure of the returned data is (deliberately) not yet documented, as it is still subject to change.

Předcházející | Nahoru | Další
openssl_x509_free | Domů | openssl_x509_read


openssl_x509_read

(PHP 4 >= 4.0.6, PHP 5)

openssl_x509_read — Parse an X.509 certificate and return a resource identifier for it

Popis

resource openssl_x509_read ( mixed $x509certdata )

openssl_x509_read() parses the certificate supplied by x509certdata and returns a resource identifier for it.

Seznam parametrů

x509certdata

Návratové hodnoty

Returns a resource identifier on success, or FALSE on failure.

Předcházející | Nahoru | Další
openssl_x509_parse | Domů | CXIII. Oracle Functions [deprecated]


Oracle Functions [deprecated]

Předcházející VI. Reference funkcí Další

CXIII. Oracle Functions [deprecated]

Úvod

Varování

This extension is deprecated. Instead, use the improved oci8 extension. Functions documented here do list recommended oci8 alternatives.

This extension adds support for Oracle database server access.

Poznámka: Toto rozšíření bylo přesunuto do repozitáře PECL a již nebude součástí balíku PHP.5.1.0.

Instalace

You have to compile PHP with the option --with-oracle[=DIR], where DIR defaults to your environment variable ORACLE_HOME.

Typy prostředků

This extension defines two resource types: an Oracle connection identifier and an Oracle cursor index.

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

ORA_BIND_INOUT (integer)
ORA_BIND_IN (integer)
ORA_BIND_OUT (integer)
ORA_FETCHINTO_ASSOC (integer)
ORA_FETCHINTO_NULLS (integer)

Obsah

ora_bind — Binds a PHP variable to an Oracle parameter
ora_close — Closes an Oracle cursor
ora_columnname — Gets the name of an Oracle result column
ora_columnsize — Returns the size of an Oracle result column
ora_columntype — Gets the type of an Oracle result column
ora_commit — Commit an Oracle transaction
ora_commitoff — Disable automatic commit
ora_commiton — Enable automatic commit
ora_do — Parse, Exec, Fetch
ora_error — Gets an Oracle error message
ora_errorcode — Gets an Oracle error code
ora_exec — Execute a parsed statement on an Oracle cursor
ora_fetch_into — Fetch a row into the specified result array
ora_fetch — Fetch a row of data from a cursor
ora_getcolumn — Get data from a fetched column
ora_logoff — Close an Oracle connection
ora_logon — Open an Oracle connection
ora_numcols — Returns the number of columns
ora_numrows — Returns the number of rows
ora_open — Opens an Oracle cursor
ora_parse — Parse an SQL statement with Oracle
ora_plogon — Open a persistent Oracle connection
ora_rollback — Rolls back a transaction
Předcházející | Nahoru | Další
openssl_x509_read | Domů | ora_bind


ora_bind

(PHP 4, PHP 5 <= 5.0.5)

ora_bind — Binds a PHP variable to an Oracle parameter

Popis

bool ora_bind ( resource $cursor, string $phpvar, string $sqlparam, int $length [, int $type] )

Binds the named PHP variable with a SQL parameter.

ora_bind() must be called after ora_parse() and before ora_exec(). Input values can be given by assignment to the bound PHP variables, after calling ora_exec() the bound PHP variables contain the output values if available.

Seznam parametrů

cursor

An Oracle cursor, opened with ora_open().

phpvar

The PHP variable to be bound.

sqlparam

The SQL parameter. Must be in the form :name.

length

type

Defines the type of the parameter. It defaults to ORA_BIND_INOUT. Possible values are listed below:

Constant | Value
ORA_BIND_INOUT | 0
ORA_BIND_IN | 1
ORA_BIND_OUT | 2

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání. Details about the error can be retrieved using the ora_error() and ora_errorcode() functions.

ChangeLog (záznam změn)

Verze | Popis
5.1.0 | The oracle extension is deprecated in favor of oci8.
3.0.1 | The constants for the type were added. In previous versions, you should use the numerical values.

Příklady

Příklad 1485. ora_bind() example

<?php
  ora_parse($curs, "declare tmp INTEGER; begin tmp := :in; :out := tmp; :x := 7.77; end;");
  ora_bind($curs, "result", ":x", $len, 2);
  ora_bind($curs, "input", ":in", 5, 1);
  ora_bind($curs, "output", ":out", 5, 2);
  $input = 765;
  ora_exec($curs);
  echo "Result: $result<br />Out: $output<br />In: $input";
?>

Poznámky

When using oci8 as a replacement for the deprecated oracle extension, consider using:
oci_bind_by_name()
oci_bind_array_by_name()

Předcházející | Nahoru | Další
CXIII. Oracle Functions [deprecated] | Domů | ora_close


ora_close

(PHP 4, PHP 5 <= 5.0.5)

ora_close — Closes an Oracle cursor

Popis

bool ora_close ( resource $cursor )

Closes a data cursor.

Seznam parametrů

cursor

An Oracle cursor, opened with ora_open().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání. Details about the error can be retrieved using the ora_error() and ora_errorcode() functions.

ChangeLog (záznam změn)

Verze | Popis
5.1.0 | The oracle extension is deprecated in favor of oci8.

Poznámky

When using oci8 as a replacement for the deprecated oracle extension, consider using:
oci_free_statement()

Předcházející | Nahoru | Další
ora_bind | Domů | ora_columnname


ora_columnname

(PHP 4, PHP 5 <= 5.0.5)

ora_columnname — Gets the name of an Oracle result column

Popis

string ora_columnname ( resource $cursor, int $column )

Returns the name of the column on the cursor.

Seznam parametrů

cursor

An Oracle cursor, opened with ora_open().

column

The column number. First is 0.

Návratové hodnoty

Returns the name as a string. The returned name is in all uppercase letters.

ChangeLog (záznam změn)

Verze | Popis
5.1.0 | The oracle extension is deprecated in favor of oci8.

Poznámky

When using oci8 as a replacement for the deprecated oracle extension, consider using:
oci_field_name()

Předcházející | Nahoru | Další
ora_close | Domů | ora_columnsize


ora_columnsize

(PHP 4, PHP 5 <= 5.0.5)

ora_columnsize — Returns the size of an Oracle result column

Popis

int ora_columnsize ( resource $cursor, int $column )

Returns the size of a column on the cursor.

Seznam parametrů

cursor

An Oracle cursor, opened with ora_open().

column

The column number. First is 0.

Návratové hodnoty

Returns the size as an integer, or FALSE on error.

ChangeLog (záznam změn)

Verze | Popis
5.1.0 | The oracle extension is deprecated in favor of oci8.

Poznámky

When using oci8 as a replacement for the deprecated oracle extension, consider using:
oci_field_size()

Předcházející | Nahoru | Další
ora_columnname | Domů | ora_columntype


ora_columntype

(PHP 4, PHP 5 <= 5.0.5)

ora_columntype — Gets the type of an Oracle result column

Popis

string ora_columntype ( resource $cursor, int $column )

Returns the Oracle data type name of the column on the cursor.

Seznam parametrů

cursor

An Oracle cursor, opened with ora_open().

column

The column number. First is 0.

Návratové hodnoty

The returned type will be one of the following strings:
"VARCHAR2"
"VARCHAR"
"CHAR"
"NUMBER"
"LONG"
"LONG RAW"
"ROWID"
"DATE"
"CURSOR"

ChangeLog (záznam změn)

Verze | Popis
5.1.0 | The oracle extension is deprecated in favor of oci8.

Poznámky

When using oci8 as a replacement for the deprecated oracle extension, consider using:
oci_field_type()
oci_field_type_raw()

Předcházející | Nahoru | Další
ora_columnsize | Domů | ora_commit


ora_commit

(PHP 4, PHP 5 <= 5.0.5)

ora_commit — Commit an Oracle transaction

Popis

bool ora_commit ( resource $connection )

Commits an Oracle transaction.

A transaction is defined as all the changes on a given connection since the last commit/rollback, autocommit was turned off or when the connection was established.

Seznam parametrů

connection

A connection identifier, opened with ora_logon().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání. Details about the error can be retrieved using the ora_error() and ora_errorcode() functions.

ChangeLog (záznam změn)

Verze | Popis
5.1.0 | The oracle extension is deprecated in favor of oci8.

Poznámky

When using oci8 as a replacement for the deprecated oracle extension, consider using:
oci_commit()

Viz také

ora_commiton()
ora_commitoff()

Předcházející | Nahoru | Další
ora_columntype | Domů | ora_commitoff


ora_commitoff

(PHP 4, PHP 5 <= 5.0.5)

ora_commitoff — Disable automatic commit

Popis

bool ora_commitoff ( resource $connection )

Turns off automatic commit after each ora_exec() on the given connection.

Seznam parametrů

connection

A connection identifier, opened with ora_logon().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání. Details about the error can be retrieved using the ora_error() and ora_errorcode() functions.

ChangeLog (záznam změn)

Verze | Popis
5.1.0 | The oracle extension is deprecated in favor of oci8.

Poznámky

When using oci8 as a replacement for the deprecated oracle extension, consider using:
Pass the OCI_DEFAULT flag to oci_execute()

Viz také

ora_commiton()
ora_commit()

Předcházející | Nahoru | Další
ora_commit | Domů | ora_commiton


ora_commiton

(PHP 4, PHP 5 <= 5.0.5)

ora_commiton — Enable automatic commit

Popis

bool ora_commiton ( resource $connection )

Turns on automatic commit after each ora_exec() on the given connection.

Seznam parametrů

connection

A connection identifier, opened with ora_logon().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání. Details about the error can be retrieved using the ora_error() and ora_errorcode() functions.

ChangeLog (záznam změn)

Verze | Popis
5.1.0 | The oracle extension is deprecated in favor of oci8.

Poznámky

When using oci8 as a replacement for the deprecated oracle extension, consider using:
oci_execute()

Viz také

ora_commitoff()
ora_commit()

Předcházející | Nahoru | Další
ora_commitoff | Domů | ora_do


ora_do

(PHP 4, PHP 5 <= 5.0.5)

ora_do — Parse, Exec, Fetch

Popis

resource ora_do ( resource $connection, string $query )

Parse and execute a statement, then fetch the first result row.

This function is a quick combination of ora_parse(), ora_exec() and ora_fetch().

Seznam parametrů

connection

A connection identifier, opened with ora_logon().

query

The SQL statement.

Návratové hodnoty

This function returns a cursor index or FALSE on failure. Details about the error can be retrieved using the ora_error() and ora_errorcode() functions.

ChangeLog (záznam změn)

Verze | Popis
5.1.0 | The oracle extension is deprecated in favor of oci8.

Poznámky

There is no direct replacement for ora_do() in oci8. Instead, use a sequence of oci_parse(), oci_excute(), and one of the oci_fetch_*() functions.

Viz také

ora_parse()
ora_exec()
ora_fetch()

Předcházející | Nahoru | Další
ora_commiton | Domů | ora_error


ora_error

(PHP 4, PHP 5 <= 5.0.5)

ora_error — Gets an Oracle error message

Popis

string ora_error ( [resource $cursor_or_connection] )

Returns the error message of the last executed statement on the specified cursor or connection.

Seznam parametrů

cursor_or_connection

An Oracle cursor or connection identifier.

Návratové hodnoty

Returns an error message of the form XXX-NNNNN where XXX is where the error comes from and NNNNN identifies the error message.

ChangeLog (záznam změn)

Verze | Popis
5.1.0 | The oracle extension is deprecated in favor of oci8.
3.0.4 | Support for connection identifiers was added.

Příklady

On Unix versions of Oracle, you can find details about an error message like this:

$> oerr ora 00001

Výše uvedený příklad vypíše něco jako:

00001, 00000,
"unique constraint (%s.%s) violated" // *Cause: An update or insert
statement attempted to insert a duplicate key //         For Trusted
ORACLE configured in DBMS MAC mode, you may see //         this message
if a duplicate entry exists at a different level.  // *Action: Either
remove the unique restriction or do not insert the key

Poznámky

When using oci8 as a replacement for the deprecated oracle extension, consider using:
oci_error()

Předcházející | Nahoru | Další
ora_do | Domů | ora_errorcode


ora_errorcode

(PHP 4, PHP 5 <= 5.0.5)

ora_errorcode — Gets an Oracle error code

Popis

int ora_errorcode ( [resource $cursor_or_connection] )

Returns the numeric error code of the last executed statement on the specified cursor or connection.

Seznam parametrů

cursor_or_connection

An Oracle cursor or connection identifier.

Návratové hodnoty

Returns the error code, as an integer.

ChangeLog (záznam změn)

Verze | Popis
5.1.0 | The oracle extension is deprecated in favor of oci8.
3.0.4 | Support for connection identifiers was added.

Poznámky

When using oci8 as a replacement for the deprecated oracle extension, consider using:
oci_error() (the "code" field of the resulting array)

Předcházející | Nahoru | Další
ora_error | Domů | ora_exec


ora_exec

(PHP 4, PHP 5 <= 5.0.5)

ora_exec — Execute a parsed statement on an Oracle cursor

Popis

bool ora_exec ( resource $cursor )

Executes the parsed statement cursor.

Seznam parametrů

cursor

An Oracle cursor, already parsed by ora_parse().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání. Details about the error can be retrieved using the ora_error() and ora_errorcode() functions.

ChangeLog (záznam změn)

Verze | Popis
5.1.0 | The oracle extension is deprecated in favor of oci8.

Poznámky

When using oci8 as a replacement for the deprecated oracle extension, consider using:
oci_execute()

Viz také

ora_parse()
ora_fetch()
ora_do()

Předcházející | Nahoru | Další
ora_errorcode | Domů | ora_fetch_into


ora_fetch_into

(PHP 4, PHP 5 <= 5.0.5)

ora_fetch_into — Fetch a row into the specified result array

Popis

int ora_fetch_into ( resource $cursor, array &$result [, int $flags] )

Fetches a row of data into an array.

Seznam parametrů

cursor

An Oracle cursor, opened with ora_open().

result

An array passed by reference. It will be filled with the fetched values.

flags

There are two possible flags. If ORA_FETCHINTO_NULLS is set, columns with NULL values are set in the array; and if the ORA_FETCHINTO_ASSOC flag is set, an associative array is created.

Návratové hodnoty

Returns the number of columns fetched, or FALSE on error.

ChangeLog (záznam změn)

Verze | Popis
5.1.0 | The oracle extension is deprecated in favor of oci8.

Příklady

Příklad 1486. ora_fetch_into()

<?php
$results = array();
ora_fetch_into($cursor, $results);
echo $results[0];
echo $results[1];
$results = array();
ora_fetch_into($cursor, $results, ORA_FETCHINTO_NULLS|ORA_FETCHINTO_ASSOC);
echo $results['MyColumn'];
?>

Poznámky

When using oci8 as a replacement for the deprecated oracle extension, consider using:
A fetch function like oci_fetch_array()

Viz také

ora_parse()
ora_exec()
ora_fetch()
ora_do()

Předcházející | Nahoru | Další
ora_exec | Domů | ora_fetch


ora_fetch

(PHP 4, PHP 5 <= 5.0.5)

ora_fetch — Fetch a row of data from a cursor

Popis

bool ora_fetch ( resource $cursor )

Retrieves a row of data from the specified cursor.

Seznam parametrů

cursor

An Oracle cursor, opened with ora_open().

Návratové hodnoty

Returns TRUE (a row was fetched) or FALSE (no more rows, or an
error occurred). If an error occurred, details can be retrieved
using the ora_error() and
ora_errorcode() functions. If there was no
error, ora_errorcode() will return 0.

ChangeLog (záznam změn)

Verze | Popis
5.1.0 | The oracle extension is deprecated in favor of oci8.

Poznámky

When using oci8 as a replacement for the deprecated oracle extension, consider using:
oci_fetch()

Viz také

ora_parse()
ora_exec()
ora_do()

Předcházející | Nahoru | Další
ora_fetch_into | Domů | ora_getcolumn


ora_getcolumn

(PHP 4, PHP 5 <= 5.0.5)

ora_getcolumn — Get data from a fetched column

Popis

string ora_getcolumn ( resource $cursor, int $column )

Fetches the data for a column or function result.

Seznam parametrů

cursor

An Oracle cursor, opened with ora_open().

column

The column number, as an integer.

Návratové hodnoty

Returns the column data. If an error occurs, FALSE is returned and ora_errorcode() will return a non-zero value. Note, however, that a test for FALSE on the results from this function may be TRUE in cases where there is not error as well (NULL result, empty string, the number 0, the string "0").

ChangeLog (záznam změn)

Verze | Popis
5.1.0 | The oracle extension is deprecated in favor of oci8.

Poznámky

When using oci8 as a replacement for the deprecated oracle extension, consider using:
oci_result()

Předcházející | Nahoru | Další
ora_fetch | Domů | ora_logoff


ora_logoff

(PHP 4, PHP 5 <= 5.0.5)

ora_logoff — Close an Oracle connection

Popis

bool ora_logoff ( resource $connection )

Logs out the user and disconnects from the server.

Seznam parametrů

connection

A connection identifier, opened with ora_logon().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání. Details about the error can be retrieved using the ora_error() and ora_errorcode() functions.

ChangeLog (záznam změn)

Verze | Popis
5.1.0 | The oracle extension is deprecated in favor of oci8.

Poznámky

When using oci8 as a replacement for the deprecated oracle extension, consider using:
oci_close()

Viz také

ora_logon()

Předcházející | Nahoru | Další
ora_getcolumn | Domů | ora_logon


ora_logon

(PHP 4, PHP 5 <= 5.0.5)

ora_logon — Open an Oracle connection

Popis

resource ora_logon ( string $user, string $password )

Establishes a connection between PHP and an Oracle database.

Connections can be made using SQL*Net by supplying the TNS name to user like this:

<?php
$conn = Ora_Logon("user@TNSNAME", "pass");
?>

If you have character data with non-ASCII characters, you should make sure that NLS_LANG is set in your environment. For server modules, you should set it in the server's environment before starting the server.

Seznam parametrů

user

The user name.

password

The password associated with user.

Návratové hodnoty

Returns a connection identifier on success, or FALSE on failure. Details about the error can be retrieved using the ora_error() and ora_errorcode() functions.

ChangeLog (záznam změn)

Verze | Popis
5.1.0 | The oracle extension is deprecated in favor of oci8.

Poznámky

When using oci8 as a replacement for the deprecated oracle extension, consider using:
oci_connect()
oci_new_connect()

Předcházející | Nahoru | Další
ora_logoff | Domů | ora_numcols


ora_numcols

(PHP 4, PHP 5 <= 5.0.5)

ora_numcols — Returns the number of columns

Popis

int ora_numcols ( resource $cursor )

Returns the number of columns in a result. It only returns meaningful values after a parse/exec/fetch sequence.

Seznam parametrů

cursor

An Oracle cursor, opened with ora_open().

Návratové hodnoty

Returns the number of columns as an integer, or FALSE on error.

ChangeLog (záznam změn)

Verze | Popis
5.1.0 | The oracle extension is deprecated in favor of oci8.

Poznámky

When using oci8 as a replacement for the deprecated oracle extension, consider using:
oci_num_fields()

Viz také

ora_parse()
ora_exec()
ora_fetch()
ora_do()

Předcházející | Nahoru | Další
ora_logon | Domů | ora_numrows


ora_numrows

(PHP 4, PHP 5 <= 5.0.5)

ora_numrows — Returns the number of rows

Popis

int ora_numrows ( resource $cursor )

Returns the number of rows in a result.

Seznam parametrů

cursor

An Oracle cursor, opened with ora_open().

Návratové hodnoty

Returns the number of rows as an integer, or FALSE on error.

ChangeLog (záznam změn)

Verze | Popis
5.1.0 | The oracle extension is deprecated in favor of oci8.

Poznámky

When using oci8 as a replacement for the deprecated oracle extension, consider using:
oci_num_rows()

Předcházející | Nahoru | Další
ora_numcols | Domů | ora_open


ora_open

(PHP 4, PHP 5 <= 5.0.5)

ora_open — Opens an Oracle cursor

Popis

resource ora_open ( resource $connection )

Opens an Oracle cursor associated with connection.

Seznam parametrů

connection

A connection identifier, opened with ora_logon().

Návratové hodnoty

Returns a cursor index or FALSE on failure. Details about the error can be retrieved using the ora_error() and ora_errorcode() functions.

ChangeLog (záznam změn)

Verze | Popis
5.1.0 | The oracle extension is deprecated in favor of oci8.

Poznámky

When using oci8 as a replacement for the deprecated oracle extension, consider using:
oci_new_cursor()

Předcházející | Nahoru | Další
ora_numrows | Domů | ora_parse


ora_parse

(PHP 4, PHP 5 <= 5.0.5)

ora_parse — Parse an SQL statement with Oracle

Popis

bool ora_parse ( resource $cursor, string $sql_statement [, int $defer] )

Parses an SQL statement or a PL/SQL block and associates it with the given cursor.

Seznam parametrů

cursor

An Oracle cursor, opened with ora_open().

sql_statement

The SQL statement, or PL/SQL block.

defer

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

ChangeLog (záznam změn)

Verze | Popis
5.1.0 | The oracle extension is deprecated in favor of oci8.

Poznámky

When using oci8 as a replacement for the deprecated oracle extension, consider using:
oci_parse()

Viz také

ora_exec()
ora_fetch()
ora_do()

Předcházející | Nahoru | Další
ora_open | Domů | ora_plogon


ora_plogon

(PHP 4, PHP 5 <= 5.0.5)

ora_plogon — Open a persistent Oracle connection

Popis

resource ora_plogon ( string $user, string $password )

Establishes a persistent connection between PHP and an Oracle database.

Seznam parametrů

user

The user name.

password

The password associated with user.

Návratové hodnoty

Returns a persistent connection identifier, or FALSE on error.

ChangeLog (záznam změn)

Verze | Popis
5.1.0 | The oracle extension is deprecated in favor of oci8.

Poznámky

When using oci8 as a replacement for the deprecated oracle extension, consider using:
oci_pconnect()

Viz také

ora_logon()

Předcházející | Nahoru | Další
ora_parse | Domů | ora_rollback


ora_rollback

(PHP 4, PHP 5 <= 5.0.5)

ora_rollback — Rolls back a transaction

Popis

bool ora_rollback ( resource $connection )

Rollbacks an Oracle transaction.

See ora_commit() for the definition of a transaction.

Seznam parametrů

connection

A connection identifier, opened with ora_logon().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání. Details about the error can be retrieved using the ora_error() and ora_errorcode() functions.

ChangeLog (záznam změn)

Verze | Popis
5.1.0 | The oracle extension is deprecated in favor of oci8.

Poznámky

When using oci8 as a replacement for the deprecated oracle extension, consider using:
oci_rollback()

Předcházející | Nahoru | Další
ora_plogon | Domů | CXIV. Oracle Functions (PDO_OCI)


Ovrimos SQL Functions

Předcházející VI. Reference funkcí Další

CXVI. Ovrimos SQL Functions

Úvod

Ovrimos SQL Server, is a client/server, transactional RDBMS combined with Web capabilities and fast transactions.

Poznámka: Toto rozšíření bylo přesunuto do repozitáře PECL a již nebude součástí balíku PHP.4.4.5 and PHP 5.1.0.

Poznámka: Toto rozšíření není k dispozici na platformách Windows.

Požadavky

You'll need to install the sqlcli library available in the Ovrimos SQL Server distribution.

Instalace

To enable Ovrimos support in PHP just compile PHP with the --with-ovrimos[=DIR] parameter to your configure line. DIR is the Ovrimos' libsqlcli install directory.

Konfigurace běhu

Toto rozšíření nemá definováno žádné konfigurační direktivy.

Typy prostředků

Příklady

Příklad 1496. Connect to Ovrimos SQL Server and select from a system table

<?php
$conn = ovrimos_connect("server.domain.com", "8001", "admin", "password");
if ($conn != 0) {
    echo "Connection ok!";
    $res = ovrimos_exec($conn, "select table_id, table_name from sys.tables");
    if ($res != 0) {
        echo "Statement ok!";
        ovrimos_result_all($res);
        ovrimos_free_result($res);
    }
    ovrimos_close($conn);
}
?>

This will just connect to an Ovrimos SQL server.

Obsah

ovrimos_close — Closes the connection to ovrimos
ovrimos_commit — Commits the transaction
ovrimos_connect — Connect to the specified database
ovrimos_cursor — Returns the name of the cursor
ovrimos_exec — Executes an SQL statement
ovrimos_execute — Executes a prepared SQL statement
ovrimos_fetch_into — Fetches a row from the result set
ovrimos_fetch_row — Fetches a row from the result set
ovrimos_field_len — Returns the length of the output column
ovrimos_field_name — Returns the output column name
ovrimos_field_num — Returns the (1-based) index of the output column
ovrimos_field_type — Returns the type of the output column
ovrimos_free_result — Frees the specified result_id
ovrimos_longreadlen — Specifies how many bytes are to be retrieved from long datatypes
ovrimos_num_fields — Returns the number of columns
ovrimos_num_rows — Returns the number of rows affected by update operations
ovrimos_prepare — Prepares an SQL statement
ovrimos_result_all — Prints the whole result set as an HTML table
ovrimos_result — Retrieves the output column
ovrimos_rollback — Rolls back the transaction
Předcházející | Nahoru | Další
output_reset_rewrite_vars | Domů | ovrimos_close


ovrimos_close

(PHP 4 >= 4.0.3, PHP 5 <= 5.0.5)

ovrimos_close — Closes the connection to ovrimos

Popis

void ovrimos_close ( int $connection )

Closes the specified connection to Ovrimos. This has the effect of rolling back uncommitted transactions.

Seznam parametrů

connection

The Ovrimos connection identifier, returned by ovrimos_connect().

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

ovrimos_connect()

Předcházející | Nahoru | Další
CXVI. Ovrimos SQL Functions | Domů | ovrimos_commit


ovrimos_commit

(PHP 4 >= 4.0.3, PHP 5 <= 5.0.5)

ovrimos_commit — Commits the transaction

Popis

bool ovrimos_commit ( int $connection_id )

Commits the transaction.

Seznam parametrů

connection_id

The Ovrimos connection identifier, returned by ovrimos_connect().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ovrimos_rollback()

Předcházející | Nahoru | Další
ovrimos_close | Domů | ovrimos_connect


ovrimos_connect

(PHP 4 >= 4.0.3, PHP 5 <= 5.0.5)

ovrimos_connect — Connect to the specified database

Popis

int ovrimos_connect ( string $host, string $dborport, string $user, string $password )

Connects to the specified database.

Seznam parametrů

host

A host name or IP address.

dborport

Either a database name, or the port number to connect to.

user

The user name.

password

Password associated with user.

Návratové hodnoty

Returns a connection identifier (greater than 0) on success, or 0 on failure.

Příklady

Příklad 1497. ovrimos_connect() Example

<?php
$conn = ovrimos_connect("server.example.com", "8001", "admin", "password");
if ($conn != 0) {
    echo "Connection ok!";
    $res = ovrimos_exec($conn, "select table_id, table_name from sys.tables");
    if ($res != 0) {
        echo "Statement ok!";
        ovrimos_result_all($res);
        ovrimos_free_result($res);
    }
    ovrimos_close($conn);
}
?>

Viz také

ovrimos_close()

Předcházející | Nahoru | Další
ovrimos_commit | Domů | ovrimos_cursor


ovrimos_cursor

(PHP 4 >= 4.0.3, PHP 5 <= 5.0.5)

ovrimos_cursor — Returns the name of the cursor

Popis

string ovrimos_cursor ( int $result_id )

Gets the name of the cursor. Useful when wishing to perform positioned updates or deletes.

Seznam parametrů

result_id

A result identifier, returned by ovrimos_execute() or ovrimos_exec().

Návratové hodnoty

Returns the name as a string, or FALSE on error.

Předcházející | Nahoru | Další
ovrimos_connect | Domů | ovrimos_exec


ovrimos_exec

(PHP 4 >= 4.0.3, PHP 5 <= 5.0.5)

ovrimos_exec — Executes an SQL statement

Popis

int ovrimos_exec ( int $connection_id, string $query )

Executes an SQL statement (query or update) and returns a result identifier.

Seznam parametrů

connection_id

The Ovrimos connection identifier, returned by ovrimos_connect().

query

The SQL statement. Evidently, it should not contain parameters. Use ovrimos_prepare() for prepared statements.

Návratové hodnoty

Returns the result identifier as an integer, or FALSE on error.

Viz také

ovrimos_execute()
ovrimos_prepare()

Předcházející | Nahoru | Další
ovrimos_cursor | Domů | ovrimos_execute


ovrimos_execute

(PHP 4 >= 4.0.3, PHP 5 <= 5.0.5)

ovrimos_execute — Executes a prepared SQL statement

Popis

bool ovrimos_execute ( int $result_id [, array $parameters_array] )

Executes a prepared statement.

Seznam parametrů

result_id

An Ovrimos result identifier prepared with ovrimos_prepare().

parameters_array

If the prepared statement contained parameters (question marks in the statement), the correct number of parameters should be passed in an array.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ovrimos_prepare()

Předcházející | Nahoru | Další
ovrimos_exec | Domů | ovrimos_fetch_into


ovrimos_fetch_into

(PHP 4 >= 4.0.3, PHP 5 <= 5.0.5)

ovrimos_fetch_into — Fetches a row from the result set

Popis

bool ovrimos_fetch_into ( int $result_id, array &$result_array [, string $how [, int $rownumber]] )

Fetches a row from the given result set, into result_array.

Seznam parametrů

result_id

A result identifier, returned by ovrimos_execute() or ovrimos_exec().

result_array

You must provide an array by reference. It will be filled with the fetched values.

how

Determines how the rows are fetched. This can be one of the following strings (case is not significant):

Option | Notes
Next | Forward direction from current position. This is the default value.
Prev | Backward direction from current position.
First | Forward direction from the start.
Last | Backward direction from the end.
Absolute | Absolute position from the start. Requires rownumber.

rownumber

The row number, first one is 0. Only needed when how is set to Absolute.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1498. A fetch into example

<?php
$conn=ovrimos_connect("neptune", "8001", "admin", "password");
if ($conn!=0) {
    echo "Connection ok!";
    $res=ovrimos_exec($conn, "select table_id, table_name from sys.tables");
    if ($res != 0) {
        echo "Statement ok!";
        if (ovrimos_fetch_into($res, &$row)) {
            list($table_id, $table_name) = $row;
            echo "table_id=" . $table_id . ", table_name=" . $table_name . "\n";
            if (ovrimos_fetch_into($res, &$row)) {
                list($table_id, $table_name) = $row;
                echo "table_id=" . $table_id . ", table_name=" . $table_name . "\n";
            } else {
                echo "Next: error\n";
            }
        } else {
            echo "First: error\n";
        }
        ovrimos_free_result($res);
    }
    ovrimos_close($conn);
}
?>

Viz také

ovrimos_fetch_row()

Předcházející | Nahoru | Další
ovrimos_execute | Domů | ovrimos_fetch_row


ovrimos_fetch_row

(PHP 4 >= 4.0.3, PHP 5 <= 5.0.5)

ovrimos_fetch_row — Fetches a row from the result set

Popis

bool ovrimos_fetch_row ( int $result_id [, int $how [, int $row_number]] )

Fetches a row from the result set. Column values should be retrieved with other calls.

Seznam parametrů

result_id

A result identifier, returned by ovrimos_execute() or ovrimos_exec().

how

Determines how the rows are fetched. This can be one of the following strings (case is not significant):

Option | Notes
Next | Forward direction from current position. This is the default value.
Prev | Backward direction from current position.
First | Forward direction from the start.
Last | Backward direction from the end.
Absolute | Absolute position from the start. Requires rownumber.

rownumber

The row number, first one is 0. Only needed when how is set to Absolute.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1499. A fetch row example

<?php
$conn = ovrimos_connect("remote.host", "8001", "admin", "password");
if ($conn != 0) {
    echo "Connection ok!";
    $res=ovrimos_exec($conn, "select table_id, table_name from sys.tables");
    if ($res != 0) {
        echo "Statement ok!";
        if (ovrimos_fetch_row($res, "First")) {
            $table_id = ovrimos_result($res, 1);
            $table_name = ovrimos_result($res, 2);
            echo "table_id=" . $table_id . ", table_name=" . $table_name . "\n";
            if (ovrimos_fetch_row($res, "Next")) {
                $table_id = ovrimos_result($res, "table_id");
                $table_name = ovrimos_result($res, "table_name");
                echo "table_id=" . $table_id . ", table_name=" . $table_name . "\n";
            } else {
                echo "Next: error\n";
            }
        } else {
            echo "First: error\n";
        }
        ovrimos_free_result($res);
    }
    ovrimos_close($conn);
}
?>

This will fetch a row and print the result.

Viz také

ovrimos_fetch_into()

Předcházející | Nahoru | Další
ovrimos_fetch_into | Domů | ovrimos_field_len


ovrimos_field_len

(PHP 4 >= 4.0.3, PHP 5 <= 5.0.5)

ovrimos_field_len — Returns the length of the output column

Popis

int ovrimos_field_len ( int $result_id, int $field_number )

Gets the length of the specified output column.

Seznam parametrů

result_id

A result identifier, returned by ovrimos_execute() or ovrimos_exec().

field_number

The field number. Starts at 1.

Návratové hodnoty

Returns the length as an interger, or FALSE on error.

Viz také

ovrimos_field_name()
ovrimos_field_num()
ovrimos_field_type()

Předcházející | Nahoru | Další
ovrimos_fetch_row | Domů | ovrimos_field_name


ovrimos_field_name

(PHP 4 >= 4.0.3, PHP 5 <= 5.0.5)

ovrimos_field_name — Returns the output column name

Popis

string ovrimos_field_name ( int $result_id, int $field_number )

Returns the output column name at the index specified.

Seznam parametrů

result_id

A result identifier, returned by ovrimos_execute() or ovrimos_exec().

field_number

The field number. Starts at 1.

Návratové hodnoty

Returns the field name as a string, or FALSE on error.

Viz také

ovrimos_field_len()
ovrimos_field_num()
ovrimos_field_type()

Předcházející | Nahoru | Další
ovrimos_field_len | Domů | ovrimos_field_num


ovrimos_field_num

(PHP 4 >= 4.0.3, PHP 5 <= 5.0.5)

ovrimos_field_num — Returns the (1-based) index of the output column

Popis

int ovrimos_field_num ( int $result_id, string $field_name )

Returns the 1-based index of the specified output column.

Seznam parametrů

result_id

A result identifier, returned by ovrimos_execute() or ovrimos_exec().

field_name

The field name.

Návratové hodnoty

Returns the index, starting at 1, or FALSE on error.

Viz také

ovrimos_field_len()
ovrimos_field_name()
ovrimos_field_type()

Předcházející | Nahoru | Další
ovrimos_field_name | Domů | ovrimos_field_type


ovrimos_field_type

(PHP 4 >= 4.0.3, PHP 5 <= 5.0.5)

ovrimos_field_type — Returns the type of the output column

Popis

int ovrimos_field_type ( int $result_id, int $field_number )

Returns the type of the output column

Seznam parametrů

result_id

A result identifier, returned by ovrimos_execute() or ovrimos_exec().

field_number

A 1-based index.

Návratové hodnoty

Returns the field type as an integer, or FALSE on error.

Viz také

ovrimos_field_len()
ovrimos_field_name()
ovrimos_field_num()

Předcházející | Nahoru | Další
ovrimos_field_num | Domů | ovrimos_free_result


ovrimos_free_result

(PHP 4 >= 4.0.3, PHP 5 <= 5.0.5)

ovrimos_free_result — Frees the specified result_id

Popis

bool ovrimos_free_result ( int $result_id )

Frees the specified result identifier.

Seznam parametrů

result_id

A result identifier, returned by ovrimos_execute() or ovrimos_exec().

Návratové hodnoty

Returns TRUE.

Předcházející | Nahoru | Další
ovrimos_field_type | Domů | ovrimos_longreadlen


ovrimos_longreadlen

(PHP 4 >= 4.0.3, PHP 5 <= 5.0.5)

ovrimos_longreadlen — Specifies how many bytes are to be retrieved from long datatypes

Popis

bool ovrimos_longreadlen ( int $result_id, int $length )

Specifies how many bytes are to be retrieved from long datatypes (long varchar and long varbinary).

Seznam parametrů

result_id

A result identifier, returned by ovrimos_execute() or ovrimos_exec().

length

The number of bytes to retrieve. Default is zero.

Návratové hodnoty

Returns TRUE.

Předcházející | Nahoru | Další
ovrimos_free_result | Domů | ovrimos_num_fields


ovrimos_num_fields

(PHP 4 >= 4.0.3, PHP 5 <= 5.0.5)

ovrimos_num_fields — Returns the number of columns

Popis

int ovrimos_num_fields ( int $result_id )

Returns the number of columns in the specified result identifier.

Seznam parametrů

result_id

A result identifier, returned by ovrimos_execute() or ovrimos_exec().

Návratové hodnoty

Returns the number of columns as an integer, or FALSE on error.

Viz také

ovrimos_num_rows()

Předcházející | Nahoru | Další
ovrimos_longreadlen | Domů | ovrimos_num_rows


ovrimos_num_rows

(PHP 4 >= 4.0.3, PHP 5 <= 5.0.5)

ovrimos_num_rows — Returns the number of rows affected by update operations

Popis

int ovrimos_num_rows ( int $result_id )

Gets the number of rows affected by update operations.

Seznam parametrů

result_id

A result identifier, returned by ovrimos_execute() or ovrimos_exec().

Návratové hodnoty

Returns the number of rows as an integer, or FALSE on error.

Viz také

ovrimos_num_fields()

Předcházející | Nahoru | Další
ovrimos_num_fields | Domů | ovrimos_prepare


ovrimos_prepare

(PHP 4 >= 4.0.3, PHP 5 <= 5.0.5)

ovrimos_prepare — Prepares an SQL statement

Popis

int ovrimos_prepare ( int $connection_id, string $query )

Prepares an SQL statement.

Seznam parametrů

connection_id

The Ovrimos connection identifier, returned by ovrimos_connect().

query

The SQL statement.

Návratové hodnoty

Returns a result identifier on success, or FALSE on error.

Příklady

Příklad 1500. ovrimos_prepare() Example

<?php
$conn=ovrimos_connect("db_host", "8001", "admin", "password");
if ($conn!=0) {
    echo "Connection ok!";

    // Prepare the statement
    $res=ovrimos_prepare($conn, "select table_id, table_name
                                  from sys.tables where table_id=1");
    if ($res != 0) {
        echo "Prepare ok!";
        // Execute the prepared statement
        if (ovrimos_execute($res)) {
            echo "Execute ok!\n";
            ovrimos_result_all($res);
        } else {
            echo "Execute not ok!";
        }
        ovrimos_free_result($res);
    } else {
        echo "Prepare not ok!\n";
    }
    ovrimos_close($conn);
}
?>

Předcházející | Nahoru | Další
ovrimos_num_rows | Domů | ovrimos_result_all


ovrimos_result_all

(PHP 4 >= 4.0.3, PHP 5 <= 5.0.5)

ovrimos_result_all — Prints the whole result set as an HTML table

Popis

int ovrimos_result_all ( int $result_id [, string $format] )

Prints the whole result set as an HTML table.

Seznam parametrů

result_id

A result identifier, returned by ovrimos_execute() or ovrimos_exec().

format

Optional HTML attributes for the generated table element.

Návratové hodnoty

Returns the number of rows in the generated table.

Příklady

This will execute an SQL statement and print the result in an HTML table.

Příklad 1501. Prepare a statement, execute, and view the result

<?php
$conn = ovrimos_connect("db_host", "8001", "admin", "password");
if ($conn != 0) {
    echo "Connection ok!";
    $res = ovrimos_prepare($conn, "select table_id, table_name
                                    from sys.tables where table_id = 7");
    if ($res != 0) {
        echo "Prepare ok!";
        if (ovrimos_execute($res, array(3))) {
            echo "Execute ok!\n";
            ovrimos_result_all($res);
        } else {
            echo "Execute not ok!";
        }
        ovrimos_free_result($res);
    } else {
        echo "Prepare not ok!\n";
    }
    ovrimos_close($conn);
}
?>

Příklad 1502. ovrimos_result_all() with meta-information

<?php
$conn = ovrimos_connect("db_host", "8001", "admin", "password");
if ($conn != 0) {
    echo "Connection ok!";
    $res = ovrimos_exec($conn, "select table_id, table_name
                                 from sys.tables where table_id = 1");
    if ($res != 0) {
        echo "Statement ok! cursor=" . ovrimos_cursor($res) . "\n";
        $colnb = ovrimos_num_fields($res);
        echo "Output columns=" . $colnb . "\n";
        for ($i=1; $i <= $colnb; $i++) {
            $name = ovrimos_field_name($res, $i);
            $type = ovrimos_field_type($res, $i);
            $len = ovrimos_field_len($res, $i);
            echo "Column " . $i . " name=" . $name . " type=" . $type . " len=" . $len . "\n";
        }
        ovrimos_result_all($res);
        ovrimos_free_result($res);
    }
    ovrimos_close($conn);
}
?>

Předcházející | Nahoru | Další
ovrimos_prepare | Domů | ovrimos_result


ovrimos_result

(PHP 4 >= 4.0.3, PHP 5 <= 5.0.5)

ovrimos_result — Retrieves the output column

Popis

string ovrimos_result ( int $result_id, mixed $field )

Retrieves the output column specified by field.

Seznam parametrů

result_id

A result identifier, returned by ovrimos_execute() or ovrimos_exec().

field

Either as a string with the field name or as an 1-based index.

Návratové hodnoty

Returns the column as a string, FALSE on failure.

Předcházející | Nahoru | Další
ovrimos_result_all | Domů | ovrimos_rollback


ovrimos_rollback

(PHP 4 >= 4.0.3, PHP 5 <= 5.0.5)

ovrimos_rollback — Rolls back the transaction

Popis

bool ovrimos_rollback ( int $connection_id )

Rolls back the transaction.

Seznam parametrů

connection_id

The Ovrimos connection identifier, returned by ovrimos_connect().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ovrimos_commit()

Předcházející | Nahoru | Další
ovrimos_result | Domů | CXVII. Paradox File Access


Funkce pro řízení výstupu

Předcházející VI. Reference funkcí Další

CXV. Funkce pro řízení výstupu

Úvod

Funkce pro řízení výstupu vám umožňují ovládat, kdy se odešle výstup skriptu. To může být užitečné v několika různých situacích, zvláště pokud potřebujete poslat browseru hlavičky poté, co váš skript začal odesílat data. Output Control funkce neovlivňují hlavičky odeslané pomocí funkcí header() nebo setcookie(), pouze funkce jako echo() a data mezi bloky PHP kódu.

Požadavky

Tyto funkce jsou k dispozici jako součást standardního modulu, který je vždy dostupný.

Instalace

K používání těchto funkcí není třeba žádná instalace, jsou součástí jádra PHP.

Konfigurace běhu

Chování těchto funkcí je ovlivněno nastavením parametrů v php.ini.

Tabulka 226. Konfigurační volby řízení výstupu

Název | Výchozí hodnota | Lze změnit
output_buffering | "0" | PHP_INI_PERDIR|PHP_INI_SYSTEM
output_handler | NULL | PHP_INI_PERDIR|PHP_INI_SYSTEM
implicit_flush | "0" | PHP_INI_PERDIR|PHP_INI_SYSTEM

Pro bližší podrobnosti a definici PHP_INI_* konstant viz ini_set().

Zde je stručný popis konfiguračních direktiv.

output_buffering boolean/integer

Řízení výstupu můžete povolit pro všechny soubory nastavením této direktivy na 'On'. Pokud chcete omezit velikost bufferu na určitou hodnotu, můžete jako hodnotu této direktivy místo 'On' použít maximální počet bytů (např. output_buffering=4096).

output_handler string

Celý výstup vašich skriptů můžete přesměrovat do funkce. Například pokud nastavíte output_handler na mb_output_handler(), kódování znaků bude transparentně překódováno do zadaného kódování. Nastavení jakékoliv funkce automaticky zapne řízení výstupu.

Poznámka:
      Nemůžete používat najednou mb_output_handler() s
      ob_inconv_handler() a nemůžete používat najednou
      ob_gzhandler() a
      zlib.output_compression.

implicit_flush boolean

Ve výchozí nastavení je FALSE. Změna na TRUE oznámí PHP, aby oznámilo výstupní vrstvě, aby se automaticky vyprázdnila po každém vypsaném bloku. Je to ekvivalentní volání PHP funkce flush() po každém zavolání funkce print() nebo echo() a po každém HTML bloku.

Když se PHP používá v prostředí webu, zapnutí této volby má závažné výkonnostní důsledky a obecně se doporučuje ho používat pouze pro ladění. Tato hodnota má výchozí nastavení TRUE pokud pracujete pod CLI SAPI.

Viz také ob_implicit_flush().

Typy prostředků

Toto rozšíření nemá definován žádný typ prostředku (resource).

Předdefinované konstanty

Toto rozšíření nemá definovány žádné konstanty.

Příklady

Příklad 1488. Ukázka řízení výstupu

<?php

ob_start();
echo "Ahoj\n";

setcookie ("cookiename", "cookiedata");

ob_end_flush();

?>

Ve výše uvedené ukázce se výstup z echo() uloží ve výstupním bufferu až do volání ob_end_flush(). Mezitím volání setcookie() úspěšně uložilo cookie bez vyvolání chyby. (Normálně nemůžete odeslat do browseru hlavičky poté, co už byla odeslána data.)

Poznámka: Při přechodu z PHP 4.1 (a 4.2) na 4.3 musíte kvůli chybě ve starších verzích zaručit, aby v php.ini byla direktiva implict_flush nastavena na OFF, jinak výstup po zavolání funkce ob_start() nebude skryt z výstupu.

Viz také

Viz také header() a setcookie().

Obsah

flush — Odeslat výstupní buffer
ob_clean — Clean (erase) the output buffer
ob_end_clean — Vyčistit (vymazat) výstupní buffer a vypnout bufferování výstupu
ob_end_flush — Vyprázdnit (odeslat) výstupní buffer a vypnout bufferování výstupu
ob_flush — Flush (send) the output buffer
ob_get_clean — Get current buffer contents and delete current output buffer
ob_get_contents — Vrátit obsah výstupního bufferu
ob_get_flush — Flush the output buffer, return it as a string and turn off output buffering
ob_get_length — Vrátit délku výstupního buffer
ob_get_level — Return the nesting level of the output buffering mechanism
ob_get_status — Get status of output buffers
ob_gzhandler — ob_start callback function to gzip output buffer
ob_implicit_flush — Vypnout/zapnout implicitní flush
ob_list_handlers — List all output handlers in use
ob_start — Zapnout bufferování výstupu
output_add_rewrite_var — Add URL rewriter values
output_reset_rewrite_vars — Reset URL rewriter values
Předcházející | Nahoru | Další
PDO_OCI DSN | Domů | flush


flush

(PHP 4, PHP 5)

flush — Odeslat výstupní buffer

Popis

void flush ( void )

Vyprázdní výstupní buffery PHP a jakéhokoli backendu, který PHP používá (CGI, web server, atd.) Odešle veškerý dosavadní výstup do uživatelova browseru.

Poznámka: flush() nemá žádný účinek na bufferovací schéma vašeho webserveru nebo browseru na klientské straně.

Některé servery, zvláště na Win32, bufferují výstup až do ukončení běhu skriptu bez ohledu na flush(), a až potom odešlou výstup browseru.

Browser může také bufferovat svůj vstup před zobrazením. Například Netscape bufferuje text do té doby než přijme konec řádku nebo začátek tagu, a nezobrazí tabulku, dokud nedostane </table> nejzevnější tabulky.

Předcházející | Nahoru | Další
CXV. Funkce pro řízení výstupu | Domů | ob_clean


ob_clean

(PHP 4 >= 4.2.0, PHP 5)

ob_clean — Clean (erase) the output buffer

Popis

void ob_clean ( void )

This function discards the contents of the output buffer.

This function does not destroy the output buffer like ob_end_clean() does.

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

ob_flush()
ob_end_flush()
ob_end_clean()

Předcházející | Nahoru | Další
flush | Domů | ob_end_clean


ob_end_clean

(PHP 4, PHP 5)

ob_end_clean — Vyčistit (vymazat) výstupní buffer a vypnout bufferování výstupu

Popis

bool ob_end_clean ( void )

Tato funkce odhodí obsah výstupního bufferu a vypne bufferování výstupu.

Viz také ob_start() a ob_end_flush().

Předcházející | Nahoru | Další
ob_clean | Domů | ob_end_flush


ob_end_flush

(PHP 4, PHP 5)

ob_end_flush — Vyprázdnit (odeslat) výstupní buffer a vypnout bufferování výstupu

Popis

bool ob_end_flush ( void )

Tato funkce odešle obsah výstupního bufferu (pokud nějaký je) a vypne
bufferování výstupu. Pokud chcete obsah výstupního bufferu dále zpracovávat,
musíte před ob_end_flush() zavolat
ob_get_contents(), protože obsah bufferu se po
ob_end_flush() odhodí.

Viz také ob_start(),
ob_get_contents() a
ob_end_clean().

Předcházející | Nahoru | Další
ob_end_clean | Domů | ob_flush


ob_flush

(PHP 4 >= 4.2.0, PHP 5)

ob_flush — Flush (send) the output buffer

Popis

void ob_flush ( void )

This function will send the contents of the output buffer (if any). If you want to further process the buffer's contents you have to call ob_get_contents() before ob_flush() as the buffer contents are discarded after ob_flush() is called.

This function does not destroy the output buffer like ob_end_flush() does.

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

ob_get_contents()
ob_clean()
ob_end_flush()
ob_end_clean()

Předcházející | Nahoru | Další
ob_end_flush | Domů | ob_get_clean


ob_get_clean

(PHP 4 >= 4.3.0, PHP 5)

ob_get_clean — Get current buffer contents and delete current output buffer

Popis

string ob_get_clean ( void )

Gets the current buffer contents and delete current output buffer.

ob_get_clean() essentially executes both
ob_get_contents() and
ob_end_clean().

Návratové hodnoty

Returns the contents of the output buffer and end output buffering. If output buffering isn't active then FALSE is returned.

Příklady

Příklad 1489. A simple ob_get_clean() example

<?php

ob_start();

echo "Hello World";

$out = ob_get_clean();
$out = strtolower($out);

var_dump($out);
?>

Výše uvedený příklad vypíše:

string(11) "hello world"

Viz také

ob_get_contents()
ob_start()

Předcházející | Nahoru | Další
ob_flush | Domů | ob_get_contents


ob_get_contents

(PHP 4, PHP 5)

ob_get_contents — Vrátit obsah výstupního bufferu

Popis

string ob_get_contents ( void )

Tato funkce vrátí obsah výstupního bufferu nebo FALSE, pokud bufferování výstupu není aktivováno.

Viz také ob_start() a ob_get_length().

Předcházející | Nahoru | Další
ob_get_clean | Domů | ob_get_flush


ob_get_flush

(PHP 4 >= 4.3.0, PHP 5)

ob_get_flush — Flush the output buffer, return it as a string and turn off output buffering

Popis

string ob_get_flush ( void )

ob_get_flush() flushes the output buffer, return it as a string and turns off output buffering.

Poznámka: This function is similar to ob_end_flush(), except that this function returns the buffer as a string.

Návratové hodnoty

Returns the output buffer or FALSE if no buffering is active.

Příklady

Příklad 1490. ob_get_flush() example

<?php
//using output_buffering=On
print_r(ob_list_handlers());

//save buffer in a file
$buffer = ob_get_flush();
file_put_contents('buffer.txt', $buffer);

print_r(ob_list_handlers());
?>

Výše uvedený příklad vypíše:

Array
(
    [0] => default output handler
)
Array
(
)

Viz také

ob_end_clean()
ob_end_flush()
ob_list_handlers()

Předcházející | Nahoru | Další
ob_get_contents | Domů | ob_get_length


ob_get_length

(PHP 4 >= 4.0.2, PHP 5)

ob_get_length — Vrátit délku výstupního buffer

Popis

int ob_get_length ( void )

Tato funkce vrátí délku obsahu výstupního bufferu nebo This will return the length of the contents in the output buffer, nebo FALSE, pokud bufferování výstupu není aktivováno.

Viz také ob_start() a ob_get_contents().

Předcházející | Nahoru | Další
ob_get_flush | Domů | ob_get_level


ob_get_level

(PHP 4 >= 4.2.0, PHP 5)

ob_get_level — Return the nesting level of the output buffering mechanism

Popis

int ob_get_level ( void )

Returns the nesting level of the output buffering mechanism.

Návratové hodnoty

Returns the level of nested output buffering handlers or zero if output buffering is not active.

Viz také

ob_start()
ob_get_contents()

Předcházející | Nahoru | Další
ob_get_length | Domů | ob_get_status


ob_get_status

(PHP 4 >= 4.2.0, PHP 5)

ob_get_status — Get status of output buffers

Popis

array ob_get_status ( [bool $full_status=FALSE] )

ob_get_status() returns status information on either the top level output buffer or all active output buffer levels if full_status is set to TRUE.

Seznam parametrů

full_status

TRUE to return all active output buffer levels. If FALSE or not set, only the top level output buffer is returned.

Návratové hodnoty

If called without the full_status parameter or with full_status = FALSE a simple array with the following elements is returned:

Array
(
    [level] => 2
    [type] => 0
    [status] => 0
    [name] => URL-Rewriter
    [del] => 1
)
Simple ob_get_status() results
Key: level
Value: Output nesting level
Key: type
Value: PHP_OUTPUT_HANDLER_INTERNAL (0) or PHP_OUTPUT_HANDLER_USER (1)
Key: status
Value: One of PHP_OUTPUT_HANDLER_START (0), PHP_OUTPUT_HANDLER_CONT (1) or PHP_OUTPUT_HANDLER_END (2)
Key: name
Value: Name of active output handler or ' default output handler' if none is set
Key: del
Value: Erase-flag as set by ob_start()

If called with full_status = TRUE an array with one element for each active output buffer level is returned. The output level is used as key of the top level array and each array element itself is another array holding status information on one active output level.

Array
(
    [0] => Array
        (
            [chunk_size] => 0
            [size] => 40960
            [block_size] => 10240
            [type] => 1
            [status] => 0
            [name] => default output handler
            [del] => 1
        )

    [1] => Array
        (
            [chunk_size] => 0
            [size] => 40960
            [block_size] => 10240
            [type] => 0
            [buffer_size] => 0
            [status] => 0
            [name] => URL-Rewriter
            [del] => 1
        )

)

The full output contains these additional elements:

Full ob_get_status() results
Key: chunk_size
Value: Chunk size as set by ob_start()
Key: size
Value: ...
Key: blocksize
Value: ...

Viz také

ob_get_level()
ob_list_handlers()

Předcházející | Nahoru | Další
ob_get_level | Domů | ob_gzhandler


ob_gzhandler

(PHP 4 >= 4.0.4, PHP 5)

ob_gzhandler — ob_start callback function to gzip output buffer

Popis

string ob_gzhandler ( string $buffer, int $mode )

ob_gzhandler() is intended to be used as a callback function for ob_start() to help facilitate sending gz-encoded data to web browsers that support compressed web pages. Before ob_gzhandler() actually sends compressed data, it determines what type of content encoding the browser will accept ("gzip", "deflate" or none at all) and will return its output accordingly. All browsers are supported since it's up to the browser to send the correct header saying that it accepts compressed web pages. If a browser doesn't support compressed pages this function returns FALSE.

Seznam parametrů

buffer

mode

Návratové hodnoty

ChangeLog (záznam změn)

Verze | Popis
4.0.5 | The mode parameter was added.

Příklady

Příklad 1491. ob_gzhandler() example

<?php

ob_start("ob_gzhandler");

?>
<html>
<body>
<p>This should be a compressed page.</p>
</html>
<body>

Poznámky

Poznámka: ob_gzhandler() requires the zlib extension.

Poznámka: You cannot use both ob_gzhandler() and zlib.output_compression. Also note that using zlib.output_compression is preferred over ob_gzhandler().

Viz také

ob_start()
ob_end_flush()

Předcházející | Nahoru | Další
ob_get_status | Domů | ob_implicit_flush


ob_implicit_flush

(PHP 4, PHP 5)

ob_implicit_flush — Vypnout/zapnout implicitní flush

Popis

void ob_implicit_flush ( [int $flag] )

ob_implicit_flush() vypne nebo zapne implicitní flushování (pokud nedostane žádný flag, default je zapnout). Implicitní flushování způsobí flush po každém vygenerování výstupu, takže už nebudou potřeba explicitní volání flush().

Zapnutí implicitního flushování zruší bufferování výstupu, a aktuální obsah výstupních bufferů se odešle jako při volání ob_end_flush().

Viz také flush(),
ob_start() a
ob_end_flush().

Předcházející | Nahoru | Další
ob_gzhandler | Domů | ob_list_handlers


ob_list_handlers

(PHP 4 >= 4.3.0, PHP 5)

ob_list_handlers — List all output handlers in use

Popis

array ob_list_handlers ( void )

Lists all output handlers in use.

Návratové hodnoty

This will return an array with the output handlers in use (if any). If output_buffering is enabled or an anonymous function was used with ob_start(), ob_list_handlers() will return "default output handler".

Příklady

Příklad 1492. ob_list_handlers() example

<?php
//using output_buffering=On
print_r(ob_list_handlers());
ob_end_flush();

ob_start("ob_gzhandler");
print_r(ob_list_handlers());
ob_end_flush();

// anonymous functions
ob_start(create_function('$string', 'return $string;'));
print_r(ob_list_handlers());
ob_end_flush();
?>

Výše uvedený příklad vypíše:

Array
(
    [0] => default output handler
)

Array
(
    [0] => ob_gzhandler
)

Array
(
    [0] => default output handler
)

Viz také

ob_end_clean()
ob_end_flush()
ob_get_flush()
ob_start()

Předcházející | Nahoru | Další
ob_implicit_flush | Domů | ob_start


ob_start

(PHP 4, PHP 5)

ob_start — Zapnout bufferování výstupu

Popis

bool ob_start ( [callback $output_callback [, int $chunk_size [, bool $erase]]] )

Tato funkce zapíná bufferování výstupu. Pokud je bufferování výstupu aktivováno, žádný výstup ze skriptu se neodešle, místo toho se ukládá v interním bufferu.

Obsah tohoto interního bufferu je možno zkopírovat do proměnné typu string
pomocí ob_get_contents(). K odeslání obsahu interního
bufferu použijte ob_end_flush(). Naprotitomu
ob_end_clean() tiše odstraní obsah výstupního bufferu.

Můžete zadat volitelný název callback funkce, která se automaticky zavolá s obsahem bufferu jako argumentem. Tato funkce musí přijímat řetězec a vracet řetězec. Tato funkce bude volána při ob_end_flush() a dostane obsah výstupního bufferu jako svůj argument. Musí vrátit nový výstupní buffer, který se pak vytiskne.

Výstupní buffery se dají stackovat, tzn. můžete zavolat ob_start() zatímco je aktivní další ob_start(). Je potřeba pouze správný počet volání ob_end_flush()(). Pokud je akivních více output callback funkcí, výstup je filtrován postupně přes každou z nich tak jak jsou do sebe vnořené.

Příklad 1493. Ukázka callback funkce

<?php
function c($str) {
  // Druu Chunusun mut dum Kuntrubuß...
  return nl2br(ereg_replace("[aeiou]", "u", $str));
}

function d($str) {
  return strip_tags($str);
}
?>

<?php ob_start("c"); ?>
Drei Chinesen mit dem Kontrabaß...
<?php ob_start("d"); ?>
<h1>..saßen auf der Straße und erzählten sich was...</h1>
<?php ob_end_flush(); ?>
... da kam die Polizei, ja was ist denn das?
<?php ob_end_flush(); ?>

?>

Viz také ob_get_contents(),
ob_end_flush(),
ob_end_clean(), and
ob_implicit_flush()

Předcházející | Nahoru | Další
ob_list_handlers | Domů | output_add_rewrite_var


output_add_rewrite_var

(PHP 4 >= 4.3.0, PHP 5)

output_add_rewrite_var — Add URL rewriter values

Popis

bool output_add_rewrite_var ( string $name, string $value )

This function adds another name/value pair to the URL rewrite mechanism. The name and value will be added to URLs (as GET parameter) and forms (as hidden input fields) the same way as the session ID when transparent URL rewriting is enabled with session.use_trans_sid. Please note that absolute URLs (http://example.com/..) aren't rewritten.

This functions behavior is controlled by the url_rewriter.tags php.ini parameter.

Poznámka: Calling this function will implicitly start output buffering if it is not active already.

Seznam parametrů

name

The variable name.

value

The variable value.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1494. output_add_rewrite_var() example

<?php
output_add_rewrite_var('var', 'value');

// some links
echo '<a href="file.php">link</a>
<a href="http://example.com">link2</a>';

// a form
echo '<form action="script.php" method="post">
<input type="text" name="var2" />
</form>';

print_r(ob_list_handlers());
?>

Výše uvedený příklad vypíše:

<a href="file.php?var=value">link</a>
<a href="http://example.com">link2</a>

<form action="script.php" method="post">
<input type="hidden" name="var" value="value" />
<input type="text" name="var2" />
</form>

Array
(
    [0] => URL-Rewriter
)

Viz také

output_reset_rewrite_vars()
ob_flush()
ob_list_handlers()

Předcházející | Nahoru | Další
ob_start | Domů | output_reset_rewrite_vars


output_reset_rewrite_vars

(PHP 4 >= 4.3.0, PHP 5)

output_reset_rewrite_vars — Reset URL rewriter values

Popis

bool output_reset_rewrite_vars ( void )

This function resets the URL rewriter and removes all rewrite variables previously set by the output_add_rewrite_var() function or the session mechanism (if session.use_trans_sid was set on session_start()).

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1495. output_reset_rewrite_vars() example

<?php
session_start();
output_add_rewrite_var('var', 'value');

echo '<a href="file.php">link</a>';
ob_flush();

output_reset_rewrite_vars();
echo '<a href="file.php">link</a>';
?>

Výše uvedený příklad vypíše:

<a href="file.php?PHPSESSID=xxx&var=value">link</a>
<a href="file.php">link</a>

Viz také

output_add_rewrite_var()
ob_flush()
ob_list_handlers()
session_start()

Předcházející | Nahoru | Další
output_add_rewrite_var | Domů | CXVI. Ovrimos SQL Functions


Object property and method call overloading

Předcházející VI. Reference funkcí Další

CVI. Object property and method call overloading

Úvod

The purpose of this extension is to allow overloading of object property access and method calls. Only one function is defined in this extension, overload() which takes the name of the class that should have this functionality enabled. The class named has to define appropriate methods if it wants to have this functionality: __get(), __set() and __call() respectively for getting/setting a property, or calling a method. This way overloading can be selective. Inside these handler functions the overloading is disabled so you can access object properties normally.

Varování

Toto rozšíření je EXPERIMENTÁLNÍ. Chování tohoto rozšíření, názvy funkcí a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může bez ohlášení změnit. Berte to v úvahu a používejte tento modul na vlastní nebezpečí.

Varování

This extension is not a part of PHP 5. PHP 5 supports __get(), __set() and __call() natively. See the Overloading in PHP 5 page for more information.

Požadavky

Tyto funkce jsou k dispozici jako součást standardního modulu, který je vždy dostupný.

Instalace

In order to use these functions, you must compile PHP with the --enable-overload option. Starting with PHP 4.3.0 this extension is enabled by default. You can disable overload support with --disable--overload.

Verze PHP pro Windows má vestavěnou podporu pro toto rozšíření. K použití těchto funkcí není třeba načítat žádná další rozšíření.

Poznámka: Builtin support for overload is available with PHP 4.3.0.

Konfigurace běhu

Toto rozšíření nemá definováno žádné konfigurační direktivy.

Typy prostředků

Toto rozšíření nemá definován žádný typ prostředku (resource).

Předdefinované konstanty

Toto rozšíření nemá definovány žádné konstanty.

Příklady

Some simple examples on using the overload() function:

Příklad 1433. Overloading a PHP class

<?php

class OO {
    var $a = 111;
    var $elem = array('b' => 9, 'c' => 42);

    // Callback method for getting a property
    function __get($prop_name, &$prop_value)
    {
        if (isset($this->elem[$prop_name])) {
            $prop_value = $this->elem[$prop_name];
            return true;
        } else {
            return false;
        }
    }

    // Callback method for setting a property
    function __set($prop_name, $prop_value)
    {
        $this->elem[$prop_name] = $prop_value;
        return true;
    }
}

// Here we overload the OO object
overload('OO');

$o = new OO;
echo "\$o->a: $o->a\n"; // print: $o->a: 111
echo "\$o->b: $o->b\n"; // print: $o->b: 9
echo "\$o->c: $o->c\n"; // print: $o->c: 42
echo "\$o->d: $o->d\n"; // print: $o->d:

// add a new item to the $elem array in OO
$o->x = 56;

// instantiate stdclass (it is built-in in PHP 4)
// $val is not overloaded!
$val = new stdclass;
$val->prop = 555;

// Set "a" to be an array with the $val object in it
// But __set() will put this in the $elem array
$o->a = array($val);
var_dump($o->a[0]->prop);

?>

Obsah

overload — Enable property and method call overloading for a class
Předcházející | Nahoru | Další
deaggregate | Domů | overload


overload

(PHP 4 >= 4.2.0)

overload — Enable property and method call overloading for a class

Popis

void overload ( string $class_name )

The overload() function will enable property and method call overloading for a class identified by class_name.

Seznam parametrů

class_name

The overloaded class name, as a string

Návratové hodnoty

Nevrací se žádná hodnota.

Příklady

See an example in the introductory section of this part.

Předcházející | Nahoru | Další
CVI. Object property and method call overloading | Domů | CVII. Oracle Functions


Parsekit Functions

Předcházející VI. Reference funkcí Další

CXVIII. Parsekit Functions

Úvod

These functions allow runtime analysis of opcodes compiled from PHP scripts.

Instalace

Toto rozšíření » PECL není přibaleno k PHP.

Informace o instalaci tohoto PECL rozšíření lze najít v kapitole manuálu nazvané Instalace rozšíření PECL. Další informace, jako nové verze, soubory ke stažení, zdrojové soubory, správcovské informace a CHANGELOG, lze najít zde: » http://pecl.php.net/package/parsekit.

Tuto DLL knihovnu pro rozšíření PECL můžete stahovat ze stránky » PHP Downloads nebo z » http://snaps.php.net/.

Konfigurace běhu

Toto rozšíření nemá definováno žádné konfigurační direktivy.

Typy prostředků

Toto rozšíření nemá definován žádný typ prostředku (resource).

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

PARSEKIT_QUIET (int)
Return full detail, but without unnecessary NULL entries.
PARSEKIT_SIMPLE (int)
Return shorthand opcode notation.
PARSEKIT_EXTENDED_VALUE (int)
Opnode Flag
PARSEKIT_RESULT_CONST (int)
Opnode Flag
PARSEKIT_RESULT_EA_TYPE (int)
Opnode Flag
PARSEKIT_RESULT_JMP_ADDR (int)
Opnode Flag
PARSEKIT_RESULT_OPARRAY (int)
Opnode Flag
PARSEKIT_RESULT_OPLINE (int)
Opnode Flag
PARSEKIT_RESULT_VAR (int)
Opnode Flag
PARSEKIT_USAGE_UNKNOWN (int)
Opnode Flag
PARSEKIT_ZEND_INTERNAL_CLASS (int)
Class Type
PARSEKIT_ZEND_USER_CLASS (int)
Class Type
PARSEKIT_ZEND_EVAL_CODE (int)
Function Type
PARSEKIT_ZEND_INTERNAL_FUNCTION (int)
Function Type
PARSEKIT_ZEND_OVERLOADED_FUNCTION (int)
Function Type
PARSEKIT_ZEND_OVERLOADED_FUNCTION_TEMPORARY (int) PHP >= 5.0.0
Function Type
PARSEKIT_ZEND_USER_FUNCTION (int)
Function Type
PARSEKIT_IS_CONST (int)
Node Type
PARSEKIT_IS_TMP_VAR (int)
Node Type
PARSEKIT_IS_UNUSED (int)
Node Type
PARSEKIT_IS_VAR (int)
Node Type
PARSEKIT_ZEND_ADD (int)
Opcode
PARSEKIT_ZEND_ADD_ARRAY_ELEMENT (int)
Opcode
PARSEKIT_ZEND_ADD_CHAR (int)
Opcode
PARSEKIT_ZEND_ADD_INTERFACE (int) PHP >= 5.0.0
Opcode
PARSEKIT_ZEND_ADD_STRING (int)
Opcode
PARSEKIT_ZEND_ADD_VAR (int)
Opcode
PARSEKIT_ZEND_ASSIGN (int)
Opcode
PARSEKIT_ZEND_ASSIGN_ADD (int)
Opcode
PARSEKIT_ZEND_ASSIGN_BW_AND (int)
Opcode
PARSEKIT_ZEND_ASSIGN_BW_OR (int)
Opcode
PARSEKIT_ZEND_ASSIGN_BW_XOR (int)
Opcode
PARSEKIT_ZEND_ASSIGN_CONCAT (int)
Opcode
PARSEKIT_ZEND_ASSIGN_DIM (int) PHP >= 5.0.0
Opcode
PARSEKIT_ZEND_ASSIGN_DIV (int)
Opcode
PARSEKIT_ZEND_ASSIGN_MOD (int)
Opcode
PARSEKIT_ZEND_ASSIGN_MUL (int)
Opcode
PARSEKIT_ZEND_ASSIGN_OBJ (int) PHP >= 5.0.0
Opcode
PARSEKIT_ZEND_ASSIGN_REF (int)
Opcode
PARSEKIT_ZEND_ASSIGN_SL (int)
Opcode
PARSEKIT_ZEND_ASSIGN_SR (int)
Opcode
PARSEKIT_ZEND_ASSIGN_SUB (int)
Opcode
PARSEKIT_ZEND_BEGIN_SILENCE (int)
Opcode
PARSEKIT_ZEND_BOOL (int)
Opcode
PARSEKIT_ZEND_BOOL_NOT (int)
Opcode
PARSEKIT_ZEND_BOOL_XOR (int)
Opcode
PARSEKIT_ZEND_BRK (int)
Opcode
PARSEKIT_ZEND_BW_AND (int)
Opcode
PARSEKIT_ZEND_BW_NOT (int)
Opcode
PARSEKIT_ZEND_BW_OR (int)
Opcode
PARSEKIT_ZEND_BW_XOR (int)
Opcode
PARSEKIT_ZEND_CASE (int)
Opcode
PARSEKIT_ZEND_CAST (int)
Opcode
PARSEKIT_ZEND_CATCH (int) PHP >= 5.0.0
Opcode
PARSEKIT_ZEND_CLONE (int) PHP >= 5.0.0
Opcode
PARSEKIT_ZEND_CONCAT (int)
Opcode
PARSEKIT_ZEND_CONT (int)
Opcode
PARSEKIT_ZEND_DECLARE_CLASS (int) PHP >= 5.0.0
Opcode
PARSEKIT_ZEND_DECLARE_FUNCTION (int) PHP >= 5.0.0
Opcode
PARSEKIT_ZEND_DECLARE_INHERITED_CLASS (int) PHP >= 5.0.0
Opcode
PARSEKIT_ZEND_DIV (int)
Opcode
PARSEKIT_ZEND_DO_FCALL (int)
Opcode
PARSEKIT_ZEND_DO_FCALL_BY_NAME (int)
Opcode
PARSEKIT_ZEND_ECHO (int)
Opcode
PARSEKIT_ZEND_END_SILENCE (int)
Opcode
PARSEKIT_ZEND_EXIT (int)
Opcode
PARSEKIT_ZEND_EXT_FCALL_BEGIN (int)
Opcode
PARSEKIT_ZEND_EXT_FCALL_END (int)
Opcode
PARSEKIT_ZEND_EXT_NOP (int)
Opcode
PARSEKIT_ZEND_EXT_STMT (int)
Opcode
PARSEKIT_ZEND_FETCH_CLASS (int) PHP >= 5.0.0
Opcode
PARSEKIT_ZEND_FETCH_CONSTANT (int)
Opcode
PARSEKIT_ZEND_FETCH_DIM_FUNC_ARG (int)
Opcode
PARSEKIT_ZEND_FETCH_DIM_IS (int)
Opcode
PARSEKIT_ZEND_FETCH_DIM_R (int)
Opcode
PARSEKIT_ZEND_FETCH_DIM_RW (int)
Opcode
PARSEKIT_ZEND_FETCH_DIM_TMP_VAR (int)
Opcode
PARSEKIT_ZEND_FETCH_DIM_UNSET (int)
Opcode
PARSEKIT_ZEND_FETCH_DIM_W (int)
Opcode
PARSEKIT_ZEND_FETCH_FUNC_ARG (int)
Opcode
PARSEKIT_ZEND_FETCH_IS (int)
Opcode
PARSEKIT_ZEND_FETCH_OBJ_FUNC_ARG (int)
Opcode
PARSEKIT_ZEND_FETCH_OBJ_IS (int)
Opcode
PARSEKIT_ZEND_FETCH_OBJ_R (int)
Opcode
PARSEKIT_ZEND_FETCH_OBJ_RW (int)
Opcode
PARSEKIT_ZEND_FETCH_OBJ_UNSET (int)
Opcode
PARSEKIT_ZEND_FETCH_OBJ_W (int)
Opcode
PARSEKIT_ZEND_FETCH_R (int)
Opcode
PARSEKIT_ZEND_FETCH_RW (int)
Opcode
PARSEKIT_ZEND_FETCH_UNSET (int)
Opcode
PARSEKIT_ZEND_FETCH_W (int)
Opcode
PARSEKIT_ZEND_FE_FETCH (int)
Opcode
PARSEKIT_ZEND_FE_RESET (int)
Opcode
PARSEKIT_ZEND_FREE (int)
Opcode
PARSEKIT_ZEND_HANDLE_EXCEPTION (int) PHP >= 5.0.0
Opcode
PARSEKIT_ZEND_IMPORT_CLASS (int) PHP >= 5.0.0
Opcode
PARSEKIT_ZEND_IMPORT_CONST (int) PHP >= 5.0.0
Opcode
PARSEKIT_ZEND_IMPORT_FUNCTION (int) PHP >= 5.0.0
Opcode
PARSEKIT_ZEND_INCLUDE_OR_EVAL (int)
Opcode
PARSEKIT_ZEND_INIT_ARRAY (int)
Opcode
PARSEKIT_ZEND_INIT_CTOR_CALL (int) PHP >= 5.0.0
Opcode
PARSEKIT_ZEND_INIT_FCALL_BY_NAME (int)
Opcode
PARSEKIT_ZEND_INIT_METHOD_CALL (int) PHP >= 5.0.0
Opcode
PARSEKIT_ZEND_INIT_STATIC_METHOD_CALL (int) PHP >= 5.0.0
Opcode
PARSEKIT_ZEND_INIT_STRING (int)
Opcode
PARSEKIT_ZEND_INSTANCEOF (int) PHP >= 5.0.0
Opcode
PARSEKIT_ZEND_ISSET_ISEMPTY (int) PHP < 5.0.0
Opcode
PARSEKIT_ZEND_ISSET_ISEMPTY_DIM_OBJ (int) PHP >= 5.0.0
Opcode
PARSEKIT_ZEND_ISSET_ISEMPTY_PROP_OBJ (int) PHP >= 5.0.0
Opcode
PARSEKIT_ZEND_ISSET_ISEMPTY_VAR (int) PHP >= 5.0.0
Opcode
PARSEKIT_ZEND_IS_EQUAL (int)
Opcode
PARSEKIT_ZEND_IS_IDENTICAL (int)
Opcode
PARSEKIT_ZEND_IS_NOT_EQUAL (int)
Opcode
PARSEKIT_ZEND_IS_NOT_IDENTICAL (int)
Opcode
PARSEKIT_ZEND_IS_SMALLER (int)
Opcode
PARSEKIT_ZEND_IS_SMALLER_OR_EQUAL (int)
Opcode
PARSEKIT_ZEND_JMP (int)
Opcode
PARSEKIT_ZEND_JMPNZ (int)
Opcode
PARSEKIT_ZEND_JMPNZ_EX (int)
Opcode
PARSEKIT_ZEND_JMPZ (int)
Opcode
PARSEKIT_ZEND_JMPZNZ (int)
Opcode
PARSEKIT_ZEND_JMPZ_EX (int)
Opcode
PARSEKIT_ZEND_JMP_NO_CTOR (int)
Opcode
PARSEKIT_ZEND_MOD (int)
Opcode
PARSEKIT_ZEND_MUL (int)
Opcode
PARSEKIT_ZEND_NEW (int)
Opcode
PARSEKIT_ZEND_NOP (int)
Opcode
PARSEKIT_ZEND_OP_DATA (int) PHP >= 5.0.0
Opcode
PARSEKIT_ZEND_POST_DEC (int)
Opcode
PARSEKIT_ZEND_POST_DEC_OBJ (int) PHP >= 5.0.0
Opcode
PARSEKIT_ZEND_POST_INC (int)
Opcode
PARSEKIT_ZEND_POST_INC_OBJ (int) PHP >= 5.0.0
Opcode
PARSEKIT_ZEND_PRE_DEC (int)
Opcode
PARSEKIT_ZEND_PRE_DEC_OBJ (int) PHP >= 5.0.0
Opcode
PARSEKIT_ZEND_PRE_INC (int)
Opcode
PARSEKIT_ZEND_PRE_INC_OBJ (int) PHP >= 5.0.0
Opcode
PARSEKIT_ZEND_PRINT (int)
Opcode
PARSEKIT_ZEND_QM_ASSIGN (int)
Opcode
PARSEKIT_ZEND_RAISE_ABSTRACT_ERROR (int) PHP >= 5.0.0
Opcode
PARSEKIT_ZEND_RECV (int)
Opcode
PARSEKIT_ZEND_RECV_INIT (int)
Opcode
PARSEKIT_ZEND_RETURN (int)
Opcode
PARSEKIT_ZEND_SEND_REF (int)
Opcode
PARSEKIT_ZEND_SEND_VAL (int)
Opcode
PARSEKIT_ZEND_SEND_VAR (int)
Opcode
PARSEKIT_ZEND_SEND_VAR_NO_REF (int)
Opcode
PARSEKIT_ZEND_SL (int)
Opcode
PARSEKIT_ZEND_SR (int)
Opcode
PARSEKIT_ZEND_SUB (int)
Opcode
PARSEKIT_ZEND_SWITCH_FREE (int)
Opcode
PARSEKIT_ZEND_THROW (int) PHP >= 5.0.0
Opcode
PARSEKIT_ZEND_TICKS (int)
Opcode
PARSEKIT_ZEND_UNSET_DIM_OBJ (int)
Opcode
PARSEKIT_ZEND_UNSET_VAR (int)
Opcode
PARSEKIT_ZEND_VERIFY_ABSTRACT_CLASS (int) PHP >= 5.0.0
Opcode

Obsah

parsekit_compile_file — Compile a string of PHP code and return the resulting op array
parsekit_compile_string — Compile a string of PHP code and return the resulting op array
parsekit_func_arginfo — Return information regarding function argument(s)
Předcházející | Nahoru | Další
px_update_record | Domů | parsekit_compile_file


parsekit_compile_file

(PECL parsekit:0.2-1.2)

parsekit_compile_file — Compile a string of PHP code and return the resulting op array

Popis

array parsekit_compile_file ( string $filename [, array &$errors [, int $options]] )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Seznam parametrů

filename

A string containing the name of the file to compile. Similar to the argument to include().

errors

A 2D hash of errors (including fatal errors) encountered during compilation. Returned by reference.

options

One of either PARSEKIT_QUIET or PARSEKIT_SIMPLE. To produce varying degrees of verbosity in the returned output.

Návratové hodnoty

Returns a complex multi-layer array structure as detailed below.

Příklady

Příklad 1509. parsekit_compile_file() example

<?php
var_dump(parsekit_compile_file('hello_world.php', $errors, PARSEKIT_SIMPLE));
?>

Výše uvedený příklad vypíše:

array(5) {
  [0]=>
  string(37) "ZEND_ECHO UNUSED 'Hello World' UNUSED"
  [1]=>
  string(30) "ZEND_RETURN UNUSED NULL UNUSED"
  [2]=>
  string(42) "ZEND_HANDLE_EXCEPTION UNUSED UNUSED UNUSED"
  ["function_table"]=>
  NULL
  ["class_table"]=>
  NULL
}

Viz také

parsekit_compile_string()

Předcházející | Nahoru | Další
CXVIII. Parsekit Functions | Domů | parsekit_compile_string


parsekit_compile_string

(PECL parsekit:0.2-1.2)

parsekit_compile_string — Compile a string of PHP code and return the resulting op array

Popis

array parsekit_compile_string ( string $phpcode [, array &$errors [, int $options]] )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Seznam parametrů

phpcode

A string containing phpcode. Similar to the argument to eval().

errors

A 2D hash of errors (including fatal errors) encountered during compilation. Returned by reference.

options

One of either PARSEKIT_QUIET or PARSEKIT_SIMPLE. To produce varying degrees of verbosity in the returned output.

Návratové hodnoty

Returns a complex multi-layer array structure as detailed below.

Příklady

Příklad 1510. parsekit_compile_string() example

<?php
  $ops = parsekit_compile_string('
echo "Foo\n";
', $errors, PARSEKIT_QUIET);

  var_dump($ops);
?>

Výše uvedený příklad vypíše:

array(20) {
  ["type"]=>
  int(4)
  ["type_name"]=>
  string(14) "ZEND_EVAL_CODE"
  ["fn_flags"]=>
  int(0)
  ["num_args"]=>
  int(0)
  ["required_num_args"]=>
  int(0)
  ["pass_rest_by_reference"]=>
  bool(false)
  ["uses_this"]=>
  bool(false)
  ["line_start"]=>
  int(0)
  ["line_end"]=>
  int(0)
  ["return_reference"]=>
  bool(false)
  ["refcount"]=>
  int(1)
  ["last"]=>
  int(3)
  ["size"]=>
  int(3)
  ["T"]=>
  int(0)
  ["last_brk_cont"]=>
  int(0)
  ["current_brk_cont"]=>
  int(-1)
  ["backpatch_count"]=>
  int(0)
  ["done_pass_two"]=>
  bool(true)
  ["filename"]=>
  string(17) "Parsekit Compiler"
  ["opcodes"]=>
  array(3) {
    [8594800]=>
    array(5) {
      ["opcode"]=>
      int(40)
      ["opcode_name"]=>
      string(9) "ZEND_ECHO"
      ["flags"]=>
      int(768)
      ["op1"]=>
      array(3) {
        ["type"]=>
        int(1)
        ["type_name"]=>
        string(8) "IS_CONST"
        ["constant"]=>
        &string(4) "Foo
"
      }
      ["lineno"]=>
      int(2)
    }
    ["859484C"]=>
    array(6) {
      ["opcode"]=>
      int(62)
      ["opcode_name"]=>
      string(11) "ZEND_RETURN"
      ["flags"]=>
      int(16777984)
      ["op1"]=>
      array(3) {
        ["type"]=>
        int(1)
        ["type_name"]=>
        string(8) "IS_CONST"
        ["constant"]=>
        &NULL
      }
      ["extended_value"]=>
      int(0)
      ["lineno"]=>
      int(3)
    }
    [8594898]=>
    array(4) {
      ["opcode"]=>
      int(149)
      ["opcode_name"]=>
      string(21) "ZEND_HANDLE_EXCEPTION"
      ["flags"]=>
      int(0)
      ["lineno"]=>
      int(3)
    }
  }
}

Viz také

parsekit_compile_file()

Předcházející | Nahoru | Další
parsekit_compile_file | Domů | parsekit_func_arginfo


parsekit_func_arginfo

(PECL parsekit:0.3-1.2)

parsekit_func_arginfo — Return information regarding function argument(s)

Popis

array parsekit_func_arginfo ( mixed $function )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Seznam parametrů

function

A string describing a function, or an array describing a class/method.

Návratové hodnoty

Returns an array containing argument information.

Příklady

Příklad 1511. parsekit_func_arginfo() example

<?php
function foo($bar, stdClass $baz, &$bomb, $bling = false) {
}

var_dump(parsekit_func_arginfo('foo'));
?>

Výše uvedený příklad vypíše:

array(4) {
  [0]=>
  array(3) {
    ["name"]=>
    string(3) "bar"
    ["allow_null"]=>
    bool(true)
    ["pass_by_reference"]=>
    bool(false)
  }
  [1]=>
  array(4) {
    ["name"]=>
    string(3) "baz"
    ["class_name"]=>
    string(8) "stdClass"
    ["allow_null"]=>
    bool(false)
    ["pass_by_reference"]=>
    bool(false)
  }
  [2]=>
  array(3) {
    ["name"]=>
    string(4) "bomb"
    ["allow_null"]=>
    bool(true)
    ["pass_by_reference"]=>
    bool(true)
  }
  [3]=>
  array(3) {
    ["name"]=>
    string(5) "bling"
    ["allow_null"]=>
    bool(true)
    ["pass_by_reference"]=>
    bool(false)
  }
}

Předcházející | Nahoru | Další
parsekit_compile_string | Domů | CXIX. Process Control Functions


PDF funkce

Předcházející VI. Reference funkcí Další

CXXI. PDF funkce

Úvod

PDF funkce v PHP mohou vytvořit PDF soubory s využitím knihovny PDFlib vytvořené » Thomasem Merzem.

Dokumentace této sekce je myšlena pouze jako přehled dostupných funkcí v knihovně PDFlib a neměla by být považována za vyčerpávající přehled. Prosím konzultujte dokumentaci obsaženou v distribuci PDFlib pro úplné a detailní vysvětlené každé zde uvedené funkce. Poskytuje velmi dobrý přehled toho, co PDFlib dokáže a obsahuje nejčerstvější dokumentaci ke všem funkcím.

Většina funkcí pdflib a příslušného PHP modulu má stejné jméno. Argumenty jsou také identické. Pokud chcete tento modul využívat opravdu efektivně, měli byste chápat také některé z konceptů PDF nebo Postscriptu. Všechny rozměry a koordináty se udávají v Postscriptových bodech. Obecně je 72 PostScriptových bodů na palec, ale závisí to na výstupním rozlišení. Věnujte prosím pozornost dokumentaci pdflib, která je součástí distribuce zdrojového kódu, pro bližší vysvětlení použitého souřadnicového systému.

Vemte prosím na vědomí, že většina PDF funkcí vyžaduje pdfdoc jako první parametr. Viz příklady níže pro bližší vysvětlení.

Poznámka: Pokud se zajímáté o alternativní volně dostupné PDF generátory, které nepotřebují externí PDF knihovny, podívejte se na tuto související FAQ.

Požadavky

PDFlib lze stáhnout na » http://www.pdflib.com/products/pdflib-family/, ale vyžaduje, abyste zakoupili licenci pro komerční použití. Pro zkompilování tohoto rozšíření jsou potřeba knihovny » JPEG a » TIFF.

Problémy se starými verzemi PDFlib

Žádná verze PHP 4 od data 9. března 2000 nepodporuje podflib starší než 3.0.

PDFlib 3.0 a vyšší je podporováno PHP 3.0.19 a vyšší.

Instalace

Abyste mohli tyto funkce používat, musíte PHP zkompilovat s volbou --with-pdflib[=DIR]. DIR je základní instalační adresář PDFlib, výchozí hodnota je /usr/local. Navíc můžete určit knihovny jpeg, tiff a png, které má PDFlib používat, což je volitelné v PDFlib 4.x. Pokud tak chcete učinit, přidejte volby configure --with-jpeg-dir[=DIR] --with-png-dir[=DIR] --with-tiff-dir[=DIR].

Od pdflib 3.0 by se pdflib měla konfigurovat s volbou --enable-shared-pdflib.

Konfigurace běhu

Toto rozšíření nemá definováno žádné konfigurační direktivy.

Zmatek se starými verzemi PDFlib

Od PHP 4.0.5 je PHP rozšíření oficiálně podporováno společností PDFlib GmbH. To znamená, že všechny funkce popsané v PDFlib manuálu (V3.00 nebo vyšší) jsou podporovány v PHP 4 s přesně stejným významem a stejnými parametry. Oproti manuálu PDFlib se mohou lišit pouze návratové hodnoty, protože byla převzata konvence PHP pro vracení FALSE was adopted. Z důvodu kompatibility toto rozšíření PDFlib stále podporuje staré funkce, ale tyto by měly být nahrazeny jejich novějšími verzemi. PDFlib GmbH nepomáhá s řešením žádných problémů plynoucích z používání těchto zastaralých funkcí.

Tabulka 238. Zastaralé funkce a jejich náhrady

Stará funkce | Náhrada
pdf_put_image() | Není potřeba.
pdf_execute_image() | Není potřeba.
pdf_get_annotation() | pdf_get_bookmark() se stejnými parametry.
pdf_get_font() | pdf_get_value() s "font" jako druhý argument.
pdf_get_fontsize() | pdf_get_value() s "fontsize" jako druhý argument.
pdf_get_fontname() | pdf_get_parameter() s "fontname" jako druhý argument.
pdf_set_info_creator() | pdf_set_info() s "Creator" jako druhý argument.
pdf_set_info_title() | pdf_set_info() s "Title" jako druhý argument.
pdf_set_info_subject() | pdf_set_info() s "Subject" jako druhý argument.
pdf_set_info_author() | pdf_set_info() s "Author" jako druhý argument.
pdf_set_info_keywords() | pdf_set_info() s "Keywords" jako druhý argument.
pdf_set_leading() | pdf_set_value() s "leading" jako druhý argument.
pdf_set_text_rendering() | pdf_set_value() s "textrendering" jako druhý argument.
pdf_set_text_rise() | pdf_set_value() s "textrise" jako druhý argument.
pdf_set_horiz_scaling() | pdf_set_value() s "horizscaling" jako druhý argument.
pdf_set_text_matrix() | neexistuje
pdf_set_char_spacing() | pdf_set_value() s "charspacing" jako druhý argument.
pdf_set_word_spacing() | pdf_set_value() s "wordspacing" jako druhý argument.
pdf_set_transition() | pdf_set_parameter() s "transition" jako druhý argument.
pdf_open() | pdf_new() plus následné zavolání pdf_open_file()
pdf_set_font() | pdf_findfont() plus následné zavolání pdf_setfont()
pdf_set_duration() | pdf_set_value() s "duration" jako druhý argument.
pdf_open_gif() | pdf_open_image_file() s "gif" jako druhý argument.
pdf_open_jpeg() | pdf_open_image_file() s "jpeg" jako druhý argument.
pdf_open_tiff() | pdf_open_image_file() s "tiff" jako druhý argument.
pdf_open_png() | pdf_open_image_file() s "png" jako druhý argument.
pdf_get_image_width() | pdf_get_value() s "imagewidth" jako druhý argument a obrázkem jako třetí argument.
pdf_get_image_height() | pdf_get_value() s "imageheight" jako druhý argument a obrázkem jako třetí argument.

Příklady

Většina funkcí se používá docela snadno. Nejtěžší je zřejmě vůbec nějaký jednoduchý PDF dokument vůbec vytvořit. Následující ukázka by měla pomoci začít. Vytvoří soubor test.pdf s jednou stránkou. Tato stránka obsahuje text "Times Roman outlined" napsaný 30ti bodovým obrysem. Text je také podtržený.

Příklad 1537. Tvorba PDF dokumentu s pdflib

<?php
$pdf = pdf_new();
pdf_open_file($pdf, "test.pdf");
pdf_set_info($pdf, "Author", "Uwe Steinmann");
pdf_set_info($pdf, "Title", "Test for PHP wrapper of PDFlib 2.0");
pdf_set_info($pdf, "Creator", "See Author");
pdf_set_info($pdf, "Subject", "Testing");
pdf_begin_page($pdf, 595, 842);
pdf_add_outline($pdf, "Page 1");
$font = pdf_findfont($pdf, "Times New Roman", "winansi", 1);
pdf_setfont($pdf, $font, 10);
pdf_set_value($pdf, "textrendering", 1);
pdf_show_xy($pdf, "Times Roman outlined", 50, 750);
pdf_moveto($pdf, 50, 740);
pdf_lineto($pdf, 330, 740);
pdf_stroke($pdf);
pdf_end_page($pdf);
pdf_close($pdf);
pdf_delete($pdf);
echo "<A HREF=getpdf.php>finished</A>";
?>

Skript getpdf.php pouze vrátí vytvořený pdf dokument.

Příklad 1538. Vrátit připravené PDF

<?php
$len = filesize($filename);
header("Content-type: application/pdf");
header("Content-Length: $len");
header("Content-Disposition: inline; filename=foo.pdf");
readfile($filename);
?>

Distribuce pdflib obsahuje rozsáhlejší ukázku, která obsahuje sérii stránek s analogovými hodinami. Tato ukázka převedená do PHP vypadá takto (stejnou ukázku najdete v dokumentaci k clibpdf modulu):

Příklad 1539. pdfclock ukázka z pdflib distribuce

<?php
$radius = 200;
$margin = 20;
$pagecount = 10;

$pdf = pdf_new();

if (!pdf_open_file($pdf, "")) {
    print error;
    exit;
};

pdf_set_parameter($pdf, "warning", "true");

pdf_set_info($pdf, "Creator", "pdf_clock.php");
pdf_set_info($pdf, "Author", "Uwe Steinmann");
pdf_set_info($pdf, "Title", "Analog Clock");

while($pagecount-- > 0) {
    pdf_begin_page($pdf, 2 * ($radius + $margin), 2 * ($radius + $margin));

    pdf_set_parameter($pdf, "transition", "wipe");
    pdf_set_value($pdf, "duration", 0.5);

    pdf_translate($pdf, $radius + $margin, $radius + $margin);
    pdf_save($pdf);
    pdf_setrgbcolor($pdf, 0.0, 0.0, 1.0);

    /* minute strokes */
    pdf_setlinewidth($pdf, 2.0);
    for ($alpha = 0; $alpha < 360; $alpha += 6) {
        pdf_rotate($pdf, 6.0);
        pdf_moveto($pdf, $radius, 0.0);
        pdf_lineto($pdf, $radius-$margin/3, 0.0);
        pdf_stroke($pdf);
    }

    pdf_restore($pdf);
    pdf_save($pdf);

    /* 5 minute strokes */
    pdf_setlinewidth($pdf, 3.0);
    for ($alpha = 0; $alpha < 360; $alpha += 30) {
        pdf_rotate($pdf, 30.0);
        pdf_moveto($pdf, $radius, 0.0);
        pdf_lineto($pdf, $radius-$margin, 0.0);
        pdf_stroke($pdf);
    }

    $ltime = getdate();

    /* draw hour hand */
    pdf_save($pdf);
    pdf_rotate($pdf,-(($ltime['minutes']/60.0)+$ltime['hours']-3.0)*30.0);
    pdf_moveto($pdf, -$radius/10, -$radius/20);
    pdf_lineto($pdf, $radius/2, 0.0);
    pdf_lineto($pdf, -$radius/10, $radius/20);
    pdf_closepath($pdf);
    pdf_fill($pdf);
    pdf_restore($pdf);

    /* draw minute hand */
    pdf_save($pdf);
    pdf_rotate($pdf,-(($ltime['seconds']/60.0)+$ltime['minutes']-15.0)*6.0);
    pdf_moveto($pdf, -$radius/10, -$radius/20);
    pdf_lineto($pdf, $radius * 0.8, 0.0);
    pdf_lineto($pdf, -$radius/10, $radius/20);
    pdf_closepath($pdf);
    pdf_fill($pdf);
    pdf_restore($pdf);

    /* draw second hand */
    pdf_setrgbcolor($pdf, 1.0, 0.0, 0.0);
    pdf_setlinewidth($pdf, 2);
    pdf_save($pdf);
    pdf_rotate($pdf, -(($ltime['seconds'] - 15.0) * 6.0));
    pdf_moveto($pdf, -$radius/5, 0.0);
    pdf_lineto($pdf, $radius, 0.0);
    pdf_stroke($pdf);
    pdf_restore($pdf);

    /* draw little circle at center */
    pdf_circle($pdf, 0, 0, $radius/30);
    pdf_fill($pdf);

    pdf_restore($pdf);

    pdf_end_page($pdf);

    # to see some difference
    sleep(1);
}

pdf_close($pdf);

$buf = pdf_get_buffer($pdf);
$len = strlen($buf);

header("Content-type: application/pdf");
header("Content-Length: $len");
header("Content-Disposition: inline; filename=foo.pdf");
print $buf;

pdf_delete($pdf);
?>

Viz také

Poznámka: Existuje další PHP modul na tvorbu PDF dokumentů, založený na ClibPDF od firmy » FastIO. Detaily viz ClibPDF funkce. Má mírně jinou API.

Obsah

PDF_activate_item — Activate structure element or other content item
PDF_add_annotation — Add annotation [deprecated]
PDF_add_bookmark — Add bookmark for current page [deprecated]
PDF_add_launchlink — Add launch annotation for current page [deprecated]
PDF_add_locallink — Add link annotation for current page [deprecated]
PDF_add_nameddest — Create named destination
PDF_add_note — Set annotation for current page [deprecated]
PDF_add_outline — Add bookmark for current page [deprecated]
PDF_add_pdflink — Add file link annotation for current page [deprecated]
PDF_add_table_cell — Add a cell to a new or existing table
PDF_add_textflow — Create Textflow or add text to existing Textflow
PDF_add_thumbnail — Add thumbnail for current page
PDF_add_weblink — Add weblink for current page [deprecated]
PDF_arc — Draw a counterclockwise circular arc segment
PDF_arcn — Draw a clockwise circular arc segment
PDF_attach_file — Add file attachment for current page [deprecated]
PDF_begin_document — Create new PDF file
PDF_begin_font — Start a Type 3 font definition
PDF_begin_glyph — Start glyph definition for Type 3 font
PDF_begin_item — Open structure element or other content item
PDF_begin_layer — Start layer
PDF_begin_page_ext — Start new page
pdf_begin_page — Začít novou stranu
PDF_begin_pattern — Start pattern definition
PDF_begin_template_ext — Start template definition
PDF_begin_template — Start template definition [deprecated]
PDF_circle — Draw a circle
PDF_clip — Clip to current path
PDF_close_image — Close image
PDF_close_pdi_page — Close the page handle
PDF_close_pdi — Close the input PDF document [deprecated]
pdf_close — Zavřít PDF dokument
PDF_closepath_fill_stroke — Close, fill and stroke current path
PDF_closepath_stroke — Close and stroke path
PDF_closepath — Close current path
PDF_concat — Concatenate a matrix to the CTM
PDF_continue_text — Output text in next line
PDF_create_3dview — Create 3D view
PDF_create_action — Create action for objects or events
PDF_create_annotation — Create rectangular annotation
PDF_create_bookmark — Create bookmark
PDF_create_field — Create form field
PDF_create_fieldgroup — Create form field group
PDF_create_gstate — Create graphics state object
PDF_create_pvf — Create PDFlib virtual file
PDF_create_textflow — Create textflow object
PDF_curveto — Draw Bezier curve
PDF_define_layer — Create layer definition
PDF_delete_pvf — Delete PDFlib virtual file
PDF_delete_table — Delete table object
PDF_delete_textflow — Delete textflow object
PDF_delete — Delete PDFlib object
PDF_encoding_set_char — Add glyph name and/or Unicode value
PDF_end_document — Close PDF file
PDF_end_font — Terminate Type 3 font definition
PDF_end_glyph — Terminate glyph definition for Type 3 font
PDF_end_item — Close structure element or other content item
PDF_end_layer — Deactivate all active layers
PDF_end_page_ext — Finish page
pdf_end_page — Ukončit stranu
PDF_end_pattern — Finish pattern
PDF_end_template — Finish template
PDF_endpath — End current path
PDF_fill_imageblock — Fill image block with variable data
PDF_fill_pdfblock — Fill PDF block with variable data
PDF_fill_stroke — Fill and stroke path
PDF_fill_textblock — Fill text block with variable data
PDF_fill — Fill current path
PDF_findfont — Prepare font for later use [deprecated]
PDF_fit_image — Place image or template
PDF_fit_pdi_page — Place imported PDF page
PDF_fit_table — Place table on page
PDF_fit_textflow — Format textflow in rectangular area
PDF_fit_textline — Place single line of text
PDF_get_apiname — Get name of unsuccessfull API function
PDF_get_buffer — Get PDF output buffer
PDF_get_errmsg — Get error text
PDF_get_errnum — Get error number
PDF_get_font — Get font [deprecated]
PDF_get_fontname — Get font name [deprecated]
PDF_get_fontsize — Font handling [deprecated]
PDF_get_image_height — Get image height [deprecated]
PDF_get_image_width — Get image width [deprecated]
PDF_get_majorversion — Get major version number [deprecated]
PDF_get_minorversion — Get minor version number [deprecated]
PDF_get_parameter — Get string parameter
PDF_get_pdi_parameter — Get PDI string parameter [deprecated]
PDF_get_pdi_value — Get PDI numerical parameter [deprecated]
PDF_get_value — Get numerical parameter
PDF_info_font — Query detailed information about a loaded font
PDF_info_matchbox — Query matchbox information
PDF_info_table — Retrieve table information
PDF_info_textflow — Query textflow state
PDF_info_textline — Perform textline formatting and query metrics
PDF_initgraphics — Reset graphic state
PDF_lineto — Draw a line
PDF_load_3ddata — Load 3D model
PDF_load_font — Search and prepare font
PDF_load_iccprofile — Search and prepare ICC profile
PDF_load_image — Open image file
PDF_makespotcolor — Make spot color
PDF_moveto — Set current point
PDF_new — Create PDFlib object
PDF_open_ccitt — Open raw CCITT image [deprecated]
PDF_open_file — Create PDF file [deprecated]
PDF_open_gif — Open GIF image [deprecated]
PDF_open_image_file — Read image from file [deprecated]
PDF_open_image — Use image data [deprecated]
PDF_open_jpeg — Open JPEG image [deprecated]
PDF_open_memory_image — Open image created with PHP's image functions [not supported]
PDF_open_pdi_page — Prepare a page
PDF_open_pdi — Open PDF file [deprecated]
PDF_open_tiff — Open TIFF image [deprecated]
PDF_pcos_get_number — Get value of pCOS path with type number or boolean
PDF_pcos_get_stream — Get contents of pCOS path with type stream, fstream, or string
PDF_pcos_get_string — Get value of pCOS path with type name, string, or boolean
PDF_place_image — Place image on the page [deprecated]
PDF_place_pdi_page — Place PDF page [deprecated]
PDF_process_pdi — Process imported PDF document
PDF_rect — Draw rectangle
PDF_restore — Restore graphics state
PDF_resume_page — Resume page
PDF_rotate — Rotate coordinate system
PDF_save — Save graphics state
PDF_scale — Scale coordinate system
PDF_set_border_color — Set border color of annotations [deprecated]
PDF_set_border_dash — Set border dash style of annotations [deprecated]
PDF_set_border_style — Set border style of annotations [deprecated]
PDF_set_char_spacing — Set character spacing [deprecated]
PDF_set_duration — Set duration between pages [deprecated]
PDF_set_gstate — Activate graphics state object
PDF_set_horiz_scaling — Set horizontal text scaling [deprecated]
PDF_set_info_author — Fill the author document info field [deprecated]
PDF_set_info_creator — Fill the creator document info field [deprecated]
PDF_set_info_keywords — Fill the keywords document info field [deprecated]
PDF_set_info_subject — Fill the subject document info field [deprecated]
PDF_set_info_title — Fill the title document info field [deprecated]
pdf_set_info — Vyplnit položku informací o dokumentu
PDF_set_layer_dependency — Define relationships among layers
pdf_set_leading — Nastavit vzdálenost mezi řádky
pdf_set_parameter — Nastavit určité parametry
PDF_set_text_matrix — Set text matrix [deprecated]
PDF_set_text_pos — Set text position
PDF_set_text_rendering — Determine text rendering [deprecated]
PDF_set_text_rise — Set text rise [deprecated]
PDF_set_value — Set numerical parameter
PDF_set_word_spacing — Set spacing between words [deprecated]
PDF_setcolor — Set fill and stroke color
PDF_setdash — Set simple dash pattern
PDF_setdashpattern — Set dash pattern
PDF_setflat — Set flatness
PDF_setfont — Set font
PDF_setgray_fill — Set fill color to gray [deprecated]
PDF_setgray_stroke — Set stroke color to gray [deprecated]
PDF_setgray — Set color to gray [deprecated]
PDF_setlinecap — Set linecap parameter
PDF_setlinejoin — Set linejoin parameter
PDF_setlinewidth — Set line width
PDF_setmatrix — Set current transformation matrix
PDF_setmiterlimit — Set miter limit
PDF_setpolydash — Set complicated dash pattern [deprecated]
PDF_setrgbcolor_fill — Set fill rgb color values [deprecated]
PDF_setrgbcolor_stroke — Set stroke rgb color values [deprecated]
PDF_setrgbcolor — Set fill and stroke rgb color values [deprecated]
PDF_shading_pattern — Define shading pattern
PDF_shading — Define blend
PDF_shfill — Fill area with shading
pdf_show_boxed — Vytisknout text v rámečku
pdf_show_xy — Vytisknout text na určené pozici
pdf_show — Umístit text na aktuální pozici
PDF_skew — Skew the coordinate system
PDF_stringwidth — Return width of text
PDF_stroke — Stroke path
PDF_suspend_page — Suspend page
PDF_translate — Set origin of coordinate system
PDF_utf16_to_utf8 — Convert string from UTF-16 to UTF-8
PDF_utf32_to_utf16 — Convert string from UTF-32 to UTF-16
PDF_utf8_to_utf16 — Convert string from UTF-8 to UTF-16
Předcházející | Nahoru | Další
preg_split | Domů | PDF_activate_item


PDF_add_annotation

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_add_annotation — Add annotation [deprecated]

Popis

This function is deprecated, use PDF_create_annotation() with type=Text instead.

Předcházející | Nahoru | Další
PDF_activate_item | Domů | PDF_add_bookmark


PDF_add_bookmark

(PHP 4 >= 4.0.1, PECL pdflib:1.0-2.1.3)

PDF_add_bookmark — Add bookmark for current page [deprecated]

Popis

This function is deprecated since PDFlib version 6, use PDF_create_bookmark() instead.

Předcházející | Nahoru | Další
PDF_add_annotation | Domů | PDF_add_launchlink


PDF_add_launchlink

(PHP 4 >= 4.0.5, PECL pdflib:1.0-2.1.3)

PDF_add_launchlink — Add launch annotation for current page [deprecated]

Popis

bool PDF_add_launchlink ( resource $pdfdoc, float $llx, float $lly, float $urx, float $ury, string $filename )

Adds a link to a web resource.

This function is deprecated since PDFlib version 6,
use PDF_create_action() with
type=Launch and
PDF_create_annotation() with
type=Link instead.

Předcházející | Nahoru | Další
PDF_add_bookmark | Domů | PDF_add_locallink


PDF_add_locallink

(PHP 4 >= 4.0.5, PECL pdflib:1.0-2.1.3)

PDF_add_locallink — Add link annotation for current page [deprecated]

Popis

bool PDF_add_locallink ( resource $pdfdoc, float $lowerleftx, float $lowerlefty, float $upperrightx, float $upperrighty, int $page, string $dest )

Add a link annotation to a target within the current PDF file. Vrací TRUE při úspěchu, FALSE při selhání.

This function is deprecated since PDFlib version 6, use
PDF_create_action() with type=GoTo
and PDF_create_annotation() with
type=Link instead.

Předcházející | Nahoru | Další
PDF_add_launchlink | Domů | PDF_add_nameddest


PDF_add_note

(PHP 4 >= 4.0.5, PECL pdflib:1.0-2.1.3)

PDF_add_note — Set annotation for current page [deprecated]

Popis

bool PDF_add_note ( resource $pdfdoc, float $llx, float $lly, float $urx, float $ury, string $contents, string $title, string $icon, int $open )

Sets an annotation for the current page. Vrací TRUE při úspěchu, FALSE při selhání.

This function is deprecated since PDFlib version 6, use PDF_create_annotation() with type=Text instead.

Předcházející | Nahoru | Další
PDF_add_nameddest | Domů | PDF_add_outline


PDF_add_outline

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_add_outline — Add bookmark for current page [deprecated]

Popis

This function is deprecated, use PDF_create_bookmark() instead.

Předcházející | Nahoru | Další
PDF_add_note | Domů | PDF_add_pdflink


PDF_add_pdflink

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_add_pdflink — Add file link annotation for current page [deprecated]

Popis

bool PDF_add_pdflink ( resource $pdfdoc, float $bottom_left_x, float $bottom_left_y, float $up_right_x, float $up_right_y, string $filename, int $page, string $dest )

Add a file link annotation to a PDF target. Vrací TRUE při úspěchu, FALSE při selhání.

This function is deprecated since PDFlib version 6, use
PDF_create_action() with
type=GoToR and
PDF_create_annotation() with
type=Link instead.

Předcházející | Nahoru | Další
PDF_add_outline | Domů | PDF_add_table_cell


PDF_add_thumbnail

(PHP 4 >= 4.0.5, PECL pdflib:1.0-2.1.3)

PDF_add_thumbnail — Add thumbnail for current page

Popis

bool PDF_add_thumbnail ( resource $pdfdoc, int $image )

Adds an existing image as thumbnail for the current page. Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
PDF_add_textflow | Domů | PDF_add_weblink


PDF_add_weblink

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_add_weblink — Add weblink for current page [deprecated]

Popis

bool PDF_add_weblink ( resource $pdfdoc, float $lowerleftx, float $lowerlefty, float $upperrightx, float $upperrighty, string $url )

Adds a weblink annotation to a target url on the Web. Vrací TRUE při úspěchu, FALSE při selhání.

This function is deprecated since PDFlib version 6, use
PDF_create_action() with type=URI
and PDF_create_annotation() with
type=Link instead.

Předcházející | Nahoru | Další
PDF_add_thumbnail | Domů | PDF_arc


PDF_arc

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_arc — Draw a counterclockwise circular arc segment

Popis

bool PDF_arc ( resource $p, float $x, float $y, float $r, float $alpha, float $beta )

Adds a counterclockwise circular arc.

Předcházející | Nahoru | Další
PDF_add_weblink | Domů | PDF_arcn


PDF_arcn

(PHP 4 >= 4.0.5, PECL pdflib:1.0-2.1.3)

PDF_arcn — Draw a clockwise circular arc segment

Popis

bool PDF_arcn ( resource $p, float $x, float $y, float $r, float $alpha, float $beta )

Except for the drawing direction, this function behaves exactly like PDF_arc().

Předcházející | Nahoru | Další
PDF_arc | Domů | PDF_attach_file


PDF_attach_file

(PHP 4 >= 4.0.5, PECL pdflib:1.0-2.1.3)

PDF_attach_file — Add file attachment for current page [deprecated]

Popis

bool PDF_attach_file ( resource $pdfdoc, float $llx, float $lly, float $urx, float $ury, string $filename, string $description, string $author, string $mimetype, string $icon )

Adds a file attachment annotation. Vrací TRUE při úspěchu, FALSE při selhání.

This function is deprecated since PDFlib version 6, use PDF_create_annotation() with type=FileAttachment instead.

Předcházející | Nahoru | Další
PDF_arcn | Domů | PDF_begin_document


pdf_begin_page

(PHP 4, PECL pdflib:1.0-2.1.3)

pdf_begin_page — Začít novou stranu

Popis

bool PDF_begin_page ( resource $pdfdoc, float $width, float $height )

Funkce pdf_begin_page() začne novou stránku s výškou height a šířkou width. Pokud chcete vytvořit validní dokument, musíte zavolat tuto funkci a pdf_end_page() přinejmenším jednou.

Viz také pdf_end_page().

Předcházející | Nahoru | Další
PDF_begin_page_ext | Domů | PDF_begin_pattern


PDF_begin_pattern

(PHP 4 >= 4.0.5, PECL pdflib:1.0-2.1.3)

PDF_begin_pattern — Start pattern definition

Popis

int PDF_begin_pattern ( resource $pdfdoc, float $width, float $height, float $xstep, float $ystep, int $painttype )

Starts a new pattern definition.

Předcházející | Nahoru | Další
pdf_begin_page | Domů | PDF_begin_template_ext


PDF_begin_template

(PHP 4 >= 4.0.5, PECL pdflib:1.0-2.1.3)

PDF_begin_template — Start template definition [deprecated]

Popis

int PDF_begin_template ( resource $pdfdoc, float $width, float $height )

Starts a new template definition.

This function is deprecated since PDFlib version 7, use PDF_begin_template_ext() instead.

Předcházející | Nahoru | Další
PDF_begin_template_ext | Domů | PDF_circle


PDF_circle

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_circle — Draw a circle

Popis

bool PDF_circle ( resource $pdfdoc, float $x, float $y, float $r )

Adds a circle. Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
PDF_begin_template | Domů | PDF_clip


PDF_clip

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_clip — Clip to current path

Popis

bool PDF_clip ( resource $p )

Uses the current path as clipping path, and terminate the path. Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
PDF_circle | Domů | PDF_close_image


PDF_close_image

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_close_image — Close image

Popis

bool PDF_close_image ( resource $p, int $image )

Closes an image retrieved with the PDF_open_image() function.

Předcházející | Nahoru | Další
PDF_clip | Domů | PDF_close_pdi_page


PDF_close_pdi_page

(PHP 4 >= 4.0.5, PECL pdflib:1.0-2.1.3)

PDF_close_pdi_page — Close the page handle

Popis

bool PDF_close_pdi_page ( resource $p, int $page )

Closes the page handle, and frees all page-related resources. Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
PDF_close_image | Domů | PDF_close_pdi


PDF_close_pdi

(PHP 4 >= 4.0.5, PECL pdflib:1.0-2.1.3)

PDF_close_pdi — Close the input PDF document [deprecated]

Popis

bool PDF_close_pdi ( resource $p, int $doc )

Closes all open page handles, and closes the input PDF document. Vrací TRUE při úspěchu, FALSE při selhání.

This function is deprecated since PDFlib version 7, use PDF_close_pdi_document() instead.

Předcházející | Nahoru | Další
PDF_close_pdi_page | Domů | pdf_close


pdf_close

(PHP 4, PECL pdflib:1.0-2.1.3)

pdf_close — Zavřít PDF dokument

Popis

bool PDF_close ( resource $p )

Funkce pdf_close() zavře PDF dokument.

Viz také pdf_open(), fclose().

Předcházející | Nahoru | Další
PDF_close_pdi | Domů | PDF_closepath_fill_stroke


PDF_closepath_fill_stroke

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_closepath_fill_stroke — Close, fill and stroke current path

Popis

bool PDF_closepath_fill_stroke ( resource $p )

Closes the path, fills, and strokes it. Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
pdf_close | Domů | PDF_closepath_stroke


PDF_closepath_stroke

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_closepath_stroke — Close and stroke path

Popis

bool PDF_closepath_stroke ( resource $p )

Closes the path, and strokes it. Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
PDF_closepath_fill_stroke | Domů | PDF_closepath


PDF_closepath

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_closepath — Close current path

Popis

bool PDF_closepath ( resource $p )

Closes the current path. Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
PDF_closepath_stroke | Domů | PDF_concat


PDF_concat

(PHP 4 >= 4.0.5, PECL pdflib:1.0-2.1.3)

PDF_concat — Concatenate a matrix to the CTM

Popis

bool PDF_concat ( resource $p, float $a, float $b, float $c, float $d, float $e, float $f )

Concatenates a matrix to the current transformation matrix (CTM). Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
PDF_closepath | Domů | PDF_continue_text


PDF_continue_text

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_continue_text — Output text in next line

Popis

bool PDF_continue_text ( resource $p, string $text )

Prints text at the next line. Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
PDF_concat | Domů | PDF_create_3dview


PDF_curveto

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_curveto — Draw Bezier curve

Popis

bool PDF_curveto ( resource $p, float $x1, float $y1, float $x2, float $y2, float $x3, float $y3 )

Draws a Bezier curve from the current point, using 3 more control points. Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
PDF_create_textflow | Domů | PDF_define_layer


PDF_delete

(PHP 4 >= 4.0.5, PECL pdflib:1.0-2.1.3)

PDF_delete — Delete PDFlib object

Popis

bool PDF_delete ( resource $pdfdoc )

Deletes a PDFlib object, and frees all internal resources. Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
PDF_delete_textflow | Domů | PDF_encoding_set_char


pdf_end_page

(PHP 4, PECL pdflib:1.0-2.1.3)

pdf_end_page — Ukončit stranu

Popis

bool PDF_end_page ( resource $p )

Funkce pdf_end_page() ukončí stranu. Jakmile je strana ukončena, nedá se už upravovat.

Viz také pdf_begin_page().

Předcházející | Nahoru | Další
PDF_end_page_ext | Domů | PDF_end_pattern


PDF_end_pattern

(PHP 4 >= 4.0.5, PECL pdflib:1.0-2.1.3)

PDF_end_pattern — Finish pattern

Popis

bool PDF_end_pattern ( resource $p )

Finishes the pattern definition. Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
pdf_end_page | Domů | PDF_end_template


PDF_end_template

(PHP 4 >= 4.0.5, PECL pdflib:1.0-2.1.3)

PDF_end_template — Finish template

Popis

bool PDF_end_template ( resource $p )

Finishes a template definition. Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
PDF_end_pattern | Domů | PDF_endpath


PDF_endpath

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_endpath — End current path

Popis

bool PDF_endpath ( resource $p )

Ends the current path without filling or stroking it.

Předcházející | Nahoru | Další
PDF_end_template | Domů | PDF_fill_imageblock


PDF_fill_stroke

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_fill_stroke — Fill and stroke path

Popis

bool PDF_fill_stroke ( resource $p )

Fills and strokes the current path with the current fill and stroke color. Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
PDF_fill_pdfblock | Domů | PDF_fill_textblock


PDF_fill

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_fill — Fill current path

Popis

bool PDF_fill ( resource $p )

Fills the interior of the current path with the current fill color. Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
PDF_fill_textblock | Domů | PDF_findfont


PDF_findfont

(PHP 4 >= 4.0.5, PECL pdflib:1.0-2.1.3)

PDF_findfont — Prepare font for later use [deprecated]

Popis

int PDF_findfont ( resource $p, string $fontname, string $encoding, int $embed )

Search for a font and prepare it for later use with PDF_setfont(). The metrics will be loaded, and if embed is nonzero, the font file will be checked, but not yet used. encoding is one of builtin, macroman, winansi, host, a user-defined encoding name or the name of a CMap. Parameter embed is optional before PHP 4.3.5 or with PDFlib less than 5.

This function is deprecated since PDFlib version 5, use PDF_load_font() instead.

Předcházející | Nahoru | Další
PDF_fill | Domů | PDF_fit_image


PDF_get_buffer

(PHP 4 >= 4.0.5, PECL pdflib:1.0-2.1.3)

PDF_get_buffer — Get PDF output buffer

Popis

string PDF_get_buffer ( resource $p )

Fetches the buffer containing the generated PDF data.

Předcházející | Nahoru | Další
PDF_get_apiname | Domů | PDF_get_errmsg


PDF_get_font

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_get_font — Get font [deprecated]

Popis

This function is deprecated since PDFlib version 3, use PDF_get_value() with the parameter font instead.

Předcházející | Nahoru | Další
PDF_get_errnum | Domů | PDF_get_fontname


PDF_get_fontname

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_get_fontname — Get font name [deprecated]

Popis

This function is deprecated since PDFlib version 3, use PDF_get_parameter() with the parameter fontname instead.

Předcházející | Nahoru | Další
PDF_get_font | Domů | PDF_get_fontsize


PDF_get_fontsize

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_get_fontsize — Font handling [deprecated]

Popis

This function is deprecated since PDFlib version 3, use PDF_get_value() with the parameter fontsizeinstead.

Předcházející | Nahoru | Další
PDF_get_fontname | Domů | PDF_get_image_height


PDF_get_image_height

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_get_image_height — Get image height [deprecated]

Popis

This function is deprecated since PDFlib version 3, use PDF_get_value() with the parameter imageheight instead.

Předcházející | Nahoru | Další
PDF_get_fontsize | Domů | PDF_get_image_width


PDF_get_image_width

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_get_image_width — Get image width [deprecated]

Popis

This function is deprecated since PDFlib version 3, use PDF_get_value() with the parameter imagewidth instead.

Předcházející | Nahoru | Další
PDF_get_image_height | Domů | PDF_get_majorversion


PDF_get_majorversion

(PHP 4 >= 4.2.0, PECL pdflib:1.0-2.1.3)

PDF_get_majorversion — Get major version number [deprecated]

Popis

int PDF_get_majorversion ( void )

This function is deprecated since PDFlib version 5, use PDF_get_value() with the parameter major instead.

Předcházející | Nahoru | Další
PDF_get_image_width | Domů | PDF_get_minorversion


PDF_get_minorversion

(PHP 4 >= 4.2.0, PECL pdflib:1.0-2.1.3)

PDF_get_minorversion — Get minor version number [deprecated]

Popis

int PDF_get_minorversion ( void )

Returns the minor version number of the PDFlib version.

This function is deprecated since PDFlib version 5, use PDF_get_value() with the parameter minor instead.

Předcházející | Nahoru | Další
PDF_get_majorversion | Domů | PDF_get_parameter


PDF_get_parameter

(PHP 4 >= 4.0.1, PECL pdflib:1.0-2.1.3)

PDF_get_parameter — Get string parameter

Popis

string PDF_get_parameter ( resource $p, string $key, float $modifier )

Gets the contents of some PDFlib parameter with string type.

Předcházející | Nahoru | Další
PDF_get_minorversion | Domů | PDF_get_pdi_parameter


PDF_get_pdi_parameter

(PHP 4 >= 4.0.5, PECL pdflib:1.0-2.1.3)

PDF_get_pdi_parameter — Get PDI string parameter [deprecated]

Popis

string PDF_get_pdi_parameter ( resource $p, string $key, int $doc, int $page, int $reserved )

Gets the contents of a PDI document parameter with string type.

This function is deprecated since PDFlib version 7, use PDF_pcos_get_string() instead.

Předcházející | Nahoru | Další
PDF_get_parameter | Domů | PDF_get_pdi_value


PDF_get_pdi_value

(PHP 4 >= 4.0.5, PECL pdflib:1.0-2.1.3)

PDF_get_pdi_value — Get PDI numerical parameter [deprecated]

Popis

float PDF_get_pdi_value ( resource $p, string $key, int $doc, int $page, int $reserved )

Gets the contents of a PDI document parameter with numerical type.

This function is deprecated since PDFlib version 7, use PDF_pcos_get_number() instead.

Předcházející | Nahoru | Další
PDF_get_pdi_parameter | Domů | PDF_get_value


PDF_get_value

(PHP 4 >= 4.0.1, PECL pdflib:1.0-2.1.3)

PDF_get_value — Get numerical parameter

Popis

float PDF_get_value ( resource $p, string $key, float $modifier )

Gets the value of some PDFlib parameter with numerical type.

Předcházející | Nahoru | Další
PDF_get_pdi_value | Domů | PDF_info_font


PDF_initgraphics

(PHP 4 >= 4.0.5, PECL pdflib:1.0-2.1.3)

PDF_initgraphics — Reset graphic state

Popis

bool PDF_initgraphics ( resource $p )

Reset all color and graphics state parameters to their defaults. Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
PDF_info_textline | Domů | PDF_lineto


PDF_lineto

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_lineto — Draw a line

Popis

bool PDF_lineto ( resource $p, float $x, float $y )

Draws a line from the current point to another point. Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
PDF_initgraphics | Domů | PDF_load_3ddata


PDF_makespotcolor

(PHP 4 >= 4.0.5, PECL pdflib:1.0-2.1.3)

PDF_makespotcolor — Make spot color

Popis

int PDF_makespotcolor ( resource $p, string $spotname )

Finds a built-in spot color name, or makes a named spot color from the current fill color. Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
PDF_load_image | Domů | PDF_moveto


PDF_moveto

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_moveto — Set current point

Popis

bool PDF_moveto ( resource $p, float $x, float $y )

Sets the current point for graphics output. Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
PDF_makespotcolor | Domů | PDF_new


PDF_new

(PHP 4 >= 4.0.5, PECL pdflib:1.0-2.1.3)

PDF_new — Create PDFlib object

Popis

resource PDF_new ( $ )

Creates a new PDFlib object with default settings.

Předcházející | Nahoru | Další
PDF_moveto | Domů | PDF_open_ccitt


PDF_open_ccitt

(PHP 4 >= 4.0.5, PECL pdflib:1.0-2.1.3)

PDF_open_ccitt — Open raw CCITT image [deprecated]

Popis

int PDF_open_ccitt ( resource $pdfdoc, string $filename, int $width, int $height, int $BitReverse, int $k, int $Blackls1 )

Opens a raw CCITT image.

This function is deprecated since PDFlib version 5, use PDF_load_image() instead.

Předcházející | Nahoru | Další
PDF_new | Domů | PDF_open_file


PDF_open_file

(PHP 4 >= 4.0.5, PECL pdflib:1.0-2.1.3)

PDF_open_file — Create PDF file [deprecated]

Popis

bool PDF_open_file ( resource $p, string $filename )

Creates a new PDF file using the supplied file name. Vrací TRUE při úspěchu, FALSE při selhání.

This function is deprecated since PDFlib version 6, use PDF_begin_document() instead.

Předcházející | Nahoru | Další
PDF_open_ccitt | Domů | PDF_open_gif


PDF_open_gif

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_open_gif — Open GIF image [deprecated]

Popis

This function is deprecated since PDFlib version 3, use PDF_load_image() instead.

Předcházející | Nahoru | Další
PDF_open_file | Domů | PDF_open_image_file


PDF_open_image_file

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_open_image_file — Read image from file [deprecated]

Popis

int PDF_open_image_file ( resource $p, string $imagetype, string $filename, string $stringparam, int $intparam )

Opens an image file.

This function is deprecated since PDFlib version 5, use PDF_load_image() with the colorize, ignoremask, invert, mask, masked, and page options instead.

Předcházející | Nahoru | Další
PDF_open_gif | Domů | PDF_open_image


PDF_open_image

(PHP 4 >= 4.0.5, PECL pdflib:1.0-2.1.3)

PDF_open_image — Use image data [deprecated]

Popis

int PDF_open_image ( resource $p, string $imagetype, string $source, string $data, int $length, int $width, int $height, int $components, int $bpc, string $params )

Uses image data from a variety of data sources.

This function is deprecated since PDFlib version 5, use virtual files and PDF_load_image() instead.

Předcházející | Nahoru | Další
PDF_open_image_file | Domů | PDF_open_jpeg


PDF_open_jpeg

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_open_jpeg — Open JPEG image [deprecated]

Popis

This function is deprecated since PDFlib version 3, use PDF_load_image() instead.

Předcházející | Nahoru | Další
PDF_open_image | Domů | PDF_open_memory_image


PDF_open_memory_image

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_open_memory_image — Open image created with PHP's image functions [not supported]

Popis

int PDF_open_memory_image ( resource $p, resource $image )

This function is not supported by PDFlib GmbH.

Předcházející | Nahoru | Další
PDF_open_jpeg | Domů | PDF_open_pdi_page


PDF_open_pdi_page

(PHP 4 >= 4.0.5, PECL pdflib:1.0-2.1.3)

PDF_open_pdi_page — Prepare a page

Popis

int PDF_open_pdi_page ( resource $p, int $doc, int $pagenumber, string $optlist )

Prepares a page for later use with PDF_fit_pdi_page().

Předcházející | Nahoru | Další
PDF_open_memory_image | Domů | PDF_open_pdi


PDF_open_pdi

(PHP 4 >= 4.0.5, PECL pdflib:1.0-2.1.3)

PDF_open_pdi — Open PDF file [deprecated]

Popis

int PDF_open_pdi ( resource $pdfdoc, string $filename, string $optlist, int $len )

Opens a disk-based or virtual PDF document and prepares it for later use.

This function is deprecated since PDFlib version 7, use PDF_open_pdi_document() instead.

Předcházející | Nahoru | Další
PDF_open_pdi_page | Domů | PDF_open_tiff


PDF_open_tiff

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_open_tiff — Open TIFF image [deprecated]

Popis

This function is deprecated since PDFlib version 3, use PDF_load_image() instead.

Předcházející | Nahoru | Další
PDF_open_pdi | Domů | PDF_pcos_get_number


PDF_place_image

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_place_image — Place image on the page [deprecated]

Popis

bool PDF_place_image ( resource $pdfdoc, int $image, float $x, float $y, float $scale )

Places an image and scales it. Vrací TRUE při úspěchu, FALSE při selhání.

This function is deprecated since PDFlib version 5, use PDF_fit_image() instead.

Předcházející | Nahoru | Další
PDF_pcos_get_string | Domů | PDF_place_pdi_page


PDF_place_pdi_page

(PHP 4 >= 4.0.6, PECL pdflib:1.0-2.1.3)

PDF_place_pdi_page — Place PDF page [deprecated]

Popis

bool PDF_place_pdi_page ( resource $pdfdoc, int $page, float $x, float $y, float $sx, float $sy )

Places a PDF page and scales it. Vrací TRUE při úspěchu, FALSE při selhání.

This function is deprecated since PDFlib version 5, use PDF_fit_pdi_page() instead.

Předcházející | Nahoru | Další
PDF_place_image | Domů | PDF_process_pdi


PDF_rect

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_rect — Draw rectangle

Popis

bool PDF_rect ( resource $p, float $x, float $y, float $width, float $height )

Draws a rectangle. Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
PDF_process_pdi | Domů | PDF_restore


PDF_restore

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_restore — Restore graphics state

Popis

bool PDF_restore ( resource $p )

Restores the most recently saved graphics state. Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
PDF_rect | Domů | PDF_resume_page


PDF_rotate

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_rotate — Rotate coordinate system

Popis

bool PDF_rotate ( resource $p, float $phi )

Rotates the coordinate system. Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
PDF_resume_page | Domů | PDF_save


PDF_save

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_save — Save graphics state

Popis

bool PDF_save ( resource $p )

Saves the current graphics state. Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
PDF_rotate | Domů | PDF_scale


PDF_scale

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_scale — Scale coordinate system

Popis

bool PDF_scale ( resource $p, float $sx, float $sy )

Scales the coordinate system. Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
PDF_save | Domů | PDF_set_border_color


PDF_set_border_color

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_set_border_color — Set border color of annotations [deprecated]

Popis

bool PDF_set_border_color ( resource $p, float $red, float $green, float $blue )

Sets the border color for all kinds of annotations. Vrací TRUE při úspěchu, FALSE při selhání.

This function is deprecated since PDFlib version 6, use the option annotcolor in PDF_create_annotation() instead.

Předcházející | Nahoru | Další
PDF_scale | Domů | PDF_set_border_dash


PDF_set_border_dash

(PHP 4 >= 4.0.1, PECL pdflib:1.0-2.1.3)

PDF_set_border_dash — Set border dash style of annotations [deprecated]

Popis

bool PDF_set_border_dash ( resource $pdfdoc, float $black, float $white )

Sets the border dash style for all kinds of annotations. Vrací TRUE při úspěchu, FALSE při selhání.

This function is deprecated since PDFlib version 6, use the option dasharray in PDF_create_annotation() instead.

Předcházející | Nahoru | Další
PDF_set_border_color | Domů | PDF_set_border_style


PDF_set_border_style

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_set_border_style — Set border style of annotations [deprecated]

Popis

bool PDF_set_border_style ( resource $pdfdoc, string $style, float $width )

Sets the border style for all kinds of annotations. Vrací TRUE při úspěchu, FALSE při selhání.

This function is deprecated since PDFlib version 6, use the options borderstyle and linewidth in PDF_create_annotation() instead.

Předcházející | Nahoru | Další
PDF_set_border_dash | Domů | PDF_set_char_spacing


PDF_set_char_spacing

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_set_char_spacing — Set character spacing [deprecated]

Popis

This function is deprecated since PDFlib version 3, use PDF_set_value() with parameter charspacing instead.

Předcházející | Nahoru | Další
PDF_set_border_style | Domů | PDF_set_duration


PDF_set_duration

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_set_duration — Set duration between pages [deprecated]

Popis

This function is deprecated since PDFlib version 3, use the duration option in PDF_begin_page_ext() or PDF_end_page_ext() instead.

Předcházející | Nahoru | Další
PDF_set_char_spacing | Domů | PDF_set_gstate


PDF_set_horiz_scaling

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_set_horiz_scaling — Set horizontal text scaling [deprecated]

Popis

This function is deprecated since PDFlib version 3, use PDF_set_value() with parameter horizscaling instead.

Předcházející | Nahoru | Další
PDF_set_gstate | Domů | PDF_set_info_author


PDF_set_info_author

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_set_info_author — Fill the author document info field [deprecated]

Popis

This function is deprecated since PDFlib version 3, use PDF_set_info() instead.

Předcházející | Nahoru | Další
PDF_set_horiz_scaling | Domů | PDF_set_info_creator


PDF_set_info_creator

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_set_info_creator — Fill the creator document info field [deprecated]

Popis

This function is deprecated since PDFlib version 3, use PDF_set_info() instead.

Předcházející | Nahoru | Další
PDF_set_info_author | Domů | PDF_set_info_keywords


PDF_set_info_keywords

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_set_info_keywords — Fill the keywords document info field [deprecated]

Popis

This function is deprecated since PDFlib version 3, use PDF_set_info() instead.

Předcházející | Nahoru | Další
PDF_set_info_creator | Domů | PDF_set_info_subject


PDF_set_info_subject

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_set_info_subject — Fill the subject document info field [deprecated]

Popis

This function is deprecated since PDFlib version 3, use PDF_set_info() instead.

Předcházející | Nahoru | Další
PDF_set_info_keywords | Domů | PDF_set_info_title


PDF_set_info_title

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_set_info_title — Fill the title document info field [deprecated]

Popis

This function is deprecated since PDFlib version 3, use PDF_set_info() instead.

Předcházející | Nahoru | Další
PDF_set_info_subject | Domů | pdf_set_info


pdf_set_info

(PHP 4 >= 4.0.1, PECL pdflib:1.0-2.1.3)

pdf_set_info — Vyplnit položku informací o dokumentu

Popis

bool PDF_set_info ( resource $p, string $key, string $value )

Funkce pdf_set_info() vyplní informační pole PDF dokumentu. Možné hodnoty argumentu fieldname jsou 'Subject', 'Title', 'Creator', 'Author', 'Keywords' a jeden uživatelsky definovaný název. Může být volána před začátkem stránky.

Příklad 1540. Zadání informací o dokumentu

<?php
$fd = fopen("test.pdf", "w");
$pdfdoc = pdf_open($fd);
pdf_set_info($pdfdoc, "Author", "Uwe Steinmann");
pdf_set_info($pdfdoc, "Creator", "Uwe Steinmann");
pdf_set_info($pdfdoc, "Title", "Testing Info Fields");
pdf_set_info($pdfdoc, "Subject", "Test");
pdf_set_info($pdfdoc, "Keywords", "Test, Fields");
pdf_set_info($pdfdoc, "CustomField", "What ever makes sense");
pdf_begin_page($pdfdoc, 595, 842);
pdf_end_page($pdfdoc);
pdf_close($pdfdoc);
?>

Poznámka:
      Tato funkce nahrazuje pdf_set_info_keywords(),
              pdf_set_info_title(),
              pdf_set_info_subject(),
              pdf_set_info_creator() a
              pdf_set_info_sybject().

Předcházející | Nahoru | Další
PDF_set_info_title | Domů | PDF_set_layer_dependency


pdf_set_leading

(PHP 4, PECL pdflib:1.0-2.1.3)

pdf_set_leading — Nastavit vzdálenost mezi řádky

Popis

void pdf_set_leading ( int $pdf document, double $distance )

Funkce pdf_set_leading() nastavuje vzdálenost mezi řádky textu. Toto nastavení se použije, pokud se text tvoří pomocí pdf_continue_text().

Viz také pdf_continue_text().

Předcházející | Nahoru | Další
PDF_set_layer_dependency | Domů | pdf_set_parameter


pdf_set_parameter

(PHP 4, PECL pdflib:1.0-2.1.3)

pdf_set_parameter — Nastavit určité parametry

Popis

bool PDF_set_parameter ( resource $p, string $key, string $value )

Funkce pdf_set_parameter() nastaví určité parametry pdflib, které jsou typu string.

Viz také pdf_get_value(),
         pdf_set_value(),
         pdf_get_parameter().

Předcházející | Nahoru | Další
pdf_set_leading | Domů | PDF_set_text_matrix


PDF_set_text_matrix

(PHP 4 <= 4.0.4)

PDF_set_text_matrix — Set text matrix [deprecated]

Popis

This function is deprecated since PDFlib version 3, use PDF_scale(), PDF_translate(), PDF_rotate(), or PDF_skew() instead.

Předcházející | Nahoru | Další
pdf_set_parameter | Domů | PDF_set_text_pos


PDF_set_text_pos

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_set_text_pos — Set text position

Popis

bool PDF_set_text_pos ( resource $p, float $x, float $y )

Sets the position for text output on the page. Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
PDF_set_text_matrix | Domů | PDF_set_text_rendering


PDF_set_text_rendering

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_set_text_rendering — Determine text rendering [deprecated]

Popis

This function is deprecated since PDFlib version 3, use PDF_set_value() with the textrendering parameter instead.

Předcházející | Nahoru | Další
PDF_set_text_pos | Domů | PDF_set_text_rise


PDF_set_text_rise

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_set_text_rise — Set text rise [deprecated]

Popis

This function is deprecated since PDFlib version 3, use PDF_set_value() with the textrise parameter instead.

Předcházející | Nahoru | Další
PDF_set_text_rendering | Domů | PDF_set_value


PDF_set_value

(PHP 4 >= 4.0.1, PECL pdflib:1.0-2.1.3)

PDF_set_value — Set numerical parameter

Popis

bool PDF_set_value ( resource $p, string $key, float $value )

Sets the value of some PDFlib parameter with numerical type. Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
PDF_set_text_rise | Domů | PDF_set_word_spacing


PDF_set_word_spacing

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_set_word_spacing — Set spacing between words [deprecated]

Popis

This function is deprecated since PDFlib version 3, use PDF_set_value() with the wordspacing parameter instead.

Předcházející | Nahoru | Další
PDF_set_value | Domů | PDF_setcolor


PDF_setcolor

(PHP 4 >= 4.0.5, PECL pdflib:1.0-2.1.3)

PDF_setcolor — Set fill and stroke color

Popis

bool PDF_setcolor ( resource $p, string $fstype, string $colorspace, float $c1, float $c2, float $c3, float $c4 )

Sets the current color space and color. Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
PDF_set_word_spacing | Domů | PDF_setdash


PDF_setdash

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_setdash — Set simple dash pattern

Popis

bool PDF_setdash ( resource $pdfdoc, float $b, float $w )

Sets the current dash pattern to b black and w white units. Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
PDF_setcolor | Domů | PDF_setdashpattern


PDF_setflat

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_setflat — Set flatness

Popis

bool PDF_setflat ( resource $pdfdoc, float $flatness )

Sets the flatness parameter. Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
PDF_setdashpattern | Domů | PDF_setfont


PDF_setfont

(PHP 4 >= 4.0.5, PECL pdflib:1.0-2.1.3)

PDF_setfont — Set font

Popis

bool PDF_setfont ( resource $pdfdoc, int $font, float $fontsize )

Sets the current font in the specified size, using a font handle returned by PDF_load_font(). Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
PDF_setflat | Domů | PDF_setgray_fill


PDF_setgray_fill

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_setgray_fill — Set fill color to gray [deprecated]

Popis

bool PDF_setgray_fill ( resource $p, float $g )

Sets the current fill color to a gray value between 0 and 1 inclusive. Vrací TRUE při úspěchu, FALSE při selhání.

This function is deprecated since PDFlib version 4, use PDF_setcolor() instead.

Předcházející | Nahoru | Další
PDF_setfont | Domů | PDF_setgray_stroke


PDF_setgray_stroke

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_setgray_stroke — Set stroke color to gray [deprecated]

Popis

bool PDF_setgray_stroke ( resource $p, float $g )

Sets the current stroke color to a gray value between 0 and 1 inclusive. Vrací TRUE při úspěchu, FALSE při selhání.

This function is deprecated since PDFlib version 4, use PDF_setcolor() instead.

Předcházející | Nahoru | Další
PDF_setgray_fill | Domů | PDF_setgray


PDF_setgray

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_setgray — Set color to gray [deprecated]

Popis

bool PDF_setgray ( resource $p, float $g )

Sets the current fill and stroke color to a gray value between 0 and 1 inclusive. Vrací TRUE při úspěchu, FALSE při selhání.

This function is deprecated since PDFlib version 4, use PDF_setcolor() instead.

Předcházející | Nahoru | Další
PDF_setgray_stroke | Domů | PDF_setlinecap


PDF_setlinecap

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_setlinecap — Set linecap parameter

Popis

bool PDF_setlinecap ( resource $p, int $linecap )

Sets the linecap parameter to control the shape at the end of a path with respect to stroking.

Předcházející | Nahoru | Další
PDF_setgray | Domů | PDF_setlinejoin


PDF_setlinejoin

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_setlinejoin — Set linejoin parameter

Popis

bool PDF_setlinejoin ( resource $p, int $value )

Sets the linejoin parameter to specify the shape at the corners of paths that are stroked. Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
PDF_setlinecap | Domů | PDF_setlinewidth


PDF_setlinewidth

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_setlinewidth — Set line width

Popis

bool PDF_setlinewidth ( resource $p, float $width )

Sets the current line width. Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
PDF_setlinejoin | Domů | PDF_setmatrix


PDF_setmatrix

(PHP 4 >= 4.0.5, PECL pdflib:1.0-2.1.3)

PDF_setmatrix — Set current transformation matrix

Popis

bool PDF_setmatrix ( resource $p, float $a, float $b, float $c, float $d, float $e, float $f )

Explicitly sets the current transformation matrix. Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
PDF_setlinewidth | Domů | PDF_setmiterlimit


PDF_setmiterlimit

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_setmiterlimit — Set miter limit

Popis

bool PDF_setmiterlimit ( resource $pdfdoc, float $miter )

Sets the miter limit.Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
PDF_setmatrix | Domů | PDF_setpolydash


PDF_setpolydash

(PHP 4 >= 4.0.5, PECL pdflib:1.0-2.1.3)

PDF_setpolydash — Set complicated dash pattern [deprecated]

Popis

This function is deprecated since PDFlib version 5, use PDF_setdashpattern() instead.

Předcházející | Nahoru | Další
PDF_setmiterlimit | Domů | PDF_setrgbcolor_fill


PDF_setrgbcolor_fill

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_setrgbcolor_fill — Set fill rgb color values [deprecated]

Popis

bool PDF_setrgbcolor_fill ( resource $p, float $red, float $green, float $blue )

Sets the current fill color to the supplied RGB values. Vrací TRUE při úspěchu, FALSE při selhání.

This function is deprecated since PDFlib version 4, use PDF_setcolor() instead.

Předcházející | Nahoru | Další
PDF_setpolydash | Domů | PDF_setrgbcolor_stroke


PDF_setrgbcolor_stroke

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_setrgbcolor_stroke — Set stroke rgb color values [deprecated]

Popis

bool PDF_setrgbcolor_stroke ( resource $p, float $red, float $green, float $blue )

Sets the current stroke color to the supplied RGB values. Vrací TRUE při úspěchu, FALSE při selhání.

This function is deprecated since PDFlib version 4, use PDF_setcolor() instead.

Předcházející | Nahoru | Další
PDF_setrgbcolor_fill | Domů | PDF_setrgbcolor


PDF_setrgbcolor

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_setrgbcolor — Set fill and stroke rgb color values [deprecated]

Popis

bool PDF_setrgbcolor ( resource $p, float $red, float $green, float $blue )

Sets the current fill and stroke color to the supplied RGB values. Vrací TRUE při úspěchu, FALSE při selhání.

This function is deprecated since PDFlib version 4, use PDF_setcolor() instead.

Předcházející | Nahoru | Další
PDF_setrgbcolor_stroke | Domů | PDF_shading_pattern


pdf_show_boxed

(PHP 4, PECL pdflib:1.0-2.1.3)

pdf_show_boxed — Vytisknout text v rámečku

Popis

int PDF_show_boxed ( resource $p, string $text, float $left, float $top, float $width, float $height, string $mode, string $feature )

Funkce pdf_show_boxed() vytiskne řetězec text v rámečku s levým dolním rohem na (x-coor, y-coor). Rozměry rámečku jsou height x width. Argument mode determines how the text is type set. Pokud jsou width a height nula, mode může být "left", "right" nebo "center". Pokud jsou width nebo height různé od nuly, může být také "justify" nebo "fulljustify".

Pokud má argument feature hodnotu "blind", text se nezobrazí.

Vrací počet znaků které nebyly zpracovány, protože se nevešly do rámečku.

Viz také pdf_show(), pdf_show_xy().

Předcházející | Nahoru | Další
PDF_shfill | Domů | pdf_show_xy


pdf_show_xy

(PHP 4, PECL pdflib:1.0-2.1.3)

pdf_show_xy — Vytisknout text na určené pozici

Popis

bool PDF_show_xy ( resource $p, string $text, float $x, float $y )

Funkce pdf_show_xy() vytiskne řetězec text na pozici (x-coor, y-coor).

Viz také pdf_show(), pdf_show_boxed().

Předcházející | Nahoru | Další
pdf_show_boxed | Domů | pdf_show


pdf_show

(PHP 4, PECL pdflib:1.0-2.1.3)

pdf_show — Umístit text na aktuální pozici

Popis

bool PDF_show ( resource $pdfdoc, string $text )

Funkce pdf_show() umístí řetězec text na současnou pozici s využitím aktuálního fontu.

Viz také pdf_show_xy(),
         pdf_show_boxed(),
         pdf_set_text_pos(),
         pdf_set_font().

Předcházející | Nahoru | Další
pdf_show_xy | Domů | PDF_skew


PDF_skew

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_skew — Skew the coordinate system

Popis

bool PDF_skew ( resource $p, float $alpha, float $beta )

Skews the coordinate system in x and y direction by alpha and beta degrees. Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
pdf_show | Domů | PDF_stringwidth


PDF_stringwidth

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_stringwidth — Return width of text

Popis

float PDF_stringwidth ( resource $p, string $text, int $font, float $fontsize )

Returns the width of text in an arbitrary font.

Předcházející | Nahoru | Další
PDF_skew | Domů | PDF_stroke


PDF_stroke

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_stroke — Stroke path

Popis

bool PDF_stroke ( resource $p )

Strokes the path with the current color and line width, and clear it. Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
PDF_stringwidth | Domů | PDF_suspend_page


PDF_translate

(PHP 4, PECL pdflib:1.0-2.1.3)

PDF_translate — Set origin of coordinate system

Popis

bool PDF_translate ( resource $p, float $tx, float $ty )

Translates the origin of the coordinate system.

Předcházející | Nahoru | Další
PDF_suspend_page | Domů | PDF_utf16_to_utf8


PDO Functions

Předcházející VI. Reference funkcí Další

CXXII. PDO Functions

Úvod

The PHP Data Objects (PDO) extension defines a lightweight, consistent interface for accessing databases in PHP. Each database driver that implements the PDO interface can expose database-specific features as regular extension functions. Note that you cannot perform any database functions using the PDO extension by itself; you must use a database-specific PDO driver to access a database server.

PDO provides a data-access abstraction layer, which means that, regardless of which database you're using, you use the same functions to issue queries and fetch data. PDO does not provide a database abstraction; it doesn't rewrite SQL or emulate missing features. You should use a full-blown abstraction layer if you need that facility.

PDO ships with PHP 5.1, and is available as a PECL extension for PHP 5.0; PDO requires the new OO features in the core of PHP 5, and so will not run with earlier versions of PHP.

Instalace

Postup 2. PHP 5.1 and up on Unix systems

  1. If you're running a PHP 5.1 release, PDO and PDO_SQLITE is included in the distribution; it will be automatically enabled when you run configure. It is recommended that you build PDO as a shared extension, as this will allow you to take advantage of updates that are made available via PECL. The recommended configure line for building PHP with PDO support should enable zlib support (for the pecl installer) as well. You may also need to enable the PDO driver for your database of choice; consult the documentation for database-specific PDO drivers to find out more about that, but note that if you build PDO as a shared extension, you must build the PDO drivers as shared extensions. SQLite extension depends on PDO so if PDO is built as a shared extension, SQLite needs to be built the same way.

./configure --with-zlib --enable-pdo=shared --with-pdo-sqlite=shared --with-sqlite=shared

  2. After installing PDO as a shared module, you must edit your php.ini file so that the PDO extension will be loaded automatically when PHP runs. You will also need to enable any database specific drivers there too; make sure that they are listed after the pdo.so line, as PDO must be initialized before the database-specific extensions can be loaded. If you built PDO and the database-specific extensions statically, you can skip this step.

extension=pdo.so

  3. Having PDO as a shared module will allow you to run pecl upgrade pdo as new versions of PDO are published, without forcing you to rebuild the whole of PHP. Note that if you do this, you also need to upgrade your database specific PDO drivers at the same time.

Postup 3. PHP 5.0.0 and up on Unix systems

  1. PDO is available as a PECL extension from » http://pecl.php.net/package/pdo. Installation can be performed via the pecl tool; this is enabled by default when you configure PHP. You should ensure that PHP was configured --with-zlib in order for pecl to be able to handle the compressed package files.

  2. Run the following command to download, build, and install the latest stable version of PDO:

pecl install pdo

  3. The pecl command automatically installs the PDO module into your PHP extensions directory. To enable the PDO extension on Linux or Unix operating systems, you must add the following line to php.ini:

extension=pdo.so

    For more information about building PECL packages, consult the PECL installation section of the manual.

Postup 4. Windows users running PHP 5.1.0 and up

  1. PDO and all the major drivers ship with PHP as shared extensions, and simply need to be activated by editing the php.ini file:

extension=php_pdo.dll

  2. Next, choose the other database-specific DLL files and either use dl() to load them at runtime, or enable them in php.ini below php_pdo.dll. For example:

extension=php_pdo.dll
extension=php_pdo_firebird.dll
extension=php_pdo_informix.dll
extension=php_pdo_mssql.dll
extension=php_pdo_mysql.dll
extension=php_pdo_oci.dll
extension=php_pdo_oci8.dll
extension=php_pdo_odbc.dll
extension=php_pdo_pgsql.dll
extension=php_pdo_sqlite.dll

    These DLLs should exist in the system's extension_dir. Note that PDO_INFORMIX is only available as a PECL extension.

Konfigurace běhu

Chování těchto funkcí je ovlivněno nastavením parametrů v php.ini.

Tabulka 240. PDO Configuration Options

Name | Default | Changeable | Changelog
pdo.dsn.* |  | php.ini only |

Pro další detaily a definice konstant PHP_INI_*, viz dokumentace k ini_set().

Zde je stručný popis konfiguračních direktiv.

pdo.dsn.* string

Defines DSN alias. See PDO->__construct() for thorough explanation.

PDO Drivers

The following drivers currently implement the PDO interface:

Driver name | Supported databases
PDO_DBLIB | FreeTDS / Microsoft SQL Server / Sybase
PDO_FIREBIRD | Firebird/Interbase 6
PDO_IBM | IBM DB2
PDO_INFORMIX | IBM Informix Dynamic Server
PDO_MYSQL | MySQL 3.x/4.x/5.x
PDO_OCI | Oracle Call Interface
PDO_ODBC | ODBC v3 (IBM DB2, unixODBC and win32 ODBC)
PDO_PGSQL | PostgreSQL
PDO_SQLITE | SQLite 3 and SQLite 2

Connections and Connection management

Connections are established by creating instances of the PDO base class. It doesn't matter which driver you want to use; you always use the PDO class name. The constructor accepts parameters for specifying the database source (known as the DSN) and optionally for the username and password (if any).

Příklad 1541. Connecting to MySQL

<?php
$dbh = new PDO('mysql:host=localhost;dbname=test', $user, $pass);
?>

If there are any connection errors, a PDOException object will be thrown. You may catch the exception if you want to handle the error condition, or you may opt to leave it for an application global exception handler that you set up via set_exception_handler().

Příklad 1542. Handling connection errors

<?php
try {
   $dbh = new PDO('mysql:host=localhost;dbname=test', $user, $pass);
   foreach ($dbh->query('SELECT * from FOO') as $row) {
      print_r($row);
   }
   $dbh = null;
} catch (PDOException $e) {
   print "Error!: " . $e->getMessage() . "<br/>";
   die();
}
?>

Varování

If your application does not catch the exception thrown from the PDO constructor, the default action taken by the zend engine is to terminate the script and display a back trace. This back trace will likely reveal the full database connection details, including the username and password. It is your responsibility to catch this exception, either explicitly (via a catch statement) or implicitly via set_exception_handler().

Upon successful connection to the database, an instance of the PDO class is returned to your script. The connection remains active for the lifetime of that PDO object. To close the connection, you need to destroy the object by ensuring that all remaining references to it are deleted--you do this by assigning NULL to the variable that holds the object. If you don't do this explicitly, PHP will automatically close the connection when your script ends.

Příklad 1543. Closing a connection

<?php
$dbh = new PDO('mysql:host=localhost;dbname=test', $user, $pass);
// use the connection here

// and now we're done; close it
$dbh = null;
?>

Many web applications will benefit from making persistent connections to database servers. Persistent connections are not closed at the end of the script, but are cached and re-used when another script requests a connection using the same credentials. The persistent connection cache allows you to avoid the overhead of establishing a new connection every time a script needs to talk to a database, resulting in a faster web application.

Příklad 1544. Persistent connections

<?php
$dbh = new PDO('mysql:host=localhost;dbname=test', $user, $pass, array(
  PDO::ATTR_PERSISTENT => true
));
?>

Poznámka: If you wish to use persistent connections, you must set PDO::ATTR_PERSISTENT in the array of driver options passed to the PDO constructor. If setting this attribute with PDO->setAttribute() after instantiation of the object, the driver will not use persistent connections.

Poznámka: If you're using the PDO ODBC driver and your ODBC libraries support ODBC Connection Pooling (unixODBC and Windows are two that do; there may be more), then it's recommended that you don't use persistent PDO connections, and instead leave the connection caching to the ODBC Connection Pooling layer. The ODBC Connection Pool is shared with other modules in the process; if PDO is told to cache the connection, then that connection would never be returned to the ODBC connection pool, resulting in additional connections being created to service those other modules.

Transactions and auto-commit

Now that you're connected via PDO, you must understand how PDO manages transactions before you start issuing queries. If you've never encountered transactions before, they offer 4 major features: Atomicity, Consistency, Isolation and Durability (ACID). In layman's terms, any work carried out in a transaction, even if it is carried out in stages, is guaranteed to be applied to the database safely, and without interference from other connections, when it is committed. Transactional work can also be automatically undone at your request (provided you haven't already committed it), which makes error handling in your scripts easier.

Transactions are typically implemented by "saving-up" your batch of changes to be applied all at once; this has the nice side effect of drastically improving the efficiency of those updates. In other words, transactions can make your scripts faster and potentially more robust (you still need to use them correctly to reap that benefit).

Unfortunately, not every database supports transactions, so PDO needs to run in what is known as "auto-commit" mode when you first open the connection. Auto-commit mode means that every query that you run has its own implicit transaction, if the database supports it, or no transaction if the database doesn't support transactions. If you need a transaction, you must use the PDO->beginTransaction() method to initiate one. If the underlying driver does not support transactions, a PDOException will be thrown (regardless of your error handling settings: this is always a serious error condition). Once you are in a transaction, you may use PDO->commit() or PDO->rollBack() to finish it, depending on the success of the code you run during the transaction.

When the script ends or when a connection is about to be closed, if you have an outstanding transaction, PDO will automatically roll it back. This is a safety measure to help avoid inconsistency in the cases where the script terminates unexpectedly--if you didn't explicitly commit the transaction, then it is assumed that something went awry, so the rollback is performed for the safety of your data.

Varování

The automatic rollback only happens if you initiate the transaction via PDO->beginTransaction(). If you manually issue a query that begins a transaction PDO has no way of knowing about it and thus cannot roll it back if something bad happens.

Příklad 1545. Executing a batch in a transaction

In the following sample, let's assume that we are creating a set of entries for a new employee, who has been assigned an ID number of 23. In addition to entering the basic data for that person, we also need to record their salary. It's pretty simple to make two separate updates, but by enclosing them within the PDO->beginTransaction() and PDO->commit() calls, we are guaranteeing that no one else will be able to see those changes until they are complete. If something goes wrong, the catch block rolls back all changes made since the transaction was started, and then prints out an error message.

<?php
try {
  $dbh = new PDO('odbc:SAMPLE', 'db2inst1', 'ibmdb2',
      array(PDO::ATTR_PERSISTENT => true));
  echo "Connected\n";
  $dbh->setAttribute(PDO::ATTR_ERRMODE, PDO::ERRMODE_EXCEPTION);

  $dbh->beginTransaction();
  $dbh->exec("insert into staff (id, first, last) values (23, 'Joe', 'Bloggs')");
  $dbh->exec("insert into salarychange (id, amount, changedate)
      values (23, 50000, NOW())");
  $dbh->commit();

} catch (Exception $e) {
  $dbh->rollBack();
  echo "Failed: " . $e->getMessage();
}
?>

You're not limited to making updates in a transaction; you can also issue complex queries to extract data, and possibly use that information to build up more updates and queries; while the transaction is active, you are guaranteed that no one else can make changes while you are in the middle of your work. In truth, this isn't 100% correct, but it is a good-enough introduction, if you've never heard of transactions before.

Prepared statements and stored procedures

Many of the more mature databases support the concept of prepared statements. What are they? You can think of them as a kind of compiled template for the SQL that you want to run, that can be customized using variable parameters. Prepared statements offer two major benefits:

  • The query only needs to be parsed (or prepared) once, but can be executed multiple times with the same or different parameters. When the query is prepared, the database will analyze, compile and optimize it's plan for executing the query. For complex queries this process can take up enough time that it will noticeably slow down your application if you need to repeat the same query many times with different parameters. By using a prepared statement you avoid repeating the analyze/compile/optimize cycle. In short, prepared statements use fewer resources and thus run faster.
  • The parameters to prepared statements don't need to be quoted; the driver handles it for you. If your application exclusively uses prepared statements, you can be sure that no SQL injection will occur. (However, if you're still building up other parts of the query based on untrusted input, you're still at risk).

Prepared statements are so useful that they are the only feature that PDO will emulate for drivers that don't support them. This ensures that you will be able to use the same data access paradigm regardless of the capabilities of the database.

Příklad 1546. Repeated inserts using prepared statements

This example performs an INSERT query by substituting a name and a value for the named placeholders.

<?php
$stmt = $dbh->prepare("INSERT INTO REGISTRY (name, value) VALUES (:name, :value)");
$stmt->bindParam(':name', $name);
$stmt->bindParam(':value', $value);

// insert one row
$name = 'one';
$value = 1;
$stmt->execute();

// insert another row with different values
$name = 'two';
$value = 2;
$stmt->execute();
?>

Příklad 1547. Repeated inserts using prepared statements

This example performs an INSERT query by substituting a name and a value for the positional ? placeholders.

<?php
$stmt = $dbh->prepare("INSERT INTO REGISTRY (name, value) VALUES (?, ?)");
$stmt->bindParam(1, $name);
$stmt->bindParam(2, $value);

// insert one row
$name = 'one';
$value = 1;
$stmt->execute();

// insert another row with different values
$name = 'two';
$value = 2;
$stmt->execute();
?>

Příklad 1548. Fetching data using prepared statements

This example fetches data based on a key value supplied by a form. The user input is automatically quoted, so there is no risk of a SQL injection attack.

<?php
$stmt = $dbh->prepare("SELECT * FROM REGISTRY where name = ?");
if ($stmt->execute(array($_GET['name']))) {
  while ($row = $stmt->fetch()) {
    print_r($row);
  }
}
?>

If the database driver supports it, you may also bind parameters for output as well as input. Output parameters are typically used to retrieve values from stored procedures. Output parameters are slightly more complex to use than input parameters, in that you must know how large a given parameter might be when you bind it. If the value turns out to be larger than the size you suggested, an error is raised.

Příklad 1549. Calling a stored procedure with an output parameter

<?php
$stmt = $dbh->prepare("CALL sp_returns_string(?)");
$stmt->bindParam(1, $return_value, PDO::PARAM_STR, 4000);

// call the stored procedure
$stmt->execute();

print "procedure returned $return_value\n";
?>

You may also specify parameters that hold values both input and output; the syntax is similar to output parameters. In this next example, the string 'hello' is passed into the stored procedure, and when it returns, hello is replaced with the return value of the procedure.

Příklad 1550. Calling a stored procedure with an input/output parameter

<?php
$stmt = $dbh->prepare("CALL sp_takes_string_returns_string(?)");
$value = 'hello';
$stmt->bindParam(1, $value, PDO::PARAM_STR|PDO::PARAM_INPUT_OUTPUT, 4000);

// call the stored procedure
$stmt->execute();

print "procedure returned $value\n";
?>

Příklad 1551. Invalid use of placeholder

<?php
$stmt = $dbh->prepare("SELECT * FROM REGISTRY where name LIKE '%?%'");
$stmt->execute(array($_GET['name']));

// placeholder must be used in the place of the whole value
$stmt = $dbh->prepare("SELECT * FROM REGISTRY where name LIKE ?");
$stmt->execute(array("%$_GET[name]%"));
?>

Errors and error handling

PDO offers you a choice of 3 different error handling strategies, to fit your style of application development.

  • PDO::ERRMODE_SILENT

    This is the default mode. PDO will simply set the error code for you to inspect using the PDO->errorCode() and PDO->errorInfo() methods on both the statement and database objects; if the error resulted from a call on a statement object, you would invoke the PDOStatement->errorCode() or PDOStatement->errorInfo() method on that object. If the error resulted from a call on the database object, you would invoke those methods on the database object instead.

  • PDO::ERRMODE_WARNING

    In addition to setting the error code, PDO will emit a traditional E_WARNING message. This setting is useful during debugging/testing, if you just want to see what problems occurred without interrupting the flow of the application.

  • PDO::ERRMODE_EXCEPTION

    In addition to setting the error code, PDO will throw a PDOException and set its properties to reflect the error code and error information. This setting is also useful during debugging, as it will effectively "blow up" the script at the point of the error, very quickly pointing a finger at potential problem areas in your code (remember: transactions are automatically rolled back if the exception causes the script to terminate).

    Exception mode is also useful because you can structure your error handling more clearly than with traditional PHP-style warnings, and with less code/nesting than by running in silent mode and explicitly checking the return value of each database call.

    See Exceptions for more information about Exceptions in PHP.

PDO standardizes on using SQL-92 SQLSTATE error code strings; individual PDO drivers are responsible for mapping their native codes to the appropriate SQLSTATE codes. The PDO->errorCode() method returns a single SQLSTATE code. If you need more specific information about an error, PDO also offers an PDO->errorInfo() method which returns an array containing the SQLSTATE code, the driver specific error code and driver specific error string.

Large Objects (LOBs)

At some point in your application, you might find that you need to store "large" data in your database. Large typically means "around 4kb or more", although some databases can happily handle up to 32kb before data becomes "large". Large objects can be either textual or binary in nature. PDO allows you to work with this large data type by using the PDO::PARAM_LOB type code in your PDOStatement->bindParam() or PDOStatement->bindColumn() calls. PDO::PARAM_LOB tells PDO to map the data as a stream, so that you can manipulate it using the PHP Streams API.

Příklad 1552. Displaying an image from a database

This example binds the LOB into the variable named $lob and then sends it to the browser using fpassthru(). Since the LOB is represented as a stream, functions such as fgets(), fread() and stream_get_contents() can be used on it.

<?php
$db = new PDO('odbc:SAMPLE', 'db2inst1', 'ibmdb2');
$stmt = $db->prepare("select contenttype, imagedata from images where id=?");
$stmt->execute(array($_GET['id']));
$stmt->bindColumn(1, $type, PDO::PARAM_STR, 256);
$stmt->bindColumn(2, $lob, PDO::PARAM_LOB);
$stmt->fetch(PDO::FETCH_BOUND);

header("Content-Type: $type");
fpassthru($lob);
?>

Příklad 1553. Inserting an image into a database

This example opens up a file and passes the file handle to PDO to insert it as a LOB. PDO will do its best to get the contents of the file up to the database in the most efficient manner possible.

<?php
$db = new PDO('odbc:SAMPLE', 'db2inst1', 'ibmdb2');
$stmt = $db->prepare("insert into images (id, contenttype, imagedata) values (?, ?, ?)");
$id = get_new_id(); // some function to allocate a new ID

// assume that we are running as part of a file upload form
// You can find more information in the PHP documentation

$fp = fopen($_FILES['file']['tmp_name'], 'rb');

$stmt->bindParam(1, $id);
$stmt->bindParam(2, $_FILES['file']['type']);
$stmt->bindParam(3, $fp, PDO::PARAM_LOB);

$db->beginTransaction();
$stmt->execute();
$db->commit();
?>

Příklad 1554. Inserting an image into a database: Oracle

Oracle requires a slightly different syntax for inserting a lob from a file. It's also essential that you perform the insert under a transaction, otherwise your newly inserted LOB will be committed with a zero-length as part of the implicit commit that happens when the query is executed:

<?php
$db = new PDO('oci:', 'scott', 'tiger');
$stmt = $db->prepare("insert into images (id, contenttype, imagedata) " .
  "VALUES (?, ?, EMPTY_BLOB()) RETURNING imagedata INTO ?");
$id = get_new_id(); // some function to allocate a new ID

// assume that we are running as part of a file upload form
// You can find more information in the PHP documentation

$fp = fopen($_FILES['file']['tmp_name'], 'rb');

$stmt->bindParam(1, $id);
$stmt->bindParam(2, $_FILES['file']['type']);
$stmt->bindParam(3, $fp, PDO::PARAM_LOB);

$stmt->beginTransaction();
$stmt->execute();
$stmt->commit();
?>

Předdefinované třídy

PDO

Represents a connection between PHP and a database server.

Konstruktory

  • PDO - constructs a new PDO object

Metody

  • beginTransaction - begins a transaction

  • commit - commits a transaction

  • errorCode - retrieves an error code, if any, from the database

  • errorInfo - retrieves an array of error information, if any, from the database

  • exec - issues an SQL statement and returns the number of affected rows

  • getAttribute - retrieves a database connection attribute

  • lastInsertId - retrieves the value of the last row that was inserted into a table

  • prepare - prepares an SQL statement for execution

  • query - issues an SQL statement and returns a result set

  • quote - returns a quoted version of a string for use in SQL statements

  • rollBack - roll back a transaction

  • setAttribute - sets a database connection attribute

PDOStatement

Represents a prepared statement and, after the statement is executed, an associated result set.

Metody

  • bindColumn - binds a PHP variable to an output column in a result set

  • bindParam - binds a PHP variable to a parameter in the prepared statement

  • bindValue - binds a value to a parameter in the prepared statement

  • closeCursor - closes the cursor, allowing the statement to be executed again

  • columnCount - returns the number of columns in the result set

  • errorCode - retrieves an error code, if any, from the statement

  • errorInfo - retrieves an array of error information, if any, from the statement

  • execute - executes a prepared statement

  • fetch - fetches a row from a result set

  • fetchAll - fetches an array containing all of the rows from a result set

  • fetchColumn - returns the data from a single column in a result set

  • getAttribute - retrieves a PDOStatement attribute

  • getColumnMeta - retrieves metadata for a column in the result set

  • nextRowset - retrieves the next rowset (result set)

  • rowCount - returns the number of rows that were affected by the execution of an SQL statement

  • setAttribute - sets a PDOStatement attribute

  • setFetchMode - sets the fetch mode for a PDOStatement

PDOException

Represents an error raised by PDO. You should not throw a PDOException from your own code. See Exceptions for more information about Exceptions in PHP.

Příklad 1555. The PDOException class

<?php
class PDOException extends Exception
{
    public $errorInfo = null;    // corresponds to PDO::errorInfo()
                                 // or PDOStatement::errorInfo()
    protected $message;          // textual error message
                                 // use Exception::getMessage() to access it
    protected $code;             // SQLSTATE error code
                                 // use Exception::getCode() to access it
}
?>

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

Varování

PDO uses class constants since PHP 5.1. Prior releases use global constants in the form PDO_PARAM_BOOL.

PDO::PARAM_BOOL (integer)
Represents a boolean data type.
PDO::PARAM_NULL (integer)
Represents the SQL NULL data type.
PDO::PARAM_INT (integer)
Represents the SQL INTEGER data type.
PDO::PARAM_STR (integer)
Represents the SQL CHAR, VARCHAR, or other string data type.
PDO::PARAM_LOB (integer)
Represents the SQL large object data type.
PDO::PARAM_STMT (integer)
Represents a recordset type. Not currently supported by any drivers.
PDO::PARAM_INPUT_OUTPUT (integer)
Specifies that the parameter is an INOUT parameter for a stored procedure. You must bitwise-OR this value with an explicit PDO::PARAM_* data type.
PDO::FETCH_LAZY (integer)
Specifies that the fetch method shall return each row as an object with variable names that correspond to the column names returned in the result set. PDO::FETCH_LAZY creates the object variable names as they are accessed.
PDO::FETCH_ASSOC (integer)
Specifies that the fetch method shall return each row as an array indexed by column name as returned in the corresponding result set. If the result set contains multiple columns with the same name, PDO::FETCH_ASSOC returns only a single value per column name.
PDO::FETCH_NAMED (integer)
Specifies that the fetch method shall return each row as an array indexed by column name as returned in the corresponding result set. If the result set contains multiple columns with the same name, PDO::FETCH_NAMED returns an array of values per column name.
PDO::FETCH_NUM (integer)
Specifies that the fetch method shall return each row as an array indexed by column number as returned in the corresponding result set, starting at column 0.
PDO::FETCH_BOTH (integer)
Specifies that the fetch method shall return each row as an array indexed by both column name and number as returned in the corresponding result set, starting at column 0.
PDO::FETCH_OBJ (integer)
Specifies that the fetch method shall return each row as an object with property names that correspond to the column names returned in the result set.
PDO::FETCH_BOUND (integer)
Specifies that the fetch method shall return TRUE and assign the values of the columns in the result set to the PHP variables to which they were bound with the PDOStatement::bindParam() or PDOStatement::bindColumn() methods.
PDO::FETCH_COLUMN (integer)
Specifies that the fetch method shall return only a single requested column from the next row in the result set.
PDO::FETCH_CLASS (integer)
Specifies that the fetch method shall return a new instance of the requested class, mapping the columns to named properties in the class.
PDO::FETCH_INTO (integer)
Specifies that the fetch method shall update an existing instance of the requested class, mapping the columns to named properties in the class.
PDO::FETCH_FUNC (integer)
PDO::FETCH_GROUP (integer)
PDO::FETCH_UNIQUE (integer)
PDO::FETCH_KEY_PAIR (integer)
Fetch into an array where the 1st column is a key and all subsequent columns are values
PDO::FETCH_CLASSTYPE (integer)
PDO::FETCH_SERIALIZE (integer)
As PDO::FETCH_INTO but object is provided as a serialized string. Available since PHP 5.1.0.
PDO::FETCH_PROPS_LATE (integer)
Available since PHP 5.2.0
PDO::ATTR_AUTOCOMMIT (integer)
If this value is FALSE, PDO attempts to disable autocommit so that the connection begins a transaction.
PDO::ATTR_PREFETCH (integer)
Setting the prefetch size allows you to balance speed against memory usage for your application. Not all database/driver combinations support setting of the prefetch size. A larger prefetch size results in increased performance at the cost of higher memory usage.
PDO::ATTR_TIMEOUT (integer)
Sets the timeout value in seconds for communications with the database.
PDO::ATTR_ERRMODE (integer)
See the Errors and error handling section for more information about this attribute.
PDO::ATTR_SERVER_VERSION (integer)
This is a read only attribute; it will return information about the version of the database server to which PDO is connected.
PDO::ATTR_CLIENT_VERSION (integer)
This is a read only attribute; it will return information about the version of the client libraries that the PDO driver is using.
PDO::ATTR_SERVER_INFO (integer)
This is a read only attribute; it will return some meta information about the database server to which PDO is connected.
PDO::ATTR_CONNECTION_STATUS (integer)
PDO::ATTR_CASE (integer)
Force column names to a specific case specified by the PDO::CASE_* constants.
PDO::ATTR_CURSOR_NAME (integer)
Get or set the name to use for a cursor. Most useful when using scrollable cursors and positioned updates.
PDO::ATTR_CURSOR (integer)
Selects the cursor type. PDO currently supports either PDO::CURSOR_FWDONLY and PDO::CURSOR_SCROLL. Stick with PDO::CURSOR_FWDONLY unless you know that you need a scrollable cursor.
PDO::ATTR_DRIVER_NAME (string)

Returns the name of the driver.

Příklad 1556. using PDO::ATTR_DRIVER_NAME

<?php
if ($db->getAttribute(PDO::ATTR_DRIVER_NAME) == 'mysql') {
  echo "Running on mysql; doing something mysql specific here\n";
}
?>

PDO::ATTR_ORACLE_NULLS (integer)
Convert empty strings to SQL NULL values on data fetches.
PDO::ATTR_PERSISTENT (integer)
Request a persistent connection, rather than creating a new connection. See Connections and Connection management for more information on this attribute.
PDO::ATTR_STATEMENT_CLASS (integer)
PDO::ATTR_FETCH_CATALOG_NAMES (integer)
Prepend the containing catalog name to each column name returned in the result set. The catalog name and column name are separated by a decimal (.) character. Support of this attribute is at the driver level; it may not be supported by your driver.
PDO::ATTR_FETCH_TABLE_NAMES (integer)
Prepend the containing table name to each column name returned in the result set. The table name and column name are separated by a decimal (.) character. Support of this attribute is at the driver level; it may not be supported by your driver.
PDO::ATTR_STRINGIFY_FETCHES (integer)
PDO::ATTR_MAX_COLUMN_LEN (integer)
PDO::ATTR_DEFAULT_FETCH_MODE (integer)
Available since PHP 5.2.0
PDO::ATTR_EMULATE_PREPARES (integer)
Available since PHP 5.1.3.
PDO::ERRMODE_SILENT (integer)
Do not raise an error or exception if an error occurs. The developer is expected to explicitly check for errors. This is the default mode. See Errors and error handling for more information about this attribute.
PDO::ERRMODE_WARNING (integer)
Issue a PHP E_WARNING message if an error occurs. See Errors and error handling for more information about this attribute.
PDO::ERRMODE_EXCEPTION (integer)
Throw a PDOException if an error occurs. See Errors and error handling for more information about this attribute.
PDO::CASE_NATURAL (integer)
Leave column names as returned by the database driver.
PDO::CASE_LOWER (integer)
Force column names to lower case.
PDO::CASE_UPPER (integer)
Force column names to upper case.
PDO::NULL_NATURAL (integer)
PDO::NULL_EMPTY_STRING (integer)
PDO::NULL_TO_STRING (integer)
PDO::FETCH_ORI_NEXT (integer)
Fetch the next row in the result set. Valid only for scrollable cursors.
PDO::FETCH_ORI_PRIOR (integer)
Fetch the previous row in the result set. Valid only for scrollable cursors.
PDO::FETCH_ORI_FIRST (integer)
Fetch the first row in the result set. Valid only for scrollable cursors.
PDO::FETCH_ORI_LAST (integer)
Fetch the last row in the result set. Valid only for scrollable cursors.
PDO::FETCH_ORI_ABS (integer)
Fetch the requested row by row number from the result set. Valid only for scrollable cursors.
PDO::FETCH_ORI_REL (integer)
Fetch the requested row by relative position from the current position of the cursor in the result set. Valid only for scrollable cursors.
PDO::CURSOR_FWDONLY (integer)
Create a PDOStatement object with a forward-only cursor. This is the default cursor choice, as it is the fastest and most common data access pattern in PHP.
PDO::CURSOR_SCROLL (integer)
Create a PDOStatement object with a scrollable cursor. Pass the PDO::FETCH_ORI_* constants to control the rows fetched from the result set.
PDO::ERR_NONE (string)
Corresponds to SQLSTATE '00000', meaning that the SQL statement was successfully issued with no errors or warnings. This constant is for your convenience when checking PDO::errorCode() or PDOStatement::errorCode() to determine if an error occurred. You will usually know if this is the case by examining the return code from the method that raised the error condition anyway.
PDO::PARAM_EVT_ALLOC (integer)
Allocation event
PDO::PARAM_EVT_FREE (integer)
Deallocation event
PDO::PARAM_EVT_EXEC_PRE (integer)
Event triggered prior to execution of a prepared statement.
PDO::PARAM_EVT_EXEC_POST (integer)
Event triggered subsequent to execution of a prepared statement.
PDO::PARAM_EVT_FETCH_PRE (integer)
Event triggered prior to fetching a result from a resultset.
PDO::PARAM_EVT_FETCH_POST (integer)
Event triggered subsequent to fetching a result from a resultset.
PDO::PARAM_EVT_NORMALIZE (integer)
Event triggered during bound parameter registration allowing the driver to normalize the parameter name.

Obsah

PDO->beginTransaction() — Initiates a transaction
PDO->commit() — Commits a transaction
PDO->__construct() — Creates a PDO instance representing a connection to a database
PDO->errorCode() — Fetch the SQLSTATE associated with the last operation on the database handle
PDO->errorInfo() — Fetch extended error information associated with the last operation on the database handle
PDO->exec() — Execute an SQL statement and return the number of affected rows
PDO->getAttribute() — Retrieve a database connection attribute
PDO->getAvailableDrivers() — Return an array of available PDO drivers
PDO->lastInsertId() — Returns the ID of the last inserted row or sequence value
PDO->prepare() — Prepares a statement for execution and returns a statement object
PDO->query() — Executes an SQL statement, returning a result set as a PDOStatement object
PDO->quote() — Quotes a string for use in a query.
PDO->rollBack() — Rolls back a transaction
PDO->setAttribute() — Set an attribute
PDOStatement->bindColumn() — Bind a column to a PHP variable
PDOStatement->bindParam() — Binds a parameter to the specified variable name
PDOStatement->bindValue() — Binds a value to a parameter
PDOStatement->closeCursor() — Closes the cursor, enabling the statement to be executed again.
PDOStatement->columnCount() — Returns the number of columns in the result set
PDOStatement->errorCode() — Fetch the SQLSTATE associated with the last operation on the statement handle
PDOStatement->errorInfo() — Fetch extended error information associated with the last operation on the statement handle
PDOStatement->execute() — Executes a prepared statement
PDOStatement->fetch() — Fetches the next row from a result set
PDOStatement->fetchAll() — Returns an array containing all of the result set rows
PDOStatement->fetchColumn() — Returns a single column from the next row of a result set
PDOStatement->fetchObject() — Fetches the next row and returns it as an object.
PDOStatement->getAttribute() — Retrieve a statement attribute
PDOStatement->getColumnMeta() — Returns metadata for a column in a result set
PDOStatement->nextRowset() — Advances to the next rowset in a multi-rowset statement handle
PDOStatement->rowCount() — Returns the number of rows affected by the last SQL statement
PDOStatement->setAttribute() — Set a statement attribute
PDOStatement->setFetchMode() — Set the default fetch mode for this statement
Předcházející | Nahoru | Další
PDF_utf8_to_utf16 | Domů | PDO->beginTransaction()


PDO->beginTransaction()

(PHP 5 >= 5.1.0, PECL pdo:0.1-1.0.3)

PDO->beginTransaction() — Initiates a transaction

Popis

class PDO {
bool beginTransaction ( void )
}

Turns off autocommit mode. While autocommit mode is turned off, changes made to the database via the PDO object instance are not committed until you end the transaction by calling PDO->commit(). Calling PDO->rollBack() will roll back all changes to the database and return the connection to autocommit mode.

Some databases, including MySQL, automatically issue an implicit COMMIT when a database definition language (DDL) statement such as DROP TABLE or CREATE TABLE is issued within a transaction. The implicit COMMIT will prevent you from rolling back any other changes within the transaction boundary.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1557. Roll back a transaction

The following example begins a transaction and issues two statements that modify the database before rolling back the changes. On MySQL, however, the DROP TABLE statement automatically commits the transaction so that none of the changes in the transaction are rolled back.

<?php
/* Begin a transaction, turning off autocommit */
$dbh->beginTransaction();

/* Change the database schema and data */
$sth = $dbh->exec("DROP TABLE fruit");
$sth = $dbh->exec("UPDATE dessert
    SET name = 'hamburger'");

/* Recognize mistake and roll back changes */
$dbh->rollBack();

/* Database connection is now back in autocommit mode */
?>

Viz také

PDO->commit()
PDO->rollBack()

Předcházející | Nahoru | Další
CXXII. PDO Functions | Domů | PDO->commit()


PDO->commit()

(PHP 5 >= 5.1.0, PECL pdo:0.1-1.0.3)

PDO->commit() — Commits a transaction

Popis

class PDO {
bool commit ( void )
}

Commits a transaction, returning the database connection to autocommit mode until the next call to PDO->beginTransaction() starts a new transaction.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1558. Commit a transaction

<?php
/* Begin a transaction, turning off autocommit */
$dbh->beginTransaction();

/* Change the database schema */
$sth = $dbh->exec("DROP TABLE fruit");

/* Commit the changes */
$dbh->commit();

/* Database connection is now back in autocommit mode */
?>

Viz také

PDO->beginTransaction()
PDO->rollBack()

Předcházející | Nahoru | Další
PDO->beginTransaction() | Domů | PDO->__construct()


PDO->__construct()

(PHP 5 >= 5.1.0, PECL pdo:0.1-1.0.3)

PDO->__construct() — Creates a PDO instance representing a connection to a database

Popis

class PDO {
PDO __construct ( string $dsn [, string $username [, string $password [, array $driver_options]]] )
}

Creates a PDO instance to represent a connection to the requested database.

Seznam parametrů

dsn

The Data Source Name, or DSN, contains the information required to connect to the database.

In general, a DSN consists of the PDO driver name, followed by a colon, followed by the PDO driver-specific connection syntax. Further information is available from the PDO driver-specific documentation.

The dsn parameter supports three different methods of specifying the arguments required to create a database connection:

Driver invocation

dsn contains the full DSN.

URI invocation

dsn consists of uri: followed by a URI that defines the location of a file containing the DSN string. The URI can specify a local file or a remote URL.

uri:file:///path/to/dsnfile

Aliasing

dsn consists of a name name that maps to pdo.dsn.name in php.ini defining the DSN string.

Poznámka: The alias must be defined in php.ini, and not .htaccess or httpd.conf

username

The user name for the DSN string. This parameter is optional for some PDO drivers.

password

The password for the DSN string. This parameter is optional for some PDO drivers.

driver_options

A key=>value array of driver-specific connection options.

Návratové hodnoty

Returns a PDO object on success.

Errors/Exceptions

PDO->__construct() throws a PDOException if the attempt to connect to the requested database fails.

Příklady

Příklad 1559. Create a PDO instance via driver invocation

<?php
/* Connect to an ODBC database using driver invocation */
$dsn = 'mysql:dbname=testdb;host=127.0.0.1';
$user = 'dbuser';
$password = 'dbpass';

try {
    $dbh = new PDO($dsn, $user, $password);
} catch (PDOException $e) {
    echo 'Connection failed: ' . $e->getMessage();
}

?>

Příklad 1560. Create a PDO instance via URI invocation

The following example assumes that the file /usr/local/dbconnect exists with file permissions that enable PHP to read the file. The file contains the PDO DSN to connect to a DB2 database through the PDO_ODBC driver:

odbc:DSN=SAMPLE;UID=john;PWD=mypass

The PHP script can then create a database connection by simply passing the uri: parameter and pointing to the file URI:

<?php
/* Connect to an ODBC database using driver invocation */
$dsn = 'uri:file:///usr/local/dbconnect';
$user = '';
$password = '';

try {
    $dbh = new PDO($dsn, $user, $password);
} catch (PDOException $e) {
    echo 'Connection failed: ' . $e->getMessage();
}

?>

Příklad 1561. Create a PDO instance using an alias

The following example assumes that php.ini contains the following entry to enable a connection to a MySQL database using only the alias mydb:

[PDO]
pdo.dsn.mydb="mysql:dbname=testdb;host=localhost"

<?php
/* Connect to an ODBC database using an alias */
$dsn = 'mydb';
$user = '';
$password = '';

try {
    $dbh = new PDO($dsn, $user, $password);
} catch (PDOException $e) {
    echo 'Connection failed: ' . $e->getMessage();
}

?>

Předcházející | Nahoru | Další
PDO->commit() | Domů | PDO->errorCode()


PDO->errorCode()

(PHP 5 >= 5.1.0, PECL pdo:0.1-1.0.3)

PDO->errorCode() — Fetch the SQLSTATE associated with the last operation on the database handle

Popis

class PDO {
string errorCode ( void )
}

Návratové hodnoty

Returns a SQLSTATE, a five-character alphanumeric identifier defined in the ANSI SQL-92 standard. Briefly, an SQLSTATE consists of a two-character class value followed by a three-character subclass value. A class value of 01 indicates a warning and is accompanied by a return code of SQL_SUCCESS_WITH_INFO. Class values other than '01', except for the class 'IM', indicate an error. The class 'IM' is specific to warnings and errors that derive from the implementation of PDO (or perhaps ODBC, if you're using the ODBC driver) itself. The subclass value '000' in any class indicates that there is no subclass for that SQLSTATE.

PDO->errorCode() only retrieves error codes for operations performed directly on the database handle. If you create a PDOStatement object through PDO->prepare() or PDO->query() and invoke an error on the statement handle, PDO->errorCode() will not reflect that error. You must call PDOStatement->errorCode() to return the error code for an operation performed on a particular statement handle.

Příklady

Příklad 1562. Retrieving a SQLSTATE code

<?php
/* Provoke an error -- the BONES table does not exist */
$dbh->exec("INSERT INTO bones(skull) VALUES ('lucy')");

echo "\nPDO::errorCode(): ";
print $dbh->errorCode();
?>

Výše uvedený příklad vypíše:

PDO::errorCode(): 42S02

Viz také

PDO->errorInfo()
PDOStatement->errorCode()
PDOStatement->errorInfo()

Předcházející | Nahoru | Další
PDO->__construct() | Domů | PDO->errorInfo()


PDO->errorInfo()

(PHP 5 >= 5.1.0, PECL pdo:0.1-1.0.3)

PDO->errorInfo() — Fetch extended error information associated with the last operation on the database handle

Popis

class PDO {
array errorInfo ( void )
}

Návratové hodnoty

PDO->errorInfo() returns an array of error information about the last operation performed by this database handle. The array consists of the following fields:

Element | Information
0 | SQLSTATE error code (a five-character alphanumeric identifier defined in the ANSI SQL standard).
1 | Driver-specific error code.
2 | Driver-specific error message.

PDO->errorInfo() only retrieves error information for operations performed directly on the database handle. If you create a PDOStatement object through PDO->prepare() or PDO->query() and invoke an error on the statement handle, PDO->errorInfo() will not reflect the error from the statement handle. You must call PDOStatement->errorInfo() to return the error information for an operation performed on a particular statement handle.

Příklady

Příklad 1563. Displaying errorInfo() fields for a PDO_ODBC connection to a DB2 database

<?php
/* Provoke an error -- bogus SQL syntax */
$stmt = $dbh->prepare('bogus sql');
if (!$stmt) {
    echo "\nPDO::errorInfo():\n";
    print_r($dbh->errorInfo());
}
?>

Výše uvedený příklad vypíše:

PDO::errorInfo():
Array
(
    [0] => HY000
    [1] => 1
    [2] => near "bogus": syntax error
)

Viz také

PDO->errorCode()
PDOStatement->errorCode()
PDOStatement->errorInfo()

Předcházející | Nahoru | Další
PDO->errorCode() | Domů | PDO->exec()


PDO->exec()

(PHP 5 >= 5.1.0, PECL pdo:0.1-1.0.3)

PDO->exec() — Execute an SQL statement and return the number of affected rows

Popis

class PDO {
int exec ( string $statement )
}

PDO->exec() executes an SQL statement in a single function call, returning the number of rows affected by the statement.

PDO->exec() does not return results from a SELECT statement. For a SELECT statement that you only need to issue once during your program, consider issuing PDO->query(). For a statement that you need to issue multiple times, prepare a PDOStatement object with PDO->prepare() and issue the statement with PDOStatement->execute().

Seznam parametrů

statement

The SQL statement to prepare and execute.

Návratové hodnoty

PDO->exec() returns the number of rows that were modified or deleted by the SQL statement you issued. If no rows were affected, PDO->exec() returns 0.

Varování

Tato funkce může vracet booleovskou hodnotu FALSE, ale také nebooleovskou hodnotu odpovídající ohodnocení FALSE, například 0 nebo "". Čtěte prosím sekci o typu Boolean, kde najdete více informací. Pro testování návratové hodnoty této funkce použijte operátor ===.

The following example incorrectly relies on the return value of PDO->exec(), wherein a statement that affected 0 rows results in a call to die(): <?php
$db->exec() or die($db->errorInfo());
?>

Příklady

Příklad 1564. Issuing a DELETE statement

Count the number of rows deleted by a DELETE statement with no WHERE clause.

<?php
$dbh = new PDO('odbc:sample', 'db2inst1', 'ibmdb2');

/* Delete all rows from the FRUIT table */
$count = $dbh->exec("DELETE FROM fruit WHERE colour = 'red'");

/* Return number of rows that were deleted */
print("Deleted $count rows.\n");
?>

Výše uvedený příklad vypíše:

Deleted 1 rows.

Viz také

PDO->prepare()
PDO->query()
PDOStatement->execute()

Předcházející | Nahoru | Další
PDO->errorInfo() | Domů | PDO->getAttribute()


PDO->lastInsertId()

(PHP 5 >= 5.1.0, PECL pdo:0.1-1.0.3)

PDO->lastInsertId() — Returns the ID of the last inserted row or sequence value

Popis

class PDO {
string lastInsertId ( [string $name] )
}

Returns the ID of the last inserted row, or the last value from a sequence object, depending on the underlying driver. For example, PDO_PGSQL() requires you to specify the name of a sequence object for the name parameter.

Poznámka: This method may not return a meaningful or consistent result across different PDO drivers, because the underlying database may not even support the notion of auto-increment fields or sequences.

Seznam parametrů

name

Name of the sequence object from which the ID should be returned.

Návratové hodnoty

If a sequence name was not specified for the name parameter, PDO->lastInsertId() returns a string representing the row ID of the last row that was inserted into the database.

If a sequence name was specified for the name parameter, PDO->lastInsertId() returns a string representing the last value retrieved from the specified sequence object.

If the PDO driver does not support this capability, PDO->lastInsertId() triggers an IM001 SQLSTATE.

Předcházející | Nahoru | Další
PDO->getAvailableDrivers() | Domů | PDO->prepare()


PDO->prepare()

(PHP 5 >= 5.1.0, PECL pdo:0.1-1.0.3)

PDO->prepare() — Prepares a statement for execution and returns a statement object

Popis

class PDO {
PDOStatement prepare ( string $statement [, array $driver_options] )
}

Prepares an SQL statement to be executed by the PDOStatement->execute() method. The SQL statement can contain zero or more named (:name) or question mark (?) parameter markers for which real values will be substituted when the statement is executed. You cannot use both named and question mark parameter markers within the same SQL statement; pick one or the other parameter style.

You must include a unique parameter marker for each value you wish to pass in to the statement when you call PDOStatement->execute(). You cannot use a named parameter marker of the same name twice in a prepared statement. You cannot bind multiple values to a single named parameter in, for example, the IN() clause of an SQL statement.

Calling PDO->prepare() and PDOStatement->execute() for statements that will be issued multiple times with different parameter values optimizes the performance of your application by allowing the driver to negotiate client and/or server side caching of the query plan and meta information, and helps to prevent SQL injection attacks by eliminating the need to manually quote the parameters.

PDO will emulate prepared statements/bound parameters for drivers that do not natively support them, and can also rewrite named or question mark style parameter markers to something more appropriate, if the driver supports one style but not the other.

Seznam parametrů

statement

This must be a valid SQL statement for the target database server.

driver_options

This array holds one or more key=>value pairs to set attribute values for the PDOStatement object that this method returns. You would most commonly use this to set the PDO::ATTR_CURSOR value to PDO::CURSOR_SCROLL to request a scrollable cursor. Some drivers have driver specific options that may be set at prepare-time.

Návratové hodnoty

If the database server successfully prepares the statement, PDO->prepare() returns a PDOStatement object. If the database server cannot successfully prepare the statement, PDO->prepare() returns FALSE.

Příklady

Příklad 1567. Prepare an SQL statement with named parameters

<?php
/* Execute a prepared statement by passing an array of values */
$sql = 'SELECT name, colour, calories
    FROM fruit
    WHERE calories < :calories AND colour = :colour';
$sth = $dbh->prepare($sql, array(PDO::ATTR_CURSOR => PDO::CURSOR_FWDONLY));
$sth->execute(array(':calories' => 150, ':colour' => 'red'));
$red = $sth->fetchAll();
$sth->execute(array('calories' => 175, 'colour' => 'yellow'));
$yellow = $sth->fetchAll();
?>

Příklad 1568. Prepare an SQL statement with question mark parameters

<?php
/* Execute a prepared statement by passing an array of values */
$sth = $dbh->prepare('SELECT name, colour, calories
    FROM fruit
    WHERE calories < ? AND colour = ?');
$sth->execute(array(150, 'red'));
$red = $sth->fetchAll();
$sth->execute(array(175, 'yellow'));
$yellow = $sth->fetchAll();
?>

Viz také

PDO->exec()
PDO->query()
PDOStatement->execute()

Předcházející | Nahoru | Další
PDO->lastInsertId() | Domů | PDO->query()


PDO->rollBack()

(PHP 5 >= 5.1.0, PECL pdo:0.1-1.0.3)

PDO->rollBack() — Rolls back a transaction

Popis

class PDO {
bool rollBack ( void )
}

Rolls back the current transaction, as initiated by PDO->beginTransaction(). It is an error to call this method if no transaction is active.

If the database was set to autocommit mode, this function will restore autocommit mode after it has rolled back the transaction.

Some databases, including MySQL, automatically issue an implicit COMMIT when a database definition language (DDL) statement such as DROP TABLE or CREATE TABLE is issued within a transaction. The implicit COMMIT will prevent you from rolling back any other changes within the transaction boundary.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1573. Roll back a transaction

The following example begins a transaction and issues two statements that modify the database before rolling back the changes. On MySQL, however, the DROP TABLE statement automatically commits the transaction so that none of the changes in the transaction are rolled back.

<?php
/* Begin a transaction, turning off autocommit */
$dbh->beginTransaction();

/* Change the database schema and data */
$sth = $dbh->exec("DROP TABLE fruit");
$sth = $dbh->exec("UPDATE dessert
    SET name = 'hamburger'");

/* Recognize mistake and roll back changes */
$dbh->rollBack();

/* Database connection is now back in autocommit mode */
?>

Viz také

PDO->beginTransaction()
PDO->commit()

Předcházející | Nahoru | Další
PDO->quote() | Domů | PDO->setAttribute()


PDO->setAttribute()

(PHP 5 >= 5.1.0, PECL pdo:0.1-1.0.3)

PDO->setAttribute() — Set an attribute

Popis

class PDO {
bool setAttribute ( int $attribute, mixed $value )
}

Sets an attribute on the database handle. Some of the available generic attributes are listed below; some drivers may make use of additional driver specific attributes.

  • PDO::ATTR_CASE: Force column names to a specific case.

    • PDO::CASE_LOWER: Force column names to lower case.

    • PDO::CASE_NATURAL: Leave column names as returned by the database driver.

    • PDO::CASE_UPPER: Force column names to upper case.

  • PDO::ATTR_ERRMODE: Error reporting.

    • PDO::ERRMODE_SILENT: Just set error codes.

    • PDO::ERRMODE_WARNING: Raise E_WARNING.

    • PDO::ERRMODE_EXCEPTION: Throw exceptions.

  • PDO::ATTR_ORACLE_NULLS (available with all drivers, not just Oracle): Conversion of NULL and empty strings.

    • PDO::NULL_NATURAL: No conversion.

    • PDO::NULL_EMPTY_STRING: Empty string is converted to NULL.

    • PDO::NULL_TO_STRING: NULL is converted to an empty string.

  • PDO::ATTR_STRINGIFY_FETCHES: Convert numeric values to strings when fetching. Requires bool.

  • PDO::ATTR_STATEMENT_CLASS: Set user-supplied statement class derived from PDOStatement. Cannot be used with persistent PDO instances. Requires array(string classname, array(mixed constructor_args)).

  • PDO::ATTR_AUTOCOMMIT (available in OCI, Firebird and MySQL): Whether to autocommit every single statement.

  • PDO::MYSQL_ATTR_USE_BUFFERED_QUERY (available in MySQL): Use buffered queries.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
PDO->rollBack() | Domů | PDOStatement->bindColumn()


PDOStatement->bindColumn()

(PHP 5 >= 5.1.0, PECL pdo:0.1-1.0.3)

PDOStatement->bindColumn() — Bind a column to a PHP variable

Popis

class PDOStatement {
bool bindColumn ( mixed $column, mixed &$param [, int $type] )
}

PDOStatement->bindColumn() arranges to have a particular variable bound to a given column in the result-set from a query. Each call to PDOStatement->fetch() or PDOStatement->fetchAll() will update all the variables that are bound to columns.

Poznámka: Since information about the columns is not always available to PDO until the statement is executed, portable applications should call this function after PDOStatement->execute().

Seznam parametrů

column

Number of the column (1-indexed) or name of the column in the result set. If using the column name, be aware that the name should match the case of the column, as returned by the driver.

param

Name of the PHP variable to which the column will be bound.

type

Data type of the parameter, specified by the PDO::PARAM_* constants.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1574. Binding result set output to PHP variables

Binding columns in the result set to PHP variables is an effective way to make the data contained in each row immediately available to your application. The following example demonstrates how PDO allows you to bind and retrieve columns with a variety of options and with intelligent defaults.

<?php
function readData($dbh) {
  $sql = 'SELECT name, colour, calories FROM fruit';
  try {
    $stmt = $dbh->prepare($sql);
    $stmt->execute();

    /* Bind by column number */
    $stmt->bindColumn(1, $name);
    $stmt->bindColumn(2, $colour);

    /* Bind by column name */
    $stmt->bindColumn('calories', $cals);

    while ($row = $stmt->fetch(PDO::FETCH_BOUND)) {
      $data = $name . "\t" . $colour . "\t" . $cals . "\n";
      print $data;
    }
  }
  catch (PDOException $e) {
    print $e->getMessage();
  }
}
readData($dbh);
?>

Výše uvedený příklad vypíše:

apple   red     150
banana  yellow  175
kiwi    green   75
orange  orange  150
mango   red     200
strawberry      red     25

Viz také

PDOStatement->execute()
PDOStatement->fetch()
PDOStatement->fetchAll()
PDOStatement->fetchColumn()

Předcházející | Nahoru | Další
PDO->setAttribute() | Domů | PDOStatement->bindParam()


PDOStatement->bindParam()

(PHP 5 >= 5.1.0, PECL pdo:0.1-1.0.3)

PDOStatement->bindParam() — Binds a parameter to the specified variable name

Popis

class PDOStatement {
bool bindParam ( mixed $parameter, mixed &$variable [, int $data_type [, int $length [, mixed $driver_options]]] )
}

Binds a PHP variable to a corresponding named or question mark placeholder in the SQL statement that was use to prepare the statement. Unlike PDOStatement->bindValue(), the variable is bound as a reference and will only be evaluated at the time that PDOStatement->execute() is called.

Most parameters are input parameters, that is, parameters that are used in a read-only fashion to build up the query. Some drivers support the invocation of stored procedures that return data as output parameters, and some also as input/output parameters that both send in data and are updated to receive it.

Seznam parametrů

parameter

Parameter identifier. For a prepared statement using named placeholders, this will be a parameter name of the form :name. For a prepared statement using question mark placeholders, this will be the 1-indexed position of the parameter.

variable

Name of the PHP variable to bind to the SQL statement parameter.

data_type

Explicit data type for the parameter using the PDO::PARAM_* constants. Defaults to PHP native type. To return an INOUT parameter from a stored procedure, use the bitwise OR operator to set the PDO::PARAM_INPUT_OUTPUT bits for the data_type parameter.

length

Length of the data type. To indicate that a parameter is an OUT parameter from a stored procedure, you must explicitly set the length.

driver_options

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1575. Execute a prepared statement with named placeholders

<?php
/* Execute a prepared statement by binding PHP variables */
$calories = 150;
$colour = 'red';
$sth = $dbh->prepare('SELECT name, colour, calories
    FROM fruit
    WHERE calories < :calories AND colour = :colour');
$sth->bindParam(':calories', $calories, PDO::PARAM_INT);
$sth->bindParam(':colour', $colour, PDO::PARAM_STR, 12);
$sth->execute();
?>

Příklad 1576. Execute a prepared statement with question mark placeholders

<?php
/* Execute a prepared statement by binding PHP variables */
$calories = 150;
$colour = 'red';
$sth = $dbh->prepare('SELECT name, colour, calories
    FROM fruit
    WHERE calories < ? AND colour = ?');
$sth->bindParam(1, $calories, PDO::PARAM_INT);
$sth->bindParam(2, $colour, PDO::PARAM_STR, 12);
$sth->execute();
?>

Příklad 1577. Call a stored procedure with an INOUT parameter

<?php
/* Call a stored procedure with an INOUT parameter */
$colour = 'red';
$sth = $dbh->prepare('CALL puree_fruit(?)');
$sth->bindParam(1, $colour, PDO::PARAM_STR|PDO::PARAM_INPUT_OUTPUT, 12);
$sth->execute();
print("After pureeing fruit, the colour is: $colour");
?>

Viz také

PDO->prepare()
PDOStatement->execute()
PDOStatement->bindValue()

Předcházející | Nahoru | Další
PDOStatement->bindColumn() | Domů | PDOStatement->bindValue()


PDOStatement->errorCode()

(PHP 5 >= 5.1.0, PECL pdo:0.1-1.0.3)

PDOStatement->errorCode() — Fetch the SQLSTATE associated with the last operation on the statement handle

Popis

class PDOStatement {
string errorCode ( void )
}

Návratové hodnoty

Identical to PDO->errorCode(), except that PDOStatement->errorCode() only retrieves error codes for operations performed with PDOStatement objects.

Příklady

Příklad 1582. Retrieving a SQLSTATE code

<?php
/* Provoke an error -- the BONES table does not exist */
$err = $dbh->prepare('SELECT skull FROM bones');
$err->execute();

echo "\nPDOStatement::errorCode(): ";
print $err->errorCode();
?>

Výše uvedený příklad vypíše:

PDOStatement::errorCode(): 42S02

Viz také

PDO->errorCode()
PDO->errorInfo()
PDOStatement->errorInfo()

Předcházející | Nahoru | Další
PDOStatement->columnCount() | Domů | PDOStatement->errorInfo()


PDOStatement->errorInfo()

(PHP 5 >= 5.1.0, PECL pdo:0.1-1.0.3)

PDOStatement->errorInfo() — Fetch extended error information associated with the last operation on the statement handle

Popis

class PDOStatement {
array errorInfo ( void )
}

Návratové hodnoty

PDOStatement->errorInfo() returns an array of error information about the last operation performed by this statement handle. The array consists of the following fields:

Element | Information
0 | SQLSTATE error code (a five-character alphanumeric identifier defined in the ANSI SQL standard).
1 | Driver-specific error code.
2 | Driver-specific error message.

Příklady

Příklad 1583. Displaying errorInfo() fields for a PDO_ODBC connection to a DB2 database

<?php
/* Provoke an error -- the BONES table does not exist */
$sth = $dbh->prepare('SELECT skull FROM bones');
$sth->execute();

echo "\nPDOStatement::errorInfo():\n";
$arr = $sth->errorInfo();
print_r($arr);
?>

Výše uvedený příklad vypíše:

PDOStatement::errorInfo():
Array
(
    [0] => 42S02
    [1] => -204
    [2] => [IBM][CLI Driver][DB2/LINUX] SQL0204N  "DANIELS.BONES" is an undefined name.  SQLSTATE=42704
)

Viz také

PDO->errorCode()
PDO->errorInfo()
PDOStatement->errorCode()

Předcházející | Nahoru | Další
PDOStatement->errorCode() | Domů | PDOStatement->execute()


PDOStatement->execute()

(PHP 5 >= 5.1.0, PECL pdo:0.1-1.0.3)

PDOStatement->execute() — Executes a prepared statement

Popis

class PDOStatement {
bool execute ( [array $input_parameters] )
}

Execute the prepared statement. If the prepared statement included parameter markers, you must either:

  • call PDOStatement->bindParam() to bind PHP variables to the parameter markers: bound variables pass their value as input and receive the output value, if any, of their associated parameter markers

  • or pass an array of input-only parameter values

Seznam parametrů

input_parameters

An array of values with as many elements as there are bound parameters in the SQL statement being executed.

You cannot bind multiple values to a single parameter; for example, you cannot bind two values to a single named parameter in an IN() clause.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1584. Execute a prepared statement with bound variables

<?php
/* Execute a prepared statement by binding PHP variables */
$calories = 150;
$colour = 'red';
$sth = $dbh->prepare('SELECT name, colour, calories
    FROM fruit
    WHERE calories < :calories AND colour = :colour');
$sth->bindParam(':calories', $calories, PDO::PARAM_INT);
$sth->bindParam(':colour', $colour, PDO::PARAM_STR, 12);
$sth->execute();
?>

Příklad 1585. Execute a prepared statement with an array of insert values (named parameters)

<?php
/* Execute a prepared statement by passing an array of insert values */
$calories = 150;
$colour = 'red';
$sth = $dbh->prepare('SELECT name, colour, calories
    FROM fruit
    WHERE calories < :calories AND colour = :colour');
$sth->execute(array(':calories' => $calories, ':colour' => $colour));
?>

Příklad 1586. Execute a prepared statement with an array of insert values (placeholders)

<?php
/* Execute a prepared statement by passing an array of insert values */
$calories = 150;
$colour = 'red';
$sth = $dbh->prepare('SELECT name, colour, calories
    FROM fruit
    WHERE calories < ? AND colour = ?');
$sth->execute(array($calories, $colour));
?>

Příklad 1587. Execute a prepared statement with question mark placeholders

<?php
/* Execute a prepared statement by binding PHP variables */
$calories = 150;
$colour = 'red';
$sth = $dbh->prepare('SELECT name, colour, calories
    FROM fruit
    WHERE calories < ? AND colour = ?');
$sth->bindParam(1, $calories, PDO::PARAM_INT);
$sth->bindParam(2, $colour, PDO::PARAM_STR, 12);
$sth->execute();
?>

Viz také

PDO->prepare()
PDOStatement->bindParam()
PDOStatement->fetch()
PDOStatement->fetchAll()
PDOStatement->fetchColumn()

Předcházející | Nahoru | Další
PDOStatement->errorInfo() | Domů | PDOStatement->fetch()


PDOStatement->fetch()

(PHP 5 >= 5.1.0, PECL pdo:0.1-1.0.3)

PDOStatement->fetch() — Fetches the next row from a result set

Popis

class PDOStatement {
mixed fetch ( [int $fetch_style [, int $cursor_orientation [, int $cursor_offset]]] )
}

Fetches a row from a result set associated with a PDOStatement object. The fetch_style parameter determines how PDO returns the row.

Seznam parametrů

fetch_style

Controls how the next row will be returned to the caller. This value must be one of the PDO::FETCH_* constants, defaulting to PDO::FETCH_BOTH.

  • PDO::FETCH_ASSOC: returns an array indexed by column name as returned in your result set

  • PDO::FETCH_BOTH (default): returns an array indexed by both column name and 0-indexed column number as returned in your result set

  • PDO::FETCH_BOUND: returns TRUE and assigns the values of the columns in your result set to the PHP variables to which they were bound with the PDOStatement->bindColumn() method

  • PDO::FETCH_CLASS: returns a new instance of the requested class, mapping the columns of the result set to named properties in the class. If fetch_style includes PDO::FETCH_CLASSTYPE (e.g. PDO::FETCH_CLASS | PDO::FETCH_CLASSTYPE) then the name of the class is determined from a value of the first column.

  • PDO::FETCH_INTO: updates an existing instance of the requested class, mapping the columns of the result set to named properties in the class

  • PDO::FETCH_LAZY: combines PDO::FETCH_BOTH and PDO::FETCH_OBJ, creating the object variable names as they are accessed

  • PDO::FETCH_NUM: returns an array indexed by column number as returned in your result set, starting at column 0

  • PDO::FETCH_OBJ: returns an anonymous object with property names that correspond to the column names returned in your result set

cursor_orientation

For a PDOStatement object representing a scrollable cursor, this value determines which row will be returned to the caller. This value must be one of the PDO::FETCH_ORI_* constants, defaulting to PDO::FETCH_ORI_NEXT. To request a scrollable cursor for your PDOStatement object, you must set the PDO::ATTR_CURSOR attribute to PDO::CURSOR_SCROLL when you prepare the SQL statement with PDO->prepare().

offset

For a PDOStatement object representing a scrollable cursor for which the cursor_orientation parameter is set to PDO::FETCH_ORI_ABS, this value specifies the absolute number of the row in the result set that shall be fetched.

For a PDOStatement object representing a scrollable cursor for which the cursor_orientation parameter is set to PDO::FETCH_ORI_REL, this value specifies the row to fetch relative to the cursor position before PDOStatement->fetch() was called.

Návratové hodnoty

The return value of this function on success depends on the fetch type. In all cases, FALSE is returned on failure.

Příklady

Příklad 1588. Fetching rows using different fetch styles

<?php
$sth = $dbh->prepare("SELECT name, colour FROM fruit");
$sth->execute();

/* Exercise PDOStatement::fetch styles */
print("PDO::FETCH_ASSOC: ");
print("Return next row as an array indexed by column name\n");
$result = $sth->fetch(PDO::FETCH_ASSOC);
print_r($result);
print("\n");

print("PDO::FETCH_BOTH: ");
print("Return next row as an array indexed by both column name and number\n");
$result = $sth->fetch(PDO::FETCH_BOTH);
print_r($result);
print("\n");

print("PDO::FETCH_LAZY: ");
print("Return next row as an anonymous object with column names as properties\n");
$result = $sth->fetch(PDO::FETCH_LAZY);
print_r($result);
print("\n");

print("PDO::FETCH_OBJ: ");
print("Return next row as an anonymous object with column names as properties\n");
$result = $sth->fetch(PDO::FETCH_OBJ);
print $result->NAME;
print("\n");
?>

Výše uvedený příklad vypíše:

PDO::FETCH_ASSOC: Return next row as an array indexed by column name
Array
(
    [NAME] => apple
    [COLOUR] => red
)

PDO::FETCH_BOTH: Return next row as an array indexed by both column name and number
Array
(
    [NAME] => banana
    [0] => banana
    [COLOUR] => yellow
    [1] => yellow
)

PDO::FETCH_LAZY: Return next row as an anonymous object with column names as properties
PDORow Object
(
    [NAME] => orange
    [COLOUR] => orange
)

PDO::FETCH_OBJ: Return next row as an anonymous object with column names as properties
kiwi

Příklad 1589. Fetching rows with a scrollable cursor

<?php
function readDataForwards($dbh) {
  $sql = 'SELECT hand, won, bet FROM mynumbers ORDER BY BET';
  try {
    $stmt = $dbh->prepare($sql, array(PDO::ATTR_CURSOR => PDO::CURSOR_SCROLL));
    $stmt->execute();
    while ($row = $stmt->fetch(PDO::FETCH_NUM, PDO::FETCH_ORI_NEXT)) {
      $data = $row[0] . "\t" . $row[1] . "\t" . $row[2] . "\n";
      print $data;
    }
    $stmt = null;
  }
  catch (PDOException $e) {
    print $e->getMessage();
  }
}
function readDataBackwards($dbh) {
  $sql = 'SELECT hand, won, bet FROM mynumbers ORDER BY bet';
  try {
    $stmt = $dbh->prepare($sql, array(PDO::ATTR_CURSOR => PDO::CURSOR_SCROLL));
    $stmt->execute();
    $row = $stmt->fetch(PDO::FETCH_NUM, PDO::FETCH_ORI_LAST);
    do {
      $data = $row[0] . "\t" . $row[1] . "\t" . $row[2] . "\n";
      print $data;
    } while ($row = $stmt->fetch(PDO::FETCH_NUM, PDO::FETCH_ORI_PRIOR));
    $stmt = null;
  }
  catch (PDOException $e) {
    print $e->getMessage();
  }
}

print "Reading forwards:\n";
readDataForwards($conn);

print "Reading backwards:\n";
readDataBackwards($conn);
?>

Výše uvedený příklad vypíše:

Reading forwards:
21    10    5
16    0     5
19    20    10

Reading backwards:
19    20    10
16    0     5
21    10    5

Viz také

PDO->prepare()
PDOStatement->execute()
PDOStatement->fetchAll()
PDOStatement->fetchColumn()
PDOStatement->fetchObject()
PDOStatement->setFetchMode()

Předcházející | Nahoru | Další
PDOStatement->execute() | Domů | PDOStatement->fetchAll()


PDOStatement->fetchAll()

(PHP 5 >= 5.1.0, PECL pdo:0.1-1.0.3)

PDOStatement->fetchAll() — Returns an array containing all of the result set rows

Popis

class PDOStatement {
array fetchAll ( [int $fetch_style [, int $column_index [, array $ctor_args]]] )
}

Seznam parametrů

fetch_style

Controls the contents of the returned array as documented in PDOStatement->fetch(). Defaults to PDO::FETCH_BOTH.

To return an array consisting of all values of a single column from the result set, specify PDO::FETCH_COLUMN. You can specify which column you want with the column-index parameter.

To fetch only the unique values of a single column from the result set, bitwise-OR PDO::FETCH_COLUMN with PDO::FETCH_UNIQUE.

To return an associative array grouped by the values of a specified column, bitwise-OR PDO::FETCH_COLUMN with PDO::FETCH_GROUP.

column_index

Returns the indicated 0-indexed column when the value of fetch_style is PDO::FETCH_COLUMN. Defaults to 0.

ctor_args

Arguments of custom class constructor.

Návratové hodnoty

PDOStatement->fetchAll() returns an array containing all of the remaining rows in the result set. The array represents each row as either an array of column values or an object with properties corresponding to each column name.

Using this method to fetch large result sets will result in a heavy demand on system and possibly network resources. Rather than retrieving all of the data and manipulating it in PHP, consider using the database server to manipulate the result sets. For example, use the WHERE and SORT BY clauses in SQL to restrict results before retrieving and processing them with PHP.

Příklady

Příklad 1590. Fetch all remaining rows in a result set

<?php
$sth = $dbh->prepare("SELECT name, colour FROM fruit");
$sth->execute();

/* Fetch all of the remaining rows in the result set */
print("Fetch all of the remaining rows in the result set:\n");
$result = $sth->fetchAll();
print_r($result);
?>

Výše uvedený příklad vypíše:

Fetch all of the remaining rows in the result set:
Array
(
    [0] => Array
        (
            [NAME] => pear
            [0] => pear
            [COLOUR] => green
            [1] => green
        )

    [1] => Array
        (
            [NAME] => watermelon
            [0] => watermelon
            [COLOUR] => pink
            [1] => pink
        )

)

Příklad 1591. Fetching all values of a single column from a result set

The following example demonstrates how to return all of the values of a single column from a result set, even though the SQL statement itself may return multiple columns per row.

<?php
$sth = $dbh->prepare("SELECT name, colour FROM fruit");
$sth->execute();

/* Fetch all of the values of the first column */
$result = $sth->fetchAll(PDO::FETCH_COLUMN, 0);
var_dump($result);
?>

Výše uvedený příklad vypíše:

Array(3)
(
    [0] =>
    string(5) => apple
    [1] =>
    string(4) => pear
    [2] =>
    string(10) => watermelon
)

Příklad 1592. Grouping all values by a single column

The following example demonstrates how to return an associative array grouped by the values of the specified column in the result set. The array contains three keys: values apple and pear are returned as arrays that contain two different colours, while watermelon is returned as an array that contains only one colour.

<?php
$insert = $dbh->prepare("INSERT INTO fruit(name, colour) VALUES (?, ?)");
$insert->execute('apple', 'green');
$insert->execute('pear', 'yellow');

$sth = $dbh->prepare("SELECT name, colour FROM fruit");
$sth->execute();

/* Group values by the first column */
var_dump($sth->fetchAll(PDO::FETCH_COLUMN|PDO::FETCH_GROUP));
?>

Výše uvedený příklad vypíše:

array(3) {
  ["apple"]=>
  array(2) {
    [0]=>
    string(5) "green"
    [1]=>
    string(3) "red"
  }
  ["pear"]=>
  array(2) {
    [0]=>
    string(5) "green"
    [1]=>
    string(6) "yellow"
  }
  ["watermelon"]=>
  array(1) {
    [0]=>
    string(5) "green"
  }
}

Viz také

PDO->query()
PDOStatement->fetch()
PDOStatement->fetchColumn()
PDO->prepare()
PDOStatement->setFetchMode()

Předcházející | Nahoru | Další
PDOStatement->fetch() | Domů | PDOStatement->fetchColumn()


PDOStatement->rowCount()

(PHP 5 >= 5.1.0, PECL pdo:0.1-1.0.3)

PDOStatement->rowCount() — Returns the number of rows affected by the last SQL statement

Popis

class PDOStatement {
int rowCount ( void )
}

PDOStatement->rowCount() returns the number of rows affected by the last DELETE, INSERT, or UPDATE statement executed by the corresponding PDOStatement object.

If the last SQL statement executed by the associated PDOStatement was a SELECT statement, some databases may return the number of rows returned by that statement. However, this behaviour is not guaranteed for all databases and should not be relied on for portable applications.

Návratové hodnoty

Returns the number of rows.

Příklady

Příklad 1596. Return the number of deleted rows

PDOStatement->rowCount() returns the number of rows affected by a DELETE, INSERT, or UPDATE statement.

<?php
/* Delete all rows from the FRUIT table */
$del = $dbh->prepare('DELETE FROM fruit');
$del->execute();

/* Return number of rows that were deleted */
print("Return number of rows that were deleted:\n");
$count = $del->rowCount();
print("Deleted $count rows.\n");
?>

Výše uvedený příklad vypíše:

Deleted 9 rows.

Příklad 1597. Counting rows returned by a SELECT statement

For most databases, PDOStatement->rowCount() does not return the number of rows affected by a SELECT statement. Instead, use PDO->query() to issue a SELECT COUNT(*) statement with the same predicates as your intended SELECT statement, then use PDOStatement->fetchColumn() to retrieve the number of rows that will be returned. Your application can then perform the correct action.

<?php
$sql = "SELECT COUNT(*) FROM fruit WHERE calories > 100";
if ($res = $conn->query($sql)) {

    /* Check the number of rows that match the SELECT statement */
  if ($res->fetchColumn() > 0) {

        /* Issue the real SELECT statement and work with the results */
         $sql = "SELECT name FROM fruit WHERE calories > 100";
       foreach ($conn->query($sql) as $row) {
           print "Name: " .  $row['NAME'] . "\n";
         }
    }
    /* No rows matched -- do something else */
  else {
      print "No rows matched the query.";
    }
}

$res = null;
$conn = null;
?>

Výše uvedený příklad vypíše:

apple
banana
orange
pear

Viz také

PDOStatement->columnCount()
PDOStatement->fetchColumn()
PDO->query()

Předcházející | Nahoru | Další
PDOStatement->nextRowset() | Domů | PDOStatement->setAttribute()


Funkce pro práci s Verisign Payflow Pro

Předcházející VI. Reference funkcí Další

CLXXII. Funkce pro práci s Verisign Payflow Pro

Úvod

Toto rozšíření umožňuje zpracovávat kreditní karty a provádět jiné finanční transakce pomocí Verisign Payment Services (dříve Signio, » http://www.verisign.com/products-services/payment-processing/online-payment/payflow-pro/index.html).

Při využívání těchto funkcí můžete vynechat volání pfpro_init() a pfpro_cleanup(), tato extenze to udělá podle potřeby automaticky. Tyto funkce jsou ale přesto dostupné pro případ, že byste potřebovali zpracovávat velké množství transakcí a vyžadovali naprostou kontrolu nad touto knihovnou. Mezi pfpro_init() a pfpro_cleanup() můžete provést libovolné množství transakcí.

Tyto funkce byly přidány v PHP 4.0.2.

Poznámka: Tyto funkce poskytují pouze spojení s Verisign Payment Services. Kompletní detaily vyžadovaných parametrů viz Payflow Pro Developer's Guide.

Poznámka: Toto rozšíření není k dispozici na platformách Windows.

Požadavky

Budete potřebovat SDK pro vaši platformu, který se dá po registraci stáhnout z » manažerského rozhraní. Pokud se chystáte používat toto rozšíření s webovým serverem s povoleným SSL nebo s jinými SSL komponentami (jako je rozšíření CURL+SSL), musíte stáhnout beta verzi SDK.

Pokud jste si stáhli SDK, zkopírujte následující soubory z lib adresáře této distribuce: pfpro.h do /usr/local/include a libpfpro.so do /usr/local/lib.

Instalace

Tyto funkce jsou dostupné pouze pokud bylo PHP zkompilováno s volbou --with-pfpro[=DIR].

Konfigurace běhu

Chování těchto funkcí je ovlivněno nastavením parametrů v php.ini.

Tabulka 315. Konfigurační volby pro Verisign Payflow Pro

Název | Výchozí hodnota | Lze změnit
pfpro.defaulthost/PFPRO_VERSION < 3 | "test.signio.com" | PHP_INI_ALL
pfpro.defaulthost | "test-payflow.verisign.com" | PHP_INI_ALL
pfpro.defaultport | "443" | PHP_INI_ALL
pfpro.defaulttimeout | "30" | PHP_INI_ALL
pfpro.proxyaddress | "" | PHP_INI_ALL
pfpro.proxyport | "" | PHP_INI_ALL
pfpro.proxylogon | "" | PHP_INI_ALL
pfpro.proxypassword | "" | PHP_INI_ALL

Pro bližší podrobnosti a definici PHP_INI_* konstant viz ini_set().

Typy prostředků

Toto rozšíření nemá definován žádný typ prostředku (resource).

Předdefinované konstanty

Toto rozšíření nemá definovány žádné konstanty.

Obsah

pfpro_cleanup — Zavřít Payflow Pro knihovnu
pfpro_init — Inicializovat Payflow Pro knihovnu
pfpro_process_raw — Zpracovat raw transakci s Payflow Pro
pfpro_process — Zpracovat transakci s Payflow Pro
pfpro_version — Vrátit verzi Payflow Pro knihovny
Předcházející | Nahoru | Další
var_export | Domů | pfpro_cleanup


pfpro_cleanup

(PHP 4 >= 4.0.2, PHP 5 <= 5.0.5)

pfpro_cleanup — Zavřít Payflow Pro knihovnu

Popis

bool pfpro_cleanup ( void )

pfpro_cleanup() se používá k čistému vypnutí Payflow Pro knihovny. Měla by se volat po provedení všech transakcí a před ukončením skriptu. Tuto funkci nicméně volat nemusíte, tato extenze automaticky zavolá pfpro_cleanup() při ukončení skriptu.

Viz také pfpro_init().

Předcházející | Nahoru | Další
CLXXII. Funkce pro práci s Verisign Payflow Pro | Domů | pfpro_init


pfpro_init

(PHP 4 >= 4.0.2, PHP 5 <= 5.0.5)

pfpro_init — Inicializovat Payflow Pro knihovnu

Popis

bool pfpro_init ( void )

pfpro_init() se používá k inicializaci Payflow Pro knihovny. Tuto funkci volat nemusíte, tato extenze automaticky zavolá pfpro_init() před první transakcí.

Viz také pfpro_cleanup().

Předcházející | Nahoru | Další
pfpro_cleanup | Domů | pfpro_process_raw


pfpro_process_raw

(PHP 4 >= 4.0.2, PHP 5 <= 5.0.5)

pfpro_process_raw — Zpracovat raw transakci s Payflow Pro

Popis

string pfpro_process_raw ( string $parameters [, string $address [, int $port [, int $timeout [, string $proxy_address [, int $proxy_port [, string $proxy_logon [, string $proxy_password]]]]]]] )

Vrací řetězec obsahující odpověď.

pfpro_process_raw() zpracuje raw řetězec transakce s Payflow Pro. Opravdu byste ale měli používat pfpro_process(), protože pravidla kódování těchto transakcí jsou nestandardní.

První argument je v tomto případě řetězec obsahující raw požadavek na transakci. Všechny ostatní argumenty jsou stejné jako u pfpro_process(). Návratová hodnota je řetězec obsahující raw odpověď.

Poznámka: Kompletní detaily vyžadovaných parametrů a pravidel kódování viz Payflow Pro Developer's Guide. Dobře vám radíme, používejte radši pfpro_process().

Příklad 2365. Ukázka Payflow Pro raw

<?php

pfpro_init();

$response = pfpro_process("USER=mylogin&PWD[5]=m&ndy&TRXTYPE=S&TENDER=C&AMT=1.50&ACCT=4111111111111111&EXPDATE=0904");

if (!$response) {
  die("Nepodařilo se spojit s Verisign.\n");
}

echo "Raw odpověď Verisignu byla ".$response;

pfpro_cleanup();

?>

Předcházející | Nahoru | Další
pfpro_init | Domů | pfpro_process


pfpro_process

(PHP 4 >= 4.0.2, PHP 5 <= 5.0.5)

pfpro_process — Zpracovat transakci s Payflow Pro

Popis

array pfpro_process ( array $parameters [, string $address [, int $port [, int $timeout [, string $proxy_address [, int $proxy_port [, string $proxy_logon [, string $proxy_password]]]]]]] )

Vrací asociativní pole obsahující odpověď.

pfpro_process() zpracuje transakci s Payflow Pro. První argument je asociativní pole obsahující klíče a hodnoty, které se zakódují a odešlou zpracovateli.

Druhý argument je volitelný a určuje serveer, ke kterému se připojit. Default je "test.signio.com", takže pokud chcete zpracovávat skutečné transakce, budete chtít tento argument nastavit na "connect.signio.com".

Třetí argument určuje port, ke kterému se připojit. Default je 443, standardní SSL port.

Čtvrtý argument určuje v sekundách, jaký časový limit se má použít. Default je 30 sekund. Tento časový limit vstupuje v platnost v okamžiku spojení se zpracovatelem, a tak by váš skript mohl potenciálně běžet velmi dlouhou dobu, pokud by nastaly problémy s DNS nebo sítí.

Pátý argument určuje hostname vaší případné SSL proxy. Šestý argument specifikuje port.

Sedmý a osmý argument určují přihlašovací jméno a heslo na tuto proxy.

Tato funkce vrací asociativní pole klíčů a hodnot odpovědi.

Poznámka: Kompletní detaily vyžadovaných parametrů viz Payflow Pro Developer's Guide.

Příklad 2366. Ukázka Payflow Pro

<?php

pfpro_init();

$transaction = array(USER    => 'login',
             PWD    => 'heslo',
             TRXTYPE    => 'S',
             TENDER    => 'C',
             AMT    => 1.50,
             ACCT    => '4111111111111111',
             EXPDATE    => '0904'
             );

$response = pfpro_process($transaction);

if (!$response) {
  die("Nepodařilo se spojit s Verisign.\n");
}

echo "Response kód Verisignu byl ".$response[RESULT];
echo ", což znamená: ".$response[RESPMSG]."\n";

echo "\nPožadavek na transakci: ";
print_r($transaction);

echo "\nOdpověď: ";
print_r($response);

pfpro_cleanup();

?>

Předcházející | Nahoru | Další
pfpro_process_raw | Domů | pfpro_version


pfpro_version

(PHP 4 >= 4.0.2, PHP 5 <= 5.0.5)

pfpro_version — Vrátit verzi Payflow Pro knihovny

Popis

string pfpro_version ( void )

pfpro_version() vrací řetězec obsahující verzi Payflow Pro knihovny. V čase psaní tohoto manuálu to bylo L211.

Předcházející | Nahoru | Další
pfpro_process | Domů | CLXXIII. vpopmail Functions


PHP volby a informace

Předcházející VI. Reference funkcí Další

CXXIV. PHP volby a informace

Úvod

Tyto funkce vám umožňují zjistit řadu informací o vlastním PHP, jako je konfigurace, nahraná rozšíření, verze a mnohé další. Naleznete zde také funkce, které vám umožňí nastavit volby běžícího PHP. Pravděporobně nejznámější funkce PHP - phpinfo() - se nachází právě v této sekci.

Požadavky

Tyto funkce jsou k dispozici jako součást standardního modulu, který je vždy dostupný.

Instalace

K používání těchto funkcí není třeba žádná instalace, jsou součástí jádra PHP.

Konfigurace běhu

Chování těchto funkcí je ovlivněno nastavením parametrů v php.ini.

Tabulka 248. PHP Options/Inf Configuration Options

Name | Default | Changeable | Changelog
assert.active | "1" | PHP_INI_ALL |
assert.bail | "0" | PHP_INI_ALL |
assert.warning | "1" | PHP_INI_ALL |
assert.callback | NULL | PHP_INI_ALL |
assert.quiet_eval | "0" | PHP_INI_ALL |
enable_dl | "1" | PHP_INI_SYSTEM | Removed in PHP 6.0.0.
max_execution_time | "30" | PHP_INI_ALL |
max_input_time | "-1" | PHP_INI_PERDIR | Available since PHP 4.3.0.
max_input_nesting_level | "64" | PHP_INI_PERDIR | Available since PHP 4.4.8. Removed in PHP 5.0.0.
magic_quotes_gpc | "1" | PHP_INI_PERDIR | PHP_INI_ALL in PHP <= 4.2.3. Removed in PHP 6.0.0.
magic_quotes_runtime | "0" | PHP_INI_ALL | Removed in PHP 6.0.0.

Pro další detaily a definice konstant PHP_INI_*, viz dokumentace k ini_set().

Zde je stručný popis konfiguračních direktiv.

assert.active boolean

Enable assert() evaluation.

assert.bail boolean

Terminate script execution on failed assertions.

assert.warning boolean

Issue a PHP warning for each failed assertion.

assert.callback string

user function to call on failed assertions

assert.quiet_eval boolean

Use the current setting of error_reporting() during assertion expression evaluation. If enabled, no errors are shown (implicit error_reporting(0)) while evaluation. If disabled, errors are shown according to the settings of error_reporting()

enable_dl boolean

This directive is really only useful in the Apache module version of PHP. You can turn dynamic loading of PHP extensions with dl() on and off per virtual server or per directory.

The main reason for turning dynamic loading off is security. With dynamic loading, it's possible to ignore all open_basedir restrictions. The default is to allow dynamic loading, except when using bezpečný režim. In bezpečný režim, it's always impossible to use dl().

max_execution_time integer

This sets the maximum time in seconds a script is allowed to run before it is terminated by the parser. This helps prevent poorly written scripts from tying up the server. The default setting is 30.

The maximum execution time is not affected by system calls, stream operations etc. Please see the set_time_limit() function for more details.

You can not change this setting with ini_set() when running in bezpečný režim. The only workaround is to turn off safe mode or by changing the time limit in the php.ini.

Your web server can have other timeouts. E.g. Apache has Timeout directive, IIS has CGI timeout function, both default to 300 seconds. See the web server documentation for meaning of it.

max_input_time integer

This sets the maximum time in seconds a script is allowed to parse input data, like POST, GET and file uploads.

max_input_nesting_level integer

Sets the max nesting dept of input variables (i.e. $_GET, $_POST..)

magic_quotes_gpc boolean
Varování

This feature is DEPRECATED and REMOVED as of PHP 6.0.0. Relying on this feature is highly discouraged.

Sets the magic_quotes state for GPC (Get/Post/Cookie) operations. When magic_quotes are on, all ' (single-quote), " (double quote), \ (backslash) and NUL's are escaped with a backslash automatically.

Poznámka: In PHP 4, also $_ENV variables are escaped.

Poznámka: If the magic_quotes_sybase directive is also ON it will completely override magic_quotes_gpc. Having both directives enabled means only single quotes are escaped as ''. Double quotes, backslashes and NUL's will remain untouched and unescaped.

See also get_magic_quotes_gpc()

magic_quotes_runtime boolean
Varování

This feature is DEPRECATED and REMOVED as of PHP 6.0.0. Relying on this feature is highly discouraged.

If magic_quotes_runtime is enabled, most functions that return data from any sort of external source including databases and text files will have quotes escaped with a backslash. If magic_quotes_sybase is also on, a single-quote is escaped with a single-quote instead of a backslash.

Typy prostředků

Toto rozšíření nemá definován žádný typ prostředku (resource).

Předdefinované konstanty

Konstanty z tohoto seznamu jsou vždy dostupné jako součást jádra PHP.

Tabulka 249. Pre-defined phpcredits() constants

Constant | Value | Description
CREDITS_GROUP | 1 | A list of the core developers
CREDITS_GENERAL | 2 | General credits: Language design and concept, PHP authors and SAPI module.
CREDITS_SAPI | 4 | A list of the server API modules for PHP, and their authors.
CREDITS_MODULES | 8 | A list of the extension modules for PHP, and their authors.
CREDITS_DOCS | 16 | The credits for the documentation team.
CREDITS_FULLPAGE | 32 | Usually used in combination with the other flags. Indicates that a complete stand-alone HTML page needs to be printed including the information indicated by the other flags.
CREDITS_QA | 64 | The credits for the quality assurance team.
CREDITS_ALL | -1 | All the credits, equivalent to using: CREDITS_DOCS + CREDITS_GENERAL + CREDITS_GROUP + CREDITS_MODULES + CREDITS_QA CREDITS_FULLPAGE. It generates a complete stand-alone HTML page with the appropriate tags. This is the default value.

Tabulka 250. phpinfo() constants

Constant | Value | Description
INFO_GENERAL | 1 | The configuration line, php.ini location, build date, Web Server, System and more.
INFO_CREDITS | 2 | PHP Credits. See also phpcredits().
INFO_CONFIGURATION | 4 | Current Local and Master values for PHP directives. See also ini_get().
INFO_MODULES | 8 | Loaded modules and their respective settings.
INFO_ENVIRONMENT | 16 | Environment Variable information that's also available in $_ENV.
INFO_VARIABLES | 32 | Shows all predefined variables from EGPCS (Environment, GET, POST, Cookie, Server).
INFO_LICENSE | 64 | PHP License information. See also the » license faq.
INFO_ALL | -1 | Shows all of the above. This is the default value.

ASSERT_ACTIVE (integer)
ASSERT_CALLBACK (integer)
ASSERT_BAIL (integer)
ASSERT_WARNING (integer)
ASSERT_QUIET_EVAL (integer)

Obsah

assert_options — Nastavit/získat různé příznaky výroků
assert — Ověřit, jestli je výrok neplatný
dl — Načíst extenzi PHP za běhu
extension_loaded — zjistit, jestli je extenze načtená
get_cfg_var — Získat hodnotu volby z konfigurace PHP
get_current_user — Získat jméno vlastníka současného PHP skriptu
get_defined_constants — Returns an associative array with the names of all the constants and their values
get_extension_funcs — Vrátit pole jmen funkcí určitého modulu
get_include_path — Gets the current include_path configuration option
get_included_files — Vrátit pole jmen všech souborů, které byly ve skriptu načteny pomocí include_once()
get_loaded_extensions — Vrátit pole se jmény všech zkompilovaných a načtených modulů (extenzí)
get_magic_quotes_gpc — Získat současné aktivní nastavení magic_quotes_gpc
get_magic_quotes_runtime — Vrátit současné aktivní nastavení magic_quotes_runtime
get_required_files — Vrátit pole jmen všech souborů, které byly v určitém skriptu načteny pomocí require_once()
getenv — Získat hodnotu systémové proměnné
getlastmod — Získat čas poslení modifikace skriptu
getmygid — Get PHP script owner's GID
getmyinode — Získat inode současného skriptu
getmypid — Získat process ID PHP
getmyuid — Získat UID majitele PHP skriptu
getopt — Gets options from the command line argument list
getrusage — Získat informace o současném využití zdrojů
ini_alter — Změnit hodnotu konfigurační volby
ini_get_all — Gets all configuration options
ini_get — Získat hodnotu konfigurační volby
ini_restore — Obnovit původní hodnotu konfigurační volby
ini_set — Změnit hodnotu konfigurační volby
main — Dummy for main()
memory_get_peak_usage — Returns the peak of memory allocated by PHP
memory_get_usage — Returns the amount of memory allocated to PHP
php_ini_scanned_files — Return a list of .ini files parsed from the additional ini dir
php_logo_guid — Get the logo guid
php_sapi_name — Vrátit typ rozhraní mezi web serverem a PHP Returns the type of interface between web server and PHP
php_uname — Vrátit informaci o operačním systému, na kterém bylo PHP zkompilováno
phpcredits — Vytisknout credits pro PHP
phpinfo — Vytisknout spoustu informací o PHP
phpversion — Získat současnou verzi PHP
putenv — Nastavit hodnotu systémové proměnné
restore_include_path — Restores the value of the include_path configuration option
set_include_path — Sets the include_path configuration option
set_magic_quotes_runtime — Nastavit současnou aktivní hodnotu magic_quotes_runtime
set_time_limit — Omezit maximální dobu průběhu skriptu
sys_get_temp_dir — Returns directory path used for temporary files
version_compare — Compares two "PHP-standardized" version number strings
zend_logo_guid — Získat zend guid
zend_thread_id — Returns a unique identifier for the current thread
zend_version — Gets the version of the current Zend engine
Předcházející | Nahoru | Další
PharFileInfo->setUncompressed | Domů | assert_options


assert_options

(PHP 4, PHP 5)

assert_options — Nastavit/získat různé příznaky výroků

Popis

mixed assert_options ( int $what [, mixed $value] )

S použitím funkce assert_options() můžete nastavit různé řídící volby funkce assert(), nebo jen získat jejich současné nastavení.

Tabulka 251. Volby výroků

volba | ini parametr | výchozí hodnota | popis
ASSERT_ACTIVE | assert.active | 1 | zapne assert() vyhodnocování
ASSERT_WARNING | assert.warning | 1 | vytvoří PHP varování pro každý selhavší výrok
ASSERT_BAIL | assert.bail | 0 | ukončí provádění skiptu, pokud výrok selže
ASSERT_QUIET_EVAL | assert.quiet_eval | 0 | vypne error_reporting během vyhodnocování výrazů výroků
ASSERT_CALLBACK | assert_callback | (NULL) | uživatelská funkce, která se zavolá pro každý selhavší výrok

assert_options() vrací původní nastavení volby, nebo FALSE při chybě.

Předcházející | Nahoru | Další
CXXIV. PHP volby a informace | Domů | assert


assert

(PHP 4, PHP 5)

assert — Ověřit, jestli je výrok neplatný

Popis

bool assert ( mixed $assertion )

assert() ověří předanou assertion a provede příslušnou akci, pokud je výsledek FALSE.

Pokud je předaná assertion řetězec, vyhodnotí se funkcí assert() jako PHP kód. Výhody řetězcové assertion jsou menší režie, když je kontrola výroků vypnutá, a zprávy obsahující assertion výraz, když výrok selže.

Kontrola výroků by se měla používat jen pro odlaďování skriptů. Můžete je použít na kontrolu podmínek, které by měly být vždycky TRUE, a které jinak indikují nějaké chyby v programování, nebo na kontrolu existence určitých vlastností, jako jsou funkce obsažené v extenzích, nebo určité systémové limity a vlastnosti.

Výroky by se neměly používat pro běžné operace jako kontrola vstupních parametrů. Jako základní pravidlo platí, že váž kód by měl fungovat správně, pokud není kontrola výroků aktivována.

Chování funkce assert() lze konfigurovat skrze assert_options() nebo .ini direktivy popsané na manuálové stránce této funkce.

Předcházející | Nahoru | Další
assert_options | Domů | dl


dl

(PHP 4, PHP 5)

dl — Načíst extenzi PHP za běhu

Popis

int dl ( string $library )

Načte extenzi PHP definovanou v library. Viz také konfigurační direktivu extension_dir.

Předcházející | Nahoru | Další
assert | Domů | extension_loaded


extension_loaded

(PHP 4, PHP 5)

extension_loaded — zjistit, jestli je extenze načtená

Popis

bool extension_loaded ( string $name )

Vrací TRUE, pokud je extenze identifikovaná argumentem name načtena. Názvy různých extenzí můžete vidět, pokud použijete phpinfo().

Viz také phpinfo().

Poznámka: Tato funkce byla přidána v PHP 3.0.10.

Předcházející | Nahoru | Další
dl | Domů | get_cfg_var


get_cfg_var

(PHP 4, PHP 5)

get_cfg_var — Získat hodnotu volby z konfigurace PHP

Popis

string get_cfg_var ( string $varname )

Vrátí současnou hodnotu konfigurační proměnné PHP určené argumentem varname, nebo FALSE pokud dojde k chybě.

Nevrací konfigurační hodnoty nastavené při kompilaci PHP a nečte konfigurační soubor Apache (použití php3_configuration_option direktiv).

Pokud chcete zjistit, jestli daný systém používá konfigurační soubor, zkuste získat hodnotu konfigurační volby cfg_file_path. Pokud je tato dostupná, používá se konfigurační soubor.

Předcházející | Nahoru | Další
extension_loaded | Domů | get_current_user


get_current_user

(PHP 4, PHP 5)

get_current_user — Získat jméno vlastníka současného PHP skriptu

Popis

string get_current_user ( void )

Vrátí jméno vlastníka současného PHP skriptu.

Viz také getmyuid(),
getmypid(), getmyinode(),
a getlastmod().

Předcházející | Nahoru | Další
get_cfg_var | Domů | get_defined_constants


get_defined_constants

(PHP 4 >= 4.0.7, PHP 5)

get_defined_constants — Returns an associative array with the names of all the constants and their values

Popis

array get_defined_constants ( [mixed $categorize] )

Returns the names and values of all the constants currently defined. This includes those created by extensions as well as those created with the define() function.

Seznam parametrů

categorize

May be passed, causing this function to return a multi-dimensional array with categories in the keys of the first dimension and constants and their values in the second dimension.

<?php
define("MY_CONSTANT", 1);
print_r(get_defined_constants(true));
?>

Výše uvedený příklad vypíše něco jako:

Array
(
    [internal] => Array
        (
            [E_ERROR] => 1
            [E_WARNING] => 2
            [E_PARSE] => 4
            [E_NOTICE] => 8
            [E_CORE_ERROR] => 16
            [E_CORE_WARNING] => 32
            [E_COMPILE_ERROR] => 64
            [E_COMPILE_WARNING] => 128
            [E_USER_ERROR] => 256
            [E_USER_WARNING] => 512
            [E_USER_NOTICE] => 1024
            [E_ALL] => 2047
            [TRUE] => 1
        )

    [pcre] => Array
        (
            [PREG_PATTERN_ORDER] => 1
            [PREG_SET_ORDER] => 2
            [PREG_OFFSET_CAPTURE] => 256
            [PREG_SPLIT_NO_EMPTY] => 1
            [PREG_SPLIT_DELIM_CAPTURE] => 2
            [PREG_SPLIT_OFFSET_CAPTURE] => 4
            [PREG_GREP_INVERT] => 1
        )

    [user] => Array
        (
            [MY_CONSTANT] => 1
        )

)

Poznámka: The value of the categorize parameter is irrelevant, only its presence is considered.

Návratové hodnoty

ChangeLog (záznam změn)

Verze | Popis
5.0.0 | The categorize parameter was added.

Příklady

Příklad 1635. get_defined_constants() Example

<?php
print_r(get_defined_constants());
?>

Výše uvedený příklad vypíše něco jako:

Array
(
    [E_ERROR] => 1
    [E_WARNING] => 2
    [E_PARSE] => 4
    [E_NOTICE] => 8
    [E_CORE_ERROR] => 16
    [E_CORE_WARNING] => 32
    [E_COMPILE_ERROR] => 64
    [E_COMPILE_WARNING] => 128
    [E_USER_ERROR] => 256
    [E_USER_WARNING] => 512
    [E_USER_NOTICE] => 1024
    [E_ALL] => 2047
    [TRUE] => 1
)

Viz také

defined()
get_loaded_extensions()
get_defined_functions()
get_defined_vars()

Předcházející | Nahoru | Další
get_current_user | Domů | get_extension_funcs


get_extension_funcs

(PHP 4, PHP 5)

get_extension_funcs — Vrátit pole jmen funkcí určitého modulu

Popis

array get_extension_funcs ( string $module_name )

Tato funkce vrací jména všech funkcí definovaných v modulu určeném argumentem module_name.

Například následující řádky

print_r (get_extension_funcs ("xml"));
print_r (get_extension_funcs ("gd"));
vytisknou seznam všech funkcí v modulech xml a gd.

Viz také: get_loaded_extensions()

Předcházející | Nahoru | Další
get_defined_constants | Domů | get_include_path


get_include_path

(PHP 4 >= 4.3.0, PHP 5)

get_include_path — Gets the current include_path configuration option

Popis

string get_include_path ( void )

Gets the current include_path configuration option value.

Návratové hodnoty

Returns the path, as a string.

Příklady

Příklad 1636. get_include_path() example

<?php
// Works as of PHP 4.3.0
echo get_include_path();

// Works in all PHP versions
echo ini_get('include_path');
?>

Viz také

ini_get()
restore_include_path()
set_include_path()
include()

Předcházející | Nahoru | Další
get_extension_funcs | Domů | get_included_files


get_included_files

(PHP 4, PHP 5)

get_included_files — Vrátit pole jmen všech souborů, které byly ve skriptu načteny pomocí include_once()

Popis

array get_included_files ( void )

Tato funkce vrátí asociativní pole jmen všech souborů, které byly načteny do skriptu pomocí include_once(). Indexy tohoto pole jsou názvy souborů použitých v include_once() bez přípony ".php".

Poznámka: Od verze PHP 4.0.1pl2 tato funkce předpokládá, že soubory v include_once končí příponou ".php", jiné přípony nefungují.

Viz také: require_once(),
include_once(),
get_required_files()

Předcházející | Nahoru | Další
get_include_path | Domů | get_loaded_extensions


get_loaded_extensions

(PHP 4, PHP 5)

get_loaded_extensions — Vrátit pole se jmény všech zkompilovaných a načtených modulů (extenzí)

Popis

array get_loaded_extensions ( void )

Tato funkce vrací jména všech modulů (extenzí) zkompilovaných a načtených do PHP interpretru.

Například následující řádek

print_r (get_loaded_extensions());
vypíše seznam podobný tomuto:
Array
(
    [0] => xml
    [1] => wddx
    [2] => standard
      [3] => session
      [4] => posix
      [5] => pgsql
      [6] => pcre
      [7] => gd
      [8] => ftp
      [9] => db
      [10] => Calendar
      [11] => bcmath
)

Viz také: get_extension_funcs().

Předcházející | Nahoru | Další
get_included_files | Domů | get_magic_quotes_gpc


get_magic_quotes_gpc

(PHP 4, PHP 5)

get_magic_quotes_gpc — Získat současné aktivní nastavení magic_quotes_gpc

Popis

int get_magic_quotes_gpc ( void )

Vrátí současné aktivní nastavení magic_quotes_gpc. (0 pro vypnuto, 1 pro zapnuto).

Viz také get_magic_quotes_runtime(), set_magic_quotes_runtime().

Předcházející | Nahoru | Další
get_loaded_extensions | Domů | get_magic_quotes_runtime


get_magic_quotes_runtime

(PHP 4, PHP 5)

get_magic_quotes_runtime — Vrátit současné aktivní nastavení magic_quotes_runtime

Popis

int get_magic_quotes_runtime ( void )

Vrátí současné aktivní nastavení magic_quotes_runtime. (0 pro vypnuto, 1 pro zapnuto).

Viz také get_magic_quotes_gpc(), set_magic_quotes_runtime().

Předcházející | Nahoru | Další
get_magic_quotes_gpc | Domů | get_required_files


get_required_files

(PHP 4, PHP 5)

get_required_files — Vrátit pole jmen všech souborů, které byly v určitém skriptu načteny pomocí require_once()

Popis

array get_required_files ( void )

Tato funkce vrátí asociativní pole jmen všech souborů, které byly načteny do probíhajícího skriptu pomocí require_once(). Indexy tohoto pole jsou názvy souborů použitých v require_once() bez přípony ".php".

Následující příklad

Příklad 1637. Tisk require()ovaných a include()ovaných souborů

<?php

require_once ("local.php");
require_once ("../inc/global.php");

for ($i=1; $i<5; $i++)
  include "util".$i."php";

  echo "Required_once files\n";
  print_r (get_required_files());

  echo "Included_once files\n";
  print_r (get_included_files());
?>

vygeneruje následující výstup:
Required_once files
Array
(
  [local] => local.php
  [../inc/global] => /full/path/to/inc/global.php
)

Included_once files
Array
(
    [util1] => util1.php
    [util2] => util2.php
    [util3] => util3.php
    [util4] => util4.php
)

Poznámka: Od verze PHP 4.0.1pl2 tato funkce předpokládá, že soubory v required_once končí příponou ".php", jiné přípony nefungují.

Viz také: require_once(),
include_once(),
get_included_files()

Předcházející | Nahoru | Další
get_magic_quotes_runtime | Domů | getenv


getenv

(PHP 4, PHP 5)

getenv — Získat hodnotu systémové proměnné

Popis

string getenv ( string $varname )

Vrátí hodnotu systémové proměnné varname, nebo FALSE při chybě.

$ip = getenv ("REMOTE_ADDR"); // získá IP adresu uživatele

Seznam všech systémových proměnných si můžete prohlédnout použitím phpinfo(). Význam mnoha z nich najdete v » CGI specifikaci, zvláště na » stránce o systémových proměnných.

Poznámka: Tato funkce nefunguje v ISAPI módu.

Předcházející | Nahoru | Další
get_required_files | Domů | getlastmod


getlastmod

(PHP 4, PHP 5)

getlastmod — Získat čas poslení modifikace skriptu

Popis

int getlastmod ( void )

Vrátí čas poslení modifikace současné stránky. Návratová hodnota je Unixový timestamp, vhodný jako vstup pro date(). Při chybě vrací FALSE.

Příklad 1638. getlastmod() příklad

// outputs e.g. 'Last modified: March 04 1998 20:43:59.'
echo "Last modified: ".date ("F d Y H:i:s.", getlastmod());

See alse date(),
getmyuid(),
get_current_user(),
getmyinode(), and
getmypid().

Předcházející | Nahoru | Další
getenv | Domů | getmygid


getmygid

(PHP 4 >= 4.0.7, PHP 5)

getmygid — Get PHP script owner's GID

Popis

int getmygid ( void )

Gets the group ID of the current script.

Návratové hodnoty

Returns the group ID of the current script, or FALSE on error.

Viz také

getmyuid()
getmypid()
get_current_user()
getmyinode()
getlastmod()

Předcházející | Nahoru | Další
getlastmod | Domů | getmyinode


getmyinode

(PHP 4, PHP 5)

getmyinode — Získat inode současného skriptu

Popis

int getmyinode ( void )

Vrátí inode současného skriptu, nebo FALSE při chybě.

Viz také getmyuid(),
get_current_user(),
getmypid(), and
getlastmod().

Poznámka: Tato funkce není podporována na Windows systémech.

Předcházející | Nahoru | Další
getmygid | Domů | getmypid


getmypid

(PHP 4, PHP 5)

getmypid — Získat process ID PHP

Popis

int getmypid ( void )

Vrátí process ID současného PHP procesu, nebo FALSE při chybě.

Varování

Process ID nejsou unikátní, a jsou tudíž slabým zdrojem entropie. Nedoporučujeme používat PIDy v prostředích závislých na bezpečnosti.

Viz také getmyuid(),
get_current_user(),
getmyinode(), a
getlastmod().

Předcházející | Nahoru | Další
getmyinode | Domů | getmyuid


getmyuid

(PHP 4, PHP 5)

getmyuid — Získat UID majitele PHP skriptu

Popis

int getmyuid ( void )

Vrátí user ID současného skriptu, nebo FALSE při chybě.

Viz také getmypid(),
get_current_user(),
getmyinode(), a
getlastmod().

Předcházející | Nahoru | Další
getmypid | Domů | getopt


getopt

(PHP 4 >= 4.3.0, PHP 5)

getopt — Gets options from the command line argument list

Popis

array getopt ( string $options [, array $longopts] )

Parses options passed to the script.

Seznam parametrů

options

Each character in this string will be used as option characters and matched against options passed to the script starting with a single hyphen (-).

For example, an option string "x" recognizes an option -x.

longopts

An array of options. Each element in this array will be used as option strings and matched against options passed to the script starting with two hyphens (--).

For example, an longopts element "opt" recognizes an option --opt.

Poznámka: Prior to PHP5.3.0 this parameter was only available on few systems

The options parameter may contain the following elements:
Individual characters (do not accept values)
Characters followed by a colon (parameter requires value)
Characters followed by two colons (optional value)
Option values are the first argument after the string. It does not matter if a value has leading white space or not.

Poznámka: Optional values do not accept " " (space) as a seperator.

Poznámka: The format for the options and longopts is almost the same, the only difference is that longopts takes an array of options (where each element is the option) where as options takes a string (where each character is the option).

Návratové hodnoty

This function will return an array of option / argument pairs or FALSE on failure.

ChangeLog (záznam změn)

Verze | Popis
5.3.0 | This function is no longer system dependent and works on Windows too.

Příklady

Příklad 1639. getopt() Example

<?php
$options = getopt("f:hp:");
var_dump($options);
?>

Running the above script with php script.php -fvalue -h will output:

array(2) {
  ["f"]=>
  string(5) "value"
  ["h"]=>
  bool(false)
}

Příklad 1640. getopt() Example#2

<?php
$shortopts  = "";
$shortopts .= "f:";  // Required value
$shortopts .= "v::"; // Optional value
$shortopts .= "abc"; // These options do not accept values

$longopts  = array(
    "required:",     // Required value
    "optional::",    // Optional value
    "option",        // No value
    "opt",           // No value
);
$options = getopt($shortopts, $longopts);
var_dump($options);
?>

Running the above script with php script.php -f "value for f" -v -a --required value --optional="optional value" --option will output:

array(6) {
  ["f"]=>
  string(11) "value for f"
  ["v"]=>
  bool(false)
  ["a"]=>
  bool(false)
  ["required"]=>
  string(5) "value"
  ["optional"]=>
  string(14) "optional value"
  ["option"]=>
  bool(false)
}

Příklad 1641. getopt() Example#3

Passing multiple options as one

<?php
$options = getopt("abc");
var_dump($options);
?>

Running the above script with php script.php -aaac will output:

array(2) {
  ["a"]=>
  array(3) {
    [0]=>
    bool(false)
    [1]=>
    bool(false)
    [2]=>
    bool(false)
  }
  ["c"]=>
  bool(false)
}

Poznámky

Poznámka: The register_argc_argv option must be enabled for this function to work

Předcházející | Nahoru | Další
getmyuid | Domů | getrusage


getrusage

(PHP 4, PHP 5)

getrusage — Získat informace o současném využití zdrojů

Popis

array getrusage ( [int $who] )

Toto je rozhraní ke to getrusage(2). Vrátí asociativní pole obsahující všechna data vrácená systémovým voláním. Pokud je who 1, getrusage se zavolá s RUSAGE_CHILDREN.

Všechny položky jsou přístupné skrze svá dokumentovaná jména.

Příklad 1642. Getrusage příklad

$dat = getrusage();
echo $dat["ru_nswap"];         # počet swapů
echo $dat["ru_majflt"];        # počet page faultů
echo $dat["ru_utime.tv_sec"];  # využitý uživatelský čas (sekundy)
echo $dat["ru_utime.tv_usec"]; # využitý uživatelský čas (mikrosekundy)

Další detaily viz man stránka getrusage(2) na vašem systému.

Předcházející | Nahoru | Další
getopt | Domů | ini_alter


ini_alter

(PHP 4, PHP 5)

ini_alter — Změnit hodnotu konfigurační volby

Popis

string ini_alter ( string $varname, string $newvalue )

Změní hodnotu konfigurační volby, vrátí FALSE při selhání, a předchozí hodnotu konfigurační volby při úspěchu.

Poznámka: Toto je alias k ini_set()

Viz také ini_get(),
ini_restore(),
ini_set()

Předcházející | Nahoru | Další
getrusage | Domů | ini_get_all


ini_get_all

(PHP 4 >= 4.2.0, PHP 5)

ini_get_all — Gets all configuration options

Popis

array ini_get_all ( [string $extension] )

Returns all the registered configuration options.

Seznam parametrů

extension

An optional extension name. If set, the function return only options specific for that extension.

Návratové hodnoty

Returns an associative array uses the directive name as the array key, with elements of that array being global_value (set in php.ini), local_value (perhaps set with ini_set() or .htaccess), and access (the access level). See the manual section on configuration changes for information on what access levels mean.

Poznámka: It's possible for a directive to have multiple access levels, which is why access shows the appropriate bitmask values.

Příklady

Příklad 1643. A ini_get_all() example

<?php
$inis = ini_get_all();

print_r($inis);

?>

Výše uvedený příklad vypíše něco jako:

Array
(
    [allow_call_time_pass_reference] => Array
    (
        [global_value] => 1
        [local_value] => 1
        [access] => 6
    )
    [allow_url_fopen] => Array
    (
        [global_value] => 1
        [local_value] => 1
        [access] => 7
    )

    ...

)

Viz také

ini_get()
ini_restore()
ini_set()
get_loaded_extensions()
phpinfo()

Předcházející | Nahoru | Další
ini_alter | Domů | ini_get


ini_get

(PHP 4, PHP 5)

ini_get — Získat hodnotu konfigurační volby

Popis

string ini_get ( string $varname )

Vrátí hodnotu konfigurační volby při úspěchu, FALSE při selhání.

Viz také ini_alter(),
ini_restore(),
ini_set()

Předcházející | Nahoru | Další
ini_get_all | Domů | ini_restore


ini_restore

(PHP 4, PHP 5)

ini_restore — Obnovit původní hodnotu konfigurační volby

Popis

void ini_restore ( string $varname )

Obnoví původní hodnotu konfigurační volby.

Viz také ini_alter(),
ini_get(),
ini_set()

Předcházející | Nahoru | Další
ini_get | Domů | ini_set


ini_set

(PHP 4, PHP 5)

ini_set — Změnit hodnotu konfigurační volby

Popis

string ini_set ( string $varname, string $newvalue )

Změní hodnotu konfigurační volby, vrátí FALSE při selhání, a předchozí hodnotu konfigurační volby při úspěchu.

Viz také ini_alter(),
ini_get(),
ini_restore()

Předcházející | Nahoru | Další
ini_restore | Domů | main


main

(No version information available, might be only in CVS)

main — Dummy for main()

Popis

There is no function named main() except in the PHP source. In PHP 4.3.0, a new type of error handling in the PHP source (php_error_docref) was introduced. One feature is to provide links to a manual page in PHP error messages when the PHP directives html_errors (on by default) and docref_root (on by default until PHP 4.3.2) are set.

Sometimes error messages refer to a manual page for the function main() which is why this page exists. Please add a user comment below that mentions what PHP function caused the error that linked to main() and it will be fixed and properly documented.

Tabulka 252. Known errors that point to main()

Function name | No longer points here as of
include() | 5.1.0
include_once() | 5.1.0
require() | 5.1.0
require_once() | 5.1.0

Viz také

html_errors
display_errors

Předcházející | Nahoru | Další
ini_set | Domů | memory_get_peak_usage


memory_get_usage

(PHP 4 >= 4.3.2, PHP 5)

memory_get_usage — Returns the amount of memory allocated to PHP

Popis

int memory_get_usage ( [bool $real_usage] )

Returns the amount of memory, in bytes, that's currently being allocated to your PHP script.

Seznam parametrů

real_usage

Set this to TRUE to get the real size of memory allocated from system. If not set or FALSE only the memory used by emalloc() is reported.

Návratové hodnoty

Returns the memory amount in bytes.

ChangeLog (záznam změn)

Verze | Popis
5.2.1 | Compiling with --enable-memory-limit is no longer required for this function to exist.
5.2.0 | real_usage was added.

Příklady

Příklad 1644. A memory_get_usage() example

<?php
// This is only an example, the numbers below will
// differ depending on your system

echo memory_get_usage() . "\n"; // 36640

$a = str_repeat("Hello", 4242);

echo memory_get_usage() . "\n"; // 57960

unset($a);

echo memory_get_usage() . "\n"; // 36744

?>

Viz také

memory_get_peak_usage()
memory_limit

Předcházející | Nahoru | Další
memory_get_peak_usage | Domů | php_ini_scanned_files


php_ini_scanned_files

(PHP 4 >= 4.3.0, PHP 5)

php_ini_scanned_files — Return a list of .ini files parsed from the additional ini dir

Popis

string php_ini_scanned_files ( void )

php_ini_scanned_files() returns a comma-separated list of configuration files parsed after php.ini. These files are found in a directory defined by the --with-config-file-scan-dir option which is set during compilation.

The returned configuration files also include the path as declared in the --with-config-file-scan-dir option.

Návratové hodnoty

Returns a comma-separated string of .ini files on success. Each comma is followed by a newline. If the directive --with-config-files-scan-dir wasn't set, FALSE is returned. If it was set and the directory was empty, an empty string is returned. If a file is unrecognizable, the file will still make it into the returned string but a PHP error will also result. This PHP error will be seen both at compile time and while using php_ini_scanned_files().

Příklady

Příklad 1645. A simple example to list the returned ini files

<?php
if ($filelist = php_ini_scanned_files()) {
    if (strlen($filelist) > 0) {
        $files = explode(',', $filelist);

        foreach ($files as $file) {
            echo "<li>" . trim($file) . "</li>\n";
        }
    }
}
?>

Viz také

ini_set()
phpinfo()

Předcházející | Nahoru | Další
memory_get_usage | Domů | php_logo_guid


php_logo_guid

(PHP 4, PHP 5)

php_logo_guid — Get the logo guid

Popis

string php_logo_guid ( void )

Poznámka: Tato funkcionalita byla přidána v PHP 4 Beta 4.

Viz také phpinfo().
phpversion(),
phpcredits()

Předcházející | Nahoru | Další
php_ini_scanned_files | Domů | php_sapi_name


php_sapi_name

(PHP 4 >= 4.0.1, PHP 5)

php_sapi_name — Vrátit typ rozhraní mezi web serverem a PHP Returns the type of interface between web server and PHP

Popis

string php_sapi_name ( void )

php_sapi_name() vrátí řetězec popisující malými písmeny typ rozhraní mezi web serverem a PHP (Server API, SAPI). U CGI PHP je tento řetězec "cgi", u mod_php pro Apache je tento řetězec "apache" a tak dále.

Příklad 1646. php_sapi_name() Example

$sapi_type = php_sapi_name();
if ($sapi_type == "cgi")
  print "Používáte CGI PHP\n";
else
  print "Nepoužíváte CGI PHP\n";

Předcházející | Nahoru | Další
php_logo_guid | Domů | php_uname


php_uname

(PHP 4 >= 4.0.2, PHP 5)

php_uname — Vrátit informaci o operačním systému, na kterém bylo PHP zkompilováno

Popis

string php_uname ( [string $mode] )

php_uname() vrátí řetězec s popisem operačního systému, na kterém bylo PHP zkompilováno.

Příklad 1647. php_uname() Example

if (substr(php_uname(), 0, 7) == "Windows") {
  die("Pardon, tento skript na Windows nefunguje.\n");
}

Předcházející | Nahoru | Další
php_sapi_name | Domů | phpcredits


phpcredits

(PHP 4, PHP 5)

phpcredits — Vytisknout credits pro PHP

Popis

bool phpcredits ( [int $flag] )

Tato funkce vytiskne credits vč. seznamu vývojářů PHP, modulů, atd. Generuje příslušný HTML kód, kterým se tyto informace vkládají do stránky. Je třeba předat argument indikující co se vytiskne (předdefinovaná konstanta flag, viz níže). Například k vytištění všeobecných credits můžete někde ve svém kódu použít:

...
phpcredits(CREDITS_GENERAL);
...
A pokud chcete vytisknout užší kruh vývojářů a dokumentační skupinu na samostatné stránce, použijte:
<?php
phpcredits(CREDITS_GROUP + CREDITS_DOCS + CREDITS_FULLPAGE);
?>
A pokud chcete vložit všechny credits do vlastní stránky, pomůže vám následující kód:
<html>
 <head>
  <title>Má stránka s credits</title>
 </head>
 <body>
  <?php
    // váš vlastní kód
    phpcredits(CREDITS_ALL + CREDITS_FULLPAGE);
    // další kód
    ?>
 </body>
</html>

Tabulka 253. Předdefinované phpcredits() příznaky

název | popis
CREDITS_ALL | Všechny credits, ekvivalentní k: CREDITS_DOCS + CREDITS_GENERAL + CREDITS_GROUP + CREDITS_MODULES + CREDITS_FULLPAGE. Vygeneruje kompletní samostatnou HTML stránku s příslušnými tagy.
CREDITS_DOCS | Credits dokumentačního týmu
CREDITS_FULLPAGE | Obvykle se používá v kombinaci s jinými příznaky. Indikuje, že se má vytisknout kompletní samostatná HTML stránka, včetně informací indikovaných jinými příznaky.
CREDITS_GENERAL | Všeobecné credits: Design a koncept jazyka, autoři PHP 4.0 a SAPI modul.
CREDITS_GROUP | Seznam užšího kruhu vývojářů
CREDITS_MODULES | Seznam rozšiřujících modulů (extenzí) PHP a jejich autorů
CREDITS_SAPI | Seznam server API modulů PHP a jejich autorů

Viz také phpinfo(),
phpversion(),
php_logo_guid().

Předcházející | Nahoru | Další
php_uname | Domů | phpinfo


phpinfo

(PHP 4, PHP 5)

phpinfo — Vytisknout spoustu informací o PHP

Popis

bool phpinfo ( [int $what] )

Vytiskne velké množství informací o současném stavu PHP. To zahrnuje informace o kompilačních volbách a extenzích, verzi PHP, informaci o serveru a systémů (pokud je PHP zkompilováno jako modul), PHP prostředí, verzi OS, cesty, hlavní a lokální hodnoty konfiguračních voleb, HTTP hlavičky, a PHP licenci.

Výstup se dá upravit předáním jednou nebo více z následujících hodnot uložených ve volitelném argumentu what.

  • INFO_GENERAL
  • INFO_CREDITS
  • INFO_CONFIGURATION
  • INFO_MODULES
  • INFO_ENVIRONMENT
  • INFO_VARIABLES
  • INFO_LICENSE
  • INFO_ALL

Viz také phpversion(),
phpcredits(),
php_logo_guid()

Předcházející | Nahoru | Další
phpcredits | Domů | phpversion


phpversion

(PHP 4, PHP 5)

phpversion — Získat současnou verzi PHP

Popis

string phpversion ( [string $extension] )

Vrátí řetězec obsahující verzi právě běžícího PHP parseru.

Příklad 1648. phpversion() example

// prints e.g. 'Současná verze PHP: 3.0rel-dev'
echo "Současná verze PHP: ".phpversion();

Viz také phpinfo(),
phpcredits(),
php_logo_guid()

Předcházející | Nahoru | Další
phpinfo | Domů | putenv


putenv

(PHP 4, PHP 5)

putenv — Nastavit hodnotu systémové proměnné

Popis

bool putenv ( string $setting )

Přidá setting do prostředí serveru.

Příklad 1649. Nastavení systémové proměnné

putenv ("UNIQID=$uniqid");

Předcházející | Nahoru | Další
phpversion | Domů | restore_include_path


restore_include_path

(PHP 4 >= 4.3.0, PHP 5)

restore_include_path — Restores the value of the include_path configuration option

Popis

void restore_include_path ( void )

Restores the include_path configuration option back to its original master value as set in php.ini

Návratové hodnoty

Nevrací se žádná hodnota.

Příklady

Příklad 1650. restore_include_path() example

<?php

echo get_include_path();  // .:/usr/local/lib/php

set_include_path('/inc');

echo get_include_path();  // /inc

// Works as of PHP 4.3.0
restore_include_path();

// Works in all PHP versions
ini_restore('include_path');

echo get_include_path();  // .:/usr/local/lib/php

?>

Viz také

ini_restore()
get_include_path()
set_include_path()
include()

Předcházející | Nahoru | Další
putenv | Domů | set_include_path


set_include_path

(PHP 4 >= 4.3.0, PHP 5)

set_include_path — Sets the include_path configuration option

Popis

string set_include_path ( string $new_include_path )

Sets the include_path configuration option for the duration of the script.

Seznam parametrů

new_include_path

The new value for the include_path

Návratové hodnoty

Returns the old include_path on success or FALSE on failure.

Příklady

Příklad 1651. set_include_path() example

<?php
// Works as of PHP 4.3.0
set_include_path('/inc');

// Works in all PHP versions
ini_set('include_path', '/inc');
?>

Příklad 1652. Adding to the include path

Making use of the PATH_SEPARATOR constant, it is possible to extend the include path regardless of the operating system.

In this example we add /usr/lib/pear to the end of the existing include_path.

<?php
$path = '/usr/lib/pear';
set_include_path(get_include_path() . PATH_SEPARATOR . $path);
?>

Viz také

ini_set()
get_include_path()
restore_include_path()
include()

Předcházející | Nahoru | Další
restore_include_path | Domů | set_magic_quotes_runtime


set_magic_quotes_runtime

(PHP 4, PHP 5)

set_magic_quotes_runtime — Nastavit současnou aktivní hodnotu magic_quotes_runtime

Popis

bool set_magic_quotes_runtime ( int $new_setting )

Nastaví současnou aktivní konfigurační volby magic_quotes_runtime. (0 vypnuto, 1 zapnuto)

Viz také get_magic_quotes_gpc(), get_magic_quotes_runtime().

Předcházející | Nahoru | Další
set_include_path | Domů | set_time_limit


set_time_limit

(PHP 4, PHP 5)

set_time_limit — Omezit maximální dobu průběhu skriptu

Popis

void set_time_limit ( int $seconds )

Určí počet sekund po které může skript běžet. Pokud je dosaženo tohoto času, skript vrátí fatální chybu. Standardní limit je 30 sekund, nebo, pokud existuje, hodnota direktivy max_execution_time definovaná v konfiguračním souboru. Pokud je seconds nula, neexistuje žádný časový limit.

set_time_limit() při svém zavolání restartuje čítač času od nuly. Jinými slovy, pokud je limit standardních šé sekund a po 25 sekundách provádění skriptu dojde k volání set_time_limit(20), tento skript poběží celkem 45 sekund předtím, než skončí na časovém limitu.

Všimněte si, že set_time_limit() nemá žádný účinek, když PHP běží v bezpečném módu. Obejít to lz jedine vypnutím bezpečného módu nebo změnou časového limitu v konfiguračním souboru.

Předcházející | Nahoru | Další
set_magic_quotes_runtime | Domů | sys_get_temp_dir


version_compare

(PHP 4 >= 4.0.7, PHP 5)

version_compare — Compares two "PHP-standardized" version number strings

Popis

mixed version_compare ( string $version1, string $version2 [, string $operator] )

version_compare() compares two "PHP-standardized" version number strings. This is useful if you would like to write programs working only on some versions of PHP.

The function first replaces _, - and + with a dot . in the version strings and also inserts dots . before and after any non number so that for example '4.3.2RC1' becomes '4.3.2.RC.1'. Then it splits the results like if you were using explode('.', $ver). Then it compares the parts starting from left to right. If a part contains special version strings these are handled in the following order: dev < alpha = a < beta = b < RC < pl. This way not only versions with different levels like '4.1' and '4.1.2' can be compared but also any PHP specific version containing development state.

Seznam parametrů

version1

First version number.

version2

Second version number.

operator

If you specify the third optional operator argument, you can test for a particular relationship. The possible operators are: <, lt, <=, le, >, gt, >=, ge, ==, =, eq, !=, <>, ne respectively. Using this argument, the function will return TRUE if the relationship is the one specified by the operator, FALSE otherwise.

Návratové hodnoty

version_compare() returns -1 if the first version is lower than the second, 0 if they are equal, and +1 if the second is lower.

Příklady

Příklad 1653. version_compare() example

<?php
// prints -1
echo version_compare("4.0.4", "4.0.6");

// these all print 1
echo version_compare("4.0.4", "4.0.6", "<");
echo version_compare("4.0.6", "4.0.6", "eq");
?>

Poznámky

Poznámka: The PHP_VERSION constant holds current PHP version.

Předcházející | Nahoru | Další
sys_get_temp_dir | Domů | zend_logo_guid


zend_logo_guid

(PHP 4, PHP 5)

zend_logo_guid — Získat zend guid

Popis

string zend_logo_guid ( void )

Poznámka: Tato funkcionalita byla přidána v PHP 4 Beta 4.

Předcházející | Nahoru | Další
version_compare | Domů | zend_thread_id


zend_version

(PHP 4, PHP 5)

zend_version — Gets the version of the current Zend engine

Popis

string zend_version ( void )

Returns a string containing the version of the currently running Zend Engine.

Návratové hodnoty

Returns the Zend Engine version number, as a string.

Příklady

Příklad 1654. zend_version() example

<?php
echo "Zend engine version: " . zend_version();
?>

Výše uvedený příklad vypíše něco jako:

Zend engine version: 2.2.0

Viz také

phpinfo()
phpcredits()
php_logo_guid()
phpversion()

Předcházející | Nahoru | Další
zend_thread_id | Domů | CXXV. POSIX Functions


POSIX Functions

Předcházející VI. Reference funkcí Další

CXXV. POSIX Functions

Úvod

This module contains an interface to those functions defined in the IEEE 1003.1 (POSIX.1) standards document which are not accessible through other means. POSIX.1 for example defined the open(), read(), write() and close() functions, too, which traditionally have been part of PHP 3 for a long time. Some more system specific functions have not been available before, though, and this module tries to remedy this by providing easy access to these functions.

Varování

Sensitive data can be retrieved with the POSIX functions, e.g. posix_getpwnam() and friends. None of the POSIX function perform any kind of access checking when safe mode is enabled. It's therefore strongly advised to disable the POSIX extension at all (use --disable-posix in your configure line) if you're operating in such an environment.

Poznámka: Toto rozšíření není k dispozici na platformách Windows.

Instalace

POSIX functions are enabled by default. You can disable POSIX-like functions with --disable-posix.

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

POSIX_F_OK (integer)
Check whether the file exists.
POSIX_R_OK (integer)
Check whether the file exists and has read permissions.
POSIX_W_OK (integer)
Check whether the file exists and has write permissions.
POSIX_X_OK (integer)
Check whether the file exists and has execute permissions.
POSIX_S_IFBLK (integer)
Block special file
POSIX_S_IFCHR (integer)
Character special file
POSIX_S_IFIFO (integer)
FIFO (named pipe) special file
POSIX_S_IFREG (integer)
Normal file
POSIX_S_IFSOCK (integer)
Socket

Poznámka: These constants are available since PHP 5.1.0. Please also note that some of them may not be available in your system.

Viz také

The section about Process Control Functions maybe of interest for you.

Obsah

posix_access — Determine accessibility of a file
posix_ctermid — Get path name of controlling terminal
posix_get_last_error — Retrieve the error number set by the last posix function that failed
posix_getcwd — Pathname of current directory
posix_getegid — Return the effective group ID of the current process
posix_geteuid — Return the effective user ID of the current process
posix_getgid — Return the real group ID of the current process
posix_getgrgid — Return info about a group by group id
posix_getgrnam — Return info about a group by name
posix_getgroups — Return the group set of the current process
posix_getlogin — Return login name
posix_getpgid — Get process group id for job control
posix_getpgrp — Return the current process group identifier
posix_getpid — Return the current process identifier
posix_getppid — Return the parent process identifier
posix_getpwnam — Return info about a user by username
posix_getpwuid — Return info about a user by user id
posix_getrlimit — Return info about system resource limits
posix_getsid — Get the current sid of the process
posix_getuid — Return the real user ID of the current process
posix_initgroups — Calculate the group access list
posix_isatty — Determine if a file descriptor is an interactive terminal
posix_kill — Send a signal to a process
posix_mkfifo — Create a fifo special file (a named pipe)
posix_mknod — Create a special or ordinary file (POSIX.1)
posix_setegid — Set the effective GID of the current process
posix_seteuid — Set the effective UID of the current process
posix_setgid — Set the GID of the current process
posix_setpgid — Set process group id for job control
posix_setsid — Make the current process a session leader
posix_setuid — Set the UID of the current process
posix_strerror — Retrieve the system error message associated with the given errno
posix_times — Get process times
posix_ttyname — Determine terminal device name
posix_uname — Get system name
Předcházející | Nahoru | Další
zend_version | Domů | posix_access


posix_ctermid

(PHP 4, PHP 5)

posix_ctermid — Get path name of controlling terminal

Popis

string posix_ctermid ( void )

Generates a string which is the pathname for the current controlling terminal for the process. On error this will set errno, which can be checked using posix_get_last_error()

Návratové hodnoty

Upon successful completion, returns string of the pathname to the current controlling terminal. Otherwise FALSE is returned and errno is set, which can be checked with posix_get_last_error().

Příklady

Příklad 1656. posix_ctermid() example

This example will display the path to the current TTY.

<?php
echo "I am running from ".posix_ctermid();
?>

Viz také

posix_ttyname()
posix_get_last_error()

Předcházející | Nahoru | Další
posix_access | Domů | posix_get_last_error


posix_get_last_error

(PHP 4 >= 4.2.0, PHP 5)

posix_get_last_error — Retrieve the error number set by the last posix function that failed

Popis

int posix_get_last_error ( void )

Retrieve the error number set by the last posix function that failed. The system error message associated with the errno may be checked with posix_strerror().

Návratové hodnoty

Returns the errno (error number) set by the last posix function that failed. If no errors exist, 0 is returned.

Příklady

Příklad 1657. posix_get_last_error() example

This example attempt to kill a bogus process id, which will set the last error. We will then print out the last errno.

<?php
posix_kill(999459,SIGKILL);
echo 'Your error returned was '.posix_get_last_error(); //Your error was ___
?>

Viz také

posix_strerror()

Předcházející | Nahoru | Další
posix_ctermid | Domů | posix_getcwd


posix_getcwd

(PHP 4, PHP 5)

posix_getcwd — Pathname of current directory

Popis

string posix_getcwd ( void )

Gets the absolute pathname of the script's current working directory. On error, it sets errno which can be checked using posix_get_last_error()

Návratové hodnoty

Returns a string of the absolute pathname on success. On error, returns FALSE and sets errno which can be checked with posix_get_last_error().

Příklady

Příklad 1658. posix_getcwd() example

This example will return the absolute path of the current working directory of the script.

<?php
echo 'My current working directory is '.posix_getcwd();
?>

Poznámky

Poznámka: This function can fail on

  • Read or Search permission was denied
  • Pathname no longer exists

Předcházející | Nahoru | Další
posix_get_last_error | Domů | posix_getegid


posix_getegid

(PHP 4, PHP 5)

posix_getegid — Return the effective group ID of the current process

Popis

int posix_getegid ( void )

Return the numeric effective group ID of the current process.

Návratové hodnoty

Returns an integer of the effective group ID.

Příklady

Příklad 1659. posix_getegid() example

This example will print out the effective group id, once it is changed with posix_setegid().

<?php
echo 'My real group id is '.posix_getgid(); //20
posix_setegid(40);
echo 'My real group id is '.posix_getgid(); //20
echo 'My effective group id is '.posix_getegid(); //40
?>

Poznámky

posix_getegid() is different than posix_getgid() because effective group ID can be changed by a calling process using posix_setegid().

Viz také

posix_getgrgid() for information on how to convert this into a useable group name
posix_getgid() get real group id.
posix_setgid() change the effective group id

Předcházející | Nahoru | Další
posix_getcwd | Domů | posix_geteuid


posix_geteuid

(PHP 4, PHP 5)

posix_geteuid — Return the effective user ID of the current process

Popis

int posix_geteuid ( void )

Return the numeric effective user ID of the current process. See also posix_getpwuid() for information on how to convert this into a useable username.

Návratové hodnoty

Returns the user id, as an integer

Příklady

Příklad 1660. posix_geteuid() example

This example will show the current user id then set the effective user id to a separate id using posix_seteuid(), then show the difference between the real id and the effective id.

<?php
echo posix_getuid()."\n"; //10001
echo posix_geteuid()."\n"; //10001
posix_seteuid(10000);
echo posix_getuid()."\n"; //10001
echo posix_geteuid()."\n"; //10000
?>

Viz také

posix_getpwuid() for more information about the user.
posix_getuid() get real user id.
posix_setuid() change the effective user id
POSIX man page GETEUID(2)

Předcházející | Nahoru | Další
posix_getegid | Domů | posix_getgid


posix_getgid

(PHP 4, PHP 5)

posix_getgid — Return the real group ID of the current process

Popis

int posix_getgid ( void )

Return the numeric real group ID of the current process.

Návratové hodnoty

Returns the real group id, as an integer.

Příklady

Příklad 1661. posix_getgid() example

This example will print out the real group id, even once the effective group id has been changed.

<?php
echo 'My real group id is '.posix_getgid(); //20
posix_setegid(40);
echo 'My real group id is '.posix_getgid(); //20
echo 'My effective group id is '.posix_getegid(); //40
?>

Viz také

posix_getgrgid() for information on how to convert this into a useable group name
posix_getegid() get effective group id.
posix_setgid() change the effective group id
POSIX man page GETGID(2)

Předcházející | Nahoru | Další
posix_geteuid | Domů | posix_getgrgid


posix_getgrgid

(PHP 4, PHP 5)

posix_getgrgid — Return info about a group by group id

Popis

array posix_getgrgid ( int $gid )

Gets information about a group provided its id.

Seznam parametrů

gid

The group id.

Návratové hodnoty

The array elements returned are:

Tabulka 254. The group information array

Element | Description
name | The name element contains the name of the group. This is a short, usually less than 16 character "handle" of the group, not the real, full name.
passwd | The passwd element contains the group's password in an encrypted format. Often, for example on a system employing "shadow" passwords, an asterisk is returned instead.
gid | Group ID, should be the same as the gid parameter used when calling the function, and hence redundant.
members | This consists of an array of string's for all the members in the group.

ChangeLog (záznam změn)

Verze | Popis
4.2.0 | Prior to this version, members was simply an integer representing the number of members in the group, and the member names were returned with numerical indices.

Příklady

Příklad 1662. Example use of posix_getgrgid()

<?php

$groupid   = posix_getegid();
$groupinfo = posix_getgrgid($groupid);

print_r($groupinfo);
?>

Výše uvedený příklad vypíše něco jako:

Array
(
    [name]    => toons
    [passwd]  => x
    [members] => Array
        (
            [0] => tom
            [1] => jerry
        )
    [gid]     => 42
)

Viz také

posix_getegid()
posix_getgrnam()
filegroup()
stat()
safe_mode_gid
POSIX man page GETGRNAM(3)

Předcházející | Nahoru | Další
posix_getgid | Domů | posix_getgrnam


posix_getgrnam

(PHP 4, PHP 5)

posix_getgrnam — Return info about a group by name

Popis

array posix_getgrnam ( string $name )

Gets information about a group provided its name.

Seznam parametrů

name

The name of the group

Návratové hodnoty

The array elements returned are:

Tabulka 255. The group information array

Element | Description
name | The name element contains the name of the group. This is a short, usually less than 16 character "handle" of the group, not the real, full name. This should be the same as the name parameter used when calling the function, and hence redundant.
passwd | The passwd element contains the group's password in an encrypted format. Often, for example on a system employing "shadow" passwords, an asterisk is returned instead.
gid | Group ID of the group in numeric form.
members | This consists of an array of string's for all the members in the group.

ChangeLog (záznam změn)

Verze | Popis
4.2.0 | Prior to this version, members was simply an integer representing the number of members in the group, and the member names were returned with numerical indices.

Příklady

Příklad 1663. Example use of posix_getgrnam()

<?php

$groupinfo = posix_getgrnam("toons");

print_r($groupinfo);
?>

Výše uvedený příklad vypíše něco jako:

Array
(
    [name]    => toons
    [passwd]  => x
    [members] => Array
        (
            [0] => tom
            [1] => jerry
        )
    [gid]     => 42
)

Viz také

posix_getegid()
posix_getgrgid()
filegroup()
stat()
safe_mode_gid
POSIX man page GETGRNAM(3)

Předcházející | Nahoru | Další
posix_getgrgid | Domů | posix_getgroups


posix_getgroups

(PHP 4, PHP 5)

posix_getgroups — Return the group set of the current process

Popis

array posix_getgroups ( void )

Gets the group set of the current process.

Návratové hodnoty

Returns an array of integers containing the numeric group ids of the group set of the current process.

Příklady

Příklad 1664. Example use of posix_getgroups()

<?php

$groups = posix_getgroups();

print_r($groups);
?>

Výše uvedený příklad vypíše něco jako:

Array
(
    [0] => 4
    [1] => 20
    [2] => 24
    [3] => 25
    [4] => 29
    [5] => 30
    [6] => 33
    [7] => 44
    [8] => 46
    [9] => 104
    [10] => 109
    [11] => 110
    [12] => 1000
)

Viz také

posix_getgrgid()

Předcházející | Nahoru | Další
posix_getgrnam | Domů | posix_getlogin


posix_getlogin

(PHP 4, PHP 5)

posix_getlogin — Return login name

Popis

string posix_getlogin ( void )

Returns the login name of the user owning the current process.

Návratové hodnoty

Returns the login name of the user, as a string.

Příklady

Příklad 1665. Example use of posix_getlogin()

<?php
echo posix_getlogin(); //apache
?>

Viz také

posix_getpwnam()
POSIX man page GETLOGIN(3)

Předcházející | Nahoru | Další
posix_getgroups | Domů | posix_getpgid


posix_getpgid

(PHP 4, PHP 5)

posix_getpgid — Get process group id for job control

Popis

int posix_getpgid ( int $pid )

Returns the process group identifier of the process pid.

Seznam parametrů

pid

The process id.

Návratové hodnoty

Returns the identifier, as an integer.

Příklady

Příklad 1666. Example use of posix_getpgid()

<?php
$pid = posix_getppid();
echo posix_getpgid($pid); //35
?>

Poznámky

Poznámka: This is a not POSIX function, but is common on BSD and System V systems. If the system does not support this function, then it will not be included at compile time. This may be checked with function_exists().

Viz také

posix_getppid()
man page SETPGID(2)

Předcházející | Nahoru | Další
posix_getlogin | Domů | posix_getpgrp


posix_getpgrp

(PHP 4, PHP 5)

posix_getpgrp — Return the current process group identifier

Popis

int posix_getpgrp ( void )

Return the process group identifier of the current process.

Návratové hodnoty

Returns the identifier, as an integer.

Viz také

POSIX.1 and the getpgrp(2) manual page on the POSIX system for more information on process groups.

Předcházející | Nahoru | Další
posix_getpgid | Domů | posix_getpid


posix_getpid

(PHP 4, PHP 5)

posix_getpid — Return the current process identifier

Popis

int posix_getpid ( void )

Return the process identifier of the current process.

Návratové hodnoty

Returns the identifier, as an integer.

Příklady

Příklad 1667. Example use of posix_getpid()

<?php
echo posix_getpid(); //8805
?>

Viz také

posix_kill() to kill a process.
POSIX man page GETPID(2)

Předcházející | Nahoru | Další
posix_getpgrp | Domů | posix_getppid


posix_getppid

(PHP 4, PHP 5)

posix_getppid — Return the parent process identifier

Popis

int posix_getppid ( void )

Return the process identifier of the parent process of the current process.

Návratové hodnoty

Returns the identifier, as an integer.

Příklady

Příklad 1668. Example use of posix_getppid()

<?php
echo posix_getppid(); //8259
?>

Předcházející | Nahoru | Další
posix_getpid | Domů | posix_getpwnam


posix_getpwnam

(PHP 4, PHP 5)

posix_getpwnam — Return info about a user by username

Popis

array posix_getpwnam ( string $username )

Returns an array of information about the given user.

Seznam parametrů

username

An alphanumeric username.

Návratové hodnoty

The array elements returned are:

Tabulka 256. The user information array

Element | Description
name | The name element contains the username of the user. This is a short, usually less than 16 character "handle" of the user, not the real, full name. This should be the same as the username parameter used when calling the function, and hence redundant.
passwd | The passwd element contains the user's password in an encrypted format. Often, for example on a system employing "shadow" passwords, an asterisk is returned instead.
uid | User ID of the user in numeric form.
gid | The group ID of the user. Use the function posix_getgrgid() to resolve the group name and a list of its members.
gecos | GECOS is an obsolete term that refers to the finger information field on a Honeywell batch processing system. The field, however, lives on, and its contents have been formalized by POSIX. The field contains a comma separated list containing the user's full name, office phone, office number, and home phone number. On most systems, only the user's full name is available.
dir | This element contains the absolute path to the home directory of the user.
shell | The shell element contains the absolute path to the executable of the user's default shell.

Příklady

Příklad 1669. Example use of posix_getpwnam()

<?php

$userinfo = posix_getpwnam("tom");

print_r($userinfo);
?>

Výše uvedený příklad vypíše něco jako:

Array
(
    [name]    => tom
    [passwd]  => x
    [uid]     => 10000
    [gid]     => 42
    [geocs]   => "tom,,,"
    [dir]     => "/home/tom"
    [shell]   => "/bin/bash"
)

Viz také

posix_getpwuid()
POSIX man page GETPWNAM(3)

Předcházející | Nahoru | Další
posix_getppid | Domů | posix_getpwuid


posix_getpwuid

(PHP 4, PHP 5)

posix_getpwuid — Return info about a user by user id

Popis

array posix_getpwuid ( int $uid )

Returns an array of information about the user referenced by the given user ID.

Seznam parametrů

uid

The user identifier.

Návratové hodnoty

Returns an associative array with the following elements:

Tabulka 257. The user information array

Element | Description
name | The name element contains the username of the user. This is a short, usually less than 16 character "handle" of the user, not the real, full name.
passwd | The passwd element contains the user's password in an encrypted format. Often, for example on a system employing "shadow" passwords, an asterisk is returned instead.
uid | User ID, should be the same as the uid parameter used when calling the function, and hence redundant.
gid | The group ID of the user. Use the function posix_getgrgid() to resolve the group name and a list of its members.
gecos | GECOS is an obsolete term that refers to the finger information field on a Honeywell batch processing system. The field, however, lives on, and its contents have been formalized by POSIX. The field contains a comma separated list containing the user's full name, office phone, office number, and home phone number. On most systems, only the user's full name is available.
dir | This element contains the absolute path to the home directory of the user.
shell | The shell element contains the absolute path to the executable of the user's default shell.

Příklady

Příklad 1670. Example use of posix_getpwuid()

<?php

$userinfo = posix_getpwuid(10000);

print_r($userinfo);
?>

Výše uvedený příklad vypíše něco jako:

Array
(
    [name]    => tom
    [passwd]  => x
    [uid]     => 10000
    [gid]     => 42
    [geocs]   => "tom,,,"
    [dir]     => "/home/tom"
    [shell]   => "/bin/bash"
)

Viz také

posix_getpwnam()
POSIX man page GETPWNAM(3)

Předcházející | Nahoru | Další
posix_getpwnam | Domů | posix_getrlimit


posix_getrlimit

(PHP 4, PHP 5)

posix_getrlimit — Return info about system resource limits

Popis

array posix_getrlimit ( void )

posix_getrlimit() returns an array of information about the current resource's soft and hard limits.

Each resource has an associated soft and hard limit. The soft limit is the value that the kernel enforces for the corresponding resource. The hard limit acts as a ceiling for the soft limit. An unprivileged process may only set its soft limit to a value from 0 to the hard limit, and irreversibly lower its hard limit.

Návratové hodnoty

Returns an associative array of elements for each limit that is defined. Each limit has a soft and a hard limit.

Tabulka 258. List of possible limits returned

Limit name | Limit description
core | The maximum size of the core file. When 0, not core files are created. When core files are larger than this size, they will be truncated at this size.
totalmem | The maximum size of the memory of the process, in bytes.
virtualmem | The maximum size of the virtual memory for the process, in bytes.
data | The maximum size of the data segment for the process, in bytes.
stack | The maximum size of the process stack, in bytes.
rss | The maximum number of virtual pages resident in RAM
maxproc | The maximum number of processes that can be created for the real user ID of the calling process.
memlock | The maximum number of bytes of memory that may be locked into RAM.
cpu | The amount of time the process is allowed to use the CPU.
filesize | The maximum size of the data segment for the process, in bytes.
openfiles | One more than the maximum number of open file descriptors.

Příklady

Příklad 1671. Example use of posix_getrlimit()

<?php

$limits = posix_getrlimit();

print_r($limits);
?>

Výše uvedený příklad vypíše něco jako:

Array
(
    [soft core] => 0
    [hard core] => unlimited
    [soft data] => unlimited
    [hard data] => unlimited
    [soft stack] => 8388608
    [hard stack] => unlimited
    [soft totalmem] => unlimited
    [hard totalmem] => unlimited
    [soft rss] => unlimited
    [hard rss] => unlimited
    [soft maxproc] => unlimited
    [hard maxproc] => unlimited
    [soft memlock] => unlimited
    [hard memlock] => unlimited
    [soft cpu] => unlimited
    [hard cpu] => unlimited
    [soft filesize] => unlimited
    [hard filesize] => unlimited
    [soft openfiles] => 1024
    [hard openfiles] => 1024
)

Poznámky

Poznámka: This is a not POSIX function, but is common on BSD and System V systems. If the system does not support this function, then it will not be included at compile time. This may be checked with function_exists().

Viz také

man page GETRLIMIT(2)

Předcházející | Nahoru | Další
posix_getpwuid | Domů | posix_getsid


posix_getsid

(PHP 4, PHP 5)

posix_getsid — Get the current sid of the process

Popis

int posix_getsid ( int $pid )

Return the session id of the process pid. The session id of a process is the process group id of the session leader.

Seznam parametrů

pid

The process identifier. If set to 0, the current process is assumed. If an invalid pid is specified, then FALSE is returned and an error is set which can be checked with posix_get_last_error().

Návratové hodnoty

Returns the identifier, as an integer.

Příklady

Příklad 1672. Example use of posix_getsid()

<?php
$pid = posix_getpid();
echo posix_getsid($pid); //8805
?>

Viz také

posix_getpgid()
posix_setsid()
POSIX man page GETSID(2)

Předcházející | Nahoru | Další
posix_getrlimit | Domů | posix_getuid


posix_getuid

(PHP 4, PHP 5)

posix_getuid — Return the real user ID of the current process

Popis

int posix_getuid ( void )

Return the numeric real user ID of the current process.

Návratové hodnoty

Returns the user id, as an integer

Příklady

Příklad 1673. Example use of posix_getuid()

<?php
echo posix_getuid(); //10000
?>

Viz také

posix_getpwuid() for information on how to convert this into a useable username
POSIX man page GETUID(2)

Předcházející | Nahoru | Další
posix_getsid | Domů | posix_initgroups


posix_isatty

(PHP 4, PHP 5)

posix_isatty — Determine if a file descriptor is an interactive terminal

Popis

bool posix_isatty ( int $fd )

Determines if the file descriptor fd refers to a valid terminal type device.

Seznam parametrů

fd

The file descriptor.

Návratové hodnoty

Returns TRUE if fd is an open descriptor connected to a terminal and FALSE otherwise.

Viz také

posix_ttyname()

Předcházející | Nahoru | Další
posix_initgroups | Domů | posix_kill


posix_kill

(PHP 4, PHP 5)

posix_kill — Send a signal to a process

Popis

bool posix_kill ( int $pid, int $sig )

Send the signal sig to the process with the process identifier pid.

Seznam parametrů

pid

The process identifier.

sig

One of the PCNTL signals constants.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

The kill(2) manual page of the POSIX system, which contains additional information about negative process identifiers, the special pid 0, the special pid -1, and the signal number 0.

Předcházející | Nahoru | Další
posix_isatty | Domů | posix_mkfifo


posix_mkfifo

(PHP 4, PHP 5)

posix_mkfifo — Create a fifo special file (a named pipe)

Popis

bool posix_mkfifo ( string $pathname, int $mode )

posix_mkfifo() creates a special FIFO file which exists in the file system and acts as a bidirectional communication endpoint for processes.

Seznam parametrů

pathname

Path to the FIFO file.

mode

The second parameter mode has to be given in octal notation (e.g. 0644). The permission of the newly created FIFO also depends on the setting of the current umask(). The permissions of the created file are (mode & ~umask).

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Poznámky

Poznámka: Pokud je zapnut bezpečný režim (safe-mode), PHP kontroluje, zda soubory/adresáře, se kterými pracujete, mají stejné UID jako spuštěný skript.

Předcházející | Nahoru | Další
posix_kill | Domů | posix_mknod


posix_setegid

(PHP 4 >= 4.0.2, PHP 5)

posix_setegid — Set the effective GID of the current process

Popis

bool posix_setegid ( int $gid )

Set the effective group ID of the current process. This is a privileged function and needs appropriate privileges (usually root) on the system to be able to perform this function.

Seznam parametrů

gid

The group id.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1675. posix_setegid() example

This example will print out the effective group id, once changed.

<?php
echo 'My real group id is '.posix_getgid(); //20
posix_setegid(40);
echo 'My real group id is '.posix_getgid(); //20
echo 'My effective group id is '.posix_getegid(); //40
?>

Viz také

posix_getgrgid() for information on how to convert a group id into a useable group name
posix_getgid() get real group id.
posix_setgid() change the effective group id

Předcházející | Nahoru | Další
posix_mknod | Domů | posix_seteuid


posix_seteuid

(PHP 4 >= 4.0.2, PHP 5)

posix_seteuid — Set the effective UID of the current process

Popis

bool posix_seteuid ( int $uid )

Set the real user ID of the current process. This is a privileged function and needs appropriate privileges (usually root) on the system to be able to perform this function.

Seznam parametrů

uid

The user id.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

posix_setgid()

Předcházející | Nahoru | Další
posix_setegid | Domů | posix_setgid


posix_setgid

(PHP 4, PHP 5)

posix_setgid — Set the GID of the current process

Popis

bool posix_setgid ( int $gid )

Set the real group ID of the current process. This is a privileged function and needs appropriate privileges (usually root) on the system to be able to perform this function. The appropriate order of function calls is posix_setgid() first, posix_setuid() last.

Poznámka: If the caller is a super user, this will also set the effective group id.

Seznam parametrů

gid

The group id.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1676. posix_setgid() example

This example will print out the effective group id, once it is changed.

<?php
echo 'My real group id is '.posix_getgid(); //20
posix_setgid(40);
echo 'My real group id is '.posix_getgid(); //40
echo 'My effective group id is '.posix_getegid(); //40
?>

Viz také

posix_getgrgid() for information on how to convert this into a useable group name
posix_getgid() get real group id.

Předcházející | Nahoru | Další
posix_seteuid | Domů | posix_setpgid


posix_setpgid

(PHP 4, PHP 5)

posix_setpgid — Set process group id for job control

Popis

bool posix_setpgid ( int $pid, int $pgid )

Let the process pid join the process group pgid.

Seznam parametrů

pid

The process id.

pgid

The process group id.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

See POSIX.1 and the setsid(2) manual page on the POSIX system for more informations on process groups and job control.

Předcházející | Nahoru | Další
posix_setgid | Domů | posix_setsid


posix_setsid

(PHP 4, PHP 5)

posix_setsid — Make the current process a session leader

Popis

int posix_setsid ( void )

Make the current process a session leader.

Návratové hodnoty

Returns the session id, or -1 on errors.

Viz také

The POSIX.1 and the setsid(2) manual page on the POSIX system for more information on process groups and job control.

Předcházející | Nahoru | Další
posix_setpgid | Domů | posix_setuid


posix_setuid

(PHP 4, PHP 5)

posix_setuid — Set the UID of the current process

Popis

bool posix_setuid ( int $uid )

Set the real user ID of the current process. This is a privileged function that needs appropriate privileges (usually root) on the system to be able to perform this function.

Seznam parametrů

uid

The user id.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1677. posix_setuid() example

This example will show the currrent user id and then set it to a different value.

<?php
echo posix_getuid()."\n"; //10001
echo posix_geteuid()."\n"; //10001
posix_setuid(10000);
echo posix_getuid()."\n"; //10000
echo posix_geteuid()."\n"; //10000
?>

Viz také

posix_setgid()
posix_seteuid()
posix_getuid()
posix_geteuid()

Předcházející | Nahoru | Další
posix_setsid | Domů | posix_strerror


posix_strerror

(PHP 4 >= 4.2.0, PHP 5)

posix_strerror — Retrieve the system error message associated with the given errno

Popis

string posix_strerror ( int $errno )

Returns the POSIX system error message associated with the given errno. You may get the errno parameter by calling posix_get_last_error().

Seznam parametrů

errno

A POSIX error number, returned by posix_get_last_error(). If set to 0, then the string "Success" is returned.

Návratové hodnoty

Returns the error message, as a string.

Příklady

Příklad 1678. posix_strerror() example

This example will attempt to kill a process which does not exist, then will print out the corresponding error message.

<?php
posix_kill(50,SIGKILL);
echo posix_strerror(posix_get_last_error())."\n";
?>

Výše uvedený příklad vypíše něco jako:

No such process

Viz také

posix_get_last_error()

Předcházející | Nahoru | Další
posix_setuid | Domů | posix_times


posix_times

(PHP 4, PHP 5)

posix_times — Get process times

Popis

array posix_times ( void )

Gets information about the current CPU usage.

Návratové hodnoty

Returns a hash of strings with information about the current process CPU usage. The indices of the hash are:

  • ticks - the number of clock ticks that have elapsed since reboot.
  • utime - user time used by the current process.
  • stime - system time used by the current process.
  • cutime - user time used by current process and children.
  • cstime - system time used by current process and children.

Poznámky

Varování

This function isn't reliable to use, it may return negative values for high times.

Příklady

Příklad 1679. Example use of posix_times()

<?php

$times = posix_times();

print_r($times);
?>

Výše uvedený příklad vypíše něco jako:

Array
(
    [ticks] => 25814410
    [utime] => 1
    [stime] => 1
    [cutime] => 0
    [cstime] => 0
)

Předcházející | Nahoru | Další
posix_strerror | Domů | posix_ttyname


posix_ttyname

(PHP 4, PHP 5)

posix_ttyname — Determine terminal device name

Popis

string posix_ttyname ( int $fd )

Returns a string for the absolute path to the current terminal device that is open on the file descriptor fd.

Seznam parametrů

fd

The file descriptor.

Návratové hodnoty

On success, returns a string of the absolute path of the fd. On failure, returns FALSE

Předcházející | Nahoru | Další
posix_times | Domů | posix_uname


posix_uname

(PHP 4, PHP 5)

posix_uname — Get system name

Popis

array posix_uname ( void )

Gets information about the system.

Posix requires that assumptions must not be made about the format of the values, e.g. the assumption that a release may contain three digits or anything else returned by this function.

Návratové hodnoty

Returns a hash of strings with information about the system. The indices of the hash are

  • sysname - operating system name (e.g. Linux)
  • nodename - system name (e.g. valiant)
  • release - operating system release (e.g. 2.2.10)
  • version - operating system version (e.g. #4 Tue Jul 20 17:01:36 MEST 1999)
  • machine - system architecture (e.g. i586)
  • domainname - DNS domainname (e.g. example.com)

domainname is a GNU extension and not part of POSIX.1, so this field is only available on GNU systems or when using the GNU libc.

Příklady

Příklad 1680. Example use of posix_uname()

<?php
$uname=posix_uname();
print_r($uname);
?>

Výše uvedený příklad vypíše něco jako:

Array
(
    [sysname] => Linux
    [nodename] => funbox
    [release] => 2.6.20-15-server
    [version] => #2 SMP Sun Apr 15 07:41:34 UTC 2007
    [machine] => i686
)

Předcházející | Nahoru | Další
posix_ttyname | Domů | CXXVI. Regular Expression Functions (POSIX Extended)


PostgreSQL Functions

Předcházející VI. Reference funkcí Další

CXXVII. PostgreSQL Functions

Úvod

PostgreSQL database is Open Source product and available without cost. Postgres, developed originally in the UC Berkeley Computer Science Department, pioneered many of the object-relational concepts now becoming available in some commercial databases. It provides SQL92/SQL99 language support, transactions, referential integrity, stored procedures and type extensibility. PostgreSQL is an open source descendant of this original Berkeley code.

Požadavky

To use PostgreSQL support, you need PostgreSQL 6.5 or later, PostgreSQL 8.0 or later to enable all PostgreSQL module features. PostgreSQL supports many character encodings including multibyte character encoding. The current version and more information about PostgreSQL is available at » http://www.postgresql.org/ and the » PostgreSQL Documentation.

Instalace

In order to enable PostgreSQL support, --with-pgsql[=DIR] is required when you compile PHP. DIR is the PostgreSQL base install directory, defaults to /usr/local/pgsql. If shared object module is available, PostgreSQL module may be loaded using extension directive in php.ini or dl() function.

Konfigurace běhu

Chování těchto funkcí je ovlivněno nastavením parametrů v php.ini.

Tabulka 259. PostgreSQL configuration options

Name | Default | Changeable | Changelog
pgsql.allow_persistent | "1" | PHP_INI_SYSTEM |
pgsql.max_persistent | "-1" | PHP_INI_SYSTEM |
pgsql.max_links | "-1" | PHP_INI_SYSTEM |
pgsql.auto_reset_persistent | "0" | PHP_INI_SYSTEM | Available since PHP 4.2.0.
pgsql.ignore_notice | "0" | PHP_INI_ALL | Available since PHP 4.3.0.
pgsql.log_notice | "0" | PHP_INI_ALL | Available since PHP 4.3.0.

Pro další detaily a definice konstant PHP_INI_*, viz dokumentace k ini_set().

Zde je stručný popis konfiguračních direktiv.

pgsql.allow_persistent boolean

Whether to allow persistent Postgres connections.

pgsql.max_persistent integer

The maximum number of persistent Postgres connections per process.

pgsql.max_links integer

The maximum number of Postgres connections per process, including persistent connections.

pgsql.auto_reset_persistent integer

Detect broken persistent links with pg_pconnect(). Needs a little overhead.

pgsql.ignore_notice integer

Whether or not to ignore PostgreSQL backend notices.

pgsql.log_notice integer

Whether or not to log PostgreSQL backends notice messages. The PHP directive pgsql.ignore_notice must be off in order to log notice messages.

Typy prostředků

There are two resource types used in the PostgreSQL module. The first one is the link identifier for a database connection, the second a resource which holds the result of a query.

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

PGSQL_ASSOC (integer)
Passed to pg_fetch_array(). Return an associative array of field names and values.
PGSQL_NUM (integer)
Passed to pg_fetch_array(). Return a numerically indexed array of field numbers and values.
PGSQL_BOTH (integer)
Passed to pg_fetch_array(). Return an array of field values that is both numerically indexed (by field number) and associated (by field name).
PGSQL_CONNECT_FORCE_NEW (integer)
Passed to pg_connect() to force the creation of a new connection, rather then re-using an existing identical connection.
PGSQL_CONNECTION_BAD (integer)
Returned by pg_connection_status() indicating that the database connection is in an invalid state.
PGSQL_CONNECTION_OK (integer)
Returned by pg_connection_status() indicating that the database connection is in a valid state.
PGSQL_SEEK_SET (integer)
Passed to pg_lo_seek(). Seek operation is to begin from the start of the object.
PGSQL_SEEK_CUR (integer)
Passed to pg_lo_seek(). Seek operation is to begin from the current position.
PGSQL_SEEK_END (integer)
Passed to pg_lo_seek(). Seek operation is to begin from the end of the object.
PGSQL_EMPTY_QUERY (integer)
Returned by pg_result_status(). The string sent to the server was empty.
PGSQL_COMMAND_OK (integer)
Returned by pg_result_status(). Successful completion of a command returning no data.
PGSQL_TUPLES_OK (integer)
Returned by pg_result_status(). Successful completion of a command returning data (such as a SELECT or SHOW).
PGSQL_COPY_OUT (integer)
Returned by pg_result_status(). Copy Out (from server) data transfer started.
PGSQL_COPY_IN (integer)
Returned by pg_result_status(). Copy In (to server) data transfer started.
PGSQL_BAD_RESPONSE (integer)
Returned by pg_result_status(). The server's response was not understood.
PGSQL_NONFATAL_ERROR (integer)
Returned by pg_result_status(). A nonfatal error (a notice or warning) occurred.
PGSQL_FATAL_ERROR (integer)
Returned by pg_result_status(). A fatal error occurred.
PGSQL_TRANSACTION_IDLE (integer)
Returned by pg_transaction_status(). Connection is currently idle, not in a transaction.
PGSQL_TRANSACTION_ACTIVE (integer)
Returned by pg_transaction_status(). A command is in progress on the connection. A query has been sent via the connection and not yet completed.
PGSQL_TRANSACTION_INTRANS (integer)
Returned by pg_transaction_status(). The connection is idle, in a transaction block.
PGSQL_TRANSACTION_INERROR (integer)
Returned by pg_transaction_status(). The connection is idle, in a failed transaction block.
PGSQL_TRANSACTION_UNKNOWN (integer)
Returned by pg_transaction_status(). The connection is bad.
PGSQL_DIAG_SEVERITY (integer)
Passed to pg_result_error_field(). The severity; the field contents are ERROR, FATAL, or PANIC (in an error message), or WARNING, NOTICE, DEBUG, INFO, or LOG (in a notice message), or a localized translation of one of these. Always present.
PGSQL_DIAG_SQLSTATE (integer)
Passed to pg_result_error_field(). The SQLSTATE code for the error. The SQLSTATE code identifies the type of error that has occurred; it can be used by front-end applications to perform specific operations (such as error handling) in response to a particular database error. This field is not localizable, and is always present.
PGSQL_DIAG_MESSAGE_PRIMARY (integer)
Passed to pg_result_error_field(). The primary human-readable error message (typically one line). Always present.
PGSQL_DIAG_MESSAGE_DETAIL (integer)
Passed to pg_result_error_field(). Detail: an optional secondary error message carrying more detail about the problem. May run to multiple lines.
PGSQL_DIAG_MESSAGE_HINT (integer)
Passed to pg_result_error_field(). Hint: an optional suggestion what to do about the problem. This is intended to differ from detail in that it offers advice (potentially inappropriate) rather than hard facts. May run to multiple lines.
PGSQL_DIAG_STATEMENT_POSITION (integer)
Passed to pg_result_error_field(). A string containing a decimal integer indicating an error cursor position as an index into the original statement string. The first character has index 1, and positions are measured in characters not bytes.
PGSQL_DIAG_INTERNAL_POSITION (integer)
Passed to pg_result_error_field(). This is defined the same as the PG_DIAG_STATEMENT_POSITION field, but it is used when the cursor position refers to an internally generated command rather than the one submitted by the client. The PG_DIAG_INTERNAL_QUERY field will always appear when this field appears.
PGSQL_DIAG_INTERNAL_QUERY (integer)
Passed to pg_result_error_field(). The text of a failed internally-generated command. This could be, for example, a SQL query issued by a PL/pgSQL function.
PGSQL_DIAG_CONTEXT (integer)
Passed to pg_result_error_field(). An indication of the context in which the error occurred. Presently this includes a call stack traceback of active procedural language functions and internally-generated queries. The trace is one entry per line, most recent first.
PGSQL_DIAG_SOURCE_FILE (integer)
Passed to pg_result_error_field(). The file name of the PostgreSQL source-code location where the error was reported.
PGSQL_DIAG_SOURCE_LINE (integer)
Passed to pg_result_error_field(). The line number of the PostgreSQL source-code location where the error was reported.
PGSQL_DIAG_SOURCE_FUNCTION (integer)
Passed to pg_result_error_field(). The name of the PostgreSQL source-code function reporting the error.
PGSQL_ERRORS_TERSE (integer)
Passed to pg_set_error_verbosity(). Specified that returned messages include severity, primary text, and position only; this will normally fit on a single line.
PGSQL_ERRORS_DEFAULT (integer)
Passed to pg_set_error_verbosity(). The default mode produces messages that include the above plus any detail, hint, or context fields (these may span multiple lines).
PGSQL_ERRORS_VERBOSE (integer)
Passed to pg_set_error_verbosity(). The verbose mode includes all available fields.
PGSQL_STATUS_LONG (integer)
Passed to pg_result_status(). Indicates that numerical result code is desired.
PGSQL_STATUS_STRING (integer)
Passed to pg_result_status(). Indicates that textual result command tag is desired.
PGSQL_CONV_IGNORE_DEFAULT (integer)
Passed to pg_convert(). Ignore default values in the table during conversion.
PGSQL_CONV_FORCE_NULL (integer)
Passed to pg_convert(). Use SQL NULL in place of an empty string.
PGSQL_CONV_IGNORE_DEFAULT (integer)
Passed to pg_convert(). Ignore conversion of NULL into SQL NOT NULL columns.

Poznámky

Poznámka: Not all functions are supported by all builds. It depends on your libpq (The PostgreSQL C client library) version and how libpq is compiled. If PHP PostgreSQL extensions are missing, then it is because your libpq version does not support them.

Poznámka: Most PostgreSQL functions accept connection as the first optional parameter. If it is not provided, the last opened connection is used. If it doesn't exist, functions return FALSE.

Poznámka: PostgreSQL automatically folds all identifiers (e.g. table/column names) to lower-case values at object creation time and at query time. To force the use of mixed or upper case identifiers, you must escape the identifier using double quotes ("").

Poznámka: PostgreSQL does not have special commands for fetching database schema information (eg. all the tables in the current database). Instead, there is a standard schema named information_schema in PostgreSQL 7.4 and above containing system views with all the necessary information, in an easily queryable form. See the » PostgreSQL Documentation for full details.

Příklady

This simple example shows how to connect, execute a query, print resulting rows and disconnect from a PostgreSQL database.

Příklad 1692. PostgreSQL extension overview example

<?php
// Connecting, selecting database
$dbconn = pg_connect("host=localhost dbname=publishing user=www password=foo")
    or die('Could not connect: ' . pg_last_error());

// Performing SQL query
$query = 'SELECT * FROM authors';
$result = pg_query($query) or die('Query failed: ' . pg_last_error());

// Printing results in HTML
echo "<table>\n";
while ($line = pg_fetch_array($result, null, PGSQL_ASSOC)) {
    echo "\t<tr>\n";
    foreach ($line as $col_value) {
        echo "\t\t<td>$col_value</td>\n";
    }
    echo "\t</tr>\n";
}
echo "</table>\n";

// Free resultset
pg_free_result($result);

// Closing connection
pg_close($dbconn);
?>

Obsah

pg_affected_rows — Returns number of affected records (tuples)
pg_cancel_query — Cancel an asynchronous query
pg_client_encoding — Gets the client encoding
pg_close — Closes a PostgreSQL connection
pg_connect — Open a PostgreSQL connection
pg_connection_busy — Get connection is busy or not
pg_connection_reset — Reset connection (reconnect)
pg_connection_status — Get connection status
pg_convert — Convert associative array values into suitable for SQL statement
pg_copy_from — Insert records into a table from an array
pg_copy_to — Copy a table to an array
pg_dbname — Get the database name
pg_delete — Deletes records
pg_end_copy — Sync with PostgreSQL backend
pg_escape_bytea — Escape a string for insertion into a bytea field
pg_escape_string — Escape a string for insertion into a text field
pg_execute — Sends a request to execute a prepared statement with given parameters, and waits for the result.
pg_fetch_all_columns — Fetches all rows in a particular result column as an array
pg_fetch_all — Fetches all rows from a result as an array
pg_fetch_array — Fetch a row as an array
pg_fetch_assoc — Fetch a row as an associative array
pg_fetch_object — Fetch a row as an object
pg_fetch_result — Returns values from a result resource
pg_fetch_row — Get a row as an enumerated array
pg_field_is_null — Test if a field is SQL NULL
pg_field_name — Returns the name of a field
pg_field_num — Returns the field number of the named field
pg_field_prtlen — Returns the printed length
pg_field_size — Returns the internal storage size of the named field
pg_field_table — Returns the name or oid of the tables field
pg_field_type_oid — Returns the type ID (OID) for the corresponding field number
pg_field_type — Returns the type name for the corresponding field number
pg_free_result — Free result memory
pg_get_notify — Gets SQL NOTIFY message
pg_get_pid — Gets the backend's process ID
pg_get_result — Get asynchronous query result
pg_host — Returns the host name associated with the connection
pg_insert — Insert array into table
pg_last_error — Get the last error message string of a connection
pg_last_notice — Returns the last notice message from PostgreSQL server
pg_last_oid — Returns the last row's OID
pg_lo_close — Close a large object
pg_lo_create — Create a large object
pg_lo_export — Export a large object to file
pg_lo_import — Import a large object from file
pg_lo_open — Open a large object
pg_lo_read_all — Reads an entire large object and send straight to browser
pg_lo_read — Read a large object
pg_lo_seek — Seeks position within a large object
pg_lo_tell — Returns current seek position a of large object
pg_lo_unlink — Delete a large object
pg_lo_write — Write to a large object
pg_meta_data — Get meta data for table
pg_num_fields — Returns the number of fields in a result
pg_num_rows — Returns the number of rows in a result
pg_options — Get the options associated with the connection
pg_parameter_status — Looks up a current parameter setting of the server.
pg_pconnect — Open a persistent PostgreSQL connection
pg_ping — Ping database connection
pg_port — Return the port number associated with the connection
pg_prepare — Submits a request to create a prepared statement with the given parameters, and waits for completion.
pg_put_line — Send a NULL-terminated string to PostgreSQL backend
pg_query_params — Submits a command to the server and waits for the result, with the ability to pass parameters separately from the SQL command text.
pg_query — Execute a query
pg_result_error_field — Returns an individual field of an error report.
pg_result_error — Get error message associated with result
pg_result_seek — Set internal row offset in result resource
pg_result_status — Get status of query result
pg_select — Select records
pg_send_execute — Sends a request to execute a prepared statement with given parameters, without waiting for the result(s).
pg_send_prepare — Sends a request to create a prepared statement with the given parameters, without waiting for completion.
pg_send_query_params — Submits a command and separate parameters to the server without waiting for the result(s).
pg_send_query — Sends asynchronous query
pg_set_client_encoding — Set the client encoding
pg_set_error_verbosity — Determines the verbosity of messages returned by pg_last_error() and pg_result_error().
pg_trace — Enable tracing a PostgreSQL connection
pg_transaction_status — Returns the current in-transaction status of the server.
pg_tty — Return the TTY name associated with the connection
pg_unescape_bytea — Unescape binary for bytea type
pg_untrace — Disable tracing of a PostgreSQL connection
pg_update — Update table
pg_version — Returns an array with client, protocol and server version (when available)
Předcházející | Nahoru | Další
sql_regcase | Domů | pg_affected_rows


pg_affected_rows

(PHP 4 >= 4.2.0, PHP 5)

pg_affected_rows — Returns number of affected records (tuples)

Popis

int pg_affected_rows ( resource $result )

pg_affected_rows() returns the number of tuples (instances/records/rows) affected by INSERT, UPDATE, and DELETE queries.

Poznámka: This function used to be called pg_cmdtuples().

Seznam parametrů

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

Návratové hodnoty

The number of rows affected by the query. If no tuple is affected, it will return 0.

Příklady

Příklad 1693. pg_affected_rows() example

<?php
$result = pg_query($conn, "INSERT INTO authors VALUES ('Orwell', 2002, 'Animal Farm')");

$cmdtuples = pg_affected_rows($result);

echo $cmdtuples . " tuples are affected.\n";
?>

Výše uvedený příklad vypíše:

1 tuples are affected.

Viz také

pg_query()
pg_query_params()
pg_execute()
pg_num_rows()

Předcházející | Nahoru | Další
CXXVII. PostgreSQL Functions | Domů | pg_cancel_query


pg_cancel_query

(PHP 4 >= 4.2.0, PHP 5)

pg_cancel_query — Cancel an asynchronous query

Popis

bool pg_cancel_query ( resource $connection )

pg_cancel_query() cancels an asynchronous query sent with pg_send_query(), pg_send_query_params() or pg_send_execute(). You cannot cancel a query executed using pg_query().

Seznam parametrů

connection

PostgreSQL database connection resource.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1694. pg_cancel_query() example

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

  if (!pg_connection_busy($dbconn)) {
      pg_send_query($dbconn, "select * from authors; select count(*) from authors;");
  }

  $res1 = pg_get_result($dbconn);
  echo "First call to pg_get_result(): $res1\n";
  $rows1 = pg_num_rows($res1);
  echo "$res1 has $rows1 records\n\n";

  // Cancel the currently running query.  Will be the second query if it is
  // still running.
  pg_cancel_query($dbconn);
?>

Výše uvedený příklad vypíše:

First call to pg_get_result(): Resource id #3
Resource id #3 has 3 records

Viz také

pg_send_query()
pg_connection_busy()

Předcházející | Nahoru | Další
pg_affected_rows | Domů | pg_client_encoding


pg_client_encoding

(PHP 4 >= 4.0.3, PHP 5)

pg_client_encoding — Gets the client encoding

Popis

string pg_client_encoding ( [resource $connection] )

PostgreSQL supports automatic character set conversion between server and client for certain character sets. pg_client_encoding() returns the client encoding as a string. The returned string will be one of the standard PostgreSQL encoding identifiers.

Poznámka: This function requires PHP 4.0.3 or higher and PostgreSQL 7.0 or higher. If libpq is compiled without multibyte encoding support, pg_client_encoding() always returns SQL_ASCII. Supported encoding depends on PostgreSQL version. Refer to the PostgreSQL Documentation supported encodings.

The function used to be called pg_clientencoding().

Seznam parametrů

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

Návratové hodnoty

The client encoding, or FALSE on error.

Příklady

Příklad 1695. pg_client_encoding() example

<?php
// Assume $conn is a connection to a ISO-8859-1 database
$encoding = pg_client_encoding($conn);

echo "Client encoding is: ", $encoding, "\n";
?>

Výše uvedený příklad vypíše:

Client encoding is: ISO-8859-1

Viz také

pg_set_client_encoding()

Předcházející | Nahoru | Další
pg_cancel_query | Domů | pg_close


pg_close

(PHP 4, PHP 5)

pg_close — Closes a PostgreSQL connection

Popis

bool pg_close ( [resource $connection] )

pg_close() closes the non-persistent connection to a PostgreSQL database associated with the given connection resource.

Poznámka: Using pg_close() is not usually necessary, as non-persistent open connections are automatically closed at the end of the script.

If there is open large object resource on the connection, do not close the connection before closing all large object resources.

Seznam parametrů

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1696. pg_close() example

<?php
$dbconn = pg_connect("host=localhost port=5432 dbname=mary")
   or die("Could not connect");
echo "Connected successfully";
pg_close($dbconn);
?>

Výše uvedený příklad vypíše:

Connected successfully

Viz také

pg_connect()

Předcházející | Nahoru | Další
pg_client_encoding | Domů | pg_connect


pg_connect

(PHP 4, PHP 5)

pg_connect — Open a PostgreSQL connection

Popis

resource pg_connect ( string $connection_string [, int $connect_type] )

pg_connect() opens a connection to a PostgreSQL database specified by the connection_string.

If a second call is made to pg_connect() with the same connection_string as an existing connection, the existing connection will be returned unless you pass PGSQL_CONNECT_FORCE_NEW as connect_type.

The old syntax with multiple parameters $conn = pg_connect("host", "port", "options", "tty", "dbname") has been deprecated.

Seznam parametrů

connection_string

The connection_string can be empty to use all default parameters, or it can contain one or more parameter settings separated by whitespace. Each parameter setting is in the form keyword = value. Spaces around the equal sign are optional. To write an empty value or a value containing spaces, surround it with single quotes, e.g., keyword = 'a value'. Single quotes and backslashes within the value must be escaped with a backslash, i.e., \' and \\.

The currently recognized parameter keywords are: host, hostaddr, port, dbname, user, password, connect_timeout, options, tty (ignored), sslmode, requiressl (deprecated in favor of sslmode), and service. Which of these arguments exist depends on your PostgreSQL version.

connect_type

If PGSQL_CONNECT_FORCE_NEW is passed, then a new connection is created, even if the connection_string is identical to an existing connection.

Návratové hodnoty

PostgreSQL connection resource on success, FALSE on failure.

Příklady

Příklad 1697. Using pg_connect()

<?php
$dbconn = pg_connect("dbname=mary");
//connect to a database named "mary"

$dbconn2 = pg_connect("host=localhost port=5432 dbname=mary");
// connect to a database named "mary" on "localhost" at port "5432"

$dbconn3 = pg_connect("host=sheep port=5432 dbname=mary user=lamb password=foo");
//connect to a database named "mary" on the host "sheep" with a username and password

$conn_string = "host=sheep port=5432 dbname=test user=lamb password=bar";
$dbconn4 = pg_connect($conn_string);
//connect to a database named "test" on the host "sheep" with a username and password
?>

Viz také

pg_pconnect()
pg_close()
pg_host()
pg_port()
pg_tty()
pg_options()
pg_dbname()

Předcházející | Nahoru | Další
pg_close | Domů | pg_connection_busy


pg_connection_busy

(PHP 4 >= 4.2.0, PHP 5)

pg_connection_busy — Get connection is busy or not

Popis

bool pg_connection_busy ( resource $connection )

pg_connection_busy() determines whether or not a connection is busy. If it is busy, a previous query is still executing. If pg_get_result() is used on the connection, it will be blocked.

Seznam parametrů

connection

PostgreSQL database connection resource.

Návratové hodnoty

Returns TRUE if the connection is busy, FALSE otherwise.

Příklady

Příklad 1698. pg_connection_busy() example

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");
  $bs = pg_connection_busy($dbconn);
  if ($bs) {
      echo 'connection is busy';
  } else {
     echo 'connection is not busy';
  }
?>

Viz také

pg_connection_status()
pg_get_result()

Předcházející | Nahoru | Další
pg_connect | Domů | pg_connection_reset


pg_connection_reset

(PHP 4 >= 4.2.0, PHP 5)

pg_connection_reset — Reset connection (reconnect)

Popis

bool pg_connection_reset ( resource $connection )

pg_connection_reset() resets the connection. It is useful for error recovery.

Seznam parametrů

connection

PostgreSQL database connection resource.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1699. pg_connection_reset() example

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");
  $dbconn2 = pg_connection_reset($dbconn);
  if ($dbconn2) {
      echo "reset successful\n";
  } else {
      echo "reset failed\n";
  }
?>

Viz také

pg_connect()
pg_pconnect()
pg_connection_status()

Předcházející | Nahoru | Další
pg_connection_busy | Domů | pg_connection_status


pg_connection_status

(PHP 4 >= 4.2.0, PHP 5)

pg_connection_status — Get connection status

Popis

int pg_connection_status ( resource $connection )

pg_connection_status() returns the status of the specified connection.

Seznam parametrů

connection

PostgreSQL database connection resource.

Návratové hodnoty

PGSQL_CONNECTION_OK or PGSQL_CONNECTION_BAD.

Příklady

Příklad 1700. pg_connection_status() example

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");
  $stat = pg_connection_status($dbconn);
  if ($stat === PGSQL_CONNECTION_OK) {
      echo 'Connection status ok';
  } else {
      echo 'Connection status bad';
  }
?>

Viz také

pg_connection_busy()

Předcházející | Nahoru | Další
pg_connection_reset | Domů | pg_convert


pg_convert

(PHP 4 >= 4.3.0, PHP 5)

pg_convert — Convert associative array values into suitable for SQL statement

Popis

array pg_convert ( resource $connection, string $table_name, array $assoc_array [, int $options] )

pg_convert() checks and converts the values in assoc_array into suitable values for use in a SQL statement. Precondition for pg_convert() is the existence of a table table_name which has at least as many columns as assoc_array has elements. The fieldnames in table_name must match the indices in assoc_array and the corresponding datatypes must be compatible. Returns an array with the converted values on success, FALSE otherwise.

Poznámka: If there are boolean fields in table_name don't use the constant TRUE in assoc_array. It will be converted to the string 'TRUE' which is no valid entry for boolean fields in PostgreSQL. Use one of t, true, 1, y, yes instead.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Seznam parametrů

connection

PostgreSQL database connection resource.

table_name

Name of the table against which to convert types.

assoc_array

Data to be converted.

options

Any number of PGSQL_CONV_IGNORE_DEFAULT, PGSQL_CONV_FORCE_NULL or PGSQL_CONV_IGNORE_NOT_NULL, combined.

Návratové hodnoty

An array of converted values, or FALSE on error.

Příklady

Příklad 1701. pg_convert() example

<?php
  $dbconn = pg_connect('dbname=foo');

  $tmp = array(
      'author' => 'Joe Thackery',
      'year' => 2005,
      'title' => 'My Life, by Joe Thackery'
  );

  $vals = pg_convert($dbconn, 'authors', $tmp);
?>

Viz také

pg_meta_data()

Předcházející | Nahoru | Další
pg_connection_status | Domů | pg_copy_from


pg_copy_from

(PHP 4 >= 4.2.0, PHP 5)

pg_copy_from — Insert records into a table from an array

Popis

bool pg_copy_from ( resource $connection, string $table_name, array $rows [, string $delimiter [, string $null_as]] )

pg_copy_from() inserts records into a table from rows. It issues a COPY FROM SQL command internally to insert records.

Seznam parametrů

connection

PostgreSQL database connection resource.

table_name

Name of the table into which to copy the rows.

rows

An array of data to be copied into table_name. Each value in rows becomes a row in table_name. Each value in rows should be a delimited string of the values to insert into each field. Values should be linefeed terminated.

delimiter

The token that separates values for each field in each element of rows. Default is TAB.

null_as

How SQL NULL values are represented in the rows. Default is \N ("\\N").

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1702. pg_copy_from() example

<?php
   $db = pg_connect("dbname=publisher") or die("Could not connect");

   $rows = pg_copy_to($db, $table_name);

   pg_query($db, "DELETE FROM $table_name");

   pg_copy_from($db, $table_name, $rows);
?>

Viz také

pg_copy_to()

Předcházející | Nahoru | Další
pg_convert | Domů | pg_copy_to


pg_copy_to

(PHP 4 >= 4.2.0, PHP 5)

pg_copy_to — Copy a table to an array

Popis

array pg_copy_to ( resource $connection, string $table_name [, string $delimiter [, string $null_as]] )

pg_copy_to() copies a table to an array. It issues COPY TO SQL command internally to retrieve records.

Seznam parametrů

connection

PostgreSQL database connection resource.

table_name

Name of the table from which to copy the data into rows.

delimiter

The token that separates values for each field in each element of rows. Default is TAB.

null_as

How SQL NULL values are represented in the rows. Default is \N ("\\N").

Návratové hodnoty

An array with one element for each line of COPY data. It returns FALSE on failure.

Příklady

Příklad 1703. pg_copy_to() example

<?php
   $db = pg_connect("dbname=publisher") or die("Could not connect");

   $rows = pg_copy_to($db, $table_name);

   pg_query($db, "DELETE FROM $table_name");

   pg_copy_from($db, $table_name, $rows);
?>

Viz také

pg_copy_from()

Předcházející | Nahoru | Další
pg_copy_from | Domů | pg_dbname


pg_dbname

(PHP 4, PHP 5)

pg_dbname — Get the database name

Popis

string pg_dbname ( [resource $connection] )

pg_dbname() returns the name of the database that the given PostgreSQL connection resource.

Seznam parametrů

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

Návratové hodnoty

A string containing the name of the database the connection is to, or FALSE on error.

Příklady

Příklad 1704. pg_dbname() example

<?php
  error_reporting(E_ALL);

  pg_connect("host=localhost port=5432 dbname=mary");
  echo pg_dbname(); // mary
?>

Předcházející | Nahoru | Další
pg_copy_to | Domů | pg_delete


pg_delete

(PHP 4 >= 4.3.0, PHP 5)

pg_delete — Deletes records

Popis

mixed pg_delete ( resource $connection, string $table_name, array $assoc_array [, int $options] )

pg_delete() deletes records from a table specified by the keys and values in assoc_array. If options is specified, pg_convert() is applied to assoc_array with the specified options.

Seznam parametrů

connection

PostgreSQL database connection resource.

table_name

Name of the table from which to delete rows.

assoc_array

An array whose keys are field names in the table table_name, and whose values are the values of those fields that are to be deleted.

options

Any number of PGSQL_CONV_FORCE_NULL, PGSQL_DML_NO_CONV, PGSQL_DML_EXEC or PGSQL_DML_STRING combined. If PGSQL_DML_STRING is part of the options then query string is returned.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání. Returns string if PGSQL_DML_STRING is passed via options.

Příklady

Příklad 1705. pg_delete() example

<?php
  $db = pg_connect('dbname=foo');
  // This is safe, since $_POST is converted automatically
  $res = pg_delete($db, 'post_log', $_POST);
  if ($res) {
      echo "POST data is deleted: $res\n";
  } else {
      echo "User must have sent wrong inputs\n";
  }
?>

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Viz také

pg_convert()

Předcházející | Nahoru | Další
pg_dbname | Domů | pg_end_copy


pg_end_copy

(PHP 4 >= 4.0.3, PHP 5)

pg_end_copy — Sync with PostgreSQL backend

Popis

bool pg_end_copy ( [resource $connection] )

pg_end_copy() syncs the PostgreSQL frontend (usually a web server process) with the PostgreSQL server after doing a copy operation performed by pg_put_line(). pg_end_copy() must be issued, otherwise the PostgreSQL server may get out of sync with the frontend and will report an error.

Seznam parametrů

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1706. pg_end_copy() example

<?php
  $conn = pg_pconnect("dbname=foo");
  pg_query($conn, "create table bar (a int4, b char(16), d float8)");
  pg_query($conn, "copy bar from stdin");
  pg_put_line($conn, "3\thello world\t4.5\n");
  pg_put_line($conn, "4\tgoodbye world\t7.11\n");
  pg_put_line($conn, "\\.\n");
  pg_end_copy($conn);
?>

Viz také

pg_put_line()

Předcházející | Nahoru | Další
pg_delete | Domů | pg_escape_bytea


pg_escape_bytea

(PHP 4 >= 4.2.0, PHP 5)

pg_escape_bytea — Escape a string for insertion into a bytea field

Popis

string pg_escape_bytea ( [resource $connection, string $data] )

pg_escape_bytea() escapes string for bytea datatype. It returns escaped string.

Poznámka: When you SELECT a bytea type, PostgreSQL returns octal byte values prefixed with '\' (e.g. \032). Users are supposed to convert back to binary format manually.

This function requires PostgreSQL 7.2 or later. With PostgreSQL 7.2.0 and 7.2.1, bytea values must be cast when you enable multi-byte support. i.e. INSERT INTO test_table (image) VALUES ('$image_escaped'::bytea); PostgreSQL 7.2.2 or later does not need a cast. The exception is when the client and backend character encoding does not match, and there may be multi-byte stream error. User must then cast to bytea to avoid this error.

Seznam parametrů

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

data

A string containing text or binary data to be inserted into a bytea column.

Návratové hodnoty

A string containing the escaped data.

ChangeLog (záznam změn)

Verze | Popis
5.2.0 | connection added

Příklady

Příklad 1707. pg_escape_bytea() example

<?php
  // Connect to the database
  $dbconn = pg_connect('dbname=foo');

  // Read in a binary file
  $data = file_get_contents('image1.jpg');

  // Escape the binary data
  $escaped = pg_escape_bytea($data);

  // Insert it into the database
  pg_query("INSERT INTO gallery (name, data) VALUES ('Pine trees', '{$escaped}')");
?>

Viz také

pg_unescape_bytea()
pg_escape_string()

Předcházející | Nahoru | Další
pg_end_copy | Domů | pg_escape_string


pg_escape_string

(PHP 4 >= 4.2.0, PHP 5)

pg_escape_string — Escape a string for insertion into a text field

Popis

string pg_escape_string ( [resource $connection, string $data] )

pg_escape_string() escapes a string for insertion into the database. It returns an escaped string in the PostgreSQL format. Use of this function is recommended instead of addslashes(). If the type of the column is bytea, pg_escape_bytea() must be used instead.

Poznámka: This function requires PostgreSQL 7.2 or later.

Seznam parametrů

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

data

A string containing text to be escaped.

Návratové hodnoty

A string containing the escaped data.

ChangeLog (záznam změn)

Verze | Popis
5.2.0 | connection added

Příklady

Příklad 1708. pg_escape_string() example

<?php
  // Connect to the database
  $dbconn = pg_connect('dbname=foo');

  // Read in a text file (containing apostrophes and backslashes)
  $data = file_get_contents('letter.txt');

  // Escape the text data
  $escaped = pg_escape_string($data);

  // Insert it into the database
  pg_query("INSERT INTO correspondence (name, data) VALUES ('My letter', '{$escaped}')");
?>

Viz také

pg_escape_bytea()

Předcházející | Nahoru | Další
pg_escape_bytea | Domů | pg_execute


pg_fetch_all

(PHP 4 >= 4.3.0, PHP 5)

pg_fetch_all — Fetches all rows from a result as an array

Popis

array pg_fetch_all ( resource $result )

pg_fetch_all() returns an array that contains all rows (records) in the result resource.

Poznámka: Tato funkce nastavuje pole s hodnotou NULL na hodnotu PHP NULL.

Seznam parametrů

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

Návratové hodnoty

An array with all rows in the result. Each row is an array of field values indexed by field name.

FALSE is returned if there are no rows in the result, or on any other error.

Příklady

Příklad 1711. PostgreSQL fetch all

<?php
$conn = pg_pconnect("dbname=publisher");
if (!$conn) {
  echo "An error occured.\n";
  exit;
}

$result = pg_query($conn, "SELECT * FROM authors");
if (!$result) {
  echo "An error occured.\n";
  exit;
}

$arr = pg_fetch_all($result);

var_dump($arr);

?>

Viz také

pg_fetch_row()
pg_fetch_array()
pg_fetch_object()
pg_fetch_result()

Předcházející | Nahoru | Další
pg_fetch_all_columns | Domů | pg_fetch_array


pg_fetch_array

(PHP 4, PHP 5)

pg_fetch_array — Fetch a row as an array

Popis

array pg_fetch_array ( resource $result [, int $row [, int $result_type]] )

pg_fetch_array() returns an array that corresponds to the fetched row (record).

pg_fetch_array() is an extended version of pg_fetch_row(). In addition to storing the data in the numeric indices (field number) to the result array, it can also store the data using associative indices (field name). It stores both indicies by default.

Poznámka: Tato funkce nastavuje pole s hodnotou NULL na hodnotu PHP NULL.

pg_fetch_array() is NOT significantly slower than using pg_fetch_row(), and is significantly easier to use.

Seznam parametrů

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

row

Row number in result to fetch. Rows are numbered from 0 upwards. If omitted, next row is fetched.

result_type

An optional parameter that controls how the returned array is indexed. result_type is a constant and can take the following values: PGSQL_ASSOC, PGSQL_NUM and PGSQL_BOTH. Using PGSQL_NUM, pg_fetch_array() will return an array with numerical indices, using PGSQL_ASSOC it will return only associative indices while PGSQL_BOTH, the default, will return both numerical and associative indices.

Návratové hodnoty

An array indexed numerically (beginning with 0) or associatively (indexed by field name), or both. Each value in the array is represented as a string. Database NULL values are returned as NULL.

FALSE is returned if row exceeds the number of rows in the set, there are no more rows, or on any other error.

ChangeLog (záznam změn)

Verze | Popis
4.1.0 | The row parameter became optional.
4.0.0 | The result_type parameter was added.

Příklady

Příklad 1712. pg_fetch_array() example

<?php

$conn = pg_pconnect("dbname=publisher");
if (!$conn) {
  echo "An error occured.\n";
  exit;
}

$result = pg_query($conn, "SELECT author, email FROM authors");
if (!$result) {
  echo "An error occured.\n";
  exit;
}

$arr = pg_fetch_array($result, 0, PGSQL_NUM);
echo $arr[0] . " <- Row 1 Author\n";
echo $arr[1] . " <- Row 1 E-mail\n";

// As of PHP 4.1.0, the row parameter is optional; NULL can be passed instead,
// to pass a result_type.  Successive calls to pg_fetch_array will return the
// next row.
$arr = pg_fetch_array($result, NULL, PGSQL_ASSOC);
echo $arr["author"] . " <- Row 2 Author\n";
echo $arr["email"] . " <- Row 2 E-mail\n";

$arr = pg_fetch_array($result);
echo $arr["author"] . " <- Row 3 Author\n";
echo $arr[1] . " <- Row 3 E-mail\n";

?>

Viz také

pg_fetch_row()
pg_fetch_object()
pg_fetch_result()

Předcházející | Nahoru | Další
pg_fetch_all | Domů | pg_fetch_assoc


pg_fetch_assoc

(PHP 4 >= 4.3.0, PHP 5)

pg_fetch_assoc — Fetch a row as an associative array

Popis

array pg_fetch_assoc ( resource $result [, int $row] )

pg_fetch_assoc() returns an associative array that corresponds to the fetched row (records).

pg_fetch_assoc() is equivalent to calling pg_fetch_array() with PGSQL_ASSOC as the optional third parameter. It only returns an associative array. If you need the numeric indices, use pg_fetch_row().

Poznámka: Tato funkce nastavuje pole s hodnotou NULL na hodnotu PHP NULL.

pg_fetch_assoc() is NOT significantly slower than using pg_fetch_row(), and is significantly easier to use.

Seznam parametrů

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

row

Row number in result to fetch. Rows are numbered from 0 upwards. If omitted, next row is fetched.

Návratové hodnoty

An array indexed associatively (by field name). Each value in the array is represented as a string. Database NULL values are returned as NULL.

FALSE is returned if row exceeds the number of rows in the set, there are no more rows, or on any other error.

ChangeLog (záznam změn)

Verze | Popis
4.1.0 | The parameter row became optional.

Příklady

Příklad 1713. pg_fetch_assoc() example

<?php
$conn = pg_connect("dbname=publisher");
if (!$conn) {
  echo "An error occured.\n";
  exit;
}

$result = pg_query($conn, "SELECT id, author, email FROM authors");
if (!$result) {
  echo "An error occured.\n";
  exit;
}

while ($row = pg_fetch_assoc($result)) {
  echo $row['id'];
  echo $row['author'];
  echo $row['email'];
}
?>

Viz také

pg_fetch_row()
pg_fetch_array()
pg_fetch_object()
pg_fetch_result()

Předcházející | Nahoru | Další
pg_fetch_array | Domů | pg_fetch_object


pg_fetch_object

(PHP 4, PHP 5)

pg_fetch_object — Fetch a row as an object

Popis

object pg_fetch_object ( resource $result [, int $row [, int $result_type]] )
object pg_fetch_object ( resource $result [, int $row [, string $class_name [, array $params]]] )

pg_fetch_object() returns an object with properties that correspond to the fetched row's field names. It can optionally instantiate an object of a specific class, and pass parameters to that class's constructor.

Poznámka: Tato funkce nastavuje pole s hodnotou NULL na hodnotu PHP NULL.

Speed-wise, the function is identical to pg_fetch_array(), and almost as fast as pg_fetch_row() (the difference is insignificant).

Seznam parametrů

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

row

Row number in result to fetch. Rows are numbered from 0 upwards. If omitted, next row is fetched.

result_type

Ignored and deprecated. Defaults to PGSQL_ASSOC.

class_name

The name of the class to instantiate, set the properties of and return. If not specified, a stdClass object is returned.

params

An optional array of parameters to pass to the constructor for class_name objects.

Návratové hodnoty

An object with one attribute for each field name in the result. Database NULL values are returned as NULL.

FALSE is returned if row exceeds the number of rows in the set, there are no more rows, or on any other error.

ChangeLog (záznam změn)

Verze | Popis
5.0.0 | class_name and params were added. The old form with result_type still exists for backwards compatibility.
4.3.0 | result_type default changed from PGSQL_BOTH to PGSQL_ASSOC, since the numeric index was illegal.
4.1.0 | The parameter row became optional.

Příklady

Příklad 1714. pg_fetch_object() example

<?php

$database = "store";

$db_conn = pg_connect("host=localhost port=5432 dbname=$database");
if (!$db_conn) {
  echo "Failed connecting to postgres database $database\n";
  exit;
}

$qu = pg_query($db_conn, "SELECT * FROM books ORDER BY author");

while ($data = pg_fetch_object($qu)) {
  echo $data->author . " (";
  echo $data->year . "): ";
  echo $data->title . "<br />";
}

pg_free_result($qu);
pg_close($db_conn);

?>

Viz také

pg_query()
pg_fetch_array()
pg_fetch_assoc()
pg_fetch_row()
pg_fetch_result()

Předcházející | Nahoru | Další
pg_fetch_assoc | Domů | pg_fetch_result


pg_fetch_result

(PHP 4 >= 4.2.0, PHP 5)

pg_fetch_result — Returns values from a result resource

Popis

string pg_fetch_result ( resource $result, int $row, mixed $field )
string pg_fetch_result ( resource $result, mixed $field )

pg_fetch_result() returns the value of a particular row and field (column) in a PostgreSQL result resource.

Poznámka: This function used to be called pg_result().

Seznam parametrů

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

row

Row number in result to fetch. Rows are numbered from 0 upwards. If omitted, next row is fetched.

field

A string representing the name of the field (column) to fetch, otherwise and int representing the field number to fetch. Fields are numbered from 0 upwards.

Návratové hodnoty

Boolean is returned as "t" or "f". All other types, including arrays are returned as strings formatted in the same default PostgreSQL manner that you would see in the psql program. Database NULL values are returned as NULL.

FALSE is returned if row exceeds the number of rows in the set, or on any other error.

Příklady

Příklad 1715. pg_fetch_result() example

<?php
$db = pg_connect("dbname=users user=me") || die();

$res = pg_query($db, "SELECT 1 UNION ALL SELECT 2");

$val = pg_fetch_result($res, 1, 0);

echo "First field in the second row is: ", $val, "\n";
?>

Výše uvedený příklad vypíše:

First field in the second row is: 2

Viz také

pg_query()
pg_fetch_array()

Předcházející | Nahoru | Další
pg_fetch_object | Domů | pg_fetch_row


pg_fetch_row

(PHP 4, PHP 5)

pg_fetch_row — Get a row as an enumerated array

Popis

array pg_fetch_row ( resource $result [, int $row] )

pg_fetch_row() fetches one row of data from the result associated with the specified result resource.

Poznámka: Tato funkce nastavuje pole s hodnotou NULL na hodnotu PHP NULL.

Seznam parametrů

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

row

Row number in result to fetch. Rows are numbered from 0 upwards. If omitted, next row is fetched.

Návratové hodnoty

An array, indexed from 0 upwards, with each value represented as a string. Database NULL values are returned as NULL.

FALSE is returned if row exceeds the number of rows in the set, there are no more rows, or on any other error.

ChangeLog (záznam změn)

Verze | Popis
4.1.0 | The parameter row became optional.

Příklady

Příklad 1716. pg_fetch_row() example

<?php

$conn = pg_pconnect("dbname=publisher");
if (!$conn) {
  echo "An error occured.\n";
  exit;
}

$result = pg_query($conn, "SELECT author, email FROM authors");
if (!$result) {
  echo "An error occured.\n";
  exit;
}

while ($row = pg_fetch_row($result)) {
  echo "Author: $row[0]  E-mail: $row[1]";
  echo "<br />\n";
}

?>

Viz také

pg_query()
pg_fetch_array()
pg_fetch_object()
pg_fetch_result()

Předcházející | Nahoru | Další
pg_fetch_result | Domů | pg_field_is_null


pg_field_is_null

(PHP 4 >= 4.2.0, PHP 5)

pg_field_is_null — Test if a field is SQL NULL

Popis

int pg_field_is_null ( resource $result, int $row, mixed $field )
int pg_field_is_null ( resource $result, mixed $field )

pg_field_is_null() tests if a field in a PostgreSQL result resource is SQL NULL or not.

Poznámka: This function used to be called pg_fieldisnull().

Seznam parametrů

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

row

Row number in result to fetch. Rows are numbered from 0 upwards. If omitted, current row is fetched.

field

Field number (starting from 0) as an integer or the field name as a string.

Návratové hodnoty

Returns 1 if the field in the given row is SQL NULL, 0 if not. FALSE is returned if the row is out of range, or upon any other error.

Příklady

Příklad 1717. pg_field_is_null() example

<?php
  $dbconn = pg_connect("dbname=publisher") or die ("Could not connect");
  $res = pg_query($dbconn, "select * from authors where author = 'Orwell'");
  if ($res) {
      if (pg_field_is_null($res, 0, "year") == 1) {
          echo "The value of the field year is null.\n";
      }
      if (pg_field_is_null($res, 0, "year") == 0) {
          echo "The value of the field year is not null.\n";
    }
 }
?>

Předcházející | Nahoru | Další
pg_fetch_row | Domů | pg_field_name


pg_field_name

(PHP 4 >= 4.2.0, PHP 5)

pg_field_name — Returns the name of a field

Popis

string pg_field_name ( resource $result, int $field_number )

pg_field_name() returns the name of the field occupying the given field_number in the given PostgreSQL result resource. Field numbering starts from 0.

Poznámka: This function used to be called pg_fieldname().

Seznam parametrů

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

field_number

Field number, starting from 0.

Návratové hodnoty

The field name, or FALSE on error.

Příklady

Příklad 1718. Getting information about fields

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

  $res = pg_query($dbconn, "select * from authors where author = 'Orwell'");
  $i = pg_num_fields($res);
  for ($j = 0; $j < $i; $j++) {
      echo "column $j\n";
      $fieldname = pg_field_name($res, $j);
      echo "fieldname: $fieldname\n";
      echo "printed length: " . pg_field_prtlen($res, $fieldname) . " characters\n";
      echo "storage length: " . pg_field_size($res, $j) . " bytes\n";
      echo "field type: " . pg_field_type($res, $j) . " \n\n";
  }
?>

Výše uvedený příklad vypíše:

column 0
fieldname: author
printed length: 6 characters
storage length: -1 bytes
field type: varchar

column 1
fieldname: year
printed length: 4 characters
storage length: 2 bytes
field type: int2

column 2
fieldname: title
printed length: 24 characters
storage length: -1 bytes
field type: varchar

Viz také

pg_field_num()

Předcházející | Nahoru | Další
pg_field_is_null | Domů | pg_field_num


pg_field_num

(PHP 4 >= 4.2.0, PHP 5)

pg_field_num — Returns the field number of the named field

Popis

int pg_field_num ( resource $result, string $field_name )

pg_field_num() will return the number of the field number that corresponds to the field_name in the given PostgreSQL result resource.

Poznámka: This function used to be called pg_fieldnum().

Seznam parametrů

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

field_name

The name of the field.

Návratové hodnoty

The field number (numbered from 0), or -1 on error.

Příklady

Příklad 1719. Getting information about fields

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

  $res = pg_query($dbconn, "select author, year, title from authors where author = 'Orwell'");

  echo "Column 'title' is field number: ", pg_field_num($res, 'title');
?>

Výše uvedený příklad vypíše:

Column 'title' is field number: 2

Viz také

pg_field_name()

Předcházející | Nahoru | Další
pg_field_name | Domů | pg_field_prtlen


pg_field_prtlen

(PHP 4 >= 4.2.0, PHP 5)

pg_field_prtlen — Returns the printed length

Popis

int pg_field_prtlen ( resource $result, int $row_number, mixed $field_name_or_number )
int pg_field_prtlen ( resource $result, mixed $field_name_or_number )

pg_field_prtlen() returns the actual printed length (number of characters) of a specific value in a PostgreSQL result. Row numbering starts at 0. This function will return -1 on an error.

field_name_or_number can be passed either as an integer or as a string. If it is passed as an integer, PHP recognises it as the field number, otherwise as field name.

See the example given at the pg_field_name() page.

Poznámka: This function used to be called pg_fieldprtlen().

Seznam parametrů

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

row

Row number in result. Rows are numbered from 0 upwards. If omitted, current row is fetched.

Návratové hodnoty

The field printed length, or FALSE on error.

Příklady

Příklad 1720. Getting information about fields

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

  $res = pg_query($dbconn, "select * from authors where author = 'Orwell'");
  $i = pg_num_fields($res);
  for ($j = 0; $j < $i; $j++) {
      echo "column $j\n";
      $fieldname = pg_field_name($res, $j);
      echo "fieldname: $fieldname\n";
      echo "printed length: " . pg_field_prtlen($res, $fieldname) . " characters\n";
      echo "storage length: " . pg_field_size($res, $j) . " bytes\n";
      echo "field type: " . pg_field_type($res, $j) . " \n\n";
  }
?>

Výše uvedený příklad vypíše:

column 0
fieldname: author
printed length: 6 characters
storage length: -1 bytes
field type: varchar

column 1
fieldname: year
printed length: 4 characters
storage length: 2 bytes
field type: int2

column 2
fieldname: title
printed length: 24 characters
storage length: -1 bytes
field type: varchar

Viz také

pg_field_size()

Předcházející | Nahoru | Další
pg_field_num | Domů | pg_field_size


pg_field_size

(PHP 4 >= 4.2.0, PHP 5)

pg_field_size — Returns the internal storage size of the named field

Popis

int pg_field_size ( resource $result, int $field_number )

pg_field_size() returns the internal storage size (in bytes) of the field number in the given PostgreSQL result.

Poznámka: This function used to be called pg_fieldsize().

Seznam parametrů

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

field_number

Field number, starting from 0.

Návratové hodnoty

The internal field storage size (in bytes). -1 indicates a variable length field. FALSE is returned on error.

Příklady

Příklad 1721. Getting information about fields

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

  $res = pg_query($dbconn, "select * from authors where author = 'Orwell'");
  $i = pg_num_fields($res);
  for ($j = 0; $j < $i; $j++) {
      echo "column $j\n";
      $fieldname = pg_field_name($res, $j);
      echo "fieldname: $fieldname\n";
      echo "printed length: " . pg_field_prtlen($res, $fieldname) . " characters\n";
      echo "storage length: " . pg_field_size($res, $j) . " bytes\n";
      echo "field type: " . pg_field_type($res, $j) . " \n\n";
  }
?>

Výše uvedený příklad vypíše:

column 0
fieldname: author
printed length: 6 characters
storage length: -1 bytes
field type: varchar

column 1
fieldname: year
printed length: 4 characters
storage length: 2 bytes
field type: int2

column 2
fieldname: title
printed length: 24 characters
storage length: -1 bytes
field type: varchar

Viz také

pg_field_prtlen()
pg_field_type()

Předcházející | Nahoru | Další
pg_field_prtlen | Domů | pg_field_table


pg_field_type

(PHP 4 >= 4.2.0, PHP 5)

pg_field_type — Returns the type name for the corresponding field number

Popis

string pg_field_type ( resource $result, int $field_number )

pg_field_type() returns a string containing the base type name of the given field_number in the given PostgreSQL result resource.

Poznámka: If the field uses a PostgreSQL domain (rather than a basic type), it is the name of the domain's underlying type that is returned, rather than the name of the domain itself.

Poznámka: This function used to be called pg_fieldtype().

Seznam parametrů

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

field_number

Field number, starting from 0.

Návratové hodnoty

A string containing the base name of the field's type, or FALSE on error.

Příklady

Příklad 1724. Getting information about fields

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

  // Assume 'title' is a varchar type
  $res = pg_query($dbconn, "select title from authors where author = 'Orwell'");

  echo "Title field type: ", pg_field_type($res, 0);
?>

Výše uvedený příklad vypíše:

Title field type: varchar

Viz také

pg_field_prtlen()
pg_field_name()
pg_field_type_oid()

Předcházející | Nahoru | Další
pg_field_type_oid | Domů | pg_free_result


pg_free_result

(PHP 4 >= 4.2.0, PHP 5)

pg_free_result — Free result memory

Popis

bool pg_free_result ( resource $result )

pg_free_result() frees the memory and data associated with the specified PostgreSQL query result resource.

This function need only be called if memory consumption during script execution is a problem. Otherwise, all result memory will be automatically freed when the script ends.

Poznámka: This function used to be called pg_freeresult().

Seznam parametrů

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1725. pg_free_result() example

<?php
$db = pg_connect("dbname=users user=me") || die();

$res = pg_query($db, "SELECT 1 UNION ALL SELECT 2");

$val = pg_fetch_result($res, 1, 0);

echo "First field in the second row is: ", $val, "\n";

pg_free_result($res);
?>

Výše uvedený příklad vypíše:

First field in the second row is: 2

Viz také

pg_query()
pg_query_params()
pg_execute()

Předcházející | Nahoru | Další
pg_field_type | Domů | pg_get_notify


pg_get_notify

(PHP 4 >= 4.3.0, PHP 5)

pg_get_notify — Gets SQL NOTIFY message

Popis

array pg_get_notify ( resource $connection [, int $result_type] )

pg_get_notify() gets notifications generated by a NOTIFY SQL command. To receive notifications, the LISTEN SQL command must be issued.

Seznam parametrů

connection

PostgreSQL database connection resource.

result_type

An optional parameter that controls how the returned array is indexed. result_type is a constant and can take the following values: PGSQL_ASSOC, PGSQL_NUM and PGSQL_BOTH. Using PGSQL_NUM, pg_get_notify() will return an array with numerical indices, using PGSQL_ASSOC it will return only associative indices while PGSQL_BOTH, the default, will return both numerical and associative indices.

Návratové hodnoty

An array containing the NOTIFY message name and backend PID. Otherwise if no NOTIFY is waiting, then FALSE is returned.

Příklady

Příklad 1726. PostgreSQL NOTIFY message

<?php
$conn = pg_pconnect("dbname=publisher");
if (!$conn) {
  echo "An error occured.\n";
  exit;
}

// Listen 'author_updated' message from other processes
pg_query($conn, 'LISTEN author_updated;');
$notify = pg_get_notify($conn);
if (!$notify) {
  echo "No messages\n";
} else {
  print_r($notify);
}
?>

Viz také

pg_get_pid()

Předcházející | Nahoru | Další
pg_free_result | Domů | pg_get_pid


pg_get_pid

(PHP 4 >= 4.3.0, PHP 5)

pg_get_pid — Gets the backend's process ID

Popis

int pg_get_pid ( resource $connection )

pg_get_pid() gets the backend's (database server process) PID. The PID is useful to determine whether or not a NOTIFY message received via pg_get_notify() is sent from another process or not.

Seznam parametrů

connection

PostgreSQL database connection resource.

Návratové hodnoty

The backend database process ID.

Příklady

Příklad 1727. PostgreSQL backend PID

<?php
$conn = pg_pconnect("dbname=publisher");
if (!$conn) {
  echo "An error occured.\n";
  exit;
}

// Backend process PID. Use PID with pg_get_notify()
$pid = pg_get_pid($conn);
?>

Viz také

pg_get_notify()

Předcházející | Nahoru | Další
pg_get_notify | Domů | pg_get_result


pg_get_result

(PHP 4 >= 4.2.0, PHP 5)

pg_get_result — Get asynchronous query result

Popis

resource pg_get_result ( [resource $connection] )

pg_get_result() gets the result resource from an asynchronous query executed by pg_send_query(), pg_send_query_params() or pg_send_execute().

pg_send_query() and the other asynchronous query functions can send multiple queries to a PostgreSQL server and pg_get_result() is used to get each query's results, one by one.

Seznam parametrů

connection

PostgreSQL database connection resource.

Návratové hodnoty

The result resource, or FALSE if no more results are available.

Příklady

Příklad 1728. pg_get_result() example

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

  if (!pg_connection_busy($dbconn)) {
      pg_send_query($dbconn, "select * from authors; select count(*) from authors;");
  }

  $res1 = pg_get_result($dbconn);
  echo "First call to pg_get_result(): $res1\n";
  $rows1 = pg_num_rows($res1);
  echo "$res1 has $rows1 records\n\n";

  $res2 = pg_get_result($dbconn);
  echo "Second call to pg_get_result(): $res2\n";
  $rows2 = pg_num_rows($res2);
  echo "$res2 has $rows2 records\n";
?>

Výše uvedený příklad vypíše:

First call to pg_get_result(): Resource id #3
Resource id #3 has 3 records

Second call to pg_get_result(): Resource id #4
Resource id #4 has 1 records

Viz také

pg_send_query()

Předcházející | Nahoru | Další
pg_get_pid | Domů | pg_host


pg_host

(PHP 4, PHP 5)

pg_host — Returns the host name associated with the connection

Popis

string pg_host ( [resource $connection] )

pg_host() returns the host name of the given PostgreSQL connection resource is connected to.

Seznam parametrů

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

Návratové hodnoty

A string containing the name of the host the connection is to, or FALSE on error.

Příklady

Příklad 1729. pg_host() example

<?php
$pgsql_conn = pg_connect("dbname=mark host=localhost");

if ($pgsql_conn) {
   print "Successfully connected to: " . pg_host($pgsql_conn) . "<br/>\n";
} else {
   print pg_last_error($pgsql_conn);
   exit;
}
?>

Viz také

pg_connect()
pg_pconnect()

Předcházející | Nahoru | Další
pg_get_result | Domů | pg_insert


pg_insert

(PHP 4 >= 4.3.0, PHP 5)

pg_insert — Insert array into table

Popis

mixed pg_insert ( resource $connection, string $table_name, array $assoc_array [, int $options] )

pg_insert() inserts the values of assoc_array into the table specified by table_name. If options is specified, pg_convert() is applied to assoc_array with the specified options.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Seznam parametrů

connection

PostgreSQL database connection resource.

table_name

Name of the table into which to insert rows. The table table_name must at least have as many columns as assoc_array has elements.

assoc_array

An array whose keys are field names in the table table_name, and whose values are the values of those fields that are to be inserted.

options

Any number of PGSQL_CONV_OPTS, PGSQL_DML_NO_CONV, PGSQL_DML_EXEC, PGSQL_DML_ASYNC or PGSQL_DML_STRING combined. If PGSQL_DML_STRING is part of the options then query string is returned.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání. Returns string if PGSQL_DML_STRING is passed via options.

Příklady

Příklad 1730. pg_insert() example

<?php
  $dbconn = pg_connect('dbname=foo');
  // This is safe, since $_POST is converted automatically
  $res = pg_insert($dbconn, 'post_log', $_POST);
  if ($res) {
      echo "POST data is successfully logged\n";
  } else {
      echo "User must have sent wrong inputs\n";
  }
?>

Viz také

pg_convert()

Předcházející | Nahoru | Další
pg_host | Domů | pg_last_error


pg_last_error

(PHP 4 >= 4.2.0, PHP 5)

pg_last_error — Get the last error message string of a connection

Popis

string pg_last_error ( [resource $connection] )

pg_last_error() returns the last error message for a given connection.

Error messages may be overwritten by internal PostgreSQL (libpq) function calls. It may not return an appropriate error message if multiple errors occur inside a PostgreSQL module function.

Use pg_result_error(), pg_result_error_field(),
pg_result_status() and
pg_connection_status() for better error handling.

Poznámka: This function used to be called pg_errormessage().

Seznam parametrů

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

Návratové hodnoty

A string containing the last error message on the given connection, or FALSE on error.

Příklady

Příklad 1731. pg_last_error() example

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

  // Query that fails
  $res = pg_query($dbconn, "select * from doesnotexist");

  echo pg_last_error($dbconn);
?>

Viz také

pg_result_error()
pg_result_error_field()

Předcházející | Nahoru | Další
pg_insert | Domů | pg_last_notice


pg_last_notice

(PHP 4 >= 4.0.6, PHP 5)

pg_last_notice — Returns the last notice message from PostgreSQL server

Popis

string pg_last_notice ( resource $connection )

pg_last_notice() returns the last notice message from the PostgreSQL server on the specified connection. The PostgreSQL server sends notice messages in several cases, for instance when creating a SERIAL column in a table.

With pg_last_notice(), you can avoid issuing useless queries by checking whether or not the notice is related to your transaction.

Notice message tracking can be set to optional by setting 1 for pgsql.ignore_notice in php.ini.

Notice message logging can be set to optional by setting 0 for pgsql.log_notice in php.ini. Unless pgsql.ignore_notice is set to 0, notice message cannot be logged.

Seznam parametrů

connection

PostgreSQL database connection resource.

Návratové hodnoty

A string containing the last notice on the given connection, or FALSE on error.

ChangeLog (záznam změn)

Verze | Popis
4.3.0 | This function is now fully implemented. Earlier versions ignores database connection parameter.
4.3.0 | The pgsql.ignore_notice and pgsql.log_notice php.ini directives were added.
4.0.6 | PHP 4.0.6 has problem with notice message handling. Use of the PostgreSQL module with PHP 4.0.6 is not recommended even if you are not using pg_last_notice().

Příklady

Příklad 1732. pg_last_error() example

<?php
  $pgsql_conn = pg_connect("dbname=mark host=localhost");

  $res = pg_query("CREATE TABLE test (id SERIAL)");

  $notice = pg_last_notice($pgsql_conn);

  echo $notice;
?>

Výše uvedený příklad vypíše:

CREATE TABLE will create implicit sequence "test_id_seq" for "serial" column "test.id"

Viz také

pg_query()
pg_last_error()

Předcházející | Nahoru | Další
pg_last_error | Domů | pg_last_oid


pg_last_oid

(PHP 4 >= 4.2.0, PHP 5)

pg_last_oid — Returns the last row's OID

Popis

string pg_last_oid ( resource $result )

pg_last_oid() is used to retrieve the OID assigned to an inserted row.

OID field became an optional field from PostgreSQL 7.2 and will not be present by default in PostgreSQL 8.1. When the OID field is not present in a table, the programmer must use pg_result_status() to check for successful insertion.

To get the value of a SERIAL field in an inserted row, it is necessary to use the PostgreSQL CURRVAL function, naming the sequence whose last value is required. If the name of the sequence is unknown, the pg_get_serial_sequence PostgreSQL 8.0 function is necessary.

PostgreSQL 8.1 has a function LASTVAL that returns the value of the most recently used sequence in the session. This avoids the need for naming the sequence, table or column altogether.

Poznámka: This function used to be called pg_getlastoid().

Seznam parametrů

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

Návratové hodnoty

A string containing the OID assigned to the most recently inserted row in the specified connection, or FALSE on error or no available OID.

Příklady

Příklad 1733. pg_last_oid() example

<?php
  $pgsql_conn = pg_connect("dbname=mark host=localhost");

  $res1 = pg_query("CREATE TABLE test (a INTEGER) WITH OIDS");

  $res2 = pg_query("INSERT INTO test VALUES (1)");

  $oid = pg_last_oid($res2);
?>

Viz také

pg_query()
pg_result_status()

Předcházející | Nahoru | Další
pg_last_notice | Domů | pg_lo_close


pg_lo_close

(PHP 4 >= 4.2.0, PHP 5)

pg_lo_close — Close a large object

Popis

bool pg_lo_close ( resource $large_object )

pg_lo_close() closes a large object. large_object is a resource for the large object from pg_lo_open().

To use the large object interface, it is necessary to enclose it within a transaction block.

Poznámka: This function used to be called pg_loclose().

Seznam parametrů

result

PostgreSQL large object (LOB) resource, returned by pg_lo_open().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1734. pg_lo_close() example

<?php
   $database = pg_connect("dbname=jacarta");
   pg_query($database, "begin");
   $oid = pg_lo_create($database);
   echo "$oid\n";
   $handle = pg_lo_open($database, $oid, "w");
   echo "$handle\n";
   pg_lo_write($handle, "large object data");
   pg_lo_close($handle);
   pg_query($database, "commit");
?>

Viz také

pg_lo_open()
pg_lo_create()
pg_lo_import()

Předcházející | Nahoru | Další
pg_last_oid | Domů | pg_lo_create


pg_lo_create

(PHP 4 >= 4.2.0, PHP 5)

pg_lo_create — Create a large object

Popis

int pg_lo_create ( [resource $connection] )

pg_lo_create() creates a large object and returns the OID of the large object. PostgreSQL access modes INV_READ, INV_WRITE, and INV_ARCHIVE are not supported, the object is created always with both read and write access. INV_ARCHIVE has been removed from PostgreSQL itself (version 6.3 and above).

To use the large object interface, it is necessary to enclose it within a transaction block.

Instead of using the large object interface (which has no access controls and is cumbersome to use), try PostgreSQL's bytea column type and pg_escape_bytea().

Poznámka: This function used to be called pg_locreate().

Seznam parametrů

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

Návratové hodnoty

A large object OID or FALSE on error.

Příklady

Příklad 1735. pg_lo_create() example

<?php
   $database = pg_connect("dbname=jacarta");
   pg_query($database, "begin");
   $oid = pg_lo_create($database);
   echo "$oid\n";
   $handle = pg_lo_open($database, $oid, "w");
   echo "$handle\n";
   pg_lo_write($handle, "large object data");
   pg_lo_close($handle);
   pg_query($database, "commit");
?>

Předcházející | Nahoru | Další
pg_lo_close | Domů | pg_lo_export


pg_lo_export

(PHP 4 >= 4.2.0, PHP 5)

pg_lo_export — Export a large object to file

Popis

bool pg_lo_export ( resource $connection, int $oid, string $pathname )
bool pg_lo_export ( int $oid, string $pathname )

pg_lo_export() takes a large object in a PostgreSQL database and saves its contents to a file on the local filesystem.

To use the large object interface, it is necessary to enclose it within a transaction block.

Poznámka: This function used to be called pg_loexport().

Seznam parametrů

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

oid

The OID of the large object in the database.

pathname

The full path and file name of the file in which to write the large object on the client filesystem.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1736. pg_lo_export() example

<?php
   $database = pg_connect("dbname=jacarta");
   pg_query($database, "begin");
   $oid = pg_lo_create($database);
   $handle = pg_lo_open($database, $oid, "w");
   pg_lo_write($handle, "large object data");
   pg_lo_close($handle);
   pg_lo_export($database, $oid, '/tmp/lob.dat');
   pg_query($database, "commit");
?>

Viz také

pg_lo_import()

Předcházející | Nahoru | Další
pg_lo_create | Domů | pg_lo_import


pg_lo_import

(PHP 4 >= 4.2.0, PHP 5)

pg_lo_import — Import a large object from file

Popis

int pg_lo_import ( resource $connection, string $pathname )
int pg_lo_import ( string $pathname )

pg_lo_import() creates a new large object in the database using a file on the filesystem as its data source.

To use the large object interface, it is necessary to enclose it within a transaction block.

Poznámka: Pokud je zapnut bezpečný režim (safe-mode), PHP kontroluje, zda soubory/adresáře, se kterými pracujete, mají stejné UID jako spuštěný skript.

Poznámka: This function used to be called pg_loimport().

Seznam parametrů

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

pathname

The full path and file name of the file on the client filesystem from which to read the large object data.

Návratové hodnoty

The OID of the newly created large object, or FALSE on failure.

ChangeLog (záznam změn)

Verze | Popis
4.2.0 | The syntax of this function changed. It used to be: int pg_lo_import ( string $pathname [, resource $connection] )

Příklady

Příklad 1737. pg_lo_import() example

<?php
   $database = pg_connect("dbname=jacarta");
   pg_query($database, "begin");
   $oid = pg_lo_import($database, '/tmp/lob.dat');
   pg_query($database, "commit");
?>

Viz také

pg_lo_export()
pg_lo_open()

Předcházející | Nahoru | Další
pg_lo_export | Domů | pg_lo_open


pg_lo_open

(PHP 4 >= 4.2.0, PHP 5)

pg_lo_open — Open a large object

Popis

resource pg_lo_open ( resource $connection, int $oid, string $mode )

pg_lo_open() opens a large object in the database and returns large object resource so that it can be manipulated.

Varování

Do not close the database connection before closing the large object resource.

To use the large object interface, it is necessary to enclose it within a transaction block.

Poznámka: This function used to be called pg_loopen().

Seznam parametrů

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

oid

The OID of the large object in the database.

mode

Can be either "r" for read-only, "w" for write only or "rw" for read and write.

Návratové hodnoty

A large object resource or FALSE on error.

Příklady

Příklad 1738. pg_lo_open() example

<?php
   $database = pg_connect("dbname=jacarta");
   pg_query($database, "begin");
   $oid = pg_lo_create($database);
   echo "$oid\n";
   $handle = pg_lo_open($database, $oid, "w");
   echo "$handle\n";
   pg_lo_write($handle, "large object data");
   pg_lo_close($handle);
   pg_query($database, "commit");
?>

Viz také

pg_lo_close()
pg_lo_create()

Předcházející | Nahoru | Další
pg_lo_import | Domů | pg_lo_read_all


pg_lo_read_all

(PHP 4 >= 4.2.0, PHP 5)

pg_lo_read_all — Reads an entire large object and send straight to browser

Popis

int pg_lo_read_all ( resource $large_object )

pg_lo_read_all() reads a large object and passes it straight through to the browser after sending all pending headers. Mainly intended for sending binary data like images or sound.

To use the large object interface, it is necessary to enclose it within a transaction block.

Poznámka: This function used to be called pg_loreadall().

Seznam parametrů

large_object

PostgreSQL large object (LOB) resource, returned by pg_lo_open().

Návratové hodnoty

Number of bytes read or FALSE on error.

Příklady

Příklad 1739. pg_lo_read_all() example

<?php
   header('Content-type: image/jpeg');
   $image_oid = 189762345;
   $database = pg_connect("dbname=jacarta");
   pg_query($database, "begin");
   $handle = pg_lo_open($database, $image_oid, "r");
   pg_lo_read_all($handle);
   pg_query($database, "commit");
?>

Viz také

pg_lo_read()

Předcházející | Nahoru | Další
pg_lo_open | Domů | pg_lo_read


pg_lo_read

(PHP 4 >= 4.2.0, PHP 5)

pg_lo_read — Read a large object

Popis

string pg_lo_read ( resource $large_object [, int $len] )

pg_lo_read() reads at most len bytes from a large object and returns it as a string.

To use the large object interface, it is necessary to enclose it within a transaction block.

Poznámka: This function used to be called pg_loread().

Seznam parametrů

large_object

PostgreSQL large object (LOB) resource, returned by pg_lo_open().

len

An optional maximum number of bytes to return. Defaults to 8192.

Návratové hodnoty

A string containing len bytes from the large object, or FALSE on error.

Příklady

Příklad 1740. pg_lo_read() example

<?php
   $doc_oid = 189762345;
   $database = pg_connect("dbname=jacarta");
   pg_query($database, "begin");
   $handle = pg_lo_open($database, $doc_oid, "r");
   $data = pg_lo_read($handle, 50000);
   pg_query($database, "commit");
   echo $data;
?>

Viz také

pg_lo_read_all()

Předcházející | Nahoru | Další
pg_lo_read_all | Domů | pg_lo_seek


pg_lo_seek

(PHP 4 >= 4.2.0, PHP 5)

pg_lo_seek — Seeks position within a large object

Popis

bool pg_lo_seek ( resource $large_object, int $offset [, int $whence] )

pg_lo_seek() seeks a position within a large object resource.

To use the large object interface, it is necessary to enclose it within a transaction block.

Seznam parametrů

large_object

PostgreSQL large object (LOB) resource, returned by pg_lo_open().

offset

The number of bytes to seek.

whence

One of the constants PGSQL_SEEK_SET (seek from object start), PGSQL_SEEK_CUR (seek from current position) or PGSQL_SEEK_END (seek from object end) .

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1741. pg_lo_seek() example

<?php
   $doc_oid = 189762345;
   $database = pg_connect("dbname=jacarta");
   pg_query($database, "begin");
   $handle = pg_lo_open($database, $doc_oid, "r");
   // Skip first 50000 bytes
   pg_lo_seek($handle, 50000, PGSQL_SEEK_SET);
   // Read the next 10000 bytes
   $data = pg_lo_read($handle, 10000);
   pg_query($database, "commit");
   echo $data;
?>

Viz také

pg_lo_tell()

Předcházející | Nahoru | Další
pg_lo_read | Domů | pg_lo_tell


pg_lo_tell

(PHP 4 >= 4.2.0, PHP 5)

pg_lo_tell — Returns current seek position a of large object

Popis

int pg_lo_tell ( resource $large_object )

pg_lo_tell() returns the current position (offset from the beginning) of a large object.

To use the large object interface, it is necessary to enclose it within a transaction block.

Seznam parametrů

large_object

PostgreSQL large object (LOB) resource, returned by pg_lo_open().

Návratové hodnoty

The current seek offset (in number of bytes) from the beginning of the large object. If there is an error, the return value is negative.

Příklady

Příklad 1742. pg_lo_tell() example

<?php
   $doc_oid = 189762345;
   $database = pg_connect("dbname=jacarta");
   pg_query($database, "begin");
   $handle = pg_lo_open($database, $doc_oid, "r");
   // Skip first 50000 bytes
   pg_lo_seek($handle, 50000, PGSQL_SEEK_SET);
   // See how far we've skipped
   $offset = pg_lo_tell($handle);
   echo "Seek position is: $offset";
   pg_query($database, "commit");
?>

Výše uvedený příklad vypíše:

Seek position is: 50000

Viz také

pg_lo_seek()

Předcházející | Nahoru | Další
pg_lo_seek | Domů | pg_lo_unlink


pg_lo_unlink

(PHP 4 >= 4.2.0, PHP 5)

pg_lo_unlink — Delete a large object

Popis

bool pg_lo_unlink ( resource $connection, int $oid )

pg_lo_unlink() deletes a large object with the oid. Vrací TRUE při úspěchu, FALSE při selhání.

To use the large object interface, it is necessary to enclose it within a transaction block.

Poznámka: This function used to be called pg_lounlink().

Seznam parametrů

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

oid

The OID of the large object in the database.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1743. pg_lo_unlink() example

<?php
   // OID of the large object to delete
   $doc_oid = 189762345;
   $database = pg_connect("dbname=jacarta");
   pg_query($database, "begin");
   pg_lo_unlink($database, $doc_oid);
   pg_query($database, "commit");
?>

Viz také

pg_lo_create()
pg_lo_import()

Předcházející | Nahoru | Další
pg_lo_tell | Domů | pg_lo_write


pg_lo_write

(PHP 4 >= 4.2.0, PHP 5)

pg_lo_write — Write to a large object

Popis

int pg_lo_write ( resource $large_object, string $data [, int $len] )

pg_lo_write() writes data into a large object at the current seek position.

To use the large object interface, it is necessary to enclose it within a transaction block.

Poznámka: This function used to be called pg_lowrite().

Seznam parametrů

large_object

PostgreSQL large object (LOB) resource, returned by pg_lo_open().

data

The data to be written to the large object. If len is specified and is less than the length of data, only len bytes will be written.

len

An optional maximum number of bytes to write. Must be greater than zero and no greater than the length of data. Defaults to the length of data.

Návratové hodnoty

The number of bytes written to the large object, or FALSE on error.

Příklady

Příklad 1744. pg_lo_write() example

<?php
   $doc_oid = 189762345;
   $data = "This will overwrite the start of the large object.";
   $database = pg_connect("dbname=jacarta");
   pg_query($database, "begin");
   $handle = pg_lo_open($database, $doc_oid, "w");
   $data = pg_lo_write($handle, $data);
   pg_query($database, "commit");
?>

Viz také

pg_lo_create()
pg_lo_open()

Předcházející | Nahoru | Další
pg_lo_unlink | Domů | pg_meta_data


pg_meta_data

(PHP 4 >= 4.3.0, PHP 5)

pg_meta_data — Get meta data for table

Popis

array pg_meta_data ( resource $connection, string $table_name )

pg_meta_data() returns table definition for table_name as an array.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Seznam parametrů

connection

PostgreSQL database connection resource.

table_name

The name of the table.

Návratové hodnoty

An array of the table definition, or FALSE on error.

Příklady

Příklad 1745. Getting table metadata

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

  $meta = pg_meta_data($dbconn, 'authors');
  if (is_array($meta)) {
      echo '<pre>';
      var_dump($meta);
      echo '</pre>';
  }
?>

Výše uvedený příklad vypíše:

array(3) {
["author"]=>
array(5) {
  ["num"]=>
  int(1)
  ["type"]=>
  string(7) "varchar"
  ["len"]=>
  int(-1)
  ["not null"]=>
  bool(false)
  ["has default"]=>
  bool(false)
}
["year"]=>
array(5) {
  ["num"]=>
  int(2)
  ["type"]=>
  string(4) "int2"
  ["len"]=>
  int(2)
  ["not null"]=>
  bool(false)
  ["has default"]=>
  bool(false)
}
["title"]=>
array(5) {
  ["num"]=>
  int(3)
  ["type"]=>
  string(7) "varchar"
  ["len"]=>
  int(-1)
  ["not null"]=>
  bool(false)
  ["has default"]=>
  bool(false)
}
}

Viz také

pg_convert()

Předcházející | Nahoru | Další
pg_lo_write | Domů | pg_num_fields


pg_num_fields

(PHP 4 >= 4.2.0, PHP 5)

pg_num_fields — Returns the number of fields in a result

Popis

int pg_num_fields ( resource $result )

pg_num_fields() returns the number of fields (columns) in a PostgreSQL result resource.

Poznámka: This function used to be called pg_numfields().

Seznam parametrů

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

Návratové hodnoty

The number of fields (columns) in the result. On error, -1 is returned.

Příklady

Příklad 1746. pg_num_fields() example

<?php
$result = pg_query($conn, "SELECT 1, 2");

$num = pg_num_fields($result);

echo $num . " field(s) returned.\n";
?>

Výše uvedený příklad vypíše:

2 field(s) returned.

Viz také

pg_num_rows()
pg_affected_rows()

Předcházející | Nahoru | Další
pg_meta_data | Domů | pg_num_rows


pg_num_rows

(PHP 4 >= 4.2.0, PHP 5)

pg_num_rows — Returns the number of rows in a result

Popis

int pg_num_rows ( resource $result )

pg_num_rows() will return the number of rows in a PostgreSQL result resource.

Poznámka: This function used to be called pg_numrows().

Seznam parametrů

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

Návratové hodnoty

The number of rows in the result. On error, -1 is returned.

Příklady

Příklad 1747. pg_num_rows() example

<?php
$result = pg_query($conn, "SELECT 1");

$rows = pg_num_rows($result);

echo $rows . " row(s) returned.\n";
?>

Výše uvedený příklad vypíše:

1 row(s) returned.

Viz také

pg_num_fields()
pg_affected_rows()

Předcházející | Nahoru | Další
pg_num_fields | Domů | pg_options


pg_options

(PHP 4, PHP 5)

pg_options — Get the options associated with the connection

Popis

string pg_options ( [resource $connection] )

pg_options() will return a string containing the options specified on the given PostgreSQL connection resource.

Seznam parametrů

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

Návratové hodnoty

A string containing the connection options, or FALSE on error.

Příklady

Příklad 1748. pg_options() example

<?php
   $pgsql_conn = pg_connect("dbname=mark host=localhost");
   echo pg_options($pgsql_conn);
?>

Viz také

pg_connect()

Předcházející | Nahoru | Další
pg_num_rows | Domů | pg_parameter_status


pg_parameter_status

(PHP 5)

pg_parameter_status — Looks up a current parameter setting of the server.

Popis

string pg_parameter_status ( resource $connection, string $param_name )
string pg_parameter_status ( string $param_name )

Looks up a current parameter setting of the server.

Certain parameter values are reported by the server automatically at connection startup or whenever their values change. pg_parameter_status() can be used to interrogate these settings. It returns the current value of a parameter if known, or FALSE if the parameter is not known.

Parameters reported as of PostgreSQL 8.0 include server_version, server_encoding, client_encoding, is_superuser, session_authorization, DateStyle, TimeZone, and integer_datetimes. (server_encoding, TimeZone, and integer_datetimes were not reported by releases before 8.0.) Note that server_version, server_encoding and integer_datetimes cannot change after PostgreSQL startup.

PostgreSQL 7.3 or lower servers do not report parameter settings, pg_parameter_status() includes logic to obtain values for server_version and client_encoding anyway. Applications are encouraged to use pg_parameter_status() rather than ad hoc code to determine these values.

Výstraha

On a pre-7.4 PostgreSQL server, changing client_encoding via SET after connection startup will not be reflected by pg_parameter_status().

Seznam parametrů

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

param_name

Possible param_name values include server_version, server_encoding, client_encoding, is_superuser, session_authorization, DateStyle, TimeZone, and integer_datetimes.

Návratové hodnoty

A string containing the value of the parameter, FALSE on failure or invalid param_name.

Příklady

Příklad 1749. pg_parameter_status() example

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

  echo "Server encoding: ", pg_parameter_status($dbconn, "server_encoding");
?>

Výše uvedený příklad vypíše:

Server encoding: SQL_ASCII

Předcházející | Nahoru | Další
pg_options | Domů | pg_pconnect


pg_pconnect

(PHP 4, PHP 5)

pg_pconnect — Open a persistent PostgreSQL connection

Popis

resource pg_pconnect ( string $connection_string [, int $connect_type] )

pg_pconnect() opens a connection to a PostgreSQL database. It returns a connection resource that is needed by other PostgreSQL functions.

If a second call is made to pg_pconnect() with the same connection_string as an existing connection, the existing connection will be returned unless you pass PGSQL_CONNECT_FORCE_NEW as connect_type.

To enable persistent connection, the pgsql.allow_persistent php.ini directive must be set to "On" (which is the default). The maximum number of persistent connection can be defined with the pgsql.max_persistent php.ini directive (defaults to -1 for no limit). The total number of connections can be set with the pgsql.max_links php.ini directive.

pg_close() will not close persistent links generated by pg_pconnect().

Seznam parametrů

connection_string

The connection_string can be empty to use all default parameters, or it can contain one or more parameter settings separated by whitespace. Each parameter setting is in the form keyword = value. Spaces around the equal sign are optional. To write an empty value or a value containing spaces, surround it with single quotes, e.g., keyword = 'a value'. Single quotes and backslashes within the value must be escaped with a backslash, i.e., \' and \\.

The currently recognized parameter keywords are: host, hostaddr, port, dbname, user, password, connect_timeout, options, tty (ignored), sslmode, requiressl (deprecated in favor of sslmode), and service. Which of these arguments exist depends on your PostgreSQL version.

connect_type

If PGSQL_CONNECT_FORCE_NEW is passed, then a new connection is created, even if the connection_string is identical to an existing connection.

Návratové hodnoty

PostgreSQL connection resource on success, FALSE on failure.

Příklady

Příklad 1750. Using pg_pconnect()

<?php
$dbconn = pg_pconnect("dbname=mary");
//connect to a database named "mary"

$dbconn2 = pg_pconnect("host=localhost port=5432 dbname=mary");
// connect to a database named "mary" on "localhost" at port "5432"

$dbconn3 = pg_pconnect("host=sheep port=5432 dbname=mary user=lamb password=foo");
//connect to a database named "mary" on the host "sheep" with a username and password

$conn_string = "host=sheep port=5432 dbname=test user=lamb password=bar";
$dbconn4 = pg_pconnect($conn_string);
//connect to a database named "test" on the host "sheep" with a username and password
?>

Viz také

pg_connect()
Persistent Database Connections

Předcházející | Nahoru | Další
pg_parameter_status | Domů | pg_ping


pg_ping

(PHP 4 >= 4.3.0, PHP 5)

pg_ping — Ping database connection

Popis

bool pg_ping ( [resource $connection] )

pg_ping() pings a database connection and tries to reconnect it if it is broken.

Seznam parametrů

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1751. pg_ping() example

<?php
$conn = pg_pconnect("dbname=publisher");
if (!$conn) {
  echo "An error occured.\n";
  exit;
}

if (!pg_ping($conn))
  die("Connection is broken\n");
?>

Viz také

pg_connection_status()
pg_connection_reset()

Předcházející | Nahoru | Další
pg_pconnect | Domů | pg_port


pg_port

(PHP 4, PHP 5)

pg_port — Return the port number associated with the connection

Popis

int pg_port ( [resource $connection] )

pg_port() returns the port number that the given PostgreSQL connection resource is connected to.

Seznam parametrů

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

Návratové hodnoty

An int containing the port number of the database server the connection is to, or FALSE on error.

Příklady

Příklad 1752. pg_port() example

<?php
$pgsql_conn = pg_connect("dbname=mark host=localhost");

if ($pgsql_conn) {
   print "Successfully connected to port: " . pg_port($pgsql_conn) . "<br/>\n";
} else {
   print pg_last_error($pgsql_conn);
   exit;
}
?>

Předcházející | Nahoru | Další
pg_ping | Domů | pg_prepare


pg_put_line

(PHP 4 >= 4.0.3, PHP 5)

pg_put_line — Send a NULL-terminated string to PostgreSQL backend

Popis

bool pg_put_line ( string $data )
bool pg_put_line ( resource $connection, string $data )

pg_put_line() sends a NULL-terminated string to the PostgreSQL backend server. This is needed in conjunction with PostgreSQL's COPY FROM command.

COPY is a high-speed data loading interface supported by PostgreSQL. Data is passed in without being parsed, and in a single transaction.

An alternative to using raw pg_put_line() commands is to use pg_copy_from(). This is a far simpler interface.

Poznámka: The application must explicitly send the two characters "\." on the last line to indicate to the backend that it has finished sending its data, before issuing pg_end_copy().

Varování

Use of the pg_put_line() causes most large object operations, including pg_lo_read() and pg_lo_tell(), to subsequently fail. You can use pg_copy_from() and pg_copy_to() instead.

Seznam parametrů

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

data

A line of text to be sent directly to the PostgreSQL backend. A NULL terminator is added automatically.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1754. pg_put_line() example

<?php
  $conn = pg_pconnect("dbname=foo");
  pg_query($conn, "create table bar (a int4, b char(16), d float8)");
  pg_query($conn, "copy bar from stdin");
  pg_put_line($conn, "3\thello world\t4.5\n");
  pg_put_line($conn, "4\tgoodbye world\t7.11\n");
  pg_put_line($conn, "\\.\n");
  pg_end_copy($conn);
?>

Viz také

pg_end_copy()

Předcházející | Nahoru | Další
pg_prepare | Domů | pg_query_params


pg_query

(PHP 4 >= 4.2.0, PHP 5)

pg_query — Execute a query

Popis

resource pg_query ( string $query )
resource pg_query ( resource $connection, string $query )

pg_query() executes the query on the specified database connection.

If an error occurs, and FALSE is returned, details of the error can be retrieved using the pg_last_error() function if the connection is valid.

Poznámka: Although connection can be omitted, it is not recommended, since it can be the cause of hard to find bugs in scripts.

Poznámka: This function used to be called pg_exec(). pg_exec() is still available for compatibility reasons, but users are encouraged to use the newer name.

Seznam parametrů

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

query

The SQL statement or statements to be executed. When multiple statements are passed to the function, they are automatically executed as one transaction, unless there are explicit BEGIN/COMMIT commands included in the query string. However, using multiple transactions in one function call is not recommended.

Návratové hodnoty

A query result resource on success, or FALSE on failure.

Příklady

Příklad 1756. pg_query() example

<?php

$conn = pg_pconnect("dbname=publisher");
if (!$conn) {
  echo "An error occured.\n";
  exit;
}

$result = pg_query($conn, "SELECT author, email FROM authors");
if (!$result) {
  echo "An error occured.\n";
  exit;
}

while ($row = pg_fetch_row($result)) {
  echo "Author: $row[0]  E-mail: $row[1]";
  echo "<br />\n";
}

?>

Příklad 1757. Using pg_query() with multiple statements

<?php

$conn = pg_pconnect("dbname=publisher");

// these statements will be executed as one transaction

$query = "UPDATE authors SET author=UPPER(author) WHERE id=1;";
$query .= "UPDATE authors SET author=LOWER(author) WHERE id=2;";
$query .= "UPDATE authors SET author=NULL WHERE id=3;";

pg_query($conn, $query);

?>

Viz také

pg_connect()
pg_pconnect()
pg_fetch_array()
pg_fetch_object()
pg_num_rows()
pg_affected_rows()

Předcházející | Nahoru | Další
pg_query_params | Domů | pg_result_error_field


pg_result_error

(PHP 4 >= 4.2.0, PHP 5)

pg_result_error — Get error message associated with result

Popis

string pg_result_error ( resource $result )

pg_result_error() returns any error message associated with the result resource. Therefore, the user has a better chance of getting the correct error message than with pg_last_error().

The function pg_result_error_field() can give much greater detail on result errors than pg_result_error().

Because pg_query() returns FALSE if the query fails, you must use pg_send_query() and pg_get_result() to get the result handle.

Seznam parametrů

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

Návratové hodnoty

Returns a string if there is an error associated with the result parameter, FALSE otherwise.

Příklady

Příklad 1759. pg_result_error() example

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

  if (!pg_connection_busy($dbconn)) {
      pg_send_query($dbconn, "select * from doesnotexist;");
  }

  $res1 = pg_get_result($dbconn);
  echo pg_result_error($res1);
?>

Viz také

pg_result_error_field()
pg_query()
pg_send_query()
pg_get_result()
pg_last_error()
pg_last_notice()

Předcházející | Nahoru | Další
pg_result_error_field | Domů | pg_result_seek


pg_result_seek

(PHP 4 >= 4.3.0, PHP 5)

pg_result_seek — Set internal row offset in result resource

Popis

bool pg_result_seek ( resource $result, int $offset )

pg_result_seek() sets the internal row offset in a result resource.

Seznam parametrů

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

offset

Row to move the internal offset to in the result resource. Rows are numbered starting from zero.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1760. pg_result_seek() example

<?php

// Connect to the database
$conn = pg_pconnect("dbname=publisher");

// Execute a query
$result = pg_query($conn, "SELECT author, email FROM authors");

// Seek to the 3rd row (assuming there are 3 rows)
pg_result_seek($result, 2);

// Fetch the 3rd row
$row = pg_fetch_row($result);

?>

Viz také

pg_fetch_row()
pg_fetch_assoc()
pg_fetch_array()
pg_fetch_object()
pg_fetch_result()

Předcházející | Nahoru | Další
pg_result_error | Domů | pg_result_status


pg_result_status

(PHP 4 >= 4.2.0, PHP 5)

pg_result_status — Get status of query result

Popis

mixed pg_result_status ( resource $result [, int $type] )

pg_result_status() returns the status of a result resource, or the PostgreSQL command completion tag associated with the result

Seznam parametrů

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

type

Either PGSQL_STATUS_LONG to return the numeric status of the result, or PGSQL_STATUS_STRING to return the command tag of the result. If not specified, PGSQL_STATUS_LONG is the default.

Návratové hodnoty

Possible return values are PGSQL_EMPTY_QUERY, PGSQL_COMMAND_OK, PGSQL_TUPLES_OK, PGSQL_COPY_OUT, PGSQL_COPY_IN, PGSQL_BAD_RESPONSE, PGSQL_NONFATAL_ERROR and PGSQL_FATAL_ERROR if PGSQL_STATUS_LONG is specified. Otherwise, a string containing the PostgreSQL command tag is returned.

ChangeLog (záznam změn)

Verze | Popis
4.3.0 | The type parameter was added.

Příklady

Příklad 1761. pg_result_status() example

<?php

// Connect to the database
$conn = pg_pconnect("dbname=publisher");

// Execute a COPY
$result = pg_query($conn, "COPY authors FROM STDIN;");

// Get the result status
$status = pg_result_status($result);

// Determine status
if ($status == PGSQL_COPY_IN)
   echo "Copy began.";
else
   echo "Copy failed.";

?>

Výše uvedený příklad vypíše:

Copy began.

Viz také

pg_connection_status()

Předcházející | Nahoru | Další
pg_result_seek | Domů | pg_select


pg_select

(PHP 4 >= 4.3.0, PHP 5)

pg_select — Select records

Popis

mixed pg_select ( resource $connection, string $table_name, array $assoc_array [, int $options] )

pg_select() selects records specified by assoc_array which has field=>value. For a successful query, it returns an array containing all records and fields that match the condition specified by assoc_array.

If options is specified, pg_convert() is applied to assoc_array with the specified flags.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Seznam parametrů

connection

PostgreSQL database connection resource.

table_name

Name of the table from which to select rows.

assoc_array

An array whose keys are field names in the table table_name, and whose values are the conditions that a row must meet to be retrieved.

options

Any number of PGSQL_CONV_FORCE_NULL, PGSQL_DML_NO_CONV, PGSQL_DML_EXEC, PGSQL_DML_ASYNC or PGSQL_DML_STRING combined. If PGSQL_DML_STRING is part of the options then query string is returned.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání. Returns string if PGSQL_DML_STRING is passed via options.

Příklady

Příklad 1762. pg_select() example

<?php
  $db = pg_connect('dbname=foo');
  // This is safe, since $_POST is converted automatically
  $rec = pg_select($db, 'post_log', $_POST);
  if ($rec) {
      echo "Records selected\n";
      var_dump($rec);
  } else {
      echo "User must have sent wrong inputs\n";
  }
?>

Viz také

pg_convert()

Předcházející | Nahoru | Další
pg_result_status | Domů | pg_send_execute


pg_send_query

(PHP 4 >= 4.2.0, PHP 5)

pg_send_query — Sends asynchronous query

Popis

bool pg_send_query ( resource $connection, string $query )

pg_send_query() sends a query or queries asynchronously to the connection. Unlike pg_query(), it can send multiple queries at once to PostgreSQL and get the results one by one using pg_get_result().

Script execution is not blocked while the queries are executing. Use pg_connection_busy() to check if the connection is busy (i.e. the query is executing). Queries may be cancelled using pg_cancel_query().

Although the user can send multiple queries at once, multiple queries cannot be sent over a busy connection. If a query is sent while the connection is busy, it waits until the last query is finished and discards all its results.

Seznam parametrů

connection

PostgreSQL database connection resource.

query

The SQL statement or statements to be executed.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Use pg_get_result() to determine the query result.

Příklady

Příklad 1766. pg_send_query() example

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

  if (!pg_connection_busy($dbconn)) {
      pg_send_query($dbconn, "select * from authors; select count(*) from authors;");
  }

  $res1 = pg_get_result($dbconn);
  echo "First call to pg_get_result(): $res1\n";
  $rows1 = pg_num_rows($res1);
  echo "$res1 has $rows1 records\n\n";

  $res2 = pg_get_result($dbconn);
  echo "Second call to pg_get_result(): $res2\n";
  $rows2 = pg_num_rows($res2);
  echo "$res2 has $rows2 records\n";
?>

Výše uvedený příklad vypíše:

First call to pg_get_result(): Resource id #3
Resource id #3 has 3 records

Second call to pg_get_result(): Resource id #4
Resource id #4 has 1 records

Viz také

pg_query()
pg_cancel_query()
pg_get_result()
pg_connection_busy()

Předcházející | Nahoru | Další
pg_send_query_params | Domů | pg_set_client_encoding


pg_set_client_encoding

(PHP 4 >= 4.0.3, PHP 5)

pg_set_client_encoding — Set the client encoding

Popis

int pg_set_client_encoding ( string $encoding )
int pg_set_client_encoding ( resource $connection, string $encoding )

pg_set_client_encoding() sets the client encoding and returns 0 if success or -1 if error.

PostgreSQL will automatically convert data in the backend database encoding into the frontend encoding.

Poznámka: The function used to be called pg_setclientencoding().

Seznam parametrů

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

encoding

The required client encoding. One of SQL_ASCII, EUC_JP, EUC_CN, EUC_KR, EUC_TW, UNICODE, MULE_INTERNAL, LATINX (X=1...9), KOI8, WIN, ALT, SJIS, BIG5 or WIN1250.

The exact list of available encodings depends on your PostgreSQL version, so check your PostgreSQL manual for a more specific list.

Návratové hodnoty

Returns 0 on success or -1 on error.

Příklady

Příklad 1767. pg_set_client_encoding() example

<?php

$conn = pg_pconnect("dbname=publisher");
if (!$conn) {
  echo "An error occured.\n";
  exit;
}

// Set the client encoding to UNICODE.  Data will be automatically
// converted from the backend encoding to the frontend.
pg_set_client_encoding($conn, UNICODE);

$result = pg_query($conn, "SELECT author, email FROM authors");
if (!$result) {
  echo "An error occured.\n";
  exit;
}

// Write out UTF-8 data
while ($row = pg_fetch_row($result)) {
  echo "Author: $row[0]  E-mail: $row[1]";
  echo "<br />\n";
}

?>

Viz také

pg_client_encoding()

Předcházející | Nahoru | Další
pg_send_query | Domů | pg_set_error_verbosity


pg_trace

(PHP 4 >= 4.0.1, PHP 5)

pg_trace — Enable tracing a PostgreSQL connection

Popis

bool pg_trace ( string $pathname [, string $mode [, resource $connection]] )

pg_trace() enables tracing of the PostgreSQL frontend/backend communication to a file. To fully understand the results, one needs to be familiar with the internals of PostgreSQL communication protocol.

For those who are not, it can still be useful for tracing errors in queries sent to the server, you could do for example grep '^To backend' trace.log and see what queries actually were sent to the PostgreSQL server. For more information, refer to the » PostgreSQL Documentation.

Seznam parametrů

pathname

The full path and file name of the file in which to write the trace log. Same as in fopen().

pathname

An optional file access mode, same as for fopen(). Defaults to "w".

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1769. pg_trace() example

<?php
$pgsql_conn = pg_connect("dbname=mark host=localhost");

if ($pgsql_conn) {
   pg_trace('/tmp/trace.log', 'w', $pgsql_conn);
   pg_query("SELECT 1");
   pg_untrace($pgsql_conn);
   // Now /tmp/trace.log will contain backend communication
} else {
   print pg_last_error($pgsql_conn);
   exit;
}
?>

Viz také

fopen()
pg_untrace()

Předcházející | Nahoru | Další
pg_set_error_verbosity | Domů | pg_transaction_status


pg_tty

(PHP 4, PHP 5)

pg_tty — Return the TTY name associated with the connection

Popis

string pg_tty ( [resource $connection] )

pg_tty() returns the TTY name that server side debugging output is sent to on the given PostgreSQL connection resource.

Poznámka: pg_tty() is obsolete, since the server no longer pays attention to the TTY setting, but the function remains for backwards compatibility.

Seznam parametrů

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

Návratové hodnoty

A string containing the debug TTY of the connection, or FALSE on error.

Příklady

Příklad 1771. pg_tty() example

<?php
$pgsql_conn = pg_connect("dbname=mark host=localhost");

if ($pgsql_conn) {
   print "Server debug TTY is: " . pg_tty($pgsql_conn) . "<br/>\n";
} else {
   print pg_last_error($pgsql_conn);
   exit;
}
?>

Předcházející | Nahoru | Další
pg_transaction_status | Domů | pg_unescape_bytea


pg_unescape_bytea

(PHP 4 >= 4.3.0, PHP 5)

pg_unescape_bytea — Unescape binary for bytea type

Popis

string pg_unescape_bytea ( string $data )

pg_unescape_bytea() unescapes PostgreSQL bytea data values. It returns the unescaped string, possibly containing binary data.

Poznámka: When you SELECT a bytea type, PostgreSQL returns octal byte values prefixed with '\' (e.g. \032). Users are supposed to convert back to binary format manually.

This function requires PostgreSQL 7.2 or later. With PostgreSQL 7.2.0 and 7.2.1, bytea values must be cast when you enable multi-byte support. i.e. INSERT INTO test_table (image) VALUES ('$image_escaped'::bytea); PostgreSQL 7.2.2 or later does not need a cast. The exception is when the client and backend character encoding does not match, and there may be multi-byte stream error. User must then cast to bytea to avoid this error.

Seznam parametrů

data

A string containing PostgreSQL bytea data to be converted into a PHP binary string.

Návratové hodnoty

A string containing the unescaped data.

Příklady

Příklad 1772. pg_unescape_bytea() example

<?php
  // Connect to the database
  $dbconn = pg_connect('dbname=foo');

  // Get the bytea data
  $res = pg_query("SELECT data FROM gallery WHERE name='Pine trees'");
  $raw = pg_fetch_result($res, 'data');

  // Convert to binary and send to the browser
  header('Content-type: image/jpeg');
  echo pg_unescape_bytea($raw);
?>

Viz také

pg_escape_bytea()
pg_escape_string()

Předcházející | Nahoru | Další
pg_tty | Domů | pg_untrace


pg_untrace

(PHP 4 >= 4.0.1, PHP 5)

pg_untrace — Disable tracing of a PostgreSQL connection

Popis

bool pg_untrace ( [resource $connection] )

Stop tracing started by pg_trace().

Seznam parametrů

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

Návratové hodnoty

Always returns TRUE.

Příklady

Příklad 1773. pg_untrace() example

<?php
$pgsql_conn = pg_connect("dbname=mark host=localhost");

if ($pgsql_conn) {
   pg_trace('/tmp/trace.log', 'w', $pgsql_conn);
   pg_query("SELECT 1");
   pg_untrace($pgsql_conn);
   // Now tracing of backend communication is disabled
} else {
   print pg_last_error($pgsql_conn);
   exit;
}
?>

Viz také

pg_trace()

Předcházející | Nahoru | Další
pg_unescape_bytea | Domů | pg_update


pg_update

(PHP 4 >= 4.3.0, PHP 5)

pg_update — Update table

Popis

mixed pg_update ( resource $connection, string $table_name, array $data, array $condition [, int $options] )

pg_update() updates records that matches condition with data. If options is specified, pg_convert() is applied to data with specified options.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Seznam parametrů

connection

PostgreSQL database connection resource.

table_name

Name of the table into which to update rows.

data

An array whose keys are field names in the table table_name, and whose values are what matched rows are to be updated to.

condition

An array whose keys are field names in the table table_name, and whose values are the conditions that a row must meet to be updated.

options

Any number of PGSQL_CONV_OPTS, PGSQL_DML_NO_CONV, PGSQL_DML_EXEC or PGSQL_DML_STRING combined. If PGSQL_DML_STRING is part of the options then query string is returned.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání. Returns string if PGSQL_DML_STRING is passed via options.

Příklady

Příklad 1774. pg_update() example

<?php
  $db = pg_connect('dbname=foo');
  $data = array('field1'=>'AA', 'field2'=>'BB');

  // This is safe, since $_POST is converted automatically
  $res = pg_update($db, 'post_log', $_POST, $data);
  if ($res) {
      echo "Data is updated: $res\n";
  } else {
      echo "User must have sent wrong inputs\n";
  }
?>

Viz také

pg_convert()

Předcházející | Nahoru | Další
pg_untrace | Domů | pg_version


pg_version

(PHP 5)

pg_version — Returns an array with client, protocol and server version (when available)

Popis

array pg_version ( [resource $connection] )

pg_version() returns an array with the client, protocol and server version. Protocol and server versions are only available if PHP was compiled with PostgreSQL 7.4 or later.

For more detailed server information, use pg_parameter_status().

Seznam parametrů

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

Návratové hodnoty

Returns an array with client, protocol and server_version keys and values (if available). Returns FALSE on error or invalid connection.

Příklady

Příklad 1775. pg_version() example

<?php
  $dbconn = pg_connect("host=localhost port=5432 dbname=mary")
     or die("Could not connect");

  $v = pg_version($dbconn);

  echo $v['client'];
?>

Výše uvedený příklad vypíše:

7.4

Viz také

pg_parameter_status()

Předcházející | Nahoru | Další
pg_update | Domů | CXXVIII. PostgreSQL Functions (PDO_PGSQL)


Process Control Functions

Předcházející VI. Reference funkcí Další

CXIX. Process Control Functions

Úvod

Process Control support in PHP implements the Unix style of process creation, program execution, signal handling and process termination. Process Control should not be enabled within a web server environment and unexpected results may happen if any Process Control functions are used within a web server environment.

This documentation is intended to explain the general usage of each of the Process Control functions. For detailed information about Unix process control you are encouraged to consult your systems documentation including fork(2), waitpid(2) and signal(2) or a comprehensive reference such as Advanced Programming in the UNIX Environment by W. Richard Stevens (Addison-Wesley).

PCNTL now uses ticks as the signal handle callback mechanism, which is much faster than the previous mechanism. This change follows the same semantics as using "user ticks". You use the declare() statement to specify the locations in your program where callbacks are allowed to occur. This allows you to minimize the overhead of handling asynchronous events. In the past, compiling PHP with pcntl enabled would always incur this overhead, whether or not your script actually used pcntl.

There is one adjustment that all pcntl scripts prior to PHP 4.3.0 must make for them to work which is to either to use declare() on a section where you wish to allow callbacks or to just enable it across the entire script using the new global syntax of declare().

Poznámka: Toto rozšíření není k dispozici na platformách Windows.

Požadavky

Tyto funkce jsou k dispozici jako součást standardního modulu, který je vždy dostupný.

Instalace

Process Control support in PHP is not enabled by default. You have to compile the CGI or CLI version of PHP with --enable-pcntl configuration option when compiling PHP to enable Process Control support.

Poznámka: Currently, this module will not function on non-Unix platforms (Windows).

Konfigurace běhu

Toto rozšíření nemá definováno žádné konfigurační direktivy.

Typy prostředků

Toto rozšíření nemá definován žádný typ prostředku (resource).

Předdefinované konstanty

The following list of signals are supported by the Process Control functions. Please see your systems signal(7) man page for details of the default behavior of these signals.

WNOHANG (integer)
WUNTRACED (integer)
SIG_IGN (integer)
SIG_DFL (integer)
SIG_ERR (integer)
SIGHUP (integer)
SIGINT (integer)
SIGQUIT (integer)
SIGILL (integer)
SIGTRAP (integer)
SIGABRT (integer)
SIGIOT (integer)
SIGBUS (integer)
SIGFPE (integer)
SIGKILL (integer)
SIGUSR1 (integer)
SIGSEGV (integer)
SIGUSR2 (integer)
SIGPIPE (integer)
SIGALRM (integer)
SIGTERM (integer)
SIGSTKFLT (integer)
SIGCLD (integer)
SIGCHLD (integer)
SIGCONT (integer)
SIGSTOP (integer)
SIGTSTP (integer)
SIGTTIN (integer)
SIGTTOU (integer)
SIGURG (integer)
SIGXCPU (integer)
SIGXFSZ (integer)
SIGVTALRM (integer)
SIGPROF (integer)
SIGWINCH (integer)
SIGPOLL (integer)
SIGIO (integer)
SIGPWR (integer)
SIGSYS (integer)
SIGBABY (integer)

Příklady

This example forks off a daemon process with a signal handler.

Příklad 1512. Process Control Example

<?php
declare(ticks=1);

$pid = pcntl_fork();
if ($pid == -1) {
     die("could not fork");
} else if ($pid) {
     exit(); // we are the parent
} else {
     // we are the child
}

// detatch from the controlling terminal
if (posix_setsid() == -1) {
    die("could not detach from terminal");
}

// setup signal handlers
pcntl_signal(SIGTERM, "sig_handler");
pcntl_signal(SIGHUP, "sig_handler");

// loop forever performing tasks
while (1) {

    // do something interesting here

}

function sig_handler($signo)
{

     switch ($signo) {
         case SIGTERM:
             // handle shutdown tasks
             exit;
             break;
         case SIGHUP:
             // handle restart tasks
             break;
         default:
             // handle all other signals
     }

}

?>

Viz také

A look at the section about POSIX functions may be useful.

Obsah

pcntl_alarm — Set an alarm clock for delivery of a signal
pcntl_exec — Executes specified program in current process space
pcntl_fork — Forks the currently running process
pcntl_getpriority — Get the priority of any process
pcntl_setpriority — Change the priority of any process
pcntl_signal — Installs a signal handler
pcntl_wait — Waits on or returns the status of a forked child
pcntl_waitpid — Waits on or returns the status of a forked child
pcntl_wexitstatus — Returns the return code of a terminated child
pcntl_wifexited — Checks if status code represents a normal exit
pcntl_wifsignaled — Checks whether the status code represents a termination due to a signal
pcntl_wifstopped — Checks whether the child process is currently stopped
pcntl_wstopsig — Returns the signal which caused the child to stop
pcntl_wtermsig — Returns the signal which caused the child to terminate
Předcházející | Nahoru | Další
parsekit_func_arginfo | Domů | pcntl_alarm


pcntl_alarm

(PHP 4 >= 4.3.0, PHP 5)

pcntl_alarm — Set an alarm clock for delivery of a signal

Popis

int pcntl_alarm ( int $seconds )

Creates a timer that will send a SIGALRM signal to the process after the given number of seconds. Any call to pcntl_alarm() will cancel any previously set alarm.

Seznam parametrů

seconds

The number of seconds to wait. If seconds is zero, no new alarm is created.

Návratové hodnoty

Returns the time in seconds that any previously scheduled alarm had remaining before it was to be delivered, or 0 if there was no previously scheduled alarm.

Předcházející | Nahoru | Další
CXIX. Process Control Functions | Domů | pcntl_exec


pcntl_exec

(PHP 4 >= 4.2.0, PHP 5)

pcntl_exec — Executes specified program in current process space

Popis

void pcntl_exec ( string $path [, array $args [, array $envs]] )

Executes the program with the given arguments.

Seznam parametrů

path

path must be the path to a binary executable or a script with a valid path pointing to an executable in the shebang ( #!/usr/local/bin/perl for example) as the first line. See your system's man execve(2) page for additional information.

args

args is an array of argument strings passed to the program.

envs

envs is an array of strings which are passed as environment to the program. The array is in the format of name => value, the key being the name of the environmental variable and the value being the value of that variable.

Návratové hodnoty

Returns FALSE on error and does not return on success.

Předcházející | Nahoru | Další
pcntl_alarm | Domů | pcntl_fork


pcntl_fork

(PHP 4 >= 4.0.7, PHP 5)

pcntl_fork — Forks the currently running process

Popis

int pcntl_fork ( void )

The pcntl_fork() function creates a child process that differs from the parent process only in its PID and PPID. Please see your system's fork(2) man page for specific details as to how fork works on your system.

Návratové hodnoty

On success, the PID of the child process is returned in the parent's thread of execution, and a 0 is returned in the child's thread of execution. On failure, a -1 will be returned in the parent's context, no child process will be created, and a PHP error is raised.

Příklady

Příklad 1513. pcntl_fork() example

<?php

$pid = pcntl_fork();
if ($pid == -1) {
     die('could not fork');
} else if ($pid) {
     // we are the parent
     pcntl_wait($status); //Protect against Zombie children
} else {
     // we are the child
}

?>

Viz také

pcntl_waitpid()
pcntl_signal()

Předcházející | Nahoru | Další
pcntl_exec | Domů | pcntl_getpriority


pcntl_getpriority

(PHP 5)

pcntl_getpriority — Get the priority of any process

Popis

int pcntl_getpriority ( [int $pid [, int $process_identifier]] )

pcntl_getpriority() gets the priority of pid. Because priority levels can differ between system types and kernel versions, please see your system's getpriority(2) man page for specific details.

Seznam parametrů

pid

If not specified, the pid of the current process is used.

process_identifier

One of PRIO_PGRP, PRIO_USER or PRIO_PROCESS.

Návratové hodnoty

pcntl_getpriority() returns the priority of the process or FALSE on error. A lower numerical value causes more favorable scheduling.

Varování

Tato funkce může vracet booleovskou hodnotu FALSE, ale také nebooleovskou hodnotu odpovídající ohodnocení FALSE, například 0 nebo "". Čtěte prosím sekci o typu Boolean, kde najdete více informací. Pro testování návratové hodnoty této funkce použijte operátor ===.

Viz také

pcntl_setpriority()

Předcházející | Nahoru | Další
pcntl_fork | Domů | pcntl_setpriority


pcntl_setpriority

(PHP 5)

pcntl_setpriority — Change the priority of any process

Popis

bool pcntl_setpriority ( int $priority [, int $pid [, int $process_identifier]] )

pcntl_setpriority() sets the priority of pid.

Seznam parametrů

priority

priority is generally a value in the range -20 to 20. The default priority is 0 while a lower numerical value causes more favorable scheduling. Because priority levels can differ between system types and kernel versions, please see your system's setpriority(2) man page for specific details.

pid

If not specified, the pid of the current process is used.

process_identifier

One of PRIO_PGRP, PRIO_USER or PRIO_PROCESS.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

pcntl_getpriority()

Předcházející | Nahoru | Další
pcntl_getpriority | Domů | pcntl_signal


pcntl_signal

(PHP 4 >= 4.0.7, PHP 5)

pcntl_signal — Installs a signal handler

Popis

bool pcntl_signal ( int $signo, callback $handler [, bool $restart_syscalls] )

The pcntl_signal() function installs a new signal handler for the signal indicated by signo.

Seznam parametrů

signo

The signal number.

handler

The signal handler which may be the name of a user created function, or method, or either of the two global constants SIG_IGN or SIG_DFL.

Poznámka: Note that when you set a handler to an object method, that object's reference count is increased which makes it persist until you either change the handler to something else, or your script ends.

restart_syscalls

Specifies whether system call restarting should be used when this signal arrives and defaults to TRUE.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

ChangeLog (záznam změn)

Verze | Popis
4.3.0 | The restart_syscalls parameter was added.
4.3.0 | The ability to use an object method as a callback became available.
4.3.0 | As of PHP 4.3.0 PCNTL uses ticks as the signal handle callback mechanism, which is much faster than the previous mechanism. This change follows the same semantics as using "user ticks". You must use the declare() statement to specify the locations in your program where callbacks are allowed to occur for the signal handler to function properly (as used in the above example).

Příklady

Příklad 1514. pcntl_signal() example

<?php
// tick use required as of PHP 4.3.0
declare(ticks = 1);

// signal handler function
function sig_handler($signo)
{

     switch ($signo) {
         case SIGTERM:
             // handle shutdown tasks
             exit;
             break;
         case SIGHUP:
             // handle restart tasks
             break;
         case SIGUSR1:
             echo "Caught SIGUSR1...\n";
             break;
         default:
             // handle all other signals
     }

}

echo "Installing signal handler...\n";

// setup signal handlers
pcntl_signal(SIGTERM, "sig_handler");
pcntl_signal(SIGHUP,  "sig_handler");
pcntl_signal(SIGUSR1, "sig_handler");

// or use an object, available as of PHP 4.3.0
// pcntl_signal(SIGUSR1, array($obj, "do_something");

echo"Generating signal SIGTERM to self...\n";

// send SIGUSR1 to current process id
posix_kill(posix_getpid(), SIGUSR1);

echo "Done\n"

?>

Viz také

pcntl_fork()
pcntl_waitpid()

Předcházející | Nahoru | Další
pcntl_setpriority | Domů | pcntl_wait


pcntl_wait

(PHP 5)

pcntl_wait — Waits on or returns the status of a forked child

Popis

int pcntl_wait ( int &$status [, int $options] )

The wait function suspends execution of the current process until a child has exited, or until a signal is delivered whose action is to terminate the current process or to call a signal handling function. If a child has already exited by the time of the call (a so-called "zombie" process), the function returns immediately. Any system resources used by the child are freed. Please see your system's wait(2) man page for specific details as to how wait works on your system.

Poznámka: This function is equivalent to calling pcntl_waitpid() with a -1 pid and no options.

Seznam parametrů

status

pcntl_wait() will store status information
in the status parameter which can be
evaluated using the following functions:
pcntl_wifexited(),
pcntl_wifstopped(),
pcntl_wifsignaled(),
pcntl_wexitstatus(),
pcntl_wtermsig() and
pcntl_wstopsig().

options

If wait3 is available on your system (mostly BSD-style systems), you can provide the optional options parameter. If this parameter is not provided, wait will be used for the system call. If wait3 is not available, providing a value for options will have no effect. The value of options is the value of zero or more of the following two constants OR'ed together:

Tabulka 230. Possible values for options

WNOHANG | Return immediately if no child has exited.
WUNTRACED | Return for children which are stopped, and whose status has not been reported.

Návratové hodnoty

pcntl_wait() returns the process ID of the child which exited, -1 on error or zero if WNOHANG was provided as an option (on wait3-available systems) and no child was available.

Viz také

pcntl_fork()
pcntl_signal()
pcntl_wifexited()
pcntl_wifstopped()
pcntl_wifsignaled()
pcntl_wexitstatus()
pcntl_wtermsig()
pcntl_wstopsig()
pcntl_waitpid()

Předcházející | Nahoru | Další
pcntl_signal | Domů | pcntl_waitpid


pcntl_waitpid

(PHP 4 >= 4.0.7, PHP 5)

pcntl_waitpid — Waits on or returns the status of a forked child

Popis

int pcntl_waitpid ( int $pid, int &$status [, int $options] )

Suspends execution of the current process until a child as specified by the pid argument has exited, or until a signal is delivered whose action is to terminate the current process or to call a signal handling function.

If a child as requested by pid has already exited by the time of the call (a so-called "zombie" process), the function returns immediately. Any system resources used by the child are freed. Please see your system's waitpid(2) man page for specific details as to how waitpid works on your system.

Seznam parametrů

pid

The value of pid can be one of the following:

Tabulka 231. possible values for pid

< -1 | wait for any child process whose process group ID is equal to the absolute value of pid.
-1 | wait for any child process; this is the same behaviour that the wait function exhibits.
0 | wait for any child process whose process group ID is equal to that of the calling process.
> 0 | wait for the child whose process ID is equal to the value of pid.

Poznámka: Specifying -1 as the pid is equivalent to the functionality pcntl_wait() provides (minus options).

status

pcntl_waitpid() will store status information
in the status parameter which can be
evaluated using the following functions:
pcntl_wifexited(),
pcntl_wifstopped(),
pcntl_wifsignaled(),
pcntl_wexitstatus(),
pcntl_wtermsig() and
pcntl_wstopsig().

options

The value of options is the value of zero or more of the following two global constants OR'ed together:

Tabulka 232. possible values for options

WNOHANG | return immediately if no child has exited.
WUNTRACED | return for children which are stopped, and whose status has not been reported.

Návratové hodnoty

pcntl_waitpid() returns the process ID of the child which exited, -1 on error or zero if WNOHANG was used and no child was available

Viz také

pcntl_fork()
pcntl_signal()
pcntl_wifexited()
pcntl_wifstopped()
pcntl_wifsignaled()
pcntl_wexitstatus()
pcntl_wtermsig()
pcntl_wstopsig()

Předcházející | Nahoru | Další
pcntl_wait | Domů | pcntl_wexitstatus


pcntl_wexitstatus

(PHP 4 >= 4.0.7, PHP 5)

pcntl_wexitstatus — Returns the return code of a terminated child

Popis

int pcntl_wexitstatus ( int $status )

Returns the return code of a terminated child. This function is only useful if pcntl_wifexited() returned TRUE.

Seznam parametrů

status

Parametr status je stavový parametr poskytnutý úspěšnému volání pcntl_waitpid().

Návratové hodnoty

Returns the return code, as an integer.

Viz také

pcntl_waitpid()
pcntl_wifexited()

Předcházející | Nahoru | Další
pcntl_waitpid | Domů | pcntl_wifexited


pcntl_wifexited

(PHP 4 >= 4.0.7, PHP 5)

pcntl_wifexited — Checks if status code represents a normal exit

Popis

bool pcntl_wifexited ( int $status )

Checks whether the child status code represents a normal exit.

Seznam parametrů

status

Parametr status je stavový parametr poskytnutý úspěšnému volání pcntl_waitpid().

Návratové hodnoty

Returns TRUE if the child status code represents a normal exit, FALSE otherwise.

Viz také

pcntl_waitpid()
pcntl_wexitstatus()

Předcházející | Nahoru | Další
pcntl_wexitstatus | Domů | pcntl_wifsignaled


pcntl_wifsignaled

(PHP 4 >= 4.0.7, PHP 5)

pcntl_wifsignaled — Checks whether the status code represents a termination due to a signal

Popis

bool pcntl_wifsignaled ( int $status )

Checks whether the child process exited because of a signal which was not caught.

Seznam parametrů

status

Parametr status je stavový parametr poskytnutý úspěšnému volání pcntl_waitpid().

Návratové hodnoty

Returns TRUE if the child process exited because of a signal which was not caught, FALSE otherwise.

Viz také

pcntl_waitpid()
pcntl_signal()

Předcházející | Nahoru | Další
pcntl_wifexited | Domů | pcntl_wifstopped


pcntl_wifstopped

(PHP 4 >= 4.0.7, PHP 5)

pcntl_wifstopped — Checks whether the child process is currently stopped

Popis

bool pcntl_wifstopped ( int $status )

Checks whether the child process which caused the return is currently stopped; this is only possible if the call to pcntl_waitpid() was done using the option WUNTRACED.

Seznam parametrů

status

Parametr status je stavový parametr poskytnutý úspěšnému volání pcntl_waitpid().

Návratové hodnoty

Returns TRUE if the child process which caused the return is currently stopped, FALSE otherwise.

Viz také

pcntl_waitpid()

Předcházející | Nahoru | Další
pcntl_wifsignaled | Domů | pcntl_wstopsig


pcntl_wstopsig

(PHP 4 >= 4.0.7, PHP 5)

pcntl_wstopsig — Returns the signal which caused the child to stop

Popis

int pcntl_wstopsig ( int $status )

Returns the number of the signal which caused the child to stop. This function is only useful if pcntl_wifstopped() returned TRUE.

Seznam parametrů

status

Parametr status je stavový parametr poskytnutý úspěšnému volání pcntl_waitpid().

Návratové hodnoty

Returns the signal number.

Viz také

pcntl_waitpid()
pcntl_wifstopped()

Předcházející | Nahoru | Další
pcntl_wifstopped | Domů | pcntl_wtermsig


pcntl_wtermsig

(PHP 4 >= 4.0.7, PHP 5)

pcntl_wtermsig — Returns the signal which caused the child to terminate

Popis

int pcntl_wtermsig ( int $status )

Returns the number of the signal that caused the child process to terminate. This function is only useful if pcntl_wifsignaled() returned TRUE.

Seznam parametrů

status

Parametr status je stavový parametr poskytnutý úspěšnému volání pcntl_waitpid().

Návratové hodnoty

Returns the signal number, as an integer.

Viz také

pcntl_waitpid()
pcntl_signal()
pcntl_wifsignaled()

Předcházející | Nahoru | Další
pcntl_wstopsig | Domů | CXX. Regular Expression Functions (Perl-Compatible)


Funkce spouštění programů

Předcházející VI. Reference funkcí Další

CXXX. Funkce spouštění programů

Úvod

Tyto funkce poskytují způsoby spouštění příkazů na vlastním systému a způsoby zabezpečení těchto příkazů.

Požadavky

Tyto funkce jsou k dispozici jako součást standardního modulu, který je vždy dostupný.

Instalace

K používání těchto funkcí není třeba žádná instalace, jsou součástí jádra PHP.

Konfigurace běhu

Toto rozšíření nemá definováno žádné konfigurační direktivy.

Typy prostředků

Toto rozšíření nemá definován žádný typ prostředku (resource).

Předdefinované konstanty

Toto rozšíření nemá definovány žádné konstanty.

Viz také

Tyto funkce jsou rovněž blízké operátoru zpětný apostrof. Pokud používáte bezpečný režim, musíte také pamatovat na nastavení direktivy safe_mode_exec_dir.

Obsah

escapeshellarg — ouvozovkování řetězce pro použití jako argument shellu
escapeshellcmd — escape shellovské metaznaky
exec — Provést externí program
passthru — Vykonat externí program a zobrazit nezpracovaný výstup
proc_close — Close a process opened by proc_open() and return the exit code of that process.
proc_get_status — Get information about a process opened by proc_open()
proc_nice — Change the priority of the current process
proc_open — Execute a command and open file pointers for input/output
proc_terminate — Kills a process opened by proc_open
shell_exec — Execute command via shell and return the complete output as a string
system — Provést externí program a zobrazit výstup
Předcházející | Nahoru | Další
printer_write | Domů | escapeshellarg


escapeshellarg

(PHP 4 >= 4.0.3, PHP 5)

escapeshellarg — ouvozovkování řetězce pro použití jako argument shellu

Popis

string escapeshellarg ( string $arg )

EscapeShellArg() přidá jednoduché uvozovky na začátek a konec řetězce a ouvozovkuje/escapes všechny výskyty jednoduchých uvozovek, takže tento řetězec můžete přímo předat shell funkci, přičemž tento bude brán jako bezpečný argument. Tato funkce by se měla používat k oescapování jednotlivých argumentů určených pro shell funkce pocházejících z uživatelského vstupu. Shell funkce zahrnujíc exec(), system() a backtick operator. Standardní použití:

system("ls ".EscapeShellArg($dir))

Viz také exec(), popen(), system(), a backtick operátor.

Předcházející | Nahoru | Další
CXXX. Funkce spouštění programů | Domů | escapeshellcmd


escapeshellcmd

(PHP 4, PHP 5)

escapeshellcmd — escape shellovské metaznaky

Popis

string escapeshellcmd ( string $command )

EscapeShellCmd() oescapuje všechny znaky v řetězci, které by se daly použít ke zneužití shellového příkazu k vykonání libovolných příkazů. Tato funkce by se měla používat k zabezpečení toho, aby všechna data pocházející z uživatelského vstupu byla oescapována přetím, než budou předána funkci exec() nebo system(), nebo backtick operátoru. Standardní použití:

$e = EscapeShellCmd($userinput);
system("echo $e"); // tady nás nezajímá, jestli jsou v $e mezery
$f = EscapeShellCmd($filename);
system("touch \"/tmp/$f\"; ls -l \"/tmp/$f\""); // a tady ano, proto použijeme uvozovky

Viz takéescapeshellarg(), exec(), popen(), system(), a backtick operátor.

Předcházející | Nahoru | Další
escapeshellarg | Domů | exec


exec

(PHP 4, PHP 5)

exec — Provést externí program

Popis

string exec ( string $command [, array &$output [, int &$return_var]] )

exec() provádí předaný command, nicméně nic netiskne. Pouze vrací poslední řádek výstupu daného příkazu. Pokud potřebujete provést příkaz a nechat všechna data z tohoto příkazu předat rovnou bez jakéhokoli zásahu, použijte funkci PassThru().

Pokud je přítomen argument array, předané pole se naplní všemi řádky výstupu daného příkazu. Pozn.: Pokud toto pole už obsahuje nějaké prvky, exec() připojí tento výstup na konec tohoto pole. Pokud nechcete, aby tato funkce připojovala prvky na konec daného pole, zavolejte na toto pole unset() předtím, než ho předáte funkci exec().

Pokud je vedle argumentu array přítomen argument return_var, návratová hodnota provedeného příkazu se zapíše do této proměnné.

Pozn.: Pokud chcete používat v této funkci data z uživatelského vstupu, měli byste používat EscapeShellCmd(), abyste měli jistotu, že uživatelé nevmanipulují systém do provádění libovolných příkazů.

Pozn.: Pokud touto funkcí nastartujete nějaký program a chcete ho nechat běžet v pozadí, musíte se zajistit přesměrování výstupu z tohoto programu do souboru nebo jineho výstupního streamu, jinak se PHP zasekne až do ukončení běhu tohoto programu.

Viz takésystem(),
PassThru(), popen(),
EscapeShellCmd(), a backtick operátor.

Předcházející | Nahoru | Další
escapeshellcmd | Domů | passthru


passthru

(PHP 4, PHP 5)

passthru — Vykonat externí program a zobrazit nezpracovaný výstup

Popis

void passthru ( string $command [, int &$return_var] )

Funkce passthru() se podobá funkci exec() v tom ohledu, že provede command. Pokud je přítomen argument return_var, návratová hodnota tohoto příkazu se umístí sem. Tato funkce by se měla používat místo exec() a system(), pokud jsou výstupem daného příkazu binární data, která je potřeba odeslat přímo do browseru. Běžným použitím této funkce vykonat např. pbmplus utility, které mohou poslat stream obrázku na stdout. Nastavením content-type na image/gif a zavoláním pbmplus programu k odeslání gifu na stdout gifu můžete vytvořit PHP skripty, které přímo tvoří obrázky.

Pozn.: Pokud touto funkcí nastartujete nějaký program a chcete ho nechat běžet v pozadí, musíte se zajistit přesměrování výstupu z tohoto programu do souboru nebo jineho výstupního streamu, jinak se PHP zasekne až do ukončení běhu tohoto programu.

Viz takéexec(), system(), popen(), EscapeShellCmd(), a backtick operátor.

Předcházející | Nahoru | Další
exec | Domů | proc_close


proc_close

(PHP 4 >= 4.3.0, PHP 5)

proc_close — Close a process opened by proc_open() and return the exit code of that process.

Popis

int proc_close ( resource $process )

proc_close() is similar to pclose() except that it only works on processes opened by proc_open(). proc_close() waits for the process to terminate, and returns its exit code. If you have open pipes to that process, you should fclose() them prior to calling this function in order to avoid a deadlock - the child process may not be able to exit while the pipes are open.

Seznam parametrů

process

The proc_open() resource that will be closed.

Návratové hodnoty

Returns the termination status of the process that was run.

Předcházející | Nahoru | Další
passthru | Domů | proc_get_status


proc_get_status

(PHP 5)

proc_get_status — Get information about a process opened by proc_open()

Popis

array proc_get_status ( resource $process )

proc_get_status() fetches data about a process opened using proc_open().

Seznam parametrů

process

The proc_open() resource that will be evaluated.

Návratové hodnoty

An array of collected information on success, and FALSE on failure. The returned array contains the following elements:

element | type | description
command | string | The command string that was passed to proc_open().
pid | int | process id
running | bool | TRUE if the process is still running, FALSE if it has terminated.
signaled | bool | TRUE if the child process has been terminated by an uncaught signal. Always set to FALSE on Windows.
stopped | bool | TRUE if the child process has been stopped by a signal. Always set to FALSE on Windows.
exitcode | int | The exit code returned by the process (which is only meaningful if running is FALSE). Only first call of this function return real value, next calls return -1.
termsig | int | The number of the signal that caused the child process to terminate its execution (only meaningful if signaled is TRUE).
stopsig | int | The number of the signal that caused the child process to stop its execution (only meaningful if stopped is TRUE).

Viz také

proc_open()

Předcházející | Nahoru | Další
proc_close | Domů | proc_nice


proc_nice

(PHP 5)

proc_nice — Change the priority of the current process

Popis

bool proc_nice ( int $increment )

proc_nice() changes the priority of the current process by the amount specified in increment. A positive increment will lower the priority of the current process, whereas a negative increment will raise the priority.

proc_nice() is not related to proc_open() and its associated functions in any way.

Seznam parametrů

increment

The increment value of the priority change.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání. If an error occurs, like the user lacks permission to change the priority, an error of level E_WARNING is also generated.

Poznámky

Availability: proc_nice() will only exist if your system has 'nice' capabilities. 'nice' conforms to: SVr4, SVID EXT, AT&T, X/OPEN, BSD 4.3. This means that proc_nice() is not available on Windows.

Předcházející | Nahoru | Další
proc_get_status | Domů | proc_open


proc_open

(PHP 4 >= 4.3.0, PHP 5)

proc_open — Execute a command and open file pointers for input/output

Popis

resource proc_open ( string $cmd, array $descriptorspec, array &$pipes [, string $cwd [, array $env [, array $other_options]]] )

proc_open() is similar to popen() but provides a much greater degree of control over the program execution.

Seznam parametrů

cmd

The command to execute

descriptorspec

An indexed array where the key represents the descriptor number and the value represents how PHP will pass that descriptor to the child process. 0 is stdin, 1 is stdout, while 2 is stderr.

The currently supported pipe types are file and pipe .

The file descriptor numbers are not limited to 0, 1 and 2 - you may specify any valid file descriptor number and it will be passed to the child process. This allows your script to interoperate with other scripts that run as "co-processes". In particular, this is useful for passing passphrases to programs like PGP, GPG and openssl in a more secure manner. It is also useful for reading status information provided by those programs on auxiliary file descriptors.

pipes

Will be set to an indexed array of file pointers that correspond to PHP's end of any pipes that are created.

cwd

The initial working dir for the command. This must be an absolute directory path, or NULL if you want to use the default value (the working dir of the current PHP process)

env

An array with the environment variables for the command that will be run, or NULL to use the same environment as the current PHP process

other_options

Allows you to specify additional options. Currently supported options include:

suppress_errors (windows only): suppresses errors generated by this function when it's set to TRUE
bypass_shell (windows only): bypass cmd.exe shell when set to TRUE
context: stream context used when opening files (created with stream_context_create())
binary_pipes: open pipes in binary mode, instead of using the usual stream_encoding

Návratové hodnoty

Returns a resource representing the process, which should be freed using proc_close() when you are finished with it. On failure returns FALSE.

ChangeLog (záznam změn)

Verze | Popis
6.0.0 | Added the context and binary_pipes options to the other_options parameter.
5.2.1 | Added the bypass_shell option to the other_options parameter.
5.0.0 | Added the cwd, env and other_options parameters.

Příklady

Příklad 1801. A proc_open() example

<?php
$descriptorspec = array(
   0 => array("pipe", "r"),  // stdin is a pipe that the child will read from
   1 => array("pipe", "w"),  // stdout is a pipe that the child will write to
   2 => array("file", "/tmp/error-output.txt", "a") // stderr is a file to write to
);

$cwd = '/tmp';
$env = array('some_option' => 'aeiou');

$process = proc_open('php', $descriptorspec, $pipes, $cwd, $env);

if (is_resource($process)) {
    // $pipes now looks like this:
    // 0 => writeable handle connected to child stdin
    // 1 => readable handle connected to child stdout
    // Any error output will be appended to /tmp/error-output.txt

    fwrite($pipes[0], '<?php print_r($_ENV); ?>');
    fclose($pipes[0]);

    echo stream_get_contents($pipes[1]);
    fclose($pipes[1]);

    // It is important that you close any pipes before calling
    // proc_close in order to avoid a deadlock
    $return_value = proc_close($process);

    echo "command returned $return_value\n";
}
?>

Výše uvedený příklad vypíše něco jako:

Array
(
    [some_option] => aeiou
    [PWD] => /tmp
    [SHLVL] => 1
    [_] => /usr/local/bin/php
)
command returned 0

Poznámky

Poznámka: Windows compatibility: Descriptors beyond 2 (stderr) are made available to the child process as inheritable handles, but since the Windows architecture does not associate file descriptor numbers with low-level handles, the child process does not (yet) have a means of accessing those handles. Stdin, stdout and stderr work as expected.

Poznámka: If you only need a uni-directional (one-way) process pipe, use popen() instead, as it is much easier to use.

Viz také

popen()
exec()
system()
passthru()
stream_select()
The backtick operator

Předcházející | Nahoru | Další
proc_nice | Domů | proc_terminate


proc_terminate

(PHP 5)

proc_terminate — Kills a process opened by proc_open

Popis

bool proc_terminate ( resource $process [, int $signal] )

Signals a process (created using proc_open()) that it should terminate. proc_terminate() returns immediately and does not wait for the process to terminate.

proc_terminate() allows you terminate the process and continue with other tasks. You may poll the process (to see if it has stopped yet) by using the proc_get_status() function. However this is only possible with PHP 5.2.2 or newer, as previous versions destroyed the given process resource.

Seznam parametrů

process

The proc_open() resource that will be closed.

signal

This optional parameter is only useful on POSIX operating systems; you may specify a signal to send to the process using the kill(2) system call. The default is SIGTERM.

Návratové hodnoty

Returns the termination status of the process that was run.

Viz také

proc_open()
proc_close()
proc_get_status()

Předcházející | Nahoru | Další
proc_open | Domů | shell_exec


shell_exec

(PHP 4, PHP 5)

shell_exec — Execute command via shell and return the complete output as a string

Popis

string shell_exec ( string $cmd )

This function is identical to the backtick operator.

Seznam parametrů

cmd

The command that will be executed.

Návratové hodnoty

The output from the executed command.

Příklady

Příklad 1802. A shell_exec() example

<?php
$output = shell_exec('ls -lart');
echo "<pre>$output</pre>";
?>

Poznámky

Poznámka: Tyto funkce jsou v bezpečném režimu (safe-mode) deaktivovány.

Viz také

exec()
escapeshellcmd()

Předcházející | Nahoru | Další
proc_terminate | Domů | system


system

(PHP 4, PHP 5)

system — Provést externí program a zobrazit výstup

Popis

string system ( string $command [, int &$return_var] )

system() je verzí stejnojmenné C funkce; vykoná předaný command a zobrazí výstup. Pokud jí předáte proměnnou jako druhý argument, návratová hodnota provedeného příkazu se zapíše do této proměnné.

Pozn.: Pokud chcete používat v této funkci data z uživatelského vstupu, měli byste používat EscapeShellCmd(), abyste měli jistotu, že uživatelé nevmanipulují systém do provádění libovolných příkazů.

Pozn.: Pokud touto funkcí nastartujete nějaký program a chcete ho nechat běžet v pozadí, musíte se zajistit přesměrování výstupu z tohoto programu do souboru nebo jineho výstupního streamu, jinak se PHP zasekne až do ukončení běhu tohoto programu.

Pokud PHP běží jako modul serveru, system() také automaticky flushne výstupní buffer web serveru po každém řádku výstupu.

Při úspěchu vrací poslední řádek výstupu příkazu, při selhání FALSE.

Pokud potřebujete provést příkaz a nechat všechna data z tohoto příkazu předat rovnou bez jakéhokoli zásahu, použijte funkci PassThru().

Viz takéexec(),
PassThru(), popen(),
EscapeShellCmd(), a backtick operátor.

Předcházející | Nahoru | Další
shell_exec | Domů | CXXXI. PostScript document creation


Printer Functions

Předcházející VI. Reference funkcí Další

CXXIX. Printer Functions

Úvod

These functions are only available under Windows 9.x, ME, NT4 and 2000. They have been added in PHP 4.0.4.

Instalace

This » PECL extension is not bundled with PHP.

Windows users must enable php_printer.dll inside of php.ini in order to use these functions. Toto nezahrnuté rozšíření PECL můžete získat z různých stránek s kopiemi PECL (vyberte si repozitář odpovídající vaší verzi PHP): » PECL pro PHP 4.3.x, » PECL pro PHP 5.0.x nebo » PECL Unstable.

Konfigurace běhu

Chování těchto funkcí je ovlivněno nastavením parametrů v php.ini.

Tabulka 260. Printer configuration options

Name | Default | Changeable | Changelog
printer.default_printer | "" | PHP_INI_ALL | Available since PHP 4.0.6. Removed in PHP 4.1.1.

Pro další detaily a definice konstant PHP_INI_*, viz dokumentace k ini_set().

Typy prostředků

This extension defines handles to a printer connection, to a brush, to a font and to a pen.

Předdefinované konstanty

See also the Printer Predefined Constants

Obsah

Constants — Printer Predefined Constants
printer_abort — Deletes the printer's spool file
printer_close — Close an open printer connection
printer_create_brush — Create a new brush
printer_create_dc — Create a new device context
printer_create_font — Create a new font
printer_create_pen — Create a new pen
printer_delete_brush — Delete a brush
printer_delete_dc — Delete a device context
printer_delete_font — Delete a font
printer_delete_pen — Delete a pen
printer_draw_bmp — Draw a bmp
printer_draw_chord — Draw a chord
printer_draw_elipse — Draw an ellipse
printer_draw_line — Draw a line
printer_draw_pie — Draw a pie
printer_draw_rectangle — Draw a rectangle
printer_draw_roundrect — Draw a rectangle with rounded corners
printer_draw_text — Draw text
printer_end_doc — Close document
printer_end_page — Close active page
printer_get_option — Retrieve printer configuration data
printer_list — Return an array of printers attached to the server
printer_logical_fontheight — Get logical font height
printer_open — Opens a connection to a printer
printer_select_brush — Select a brush
printer_select_font — Select a font
printer_select_pen — Select a pen
printer_set_option — Configure the printer connection
printer_start_doc — Start a new document
printer_start_page — Start a new page
printer_write — Write data to the printer
Předcházející | Nahoru | Další
PDO::pgsqlLOBUnlink | Domů | Constants


printer_abort

(No version information available, might be only in CVS)

printer_abort — Deletes the printer's spool file

Popis

void printer_abort ( resource $printer_handle )

This function deletes the printers spool file.

Seznam parametrů

printer_handle

printer_handle must be a valid handle to a printer.

Návratové hodnoty

Nevrací se žádná hodnota.

Příklady

Příklad 1780. printer_abort() example

<?php
$handle = printer_open();
printer_abort($handle);
printer_close($handle);
?>

Předcházející | Nahoru | Další
Constants | Domů | printer_close


printer_close

(No version information available, might be only in CVS)

printer_close — Close an open printer connection

Popis

void printer_close ( resource $printer_handle )

This function closes the printer connection. printer_close() also closes the active device context.

Seznam parametrů

printer_handle

printer_handle must be a valid handle to a printer.

Návratové hodnoty

Nevrací se žádná hodnota.

Příklady

Příklad 1781. printer_close() example

<?php
$handle = printer_open();
printer_close($handle);
?>

Předcházející | Nahoru | Další
printer_abort | Domů | printer_create_brush


printer_create_brush

(No version information available, might be only in CVS)

printer_create_brush — Create a new brush

Popis

resource printer_create_brush ( int $style, string $color )

The function creates a new brush and returns a handle to it. A brush is used to fill shapes. For an example see printer_select_brush().

Seznam parametrů

style

style must be one of the following constants:

  • PRINTER_BRUSH_SOLID: creates a brush with a solid color.
  • PRINTER_BRUSH_DIAGONAL: creates a brush with a 45-degree upward left-to-right hatch ( / ).
  • PRINTER_BRUSH_CROSS: creates a brush with a cross hatch ( + ).
  • PRINTER_BRUSH_DIAGCROSS: creates a brush with a 45 cross hatch ( x ).
  • PRINTER_BRUSH_FDIAGONAL: creates a brush with a 45-degree downward left-to-right hatch ( \ ).
  • PRINTER_BRUSH_HORIZONTAL: creates a brush with a horizontal hatch ( - ).
  • PRINTER_BRUSH_VERTICAL: creates a brush with a vertical hatch ( | ).
  • PRINTER_BRUSH_CUSTOM: creates a custom brush from an BMP file. The second parameter is used to specify the BMP instead of the RGB color code.

color

color must be a color in RGB hex format, i.e. "000000" for black.

Návratové hodnoty

Returns a brush handle or FALSE on error.

Předcházející | Nahoru | Další
printer_close | Domů | printer_create_dc


printer_create_dc

(No version information available, might be only in CVS)

printer_create_dc — Create a new device context

Popis

void printer_create_dc ( resource $printer_handle )

The function creates a new device context. A device context is used to customize the graphic objects of the document.

Seznam parametrů

printer_handle

printer_handle must be a valid printer handle.

Návratové hodnoty

Nevrací se žádná hodnota.

Příklady

Příklad 1782. printer_create_dc() example

<?php
$handle = printer_open();
printer_start_doc($handle);
printer_start_page($handle);

printer_create_dc($handle);
/* do some stuff with the dc */
printer_set_option($handle, PRINTER_TEXT_COLOR, "333333");
printer_draw_text($handle, 1, 1, "text");
printer_delete_dc($handle);

/* create another dc */
printer_create_dc($handle);
printer_set_option($handle, PRINTER_TEXT_COLOR, "000000");
printer_draw_text($handle, 1, 1, "text");
/* do some stuff with the dc */

printer_delete_dc($handle);

printer_end_page($handle);
printer_end_doc($handle);
printer_close($handle);
?>

Předcházející | Nahoru | Další
printer_create_brush | Domů | printer_create_font


printer_create_font

(No version information available, might be only in CVS)

printer_create_font — Create a new font

Popis

resource printer_create_font ( string $face, int $height, int $width, int $font_weight, bool $italic, bool $underline, bool $strikeout, int $orientation )

The function creates a new font and returns a handle to it. A font is used to draw text. For an example see printer_select_font().

Seznam parametrů

face

face must be a string specifying the font face.

height

height specifies the font height.

width

width specifies the font width.

font_weight

The font_weight specifies the font weight (400 is normal), and can be one of the following predefined constants.

  • PRINTER_FW_THIN: sets the font weight to thin (100).
  • PRINTER_FW_ULTRALIGHT: sets the font weight to ultra light (200).
  • PRINTER_FW_LIGHT: sets the font weight to light (300).
  • PRINTER_FW_NORMAL: sets the font weight to normal (400).
  • PRINTER_FW_MEDIUM: sets the font weight to medium (500).
  • PRINTER_FW_BOLD: sets the font weight to bold (700).
  • PRINTER_FW_ULTRABOLD: sets the font weight to ultra bold (800).
  • PRINTER_FW_HEAVY: sets the font weight to heavy (900).

italic

italic can be TRUE or FALSE, and sets whether the font should be italic.

underline

underline can be TRUE or FALSE, and sets whether the font should be underlined.

strikeout

strikeout can be TRUE or FALSE, and sets whether the font should be stroked out.

orientaton

orientation specifies a rotation.

Návratové hodnoty

Returns a font handle on success or FALSE on error.

Předcházející | Nahoru | Další
printer_create_dc | Domů | printer_create_pen


printer_create_pen

(No version information available, might be only in CVS)

printer_create_pen — Create a new pen

Popis

resource printer_create_pen ( int $style, int $width, string $color )

The function creates a new pen and returns a handle to it. A pen is used to draw lines and curves. For an example see printer_select_pen().

Seznam parametrů

style

style must be one of the following constants:

  • PRINTER_PEN_SOLID: creates a solid pen.
  • PRINTER_PEN_DASH: creates a dashed pen.
  • PRINTER_PEN_DOT: creates a dotted pen.
  • PRINTER_PEN_DASHDOT: creates a pen with dashes and dots.
  • PRINTER_PEN_DASHDOTDOT: creates a pen with dashes and double dots.
  • PRINTER_PEN_INVISIBLE: creates an invisible pen.

width

width specifies the width of the pen.

color

color must be a color in RGB hex format, i.e. "000000" for black.

Návratové hodnoty

Returns a pen handle or FALSE on error.

Předcházející | Nahoru | Další
printer_create_font | Domů | printer_delete_brush


printer_delete_brush

(No version information available, might be only in CVS)

printer_delete_brush — Delete a brush

Popis

void printer_delete_brush ( resource $brush_handle )

The function deletes the selected brush. For an example see printer_select_brush().

Seznam parametrů

brush_handle

brush_handle must be a valid handle to a brush.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
printer_create_pen | Domů | printer_delete_dc


printer_delete_dc

(No version information available, might be only in CVS)

printer_delete_dc — Delete a device context

Popis

bool printer_delete_dc ( resource $printer_handle )

The function deletes the device context. For an example see printer_create_dc().

Seznam parametrů

printer_handle

printer_handle must be a valid printer handle.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
printer_delete_brush | Domů | printer_delete_font


printer_delete_font

(No version information available, might be only in CVS)

printer_delete_font — Delete a font

Popis

void printer_delete_font ( resource $font_handle )

The function deletes the selected font. For an example see printer_select_font().

Seznam parametrů

font_handle

font_handle must be a valid handle to a font.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
printer_delete_dc | Domů | printer_delete_pen


printer_delete_pen

(No version information available, might be only in CVS)

printer_delete_pen — Delete a pen

Popis

void printer_delete_pen ( resource $pen_handle )

The function deletes the selected pen. For an example see printer_select_pen().

Seznam parametrů

pen_handle

pen_handle must be a valid pen handle.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
printer_delete_font | Domů | printer_draw_bmp


printer_draw_bmp

(No version information available, might be only in CVS)

printer_draw_bmp — Draw a bmp

Popis

bool printer_draw_bmp ( resource $printer_handle, string $filename, int $x, int $y [, int $width, int $height] )

The function draws an bmp.

Seznam parametrů

printer_handle

printer_handle must be a valid printer handle.

filename

Path to the bitmap.

x

x is the upper left x coordinate of the bitmap.

y

y is the upper left y coordinate of the bitmap.

width

The bitmap width.

height

The bitmap height.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1783. printer_draw_bmp() example

<?php
$handle = printer_open();
printer_start_doc($handle, "My Document");
printer_start_page($handle);

printer_draw_bmp($handle, "c:\\image.bmp", 1, 1);

printer_end_page($handle);
printer_end_doc($handle);
printer_close($handle);
?>

Předcházející | Nahoru | Další
printer_delete_pen | Domů | printer_draw_chord


printer_draw_chord

(No version information available, might be only in CVS)

printer_draw_chord — Draw a chord

Popis

void printer_draw_chord ( resource $printer_handle, int $rec_x, int $rec_y, int $rec_x1, int $rec_y1, int $rad_x, int $rad_y, int $rad_x1, int $rad_y1 )

The function simply draws an chord.

Seznam parametrů

printer_handle

printer_handle must be a valid printer handle.

rec_x

rec_x is the upper left x coordinate of the bounding rectangle.

rec_y

rec_y is the upper left y coordinate of the bounding rectangle.

rec_x1

rec_x1 is the lower right x coordinate of the bounding rectangle.

rec_y1

rec_y1 is the lower right y coordinate of the bounding rectangle.

rad_x

rad_x is x coordinate of the radial defining the beginning of the chord.

rad_y

rad_y is y coordinate of the radial defining the beginning of the chord.

rad_x1

rad_x1 is x coordinate of the radial defining the end of the chord.

rad_y1

rad_y1 is y coordinate of the radial defining the end of the chord.

Návratové hodnoty

Nevrací se žádná hodnota.

Příklady

Příklad 1784. printer_draw_chord() example

<?php
$handle = printer_open();
printer_start_doc($handle, "My Document");
printer_start_page($handle);

$pen = printer_create_pen(PRINTER_PEN_SOLID, 2, "000000");
printer_select_pen($handle, $pen);

$brush = printer_create_brush(PRINTER_BRUSH_SOLID, "2222FF");
printer_select_brush($handle, $brush);

printer_draw_chord($handle, 1, 1, 500, 500, 1, 1, 500, 1);

printer_delete_brush($brush);
printer_delete_pen($pen);

printer_end_page($handle);
printer_end_doc($handle);
printer_close($handle);
?>

Předcházející | Nahoru | Další
printer_draw_bmp | Domů | printer_draw_elipse


printer_draw_elipse

(No version information available, might be only in CVS)

printer_draw_elipse — Draw an ellipse

Popis

void printer_draw_elipse ( resource $printer_handle, int $ul_x, int $ul_y, int $lr_x, int $lr_y )

The function draws an ellipse.

Seznam parametrů

printer_handle

printer_handle must be a valid printer handle.

ul_x

ul_x is the upper left x coordinate of the ellipse.

ul_y

ul_y is the upper left y coordinate of the ellipse.

lr_x

lr_x is the lower right x coordinate of the ellipse.

lr_y

lr_y is the lower right y coordinate of the ellipse.

Návratové hodnoty

Nevrací se žádná hodnota.

Příklady

Příklad 1785. printer_draw_elipse() example

<?php
$handle = printer_open();
printer_start_doc($handle, "My Document");
printer_start_page($handle);

$pen = printer_create_pen(PRINTER_PEN_SOLID, 2, "000000");
printer_select_pen($handle, $pen);

$brush = printer_create_brush(PRINTER_BRUSH_SOLID, "2222FF");
printer_select_brush($handle, $brush);

printer_draw_elipse($handle, 1, 1, 500, 500);

printer_delete_brush($brush);
printer_delete_pen($pen);

printer_end_page($handle);
printer_end_doc($handle);
printer_close($handle);
?>

Předcházející | Nahoru | Další
printer_draw_chord | Domů | printer_draw_line


printer_draw_line

(No version information available, might be only in CVS)

printer_draw_line — Draw a line

Popis

void printer_draw_line ( resource $printer_handle, int $from_x, int $from_y, int $to_x, int $to_y )

The function draws a line using the selected pen.

Seznam parametrů

printer_handle

printer_handle must be a valid printer handle.

from_x

from_x is the x coordinate of the origin point.

from_y

from_y is the y coordinate of the origin point.

to_x

to_x is the x coordinate of the destination point.

to_y

to_y is the y coordinate of the destination point.

Návratové hodnoty

Nevrací se žádná hodnota.

Příklady

Příklad 1786. printer_draw_line() example

<?php
$handle = printer_open();
printer_start_doc($handle, "My Document");
printer_start_page($handle);

$pen = printer_create_pen(PRINTER_PEN_SOLID, 30, "000000");
printer_select_pen($handle, $pen);

printer_draw_line($handle, 1, 10, 1000, 10);
printer_draw_line($handle, 1, 60, 500, 60);

printer_delete_pen($pen);

printer_end_page($handle);
printer_end_doc($handle);
printer_close($handle);
?>

Předcházející | Nahoru | Další
printer_draw_elipse | Domů | printer_draw_pie


printer_draw_pie

(No version information available, might be only in CVS)

printer_draw_pie — Draw a pie

Popis

void printer_draw_pie ( resource $printer_handle, int $rec_x, int $rec_y, int $rec_x1, int $rec_y1, int $rad1_x, int $rad1_y, int $rad2_x, int $rad2_y )

The function draws an pie.

Seznam parametrů

printer_handle

printer_handle must be a valid printer handle.

rec_x

rec_x is the upper left x coordinate of the bounding rectangle.

rec_y

rec_y is the upper left y coordinate of the bounding rectangle.

rec_x1

rec_x1 is the lower right x coordinate of the bounding rectangle.

rec_y1

rec_y1 is the lower right y coordinate of the bounding rectangle.

rad1_x

rad1_x is x coordinate of the first radial's ending.

rad1_y

rad1_y is y coordinate of the first radial's ending.

rad2_x

rad2_x is x coordinate of the second radial's ending.

rad2_y

rad2_y is y coordinate of the second radial's ending.

Návratové hodnoty

Nevrací se žádná hodnota.

Příklady

Příklad 1787. printer_draw_pie() example

<?php
$handle = printer_open();
printer_start_doc($handle, "My Document");
printer_start_page($handle);

$pen = printer_create_pen(PRINTER_PEN_SOLID, 2, "000000");
printer_select_pen($handle, $pen);

$brush = printer_create_brush(PRINTER_BRUSH_SOLID, "2222FF");
printer_select_brush($handle, $brush);

printer_draw_pie($handle, 1, 1, 500, 500, 1, 1, 500, 1);

printer_delete_brush($brush);
printer_delete_pen($pen);

printer_end_page($handle);
printer_end_doc($handle);
printer_close($handle);
?>

Předcházející | Nahoru | Další
printer_draw_line | Domů | printer_draw_rectangle


printer_draw_rectangle

(No version information available, might be only in CVS)

printer_draw_rectangle — Draw a rectangle

Popis

void printer_draw_rectangle ( resource $printer_handle, int $ul_x, int $ul_y, int $lr_x, int $lr_y )

The function draws a rectangle.

Seznam parametrů

printer_handle

printer_handle must be a valid printer handle.

ul_x

ul_x is the upper left x coordinate of the rectangle.

ul_y

ul_y is the upper left y coordinate of the rectangle.

lr_x

lr_x is the lower right x coordinate of the rectangle.

lr_y

lr_y is the lower right y coordinate of the rectangle.

Návratové hodnoty

Nevrací se žádná hodnota.

Příklady

Příklad 1788. printer_draw_rectangle() example

<?php
$handle = printer_open();
printer_start_doc($handle, "My Document");
printer_start_page($handle);

$pen = printer_create_pen(PRINTER_PEN_SOLID, 2, "000000");
printer_select_pen($handle, $pen);

$brush = printer_create_brush(PRINTER_BRUSH_SOLID, "2222FF");
printer_select_brush($handle, $brush);

printer_draw_rectangle($handle, 1, 1, 500, 500);

printer_delete_brush($brush);
printer_delete_pen($pen);

printer_end_page($handle);
printer_end_doc($handle);
printer_close($handle);
?>

Předcházející | Nahoru | Další
printer_draw_pie | Domů | printer_draw_roundrect


printer_draw_roundrect

(No version information available, might be only in CVS)

printer_draw_roundrect — Draw a rectangle with rounded corners

Popis

void printer_draw_roundrect ( resource $printer_handle, int $ul_x, int $ul_y, int $lr_x, int $lr_y, int $width, int $height )

The function draws a rectangle with rounded corners.

Seznam parametrů

printer_handle

printer_handle must be a valid printer handle.

ul_x

ul_x is the upper left x coordinate of the rectangle.

ul_y

ul_y is the upper left y coordinate of the rectangle.

lr_x

lr_x is the lower right x coordinate of the rectangle.

lr_y

lr_y is the lower right y coordinate of the rectangle.

width

width is the width of the ellipse.

height

height is the height of the ellipse.

Návratové hodnoty

Nevrací se žádná hodnota.

Příklady

Příklad 1789. printer_draw_roundrect() example

<?php
$handle = printer_open();
printer_start_doc($handle, "My Document");
printer_start_page($handle);

$pen = printer_create_pen(PRINTER_PEN_SOLID, 2, "000000");
printer_select_pen($handle, $pen);

$brush = printer_create_brush(PRINTER_BRUSH_SOLID, "2222FF");
printer_select_brush($handle, $brush);

printer_draw_roundrect($handle, 1, 1, 500, 500, 200, 200);

printer_delete_brush($brush);
printer_delete_pen($pen);

printer_end_page($handle);
printer_end_doc($handle);
printer_close($handle);
?>

Předcházející | Nahoru | Další
printer_draw_rectangle | Domů | printer_draw_text


printer_draw_text

(No version information available, might be only in CVS)

printer_draw_text — Draw text

Popis

void printer_draw_text ( resource $printer_handle, string $text, int $x, int $y )

The function draws text at position x, y using the selected font.

Seznam parametrů

printer_handle

printer_handle must be a valid handle to a printer.

text

The text to be written.

x

x is the x coordinate of the position.

y

y is the y coordinate of the position.

Návratové hodnoty

Nevrací se žádná hodnota.

Příklady

Příklad 1790. printer_draw_text() example

<?php
$handle = printer_open();
printer_start_doc($handle, "My Document");
printer_start_page($handle);

$font = printer_create_font("Arial", 72, 48, 400, false, false, false, 0);
printer_select_font($handle, $font);
printer_draw_text($handle, "test", 10, 10);
printer_delete_font($font);

printer_end_page($handle);
printer_end_doc($handle);
printer_close($handle);
?>

Předcházející | Nahoru | Další
printer_draw_roundrect | Domů | printer_end_doc


printer_end_doc

(No version information available, might be only in CVS)

printer_end_doc — Close document

Popis

bool printer_end_doc ( resource $printer_handle )

Closes a new document in the printer spooler. The document is now ready for printing. For an example see printer_start_doc().

Seznam parametrů

printer_handle

printer_handle must be a valid handle to a printer.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
printer_draw_text | Domů | printer_end_page


printer_end_page

(No version information available, might be only in CVS)

printer_end_page — Close active page

Popis

bool printer_end_page ( resource $printer_handle )

The function closes the active page in the active document. For an example see printer_start_doc().

Seznam parametrů

printer_handle

printer_handle must be a valid handle to a printer.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
printer_end_doc | Domů | printer_get_option


printer_get_option

(No version information available, might be only in CVS)

printer_get_option — Retrieve printer configuration data

Popis

mixed printer_get_option ( resource $printer_handle, string $option )

The function retrieves the configuration setting of option.

Seznam parametrů

printer_handle

printer_handle must be a valid handle to a printer.

option

Take a look at printer_set_option() for the settings that can be retrieved, additionally the following settings can be retrieved:

  • PRINTER_DEVICENAME returns the devicename of the printer.
  • PRINTER_DRIVERVERSION returns the printer driver version.

Návratové hodnoty

Returns the value of option.

Příklady

Příklad 1791. printer_get_option() example

<?php
$handle = printer_open();
echo printer_get_option($handle, PRINTER_DRIVERVERSION);
printer_close($handle);
?>

Předcházející | Nahoru | Další
printer_end_page | Domů | printer_list


printer_list

(No version information available, might be only in CVS)

printer_list — Return an array of printers attached to the server

Popis

array printer_list ( int $enumtype [, string $name [, int $level]] )

The function enumerates available printers and their capabilities.

Seznam parametrů

enumtype

enumtype must be one of the following predefined constants:

  • PRINTER_ENUM_LOCAL: enumerates the locally installed printers.
  • PRINTER_ENUM_NAME: enumerates the printer of name, can be a server, domain or print provider.
  • PRINTER_ENUM_SHARED: this parameter can't be used alone, it has to be OR'ed with other parameters, i.e. PRINTER_ENUM_LOCAL to detect the locally shared printers.
  • PRINTER_ENUM_DEFAULT: (Win9.x only) enumerates the default printer.
  • PRINTER_ENUM_CONNECTIONS: (WinNT/2000 only) enumerates the printers to which the user has made connections.
  • PRINTER_ENUM_NETWORK: (WinNT/2000 only) enumerates network printers in the computer's domain. Only valid if level is 1.
  • PRINTER_ENUM_REMOTE: (WinNT/2000 only) enumerates network printers and print servers in the computer's domain. Only valid if level is 1.

name

Used with PRINTER_ENUM_NAME.

level

level sets the level of information request. Can be 1,2,4 or 5.

Návratové hodnoty

Return an array of printers.

Příklady

Příklad 1792. printer_list() example

<?php
/* detect locally shared printer */
var_dump(printer_list(PRINTER_ENUM_LOCAL | PRINTER_ENUM_SHARED));
?>

Předcházející | Nahoru | Další
printer_get_option | Domů | printer_logical_fontheight


printer_logical_fontheight

(No version information available, might be only in CVS)

printer_logical_fontheight — Get logical font height

Popis

int printer_logical_fontheight ( resource $printer_handle, int $height )

The function calculates the logical font height of height.

Seznam parametrů

printer_handle

printer_handle must be a valid printer handle.

height

The font height.

Návratové hodnoty

Returns the logical font height or FALSE on failure.

Příklady

Příklad 1793. printer_logical_fontheight() example

<?php
$handle = printer_open();
echo printer_logical_fontheight($handle, 72);
printer_close($handle);
?>

Předcházející | Nahoru | Další
printer_list | Domů | printer_open


printer_open

(No version information available, might be only in CVS)

printer_open — Opens a connection to a printer

Popis

resource printer_open ( [string $printername] )

This function tries to open a connection to the given printer.

printer_open() also starts a device context.

Seznam parametrů

printername

The printer name. If no parameter was given it tries to open a connection to the default printer (if not specified in php.ini as printer.default_printer, PHP tries to detect it).

Návratové hodnoty

Returns a printer handle on success or FALSE on failure.

Příklady

Příklad 1794. printer_open() example

<?php
$handle = printer_open("HP Deskjet 930c");
$handle = printer_open();
?>

Předcházející | Nahoru | Další
printer_logical_fontheight | Domů | printer_select_brush


printer_select_brush

(No version information available, might be only in CVS)

printer_select_brush — Select a brush

Popis

void printer_select_brush ( resource $printer_handle, resource $brush_handle )

The function selects a brush as the active drawing object of the actual device context. A brush is used to fill shapes. If you draw an rectangle the brush is used to draw the shapes, while the pen is used to draw the border.

If you haven't selected a brush before drawing shapes, the shape won't be filled.

Seznam parametrů

printer_handle

printer_handle must be a valid printer handle.

brush_handle

brush_handle must be a valid brush handle.

Návratové hodnoty

Nevrací se žádná hodnota.

Příklady

Příklad 1795. printer_select_brush() example

<?php
$handle = printer_open();
printer_start_doc($handle, "My Document");
printer_start_page($handle);

$pen = printer_create_pen(PRINTER_PEN_SOLID, 2, "000000");
printer_select_pen($handle, $pen);
$brush = printer_create_brush(PRINTER_BRUSH_CUSTOM, "c:\\brush.bmp");
printer_select_brush($handle, $brush);

printer_draw_rectangle($handle, 1, 1, 500, 500);

printer_delete_brush($brush);

$brush = printer_create_brush(PRINTER_BRUSH_SOLID, "000000");
printer_select_brush($handle, $brush);
printer_draw_rectangle($handle, 1, 501, 500, 1001);
printer_delete_brush($brush);

printer_delete_pen($pen);

printer_end_page($handle);
printer_end_doc($handle);
printer_close($handle);
?>

Předcházející | Nahoru | Další
printer_open | Domů | printer_select_font


printer_select_font

(No version information available, might be only in CVS)

printer_select_font — Select a font

Popis

void printer_select_font ( resource $printer_handle, resource $font_handle )

The function selects a font to draw text.

Seznam parametrů

printer_handle

printer_handle must be a valid printer handle.

font_handle

font_handle must be a valid font handle.

Návratové hodnoty

Nevrací se žádná hodnota.

Příklady

Příklad 1796. printer_select_font() example

<?php
$handle = printer_open();
printer_start_doc($handle, "My Document");
printer_start_page($handle);

$font = printer_create_font("Arial", 148, 76, PRINTER_FW_MEDIUM, false, false, false, -50);
printer_select_font($handle, $font);
printer_draw_text($handle, "PHP is simply cool", 40, 40);
printer_delete_font($font);

printer_end_page($handle);
printer_end_doc($handle);
printer_close($handle);
?>

Předcházející | Nahoru | Další
printer_select_brush | Domů | printer_select_pen


printer_select_pen

(No version information available, might be only in CVS)

printer_select_pen — Select a pen

Popis

void printer_select_pen ( resource $printer_handle, resource $pen_handle )

The function selects a pen as the active drawing object of the actual device context. A pen is used to draw lines and curves. I.e. if you draw a single line the pen is used. If you draw an rectangle the pen is used to draw the borders, while the brush is used to fill the shape. If you haven't selected a pen before drawing shapes, the shape won't be outlined.

Seznam parametrů

printer_handle

printer_handle must be a valid printer handle.

pen_handle

pen_handle must be a valid pen handle.

Návratové hodnoty

Nevrací se žádná hodnota.

Příklady

Příklad 1797. printer_select_pen() example

<?php
$handle = printer_open();
printer_start_doc($handle, "My Document");
printer_start_page($handle);

$pen = printer_create_pen(PRINTER_PEN_SOLID, 30, "2222FF");
printer_select_pen($handle, $pen);

printer_draw_line($handle, 1, 60, 500, 60);

printer_delete_pen($pen);

printer_end_page($handle);
printer_end_doc($handle);
printer_close($handle);
?>

Předcházející | Nahoru | Další
printer_select_font | Domů | printer_set_option


printer_set_option

(No version information available, might be only in CVS)

printer_set_option — Configure the printer connection

Popis

bool printer_set_option ( resource $printer_handle, int $option, mixed $value )

The function sets options for the current connection.

Seznam parametrů

printer_handle

printer_handle must be a valid printer handle.

option

Option can be one of the following constants:

  • PRINTER_COPIES: sets how many copies should be printed, value must be an integer.
  • PRINTER_MODE: specifies the type of data (text, raw or emf), value must be a string.
  • PRINTER_TITLE: specifies the name of the document, value must be a string.
  • PRINTER_ORIENTATION: specifies the orientation of the paper, value can be either PRINTER_ORIENTATION_PORTRAIT or PRINTER_ORIENTATION_LANDSCAPE
  • PRINTER_RESOLUTION_Y: specifies the y-resolution in DPI, value must be an integer.
  • PRINTER_RESOLUTION_X: specifies the x-resolution in DPI, value must be an integer.

  • PRINTER_PAPER_FORMAT: specifies a predefined paper format, set value to PRINTER_FORMAT_CUSTOM if you want to specify a custom format with PRINTER_PAPER_WIDTH and PRINTER_PAPER_LENGTH. value can be one of the following constants.

    • PRINTER_FORMAT_CUSTOM: let's you specify a custom paper format.
    • PRINTER_FORMAT_LETTER: specifies standard letter format (8 1/2- by 11-inches).
    • PRINTER_FORMAT_LEGAL: specifies standard legal format (8 1/2- by 14-inches).
    • PRINTER_FORMAT_A3: specifies standard A3 format (297- by 420-millimeters).
    • PRINTER_FORMAT_A4: specifies standard A4 format (210- by 297-millimeters).
    • PRINTER_FORMAT_A5: specifies standard A5 format (148- by 210-millimeters).
    • PRINTER_FORMAT_B4: specifies standard B4 format (250- by 354-millimeters).
    • PRINTER_FORMAT_B5: specifies standard B5 format (182- by 257-millimeter).
    • PRINTER_FORMAT_FOLIO: specifies standard FOLIO format (8 1/2- by 13-inch).
  • PRINTER_PAPER_LENGTH: if PRINTER_PAPER_FORMAT is set to PRINTER_FORMAT_CUSTOM, PRINTER_PAPER_LENGTH specifies a custom paper length in mm, value must be an integer.
  • PRINTER_PAPER_WIDTH: if PRINTER_PAPER_FORMAT is set to PRINTER_FORMAT_CUSTOM, PRINTER_PAPER_WIDTH specifies a custom paper width in mm, value must be an integer.
  • PRINTER_SCALE: specifies the factor by which the printed output is to be scaled. the page size is scaled from the physical page size by a factor of scale/100. for example if you set the scale to 50, the output would be half of its original size. value must be an integer.
  • PRINTER_BACKGROUND_COLOR: specifies the background color for the actual device context, value must be a string containing the rgb information in hex format i.e. "005533".
  • PRINTER_TEXT_COLOR: specifies the text color for the actual device context, value must be a string containing the rgb information in hex format i.e. "005533".

  • PRINTER_TEXT_ALIGN: specifies the text alignment for the actual device context, value can be combined through OR'ing the following constants:

    • PRINTER_TA_BASELINE: text will be aligned at the base line.
    • PRINTER_TA_BOTTOM: text will be aligned at the bottom.
    • PRINTER_TA_TOP: text will be aligned at the top.
    • PRINTER_TA_CENTER: text will be aligned at the center.
    • PRINTER_TA_LEFT: text will be aligned at the left.
    • PRINTER_TA_RIGHT: text will be aligned at the right.

value

The option value.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1798. printer_set_option() example

<?php
$handle = printer_open();
printer_set_option($handle, PRINTER_SCALE, 75);
printer_set_option($handle, PRINTER_TEXT_ALIGN, PRINTER_TA_LEFT);
printer_close($handle);
?>

Předcházející | Nahoru | Další
printer_select_pen | Domů | printer_start_doc


printer_start_doc

(No version information available, might be only in CVS)

printer_start_doc — Start a new document

Popis

bool printer_start_doc ( resource $printer_handle [, string $document] )

The function creates a new document in the printer spooler. A document can contain multiple pages, it's used to schedule the print job in the spooler.

Seznam parametrů

printer_handle

printer_handle must be a valid printer handle.

document

The optional parameter document can be used to set an alternative document name.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1799. printer_start_doc() example

<?php
$handle = printer_open();
printer_start_doc($handle, "My Document");
printer_start_page($handle);

printer_end_page($handle);
printer_end_doc($handle);
printer_close($handle);
?>

Předcházející | Nahoru | Další
printer_set_option | Domů | printer_start_page


printer_start_page

(No version information available, might be only in CVS)

printer_start_page — Start a new page

Popis

bool printer_start_page ( resource $printer_handle )

The function creates a new page in the active document. For an example see printer_start_doc().

Seznam parametrů

printer_handle

printer_handle must be a valid printer handle.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
printer_start_doc | Domů | printer_write


printer_write

(No version information available, might be only in CVS)

printer_write — Write data to the printer

Popis

bool printer_write ( resource $printer_handle, string $content )

Writes content directly to the printer.

Seznam parametrů

printer_handle

printer_handle must be a valid printer handle.

content

The data to be written.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1800. printer_write() example

<?php
$handle = printer_open();
printer_write($handle, "Text to print");
printer_close($handle);
?>

Předcházející | Nahoru | Další
printer_start_page | Domů | CXXX. Funkce spouštění programů


Pspell Functions

Předcházející VI. Reference funkcí Další

CXXXII. Pspell Functions

Úvod

These functions allow you to check the spelling of a word and offer suggestions.

Požadavky

To compile PHP with pspell support, you need the aspell library, available from » http://aspell.sourceforge.net/.

Instalace

If you have the libraries needed add the --with-pspell[=dir] option when compiling PHP.

Note to Win32 Users: In order for this extension to work, there are DLL files that must be available to the Windows system PATH. See the FAQ titled "How do I add my PHP directory to the PATH on Windows" for information on how to do this. Although copying DLL files from the PHP folder into the Windows system directory also works (because the system directory is by default in the systems PATH), it is not recommended. This extension requires the following files to be in the PATH: aspell-15.dll from the bin folder of the aspell installation.

Win32 support is available only in PHP 4.3.3 and later versions. Also, at least aspell version 0.50 is required.

Konfigurace běhu

Toto rozšíření nemá definováno žádné konfigurační direktivy.

Typy prostředků

Toto rozšíření nemá definován žádný typ prostředku (resource).

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

PSPELL_FAST (integer)
PSPELL_NORMAL (integer)
PSPELL_BAD_SPELLERS (integer)
PSPELL_RUN_TOGETHER (integer)

Obsah

pspell_add_to_personal — Add the word to a personal wordlist
pspell_add_to_session — Add the word to the wordlist in the current session
pspell_check — Check a word
pspell_clear_session — Clear the current session
pspell_config_create — Create a config used to open a dictionary
pspell_config_data_dir — location of language data files
pspell_config_dict_dir — Location of the main word list
pspell_config_ignore — Ignore words less than N characters long
pspell_config_mode — Change the mode number of suggestions returned
pspell_config_personal — Set a file that contains personal wordlist
pspell_config_repl — Set a file that contains replacement pairs
pspell_config_runtogether — Consider run-together words as valid compounds
pspell_config_save_repl — Determine whether to save a replacement pairs list along with the wordlist
pspell_new_config — Load a new dictionary with settings based on a given config
pspell_new_personal — Load a new dictionary with personal wordlist
pspell_new — Load a new dictionary
pspell_save_wordlist — Save the personal wordlist to a file
pspell_store_replacement — Store a replacement pair for a word
pspell_suggest — Suggest spellings of a word
Předcházející | Nahoru | Další
ps_translate | Domů | pspell_add_to_personal


pspell_add_to_personal

(PHP 4 >= 4.0.2, PHP 5)

pspell_add_to_personal — Add the word to a personal wordlist

Popis

bool pspell_add_to_personal ( int $dictionary_link, string $word )

pspell_add_to_personal() adds a word to the personal wordlist. If you used pspell_new_config() with pspell_config_personal() to open the dictionary, you can save the wordlist later with pspell_save_wordlist().

Seznam parametrů

dictionary_link

word

The added word.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1812. pspell_add_to_personal()

<?php
$pspell_config = pspell_config_create("en");
pspell_config_personal($pspell_config, "/var/dictionaries/custom.pws");
$pspell_link = pspell_new_config($pspell_config);

pspell_add_to_personal($pspell_link, "Vlad");
pspell_save_wordlist($pspell_link);
?>

Poznámky

Poznámka: This function will not work unless you have pspell .11.2 and aspell .32.5 or later.

Předcházející | Nahoru | Další
CXXXII. Pspell Functions | Domů | pspell_add_to_session


pspell_add_to_session

(PHP 4 >= 4.0.2, PHP 5)

pspell_add_to_session — Add the word to the wordlist in the current session

Popis

bool pspell_add_to_session ( int $dictionary_link, string $word )

pspell_add_to_session() adds a word to the wordlist associated with the current session. It is very similar to pspell_add_to_personal()

Seznam parametrů

dictionary_link

word

The added word.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
pspell_add_to_personal | Domů | pspell_check


pspell_check

(PHP 4 >= 4.0.2, PHP 5)

pspell_check — Check a word

Popis

bool pspell_check ( int $dictionary_link, string $word )

pspell_check() checks the spelling of a word.

Seznam parametrů

dictionary_link

word

The tested word.

Návratové hodnoty

Returns TRUE if the spelling is correct, FALSE if not.

Příklady

Příklad 1813. pspell_check() Example

<?php
$pspell_link = pspell_new("en");

if (pspell_check($pspell_link, "testt")) {
    echo "This is a valid spelling";
} else {
    echo "Sorry, wrong spelling";
}
?>

Předcházející | Nahoru | Další
pspell_add_to_session | Domů | pspell_clear_session


pspell_clear_session

(PHP 4 >= 4.0.2, PHP 5)

pspell_clear_session — Clear the current session

Popis

bool pspell_clear_session ( int $dictionary_link )

pspell_clear_session() clears the current session. The current wordlist becomes blank, and, for example, if you try to save it with pspell_save_wordlist(), nothing happens.

Seznam parametrů

dictionary_link

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1814. pspell_add_to_personal() Example

<?php
$pspell_config = pspell_config_create("en");
pspell_config_personal($pspell_config, "/var/dictionaries/custom.pws");
$pspell_link = pspell_new_config($pspell_config);

pspell_add_to_personal($pspell_link, "Vlad");
pspell_clear_session($pspell_link);
pspell_save_wordlist($pspell_link);    //"Vlad" will not be saved
?>

Předcházející | Nahoru | Další
pspell_check | Domů | pspell_config_create


pspell_config_create

(PHP 4 >= 4.0.2, PHP 5)

pspell_config_create — Create a config used to open a dictionary

Popis

int pspell_config_create ( string $language [, string $spelling [, string $jargon [, string $encoding]]] )

Create a config used to open a dictionary.

pspell_config_create() has a very similar syntax to pspell_new(). In fact, using pspell_config_create() immediately followed by pspell_new_config() will produce the exact same result. However, after creating a new config, you can also use pspell_config_*() functions before calling pspell_new_config() to take advantage of some advanced functionality.

For more information and examples, check out inline manual pspell website:» http://aspell.net/.

Seznam parametrů

language

The language parameter is the language code which consists of the two letter ISO 639 language code and an optional two letter ISO 3166 country code after a dash or underscore.

spelling

The spelling parameter is the requested spelling for languages with more than one spelling such as English. Known values are 'american', 'british', and 'canadian'.

jargon

The jargon parameter contains extra information to distinguish two different words lists that have the same language and spelling parameters.

encoding

The encoding parameter is the encoding that words are expected to be in. Valid values are 'utf-8', 'iso8859-*', 'koi8-r', 'viscii', 'cp1252', 'machine unsigned 16', 'machine unsigned 32'. This parameter is largely untested, so be careful when using.

Návratové hodnoty

Retuns a pspell config identifier, or FALSE on error.

Příklady

Příklad 1815. pspell_config_create()

<?php
$pspell_config = pspell_config_create("en");
pspell_config_personal($pspell_config, "/var/dictionaries/custom.pws");
pspell_config_repl($pspell_config, "/var/dictionaries/custom.repl");
$pspell_link = pspell_new_personal($pspell_config, "en");
?>

Předcházející | Nahoru | Další
pspell_clear_session | Domů | pspell_config_data_dir


pspell_config_data_dir

(PHP 5)

pspell_config_data_dir — location of language data files

Popis

bool pspell_config_data_dir ( int $conf, string $directory )

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
pspell_config_create | Domů | pspell_config_dict_dir


pspell_config_dict_dir

(PHP 5)

pspell_config_dict_dir — Location of the main word list

Popis

bool pspell_config_dict_dir ( int $conf, string $directory )

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
pspell_config_data_dir | Domů | pspell_config_ignore


pspell_config_ignore

(PHP 4 >= 4.0.2, PHP 5)

pspell_config_ignore — Ignore words less than N characters long

Popis

bool pspell_config_ignore ( int $dictionary_link, int $n )

pspell_config_ignore() should be used on a config before calling pspell_new_config(). This function allows short words to be skipped by the spell checker.

Seznam parametrů

dictionary_link

n

Words less than n characters will be skipped.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1816. pspell_config_ignore()

<?php
$pspell_config = pspell_config_create("en");
pspell_config_ignore($pspell_config, 5);
$pspell_link = pspell_new_config($pspell_config);
pspell_check($pspell_link, "abcd");    //will not result in an error
?>

Předcházející | Nahoru | Další
pspell_config_dict_dir | Domů | pspell_config_mode


pspell_config_mode

(PHP 4 >= 4.0.2, PHP 5)

pspell_config_mode — Change the mode number of suggestions returned

Popis

bool pspell_config_mode ( int $dictionary_link, int $mode )

pspell_config_mode() should be used on a config before calling pspell_new_config(). This function determines how many suggestions will be returned by pspell_suggest().

Seznam parametrů

dictionary_link

mode

The mode parameter is the mode in which spellchecker will work. There are several modes available:

  • PSPELL_FAST - Fast mode (least number of suggestions)
  • PSPELL_NORMAL - Normal mode (more suggestions)
  • PSPELL_BAD_SPELLERS - Slow mode (a lot of suggestions)

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1817. pspell_config_mode() Example

<?php
$pspell_config = pspell_config_create("en");
pspell_config_mode($pspell_config, PSPELL_FAST);
$pspell_link = pspell_new_config($pspell_config);
pspell_check($pspell_link, "thecat");
?>

Předcházející | Nahoru | Další
pspell_config_ignore | Domů | pspell_config_personal


pspell_config_personal

(PHP 4 >= 4.0.2, PHP 5)

pspell_config_personal — Set a file that contains personal wordlist

Popis

bool pspell_config_personal ( int $dictionary_link, string $file )

Set a file that contains personal wordlist. The personal wordlist will be loaded and used in addition to the standard one after you call pspell_new_config(). The file is also the file where pspell_save_wordlist() will save personal wordlist to.

pspell_config_personal() should be used on a config before calling pspell_new_config().

Seznam parametrů

dictionary_link

file

The personal wordlist. If the file does not exist, it will be created. The file should be writable by whoever PHP runs as (e.g. nobody).

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1818. pspell_config_personal()

<?php
$pspell_config = pspell_config_create("en");
pspell_config_personal($pspell_config, "/var/dictionaries/custom.pws");
$pspell_link = pspell_new_config($pspell_config);
pspell_check($pspell_link, "thecat");
?>

Poznámky

Poznámka: This function will not work unless you have pspell .11.2 and aspell .32.5 or later.

Předcházející | Nahoru | Další
pspell_config_mode | Domů | pspell_config_repl


pspell_config_repl

(PHP 4 >= 4.0.2, PHP 5)

pspell_config_repl — Set a file that contains replacement pairs

Popis

bool pspell_config_repl ( int $dictionary_link, string $file )

Set a file that contains replacement pairs.

The replacement pairs improve the quality of the spellchecker. When a word is misspelled, and a proper suggestion was not found in the list, pspell_store_replacement() can be used to store a replacement pair and then pspell_save_wordlist() to save the wordlist along with the replacement pairs.

pspell_config_repl() should be used on a config before calling pspell_new_config().

Seznam parametrů

dictionary_link

file

The file should be writable by whoever PHP runs as (e.g. nobody).

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1819. pspell_config_repl()

<?php
$pspell_config = pspell_config_create("en");
pspell_config_personal($pspell_config, "/var/dictionaries/custom.pws");
pspell_config_repl($pspell_config, "/var/dictionaries/custom.repl");
$pspell_link = pspell_new_config($pspell_config);
pspell_check($pspell_link, "thecat");
?>

Poznámky

Poznámka: This function will not work unless you have pspell .11.2 and aspell .32.5 or later.

Předcházející | Nahoru | Další
pspell_config_personal | Domů | pspell_config_runtogether


pspell_config_runtogether

(PHP 4 >= 4.0.2, PHP 5)

pspell_config_runtogether — Consider run-together words as valid compounds

Popis

bool pspell_config_runtogether ( int $dictionary_link, bool $flag )

This function determines whether run-together words will be treated as legal compounds. That is, "thecat" will be a legal compound, although there should be a space between the two words. Changing this setting only affects the results returned by pspell_check(); pspell_suggest() will still return suggestions.

pspell_config_runtogether() should be used on a config before calling pspell_new_config().

Seznam parametrů

dictionary_link

flag

TRUE if run-together words should be treated as legal compounds, FALSE otherwise.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1820. pspell_config_runtogether()

<?php
$pspell_config = pspell_config_create("en");
pspell_config_runtogether($pspell_config, true);
$pspell_link = pspell_new_config($pspell_config);
pspell_check($pspell_link, "thecat");
?>

Předcházející | Nahoru | Další
pspell_config_repl | Domů | pspell_config_save_repl


pspell_config_save_repl

(PHP 4 >= 4.0.2, PHP 5)

pspell_config_save_repl — Determine whether to save a replacement pairs list along with the wordlist

Popis

bool pspell_config_save_repl ( int $dictionary_link, bool $flag )

pspell_config_save_repl() determines whether pspell_save_wordlist() will save the replacement pairs along with the wordlist. Usually there is no need to use this function because if pspell_config_repl() is used, the replacement pairs will be saved by pspell_save_wordlist() anyway, and if it is not, the replacement pairs will not be saved.

pspell_config_save_repl() should be used on a config before calling pspell_new_config().

Seznam parametrů

dictionary_link

flag

TRUE if replacement pairs should be saved, FALSE otherwise.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Poznámky

Poznámka: This function will not work unless you have pspell .11.2 and aspell .32.5 or later.

Předcházející | Nahoru | Další
pspell_config_runtogether | Domů | pspell_new_config


pspell_new_config

(PHP 4 >= 4.0.2, PHP 5)

pspell_new_config — Load a new dictionary with settings based on a given config

Popis

int pspell_new_config ( int $config )

pspell_new_config() opens up a new dictionary with settings specified in a config, created with pspell_config_create() and modified with pspell_config_*() functions. This method provides you with the most flexibility and has all the functionality provided by pspell_new() and pspell_new_personal().

Seznam parametrů

config

The config parameter is the one returned by pspell_config_create() when the config was created.

Návratové hodnoty

Returns a dictionary link identifier on success.

Příklady

Příklad 1821. pspell_new_config()

<?php
$pspell_config = pspell_config_create("en");
pspell_config_personal($pspell_config, "/var/dictionaries/custom.pws");
pspell_config_repl($pspell_config, "/var/dictionaries/custom.repl");
$pspell_link = pspell_new_config($pspell_config);
?>

Předcházející | Nahoru | Další
pspell_config_save_repl | Domů | pspell_new_personal


pspell_new_personal

(PHP 4 >= 4.0.2, PHP 5)

pspell_new_personal — Load a new dictionary with personal wordlist

Popis

int pspell_new_personal ( string $personal, string $language [, string $spelling [, string $jargon [, string $encoding [, int $mode]]]] )

pspell_new_personal() opens up a new dictionary with a personal wordlist. The wordlist can be modified and saved with pspell_save_wordlist(), if desired. However, the replacement pairs are not saved. In order to save replacement pairs, you should create a config using pspell_config_create(), set the personal wordlist file with pspell_config_personal(), set the file for replacement pairs with pspell_config_repl(), and open a new dictionary with pspell_new_config().

For more information and examples, check out inline manual pspell website:» http://aspell.net/.

Seznam parametrů

personal

The file where words added to the personal list will be stored. It should be an absolute filename beginning with '/' because otherwise it will be relative to $HOME, which is "/root" for most systems, and is probably not what you want.

language

The language code which consists of the two letter ISO 639 language code and an optional two letter ISO 3166 country code after a dash or underscore.

spelling

The requested spelling for languages with more than one spelling such as English. Known values are 'american', 'british', and 'canadian'.

jargon

Extra information to distinguish two different words lists that have the same language and spelling parameters.

encoding

The encoding that words are expected to be in. Valid values are utf-8, iso8859-*, koi8-r, viscii, cp1252, machine unsigned 16, machine unsigned 32.

mode

The mode in which spellchecker will work. There are several modes available:

  • PSPELL_FAST - Fast mode (least number of suggestions)
  • PSPELL_NORMAL - Normal mode (more suggestions)
  • PSPELL_BAD_SPELLERS - Slow mode (a lot of suggestions)
  • PSPELL_RUN_TOGETHER - Consider run-together words as legal compounds. That is, "thecat" will be a legal compound, although there should be a space between the two words. Changing this setting only affects the results returned by pspell_check(); pspell_suggest() will still return suggestions.

Mode is a bitmask constructed from different constants listed above. However, PSPELL_FAST, PSPELL_NORMAL and PSPELL_BAD_SPELLERS are mutually exclusive, so you should select only one of them.

Návratové hodnoty

Returns the dictionary link identifier for use in other pspell functions.

Příklady

Příklad 1822. pspell_new_personal()

<?php
$pspell_link = pspell_new_personal ("/var/dictionaries/custom.pws",
        "en", "", "", "", PSPELL_FAST|PSPELL_RUN_TOGETHER);
?>

Předcházející | Nahoru | Další
pspell_new_config | Domů | pspell_new


pspell_new

(PHP 4 >= 4.0.2, PHP 5)

pspell_new — Load a new dictionary

Popis

int pspell_new ( string $language [, string $spelling [, string $jargon [, string $encoding [, int $mode]]]] )

pspell_new() opens up a new dictionary and returns the dictionary link identifier for use in other pspell functions.

For more information and examples, check out inline manual pspell website:» http://aspell.net/.

Seznam parametrů

language

The language parameter is the language code which consists of the two letter ISO 639 language code and an optional two letter ISO 3166 country code after a dash or underscore.

spelling

The spelling parameter is the requested spelling for languages with more than one spelling such as English. Known values are 'american', 'british', and 'canadian'.

jargon

The jargon parameter contains extra information to distinguish two different words lists that have the same language and spelling parameters.

encoding

The encoding parameter is the encoding that words are expected to be in. Valid values are 'utf-8', 'iso8859-*', 'koi8-r', 'viscii', 'cp1252', 'machine unsigned 16', 'machine unsigned 32'. This parameter is largely untested, so be careful when using.

mode

The mode parameter is the mode in which spellchecker will work. There are several modes available:

  • PSPELL_FAST - Fast mode (least number of suggestions)
  • PSPELL_NORMAL - Normal mode (more suggestions)
  • PSPELL_BAD_SPELLERS - Slow mode (a lot of suggestions)
  • PSPELL_RUN_TOGETHER - Consider run-together words as legal compounds. That is, "thecat" will be a legal compound, although there should be a space between the two words. Changing this setting only affects the results returned by pspell_check(); pspell_suggest() will still return suggestions.

Mode is a bitmask constructed from different constants listed above. However, PSPELL_FAST, PSPELL_NORMAL and PSPELL_BAD_SPELLERS are mutually exclusive, so you should select only one of them.

Návratové hodnoty

Returns the dictionary link identifier on success, or FALSE on failure.

Příklady

Příklad 1823. pspell_new()

<?php
$pspell_link = pspell_new("en", "", "", "",
                           (PSPELL_FAST|PSPELL_RUN_TOGETHER));
?>

Předcházející | Nahoru | Další
pspell_new_personal | Domů | pspell_save_wordlist


pspell_save_wordlist

(PHP 4 >= 4.0.2, PHP 5)

pspell_save_wordlist — Save the personal wordlist to a file

Popis

bool pspell_save_wordlist ( int $dictionary_link )

pspell_save_wordlist() saves the personal wordlist from the current session. The location of files to be saved specified with pspell_config_personal() and (optionally) pspell_config_repl().

Seznam parametrů

dictionary_link

A dictionary link identifier opened with pspell_new_personal().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1824. pspell_add_to_personal()

<?php
$pspell_config = pspell_config_create("en");
pspell_config_personal($pspell_config, "/tmp/dicts/newdict");
$pspell_link = pspell_new_config($pspell_config);

pspell_add_to_personal($pspell_link, "Vlad");
pspell_save_wordlist($pspell_link);
?>

Poznámky

Poznámka: This function will not work unless you have pspell .11.2 and aspell .32.5 or later.

Předcházející | Nahoru | Další
pspell_new | Domů | pspell_store_replacement


pspell_store_replacement

(PHP 4 >= 4.0.2, PHP 5)

pspell_store_replacement — Store a replacement pair for a word

Popis

bool pspell_store_replacement ( int $dictionary_link, string $misspelled, string $correct )

pspell_store_replacement() stores a replacement pair for a word, so that replacement can be returned by pspell_suggest() later. In order to be able to take advantage of this function, you have to use pspell_new_personal() to open the dictionary. In order to permanently save the replacement pair, you have to use pspell_config_personal() and pspell_config_repl() to set the path where to save your custom wordlists, and then use pspell_save_wordlist() for the changes to be written to disk.

Seznam parametrů

dictionary_link

A dictionary link identifier, opened with pspell_new_personal()

misspelled

The misspelled word.

correct

The fixed spelling for the misspelled word.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1825. pspell_store_replacement()

<?php
$pspell_config = pspell_config_create("en");
pspell_config_personal($pspell_config, "/var/dictionaries/custom.pws");
pspell_config_repl($pspell_config, "/var/dictionaries/custom.repl");
$pspell_link = pspell_new_config($pspell_config);

pspell_store_replacement($pspell_link, $misspelled, $correct);
pspell_save_wordlist($pspell_link);
?>

Poznámky

Poznámka: This function will not work unless you have pspell .11.2 and aspell .32.5 or later.

Předcházející | Nahoru | Další
pspell_save_wordlist | Domů | pspell_suggest


pspell_suggest

(PHP 4 >= 4.0.2, PHP 5)

pspell_suggest — Suggest spellings of a word

Popis

array pspell_suggest ( int $dictionary_link, string $word )

pspell_suggest() returns an array of possible spellings for the given word.

Seznam parametrů

dictionary_link

word

The tested word.

Návratové hodnoty

Returns an array of possible spellings.

Příklady

Příklad 1826. pspell_suggest() example

<?php
$pspell_link = pspell_new("en");

if (!pspell_check($pspell_link, "testt")) {
    $suggestions = pspell_suggest($pspell_link, "testt");

    foreach ($suggestions as $suggestion) {
        echo "Possible spelling: $suggestion<br />";
    }
}
?>

Předcházející | Nahoru | Další
pspell_store_replacement | Domů | CXXXIII. qtdom Functions


GNU Readline

Předcházející VI. Reference funkcí Další

CXXXVI. GNU Readline

Úvod

readline() funkce implementují rozhraní ke GNU Readline knihovně. Tyto funkce poskytují editovatelné příkazové řádky. Příkladem může být způsob, jakým vám Bash umožňuje vkládat znaky nebo listovat historií příkazů pomocí kláves pro pohyb kurzoru. Z interaktivní povahy této knihovny vyplývá, že není příliš užitečná pro psaní webových aplikací, ale může být užitečná při psaní skriptů, které se mají spouštět z příkazové řádky.

Poznámka: Toto rozšíření není k dispozici na platformách Windows.

Požadavky

Abyste mohli používat readline funkce, musíte nainstalovat libreadline. Domovskou stránkou GNU Readline projektu je » http://cnswww.cns.cwru.edu/~chet/readline/rltop.html. Udržuje jej Chet Ramey, který je také autorem Bashe.

Tyto funkce můžete používat také s knihovnou libedit, ne-GPL náhradou za knihovnu readline. Knihovna libedit je pod licencí BSD a stáhnout lze z » http://www.thrysoee.dk/editline/.

Instalace

Abyste mohli používat tyto funkce, musíte zkompilovat CGI nebo CLI verzi PHP s podporou pro readline. PHP musíte zkonfigurovat s volbou --with-readline[=DIR]. Pokud chcete používat libedit jako náhradu za readline, zkonfigurujte PHP s volbou --with-libedit[=DIR].

Konfigurace běhu

Toto rozšíření nemá definováno žádné konfigurační direktivy.

Typy prostředků

Toto rozšíření nemá definován žádný typ prostředku (resource).

Předdefinované konstanty

Toto rozšíření nemá definovány žádné konstanty.

Obsah

readline_add_history — Přidat řádek do historie
readline_callback_handler_install — Initializes the readline callback interface and terminal, prints the prompt and returns immediately
readline_callback_handler_remove — Removes a previously installed callback handler and restores terminal settings
readline_callback_read_char — Reads a character and informs the readline callback interface when a line is received
readline_clear_history — Smazat historii
readline_completion_function — Zaregistrovat dokončující funkci
readline_info — Zjistit/nastavit různé interní proměnné readline
readline_list_history — Vypsat historii
readline_on_new_line — Inform readline that the cursor has moved to a new line
readline_read_history — Vrátit historii
readline_redisplay — Redraws the display
readline_write_history — Zapsat historii
readline — Přečíst řádek
Předcházející | Nahoru | Další
rar_open | Domů | readline_add_history


readline_add_history

(PHP 4, PHP 5)

readline_add_history — Přidat řádek do historie

Popis

bool readline_add_history ( string $line )

Tato funkce přidá řádek do historie příkazové řádky.

Předcházející | Nahoru | Další
CXXXVI. GNU Readline | Domů | readline_callback_handler_install


readline_callback_handler_install

(PHP 5 >= 5.1.0)

readline_callback_handler_install — Initializes the readline callback interface and terminal, prints the prompt and returns immediately

Popis

bool readline_callback_handler_install ( string $prompt, callback $callback )

Sets up a readline callback interface then prints prompt and immediately returns. Calling this function twice without removing the previous callback interface will automatically and conveniently overwrite the old interface.

The callback feature is useful when combined with stream_select() as it allows interleaving of IO and user input, unlike readline().

Seznam parametrů

prompt

The prompt message.

callback

The callback function takes one parameter; the user input returned.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1853. Readline Callback Interface Example

<?php
function rl_callback($ret)
{
    global $c, $prompting;

    echo "You entered: $ret\n";
    $c++;

    if ($c > 10) {
        $prompting = false;
        readline_callback_handler_remove();
    } else {
        readline_callback_handler_install("[$c] Enter something: ", 'rl_callback');
    }
}

$c = 1;
$prompting = true;

readline_callback_handler_install("[$c] Enter something: ", 'rl_callback');

while ($prompting) {
    $w = NULL;
    $e = NULL;
    $n = stream_select($r = array(STDIN), $w, $e, null);
    if ($n && in_array(STDIN, $r)) {
        // read a character, will call the callback when a newline is entered
        readline_callback_read_char();
    }
}

echo "Prompting disabled. All done.\n";
?>

Viz také

readline_callback_handler_remove()
readline_callback_read_char()
stream_select()

Předcházející | Nahoru | Další
readline_add_history | Domů | readline_callback_handler_remove


readline_callback_handler_remove

(PHP 5 >= 5.1.0)

readline_callback_handler_remove — Removes a previously installed callback handler and restores terminal settings

Popis

bool readline_callback_handler_remove ( void )

Removes a previously installed callback handler and restores terminal settings.

Návratové hodnoty

Returns TRUE if a previously installed callback handler was removed, or FALSE if one could not be found.

Příklady

See readline_callback_handler_install() for an example of how to use the readline callback interface.

Viz také

readline_callback_handler_install()
readline_callback_read_char()

Předcházející | Nahoru | Další
readline_callback_handler_install | Domů | readline_callback_read_char


readline_callback_read_char

(PHP 5 >= 5.1.0)

readline_callback_read_char — Reads a character and informs the readline callback interface when a line is received

Popis

void readline_callback_read_char ( void )

Reads a character of user input. When a line is received, this function informs the readline callback interface installed using readline_callback_handler_install() that a line is ready for input.

Návratové hodnoty

Nevrací se žádná hodnota.

Příklady

See readline_callback_handler_install() for an example of how to use the readline callback interface.

Viz také

readline_callback_handler_install()
readline_callback_handler_remove()

Předcházející | Nahoru | Další
readline_callback_handler_remove | Domů | readline_clear_history


readline_clear_history

(PHP 4, PHP 5)

readline_clear_history — Smazat historii

Popis

bool readline_clear_history ( void )

Tato funkce smaže celou historii příkazové řádky.

Předcházející | Nahoru | Další
readline_callback_read_char | Domů | readline_completion_function


readline_completion_function

(PHP 4, PHP 5)

readline_completion_function — Zaregistrovat dokončující funkci

Popis

bool readline_completion_function ( callback $function )

Tato funkce zaregistruje dokončující funkci. Musíte zadat název existující funkce, která přijímá částečný příkaz a vrací pole možných protějšků. Toto je stejná funkcionalita jakou dostanete, pokud v Bashi zmáčknete klávesu tab.

Předcházející | Nahoru | Další
readline_clear_history | Domů | readline_info


readline_info

(PHP 4, PHP 5)

readline_info — Zjistit/nastavit různé interní proměnné readline

Popis

mixed readline_info ( [string $varname [, string $newvalue]] )

Při volání bez argumentů tato funkce vrátí pole hodnot pro všechna nastavení, která readline používá. Prvky jsou indexovány podle následujících hodnot: done, end, erase_empty_line, library_version, line_buffer, mark, pending_input, point, prompt, readline_name a terminal_name.

Při volání s jedním argumentem vrátí hodnotu tohoto nastavení. Při volání se dvěma argumenty se nastavení zmení na danou hodnotu.

Předcházející | Nahoru | Další
readline_completion_function | Domů | readline_list_history


readline_list_history

(PHP 4, PHP 5)

readline_list_history — Vypsat historii

Popis

array readline_list_history ( void )

Tato funkce vrátí pole celé historie příkazové řádky. Prvky jsou indexovány integery, počínaje nulou.

Předcházející | Nahoru | Další
readline_info | Domů | readline_on_new_line


readline_on_new_line

(PHP 5 >= 5.1.0)

readline_on_new_line — Inform readline that the cursor has moved to a new line

Popis

void readline_on_new_line ( void )

Tells readline that the cursor has moved to a new line.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
readline_list_history | Domů | readline_read_history


readline_read_history

(PHP 4, PHP 5)

readline_read_history — Vrátit historii

Popis

bool readline_read_history ( [string $filename] )

Tato funkce přečte historii příkazové řádky ze souboru.

Předcházející | Nahoru | Další
readline_on_new_line | Domů | readline_redisplay


readline_redisplay

(PHP 5 >= 5.1.0)

readline_redisplay — Redraws the display

Popis

void readline_redisplay ( void )

Redraws readline to redraw the display.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
readline_read_history | Domů | readline_write_history


readline_write_history

(PHP 4, PHP 5)

readline_write_history — Zapsat historii

Popis

bool readline_write_history ( [string $filename] )

Tato funkce zapíše historii příkazové řádky do souboru.

Předcházející | Nahoru | Další
readline_redisplay | Domů | readline


readline

(PHP 4, PHP 5)

readline — Přečíst řádek

Popis

string readline ( string $prompt )

Tato funkce vrátí jeden řádek od uživatele. Můžete specifikovat řetězec, který se má uživateli zobrazit jako výzva. Z vráceného řádku je odstraněna sekvence konce řádku. Do historie tento řádek musíte přidat sami pomocí readline_add_history().

Příklad 1854. readline()

//ziska 3 prikazy uzivatele
for ($i=0; $i < 3; $i++) {
        $line = readline ("Command: ");
        readline_add_history ($line);
}

//vypise historii
print_r (readline_list_history());

//vypise promenne
print_r (readline_info());

Předcházející | Nahoru | Další
readline_write_history | Domů | CXXXVII. GNU Recode funkce


GNU Recode funkce

Předcházející VI. Reference funkcí Další

CXXXVII. GNU Recode funkce

Úvod

Tento modul obsahuje rozhraní ke GNU Recode knihovně, verze 3.5. GNU Recode knihovna konvertuje soubory mezi různými znakovými sadami a kódováními. Když nelze dosáhnout přesné konverze, může se uchýlit k aproximacím. Tato knihovna rozeznává nebo produkuje téměř 150 různých znakových sad, a je schopná konvertovat soubory mezi téměř libovolným párem. Podporuje většinu znakových sad z » RFC 1345.

Poznámka: Toto rozšíření není k dispozici na platformách Windows.

Požadavky

Na svém systému musíte mít nainstalovanou GNU Recode 3.nebo vyšší. Balíček lze stáhnout z » http://directory.fsf.org/All_GNU_Packages/recode.html.

Instalace

Pokud cchete používat funkce definované v tomto modulu, musíte zkompilovat váš PHP interpretr s volbou --with-recode[=DIR].

Varování

Padání a problémy při startu PHP mohou být zaznamenány když nahráváte rozšíření Recode po nahrání rozšíření mysql nebo imap. Nahrání Recode před těmito rozšířeními problém vyřeší. Je to kvůli technickému problému spočívajícímu v tom, že obě C-knihovny používané knihovnou imap a recode mají svou vlastní funkci hash_lookup() a obě knihovny používané mysql a recode mají svou vlastní funkci hash_insert.

Varování

Rozšíření IMAP, recode, YAZ a Cyrus nelze používat současně, protože sdílejí stejný interní symbol.

Konfigurace běhu

Toto rozšíření nemá definováno žádné konfigurační direktivy.

Typy prostředků

Toto rozšíření nemá definován žádný typ prostředku (resource).

Předdefinované konstanty

Toto rozšíření nemá definovány žádné konstanty.

Obsah

recode_file — Překóduje soubor na soubor podle požadavku
recode_string — Překóduje řetězec podle požadavku
recode — Překóduje řetězec podle požadavku
Předcházející | Nahoru | Další
readline | Domů | recode_file


recode_file

(PHP 4, PHP 5)

recode_file — Překóduje soubor na soubor podle požadavku

Popis

bool recode_file ( string $request, resource $input, resource $output )

Překóduje soubor odkazovaný deskriptorem input do souboru odkazovaném deskriptorem output podle požadavku request. Pokud se nepodařilo požadavek provést, vrací FALSE, jinak TRUE.

Tato funkce v současnosti nezpracovává deskriptory odkazující na vzdálené soubory (URL). Oba deskriptory musí ukazovat na místní soubory.

Příklad 1855. Základní příklad recode_file()

$input = fopen ('input.txt', 'r');
$output = fopen ('output.txt', 'w');
recode_file ("us..flat", $input, $output);

Předcházející | Nahoru | Další
CXXXVII. GNU Recode funkce | Domů | recode_string


recode_string

(PHP 4, PHP 5)

recode_string — Překóduje řetězec podle požadavku

Popis

string recode_string ( string $request, string $string )

Překóduje řetězec string podle požadavku request. Vrací překódovaný řetězec nebo FALSE, pokud nebylo možné provést požadavek na překódování.

Jednoduchý požadavek na překódování může být "lat1..iso646-de". Detailní instrukce k požadavkům viz GNU Recode dokumentaci u vaší instalace.

Příklad 1856. Základní recode_string() příklad:

print recode_string ("us..flat", "Následující znak má diakritické znaménko: &aacute;");

Předcházející | Nahoru | Další
recode_file | Domů | recode


recode

(PHP 4, PHP 5)

recode — Překóduje řetězec podle požadavku

Popis

string recode ( string $request, string $string )

Poznámka: Toto je alias k recode_string(). Byl přidán v PHP 4.

Předcházející | Nahoru | Další
recode_string | Domů | CXXXVIII. RPM Header Reading Funkce


Regular Expression Functions (Perl-Compatible)

Předcházející VI. Reference funkcí Další

CXX. Regular Expression Functions (Perl-Compatible)

Úvod

The syntax for patterns used in these functions closely resembles Perl. The expression should be enclosed in the delimiters, a forward slash (/), for example. Any character can be used for delimiter as long as it's not alphanumeric or backslash (\). If the delimiter character has to be used in the expression itself, it needs to be escaped by backslash. Since PHP 4.0.4, you can also use Perl-style (), {}, [], and <> matching delimiters. See Pattern Syntax for detailed explanation.

The ending delimiter may be followed by various modifiers that affect the matching. See Pattern Modifiers.

PHP also supports regular expressions using a POSIX-extended syntax using the POSIX-extended regex functions.

Poznámka: This extension maintains a global per-thread cache of compiled regular expressions (up to 4096).

Varování

You should be aware of some limitations of PCRE. Read » http://www.pcre.org/pcre.txt for more info.

Požadavky

Tyto funkce jsou k dispozici jako součást standardního modulu, který je vždy dostupný.

Instalace

Beginning with PHP 4.2.0 these functions are enabled by default. You can disable the pcre functions with --without-pcre-regex. Use --with-pcre-regex=DIR to specify DIR where PCRE's include and library files are located, if not using bundled library. For older versions you have to configure and compile PHP with --with-pcre-regex[=DIR] in order to use these functions.

Verze PHP pro Windows má vestavěnou podporu pro toto rozšíření. K použití těchto funkcí není třeba načítat žádná další rozšíření.

Konfigurace běhu

Chování těchto funkcí je ovlivněno nastavením parametrů v php.ini.

Tabulka 233. PCRE Configuration Options

Name | Default | Changeable | Changelog
pcre.backtrack_limit | "100000" | PHP_INI_ALL | Available since PHP 5.2.0.
pcre.recursion_limit | "100000" | PHP_INI_ALL | Available since PHP 5.2.0.

Pro další detaily a definice konstant PHP_INI_*, viz dokumentace k ini_set().

Zde je stručný popis konfiguračních direktiv.

pcre.backtrack_limit integer

PCRE's backtracking limit.

pcre.recursion_limit integer

PCRE's recursion limit. Please note that if you set this value to a high number you may consume all the available process stack and eventually crash PHP (due to reaching the stack size limit imposed by the Operating System).

Typy prostředků

Toto rozšíření nemá definován žádný typ prostředku (resource).

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

Tabulka 234. PREG constants

constant | description
PREG_PATTERN_ORDER | Orders results so that $matches[0] is an array of full pattern matches, $matches[1] is an array of strings matched by the first parenthesized subpattern, and so on. This flag is only used with preg_match_all().
PREG_SET_ORDER | Orders results so that $matches[0] is an array of first set of matches, $matches[1] is an array of second set of matches, and so on. This flag is only used with preg_match_all().
PREG_OFFSET_CAPTURE | See the description of PREG_SPLIT_OFFSET_CAPTURE. This flag is available since PHP 4.3.0.
PREG_SPLIT_NO_EMPTY | This flag tells preg_split() to return only non-empty pieces.
PREG_SPLIT_DELIM_CAPTURE | This flag tells preg_split() to capture parenthesized expression in the delimiter pattern as well. This flag is available since PHP 4.0.5.
PREG_SPLIT_OFFSET_CAPTURE | If this flag is set, for every occurring match the appendant string offset will also be returned. Note that this changes the return values in an array where every element is an array consisting of the matched string at offset 0 and its string offset within subject at offset 1. This flag is available since PHP 4.3.0 and is only used for preg_split().
PREG_NO_ERROR | Returned by preg_last_error() if there were no errors. Available since PHP 5.2.0.
PREG_INTERNAL_ERROR | Returned by preg_last_error() if there was an internal PCRE error. Available since PHP 5.2.0.
PREG_BACKTRACK_LIMIT_ERROR | Returned by preg_last_error() if backtrack limit was exhausted. Available since PHP 5.2.0.
PREG_RECURSION_LIMIT_ERROR | Returned by preg_last_error() if recursion limit was exhausted. Available since PHP 5.2.0.
PREG_BAD_UTF8_ERROR | Returned by preg_last_error() if the last error was caused by malformed UTF-8 data (only when running a regex in UTF-8 mode). Available since PHP 5.2.0.
PCRE_VERSION | PCRE version and release date (e.g. "7.0 18-Dec-2006"). Available since PHP 5.2.4.

Příklady

Příklad 1515. Examples of valid patterns

  • /<\/\w+>/
  • |(\d{3})-\d+|Sm
  • /^(?i)php[34]/
  • {^\s+(\s+)?$}

Příklad 1516. Examples of invalid patterns

  • /href='(.*)' - missing ending delimiter
  • /\w+\s*\w+/J - unknown modifier 'J'
  • 1-\d3-\d3-\d4| - missing starting delimiter

Obsah

Pattern Modifiers — Describes possible modifiers in regex patterns
Pattern Syntax — Describes PCRE regex syntax
preg_grep — Return array entries that match the pattern
preg_last_error — Returns the error code of the last PCRE regex execution
preg_match_all — Perform a global regular expression match
preg_match — Perform a regular expression match
preg_quote — Quote regular expression characters
preg_replace_callback — Perform a regular expression search and replace using a callback
preg_replace — Perform a regular expression search and replace
preg_split — Split string by a regular expression
Předcházející | Nahoru | Další
pcntl_wtermsig | Domů | Pattern Modifiers


Pattern Modifiers

(No version information available, might be only in CVS)

Pattern Modifiers — Describes possible modifiers in regex patterns

Description

The current possible PCRE modifiers are listed below. The names in parentheses refer to internal PCRE names for these modifiers. Spaces and newlines are ignored in modifiers, other characters cause error.

i (PCRE_CASELESS)
If this modifier is set, letters in the pattern match both upper and lower case letters.
m (PCRE_MULTILINE)

By default, PCRE treats the subject string as consisting of a single "line" of characters (even if it actually contains several newlines). The "start of line" metacharacter (^) matches only at the start of the string, while the "end of line" metacharacter ($) matches only at the end of the string, or before a terminating newline (unless D modifier is set). This is the same as Perl.

When this modifier is set, the "start of line" and "end of line" constructs match immediately following or immediately before any newline in the subject string, respectively, as well as at the very start and end. This is equivalent to Perl's /m modifier. If there are no "\n" characters in a subject string, or no occurrences of ^ or $ in a pattern, setting this modifier has no effect.

s (PCRE_DOTALL)
If this modifier is set, a dot metacharacter in the pattern matches all characters, including newlines. Without it, newlines are excluded. This modifier is equivalent to Perl's /s modifier. A negative class such as [^a] always matches a newline character, independent of the setting of this modifier.
x (PCRE_EXTENDED)
If this modifier is set, whitespace data characters in the pattern are totally ignored except when escaped or inside a character class, and characters between an unescaped # outside a character class and the next newline character, inclusive, are also ignored. This is equivalent to Perl's /x modifier, and makes it possible to include comments inside complicated patterns. Note, however, that this applies only to data characters. Whitespace characters may never appear within special character sequences in a pattern, for example within the sequence (?( which introduces a conditional subpattern.
e (PREG_REPLACE_EVAL)

If this modifier is set, preg_replace() does normal substitution of backreferences in the replacement string, evaluates it as PHP code, and uses the result for replacing the search string. Single quotes, double quotes, backslashes and NULL chars will be escaped by backslashes in substituted backreferences.

Only preg_replace() uses this modifier; it is ignored by other PCRE functions.

Poznámka: This modifier was not available in PHP 3.

A (PCRE_ANCHORED)
If this modifier is set, the pattern is forced to be "anchored", that is, it is constrained to match only at the start of the string which is being searched (the "subject string"). This effect can also be achieved by appropriate constructs in the pattern itself, which is the only way to do it in Perl.
D (PCRE_DOLLAR_ENDONLY)
If this modifier is set, a dollar metacharacter in the pattern matches only at the end of the subject string. Without this modifier, a dollar also matches immediately before the final character if it is a newline (but not before any other newlines). This modifier is ignored if m modifier is set. There is no equivalent to this modifier in Perl.
S
When a pattern is going to be used several times, it is worth spending more time analyzing it in order to speed up the time taken for matching. If this modifier is set, then this extra analysis is performed. At present, studying a pattern is useful only for non-anchored patterns that do not have a single fixed starting character.
U (PCRE_UNGREEDY)
This modifier inverts the "greediness" of the quantifiers so that they are not greedy by default, but become greedy if followed by "?". It is not compatible with Perl. It can also be set by a (?U) modifier setting within the pattern or by a question mark behind a quantifier (e.g. .*?).
X (PCRE_EXTRA)
This modifier turns on additional functionality of PCRE that is incompatible with Perl. Any backslash in a pattern that is followed by a letter that has no special meaning causes an error, thus reserving these combinations for future expansion. By default, as in Perl, a backslash followed by a letter with no special meaning is treated as a literal. There are at present no other features controlled by this modifier.
u (PCRE_UTF8)
This modifier turns on additional functionality of PCRE that is incompatible with Perl. Pattern strings are treated as UTF-8. This modifier is available from PHP 4.1.0 or greater on Unix and from PHP 4.2.3 on win32. UTF-8 validity of the pattern is checked since PHP 4.3.5.

Předcházející | Nahoru | Další
CXX. Regular Expression Functions (Perl-Compatible) | Domů | Pattern Syntax


Pattern Syntax

(No version information available, might be only in CVS)

Pattern Syntax — Describes PCRE regex syntax

Description

The PCRE library is a set of functions that implement regular expression pattern matching using the same syntax and semantics as Perl 5, with just a few differences (see below). The current implementation corresponds to Perl 5.005.

Differences From Perl

The differences described here are with respect to Perl 5.005.

  1. By default, a whitespace character is any character that the C library function isspace() recognizes, though it is possible to compile PCRE with alternative character type tables. Normally isspace() matches space, formfeed, newline, carriage return, horizontal tab, and vertical tab. Perl 5 no longer includes vertical tab in its set of whitespace characters. The \v escape that was in the Perl documentation for a long time was never in fact recognized. However, the character itself was treated as whitespace at least up to 5.002. In 5.004 and 5.005 it does not match \s.
  2. PCRE does not allow repeat quantifiers on lookahead assertions. Perl permits them, but they do not mean what you might think. For example, (?!a){3} does not assert that the next three characters are not "a". It just asserts that the next character is not "a" three times.
  3. Capturing subpatterns that occur inside negative lookahead assertions are counted, but their entries in the offsets vector are never set. Perl sets its numerical variables from any such patterns that are matched before the assertion fails to match something (thereby succeeding), but only if the negative lookahead assertion contains just one branch.
  4. Though binary zero characters are supported in the subject string, they are not allowed in a pattern string because it is passed as a normal C string, terminated by zero. The escape sequence "\x00" can be used in the pattern to represent a binary zero.
  5. The following Perl escape sequences are not supported: \l, \u, \L, \U. In fact these are implemented by Perl's general string-handling and are not part of its pattern matching engine.
  6. The Perl \G assertion is not supported as it is not relevant to single pattern matches.
  7. Fairly obviously, PCRE does not support the (?{code}) construction.
  8. There are at the time of writing some oddities in Perl 5.005_02 concerned with the settings of captured strings when part of a pattern is repeated. For example, matching "aba" against the pattern /^(a(b)?)+$/ sets $2 to the value "b", but matching "aabbaa" against /^(aa(bb)?)+$/ leaves $2 unset. However, if the pattern is changed to /^(aa(b(b))?)+$/ then $2 (and $3) get set. In Perl 5.004 $2 is set in both cases, and that is also TRUE of PCRE. If in the future Perl changes to a consistent state that is different, PCRE may change to follow.
  9. Another as yet unresolved discrepancy is that in Perl 5.005_02 the pattern /^(a)?(?(1)a|b)+$/ matches the string "a", whereas in PCRE it does not. However, in both Perl and PCRE /^(a)?a/ matched against "a" leaves $1 unset.

  10. PCRE provides some extensions to the Perl regular expression facilities:

    1. Although lookbehind assertions must match fixed length strings, each alternative branch of a lookbehind assertion can match a different length of string. Perl 5.005 requires them all to have the same length.
    2. If PCRE_DOLLAR_ENDONLY is set and PCRE_MULTILINE is not set, the $ meta-character matches only at the very end of the string.
    3. If PCRE_EXTRA is set, a backslash followed by a letter with no special meaning is faulted.
    4. If PCRE_UNGREEDY is set, the greediness of the repetition quantifiers is inverted, that is, by default they are not greedy, but if followed by a question mark they are.

Regular Expression Details

Introduction

The syntax and semantics of the regular expressions supported by PCRE are described below. Regular expressions are also described in the Perl documentation and in a number of other books, some of which have copious examples. Jeffrey Friedl's "Mastering Regular Expressions", published by O'Reilly (ISBN 1-56592-257-3), covers them in great detail. The description here is intended as reference documentation.

A regular expression is a pattern that is matched against a subject string from left to right. Most characters stand for themselves in a pattern, and match the corresponding characters in the subject. As a trivial example, the pattern The quick brown fox matches a portion of a subject string that is identical to itself.

Meta-characters

The power of regular expressions comes from the ability to include alternatives and repetitions in the pattern. These are encoded in the pattern by the use of meta-characters, which do not stand for themselves but instead are interpreted in some special way.

There are two different sets of meta-characters: those that are recognized anywhere in the pattern except within square brackets, and those that are recognized in square brackets. Outside square brackets, the meta-characters are as follows:

\
general escape character with several uses
^
assert start of subject (or line, in multiline mode)
$
assert end of subject (or line, in multiline mode)
.
match any character except newline (by default)
[
start character class definition
]
end character class definition
|
start of alternative branch
(
start subpattern
)
end subpattern
?
extends the meaning of (, also 0 or 1 quantifier, also quantifier minimizer
*
0 or more quantifier
+
1 or more quantifier
{
start min/max quantifier
}
end min/max quantifier
Part of a pattern that is in square brackets is called a "character class". In a character class the only meta-characters are:
\
general escape character
^
negate the class, but only if the first character
-
indicates character range
]
terminates the character class
The following sections describe the use of each of the meta-characters.

Backslash

The backslash character has several uses. Firstly, if it is followed by a non-alphanumeric character, it takes away any special meaning that character may have. This use of backslash as an escape character applies both inside and outside character classes.

For example, if you want to match a "*" character, you write "\*" in the pattern. This applies whether or not the following character would otherwise be interpreted as a meta-character, so it is always safe to precede a non-alphanumeric with "\" to specify that it stands for itself. In particular, if you want to match a backslash, you write "\\".

Poznámka: Single and double quoted PHP strings have special meaning of backslash. Thus if \ has to be matched with a regular expression \\, then "\\\\" or '\\\\' must be used in PHP code.

If a pattern is compiled with the PCRE_EXTENDED option, whitespace in the pattern (other than in a character class) and characters between a "#" outside a character class and the next newline character are ignored. An escaping backslash can be used to include a whitespace or "#" character as part of the pattern.

A second use of backslash provides a way of encoding non-printing characters in patterns in a visible manner. There is no restriction on the appearance of non-printing characters, apart from the binary zero that terminates a pattern, but when a pattern is being prepared by text editing, it is usually easier to use one of the following escape sequences than the binary character it represents:

\a
alarm, that is, the BEL character (hex 07)
\cx
"control-x", where x is any character
\e
escape (hex 1B)
\f
formfeed (hex 0C)
\n
newline (hex 0A)
\r
carriage return (hex 0D)
\t
tab (hex 09)
\xhh
character with hex code hh
\ddd
character with octal code ddd, or backreference

The precise effect of "\cx" is as follows: if "x" is a lower case letter, it is converted to upper case. Then bit 6 of the character (hex 40) is inverted. Thus "\cz" becomes hex 1A, but "\c{" becomes hex 3B, while "\c;" becomes hex 7B.

After "\x", up to two hexadecimal digits are read (letters can be in upper or lower case). In UTF-8 mode, "\x{...}" is allowed, where the contents of the braces is a string of hexadecimal digits. It is interpreted as a UTF-8 character whose code number is the given hexadecimal number. The original hexadecimal escape sequence, \xhh, matches a two-byte UTF-8 character if the value is greater than 127.

After "\0" up to two further octal digits are read. In both cases, if there are fewer than two digits, just those that are present are used. Thus the sequence "\0\x\07" specifies two binary zeros followed by a BEL character. Make sure you supply two digits after the initial zero if the character that follows is itself an octal digit.

The handling of a backslash followed by a digit other than 0 is complicated. Outside a character class, PCRE reads it and any following digits as a decimal number. If the number is less than 10, or if there have been at least that many previous capturing left parentheses in the expression, the entire sequence is taken as a back reference. A description of how this works is given later, following the discussion of parenthesized subpatterns.

Inside a character class, or if the decimal number is greater than 9 and there have not been that many capturing subpatterns, PCRE re-reads up to three octal digits following the backslash, and generates a single byte from the least significant 8 bits of the value. Any subsequent digits stand for themselves. For example:

\040
is another way of writing a space
\40
is the same, provided there are fewer than 40 previous capturing subpatterns
\7
is always a back reference
\11
might be a back reference, or another way of writing a tab
\011
is always a tab
\0113
is a tab followed by the character "3"
\113
is the character with octal code 113 (since there can be no more than 99 back references)
\377
is a byte consisting entirely of 1 bits
\81
is either a back reference, or a binary zero followed by the two characters "8" and "1"

Note that octal values of 100 or greater must not be introduced by a leading zero, because no more than three octal digits are ever read.

All the sequences that define a single byte value can be used both inside and outside character classes. In addition, inside a character class, the sequence "\b" is interpreted as the backspace character (hex 08). Outside a character class it has a different meaning (see below).

The third use of backslash is for specifying generic character types:

\d
any decimal digit
\D
any character that is not a decimal digit
\h
any horizontal whitespace character (since PHP 5.2.4)
\H
any character that is not a horizontal whitespace character (since PHP 5.2.4)
\s
any whitespace character
\S
any character that is not a whitespace character
\v
any vertical whitespace character (since PHP 5.2.4)
\V
any character that is not a vertical whitespace character (since PHP 5.2.4)
\w
any "word" character
\W
any "non-word" character

Each pair of escape sequences partitions the complete set of characters into two disjoint sets. Any given character matches one, and only one, of each pair.

A "word" character is any letter or digit or the underscore character, that is, any character which can be part of a Perl "word". The definition of letters and digits is controlled by PCRE's character tables, and may vary if locale-specific matching is taking place. For example, in the "fr" (French) locale, some character codes greater than 128 are used for accented letters, and these are matched by \w.

These character type sequences can appear both inside and outside character classes. They each match one character of the appropriate type. If the current matching point is at the end of the subject string, all of them fail, since there is no character to match.

The fourth use of backslash is for certain simple assertions. An assertion specifies a condition that has to be met at a particular point in a match, without consuming any characters from the subject string. The use of subpatterns for more complicated assertions is described below. The backslashed assertions are

\b
word boundary
\B
not a word boundary
\A
start of subject (independent of multiline mode)
\Z
end of subject or newline at end (independent of multiline mode)
\z
end of subject (independent of multiline mode)
\G
first matching position in subject

These assertions may not appear in character classes (but note that "\b" has a different meaning, namely the backspace character, inside a character class).

A word boundary is a position in the subject string where the current character and the previous character do not both match \w or \W (i.e. one matches \w and the other matches \W), or the start or end of the string if the first or last character matches \w, respectively.

The \A, \Z, and \z assertions differ from the traditional circumflex and dollar (described below) in that they only ever match at the very start and end of the subject string, whatever options are set. They are not affected by the PCRE_MULTILINE or PCRE_DOLLAR_ENDONLY options. The difference between \Z and \z is that \Z matches before a newline that is the last character of the string as well as at the end of the string, whereas \z matches only at the end.

The \G assertion is true only when the current matching position is at the start point of the match, as specified by the offset argument of preg_match(). It differs from \A when the value of offset is non-zero. It is available since PHP 4.3.3.

\Q and \E can be used to ignore regexp metacharacters in the pattern since PHP 4.3.3. For example: \w+\Q.$.\E$ will match one or more word characters, followed by literals .$. and anchored at the end of the string.

\K can be used to reset the match start since PHP 5.2.4. For example, the pattern foo\Kbar matches "foobar", but reports that it has matched "bar". The use of \K does not interfere with the setting of captured substrings. For example, when the pattern (foo)\Kbar matches "foobar", the first substring is still set to "foo".

Unicode character properties

Since PHP 4.4.0 and 5.1.0, three additional escape sequences to match generic character types are available when UTF-8 mode is selected. They are:

\p{xx}
a character with the xx property
\P{xx}
a character without the xx property
\X
an extended Unicode sequence

The property names represented by xx above are limited to the Unicode general category properties. Each character has exactly one such property, specified by a two-letter abbreviation. For compatibility with Perl, negation can be specified by including a circumflex between the opening brace and the property name. For example, \p{^Lu} is the same as \P{Lu}.

If only one letter is specified with \p or \P, it includes all the properties that start with that letter. In this case, in the absence of negation, the curly brackets in the escape sequence are optional; these two examples have the same effect:

\p{L}
\pL

Tabulka 235. Supported property codes

C | Other
Cc | Control
Cf | Format
Cn | Unassigned
Co | Private use
Cs | Surrogate
L | Letter
Ll | Lower case letter
Lm | Modifier letter
Lo | Other letter
Lt | Title case letter
Lu | Upper case letter
M | Mark
Mc | Spacing mark
Me | Enclosing mark
Mn | Non-spacing mark
N | Number
Nd | Decimal number
Nl | Letter number
No | Other number
P | Punctuation
Pc | Connector punctuation
Pd | Dash punctuation
Pe | Close punctuation
Pf | Final punctuation
Pi | Initial punctuation
Po | Other punctuation
Ps | Open punctuation
S | Symbol
Sc | Currency symbol
Sk | Modifier symbol
Sm | Mathematical symbol
So | Other symbol
Z | Separator
Zl | Line separator
Zp | Paragraph separator
Zs | Space separator

Extended properties such as "Greek" or "InMusicalSymbols" are not supported by PCRE.

Specifying caseless matching does not affect these escape sequences. For example, \p{Lu} always matches only upper case letters.

The \X escape matches any number of Unicode characters that form an extended Unicode sequence. \X is equivalent to (?>\PM\pM*).

That is, it matches a character without the "mark" property, followed by zero or more characters with the "mark" property, and treats the sequence as an atomic group (see below). Characters with the "mark" property are typically accents that affect the preceding character.

Matching characters by Unicode property is not fast, because PCRE has to search a structure that contains data for over fifteen thousand characters. That is why the traditional escape sequences such as \d and \w do not use Unicode properties in PCRE.

Circumflex and dollar

Outside a character class, in the default matching mode, the circumflex character is an assertion which is true only if the current matching point is at the start of the subject string. Inside a character class, circumflex has an entirely different meaning (see below).

Circumflex need not be the first character of the pattern if a number of alternatives are involved, but it should be the first thing in each alternative in which it appears if the pattern is ever to match that branch. If all possible alternatives start with a circumflex, that is, if the pattern is constrained to match only at the start of the subject, it is said to be an "anchored" pattern. (There are also other constructs that can cause a pattern to be anchored.)

A dollar character is an assertion which is TRUE only if the current matching point is at the end of the subject string, or immediately before a newline character that is the last character in the string (by default). Dollar need not be the last character of the pattern if a number of alternatives are involved, but it should be the last item in any branch in which it appears. Dollar has no special meaning in a character class.

The meaning of dollar can be changed so that it matches only at the very end of the string, by setting the PCRE_DOLLAR_ENDONLY option at compile or matching time. This does not affect the \Z assertion.

The meanings of the circumflex and dollar characters are changed if the PCRE_MULTILINE option is set. When this is the case, they match immediately after and immediately before an internal "\n" character, respectively, in addition to matching at the start and end of the subject string. For example, the pattern /^abc$/ matches the subject string "def\nabc" in multiline mode, but not otherwise. Consequently, patterns that are anchored in single line mode because all branches start with "^" are not anchored in multiline mode. The PCRE_DOLLAR_ENDONLY option is ignored if PCRE_MULTILINE is set.

Note that the sequences \A, \Z, and \z can be used to match the start and end of the subject in both modes, and if all branches of a pattern start with \A is it always anchored, whether PCRE_MULTILINE is set or not.

Full stop

Outside a character class, a dot in the pattern matches any one character in the subject, including a non-printing character, but not (by default) newline. If the PCRE_DOTALL option is set, then dots match newlines as well. The handling of dot is entirely independent of the handling of circumflex and dollar, the only relationship being that they both involve newline characters. Dot has no special meaning in a character class.

\C can be used to match single byte. It makes sense in UTF-8 mode where full stop matches the whole character which can consist of multiple bytes.

Square brackets

An opening square bracket introduces a character class, terminated by a closing square bracket. A closing square bracket on its own is not special. If a closing square bracket is required as a member of the class, it should be the first data character in the class (after an initial circumflex, if present) or escaped with a backslash.

A character class matches a single character in the subject; the character must be in the set of characters defined by the class, unless the first character in the class is a circumflex, in which case the subject character must not be in the set defined by the class. If a circumflex is actually required as a member of the class, ensure it is not the first character, or escape it with a backslash.

For example, the character class [aeiou] matches any lower case vowel, while [^aeiou] matches any character that is not a lower case vowel. Note that a circumflex is just a convenient notation for specifying the characters which are in the class by enumerating those that are not. It is not an assertion: it still consumes a character from the subject string, and fails if the current pointer is at the end of the string.

When caseless matching is set, any letters in a class represent both their upper case and lower case versions, so for example, a caseless [aeiou] matches "A" as well as "a", and a caseless [^aeiou] does not match "A", whereas a caseful version would.

The newline character is never treated in any special way in character classes, whatever the setting of the PCRE_DOTALL or PCRE_MULTILINE options is. A class such as [^a] will always match a newline.

The minus (hyphen) character can be used to specify a range of characters in a character class. For example, [d-m] matches any letter between d and m, inclusive. If a minus character is required in a class, it must be escaped with a backslash or appear in a position where it cannot be interpreted as indicating a range, typically as the first or last character in the class.

It is not possible to have the literal character "]" as the end character of a range. A pattern such as [W-]46] is interpreted as a class of two characters ("W" and "-") followed by a literal string "46]", so it would match "W46]" or "-46]". However, if the "]" is escaped with a backslash it is interpreted as the end of range, so [W-\]46] is interpreted as a single class containing a range followed by two separate characters. The octal or hexadecimal representation of "]" can also be used to end a range.

Ranges operate in ASCII collating sequence. They can also be used for characters specified numerically, for example [\000-\037]. If a range that includes letters is used when caseless matching is set, it matches the letters in either case. For example, [W-c] is equivalent to [][\^_`wxyzabc], matched caselessly, and if character tables for the "fr" locale are in use, [\xc8-\xcb] matches accented E characters in both cases.

The character types \d, \D, \s, \S, \w, and \W may also appear in a character class, and add the characters that they match to the class. For example, [\dABCDEF] matches any hexadecimal digit. A circumflex can conveniently be used with the upper case character types to specify a more restricted set of characters than the matching lower case type. For example, the class [^\W_] matches any letter or digit, but not underscore.

All non-alphanumeric characters other than \, -, ^ (at the start) and the terminating ] are non-special in character classes, but it does no harm if they are escaped.

Vertical bar

Vertical bar characters are used to separate alternative patterns. For example, the pattern gilbert|sullivan matches either "gilbert" or "sullivan". Any number of alternatives may appear, and an empty alternative is permitted (matching the empty string). The matching process tries each alternative in turn, from left to right, and the first one that succeeds is used. If the alternatives are within a subpattern (defined below), "succeeds" means matching the rest of the main pattern as well as the alternative in the subpattern.

Internal option setting

The settings of PCRE_CASELESS, PCRE_MULTILINE, PCRE_DOTALL, PCRE_UNGREEDY, PCRE_EXTRA, and PCRE_EXTENDED can be changed from within the pattern by a sequence of Perl option letters enclosed between "(?" and ")". The option letters are:

Tabulka 236. Internal option letters

i | for PCRE_CASELESS
m | for PCRE_MULTILINE
s | for PCRE_DOTALL
x | for PCRE_EXTENDED
U | for PCRE_UNGREEDY
X | for PCRE_EXTRA

For example, (?im) sets caseless, multiline matching. It is also possible to unset these options by preceding the letter with a hyphen, and a combined setting and unsetting such as (?im-sx), which sets PCRE_CASELESS and PCRE_MULTILINE while unsetting PCRE_DOTALL and PCRE_EXTENDED, is also permitted. If a letter appears both before and after the hyphen, the option is unset.

When an option change occurs at top level (that is, not inside subpattern parentheses), the change applies to the remainder of the pattern that follows. So /ab(?i)c/ matches only "abc" and "abC". This behaviour has been changed in PCRE 4.0, which is bundled since PHP 4.3.3. Before those versions, /ab(?i)c/ would perform as /abc/i (e.g. matching "ABC" and "aBc").

If an option change occurs inside a subpattern, the effect is different. This is a change of behaviour in Perl 5.005. An option change inside a subpattern affects only that part of the subpattern that follows it, so (a(?i)b)c matches abc and aBc and no other strings (assuming PCRE_CASELESS is not used). By this means, options can be made to have different settings in different parts of the pattern. Any changes made in one alternative do carry on into subsequent branches within the same subpattern. For example, (a(?i)b|c) matches "ab", "aB", "c", and "C", even though when matching "C" the first branch is abandoned before the option setting. This is because the effects of option settings happen at compile time. There would be some very weird behaviour otherwise.

The PCRE-specific options PCRE_UNGREEDY and PCRE_EXTRA can be changed in the same way as the Perl-compatible options by using the characters U and X respectively. The (?X) flag setting is special in that it must always occur earlier in the pattern than any of the additional features it turns on, even when it is at top level. It is best put at the start.

Subpatterns

Subpatterns are delimited by parentheses (round brackets), which can be nested. Marking part of a pattern as a subpattern does two things:

1. It localizes a set of alternatives. For example, the pattern cat(aract|erpillar|) matches one of the words "cat", "cataract", or "caterpillar". Without the parentheses, it would match "cataract", "erpillar" or the empty string.

2. It sets up the subpattern as a capturing subpattern (as defined above). When the whole pattern matches, that portion of the subject string that matched the subpattern is passed back to the caller via the ovector argument of pcre_exec(). Opening parentheses are counted from left to right (starting from 1) to obtain the numbers of the capturing subpatterns.

For example, if the string "the red king" is matched against the pattern the ((red|white) (king|queen)) the captured substrings are "red king", "red", and "king", and are numbered 1, 2, and 3.

The fact that plain parentheses fulfil two functions is not always helpful. There are often times when a grouping subpattern is required without a capturing requirement. If an opening parenthesis is followed by "?:", the subpattern does not do any capturing, and is not counted when computing the number of any subsequent capturing subpatterns. For example, if the string "the white queen" is matched against the pattern the ((?:red|white) (king|queen)) the captured substrings are "white queen" and "queen", and are numbered 1 and 2. The maximum number of captured substrings is 99, and the maximum number of all subpatterns, both capturing and non-capturing, is 200.

As a convenient shorthand, if any option settings are required at the start of a non-capturing subpattern, the option letters may appear between the "?" and the ":". Thus the two patterns

(?i:saturday|sunday)
(?:(?i)saturday|sunday)

match exactly the same set of strings. Because alternative branches are tried from left to right, and options are not reset until the end of the subpattern is reached, an option setting in one branch does affect subsequent branches, so the above patterns match "SUNDAY" as well as "Saturday".

It is possible to name the subpattern with (?P<name>pattern) since PHP 4.3.3. Array with matches will contain the match indexed by the string alongside the match indexed by a number, then.

Repetition

Repetition is specified by quantifiers, which can follow any of the following items:

  • a single character, possibly escaped
  • the . metacharacter
  • a character class
  • a back reference (see next section)
  • a parenthesized subpattern (unless it is an assertion - see below)

The general repetition quantifier specifies a minimum and maximum number of permitted matches, by giving the two numbers in curly brackets (braces), separated by a comma. The numbers must be less than 65536, and the first must be less than or equal to the second. For example: z{2,4} matches "zz", "zzz", or "zzzz". A closing brace on its own is not a special character. If the second number is omitted, but the comma is present, there is no upper limit; if the second number and the comma are both omitted, the quantifier specifies an exact number of required matches. Thus [aeiou]{3,} matches at least 3 successive vowels, but may match many more, while \d{8} matches exactly 8 digits. An opening curly bracket that appears in a position where a quantifier is not allowed, or one that does not match the syntax of a quantifier, is taken as a literal character. For example, {,6} is not a quantifier, but a literal string of four characters.

The quantifier {0} is permitted, causing the expression to behave as if the previous item and the quantifier were not present.

For convenience (and historical compatibility) the three most common quantifiers have single-character abbreviations:

Tabulka 237. Single-character quantifiers

* | equivalent to {0,}
+ | equivalent to {1,}
? | equivalent to {0,1}

It is possible to construct infinite loops by following a subpattern that can match no characters with a quantifier that has no upper limit, for example: (a?)*

Earlier versions of Perl and PCRE used to give an error at compile time for such patterns. However, because there are cases where this can be useful, such patterns are now accepted, but if any repetition of the subpattern does in fact match no characters, the loop is forcibly broken.

By default, the quantifiers are "greedy", that is, they match as much as possible (up to the maximum number of permitted times), without causing the rest of the pattern to fail. The classic example of where this gives problems is in trying to match comments in C programs. These appear between the sequences /* and */ and within the sequence, individual * and / characters may appear. An attempt to match C comments by applying the pattern /\*.*\*/ to the string /* first comment */ not comment /* second comment */ fails, because it matches the entire string due to the greediness of the .* item.

However, if a quantifier is followed by a question mark, then it ceases to be greedy, and instead matches the minimum number of times possible, so the pattern /\*.*?\*/ does the right thing with the C comments. The meaning of the various quantifiers is not otherwise changed, just the preferred number of matches. Do not confuse this use of question mark with its use as a quantifier in its own right. Because it has two uses, it can sometimes appear doubled, as in \d??\d which matches one digit by preference, but can match two if that is the only way the rest of the pattern matches.

If the PCRE_UNGREEDY option is set (an option which is not available in Perl) then the quantifiers are not greedy by default, but individual ones can be made greedy by following them with a question mark. In other words, it inverts the default behaviour.

Quantifiers followed by + are "possessive". They eat as many characters as possible and don't return to match the rest of the pattern. Thus .*abc matches "aabc" but .*+abc doesn't because .*+ eats the whole string. Possessive quantifiers can be used to speed up processing since PHP 4.3.3.

When a parenthesized subpattern is quantified with a minimum repeat count that is greater than 1 or with a limited maximum, more store is required for the compiled pattern, in proportion to the size of the minimum or maximum.

If a pattern starts with .* or .{0,} and the PCRE_DOTALL option (equivalent to Perl's /s) is set, thus allowing the . to match newlines, then the pattern is implicitly anchored, because whatever follows will be tried against every character position in the subject string, so there is no point in retrying the overall match at any position after the first. PCRE treats such a pattern as though it were preceded by \A. In cases where it is known that the subject string contains no newlines, it is worth setting PCRE_DOTALL when the pattern begins with .* in order to obtain this optimization, or alternatively using ^ to indicate anchoring explicitly.

When a capturing subpattern is repeated, the value captured is the substring that matched the final iteration. For example, after (tweedle[dume]{3}\s*)+ has matched "tweedledum tweedledee" the value of the captured substring is "tweedledee". However, if there are nested capturing subpatterns, the corresponding captured values may have been set in previous iterations. For example, after /(a|(b))+/ matches "aba" the value of the second captured substring is "b".

Back references

Outside a character class, a backslash followed by a digit greater than 0 (and possibly further digits) is a back reference to a capturing subpattern earlier (i.e. to its left) in the pattern, provided there have been that many previous capturing left parentheses.

However, if the decimal number following the backslash is less than 10, it is always taken as a back reference, and causes an error only if there are not that many capturing left parentheses in the entire pattern. In other words, the parentheses that are referenced need not be to the left of the reference for numbers less than 10. See the section entitled "Backslash" above for further details of the handling of digits following a backslash.

A back reference matches whatever actually matched the capturing subpattern in the current subject string, rather than anything matching the subpattern itself. So the pattern (sens|respons)e and \1ibility matches "sense and sensibility" and "response and responsibility", but not "sense and responsibility". If caseful matching is in force at the time of the back reference, then the case of letters is relevant. For example, ((?i)rah)\s+\1 matches "rah rah" and "RAH RAH", but not "RAH rah", even though the original capturing subpattern is matched caselessly.

There may be more than one back reference to the same subpattern. If a subpattern has not actually been used in a particular match, then any back references to it always fail. For example, the pattern (a|(bc))\2 always fails if it starts to match "a" rather than "bc". Because there may be up to 99 back references, all digits following the backslash are taken as part of a potential back reference number. If the pattern continues with a digit character, then some delimiter must be used to terminate the back reference. If the PCRE_EXTENDED option is set, this can be whitespace. Otherwise an empty comment can be used.

A back reference that occurs inside the parentheses to which it refers fails when the subpattern is first used, so, for example, (a\1) never matches. However, such references can be useful inside repeated subpatterns. For example, the pattern (a|b\1)+ matches any number of "a"s and also "aba", "ababaa" etc. At each iteration of the subpattern, the back reference matches the character string corresponding to the previous iteration. In order for this to work, the pattern must be such that the first iteration does not need to match the back reference. This can be done using alternation, as in the example above, or by a quantifier with a minimum of zero.

Back references to the named subpatterns can be achieved by (?P=name) or, since PHP 5.2.4, also by \k<name>, \k'name' or \k{name}.

Assertions

An assertion is a test on the characters following or preceding the current matching point that does not actually consume any characters. The simple assertions coded as \b, \B, \A, \Z, \z, ^ and $ are described above. More complicated assertions are coded as subpatterns. There are two kinds: those that look ahead of the current position in the subject string, and those that look behind it.

An assertion subpattern is matched in the normal way, except that it does not cause the current matching position to be changed. Lookahead assertions start with (?= for positive assertions and (?! for negative assertions. For example, \w+(?=;) matches a word followed by a semicolon, but does not include the semicolon in the match, and foo(?!bar) matches any occurrence of "foo" that is not followed by "bar". Note that the apparently similar pattern (?!foo)bar does not find an occurrence of "bar" that is preceded by something other than "foo"; it finds any occurrence of "bar" whatsoever, because the assertion (?!foo) is always TRUE when the next three characters are "bar". A lookbehind assertion is needed to achieve this effect.

Lookbehind assertions start with (?<= for positive assertions and (?<! for negative assertions. For example, (?<!foo)bar does find an occurrence of "bar" that is not preceded by "foo". The contents of a lookbehind assertion are restricted such that all the strings it matches must have a fixed length. However, if there are several alternatives, they do not all have to have the same fixed length. Thus (?<=bullock|donkey) is permitted, but (?<!dogs?|cats?) causes an error at compile time. Branches that match different length strings are permitted only at the top level of a lookbehind assertion. This is an extension compared with Perl 5.005, which requires all branches to match the same length of string. An assertion such as (?<=ab(c|de)) is not permitted, because its single top-level branch can match two different lengths, but it is acceptable if rewritten to use two top-level branches: (?<=abc|abde) The implementation of lookbehind assertions is, for each alternative, to temporarily move the current position back by the fixed width and then try to match. If there are insufficient characters before the current position, the match is deemed to fail. Lookbehinds in conjunction with once-only subpatterns can be particularly useful for matching at the ends of strings; an example is given at the end of the section on once-only subpatterns.

Several assertions (of any sort) may occur in succession. For example, (?<=\d{3})(?<!999)foo matches "foo" preceded by three digits that are not "999". Notice that each of the assertions is applied independently at the same point in the subject string. First there is a check that the previous three characters are all digits, then there is a check that the same three characters are not "999". This pattern does not match "foo" preceded by six characters, the first of which are digits and the last three of which are not "999". For example, it doesn't match "123abcfoo". A pattern to do that is (?<=\d{3}...)(?<!999)foo

This time the first assertion looks at the preceding six characters, checking that the first three are digits, and then the second assertion checks that the preceding three characters are not "999".

Assertions can be nested in any combination. For example, (?<=(?<!foo)bar)baz matches an occurrence of "baz" that is preceded by "bar" which in turn is not preceded by "foo", while (?<=\d{3}...(?<!999))foo is another pattern which matches "foo" preceded by three digits and any three characters that are not "999".

Assertion subpatterns are not capturing subpatterns, and may not be repeated, because it makes no sense to assert the same thing several times. If any kind of assertion contains capturing subpatterns within it, these are counted for the purposes of numbering the capturing subpatterns in the whole pattern. However, substring capturing is carried out only for positive assertions, because it does not make sense for negative assertions.

Assertions count towards the maximum of 200 parenthesized subpatterns.

Once-only subpatterns

With both maximizing and minimizing repetition, failure of what follows normally causes the repeated item to be re-evaluated to see if a different number of repeats allows the rest of the pattern to match. Sometimes it is useful to prevent this, either to change the nature of the match, or to cause it fail earlier than it otherwise might, when the author of the pattern knows there is no point in carrying on.

Consider, for example, the pattern \d+foo when applied to the subject line 123456bar

After matching all 6 digits and then failing to match "foo", the normal action of the matcher is to try again with only 5 digits matching the \d+ item, and then with 4, and so on, before ultimately failing. Once-only subpatterns provide the means for specifying that once a portion of the pattern has matched, it is not to be re-evaluated in this way, so the matcher would give up immediately on failing to match "foo" the first time. The notation is another kind of special parenthesis, starting with (?> as in this example: (?>\d+)bar

This kind of parenthesis "locks up" the part of the pattern it contains once it has matched, and a failure further into the pattern is prevented from backtracking into it. Backtracking past it to previous items, however, works as normal.

An alternative description is that a subpattern of this type matches the string of characters that an identical standalone pattern would match, if anchored at the current point in the subject string.

Once-only subpatterns are not capturing subpatterns. Simple cases such as the above example can be thought of as a maximizing repeat that must swallow everything it can. So, while both \d+ and \d+? are prepared to adjust the number of digits they match in order to make the rest of the pattern match, (?>\d+) can only match an entire sequence of digits.

This construction can of course contain arbitrarily complicated subpatterns, and it can be nested.

Once-only subpatterns can be used in conjunction with look-behind assertions to specify efficient matching at the end of the subject string. Consider a simple pattern such as abcd$ when applied to a long string which does not match. Because matching proceeds from left to right, PCRE will look for each "a" in the subject and then see if what follows matches the rest of the pattern. If the pattern is specified as ^.*abcd$ then the initial .* matches the entire string at first, but when this fails (because there is no following "a"), it backtracks to match all but the last character, then all but the last two characters, and so on. Once again the search for "a" covers the entire string, from right to left, so we are no better off. However, if the pattern is written as ^(?>.*)(?<=abcd) then there can be no backtracking for the .* item; it can match only the entire string. The subsequent lookbehind assertion does a single test on the last four characters. If it fails, the match fails immediately. For long strings, this approach makes a significant difference to the processing time.

When a pattern contains an unlimited repeat inside a subpattern that can itself be repeated an unlimited number of times, the use of a once-only subpattern is the only way to avoid some failing matches taking a very long time indeed. The pattern (\D+|<\d+>)*[!?] matches an unlimited number of substrings that either consist of non-digits, or digits enclosed in <>, followed by either ! or ?. When it matches, it runs quickly. However, if it is applied to aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa it takes a long time before reporting failure. This is because the string can be divided between the two repeats in a large number of ways, and all have to be tried. (The example used [!?] rather than a single character at the end, because both PCRE and Perl have an optimization that allows for fast failure when a single character is used. They remember the last single character that is required for a match, and fail early if it is not present in the string.) If the pattern is changed to ((?>\D+)|<\d+>)*[!?] sequences of non-digits cannot be broken, and failure happens quickly.

Conditional subpatterns

It is possible to cause the matching process to obey a subpattern conditionally or to choose between two alternative subpatterns, depending on the result of an assertion, or whether a previous capturing subpattern matched or not. The two possible forms of conditional subpattern are

(?(condition)yes-pattern)
(?(condition)yes-pattern|no-pattern)

If the condition is satisfied, the yes-pattern is used; otherwise the no-pattern (if present) is used. If there are more than two alternatives in the subpattern, a compile-time error occurs.

There are two kinds of condition. If the text between the parentheses consists of a sequence of digits, then the condition is satisfied if the capturing subpattern of that number has previously matched. Consider the following pattern, which contains non-significant white space to make it more readable (assume the PCRE_EXTENDED option) and to divide it into three parts for ease of discussion: ( \( )? [^()]+ (?(1) \) )

The first part matches an optional opening parenthesis, and if that character is present, sets it as the first captured substring. The second part matches one or more characters that are not parentheses. The third part is a conditional subpattern that tests whether the first set of parentheses matched or not. If they did, that is, if subject started with an opening parenthesis, the condition is TRUE, and so the yes-pattern is executed and a closing parenthesis is required. Otherwise, since no-pattern is not present, the subpattern matches nothing. In other words, this pattern matches a sequence of non-parentheses, optionally enclosed in parentheses.

If the condition is the string (R), it is satisfied if a recursive call to the pattern or subpattern has been made. At "top level", the condition is false.

If the condition is not a sequence of digits or (R), it must be an assertion. This may be a positive or negative lookahead or lookbehind assertion. Consider this pattern, again containing non-significant white space, and with the two alternatives on the second line:

(?(?=[^a-z]*[a-z])
\d{2}-[a-z]{3}-\d{2} | \d{2}-\d{2}-\d{2} )

The condition is a positive lookahead assertion that matches an optional sequence of non-letters followed by a letter. In other words, it tests for the presence of at least one letter in the subject. If a letter is found, the subject is matched against the first alternative; otherwise it is matched against the second. This pattern matches strings in one of the two forms dd-aaa-dd or dd-dd-dd, where aaa are letters and dd are digits.

Comments

The sequence (?# marks the start of a comment which continues up to the next closing parenthesis. Nested parentheses are not permitted. The characters that make up a comment play no part in the pattern matching at all.

If the PCRE_EXTENDED option is set, an unescaped # character outside a character class introduces a comment that continues up to the next newline character in the pattern.

Recursive patterns

Consider the problem of matching a string in parentheses, allowing for unlimited nested parentheses. Without the use of recursion, the best that can be done is to use a pattern that matches up to some fixed depth of nesting. It is not possible to handle an arbitrary nesting depth. Perl 5.6 has provided an experimental facility that allows regular expressions to recurse (among other things). The special item (?R) is provided for the specific case of recursion. This PCRE pattern solves the parentheses problem (assume the PCRE_EXTENDED option is set so that white space is ignored): \( ( (?>[^()]+) | (?R) )* \)

First it matches an opening parenthesis. Then it matches any number of substrings which can either be a sequence of non-parentheses, or a recursive match of the pattern itself (i.e. a correctly parenthesized substring). Finally there is a closing parenthesis.

This particular example pattern contains nested unlimited repeats, and so the use of a once-only subpattern for matching strings of non-parentheses is important when applying the pattern to strings that do not match. For example, when it is applied to (aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa() it yields "no match" quickly. However, if a once-only subpattern is not used, the match runs for a very long time indeed because there are so many different ways the + and * repeats can carve up the subject, and all have to be tested before failure can be reported.

The values set for any capturing subpatterns are those from the outermost level of the recursion at which the subpattern value is set. If the pattern above is matched against (ab(cd)ef) the value for the capturing parentheses is "ef", which is the last value taken on at the top level. If additional parentheses are added, giving \( ( ( (?>[^()]+) | (?R) )* ) \) then the string they capture is "ab(cd)ef", the contents of the top level parentheses. If there are more than 15 capturing parentheses in a pattern, PCRE has to obtain extra memory to store data during a recursion, which it does by using pcre_malloc, freeing it via pcre_free afterwards. If no memory can be obtained, it saves data for the first 15 capturing parentheses only, as there is no way to give an out-of-memory error from within a recursion.

Since PHP 4.3.3, (?1), (?2) and so on can be used for recursive subpatterns too. It is also possible to use named subpatterns: (?P<name>foo).

If the syntax for a recursive subpattern reference (either by number or by name) is used outside the parentheses to which it refers, it operates like a subroutine in a programming language. An earlier example pointed out that the pattern (sens|respons)e and \1ibility matches "sense and sensibility" and "response and responsibility", but not "sense and responsibility". If instead the pattern (sens|respons)e and (?1)ibility is used, it does match "sense and responsibility" as well as the other two strings. Such references must, however, follow the subpattern to which they refer.

The maximum length of a subject string is the largest positive number that an integer variable can hold. However, PCRE uses recursion to handle subpatterns and indefinite repetition. This means that the available stack space may limit the size of a subject string that can be processed by certain patterns.

Performances

Certain items that may appear in patterns are more efficient than others. It is more efficient to use a character class like [aeiou] than a set of alternatives such as (a|e|i|o|u). In general, the simplest construction that provides the required behaviour is usually the most efficient. Jeffrey Friedl's book contains a lot of discussion about optimizing regular expressions for efficient performance.

When a pattern begins with .* and the PCRE_DOTALL option is set, the pattern is implicitly anchored by PCRE, since it can match only at the start of a subject string. However, if PCRE_DOTALL is not set, PCRE cannot make this optimization, because the . metacharacter does not then match a newline, and if the subject string contains newlines, the pattern may match from the character immediately following one of them instead of from the very start. For example, the pattern (.*) second matches the subject "first\nand second" (where \n stands for a newline character) with the first captured substring being "and". In order to do this, PCRE has to retry the match starting after every newline in the subject.

If you are using such a pattern with subject strings that do not contain newlines, the best performance is obtained by setting PCRE_DOTALL, or starting the pattern with ^.* to indicate explicit anchoring. That saves PCRE from having to scan along the subject looking for a newline to restart at.

Beware of patterns that contain nested indefinite repeats. These can take a long time to run when applied to a string that does not match. Consider the pattern fragment (a+)*

This can match "aaaa" in 33 different ways, and this number increases very rapidly as the string gets longer. (The * repeat can match 0, 1, 2, 3, or 4 times, and for each of those cases other than 0, the + repeats can match different numbers of times.) When the remainder of the pattern is such that the entire match is going to fail, PCRE has in principle to try every possible variation, and this can take an extremely long time.

An optimization catches some of the more simple cases such as (a+)*b where a literal character follows. Before embarking on the standard matching procedure, PCRE checks that there is a "b" later in the subject string, and if there is not, it fails the match immediately. However, when there is no following literal this optimization cannot be used. You can see the difference by comparing the behaviour of (a+)*\d with the pattern above. The former gives a failure almost instantly when applied to a whole line of "a" characters, whereas the latter takes an appreciable time with strings longer than about 20 characters.

Předcházející | Nahoru | Další
Pattern Modifiers | Domů | preg_grep


preg_grep

(PHP 4, PHP 5)

preg_grep — Return array entries that match the pattern

Popis

array preg_grep ( string $pattern, array $input [, int $flags] )

Returns the array consisting of the elements of the input array that match the given pattern.

Seznam parametrů

pattern

The pattern to search for, as a string.

input

The input array.

flags

If set to PREG_GREP_INVERT, this function returns the elements of the input array that do not match the given pattern.

Návratové hodnoty

Returns an array indexed using the keys from the input array.

ChangeLog (záznam změn)

Verze | Popis
4.2.0 | The flags parameter was added.
4.0.4

Prior to this version, the returned array was indexed regardless of the keys of the input array.

If you want to reproduce this old behavior, use array_values() on the returned array to reindex the values.

Příklady

Příklad 1517. preg_grep() example

<?php
// return all array elements
// containing floating point numbers
$fl_array = preg_grep("/^(\d+)?\.\d+$/", $array);
?>

Předcházející | Nahoru | Další
Pattern Syntax | Domů | preg_last_error


preg_match_all

(PHP 4, PHP 5)

preg_match_all — Perform a global regular expression match

Popis

int preg_match_all ( string $pattern, string $subject, array &$matches [, int $flags [, int $offset]] )

Searches subject for all matches to the regular expression given in pattern and puts them in matches in the order specified by flags.

After the first match is found, the subsequent searches are continued on from end of the last match.

Seznam parametrů

pattern

The pattern to search for, as a string.

subject

The input string.

matches

Array of all matches in multi-dimensional array ordered according to flags.

flags

Can be a combination of the following flags (note that it doesn't make sense to use PREG_PATTERN_ORDER together with PREG_SET_ORDER):

PREG_PATTERN_ORDER

Orders results so that $matches[0] is an array of full pattern matches, $matches[1] is an array of strings matched by the first parenthesized subpattern, and so on.

<?php
preg_match_all("|<[^>]+>(.*)</[^>]+>|U",
    "<b>example: </b><div align=left>this is a test</div>",
    $out, PREG_PATTERN_ORDER);
echo $out[0][0] . ", " . $out[0][1] . "\n";
echo $out[1][0] . ", " . $out[1][1] . "\n";
?>

Výše uvedený příklad vypíše:

<b>example: </b>, <div align=left>this is a test</div>
example: , this is a test

So, $out[0] contains array of strings that matched full pattern, and $out[1] contains array of strings enclosed by tags.

PREG_SET_ORDER

Orders results so that $matches[0] is an array of first set of matches, $matches[1] is an array of second set of matches, and so on.

<?php
preg_match_all("|<[^>]+>(.*)</[^>]+>|U",
    "<b>example: </b><div align=\"left\">this is a test</div>",
    $out, PREG_SET_ORDER);
echo $out[0][0] . ", " . $out[0][1] . "\n";
echo $out[1][0] . ", " . $out[1][1] . "\n";
?>

Výše uvedený příklad vypíše:

<b>example: </b>, example:
<div align="left">this is a test</div>, this is a test

PREG_OFFSET_CAPTURE

If this flag is passed, for every occurring match the appendant string offset will also be returned. Note that this changes the value of matches in an array where every element is an array consisting of the matched string at offset 0 and its string offset into subject at offset 1.

If no order flag is given, PREG_PATTERN_ORDER is assumed.

offset

Normally, the search starts from the beginning of the subject string. The optional parameter offset can be used to specify the alternate place from which to start the search (in bytes).

Poznámka: Using offset is not equivalent to passing substr($subject, $offset) to preg_match_all() in place of the subject string, because pattern can contain assertions such as ^, $ or (?<=x). See preg_match() for examples.

Návratové hodnoty

Returns the number of full pattern matches (which might be zero), or FALSE if an error occurred.

ChangeLog (záznam změn)

Verze | Popis
4.3.3 | The offset parameter was added
4.3.0 | The PREG_OFFSET_CAPTURE flag was added

Příklady

Příklad 1518. Getting all phone numbers out of some text.

<?php
preg_match_all("/\(?  (\d{3})?  \)?  (?(1)  [\-\s] ) \d{3}-\d{4}/x",
                "Call 555-1212 or 1-800-555-1212", $phones);
?>

Příklad 1519. Find matching HTML tags (greedy)

<?php
// The \\2 is an example of backreferencing. This tells pcre that
// it must match the second set of parentheses in the regular expression
// itself, which would be the ([\w]+) in this case. The extra backslash is
// required because the string is in double quotes.
$html = "<b>bold text</b><a href=howdy.html>click me</a>";

preg_match_all("/(<([\w]+)[^>]*>)(.*)(<\/\\2>)/", $html, $matches, PREG_SET_ORDER);

foreach ($matches as $val) {
    echo "matched: " . $val[0] . "\n";
    echo "part 1: " . $val[1] . "\n";
    echo "part 2: " . $val[3] . "\n";
    echo "part 3: " . $val[4] . "\n\n";
}
?>

Výše uvedený příklad vypíše:

matched: <b>bold text</b>
part 1: <b>
part 2: bold text
part 3: </b>

matched: <a href=howdy.html>click me</a>
part 1: <a href=howdy.html>
part 2: click me
part 3: </a>

Viz také

preg_match()
preg_replace()
preg_split()

Předcházející | Nahoru | Další
preg_last_error | Domů | preg_match


preg_match

(PHP 4, PHP 5)

preg_match — Perform a regular expression match

Popis

int preg_match ( string $pattern, string $subject [, array &$matches [, int $flags [, int $offset]]] )

Searches subject for a match to the regular expression given in pattern.

Seznam parametrů

pattern

The pattern to search for, as a string.

subject

The input string.

matches

If matches is provided, then it is filled with the results of search. $matches[0] will contain the text that matched the full pattern, $matches[1] will have the text that matched the first captured parenthesized subpattern, and so on.

flags

flags can be the following flag:

PREG_OFFSET_CAPTURE
If this flag is passed, for every occurring match the appendant string offset will also be returned. Note that this changes the return value in an array where every element is an array consisting of the matched string at index 0 and its string offset into subject at index 1.

offset

Normally, the search starts from the beginning of the subject string. The optional parameter offset can be used to specify the alternate place from which to start the search (in bytes).

Poznámka: Using offset is not equivalent to passing substr($subject, $offset) to preg_match() in place of the subject string, because pattern can contain assertions such as ^, $ or (?<=x). Compare:

<?php
$subject = "abcdef";
$pattern = '/^def/';
preg_match($pattern, $subject, $matches, PREG_OFFSET_CAPTURE, 3);
print_r($matches);
?>

Výše uvedený příklad vypíše:

Array
(
)

while this example

<?php
$subject = "abcdef";
$pattern = '/^def/';
preg_match($pattern, substr($subject,3), $matches, PREG_OFFSET_CAPTURE);
print_r($matches);
?>

will produce

Array
(
    [0] => Array
        (
            [0] => def
            [1] => 0
        )

)

Návratové hodnoty

preg_match() returns the number of times pattern matches. That will be either 0 times (no match) or 1 time because preg_match() will stop searching after the first match. preg_match_all() on the contrary will continue until it reaches the end of subject. preg_match() returns FALSE if an error occurred.

ChangeLog (záznam změn)

Verze | Popis
4.3.3 | The offset parameter was added
4.3.0 | The PREG_OFFSET_CAPTURE flag was added
4.3.0 | The flags parameter was added

Příklady

Příklad 1520. Find the string of text "php"

<?php
// The "i" after the pattern delimiter indicates a case-insensitive search
if (preg_match("/php/i", "PHP is the web scripting language of choice.")) {
    echo "A match was found.";
} else {
    echo "A match was not found.";
}
?>

Příklad 1521. Find the word "web"

<?php
/* The \b in the pattern indicates a word boundary, so only the distinct
 * word "web" is matched, and not a word partial like "webbing" or "cobweb" */
if (preg_match("/\bweb\b/i", "PHP is the web scripting language of choice.")) {
    echo "A match was found.";
} else {
    echo "A match was not found.";
}

if (preg_match("/\bweb\b/i", "PHP is the website scripting language of choice.")) {
    echo "A match was found.";
} else {
    echo "A match was not found.";
}
?>

Příklad 1522. Getting the domain name out of a URL

<?php
// get host name from URL
preg_match('@^(?:http://)?([^/]+)@i',
    "http://www.php.net/index.html", $matches);
$host = $matches[1];

// get last two segments of host name
preg_match('/[^.]+\.[^.]+$/', $host, $matches);
echo "domain name is: {$matches[0]}\n";
?>

Výše uvedený příklad vypíše:

domain name is: php.net

Poznámky

Tip

Do not use preg_match() if you only want to check if one string is contained in another string. Use strpos() or strstr() instead as they will be faster.

Viz také

preg_match_all()
preg_replace()
preg_split()

Předcházející | Nahoru | Další
preg_match_all | Domů | preg_quote


preg_quote

(PHP 4, PHP 5)

preg_quote — Quote regular expression characters

Popis

string preg_quote ( string $str [, string $delimiter] )

preg_quote() takes str and puts a backslash in front of every character that is part of the regular expression syntax. This is useful if you have a run-time string that you need to match in some text and the string may contain special regex characters.

The special regular expression characters are: . \ + * ? [ ^ ] $ ( ) { } = ! < > | :

Seznam parametrů

str

The input string.

delimiter

If the optional delimiter is specified, it will also be escaped. This is useful for escaping the delimiter that is required by the PCRE functions. The / is the most commonly used delimiter.

Návratové hodnoty

Returns the quoted string.

Příklady

Příklad 1523. preg_quote() example

<?php
$keywords = '$40 for a g3/400';
$keywords = preg_quote($keywords, '/');
echo $keywords; // returns \$40 for a g3\/400
?>

Příklad 1524. Italicizing a word within some text

<?php
// In this example, preg_quote($word) is used to keep the
// asterisks from having special meaning to the regular
// expression.

$textbody = "This book is *very* difficult to find.";
$word = "*very*";
$textbody = preg_replace ("/" . preg_quote($word) . "/",
                          "<i>" . $word . "</i>",
                          $textbody);
?>

Poznámky

Poznámka: Tato funkce je binárně bezpečná.

Předcházející | Nahoru | Další
preg_match | Domů | preg_replace_callback


preg_replace_callback

(PHP 4 >= 4.0.5, PHP 5)

preg_replace_callback — Perform a regular expression search and replace using a callback

Popis

mixed preg_replace_callback ( mixed $pattern, callback $callback, mixed $subject [, int $limit [, int &$count]] )

The behavior of this function is almost identical to preg_replace(), except for the fact that instead of replacement parameter, one should specify a callback.

Seznam parametrů

pattern

The pattern to search for. It can be either a string or an array with strings.

callback

A callback that will be called and passed an array of matched elements in the subject string. The callback should return the replacement string.

You'll often need the callback function for a preg_replace_callback() in just one place. In this case you can use create_function() to declare an anonymous function as callback within the call to preg_replace_callback(). By doing it this way you have all information for the call in one place and do not clutter the function namespace with a callback function's name not used anywhere else.

Příklad 1525. preg_replace_callback() and create_function()

<?php
/* a unix-style command line filter to convert uppercase
 * letters at the beginning of paragraphs to lowercase */
$fp = fopen("php://stdin", "r") or die("can't read stdin");
while (!feof($fp)) {
    $line = fgets($fp);
    $line = preg_replace_callback(
        '|<p>\s*\w|',
        create_function(
            // single quotes are essential here,
            // or alternative escape all $ as \$
            '$matches',
            'return strtolower($matches[0]);'
        ),
        $line
    );
    echo $line;
}
fclose($fp);
?>

subject

The string or an array with strings to search and replace.

limit

The maximum possible replacements for each pattern in each subject string. Defaults to -1 (no limit).

count

If specified, this variable will be filled with the number of replacements done.

Návratové hodnoty

preg_replace_callback() returns an array if the subject parameter is an array, or a string otherwise.

If matches are found, the new subject will be returned, otherwise subject will be returned unchanged.

ChangeLog (záznam změn)

Verze | Popis
5.1.0 | The count parameter was added

Příklady

Příklad 1526. preg_replace_callback() example

<?php
// this text was used in 2002
// we want to get this up to date for 2003
$text = "April fools day is 04/01/2002\n";
$text.= "Last christmas was 12/24/2001\n";
// the callback function
function next_year($matches)
{
  // as usual: $matches[0] is the complete match
  // $matches[1] the match for the first subpattern
  // enclosed in '(...)' and so on
  return $matches[1].($matches[2]+1);
}
echo preg_replace_callback(
            "|(\d{2}/\d{2}/)(\d{4})|",
            "next_year",
            $text);

?>

Výše uvedený příklad vypíše:

April fools day is 04/01/2003
Last christmas was 12/24/2002

Příklad 1527. preg_replace_callback() using recursive structure to handle encapsulated BB code

<?php
$input = "plain [indent] deep [indent] deeper [/indent] deep [/indent] plain";

function parseTagsRecursive($input)
{

    $regex = '#\[indent]((?:[^[]|\[(?!/?indent])|(?R))+)\[/indent]#';

    if (is_array($input)) {
        $input = '<div style="margin-left: 10px">'.$input[1].'</div>';
    }

    return preg_replace_callback($regex, 'parseTagsRecursive', $input);
}

$output = parseTagsRecursive($input);

echo $output;
?>

Viz také

preg_replace()
create_function()
informace typu callback

Předcházející | Nahoru | Další
preg_quote | Domů | preg_replace


preg_replace

(PHP 4, PHP 5)

preg_replace — Perform a regular expression search and replace

Popis

mixed preg_replace ( mixed $pattern, mixed $replacement, mixed $subject [, int $limit [, int &$count]] )

Searches subject for matches to pattern and replaces them with replacement.

Seznam parametrů

pattern

The pattern to search for. It can be either a string or an array with strings.

The e modifier makes preg_replace() treat the replacement parameter as PHP code after the appropriate references substitution is done. Tip: make sure that replacement constitutes a valid PHP code string, otherwise PHP will complain about a parse error at the line containing preg_replace().

replacement

The string or an array with strings to replace. If this parameter is a string and the pattern parameter is an array, all patterns will be replaced by that string. If both pattern and replacement parameters are arrays, each pattern will be replaced by the replacement counterpart. If there are fewer elements in the replacement array than in the pattern array, any extra patterns will be replaced by an empty string.

replacement may contain references of the form \\n or (since PHP 4.0.4) $n, with the latter form being the preferred one. Every such reference will be replaced by the text captured by the n'th parenthesized pattern. n can be from 0 to 99, and \\0 or $0 refers to the text matched by the whole pattern. Opening parentheses are counted from left to right (starting from 1) to obtain the number of the capturing subpattern.

When working with a replacement pattern where a backreference is immediately followed by another number (i.e.: placing a literal number immediately after a matched pattern), you cannot use the familiar \\1 notation for your backreference. \\11, for example, would confuse preg_replace() since it does not know whether you want the \\1 backreference followed by a literal 1, or the \\11 backreference followed by nothing. In this case the solution is to use \${1}1. This creates an isolated $1 backreference, leaving the 1 as a literal.

When using the e modifier, this function escapes some characters (namely ', ", \ and NULL) in the strings that replace the backreferences. This is done to ensure that no syntax errors arise from backreference usage with either single or double quotes (e.g. 'strlen(\'$1\')+strlen("$2")'). Make sure you are aware of PHP's string syntax to know exactly how the interpreted string will look like.

subject

The string or an array with strings to search and replace.

If subject is an array, then the search and replace is performed on every entry of subject, and the return value is an array as well.

limit

The maximum possible replacements for each pattern in each subject string. Defaults to -1 (no limit).

count

If specified, this variable will be filled with the number of replacements done.

Návratové hodnoty

preg_replace() returns an array if the subject parameter is an array, or a string otherwise.

If matches are found, the new subject will be returned, otherwise subject will be returned unchanged.

ChangeLog (záznam změn)

Verze | Popis
5.1.0 | Added the count parameter
4.0.4 | Added the '$n' form for the replacement parameter
4.0.2 | Added the limit parameter

Příklady

Příklad 1528. Using backreferences followed by numeric literals

<?php
$string = 'April 15, 2003';
$pattern = '/(\w+) (\d+), (\d+)/i';
$replacement = '${1}1,$3';
echo preg_replace($pattern, $replacement, $string);
?>

Výše uvedený příklad vypíše:

April1,2003

Příklad 1529. Using indexed arrays with preg_replace()

<?php
$string = 'The quick brown fox jumped over the lazy dog.';
$patterns[0] = '/quick/';
$patterns[1] = '/brown/';
$patterns[2] = '/fox/';
$replacements[2] = 'bear';
$replacements[1] = 'black';
$replacements[0] = 'slow';
echo preg_replace($patterns, $replacements, $string);
?>

Výše uvedený příklad vypíše:

The bear black slow jumped over the lazy dog.

By ksorting patterns and replacements, we should get what we wanted.

<?php
ksort($patterns);
ksort($replacements);
echo preg_replace($patterns, $replacements, $string);
?>

Výše uvedený příklad vypíše:

The slow black bear jumped over the lazy dog.

Příklad 1530. Replacing several values

<?php
$patterns = array ('/(19|20)(\d{2})-(\d{1,2})-(\d{1,2})/',
                   '/^\s*{(\w+)}\s*=/');
$replace = array ('\3/\4/\1\2', '$\1 =');
echo preg_replace($patterns, $replace, '{startDate} = 1999-5-27');
?>

Výše uvedený příklad vypíše:

$startDate = 5/27/1999

Příklad 1531. Using the 'e' modifier

<?php
preg_replace("/(<\/?)(\w+)([^>]*>)/e",
             "'\\1'.strtoupper('\\2').'\\3'",
             $html_body);
?>

This would capitalize all HTML tags in the input text.

Příklad 1532. Strip whitespace

This example strips excess whitespace from a string.

<?php
$str = 'foo   o';
$str = preg_replace('/\s\s+/', ' ', $str);
// This will be 'foo o' now
echo $str;
?>

Příklad 1533. Using the count parameter

<?php
$count = 0;

echo preg_replace(array('/\d/', '/\s/'), '*', 'xp 4 to', -1 , $count);
echo $count; //3
?>

Výše uvedený příklad vypíše:

xp***to
3

Poznámky

Poznámka: When using arrays with pattern and replacement, the keys are processed in the order they appear in the array. This is not necessarily the same as the numerical index order. If you use indexes to identify which pattern should be replaced by which replacement, you should perform a ksort() on each array prior to calling preg_replace().

Viz také

preg_match()
preg_replace_callback()
preg_split()

Předcházející | Nahoru | Další
preg_replace_callback | Domů | preg_split


preg_split

(PHP 4, PHP 5)

preg_split — Split string by a regular expression

Popis

array preg_split ( string $pattern, string $subject [, int $limit [, int $flags]] )

Split the given string by a regular expression.

Seznam parametrů

pattern

The pattern to search for, as a string.

subject

The input string.

limit

If specified, then only substrings up to limit are returned, and if limit is -1, it actually means "no limit", which is useful for specifying the flags.

flags

flags can be any combination of the following flags (combined with bitwise | operator):

PREG_SPLIT_NO_EMPTY
If this flag is set, only non-empty pieces will be returned by preg_split().
PREG_SPLIT_DELIM_CAPTURE
If this flag is set, parenthesized expression in the delimiter pattern will be captured and returned as well.
PREG_SPLIT_OFFSET_CAPTURE

If this flag is set, for every occurring match the appendant string offset will also be returned. Note that this changes the return value in an array where every element is an array consisting of the matched string at offset 0 and its string offset into subject at offset 1.

Návratové hodnoty

Returns an array containing substrings of subject split along boundaries matched by pattern.

ChangeLog (záznam změn)

Verze | Popis
4.3.0 | The PREG_SPLIT_OFFSET_CAPTURE was added
4.0.5 | The PREG_SPLIT_DELIM_CAPTURE was added
4.0.0 | The flags parameter was added

Příklady

Příklad 1534. preg_split() example : Get the parts of a search string

<?php
// split the phrase by any number of commas or space characters,
// which include " ", \r, \t, \n and \f
$keywords = preg_split("/[\s,]+/", "hypertext language, programming");
?>

Příklad 1535. Splitting a string into component characters

<?php
$str = 'string';
$chars = preg_split('//', $str, -1, PREG_SPLIT_NO_EMPTY);
print_r($chars);
?>

Příklad 1536. Splitting a string into matches and their offsets

<?php
$str = 'hypertext language programming';
$chars = preg_split('/ /', $str, -1, PREG_SPLIT_OFFSET_CAPTURE);
print_r($chars);
?>

Výše uvedený příklad vypíše:

Array
(
    [0] => Array
        (
            [0] => hypertext
            [1] => 0
        )

    [1] => Array
        (
            [0] => language
            [1] => 10
        )

    [2] => Array
        (
            [0] => programming
            [1] => 19
        )

)

Poznámky

Tip

If you don't need the power of regular expressions, you can choose faster (albeit simpler) alternatives like explode() or str_split().

Viz také

spliti()
split()
implode()
preg_match()
preg_match_all()
preg_replace()

Předcházející | Nahoru | Další
preg_replace | Domů | CXXI. PDF funkce


qtdom Functions

Předcházející VI. Reference funkcí Další

CXXXIII. qtdom Functions

Varování

Toto rozšíření je EXPERIMENTÁLNÍ. Chování tohoto rozšíření, názvy funkcí a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může bez ohlášení změnit. Berte to v úvahu a používejte tento modul na vlastní nebezpečí.

Poznámka: Toto rozšíření není k dispozici na platformách Windows.

Poznámka: Toto rozšíření bylo přesunuto do repozitáře PECL a již nebude součástí balíku PHP.5.0.0.

Požadavky

You need the Qt-library >=2.2.0

Instalace

Configure PHP --with-qtdom to use these functions.

Obsah

qdom_error — Returns the error string from the last QDOM operation or FALSE if no errors occurred
qdom_tree — Creates a tree of an XML string
Předcházející | Nahoru | Další
pspell_suggest | Domů | qdom_error


qdom_error

(PHP 4 >= 4.0.5)

qdom_error — Returns the error string from the last QDOM operation or FALSE if no errors occurred

Popis

string qdom_error ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
CXXXIII. qtdom Functions | Domů | qdom_tree


qdom_tree

(PHP 4 >= 4.0.4)

qdom_tree — Creates a tree of an XML string

Popis

QDomDocument qdom_tree ( string $doc )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
qdom_error | Domů | CXXXIV. Radius


Rar Functions

Předcházející VI. Reference funkcí Další

CXXXV. Rar Functions

Úvod

Rar is a powerful and effective archiver created by Eugene Roshal. This extension gives you possibility to read Rar archives but doesn't support writing Rar archives, because this is not supported by UnRar library and is directly prohibited by it's license.

More information about Rar and UnRar can be found at » http://www.rarlabs.com/.

Požadavky

Tyto funkce jsou k dispozici jako součást standardního modulu, který je vždy dostupný.

Konfigurace běhu

Toto rozšíření nemá definováno žádné konfigurační direktivy.

Instalace

Rar is currently available through PECL » http://pecl.php.net/package/rar.

Also you can use the PECL installer to install the Rar extension, using the following command: pecl -v install rar.

You can always download the tar.gz package and install Rar by hand:

Příklad 1840. Rar installation

gunzip rar-xxx.tgz
tar -xvf rar-xxx.tar
cd rar-xxx
phpize
./configure && make && make install

Windows users can download the extension dll php_rar.dll here: » http://snaps.php.net/win32/PECL_STABLE/.

Typy prostředků

There is one resource used in Rar extension: a file descriptor returned by rar_open().

Předdefinované konstanty

RAR_HOST_MSDOS (integer)
RAR_HOST_OS2 (integer)
RAR_HOST_WIN32 (integer)
RAR_HOST_UNIX (integer)
RAR_HOST_BEOS (integer)

Příklady

Příklad 1841. Rar extension overview example

<?php

$rar_file = rar_open('example.rar') or die("Can't open Rar archive");

$entries = rar_list($rar_file);

foreach ($entries as $entry) {
    echo 'Filename: ' . $entry->getName() . "\n";
    echo 'Packed size: ' . $entry->getPackedSize() . "\n";
    echo 'Unpacked size: ' . $entry->getUnpackedSize() . "\n";

    $entry->extract('/dir/extract/to/');
}

rar_close($rar_file);

?>

This example opens a Rar file archive and extracts each entry to the specified directory.

Obsah

rar_close — Close Rar archive and free all resources
rar_entry_get — Get entry object from the Rar archive
Rar::extract — Extract entry from the archive
Rar::getAttr — Get attributes of the entry
Rar::getCrc — Get CRC of the entry
Rar::getFileTime — Get entry last modification time
Rar::getHostOs — Get entry host OS
Rar::getMethod — Get pack method of the entry
Rar::getName — Get name of the entry
Rar::getPackedSize — Get packed size of the entry
Rar::getUnpackedSize — Get unpacked size of the entry
Rar::getVersion — Get version of the archiver used to add the entry
rar_list — Get entries list from the Rar archive
rar_open — Open Rar archive
Předcházející | Nahoru | Další
radius_strerror | Domů | rar_close


rar_close

(No version information available, might be only in CVS)

rar_close — Close Rar archive and free all resources

Popis

bool rar_close ( resource $rar_file )

Close Rar archive and free all allocated resources.

Seznam parametrů

rar_file

A Rar file resource, opened with rar_open().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
CXXXV. Rar Functions | Domů | rar_entry_get


rar_entry_get

(No version information available, might be only in CVS)

rar_entry_get — Get entry object from the Rar archive

Popis

RarEntry rar_entry_get ( resource $rar_file, string $entry_name )

Get entry object from the Rar archive.

Seznam parametrů

rar_file

A Rar file resource, opened with rar_open().

entry_name

Path to the entry within the Rar archive.

Návratové hodnoty

rar_get_entry() returns entry object or FALSE on error.

Příklady

Příklad 1842. rar_entry_get() example

<?php

$rar_file = rar_open('example.rar') or die("Failed to open Rar archive");

$entry = rar_entry_get($rar_file, 'Dir/file.txt') or die("Failed to find such entry");

print_r($entry);

?>

Předcházející | Nahoru | Další
rar_close | Domů | Rar::extract


Rar::extract

(No version information available, might be only in CVS)

Rar::extract — Extract entry from the archive

Popis

class Rar {
bool extract ( string $dir [, string $filepath] )
}

Rar::extract() extracts entry's data to the dir. It will create new file in the specified dir with the name identical to the entry's name.

Seznam parametrů

dir

Path to the directory where files should be extracted.

filepath

If parameter filepath is specified instead dir, Rar::extract() will extract entry's data to the specified file.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1843. Rar::extract() example

<?php

$rar_file = rar_open('example.rar') or die("Failed to open Rar archive");

$entry = rar_entry_get($rar_file, 'Dir/file.txt') or die("Failed to find such entry");

$entry->extract('/dir/to'); // create /dir/to/Dir/file.txt
$entry->extract(false, '/dir/to/new_name.txt'); // create /dir/to/new_name.txt

?>

Příklad 1844. How to extract all files in archive:

<?php

/* example by Erik Jenssen aka erix */

$filename = "foobar.rar";
$filepath = "/home/foo/bar/";

$rar_file = rar_open($filepath.$filename);
$list = rar_list($rar_file);
foreach($list as $file) {
    $entry = rar_entry_get($rar_file, $file);
    $entry->extract("."); // extract to the current dir
}
rar_close($rar_file);

?>

Předcházející | Nahoru | Další
rar_entry_get | Domů | Rar::getAttr


Rar::getAttr

(No version information available, might be only in CVS)

Rar::getAttr — Get attributes of the entry

Popis

class Rar {
int getAttr ( void )
}

Rar::getAttr() returns attributes of the archive entry.

Návratové hodnoty

Returns the attributes or FALSE on error.

Příklady

Příklad 1845. Rar::getAttr() example

<?php

$rar_file = rar_open('example.rar') or die("Can't open Rar archive");

$entry = rar_entry_get($rar_file, 'dir/in/the/archive') or die("Can't find such entry");

$host_os = $entry->getHostOs();
$attr = $entry->getAttr();

switch($host_os) {
    case RAR_HOST_MSDOS:
    case RAR_HOST_OS2:
    case RAR_HOST_WIN32:
    case RAR_HOST_MACOS:
        printf("%c%c%c%c%c%c\n",
                ($attr & 0x08) ? 'V' : '.',
                ($attr & 0x10) ? 'D' : '.',
                ($attr & 0x01) ? 'R' : '.',
                ($attr & 0x02) ? 'H' : '.',
                ($attr & 0x04) ? 'S' : '.',
                ($attr & 0x20) ? 'A' : '.');
        break;
    case RAR_HOST_UNIX:
    case RAR_HOST_BEOS:
        switch ($attr & 0xF000)
        {
            case 0x4000:
                printf("d");
                break;
            case 0xA000:
                printf("l");
                break;
            default:
                printf("-");
                break;
        }
        printf("%c%c%c%c%c%c%c%c%c\n",
                ($attr & 0x0100) ? 'r' : '-',
                ($attr & 0x0080) ? 'w' : '-',
                ($attr & 0x0040) ? (($attr & 0x0800) ? 's':'x'):(($attr & 0x0800) ? 'S':'-'),
                ($attr & 0x0020) ? 'r' : '-',
                ($attr & 0x0010) ? 'w' : '-',
                ($attr & 0x0008) ? (($attr & 0x0400) ? 's':'x'):(($attr & 0x0400) ? 'S':'-'),
                ($attr & 0x0004) ? 'r' : '-',
                ($attr & 0x0002) ? 'w' : '-',
                ($attr & 0x0001) ? 'x' : '-');
        break;
}

rar_close($rar_file);

?>

Viz také

Rar::getHostOs

Předcházející | Nahoru | Další
Rar::extract | Domů | Rar::getCrc


Rar::getCrc

(No version information available, might be only in CVS)

Rar::getCrc — Get CRC of the entry

Popis

class Rar {
int getCrc ( void )
}

Rar::getCrc() returns CRC of the archive entry.

Návratové hodnoty

Returns the CRC of the archive entry or FALSE on error.

Předcházející | Nahoru | Další
Rar::getAttr | Domů | Rar::getFileTime


Rar::getFileTime

(No version information available, might be only in CVS)

Rar::getFileTime — Get entry last modification time

Popis

class Rar {
string getFileTime ( void )
}

Gets entry last modification time.

Návratové hodnoty

Returns entry last modification time as string in format YYYY-MM-DD HH:II:SS, or FALSE on error.

Předcházející | Nahoru | Další
Rar::getCrc | Domů | Rar::getHostOs


Rar::getHostOs

(No version information available, might be only in CVS)

Rar::getHostOs — Get entry host OS

Popis

class Rar {
int getHostOs ( void )
}

Rar::getHostOs() return code of the host OS of the archive entry.

Návratové hodnoty

Returns the code of the host OS, or FALSE on error.

Příklady

Příklad 1846. Rar::getHostOs() example

<?php

$rar_file = rar_open('example.rar') or die("Failed to open Rar archive");

$entry = rar_entry_get($rar_file, 'Dir/file.txt') or die("Failed to find such entry");

switch ($entry->getHostOs()) {
    case RAR_HOST_MSDOS:
        echo "MS-DOS\n";
        break;
    case RAR_HOST_OS2:
        echo "OS2\n";
        break;
    case RAR_HOST_WIN32:
        echo "Win32\n";
        break;
    case RAR_HOST_MACOS:
        echo "MacOS\n";
        break;
    case RAR_HOST_UNIX:
        echo "Unix/Linux\n";
        break;
    case RAR_HOST_BEOS:
        echo "BeOS\n";
        break;
}

?>

Předcházející | Nahoru | Další
Rar::getFileTime | Domů | Rar::getMethod


Rar::getMethod

(No version information available, might be only in CVS)

Rar::getMethod — Get pack method of the entry

Popis

class Rar {
int getMethod ( void )
}

Rar::getMethod() returns number of the method used when adding current archive entry.

Návratové hodnoty

Returns the method number or FALSE on error.

Příklady

Příklad 1847. Rar::getMethod() example

<?php

$rar_file = rar_open('example.rar') or die("Failed to open Rar archive");

$entry = rar_entry_get($rar_file, 'Dir/file.txt') or die("Failed to find such entry");

echo "Method number: " . $entry->getMethod();

?>

Předcházející | Nahoru | Další
Rar::getHostOs | Domů | Rar::getName


Rar::getName

(No version information available, might be only in CVS)

Rar::getName — Get name of the entry

Popis

class Rar {
string getName ( void )
}

Rar::getName() returns full name of the archive entry.

Návratové hodnoty

Returns the entry name as a string, or FALSE on error.

Příklady

Příklad 1848. Rar::getName() example

<?php

$rar_file = rar_open('example.rar') or die("Failed to open Rar archive");

$entry = rar_entry_get($rar_file, 'Dir/file.txt') or die("Failed to find such entry");

echo "Entry name: " . $entry->getName();

?>

Předcházející | Nahoru | Další
Rar::getMethod | Domů | Rar::getPackedSize


Rar::getPackedSize

(No version information available, might be only in CVS)

Rar::getPackedSize — Get packed size of the entry

Popis

class Rar {
int getPackedSize ( void )
}

Get packed size of the archive entry.

Návratové hodnoty

Returns the packed size, or FALSE on error.

Příklady

Příklad 1849. Rar::getPackedSize() example

<?php

$rar_file = rar_open('example.rar') or die("Failed to open Rar archive");

$entry = rar_entry_get($rar_file, 'Dir/file.txt') or die("Failed to find such entry");

echo "Packed size of " . $entry->getName() . " = " . $entry->getPackedSize() . " bytes";

?>

Předcházející | Nahoru | Další
Rar::getName | Domů | Rar::getUnpackedSize


Rar::getUnpackedSize

(No version information available, might be only in CVS)

Rar::getUnpackedSize — Get unpacked size of the entry

Popis

class Rar {
int getUnpackedSize ( void )
}

Get unpacked size of the archive entry.

Návratové hodnoty

Returns the unpacked size, or FALSE on error.

Návratové hodnoty

Příklad 1850. Rar::getUnpackedSize() example

<?php

$rar_file = rar_open('example.rar') or die("Failed to open Rar archive");

$entry = rar_entry_get($rar_file, 'Dir/file.txt') or die("Failed to find such entry");

echo "Unpacked size of " . $entry->getName() . " = " . $entry->getPackedSize() . " bytes";

?>

Předcházející | Nahoru | Další
Rar::getPackedSize | Domů | Rar::getVersion


Rar::getVersion

(No version information available, might be only in CVS)

Rar::getVersion — Get version of the archiver used to add the entry

Popis

class Rar {
int getVersion ( void )
}

Get version of the archiver used to add the archive entry.

Návratové hodnoty

Returns the version or FALSE on error.

Příklady

Příklad 1851. Rar::getVersion() example

<?php

$rar_file = rar_open('example.rar') or die("Failed to open Rar archive");

$entry = rar_entry_get($rar_file, 'Dir/file.txt') or die("Failed to find such entry");

echo "Rar (WinRAR) version used: " . $entry->getVersion();

?>

Předcházející | Nahoru | Další
Rar::getUnpackedSize | Domů | rar_list


rar_list

(No version information available, might be only in CVS)

rar_list — Get entries list from the Rar archive

Popis

array rar_list ( resource $rar_file )

Get entries list from the Rar archive.

Seznam parametrů

rar_file

A Rar file resource, opened with rar_open().

Návratové hodnoty

rar_list() returns array of entries or FALSE on error.

Příklady

Příklad 1852. rar_list() example

<?php

$rar_file = rar_open('example.rar') or die("Failed to open Rar archive");

$entries_list = rar_list($rar_file);

print_r($entries_list);

?>

Předcházející | Nahoru | Další
Rar::getVersion | Domů | rar_open


rar_open

(No version information available, might be only in CVS)

rar_open — Open Rar archive

Popis

resource rar_open ( string $filename [, string $password] )

Open specified Rar archive and return Rar file resource.

Seznam parametrů

filename

Path to the Rar archive.

password

A plain password, if needed.

Návratové hodnoty

rar_open() returns Rar file resource or FALSE on error.

Předcházející | Nahoru | Další
rar_list | Domů | CXXXVI. GNU Readline


Regular Expression Functions (POSIX Extended)

Předcházející VI. Reference funkcí Další

CXXVI. Regular Expression Functions (POSIX Extended)

Úvod

Tip

PHP also supports regular expressions using a Perl-compatible syntax using the PCRE functions. Those functions support non-greedy matching, assertions, conditional subpatterns, and a number of other features not supported by the POSIX-extended regular expression syntax.

Varování

These regular expression functions are not binary-safe. The PCRE functions are.

Regular expressions are used for complex string manipulation. PHP uses the POSIX extended regular expressions as defined by POSIX 1003.2. For a full description of POSIX regular expressions see the » regex man pages included in the regex directory in the PHP distribution. It's in manpage format, so you'll want to do something along the lines of man /usr/local/src/regex/regex.7 in order to read it.

Požadavky

Tyto funkce jsou k dispozici jako součást standardního modulu, který je vždy dostupný.

Instalace

Varování

Do not change the TYPE unless you know what you are doing.

To enable regexp support configure PHP --with-regex[=TYPE]. TYPE can be one of system, apache, php. The default is to use php.

Verze PHP pro Windows má vestavěnou podporu pro toto rozšíření. K použití těchto funkcí není třeba načítat žádná další rozšíření.

Konfigurace běhu

Toto rozšíření nemá definováno žádné konfigurační direktivy.

Typy prostředků

Toto rozšíření nemá definován žádný typ prostředku (resource).

Předdefinované konstanty

Toto rozšíření nemá definovány žádné konstanty.

Příklady

Příklad 1681. Regular Expression Examples

<?php
// Returns true if "abc" is found anywhere in $string.
ereg("abc", $string);

// Returns true if "abc" is found at the beginning of $string.
ereg("^abc", $string);

// Returns true if "abc" is found at the end of $string.
ereg("abc$", $string);

// Returns true if client browser is Netscape 2, 3 or MSIE 3.
eregi("(ozilla.[23]|MSIE.3)", $_SERVER["HTTP_USER_AGENT"]);

// Places three space separated words into $regs[1], $regs[2] and $regs[3].
ereg("([[:alnum:]]+) ([[:alnum:]]+) ([[:alnum:]]+)", $string, $regs);

// Put a <br /> tag at the beginning of $string.
$string = ereg_replace("^", "<br />", $string);

// Put a <br /> tag at the end of $string.
$string = ereg_replace("$", "<br />", $string);

// Get rid of any newline characters in $string.
$string = ereg_replace("\n", "", $string);
?>

Viz také

For regular expressions in Perl-compatible syntax have a look at the PCRE functions. The simpler shell style wildcard pattern matching is provided by fnmatch().

Obsah

ereg_replace — Replace regular expression
ereg — Regular expression match
eregi_replace — Replace regular expression case insensitive
eregi — Case insensitive regular expression match
split — Split string into array by regular expression
spliti — Split string into array by regular expression case insensitive
sql_regcase — Make regular expression for case insensitive match
Předcházející | Nahoru | Další
posix_uname | Domů | ereg_replace


ereg_replace

(PHP 4, PHP 5)

ereg_replace — Replace regular expression

Popis

string ereg_replace ( string $pattern, string $replacement, string $string )

This function scans string for matches to pattern, then replaces the matched text with replacement.

Seznam parametrů

pattern

A POSIX extended regular expression.

replacement

If pattern contains parenthesized substrings, replacement may contain substrings of the form \\digit, which will be replaced by the text matching the digit'th parenthesized substring; \\0 will produce the entire contents of string. Up to nine substrings may be used. Parentheses may be nested, in which case they are counted by the opening parenthesis.

string

The input string.

Návratové hodnoty

The modified string is returned. If no matches are found in string, then it will be returned unchanged.

Příklady

For example, the following code snippet prints "This was a test" three times:

Příklad 1682. ereg_replace() example

<?php

$string = "This is a test";
echo str_replace(" is", " was", $string);
echo ereg_replace("( )is", "\\1was", $string);
echo ereg_replace("(( )is)", "\\2was", $string);

?>

One thing to take note of is that if you use an integer value as the replacement parameter, you may not get the results you expect. This is because ereg_replace() will interpret the number as the ordinal value of a character, and apply that. For instance:

Příklad 1683. ereg_replace() example

<?php
/* This will not work as expected. */
$num = 4;
$string = "This string has four words.";
$string = ereg_replace('four', $num, $string);
echo $string;   /* Output: 'This string has   words.' */

/* This will work. */
$num = '4';
$string = "This string has four words.";
$string = ereg_replace('four', $num, $string);
echo $string;   /* Output: 'This string has 4 words.' */
?>

Příklad 1684. Replace URLs with links

<?php
$text = ereg_replace("[[:alpha:]]+://[^<>[:space:]]+[[:alnum:]/]",
                     "<a href=\"\\0\">\\0</a>", $text);
?>

Poznámky

Tip

preg_replace(), which uses a Perl-compatible regular expression syntax, is often a faster alternative to ereg_replace().

Viz také

ereg()
eregi()
eregi_replace()
str_replace()
preg_match()

Předcházející | Nahoru | Další
CXXVI. Regular Expression Functions (POSIX Extended) | Domů | ereg


ereg

(PHP 4, PHP 5)

ereg — Regular expression match

Popis

int ereg ( string $pattern, string $string [, array &$regs] )

Searches a string for matches to the regular expression given in pattern in a case-sensitive way.

Seznam parametrů

pattern

Case sensitive regular expression.

string

The input string.

regs

If matches are found for parenthesized substrings of pattern and the function is called with the third argument regs, the matches will be stored in the elements of the array regs.

$regs[1] will contain the substring which starts at the first left parenthesis; $regs[2] will contain the substring starting at the second, and so on. $regs[0] will contain a copy of the complete string matched.

Návratové hodnoty

Returns the length of the matched string if a match for pattern was found in string, or FALSE if no matches were found or an error occurred.

If the optional parameter regs was not passed or the length of the matched string is 0, this function returns 1.

Příklady

Příklad 1685. ereg() example

The following code snippet takes a date in ISO format (YYYY-MM-DD) and prints it in DD.MM.YYYY format:

<?php
if (ereg ("([0-9]{4})-([0-9]{1,2})-([0-9]{1,2})", $date, $regs)) {
    echo "$regs[3].$regs[2].$regs[1]";
} else {
    echo "Invalid date format: $date";
}
?>

Poznámky

Poznámka: preg_match(), which uses a Perl-compatible regular expression syntax, is often a faster alternative to ereg().

Poznámka: Up to (and including) PHP 4.1.0 $regs will be filled with exactly ten elements, even though more or fewer than ten parenthesized substrings may actually have matched. This has no effect on ereg()'s ability to match more substrings. If no matches are found, $regs will not be altered by ereg().

Viz také

eregi()
ereg_replace()
eregi_replace()
preg_match()
strpos()
strstr()

Předcházející | Nahoru | Další
ereg_replace | Domů | eregi_replace


eregi_replace

(PHP 4, PHP 5)

eregi_replace — Replace regular expression case insensitive

Popis

string eregi_replace ( string $pattern, string $replacement, string $string )

This function is identical to ereg_replace() except that this ignores case distinction when matching alphabetic characters.

Seznam parametrů

pattern

A POSIX extended regular expression.

replacement

If pattern contains parenthesized substrings, replacement may contain substrings of the form \\digit, which will be replaced by the text matching the digit'th parenthesized substring; \\0 will produce the entire contents of string. Up to nine substrings may be used. Parentheses may be nested, in which case they are counted by the opening parenthesis.

string

The input string.

Návratové hodnoty

The modified string is returned. If no matches are found in string, then it will be returned unchanged.

Příklady

Příklad 1686. Highlight search results

<?php
$pattern = '(>[^<]*)('. quotemeta($_GET['search']) .')';
$replacement = '\\1<span class="search">\\2</span>';
$body = eregi_replace($pattern, $replacement, $body);
?>

Viz také

ereg()
eregi()
ereg_replace()

Předcházející | Nahoru | Další
ereg | Domů | eregi


eregi

(PHP 4, PHP 5)

eregi — Case insensitive regular expression match

Popis

int eregi ( string $pattern, string $string [, array &$regs] )

This function is identical to ereg() except that it ignores case distinction when matching alphabetic characters.

Seznam parametrů

pattern

Case insensitive regular expression.

string

The input string.

regs

If matches are found for parenthesized substrings of pattern and the function is called with the third argument regs, the matches will be stored in the elements of the array regs.

$regs[1] will contain the substring which starts at the first left parenthesis; $regs[2] will contain the substring starting at the second, and so on. $regs[0] will contain a copy of the complete string matched.

Návratové hodnoty

Returns the length of the matched string if a match for pattern was found in string, or FALSE if no matches were found or an error occurred.

If the optional parameter regs was not passed or the length of the matched string is 0, this function returns 1.

Příklady

Příklad 1687. eregi() example

<?php
$string = 'XYZ';
if (eregi('z', $string)) {
    echo "'$string' contains a 'z' or 'Z'!";
}
?>

Viz také

ereg()
ereg_replace()
eregi_replace()
stripos()
stristr()

Předcházející | Nahoru | Další
eregi_replace | Domů | split


split

(PHP 4, PHP 5)

split — Split string into array by regular expression

Popis

array split ( string $pattern, string $string [, int $limit] )

Splits a string into array by regular expression.

Seznam parametrů

pattern

Case sensitive regular expression.

If you want to split on any of the characters which are considered special by regular expressions, you'll need to escape them first. If you think split() (or any other regex function, for that matter) is doing something weird, please read the file regex.7, included in the regex/ subdirectory of the PHP distribution. It's in manpage format, so you'll want to do something along the lines of man /usr/local/src/regex/regex.7 in order to read it.

string

The input string.

limit

If limit is set, the returned array will contain a maximum of limit elements with the last element containing the whole rest of string.

Návratové hodnoty

Returns an array of strings, each of which is a substring of string formed by splitting it on boundaries formed by the case-sensitive regular expression pattern.

If there are n occurrences of pattern, the returned array will contain n+1 items. For example, if there is no occurrence of pattern, an array with only one element will be returned. Of course, this is also true if string is empty. If an error occurs, split() returns FALSE.

Příklady

Příklad 1688. split() example

To split off the first four fields from a line from /etc/passwd:

<?php
list($user, $pass, $uid, $gid, $extra) =
    split(":", $passwd_line, 5);
?>

Příklad 1689. split() example

To parse a date which may be delimited with slashes, dots, or hyphens:

<?php
// Delimiters may be slash, dot, or hyphen
$date = "04/30/1973";
list($month, $day, $year) = split('[/.-]', $date);
echo "Month: $month; Day: $day; Year: $year<br />\n";
?>

Poznámky

Tip

preg_split(), which uses a Perl-compatible regular expression syntax, is often a faster alternative to split(). If you don't require the power of regular expressions, it is faster to use explode(), which doesn't incur the overhead of the regular expression engine.

Tip

For users looking for a way to emulate Perl's @chars = split('', $str) behaviour, please see the examples for preg_split() or str_split().

Viz také

preg_split()
spliti()
str_split()
explode()
implode()
chunk_split()
wordwrap()

Předcházející | Nahoru | Další
eregi | Domů | spliti


spliti

(PHP 4 >= 4.0.1, PHP 5)

spliti — Split string into array by regular expression case insensitive

Popis

array spliti ( string $pattern, string $string [, int $limit] )

Splits a string into array by regular expression.

This function is identical to split() except that this ignores case distinction when matching alphabetic characters.

Seznam parametrů

pattern

Case insensitive regular expression.

If you want to split on any of the characters which are considered special by regular expressions, you'll need to escape them first. If you think spliti() (or any other regex function, for that matter) is doing something weird, please read the file regex.7, included in the regex/ subdirectory of the PHP distribution. It's in manpage format, so you'll want to do something along the lines of man /usr/local/src/regex/regex.7 in order to read it.

string

The input string.

limit

If limit is set, the returned array will contain a maximum of limit elements with the last element containing the whole rest of string.

Návratové hodnoty

Returns an array of strings, each of which is a substring of string formed by splitting it on boundaries formed by the case insensitive regular expression pattern.

If there are n occurrences of pattern, the returned array will contain n+1 items. For example, if there is no occurrence of pattern, an array with only one element will be returned. Of course, this is also true if string is empty. If an error occurs, spliti() returns FALSE.

Příklady

This example splits a string using 'a' as the separator :

Příklad 1690. spliti() example

<?php
$string = "aBBBaCCCADDDaEEEaGGGA";
$chunks = spliti ("a", $string, 5);
print_r($chunks);
?>

Výše uvedený příklad vypíše:

Array
(
  [0] =>
  [1] => BBB
  [2] => CCC
  [3] => DDD
  [4] => EEEaGGGA
)

Viz také

preg_split()
split()
explode()
implode()

Předcházející | Nahoru | Další
split | Domů | sql_regcase


sql_regcase

(PHP 4, PHP 5)

sql_regcase — Make regular expression for case insensitive match

Popis

string sql_regcase ( string $string )

Creates a regular expression for a case insensitive match.

Seznam parametrů

string

The input string.

Návratové hodnoty

Returns a valid regular expression which will match string, ignoring case. This expression is string with each alphabetic character converted to a bracket expression; this bracket expression contains that character's uppercase and lowercase form. Other characters remain unchanged.

Příklady

Příklad 1691. sql_regcase() example

<?php
echo sql_regcase("Foo - bar.");
?>

Výše uvedený příklad vypíše:

[Ff][Oo][Oo] - [Bb][Aa][Rr].

This can be used to achieve case insensitive pattern matching in products which support only case sensitive regular expressions.

Předcházející | Nahoru | Další
spliti | Domů | CXXVII. PostgreSQL Functions


Semaphore, Shared Memory and IPC Functions

Předcházející VI. Reference funkcí Další

CXLVI. Semaphore, Shared Memory and IPC Functions

Úvod

Toto rozšíření poskytuje rozhraní k rodině IPC funkcí Systemu V. To zahrnuje semafory, sdílenou paměť a meziprocesové zprávy (IPC).

Semafory se dají používat k poskytování exkluzivního přístupu k prostředkům na daném systému, nebo k omezení počtu procesů, které mohou současně používat určitý prostředek.

Toto rozšíření také poskytuje funkce pro práci se sdílenou pamětí využívající System V sdílenou paměť. Sdílená pmět se dá používat k poskytování přístupu ke globálním proměnným. Různí httpd-daemoni a dokonce i jiné programy (např. Perl, C, ...) mohou k těmto datům přistupovat, a vytvořit tak globální výměnu dat. Pamatujte, že sdílená paměť není chráněna proti simultáním přístupům. K synchronizaci použijte semafory.

Tabulka 265. Omezení sdílené paměti systémem Unix

SHMMAX | max. velikost sdílené paměti, normálně 131072 bytů
SHMMIN | min. velikost sdílené paměti, normálne 1 byte
SHMMNI | max. počet segmentů sdílené paměti, normálně 100
SHMSEG | max. počet segmentů sdílené paměti na proces, normálně 6

The messaging functions may be used to send and receive messages to/from other processes. They provide a simple and effective means of exchanging data between processes, without the need for setting up an alternative using unix domain sockets.

Poznámka: Toto rozšíření není k dispozici na platformách Windows.

Požadavky

Tyto funkce jsou k dispozici jako součást standardního modulu, který je vždy dostupný.

Instalace

Podpora těchto funkcí není ve výchozím nastavení zapnuta. Pro zapnutí podpory semaforů Systemu V zkompilujte PHP s volbou --enable-sysvsem. Pro zapnutí podpory sdílené paměti Systemu V zkompilujte PHP s volbou --enable-sysvshm. Pro zapnutí podpory zpráv Systemu V zkompilujte PHP s volbou --enable-sysvmsg.

Konfigurace běhu

Chování těchto funkcí je ovlivněno nastavením parametrů v php.ini.

Tabulka 266. Konfigura?ní volby pro Semaphore

Název | Výchozí hodnota | Lze zm?nit
sysvmsg.value | "42" | PHP_INI_ALL
sysvmsg.string | "foobar" | PHP_INI_ALL

Pro bli 3/4 ?í podrobnosti a definici PHP_INI_* konstant viz ini_set().

Typy prostředků

Předdefinované konstanty

Toto rozšíření nemá definovány žádné konstanty.

Obsah

ftok — Convert a pathname and a project identifier to a System V IPC key
msg_get_queue — Create or attach to a message queue
msg_receive — Receive a message from a message queue
msg_remove_queue — Destroy a message queue
msg_send — Send a message to a message queue
msg_set_queue — Set information in the message queue data structure
msg_stat_queue — Returns information from the message queue data structure
sem_acquire — Získat semafor
sem_get — Získat id semaforu
sem_release — Uvolnit semafor
sem_remove — Remove a semaphore
shm_attach — Vytvořit nebo otevřít segment sdílené paměti
shm_detach — Odpojit se od segmentu sdílené paměti
shm_get_var — Vrátit proměnnou ze sdílené paměti
shm_put_var — Vložit nebo modifikovat proměnnou do sdílené paměti
shm_remove_var — Odstranit proměnnou ze sdílené paměti
shm_remove — Odstranit sdílenou paměť ze systému
Předcházející | Nahoru | Další
SDO_DAS_Relational::executeQuery | Domů | ftok


ftok

(PHP 4 >= 4.2.0, PHP 5)

ftok — Convert a pathname and a project identifier to a System V IPC key

Popis

int ftok ( string $pathname, string $proj )

The function converts the pathname of an existing accessible file and a project identifier into an integer for use with for example shmop_open() and other System V IPC keys.

Seznam parametrů

pathname

Path to an accessible file.

proj

Project identifier. This must be a one character string.

Návratové hodnoty

On success the return value will be the created key value, otherwise -1 is returned.

Viz také

shmop_open()
sem_get()

Předcházející | Nahoru | Další
CXLVI. Semaphore, Shared Memory and IPC Functions | Domů | msg_get_queue


msg_get_queue

(PHP 4 >= 4.3.0, PHP 5)

msg_get_queue — Create or attach to a message queue

Popis

resource msg_get_queue ( int $key [, int $perms] )

msg_get_queue() returns an id that can be used to access the System V message queue with the given key. The first call creates the message queue with the optional perms. A second call to msg_get_queue() for the same key will return a different message queue identifier, but both identifiers access the same underlying message queue.

Seznam parametrů

key

perms

Queue permissions. Default to 0666. If the message queue already exists, the perms will be ignored.

Návratové hodnoty

Returns an id that can be used to access the System V message queue.

Viz také

msg_remove_queue()
msg_receive()
msg_send()
msg_stat_queue()
msg_set_queue()

Předcházející | Nahoru | Další
ftok | Domů | msg_receive


msg_receive

(PHP 4 >= 4.3.0, PHP 5)

msg_receive — Receive a message from a message queue

Popis

bool msg_receive ( resource $queue, int $desiredmsgtype, int &$msgtype, int $maxsize, mixed &$message [, bool $unserialize [, int $flags [, int &$errorcode]]] )

msg_receive() will receive the first message from the specified queue of the type specified by desiredmsgtype.

Seznam parametrů

queue

desiredmsgtype

If desiredmsgtype is 0, the message from the front of the queue is returned. If desiredmsgtype is greater than 0, then the first message of that type is returned. If desiredmsgtype is less than 0, the first message on the queue with the lowest type less than or equal to the absolute value of desiredmsgtype will be read. If no messages match the criteria, your script will wait until a suitable message arrives on the queue. You can prevent the script from blocking by specifying MSG_IPC_NOWAIT in the flags parameter.

msgtype

The type of the message that was received will be stored in this parameter.

maxsize

The maximum size of message to be accepted is specified by the maxsize; if the message in the queue is larger than this size the function will fail (unless you set flags as described below).

message

The received message will be stored in message, unless there were errors receiving the message.

unserialize

unserialize defaults to TRUE; if it is set to TRUE, the message is treated as though it was serialized using the same mechanism as the session module. The message will be unserialized and then returned to your script. This allows you to easily receive arrays or complex object structures from other PHP scripts, or if you are using the WDDX serializer, from any WDDX compatible source.

If unserialize is FALSE, the message will be returned as a binary-safe string.

flags

The optional flags allows you to pass flags to the low-level msgrcv system call. It defaults to 0, but you may specify one or more of the following values (by adding or ORing them together).

Tabulka 267. Flag values for msg_receive

MSG_IPC_NOWAIT | If there are no messages of the desiredmsgtype, return immediately and do not wait. The function will fail and return an integer value corresponding to MSG_ENOMSG.
MSG_EXCEPT | Using this flag in combination with a desiredmsgtype greater than 0 will cause the function to receive the first message that is not equal to desiredmsgtype.
MSG_NOERROR | If the message is longer than maxsize, setting this flag will truncate the message to maxsize and will not signal an error.

errorcode

If the function fails, the optional errorcode will be set to the value of the system errno variable.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Upon successful completion the message queue data structure is updated as follows: msg_lrpid is set to the process-ID of the calling process, msg_qnum is decremented by 1 and msg_rtime is set to the current time.

Viz také

msg_remove_queue()
msg_send()
msg_stat_queue()
msg_set_queue()

Předcházející | Nahoru | Další
msg_get_queue | Domů | msg_remove_queue


msg_remove_queue

(PHP 4 >= 4.3.0, PHP 5)

msg_remove_queue — Destroy a message queue

Popis

bool msg_remove_queue ( resource $queue )

msg_remove_queue() destroys the message queue specified by the queue. Only use this function when all processes have finished working with the message queue and you need to release the system resources held by it.

Seznam parametrů

queue

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

msg_get_queue()
msg_receive()
msg_stat_queue()
msg_set_queue()

Předcházející | Nahoru | Další
msg_receive | Domů | msg_send


msg_send

(PHP 4 >= 4.3.0, PHP 5)

msg_send — Send a message to a message queue

Popis

bool msg_send ( resource $queue, int $msgtype, mixed $message [, bool $serialize [, bool $blocking [, int &$errorcode]]] )

msg_send() sends a message of type msgtype (which MUST be greater than 0) to the message queue specified by queue.

Seznam parametrů

queue

msgtype

message

serialize

The optional serialize controls how the message is sent. serialize defaults to TRUE which means that the message is serialized using the same mechanism as the session module before being sent to the queue. This allows complex arrays and objects to be sent to other PHP scripts, or if you are using the WDDX serializer, to any WDDX compatible client.

blocking

If the message is too large to fit in the queue, your script will wait until another process reads messages from the queue and frees enough space for your message to be sent. This is called blocking; you can prevent blocking by setting the optional blocking parameter to FALSE, in which case msg_send() will immediately return FALSE if the message is too big for the queue, and set the optional errorcode to MSG_EAGAIN, indicating that you should try to send your message again a little later on.

errorcode

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Upon successful completion the message queue data structure is updated as follows: msg_lspid is set to the process-ID of the calling process, msg_qnum is incremented by 1 and msg_stime is set to the current time.

Viz také

msg_remove_queue()
msg_receive()
msg_stat_queue()
msg_set_queue()

Předcházející | Nahoru | Další
msg_remove_queue | Domů | msg_set_queue


msg_set_queue

(PHP 4 >= 4.3.0, PHP 5)

msg_set_queue — Set information in the message queue data structure

Popis

bool msg_set_queue ( resource $queue, array $data )

msg_set_queue() allows you to change the values of the msg_perm.uid, msg_perm.gid, msg_perm.mode and msg_qbytes fields of the underlying message queue data structure.

Changing the data structure will require that PHP be running as the same user that created the queue, owns the queue (as determined by the existing msg_perm.xxx fields), or be running with root privileges. root privileges are required to raise the msg_qbytes values above the system defined limit.

Seznam parametrů

queue

data

You specify the values you require by setting the value of the keys that you require in the data array.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

msg_remove_queue()
msg_receive()
msg_stat_queue()
msg_get_queue()

Předcházející | Nahoru | Další
msg_send | Domů | msg_stat_queue


msg_stat_queue

(PHP 4 >= 4.3.0, PHP 5)

msg_stat_queue — Returns information from the message queue data structure

Popis

array msg_stat_queue ( resource $queue )

msg_stat_queue() returns the message queue meta data for the message queue specified by the queue. This is useful, for example, to determine which process sent the message that was just received.

Seznam parametrů

queue

Návratové hodnoty

The return value is an array whose keys and values have the following meanings:

Tabulka 268. Array structure for msg_stat_queue

msg_perm.uid | The uid of the owner of the queue.
msg_perm.gid | The gid of the owner of the queue.
msg_perm.mode | The file access mode of the queue.
msg_stime | The time that the last message was sent to the queue.
msg_rtime | The time that the last message was received from the queue.
msg_ctime | The time that the queue was last changed.
msg_qnum | The number of messages waiting to be read from the queue.
msg_qbytes | The number of bytes of space currently available in the queue to hold sent messages until they are received.
msg_lspid | The pid of the process that sent the last message to the queue.
msg_lrpid | The pid of the process that received the last message from the queue.

Viz také

msg_remove_queue()
msg_receive()
msg_get_queue()
msg_set_queue()

Předcházející | Nahoru | Další
msg_set_queue | Domů | sem_acquire


sem_acquire

(PHP 4, PHP 5)

sem_acquire — Získat semafor

Popis

bool sem_acquire ( resource $sem_identifier )

Při úspěchu vrací TRUE, při chybě FALSE.

sem_acquire() blokuje (pokud je optřeba) až do získání semaforu. Proces pokoušející se získat semafor, který už získal bude blokovat navěky, pokud by získání tohoto semaforu způsobilo překročení jeho hodnoty max_acquire.

Po zpracování požadavku se všechny získané, ale explicitně neuvolněné semafoty uvolní automaticky, a vygeneruje se varování.

Viz také: sem_get() a sem_release().

Předcházející | Nahoru | Další
msg_stat_queue | Domů | sem_get


sem_get

(PHP 4, PHP 5)

sem_get — Získat id semaforu

Popis

resource sem_get ( int $key [, int $max_acquire [, int $perm [, int $auto_release]]] )

Vrací idenfifikátor semaforu nebo FALSE.

sem_get() vrací id, které se dá použít k přístupu k System V semaforu s daným klíčem. Podle potřeby se vytvoří nový semafor s přístupovými právy definovanými v perm (default je 0666). Počet procesů, které mohou tento semafor získat současně je max_acquire (default je 1). Tato hodnota je ale nastavena pouze pokud tento proces zjistí, že k tomuto semaforu není současně připojen jiný proces.

Druhé volání sem_get() se stejným key vrátí jiný identifikátor semaforu, ale oba identifikátory ukazují na stejný semafor.

Viz také: sem_acquire() a sem_release().

Poznámka: Tato funkce nefunguje na Windows.

Předcházející | Nahoru | Další
sem_acquire | Domů | sem_release


sem_release

(PHP 4, PHP 5)

sem_release — Uvolnit semafor

Popis

bool sem_release ( resource $sem_identifier )

Při úspěchu vrací TRUE, jinak FALSE.

sem_release() uvolňí semafor, pokud ho volající proces drží, jinak se vygeneruje varování.

Po uvolnění může být semafor znovu získán pomocí sem_acquire().

Viz také: sem_get() a sem_acquire().

Poznámka: Tato funkce nefunguje na Windows.

Předcházející | Nahoru | Další
sem_get | Domů | sem_remove


sem_remove

(PHP 4 >= 4.0.7, PHP 5)

sem_remove — Remove a semaphore

Popis

bool sem_remove ( resource $sem_identifier )

sem_remove() removes the given semaphore.

After removing the semaphore, it is no more accessible.

Seznam parametrů

sem_identifier

The semaphore identifier. Must have been created with sem_get(), otherwise a warning is generated.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

sem_get()
sem_release()
sem_acquire()

Předcházející | Nahoru | Další
sem_release | Domů | shm_attach


shm_attach

(PHP 4, PHP 5)

shm_attach — Vytvořit nebo otevřít segment sdílené paměti

Popis

int shm_attach ( int $key [, int $memsize [, int $perm]] )

shm_attach() vrací id, které se dá použít k přístupu k System V sdílené paměti s daným klíčem; první volání vytvoří segment paměti o velikosti mem_size (default: sysvshm.init_mem v konfiguračním souboru, jinak 10000 bytů) a s volitelnými právy (default: 0666).

Druhé volání shm_attach() se stejným key vrátí jiný identifikáto, ale oba ukazují na stejnou sdílenou paměť. memsize a perm se v takovém případě ignorují.

Poznámka: Tato funkce nefunguje na Windows.

Předcházející | Nahoru | Další
sem_remove | Domů | shm_detach


shm_detach

(PHP 4, PHP 5)

shm_detach — Odpojit se od segmentu sdílené paměti

Popis

bool shm_detach ( int $shm_identifier )

shm_detach() odpojuje od sdílené paměti identifikované shm_identifier vytvořeným shm_attach(). Pamatujte, že tato sdílená paměť dál existuje a drží si data.

Předcházející | Nahoru | Další
shm_attach | Domů | shm_get_var


shm_get_var

(PHP 4, PHP 5)

shm_get_var — Vrátit proměnnou ze sdílené paměti

Popis

mixed shm_get_var ( int $shm_identifier, int $variable_key )

shm_get_var() vrací proměnnou s daným variable_key. Proměnná zůstává ve sdílené paměti.

Poznámka: Tato funkce nefunguje na Windows.

Předcházející | Nahoru | Další
shm_detach | Domů | shm_put_var


shm_put_var

(PHP 4, PHP 5)

shm_put_var — Vložit nebo modifikovat proměnnou do sdílené paměti

Popis

bool shm_put_var ( int $shm_identifier, int $variable_key, mixed $variable )

Vloží nebo modifikuje variable s daným variable_key. Všechny typy proměnných (double, int, string, array) jsou podporovány.

Poznámka: Tato funkce nefunguje na Windows.

Předcházející | Nahoru | Další
shm_get_var | Domů | shm_remove_var


shm_remove_var

(PHP 4, PHP 5)

shm_remove_var — Odstranit proměnnou ze sdílené paměti

Popis

bool shm_remove_var ( int $shm_identifier, int $variable_key )

Odstraní proměnnou s danýmvariable_key a uvolní zabranou paměť.

Poznámka: Tato funkce nefunguje na Windows.

Předcházející | Nahoru | Další
shm_put_var | Domů | shm_remove


shm_remove

(PHP 4, PHP 5)

shm_remove — Odstranit sdílenou paměť ze systému

Popis

bool shm_remove ( int $shm_identifier )

Odstraní sdílenou paměť z UNIXového systému. Všechna data v ní budou zničena.

Poznámka: Tato funkce nefunguje na Windows.

Předcházející | Nahoru | Další
shm_remove_var | Domů | CXLVII. SESAM Database Functions


SESAM Database Functions

Předcházející VI. Reference funkcí Další

CXLVII. SESAM Database Functions

Úvod

SESAM/SQL-Server is a mainframe database system, developed by Fujitsu Siemens Computers, Germany. It runs on high-end mainframe servers using the operating system BS2000/OSD.

In numerous productive BS2000 installations, SESAM/SQL-Server has proven

  • the ease of use of Java-, Web- and client/server connectivity,
  • the capability to work with an availability of more than 99.99%,
  • the ability to manage tens and even hundreds of thousands of users.

There is a PHP 3 SESAM interface available which allows database operations via PHP-scripts.

Poznámka: Access to SESAM is only available with the latest CVS-Version of PHP 3. PHP 4 does not support the SESAM database.

Konfigurace běhu

Chování těchto funkcí je ovlivněno nastavením parametrů v php.ini.

sesam_oml string

Name of BS2000 PLAM library containing the loadable SESAM driver modules. Required for using SESAM functions. The BS2000 PLAM library must be set ACCESS=READ,SHARE=YES because it must be readable by the apache server's user id.

sesam_configfile string

Name of SESAM application configuration file. Required for using SESAM functions. The BS2000 file must be readable by the apache server's user id.

The application configuration file will usually contain a configuration like (see SESAM reference manual):

CNF=B
NAM=K
NOTYPE

sesam_messagecatalog string

Name of SESAM message catalog file. In most cases, this directive is not necessary. Only if the SESAM message file is not installed in the system's BS2000 message file table, it can be set with this directive.

The message catalog must be set ACCESS=READ,SHARE=YES because it must be readable by the apache server's user id.

Configuration notes

There is no standalone support for the PHP SESAM interface, it works only as an integrated Apache module. In the Apache PHP module, this SESAM interface is configured using Apache directives.

Tabulka 269. SESAM Configuration directives

Directive Meaning
php3_sesam_oml

Name of BS2000 PLAM library containing the loadable SESAM driver modules. Required for using SESAM functions.

Example:

php3_sesam_oml $.SYSLNK.SESAM-SQL.030

php3_sesam_configfile

Name of SESAM application configuration file. Required for using SESAM functions.

Example:

php3_sesam_configfile $SESAM.SESAM.CONF.AW

It will usually contain a configuration like (see SESAM reference manual):

CNF=B
NAM=K
NOTYPE

php3_sesam_messagecatalog

Name of SESAM message catalog file. In most cases, this directive is not necessary. Only if the SESAM message file is not installed in the system's BS2000 message file table, it can be set with this directive.

Example:

php3_sesam_messagecatalog $.SYSMES.SESAM-SQL.030

In addition to the configuration of the PHP/SESAM interface, you have to configure the SESAM-Database server itself on your mainframe as usual. That means:

  • starting the SESAM database handler (DBH), and
  • connecting the databases with the SESAM database handler

To get a connection between a PHP script and the database handler, the CNF and NAM parameters of the selected SESAM configuration file must match the id of the started database handler.

In case of distributed databases you have to start a SESAM/SQL-DCN agent with the distribution table including the host and database names.

The communication between PHP (running in the POSIX subsystem) and the database handler (running outside the POSIX subsystem) is realized by a special driver module called SQLSCI and SESAM connection modules using common memory. Because of the common memory access, and because PHP is a static part of the web server, database accesses are very fast, as they do not require remote accesses via ODBC, JDBC or UTM.

Only a small stub loader (SESMOD) is linked with PHP, and the SESAM connection modules are pulled in from SESAM's OML PLAM library. In the configuration, you must tell PHP the name of this PLAM library, and the file link to use for the SESAM configuration file (As of SESAM V3.0, SQLSCI is available in the SESAM Tool Library, which is part of the standard distribution).

Because the SQL command quoting for single quotes uses duplicated single quotes (as opposed to a single quote preceded by a backslash, used in some other databases), it is advisable to set the PHP configuration directives php3_magic_quotes_gpc and php3_magic_quotes_sybase to On for all PHP scripts using the SESAM interface.

Runtime considerations

Because of limitations of the BS2000 process model, the driver can be loaded only after the Apache server has forked off its server child processes. This will slightly slow down the initial SESAM request of each child, but subsequent accesses will respond at full speed.

When explicitly defining a Message Catalog for SESAM, that catalog will be loaded each time the driver is loaded (i.e., at the initial SESAM request). The BS2000 operating system prints a message after successful load of the message catalog, which will be sent to Apache's error_log file. BS2000 currently does not allow suppression of this message, it will slowly fill up the log.

Make sure that the SESAM OML PLAM library and SESAM configuration file are readable by the user id running the web server. Otherwise, the server will be unable to load the driver, and will not allow to call any SESAM functions. Also, access to the database must be granted to the user id under which the Apache server is running. Otherwise, connections to the SESAM database handler will fail.

Cursor Types

The result cursors which are allocated for SQL "select type" queries can be either "sequential" or "scrollable". Because of the larger memory overhead needed by "scrollable" cursors, the default is "sequential".

When using "scrollable" cursors, the cursor can be freely positioned on the result set. For each "scrollable" query, there are global default values for the scrolling type (initialized to: SESAM_SEEK_NEXT) and the scrolling offset which can either be set once by sesam_seek_row() or each time when fetching a row using sesam_fetch_row(). When fetching a row using a "scrollable" cursor, the following post-processing is done for the global default values for the scrolling type and scrolling offset:

Tabulka 270. Scrolled Cursor Post-Processing

Scroll Type | Action
SESAM_SEEK_NEXT | none
SESAM_SEEK_PRIOR | none
SESAM_SEEK_FIRST | set scroll type to SESAM_SEEK_NEXT
SESAM_SEEK_LAST | set scroll type to SESAM_SEEK_PRIOR
SESAM_SEEK_ABSOLUTE | Auto-Increment internal offset value
SESAM_SEEK_RELATIVE | none. (maintain global default offset value, which allows for, e.g., fetching each 10th row backwards)

Porting note

Because in the PHP world it is natural to start indexes at zero (rather than 1), some adaptions have been made to the SESAM interface: whenever an indexed array is starting with index 1 in the native SESAM interface, the PHP interface uses index 0 as a starting point. E.g., when retrieving columns with sesam_fetch_row(), the first column has the index 0, and the subsequent columns have indexes up to (but not including) the column count ($array["count"]). When porting SESAM applications from other high level languages to PHP, be aware of this changed interface. Where appropriate, the description of the respective PHP sesam functions include a note that the index is zero based.

Security concerns

When allowing access to the SESAM databases, the web server user should only have as little privileges as possible. For most databases, only read access privilege should be granted. Depending on your usage scenario, add more access rights as you see fit. Never allow full control to any database for any user from the 'net! Restrict access to PHP scripts which must administer the database by using password control and/or SSL security.

Migration from other SQL databases

No two SQL dialects are ever 100% compatible. When porting SQL applications from other database interfaces to SESAM, some adaption may be required. The following typical differences should be noted:

  • Vendor specific data types

    Some vendor specific data types may have to be replaced by standard SQL data types (e.g., TEXT could be replaced by VARCHAR(max. size)).

  • Keywords as SQL identifiers

    In SESAM (as in standard SQL), such identifiers must be enclosed in double quotes (or renamed).

  • Display length in data types

    SESAM data types have a precision, not a display length. Instead of int(4) (intended use: integers up to '9999'), SESAM requires simply int for an implied size of 31 bits. Also, the only datetime data types available in SESAM are: DATE, TIME(3) and TIMESTAMP(3).

  • SQL types with vendor-specific unsigned, zerofill, or auto_increment attributes

    Unsigned and zerofill are not supported. Auto_increment is automatic (use "INSERT ... VALUES(*, ...)" instead of "... VALUES(0, ...)" to take advantage of SESAM-implied auto-increment.

  • int ... DEFAULT '0000'

    Numeric variables must not be initialized with string constants. Use DEFAULT 0 instead. To initialize variables of the datetime SQL data types, the initialization string must be prefixed with the respective type keyword, as in: CREATE TABLE exmpl ( xtime timestamp(3) DEFAULT TIMESTAMP '1970-01-01 00:00:00.000' NOT NULL );

  • $count = xxxx_num_rows();

    Some databases promise to guess/estimate the number of the rows in a query result, even though the returned value is grossly incorrect. SESAM does not know the number of rows in a query result before actually fetching them. If you REALLY need the count, try SELECT COUNT(...) WHERE ..., it will tell you the number of hits. A second query will (hopefully) return the results.

  • DROP TABLE thename;

    In SESAM, in the DROP TABLE command, the table name must be either followed by the keyword RESTRICT or CASCADE. When specifying RESTRICT, an error is returned if there are dependent objects (e.g., VIEWs), while with CASCADE, dependent objects will be deleted along with the specified table.

Notes on the use of various SQL types

SESAM does not currently support the BLOB type. A future version of SESAM will have support for BLOB.

At the PHP interface, the following type conversions are automatically applied when retrieving SQL fields:

Tabulka 271. SQL to PHP Type Conversions

SQL Type | PHP Type
SMALLINT, INTEGER | integer
NUMERIC, DECIMAL, FLOAT, REAL, DOUBLE | float
DATE, TIME, TIMESTAMP | string
VARCHAR, CHARACTER | string

When retrieving a complete row, the result is returned as an array. Empty fields are not filled in, so you will have to check for the existence of the individual fields yourself (use isset() or empty() to test for empty fields). That allows more user control over the appearance of empty fields (than in the case of an empty string as the representation of an empty field).

Support of SESAM's "multiple fields" feature

The special "multiple fields" feature of SESAM allows a column to consist of an array of fields. Such a "multiple field" column can be created like this:

Příklad 1992. Creating a "multiple field" column

CREATE TABLE multi_field_test (
    pkey CHAR(20) PRIMARY KEY,
    multi(3) CHAR(12)
)

and can be filled in using:

Příklad 1993. Filling a "multiple field" column

INSERT INTO multi_field_test (pkey, multi(2..3) )
    VALUES ('Second', <'first_val', 'second_val'>)

Note that (like in this case) leading empty sub-fields are ignored, and the filled-in values are collapsed, so that in the above example the result will appear as multi(1..2) instead of multi(2..3).

When retrieving a result row, "multiple columns" are accessed like "inlined" additional columns. In the example above, "pkey" will have the index 0, and the three "multi(1..3)" columns will be accessible as indices 1 through 3.

Viz také

For specific SESAM details, please refer to » the SESAM/SQL-Server documentation (english) or » the SESAM/SQL-Server documentation (german), both available online, or use the respective manuals.

Obsah

sesam_affected_rows — Get number of rows affected by an immediate query
sesam_commit — Commit pending updates to the SESAM database
sesam_connect — Open SESAM database connection
sesam_diagnostic — Return status information for last SESAM call
sesam_disconnect — Detach from SESAM connection
sesam_errormsg — Returns error message of last SESAM call
sesam_execimm — Execute an "immediate" SQL-statement
sesam_fetch_array — Fetch one row as an associative array
sesam_fetch_result — Return all or part of a query result
sesam_fetch_row — Fetch one row as an array
sesam_field_array — Return meta information about individual columns in a result
sesam_field_name — Return one column name of the result set
sesam_free_result — Releases resources for the query
sesam_num_fields — Return the number of fields/columns in a result set
sesam_query — Perform a SESAM SQL query and prepare the result
sesam_rollback — Discard any pending updates to the SESAM database
sesam_seek_row — Set scrollable cursor mode for subsequent fetches
sesam_settransaction — Set SESAM transaction parameters
Předcházející | Nahoru | Další
shm_remove | Domů | sesam_affected_rows


sesam_affected_rows

(No version information available, might be only in CVS)

sesam_affected_rows — Get number of rows affected by an immediate query

Popis

int sesam_affected_rows ( string $result_id )

Gets the number of rows affected by an immediate query.

The sesam_affected_rows() function can only return useful values when used in combination with "immediate" SQL statements (updating operations like INSERT, UPDATE and DELETE) because SESAM does not deliver any "affected rows" information for "select type" queries.

Seznam parametrů

result_id

A valid result id returned by sesam_query().

Návratové hodnoty

Returns the number of rows affected by a query associated with result_id.

Příklady

Příklad 1994. sesam_affected_rows() example

<?php
$result = sesam_execimm("DELETE FROM PHONE WHERE LASTNAME = '" . strtoupper($name) . "'");
if (!$result) {
    /* ... error ... */
}
echo sesam_affected_rows($result).
    " entries with last name " . $name . " deleted.\n";
?>

Viz také

sesam_query()
sesam_execimm()

Předcházející | Nahoru | Další
CXLVII. SESAM Database Functions | Domů | sesam_commit


sesam_commit

(No version information available, might be only in CVS)

sesam_commit — Commit pending updates to the SESAM database

Popis

bool sesam_commit ( void )

Commits any pending updates to the database.

Note that there is no "auto-commit" feature as in other databases, as it could lead to accidental data loss. Uncommitted data at the end of the current script (or when calling sesam_disconnect()) will be discarded by an implied sesam_rollback() call.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1995. Committing an update to the SESAM database

<?php
if (sesam_connect ("mycatalog", "myschema", "otto")) {
    if (!sesam_execimm ("INSERT INTO mytable VALUES (*, 'Small Test', <0, 8, 15>)"))
        die("insert failed");
    if (!sesam_commit())
        die("commit failed");
}
?>

Viz také

sesam_rollback()

Předcházející | Nahoru | Další
sesam_affected_rows | Domů | sesam_connect


sesam_connect

(No version information available, might be only in CVS)

sesam_connect — Open SESAM database connection

Popis

bool sesam_connect ( string $catalog, string $schema, string $user )

Establishes a connection to a SESAM database handler task. The connection is always "persistent" in the sense that only the very first invocation will actually load the driver from the configured SESAM OML PLAM library. Subsequent calls will reuse the driver and will immediately use the given catalog, schema, and user.

Seznam parametrů

catalog

When creating a database, the "catalog" name is specified in the SESAM configuration directive //ADD-SQL-DATABASE-CATALOG-LIST ENTRY-1 = *CATALOG(CATALOG-NAME = catalogname,...)

schema

The schema references the desired database schema (see SESAM handbook).

user

The "user" argument references one of the users which are allowed to access this "catalog" / "schema" combination. Note that "user" is completely independent from both the system's user id's and from HTTP user/password protection. It appears in the SESAM configuration only.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1996. Connect to a SESAM database

<?php
if (!sesam_connect ("mycatalog", "myschema", "otto")) {
    die("Unable to connect to SESAM");
}
?>

Viz také

sesam_disconnect()

Předcházející | Nahoru | Další
sesam_commit | Domů | sesam_diagnostic


sesam_diagnostic

(No version information available, might be only in CVS)

sesam_diagnostic — Return status information for last SESAM call

Popis

array sesam_diagnostic ( void )

Returns status information for last SESAM call.

Návratové hodnoty

Returns an associative array of status and return codes for the last SQL query/statement/command. Elements of the array are:

Tabulka 272. Status information returned by sesam_diagnostic()

Element | Contents
$array["sqlstate"] | 5 digit SQL return code (see the SESAM manual for the description of the possible values of SQLSTATE)
$array["rowcount"] | number of affected rows in last update/insert/delete (set after "immediate" statements only)
$array["errmsg"] | "human readable" error message string (set after errors only)
$array["errcol"] | error column number of previous error (0-based; or -1 if undefined. Set after errors only)
$array["errlin"] | error line number of previous error (0-based; or -1 if undefined. Set after errors only)

Příklady

In the following example, a syntax error (E SEW42AE ILLEGAL CHARACTER) is displayed by including the offending SQL statement and pointing to the error location:

Příklad 1997. Displaying SESAM error messages with error position

<?php
// Function which prints a formatted error message,
// displaying a pointer to the syntax error in the
// SQL statement
function PrintReturncode($exec_str)
{
    $err = Sesam_Diagnostic();
    $colspan=4; // 4 cols for: sqlstate, errlin, errcol, rowcount
    if ($err["errlin"] == -1)
        --$colspan;
    if ($err["errcol"] == -1)
        --$colspan;
    if ($err["rowcount"] == 0)
        --$colspan;
    echo "<table border=\"1\">\n";
    echo "<tr><th colspan=\"" . $colspan . "\"><span class=\"spanred\">ERROR:</span> ".
         htmlspecialchars($err["errmsg"]) . "</th></tr>\n";
    if ($err["errcol"] >= 0) {
        echo "<tr><td colspan=\"" . $colspan . "\"><pre>\n";
        $errstmt = $exec_str . "\n";
        for ($lin=0; $errstmt != ""; ++$lin) {
            if ($lin != $err["errlin"]) { // $lin is less or greater than errlin
                if (!($i = strchr($errstmt, "\n")))
                    $i = "";
                $line = substr ($errstmt, 0, strlen($errstmt)-strlen($i)+1);
                $errstmt = substr($i, 1);
                if ($line != "\n")
                    echo htmlspecialchars($line);
            } else {
                if (! ($i = strchr ($errstmt, "\n")))
                    $i = "";
                $line = substr ($errstmt, 0, strlen ($errstmt)-strlen($i)+1);
                $errstmt = substr($i, 1);
                for ($col=0; $col < $err["errcol"]; ++$col) {
                    echo (substr($line, $col, 1) == "\t") ? "\t" : ".";
                }
                echo "<span class=\"spanred\">\\</span>\n";
                echo "<span class=\"normal\">" . htmlspecialchars($line) . "</span>";
                for ($col=0; $col < $err["errcol"]; ++$col) {
                    echo (substr ($line, $col, 1) == "\t") ? "\t" : ".";
                }
                echo "<span class=\"spanred\">/</span>\n";
            }
        }
        echo "</pre></td></tr>\n";
    }
    echo "<tr>\n";
    echo " <td>sqlstate=" . $err["sqlstate"] . "</td>\n";
    if ($err["errlin"] != -1)
        echo " <td>errlin=" . $err["errlin"] . "</td>\n";
    if ($err["errcol"] != -1)
        echo " <td>errcol=" . $err["errcol"] . "</td>\n";
    if ($err["rowcount"] != 0)
         echo " <td>rowcount=" . $err["rowcount"] . "</td>\n";
    echo "</tr>\n";
    echo "</table>\n";
}

if (!sesam_connect ("mycatalog", "phoneno", "otto"))
  die ("cannot connect");

$stmt = "SELECT * FROM phone\n" .
        " WHERE@ LASTNAME='KRAEMER'\n" .
        " ORDER BY FIRSTNAME";
if (!($result = sesam_query ($stmt)))
    PrintReturncode ($stmt);
?>

Viz také

sesam_errormsg()

Předcházející | Nahoru | Další
sesam_connect | Domů | sesam_disconnect


sesam_disconnect

(No version information available, might be only in CVS)

sesam_disconnect — Detach from SESAM connection

Popis

bool sesam_disconnect ( void )

Closes the logical link to a SESAM database (without actually disconnecting and unloading the driver).

Note that this isn't usually necessary, as the open connection is automatically closed at the end of the script's execution. Uncommitted data will be discarded, because an implicit sesam_rollback() is executed.

sesam_disconnect() will not close the persistent link, it will only invalidate the currently defined "catalog", "schema" and "user" triple, so that any sesam function called after sesam_disconnect() will fail.

Návratové hodnoty

Always returns TRUE.

Příklady

Příklad 1998. Closing a SESAM connection

<?php
if (sesam_connect ("mycatalog", "myschema", "otto")) {
    /* ... some queries and stuff ... */
    sesam_disconnect();
}
?>

Viz také

sesam_connect()

Předcházející | Nahoru | Další
sesam_diagnostic | Domů | sesam_errormsg


sesam_errormsg

(No version information available, might be only in CVS)

sesam_errormsg — Returns error message of last SESAM call

Popis

string sesam_errormsg ( void )

Gets the SESAM error message associated with the most recent SESAM error.

Návratové hodnoty

Returns the SESAM error message associated with the most recent SESAM error. An empty string means no errors.

Příklady

Příklad 1999. sesam_errormsg() example

<?php
if (!sesam_execimm($stmt)) {
  echo sesam_errormsg() . "<br />\n";
}
?>

Viz také

sesam_diagnostic()

Předcházející | Nahoru | Další
sesam_disconnect | Domů | sesam_execimm


sesam_execimm

(No version information available, might be only in CVS)

sesam_execimm — Execute an "immediate" SQL-statement

Popis

string sesam_execimm ( string $query )

Executes an "immediate" statement.

Sets the affected_rows value for retrieval by the sesam_affected_rows() function.

Note that sesam_query() can handle both "immediate" and "select-type" queries. Use sesam_execimm() only if you know beforehand what type of statement will be executed. An attempt to use SELECT type queries with sesam_execimm() will return $err["sqlstate"] == "42SBW".

Seznam parametrů

query

An "immediate" statement (i.e., a statement like UPDATE, INSERT or DELETE which returns no result, and has no INPUT or OUTPUT variables). "select type" queries can not be used with sesam_execimm().

Návratové hodnoty

Returns a SESAM result identifier on success, or FALSE on error.

The returned "result identifier" can not be used for retrieving anything but the sesam_affected_rows(); it is only returned for symmetry with the sesam_query() function.

Příklady

Příklad 2000. sesam_execimm() Example

<?php
$stmt = "INSERT INTO mytable VALUES ('one', 'two')";
$result = sesam_execimm($stmt);
$err = sesam_diagnostic();
echo "sqlstate = " . $err["sqlstate"] . "\n".
       "Affected rows = " . $err["rowcount"] . " == " .
       sesam_affected_rows($result) . "\n";
?>

Viz také

sesam_query()
sesam_affected_rows()

Předcházející | Nahoru | Další
sesam_errormsg | Domů | sesam_fetch_array


sesam_fetch_array

(No version information available, might be only in CVS)

sesam_fetch_array — Fetch one row as an associative array

Popis

array sesam_fetch_array ( string $result_id [, int $whence [, int $offset]] )

sesam_fetch_array() is an alternative version of sesam_fetch_row(). Instead of storing the data in the numeric indices of the result array, it stores the data in associative indices, using the field names as keys.

sesam_fetch_array() fetches one row of data from the result associated with the specified result identifier. The row is returned as an associative array. Each result column is stored with an associative index equal to its column (aka. field) name. The column names are converted to lower case.

Columns without a field name (e.g., results of arithmetic operations) and empty fields are not stored in the array. Also, if two or more columns of the result have the same column names, the later column will take precedence. In this situation, either call sesam_fetch_row() or make an alias for the column.

SELECT TBL1.COL AS FOO, TBL2.COL AS BAR FROM TBL1, TBL2

A special handling allows fetching "multiple field" columns (which would otherwise all have the same column names). For each column of a "multiple field", the index name is constructed by appending the string "(n)" where n is the sub-index of the multiple field column, ranging from 1 to its declared repetition factor. The indices are NOT zero based, in order to match the nomenclature used in the respective query syntax. For a column declared as:

CREATE TABLE ... ( ... MULTI(3) INT )
the associative indices used for the individual "multiple field" columns would be "multi(1)", "multi(2)", and "multi(3)" respectively.

Subsequent calls to sesam_fetch_array() would return the next (or prior, or n'th next/prior, depending on the scroll attributes) row in the result set, or FALSE if there are no more rows.

Seznam parametrů

result_id

A valid result id returned by sesam_query().

whence

whence is an optional parameter for a fetch operation on "scrollable" cursors, which can be set to the following predefined constants:

Tabulka 273. Valid values for "whence" parameter

Value | Constant | Meaning
0 | SESAM_SEEK_NEXT | read sequentially (after fetch, the internal default is set to SESAM_SEEK_NEXT)
1 | SESAM_SEEK_PRIOR | read sequentially backwards (after fetch, the internal default is set to SESAM_SEEK_PRIOR)
2 | SESAM_SEEK_FIRST | rewind to first row (after fetch, the default is set to SESAM_SEEK_NEXT)
3 | SESAM_SEEK_LAST | seek to last row (after fetch, the default is set to SESAM_SEEK_PRIOR)
4 | SESAM_SEEK_ABSOLUTE | seek to absolute row number given as offset (Zero-based. After fetch, the internal default is set to SESAM_SEEK_ABSOLUTE, and the internal offset value is auto-incremented)
5 | SESAM_SEEK_RELATIVE | seek relative to current scroll position, where offset can be a positive or negative offset value.

This parameter is only valid for "scrollable" cursors.

When using "scrollable" cursors, the cursor can be freely positioned on the result set. If the whence parameter is omitted, the global default values for the scrolling type (initialized to: SESAM_SEEK_NEXT, and settable by sesam_seek_row()) are used. If whence is supplied, its value replaces the global default.

offset

Only evaluated (and required) if whence is either SESAM_SEEK_RELATIVE or SESAM_SEEK_ABSOLUTE. This parameter is only valid for "scrollable" cursors.

Návratové hodnoty

Returns an array that corresponds to the fetched row, or FALSE if there are no more rows.

Příklady

Příklad 2001. SESAM fetch array

<?php
$result = sesam_query("SELECT * FROM phone\n" .
                       "  WHERE LASTNAME='" . strtoupper($name) . "'\n".
                       "  ORDER BY FIRSTNAME", 1);
if (!$result) {
    /* ... error ... */
}
// print the table:
echo "<table border=\"1\">\n";
while (($row = sesam_fetch_array($result)) && count($row) > 0) {
    echo "<tr>\n";
    echo "<td>" . htmlspecialchars($row["firstname"]) . "</td>\n";
    echo "<td>" . htmlspecialchars($row["lastname"]) . "</td>\n";
    echo "<td>" . htmlspecialchars($row["phoneno"]) . "</td>\n";
    echo "</tr>\n";
}
echo "</table>\n";
sesam_free_result($result);
?>

Viz také

sesam_fetch_row()

Předcházející | Nahoru | Další
sesam_execimm | Domů | sesam_fetch_result


sesam_fetch_result

(No version information available, might be only in CVS)

sesam_fetch_result — Return all or part of a query result

Popis

mixed sesam_fetch_result ( string $result_id [, int $max_rows] )

Fetches a result, optionally limited to max_rows.

Seznam parametrů

result_id

A valid result id returned by sesam_query().

max_rows

Note that the amount of memory used up by a large query may be gigantic. Use the max_rows parameter to limit the maximum number of rows returned, unless you are absolutely sure that your result will not use up all available memory.

Návratové hodnoty

Returns a mixed array with the query result entries, optionally limited to a maximum of max_rows rows. Note that both row and column indexes are zero-based.

Tabulka 274. Mixed result set returned by sesam_fetch_result()

Array Element | Contents
int $arr["count"] | number of columns in result set (or zero if this was an "immediate" query)
int $arr["rows"] | number of rows in result set (between zero and max_rows)
bool $arr["truncated"] | TRUE if the number of rows was at least max_rows, FALSE otherwise. Note that even when this is TRUE, the next sesam_fetch_result() call may return zero rows because there are no more result entries.
mixed $arr[col][row] | result data for all the fields at row(row) and column(col), (where the integer index row is between 0 and $arr["rows"]-1, and col is between 0 and $arr["count"]-1). Fields may be empty, so you must check for the existence of a field by using the php isset() function. The type of the returned fields depend on the respective SQL type declared for its column (see SESAM overview for the conversions applied). SESAM "multiple fields" are "inlined" and treated like a sequence of columns.

Viz také

sesam_fetch_array()
sesam_fetch_row()
sesam_query()

Předcházející | Nahoru | Další
sesam_fetch_array | Domů | sesam_fetch_row


sesam_fetch_row

(No version information available, might be only in CVS)

sesam_fetch_row — Fetch one row as an array

Popis

array sesam_fetch_row ( string $result_id [, int $whence [, int $offset]] )

Fetches one row of data from the result associated with the specified result identifier. The row is returned as an array (indexed by values between 0 and $array["count"]-1). Fields may be empty, so you must check for the existence of a field by using the isset() function. The type of the returned fields depend on the respective SQL type declared for its column (see SESAM overview for the conversions applied). SESAM "multiple fields" are "inlined" and treated like a sequence of columns.

The number of columns in the result set is returned in an associative array element $array["count"]. Because some of the result columns may be empty, the count() function can not be used on the result row returned by sesam_fetch_row().

Subsequent calls to sesam_fetch_row() would return the next (or prior, or n'th next/prior, depending on the scroll attributes) row in the result set, or FALSE if there are no more rows.

Seznam parametrů

result_id

A valid result id returned by sesam_query().

whence

whence is an optional parameter for a fetch operation on "scrollable" cursors, which can be set to the following predefined constants:

Tabulka 275. Valid values for "whence" parameter

Value | Constant | Meaning
0 | SESAM_SEEK_NEXT | read sequentially (after fetch, the internal default is set to SESAM_SEEK_NEXT)
1 | SESAM_SEEK_PRIOR | read sequentially backwards (after fetch, the internal default is set to SESAM_SEEK_PRIOR)
2 | SESAM_SEEK_FIRST | rewind to first row (after fetch, the default is set to SESAM_SEEK_NEXT)
3 | SESAM_SEEK_LAST | seek to last row (after fetch, the default is set to SESAM_SEEK_PRIOR)
4 | SESAM_SEEK_ABSOLUTE | seek to absolute row number given as offset (Zero-based. After fetch, the internal default is set to SESAM_SEEK_ABSOLUTE, and the internal offset value is auto-incremented)
5 | SESAM_SEEK_RELATIVE | seek relative to current scroll position, where offset can be a positive or negative offset value.

This parameter is only valid for "scrollable" cursors.

When using "scrollable" cursors, the cursor can be freely positioned on the result set. If the whence parameter is omitted, the global default values for the scrolling type (initialized to: SESAM_SEEK_NEXT, and settable by sesam_seek_row()) are used. If whence is supplied, its value replaces the global default.

offset

Only evaluated (and required) if whence is either SESAM_SEEK_RELATIVE or SESAM_SEEK_ABSOLUTE. This parameter is only valid for "scrollable" cursors.

Návratové hodnoty

Returns an array that corresponds to the fetched row, or FALSE if there are no more rows.

Příklady

Příklad 2002. SESAM fetch rows

<?php
$result = sesam_query("SELECT * FROM phone\n" .
                       "  WHERE LASTNAME='" . strtoupper($name) . "'\n" .
                       "  ORDER BY FIRSTNAME", 1);
if (!$result) {
    /* ... error ... */
}
// print the table in backward order
echo "<table border=\"1\">\n";
$row = sesam_fetch_row($result, SESAM_SEEK_LAST);
while (is_array($row)) {
    echo "<tr>\n";
    for ($col = 0; $col < $row["count"]; ++$col) {
        echo "<td>" . htmlspecialchars($row[$col]) . "</td>\n";
    }
    echo "</tr>\n";
    // use implied SESAM_SEEK_PRIOR
    $row = sesam_fetch_row($result);
}
echo "</table>\n";
sesam_free_result($result);
?>

Viz také

sesam_fetch_array()
sesam_fetch_result()

Předcházející | Nahoru | Další
sesam_fetch_result | Domů | sesam_field_array


sesam_field_array

(No version information available, might be only in CVS)

sesam_field_array — Return meta information about individual columns in a result

Popis

array sesam_field_array ( string $result_id )

Returns a mixed associative/indexed array with meta information (column name, type, precision, ...) about individual columns of the result after the query associated with result_id.

Seznam parametrů

result_id

A valid result id returned by sesam_query().

Návratové hodnoty

Tabulka 276. Mixed result set returned by sesam_field_array()

Array Element | Contents
int $arr["count"] | Total number of columns in result set (or zero if this was an "immediate" query). SESAM "multiple fields" are "inlined" and treated like the respective number of columns.
string $arr[col]["name"] | column name for column(col), where col is between 0 and $arr["count"]-1. The returned value can be the empty string (for dynamically computed columns). SESAM "multiple fields" are "inlined" and treated like the respective number of columns, each with the same column name.
string $arr[col]["count"] | The "count" attribute describes the repetition factor when the column has been declared as a "multiple field". Usually, the "count" attribute is 1. The first column of a "multiple field" column however contains the number of repetitions (the second and following column of the "multiple field" contain a "count" attribute of 1). This can be used to detect "multiple fields" in the result set. See the example shown in the sesam_query() description for a sample use of the "count" attribute.
string $arr[col]["type"]

PHP variable type of the data for column(col), where col is between 0 and $arr["count"]-1. The returned value can be one of

  • integer
  • float
  • string

depending on the SQL type of the result. SESAM "multiple fields" are "inlined" and treated like the respective number of columns, each with the same PHP type.

string $arr[col]["sqltype"]

SQL variable type of the column data for column(col), where col is between 0 and $arr["count"]-1. The returned value can be one of

  • "CHARACTER"
  • "VARCHAR"
  • "NUMERIC"
  • "DECIMAL"
  • "INTEGER"
  • "SMALLINT"
  • "FLOAT"
  • "REAL"
  • "DOUBLE"
  • "DATE"
  • "TIME"
  • "TIMESTAMP"

describing the SQL type of the result. SESAM "multiple fields" are "inlined" and treated like the respective number of columns, each with the same SQL type.

string $arr[col]["length"] | The SQL "length" attribute of the SQL variable in column(col), where col is between 0 and $arr["count"]-1. The "length" attribute is used with "CHARACTER" and "VARCHAR" SQL types to specify the (maximum) length of the string variable. SESAM "multiple fields" are "inlined" and treated like the respective number of columns, each with the same length attribute.
string $arr[col]["precision"] | The "precision" attribute of the SQL variable in column(col), where col is between 0 and $arr["count"]-1. The "precision" attribute is used with numeric and time data types. SESAM "multiple fields" are "inlined" and treated like the respective number of columns, each with the same precision attribute.
string $arr[col]["scale"] | The "scale" attribute of the SQL variable in column(col), where col is between 0 and $arr["count"]-1. The "scale" attribute is used with numeric data types. SESAM "multiple fields" are "inlined" and treated like the respective number of columns, each with the same scale attribute.

Viz také

sesam_query()

Předcházející | Nahoru | Další
sesam_fetch_row | Domů | sesam_field_name


sesam_field_name

(No version information available, might be only in CVS)

sesam_field_name — Return one column name of the result set

Popis

int sesam_field_name ( string $result_id, int $index )

Gets the field name.

Seznam parametrů

result_id

A valid result id returned by sesam_query().

index

The column index is zero-based, not one-based as in SESAM.

Návratové hodnoty

Returns the name of a field in the result set, or FALSE on error.

For "immediate" queries, or for dynamic columns, an empty string is returned.

Viz také

sesam_field_array(). It provides an easier interface to access the column names and types, and allows for detection of "multiple fields".

Předcházející | Nahoru | Další
sesam_field_array | Domů | sesam_free_result


sesam_free_result

(No version information available, might be only in CVS)

sesam_free_result — Releases resources for the query

Popis

bool sesam_free_result ( string $result_id )

Releases resources for the query.

Seznam parametrů

result_id

A valid result id returned by sesam_query().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
sesam_field_name | Domů | sesam_num_fields


sesam_num_fields

(No version information available, might be only in CVS)

sesam_num_fields — Return the number of fields/columns in a result set

Popis

int sesam_num_fields ( string $result_id )

After calling sesam_query() with a "select type" query, this function gives you the number of columns in the result.

For "immediate" statements, the value zero is returned. The SESAM "multiple field" columns count as their respective dimension, i.e., a three-column "multiple field" counts as three columns.

Seznam parametrů

result_id

A valid result id returned by sesam_query().

Návratové hodnoty

Returns an integer describing the total number of columns (aka. fields) in the current result_id result set or FALSE on error.

Viz také

sesam_query()
sesam_field_array() for a way to distinguish between "multiple field" columns and regular columns.

Předcházející | Nahoru | Další
sesam_free_result | Domů | sesam_query


sesam_query

(No version information available, might be only in CVS)

sesam_query — Perform a SESAM SQL query and prepare the result

Popis

string sesam_query ( string $query [, bool $scrollable] )

sesam_query() sends a query to the currently active database on the server. It can execute both "immediate" SQL statements and "select type" queries. If an "immediate" statement is executed, then no cursor is allocated, and any subsequent sesam_fetch_row() or sesam_fetch_result() call will return an empty result (zero columns, indicating end-of-result).

When using "scrollable" cursors, the cursor can be freely positioned on the result set. For each "scrollable" query, there are global default values for the scrolling type (initialized to: SESAM_SEEK_NEXT) and the scrolling offset which can either be set once by sesam_seek_row() or each time when fetching a row using sesam_fetch_row().

For "immediate" statements, the number of affected rows is saved for retrieval by the sesam_affected_rows() function.

Seznam parametrů

query

The query statement.

scrollable

For "select type" statements, a result descriptor and a (scrollable or sequential, depending on the optional boolean scrollable parameter) cursor will be allocated. If scrollable is omitted, the cursor will be sequential.

Návratové hodnoty

Returns a SESAM "result identifier" on success, or FALSE on error. This result id is used by the other functions.

Příklady

Příklad 2003. Show all rows of the "phone" table as a HTML table

<?php
if (!sesam_connect("phonedb", "demo", "otto"))
    die("cannot connect");
$result = sesam_query("select * from phone");
if (!$result) {
    $err = sesam_diagnostic();
    die ($err["errmsg"]);
}
echo "<table border>\n";
// Add title header with column names above the result:
if ($cols = sesam_field_array($result)) {
    echo "<tr><th colspan=" . $cols["count"] . ">Result:</th></tr>\n";
    echo "<tr>\n";
    for ($col = 0; $col < $cols["count"]; ++$col) {
        $colattr = $cols[$col];
        /* Span the table head over SESAM's "Multiple Fields": */
        if ($colattr["count"] > 1) {
            echo "<th colspan=\"" . $colattr["count"] . "\">" . $colattr["name"] .
                "(1.." . $colattr["count"] . ")</th>\n";
            $col += $colattr["count"] - 1;
        } else
            echo "<th>" . $colattr["name"] . "</th>\n";
    }
    echo "</tr>\n";
}

do {
    // Fetch the result in chunks of 100 rows max.
    $ok = sesam_fetch_result($result, 100);
    for ($row=0; $row < $ok["rows"]; ++$row) {
        echo " <tr>\n";
        for ($col = 0; $col < $ok["cols"]; ++$col) {
            if (isset($ok[$col][$row])) {
                echo "<td>" . $ok[$col][$row] . "</td>\n";
            } else {
                echo "<td>-empty-</td>\n";
            }
        }
        echo "</tr>\n";
    }
} while ($ok["truncated"]); // while there may be more data

echo "</table>\n";
// free result id
sesam_free_result($result);
?>

Viz také

sesam_fetch_row()
sesam_fetch_result()

Předcházející | Nahoru | Další
sesam_num_fields | Domů | sesam_rollback


sesam_rollback

(No version information available, might be only in CVS)

sesam_rollback — Discard any pending updates to the SESAM database

Popis

bool sesam_rollback ( void )

sesam_rollback() discards any pending updates to the database. Also affected are result cursors and result descriptors.

At the end of each script, and as part of the sesam_disconnect() function, an implied sesam_rollback() is executed, discarding any pending changes to the database.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 2004. Discarding an update to the SESAM database

<?php
if (sesam_connect ("mycatalog", "myschema", "otto")) {
    if (sesam_execimm ("INSERT INTO mytable VALUES (*, 'Small Test', <0, 8, 15>)")
        && sesam_execimm ("INSERT INTO othertable VALUES (*, 'Another Test', 1)")) {
        sesam_commit();
    } else {
        sesam_rollback();
    }
}
?>

Viz také

sesam_commit()

Předcházející | Nahoru | Další
sesam_query | Domů | sesam_seek_row


sesam_seek_row

(No version information available, might be only in CVS)

sesam_seek_row — Set scrollable cursor mode for subsequent fetches

Popis

bool sesam_seek_row ( string $result_id, int $whence [, int $offset] )

Sets the scrollable cursor mode for subsequent fetches.

Seznam parametrů

result_id

result_id is a valid result id (select type queries only, and only if a "scrollable" cursor was requested when calling sesam_query()).

whence

whence sets the global default value for the scrolling type, it specifies the scroll type to use in subsequent fetch operations on "scrollable" cursors, which can be set to the following predefined constants:

Tabulka 277. Valid values for whence

Value | Constant | Meaning
0 | SESAM_SEEK_NEXT | read sequentially
1 | SESAM_SEEK_PRIOR | read sequentially backwards
2 | SESAM_SEEK_FIRST | fetch first row (after fetch, the default is set to SESAM_SEEK_NEXT)
3 | SESAM_SEEK_LAST | fetch last row (after fetch, the default is set to SESAM_SEEK_PRIOR)
4 | SESAM_SEEK_ABSOLUTE | fetch absolute row number given as offset (Zero-based. After fetch, the default is set to SESAM_SEEK_ABSOLUTE, and the offset value is auto-incremented)
5 | SESAM_SEEK_RELATIVE | fetch relative to current scroll position, where offset can be a positive or negative offset value (this also sets the default "offset" value for subsequent fetches).

offset

An optional parameter which is only evaluated (and required) if whence is either SESAM_SEEK_RELATIVE or SESAM_SEEK_ABSOLUTE.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
sesam_rollback | Domů | sesam_settransaction


sesam_settransaction

(No version information available, might be only in CVS)

sesam_settransaction — Set SESAM transaction parameters

Popis

bool sesam_settransaction ( int $isolation_level, int $read_only )

Overrides the default values for the isolation level and read-only transaction parameters (which are set in the SESAM configuration file), in order to optimize subsequent queries and guarantee database consistency. The overridden values are used for the next transaction only. See the SESAM handbook for detailed explanation of the semantics.

This function can only be called before starting a transaction, not after the transaction has been started already.

The values set by sesam_settransaction() will override the default setting specified in the SESAM configuration file.

Seznam parametrů

isolation_level

Tabulka 278. Valid values for isolation_level parameter

Value | Constant | Meaning
1 | SESAM_TXISOL_READ_UNCOMMITTED | Read Uncommitted
2 | SESAM_TXISOL_READ_COMMITTED | Read Committed
3 | SESAM_TXISOL_REPEATABLE_READ | Repeatable Read
4 | SESAM_TXISOL_SERIALIZABLE | Serializable

read_only

Tabulka 279. Valid values for read_only parameter

Value | Constant | Meaning
0 | SESAM_TXREAD_READWRITE | Read/Write
1 | SESAM_TXREAD_READONLY | Read-Only

Návratové hodnoty

Returns TRUE if the values are valid, and the settransaction operation was successful, FALSE otherwise.

Příklady

Příklad 2005. Setting SESAM transaction parameters

<?php
sesam_settransaction (SESAM_TXISOL_REPEATABLE_READ,
                     SESAM_TXREAD_READONLY);
?>

Předcházející | Nahoru | Další
sesam_seek_row | Domů | CXLVIII. PostgreSQL Session Save Handler


Session Handling Functions

Předcházející VI. Reference funkcí Další

CXLIX. Session Handling Functions

Úvod

Session support in PHP consists of a way to preserve certain data across subsequent accesses. This enables you to build more customized applications and increase the appeal of your web site.

A visitor accessing your web site is assigned a unique id, the so-called session id. This is either stored in a cookie on the user side or is propagated in the URL.

The session support allows you to register arbitrary numbers of variables to be preserved across requests. When a visitor accesses your site, PHP will check automatically (if session.auto_start is set to 1) or on your request (explicitly through session_start() or implicitly through session_register()) whether a specific session id has been sent with the request. If this is the case, the prior saved environment is recreated.

Výstraha

If you do turn on session.auto_start then you cannot put objects into your sessions since the class definition has to be loaded before starting the session in order to recreate the objects in your session.

All registered variables are serialized after the request finishes. Registered variables which are undefined are marked as being not defined. On subsequent accesses, these are not defined by the session module unless the user defines them later.

Varování

Some types of data can not be serialized thus stored in sessions. It includes resource variables or objects with circular references (i.e. objects which passes a reference to itself to another object).

Poznámka: Session handling was added in PHP 4.0.0.

Poznámka: Please note when working with sessions that a record of a session is not created until a variable has been registered using the session_register() function or by adding a new key to the $_SESSION superglobal array. This holds true regardless of if a session has been started using the session_start() function.

Sessions and security

External links: » Session fixation

The session module cannot guarantee that the information you store in a session is only viewed by the user who created the session. You need to take additional measures to actively protect the integrity of the session, depending on the value associated with it.

Assess the importance of the data carried by your sessions and deploy additional protections -- this usually comes at a price, reduced convenience for the user. For example, if you want to protect users from simple social engineering tactics, you need to enable session.use_only_cookies. In that case, cookies must be enabled unconditionally on the user side, or sessions will not work.

There are several ways to leak an existing session id to third parties. A leaked session id enables the third party to access all resources which are associated with a specific id. First, URLs carrying session ids. If you link to an external site, the URL including the session id might be stored in the external site's referrer logs. Second, a more active attacker might listen to your network traffic. If it is not encrypted, session ids will flow in plain text over the network. The solution here is to implement SSL on your server and make it mandatory for users.

Požadavky

Tyto funkce jsou k dispozici jako součást standardního modulu, který je vždy dostupný.

Poznámka: Optionally you can use shared memory allocation (mm), developed by Ralf S. Engelschall, for session storage. You have to download » mm and install it. This option is not available for Windows platforms. Note that the session storage module for mm does not guarantee that concurrent accesses to the same session are properly locked. It might be more appropriate to use a shared memory based filesystem (such as tmpfs on Solaris/Linux, or /dev/md on BSD) to store sessions in files, because they are properly locked. Session data is stored in memory thus web server restart deletes it.

Instalace

Session support is enabled in PHP by default. If you would not like to build your PHP with session support, you should specify the --disable-session option to configure. To use shared memory allocation (mm) for session storage configure PHP --with-mm[=DIR] .

Verze PHP pro Windows má vestavěnou podporu pro toto rozšíření. K použití těchto funkcí není třeba načítat žádná další rozšíření.

Poznámka: By default, all data related to a particular session will be stored in a file in the directory specified by the session.save_path INI option. A file for each session (regardless of if any data is associated with that session) will be created. This is due to the fact that a session is opened (a file is created) but no data is even written to that file. Note that this behavior is a side-effect of the limitations of working with the file system and it is possible that a custom session handler (such as one which uses a database) does not keep track of sessions which store no data.

Konfigurace běhu

Chování těchto funkcí je ovlivněno nastavením parametrů v php.ini.

Tabulka 280. Session configuration options

Name | Default | Changeable | Changelog
session.save_path | "" | PHP_INI_ALL |
session.name | "PHPSESSID" | PHP_INI_ALL |
session.save_handler | "files" | PHP_INI_ALL |
session.auto_start | "0" | PHP_INI_ALL |
session.gc_probability | "1" | PHP_INI_ALL |
session.gc_divisor | "100" | PHP_INI_ALL | Available since PHP 4.3.2.
session.gc_maxlifetime | "1440" | PHP_INI_ALL |
session.serialize_handler | "php" | PHP_INI_ALL |
session.cookie_lifetime | "0" | PHP_INI_ALL |
session.cookie_path | "/" | PHP_INI_ALL |
session.cookie_domain | "" | PHP_INI_ALL |
session.cookie_secure | "" | PHP_INI_ALL | Available since PHP 4.0.4.
session.cookie_httponly | "" | PHP_INI_ALL | Available since PHP 5.2.0.
session.use_cookies | "1" | PHP_INI_ALL |
session.use_only_cookies | "1" | PHP_INI_ALL | Available since PHP 4.3.0.
session.referer_check | "" | PHP_INI_ALL |
session.entropy_file | "" | PHP_INI_ALL |
session.entropy_length | "0" | PHP_INI_ALL |
session.cache_limiter | "nocache" | PHP_INI_ALL |
session.cache_expire | "180" | PHP_INI_ALL |
session.use_trans_sid | "0" | PHP_INI_ALL | PHP_INI_ALL in PHP <= 4.2.3. PHP_INI_PERDIR in PHP < 5. Available since PHP 4.0.3.
session.bug_compat_42 | "1" | PHP_INI_ALL | Available since PHP 4.3.0. Removed in PHP 6.0.0.
session.bug_compat_warn | "1" | PHP_INI_ALL | Available since PHP 4.3.0. Removed in PHP 6.0.0.
session.hash_function | "0" | PHP_INI_ALL | Available since PHP 5.0.0.
session.hash_bits_per_character | "4" | PHP_INI_ALL | Available since PHP 5.0.0.
url_rewriter.tags | "a=href,area=href,frame=src,form=,fieldset=" | PHP_INI_ALL | Available since PHP 4.0.4.

Pro další detaily a definice konstant PHP_INI_*, viz dokumentace k ini_set().

The session management system supports a number of configuration options which you can place in your php.ini file. We will give a short overview.

session.save_handler string
session.save_handler defines the name of the handler which is used for storing and retrieving data associated with a session. Defaults to files. Note that individual extensions may register their own save_handlers; registered handlers can be obtained on a per-installation basis by referring to phpinfo(). See also session_set_save_handler().
session.save_path string

session.save_path defines the argument which is passed to the save handler. If you choose the default files handler, this is the path where the files are created. See also session_save_path().

There is an optional N argument to this directive that determines the number of directory levels your session files will be spread around in. For example, setting to '5;/tmp' may end up creating a session file and location like /tmp/4/b/1/e/3/sess_4b1e384ad74619bd212e236e52a5a174If . In order to use N you must create all of these directories before use. A small shell script exists in ext/session to do this, it's called mod_files.sh. Also note that if N is used and greater than 0 then automatic garbage collection will not be performed, see a copy of php.ini for further information. Also, if you use N, be sure to surround session.save_path in "quotes" because the separator (;) is also used for comments in php.ini.

Varování

If you leave this set to a world-readable directory, such as /tmp (the default), other users on the server may be able to hijack sessions by getting the list of files in that directory.

Poznámka: Prior to PHP 4.3.6, Windows users had to change this variable in order to use PHP's session functions. A valid path must be specified, e.g.: c:/temp.

session.name string
session.name specifies the name of the session which is used as cookie name. It should only contain alphanumeric characters. Defaults to PHPSESSID. See also session_name().
session.auto_start boolean
session.auto_start specifies whether the session module starts a session automatically on request startup. Defaults to 0 (disabled).
session.serialize_handler string
session.serialize_handler defines the name of the handler which is used to serialize/deserialize data. Currently, a PHP internal format (name php or php_binary) and WDDX are supported (name wddx). WDDX is only available, if PHP is compiled with WDDX support. Defaults to php.
session.gc_probability integer
session.gc_probability in conjunction with session.gc_divisor is used to manage probability that the gc (garbage collection) routine is started. Defaults to 1. See session.gc_divisor for details.
session.gc_divisor integer
session.gc_divisor coupled with session.gc_probability defines the probability that the gc (garbage collection) process is started on every session initialization. The probability is calculated by using gc_probability/gc_divisor, e.g. 1/100 means there is a 1% chance that the GC process starts on each request. session.gc_divisor defaults to 100.
session.gc_maxlifetime integer

session.gc_maxlifetime specifies the number of seconds after which data will be seen as 'garbage' and cleaned up. Garbage collection occurs during session start.

Poznámka: If different scripts have different values of session.gc_maxlifetime but share the same place for storing the session data then the script with the minimum value will be cleaning the data. In this case, use this directive together with session.save_path.

Poznámka: If you are using the default file-based session handler, your filesystem must keep track of access times (atime). Windows FAT does not so you will have to come up with another way to handle garbage collecting your session if you are stuck with a FAT filesystem or any other filesystem where atime tracking is not available. Since PHP 4.2.3 it has used mtime (modified date) instead of atime. So, you won't have problems with filesystems where atime tracking is not available.

session.referer_check string
session.referer_check contains the substring you want to check each HTTP Referer for. If the Referer was sent by the client and the substring was not found, the embedded session id will be marked as invalid. Defaults to the empty string.
session.entropy_file string
session.entropy_file gives a path to an external resource (file) which will be used as an additional entropy source in the session id creation process. Examples are /dev/random or /dev/urandom which are available on many Unix systems.
session.entropy_length integer
session.entropy_length specifies the number of bytes which will be read from the file specified above. Defaults to 0 (disabled).
session.use_cookies boolean
session.use_cookies specifies whether the module will use cookies to store the session id on the client side. Defaults to 1 (enabled).
session.use_only_cookies boolean
session.use_only_cookies specifies whether the module will only use cookies to store the session id on the client side. Enabling this setting prevents attacks involved passing session ids in URLs. This setting was added in PHP 4.3.0. Defaults to 1 (enabled) since PHP 6.0.
session.cookie_lifetime integer

session.cookie_lifetime specifies the lifetime of the cookie in seconds which is sent to the browser. The value 0 means "until the browser is closed." Defaults to 0. See also session_get_cookie_params() and session_set_cookie_params().

Poznámka: The expiration timestamp is set relative to the server time, which is not necessarily the same as the time in the client's browser.

session.cookie_path string
session.cookie_path specifies path to set in session_cookie. Defaults to /. See also session_get_cookie_params() and session_set_cookie_params().
session.cookie_domain string
session.cookie_domain specifies the domain to set in session_cookie. Default is none at all meaning the host name of the server which generated the cookie according to cookies specification. See also session_get_cookie_params() and session_set_cookie_params().
session.cookie_secure boolean
session.cookie_secure specifies whether cookies should only be sent over secure connections. Defaults to off. This setting was added in PHP 4.0.4. See also session_get_cookie_params() and session_set_cookie_params().
session.cookie_httponly boolean
Marks the cookie as accessible only through the HTTP protocol. This means that the cookie won't be accessible by scripting languages, such as JavaScript. This setting can effectively help to reduce identity theft through XSS attacks (although it is not supported by all browsers).
session.cache_limiter string
session.cache_limiter specifies cache control method to use for session pages (none/nocache/private/private_no_expire/public). Defaults to nocache. See also session_cache_limiter().
session.cache_expire integer
session.cache_expire specifies time-to-live for cached session pages in minutes, this has no effect for nocache limiter. Defaults to 180. See also session_cache_expire().
session.use_trans_sid boolean

session.use_trans_sid whether transparent sid support is enabled or not. Defaults to 0 (disabled).

Poznámka: For PHP 4.1.2 or less, it is enabled by compiling with --enable-trans-sid. From PHP 4.2.0, trans-sid feature is always compiled.

URL based session management has additional security risks compared to cookie based session management. Users may send a URL that contains an active session ID to their friends by email or users may save a URL that contains a session ID to their bookmarks and access your site with the same session ID always, for example.

session.bug_compat_42 boolean
PHP versions 4.2.3 and lower have an undocumented feature/bug that allows you to initialize a session variable in the global scope, albeit register_globals is disabled. PHP 4.3.0 and later will warn you, if this feature is used, and if session.bug_compat_warn is also enabled. This feature/bug can be disabled by disabling this directive.
session.bug_compat_warn boolean
PHP versions 4.2.3 and lower have an undocumented feature/bug that allows you to initialize a session variable in the global scope, albeit register_globals is disabled. PHP 4.3.0 and later will warn you, if this feature is used by enabling both session.bug_compat_42 and session.bug_compat_warn.
session.hash_function mixed

session.hash_function allows you to specify the hash algorithm used to generate the session IDs. '0' means MD5 (128 bits) and '1' means SHA-1 (160 bits).

Since PHP 6.0.0 it is also possible to specify any of the algorithms provided by the hash extension (if it is available), like sha512 or whirlpool. A complete list of supported algorithms can be obtained with the hash_algos() function.

Poznámka: This was introduced in PHP 5.

session.hash_bits_per_character integer

session.hash_bits_per_character allows you to define how many bits are stored in each character when converting the binary hash data to something readable. The possible values are '4' (0-9, a-f), '5' (0-9, a-v), and '6' (0-9, a-z, A-Z, "-", ",").

Poznámka: This was introduced in PHP 5.

url_rewriter.tags string

url_rewriter.tags specifies which HTML tags are rewritten to include session id if transparent sid support is enabled. Defaults to a=href,area=href,frame=src,input=src,form=fakeentry,fieldset=

Poznámka: If you want HTML/XHTML strict conformity, remove the form entry and use the <fieldset> tags around your form fields.

The track_vars and register_globals configuration settings influence how the session variables get stored and restored.

Poznámka: As of PHP 4.0.3, track_vars is always turned on.

Typy prostředků

Toto rozšíření nemá definován žádný typ prostředku (resource).

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

SID (string)
Constant containing either the session name and session ID in the form of "name=ID" or empty string if session ID was set in an appropriate session cookie.

Příklady

Poznámka: As of PHP 4.1.0, $_SESSION is available as a global variable just like $_POST, $_GET, $_REQUEST and so on. Unlike $HTTP_SESSION_VARS, $_SESSION is always global. Therefore, you do not need to use the global keyword for $_SESSION. Please note that this documentation has been changed to use $_SESSION everywhere. You can substitute $HTTP_SESSION_VARS for $_SESSION, if you prefer the former. Also note that you must start your session using session_start() before use of $_SESSION becomes available.

The keys in the $_SESSION associative array are subject to the same limitations as regular variable names in PHP, i.e. they cannot start with a number and must start with a letter or underscore. For more details see the section on variables in this manual.

If register_globals is disabled, only members of the global associative array $_SESSION can be registered as session variables. The restored session variables will only be available in the array $_SESSION.

Use of $_SESSION (or $HTTP_SESSION_VARS with PHP 4.0.6 or less) is recommended for improved security and code readability. With $_SESSION, there is no need to use the session_register(), session_unregister(), session_is_registered() functions. Session variables are accessible like any other variables.

Příklad 2006. Registering a variable with $_SESSION.

<?php
session_start();
// Use $HTTP_SESSION_VARS with PHP 4.0.6 or less
if (!isset($_SESSION['count'])) {
    $_SESSION['count'] = 0;
} else {
    $_SESSION['count']++;
}
?>

Příklad 2007. Unregistering a variable with $_SESSION and register_globals disabled.

<?php
session_start();
// Use $HTTP_SESSION_VARS with PHP 4.0.6 or less
unset($_SESSION['count']);
?>

Výstraha

Do NOT unset the whole $_SESSION with unset($_SESSION) as this will disable the registering of session variables through the $_SESSION superglobal.

Varování

You can't use references in session variables as there is no feasible way to restore a reference to another variable.

If register_globals is enabled, then each global variable can be registered as session variable. Upon a restart of a session, these variables will be restored to corresponding global variables. Since PHP must know which global variables are registered as session variables, users need to register variables with session_register() function. You can avoid this by simply setting entries in $_SESSION.

Výstraha

Before PHP 4.3.0, if you are using $_SESSION and you have disabled register_globals, don't use session_register(), session_is_registered() or session_unregister(). Disabling register_globals is recommended for both security and performance reasons.

If register_globals is enabled, then the global variables and the $_SESSION entries will automatically reference the same values which were registered in the prior session instance. However, if the variable is registered by $_SESSION then the global variable is available since the next request.

There is a defect in PHP 4.2.3 and earlier. If you register a new session variable by using session_register(), the entry in the global scope and the $_SESSION entry will not reference the same value until the next session_start(). I.e. a modification to the newly registered global variable will not be reflected by the $_SESSION entry. This has been corrected in PHP 4.3.0.

Passing the Session ID

There are two methods to propagate a session id:

  • Cookies
  • URL parameter

The session module supports both methods. Cookies are optimal, but because they are not always available, we also provide an alternative way. The second method embeds the session id directly into URLs.

PHP is capable of transforming links transparently. Unless you are using PHP 4.2.0 or later, you need to enable it manually when building PHP. Under Unix, pass --enable-trans-sid to configure. If this build option and the run-time option session.use_trans_sid are enabled, relative URIs will be changed to contain the session id automatically.

Poznámka: The arg_separator.output php.ini directive allows to customize the argument seperator. For full XHTML conformance, specify &amp; there.

Alternatively, you can use the constant SID which is defined if the session started. If the client did not send an appropriate session cookie, it has the form session_name=session_id. Otherwise, it expands to an empty string. Thus, you can embed it unconditionally into URLs.

The following example demonstrates how to register a variable, and how to link correctly to another page using SID.

Příklad 2008. Counting the number of hits of a single user

<?php

session_start();

if (empty($_SESSION['count'])) {
   $_SESSION['count'] = 1;
} else {
   $_SESSION['count']++;
}
?>

<p>
Hello visitor, you have seen this page <?php echo $_SESSION['count']; ?> times.
</p>

<p>
To continue, <a href="nextpage.php?<?php echo htmlspecialchars(SID); ?>">click
here</a>.
</p>

The htmlspecialchars() may be used when printing the SID in order to prevent XSS related attacks.

Printing the SID, like shown above, is not necessary if --enable-trans-sid was used to compile PHP.

Poznámka: Non-relative URLs are assumed to point to external sites and hence don't append the SID, as it would be a security risk to leak the SID to a different server.

Custom Session Handlers

To implement database storage, or any other storage method, you will need to use session_set_save_handler() to create a set of user-level storage functions.

Obsah

session_cache_expire — Return current cache expire
session_cache_limiter — Get and/or set the current cache limiter
session_commit — Alias pro session_write_close()
session_decode — Decodes session data from a string
session_destroy — Destroys all data registered to a session
session_encode — Encodes the current session data as a string
session_get_cookie_params — Get the session cookie parameters
session_id — Get and/or set the current session id
session_is_registered — Find out whether a global variable is registered in a session
session_module_name — Get and/or set the current session module
session_name — Get and/or set the current session name
session_regenerate_id — Update the current session id with a newly generated one
session_register — Register one or more global variables with the current session
session_save_path — Get and/or set the current session save path
session_set_cookie_params — Set the session cookie parameters
session_set_save_handler — Sets user-level session storage functions
session_start — Initialize session data
session_unregister — Unregister a global variable from the current session
session_unset — Free all session variables
session_write_close — Write session data and end session
Předcházející | Nahoru | Další
session_pgsql_status | Domů | session_cache_expire


session_cache_expire

(PHP 4 >= 4.2.0, PHP 5)

session_cache_expire — Return current cache expire

Popis

int session_cache_expire ( [int $new_cache_expire] )

session_cache_expire() returns the current setting of session.cache_expire.

The cache expire is reset to the default value of 180 stored in session.cache_limiter at request startup time. Thus, you need to call session_cache_expire() for every request (and before session_start() is called).

Seznam parametrů

new_cache_expire

If new_cache_expire is given, the current cache expire is replaced with new_cache_expire.

Poznámka: Setting new_cache_expire is of value only, if session.cache_limiter is set to a value different from nocache.

Návratové hodnoty

Returns the current setting of session.cache_expire. The value returned should be read in minutes, defaults to 180.

Příklady

Příklad 2009. session_cache_expire() example

<?php

/* set the cache limiter to 'private' */

session_cache_limiter('private');
$cache_limiter = session_cache_limiter();

/* set the cache expire to 30 minutes */
session_cache_expire(30);
$cache_expire = session_cache_expire();

/* start the session */

session_start();

echo "The cache limiter is now set to $cache_limiter<br />";
echo "The cached session pages expire after $cache_expire minutes";
?>

Viz také

session.cache_expire
session.cache_limiter
session_cache_limiter()

Předcházející | Nahoru | Další
CXLIX. Session Handling Functions | Domů | session_cache_limiter


session_cache_limiter

(PHP 4 >= 4.0.3, PHP 5)

session_cache_limiter — Get and/or set the current cache limiter

Popis

string session_cache_limiter ( [string $cache_limiter] )

session_cache_limiter() returns the name of the current cache limiter.

The cache limiter defines which cache control HTTP headers are sent to the client. These headers determine the rules by which the page content may be cached by the client and intermediate proxies. Setting the cache limiter to nocache disallows any client/proxy caching. A value of public permits caching by proxies and the client, whereas private disallows caching by proxies and permits the client to cache the contents.

In private mode, the Expire header sent to the client may cause confusion for some browsers, including Mozilla. You can avoid this problem by using private_no_expire mode. The expire header is never sent to the client in this mode.

The cache limiter is reset to the default value stored in session.cache_limiter at request startup time. Thus, you need to call session_cache_limiter() for every request (and before session_start() is called).

Seznam parametrů

cache_limiter

If cache_limiter is specified, the name of the current cache limiter is changed to the new value.

Návratové hodnoty

Returns the name of the current cache limiter.

ChangeLog (záznam změn)

Verze | Popis
4.2.0 | The private_no_expire cache limiter was added.

Příklady

Příklad 2010. session_cache_limiter() example

<?php

/* set the cache limiter to 'private' */

session_cache_limiter('private');
$cache_limiter = session_cache_limiter();

echo "The cache limiter is now set to $cache_limiter<br />";
?>

Viz také

session.cache_limiter

Předcházející | Nahoru | Další
session_cache_expire | Domů | session_commit


session_commit

(PHP 4 >= 4.4.0, PHP 5)

session_commit — Alias pro session_write_close()

Popis

Tato funkce je aliasem: session_write_close().

Předcházející | Nahoru | Další
session_cache_limiter | Domů | session_decode


session_decode

(PHP 4, PHP 5)

session_decode — Decodes session data from a string

Popis

bool session_decode ( string $data )

session_decode() decodes the session data in data, setting variables stored in the session.

Seznam parametrů

data

The encoded data to be stored.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

session_encode()

Předcházející | Nahoru | Další
session_commit | Domů | session_destroy


session_destroy

(PHP 4, PHP 5)

session_destroy — Destroys all data registered to a session

Popis

bool session_destroy ( void )

session_destroy() destroys all of the data associated with the current session. It does not unset any of the global variables associated with the session, or unset the session cookie.

In order to kill the session altogether, like to log the user out, the session id must also be unset. If a cookie is used to propagate the session id (default behavior), then the session cookie must be deleted. setcookie() may be used for that.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 2011. Destroying a session with $_SESSION

<?php
// Initialize the session.
// If you are using session_name("something"), don't forget it now!
session_start();

// Unset all of the session variables.
$_SESSION = array();

// If it's desired to kill the session, also delete the session cookie.
// Note: This will destroy the session, and not just the session data!
if (isset($_COOKIE[session_name()])) {
    setcookie(session_name(), '', time()-42000, '/');
}

// Finally, destroy the session.
session_destroy();
?>

Poznámky

Poznámka: Only use session_unset() for older deprecated code that does not use $_SESSION.

Viz také

unset()
setcookie()

Předcházející | Nahoru | Další
session_decode | Domů | session_encode


session_encode

(PHP 4, PHP 5)

session_encode — Encodes the current session data as a string

Popis

string session_encode ( void )

session_encode() returns a string with the contents of the current session encoded within.

Návratové hodnoty

Returns the contents of the current session encoded.

Viz také

session_decode()

Předcházející | Nahoru | Další
session_destroy | Domů | session_get_cookie_params


session_get_cookie_params

(PHP 4, PHP 5)

session_get_cookie_params — Get the session cookie parameters

Popis

array session_get_cookie_params ( void )

Gets the session cookie parameters.

Návratové hodnoty

Returns an array with the current session cookie information, the array contains the following items:

  • "lifetime" - The lifetime of the cookie in seconds.
  • "path" - The path where information is stored.
  • "domain" - The domain of the cookie.
  • "secure" - The cookie should only be sent over secure connections.
  • "httponly" - The cookie can only be accessed through the HTTP protocol.

ChangeLog (záznam změn)

Verze | Popis
5.2.0 | The "httponly" entry was added in the returned array?
4.0.4 | The "secure" entry was added in the returned array?

Viz také

session.cookie_lifetime
session.cookie_path
session.cookie_domain
session.cookie_secure
session.cookie_httponly
session.cookie_lifetime
session_set_cookie_params()

Předcházející | Nahoru | Další
session_encode | Domů | session_id


session_id

(PHP 4, PHP 5)

session_id — Get and/or set the current session id

Popis

string session_id ( [string $id] )

session_id() is used to get or set the session id for the current session.

The constant SID can also be used to retrieve the current name and session id as a string suitable for adding to URLs. See also Session handling.

Seznam parametrů

id

If id is specified, it will replace the current session id. session_id() needs to be called before session_start() for that purpose. Depending on the session handler, not all characters are allowed within the session id. For example, the file session handler only allows characters in the range a-z, A-Z and 0-9!

Poznámka: When using session cookies, specifying an id for session_id() will always send a new cookie when session_start() is called, regardless if the current session id is identical to the one being set.

Návratové hodnoty

session_id() returns the session id for the current session or the empty string ("") if there is no current session (no current session id exists).

Viz také

session_regenerate_id()
session_start()
session_set_save_handler()
session.save_handler

Předcházející | Nahoru | Další
session_get_cookie_params | Domů | session_is_registered


session_is_registered

(PHP 4, PHP 5)

session_is_registered — Find out whether a global variable is registered in a session

Popis

bool session_is_registered ( string $name )

Finds out whether a global variable is registered in a session.

Seznam parametrů

name

The variable name.

Návratové hodnoty

session_is_registered() returns TRUE if there is a global variable with the name name registered in the current session, FALSE otherwise.

Poznámky

Poznámka: If $_SESSION (or $HTTP_SESSION_VARS for PHP 4.0.6 or less) is used, use isset() to check a variable is registered in $_SESSION.

Výstraha

If you are using $_SESSION
(or $HTTP_SESSION_VARS), do not use
session_register(),
session_is_registered() and
session_unregister().

Předcházející | Nahoru | Další
session_id | Domů | session_module_name


session_module_name

(PHP 4, PHP 5)

session_module_name — Get and/or set the current session module

Popis

string session_module_name ( [string $module] )

session_module_name() gets the name of the current session module.

Seznam parametrů

module

If module is specified, that module will be used instead.

Návratové hodnoty

Returns the name of the current session module.

Předcházející | Nahoru | Další
session_is_registered | Domů | session_name


session_name

(PHP 4, PHP 5)

session_name — Get and/or set the current session name

Popis

string session_name ( [string $name] )

session_name() returns the name of the current session.

The session name is reset to the default value stored in session.name at request startup time. Thus, you need to call session_name() for every request (and before session_start() or session_register() are called).

Seznam parametrů

name

The session name references the session id in cookies and URLs. It should contain only alphanumeric characters; it should be short and descriptive (i.e. for users with enabled cookie warnings). If name is specified, the name of the current session is changed to its value.

Varování

The session name can't consist of digits only, at least one letter must be present. Otherwise a new session id is generated every time.

Návratové hodnoty

Returns the name of the current session.

Příklady

Příklad 2012. session_name() example

<?php

/* set the session name to WebsiteID */

$previous_name = session_name("WebsiteID");

echo "The previous session name was $previous_name<br />";
?>

Viz také

The session.name configuration directive

Předcházející | Nahoru | Další
session_module_name | Domů | session_regenerate_id


session_regenerate_id

(PHP 4 >= 4.3.2, PHP 5)

session_regenerate_id — Update the current session id with a newly generated one

Popis

bool session_regenerate_id ( [bool $delete_old_session] )

session_regenerate_id() will replace the current session id with a new one, and keep the current session information.

Seznam parametrů

delete_old_session

Whether to delete the old associated session file or not. Defaults to FALSE.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

ChangeLog (záznam změn)

Verze | Popis
4.3.3 | Since then, if session cookies are enabled, use of session_regenerate_id() will also submit a new session cookie with the new session id.
5.1.0 | Added the delete_old_session parameter.

Příklady

Příklad 2013. A session_regenerate_id() example

<?php
session_start();

$old_sessionid = session_id();

session_regenerate_id();

$new_sessionid = session_id();

echo "Old Session: $old_sessionid<br />";
echo "New Session: $new_sessionid<br />";

print_r($_SESSION);
?>

Viz také

session_id()
session_start()
session_name()

Předcházející | Nahoru | Další
session_name | Domů | session_register


session_register

(PHP 4, PHP 5)

session_register — Register one or more global variables with the current session

Popis

bool session_register ( mixed $name [, mixed $...] )

session_register() accepts a variable number of arguments, any of which can be either a string holding the name of a variable or an array consisting of variable names or other arrays. For each name, session_register() registers the global variable with that name in the current session.

You can also create a session variable by simply setting the appropriate member of the $_SESSION or $HTTP_SESSION_VARS (PHP < 4.1.0) array.

<?php
// Use of session_register() is deprecated
$barney = "A big purple dinosaur.";
session_register("barney");

// Use of $_SESSION is preferred, as of PHP 4.1.0
$_SESSION["zim"] = "An invader from another planet.";

// The old way was to use $HTTP_SESSION_VARS
$HTTP_SESSION_VARS["spongebob"] = "He's got square pants.";
?>

If session_start() was not called before this function is called, an implicit call to session_start() with no parameters will be made. $_SESSION does not mimic this behavior and requires session_start() before use.

Seznam parametrů

name

A string holding the name of a variable or an array consisting of variable names or other arrays.

...

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Poznámky

Výstraha

If you want your script to work regardless of register_globals, you need to instead use the $_SESSION array as $_SESSION entries are automatically registered. If your script uses session_register(), it will not work in environments where the PHP directive register_globals is disabled.

Důležitá poznámka k register_globals: Od PHP 4.2.0 je výchozí hodnota PHP direktivy register_globals off a od PHP 6.0.0 je direktiva zcela odstraněna. Společenství vývojářů PHP všem doporučuje na této direktivě nelpět a místo toho raději použít jiné prostředky, jako například superglobals.

Výstraha

This registers a global variable. If you want to register a session variable from within a function, you need to make sure to make it global using the global keyword or the $GLOBALS[] array, or use the special session arrays as noted below.

Výstraha

If you are using $_SESSION
(or $HTTP_SESSION_VARS), do not use
session_register(),
session_is_registered(), and
session_unregister().

Poznámka: It is currently impossible to register resource variables in a session. For example, you cannot create a connection to a database and store the connection id as a session variable and expect the connection to still be valid the next time the session is restored. PHP functions that return a resource are identified by having a return type of resource in their function definition. A list of functions that return resources are available in the resource types appendix.

If $_SESSION (or $HTTP_SESSION_VARS for PHP 4.0.6 or less) is used, assign values to $_SESSION. For example: $_SESSION['var'] = 'ABC';

Viz také

session_is_registered()
session_unregister()
$_SESSION

Předcházející | Nahoru | Další
session_regenerate_id | Domů | session_save_path


session_save_path

(PHP 4, PHP 5)

session_save_path — Get and/or set the current session save path

Popis

string session_save_path ( [string $path] )

session_save_path() returns the path of the current directory used to save session data.

Seznam parametrů

path

Session data path. If specified, the path to which data is saved will be changed. session_save_path() needs to be called before session_start() for that purpose.

Poznámka: On some operating systems, you may want to specify a path on a filesystem that handles lots of small files efficiently. For example, on Linux, reiserfs may provide better performance than ext2fs.

Návratové hodnoty

Returns the path of the current directory used for data storage.

Viz také

The session.save_path configuration directive

Předcházející | Nahoru | Další
session_register | Domů | session_set_cookie_params


session_set_cookie_params

(PHP 4, PHP 5)

session_set_cookie_params — Set the session cookie parameters

Popis

void session_set_cookie_params ( int $lifetime [, string $path [, string $domain [, bool $secure [, bool $httponly]]]] )

Set cookie parameters defined in the php.ini file. The effect of this function only lasts for the duration of the script. Thus, you need to call session_set_cookie_params() for every request and before session_start() is called.

Seznam parametrů

lifetime

path

domain

secure

httponly

Návratové hodnoty

Nevrací se žádná hodnota.

ChangeLog (záznam změn)

Verze | Popis
5.2.0 | The httponly parameter was added.
4.0.4 | The secure parameter was added.

Viz také

session.cookie_lifetime
session.cookie_domain
session.cookie_secure
session.cookie_httponly
session_get_cookie_params()

Předcházející | Nahoru | Další
session_save_path | Domů | session_set_save_handler


session_set_save_handler

(PHP 4, PHP 5)

session_set_save_handler — Sets user-level session storage functions

Popis

bool session_set_save_handler ( callback $open, callback $close, callback $read, callback $write, callback $destroy, callback $gc )

session_set_save_handler() sets the user-level session storage functions which are used for storing and retrieving data associated with a session. This is most useful when a storage method other than those supplied by PHP sessions is preferred. i.e. Storing the session data in a local database.

Seznam parametrů

open

close

read

Read function must return string value always to make save handler work as expected. Return empty string if there is no data to read. Return values from other handlers are converted to boolean expression. TRUE for success, FALSE for failure.

write

Poznámka: The "write" handler is not executed until after the output stream is closed. Thus, output from debugging statements in the "write" handler will never be seen in the browser. If debugging output is necessary, it is suggested that the debug output be written to a file instead.

destroy

gc

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 2014. session_set_save_handler() example

The following example provides file based session storage similar to the PHP sessions default save handler files. This example could easily be extended to cover database storage using your favorite PHP supported database engine.

<?php
function open($save_path, $session_name)
{
  global $sess_save_path;

  $sess_save_path = $save_path;
  return(true);
}

function close()
{
  return(true);
}

function read($id)
{
  global $sess_save_path;

  $sess_file = "$sess_save_path/sess_$id";
  return (string) @file_get_contents($sess_file);
}

function write($id, $sess_data)
{
  global $sess_save_path;

  $sess_file = "$sess_save_path/sess_$id";
  if ($fp = @fopen($sess_file, "w")) {
    $return = fwrite($fp, $sess_data);
    fclose($fp);
    return $return;
  } else {
    return(false);
  }

}

function destroy($id)
{
  global $sess_save_path;

  $sess_file = "$sess_save_path/sess_$id";
  return(@unlink($sess_file));
}

function gc($maxlifetime)
{
  global $sess_save_path;

  foreach (glob("$sess_save_path/sess_*") as $filename) {
    if (filemtime($filename) + $maxlifetime < time()) {
      @unlink($filename);
    }
  }
  return true;
}

session_set_save_handler("open", "close", "read", "write", "destroy", "gc");

session_start();

// proceed to use sessions normally

?>

Poznámky

Varování

As of PHP 5.0.5 the write and close handlers are called after object destruction and therefore cannot use objects or throw exceptions. The object destructors can however use sessions.

It is possible to call session_write_close() from the destructor to solve this chicken and egg problem.

Varování

Current working directory is changed with some SAPIs if session is closed in the script termination. It is possible to close the session earlier with session_write_close().

Viz také

The session.save_handler configuration directive

Předcházející | Nahoru | Další
session_set_cookie_params | Domů | session_start


session_start

(PHP 4, PHP 5)

session_start — Initialize session data

Popis

bool session_start ( void )

session_start() creates a session or resumes the current one based on the current session id that's being passed via a request, such as GET, POST, or a cookie.

If you want to use a named session, you must call session_name() before calling session_start().

session_start() will register internal output handler for URL rewriting when trans-sid is enabled. If a user uses ob_gzhandler or like with ob_start(), the order of output handler is important for proper output. For example, user must register ob_gzhandler before session start.

Návratové hodnoty

This function always returns TRUE.

ChangeLog (záznam změn)

Verze | Popis
4.3.3 | As of now, calling session_start() while the session has already been started will result in an error of level E_NOTICE. Also, the second session start will simply be ignored.

Příklady

Příklad 2015. A session example: page1.php

<?php
// page1.php

session_start();

echo 'Welcome to page #1';

$_SESSION['favcolor'] = 'green';
$_SESSION['animal']   = 'cat';
$_SESSION['time']     = time();

// Works if session cookie was accepted
echo '<br /><a href="page2.php">page 2</a>';

// Or maybe pass along the session id, if needed
echo '<br /><a href="page2.php?' . SID . '">page 2</a>';
?>

After viewing page1.php, the second page page2.php will magically contain the session data. Read the session reference for information on propagating session ids as it, for example, explains what the constant SID is all about.

Příklad 2016. A session example: page2.php

<?php
// page2.php

session_start();

echo 'Welcome to page #2<br />';

echo $_SESSION['favcolor']; // green
echo $_SESSION['animal'];   // cat
echo date('Y m d H:i:s', $_SESSION['time']);

// You may want to use SID here, like we did in page1.php
echo '<br /><a href="page1.php">page 1</a>';
?>

Poznámky

Poznámka: If you are using cookie-based sessions, you must call session_start() before anything is outputted to the browser.

Poznámka: Use of zlib.output_compression is recommended rather than ob_gzhandler()

Viz také

$_SESSION
The session.auto_start configuration directive
session_id()

Předcházející | Nahoru | Další
session_set_save_handler | Domů | session_unregister


session_unregister

(PHP 4, PHP 5)

session_unregister — Unregister a global variable from the current session

Popis

bool session_unregister ( string $name )

session_unregister() unregisters the global variable named name from the current session.

Seznam parametrů

name

The variable name.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Poznámky

Poznámka: If $_SESSION (or $HTTP_SESSION_VARS for PHP 4.0.6 or less) is used, use unset() to unregister a session variable. Do not unset() $_SESSION itself as this will disable the special function of the $_SESSION superglobal.

Výstraha

This function does not unset the corresponding global variable for name, it only prevents the variable from being saved as part of the session. You must call unset() to remove the corresponding global variable.

Výstraha

If you are using $_SESSION (or
$HTTP_SESSION_VARS), do not use
session_register(),
session_is_registered() and
session_unregister().

Předcházející | Nahoru | Další
session_start | Domů | session_unset


session_unset

(PHP 4, PHP 5)

session_unset — Free all session variables

Popis

void session_unset ( void )

The session_unset() function frees all session variables currently registered.

Návratové hodnoty

Nevrací se žádná hodnota.

Poznámky

Poznámka: If $_SESSION (or $HTTP_SESSION_VARS for PHP 4.0.6 or less) is used, use unset() to unregister a session variable, i.e. unset ($_SESSION['varname']);.

Výstraha

Do NOT unset the whole $_SESSION with unset($_SESSION) as this will disable the registering of session variables through the $_SESSION superglobal.

Předcházející | Nahoru | Další
session_unregister | Domů | session_write_close


session_write_close

(PHP 4 >= 4.0.4, PHP 5)

session_write_close — Write session data and end session

Popis

void session_write_close ( void )

End the current session and store session data.

Session data is usually stored after your script terminated without the need to call session_write_close(), but as session data is locked to prevent concurrent writes only one script may operate on a session at any time. When using framesets together with sessions you will experience the frames loading one by one due to this locking. You can reduce the time needed to load all the frames by ending the session as soon as all changes to session variables are done.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
session_unset | Domů | CL. Funkce pro práci se sdílenou pamětí


Funkce pro práci se sdílenou pamětí

Předcházející VI. Reference funkcí Další

CL. Funkce pro práci se sdílenou pamětí

Úvod

Shmop je snadno použitelná sada funkcí, která PHP umožňuje číst, zapisovat, vytvářet a mazat segmenty UNIXové sdílené paměti. Tyto funkce na Windows předcházejících Windows 2000 nefungují.

Poznámka: Názvy funkcí popisovaných v této kapitole začínají v PHP 4.0.3 na shm_(), ale od PHP 4.0.4 se jejich názvy změnily na shmop_().

Požadavky

Tyto funkce jsou k dispozici jako součást standardního modulu, který je vždy dostupný.

Instalace

Pokud chcete shmop používat, musíte PHP zkompilovat s volbou --enable-shmop.

Konfigurace běhu

Toto rozšíření nemá definováno žádné konfigurační direktivy.

Typy prostředků

Předdefinované konstanty

Toto rozšíření nemá definovány žádné konstanty.

Příklady

Příklad 2017. Shared Memory Operations Overview

<?php

// Vytvořit 100 bytový blok sdílené paměti se system id 0xff3
$shm_id = shmop_open(0xff3, "c", 0644, 100);
if (!$shm_id) {
    echo "Nepodařilo se vytvořit segment sdílené paměti\n";
}

// Zjistit velikost bloku sdílené paměti
$shm_size = shmop_size($shm_id);
echo "SHM blok o velikosti : ".$shm_size. " byl vytvořen.\n";

// Zapíšeme do sdílené paměti zkušební řetězec
$shm_bytes_written = shmop_write($shm_id, "my shared memory block", 0);
if ($shm_bytes_written != strlen("my shared memory block")) {
    echo "Nepodařilo se zapsat kompletní data\n";
}

// Načteme řetězec zpátky
$my_string = shmop_read($shm_id, 0, $shm_size);
if (!$my_string) {
    echo "Nepodařilo se číst z bloku sdílené paměti\n";
}
echo "Data ve sdílené paměti byla: ".$my_string."\n";

// Smažeme tento blok a zavřeme segment sdílené paměti
if (!shmop_delete($shm_id)) {
    echo "Nepodařilo se smazat blok sdílené paměti.";
}
shmop_close($shm_id);

?>

Obsah

shmop_close — Zavřít blok sdílené paměti
shmop_delete — Smazat blok sdílené paměti
shmop_open — Vytvořit nebo otevřít blok sdílené paměti
shmop_read — Přečíst data z bloku sdílené paměti
shmop_size — Zjistit velikost bloku sdílené paměti
shmop_write — Zapsat data do bloku sdílené paměti
Předcházející | Nahoru | Další
session_write_close | Domů | shmop_close


shmop_close

(PHP 4 >= 4.0.4, PHP 5)

shmop_close — Zavřít blok sdílené paměti

Popis

void shmop_close ( int $shmid )

shmop_close() se používá k zavření bloku sdílené paměti.

shmop_close() přijímá shmid, což je identifikátor bloku sdílené paměti vytvořený funkcí shmop_open().

Příklad 2018. Zavření bloku sdílené paměti

<?php
shmop_close($shm_id);
?>

Tato ukázka zavře blok sdílené paměti pojmenovaný $shm_id.

Předcházející | Nahoru | Další
CL. Funkce pro práci se sdílenou pamětí | Domů | shmop_delete


shmop_delete

(PHP 4 >= 4.0.4, PHP 5)

shmop_delete — Smazat blok sdílené paměti

Popis

bool shmop_delete ( int $shmid )

shmop_delete() se používá ke smazání bloku sdílené paměti.

shmop_delete() přijímá shmid, což je identifikátor bloku sdílené paměti vytvořený funkcí shmop_open(). Při úspěchu vrací 1, jinak 0.

Příklad 2019. Smazání bloku sdílené paměti

<?php
shmop_delete($shm_id);
?>

Tato ukázka smaže blok sdílené paměti pojmenovaný $shm_id.

Předcházející | Nahoru | Další
shmop_close | Domů | shmop_open


shmop_open

(PHP 4 >= 4.0.4, PHP 5)

shmop_open — Vytvořit nebo otevřít blok sdílené paměti

Popis

int shmop_open ( int $key, string $flags, int $mode, int $size )

shmop_open() vytvoří nebo otevře blok sdílené paměti.

shmop_open() přijímá 4 argumenty: klíč, což je system id bloku sdílené paměti; tento argument může být předán jako desítkové nebo hexadecimální číslo. Druhý argument jsou parametry:

  • "a" pro přístup (nastavuje IPC_EXCL) tento parametr použijte, pokud chcete otevřít existující segment sdílené paměti
  • "c" pro vytvoření (nastavuje IPC_CREATE) tento parametr použijte, pokud chcete vytvořit nový segment sdílené paměti
Třetí argument je mód, což jsou přístupová práva, která chcete tomuto segmentu přiřadit; jsou stejná jako práva pro soubory. Přístupová práva musí být předána jako oktalové číslo, např. 0644. Poslední argument je velikost bloku sdílené paměti, který chcete vytvořit, v bytech.

Poznámka: Pozn.: Pokud otvíráte existující segment paměti, 3. 4. argument by měly být předány jako 0. Při úspěchu shmop_open() vrací id, které můžete použít k přístupu na tento segment sdílené paměti.

Příklad 2020. Vytvoření bloku sdílené paměti

<?php
$shm_id = shmop_open(0x0fff, "c", 0644, 100);
?>

Tato ukázka otevřela blok sdílené paměti se system id 0x0fff.

Předcházející | Nahoru | Další
shmop_delete | Domů | shmop_read


shmop_read

(PHP 4 >= 4.0.4, PHP 5)

shmop_read — Přečíst data z bloku sdílené paměti

Popis

string shmop_read ( int $shmid, int $start, int $count )

shmop_read() čte řetězec z bloku sdílené paměti.

shmop_read() přijímá 3 argumenty: shmid, což je id bloku sdílené paměti vytvořeného funkcí shmop_open(), start, což je offset na kterém má čtení začít, a count, což je počet bytů, které se mají přečíst.

Příklad 2021. Čtení bloku sdílené paměti

<?php
$shm_data = shmop_read($shm_id, 0, 50);
?>

Tato ukázka přečte z bloku sdílené paměti 50 bytů a umístí načtená data do $shm_data.

Předcházející | Nahoru | Další
shmop_open | Domů | shmop_size


shmop_size

(PHP 4 >= 4.0.4, PHP 5)

shmop_size — Zjistit velikost bloku sdílené paměti

Popis

int shmop_size ( int $shmid )

shmop_size() se používá ke zjištění velikosti bloku sdílené paměti v bytech.

shmop_size() přijímá shmid, což je
idenfifikátor vytvořený funkcí shmop_open().
shmop_size() vrací integer představující počet bytů,
které blok sdílené paměti zabírá.

Příklad 2022. Zjištění velikosti bloku sdílené paměti

<?php
$shm_size = shmop_size($shm_id);
?>

Tato ukázka zapíše velikost bloku sdílené paměti určeného identifikátorem $shm_id do $shm_size.

Předcházející | Nahoru | Další
shmop_read | Domů | shmop_write


shmop_write

(PHP 4 >= 4.0.4, PHP 5)

shmop_write — Zapsat data do bloku sdílené paměti

Popis

int shmop_write ( int $shmid, string $data, int $offset )

shmop_write() zapíše řetězec do bloku sdílené paměti.

shmop_write() přijímá 3 argumenty: shmid, což je id bloku sdílené paměti vytvořeného funkcí shmop_open(), data, což je řetězec, který se zapíše do bloku sdílené paměti, a offset, což je offset na kterém má zápis začít.

Příklad 2023. Zápis do bloku sdílené paměti

<?php
$shm_bytes_written = shmop_write($shm_id, $my_string, 0);
?>

Tato ukázka zapíše data obsažená v $my_string do bloku sdílené paměti, a $shm_bytes_written obsahuje počet zapsaných bytů.

Předcházející | Nahoru | Další
shmop_size | Domů | CLI. SimpleXML functions


SimpleXML functions

Předcházející VI. Reference funkcí Další

CLI. SimpleXML functions

Úvod

The SimpleXML extension provides a very simple and easily usable toolset to convert XML to an object that can be processed with normal property selectors and array iterators.

Požadavky

The SimpleXML extension requires PHP 5.

Instalace

The SimpleXML extension is enabled by default. To disable it, use the --disable-simplexml configure option.

Příklady

Many examples in this reference require an XML string. Instead of repeating this string in every example, we put it into a file which we include in each example. This included file is shown in the following example section. Alternatively, you could create an XML document and read it with simplexml_load_file().

Příklad 2024. Include file example.php with XML string

<?php
$xmlstr = <<<XML
<?xml version='1.0' standalone='yes'?>
<movies>
 <movie>
  <title>PHP: Behind the Parser</title>
  <characters>
   <character>
    <name>Ms. Coder</name>
    <actor>Onlivia Actora</actor>
   </character>
   <character>
    <name>Mr. Coder</name>
    <actor>El Act&#211;r</actor>
   </character>
  </characters>
  <plot>
   So, this language. It's like, a programming language. Or is it a
   scripting language? All is revealed in this thrilling horror spoof
   of a documentary.
  </plot>
  <great-lines>
   <line>PHP solves all my web problems</line>
  </great-lines>
  <rating type="thumbs">7</rating>
  <rating type="stars">5</rating>
 </movie>
</movies>
XML;
?>

The simplicity of SimpleXML appears most clearly when one extracts a string or number from a basic XML document.

Příklad 2025. Getting <plot>

<?php
include 'example.php';

$xml = new SimpleXMLElement($xmlstr);

echo $xml->movie[0]->plot; // "So this language. It's like..."
?>

Accessing elements within an XML document that contain characters not permitted under PHP's naming convention (e.g. the hyphen) can be accomplished by encapsulating the element name within braces and the apostrophe.

Příklad 2026. Getting <line>

<?php
include 'example.php';

$xml = new SimpleXMLElement($xmlstr);

echo $xml->movie->{'great-lines'}->line; // "PHP solves all my web problems"
?>

Příklad 2027. Accessing non-unique elements in SimpleXML

When multiple instances of an element exist as children of a single parent element, normal iteration techniques apply.

<?php
include 'example.php';

$xml = new SimpleXMLElement($xmlstr);

/* For each <movie> node, we echo a separate <plot>. */
foreach ($xml->movie as $movie) {
   echo $movie->plot, '<br />';
}

?>

Příklad 2028. Using attributes

So far, we have only covered the work of reading element names and their values. SimpleXML can also access element attributes. Access attributes of an element just as you would elements of an array.

<?php
include 'example.php';

$xml = new SimpleXMLElement($xmlstr);

/* Access the <rating> nodes of the first movie.
 * Output the rating scale, too. */
foreach ($xml->movie[0]->rating as $rating) {
    switch((string) $rating['type']) { // Get attributes as element indices
    case 'thumbs':
        echo $rating, ' thumbs up';
        break;
    case 'stars':
        echo $rating, ' stars';
        break;
    }
}
?>

Příklad 2029. Comparing Elements and Attributes with Text

To compare an element or attribute with a string or pass it into a function that requires a string, you must cast it to a string using (string). Otherwise, PHP treats the element as an object.

<?php
include 'example.php';

$xml = new SimpleXMLElement($xmlstr);

if ((string) $xml->movie->title == 'PHP: Behind the Parser') {
    print 'My favorite movie.';
}

htmlentities((string) $xml->movie->title);
?>

Příklad 2030. Using XPath

SimpleXML includes built-in XPath support. To find all <character> elements:

<?php
include 'example.php';
$xml = new SimpleXMLElement($xmlstr);

foreach ($xml->xpath('//character') as $character) {
    echo $character->name, 'played by ', $character->actor, '<br />';
}
?>

'//' serves as a wildcard. To specify absolute paths, omit one of the slashes.

Příklad 2031. Setting values

Data in SimpleXML doesn't have to be constant. The object allows for manipulation of all of its elements.

<?php
include 'example.php';
$xml = new SimpleXMLElement($xmlstr);

$xml->movie[0]->characters->character[0]->name = 'Miss Coder';

echo $xml->asXML();
?>

The above code will output a new XML document, just like the original, except that the new XML will change Ms. Coder to Miss Coder.

Příklad 2032. Adding elements and attributes

Since PHP 5.1.3, SimpleXML has had the ability to easily add children and attributes.

<?php
include 'example.php';
$xml = new SimpleXMLElement($xmlstr);

$character = $xml->movie[0]->characters->addChild('character');
$character->addChild('name', 'Mr. Parser');
$character->addChild('actor', 'John Doe');

$rating = $xml->movie[0]->addChild('rating', 'PG');
$rating->addAttribute('type', 'mpaa');

echo $xml->asXML();
?>

The above code will output an XML document based on the original but having a new character and rating.

Příklad 2033. DOM Interoperability

PHP has a mechanism to convert XML nodes between SimpleXML and DOM formats. This example shows how one might change a DOM element to SimpleXML.

<?php
$dom = new domDocument;
$dom->loadXML('<books><book><title>blah</title></book></books>');
if (!$dom) {
     echo 'Error while parsing the document';
     exit;
}

$s = simplexml_import_dom($dom);

echo $s->book[0]->title;
?>

Obsah

SimpleXMLElement->addAttribute() — Adds an attribute to the SimpleXML element
SimpleXMLElement->addChild() — Adds a child element to the XML node
SimpleXMLElement->asXML() — Return a well-formed XML string based on SimpleXML element
SimpleXMLElement->attributes() — Identifies an element's attributes
SimpleXMLElement->children() — Finds children of given node
SimpleXMLElement->__construct() — Creates a new SimpleXMLElement object
SimpleXMLElement->getDocNamespaces() — Returns namespaces declared in document
SimpleXMLElement->getName() — Gets the name of the XML element
SimpleXMLElement->getNamespaces() — Returns namespaces used in document
SimpleXMLElement->registerXPathNamespace() — Creates a prefix/ns context for the next XPath query
SimpleXMLElement->xpath() — Runs XPath query on XML data
simplexml_import_dom — Get a SimpleXMLElement object from a DOM node.
simplexml_load_file — Interprets an XML file into an object
simplexml_load_string — Interprets a string of XML into an object
Předcházející | Nahoru | Další
shmop_write | Domů | SimpleXMLElement->addAttribute()


SimpleXMLElement->asXML()

(PHP 5 >= 5.0.1)

SimpleXMLElement->asXML() — Return a well-formed XML string based on SimpleXML element

Popis

class SimpleXMLElement {
mixed asXML ( [string $filename] )
}

The asXML method formats the parent object's data in XML version 1.0.

Seznam parametrů

filename

If specified, the function writes the data to the file rather than returning it.

Návratové hodnoty

If the filename isn't specified, this function returns a string on success and FALSE on error. If the parameter is specified, it returns TRUE if the file was written successfully and FALSE otherwise.

Příklady

Příklad 2036. Get XML

<?php
$string = <<<XML
<a>
 <b>
  <c>text</c>
  <c>stuff</c>
 </b>
 <d>
  <c>code</c>
 </d>
</a>
XML;

$xml = new SimpleXMLElement($string);

echo $xml->asXML(); // <?xml ... <a><b><c>text</c><c>stuff</c> ...

?>

asXML also works on Xpath results:

Příklad 2037. Using asXML() on Xpath results

<?php
// Continued from example XML above.

/* Search for <a><b><c> */
$result = $xml->xpath('/a/b/c');

while(list( , $node) = each($result)) {
    echo $node->asXML(); // <c>text</c> and <c>stuff</c>
}
?>

Předcházející | Nahoru | Další
SimpleXMLElement->addChild() | Domů | SimpleXMLElement->attributes()


SimpleXMLElement->attributes()

(PHP 5 >= 5.0.1)

SimpleXMLElement->attributes() — Identifies an element's attributes

Popis

class SimpleXMLElement {
SimpleXMLElement attributes ( [string $ns [, bool $is_prefix]] )
}

This function provides the attributes and values defined within an xml tag.

Poznámka: SimpleXML vytvořilo pravidlo pro vkládání iterativních vlastností do většiny metod. Nelze je prohlížet pomocí var_dump() nebo čímkoli jiným, co může prověřovat objekty.

Seznam parametrů

ns

An optional namespace for the retrieved attributes

is_prefix

Default to FALSE

Návratové hodnoty

Příklady

Příklad 2038. Interpret an XML string

<?php
$string = <<<XML
<a xmlns:b>
 <foo name="one" game="lonely">1</foo>
</a>
XML;

$xml = simplexml_load_string($string);
foreach($xml->foo[0]->attributes() as $a => $b) {
    echo $a,'="',$b,"\"\n";
}
?>

Výše uvedený příklad vypíše:

name="one"
game="lonely"

Předcházející | Nahoru | Další
SimpleXMLElement->asXML() | Domů | SimpleXMLElement->children()


SimpleXMLElement->children()

(PHP 5 >= 5.0.1)

SimpleXMLElement->children() — Finds children of given node

Popis

class SimpleXMLElement {
SimpleXMLElement children ( [string $ns [, bool $is_prefix]] )
}

This method finds the children of the element of which it is a member. The result follows normal iteration rules.

Poznámka: SimpleXML vytvořilo pravidlo pro vkládání iterativních vlastností do většiny metod. Nelze je prohlížet pomocí var_dump() nebo čímkoli jiným, co může prověřovat objekty.

Seznam parametrů

ns

is_prefix

Default to FALSE

Návratové hodnoty

ChangeLog (záznam změn)

Verze | Popis
5.2.0 | The optional parameter is_prefix was added.

Příklady

Příklad 2039. Traversing a children() pseudo-array

<?php
$xml = new SimpleXMLElement(
'<person>
 <child role="son">
  <child role="daughter"/>
 </child>
 <child role="daughter">
  <child role="son">
   <child role="son"/>
  </child>
 </child>
</person>');

foreach ($xml->children() as $second_gen) {
    echo ' The person begot a ' . $second_gen['role'];

    foreach ($second_gen->children() as $third_gen) {
        echo ' who begot a ' . $third_gen['role'] . ';';

        foreach ($third_gen->children() as $fourth_gen) {
            echo ' and that ' . $third_gen['role'] .
                ' begot a ' . $fourth_gen['role'];
        }
    }
}
?>

Výše uvedený příklad vypíše:

The person begot a son who begot a daughter; The person
begot a daughter who begot a son; and that son begot a son

Předcházející | Nahoru | Další
SimpleXMLElement->attributes() | Domů | SimpleXMLElement->__construct()


SimpleXMLElement->xpath()

(PHP 5 >= 5.2.0)

SimpleXMLElement->xpath() — Runs XPath query on XML data

Popis

class SimpleXMLElement {
array xpath ( string $path )
}

The xpath method searches the SimpleXML node for children matching the XPath path.

Seznam parametrů

path

An XPath path

Návratové hodnoty

Returns an array of SimpleXMLElement objects or FALSE in case of an error.

Příklady

Příklad 2047. Xpath

<?php
$string = <<<XML
<a>
 <b>
  <c>text</c>
  <c>stuff</c>
 </b>
 <d>
  <c>code</c>
 </d>
</a>
XML;

$xml = new SimpleXMLElement($string);

/* Search for <a><b><c> */
$result = $xml->xpath('/a/b/c');

while(list( , $node) = each($result)) {
    echo '/a/b/c: ',$node,"\n";
}

/* Relative paths also work... */
$result = $xml->xpath('b/c');

while(list( , $node) = each($result)) {
    echo 'b/c: ',$node,"\n";
}
?>

Výše uvedený příklad vypíše:

/a/b/c: text
/a/b/c: stuff
b/c: text
b/c: stuff

Notice that the two results are equal.

Předcházející | Nahoru | Další
SimpleXMLElement->registerXPathNamespace() | Domů | simplexml_import_dom


simplexml_import_dom

(PHP 5)

simplexml_import_dom — Get a SimpleXMLElement object from a DOM node.

Popis

SimpleXMLElement simplexml_import_dom ( DOMNode $node [, string $class_name] )

This function takes a node of a DOM document and makes it into a SimpleXML node. This new object can then be used as a native SimpleXML element.

Seznam parametrů

node

A DOM Element node

class_name

You may use this optional parameter so that simplexml_load_string() will return an object of the specified class. That class should extend the SimpleXMLElement class.

Návratové hodnoty

Returns a SimpleXMLElement or FALSE on failure.

Příklady

Příklad 2048. Importing DOM

<?php
$dom = new DOMDocument;
$dom->loadXML('<books><book><title>blah</title></book></books>');
if (!$dom) {
    echo 'Error while parsing the document';
    exit;
}

$s = simplexml_import_dom($dom);

echo $s->book[0]->title; // blah
?>

Viz také

dom_import_simplexml()

Předcházející | Nahoru | Další
SimpleXMLElement->xpath() | Domů | simplexml_load_file


simplexml_load_file

(PHP 5)

simplexml_load_file — Interprets an XML file into an object

Popis

object simplexml_load_file ( string $filename [, string $class_name [, int $options [, string $ns [, bool $is_prefix]]]] )

Convert the well-formed XML document in the given file to an object.

Seznam parametrů

filename

Path to the XML file

Poznámka: Libxml 2 unescapes the URI, so if you want to pass e.g. b&c as the URI parameter a, you have to call simplexml_load_file(rawurlencode('http://example.com/?a=' . urlencode('b&c'))). Since PHP 5.1.0 you don't need to do this because PHP will do it for you.

class_name

You may use this optional parameter so that simplexml_load_file() will return an object of the specified class. That class should extend the SimpleXMLElement class.

options

Since PHP 5.1.0 and Libxml 2.6.0, you may also use the options parameter to specify additional Libxml parameters.

ns

is_prefix

Návratové hodnoty

Returns an object of class SimpleXMLElement with properties containing the data held within the XML document. On errors, it will return FALSE.

Příklady

Příklad 2049. Interpret an XML document

<?php
// The file test.xml contains an XML document with a root element
// and at least an element /[root]/title.

if (file_exists('test.xml')) {
    $xml = simplexml_load_file('test.xml');

    print_r($xml);
} else {
    exit('Failed to open test.xml.');
}
?>

This script will display, on success:

SimpleXMLElement Object
(
  [title] => Example Title
  ...
)

At this point, you can go about using $xml->title and any other elements.

Viz také

simplexml_load_string
SimpleXMLElement->__construct()

Předcházející | Nahoru | Další
simplexml_import_dom | Domů | simplexml_load_string


simplexml_load_string

(PHP 5)

simplexml_load_string — Interprets a string of XML into an object

Popis

object simplexml_load_string ( string $data [, string $class_name [, int $options [, string $ns [, bool $is_prefix]]]] )

Takes a well-formed XML string and returns it as an object.

Seznam parametrů

data

A well-formed XML string

class_name

You may use this optional parameter so that simplexml_load_string() will return an object of the specified class. That class should extend the SimpleXMLElement class.

options

Since PHP 5.1.0 and Libxml 2.6.0, you may also use the options parameter to specify additional Libxml parameters.

ns

is_prefix

Návratové hodnoty

Returns an object of class SimpleXMLElement with properties containing the data held within the xml document. On errors, it will return FALSE.

Příklady

Příklad 2050. Interpret an XML string

<?php
$string = <<<XML
<?xml version='1.0'?>
<document>
 <title>Forty What?</title>
 <from>Joe</from>
 <to>Jane</to>
 <body>
  I know that's the answer -- but what's the question?
 </body>
</document>
XML;

$xml = simplexml_load_string($string);

var_dump($xml);
?>

Výše uvedený příklad vypíše:

SimpleXMLElement Object
(
  [title] => Forty What?
  [from] => Joe
  [to] => Jane
  [body] =>
   I know that's the answer -- but what's the question?
)

At this point, you can go about using $xml->body and such.

Viz také

simplexml_load_file
SimpleXMLElement->__construct()

Předcházející | Nahoru | Další
simplexml_load_file | Domů | CLII. SNMP Functions


SOAP Functions

Předcházející VI. Reference funkcí Další

CLIII. SOAP Functions

Úvod

The SOAP extension can be used to write SOAP Servers and Clients. It supports subsets of » SOAP 1.1, » SOAP 1.2 and » WSDL 1.1 specifications.

Požadavky

This extension makes use of the » GNOME xml library. Download and install this library. You will need at least libxml-2.5.4.

Instalace

This extension is only available if PHP was configured with --enable-soap.

Konfigurace běhu

Chování těchto funkcí je ovlivněno nastavením parametrů v php.ini.

Tabulka 281. SOAP Configuration Options

Name | Default | Changeable | Changelog
soap.wsdl_cache_enabled | "1" | PHP_INI_ALL | Available since PHP 5.0.0.
soap.wsdl_cache_dir | "/tmp" | PHP_INI_ALL | Available since PHP 5.0.0.
soap.wsdl_cache_ttl | "86400" | PHP_INI_ALL | Available since PHP 5.0.0.
soap.wsdl_cache_limit | "5" | PHP_INI_ALL | Available since PHP 5.1.5.

Pro další detaily a definice konstant PHP_INI_*, viz dokumentace k ini_set().

Zde je stručný popis konfiguračních direktiv.

soap.wsdl_cache_enabled boolean

Enables or disables the WSDL caching feature.

soap.wsdl_cache_dir string

Sets the directory name where the SOAP extension will put cache files.

soap.wsdl_cache_ttl int

Sets the number of seconds (time to live) that cached files will be used instead the originals.

soap.wsdl_cache_limit integer

Maximum number of in memory cached wsdl files

Předdefinované třídy

SoapClient

Konstruktory

  • SoapClient->__construct() - constructs a new SoapClient object

Metody

  • SoapClient->__call() - Calls a SOAP function (deprecated)

  • SoapClient->__doRequest() - Performs a SOAP request

  • SoapClient->__getFunctions() - Returns list of SOAP functions

  • SoapClient->__getLastRequest() - Returns last SOAP request

  • SoapClient->__getLastRequestHeaders() - Returns last SOAP request headers

  • SoapClient->__getLastResponse() - Returns last SOAP response

  • SoapClient->__getLastResponseHeaders() - Returns last SOAP response headers

  • SoapClient->__getTypes() - Returns list of SOAP types

  • SoapClient->__setCookie() - Sets the cookie that will be sent with the SOAP request

  • SoapClient->__soapCall() - Calls a SOAP function

SoapFault

Konstruktory

  • SoapFault->__construct() - construct a new SoapFault object

SoapHeader

SoapHeader is a special low-level class for passing or returning SOAP headers. It's just a data holder and it does not have any special methods except its constructor. It can be used in the SoapClient->__soapCall() method to pass a SOAP header or in a SOAP header handler to return the header in a SOAP response.

Konstruktory

  • SoapHeader->__construct() - construct a new SoapHeader object

SoapParam

SoapParam is a special low-level class for naming parameters and returning values in non-WSDL mode. It's just a data holder and it does not have any special methods except its constructor.

Konstruktory

  • SoapParam->__construct() - construct a new SoapParam object

SoapServer

Konstruktory

  • SoapServer->__construct() - construct a new SoapServer object

Metody

  • SoapServer->addFunction() - Adds one or several functions those will handle SOAP requests

  • SoapServer->fault() -

  • SoapServer->getFunctions() - Returns list of defined functions

  • SoapServer->handle() - Handles a SOAP request

  • SoapServer->setClass() - Sets class which will handle SOAP requests

  • SoapServer->setPersistence() - Sets persistence mode of SoapServer

SoapVar

SoapVar is a special low-level class for encoding parameters and returning values in non-WSDL mode. It's just a data holder and does not have any special methods except the constructor. It's useful when you want to set the type property in SOAP request or response.

Konstruktory

  • SoapVar->__construct() - construct a new SoapVar object

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

SOAP_1_1 (integer)
SOAP_1_2 (integer)
SOAP_PERSISTENCE_SESSION (integer)
SOAP_PERSISTENCE_REQUEST (integer)
SOAP_FUNCTIONS_ALL (integer)
SOAP_ENCODED (integer)
SOAP_LITERAL (integer)
SOAP_RPC (integer)
SOAP_DOCUMENT (integer)
SOAP_ACTOR_NEXT (integer)
SOAP_ACTOR_NONE (integer)
SOAP_ACTOR_UNLIMATERECEIVER (integer)
SOAP_COMPRESSION_ACCEPT (integer)
SOAP_COMPRESSION_GZIP (integer)
SOAP_COMPRESSION_DEFLATE (integer)
SOAP_WAIT_ONE_WAY_CALLS (integer)
Added in PHP 5.1.0.
UNKNOWN_TYPE (integer)
XSD_STRING (integer)
XSD_BOOLEAN (integer)
XSD_DECIMAL (integer)
XSD_FLOAT (integer)
XSD_DOUBLE (integer)
XSD_DURATION (integer)
XSD_DATETIME (integer)
XSD_TIME (integer)
XSD_DATE (integer)
XSD_GYEARMONTH (integer)
XSD_GYEAR (integer)
XSD_GMONTHDAY (integer)
XSD_GDAY (integer)
XSD_GMONTH (integer)
XSD_HEXBINARY (integer)
XSD_BASE64BINARY (integer)
XSD_ANYURI (integer)
XSD_ANYXML (integer)
Added in PHP 5.1.0.
XSD_QNAME (integer)
XSD_NOTATION (integer)
XSD_NORMALIZEDSTRING (integer)
XSD_TOKEN (integer)
XSD_LANGUAGE (integer)
XSD_NMTOKEN (integer)
XSD_NAME (integer)
XSD_NCNAME (integer)
XSD_ID (integer)
XSD_IDREF (integer)
XSD_IDREFS (integer)
XSD_ENTITY (integer)
XSD_ENTITIES (integer)
XSD_INTEGER (integer)
XSD_NONPOSITIVEINTEGER (integer)
XSD_NEGATIVEINTEGER (integer)
XSD_LONG (integer)
XSD_INT (integer)
XSD_SHORT (integer)
XSD_BYTE (integer)
XSD_NONNEGATIVEINTEGER (integer)
XSD_UNSIGNEDLONG (integer)
XSD_UNSIGNEDINT (integer)
XSD_UNSIGNEDSHORT (integer)
XSD_UNSIGNEDBYTE (integer)
XSD_POSITIVEINTEGER (integer)
XSD_NMTOKENS (integer)
XSD_ANYTYPE (integer)
SOAP_ENC_OBJECT (integer)
SOAP_ENC_ARRAY (integer)
XSD_1999_TIMEINSTANT (integer)
XSD_NAMESPACE (string)
XSD_1999_NAMESPACE (string)

Obsah

is_soap_fault — Checks if SOAP call was failed
SoapClient->__call() — Calls a SOAP function (deprecated)
SoapClient->__construct() — SoapClient constructor
SoapClient->__doRequest() — Performs a SOAP request
SoapClient->__getFunctions() — Returns list of SOAP functions
SoapClient->__getLastRequest() — Returns last SOAP request
SoapClient->__getLastRequestHeaders() — Returns last SOAP request headers
SoapClient->__getLastResponse() — Returns last SOAP response.
SoapClient->__getLastResponseHeaders() — Returns last SOAP response headers.
SoapClient->__getTypes() — Returns list of SOAP types
SoapClient->__setCookie() — Sets the cookie that will be sent with the SOAP request
SoapClient->__soapCall() — Calls a SOAP function
SoapFault->__construct() — SoapFault constructor
SoapHeader->__construct() — SoapHeader constructor
SoapParam->__construct() — SoapParam constructor
SoapServer->addFunction() — Adds one or several functions those will handle SOAP requests
SoapServer->__construct() — SoapServer constructor
SoapServer->fault() — Issue SoapServer fault indicating an error
SoapServer->getFunctions() — Returns list of defined functions
SoapServer->handle() — Handles a SOAP request
SoapServer->setClass() — Sets class which will handle SOAP requests
SoapServer->setPersistence() — Sets persistence mode of SoapServer
SoapVar->__construct() — SoapVar constructor
use_soap_error_handler — Set whether to use the SOAP error handler and return the former value
Předcházející | Nahoru | Další
snmpwalkoid | Domů | is_soap_fault


is_soap_fault

(PHP 5)

is_soap_fault — Checks if SOAP call was failed

Popis

bool is_soap_fault ( mixed $obj )

This function is useful when you like to check if the SOAP call failed, but don't like to use exceptions. To use it you must create a SoapClient object with the exceptions option set to zero or FALSE. In this case, the SOAP method will return a special SoapFault object which encapsulates the fault details (faultcode, faultstring, faultactor and faultdetails).

If exceptions is not set then SOAP call will throw an exception on error. is_soap_fault() checks if the given parameter is a SoapFault object.

Seznam parametrů

obj

The tested object.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 2056. is_soap_fault() example

<?php
$client = new SoapClient("some.wsdl", array('exceptions' => 0));
$result = $client->SomeFunction();
if (is_soap_fault($result)) {
    trigger_error("SOAP Fault: (faultcode: {$result->faultcode}, faultstring: {$result->faultstring})", E_USER_ERROR);
}
?>

Příklad 2057. SOAP's standard method for error reporting is exceptions

<?php
try {
    $client = new SoapClient("some.wsdl");
    $result = $client->SomeFunction(/* ... */);
} catch (SoapFault $fault) {
    trigger_error("SOAP Fault: (faultcode: {$fault->faultcode}, faultstring: {$fault->faultstring})", E_USER_ERROR);
}
?>

Viz také

SoapClient->__construct()
SoapFault->__construct()

Předcházející | Nahoru | Další
CLIII. SOAP Functions | Domů | SoapClient->__call()


SQLite Functions

Předcházející VI. Reference funkcí Další

CLVI. SQLite Functions

Úvod

This is an extension for the SQLite Embeddable SQL Database Engine. SQLite is a C library that implements an embeddable SQL database engine. Programs that link with the SQLite library can have SQL database access without running a separate RDBMS process.

SQLite is not a client library used to connect to a big database server. SQLite is the server. The SQLite library reads and writes directly to and from the database files on disk.

Poznámka: For further information see the SQLite Website (» http://sqlite.org/).

Installation

Read the INSTALL file, which comes with the package. Or just use the PEAR installer with pecl install sqlite. SQLite itself is already included, You do not need to install any additional software.

Windows users may download the DLL version of the SQLite extension here: (» php_sqlite.dll).

In PHP 5, the SQLite extension and the engine itself are bundled and compiled by default. However, since PHP 5.1.0 you need to manually activate the extension in php.ini (because it is now bundled as shared). Moreover, since PHP 5.1.0 SQLite depends on PDO it must be enabled too, by adding the following lines to php.ini (in order):

extension=php_pdo.dll
extension=php_sqlite.dll
On Linux or Unix operating systems, if you build PDO as a shared extension, you must build SQLite as a shared extension using the --with-sqlite=shared configure option.

SQLite 3 is supported through PDO SQLite.

Windows installation for unprivileged accounts: On Windows operating systems, unprivileged accounts don't have the TMP environment variable set by default. This will make sqlite create temporary files in the windows directory, which is not desirable. So, you should set the TMP environment variable for the web server or the user account the web server is running under. If Apache is your web server, you can accomplish this via a SetEnv directive in your httpd.conf file. For example:

SetEnv TMP c:/temp
If you are unable to establish this setting at the server level, you can implement the setting in your script:
putenv('TMP=C:/temp');
The setting must refer to a directory that the web server has permission to create files in and subsequently write to and delete the files it created. Otherwise, you may receive the following error message: malformed database schema - unable to open a temporary database file for storing temporary tables

Požadavky

In order to have these functions available, you must compile PHP with SQLite support, or load the SQLite extension dynamically from your php.ini.

Typy prostředků

There are two resources used in the SQLite Interface. The first one is the database connection, the second one the result set.

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

The functions sqlite_fetch_array() and sqlite_current() use a constant for the different types of result arrays. The following constants are defined:

SQLite result type constants

SQLITE_ASSOC (int)
Columns are returned into the array having the field name as the array index.
SQLITE_BOTH (int)
Columns are returned into the array having both a numerical index and the field name as the array index.
SQLITE_NUM (int)
Columns are returned into the array having a numerical index to the fields. This index starts with 0, the first field in the result.

A number of functions may return status codes. The following constants are defined:

SQLite status code constants

SQLITE_OK (int)
Successful result.
SQLITE_ERROR (int)
SQL error or missing database.
SQLITE_INTERNAL (int)
An internal logic error in SQLite.
SQLITE_PERM (int)
Access permission denied.
SQLITE_ABORT (int)
Callback routine requested an abort.
SQLITE_BUSY (int)
The database file is locked.
SQLITE_LOCKED (int)
A table in the database is locked.
SQLITE_NOMEM (int)
Memory allocation failed.
SQLITE_READONLY (int)
Attempt to write a readonly database.
SQLITE_INTERRUPT (int)
Operation terminated internally.
SQLITE_IOERR (int)
Disk I/O error occurred.
SQLITE_CORRUPT (int)
The database disk image is malformed.
SQLITE_NOTFOUND (int)
(Internal) Table or record not found.
SQLITE_FULL (int)
Insertion failed because database is full.
SQLITE_CANTOPEN (int)
Unable to open the database file.
SQLITE_PROTOCOL (int)
Database lock protocol error.
SQLITE_EMPTY (int)
(Internal) Database table is empty.
SQLITE_SCHEMA (int)
The database schema changed.
SQLITE_TOOBIG (int)
Too much data for one row of a table.
SQLITE_CONSTRAINT (int)
Abort due to constraint violation.
SQLITE_MISMATCH (int)
Data type mismatch.
SQLITE_MISUSE (int)
Library used incorrectly.
SQLITE_NOLFS (int)
Uses of OS features not supported on host.
SQLITE_AUTH (int)
Authorized failed.
SQLITE_ROW (int)
Internal process has another row ready.
SQLITE_DONE (int)
Internal process has finished executing.

Předdefinované třídy

SQLiteDatabase

Represents an opened SQLite database.

Konstruktory

  • __construct - construct a new SQLiteDatabase object

Metody

  • query - Execute a query

  • queryExec - Execute a result-less query

  • arrayQuery - Execute a query and return the result as an array

  • singleQuery - Execute a query and return either an array for one single column or the value of the first row

  • unbufferedQuery - Execute an unbuffered query

  • lastInsertRowid - Returns the rowid of the most recently inserted row

  • changes - Returns the number of rows changed by the most recent statement

  • createAggregate - Register an aggregating UDF for use in SQL statements

  • createFunction - Register a UDF for use in SQL statements

  • busyTimeout - Sets or disables busy timeout duration

  • lastError - Returns the last error code of the most recently encountered error

  • fetchColumnTypes - Return an array of column types from a particular table

SQLiteResult

Represents a buffered SQLite result set.

Metody

  • fetch - Fetches the next row from the result set as an array

  • fetchObject - Fetches the next row from the result set as an object

  • fetchSingle - Fetches the first column from the result set as a string

  • fetchAll - Fetches all rows from the result set as an array of arrays

  • column - Fetches a column from the current row of the result set

  • numFields - Returns the number of fields in the result set

  • fieldName - Returns the name of a particular field in the result set

  • current - Fetches the current row from the result set as an array

  • key - Return the current row index

  • next - Seek to the next row number

  • valid - Returns whether more rows are available

  • rewind - Seek to the first row number of the result set

  • prev - Seek to the previous row number of the result set

  • hasPrev - Returns whether or not a previous row is available

  • numRows - Returns the number of rows in the result set

  • seek - Seek to a particular row number

SQLiteUnbuffered

Represents an unbuffered SQLite result set. Unbuffered results sets are sequential, forward-seeking only.

Metody

  • fetch - Fetches the next row from the result set as an array

  • fetchObject - Fetches the next row from the result set as an object

  • fetchSingle - Fetches the first column from the result set as a string

  • fetchAll - Fetches all rows from the result set as an array of arrays

  • column - Fetches a column from the current row of the result set

  • numFields - Returns the number of fields in the result set

  • fieldName - Returns the name of a particular field in the result set

  • current - Fetches the current row from the result set as an array

  • next - Seek to the next row number

  • valid - Returns whether more rows are available

Konfigurace běhu

Chování těchto funkcí je ovlivněno nastavením parametrů v php.ini.

Tabulka 290. SQLite Konfigurační volby

Jméno | Výchozí | Měnitelné | Changelog
sqlite.assoc_case | "0" | PHP_INI_ALL | Available since PHP 5.0.0.

Pro další detaily a definice konstant PHP_INI_*, viz dokumentace k ini_set().

Zde je stručný popis konfiguračních direktiv.

sqlite.assoc_case int

Whether to use mixed case (0), upper case (1) or lower case (2) hash indexes.

This option is primarily useful when you need compatibility with other database systems, where the names of the columns are always returned as uppercase or lowercase, regardless of the case of the actual field names in the database schema.

The SQLite library returns the column names in their natural case (that matches the case you used in your schema). When sqlite.assoc_case is set to 0 the natural case will be preserved. When it is set to 1 or 2, PHP will apply case folding on the hash keys to upper- or lower-case the keys, respectively.

Use of this option incurs a slight performance penalty, but is MUCH faster than performing the case folding yourself using PHP script.

Obsah

sqlite_array_query — Execute a query against a given database and returns an array
sqlite_busy_timeout — Set busy timeout duration, or disable busy handlers
sqlite_changes — Returns the number of rows that were changed by the most recent SQL statement
sqlite_close — Closes an open SQLite database
sqlite_column — Fetches a column from the current row of a result set
sqlite_create_aggregate — Register an aggregating UDF for use in SQL statements
sqlite_create_function — Registers a "regular" User Defined Function for use in SQL statements
sqlite_current — Fetches the current row from a result set as an array
sqlite_error_string — Returns the textual description of an error code
sqlite_escape_string — Escapes a string for use as a query parameter
sqlite_exec — Executes a result-less query against a given database
sqlite_factory — Opens a SQLite database and returns a SQLiteDatabase object
sqlite_fetch_all — Fetches all rows from a result set as an array of arrays
sqlite_fetch_array — Fetches the next row from a result set as an array
sqlite_fetch_column_types — Return an array of column types from a particular table
sqlite_fetch_object — Fetches the next row from a result set as an object
sqlite_fetch_single — Fetches the first column of a result set as a string
sqlite_fetch_string — Alias pro sqlite_fetch_single()
sqlite_field_name — Returns the name of a particular field
sqlite_has_more — Finds whether or not more rows are available
sqlite_has_prev — Returns whether or not a previous row is available
sqlite_key — Returns the current row index
sqlite_last_error — Returns the error code of the last error for a database
sqlite_last_insert_rowid — Returns the rowid of the most recently inserted row
sqlite_libencoding — Returns the encoding of the linked SQLite library
sqlite_libversion — Returns the version of the linked SQLite library
sqlite_next — Seek to the next row number
sqlite_num_fields — Returns the number of fields in a result set
sqlite_num_rows — Returns the number of rows in a buffered result set
sqlite_open — Opens a SQLite database and create the database if it does not exist
sqlite_popen — Opens a persistent handle to an SQLite database and create the database if it does not exist
sqlite_prev — Seek to the previous row number of a result set
sqlite_query — Executes a query against a given database and returns a result handle
sqlite_rewind — Seek to the first row number
sqlite_seek — Seek to a particular row number of a buffered result set
sqlite_single_query — Executes a query and returns either an array for one single column or the value of the first row
sqlite_udf_decode_binary — Decode binary data passed as parameters to an UDF
sqlite_udf_encode_binary — Encode binary data before returning it from an UDF
sqlite_unbuffered_query — Execute a query that does not prefetch and buffer all data
sqlite_valid — Returns whether more rows are available
Předcházející | Nahoru | Další
spl_object_hash | Domů | sqlite_array_query


sqlite_array_query

Předcházející CLVI. SQLite Functions Další

sqlite_array_query,

(PHP 5, PECL sqlite:1.0-1.0.3)

sqlite_array_query, SQLiteDatabase->arrayQuery — Execute a query against a given database and returns an array

Popis

array sqlite_array_query ( resource $dbhandle, string $query [, int $result_type [, bool $decode_binary]] )
array sqlite_array_query ( string $query, resource $dbhandle [, int $result_type [, bool $decode_binary]] )

Object oriented style (method):

class SQLiteDatabase {
array arrayQuery ( string $query [, int $result_type [, bool $decode_binary]] )
}

sqlite_array_query() executes the given query and returns an array of the entire result set. It is similar to calling sqlite_query() and then sqlite_fetch_array() for each row in the result set. sqlite_array_query() is significantly faster than the aforementioned.

Tip

sqlite_array_query() is best suited to queries returning 45 rows or less. If you have more data than that, it is recommended that you write your scripts to use sqlite_unbuffered_query() instead for more optimal performance.

Seznam parametrů

query

The query to be executed.

dbhandle

The SQLite Database resource; returned from sqlite_open() when used procedurally. This parameter is not required when using the object-oriented method.

result_type

Nepovinný parametr result_type přijímá konstantu a určuje, jak bude indexováno vrácené pole. Konstanta SQLITE_ASSOC způsobí vracení pouze asociativních indexů (pojmenované prvky), kdežto SQLITE_NUM znamená vracení jen numerických indexů. Hodnota SQLITE_BOTH způsobí, že budou použity obě formy indexace. Výchozí hodnota pro tuto funkci je SQLITE_BOTH.

decode_binary

Když je parametr decode_binary nastaven na TRUE (výchozí hodnota), PHP bude dekódovat binární kódování; týká se to dat, která byla zakódována pomocí sqlite_escape_string(). Toto byste normálně měli ponechat ve výchozím nastavení, s výjimkou případu, kdy potřebujete zajistit interoperabilitu s databázemi, které byly vytvořeny pomocí jiných aplikací využívajících sqlite.

Poznámka: Pro kompatibilitu s jinými databázovými rozšířeními (např. MySQL) jsou podporovány dvě alternativní syntaxe. Preferována je první z nich, kde parametr dbhandle je prvním parametrem funkce.

Návratové hodnoty

Returns an array of the entire result set; FALSE otherwise.

Názvy sloupců zjištěné pomocí SQLITE_ASSOC a SQLITE_BOTH will be upraveny z hlediska malých/velkých písmen podle hodnoty konfiguračního parametru sqlite.assoc_case.

Příklady

Příklad 2103. Procedural style

<?php
$dbhandle = sqlite_open('sqlitedb');
$result = sqlite_array_query($dbhandle, 'SELECT name, email FROM users LIMIT 25', SQLITE_ASSOC);
foreach ($result as $entry) {
    echo 'Name: ' . $entry['name'] . '  E-mail: ' . $entry['email'];
}
?>

Příklad 2104. Object-oriented style

<?php
$dbhandle = new SQLiteDatabase('sqlitedb');
$result = $dbhandle->arrayQuery('SELECT name, email FROM users LIMIT 25', SQLITE_ASSOC);
foreach ($result as $entry) {
    echo 'Name: ' . $entry['name'] . '  E-mail: ' . $entry['email'];
}
?>

Viz také

sqlite_query()
sqlite_fetch_array()
sqlite_fetch_string()

Předcházející | Nahoru | Další
CLVI. SQLite Functions | Domů | sqlite_busy_timeout


sqlite_busy_timeout

Předcházející CLVI. SQLite Functions Další

sqlite_busy_timeout,

(PHP 5, PECL sqlite:1.0-1.0.3)

sqlite_busy_timeout, SQLiteDatabase->busyTimeout — Set busy timeout duration, or disable busy handlers

Popis

void sqlite_busy_timeout ( resource $dbhandle, int $milliseconds )

Object oriented style (method):

class SQLiteDatabase {
void busyTimeout ( int $milliseconds )
}

Set the maximum time, in milliseconds, that SQLite will wait for a dbhandle to become ready for use.

Seznam parametrů

dbhandle

The SQLite Database resource; returned from sqlite_open() when used procedurally. This parameter is not required when using the object-oriented method.

milliseconds

The number of milliseconds. When set to 0, busy handlers will be disabled and SQLite will return immediately with a SQLITE_BUSY status code if another process/thread has the database locked for an update.

PHP sets the default busy timeout to be 60 seconds when the database is opened.

Poznámka: There are one thousand (1000) milliseconds in one second.

Návratové hodnoty

Nevrací se žádná hodnota.

Příklady

Příklad 2105. Procedural style

<?php
$dbhandle = sqlite_open('sqlitedb');
sqlite_busy_timeout($dbhandle, 10000); // set timeout to 10 seconds
sqlite_busy_timeout($dbhandle, 0); // disable busy handler
?>

Příklad 2106. Object oriented style

<?php
$dbhandle = new SQLiteDatabase('sqlitedb');
$dbhandle->busyTimeout(10000); // 10 seconds
$dbhandle->busyTimeout(0); // disable
?>

Viz také

sqlite_open()

Předcházející | Nahoru | Další
sqlite_array_query | Domů | sqlite_changes


sqlite_changes

Předcházející CLVI. SQLite Functions Další

sqlite_changes,

(PHP 5, PECL sqlite:1.0-1.0.3)

sqlite_changes, SQLiteDatabase->changes — Returns the number of rows that were changed by the most recent SQL statement

Popis

int sqlite_changes ( resource $dbhandle )

Object oriented style (method):

class SQLiteDatabase {
int changes ( void )
}

Returns the numbers of rows that were changed by the most recent SQL statement executed against the dbhandle database handle.

Seznam parametrů

dbhandle

The SQLite Database resource; returned from sqlite_open() when used procedurally. This parameter is not required when using the object-oriented method.

Příklady

Příklad 2107. Procedural style

<?php
$dbhandle = sqlite_open('mysqlitedb');
$query = sqlite_query($dbhandle, "UPDATE users SET email='jDoe@example.com' WHERE username='jDoe'");
if (!$query) {
    exit('Error in query.');
} else {
    echo 'Number of rows modified: ', sqlite_changes($dbhandle);
}
?>

Příklad 2108. Object oriented style

<?php
$dbhandle = new SQLiteDatabase('mysqlitedb');
$query = $dbhandle->query("UPDATE users SET email='jDoe@example.com' WHERE username='jDoe'");
if (!$query) {
    exit('Error in query.');
} else {
    echo 'Number of rows modified: ', $dbhandle->changes();
}
?>

Viz také

sqlite_open()

Předcházející | Nahoru | Další
sqlite_busy_timeout | Domů | sqlite_close


sqlite_close

(PHP 5, PECL sqlite:1.0-1.0.3)

sqlite_close — Closes an open SQLite database

Popis

void sqlite_close ( resource $dbhandle )

Closes the given database handle. If the database was persistent, it will be closed and removed from the persistent list.

Seznam parametrů

dbhandle

The SQLite Database resource; returned from sqlite_open() when used procedurally.

Návratové hodnoty

Nevrací se žádná hodnota.

Příklady

Příklad 2109. sqlite_close() example

<?php
$dbhandle = sqlite_open('sqlitedb');
sqlite_close($dbhandle);
?>

Viz také

sqlite_open()
sqlite_popen()

Předcházející | Nahoru | Další
sqlite_changes | Domů | sqlite_column


sqlite_column

Předcházející CLVI. SQLite Functions Další

sqlite_column,

(PHP 5, PECL sqlite:1.0-1.0.3)

sqlite_column, SQLiteResult->column, SQLiteUnbuffered->column — Fetches a column from the current row of a result set

Popis

mixed sqlite_column ( resource $result, mixed $index_or_name [, bool $decode_binary] )
class SQLiteResult {
mixed column ( mixed $index_or_name [, bool $decode_binary] )
} class SQLiteUnbuffered {
mixed column ( mixed $index_or_name [, bool $decode_binary] )
}

Fetches the value of a column named index_or_name (if it is a string), or of the ordinal column numbered index_or_name (if it is an integer) from the current row of the query result handle result.

Seznam parametrů

result

The SQLite result resource. This parameter is not required when using the object-oriented method.

index_or_name

The column index or name to fetch.

decode_binary

Když je parametr decode_binary nastaven na TRUE (výchozí hodnota), PHP bude dekódovat binární kódování; týká se to dat, která byla zakódována pomocí sqlite_escape_string(). Toto byste normálně měli ponechat ve výchozím nastavení, s výjimkou případu, kdy potřebujete zajistit interoperabilitu s databázemi, které byly vytvořeny pomocí jiných aplikací využívajících sqlite.

Poznámky

Poznámka: Use this function when you are iterating a large result set with many columns, or with columns that contain large amounts of data.

Viz také

sqlite_fetch_string()

Předcházející | Nahoru | Další
sqlite_close | Domů | sqlite_create_aggregate


sqlite_create_aggregate

Předcházející CLVI. SQLite Functions Další

sqlite_create_aggregate,

(PHP 5, PECL sqlite:1.0-1.0.3)

sqlite_create_aggregate, SQLiteDatabase->createAggregate — Register an aggregating UDF for use in SQL statements

Popis

void sqlite_create_aggregate ( resource $dbhandle, string $function_name, callback $step_func, callback $finalize_func [, int $num_args] )

Object oriented style (method):

class SQLiteDatabase {
void createAggregate ( string $function_name, callback $step_func, callback $finalize_func [, int $num_args] )
}

sqlite_create_aggregate() is similar to sqlite_create_function() except that it registers functions that can be used to calculate a result aggregated across all the rows of a query.

The key difference between this function and sqlite_create_function() is that two functions are required to manage the aggregate; step_func is called for each row of the result set. Your PHP function should accumulate the result and store it into the aggregation context. Once all the rows have been processed, finalize_func will be called and it should then take the data from the aggregation context and return the result. Callback functions should return a type understood by SQLite (i.e. scalar type).

Seznam parametrů

dbhandle

The SQLite Database resource; returned from sqlite_open() when used procedurally. This parameter is not required when using the object-oriented method.

function_name

The name of the function used in SQL statements.

step_func

Callback function called for each row of the result set.

finalize_func

Callback function to aggregate the "stepped" data from each row.

num_args

Hint to the SQLite parser if the callback function accepts a predetermined number of arguments.

Návratové hodnoty

Nevrací se žádná hodnota.

Příklady

Příklad 2110. max_length aggregation function example

<?php
$data = array(
   'one',
   'two',
   'three',
   'four',
   'five',
   'six',
   'seven',
   'eight',
   'nine',
   'ten',
   );
$dbhandle = sqlite_open(':memory:');
sqlite_query($dbhandle, "CREATE TABLE strings(a)");
foreach ($data as $str) {
    $str = sqlite_escape_string($str);
    sqlite_query($dbhandle, "INSERT INTO strings VALUES ('$str')");
}

function max_len_step(&$context, $string)
{
    if (strlen($string) > $context) {
        $context = strlen($string);
    }
}

function max_len_finalize(&$context)
{
    return $context;
}

sqlite_create_aggregate($dbhandle, 'max_len', 'max_len_step', 'max_len_finalize');

var_dump(sqlite_array_query($dbhandle, 'SELECT max_len(a) from strings'));

?>

In this example, we are creating an aggregating function that will calculate the length of the longest string in one of the columns of the table. For each row, the max_len_step function is called and passed a context parameter. The context parameter is just like any other PHP variable and be set to hold an array or even an object value. In this example, we are simply using it to hold the maximum length we have seen so far; if the string has a length longer than the current maximum, we update the context to hold this new maximum length.

After all of the rows have been processed, SQLite calls the max_len_finalize function to determine the aggregate result. Here, we could perform some kind of calculation based on the data found in the context. In our simple example though, we have been calculating the result as the query progressed, so we simply need to return the context value.

Poznámka: The example above will not work correctly if the column contains binary data. Take a look at the manual page for sqlite_udf_decode_binary() for an explanation of why this is so, and an example of how to make it respect the binary encoding.

Tip

It is NOT recommended for you to store a copy of the values in the context and then process them at the end, as you would cause SQLite to use a lot of memory to process the query - just think of how much memory you would need if a million rows were stored in memory, each containing a string 32 bytes in length.

Tip

You can use sqlite_create_function() and sqlite_create_aggregate() to override SQLite native SQL functions.

Viz také

sqlite_create_function()
sqlite_udf_encode_binary()
sqlite_udf_decode_binary()

Předcházející | Nahoru | Další
sqlite_column | Domů | sqlite_create_function


sqlite_create_function

Předcházející CLVI. SQLite Functions Další

sqlite_create_function,

(PHP 5, PECL pdo_sqlite:0.2-0.3 sqlite:1.0-1.0.3)

sqlite_create_function, SQLiteDatabase->createFunction — Registers a "regular" User Defined Function for use in SQL statements

Popis

void sqlite_create_function ( resource $dbhandle, string $function_name, callback $callback [, int $num_args] )

Object oriented style (method):

class SQLiteDatabase {
void createFunction ( string $function_name, callback $callback [, int $num_args] )
}

sqlite_create_function() allows you to register a PHP function with SQLite as an UDF (User Defined Function), so that it can be called from within your SQL statements.

The UDF can be used in any SQL statement that can call functions, such as SELECT and UPDATE statements and also in triggers.

Seznam parametrů

dbhandle

The SQLite Database resource; returned from sqlite_open() when used procedurally. This parameter is not required when using the object-oriented method.

function_name

The name of the function used in SQL statements.

callback

Callback function to handle the defined SQL function.

Poznámka: Callback functions should return a type understood by SQLite (i.e. scalar type).

num_args

Hint to the SQLite parser if the callback function accepts a predetermined number of arguments.

Poznámka: Pro kompatibilitu s jinými databázovými rozšířeními (např. MySQL) jsou podporovány dvě alternativní syntaxe. Preferována je první z nich, kde parametr dbhandle je prvním parametrem funkce.

Návratové hodnoty

Nevrací se žádná hodnota.

Příklady

Příklad 2111. sqlite_create_function() example

<?php
function md5_and_reverse($string)
{
    return strrev(md5($string));
}

if ($dbhandle = sqlite_open('mysqlitedb', 0666, $sqliteerror)) {

    sqlite_create_function($dbhandle, 'md5rev', 'md5_and_reverse', 1);

    $sql  = 'SELECT md5rev(filename) FROM files';
    $rows = sqlite_array_query($dbhandle, $sql);
} else {
    echo 'Error opening sqlite db: ' . $sqliteerror;
    exit;
}
?>

In this example, we have a function that calculates the md5 sum of a string, and then reverses it. When the SQL statement executes, it returns the value of the filename transformed by our function. The data returned in $rows contains the processed result.

The beauty of this technique is that you do not need to process the result using a foreach() loop after you have queried for the data.

PHP registers a special function named php when the database is first opened. The php function can be used to call any PHP function without having to register it first.

Příklad 2112. Example of using the PHP function

<?php
$rows = sqlite_array_query($dbhandle, "SELECT php('md5', filename) from files");
?>

This example will call the md5() on each filename column in the database and return the result into $rows

Poznámka: For performance reasons, PHP will not automatically encode/decode binary data passed to and from your UDF's. You need to manually encode/decode the parameters and return values if you need to process binary data in this way. Take a look at sqlite_udf_encode_binary() and sqlite_udf_decode_binary() for more details.

Tip

It is not recommended to use UDF's to handle processing of binary data, unless high performance is not a key requirement of your application.

Tip

You can use sqlite_create_function() and sqlite_create_aggregate() to override SQLite native SQL functions.

Viz také

sqlite_create_aggregate()

Předcházející | Nahoru | Další
sqlite_create_aggregate | Domů | sqlite_current


sqlite_current

Předcházející CLVI. SQLite Functions Další

sqlite_current,

(PHP 5, PECL sqlite:1.0-1.0.3)

sqlite_current, SQLiteResult->current, SQLiteUnbuffered->current — Fetches the current row from a result set as an array

Popis

array sqlite_current ( resource $result [, int $result_type [, bool $decode_binary]] )

Object oriented style (method):

class SQLiteResult {
array current ( [int $result_type [, bool $decode_binary]] )
} class SQLiteUnbuffered {
array current ( [int $result_type [, bool $decode_binary]] )
}

sqlite_current() is identical to sqlite_fetch_array() except that it does not advance to the next row prior to returning the data; it returns the data from the current position only.

Seznam parametrů

result

The SQLite result resource. This parameter is not required when using the object-oriented method.

result_type

Nepovinný parametr result_type přijímá konstantu a určuje, jak bude indexováno vrácené pole. Konstanta SQLITE_ASSOC způsobí vracení pouze asociativních indexů (pojmenované prvky), kdežto SQLITE_NUM znamená vracení jen numerických indexů. Hodnota SQLITE_BOTH způsobí, že budou použity obě formy indexace. Výchozí hodnota pro tuto funkci je SQLITE_BOTH.

decode_binary

Když je parametr decode_binary nastaven na TRUE (výchozí hodnota), PHP bude dekódovat binární kódování; týká se to dat, která byla zakódována pomocí sqlite_escape_string(). Toto byste normálně měli ponechat ve výchozím nastavení, s výjimkou případu, kdy potřebujete zajistit interoperabilitu s databázemi, které byly vytvořeny pomocí jiných aplikací využívajících sqlite.

Návratové hodnoty

Returns an array of the current row from a result set; FALSE if the current position is beyond the final row.

Názvy sloupců zjištěné pomocí SQLITE_ASSOC a SQLITE_BOTH will be upraveny z hlediska malých/velkých písmen podle hodnoty konfiguračního parametru sqlite.assoc_case.

Viz také

sqlite_seek()
sqlite_next()
sqlite_fetch_array()

Předcházející | Nahoru | Další
sqlite_create_function | Domů | sqlite_error_string


sqlite_error_string

(PHP 5, PECL sqlite:1.0-1.0.3)

sqlite_error_string — Returns the textual description of an error code

Popis

string sqlite_error_string ( int $error_code )

Returns a human readable description of the error_code returned from sqlite_last_error().

Viz také

sqlite_last_error()

Předcházející | Nahoru | Další
sqlite_current | Domů | sqlite_escape_string


sqlite_escape_string

(PHP 5, PECL sqlite:1.0-1.0.3)

sqlite_escape_string — Escapes a string for use as a query parameter

Popis

string sqlite_escape_string ( string $item )

sqlite_escape_string() will correctly quote the string specified by item for use in an SQLite SQL statement. This includes doubling up single-quote characters (') and checking for binary-unsafe characters in the query string.

If the item contains a NUL character, or if it begins with a character whose ordinal value is 0x01, PHP will apply a binary encoding scheme so that you can safely store and retrieve binary data.

Although the encoding makes it safe to insert the data, it will render simple text comparisons and LIKE clauses in your queries unusable for the columns that contain the binary data. In practice, this shouldn't be a problem, as your schema should be such that you don't use such things on binary columns (in fact, it might be better to store binary data using other means, such as in files).

Varování

addslashes() should NOT be used to quote your strings for SQLite queries; it will lead to strange results when retrieving your data.

Poznámka:
    Do not use this function to encode the return values from UDF's created
    using sqlite_create_function() or
    sqlite_create_aggregate() - use
    sqlite_udf_encode_binary() instead.

Viz také

sqlite_udf_encode_binary()

Předcházející | Nahoru | Další
sqlite_error_string | Domů | sqlite_exec


sqlite_exec

Předcházející CLVI. SQLite Functions Další

sqlite_exec,

(PHP 5, PECL sqlite:1.0.3)

sqlite_exec, SQLiteDatabase->exec — Executes a result-less query against a given database

Popis

bool sqlite_exec ( resource $dbhandle, string $query [, string &$error_msg] )
bool sqlite_exec ( string $query, resource $dbhandle )

Object oriented style (method):

class SQLiteDatabase {
bool queryExec ( string $query [, string &$error_msg] )
}

Executes an SQL statement given by the query against a given database handle (specified by the dbhandle parameter).

Varování

SQLite will execute multiple queries separated by semicolons, so you can use it to execute a batch of SQL that you have loaded from a file or have embedded in a script.

Seznam parametrů

dbhandle

The SQLite Database resource; returned from sqlite_open() when used procedurally. This parameter is not required when using the object-oriented method.

query

The query to be executed.

error_msg

The specified variable will be filled if an error occurs. This is specially important because SQL syntax errors can't be fetched using the sqlite_last_error() function.

Poznámka: Pro kompatibilitu s jinými databázovými rozšířeními (např. MySQL) jsou podporovány dvě alternativní syntaxe. Preferována je první z nich, kde parametr dbhandle je prvním parametrem funkce.

Návratové hodnoty

This function will return a boolean result; TRUE for success or FALSE for failure. If you need to run a query that returns rows, see sqlite_query().

Názvy sloupců zjištěné pomocí SQLITE_ASSOC a SQLITE_BOTH will be upraveny z hlediska malých/velkých písmen podle hodnoty konfiguračního parametru sqlite.assoc_case.

ChangeLog (záznam změn)

Verze | Popis
5.1.0 | Added the error_msg parameter

Příklady

Příklad 2113. Procedural example

<?php
$dbhandle = sqlite_open('mysqlitedb');
$query = sqlite_exec($dbhandle, "UPDATE users SET email='jDoe@example.com' WHERE username='jDoe'", $error);
if (!$query) {
    exit("Error in query: '$error'");
} else {
    echo 'Number of rows modified: ', sqlite_changes($dbhandle);
}
?>

Příklad 2114. Object-oriented example

<?php
$dbhandle = new SQLiteDatabase('mysqlitedb');
$query = $dbhandle->queryExec("UPDATE users SET email='jDoe@example.com' WHERE username='jDoe'", $error);
if (!$query) {
    exit("Error in query: '$error'");
} else {
    echo 'Number of rows modified: ', $dbhandle->changes();
}
?>

Viz také

sqlite_query()
sqlite_unbuffered_query()
sqlite_array_query()

Předcházející | Nahoru | Další
sqlite_escape_string | Domů | sqlite_factory


sqlite_factory

(PHP 5)

sqlite_factory — Opens a SQLite database and returns a SQLiteDatabase object

Popis

SQLiteDatabase sqlite_factory ( string $filename [, int $mode [, string &$error_message]] )

sqlite_factory() behaves similarly to sqlite_open() in that it opens an SQLite database or attempts to create it if it does not exist. However, a SQLiteDatabase object is returned rather than a resource. Please see the sqlite_open() reference page for further usage and caveats.

Seznam parametrů

filename

The filename of the SQLite database.

mode

The mode of the file. Intended to be used to open the database in read-only mode. Presently, this parameter is ignored by the sqlite library. The default value for mode is the octal value 0666 and this is the recommended value.

error_message

Passed by reference and is set to hold a descriptive error message explaining why the database could not be opened if there was an error.

Návratové hodnoty

Returns a SQLiteDatabase object on success, NULL on error.

Příklady

Příklad 2115. sqlite_factory() example

<?php
$dbhandle = sqlite_factory('sqlitedb');
$dbhandle->query('SELECT user_id, username FROM users');

/* functionally equivalent to: */

$dbhandle = new SQLiteDatabase('sqlitedb');
$dbhandle->query('SELECT user_id, username FROM users');

?>

Viz také

sqlite_open()
sqlite_popen()

Předcházející | Nahoru | Další
sqlite_exec | Domů | sqlite_fetch_all


sqlite_fetch_all

Předcházející CLVI. SQLite Functions Další

sqlite_fetch_all,

(PHP 5, PECL sqlite:1.0-1.0.3)

sqlite_fetch_all, SQLiteResult->fetchAll, SQLiteUnbuffered->fetchAll — Fetches all rows from a result set as an array of arrays

Popis

array sqlite_fetch_all ( resource $result [, int $result_type [, bool $decode_binary]] )

Object oriented style (method):

class SQLiteResult {
array fetchAll ( [int $result_type [, bool $decode_binary]] )
} class SQLiteUnbuffered {
array fetchAll ( [int $result_type [, bool $decode_binary]] )
}

sqlite_fetch_all() returns an array of the entire result set from the result resource. It is similar to calling sqlite_query() (or sqlite_unbuffered_query()) and then sqlite_fetch_array() for each row in the result set.

Seznam parametrů

result

The SQLite result resource. This parameter is not required when using the object-oriented method.

result_type

Nepovinný parametr result_type přijímá konstantu a určuje, jak bude indexováno vrácené pole. Konstanta SQLITE_ASSOC způsobí vracení pouze asociativních indexů (pojmenované prvky), kdežto SQLITE_NUM znamená vracení jen numerických indexů. Hodnota SQLITE_BOTH způsobí, že budou použity obě formy indexace. Výchozí hodnota pro tuto funkci je SQLITE_BOTH.

decode_binary

Když je parametr decode_binary nastaven na TRUE (výchozí hodnota), PHP bude dekódovat binární kódování; týká se to dat, která byla zakódována pomocí sqlite_escape_string(). Toto byste normálně měli ponechat ve výchozím nastavení, s výjimkou případu, kdy potřebujete zajistit interoperabilitu s databázemi, které byly vytvořeny pomocí jiných aplikací využívajících sqlite.

Návratové hodnoty

Returns an array of the remaining rows in a result set. If called right after sqlite_query(), it returns all rows. If called after sqlite_fetch_array(), it returns the rest. If there are no rows in a result set, it returns an empty array.

Názvy sloupců zjištěné pomocí SQLITE_ASSOC a SQLITE_BOTH will be upraveny z hlediska malých/velkých písmen podle hodnoty konfiguračního parametru sqlite.assoc_case.

Příklady

Příklad 2116. Procedural example

<?php
$dbhandle = sqlite_open('sqlitedb');
$query = sqlite_query($dbhandle, 'SELECT name, email FROM users LIMIT 25');
$result = sqlite_fetch_all($query, SQLITE_ASSOC);
foreach ($result as $entry) {
    echo 'Name: ' . $entry['name'] . '  E-mail: ' . $entry['email'];
}
?>

Příklad 2117. Object-oriented example

<?php
$dbhandle = new SQLiteDatabase('sqlitedb');

$query = $dbhandle->query('SELECT name, email FROM users LIMIT 25'); // buffered result set
$query = $dbhandle->unbufferedQuery('SELECT name, email FROM users LIMIT 25'); // unbuffered result set

$result = $query->fetchAll(SQLITE_ASSOC);
foreach ($result as $entry) {
    echo 'Name: ' . $entry['name'] . '  E-mail: ' . $entry['email'];
}
?>

Viz také

sqlite_fetch_array()

Předcházející | Nahoru | Další
sqlite_factory | Domů | sqlite_fetch_array


sqlite_fetch_array

Předcházející CLVI. SQLite Functions Další

sqlite_fetch_array,

(PHP 5, PECL sqlite:1.0-1.0.3)

sqlite_fetch_array, SQLiteResult->fetch, SQLiteUnbuffered->fetch — Fetches the next row from a result set as an array

Popis

array sqlite_fetch_array ( resource $result [, int $result_type [, bool $decode_binary]] )

Object oriented style (method):

class SQLiteResult {
array fetch ( [int $result_type [, bool $decode_binary]] )
} class SQLiteUnbuffered {
array fetch ( [int $result_type [, bool $decode_binary]] )
}

Fetches the next row from the given result handle. If there are no more rows, returns FALSE, otherwise returns an associative array representing the row data.

Seznam parametrů

result

The SQLite result resource. This parameter is not required when using the object-oriented method.

result_type

Nepovinný parametr result_type přijímá konstantu a určuje, jak bude indexováno vrácené pole. Konstanta SQLITE_ASSOC způsobí vracení pouze asociativních indexů (pojmenované prvky), kdežto SQLITE_NUM znamená vracení jen numerických indexů. Hodnota SQLITE_BOTH způsobí, že budou použity obě formy indexace. Výchozí hodnota pro tuto funkci je SQLITE_BOTH.

decode_binary

Když je parametr decode_binary nastaven na TRUE (výchozí hodnota), PHP bude dekódovat binární kódování; týká se to dat, která byla zakódována pomocí sqlite_escape_string(). Toto byste normálně měli ponechat ve výchozím nastavení, s výjimkou případu, kdy potřebujete zajistit interoperabilitu s databázemi, které byly vytvořeny pomocí jiných aplikací využívajících sqlite.

Návratové hodnoty

Returns an array of the next row from a result set; FALSE if the next position is beyond the final row.

Názvy sloupců zjištěné pomocí SQLITE_ASSOC a SQLITE_BOTH will be upraveny z hlediska malých/velkých písmen podle hodnoty konfiguračního parametru sqlite.assoc_case.

Příklady

Příklad 2118. Procedural example

<?php
$dbhandle = sqlite_open('sqlitedb');
$query = sqlite_query($dbhandle, 'SELECT name, email FROM users LIMIT 25');
while ($entry = sqlite_fetch_array($query, SQLITE_ASSOC)) {
    echo 'Name: ' . $entry['name'] . '  E-mail: ' . $entry['email'];
}
?>

Příklad 2119. Object-oriented example

<?php
$dbhandle = new SQLiteDatabase('sqlitedb');

$query = $dbhandle->query('SELECT name, email FROM users LIMIT 25'); // buffered result set
$query = $dbhandle->unbufferedQuery('SELECT name, email FROM users LIMIT 25'); // unbuffered result set

while ($entry = $query->fetch(SQLITE_ASSOC)) {
    echo 'Name: ' . $entry['name'] . '  E-mail: ' . $entry['email'];
}
?>

Viz také

sqlite_array_query()
sqlite_fetch_string()

Předcházející | Nahoru | Další
sqlite_fetch_all | Domů | sqlite_fetch_column_types


sqlite_fetch_column_types

Předcházející CLVI. SQLite Functions Další

sqlite_fetch_column_types,

(PHP 5)

sqlite_fetch_column_types, SQLiteDatabase->fetchColumnTypes — Return an array of column types from a particular table

Popis

array sqlite_fetch_column_types ( string $table_name, resource $dbhandle [, int $result_type] )

Object oriented style (method):

class SQLiteDatabase {
array fetchColumnTypes ( string $table_name [, int $result_type] )
}

sqlite_fetch_column_types() returns an array of column data types from the specified table_name table.

Seznam parametrů

table_name

The table name to query.

dbhandle

The SQLite Database resource; returned from sqlite_open() when used procedurally. This parameter is not required when using the object-oriented method.

result_type

The optional result_type parameter accepts a constant and determines how the returned array will be indexed. Using SQLITE_ASSOC will return only associative indices (named fields) while SQLITE_NUM will return only numerical indices (ordinal field numbers). SQLITE_BOTH will return both associative and numerical indices. SQLITE_ASSOC is the default for this function.

Návratové hodnoty

Returns an array of column data types; FALSE on error.

Názvy sloupců zjištěné pomocí SQLITE_ASSOC a SQLITE_BOTH will be upraveny z hlediska malých/velkých písmen podle hodnoty konfiguračního parametru sqlite.assoc_case.

ChangeLog (záznam změn)

Verze | Popis
5.1.0 | Added result_type

Příklady

Příklad 2120. Procedural example

<?php
$db = sqlite_open('mysqlitedb');
sqlite_query($db, 'CREATE TABLE foo (bar varchar(10), arf text)');
$cols = sqlite_fetch_column_types('foo', $db, SQLITE_ASSOC);

foreach ($cols as $column => $type) {
    echo "Column: $column  Type: $type";
}
?>

Příklad 2121. Object-oriented example

<?php
$db = new SQLiteDatabase('mysqlitedb');
$db->query('CREATE TABLE foo (bar varchar(10), arf text)');
$cols = $db->fetchColumnTypes('foo', SQLITE_ASSOC);

foreach ($cols as $column => $type) {
    echo "Column: $column  Type: $type";
}
?>

Výše uvedený příklad vypíše:

Column: bar  Type: VARCHAR
Column: arf  Type: TEXT

Předcházející | Nahoru | Další
sqlite_fetch_array | Domů | sqlite_fetch_object


sqlite_fetch_object

Předcházející CLVI. SQLite Functions Další

sqlite_fetch_object,

(PHP 5)

sqlite_fetch_object, SQLiteResult->fetchObject, SQLiteUnbuffered->fetchObject — Fetches the next row from a result set as an object

Popis

object sqlite_fetch_object ( resource $result [, string $class_name [, array $ctor_params [, bool $decode_binary]]] )

Object oriented style (method):

class SQLiteResult {
object fetchObject ( [string $class_name [, array $ctor_params [, bool $decode_binary]]] )
} class SQLiteUnbuffered {
object fetchObject ( [string $class_name [, array $ctor_params [, bool $decode_binary]]] )
}
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
sqlite_fetch_column_types | Domů | sqlite_fetch_single


sqlite_fetch_single

Předcházející CLVI. SQLite Functions Další

sqlite_fetch_single,

(PHP 5, PECL sqlite:1.0.1-1.0.3)

sqlite_fetch_single, SQLiteResult->fetchSingle, SQLiteUnbuffered->fetchSingle — Fetches the first column of a result set as a string

Popis

string sqlite_fetch_single ( resource $result [, bool $decode_binary] )

Object oriented style (method):

class SQLiteResult {
string fetchSingle ( [bool $decode_binary] )
} class SQLiteUnbuffered {
string fetchSingle ( [bool $decode_binary] )
}

sqlite_fetch_single() is identical to sqlite_fetch_array() except that it returns the value of the first column of the rowset.

This is the most optimal way to retrieve data when you are only interested in the values from a single column of data.

Seznam parametrů

result

The SQLite result resource. This parameter is not required when using the object-oriented method.

decode_binary

Když je parametr decode_binary nastaven na TRUE (výchozí hodnota), PHP bude dekódovat binární kódování; týká se to dat, která byla zakódována pomocí sqlite_escape_string(). Toto byste normálně měli ponechat ve výchozím nastavení, s výjimkou případu, kdy potřebujete zajistit interoperabilitu s databázemi, které byly vytvořeny pomocí jiných aplikací využívajících sqlite.

Příklady

Příklad 2122. A sqlite_fetch_single() example

<?php
if ($dbhandle = sqlite_open('mysqlitedb', 0666, $sqliteerror)) {

    $sql = "SELECT id FROM sometable WHERE id = 42";
    $res = sqlite_query($dbhandle, $sql);

    if (sqlite_num_rows($res) > 0) {
        echo sqlite_fetch_single($res); // 42
    }

    sqlite_close($dbhandle);
}
?>

Viz také

sqlite_fetch_array()

Předcházející | Nahoru | Další
sqlite_fetch_object | Domů | sqlite_fetch_string


sqlite_fetch_string

(PHP 5, PECL sqlite:1.0-1.0.3)

sqlite_fetch_string — Alias pro sqlite_fetch_single()

Popis

Tato funkce je aliasem: sqlite_fetch_single().

Předcházející | Nahoru | Další
sqlite_fetch_single | Domů | sqlite_field_name


sqlite_field_name

Předcházející CLVI. SQLite Functions Další

sqlite_field_name,

(PHP 5, PECL sqlite:1.0-1.0.3)

sqlite_field_name, SQLiteResult->fieldName, SQLiteUnbuffered->fieldName — Returns the name of a particular field

Popis

string sqlite_field_name ( resource $result, int $field_index )

Object oriented style (method):

class SQLiteResult {
string fieldName ( int $field_index )
} class SQLiteUnbuffered {
string fieldName ( int $field_index )
}

Given the ordinal column number, field_index, sqlite_field_name() returns the name of that field in the result set result.

Seznam parametrů

result

The SQLite result resource. This parameter is not required when using the object-oriented method.

field_index

The ordinal column number in the result set.

Návratové hodnoty

Returns the name of a field in an SQLite result set, given the ordinal column number; FALSE on error.

Názvy sloupců zjištěné pomocí SQLITE_ASSOC a SQLITE_BOTH will be upraveny z hlediska malých/velkých písmen podle hodnoty konfiguračního parametru sqlite.assoc_case.

Předcházející | Nahoru | Další
sqlite_fetch_string | Domů | sqlite_has_more


sqlite_has_more

(PHP 5, PECL sqlite:1.0-1.0.3)

sqlite_has_more — Finds whether or not more rows are available

Popis

bool sqlite_has_more ( resource $result )

Finds whether more rows are available from the given result set.

Seznam parametrů

result

The SQLite result resource.

Návratové hodnoty

Returns TRUE if there are more rows available from the result handle, or FALSE otherwise.

Viz také

sqlite_num_rows()
sqlite_changes()

Předcházející | Nahoru | Další
sqlite_field_name | Domů | sqlite_has_prev


sqlite_has_prev

Předcházející CLVI. SQLite Functions Další

sqlite_has_prev,

(PHP 5)

sqlite_has_prev, SQLiteResult->hasPrev — Returns whether or not a previous row is available

Popis

bool sqlite_has_prev ( resource $result )

Object oriented style (method):

class SQLiteResult {
bool hasPrev ( void )
}

Find whether there are more previous rows from the given result handle.

Seznam parametrů

result

The SQLite result resource. This parameter is not required when using the object-oriented method.

Poznámka: Tuto funkci nelze použít s nebufferovaným přístupem k výsledkům.

Návratové hodnoty

Returns TRUE if there are more previous rows available from the result handle, or FALSE otherwise.

Viz také

sqlite_prev()
sqlite_has_more()
sqlite_num_rows()

Předcházející | Nahoru | Další
sqlite_has_more | Domů | sqlite_key


sqlite_last_error

Předcházející CLVI. SQLite Functions Další

sqlite_last_error,

(PHP 5, PECL sqlite:1.0-1.0.3)

sqlite_last_error, SQLiteDatabase->lastError — Returns the error code of the last error for a database

Popis

int sqlite_last_error ( resource $dbhandle )

Object oriented style (method):

class SQLiteDatabase {
int lastError ( void )
}

Returns the error code from the last operation performed on dbhandle (the database handle), or 0 when no error occurred. A human readable description of the error code can be retrieved using sqlite_error_string().

Seznam parametrů

dbhandle

The SQLite Database resource; returned from sqlite_open() when used procedurally. This parameter is not required when using the object-oriented method.

Viz také

sqlite_error_string()

Předcházející | Nahoru | Další
sqlite_key | Domů | sqlite_last_insert_rowid


sqlite_last_insert_rowid

Předcházející CLVI. SQLite Functions Další

sqlite_last_insert_rowid,

(PHP 5, PECL sqlite:1.0-1.0.3)

sqlite_last_insert_rowid, SQLiteDatabase->lastInsertRowid — Returns the rowid of the most recently inserted row

Popis

int sqlite_last_insert_rowid ( resource $dbhandle )

Object oriented style (method):

class SQLiteDatabase {
int lastInsertRowid ( void )
}

Returns the rowid of the row that was most recently inserted into the database dbhandle, if it was created as an auto-increment field.

Tip

You can create auto-increment fields in SQLite by declaring them as INTEGER PRIMARY KEY in your table schema.

Seznam parametrů

dbhandle

The SQLite Database resource; returned from sqlite_open() when used procedurally. This parameter is not required when using the object-oriented method.

Předcházející | Nahoru | Další
sqlite_last_error | Domů | sqlite_libencoding


sqlite_libencoding

(PHP 5, PECL sqlite:1.0-1.0.3)

sqlite_libencoding — Returns the encoding of the linked SQLite library

Popis

string sqlite_libencoding ( void )

The SQLite library may be compiled in either ISO-8859-1 or UTF-8 compatible modes. This function allows you to determine which encoding scheme is used by your version of the library.

Varování

The default PHP distribution builds libsqlite in ISO-8859-1 encoding mode. However, this is a misnomer; rather than handling ISO-8859-1, it operates according to your current locale settings for string comparisons and sort ordering. So, rather than ISO-8859-1, you should think of it as being '8-bit' instead.

When compiled with UTF-8 support, sqlite handles encoding and decoding of UTF-8 multi-byte character sequences, but does not yet do a complete job when working with the data (no normalization is performed for example), and some comparison operations may still not be carried out correctly.

Varování

It is not recommended that you use PHP in a web-server configuration with a version of the SQLite library compiled with UTF-8 support, since libsqlite will abort the process if it detects a problem with the UTF-8 encoding.

Viz také

sqlite_lib_version()

Předcházející | Nahoru | Další
sqlite_last_insert_rowid | Domů | sqlite_libversion


sqlite_libversion

(PHP 5, PECL sqlite:1.0-1.0.3)

sqlite_libversion — Returns the version of the linked SQLite library

Popis

string sqlite_libversion ( void )

Returns the version of the linked SQLite library.

Viz také

sqlite_libencoding()

Předcházející | Nahoru | Další
sqlite_libencoding | Domů | sqlite_next


sqlite_next

Předcházející CLVI. SQLite Functions Další

sqlite_next,

(PHP 5, PECL sqlite:1.0-1.0.3)

sqlite_next, SQLiteResult->next, SQLiteUnbuffered->next — Seek to the next row number

Popis

bool sqlite_next ( resource $result )

Object oriented style (method):

class SQLiteResult {
bool next ( void )
} class SQLiteUnbuffered {
bool next ( void )
}

sqlite_next() advances the result handle result to the next row.

Seznam parametrů

result

The SQLite result resource. This parameter is not required when using the object-oriented method.

Návratové hodnoty

Returns TRUE on success, or FALSE if there are no more rows.

Viz také

sqlite_seek()
sqlite_current()
sqlite_rewind()

Předcházející | Nahoru | Další
sqlite_libversion | Domů | sqlite_num_fields


sqlite_num_fields

Předcházející CLVI. SQLite Functions Další

sqlite_num_fields,

(PHP 5, PECL sqlite:1.0-1.0.3)

sqlite_num_fields, SQLiteResult->numFields, SQLiteUnbuffered->numFields — Returns the number of fields in a result set

Popis

int sqlite_num_fields ( resource $result )

Object oriented style (method):

class SQLiteResult {
int numFields ( void )
} class SQLiteUnbuffered {
int numFields ( void )
}

Returns the number of fields in the result set.

Seznam parametrů

result

The SQLite result resource. This parameter is not required when using the object-oriented method.

Viz také

sqlite_changes()
sqlite_num_rows()

Předcházející | Nahoru | Další
sqlite_next | Domů | sqlite_num_rows


sqlite_num_rows

Předcházející CLVI. SQLite Functions Další

sqlite_num_rows,

(PHP 5, PECL sqlite:1.0-1.0.3)

sqlite_num_rows, SQLiteResult->numRows — Returns the number of rows in a buffered result set

Popis

int sqlite_num_rows ( resource $result )

Object oriented style (method):

class SQLiteResult {
int numRows ( void )
}

Returns the number of rows in the buffered result set.

Seznam parametrů

result

The SQLite result resource. This parameter is not required when using the object-oriented method.

Poznámka: Tuto funkci nelze použít s nebufferovaným přístupem k výsledkům.

Příklady

Příklad 2123. Procedural example

<?php
$db = sqlite_open('mysqlitedb');
$result = sqlite_query($db, "SELECT * FROM mytable WHERE name='John Doe'");
$rows = sqlite_num_rows($result);

echo "Number of rows: $rows";
?>

Příklad 2124. Object-oriented example

<?php
$db = new SQLiteDatabase('mysqlitedb');
$result = $db->query("SELECT * FROM mytable WHERE name='John Doe'");
$rows = $result->numRows();

echo "Number of rows: $rows";
?>

Viz také

sqlite_changes()
sqlite_query()
sqlite_num_fields()

Předcházející | Nahoru | Další
sqlite_num_fields | Domů | sqlite_open


sqlite_open

(PHP 5, PECL sqlite:1.0-1.0.3)

sqlite_open — Opens a SQLite database and create the database if it does not exist

Popis

resource sqlite_open ( string $filename [, int $mode [, string &$error_message]] )

Object oriented style (constructor):

class SQLiteDatabase {
__construct ( string $filename [, int $mode [, string &$error_message]] )
}

Opens a SQLite database or creates the database if it does not exist.

Seznam parametrů

filename

The filename of the SQLite database. If the file does not exist, SQLite will attempt to create it. PHP must have write permissions to the file if data is inserted, the database schema is modified or to create the database if it does not exist.

mode

The mode of the file. Intended to be used to open the database in read-only mode. Presently, this parameter is ignored by the sqlite library. The default value for mode is the octal value 0666 and this is the recommended value.

error_message

Passed by reference and is set to hold a descriptive error message explaining why the database could not be opened if there was an error.

Návratové hodnoty

Returns a resource (database handle) on success, FALSE on error.

Příklady

Příklad 2125. sqlite_open() example

<?php
if ($db = sqlite_open('mysqlitedb', 0666, $sqliteerror)) {
    sqlite_query($db, 'CREATE TABLE foo (bar varchar(10))');
    sqlite_query($db, "INSERT INTO foo VALUES ('fnord')");
    $result = sqlite_query($db, 'select bar from foo');
    var_dump(sqlite_fetch_array($result));
} else {
    die($sqliteerror);
}
?>

Poznámky

Tip

On Unix platforms, SQLite is sensitive to scripts that use the fork() system call. If you do have such a script, it is recommended that you close the handle prior to forking and then re-open it in the child and/or parent. For more information on this issue, see » The C language interface to the SQLite library in the section entitled Multi-Threading And SQLite.

Tip

It is not recommended to work with SQLite databases mounted on NFS partitions. Since NFS is notoriously bad when it comes to locking you may find that you cannot even open the database at all, and if it succeeds, the locking behaviour may be undefined.

Poznámka: Starting with SQLite library version 2.8.2, you can specify :memory: as the filename to create a database that lives only in the memory of the computer. This is useful mostly for temporary processing, as the in-memory database will be destroyed when the process ends. It can also be useful when coupled with the ATTACH DATABASE SQL statement to load other databases and move and query data between them.

Poznámka: SQLite is bezpečný režim and open_basedir aware.

Viz také

sqlite_popen()
sqlite_close()
sqlite_factory()

Předcházející | Nahoru | Další
sqlite_num_rows | Domů | sqlite_popen


sqlite_popen

(PHP 5, PECL sqlite:1.0-1.0.3)

sqlite_popen — Opens a persistent handle to an SQLite database and create the database if it does not exist

Popis

resource sqlite_popen ( string $filename [, int $mode [, string &$error_message]] )

This function behaves identically to sqlite_open() except that is uses the persistent resource mechanism of PHP. For information about the meaning of the parameters, read the sqlite_open() manual page.

sqlite_popen() will first check to see if a persistent handle has already been opened for the given filename. If it finds one, it returns that handle to your script, otherwise it opens a fresh handle to the database.

The benefit of this approach is that you don't incur the performance cost of re-reading the database and index schema on each page hit served by persistent web server SAPI's (any SAPI except for regular CGI or CLI).

Poznámka: If you use persistent handles and have the database updated by a background process (perhaps via a crontab), and that process re-creates the database by overwriting it (either by unlinking and rebuilding, or moving the updated version to replace the current version), you may experience undefined behaviour when a persistent handle on the old version of the database is recycled.

To avoid this situation, have your background processes open the same database file and perform their updates in a transaction.

Seznam parametrů

filename

The filename of the SQLite database. If the file does not exist, SQLite will attempt to create it. PHP must have write permissions to the file if data is inserted, the database schema is modified or to create the database if it does not exist.

mode

The mode of the file. Intended to be used to open the database in read-only mode. Presently, this parameter is ignored by the sqlite library. The default value for mode is the octal value 0666 and this is the recommended value.

error_message

Passed by reference and is set to hold a descriptive error message explaining why the database could not be opened if there was an error.

Návratové hodnoty

Returns a resource (database handle) on success, FALSE on error.

Viz také

sqlite_open()
sqlite_close()
sqlite_factory()

Předcházející | Nahoru | Další
sqlite_open | Domů | sqlite_prev


sqlite_prev

Předcházející CLVI. SQLite Functions Další

sqlite_prev,

(PHP 5)

sqlite_prev, SQLiteResult->prev — Seek to the previous row number of a result set

Popis

bool sqlite_prev ( resource $result )

Object oriented style (method):

class SQLiteResult {
bool prev ( void )
}

sqlite_prev() seeks back the result handle to the previous row.

Seznam parametrů

result

The SQLite result resource. This parameter is not required when using the object-oriented method.

Poznámka: Tuto funkci nelze použít s nebufferovaným přístupem k výsledkům.

Návratové hodnoty

Returns TRUE on success, or FALSE if there are no more previous rows.

Viz také

sqlite_has_prev()
sqlite_rewind()
sqlite_next()

Předcházející | Nahoru | Další
sqlite_popen | Domů | sqlite_query


sqlite_query

Předcházející CLVI. SQLite Functions Další

sqlite_query,

(PHP 5, PECL sqlite:1.0-1.0.3)

sqlite_query, SQLiteDatabase->query — Executes a query against a given database and returns a result handle

Popis

resource sqlite_query ( resource $dbhandle, string $query [, int $result_type [, string &$error_msg]] )
resource sqlite_query ( string $query, resource $dbhandle [, int $result_type [, string &$error_msg]] )

Object oriented style (method):

class SQLiteDatabase {
SQLiteResult query ( string $query [, int $result_type [, string &$error_msg]] )
}

Executes an SQL statement given by the query against a given database handle.

Seznam parametrů

dbhandle

The SQLite Database resource; returned from sqlite_open() when used procedurally. This parameter is not required when using the object-oriented method.

query

The query to be executed.

result_type

Nepovinný parametr result_type přijímá konstantu a určuje, jak bude indexováno vrácené pole. Konstanta SQLITE_ASSOC způsobí vracení pouze asociativních indexů (pojmenované prvky), kdežto SQLITE_NUM znamená vracení jen numerických indexů. Hodnota SQLITE_BOTH způsobí, že budou použity obě formy indexace. Výchozí hodnota pro tuto funkci je SQLITE_BOTH.

error_msg

The specified variable will be filled if an error occurs. This is specially important because SQL syntax errors can't be fetched using the sqlite_last_error() function.

Poznámka: Pro kompatibilitu s jinými databázovými rozšířeními (např. MySQL) jsou podporovány dvě alternativní syntaxe. Preferována je první z nich, kde parametr dbhandle je prvním parametrem funkce.

Návratové hodnoty

This function will return a result handle or FALSE on failure. For queries that return rows, the result handle can then be used with functions such as sqlite_fetch_array() and sqlite_seek().

Regardless of the query type, this function will return FALSE if the query failed.

sqlite_query() returns a buffered, seekable result handle. This is useful for reasonably small queries where you need to be able to randomly access the rows. Buffered result handles will allocate memory to hold the entire result and will not return until it has been fetched. If you only need sequential access to the data, it is recommended that you use the much higher performance sqlite_unbuffered_query() instead.

ChangeLog (záznam změn)

Verze | Popis
5.1.0 | Added the error_msg parameter

Poznámky

Varování

SQLite will execute multiple queries separated by semicolons, so you can use it to execute a batch of SQL that you have loaded from a file or have embedded in a script. However, this works only when the result of the function is not used - if it is used, only the first SQL statement would be executed. Function sqlite_exec() will always execute multiple SQL statements.

When executing multiple queries, the return value of this function will be FALSE if there was an error, but undefined otherwise (it might be TRUE for success or it might return a result handle).

Viz také

sqlite_unbuffered_query()
sqlite_array_query()

Předcházející | Nahoru | Další
sqlite_prev | Domů | sqlite_rewind


sqlite_rewind

Předcházející CLVI. SQLite Functions Další

sqlite_rewind,

(PHP 5, PECL sqlite:1.0-1.0.3)

sqlite_rewind, SQLiteResult->rewind — Seek to the first row number

Popis

bool sqlite_rewind ( resource $result )

Object oriented style (method):

class SQLiteResult {
bool rewind ( void )
}

sqlite_rewind() seeks back to the first row in the given result set.

Seznam parametrů

result

The SQLite result resource. This parameter is not required when using the object-oriented method.

Poznámka: Tuto funkci nelze použít s nebufferovaným přístupem k výsledkům.

Návratové hodnoty

Returns FALSE if there are no rows in the result set, TRUE otherwise.

Viz také

sqlite_next()
sqlite_current()
sqlite_seek()

Předcházející | Nahoru | Další
sqlite_query | Domů | sqlite_seek


sqlite_seek

Předcházející CLVI. SQLite Functions Další

sqlite_seek,

(PHP 5, PECL sqlite:1.0-1.0.3)

sqlite_seek, SQLiteResult->seek — Seek to a particular row number of a buffered result set

Popis

bool sqlite_seek ( resource $result, int $rownum )

Object oriented style (method):

class SQLiteResult {
bool seek ( int $rownum )
}

sqlite_seek() seeks to the row given by the parameter rownum.

Seznam parametrů

result

The SQLite result resource. This parameter is not required when using the object-oriented method.

Poznámka: Tuto funkci nelze použít s nebufferovaným přístupem k výsledkům.

rownum

The ordinal row number to seek to. The row number is zero-based (0 is the first row).

Poznámka: Tuto funkci nelze použít s nebufferovaným přístupem k výsledkům.

Návratové hodnoty

Returns FALSE if the row does not exist, TRUE otherwise.

Viz také

sqlite_next()
sqlite_current()
sqlite_rewind()

Předcházející | Nahoru | Další
sqlite_rewind | Domů | sqlite_single_query


sqlite_single_query

Předcházející CLVI. SQLite Functions Další

sqlite_single_query,

(PHP 5, PECL sqlite:1.0.1-1.0.3)

sqlite_single_query, SQLiteDatabase->singleQuery — Executes a query and returns either an array for one single column or the value of the first row

Popis

array sqlite_single_query ( resource $db, string $query [, bool $first_row_only [, bool $decode_binary]] )

Object oriented style (method):

class SQLiteDatabase {
array singleQuery ( string $query [, bool $first_row_only [, bool $decode_binary]] )
}
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
sqlite_seek | Domů | sqlite_udf_decode_binary


sqlite_udf_decode_binary

(PHP 5, PECL sqlite:1.0-1.0.3)

sqlite_udf_decode_binary — Decode binary data passed as parameters to an UDF

Popis

string sqlite_udf_decode_binary ( string $data )

sqlite_udf_decode_binary() decodes the binary encoding that was applied to the parameter by either sqlite_udf_encode_binary() or sqlite_escape_string().

You must call this function on parameters passed to your UDF if you need them to handle binary data, as the binary encoding employed by PHP will obscure the content and of the parameter in its natural, non-coded form.

PHP does not perform this encode/decode operation automatically as it would severely impact performance if it did.

Příklady

Příklad 2126. binary-safe max_length aggregation function example

<?php
$data = array(
   'one',
   'two',
   'three',
   'four',
   'five',
   'six',
   'seven',
   'eight',
   'nine',
   'ten',
   );
$db = sqlite_open(':memory:');
sqlite_query($db, "CREATE TABLE strings(a)");
foreach ($data as $str) {
    $str = sqlite_escape_string($str);
    sqlite_query($db, "INSERT INTO strings VALUES ('$str')");
}

function max_len_step(&$context, $string)
{
    $string = sqlite_udf_decode_binary($string);
    if (strlen($string) > $context) {
        $context = strlen($string);
    }
}

function max_len_finalize(&$context)
{
    return $context;
}

sqlite_create_aggregate($db, 'max_len', 'max_len_step', 'max_len_finalize');

var_dump(sqlite_array_query($db, 'SELECT max_len(a) from strings'));

?>

Viz také

sqlite_udf_encode_binary()
sqlite_create_function()
sqlite_create_aggregate()

Předcházející | Nahoru | Další
sqlite_single_query | Domů | sqlite_udf_encode_binary


sqlite_udf_encode_binary

(PHP 5, PECL sqlite:1.0-1.0.3)

sqlite_udf_encode_binary — Encode binary data before returning it from an UDF

Popis

string sqlite_udf_encode_binary ( string $data )

sqlite_udf_encode_binary() applies a binary encoding to the data so that it can be safely returned from queries (since the underlying libsqlite API is not binary safe).

If there is a chance that your data might be binary unsafe (e.g.: it contains a NUL byte in the middle rather than at the end, or if it has and 0x01 byte as the first character) then you must call this function to encode the return value from your UDF.

PHP does not perform this encode/decode operation automatically as it would severely impact performance if it did.

Poznámka: Do not use sqlite_escape_string() to quote strings returned from UDF's as it will lead to double-quoting of the data. Use sqlite_udf_encode_binary() instead!

Viz také

sqlite_udf_decode_binary()
sqlite_escape_string()
sqlite_create_function()
sqlite_create_aggregate()

Předcházející | Nahoru | Další
sqlite_udf_decode_binary | Domů | sqlite_unbuffered_query


sqlite_unbuffered_query

Předcházející CLVI. SQLite Functions Další

sqlite_unbuffered_query,

(PHP 5, PECL sqlite:1.0-1.0.3)

sqlite_unbuffered_query, SQLiteDatabase->unbufferedQuery — Execute a query that does not prefetch and buffer all data

Popis

resource sqlite_unbuffered_query ( resource $dbhandle, string $query [, int $result_type [, string &$error_msg]] )
resource sqlite_unbuffered_query ( string $query, resource $dbhandle [, int $result_type [, string &$error_msg]] )

Object oriented style (method):

class SQLiteDatabase {
SQLiteUnbuffered unbufferedQuery ( string $query [, int $result_type [, string &$error_msg]] )
}

sqlite_unbuffered_query() is identical to sqlite_query() except that the result that is returned is a sequential forward-only result set that can only be used to read each row, one after the other.

This function is ideal for generating things such as HTML tables where you only need to process one row at a time and don't need to randomly access the row data.

Poznámka:
    Functions such as sqlite_seek(),
    sqlite_rewind(), sqlite_next(),
    sqlite_current(), and
    sqlite_num_rows() do not work on result handles
    returned from sqlite_unbuffered_query().

Seznam parametrů

dbhandle

The SQLite Database resource; returned from sqlite_open() when used procedurally. This parameter is not required when using the object-oriented method.

query

The query to be executed.

result_type

Nepovinný parametr result_type přijímá konstantu a určuje, jak bude indexováno vrácené pole. Konstanta SQLITE_ASSOC způsobí vracení pouze asociativních indexů (pojmenované prvky), kdežto SQLITE_NUM znamená vracení jen numerických indexů. Hodnota SQLITE_BOTH způsobí, že budou použity obě formy indexace. Výchozí hodnota pro tuto funkci je SQLITE_BOTH.

error_msg

The specified variable will be filled if an error occurs. This is specially important because SQL syntax errors can't be fetched using the sqlite_last_error() function.

Poznámka: Pro kompatibilitu s jinými databázovými rozšířeními (např. MySQL) jsou podporovány dvě alternativní syntaxe. Preferována je první z nich, kde parametr dbhandle je prvním parametrem funkce.

Návratové hodnoty

Returns a result handle or FALSE on failure.

sqlite_unbuffered_query() returns a sequential forward-only result set that can only be used to read each row, one after the other.

ChangeLog (záznam změn)

Verze | Popis
5.1.0 | Added the error_msg parameter

Viz také

sqlite_query()

Předcházející | Nahoru | Další
sqlite_udf_encode_binary | Domů | sqlite_valid


Shockwave Flash Functions

Předcházející VI. Reference funkcí Další

CLXIII. Shockwave Flash Functions

Úvod

PHP offers the ability to create Shockwave Flash files via Paul Haeberli's libswf module.

Poznámka: SWF support was added in PHP 4 RC2.

The libswf does not have support for Windows. The development of that library has been stopped, and the source is not available to port it to another systems.

For up to date SWF support take a look at the MING functions.

Poznámka: Toto rozšíření bylo přesunuto do repozitáře PECL a již nebude součástí balíku PHP.5.0.0.

Požadavky

You need the libswf library to compile PHP with support for this extension. You can download libswf at » ftp://ftp.sgi.com/sgi/graphics/grafica/flash/.

Instalace

Once you have libswf all you need to do is to configure --with-swf[=DIR] where DIR is a location containing the directories include and lib. The include directory has to contain the swf.h file and the lib directory has to contain the libswf.a file. If you unpack the libswf distribution the two files will be in one directory. Consequently you will have to copy the files to the proper location manually.

Konfigurace běhu

Toto rozšíření nemá definováno žádné konfigurační direktivy.

Typy prostředků

Toto rozšíření nemá definován žádný typ prostředku (resource).

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

MOD_COLOR (integer)
MOD_MATRIX (integer)
TYPE_PUSHBUTTON (integer)
TYPE_MENUBUTTON (integer)
BSHitTest (float)
BSDown (float)
BSOver (float)
BSUp (float)
OverDowntoIdle (integer)
IdletoOverDown (integer)
OutDowntoIdle (integer)
OutDowntoOverDown (integer)
OverDowntoOutDown (integer)
OverUptoOverDown (integer)
OverUptoIdle (integer)
IdletoOverUp (integer)
ButtonEnter (integer)
ButtonExit (integer)
MenuEnter (integer)
MenuExit (integer)

Příklady

Once you've successfully installed PHP with Shockwave Flash support you can then go about creating Shockwave files from PHP. You would be surprised at what you can do, take the following code:

Příklad 2265. SWF example

<?php
swf_openfile("test.swf", 256, 256, 30, 1, 1, 1);
swf_ortho2(-100, 100, -100, 100);
swf_defineline(1, -70, 0, 70, 0, .2);
swf_definerect(4, 60, -10, 70, 0, 0);
swf_definerect(5, -60, 0, -70, 10, 0);
swf_addcolor(0, 0, 0, 0);

swf_definefont(10, "Mod");
swf_fontsize(5);
swf_fontslant(10);
swf_definetext(11, "This be Flash wit PHP!", 1);

swf_pushmatrix();
swf_translate(-50, 80, 0);
swf_placeobject(11, 60);
swf_popmatrix();

for ($i = 0; $i < 30; $i++) {
    $p = $i/(30-1);
    swf_pushmatrix();
    swf_scale(1-($p*.9), 1, 1);
    swf_rotate(60*$p, 'z');
    swf_translate(20+20*$p, $p/1.5, 0);
    swf_rotate(270*$p,  'z');
    swf_addcolor($p, 0, $p/1.2, -$p);
    swf_placeobject(1, 50);
    swf_placeobject(4, 50);
    swf_placeobject(5, 50);
    swf_popmatrix();
    swf_showframe();
}

for ($i = 0; $i < 30; $i++) {
    swf_removeobject(50);
    if (($i%4) == 0) {
        swf_showframe();
    }
}

swf_startdoaction();
swf_actionstop();
swf_enddoaction();

swf_closefile();
?>

Obsah

swf_actiongeturl — Get a URL from a Shockwave Flash movie
swf_actiongotoframe — Play a frame and then stop
swf_actiongotolabel — Display a frame with the specified label
swf_actionnextframe — Go forward one frame
swf_actionplay — Start playing the flash movie from the current frame
swf_actionprevframe — Go backwards one frame
swf_actionsettarget — Set the context for actions
swf_actionstop — Stop playing the flash movie at the current frame
swf_actiontogglequality — Toggle between low and high quality
swf_actionwaitforframe — Skip actions if a frame has not been loaded
swf_addbuttonrecord — Controls location, appearance and active area of the current button
swf_addcolor — Set the global add color to the rgba value specified
swf_closefile — Close the current Shockwave Flash file
swf_definebitmap — Define a bitmap
swf_definefont — Defines a font
swf_defineline — Define a line
swf_definepoly — Define a polygon
swf_definerect — Define a rectangle
swf_definetext — Define a text string
swf_endbutton — End the definition of the current button
swf_enddoaction — End the current action
swf_endshape — Completes the definition of the current shape
swf_endsymbol — End the definition of a symbol
swf_fontsize — Change the font size
swf_fontslant — Set the font slant
swf_fonttracking — Set the current font tracking
swf_getbitmapinfo — Get information about a bitmap
swf_getfontinfo — Gets font information
swf_getframe — Get the frame number of the current frame
swf_labelframe — Label the current frame
swf_lookat — Define a viewing transformation
swf_modifyobject — Modify an object
swf_mulcolor — Sets the global multiply color to the rgba value specified
swf_nextid — Returns the next free object id
swf_oncondition — Describe a transition used to trigger an action list
swf_openfile — Open a new Shockwave Flash file
swf_ortho2 — Defines 2D orthographic mapping of user coordinates onto the current viewport
swf_ortho — Defines an orthographic mapping of user coordinates onto the current viewport
swf_perspective — Define a perspective projection transformation
swf_placeobject — Place an object onto the screen
swf_polarview — Define the viewer's position with polar coordinates
swf_popmatrix — Restore a previous transformation matrix
swf_posround — Enables or Disables the rounding of the translation when objects are placed or moved
swf_pushmatrix — Push the current transformation matrix back unto the stack
swf_removeobject — Remove an object
swf_rotate — Rotate the current transformation
swf_scale — Scale the current transformation
swf_setfont — Change the current font
swf_setframe — Switch to a specified frame
swf_shapearc — Draw a circular arc
swf_shapecurveto3 — Draw a cubic bezier curve
swf_shapecurveto — Draw a quadratic bezier curve between two points
swf_shapefillbitmapclip — Set current fill mode to clipped bitmap
swf_shapefillbitmaptile — Set current fill mode to tiled bitmap
swf_shapefilloff — Turns off filling
swf_shapefillsolid — Set the current fill style to the specified color
swf_shapelinesolid — Set the current line style
swf_shapelineto — Draw a line
swf_shapemoveto — Move the current position
swf_showframe — Display the current frame
swf_startbutton — Start the definition of a button
swf_startdoaction — Start a description of an action list for the current frame
swf_startshape — Start a complex shape
swf_startsymbol — Define a symbol
swf_textwidth — Get the width of a string
swf_translate — Translate the current transformations
swf_viewport — Select an area for future drawing
Předcházející | Nahoru | Další
svn_update | Domů | swf_actiongeturl


swf_actiongeturl

(PHP 4)

swf_actiongeturl — Get a URL from a Shockwave Flash movie

Popis

void swf_actiongeturl ( string $url, string $target )

Gets the URL specified by the parameter url with the given target.

Seznam parametrů

url

The URL, as a string.

target

The target, as a string.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
CLXIII. Shockwave Flash Functions | Domů | swf_actiongotoframe


swf_actiongotoframe

(PHP 4)

swf_actiongotoframe — Play a frame and then stop

Popis

void swf_actiongotoframe ( int $framenumber )

The swf_actiongotoframe() function will go to the frame specified by framenumber, play it, and then stop.

Seznam parametrů

framenumber

The frame number.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
swf_actiongeturl | Domů | swf_actiongotolabel


swf_actiongotolabel

(PHP 4)

swf_actiongotolabel — Display a frame with the specified label

Popis

void swf_actiongotolabel ( string $label )

The swf_actiongotolabel() function displays the frame with the label given by the label parameter and then stops.

Seznam parametrů

label

The frame label.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
swf_actiongotoframe | Domů | swf_actionnextframe


swf_actionnextframe

(PHP 4)

swf_actionnextframe — Go forward one frame

Popis

void swf_actionnextframe ( void )

Go forward one frame.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
swf_actiongotolabel | Domů | swf_actionplay


swf_actionplay

(PHP 4)

swf_actionplay — Start playing the flash movie from the current frame

Popis

void swf_actionplay ( void )

Start playing the flash movie from the current frame.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
swf_actionnextframe | Domů | swf_actionprevframe


swf_actionprevframe

(PHP 4)

swf_actionprevframe — Go backwards one frame

Popis

void swf_actionprevframe ( void )

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
swf_actionplay | Domů | swf_actionsettarget


swf_actionsettarget

(PHP 4)

swf_actionsettarget — Set the context for actions

Popis

void swf_actionsettarget ( string $target )

Sets the context for all actions. You can use this to control other flash movies that are currently playing.

Seznam parametrů

target

The target, as a string.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
swf_actionprevframe | Domů | swf_actionstop


swf_actionstop

(PHP 4)

swf_actionstop — Stop playing the flash movie at the current frame

Popis

void swf_actionstop ( void )

Stop playing the flash movie at the current frame.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
swf_actionsettarget | Domů | swf_actiontogglequality


swf_actiontogglequality

(PHP 4)

swf_actiontogglequality — Toggle between low and high quality

Popis

void swf_actiontogglequality ( void )

Toggle the flash movie between high and low quality.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
swf_actionstop | Domů | swf_actionwaitforframe


swf_actionwaitforframe

(PHP 4)

swf_actionwaitforframe — Skip actions if a frame has not been loaded

Popis

void swf_actionwaitforframe ( int $framenumber, int $skipcount )

The swf_actionwaitforframe() function will check to see if the frame, specified by the framenumber parameter has been loaded, if not it will skip the number of actions specified by the skipcount parameter. This can be useful for "Loading..." type animations.

Seznam parametrů

framenumber

The frame number.

skipcount

The number of actions to skip.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
swf_actiontogglequality | Domů | swf_addbuttonrecord


swf_addbuttonrecord

(PHP 4)

swf_addbuttonrecord — Controls location, appearance and active area of the current button

Popis

void swf_addbuttonrecord ( int $states, int $shapeid, int $depth )

Allow you to define the specifics of using a button.

Seznam parametrů

states

Defines what states the button can have, these can be any or all of the following constants: BSHitTest, BSDown, BSOver or BSUp.

shapeid

The second parameter, the shapeid is the look of the button, this is usually the object id of the shape of the button.

depth

This parameter is the placement of the button in the current frame.

Návratové hodnoty

Nevrací se žádná hodnota.

Příklady

Příklad 2266. swf_addbuttonrecord() example

<?php
swf_startButton($objid, TYPE_MENUBUTTON);
swf_addButtonRecord(BSDown|BSOver, $buttonImageId, 340);
swf_onCondition(MenuEnter);
swf_actionGetUrl("http://www.example.com", "_level1");
swf_onCondition(MenuExit);
swf_actionGetUrl("", "_level1");
swf_endButton();
?>

Předcházející | Nahoru | Další
swf_actionwaitforframe | Domů | swf_addcolor


swf_addcolor

(PHP 4)

swf_addcolor — Set the global add color to the rgba value specified

Popis

void swf_addcolor ( float $r, float $g, float $b, float $a )

Sets the global add color to the specified color. This color is then
implicitly used by the swf_placeobject(),
swf_modifyobject() and
swf_addbuttonrecord() functions.

The color of the object will be add by the given values when the object is written to the screen.

Seznam parametrů

r

Red value

g

Green value

b

Blue value

a

Alpha value

These parameters can be either positive or negative.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
swf_addbuttonrecord | Domů | swf_closefile


swf_closefile

(PHP 4)

swf_closefile — Close the current Shockwave Flash file

Popis

void swf_closefile ( [int $return_file] )

Close a file that was opened by the swf_openfile() function.

Seznam parametrů

return_file

If set then the contents of the SWF file are returned from the function.

Příklady

Příklad 2267. Creating a simple flash file based on user input and outputting it and saving it in a database

<?php

// The $text variable is submitted by the
// user

// Global variables for database
// access (used in the swf_savedata() function)
$DBHOST = "localhost";
$DBUSER = "sterling";
$DBPASS = "secret";

swf_openfile("php://stdout", 256, 256, 30, 1, 1, 1);

    swf_definefont(10, "Ligon-Bold");
        swf_fontsize(12);
        swf_fontslant(10);

    swf_definetext(11, $text, 1);

    swf_pushmatrix();
        swf_translate(-50, 80, 0);
        swf_placeobject(11, 60);
    swf_popmatrix();

    swf_showframe();

    swf_startdoaction();
        swf_actionstop();
    swf_enddoaction();

$data = swf_closefile(1);

$data ?
  swf_savedata($data) :
  die("Error could not save SWF file");

// void swf_savedata(string data)
// Save the generated file a database
// for later retrieval
function swf_savedata($data)
{
    global $DBHOST,
           $DBUSER,
           $DBPASS;

    $dbh = @mysql_connect($DBHOST, $DBUSER, $DBPASS);

    if (!$dbh) {
        die (sprintf("Error [%d]: %s",
                      mysql_errno(), mysql_error()));
    }

    $stmt = "INSERT INTO swf_files (file) VALUES ('$data')";

    $sth = @mysql_query($stmt, $dbh);

    if (!$sth) {
        die (sprintf("Error [%d]: %s",
                      mysql_errno(), mysql_error()));
    }

    @mysql_free_result($sth);
    @mysql_close($dbh);
}
?>

Předcházející | Nahoru | Další
swf_addcolor | Domů | swf_definebitmap


swf_definebitmap

(PHP 4)

swf_definebitmap — Define a bitmap

Popis

void swf_definebitmap ( int $objid, string $image_name )

The swf_definebitmap() function defines a bitmap given an image.

Seznam parametrů

objid

An SWF object id.

image_name

A GIF, JPEG, RGB or FI image. The image will be converted into a Flash JPEG or Flash color map format.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
swf_closefile | Domů | swf_definefont


swf_definefont

(PHP 4)

swf_definefont — Defines a font

Popis

void swf_definefont ( int $fontid, string $fontname )

The swf_definefont() function defines a font parameter and gives it the specified id. It then sets the font given by fontname to the current font.

Seznam parametrů

fontid

The id to be given to the font.

fontname

The font so be set as current font.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
swf_definebitmap | Domů | swf_defineline


swf_defineline

(PHP 4)

swf_defineline — Define a line

Popis

void swf_defineline ( int $objid, float $x1, float $y1, float $x2, float $y2, float $width )

Defines a line.

Seznam parametrů

objid

The object id.

x1

x-coordinate of start point.

y1

y-coordinate of start point.

x2

x-coordinate of end point.

y2

y-coordinate of end point.

width

The line width.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
swf_definefont | Domů | swf_definepoly


swf_definepoly

(PHP 4)

swf_definepoly — Define a polygon

Popis

void swf_definepoly ( int $objid, array $coords, int $npoints, float $width )

Defines a polygon given an array of x, y coordinates.

Seznam parametrů

objid

The object id.

coords

An array of x, y coordinates.

npoints

The number of overall points that are contained in the array given by coords

width

The width of the polygon's border, if set to 0.0 the polygon is filled.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
swf_defineline | Domů | swf_definerect


swf_definerect

(PHP 4)

swf_definerect — Define a rectangle

Popis

void swf_definerect ( int $objid, float $x1, float $y1, float $x2, float $y2, float $width )

Defines a rectangle with an upper left hand coordinate and a lower right hand coordinate.

Seznam parametrů

objid

The object id.

x1

x-coordinate of upper left point.

y1

y-coordinate of upper left point.

x2

x-coordinate of lower right point.

y2

y-coordinate of lower right point.

width

Width of the rectangles border, if the width is 0.0 then the rectangle is filled.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
swf_definepoly | Domů | swf_definetext


swf_definetext

(PHP 4)

swf_definetext — Define a text string

Popis

void swf_definetext ( int $objid, string $str, int $docenter )

Defines a text string using the current font and font size.

Seznam parametrů

objid

The object id.

str

The text, as a string.

docenter

The docenter is where the word is centered, if docenter is 1, then the word is centered in x.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
swf_definerect | Domů | swf_endbutton


swf_endbutton

(PHP 4)

swf_endbutton — End the definition of the current button

Popis

void swf_endbutton ( void )

The swf_endbutton() function ends the definition of the current button.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
swf_definetext | Domů | swf_enddoaction


swf_enddoaction

(PHP 4)

swf_enddoaction — End the current action

Popis

void swf_enddoaction ( void )

Ends the current action started by the swf_startdoaction() function.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
swf_endbutton | Domů | swf_endshape


swf_endshape

(PHP 4)

swf_endshape — Completes the definition of the current shape

Popis

void swf_endshape ( void )

The swf_endshape() completes the definition of the current shape.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
swf_enddoaction | Domů | swf_endsymbol


swf_endsymbol

(PHP 4)

swf_endsymbol — End the definition of a symbol

Popis

void swf_endsymbol ( void )

Ends the definition of a symbol that was started by the swf_startsymbol() function.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
swf_endshape | Domů | swf_fontsize


swf_fontsize

(PHP 4)

swf_fontsize — Change the font size

Popis

void swf_fontsize ( float $size )

Changes the font size to the value given by the size parameter.

Seznam parametrů

size

The font size, as an integer.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
swf_endsymbol | Domů | swf_fontslant


swf_fontslant

(PHP 4)

swf_fontslant — Set the font slant

Popis

void swf_fontslant ( float $slant )

Set the current font slant to the angle indicated by the slant parameter.

Seznam parametrů

slant

Positive values create a forward slant, negative values create a negative slant.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
swf_fontsize | Domů | swf_fonttracking


swf_fonttracking

(PHP 4)

swf_fonttracking — Set the current font tracking

Popis

void swf_fonttracking ( float $tracking )

Set the font tracking to the value specified by the tracking parameter. This function is used to increase the spacing between letters and text, positive values increase the space and negative values decrease the space between letters.

Seznam parametrů

tracking

The font tracking.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
swf_fontslant | Domů | swf_getbitmapinfo


swf_getbitmapinfo

(PHP 4)

swf_getbitmapinfo — Get information about a bitmap

Popis

array swf_getbitmapinfo ( int $bitmapid )

Returns information about a bitmap.

Seznam parametrů

bitmapid

The bitmap id.

Návratové hodnoty

Returns an array with the following elements:

  • "size" - The size in bytes of the bitmap.
  • "width" - The width in pixels of the bitmap.
  • "height" - The height in pixels of the bitmap.

Předcházející | Nahoru | Další
swf_fonttracking | Domů | swf_getfontinfo


swf_getfontinfo

(PHP 4)

swf_getfontinfo — Gets font information

Popis

array swf_getfontinfo ( void )

Gets information about the font by giving the height in pixels of a capital A and a lowercase x.

Návratové hodnoty

Returns an associative array with the following parameters:

  • Aheight - The height in pixels of a capital A.
  • xheight - The height in pixels of a lowercase x.

Předcházející | Nahoru | Další
swf_getbitmapinfo | Domů | swf_getframe


swf_getframe

(PHP 4)

swf_getframe — Get the frame number of the current frame

Popis

int swf_getframe ( void )

The swf_getframe() function gets the number of the current frame.

Návratové hodnoty

Returns the current frame number, as an integer.

Předcházející | Nahoru | Další
swf_getfontinfo | Domů | swf_labelframe


swf_labelframe

(PHP 4)

swf_labelframe — Label the current frame

Popis

void swf_labelframe ( string $name )

Labels the current frame with the given name.

Seznam parametrů

name

The frame label.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
swf_getframe | Domů | swf_lookat


swf_lookat

(PHP 4)

swf_lookat — Define a viewing transformation

Popis

void swf_lookat ( float $view_x, float $view_y, float $view_z, float $reference_x, float $reference_y, float $reference_z, float $twist )

Defines a viewing transformation by giving the viewing position and the coordinates of a reference point in the scene.

Seznam parametrů

view_x

x-coordinate for the viewing position

view_y

y-coordinate for the viewing position

view_z

z-coordinate for the viewing position

reference_x

x-coordinate for the reference point

reference_y

y-coordinate for the reference point

reference_z

z-coordinate for the reference point

twist

Controls the rotation along with viewer's z axis.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
swf_labelframe | Domů | swf_modifyobject


swf_modifyobject

(PHP 4)

swf_modifyobject — Modify an object

Popis

void swf_modifyobject ( int $depth, int $how )

Updates the position and/or color of the object at the specified depth.

Seznam parametrů

depth

The depth, as an integer.

how

Determines what is updated. how can either be the constant MOD_MATRIX or MOD_COLOR or it can be a combination of both.

MOD_COLOR uses the current mulcolor (specified by the function swf_mulcolor()) and addcolor (specified by the function swf_addcolor()) to color the object. MOD_MATRIX uses the current matrix to position the object.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
swf_lookat | Domů | swf_mulcolor


swf_mulcolor

(PHP 4)

swf_mulcolor — Sets the global multiply color to the rgba value specified

Popis

void swf_mulcolor ( float $r, float $g, float $b, float $a )

Sets the global multiply color to the given one. This color is then
implicitly used by the swf_placeobject(),
swf_modifyobject() and
swf_addbuttonrecord() functions.

The color of the object will be multiplied by the given color values when the object is written to the screen.

Seznam parametrů

r

Red value

g

Green value

b

Blue value

a

Alpha value

These parameters can be either positive or negative.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
swf_modifyobject | Domů | swf_nextid


swf_nextid

(PHP 4)

swf_nextid — Returns the next free object id

Popis

int swf_nextid ( void )

The swf_nextid() function returns the next available object id.

Návratové hodnoty

Returns the id, as an integer.

Předcházející | Nahoru | Další
swf_mulcolor | Domů | swf_oncondition


swf_oncondition

(PHP 4)

swf_oncondition — Describe a transition used to trigger an action list

Popis

void swf_oncondition ( int $transition )

The swf_oncondition() function describes a transition that will trigger an action list.

Seznam parametrů

transition

There are several types of possible transitions, the following are for buttons defined as TYPE_MENUBUTTON:

  • IdletoOverUp
  • OverUptoIdle
  • OverUptoOverDown
  • OverDowntoOverUp
  • IdletoOverDown
  • OutDowntoIdle
  • MenuEnter (IdletoOverUp|IdletoOverDown)
  • MenuExit (OverUptoIdle|OverDowntoIdle)

For TYPE_PUSHBUTTON there are the following options:

  • IdletoOverUp
  • OverUptoIdle
  • OverUptoOverDown
  • OverDowntoOverUp
  • OverDowntoOutDown
  • OutDowntoOverDown
  • OutDowntoIdle
  • ButtonEnter (IdletoOverUp|OutDowntoOverDown)
  • ButtonExit (OverUptoIdle|OverDowntoOutDown)

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
swf_nextid | Domů | swf_openfile


swf_openfile

(PHP 4)

swf_openfile — Open a new Shockwave Flash file

Popis

void swf_openfile ( string $filename, float $width, float $height, float $framerate, float $r, float $g, float $b )

Opens a new file. This must be the first function you call, otherwise your script will not work.

Seznam parametrů

filename

The path to the SWF file. If you want to send your output to the screen, set this to php://stdout.

width

The movie width

height

The movie height

framerate

The frame rate.

r

Red value for the background.

g

Green value for the background.

b

Blue value for the background.

Návratové hodnoty

Nevrací se žádná hodnota.

ChangeLog (záznam změn)

Verze | Popis
4.0.1 | Support for php://stdout was added.

Předcházející | Nahoru | Další
swf_oncondition | Domů | swf_ortho2


swf_ortho2

(PHP 4)

swf_ortho2 — Defines 2D orthographic mapping of user coordinates onto the current viewport

Popis

void swf_ortho2 ( float $xmin, float $xmax, float $ymin, float $ymax )

Defines a two dimensional orthographic mapping of user coordinates onto the current viewport, this defaults to one to one mapping of the area of the Flash movie.

If a perspective transformation is desired, swf_perspective() can be used.

Seznam parametrů

xmin

xmax

ymin

ymax

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
swf_openfile | Domů | swf_ortho


swf_ortho

(PHP 4 >= 4.0.1)

swf_ortho — Defines an orthographic mapping of user coordinates onto the current viewport

Popis

void swf_ortho ( float $xmin, float $xmax, float $ymin, float $ymax, float $zmin, float $zmax )

Defines an orthographic mapping of user coordinates onto the current viewport.

Seznam parametrů

xmin

xmax

ymin

ymax

zmin

zmax

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
swf_ortho2 | Domů | swf_perspective


swf_perspective

(PHP 4)

swf_perspective — Define a perspective projection transformation

Popis

void swf_perspective ( float $fovy, float $aspect, float $near, float $far )

Defines a perspective projection transformation.

Poznámka: Various distortion artifacts may appear when performing a perspective projection, this is because Flash players only have a two dimensional matrix. Some are not to pretty.

Seznam parametrů

fovy

A field-of-view angle in the y direction.

aspect

The aspect ratio of the viewport that is being drawn onto.

near

The near clipping plane.

far

The far clipping plane.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
swf_ortho | Domů | swf_placeobject


swf_placeobject

(PHP 4)

swf_placeobject — Place an object onto the screen

Popis

void swf_placeobject ( int $objid, int $depth )

Places the object in the current frame at a specified depth.

This uses the current mulcolor (specified by swf_mulcolor()) and the current addcolor (specified by swf_addcolor()) to color the object and it uses the current matrix to position the object.

Seznam parametrů

objid

The object id.

depth

Must be between 1 and 65535.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
swf_perspective | Domů | swf_polarview


swf_polarview

(PHP 4)

swf_polarview — Define the viewer's position with polar coordinates

Popis

void swf_polarview ( float $dist, float $azimuth, float $incidence, float $twist )

The swf_polarview() function defines the viewer's position in polar coordinates.

Seznam parametrů

dist

The distance between the viewpoint to the world space origin.

azimuth

Defines the azimuthal angle in the x,y coordinate plane, measured in distance from the y axis.

incidence

Defines the angle of incidence in the y,z plane, measured in distance from the z axis. The incidence angle is defined as the angle of the viewport relative to the z axis.

twist

Specifies the amount that the viewpoint is to be rotated about the line of sight using the right hand rule.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
swf_placeobject | Domů | swf_popmatrix


swf_popmatrix

(PHP 4)

swf_popmatrix — Restore a previous transformation matrix

Popis

void swf_popmatrix ( void )

Pushes the current transformation matrix back onto the stack.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
swf_polarview | Domů | swf_posround


swf_posround

(PHP 4)

swf_posround — Enables or Disables the rounding of the translation when objects are placed or moved

Popis

void swf_posround ( int $round )

Enables or disables the rounding of the translation when objects are placed or moved, there are times when text becomes more readable because rounding has been enabled.

Seznam parametrů

round

Whether to enable rounding or not, if set to the value of 1, then rounding is enabled, if set to 0 then rounding is disabled.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
swf_popmatrix | Domů | swf_pushmatrix


swf_pushmatrix

(PHP 4)

swf_pushmatrix — Push the current transformation matrix back unto the stack

Popis

void swf_pushmatrix ( void )

Pushes the current transformation matrix back onto the stack.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
swf_posround | Domů | swf_removeobject


swf_removeobject

(PHP 4)

swf_removeobject — Remove an object

Popis

void swf_removeobject ( int $depth )

Removes the object at the depth specified by depth.

Seznam parametrů

depth

The depth, as an integer.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
swf_pushmatrix | Domů | swf_rotate


swf_rotate

(PHP 4)

swf_rotate — Rotate the current transformation

Popis

void swf_rotate ( float $angle, string $axis )

Rotates the current transformation by a given angle around the given axis.

Seznam parametrů

angle

The rotation angle.

axis

The axis. Valid values axis are x (the x axis), y (the y axis) or z (the z axis).

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
swf_removeobject | Domů | swf_scale


swf_scale

(PHP 4)

swf_scale — Scale the current transformation

Popis

void swf_scale ( float $x, float $y, float $z )

The swf_scale() scales curve coordinates by the given value.

Seznam parametrů

x

x scale factor.

y

y scale factor.

z

z scale factor.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
swf_rotate | Domů | swf_setfont


swf_setfont

(PHP 4)

swf_setfont — Change the current font

Popis

void swf_setfont ( int $fontid )

The swf_setfont() sets the current font to the value given by the fontid parameter.

Seznam parametrů

fontid

The font identifier.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
swf_scale | Domů | swf_setframe


swf_setframe

(PHP 4)

swf_setframe — Switch to a specified frame

Popis

void swf_setframe ( int $framenumber )

Changes the active frame to the specified on.

Seznam parametrů

framenumber

The frame number to be set.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
swf_setfont | Domů | swf_shapearc


swf_shapearc

(PHP 4)

swf_shapearc — Draw a circular arc

Popis

void swf_shapearc ( float $x, float $y, float $r, float $ang1, float $ang2 )

Draws a circular arc.

Seznam parametrů

x

x-coordinate of the center.

y

y-coordinate of the center.

r

The arc radius.

ang1

The start angle.

ang2

The end angle.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
swf_setframe | Domů | swf_shapecurveto3


swf_shapecurveto3

(PHP 4)

swf_shapecurveto3 — Draw a cubic bezier curve

Popis

void swf_shapecurveto3 ( float $x1, float $y1, float $x2, float $y2, float $x3, float $y3 )

Draw a cubic bezier curve using the given coordinates.

The current position is then set to the x3,y3 coordinate.

Seznam parametrů

x1

x-coordinate of the first off curve control point.

y1

y-coordinate of the first off curve control point.

x2

x-coordinate of the second off curve control point.

y2

y-coordinate of the second off curve control point.

x3

x-coordinate of the endpoint.

y3

y-coordinate of the endpoint.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
swf_shapearc | Domů | swf_shapecurveto


swf_shapecurveto

(PHP 4)

swf_shapecurveto — Draw a quadratic bezier curve between two points

Popis

void swf_shapecurveto ( float $x1, float $y1, float $x2, float $y2 )

Draws a quadratic bezier curve from the current location, though the two given points.

The current position is then set to the point defined by the x2 and y2 parameters.

Seznam parametrů

x1

x-coordinate of the first point.

y1

y-coordinate of the first point.

x2

x-coordinate of the second point.

y2

y-coordinate of the second point.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
swf_shapecurveto3 | Domů | swf_shapefillbitmapclip


swf_shapefillbitmapclip

(PHP 4)

swf_shapefillbitmapclip — Set current fill mode to clipped bitmap

Popis

void swf_shapefillbitmapclip ( int $bitmapid )

Sets the fill to bitmap clipped, empty spaces will be filled by the bitmap.

Seznam parametrů

bitmapid

The bitmap id.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
swf_shapecurveto | Domů | swf_shapefillbitmaptile


swf_shapefillbitmaptile

(PHP 4)

swf_shapefillbitmaptile — Set current fill mode to tiled bitmap

Popis

void swf_shapefillbitmaptile ( int $bitmapid )

Sets the fill to bitmap tile, empty spaces will be filled by the bitmap.

Seznam parametrů

bitmapid

The bitmap id.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
swf_shapefillbitmapclip | Domů | swf_shapefilloff


swf_shapefilloff

(PHP 4)

swf_shapefilloff — Turns off filling

Popis

void swf_shapefilloff ( void )

Turns off filling for the current shape.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
swf_shapefillbitmaptile | Domů | swf_shapefillsolid


swf_shapefillsolid

(PHP 4)

swf_shapefillsolid — Set the current fill style to the specified color

Popis

void swf_shapefillsolid ( float $r, float $g, float $b, float $a )

Sets the current fill style to solid, and then sets the fill color to the given color.

Seznam parametrů

r

Red value

g

Green value

b

Blue value

a

Alpha value

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
swf_shapefilloff | Domů | swf_shapelinesolid


swf_shapelinesolid

(PHP 4)

swf_shapelinesolid — Set the current line style

Popis

void swf_shapelinesolid ( float $r, float $g, float $b, float $a, float $width )

Sets the current line style to the given color and width.

Seznam parametrů

r

Red value

g

Green value

b

Blue value

a

Alpha value

width

The line width. If 0.0 is given then no lines are drawn.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
swf_shapefillsolid | Domů | swf_shapelineto


swf_shapelineto

(PHP 4)

swf_shapelineto — Draw a line

Popis

void swf_shapelineto ( float $x, float $y )

Draws a line to the x and y coordinates. The current position is then set to that point.

Seznam parametrů

x

x-coordinate of the target.

y

y-coordinate of the target.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
swf_shapelinesolid | Domů | swf_shapemoveto


swf_shapemoveto

(PHP 4)

swf_shapemoveto — Move the current position

Popis

void swf_shapemoveto ( float $x, float $y )

Moves the current position to the given point.

Seznam parametrů

x

x-coordinate of the target.

y

y-coordinate of the target.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
swf_shapelineto | Domů | swf_showframe


swf_showframe

(PHP 4)

swf_showframe — Display the current frame

Popis

void swf_showframe ( void )

Outputs the current frame.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
swf_shapemoveto | Domů | swf_startbutton


swf_startbutton

(PHP 4)

swf_startbutton — Start the definition of a button

Popis

void swf_startbutton ( int $objid, int $type )

Starts the definition of a button.

Seznam parametrů

objid

The object id.

type

Can either be TYPE_MENUBUTTON or TYPE_PUSHBUTTON. The TYPE_MENUBUTTON constant allows the focus to travel from the button when the mouse is down, TYPE_PUSHBUTTON does not allow the focus to travel when the mouse is down.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
swf_showframe | Domů | swf_startdoaction


swf_startdoaction

(PHP 4)

swf_startdoaction — Start a description of an action list for the current frame

Popis

void swf_startdoaction ( void )

Starts the description of an action list for the current frame. This must be called before actions are defined for the current frame.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
swf_startbutton | Domů | swf_startshape


swf_startshape

(PHP 4)

swf_startshape — Start a complex shape

Popis

void swf_startshape ( int $objid )

Starts a complex shape.

Seznam parametrů

objid

The object id.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
swf_startdoaction | Domů | swf_startsymbol


swf_startsymbol

(PHP 4)

swf_startsymbol — Define a symbol

Popis

void swf_startsymbol ( int $objid )

Defines an object id as a symbol. Symbols are tiny flash movies that can be played simultaneously.

Seznam parametrů

objid

The object id you want to define as a symbol.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
swf_startshape | Domů | swf_textwidth


swf_textwidth

(PHP 4)

swf_textwidth — Get the width of a string

Popis

float swf_textwidth ( string $str )

Gives the width of the string in pixels, using the current font and font size.

Seznam parametrů

str

The string.

Návratové hodnoty

Returns the line width, as a float.

Předcházející | Nahoru | Další
swf_startsymbol | Domů | swf_translate


swf_translate

(PHP 4)

swf_translate — Translate the current transformations

Popis

void swf_translate ( float $x, float $y, float $z )

Translates the current transformation by the given values.

Seznam parametrů

x

x value.

y

y value.

z

z value.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
swf_textwidth | Domů | swf_viewport


swf_viewport

(PHP 4)

swf_viewport — Select an area for future drawing

Popis

void swf_viewport ( float $xmin, float $xmax, float $ymin, float $ymax )

Selects an area for future drawing for xmin to xmax and ymin to ymax, if this function is not called the area defaults to the size of the screen.

Seznam parametrů

xmin

xmax

ymin

ymax

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
swf_translate | Domů | CLXIV. Swish Functions


SNMP Functions

Předcházející VI. Reference funkcí Další

CLII. SNMP Functions

Úvod

Požadavky

In order to use the SNMP functions on Unix you need to install the » NET-SNMP package. On Windows these functions are only available on NT and not on Win95/98.

Instalace

Important: In order to use the UCD SNMP package, you need to define NO_ZEROLENGTH_COMMUNITY to 1 before compiling it. After configuring UCD SNMP, edit config.h or acconfig.h and search for NO_ZEROLENGTH_COMMUNITY. Uncomment the #define line. It should look like this afterwards:

#define NO_ZEROLENGTH_COMMUNITY 1
Now compile PHP --with-snmp[=DIR].

If you see strange segmentation faults in combination with SNMP commands, you did not follow the above instructions. If you do not want to recompile UCD SNMP, you can compile PHP with the --enable-ucd-snmp-hack switch which will work around the misfeature.

The Windows distribution contains support files for SNMP in the mibs directory. This directory should be moved to DRIVE:\usr\mibs, where DRIVE must be replaced with the driveletter where PHP is installed on, e.g.c:\usr\mibs.

Konfigurace běhu

Toto rozšíření nemá definováno žádné konfigurační direktivy.

Typy prostředků

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

SNMP_OID_OUTPUT_FULL (integer)
As of 5.2.0
SNMP_OID_OUTPUT_NUMERIC (integer)
As of 5.2.0
SNMP_VALUE_LIBRARY (integer)
SNMP_VALUE_PLAIN (integer)
SNMP_VALUE_OBJECT (integer)
SNMP_BIT_STR (integer)
SNMP_OCTET_STR (integer)
SNMP_OPAQUE (integer)
SNMP_NULL (integer)
SNMP_OBJECT_ID (integer)
SNMP_IPADDRESS (integer)
SNMP_COUNTER (integer)
SNMP_UNSIGNED (integer)
SNMP_TIMETICKS (integer)
SNMP_UINTEGER (integer)
SNMP_INTEGER (integer)
SNMP_COUNTER64 (integer)

Obsah

snmp_get_quick_print — Fetches the current value of the UCD library's quick_print setting
snmp_get_valueretrieval — Return the method how the SNMP values will be returned
snmp_read_mib — Reads and parses a MIB file into the active MIB tree
snmp_set_enum_print — Return all values that are enums with their enum value instead of the raw integer
snmp_set_oid_numeric_print — Return all objects including their respective object id within the specified one
snmp_set_oid_output_format — Set the OID output format
snmp_set_quick_print — Set the value of quick_print within the UCD SNMP library
snmp_set_valueretrieval — Specify the method how the SNMP values will be returned
snmpget — Fetch an SNMP object
snmpgetnext — Fetch a SNMP object
snmprealwalk — Return all objects including their respective object ID within the specified one
snmpset — Set an SNMP object
snmpwalk — Fetch all the SNMP objects from an agent
snmpwalkoid — Query for a tree of information about a network entity
Předcházející | Nahoru | Další
simplexml_load_string | Domů | snmp_get_quick_print


snmp_get_quick_print

(PHP 4, PHP 5)

snmp_get_quick_print — Fetches the current value of the UCD library's quick_print setting

Popis

bool snmp_get_quick_print ( void )

Returns the current value stored in the UCD Library for quick_print. quick_print is off by default.

Návratové hodnoty

Returns TRUE if quick_print is on, FALSE otherwise.

Příklady

Příklad 2051. snmp_get_quick_print() example

<?php
$quickprint = snmp_get_quick_print();
?>

Viz také

snmp_set_quick_print() for a full description of what quick_print does.

Předcházející | Nahoru | Další
CLII. SNMP Functions | Domů | snmp_get_valueretrieval


snmp_get_valueretrieval

(PHP 4 >= 4.3.3, PHP 5)

snmp_get_valueretrieval — Return the method how the SNMP values will be returned

Popis

int snmp_get_valueretrieval ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Viz také

snmp_set_valueretrieval()

Předcházející | Nahoru | Další
snmp_get_quick_print | Domů | snmp_read_mib


snmp_read_mib

(PHP 5)

snmp_read_mib — Reads and parses a MIB file into the active MIB tree

Popis

bool snmp_read_mib ( string $filename )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
snmp_get_valueretrieval | Domů | snmp_set_enum_print


snmp_set_enum_print

(PHP 4 >= 4.3.0, PHP 5)

snmp_set_enum_print — Return all values that are enums with their enum value instead of the raw integer

Popis

void snmp_set_enum_print ( int $enum_print )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Poznámky

Poznámka: snmp_set_enum_print() is only available when using the UCD SNMP library. This function is not available when using the Windows SNMP library.

Předcházející | Nahoru | Další
snmp_read_mib | Domů | snmp_set_oid_numeric_print


snmp_set_oid_numeric_print

(PHP 4 >= 4.3.0, PHP 5)

snmp_set_oid_numeric_print — Return all objects including their respective object id within the specified one

Popis

void snmp_set_oid_numeric_print ( int $oid_numeric_print )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

ChangeLog (záznam změn)

Verze | Popis
5.2.0 | Since PHP 5.2.0, Tato funkce je aliasem: snmp_set_oid_output_format().

Viz také

snmp_set_oid_output_format()

Předcházející | Nahoru | Další
snmp_set_enum_print | Domů | snmp_set_oid_output_format


snmp_set_quick_print

(PHP 4, PHP 5)

snmp_set_quick_print — Set the value of quick_print within the UCD SNMP library

Popis

void snmp_set_quick_print ( bool $quick_print )

Sets the value of quick_print within the UCD SNMP library. When this is set (1), the SNMP library will return 'quick printed' values. This means that just the value will be printed. When quick_print is not enabled (default) the UCD SNMP library prints extra information including the type of the value (i.e. IpAddress or OID). Additionally, if quick_print is not enabled, the library prints additional hex values for all strings of three characters or less.

By default the UCD SNMP library returns verbose values, quick_print is used to return only the value.

Currently strings are still returned with extra quotes, this will be corrected in a later release.

Seznam parametrů

quick_print

Návratové hodnoty

Nevrací se žádná hodnota.

Příklady

Setting quick_print is often used when using the information returned rather then displaying it.

Příklad 2052. Using snmp_set_quick_print()

<?php
snmp_set_quick_print(0);
$a = snmpget("127.0.0.1", "public", ".1.3.6.1.2.1.2.2.1.9.1");
echo "$a\n";
snmp_set_quick_print(1);
$a = snmpget("127.0.0.1", "public", ".1.3.6.1.2.1.2.2.1.9.1");
echo "$a\n";
?>

Výše uvedený příklad vypíše něco jako:

'Timeticks: (0) 0:00:00.00'
'0:00:00.00'

Viz také

snmp_get_quick_print()

Předcházející | Nahoru | Další
snmp_set_oid_output_format | Domů | snmp_set_valueretrieval


snmp_set_valueretrieval

(PHP 4 >= 4.3.3, PHP 5)

snmp_set_valueretrieval — Specify the method how the SNMP values will be returned

Popis

void snmp_set_valueretrieval ( int $method )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Viz také

snmp_get_valueretrieval()

Předcházející | Nahoru | Další
snmp_set_quick_print | Domů | snmpget


snmpget

(PHP 4, PHP 5)

snmpget — Fetch an SNMP object

Popis

string snmpget ( string $hostname, string $community, string $object_id [, int $timeout [, int $retries]] )

The snmpget() function is used to read the value of an SNMP object specified by the object_id.

Seznam parametrů

hostname

The SNMP agent.

community

The read community.

object_id

The SNMP object.

timeout

retries

Návratové hodnoty

Returns SNMP object value on success or FALSE on error.

Příklady

Příklad 2053. Using snmpget()

<?php
$syscontact = snmpget("127.0.0.1", "public", "system.SysContact.0");
?>

Viz také

snmpset()

Předcházející | Nahoru | Další
snmp_set_valueretrieval | Domů | snmpgetnext


snmpgetnext

(PHP 5)

snmpgetnext — Fetch a SNMP object

Popis

string snmpgetnext ( string $host, string $community, string $object_id [, int $timeout [, int $retries]] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
snmpget | Domů | snmprealwalk


snmprealwalk

(PHP 4, PHP 5)

snmprealwalk — Return all objects including their respective object ID within the specified one

Popis

array snmprealwalk ( string $host, string $community, string $object_id [, int $timeout [, int $retries]] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
snmpgetnext | Domů | snmpset


snmpset

(PHP 4, PHP 5)

snmpset — Set an SNMP object

Popis

bool snmpset ( string $hostname, string $community, string $object_id, string $type, mixed $value [, int $timeout [, int $retries]] )

snmpset() is used to set the value of an SNMP object specified by the object_id.

Seznam parametrů

hostname

The SNMP agent.

community

The read community.

object_id

The SNMP object.

type

value

timeout

retries

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

snmpget()

Předcházející | Nahoru | Další
snmprealwalk | Domů | snmpwalk


snmpwalk

(PHP 4, PHP 5)

snmpwalk — Fetch all the SNMP objects from an agent

Popis

array snmpwalk ( string $hostname, string $community, string $object_id [, int $timeout [, int $retries]] )

snmpwalk() function is used to read all the values from an SNMP agent specified by the hostname.

Seznam parametrů

hostname

The SNMP agent.

community

The read community.

object_id

If NULL, object_id is taken as the root of the SNMP objects tree and all objects under that tree are returned as an array.

If object_id is specified, all the SNMP objects below that object_id are returned.

timeout

retries

Návratové hodnoty

Returns an array of SNMP object values starting from the object_id as root or FALSE on error.

Příklady

Příklad 2054. snmpwalk() Example

<?php
$a = snmpwalk("127.0.0.1", "public", "");

foreach ($a as $val) {
    echo "$val\n";
}

?>

Above function call would return all the SNMP objects from the SNMP agent running on localhost. One can step through the values with a loop

Viz také

snmpwalkoid()

Předcházející | Nahoru | Další
snmpset | Domů | snmpwalkoid


snmpwalkoid

(PHP 4, PHP 5)

snmpwalkoid — Query for a tree of information about a network entity

Popis

array snmpwalkoid ( string $hostname, string $community, string $object_id [, int $timeout [, int $retries]] )

snmpwalkoid() function is used to read all object ids and their respective values from an SNMP agent specified by hostname.

The existence of snmpwalkoid() and snmpwalk() has historical reasons. Both functions are provided for backward compatibility. Use snmprealwalk() instead.

Seznam parametrů

hostname

The SNMP agent.

community

The read community.

object_id

If NULL, object_id is taken as the root of the SNMP objects tree and all objects under that tree are returned as an array.

If object_id is specified, all the SNMP objects below that object_id are returned.

timeout

retries

Návratové hodnoty

Returns an associative array with object ids and their respective object value starting from the object_id as root or FALSE on error.

Příklady

Příklad 2055. snmpwalkoid() Example

<?php
$a = snmpwalkoid("127.0.0.1", "public", "");
for (reset($a); $i = key($a); next($a)) {
    echo "$i: $a[$i]<br />\n";
}
?>

Above function call would return all the SNMP objects from the SNMP agent running on localhost. One can step through the values with a loop

Viz také

snmpwalk()

Předcházející | Nahoru | Další
snmpwalk | Domů | CLIII. SOAP Functions


Socket Functions

Předcházející VI. Reference funkcí Další

CLIV. Socket Functions

Úvod

The socket extension implements a low-level interface to the socket communication functions based on the popular BSD sockets, providing the possibility to act as a socket server as well as a client.

For a more generic client-side socket interface, see
stream_socket_client(),
stream_socket_server(),
fsockopen(), and
pfsockopen().

When using these functions, it is important to remember that while many of them have identical names to their C counterparts, they often have different declarations. Please be sure to read the descriptions to avoid confusion.

Those unfamiliar with socket programming can find a lot of useful material in the appropriate Unix man pages, and there is a great deal of tutorial information on socket programming in C on the web, much of which can be applied, with slight modifications, to socket programming in PHP. The » Unix Socket FAQ might be a good start.

Poznámka: Toto rozšíření bylo přesunuto do repozitáře PECL a již nebude součástí balíku PHP.5.3.0.

Požadavky

Tyto funkce jsou k dispozici jako součást standardního modulu, který je vždy dostupný.

Instalace

The socket functions described here are part of an extension to PHP which must be enabled at compile time by giving the --enable-sockets option to configure.

Poznámka: Podpora IPv6 byla přidána v PHP 5.0.0 .

Konfigurace běhu

Toto rozšíření nemá definováno žádné konfigurační direktivy.

Typy prostředků

socket_accept(),
socket_create_listen() and
socket_create() return socket recources.

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

AF_UNIX (integer)
AF_INET (integer)
AF_INET6 (integer)
SOCK_STREAM (integer)
SOCK_DGRAM (integer)
SOCK_RAW (integer)
SOCK_SEQPACKET (integer)
SOCK_RDM (integer)
MSG_OOB (integer)
MSG_WAITALL (integer)
MSG_PEEK (integer)
MSG_DONTROUTE (integer)
MSG_EOR (integer)
MSG_EOF (integer)
SO_DEBUG (integer)
SO_REUSEADDR (integer)
SO_KEEPALIVE (integer)
SO_DONTROUTE (integer)
SO_LINGER (integer)
SO_BROADCAST (integer)
SO_OOBINLINE (integer)
SO_SNDBUF (integer)
SO_RCVBUF (integer)
SO_SNDLOWAT (integer)
SO_RCVLOWAT (integer)
SO_SNDTIMEO (integer)
SO_RCVTIMEO (integer)
SO_TYPE (integer)
SO_ERROR (integer)
SOL_SOCKET (integer)
PHP_NORMAL_READ (integer)
PHP_BINARY_READ (integer)
SOL_TCP (integer)
SOL_UDP (integer)

Socket Errors

The socket extension was written to provide a usable interface to the powerful BSD sockets. Care has been taken that the functions work equally well on Win32 and Unix implementations. Almost all of the sockets functions may fail under certain conditions and therefore emit an E_WARNING message describing the error. Sometimes this doesn't happen to the desire of the developer. For example the function socket_read() may suddenly emit an E_WARNING message because the connection broke unexpectedly. It's common to suppress the warning with the @-operator and catch the error code within the application with the socket_last_error() function. You may call the socket_strerror() function with this error code to retrieve a string describing the error. See their description for more information.

Poznámka: The E_WARNING messages generated by the socket extension are in English though the retrieved error message will appear depending on the current locale (LC_MESSAGES): Warning - socket_bind() unable to bind address [98]: Die Adresse wird bereits verwendet

Příklady

Příklad 2076. Socket example: Simple TCP/IP server

This example shows a simple talkback server. Change the address and port variables to suit your setup and execute. You may then connect to the server with a command similar to: telnet 192.168.1.53 10000 (where the address and port match your setup). Anything you type will then be output on the server side, and echoed back to you. To disconnect, enter 'quit'.

#!/usr/local/bin/php -q
<?php
error_reporting(E_ALL);

/* Allow the script to hang around waiting for connections. */
set_time_limit(0);

/* Turn on implicit output flushing so we see what we're getting
 * as it comes in. */
ob_implicit_flush();

$address = '192.168.1.53';
$port = 10000;

if (($sock = socket_create(AF_INET, SOCK_STREAM, SOL_TCP)) === false) {
    echo "socket_create() failed: reason: " . socket_strerror(socket_last_error()) . "\n";
}

if (socket_bind($sock, $address, $port) === false) {
    echo "socket_bind() failed: reason: " . socket_strerror(socket_last_error($sock)) . "\n";
}

if (socket_listen($sock, 5) === false) {
    echo "socket_listen() failed: reason: " . socket_strerror(socket_last_error($sock)) . "\n";
}

do {
    if (($msgsock = socket_accept($sock)) === false) {
        echo "socket_accept() failed: reason: " . socket_strerror(socket_last_error($sock)) . "\n";
        break;
    }
    /* Send instructions. */
    $msg = "\nWelcome to the PHP Test Server. \n" .
        "To quit, type 'quit'. To shut down the server type 'shutdown'.\n";
    socket_write($msgsock, $msg, strlen($msg));

    do {
        if (false === ($buf = socket_read($msgsock, 2048, PHP_NORMAL_READ))) {
            echo "socket_read() failed: reason: " . socket_strerror(socket_last_error($msgsock)) . "\n";
            break 2;
        }
        if (!$buf = trim($buf)) {
            continue;
        }
        if ($buf == 'quit') {
            break;
        }
        if ($buf == 'shutdown') {
            socket_close($msgsock);
            break 2;
        }
        $talkback = "PHP: You said '$buf'.\n";
        socket_write($msgsock, $talkback, strlen($talkback));
        echo "$buf\n";
    } while (true);
    socket_close($msgsock);
} while (true);

socket_close($sock);
?>

Příklad 2077. Socket example: Simple TCP/IP client

This example shows a simple, one-shot HTTP client. It simply connects to a page, submits a HEAD request, echoes the reply, and exits.

<?php
error_reporting(E_ALL);

echo "<h2>TCP/IP Connection</h2>\n";

/* Get the port for the WWW service. */
$service_port = getservbyname('www', 'tcp');

/* Get the IP address for the target host. */
$address = gethostbyname('www.example.com');

/* Create a TCP/IP socket. */
$socket = socket_create(AF_INET, SOCK_STREAM, SOL_TCP);
if ($socket === false) {
    echo "socket_create() failed: reason: " . socket_strerror(socket_last_error()) . "\n";
} else {
    echo "OK.\n";
}

echo "Attempting to connect to '$address' on port '$service_port'...";
$result = socket_connect($socket, $address, $service_port);
if ($result === false) {
    echo "socket_connect() failed.\nReason: ($result) " . socket_strerror(socket_last_error($socket)) . "\n";
} else {
    echo "OK.\n";
}

$in = "HEAD / HTTP/1.1\r\n";
$in .= "Host: www.example.com\r\n";
$in .= "Connection: Close\r\n\r\n";
$out = '';

echo "Sending HTTP HEAD request...";
socket_write($socket, $in, strlen($in));
echo "OK.\n";

echo "Reading response:\n\n";
while ($out = socket_read($socket, 2048)) {
    echo $out;
}

echo "Closing socket...";
socket_close($socket);
echo "OK.\n\n";
?>

Obsah

socket_accept — Accepts a connection on a socket
socket_bind — Binds a name to a socket
socket_clear_error — Clears the error on the socket or the last error code
socket_close — Closes a socket resource
socket_connect — Initiates a connection on a socket
socket_create_listen — Opens a socket on port to accept connections
socket_create_pair — Creates a pair of indistinguishable sockets and stores them in an array
socket_create — Create a socket (endpoint for communication)
socket_get_option — Gets socket options for the socket
socket_getpeername — Queries the remote side of the given socket which may either result in host/port or in a Unix filesystem path, dependent on its type
socket_getsockname — Queries the local side of the given socket which may either result in host/port or in a Unix filesystem path, dependent on its type
socket_last_error — Returns the last error on the socket
socket_listen — Listens for a connection on a socket
socket_read — Reads a maximum of length bytes from a socket
socket_recv — Receives data from a connected socket
socket_recvfrom — Receives data from a socket whether or not it is connection-oriented
socket_select — Runs the select() system call on the given arrays of sockets with a specified timeout
socket_send — Sends data to a connected socket
socket_sendto — Sends a message to a socket, whether it is connected or not
socket_set_block — Sets blocking mode on a socket resource
socket_set_nonblock — Sets nonblocking mode for file descriptor fd
socket_set_option — Sets socket options for the socket
socket_shutdown — Shuts down a socket for receiving, sending, or both
socket_strerror — Return a string describing a socket error
socket_write — Write to a socket
Předcházející | Nahoru | Další
use_soap_error_handler | Domů | socket_accept


socket_accept

(PHP 4 >= 4.0.7, PHP 5)

socket_accept — Accepts a connection on a socket

Popis

resource socket_accept ( resource $socket )

After the socket socket has been created using socket_create(), bound to a name with socket_bind(), and told to listen for connections with socket_listen(), this function will accept incoming connections on that socket. Once a successful connection is made, a new socket resource is returned, which may be used for communication. If there are multiple connections queued on the socket, the first will be used. If there are no pending connections, socket_accept() will block until a connection becomes present. If socket has been made non-blocking using socket_set_blocking() or socket_set_nonblock(), FALSE will be returned.

The socket resource returned by socket_accept() may not be used to accept new connections. The original listening socket socket, however, remains open and may be reused.

Seznam parametrů

socket

A valid socket resource created with socket_create().

Návratové hodnoty

Returns a new socket resource on success, or FALSE on error. The actual error code can be retrieved by calling socket_last_error(). This error code may be passed to socket_strerror() to get a textual explanation of the error.

Viz také

socket_connect()
socket_listen()
socket_create()
socket_bind()
socket_strerror()

Předcházející | Nahoru | Další
CLIV. Socket Functions | Domů | socket_bind


socket_bind

(PHP 4 >= 4.0.7, PHP 5)

socket_bind — Binds a name to a socket

Popis

bool socket_bind ( resource $socket, string $address [, int $port] )

Binds the name given in address to the socket described by socket. This has to be done before a connection is be established using socket_connect() or socket_listen().

Seznam parametrů

socket

A valid socket resource created with socket_create().

address

If the socket is of the AF_INET family, the address is an IP in dotted-quad notation (e.g. 127.0.0.1).

If the socket is of the AF_UNIX family, the address is the path of a Unix-domain socket (e.g. /tmp/my.sock).

port (Optional)

The port parameter is only used when connecting to an AF_INET socket, and designates the port on the remote host to which a connection should be made.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

The error code can be retrieved with socket_last_error(). This code may be passed to socket_strerror() to get a textual explanation of the error.

Příklady

Příklad 2078. Using socket_bind() to set the source address

<?php
// Create a new socket
$sock = socket_create(AF_INET, SOCK_STREAM, SOL_TCP);

// An example list of IP addresses owned by the computer
$sourceips['kevin']    = '127.0.0.1';
$sourceips['madcoder'] = '127.0.0.2';

// Bind the source address
socket_bind($sock, $sourceips['madcoder']);

// Connect to destination address
socket_connect($sock, '127.0.0.1', 80);

// Write
$request = 'GET / HTTP/1.1' . "\r\n" .
           'Host: example.com' . "\r\n\r\n";
socket_write($sock, $request);

// Close
socket_close($sock);

?>

Poznámky

Poznámka: This function must be used on the socket before socket_connect().

Poznámka: Windows 9x/ME compatibility note: socket_last_error() may return an invalid error code if trying to bind the socket to a wrong address that does not belong to your machine.

Viz také

socket_connect()
socket_listen()
socket_create()
socket_last_error()
socket_strerror()

Předcházející | Nahoru | Další
socket_accept | Domů | socket_clear_error


socket_clear_error

(PHP 4 >= 4.2.0, PHP 5)

socket_clear_error — Clears the error on the socket or the last error code

Popis

void socket_clear_error ( [resource $socket] )

This function clears the error code on the given socket or the global last socket error if no socket is specified.

This function allows explicitly resetting the error code value either of a socket or of the extension global last error code. This may be useful to detect within a part of the application if an error occurred or not.

Seznam parametrů

socket

A valid socket resource created with socket_create().

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

socket_last_error()
socket_strerror()

Předcházející | Nahoru | Další
socket_bind | Domů | socket_close


socket_close

(PHP 4 >= 4.0.7, PHP 5)

socket_close — Closes a socket resource

Popis

void socket_close ( resource $socket )

socket_close() closes the socket resource given by socket. This function is specific to sockets and cannot be used on any other type of resources.

Seznam parametrů

socket

A valid socket resource created with socket_create() or socket_accept().

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

socket_bind()
socket_listen()
socket_create()
socket_strerror()

Předcházející | Nahoru | Další
socket_clear_error | Domů | socket_connect


socket_connect

(PHP 4 >= 4.0.7, PHP 5)

socket_connect — Initiates a connection on a socket

Popis

bool socket_connect ( resource $socket, string $address [, int $port] )

Initiate a connection to address using the socket resource socket, which must be a valid socket resource created with socket_create().

Seznam parametrů

socket

address

The address parameter is either an IPv4 address in dotted-quad notation (e.g. 127.0.0.1) if socket is AF_INET, a valid IPv6 address (e.g. ::1) if IPv6 support is enabled and socket is AF_INET6 or the pathname of a Unix domain socket, if the socket family is AF_UNIX.

port

The port parameter is only used and is mandatory when connecting to an AF_INET or an AF_INET6 socket, and designates the port on the remote host to which a connection should be made.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání. The error code can be retrieved with socket_last_error(). This code may be passed to socket_strerror() to get a textual explanation of the error.

Poznámka: If the socket is non-blocking then this function returns FALSE with an error Operation now in progress.

Viz také

socket_bind()
socket_listen()
socket_create()
socket_last_error()
socket_strerror()

Předcházející | Nahoru | Další
socket_close | Domů | socket_create_listen


socket_create_listen

(PHP 4 >= 4.0.7, PHP 5)

socket_create_listen — Opens a socket on port to accept connections

Popis

resource socket_create_listen ( int $port [, int $backlog] )

socket_create_listen() creates a new socket resource of type AF_INET listening on all local interfaces on the given port waiting for new connections.

This function is meant to ease the task of creating a new socket which only listens to accept new connections.

Seznam parametrů

port

The port on which to listen on all interfaces.

backlog

The backlog parameter defines the maximum length the queue of pending connections may grow to. SOMAXCONN may be passed as backlog parameter, see socket_listen() for more information.

Návratové hodnoty

socket_create_listen() returns a new socket resource on success or FALSE on error. The error code can be retrieved with socket_last_error(). This code may be passed to socket_strerror() to get a textual explanation of the error.

Poznámky

Poznámka: If you want to create a socket which only listens on a certain interface you need to use socket_create(), socket_bind() and socket_listen().

Viz také

socket_create()
socket_create_pair()
socket_bind()
socket_listen()
socket_last_error()
socket_strerror()

Předcházející | Nahoru | Další
socket_connect | Domů | socket_create_pair


socket_create_pair

(PHP 4 >= 4.0.7, PHP 5)

socket_create_pair — Creates a pair of indistinguishable sockets and stores them in an array

Popis

bool socket_create_pair ( int $domain, int $type, int $protocol, array &$fd )

socket_create_pair() creates two connected and indistinguishable sockets, and stores them in fd. This function is commonly used in IPC (InterProcess Communication).

Seznam parametrů

domain

The domain parameter specifies the protocol family to be used by the socket. See socket_create() for the full list.

type

The type parameter selects the type of communication to be used by the socket. See socket_create() for the full list.

protocol

The protocol parameter sets the specific protocol within the specified domain to be used when communicating on the returned socket. The proper value can be retrieved by name by using getprotobyname(). If the desired protocol is TCP, or UDP the corresponding constants SOL_TCP, and SOL_UDP can also be used.

See socket_create() for the full list of supported protocols.

fd

Reference to an array in which the two socket resources will be inserted.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 2079. socket_create_pair() example

<?php
$sockets = array();
/* Setup socket pair */
if (socket_create_pair(AF_UNIX, SOCK_STREAM, 0, $sockets) === false) {
    echo "socket_create_pair failed. Reason: ".socket_strerror(socket_last_error());
}
/* Send and Recieve Data */
if (socket_write($sockets[0], "ABCdef123\n", strlen("ABCdef123\n")) === false) {
    echo "socket_write() failed. Reason: ".socket_strerror(socket_last_error($sockets[0]));
}
if (($data = socket_read($sockets[1], strlen("ABCdef123\n"), PHP_BINARY_READ) === false) {
    echo "socket_read() failed. Reason: ".socket_strerror(socket_last_error($sockets[1]));
}
var_dump($data);

/* Close sockets */
socket_close($sockets[0]);
socket_close($sockets[1]);
?>

Příklad 2080. socket_create_pair() IPC example

<?php
$ary = array();
$strone = 'Message From Parent.';
$strtwo = 'Message From Child.';
if (socket_create_pair(AF_UNIX, SOCK_STREAM, 0, $ary) === false) {
    echo "socket_create_pair() failed. Reason: ".socket_strerror(socket_last_error());
}
$pid = pcntl_fork();
if ($pid == -1) {
    echo 'Could not fork Process.';
} elseif ($pid) {
    /*parent*/
    socket_close($ary[0]);
    if (socket_write($ary[1], $strone, strlen($strone)) === false) {
        echo "socket_write() failed. Reason: ".socket_strerror(socket_last_error($ary[1]));
    }
    if (socket_read($ary[1], strlen($strtwo), PHP_BINARY_READ) == $strtwo) {
        echo "Recieved $strtwo\n";
    }
    socket_close($ary[1]);
} else {
    /*child*/
    socket_close($ary[1]);
    if (socket_write($ary[0], $strtwo, strlen($strtwo)) === false) {
        echo "socket_write() failed. Reason: ".socket_strerror(socket_last_error($ary[0]));
    }
    if (socket_read($ary[0], strlen($strone), PHP_BINARY_READ) == $strone) {
        echo "Recieved $strone\n";
    }
    socket_close($ary[0]);
}
?>

Viz také

socket_create()
socket_create_listen()
socket_bind()
socket_listen()
socket_last_error()
socket_strerror()

Předcházející | Nahoru | Další
socket_create_listen | Domů | socket_create


socket_create

(PHP 4 >= 4.0.7, PHP 5)

socket_create — Create a socket (endpoint for communication)

Popis

resource socket_create ( int $domain, int $type, int $protocol )

Creates and returns a socket resource, also referred to as an endpoint of communication. A typical network connection is made up of 2 sockets, one performing the role of the client, and another performing the role of the server.

Seznam parametrů

domain

The domain parameter specifies the protocol family to be used by the socket.

Tabulka 282. Available address/protocol families

Domain | Description
AF_INET | IPv4 Internet based protocols. TCP and UDP are common protocols of this protocol family.
AF_INET6 | IPv6 Internet based protocols. TCP and UDP are common protocols of this protocol family. Support added in PHP 5.0.0.
AF_UNIX | Local communication protocol family. High efficiency and low overhead make it a great form of IPC (Interprocess Communication).

type

The type parameter selects the type of communication to be used by the socket.

Tabulka 283. Available socket types

Type | Description
SOCK_STREAM | Provides sequenced, reliable, full-duplex, connection-based byte streams. An out-of-band data transmission mechanism may be supported. The TCP protocol is based on this socket type.
SOCK_DGRAM | Supports datagrams (connectionless, unreliable messages of a fixed maximum length). The UDP protocol is based on this socket type.
SOCK_SEQPACKET | Provides a sequenced, reliable, two-way connection-based data transmission path for datagrams of fixed maximum length; a consumer is required to read an entire packet with each read call.
SOCK_RAW | Provides raw network protocol access. This special type of socket can be used to manually construct any type of protocol. A common use for this socket type is to perform ICMP requests (like ping, traceroute, etc).
SOCK_RDM | Provides a reliable datagram layer that does not guarantee ordering. This is most likely not implemented on your operating system.

protocol

The protocol parameter sets the specific protocol within the specified domain to be used when communicating on the returned socket. The proper value can be retrieved by name by using getprotobyname(). If the desired protocol is TCP, or UDP the corresponding constants SOL_TCP, and SOL_UDP can also be used.

Tabulka 284. Common protocols

Name | Description
icmp | The Internet Control Message Protocol is used primarily by gateways and hosts to report errors in datagram communication. The "ping" command (present in most modern operating systems) is an example application of ICMP.
udp | The User Datagram Protocol is a connectionless, unreliable, protocol with fixed record lengths. Due to these aspects, UDP requires a minimum amount of protocol overhead.
tcp | The Transmission Control Protocol is a reliable, connection based, stream oriented, full duplex protocol. TCP guarantees that all data packets will be received in the order in which they were sent. If any packet is somehow lost during communication, TCP will automatically retransmit the packet until the destination host acknowledges that packet. For reliability and performance reasons, the TCP implementation itself decides the appropriate octet boundaries of the underlying datagram communication layer. Therefore, TCP applications must allow for the possibility of partial record transmission.

Návratové hodnoty

socket_create() returns a socket resource on success, or FALSE on error. The actual error code can be retrieved by calling socket_last_error(). This error code may be passed to socket_strerror() to get a textual explanation of the error.

Errors/Exceptions

If an invalid domain or type is given, socket_create() defaults to AF_INET and SOCK_STREAM respectively and additionally emits an E_WARNING message.

Viz také

socket_accept()
socket_bind()
socket_connect()
socket_listen()
socket_last_error()
socket_strerror()

Předcházející | Nahoru | Další
socket_create_pair | Domů | socket_get_option


socket_get_option

(PHP 4 >= 4.3.0, PHP 5)

socket_get_option — Gets socket options for the socket

Popis

mixed socket_get_option ( resource $socket, int $level, int $optname )

The socket_get_option() function retrieves the value for the option specified by the optname parameter for the specified socket.

Seznam parametrů

socket

A valid socket resource created with socket_create() or socket_accept().

level

The level parameter specifies the protocol level at which the option resides. For example, to retrieve options at the socket level, a level parameter of SOL_SOCKET would be used. Other levels, such as TCP, can be used by specifying the protocol number of that level. Protocol numbers can be found by using the getprotobyname() function.

optname

Tabulka 285. Available Socket Options

Option | Description | Type
SO_DEBUG | Reports whether debugging information is being recorded. | int
SO_BROADCAST | Reports whether transmission of broadcast messages is supported. | int
SO_REUSEADDR | Reports whether local addresses can be reused. | int
SO_KEEPALIVE | Reports whether connections are kept active with periodic transmission of messages. If the connected socket fails to respond to these messages, the connection is broken and processes writing to that socket are notified with a SIGPIPE signal. | int
SO_LINGER

Reports whether the socket lingers on socket_close() if data is present. By default, when the socket is closed, it attempts to send all unsent data. In the case of a connection-oriented socket, socket_close() will wait for its peer to acknowledge the data.

If l_onoff is non-zero and l_linger is zero, all the unsent data will be discarded and RST (reset) is sent to the peer in the case of a connection-oriented socket.

On the other hand, if l_onoff is non-zero and l_linger is non-zero, socket_close() will block until all the data is sent or the time specified in l_linger elapses. If the socket is non-blocking, socket_close() will fail and return an error.

array. The array will contain two keys: l_onoff and l_linger.
SO_OOBINLINE | Reports whether the socket leaves out-of-band data inline. | int
SO_SNDBUF | Reports the size of the send buffer. | int
SO_RCVBUF | Reports the size of the receive buffer. | int
SO_ERROR | Reports information about error status and clears it. | int (cannot be set by socket_set_option())
SO_TYPE | Reports the socket type (e.g. SOCK_STREAM). | int (cannot be set by socket_set_option())
SO_DONTROUTE | Reports whether outgoing messages bypass the standard routing facilities. | int
SO_RCVLOWAT | Reports the minimum number of bytes to process for socket input operations. | int
SO_RCVTIMEO | Reports the timeout value for input operations. | array. The array will contain two keys: sec which is the seconds part on the timeout value and usec which is the microsecond part of the timeout value.
SO_SNDTIMEO | Reports the timeout value specifying the amount of time that an output function blocks because flow control prevents data from being sent. | array. The array will contain two keys: sec which is the seconds part on the timeout value and usec which is the microsecond part of the timeout value.
SO_SNDLOWAT | Reports the minimum number of bytes to process for socket output operations. | int

Návratové hodnoty

Returns the value of the given option, or FALSE on errors.

Příklady

Příklad 2081. socket_set_option() example

<?php
$socket = socket_create_listen(1223);

$linger = array('l_linger' => 1, 'l_onoff' => 1);
socket_set_option($socket, SOL_SOCKET, SO_LINGER, $linger);

var_dump(socket_get_option($socket, SOL_SOCKET, SO_REUSEADDR));
?>

ChangeLog (záznam změn)

Verze | Popis
4.3.0 | The name of this function was changed. It used to be called socket_getopt().

Předcházející | Nahoru | Další
socket_create | Domů | socket_getpeername


socket_getpeername

(PHP 4 >= 4.0.7, PHP 5)

socket_getpeername — Queries the remote side of the given socket which may either result in host/port or in a Unix filesystem path, dependent on its type

Popis

bool socket_getpeername ( resource $socket, string &$address [, int &$port] )

Queries the remote side of the given socket which may either result in host/port or in a Unix filesystem path, dependent on its type.

Seznam parametrů

socket

A valid socket resource created with socket_create() or socket_accept().

address

If the given socket is of type AF_INET or AF_INET6, socket_getpeername() will return the peers (remote) IP address in appropriate notation (e.g. 127.0.0.1 or fe80::1) in the address parameter and, if the optional port parameter is present, also the associated port.

If the given socket is of type AF_UNIX, socket_getpeername() will return the Unix filesystem path (e.g. /var/run/daemon.sock) in the address parameter.

port

If given, this will hold the port associated to address.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání. socket_getpeername() may also return FALSE if the socket type is not any of AF_INET, AF_INET6, or AF_UNIX, in which case the last socket error code is not updated.

Poznámky

Poznámka: socket_getpeername() should not be used with AF_UNIX sockets created with socket_accept(). Only sockets created with socket_connect() or a primary server socket following a call to socket_bind() will return meaningful values.

Viz také

socket_getsockname()
socket_last_error()
socket_strerror()

Předcházející | Nahoru | Další
socket_get_option | Domů | socket_getsockname


socket_getsockname

(PHP 4 >= 4.0.7, PHP 5)

socket_getsockname — Queries the local side of the given socket which may either result in host/port or in a Unix filesystem path, dependent on its type

Popis

bool socket_getsockname ( resource $socket, string &$addr [, int &$port] )

Poznámka: socket_getsockname() should not be used with AF_UNIX sockets created with socket_connect(). Only sockets created with socket_accept() or a primary server socket following a call to socket_bind() will return meaningful values.

Seznam parametrů

socket

A valid socket resource created with socket_create() or socket_accept().

addr

If the given socket is of type AF_INET or AF_INET6, socket_getsockname() will return the local IP address in appropriate notation (e.g. 127.0.0.1 or fe80::1) in the address parameter and, if the optional port parameter is present, also the associated port.

If the given socket is of type AF_UNIX, socket_getsockname() will return the Unix filesystem path (e.g. /var/run/daemon.sock) in the address parameter.

port

If provided, this will hold the associated port.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání. socket_getsockname() may also return FALSE if the socket type is not any of AF_INET, AF_INET6, or AF_UNIX, in which case the last socket error code is not updated.

Viz také

socket_getpeername()
socket_last_error()
socket_strerror()

Předcházející | Nahoru | Další
socket_getpeername | Domů | socket_last_error


socket_last_error

(PHP 4 >= 4.0.7, PHP 5)

socket_last_error — Returns the last error on the socket

Popis

int socket_last_error ( [resource $socket] )

If a socket resource is passed to this function, the last error which occurred on this particular socket is returned. If the socket resource is omitted, the error code of the last failed socket function is returned. The latter is particularly helpful for functions like socket_create() which don't return a socket on failure and socket_select() which can fail for reasons not directly tied to a particular socket. The error code is suitable to be fed to socket_strerror() which returns a string describing the given error code.

Seznam parametrů

socket

A valid socket resource created with socket_create().

Návratové hodnoty

This function returns a socket error code.

Příklady

Příklad 2082. socket_last_error() example

<?php
$socket = @socket_create(AF_INET, SOCK_STREAM, SOL_TCP);

if ($socket === false) {
    $errorcode = socket_last_error();
    $errormsg = socket_strerror($errorcode);

    die("Couldn't create socket: [$errorcode] $errormsg");
}
?>

Poznámky

Poznámka: socket_last_error() does not clear the error code, use socket_clear_error() for this purpose.

Předcházející | Nahoru | Další
socket_getsockname | Domů | socket_listen


socket_listen

(PHP 4 >= 4.0.7, PHP 5)

socket_listen — Listens for a connection on a socket

Popis

bool socket_listen ( resource $socket [, int $backlog] )

After the socket socket has been created using socket_create() and bound to a name with socket_bind(), it may be told to listen for incoming connections on socket.

socket_listen() is applicable only to sockets of type SOCK_STREAM or SOCK_SEQPACKET.

Seznam parametrů

socket

A valid socket resource created with socket_create().

backlog

A maximum of backlog incoming connections will be queued for processing. If a connection request arrives with the queue full the client may receive an error with an indication of ECONNREFUSED, or, if the underlying protocol supports retransmission, the request may be ignored so that retries may succeed.

Poznámka: The maximum number passed to the backlog parameter highly depends on the underlying platform. On Linux, it is silently truncated to SOMAXCONN. On win32, if passed SOMAXCONN, the underlying service provider responsible for the socket will set the backlog to a maximum reasonable value. There is no standard provision to find out the actual backlog value on this platform.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání. The error code can be retrieved with socket_last_error(). This code may be passed to socket_strerror() to get a textual explanation of the error.

Viz také

socket_accept()
socket_bind()
socket_connect()
socket_create()
socket_strerror()

Předcházející | Nahoru | Další
socket_last_error | Domů | socket_read


socket_read

(PHP 4 >= 4.0.7, PHP 5)

socket_read — Reads a maximum of length bytes from a socket

Popis

string socket_read ( resource $socket, int $length [, int $type] )

The function socket_read() reads from the socket resource socket created by the socket_create() or socket_accept() functions.

Seznam parametrů

socket

A valid socket resource created with socket_create() or socket_accept().

length

The maximum number of bytes read is specified by the length parameter. Otherwise you can use \r, \n, or \0 to end reading (depending on the type parameter, see below).

type

Optional type parameter is a named constant:

  • PHP_BINARY_READ (Default) - use the system recv() function. Safe for reading binary data.
  • PHP_NORMAL_READ - reading stops at \n or \r.

Návratové hodnoty

socket_read() returns the data as a string on success, or FALSE on error (including if the remote host has closed the connection). The error code can be retrieved with socket_last_error(). This code may be passed to socket_strerror() to get a textual representation of the error.

Poznámka: socket_read() returns a zero length string ("") when there is no more data to read.

ChangeLog (záznam změn)

Verze | Popis
4.1.0 | The default value for type was changed from PHP_NORMAL_READ to PHP_BINARY_READ

Viz také

socket_accept()
socket_bind()
socket_connect()
socket_listen()
socket_last_error()
socket_strerror()
socket_write()

Předcházející | Nahoru | Další
socket_listen | Domů | socket_recv


socket_recv

(PHP 4 >= 4.0.7, PHP 5)

socket_recv — Receives data from a connected socket

Popis

int socket_recv ( resource $socket, string &$buf, int $len, int $flags )

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
socket_read | Domů | socket_recvfrom


socket_recvfrom

(PHP 4 >= 4.0.7, PHP 5)

socket_recvfrom — Receives data from a socket whether or not it is connection-oriented

Popis

int socket_recvfrom ( resource $socket, string &$buf, int $len, int $flags, string &$name [, int &$port] )

The socket_recvfrom() function receives len bytes of data in buf from name on port port (if the socket is not of type AF_UNIX) using socket. socket_recvfrom() can be used to gather data from both connected and unconnected sockets. Additionally, one or more flags can be specified to modify the behaviour of the function.

The name and port must be passed by reference. If the socket is not connection-oriented, name will be set to the internet protocol address of the remote host or the path to the UNIX socket. If the socket is connection-oriented, name is NULL. Additionally, the port will contain the port of the remote host in the case of an unconnected AF_INET or AF_INET6 socket.

Seznam parametrů

socket

The socket must be a socket resource previously created by socket_create().

buf

The data received will be fetched to the variable specified with buf.

len

Up to len bytes will be fetched from remote host.

flags

The value of flags can be any combination of the following flags, joined with the binary OR (|) operator.

Tabulka 286. Possible values for flags

Flag | Description
MSG_OOB | Process out-of-band data.
MSG_PEEK | Receive data from the beginning of the receive queue without removing it from the queue.
MSG_WAITALL | Block until at least len are received. However, if a signal is caught or the remote host disconnects, the function may return less data.
MSG_DONTWAIT | With this flag set, the function returns even if it would normally have blocked.

name

If the socket is of the type AF_UNIX type, name is the path to the file. Else, for unconnected sockets, name is the IP address of, the remote host, or NULL if the socket is connection-oriented.

port

This argument only applies to AF_INET and AF_INET6 sockets, and specifies the remote port from which the data is received. If the socket is connection-oriented, port will be NULL.

Návratové hodnoty

socket_recvfrom() returns the number of bytes received, or -1 if there was an error. The actual error code can be retrieved by calling socket_last_error(). This error code may be passed to socket_strerror() to get a textual explanation of the error.

Příklady

Příklad 2083. socket_recvfrom() example

<?php
error_reporting(E_ALL | E_STRICT);

$socket = socket_create(AF_INET, SOCK_DGRAM, SOL_UDP);
socket_bind($socket, '127.0.0.1', 1223);

$from = "";
$port = 0;
socket_recvfrom($socket, $buf, 12, 0, $from, $port);

echo "Received $buf from remote address $from and remote port $port" . PHP_EOL;
?>

This example will initiate an UDP socket on port 1223 of 127.0.0.1 and print at most 12 characters received from a remote host.

ChangeLog (záznam změn)

Verze | Popis
4.3.0 | socket_recvfrom() is now binary safe.

Viz také

socket_recv()
socket_send()
socket_sendto()
socket_create()

Předcházející | Nahoru | Další
socket_recv | Domů | socket_select


socket_select

(PHP 4 >= 4.0.7, PHP 5)

socket_select — Runs the select() system call on the given arrays of sockets with a specified timeout

Popis

int socket_select ( array &$read, array &$write, array &$except, int $tv_sec [, int $tv_usec] )

socket_select() accepts arrays of sockets and waits for them to change status. Those coming with BSD sockets background will recognize that those socket resource arrays are in fact the so-called file descriptor sets. Three independent arrays of socket resources are watched.

Seznam parametrů

read

The sockets listed in the read array will be watched to see if characters become available for reading (more precisely, to see if a read will not block - in particular, a socket resource is also ready on end-of-file, in which case a socket_read() will return a zero length string).

write

The sockets listed in the write array will be watched to see if a write will not block.

except

The sockets listed in the except array will be watched for exceptions.

tv_sec

The tv_sec and tv_usec together form the timeout parameter. The timeout is an upper bound on the amount of time elapsed before socket_select() return. tv_sec may be zero , causing socket_select() to return immediately. This is useful for polling. If tv_sec is NULL (no timeout), socket_select() can block indefinitely.

tv_usec

Varování

On exit, the arrays are modified to indicate which socket resource actually changed status.

You do not need to pass every array to socket_select(). You can leave it out and use an empty array or NULL instead. Also do not forget that those arrays are passed by reference and will be modified after socket_select() returns.

Poznámka: Due a limitation in the current Zend Engine it is not possible to pass a constant modifier like NULL directly as a parameter to a function which expects this parameter to be passed by reference. Instead use a temporary variable or an expression with the leftmost member being a temporary variable:

Příklad 2084. Using NULL with socket_select()

<?php
$e = NULL;
socket_select($r, $w, $e, 0);
?>

Návratové hodnoty

On success socket_select() returns the number of socket resources contained in the modified arrays, which may be zero if the timeout expires before anything interesting happens. On error FALSE is returned. The error code can be retrieved with socket_last_error().

Poznámka: Be sure to use the === operator when checking for an error. Since the socket_select() may return 0 the comparison with == would evaluate to TRUE:

Příklad 2085. Understanding socket_select()'s result

<?php
$e = NULL;
if (false === socket_select($r, $w, $e, 0)) {
    echo "socket_select() failed, reason: " .
        socket_strerror(socket_last_error()) . "\n";
}
?>

Příklady

Příklad 2086. socket_select() example

<?php
/* Prepare the read array */
$read   = array($socket1, $socket2);
$write  = NULL;
$except = NULL;
$num_changed_sockets = socket_select($read, $write, $except, 0);

if ($num_changed_sockets === false) {
    /* Error handling */
} else if ($num_changed_sockets > 0) {
    /* At least at one of the sockets something interesting happened */
}
?>

Poznámky

Poznámka: Be aware that some socket implementations need to be handled very carefully. A few basic rules:

  • You should always try to use socket_select() without timeout. Your program should have nothing to do if there is no data available. Code that depends on timeouts is not usually portable and difficult to debug.
  • No socket resource must be added to any set if you do not intend to check its result after the socket_select() call, and respond appropriately. After socket_select() returns, all socket resources in all arrays must be checked. Any socket resource that is available for writing must be written to, and any socket resource available for reading must be read from.
  • If you read/write to a socket returns in the arrays be aware that they do not necessarily read/write the full amount of data you have requested. Be prepared to even only be able to read/write a single byte.
  • It's common to most socket implementations that the only exception caught with the except array is out-of-bound data received on a socket.

Viz také

socket_read()
socket_write()
socket_last_error()
socket_strerror()

Předcházející | Nahoru | Další
socket_recvfrom | Domů | socket_send


socket_send

(PHP 4 >= 4.0.7, PHP 5)

socket_send — Sends data to a connected socket

Popis

int socket_send ( resource $socket, string $buf, int $len, int $flags )

The function socket_send() sends len bytes to the socket socket from buf.

Seznam parametrů

socket

A valid socket resource created with socket_create() or socket_accept().

buf

A buffer containing the data that will be sent to the remote host.

len

The number of bytes that will be sent to the remote host from buf.

flags

The value of flags can be any combination of the following flags, joined with the binary OR (|) operator.

Tabulka 287. Possible values for flags

MSG_OOB | Send OOB (out-of-band) data.
MSG_EOR | Indicate a record mark. The sent data completes the record.
MSG_EOF | Close the sender side of the socket and include an appropriate notification of this at the end of the sent data. The sent data completes the transaction.
MSG_DONTROUTE | Bypass routing, use direct interface.

Návratové hodnoty

Viz také

socket_sendto()

Předcházející | Nahoru | Další
socket_select | Domů | socket_sendto


socket_sendto

(PHP 4 >= 4.0.7, PHP 5)

socket_sendto — Sends a message to a socket, whether it is connected or not

Popis

int socket_sendto ( resource $socket, string $buf, int $len, int $flags, string $addr [, int $port] )

The function socket_sendto() sends len bytes from buf through the socket socket to the port at the address addr.

Seznam parametrů

socket

A valid socket ressource created using socket_create().

buf

The sent data will be taken from buffer buf.

len

len bytes from buf will be sent.

flags

The value of flags can be any combination of the following flags, joined with the binary OR (|) operator.

Tabulka 288. Possible values for flags

MSG_OOB | Send OOB (out-of-band) data.
MSG_EOR | Indicate a record mark. The sent data completes the record.
MSG_EOF | Close the sender side of the socket and include an appropriate notification of this at the end of the sent data. The sent data completes the transaction.
MSG_DONTROUTE | Bypass routing, use direct interface.

addr

IP address of the remote host.

port

port is the remote port number at which the data will be sent.

Návratové hodnoty

socket_sendto() returns the number of bytes sent to the remote host or -1 if an error occured.

Příklady

Příklad 2087. socket_sendto() Example

<?php
    $sock = socket_create(AF_INET, SOCK_DGRAM, SOL_UDP);

    $msg = "Ping !";
    $len = strlen($msg);

    socket_sendto($sock, $msg, $len, 0, '127.0.0.1', 1223);
    socket_close($sock);
?>

Viz také

socket_send()

Předcházející | Nahoru | Další
socket_send | Domů | socket_set_block


socket_set_block

(PHP 4 >= 4.2.0, PHP 5)

socket_set_block — Sets blocking mode on a socket resource

Popis

bool socket_set_block ( resource $socket )

The socket_set_block() function removes the O_NONBLOCK flag on the socket specified by the socket parameter.

When an operation (e.g. receive, send, connect, accept, ...) is performed on a blocking socket, the script will pause its execution until it receives a signal or it can perform the operation.

Seznam parametrů

socket

A valid socket resource created with socket_create() or socket_accept().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 2088. socket_set_block() example

<?php
$socket = socket_create_listen(1223);
socket_set_block($socket);

socket_accept($socket);
?>

This example creates a listening socket on all interfaces on port 1223 and sets the socket to O_BLOCK mode. socket_accept() will hang until there is a connection to accept.

Viz také

socket_set_nonblock()
socket_set_option()

Předcházející | Nahoru | Další
socket_sendto | Domů | socket_set_nonblock


socket_set_nonblock

(PHP 4 >= 4.0.7, PHP 5)

socket_set_nonblock — Sets nonblocking mode for file descriptor fd

Popis

bool socket_set_nonblock ( resource $socket )

The socket_set_nonblock() function sets the O_NONBLOCK flag on the socket specified by the socket parameter.

When an operation (e.g. receive, send, connect, accept, ...) is performed on a non-blocking socket, the script not pause its execution until it receives a signal or it can perform the operation. Rather, if the operation would result in a block, the called function will fail.

Seznam parametrů

socket

A valid socket resource created with socket_create() or socket_accept().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 2089. socket_set_nonblock() example

<?php
$socket = socket_create_listen(1223);
socket_set_nonblock($socket);

socket_accept($socket);
?>

This example creates a listening socket on all interfaces on port 1223 and sets the socket to O_NONBLOCK mode. socket_accept() will immediately fail unless there is a pending connection exactly at this moment.

Viz také

socket_set_block()
socket_set_option()

Předcházející | Nahoru | Další
socket_set_block | Domů | socket_set_option


socket_set_option

(PHP 4 >= 4.3.0, PHP 5)

socket_set_option — Sets socket options for the socket

Popis

bool socket_set_option ( resource $socket, int $level, int $optname, mixed $optval )

The socket_set_option() function sets the option specified by the optname parameter, at the specified protocol level, to the value pointed to by the optval parameter for the socket.

Seznam parametrů

socket

A valid socket resource created with socket_create() or socket_accept().

level

The level parameter specifies the protocol level at which the option resides. For example, to retrieve options at the socket level, a level parameter of SOL_SOCKET would be used. Other levels, such as TCP, can be used by specifying the protocol number of that level. Protocol numbers can be found by using the getprotobyname() function.

optname

The available socket options are the same as those for the socket_get_option() function.

optval

The option value.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 2090. socket_set_option() example

<?php
$socket = socket_create(AF_INET, SOCK_STREAM, SOL_TCP);

if (!is_resource($socket)) {
    echo 'Unable to create socket: '. socket_strerror(socket_last_error()) . PHP_EOL;
}

if (!socket_set_option($socket, SOL_SOCKET, SO_REUSEADDR, 1)) {
    echo 'Unable to set option on socket: '. socket_strerror(socket_last_error()) . PHP_EOL;
}

if (!socket_bind($socket, '127.0.0.1', 1223)) {
    echo 'Unable to bind socket: '. socket_strerror(socket_last_error()) . PHP_EOL;
}

$rval = socket_get_option($socket, SOL_SOCKET, SO_REUSEADDR);

if ($rval === false) {
    echo 'Unable to get socket option: '. socket_strerror(socket_last_error()) . PHP_EOL;
} else if ($rval !== 0) {
    echo 'SO_REUSEADDR is set on socket !' . PHP_EOL;
}
?>

ChangeLog (záznam změn)

Verze | Popis
4.3.0 | This function was renamed. It used to be called socket_setopt().

Předcházející | Nahoru | Další
socket_set_nonblock | Domů | socket_shutdown


socket_shutdown

(PHP 4 >= 4.0.7, PHP 5)

socket_shutdown — Shuts down a socket for receiving, sending, or both

Popis

bool socket_shutdown ( resource $socket [, int $how] )

The socket_shutdown() function allows you to stop incoming, outgoing or all data (the default) from being sent through the socket

Seznam parametrů

socket

A valid socket resource created with socket_create().

how

The value of how can be one of the following:

Tabulka 289. possible values for how

0 | Shutdown socket reading
1 | Shutdown socket writing
2 | Shutdown socket reading and writing

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
socket_set_option | Domů | socket_strerror


socket_strerror

(PHP 4 >= 4.0.7, PHP 5)

socket_strerror — Return a string describing a socket error

Popis

string socket_strerror ( int $errno )

socket_strerror() takes as its errno parameter a socket error code as returned by socket_last_error() and returns the corresponding explanatory text.

Poznámka: Although the error messages generated by the socket extension are in English, the system messages retrieved with this function will appear depending on the current locale (LC_MESSAGES).

Seznam parametrů

errno

A valid socket error number, likely produced by socket_last_error().

Návratové hodnoty

Returns the error message associated with the errno parameter.

Příklady

Příklad 2091. socket_strerror() example

<?php
if (false == ($socket = @socket_create(AF_INET, SOCK_STREAM, SOL_TCP))) {
   echo "socket_create() failed: reason: " . socket_strerror(socket_last_error()) . "\n";
}

if (false == (@socket_bind($socket, '127.0.0.1', 80))) {
   echo "socket_bind() failed: reason: " . socket_strerror(socket_last_error($socket)) . "\n";
}
?>

The expected output from the above example (assuming the script is not run with root privileges):

socket_bind() failed: reason: Permission denied

Viz také

socket_accept()
socket_bind()
socket_connect()
socket_listen()
socket_create()

Předcházející | Nahoru | Další
socket_shutdown | Domů | socket_write


socket_write

(PHP 4 >= 4.0.7, PHP 5)

socket_write — Write to a socket

Popis

int socket_write ( resource $socket, string $buffer [, int $length] )

The function socket_write() writes to the socket from the given buffer.

Seznam parametrů

socket

buffer

The buffer to be written.

length

The optional parameter length can specify an alternate length of bytes written to the socket. If this length is greater then the buffer length, it is silently truncated to the length of the buffer.

Návratové hodnoty

Returns the number of bytes successfully written to the socket or FALSE one error. The error code can be retrieved with socket_last_error(). This code may be passed to socket_strerror() to get a textual explanation of the error.

Poznámka: It is perfectly valid for socket_write() to return zero which means no bytes have been written. Be sure to use the === operator to check for FALSE in case of an error.

Poznámky

Poznámka: socket_write() does not necessarily write all bytes from the given buffer. It's valid that, depending on the network buffers etc., only a certain amount of data, even one byte, is written though your buffer is greater. You have to watch out so you don't unintentionally forget to transmit the rest of your data.

Viz také

socket_accept()
socket_bind()
socket_connect()
socket_listen()
socket_read()
socket_strerror()

Předcházející | Nahoru | Další
socket_strerror | Domů | CLV. Standard PHP Library (SPL) Functions


Standard PHP Library (SPL) Functions

Předcházející VI. Reference funkcí Další

CLV. Standard PHP Library (SPL) Functions

Úvod

SPL is a collection of interfaces and classes that are meant to solve standard problems.

Tip

A more detailed documentation of SPL can be found » here.

Instalace

This extension is available and compiled by default in PHP 5.

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

Varování

SPL uses class constants since PHP 5.1. Prior releases use global constants in the form RIT_LEAVES_ONLY.

RecursiveIteratorIterator::LEAVES_ONLY (integer)
RecursiveIteratorIterator::SELF_FIRST (integer)
RecursiveIteratorIterator::CHILD_FIRST (integer)
CachingIterator::CALL_TOSTRING (integer)
CachingIterator::CATCH_GET_CHILD (integer)

Obsah

ArrayIterator::current — Return current array entry
ArrayIterator::key — Return current array key
ArrayIterator::next — Move to next entry
ArrayIterator::rewind — Rewind array back to the start
ArrayIterator::seek — Seek to position
ArrayIterator::valid — Check whether array contains more entries
ArrayObject::append — Appends the value
ArrayObject::__construct — Construct a new array object
ArrayObject::count — Return the number of elements in the Iterator
ArrayObject::getIterator — Create a new iterator from an ArrayObject instance
ArrayObject::offsetExists — Returns whether the requested $index exists
ArrayObject::offsetGet — Returns the value at the specified $index
ArrayObject::offsetSet — Sets the value at the specified $index to $newval
ArrayObject::offsetUnset — Unsets the value at the specified $index
CachingIterator::hasNext — Check whether the inner iterator has a valid next element
CachingIterator::next — Move the iterator forward
CachingIterator::rewind — Rewind the iterator
CachingIterator::__toString — Return the string representation of the current element
CachingIterator::valid — Check whether the current element is valid
CachingRecursiveIterator::getChildren — Return the inner iterator's children as a CachingRecursiveIterator
CachingRecursiveIterator::hasChildren — Check whether the current element of the inner iterator has children
DirectoryIterator::__construct — Constructs a new dir iterator from a path
DirectoryIterator::current — Return this (needed for Iterator interface)
DirectoryIterator::getATime — Get last access time of file
DirectoryIterator::getCTime — Get inode modification time of file
DirectoryIterator::getFilename — Return filename of current dir entry
DirectoryIterator::getGroup — Get file group
DirectoryIterator::getInode — Get file inode
DirectoryIterator::getMTime — Get last modification time of file
DirectoryIterator::getOwner — Get file owner
DirectoryIterator::getPath — Return directory path
DirectoryIterator::getPathname — Return path and filename of current dir entry
DirectoryIterator::getPerms — Get file permissions
DirectoryIterator::getSize — Get file size
DirectoryIterator::getType — Get file type
DirectoryIterator::isDir — Returns true if file is directory
DirectoryIterator::isDot — Returns true if current entry is '.' or '..'
DirectoryIterator::isExecutable — Returns true if file is executable
DirectoryIterator::isFile — Returns true if file is a regular file
DirectoryIterator::isLink — Returns true if file is symbolic link
DirectoryIterator::isReadable — Returns true if file can be read
DirectoryIterator::isWritable — Returns true if file can be written
DirectoryIterator::key — Return current dir entry
DirectoryIterator::next — Move to next entry
DirectoryIterator::rewind — Rewind dir back to the start
DirectoryIterator::valid — Check whether dir contains more entries
FilterIterator::current — Get the current element value
FilterIterator::getInnerIterator — Get the inner iterator
FilterIterator::key — Get the current key
FilterIterator::next — Move the iterator forward
FilterIterator::rewind — Rewind the iterator
FilterIterator::valid — Check whether the current element is valid
LimitIterator::getPosition — Return the current position
LimitIterator::next — Move the iterator forward
LimitIterator::rewind — Rewind the iterator to the specified starting offset
LimitIterator::seek — Seek to the given position
LimitIterator::valid — Check whether the current element is valid
ParentIterator::getChildren — Return the inner iterator's children contained in a ParentIterator
ParentIterator::hasChildren — Check whether the inner iterator's current element has children
ParentIterator::next — Move the iterator forward
ParentIterator::rewind — Rewind the iterator
RecursiveDirectoryIterator::getChildren — Returns an iterator for the current entry if it is a directory
RecursiveDirectoryIterator::hasChildren — Returns whether current entry is a directory and not '.' or '..'
RecursiveDirectoryIterator::key — Return path and filename of current dir entry
RecursiveDirectoryIterator::next — Move to next entry
RecursiveDirectoryIterator::rewind — Rewind dir back to the start
RecursiveIteratorIterator::current — Access the current element value
RecursiveIteratorIterator::getDepth — Get the current depth of the recursive iteration
RecursiveIteratorIterator::getSubIterator — The current active sub iterator
RecursiveIteratorIterator::key — Access the current key
RecursiveIteratorIterator::next — Move forward to the next element
RecursiveIteratorIterator::rewind — Rewind the iterator to the first element of the top level inner iterator
RecursiveIteratorIterator::valid — Check whether the current position is valid
SimpleXMLIterator::current — Return current SimpleXML entry
SimpleXMLIterator::getChildren — Returns an iterator for the current entry if it is a SimpleXML object
SimpleXMLIterator::hasChildren — Returns whether current entry is a SimpleXML object
SimpleXMLIterator::key — Return current SimpleXML key
SimpleXMLIterator::next — Move to next entry
SimpleXMLIterator::rewind — Rewind SimpleXML back to the start
SimpleXMLIterator::valid — Check whether SimpleXML contains more entries
class_implements — Return the interfaces which are implemented by the given class
class_parents — Return the parent classes of the given class
iterator_count — Count the elements in an iterator
iterator_to_array — Copy the iterator into an array
spl_autoload_call — Try all registered __autoload() function to load the requested class
spl_autoload_extensions — Register and return default file extensions for spl_autoload
spl_autoload_functions — Return all registered __autoload() functions
spl_autoload_register — Register given function as __autoload() implementation
spl_autoload_unregister — Unregister given function as __autoload() implementation
spl_autoload — Default implementation for __autoload()
spl_classes — Return available SPL classes
spl_object_hash — Return hash id for given object
Předcházející | Nahoru | Další
socket_write | Domů | ArrayIterator::current


ArrayIterator::current

(PHP 5)

ArrayIterator::current — Return current array entry

Description

mixed ArrayIterator::current ( void )

This function returns the current array entry

Příklad 2092. ArrayIterator::current() example

<?php
$array = array('1' => 'one',
               '2' => 'two',
               '3' => 'three');

$arrayobject = new ArrayObject($array);

for($iterator = $arrayobject->getIterator();
    $iterator->valid();
    $iterator->next()) {

    echo $iterator->key() . ' => ' . $iterator->current() . "\n";
}
?>

Výše uvedený příklad vypíše:

1 => one
2 => two
3 => three

Předcházející | Nahoru | Další
CLV. Standard PHP Library (SPL) Functions | Domů | ArrayIterator::key


ArrayIterator::key

(PHP 5)

ArrayIterator::key — Return current array key

Description

mixed ArrayIterator::key ( void )

This function returns the current array key

Příklad 2093. ArrayIterator::key() example

<?php
$array = array('key' => 'value');

$arrayobject = new ArrayObject($array);
$iterator = $arrayobject->getIterator();

echo $iterator->key(); //key
?>

Předcházející | Nahoru | Další
ArrayIterator::current | Domů | ArrayIterator::next


ArrayIterator::next

(PHP 5)

ArrayIterator::next — Move to next entry

Description

void ArrayIterator::next ( void )

This function moves the iterator to the next entry.

Příklad 2094. ArrayIterator::next() example

<?php
$arrayobject = new ArrayObject();

$arrayobject[] = 'zero';
$arrayobject[] = 'one';

$iterator = $arrayobject->getIterator();

while($iterator->valid()) {
    echo $iterator->key() . ' => ' . $iterator->current() . "\n";

    $iterator->next();
}
?>

Výše uvedený příklad vypíše:

0 => zero
1 => one

Předcházející | Nahoru | Další
ArrayIterator::key | Domů | ArrayIterator::rewind


ArrayIterator::rewind

(PHP 5)

ArrayIterator::rewind — Rewind array back to the start

Description

void ArrayIterator::rewind ( void )

This function rewinds the iterator to the beginning.

Příklad 2095. ArrayIterator::rewind() example

<?php
$arrayobject = new ArrayObject();

$arrayobject[] = 'zero';
$arrayobject[] = 'one';
$arrayobject[] = 'two';

$iterator = $arrayobject->getIterator();

$iterator->next();
echo $iterator->key(); //1

$iterator->rewind(); //rewinding to the begining
echo $iterator->key(); //0
?>

Předcházející | Nahoru | Další
ArrayIterator::next | Domů | ArrayIterator::seek


ArrayIterator::seek

(PHP 5)

ArrayIterator::seek — Seek to position

Description

void ArrayIterator::seek ( int $position )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
ArrayIterator::rewind | Domů | ArrayIterator::valid


ArrayIterator::valid

(PHP 5)

ArrayIterator::valid — Check whether array contains more entries

Description

bool ArrayIterator::valid ( void )

This function checks if the array contains any more entries.

Příklad 2096. ArrayIterator::valid() example

<?php
$array = array('1' => 'one');

$arrayobject = new ArrayObject($array);
$iterator = $arrayobject->getIterator();

var_dump($iterator->valid()); //bool(true)

$iterator->next(); // advance to the next item

//bool(false) because there is only one array element
var_dump($iterator->valid());
?>

Předcházející | Nahoru | Další
ArrayIterator::seek | Domů | ArrayObject::append


ArrayObject::append

(PHP 5)

ArrayObject::append — Appends the value

Description

void ArrayObject::append ( mixed $newval )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
ArrayIterator::valid | Domů | ArrayObject::__construct


ArrayObject::__construct

(PHP 5)

ArrayObject::__construct — Construct a new array object

Description

ArrayObject ArrayObject::__construct ( mixed $input )

This constructs a new array object. The input parameter accepts an array or another ArrayObject.

Příklad 2097. ArrayObject::__construct() example

<?php
$array = array('1' => 'one',
               '2' => 'two',
               '3' => 'three');

$arrayobject = new ArrayObject($array);

var_dump($arrayobject);
?>

Výše uvedený příklad vypíše:

object(ArrayObject)#1 (3) {
  [1]=>
  string(3) "one"
  [2]=>
  string(3) "two"
  [3]=>
  string(5) "three"
}

Předcházející | Nahoru | Další
ArrayObject::append | Domů | ArrayObject::count


ArrayObject::count

(PHP 5)

ArrayObject::count — Return the number of elements in the Iterator

Description

int ArrayObject::count ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
ArrayObject::__construct | Domů | ArrayObject::getIterator


ArrayObject::getIterator

(PHP 5)

ArrayObject::getIterator — Create a new iterator from an ArrayObject instance

Description

ArrayIterator ArrayObject::getIterator ( void )

This function will return an iterator from an ArrayObject.

Příklad 2098. ArrayObject::getIterator() example

<?php
$array = array('1' => 'one',
               '2' => 'two',
               '3' => 'three');

$arrayobject = new ArrayObject($array);

$iterator = $arrayobject->getIterator();

while($iterator->valid()) {
    echo $iterator->key() . ' => ' . $iterator->current() . "\n";

    $iterator->next();
}
?>

The above example will output:

1 => one
2 => two
3 => three

Předcházející | Nahoru | Další
ArrayObject::count | Domů | ArrayObject::offsetExists


ArrayObject::offsetExists

(PHP 5)

ArrayObject::offsetExists — Returns whether the requested $index exists

Description

bool ArrayObject::offsetExists ( mixed $index )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
ArrayObject::getIterator | Domů | ArrayObject::offsetGet


ArrayObject::offsetGet

(PHP 5)

ArrayObject::offsetGet — Returns the value at the specified $index

Description

mixed ArrayObject::offsetGet ( mixed $index )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
ArrayObject::offsetExists | Domů | ArrayObject::offsetSet


ArrayObject::offsetSet

(PHP 5)

ArrayObject::offsetSet — Sets the value at the specified $index to $newval

Description

void ArrayObject::offsetSet ( mixed $index, mixed $newval )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
ArrayObject::offsetGet | Domů | ArrayObject::offsetUnset


ArrayObject::offsetUnset

(PHP 5)

ArrayObject::offsetUnset — Unsets the value at the specified $index

Description

void ArrayObject::offsetUnset ( mixed $index )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
ArrayObject::offsetSet | Domů | CachingIterator::hasNext


CachingIterator::hasNext

(PHP 5)

CachingIterator::hasNext — Check whether the inner iterator has a valid next element

Description

bool CachingIterator::hasNext ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
ArrayObject::offsetUnset | Domů | CachingIterator::next


CachingIterator::next

(PHP 5)

CachingIterator::next — Move the iterator forward

Description

void CachingIterator::next ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
CachingIterator::hasNext | Domů | CachingIterator::rewind


CachingIterator::rewind

(PHP 5)

CachingIterator::rewind — Rewind the iterator

Description

void CachingIterator::rewind ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
CachingIterator::next | Domů | CachingIterator::__toString


CachingIterator::__toString

(PHP 5)

CachingIterator::__toString — Return the string representation of the current element

Description

string CachingIterator::__toString ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
CachingIterator::rewind | Domů | CachingIterator::valid


CachingIterator::valid

(PHP 5)

CachingIterator::valid — Check whether the current element is valid

Description

bool CachingIterator::valid ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
CachingIterator::__toString | Domů | CachingRecursiveIterator::getChildren


CachingRecursiveIterator::getChildren

(PHP 5 <= 5.0.5)

CachingRecursiveIterator::getChildren — Return the inner iterator's children as a CachingRecursiveIterator

Description

CachingRecursiveIterator CachingRecursiveIterator::getChildren ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
CachingIterator::valid | Domů | CachingRecursiveIterator::hasChildren


CachingRecursiveIterator::hasChildren

(PHP 5 <= 5.0.5)

CachingRecursiveIterator::hasChildren — Check whether the current element of the inner iterator has children

Description

bolean CachingRecursiveIterator::hasChildren ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
CachingRecursiveIterator::getChildren | Domů | DirectoryIterator::__construct


DirectoryIterator::__construct

(PHP 5)

DirectoryIterator::__construct — Constructs a new dir iterator from a path

Description

DirectoryIterator DirectoryIterator::__construct ( string $path )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
CachingRecursiveIterator::hasChildren | Domů | DirectoryIterator::current


DirectoryIterator::current

(PHP 5)

DirectoryIterator::current — Return this (needed for Iterator interface)

Description

DirectoryIterator DirectoryIterator::current ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
DirectoryIterator::__construct | Domů | DirectoryIterator::getATime


DirectoryIterator::getATime

(PHP 5 >= 5.0.2)

DirectoryIterator::getATime — Get last access time of file

Description

int DirectoryIterator::getATime ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
DirectoryIterator::current | Domů | DirectoryIterator::getCTime


DirectoryIterator::getCTime

(PHP 5 >= 5.0.2)

DirectoryIterator::getCTime — Get inode modification time of file

Description

int DirectoryIterator::getCTime ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
DirectoryIterator::getATime | Domů | DirectoryIterator::getFilename


DirectoryIterator::getFilename

(PHP 5)

DirectoryIterator::getFilename — Return filename of current dir entry

Description

string DirectoryIterator::getFilename ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
DirectoryIterator::getCTime | Domů | DirectoryIterator::getGroup


DirectoryIterator::getGroup

(PHP 5 >= 5.0.2)

DirectoryIterator::getGroup — Get file group

Description

int DirectoryIterator::getGroup ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
DirectoryIterator::getFilename | Domů | DirectoryIterator::getInode


DirectoryIterator::getInode

(PHP 5 >= 5.0.2)

DirectoryIterator::getInode — Get file inode

Description

int DirectoryIterator::getInode ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
DirectoryIterator::getGroup | Domů | DirectoryIterator::getMTime


DirectoryIterator::getMTime

(PHP 5 >= 5.0.2)

DirectoryIterator::getMTime — Get last modification time of file

Description

int DirectoryIterator::getMTime ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
DirectoryIterator::getInode | Domů | DirectoryIterator::getOwner


DirectoryIterator::getOwner

(PHP 5 >= 5.0.2)

DirectoryIterator::getOwner — Get file owner

Description

int DirectoryIterator::getOwner ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
DirectoryIterator::getMTime | Domů | DirectoryIterator::getPath


DirectoryIterator::getPath

(PHP 5 <= 5.1.1)

DirectoryIterator::getPath — Return directory path

Description

string DirectoryIterator::getPath ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
DirectoryIterator::getOwner | Domů | DirectoryIterator::getPathname


DirectoryIterator::getPathname

(PHP 5 <= 5.1.1)

DirectoryIterator::getPathname — Return path and filename of current dir entry

Description

string DirectoryIterator::getPathname ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
DirectoryIterator::getPath | Domů | DirectoryIterator::getPerms


DirectoryIterator::getPerms

(PHP 5 >= 5.0.2)

DirectoryIterator::getPerms — Get file permissions

Description

int DirectoryIterator::getPerms ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
DirectoryIterator::getPathname | Domů | DirectoryIterator::getSize


DirectoryIterator::getSize

(PHP 5 >= 5.0.2)

DirectoryIterator::getSize — Get file size

Description

int DirectoryIterator::getSize ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
DirectoryIterator::getPerms | Domů | DirectoryIterator::getType


DirectoryIterator::getType

(PHP 5 >= 5.0.2)

DirectoryIterator::getType — Get file type

Description

string DirectoryIterator::getType ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
DirectoryIterator::getSize | Domů | DirectoryIterator::isDir


DirectoryIterator::isDir

(PHP 5 <= 5.1.1)

DirectoryIterator::isDir — Returns true if file is directory

Description

bool DirectoryIterator::isDir ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
DirectoryIterator::getType | Domů | DirectoryIterator::isDot


DirectoryIterator::isDot

(PHP 5)

DirectoryIterator::isDot — Returns true if current entry is '.' or '..'

Description

bool DirectoryIterator::isDot ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
DirectoryIterator::isDir | Domů | DirectoryIterator::isExecutable


DirectoryIterator::isExecutable

(PHP 5 <= 5.1.1)

DirectoryIterator::isExecutable — Returns true if file is executable

Description

bool DirectoryIterator::isExecutable ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
DirectoryIterator::isDot | Domů | DirectoryIterator::isFile


DirectoryIterator::isFile

(PHP 5 <= 5.1.1)

DirectoryIterator::isFile — Returns true if file is a regular file

Description

bool DirectoryIterator::isFile ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
DirectoryIterator::isExecutable | Domů | DirectoryIterator::isLink


DirectoryIterator::isLink

(PHP 5 <= 5.1.1)

DirectoryIterator::isLink — Returns true if file is symbolic link

Description

bool DirectoryIterator::isLink ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
DirectoryIterator::isFile | Domů | DirectoryIterator::isReadable


DirectoryIterator::isReadable

(PHP 5 <= 5.1.1)

DirectoryIterator::isReadable — Returns true if file can be read

Description

bool DirectoryIterator::isReadable ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
DirectoryIterator::isLink | Domů | DirectoryIterator::isWritable


DirectoryIterator::isWritable

(PHP 5 <= 5.1.1)

DirectoryIterator::isWritable — Returns true if file can be written

Description

bool DirectoryIterator::isWritable ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
DirectoryIterator::isReadable | Domů | DirectoryIterator::key


DirectoryIterator::key

(PHP 5)

DirectoryIterator::key — Return current dir entry

Description

string DirectoryIterator::key ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
DirectoryIterator::isWritable | Domů | DirectoryIterator::next


DirectoryIterator::next

(PHP 5)

DirectoryIterator::next — Move to next entry

Description

void DirectoryIterator::next ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
DirectoryIterator::key | Domů | DirectoryIterator::rewind


DirectoryIterator::rewind

(PHP 5)

DirectoryIterator::rewind — Rewind dir back to the start

Description

void DirectoryIterator::rewind ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
DirectoryIterator::next | Domů | DirectoryIterator::valid


DirectoryIterator::valid

(PHP 5)

DirectoryIterator::valid — Check whether dir contains more entries

Description

string DirectoryIterator::valid ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
DirectoryIterator::rewind | Domů | FilterIterator::current


FilterIterator::current

(PHP 5)

FilterIterator::current — Get the current element value

Description

mixed FilterIterator::current ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
DirectoryIterator::valid | Domů | FilterIterator::getInnerIterator


FilterIterator::getInnerIterator

(PHP 5)

FilterIterator::getInnerIterator — Get the inner iterator

Description

Iterator FilterIterator::getInnerIterator ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
FilterIterator::current | Domů | FilterIterator::key


FilterIterator::key

(PHP 5)

FilterIterator::key — Get the current key

Description

mixed FilterIterator::key ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
FilterIterator::getInnerIterator | Domů | FilterIterator::next


FilterIterator::next

(PHP 5)

FilterIterator::next — Move the iterator forward

Description

void FilterIterator::next ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
FilterIterator::key | Domů | FilterIterator::rewind


FilterIterator::rewind

(PHP 5)

FilterIterator::rewind — Rewind the iterator

Description

void FilterIterator::rewind ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
FilterIterator::next | Domů | FilterIterator::valid


FilterIterator::valid

(PHP 5)

FilterIterator::valid — Check whether the current element is valid

Description

bool FilterIterator::valid ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
FilterIterator::rewind | Domů | LimitIterator::getPosition


LimitIterator::getPosition

(PHP 5)

LimitIterator::getPosition — Return the current position

Description

int LimitIterator::getPosition ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
FilterIterator::valid | Domů | LimitIterator::next


LimitIterator::next

(PHP 5)

LimitIterator::next — Move the iterator forward

Description

void LimitIterator::next ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
LimitIterator::getPosition | Domů | LimitIterator::rewind


LimitIterator::rewind

(PHP 5)

LimitIterator::rewind — Rewind the iterator to the specified starting offset

Description

void LimitIterator::rewind ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
LimitIterator::next | Domů | LimitIterator::seek


LimitIterator::seek

(PHP 5)

LimitIterator::seek — Seek to the given position

Description

void LimitIterator::seek ( int $position )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
LimitIterator::rewind | Domů | LimitIterator::valid


LimitIterator::valid

(PHP 5)

LimitIterator::valid — Check whether the current element is valid

Description

bool LimitIterator::valid ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
LimitIterator::seek | Domů | ParentIterator::getChildren


ParentIterator::getChildren

(PHP 5 <= 5.2.1)

ParentIterator::getChildren — Return the inner iterator's children contained in a ParentIterator

Description

ParentIterator ParentIterator::getChildren ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
LimitIterator::valid | Domů | ParentIterator::hasChildren


ParentIterator::hasChildren

(PHP 5 <= 5.2.1)

ParentIterator::hasChildren — Check whether the inner iterator's current element has children

Description

bool ParentIterator::hasChildren ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
ParentIterator::getChildren | Domů | ParentIterator::next


ParentIterator::next

(PHP 5)

ParentIterator::next — Move the iterator forward

Description

void ParentIterator::next ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
ParentIterator::hasChildren | Domů | ParentIterator::rewind


ParentIterator::rewind

(PHP 5)

ParentIterator::rewind — Rewind the iterator

Description

void ParentIterator::rewind ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
ParentIterator::next | Domů | RecursiveDirectoryIterator::getChildren


RecursiveDirectoryIterator::getChildren

(No version information available, might be only in CVS)

RecursiveDirectoryIterator::getChildren — Returns an iterator for the current entry if it is a directory

Description

object RecursiveDirectoryIterator::getChildren ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
ParentIterator::rewind | Domů | RecursiveDirectoryIterator::hasChildren


RecursiveDirectoryIterator::hasChildren

(PHP 5)

RecursiveDirectoryIterator::hasChildren — Returns whether current entry is a directory and not '.' or '..'

Description

bool RecursiveDirectoryIterator::hasChildren ( [bool $allow_links] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
RecursiveDirectoryIterator::getChildren | Domů | RecursiveDirectoryIterator::key


RecursiveDirectoryIterator::key

(PHP 5)

RecursiveDirectoryIterator::key — Return path and filename of current dir entry

Description

string RecursiveDirectoryIterator::key ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
RecursiveDirectoryIterator::hasChildren | Domů | RecursiveDirectoryIterator::next


RecursiveDirectoryIterator::next

(PHP 5)

RecursiveDirectoryIterator::next — Move to next entry

Description

void RecursiveDirectoryIterator::next ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
RecursiveDirectoryIterator::key | Domů | RecursiveDirectoryIterator::rewind


RecursiveDirectoryIterator::rewind

(PHP 5)

RecursiveDirectoryIterator::rewind — Rewind dir back to the start

Description

void RecursiveDirectoryIterator::rewind ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
RecursiveDirectoryIterator::next | Domů | RecursiveIteratorIterator::current


RecursiveIteratorIterator::current

(PHP 5)

RecursiveIteratorIterator::current — Access the current element value

Description

mixed RecursiveIteratorIterator::current ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
RecursiveDirectoryIterator::rewind | Domů | RecursiveIteratorIterator::getDepth


RecursiveIteratorIterator::getDepth

(PHP 5)

RecursiveIteratorIterator::getDepth — Get the current depth of the recursive iteration

Description

int RecursiveIteratorIterator::getDepth ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
RecursiveIteratorIterator::current | Domů | RecursiveIteratorIterator::getSubIterator


RecursiveIteratorIterator::getSubIterator

(PHP 5)

RecursiveIteratorIterator::getSubIterator — The current active sub iterator

Description

RecursiveIterator RecursiveIteratorIterator::getSubIterator ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
RecursiveIteratorIterator::getDepth | Domů | RecursiveIteratorIterator::key


RecursiveIteratorIterator::key

(PHP 5)

RecursiveIteratorIterator::key — Access the current key

Description

mixed RecursiveIteratorIterator::key ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
RecursiveIteratorIterator::getSubIterator | Domů | RecursiveIteratorIterator::next


RecursiveIteratorIterator::next

(PHP 5)

RecursiveIteratorIterator::next — Move forward to the next element

Description

void RecursiveIteratorIterator::next ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
RecursiveIteratorIterator::key | Domů | RecursiveIteratorIterator::rewind


RecursiveIteratorIterator::rewind

(PHP 5)

RecursiveIteratorIterator::rewind — Rewind the iterator to the first element of the top level inner iterator

Description

void RecursiveIteratorIterator::rewind ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
RecursiveIteratorIterator::next | Domů | RecursiveIteratorIterator::valid


RecursiveIteratorIterator::valid

(PHP 5)

RecursiveIteratorIterator::valid — Check whether the current position is valid

Description

bolean RecursiveIteratorIterator::valid ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
RecursiveIteratorIterator::rewind | Domů | SimpleXMLIterator::current


SimpleXMLIterator::current

(PHP 5 >= 5.1.3)

SimpleXMLIterator::current — Return current SimpleXML entry

Description

mixed SimpleXMLIterator::current ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
RecursiveIteratorIterator::valid | Domů | SimpleXMLIterator::getChildren


SimpleXMLIterator::getChildren

(PHP 5 >= 5.1.3)

SimpleXMLIterator::getChildren — Returns an iterator for the current entry if it is a SimpleXML object

Description

object SimpleXMLIterator::getChildren ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
SimpleXMLIterator::current | Domů | SimpleXMLIterator::hasChildren


SimpleXMLIterator::hasChildren

(PHP 5 >= 5.1.3)

SimpleXMLIterator::hasChildren — Returns whether current entry is a SimpleXML object

Description

bool SimpleXMLIterator::hasChildren ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
SimpleXMLIterator::getChildren | Domů | SimpleXMLIterator::key


SimpleXMLIterator::key

(PHP 5 >= 5.1.3)

SimpleXMLIterator::key — Return current SimpleXML key

Description

mixed SimpleXMLIterator::key ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
SimpleXMLIterator::hasChildren | Domů | SimpleXMLIterator::next


SimpleXMLIterator::next

(PHP 5 >= 5.1.3)

SimpleXMLIterator::next — Move to next entry

Description

void SimpleXMLIterator::next ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
SimpleXMLIterator::key | Domů | SimpleXMLIterator::rewind


SimpleXMLIterator::rewind

(PHP 5 >= 5.1.3)

SimpleXMLIterator::rewind — Rewind SimpleXML back to the start

Description

void SimpleXMLIterator::rewind ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
SimpleXMLIterator::next | Domů | SimpleXMLIterator::valid


SimpleXMLIterator::valid

(PHP 5 >= 5.1.3)

SimpleXMLIterator::valid — Check whether SimpleXML contains more entries

Description

bool SimpleXMLIterator::valid ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
SimpleXMLIterator::rewind | Domů | class_implements


class_implements

(PHP 5)

class_implements — Return the interfaces which are implemented by the given class

Popis

array class_implements ( mixed $class [, bool $autoload] )

This function returns an array with the names of the interfaces that the given class and its parents implement.

Seznam parametrů

class

An object (class instance) or a string (class name).

autoload

Whether to allow this function to load the class automatically through the __autoload magic method. Defaults to TRUE.

Návratové hodnoty

Returns an array or FALSE on error.

ChangeLog (záznam změn)

Verze | Popis
5.1.0 | Added the option to pass the class parameter as a string. Added the autoload parameter.

Příklady

Příklad 2099. class_implements() example

<?php

interface foo { }
class bar implements foo {}

print_r(class_implements(new bar));

// since PHP 5.1.0 you may also specify the parameter as a string
print_r(class_implements('bar'));

function __autoload($class_name) {
   require_once $class_name . '.php';
}

// use __autoload to load the 'not_loaded' class
print_r(class_implements('not_loaded', true));

?>

Výše uvedený příklad vypíše něco jako:

Array
(
    [foo] => foo
)

Array
(
    [interface_of_not_loaded] => interface_of_not_loaded
)

Viz také

class_parents()

Předcházející | Nahoru | Další
SimpleXMLIterator::valid | Domů | class_parents


class_parents

(PHP 5)

class_parents — Return the parent classes of the given class

Popis

array class_parents ( mixed $class [, bool $autoload] )

This function returns an array with the name of the parent classes of the given class.

Seznam parametrů

class

An object (class instance) or a string (class name).

autoload

Whether to allow this function to load the class automatically through the __autoload magic method. Defaults to TRUE.

Návratové hodnoty

Returns an array or FALSE on error.

ChangeLog (záznam změn)

Verze | Popis
5.1.0 | Added the option to pass the class parameter as a string. Added the autoload parameter.

Příklady

Příklad 2100. class_parents() example

<?php

class foo { }
class bar extends foo {}

print_r(class_parents(new bar));

// since PHP 5.1.0 you may also specify the parameter as a string
print_r(class_parents('bar'));

function __autoload($class_name) {
   require_once $class_name . '.php';
}

// use __autoload to load the 'not_loaded' class
print_r(class_parents('not_loaded', true));
?>

Výše uvedený příklad vypíše něco jako:

Array
(
    [foo] => foo
)

Array
(
    [parent_of_not_loaded] => parent_of_not_loaded
)

Viz také

class_implements()

Předcházející | Nahoru | Další
class_implements | Domů | iterator_count


iterator_count

(PHP 5 >= 5.1.3)

iterator_count — Count the elements in an iterator

Description

int iterator_count ( IteratorAggregate $iterator )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
class_parents | Domů | iterator_to_array


iterator_to_array

(PHP 5 >= 5.1.3)

iterator_to_array — Copy the iterator into an array

Description

array iterator_to_array ( IteratorAggregate $iterator [, bool $use_keys] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
iterator_count | Domů | spl_autoload_call


spl_classes

(PHP 5)

spl_classes — Return available SPL classes

Description

array spl_classes ( void )

This function returns an array with the current available SPL classes.

Příklad 2101. spl_classes() example

<?php

print_r(spl_classes());

?>

Výše uvedený příklad vypíše něco jako:

Array
(
    [ArrayObject] => ArrayObject
    [ArrayIterator] => ArrayIterator
    [CachingIterator] => CachingIterator
    [CachingRecursiveIterator] => CachingRecursiveIterator
    [DirectoryIterator] => DirectoryIterator
    [FilterIterator] => FilterIterator
    [LimitIterator] => LimitIterator
    [ParentIterator] => ParentIterator
    [RecursiveDirectoryIterator] => RecursiveDirectoryIterator
    [RecursiveIterator] => RecursiveIterator
    [RecursiveIteratorIterator] => RecursiveIteratorIterator
    [SeekableIterator] => SeekableIterator
    [SimpleXMLIterator] => SimpleXMLIterator
)

Předcházející | Nahoru | Další
spl_autoload | Domů | spl_object_hash


Stream Functions

Předcházející VI. Reference funkcí Další

CLX. Stream Functions

Úvod

Streams were introduced with PHP 4.3.0 as a way of generalizing file, network, data compression, and other operations which share a common set of functions and uses. In its simplest definition, a stream is a resource object which exhibits streamable behavior. That is, it can be read from or written to in a linear fashion, and may be able to fseek() to an arbitrary locations within the stream.

A wrapper is additional code which tells the stream how to handle specific protocols/encodings. For example, the http wrapper knows how to translate a URL into an HTTP/1.0 request for a file on a remote server. There are many wrappers built into PHP by default (See O – „List of Supported Protocols/Wrappers“), and additional, custom wrappers may be added either within a PHP script using stream_wrapper_register(), or directly from an extension using the API Reference in 53 – „Working with streams“. Because any variety of wrapper may be added to PHP, there is no set limit on what can be done with them. To access the list of currently registered wrappers, use stream_get_wrappers().

A stream is referenced as: scheme://target

  • scheme(string) - The name of the wrapper to be used. Examples include: file, http, https, ftp, ftps, compress.zlib, compress.bz2, and php. See O – „List of Supported Protocols/Wrappers“ for a list of PHP built-in wrappers. If no wrapper is specified, the function default is used (typically file://).
  • target - Depends on the wrapper used. For filesystem related streams this is typically a path and filename of the desired file. For network related streams this is typically a hostname, often with a path appended. Again, see O – „List of Supported Protocols/Wrappers“ for a description of targets for built-in streams.

Stream Filters

A filter is a final piece of code which may perform operations on data as it is being read from or written to a stream. Any number of filters may be stacked onto a stream. Custom filters can be defined in a PHP script using stream_filter_register() or in an extension using the API Reference in 53 – „Working with streams“. To access the list of currently registered filters, use stream_get_filters().

Stream Contexts

A context is a set of parameters and wrapper specific options which modify or enhance the behavior of a stream. Contexts are created using stream_context_create() and can be passed to most filesystem related stream creation functions (i.e. fopen(), file(), file_get_contents(), etc...).

Options can be specified when calling stream_context_create(), or later using stream_context_set_option(). A list of wrapper specific options can be found with the list of built-in wrappers (See O – „List of Supported Protocols/Wrappers“).

In addition, parameters may be set on a context using stream_context_set_params(). Currently the only context parameter supported by PHP is notification. The value of this parameter must be the name of a function to be called when an event occurs on a stream. The notification function called during an event should accept the following six parameters:

void my_notifier ( int $notification_code, int $severity, string $message, int $message_code, int $bytes_transferred, int $bytes_max )

notification_code and severity are numerical values which correspond to the STREAM_NOTIFY_* constants listed below. If a descriptive message is available from the stream, message and message_code will be populated with the appropriate values. The meaning of these values is dependent on the specific wrapper in use. bytes_transferred and bytes_max will be populated when applicable.

Instalace

Streams are an integral part of PHP as of version 4.3.0. No steps are required to enable them.

Stream Classes

User designed wrappers can be registered via stream_wrapper_register(), using the class definition shown on that manual page.

class php_user_filter is predefined and is an abstract baseclass for use with user defined filters. See the manual page for stream_filter_register() for details on implementing user defined filters.

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

Constant | Description
STREAM_FILTER_READ * | Used with stream_filter_append() and stream_filter_prepend() to indicate that the specified filter should only be applied when reading
STREAM_FILTER_WRITE * | Used with stream_filter_append() and stream_filter_prepend() to indicate that the specified filter should only be applied when writing
STREAM_FILTER_ALL * | This constant is equivalent to STREAM_FILTER_READ | STREAM_FILTER_WRITE
PSFS_PASS_ON * | Return Code indicating that the userspace filter returned buckets in $out.
PSFS_FEED_ME * | Return Code indicating that the userspace filter did not return buckets in $out (i.e. No data available).
PSFS_ERR_FATAL * | Return Code indicating that the userspace filter encountered an unrecoverable error (i.e. Invalid data received).
STREAM_USE_PATH | Flag indicating if the stream used the include path.
STREAM_REPORT_ERRORS | Flag indicating if the wrapper is responsible for raising errors using trigger_error() during opening of the stream. If this flag is not set, you should not raise any errors.
STREAM_CLIENT_ASYNC_CONNECT * | Open client socket asynchronously. This option must be used together with the STREAM_CLIENT_CONNECT flag. Used with stream_socket_client().
STREAM_CLIENT_CONNECT * | Open client socket connection. Client sockets should always include this flag. Used with stream_socket_client().
STREAM_CLIENT_PERSISTENT * | Client socket opened with stream_socket_client() should remain persistent between page loads.
STREAM_SERVER_BIND * | Tells a stream created with stream_socket_server() to bind to the specified target. Server sockets should always include this flag.
STREAM_SERVER_LISTEN * | Tells a stream created with stream_socket_server() and bound using the STREAM_SERVER_BIND flag to start listening on the socket. Connection-orientated transports (such as TCP) must use this flag, otherwise the server socket will not be enabled. Using this flag for connect-less transports (such as UDP) is an error.
STREAM_NOTIFY_RESOLVE * | A remote address required for this stream has been resolved, or the resolution failed. See severity for an indication of which happened.
STREAM_NOTIFY_CONNECT | A connection with an external resource has been established.
STREAM_NOTIFY_AUTH_REQUIRED | Additional authorization is required to access the specified resource. Typical issued with severity level of STREAM_NOTIFY_SEVERITY_ERR.
STREAM_NOTIFY_MIME_TYPE_IS | The mime-type of resource has been identified, refer to message for a description of the discovered type.
STREAM_NOTIFY_FILE_SIZE_IS | The size of the resource has been discovered.
STREAM_NOTIFY_REDIRECTED | The external resource has redirected the stream to an alternate location. Refer to message.
STREAM_NOTIFY_PROGRESS | Indicates current progress of the stream transfer in bytes_transferred and possibly bytes_max as well.
STREAM_NOTIFY_COMPLETED * | There is no more data available on the stream.
STREAM_NOTIFY_FAILURE | A generic error occurred on the stream, consult message and message_code for details.
STREAM_NOTIFY_AUTH_RESULT | Authorization has been completed (with or without success).
STREAM_NOTIFY_SEVERITY_INFO | Normal, non-error related, notification.
STREAM_NOTIFY_SEVERITY_WARN | Non critical error condition. Processing may continue.
STREAM_NOTIFY_SEVERITY_ERR | A critical error occurred. Processing cannot continue.
STREAM_IPPROTO_ICMP + | Provides a ICMP socket.
STREAM_IPPROTO_IP + | Provides a IP socket.
STREAM_IPPROTO_RAW + | Provides a RAW socket.
STREAM_IPPROTO_TCP + | Provides a TCP socket.
STREAM_IPPROTO_UDP + | Provides a UDP socket.
STREAM_PF_INET + | Internet Protocol Version 4 (IPv4).
STREAM_PF_INET6 + | Internet Protocol Version 6 (IPv6).
STREAM_PF_UNIX + | Unix system internal protocols.
STREAM_SOCK_DGRAM + | Provides datagrams, which are connectionless messages (UDP, for example).
STREAM_SOCK_RAW + | Provides a raw socket, which provides access to internal network protocols and interfaces. Usually this type of socket is just available to the root user.
STREAM_SOCK_RDM + | Provides a RDM (Reliably-delivered messages) socket.
STREAM_SOCK_SEQPACKET + | Provides a sequenced packet stream socket.
STREAM_SOCK_STREAM + | Provides sequenced, two-way byte streams with a transmission mechanism for out-of-band data (TCP, for example).
STREAM_SHUT_RD | Used with stream_socket_shutdown() to disable further receptions. Added in PHP 5.2.1.
STREAM_SHUT_WR | Used with stream_socket_shutdown() to disable further transmissions. Added in PHP 5.2.1.
STREAM_SHUT_RDWR | Used with stream_socket_shutdown() to disable further receptions and transmissions. Added in PHP 5.2.1.

Poznámka: The constants marked with * are just available since PHP 5.0.0.

Poznámka: The constants marked with + are available since PHP 5.1.0 and are meant to be used with stream_socket_pair(). Please note that some of these constants might not be available in your system.

Stream Errors

As with any file or socket related function, an operation on a stream may fail for a variety of normal reasons (i.e.: Unable to connect to remote host, file not found, etc...). A stream related call may also fail because the desired stream is not registered on the running system. See the array returned by stream_get_wrappers() for a list of streams supported by your installation of PHP. As with most PHP internal functions if a failure occurs an E_WARNING message will be generated describing the nature of the error.

Příklady

Příklad 2155. Using file_get_contents() to retrieve data from multiple sources

<?php
/* Read local file from /home/bar */
$localfile = file_get_contents("/home/bar/foo.txt");

/* Identical to above, explicitly naming FILE scheme */
$localfile = file_get_contents("file:///home/bar/foo.txt");

/* Read remote file from www.example.com using HTTP */
$httpfile  = file_get_contents("http://www.example.com/foo.txt");

/* Read remote file from www.example.com using HTTPS */
$httpsfile = file_get_contents("https://www.example.com/foo.txt");

/* Read remote file from ftp.example.com using FTP */
$ftpfile   = file_get_contents("ftp://user:pass@ftp.example.com/foo.txt");

/* Read remote file from ftp.example.com using FTPS */
$ftpsfile  = file_get_contents("ftps://user:pass@ftp.example.com/foo.txt");
?>

Příklad 2156. Making a POST request to an https server

<?php
/* Send POST request to https://secure.example.com/form_action.php
 * Include form elements named "foo" and "bar" with dummy values
 */

$sock = fsockopen("ssl://secure.example.com", 443, $errno, $errstr, 30);
if (!$sock) die("$errstr ($errno)\n");

$data = "foo=" . urlencode("Value for Foo") . "&bar=" . urlencode("Value for Bar");

fwrite($sock, "POST /form_action.php HTTP/1.0\r\n");
fwrite($sock, "Host: secure.example.com\r\n");
fwrite($sock, "Content-type: application/x-www-form-urlencoded\r\n");
fwrite($sock, "Content-length: " . strlen($data) . "\r\n");
fwrite($sock, "Accept: */*\r\n");
fwrite($sock, "\r\n");
fwrite($sock, "$data\r\n");
fwrite($sock, "\r\n");

$headers = "";
while ($str = trim(fgets($sock, 4096)))
  $headers .= "$str\n";

echo "\n";

$body = "";
while (!feof($sock))
  $body .= fgets($sock, 4096);

fclose($sock);
?>

Příklad 2157. Writing data to a compressed file

<?php
/* Create a compressed file containing an arbitrarty string
 * File can be read back using compress.zlib stream or just
 * decompressed from the command line using 'gzip -d foo-bar.txt.gz'
 */
$fp = fopen("compress.zlib://foo-bar.txt.gz", "wb");
if (!$fp) die("Unable to create file.");

fwrite($fp, "This is a test.\n");

fclose($fp);
?>

Obsah

stream_bucket_append — Append bucket to brigade
stream_bucket_make_writeable — Return a bucket object from the brigade for operating on
stream_bucket_new — Create a new bucket for use on the current stream
stream_bucket_prepend — Prepend bucket to brigade
stream_context_create — Create a streams context
stream_context_get_default — Retreive the default streams context
stream_context_get_options — Retrieve options for a stream/wrapper/context
stream_context_set_option — Sets an option for a stream/wrapper/context
stream_context_set_params — Set parameters for a stream/wrapper/context
stream_copy_to_stream — Copies data from one stream to another
stream_encoding — Set character set for stream encoding
stream_filter_append — Attach a filter to a stream
stream_filter_prepend — Attach a filter to a stream
stream_filter_register — Register a stream filter implemented as a PHP class derived from php_user_filter
stream_filter_remove — Remove a filter from a stream
stream_get_contents — Reads remainder of a stream into a string
stream_get_filters — Retrieve list of registered filters
stream_get_line — Gets line from stream resource up to a given delimiter
stream_get_meta_data — Retrieves header/meta data from streams/file pointers
stream_get_transports — Retrieve list of registered socket transports
stream_get_wrappers — Retrieve list of registered streams
stream_register_wrapper — Alias of stream_wrapper_register()
stream_resolve_include_path — Determine what file will be opened by calls to fopen() with a relative path
stream_select — Runs the equivalent of the select() system call on the given arrays of streams with a timeout specified by tv_sec and tv_usec
stream_set_blocking — Set blocking/non-blocking mode on a stream
stream_set_timeout — Set timeout period on a stream
stream_set_write_buffer — Sets file buffering on the given stream
stream_socket_accept — Accept a connection on a socket created by stream_socket_server()
stream_socket_client — Open Internet or Unix domain socket connection
stream_socket_enable_crypto — Turns encryption on/off on an already connected socket
stream_socket_get_name — Retrieve the name of the local or remote sockets
stream_socket_pair — Creates a pair of connected, indistinguishable socket streams
stream_socket_recvfrom — Receives data from a socket, connected or not
stream_socket_sendto — Sends a message to a socket, whether it is connected or not
stream_socket_server — Create an Internet or Unix domain server socket
stream_socket_shutdown — Shutdown a full-duplex connection
stream_wrapper_register — Register a URL wrapper implemented as a PHP class
stream_wrapper_restore — Restores a previously unregistered built-in wrapper
stream_wrapper_unregister — Unregister a URL wrapper
Předcházející | Nahoru | Další
stats_variance | Domů | stream_bucket_append


stream_context_create

(PHP 4 >= 4.3.0, PHP 5)

stream_context_create — Create a streams context

Description

resource stream_context_create ( [array $options [, array $params]] )

Creates and returns a stream context with any options supplied in options preset.

options must be an associative array of associative arrays in the format $arr['wrapper']['option'] = $value. It defaults to an empty array.

params must be an associative array in the format $arr['parameter'] = $value. Refer to stream_context_set_params() for a listing of standard stream parameters.

Poznámka: The params argument was added to PHP 6.0.0.

Příklad 2158. Using stream_context_create()

<?php
$opts = array(
  'http'=>array(
    'method'=>"GET",
    'header'=>"Accept-language: en\r\n" .
              "Cookie: foo=bar\r\n"
  )
);

$context = stream_context_create($opts);

/* Sends an http request to www.example.com
   with additional headers shown above */
$fp = fopen('http://www.example.com', 'r', false, $context);
fpassthru($fp);
fclose($fp);
?>

See also stream_context_set_option(), and Listing of supported wrappers with context options (O – „List of Supported Protocols/Wrappers“).

Předcházející | Nahoru | Další
stream_bucket_prepend | Domů | stream_context_get_default


stream_context_get_default

(PHP 5 >= 5.1.0)

stream_context_get_default — Retreive the default streams context

Description

resource stream_context_get_default ( [array $options] )

Returns the default stream context which is used whenever file operations (fopen(), file_get_contents(), etc...) are called without a context parameter. Options for the default context can optionally be specified with this function using the same syntax as stream_context_create().

options must be an associative array of associative arrays in the format $arr['wrapper']['option'] = $value.

Příklad 2159. Using stream_context_get_default()

<?php
$default_opts = array(
  'http'=>array(
    'method'=>"GET",
    'header'=>"Accept-language: en\r\n" .
              "Cookie: foo=bar",
    'proxy'=>"tcp://10.54.1.39:8000"
  )
);

$alternate_opts = array(
  'http'=>array(
    'method'=>"POST",
    'header'=>"Content-type: application/x-www-form-urlencoded\r\n" .
              "Content-length: " . strlen("baz=bomb"),
    'content'=>"baz=bomb"
  )
);

$default = stream_context_get_default($default_opts);
$alternate = stream_context_create($alternate_opts);

/* Sends a regular GET request to proxy server at 10.54.1.39
 * For www.example.com using context options specified in $default_opts
 */
readfile('http://www.example.com');

/* Sends a POST request directly to www.example.com
 * Using context options specified in $alternate_opts
 */
readfile('http://www.example.com', false, $alternate);

?>

See also stream_context_create(), and Listing of supported wrappers with context options (O – „List of Supported Protocols/Wrappers“).

Předcházející | Nahoru | Další
stream_context_create | Domů | stream_context_get_options


stream_context_get_options

(PHP 4 >= 4.3.0, PHP 5)

stream_context_get_options — Retrieve options for a stream/wrapper/context

Description

array stream_context_get_options ( resource $stream_or_context )

Returns an array of options on the specified stream or context.

Předcházející | Nahoru | Další
stream_context_get_default | Domů | stream_context_set_option


stream_context_set_option

(PHP 4 >= 4.3.0, PHP 5)

stream_context_set_option — Sets an option for a stream/wrapper/context

Description

bool stream_context_set_option ( resource $stream_or_context, string $wrapper, string $option, mixed $value )
bool stream_context_set_option ( resource $stream_or_context, array $options )

Sets an option on the specified context. value is set to option for wrapper

Předcházející | Nahoru | Další
stream_context_get_options | Domů | stream_context_set_params


stream_context_set_params

(PHP 4 >= 4.3.0, PHP 5)

stream_context_set_params — Set parameters for a stream/wrapper/context

Description

bool stream_context_set_params ( resource $stream_or_context, array $params )

params should be an associative array of the structure: $params['paramname'] = "paramvalue";.

Tabulka 295. Parameters

Parameters | Purpose
notification | Name of user-defined callback function to be called whenever a stream triggers a notification.
options | Array of options as in stream_context_create().

Předcházející | Nahoru | Další
stream_context_set_option | Domů | stream_copy_to_stream


stream_copy_to_stream

(PHP 5)

stream_copy_to_stream — Copies data from one stream to another

Popis

int stream_copy_to_stream ( resource $source, resource $dest [, int $maxlength [, int $offset]] )

Makes a copy of up to maxlength bytes of data from the current position (or from the offset position, if specified) in source to dest. If maxlength is not specified, all remaining content in source will be copied.

Seznam parametrů

source

The source stream

dest

The destination stream

maxlength

Maximum bytes to copy

offset

The offset where to start to copy data

Návratové hodnoty

Returns the total count of bytes copied.

ChangeLog (záznam změn)

Verze | Popis
5.1.0 | Added the offset parameter

Příklady

Příklad 2160. A stream_copy_to_stream() example

<?php
$src = fopen('http://www.example.com', 'r');
$dest1 = fopen('first1k.txt', 'w');
$dest2 = fopen('remainder.txt', 'w');

echo stream_copy_to_stream($src, $dest1, 1024) . " bytes copied to first1k.txt\n";
echo stream_copy_to_stream($src, $dest2) . " bytes copied to remainder.txt\n";

?>

Viz také

copy()

Předcházející | Nahoru | Další
stream_context_set_params | Domů | stream_encoding


stream_filter_append

(PHP 4 >= 4.3.0, PHP 5)

stream_filter_append — Attach a filter to a stream

Description

resource stream_filter_append ( resource $stream, string $filtername [, int $read_write [, mixed $params]] )

Adds filtername to the list of filters attached to stream. This filter will be added with the specified params to the end of the list and will therefore be called last during stream operations. To add a filter to the beginning of the list, use stream_filter_prepend().

By default, stream_filter_append() will attach the filter to the read filter chain if the file was opened for reading (i.e. File Mode: r, and/or +). The filter will also be attached to the write filter chain if the file was opened for writing (i.e. File Mode: w, a, and/or +). STREAM_FILTER_READ, STREAM_FILTER_WRITE, and/or STREAM_FILTER_ALL can also be passed to the read_write parameter to override this behavior.

As of PHP 5.1.0, this function returns a resource which can be used to refer to this filter instance during a call to stream_filter_remove(). Prior to PHP 5.1.0, this function returns TRUE on success or FALSE on failure.

Příklad 2161. Controlling where filters are applied

<?php
/* Open a test file for reading and writing */
$fp = fopen('test.txt', 'w+');

/* Apply the ROT13 filter to the
 * write filter chain, but not the
 * read filter chain */
stream_filter_append($fp, "string.rot13", STREAM_FILTER_WRITE);

/* Write a simple string to the file
 * it will be ROT13 transformed on the
 * way out */
fwrite($fp, "This is a test\n");

/* Back up to the beginning of the file */
rewind($fp);

/* Read the contents of the file back out.
 * Had the filter been applied to the
 * read filter chain as well, we would see
 * the text ROT13ed back to its original state */
fpassthru($fp);

fclose($fp);

/* Expected Output
   ---------------

Guvf vf n grfg

 */
?>

When using custom (user) filters: stream_filter_register() must be called first in order to register the desired user filter to filtername.

Poznámka: Stream data is read from resources (both local and remote) in chunks, with any unconsumed data kept in internal buffers. When a new filter is appended to a stream, data in the internal buffers is processed through the new filter at that time. This differs from the behavior of stream_filter_prepend().

See also
stream_filter_register(),
stream_filter_prepend(), and
stream_get_filters().

Předcházející | Nahoru | Další
stream_encoding | Domů | stream_filter_prepend


stream_filter_prepend

(PHP 4 >= 4.3.0, PHP 5)

stream_filter_prepend — Attach a filter to a stream

Description

resource stream_filter_prepend ( resource $stream, string $filtername [, int $read_write [, mixed $params]] )

Adds filtername to the list of filters attached to stream. This filter will be added with the specified params to the beginning of the list and will therefore be called first during stream operations. To add a filter to the end of the list, use stream_filter_append().

By default, stream_filter_prepend() will attach the filter to the read filter chain if the file was opened for reading (i.e. File Mode: r, and/or +). The filter will also be attached to the write filter chain if the file was opened for writing (i.e. File Mode: w, a, and/or +). STREAM_FILTER_READ, STREAM_FILTER_WRITE, and/or STREAM_FILTER_ALL can also be passed to the read_write parameter to override this behavior. See stream_filter_append() for an example of using this parameter.

As of PHP 5.1.0, this function returns a resource which can be used to refer to this filter instance during a call to stream_filter_remove(). Prior to PHP 5.1.0, this function returns TRUE on success or FALSE on failure.

When using custom (user) filters: stream_filter_register() must be called first in order to register the desired user filter to filtername.

Poznámka: Stream data is read from resources (both local and remote) in chunks, with any unconsumed data kept in internal buffers. When a new filter is prepended to a stream, data in the internal buffers, which has already been processed through other filters will not be reprocessed through the new filter at that time. This differs from the behavior of stream_filter_append().

See also stream_filter_register(), and stream_filter_append().

Předcházející | Nahoru | Další
stream_filter_append | Domů | stream_filter_register


stream_filter_register

(PHP 5)

stream_filter_register — Register a stream filter implemented as a PHP class derived from php_user_filter

Description

bool stream_filter_register ( string $filtername, string $classname )

stream_filter_register() allows you to implement your own filter on any registered stream used with all the other filesystem functions (such as fopen(), fread() etc.).

To implement a filter, you need to define a class as an extension of php_user_filter with a number of member functions as defined below. When performing read/write operations on the stream to which your filter is attached, PHP will pass the data through your filter (and any other filters attached to that stream) so that the data may be modified as desired. You must implement the methods exactly as described below - doing otherwise will lead to undefined behaviour.

stream_filter_register() will return FALSE if the filtername is already defined.

int filter ( resource $in, resource $out, int &$consumed, bool $closing )

This method is called whenever data is read from or written to the attached stream (such as with fread() or fwrite()). in is a resource pointing to a bucket brigade which contains one or more bucket objects containing data to be filtered. out is a resource pointing to a second bucket brigade into which your modified buckets should be placed. consumed, which must always be declared by reference, should be incremented by the length of the data which your filter reads in and alters. In most cases this means you will increment consumed by $bucket->datalen for each $bucket. If the stream is in the process of closing (and therefore this is the last pass through the filterchain), the closing parameter will be set to TRUE The filter method must return one of three values upon completion.

Return Value | Meaning
PSFS_PASS_ON | Filter processed successfully with data available in the out bucket brigade.
PSFS_FEED_ME | Filter processed successfully, however no data was available to return. More data is required from the stream or prior filter.
PSFS_ERR_FATAL (default) | The filter experienced an unrecoverable error and cannot continue.

bool onCreate ( void )

This method is called during instantiation of the filter class object. If your filter allocates or initializes any other resources (such as a buffer), this is the place to do it. Your implementation of this method should return FALSE on failure, or TRUE on success.

When your filter is first instantiated, and yourfilter->onCreate() is called, a number of properties will be available as shown in the table below.

Property | Contents
FilterClass->filtername | A string containing the name the filter was instantiated with. Filters may be registered under multiple names or under wildcards. Use this property to determine which name was used.
FilterClass->params | The contents of the params parameter passed to stream_filter_append() or stream_filter_prepend().

void onClose ( void )

This method is called upon filter shutdown (typically, this is also during stream shutdown), and is executed after the flush method is called. If any resources were allocated or initialzed during onCreate this would be the time to destroy or dispose of them.

The example below implements a filter named strtoupper on the foo-bar.txt stream which will capitalize all letter characters written to/read from that stream.

Příklad 2162. Filter for capitalizing characters on foo-bar.txt stream

<?php

/* Define our filter class */
class strtoupper_filter extends php_user_filter {
  function filter($in, $out, &$consumed, $closing)
  {
    while ($bucket = stream_bucket_make_writeable($in)) {
      $bucket->data = strtoupper($bucket->data);
      $consumed += $bucket->datalen;
      stream_bucket_append($out, $bucket);
    }
    return PSFS_PASS_ON;
  }
}

/* Register our filter with PHP */
stream_filter_register("strtoupper", "strtoupper_filter")
    or die("Failed to register filter");

$fp = fopen("foo-bar.txt", "w");

/* Attach the registered filter to the stream just opened */
stream_filter_append($fp, "strtoupper");

fwrite($fp, "Line1\n");
fwrite($fp, "Word - 2\n");
fwrite($fp, "Easy As 123\n");

fclose($fp);

/* Read the contents back out
 */
readfile("foo-bar.txt");

?>

Výše uvedený příklad vypíše:

LINE1
WORD - 2
EASY AS 123

Příklad 2163. Registering a generic filter class to match multiple filter names.

<?php

/* Define our filter class */
class string_filter extends php_user_filter {
  var $mode;

  function filter($in, $out, &$consumed, $closing)
  {
    while ($bucket = stream_bucket_make_writeable($in)) {
      if ($this->mode == 1) {
        $bucket->data = strtoupper($bucket->data);
      } elseif ($this->mode == 0) {
        $bucket->data = strtolower($bucket->data);
      }

      $consumed += $bucket->datalen;
      stream_bucket_append($out, $bucket);
    }
    return PSFS_PASS_ON;
  }

  function onCreate()
  {
    if ($this->filtername == 'str.toupper') {
      $this->mode = 1;
    } elseif ($this->filtername == 'str.tolower') {
      $this->mode = 0;
    } else {
      /* Some other str.* filter was asked for,
         report failure so that PHP will keep looking */
      return false;
    }

    return true;
  }
}

/* Register our filter with PHP */
stream_filter_register("str.*", "string_filter")
    or die("Failed to register filter");

$fp = fopen("foo-bar.txt", "w");

/* Attach the registered filter to the stream just opened
   We could alternately bind to str.tolower here */
stream_filter_append($fp, "str.toupper");

fwrite($fp, "Line1\n");
fwrite($fp, "Word - 2\n");
fwrite($fp, "Easy As 123\n");

fclose($fp);

/* Read the contents back out
 */
readfile("foo-bar.txt");
?>

Výše uvedený příklad vypíše:

LINE1
WORD - 2
EASY AS 123

See also
stream_wrapper_register(),
stream_filter_prepend(), and
stream_filter_append().

Předcházející | Nahoru | Další
stream_filter_prepend | Domů | stream_filter_remove


stream_filter_remove

(PHP 5 >= 5.1.0)

stream_filter_remove — Remove a filter from a stream

Description

bool stream_filter_remove ( resource $stream_filter )

Removes a stream filter previously added to a stream with stream_filter_prepend() or stream_filter_append(). Any data remaining in the filter's internal buffer will be flushed through to the next filter before removing it.

Příklad 2164. Dynamicly refiltering a stream

<?php
/* Open a test file for reading and writing */
$fp = fopen("test.txt", "rw");

$rot13_filter = stream_filter_append($fp, "string.rot13", STREAM_FILTER_WRITE);
fwrite($fp, "This is ");
stream_filter_remove($rot13_filter);
fwrite($fp, "a test\n");

rewind($fp);
fpassthru($fp);
fclose($fp);

/* Expected Output
   ---------------

Guvf vf a test

 */
?>

See also
stream_filter_register(),
stream_filter_append(), and
stream_filter_prepend().

Předcházející | Nahoru | Další
stream_filter_register | Domů | stream_get_contents


stream_get_contents

(PHP 5)

stream_get_contents — Reads remainder of a stream into a string

Description

string stream_get_contents ( resource $handle [, int $maxlength [, int $offset]] )

Identical to file_get_contents(), except that stream_get_contents() operates on an already open stream resource and returns the remaining contents in a string, up to maxlength bytes and starting at the specified offset.

Seznam parametrů

handle (resource)

A stream resource (e.g. returned from fopen())

maxlength (integer)

The maximum bytes to read. Defaults to -1 (read all the remaining buffer).

offset (integer)

Seek to the specified offset before reading. Added in PHP 5.1.0.

Návratové hodnoty

Returns a string, or FALSE on failure.

Příklady

Příklad 2165. stream_get_contents() example

<?php

if ($stream = fopen('http://www.example.com', 'r')) {
    // print all the page starting at the offset 10
    echo stream_get_contents($stream, -1, 10);

    fclose($stream);
}

if ($stream = fopen('http://www.example.net', 'r')) {
    // print the first 5 bytes
    echo stream_get_contents($stream, 5);

    fclose($stream);
}

?>

Viz také

fgets()
fread()
fpassthru()

Poznámka: Tato funkce je binárně bezpečná.

Předcházející | Nahoru | Další
stream_filter_remove | Domů | stream_get_filters


stream_get_filters

(PHP 5)

stream_get_filters — Retrieve list of registered filters

Description

array stream_get_filters ( void )

Returns an indexed array containing the name of all stream filters available on the running system.

Příklad 2166. Using stream_get_filters()

<?php
$streamlist = stream_get_filters();
print_r($streamlist);
?>

Output will be similar to the following. Note: there may be more or fewer filters in your version of PHP.

Array (
  [0] => string.rot13
  [1] => string.toupper
  [2] => string.tolower
  [3] => string.base64
  [4] => string.quoted-printable
)

See also stream_filter_register(), and stream_get_wrappers().

Předcházející | Nahoru | Další
stream_get_contents | Domů | stream_get_line


stream_get_line

(PHP 5)

stream_get_line — Gets line from stream resource up to a given delimiter

Description

string stream_get_line ( resource $handle, int $length [, string $ending] )

Returns a string of up to length bytes read from the file pointed to by handle. Reading ends when length bytes have been read, when the string specified by ending is found (which is not included in the return value), or on EOF (whichever comes first).

If an error occurs, returns FALSE.

This function is nearly identical to fgets() except in that it allows end of line delimiters other than the standard \n, \r, and \r\n, and does not return the delimiter itself.

See also fread(),
fgets(), and
fgetc().

Předcházející | Nahoru | Další
stream_get_filters | Domů | stream_get_meta_data


stream_get_meta_data

(PHP 4 >= 4.3.0, PHP 5)

stream_get_meta_data — Retrieves header/meta data from streams/file pointers

Description

array stream_get_meta_data ( resource $stream )

Returns information about an existing stream. The stream can be any stream created by fopen(), fsockopen() and pfsockopen(). The result array contains the following items:

  • timed_out (bool) - TRUE if the stream timed out while waiting for data on the last call to fread() or fgets().

  • blocked (bool) - TRUE if the stream is in blocking IO mode. See stream_set_blocking().

  • eof (bool) - TRUE if the stream has reached end-of-file. Note that for socket streams this member can be TRUE even when unread_bytes is non-zero. To determine if there is more data to be read, use feof() instead of reading this item.

  • unread_bytes (int) - the number of bytes currently contained in the PHP's own internal buffer.

    Poznámka: You shouldn't use this value in a script.

The following items were added in PHP 4.3.0:

  • stream_type (string) - a label describing the underlying implementation of the stream.

  • wrapper_type (string) - a label describing the protocol wrapper implementation layered over the stream. See O – „List of Supported Protocols/Wrappers“ for more information about wrappers.

  • wrapper_data (mixed) - wrapper specific data attached to this stream. See O – „List of Supported Protocols/Wrappers“ for more information about wrappers and their wrapper data.

  • filters (array) - and array containing the names of any filters that have been stacked onto this stream. Documentation on filters can be found in the Filters appendix.

Poznámka: This function was introduced in PHP 4.3.0, but prior to this version, socket_get_status() could be used to retrieve the first four items, for socket based streams only.

In PHP 4.3.0 and later, socket_get_status() is an alias for this function.

Poznámka: This function does NOT work on sockets created by the Socket extension.

The following items were added in PHP 5.0.0:

  • mode (string) - the type of access required for this stream (see Table 1 of the fopen() reference)

  • seekable (bool) - whether the current stream can be seeked.

  • uri (string) - the URI/filename associated with this stream.

Předcházející | Nahoru | Další
stream_get_line | Domů | stream_get_transports


stream_get_transports

(PHP 5)

stream_get_transports — Retrieve list of registered socket transports

Description

array stream_get_transports ( void )

Returns an indexed array containing the name of all socket transports available on the running system.

Příklad 2167. Using stream_get_transports()

<?php
$xportlist = stream_get_transports();
print_r($xportlist);
?>

Output will be similar to the following. Note: there may be more or fewer transports in your version of PHP.

Array (
  [0] => tcp
  [1] => udp
  [2] => unix
  [3] => udg
)

See also stream_get_filters(), and stream_get_wrappers().

Předcházející | Nahoru | Další
stream_get_meta_data | Domů | stream_get_wrappers


stream_get_wrappers

(PHP 5)

stream_get_wrappers — Retrieve list of registered streams

Description

array stream_get_wrappers ( void )

Returns an indexed array containing the name of all stream wrappers available on the running system.

Příklad 2168. stream_get_wrappers() example

<?php
print_r(stream_get_wrappers());
?>

Výše uvedený příklad vypíše něco jako:

Array
(
    [0] => php
    [1] => file
    [2] => http
    [3] => ftp
    [4] => compress.bzip2
    [5] => compress.zlib
)

Příklad 2169. Checking for the existence of a stream wrapper

<?php
// check for the existence of the bzip2 stream wrapper
if (in_array('compress.bzip2', stream_get_wrappers())) {
    echo 'compress.bzip2:// support enabled.';
} else {
    echo 'compress.bzip2:// support not enabled.';
}
?>

See also stream_wrapper_register().

Předcházející | Nahoru | Další
stream_get_transports | Domů | stream_register_wrapper


stream_register_wrapper

(PHP 4 >= 4.3.0, PHP 5)

stream_register_wrapper — Alias of stream_wrapper_register()

Description

This function is an alias of stream_wrapper_register(). This function is included for compatability with PHP 4.3.0 and PHP 4.3.1 only. stream_wrapper_register() should be used instead.

Předcházející | Nahoru | Další
stream_get_wrappers | Domů | stream_resolve_include_path


stream_select

(PHP 4 >= 4.3.0, PHP 5)

stream_select — Runs the equivalent of the select() system call on the given arrays of streams with a timeout specified by tv_sec and tv_usec

Description

int stream_select ( array &$read, array &$write, array &$except, int $tv_sec [, int $tv_usec] )

The stream_select() function accepts arrays of streams and waits for them to change status. Its operation is equivalent to that of the socket_select() function except in that it acts on streams.

The streams listed in the read array will be watched to see if characters become available for reading (more precisely, to see if a read will not block - in particular, a stream resource is also ready on end-of-file, in which case an fread() will return a zero length string).

The streams listed in the write array will be watched to see if a write will not block.

The streams listed in the except array will be watched for high priority exceptional ("out-of-band") data arriving.

Poznámka: When stream_select() returns, the arrays read, write and except are modified to indicate which stream resource(s) actually changed status.

The tv_sec and tv_usec together form the timeout parameter, tv_sec specifies the number of seconds while tv_usec the number of microseconds. The timeout is an upper bound on the amount of time that stream_select() will wait before it returns. If tv_sec and tv_usec are both set to 0, stream_select() will not wait for data - instead it will return immediately, indicating the current status of the streams. If tv_sec is NULL stream_select() can block indefinitely, returning only when an event on one of the watched streams occurs (or if a signal interrupts the system call).

On success stream_select() returns the number of stream resources contained in the modified arrays, which may be zero if the timeout expires before anything interesting happens. On error FALSE is returned and a warning raised (this can happen if the system call is interrupted by an incoming signal).

Varování

Using a timeout value of 0 allows you to instantaneously poll the status of the streams, however, it is NOT a good idea to use a 0 timeout value in a loop as it will cause your script to consume too much CPU time.

It is much better to specify a timeout value of a few seconds, although if you need to be checking and running other code concurrently, using a timeout value of at least 200000 microseconds will help reduce the CPU usage of your script.

Remember that the timeout value is the maximum time that will elapse; stream_select() will return as soon as the requested streams are ready for use.

You do not need to pass every array to stream_select(). You can leave it out and use an empty array or NULL instead. Also do not forget that those arrays are passed by reference and will be modified after stream_select() returns.

     This example checks to see if data has arrived for reading on either
     $stream1 or $stream2.
     Since the timeout value is 0 it will return
     immediately:

<?php
/* Prepare the read array */
$read   = array($stream1, $stream2);
$write  = NULL;
$except = NULL;
if (false === ($num_changed_streams = stream_select($read, $write, $except, 0))) {
/* Error handling */
} elseif ($num_changed_streams > 0) {
/* At least on one of the streams something interesting happened */
}
?>

Poznámka: Due to a limitation in the current Zend Engine it is not possible to pass a constant modifier like NULL directly as a parameter to a function which expects this parameter to be passed by reference. Instead use a temporary variable or an expression with the leftmost member being a temporary variable: <?php
$e = NULL;
stream_select($r, $w, $e, 0);
?>

Poznámka: Be sure to use the === operator when checking for an error. Since the stream_select() may return 0 the comparison with == would evaluate to TRUE: <?php
$e = NULL;
if (false === stream_select($r, $w, $e, 0)) {
    echo "stream_select() failed\n";
}
?>

Poznámka: If you read/write to a stream returned in the arrays be aware that they do not necessarily read/write the full amount of data you have requested. Be prepared to even only be able to read/write a single byte.

Poznámka: Windows compatibility: stream_select() used on a pipe returned from proc_open() may cause data loss under Windows 98.

Use of stream_select() on file descriptors returned by proc_open() will fail and return FALSE under Windows.

See also stream_set_blocking().

Předcházející | Nahoru | Další
stream_resolve_include_path | Domů | stream_set_blocking


stream_set_blocking

(PHP 4 >= 4.3.0, PHP 5)

stream_set_blocking — Set blocking/non-blocking mode on a stream

Description

bool stream_set_blocking ( resource $stream, int $mode )

If mode is 0, the given stream will be switched to non-blocking mode, and if 1, it will be switched to blocking mode. This affects calls like fgets() and fread() that read from the stream. In non-blocking mode an fgets() call will always return right away while in blocking mode it will wait for data to become available on the stream.

Vrací TRUE při úspěchu, FALSE při selhání.

This function was previously called as set_socket_blocking() and later socket_set_blocking() but this usage is deprecated.

Poznámka: Prior to PHP 4.3, this function only worked on socket based streams. Since PHP 4.3, this function works for any stream that supports non-blocking mode (currently, regular files and socket streams).

See also stream_select().

Předcházející | Nahoru | Další
stream_select | Domů | stream_set_timeout


stream_set_timeout

(PHP 4 >= 4.3.0, PHP 5)

stream_set_timeout — Set timeout period on a stream

Description

bool stream_set_timeout ( resource $stream, int $seconds [, int $microseconds] )

Sets the timeout value on stream, expressed in the sum of seconds and microseconds. Vrací TRUE při úspěchu, FALSE při selhání.

When the stream times out, the 'timed_out' key of the array returned by stream_get_meta_data() is set to TRUE, although no error/warning is generated.

Příklad 2170. stream_set_timeout() example

<?php
$fp = fsockopen("www.example.com", 80);
if (!$fp) {
    echo "Unable to open\n";
} else {

    fwrite($fp, "GET / HTTP/1.0\r\n\r\n");
    stream_set_timeout($fp, 2);
    $res = fread($fp, 2000);

    $info = stream_get_meta_data($fp);
    fclose($fp);

    if ($info['timed_out']) {
        echo 'Connection timed out!';
    } else {
        echo $res;
    }

}
?>

Poznámka: As of PHP 4.3, this function can (potentially) work on any kind of stream. In PHP 4.3, socket based streams are still the only kind supported in the PHP core, although streams from other extensions may support this function.

Poznámka: This function doesn't work with advanced operations like stream_socket_recvfrom(), use stream_select() with timeout parameter instead.

This function was previously called as set_socket_timeout() and later socket_set_timeout() but this usage is deprecated.

See also fsockopen() and fopen().

Předcházející | Nahoru | Další
stream_set_blocking | Domů | stream_set_write_buffer


stream_set_write_buffer

(PHP 4 >= 4.3.0, PHP 5)

stream_set_write_buffer — Sets file buffering on the given stream

Description

int stream_set_write_buffer ( resource $stream, int $buffer )

Output using fwrite() is normally buffered at 8K. This means that if there are two processes wanting to write to the same output stream (a file), each is paused after 8K of data to allow the other to write. stream_set_write_buffer() sets the buffering for write operations on the given filepointer stream to buffer bytes. If buffer is 0 then write operations are unbuffered. This ensures that all writes with fwrite() are completed before other processes are allowed to write to that output stream.

The function returns 0 on success, or EOF if the request cannot be honored.

The following example demonstrates how to use stream_set_write_buffer() to create an unbuffered stream.

Příklad 2171. stream_set_write_buffer() example

<?php
$fp = fopen($file, "w");
if ($fp) {
  stream_set_write_buffer($fp, 0);
  fwrite($fp, $output);
  fclose($fp);
}
?>

See also fopen() and fwrite().

Předcházející | Nahoru | Další
stream_set_timeout | Domů | stream_socket_accept


stream_socket_accept

(PHP 5)

stream_socket_accept — Accept a connection on a socket created by stream_socket_server()

Description

resource stream_socket_accept ( resource $server_socket [, float $timeout [, string &$peername]] )

Accept a connection on a socket previously created by stream_socket_server(). If timeout is specified, the default socket accept timeout will be overridden with the time specified in seconds. The name (address) of the client which connected will be passed back in peername if included and available from the selected transport.

peername can also be determined later using stream_socket_get_name().

If the call fails, it will return FALSE.

Varování

This function should not be used with UDP server sockets. Instead, use stream_socket_recvfrom() and stream_socket_sendto().

See also stream_socket_server(),
stream_socket_get_name(),
stream_set_blocking(),
stream_set_timeout(),
fgets(),
fgetss(), fwrite(),
fclose(), feof(), and
the Curl extension.

Předcházející | Nahoru | Další
stream_set_write_buffer | Domů | stream_socket_client


stream_socket_client

(PHP 5)

stream_socket_client — Open Internet or Unix domain socket connection

Description

resource stream_socket_client ( string $remote_socket [, int &$errno [, string &$errstr [, float $timeout [, int $flags [, resource $context]]]]] )

Initiates a stream or datagram connection to the destination specified by remote_socket. The type of socket created is determined by the transport specified using standard URL formatting: transport://target. For Internet Domain sockets (AF_INET) such as TCP and UDP, the target portion of the remote_socket parameter should consist of a hostname or IP address followed by a colon and a port number. For Unix domain sockets, the target portion should point to the socket file on the filesystem. The optional timeout can be used to set a timeout in seconds for the connect system call. flags is a bitmask field which may be set to any combination of connection flags. Currently the selection of connection flags is limited to STREAM_CLIENT_CONNECT (default), STREAM_CLIENT_ASYNC_CONNECT and STREAM_CLIENT_PERSISTENT.

Poznámka: If you need to set a timeout for reading/writing data over the socket, use stream_set_timeout(), as the timeout parameter to stream_socket_client() only applies while connecting the socket.

Poznámka: The timeout parameter only applies if you are not making an asynchronous connection attempt.

stream_socket_client() returns a
stream resource which may
be used together with the other file functions (such as
fgets(), fgetss(),
fwrite(), fclose(), and
feof()).

If the call fails, it will return FALSE and if the optional errno and errstr arguments are present they will be set to indicate the actual system level error that occurred in the system-level connect() call. If the value returned in errno is 0 and the function returned FALSE, it is an indication that the error occurred before the connect() call. This is most likely due to a problem initializing the socket. Note that the errno and errstr arguments will always be passed by reference.

Depending on the environment, the Unix domain or the optional connect timeout may not be available. A list of available transports can be retrieved using stream_get_transports(). See Q – „Seznam podporovaných socketových transportů“ for a list of built in transports.

The stream will by default be opened in blocking mode. You can switch it to non-blocking mode by using stream_set_blocking().

Příklad 2172. stream_socket_client() Example

<?php
$fp = stream_socket_client("tcp://www.example.com:80", $errno, $errstr, 30);
if (!$fp) {
    echo "$errstr ($errno)<br />\n";
} else {
    fwrite($fp, "GET / HTTP/1.0\r\nHost: www.example.com\r\nAccept: */*\r\n\r\n");
    while (!feof($fp)) {
        echo fgets($fp, 1024);
    }
    fclose($fp);
}
?>

The example below shows how to retrieve the day and time from the UDP service "daytime" (port 13) in your own machine.

Příklad 2173. Using UDP connection

<?php
$fp = stream_socket_client("udp://127.0.0.1:13", $errno, $errstr);
if (!$fp) {
    echo "ERROR: $errno - $errstr<br />\n";
} else {
    fwrite($fp, "\n");
    echo fread($fp, 26);
    fclose($fp);
}
?>

Varování

UDP sockets will sometimes appear to have opened without an error, even if the remote host is unreachable. The error will only become apparent when you read or write data to/from the socket. The reason for this is because UDP is a "connectionless" protocol, which means that the operating system does not try to establish a link for the socket until it actually needs to send or receive data.

Poznámka: Když zadáváte číselnou IPv6 adresu (např. fe80::1), musíte ji uzavřít do hranatých závorek. Například tcp://[fe80::1]:80.

See also stream_socket_server(),
stream_set_blocking(),
stream_set_timeout(),
stream_select(),
fgets(),
fgetss(), fwrite(),
fclose(), feof(), and
the Curl extension.

Předcházející | Nahoru | Další
stream_socket_accept | Domů | stream_socket_enable_crypto


stream_socket_enable_crypto

(PHP 5 >= 5.1.0)

stream_socket_enable_crypto — Turns encryption on/off on an already connected socket

Description

mixed stream_socket_enable_crypto ( resource $stream, bool $enable [, int $crypto_type [, resource $session_stream]] )

When called with the crypto_type parameter, stream_socket_enable_crypto() will setup encryption on the stream using the specified method.

Valid values for crypto_type

  • STREAM_CRYPTO_METHOD_SSLv2_CLIENT
  • STREAM_CRYPTO_METHOD_SSLv3_CLIENT
  • STREAM_CRYPTO_METHOD_SSLv23_CLIENT
  • STREAM_CRYPTO_METHOD_TLS_CLIENT
  • STREAM_CRYPTO_METHOD_SSLv2_SERVER
  • STREAM_CRYPTO_METHOD_SSLv3_SERVER
  • STREAM_CRYPTO_METHOD_SSLv23_SERVER
  • STREAM_CRYPTO_METHOD_TLS_SERVER

Once the crypto settings are established, cryptography can be turned on and off dynamically by passing TRUE or FALSE in the enable parameter.

If this stream should be seeded with settings from an already established crypto enabled stream, pass that stream's resource variable in the fourth parameter.

Returns TRUE on success, FALSE if negotiation has failed or 0 if there isn't enough data and you should try again (only for non-blocking sockets).

Příklad 2174. stream_socket_enable_crypto() Example

<?php
$fp = stream_socket_client("tcp://myproto.example.com:31337", $errno, $errstr, 30);
if (!$fp) {
  die("Unable to connect: $errstr ($errno)");
}
/* Turn on encryption for login phase */
stream_socket_enable_crypto($fp, true, STREAM_CRYPTO_METHOD_SSLv23_CLIENT);
fwrite($fp, "USER god\r\n");
fwrite($fp, "PASS secret\r\n");
/* Turn off encryption for the rest */
stream_socket_enable_crypto($fp, false);
while ($motd = fgets($fp)) {
  echo $motd;
}
fclose($fp);
?>

OpenSSL, and Q – „Seznam podporovaných socketových transportů“

Předcházející | Nahoru | Další
stream_socket_client | Domů | stream_socket_get_name


stream_socket_get_name

(PHP 5)

stream_socket_get_name — Retrieve the name of the local or remote sockets

Description

string stream_socket_get_name ( resource $handle, bool $want_peer )

Returns the local or remote name of a given socket connection. If want_peer is set to TRUE the remote socket name will be returned, if it is set to FALSE the local socket name will be returned.

See also stream_socket_accept().

Předcházející | Nahoru | Další
stream_socket_enable_crypto | Domů | stream_socket_pair


stream_socket_recvfrom

(PHP 5)

stream_socket_recvfrom — Receives data from a socket, connected or not

Description

string stream_socket_recvfrom ( resource $socket, int $length [, int $flags [, string &$address]] )

The function stream_socket_recvfrom() accepts data from a remote socket up to length bytes. If address is provided it will be populated with the address of the remote socket.

The value of flags can be any combination of the following:

Tabulka 296. possible values for flags

STREAM_OOB | Process OOB (out-of-band) data.
STREAM_PEEK | Retrieve data from the socket, but do not consume the buffer. Subsequent calls to fread() or stream_socket_recvfrom() will see the same data.

Příklad 2176. stream_socket_recvfrom() Example

<?php
/* Open a server socket to port 1234 on localhost */
$server = stream_socket_server('tcp://127.0.0.1:1234');

/* Accept a connection */
$socket = stream_socket_accept($server);

/* Grab a packet (1500 is a typical MTU size) of OOB data */
echo "Received Out-Of-Band: '" . stream_socket_recvfrom($socket, 1500, STREAM_OOB) . "'\n";

/* Take a peek at the normal in-band data, but don't comsume it. */
echo "Data: '" . stream_socket_recvfrom($socket, 1500, STREAM_PEEK) . "'\n";

/* Get the exact same packet again, but remove it from the buffer this time. */
echo "Data: '" . stream_socket_recvfrom($socket, 1500) . "'\n";

/* Close it up */
fclose($socket);
fclose($server);
?>

Poznámka: If a message received is longer than the length parameter, excess bytes may be discarded depending on the type of socket the message is received from (such as UDP).

Poznámka: Calls to stream_socket_recvfrom() on socket-based streams, after calls to buffer-based stream functions (like fread() or stream_get_line()) read data directly from the socket and bypass the stream buffer.

See also
stream_socket_sendto(),
stream_socket_client(), and
stream_socket_server().

Předcházející | Nahoru | Další
stream_socket_pair | Domů | stream_socket_sendto


stream_socket_sendto

(PHP 5)

stream_socket_sendto — Sends a message to a socket, whether it is connected or not

Description

int stream_socket_sendto ( resource $socket, string $data [, int $flags [, string $address]] )

The function stream_socket_sendto() sends the data specified by data through the socket specified by socket. The address specified when the socket stream was created will be used unless an alternate address is specified in address.

The value of flags can be any combination of the following:

Tabulka 297. possible values for flags

STREAM_OOB Process OOB (out-of-band) data.

Příklad 2177. stream_socket_sendto() Example

<?php
/* Open a socket to port 1234 on localhost */
$socket = stream_socket_client('tcp://127.0.0.1:1234');

/* Send ordinary data via ordinary channels. */
fwrite($socket, "Normal data transmit.");

/* Send more data out of band. */
stream_socket_sendto($socket, "Out of Band data.", STREAM_OOB);

/* Close it up */
fclose($socket);
?>

See also
stream_socket_recvfrom(),
stream_socket_client(), and
stream_socket_server().

Předcházející | Nahoru | Další
stream_socket_recvfrom | Domů | stream_socket_server


stream_socket_server

(PHP 5)

stream_socket_server — Create an Internet or Unix domain server socket

Description

resource stream_socket_server ( string $local_socket [, int &$errno [, string &$errstr [, int $flags [, resource $context]]]] )

Creates a stream or datagram socket on the specified local_socket. The type of socket created is determined by the transport specified using standard URL formatting: transport://target. For Internet Domain sockets (AF_INET) such as TCP and UDP, the target portion of the remote_socket parameter should consist of a hostname or IP address followed by a colon and a port number. For Unix domain sockets, the target portion should point to the socket file on the filesystem. flags is a bitmask field which may be set to any combination of socket creation flags. The default value of flags is STREAM_SERVER_BIND | STREAM_SERVER_LISTEN.

Poznámka: For UDP sockets, you must use STREAM_SERVER_BIND as the flags parameter.

This function only creates a socket, to begin accepting connections use stream_socket_accept().

If the call fails, it will return FALSE and if the optional errno and errstr arguments are present they will be set to indicate the actual system level error that occurred in the system-level socket(), bind(), and listen() calls. If the value returned in errno is 0 and the function returned FALSE, it is an indication that the error occurred before the bind() call. This is most likely due to a problem initializing the socket. Note that the errno and errstr arguments will always be passed by reference.

Depending on the environment, Unix domain sockets may not be available. A list of available transports can be retrieved using stream_get_transports(). See Q – „Seznam podporovaných socketových transportů“ for a list of bulitin transports.

Příklad 2178. Using TCP server sockets

<?php
$socket = stream_socket_server("tcp://0.0.0.0:8000", $errno, $errstr);
if (!$socket) {
  echo "$errstr ($errno)<br />\n";
} else {
  while ($conn = stream_socket_accept($socket)) {
    fwrite($conn, 'The local time is ' . date('n/j/Y g:i a') . "\n");
    fclose($conn);
  }
  fclose($socket);
}
?>

The example below shows how to act as a time server which can respond to time queries as shown in an example on stream_socket_client().

Poznámka: Most systems require root access to create a server socket on a port below 1024.

Příklad 2179. Using UDP server sockets

<?php
$socket = stream_socket_server("udp://127.0.0.1:1113", $errno, $errstr, STREAM_SERVER_BIND);
if (!$socket) {
    die("$errstr ($errno)");
}

do {
    $pkt = stream_socket_recvfrom($socket, 1, 0, $peer);
    echo "$peer\n";
    stream_socket_sendto($socket, date("D M j H:i:s Y\r\n"), 0, $peer);
} while ($pkt !== false);

?>

Poznámka: Když zadáváte číselnou IPv6 adresu (např. fe80::1), musíte ji uzavřít do hranatých závorek. Například tcp://[fe80::1]:80.

See also stream_socket_client(),
stream_set_blocking(),
stream_set_timeout(),
fgets(),
fgetss(), fwrite(),
fclose(), feof(), and
the Curl extension.

Předcházející | Nahoru | Další
stream_socket_sendto | Domů | stream_socket_shutdown


stream_wrapper_register

(PHP 4 >= 4.3.2, PHP 5)

stream_wrapper_register — Register a URL wrapper implemented as a PHP class

Description

bool stream_wrapper_register ( string $protocol, string $classname )

stream_wrapper_register() allows you to implement your own protocol handlers and streams for use with all the other filesystem functions (such as fopen(), fread() etc.).

To implement a wrapper, you need to define a class with a number of member functions, as defined below. When someone fopens your stream, PHP will create an instance of classname and then call methods on that instance. You must implement the methods exactly as described below - doing otherwise will lead to undefined behaviour.

Poznámka: As of PHP 5.0.0 the instance of classname will be populated with a context property referencing a Context Resource which may be accessed with stream_context_get_options(). If no context was passed to the stream creation function, context will be set to NULL.

stream_wrapper_register() will return FALSE if the protocol already has a handler.

bool stream_open ( string $path, string $mode, int $options, string $opened_path )

This method is called immediately after your stream object is created. path specifies the URL that was passed to fopen() and that this object is expected to retrieve. You can use parse_url() to break it apart.

mode is the mode used to open the file, as detailed for fopen(). You are responsible for checking that mode is valid for the path requested.

options holds additional flags set by the streams API. It can hold one or more of the following values OR'd together.

Flag | Description
STREAM_USE_PATH | If path is relative, search for the resource using the include_path.
STREAM_REPORT_ERRORS | If this flag is set, you are responsible for raising errors using trigger_error() during opening of the stream. If this flag is not set, you should not raise any errors.

If the path is opened successfully, and STREAM_USE_PATH is set in options, you should set opened_path to the full path of the file/resource that was actually opened.

If the requested resource was opened successfully, you should return TRUE, otherwise you should return FALSE

void stream_close ( void )

This method is called when the stream is closed, using fclose(). You must release any resources that were locked or allocated by the stream.

string stream_read ( int $count )

This method is called in response to fread() and fgets() calls on the stream. You must return up-to count bytes of data from the current read/write position as a string. If there are less than count bytes available, return as many as are available. If no more data is available, return either FALSE or an empty string. You must also update the read/write position of the stream by the number of bytes that were successfully read.

int stream_write ( string $data )

This method is called in response to fwrite() calls on the stream. You should store data into the underlying storage used by your stream. If there is not enough room, try to store as many bytes as possible. You should return the number of bytes that were successfully stored in the stream, or 0 if none could be stored. You must also update the read/write position of the stream by the number of bytes that were successfully written.

bool stream_eof ( void )

This method is called in response to feof() calls on the stream. You should return TRUE if the read/write position is at the end of the stream and if no more data is available to be read, or FALSE otherwise.

int stream_tell ( void )

This method is called in response to ftell() calls on the stream. You should return the current read/write position of the stream.

bool stream_seek ( int $offset, int $whence )

This method is called in response to fseek() calls on the stream. You should update the read/write position of the stream according to offset and whence. See fseek() for more information about these parameters. Return TRUE if the position was updated, FALSE otherwise.

bool stream_flush ( void )

This method is called in response to fflush() calls on the stream. If you have cached data in your stream but not yet stored it into the underlying storage, you should do so now. Return TRUE if the cached data was successfully stored (or if there was no data to store), or FALSE if the data could not be stored.

array stream_stat ( void )

This method is called in response to fstat() calls on the stream and should return an array containing the same values as appropriate for the stream.

bool unlink ( string $path )

This method is called in response to unlink() calls on URL paths associated with the wrapper and should attempt to delete the item specified by path. It should return TRUE on success or FALSE on failure. In order for the appropriate error message to be returned, do not define this method if your wrapper does not support unlinking.

Poznámka: Userspace wrapper unlink method is not supported prior to PHP 5.0.0.

bool rename ( string $path_from, string $path_to )

This method is called in response to rename() calls on URL paths associated with the wrapper and should attempt to rename the item specified by path_from to the specification given by path_to. It should return TRUE on success or FALSE on failure. In order for the appropriate error message to be returned, do not define this method if your wrapper does not support renaming.

Poznámka: Userspace wrapper rename method is not supported prior to PHP 5.0.0.

bool mkdir ( string $path, int $mode, int $options )

This method is called in response to mkdir() calls on URL paths associated with the wrapper and should attempt to create the directory specified by path. It should return TRUE on success or FALSE on failure. In order for the appropriate error message to be returned, do not define this method if your wrapper does not support creating directories. Posible values for options include STREAM_REPORT_ERRORS and STREAM_MKDIR_RECURSIVE.

Poznámka: Userspace wrapper mkdir method is not supported prior to PHP 5.0.0.

bool rmdir ( string $path, int $options )

This method is called in response to rmdir() calls on URL paths associated with the wrapper and should attempt to remove the directory specified by path. It should return TRUE on success or FALSE on failure. In order for the appropriate error message to be returned, do not define this method if your wrapper does not support removing directories. Possible values for options include STREAM_REPORT_ERRORS.

Poznámka: Userspace wrapper rmdir method is not supported prior to PHP 5.0.0.

bool dir_opendir ( string $path, int $options )

This method is called immediately when your stream object is created for examining directory contents with opendir(). path specifies the URL that was passed to opendir() and that this object is expected to explore. You can use parse_url() to break it apart.

array url_stat ( string $path, int $flags )

This method is called in response to stat() calls on the URL paths associated with the wrapper and should return as many elements in common with the system function as possible. Unknown or unavailable values should be set to a rational value (usually 0).

flags holds additional flags set by the streams API. It can hold one or more of the following values OR'd together.

Flag | Description
STREAM_URL_STAT_LINK | For resources with the ability to link to other resource (such as an HTTP Location: forward, or a filesystem symlink). This flag specified that only information about the link itself should be returned, not the resource pointed to by the link. This flag is set in response to calls to lstat(), is_link(), or filetype().
STREAM_URL_STAT_QUIET | If this flag is set, your wrapper should not raise any errors. If this flag is not set, you are responsible for reporting errors using the trigger_error() function during stating of the path.

string dir_readdir ( void )

This method is called in response to readdir() and should return a string representing the next filename in the location opened by dir_opendir().

bool dir_rewinddir ( void )

This method is called in response to rewinddir() and should reset the output generated by dir_readdir(). i.e.: The next call to dir_readdir() should return the first entry in the location returned by dir_opendir().

bool dir_closedir ( void )

This method is called in response to closedir(). You should release any resources which were locked or allocated during the opening and use of the directory stream.

The example below implements a var:// protocol handler that allows read/write access to a named global variable using standard filesystem stream functions such as fread(). The var:// protocol implemented below, given the URL "var://foo" will read/write data to/from $GLOBALS["foo"].

Příklad 2181. A Stream for reading/writing global variables

<?php

class VariableStream {
    var $position;
    var $varname;

    function stream_open($path, $mode, $options, &$opened_path)
    {
        $url = parse_url($path);
        $this->varname = $url["host"];
        $this->position = 0;

        return true;
    }

    function stream_read($count)
    {
        $ret = substr($GLOBALS[$this->varname], $this->position, $count);
        $this->position += strlen($ret);
        return $ret;
    }

    function stream_write($data)
    {
        $left = substr($GLOBALS[$this->varname], 0, $this->position);
        $right = substr($GLOBALS[$this->varname], $this->position + strlen($data));
        $GLOBALS[$this->varname] = $left . $data . $right;
        $this->position += strlen($data);
        return strlen($data);
    }

    function stream_tell()
    {
        return $this->position;
    }

    function stream_eof()
    {
        return $this->position >= strlen($GLOBALS[$this->varname]);
    }

    function stream_seek($offset, $whence)
    {
        switch ($whence) {
            case SEEK_SET:
                if ($offset < strlen($GLOBALS[$this->varname]) && $offset >= 0) {
                     $this->position = $offset;
                     return true;
                } else {
                     return false;
                }
                break;

            case SEEK_CUR:
                if ($offset >= 0) {
                     $this->position += $offset;
                     return true;
                } else {
                     return false;
                }
                break;

            case SEEK_END:
                if (strlen($GLOBALS[$this->varname]) + $offset >= 0) {
                     $this->position = strlen($GLOBALS[$this->varname]) + $offset;
                     return true;
                } else {
                     return false;
                }
                break;

            default:
                return false;
        }
    }
}

stream_wrapper_register("var", "VariableStream")
    or die("Failed to register protocol");

$myvar = "";

$fp = fopen("var://myvar", "r+");

fwrite($fp, "line1\n");
fwrite($fp, "line2\n");
fwrite($fp, "line3\n");

rewind($fp);
while (!feof($fp)) {
    echo fgets($fp);
}
fclose($fp);
var_dump($myvar);

?>

Předcházející | Nahoru | Další
stream_socket_shutdown | Domů | stream_wrapper_restore


stream_wrapper_restore

(PHP 5 >= 5.1.0)

stream_wrapper_restore — Restores a previously unregistered built-in wrapper

Description

bool stream_wrapper_restore ( string $protocol )

Restores a built-in wrapper previously unregistered with stream_wrapper_unregister().

Předcházející | Nahoru | Další
stream_wrapper_register | Domů | stream_wrapper_unregister


stream_wrapper_unregister

(PHP 5 >= 5.1.0)

stream_wrapper_unregister — Unregister a URL wrapper

Description

bool stream_wrapper_unregister ( string $protocol )

stream_wrapper_unregister() allows you to disable an already defined stream wrapper. Once the wrapper has been disabled you may override it with a user-defined wrapper using stream_wrapper_register() or reenable it later on with stream_wrapper_restore().

Předcházející | Nahoru | Další
stream_wrapper_restore | Domů | CLXI. Funkce pro práci s řetězci


Funkce pro práci s řetězci

Předcházející VI. Reference funkcí Další

CLXI. Funkce pro práci s řetězci

Úvod

Všechny tyto funkce různými způsoby pracují s řetězci. Některé specializovanější funkce najdete v sekcích regulárních výrazů a obsluha URL.

Informace o chování řetězců, zvláště v souvislosti s použitím jednoduchých uvozovek, dvojitých uvozovek a znaků opatřených zpětnými lomítky, viz položky Řetězce v sekci Typy tohoto manuálu.

Požadavky

Tyto funkce jsou k dispozici jako součást standardního modulu, který je vždy dostupný.

Instalace

K používání těchto funkcí není třeba žádná instalace, jsou součástí jádra PHP.

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

CRYPT_SALT_LENGTH integer
CRYPT_STD_DES integer
CRYPT_EXT_DES integer
CRYPT_MD5 integer
CRYPT_BLOWFISH integer
HTML_SPECIALCHARS (integer)
HTML_ENTITIES (integer)
ENT_COMPAT (integer)
ENT_QUOTES (integer)
ENT_NOQUOTES (integer)
CHAR_MAX (integer)
LC_CTYPE (integer)
LC_NUMERIC (integer)
LC_TIME (integer)
LC_COLLATE (integer)
LC_MONETARY (integer)
LC_ALL (integer)
LC_MESSAGES (integer)
STR_PAD_LEFT (integer)
STR_PAD_RIGHT (integer)
STR_PAD_BOTH (integer)

Viz také

Další informace o mnohem mocnějším zacházení s řetězci a obslužnými funkcemi nalezenete v sekcích POSIX funkce pro regulární výrazy a Perl kompatibilní funkce pro regulární výrazy.

Obsah

addcslashes — Opatřit řetězec lomítky ve stylu jazyka C
addslashes — Opatřit řetězec lomítky
bin2hex — Převést binární data na hexadecimální reprezentaci
chop — Odstranit netisknutelné znaky z konce řetězce
chr — Vrátit určitý znak
chunk_split — Rozdělit řetězec na menší části
convert_cyr_string — Převést z jedné znakové sady Azbuky do jiné
convert_uudecode — Decode a uuencoded string
convert_uuencode — Uuencode a string
count_chars — Vrátit informace o znacích použitých v řetězci
crc32 — Spočítat kontrolní součet crc32 řetězce
crypt — Jednosměrné zašifrování řetězce
echo — Vytisknout jeden nebo více řetězců
explode — Rozděluje řetězec jiným řetězcem
fprintf — Write a formatted string to a stream
get_html_translation_table — Vrací překladovou tabulku používanou v htmlspecialchars() a htmlentities()
hebrev — Převést logický Hebrejský text na vizuální text
hebrevc — Převést logický Hebrejský text na vizuální text s konverzí konců řádků
html_entity_decode — Convert all HTML entities to their applicable characters
htmlentities — Převést všechny použitelné znaky na HTML entity
htmlspecialchars_decode — Convert special HTML entities back to characters
htmlspecialchars — Převést zvláštní znaky na HTML entity
implode — Spojit prvky pole pomocí řetězce
join — Spojit prvky pole pomocí řetězce
levenshtein — Spočítat XXX Levenshteinovu vzdálenost mezi dvěma řetězci
localeconv — Get numeric formatting information
ltrim — Odstranit netisknutelné znaky ze začátku řetězce
md5_file — Calculates the md5 hash of a given file
md5 — Spočítat MD5 hash řetězce
metaphone — Spočítat metaphone klíč řetězce
money_format — Formats a number as a currency string
nl_langinfo — Query language and locale information
nl2br — Před všechny konce řádků v řetězci vloží HTML konce řádků
number_format — Format a number with grouped thousands
ord — Vrátit ASCII hodnotu znaku
parse_str — Rozparsovat řetězec do proměnných
print — Vytisknout řetězec
printf — Vytisknout formátovaný řetězec
quoted_printable_decode — Převést quoted-printable řetězec na osmibitový řetězec
quotemeta — Opatřit lomítky metaznaky
rtrim — Odstranit netisknutelné znaky z konce řetězce
setlocale — Set locale information
sha1_file — Calculate the sha1 hash of a file
sha1 — Calculate the sha1 hash of a string
similar_text — Spočítat podobnost dvou řetězců
soundex — Spočítat soundex klíč řetězce
sprintf — Vrátit formátovaný řetězec
sscanf — Rozparsovat vstupní řetězec podle formátu
str_getcsv — Parse a CSV string into an array
str_ireplace — Case-insensitive version of str_replace().
str_pad — Doplnit řetězec jiným řetězcem na určitou délku
str_repeat — Opakovat řetězec
str_replace — Nahradit všechny výskyty jednoho řetězce dalším řetězcem
str_rot13 — Perform the rot13 transform on a string
str_shuffle — Randomly shuffles a string
str_split — Convert a string to an array
str_word_count — Return information about words used in a string
strcasecmp — Binárně bezpečné case-insensitive porovnání řetězců
strchr — Najít první výskyt znaku
strcmp — Binárně bezpečně porovnat řetězce
strcoll — Locale based string comparison
strcspn — Najít délku úvodního segmentu neodpovídajícího masce
strip_tags — Odstranit z řetězce HTML a PHP tagy
stripcslashes — Un-quote string quoted with addcslashes()
stripos — Find position of first occurrence of a case-insensitive string
stripslashes — Zrušit escapování provedené funkcí addslashes()
stristr — strstr() bez rozlišení velikosti písmen
strlen — Zjistit délku řetězce
strnatcasecmp — Case-insensitive textové porovnání s využitím "natural order" algoritmu
strnatcmp — Porovnání řetězců algoritmem "přirozeného třídění"
strncasecmp — Binárně bezpečné case-insensitive porovnání prvních n znaků řetězců
strncmp — Binárně bezpečné porovnání prvních n znaků v řetězcích
strpbrk — Search a string for any of a set of characters
strpos — Najít pozici prvního výskytu řetězce
strrchr — Najít poslední výskyt znaku v řetězci
strrev — Obrátit řetězec
strripos — Find position of last occurrence of a case-insensitive string in a string
strrpos — Najít pozici posledního výskytu znaku v řetězci
strspn — Zjistit délku úvodního segmentu odpovídajícího masce
strstr — Najít první výskyt řetězce
strtok — Tokenize string
strtolower — Změnit řetězec na malá písmena
strtoupper — Změnit řetězec na velká písmena
strtr — Přeložit určité znaky
substr_compare — Binary safe comparison of 2 strings from an offset, up to length characters
substr_count — Spočítat počet výskytů řetězce
substr_replace — Nahradit část řetězce jiným řetězcem
substr — Vrátit část řetězce
trim — Odstranit netisknutelné znaky ze začátku a konce řetězce
ucfirst — Změní první písmeno řetězce na velké
ucwords — Změnit první znak každého slova v řetězci na velké písmeno
vfprintf — Write a formatted string to a stream
vprintf — Output a formatted string
vsprintf — Return a formatted string
wordwrap — Zalámat řetězec na daný počet znaků pomocí break znaku
Předcházející | Nahoru | Další
stream_wrapper_unregister | Domů | addcslashes


addcslashes

(PHP 4, PHP 5)

addcslashes — Opatřit řetězec lomítky ve stylu jazyka C

Popis

string addcslashes ( string $str, string $charlist )

Vrací řetězec se zpětnými lomítky před znaky, které jsou vypsány v parametru charlist. Dále doplní \n, \r atd. podobně jako v jazyce C, znaky s ASCII kódem nižším než 32 a vyšším než 126 se převedou na osmičkovou reprezentaci.

Pokud zvolíte oescapovat znaky 0, a, b, f, n, r, t a v, budou konvertovány na \0, \a, \b, \f, \n, \r, \t a \v. V PHP \0 (NULL), \r (carriage return), \n (nový řádek) a \t (tab) jsou předdefinované escape sekvence, while in C all of these are predefined escape sequences.

V charlist můžete udat rozsah, např. "\0..\37", což by escapovalo všechny znaky s ASCII kódem mezi 0 a 31.

Příklad 2182. Ukázka addcslashes()

$escaped = addcslashes ($not_escaped, "\0..\37!@\177..\377");

Pakliže uvádíte sekvenci znaků v parametru charlist ujistěte se, že víte které další znaky jdou mezi znaky, jež jsou uvedeny na začátku a na konci rozsahu.

echo addcslashes('foo[ ]', 'A..z');
// Výstup:  \f\o\o\[ \]
// Všechny velké i malé znaky budou escapovány
// ... but so will the [\]^_` and any tabs, line
// feeds, carriage returns, etc.
Také pokud první znak v rozsahu má nižší ASCII hodnotu než druhý znak v rozsahu, nebude žádný rozsah vytvořen. Pouze znkay začáteční, koncové a v periodě budou escapovány. Použijte funkci ord() k zjištění ASCII hodnoty znaků.
echo addcslashes("zoo['.']", 'z..A');
// Výstup:  \zoo['\.']

Viz také: stripcslashes(),
stripslashes(),
htmlspecialchars(),
htmlspecialchars() a
quotemeta().

Předcházející | Nahoru | Další
CLXI. Funkce pro práci s řetězci | Domů | addslashes


addslashes

(PHP 4, PHP 5)

addslashes — Opatřit řetězec lomítky

Popis

string addslashes ( string $str )

Vrací řetězec se zpětnými lomítky před znaky, které by mohly být problémové v databázových dotazech apod. Tyto znaky jsou jednoduchá uvozovka ('), dvojitá uvozovka ("), zpětné lomítko (\) a NUL (NULL byte).

Příklad použití funkce addslashes() je když vkládáte data do databáze. Například při vložení jména O'reilly do databáze musíte tento řetězec escapovat. Většina databází pro to používá znak \, z čehož vyjde O\'reilly. To se použije pouze pro vložení do databáze, lomítka navíc nebudou uložena. Nastavení PHP direktivy magic_quotes_sybase na on způsobí, že znak ' je místo lomítka escapován dalším znakem '.

PHP direktiva magic_quotes_gpc je výchozím nastavení nastavena na on, což způsobí že funkce addslashes() bude použita na všechna data GET, POST a COOKIE. Nepoužívejte funkci addslashes() na řetězce, které již byly escapovány díky direktivě magic_quotes_gpc, jinak způsobíte dvojité escapování. Funkce get_magic_quotes_gpc() se může hodit, pro ověření nastavení této direktivy.

Příklad 2183. Příklad funkce addslashes()

<?php
$str = "Jmenuješ se O'reilly?";

// Vypíše: Jmenuješ se O\'reilly?
echo addslashes($str);
?>

Viz také stripslashes(),
htmlspecialchars(),
quotemeta() a
get_magic_quotes_gpc().

Předcházející | Nahoru | Další
addcslashes | Domů | bin2hex


bin2hex

(PHP 4, PHP 5)

bin2hex — Převést binární data na hexadecimální reprezentaci

Popis

string bin2hex ( string $str )

Vrací ASCII řetězec obsahující hexadecimální reprezentaci str. Konverze probíhá po bytech, horní slabika první.

Dále také pack() a unpack().

Předcházející | Nahoru | Další
addslashes | Domů | chop


chop

(PHP 4, PHP 5)

chop — Odstranit netisknutelné znaky z konce řetězce

Popis

string chop ( string $str )

Vrací předaný řetězec bez netisknutelných znaků (vč. konců řádku) na konci.

Příklad 2184. Ukázka chop()

$trimmed = chop ($line);

Poznámka: chop() se liší do Perlovské funkce chop(), která z řetězce odstraňuje poslední znak.

Viz také: trim(),
ltrim(),
rtrim() a
chop().

Předcházející | Nahoru | Další
bin2hex | Domů | chr


chr

(PHP 4, PHP 5)

chr — Vrátit určitý znak

Popis

string chr ( int $ascii )

Vrací řetězec jednoho znaku obsahující znak specifikovaný argumentem ascii.

Příklad 2185. Ukázka chr()

$str .= chr (27); /* přidá escape znak na konec $str */

/* Toto je většinou užitečnější */

$str = sprintf ("Řetězec konči escape znakem: %c", 27);

Tato funkce se doplňuje s funkcí ord(). Viz také: sprintf() s formátovacím řetězcem %c.

Předcházející | Nahoru | Další
chop | Domů | chunk_split


chunk_split

(PHP 4, PHP 5)

chunk_split — Rozdělit řetězec na menší části

Popis

string chunk_split ( string $body [, int $chunklen [, string $end]] )

Dá se použít k rozdělení řetězce na menší části, což může být užitečné např. při uvádění výstupu z base64_encode do souladu se sémantikou RFC 2045. Každých chunklen (defaultně 76) znaků vloží řetězec end (defaultně "\r\n"). Vrací nový řetězec, původní zůstává beze změny.

Příklad 2186. Ukázka chunk_split()

# naformátuje $data s použitím RFC 2045 sémantiky

$new_string = chunk_split (base64_encode($data));

Tato funkce je výrazně rychlejší než ereg_replace().

Poznámka: Tato funkce byla přidána v 3.0.6.

Předcházející | Nahoru | Další
chr | Domů | convert_cyr_string


convert_cyr_string

(PHP 4, PHP 5)

convert_cyr_string — Převést z jedné znakové sady Azbuky do jiné

Popis

string convert_cyr_string ( string $str, string $from, string $to )

Tato funkce převede daný řetězec z jedné znakové sady azbuky do jiné. Argumenty from a to jsou jednotlivé znaky, které představují zdrojovou a cílovou znakovou sadu Azbuky. Podporované typy jsou:

  • k - koi8-r
  • w - windows-1251
  • i - iso8859-5
  • a - x-cp866
  • d - x-cp866
  • m - x-mac-cyrillic

Předcházející | Nahoru | Další
chunk_split | Domů | convert_uudecode


convert_uudecode

(PHP 5)

convert_uudecode — Decode a uuencoded string

Popis

string convert_uudecode ( string $data )

convert_uudecode() decodes a uuencoded string.

Seznam parametrů

data

The uuencoded data.

Návratové hodnoty

Returns the decoded data as a string.

Příklady

Příklad 2187. convert_uudecode() example

<?php
/* Can you imagine what this will print? :) */
echo convert_uudecode("+22!L;W9E(%!(4\"$`\n`");
?>

Viz také

convert_uuencode()

Předcházející | Nahoru | Další
convert_cyr_string | Domů | convert_uuencode


convert_uuencode

(PHP 5)

convert_uuencode — Uuencode a string

Popis

string convert_uuencode ( string $data )

convert_uuencode() encodes a string using the uuencode algorithm.

Uuencode translates all strings (including binary's ones) into printable characters, making them safe for network transmissions. Uuencoded data is about 35% larger than the original.

Seznam parametrů

data

The data to be encoded.

Návratové hodnoty

Returns the uuencoded data.

Příklady

Příklad 2188. convert_uuencode() example

<?php
$some_string = "test\ntext text\r\n";

echo convert_uuencode($some_string);
?>

Viz také

convert_uudecode()
base64_encode()

Předcházející | Nahoru | Další
convert_uudecode | Domů | count_chars


count_chars

(PHP 4, PHP 5)

count_chars — Vrátit informace o znacích použitých v řetězci

Popis

mixed count_chars ( string $string [, int $ mode ] )

Počítá počet výskytů všech byte hodnot (0..255) v string a vrací je různými způsoby. Volitelný argument Mode má defaultní hodnotu 0. V závislosti na mode vrací count_chars() jednu z následujících možností:

  • 0 - pole s klíči tvořenými byte hodnotami a hodnotami tvořenými četností každého bytu.
  • 1 - stejné jako 0, ale vrací pouze byte hodnoty s četností vyšší než nula.
  • 2 - stejné jako 0, ale vrací pouze byte hodnoty s četností rovnou nule.
  • 3 - vrací řetězec obsahující všechny použité byte hodnoty.
  • 4 - vrací řetězec obsahující všechny nepoužité byte hodnoty.

Předcházející | Nahoru | Další
convert_uuencode | Domů | crc32


crc32

(PHP 4 >= 4.0.1, PHP 5)

crc32 — Spočítat kontrolní součet crc32 řetězce

Popis

int crc32 ( string $str )

Generuje 32bitový polynomický kontrolní součet pro str. Obvykle se používá ke kontrole integrity přenášených dat.

Viz také: md5().

Předcházející | Nahoru | Další
count_chars | Domů | crypt


crypt

(PHP 4, PHP 5)

crypt — Jednosměrné zašifrování řetězce

Popis

string crypt ( string $str [, string $salt] )

crypt() zašifruje řetězec pomocí standardní Unixovské šifrovací metody DES nebo alternativního algoritmu dostupného v operačním systému. Argumenty jsou řetězec k zašifrování a volitelný dvouznakový řetězec salt, na kterém se šifrování založí. Více informací naleznete v Unixovské man stránce vaší crypt funkce.

Není-li uveden salt, PHP jej náhodně vygeneruje.

Některé operační systémy podporují více typů šifrování. Někdy se standardní DES šifrování nahrazuje šifrovacím algoritmem založeným na MD5. Typ šifrování se zvolí podle argumentu salt. PHP zjistí pči instalaci schopnosti funkce crypt a bude přijímat salt pro další typy šifrování. Při absenci salt PHP automaticky vygeneruje standardní dvouznakový DES salt a v případě, že je výchozím typem šifrování na daném systému MD5, vygeneruje náhodný salt kompatibilní s MD5. PHP vytváří konstantu CRYPT_SALT_LENGTH, která vám řekne, jestli se na váš systém hodí běžný dvouznakový salt nebo delší dvanáctiznakový MD5 salt.

Používáte-li poskytnutý salt, měli byste si být vědomi toho, že se generuje jen jednou. Pokud tuto funkci voláte rekurzivně, může to mít účinek na vzhled a bezpečnost.

U standardního DES šifrování crypt() vrací salt jako první dva znaky výstupu. K tomu také používá jen prvních osum znaků z str, takže delší řetězce, ktewré začínají osmi stejnými znaky budou generovat i stejný výsledek (když je použit stejný salt).

Na systémech, kde funkce crypt()() podporuje více typů šifrování se následující konstanty nastaví na 0 nebo 1 podle toho, zda je daný typ dostupný:

  • CRYPT_STD_DES - Standardní DES šifrování s dvouznakovým SALT
  • CRYPT_EXT_DES - Rozšířené DES šifrování s devítiznakovým SALT
  • CRYPT_MD5 - MD5 šifrování s dvanáctiznakovým SALT začínajícím $1$
  • CRYPT_BLOWFISH - Rozšířené DES šifrování s šestnáctiznakovým SALT začínajícím $2$

Poznámka: Neexistuje žádná decrypt funkce, protože crypt() používá jednosměrný algoritmus.

Příklad 2189. crypt() příklad

<?php
$heslo = crypt("MePrvniHeslo"); # necháme vygenerovat salt
# Mohli byste narazit na problémy při úplném výsledku crypt() jako salt pro
# porovnání hesla, pokud jsou použity rozdílné šifrovací algoritmy. (jak bylo
# řečeno výše, standardní DES šifrování používá dvouznakový salt, ale MD5
# šifrování používá dvanáctiznakový.
if (crypt($uziv_vstup, $heslo) == $heslo) {
   echo "Heslo ověřeno!";
}
?>

Dále také md5() a Mcrypt příkazy.

Předcházející | Nahoru | Další
crc32 | Domů | echo


echo

(PHP 4, PHP 5)

echo — Vytisknout jeden nebo více řetězců

Popis

void echo ( string $arg1 [, string $...] )

Vytiskne všechny parametry.

echo() vlastně není funkce (je to jazykový konstrukt), takže u něj nemusíte používat závorky. Opravdu, pokud byste potřebovali vytisknout více než jeden parametr, nemohli byste dokonce závorky vůbec použít. Proto nelze použít echo() ani pro proměnnou funkci, ovšem místo toho můžete použít funkci print().

Příklad 2190. Ukázka echo()

<?php
echo "Nazdar světe";

echo "Toto zabírá
několik řádků. Konce řádků se
vytisknou také";

echo "Toto zabírá\nněkolik řádků. Konce řádků se\nvytisknou také.";

echo "Speciální znaky předřazené zpětnými lomítky lze použít i v řetězci \"jako toto\".";

//Proměnné lze použít i uvnitř příkazu echo
$foo = "foobar";
$bar = "barbaz";

echo "foo je $foo"; // foo je foobar

// Použitím jednoduchých uvozovek vypíšte jméno proměnné, nikoli její hodnotu
echo 'foo je $foo'; // foo je $foo

// Jestliže nepotřebujete vypisovat další znaky, můžete rovnou uvést jen názvy proměnných
echo $foo;          // foobar
echo $foo, $bar;     // foobarbarbaz

echo <<<END
Toto používá "dokumentovou" syntaxi pro víceřádkový výstup
s vložnými $prommenymi. Uvědomte si, že ukončovací řetězec
se středníkem musí být na začátku nového řádku (bez mezer či
tabulátorů).
END;

// Protože echo není funkce, následující kód je neplatný
($some_var) ? echo('true'): echo('false');

// Nicméně tento příklad fungovat bude
($some_var) ? print('true'): print('false'); // print je funkce
echo $some_var ? 'true': 'false'; // příkaz musíte uvést předtím
?>

echo() také má zkrácenou syntaxi, kdy je možné následně za otvíracím php tagem použít jen znak rovná se.

Mám <?=$foo?> foo.

Poznámka: Tato zkrácená syntaxe bude fungovat pouze jsou-li povoleny zkrácené otvírací php tagy; short_open_tag je nastaveno na "on".

Viz také:
print(),
printf() a
flush().

Předcházející | Nahoru | Další
crypt | Domů | explode


explode

(PHP 4, PHP 5)

explode — Rozděluje řetězec jiným řetězcem

Popis

array explode ( string $delimiter, string $string [, int $limit] )

Vrací pole řetězců, z nichž každý je částí argumentu string vzniklý jeho rozdělením na hranicích tvořených řetězcem separator. Pokud je definován limit, vrácené pole bude obsahovat maximálně limit prvků, a poslední prvek bude obsahovat celý zbytek parametru string.

Poznámka: Je-li separator prázdný řetězec (""), explode() vrátí FALSE. Pokud separator obsahuje hodnotu, která není obsažena v string, pak explode() vrátí pole obsahující celý string.

I když implode() může z historických důvodů přijímat argumenty v obou možných pořadích, explode() nemůže. Musíte zajistit, aby byl argument separator před argumentem string.

Parametr limit byl přidán v PHP 4.0.1

Příklad 2191. Ukázka explode()

<?php
// Příklad 1
$pizza  = "díl1 díl2 díl3 díl4 díl5 díl6";
$dily = explode(" ", $pizza);
echo $dily[0]; // díl1
echo $dily[1]; // díl2

// Příklad 2
$data = "foo:*:1023:1000::/home/foo:/bin/sh";
list($user, $pass, $uid, $gid, $gecos, $home, $shell) = explode(":", $data);
echo $user; // foo
echo $pass; // *

?>

Viz také
preg_split(),
spliti(),
split() a
implode().

Předcházející | Nahoru | Další
echo | Domů | fprintf


fprintf

(PHP 5)

fprintf — Write a formatted string to a stream

Popis

int fprintf ( resource $handle, string $format [, mixed $args [, mixed $...]] )

Write a string produced according to format to the stream resource specified by handle.

Seznam parametrů

handle

format

See sprintf() for a description of format.

args

...

Návratové hodnoty

Returns the length of the outputted string.

Příklady

Příklad 2192. fprintf(): zero-padded integers

<?php
if (!($fp = fopen('date.txt', 'w')))
    return;

fprintf($fp, "%04d-%02d-%02d", $year, $month, $day);
// will write the formatted ISO date to date.txt
?>

Příklad 2193. fprintf(): formatting currency

<?php
if (!($fp = fopen('currency.txt', 'w')))
    return;

$money1 = 68.75;
$money2 = 54.35;
$money = $money1 + $money2;
// echo $money will output "123.1";
$len = fprintf($fp, '%01.2f', $money);
// will write "123.10" to currency.txt

echo "wrote $len bytes to currency.txt";
// use the return value of fprintf to determine how many bytes we wrote
?>

Viz také

printf()
sprintf()
sscanf()
fscanf()
vsprintf()
number_format()

Předcházející | Nahoru | Další
explode | Domů | get_html_translation_table


get_html_translation_table

(PHP 4, PHP 5)

get_html_translation_table — Vrací překladovou tabulku používanou v htmlspecialchars() a htmlentities()

Popis

array get_html_translation_table ( [int $table [, int $quote_style]] )

get_html_translation_table() vrací překladovou tabulku, která se interně používá ve funkcích htmlspecialchars() a htmlentities(). Dvě nové konstanty (HTML_ENTITIES, HTML_SPECIALCHARS) vám umožňují určit, kterou tabulku chcete. A stejně jako u funkcí htmlspecialchars() a htmlentities() můžete případně určit quote_style se kterým pracujete. Defaultní hodnota je ENT_COMPAT mód. Viz popis těchto módů u htmlspecialchars().

Příklad 2194. Ukázka na překladovou tabulku

$trans = get_html_translation_table (HTML_ENTITIES);
$str = "Hallo & <Frau> & Krämer";
$encoded = strtr ($str, $trans);

Proměnná $encoded teď obsahuje: "Hallo &amp; &lt;Frau&gt; &amp; Kr&auml;mer".

Skvělé je, že pomocí array_flip() můžete změnit směr překladu.

$trans = array_flip ($trans);
$original = strtr ($str, $trans);
Obsahem $original je: "Hallo & <Frau> & Krämer".

Poznámka: Tato funkce byla přidána v PHP 4.0.

Viz také: htmlspecialchars(),
htmlentities(),
strtr() a
array_flip().

Předcházející | Nahoru | Další
fprintf | Domů | hebrev


hebrev

(PHP 4, PHP 5)

hebrev — Převést logický Hebrejský text na vizuální text

Popis

string hebrev ( string $hebrew_text [, int $max_chars_per_line] )

Volitelný argument max_chars_per_line indikuje maximální počet znaků na řádek výstupu. Funkce se snaží nerozdělovat slova.

Viz také: hebrevc().

Předcházející | Nahoru | Další
get_html_translation_table | Domů | hebrevc


hebrevc

(PHP 4, PHP 5)

hebrevc — Převést logický Hebrejský text na vizuální text s konverzí konců řádků

Popis

string hebrevc ( string $hebrew_text [, int $max_chars_per_line] )

Tato funkce se podobá hebrev() s tím rozdílem, že převádí konce řádků (\n) na "<br>\n". Volitelný argument max_chars_per_line indikuje maximální počet znaků na řádek výstupu. Funkce se snaží nerozdělovat slova.

Viz také: hebrev().

Předcházející | Nahoru | Další
hebrev | Domů | html_entity_decode


html_entity_decode

(PHP 4 >= 4.3.0, PHP 5)

html_entity_decode — Convert all HTML entities to their applicable characters

Popis

string html_entity_decode ( string $string [, int $quote_style [, string $charset]] )

html_entity_decode() is the opposite of htmlentities() in that it converts all HTML entities to their applicable characters from string.

Seznam parametrů

string

The input string.

quote_style

The optional second quote_style parameter lets you define what will be done with 'single' and "double" quotes. It takes on one of three constants with the default being ENT_COMPAT:

Tabulka 298. Available quote_style constants

Constant Name | Description
ENT_COMPAT | Will convert double-quotes and leave single-quotes alone.
ENT_QUOTES | Will convert both double and single quotes.
ENT_NOQUOTES | Will leave both double and single quotes unconverted.

charset

The ISO-8859-1 character set is used as default for the optional third charset. This defines the character set used in conversion.

Following character sets are supported in PHP 4.3.0 and later.

Tabulka 299. Supported charsets

Charset | Aliases | Description
ISO-8859-1 | ISO8859-1 | Western European, Latin-1
ISO-8859-15 | ISO8859-15 | Western European, Latin-9. Adds the Euro sign, French and Finnish letters missing in Latin-1(ISO-8859-1).
UTF-8 | ASCII compatible multi-byte 8-bit Unicode.
cp866 | ibm866, 866 | DOS-specific Cyrillic charset. This charset is supported in 4.3.2.
cp1251 | Windows-1251, win-1251, 1251 | Windows-specific Cyrillic charset. This charset is supported in 4.3.2.
cp1252 | Windows-1252, 1252 | Windows specific charset for Western European.
KOI8-R | koi8-ru, koi8r | Russian. This charset is supported in 4.3.2.
BIG5 | 950 | Traditional Chinese, mainly used in Taiwan.
GB2312 | 936 | Simplified Chinese, national standard character set.
BIG5-HKSCS | Big5 with Hong Kong extensions, Traditional Chinese.
Shift_JIS | SJIS, 932 | Japanese
EUC-JP | EUCJP | Japanese

Poznámka: Any other character sets are not recognized and ISO-8859-1 will be used instead.

Návratové hodnoty

Returns the decoded string.

ChangeLog (záznam změn)

Verze | Popis
5.0.0 | Support for multi-byte character sets was added.

Příklady

Příklad 2195. Decoding HTML entities

<?php
$orig = "I'll \"walk\" the <b>dog</b> now";

$a = htmlentities($orig);

$b = html_entity_decode($a);

echo $a; // I'll &quot;walk&quot; the &lt;b&gt;dog&lt;/b&gt; now

echo $b; // I'll "walk" the <b>dog</b> now

// For users prior to PHP 4.3.0 you may do this:
function unhtmlentities($string)
{
    // replace numeric entities
    $string = preg_replace('~&#x([0-9a-f]+);~ei', 'chr(hexdec("\\1"))', $string);
    $string = preg_replace('~&#([0-9]+);~e', 'chr("\\1")', $string);
    // replace literal entities
    $trans_tbl = get_html_translation_table(HTML_ENTITIES);
    $trans_tbl = array_flip($trans_tbl);
    return strtr($string, $trans_tbl);
}

$c = unhtmlentities($a);

echo $c; // I'll "walk" the <b>dog</b> now

?>

Poznámky

Poznámka: You might wonder why trim(html_entity_decode('&nbsp;')); doesn't reduce the string to an empty string, that's because the '&nbsp;' entity is not ASCII code 32 (which is stripped by trim()) but ASCII code 160 (0xa0) in the default ISO 8859-1 characterset.

Viz také

htmlentities()
htmlspecialchars()
get_html_translation_table()
urldecode()

Předcházející | Nahoru | Další
hebrevc | Domů | htmlentities


htmlentities

(PHP 4, PHP 5)

htmlentities — Převést všechny použitelné znaky na HTML entity

Popis

string htmlentities ( string $string [, int $quote_style [, string $charset]] )

Tato funkce je ve všem shodná s htmlspecialchars() kromě toho, že na HTML entity se převedou všechny znaky, které mají odpovídající entity. Stejně jako htmlspecialchars() přijímá volitelný druhý argument, který indikuje, co se má stát s jednoduchými a dvojitými uvozovkami. ENT_COMPAT (default) převede pouze dvojité uvozovky, ENT_QUOTES převede dvojité i jednoduché uvozovky, a ENT_NOQUOTES ponechá jednoduché i dvojité uvozovky bez konverze.

V současnosti se jako výchozí znaková sada používá ISO-8859-1. Volitelný druhý argument byl přidán v PHP 3.0.17 a PHP 4.0.3.

Stejně jako htmlspecialchars() lze pomocí třetího parametru nastavit znakovou sadu, která má být použita při konverzi řetězce. Tento třetí parametr byl přidán v PHP 4.1.0.

Neexistuje žádná zpětná funkce. Každopádně si můžete vytvořit vlastní. Následuje příklad jak na to.

Příklad 2196. Zpětná htmlentities()

<?php
function unhtmlentities ($string)
{
    $trans_tbl = get_html_translation_table (HTML_ENTITIES);
    $trans_tbl = array_flip ($trans_tbl);
    return strtr ($string, $trans_tbl);
}
?>

Viz také: htmlspecialchars() a nl2br().

Předcházející | Nahoru | Další
html_entity_decode | Domů | htmlspecialchars_decode


htmlspecialchars

(PHP 4, PHP 5)

htmlspecialchars — Převést zvláštní znaky na HTML entity

Popis

string htmlspecialchars ( string $string [, int $quote_style [, string $charset]] )

Některé znaky mají v HTML zvláštní význam, a pokud si mají zachovat běžný význam, měly by být reprezentovány HTML entitami. Tato funkce vrací řetězec, ve kterém došlo k některým z těchto konverzí; provádějí se ty překlady, které jsou v každodenním programování pro web nejužitečnější. Pokud požadujete překlad všech znakových entit HTML, použijte htmlentities().

Tato funkce je užitečná, pokud se chcete chránit před případným výskytem HTML v textu dodaném uživateli, například u aplikací typu kniha hostů nebo diskusní skupina. Volitelný druhý argument, quote_style, určuje, co se má stát s jednoduchými a dvojitými uvozovkami. Defaultní mód, ENT_COMPAT, je zpětně kompatibilní mód, konvertuje pouze dvojité uvozovky a jednoduché uvozovky ponechává nepřeložené. Pokud zadáte ENT_QUOTES, přeloží se jednoduché i dvojité uvozovky, a pokud zadáte ENT_NOQUOTES, oba druhy zůstanou bez překladu.

Dochází k těmto překladům:

  • '&' (ampersand) se stává '&amp;'
  • '"' (dvojitá uvozovka) se stává '&quot;' when ENT_NOQUOTES is not set.
  • ''' (jednoduchá uvozovka) se stává '&#039;' only when ENT_QUOTES is set.
  • '<' (menší než) se stává '&lt;'
  • '>' (větší než) se stává '&gt;'

Příklad 2198. Ukázka htmlspecialchars()

<?php
$new = htmlspecialchars("<a href='test'>Test</a>", ENT_QUOTES);
echo $new; // &lt;a href=&#039;test&#039;&gt;Test&lt;/a&gt;
?>

Poznámka: tato funkce provádí pouze výše uvedené překlady. Kompletní překlad entit viz htmlentities(). Volitelný druhý argument byl přidán v PHP 3.0.17 a PHP 4.0.3.

Třetí parametr charset definuje kódovou stránku použitou pro převod. Výchozí kódová stránka je ISO-8859-1. Třetí parametr je k dispozici od PHP 4.1.0.

Viz také get_html_translation_table(),
strip_tags(),
htmlentities() a nl2br().

Předcházející | Nahoru | Další
htmlspecialchars_decode | Domů | implode


implode

(PHP 4, PHP 5)

implode — Spojit prvky pole pomocí řetězce

Popis

string implode ( string $glue, array $pieces )

Vrací řetězec obsahující řetězcovou reprezentaci všech prvků pole v původním pořadí s řetězcem glue mezi každými dvěma prvky.

Příklad 2199. Ukázka implode()

<?php

$array = array('příjmení', 'e-mail', 'telefon');
$oddelene_carkami = implode(",", $array);

echo $oddelene_carkami; // příjmení,e-mail,telefon

?>

Poznámka: implode() může z historických důvodů přijímat argumenty v obou možných pořadích. Kvůli konzistenci s explode() se ale doporučuje používat dokumentované pořadí argumentů.

Poznámka: Od PHP 4.3.0 je parametr glue volitelný a jeho výchozí hodnota je prázdný řetězec (''). Toto použití však nedoporučujeme, pro zajištění kompatibility se staršími verzemi je lepší vždy používat dva parametry.

Viz také explode() a split().

Předcházející | Nahoru | Další
htmlspecialchars | Domů | join


join

(PHP 4, PHP 5)

join — Spojit prvky pole pomocí řetězce

Popis

string join ( string $glue, array $pieces )

Funkce join() je alias k implode(), a je ve všech ohledech stejná.

Viz také: explode(),
implode() a
split().

Předcházející | Nahoru | Další
implode | Domů | levenshtein


levenshtein

(PHP 4 >= 4.0.1, PHP 5)

levenshtein — Spočítat XXX Levenshteinovu vzdálenost mezi dvěma řetězci

Popis

int levenshtein ( string $str1, string $str2 [, int $cost_ins, int $cost_rep, int $cost_del] )

Tato funkce vrací XXX Levenshtein-Distance mezi předanými řetězci nebo -1, pokud délka jednoho z předaných řetězců přesáhne omezení 255 znaků (255 by mělo být pro běžná porovnání víc než dost, a nikdo se zdravým rozumem nebude v PHP dělat genetickou analýzu).

Levenshteinova vzdálenost se definuje jako minimální počet znaku, které musíte nahradit, vložit nebo smazat, abyste změnili str1 na str2. Složitost tohoto algoritmu je O(m*n), kde n a m jsou délky str1 a str2 (celkem slušné v porovnání se similar_text(), který je O(max(n,m)**3), ale i tak drahé).

Ve své nejjednodušší podobě tato funkce pouze vezme dva řetězce jako argumenty a spočítá počet vložení, nahrazení a smazání nutných k transformaci str1 na str2.

Druhá varianta přijme tři další argumenty, které definují náklady na operace vložení, nahrazeni a smazání. Tato varianta je všeobecnější a přizpůsobivější než varianta první, ale ne tak výkonná.

Třetí varianta (zatím neimplementovaná) bude nejvšeobecnější a nejpřizpůsobivější, ale také nejpomalejší alternativou. Bude volat uživatelskou funkci, která určí náklady na všechny možné operace.

Tato uživatelská funkce se bude volat s následujícími argumenty:

  • operatce, která se má provést: 'I', 'R' or 'D'
  • původní znak v řetězci 1
  • původní znak v řetězci 2
  • pozice v řetězci 1
  • pozice v řetězci 2
  • znaky zbývající v řetězci 1
  • znaky zbývající v řetězci 2
Tato uživatelská funkce musí vrátit kladné celé číslo vyčíslující náklady na tuto konkrétní operaci, ale může se rozhodnout použít pouze některé z přijatých argumentů.

Tento přístup nabízí možnost zohlednit důležitost určitých symbolů (znaků) a/nebo rozdíly mezi nimi, či dokonce kontext, ve kterém se vyskytují při určování nákladů na vložení, změnu nebo smazání, ale za cenu ztráty všech optimalizací využití CPU registru a XXX cache misses, které byly zapracovány do předchozích dvou variant.

Viz také: soundex(),
similar_text() a
metaphone().

Předcházející | Nahoru | Další
join | Domů | localeconv


localeconv

(PHP 4 >= 4.0.5, PHP 5)

localeconv — Get numeric formatting information

Popis

array localeconv ( void )

Returns an associative array containing localized numeric and monetary formatting information.

Návratové hodnoty

localeconv() returns data based upon the current locale as set by setlocale(). The associative array that is returned contains the following fields:

Array element | Description
decimal_point | Decimal point character
thousands_sep | Thousands separator
grouping | Array containing numeric groupings
int_curr_symbol | International currency symbol (i.e. USD)
currency_symbol | Local currency symbol (i.e. $)
mon_decimal_point | Monetary decimal point character
mon_thousands_sep | Monetary thousands separator
mon_grouping | Array containing monetary groupings
positive_sign | Sign for positive values
negative_sign | Sign for negative values
int_frac_digits | International fractional digits
frac_digits | Local fractional digits
p_cs_precedes | TRUE if currency_symbol precedes a positive value, FALSE if it succeeds one
p_sep_by_space | TRUE if a space separates currency_symbol from a positive value, FALSE otherwise
n_cs_precedes | TRUE if currency_symbol precedes a negative value, FALSE if it succeeds one
n_sep_by_space | TRUE if a space separates currency_symbol from a negative value, FALSE otherwise
p_sign_posn
0 - Parentheses surround the quantity and currency_symbol
1 - The sign string precedes the quantity and currency_symbol
2 - The sign string succeeds the quantity and currency_symbol
3 - The sign string immediately precedes the currency_symbol
4 - The sign string immediately succeeds the currency_symbol
n_sign_posn
0 - Parentheses surround the quantity and currency_symbol
1 - The sign string precedes the quantity and currency_symbol
2 - The sign string succeeds the quantity and currency_symbol
3 - The sign string immediately precedes the currency_symbol
4 - The sign string immediately succeeds the currency_symbol

The p_sign_posn, and n_sign_posn contain a string of formatting options. Each number representing one of the above listed conditions.

The grouping fields contain arrays that define the way numbers should be grouped. For example, the monetary grouping field for the nl_NL locale (in UTF-8 mode with the euro sign), would contain a 2 item array with the values 3 and 3. The higher the index in the array, the farther left the grouping is. If an array element is equal to CHAR_MAX, no further grouping is done. If an array element is equal to 0, the previous element should be used.

Příklady

Příklad 2200. localeconv() example

<?php
if (false !== setlocale(LC_ALL, 'nl_NL.UTF-8@euro')) {
    $locale_info = localeconv();
    print_r($locale_info);
}
?>

Výše uvedený příklad vypíše:

Array
(
    [decimal_point] => .
    [thousands_sep] =>
    [int_curr_symbol] => EUR
    [currency_symbol] => €
    [mon_decimal_point] => ,
    [mon_thousands_sep] =>
    [positive_sign] =>
    [negative_sign] => -
    [int_frac_digits] => 2
    [frac_digits] => 2
    [p_cs_precedes] => 1
    [p_sep_by_space] => 1
    [n_cs_precedes] => 1
    [n_sep_by_space] => 1
    [p_sign_posn] => 1
    [n_sign_posn] => 2
    [grouping] => Array
        (
        )

    [mon_grouping] => Array
        (
            [0] => 3
            [1] => 3
        )

)

Viz také

setlocale()

Předcházející | Nahoru | Další
levenshtein | Domů | ltrim


ltrim

(PHP 4, PHP 5)

ltrim — Odstranit netisknutelné znaky ze začátku řetězce

Popis

string ltrim ( string $str [, string $charlist] )

Tato funkce ořízne netisknutelné znaky ze začátku řetězce a vrací oříznutý řetězec. Netisknutelné znaky, které se v současnosti odstraňují, jsou: "\n", "\r", "\t", "\v", "\0", a prostá mezera.

Viz také: chop(),
rtrim() a
trim().

Předcházející | Nahoru | Další
localeconv | Domů | md5_file


md5_file

(PHP 4 >= 4.2.0, PHP 5, PECL hash:1.1-1.3)

md5_file — Calculates the md5 hash of a given file

Popis

string md5_file ( string $filename [, bool $raw_output] )

Calculates the MD5 hash of the file specified by the filename parameter using the » RSA Data Security, Inc. MD5 Message-Digest Algorithm, and returns that hash. The hash is a 32-character hexadecimal number.

Seznam parametrů

filename

The filename

raw_output

When TRUE, returns the digest in raw binary format with a length of 16. Defaults to FALSE.

Návratové hodnoty

Returns a string on success, FALSE otherwise.

ChangeLog (záznam změn)

Verze | Popis
5.0.0 | Added the raw_output parameter
5.1.0 | Changed the function to use the streams API. It means that you can use it with wrappers, like md5_file('http://example.com/..')

Viz také

md5()
sha1_file()
crc32()

Předcházející | Nahoru | Další
ltrim | Domů | md5


md5

(PHP 4, PHP 5, PECL hash:1.1-1.3)

md5 — Spočítat MD5 hash řetězce

Popis

string md5 ( string $str [, bool $raw_output] )

Spočítá MD5 hash argumentu str pomocí » MD5 Message-Digest Algoritmu společnosti RSA Data Security, Inc. a vrátí tento hash. Pokud je volitelný parametr raw_output nastaven na TRUE, je vrácen md5 otisk v binárním formátu délky 16 bytů.

Poznámka: Volitelný parametr raw_output byl přidán ve verzi PHP 5.0.0 a jeho výchozí hodnota je FALSE

Příklad 2201. Příklad md5()

<?php
$str = 'apple';

if (md5($str) === '1f3870be274f6c49b3e31a0c6728957f') {
    echo "Přejete si zelené nebo červené jablko?";
    exit;
}
?>

Viz také crc32(), md5_file() a sha1().

Předcházející | Nahoru | Další
md5_file | Domů | metaphone


metaphone

(PHP 4, PHP 5)

metaphone — Spočítat metaphone klíč řetězce

Popis

string metaphone ( string $str [, int $phones] )

Spočítá metaphone klíč argumentu str.

metaphone(), podobně jako soundex(), vytvoří stejný klíč pro podobně znějící slova. Je přesnější než soundex(), protože zná základní pravidla anglické výslovnosti. Metaphone klíče mají proměnlivou délku.

Metaphone vyvinul Lawrence Philips <lphilips@verity.com>. Je popsáno v ["Practical Algorithms for Programmers", Binstock & Rex, Addison Wesley, 1995].

Poznámka: Tato funkce byla přidána v PHP 4.0.

Předcházející | Nahoru | Další
md5 | Domů | money_format


money_format

(PHP 4 >= 4.3.0, PHP 5)

money_format — Formats a number as a currency string

Popis

string money_format ( string $format, float $number )

money_format() returns a formatted version of number. This function wraps the C library function strfmon(), with the difference that this implementation converts only one number at a time.

Seznam parametrů

format

The format specification consists of the following sequence:

  • a % character

  • optional flags

  • optional field width

  • optional left precision

  • optional right precision

  • a required conversion character

Flags.

One or more of the optional flags below can be used:

=f

The character = followed by a (single byte) character f to be used as the numeric fill character. The default fill character is space.

^

Disable the use of grouping characters (as defined by the current locale).

+ or (

Specify the formatting style for positive and negative numbers. If + is used, the locale's equivalent for + and - will be used. If ( is used, negative amounts are enclosed in parenthesis. If no specification is given, the default is +.

!

Suppress the currency symbol from the output string.

-

If present, it will make all fields left-justified (padded to the right), as opposed to the default which is for the fields to be right-justified (padded to the left).

Field width.

w

A decimal digit string specifying a minimum field width. Field will be right-justified unless the flag - is used. Default value is 0 (zero).

Left precision.

#n

The maximum number of digits (n) expected to the left of the decimal character (e.g. the decimal point). It is used usually to keep formatted output aligned in the same columns, using the fill character if the number of digits is less than n. If the number of actual digits is bigger than n, then this specification is ignored.

If grouping has not been suppressed using the ^ flag, grouping separators will be inserted before the fill characters (if any) are added. Grouping separators will not be applied to fill characters, even if the fill character is a digit.

To ensure alignment, any characters appearing before or after the number in the formatted output such as currency or sign symbols are padded as necessary with space characters to make their positive and negative formats an equal length.

Right precision .

.p

A period followed by the number of digits (p) after the decimal character. If the value of p is 0 (zero), the decimal character and the digits to its right will be omitted. If no right precision is included, the default will dictated by the current local in use. The amount being formatted is rounded to the specified number of digits prior to formatting.

Conversion characters .

i

The number is formatted according to the locale's international currency format (e.g. for the USA locale: USD 1,234.56).

n

The number is formatted according to the locale's national currency format (e.g. for the de_DE locale: DM1.234,56).

%

Returns the % character.

number

The number to be formatted.

Návratové hodnoty

Returns the formatted string. Characters before and after the formatting string will be returned unchanged.

Poznámky

Poznámka: The function money_format() is only defined if the system has strfmon capabilities. For example, Windows does not, so money_format() is undefined in Windows.

Poznámka: The LC_MONETARY category of the locale settings, affects the behavior of this function. Use setlocale() to set to the appropriate default locale before using this function.

Příklady

Příklad 2202. money_format() Example

We will use different locales and format specifications to illustrate the use of this function.

<?php

$number = 1234.56;

// let's print the international format for the en_US locale
setlocale(LC_MONETARY, 'en_US');
echo money_format('%i', $number) . "\n";
// USD 1,234.56

// Italian national format with 2 decimals`
setlocale(LC_MONETARY, 'it_IT');
echo money_format('%.2n', $number) . "\n";
// L. 1.234,56

// Using a negative number
$number = -1234.5672;

// US national format, using () for negative numbers
// and 10 digits for left precision
setlocale(LC_MONETARY, 'en_US');
echo money_format('%(#10n', $number) . "\n";
// ($        1,234.57)

// Similar format as above, adding the use of 2 digits of right
// precision and '*' as a fill character
echo money_format('%=*(#10.2n', $number) . "\n";
// ($********1,234.57)

// Let's justify to the left, with 14 positions of width, 8 digits of
// left precision, 2 of right precision, withouth grouping character
// and using the international format for the de_DE locale.
setlocale(LC_MONETARY, 'de_DE');
echo money_format('%=*^-14#8.2i', 1234.56) . "\n";
// DEM 1234,56****

// Let's add some blurb before and after the conversion specification
setlocale(LC_MONETARY, 'en_GB');
$fmt = 'The final value is %i (after a 10%% discount)';
echo money_format($fmt, 1234.56) . "\n";
// The final value is  GBP 1,234.56 (after a 10% discount)

?>

Viz také

setlocale()
sscanf()
sprintf()
printf()
number_format()

Předcházející | Nahoru | Další
metaphone | Domů | nl_langinfo


nl_langinfo

(PHP 4 >= 4.0.7, PHP 5)

nl_langinfo — Query language and locale information

Popis

string nl_langinfo ( int $item )

nl_langinfo() is used to access individual elements of the locale categories. Unlike localeconv(), which returns all of the elements, nl_langinfo() allows you to select any specific element.

Seznam parametrů

item

item may be an integer value of the element or the constant name of the element. The following is a list of constant names for item that may be used and their description. Some of these constants may not be defined or hold no value for certain locales.

Tabulka 301. nl_langinfo Constants

Constant | Description
LC_TIME Category Constants
ABDAY_(1-7) | Abbreviated name of n-th day of the week.
DAY_(1-7) | Name of the n-th day of the week (DAY_1 = Sunday).
ABMON_(1-12) | Abbreviated name of the n-th month of the year.
MON_(1-12) | Name of the n-th month of the year.
AM_STR | String for Ante meridian.
PM_STR | String for Post meridian.
D_T_FMT | String that can be used as the format string for strftime() to represent time and date.
D_FMT | String that can be used as the format string for strftime() to represent date.
T_FMT | String that can be used as the format string for strftime() to represent time.
T_FMT_AMPM | String that can be used as the format string for strftime() to represent time in 12-hour format with ante/post meridian.
ERA | Alternate era.
ERA_YEAR | Year in alternate era format.
ERA_D_T_FMT | Date and time in alternate era format (string can be used in strftime()).
ERA_D_FMT | Date in alternate era format (string can be used in strftime()).
ERA_T_FMT | Time in alternate era format (string can be used in strftime()).
LC_MONETARY Category Constants
INT_CURR_SYMBOL | International currency symbol.
CURRENCY_SYMBOL | Local currency symbol.
CRNCYSTR | Same value as CURRENCY_SYMBOL.
MON_DECIMAL_POINT | Decimal point character.
MON_THOUSANDS_SEP | Thousands separator (groups of three digits).
MON_GROUPING | Like 'grouping' element.
POSITIVE_SIGN | Sign for positive values.
NEGATIVE_SIGN | Sign for negative values.
INT_FRAC_DIGITS | International fractional digits.
FRAC_DIGITS | Local fractional digits.
P_CS_PRECEDES | Returns 1 if CURRENCY_SYMBOL precedes a positive value.
P_SEP_BY_SPACE | Returns 1 if a space separates CURRENCY_SYMBOL from a positive value.
N_CS_PRECEDES | Returns 1 if CURRENCY_SYMBOL precedes a negative value.
N_SEP_BY_SPACE | Returns 1 if a space separates CURRENCY_SYMBOL from a negative value.
P_SIGN_POSN
  • Returns 0 if parentheses surround the quantity and currency_symbol.
  • Returns 1 if the sign string precedes the quantity and currency_symbol.
  • Returns 2 if the sign string follows the quantity and currency_symbol.
  • Returns 3 if the sign string immediately precedes the currency_symbol.
  • Returns 4 if the sign string immediately follows the currency_symbol.
N_SIGN_POSN
LC_NUMERIC Category Constants
DECIMAL_POINT | Decimal point character.
RADIXCHAR | Same value as DECIMAL_POINT.
THOUSANDS_SEP | Separator character for thousands (groups of three digits).
THOUSEP | Same value as THOUSANDS_SEP.
GROUPING
LC_MESSAGES Category Constants
YESEXPR | Regex string for matching 'yes' input.
NOEXPR | Regex string for matching 'no' input.
YESSTR | Output string for 'yes'.
NOSTR | Output string for 'no'.
LC_CTYPE Category Constants
CODESET | Return a string with the name of the character encoding.

Návratové hodnoty

Returns the element as a string, or FALSE if item is not valid.

Poznámky

Poznámka: Tato funkce není implementována na platformách Windows.

Viz také

setlocale()
localeconv()

Předcházející | Nahoru | Další
money_format | Domů | nl2br


nl2br

(PHP 4, PHP 5)

nl2br — Před všechny konce řádků v řetězci vloží HTML konce řádků

Popis

string nl2br ( string $string )

Vrací string, ve kterém je před každý konec řádku vložena značka '<br />'.

Poznámka: Od PHP 4.0.5, je funkce nl2br() XHTML způsobilá. Všechny verze před 4.0.5 vrátí string se značkou '<br>' vloženou před konce řádků místo '<br />'.

Příklad 2203. Použití nl2br()

<?php
echo nl2br("foo není\n bar");
?>

Vypíše:

foo není<br />
 bar

Viz také htmlspecialchars(),
htmlentities(),
wordwrap() a
str_replace().

Předcházející | Nahoru | Další
nl_langinfo | Domů | number_format


number_format

(PHP 4, PHP 5)

number_format — Format a number with grouped thousands

Description

string number_format ( float $number [, int $decimals [, string $dec_point, string $thousands_sep]] )

number_format() returns a formatted version of number. This function accepts either one, two or four parameters (not three):

If only one parameter is given, number will be formatted without decimals, but with a comma (",") between every group of thousands.

If two parameters are given, number will be formatted with decimals decimals with a dot (".") in front, and a comma (",") between every group of thousands.

If all four parameters are given, number will be formatted with decimals decimals, dec_point instead of a dot (".") before the decimals and thousands_sep instead of a comma (",") between every group of thousands.

Only the first character of thousands_sep is used. For example, if you use bar as thousands_sep on the number 1000, number_format() will return 1b000.

Příklad 2204. number_format() Example

For instance, French notation usually use two decimals, comma (',') as decimal separator, and space (' ') as thousand separator. This is achieved with this line :

<?php

$number = 1234.56;

// english notation (default)
$english_format_number = number_format($number);
// 1,235

// French notation
$nombre_format_francais = number_format($number, 2, ',', ' ');
// 1 234,56

$number = 1234.5678;

// english notation without thousands seperator
$english_format_number = number_format($number, 2, '.', '');
// 1234.57

?>

See also: money_format(), sprintf(), printf() and sscanf().

Předcházející | Nahoru | Další
nl2br | Domů | ord


ord

(PHP 4, PHP 5)

ord — Vrátit ASCII hodnotu znaku

Popis

int ord ( string $string )

Vrací ASCII hodnotu prvního znaku v string. Tato funkce doplňuje chr().

Příklad 2205. Ukázka ord()

if (ord ($str) == 10) {
    echo "Prvním znakem \$str je line feed.\n";
}

Viz také: chr().

Předcházející | Nahoru | Další
number_format | Domů | parse_str


parse_str

(PHP 4, PHP 5)

parse_str — Rozparsovat řetězec do proměnných

Popis

void parse_str ( string $str [, array &$arr] )

Rozparsuje řetězec jako kdyby to byl query-string předaný v URL a definuje příslušné proměnné v současném rozsahu platnosti. Pokud je předán druhý argument arr, proměnné se místo toho uloží do této proměnné jako pole.

Poznámka: Volitelný druhý parametr je k dispozici od PHP 4.0.3.

Poznámka: Pro získání aktuálního QUERY_STRING, možná budete muset použít proměnnou $_SERVER['QUERY_STRING']. Možná vás také bude zajímat kapitola proměnné mimo PHP.

Příklad 2206. Použití parse_str()

<?php
$str = "first=value&arr[]=foo+bar&arr[]=baz";
parse_str($str);
echo $first;  // value
echo $arr[0]; // foo bar
echo $arr[1]; // baz

parse_str($str, $output);
echo $output['first'];  // value
echo $output['arr'][0]; // foo bar
echo $output['arr'][1]; // baz

?>

Viz také parse_url(), pathinfo(), set_magic_quotes_runtime() a urldecode().

Předcházející | Nahoru | Další
ord | Domů | print


print

(PHP 4, PHP 5)

print — Vytisknout řetězec

Popis

int print ( string $arg )

Vytiskne arg.

Viz také: echo(),
printf() a
flush().

Předcházející | Nahoru | Další
parse_str | Domů | printf


printf

(PHP 4, PHP 5)

printf — Vytisknout formátovaný řetězec

Popis

int printf ( string $format [, mixed $args [, mixed $...]] )

Vytvoří výtup podle argumentu format, který je popsán v dokumentaci sprintf().

Viz také: print(),
sprintf(),
sscanf(),
fscanf() a
flush().

Předcházející | Nahoru | Další
print | Domů | quoted_printable_decode


quoted_printable_decode

(PHP 4, PHP 5)

quoted_printable_decode — Převést quoted-printable řetězec na osmibitový řetězec

Popis

string quoted_printable_decode ( string $str )

Tato funkce vrací osmibitový binární řetězec odpovídající dekódovanému quoted printable řetězci. Tato funkce je podobná imap_qprint() s tou výjimkou, že tato funkce nevyžaduje IMAP modul.

Předcházející | Nahoru | Další
printf | Domů | quotemeta


quotemeta

(PHP 4, PHP 5)

quotemeta — Opatřit lomítky metaznaky

Popis

string quotemeta ( string $str )

Vrací verzi str se zpětným lomítkem před všemi výskyty následujících znaků:

. \\ + * ? [ ^ ] ( $ )

Viz také: addslashes(),
htmlentities(),
htmlspecialchars(),
nl2br() a
stripslashes().

Předcházející | Nahoru | Další
quoted_printable_decode | Domů | rtrim


rtrim

(PHP 4, PHP 5)

rtrim — Odstranit netisknutelné znaky z konce řetězce

Popis

string rtrim ( string $str [, string $charlist] )

Vrací předaný řetězec bez netisknutelných znaků (vč. konců řádku) na konci. Toto je alias k chop().

Příklad 2207. Ukázka rtrim()

$trimmed = rtrim ($line);

Viz také: trim(),
ltrim() a
rtrim().

Předcházející | Nahoru | Další
quotemeta | Domů | setlocale


setlocale

(PHP 4, PHP 5)

setlocale — Set locale information

Popis

string setlocale ( int $category, string $locale [, string $...] )
string setlocale ( int $category, array $locale )

category je řetězec určující kategorii funkcí ovlivněných nastavením locale:

  • LC_ALL pro všechny níže uvedené kategorie
  • LC_COLLATE pro porovnávání řetězců - v PHP v současnosti neimplementováno
  • LC_CTYPE pro klasifikaci a konverzi znaků, např. strtoupper()
  • LC_MONETARY pro localeconv() - v PHP v současnosti neimplementováno
  • LC_NUMERIC pro oddělovač desetinných míst
  • LC_TIME pro formátování data a času pomocí strftime()

Pokud je locale prázný řetězec (""), názvy locale se nastaví na hodnoty systémových proměnných se stejnými jmény jako mají výše uvedené kategorie, nebo z "LANG".

Pokud je locale nula nebo "0", locale se nezmění, pouze se vrátí současná hodnota.

setlocale() vrací nové aktuální locale nebo FALSE, pokud na dotyčné platformě není funkcionalita locale implementována, zadané locale neexistuje, nebo je název kategorie neplatný. Neplatný název kategorie také vyvolá varování.

Předcházející | Nahoru | Další
rtrim | Domů | sha1_file


sha1_file

(PHP 4 >= 4.3.0, PHP 5, PECL hash:1.1-1.3)

sha1_file — Calculate the sha1 hash of a file

Popis

string sha1_file ( string $filename [, bool $raw_output] )

Calculates the sha1 hash of filename using the » US Secure Hash Algorithm 1, and returns that hash. The hash is a 40-character hexadecimal number.

Seznam parametrů

filename

The filename

raw_output

When TRUE, returns the digest in raw binary format with a length of 20. Defaults to FALSE.

Návratové hodnoty

Returns a string on success, FALSE otherwise.

ChangeLog (záznam změn)

Verze | Popis
5.0.0 | Added the raw_output parameter
5.1.0 | Changed the function to use the streams API. It means that you can use it with wrappers, like sha1_file('http://example.com/..')

Viz také

sha1()
md5_file()
crc32()

Předcházející | Nahoru | Další
setlocale | Domů | sha1


sha1

(PHP 4 >= 4.3.0, PHP 5, PECL hash:1.1-1.3)

sha1 — Calculate the sha1 hash of a string

Popis

string sha1 ( string $str [, bool $raw_output] )

Calculates the sha1 hash of str using the » US Secure Hash Algorithm 1,

Seznam parametrů

str

The input string.

raw_output

If the optional raw_output is set to TRUE, then the sha1 digest is instead returned in raw binary format with a length of 20, otherwise the returned value is a 40-character hexadecimal number. Defaults to FALSE.

Návratové hodnoty

Returns the sha1 hash as a string.

ChangeLog (záznam změn)

Verze | Popis
5.0.0 | The raw_output parameter was added.

Příklady

Příklad 2208. A sha1() example

<?php
$str = 'apple';

if (sha1($str) === 'd0be2dc421be4fcd0172e5afceea3970e2f3d940') {
    echo "Would you like a green or red apple?";
    exit;
}
?>

Viz také

sha1_file()
crc32()
md5()

Předcházející | Nahoru | Další
sha1_file | Domů | similar_text


similar_text

(PHP 4, PHP 5)

similar_text — Spočítat podobnost dvou řetězců

Popis

int similar_text ( string $first, string $second [, float &$percent] )

similar_text() spočítá podobnost dvou řetězců podle Oliver [1993]. Pozn.: Tato implementace nepoužívá stack jako v Oliverově pseudokódu, nýbrž rekurzivní volání, což může či nemusí celý proces zrychlit. Komplexita tohoto algoritmu je O(N**3) kde N je délka nejdelšího řetězce.

Pokud je similar_text() předán třetí argument (odkazem), spočítá tato funkce podobnost v procentech. Vrací počet znaků shodných v obou řetězcích.

Předcházející | Nahoru | Další
sha1 | Domů | soundex


soundex

(PHP 4, PHP 5)

soundex — Spočítat soundex klíč řetězce

Popis

string soundex ( string $str )

Spočítá soundex klíč str.

Soundex klíče mají tu vlastnost, že slova vyslovovaná podobně produkují shodné soundex klíče, a dají se proto využít ke zjednodušení hledání v databázích, kde znáte výslovnost, ale ne hláskování. Tato funkce vrací řetězec dlouhý 4 znaky začínající písmenem.

Tato konkrétní soundex funkce je popsána Donaldem Knuthem v "The Art Of Computer Programming, vol. 3: Sorting And Searching", Addison-Wesley (1973), pp. 391-392.

Příklad 2209. Soundex ukázky

soundex ("Euler") == soundex ("Ellery") == 'E460';
soundex ("Gauss") == soundex ("Ghosh") == 'G200';
soundex ("Hilbert") == soundex ("Heilbronn") == 'H416';
soundex ("Knuth") == soundex ("Kant") == 'K530';
soundex ("Lloyd") == soundex ("Ladd") == 'L300';
soundex ("Lukasiewicz") == soundex ("Lissajous") == 'L222';

Předcházející | Nahoru | Další
similar_text | Domů | sprintf


sprintf

(PHP 4, PHP 5)

sprintf — Vrátit formátovaný řetězec

Popis

string sprintf ( string $format [, mixed $args [, mixed $...]] )

Vrací řetězec vytvořený podle formátovacího řetězce format.

Formátovací řetězec se skládá z nula nebo více direktiv: běžných znaků (kromě %), které se přímo kopírují do výsledku, a převodních specifikací, z nichž každá přijímá jeden argument. Toto platí pro sprintf() i printf().

Každá převodní specifikace se skládá ze znaku procenta (%), následovaného jedním nebo více z těchto znaků, v tomto pořadí:

  1. Volitelný padding specifier, který určuje, jaký znak se použije na doplnění výsledku na správnou délku řetězce. Může to být mezera nebo 0 (písmeno nula). Default je nula. Jiný doplňující znak můžete zadat tak, že před něj předřadíte jednoduchou uvozovku ('). Viz ukázky níže.
  2. Volitelný alignment specifier, který určuje, jestli se má výsledek zarovnat doleva nebo doprava. Default je doprava, pomlčka (-) to změní na doleva.
  3. Volitelné číslo width specifier, které určuje, kolik znaků (minimálně) má obsahovat výsledek převodu.
  4. Volitelný precision specifier, který určuje, kolik desetinných míst se má zobrazit u čísel s desetinnou čárkou. Tento přepínač nemá žádný vliv na jiné typy než double. (Další funkcí užitečnou na formátování čísel je number_format().)

  5. type specifier, který určuje, za jaký typ se mají data argumentu považovat. Možné typy:

    % - a doslovný znak procenta. Nevyžaduje se žádný argument.
    b - argument se považuje za integer a je prezentován jako binární číslo.
    c - argument se považuje za integer a je prezentován jako znak s touto ASCII hodnotou.
    d - argument se považuje za integer a je prezentován jako desítkové číslo.
    f - argument se považuje za double a je prezentován jako číslo s plovoucí desetinou čárkou.
    o - argument se považuje za integer a je prezentován jako oktalové číslo.
    s - argument se považuje za řetězec a je takto prezentován.
    x - the argument se považuje za integer a je prezentován jako hexadecimální číslo (s malými písmeny).
    X - argument se považuje za integer a je prezentován jako hexadecimální číslo (s kapitálkami).

   Viz také: printf(),
   sscanf(),
fscanf() a
number_format().

Ukázky

Příklad 2210. Ukázka sprintf(): zero-padded integers

$isodate = sprintf ("%04d-%02d-%02d", $year, $month, $day);

Příklad 2211. Ukázka sprintf(): formatting currency

$money1 = 68.75;
$money2 = 54.35;
$money = $money1 + $money2;
// echo $money will output "123.1";
$formatted = sprintf ("%01.2f", $money);
// echo $formatted will output "123.10"

Předcházející | Nahoru | Další
soundex | Domů | sscanf


sscanf

(PHP 4 >= 4.0.1, PHP 5)

sscanf — Rozparsovat vstupní řetězec podle formátu

Popis

mixed sscanf ( string $str, string $format [, mixed &$...] )

Funkce sscanf() je vstupním analogem printf(). sscanf() čte řetězec str a interpretuje ho podle formátu format. Pokud jsou jí předány pouze dva argumenty, vrací rozparsované hodnoty v poli.

Příklad 2212. Ukázka sscanf()

// zjištění sériového čísla
$serial = sscanf("SN/2350001","SN/%d");
// a data výroby
$mandate = "January 01 2000";
list($month, $day, $year) = sscanf($mandate,"%s %d %d");
echo "Zboží $serial bylo vyrobeno: $year-".substr($month,0,3)."-$day\n";

Pokud jsou jí předány volitelné argumenty, vrací tato funkce počet přiřazených hodnot. Volitelné argumenty musí být předány odkazem.

Příklad 2213. Ukázka sscanf() - použití volitelných argumentů

// zjistit informace o autorovi a vygenerovat DocBook záznam
$auth = "24\tLewis Carroll";
$n = sscanf($auth,"%d\t%s %s", &$id, &$first, &$last);
echo "<author xml:id='$id'>
    <firstname>$first</firstname>
    <surname>$last</surname>
</author>\n";

Viz také: fscanf(),
printf() a
sprintf().

Předcházející | Nahoru | Další
sprintf | Domů | str_getcsv


str_ireplace

(PHP 5)

str_ireplace — Case-insensitive version of str_replace().

Popis

mixed str_ireplace ( mixed $search, mixed $replace, mixed $subject [, int &$count] )

This function returns a string or an array with all occurrences of search in subject (ignoring case) replaced with the given replace value. If you don't need fancy replacing rules, you should generally use this function instead of eregi_replace() or preg_replace() with the i modifier.

Seznam parametrů

search

Poznámka: Every replacement with search array is performed on the result of previous replacement.

replace

subject

If subject is an array, then the search and replace is performed with every entry of subject, and the return value is an array as well.

count

The number of matched and replaced needles will be returned in count which is passed by reference.

If search and replace are arrays, then str_ireplace() takes a value from each array and uses them to do search and replace on subject. If replace has fewer values than search, then an empty string is used for the rest of replacement values. If search is an array and replace is a string; then this replacement string is used for every value of search.

Návratové hodnoty

Returns a string or an array of replacements.

ChangeLog (záznam změn)

Verze | Popis
5.0.0 | The count parameter was added.

Příklady

Příklad 2214. str_ireplace() example

<?php
$bodytag = str_ireplace("%body%", "black", "<body text=%BODY%>");
?>

Poznámky

Poznámka: This function is binary safe.

Viz také

str_replace()
preg_replace()
strtr()

Předcházející | Nahoru | Další
str_getcsv | Domů | str_pad


str_pad

(PHP 4 >= 4.0.1, PHP 5)

str_pad — Doplnit řetězec jiným řetězcem na určitou délku

Popis

string str_pad ( string $input, int $pad_length [, string $pad_string [, int $pad_type]] )

str_pad() doplní řetězec input zleva, zprava nebo z obou stran na danou délku. Pokud jí není předán volitelný argument pad_string, doplní se input mezerami, jinak se doplní znaky z pad_string.

Volitelný argument pad_type může nabýt hodnot STR_PAD_RIGHT, STR_PAD_LEFT nebo STR_PAD_BOTH. Default je STR_PAD_RIGHT.

Pokud je hodnota pad_length negativní nebo menší než je délka input, k doplnění nedojde.

Příklad 2215. Ukázka str_pad()

$input = "Alien";
print str_pad($input, 10);                      // produces "Alien     "
print str_pad($input, 10, "-=", STR_PAD_LEFT);  // produces "-=-=-Alien"
print str_pad($input, 10, "_", STR_PAD_BOTH);   // produces "__Alien___"

Předcházející | Nahoru | Další
str_ireplace | Domů | str_repeat


str_repeat

(PHP 4, PHP 5)

str_repeat — Opakovat řetězec

Popis

string str_repeat ( string $input, int $multiplier )

Vrací input_str multiplier krát opakovaný. multiplier musí být větší než 0.

Příklad 2216. Ukázka str_repeat()

echo str_repeat ("-=", 10);

This will output "-=-=-=-=-=-=-=-=-=-=".

Poznámka: Tato funkce byla přidána v PHP 4.0.

Předcházející | Nahoru | Další
str_pad | Domů | str_replace


str_replace

(PHP 4, PHP 5)

str_replace — Nahradit všechny výskyty jednoho řetězce dalším řetězcem

Popis

mixed str_replace ( mixed $search, mixed $replace, mixed $subject [, int &$count] )

Tato funkce nahradí všechny výskyty needle v argumentu haystack argumentem str. Pokud nepotřebujete složitá pravidla pro nahrazování, měli byste vždy použít tuto funkci místo ereg_replace() nebo preg_replace().

Od PHP 4.0.5 může být každý parametr funkce str_replace() typu array.

Varování

V PHP verzích starších než 4.3.3 byla chyba při používání polí v parametrech search a zároveň replace, která způsobila, že prázdné položky pole search byly přeskočeny bez zvýšení interního ukazatele v poli replace. Bylo to opraveno v PHP 4.3.3. Všechny skripty, které na tuto chybu spoléhaly, by měly před zavoláním této funkce odstranit prázdné hodnoty vyhledávání, aby nasimulovaly původní chování.

Pokud je parametr subject pole, proběhne vyhledávání a nahrazení v každé položce pole subject a návratová hodnota je také pole.

Pokud jsou parametry search a replace pole, funkce str_replace() bere hodnoty těchto polí a používá je pro vyhledávání a nahrazení v parametru subject. Pokud má parametr replace méně hodnot než parametr search, tak se pro chybějící hodnoty použije prázdný řetězec. Pokud je parametr search pole a parametr replace je řetězec, tak se tento řetězec použije pro každou hodnotu parametru search.

Příklad 2217. Ukázka str_replace()

<?php
// Vrátí: <body text='black'>
$bodytag = str_replace("%body%", "black", "<body text='%body%'>");

// Vrátí: Hll Wrld f PHP
$vowels = array("a", "e", "i", "o", "u", "A", "E", "I", "O", "U");
$onlyconsonants = str_replace($vowels, "", "Hello World of PHP");

// Vrátí: You should eat pizza, beer, and ice cream every day
$phrase  = "You should eat fruits, vegetables, and fiber every day.";
$healthy = array("fruits", "vegetables", "fiber");
$yummy   = array("pizza", "beer", "ice cream");

$newphrase = str_replace($healthy, $yummy, $phrase);

// Parametr count je k dispozici od PHP 5.0.0
$str = str_replace("ll", "", "good golly miss molly!", $count);
echo $count; // 2
?>

Poznámka: Tato funkce je binárně bezpečná.

Poznámka: Od PHP 5.0.0 je počet nalezených a zaměněných řetězců (search) vrácen v parametru count, který je předáván referencí. Před PHP 5.0.0 není tento parametr k dispozici.

Viz také
str_ireplace(),
substr_replace(),
ereg_replace(),
preg_replace() a
strtr().

Předcházející | Nahoru | Další
str_repeat | Domů | str_rot13


str_rot13

(PHP 4 >= 4.2.0, PHP 5)

str_rot13 — Perform the rot13 transform on a string

Popis

string str_rot13 ( string $str )

Performs the ROT13 encoding on the str argument and returns the resulting string.

The ROT13 encoding simply shifts every letter by 13 places in the alphabet while leaving non-alpha characters untouched. Encoding and decoding are done by the same function, passing an encoded string as argument will return the original version.

Seznam parametrů

str

The input string.

Návratové hodnoty

Returns the ROT13 version of the given string.

Příklady

Příklad 2218. str_rot13() example

<?php

echo str_rot13('PHP 4.3.0'); // CUC 4.3.0

?>

ChangeLog (záznam změn)

Verze | Popis
4.3.0 | The behaviour of this function was fixed. Before this fix, the str was also modified, as if it was passed by reference.

Předcházející | Nahoru | Další
str_replace | Domů | str_shuffle


str_shuffle

(PHP 4 >= 4.3.0, PHP 5)

str_shuffle — Randomly shuffles a string

Popis

string str_shuffle ( string $str )

str_shuffle() shuffles a string. One permutation of all possible is created.

Seznam parametrů

str

The input string.

Návratové hodnoty

Returns the shuffled string.

Příklady

Příklad 2219. str_shuffle() example

<?php
$str = 'abcdef';
$shuffled = str_shuffle($str);

// This will echo something like: bfdaec
echo $shuffled;
?>

Viz také

shuffle()
rand()

Předcházející | Nahoru | Další
str_rot13 | Domů | str_split


str_split

(PHP 5)

str_split — Convert a string to an array

Popis

array str_split ( string $string [, int $split_length] )

Converts a string to an array.

Seznam parametrů

string

The input string.

split_length

Maximum length of the chunk.

Návratové hodnoty

If the optional split_length parameter is specified, the returned array will be broken down into chunks with each being split_length in length, otherwise each chunk will be one character in length.

FALSE is returned if split_length is less than 1. If the split_length length exceeds the length of string, the entire string is returned as the first (and only) array element.

Příklady

Příklad 2220. Example uses of str_split()

<?php

$str = "Hello Friend";

$arr1 = str_split($str);
$arr2 = str_split($str, 3);

print_r($arr1);
print_r($arr2);

?>

Výše uvedený příklad vypíše:

Array
(
    [0] => H
    [1] => e
    [2] => l
    [3] => l
    [4] => o
    [5] =>
    [6] => F
    [7] => r
    [8] => i
    [9] => e
    [10] => n
    [11] => d
)

Array
(
    [0] => Hel
    [1] => lo
    [2] => Fri
    [3] => end
)

Viz také

chunk_split()
preg_split()
explode()
count_chars()
str_word_count()
for

Předcházející | Nahoru | Další
str_shuffle | Domů | str_word_count


str_word_count

(PHP 4 >= 4.3.0, PHP 5)

str_word_count — Return information about words used in a string

Popis

mixed str_word_count ( string $string [, int $format [, string $charlist]] )

Counts the number of words inside string. If the optional format is not specified, then the return value will be an integer representing the number of words found. In the event the format is specified, the return value will be an array, content of which is dependent on the format. The possible value for the format and the resultant outputs are listed below.

For the purpose of this function, 'word' is defined as a locale dependent string containing alphabetic characters, which also may contain, but not start with "'" and "-" characters.

Seznam parametrů

string

The string

format

Specify the return value of this function. The current supported values are:

  • 0 - returns the number of words found
  • 1 - returns an array containing all the words found inside the string
  • 2 - returns an associative array, where the key is the numeric position of the word inside the string and the value is the actual word itself

charlist

A list of additional characters which will be considered as 'word'

Návratové hodnoty

Returns an array or an integer, depending on the format chosen.

ChangeLog (záznam změn)

Verze | Popis
5.1.0 | Added the charlist parameter

Příklady

Příklad 2221. A str_word_count() example

<?php

$str = "Hello fri3nd, you're
       looking          good today!";

print_r(str_word_count($str, 1));
print_r(str_word_count($str, 2));
print_r(str_word_count($str, 1, '?á?ç3'));

echo str_word_count($str);

?>

Výše uvedený příklad vypíše:

Array
(
    [0] => Hello
    [1] => fri
    [2] => nd
    [3] => you're
    [4] => looking
    [5] => good
    [6] => today
)

Array
(
    [0] => Hello
    [6] => fri
    [10] => nd
    [14] => you're
    [29] => looking
    [46] => good
    [51] => today
)

Array
(
    [0] => Hello
    [1] => fri3nd
    [2] => you're
    [3] => looking
    [4] => good
    [5] => today
)

7

Viz také

explode()
preg_split()
split()
count_chars()
substr_count()

Předcházející | Nahoru | Další
str_split | Domů | strcasecmp


strcasecmp

(PHP 4, PHP 5)

strcasecmp — Binárně bezpečné case-insensitive porovnání řetězců

Popis

int strcasecmp ( string $str1, string $str2 )

Pokud je str1 méně než str2 vrací < 0; pokud je str1 větší než str2 vrací > 0, a 0, pokud jsou stejné.

Příklad 2222. Ukázka strcasecmp()

$var1 = "Hello";
$var2 = "hello";
if (!strcasecmp ($var1, $var2)) {
    echo 'v case-insensitive textovém porovnání se $var1 rovná $var2';
}

Viz také: ereg(),
strcmp(),
substr(),
stristr(),
strncasecmp() a
strstr().

Předcházející | Nahoru | Další
str_word_count | Domů | strchr


strchr

(PHP 4, PHP 5)

strchr — Najít první výskyt znaku

Popis

string strchr ( string $haystack, string $needle )

Tato funkce je alias k strstr(), a je ve všech směrech identická.

Předcházející | Nahoru | Další
strcasecmp | Domů | strcmp


strcmp

(PHP 4, PHP 5)

strcmp — Binárně bezpečně porovnat řetězce

Popis

int strcmp ( string $str1, string $str2 )

Pokud je str1 méně než str2, vrací < 0; pokud je str1 větší než str2, vrací > 0, a 0, pokud jsou stejné.

Pozn.: toto srovnání je case-sensitive.

Viz také: ereg(),
strcasecmp(),
substr(),
stristr(),
strncasecmp(),
strncmp() a
strstr().

Předcházející | Nahoru | Další
strchr | Domů | strcoll


strcoll

(PHP 4 >= 4.0.5, PHP 5)

strcoll — Locale based string comparison

Popis

int strcoll ( string $str1, string $str2 )

Note that this comparison is case sensitive, and unlike strcmp() this function is not binary safe.

strcoll() uses the current locale for doing the comparisons. If the current locale is C or POSIX, this function is equivalent to strcmp().

Seznam parametrů

str1

The first string.

str2

The second string.

Návratové hodnoty

Returns < 0 if str1 is less than str2; > 0 if str1 is greater than str2, and 0 if they are equal.

ChangeLog (záznam změn)

Verze | Popis
4.2.3 | This function now works on win32.

Viz také

preg_match()
strcmp()
strcasecmp()
substr()
stristr()
strncasecmp()
strncmp()
strstr()
setlocale()

Předcházející | Nahoru | Další
strcmp | Domů | strcspn


strcspn

(PHP 4, PHP 5)

strcspn — Najít délku úvodního segmentu neodpovídajícího masce

Popis

int strcspn ( string $str1, string $str2 [, int $start [, int $length]] )

Vrací délku úvodního segmentu str1, který neobsahuje žádný ze znaků str2.

Viz také: strspn().

Předcházející | Nahoru | Další
strcoll | Domů | strip_tags


strip_tags

(PHP 4, PHP 5)

strip_tags — Odstranit z řetězce HTML a PHP tagy

Popis

string strip_tags ( string $str [, string $allowable_tags] )

Tato funkce se snaží odstranit z předaného řetězce všechny HTML a PHP tagy. It errors on the side of caution in case of incomplete or bogus tags. It uses the same tag stripping state machine as the fgetss() function.

Volitelný druhý argument můžete použít k určení tagů, které se nemají odstranit.

Poznámka: Argument allowable_tags byl přidán v PHP 3.0.13, PHP 4 b3.

Předcházející | Nahoru | Další
strcspn | Domů | stripcslashes


stripcslashes

(PHP 4, PHP 5)

stripcslashes — Un-quote string quoted with addcslashes()

Popis

string stripcslashes ( string $str )

Vrací řetězec bez odstraněných zpětných lomítek. Rozeznává Céčkové \n, \r ..., oktalové a hexadecimální reprezentace.

Poznámka: Tato funkce byla přidána v PHP4b3-dev.

Viz také: addcslashes().

Předcházející | Nahoru | Další
strip_tags | Domů | stripos


stripos

(PHP 5)

stripos — Find position of first occurrence of a case-insensitive string

Popis

int stripos ( string $haystack, string $needle [, int $offset] )

Returns the numeric position of the first occurrence of needle in the haystack string.

Unlike strpos(), stripos() is case-insensitive.

Seznam parametrů

haystack

The string to search in

needle

Note that the needle may be a string of one or more characters.

If needle is not a string, it is converted to an integer and applied as the ordinal value of a character.

offset

The optional offset parameter allows you to specify which character in haystack to start searching. The position returned is still relative to the beginning of haystack.

Návratové hodnoty

If needle is not found, stripos() will return boolean FALSE.

Varování

Tato funkce může vracet booleovskou hodnotu FALSE, ale také nebooleovskou hodnotu odpovídající ohodnocení FALSE, například 0 nebo "". Čtěte prosím sekci o typu Boolean, kde najdete více informací. Pro testování návratové hodnoty této funkce použijte operátor ===.

Příklady

Příklad 2223. stripos() examples

<?php
$findme    = 'a';
$mystring1 = 'xyz';
$mystring2 = 'ABC';

$pos1 = stripos($mystring1, $findme);
$pos2 = stripos($mystring2, $findme);

// Nope, 'a' is certainly not in 'xyz'
if ($pos1 === false) {
    echo "The string '$findme' was not found in the string '$mystring1'";
}

// Note our use of ===.  Simply == would not work as expected
// because the position of 'a' is the 0th (first) character.
if ($pos2 !== false) {
    echo "We found '$findme' in '$mystring2' at position $pos2";
}
?>

Poznámky

Poznámka: Tato funkce je binárně bezpečná.

Viz také

strpos()
strrpos()
strrchr()
substr()
stristr()
strstr()
strripos()
str_ireplace()

Předcházející | Nahoru | Další
stripcslashes | Domů | stripslashes


stripslashes

(PHP 4, PHP 5)

stripslashes — Zrušit escapování provedené funkcí addslashes()

Popis

string stripslashes ( string $str )

Vrací řetězec s odstraněnými zpětnými lomítky. (\' se stává ' a pod.) Zdvojená zpětná lomítka (\\) se spojují do jednoduchých (\).

Funkce stripslashes() může být použita například tehdy, když je PHP direktiva magic_quotes_gpc nastavena na on (což je výchozí nastavení) a vy tato data nevkládáte na místa (jako je databáze), která toto escapování potřebují. To je například tehdy, když data zadaná do HTML formuláře pouze vypisujete.

Příklad 2224. Příklad funkce stripslashes()

<?php
$str = "Jmenuješ se O\'reilly?";

// Outputs: Jmenuješ se O'reilly?
echo stripslashes($str);
?>

Viz také addslashes() a get_magic_quotes_gpc().

Předcházející | Nahoru | Další
stripos | Domů | stristr


stristr

(PHP 4, PHP 5)

stristr — strstr() bez rozlišení velikosti písmen

Popis

string stristr ( string $haystack, string $needle )

Vrací haystack od prvního výskytu needle do konce. needle a haystack se zkoumají bez ohledu na velikost písmen.

Pokud needle nenajde, vrací FALSE.

Pokud needle není řetězec, převede se na integer a použije se jako číselná hodnota znaku.

Příklad 2225. Příklad použití stristr()

<?php
  $email = 'USER@EXAMPLE.com';
  $domain = stristr($email, 'e');
  echo $domain; // ER@EXAMPLE.com
?>

Viz také strchr(),
strrchr(), substr() a
ereg().

Předcházející | Nahoru | Další
stripslashes | Domů | strlen


strlen

(PHP 4, PHP 5)

strlen — Zjistit délku řetězce

Popis

int strlen ( string $string )

Vrací délku (počet znaků) argumentu string.

Příklad 2226. Příklad funkce strlen()

<?php
$str = 'abcdef';
echo strlen($str); // 6

$str = ' ab cd ';
echo strlen($str); // 7
?>

Viz také count().

Předcházející | Nahoru | Další
stristr | Domů | strnatcasecmp


strnatcasecmp

(PHP 4, PHP 5)

strnatcasecmp — Case-insensitive textové porovnání s využitím "natural order" algoritmu

Popis

int strnatcasecmp ( string $str1, string $str2 )

Tato funkce implementuje srovnávací algoritmus který třídí alfanumerické řetězce stejným způsobem jako člověk. Chování této funkce se podobá strnatcmp() s tou výjimkou, že porovnání je case-insensitive. Více informací viz stránka Martina Poola » Natural Order String Comparison.

Podobně jako jiné funkce pro porovnávání řetězců i tato vrací < 0 pokud je str1 menší než str2; > 0 pokud je str1 větší než str2, a 0 pokud jsou shodné.

Viz také: ereg(),
strcasecmp(),
substr(),
stristr(),
strcmp(),
strncmp(),
strncasecmp(),
strnatcmp() a
strstr().

Předcházející | Nahoru | Další
strlen | Domů | strnatcmp


strnatcmp

(PHP 4, PHP 5)

strnatcmp — Porovnání řetězců algoritmem "přirozeného třídění"

Popis

int strnatcmp ( string $str1, string $str2 )

Tato funkce implementuje srovnávací algoritmus který třídí alfanumerické řetězce stejným způsobem jako člověk, toto se popisuje jako "přirozené třídění". Ukázka rozdílu mězi tímto algoritmem a běžnými počítačovými algoritmy pro řazení řetězců (např. strcmp()):

$arr1 = $arr2 = array ("img12.png","img10.png","img2.png","img1.png");
echo "Standardní porovnávání řetězců\n";
usort($arr1,"strcmp");
print_r($arr1);
echo "\nPřirozené porovnávání řetězců\n";
usort($arr2,"strnatcmp");
print_r($arr2);
Výše uvedený kód vygeneruje následující výstup:
Standardní porovnávání řetězců
Array
(
    [0] => img1.png
    [1] => img10.png
    [2] => img12.png
    [3] => img2.png
)

Přirozené porovnávání řetězců
Array
(
    [0] => img1.png
    [1] => img2.png
    [2] => img10.png
    [3] => img12.png
)
Více informací viz stránka Martina Poola » Natural Order String Comparison.

Podobně jako jiné funkce pro porovnávání řetězců i tato vrací < 0 pokud je str1 menší než str2; > 0 pokud je str1 větší než str2, a 0 pokud jsou shodné.

Pozn.: toto porovnání je case-sensitive.

Viz také: ereg(),
strcasecmp(),
substr(),
stristr(),
strcmp(),
strncmp(),
strncasecmp(),
strnatcasecmp(),
strstr(),
natsort() a
natcasesort().

Předcházející | Nahoru | Další
strnatcasecmp | Domů | strncasecmp


strncasecmp

(PHP 4 >= 4.0.2, PHP 5)

strncasecmp — Binárně bezpečné case-insensitive porovnání prvních n znaků řetězců

Popis

int strncasecmp ( string $str1, string $str2, int $len )

Tato funkce se podobá strcasecmp(), s tím rozdílem, že můžete určit (maximální) počet znaků (len) z každého z řetězců, které se použijí při porovnání. Pokud je některý z řetězců kratší než len, pak se pro porovnání použije délka tohoto řetězce.

Pokud je str1 méně než str2, vrací < 0; pokud je str1 větší než str2, vrací > 0, a 0, pokud jsou stejné.

Viz také: ereg(),
strcasecmp(),
strcmp(),
substr(),
stristr() a
strstr().

Předcházející | Nahoru | Další
strnatcmp | Domů | strncmp


strncmp

(PHP 4, PHP 5)

strncmp — Binárně bezpečné porovnání prvních n znaků v řetězcích

Popis

int strncmp ( string $str1, string $str2, int $len )

This function is similar to strcmp(), with the difference that you can specify the (upper limit of the) number of characters (len) from each string to be used in the comparison. If any of the strings is shorter than len, then the length of that string will be used for the comparison.

Vrací < 0 pokud je str1 menší než str2; > 0 pokud je str1 větší než str2, a 0 pokud jsou shodné.

Pozn.: toto srovnání je case-sensitive.

Viz také: ereg(),
strncasecmp(),
strcasecmp(),
substr(),
stristr(),
strcmp() a
strstr().

Předcházející | Nahoru | Další
strncasecmp | Domů | strpbrk


strpbrk

(PHP 5)

strpbrk — Search a string for any of a set of characters

Popis

string strpbrk ( string $haystack, string $char_list )

strpbrk() searches the haystack string for a char_list.

Seznam parametrů

haystack

The string where char_list is looked for.

char_list

This parameter is case sensitive.

Návratové hodnoty

Returns a string starting from the character found, or FALSE if it is not found.

Příklady

Příklad 2227. strpbrk() example

<?php

$text = 'This is a Simple text.';

// this echoes "is is a Simple text." because 'i' is matched first
echo strpbrk($text, 'mi');

// this echoes "Simple text." because chars are case sensitive
echo strpbrk($text, 'S');
?>

Předcházející | Nahoru | Další
strncmp | Domů | strpos


strpos

(PHP 4, PHP 5)

strpos — Najít pozici prvního výskytu řetězce

Popis

int strpos ( string $haystack, mixed $needle [, int $offset] )

Vrací číselnou pozici prvního výskytu needle v řetězci haystack. Narozdíl od strrpos() tato funkce přijme jako argument needle řetězec více znaků, a celý tento řetězec se použije.

Pokud needle nenajde, vrací FALSE.

Varování

Tato funkce může vracet booleovskou hodnotu FALSE, ale také nebooleovskou hodnotu odpovídající ohodnocení FALSE, například 0 nebo "". Čtěte prosím sekci o typu Boolean, kde najdete více informací. Pro testování návratové hodnoty této funkce použijte operátor ===.

Příklad 2228. strpos() examples

<?php
$mystring = 'abc';
$findme   = 'a';
$pos = strpos($mystring, $findme);

// Všimněte si použití ===. Obyčejné == by nefungovalo podle předpokladu,
// protože 'a' je na nultém (prvním) místě.
if ($pos === false) {
    echo "Řetězec '$findme' nebyl nalezen v řetězci '$mystring'";
} else {
    echo "Řetězec '$findme' byl nalezen v řetězci '$mystring'";
    echo " a je na pozici $pos";
}

?>

Pokud needle není řetězec, převede se na integer a použije se jako číselná hodnota znaku.

Volitelný argument offset vám umožňuje určit, na které pozici v haystack má hledání začít. Vrácená pozice je i tak relativní k začátku haystack.

Viz také: strrpos(),
stripos(),
strripos(),
strrchr(),
substr(),
stristr() a
strstr().

Předcházející | Nahoru | Další
strpbrk | Domů | strrchr


strrchr

(PHP 4, PHP 5)

strrchr — Najít poslední výskyt znaku v řetězci

Popis

string strrchr ( string $haystack, string $needle )

Tato funkce vrací tu část haystack, která začíná posledním výskytem needle a pokračuje do konce haystack.

Pokud needle nenajde, vrací FALSE.

Pokud needle obsahuje více než jeden znak, použije se první z nich. Toto chování je odlišné od funkce strchr().

Pokud needle není řetězec, převede se na integer a použije se jako číselná hodnota znaku.

Příklad 2229. Ukázka strrchr()

<?php
// získat poslední adresář v $PATH
$dir = substr(strrchr($PATH, ":"), 1);

// získat všechno po posledním konci řádku
$text = "Řádek 1\nŘádek 2\nŘádek 3";
$last = substr(strrchr($text, 10), 1 );
?>

Viz také strchr(), substr(), stristr() a strstr().

Předcházející | Nahoru | Další
strpos | Domů | strrev


strrev

(PHP 4, PHP 5)

strrev — Obrátit řetězec

Popis

string strrev ( string $string )

Vrací string v opačném pořadí.

Předcházející | Nahoru | Další
strrchr | Domů | strripos


strripos

(PHP 5)

strripos — Find position of last occurrence of a case-insensitive string in a string

Popis

int strripos ( string $haystack, string $needle [, int $offset] )

Find position of last occurrence of a case-insensitive string in a string. Unlike strrpos(), strripos() is case-insensitive.

Seznam parametrů

haystack

The string to search in

needle

Note that the needle may be a string of one or more characters.

offset

The offset parameter may be specified to begin searching an arbitrary number of characters into the string.

Negative offset values will start the search at offset characters from the start of the string.

Návratové hodnoty

Returns the numerical position of the last occurence of needle. Also note that string positions start at 0, and not 1.

If needle is not found, FALSE is returned.

Varování

Tato funkce může vracet booleovskou hodnotu FALSE, ale také nebooleovskou hodnotu odpovídající ohodnocení FALSE, například 0 nebo "". Čtěte prosím sekci o typu Boolean, kde najdete více informací. Pro testování návratové hodnoty této funkce použijte operátor ===.

Příklady

Příklad 2230. A simple strripos() example

<?php
$haystack = 'ababcd';
$needle   = 'aB';

$pos      = strripos($haystack, $needle);

if ($pos === false) {
    echo "Sorry, we did not find ($needle) in ($haystack)";
} else {
    echo "Congratulations!\n";
    echo "We found the last ($needle) in ($haystack) at position ($pos)";
}
?>

Výše uvedený příklad vypíše:

   Congratulations!
   We found the last (aB) in (ababcd) at position (2)

Viz také

strpos()
stripos()
strrchr()
substr()
stristr()
strstr()

Předcházející | Nahoru | Další
strrev | Domů | strrpos


strrpos

(PHP 4, PHP 5)

strrpos — Najít pozici posledního výskytu znaku v řetězci

Popis

int strrpos ( string $haystack, string $needle [, int $offset] )

Vrací číselnou pozici posledního výskytu needle v řetězci haystack. Řetězec needle může být v PHP 4 jen jeden znak dlouhý. Pokud obsahuje více znaků, použije se první z nich.

Pokud needle nenajde, vrací FALSE.

Poznámka: Návratové hodnoty "znak nalezen na pozici 0" a "znak nenalezen" se dají snadno zaměnit. Tady je návod, jak zjistit tento rozdíl:

<?php

// v PHP 4.0b3 a novějších:
$pos = strrpos($mystring, "b");
if ($pos === false) { // všimněte si: tři rovnítka
    // nenalezeno...
}

// ve verzích starších než 4.0b3:
$pos = strrpos($mystring, "b");
if (is_bool($pos) && !$pos) {
    // nenalezeno...
}
?>

Pokud needle není řetězec, převede se na integer a použije se jako číselná hodnota znaku.

Poznámka: Od PHP 5.0.0 může být zadán parametr offset. To způsobí, že hledání začne od určité pozice v řetězci. Záporné hodnoty zastaví hledání na určitém místě před koncem řetězce.

Poznámka: Parametr needle může být od PHP 5.0.0 řetězec delší než 1 znak.

Viz také strpos(),
strripos(),
strrchr(),
substr(),
stristr() a
strstr().

Předcházející | Nahoru | Další
strripos | Domů | strspn


strspn

(PHP 4, PHP 5)

strspn — Zjistit délku úvodního segmentu odpovídajícího masce

Popis

int strspn ( string $str1, string $str2 [, int $start [, int $length]] )

Vrací úvodního segmentu str1, který se skládá výhradně ze znaků v str2.

strspn ("42 je odpověď, co je otázka...", "1234567890");

vrátí 2.

Viz také: strcspn().

Předcházející | Nahoru | Další
strrpos | Domů | strstr


strstr

(PHP 4, PHP 5)

strstr — Najít první výskyt řetězce

Popis

string strstr ( string $haystack, string $needle )

Vrací část haystack od prvního výskytu needle do konce.

Pokud needle nenajde, vrací FALSE.

Pokud needle není řetězec, převede se na integer a použije se jako číselná hodnota znaku.

Poznámka: Pozn.: tato funkce rozlišuje velikost písmen. Pro hledání bez rozlišení velikosti písmen použijte stristr().

Příklad 2231. Ukázka strstr()

<?php
$email = 'user@example.com';
$domain = strstr($email, '@');
echo $domain; // @example.com
?>

Poznámka: Pokud pouze chcete zjistit, zda se určitý řetězec needle vyskytuje v řetězci haystack, je rychlejší a méně náročné na paměť použití funkce strpos().

Viz také ereg(), preg_match(),
strchr(), stristr(),
strpos(), strrchr() a
substr().

Předcházející | Nahoru | Další
strspn | Domů | strtok


strtok

(PHP 4, PHP 5)

strtok — Tokenize string

Popis

string strtok ( string $str, string $token )

strtok() is used to tokenize a string. That is, if you have a string like "This is an example string" you could tokenize this string into its individual words by using the space character as the token.

Příklad 2232. Ukázka strtok()

$string = "This is an example string";
$tok = strtok ($string," ");
while ($tok) {
    echo "Word=$tok<br>";
    $tok = strtok (" ");
}

Note that only the first call to strtok uses the string argument. Every subsequent call to strtok only needs the token to use, as it keeps track of where it is in the current string. To start over, or to tokenize a new string you simply call strtok with the string argument again to initialize it. Note that you may put multiple tokens in the token parameter. The string will be tokenized when any one of the characters in the argument are found.

Also be careful that your tokens may be equal to "0". This evaluates to FALSE in conditional expressions.

Viz také: split() a explode().

Předcházející | Nahoru | Další
strstr | Domů | strtolower


strtolower

(PHP 4, PHP 5)

strtolower — Změnit řetězec na malá písmena

Popis

string strtolower ( string $str )

Vrací string se všemi alfabetickými znaky změněnými na malá písmena.

Pozn.: co je 'alfabetický' je dáno aktuálním místním nastavením. Například ve standardním "C" locale se znaky jako přehlasované a (Ä) nepřevedou.

Příklad 2233. Ukázka strtolower()

$str = "Mary Had A Little Lamb and She LOVED It So";
$str = strtolower($str);
print $str; # vytiskne mary had a little lamb and she loved it so

Viz také: strtoupper() a ucfirst().

Předcházející | Nahoru | Další
strtok | Domů | strtoupper


strtoupper

(PHP 4, PHP 5)

strtoupper — Změnit řetězec na velká písmena

Popis

string strtoupper ( string $string )

Vrací string se všemi alfabetickými znaky změněnými na velká písmena.

Pozn.: co je 'alfabetický' je dáno aktuálním místním nastavením. Například ve standardním "C" locale se znaky jako přehlasované a (ä) nepřevedou.

Příklad 2234. Ukázka strtoupper()

$str = "Mary Had A Little Lamb and She LOVED It So";
$str = strtoupper ($str);
print $str; # vytiskne MARY HAD A LITTLE LAMB AND SHE LOVED IT SO

Viz také: strtolower() a ucfirst().

Předcházející | Nahoru | Další
strtolower | Domů | strtr


strtr

(PHP 4, PHP 5)

strtr — Přeložit určité znaky

Popis

string strtr ( string $str, string $from, string $to )
string strtr ( string $str, array $replace_pairs )

Tato funkce upraví str tak, že všechny výskyty všech znaků ve from přeloží na odpovídající znaky v to a vrátí výsledek.

Pokud jsou from a to různě dlouhé, přebývající znaky z delšího z těch dvou se ignorují.

Příklad 2235. Ukázka strtr()

<?php
$addr = strtr($addr, "äĺö", "aao");
?>

strtr() se dá také volat pouze se dvěma argumenty. Při volání se dvěma argumenty se chová takto: from musí být pole obsahující páry řetězců, které se zamění ve zdrojovém řetězci. strtr() vždy hledá nejdelší možnou shodu a NENAHRAZUJE ty části řetězce, na kterých už pracovala.

Příklad 2236. strtr() example with two arguments

<?php
$trans = array("ahoj" => "nazdar", "nazdar" => "ahoj");
echo strtr("nazdar lidi, řekl jsem ahoj", $trans);
?>

Výsledek:

ahoj lidi, řekl jsem nazdar

Poznámka: Tato vlastnost (dva argumenty) byla přidána v PHP 4.0.

Viz také: ereg_replace().

Předcházející | Nahoru | Další
strtoupper | Domů | substr_compare


substr_compare

(PHP 5)

substr_compare — Binary safe comparison of 2 strings from an offset, up to length characters

Popis

int substr_compare ( string $main_str, string $str, int $offset [, int $length [, bool $case_insensitivity]] )

substr_compare() compares main_str from position offset with str up to length characters.

Seznam parametrů

main_str

str

offset

The start position for the comparison. If negative, it starts counting from the end of the string.

length

The length of the comparison.

case_insensitivity

If case_insensitivity is TRUE, comparison is case insensitive.

Návratové hodnoty

Returns < 0 if main_str from position offset is less than str, > 0 if it is greater than str, and 0 if they are equal. If length is equal or greater than length of main_str and length is set, substr_compare() prints warning and returns FALSE.

ChangeLog (záznam změn)

Verze | Popis
5.1.0 | Added the possibility to use a negative offset.

Příklady

Příklad 2237. A substr_compare() example

<?php
echo substr_compare("abcde", "bc", 1, 2); // 0
echo substr_compare("abcde", "de", -2, 2); // 0
echo substr_compare("abcde", "bcg", 1, 2); // 0
echo substr_compare("abcde", "BC", 1, 2, true); // 0
echo substr_compare("abcde", "bc", 1, 3); // 1
echo substr_compare("abcde", "cd", 1, 2); // -1
echo substr_compare("abcde", "abc", 5, 1); // warning
?>

Předcházející | Nahoru | Další
strtr | Domů | substr_count


substr_count

(PHP 4, PHP 5)

substr_count — Spočítat počet výskytů řetězce

Popis

int substr_count ( string $haystack, string $needle [, int $offset [, int $length]] )

substr_count() vrací počet výskytů řetězce needle v řetězci haystack string.

Příklad 2238. Ukázka substr_count()

print substr_count("This is a test", "is"); // prints out 2

Předcházející | Nahoru | Další
substr_compare | Domů | substr_replace


substr_replace

(PHP 4, PHP 5)

substr_replace — Nahradit část řetězce jiným řetězcem

Popis

mixed substr_replace ( mixed $string, string $replacement, int $start [, int $length] )

substr_replace() nahrazuje část řetězce string ohraničenou argumenty start a (volitelně) length řetězcem v argumentu replacement. Vrací výsledek.

Pokud je start pozitivní, náhrada začne na start-tém znaku argumentu string.

Pokud je start negativní, náhrada začne na start-tém znaku od konce argumentu string.

Pokud je přítomen length, a je pozitivní, představuje délku části argumentu string, která bude nahražena. Pokud je negativní, představuje počet znaků od konce string, kde má nahrazování skončit. Pokud přítomen není, bere se standardně strlen( string ); tj. nahrazování končí na konci argumentu string.

Příklad 2239. Ukázka substr_replace()

<?php
$var = 'ABCDEFGH:/MNRPQR/';
echo "Originál: $var<hr>\n";

/* Tyto dva příklady nahradí celý obsah proměnné $var řetězcem 'bob'. */
echo substr_replace ($var, 'bob', 0) . "<br>\n";
echo substr_replace ($var, 'bob', 0, strlen ($var)) . "<br>\n";

/* Toto vloží 'bob' na začátek $var. */
echo substr_replace ($var, 'bob', 0, 0) . "<br>\n";

/* Tyto dva příklady nahradí 'MNRPQR' ve $var řetězcem 'bob'. */
echo substr_replace ($var, 'bob', 10, -1) . "<br>\n";
echo substr_replace ($var, 'bob', -7, -1) . "<br>\n";

/* Toto z $var odstraní 'MNRPQR'. */
echo substr_replace ($var, '', 10, -1) . "<br>\n";
?>

Viz také str_replace() a substr().

Poznámka: Funkce substr_replace() byla přidána v PHP 4.0.

Předcházející | Nahoru | Další
substr_count | Domů | substr


substr

(PHP 4, PHP 5)

substr — Vrátit část řetězce

Popis

string substr ( string $string, int $start [, int $length] )

substr() vrací část argumentu string určenou argumenty start a length.

Pokud je start kladný, vrácený řetězec začne start-tým znakem řetězce string, počítáno od nuly. Například v řetězci 'abcdef' je znakem na 0-té pozici 'a', znakem na pozici 2 je 'c', atd.

Příklad 2240. Základní použití substr()

<?php
$rest = substr("abcdef", 1);    // vrátí "bcdef"
$rest = substr("abcdef", 1, 3); // vrátí "bcd"
$rest = substr("abcdef", 0, 4); // vrátí "abcd"
$rest = substr("abcdef", 0, 8); // vrátí "abcdef"

// Přístup přes složené závorky je další možnost
$string = 'abcdef';
echo $string{0};                // vrátí a
echo $string{3};                // vrátí d
?>

Pokud je start záporný, vrácený řetězec začne start-tým znakem od konce argumentu string.

Příklad 2241. Použití záporného čísla v parametru start

<?php
$rest = substr("abcdef", -1);    // returns "f"
$rest = substr("abcdef", -2);    // returns "ef"
$rest = substr("abcdef", -3, 1); // returns "d"
?>

Pokud je argument length kladný, vrácený řetězec skončí length znaků za pozicí start. Pokud je parametr string kratší než start znaků, vrátí tato funkce FALSE.

Pokud je parametr length negativní, tak bude z konce řetězce string vynechán odpovídající počet znaků. Pokud parametr start určuje pozici za tímto zkrácením, bude vrácen prázdný řetězec.

Příklad 2242. Použití záporného parametru length

<?php
$rest = substr("abcdef", 0, -1);  // vrátí "abcde"
$rest = substr("abcdef", 2, -1);  // vrátí "cde"
$rest = substr("abcdef", 4, -4);  // vrátí ""
$rest = substr("abcdef", -3, -1); // vrátí "de"
?>

Viz také strrchr(),
substr_replace(),
ereg() a
trim().

Předcházející | Nahoru | Další
substr_replace | Domů | trim


trim

(PHP 4, PHP 5)

trim — Odstranit netisknutelné znaky ze začátku a konce řetězce

Popis

string trim ( string $str [, string $charlist] )

Poznámka: Volitelný parametr charlist byl přidán v PHP 4.1.0

Tato funkce odstraňuje bílé znaky ze začátku a konce řetězce a vrací řetězec bez těchto znaků. Bez druhého parametru odstraní tato funkce následující znaky:

  • " " (ASCII 32 (0x20)), obyčejná mezera.
  • "\t" (ASCII 9 (0x09)), tabulátor.
  • "\n" (ASCII 10 (0x0A)), nová řádka (line feed).
  • "\r" (ASCII 13 (0x0D)), návrat vozíku (carriage return).
  • "\0" (ASCII 0 (0x00)), znak NUL.
  • "\x0B" (ASCII 11 (0x0B)), vertikální tabulátor.

Můžete také určit, které znaky chcete odstranit, a to pomocí parametru charlist. Jednoduše vyjmenujte všechny znaky, které chcete odstranit. Pomocí .. můžete určit rozsah znaků.

Příklad 2243. Příklady použití trim()

<?php

$text = "\t\tZde je pár slov :) ...  ";
$trimmed = trim($text);
// $trimmed = "Zde je pár slov :) ..."
$trimmed = trim($text, " \t.");
// $trimmed = "Zde je pár slov :)"
$clean = trim($binary, "\0x00..\0x1F");
// odstranit kontrolní znaky ASCII ze začátku i konce proměnné $binary
// (od 0 do 31 včetně)

?>

Viz také ltrim() a rtrim().

Předcházející | Nahoru | Další
substr | Domů | ucfirst


ucfirst

(PHP 4, PHP 5)

ucfirst — Změní první písmeno řetězce na velké

Popis

string ucfirst ( string $str )

Změní první znak argumentu str, pokud je tento znak alfabetický.

Pozn.: co znamená 'alfabetický' určuje aktuální místní nastavení (locale). Například ve standardním "C" locale se znaky jako přehlasované a (ä) nepřevedou.

Příklad 2244. Ukázka ucfirst()

$text = 'mary had a little lamb and she loved it so.';
$text = ucfirst ($text); // $text is now Mary had a little lamb
                         // and she loved it so.

Viz také strtoupper() a strtolower().

Předcházející | Nahoru | Další
trim | Domů | ucwords


ucwords

(PHP 4, PHP 5)

ucwords — Změnit první znak každého slova v řetězci na velké písmeno

Popis

string ucwords ( string $str )

Změní první znak každého slova v argumentu str na velké písmeno, pokud je tento znak alfabetický.

Příklad 2245. Ukázka ucwords()

$text = "mary had a little lamb and she loved it so.";
$text = ucwords($text); // $text is now: Mary Had A Little
                        // Lamb And She Loved It So.

Poznámka: Definice slova je: jakýkoli řetězec znaků, který následuje bezprostředně po netisknutelném znaku (to jsou: mezera, posun o tiskouvou stranu, přesun na novou řádku, návrat vozíku, horizontální tabelátor a vertikální tabelátor0.

Viz také strtoupper(), strtolower() and ucfirst().

Předcházející | Nahoru | Další
ucfirst | Domů | vfprintf


vfprintf

(PHP 5)

vfprintf — Write a formatted string to a stream

Popis

int vfprintf ( resource $handle, string $format, array $args )

Write a string produced according to format to the stream resource specified by handle.

Operates as fprintf() but accepts an array of arguments, rather than a variable number of arguments.

Seznam parametrů

handle

format

See sprintf() for a description of format.

args

Návratové hodnoty

Returns the length of the outputted string.

Příklady

Příklad 2246. vfprintf(): zero-padded integers

<?php
if (!($fp = fopen('date.txt', 'w')))
    return;

vfprintf($fp, "%04d-%02d-%02d", array($year, $month, $day));
// will write the formatted ISO date to date.txt
?>

Viz také

printf()
sprintf()
sscanf()
fscanf()
vsprintf()
number_format()

Předcházející | Nahoru | Další
ucwords | Domů | vprintf


vprintf

(PHP 4 >= 4.0.7, PHP 5)

vprintf — Output a formatted string

Popis

int vprintf ( string $format, array $args )

Display array values as a formatted string according to format (which is described in the documentation for sprintf()).

Operates as printf() but accepts an array of arguments, rather than a variable number of arguments.

Seznam parametrů

format

args

Návratové hodnoty

Returns the length of the outputted string.

Viz také

printf()
sprintf()
vsprintf()

Předcházející | Nahoru | Další
vfprintf | Domů | vsprintf


vsprintf

(PHP 4 >= 4.0.7, PHP 5)

vsprintf — Return a formatted string

Popis

string vsprintf ( string $format, array $args )

Operates as sprintf() but accepts an array of arguments, rather than a variable number of arguments.

Seznam parametrů

format

args

Návratové hodnoty

Return array values as a formatted string according to format (which is described in the documentation for sprintf()).

Viz také

sprintf()
vprintf()

Předcházející | Nahoru | Další
vprintf | Domů | wordwrap


wordwrap

(PHP 4 >= 4.0.2, PHP 5)

wordwrap — Zalámat řetězec na daný počet znaků pomocí break znaku

Popis

string wordwrap ( string $str [, int $width [, string $break [, bool $cut]]] )

Zaláme řetězec str na sloupci určeném (volitelným) argumentem break.

Pokud není zadán argument width nebo break, wordwrap() automaticky zaláme řádky řetězce na sloupci 75 znakem '\n' (konec řádku).

Pokud má argument cut hodnotu 1, řetězec se na určenou šířku zalomí vždy. Takže pokud máte slovo delší než je daná šířka, rozdělí se. (Viz druhý příklad.)

Poznámka: Argument cut byl přidán PHP 4.0.3.

Příklad 2247. Ukázka wordwrap()

$text = "Rychlá hnědá liška přeskočila líného psa.";
$newtext = wordwrap( $text, 20 );

echo "$newtext\n";

Tato ukázka by zobrazila:

Rychlá hnědá liška
přeskočila líného psa.

Příklad 2248. Ukázka wordwrap()

$text = "Velmi dlouhé slooooooooooovo.";
$newtext = wordwrap( $text, 8, "\n", 1);

echo "$newtext\n";

Tato ukázka by zobrazila:

Velmi
dlouhé
sloooooo
ooooovo.

Viz také: nl2br().

Předcházející | Nahoru | Další
vsprintf | Domů | CLXII. Subversion Funkce


Sybase Functions

Předcházející VI. Reference funkcí Další

CLXV. Sybase Functions

Úvod

Požadavky

Instalace

To enable Sybase-DB support configure PHP --with-sybase[=DIR]. DIR is the Sybase home directory, defaults to /home/sybase. To enable Sybase-CT support configure PHP --with-sybase-ct[=DIR]. DIR is the Sybase home directory, defaults to /home/sybase.

Konfigurace běhu

Chování těchto funkcí je ovlivněno nastavením parametrů v php.ini.

Tabulka 303. Sybase configuration options

Name | Default | Changeable | Changelog
sybase.allow_persistent | "1" | PHP_INI_ALL | PHP_INI_ALL in PHP <= 4.0.2. PHP_INI_SYSTEM in PHP <= 4.0.3.
sybase.max_persistent | "-1" | PHP_INI_ALL | PHP_INI_ALL in PHP <= 4.0.2. PHP_INI_SYSTEM in PHP <= 4.0.3.
sybase.max_links | "-1" | PHP_INI_ALL | PHP_INI_ALL in PHP <= 4.0.2. PHP_INI_SYSTEM in PHP <= 4.0.3.
sybase.interface_file | "/usr/sybase/interfaces" | PHP_INI_SYSTEM |
sybase.min_error_severity | "10" | PHP_INI_ALL |
sybase.min_message_severity | "10" | PHP_INI_ALL |
sybase.compatability_mode | "0" | PHP_INI_ALL |
magic_quotes_sybase | "0" | PHP_INI_ALL | Removed in PHP 6.0.0.

Zde je stručný popis konfiguračních direktiv.

sybase.allow_persistent boolean

Whether to allow persistent Sybase connections.

sybase.max_persistent integer

The maximum number of persistent Sybase connections per process. -1 means no limit.

sybase.max_links integer

The maximum number of Sybase connections per process, including persistent connections. -1 means no limit.

sybase.min_error_severity integer

Minimum error severity to display.

sybase.min_message_severity integer

Minimum message severity to display.

sybase.compatability_mode boolean

Compatibility mode with old versions of PHP 3.0. If on, this will cause PHP to automatically assign types to results according to their Sybase type, instead of treating them all as strings. This compatibility mode will probably not stay around forever, so try applying whatever necessary changes to your code, and turn it off.

magic_quotes_sybase boolean

If magic_quotes_sybase is on, a single-quote is escaped with a single-quote instead of a backslash if magic_quotes_gpc or magic_quotes_runtime are enabled.

Poznámka: Note that when magic_quotes_sybase is ON it completely overrides magic_quotes_gpc . In this case even when magic_quotes_gpc is enabled neither double quotes, backslashes or NUL's will be escaped.

Tabulka 304. Sybase-CT configuration options

Name | Default | Changeable | Changelog
sybct.allow_persistent | "1" | PHP_INI_SYSTEM | PHP_INI_ALL in PHP <= 4.0.2. Available since PHP 4.0.2. Removed in PHP 4.0.3.
sybct.max_persistent | "-1" | PHP_INI_SYSTEM | PHP_INI_ALL in PHP <= 4.0.2. Available since PHP 4.0.2. Removed in PHP 4.0.3.
sybct.max_links | "-1" | PHP_INI_SYSTEM | PHP_INI_ALL in PHP <= 4.0.2. Available since PHP 4.0.2. Removed in PHP 4.0.3.
sybct.min_server_severity | "10" | PHP_INI_ALL | Available since PHP 4.0.2. Removed in PHP 4.0.3.
sybct.min_client_severity | "10" | PHP_INI_ALL | Available since PHP 4.0.2. Removed in PHP 4.0.3.
sybct.hostname | NULL | PHP_INI_ALL | Available since PHP 4.0.2. Removed in PHP 4.0.3.
sybct.deadlock_retry_count | "0" | PHP_INI_ALL | Available since PHP 4.3.0.

Zde je stručný popis konfiguračních direktiv.

sybct.allow_persistent boolean

Whether to allow persistent Sybase-CT connections. The default is on.

sybct.max_persistent integer

The maximum number of persistent Sybase-CT connections per process. The default is -1 meaning unlimited.

sybct.max_links integer

The maximum number of Sybase-CT connections per process, including persistent connections. The default is -1 meaning unlimited.

sybct.min_server_severity integer

Server messages with severity greater than or equal to sybct.min_server_severity will be reported as warnings. This value can also be set from a script by calling sybase_min_server_severity(). The default is 10 which reports errors of information severity or greater.

sybct.min_client_severity integer

Client library messages with severity greater than or equal to sybct.min_client_severity will be reported as warnings. This value can also be set from a script by calling sybase_min_client_severity(). The default is 10 which effectively disables reporting.

sybct.login_timeout integer

The maximum time in seconds to wait for a connection attempt to succeed before returning failure. Note that if max_execution_time has been exceeded when a connection attempt times out, your script will be terminated before it can take action on failure. The default is one minute.

sybct.timeout integer

The maximum time in seconds to wait for a select_db or query operation to succeed before returning failure. Note that if max_execution_time has been exceeded when an operation times out, your script will be terminated before it can take action on failure. The default is no limit.

sybct.hostname string

The name of the host you claim to be connecting from, for display by sp_who. The default is none.

sybct.deadlock_retry_count int

Allows you to define how often deadlocks are to be retried. The default is -1, or "forever".

Pro další detaily a definice konstant PHP_INI_*, viz dokumentace k ini_set().

Typy prostředků

Předdefinované konstanty

Toto rozšíření nemá definovány žádné konstanty.

Obsah

sybase_affected_rows — Gets number of affected rows in last query
sybase_close — Closes a Sybase connection
sybase_connect — Opens a Sybase server connection
sybase_data_seek — Moves internal row pointer
sybase_deadlock_retry_count — Sets the deadlock retry count
sybase_fetch_array — Fetch row as array
sybase_fetch_assoc — Fetch a result row as an associative array
sybase_fetch_field — Get field information from a result
sybase_fetch_object — Fetch a row as an object
sybase_fetch_row — Get a result row as an enumerated array
sybase_field_seek — Sets field offset
sybase_free_result — Frees result memory
sybase_get_last_message — Returns the last message from the server
sybase_min_client_severity — Sets minimum client severity
sybase_min_error_severity — Sets minimum error severity
sybase_min_message_severity — Sets minimum message severity
sybase_min_server_severity — Sets minimum server severity
sybase_num_fields — Gets the number of fields in a result set
sybase_num_rows — Get number of rows in a result set
sybase_pconnect — Open persistent Sybase connection
sybase_query — Sends a Sybase query
sybase_result — Get result data
sybase_select_db — Selects a Sybase database
sybase_set_message_handler — Sets the handler called when a server message is raised
sybase_unbuffered_query — Send a Sybase query and do not block
Předcházející | Nahoru | Další
SwishSearch->setStructure | Domů | sybase_affected_rows


sybase_affected_rows

(PHP 4, PHP 5)

sybase_affected_rows — Gets number of affected rows in last query

Popis

int sybase_affected_rows ( [resource $link_identifier] )

sybase_affected_rows() returns the number of rows affected by the last INSERT, UPDATE or DELETE query on the server associated with the specified link identifier.

This command is not effective for SELECT statements, only on statements which modify records. To retrieve the number of rows returned from a SELECT, use sybase_num_rows().

Seznam parametrů

link_identifier

If the link identifier isn't specified, the last opened link is assumed.

Návratové hodnoty

Returns the number of affected rows, as an integer.

Příklady

Příklad 2284. Delete-Query

<?php
/* connect to database */
sybase_connect('SYBASE', '', '') or
die("Could not connect");
sybase_select_db("db");

sybase_query("DELETE FROM sometable WHERE id < 10");
printf("Records deleted: %d\n", sybase_affected_rows());
?>

Výše uvedený příklad vypíše:

Records deleted: 10

Viz také

sybase_num_rows()

Předcházející | Nahoru | Další
CLXV. Sybase Functions | Domů | sybase_close


sybase_close

(PHP 4, PHP 5)

sybase_close — Closes a Sybase connection

Popis

bool sybase_close ( [resource $link_identifier] )

sybase_close() closes the link to a Sybase database that's associated with the specified link link_identifier.

Note that this isn't usually necessary, as non-persistent open links are automatically closed at the end of the script's execution.

sybase_close() will not close persistent links generated by sybase_pconnect().

Seznam parametrů

link_identifier

If the link identifier isn't specified, the last opened link is assumed.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

sybase_connect()
sybase_pconnect()

Předcházející | Nahoru | Další
sybase_affected_rows | Domů | sybase_connect


sybase_connect

(PHP 4, PHP 5)

sybase_connect — Opens a Sybase server connection

Popis

resource sybase_connect ( [string $servername [, string $username [, string $password [, string $charset [, string $appname]]]]] )

sybase_connect() establishes a connection to a Sybase server.

In case a second call is made to sybase_connect() with the same arguments, no new link will be established, but instead, the link identifier of the already opened link will be returned.

The link to the server will be closed as soon as the execution of the script ends, unless it's closed earlier by explicitly calling sybase_close().

Seznam parametrů

servername

The servername argument has to be a valid servername that is defined in the 'interfaces' file.

username

Sybase user name

password

Password associated with username.

charset

Specifies the charset for the connection

appname

Návratové hodnoty

Returns a positive Sybase link identifier on success, or FALSE on failure.

ChangeLog (záznam změn)

Verze | Popis
4.0.2 | The charset parameter was added.

Příklady

Příklad 2285. sybase_connect() example

<?php
$link = sybase_connect('SYBASE', '', '')
        or die("Could not connect !");
echo "Connected successfully";
sybase_close($link);
?>

Viz také

sybase_pconnect()
sybase_close()

Předcházející | Nahoru | Další
sybase_close | Domů | sybase_data_seek


sybase_data_seek

(PHP 4, PHP 5)

sybase_data_seek — Moves internal row pointer

Popis

bool sybase_data_seek ( resource $result_identifier, int $row_number )

sybase_data_seek() moves the internal row pointer of the Sybase result associated with the specified result identifier to pointer to the specified row number. The next call to sybase_fetch_row() would return that row.

Seznam parametrů

result_identifier

row_number

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

sybase_fetch_row()

Předcházející | Nahoru | Další
sybase_connect | Domů | sybase_deadlock_retry_count


sybase_deadlock_retry_count

(PHP 4 >= 4.3.0, PHP 5)

sybase_deadlock_retry_count — Sets the deadlock retry count

Popis

void sybase_deadlock_retry_count ( int $retry_count )

Using sybase_deadlock_retry_count(), the number of retries can be defined in cases of deadlocks. By default, every deadlock is retried an infinite number of times or until the process is killed by Sybase, the executing script is killed (for instance, by set_time_limit()) or the query succeeds.

Seznam parametrů

retry_count

Tabulka 305. Values for retry_count

-1 | Retry forever (default)
0 | Do not retry
n | Retry n times

Návratové hodnoty

Nevrací se žádná hodnota.

Poznámky

Poznámka: Tato funkce je k dispozici pouze při použití rozhraní knihovny CT k Sybase, a ne knihovny DB.

Předcházející | Nahoru | Další
sybase_data_seek | Domů | sybase_fetch_array


sybase_fetch_array

(PHP 4, PHP 5)

sybase_fetch_array — Fetch row as array

Popis

array sybase_fetch_array ( resource $result )

sybase_fetch_array() is an extended version of sybase_fetch_row(). In addition to storing the data in the numeric indices of the result array, it also stores the data in associative indices, using the field names as keys.

An important thing to note is that using sybase_fetch_array() is NOT significantly slower than using sybase_fetch_row(), while it provides a significant added value.

Seznam parametrů

result

Návratové hodnoty

Returns an array that corresponds to the fetched row, or FALSE if there are no more rows.

Poznámka: When selecting fields with identical names (for instance, in a join), the associative indices will have a sequential number prepended. See the example for details.

Příklady

Příklad 2286. Identical fieldnames

<?php

$dbh = sybase_connect('SYBASE', '', '');
$q = sybase_query('SELECT * FROM p, a WHERE p.person_id= a.person_id');
var_dump(sybase_fetch_array($q));
sybase_close($dbh);
?>

The above example would produce the following output (assuming the two tables only have each one column called "person_id"):

array(4) {
  [0]=>
  int(1)
  ["person_id"]=>
  int(1)
  [1]=>
  int(1)
  ["person_id1"]=>
  int(1)
}

Viz také

sybase_fetch_row()
sybase_fetch_assoc()
sybase_fetch_object()

Předcházející | Nahoru | Další
sybase_deadlock_retry_count | Domů | sybase_fetch_assoc


sybase_fetch_assoc

(PHP 4 >= 4.3.0, PHP 5)

sybase_fetch_assoc — Fetch a result row as an associative array

Popis

array sybase_fetch_assoc ( resource $result )

sybase_fetch_assoc() is a version of sybase_fetch_row() that uses column names instead of integers for indices in the result array. Columns from different tables with the same names are returned as name, name1, name2, ..., nameN.

An important thing to note is that using sybase_fetch_assoc() is NOT significantly slower than using sybase_fetch_row(), while it provides a significant added value.

Seznam parametrů

result

Návratové hodnoty

Returns an array that corresponds to the fetched row, or FALSE if there are no more rows.

Poznámky

Poznámka: Tato funkce je k dispozici pouze při použití rozhraní knihovny CT k Sybase, a ne knihovny DB.

Viz také

sybase_fetch_row()
sybase_fetch_array()
sybase_fetch_object()

Předcházející | Nahoru | Další
sybase_fetch_array | Domů | sybase_fetch_field


sybase_fetch_field

(PHP 4, PHP 5)

sybase_fetch_field — Get field information from a result

Popis

object sybase_fetch_field ( resource $result [, int $field_offset] )

sybase_fetch_field() can be used in order to obtain information about fields in a certain query result.

Seznam parametrů

result

field_offset

If the field offset isn't specified, the next field that wasn't yet retrieved by sybase_fetch_field() is retrieved.

Návratové hodnoty

Returns an object containing field information.

The properties of the object are:

  • name - column name. if the column is a result of a function, this property is set to computed#N, where #N is a serial number.
  • column_source - the table from which the column was taken
  • max_length - maximum length of the column
  • numeric - 1 if the column is numeric
  • type - datatype of the column

Viz také

sybase_field_seek()

Předcházející | Nahoru | Další
sybase_fetch_assoc | Domů | sybase_fetch_object


sybase_fetch_object

(PHP 4, PHP 5)

sybase_fetch_object — Fetch a row as an object

Popis

object sybase_fetch_object ( resource $result [, mixed $object] )

sybase_fetch_object() is similar to sybase_fetch_assoc(), with one difference - an object is returned, instead of an array.

Speed-wise, the function is identical to sybase_fetch_array(), and almost as quick as sybase_fetch_row() (the difference is insignificant).

Seznam parametrů

result

object

Use the second object to specify the type of object you want to return. If this parameter is omitted, the object will be of type stdClass.

Návratové hodnoty

Returns an object with properties that correspond to the fetched row, or FALSE if there are no more rows.

ChangeLog (záznam změn)

Verze Popis
4.3.0

This function will no longer return numeric object members. Old behaviour:

object(stdclass)(3) {
  [0]=>
  string(3) "foo"
  ["foo"]=>
  string(3) "foo"
  [1]=>
  string(3) "bar"
  ["bar"]=>
  string(3) "bar"
}

New behaviour:

object(stdclass)(3) {
  ["foo"]=>
  string(3) "foo"
  ["bar"]=>
  string(3) "bar"
}

Příklady

Příklad 2287. sybase_fetch_object() return as Foo

<?php
    class Foo {
        var $foo, $bar, $baz;
    }

    // {...]
    $qrh= sybase_query('SELECT foo, bar, baz FROM example');
    $foo= sybase_fetch_object($qrh, 'Foo');
    $bar= sybase_fetch_object($qrh, new Foo());
    // {...]
?>

Viz také

sybase_fetch_array()
sybase_fetch_row()

Předcházející | Nahoru | Další
sybase_fetch_field | Domů | sybase_fetch_row


sybase_fetch_row

(PHP 4, PHP 5)

sybase_fetch_row — Get a result row as an enumerated array

Popis

array sybase_fetch_row ( resource $result )

sybase_fetch_row() fetches one row of data from the result associated with the specified result identifier.

Subsequent call to sybase_fetch_row() would return the next row in the result set, or FALSE if there are no more rows.

Seznam parametrů

result

Návratové hodnoty

Returns an array that corresponds to the fetched row, or FALSE if there are no more rows. Each result column is stored in an array offset, starting at offset 0.

Tabulka 306. Data types

PHP | Sybase
string | VARCHAR, TEXT, CHAR, IMAGE, BINARY, VARBINARY, DATETIME
int | NUMERIC (w/o precision), DECIMAL (w/o precision), INT, BIT, TINYINT, SMALLINT
float | NUMERIC (w/ precision), DECIMAL (w/ precision), REAL, FLOAT, MONEY
NULL | NULL

Viz také

sybase_fetch_array()
sybase_fetch_assoc()
sybase_fetch_object()
sybase_data_seek()
sybase_result()

Předcházející | Nahoru | Další
sybase_fetch_object | Domů | sybase_field_seek


sybase_field_seek

(PHP 4, PHP 5)

sybase_field_seek — Sets field offset

Popis

bool sybase_field_seek ( resource $result, int $field_offset )

Seeks to the specified field offset. If the next call to sybase_fetch_field() won't include a field offset, this field would be returned.

Seznam parametrů

result

field_offset

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

sybase_fetch_field()

Předcházející | Nahoru | Další
sybase_fetch_row | Domů | sybase_free_result


sybase_free_result

(PHP 4, PHP 5)

sybase_free_result — Frees result memory

Popis

bool sybase_free_result ( resource $result )

sybase_free_result() only needs to be called if you are worried about using too much memory while your script is running. All result memory will automatically be freed when the script ends. You may call sybase_free_result() with the result identifier as an argument and the associated result memory will be freed.

Seznam parametrů

result

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
sybase_field_seek | Domů | sybase_get_last_message


sybase_get_last_message

(PHP 4, PHP 5)

sybase_get_last_message — Returns the last message from the server

Popis

string sybase_get_last_message ( void )

sybase_get_last_message() returns the last message reported by the server.

Návratové hodnoty

Returns the message as a string.

Viz také

sybase_min_message_severity()

Předcházející | Nahoru | Další
sybase_free_result | Domů | sybase_min_client_severity


sybase_min_client_severity

(PHP 4, PHP 5)

sybase_min_client_severity — Sets minimum client severity

Popis

void sybase_min_client_severity ( int $severity )

sybase_min_client_severity() sets the minimum client severity level.

Seznam parametrů

severity

Návratové hodnoty

Nevrací se žádná hodnota.

Poznámky

Poznámka: Tato funkce je k dispozici pouze při použití rozhraní knihovny CT k Sybase, a ne knihovny DB.

Viz také

sybase_min_server_severity()

Předcházející | Nahoru | Další
sybase_get_last_message | Domů | sybase_min_error_severity


sybase_min_error_severity

(PHP 4, PHP 5)

sybase_min_error_severity — Sets minimum error severity

Popis

void sybase_min_error_severity ( int $severity )

sybase_min_error_severity() sets the minimum error severity level.

Seznam parametrů

severity

Návratové hodnoty

Nevrací se žádná hodnota.

Poznámky

Poznámka: Tato funkce je k dispozici pouze při použití rozhraní knihovny CT k Sybase, a ne knihovny DB.

Viz také

sybase_min_message_severity()

Předcházející | Nahoru | Další
sybase_min_client_severity | Domů | sybase_min_message_severity


sybase_min_message_severity

(PHP 4, PHP 5)

sybase_min_message_severity — Sets minimum message severity

Popis

void sybase_min_message_severity ( int $severity )

sybase_min_message_severity() sets the minimum message severity level.

Seznam parametrů

severity

Návratové hodnoty

Nevrací se žádná hodnota.

Poznámky

Poznámka: Tato funkce je k dispozici pouze při použití rozhraní knihovny DB k Sybase, a ne knihovny CT.

Viz také

sybase_min_error_severity()

Předcházející | Nahoru | Další
sybase_min_error_severity | Domů | sybase_min_server_severity


sybase_min_server_severity

(PHP 4, PHP 5)

sybase_min_server_severity — Sets minimum server severity

Popis

void sybase_min_server_severity ( int $severity )

sybase_min_server_severity() sets the minimum server severity level.

Seznam parametrů

severity

Návratové hodnoty

Nevrací se žádná hodnota.

Poznámky

Poznámka: Tato funkce je k dispozici pouze při použití rozhraní knihovny CT k Sybase, a ne knihovny DB.

Viz také

sybase_min_client_severity()

Předcházející | Nahoru | Další
sybase_min_message_severity | Domů | sybase_num_fields


sybase_num_fields

(PHP 4, PHP 5)

sybase_num_fields — Gets the number of fields in a result set

Popis

int sybase_num_fields ( resource $result )

sybase_num_fields() returns the number of fields in a result set.

Seznam parametrů

result

Návratové hodnoty

Returns the number of fields as an integer.

Viz také

sybase_query()
sybase_fetch_field()
sybase_num_rows()

Předcházející | Nahoru | Další
sybase_min_server_severity | Domů | sybase_num_rows


sybase_num_rows

(PHP 4, PHP 5)

sybase_num_rows — Get number of rows in a result set

Popis

int sybase_num_rows ( resource $result )

sybase_num_rows() returns the number of rows in a result set.

Seznam parametrů

result

Návratové hodnoty

Returns the number of rows as an integer.

Viz také

sybase_num_fields()
sybase_query()
sybase_fetch_row()

Předcházející | Nahoru | Další
sybase_num_fields | Domů | sybase_pconnect


sybase_pconnect

(PHP 4, PHP 5)

sybase_pconnect — Open persistent Sybase connection

Popis

resource sybase_pconnect ( [string $servername [, string $username [, string $password [, string $charset [, string $appname]]]]] )

sybase_pconnect() acts very much like sybase_connect() with two major differences.

First, when connecting, the function would first try to find a (persistent) link that's already open with the same host, username and password. If one is found, an identifier for it will be returned instead of opening a new connection.

Second, the connection to the SQL server will not be closed when the execution of the script ends. Instead, the link will remain open for future use (sybase_close() will not close links established by sybase_pconnect()).

This type of links is therefore called 'persistent'.

Seznam parametrů

servername

The servername argument has to be a valid servername that is defined in the 'interfaces' file.

username

Sybase user name

password

Password associated with username.

charset

Specifies the charset for the connection

appname

Návratové hodnoty

Returns a positive Sybase persistent link identifier on success, or FALSE on error.

ChangeLog (záznam změn)

Verze | Popis
4.0.2 | The charset parameter was added.

Viz také

sybase_connect()

Předcházející | Nahoru | Další
sybase_num_rows | Domů | sybase_query


sybase_query

(PHP 4, PHP 5)

sybase_query — Sends a Sybase query

Popis

mixed sybase_query ( string $query [, resource $link_identifier] )

sybase_query() sends a query to the currently active database on the server that's associated with the specified link identifier.

Seznam parametrů

query

link_identifier

If the link identifier isn't specified, the last opened link is assumed. If no link is open, the function tries to establish a link as if sybase_connect() was called, and use it.

Návratové hodnoty

Returns a positive Sybase result identifier on success, FALSE on error, or TRUE if the query was successful but didn't return any columns.

Viz také

sybase_select_db()
sybase_connect()

Předcházející | Nahoru | Další
sybase_pconnect | Domů | sybase_result


sybase_result

(PHP 4, PHP 5)

sybase_result — Get result data

Popis

string sybase_result ( resource $result, int $row, mixed $field )

Returns the contents of the cell at the row and offset in the specified Sybase result set.

When working on large result sets, you should consider using one of the functions that fetch an entire row (specified below). As these functions return the contents of multiple cells in one function call, they're MUCH quicker than sybase_result(). Also, note that specifying a numeric offset for the field argument is much quicker than specifying a fieldname or tablename.fieldname argument.

Recommended high-performance alternatives:
sybase_fetch_row(),
sybase_fetch_array() and
sybase_fetch_object().

Seznam parametrů

result

row

field

The field argument can be the field's offset, or the field's name, or the field's table dot field's name (tablename.fieldname). If the column name has been aliased ('select foo as bar from...'), use the alias instead of the column name.

Návratové hodnoty

sybase_result() returns the contents of one cell from a Sybase result set.

Předcházející | Nahoru | Další
sybase_query | Domů | sybase_select_db


sybase_select_db

(PHP 4, PHP 5)

sybase_select_db — Selects a Sybase database

Popis

bool sybase_select_db ( string $database_name [, resource $link_identifier] )

sybase_select_db() sets the current active database on the server that's associated with the specified link identifier.

Every subsequent call to sybase_query() will be made on the active database.

Seznam parametrů

database_name

link_identifier

If no link identifier is specified, the last opened link is assumed. If no link is open, the function will try to establish a link as if sybase_connect() was called, and use it.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

sybase_connect()
sybase_pconnect()
sybase_query()

Předcházející | Nahoru | Další
sybase_result | Domů | sybase_set_message_handler


sybase_set_message_handler

(PHP 4 >= 4.3.0, PHP 5)

sybase_set_message_handler — Sets the handler called when a server message is raised

Popis

bool sybase_set_message_handler ( callback $handler [, resource $connection] )

sybase_set_message_handler() sets a user function to handle messages generated by the server. You may specify the name of a global function, or use an array to specify an object reference and a method name.

Seznam parametrů

handler

The handler expects five arguments in the following order: message number, severity, state, line number and description. The first four are integers. The last is a string. If the function returns FALSE, PHP generates an ordinary error message.

connection

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

ChangeLog (záznam změn)

Verze | Popis
4.3.5 | The connection parameter was added.

Příklady

Příklad 2288. sybase_set_message_handler() callback function

<?php
    function msg_handler($msgnumber, $severity, $state, $line, $text)
    {
        var_dump($msgnumber, $severity, $state, $line, $text);
    }

    sybase_set_message_handler('msg_handler');
?>

Příklad 2289. sybase_set_message_handler() callback to a class

<?php
    class Sybase {
        function handler($msgnumber, $severity, $state, $line, $text)
        {
            var_dump($msgnumber, $severity, $state, $line, $text);
        }
    }

    $sybase= new Sybase();
    sybase_set_message_handler(array($sybase, 'handler'));
?>

Příklad 2290. sybase_set_message_handler() unhandled messages

<?php
    // Return FALSE from this function to indicate you can't handle
    // this. The error is printed out as a warning, the way you're used
    // to it if there is no handler installed.
    function msg_handler($msgnumber, $severity, $state, $line, $text)
    {
        if (257 == $msgnumber) {
            return false;
        }
        var_dump($msgnumber, $severity, $state, $line, $text);
    }

    sybase_set_message_handler('msg_handler');
?>

Poznámky

Poznámka: Tato funkce je k dispozici pouze při použití rozhraní knihovny CT k Sybase, a ne knihovny DB.

Předcházející | Nahoru | Další
sybase_select_db | Domů | sybase_unbuffered_query


sybase_unbuffered_query

(PHP 4 >= 4.3.0, PHP 5)

sybase_unbuffered_query — Send a Sybase query and do not block

Popis

resource sybase_unbuffered_query ( string $query, resource $link_identifier [, bool $store_result] )

sybase_unbuffered_query() sends a query to the currently active database on the server that's associated with the specified link identifier. If the link identifier isn't specified, the last opened link is assumed. If no link is open, the function tries to establish a link as if sybase_connect() was called, and use it.

Unlike sybase_query(), sybase_unbuffered_query() reads only the first row of the result set. sybase_fetch_array() and similar function read more rows as needed. sybase_data_seek() reads up to the target row. The behavior may produce better performance for large result sets.

sybase_num_rows() will only return the correct number of rows if all result sets have been read. To Sybase, the number of rows is not known and is therefore computed by the client implementation.

Poznámka: If you don't read all of the resultsets prior to executing the next query, PHP will raise a warning and cancel all of the pending results. To get rid of this, use sybase_free_result() which will cancel pending results of an unbuffered query.

Seznam parametrů

query

link_identifier

store_result

The optional store_result can be FALSE to indicate the resultsets shouldn't be fetched into memory, thus minimizing memory usage which is particularly interesting with very large resultsets.

Návratové hodnoty

Returns a positive Sybase result identifier on success, or FALSE on error.

Příklady

Příklad 2291. sybase_unbuffered_query() example

<?php

$dbh = sybase_connect('SYBASE', '', '');
$q = sybase_unbuffered_query('select firstname, lastname from huge_table', $dbh, false);
sybase_data_seek($q, 10000);
$i = 0;

while ($row = sybase_fetch_row($q)) {
    echo $row[0], ' ', $row[1], '<br />';
    if ($i++ > 40000) {
        break;
    }
}

sybase_free_result($q);
sybase_close($dbh);

?>

Poznámky

Poznámka: Tato funkce je k dispozici pouze při použití rozhraní knihovny CT k Sybase, a ne knihovny DB.

Viz také

sybase_query()

Předcházející | Nahoru | Další
sybase_set_message_handler | Domů | CLXVI. TCP Wrappers Functions


TCP Wrappers Functions

Předcházející VI. Reference funkcí Další

CLXVI. TCP Wrappers Functions

Úvod

The TCP wrappers provides a classical Unix mechanism which has been designed to check if the remote client is able to connect from the given IP address.

Instalace

Tcpwrap is currently available through PECL » http://pecl.php.net/package/tcpwrap.

If » PEAR is available on your *nix-like system you can use the pear installer to install the tcpwrap extension, by the following command: pear -v install tcpwrap.

You can always download the tar.gz package and install tcpwrap by hand:

Příklad 2292. tcpwrap install by hand

gunzip tcpwrap-xxx.tgz
tar -xvf tcpwrap-xxx.tar
cd tcpwrap-xxx
phpize
./configure && make && make install

Obsah

tcpwrap_check — Performs a tcpwrap check
Předcházející | Nahoru | Další
sybase_unbuffered_query | Domů | tcpwrap_check


tcpwrap_check

(PECL tcpwrap:0.1-1.0)

tcpwrap_check — Performs a tcpwrap check

Popis

bool tcpwrap_check ( string $daemon, string $address [, string $user [, bool $nodns]] )

This function consults the /etc/hosts.allow and /etc/hosts.deny files to check if access to service daemon should be granted or denied for a client.

Seznam parametrů

daemon

The service name.

address

The client remote address. Can be either an IP address or a domain name.

user

An optional user name.

nodns

If address looks like domain name then DNS is used to resolve it to IP address; set nodns to TRUE to avoid this.

Návratové hodnoty

This function returns TRUE if access should be granted, FALSE otherwise.

Příklady

Příklad 2293. Deny all connections from localhost

If your /etc/hosts.deny file contains:

php: 127.0.0.1

And your code looks like:

<?php
if (!tcpwrap_check('php', $_SERVER['REMOTE_ADDR'])) {
  die('You are not welcome here');
}
?>

Viz také

For more details please consult hosts_access(3) man page.

Předcházející | Nahoru | Další
CLXVI. TCP Wrappers Functions | Domů | CLXVII. Tidy Functions


Tidy Functions

Předcházející VI. Reference funkcí Další

CLXVII. Tidy Functions

Úvod

Tidy is a binding for the Tidy HTML clean and repair utility which allows you to not only clean and otherwise manipulate HTML documents, but also traverse the document tree.

Požadavky

To use Tidy, you will need libtidy installed, available on the tidy homepage » http://tidy.sourceforge.net/.

Instalace

Tidy is currently available for PHP 4.3.x and PHP 5 as a PECL extension from » http://pecl.php.net/package/tidy.

Poznámka: Tidy 1.0 is just for PHP 4.3.x, while Tidy 2.0 is just for PHP 5.

If » PEAR is available on your *nix-like system you can use the pear installer to install the tidy extension, by the following command: pecl install tidy.

You can always download the tar.gz package and install tidy by hand:

Příklad 2294. tidy install by hand in PHP 4.3.x

gunzip tidy-xxx.tgz
tar -xvf tidy-xxx.tar
cd tidy-xxx
phpize
./configure && make && make install

Windows users can download the extension dll from » http://pecl4win.php.net/ext.php/php_tidy.dll.

In PHP 5 you need only to compile using the --with-tidy option.

Konfigurace běhu

Chování těchto funkcí je ovlivněno nastavením parametrů v php.ini.

Tabulka 307. Tidy Configuration Options

Name | Default | Changeable | Changelog
tidy.default_config | "" | PHP_INI_SYSTEM | Available since PHP 5.0.0.
tidy.clean_output | "0" | PHP_INI_USER | PHP_INI_PERDIR in PHP 5. Available since PHP 5.0.0.

Pro další detaily a definice konstant PHP_INI_*, viz dokumentace k ini_set().

Zde je stručný popis konfiguračních direktiv.

tidy.default_config string

Default path for tidy config file.

tidy.clean_output boolean

Turns on/off the output repairing by Tidy.

Varování

Do not turn on tidy.clean_output if you are generating non-html content such as dynamic images.

Typy prostředků

Toto rozšíření nemá definován žádný typ prostředku (resource).

Předdefinované třídy

tidyNode

Metody

  • tidyNode::getParent - Returns the parent of the current node

  • tidyNode->hasChildren - Returns TRUE if the current node has children

  • tidyNode->hasSiblings - Returns TRUE if the current node has siblings

  • tidyNode->isAsp - Returns TRUE if the current node is ASP code

  • tidyNode->isComment - Returns TRUE if the current node is a comment

  • tidyNode->isHtml - Returns TRUE if the current node is HTML

  • tidyNode->isJste - Returns TRUE if the current node is JSTE

  • tidyNode->isPhp - Returns TRUE if the current node is PHP

  • tidyNode->isText - Returns TRUE if the current node is Text (no markup)

Vlastnosti

  • value - the value of the node (e.g. the html text)

  • name - the name of the tag (e.g. html, a, etc..)

  • type - the type of the node (one of the constants above, e.g. TIDY_NODETYPE_PHP)

  • line* - the line where the node starts

  • column* - the column where the node starts

  • proprietary* - TRUE if the node refers to a proprietary tag

  • id - the ID of the tag (one of the constants above, e.g. TIDY_TAG_FRAME)

  • attribute - an array with the attributes of the current node, or NULL if there aren't any

  • child - an array with the child tidyNodes, or NULL if there aren't any

Poznámka: The properties marked with * are just available since PHP 5.1.0.

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

Each TIDY_TAG_XXX represents a HTML tag. For example, TIDY_TAG_A represents a <a href="XX">link</a> tag. Each TIDY_ATTR_XXX represents a HTML atribute. For example TIDY_ATTR_HREF would represent the href atribute in the previous example.

The following constants are defined:

Tabulka 308. tidy tag constants

constant
TIDY_TAG_UNKNOWN
TIDY_TAG_A
TIDY_TAG_ABBR
TIDY_TAG_ACRONYM
TIDY_TAG_ALIGN
TIDY_TAG_APPLET
TIDY_TAG_AREA
TIDY_TAG_B
TIDY_TAG_BASE
TIDY_TAG_BASEFONT
TIDY_TAG_BDO
TIDY_TAG_BGSOUND
TIDY_TAG_BIG
TIDY_TAG_BLINK
TIDY_TAG_BLOCKQUOTE
TIDY_TAG_BODY
TIDY_TAG_BR
TIDY_TAG_BUTTON
TIDY_TAG_CAPTION
TIDY_TAG_CENTER
TIDY_TAG_CITE
TIDY_TAG_CODE
TIDY_TAG_COL
TIDY_TAG_COLGROUP
TIDY_TAG_COMMENT
TIDY_TAG_DD
TIDY_TAG_DEL
TIDY_TAG_DFN
TIDY_TAG_DIR
TIDY_TAG_DIV
TIDY_TAG_DL
TIDY_TAG_DT
TIDY_TAG_EM
TIDY_TAG_EMBED
TIDY_TAG_FIELDSET
TIDY_TAG_FONT
TIDY_TAG_FORM
TIDY_TAG_FRAME
TIDY_TAG_FRAMESET
TIDY_TAG_H1
TIDY_TAG_H2
TIDY_TAG_H3
TIDY_TAG_H4
TIDY_TAG_H5
TIDY_TAG_H6
TIDY_TAG_HEAD
TIDY_TAG_HR
TIDY_TAG_HTML
TIDY_TAG_I
TIDY_TAG_IFRAME
TIDY_TAG_ILAYER
TIDY_TAG_IMG
TIDY_TAG_INPUT
TIDY_TAG_INS
TIDY_TAG_ISINDEX
TIDY_TAG_KBD
TIDY_TAG_KEYGEN
TIDY_TAG_LABEL
TIDY_TAG_LAYER
TIDY_TAG_LEGEND
TIDY_TAG_LI
TIDY_TAG_LINK
TIDY_TAG_LISTING
TIDY_TAG_MAP
TIDY_TAG_MARQUEE
TIDY_TAG_MENU
TIDY_TAG_META
TIDY_TAG_MULTICOL
TIDY_TAG_NOBR
TIDY_TAG_NOEMBED
TIDY_TAG_NOFRAMES
TIDY_TAG_NOLAYER
TIDY_TAG_NOSAVE
TIDY_TAG_NOSCRIPT
TIDY_TAG_OBJECT
TIDY_TAG_OL
TIDY_TAG_OPTGROUP
TIDY_TAG_OPTION
TIDY_TAG_P
TIDY_TAG_PARAM
TIDY_TAG_PLAINTEXT
TIDY_TAG_PRE
TIDY_TAG_Q
TIDY_TAG_RP
TIDY_TAG_RT
TIDY_TAG_RTC
TIDY_TAG_RUBY
TIDY_TAG_S
TIDY_TAG_SAMP
TIDY_TAG_SCRIPT
TIDY_TAG_SELECT
TIDY_TAG_SERVER
TIDY_TAG_SERVLET
TIDY_TAG_SMALL
TIDY_TAG_SPACER
TIDY_TAG_SPAN
TIDY_TAG_STRIKE
TIDY_TAG_STRONG
TIDY_TAG_STYLE
TIDY_TAG_SUB
TIDY_TAG_TABLE
TIDY_TAG_TBODY
TIDY_TAG_TD
TIDY_TAG_TEXTAREA
TIDY_TAG_TFOOT
TIDY_TAG_TH
TIDY_TAG_THEAD
TIDY_TAG_TITLE
TIDY_TAG_TR
TIDY_TAG_TR
TIDY_TAG_TT
TIDY_TAG_U
TIDY_TAG_UL
TIDY_TAG_VAR
TIDY_TAG_WBR
TIDY_TAG_XMP

Tabulka 309. tidy attribute constants

constant
TIDY_ATTR_UNKNOWN
TIDY_ATTR_ABBR
TIDY_ATTR_ACCEPT
TIDY_ATTR_ACCEPT_CHARSET
TIDY_ATTR_ACCESSKEY
TIDY_ATTR_ACTION
TIDY_ATTR_ADD_DATE
TIDY_ATTR_ALIGN
TIDY_ATTR_ALINK
TIDY_ATTR_ALT
TIDY_ATTR_ARCHIVE
TIDY_ATTR_AXIS
TIDY_ATTR_BACKGROUND
TIDY_ATTR_BGCOLOR
TIDY_ATTR_BGPROPERTIES
TIDY_ATTR_BORDER
TIDY_ATTR_BORDERCOLOR
TIDY_ATTR_BOTTOMMARGIN
TIDY_ATTR_CELLPADDING
TIDY_ATTR_CELLSPACING
TIDY_ATTR_CHAR
TIDY_ATTR_CHAROFF
TIDY_ATTR_CHARSET
TIDY_ATTR_CHECKED
TIDY_ATTR_CITE
TIDY_ATTR_CLASS
TIDY_ATTR_CLASSID
TIDY_ATTR_CLEAR
TIDY_ATTR_CODE
TIDY_ATTR_CODEBASE
TIDY_ATTR_CODETYPE
TIDY_ATTR_COLOR
TIDY_ATTR_COLS
TIDY_ATTR_COLSPAN
TIDY_ATTR_COMPACT
TIDY_ATTR_CONTENT
TIDY_ATTR_COORDS
TIDY_ATTR_DATA
TIDY_ATTR_DATAFLD
TIDY_ATTR_DATAPAGESIZE
TIDY_ATTR_DATASRC
TIDY_ATTR_DATETIME
TIDY_ATTR_DECLARE
TIDY_ATTR_DEFER
TIDY_ATTR_DIR
TIDY_ATTR_DISABLED
TIDY_ATTR_ENCODING
TIDY_ATTR_ENCTYPE
TIDY_ATTR_FACE
TIDY_ATTR_FOR
TIDY_ATTR_FRAME
TIDY_ATTR_FRAMEBORDER
TIDY_ATTR_FRAMESPACING
TIDY_ATTR_GRIDX
TIDY_ATTR_GRIDY
TIDY_ATTR_HEADERS
TIDY_ATTR_HEIGHT
TIDY_ATTR_HREF
TIDY_ATTR_HREFLANG
TIDY_ATTR_HSPACE
TIDY_ATTR_HTTP_EQUIV
TIDY_ATTR_ID
TIDY_ATTR_ISMAP
TIDY_ATTR_LABEL
TIDY_ATTR_LANG
TIDY_ATTR_LANGUAGE
TIDY_ATTR_LAST_MODIFIED
TIDY_ATTR_LAST_VISIT
TIDY_ATTR_LEFTMARGIN
TIDY_ATTR_LINK
TIDY_ATTR_LONGDESC
TIDY_ATTR_LOWSRC
TIDY_ATTR_MARGINHEIGHT
TIDY_ATTR_MARGINWIDTH
TIDY_ATTR_MAXLENGTH
TIDY_ATTR_MEDIA
TIDY_ATTR_METHOD
TIDY_ATTR_MULTIPLE
TIDY_ATTR_NAME
TIDY_ATTR_NOHREF
TIDY_ATTR_NORESIZE
TIDY_ATTR_NOSHADE
TIDY_ATTR_NOWRAP
TIDY_ATTR_OBJECT
TIDY_ATTR_OnAFTERUPDATE
TIDY_ATTR_OnBEFOREUNLOAD
TIDY_ATTR_OnBEFOREUPDATE
TIDY_ATTR_OnBLUR
TIDY_ATTR_OnCHANGE
TIDY_ATTR_OnCLICK
TIDY_ATTR_OnDATAAVAILABLE
TIDY_ATTR_OnDATASETCHANGED
TIDY_ATTR_OnDATASETCOMPLETE
TIDY_ATTR_OnDBLCLICK
TIDY_ATTR_OnERRORUPDATE
TIDY_ATTR_OnFOCUS
TIDY_ATTR_OnKEYDOWN
TIDY_ATTR_OnKEYPRESS
TIDY_ATTR_OnKEYUP
TIDY_ATTR_OnLOAD
TIDY_ATTR_OnMOUSEDOWN
TIDY_ATTR_OnMOUSEMOVE
TIDY_ATTR_OnMOUSEOUT
TIDY_ATTR_OnMOUSEOVER
TIDY_ATTR_OnMOUSEUP
TIDY_ATTR_OnRESET
TIDY_ATTR_OnROWENTER
TIDY_ATTR_OnROWEXIT
TIDY_ATTR_OnSELECT
TIDY_ATTR_OnSUBMIT
TIDY_ATTR_OnUNLOAD
TIDY_ATTR_PROFILE
TIDY_ATTR_PROMPT
TIDY_ATTR_RBSPAN
TIDY_ATTR_READONLY
TIDY_ATTR_REL
TIDY_ATTR_REV
TIDY_ATTR_RIGHTMARGIN
TIDY_ATTR_ROWS
TIDY_ATTR_ROWSPAN
TIDY_ATTR_RULES
TIDY_ATTR_SCHEME
TIDY_ATTR_SCOPE
TIDY_ATTR_SCROLLING
TIDY_ATTR_SELECTED
TIDY_ATTR_SHAPE
TIDY_ATTR_SHOWGRID
TIDY_ATTR_SHOWGRIDX
TIDY_ATTR_SHOWGRIDY
TIDY_ATTR_SIZE
TIDY_ATTR_SPAN
TIDY_ATTR_SRC
TIDY_ATTR_STANDBY
TIDY_ATTR_START
TIDY_ATTR_STYLE
TIDY_ATTR_SUMMARY
TIDY_ATTR_TABINDEX
TIDY_ATTR_TARGET
TIDY_ATTR_TEXT
TIDY_ATTR_TITLE
TIDY_ATTR_TOPMARGIN
TIDY_ATTR_TYPE
TIDY_ATTR_USEMAP
TIDY_ATTR_VALIGN
TIDY_ATTR_VALUE
TIDY_ATTR_VALUETYPE
TIDY_ATTR_VERSION
TIDY_ATTR_VLINK
TIDY_ATTR_VSPACE
TIDY_ATTR_WIDTH
TIDY_ATTR_WRAP
TIDY_ATTR_XML_LANG
TIDY_ATTR_XML_SPACE
TIDY_ATTR_XMLNS

Tabulka 310. tidy nodetype constants

constant | description
TIDY_NODETYPE_ROOT | root node
TIDY_NODETYPE_DOCTYPE | doctype
TIDY_NODETYPE_COMMENT | HTML comment
TIDY_NODETYPE_PROCINS | Processing Instruction
TIDY_NODETYPE_TEXT | Text
TIDY_NODETYPE_START | start tag
TIDY_NODETYPE_END | end tag
TIDY_NODETYPE_STARTEND | empty tag
TIDY_NODETYPE_CDATA | CDATA
TIDY_NODETYPE_SECTION | XML section
TIDY_NODETYPE_ASP | ASP code
TIDY_NODETYPE_JSTE | JSTE code
TIDY_NODETYPE_PHP | PHP code
TIDY_NODETYPE_XMLDECL | XML declaration

Příklady

This simple example shows basic Tidy usage.

Příklad 2295. Basic Tidy usage

<?php
ob_start();
?>
<html>a html document</html>
<?php
$html = ob_get_clean();

// Specify configuration
$config = array(
           'indent'         => true,
           'output-xhtml'   => true,
           'wrap'           => 200);

// Tidy
$tidy = new tidy;
$tidy->parseString($html, $config, 'utf8');
$tidy->cleanRepair();

// Output
echo $tidy;
?>

Obsah

ob_tidyhandler — ob_start callback function to repair the buffer
tidy_access_count — Returns the Number of Tidy accessibility warnings encountered for specified document
tidy_clean_repair — Execute configured cleanup and repair operations on parsed markup
tidy_config_count — Returns the Number of Tidy configuration errors encountered for specified document
tidy::__construct — Constructs a new tidy object
tidy_diagnose — Run configured diagnostics on parsed and repaired markup
tidy_error_count — Returns the Number of Tidy errors encountered for specified document
tidy_get_body — Returns a tidyNode Object starting from the <body> tag of the tidy parse tree
tidy_get_config — Get current Tidy configuration
tidy_get_error_buffer — Return warnings and errors which occurred parsing the specified document
tidy_get_head — Returns a tidyNode Object starting from the <head> tag of the tidy parse tree
tidy_get_html_ver — Get the Detected HTML version for the specified document
tidy_get_html — Returns a tidyNode Object starting from the <html> tag of the tidy parse tree
tidy_get_opt_doc — Returns the documentation for the given option name
tidy_get_output — Return a string representing the parsed tidy markup
tidy_get_release — Get release date (version) for Tidy library
tidy_get_root — Returns a tidyNode object representing the root of the tidy parse tree
tidy_get_status — Get status of specified document
tidy_getopt — Returns the value of the specified configuration option for the tidy document
tidy_is_xhtml — Indicates if the document is a XHTML document
tidy_is_xml — Indicates if the document is a generic (non HTML/XHTML) XML document
tidy_load_config — Load an ASCII Tidy configuration file with the specified encoding
tidy_node->get_attr — Return the attribute with the provided attribute id
tidy_node->get_nodes — Return an array of nodes under this node with the specified id
tidy_node->next — Returns the next sibling to this node
tidy_node->prev — Returns the previous sibling to this node
tidy_parse_file — Parse markup in file or URI
tidy_parse_string — Parse a document stored in a string
tidy_repair_file — Repair a file and return it as a string
tidy_repair_string — Repair a string using an optionally provided configuration file
tidy_reset_config — Restore Tidy configuration to default values
tidy_save_config — Save current settings to named file
tidy_set_encoding — Set the input/output character encoding for parsing markup
tidy_setopt — Updates the configuration settings for the specified tidy document
tidy_warning_count — Returns the Number of Tidy warnings encountered for specified document
tidyNode->hasChildren — Returns true if this node has children
tidyNode->hasSiblings — Returns true if this node has siblings
tidyNode->isAsp — Returns true if this node is ASP
tidyNode->isComment — Returns true if this node represents a comment
tidyNode->isHtml — Returns true if this node is part of a HTML document
tidyNode->isJste — Returns true if this node is JSTE
tidyNode->isPhp — Returns true if this node is PHP
tidyNode->isText — Returns true if this node represents text (no markup)
tidyNode::getParent — returns the parent node of the current node
Předcházející | Nahoru | Další
tcpwrap_check | Domů | ob_tidyhandler


ob_tidyhandler

(PHP 5)

ob_tidyhandler — ob_start callback function to repair the buffer

Description

string ob_tidyhandler ( string $input [, int $mode] )

ob_tidyhandler() is intended to be used as a callback function for ob_start() to repair the buffer.

Příklad 2296. ob_tidyhandler() example

<?php
ob_start('ob_tidyhandler');

echo '<p>test</i>';
?>

Výše uvedený příklad vypíše:

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 3.2//EN">
<html>
<head>
<title></title>
</head>
<body>
<p>test</p>
</body>
</html>

See also ob_start().

Předcházející | Nahoru | Další
CLXVII. Tidy Functions | Domů | tidy_access_count


tidy_access_count

(PHP 5, PECL tidy:0.5.2-1.2)

tidy_access_count — Returns the Number of Tidy accessibility warnings encountered for specified document

Description

int tidy_access_count ( tidy $object )

tidy_access_count() returns the number of accessibility warnings found for the specified document.

Poznámka: Due to the design of the TidyLib, you must call tidy_diagnose() before tidy_access_count() or it will return always 0. You must also need to enable the accessibility-check option.

Příklad 2297. tidy_access_count() example

<?php

$html ='<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 3.2//EN">
<html><head><title>Title</title></head>
<body>

<p><img src="img.png"></p>

</body></html>';

// select the accessibility check level: 1, 2 or 3
$config = array('accessibility-check' => 3);

$tidy = new tidy();
$tidy->parseString($html, $config);
$tidy->CleanRepair();

/* Never forget to call this! */
$tidy->diagnose();

echo tidy_access_count($tidy); //5

?>

See also tidy_error_count() and tidy_warning_count().

Předcházející | Nahoru | Další
ob_tidyhandler | Domů | tidy_clean_repair


tidy_clean_repair

(PHP 5, PECL tidy:0.5.2-1.2)

tidy_clean_repair — Execute configured cleanup and repair operations on parsed markup

Description

Procedural style:

bool tidy_clean_repair ( tidy $object )

Object oriented style:

bool tidy->cleanRepair ( void )

This function cleans and repairs the given tidy object.

Příklad 2298. tidy_clean_repair() example

<?php
$html = '<p>test</I>';

$tidy = tidy_parse_string($html);
tidy_clean_repair($tidy);

echo $tidy;
?>

Výše uvedený příklad vypíše:

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 3.2//EN">
<html>
<head>
<title></title>
</head>
<body>
<p>test</p>
</body>
</html>

See also tidy_repair_file() and tidy_repair_string().

Předcházející | Nahoru | Další
tidy_access_count | Domů | tidy_config_count


tidy_config_count

(PHP 5, PECL tidy:0.5.2-1.2)

tidy_config_count — Returns the Number of Tidy configuration errors encountered for specified document

Description

int tidy_config_count ( tidy $object )

tidy_config_count() returns the number of errors encountered in the configuration of the specified tidy object.

Příklad 2299. tidy_config_count() example

<?php
$html = '<p>test</I>';

$config = array('doctype' => 'bogus');

$tidy = tidy_parse_string($html, $config);

/* This outputs 1, because 'bogus' isn't a valid doctype */
echo tidy_config_count($tidy);
?>

Předcházející | Nahoru | Další
tidy_clean_repair | Domů | tidy::__construct


tidy::__construct

(No version information available, might be only in CVS)

tidy::__construct — Constructs a new tidy object

Description

tidy tidy::__construct ( [string $filename [, mixed $config [, string $encoding [, bool $use_include_path]]]] )

tidy::__construct() constructs a new tidy object.

If the filename parameter is given, this function will also read that file and initialize the object with the file, acting like tidy_parse_file().

Parametr config lze předávat jak jako pole, tak jako řetězec. Předává-li se jako řetězec, představuje název konfiguračního souboru, jinak jsou obsažené parametry přímo interpretovány. Vysvětlení všech voleb naleznete na » http://tidy.sourceforge.net/docs/quickref.html

Parametr encoding nastavuje kódování pro vstupní/výstupní dokumenty. Možné hodnoty parametru encoding jsou: ascii, latin0, latin1, raw, utf8, iso202, utf16le, utf16be, utf16, mac, win1252, ibm858, big5 a shiftjis.

Příklad 2300. tidy::__construct() example

<?php

$html = <<< HTML

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head><title>title</title></head>
<body>
<p>paragraph <bt />
text</p>
</body></html>

HTML;

$tidy = new tidy;
$tidy->parseString($html);

$tidy->CleanRepair();

if ($tidy->errorBuffer) {
    echo "The following errors were detected:\n";
    echo $tidy->errorBuffer;
}

?>

Výše uvedený příklad vypíše:

The following errors were detected:
line 8 column 14 - Error: <bt> is not recognized!
line 8 column 14 - Warning: discarding unexpected <bt>

See also tidy_parse_file() and tidy_parse_string().

Předcházející | Nahoru | Další
tidy_config_count | Domů | tidy_diagnose


tidy_diagnose

(PHP 5, PECL tidy:0.5.2-1.2)

tidy_diagnose — Run configured diagnostics on parsed and repaired markup

Description

Procedural style:

bool tidy_diagnose ( tidy $object )

Object oriented style:

bool tidy->diagnose ( void )

tidy_diagnose() runs diagnostic tests on the given tidy object, adding some more information about the document in the error buffer.

Vrací TRUE při úspěchu, FALSE při selhání.

Příklad 2301. tidy_diagnose() example

<?php

$html = <<< HTML
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">

<p>paragraph</p>
HTML;

$tidy = tidy_parse_string($html);
$tidy->CleanRepair();

// note the difference between the two outputs
echo tidy_get_error_buffer($tidy) . "\n";

$tidy->diagnose();
echo tidy_get_error_buffer($tidy);

?>

Výše uvedený příklad vypíše:

line 5 column 1 - Warning: <p> isn't allowed in <head> elements
line 5 column 1 - Warning: inserting missing 'title' element

line 5 column 1 - Warning: <p> isn't allowed in <head> elements
line 5 column 1 - Warning: inserting missing 'title' element
Info: Doctype given is "-//W3C//DTD XHTML 1.0 Strict//EN"
Info: Document content looks like XHTML 1.0 Strict
2 warnings, 0 errors were found!

See also tidy_get_error_buffer().

Předcházející | Nahoru | Další
tidy::__construct | Domů | tidy_error_count


tidy_error_count

(PHP 5, PECL tidy:0.5.2-1.2)

tidy_error_count — Returns the Number of Tidy errors encountered for specified document

Description

int tidy_error_count ( tidy $object )

tidy_error_count() returns the number of Tidy errors encountered for the specified document.

Příklad 2302. tidy_error_count() example

<?php
$html = '<p>test</i>
<bogustag>bogus</bogustag>';

$tidy = tidy_parse_string($html);

echo tidy_error_count($tidy) . "\n"; //1

echo $tidy->errorBuffer;
?>

Výše uvedený příklad vypíše:

1
line 1 column 1 - Warning: missing <!DOCTYPE> declaration
line 1 column 8 - Warning: discarding unexpected </i>
line 2 column 1 - Error: <bogustag> is not recognized!
line 2 column 1 - Warning: discarding unexpected <bogustag>
line 2 column 16 - Warning: discarding unexpected </bogustag>
line 1 column 1 - Warning: inserting missing 'title' element

See also tidy_access_count() and tidy_warning_count().

Předcházející | Nahoru | Další
tidy_diagnose | Domů | tidy_get_body


tidy_get_body

(PHP 5, PECL tidy:0.5.2-1.0)

tidy_get_body — Returns a tidyNode Object starting from the <body> tag of the tidy parse tree

Description

Procedural style:

tidyNode tidy_get_body ( tidy $object )

Object oriented style:

tidyNode tidy->body ( void )

This function returns a tidyNode object starting from the <body> tag of the tidy parse tree.

Příklad 2303. tidy_get_body() example

<?php
$html = '
<html>
  <head>
    <title>test</title>
  </head>
  <body>
    <p>paragraph</p>
  </body>
</html>';

$tidy = tidy_parse_string($html);

$body = tidy_get_body($tidy);
echo $body->value;
?>

Výše uvedený příklad vypíše:

<body>
<p>paragraph</p>
</body>

Poznámka: Tato funkce je k dispozici pouze v Zend Engine 2, to znamená v PHP >= 5.0.0.

See also tidy_get_head() and tidy_get_html().

Předcházející | Nahoru | Další
tidy_error_count | Domů | tidy_get_config


tidy_get_config

(PHP 5, PECL tidy:0.7-1.2)

tidy_get_config — Get current Tidy configuration

Description

Procedural style:

array tidy_get_config ( tidy $object )

Object oriented style:

array tidy->getConfig ( void )

tidy_get_config() returns an array with the configuration options in use by the given tidy object.

For an explanation about each option, visit » http://tidy.sourceforge.net/docs/quickref.html.

Příklad 2304. tidy_get_config() example

<?php
$html = '<p>test</p>';
$config = array('indent' => TRUE,
                'output-xhtml' => TRUE,
                'wrap' => 200);

$tidy = tidy_parse_string($html, $config);

print_r(tidy_get_config($tidy));
?>

Výše uvedený příklad vypíše:

Array
(
    [indent-spaces] => 2
    [wrap] => 200
    [tab-size] => 8
    [char-encoding] => 1
    [input-encoding] => 3
    [output-encoding] => 1
    [newline] => 1
    [doctype-mode] => 1
    [doctype] =>
    [repeated-attributes] => 1
    [alt-text] =>
    [slide-style] =>
    [error-file] =>
    [output-file] =>
    [write-back] =>
    [markup] => 1
    [show-warnings] => 1
    [quiet] =>
    [indent] => 1
    [hide-endtags] =>
    [input-xml] =>
    [output-xml] => 1
    [output-xhtml] => 1
    [output-html] =>
    [add-xml-decl] =>
    [uppercase-tags] =>
    [uppercase-attributes] =>
    [bare] =>
    [clean] =>
    [logical-emphasis] =>
    [drop-proprietary-attributes] =>
    [drop-font-tags] =>
    [drop-empty-paras] => 1
    [fix-bad-comments] => 1
    [break-before-br] =>
    [split] =>
    [numeric-entities] =>
    [quote-marks] =>
    [quote-nbsp] => 1
    [quote-ampersand] => 1
    [wrap-attributes] =>
    [wrap-script-literals] =>
    [wrap-sections] => 1
    [wrap-asp] => 1
    [wrap-jste] => 1
    [wrap-php] => 1
    [fix-backslash] => 1
    [indent-attributes] =>
    [assume-xml-procins] =>
    [add-xml-space] =>
    [enclose-text] =>
    [enclose-block-text] =>
    [keep-time] =>
    [word-2000] =>
    [tidy-mark] =>
    [gnu-emacs] =>
    [gnu-emacs-file] =>
    [literal-attributes] =>
    [show-body-only] =>
    [fix-uri] => 1
    [lower-literals] => 1
    [hide-comments] =>
    [indent-cdata] =>
    [force-output] => 1
    [show-errors] => 6
    [ascii-chars] => 1
    [join-classes] =>
    [join-styles] => 1
    [escape-cdata] =>
    [language] =>
    [ncr] => 1
    [output-bom] => 2
    [replace-color] =>
    [css-prefix] =>
    [new-inline-tags] =>
    [new-blocklevel-tags] =>
    [new-empty-tags] =>
    [new-pre-tags] =>
    [accessibility-check] => 0
    [vertical-space] =>
    [punctuation-wrap] =>
    [merge-divs] => 1
)

See also tidy_reset_config() and tidy_save_config().

Předcházející | Nahoru | Další
tidy_get_body | Domů | tidy_get_error_buffer


tidy_get_error_buffer

(PHP 5, PECL tidy:0.5.2-1.2)

tidy_get_error_buffer — Return warnings and errors which occurred parsing the specified document

Description

Procedural style:

string tidy_get_error_buffer ( tidy $object )

Object oriented style (property):

class tidy {
string errorBuffer
}

tidy_get_error_buffer() returns warnings and errors which occurred parsing the specified document.

Příklad 2305. tidy_get_error_buffer() example

<?php
$html = '<p>paragraph</p>';

$tidy = tidy_parse_string($html);

echo tidy_get_error_buffer($tidy);
/* or in OO: */
echo $tidy->errorBuffer;
?>

Výše uvedený příklad vypíše:

line 1 column 1 - Warning: missing <!DOCTYPE> declaration
line 1 column 1 - Warning: inserting missing 'title' element

See also tidy_access_count(),
tidy_error_count() and
tidy_warning_count().

Předcházející | Nahoru | Další
tidy_get_config | Domů | tidy_get_head


tidy_get_head

(PHP 5, PECL tidy:0.5.2-1.0)

tidy_get_head — Returns a tidyNode Object starting from the <head> tag of the tidy parse tree

Description

Procedural style:

tidyNode tidy_get_head ( tidy $object )

Object oriented style:

tidyNode tidy->head ( void )

This function returns a tidyNode object starting from the <head> tag of the tidy parse tree.

Příklad 2306. tidy_get_head() example

<?php
$html = '
<html>
  <head>
    <title>test</title>
  </head>
  <body>
    <p>paragraph</p>
  </body>
</html>';

$tidy = tidy_parse_string($html);

$head = tidy_get_head($tidy);
echo $head->value;
?>

Výše uvedený příklad vypíše:

<head>
<title>test</title>
</head>

Poznámka: Tato funkce je k dispozici pouze v Zend Engine 2, to znamená v PHP >= 5.0.0.

See also tidy_get_body() and tidy_get_html().

Předcházející | Nahoru | Další
tidy_get_error_buffer | Domů | tidy_get_html_ver


tidy_get_html_ver

(PHP 5, PECL tidy:0.5.2-1.2)

tidy_get_html_ver — Get the Detected HTML version for the specified document

Description

Procedural style:

int tidy_get_html_ver ( tidy $object )

Object oriented style:

int tidy->getHtmlVer ( void )

tidy_get_html_ver() returns the detected HTML version for the specified tidy object.

Varování

This function is not yet implemented in the Tidylib itself, so it always return 0.

Předcházející | Nahoru | Další
tidy_get_head | Domů | tidy_get_html


tidy_get_html

(PHP 5, PECL tidy:0.5.2-1.0)

tidy_get_html — Returns a tidyNode Object starting from the <html> tag of the tidy parse tree

Description

Procedural style:

tidyNode tidy_get_html ( tidy $object )

Object oriented style:

tidyNode tidy->html ( void )

This function returns a tidyNode object starting from the <html> tag of the tidy parse tree.

Příklad 2307. tidy_get_html() example

<?php
$html = '
<html>
  <head>
    <title>test</title>
  </head>
  <body>
    <p>paragraph</p>
  </body>
</html>';

$tidy = tidy_parse_string($html);

$html = tidy_get_html($tidy);
echo $html->value;
?>

Výše uvedený příklad vypíše:

<html>
<head>
<title>test</title>
</head>
<body>
<p>paragraph</p>
</body>
</html>

Poznámka: Tato funkce je k dispozici pouze v Zend Engine 2, to znamená v PHP >= 5.0.0.

See also tidy_get_body() and tidy_get_head().

Předcházející | Nahoru | Další
tidy_get_html_ver | Domů | tidy_get_opt_doc


tidy_get_output

(PHP 5, PECL tidy:0.5.2-1.2)

tidy_get_output — Return a string representing the parsed tidy markup

Description

string tidy_get_output ( tidy $object )

tidy_get_output() returns a string with the repaired html.

Příklad 2309. tidy_get_output() example

<?php

$html = '<p>paragraph</i>';
$tidy = tidy_parse_string($html);

$tidy->CleanRepair();

echo tidy_get_output($tidy);
?>

Výše uvedený příklad vypíše:

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 3.2//EN">
<html>
<head>
<title></title>
</head>
<body>
<p>paragraph</p>
</body>
</html>

Předcházející | Nahoru | Další
tidy_get_opt_doc | Domů | tidy_get_release


tidy_get_release

(PHP 5, PECL tidy:0.5.2-1.2)

tidy_get_release — Get release date (version) for Tidy library

Description

Procedural style:

string tidy_get_release ( void )

Object oriented style:

string tidy->getRelease ( void )

This function returns a string with the release date of the Tidy library.

Předcházející | Nahoru | Další
tidy_get_output | Domů | tidy_get_root


tidy_get_root

(PHP 5, PECL tidy:0.5.2-1.0)

tidy_get_root — Returns a tidyNode object representing the root of the tidy parse tree

Description

Procedural style:

tidyNode tidy_get_root ( tidy $object )

Object oriented style:

tidyNode tidy->root ( void )

Returns a tidyNode object representing the root of the tidy parse tree.

Příklad 2310. dump nodes

<?php

$html = <<< HTML
<html><body>

<p>paragraph</p>
<br/>

</body></html>
HTML;

$tidy = tidy_parse_string($html);
dump_nodes($tidy->root(), 1);

function dump_nodes($node, $indent) {

    if($node->hasChildren()) {
        foreach($node->child as $child) {
            echo str_repeat('.', $indent*2) . ($child->name ? $child->name : '"'.$child->value.'"'). "\n";

            dump_nodes($child, $indent+1);
        }
    }
}
?>

Výše uvedený příklad vypíše:

..html
....head
......title
....body
......p
........"paragraph"
......br

Poznámka: Tato funkce je k dispozici pouze v Zend Engine 2, to znamená v PHP >= 5.0.0.

Předcházející | Nahoru | Další
tidy_get_release | Domů | tidy_get_status


tidy_get_status

(PHP 5, PECL tidy:0.5.2-1.2)

tidy_get_status — Get status of specified document

Description

Procedural style:

int tidy_get_status ( tidy $object )

Object oriented style:

int tidy->getStatus ( void )

tidy_get_status() returns the status for the specified tidy object. It returns 0 if no error/warning was raised, 1 for warnings or accessibility errors, or 2 for errors.

Příklad 2311. tidy_get_status() example

<?php
$html = '<p>paragraph</i>';
$tidy = tidy_parse_string($html);

$html2 = '<bogus>test</bogus>';
$tidy2 = tidy_parse_string($html2);

echo tidy_get_status($tidy); //1

echo tidy_get_status($tidy2); //2
?>

Předcházející | Nahoru | Další
tidy_get_root | Domů | tidy_getopt


tidy_getopt

(PHP 5, PECL tidy:0.5.2-1.2)

tidy_getopt — Returns the value of the specified configuration option for the tidy document

Description

Procedural style:

mixed tidy_getopt ( tidy $object, string $option )

Object oriented style:

mixed tidy->getOpt ( string $option )

tidy_getopt() returns the value of the specified option for the specified tidy object. The return type depends on the type of the specified option. You will find a list with each configuration option and their types at: » http://tidy.sourceforge.net/docs/quickref.html.

Příklad 2312. tidy_getopt() example

<?php

$html ='<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 3.2//EN">
<html><head><title>Title</title></head>
<body>

<p><img src="img.png"></p>

</body></html>';

$config = array('accessibility-check' => 3,
                'alt-text' => 'some text');

$tidy = new tidy();
$tidy->parseString($html, $config);

var_dump($tidy->getOpt('accessibility-check')); //integer
var_dump($tidy->getOpt('lower-literals')); //boolean
var_dump($tidy->getOpt('alt-text')); //string

?>

Výše uvedený příklad vypíše:

int(3)
bool(true)
string(9) "some text"

Předcházející | Nahoru | Další
tidy_get_status | Domů | tidy_is_xhtml


tidy_is_xhtml

(PHP 5, PECL tidy:0.5.2-1.2)

tidy_is_xhtml — Indicates if the document is a XHTML document

Description

Procedural style:

bool tidy_is_xhtml ( tidy $object )

Object oriented style:

bool tidy->isXhtml ( void )

This function returns TRUE if the specified tidy object is a XHTML document, or FALSE otherwise.

Varování

This function is not yet implemented in the Tidylib itself, so it always return FALSE.

Předcházející | Nahoru | Další
tidy_getopt | Domů | tidy_is_xml


tidy_is_xml

(PHP 5, PECL tidy:0.5.2-1.2)

tidy_is_xml — Indicates if the document is a generic (non HTML/XHTML) XML document

Description

Procedural style:

bool tidy_is_xml ( tidy $object )

Object oriented style:

bool tidy->isXml ( void )

This function returns TRUE if the specified tidy object is a generic XML document (non HTML/XHTML), or FALSE otherwise.

Varování

This function is not yet implemented in the Tidylib itself, so it always return FALSE.

Předcházející | Nahoru | Další
tidy_is_xhtml | Domů | tidy_load_config


tidy_load_config

(PECL tidy:0.5.2-1.2)

tidy_load_config — Load an ASCII Tidy configuration file with the specified encoding

Description

void tidy_load_config ( string $filename, string $encoding )

This function loads a Tidy configuration file, with the specified encoding.

Poznámka: Tato funkce je k dispozici pouze v Tidy 1.0. Ve verzi Tidy 2.0 je překonána a byla proto odstraněna.

Předcházející | Nahoru | Další
tidy_is_xml | Domů | tidy_node->get_attr


tidy_node->get_attr

(PECL tidy:0.7-1.0)

tidy_node->get_attr — Return the attribute with the provided attribute id

Description

tidy_attr tidy_node->get_attr ( int $attrib_id )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
tidy_load_config | Domů | tidy_node->get_nodes


tidy_node->get_nodes

(PECL tidy:0.7-1.0)

tidy_node->get_nodes — Return an array of nodes under this node with the specified id

Description

array tidy_node->get_nodes ( int $node_id )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
tidy_node->get_attr | Domů | tidy_node->next


tidy_node->next

(PECL tidy:0.7-1.0)

tidy_node->next — Returns the next sibling to this node

Description

tidy_node tidy_node->next ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
tidy_node->get_nodes | Domů | tidy_node->prev


tidy_node->prev

(PECL tidy:0.7-1.0)

tidy_node->prev — Returns the previous sibling to this node

Description

tidy_node tidy_node->prev ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
tidy_node->next | Domů | tidy_parse_file


tidy_parse_file

(PHP 5, PECL tidy:0.5.2-1.2)

tidy_parse_file — Parse markup in file or URI

Description

Procedural style:

tidy tidy_parse_file ( string $filename [, mixed $config [, string $encoding [, bool $use_include_path]]] )

Object oriented style:

bool tidy->parseFile ( string $filename [, mixed $config [, string $encoding [, bool $use_include_path]]] )

This function parses the given file.

Parametr config lze předávat jak jako pole, tak jako řetězec. Předává-li se jako řetězec, představuje název konfiguračního souboru, jinak jsou obsažené parametry přímo interpretovány. Vysvětlení všech voleb naleznete na » http://tidy.sourceforge.net/docs/quickref.html

Parametr encoding nastavuje kódování pro vstupní/výstupní dokumenty. Možné hodnoty parametru encoding jsou: ascii, latin0, latin1, raw, utf8, iso202, utf16le, utf16be, utf16, mac, win1252, ibm858, big5 a shiftjis.

Příklad 2313. tidy_parse_file() example

<?php
$tidy = tidy_parse_file('file.html');

$tidy->cleanRepair();

if(!empty($tidy->errorBuffer)) {
    echo "The following errors or warnings occured:\n";
    echo $tidy->errorBuffer;
}
?>

Poznámka: Ve verzi Tidy 2.0 byly přidány nepovinné parametry config_options a enconding.

See also tidy_parse_string(),
tidy_repair_file() and
tidy_repair_string().

Předcházející | Nahoru | Další
tidy_node->prev | Domů | tidy_parse_string


tidy_parse_string

(PHP 5, PECL tidy:0.5.2-1.2)

tidy_parse_string — Parse a document stored in a string

Description

Procedural style:

tidy tidy_parse_string ( string $input [, mixed $config [, string $encoding]] )

Object oriented style:

bool tidy->parseString ( string $input [, mixed $config [, string $encoding]] )

tidy_parse_string() parses a document stored in a string.

Parametr config lze předávat jak jako pole, tak jako řetězec. Předává-li se jako řetězec, představuje název konfiguračního souboru, jinak jsou obsažené parametry přímo interpretovány. Vysvětlení všech voleb naleznete na » http://tidy.sourceforge.net/docs/quickref.html

Parametr encoding nastavuje kódování pro vstupní/výstupní dokumenty. Možné hodnoty parametru encoding jsou: ascii, latin0, latin1, raw, utf8, iso202, utf16le, utf16be, utf16, mac, win1252, ibm858, big5 a shiftjis.

Příklad 2314. tidy_parse_string() example

<?php
ob_start();
?>

<html>
  <head>
   <title>test</title>
  </head>
  <body>
   <p>error<br>another line</i>
  </body>
</html>

<?php

$buffer = ob_get_clean();
$config = array('indent' => TRUE,
                'output-xhtml' => TRUE,
                'wrap' => 200);

$tidy = tidy_parse_string($buffer, $config, 'UTF8');

$tidy->cleanRepair();
echo $tidy;
?>

Výše uvedený příklad vypíše:

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
    "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
  <head>
    <title>
      test
    </title>
  </head>
  <body>
    <p>
      error<br />
      another line
    </p>
  </body>
</html>

Poznámka: Ve verzi Tidy 2.0 byly přidány nepovinné parametry config_options a enconding.

See also tidy_parse_file(),
tidy_repair_file() and
tidy_repair_string().

Předcházející | Nahoru | Další
tidy_parse_file | Domů | tidy_repair_file


tidy_repair_file

(PHP 5, PECL tidy:0.7-1.2)

tidy_repair_file — Repair a file and return it as a string

Description

string tidy_repair_file ( string $filename [, mixed $config [, string $encoding [, bool $use_include_path]]] )

This function repairs the given file and returns it as a string.

Parametr config lze předávat jak jako pole, tak jako řetězec. Předává-li se jako řetězec, představuje název konfiguračního souboru, jinak jsou obsažené parametry přímo interpretovány. Vysvětlení všech voleb naleznete na » http://tidy.sourceforge.net/docs/quickref.html

Parametr encoding nastavuje kódování pro vstupní/výstupní dokumenty. Možné hodnoty parametru encoding jsou: ascii, latin0, latin1, raw, utf8, iso202, utf16le, utf16be, utf16, mac, win1252, ibm858, big5 a shiftjis.

Příklad 2315. tidy_repair_file() example

<?php
$file = 'file.html';

$repaired = tidy_repair_file($file);
rename($file, $file . '.bak');

file_put_contents($file, $repaired);
?>

Poznámka: Ve verzi Tidy 2.0 byly přidány nepovinné parametry config_options a enconding.

See also tidy_parse_file(),
tidy_parse_string() and
tidy_repair_string().

Předcházející | Nahoru | Další
tidy_parse_string | Domů | tidy_repair_string


tidy_repair_string

(PHP 5, PECL tidy:0.7-1.2)

tidy_repair_string — Repair a string using an optionally provided configuration file

Description

string tidy_repair_string ( string $data [, mixed $config [, string $encoding]] )

This function repairs the given string.

Parametr config lze předávat jak jako pole, tak jako řetězec. Předává-li se jako řetězec, představuje název konfiguračního souboru, jinak jsou obsažené parametry přímo interpretovány. Vysvětlení všech voleb naleznete na » http://tidy.sourceforge.net/docs/quickref.html

Parametr encoding nastavuje kódování pro vstupní/výstupní dokumenty. Možné hodnoty parametru encoding jsou: ascii, latin0, latin1, raw, utf8, iso202, utf16le, utf16be, utf16, mac, win1252, ibm858, big5 a shiftjis.

Příklad 2316. tidy_repair_string() example

<?php
ob_start();
?>

<html>
  <head>
    <title>test</title>
  </head>
  <body>
    <p>error</i>
  </body>
</html>

<?php

$buffer = ob_get_clean();
$tidy = tidy_repair_string($buffer);

echo $tidy;
?>

Výše uvedený příklad vypíše:

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 3.2//EN">
<html>
<head>
<title>test</title>
</head>
<body>
<p>error</p>
</body>
</html>

Poznámka: Ve verzi Tidy 2.0 byly přidány nepovinné parametry config_options a enconding.

See also tidy_parse_file(),
tidy_parse_string() and
tidy_repair_file().

Předcházející | Nahoru | Další
tidy_repair_file | Domů | tidy_reset_config


tidy_reset_config

(PECL tidy:0.7-1.2)

tidy_reset_config — Restore Tidy configuration to default values

Description

bool tidy_reset_config ( void )

This function restores the Tidy configuration to the default values.

Poznámka: Tato funkce je k dispozici pouze v Tidy 1.0. Ve verzi Tidy 2.0 je překonána a byla proto odstraněna.

Předcházející | Nahoru | Další
tidy_repair_string | Domů | tidy_save_config


tidy_save_config

(PECL tidy:0.5.2-1.2)

tidy_save_config — Save current settings to named file

Description

bool tidy_save_config ( string $filename )

tidy_save_config() saves current settings to the specified file. Only non-default values are written.

See also tidy_get_config(),
tidy_getopt(),
tidy_reset_config() and
tidy_setopt().

Poznámka: Tato funkce je k dispozici pouze v Tidy 1.0. Ve verzi Tidy 2.0 je překonána a byla proto odstraněna.

Předcházející | Nahoru | Další
tidy_reset_config | Domů | tidy_set_encoding


tidy_set_encoding

(PECL tidy:0.5.2-1.2)

tidy_set_encoding — Set the input/output character encoding for parsing markup

Description

bool tidy_set_encoding ( string $encoding )

Sets the encoding for input/output documents. Vrací TRUE při úspěchu, FALSE při selhání. Possible values for encoding are ascii, latin0, latin1, raw, utf8, iso2022, mac, win1252, ibm858, utf16, utf16le, utf16be, big5 and shiftjis

Poznámka: Tato funkce je k dispozici pouze v Tidy 1.0. Ve verzi Tidy 2.0 je překonána a byla proto odstraněna.

Předcházející | Nahoru | Další
tidy_save_config | Domů | tidy_setopt


tidy_setopt

(PECL tidy:0.5.2-1.2)

tidy_setopt — Updates the configuration settings for the specified tidy document

Description

bool tidy_setopt ( string $option, mixed $value )

tidy_setopt() updates the specified option with a new value. You will find a list with each configuration option at: » http://tidy.sourceforge.net/docs/quickref.html.

Příklad 2317. tidy_setopt() example

<?php
$html = '<p>test</i>';

$tidy = tidy_parse_string($html);

tidy_setopt('indent', FALSE);
?>

See also tidy_getopt(),
tidy_get_config(),
tidy_reset_config() and
tidy_save_config().

Poznámka: Tato funkce je k dispozici pouze v Tidy 1.0. Ve verzi Tidy 2.0 je překonána a byla proto odstraněna.

Předcházející | Nahoru | Další
tidy_set_encoding | Domů | tidy_warning_count


tidy_warning_count

(PHP 5, PECL tidy:0.5.2-1.2)

tidy_warning_count — Returns the Number of Tidy warnings encountered for specified document

Description

int tidy_warning_count ( tidy $object )

tidy_warning_count() returns the number of Tidy warnings encountered for the specified document.

Příklad 2318. tidy_warning_count() example

<?php
$html = '<p>test</i>
<bogustag>bogus</bogustag>';

$tidy = tidy_parse_string($html);

echo tidy_error_count($tidy) . "\n"; //1
echo tidy_warning_count($tidy) . "\n"; //5
?>

See also tidy_access_count() and tidy_error_count().

Předcházející | Nahoru | Další
tidy_setopt | Domů | tidyNode->hasChildren


tidyNode->isAsp

(PHP 5 >= 5.0.1)

tidyNode->isAsp — Returns true if this node is ASP

Description

bool tidyNode->isAsp ( void )

This functions returns TRUE if the current node is ASP, or FALSE otherwise.

Poznámka: This function was named tidy_node->is_asp() in PHP 4/Tidy 1.

Předcházející | Nahoru | Další
tidyNode->hasSiblings | Domů | tidyNode->isComment


tidyNode->isPhp

(PHP 5 >= 5.0.1)

tidyNode->isPhp — Returns true if this node is PHP

Description

bool tidyNode->isPhp ( void )

Returns TRUE if the current node is PHP code, FALSE otherwise.

Příklad 2319. get the PHP code from a mixed HTML/PHP document

<?php

$html = <<< HTML
<html><head>
<?php echo '<title>title</title>'; ?>
</head>
<body>

<?php
echo 'hello world!';
?>

</body></html>
HTML;

$tidy = tidy_parse_string($html);
$num = 0;

get_php($tidy->html());

function get_php($node) {

    // check if the current node is PHP code
    if($node->isPhp()) {
        echo "\n\n# PHP node #" . ++$GLOBALS['num'] . "\n";
        echo $node->value;
    }

    // check if the current node has childrens
    if($node->hasChildren()) {
        foreach($node->child as $child) {
            get_php($child);
        }
    }
}

?>

Výše uvedený příklad vypíše:

# PHP node #1
<?php echo '<title>title</title>'; ?>

# PHP node #2
<?php
echo 'hello world!';
?>

Poznámka: This function was named tidy_node->is_php() in PHP 4/Tidy 1.

Předcházející | Nahoru | Další
tidyNode->isJste | Domů | tidyNode->isText


Tokenizer Functions

Předcházející VI. Reference funkcí Další

CLXVIII. Tokenizer Functions

Úvod

The tokenizer functions provide an interface to the PHP tokenizer embedded in the Zend Engine. Using these functions you may write your own PHP source analyzing or modification tools without having to deal with the language specification at the lexical level.

See also the appendix about tokens.

Požadavky

Tyto funkce jsou k dispozici jako součást standardního modulu, který je vždy dostupný.

Instalace

Beginning with PHP 4.3.0 these functions are enabled by default. For older versions you have to configure and compile PHP with --enable-tokenizer. You can disable tokenizer support with --disable-tokenizer.

Verze PHP pro Windows má vestavěnou podporu pro toto rozšíření. K použití těchto funkcí není třeba načítat žádná další rozšíření.

Poznámka: Built-in support for tokenizer is available as of PHP 4.3.0.

Předdefinované konstanty

When the extension has either been compiled into PHP or dynamically loaded at runtime, the tokens listed in S – „Seznam tokenů parseru“ are defined as constants.

Příklady

Here is a simple example PHP scripts using the tokenizer that will read in a PHP file, strip all comments from the source and print the pure code only.

Příklad 2320. Strip comments with the tokenizer

<?php
/*
 * T_ML_COMMENT does not exist in PHP 5.
 * The following three lines define it in order to
 * preserve backwards compatibility.
 *
 * The next two lines define the PHP 5 only T_DOC_COMMENT,
 * which we will mask as T_ML_COMMENT for PHP 4.
 */
if (!defined('T_ML_COMMENT')) {
    define('T_ML_COMMENT', T_COMMENT);
} else {
    define('T_DOC_COMMENT', T_ML_COMMENT);
}

$source = file_get_contents('example.php');
$tokens = token_get_all($source);

foreach ($tokens as $token) {
    if (is_string($token)) {
        // simple 1-character token
        echo $token;
    } else {
        // token array
        list($id, $text) = $token;

        switch ($id) {
            case T_COMMENT:
            case T_ML_COMMENT: // we've defined this
            case T_DOC_COMMENT: // and this
                // no action on comments
                break;

            default:
                // anything else -> output "as is"
                echo $text;
                break;
        }
    }
}
?>

Obsah

token_get_all — Split given source into PHP tokens
token_name — Get the symbolic name of a given PHP token
Předcházející | Nahoru | Další
tidyNode::getParent | Domů | token_get_all


token_get_all

(PHP 4 >= 4.2.0, PHP 5)

token_get_all — Split given source into PHP tokens

Popis

array token_get_all ( string $source )

token_get_all() parses the given source string into PHP language tokens using the Zend engine's lexical scanner.

For a list of parser tokens, see S – „Seznam tokenů parseru“, or use token_name() to translate a token value into its string representation.

Seznam parametrů

source

The PHP source to parse.

Návratové hodnoty

An array of token identifiers. Each individual token identifier is either a single character (i.e.: ;, ., >, !, etc...), or a three element array containing the token index in element 0, the string content of the original token in element 1 and the line number in element 2.

Příklady

Příklad 2321. token_get_all() examples

<?php
$tokens = token_get_all('<?php echo; ?>'); /* => array(
                                                  array(T_OPEN_TAG, '<?php'),
                                                  array(T_ECHO, 'echo'),
                                                  ';',
                                                  array(T_CLOSE_TAG, '?>') ); */

/* Note in the following example that the string is parsed as T_INLINE_HTML
   rather than the otherwise expected T_COMMENT (T_ML_COMMENT in PHP <5).
   This is because no open/close tags were used in the "code" provided.
   This would be equivalent to putting a comment outside of <?php ?> tags in a normal file. */
$tokens = token_get_all('/* comment */'); // => array(array(T_INLINE_HTML, '/* comment */'));
?>

ChangeLog (záznam změn)

Verze | Popis
5.2.2 | Line numbers are returned in element 2

Předcházející | Nahoru | Další
CLXVIII. Tokenizer Functions | Domů | token_name


token_name

(PHP 4 >= 4.2.0, PHP 5)

token_name — Get the symbolic name of a given PHP token

Popis

string token_name ( int $token )

token_name() gets the symbolic name for a PHP token value.

Seznam parametrů

token

The token value.

Návratové hodnoty

The symbolic name of the given token. The returned name returned matches the name of the matching token constant.

Příklady

Příklad 2322. token_name() example

<?php
// 260 is the token value for the T_REQUIRE token
echo token_name(260);        // -> "T_REQUIRE"

// a token constant maps to its own name
echo token_name(T_FUNCTION); // -> "T_FUNCTION"
?>

Viz také

List of Parser Tokens

Předcházející | Nahoru | Další
token_get_all | Domů | CLXIX. Unicode Functions


URL funkce

Předcházející VI. Reference funkcí Další

CLXX. URL funkce

Úvod

Práce s URL řetězci: kódování, dekódování a parsování.

Požadavky

Tyto funkce jsou k dispozici jako součást standardního modulu, který je vždy dostupný.

Instalace

K používání těchto funkcí není třeba žádná instalace, jsou součástí jádra PHP.

Konfigurace běhu

Toto rozšíření nemá definováno žádné konfigurační direktivy.

Typy prostředků

Toto rozšíření nemá definován žádný typ prostředku (resource).

Předdefinované konstanty

Toto rozšíření nemá definovány žádné konstanty.

Obsah

base64_decode — Dekódovat data kódovaná pomocí MIME base64
base64_encode — Zakódovat data pomocí MIME base64
get_headers — Fetches all the headers sent by the server in response to a HTTP request
get_meta_tags — Získá hodnoty content atributů všech meta tagů v souboru a vrátí pole
http_build_query — Generate URL-encoded query string
parse_url — Rozebrat URL a vrátit její komponenty
rawurldecode — Dekódovat URL-kódovaný řetězec
rawurlencode — URL-kódovat podle RFC1738
urldecode — Dekódovat URL-kódovaný řetězec
urlencode — URL-kódovat řetězec
Předcházející | Nahoru | Další
unicode_set_subst_char | Domů | base64_decode


base64_decode

(PHP 4, PHP 5)

base64_decode — Dekódovat data kódovaná pomocí MIME base64

Popis

string base64_decode ( string $encoded_data )

base64_decode() dekóduje encoded_data a vrátí původní data. Vrácená data mohou být binární

Viz také: base64_encode(), RFC 2045 sekce 6.8.

Předcházející | Nahoru | Další
CLXX. URL funkce | Domů | base64_encode


base64_encode

(PHP 4, PHP 5)

base64_encode — Zakódovat data pomocí MIME base64

Popis

string base64_encode ( string $data )

base64_encode() vrátí data zakódovaný pomocí base64. Toto kódování je navrženo tak, aby umožnilo binárním datům přežít transport přenosovými vrstvami, které nejsou osmibitové, jako jsou například těla emailů.

Data kódovaná pomocí base64 zabírají o zhruba 33% prostoru více než původní data.

Viz také: base64_decode(), chunk_split(), RFC-2045 sekce 6.8.

Předcházející | Nahoru | Další
base64_decode | Domů | get_headers


get_headers

(PHP 5)

get_headers — Fetches all the headers sent by the server in response to a HTTP request

Popis

array get_headers ( string $url [, int $format] )

get_headers() returns an array with the headers sent by the server in response to a HTTP request.

Seznam parametrů

url

The target URL.

format

If the optional format parameter is set to 1, get_headers() parses the response and sets the array's keys.

Návratové hodnoty

Returns an indexed or associative array with the headers, or FALSE on failure.

ChangeLog (záznam změn)

Verze | Popis
5.1.3 | This function now uses the default stream context, which can be set/changed with the stream_context_get_default() function.

Příklady

Příklad 2325. get_headers() example

<?php
$url = 'http://www.example.com';

print_r(get_headers($url));

print_r(get_headers($url, 1));
?>

Výše uvedený příklad vypíše něco jako:

Array
(
    [0] => HTTP/1.1 200 OK
    [1] => Date: Sat, 29 May 2004 12:28:13 GMT
    [2] => Server: Apache/1.3.27 (Unix)  (Red-Hat/Linux)
    [3] => Last-Modified: Wed, 08 Jan 2003 23:11:55 GMT
    [4] => ETag: "3f80f-1b6-3e1cb03b"
    [5] => Accept-Ranges: bytes
    [6] => Content-Length: 438
    [7] => Connection: close
    [8] => Content-Type: text/html
)

Array
(
    [0] => HTTP/1.1 200 OK
    [Date] => Sat, 29 May 2004 12:28:14 GMT
    [Server] => Apache/1.3.27 (Unix)  (Red-Hat/Linux)
    [Last-Modified] => Wed, 08 Jan 2003 23:11:55 GMT
    [ETag] => "3f80f-1b6-3e1cb03b"
    [Accept-Ranges] => bytes
    [Content-Length] => 438
    [Connection] => close
    [Content-Type] => text/html
)

Předcházející | Nahoru | Další
base64_encode | Domů | get_meta_tags


get_meta_tags

(PHP 4, PHP 5)

get_meta_tags — Získá hodnoty content atributů všech meta tagů v souboru a vrátí pole

Popis

array get_meta_tags ( string $filename [, bool $use_include_path] )

Otevře filename, přečte ho po řádcích, a vyhledá <meta> tagy ve tvaru

Příklad 2326. Ukázka na Meta Tagy

<meta name="author" content="name">
<meta name="tags" content="php3 documentation">
</head> <!-- tady čtení skončí -->

(věnujte pozornost koncům řádků - PHP používá ke čtení vstupu nativní funkci, takže Macovský soubor na Unixu nebude fungovat).

Hodnota atributu name se ve vráceném poli stává klíčem, hodnota atributu content hodnotou tohoto pole, takže ho můžete snadno projít nebo získat jednotlivé hodnoty pomocí snandardních funkcí pro práci s poli. Zvláštní znaky v hodnotě atributu name jsou nahrazeny znakem '_', zbytek se převede na malá písmena.

Pokud je use_include_path rovno 1, PHP se pokusí otevřít soubor v standardní include cestě.

Předcházející | Nahoru | Další
get_headers | Domů | http_build_query


http_build_query

(PHP 5, PECL pecl_http:0.1.0-0.9.0)

http_build_query — Generate URL-encoded query string

Popis

string http_build_query ( array $formdata [, string $numeric_prefix [, string $arg_separator]] )

Generates a URL-encoded query string from the associative (or indexed) array provided.

Seznam parametrů

formdata

May be an array or object containing properties.

The array form may be a simple one-dimensional structure, or an array of arrays (who in turn may contain other arrays).

numeric_prefix

If numeric indices are used in the base array and this parameter is provided, it will be prepended to the numeric index for elements in the base array only.

This is meant to allow for legal variable names when the data is decoded by PHP or another CGI application later on.

arg_separator

arg_separator.output is used to separate arguments, unless this parameter is specified, and is then used.

Návratové hodnoty

Returns a URL-encoded string.

ChangeLog (záznam změn)

Verze | Popis
5.1.2 | The arg_separator parameter was added.
5.1.3 | Square brackets are escaped.

Příklady

Příklad 2327. Simple usage of http_build_query()

<?php
$data = array('foo'=>'bar',
              'baz'=>'boom',
              'cow'=>'milk',
              'php'=>'hypertext processor');

echo http_build_query($data); // foo=bar&baz=boom&cow=milk&php=hypertext+processor
echo http_build_query($data, '', '&amp;'); // foo=bar&amp;baz=boom&amp;cow=milk&amp;php=hypertext+processor

?>

Příklad 2328. http_build_query() with numerically index elements.

<?php
$data = array('foo', 'bar', 'baz', 'boom', 'cow' => 'milk', 'php' =>'hypertext processor');

echo http_build_query($data) . "\n";
echo http_build_query($data, 'myvar_');
?>

Výše uvedený příklad vypíše:

0=foo&1=bar&2=baz&3=boom&cow=milk&php=hypertext+processor
myvar_0=foo&myvar_1=bar&myvar_2=baz&myvar_3=boom&cow=milk&php=hypertext+processor

Příklad 2329. http_build_query() with complex arrays

<?php
$data = array('user'=>array('name'=>'Bob Smith',
                            'age'=>47,
                            'sex'=>'M',
                            'dob'=>'5/12/1956'),
              'pastimes'=>array('golf', 'opera', 'poker', 'rap'),
              'children'=>array('bobby'=>array('age'=>12,
                                               'sex'=>'M'),
                                'sally'=>array('age'=>8,
                                               'sex'=>'F')),
              'CEO');

echo http_build_query($data, 'flags_');
?>

this will output : (word wrapped for readability)

user%5Bname%5D=Bob+Smith&user%5Bage%5D=47&user%5Bsex%5D=M&
user%5Bdob%5D=5%2F12%2F1956&pastimes%5B0%5D=golf&pastimes%5B1%5D=opera&
pastimes%5B2%5D=poker&pastimes%5B3%5D=rap&children%5Bbobby%5D%5Bage%5D=12&
children%5Bbobby%5D%5Bsex%5D=M&children%5Bsally%5D%5Bage%5D=8&
children%5Bsally%5D%5Bsex%5D=F&flags_0=CEO

Poznámka: Only the numerically indexed element in the base array "CEO" received a prefix. The other numeric indices, found under pastimes, do not require a string prefix to be legal variable names.

Příklad 2330. Using http_build_query() with an object

<?php
class myClass {
    var $foo;
    var $baz;

    function myClass() {
        $this->foo = 'bar';
        $this->baz = 'boom';
    }
}

$data = new myClass();

echo http_build_query($data); // foo=bar&baz=boom

?>

Viz také

parse_str()
parse_url()
urlencode()
array_walk()

Předcházející | Nahoru | Další
get_meta_tags | Domů | parse_url


parse_url

(PHP 4, PHP 5)

parse_url — Rozebrat URL a vrátit její komponenty

Popis

mixed parse_url ( string $url [, int $component] )

Tato funkce vrátí asociativní pole všech komponent URL přítomnych v url. Ty mohou být: "scheme", "host", "port", "user", "pass", "path", "query" a "fragment".

Předcházející | Nahoru | Další
http_build_query | Domů | rawurldecode


rawurldecode

(PHP 4, PHP 5)

rawurldecode — Dekódovat URL-kódovaný řetězec

Popis

string rawurldecode ( string $str )

Vrátí řetězec, ve kterém sekvence znaku procent (%) následových dvěma šestnáctkovými číslicemi byly nahrazeny prostými znaky. Například řetězec

foo%20bar%40baz
dekóduje na
foo bar@baz
.

Viz také: rawurlencode(),
urldecode(),
urlencode().

Předcházející | Nahoru | Další
parse_url | Domů | rawurlencode


rawurlencode

(PHP 4, PHP 5)

rawurlencode — URL-kódovat podle RFC1738

Popis

string rawurlencode ( string $str )

Vrátí řetězec, ve kterém byly všechny nealfanumerické znaky kromě

-_.
nahrazeny znakem procent (%) následovaným dvěma šestnáctkovými číslicemi. To je kódování popsané v RFC1738 na ochranu prostých znaků před interpretací jako zvláštní oddělovače v URL a na ochranu URL před komolením přenosovými systémy se znakovými konvencemi (jako jsou některé emailové systémy). Například, pokud chcete k FTP URL přidat heslo:

Příklad 2331. Příklad rawurlencode() č. 1

<?php
echo '<a href="ftp://user:', rawurlencode('foo @+%/'),
     '@ftp.example.com/x.txt">';
?>

Nebo, pokud předáváte informace v komponentě URL obsahující informaci o cestě:

Příklad 2332. Příklad rawurlencode() č. 2

<?php
echo '<a href="http://example.com/department_list_script/',
    rawurlencode('sales and marketing/Miami'), '">';
?>

Viz také: rawurldecode(),
urldecode(),
urlencode() a
» RFC 1738.

Předcházející | Nahoru | Další
rawurldecode | Domů | urldecode


urldecode

(PHP 4, PHP 5)

urldecode — Dekódovat URL-kódovaný řetězec

Popis

string urldecode ( string $str )

Dekóduje všechny %## kódy v daném řetězci. Vrátí dekódovaný řetězec.

Příklad 2333. Příklad urldecode()

<?php
$a = explode('&', $QUERY_STRING);
$i = 0;
while ($i < count($a)) {
    $b = split('=', $a[$i]);
    echo 'Hodnota parametru ', htmlspecialchars(urldecode($b[0])),
         ' je ', htmlspecialchars(urldecode($b[1])), "<br />\n";
    $i++;
}
?>

Viz také urlencode(),
rawurlencode() a
rawurldecode().

Předcházející | Nahoru | Další
rawurlencode | Domů | urlencode


urlencode

(PHP 4, PHP 5)

urlencode — URL-kódovat řetězec

Popis

string urlencode ( string $str )

Vrátí řetězec, ve kterém byly všechny nealfanumerické znaky kromě -_. nahrazeny znakem procent (%) následovaným dvěma šestnácktovými číslicemi a mezery kódovány jako znaky plus (+). Kódování je stejné jako u dat postovaných z WWW formuláře, tj. stejně jako u application/x-www-form-urlencoded typu. To se liší od RFC1738 kódování (viz rawurlencode()) v tom, že z historických důvodů se mezery kódují jako znaky plus (+). Tato funkce je vhodná při kódování řetězce, který se má použít jako query část URL jako příhodný způsob předání proměnných na další stránku:

Příklad 2334. Příklad urlencode()

echo '<A HREF="mycgi?foo=', urlencode ($userinput), '">';

Poznámka: pozor při předávání proměnných, které by mohly odpovídat HTML entitám. Věci jako &amp, &copy a &pound browser analyzuje a místo požadovaného jména proměnné použije odpovídající entitu. To je zřejmý problém, na který W3C upozorňuje už léta. Příručka je tady: » http://www.w3.org/TR/html4/appendix/notes.html#h-B.2.2 PHP podporuje změnu oddělovače argumentů na středník doporučovaný W3C skrze .ini direktivu arg_separator. Bohužel, většina uživatelských programů neposílá data z formulářů v tomto formátu. Přenositelnější formou je použít jako oddělovač &amp; místo &. Na to nemusíte měnit arg_separator. Nechte ho na &, ale kódujte URL pomocí htmlentities() (urlencode($data)).

Příklad 2335. Příklad na urlencode/htmlentities()

echo '<A HREF="mycgi?foo=', htmlentities (urlencode ($userinput) ), '">';

Viz také urldecode(),
htmlentities(),
rawurldecode(),
rawurlencode().

Předcházející | Nahoru | Další
urldecode | Domů | CLXXI. Variable Handling Functions


Variable Handling Functions

Předcházející VI. Reference funkcí Další

CLXXI. Variable Handling Functions

Úvod

For information on how variables behave, see the Variables entry in the Language Reference section of the manual.

Požadavky

Tyto funkce jsou k dispozici jako součást standardního modulu, který je vždy dostupný.

Instalace

K používání těchto funkcí není třeba žádná instalace, jsou součástí jádra PHP.

Konfigurace běhu

Chování těchto funkcí je ovlivněno nastavením parametrů v php.ini.

Tabulka 314. Variables Configuration Options

Name | Default | Changeable | Changelog
unserialize_callback_func | NULL | PHP_INI_ALL | Available since PHP 4.2.0.

Pro další detaily a definice konstant PHP_INI_*, viz dokumentace k ini_set().

Zde je stručný popis konfiguračních direktiv.

unserialize_callback_func string

The unserialize() callback function will called (with the undefined class' name as parameter), if the unserializer finds an undefined class which should be instanciated. A warning appears if the specified function is not defined, or if the function doesn't include/implement the missing class. So only set this entry, if you really want to implement such a callback-function.

See also unserialize().

Typy prostředků

Toto rozšíření nemá definován žádný typ prostředku (resource).

Předdefinované konstanty

Toto rozšíření nemá definovány žádné konstanty.

Obsah

debug_zval_dump — Dumps a string representation of an internal zend value to output
doubleval — Alias pro floatval()
empty — Determine whether a variable is empty
floatval — Get float value of a variable
get_defined_vars — Returns an array of all defined variables
get_resource_type — Returns the resource type
gettype — Get the type of a variable
import_request_variables — Import GET/POST/Cookie variables into the global scope
intval — Get the integer value of a variable
is_array — Finds whether a variable is an array
is_binary — Finds whether a variable is a native binary string
is_bool — Finds out whether a variable is a boolean
is_buffer — Finds whether a variable is a native unicode or binary string
is_callable — Verify that the contents of a variable can be called as a function
is_double — Alias pro is_float()
is_float — Finds whether the type of a variable is float
is_int — Find whether the type of a variable is integer
is_integer — Alias pro is_int()
is_long — Alias pro is_int()
is_null — Finds whether a variable is NULL
is_numeric — Finds whether a variable is a number or a numeric string
is_object — Finds whether a variable is an object
is_real — Alias pro is_float()
is_resource — Finds whether a variable is a resource
is_scalar — Finds whether a variable is a scalar
is_string — Find whether the type of a variable is string
is_unicode — Finds whether a variable is a unicode string
isset — Determine whether a variable is set
print_r — Prints human-readable information about a variable
serialize — Generates a storable representation of a value
settype — Set the type of a variable
strval — Get string value of a variable
unserialize — Creates a PHP value from a stored representation
unset — Unset a given variable
var_dump — Dumps information about a variable
var_export — Outputs or returns a parsable string representation of a variable
Předcházející | Nahoru | Další
urlencode | Domů | debug_zval_dump


debug_zval_dump

(PHP 4 >= 4.2.0, PHP 5)

debug_zval_dump — Dumps a string representation of an internal zend value to output

Popis

void debug_zval_dump ( mixed $variable )

Dumps a string representation of an internal zend value to output.

Seznam parametrů

variable

The variable being evaluated.

Návratové hodnoty

Nevrací se žádná hodnota.

Příklady

Příklad 2336. debug_zval_dump() example

<?php
$var1 = 'Hello World';
$var2 = '';

$var2 =& $var1;

debug_zval_dump(&$var1);
?>

Výše uvedený příklad vypíše:

&string(11) "Hello World" refcount(3)

Beware the refcount: The refcount value returned by this function is non-obvious in certain circumstances. For example, a developer might expect the above example to indicate a refcount of 2. The third reference is created when actually calling debug_zval_dump().

This behavior is further compounded when a variable is not passed to debug_zval_dump() by reference. To illustrate, consider a slightly modified version of the above example:

Příklad 2337.

<?php
$var1 = 'Hello World';
$var2 = '';

$var2 =& $var1;

debug_zval_dump($var1); // not passed by reference, this time
?>

Výše uvedený příklad vypíše:

string(11) "Hello World" refcount(1)

Why refcount(1)? Because a copy of $var1 is being made, when the function is called.

This function becomes even more confusing when a variable with a refcount of 1 is passed (by copy/value):

Příklad 2338.

<?php
$var1 = 'Hello World';

debug_zval_dump($var1);
?>

Výše uvedený příklad vypíše:

string(11) "Hello World" refcount(2)

A refcount of 2, here, is extremely non-obvious. Especially considering the above examples. So what's happening?

When a variable has a single reference (as did $var1 before it was used as an argument to debug_zval_dump()), PHP's engine optimizes the manner in which it is passed to a function. Internally, PHP treats $var1 like a reference (in that the refcount is increased for the scope of this function), with the caveat that if the passed reference happens to be written to, a copy is made, but only at the moment of writing. This is known as "copy on write."

So, if debug_zval_dump() happened to write to its sole parameter (and it doesn't), then a copy would be made. Until then, the parameter remains a reference, causing the refcount to be incremented to 2 for the scope of the function call.

Viz také

var_dump()
debug_backtrace()
References Explained
» References Explained (by Derick Rethans)

Předcházející | Nahoru | Další
CLXXI. Variable Handling Functions | Domů | doubleval


doubleval

(PHP 4, PHP 5)

doubleval — Alias pro floatval()

Popis

Tato funkce je aliasem: floatval().

ChangeLog (záznam změn)

Verze | Popis
4.2.0 | doubleval() became an alias of floatval(). Before this time, only doubleval() existed.

Předcházející | Nahoru | Další
debug_zval_dump | Domů | empty


empty

(PHP 4, PHP 5)

empty — Determine whether a variable is empty

Popis

bool empty ( mixed $var )

Determine whether a variable is considered to be empty.

Seznam parametrů

var

Variable to be checked

Poznámka: empty() only checks variables as anything else will result in a parse error. In other words, the following will not work: empty(trim($name)).

empty() is the opposite of (boolean) var, except that no warning is generated when the variable is not set.

Návratové hodnoty

Returns FALSE if var has a non-empty and non-zero value.

The following things are considered to be empty:
"" (an empty string)
0 (0 as an integer)
"0" (0 as a string)
NULL
FALSE
array() (an empty array)
var $var; (a variable declared, but without a value in a class)

ChangeLog (záznam změn)

Verze | Popis
PHP 5 | As of PHP 5, objects with no properties are no longer considered empty.
PHP 4 | As of PHP 4, The string value "0" is considered empty.

Příklady

Příklad 2339. A simple empty() / isset() comparison.

<?php
$var = 0;

// Evaluates to true because $var is empty
if (empty($var)) {
    echo '$var is either 0, empty, or not set at all';
}

// Evaluates as true because $var is set
if (isset($var)) {
    echo '$var is set even though it is empty';
}
?>

Poznámky

Poznámka: Protože se jedná o jazykový konstrukt a ne o funkci, nemůžete ho volat pomocí funkcí v proměnných

Viz také

isset()
unset()
array_key_exists()
count()
strlen()
The type comparison tables

Předcházející | Nahoru | Další
doubleval | Domů | floatval


floatval

(PHP 4 >= 4.2.0, PHP 5)

floatval — Get float value of a variable

Popis

float floatval ( mixed $var )

Gets the float value of var.

Seznam parametrů

var

May be any scalar type. You cannot use floatval() on arrays or objects.

Návratové hodnoty

The float value of the given variable.

Příklady

Příklad 2340. floatval() Example

<?php
$var = '122.34343The';
$float_value_of_var = floatval($var);
echo $float_value_of_var; // 122.34343
?>

Viz také

intval()
strval()
settype()
Type juggling

Předcházející | Nahoru | Další
empty | Domů | get_defined_vars


get_defined_vars

(PHP 4 >= 4.0.4, PHP 5)

get_defined_vars — Returns an array of all defined variables

Popis

array get_defined_vars ( void )

This function returns a multidimensional array containing a list of all defined variables, be them environment, server or user-defined variables, within the scope that get_defined_vars() is called.

Návratové hodnoty

A multidimensional array with all the variables.

Příklady

Příklad 2341. get_defined_vars() Example

<?php
$b = array(1, 1, 2, 3, 5, 8);

$arr = get_defined_vars();

// print $b
print_r($arr["b"]);

/* print path to the PHP interpreter (if used as a CGI)
 * e.g. /usr/local/bin/php */
echo $arr["_"];

// print the command-line parameters if any
print_r($arr["argv"]);

// print all the server vars
print_r($arr["_SERVER"]);

// print all the available keys for the arrays of variables
print_r(array_keys(get_defined_vars()));
?>

ChangeLog (záznam změn)

Verze | Popis
5.0.0 | The $GLOBALS variable is included in the results of the array returned.

Viz také

isset()
get_defined_functions()
get_defined_constants()

Předcházející | Nahoru | Další
floatval | Domů | get_resource_type


get_resource_type

(PHP 4 >= 4.0.2, PHP 5)

get_resource_type — Returns the resource type

Popis

string get_resource_type ( resource $handle )

This function gets the type of the given resource.

Seznam parametrů

handle

The evaluated resource handle.

Návratové hodnoty

If the given handle is a resource, this function will return a string representing its type. If the type is not identified by this function, the return value will be the string Unknown.

This function will return FALSE and generate an error if handle is not a resource.

Příklady

Příklad 2342. get_resource_type() example

<?php
// prints: mysql link
$c = mysql_connect();
echo get_resource_type($c) . "\n";

// prints: file
$fp = fopen("foo", "w");
echo get_resource_type($fp) . "\n";

// prints: domxml document
$doc = new_xmldoc("1.0");
echo get_resource_type($doc->doc) . "\n";
?>

Předcházející | Nahoru | Další
get_defined_vars | Domů | gettype


gettype

(PHP 4, PHP 5)

gettype — Get the type of a variable

Popis

string gettype ( mixed $var )

Returns the type of the PHP variable var.

Varování

Never use gettype() to test for a certain type, since the returned string may be subject to change in a future version. In addition, it is slow too, as it involves string comparison.

Instead, use the is_* functions.

Návratové hodnoty

Possibles values for the returned string are:

  • "boolean" (since PHP 4)
  • "integer"
  • "double" (for historical reasons "double" is returned in case of a float, and not simply "float")
  • "string"
  • "array"
  • "object"
  • "resource" (since PHP 4)
  • "NULL" (since PHP 4)
  • "user function" (PHP 3 only, deprecated)
  • "unknown type"

For PHP 4, you should use function_exists() and method_exists() to replace the prior usage of gettype() on a function.

Viz také

settype()
is_array()
is_bool()
is_float()
is_int()
is_null()
is_numeric()
is_object()
is_resource()
is_scalar()
is_string()

Předcházející | Nahoru | Další
get_resource_type | Domů | import_request_variables


import_request_variables

(PHP 4 >= 4.0.7, PHP 5)

import_request_variables — Import GET/POST/Cookie variables into the global scope

Popis

bool import_request_variables ( string $types [, string $prefix] )

Imports GET/POST/Cookie variables into the global scope. It is useful if you disabled register_globals, but would like to see some variables in the global scope.

If you're interested in importing other variables into the global scope, such as SERVER, consider using extract().

Seznam parametrů

types

Using the types parameter, you can specify which request variables to import. You can use 'G', 'P' and 'C' characters respectively for GET, POST and Cookie. These characters are not case sensitive, so you can also use any combination of 'g', 'p' and 'c'. POST includes the POST uploaded file information.

Poznámka: Note that the order of the letters matters, as when using "gp", the POST variables will overwrite GET variables with the same name. Any other letters than GPC are discarded.

prefix

Variable name prefix, prepended before all variable's name imported into the global scope. So if you have a GET value named "userid", and provide a prefix "pref_", then you'll get a global variable named $pref_userid.

Poznámka: Although the prefix parameter is optional, you will get an E_NOTICE level error if you specify no prefix, or specify an empty string as a prefix. This is a possible security hazard. Notice level errors are not displayed using the default error reporting level.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 2343. import_request_variables() example

<?php
// This will import GET and POST vars
// with an "rvar_" prefix
import_request_variables("gp", "rvar_");

echo $rvar_foo;
?>

Viz také

$_REQUEST
register_globals
Predefined Variables
extract()

Předcházející | Nahoru | Další
gettype | Domů | intval


intval

(PHP 4, PHP 5)

intval — Get the integer value of a variable

Popis

int intval ( mixed $var [, int $base] )

Returns the integer value of var, using the specified base for the conversion (the default is base 10).

Seznam parametrů

var

The scalar value being converted to an integer

base

The base for the conversion (default is base 10)

Návratové hodnoty

The integer value of var on success, or 0 on failure. Empty arrays and objects return 0, non-empty arrays and objects return 1.

The maximum value depends on the system. 32 bit systems have a maximum signed integer range of -2147483648 to 2147483647. So for example on such a system, intval('1000000000000') will return 2147483647. The maximum signed integer value for 64 bit systems is 9223372036854775807.

Strings will most likely return 0 although this depends on the leftmost characters of the string. The common rules of integer casting apply.

Příklady

Příklad 2344. intval() examples

The following examples are based on a 32 bit system.

<?php
echo intval(42);                      // 42
echo intval(4.2);                     // 4
echo intval('42');                    // 42
echo intval('+42');                   // 42
echo intval('-42');                   // -42
echo intval(042);                     // 34
echo intval('042');                   // 42
echo intval(1e10);                    // 1410065408
echo intval('1e10');                  // 1
echo intval(0x1A);                    // 26
echo intval(42000000);                // 42000000
echo intval(420000000000000000000);   // 0
echo intval('420000000000000000000'); // 2147483647
echo intval(42, 8);                   // 42
echo intval('42', 8);                 // 34
?>

Poznámky

Poznámka: The base parameter has no effect unless the var parameter is a string.

Viz také

floatval()
strval()
settype()
is_numeric()
Type juggling
BCMath Arbitrary Precision Mathematics Functions

Předcházející | Nahoru | Další
import_request_variables | Domů | is_array


is_array

(PHP 4, PHP 5)

is_array — Finds whether a variable is an array

Popis

bool is_array ( mixed $var )

Finds whether the given variable is an array.

Seznam parametrů

var

The variable being evaluated.

Návratové hodnoty

Returns TRUE if var is an array, FALSE otherwise.

Příklady

Příklad 2345. Check that variable is an array

<?php
$yes = array('this', 'is', 'an array');

echo is_array($yes) ? 'Array' : 'not an Array';
echo "\n";

$no = 'this is a string';

echo is_array($no) ? 'Array' : 'not an Array';
?>

Výše uvedený příklad vypíše:

Array
not an Array

Viz také

is_float()
is_int()
is_string()
is_object()

Předcházející | Nahoru | Další
intval | Domů | is_binary


is_bool

(PHP 4, PHP 5)

is_bool — Finds out whether a variable is a boolean

Popis

bool is_bool ( mixed $var )

Finds whether the given variable is a boolean.

Seznam parametrů

var

The variable being evaluated.

Návratové hodnoty

Returns TRUE if var is a boolean, FALSE otherwise.

Příklady

Příklad 2346. is_bool() examples

<?php
$a = false;
$b = 0;

// Since $a is a boolean, this is true
if (is_bool($a)) {
    echo "Yes, this is a boolean";
}

// Since $b is not a boolean, this is not true
if (is_bool($b)) {
    echo "Yes, this is a boolean";
}
?>

Viz také

is_float()
is_int()
is_string()
is_object()
is_array()

Předcházející | Nahoru | Další
is_binary | Domů | is_buffer


is_callable

(PHP 4 >= 4.0.6, PHP 5)

is_callable — Verify that the contents of a variable can be called as a function

Popis

bool is_callable ( mixed $var [, bool $syntax_only [, string &$callable_name]] )

Verify that the contents of a variable can be called as a function. This can check that a simple variable contains the name of a valid function, or that an array contains a properly encoded object and function name.

Seznam parametrů

var

Can be either the name of a function stored in a string variable, or an object and the name of a method within the object, like this:

array($SomeObject, 'MethodName')

syntax_only

If set to TRUE the function only verifies that var might be a function or method. It will only reject simple variables that are not strings, or an array that does not have a valid structure to be used as a callback. The valid ones are supposed to have only 2 entries, the first of which is an object or a string, and the second a string.

callable_name

Receives the "callable name". In the example below it is "someClass:someMethod". Note, however, that despite the implication that someClass::SomeMethod() is a callable static method, this is not the case.

Návratové hodnoty

Returns TRUE if var is callable, FALSE otherwise.

Příklady

Příklad 2347. is_callable() example

<?php
//  How to check a variable to see if it can be called
//  as a function.

//
//  Simple variable containing a function
//

function someFunction()
{
}

$functionVariable = 'someFunction';

var_dump(is_callable($functionVariable, false, $callable_name));  // bool(true)

echo $callable_name, "\n";  // someFunction

//
//  Array containing a method
//

class someClass {

  function someMethod()
  {
  }

}

$anObject = new someClass();

$methodVariable = array($anObject, 'someMethod');

var_dump(is_callable($methodVariable, true, $callable_name));  //  bool(true)

echo $callable_name, "\n";  //  someClass:someMethod

?>

Viz také

function_exists()
method_exists()

Předcházející | Nahoru | Další
is_buffer | Domů | is_double


is_double

(PHP 4, PHP 5)

is_double — Alias pro is_float()

Popis

Tato funkce je aliasem: is_float().

Předcházející | Nahoru | Další
is_callable | Domů | is_float


is_float

(PHP 4, PHP 5)

is_float — Finds whether the type of a variable is float

Popis

bool is_float ( mixed $var )

Finds whether the type of the given variable is float.

Poznámka: To test if a variable is a number or a numeric string (such as form input, which is always a string), you must use is_numeric().

Seznam parametrů

var

The variable being evaluated.

Návratové hodnoty

Returns TRUE if var is a float, FALSE otherwise.

Příklady

Příklad 2348. is_float() example

<?php
if(is_float(27.25)) {
 echo "is float\n";
}else {
 echo "is not float\n";
}
var_dump(is_float('abc'));
var_dump(is_float(23));
var_dump(is_float(23.5));
var_dump(is_float(1e7));  //Scientific Notation
var_dump(is_float(true));
?>

Výše uvedený příklad vypíše:

is float
bool(false)
bool(false)
bool(true)
bool(true)
bool(false)

Viz také

is_bool()
is_int()
is_numeric()
is_string()
is_array()
is_object()

Předcházející | Nahoru | Další
is_double | Domů | is_int


is_int

(PHP 4, PHP 5)

is_int — Find whether the type of a variable is integer

Popis

bool is_int ( mixed $var )

Finds whether the type of the given variable is integer.

Poznámka: To test if a variable is a number or a numeric string (such as form input, which is always a string), you must use is_numeric().

Seznam parametrů

var

The variable being evaluated.

Návratové hodnoty

Returns TRUE if var is an integer, FALSE otherwise.

Příklady

Příklad 2349. is_int() example

<?php
if (is_int(23)) {
 echo "is integer\n";
} else {
 echo "is not an integer\n";
}
var_dump(is_int(23));
var_dump(is_int("23"));
var_dump(is_int(23.5));
var_dump(is_int(true));
?>

Výše uvedený příklad vypíše:

is integer
bool(true)
bool(false)
bool(false)
bool(false)

Viz také

is_bool()
is_float()
is_numeric()
is_string()
is_array()
is_object()

Předcházející | Nahoru | Další
is_float | Domů | is_integer


is_integer

(PHP 4, PHP 5)

is_integer — Alias pro is_int()

Popis

Tato funkce je aliasem: is_int().

Předcházející | Nahoru | Další
is_int | Domů | is_long


is_long

(PHP 4, PHP 5)

is_long — Alias pro is_int()

Popis

Tato funkce je aliasem: is_int().

Předcházející | Nahoru | Další
is_integer | Domů | is_null


is_null

(PHP 4 >= 4.0.4, PHP 5)

is_null — Finds whether a variable is NULL

Popis

bool is_null ( mixed $var )

Finds whether the given variable is NULL.

Seznam parametrů

var

The variable being evaluated.

Návratové hodnoty

Returns TRUE if var is null, FALSE otherwise.

Viz také

The NULL type
isset()
is_bool()
is_numeric()
is_float()
is_int()
is_string()
is_object()
is_array()

Předcházející | Nahoru | Další
is_long | Domů | is_numeric


is_numeric

(PHP 4, PHP 5)

is_numeric — Finds whether a variable is a number or a numeric string

Popis

bool is_numeric ( mixed $var )

Finds whether the given variable is numeric. Numeric strings consist of optional sign, any number of digits, optional decimal part and optional exponential part. Thus +0123.45e6 is a valid numeric value. Hexadecimal notation (0xFF) is allowed too but only without sign, decimal and exponential part.

Seznam parametrů

var

The variable being evaluated.

Návratové hodnoty

Returns TRUE if var is a number or a numeric string, FALSE otherwise.

Viz také

ctype_digit()
is_bool()
is_null()
is_float()
is_int()
is_string()
is_object()
is_array()

Předcházející | Nahoru | Další
is_null | Domů | is_object


is_object

(PHP 4, PHP 5)

is_object — Finds whether a variable is an object

Popis

bool is_object ( mixed $var )

Finds whether the given variable is an object.

Seznam parametrů

var

The variable being evaluated.

Návratové hodnoty

Returns TRUE if var is an object, FALSE otherwise.

Poznámky

Poznámka: This function will return FALSE if used on an unserialized object where the class definition is not present (even though gettype() returns object).

Viz také

is_bool()
is_int()
is_float()
is_string()
is_array()

Předcházející | Nahoru | Další
is_numeric | Domů | is_real


is_real

(PHP 4, PHP 5)

is_real — Alias pro is_float()

Popis

Tato funkce je aliasem: is_float().

Předcházející | Nahoru | Další
is_object | Domů | is_resource


is_resource

(PHP 4, PHP 5)

is_resource — Finds whether a variable is a resource

Popis

bool is_resource ( mixed $var )

Finds whether the given variable is a resource.

Seznam parametrů

var

The variable being evaluated.

Návratové hodnoty

Returns TRUE if var is a resource, FALSE otherwise.

Příklady

Příklad 2350. is_resource() example

<?php

$db_link = @mysql_connect('localhost', 'mysql_user', 'mysql_pass');
if (!is_resource($db_link)) {
    die('Can\'t connect : ' . mysql_error());
}

?>

Viz také

The resource-type documentation
get_resource_type()

Předcházející | Nahoru | Další
is_real | Domů | is_scalar


is_scalar

(PHP 4 >= 4.0.5, PHP 5)

is_scalar — Finds whether a variable is a scalar

Popis

bool is_scalar ( mixed $var )

Finds whether the given variable is a scalar.

Scalar variables are those containing an integer, float, string or boolean. Types array, object and resource are not scalar.

Poznámka: is_scalar() does not consider resource type values to be scalar as resources are abstract datatypes which are currently based on integers. This implementation detail should not be relied upon, as it may change.

Seznam parametrů

var

The variable being evaluated.

Návratové hodnoty

Returns TRUE if var is a scalar FALSE otherwise.

Příklady

Příklad 2351. is_scalar() example

<?php
function show_var($var)
{
    if (is_scalar($var)) {
        echo $var;
    } else {
        var_dump($var);
    }
}
$pi = 3.1416;
$proteins = array("hemoglobin", "cytochrome c oxidase", "ferredoxin");

show_var($pi);
show_var($proteins)

?>

Výše uvedený příklad vypíše:

3.1416
array(3) {
  [0]=>
  string(10) "hemoglobin"
  [1]=>
  string(20) "cytochrome c oxidase"
  [2]=>
  string(10) "ferredoxin"
}

Viz také

is_float()
is_int()
is_numeric()
is_real()
is_string()
is_bool()
is_object()
is_array()

Předcházející | Nahoru | Další
is_resource | Domů | is_string


is_string

(PHP 4, PHP 5)

is_string — Find whether the type of a variable is string

Popis

bool is_string ( mixed $var )

Finds whether the type given variable is string.

Seznam parametrů

var

The variable being evaluated.

Návratové hodnoty

Returns TRUE if var is of type string, FALSE otherwise.

Příklady

Příklad 2352. is_string() example

<?php
if (is_string("23")) {
 echo "is string\n";
} else {
 echo "is not an string\n";
}
var_dump(is_string('abc'));
var_dump(is_string("23"));
var_dump(is_string(23.5));
var_dump(is_string(true));
?>

Výše uvedený příklad vypíše:

is string
bool(true)
bool(true)
bool(false)
bool(false)

Viz také

is_float()
is_int()
is_bool()
is_object()
is_array()

Předcházející | Nahoru | Další
is_scalar | Domů | is_unicode


isset

(PHP 4, PHP 5)

isset — Determine whether a variable is set

Popis

bool isset ( mixed $var [, mixed $var [, $...]] )

Determine whether a variable is set.

If a variable has been unset with unset(), it will no longer be set. isset() will return FALSE if testing a variable that has been set to NULL. Also note that a NULL byte ("\0") is not equivalent to the PHP NULL constant.

If multiple parameters are supplied then isset() will return TRUE only if all of the parameters are set. Evaluation goes from left to right and stops as soon as an unset variable is encountered.

Seznam parametrů

var

The variable to be checked.

var

Another variable ..

...

Návratové hodnoty

Returns TRUE if var exists; FALSE otherwise.

Příklady

Příklad 2353. isset() Examples

<?php

$var = '';

// This will evaluate to TRUE so the text will be printed.
if (isset($var)) {
    echo "This var is set so I will print.";
}

// In the next examples we'll use var_dump to output
// the return value of isset().

$a = "test";
$b = "anothertest";

var_dump(isset($a));      // TRUE
var_dump(isset($a, $b)); // TRUE

unset ($a);

var_dump(isset($a));     // FALSE
var_dump(isset($a, $b)); // FALSE

$foo = NULL;
var_dump(isset($foo));   // FALSE

?>

This also work for elements in arrays:

<?php

$a = array ('test' => 1, 'hello' => NULL);

var_dump(isset($a['test']));            // TRUE
var_dump(isset($a['foo']));             // FALSE
var_dump(isset($a['hello']));           // FALSE

// The key 'hello' equals NULL so is considered unset
// If you want to check for NULL key values then try:
var_dump(array_key_exists('hello', $a)); // TRUE

?>

Poznámky

Varování

isset() only works with variables as passing anything else will result in a parse error. For checking if constants are set use the defined() function.

Poznámka: Protože se jedná o jazykový konstrukt a ne o funkci, nemůžete ho volat pomocí funkcí v proměnných

Viz také

empty()
unset()
defined()
the type comparison tables
array_key_exists()
is_null()
the error control @ operator

Předcházející | Nahoru | Další
is_unicode | Domů | print_r


print_r

(PHP 4, PHP 5)

print_r — Prints human-readable information about a variable

Popis

mixed print_r ( mixed $expression [, bool $return] )

print_r() displays information about a variable in a way that's readable by humans.

print_r(), var_dump() and var_export() will also show protected and private properties of objects with PHP 5.

Remember that print_r() will move the array pointer to the end. Use reset() to bring it back to beginning.

Seznam parametrů

expression

The expression to be printed.

return

If you would like to capture the output of print_r(), use the return parameter. If this parameter is set to TRUE, print_r() will return its output, instead of printing it (which it does by default).

Návratové hodnoty

If given a string, integer or float, the value itself will be printed. If given an array, values will be presented in a format that shows keys and elements. Similar notation is used for objects.

Poznámky

Poznámka: Tato funkce vnitřně používá výstupní bufferování s tímto parametrem a proto ji nelze použít uvnitř callbacku ob_start().

ChangeLog (záznam změn)

Verze | Popis
4.3.0 | The return parameter was added. If you need to capture the output of print_r() with an older version of PHP prior, use the output-control functions.
4.0.4 | Prior to PHP 4.0.4, print_r() will continue forever if given an array or object that contains a direct or indirect reference to itself. An example is print_r($GLOBALS) because $GLOBALS is itself a global variable that contains a reference to itself.

Příklady

Příklad 2354. print_r() example

<pre>
<?php
$a = array ('a' => 'apple', 'b' => 'banana', 'c' => array ('x', 'y', 'z'));
print_r ($a);
?>
</pre>

Výše uvedený příklad vypíše:

<pre>
Array
(
    [a] => apple
    [b] => banana
    [c] => Array
        (
            [0] => x
            [1] => y
            [2] => z
        )
)
</pre>

Příklad 2355. return parameter example

<?php
$b = array ('m' => 'monkey', 'foo' => 'bar', 'x' => array ('x', 'y', 'z'));
$results = print_r($b, true); // $results now contains output from print_r
?>

Viz také

ob_start()
var_dump()
var_export()

Předcházející | Nahoru | Další
isset | Domů | serialize


serialize

(PHP 4, PHP 5, PECL axis2:0.1.0-0.1.1)

serialize — Generates a storable representation of a value

Popis

string serialize ( mixed $value )

Generates a storable representation of a value

This is useful for storing or passing PHP values around without losing their type and structure.

To make the serialized string into a PHP value again, use unserialize().

Seznam parametrů

value

The value to be serialized. serialize() handles all types, except the resource-type. You can even serialize() arrays that contain references to itself. Circular references inside the array/object you are serialize()ing will also be stored. Any other reference will be lost.

When serializing objects, PHP will attempt to call the member function __sleep prior to serialization. This is to allow the object to do any last minute clean-up, etc. prior to being serialized. Likewise, when the object is restored using unserialize() the __wakeup member function is called.

Návratové hodnoty

Returns a string containing a byte-stream representation of value that can be stored anywhere.

Příklady

Příklad 2356. serialize() example

<?php
// $session_data contains a multi-dimensional array with session
// information for the current user.  We use serialize() to store
// it in a database at the end of the request.

$conn = odbc_connect("webdb", "php", "chicken");
$stmt = odbc_prepare($conn,
      "UPDATE sessions SET data = ? WHERE id = ?");
$sqldata = array (serialize($session_data), $_SERVER['PHP_AUTH_USER']);
if (!odbc_execute($stmt, &$sqldata)) {
    $stmt = odbc_prepare($conn,
     "INSERT INTO sessions (id, data) VALUES(?, ?)");
    if (!odbc_execute($stmt, &$sqldata)) {
        /* Something went wrong.. */
    }
}
?>

ChangeLog (záznam změn)

Verze | Popis
4.0.7 | The object serialization process was fixed.
4.0.0 | When serializing an object, methods are not lost anymore. Please see the Serializing Objects for more information.

Poznámky

Poznámka: It is not possible to serialize PHP built-in objects.

Viz také

unserialize()
Serializing Objects

Předcházející | Nahoru | Další
print_r | Domů | settype


settype

(PHP 4, PHP 5)

settype — Set the type of a variable

Popis

bool settype ( mixed &$var, string $type )

Set the type of variable var to type.

Seznam parametrů

var

The variable being converted.

type

Possibles values of type are:

  • "boolean" (or, since PHP 4.2.0, "bool")
  • "integer" (or, since PHP 4.2.0, "int")
  • "float" (only possible since PHP 4.2.0, for older versions use the deprecated variant "double")
  • "string"
  • "array"
  • "object"
  • "null" (since PHP 4.2.0)

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 2357. settype() example

<?php
$foo = "5bar"; // string
$bar = true;   // boolean

settype($foo, "integer"); // $foo is now 5   (integer)
settype($bar, "string");  // $bar is now "1" (string)
?>

Poznámky

Poznámka: Maximum value for "int" is PHP_INT_MAX.

Viz také

gettype()
type-casting
type-juggling

Předcházející | Nahoru | Další
serialize | Domů | strval


strval

(PHP 4, PHP 5)

strval — Get string value of a variable

Popis

string strval ( mixed $var )

Returns the string value of var. See the documentation on string for more information on converting to string.

var may be any scalar type. You cannot use strval() on arrays or objects.

Viz také

floatval()
intval()
settype()
Type juggling

Předcházející | Nahoru | Další
settype | Domů | unserialize


unserialize

(PHP 4, PHP 5)

unserialize — Creates a PHP value from a stored representation

Popis

mixed unserialize ( string $str )

unserialize() takes a single serialized variable and converts it back into a PHP value.

Seznam parametrů

str

The serialized string.

If the variable being unserialized is an object, after successfully reconstructing the object PHP will automatically attempt to call the __wakeup() member function (if it exists).

unserialize_callback_func directive: It's possible to set a callback-function which will be called, if an undefined class should be instantiated during unserializing. (to prevent getting an incomplete object "__PHP_Incomplete_Class".) Use your php.ini, ini_set() or .htaccess to define 'unserialize_callback_func'. Everytime an undefined class should be instantiated, it'll be called. To disable this feature just empty this setting.

Návratové hodnoty

The converted value is returned, and can be a boolean, integer, float, string, array or object.

In case the passed string is not unserializeable, FALSE is returned and E_NOTICE is issued.

ChangeLog (záznam změn)

Verze | Popis
4.2.0 | The directive unserialize_callback_func directive became available.
4.0.0 | When serializing an object, methods are not lost anymore. Please see the Serializing Objects for more information.

Příklady

Příklad 2358. unserialize() example

<?php
// Here, we use unserialize() to load session data to the
// $session_data array from the string selected from a database.
// This example complements the one described with serialize().

$conn = odbc_connect("webdb", "php", "chicken");
$stmt = odbc_prepare($conn, "SELECT data FROM sessions WHERE id = ?");
$sqldata = array($_SERVER['PHP_AUTH_USER']);
if (!odbc_execute($stmt, &$sqldata) || !odbc_fetch_into($stmt, &$tmp)) {
    // if the execute or fetch fails, initialize to empty array
    $session_data = array();
} else {
    // we should now have the serialized data in $tmp[0].
    $session_data = unserialize($tmp[0]);
    if (!is_array($session_data)) {
        // something went wrong, initialize to empty array
        $session_data = array();
    }
}
?>

Příklad 2359. unserialize_callback_func example

<?php
$serialized_object='O:1:"a":1:{s:5:"value";s:3:"100";}';

// unserialize_callback_func directive available as of PHP 4.2.0
ini_set('unserialize_callback_func', 'mycallback'); // set your callback_function

function mycallback($classname)
{
    // just include a file containing your classdefinition
    // you get $classname to figure out which classdefinition is required
}
?>

Poznámky

Varování

FALSE is returned both in the case of an error and if unserializing the serialized FALSE value. It is possible to catch this special case by comparing str with serialize(false) or by catching the issued E_NOTICE.

Viz také

serialize()

Předcházející | Nahoru | Další
strval | Domů | unset


unset

(PHP 4, PHP 5)

unset — Unset a given variable

Popis

void unset ( mixed $var [, mixed $var [, mixed $...]] )

unset() destroys the specified variables.

The behavior of unset() inside of a function can vary depending on what type of variable you are attempting to destroy.

If a globalized variable is unset() inside of a function, only the local variable is destroyed. The variable in the calling environment will retain the same value as before unset() was called.

<?php
function destroy_foo()
{
    global $foo;
    unset($foo);
}

$foo = 'bar';
destroy_foo();
echo $foo;
?>

Výše uvedený příklad vypíše:

bar

If you would like to unset() a global variable inside of a function, you can use the $GLOBALS array to do so:

<?php
function foo()
{
    unset($GLOBALS['bar']);
}

$bar = "something";
foo();
?>

If a variable that is PASSED BY REFERENCE is unset() inside of a function, only the local variable is destroyed. The variable in the calling environment will retain the same value as before unset() was called.

<?php
function foo(&$bar)
{
    unset($bar);
    $bar = "blah";
}

$bar = 'something';
echo "$bar\n";

foo($bar);
echo "$bar\n";
?>

Výše uvedený příklad vypíše:

something
something

If a static variable is unset() inside of a function, unset() destroys the variable only in the context of the rest of a function. Following calls will restore the previous value of a variable.

<?php
function foo()
{
    static $bar;
    $bar++;
    echo "Before unset: $bar, ";
    unset($bar);
    $bar = 23;
    echo "after unset: $bar\n";
}

foo();
foo();
foo();
?>

Výše uvedený příklad vypíše:

Before unset: 1, after unset: 23
Before unset: 2, after unset: 23
Before unset: 3, after unset: 23

Seznam parametrů

var

The variable to be unset.

var

Another variable ..

...

Návratové hodnoty

Nevrací se žádná hodnota.

ChangeLog (záznam změn)

Verze | Popis
4.0.0 | unset() became an expression. (In PHP 3, unset() would always return 1).

Příklady

Příklad 2360. unset() example

<?php
// destroy a single variable
unset($foo);

// destroy a single element of an array
unset($bar['quux']);

// destroy more than one variable
unset($foo1, $foo2, $foo3);
?>

Poznámky

Poznámka: Protože se jedná o jazykový konstrukt a ne o funkci, nemůžete ho volat pomocí funkcí v proměnných

Poznámka: It is possible to unset even object properties visible in current context.

Poznámka: It is not possible to unset $this inside an object method since PHP 5.

Viz také

isset()
empty()
array_splice()

Předcházející | Nahoru | Další
unserialize | Domů | var_dump


var_dump

(PHP 4, PHP 5)

var_dump — Dumps information about a variable

Popis

void var_dump ( mixed $expression [, mixed $expression [, $...]] )

This function displays structured information about one or more expressions that includes its type and value. Arrays and objects are explored recursively with values indented to show structure.

In PHP 5 all public, private and protected properties of objects will be returned in the output.

Tip

Jako pro cokoliv, co posílá své výsledky přímo do prohlížeče, můžete použít funkce pro řízení výstupu k zachycení výstupu této funkce a jeho uložení - například - do řetězce (string).

Seznam parametrů

expression

The variable you want to export.

Návratové hodnoty

Nevrací se žádná hodnota.

Příklady

Příklad 2361. var_dump() example

<?php
$a = array(1, 2, array("a", "b", "c"));
var_dump($a);
?>

Výše uvedený příklad vypíše:

array(3) {
  [0]=>
  int(1)
  [1]=>
  int(2)
  [2]=>
  array(3) {
    [0]=>
    string(1) "a"
    [1]=>
    string(1) "b"
    [2]=>
    string(1) "c"
  }
}
<?php

$b = 3.1;
$c = true;
var_dump($b, $c);

?>

Výše uvedený příklad vypíše:

float(3.1)
bool(true)

Viz také

var_export()
print_r()

Předcházející | Nahoru | Další
unset | Domů | var_export


var_export

(PHP 4 >= 4.2.0, PHP 5)

var_export — Outputs or returns a parsable string representation of a variable

Popis

mixed var_export ( mixed $expression [, bool $return] )

var_export() gets structured information about the given variable. It is similar to var_dump() with one exception: the returned representation is valid PHP code.

Seznam parametrů

expression

The variable you want to export.

return

If used and set to TRUE, var_export() will return the variable representation instead of outputing it.

Poznámka: Tato funkce vnitřně používá výstupní bufferování s tímto parametrem a proto ji nelze použít uvnitř callbacku ob_start().

Návratové hodnoty

Returns the variable representation when the return parameter is used and evaluates to TRUE. Otherwise, this function will return NULL.

ChangeLog (záznam změn)

Verze | Popis
5.1.0 | Possibility to export classes and arrays containing classes using the __set_state magic method.

Příklady

Příklad 2362. var_export() Examples

<?php
$a = array (1, 2, array ("a", "b", "c"));
var_export($a);
?>

Výše uvedený příklad vypíše:

array (
  0 => 1,
  1 => 2,
  2 =>
  array (
    0 => 'a',
    1 => 'b',
    2 => 'c',
  ),
)
<?php

$b = 3.1;
$v = var_export($b, true);
echo $v;

?>

Výše uvedený příklad vypíše:

3.1

Příklad 2363. Exporting classes since PHP 5.1.0

<?php
class A { public $var; }
$a = new A;
$a->var = 5;
var_export($a);
?>

Výše uvedený příklad vypíše:

A::__set_state(array(
   'var' => 5,
))

Příklad 2364. Using __set_state (since PHP 5.1.0)

<?php
class A
{
    public $var1;
    public $var2;

    public static function __set_state($an_array)
    {
        $obj = new A;
        $obj->var1 = $an_array['var1'];
        $obj->var2 = $an_array['var2'];
        return $obj;
    }
}

$a = new A;
$a->var1 = 5;
$a->var2 = 'foo';

eval('$b = ' . var_export($a, true) . ';'); // $b = A::__set_state(array(
                                            //    'var1' => 5,
                                            //    'var2' => 'foo',
                                            // ));
var_dump($b);
?>

Výše uvedený příklad vypíše:

object(A)#2 (2) {
  ["var1"]=>
  int(5)
  ["var2"]=>
  string(3) "foo"
}

Poznámky

Poznámka: Variables of type resource couldn't be exported by this function.

Poznámka: var_export() does not handle circular references as it would be close to impossible to generate parsable PHP code for that. If you want to do something with the full representation of an array or object, use serialize().

Viz také

print_r()
serialize()
var_dump()

Předcházející | Nahoru | Další
var_dump | Domů | CLXXII. Funkce pro práci s Verisign Payflow Pro


vpopmail Functions

Předcházející VI. Reference funkcí Další

CLXXIII. vpopmail Functions

Úvod

Varování

Toto rozšíření je EXPERIMENTÁLNÍ. Chování tohoto rozšíření, názvy funkcí a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může bez ohlášení změnit. Berte to v úvahu a používejte tento modul na vlastní nebezpečí.

This extension has been moved from PHP as of PHP 4.3.0 and now vpopmail lives in » PECL.

Instalace

As of PHP 4, these functions are only available if PHP was configured with --with-vpopmail[=DIR].

Obsah

vpopmail_add_alias_domain_ex — Add alias to an existing virtual domain
vpopmail_add_alias_domain — Add an alias for a virtual domain
vpopmail_add_domain_ex — Add a new virtual domain
vpopmail_add_domain — Add a new virtual domain
vpopmail_add_user — Add a new user to the specified virtual domain
vpopmail_alias_add — Insert a virtual alias
vpopmail_alias_del_domain — Deletes all virtual aliases of a domain
vpopmail_alias_del — Deletes all virtual aliases of a user
vpopmail_alias_get_all — Get all lines of an alias for a domain
vpopmail_alias_get — Get all lines of an alias for a domain
vpopmail_auth_user — Attempt to validate a username/domain/password
vpopmail_del_domain_ex — Delete a virtual domain
vpopmail_del_domain — Delete a virtual domain
vpopmail_del_user — Delete a user from a virtual domain
vpopmail_error — Get text message for last vpopmail error
vpopmail_passwd — Change a virtual user's password
vpopmail_set_user_quota — Sets a virtual user's quota
Předcházející | Nahoru | Další
pfpro_version | Domů | vpopmail_add_alias_domain_ex


vpopmail_add_alias_domain_ex

(PHP 4 >= 4.0.5, PECL vpopmail:0.2)

vpopmail_add_alias_domain_ex — Add alias to an existing virtual domain

Popis

bool vpopmail_add_alias_domain_ex ( string $olddomain, string $newdomain )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
CLXXIII. vpopmail Functions | Domů | vpopmail_add_alias_domain


vpopmail_add_alias_domain

(PHP 4 >= 4.0.5, PECL vpopmail:0.2)

vpopmail_add_alias_domain — Add an alias for a virtual domain

Popis

bool vpopmail_add_alias_domain ( string $domain, string $aliasdomain )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
vpopmail_add_alias_domain_ex | Domů | vpopmail_add_domain_ex


vpopmail_add_domain_ex

(PHP 4 >= 4.0.5, PECL vpopmail:0.2)

vpopmail_add_domain_ex — Add a new virtual domain

Popis

bool vpopmail_add_domain_ex ( string $domain, string $passwd [, string $quota [, string $bounce [, bool $apop]]] )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
vpopmail_add_alias_domain | Domů | vpopmail_add_domain


vpopmail_add_domain

(PHP 4 >= 4.0.5, PECL vpopmail:0.2)

vpopmail_add_domain — Add a new virtual domain

Popis

bool vpopmail_add_domain ( string $domain, string $dir, int $uid, int $gid )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
vpopmail_add_domain_ex | Domů | vpopmail_add_user


vpopmail_add_user

(PHP 4 >= 4.0.5, PECL vpopmail:0.2)

vpopmail_add_user — Add a new user to the specified virtual domain

Popis

bool vpopmail_add_user ( string $user, string $domain, string $password [, string $gecos [, bool $apop]] )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
vpopmail_add_domain | Domů | vpopmail_alias_add


vpopmail_alias_add

(PHP 4 >= 4.0.7, PECL vpopmail:0.2)

vpopmail_alias_add — Insert a virtual alias

Popis

bool vpopmail_alias_add ( string $user, string $domain, string $alias )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
vpopmail_add_user | Domů | vpopmail_alias_del_domain


vpopmail_alias_del_domain

(PHP 4 >= 4.0.7, PECL vpopmail:0.2)

vpopmail_alias_del_domain — Deletes all virtual aliases of a domain

Popis

bool vpopmail_alias_del_domain ( string $domain )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
vpopmail_alias_add | Domů | vpopmail_alias_del


vpopmail_alias_del

(PHP 4 >= 4.0.7, PECL vpopmail:0.2)

vpopmail_alias_del — Deletes all virtual aliases of a user

Popis

bool vpopmail_alias_del ( string $user, string $domain )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
vpopmail_alias_del_domain | Domů | vpopmail_alias_get_all


vpopmail_alias_get_all

(PHP 4 >= 4.0.7, PECL vpopmail:0.2)

vpopmail_alias_get_all — Get all lines of an alias for a domain

Popis

array vpopmail_alias_get_all ( string $domain )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
vpopmail_alias_del | Domů | vpopmail_alias_get


vpopmail_alias_get

(PHP 4 >= 4.0.7, PECL vpopmail:0.2)

vpopmail_alias_get — Get all lines of an alias for a domain

Popis

array vpopmail_alias_get ( string $alias, string $domain )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
vpopmail_alias_get_all | Domů | vpopmail_auth_user


vpopmail_auth_user

(PHP 4 >= 4.0.5, PECL vpopmail:0.2)

vpopmail_auth_user — Attempt to validate a username/domain/password

Popis

bool vpopmail_auth_user ( string $user, string $domain, string $password [, string $apop] )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
vpopmail_alias_get | Domů | vpopmail_del_domain_ex


vpopmail_del_domain_ex

(PHP 4 >= 4.0.5, PECL vpopmail:0.2)

vpopmail_del_domain_ex — Delete a virtual domain

Popis

bool vpopmail_del_domain_ex ( string $domain )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
vpopmail_auth_user | Domů | vpopmail_del_domain


vpopmail_del_domain

(PHP 4 >= 4.0.5, PECL vpopmail:0.2)

vpopmail_del_domain — Delete a virtual domain

Popis

bool vpopmail_del_domain ( string $domain )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
vpopmail_del_domain_ex | Domů | vpopmail_del_user


vpopmail_del_user

(PHP 4 >= 4.0.5, PECL vpopmail:0.2)

vpopmail_del_user — Delete a user from a virtual domain

Popis

bool vpopmail_del_user ( string $user, string $domain )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
vpopmail_del_domain | Domů | vpopmail_error


vpopmail_error

(PHP 4 >= 4.0.5, PECL vpopmail:0.2)

vpopmail_error — Get text message for last vpopmail error

Popis

string vpopmail_error ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
vpopmail_del_user | Domů | vpopmail_passwd


vpopmail_passwd

(PHP 4 >= 4.0.5, PECL vpopmail:0.2)

vpopmail_passwd — Change a virtual user's password

Popis

bool vpopmail_passwd ( string $user, string $domain, string $password [, bool $apop] )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
vpopmail_error | Domů | vpopmail_set_user_quota


vpopmail_set_user_quota

(PHP 4 >= 4.0.5, PECL vpopmail:0.2)

vpopmail_set_user_quota — Sets a virtual user's quota

Popis

bool vpopmail_set_user_quota ( string $user, string $domain, string $quota )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
vpopmail_passwd | Domů | CLXXIV. W32api Functions


W32api Functions

Předcházející VI. Reference funkcí Další

CLXXIV. W32api Functions

Úvod

This extension is a generic extension API to DLLs. This was originally written to allow access to the Win32 API from PHP, although you can also access other functions exported via other DLLs.

Currently supported types are generic PHP types (strings, booleans, floats, integers and nulls) and types you define with w32api_deftype().

Poznámka: Toto rozšíření bylo přesunuto do repozitáře PECL a již nebude součástí balíku PHP.5.1.0.

Varování

Toto rozšíření je EXPERIMENTÁLNÍ. Chování tohoto rozšíření, názvy funkcí a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může bez ohlášení změnit. Berte to v úvahu a používejte tento modul na vlastní nebezpečí.

Požadavky

This extension will only work on Windows systems.

Instalace

K používání těchto funkcí není třeba žádná instalace, jsou součástí jádra PHP.

Konfigurace běhu

Toto rozšíření nemá definováno žádné konfigurační direktivy.

Typy prostředků

This extension defines one resource type, used for user defined types. The name of this resource is "dynaparm".

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

DC_MICROSOFT (integer)
DC_BORLAND (integer)
DC_CALL_CDECL (integer)
DC_CALL_STD (integer)
DC_RETVAL_MATH4 (integer)
DC_RETVAL_MATH8 (integer)
DC_CALL_STD_BO (integer)
DC_CALL_STD_MS (integer)
DC_CALL_STD_M8 (integer)
DC_FLAG_ARGPTR (integer)

Příklady

This example gets the amount of time the system has been running and displays it in a message box.

Příklad 2367. Get the uptime and display it in a message box

<?php
// Define constants needed, taken from
// Visual Studio/Tools/Winapi/WIN32API.txt
define("MB_OK", 0);

// Load the extension in
dl("php_w32api.dll");

// Register the GetTickCount function from kernel32.dll
w32api_register_function("kernel32.dll",
                         "GetTickCount",
                         "long");

// Register the MessageBoxA function from User32.dll
w32api_register_function("User32.dll",
                         "MessageBoxA",
                         "long");

// Get uptime information
$ticks = GetTickCount();

// Convert it to a nicely displayable text
$secs  = floor($ticks / 1000);
$mins  = floor($secs / 60);
$hours = floor($mins / 60);

$str = sprintf("You have been using your computer for:" .
                "\r\n %d Milliseconds, or \r\n %d Seconds" .
                "or \r\n %d mins or\r\n %d hours %d mins.",
                $ticks,
                $secs,
                $mins,
                $hours,
                $mins - ($hours*60));

// Display a message box with only an OK button and the uptime text
MessageBoxA(NULL,
            $str,
            "Uptime Information",
            MB_OK);
?>

Obsah

w32api_deftype — Defines a type for use with other w32api_functions
w32api_init_dtype — Creates an instance of the data type typename and fills it with the values passed
w32api_invoke_function — Invokes function funcname with the arguments passed after the function name
w32api_register_function — Registers function function_name from library with PHP
w32api_set_call_method — Sets the calling method used
Předcházející | Nahoru | Další
vpopmail_set_user_quota | Domů | w32api_deftype


w32api_deftype

(PHP 4 >= 4.2.0)

w32api_deftype — Defines a type for use with other w32api_functions

Popis

bool w32api_deftype ( string $typename, string $member1_type, string $member1_name [, string $... [, string $...]] )

You need to call this function if you would like to define a type for a w32api call.

Seznam parametrů

typename

The name of the type.

member1_type

A member type can be a user defined type. All the type names are case sensitive. Built in type names should be provided in lowercase.

member1_name

The member name of member1_type.

...

...

This function takes 2n+1 arguments, where n is the number of members the type has. After that is the type of the member followed by the members name (in pairs).

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
CLXXIV. W32api Functions | Domů | w32api_init_dtype


w32api_init_dtype

(PHP 4 >= 4.2.0)

w32api_init_dtype — Creates an instance of the data type typename and fills it with the values passed

Popis

resource w32api_init_dtype ( string $typename, mixed $value [, mixed $...] )

This function creates an instance of the data type named typename, filling in the values of the data type.

Seznam parametrů

typename

The typename parameter is case sensitive.

value

You should give the values in the same order as you defined the data type with w32api_deftype().

...

Návratové hodnoty

Returns a dynaparm resource.

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
w32api_deftype | Domů | w32api_invoke_function


w32api_invoke_function

(PHP 4 >= 4.2.0)

w32api_invoke_function — Invokes function funcname with the arguments passed after the function name

Popis

mixed w32api_invoke_function ( string $funcname, mixed $argument [, mixed $...] )

w32api_invoke_function() tries to find the previously registered function, passing the parameters you provided.

Seznam parametrů

funcname

The function name.

argument

Any of the arguments can be of any PHP type or w32api_deftype() defined type, as needed.

...

Návratové hodnoty

The return type is the one you set when you registered the function, the value is the one returned by the function itself.

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
w32api_init_dtype | Domů | w32api_register_function


w32api_register_function

(PHP 4 >= 4.2.0)

w32api_register_function — Registers function function_name from library with PHP

Popis

bool w32api_register_function ( string $library, string $function_name, string $return_type )

This function tries to find the function_name function in libary, and tries to import it into PHP.

Seznam parametrů

library

The library name, as a string.

function_name

The function name, as a string.

return_type

The function will be registered with the given return_type. This type can be a generic PHP type, or a type defined with w32api_deftype(). All type names are case sensitive. Built in type names should be provided in lowercase.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
w32api_invoke_function | Domů | w32api_set_call_method


w32api_set_call_method

(PHP 4 >= 4.2.0)

w32api_set_call_method — Sets the calling method used

Popis

void w32api_set_call_method ( int $method )

This function sets the method call type.

Seznam parametrů

method

Can be one of DC_CALL_CDECL or DC_CALL_STD (the extension default).

Návratové hodnoty

Nevrací se žádná hodnota.

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
w32api_register_function | Domů | CLXXV. WDDX funkce


WDDX funkce

Předcházející VI. Reference funkcí Další

CLXXV. WDDX funkce

Úvod

Tyto funkce jsou určeny pro práci s » WDDX.

Požadavky

Pokud chcete používat WDDX, budete muset nainstalovat expat knihovnu (která je u Apache 1.3.7 a vyšších).

Instalace

Po instalaci expatu zkompilujte PHP s volbou --enable-wddx.

Verze PHP pro Windows má vestavěnou podporu pro toto rozšíření. K použití těchto funkcí není třeba načítat žádná další rozšíření.

Konfigurace běhu

Toto rozšíření nemá definováno žádné konfigurační direktivy.

Typy prostředků

Toto rozšíření nemá definován žádný typ prostředku (resource).

Předdefinované konstanty

Toto rozšíření nemá definovány žádné konstanty.

Příklady

Všechny funkce, které serializují proměnné, používají první element pole k rozhodnutí jestli se toto pole serializuje do pole nebo struktury. Pokud má první element řetězec jako index, serializuje se do struktury, jinak do pole.

Příklad 2368. Serializace jediné hodnoty

<?php
print wddx_serialize_value("Ukázka převodu paketu z PHP do WDDX", "PHP packet");
?>

Tato ukázka vytvoří:

<wddxPacket version='1.0'><header comment='PHP packet'/><data>
<string>Ukázka převodu paketu z PHP do WDDX</string></data></wddxPacket>

Příklad 2369. Použití inkrementálních paketů

<?php
$pi = 3.1415926;
$packet_id = wddx_packet_start("PHP");
wddx_add_vars($packet_id, "pi");

/* Předpokládejme, že $cities pochází z databáze */
$cities = array("Austin", "Novato", "Seattle");
wddx_add_vars($packet_id, "cities");

$packet = wddx_packet_end($packet_id);
print $packet;
?>

Tato ukázka vytvoří:

<wddxPacket version='1.0'><header comment='PHP'/><data><struct>
<var name='pi'><number>3.1415926</number></var><var name='cities'>
<array length='3'><string>Austin</string><string>Novato</string>
<string>Seattle</string></array></var></struct></data></wddxPacket>

Poznámka: If you want to serialize non-ASCII characters you have to set the appropriate locale before doing so (see setlocale()).

Obsah

wddx_add_vars — Přidat proměnné do WDDX paketu s určeným ID
wddx_deserialize — Deserializovat WDDX paket
wddx_packet_end — Ukončit WDDX paket se zadaným ID
wddx_packet_start — Začít nový WDDX paket obsahující strukturu
wddx_serialize_value — Serializovat jedinou hodnotu do WDDX paketu
wddx_serialize_vars — Serializovat proměnné do WDDX paketu
wddx_unserialize — Unserializes a WDDX packet
Předcházející | Nahoru | Další
w32api_set_call_method | Domů | wddx_add_vars


wddx_add_vars

(PHP 4, PHP 5)

wddx_add_vars — Přidat proměnné do WDDX paketu s určeným ID

Popis

bool wddx_add_vars ( int $packet_id, mixed $name_var [, mixed $...] )

wddx_add_vars() se používá k serializaci předaných proměnných a přidání výsledku do paketu specifikovaného packet_id. Proměnné určené k serializaci se udávají stejně jako u wddx_serialize_vars().

Předcházející | Nahoru | Další
CLXXV. WDDX funkce | Domů | wddx_deserialize


wddx_deserialize

(PHP 4, PHP 5)

wddx_deserialize — Deserializovat WDDX paket

Popis

mixed wddx_deserialize ( string $packet )

wddx_deserialized() přijímá řetězec packet a deserializuje ho. Vrací výsledek, což může být řetězec, číslo, nebo pole. Pozn.: Struktury se deserializují do asociativních polí.

Předcházející | Nahoru | Další
wddx_add_vars | Domů | wddx_packet_end


wddx_packet_end

(PHP 4, PHP 5)

wddx_packet_end — Ukončit WDDX paket se zadaným ID

Popis

string wddx_packet_end ( resource $packet_id )

wddx_packet_end() ukončí WDDX paket určený argumentem packet_id a vrací řetězec obsahující tento paket.

Předcházející | Nahoru | Další
wddx_deserialize | Domů | wddx_packet_start


wddx_packet_start

(PHP 4, PHP 5)

wddx_packet_start — Začít nový WDDX paket obsahující strukturu

Popis

resource wddx_packet_start ( [string $comment] )

wddx_packet_start() se používá k započetí nového WDDX paketu pro inkrementální přidávání proměnných. Přijímá volitelný řetězec comment a vrací ID packetu pro použití v dalších funkcích. Uvnitř paketu automaticky vytváří definici struktury která bude obsahovat přidané proměnné.

Předcházející | Nahoru | Další
wddx_packet_end | Domů | wddx_serialize_value


wddx_serialize_value

(PHP 4, PHP 5)

wddx_serialize_value — Serializovat jedinou hodnotu do WDDX paketu

Popis

string wddx_serialize_value ( mixed $var [, string $comment] )

wddx_serialize_value() se používá k vytvoření WDDX paketu z jediné dané hodnoty. Přijímá hodnotu obsaženou ve var a volitelný řetězec comment, který se použije v hlavičce paketu, a vrací WDDX paket.

Předcházející | Nahoru | Další
wddx_packet_start | Domů | wddx_serialize_vars


wddx_serialize_vars

(PHP 4, PHP 5)

wddx_serialize_vars — Serializovat proměnné do WDDX paketu

Popis

string wddx_serialize_vars ( mixed $var_name [, mixed $...] )

wddx_serialize_vars() se používá k vytvoření WDDX paketu se strukturou která obsahuje serializovanou reprezentaci předaných proměnných.

wddx_serialize_vars() přijímá proměnný počet argumentů, každý z nich může být buď řetězec obsahující název proměnné, nebo pole názvů proměnných, nebo jiné pole atd.

Příklad 2370. wddx_serialize_vars example

<?php
$a = 1;
$b = 5.5;
$c = array("blue", "orange", "violet");
$d = "colors";

$clvars = array("c", "d");
print wddx_serialize_vars("a", "b", $clvars);
?>

Výše uvedená ukázka vytvoří:

<wddxPacket version='1.0'><header/><data><struct><var name='a'><number>1</number></var>
<var name='b'><number>5.5</number></var><var name='c'><array length='3'>
<string>blue</string><string>orange</string><string>violet</string></array></var>
<var name='d'><string>colors</string></var></struct></data></wddxPacket>

Předcházející | Nahoru | Další
wddx_serialize_value | Domů | wddx_unserialize


xattr Functions

Předcházející VI. Reference funkcí Další

CLXXVIII. xattr Functions

Úvod

The xattr extension allows for the manipulation of extended attributes on a filesystem.

Požadavky

To use xattr, you will need libattr installed. It is available at » http://oss.sgi.com/projects/xfs/.

Poznámka: These functions only work on filesystems that support extended attributes, and have them enabled at mount time. Some common filesystems that support extended attributes are ext2, ext3, reiserfs, jfs, and xfs.

Instalace

xattr is currently available through PECL » http://pecl.php.net/package/xattr.

If » PEAR is available on your *nix-like system you can use the pear installer to install the xattr extension, by the following command: pear -v install xattr.

You can always download the tar.gz package and install xattr by hand:

Příklad 2379. xattr install by hand

gunzip xattr-xxx.tgz
tar -xvf xattr-xxx.tar
cd xattr-xxx
phpize
./configure && make && make install

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

XATTR_ROOT (integer)
Set attribute in root (trusted) namespace. Requires root privileges.
XATTR_DONTFOLLOW (integer)
Do not follow the symbolic link but operate on symbolic link itself.
XATTR_CREATE (integer)
Function will fail if extended attribute already exists.
XATTR_REPLACE (integer)
Function will fail if extended attribute doesn't exist.

Obsah

xattr_get — Get an extended attribute
xattr_list — Get a list of extended attributes
xattr_remove — Remove an extended attribute
xattr_set — Set an extended attribute
xattr_supported — Check if filesystem supports extended attributes
Předcházející | Nahoru | Další
win32_stop_service | Domů | xattr_get


xattr_get

(PECL xattr:0.9-1.0)

xattr_get — Get an extended attribute

Popis

string xattr_get ( string $filename, string $name [, int $flags] )

This function gets the value of an extended attribute of a file.

Rozšířené atributy mají dva různé prostory jmen: uživatelský (user) a superuživatelský (root). Uživatelský je dostupný všem uživatelům, kdežto superuživatelský pouze uživatelům s oprávněním root. xattr pracuje implicitně v uživatelském prostoru, ale lze to změnit parametrem flags.

Seznam parametrů

filename

The file from which we get the attribute.

name

The name of the attribute.

flags

Tabulka 316. Supported xattr flags

XATTR_DONTFOLLOW | Do not follow the symbolic link but operate on symbolic link itself.
XATTR_ROOT | Set attribute in root (trusted) namespace. Requires root privileges.

Návratové hodnoty

Returns a string containing the value or FALSE if the attribute doesn't exist.

Příklady

Příklad 2380. Checks if system administrator has signed the file

<?php
$file = '/usr/local/sbin/some_binary';
$signature = xattr_get($file, 'Root signature', XATTR_ROOT);

/* ... check if $signature is valid ... */

?>

Viz také

xattr_list()
xattr_set()
xattr_remove()

Předcházející | Nahoru | Další
CLXXVIII. xattr Functions | Domů | xattr_list


xattr_list

(PECL xattr:0.9-1.0)

xattr_list — Get a list of extended attributes

Popis

array xattr_list ( string $filename [, int $flags] )

This functions gets a list of names of extended attributes of a file.

Rozšířené atributy mají dva různé prostory jmen: uživatelský (user) a superuživatelský (root). Uživatelský je dostupný všem uživatelům, kdežto superuživatelský pouze uživatelům s oprávněním root. xattr pracuje implicitně v uživatelském prostoru, ale lze to změnit parametrem flags.

Seznam parametrů

filename

The path of the file.

flags

Tabulka 317. Supported xattr flags

XATTR_DONTFOLLOW | Do not follow the symbolic link but operate on symbolic link itself.
XATTR_ROOT | Set attribute in root (trusted) namespace. Requires root privileges.

Návratové hodnoty

This function returns an array with names of extended attributes.

Příklady

Příklad 2381. Prints names of all extended attributes of file

<?php
$file = 'some_file';
$root_attributes = xattr_list($file, XATTR_ROOT);
$user_attributes = xattr_list($file);

echo "Root attributes: \n";
foreach ($root_attributes as $attr_name) {
    printf("%s\n", $attr_name);
}

echo "\n User attributes: \n";
foreach ($attributes as $attr_name) {
    printf("%s\n", $attr_name);
}

?>

Viz také

xattr_get()

Předcházející | Nahoru | Další
xattr_get | Domů | xattr_remove


xattr_remove

(PECL xattr:0.9-1.0)

xattr_remove — Remove an extended attribute

Popis

bool xattr_remove ( string $filename, string $name [, int $flags] )

This function removes an extended attribute of a file.

Rozšířené atributy mají dva různé prostory jmen: uživatelský (user) a superuživatelský (root). Uživatelský je dostupný všem uživatelům, kdežto superuživatelský pouze uživatelům s oprávněním root. xattr pracuje implicitně v uživatelském prostoru, ale lze to změnit parametrem flags.

Seznam parametrů

filename

The file from which we remove the attribute.

name

The name of the attribute to remove.

flags

Tabulka 318. Supported xattr flags

XATTR_DONTFOLLOW | Do not follow the symbolic link but operate on symbolic link itself.
XATTR_ROOT | Set attribute in root (trusted) namespace. Requires root privileges.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 2382. Removes all extended attributes of a file

<?php
$file = 'some_file';
$attributes = xattr_list($file);

foreach ($attributes as $attr_name) {
    xattr_remove($file, $attr_name);
}
?>

Viz také

xattr_list()
xattr_set()
xattr_get()

Předcházející | Nahoru | Další
xattr_list | Domů | xattr_set


xattr_set

(PECL xattr:0.9-1.0)

xattr_set — Set an extended attribute

Popis

bool xattr_set ( string $filename, string $name, string $value [, int $flags] )

This function sets the value of an extended attribute of a file.

Rozšířené atributy mají dva různé prostory jmen: uživatelský (user) a superuživatelský (root). Uživatelský je dostupný všem uživatelům, kdežto superuživatelský pouze uživatelům s oprávněním root. xattr pracuje implicitně v uživatelském prostoru, ale lze to změnit parametrem flags.

Seznam parametrů

filename

The file in which we set the attribute.

name

The name of the extended attribute. This attribute will be created if it doesn't exist or replaced otherwise. You can change this behaviour by using the flags parameter.

value

The value of the attribute.

flags

Tabulka 319. Supported xattr flags

XATTR_CREATE | Function will fail if extended attribute already exists.
XATTR_REPLACE | Function will fail if extended attribute doesn't exist.
XATTR_DONTFOLLOW | Do not follow the symbolic link but operate on symbolic link itself.
XATTR_ROOT | Set attribute in root (trusted) namespace. Requires root privileges.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 2383. Sets extended attributes on .wav file

<?php
$file = 'my_favourite_song.wav';
xattr_set($file, 'Artist', 'Someone');
xattr_set($file, 'My ranking', 'Good');
xattr_set($file, 'Listen count', '34');

/* ... other code ... */

printf("You've played this song %d times", xattr_get($file, 'Listen count'));
?>

Viz také

xattr_get()
xattr_remove()

Předcházející | Nahoru | Další
xattr_remove | Domů | xattr_supported


xattr_supported

(PECL xattr:1.0)

xattr_supported — Check if filesystem supports extended attributes

Popis

bool xattr_supported ( string $filename [, int $flags] )

This functions checks if the filesystem holding the given file supports extended attributes. Read access to the file is required.

Seznam parametrů

filename

The path of the tested file.

flags

Tabulka 320. Supported xattr flags

XATTR_DONTFOLLOW Do not follow the symbolic link but operate on symbolic link itself.

Návratové hodnoty

This function returns TRUE if filesystem supports extended attributes, FALSE if it doesn't and NULL if it can't be determined (for example wrong path or lack of permissions to file).

Příklady

Příklad 2384. xattr_supported() example

The following code checks if we can use extended attributes.

<?php
$file = 'some_file';

if (xattr_supported($file)) {
    /* ... make use of some xattr_* functions ... */
}

?>

Viz také

xattr_get()
xattr_list()

Předcházející | Nahoru | Další
xattr_set | Domů | CLXXIX. xdiff Functions


XML Parser Functions

Předcházející VI. Reference funkcí Další

CLXXX. XML Parser Functions

Úvod

XML (eXtensible Markup Language) is a data format for structured document interchange on the Web. It is a standard defined by The World Wide Web consortium (W3C). Information about XML and related technologies can be found at » http://www.w3.org/XML/.

This PHP extension implements support for James Clark's expat in PHP. This toolkit lets you parse, but not validate, XML documents. It supports three source character encodings also provided by PHP: US-ASCII, ISO-8859-1 and UTF-8. UTF-16 is not supported.

This extension lets you create XML parsers and then define handlers for different XML events. Each XML parser also has a few parameters you can adjust.

Požadavky

This extension uses an expat compat layer by default. It can use also expat, which can be found at » http://www.jclark.com/xml/expat.html. The Makefile that comes with expat does not build a library by default, you can use this make rule for that:

libexpat.a: $(OBJS)
    ar -rc $@ $(OBJS)
    ranlib $@
A source RPM package of expat can be found at » http://sourceforge.net/projects/expat/.

Instalace

These functions are enabled by default, using the bundled expat library. You can disable XML support with --disable-xml. If you compile PHP as a module for Apache 1.3.9 or later, PHP will automatically use the bundled expat library from Apache. In order you don't want to use the bundled expat library configure PHP --with-expat-dir=DIR, where DIR should point to the base installation directory of expat.

Verze PHP pro Windows má vestavěnou podporu pro toto rozšíření. K použití těchto funkcí není třeba načítat žádná další rozšíření.

Konfigurace běhu

Toto rozšíření nemá definováno žádné konfigurační direktivy.

Typy prostředků

xml

The xml resource as returned by xml_parser_create() and xml_parser_create_ns() references an xml parser instance to be used with the functions provided by this extension.

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

XML_ERROR_NONE (integer)
XML_ERROR_NO_MEMORY (integer)
XML_ERROR_SYNTAX (integer)
XML_ERROR_NO_ELEMENTS (integer)
XML_ERROR_INVALID_TOKEN (integer)
XML_ERROR_UNCLOSED_TOKEN (integer)
XML_ERROR_PARTIAL_CHAR (integer)
XML_ERROR_TAG_MISMATCH (integer)
XML_ERROR_DUPLICATE_ATTRIBUTE (integer)
XML_ERROR_JUNK_AFTER_DOC_ELEMENT (integer)
XML_ERROR_PARAM_ENTITY_REF (integer)
XML_ERROR_UNDEFINED_ENTITY (integer)
XML_ERROR_RECURSIVE_ENTITY_REF (integer)
XML_ERROR_ASYNC_ENTITY (integer)
XML_ERROR_BAD_CHAR_REF (integer)
XML_ERROR_BINARY_ENTITY_REF (integer)
XML_ERROR_ATTRIBUTE_EXTERNAL_ENTITY_REF (integer)
XML_ERROR_MISPLACED_XML_PI (integer)
XML_ERROR_UNKNOWN_ENCODING (integer)
XML_ERROR_INCORRECT_ENCODING (integer)
XML_ERROR_UNCLOSED_CDATA_SECTION (integer)
XML_ERROR_EXTERNAL_ENTITY_HANDLING (integer)
XML_OPTION_CASE_FOLDING (integer)
XML_OPTION_TARGET_ENCODING (integer)
XML_OPTION_SKIP_TAGSTART (integer)
XML_OPTION_SKIP_WHITE (integer)

Event Handlers

The XML event handlers defined are:

Tabulka 321. Supported XML handlers

PHP function to set handler | Event description
xml_set_element_handler() | Element events are issued whenever the XML parser encounters start or end tags. There are separate handlers for start tags and end tags.
xml_set_character_data_handler() | Character data is roughly all the non-markup contents of XML documents, including whitespace between tags. Note that the XML parser does not add or remove any whitespace, it is up to the application (you) to decide whether whitespace is significant.
xml_set_processing_instruction_handler() | PHP programmers should be familiar with processing instructions (PIs) already. <?php ?> is a processing instruction, where php is called the "PI target". The handling of these are application-specific, except that all PI targets starting with "XML" are reserved.
xml_set_default_handler() | What goes not to another handler goes to the default handler. You will get things like the XML and document type declarations in the default handler.
xml_set_unparsed_entity_decl_handler() | This handler will be called for declaration of an unparsed (NDATA) entity.
xml_set_notation_decl_handler() | This handler is called for declaration of a notation.
xml_set_external_entity_ref_handler() | This handler is called when the XML parser finds a reference to an external parsed general entity. This can be a reference to a file or URL, for example. See the external entity example for a demonstration.

Case Folding

The element handler functions may get their element names case-folded. Case-folding is defined by the XML standard as "a process applied to a sequence of characters, in which those identified as non-uppercase are replaced by their uppercase equivalents". In other words, when it comes to XML, case-folding simply means uppercasing.

By default, all the element names that are passed to the handler functions are case-folded. This behaviour can be queried and controlled per XML parser with the xml_parser_get_option() and xml_parser_set_option() functions, respectively.

Error Codes

The following constants are defined for XML error codes (as returned by xml_parse()):
XML_ERROR_NONE
XML_ERROR_NO_MEMORY
XML_ERROR_SYNTAX
XML_ERROR_NO_ELEMENTS
XML_ERROR_INVALID_TOKEN
XML_ERROR_UNCLOSED_TOKEN
XML_ERROR_PARTIAL_CHAR
XML_ERROR_TAG_MISMATCH
XML_ERROR_DUPLICATE_ATTRIBUTE
XML_ERROR_JUNK_AFTER_DOC_ELEMENT
XML_ERROR_PARAM_ENTITY_REF
XML_ERROR_UNDEFINED_ENTITY
XML_ERROR_RECURSIVE_ENTITY_REF
XML_ERROR_ASYNC_ENTITY
XML_ERROR_BAD_CHAR_REF
XML_ERROR_BINARY_ENTITY_REF
XML_ERROR_ATTRIBUTE_EXTERNAL_ENTITY_REF
XML_ERROR_MISPLACED_XML_PI
XML_ERROR_UNKNOWN_ENCODING
XML_ERROR_INCORRECT_ENCODING
XML_ERROR_UNCLOSED_CDATA_SECTION
XML_ERROR_EXTERNAL_ENTITY_HANDLING

Character Encoding

PHP's XML extension supports the » Unicode character set through different character encodings. There are two types of character encodings, source encoding and target encoding. PHP's internal representation of the document is always encoded with UTF-8.

Source encoding is done when an XML document is parsed. Upon creating an XML parser, a source encoding can be specified (this encoding can not be changed later in the XML parser's lifetime). The supported source encodings are ISO-8859-1, US-ASCII and UTF-8. The former two are single-byte encodings, which means that each character is represented by a single byte. UTF-8 can encode characters composed by a variable number of bits (up to 21) in one to four bytes. The default source encoding used by PHP is ISO-8859-1.

Target encoding is done when PHP passes data to XML handler functions. When an XML parser is created, the target encoding is set to the same as the source encoding, but this may be changed at any point. The target encoding will affect character data as well as tag names and processing instruction targets.

If the XML parser encounters characters outside the range that its source encoding is capable of representing, it will return an error.

If PHP encounters characters in the parsed XML document that can not be represented in the chosen target encoding, the problem characters will be "demoted". Currently, this means that such characters are replaced by a question mark.

Příklady

Here are some example PHP scripts parsing XML documents.

XML Element Structure Example

This first example displays the structure of the start elements in a document with indentation.

Příklad 2394. Show XML Element Structure

<?php
$file = "data.xml";
$depth = array();

function startElement($parser, $name, $attrs)
{
    global $depth;
    for ($i = 0; $i < $depth[$parser]; $i++) {
        echo "  ";
    }
    echo "$name\n";
    $depth[$parser]++;
}

function endElement($parser, $name)
{
    global $depth;
    $depth[$parser]--;
}

$xml_parser = xml_parser_create();
xml_set_element_handler($xml_parser, "startElement", "endElement");
if (!($fp = fopen($file, "r"))) {
    die("could not open XML input");
}

while ($data = fread($fp, 4096)) {
    if (!xml_parse($xml_parser, $data, feof($fp))) {
        die(sprintf("XML error: %s at line %d",
                    xml_error_string(xml_get_error_code($xml_parser)),
                    xml_get_current_line_number($xml_parser)));
    }
}
xml_parser_free($xml_parser);
?>

XML Tag Mapping Example

Příklad 2395. Map XML to HTML

This example maps tags in an XML document directly to HTML tags. Elements not found in the "map array" are ignored. Of course, this example will only work with a specific XML document type.

<?php
$file = "data.xml";
$map_array = array(
    "BOLD"     => "B",
    "EMPHASIS" => "I",
    "LITERAL"  => "TT"
);

function startElement($parser, $name, $attrs)
{
    global $map_array;
    if (isset($map_array[$name])) {
        echo "<$map_array[$name]>";
    }
}

function endElement($parser, $name)
{
    global $map_array;
    if (isset($map_array[$name])) {
        echo "</$map_array[$name]>";
    }
}

function characterData($parser, $data)
{
    echo $data;
}

$xml_parser = xml_parser_create();
// use case-folding so we are sure to find the tag in $map_array
xml_parser_set_option($xml_parser, XML_OPTION_CASE_FOLDING, true);
xml_set_element_handler($xml_parser, "startElement", "endElement");
xml_set_character_data_handler($xml_parser, "characterData");
if (!($fp = fopen($file, "r"))) {
    die("could not open XML input");
}

while ($data = fread($fp, 4096)) {
    if (!xml_parse($xml_parser, $data, feof($fp))) {
        die(sprintf("XML error: %s at line %d",
                    xml_error_string(xml_get_error_code($xml_parser)),
                    xml_get_current_line_number($xml_parser)));
    }
}
xml_parser_free($xml_parser);
?>

XML External Entity Example

This example highlights XML code. It illustrates how to use an external entity reference handler to include and parse other documents, as well as how PIs can be processed, and a way of determining "trust" for PIs containing code.

XML documents that can be used for this example are found below the example (xmltest.xml and xmltest2.xml.)

Příklad 2396. External Entity Example

<?php
$file = "xmltest.xml";

function trustedFile($file)
{
    // only trust local files owned by ourselves
    if (!eregi("^([a-z]+)://", $file)
        && fileowner($file) == getmyuid()) {
            return true;
    }
    return false;
}

function startElement($parser, $name, $attribs)
{
    echo "&lt;<font color=\"#0000cc\">$name</font>";
    if (count($attribs)) {
        foreach ($attribs as $k => $v) {
            echo " <font color=\"#009900\">$k</font>=\"<font
                   color=\"#990000\">$v</font>\"";
        }
    }
    echo "&gt;";
}

function endElement($parser, $name)
{
    echo "&lt;/<font color=\"#0000cc\">$name</font>&gt;";
}

function characterData($parser, $data)
{
    echo "<b>$data</b>";
}

function PIHandler($parser, $target, $data)
{
    switch (strtolower($target)) {
        case "php":
            global $parser_file;
            // If the parsed document is "trusted", we say it is safe
            // to execute PHP code inside it.  If not, display the code
            // instead.
            if (trustedFile($parser_file[$parser])) {
                eval($data);
            } else {
                printf("Untrusted PHP code: <i>%s</i>",
                        htmlspecialchars($data));
            }
            break;
    }
}

function defaultHandler($parser, $data)
{
    if (substr($data, 0, 1) == "&" && substr($data, -1, 1) == ";") {
        printf('<font color="#aa00aa">%s</font>',
                htmlspecialchars($data));
    } else {
        printf('<font size="-1">%s</font>',
                htmlspecialchars($data));
    }
}

function externalEntityRefHandler($parser, $openEntityNames, $base, $systemId,
                                  $publicId) {
    if ($systemId) {
        if (!list($parser, $fp) = new_xml_parser($systemId)) {
            printf("Could not open entity %s at %s\n", $openEntityNames,
                   $systemId);
            return false;
        }
        while ($data = fread($fp, 4096)) {
            if (!xml_parse($parser, $data, feof($fp))) {
                printf("XML error: %s at line %d while parsing entity %s\n",
                       xml_error_string(xml_get_error_code($parser)),
                       xml_get_current_line_number($parser), $openEntityNames);
                xml_parser_free($parser);
                return false;
            }
        }
        xml_parser_free($parser);
        return true;
    }
    return false;
}

function new_xml_parser($file)
{
    global $parser_file;

    $xml_parser = xml_parser_create();
    xml_parser_set_option($xml_parser, XML_OPTION_CASE_FOLDING, 1);
    xml_set_element_handler($xml_parser, "startElement", "endElement");
    xml_set_character_data_handler($xml_parser, "characterData");
    xml_set_processing_instruction_handler($xml_parser, "PIHandler");
    xml_set_default_handler($xml_parser, "defaultHandler");
    xml_set_external_entity_ref_handler($xml_parser, "externalEntityRefHandler");

    if (!($fp = @fopen($file, "r"))) {
        return false;
    }
    if (!is_array($parser_file)) {
        settype($parser_file, "array");
    }
    $parser_file[$xml_parser] = $file;
    return array($xml_parser, $fp);
}

if (!(list($xml_parser, $fp) = new_xml_parser($file))) {
    die("could not open XML input");
}

echo "<pre>";
while ($data = fread($fp, 4096)) {
    if (!xml_parse($xml_parser, $data, feof($fp))) {
        die(sprintf("XML error: %s at line %d\n",
                    xml_error_string(xml_get_error_code($xml_parser)),
                    xml_get_current_line_number($xml_parser)));
    }
}
echo "</pre>";
echo "parse complete\n";
xml_parser_free($xml_parser);

?>

Příklad 2397. xmltest.xml

<?xml version='1.0' ?>
<!DOCTYPE chapter SYSTEM "/just/a/test.dtd" [
<!ENTITY plainEntity "FOO entity">
<!ENTITY systemEntity SYSTEM "xmltest2.xml">
]>
<chapter>
<TITLE>Title &plainEntity;</TITLE>
<para>
<informaltable>
<tgroup cols="3">
<tbody>
<row><entry>a1</entry><entry morerows="1">b1</entry><entry>c1</entry></row>
<row><entry>a2</entry><entry>c2</entry></row>
<row><entry>a3</entry><entry>b3</entry><entry>c3</entry></row>
</tbody>
</tgroup>
</informaltable>
</para>
&systemEntity;
<section id="about">
<title>About this Document</title>
<para>
<!-- this is a comment -->
<?php echo 'Hi! This is PHP version ' . phpversion(); ?>
</para>
</section>
</chapter>

This file is included from xmltest.xml:

Příklad 2398. xmltest2.xml

<?xml version="1.0" ?>
<!DOCTYPE foo [
<!ENTITY testEnt "test entity">
]>
<foo>
<element attrib="value"/>
&testEnt;
<?php echo "This is some more PHP code being executed."; ?>
</foo>

Obsah

utf8_decode — Converts a string with ISO-8859-1 characters encoded with UTF-8 to single-byte ISO-8859-1
utf8_encode — Encodes an ISO-8859-1 string to UTF-8
xml_error_string — Get XML parser error string
xml_get_current_byte_index — Get current byte index for an XML parser
xml_get_current_column_number — Get current column number for an XML parser
xml_get_current_line_number — Get current line number for an XML parser
xml_get_error_code — Get XML parser error code
xml_parse_into_struct — Parse XML data into an array structure
xml_parse — Start parsing an XML document
xml_parser_create_ns — Create an XML parser with namespace support
xml_parser_create — Create an XML parser
xml_parser_free — Free an XML parser
xml_parser_get_option — Get options from an XML parser
xml_parser_set_option — Set options in an XML parser
xml_set_character_data_handler — Set up character data handler
xml_set_default_handler — Set up default handler
xml_set_element_handler — Set up start and end element handlers
xml_set_end_namespace_decl_handler — Set up end namespace declaration handler
xml_set_external_entity_ref_handler — Set up external entity reference handler
xml_set_notation_decl_handler — Set up notation declaration handler
xml_set_object — Use XML Parser within an object
xml_set_processing_instruction_handler — Set up processing instruction (PI) handler
xml_set_start_namespace_decl_handler — Set up start namespace declaration handler
xml_set_unparsed_entity_decl_handler — Set up unparsed entity declaration handler
Předcházející | Nahoru | Další
xdiff_string_patch | Domů | utf8_decode


utf8_decode

(PHP 4, PHP 5)

utf8_decode — Converts a string with ISO-8859-1 characters encoded with UTF-8 to single-byte ISO-8859-1

Popis

string utf8_decode ( string $data )

This function decodes data, assumed to be UTF-8 encoded, to ISO-8859-1.

Seznam parametrů

data

An UTF-8 encoded string.

Návratové hodnoty

Returns the ISO-8859-1 translation of data.

Viz také

utf8_encode() for an explanation of UTF-8 encoding

Předcházející | Nahoru | Další
CLXXX. XML Parser Functions | Domů | utf8_encode


utf8_encode

(PHP 4, PHP 5)

utf8_encode — Encodes an ISO-8859-1 string to UTF-8

Popis

string utf8_encode ( string $data )

This function encodes the string data to UTF-8, and returns the encoded version. UTF-8 is a standard mechanism used by Unicode for encoding wide character values into a byte stream. UTF-8 is transparent to plain ASCII characters, is self-synchronized (meaning it is possible for a program to figure out where in the bytestream characters start) and can be used with normal string comparison functions for sorting and such. PHP encodes UTF-8 characters in up to four bytes, like this:

Tabulka 322. UTF-8 encoding

bytes | bits | representation
1 | 7 | 0bbbbbbb
2 | 11 | 110bbbbb 10bbbbbb
3 | 16 | 1110bbbb 10bbbbbb 10bbbbbb
4 | 21 | 11110bbb 10bbbbbb 10bbbbbb 10bbbbbb

Each b represents a bit that can be used to store character data.

Seznam parametrů

data

An ISO-8859-1 string.

Návratové hodnoty

Returns the UTF-8 translation of data.

Předcházející | Nahoru | Další
utf8_decode | Domů | xml_error_string


xml_error_string

(PHP 4, PHP 5)

xml_error_string — Get XML parser error string

Popis

string xml_error_string ( int $code )

Gets the XML parser error string associated with the given code.

Seznam parametrů

code

An error code from xml_get_error_code().

Návratové hodnoty

Returns a string with a textual description of the error code, or FALSE if no description was found.

Viz také

xml_get_error_code()

Předcházející | Nahoru | Další
utf8_encode | Domů | xml_get_current_byte_index


xml_get_current_byte_index

(PHP 4, PHP 5)

xml_get_current_byte_index — Get current byte index for an XML parser

Popis

int xml_get_current_byte_index ( resource $parser )

Gets the current byte index of the given XML parser.

Seznam parametrů

parser

A reference to the XML parser to get byte index from.

Návratové hodnoty

This function returns FALSE if parser does not refer to a valid parser, or else it returns which byte index the parser is currently at in its data buffer (starting at 0).

Poznámky

Varování

This function returns byte index according to UTF-8 encoded text disregarding if input is in another encoding.

Viz také

xml_get_current_column_index()
xml_get_current_line_index()

Předcházející | Nahoru | Další
xml_error_string | Domů | xml_get_current_column_number


xml_get_current_column_number

(PHP 4, PHP 5)

xml_get_current_column_number — Get current column number for an XML parser

Popis

int xml_get_current_column_number ( resource $parser )

Gets the current column number of the given XML parser.

Seznam parametrů

parser

A reference to the XML parser to get column number from.

Návratové hodnoty

This function returns FALSE if parser does not refer to a valid parser, or else it returns which column on the current line (as given by xml_get_current_line_number()) the parser is currently at.

Viz také

xml_get_current_byte_index()
xml_get_current_line_index()

Předcházející | Nahoru | Další
xml_get_current_byte_index | Domů | xml_get_current_line_number


xml_get_current_line_number

(PHP 4, PHP 5)

xml_get_current_line_number — Get current line number for an XML parser

Popis

int xml_get_current_line_number ( resource $parser )

Gets the current line number for the given XML parser.

Seznam parametrů

parser

A reference to the XML parser to get line number from.

Návratové hodnoty

This function returns FALSE if parser does not refer to a valid parser, or else it returns which line the parser is currently at in its data buffer.

Viz také

xml_get_current_column_index()
xml_get_current_byte_index()

Předcházející | Nahoru | Další
xml_get_current_column_number | Domů | xml_get_error_code


xml_get_error_code

(PHP 4, PHP 5)

xml_get_error_code — Get XML parser error code

Popis

int xml_get_error_code ( resource $parser )

Gets the XML parser error code.

Seznam parametrů

parser

A reference to the XML parser to get error code from.

Návratové hodnoty

This function returns FALSE if parser does not refer to a valid parser, or else it returns one of the error codes listed in the error codes section.

Viz také

xml_error_string()

Předcházející | Nahoru | Další
xml_get_current_line_number | Domů | xml_parse_into_struct


xml_parse_into_struct

(PHP 4, PHP 5)

xml_parse_into_struct — Parse XML data into an array structure

Popis

int xml_parse_into_struct ( resource $parser, string $data, array &$values [, array &$index] )

This function parses an XML file into 2 parallel array structures, one (index) containing pointers to the location of the appropriate values in the values array. These last two parameters must be passed by reference.

Seznam parametrů

parser

data

values

index

Návratové hodnoty

xml_parse_into_struct() returns 0 for failure and 1 for success. This is not the same as FALSE and TRUE, be careful with operators such as ===.

Příklady

Below is an example that illustrates the internal structure of the arrays being generated by the function. We use a simple note tag embedded inside a para tag, and then we parse this and print out the structures generated:

Příklad 2399. xml_parse_into_struct() example

<?php
$simple = "<para><note>simple note</note></para>";
$p = xml_parser_create();
xml_parse_into_struct($p, $simple, $vals, $index);
xml_parser_free($p);
echo "Index array\n";
print_r($index);
echo "\nVals array\n";
print_r($vals);
?>

When we run that code, the output will be:

Index array
Array
(
    [PARA] => Array
        (
            [0] => 0
            [1] => 2
        )

    [NOTE] => Array
        (
            [0] => 1
        )

)

Vals array
Array
(
    [0] => Array
        (
            [tag] => PARA
            [type] => open
            [level] => 1
        )

    [1] => Array
        (
            [tag] => NOTE
            [type] => complete
            [level] => 2
            [value] => simple note
        )

    [2] => Array
        (
            [tag] => PARA
            [type] => close
            [level] => 1
        )

)

Event-driven parsing (based on the expat library) can get complicated when you have an XML document that is complex. This function does not produce a DOM style object, but it generates structures amenable of being transversed in a tree fashion. Thus, we can create objects representing the data in the XML file easily. Let's consider the following XML file representing a small database of aminoacids information:

Příklad 2400. moldb.xml - small database of molecular information

<?xml version="1.0" ?>
<moldb>

<molecule>
<name>Alanine</name>
<symbol>ala</symbol>
<code>A</code>
<type>hydrophobic</type>
</molecule>

<molecule>
<name>Lysine</name>
<symbol>lys</symbol>
<code>K</code>
<type>charged</type>
</molecule>

</moldb>

And some code to parse the document and generate the appropriate objects:

Příklad 2401. parsemoldb.php - parses moldb.xml into an array of molecular objects

<?php

class AminoAcid {
    var $name;  // aa name
    var $symbol;    // three letter symbol
    var $code;  // one letter code
    var $type;  // hydrophobic, charged or neutral

    function AminoAcid ($aa)
    {
        foreach ($aa as $k=>$v)
            $this->$k = $aa[$k];
    }
}

function readDatabase($filename)
{
    // read the XML database of aminoacids
    $data = implode("", file($filename));
    $parser = xml_parser_create();
    xml_parser_set_option($parser, XML_OPTION_CASE_FOLDING, 0);
    xml_parser_set_option($parser, XML_OPTION_SKIP_WHITE, 1);
    xml_parse_into_struct($parser, $data, $values, $tags);
    xml_parser_free($parser);

    // loop through the structures
    foreach ($tags as $key=>$val) {
        if ($key == "molecule") {
            $molranges = $val;
            // each contiguous pair of array entries are the
            // lower and upper range for each molecule definition
            for ($i=0; $i < count($molranges); $i+=2) {
                $offset = $molranges[$i] + 1;
                $len = $molranges[$i + 1] - $offset;
                $tdb[] = parseMol(array_slice($values, $offset, $len));
            }
        } else {
            continue;
        }
    }
    return $tdb;
}

function parseMol($mvalues)
{
    for ($i=0; $i < count($mvalues); $i++) {
        $mol[$mvalues[$i]["tag"]] = $mvalues[$i]["value"];
    }
    return new AminoAcid($mol);
}

$db = readDatabase("moldb.xml");
echo "** Database of AminoAcid objects:\n";
print_r($db);

?>

After executing parsemoldb.php, the variable $db contains an array of AminoAcid objects, and the output of the script confirms that:

** Database of AminoAcid objects:
Array
(
    [0] => aminoacid Object
        (
            [name] => Alanine
            [symbol] => ala
            [code] => A
            [type] => hydrophobic
        )

    [1] => aminoacid Object
        (
            [name] => Lysine
            [symbol] => lys
            [code] => K
            [type] => charged
        )

)

Předcházející | Nahoru | Další
xml_get_error_code | Domů | xml_parse


xml_parse

(PHP 4, PHP 5)

xml_parse — Start parsing an XML document

Popis

int xml_parse ( resource $parser, string $data [, bool $is_final] )

xml_parse() parses an XML document. The handlers for the configured events are called as many times as necessary.

Seznam parametrů

parser

A reference to the XML parser to use.

data

Chunk of data to parse. A document may be parsed piece-wise by calling xml_parse() several times with new data, as long as the is_final parameter is set and TRUE when the last data is parsed.

is_final

If set and TRUE, data is the last piece of data sent in this parse.

Návratové hodnoty

Returns 1 on success or 0 on failure.

For unsuccessful parses, error information can be retrieved with
xml_get_error_code(),
xml_error_string(),
xml_get_current_line_number(),
xml_get_current_column_number() and
xml_get_current_byte_index().

Poznámka: Entity errors are reported at the end of the data thus only if is_final is set and TRUE.

Předcházející | Nahoru | Další
xml_parse_into_struct | Domů | xml_parser_create_ns


xml_parser_create_ns

(PHP 4 >= 4.0.5, PHP 5)

xml_parser_create_ns — Create an XML parser with namespace support

Popis

resource xml_parser_create_ns ( [string $encoding [, string $separator]] )

xml_parser_create_ns() creates a new XML parser with XML namespace support and returns a resource handle referencing it to be used by the other XML functions.

Seznam parametrů

encoding

The optional encoding specifies the character encoding for the input/output in PHP 4. Starting from PHP 5, the input encoding is automatically detected, so that the encoding parameter specifies only the output encoding. In PHP 4, the default output encoding is the same as the input charset. In PHP 5.0.0 and 5.0.1, the default output charset is ISO-8859-1, while in PHP 5.0.2 and upper is UTF-8. The supported encodings are ISO-8859-1, UTF-8 and US-ASCII.

separator

With a namespace aware parser tag parameters passed to the various handler functions will consist of namespace and tag name separated by the string specified in seperator or ':' by default.

Návratové hodnoty

Returns a resource handle for the new XML parser.

Viz také

xml_parser_create()
xml_parser_free()

Předcházející | Nahoru | Další
xml_parse | Domů | xml_parser_create


xml_parser_create

(PHP 4, PHP 5)

xml_parser_create — Create an XML parser

Popis

resource xml_parser_create ( [string $encoding] )

xml_parser_create() creates a new XML parser and returns a resource handle referencing it to be used by the other XML functions.

Seznam parametrů

encoding

The optional encoding specifies the character encoding for the input/output in PHP 4. Starting from PHP 5, the input encoding is automatically detected, so that the encoding parameter specifies only the output encoding. In PHP 4, the default output encoding is the same as the input charset. If empty string is passed, the parser attempts to identify which encoding the document is encoded in by looking at the heading 3 or 4 bytes. In PHP 5.0.0 and 5.0.1, the default output charset is ISO-8859-1, while in PHP 5.0.2 and upper is UTF-8. The supported encodings are ISO-8859-1, UTF-8 and US-ASCII.

Návratové hodnoty

Returns a resource handle for the new XML parser.

Viz také

xml_parser_create_ns()
xml_parser_free()

Předcházející | Nahoru | Další
xml_parser_create_ns | Domů | xml_parser_free


xml_parser_free

(PHP 4, PHP 5)

xml_parser_free — Free an XML parser

Popis

bool xml_parser_free ( resource $parser )

Frees the given XML parser.

Seznam parametrů

parser
A reference to the XML parser to free.

Návratové hodnoty

This function returns FALSE if parser does not refer to a valid parser, or else it frees the parser and returns TRUE.

Předcházející | Nahoru | Další
xml_parser_create | Domů | xml_parser_get_option


xml_parser_get_option

(PHP 4, PHP 5)

xml_parser_get_option — Get options from an XML parser

Popis

mixed xml_parser_get_option ( resource $parser, int $option )

Gets an option value from an XML parser.

Seznam parametrů

parser
A reference to the XML parser to get an option from.
option
Which option to fetch. XML_OPTION_CASE_FOLDING and XML_OPTION_TARGET_ENCODING are available. See xml_parser_set_option() for their description.

Návratové hodnoty

This function returns FALSE if parser does not refer to a valid parser or if option isn't valid (generates also a E_WARNING). Else the option's value is returned.

Předcházející | Nahoru | Další
xml_parser_free | Domů | xml_parser_set_option


xml_parser_set_option

(PHP 4, PHP 5)

xml_parser_set_option — Set options in an XML parser

Popis

bool xml_parser_set_option ( resource $parser, int $option, mixed $value )

Sets an option in an XML parser.

Seznam parametrů

parser

A reference to the XML parser to set an option in.

option

Which option to set. See below.

The following options are available:

Tabulka 323. XML parser options

Option constant | Data type | Description
XML_OPTION_CASE_FOLDING | integer | Controls whether case-folding is enabled for this XML parser. Enabled by default.
XML_OPTION_SKIP_TAGSTART | integer | Specify how many characters should be skipped in the beginning of a tag name.
XML_OPTION_SKIP_WHITE | integer | Whether to skip values consisting of whitespace characters.
XML_OPTION_TARGET_ENCODING | string | Sets which target encoding to use in this XML parser.By default, it is set to the same as the source encoding used by xml_parser_create(). Supported target encodings are ISO-8859-1, US-ASCII and UTF-8.

value

The option's new value.

Návratové hodnoty

This function returns FALSE if parser does not refer to a valid parser, or if the option could not be set. Else the option is set and TRUE is returned.

Předcházející | Nahoru | Další
xml_parser_get_option | Domů | xml_set_character_data_handler


xml_set_character_data_handler

(PHP 4, PHP 5)

xml_set_character_data_handler — Set up character data handler

Popis

bool xml_set_character_data_handler ( resource $parser, callback $handler )

Sets the character data handler function for the XML parser parser.

Seznam parametrů

parser

handler

handler is a string containing the name of a function that must exist when xml_parse() is called for parser.

The function named by handler must accept two parameters: handler ( resource $parser, string $data )

parser
The first parameter, parser, is a reference to the XML parser calling the handler.
data
The second parameter, data, contains the character data as a string.

Character data handler is called for every piece of a text in the XML document. It can be called multiple times inside each fragment (e.g. for non-ASCII strings).

If a handler function is set to an empty string, or FALSE, the handler in question is disabled.

Poznámka: Místo názvu funkce může být použito pole obsahující odkaz na objekt a název metody.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
xml_parser_set_option | Domů | xml_set_default_handler


xml_set_default_handler

(PHP 4, PHP 5)

xml_set_default_handler — Set up default handler

Popis

bool xml_set_default_handler ( resource $parser, callback $handler )

Sets the default handler function for the XML parser parser.

Seznam parametrů

parser

handler

handler is a string containing the name of a function that must exist when xml_parse() is called for parser.

The function named by handler must accept two parameters: handler ( resource $parser, string $data )

parser
The first parameter, parser, is a reference to the XML parser calling the handler.
data
The second parameter, data, contains the character data.This may be the XML declaration, document type declaration, entities or other data for which no other handler exists.

If a handler function is set to an empty string, or FALSE, the handler in question is disabled.

Poznámka: Místo názvu funkce může být použito pole obsahující odkaz na objekt a název metody.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
xml_set_character_data_handler | Domů | xml_set_element_handler


xml_set_element_handler

(PHP 4, PHP 5)

xml_set_element_handler — Set up start and end element handlers

Popis

bool xml_set_element_handler ( resource $parser, callback $start_element_handler, callback $end_element_handler )

Sets the element handler functions for the XML parser. start_element_handler and end_element_handler are strings containing the names of functions that must exist when xml_parse() is called for parser.

Seznam parametrů

parser

start_element_handler

The function named by start_element_handler must accept three parameters: start_element_handler ( resource $parser, string $name, array $attribs )

parser
The first parameter, parser, is a reference to the XML parser calling the handler.
name
The second parameter, name, contains the name of the element for which this handler is called.If case-folding is in effect for this parser, the element name will be in uppercase letters.
attribs

The third parameter, attribs, contains an associative array with the element's attributes (if any).The keys of this array are the attribute names, the values are the attribute values.Attribute names are case-folded on the same criteria as element names.Attribute values are not case-folded.

The original order of the attributes can be retrieved by walking through attribs the normal way, using each().The first key in the array was the first attribute, and so on.

Poznámka: Místo názvu funkce může být použito pole obsahující odkaz na objekt a název metody.

end_element_handler

The function named by end_element_handler must accept two parameters: end_element_handler ( resource $parser, string $name )

parser
The first parameter, parser, is a reference to the XML parser calling the handler.
name
The second parameter, name, contains the name of the element for which this handler is called.If case-folding is in effect for this parser, the element name will be in uppercase letters.

If a handler function is set to an empty string, or FALSE, the handler in question is disabled.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
xml_set_default_handler | Domů | xml_set_end_namespace_decl_handler


xml_set_end_namespace_decl_handler

(PHP 4 >= 4.0.5, PHP 5)

xml_set_end_namespace_decl_handler — Set up end namespace declaration handler

Popis

bool xml_set_end_namespace_decl_handler ( resource $parser, callback $handler )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Poznámka: Místo názvu funkce může být použito pole obsahující odkaz na objekt a název metody.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
xml_set_element_handler | Domů | xml_set_external_entity_ref_handler


xml_set_external_entity_ref_handler

(PHP 4, PHP 5)

xml_set_external_entity_ref_handler — Set up external entity reference handler

Popis

bool xml_set_external_entity_ref_handler ( resource $parser, callback $handler )

Sets the external entity reference handler function for the XML parser parser.

Seznam parametrů

parser

handler

handler is a string containing the name of a function that must exist when xml_parse() is called for parser.

The function named by handler must accept five parameters, and should return an integer value.If the value returned from the handler is FALSE (which it will be if no value is returned), the XML parser will stop parsing and xml_get_error_code() will return XML_ERROR_EXTERNAL_ENTITY_HANDLING. handler ( resource $parser, string $open_entity_names, string $base, string $system_id, string $public_id )

parser
The first parameter, parser, is a reference to the XML parser calling the handler.
open_entity_names
The second parameter, open_entity_names, is a space-separated list of the names of the entities that are open for the parse of this entity (including the name of the referenced entity).
base
This is the base for resolving the system identifier (system_id) of the external entity.Currently this parameter will always be set to an empty string.
system_id
The fourth parameter, system_id, is the system identifier as specified in the entity declaration.
public_id
The fifth parameter, public_id, is the public identifier as specified in the entity declaration, or an empty string if none was specified; the whitespace in the public identifier will have been normalized as required by the XML spec.

If a handler function is set to an empty string, or FALSE, the handler in question is disabled.

Poznámka: Místo názvu funkce může být použito pole obsahující odkaz na objekt a název metody.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
xml_set_end_namespace_decl_handler | Domů | xml_set_notation_decl_handler


xml_set_notation_decl_handler

(PHP 4, PHP 5)

xml_set_notation_decl_handler — Set up notation declaration handler

Popis

bool xml_set_notation_decl_handler ( resource $parser, callback $handler )

Sets the notation declaration handler function for the XML parser parser.

A notation declaration is part of the document's DTD and has the following format:

<!NOTATION <parameter>name</parameter>
{ <parameter>systemId</parameter> | <parameter>publicId</parameter>?>
See » section 4.7 of the XML 1.0 spec for the definition of notation declarations.

Seznam parametrů

parser

handler

handler is a string containing the name of a function that must exist when xml_parse() is called for parser.

The function named by handler must accept five parameters: handler ( resource $parser, string $notation_name, string $base, string $system_id, string $public_id )

parser
The first parameter, parser, is a reference to the XML parser calling the handler.
notation_name
This is the notation's name, as per the notation format described above.
base
This is the base for resolving the system identifier (system_id) of the notation declaration. Currently this parameter will always be set to an empty string.
system_id
System identifier of the external notation declaration.
public_id
Public identifier of the external notation declaration.

If a handler function is set to an empty string, or FALSE, the handler in question is disabled.

Poznámka: Místo názvu funkce může být použito pole obsahující odkaz na objekt a název metody.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
xml_set_external_entity_ref_handler | Domů | xml_set_object


xml_set_object

(PHP 4, PHP 5)

xml_set_object — Use XML Parser within an object

Popis

bool xml_set_object ( resource $parser, object &$object )

This function allows to use parser inside object. All callback functions could be set with xml_set_element_handler() etc and assumed to be methods of object.

Seznam parametrů

parser

object

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 2402. xml_set_object() example

<?php
class xml  {
    var $parser;

    function xml()
    {
        $this->parser = xml_parser_create();

        xml_set_object($this->parser, $this);
        xml_set_element_handler($this->parser, "tag_open", "tag_close");
        xml_set_character_data_handler($this->parser, "cdata");
    }

    function parse($data)
    {
        xml_parse($this->parser, $data);
    }

    function tag_open($parser, $tag, $attributes)
    {
        var_dump($parser, $tag, $attributes);
    }

    function cdata($parser, $cdata)
    {
        var_dump($parser, $cdata);
    }

    function tag_close($parser, $tag)
    {
        var_dump($parser, $tag);
    }

} // end of class xml

$xml_parser = new xml();
$xml_parser->parse("<A ID='hallo'>PHP</A>");
?>

Předcházející | Nahoru | Další
xml_set_notation_decl_handler | Domů | xml_set_processing_instruction_handler


xml_set_processing_instruction_handler

(PHP 4, PHP 5)

xml_set_processing_instruction_handler — Set up processing instruction (PI) handler

Popis

bool xml_set_processing_instruction_handler ( resource $parser, callback $handler )

Sets the processing instruction (PI) handler function for the XML parser parser.

A processing instruction has the following format:

<?target
     data?>
You can put PHP code into such a tag, but be aware of one limitation: in an XML PI, the PI end tag (?>) can not be quoted, so this character sequence should not appear in the PHP code you embed with PIs in XML documents.If it does, the rest of the PHP code, as well as the "real" PI end tag, will be treated as character data.

Seznam parametrů

parser

handler

handler is a string containing the name of a function that must exist when xml_parse() is called for parser.

The function named by handler must accept three parameters: handler ( resource $parser, string $target, string $data )

parser
The first parameter, parser, is a reference to the XML parser calling the handler.
target
The second parameter, target, contains the PI target.
data
The third parameter, data, contains the PI data.

If a handler function is set to an empty string, or FALSE, the handler in question is disabled.

Poznámka: Místo názvu funkce může být použito pole obsahující odkaz na objekt a název metody.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
xml_set_object | Domů | xml_set_start_namespace_decl_handler


xml_set_start_namespace_decl_handler

(PHP 4 >= 4.0.5, PHP 5)

xml_set_start_namespace_decl_handler — Set up start namespace declaration handler

Popis

bool xml_set_start_namespace_decl_handler ( resource $parser, callback $handler )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Poznámka: Místo názvu funkce může být použito pole obsahující odkaz na objekt a název metody.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
xml_set_processing_instruction_handler | Domů | xml_set_unparsed_entity_decl_handler


xml_set_unparsed_entity_decl_handler

(PHP 4, PHP 5)

xml_set_unparsed_entity_decl_handler — Set up unparsed entity declaration handler

Popis

bool xml_set_unparsed_entity_decl_handler ( resource $parser, callback $handler )

Sets the unparsed entity declaration handler function for the XML parser parser.

The handler will be called if the XML parser encounters an external entity declaration with an NDATA declaration, like the following:

<!ENTITY <parameter>name</parameter> {<parameter>publicId</parameter> | <parameter>systemId</parameter>}
NDATA <parameter>notationName</parameter>

See » section 4.2.2 of the XML 1.0 spec for the definition of notation declared external entities.

Seznam parametrů

parser

handler

handler is a string containing the name of a function that must exist when xml_parse() is called for parser.

The function named by handler must accept six parameters: handler ( resource $parser, string $entity_name, string $base, string $system_id, string $public_id, string $notation_name )

parser
The first parameter, parser, is a reference to the XML parser calling the handler.
entity_name
The name of the entity that is about to be defined.
base
This is the base for resolving the system identifier (systemId) of the external entity.Currently this parameter will always be set to an empty string.
system_id
System identifier for the external entity.
public_id
Public identifier for the external entity.
notation_name
Name of the notation of this entity (see xml_set_notation_decl_handler()).

If a handler function is set to an empty string, or FALSE, the handler in question is disabled.

Poznámka: Místo názvu funkce může být použito pole obsahující odkaz na objekt a název metody.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
xml_set_start_namespace_decl_handler | Domů | CLXXXI. XML-RPC Functions


XML-RPC Functions

Předcházející VI. Reference funkcí Další

CLXXXI. XML-RPC Functions

Úvod

These functions can be used to write XML-RPC servers and clients. You can find more information about XML-RPC at » http://www.xmlrpc.com/, and more documentation on this extension and its functions at » http://xmlrpc-epi.sourceforge.net/.

Varování

Toto rozšíření je EXPERIMENTÁLNÍ. Chování tohoto rozšíření, názvy funkcí a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může bez ohlášení změnit. Berte to v úvahu a používejte tento modul na vlastní nebezpečí.

Požadavky

Tyto funkce jsou k dispozici jako součást standardního modulu, který je vždy dostupný.

Instalace

XML-RPC support in PHP is not enabled by default. You will need to use the --with-xmlrpc[=DIR] configuration option when compiling PHP to enable XML-RPC support. This extension is bundled into PHP as of 4.1.0.

Konfigurace běhu

Chování těchto funkcí je ovlivněno nastavením parametrů v php.ini.

Tabulka 324. XML-RPC configuration options

Name | Default | Changeable | Changelog
xmlrpc_errors | "0" | PHP_INI_SYSTEM | Available since PHP 4.1.0.
xmlrpc_error_number | "0" | PHP_INI_ALL | Available since PHP 4.1.0.

Pro další detaily a definice konstant PHP_INI_*, viz dokumentace k ini_set().

Typy prostředků

This extension defines a XML-RPC server resource returned by xmlrpc_server_create().

Předdefinované konstanty

Toto rozšíření nemá definovány žádné konstanty.

Obsah

xmlrpc_decode_request — Decodes XML into native PHP types
xmlrpc_decode — Decodes XML into native PHP types
xmlrpc_encode_request — Generates XML for a method request
xmlrpc_encode — Generates XML for a PHP value
xmlrpc_get_type — Gets xmlrpc type for a PHP value
xmlrpc_is_fault — Determines if an array value represents an XMLRPC fault
xmlrpc_parse_method_descriptions — Decodes XML into a list of method descriptions
xmlrpc_server_add_introspection_data — Adds introspection documentation
xmlrpc_server_call_method — Parses XML requests and call methods
xmlrpc_server_create — Creates an xmlrpc server
xmlrpc_server_destroy — Destroys server resources
xmlrpc_server_register_introspection_callback — Register a PHP function to generate documentation
xmlrpc_server_register_method — Register a PHP function to resource method matching method_name
xmlrpc_set_type — Sets xmlrpc type, base64 or datetime, for a PHP string value
Předcházející | Nahoru | Další
xml_set_unparsed_entity_decl_handler | Domů | xmlrpc_decode_request


xmlrpc_decode_request

(PHP 4 >= 4.0.7, PHP 5)

xmlrpc_decode_request — Decodes XML into native PHP types

Popis

mixed xmlrpc_decode_request ( string $xml, string &$method [, string $encoding] )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
CLXXXI. XML-RPC Functions | Domů | xmlrpc_decode


xmlrpc_decode

(PHP 4 >= 4.0.7, PHP 5)

xmlrpc_decode — Decodes XML into native PHP types

Popis

mixed xmlrpc_decode ( string $xml [, string $encoding] )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Seznam parametrů

xml

XML response returned by XMLRPC method.

encoding

Input encoding supported by iconv (defaults to "iso-8859-1").

Návratové hodnoty

Returns either an array, or an integer, or a string, or a boolean according to the response returned by the XMLRPC method.

Příklady

See example by xmlrpc_encode_request().

Viz také

xmlrpc_encode_request()
xmlrpc_is_fault()

Předcházející | Nahoru | Další
xmlrpc_decode_request | Domů | xmlrpc_encode_request


xmlrpc_encode_request

(PHP 4 >= 4.0.7, PHP 5)

xmlrpc_encode_request — Generates XML for a method request

Popis

string xmlrpc_encode_request ( string $method, mixed $params [, array $output_options] )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Seznam parametrů

method

Name of the method to call.

params

Method parameters compatible with method signature.

output_options

Array specifying output options may contain (default values are emphasised):

  • output_type: php, xml

  • verbosity: no_white_space, newlines_only, pretty

  • escaping: cdata, non-ascii, non-print, markup (may be a string with one value or an array with multiple values)

  • version: simple, xmlrpc, soap 1.1, auto

  • encoding: iso-8859-1, other character set supported by iconv

Návratové hodnoty

Returns a string containing the XML representation of the request.

Příklady

Příklad 2403. XMLRPC client functions example

<?php
$request = xmlrpc_encode_request("method", array(1, 2, 3));
$context = stream_context_create(array('http' => array(
    'method' => "POST",
    'header' => "Content-Type: text/xml",
    'content' => $request
)));
$file = file_get_contents("http://www.example.com/xmlrpc", false, $context);
$response = xmlrpc_decode($file);
if (xmlrpc_is_fault($response)) {
    trigger_error("xmlrpc: $response[faultString] ($response[faultCode])");
} else {
    print_r($response);
}
?>

Viz také

stream_context_create()
file_get_contents()
xmlrpc_decode()

Předcházející | Nahoru | Další
xmlrpc_decode | Domů | xmlrpc_encode


xmlrpc_encode

(PHP 4 >= 4.0.7, PHP 5)

xmlrpc_encode — Generates XML for a PHP value

Popis

string xmlrpc_encode ( mixed $value )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
xmlrpc_encode_request | Domů | xmlrpc_get_type


xmlrpc_get_type

(PHP 4 >= 4.0.7, PHP 5)

xmlrpc_get_type — Gets xmlrpc type for a PHP value

Popis

string xmlrpc_get_type ( mixed $value )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

This function is especially useful for base64 and datetime strings.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
xmlrpc_encode | Domů | xmlrpc_is_fault


xmlrpc_is_fault

(PHP 4 >= 4.3.0, PHP 5)

xmlrpc_is_fault — Determines if an array value represents an XMLRPC fault

Popis

bool xmlrpc_is_fault ( array $arg )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Seznam parametrů

arg

Array returned by xmlrpc_decode().

Návratové hodnoty

Returns TRUE if the argument means fault, FALSE otherwise. Fault description is available in $arg["faultString"], fault code is in $arg["faultCode"].

Příklady

See example by xmlrpc_encode_request().

Viz také

xmlrpc_decode()

Předcházející | Nahoru | Další
xmlrpc_get_type | Domů | xmlrpc_parse_method_descriptions


xmlrpc_parse_method_descriptions

(PHP 4 >= 4.0.7, PHP 5)

xmlrpc_parse_method_descriptions — Decodes XML into a list of method descriptions

Popis

array xmlrpc_parse_method_descriptions ( string $xml )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
xmlrpc_is_fault | Domů | xmlrpc_server_add_introspection_data


xmlrpc_server_add_introspection_data

(PHP 4 >= 4.0.7, PHP 5)

xmlrpc_server_add_introspection_data — Adds introspection documentation

Popis

int xmlrpc_server_add_introspection_data ( resource $server, array $desc )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
xmlrpc_parse_method_descriptions | Domů | xmlrpc_server_call_method


xmlrpc_server_call_method

(PHP 4 >= 4.0.7, PHP 5)

xmlrpc_server_call_method — Parses XML requests and call methods

Popis

string xmlrpc_server_call_method ( resource $server, string $xml, mixed $user_data [, array $output_options] )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
xmlrpc_server_add_introspection_data | Domů | xmlrpc_server_create


xmlrpc_server_create

(PHP 4 >= 4.0.7, PHP 5)

xmlrpc_server_create — Creates an xmlrpc server

Popis

resource xmlrpc_server_create ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
xmlrpc_server_call_method | Domů | xmlrpc_server_destroy


xmlrpc_server_destroy

(PHP 4 >= 4.0.7, PHP 5)

xmlrpc_server_destroy — Destroys server resources

Popis

int xmlrpc_server_destroy ( resource $server )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
xmlrpc_server_create | Domů | xmlrpc_server_register_introspection_callback


xmlrpc_server_register_introspection_callback

(PHP 4 >= 4.0.7, PHP 5)

xmlrpc_server_register_introspection_callback — Register a PHP function to generate documentation

Popis

bool xmlrpc_server_register_introspection_callback ( resource $server, string $function )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
xmlrpc_server_destroy | Domů | xmlrpc_server_register_method


xmlrpc_server_register_method

(PHP 4 >= 4.0.7, PHP 5)

xmlrpc_server_register_method — Register a PHP function to resource method matching method_name

Popis

bool xmlrpc_server_register_method ( resource $server, string $method_name, string $function )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
xmlrpc_server_register_introspection_callback | Domů | xmlrpc_set_type


xmlrpc_set_type

(PHP 4 >= 4.0.7, PHP 5)

xmlrpc_set_type — Sets xmlrpc type, base64 or datetime, for a PHP string value

Popis

bool xmlrpc_set_type ( string &$value, string $type )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Seznam parametrů

value

Value to set the type

type

'base64' or 'datetime'

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání. If successful, value is converted to an object.

Errors/Exceptions

Issues E_WARNING with type unsupported by XMLRPC.

Předcházející | Nahoru | Další
xmlrpc_server_register_method | Domů | CLXXXII. XMLReader functions


xdiff Functions

Předcházející VI. Reference funkcí Další

CLXXIX. xdiff Functions

Úvod

xdiff extension creates and applies patches to both text and binary files.

Požadavky

To use xdiff, you will need libxdiff installed, available on the libxdiff homepage » http://www.xmailserver.org/xdiff-lib.html.

Poznámka: You'll need at least libxdiff 0.7 for these functions to be aware of memory_limit.

Instalace

xdiff is currently available through PECL » http://pecl.php.net/package/xdiff.

If » PEAR is available on your *nix-like system you can use the pear installer to install the xdiff extension, by the following command: pear -v install xdiff.

You can always download the tar.gz package and install xdiff by hand:

Příklad 2385. xdiff install by hand

gunzip xdiff-xxx.tgz
tar -xvf xdiff-xxx.tar
cd xdiff-xxx
phpize
./configure && make && make install

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

XDIFF_PATCH_NORMAL (integer)
XDIFF_PATCH_REVERSE (integer)

Obsah

xdiff_file_diff_binary — Make binary diff of two files
xdiff_file_diff — Make unified diff of two files
xdiff_file_merge3 — Merge 3 files into one
xdiff_file_patch_binary — Patch a file with a binary diff
xdiff_file_patch — Patch a file with an unified diff
xdiff_string_diff_binary — Make binary diff of two strings
xdiff_string_diff — Make unified diff of two strings
xdiff_string_merge3 — Merge 3 strings into one
xdiff_string_patch_binary — Patch a string with a binary diff
xdiff_string_patch — Patch a string with an unified diff
Předcházející | Nahoru | Další
xattr_supported | Domů | xdiff_file_diff_binary


xdiff_file_diff_binary

(PECL xdiff:0.2-1.4)

xdiff_file_diff_binary — Make binary diff of two files

Popis

bool xdiff_file_diff_binary ( string $file1, string $file2, string $dest )

Makes a binary diff of two files and stores the result in a file. This function works with both text and binary files.

Seznam parametrů

file1

file2

dest

Path of the resulting file. Resulting file is in binary format.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 2386. xdiff_file_diff_binary() example

The following code makes binary diff of two archives.

<?php
$old_version = 'my_script_1.0.tgz';
$new_version = 'my_script_1.1.tgz';

xdiff_file_diff_binary($old_version, $new_version, 'my_script.bdiff');
?>

Poznámky

Poznámka: Both files will be loaded into memory so ensure that your memory_limit is set high enough.

Viz také

xdiff_string_diff_binary()

Předcházející | Nahoru | Další
CLXXIX. xdiff Functions | Domů | xdiff_file_diff


xdiff_file_diff

(PECL xdiff:0.2-1.4)

xdiff_file_diff — Make unified diff of two files

Popis

bool xdiff_file_diff ( string $file1, string $file2, string $dest [, int $context [, bool $minimal]] )

Makes a diff of two files and stores the result in a file.

Seznam parametrů

file1

file2

dest

Path of the resulting file.

context

Indicates how many lines of context you want to include in diff result.

minimal

Set this parameter to TRUE if you want to minimalize size of diff (can take a long time). Resulting file is human-readable.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 2387. xdiff_file_diff() example

The following code makes unified diff of two php files.

<?php
$old_version = 'my_script.php';
$new_version = 'my_new_script.php';

xdiff_file_diff($old_version, $new_version, 'my_script.diff', 2);
?>

Poznámky

Poznámka: This function doesn't work well with binary files. To make diff of binary files use xdiff_file_diff_binary().

Viz také

xdiff_string_diff()

Předcházející | Nahoru | Další
xdiff_file_diff_binary | Domů | xdiff_file_merge3


xdiff_file_merge3

(PECL xdiff:0.2-1.4)

xdiff_file_merge3 — Merge 3 files into one

Popis

mixed xdiff_file_merge3 ( string $file1, string $file2, string $file3, string $dest )

Merges three files into one and stores the result in a file.

Seznam parametrů

file1

file2

file3

dest

Path of the resulting file.

Návratové hodnoty

Returns TRUE if merge was successful, string with rejected chunks if it was not or FALSE if an internal error happened.

Příklady

Příklad 2388. xdiff_file_merge3() example

The following code merges three files into one.

<?php
$old_version = 'original_script.php';
$fix1 = 'script_with_fix1.php';
$fix2 = 'script_with_fix2.php';

$errors = xdiff_file_merge3($old_version, $fix1, $fix2, 'fixed_script.php');
if (is_string($errors)) {
    echo "Rejects:\n";
    echo $errors;
}
?>

Viz také

xdiff_string_merge3()

Předcházející | Nahoru | Další
xdiff_file_diff | Domů | xdiff_file_patch_binary


xdiff_file_patch_binary

(PECL xdiff:0.2-1.4)

xdiff_file_patch_binary — Patch a file with a binary diff

Popis

bool xdiff_file_patch_binary ( string $file, string $patch, string $dest )

Patches a file with a binary patch and stores the result in a file.

Seznam parametrů

file

The original file.

patch

The binary patch file.

dest

Path of the resulting file.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 2389. xdiff_file_patch_binary() example

The following code applies binary diff to a file.

<?php
$old_version = 'archive-1.0.tgz';
$patch = 'archive.bpatch';

$result = xdiff_file_patch_binary($old_version, $patch, 'archive-1.1.tgz');
if ($result) {
   echo "File patched";
} else {
   echo "File couldn't be patched";
}

?>

Poznámky

Poznámka: Both files (file and patch) will be loaded into memory so ensure that your memory_limit is set high enough.

Viz také

xdiff_string_patch_binary()

Předcházející | Nahoru | Další
xdiff_file_merge3 | Domů | xdiff_file_patch


xdiff_file_patch

(PECL xdiff:0.2-1.4)

xdiff_file_patch — Patch a file with an unified diff

Popis

mixed xdiff_file_patch ( string $file, string $patch, string $dest [, int $flags] )

Patches a file with a unified patch and stores the result in a file.

Seznam parametrů

file

The original file.

patch

The patch file.

dest

Path of the resulting file.

flags

Can be either XDIFF_PATCH_NORMAL (default mode, normal patch) or XDIFF_PATCH_REVERSE (reversed patch).

Návratové hodnoty

Returns FALSE if an internal error happened, string with rejected chunks of patch or TRUE if patch has been successfully applied.

Příklady

Příklad 2390. xdiff_file_patch() example

The following code applies unified diff to a file.

<?php
$old_version = 'my_script-1.0.php';
$patch = 'my_script.patch';

$errors = xdiff_file_patch($old_version, $patch, 'my_script-1.1.php');
if (is_string($errors)) {
   echo "Rejects:\n";
   echo $errors;
}

?>

Příklad 2391. Patch reversing example

The following code reverses a patch.

<?php
$new_version = 'my_script-1.1.php';
$patch = 'my_script.patch';

$errors = xdiff_file_patch($new_version, $patch, 'my_script-1.0.php', XDIFF_PATCH_REVERSE);
if (is_string($errors)) {
   echo "Rejects:\n";
   echo $errors;
}

?>

Viz také

xdiff_string_patch()

Předcházející | Nahoru | Další
xdiff_file_patch_binary | Domů | xdiff_string_diff_binary


xdiff_string_diff_binary

(PECL xdiff:0.2-1.4)

xdiff_string_diff_binary — Make binary diff of two strings

Popis

string xdiff_string_diff_binary ( string $str1, string $str2 )

Makes a binary diff of two strings.

Seznam parametrů

str1

str2

Návratové hodnoty

Returns string with result or FALSE if an internal error happened.

Viz také

xdiff_file_diff_binary()

Předcházející | Nahoru | Další
xdiff_file_patch | Domů | xdiff_string_diff


xdiff_string_diff

(PECL xdiff:0.2-1.4)

xdiff_string_diff — Make unified diff of two strings

Popis

string xdiff_string_diff ( string $str1, string $str2 [, int $context [, bool $minimal]] )

Makes a unified diff of two strings.

Seznam parametrů

str1

str2

context

Indicates how many lines of context you want to include in the diff result.

minimal

Set this parameter to TRUE if you want to minimalize the size of the diff (can take a long time).

Návratové hodnoty

Returns string with result or FALSE if an internal error happened.

Příklady

Příklad 2392. xdiff_string_diff() example

The following code makes unified diff of two articles.

<?php
$old_article = file_get_contents('./old_article.txt');
$new_article = $_REQUEST['article']; /* Let's say that someone pasted a new article to html form */

$diff = xdiff_string_diff($old_article, $new_article, 1);
if (is_string($diff)) {
    echo "Differences between two articles:\n";
    echo $diff;
}

?>

Poznámky

Poznámka: This function doesn't work well with binary strings. To make diff of binary strings use xdiff_string_diff_binary().

Viz také

xdiff_file_diff()

Předcházející | Nahoru | Další
xdiff_string_diff_binary | Domů | xdiff_string_merge3


xdiff_string_merge3

(PECL xdiff:0.2-1.4)

xdiff_string_merge3 — Merge 3 strings into one

Popis

mixed xdiff_string_merge3 ( string $str1, string $str2, string $str3 [, string &$error] )

Merges three strings into one.

Seznam parametrů

str1

str2

str3

error

If provided then rejected parts are stored inside this variable.

Návratové hodnoty

Returns merged string, FALSE if an internal error happened, or TRUE if merged string is empty.

Viz také

xdiff_file_merge3()

Předcházející | Nahoru | Další
xdiff_string_diff | Domů | xdiff_string_patch_binary


xdiff_string_patch_binary

(PECL xdiff:0.2-1.4)

xdiff_string_patch_binary — Patch a string with a binary diff

Popis

string xdiff_string_patch_binary ( string $str, string $patch )

Patches a string with a binary patch.

Seznam parametrů

str

The original binary string.

patch

The binary patch string.

Návratové hodnoty

Returns the patched string, or FALSE on error.

Viz také

xdiff_file_patch_binary()

Předcházející | Nahoru | Další
xdiff_string_merge3 | Domů | xdiff_string_patch


xdiff_string_patch

(PECL xdiff:0.2-1.4)

xdiff_string_patch — Patch a string with an unified diff

Popis

string xdiff_string_patch ( string $str, string $patch [, int $flags [, string &$error]] )

Patches a string with a unified patch string.

Seznam parametrů

str

The original string.

patch

The unified patch string.

flags

flags can be either XDIFF_PATCH_NORMAL (default mode, normal patch) or XDIFF_PATCH_REVERSE (reversed patch).

error

If provided then rejected parts are stored inside this variable.

Návratové hodnoty

Returns the patched string, or FALSE on error.

Příklady

Příklad 2393. xdiff_string_patch() example

The following code applies changes to some article.

<?php
$old_article = file_get_contents('./old_article.txt');
$diff = $_SERVER['patch']; /* Let's say that someone pasted a patch to html form */

$errors = '';

$new_article = xdiff_string_patch($old_article, $diff, XDIFF_PATCH_NORMAL, $errors);
if (is_string($new_article)) {
    echo "New article:\n";
    echo $new_article;
}

if (strlen($errors)) {
    echo "Rejects: \n";
    echo $errors;
}

?>

Viz také

xdiff_file_patch()

Předcházející | Nahoru | Další
xdiff_string_patch_binary | Domů | CLXXX. XML Parser Functions


XSL functions

Předcházející VI. Reference funkcí Další

CLXXXIV. XSL functions

Úvod

The XSL extension implements the XSL standard, performing » XSLT transformations using the » libxslt library

Požadavky

This extension uses libxslt which can be found at » http://xmlsoft.org/XSLT/. libxslt version 1.1.0 or greater is required.

Instalace

PHP 5 includes the XSL extension by default and can be enabled by adding the argument --with-xsl[=DIR] to your configure line. DIR is the libxslt installation directory.

Předdefinované třídy

XSLTProcessor

Konstruktory

  • XSLTProcessor::__construct - construct a new XSLTProcessor object

Metody

  • XSLTProcessor::getParameter - Get value of a parameter

  • XSLTProcessor::hasExsltSupport - Determine if PHP has EXSLT support

  • XSLTProcessor::importStylesheet - Import stylesheet

  • XSLTProcessor::registerPHPFunctions - Enables the ability to use PHP functions as XSLT functions

  • XSLTProcessor::removeParameter - Remove parameter

  • XSLTProcessor::setParameter - Set value for a parameter

  • XSLTProcessor::transformToDoc - Transform to DOMDocument

  • XSLTProcessor::transformToURI - Transform to URI

  • XSLTProcessor::transformToXML - Transform to XML

Příklady

Many examples in this reference require both an XML and an XSL file. We will use collection.xml and collection.xsl that contains the following:

Příklad 2404. collection.xml

<collection>
<cd>
<title>Fight for your mind</title>
<artist>Ben Harper</artist>
<year>1995</year>
</cd>
<cd>
<title>Electric Ladyland</title>
<artist>Jimi Hendrix</artist>
<year>1997</year>
</cd>
</collection>

Příklad 2405. collection.xsl

<xsl:stylesheet version="1.0" xmlns:xsl="http://www.w3.org/1999/XSL/Transform">
<xsl:param name="owner" select="'Nicolas Eliaszewicz'"/>
<xsl:output method="html" encoding="iso-8859-1" indent="no"/>
<xsl:template match="collection">
Hey! Welcome to <xsl:value-of select="$owner"/>'s sweet CD collection!
<xsl:apply-templates/>
</xsl:template>
<xsl:template match="cd">
<h1><xsl:value-of select="title"/></h1>
<h2>by <xsl:value-of select="artist"/> - <xsl:value-of select="year"/></h2>
<hr />
</xsl:template>
</xsl:stylesheet>

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

XSL_CLONE_AUTO (integer)
XSL_CLONE_NEVER (integer)
XSL_CLONE_ALWAYS (integer)
LIBXSLT_VERSION (integer)
libxslt version like 10117. Available as of PHP 5.1.2.
LIBXSLT_DOTTED_VERSION (string)
libxslt version like 1.1.17. Available as of PHP 5.1.2.
LIBEXSLT_VERSION (integer)
libexslt version like 813. Available as of PHP 5.1.2.
LIBEXSLT_DOTTED_VERSION (string)
libexslt version like 1.1.17. Available as of PHP 5.1.2.

Obsah

XSLTProcessor::__construct — Creates a new XSLTProcessor object
XSLTProcessor::getParameter — Get value of a parameter
XSLTProcessor::hasExsltSupport — Determine if PHP has EXSLT support
XSLTProcessor::importStylesheet — Import stylesheet
XSLTProcessor::registerPHPFunctions — Enables the ability to use PHP functions as XSLT functions
XSLTProcessor::removeParameter — Remove parameter
XSLTProcessor::setParameter — Set value for a parameter
XSLTProcessor::transformToDoc — Transform to a DOMDocument
XSLTProcessor::transformToURI — Transform to URI
XSLTProcessor::transformToXML — Transform to XML
Předcházející | Nahoru | Další
XMLWriter::writeRaw | Domů | XSLTProcessor::__construct


XSLTProcessor::getParameter

(No version information available, might be only in CVS)

XSLTProcessor::getParameter — Get value of a parameter

Popis

class XSLTProcessor {
string getParameter ( string $namespaceURI, string $localName )
}

Gets a parameter if previously set by XSLTProcessor::setParameter.

Seznam parametrů

namespaceURI

The namespace URI of the XSLT parameter.

localName

The local name of the XSLT parameter.

Návratové hodnoty

The value of the parameter or NULL if it's not set.

Viz také

XSLTProcessor::setParameter
XSLTProcessor::removeParameter

Předcházející | Nahoru | Další
XSLTProcessor::__construct | Domů | XSLTProcessor::hasExsltSupport


XSLTProcessor::hasExsltSupport

(No version information available, might be only in CVS)

XSLTProcessor::hasExsltSupport — Determine if PHP has EXSLT support

Popis

class XSLTProcessor {
bool hasExsltSupport ( void )
}

This method determine if PHP was built with the » EXSLT library.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 2407. Testing EXSLT support

<?php

$proc = new XSLTProcessor;
if (!$proc->hasExsltSupport()) {
    die('EXSLT support not available');
}

// do EXSLT stuff here ..

?>

Předcházející | Nahoru | Další
XSLTProcessor::getParameter | Domů | XSLTProcessor::importStylesheet


XSLTProcessor::importStylesheet

(No version information available, might be only in CVS)

XSLTProcessor::importStylesheet — Import stylesheet

Popis

class XSLTProcessor {
void importStylesheet ( DOMDocument $stylesheet )
}

This method import the stylesheet into the XSLTProcessor for transformations.

Seznam parametrů

stylesheet

The imported style sheet as a DOMDocument object.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
XSLTProcessor::hasExsltSupport | Domů | XSLTProcessor::registerPHPFunctions


XSLTProcessor::registerPHPFunctions

(No version information available, might be only in CVS)

XSLTProcessor::registerPHPFunctions — Enables the ability to use PHP functions as XSLT functions

Popis

class XSLTProcessor {
void registerPHPFunctions ( [mixed $restrict] )
}

This method enables the ability to use PHP functions as XSLT functions within XSL stylesheets.

Seznam parametrů

restrict

Use this parameter to only allow certain functions to be called from XSLT.

This parameter can be either a string (a function name) or an array of functions.

Návratové hodnoty

Nevrací se žádná hodnota.

Příklady

Příklad 2408. Simple PHP Function call from a stylesheet

<?php
$xml = <<<EOB
<allusers>
 <user>
  <uid>bob</uid>
 </user>
 <user>
  <uid>joe</uid>
 </user>
</allusers>
EOB;
$xsl = <<<EOB
<?xml version="1.0" encoding="UTF-8"?>
<xsl:stylesheet version="1.0"
     xmlns:xsl="http://www.w3.org/1999/XSL/Transform"
     xmlns:php="http://php.net/xsl">
<xsl:output method="html" encoding="utf-8" indent="yes"/>
 <xsl:template match="allusers">
  <html><body>
    <h2>Users</h2>
    <table>
    <xsl:for-each select="user">
      <tr><td>
        <xsl:value-of
             select="php:function('ucfirst',string(uid))"/>
      </td></tr>
    </xsl:for-each>
    </table>
  </body></html>
 </xsl:template>
</xsl:stylesheet>
EOB;
$xmldoc = DOMDocument::loadXML($xml);
$xsldoc = DOMDocument::loadXML($xsl);

$proc = new XSLTProcessor();
$proc->registerPHPFunctions();
$proc->importStyleSheet($xsldoc);
echo $proc->transformToXML($xmldoc);
?>

ChangeLog (záznam změn)

Verze | Popis
5.1.0 | The restrict parameter was added.

Předcházející | Nahoru | Další
XSLTProcessor::importStylesheet | Domů | XSLTProcessor::removeParameter


XSLTProcessor::removeParameter

(No version information available, might be only in CVS)

XSLTProcessor::removeParameter — Remove parameter

Popis

class XSLTProcessor {
bool removeParameter ( string $namespaceURI, string $localName )
}

Removes a parameter, if set. This will make the processor use the default value for the parameter as specified in the stylesheet.

Seznam parametrů

namespaceURI

The namespace URI of the XSLT parameter.

localName

The local name of the XSLT parameter.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

XSLTProcessor::setParameter
XSLTProcessor::getParameter

Předcházející | Nahoru | Další
XSLTProcessor::registerPHPFunctions | Domů | XSLTProcessor::setParameter


XSLTProcessor::setParameter

(No version information available, might be only in CVS)

XSLTProcessor::setParameter — Set value for a parameter

Popis

class XSLTProcessor {
bool setParameter ( string $namespace, string $name, string $value )
} class XSLTProcessor {
bool setParameter ( string $namespace, array $options )
}

Sets the value of one or more parameters to be used in subsequent transformations with XSLTProcessor. If the parameter doesn't exist in the stylesheet it will be ignored.

Seznam parametrů

namespace

The namespace URI of the XSLT parameter.

name

The local name of the XSLT parameter.

value

The new value of the XSLT parameter.

options

An array of name => value pairs. This syntax is available since PHP 5.1.0.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 2409. Changing the owner before the transformation

<?php

$collections = array(
    'Marc Rutkowski' => 'marc',
    'Olivier Parmentier' => 'olivier'
);

$xsl = new DOMDocument;
$xsl->load('collection.xsl');

// Configure the transformer
$proc = new XSLTProcessor;
$proc->importStyleSheet($xsl); // attach the xsl rules

foreach ($collections as $name => $file) {
    // Load the XML source
    $xml = new DOMDocument;
    $xml->load('collection_' . $file . '.xml');

    $proc->setParameter('', 'owner', $name);
    $proc->transformToURI($xml, 'file:///tmp/' . $file . '.html');
}

?>

Viz také

XSLTProcessor::getParameter
XSLTProcessor::removeParameter

Předcházející | Nahoru | Další
XSLTProcessor::removeParameter | Domů | XSLTProcessor::transformToDoc


XSLTProcessor::transformToDoc

(No version information available, might be only in CVS)

XSLTProcessor::transformToDoc — Transform to a DOMDocument

Popis

class XSLTProcessor {
DOMDocument transformToDoc ( DOMNode $doc )
}

Transforms the source node to a DOMDocument applying the stylesheet given by the XSLTProcessor::importStylesheet method.

Seznam parametrů

doc

The node to be transformed.

Návratové hodnoty

The resulting DOMDocument or FALSE on error.

Příklady

Příklad 2410. Transforming to a DOMDocument

<?php

// Load the XML source
$xml = new DOMDocument;
$xml->load('collection.xml');

$xsl = new DOMDocument;
$xsl->load('collection.xsl');

// Configure the transformer
$proc = new XSLTProcessor;
$proc->importStyleSheet($xsl); // attach the xsl rules

echo trim($proc->transformToDoc($xml)->firstChild->wholeText);

?>

Výše uvedený příklad vypíše:

Hey! Welcome to Nicolas Eliaszewicz's sweet CD collection!

Viz také

XSLTProcessor::transformToURI
XSLTProcessor::transformToXML

Předcházející | Nahoru | Další
XSLTProcessor::setParameter | Domů | XSLTProcessor::transformToURI


XSLTProcessor::transformToURI

(No version information available, might be only in CVS)

XSLTProcessor::transformToURI — Transform to URI

Popis

class XSLTProcessor {
int transformToURI ( DOMDocument $doc, string $uri )
}

Transforms the source node to an URI applying the stylesheet given by the XSLTProcessor::importStylesheet method.

Seznam parametrů

doc

The transformed document.

uri

Návratové hodnoty

Returns the number of bytes written or FALSE if an error occurred.

Příklady

Příklad 2411. Transforming to a HTML file

<?php

// Load the XML source
$xml = new DOMDocument;
$xml->load('collection.xml');

$xsl = new DOMDocument;
$xsl->load('collection.xsl');

// Configure the transformer
$proc = new XSLTProcessor;
$proc->importStyleSheet($xsl); // attach the xsl rules

$proc->transformToURI($xml, 'file:///tmp/out.html');

?>

Viz také

XSLTProcessor::transformToDoc
XSLTProcessor::transformToXML

Předcházející | Nahoru | Další
XSLTProcessor::transformToDoc | Domů | XSLTProcessor::transformToXML


XSLTProcessor::transformToXML

(No version information available, might be only in CVS)

XSLTProcessor::transformToXML — Transform to XML

Popis

class XSLTProcessor {
string transformToXML ( DOMDocument $doc )
}

Transforms the source node to a string applying the stylesheet given by the XSLTProcessor::importStylesheet method.

Seznam parametrů

doc

The transformed document.

Návratové hodnoty

The result of the transformation as a string or FALSE on error.

Příklady

Příklad 2412. Transforming to a string

<?php

// Load the XML source
$xml = new DOMDocument;
$xml->load('collection.xml');

$xsl = new DOMDocument;
$xsl->load('collection.xsl');

// Configure the transformer
$proc = new XSLTProcessor;
$proc->importStyleSheet($xsl); // attach the xsl rules

echo $proc->transformToXML($xml);

?>

Výše uvedený příklad vypíše:

Hey! Welcome to Nicolas Eliaszewicz's sweet CD collection!

<h1>Fight for your mind</h1><h2>by Ben Harper - 1995</h2><hr>
<h1>Electric Ladyland</h1><h2>by Jimi Hendrix - 1997</h2><hr>

Viz také

XSLTProcessor::transformToDoc
XSLTProcessor::transformToURI

Předcházející | Nahoru | Další
XSLTProcessor::transformToURI | Domů | CLXXXV. XSLT funkce


XSLT funkce

Předcházející VI. Reference funkcí Další

CLXXXV. XSLT funkce

Úvod

Toto rozšíření PHP poskytuje API nezávislé na zpracovateli pro XSLT transformace. V současnosti toto rozšíření podporuje pouze knihovnu Sablotron od Ginger Alliance. Plánována je podpora také pro další knihovny, jako například Xalan nebo libxslt.

XSLT (Extensible Stylesheet Language (XSL) Transformations) je jazyk pro transformaci XML dokumentů do jiných XML dokumentů. Je to standard definovaný The World Wide Web konsorciem (W3C). Imformace o XSLT a souvisejících technologiích jsou dostupné na » http://www.w3.org/TR/xslt.

Poznámka: Toto rozšíření se liší od rozšíření Sablotron, které bylo distribuováno s PHP verzemi nižšími než 4.1. Od PHP 4.1 je podporováno pouze toto nové rozšíření. Pokud potřebujete podporu pro starší rozšíření, zeptejte se prosím v PHP konferencích.

Požadavky

Tato extenze využívá Sabloton a expat, které jsou dostupné na » http://www.gingerall.org/sablotron.html, a to jak binární soubory tak zdrojové kódy.

Instalace

Na UNIXu spusťte configure s volbami --enable-xslt a --with-xslt-sablot. Sablotron knihovna by měla být nainstalována na nějakém místě, kde ji váš kompilátor může najít.

Zaručte, aby byly k Sablotronu přilinkovány stejné knihovny, které jsou přilinkovány k PHP. Konfigurační přepínače --with-expat-dir=DIR a --with-iconv-dir=DIR jsou zde proto, aby vám pomohly s jejich specifikací. Pokud požadujete podporu, vždy se zmiňte o těchto direktivách a o tom, zda jsou na vašem systému instalovány jiné verze těchto knihoven. Jednoduše řečeno, poskytněte všechna čísla verzí.

Výstraha

Zaručte, aby knihovna Sablot byla přilinkována k -lstdc++, jinak se konfigurace nepodaří nebo se PHP nespustí nebo nezavede.

Podpora pro JavaScript E-XSLT: Pokud jste Sablotron zkompilovali s podporou pro JavaScript, musíte zadat volbu --with-sablot-js=DIR.

Poznámka pro uživatele Win32: Abyste mohli tento modul používat pod Windows, musíte zkopírovat nějaké soubory z adresáře DLL disribučního archivu PHP/Win32 do adresáře SYSTEM32 vašich Windows. (Např.: C:\WINNT\SYSTEM32 nebo C:\WINDOWS\SYSTEM32). Pro PHP <= 4.2.0 zkopírujte sablot.dll a expat.dll. Pro PHP >= 4.2.1 zkopírujte sablot.dll, expat.dll a iconv.dll.

Konfigurace běhu

Toto rozšíření nemá definováno žádné konfigurační direktivy.

Typy prostředků

Toto rozšíření nemá definován žádný typ prostředku (resource).

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

XSLT_OPT_SILENT (integer)
Zrušit veškeré logování a hlášení chyb. Jedná se o obecnou volbu pro všechny nástroje, které mohou být přidány v budoucnu.
XSLT_SABOPT_PARSE_PUBLIC_ENTITIES (integer)

Přikázat Sablotronu, aby parsoval veřejné entity. Ve výchozím nastavení je tato volba vypnuta.

XSLT_SABOPT_DISABLE_ADDING_META (integer)

Nepřidávat meta značku "Content-Type" do HTML výstupu. Výchozí nastavení je určeno během kompilace Sablotronu.

XSLT_SABOPT_DISABLE_STRIPPING (integer)
Potlačit odstraňování bílých znaků (pouze u datových souborů).
XSLT_SABOPT_IGNORE_DOC_NOT_FOUND (integer)
Považovat nerozpoznané dokumenty (funkce document()) za nesmrtelné.
XSLT_ERR_UNSUPPORTED_SCHEME (integer)
Vrátit chybový kód, pro scheme handlers.

Obsah

xslt_backend_info — Returns the information on the compilation settings of the backend
xslt_backend_name — Returns the name of the backend
xslt_backend_version — Returns the version number of Sablotron
xslt_create — Vytvořit nový XSL procesor
xslt_errno — Vrátit číslo současné chyby
xslt_error — Vrátit text poslední chyby
xslt_free — Uvolnit XSLT procesor
xslt_getopt — Get options on a given xsl processor
xslt_process — Transformovat XML data řetězcem obsahujícím XSL data
xslt_set_base — Set the base URI for all XSLT transformations
xslt_set_encoding — Set the encoding for the parsing of XML documents
xslt_set_error_handler — Set an error handler for a XSLT processor
xslt_set_log — Set the log file to write log messages to
xslt_set_object — Sets the object in which to resolve callback functions
xslt_set_sax_handler — Určit SAX handlery XSLT procesoru
xslt_set_sax_handlers — Set the SAX handlers to be called when the XML document gets processed
xslt_set_scheme_handler — Set Scheme handlers for a XSLT processor
xslt_set_scheme_handlers — Set the scheme handlers for the XSLT processor
xslt_setopt — Set options on a given xsl processor
Předcházející | Nahoru | Další
XSLTProcessor::transformToXML | Domů | xslt_backend_info


xslt_backend_info

(PHP 4 >= 4.3.0)

xslt_backend_info — Returns the information on the compilation settings of the backend

Popis

string xslt_backend_info ( void )

xslt_backend_info() gets information about the compilation settings of the backend.

Návratové hodnoty

Returns a string with information about the compilation setting of the backend or an error string when no information available.

Viz také

xslt_backend_name()
xslt_backend_version()

Předcházející | Nahoru | Další
CLXXXV. XSLT funkce | Domů | xslt_backend_name


xslt_backend_name

(PHP 4 >= 4.3.0)

xslt_backend_name — Returns the name of the backend

Popis

string xslt_backend_name ( void )

xslt_backend_name() gets the name of the backend.

Návratové hodnoty

Returns Sablotron.

Příklady

Příklad 2413. xslt_backend_name() example

<?php

echo xslt_backend_name(); // Sablotron

?>

Viz také

xslt_backend_info()
xslt_backend_version()

Předcházející | Nahoru | Další
xslt_backend_info | Domů | xslt_backend_version


xslt_backend_version

(PHP 4 >= 4.3.0)

xslt_backend_version — Returns the version number of Sablotron

Popis

string xslt_backend_version ( void )

xslt_backend_version() gets the version number of Sablotron.

Návratové hodnoty

Returns the version number, or FALSE if not available.

Příklady

Příklad 2414. xslt_backend_version() example

<?php

echo xslt_backend_version(); // 0.98 for example

?>

Viz také

xslt_backend_info()
xslt_backend_name()

Předcházející | Nahoru | Další
xslt_backend_name | Domů | xslt_create


xslt_create

(PHP 4 >= 4.0.3)

xslt_create — Vytvořit nový XSL procesor

Popis

resource xslt_create ( void )

Tato funkce vrací handle nového XSL procesoru. Tento handle je potřeba ve všech následných voláních XSL funkcí.

Předcházející | Nahoru | Další
xslt_backend_version | Domů | xslt_errno


xslt_errno

(PHP 4 >= 4.0.3)

xslt_errno — Vrátit číslo současné chyby

Popis

int xslt_errno ( resource $xh )

Vrací číslo současné chyby daného XSL procesoru. Pokud nedostane handle, vrací číslo poslední chyby bez ohledu na její výskyt.

Předcházející | Nahoru | Další
xslt_create | Domů | xslt_error


xslt_error

(PHP 4 >= 4.0.3)

xslt_error — Vrátit text poslední chyby

Popis

string xslt_error ( resource $xh )

Vrací text současné chyby daného XSL procesoru. Pokud nedostane handle, vrací text poslední chyby bez ohledu na její výskyt.

Předcházející | Nahoru | Další
xslt_errno | Domů | xslt_free


xslt_free

(PHP 4 >= 4.0.3)

xslt_free — Uvolnit XSLT procesor

Popis

void xslt_free ( resource $xh )

Uvolní XSLT procesor identifikovaný předaným handle.

Předcházející | Nahoru | Další
xslt_error | Domů | xslt_getopt


xslt_getopt

(PHP 4 >= 4.3.0)

xslt_getopt — Get options on a given xsl processor

Popis

int xslt_getopt ( resource $processor )

xslt_getopt() returns the options on the given processor.

Seznam parametrů

processor

The XSLT processor link identifier, created with xslt_create().

Návratové hodnoty

Returns the options, a bitmask constructed with the XSLT_SABOPT_XXX constants.

Viz také

xslt_setopt()

Předcházející | Nahoru | Další
xslt_free | Domů | xslt_process


xslt_process

(PHP 4 >= 4.0.3)

xslt_process — Transformovat XML data řetězcem obsahujícím XSL data

Popis

mixed xslt_process ( resource $xh, string $xmlcontainer, string $xslcontainer [, string $resultcontainer [, array $arguments [, array $parameters]]] )

xslt_process() přijímá jako první argument řetězec obsahující XSLT stylesheet, jako druhý argument řetězec obsahující XML data, která chcete transformovat, a jako třetí argument řetězec obsahujícící výsledky transformace. xslt_process() vrací TRUE při úspěchu a FALSE při selhání. Číslo a text chyby případně vzniklé při transformaci můžete získat pomocí xslt_errno() a xslt_error() funkcí.

Příklad 2415. Použití xslt_process() k transformaci tří řetězců

<?php

$xslData = '
<xsl:stylesheet
  version="1.0"
  xmlns:xsl="http://www.w3.org/1999/XSL/Transform">

<xsl:template match="article">
    <table border="1" cellpadding="2" cellspacing="1">
        <tr>
            <td width="20%">

            </title>
            <td width="80%">
                <h2><xsl:value-of select="title"></h2>
                <h3><xsl:value-of select="author"></h3>
                <br>

                <xsl:value-of select="body">
            </td>
        </tr>
    </table>
</xsl:template>

</xsl:stylesheet>';

$xmlData = '
<?xml version="1.0"?>
<article>
    <title>Learning German</title>
    <author>Sterling Hughes</author>
    <body>
      Essential phrases:
      <br>
      <br>
      Komme sie mir sagen, woe die toilette es?<br>
      Eine grande beer bitte!<br>
      Noch einem bitte.<br>
    </body>
</article>';

if (xslt_process($xslData, $xmlData, $result))
{
    echo "Here is the brilliant in-depth article on learning";
    echo " German: ";
    echo "<br>\n<br>";
    echo $result;
}
else
{
    echo "There was an error that occurred in the XSL transformace...\n";
    echo "\tError number: " . xslt_errno() . "\n";
    echo "\tError string: " . xslt_error() . "\n";
    exit;
}
?>

Předcházející | Nahoru | Další
xslt_getopt | Domů | xslt_set_base


xslt_set_base

(PHP 4 >= 4.0.5)

xslt_set_base — Set the base URI for all XSLT transformations

Popis

void xslt_set_base ( resource $xh, string $uri )

Sets the base URI for all XSLT transformations, the base URI is used with Xpath instructions to resolve document() and other commands which access external resources. It is also used to resolve URIs for the <xsl:include> and <xsl:import> elements.

Seznam parametrů

xh

The XSLT processor link identifier, created with xslt_create().

uri

The base URI to be used.

Návratové hodnoty

Nevrací se žádná hodnota.

ChangeLog (záznam změn)

Verze | Popis
4.3.0 | As of PHP 4.3.0, the default base URI is the directory of the executing script. In effect, it is the directory name value of the __FILE__ constant. The default base URI is less predictable with older versions.

Poznámky

Poznámka: Uvědomte si prosím, že pokud pracujete na Windows, je třeba na začátku cesty uvést file://.

Předcházející | Nahoru | Další
xslt_process | Domů | xslt_set_encoding


xslt_set_encoding

(PHP 4 >= 4.0.5)

xslt_set_encoding — Set the encoding for the parsing of XML documents

Popis

void xslt_set_encoding ( resource $xh, string $encoding )

Set the output encoding for the XSLT transformations. When using the Sablotron backend, this option is only available when you compile Sablotron with encoding support.

Seznam parametrů

xh

The XSLT processor link identifier, created with xslt_create().

encoding

An output encoding, e.g iso-8859-1.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
xslt_set_base | Domů | xslt_set_error_handler


xslt_set_error_handler

(PHP 4 >= 4.0.4)

xslt_set_error_handler — Set an error handler for a XSLT processor

Popis

void xslt_set_error_handler ( resource $xh, mixed $handler )

Set an error handler function for the XSLT processor given by xh, this function will be called whenever an error occurs in the XSLT transformation (this function is also called for notices).

Seznam parametrů

xh

The XSLT processor link identifier, created with xslt_create().

handler

The user function needs to accept four parameters: the XSLT processor, the error level, the error code and an array of messages. The function can be shown as: error_handler ( resource $xh, int $error_level, int $error_code, array $messages )

Návratové hodnoty

Nevrací se žádná hodnota.

Příklady

Příklad 2416. xslt_set_error_handler() Example

<?php

// Our XSLT error handler
function xslt_error_handler($handler, $errno, $level, $info)
{
  // for now, let's just see the arguments
  var_dump(func_get_args());
}

// XML content :
$xml='<?xml version="1.0"?>
<para>
 oops, I misspelled the closing tag
</pata>';

// XSL content :
$xsl='<?xml version="1.0"?>
<xsl:stylesheet version="1.0" xmlns:xsl="http://www.w3.org/1999/XSL/Transform">
<xsl:template match="/">
   <strong><xsl:value-of select="para"/></strong>
</xsl:template>
</xsl:stylesheet>';

$xh = xslt_create();

xslt_set_error_handler($xh, "xslt_error_handler");

echo xslt_process($xh, 'arg:/_xml', 'arg:/_xsl',
                  NULL, array("/_xml" => $xml, "/_xsl" => $xsl));

?>

Výše uvedený příklad vypíše něco jako:

array(4) {
  [0]=>
  resource(1) of type (XSLT Processor)
  [1]=>
  int(3)
  [2]=>
  int(0)
  [3]=>
  array(6) {
    ["msgtype"]=>
    string(5) "error"
    ["code"]=>
    string(1) "2"
    ["module"]=>
    string(9) "Sablotron"
    ["URI"]=>
    string(9) "arg:/_xml"
    ["line"]=>
    string(1) "4"
    ["msg"]=>
    string(34) "XML parser error 7: mismatched tag"
  }
}

Viz také

xslt_set_object() if you want to use an object method as handler

Předcházející | Nahoru | Další
xslt_set_encoding | Domů | xslt_set_log


xslt_set_log

(PHP 4 >= 4.0.6)

xslt_set_log — Set the log file to write log messages to

Popis

void xslt_set_log ( resource $xh [, mixed $log] )

This function allows you to set the file in which you want XSLT log messages to, XSLT log messages are different than error messages, in that log messages are not actually error messages but rather messages related to the state of the XSLT processor. They are useful for debugging XSLT, when something goes wrong.

By default logging is disabled, in order to enable logging you must first call xslt_set_log() with a boolean parameter which enables logging, then if you want to set the log file to debug to, you must then pass it a string containing the filename.

Seznam parametrů

xh

The XSLT processor link identifier, created with xslt_create().

log

This parameter is either a boolean value which toggles logging on and off, or a string containing the logfile in which log errors too.

Návratové hodnoty

Nevrací se žádná hodnota.

Poznámky

Poznámka: Uvědomte si prosím, že pokud pracujete na Windows, je třeba na začátku cesty uvést file://.

Příklady

Příklad 2417. Using the XSLT Logging features

<?php

$xh = xslt_create();
xslt_set_log($xh, true);
xslt_set_log($xh, getcwd() . '/myfile.log');

$result = xslt_process($xh, 'dog.xml', 'pets.xsl');
echo $result;

xslt_free($xh);
?>

Předcházející | Nahoru | Další
xslt_set_error_handler | Domů | xslt_set_object


xslt_set_object

(PHP 4 >= 4.3.0)

xslt_set_object — Sets the object in which to resolve callback functions

Popis

bool xslt_set_object ( resource $processor, object &$obj )

This function allows to use the processor inside an object and to resolve all callback functions in it.

The callback functions can be declared with xml_set_sax_handlers(), xslt_set_scheme_handlers() or xslt_set_error_handler() and are assumed to be methods of object.

Seznam parametrů

processor

The XSLT processor link identifier, created with xslt_create().

obj

An object.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 2418. Using your own error handler as a method

<?php

class my_xslt_processor {

    var $_xh; // our XSLT processor

    function my_xslt_processor()
    {
        $this->_xh = xslt_create();

        // Make $this object the callback resolver
        xslt_set_object($this->_xh, $this);

        // Let's handle the errors
        xslt_set_error_handler($this->_xh, "my_xslt_error_handler");
    }

    function my_xslt_error_handler($handler, $errno, $level, $info)
    {
        // for now, let's just see the arguments
        var_dump(func_get_args());
    }
}

?>

Předcházející | Nahoru | Další
xslt_set_log | Domů | xslt_set_sax_handler


xslt_set_sax_handler

(PHP 4 >= 4.0.3)

xslt_set_sax_handler — Určit SAX handlery XSLT procesoru

Popis

void xslt_set_sax_handler ( resource $xh, array $handlers )

Určit SAX handlery pro handle určený v xh.

Předcházející | Nahoru | Další
xslt_set_object | Domů | xslt_set_sax_handlers


xslt_set_sax_handlers

(PHP 4 >= 4.0.6)

xslt_set_sax_handlers — Set the SAX handlers to be called when the XML document gets processed

Popis

void xslt_set_sax_handlers ( resource $processor, array $handlers )

xslt_set_sax_handlers() registers the SAX handlers for the document, given a XSLT processor resource.

Using xslt_set_sax_handlers() doesn't look very different than running a SAX parser like xml_parse() on the result of an xslt_process() transformation.

Seznam parametrů

processor

The XSLT processor link identifier, created with xslt_create().

handlers

handlers should be an array in the following format:

<?php

$handlers = array(

  "document" => array(
    "start_doc",
    "end_doc"),

  "element"  => array(
    "start_element",
    "end_element"),

  "namespace" => array(
    "start_namespace",
    "end_namespace"),

  "comment"   => "comment",

  "pi"        => "pi",

  "character" => "characters"

);
?>

Where the functions follow the syntax described for the scheme handler functions.

Poznámka: The given array does not need to contain all of the different sax handler elements (although it can), but it only needs to conform to "handler" => "function" format described above.

Each of the individual SAX handler functions are in the format below:

  • start_doc ( resource $processor )

  • end_doc ( resource $processor )

  • start_element ( resource $processor, string $name, array $attributes )

  • end_element ( resource $processor, string $name )

  • start_namespace ( resource $processor, string $prefix, string $uri )

  • end_namespace ( resource $processor, string $prefix )

  • comment ( resource $processor, string $contents )

  • pi ( resource $processor, string $target, string $contents )

  • characters ( resource $processor, string $contents )

Návratové hodnoty

Nevrací se žádná hodnota.

Příklady

Příklad 2419. xslt_set_sax_handlers() Example

<?php
// From ohlesbeauxjours at yahoo dot fr
// Here's a simple example that applies strtoupper() on
// the content of every <auteur> tag and then displays the
// resulting XML tree:

$xml='<?xml version="1.0"?>
<books>
 <book>
  <title>Mme Bovary</title>
  <author>Gustave Flaubert</author>
 </book>
 <book>
  <title>Mrs Dalloway</title>
  <author>Virginia Woolf</author>
 </book>
</books>';

$xsl='<?xml version="1.0"?>
<xsl:stylesheet version="1.0" xmlns:xsl="http://www.w3.org/1999/XSL/Transform">
<xsl:output method="html" encoding="ISO-8859-1" indent="no" omit-xml-declaration="yes"/>
<xsl:template match="/">
 <xsl:for-each select="books/book">
  <livre>
   <auteur><xsl:value-of select="author/text()"/></auteur>
  </livre>
 </xsl:for-each>
</xsl:template>
</xsl:stylesheet>';

// Handlers :
function start_document()
{
  // start reading the document
}

function end_document()
{
  // end reading the document
}

function start_element($parser, $name, $attributes)
{
  global $result,$tag;
  $result .= "<". $name . ">";
  $tag = $name;
}

function end_element($parser, $name)
{
  global $result;
  $result .= "</" . $name . ">";
}

function characters($parser, $data)
{
  global $result,$tag;
  if ($tag == "auteur" ) {
    $data = strtoupper($data);
  }
  $result .= $data;
}

// Transformation :
$xh = xslt_create();
$handlers = array("document" => array("start_document","end_document"),
   "element" => array("start_element","end_element"),
   "character" => "characters");

xslt_set_sax_handlers($xh, $handlers);
xslt_process($xh, 'arg:/_xml', 'arg:/_xsl', NULL, array("/_xml"=>$xml, "/_xsl"=>$xsl));
xslt_free($xh);
?>

You can also use xslt_set_object() if you want to implement your handlers in an object.

Příklad 2420. Object oriented handler

<?php
// This is the object oriented version of the previous example
class data_sax_handler {

  var $buffer, $tag, $attrs;

  var $_xh;

  function data_sax_handler($xml, $xsl)
  {
      // our xslt resource
      $this->_xh = xslt_create();

      xslt_set_object($this->_xs, $this);

      // configure sax handlers
      $handlers = array(
        "document" => array('start_document', 'end_document'),
        "element" => array('start_element', 'end_element'),
        "character" => 'characters'
      );

      xslt_set_sax_handlers($this->_xh, $handlers);

      xslt_process($this->_xh, 'arg:/_xml', 'arg:/_xsl', NULL, array("/_xml"=>$xml, "/_xsl"=>$xsl));
      xslt_free($this->_xh);

  }

  function start_document()
  {
        // start reading the document
  }

  function end_document() {
        // complete reading the document
  }

  function start_element($parser, $name, $attributes) {
        $this->tag = $name;
        $this->buffer .= "<" . $name . ">";
        $this->attrs = $attributes;
  }

  function end_element($parser, $name)
  {
        $this->tag = '';
        $this->buffer .= "</" . $name . ">";
  }

  function characters($parser, $data)
  {
    if ($this->tag == 'auteur') {
          $data = strtoupper($data);
    }
    $this->buffer .= $data;
  }

  function get_buffer() {
    return $this->buffer;
  }

}

$exec = new data_sax_handler($xml, $xsl);

?>

Both examples will output:

<livre>
<auteur>GUSTAVE FLAUBERT</auteur>
</livre>
<livre>
<auteur>VIRGINIA WOOLF</auteur>
</livre>

Předcházející | Nahoru | Další
xslt_set_sax_handler | Domů | xslt_set_scheme_handler


xslt_set_scheme_handler

(PHP 4 >= 4.0.5)

xslt_set_scheme_handler — Set Scheme handlers for a XSLT processor

Popis

void xslt_set_scheme_handler ( resource $xh, array $handlers )

Set Scheme handlers on the resource handle given by xh.

Seznam parametrů

xh

The XSLT processor link identifier, created with xslt_create().

handlers

Scheme handlers should be an array with the format (all elements are optional):

array(
[get_all] => get all handler,
[open] => open handler,
[get] => get handler,
[put] => put handler,
[close] => close handler
)

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
xslt_set_sax_handlers | Domů | xslt_set_scheme_handlers


xslt_set_scheme_handlers

(PHP 4 >= 4.0.6)

xslt_set_scheme_handlers — Set the scheme handlers for the XSLT processor

Popis

void xslt_set_scheme_handlers ( resource $processor, array $handlers )

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
xslt_set_scheme_handler | Domů | xslt_setopt


xslt_setopt

(PHP 4 >= 4.3.0)

xslt_setopt — Set options on a given xsl processor

Popis

mixed xslt_setopt ( resource $processor, int $newmask )

xslt_setopt() sets the options specified by newmask on the given processor.

Seznam parametrů

processor

The XSLT processor link identifier, created with xslt_create().

newmask

newmask is a bitmask constructed with the following constants:

  • XSLT_SABOPT_PARSE_PUBLIC_ENTITIES - Tell the processor to parse public entities. By default this has been turned off.

  • XSLT_SABOPT_DISABLE_ADDING_META - Do not add the meta tag "Content-Type" for HTML output. The default is set during the compilation of the processor.

  • XSLT_SABOPT_DISABLE_STRIPPING - Suppress the whitespace stripping (on data files only).

  • XSLT_SABOPT_IGNORE_DOC_NOT_FOUND - Consider unresolved documents (the document() function) non-lethal.

Návratové hodnoty

Returns the number of previous mask is possible, TRUE otherwise, FALSE in case of an error.

Příklady

Příklad 2421. xslt_setopt() Example

<?php

$xh = xslt_create();

// Tell Sablotron to process public entities
xslt_setopt($xh, XSLT_SABOPT_PARSE_PUBLIC_ENTITIES);

// Let's also ask him to suppress whitespace stripping
xslt_setopt($xh, xslt_getopt($xh) | XSLT_SABOPT_DISABLE_STRIPPING);

?>

Viz také

xslt_getopt()

Předcházející | Nahoru | Další
xslt_set_scheme_handlers | Domů | CLXXXVI. YAZ Functions


YAZ Functions

Předcházející VI. Reference funkcí Další

CLXXXVI. YAZ Functions

Úvod

This extension offers a PHP interface to the YAZ toolkit that implements the » Z39.50 Protocol for Information Retrieval. With this extension you can easily implement a Z39.50 origin (client) that searches or scans Z39.50 targets (servers) in parallel.

The module hides most of the complexity of Z39.50 so it should be fairly easy to use. It supports persistent stateless connections very similar to those offered by the various RDB APIs that are available for PHP. This means that sessions are stateless but shared among users, thus saving the connect and initialize phase steps in most cases.

YAZ is available at » http://www.indexdata.dk/yaz/. You can find news information, example scripts, etc. for this extension at » http://www.indexdata.dk/phpyaz/.

Poznámka: Toto rozšíření bylo přesunuto do repozitáře PECL a již nebude součástí balíku PHP.5.0.0.

Instalace

Obtain YAZ (ANSI/NISO Z39.50 support) and install it. YAZ can be fetched in source or in various prebuilt packages from the » YAZ archive. Systems such as Debian GNU/Linux, Suse Linux, FreeBSD also has YAZ as part of their distribution.

For the PHP 4 series, the YAZ extension is bundled (but not YAZ itself) Build PHP with your favorite modules and add option --with-yaz[=DIR].

Příklad 2422. YAZ compilation for PHP 4 on Unix

gunzip -c php-4.4.X.tar.gz|tar xf -
gunzip -c yaz-2.1.8.tar.gz|tar xf -
cd yaz-2.1.8
./configure --prefix=/usr
make
sudo make install
cd ../php-4.4.X.
./configure --with-yaz=/usr/bin
make
sudo make install

For PHP 5, the YAZ extension is in » PECL and is installed as a shared object/dll. If you have pear installed the easiest way to download, configure and install the YAZ extension is by using the pecl command.

Installation of YAZ on Linux

Informace o instalaci tohoto PECL rozšíření lze najít v kapitole manuálu nazvané Instalace rozšíření PECL. Další informace, jako nové verze, soubory ke stažení, zdrojové soubory, správcovské informace a CHANGELOG, lze najít zde: » http://pecl.php.net/package/yaz

Installation on Windows systems

Tuto DLL knihovnu pro rozšíření PECL můžete stahovat ze stránky » PHP Downloads nebo z » http://snaps.php.net/. php_yaz.dll depends on yaz.dll. The yaz.dll is part of the Win32 ZIP from the PHP site. It is also part of the Windows YAZ install available from the » YAZ WIN32 area.

Varování

The PHP 5.0.5 Win32 zip includes a too old version of yaz.dll (version 1.9.1 < required version 2.0.13). If that's the case use the yaz.dll from a newer » YAZ WIN32 install.

On windows, don't forget to add the PHP directory to the PATH, so that the yaz.dll file can be found by the system.

If you are using YAZ as a shared extension, add (or uncomment) the following line in php.ini on Unix:

   extension=yaz.so
And for Windows:
   extension=php_yaz.dll

Varování

Rozšíření IMAP, recode, YAZ a Cyrus nelze používat současně, protože sdílejí stejný interní symbol.

Poznámka: The above problem is solved in version 2.0 of YAZ.

Konfigurace běhu

Chování těchto funkcí je ovlivněno nastavením parametrů v php.ini.

Tabulka 328. YAZ configuration options

Name | Default | Changeable | Changelog
yaz.max_links | "100" | PHP_INI_ALL | Available since PHP 4.3.0. Removed in PHP 5.0.0.
yaz.log_file | NULL | PHP_INI_ALL | Available since PHP 4.3.0. Removed in PHP 5.0.0.

Pro další detaily a definice konstant PHP_INI_*, viz dokumentace k ini_set().

Typy prostředků

Toto rozšíření nemá definován žádný typ prostředku (resource).

Předdefinované konstanty

Toto rozšíření nemá definovány žádné konstanty.

Příklady

PHP/YAZ keeps track of connections with targets (Z-Associations). A resource represents a connection to a target.

The script below demonstrates the parallel searching feature of the API. When invoked with no arguments it prints a query form; else (arguments are supplied) it searches the targets as given in array host.

Příklad 2423. Parallel searching using Yaz

<?php
$host=$_REQUEST[host];
$query=$_REQUEST[query];
$num_hosts = count($host);
if (empty($query) || count($host) == 0) {
    echo '<form method="get">
    <input type="checkbox"
    name="host[]" value="bagel.indexdata.dk/gils" />
        GILS test
    <input type="checkbox"
    name="host[]" value="localhost:9999/Default" />
        local test
    <input type="checkbox" checked="checked"
    name="host[]" value="z3950.loc.gov:7090/voyager" />
        Library of Congress
    <br />
    RPN Query:
    <input type="text" size="30" name="query" />
    <input type="submit" name="action" value="Search" />
    </form>
    ';
} else {
    echo 'You searched for ' . htmlspecialchars($query) . '<br />';
    for ($i = 0; $i < $num_hosts; $i++) {
        $id[] = yaz_connect($host[$i]);
        yaz_syntax($id[$i], "usmarc");
        yaz_range($id[$i], 1, 10);
        yaz_search($id[$i], "rpn", $query);
    }
    yaz_wait();
    for ($i = 0; $i < $num_hosts; $i++) {
        echo '<hr />' . $host[$i] . ':';
        $error = yaz_error($id[$i]);
        if (!empty($error)) {
            echo "Error: $error";
        } else {
            $hits = yaz_hits($id[$i]);
            echo "Result Count $hits";
        }
        echo '<dl>';
        for ($p = 1; $p <= 10; $p++) {
            $rec = yaz_record($id[$i], $p, "string");
            if (empty($rec)) continue;
            echo "<dt><b>$p</b></dt><dd>";
            echo nl2br($rec);
            echo "</dd>";
        }
        echo '</dl>';
    }
}
?>

Obsah

yaz_addinfo — Returns additional error information
yaz_ccl_conf — Configure CCL parser
yaz_ccl_parse — Invoke CCL Parser
yaz_close — Close YAZ connection
yaz_connect — Prepares for a connection to a Z39.50 server
yaz_database — Specifies the databases within a session
yaz_element — Specifies Element-Set Name for retrieval
yaz_errno — Returns error number
yaz_error — Returns error description
yaz_es_result — Inspects Extended Services Result
yaz_es — Prepares for an Extended Service Request
yaz_get_option — Returns value of option for connection
yaz_hits — Returns number of hits for last search
yaz_itemorder — Prepares for Z39.50 Item Order with an ILL-Request package
yaz_present — Prepares for retrieval (Z39.50 present)
yaz_range — Specifies a range of records to retrieve
yaz_record — Returns a record
yaz_scan_result — Returns Scan Response result
yaz_scan — Prepares for a scan
yaz_schema — Specifies schema for retrieval
yaz_search — Prepares for a search
yaz_set_option — Sets one or more options for connection
yaz_sort — Sets sorting criteria
yaz_syntax — Specifies the preferred record syntax for retrieval
yaz_wait — Wait for Z39.50 requests to complete
Předcházející | Nahoru | Další
xslt_setopt | Domů | yaz_addinfo


yaz_addinfo

(PHP 4 >= 4.0.1, PECL yaz:0.9-1.0.9)

yaz_addinfo — Returns additional error information

Popis

string yaz_addinfo ( resource $id )

Returns additional error information for the last request on the server.

With some servers, this function may return the same string as yaz_error().

Seznam parametrů

id

The connection resource returned by yaz_connect().

Návratové hodnoty

A string containing additional error information or an empty string if the last operation was successful or if no additional information was provided by the server.

Viz také

yaz_error()
yaz_errno()

Předcházející | Nahoru | Další
CLXXXVI. YAZ Functions | Domů | yaz_ccl_conf


yaz_ccl_conf

(PHP 4 >= 4.0.5, PECL yaz:0.9-1.0.9)

yaz_ccl_conf — Configure CCL parser

Popis

void yaz_ccl_conf ( resource $id, array $config )

This function configures the CCL query parser for a server with definitions of access points (CCL qualifiers) and their mapping to RPN.

To map a specific CCL query to RPN afterwards call the yaz_ccl_parse() function.

Seznam parametrů

id

The connection resource returned by yaz_connect().

config

An array of configuration. Each key of the array is the name of a CCL field and the corresponding value holds a string that specifies a mapping to RPN.

The mapping is a sequence of attribute-type, attribute-value pairs. Attribute-type and attribute-value is separated by an equal sign (=). Each pair is separated by white space.

Additional information can be found on the » CCL page.

Návratové hodnoty

Nevrací se žádná hodnota.

Příklady

In the example below, the CCL parser is configured to support three CCL fields: ti, au and isbn. Each field is mapped to their BIB-1 equivalent. It is assumed that variable $id is the connection ID.

Příklad 2424. CCL configuration

<?php
$fields = array(
  "ti" => "1=4",
  "au"   => "1=1",
  "isbn" => "1=7"
);
yaz_ccl_conf($id, $fields);
?>

Viz také

yaz_ccl_parse()

Předcházející | Nahoru | Další
yaz_addinfo | Domů | yaz_ccl_parse


yaz_ccl_parse

(PHP 4 >= 4.0.5, PECL yaz:0.9-1.0.9)

yaz_ccl_parse — Invoke CCL Parser

Popis

bool yaz_ccl_parse ( resource $id, string $query, array &$result )

This function invokes a CCL parser. It converts a given CCL FIND query to an RPN query which may be passed to the yaz_search() function to perform a search.

To define a set of valid CCL fields call yaz_ccl_conf() prior to this function.

Seznam parametrů

id

The connection resource returned by yaz_connect().

query

The CCL FIND query.

result

If the function was executed successfully, this will be an array containing the valid RPN query under the key rpn.

Upon failure, three indexes are set in this array to indicate the cause of failure:

  • errorcode - the CCL error code (integer)

  • errorstring - the CCL error string

  • errorpos - approximate position in query of failure (integer is character position)

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 2425. CCL Parsing

We will try to search using CCL. In the example below, $ccl is a CCL query.

<?php

yaz_ccl_conf($id, $fields);  // see example for yaz_ccl_conf
if (!yaz_ccl_parse($id, $ccl, &$cclresult)) {
    echo 'Error: ' . $cclresult["errorstring"];
} else {
    $rpn = $cclresult["rpn"];
    yaz_search($id, "rpn", $rpn);
}
?>

Předcházející | Nahoru | Další
yaz_ccl_conf | Domů | yaz_close


yaz_close

(PHP 4 >= 4.0.1, PECL yaz:0.9-1.0.9)

yaz_close — Close YAZ connection

Popis

bool yaz_close ( resource $id )

Closes the connection given by parameter id.

Poznámka: This function will only close a non-persistent connection opened by setting the persistent option to FALSE with yaz_connect().

Seznam parametrů

id

The connection resource returned by yaz_connect().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

yaz_connect()

Předcházející | Nahoru | Další
yaz_ccl_parse | Domů | yaz_connect


yaz_connect

(PHP 4 >= 4.0.1, PECL yaz:0.9-1.0.9)

yaz_connect — Prepares for a connection to a Z39.50 server

Popis

mixed yaz_connect ( string $zurl [, mixed $options] )

This function returns a connection resource on success, zero on failure.

yaz_connect() prepares for a connection to a Z39.50 server. This function is non-blocking and does not attempt to establish a connection - it merely prepares a connect to be performed later when yaz_wait() is called.

Poznámka: The » YAZ proxy is a freely available Z39.50 proxy.

Seznam parametrů

zurl

A string that takes the form host[:port][/database]. If port is omitted, port 210 is used. If database is omitted Default is used.

options

If given as a string, it is treated as the Z39.50 V2 authentication string (OpenAuth).

If given as an array, the contents of the array serves as options.

user

Username for authentication.

group

Group for authentication.

password

Password for authentication.

cookie

Cookie for session (YAZ proxy).

proxy

Proxy for connection (YAZ proxy).

persistent

A boolean. If TRUE the connection is persistent; If FALSE the connection is not persistent. By default connections are persistent.

Poznámka: If you open a persistent connection, you won't be able to close it later with yaz_close().

piggyback

A boolean. If TRUE piggyback is enabled for searches; If FALSE piggyback is disabled. By default piggyback is enabled.

Enabling piggyback is more efficient and usually saves a network-round-trip for first time fetches of records. However, a few Z39.50 servers do not support piggyback or they ignore element set names. For those, piggyback should be disabled.

charset

A string that specifies character set to be used in Z39.50 language and character set negotiation. Use strings such as: ISO-8859-1, UTF-8, UTF-16.

Most Z39.50 servers do not support this feature (and thus, this is ignored). Many servers use the ISO-8859-1 encoding for queries and messages. MARC21/USMARC records are not affected by this setting.

preferredMessageSize

An integer that specifies the maximum byte size of all records to be returned by a target during retrieval. See the » Z39.50 standard for more information.

Poznámka: This option is supported in PECL YAZ 1.0.5 or later.

maximumRecordSize

An integer that specifies the maximum byte size of a single record to be returned by a target during retrieval. This entity is referred to as Exceptional-record-size in the » Z39.50 standard.

Poznámka: This option is supported in PECL YAZ 1.0.5 or later.

Návratové hodnoty

A connection resource on success, FALSE on error.

ChangeLog (záznam změn)

Verze | Popis
4.1.0 | The parameter options was added.

Viz také

yaz_close()

Předcházející | Nahoru | Další
yaz_close | Domů | yaz_database


yaz_database

(PHP 4 >= 4.0.6, PECL yaz:0.9-1.0.9)

yaz_database — Specifies the databases within a session

Popis

bool yaz_database ( resource $id, string $databases )

This function allows you to change databases within a session by specifying one or more databases to be used in search, retrieval, etc. - overriding databases specified in call to yaz_connect().

Seznam parametrů

id

The connection resource returned by yaz_connect().

databases

A string containing one or more databases. Multiple databases are separated by a plus sign +.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
yaz_connect | Domů | yaz_element


yaz_element

(PHP 4 >= 4.0.1, PECL yaz:0.9-1.0.9)

yaz_element — Specifies Element-Set Name for retrieval

Popis

bool yaz_element ( resource $id, string $elementset )

This function sets the element set name for retrieval.

Call this function before yaz_search() or yaz_present() to specify the element set name for records to be retrieved.

Poznámka: If this function seems effectless, see the description of the piggybacking option in yaz_connect().

Seznam parametrů

id

The connection resource returned by yaz_connect().

elementset

Most servers support F (for full records) and B (for brief records).

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
yaz_database | Domů | yaz_errno


yaz_errno

(PHP 4 >= 4.0.1, PECL yaz:0.9-1.0.9)

yaz_errno — Returns error number

Popis

int yaz_errno ( resource $id )

Returns an error number for the server (last request) identified by id.

yaz_errno() should be called after network activity for each server - (after yaz_wait() returns) to determine the success or failure of the last operation (e.g. search).

Seznam parametrů

id

The connection resource returned by yaz_connect().

Návratové hodnoty

Returns an error code. The error code is either a Z39.50 diagnostic code (usually a Bib-1 diagnostic) or a client side error code which is generated by PHP/YAZ itself, such as "Connect failed", "Init Rejected", etc.

Viz také

yaz_error()
yaz_addinfo()

Předcházející | Nahoru | Další
yaz_element | Domů | yaz_error


yaz_error

(PHP 4 >= 4.0.1, PECL yaz:0.9-1.0.9)

yaz_error — Returns error description

Popis

string yaz_error ( resource $id )

yaz_error() returns an English text message corresponding to the last error number as returned by yaz_errno().

Seznam parametrů

id

The connection resource returned by yaz_connect().

Návratové hodnoty

Returns an error text message for server (last request), identified by parameter id. An empty string is returned if the last operation was successful.

Viz také

yaz_errno()
yaz_addinfo()

Předcházející | Nahoru | Další
yaz_errno | Domů | yaz_es_result


yaz_es_result

(PHP 4 >= 4.2.0, PECL yaz:0.9-1.0.9)

yaz_es_result — Inspects Extended Services Result

Popis

array yaz_es_result ( resource $id )

This function inspects the last returned Extended Service result from a server. An Extended Service is initiated by either yaz_item_order() or yaz_es().

Seznam parametrů

id

The connection resource returned by yaz_connect().

Návratové hodnoty

Returns array with element targetReference for the reference for the extended service operation (generated and returned from the server).

Viz také

yaz_es()

Předcházející | Nahoru | Další
yaz_error | Domů | yaz_es


yaz_get_option

(PECL yaz:0.9-1.0.9)

yaz_get_option — Returns value of option for connection

Popis

string yaz_get_option ( resource $id, string $name )

Returns the value of the option specified with name.

Seznam parametrů

id

The connection resource returned by yaz_connect().

name

The option name.

Návratové hodnoty

Returns the value of the specified option or an empty string if the option wasn't set.

Viz také

The description of yaz_set_option() for available options

Předcházející | Nahoru | Další
yaz_es | Domů | yaz_hits


yaz_hits

(PHP 4 >= 4.0.1, PECL yaz:0.9-1.0.9)

yaz_hits — Returns number of hits for last search

Popis

int yaz_hits ( resource $id [, array &$searchresult] )

yaz_hits() returns the number of hits for the last search.

Seznam parametrů

id

The connection resource returned by yaz_connect().

searchresult

Result array for detailed search result information.

Návratové hodnoty

Returns the number of hits for the last search or 0 if no search was performed.

The search result array (if supplied) holds information that is returned by a Z39.50 server in the SearchResult-1 format part of a search response. The SearchResult-1 format can be used to obtain information about hit counts for various parts of the query (subquery). In particular, it is possible to obtain hit counts for the individual search terms in a query. Information for first subquery is in $array[0], second subquery in $array[1], and so forth.

Tabulka 329. searchresult members

Element | Description
id | Sub query ID2 (string)
count | Result count / hits (integer)
subquery.term | Sub query term (string)
interpretation.term | Interpretated sub query term (string)
recommendation.term | Recommended sub query term (string)

Poznámka: The SearchResult facility requires PECL YAZ 1.0.5 or later and YAZ 2.1.9 or later.

Poznámka: Very few Z39.50 implementations support the SearchResult facility.

Předcházející | Nahoru | Další
yaz_get_option | Domů | yaz_itemorder


yaz_itemorder

(PHP 4 >= 4.0.5, PECL yaz:0.9-1.0.9)

yaz_itemorder — Prepares for Z39.50 Item Order with an ILL-Request package

Popis

void yaz_itemorder ( resource $id, array $args )

This function prepares for an Extended Services request using the Profile for the Use of Z39.50 Item Order Extended Service to Transport ILL (Profile/1). See » this and the » specification.

Seznam parametrů

id

The connection resource returned by yaz_connect().

args

Must be an associative array with information about the Item Order request to be sent. The key of the hash is the name of the corresponding ASN.1 tag path. For example, the ISBN below the Item-ID has the key item-id,ISBN.

The ILL-Request parameters are:

protocol-version-num
transaction-id,initial-requester-id,person-or-institution-symbol,person
transaction-id,initial-requester-id,person-or-institution-symbol,institution
transaction-id,initial-requester-id,name-of-person-or-institution,name-of-person
transaction-id,initial-requester-id,name-of-person-or-institution,name-of-institution
transaction-id,transaction-group-qualifier
transaction-id,transaction-qualifier
transaction-id,sub-transaction-qualifier
service-date-time,this,date
service-date-time,this,time
service-date-time,original,date
service-date-time,original,time
requester-id,person-or-institution-symbol,person
requester-id,person-or-institution-symbol,institution
requester-id,name-of-person-or-institution,name-of-person
requester-id,name-of-person-or-institution,name-of-institution
responder-id,person-or-institution-symbol,person
responder-id,person-or-institution-symbol,institution
responder-id,name-of-person-or-institution,name-of-person
responder-id,name-of-person-or-institution,name-of-institution
transaction-type
delivery-address,postal-address,name-of-person-or-institution,name-of-person
delivery-address,postal-address,name-of-person-or-institution,name-of-institution
delivery-address,postal-address,extended-postal-delivery-address
delivery-address,postal-address,street-and-number
delivery-address,postal-address,post-office-box
delivery-address,postal-address,city
delivery-address,postal-address,region
delivery-address,postal-address,country
delivery-address,postal-address,postal-code
delivery-address,electronic-address,telecom-service-identifier
delivery-address,electronic-address,telecom-service-addreess
billing-address,postal-address,name-of-person-or-institution,name-of-person
billing-address,postal-address,name-of-person-or-institution,name-of-institution
billing-address,postal-address,extended-postal-delivery-address
billing-address,postal-address,street-and-number
billing-address,postal-address,post-office-box
billing-address,postal-address,city
billing-address,postal-address,region
billing-address,postal-address,country
billing-address,postal-address,postal-code
billing-address,electronic-address,telecom-service-identifier
billing-address,electronic-address,telecom-service-addreess
ill-service-type
requester-optional-messages,can-send-RECEIVED
requester-optional-messages,can-send-RETURNED
requester-optional-messages,requester-SHIPPED
requester-optional-messages,requester-CHECKED-IN
search-type,level-of-service
search-type,need-before-date
search-type,expiry-date
search-type,expiry-flag
place-on-hold
client-id,client-name
client-id,client-status
client-id,client-identifier
item-id,item-type
item-id,call-number
item-id,author
item-id,title
item-id,sub-title
item-id,sponsoring-body
item-id,place-of-publication
item-id,publisher
item-id,series-title-number
item-id,volume-issue
item-id,edition
item-id,publication-date
item-id,publication-date-of-component
item-id,author-of-article
item-id,title-of-article
item-id,pagination
item-id,ISBN
item-id,ISSN
item-id,additional-no-letters
item-id,verification-reference-source
copyright-complicance
retry-flag
forward-flag
requester-note
forward-note

There are also a few parameters that are part of the Extended Services Request package and the ItemOrder package:

package-name
user-id
contact-name
contact-phone
contact-email
itemorder-item

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
yaz_hits | Domů | yaz_present


yaz_present

(PHP 4 >= 4.0.5, PECL yaz:0.9-1.0.9)

yaz_present — Prepares for retrieval (Z39.50 present)

Popis

bool yaz_present ( resource $id )

This function prepares for retrieval of records after a successful search.

The yaz_range() function should be called prior to this function to specify the range of records to be retrieved.

Seznam parametrů

id

The connection resource returned by yaz_connect().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
yaz_itemorder | Domů | yaz_range


yaz_range

(PHP 4 >= 4.0.1, PECL yaz:0.9-1.0.9)

yaz_range — Specifies a range of records to retrieve

Popis

void yaz_range ( resource $id, int $start, int $number )

Specifies a range of records to retrieve.

This function should be called before yaz_search() or yaz_present().

Seznam parametrů

id

The connection resource returned by yaz_connect().

start

Specifies the position of the first record to be retrieved. The records numbers goes from 1 to yaz_hits().

number

Specifies the number of records to be retrieved.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
yaz_present | Domů | yaz_record


yaz_record

(PHP 4 >= 4.0.1, PECL yaz:0.9-1.0.9)

yaz_record — Returns a record

Popis

string yaz_record ( resource $id, int $pos, string $type )

The yaz_record() function inspects a record in the current result set at the position specified by parameter pos.

Seznam parametrů

id

The connection resource returned by yaz_connect().

pos

The record position. Records positions in a result set are numbered 1, 2, ... $hits where $hits is the count returned by yaz_hits().

type

The type specifies the form of the returned record.

Poznámka: It is the application which is responsible for actually ensuring that the records are returned from the Z39.50/SRW server in the proper format. The type given only specifies a conversion to take place on the client side (in PHP/YAZ).

Besides conversion of the transfer record to a string/array, PHP/YAZ it is also possible to perform a character set conversion of the record. Especially for USMARC/MARC21 that is recommended since these are typically returned in the character set MARC-8 that is not supported by browsers, etc. To specify a conversion, add ; charset=from, to where from is the original character set of the record and to is the resulting character set (as seen by PHP).

string

The record is returned as a string for simple display. In this mode, all MARC records are converted to a line-by-line format since ISO2709 is hardly readable. XML records and SUTRS are returned in their original format. GRS-1 are returned in a (ugly) line-by-line format.

This format is suitable if records are to be displayed in a quick way - for debugging - or because it is not feasible to perform proper display.

xml

The record is returned as an XML string if possible. In this mode, all MARC records are converted to » MARCXML. XML records and SUTRS are returned in their original format. GRS-1 is not supported.

This format is similar to string except that MARC records are converted to MARCXML

This format is suitable if records are processed by an XML parser or XSLT processor afterwards.

raw

The record is returned as a string in its original form. This type is suitable for MARC, XML and SUTRS. It does not work for GRS-1.

MARC records are returned as a ISO2709 string. XML and SUTRS are returned as strings.

syntax

The syntax of the record is returned as a string, i.e. USmarc, GRS-1, XML, etc.

database

The name of database associated with record at the position is returned as a string.

array

The record is returned as an array that reflects the GRS-1 structure. This type is suitable for MARC and GRS-1. XML, SUTRS are not supported and if the actual record is XML or SUTRS an empty string will be returned.

The array returned consists of a list corresponding to each leaf/internal node of GRS-1. Each list item consists a sub list with first element path and data (if data is available).

The path which is a string holds a list of each tree component (of the structured GRS-1 record) from root to leaf. Each component is a tag type, tag value pair of the form (type, value

String tags normally has a corresponding tag type 3. MARC can also be returned as an array (they are converted to GRS-1 internally).

Návratové hodnoty

Returns the record at position pos or an empty string if no record exists at the given position.

If no database record exists at the given position an empty string is returned.

Příklady

Příklad 2427. Array for GRS-1 record

Consider this GRS-1 record:

(4,52)Robert M. Pirsig
(4,70)
      (4,90)
            (2,7)Transworld Publishers, ltd.
This record has two nodes at root level. First element at root level is (4,52) [tag type 4, tag value 52], and has data Robert M. Pirsig. Second element at root level (4,70) has a subtree with a single element (4,90). (4,90) has yet another sub tree (2,7) with data Transworld Publishers, ltd..

If this record is present at position $p, then <?php

$ar = yaz_record($id, $p, "array");
print_r($ar);

?> will output:

Array
(
    [0] => Array
        (
            [0] => (4,52)
            [1] => Robert M. Pirsig
        )
    [1] => Array
        (
            [0] => (4,70)
        )
    [2] => Array
        (
            [0] => (4,70)(4,90)
        )
    [3] => Array
        (
            [0] => (4,70)(4,90)(2,7)
            [1] => Transworld Publishers, ltd.
        )
)

Příklad 2428. Working with MARCXML

The following PHP snippet returns a MARC21/USMARC record as MARCXML. The original record is returned in marc-8 (unknown to most XML parsers), so we convert it to UTF-8 (which all XML parsers must support). <?php
$rec = yaz_record($id, $p, "xml; charset=marc-8,utf-8");
?>

The record $rec can be processed with the Sablotron XSLT processor as follows:

<?php

$xslfile = 'display.xsl';
$processor = xslt_create();
$parms = array('/_xml' => $rec);
$res = xslt_process($processor, 'arg:/_xml', $xslfile, NULL, $parms);
xslt_free($processor);
$res = preg_replace("'</?html[^>]*>'", '', $res);
echo $res;

?>

For PHP 5 the XSL extension must be used instead of Sablotron XSLT.

Předcházející | Nahoru | Další
yaz_range | Domů | yaz_scan_result


yaz_scan_result

(PHP 4 >= 4.0.5, PECL yaz:0.9-1.0.9)

yaz_scan_result — Returns Scan Response result

Popis

array yaz_scan_result ( resource $id [, array &$result] )

yaz_scan_result() returns terms and associated information as received from the server in the last performed yaz_scan().

Seznam parametrů

id

The connection resource returned by yaz_connect().

result

If given, this array will be modified to hold additional information taken from the Scan Response:

  • number - Number of entries returned

  • stepsize - Step size

  • position - Position of term

  • status - Scan status

Návratové hodnoty

Returns an array (0..n-1) where n is the number of terms returned. Each value is a pair where the first item is the term, and the second item is the result-count.

Předcházející | Nahoru | Další
yaz_record | Domů | yaz_scan


yaz_scan

(PHP 4 >= 4.0.5, PECL yaz:0.9-1.0.9)

yaz_scan — Prepares for a scan

Popis

void yaz_scan ( resource $id, string $type, string $startterm [, array $flags] )

This function prepares for a Z39.50 Scan Request on the specified connection.

To actually transfer the Scan Request to the server and receive the Scan Response, yaz_wait() must be called. Upon completion of yaz_wait() call yaz_error() and yaz_scan_result() to handle the response.

Seznam parametrů

id

The connection resource returned by yaz_connect().

type

Currently only type rpn is supported.

startterm

Starting term point for the scan.

The form in which the starting term is specified is given by parameter type.

The syntax this parameter is similar to the RPN query as described in yaz_search(). It consists of zero or more @attr-operator specifications, then followed by exactly one token.

flags

This optional parameter specifies additional information to control the behaviour of the scan request. Three indexes are currently read from the flags array: number (number of terms requested), position (preferred position of term) and stepSize (preferred step size).

Návratové hodnoty

Nevrací se žádná hodnota.

Příklady

Příklad 2429. PHP function that scans titles

<?php
function scan_titles($id, $startterm)
{
  yaz_scan($id, "rpn", "@attr 1=4 " . $startterm);
  yaz_wait();
  $errno = yaz_errno($id);
  if ($errno == 0) {
    $ar = yaz_scan_result($id, &$options);
    echo 'Scan ok; ';
    foreach ($options as $key => $val) {
      echo "$key = $val &nbsp;";
    }
    echo '<br /><table>';
    while (list($key, list($k, $term, $tcount)) = each($ar)) {
      if (empty($k)) continue;
      echo "<tr><td>$term</td><td>$tcount</td></tr>";
    }
    echo '</table>';
  } else {
    echo "Scan failed. Error: " . yaz_error($id) . "<br />";
  }
}
?>

Předcházející | Nahoru | Další
yaz_scan_result | Domů | yaz_schema


yaz_schema

(PHP 4 >= 4.2.0, PECL yaz:0.9-1.0.9)

yaz_schema — Specifies schema for retrieval

Popis

void yaz_schema ( resource $id, string $schema )

yaz_schema() specifies the schema for retrieval.

This function should be called before yaz_search() or yaz_present().

Seznam parametrů

id

The connection resource returned by yaz_connect().

schema

Must be specified as an OID (Object Identifier) in a raw dot-notation (like 1.2.840.10003.13.4) or as one of the known registered schemas: GILS-schema, Holdings, Zthes, ...

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
yaz_scan | Domů | yaz_search


yaz_search

(PHP 4 >= 4.0.1, PECL yaz:0.9-1.0.9)

yaz_search — Prepares for a search

Popis

bool yaz_search ( resource $id, string $type, string $query )

yaz_search() prepares for a search on the given connection.

Like yaz_connect() this function is non-blocking and only prepares for a search to be executed later when yaz_wait() is called.

Seznam parametrů

id

The connection resource returned by yaz_connect().

type

This parameter represents the query type - only "rpn" is supported now in which case the third argument specifies a Type-1 query in prefix query notation.

query

The RPN query is a textual representation of the Type-1 query as defined by the Z39.50 standard. However, in the text representation as used by YAZ a prefix notation is used, that is the operator precedes the operands. The query string is a sequence of tokens where white space is ignored unless surrounded by double quotes. Tokens beginning with an at-character (@) are considered operators, otherwise they are treated as search terms.

Tabulka 330. RPN Operators

Construct | Description
@and query1 query2 | intersection of query1 and query2
@or query1 query2 | union of query1 and query2
@not query1 query2 | query1 and not query2
@set name | result set reference
@attrset set query | specifies attribute-set for query. This construction is only allowed once - in the beginning of the whole query
@attr [set] type=value query | applies attribute to query. The type and value are integers specifying the attribute-type and attribute-value respectively. The set, if given, specifies the attribute-set.

You can find information about attributes at the » Z39.50 Maintenance Agency site.

Poznámka: If you would like to use a more friendly notation, use the CCL parser - functions yaz_ccl_conf() and yaz_ccl_parse().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 2430. Query Examples

You can search for simple terms, like this:

computer
which matches documents where "computer" occur. No attributes are specified.

The query

"knuth donald"
matches documents where "knuth donald" occur (provided that the server supports phrase search).

This query applies two attributes for the same phrase.

@attr 1=1003 @attr 4=1 "knuth donald"
First attribute is type 1 (Bib-1 use), attribute value is 1003 (Author). Second attribute has is type 4 (structure), value 1 (phrase), so this should match documents where Donald Knuth is author.

The query

@and @or a b @not @or c d e
would in infix notation look like (a or b) and ((c or d) not e).

Another, more complex, one:

@attrset gils @and @attr 1=4 art @attr 1=2000 company
The query as a whole uses the GILS attributeset. The query matches documents where art occur in the title (GILS,BIB-1) and in which company occur as Distributor (GILS).

Předcházející | Nahoru | Další
yaz_schema | Domů | yaz_set_option


yaz_set_option

(PECL yaz:0.9-1.0.9)

yaz_set_option — Sets one or more options for connection

Popis

void yaz_set_option ( resource $id, string $name, string $value )
void yaz_set_option ( resource $id, array $options )

Sets one or more options on the given connection.

Seznam parametrů

id

The connection resource returned by yaz_connect().

name or options

May be either a string or an array.

If given as a string, this will be the name of the option to set. You'll need to give it's value.

If given as an array, this will be an associative array (option name => option value).

Tabulka 331. PHP/YAZ Connection Options

Name | Description
implementationName | implementation name of server
implementationVersion | implementation version of server
implementationId | implementation ID of server
schema | schema for retrieval. By default, no schema is used. Setting this option is equivalent to using function yaz_schema()
preferredRecordSyntax | record syntax for retrieval. By default, no syntax is used. Setting this option is equivalent to using function yaz_syntax()
start | offset for first record to be retrieved via yaz_search() or yaz_present(). First record is numbered has a start value of 0. Second record has start value 1. Setting this option in combination with option count has the same effect as calling yaz_range() except that records are numbered from 1 in yaz_range()
count | maximum number of records to be retrieved via yaz_search() or yaz_present().
elementSetName | element-set-name for retrieval. Setting this option is equivalent to calling yaz_element().

value

The new value of the option. Use this only if the previous argument is a string.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
yaz_search | Domů | yaz_sort


yaz_sort

(PHP 4 >= 4.0.7, PECL yaz:0.9-1.0.9)

yaz_sort — Sets sorting criteria

Popis

void yaz_sort ( resource $id, string $criteria )

This function sets sorting criteria and enables Z39.50 Sort.

Call this function before yaz_search(). Using this function alone does not have any effect. When used in conjunction with yaz_search(), a Z39.50 Sort will be sent after a search response has been received and before any records are retrieved with Z39.50 Present (yaz_present().

Seznam parametrů

id

The connection resource returned by yaz_connect().

criteria

A string that takes the form field1 flags1 field2 flags2 where field1 specifies the primary attributes for sort, field2 seconds, etc..

The field specifies either a numerical attribute combinations consisting of type=value pairs separated by comma (e.g. 1=4,2=1) ; or the field may specify a plain string criteria (e.g. title. The flags is a sequence of the following characters which may not be separated by any white space.

Sort Flags

a

Sort ascending

d

Sort descending

i

Case insensitive sorting

s

Case sensitive sorting

Návratové hodnoty

Nevrací se žádná hodnota.

Příklady

Příklad 2431. Sort Criterias

To sort on Bib1 attribute title, case insensitive, and ascending you would use the following sort criteria:

1=4 ia

If the secondary sorting criteria should be author, case sensitive and ascending you would use:

1=4 ia 1=1003 sa

Předcházející | Nahoru | Další
yaz_set_option | Domů | yaz_syntax


yaz_syntax

(PHP 4 >= 4.0.1, PECL yaz:0.9-1.0.9)

yaz_syntax — Specifies the preferred record syntax for retrieval

Popis

void yaz_syntax ( resource $id, string $syntax )

yaz_syntax() specifies the preferred record syntax for retrieval

This function should be called before yaz_search() or yaz_present().

Seznam parametrů

id

The connection resource returned by yaz_connect().

syntax

The syntax must be specified as an OID (Object Identifier) in a raw dot-notation (like 1.2.840.10003.5.10) or as one of the known registered record syntaxes (sutrs, usmarc, grs1, xml, etc.).

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
yaz_sort | Domů | yaz_wait


yaz_wait

(PHP 4 >= 4.0.1, PECL yaz:0.9-1.0.9)

yaz_wait — Wait for Z39.50 requests to complete

Popis

mixed yaz_wait ( [array &$options] )

This function carries out networked (blocked) activity for outstanding
requests which have been prepared by the functions
yaz_connect(), yaz_search(),
yaz_present(), yaz_scan() and
yaz_itemorder().

yaz_wait() returns when all servers have either completed all requests or aborted (in case of errors).

Seznam parametrů

options

An associative array of options:

timeout

Sets timeout in seconds. If a server has not responded within the timeout it is considered dead and yaz_wait() returns. The default value for timeout is 15 seconds.

event

A boolean.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání. In event mode, returns resource or FALSE in case of an error.

Předcházející | Nahoru | Další
yaz_syntax | Domů | CLXXXVII. Funkce pro práci s YP/NIS


Funkce pro práci s YP/NIS

Předcházející VI. Reference funkcí Další

CLXXXVII. Funkce pro práci s YP/NIS

Úvod

NIS (dříve Yellow Pages) umožňuje síťovou správu důležitých administrativních souborů (např. soubory s hesly). Více informací viz NIS man stránka a » The Linux NIS(YP)/NYS/NIS+ HOWTO. Existuje také kniha » Managing NFS and NIS od Hala Sterna.

Poznámka: Toto rozšíření není k dispozici na platformách Windows.

Požadavky

None besides functions from standard Unix libraries which are always available (either libc or libnsl, configure will detect which one to use).

Instalace

Pokud chcete tyto funkce zprovoznit, musíte PHP zkonfigurovat s volbou --enable-yp (PHP 4).

Konfigurace běhu

Toto rozšíření nemá definováno žádné konfigurační direktivy.

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

YPERR_BADARGS (integer)
YPERR_BADDB (integer)
YPERR_BUSY (integer)
YPERR_DOMAIN (integer)
YPERR_KEY (integer)
YPERR_MAP (integer)
YPERR_NODOM (integer)
YPERR_NOMORE (integer)
YPERR_PMAP (integer)
YPERR_RESRC (integer)
YPERR_RPC (integer)
YPERR_YPBIND (integer)
YPERR_YPERR (integer)
YPERR_YPSERV (integer)
YPERR_VERS (integer)

Obsah

yp_all — Traverse the map and call a function on each entry
yp_cat — Return an array containing the entire map
yp_err_string — Returns the error string associated with the previous operation
yp_errno — Returns the error code of the previous operation
yp_first — Vrátit pvní klíč/hodnota pár mapy
yp_get_default_domain — Zjistit defaultní NIS doménu stroje
yp_master — Zjistit název master NIS serveru mapy
yp_match — Vrátit odpovídající záznam
yp_next — Vrátit další klíč/hodnota pár mapy
yp_order — Returns the order number for a map
Předcházející | Nahoru | Další
yaz_wait | Domů | yp_all


yp_all

(PHP 4 >= 4.0.6, PHP 5 <= 5.0.5)

yp_all — Traverse the map and call a function on each entry

Popis

void yp_all ( string $domain, string $map, string $callback )

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

domain

The NIS domain name.

map

The NIS map.

callback

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
CLXXXVII. Funkce pro práci s YP/NIS | Domů | yp_cat


yp_cat

(PHP 4 >= 4.0.6, PHP 5 <= 5.0.5)

yp_cat — Return an array containing the entire map

Popis

array yp_cat ( string $domain, string $map )

Returns all map entries.

Seznam parametrů

domain

The NIS domain name.

map

The NIS map.

Návratové hodnoty

Returns an array of all map entries, the maps key values as array indices and the maps entries as array data.

Předcházející | Nahoru | Další
yp_all | Domů | yp_err_string


yp_err_string

(PHP 4 >= 4.0.6, PHP 5 <= 5.0.5)

yp_err_string — Returns the error string associated with the previous operation

Popis

string yp_err_string ( int $errorcode )

yp_err_string() returns the error message associated with the previous operation. Useful to indicate what exactly went wrong.

Příklad 2432. Example for NIS errors

<?php
    echo "Error: " . yp_err_string();
?>

Viz také yp_errno().

Předcházející | Nahoru | Další
yp_cat | Domů | yp_errno


yp_errno

(PHP 4 >= 4.0.6, PHP 5 <= 5.0.5)

yp_errno — Returns the error code of the previous operation

Popis

int yp_errno ( void )

yp_errno() returns the error code of the previous operation.

Possible errors are:

1 args to function are bad
2 RPC failure - domain has been unbound
3 can't bind to server on this domain
4 no such map in server's domain
5 no such key in map
6 internal yp server or client error
7 resource allocation failure
8 no more records in map database
9 can't communicate with portmapper
10 can't communicate with ypbind
11 can't communicate with ypserv
12 local domain name not set
13 yp database is bad
14 yp version mismatch
15 access violation
16 database busy

Viz také yp_err_string().

Předcházející | Nahoru | Další
yp_err_string | Domů | yp_first


yp_first

(PHP 4, PHP 5 <= 5.0.5)

yp_first — Vrátit pvní klíč/hodnota pár mapy

Popis

array yp_first ( string $domain, string $map )

yp_first() vrací první klíč/hodnota pár dané mapy v dané doméně, nebo FALSE.

Příklad 2433. Ukázka NIS first

<?php
    $entry = yp_first($domain, "passwd.byname");
    $key = key($entry);
    echo "První záznam v této mapě má klíč " . $key
          . " a hodnotu " . $entry[$key];
?>

Viz také yp-get-default-domain()

Předcházející | Nahoru | Další
yp_errno | Domů | yp_get_default_domain


yp_get_default_domain

(PHP 4, PHP 5 <= 5.0.5)

yp_get_default_domain — Zjistit defaultní NIS doménu stroje

Popis

string yp_get_default_domain ( void )

yp_get_default_domain() vrací defaultní doménu uzlu nebo FALSE. Dá se používat jako argument domény v následných voláních NIS.

NIS doména se dá popsat jako skupina map NIS. Každý server, který potřebuje vyhledat informace se připojí k určité doméně. Detailnější informace viz dokumentace zmíněná v úvodu.

Příklad 2434. Ukázka defaultní domény

<?php
$domain = yp_get_default_domain();
echo "Defaultní NIS doména je: " . $domain;
?>

Předcházející | Nahoru | Další
yp_first | Domů | yp_master


yp_master

(PHP 4, PHP 5 <= 5.0.5)

yp_master — Zjistit název master NIS serveru mapy

Popis

string yp_master ( string $domain, string $map )

yp_master() vrací název master NIS serveru určité mapy.

Příklad 2435. Ukázka NIS masteru

<?php
$number = yp_master ($domain, $mapname);
echo "Master této mapy je: " . $master;
?>

Viz také yp-get-default-domain().

Předcházející | Nahoru | Další
yp_get_default_domain | Domů | yp_match


yp_match

(PHP 4, PHP 5 <= 5.0.5)

yp_match — Vrátit odpovídající záznam

Popis

string yp_match ( string $domain, string $map, string $key )

yp_match() vrací hodnotu asociovanou v dané mapě s předaným klíčem nebo FALSE. Klíč musí být dán přesně.

Příklad 2436. Ukázka NIS match

<?php
$entry = yp_match ($domain, "passwd.byname", "joe");
echo "Odpovídající záznam je: " . $entry;
?>

V tomto případě by to mohlo být: joe:##joe:11111:100:Joe User:/home/j/joe:/usr/local/bin/bash

Viz také yp-get-default-domain()

Předcházející | Nahoru | Další
yp_master | Domů | yp_next


yp_next

(PHP 4, PHP 5 <= 5.0.5)

yp_next — Vrátit další klíč/hodnota pár mapy

Popis

array yp_next ( string $domain, string $map, string $key )

yp_next() vrací další klíč/hodnota pár v mapě po daném klíči, nebo FALSE.

Příklad 2437. Ukázka NIS next

<?php
$entry = yp_next ($domain, "passwd.byname", "joe");

if (!$entry) {
    echo yp_errno() . ": " . yp_err_string();
}

$key = key ($entry);

echo "Položka následující po joe má klíč " . $key
      . " a hodnotu " . $entry[$key];
?>

Viz také yp-get-default-domain().

Předcházející | Nahoru | Další
yp_match | Domů | yp_order


yp_order

(PHP 4, PHP 5 <= 5.0.5)

yp_order — Returns the order number for a map

Popis

int yp_order ( string $domain, string $map )

yp_order() vrací pořadové číslo mapy nebo FALSE.

Příklad 2438. Ukázka NIS order

<?php
    $number = yp_order($domain,$mapname);
    echo "Pořadové číslo této mapy je: " . $order;
?>

Viz také: yp-get-default-domain().

Předcházející | Nahoru | Další
yp_next | Domů | CLXXXVIII. Zip File Functions


Zip File Functions

Předcházející VI. Reference funkcí Další

CLXXXVIII. Zip File Functions

Úvod

This extension enables you to transparently read or write ZIP compressed archives and the files inside them.

Požadavky

PHP 4

The bundled PHP 4 version requires » ZZIPlib, by Guido Draheim, version 0.10.6 or later

PHP 5.2.0 or later

This extension uses the functions of » zlib by Jean-loup Gailly and Mark Adler.

Instalace

PHP 4

Poznámka: Zip support before PHP 4.1.0 is experimental.

Varování

Because the PHP 4 zip extension is unmaintained we recommend that the PECL extension is used rather than the bundled one.

Linux systems

In order to use these functions you must compile PHP with zip support by using the --with-zip[=DIR] configure option, where [DIR] is the prefix of the » ZZIPlib library install.

Windows

Windows users need to enable php_zip.dll inside of php.ini in order to use these functions.

PHP 5.2.0 and later

Linux systems

In order to use these functions you must compile PHP with zip support by using the --enable-zip configure option.

Windows

Windows users need to enable php_zip.dll inside of php.ini in order to use these functions.

Installation via PECL

Informace o instalaci tohoto PECL rozšíření lze najít v kapitole manuálu nazvané Instalace rozšíření PECL. Další informace, jako nové verze, soubory ke stažení, zdrojové soubory, správcovské informace a CHANGELOG, lze najít zde: » http://pecl.php.net/package/zip.

Tuto DLL knihovnu pro rozšíření PECL můžete stahovat ze stránky » PHP Downloads nebo z » http://snaps.php.net/.

V PHP 4 je tato DLL knihovna umístěna v adresáři extensions/ v downloadu binárních souborů PHP pro Windows.

Konfigurace běhu

Toto rozšíření nemá definováno žádné konfigurační direktivy.

Typy prostředků

There are two resource types used in the Zip module. The first one is the Zip directory for the Zip archive, the second Zip Entry for the archive entries.

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

ZipArchive uses class constants. There is three types of constants, Flags (FL_) errors (ER_) or mode (no prefix).

ZIPARCHIVE::CREATE (integer)
Create the archive if it does not exist.
ZIPARCHIVE::OVERWRITE (integer)
Always start a new archive, this mode will overwrite the file if it already exists.
ZIPARCHIVE::EXCL (integer)
Error if archive already exists.
ZIPARCHIVE::CHECKCONS (integer)
Perform additional consistency checks on the archive, and error if they fail.
ZIPARCHIVE::FL_NOCASE (integer)
Ignore case on name lookup
ZIPARCHIVE::FL_NODIR (integer)
Ignore directory component
ZIPARCHIVE::FL_COMPRESSED (integer)
Read compressed data
ZIPARCHIVE::FL_UNCHANGED (integer)
Use original data, ignoring changes.
ZIPARCHIVE::CM_DEFAULT (integer)
better of deflate or store.
ZIPARCHIVE::CM_STORE (integer)
stored (uncompressed).
ZIPARCHIVE::CM_SHRINK (integer)
shrunk
ZIPARCHIVE::CM_REDUCE_1 (integer)
reduced with factor 1
ZIPARCHIVE::CM_REDUCE_2 (integer)
reduced with factor 2
ZIPARCHIVE::CM_REDUCE_3 (integer)
reduced with factor 3
ZIPARCHIVE::CM_REDUCE_4 (integer)
reduced with factor 4
ZIPARCHIVE::CM_IMPLODE (integer)
imploded
ZIPARCHIVE::CM_DEFLATE (integer)
deflated
ZIPARCHIVE::CM_DEFLATE64 (integer)
deflate64
ZIPARCHIVE::CM_PKWARE_IMPLODE (integer)
PKWARE imploding
ZIPARCHIVE::CM_BZIP2 (integer)
BZIP2 algorithm
ZIPARCHIVE::ER_OK (integer)
No error.
ZIPARCHIVE::ER_MULTIDISK (integer)
Multi-disk zip archives not supported.
ZIPARCHIVE::ER_RENAME (integer)
Renaming temporary file failed.
ZIPARCHIVE::ER_CLOSE (integer)
Closing zip archive failed
ZIPARCHIVE::ER_SEEK (integer)
Seek error
ZIPARCHIVE::ER_READ (integer)
Read error
ZIPARCHIVE::ER_WRITE (integer)
Write error
ZIPARCHIVE::ER_CRC (integer)
CRC error
ZIPARCHIVE::ER_ZIPCLOSED (integer)
Containing zip archive was closed
ZIPARCHIVE::ER_NOENT (integer)
No such file.
ZIPARCHIVE::ER_EXISTS (integer)
File already exists
ZIPARCHIVE::ER_OPEN (integer)
Can't open file
ZIPARCHIVE::ER_TMPOPEN (integer)
Failure to create temporary file.
ZIPARCHIVE::ER_ZLIB (integer)
Zlib error
ZIPARCHIVE::ER_MEMORY (integer)
Memory allocation failure
ZIPARCHIVE::ER_CHANGED (string)
Entry has been changed
ZIPARCHIVE::ER_COMPNOTSUPP (integer)
Compression method not supported.
ZIPARCHIVE::ER_EOF (integer)
Premature EOF
ZIPARCHIVE::ER_INVAL (integer)
Invalid argument
ZIPARCHIVE::ER_NOZIP (integer)
Not a zip archive
ZIPARCHIVE::ER_INTERNAL (integer)
Internal error
ZIPARCHIVE::ER_INCONS (integer)
Zip archive inconsistent
ZIPARCHIVE::ER_REMOVE (integer)
Can't remove file
ZIPARCHIVE::ER_DELETED (integer)
Entry has been deleted

Příklady

Příklad 2439. Create a Zip archive

<?php

$zip = new ZipArchive();
$filename = "./test112.zip";

if ($zip->open($filename, ZIPARCHIVE::CREATE)!==TRUE) {
    exit("cannot open <$filename>\n");
}

$zip->addFromString("testfilephp.txt" . time(), "#1 This is a test string added as testfilephp.txt.\n");
$zip->addFromString("testfilephp2.txt" . time(), "#2 This is a test string added as testfilephp2.txt.\n");
$zip->addFile($thisdir . "/too.php","/testfromfile.php");
echo "numfiles: " . $zip->numFiles . "\n";
echo "status:" . $zip->status . "\n";
$zip->close();
?>

Příklad 2440. Dump the archive details and listing

<?php
$za = new ZipArchive();

$za->open('test_with_comment.zip');
print_r($za);
var_dump($za);
echo "numFiles: " . $za->numFiles . "\n";
echo "status: " . $za->status  . "\n";
echo "statusSys: " . $za->statusSys . "\n";
echo "filename: " . $za->filename . "\n";
echo "comment: " . $za->comment . "\n";

for ($i=0; $i<$za->numFiles;$i++) {
    echo "index: $i\n";
    print_r($za->statIndex($i));
}
echo "numFile:" . $za->numFiles . "\n";
?>

Příklad 2441. Zip stream wrapper, read an OpenOffice meta info

<?php
$reader = new XMLReader();

$reader->open('zip://' . dirname(__FILE__) . '/test.odt#meta.xml');
$odt_meta = array();
while ($reader->read()) {
    if ($reader->nodeType == XMLREADER::ELEMENT) {
        $elm = $reader->name;
    } else {
        if ($reader->nodeType == XMLREADER::END_ELEMENT && $reader->name == 'office:meta') {
            break;
        }
        if (!trim($reader->value)) {
            continue;
        }
        $odt_meta[$elm] = $reader->value;
    }
}
print_r($odt_meta);
?>

This example uses the old API (PHP 4), it opens a ZIP file archive, reads each file in the archive and prints out its contents. The test2.zip archive used in this example is one of the test archives in the ZZIPlib source distribution.

Příklad 2442. Zip Usage Example

<?php

$zip = zip_open("/tmp/test2.zip");

if ($zip) {
    while ($zip_entry = zip_read($zip)) {
        echo "Name:               " . zip_entry_name($zip_entry) . "\n";
        echo "Actual Filesize:    " . zip_entry_filesize($zip_entry) . "\n";
        echo "Compressed Size:    " . zip_entry_compressedsize($zip_entry) . "\n";
        echo "Compression Method: " . zip_entry_compressionmethod($zip_entry) . "\n";

        if (zip_entry_open($zip, $zip_entry, "r")) {
            echo "File Contents:\n";
            $buf = zip_entry_read($zip_entry, zip_entry_filesize($zip_entry));
            echo "$buf\n";

            zip_entry_close($zip_entry);
        }
        echo "\n";

    }

    zip_close($zip);

}
?>

Obsah

zip_close — Close a ZIP file archive
zip_entry_close — Close a directory entry
zip_entry_compressedsize — Retrieve the compressed size of a directory entry
zip_entry_compressionmethod — Retrieve the compression method of a directory entry
zip_entry_filesize — Retrieve the actual file size of a directory entry
zip_entry_name — Retrieve the name of a directory entry
zip_entry_open — Open a directory entry for reading
zip_entry_read — Read from an open directory entry
zip_open — Open a ZIP file archive
zip_read — Read next entry in a ZIP file archive
ZipArchive::addEmptyDir — Add a new directory
ZipArchive::addFile — Adds a file to a ZIP archive from the given path
ZipArchive::addFromString — Add a file to a ZIP archive using its contents
ZipArchive::close — Close the active archive (opened or newly created)
ZipArchive::deleteIndex — delete an entry in the archive using its index
ZipArchive::deleteName — delete an entry in the archive using its name
ZipArchive::extractTo — Extract the archive contents
ZipArchive::getArchiveComment — Returns the Zip archive comment
ZipArchive::getCommentIndex — Returns the comment of an entry using the entry index
ZipArchive::getCommentName — Returns the comment of an entry using the entry name
ZipArchive::getFromIndex — Returns the entry contents using its index.
ZipArchive::getFromName — Returns the entry contents using its name.
ZipArchive::getNameIndex — Returns the name of an entry using its index
ZipArchive::getStream — Get a file handler to the entry defined by its name (read only).
ZipArchive::locateName — Returns the index of the entry in the archive
ZipArchive::open — Open a ZIP file archive
ZipArchive::renameIndex — Renames an entry defined by its index
ZipArchive::renameName — Renames an entry defined by its name
ZipArchive::setArchiveComment — Set the comment of a ZIP archive
ZipArchive::setCommentIndex — Set the comment of an entry defined by its index
ZipArchive::setCommentName — Set the comment of an entry defined by its name
ZipArchive::statIndex — Get the details of an entry defined by its index.
ZipArchive::statName — Get the details of an entry defined by its name.
ZipArchive::unchangeAll — Undo all changes done in the archive.
ZipArchive::unchangeArchive — Revert all global changes done in the archive.
ZipArchive::unchangeIndex — Revert all changes done to an entry at the given index.
ZipArchive::unchangeName — Revert all changes done to an entry with the given name.
Předcházející | Nahoru | Další
yp_order | Domů | zip_close


zip_close

(PHP 4 >= 4.0.7, PHP 5 >= 5.2.0, PECL zip:1.0-1.9.0)

zip_close — Close a ZIP file archive

Popis

void zip_close ( resource $zip )

Closes the given ZIP file archive.

Seznam parametrů

zip

A ZIP file previously opened with zip_open().

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

zip_open()
zip_read()

Předcházející | Nahoru | Další
CLXXXVIII. Zip File Functions | Domů | zip_entry_close


zip_entry_close

(PHP 4 >= 4.0.7, PHP 5 >= 5.2.0, PECL zip:1.0-1.9.0)

zip_entry_close — Close a directory entry

Popis

bool zip_entry_close ( resource $zip_entry )

Closes the specified directory entry.

Seznam parametrů

zip_entry

A directory entry previously opened zip_entry_open().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

zip_entry_open()
zip_entry_read()

Předcházející | Nahoru | Další
zip_close | Domů | zip_entry_compressedsize


zip_entry_compressedsize

(PHP 4 >= 4.0.7, PHP 5 >= 5.2.0, PECL zip:1.0-1.9.0)

zip_entry_compressedsize — Retrieve the compressed size of a directory entry

Popis

int zip_entry_compressedsize ( resource $zip_entry )

Returns the compressed size of the specified directory entry.

Seznam parametrů

zip_entry

A directory entry returned by zip_read().

Návratové hodnoty

The compressed size.

Viz také

zip_open()
zip_read()

Předcházející | Nahoru | Další
zip_entry_close | Domů | zip_entry_compressionmethod


zip_entry_compressionmethod

(PHP 4 >= 4.0.7, PHP 5 >= 5.2.0, PECL zip:1.0-1.9.0)

zip_entry_compressionmethod — Retrieve the compression method of a directory entry

Popis

string zip_entry_compressionmethod ( resource $zip_entry )

Returns the compression method of the directory entry specified by zip_entry.

Seznam parametrů

zip_entry

A directory entry returned by zip_read().

Návratové hodnoty

The compression method.

Viz také

zip_open()
zip_read()

Předcházející | Nahoru | Další
zip_entry_compressedsize | Domů | zip_entry_filesize


zip_entry_filesize

(PHP 4 >= 4.0.7, PHP 5 >= 5.2.0, PECL zip:1.0-1.9.0)

zip_entry_filesize — Retrieve the actual file size of a directory entry

Popis

int zip_entry_filesize ( resource $zip_entry )

Returns the actual size of the specified directory entry.

Seznam parametrů

zip_entry

A directory entry returned by zip_read().

Návratové hodnoty

The size of the directory entry.

Viz také

zip_open()
zip_read()

Předcházející | Nahoru | Další
zip_entry_compressionmethod | Domů | zip_entry_name


zip_entry_name

(PHP 4 >= 4.0.7, PHP 5 >= 5.2.0, PECL zip:1.0-1.9.0)

zip_entry_name — Retrieve the name of a directory entry

Popis

string zip_entry_name ( resource $zip_entry )

Returns the name of the specified directory entry.

Seznam parametrů

zip_entry

A directory entry returned by zip_read().

Návratové hodnoty

The name of the directory entry.

Viz také

zip_open()
zip_read()

Předcházející | Nahoru | Další
zip_entry_filesize | Domů | zip_entry_open


zip_entry_open

(PHP 4 >= 4.0.7, PHP 5 >= 5.2.0, PECL zip:1.0-1.9.0)

zip_entry_open — Open a directory entry for reading

Popis

bool zip_entry_open ( resource $zip, resource $zip_entry [, string $mode] )

Opens a directory entry in a zip file for reading.

Seznam parametrů

zip

A valid resource handle returned by zip_open().

zip_entry

A directory entry returned by zip_read().

mode

Any of the modes specified in the documentation of fopen().

Poznámka: Currently, mode is ignored and is always "rb". This is due to the fact that zip support in PHP is read only access.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Poznámka: Unlike fopen() and other similar functions, the return value of zip_entry_open() only indicates the result of the operation and is not needed for reading or closing the directory entry.

Viz také

zip_entry_close()
zip_entry_read()

Předcházející | Nahoru | Další
zip_entry_name | Domů | zip_entry_read


zip_entry_read

(PHP 4 >= 4.0.7, PHP 5 >= 5.2.0, PECL zip:1.0-1.9.0)

zip_entry_read — Read from an open directory entry

Popis

string zip_entry_read ( resource $zip_entry [, int $length] )

Reads from an open directory entry.

Seznam parametrů

zip_entry

A directory entry returned by zip_read().

length

The number of bytes to return. If not specified, this function will attempt to read 1024 bytes.

Poznámka: This should be the uncompressed length you wish to read.

Návratové hodnoty

Returns the data read, or FALSE if the end of the file is reached.

Viz také

zip_entry_open()
zip_entry_close()
zip_entry_filesize()

Předcházející | Nahoru | Další
zip_entry_open | Domů | zip_open


zip_open

(PHP 4 >= 4.0.7, PHP 5 >= 5.2.0, PECL zip:1.0-1.9.0)

zip_open — Open a ZIP file archive

Popis

mixed zip_open ( string $filename )

Opens a new zip archive for reading.

Seznam parametrů

filename

The file name of the ZIP archive to open.

Návratové hodnoty

Returns a resource handle for later use with zip_read() and zip_close() or returns the number of error if filename does not exist or in case of other error.

Viz také

zip_read()
zip_close()

Předcházející | Nahoru | Další
zip_entry_read | Domů | zip_read


zip_read

(PHP 4 >= 4.0.7, PHP 5 >= 5.2.0, PECL zip:1.0-1.9.0)

zip_read — Read next entry in a ZIP file archive

Popis

mixed zip_read ( resource $zip )

Reads the next entry in a zip file archive.

Seznam parametrů

zip

A ZIP file previously opened with zip_open().

Návratové hodnoty

Returns a directory entry resource for later use with the zip_entry_... functions or FALSE if there's no more entries to read or number of error in case of other error.

Viz také

zip_open()
zip_close()
zip_entry_open()
zip_entry_read()

Předcházející | Nahoru | Další
zip_open | Domů | ZipArchive::addEmptyDir


Zlib Compression Functions

Předcházející VI. Reference funkcí Další

CLXXXIX. Zlib Compression Functions

Úvod

This module enables you to transparently read and write gzip (.gz) compressed files, through versions of most of the filesystem functions which work with gzip-compressed files (and uncompressed files, too, but not with sockets).

Poznámka: Version 4.0.4 introduced a fopen-wrapper for .gz-files, so that you can use a special zlib: URL to access compressed files transparently using the normal f*() file access functions if you prefix the filename or path with zlib: when calling fopen(). This feature requires a C runtime library that provides the fopencookie() function. Up to now the GNU libc seems to be the only library that provides this feature.

In PHP 4.3.0, zlib: has been changed to compress.zlib:// to prevent ambiguities with filenames containing ':' characters. The fopencookie() function is not longer required. More information is available in the section about „Compression Streams“.

Požadavky

This module uses the functions of » zlib by Jean-loup Gailly and Mark Adler. You have to use a zlib version >= 1.0.9 with this module.

Instalace

Zlib support in PHP is not enabled by default. You will need to configure PHP --with-zlib[=DIR]

Verze PHP pro Windows má vestavěnou podporu pro toto rozšíření. K použití těchto funkcí není třeba načítat žádná další rozšíření.

Poznámka: Built-in support for zlib on Windows is available with PHP 4.3.0.

Konfigurace běhu

Chování těchto funkcí je ovlivněno nastavením parametrů v php.ini.

The zlib extension offers the option to transparently compress your pages on-the-fly, if the requesting browser supports this. Therefore there are three options in the configuration file php.ini.

Tabulka 332. Zlib Configuration Options

Name | Default | Changeable | Changelog
zlib.output_compression | "0" | PHP_INI_ALL | Available since PHP 4.0.5.
zlib.output_compression_level | "-1" | PHP_INI_ALL | Available since PHP 4.3.0.
zlib.output_handler | "" | PHP_INI_ALL | Available since PHP 4.3.0.

Pro další detaily a definice konstant PHP_INI_*, viz dokumentace k ini_set().

Zde je stručný popis konfiguračních direktiv.

zlib.output_compression boolean/integer

Whether to transparently compress pages. If this option is set to "On" in php.ini or the Apache configuration, pages are compressed if the browser sends an "Accept-Encoding: gzip" or "deflate" header. "Content-Encoding: gzip" (respectively "deflate") and "Vary: Accept-Encoding" headers are added to the output. In runtime, it can be set only before sending any output.

This option also accepts integer values instead of boolean "On"/"Off", using this you can set the output buffer size (default is 4KB).

Poznámka: output_handler must be empty if this is set 'On' ! Instead you must use zlib.output_handler.

zlib.output_compression_level integer

Compression level used for transparent output compression.

zlib.output_handler string

You cannot specify additional output handlers if zlib.output_compression is activated here. This setting does the same as output_handler but in a different order.

Typy prostředků

This extension defines a file pointer resource returned by gzopen().

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

FORCE_GZIP (integer)
FORCE_DEFLATE (integer)

Příklady

This example opens a temporary file and writes a test string to it, then it prints out the content of this file twice.

Příklad 2470. Small Zlib Example

<?php

$filename = tempnam('/tmp', 'zlibtest') . '.gz';
echo "<html>\n<head></head>\n<body>\n<pre>\n";
$s = "Only a test, test, test, test, test, test, test, test!\n";

// open file for writing with maximum compression
$zp = gzopen($filename, "w9");

// write string to file
gzwrite($zp, $s);

// close file
gzclose($zp);

// open file for reading
$zp = gzopen($filename, "r");

// read 3 char
echo gzread($zp, 3);

// output until end of the file and close it.
gzpassthru($zp);
gzclose($zp);

echo "\n";

// open file and print content (the 2nd time).
if (readgzfile($filename) != strlen($s)) {
        echo "Error with zlib functions!";
}
unlink($filename);
echo "</pre>\n</body>\n</html>\n";

?>

Obsah

gzclose — Close an open gz-file pointer
gzcompress — Compress a string
gzdecode — Decodes a gzip compressed string
gzdeflate — Deflate a string
gzencode — Create a gzip compressed string
gzeof — Test for end-of-file on a gz-file pointer
gzfile — Read entire gz-file into an array
gzgetc — Get character from gz-file pointer
gzgets — Get line from file pointer
gzgetss — Get line from gz-file pointer and strip HTML tags
gzinflate — Inflate a deflated string
gzopen — Open gz-file
gzpassthru — Output all remaining data on a gz-file pointer
gzputs — Alias pro gzwrite()
gzread — Binary-safe gz-file read
gzrewind — Rewind the position of a gz-file pointer
gzseek — Seek on a gz-file pointer
gztell — Tell gz-file pointer read/write position
gzuncompress — Uncompress a compressed string
gzwrite — Binary-safe gz-file write
readgzfile — Output a gz-file
zlib_get_coding_type — Returns the coding type used for output compression
Předcházející | Nahoru | Další
ZipArchive::unchangeName | Domů | gzclose


gzclose

(PHP 4, PHP 5)

gzclose — Close an open gz-file pointer

Popis

bool gzclose ( resource $zp )

Closes the given gz-file pointer.

Seznam parametrů

zp

The gz-file pointer. It must be valid, and must point to a file successfully opened by gzopen().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 2471. gzclose() example

<?php
$gz = gzopen('somefile.gz','w9');
gzputs ($gz, 'I was added to somefile.gz');
gzclose($gz);
?>

Viz také

gzopen()

Předcházející | Nahoru | Další
CLXXXIX. Zlib Compression Functions | Domů | gzcompress


gzcompress

(PHP 4 >= 4.0.1, PHP 5)

gzcompress — Compress a string

Popis

string gzcompress ( string $data [, int $level] )

This function compress the given string using the ZLIB data format.

For details on the ZLIB compression algorithm see the document "» ZLIB Compressed Data Format Specification version 3.3" (RFC 1950).

Poznámka: This is not the same as gzip compression, which includes some header data. See gzencode() for gzip compression.

Seznam parametrů

data

The data to compress.

level

The level of compression. Can be given as 0 for no compression up to 9 for maximum compression.

Návratové hodnoty

The compressed string or FALSE if an error occurred.

Příklady

Příklad 2472. gzcompress() example

<?php
$compressed = gzcompress('Compress me', 9);
echo $compressed;
?>

Viz také

gzdeflate()
gzinflate()
gzuncompress()
gzencode()

Předcházející | Nahoru | Další
gzclose | Domů | gzdecode


gzdeflate

(PHP 4 >= 4.0.4, PHP 5)

gzdeflate — Deflate a string

Popis

string gzdeflate ( string $data [, int $level] )

This function compress the given string using the DEFLATE data format.

For details on the DEFLATE compression algorithm see the document "» DEFLATE Compressed Data Format Specification version 1.3" (RFC 1951).

Seznam parametrů

data

The data to deflate.

level

The level of compression. Can be given as 0 for no compression up to 9 for maximum compression. If not given, the default compression level will be the default compression level of the zlib library.

Návratové hodnoty

The deflated string or FALSE if an error occurred.

Příklady

Příklad 2473. gzdeflate() example

<?php
$compressed = gzdeflate('Compress me', 9);
echo $compressed;
?>

Viz také

gzinflate()
gzcompress()
gzuncompress()
gzencode()

Předcházející | Nahoru | Další
gzdecode | Domů | gzencode


gzencode

(PHP 4 >= 4.0.4, PHP 5)

gzencode — Create a gzip compressed string

Popis

string gzencode ( string $data [, int $level [, int $encoding_mode]] )

This function returns a compressed version of the input data compatible with the output of the gzip program.

For more information on the GZIP file format, see the document: » GZIP file format specification version 4.3 (RFC 1952).

Seznam parametrů

data

The data to encode.

level

The level of compression. Can be given as 0 for no compression up to 9 for maximum compression. If not given, the default compression level will be the default compression level of the zlib library.

encoding_mode

The encoding mode. Can be FORCE_GZIP (the default) or FORCE_DEFLATE.

If you use FORCE_DEFLATE, you get a standard zlib deflated string (inclusive zlib headers) after the gzip file header but without the trailing crc32 checksum.

Návratové hodnoty

The encoded string, or FALSE if an error occurred.

ChangeLog (záznam změn)

Verze | Popis
4.2.0 | The encoding_mode parameter was added

Příklady

The resulting data contains the appropriate headers and data structure to make a standard .gz file, e.g.:

Příklad 2474. Creating a gzip file

<?php
$data = implode("", file("bigfile.txt"));
$gzdata = gzencode($data, 9);
$fp = fopen("bigfile.txt.gz", "w");
fwrite($fp, $gzdata);
fclose($fp);
?>

Viz také

gzdecode()
gzdeflate()
gzinflate()
gzuncompress()
gzcompress()

Předcházející | Nahoru | Další
gzdeflate | Domů | gzeof


gzeof

(PHP 4, PHP 5)

gzeof — Test for end-of-file on a gz-file pointer

Popis

int gzeof ( resource $zp )

Tests the given GZ file pointer for EOF (end-of-file).

Seznam parametrů

zp

The gz-file pointer. It must be valid, and must point to a file successfully opened by gzopen().

Návratové hodnoty

Returns TRUE if the gz-file pointer is at EOF or an error occurs; otherwise returns FALSE.

Příklady

Příklad 2475. gzeof() example

<?php
$gz = gzopen('somefile.gz', 'r');
while (!gzeof($gz)) {
  echo gzgetc($gz);
}
gzclose($gz);
?>

Předcházející | Nahoru | Další
gzencode | Domů | gzfile


gzfile

(PHP 4, PHP 5)

gzfile — Read entire gz-file into an array

Popis

array gzfile ( string $filename [, int $use_include_path] )

This function is identical to readgzfile(), except that it returns the file in an array.

Seznam parametrů

filename

The file name.

use_include_path

You can set this optional parameter to 1, if you want to search for the file in the include_path too.

Návratové hodnoty

An array containing the file, one line per cell.

Příklady

Příklad 2476. gzfile() example

<?php
$lines = gzfile('somefile.gz');
foreach ($lines as $line) {
    echo $line;
}
?>

Viz také

readgzfile()
gzopen()

Předcházející | Nahoru | Další
gzeof | Domů | gzgetc


gzgetc

(PHP 4, PHP 5)

gzgetc — Get character from gz-file pointer

Popis

string gzgetc ( resource $zp )

Returns a string containing a single (uncompressed) character read from the given gz-file pointer.

Seznam parametrů

zp

The gz-file pointer. It must be valid, and must point to a file successfully opened by gzopen().

Návratové hodnoty

The uncompressed character or FALSE on EOF (unlike gzeof()).

Příklady

Příklad 2477. gzgetc() example

<?php
$gz = gzopen('somefile.gz', 'r');
while (!gzeof($gz)) {
  echo gzgetc($gz);
}
gzclose($gz);
?>

Viz také

gzopen()
gzgets()

Předcházející | Nahoru | Další
gzfile | Domů | gzgets


gzgets

(PHP 4, PHP 5)

gzgets — Get line from file pointer

Popis

string gzgets ( resource $zp, int $length )

Gets a (uncompressed) string of up to length - 1 bytes read from the given file pointer. Reading ends when length - 1 bytes have been read, on a newline, or on EOF (whichever comes first).

Seznam parametrů

zp

The gz-file pointer. It must be valid, and must point to a file successfully opened by gzopen().

length

The length of data to get.

Návratové hodnoty

The uncompressed string, or FALSE on error.

Příklady

Příklad 2478. gzgets() example

<?php
$handle = gzopen('somefile.gz', 'r');
while (!gzeof($handle)) {
   $buffer = gzgets($handle, 4096);
   echo $buffer;
}
gzclose($handle);
?>

Viz také

gzopen()
gzgetc()
gzwrite()

Předcházející | Nahoru | Další
gzgetc | Domů | gzgetss


gzgetss

(PHP 4, PHP 5)

gzgetss — Get line from gz-file pointer and strip HTML tags

Popis

string gzgetss ( resource $zp, int $length [, string $allowable_tags] )

Identical to gzgets(), except that gzgetss() attempts to strip any HTML and PHP tags from the text it reads.

Seznam parametrů

zp

The gz-file pointer. It must be valid, and must point to a file successfully opened by gzopen().

length

The length of data to get.

allowable_tags

You can use this optional parameter to specify tags which should not be stripped.

Návratové hodnoty

The uncompressed and striped string, or FALSE on error.

ChangeLog (záznam změn)

Verze | Popis
3.0.13 and 4.0.0 | allowable_tags was added.

Příklady

Příklad 2479. gzgetss() example

<?php
$handle = gzopen('somefile.gz', 'r');
while (!gzeof($handle)) {
   $buffer = gzgetss($handle, 4096);
   echo $buffer;
}
gzclose($handle);
?>

Viz také

gzopen()
gzgets()
strip_tags()

Předcházející | Nahoru | Další
gzgets | Domů | gzinflate


gzinflate

(PHP 4 >= 4.0.4, PHP 5)

gzinflate — Inflate a deflated string

Popis

string gzinflate ( string $data [, int $length] )

This function inflate a deflated string.

Seznam parametrů

data

The data compressed by gzdeflate().

length

The maximum length of data to decode.

Návratové hodnoty

The original uncompressed data or FALSE on error.

The function will return an error if the uncompressed data is more than 32768 times the length of the compressed input data or more than the optional parameter length.

Příklady

Příklad 2480. gzinflate() example

<?php
$compressed   = gzdeflate('Compress me', 9);
$uncompressed = gzinflate($compressed);
echo $uncompressed;
?>

Viz také

gzdeflate()
gzcompress()
gzuncompress()
gzencode()

Předcházející | Nahoru | Další
gzgetss | Domů | gzopen


gzopen

(PHP 4, PHP 5)

gzopen — Open gz-file

Popis

resource gzopen ( string $filename, string $mode [, int $use_include_path] )

Opens a gzip (.gz) file for reading or writing.

gzopen() can be used to read a file which is not in gzip format; in this case gzread() will directly read from the file without decompression.

Seznam parametrů

filename

The file name.

mode

As in fopen() (rb or wb) but can also include a compression level (wb9) or a strategy: f for filtered data as in wb6f, h for Huffman only compression as in wb1h. (See the description of deflateInit2 in zlib.h for more information about the strategy parameter.)

use_include_path

You can set this optional parameter to 1, if you want to search for the file in the include_path too.

Návratové hodnoty

Returns a file pointer to the file opened, after that, everything you read from this file descriptor will be transparently decompressed and what you write gets compressed.

If the open fails, the function returns FALSE.

Příklady

Příklad 2481. gzopen() Example

<?php
$fp = gzopen("/tmp/file.gz", "r");
?>

Viz také

gzclose()

Předcházející | Nahoru | Další
gzinflate | Domů | gzpassthru


gzpassthru

(PHP 4, PHP 5)

gzpassthru — Output all remaining data on a gz-file pointer

Popis

int gzpassthru ( resource $zp )

Reads to EOF on the given gz-file pointer from the current position and writes the (uncompressed) results to standard output.

Poznámka: You may need to call gzrewind() to reset the file pointer to the beginning of the file if you have already written data to it.

Tip

If you just want to dump the contents of a file to the output buffer, without first modifying it or seeking to a particular offset, you may want to use the readgzfile() function, which saves you the gzopen() call.

Seznam parametrů

zp

The gz-file pointer. It must be valid, and must point to a file successfully opened by gzopen().

Návratové hodnoty

The number of uncompressed characters read from gz and passed through to the input, or FALSE on error.

Příklady

Příklad 2482. gzpassthru() example

<?php
$fp = gzopen('file.gz', 'r');
gzpassthru($fp);
gzclose($fp);
?>

Předcházející | Nahoru | Další
gzopen | Domů | gzputs


gzputs

(PHP 4, PHP 5)

gzputs — Alias pro gzwrite()

Popis

Tato funkce je aliasem: gzwrite().

Předcházející | Nahoru | Další
gzpassthru | Domů | gzread


gzread

(PHP 4, PHP 5)

gzread — Binary-safe gz-file read

Popis

string gzread ( resource $zp, int $length )

gzread() reads up to length bytes from the given gz-file pointer. Reading stops when length (uncompressed) bytes have been read or EOF is reached, whichever comes first.

Seznam parametrů

zp

The gz-file pointer. It must be valid, and must point to a file successfully opened by gzopen().

length

The number of bytes to read.

Návratové hodnoty

The data that have been read.

Příklady

Příklad 2483. gzread() example

<?php
// get contents of a gz-file into a string
$filename = "/usr/local/something.txt.gz";
$zd = gzopen($filename, "r");
$contents = gzread($zd, 10000);
gzclose($zd);
?>

Viz také

gzwrite()
gzopen()
gzgets()
gzgetss()
gzfile()
gzpassthru()

Předcházející | Nahoru | Další
gzputs | Domů | gzrewind


gzrewind

(PHP 4, PHP 5)

gzrewind — Rewind the position of a gz-file pointer

Popis

bool gzrewind ( resource $zp )

Sets the file position indicator of the given gz-file pointer to the beginning of the file stream.

Seznam parametrů

zp

The gz-file pointer. It must be valid, and must point to a file successfully opened by gzopen().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

gzseek()
gztell()

Předcházející | Nahoru | Další
gzread | Domů | gzseek


gzseek

(PHP 4, PHP 5)

gzseek — Seek on a gz-file pointer

Popis

int gzseek ( resource $zp, int $offset )

Sets the file position indicator for the given file pointer to the given offset byte into the file stream. Equivalent to calling (in C) gzseek(zp, offset, SEEK_SET).

If the file is opened for reading, this function is emulated but can be extremely slow. If the file is opened for writing, only forward seeks are supported; gzseek() then compresses a sequence of zeroes up to the new starting position.

Seznam parametrů

zp

The gz-file pointer. It must be valid, and must point to a file successfully opened by gzopen().

offset

The seeked offset.

Návratové hodnoty

Upon success, returns 0; otherwise, returns -1. Note that seeking past EOF is not considered an error.

Příklady

Příklad 2484. gzseek() example

<?php
$gz = gzopen('somefile.gz', 'r');
gzseek($gz,2);
echo gzgetc($gz);
gzclose($gz);
?>

Viz také

gztell()
gzrewind()

Předcházející | Nahoru | Další
gzrewind | Domů | gztell


gztell

(PHP 4, PHP 5)

gztell — Tell gz-file pointer read/write position

Popis

int gztell ( resource $zp )

Gets the position of the given file pointer; i.e., its offset into the uncompressed file stream.

Seznam parametrů

zp

The gz-file pointer. It must be valid, and must point to a file successfully opened by gzopen().

Návratové hodnoty

The position of the file pointer or FALSE if an error occurs.

Viz také

gzopen()
gzseek()
gzrewind()

Předcházející | Nahoru | Další
gzseek | Domů | gzuncompress


gzuncompress

(PHP 4 >= 4.0.1, PHP 5)

gzuncompress — Uncompress a compressed string

Popis

string gzuncompress ( string $data [, int $length] )

This function uncompress a compressed string.

Seznam parametrů

data

The data compressed by gzcompress().

length

The maximum length of data to decode.

Návratové hodnoty

The original uncompressed data or FALSE on error.

The function will return an error if the uncompressed data is more than 32768 times the length of the compressed input data or more than the optional parameter length.

Příklady

Příklad 2485. gzuncompress() example

<?php
$compressed   = gzcompress('Compress me', 9);
$uncompressed = gzuncompress($compressed);
echo $uncompressed;
?>

Viz také

gzcompress()
gzinflate()
gzdeflate()
gzencode()

Předcházející | Nahoru | Další
gztell | Domů | gzwrite


gzwrite

(PHP 4, PHP 5)

gzwrite — Binary-safe gz-file write

Popis

int gzwrite ( resource $zp, string $string [, int $length] )

gzwrite() writes the contents of string to the given gz-file.

Seznam parametrů

zp

The gz-file pointer. It must be valid, and must point to a file successfully opened by gzopen().

string

The string to write.

length

The number of uncompressed bytes to write. If supplied, writing will stop after length (uncompressed) bytes have been written or the end of string is reached, whichever comes first.

Poznámka: Note that if the length argument is given, then the magic_quotes_runtime configuration option will be ignored and no slashes will be stripped from string.

Návratové hodnoty

Returns the number of (uncompressed) bytes written to the given gz-file stream.

Příklady

Příklad 2486. gzwrite() example

<?php
$string = 'Some information to compress';
$gz = gzopen('somefile.gz','w9');
gzwrite($gz, $string);
gzclose($gz);
?>

Viz také

gzread()
gzopen()

Předcházející | Nahoru | Další
gzuncompress | Domů | readgzfile


readgzfile

(PHP 4, PHP 5)

readgzfile — Output a gz-file

Popis

int readgzfile ( string $filename [, int $use_include_path] )

Reads a file, decompresses it and writes it to standard output.

readgzfile() can be used to read a file which is not in gzip format; in this case readgzfile() will directly read from the file without decompression.

Seznam parametrů

filename

The file name. This file will be opened from the filesystem and its contents written to standard output.

use_include_path

You can set this optional parameter to 1, if you want to search for the file in the include_path too.

Návratové hodnoty

Returns the number of (uncompressed) bytes read from the file. If an error occurs, FALSE is returned and unless the function was called as @readgzfile, an error message is printed.

Viz také

gzpassthru()
gzfile()
gzopen()

Předcházející | Nahoru | Další
gzwrite | Domů | zlib_get_coding_type


zlib_get_coding_type

(PHP 4 >= 4.3.2, PHP 5)

zlib_get_coding_type — Returns the coding type used for output compression

Popis

string zlib_get_coding_type ( void )

Returns the coding type used for output compression.

Návratové hodnoty

Possible return values are gzip, deflate, or FALSE.

Viz také

The zlib.output_compression directive

Předcházející | Nahoru | Další
readgzfile | Domů | VII. PHP at the Core: A Hacker's Guide to the Zend Engine


Část VIII. FAQ: Často kladené otázky

Obsah

59. Obecné informace
60. E-mailové konference (mailing lists)
61. Získání PHP
62. Záležitosti databází
63. Instalace
64. Sestavovací (kompilační) problémy
65. Používání PHP
66. PHP a HTML
67. PHP a COM
68. PHP a jiné jazyky
69. Přechod z PHP 2 na PHP 3
70. Přechod z PHP 3 na PHP 4
71. Přechod z PHP 4 na PHP 5
72. Ostatní otázky
Předcházející | Nahoru | Další
58. The future: PHP 6 and Zend Engine 3 | Domů | 59. Obecné informace


Kapitola 59. Obecné informace

Tato sekce se zabývá obecnými otázkami okolo PHP: co to je a co to dělá.

59.1. Co je to PHP?
59.2. Co znamená zkratka PHP?
59.3. Jaký je vztah mezi verzemi?
59.4. Mohu současně pouštět více verzí PHP?
59.5. Jaké jsou rozdíly mezi PHP 3 a PHP 4?
59.6. Myslím, že jsem našel chybu! Komu to mám říct?
59.1. | Co je to PHP?

Z předsádky manuálu:

PHP je skriptovací jazyk vkládaný do HTML. Mnoho jeho syntaxe je vypůjčeno z C, Javy a Perlu s několika přidanými prostředky specifickými pro PHP. Cílem jazyka je umožnit vývojářům webů rychleji psát dynamicky generované stránky.

Milý úvod do PHP od Stiga Saether Bakkena najdete » tady na stránkách Zendu. Volně k dispozici je také mnoho » materiálů PHP konference.

59.2. | Co znamená zkratka PHP?

PHP je zkratka pro PHP: Hypertext Preprocessor. Mnoho lidí může mást, že první slovo akronymu je také akronym. Tomuto typu zkratek se říká rekurzívní akronym. Zvědavci mohou navštívit » Free On-Line Dictionary of Computing, kde najdou více informací o rekurzívních akronymech.

59.3. | Jaký je vztah mezi verzemi?

PHP/FI 2.0 je časná a již nepodporovaná verze PHP. PHP 3 je následník PHP/FI 2.0 a je mnohem lepší. PHP 4 je zatím poslední generací PHP a má pod kapotou » Zend engine.

59.4. | Mohu současně pouštět více verzí PHP?

Ano. Podívejte se do souboru INSTALL, který je přiložen k distribuci zdrojových souborů PHP 4. Přečtěte si i příslušný dodatek.

59.5. | Jaké jsou rozdíly mezi PHP 3 a PHP 4?

Existuje » několik článků, které o tom napsali autoři PHP 4. Tady je seznam některých důležitějších nových prvků:

  • Rozšířený API modul
  • Zobecněný sestavovací (kompilační) proces pod UNIXem
  • Generické rozhraní pro WWW servery, které podporuje také multithreadové servery
  • Vylepšený zvýrazňovač syntaxe
  • Nativní podpora HTTP sessions
  • Podpora výstupního bufferingu
  • Silnější konfigurační systém
  • Reference counting
Podívejte se laskavě na » What's new in PHP 4 overview, kde najdete detailní vysvětlení těchto prvků a ještě mnohem víc. Pokud přecházíte z PHP 3 na PHP 4, přečtěte si také příslušný dodatek.

59.6. | Myslím, že jsem našel chybu! Komu to mám říct?

Měli byste navštívit databázi chyb (PHP Bug Database) a ujistit se, zda nalezená chyba již není v seznamu známých chyb. Pokud ji tam nenajdete, použijte formulář pro ohlašování chyb. Je důležité použít databázi chyb namísto posílání zprávy do distribučního seznamu, protože chyba bude mít přiřazeno své číslo a bude potom možné, abyste se sem později vrátili a zkontrolovali stav chyby. Chybovou databázi najdete na » http://bugs.php.net/.

Předcházející | Nahoru | Další
VIII. FAQ: Často kladené otázky | Domů | 60. E-mailové konference (mailing lists)


Kapitola 60. E-mailové konference (mailing lists)

Tato část se zabývá záležitostmi o tom, jak můžete navázat kontakt s PHP komunitou. Nejlepším způsobem jsou e-mailové konference.

Pozn. překladatele: Čeština nemá adekvátní termín pro "mailing list". Protože se běžně používá termínů "e-mailová konference" nebo "konference", budu je používat i zde, i když to není úplně nejlepší řešení.

60.1. Existují nějaké e-mailové konference pro PHP?
60.2. Existují ještě jiné komunity?
60.3. Pomoc! Nedaří se mi přihlásit/odhlásit se do/z konference!
60.4. Existuje někde archiv konferencí?
60.5. Na co se mohu ptát v konferenci?
60.6. Jaké informace mám přiložit k příspěvku do konference?
60.1. | Existují nějaké e-mailové konference pro PHP?

Samozřejmě! Je mnoho konferencí pro různé záležitosti. Kompletní seznam těchto konferencí můžete najít na naší stránce » Podpora.

Většina konferencí patří do třídy php-general, tedy obecné záležitosti PHP. K přihlášení pošlete zprávu na » php-general-subscribe@lists.php.net. Do předmětu zprávy ani jejího těla nemusíte vkládat nic speciálního. Odhlásíte se posláním zprávy na » php-general-unsubscribe@lists.php.net.

Přihlásit nebo odhlásit se můžete také pomocí rozhraní na webu na stránce » Podpora.

60.2. | Existují ještě jiné komunity?

Je jich nespočetně po celém světě. Máme např. odkazy na některé IRC servery a konference v cizích jazycích - na stránce » Podpora.

60.3. | Pomoc! Nedaří se mi přihlásit/odhlásit se do/z konference!

Pokud máte problémy s přihlašováním nebo odhlašováním konference php-general, může to být proto, že její software nemůže vyhodnotit správnou e-mailovou adresu k použití. Pokud by vaše adresa byla joeblow@example.com, můžete poslat přihlašovací požadavek na php-general-subscribe-joeblow=example.com@lists.php.net, resp. odhlašovací na php-general-unsubscribe-joeblow=example.com@lists.php.net. Pro ostatní konference použijte obdobné adresy.

60.4. | Existuje někde archiv konferencí?

Ano, seznam archivů najdete na stránce » Podpora. Příspěvky do konferencí se archivují také jako zprávy služby news (protokol NNTP). Server této služby je k dispozici na » news://news.php.net/. Existuje také experimentální webovské rozhraní pro news server na » http://news.php.net/

60.5. | Na co se mohu ptát v konferenci?

Jak je PHP den ze dne stále populárnější, provoz v konferenci php-general narůstal a nyní přichází 150-200 příspěvků denně. Kvůli tomu je v zájmu každého, aby používal tuto konferenci až jako poslední možnost poté, co hledal všude jinde.

Než něco pošlete do konference, podívejte se prosím do FAQ a do manuálu, zda nemůžete najít odpověd tam. Pokud ji nenajdete, prohlédněte si archivy konferencí (viz výše). Když máte problémy s instalací nebo konfigurací PHP, přečtěte si prosím všechnu přiloženou dokumentaci a soubory README. Pokud stále nemůžete najít nic, co by vám pomohlo, jste více než vítáni v konferenci.

60.6. | Jaké informace mám přiložit k příspěvku do konference?

Příspěvky jako "PHP mi nechce fungovat! Pomozte mi! Co mám špatně?" jsou absolutně k ničemu. Pokud máte problémy se spouštěním a během PHP, musíte napsat, na jakém operačním systému ho spouštíte, o kterou verzi PHP se jedná, jak jste ji získali (předkompilovaný balík, CVS, RPM apod.), co jste s ním udělali, kde to uvázlo, a přesnou chybovou zprávu.

To platí úplně stejně i pro jiné problémy. Měli byste přiložit informace o tom, co jste dělali, kde to uvázlo, co jste s tím zkoušeli dělat a, pokud to lze, přesnou chybovou zprávu. Máte-li problémy se zdrojovým kódem, je třeba přiložit ten kus kódu, který nepracuje. Nepřikládejte více kódu, než je třeba! Příspěvek by byl hůře čitelný a mnoho lidí by ho kvůli tomu přeskočilo. Pokud si nejste jisti, kolik informací máte přiložit do zprávy, je lépe přidat více než méně.

Jinou důležitou věcí, kterou je třeba mít na paměti, je sumarizace problému v předmětu zprávy. Předmět typu "POMOZTEEE! nebo "Co je to za problém?" bude většina čtenářů ignorovat.

Předcházející | Nahoru | Další
59. Obecné informace | Domů | 61. Získání PHP


Kapitola 61. Získání PHP

Tato část obsahuje detaily o umístění PHP downloadu a záležitostech operačních systémů.

61.1. Kde mohu získat PHP?
61.2. Jsou k dispozici předkompilované binární verze?
61.3. Kde mohu získat knihovny potřebné pro kompilaci některých volitelných rozšíření PHP?
61.4. Jak zařídím, aby tyto knihovny fungovaly?
61.5. Získal jsem poslední verzi zdrojového kódu PHP z CVS repozitáře, co potřebuji ke kompilaci na Windows?
61.6. Kde najdu Browser Capabilities File?
61.1. | Kde mohu získat PHP?

PHP můžete stáhnout z kteréhokoli bodu, který je součástí sítě PHP serverů. Najdete je na » http://www.php.net/. Můžete také použít anonymní CVS přístup, čímž získáte absolutně nejnovější verzi zdrojových souborů. Více informací najdete na » http://cvs.php.net/.

61.2. | Jsou k dispozici předkompilované binární verze?

Předkompilované verze distribuujeme pouze pro systémy Windows, protože nejsme schopni zkompilovat PHP pro všechny hlavní platformy Linux/UNIX se všemi kombinacemí rozšíření. Také si uvědomte, že mnoho distribucí Linuxu dnes přímo obsahuje PHP. Binární soubory pro Windows si můžete stáhnout z naší stránky » Download, pro binární soubory pro Linux navštivte stránky distribucí Linuxu.

61.3. | Kde mohu získat knihovny potřebné pro kompilaci některých volitelných rozšíření PHP?

Poznámka: Knihovny označené * (hvězdičkou) nejsou vláknově bezpečné a neměly by se používat s PHP jako modulem do multithreadových serverů pod Windows (IIS, Netscape). V UNIXu na tom nezáleží.

  • » LDAP (unix).
  • » LDAP* (unix).
  • » LDAP (unix/win) : Netscape Directory (LDAP) SDK 1.1.
  • » free LDAP server.
  • » Berkeley DB2 (Unix/Win) : http://www.sleepycat.com/.
  • » SNMP* (Unix): .
  • » GD* (Unix/Win).
  • mSQL* (Win).
  • » mSQL* (Unix).
  • » PostgreSQL (Unix).
  • » IMAP* (Win/Unix).
  • » Sybase-CT* (Linux, libc5) : Available locally.
  • » FreeType (libttf):.
  • » ZLib (Unix/Win32).
  • » expat XML parser (Unix/Win32).
  • » PDFLib.
  • » mcrypt.
  • » mhash.
  • » t1lib.
  • » dmalloc.
  • » aspell.
  • » readline.

61.4. | Jak zařídím, aby tyto knihovny fungovaly?

Musíte se řídit instrukcemi dodanými s příslušnou knihovnou. Některé knihovny se automaticky detekují při spuštění skriptu 'configure' pro PHP (např. knihovna GD), jiné musíte aktivovat pomocí parametru '--with-EXTENSION' pro 'configure'. Seznam těchto parametrů získáte spuštěním 'configure --help'.

61.5. | Získal jsem poslední verzi zdrojového kódu PHP z CVS repozitáře, co potřebuji ke kompilaci na Windows?

V první řadě musíte mít Microsoft Visual C++ verze 6 (MSVC++ 5 také postačí, ale my používáme verzi 6) a budete potřebovat nějaké podpůrné soubory. Podívejte se do sekce manuálu o kompilaci PHP pod Windows.

61.6. | Kde najdu Browser Capabilities File?

Je to soubor browscap.ini na » http://browsers.garykeith.com/downloads.asp.

Předcházející | Nahoru | Další
60. E-mailové konference (mailing lists) | Domů | 62. Záležitosti databází


Kapitola 62. Záležitosti databází

Tato sekce se zabývá častými otázkami okolo vztahu PHP a databází. Ano, PHP dnes může virtuálně přistupovat ke kterékoli dostupné databázi.

62.1. Slyšel jsem, že lze z PHP přistupovat k Microsoft SQL Serveru. Jak?
62.2. Lze přistupovat k databázím Microsoft Access?
62.3. Upgradoval jsem na PHP 4 a MySQL mi teď hlásí "Warning: MySQL: Unable to save result set in ...". Co se děje?
62.4. Po instalaci podpory sdíleného MySQL havaruje Apache v momentě, kdy načítá libphp4.so. Lze to vyřešit?
62.5. Proč dostávám chybu, která vypadá nějak takto: "Warning: 0 is not a MySQL result index in <file> on line <x>" nebo "Warning: Supplied argument is not a valid MySQL result resource in <file> on line <x>?
62.1. | Slyšel jsem, že lze z PHP přistupovat k Microsoft SQL Serveru. Jak?

Na strojích s Windows můžete jednoduše použít zabudovanou podporu ODBC a správný ovladač ODBC.

Na Unixových strojích můžete k přístupu na Microsoft SQL Servery použít ovladač Sybase-CT, protože tyto protokoly jsou (alespoň z většiny) kompatibilní. V Sybase připravili » volnou verzi potřebných knihoven pro Linux. Pro jiné Unixové systémy musíte kontaktovat Sybase k získání správných knihoven. Podívejte se také na odpověď na příští otázku.

62.2. | Lze přistupovat k databázím Microsoft Access?

Ano. Pokud pracujete pod Windows 9x/Me nebo NT/2000, všechny potřebné nástroje již máte k dispozici - můžete použít ODBC a ovladače pro ODBC k databázím Microsoft Access.

Pokud používáte PHP na Unixu a chcete komunikovat s databázemi MS Access běžících na Windows, budete potřebovat ODBC ovladače pro Unix. » OpenLink Software má unixové ovladače pro ODBC, které zde vyhoví. Existuje pilotní program, kdy si můžete stáhnout zkušební kopii, která má neomezenou zkušební dobu; ceny komerční verze s podporou začínají na 675 USD.

Jinou alternativou je použít SQL server, který má ODBC ovladače pro Windows a použít ho k uložení dat, ke kterým pak můžete přistupovat z aplikace Microsoft Access (pomocí ODBC) a z PHP (pomocí vestavěných ovladačů), nebo použít souborový meziformát, kterému rozumí Access i PHP (např. obyčejné soubory nebo databáze dBase). K tomuto bodu Tim Hayes z OpenLink soiftware píše:

Použití jiné databáze jako meziformátu není dobrý nápad, pokud můžete použít
ODBC z PHP přímo na vaší databázi - např. pomocí ovladačů od OpenLink software.
Když meziformát použít musíte, OpenLink nyní uvolnil Virtuoso (virtuální
databázový stroj) pro WinNT, Linux a jiné unixové platformy. Navštivte
prosím naši website a zdarma si ho
stáhněte.

Jednou z prověřených možností je použít MySQL a jeho ODBC ovladače pro Windows a synchronizace databází. Steve Lawrence píše:

  • Nainstalujte si na svou platformu MySQL podle přiložených instrukcí. Nejnovější verzi získáte na » www.mysql.com (stahujte z nejbližšího zrcadla!). Není třeba žádná zvláštní konfigurace kromě toho, že když instalujete databázi a konfigurujete uživatelský účet, měli byste do pole "host" přidat % nebo název počítače s Windows, na kterém chcete MySQL spouštět. Poznamenejte si název serveru, uživatelské jméno a heslo.
  • Stáhněte si ovladač MyODBC pro Windows ze stránek MySQL. Nejnovější verze je myodbc-2_50_19-win95.zip (k dispozici také verze pro NT, stejně tak i zdrojový kód). Nainstalujte ho na počítač s Windows. Funkci můžete otestovat pomocí přiložených utilit.
  • Vytvořte uživatelský nebo systémový dsn v administrátoru ODBC, umístěném v ovládacích panelech. Zvolte název dsn, vložte název počítače, heslo, port apod. pro databázi MySQL nakonfigurovanou v kroku 1.
  • Nainstalujte plnou instalaci Accessu, což zajistí, že budou k dispozici všechny doplňky; budete potřebovat alespoň podporu ODBC a správu propojených tabulek.
  • A teď to nejzábavnější! Vytvořte novou databázi v Accessu. Klikněte pravým tlačítkem v okně tabulek a vyberte "Propojit tabulky", nebo pod nabídkou "Soubor" vyberte "Načíst externí data" a potom "Propojit tabulky". Až se otevře dialog, vyberte soubory typu ODBC. Zvolte systémový dsn a název dsn vytvořeného v kroku 3. Vyberte tabulku k propojení, stiskněte "OK" a je to"! Nyní můžete otevřít tabulku a přidat/smazat/upravovat data na vašem MySQL serveru! Můžete také vytvářet dotazy, importovat/exportovat tabulky do MySQL, vytvářet formuláře a sestavy atd.

Tipy a triky:

  • Můžete vytvořit tabulky v Accessu, exportovat je do MySQL a potom propojit zpět. To urychluje návrh tabulek.
  • Když vytváříte tabulky v Accessu, musíte mít definován primární klíč kvůli zápisu do tabulky. Ujistěte se, že jste primární klíč v MySQL vytvořili před propojením do Accessu.
  • Pokud změníte tabulku v MySQL, musíte ji znovu připojit do Accessu. Go to tools>add-ins>linked table manager, cruise to your ODBC DSN, and select the table to re-link from there. you can also move your dsn source around there, just hit the always prompt for new location checkbox before pressing ok.

62.3. | Upgradoval jsem na PHP 4 a MySQL mi teď hlásí "Warning: MySQL: Unable to save result set in ...". Co se děje?

Nejspíše se stalo to, že bylo PHP 4 zkompilováno s volbout '--with-mysql' bez specifikace cesty k MySQL. To znamená, že PHP používá svoji vestavěnou klientskou knihovnu. Pokud na vašem systému běží aplikace jako PHP 3 (jako paralelně běžící modul Apache) nebo auth-mysql, používá jiné verze klientů MySQL, a je zde tedy konflikt dvou různých verzí těchto klientů.

Překompilování PHP 4 s přidáním cesty k MySQL do parametru, '--with-mysql=/your/path/to/mysql', obvykle tento problém vyřeší.

62.4. | Po instalaci podpory sdíleného MySQL havaruje Apache v momentě, kdy načítá libphp4.so. Lze to vyřešit?

To se stává, když jsou knihovny MySQL připojovány s použitím pthreads. Ověřte to použitím "ldd". Pokud tomu tak je, stáhněte si balík MySQL a zkompilujte zdrojové soubory, nebo překompilujte soubory z RPM balíku a odstraňte přepínač, který zapíná threadový kód klienta. Jeden z těchto způsobů by měl problém vyřešit. Potom překompilujte PHP s novými knihovnami MySQL.

62.5. | Proč dostávám chybu, která vypadá nějak takto: "Warning: 0 is not a MySQL result index in <file> on line <x>" nebo "Warning: Supplied argument is not a valid MySQL result resource in <file> on line <x>?

Pokoušíte se použít indentifikátor výsledku, který je 0. Nula indikuje, že váš dotaz z nějakého důvodu selhal. Po odeslání dotazu musíte provést kontrolu na chyby, dřív než se pokusíte použít vrácený indentifikátor výsledku. Správný způsob, jak to udělat, je popsán následujícím kódem: $result = mysql_query("SELECT * FROM tables_priv");
if (!$result) {
    echo mysql_error();
    exit;
} or $result = mysql_query("SELECT * FROM tables_priv")
    or die("Bad query: ".mysql_error());

Předcházející | Nahoru | Další
61. Získání PHP | Domů | 63. Instalace


Kapitola 63. Instalace

Tato část se zabývá častými otázkamni ohledně způsobu instalace PHP. PHP je dostupné pro většinu OS (v podstatě kromě MacOS pře OSX) a většinu webovských serverů.

Při instalaci PHP postupujte podle instrukcí v souboru » INSTALL v příslušné distribuci. Uživatelé Windows by si také měli přečíst soubor » install.txt. Existuje také soubor s různými fintami pro Windows - najdete ho tady.

63.1. Unix/Windows: Kde by měl být uložen soubor php.ini?
63.2. UNIX: Nainstaloval jsem PHP, ale vždy, když načítám dokument, dostanu zprávu 'Document Contains No Data'! O co jde?
63.3. UNIX: Instaloval jsem PHP z balíčků RPM, ale Apache nezpracovává stránky s PHP! O co tu jde?
63.4. UNIX: Instaloval jsem PHP 3 z balíčků RPM, ale nekompiluje se s podporou databáze, kterou potřebuji! O co tu jde?
63.5. UNIX: Přidal jsem do Apache patch pro FrontPage Extension a PHP náhle přestalo pracovat. Je PHP nekompatibilní s FrontPage Extension pro Apache?
63.6. UNIX/Windows: Nainstaloval jsem PHP, ale při pokusu načíst soubor PHP skriptu do prohlížeče se zobrazí pouze prázdná obrazovka.
63.7. UNIX/Windows: Nainstaloval jsem PHP a když chci načíst PHP soubor do prohlížeče, objeví se "500 Internal Server Error".
63.8. Některé operační systémy: Nainstaloval jsem PHP bez chyb, ale nyní, když zkusím spustit Apache, ohlásí se chyby o nedefinovaných symbolech: [mybox:user /src/php4] root# apachectl configtest apachectl: /usr/local/apache/bin/httpd Undefined symbols: _compress _uncompress
63.9. Windows: Nainstaloval jsem PHP, ale při načtení stránky do prohlížeče se zobrazí chyba: cgi error: The specified CGI application misbehaved by not returning a complete set of HTTP headers. The headers it did return are:
63.10. Windows: Dodržel jsem všechny instrukce, ale PHP a IIS stále odmítají spolupracovat!
63.1. | Unix/Windows: Kde by měl být uložen soubor php.ini?

V UNIXu má být implicitně v adresáři /usr/local/lib. Mnoho lidí to bude chtít při kompilaci změnit pomocí parametru --with-config-file-path. Mohli byste ho, například, nastavit zhruba takto:

--with-config-file-path=/etc
Pak byste zkopírovali soubor php.ini-dist z distribuce do /etc/php.ini a upravili tak, jak chcete.

Pod Windows je soubor php.ini implicintě umístěn v adresáři systému Windows.

63.2. | UNIX: Nainstaloval jsem PHP, ale vždy, když načítám dokument, dostanu zprávu 'Document Contains No Data'! O co jde?

Pravděpobně to znamená, že PHP má nějaký problém a padá. Podívejte se do protokolu chyb, zda se jedná o tento případ a pak zkuste problém reprodukovat malým testem. Pokud víte, jak používat 'gdb', velmi pomůže, když můžete s vaším hlášením chyby poskytnout výpis (backtrace). Vývojáři tak mohou snadněji lokalizovat problém. Používáte-li PHP jako modul do serveru Apache, zkuste něco jako:

  • Zastavte httpd procesy

  • gdb httpd

  • Zastavte httpd procesy

  • > run -X -f /path/to/httpd.conf

  • Potom načtěte do prohlížeče URL, kde se vyskytl problém

  • > run -X -f /path/to/httpd.conf

  • Dostanete-li core dump (PHP spadne), gdb by vás o tom měl informovat

  • napište: bt

  • Získaný výpis (backtrace) byste měli přiložit k hlášení chyby. To by se mělo poslat na » http://bugs.php.net/

Pokud váš skript používá funkce pro regulární výrazy (ereg() a další), měli byste se ujistit, že jste zkompilovali PHP a Apache se stejným balíčkem pro regulární výrazy. S PHP a Apachem 1.3.x by se to mělo dít automaticky.

63.3. | UNIX: Instaloval jsem PHP z balíčků RPM, ale Apache nezpracovává stránky s PHP! O co tu jde?

Za předpokladu, že se obojí, jak Apache, tak PHP, instalovalo z balíčků RPM, bude třeba "odkomentovat" nebo přidat do souboru http.conf některé z následujících řádků (nebo všechny):

# Extra Modules
AddModule mod_php.c
AddModule mod_php3.c
AddModule mod_perl.c

# Extra Modules
LoadModule php_module         modules/mod_php.so
LoadModule php3_module        modules/libphp3.so     /* pro PHP 3 */
LoadModule php4_module        modules/libphp4.so     /* pro PHP 4 */
LoadModule perl_module        modules/libperl.so
Přidejte také:
AddType application/x-httpd-php3 .php3    /* pro PHP 3 */
AddType application/x-httpd-php .php      /* pro PHP 4 */
... do globálních vlastností nebo do vlastností virtuální domény (VirtualDomain) by se měla přidat podpora PHP.

63.4. | UNIX: Instaloval jsem PHP 3 z balíčků RPM, ale nekompiluje se s podporou databáze, kterou potřebuji! O co tu jde?

Kvůli tomu, jak se PHP 3 budovalo, není snadné sestavit kompletní flexibilní RPM balíček s PHP. Problém je vyřešen v PHP 4. Pro PHP 3 nyní doporučujeme používat mechanismus popsaný v souboru INSTALL.REDHAT v distribuci PHP. Pokud trváte na použití RPM verze PHP 3, čtěte dál...

RPM pakovače jsou nastaveny na tvorbu RPM balíčků k instalaci bez podpory databází kvůli zjednodušení instalací a proto, že RPM používá adresář /usr/ namísto standardního /usr/local/. Musít sdělit RPM souboru spec, které databáze podporovat a umístění adresáře nejvyšší úrovně databázového serveru.

Tento příklad vysvětluje proces přidání podpory populárního databázového serveru MySQL, pro instalaci PHP jako modulu do Apache.

Všechny tyto informace smaozřejmě mohou být upraveny pro libovolný databázový server, který PHP podporuje. Pro tento příklad budeme předpokládat, že jste instalovali MySQL a Apache plně z balíčků RPM.

  • Nejdříve odstraňte mod_php3 :

    rpm -e mod_php3

  • Potom vezměte zdrojový balíček RPM a spusťte na něm, NE --rebuild

    rpm -Uvh mod_php3-3.0.5-2.src.rpm

  • Upravte soubor /usr/src/redhat/SPECS/mod_php3.spec

    V sekci %build přidejte databázovou podporu, kterou chcete, a nastavte cestu.

    Pro MySQL byste přidali

    --with-mysql=/usr \

    Sekce %build bude vypadat přibližně takto:

        ./configure --prefix=/usr \
    --with-apxs=/usr/sbin/apxs \
    --with-config-file-path=/usr/lib \
    --enable-debug=no \
    --enable-safe-mode \
    --with-exec-dir=/usr/bin \
    --with-mysql=/usr \
    --with-system-regex

  • Poté, co jsou provedeny tyto změny, zkompilujte balíček takto:

    rpm -bb /usr/src/redhat/SPECS/mod_php3.spec

  • Potom balíček nainstalujte:

    rpm -ivh /usr/src/redhat/RPMS/i386/mod_php3-3.0.5-2.i386.rpm

Ujistěte se, že jste restartovali Apache, a nyní již máte PHP 3 s podporou MySQL. Uvědomte si, že je pravděpodobně mnohem jednodušší zkompilovat distribuční balíček tar a držet se instrukcí v souboru INSTALL.REDHAT z distribuce.

63.5. | UNIX: Přidal jsem do Apache patch pro FrontPage Extension a PHP náhle přestalo pracovat. Je PHP nekompatibilní s FrontPage Extension pro Apache?

Ne, PHP pracuje dobře i s FrontPage Extension. Problém je v tom, že FrontPage patch modifikuje některé struktury Apache, na které PHP spoléhá. Překompilování PHP (použitím 'make clean ; make') po instalaci FP patche by mělo problém vyřešit.

63.6. | UNIX/Windows: Nainstaloval jsem PHP, ale při pokusu načíst soubor PHP skriptu do prohlížeče se zobrazí pouze prázdná obrazovka.

V prohlížeči vyberte funkci 'zobrazit zdrojový kód', nejspíš uvidíte zdrojový kód vašeho PHP skriptu. To znamená, že server neposílá skript k interpretaci. Chyba je někde v konfiguraci serveru - raději dvakrát zkontrolujte konfiguraci podle instrukcí k instalaci PHP.

63.7. | UNIX/Windows: Nainstaloval jsem PHP a když chci načíst PHP soubor do prohlížeče, objeví se "500 Internal Server Error".

Při pokusu spustit PHP došlo k nějaké chybě. Abyste viděli detailnější chybovou zprávu, z příkazové řádky, přejděte do adresáře se souborem PHP (pod Windows php.exe) a spusťte php -i. Pokud při běhu PHP dojde k chybě, bude zobrazena odpovídající chybovou zpráva, která vám řekne, co se má dál udělat. Pokud získáte obrazovku plnou HTML kódu (výstup funkce phpinfo()), pak PHP funguje a váš problém může souviset s konfigurací serveru, kterou je pak třeba dobře zkontrolovat.

63.8. Některé operační systémy: Nainstaloval jsem PHP bez chyb, ale nyní, když zkusím spustit Apache, ohlásí se chyby o nedefinovaných symbolech:
[mybox:user /src/php4] root# apachectl configtest
 apachectl: /usr/local/apache/bin/httpd Undefined symbols:
  _compress
  _uncompress

To aktuálně nemá nic společného s PHP, ale s knihovnami klienta MySQL. Některé potřebují --with-zlib, jiné nikoli. Tímto se zabývá také MySQL FAQ.

63.9. Windows: Nainstaloval jsem PHP, ale při načtení stránky do prohlížeče se zobrazí chyba:
cgi error:
 The specified CGI application misbehaved by not
 returning a complete set of HTTP headers.
 The headers it did return are:

Tato chybová zpráva znamená, že z PHP nemohou vycházet žádná data. Abyste viděli detailnější chybovou zprávu, z příkazové řádky, přejděte do adresáře se souborem PHP (pod Windows php.exe) a spusťte php -i. Pokud při běhu PHP dojde k chybě, bude zobrazena odpovídající chybovou zpráva, která vám řekne, co se má dál udělat. Pokud získáte obrazovku plnou HTML kódu (výstup funkce phpinfo()), PHP funguje.

Jestliže PHP pracuje v příkazové řádce, zkuste to znovu z prohlížeče. Pokud to stále nefunguje, může to být jedním z těchto důvodů:

  • Nastavení přístupových práv k souboru se skriptem, k php.exe, php4ts.dll, php.ini nebo nějakému rozšíření PHP, které se pokoušíte načíst, je takové, že k nim anonymní internetový uživatel ISUR_<machinename> nemá přístup.
  • Soubor se skriptem neexistuje (nebo případně není tam, kde si myslíte, že je, relativně ke kořenovému adresáři webu). Uvědomte si, že na IIS můžete tuto chybu zachytit zaškrtnutím volby 'check file exists' při nastavování skriptových služeb v Internet Services Manageru. Pokud skript neexistuje, server vrátí chybu 404. Další výhodou je to, že IIS provede na souboru se skriptem všechny potřebné autentikace založené NTLanMan.
63.10. | Windows: Dodržel jsem všechny instrukce, ale PHP a IIS stále odmítají spolupracovat!

Ujistěte se, že každý uživatel, který potřebuje spouštět PHP skripty má práva pro spouštění php.exe! IIS používá anonymního uživatele, který se přidá při instalaci IIS. Tento uživatel potřebuje práva k php.exe. Také každý autentikovaný uživatel bude potřebovat práva na spouštění php.exe. A IIS4 musíte sdělit, že PHP je skriptovací engine.

Předcházející | Nahoru | Další
62. Záležitosti databází | Domů | 64. Sestavovací (kompilační) problémy


Kapitola 64. Sestavovací (kompilační) problémy

Tato sekce shrnuje nejčastější chyby, které se vyskytují při sestavování PHP.

64.1. Pomocí anonymního přístupu do CVS jsem získal poslední verzi PHP, ale chybí v ní skript "configure"!
64.2. Mám problém nakonfigurovat PHP tak, aby fungovalo se serverem Apache. Hlásí, že nemůže najít httpd.h, ale ten je přesně tam, kde jsem uvedl, že je!
64.3. Když spustím "configure", hlásí to, že nemůže najít "include" soubory nebo knihovny pro GD, gdbm a nějaké další balíky!
64.4. Když se kompiluje soubor language-parser.tab.c, hlásí to chyby, které říkají 'yytname undeclared'.
64.5. Když spustím "make", zdá se, že běží dobře, ale havaruje, když se pokouší sestavit konečnou aplikaci s hlášením, že nemůže najít nějaké soubory.
64.6. Při sestavování PHP to hlásí mnoho nedefinovaných referencí.
64.7. Nepřišel jsem na to, jak sestavit PHP pro Apache 1.3.
64.8. Postupoval jsem přesně podle instrukcí k instalaci PHP ve verzi jako modul pro Apache na UNIXu, a moje PHP skripty se zobrazují v prohlížeči nebo se je prohlížeč snaží uložit jako soubory.
64.9. Hlásí to použití --activate-module=src/modules/php4/libphp4.a, ale tento soubor neexistuje; proto jsem to změnil na --activate-module=src/modules/php4/libmodphp4.a a ono to nefunguje? O co jde?
64.10. Když zkusím sestavit Apache s PHP jakožto statickým modulem pomocí --activate-module=src/modules/php4/libphp4.a, hlásí to, že můj kompilátor nevyhovuje ANSI.
64.11. Když zkusím sestavit PHP s parametrem --with-apxs, dostanu záhadné chybové zprávy.
64.12. During 'make', I get errors in microtime, and a lot of 'RUSAGE_' stuff.
64.13. Chci upgradovat své PHP. Kde najdu tvar řádku ./configure, který byl použit pro sestavení stávající instalace PHP?
64.1. | Pomocí anonymního přístupu do CVS jsem získal poslední verzi PHP, ale chybí v ní skript "configure"!

Musíte mít nainstalovaný balík "GNU autoconf", takže můžete vygenerovat skript "configure" z "configure.in". Po stažení zdrojových souborů z CVS serveru spusťte ./buildconf z nejvyšší adresářové úrovně (pokud nespustíte "configure" s parametrem --enable-maintainer-mode, skript "configure" nebude automaticky aktualizován při změně souboru "configure.in", takže se musíte ujistit, zda jste to udělali ručně poté, co byl "configure.in" změněn. Jedním z příznaků tohoto je nalezení elementů jako @VARIABLE@ v souboru "Makefile" potom, co byl spuštěn "configure" nebo "config.status").

64.2. | Mám problém nakonfigurovat PHP tak, aby fungovalo se serverem Apache. Hlásí, že nemůže najít httpd.h, ale ten je přesně tam, kde jsem uvedl, že je!

Potřebujete sdělit konfiguračnímu/instalačnímu skriptu umístění nejvyšší úrovně zdrojových souborů Apache. To znamená, že specifikujete '--with-apache=/path/to/apache' a ne '--with-apache=/path/to/apache/src'.

64.3. | Když spustím "configure", hlásí to, že nemůže najít "include" soubory nebo knihovny pro GD, gdbm a nějaké další balíky!

Můžete určit, aby skript "configure" hledal hlavičkové soubory a knihovny na nestandardních místech specifikací pomocných příznaků pro C preprocesor a linker, například:

    CPPFLAGS=-I/path/to/include LDFLAGS=-L/path/to/library ./configure
Pokud používáte csh (C-shell) jako váš login shell (proč?), bylo by to:
    env CPPFLAGS=-I/path/to/include LDFLAGS=-L/path/to/library ./configure

64.4. | Když se kompiluje soubor language-parser.tab.c, hlásí to chyby, které říkají 'yytname undeclared'.

Musíte updatovat vaši verzi programu Bison. Nejnovější verzi najdete na » http://www.gnu.org/software/bison/bison.html.

64.5. | Když spustím "make", zdá se, že běží dobře, ale havaruje, když se pokouší sestavit konečnou aplikaci s hlášením, že nemůže najít nějaké soubory.

Některé starší verze programu "make" neukládají korektně zkompilované verze souborů umístěných v adresáři funkcí do téhož adresáře. Zkuste spustit "cp *.o functions" a potom znovu 'make', abyste viděli, zda to pomohlo. Pokud ano, měli byste opravdu nainstalovat nejnovější verzi "GNU make".

64.6. | Při sestavování PHP to hlásí mnoho nedefinovaných referencí.

Podívejte se do řádku, kde je popsáno sestavování a ujistěte se, že byly přidány na konec všechny potřebné knihovny. Často se stává, že chybí '-ldl' a některé knihovny potřebné pro podporu databáze, kterou jste určili.

Pokud sestavujete pro Apache 1.2.x, nezapomněli jste přidat odpovídající informace na řádek EXTRA_LIBS v souboru "configure" a spustit skript pro konfiguraci Apache? Pro více informací se podívejte do souboru » INSTALL, který získáte s distribučním balíkem.

Někteří lidé také hlásili, že pokud sestavovali pro Apache, museli přidat '-ldl' těsně za 'libphp4.a'.

64.7. | Nepřišel jsem na to, jak sestavit PHP pro Apache 1.3.

Toto je nyní velmi snadné. Následujte pečlivě tyto kroky:

  • Stáhněte nejnovější distribuci Apache 1.3 z » http://www.apache.org/.
  • Rozbalte ji někam, například do /usr/local/src/apache-1.3.
  • Zkompilujte PHP nejdříve spuštěním ./configure --with-apache=/<path>/apache-1.3 (nahraďte <path> aktuální cestou k adresáři apache-1.3).
  • Napište 'make' a potom 'make install' k sestavení PHP a zkopírování potřebných souborů do distribučního stromu Apache.
  • Změňte adresář na /<path>/apache-1.3/src a upravte soubor Configuration. Do souboru přidejte: AddModule modules/php4/libphp4.a.
  • Spusťte './Configure' a potom 'make'.
  • Nyní byste měli míst hotové soubory httpd pro práci s PHP.

Poznámka: : Můžete použít také nový skript ./configure pro Apache. Přečtěte si instrukce v README.configure, který je v distribuci Apache. Nahlédněte také do souboru INSTALL z distribuce PHP.

64.8. | Postupoval jsem přesně podle instrukcí k instalaci PHP ve verzi jako modul pro Apache na UNIXu, a moje PHP skripty se zobrazují v prohlížeči nebo se je prohlížeč snaží uložit jako soubory.

To znamená, že PHP modul není z nějakých důvodů vyvoláván. Dříve, než budete shánět další pomoc, zkontrolujte tři věci:

  • Ujistěte se, že se spouští právě ten httpd, který jste zkompilovali. Zkuste spustit /path/to/binary/httpd -l

    Pokud v seznamu neuvidíte mod_php4.c, potom nespouštíte správnou verzi httpd. Najděte s instalujte správnou verzi.

  • Ujistěte se, že jste přidali správnou specifikaci Mime Type do souborů .confpro Apache. Mělo by tam být: AddType application/x-httpd-php3 .php3 (pro PHP 3)

    nebo AddType application/x-httpd-php .php (pro PHP 4)

    Také se ujistěte, že tento řádek AddType není ukryt uvnitř bloku <Virtualhost> nebo <Directory>, což může zabránit aplikaci pravidla na oblast, kde je umístěn testovací skript.

  • Konečně, implicitní umístění konfiguračních souborů Apache se mezi verzemi Apache 1.2 a 1.3 změnilo. Měli byste ověřit, že soubor, do kterého jste přidali řádek AddType je ten, který je skutečně načítán. Můžete zkusit vložit nějakou příšernou syntaktickou chybu do souboru httpd.conf nebo udělat nějakou jinou změnu tohoto rázu - uvidíte, zda je soubor správně načítán.

64.9. | Hlásí to použití --activate-module=src/modules/php4/libphp4.a, ale tento soubor neexistuje; proto jsem to změnil na --activate-module=src/modules/php4/libmodphp4.a a ono to nefunguje? O co jde?

Uvědomte si, že soubor libphp4.a nemá existovat. Vytváří ho proces serveru Apache!

64.10. | Když zkusím sestavit Apache s PHP jakožto statickým modulem pomocí --activate-module=src/modules/php4/libphp4.a, hlásí to, že můj kompilátor nevyhovuje ANSI.

Toto je zavádějící chybové hlášení, které bylo odstraněno v pozdějších verzích.

64.11. | Když zkusím sestavit PHP s parametrem --with-apxs, dostanu záhadné chybové zprávy.

Je třeba zkontrolovat tři věci. Nejdříve, z důvodu, že když Apache vytváří apxs skript v Perlu, někdy ukončí kompilaci bez odpovídajících proměnných. Najděte skript apxs (zkuste příkaz 'which apxs', někdy bývá v /usr/local/apache/bin/apxs nebo /usr/sbin/apxs). Otevřte ho a zkontrolujte řádky podobné těmto:

my $CFG_CFLAGS_SHLIB  = ' ';          # nahrazeno pomocí Makefile.tmpl
my $CFG_LD_SHLIB      = ' ';          # nahrazeno pomocí Makefile.tmpl
my $CFG_LDFLAGS_SHLIB = ' ';          # nahrazeno pomocí Makefile.tmpl
Pokud vidíte toto, našli jste ten problém. Mohou se tam vyskytovat mezery nebo jiné nekorektní hodnoty, např. 'q()'. Změňte řádky takto:
my $CFG_CFLAGS_SHLIB  = '-fpic -DSHARED_MODULE'; # substituted via Makefile.tmpl
my $CFG_LD_SHLIB      = 'gcc';             # nahrazeno pomocí Makefile.tmpl
my $CFG_LDFLAGS_SHLIB = q(-shared);        # nahrazeno pomocí Makefile.tmpl
Druhý možný problém by měl vyskytovat pouze na Red Hat Linuxu 6.1 a 6.2. Skript apxs v těchto distribucích Red Hat je poškozený. Najděte řádek
my $CFG_LIBEXECDIR    = 'modules';         # nahrazeno pomocí APACI install
Pokud vidíte výše uvedený řádek, nahraďte ho tímto:
my $CFG_LIBEXECDIR    = '/usr/lib/apache'; # nahrazeno pomocí APACI install
Nakonec, když budete přeinstalovávat Apache, zařaďte 'make clean' mezi './configure' a 'make'.

64.12. | During 'make', I get errors in microtime, and a lot of 'RUSAGE_' stuff.

During the 'make' portion of installation, if you encounter problems that look similar to this:

    microtime.c: In function `php_if_getrusage':
    microtime.c:94: storage size of `usg' isn't known
    microtime.c:97: `RUSAGE_SELF' undeclared (first use in this function)
    microtime.c:97: (Each undeclared identifier is reported only once
    microtime.c:97: for each function it appears in.)
    microtime.c:103: `RUSAGE_CHILDREN' undeclared (first use in this function)
    make[3]: *** [microtime.lo] Error 1
    make[3]: Leaving directory `/home/master/php-4.0.1/ext/standard'
    make[2]: *** [all-recursive] Error 1
    make[2]: Leaving directory `/home/master/php-4.0.1/ext/standard'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/home/master/php-4.0.1/ext'
    make: *** [all-recursive] Error 1

Váš systém je poškozen. Musíte opravit soubory v /usr/include instalací balíku glibc-devel, který patří k vašemu glibc. Nemá to absolutně nic společného s PHP. Důkaz získáte tímto jednoduchým testem:

    $ cat >test.c <<X
    #include <sys/resource.h>
    X
    $ gcc -E test.c >/dev/null
Pokud se objeví chyby, ve vašich hlavičkových souborech panuje chaos.

64.13. | Chci upgradovat své PHP. Kde najdu tvar řádku ./configure, který byl použit pro sestavení stávající instalace PHP?

Když se podíváte do souboru config.nice ve zdrojovém stromu současné instalace PHP. Není-li k dispozici, jednoduše spusťte skript
Nahoře ve výpisu najdete řádek ./configure, který byl použit při sestavování stávající instalace.

Předcházející | Nahoru | Další
63. Instalace | Domů | 65. Používání PHP


Kapitola 65. Používání PHP

Tato část shrnuje nejčastější chyby, se kterými se můžete setkat při psaní PHP skriptů.

65.1. Chtěl bych napsat generický PHP skript, který by uměl zpracovat data z jakéhokoli formuláře. Jak se dozvím, které proměnné metody POST jsou k dispozici?
65.2. Potřebuji převést všechny apostrofy (') na zpětná lomítka následovaná apostrofy. Jak se to dá udělat pomocí regulárního výrazu?
65.3.
      Když napíšu následující kód, výstup se tiskne v nesprávném pořadí:

function myfunc($argument)
{
    echo $argument + 10;
}
$variable = 10;
echo "myfunc($variable) = " . myfunc($variable);

     what's going on?
65.4. Hej, co se stalo s mými konci řádků? <pre> <?php echo "Tohle by měl být první řádek."; ?> <?php echo "Tohle by se mělo ukázat na novém řádku."; ?> </pre>
65.5. Zobrazila se mi zpráva 'Warning: Cannot send session cookie - headers already sent...' nebo 'Cannot add header information - headers already sent...'.
65.6. Potřebuji přímo přistupovat k hlavičce požadavku. Jak to udělat?
65.7. Když zkusím autentikaci s IIS, dostanu 'No Input file specified'.
65.8. Můj PHP skript pracuje na IE a Lynxu, ale v Netscapu část výstupu mizí. Když si zapnu "Zobrazit zdrojový kód", v IE vidím obsah, v Netscapu nikoliv.
65.9. Jaké jsou předpoklady míchání XML a PHP? Stěžuje si to na moje <?xml> tagy!
65.10. Jak mohu použít PHP s FrontPagem nebo jiným HTML editorem, který trvá na odsunutí mého kódu?
65.11. Kde najdi úplný seznam dostupných přednastavených proměnných, a proč to není zdokumentováno v dokumentaci PHP?
65.12. Zkouším přistupovat k jedné ze standardních CGI proměnných (jako je $DOCUMENT_ROOT nebo $HTTP_REFERER) v uživatelsky definované funkci, a nemůže ji to najít. Co je špatně?
65.1. | Chtěl bych napsat generický PHP skript, který by uměl zpracovat data z jakéhokoli formuláře. Jak se dozvím, které proměnné metody POST jsou k dispozici?

Ujistěte se, že máte v souboru php.ini zapnuto track_vars Od PHP 4.0.3 je tato možnost vždy zapnuta. Pokud tomu tak je, vytvoří se nějaká asociativní pole, z nichž nejdůležitější je $HTTP_POST_VARS. Takže pro psaní generického skriptu pro obsluhu proměnných metody POST budete potřebovat přibližně toto: foreach ($HTTP_POST_VARS as $var => $value) {
    echo "$var = $value<br>\n";
}

65.2. | Potřebuji převést všechny apostrofy (') na zpětná lomítka následovaná apostrofy. Jak se to dá udělat pomocí regulárního výrazu?

Nejdříve se podívejte na funkci addslashes(). Dělá přesně to, co potřebujete. Měli byste se také podívat na direktivu magic_quotes_gpc v souboru php.ini.

65.3. Když napíšu následující kód, výstup se tiskne v nesprávném pořadí: function myfunc($argument)
{
    echo $argument + 10;
}
$variable = 10;
echo "myfunc($variable) = " . myfunc($variable); what's going on?

Pro použití výsledků vaší funkce ve výrazu (jako je spojení s jiným řetězcem v příkladu výše), musíte hodnotu vracet (pomocí vracet), ne tisknout() (pomocí echo()).

65.4. Hej, co se stalo s mými konci řádků? <pre>
<?php echo "Tohle by měl být první řádek."; ?>
<?php echo "Tohle by se mělo ukázat na novém řádku."; ?>
</pre>

V PHP se blok kódu zakončuje buď "?>", nebo "?>\n" (kde \n znamená nový řádek). Takže ve výše uvedeném příkladu budou vypsané věty na jediném řádku, protože PHP vynechává konce řádků za koncem bloku. To znamená, že musíte přidávat zvláštní konce řádků za každý blok PHP kódu, aby se vytisklo odřádkování jediné.

Proč to PHP dělá? Při formátování normálního HTML to obvykle zjednodušuje život, protože nechcete konce řádků, nýbrž chcete vytvořit extrémně dlouhé řádky nebo jinak znečitelnit zdrojový kód.

65.5. | Zobrazila se mi zpráva 'Warning: Cannot send session cookie - headers already sent...' nebo 'Cannot add header information - headers already sent...'.

Funkce header(), set_cookie() a funkce session musí do výstupu přidat hlavičky. Hlavičky je možno posílat pouze před vlastním obsahem. Funkce to udělají, pokud PHP běží jako modul Apache. Následující kus kódu zobrazí všechny hlavičky v požadavku: $headers = getallheaders();
foreach ($headers as $name => $content) {
    echo "headers[$name] = $content<br>\n";
}

65.6. | Potřebuji přímo přistupovat k hlavičce požadavku. Jak to udělat?

Funkce getallheaders() to udělá, pokud PHP běží jako modul do Apache. Následující kus kódu zobrazí všechny hlavičky v požadavku: $headers = getallheaders();
foreach ($headers as $name => $content) {
    echo "headers[$name] = $content<br>\n";
}

65.7. | Když zkusím autentikaci s IIS, dostanu 'No Input file specified'.

Bezpečnostní model IIS je s tím na štíru. Je to problém společný všem CGI programům běžícím pod IIS. Řešením je vytvořit obyčejný HTML soubor (neparsovaný PHP) jako vstupní stránku do autentikovaného adresáře. Potom se použije META tag k přesměrování na PHP stránku nebo odkaz k ručnímu přechodu. PHP pak autentikaci zpracuje správně. S modulem ISAPI toto není problémem. Jiných NT webovských serverů se problém netýká. Více informací - viz » http://support.microsoft.com/kb/q160422/.

65.8. | Můj PHP skript pracuje na IE a Lynxu, ale v Netscapu část výstupu mizí. Když si zapnu "Zobrazit zdrojový kód", v IE vidím obsah, v Netscapu nikoliv.

Netscape je striktnější ohledně HTML tagů (např. tabulek) něž IE. Kontrola HTML výstupu pomocí HTML validátoru, jako je » validator.w3.org, může být nápomocna. Například chybějící </table> způsobuje výše uvedený problém.

IE i Lynx také ignorují jakékoliv nulové (\0) znaky v HTML proudu, Netscape nikoli. Nejlepší cestou k ověření je zkompilovat verzi PHP pro příkazovou řádku (známou jako CGI verze) a spustit skript z příkazové řádky. Na *NIXech to přesměrujte do od -c a hledejte znaky \0. Pod Windows musíte najít editor nebo jiný program, který umožňuje prohlížení binárních souborů. Když Netscape uvidí v souboru nulový znak, typicky nic dalšího nezobrazí, ačkoli IE i Lynx ano.

65.9. | Jaké jsou předpoklady míchání XML a PHP? Stěžuje si to na moje <?xml> tagy!

Musíte vypnout krátké tagy v souboru php.ini nastavením short_tags na 0 nebo použitím odpovídající direktivy Apache. Můžete také použít sekci <File> k selektivnímu nastavení.

65.10. | Jak mohu použít PHP s FrontPagem nebo jiným HTML editorem, který trvá na odsunutí mého kódu?

Jedním z nejjednodušších způsobů je povolit použití ASP tagů v PHP kódu. To umožní používat oddělovače v ASP stylu (<% a %>). Některé populární HTML editory s pracují (v tuto chvíli) inteligentněji. K zapnutí ASP tagů musíte v souboru php.ini nastavit proměnnou asp_tags nebo použít příslušnou direktivu Apache.

65.11. | Kde najdi úplný seznam dostupných přednastavených proměnných, a proč to není zdokumentováno v dokumentaci PHP?

Nejlepší metodou je vložit do stránky <?php phpinfo(); ?> a načíst to do prohlížeče. Zobrazí se informace všeho druhu o nainstalovaném PHP, včetně seznamu proměnných prostředí i speciálních proměnných nastavovaných HTTP serverem. Tento seznam opravdu nemůže být zdokumentován v dokumentaci k PHP, protže se liší server od serveru.

65.12. | Zkouším přistupovat k jedné ze standardních CGI proměnných (jako je $DOCUMENT_ROOT nebo $HTTP_REFERER) v uživatelsky definované funkci, a nemůže ji to najít. Co je špatně?

Proměnné prostředí jsou normální globální proměnné, takže je musíte buď deklarovat ve funkci jako globální proměnné (například použitím "global $DOCUMENT_ROOT;") nebo použít pole globálních proměnných (např. "$GLOBALS["DOCUMENT_ROOT"]").

Předcházející | Nahoru | Další
64. Sestavovací (kompilační) problémy | Domů | 66. PHP a HTML


Kapitola 66. PHP a HTML

PHP a HTML mají hodně společného: PHP generuje HTML, a HTML má informace, které budou poslány PHP.

66.1. Jaké zakódování/dekódování potřebuji, když posílám hodnotu přes formulář? A v URL?
66.2. Zkouším použít tag <input type="image">, ale proměnné $foo.x a $foo.y nejsou dostupné. Kde jsou?
66.3. Jak vytvořím pole ("array") v HTML formuláři?
66.4. Jak získám všechna data z HTML elementu pro vícenásobný výběr?
66.1. | Jaké zakódování/dekódování potřebuji, když posílám hodnotu přes formulář? A v URL?

Je více situací, pro které je zakódování důležité. Za předpokladu, že máte string $data, který obsahuje řetězec, jenž máte nezakódovaný a chcete ho poslat, je třeba se zabývat těmito relevantními problémy:

  • HTML interpretace. Pokud specifikujete náhodný (obecný) řetězec, musíte ho dát do uvozovek a celý ho zpracovat funkcí htmlspecialchars() (aby se odstranily/převedly speciální znaky jazyka HTML).

  • URL: sestává z několika částí. Pokud chcete, aby vaše data byla interpretována jako jedna položka, musíte je zakódovat pomocí urlencode().

Příklad 66.1. Skrytý element HTML formuláře

<?php
    echo "<input type=hidden value=\"" . htmlspecialchars($data) . "\">\n";
?>

Poznámka: Je chybou použít urlencode() pro $data, protože prohlížeče samy zajišťují zpracování dat shodné s funkcí urlencode(). Všechny oblíbené prohlížeče to dělají korektně. Uvědomte si, že toto není závislé na použité metodě (např. GET nebo POST). Všimnete si toho však pouze v případě GET, protože požadavky POST jsou obvykle skryté.

Příklad 66.2. Data k editaci uživatelem

<?php
    echo "<textarea name=mydata>\n";
    echo htmlspecialchars($data)."\n";
    echo "</textarea>";
?>

Poznámka: Data jsou v prohlížeči zobrazena tak, jak bylo zamýšleno, protože prohlížeč bude správně interpretovat speciální symboly.

Po odeslání, ať již pomocí GET nebo POST, data budou zakódována způsobem urlencode pro přenos a následně přímo dekódována v PHP. Takže vůbec nepotřebujete provádět žádné zakódování/dekódování ručně, vše je prováděno automaticky.

Příklad 66.3. Uvnitř URL

<?php
    echo "<a href=\"" . htmlspecialchars("/nexpage.php?stage=23&data=" .
        urlencode($data)) . "\">\n";
?>

Poznámka: V tomto případě již opravdu vytváříte GET požadavek, proto je nutné data kódovat ručně pomocí urlencode().

Poznámka: Musíte také použít htmlspecialchars() na celý URL, protože URL je zde hodnotou HTML atributu. V tomto případě prohlížeč nejdříve odstraní speciální znaky a pak zpracuje URL. PHP správně pochopí posílaný URL, protože jste data zakódovali pomocí urlencoded().

Můžete se všimnout, že symbol & v URL je nahrazen &amp;. Přestože to většina prohlížečů opraví. pokud na to zapomenete, není to vždy možné. Takže pokud váš URL není dynamický, musíte použít htmlspecialchars().

66.2. | Zkouším použít tag <input type="image">, ale proměnné $foo.x a $foo.y nejsou dostupné. Kde jsou?

Když odesíláte formulář, lze namísto standardního tlačítka použít obrázek pomocí tagu jako

<input type="image" src="image.gif" name="foo">
Když uživatel klikne někde na obrázku, příslušný formulář se odešle na server s dvěma proměnnými navíc: foo.x a foo.y.

Protože $foo.x a $foo.y jsou v PHP neplatné názvy proměnných, jsou automaticky převedeny na $foo_x a $foo_y. Tzn. tečky jsou nahrazeny podtržítky.

66.3. | Jak vytvořím pole ("array") v HTML formuláři?

Aby výsledky odeslání vašeho formuláře byly umístěny v poli (array), nazvěte elementy <input>, <select> nebo <textarea> tímto způsobem:

<input name="MyArray[]">
<input name="MyArray[]">
<input name="MyArray[]">
<input name="MyArray[]">
Všimněte si hranatých závorek po názvu proměnné, to je to, co z toho dělá pole. Můžete seskupovat elementy do různých polí spojením stejného jména s různými elementy:

<input name="MyArray[]">
<input name="MyArray[]">
<input name="MyOtherArray[]">
<input name="MyOtherArray[]">
Toto produkuje dvě pole, MyArray a MyOtherArray, která budou zaslána PHP skriptu. Je také možné dát do polí specifické klíče:

<input name="AnotherArray[]">
<input name="AnotherArray[]">
<input name="AnotherArray[email]">
<input name="AnotherArray[phone]">
Pole AnotherArray bude nyní obsahovat klíče 0, 1, email a phone.

Poznámka: Specifikace klíců polí je v HTML nepovinné. Pokud klíče nespecifikujete, pole bude vyplněno podle pořadí elementů ve formuláři. Náš první příklad obsahuje klíče 0, 1, 2 a 3.

Viz také Funkce pro práci s poli a Proměnné z vnějšku PHP.

66.4. | Jak získám všechna data z HTML elementu pro vícenásobný výběr?

Tag pro vícenásobný výběr v HTML příkazu umožňuje uživatelům vybrat více položej ze seznamu. Tyto položky se posílají do handleru pro formulář. Problém je v tom, že se zpracovávají pod stejným jménem. Například:

<select name="var" multiple>
Každá vybraná možnost přijde do handleru akce jako:
var=option1
var=option2
var=option3
Každá volba tedy přepíše předchozí obsah proměnné $var Řešením je použít "pole vytvořené v elementu formuláře". Mělo by se použít toto:

<select name="var[]" multiple>
Výše uvedený kód říká PHP, že má proměnnou $var zpracovat jako pole a každé přiřazení hodnoty do var[] znamená přidání prvku do pole. První položka se tedy stane prvkem $var[0], další $var[1] atd. Funkci count() lze použít k určení, kolik možností bylo vybráno, a v případě potřeby lze seřadit pole funkcí sort().

Uvědomte si, že pokud používáte JavaScript, může přidání [] do názvu elementu způsobit problémy při pokusu odkazovat element jeho jménem. Tehdy použijte číselnou identifikaci elementu, nebo název proměnné uzavřete do apostrofů a použijte ho jako indexaci do pole elementů, například:

variable = documents.forms[0].elements['var[]'];

Předcházející | Nahoru | Další
65. Používání PHP | Domů | 67. PHP a COM


Kapitola 67. PHP a COM

PHP lze na platformách Win32 použít k přístupu k objektům COM a DCOM.

67.1. Zkompiloval jsem knihovnu DLL k nějakým výpočtům. Existuje způsob, jak tuto knihovnu spustit pod PHP?
67.2. Co znamená 'Unsupported variant type: xxxx (0xxxxx)'?
67.3. Je možné v PHP manipulovat vizuálními objekty?
67.4. Mohu ukládat COM objekty do session?
67.5. Jak mohu zachycovat chyby COM?
67.6. Mohu generovat knihovny DLL z PHP skriptů, podobně jako v Perlu?
67.7. Co znamená 'Unable to obtain IDispatch interface for CLSID {xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx}'?
67.8. Jak lze spustit objekt COM ze vzdáleného serveru?
67.9. Zobrazilo se 'DCOM is disabled in C:\path...\scriptname.php on line 6', co mám dělat?
67.10. Lze načíst objekt ActiveX na stránce, resp. s ním manipulovat, pomocí PHP?
67.11. Je možné získat běžící instanci komponenty?
67.12. Existuje způsob, jak obsloužit událost odeslanou z objektu COM?
67.13. Mám problémy, když se pokouším vyvolat metodu objektu COM, která vystavuje více než jeden interface. Co mám dělat?
67.14. Když PHP pracuje s COM, jak je to s COM+?
67.15. Jestliže může PHP manipulovat s objekty COM, lze si představit použití MTS ke správě prostředků komponent společně s PHP?
67.1. | Zkompiloval jsem knihovnu DLL k nějakým výpočtům. Existuje způsob, jak tuto knihovnu spustit pod PHP?

Pokud je to jednoduchá DLL knihovna, zatím ji není možné spustit z PHP. Pokud však tato knihovna obsahuje COM server, můžete k ní přistupovat, pokud implementuje interface IDispatch.

67.2. | Co znamená 'Unsupported variant type: xxxx (0xxxxx)'?

Existují tucty typů VARIANT a jejich kombinací. Většina z nich je již podporována, ale několik z nich teprve musí být implementováno. Pole nejsou podporována plně. Mezi PHP a COM lze vyměňovat pouze jednorozměrná indexovaná pole. Pokud najdete jiné typy, které nejsou podporovány, ohlašte je prosím jako chybu - bug (pokud již nebyly ohlášeny) a poskytněte o nich tolik informací, kolik můžete.

67.3. | Je možné v PHP manipulovat vizuálními objekty?

Obecně je, ale protože PHP se nejčastěji používá jako webovský skriptovací jazyk, běží v prostředí WWW serveru, a proto se vizuální objekty nezobrazují na ploše displeje serveru. Pokud používáte PHP pro aplikační skriptování, např. společně s PHP-GTK, neexistuje omezení přístupu a manipulace s vizuálními objekty pomocí COM.

67.4. | Mohu ukládat COM objekty do session?

Nemůžete. S instancemi COM se nakládá jako s prostředky a proto jsou k dispozici pouze v kontextu jediného skriptu.

67.5. | Jak mohu zachycovat chyby COM?

Momentálně není možné zachycovat chyby COM kromě způsobů poskytovaných samotným PHP (@, track_errors, ...), nicméně přemýšlíme o způsobu, jak to implementovat.

67.6. | Mohu generovat knihovny DLL z PHP skriptů, podobně jako v Perlu?

Ne, v PHP bohužel není takový nástroj k dispozici.

67.7. | Co znamená 'Unable to obtain IDispatch interface for CLSID {xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx}'?

Tato chyba může mít více příčin:

  • hodnota CLSID je chybná
  • chybí požadovaná DLL knihovna
  • požadovaná komponenta neimplementuje interface IDispatch

67.8. | Jak lze spustit objekt COM ze vzdáleného serveru?

Přesně tak, jak spouštíte místní objekty. Musíte pouze použít IP adresu vzdáleného stroje jako druhý parametr konstruktoru COM.

Ujistěte se, že je nastaveno com.allow_dcom=true v souboru php.ini.

67.9. | Zobrazilo se 'DCOM is disabled in C:\path...\scriptname.php on line 6', co mám dělat?

Upravte soubor php.ini - nastavte tam com.allow_dcom=true.

67.10. | Lze načíst objekt ActiveX na stránce, resp. s ním manipulovat, pomocí PHP?

To nemá s PHP nic společného. Objekty ActiveX se načítají na straně klienta, pokud jsou vyžádány HTML dokumentem. Nemá to žádnou souvislost s PHP skriptem a proto není možná žádná přímá interakce na straně serveru.

67.11. | Je možné získat běžící instanci komponenty?

Je to možné pomocí "monikerů". Pokud chcete získat více referencí na tutéž instanci, můžete vytvořit tuto instanci tímto způsobem:

$word = new COM("C:\docs\word.doc");

Toto vytvoří novou instanci, pokud není k dispozici žádná běžící instance, resp. vrátí handle na běžící instanci.

67.12. | Existuje způsob, jak obsloužit událost odeslanou z objektu COM?

Zatím ne.

67.13. | Mám problémy, když se pokouším vyvolat metodu objektu COM, která vystavuje více než jeden interface. Co mám dělat?

Odpověď je stejně tak jednoduchá, jako neuspokojivá. Nelze to říci přesně, ale asi nemůžete dělat nic. Pokud má někdo specifické informace o tomto problému, ať laskavě napíše » sem.

67.14. | Když PHP pracuje s COM, jak je to s COM+?

COM+ rozšiřuje COM rámec pro správu komponent přes MTS a MSMQ, ale není to nic zvláštního na to, aby PHP muselo takové komponenty podporovat.

67.15. | Jestliže může PHP manipulovat s objekty COM, lze si představit použití MTS ke správě prostředků komponent společně s PHP?

PHP samotné nemůže zatím obsluhovat transakce. Proto když nastane chyba, není iniciován žádný rollback. Pokud používáte komponenty, které podporují transakce, budete muset implementovat vlastní mechanismus správy transakcí.

Předcházející | Nahoru | Další
66. PHP a HTML | Domů | 68. PHP a jiné jazyky


Kapitola 68. PHP a jiné jazyky

PHP je nejlepší jazyk pro webové programování, ale co jiné jazyky?

68.1. PHP vs. ASP?
68.2. Existuje konvertot z ASP do PHP?
68.3. PHP vs. Cold Fusion?
68.4. PHP vs. Perl?
68.1. | PHP vs. ASP?

ASP ve skutečnosti není jazyk jako takový, je to zkratka pro Active Server Pages, jazyky nyní používanými k programování ASP jsou Visual Basic Script a JScript. Největší nevýhodou ASP je to, že se jedná o proprietární systém, který je nativně používán pouze na serveru Microsoft Internet Information Server (IIS). To omezuje jeho dostupnost na servery založené na Win32. Existuje několik projektů, které umožňují běh ASP v jiných prostředích a serverech: » InstantASP od » Halcyon (komerční), » Chili!Soft ASP od » Chili!Soft (komerční) a » OpenASP od ActiveScripting.org (free). O ASP se tvrdí, že je pomalejší a těžkopádnější, a stejně tak i méně stabilní. Z výhod ASP lze uvést to, že primárně používá VBScript, který je poměrně snadno uchopitelný, pokud již víte, jak programovat ve Visual Basicu. Podpora ASP je také standardně zapnuta na IIS, takže se snadno spustí a běží. Komponenty zabudované v ASP jsou opravdu omezené, takže pokud potřebujete použít "pokročilé" prvky, jako interakce s FTP servery, musíte si koupit doplňující komponenty.

68.2. | Existuje konvertot z ASP do PHP?

Ano, jedním z nejčastěji zmiňovaných je » asp2php.

68.3. | PHP vs. Cold Fusion?

O PHP se často tvrdí, že je rychlejší a efektivnější pro složité programové úlohy a zkoušení nových myšlenek. PHP je obecně zmiňováno jako stabilnější a méně náročné na systémové prostředky. Cold Fusion má lepší zpracování chyb, databázovou abstrakci a parsování dat, ačkoliv databázová abstrakce je addressed in PHP 4. Jinou věcí, která je uváděna jako silný nástroj Cold Fusion, je jeho výborný vyhledávací engine, avšak s tím, že vyhledávací engine není něco, co by mělo být součástí skriptovacího jazyka pro web. PHP běží na většině existujících platforem; Cold Fusion je k dispozici pouze na Win32, Solarisu, Linuxu a HP/UX. Cold Fusion má dobré IDE a je obecně jednodušší pro začátky, zatímco PHP vyžaduje více programátorských znalostí. Produkt Cold Fusion je navržen s ohledem na neprogramátory, PHP je naopak zaměřeno na programátory.

Velký souhrn na toto téma od Michaela J. Sheldona bylo posláno do mailové konfernce PHP. Kopii najdete » ¨zde.

68.4. | PHP vs. Perl?

Největší výhodou PHP oproti Perlu je, že PHP bylo navrženo pro skriptování pro web, kdežto cílem Perlu bylo dělat mnohem víc věcí, a může proto být velmi komplikovaný. Flexibilita/složitost Perlu usnadňuje napsání kódu, který bude pro jiného autora těžko čitelný. PHP má méně zmatečný a striktnější formát beze ztráty flexibility. PHP je oproti Perlu jednodušší integrovat do existujícího HTML kódu. PHP obsahuje mnoho z "dobré" funkcionality Perlu: příkazy, syntaxi apod., bez komplikovanosti, kterou může Perl přinést. Perl je dobře vyzkoušený a "opravdový jazyk", byl k dispozici již na konci 80. let, ale PHP rychle dospívá.

Předcházející | Nahoru | Další
67. PHP a COM | Domů | 69. Přechod z PHP 2 na PHP 3


Kapitola 69. Přechod z PHP 2 na PHP 3

PHP má již za sebou dlouhou historii: Legendární PHP 1.0, PHP/FI, PHP 3.0 a PHP 4.0.

69.1. Přechod z PHP 2 na PHP 3?
69.1. | Přechod z PHP 2 na PHP 3?
 | PHP/FI 2.0 již není podporováno. Podívejte se prosím do odpovídající části manuálu, kde najdete informace o přechodu z PHP/FI 2.0. Pokud stále používáte PHP 2, vřele vám doporučujeme upgradovat přímo na PHP 4.
Předcházející | Nahoru | Další
68. PHP a jiné jazyky | Domů | 70. Přechod z PHP 3 na PHP 4


Kapitola 70. Přechod z PHP 3 na PHP 4

PHP má již za sebou dlouhou historii: Legendární PHP 1.0, PHP/FI, PHP 3.0 a PHP 4.0.

70.1. Přechod z PHP3 na PHP4
70.2. Nekompatibilní funkce?
70.1. | Přechod z PHP3 na PHP4
 | PHP 4 bylo navrženo tak, aby bylo tak kompatibilní se staršími verzemi, jak je to jen možné, a přitom se ztratila troška funkčnosti. Pokud jste opravdu nejistí ohledně kompatibility, měli byste nainstalovat PHP 4 do testovacího prostředí a spouštět skripty tam. Viz také příslušný dodatek tohoto manuálu.
70.2. | Nekompatibilní funkce?
 | Přestože je PHP 4 kompletně přepsaný PHP engine, je jen velmi málo funkcí, která se změnily a to pouze ty exotičtější.
Předcházející | Nahoru | Další
69. Přechod z PHP 2 na PHP 3 | Domů | 71. Přechod z PHP 4 na PHP 5


Kapitola 71. Přechod z PHP 4 na PHP 5

Tato sekce FAQ This faq section will help you migrate from PHP 4 to PHP 5.

71.1. Přechod z PHP 4 na PHP 5
71.2. Funguje MySQL v PHP 5? Does MySQL work in PHP 5? Zdá se mi, že to zmizelo.
71.3. Slyšel jsem, že PHP používá úplně nový model OOP, bude můj existující OOP kód fungovat? Kde najdu informace o těchto nových vlastnostech OOP?
71.4. Kromě nového modelu OOP, co se dalšího změnilo v PHP 5? A také, existuje specifická verze manuálu pro PHP 5?
71.1. | Přechod z PHP 4 na PHP 5

Přestože PHP 5 nabízí mnoho nových vlastností, je navrženo tak, aby bylo kompatibilní s dřívějšími verzemi PHP jak je to jen možné, s jen malým narušením funkcionality.

Určitě si přečtěte příslušný dodatek o přechodu na PHP 5 v tomto manuálu, protože obsahuje mnohem více informací na téma přechodu na PHP 5.

71.2. | Funguje MySQL v PHP 5? Does MySQL work in PHP 5? Zdá se mi, že to zmizelo.

Databáze MySQL je podporována, změna je pouze v tom, že ve výchozím stavu není v PHP 5 podpora MySQL zapnuta. To v zásadě znamená, že PHP nezahrnuje volbu --with-mysql v configure, takže to musíte při kompilaci PHP udělat ručně. Uživatelé Windows upraví php.ini a povolí knihovnu php_mysql.dll, která v PHP 4 neexistovala, podpora MySQL byla jednoduše zakompilována do programu PHP.

Tedy, klientské knihovny MySQL již nejsou přímou součástí PHP. Více detailů na toto téma řeší následující FAQ, a určitě si přečtěte sekci MySQL ohledně detailů instalace MySQL. Příklad konfigurace by mohl být --with-mysql=/usr, přičemž uživatelé Windows budou potřebovat mít v systému dostupnou knihovnu libmySQL.dll.

71.3. | Slyšel jsem, že PHP používá úplně nový model OOP, bude můj existující OOP kód fungovat? Kde najdu informace o těchto nových vlastnostech OOP?

Hlavní změnou v PHP 5 je, že model OOP od PHP 5 nyní používá Zend Engine 2.0. Direktiva zend.ze1_compatibility_mode zapne kompatibilitu se Zend Engine 1.0 (PHP 4).

Nový model OOP je zdokumentován v sekcích Jazyková reference OOP a Dodatek o přechodu OOP.

71.4. | Kromě nového modelu OOP, co se dalšího změnilo v PHP 5? A také, existuje specifická verze manuálu pro PHP 5?

Existuje pár dalších změn, pro detaily viz dodatek o přechodu na PHP 5. Specifická verze manuálu pro PHP 5 není, většina PHP zůstává stejná.

Předcházející | Nahoru | Další
70. Přechod z PHP 3 na PHP 4 | Domů | 72. Ostatní otázky


Kapitola 72. Ostatní otázky

Mohou existovat otázky, které nemůžeme umístit do žádné jiné kategorie. Najdete je zde.

72.1. Mohu s manuály komprimovanými pomocí bz2 pracovat ve Windows?
72.1. Mohu s manuály komprimovanými pomocí bz2 pracovat ve Windows?

Pokud nemáte archivační nástroj pro práci se soubory bz2, » stáhněte si nástroj pro příkazovou řádku od RedHatu (viz níže).

Pokud byste nechtěli používat nástroj pro příkazovou řádku, můžete zkusit free software » Stuffit Expander, » UltimateZip, » 7-Zip nebo » Quick Zip. Máte-li » WinRAR nebo » Power Archiver, můžete s ním také snadno dekomprimovat bz2 soubory. Pokud používáte Windows Commander, plugin pro bz2 je k dispozici zdarma přímo na stránce programu » Windows Commander.

Nástroj příkazové řádky bzip2 od firmy Redhat:

Uživatelé Win2k SP2 ať si stáhnou nejnovější verzi 1.0.2, uživatelé ostatních systémů Windows by si měli stáhnout verzi 1.00. Po stažení přejmenujte spustitelný soubor na bzip2.exe. Je výhodné přesunout ho do adresáře v nastavení cest, např. C:\Windows (kde C představuje disk, kde jsou nainstalovány Windows).

Pozn.: "lang" představuje váš jazyk a "x" zvolený formát, např. pdf. K rozbalení souboru php_manual_lang.x.bz2 postupujte podle těchto kroků:

  • otevřte okno příkazové řádky
  • přejděte do složky, kde je uložen stažený soubor php_manual_lang.x.bz2
  • spusťte bzip2 -d php_manual_lang.x.bz2, rozbalí php_manual_lang.x do téže složky

V případě, že jste stáhli php_manual_lang.tar.bz2 obsahující v sobě více HTML souborů, je procedura stejná. Jediný rozdíl je ten, že obdržíte soubor php_manual_lang.tar. O formátu tar je známo, že ho lze zpracovat běžnými archivačními programy na Windows, jako je » WinZip.

Předcházející | Nahoru | Další
71. Přechod z PHP 4 na PHP 5 | Domů | IX. Appendices


Příloha A. Historie PHP a souvisejících projektů

Obsah

Historie PHP
Historie projektů souvisejících s PHP
Knihy o PHP
Ostatní publikace o PHP

PHP urazilo v posledních několika málo letech dlouhou cestu. Růst v jeden z nejprominentnějších jazyků ovládajích Web nebyl snadný. Ti z vás, kdo máte zájem dozvědět se ve zkratce, jak PHP vyrostlo do dnešní podoby, čtěte dále. Staré verze PHP lze najít v » PHP Muzeu.

Historie PHP

PHP/FI

PHP je nástupcem staršího produktu, nazvaného PHP/FI. PHP/FI vytvořil Rasmus Lerdorf v roce 1995, na počátku jako jednoduchou sadu skriptů v jazyce Perl pro zpracování záznamů o přístupech k jeho webu. Tuto sadu nazval 'Personal Home Page Tools'. Protože byla třeba větší funkčnost, napsal Rasmus mnohem rozsáhlejší implementaci v C, která byla schopna komunikovat s databázemi aumožňovala uživatelům vyvíjet jednoduché dynamické aplikace pro Web. Rasmus se rozhodl » uvolnit zdrojový kód PHP/FI pro všechny, takže kdokoli ho může používat, stejně jako opravovat chyby a vylepšovat kód.

PHP/FI, což znamená Personal Home Page / Forms Interpreter, obsahovalo něco ze základní funkcionality PHP, jak ho známe dnes. Mělo proměnné perlovského typu, automatickou interpretaci formulářových proměnných a syntaxi vloženou do HTML. Syntaxe samotná byla podobná jazyku Perl, přestože mnohem omezenější, jednodušší a v něčem nekonzistentní.

V roce 1997 se PHP/FI 2.0, druhá implementace psaná v C, stala kultovní záležitostí pro (odhadem) tisíce uživatelů po celém světě, a s přibližně 50.000 doménami oznamujícími nainstalované PHP/FI, což čítalo zhruba 1 % všech domén na Internetu. I když do projektu začalo svými kusy kódu přispívat více lidí, stále to byl velký projekt jednoho muže.

PHP/FI 2.0 bylo oficiálně uvolněno až v listopadu 1997, poté co strávilo většinu svého života v betaverzích. Krátce nato bylo následováno první alfaverzí PHP 3.0.

PHP 3

PHP 3.0 byla první verze, která se velmi blížila takovému PHP, jak ho známe dnes. Vytvořili ho Andi Gutmans a Zeev Suraski v roce 1997 jako kompletně přepsaný celek, poté co shledali PHP/FI 2.0 výrazně "poddimenzované" pro vývoj svých aplikací pro e-komerci. Ve snaze spolupracovat a zahájit budování nad existující uživatelskou základnou PHP/FI, rozhodli se Andi, Rasmus a Zeev pracovat společně a prohlásit PHP 3.0 za oficiálního nástupce PHP/FI 2.0, a vývoj PHP/FI 2.0 byl v podstatě zastaven.

Jednou z nejsilnějších zbraní PHP 3.0 byly jeho obrovské možnosti rozšíření. K poskytnutí pevné infrastruktury pro mnoho různých databází, protokolů a API koncovým uživatelům, přilákaly možnosti rozšíření PHP 3.0 také tucty vývojářů, kteří se připojili a vytvořili nové rozšiřující moduly. Toto byl nesporně klíč k obrovskému úspěchu PHP 3.0. Jiným klíčovým prvkem v PHP 3.0 byla podpora objektově orientované syntaxe a mnohem silnější a konzistentnější syntaxe jazyka.

Nový jazyk byl uvolněn pod novým názvem, který odstranil implikaci omezeného osobního použití, kterou neslo označení PHP/FI 2.0. Byl nazván pouze 'PHP', což je rekurzívní akronym - PHP: Hypertext Preprocessor.

Na konci roku 1998 vyrostlo PHP do rozsahu instalací v řádu (odhadem) desítek tisíc uživatelů a stovek tisíc Webů. V době svého vrcholu bylo PHP 3.0 instalováno na přibližně 10 % všech WWW serverů na Internetu.

PHP 3.0 bylo oficiálně uvolněno v červnu 1998, poté co strávilo cca 9 měsíců ve veřejném testování.

PHP 4

V zimě 1998, krátce po oficiálním uvolnění PHP 3.0, začali Andi Gutmans a Zeev Suraski pracovat na přespání jádra PHP. Cílem návrhu bylo zvýšit výkon pro složité aplikace a zlepšit modularitu kódové báze PHP. Takové aplikace byly schopny pracovat s PHP 3.0 (díky novým možnostem a podpoře široké škály databází a API od jiných tvůrců), ale PHP 3.0 nebylo navrženo pro efektivní práci tak náročných aplikací.

Nový engine, nazvaný 'Zend Engine' (sestaven z jejich křestních jmen, Zeev a Andi), úspěšně splnil cíle návrhu a byl uveden v polovině roku 1999. PHP 4.0, založené na tomto enginu a doplněné širokou škálou nových prvků, bylo oficiálně uvolněno v květnu 2000, necelé dva roky po svém předchůdci, PHP 3.0. K podstatně zvýšenému výkonu této verze, přidává PHP 4.0 další klíčové prvky, jako je podpora pro mnoho WWW serverů, HTTP sessions, buffering výstupu, bezpečnější způsoby zpracování vstupů uživatele a mnoho nových jazykových konstruktů.

Dnes používají PHP (odhadem) stovky tisíc vývojářů a nainstalované PHP hlásí několik milionů serverů - tj. přes 20 % domén na Internetu.

Vývojový tým PHP zahrnuje tucty vývojářů, stejně tak jako tucty dalších lidí, kteří pracují na projektech spojených s PHP, jako je PEAR a dokumentační projekt.

PHP 5

PHP 5 bylo vydání v červenci 2004 po dlouhém vývoji a řadě předverzí. Je řízeno hlavně svým jádrem, Zend Engine 2.0, s novým objektovým modelem a tucty nových vlastností. Pro více informací o tomto jádře, viz » jeho stránky.

Předcházející | Nahoru | Další
IX. Appendices | Domů | Historie projektů souvisejících s PHP


Historie projektů souvisejících s PHP

PEAR

» PEAR, PHP Extension and Application Repository (česky repozitář rozšíření a aplikací PHP) - původně PHP Extension and Add-on Repository (repozitář rozšíření a doplňků) - je PHP verze "foundation classes", a může v budoucnu vyrůst v jeden z klíčových způsobů distribuce rozšíření PHP mezi vývojáře.

PEAR se zrodil v diskusi na mítinku PHP Developers' Meeting (PDM) v lednu 2000 v Tel Avivu. Byl vytvořen Stigem S. Bakkenem a delegován na jeho prvorozenou dceru Malin Bakken.

Od začátku roku 2000 PEAR vyrostl ve velký, významný projekt s velkým počtem vývojářů pracujících na společné, široce použitelné funkcionalitě ve prospěch celé PHP komunity. PEAR dnes zahrnuje širokou paletu infrastrukturních "foundation classes" pro přístup k databázím, cachování obsahu e-komerci a mnoho dalšího.

Více informací o PEAR lze najít v » manuálu.

PHP Quality Assurance Initiative

» PHP Quality Assurance Initiative (iniciativa zajištění kvality PHP) byla ustavena v létě 2000 v rakci na kritiku, že uvolněné verze PHP nebyly dostatečně testovány pro produkční prostředí. Tým nyní sestává z pevné skupiny vývojářů, kteří dobře rozumějí kódové bázi PHP. Tito vývojáři tráví mnoho času lokalizací a odstraňováním chyb v PHP. Navíc je zde mnoho členů týmu, kteří to pak testují a poskytují zpětnou vazbu na tyto opravy na široké škále platforem.

PHP-GTK

» PHP-GTK je PHP řešení pro psaní GUI aplikací pro stranu klienta. Andrei Zmievski připomíná plánování a proces tvorby PHP-GTK:

Programování GUI vždy patřilo mezi mé zájmy a shledal jsem Gtk+ velmi příjemným toolkitem, kromě toho, že programovat s jeho použitím v C je někdy nudné. Po zkušenostech s PyGtk a GTK-Perl implemetacemi jsem se rozhodl podívat se, zda by se dalo v PHP vytvořit, alespoň trochu, rozhraní ke Gtk+. Počínaje srpnem 2000 jsem měl o něco více volného času, takže jsem začal experimentovat. Mým hlavním vodítkem byla implementace PyGtk, což bylo skutečně funkčně kompletní a příjemné objektově orientované rozhraní. James Henstridge, autor PyGtk, mi poskytl velmi užitečné rady během počatečního stádia vývoje.

Ruční psaní rozhraní ke všem funkcím Gtk+ bylo zcela mimo hru, takže jsem se zabýval ideou generátoru kódu, podobného jako v případě PyGtk. Generátor kódu je program v PHP, který čte sadu .defs souborů obsahujících informace o třídách, konstantách a metodách Gtk+ a generuje kód v C, který pro ně poskytuje rozhraní. Co nelze vygenerovat automaticky, může být napsáno ručně v souboru .overrides.

Práce na generátoru kódu a na infrastruktuře trvala nějakou dobu, protože jsem na podzim 2000 mohl práci na PHP-GTK věnovat jen málo času. Když jsem to pak ukázal Franku Kromannovi, byl zaujat a začal mi pomáhat s prací na generátoru kódu a implementaci pro Win32. Když jsme napsali první program "Ahoj světe!" a spustili ho, bylo to extrémně vzrušující. Trvalo to několik měsíců, než se projekt dostal do prezentovatelného stavu a úvodní verze byla uvolněna 1 .března 2001. Příběh okamžitě zasáhl SlashDot.

S ohledem na to, jak může být projekt PHP-GTK rozsáhlý, založil jsem pro něj samostatné diskusní skupiny a CVS repozitáře, stejně jako (s pomocí Colina Viebrocka) webovskou stránku gtk.php.net. Také by bylo třeba udělat dokumentaci a James Moore přispěchal pomoci s ní.

Uvolněná verze PHP-GTK si již získala popularitu. Máme vlastní dokumentační tým, manuál se stále zlepšuje, lidé začínají psát rozšíření pro PHP-GTK, a víc a víc vzrušujících aplikací.

Předcházející | Nahoru | Další
A. Historie PHP a souvisejících projektů | Domů | Knihy o PHP


Knihy o PHP

Jak PHP rostlo, začalo být považováno za celosvětově populární vývojovou platformu. Jedním z nejzajímavějších způsobů pozorování tohoto trendu je sledování knih o PHP vydávaných během posledních let.

Pokud si dobře pamatujeme, první kniha zaměřená na PHP byla 'PHP - tvorba interaktivních internetových aplikací' - česká kniha vydaná v dubnu 1999, jejímž autorem je Jirka Kosek. V následujícím měsící vyšla německá kniha - autoři Egon Schmid, Christian Cartus and Richard Blume. První kniha v angličtině byla vydána krátce nato: 'Core PHP Programming' od Leona Atkinsona. Všechny tyto knihy se zabývaly PHP 3.0.

Tyto knihy byly první svého druhu - a byly následovány velkým množstvím knih různých autorů a vydavatelů. Existuje přes 40 knih v angličtině, 50 knih v němčině a přes 20 knih ve francouzštině. Navíc můžete najít knihy o PHP v mnoha dalších jazycích včetně španělštiny, korejštiny, japonštiny a hebrejštiny.

Samozřejmě, tento velký počet knih, psaných různými autory, vydávaných mnoha vydavateli a jejich dostupnost v tolika jazycích - je potvrzením celosvětového úspěchu PHP.

Předcházející | Nahoru | Další
Historie projektů souvisejících s PHP | Domů | Ostatní publikace o PHP


Ostatní publikace o PHP

Podle našich nejlepších informací byl první článek o PHP v tištěném časopisu publikován v české mutaci magazínu Computerworld na jaře 1998 a zabýval se PHP 3.0. Stejně jako v případě knih byl první v dlouhé řadě článků publikovaných v různých uznávaných časopisech.

Články o PHP se objevily v časopisech Dr. Dobbs, Linux Enterprise, Linux Magazine a mnoha dalších. Články o přechod z aplikací založených na ASP na platformu PHP pod Windows se objevily dokonce na ryze Microsoftím MSDN!

Předcházející | Nahoru | Další
Knihy o PHP | Domů | B. Migrating from PHP 5.1.x to PHP 5.2.x


Příloha D. Migrating from PHP 4 to PHP 5

Obsah

What has changed in PHP 5
Backward Incompatible Changes
CLI and CGI
Migrating Configuration Files
New Functions
New Directives
Databases
New Object Model
Error Reporting

What has changed in PHP 5

PHP 5 and the integrated Zend Engine 2 have greatly improved PHP's performance and capabilities, but great care has been taken to break as little existing code as possible. So migrating your code from PHP 4 to 5 should be very easy. Most existing PHP 4 code should be ready to run without changes, but you should still know about the few differences and take care to test your code before switching versions in production environments.

Předcházející | Nahoru | Další
Checking for E_STRICT | Domů | Backward Incompatible Changes


Backward Incompatible Changes

Although most existing PHP 4 code should work without changes, you should pay attention to the following backward incompatible changes:

  • There are some new reserved keywords.
  • strrpos() and strripos() now use the entire string as a needle.
  • Illegal use of string offsets causes E_ERROR instead of E_WARNING. An example illegal use is: $str = 'abc'; unset($str[0]);.
  • array_merge() was changed to accept only arrays. If a non-array variable is passed, a E_WARNING will be thrown for every such parameter. Be careful because your code may start emitting E_WARNING out of the blue.
  • PATH_TRANSLATED server variable is no longer set implicitly under Apache2 SAPI in contrast to the situation in PHP 4, where it is set to the same value as the SCRIPT_FILENAME server variable when it is not populated by Apache. This change was made to comply with the » CGI specification. Please refer to » bug #23610 for further information, and see also the $_SERVER['PATH_TRANSLATED'] description in the manual. This issue also affects PHP versions >= 4.3.2.
  • The T_ML_COMMENT constant is no longer defined by the Tokenizer extension. If error_reporting is set to E_ALL, PHP will generate a notice. Although the T_ML_COMMENT was never used at all, it was defined in PHP 4. In both PHP 4 and PHP 5 // and /* */ are resolved as the T_COMMENT constant. However the PHPDoc style comments /** */, which starting PHP 5 are parsed by PHP, are recognized as T_DOC_COMMENT.
  • $_SERVER should be populated with argc and argv if variables_order includes "S". If you have specifically configured your system to not create $_SERVER, then of course it shouldn't be there. The change was to always make argc and argv available in the CLI version regardless of the variables_order setting. As in, the CLI version will now always populate the global $argc and $argv variables.
  • An object with no properties is no longer considered "empty".
  • In some cases classes must be declared before use. It only happens if some of the new features of PHP 5 (such as interfaces) are used. Otherwise the behaviour is the old.

  • get_class(), get_parent_class() and get_class_methods() now return the name of the classes/methods as they were declared (case-sensitive) which may lead to problems in older scripts that rely on the previous behaviour (the class/method name was always returned lowercased). A possible solution is to search for those functions in all your scripts and use strtolower().

    This case sensitivity change also applies to the magical predefined constants __CLASS__, __METHOD__, and __FUNCTION__. The values are returned exactly as they're declared (case-sensitive).

  • ip2long() now returns FALSE when an invalid IP address is passed as argument to the function, and no longer -1.
  • If there are functions defined in the included file, they can be used in the main file independent if they are before return() or after. If the file is included twice, PHP 5 issues fatal error because functions were already declared, while PHP 4 doesn't complain about it. It is recommended to use include_once() instead of checking if the file was already included and conditionally return inside the included file.
  • include_once() and require_once() first normalize the path of included file on Windows so that including A.php and a.php include the file just once.

Příklad D.1. strrpos() and strripos() now use the entire string as a needle

<?php
var_dump(strrpos('ABCDEF','DEF')); //int(3)

var_dump(strrpos('ABCDEF','DAF')); //bool(false)
?>

Příklad D.2. An object with no properties is no longer considered "empty"

<?php
class test { }
$t = new test();

var_dump(empty($t)); // echo bool(false)

if ($t) {
    // Will be executed
}
?>

Příklad D.3. In some cases classes must be declared before used

<?php

//works with no errors:
$a = new a();
class a {
}

//throws an error:
$a = new b();

interface c{
}
class b implements c {
}

?>

Předcházející | Nahoru | Další
D. Migrating from PHP 4 to PHP 5 | Domů | CLI and CGI


CLI and CGI

In PHP 5 there were some changes in CLI and CGI filenames. In PHP 5, the CGI version was renamed to php-cgi.exe (previously php.exe) and the CLI version now sits in the main directory (previously cli/php.exe).

In PHP 5 it was also introduced a new mode: php-win.exe. This is equal to the CLI version, except that php-win doesn't output anything and thus provides no console (no "dos box" appears on the screen). This behavior is similar to php-gtk.

In PHP 5, the CLI version will always populate the global $argv and $argc variables regardless of any php.ini directive setting. Even having register_argc_argv set to off will have no affect in CLI.

See also the command line reference.

Předcházející | Nahoru | Další
Backward Incompatible Changes | Domů | Migrating Configuration Files


Migrating Configuration Files

Since the ISAPI modules changed their names, from php4xxx to php5xxx, you need to make some changes in the configuration files. There were also changes in the CLI and CGI filenames. Please refer to the corresponding section for more information.

Migrating the Apache configuration is extremely easy. See the example below to check the change you need to do:

Příklad D.4. Migrating Apache configuration files for PHP 5

# change this line:
LoadModule php4_module /php/sapi/php4apache2.dll

# with this one:
LoadModule php5_module /php/php5apache2.dll

If your web server is running PHP in CGI mode, you should note that the CGI version has changed its name from php.exe to php-cgi.exe. In Apache, you should do something like this:

Příklad D.5. Migrating Apache configuration files for PHP 5, CGI mode

# change this line:
Action application/x-httpd-php "/php/php.exe"

# with this one:
Action application/x-httpd-php "/php/php-cgi.exe"

In other web servers you need to change either the CGI or the ISAPI module filenames.

Předcházející | Nahoru | Další
CLI and CGI | Domů | New Functions


New Functions

In PHP 5 there are some new functions. Here is the list of them:

Arrays:

  • array_combine() - Creates an array by using one array for keys and another for its values
  • array_diff_uassoc() - Computes the difference of arrays with additional index check which is performed by a user supplied callback function
  • array_udiff() - Computes the difference of arrays by using a callback function for data comparison
  • array_udiff_assoc() - Computes the difference of arrays with additional index check. The data is compared by using a callback function
  • array_udiff_uassoc() - Computes the difference of arrays with additional index check. The data is compared by using a callback function. The index check is done by a callback function also
  • array_walk_recursive() - Apply a user function recursively to every member of an array
  • array_uintersect_assoc() - Computes the intersection of arrays with additional index check. The data is compared by using a callback function
  • array_uintersect_uassoc() - Computes the intersection of arrays with additional index check. Both the data and the indexes are compared by using separate callback functions
  • array_uintersect() - Computes the intersection of arrays. The data is compared by using a callback function

InterBase:

  • ibase_affected_rows() - Return the number of rows that were affected by the previous query
  • ibase_backup() - Initiates a backup task in the service manager and returns immediately
  • ibase_commit_ret() - Commit a transaction without closing it
  • ibase_db_info() - Request statistics about a database
  • ibase_drop_db() - Drops a database
  • ibase_errcode() - Return an error code
  • ibase_free_event_handler() - Cancels a registered event handler
  • ibase_gen_id() - Increments the named generator and returns its new value
  • ibase_maintain_db() - Execute a maintenance command on the database server
  • ibase_name_result() - Assigns a name to a result set
  • ibase_num_params() - Return the number of parameters in a prepared query
  • ibase_param_info() - Return information about a parameter in a prepared query
  • ibase_restore() - Initiates a restore task in the service manager and returns immediately
  • ibase_rollback_ret() - Rollback transaction and retain the transaction context
  • ibase_server_info() - Request statistics about a database server
  • ibase_service_attach() - Connect to the service manager
  • ibase_service_detach() - Disconnect from the service manager
  • ibase_set_event_handler() - Register a callback function to be called when events are posted
  • ibase_wait_event() - Wait for an event to be posted by the database

iconv:

  • iconv_mime_decode() - Decodes a MIME header field
  • iconv_mime_decode_headers() - Decodes multiple MIME header fields at once
  • iconv_mime_encode() - Composes a MIME header field
  • iconv_strlen() - Returns the character count of string
  • iconv_strpos() - Finds position of first occurrence of a needle within a haystack
  • iconv_strrpos() - Finds the last occurrence of a needle within a haystack
  • iconv_substr() - Cut out part of a string

Streams:

  • stream_copy_to_stream() - Copies data from one stream to another
  • stream_get_line() - Gets line from stream resource up to a given delimiter
  • stream_socket_accept() - Accept a connection on a socket created by stream_socket_server()
  • stream_socket_client() - Open Internet or Unix domain socket connection
  • stream_socket_get_name() - Retrieve the name of the local or remote sockets
  • stream_socket_recvfrom() - Receives data from a socket, connected or not
  • stream_socket_sendto() - Sends a message to a socket, whether it is connected or not
  • stream_socket_server() - Create an Internet or Unix domain server socket

Date and time related:

  • idate() - Format a local time/date as integer
  • date_sunset() - Time of sunset for a given day and location
  • date_sunrise() - Time of sunrise for a given day and location
  • time_nanosleep() - Delay for a number of seconds and nanoseconds

Strings:

  • str_split() - Convert a string to an array
  • strpbrk() - Search a string for any of a set of characters
  • substr_compare() - Binary safe optionally case insensitive comparison of two strings from an offset, up to length characters

Other:

  • convert_uudecode() - decode a uuencoded string
  • convert_uuencode() - uuencode a string
  • curl_copy_handle() - Copy a cURL handle along with all of its preferences
  • dba_key_split() - Splits a key in string representation into array representation
  • dbase_get_header_info() - Get the header info of a dBase database
  • dbx_fetch_row() - Fetches rows from a query-result that had the DBX_RESULT_UNBUFFERED flag set
  • fbsql_set_password() - Change the password for a given user
  • file_put_contents() - Write a string to a file
  • ftp_alloc() - Allocates space for a file to be uploaded
  • get_declared_interfaces() - Returns an array of all declared interfaces
  • get_headers() - Fetches all the headers sent by the server in response to a HTTP request
  • headers_list() - Returns a list of response headers sent (or ready to send)
  • http_build_query() - Generate URL-encoded query string
  • image_type_to_extension() - Get file extension for
image-type returned by getimagesize(),
exif_read_data(),
exif_thumbnail(),
exif_imagetype()
  • imagefilter() - Applies a filter to an image using custom arguments
  • imap_getacl() - Gets the ACL for a given mailbox
  • ldap_sasl_bind() - Bind to LDAP directory using SASL
  • mb_list_encodings() - Returns an array of all supported encodings
  • pcntl_getpriority() - Get the priority of any process
  • pcntl_wait() - Waits on or returns the status of a forked child as defined by the waitpid() system call
  • pg_version() - Returns an array with client, protocol and server version (when available)
  • php_check_syntax() - Check the syntax of the specified file
  • php_strip_whitespace() - Return source with stripped comments and whitespace
  • proc_nice() - Change the priority of the current process
  • pspell_config_data_dir() - Change location of language data files
  • pspell_config_dict_dir() - Change location of the main word list
  • setrawcookie() - Send a cookie without URL-encoding the value
  • scandir() - List files and directories inside the specified path
  • snmp_read_mib() - Reads and parses a MIB file into the active MIB tree
  • sqlite_fetch_column_types() - Return an array of column types from a particular table

Poznámka: The Tidy extension has also changed its API completely.

Předcházející | Nahoru | Další
Migrating Configuration Files | Domů | New Directives


New Directives

There were some new php.ini directives introduced in PHP 5. Here is a list of them:

  • mail.force_extra_parameters - Force the addition of the specified parameters to be passed as extra parameters to the sendmail binary. These parameters will always replace the value of the 5th parameter to mail(), even in safe mode
  • register_long_arrays - allow/disallow PHP to register the deprecated long $HTTP_*_VARS
  • session.hash_function - select a hash function (MD5 or SHA-1)
  • session.hash_bits_per_character - define how many bits are stored in each character when converting the binary hash data to something readable (from 4 to 6)
  • zend.ze1_compatibility_mode - Enable compatibility mode with Zend Engine 1 (PHP 4)
Předcházející | Nahoru | Další
New Functions | Domů | Databases


Databases

There were some changes in PHP 5 regarding databases (MySQL and SQLite).

In PHP 5 the MySQL client libraries are not bundled, because of license problems and some others. For more information, read the FAQ entry.

There is also a new extension, MySQLi (Improved MySQL), which is designed to work with MySQL 4.1 and above.

Since PHP 5, the SQLite extension is built-in PHP. SQLite is an embeddable SQL database engine and is not a client library used to connect to a big database server (like MySQL or PostgreSQL). The SQLite library reads and writes directly to and from the database files on disk.

Předcházející | Nahoru | Další
New Directives | Domů | New Object Model


New Object Model

In PHP 5 there is a new Object Model. PHP's handling of objects has been completely rewritten, allowing for better performance and more features. In previous versions of PHP, objects were handled like primitive types (for instance integers and strings). The drawback of this method was that semantically the whole object was copied when a variable was assigned, or passed as a parameter to a method. In the new approach, objects are referenced by handle, and not by value (one can think of a handle as an object's identifier).

Many PHP programmers aren't even aware of the copying quirks of the old object model and, therefore, the majority of PHP applications will work out of the box, or with very few modifications.

The new Object Model is documented at the Language Reference.

In PHP 5, function with the name of a class is called as a constructor only if defined in the same class. In PHP 4, it is called also if defined in the parent class.

See also the zend.ze1_compatibility_mode directive for compatability with PHP 4.

Předcházející | Nahoru | Další
Databases | Domů | Error Reporting


Error Reporting

As of PHP 5 new error reporting constant E_STRICT was introduced with value 2048. It enables run-time PHP suggestions on your code interoperability and forward compatibility, that will help you to keep latest and greatest suggested method of coding. E.g. STRICT message will warn you on using deprecated functions.

Poznámka: E_ALL does not include E_STRICT so it's not enabled by default

Předcházející | Nahoru | Další
New Object Model | Domů | E. Přechod z PHP 3 na PHP 4


Příloha E. Přechod z PHP 3 na PHP 4

Obsah

Co se změnilo v PHP 4
Současný běh PHP 3 a PHP 4
Převod konfiguračních souborů
Chování parseru
Hlášení chyb
Inicializátory
empty("0")
Chybějící funkce
Rozšíření PHP 3
Substituce za proměnné v řetězcích
Cookies
Obsluha globálních proměnných

Co se změnilo v PHP 4

PHP 4 a integrovaný Zend engine se vyznačuje podstatně vyšším výkonem a schopnostmi, přesto však byla věnována zvláštní péče tomu, dopady na stávající kód byly co nejmenší. Takže úpravy vašeho kódu z PHP 3 na PHP 4 by měly být podstatně snadnější než při přechodu z PHP/FI 2.0 na PHP 3. Mnoho existujícího kódu pro PHP 3 by mělo být připraveno běžet bez jakýchkoli změn, měli byste však vědět o několika podstatných odlišnostech a věnovat dobrou péči otestování kódu před změnou verze produkčního prostředí. Následující text by vám měl poradit, na co se zaměřit.

Předcházející | Nahoru | Další
Error Reporting | Domů | Současný běh PHP 3 a PHP 4


Současný běh PHP 3 a PHP 4

Nejnovější operační systémy poskytují možnost versioningu a scopingu. Tyto prostředky umožňují nechat běžet PHP 3 a PHP 4 současně na jediném serveru Apache.

Funkce je ověřena na těchto platformách:

  • Linux + nejnovější binutils (testována verze binutils 2.9.1.0.25)
  • Solaris 2.5 a novější
  • FreeBSD (testovány verze 3.2 a 4.0)

K aktivaci této možnosti je třeba nakonfigurovat PHP 3 a PHP 4 k použití APXS (--with-apxs) a nezbytných rozšíření vazeb (--enable-versioning). Jinak postupujte zcela standardním způsobem (pro konfiguraci, kompilaci a instalaci). Například:

$ ./configure \
  --with-apxs=/apache/bin/apxs \
  --enable-versioning \
  --with-mysql \
  --enable-track-vars

Předcházející | Nahoru | Další
E. Přechod z PHP 3 na PHP 4 | Domů | Převod konfiguračních souborů


Převod konfiguračních souborů

Název globálního konfiguračního souboru, php3.ini, se změnil na php.ini.

V konfiguračním souboru serveru Apache je poněkud více změn. Změnily se především MIME datové typy rozpoznávané modulem PHP.

application/x-httpd-php3        -->    application/x-httpd-php
application/x-httpd-php3-source -->    application/x-httpd-php-source

Můžete upravit vaše konfigurační soubory tak, aby pracovaly s oběma verzemi PHP (v závislosti na tom, která je v příslušném okamžiku zkompilována pro server) použitím následující syntaxe:

AddType  application/x-httpd-php3        .php3
AddType  application/x-httpd-php3-source .php3s

AddType  application/x-httpd-php         .php
AddType  application/x-httpd-php-source  .phps

Změnily se také názvy direktiv pro server Apache.

Od verze PHP 4.0 existují pouze čtyři direktivy pro Apache, které mají spojitost s PHP:

php_value [PHP directive name] [value]
php_flag [PHP directive name] [On|Off]
php_admin_value [PHP directive name] [value]
php_admin_flag [PHP directive name] [On|Off]

Jsou dva rozdíly mezi hodnotami "admin" a ostatními:

  • Hodnoty (nebo příznaky) "admin" se mohou objevit pouze v konfiguračních souborech pro celý server (např. httpd.conf).
  • Standardní hodnoty (nebo příznaky) nemohou ovládat jisté PHP direktivy, například bezpečný režim (pokud byste mohli změnit nastavení bezpečného režimu v souborech .htaccess, bezpečný režim ztrácí smysl). Naopak, "admin" hodnoty mohou zasahovat do jakýchkoli PHP direktiv.

Aby byl přechod na novou verzi snazší, balík PHP 4 obsahuje skripty, které automaticky převedou váš konfigurační soubor pro Apache a soubory .htaccess tak, aby pracovaly jak s PHP 3, tak s PHP 4. Tyto skripty NEPŘEVÁDĚJÍ řádky s popisy MIME typů! Musíte je upravit ručně.

K převedení konfiguračních souborů pro Apache, spusťte skript apconf-conv.sh (umístěný v adresáři scripts/apache/). Například:

~/php4/scripts/apache:#  ./apconf-conv.sh /usr/local/apache/conf/httpd.conf

Váš originální konfigurační soubor bude uložen jako httpd.conf.orig.

K převedení souborů .htaccess, spusťte skript aphtaccess-conv.sh (dostupný rovněž v adresáři scripts/apache/):

~/php4/scripts/apache:#  find / -name .htaccess -exec ./aphtaccess-conv.sh {} \;

I v tomto případě budou originální soubory .htaccess uloženy s koncovkou .orig.

Konverzní skripty vyžadují nainstalovaný nástroj awk.

Předcházející | Nahoru | Další
Současný běh PHP 3 a PHP 4 | Domů | Chování parseru


Chování parseru

Parsing a provádění kódu jsou nyní dva naprosto oddělené kroky, nic z kódu v souboru se neprovádí dříve, než je úspěšně provedena úplná syntaktická analýza celého souboru a všeho, co je třeba.

Jeden z nových požadavků, které vyvstaly tímto rozdělením, je, že všechny soubory připojené prostřednictvím "require" a "include" nyní musí být syntakticky úplné. Již nelze rozložit různé části řídicích konstrukcí přes hranice souborů. Tj. nelze začít cyklus for nebo while, větvení if nebo switch v jednom souboru a ukočit je (resp. pokračovat pomocí else, endif, case nebo break) v souboru jiném.

Zůstává zcela legální vložit další kód do cyklů nebo jiných řídicích struktur, pouze řídicí klíčová slova a odpovídající složené závorky {...} musí být ve stejné kompilační jednotce (souboru nebo řetězci zpracovaném pomocí eval()).

Toto neškodí tolik jako výše uvedené rozkládání kódu, přesto to může být považováno za velmi špatný styl.

Jinou věcí, která již není možná, je vzácně vídané vracení hodnot ze souborů připojených pomocí "require". Vracení hodnot ze souborů připojených "include" je možné i nadále.

Předcházející | Nahoru | Další
Převod konfiguračních souborů | Domů | Hlášení chyb


Hlášení chyb

Změny konfigurace

Hlášení chyb v PHP 3 bylo založeno na úrovních, představovaných jednoduchou číselnou hodnotou. Hodnoty se sčítaly pro různé úrovně chyb. Obvyklé hodnoty byly 15 pro hlášení všech chyb a varování, 7 pro hlášení všeho kromě informativních zpráv, ohlašujících špatný styl a podobné věci.

PHP 4 má větší množinu úrovní chyb a varování a přichází s konfiguračním parserem, který nyní umožňuje k nastavení potřebného chování používat symbolické konstanty.

Úroveň hlášení chyb by měla být nyní nastavována explicitním odebíráním těch úrovní, u kterých které nechceme, aby byly hlášeny (pomocí logické operace XOR se symbolickou konstantou). E_ALL. Zní to komplikovaně? No, tak řekněme, že chcete hlásit všechny chyby s výjimkou jednoduchých "stylových" varování, která jsou zařazena do kategorie popsané symbolickou konstantou E_NOTICE. Potom do souboru php.ini vložíte: error_reporting = E_ALL & ~ ( E_NOTICE ). Pokud chcete potlačit také všechna varování, přidáte odpovídající konstantu do závorek s použitím binárního operátoru '|': error_reporting= E_ALL & ~ ( E_NOTICE | E_WARNING ).

Varování

Při upgradu kódu nebo serverů z PHP 3 na PHP 4 byste měli zkontrolovat tato nastavení a volání error_reporting(), jinak byste mohli mít deaktivováno hlášení nových typů chyb, obzvláště E_COMPILE_ERROR. To může vést k prázdným dokumentům bez jakékoli zpětné informace o tom, co se stalo nebo kde hledat problém.

Varování

Používání starých hodnot 7 a 15 pro nastavení hlášení chyb je velmi špatný nápad, protože to potlačuje některé nově přidané třídy chyb včetně syntaktických. To může vést k velmi záhadnému chování, kdy skripty nepracují, aniž by vydaly jakoukoli zprávu o chybě.

Toto v minulosti vedlo k množství nereprodukovatelných bug reportů (hlášení o chybách v PHP), když lidé hlásili problémy s enginem, které nebyli schopni vystopovat. Pravou příčinou byla obvykle chybějící uzavírací závorka '}' v souboru připojeném pomocí "require", a parser je nemohl ohlásit kvůli špatně nakonfigurovanému hlášení chyb.

Takže kontrola nastavení hlášení chyb by měla být první věcí, pokud vaše skripty tiše havarují. Zend engine může být nyní považován za dost vyspělý na to, aby způsoboval takové podivné chování.

Přídavné varovné zprávy

Mnoho existujících kódů v PHP 3 používá jazykové konstrukty, které by měly být považovány za velmi špatný styl psaní, neboť přestože nyní dělají zamýšlené věci, snadno mohou být narušeny změnami jinde. PHP 4 bude vydávat spousty informativních zpráv v takových situacích, kdy se v PHP 3 nic nedělo. Snadnou nápravou je vypnutí zpráv E_NOTICE, ale obvykle je lepší raději opravit kód.

Nejčastějším případem, který bude produkovat takové zprávy, je použití řetězců bez uvozovek jako prvků pole. Jak PHP 3, tak PHP 4 je budou interpretovat jako řetězce, pokud pod tímto jménem není známo žádné klíčové slovo ani konstanta. Pokud by však nějaká taková konstanta (někde jinde v kódu) definována byla, skript může havarovat. Může to přerůst i v bezpečnostní riziko, pokud nějaký útočník předefinuje řetězcové konstanty způsobem, který mu dá přístupová práva, jež by mít neměl. Takže PHP 4 vás bude nyní varovat, pokud použijete řetězecovou konstantu neuzavřenou do uvozovek, jako například $_SERVER[REQUEST_METHOD]. Změníte-li to na $_SERVER['REQUEST_METHOD'], parser se uklidní a výrazně se zlepší styl a bezpečnost vašeho kódu.

Další věcí v PHP 4 je hlášení použití neinicializovaných proměnných a prvků polí.

Předcházející | Nahoru | Další
Chování parseru | Domů | Inicializátory


Inicializátory

Statické proměnné a inicializátory položek tříd přijímají pouze skalární hodnoty, zatímco v PHP 3 přijímaly i jakékoli platné výrazy. Toto je, opět, kvůli rozdělení mezi parsing a provádění kódu - když parser zpracovává inicializátor, ještě není proveden žádný kód.

K inicializaci položek ve třídách byste měli namísto toho používat konstruktory. Pro statické proměnné přesto vzácně dává smysl i něco jiného než obyčejná hodnota.

Předcházející | Nahoru | Další
Hlášení chyb | Domů | empty("0")


Chybějící funkce

Současně s tím, že se v PHP 4 objevuje mnoho nových prostředků, funkcí a rozšíření, můžete najít i funkce, které oproti verzi 3 chybí. Malý počet jádrových funkcí zmizel, protože nefungují s novým schématem oddělení parsingu a provádění kódu v Zend enginu. Jiné funkce i celá kompletní rozšíření se staly zastaralými tím, že novější funkce a rozšíření poslouží ve stejné roli lépe nebo obecněji. Některé funkce jednoduše ještě nebyly portovány a konečně jsou také funkce a rozšíření chybějící kvůli licenčním konfliktům.

Funkce chybějící kvůli konceptuálním změnám

Tím, že PHP 4 odděluje syntaktickou analýzu od interpretace, již není možné měnit chování parseru (nyní vloženého do Zend enginu) během provádění skriptu, který byl již syntakticky zpracován. Takže funkce short_tags() již neexistuje. Měnit chování parseru stále můžete, a to nastavením hodnot v souboru php.ini.

Jiným prostředkem PHP 3, který není součástí PHP 4, je zabudované rozhraní pro ladění. Existují externí doplňky pro Zend engine, které poskytují podobné funkce.

Zavržené funkce a rozšíření

Databázová rozšíření Adabas a Solid již nejsou k dispozici. Namísto toho se používá rozšíření unifikované rozhraní ODBC.

Změněný status funkce unset()

unset(), přestože je stále k dispozici, je implementována jako jazykový konstrukt namísto funkce.

To nemá žádné důsledky v chování unset(), ale test "unset" pomocí function_exists() vrátí FALSE, stejně jako v případě jiných jazykových konstruktů, které vypadají jako funkce, např. echo().

Jinou, praktičtější změnou je to, že již nelze volat unset() nepřímo, tzn. $func="unset"; $func($somevar) už nebude fungovat.

Předcházející | Nahoru | Další
empty("0") | Domů | Rozšíření PHP 3


Rozšíření PHP 3

Rozšíření psaná pro PHP 3 nebudou s PHP 4 pracovat, ani na binární, ani na zdrojové úrovni. Není těžké portovat tato rozšíření na PHP 4, pokud máte přístup k originálnímu zdrojovému kódu. Detailní popis procesu portace není součástí tohoto textu.

Předcházející | Nahoru | Další
Chybějící funkce | Domů | Substituce za proměnné v řetězcích


Substituce za proměnné v řetězcích

PHP 4 přidává nový mechanismus k substituci za proměnné v řetězcích. Nyní můžete konečně uvnitř řetězců přistupovat k položkám v objektech a k prvkům vícerozměrných polí.

To se udělá pomocí uzavření proměnných do složených závorek se znakem dolaru ihned za otvírací závorkou: {$...}

K vložení hodnoty položky objektu do řetězce jednoduše napíšete "text {$obj->member} text", zatímco v PHP 3 jste museli napsat něco jako "text ".$obj->member." text".

Toto by mělo vést k čitelnějšímu kódu, ale může to způsobovat problémy s existujícími skripty pro PHP 3. Můžete ale provést test na kombinaci znaků {$ ve vašem kódu a jejich nahrazení \{$ pomocí vašeho oblíbeného nástroje pro hledání a náhradu.

Předcházející | Nahoru | Další
Rozšíření PHP 3 | Domů | Cookies


Cookies

V PHP 3 se zavedl špatný zvyk nastavovat cookies opačným pořadím volání setcookie() v kódu. PHP 4 toto napravuje a vytváří hlavičkové řádky pro cookies v přesně stejném pořadí, jak jdou za sebou v kódu.

Opět se mohou vyskytnout problémy s existujícím kódem, ale staré chování bylo tak těžko pochopitelné, že si zasloužilo změnu, aby se zabránilo dalším problémům v budoucnosti.

Předcházející | Nahoru | Další
Substituce za proměnné v řetězcích | Domů | Obsluha globálních proměnných


Obsluha globálních proměnných

Zatímco v PHP 3 a prvních verzích PHP 4 se při obsluze globálních proměnných dbalo především na jednoduchost, nyní se zaměření změnilo směrem k vyšší bezpečnosti. Takže jestliže následující případ dobře fungoval v PHP 3, v PHP 4 je třeba provést unset($GLOBALS["id"]);. Toto je jen jeden aspekt obsluhy globálních proměnných. Měli byste vždy používat $GLOBALS, v novějších verzích PHP 4 budete nuceni tak učinit ve většině případů. Více o této problematice najdete v části global (globální) reference.

Příklad E.1. Změny u globálních proměnných

<?php
$id = 1;
function test()
{
    global $id;
    unset($id);
}
test();
echo($id); // This will print out 1 in PHP 4

Předcházející | Nahoru | Další
Cookies | Domů | F. Přechod z PHP/FI 2 na PHP 3


Příloha F. Přechod z PHP/FI 2 na PHP 3

Obsah

O nekompatibilitách v 3.0
old_function
Otvírací/uzavírací značky (start/end tags)
syntaxe if..endif
syntaxe while
Typy výrazů
Chybové zprávy se změnily
Zkrácené vyhodnocení logických výrazů
Návratové hodnoty TRUE/FALSE
Jiné nekompatibility

O nekompatibilitách v 3.0

PHP 3.0 je od základu přepsáno. Má náležitý parser, který je mnohem robustnější a konzistentnější než ten ve verzi 2.0. Verze 3.0 je také signifikantně rychlejší a používá méně paměti. Logicky, některá z těchto vylepšení nebyla možná bez změnách v kompatibilitě, jak v syntaxi, tak ve funkcionalitě.

Navíc se vývojáři PHP snažili vyčistit jak syntaxi, tak sémantiku PHP, což také přineslo nějaké nekompatibility. Ze širšího pohledu, věříme že tyto změny jsou pro dobro věci.

Tato kapitola se pokusí provést vás nekompatibilitami, na které můžete narazit při přechodu z PHP/FI 2.0 na PHP 3.0 a pomoci vám je vyřešit. Nové prvky zde nebudou zmiňovány, pokud to nebude nutné.

Konverzní program, který automaticky převede vaše staré skripty v PHP/FI 2.0, existuje. Najdete ho adresáři convertor v distribuci PHP 3.0. Tento program však zachycuje pouze změny syntaxe, takže přesto pozorně čtěte tuto kapitolu.

Předcházející | Nahoru | Další
Obsluha globálních proměnných | Domů | old_function


Otvírací/uzavírací značky (start/end tags)

Pravděpodobně první věcí, kterou zaznamenáte, je, že se změnily otevírací a uzavírací značky (označují začátek a konec kódu PHP). Staré značky <? > byly nahrazeny třemi možnými formami:

Příklad F.1. Přechod: staré otvírací/uzavírací značky

<? echo "This is PHP/FI 2.0 code.\n"; >

Jako verze 2.0, PHP 3.0 podporuje také tuto variantu:

Příklad F.2. Přechod: první otvírací/uzavírací značky

<? echo "This is PHP 3.0 code!\n"; ?>

Všimněte si, že uzavírací značka nyní sestává z otazníku a znaku "větší než" namísto pouhého znaku "větší než". Bohužel, pokud na svém serveru plánujete používat XML, bude tato varianta dělat problémy, protože se PHP může pokoušet interpretovat XML značku jako PHP kód. Z tohoto důvodu byla zavedena nová varianta:

Příklad F.3. Přechod: druhé otvírací/uzavírací značky

<?php echo "This is PHP 3.0 code!\n"; ?>

Někteří lidé mají problémy s editory, které zcela neporozumí zpracování instrukčních značek. Jedním z takových editorů je Microsoft FrontPage, a jako řešení tohoto problému byla přidána ještě další varianta:

Příklad F.4. Přechod: třetí otvírací/uzavírací značky

<script language="php">

  echo "This is PHP 3.0 code!\n";

</script>

Předcházející | Nahoru | Další
old_function | Domů | syntaxe if..endif


syntaxe if..endif

Alternativní způsob, jak zapsat konstrukci if/elseif/else, za použití if(); elseif(); else; endif;, nemůže být efektivně implementována bez podstatného nárůstu složitosti 3.0 parseru. Kvůli tomu se změnila syntaxe:

Příklad F.5. Přechod: stará syntaxe if..endif

if ($foo);
    echo "yep\n";
elseif ($bar);
    echo "almost\n";
else;
    echo "nope\n";
endif;

Příklad F.6. Přechod: nová syntaxe if..endif

if ($foo):
    echo "yep\n";
elseif ($bar):
    echo "almost\n";
else:
    echo "nope\n";
endif;

Všimněte si, že středníky byly nahrazeny dvojtečkami ve všech příkazech kromě závěrečného (endif).

Předcházející | Nahoru | Další
Otvírací/uzavírací značky (start/end tags) | Domů | syntaxe while


syntaxe while

Stejně jako if..endif, syntaxe while..endwhile byla změněna:

Příklad F.7. Přechod: stará syntaxe while..endwhile

while ($more_to_come);
    ...
endwhile;

Příklad F.8. Přechod: nová syntaxe while..endwhile

while ($more_to_come):
    ...
endwhile;

Varování

Pokud v PHP 3.0 použijete starou syntaxi while..endwhile, získáte nekonečnou smyčku.

Předcházející | Nahoru | Další
syntaxe if..endif | Domů | Typy výrazů


Typy výrazů

PHP/FI 2.0 používalo levou stranu výrazů k určení, jakého typu má výsledek být. PHP 3.0 bere pro určení typu v úvahu obě strany výrazu, a to může způsobit nepředvídatelné chování 2.0 skriptů v PHP 3.0.

Uvažujme tento příklad:

$a[0]=5;
$a[1]=7;

$key = key($a);
while ("" != $key) {
    echo "$keyn";
    next($a);
}
V PHP/FI 2.0 by to zobrazilo obě hodnoty v $a. V PHP 3.0 se však nezobrazí nic. Důvod je ten, že PHP 2.0 kvůli tomu, že na levé straně je řetezec, provede porovnání řetězců, a "" se nerovná "0", tedy se bude procházet cyklem. V PHP 3.0 se řetězec porovná s celým číslem (integer), provede se porovnání celých čísel (řetězec je převeden na celé číslo). Výsledkem je porovnání atoi(""), což je 0, a variablelist, což je také 0. A protože 0==0, cyklem se vůbec procházet nebude.

Oprava pro tento příklad je snadná. Nahraďte původní konstrukci tímto:

while ((string)$key != "") {

Předcházející | Nahoru | Další
syntaxe while | Domů | Chybové zprávy se změnily


Chybové zprávy se změnily

Chybové zprávy PHP 3.0 jsou obvykle přesnější, než byly ve 2.0. Neuvidíte však část kódu, kde nastala chyba. Vypíše se pouze název souboru a číslo řádku, kde nastala chyba.

Předcházející | Nahoru | Další
Typy výrazů | Domů | Zkrácené vyhodnocení logických výrazů


Zkrácené vyhodnocení logických výrazů

V PHP 3.0 se používá zkrácené vyhodnocení logických výrazů. To znamená, že pro výraz jako (1 || test_me()) již nebude funkce test_me() volána, protože za 1 již nic nemůže ovlivnit hodnotu výrazu.

Toto je malá změna kompatibility,ale může způsobit neočekávané vedlejší efekty.

Předcházející | Nahoru | Další
Chybové zprávy se změnily | Domů | Návratové hodnoty TRUE/FALSE


Jiné nekompatibility

  • Modul PHP 3.0 pro Apache již nepodporuje verze Apache starší než 1.2. Je třeba Apache 1.2 nebo pozdější.
  • Funkce echo() již nepodporuje formátovaný řetězec. Použijte namísto toho printf().
  • V PHP/FI 2.0 způsobovaly vedlejší efekty implementace to, že $foo[0] mělo stejný účinek jako $foo. Toto již v PHP 3.0 neplatí

  • Čtení z polí pomocí $array[] již není podporováno.

    To znamená, že nemůžete traverzovat pole v cyklu, který provádí $data = $array[]. Použijte funkce current() a next().

    Současně $array1[] = $array2 nepřipojuje hodnoty pole $array2 k poli $array1, nýbrž připojuje pole $array2 jako poslední položku pole $array1. Viz též: podpora vícerozměrných polí.

  • "+" již není přetěžován jako spojovací operátor pro řetězce, namísto toho konvertuje řetězce na čísla a provede jejich (numerický) součet. Použijte tedy operátor "." instead.

Příklad F.11. Přechod z 2.0: spojení řetězců

echo "1" + "1";

    V PHP 2.0 by se vypsalo 11, v PHP 3.0 se vypíše 2.
    Když místo toho použijete:

echo "1"."1";

$a = 1;
$b = 1;
echo $a + $b;

    vypíše se 2 v PHP 2.0 i 3.0.

$a = 1;
$b = 1;
echo $a.$b;

    Toto v PHP 3.0 vypíše 11.

Předcházející | Nahoru | Další
Návratové hodnoty TRUE/FALSE | Domů | G. Ladění (debugging) PHP


Příloha G. Ladění (debugging) PHP

Obsah

O debuggeru
Použití debuggeru
Protokol debuggeru

O debuggeru

PHP 3 obsahuje pro podporu pro síťově založený debugger.

PHP 4 nemá vnitřní mechanismy pro ladění. Nicméně můžete používat některý z externích debuggerů. » Zend IDE obsahuje debugger, a ladicí rozšíření (jako DBG) zdarma najdete také na » http://dd.cron.ru/dbg/, dále je tu » Advanced PHP Debugger (APD) nebo » Xdebug, který má také kompatibilní ladicí rozhraní s funkcionalitou ladění PHP 3, jak je popsáno v této sekci.

Předcházející | Nahoru | Další
Jiné nekompatibility | Domů | Použití debuggeru


Použití debuggeru

Vnitřní debugger v PHP 3 je užitečný pro hledání záludných chyb. Debugger pracuje prostřednictvím připojení na TCP port při každém startu PHP 3. Všechny chybové zprávy z příslušné relace jsou posílány do tohoto TCP kanálu. Tyto informace jsou určeny pro "debugging server", který může běžet uvnitř IDE nebo programovatelného editoru (jako je Emacs).

Jak nastavit debugger:

  1. Nastavte TCP port pro debugger v konfiguračním souboru (debugger.port) a aktivujte ho (debugger.enabled).
  2. Nastavte TCP pro poslech na nějakém portu (například socket -l -s 1400 v unixovských systémech).
  3. Ve vašem kódu spusťte "debugger_on(host)", kde host je IP adresa nebo doménový název počítače, kde běží příslušný TCP server.
Nyní budou všechna varování, informativní zprávy apod. mířit na síťový socket, a to i tehdy, pokud je vypnete pomocí nastavení error_reporting().

Předcházející | Nahoru | Další
G. Ladění (debugging) PHP | Domů | Protokol debuggeru


Protokol debuggeru

Protokol PHP 3 debuggeru je řádkově orientovaný. Každý řádek je určitého typu a několik řádků tvoří zprávu. Každá zpráva začíná řádkem typu start a končí řádkem typu end. PHP 3 může současně posílat řádky pro různé zprávy.

Řádek má tento formát:

date time host(pid) type: message-data

date
Datum ve formátu ISO 8601 (yyyy-mm-dd)
time
Čas včetně mikrosekund: hh:mm:uuuuuu
host
DNS (doménový) název nebo IP adresa počítače, kde byla vygenerována chyba ve skriptu.
pid
PID (process id) na počítači host procesu, který vygeneroval chybu v PHP 3 skriptu.
type

Typ řádku. Říká přijímajícímu programu, jak má s následujícími daty naložit:

Tabulka G.1. Typy řádků debuggeru

Název | Význam
start | Říká přijímajícímu programu, že tady začíná zpráva debuggeru. Obsahem datové části (data)bude typ chybové zprávy z níže uvedeného seznamu.
message | Chybová zpráva PHP 3.
location | Název souboru a číslo řádku, kde nastala chyba. První řádek location bude vždy obsahovat nejvyšší úroveň umístění. data bude obsahovat file:line. Řádek location bude následovat za každým řádkem message a každým řádkem function.
frames | Počet rámců v následujícím výpisu zásobníku. Pokud jsou zde čtyři rámce, očekávejte informace o čtyřech úrovních volaných funkcí. Pokud se žádný řádek "frames" nevyskytuje, předpokládá se hloubka 0 (chyba nastala na nejvyšší úrovni).
function | Název funkce, kde nastala chyba. Bude se opakovat pro každou úroveň zásobníku volání funkcí.
end | Říká přijímajícímu programu, že tady končí zpráva debuggeru.

data
Data v řádku.

Tabulka G.2. Typy chyb rozlišované debuggerem

Debugger | PHP 3 Internal
warning | E_WARNING
error | E_ERROR
parse | E_PARSE
notice | E_NOTICE
core-error | E_CORE_ERROR
core-warning | E_CORE_WARNING
unknown | (všechny ostatní)

Příklad G.1. Příklad - zpráva debuggeru

1998-04-05 23:27:400966 lucifer.guardian.no(20481) start: notice
1998-04-05 23:27:400966 lucifer.guardian.no(20481) message: Uninitialized variable
1998-04-05 23:27:400966 lucifer.guardian.no(20481) location: (null;):7
1998-04-05 23:27:400966 lucifer.guardian.no(20481) frames: 1
1998-04-05 23:27:400966 lucifer.guardian.no(20481) function: display
1998-04-05 23:27:400966 lucifer.guardian.no(20481) location: /home/ssb/public_html/test.php3:10
1998-04-05 23:27:400966 lucifer.guardian.no(20481) end: notice

Předcházející | Nahoru | Další
Použití debuggeru | Domů | H. Konfigurační volby


Příloha H. Konfigurační volby

Obsah

Seznam základních konfiguračních voleb

Seznam základních konfiguračních voleb

Níže je částečný seznam konfiguračních voleb používaný skipt configure při kompilaci PHP v unixovských prostředích. Většina konfiguračních voleb je uvedena na příslušných místech na referenčních stránkách jednotlivých rozšíření, nikoli zde. Pro úplný aktuální seznam konfiguračních voleb spusťte ve svém adresáři se zdrojovými kódy PHP příkaz ./configure --help poté, co jste spustili autoconf (viz také Instalační kapitolu). Může pro vás být také zajímavé přečíst si dokumentaci » GNU configure, kde najdete informace od dalších volbách configure, jako je --prefix=PREFIX.

Poznámka: Tyto volby se používají pouze při kompilaci. Chcete-li změnit provozní konfiguraci PHP, přečtěte si prosím kapitolu o Provozní konfiguraci.

  • Různé

  • Chování PHP

  • Server

Konfigurační volby PHP 4

Poznámka: Tyto volby se používají pouze v PHP 4 od PHP 4.1.0. Některé jsou k dispozici ve starších verzích PHP 4, některé i v PHP3, některé jen v PHP 4.1.0. Chcete-li kompilovat starší verzi, některé volby pravděpodobně nebudou dostupné.

Různé volby

--enable-debug

Kompiluje s ladicími symboly.

--with-layout=TYPE

Nastavuje, jak mají být instalované soubory rozloženy. Typ je buď PHP (výchozí) nebo GNU.

--with-pear=DIR

Instaluje PEAR do adresáře DIR (výchozí je PREFIX/lib/php).

--without-pear

Neinstaluje se PEAR.

--enable-sigchild

Zapne vlastní handler PHP pro signál SIGCHLD.

--disable-rpath

Vypne předávání dalších vyhledávacích cest pro knihovny.

--enable-libgcc

Zapne explicitní linkování proti libgcc.

--enable-php-streams

Zahrne experimentální PHP streamy. Nepoužívejte, pokud netestujete kód!

--with-zlib-dir[=DIR]

Určuje umístění instalačního adresáře zlib.

--enable-trans-sid

Zapne transparentní propagaci session id. Platí pouze pro PHP 4.1.2 nebo starší. Od PHP 4.2.0 se trans-sid kompiluje vždy.

--with-tsrm-pthreads

Použije vlákna POSIXu (výchozí).

--enable-shared[=PKGS]

Kompiluje sdílené knihovny [výchozí=yes].

--enable-static[=PKGS]

Kompiluje statické knihovny [výchozí=yes].

--enable-fast-install[=PKGS]

Optimalizuje pro rychlou instalaci [výchozí=yes].

--with-gnu-ld

Stanoví předpoklad, že kompilátor C používá GNU ld [výchozí=no].

--disable-libtool-lock

Zamezí zamykání během kompilace (může poškodit paralelní kompilace).

--with-pic

Pokusí se použít pouze PIC/non-PIC objekty [výchozí=use both].

--enable-memory-limit

Kompiluje se s porporou pro limit paměti.

--disable-url-fopen-wrapper

Vypne wrapper fopen, který rozpoznává URL a umožňuje přistupovat k souborům přes HTTP nebo FTP.

--enable-versioning

Exportuje pouze vyžadované symboly. Pro více informací viz INSTALL.

--with-imsp[=DIR]

Zahrne podporu pro IMSP (DIR je adresář pro include IMSP a soubor libimsp.a). Pouze pro PHP 3!

--with-mck[=DIR]

Zahrne podporu pro Cybercash MCK. DIR je kompilační adresář Cybercash MCK, výchozí je /usr/src/mck-3.2.0.3-linux. Nápovědu najdete v extra/cyberlib. Pouze pro PHP 3!

--with-mod-dav=DIR

Zahrne podporu DAV skrze modul Apache mod_dav. DIR je instalační adresář mod_dav (pouze verze jako modul Apache!). Pouze pro PHP 3!

--enable-debugger

Kompiluje s funkce pro vzdálené ladění. Pouze pro PHP 3!

--enable-versioning

Využívá možností verzování a rozsahů poskytovaných systémy Solaris 2.x a Linux. Pouze pro PHP 3!

Volby PHP

--enable-maintainer-mode

Zapne sestavovací pravidla a závislosti, které nejsou u?ite?né (a jsou ob?as matoucí) pro b??nou instalaci.

--with-config-file-path=PATH

Nastaví cestu, kde se má hledat php.ini, výchozí hodnota je PREFIX/lib.

--enable-safe-mode

Zapne bezpe?ný re?im jako výchozí nastavení.

--with-exec-dir[=DIR]

Povolí pro bezpe?ný re?im pouze programy v adresá?i DIR (výchozí hodnota je /usr/local/php/bin).

--enable-magic-quotes

Zapne "magic quotes" jako výchozí volbu.

--disable-short-tags

Vypne zkrácenou startovací zna?ku <? jako výchozí volbu.

Volby SAPI

Následující seznam obsahuje dostupné SAPI (Server Application Programming Interface) pro PHP.

--with-aolserver=DIR

Specifikuje cestu k instalaci AOLserver.

--with-apxs[=FILE]

Kompiluje sdílený modul Apache. FILE je volitelná cesta k nástroji apxs Apache; výchozí je apxs. Ujistěte se, že specifikujete verzi apxs, která je aktuálně nainstalována na vašem systému a NE tu, která je ve zdrojovém balíku Apache.

--with-apache[=DIR]

Kompiluje statický modul Apache. DIR je nejvyšší adresář kompilace Apache, výchozí je /usr/local/apache.

--with-mod_charset

Zapne přenosové tabulky pro mod_charset (ruský Apache).

--with-apxs2[=FILE]

Kompiluje sdílený modul Apache 2.0. FILE je volitelná cesta k nástroji apxs Apache; výchozí je apxs.

--with-caudium=DIR

Kompiluje PHP jako modul Pike pro použití se serverem Caudium. DIR je adresář serveru Caudium s výchozí hodnotou /usr/local/caudium/server.

--disable-cli

Dostupné v PHP 4.3.0. Vypne kompilaci CLI verze PHP (vynucuje --without-pear). Více informací je k dispozici v sekci o Používání PHP z příkazové řádky.

--enable-embed[=TYPE]

Zapne kompilaci embedded SAPI knihovny. TYPE je buď shared nebo static, přičemž výchozí je shared. Dostupné v PHP 4.3.0.

--with-fhttpd[=DIR]

Kompiluje modul fhttpd. DIR je adresář se zdroji fhttpd, výchozí hodnota je /usr/local/src/fhttpd. Od PHP 4.3.0 již není k dispozici.

--with-isapi=DIR

Kompiluje PHP jak modul ISAPI pro použití se serverem Zeus.

--with-nsapi=DIR

Určuje cestu k instalovanému serveru Netscape/iPlanet/SunONE Webserver.

--with-phttpd=DIR

Zatím bez informací.

--with-pi3web=DIR

Kompiluje PHP jako modul pro použití s Pi3Web.

--with-roxen=DIR

Kompiluje PHP jako modul Pike. DIR je základní adresář Roxen, normálně /usr/local/roxen/server.

--enable-roxen-zts

Kompiluje modul Roxen s použitím Zend Thread Safety.

--with-servlet[=DIR]

Zahrne podporu pro servlet. DIR je základní instalační adresář JSDK. Toto SAPI vyžaduje, aby rozšíření Java bylo kompilováno jako sdílená knihovna.

--with-thttpd=SRCDIR

Kompiluje PHP jako modul thttpd.

--with-tux=MODULEDIR

Kompiluje PHP jako modul pro TUX (pouze Linux).

--with-webjames=SRCDIR

Kompiluje PHP jako modul pro WebJames (pouze RISC OS).

--disable-cgi

Vypne kompilaci CGI verze PHP. Dostupné v PHP 4.3.0.

--enable-force-cgi-redirect

Zapne bezpečnostní kontrolu na vnitřní přesměrování serveru. Měli byste ho používat, pokud spouštíte CGI verzi PHP se serverem Apache.

--enable-discard-path

Pokud je zapnuto, CGI program PHP může být bezpečně umístěn mimo webový strom a uživatelé nebudou schopni obejít zabezpečení .htaccess.

--with-fastcgi

Kompiluje PHP jako aplikaci FastCGI. Od PHP 4.3.0 již není k dispozici, místo toho používejte --enable-fastcgi.

--enable-fastcgi

Je-li zapnuto, CGI modul bude kompilován i s podporou FastCGI. K dispozici od PHP 4.3.0.

--disable-path-info-check

Je-li vypnuto, cesty jako /info.php/test?a=b nebudou fungovat. Dostupné od PHP 4.3.0. Pro více informací viz » Manuál Apache.

Předcházející | Nahoru | Další
Protokol debuggeru | Domů | I. Direktivy php.ini


Příloha L. Seznam aliasů funkcí

V PHP existuje něco málo funkcí, které můžete volat víc než jedním jménem. V některých případech není preferováno jedno jméno před ostatními - dobrými příklady jsou is_int() a is_integer(). Jsou však funkce, které změnily název kvůli čištění API nebo z nějakého jiného důvodu, a staré názvy jsou udržovány jen jako aliasy pro zpětnou kompatibilitu. Obvykle je špatným nápadem používat tento druh aliasů, mohou být zcela zavrženy nebo přejmenovány, což povede k neportovatelnému skriptu. Tento seznam se poskytuje proto, aby pomohl těm, kdo chtějí upgradovat své staré skripty na novou syntaxi.

Tento seznam je konzistentní s PHP 4.0.6. Seznam aliasů, který se aktualizuje denně, je k dispozici na » http://www.zend.com/phpfunc/all_aliases.php.

Tabulka L.1. Aliasy

Alias | Základní funkce | Použité rozšíření
_ | gettext() | Gettext
add | swfmovie_add() | Ming (flash)
add | swfsprite_add() | Ming (flash)
add_root | domxml_add_root() | DOM XML
addaction | swfbutton_addAction() | Ming (flash)
addcolor | swfdisplayitem_addColor() | Ming (flash)
addentry | swfgradient_addEntry() | Ming (flash)
addfill | swfshape_addfill() | Ming (flash)
addshape | swfbutton_addShape() | Ming (flash)
addstring | swftext_addString() | Ming (flash)
addstring | swftextfield_addString() | Ming (flash)
align | swftextfield_align() | Ming (flash)
attributes | domxml_attributes() | DOM XML
children | domxml_children() | DOM XML
chop | rtrim() | Base syntax
close | closedir() | Base syntax
com_get | com_propget() | COM
com_propset | com_propput() | COM
com_set | com_propput() | COM
cv_add | ccvs_add() | CCVS
cv_auth | ccvs_auth() | CCVS
cv_command | ccvs_command() | CCVS
cv_count | ccvs_count() | CCVS
cv_delete | ccvs_delete() | CCVS
cv_done | ccvs_done() | CCVS
cv_init | ccvs_init() | CCVS
cv_lookup | ccvs_lookup() | CCVS
cv_new | ccvs_new() | CCVS
cv_report | ccvs_report() | CCVS
cv_return | ccvs_return() | CCVS
cv_reverse | ccvs_reverse() | CCVS
cv_sale | ccvs_sale() | CCVS
cv_status | ccvs_status() | CCVS
cv_textvalue | ccvs_textvalue() | CCVS
cv_void | ccvs_void() | CCVS
die | exit() | Ostatní funkce
dir | getdir() | Základní syntaxe
diskfreespace | disk_free_space() | Filesystém
domxml_getattr | domxml_get_attribute() | DOM XML
domxml_setattr | domxml_set_attribute() | DOM XML
doubleval | floatval() | Base syntax
drawarc | swfshape_drawarc() | Ming (flash)
drawcircle | swfshape_drawcircle() | Ming (flash)
drawcubic | swfshape_drawcubic() | Ming (flash)
drawcubicto | swfshape_drawcubicto() | Ming (flash)
drawcurve | swfshape_drawcurve() | Ming (flash)
drawcurveto | swfshape_drawcurveto() | Ming (flash)
drawglyph | swfshape_drawglyph() | Ming (flash)
drawline | swfshape_drawline() | Ming (flash)
drawlineto | swfshape_drawlineto() | Ming (flash)
dtd | domxml_intdtd() | DOM XML
dumpmem | domxml_dumpmem() | DOM XML
fbsql | fbsql_db_query() | FrontBase
fputs | fwrite() | Base syntax
get_attribute | domxml_get_attribute() | DOM XML
getascent | swffont_getAscent() | Ming (flash)
getascent | swftext_getAscent() | Ming (flash)
getattr | domxml_get_attribute() | DOM XML
getdescent | swffont_getDescent() | Ming (flash)
getdescent | swftext_getDescent() | Ming (flash)
getheight | swfbitmap_getHeight() | Ming (flash)
getleading | swffont_getLeading() | Ming (flash)
getleading | swftext_getLeading() | Ming (flash)
getshape1 | swfmorph_getShape1() | Ming (flash)
getshape2 | swfmorph_getShape2() | Ming (flash)
getwidth | swfbitmap_getWidth() | Ming (flash)
getwidth | swffont_getWidth() | Ming (flash)
getwidth | swftext_getWidth() | Ming (flash)
gzputs | gzwrite() | Zlib
i18n_convert | mb_convert_encoding() | Řetězce s vícebytovými znaky
i18n_discover_encoding | mb_detect_encoding() | Řetězce s vícebytovými znaky
i18n_http_input | mb_http_input() | Řetězce s vícebytovými znaky
i18n_http_output | mb_http_output() | Řetězce s vícebytovými znaky
i18n_internal_encoding | mb_internal_encoding() | Řetězce s vícebytovými znaky
i18n_ja_jp_hantozen | mb_convert_kana() | Řetězce s vícebytovými znaky
i18n_mime_header_decode | mb_decode_mimeheader() | Řetězce s vícebytovými znaky
i18n_mime_header_encode | mb_encode_mimeheader() | Řetězce s vícebytovými znaky
imap_create | imap_createmailbox() | IMAP
imap_fetchtext | imap_body() | IMAP
imap_getmailboxes | imap_list_full() | IMAP
imap_getsubscribed | imap_lsub_full() | IMAP
imap_header | imap_headerinfo() | IMAP
imap_listmailbox | imap_list() | IMAP
imap_listsubscribed | imap_lsub() | IMAP
imap_rename | imap_renamemailbox() | IMAP
imap_scan | imap_listscan() | IMAP
imap_scanmailbox | imap_listscan() | IMAP
ini_alter | ini_set() | Základní syntaxe
is_double | is_float() | Základní syntaxe
is_integer | is_int() | Základní syntaxe
is_long | is_int() | Základní syntaxe
is_real | is_float() | Základní syntaxe
is_writeable | is_writable() | Základní syntaxe
join | implode() | Základní syntaxe
labelframe | swfmovie_labelFrame() | Ming (flash)
labelframe | swfsprite_labelFrame() | Ming (flash)
last_child | domxml_last_child() | DOM XML
lastchild | domxml_last_child() | DOM XML
ldap_close | ldap_unbind() | LDAP
magic_quotes_runtime | set_magic_quotes_runtime() | Základní syntaxe
mbstrcut | mb_strcut() | Řetězce s vícebytovými znaky
mbstrlen | mb_strlen() | Řetězce s vícebytovými znaky
mbstrpos | mb_strpos() | Řetězce s vícebytovými znaky
mbstrrpos | mb_strrpos() | Řetězce s vícebytovými znaky
mbsubstr | mb_substr() | Řetězce s vícebytovými znaky
ming_setcubicthreshold | ming_setCubicThreshold() | Ming (flash)
ming_setscale | ming_setScale() | Ming (flash)
move | swfdisplayitem_move() | Ming (flash)
movepen | swfshape_movepen() | Ming (flash)
movepento | swfshape_movepento() | Ming (flash)
moveto | swfdisplayitem_moveTo() | Ming (flash)
moveto | swffill_moveTo() | Ming (flash)
moveto | swftext_moveTo() | Ming (flash)
msql | msql_db_query() | mSQL
msql_createdb | msql_create_db() | mSQL
msql_dbname | msql_result() | mSQL
msql_dropdb | msql_drop_db() | mSQL
msql_fieldflags | msql_field_flags() | mSQL
msql_fieldlen | msql_field_len() | mSQL
msql_fieldname | msql_field_name() | mSQL
msql_fieldtable | msql_field_table() | mSQL
msql_fieldtype | msql_field_type() | mSQL
msql_freeresult | msql_free_result() | mSQL
msql_listdbs | msql_list_dbs() | mSQL
msql_listfields | msql_list_fields() | mSQL
msql_listtables | msql_list_tables() | mSQL
msql_numfields | msql_num_fields() | mSQL
msql_numrows | msql_num_rows() | mSQL
msql_regcase | sql_regcase() | mSQL
msql_selectdb | msql_select_db() | mSQL
msql_tablename | msql_result() | mSQL
mssql_affected_rows | sybase_affected_rows() | Sybase
mssql_affected_rows | sybase_affected_rows() | Sybase
mssql_close | sybase_close() | Sybase
mssql_close | sybase_close() | Sybase
mssql_connect | sybase_connect() | Sybase
mssql_connect | sybase_connect() | Sybase
mssql_data_seek | sybase_data_seek() | Sybase
mssql_data_seek | sybase_data_seek() | Sybase
mssql_fetch_array | sybase_fetch_array() | Sybase
mssql_fetch_array | sybase_fetch_array() | Sybase
mssql_fetch_field | sybase_fetch_field() | Sybase
mssql_fetch_field | sybase_fetch_field() | Sybase
mssql_fetch_object | sybase_fetch_object() | Sybase
mssql_fetch_object | sybase_fetch_object() | Sybase
mssql_fetch_row | sybase_fetch_row() | Sybase
mssql_fetch_row | sybase_fetch_row() | Sybase
mssql_field_seek | sybase_field_seek() | Sybase
mssql_field_seek | sybase_field_seek() | Sybase
mssql_free_result | sybase_free_result() | Sybase
mssql_free_result | sybase_free_result() | Sybase
mssql_get_last_message | sybase_get_last_message() | Sybase
mssql_get_last_message | sybase_get_last_message() | Sybase
mssql_min_client_severity | sybase_min_client_severity() | Sybase
mssql_min_error_severity | sybase_min_error_severity() | Sybase
mssql_min_message_severity | sybase_min_message_severity() | Sybase
mssql_min_server_severity | sybase_min_server_severity() | Sybase
mssql_num_fields | sybase_num_fields() | Sybase
mssql_num_fields | sybase_num_fields() | Sybase
mssql_num_rows | sybase_num_rows() | Sybase
mssql_num_rows | sybase_num_rows() | Sybase
mssql_pconnect | sybase_pconnect() | Sybase
mssql_pconnect | sybase_pconnect() | Sybase
mssql_query | sybase_query() | Sybase
mssql_query | sybase_query() | Sybase
mssql_result | sybase_result() | Sybase
mssql_result | sybase_result() | Sybase
mssql_select_db | sybase_select_db() | Sybase
mssql_select_db | sybase_select_db() | Sybase
multcolor | swfdisplayitem_multColor() | Ming (flash)
mysql | mysql_db_query() | MySQL
mysql_createdb | mysql_create_db() | MySQL
mysql_db_name | mysql_result() | MySQL
mysql_dbname | mysql_result() | MySQL
mysql_dropdb | mysql_drop_db() | MySQL
mysql_fieldflags | mysql_field_flags() | MySQL
mysql_fieldlen | mysql_field_len() | MySQL
mysql_fieldname | mysql_field_name() | MySQL
mysql_fieldtable | mysql_field_table() | MySQL
mysql_fieldtype | mysql_field_type() | MySQL
mysql_freeresult | mysql_free_result() | MySQL
mysql_listdbs | mysql_list_dbs() | MySQL
mysql_listfields | mysql_list_fields() | MySQL
mysql_listtables | mysql_list_tables() | MySQL
mysql_numfields | mysql_num_fields() | MySQL
mysql_numrows | mysql_num_rows() | MySQL
mysql_selectdb | mysql_select_db() | MySQL
mysql_tablename | mysql_result() | MySQL
name | domxml_attrname() | DOM XML
new_child | domxml_new_child() | DOM XML
new_xmldoc | domxml_new_xmldoc() | DOM XML
nextframe | swfmovie_nextFrame() | Ming (flash)
nextframe | swfsprite_nextFrame() | Ming (flash)
node | domxml_node() | DOM XML
oci8append | ocicollappend() | OCI8
oci8assign | ocicollassign() | OCI8
oci8assignelem | ocicollassignelem() | OCI8
oci8close | ocicloselob() | OCI8
oci8free | ocifreecoll() | OCI8
oci8free | ocifreedesc() | OCI8
oci8getelem | ocicollgetelem() | OCI8
oci8load | ociloadlob() | OCI8
oci8max | ocicollmax() | OCI8
oci8ocifreecursor | ocifreestatement() | OCI8
oci8save | ocisavelob() | OCI8
oci8savefile | ocisavelobfile() | OCI8
oci8size | ocicollsize() | OCI8
oci8trim | ocicolltrim() | OCI8
oci8writetemporary | ociwritetemporarylob() | OCI8
oci8writetofile | ociwritelobtofile() | OCI8
odbc_do | odbc_exec() | ODBC
odbc_field_precision | odbc_field_len() | ODBC
output | swfmovie_output() | Ming (flash)
parent | domxml_parent() | DOM XML
pdf_add_outline | pdf_add_bookmark() | PDF
pg_clientencoding | pg_client_encoding() | PostgreSQL
pg_setclientencoding | pg_set_client_encoding() | PostgreSQL
pos | current() | Base syntax
recode | recode_string() | Recode
remove | swfmovie_remove() | Ming (flash)
remove | swfsprite_remove() | Ming (flash)
rewind | rewinddir() | Base syntax
root | domxml_root() | DOM XML
rotate | swfdisplayitem_rotate() | Ming (flash)
rotateto | swfdisplayitem_rotateTo() | Ming (flash)
rotateto | swffill_rotateTo() | Ming (flash)
save | swfmovie_save() | Ming (flash)
savetofile | swfmovie_saveToFile() | Ming (flash)
scale | swfdisplayitem_scale() | Ming (flash)
scaleto | swfdisplayitem_scaleTo() | Ming (flash)
scaleto | swffill_scaleTo() | Ming (flash)
set_attribute | domxml_set_attribute() | DOM XML
set_content | domxml_set_content() | DOM XML
setaction | swfbutton_setAction() | Ming (flash)
setattr | domxml_set_attribute() | DOM XML
setbackground | swfmovie_setBackground() | Ming (flash)
setbounds | swftextfield_setBounds() | Ming (flash)
setcolor | swftext_setColor() | Ming (flash)
setcolor | swftextfield_setColor() | Ming (flash)
setdepth | swfdisplayitem_setDepth() | Ming (flash)
setdimension | swfmovie_setDimension() | Ming (flash)
setdown | swfbutton_setDown() | Ming (flash)
setfont | swftext_setFont() | Ming (flash)
setfont | swftextfield_setFont() | Ming (flash)
setframes | swfmovie_setFrames() | Ming (flash)
setframes | swfsprite_setFrames() | Ming (flash)
setheight | swftext_setHeight() | Ming (flash)
setheight | swftextfield_setHeight() | Ming (flash)
sethit | swfbutton_setHit() | Ming (flash)
setindentation | swftextfield_setIndentation() | Ming (flash)
setleftfill | swfshape_setleftfill() | Ming (flash)
setleftmargin | swftextfield_setLeftMargin() | Ming (flash)
setline | swfshape_setline() | Ming (flash)
setlinespacing | swftextfield_setLineSpacing() | Ming (flash)
setmargins | swftextfield_setMargins() | Ming (flash)
setmatrix | swfdisplayitem_setMatrix() | Ming (flash)
setname | swfdisplayitem_setName() | Ming (flash)
setname | swftextfield_setName() | Ming (flash)
setover | swfbutton_setOver() | Ming (flash)
setrate | swfmovie_setRate() | Ming (flash)
setratio | swfdisplayitem_setRatio() | Ming (flash)
setrightfill | swfshape_setrightfill() | Ming (flash)
setrightmargin | swftextfield_setRightMargin() | Ming (flash)
setspacing | swftext_setSpacing() | Ming (flash)
setup | swfbutton_setUp() | Ming (flash)
show_source | highlight_file () | Základní syntaxe
sizeof | count() | Základní syntaxe
skewx | swfdisplayitem_skewX() | Ming (flash)
skewxto | swfdisplayitem_skewXTo() | Ming (flash)
skewxto | swffill_skewXTo() | Ming (flash)
skewy | swfdisplayitem_skewY() | Ming (flash)
skewyto | swfdisplayitem_skewYTo() | Ming (flash)
skewyto | swffill_skewYTo() | Ming (flash)
snmpwalkoid | snmprealwalk() | SNMP
strchr | strstr() | Základní syntaxe
streammp3 | swfmovie_streamMp3() | Ming (flash)
swfaction | swfaction_init() | Ming (flash)
swfbitmap | swfbitmap_init() | Ming (flash)
swfbutton | swfbutton_init() | Ming (flash)
swffill | swffill_init() | Ming (flash)
swffont | swffont_init() | Ming (flash)
swfgradient | swfgradient_init() | Ming (flash)
swfmorph | swfmorph_init() | Ming (flash)
swfmovie | swfmovie_init() | Ming (flash)
swfshape | swfshape_init() | Ming (flash)
swfsprite | swfsprite_init() | Ming (flash)
swftext | swftext_init() | Ming (flash)
swftextfield | swftextfield_init() | Ming (flash)
unlink | domxml_unlink_node() | DOM XML
xptr_new_context | xpath_new_context() | DOM XML

Předcházející | Nahoru | Další
Stav | Domů | M. List of Reserved Words


Příloha M. List of Reserved Words

Obsah

List of Keywords
Predefined Variables
Predefined Classes
Předdefinované konstanty

The following is a listing of predefined identifiers in PHP. None of the identifiers listed here should be used as identifiers in any of your scripts. These lists include keywords and predefined variable, constant, and class names. These lists are neither exhaustive or complete.

List of Keywords

These words have special meaning in PHP. Some of them represent things which look like functions, some look like constants, and so on--but they're not, really: they are language constructs. You cannot use any of the following words as constants, class names, function or method names. Using them as variable names is generally OK, but could lead to confusion.

Tabulka M.1. PHP Keywords

and | or | xor | __FILE__ | exception (PHP 5)
__LINE__ | array() | as | break | case
class | const | continue | declare | default
die() | do | echo() | else | elseif
empty() | enddeclare | endfor | endforeach | endif
endswitch | endwhile | eval() | exit() | extends
for | foreach | function | global | if
include() | include_once() | isset() | list() | new
print() | require() | require_once() | return() | static
switch | unset() | use | var | while
__FUNCTION__ | __CLASS__ | __METHOD__ | final (as of PHP 5) | php_user_filter (as of PHP 5)
interface (as of PHP 5) | implements (as of PHP 5) | extends | public (as of PHP 5) | private (as of PHP 5)
protected (as of PHP 5) | abstract (as of PHP 5) | clone (as of PHP 5) | try (as of PHP 5) | catch (as of PHP 5)
throw (as of PHP 5) | cfunction (PHP 4 only) | old_function (PHP 4 only) | this (as of PHP 5) | namespace (PHP 6 only)
import (PHP 6 only) | goto (PHP 6 only) |  |  |

Předcházející | Nahoru | Další
L. Seznam aliasů funkcí | Domů | Predefined Variables


Příloha N. Seznam typů prostředků

Toto je seznam funkcí, které vytváření, používají nebo ruší prostředky PHP. Funkci is_resource() lze použít ke zjištění, zda je proměnná prostředkem, a funkce get_resource_type() pak vrátí, o jaký prostředek se jedná.

Tabulka N.1. Typy prostředků

Název typu prostředku | Vytvoření | Použití | Zrušení | Definice
aspell | aspell_new() | aspell_check(), aspell_check_raw(), aspell_suggest() | není | Slovník aspell
bzip2 | bzopen() | bzerrno(), bzerror(), bzerrstr(), bzflush(), bzread(), bzwrite() | bzclose() | Soubor bzip2
COM | com_load() | com_invoke(), com_propget(), com_get(), com_propput(), com_set(), com_propput() | není | Reference na objekt COM
VARIANT
cpdf | cpdf_open() | cpdf_page_init(), cpdf_finalize_page(), cpdf_finalize(), cpdf_output_buffer(), cpdf_save_to_file(), cpdf_set_current_page(), cpdf_begin_text(), cpdf_end_text(), cpdf_show(), cpdf_show_xy(), cpdf_text(), cpdf_set_font(), cpdf_set_leading(), cpdf_set_text_rendering(), cpdf_set_horiz_scaling(), cpdf_set_text_rise(), cpdf_set_text_matrix(), cpdf_set_text_pos(), cpdf_set_text_pos(), cpdf_set_word_spacing(), cpdf_continue_text(), cpdf_stringwidth(), cpdf_save(), cpdf_translate(), cpdf_restore(), cpdf_scale(), cpdf_rotate(), cpdf_setflat(), cpdf_setlinejoin(), cpdf_setlinecap(), cpdf_setmiterlimit(), cpdf_setlinewidth(), cpdf_setdash(), cpdf_moveto(), cpdf_rmoveto(), cpdf_curveto(), cpdf_lineto(), cpdf_rlineto(), cpdf_circle(), cpdf_arc(), cpdf_rect(), cpdf_closepath(), cpdf_stroke(), cpdf_closepath_fill_stroke(), cpdf_fill_stroke(), cpdf_clip(), cpdf_fill(), cpdf_setgray_fill(), cpdf_setgray_stroke(), cpdf_setgray(), cpdf_setrgbcolor_fill(), cpdf_setrgbcolor_stroke(), cpdf_setrgbcolor(), cpdf_add_outline(), cpdf_set_page_animation(), cpdf_import_jpeg(), cpdf_place_inline_image(), cpdf_add_annotation() | cpdf_close() | PDF dokument - knihovna CPDF
cpdf outline
curl | curl_copy_handle(), curl_init() | curl_copy_handle(), curl_errno(), curl_error(), curl_exec(), curl_getinfo(), curl_setopt() | curl_close() | Relace curl
dbm | dbmopen() | dbmexists(), dbmfetch(), dbminsert(), dbmreplace(), dbmdelete(), dbmfirstkey(), dbmnextkey() | dbmclose() | Spojení na databázi DBM
dba | dba_open() | dba_delete(), dba_exists(), dba_fetch(), dba_firstkey(), dba_insert(), dba_nextkey(), dba_optimize(), dba_replace(), dba_sync() | dba_close() | Spojení na databázi DBA
dba persistent | dba_popen() | dba_delete(), dba_exists(), dba_fetch(), dba_firstkey(), dba_insert(), dba_nextkey(), dba_optimize(), dba_replace(), dba_sync() | není | Perzistentní spojení na databázi DBA
dbase | dbase_open() | dbase_pack(), dbase_add_record(), dbase_replace_record(), dbase_delete_record(), dbase_get_record(), dbase_get_record_with_names(), dbase_numfields(), dbase_numrecords() | dbase_close() | Spojení na databázi Dbase
dbx_link_object | dbx_connect() | dbx_query() | dbx_close() | dbx connection
dbx_result_object | dbx_query() | není | dbx result
domxml attribute
domxml document
domxml node
xpath context
xpath object
fbsql link | fbsql_change_user(), fbsql_connect() | fbsql_autocommit(), fbsql_blob_size(), fbsql_clob_size(), fbsql_commit(), fbsql_change_user(), fbsql_create_blob(), fbsql_create_db(), fbsql_create_clob(), fbsql_data_seek(), fbsql_database_password(), fbsql_database(), fbsql_db_query(), fbsql_db_status(), fbsql_drop_db(), fbsql_errno(), fbsql_error(), fbsql_get_autostart_info(), fbsql_hostname(), fbsql_insert_id(), fbsql_list_dbs(), fbsql_password(), fbsql_read_blob(), fbsql_read_clob(), fbsql_rollback(), fbsql_select_db(), fbsql_set_password(), fbsql_set_transaction(), fbsql_start_db(), fbsql_stop_db(), fbsql_username() | fbsql_close() | Spojení na databázi fbsql
fbsql plink | fbsql_change_user(), fbsql_pconnect() | fbsql_autocommit(), fbsql_change_user(), fbsql_create_db(), fbsql_data_seek(), fbsql_db_query(), fbsql_drop_db(), fbsql_select_db(), fbsql_errno(), fbsql_error(), fbsql_insert_id(), fbsql_list_dbs() | není | Perzistentní spojení na databázi fbsql
fbsql result | fbsql_db_query(), fbsql_list_dbs(), fbsql_query(), fbsql_list_fields(), fbsql_list_tables(), fbsql_tablename() | fbsql_affected_rows(), fbsql_fetch_array(), fbsql_fetch_assoc(), fbsql_fetch_field(), fbsql_fetch_lengths(), fbsql_fetch_object(), fbsql_fetch_row(), fbsql_field_flags(), fbsql_field_name(), fbsql_field_len(), fbsql_field_seek(), fbsql_field_table(), fbsql_field_type(), fbsql_next_result(), fbsql_num_fields(), fbsql_num_rows(), fbsql_result(), fbsql_num_rows() | fbsql_free_result() | fbsql result
fdf | fdf_open() | fdf_create(), fdf_save(), fdf_get_value(), fdf_set_value(), fdf_next_field_name(), fdf_set_ap(), fdf_set_status(), fdf_get_status(), fdf_set_file(), fdf_get_file(), fdf_set_flags(), fdf_set_opt(), fdf_set_submit_form_action(), fdf_set_javascript_action() | fdf_close() | Soubor FDF
ftp | ftp_connect(), ftp_ssl_connect() | ftp_login(), ftp_pwd(), ftp_cdup(), ftp_chdir(), ftp_mkdir(), ftp_rmdir(), ftp_nlist(), ftp_rawlist(), ftp_systype(), ftp_pasv(), ftp_get(), ftp_fget(), ftp_put(), ftp_fput(), ftp_size(), ftp_mdtm(), ftp_rename(), ftp_delete(), ftp_site(), ftp_alloc(), ftp_chmod(), ftp_exec(), ftp_get_option(), ftp_nb_continue(), ftp_nb_fget(), ftp_nb_fput(), ftp_nb_get(), ftp_nb_put(), ftp_raw(), ftp_set_option() | ftp_close() | FTP stream
gd | imagecreate(), imagecreatefromgd(), imagecreatefromgd2(), imagecreatefromgd2part(), imagecreatefromgif(), imagecreatefromjpeg(), imagecreatefrompng(), imagecreatefromwbmp(), imagecreatefromstring(), imagecreatefromxbm(), imagecreatefromxpm(), imagecreatetruecolor(), imagerotate() | imagearc(), imagechar(), imagecharup(), imagecolorallocate(), imagecolorat(), imagecolorclosest(), imagecolorexact(), imagecolorresolve(), imagegammacorrect(), imagegammacorrect(), imagecolorset(), imagecolorsforindex(), imagecolorstotal(), imagecolortransparent(), imagecopy(), imagecopyresized(), imagedashedline(), imagefill(), imagefilledpolygon(), imagefilledrectangle(), imagefilltoborder(), imagegif(), imagepng(), imagejpeg(), imagewbmp(), imageinterlace(), imageline(), imagepolygon(), imagepstext(), imagerectangle(), imagerotate(), imagesetpixel(), imagestring(), imagestringup(), imagesx(), imagesy(), imagettftext(), imagefilledarc(), imageellipse(), imagefilledellipse(), imagecolorclosestalpha(), imagecolorexactalpha(), imagecolorresolvealpha(), imagecopymerge(), imagecopymergegray(), imagecopyresampled(), imagetruecolortopalette(), imagesetbrush(), imagesettile(), imagesetthickness(), image2wbmp(), imagealphablending(), imageantialias(), imagecolorallocatealpha(), imagecolorclosesthwb(), imagecolordeallocate(), imagecolormatch(), imagefilter(), imagefttext(), imagegd(), imagegd2(), imageistruecolor(), imagelayereffect(), imagepalettecopy(), imagesavealpha(), imagesetstyle(), imagexbm() | imagedestroy() | Obrázek GD
gd font | imageloadfont() | imagechar(), imagecharup(), imagefontheight() | není | Font pro GD
gd PS encoding
gd PS font | imagepsloadfont() | imagepstext(), imagepsslantfont(), imagepsextendfont(), imagepsencodefont(), imagepsbbox() | imagepsfreefont() | PS font pro GD
GMP integer | gmp_init() | gmp_intval(), gmp_strval(), gmp_add(), gmp_sub(), gmp_mul(), gmp_div_q(), gmp_div_r(), gmp_div_qr(), gmp_div(), gmp_mod(), gmp_divexact(), gmp_cmp(), gmp_neg(), gmp_abs(), gmp_sign(), gmp_fact(), gmp_sqrt(), gmp_sqrtrm(), gmp_perfect_square(), gmp_pow(), gmp_powm(), gmp_prob_prime(), gmp_gcd(), gmp_gcdext(), gmp_invert(), gmp_legendre(), gmp_jacobi(), gmp_random(), gmp_and(), gmp_or(), gmp_xor(), gmp_setbit(), gmp_clrbit(), gmp_scan0(), gmp_scan1(), gmp_popcount(), gmp_hamdist() | není | Číslo GMP
hyperwave document | hw_cp(), hw_docbyanchor(), hw_getremote(), hw_getremotechildren() | hw_children(), hw_childrenobj(), hw_getparents(), hw_getparentsobj(), hw_getchildcoll(), hw_getchildcollobj(), hw_getremote(), hw_getsrcbydestobj(), hw_getandlock(), hw_gettext(), hw_getobjectbyquerycoll(), hw_getobjectbyquerycollobj(), hw_getchilddoccoll(), hw_getchilddoccollobj(), hw_getanchors(), hw_getanchorsobj(), hw_inscoll(), hw_pipedocument(), hw_unlock() | hw_deleteobject() | Objekt Hyperwave
hyperwave link | hw_connect() | hw_children(), hw_childrenobj(), hw_cp(), hw_deleteobject(), hw_docbyanchor(), hw_docbyanchorobj(), hw_errormsg(), hw_edittext(), hw_error(), hw_getparents(), hw_getparentsobj(), hw_getchildcoll(), hw_getchildcollobj(), hw_getremote(), hw_getremotechildren(), hw_getsrcbydestobj(), hw_getobject(), hw_getandlock(), hw_gettext(), hw_getobjectbyquery(), hw_getobjectbyqueryobj(), hw_getobjectbyquerycoll(), hw_getobjectbyquerycollobj(), hw_getchilddoccoll(), hw_getchilddoccollobj(), hw_getanchors(), hw_getanchorsobj(), hw_mv(), hw_incollections(), hw_info(), hw_inscoll(), hw_insdoc(), hw_insertdocument(), hw_insertobject(), hw_mapid(), hw_modifyobject(), hw_pipedocument(), hw_unlock(), hw_who(), hw_getusername() | hw_close(), hw_free_document() | Spojení na server Hyperwave
hyperwave link persistent | hw_pconnect() | hw_children(), hw_childrenobj(), hw_cp(), hw_deleteobject(), hw_docbyanchor(), hw_docbyanchorobj(), hw_errormsg(), hw_edittext(), hw_error(), hw_getparents(), hw_getparentsobj(), hw_getchildcoll(), hw_getchildcollobj(), hw_getremote(), hw_getremotechildren(), hw_getsrcbydestobj(), hw_getobject(), hw_getandlock(), hw_gettext(), hw_getobjectbyquery(), hw_getobjectbyqueryobj(), hw_getobjectbyquerycoll(), hw_getobjectbyquerycollobj(), hw_getchilddoccoll(), hw_getchilddoccollobj(), hw_getanchors(), hw_getanchorsobj(), hw_mv(), hw_incollections(), hw_info(), hw_inscoll(), hw_insdoc(), hw_insertdocument(), hw_insertobject(), hw_mapid(), hw_modifyobject(), hw_pipedocument(), hw_unlock(), hw_who(), hw_getusername() | není | Perzistentní spojení na server Hyperwave
icap | icap_open() | icap_fetch_event(), icap_list_events(), icap_store_event(), icap_snooze(), icap_list_alarms(), icap_delete_event() | icap_close() | Spojení na server icap
imap | imap_open() | imap_append(), imap_body(), imap_check(), imap_createmailbox(), imap_delete(), imap_deletemailbox(), imap_expunge(), imap_fetchbody(), imap_fetchstructure(), imap_headerinfo(), imap_header(), imap_headers(), imap_listmailbox(), imap_getmailboxes(), imap_get_quota(), imap_status(), imap_listsubscribed(), imap_set_quota(), imap_set_quota(), imap_getsubscribed(), imap_mail_copy(), imap_mail_move(), imap_num_msg(), imap_num_recent(), imap_ping(), imap_renamemailbox(), imap_reopen(), imap_subscribe(), imap_undelete(), imap_unsubscribe(), imap_scanmailbox(), imap_mailboxmsginfo(), imap_fetchheader(), imap_uid(), imap_msgno(), imap_search(), imap_fetch_overview() | imap_close() | Spojení na IMAP, POP3 server
imap chain persistent
imap persistent
ingres | ingres_connect() | ingres_query(), ingres_num_rows(), ingres_num_fields(), ingres_field_name(), ingres_field_type(), ingres_field_nullable(), ingres_field_length(), ingres_field_precision(), ingres_field_scale(), ingres_fetch_array(), ingres_fetch_row(), ingres_fetch_object(), ingres_rollback(), ingres_commit(), ingres_autocommit() | ingres_close() | Spojení na databázi ingresII
ingres persistent | ingres_pconnect() | ingres_query(), ingres_num_rows(), ingres_num_fields(), ingres_field_name(), ingres_field_type(), ingres_field_nullable(), ingres_field_length(), ingres_field_precision(), ingres_field_scale(), ingres_fetch_array(), ingres_fetch_row(), ingres_fetch_object(), ingres_rollback(), ingres_commit(), ingres_autocommit() | není | Perzistentní spojení na databázi ingresII
interbase blob
interbase link | ibase_connect() | ibase_query(), ibase_prepare(), ibase_trans() | ibase_close() | Spojení na databázi Interbase
interbase link persistent | ibase_pconnect() | ibase_query(), ibase_prepare(), ibase_trans() | není | Perzistentní spojení na databázi Interbase
interbase query | ibase_prepare() | ibase_execute() | ibase_free_query() | Dotaz Interbase
interbase result | ibase_query() | ibase_fetch_row(), ibase_fetch_object(), ibase_field_info(), ibase_num_fields() | ibase_free_result() | Výsledek Interbase
interbase transaction | ibase_trans() | ibase_commit() | ibase_rollback() | Transakce Interbase
java
ldap link | ldap_connect(), ldap_search() | ldap_count_entries(), ldap_first_attribute(), ldap_first_entry(), ldap_get_attributes(), ldap_get_dn(), ldap_get_entries(), ldap_get_values(), ldap_get_values_len(), ldap_next_attribute(), ldap_next_entry() | ldap_close() | Spojení na LDAP
ldap result | ldap_read() | ldap_add(), ldap_compare(), ldap_bind(), ldap_count_entries(), ldap_delete(), ldap_errno(), ldap_error(), ldap_first_attribute(), ldap_first_entry(), ldap_get_attributes(), ldap_get_dn(), ldap_get_entries(), ldap_get_values(), ldap_get_values_len(), ldap_get_option(), ldap_list(), ldap_modify(), ldap_mod_add(), ldap_mod_replace(), ldap_next_attribute(), ldap_next_entry(), ldap_mod_del(), ldap_set_option(), ldap_unbind() | ldap_free_result() | Výsledek hledání na LDAP
ldap result entry
mcal | mcal_open(), mcal_popen() | mcal_create_calendar(), mcal_rename_calendar(), mcal_rename_calendar(), mcal_delete_calendar(), mcal_fetch_event(), mcal_list_events(), mcal_append_event(), mcal_store_event(), mcal_delete_event(), mcal_list_alarms(), mcal_event_init(), mcal_event_set_category(), mcal_event_set_title(), mcal_event_set_description(), mcal_event_set_start(), mcal_event_set_end(), mcal_event_set_alarm(), mcal_event_set_class(), mcal_next_recurrence(), mcal_event_set_recur_none(), mcal_event_set_recur_daily(), mcal_event_set_recur_weekly(), mcal_event_set_recur_monthly_mday(), mcal_event_set_recur_monthly_wday(), mcal_event_set_recur_yearly(), mcal_fetch_current_stream_event(), mcal_event_add_attribute(), mcal_expunge() | mcal_close() | Spojení na kalendářový server
SWFAction
SWFBitmap
SWFButton
SWFDisplayItem
SWFFill
SWFFont
SWFGradient
SWFMorph
SWFMovie
SWFShape
SWFSprite
SWFText
SWFTextField
mnogosearch agent
mnogosearch result
msql link | msql_connect() | msql(), msql_create_db(), msql_createdb(), msql_drop_db(), msql_drop_db(), msql_select_db(), msql_select_db() | msql_close() | Spojení na databázi mSQL
msql link persistent | msql_pconnect() | msql(), msql_create_db(), msql_createdb(), msql_drop_db(), msql_drop_db(), msql_select_db(), msql_select_db() | není | Perzistentní spojení na databázi mSQL
msql query | msql_db_query(), msql_list_dbs(), msql_list_fields(), msql_list_tables(), msql_query() | msql(), msql_affected_rows(), msql_data_seek(), msql_dbname(), msql_fetch_array(), msql_fetch_field(), msql_fetch_object(), msql_fetch_row(), msql_field_seek(), msql_field_table(), msql_field_flags(), msql_field_len(), msql_field_name(), msql_field_type(), msql_num_fields(), msql_num_rows(), msql_numfields(), msql_numrows(), msql_result() | msql_free_result(), msql_free_result() | Výsledek mSQL
mssql link | mssql_connect() | mssql_query(), mssql_select_db() | mssql_close() | Spojení na databázi Microsoft SQL Server
mssql link persistent | mssql_pconnect() | mssql_query(), mssql_select_db() | není | Perzistentní spojení na databázi Microsoft SQL Server
mssql result | mssql_query() | mssql_data_seek(), mssql_fetch_array(), mssql_fetch_field(), mssql_fetch_object(), mssql_fetch_row(), mssql_field_length(), mssql_field_name(), mssql_field_seek(), mssql_field_type(), mssql_num_fields(), mssql_num_rows(), mssql_result() | mssql_free_result() | Výsledek Microsoft SQL Server
mysql link | mysql_connect() | mysql_affected_rows(), mysql_change_user(), mysql_create_db(), mysql_data_seek(), mysql_db_name(), mysql_db_query(), mysql_drop_db(), mysql_errno(), mysql_error(), mysql_insert_id(), mysql_list_dbs(), mysql_list_fields(), mysql_list_tables(), mysql_query(), mysql_result(), mysql_select_db(), mysql_tablename(), mysql_get_host_info(), mysql_get_proto_info(), mysql_get_server_info() | mysql_close() | Spojení na databázi MySQL
mysql link persistent | mysql_pconnect() | mysql_affected_rows(), mysql_change_user(), mysql_create_db(), mysql_data_seek(), mysql_db_name(), mysql_db_query(), mysql_drop_db(), mysql_errno(), mysql_error(), mysql_insert_id(), mysql_list_dbs(), mysql_list_fields(), mysql_list_tables(), mysql_query(), mysql_result(), mysql_select_db(), mysql_tablename(), mysql_get_host_info(), mysql_get_proto_info(), mysql_get_server_info() | není | Perzistentní spojení na databázi MySQL
mysql result | mysql_db_query(), mysql_list_dbs(), mysql_list_fields(), mysql_list_processes(), mysql_list_tables(), mysql_query(), mysql_unbuffered_query() | mysql_data_seek(), mysql_db_name(), mysql_fetch_array(), mysql_fetch_assoc(), mysql_fetch_field(), mysql_fetch_lengths(), mysql_fetch_object(), mysql_fetch_row(), mysql_fetch_row(), mysql_field_flags(), mysql_field_name(), mysql_field_len(), mysql_field_seek(), mysql_field_table(), mysql_field_type(), mysql_num_fields(), mysql_num_rows(), mysql_result(), mysql_tablename() | mysql_free_result() | Výsledek MySQL
oci8 collection
oci8 connection | ocilogon(), ociplogon(), ocinlogon() | ocicommit(), ociserverversion(), ocinewcursor(), ociparse(), ocierror() | ocilogoff() | Spojení na databázi Oracle
oci8 descriptor
oci8 server
oci8 session
oci8 statement | ocinewdescriptor() | ocirollback(), ocinewdescriptor(), ocirowcount(), ocidefinebyname(), ocibindbyname(), ociexecute(), ocinumcols(), ociresult(), ocifetch(), ocifetchinto(), ocifetchstatement(), ocicolumnisnull(), ocicolumnname(), ocicolumnsize(), ocicolumntype(), ocistatementtype(), ocierror() | ocifreestatement() | Kurzor Oracle
odbc link | odbc_connect() | odbc_autocommit(), odbc_commit(), odbc_error(), odbc_errormsg(), odbc_exec(), odbc_tables(), odbc_tableprivileges(), odbc_do(), odbc_prepare(), odbc_columns(), odbc_columnprivileges(), odbc_procedurecolumns(), odbc_specialcolumns(), odbc_rollback(), odbc_setoption(), odbc_gettypeinfo(), odbc_primarykeys(), odbc_foreignkeys(), odbc_procedures(), odbc_statistics() | odbc_close() | Spojení na ODBC databázi
odbc link persistent | odbc_pconnect() | odbc_autocommit(), odbc_commit(), odbc_error(), odbc_errormsg(), odbc_exec(), odbc_tables(), odbc_tableprivileges(), odbc_do(), odbc_prepare(), odbc_columns(), odbc_columnprivileges(), odbc_procedurecolumns(), odbc_specialcolumns(), odbc_rollback(), odbc_setoption(), odbc_gettypeinfo(), odbc_primarykeys(), odbc_foreignkeys(), odbc_procedures(), odbc_statistics() | není | Perzistentní spojení na ODBC databázi
odbc result | odbc_prepare() | odbc_binmode(), odbc_cursor(), odbc_execute(), odbc_fetch_into(), odbc_fetch_row(), odbc_field_name(), odbc_field_num(), odbc_field_type(), odbc_field_len(), odbc_field_precision(), odbc_field_scale(), odbc_longreadlen(), odbc_num_fields(), odbc_num_rows(), odbc_result(), odbc_result_all(), odbc_setoption() | odbc_free_result() | Výsledek ODBC
birdstep link
birdstep result
OpenSSL key | openssl_get_privatekey(), openssl_get_publickey() | openssl_sign(), openssl_seal(), openssl_open(), openssl_verify() | openssl_free_key() | OpenSSL klíč
OpenSSL X.509 | openssl_x509_read() | openssl_x509_parse(), openssl_x509_checkpurpose() | openssl_x509_free() | Veřejný klíč
oracle Cursor | ora_open() | ora_bind(), ora_columnname(), ora_columnsize(), ora_columntype(), ora_error(), ora_errorcode(), ora_exec(), ora_fetch(), ora_fetch_into(), ora_getcolumn(), ora_numcols(), ora_numrows(), ora_parse() | ora_close() | Kurzor Oracle
oracle link | ora_logon() | ora_do(), ora_error(), ora_errorcode(), ora_rollback(), ora_commitoff(), ora_commiton(), ora_open(), ora_commit() | ora_logoff() | Spojení na databázi Oracle
oracle link persistent | ora_plogon() | ora_do(), ora_error(), ora_errorcode(), ora_rollback(), ora_commitoff(), ora_commiton(), ora_open(), ora_commit() | není | Perzistentní spojení na databázi Oracle
pdf document | pdf_new() | pdf_add_bookmark(), pdf_add_launchlink(), pdf_add_locallink(), pdf_add_note(), pdf_add_pdflink(), pdf_add_weblink(), pdf_arc(), pdf_attach_file(), pdf_begin_page(), pdf_circle(), pdf_clip(), pdf_closepath(), pdf_closepath_fill_stroke(), pdf_closepath_stroke(), pdf_concat(), pdf_continue_text(), pdf_curveto(), pdf_end_page(), pdf_endpath(), pdf_fill(), pdf_fill_stroke(), pdf_findfont(), pdf_get_buffer(), pdf_get_image_height(), pdf_get_image_width(), pdf_get_parameter(), pdf_get_value(), pdf_lineto(), pdf_moveto(), pdf_open_ccitt(), pdf_open_file(), pdf_open_image_file(), pdf_place_image(), pdf_rect(), pdf_restore(), pdf_rotate(), pdf_save(), pdf_scale(), pdf_setdash(), pdf_setflat(), pdf_setfont(), pdf_setgray(), pdf_setgray_fill(), pdf_setgray_stroke(), pdf_setlinecap(), pdf_setlinejoin(), pdf_setlinewidth(), pdf_setmiterlimit(), pdf_setpolydash(), pdf_setrgbcolor(), pdf_setrgbcolor_fill(), pdf_setrgbcolor_stroke(), pdf_set_border_color(), pdf_set_border_dash(), pdf_set_border_style(), pdf_set_char_spacing(), pdf_set_duration(), pdf_set_font(), pdf_set_horiz_scaling(), pdf_set_parameter(), pdf_set_text_pos(), pdf_set_text_rendering(), pdf_set_value(), pdf_set_word_spacing(), pdf_show(), pdf_show_boxed(), pdf_show_xy(), pdf_skew(), pdf_stringwidth(), pdf_stroke(), pdf_translate(), pdf_add_thumbnail(), pdf_arcn(), pdf_begin_pattern(), pdf_begin_template(), pdf_end_pattern(), pdf_end_template(), pdf_initgraphics(), pdf_makespotcolor(), pdf_set_info(), pdf_setcolor(), pdf_setmatrix(), pdf_open_memory_image() | pdf_close(), pdf_delete() | PDF dokument
pdf image | pdf_open_image(), pdf_open_image_file(), pdf_open_memory_image() | pdf_get_image_height(), pdf_get_image_width(), pdf_open_CCITT(), pdf_place_image() | pdf_close_image() | Obrázek v PDF souboru
pdf object
pdf outline
pgsql large object | pg_lo_open() | pg_lo_open(), pg_lo_create(), pg_lo_read(), pg_lo_read_all(), pg_lo_seek(), pg_lo_tell(), pg_lo_unlink(), pg_lo_write() | pg_lo_close() | PostgreSQL Large Object
pgsql link | pg_connect() | pg_affected_rows(), pg_query(), pg_send_query(), pg_get_result(), pg_connection_busy(), pg_connection_reset(), pg_connection_status(), pg_last_error(), pg_last_notice(), pg_lo_create(), pg_lo_export(), pg_lo_import(), pg_lo_open(), pg_lo_unlink(), pg_host(), pg_port(), pg_dbname(), pg_options(), pg_copy_from(), pg_copy_to(), pg_end_copy(), pg_put_line(), pg_tty(), pg_trace(), pg_untrace(), pg_set_client_encoding(), pg_client_encoding(), pg_metadata(), pg_convert(), pg_insert(), pg_select(), pg_delete(), pg_update() | pg_close() | Spojení na databázi PostgreSQL
pgsql link persistent | pg_pconnect() | pg_affected_rows(), pg_query(), pg_send_query(), pg_get_result(), pg_connection_busy(), pg_connection_reset(), pg_connection_status(), pg_last_error(), pg_last_notice(), pg_lo_create(), pg_lo_export(), pg_lo_import(), pg_lo_open(), pg_lo_unlink(), pg_host(), pg_port(), pg_dbname(), pg_options(), pg_copy_from(), pg_copy_to(), pg_end_copy(), pg_put_line(), pg_tty(), pg_trace(), pg_untrace(), pg_set_client_encoding(), pg_client_encoding(), pg_metadata(), pg_convert(), pg_insert(), pg_select(), pg_delete(), pg_update() | není | Perzistentní spojení na databázi PostgreSQL
pgsql result | pg_execute(), pg_query(), pg_query_params(), pg_get_result() | pg_fetch_array(), pg_fetch_object(), pg_fetch_result(), pg_fetch_row(), pg_field_is_null(), pg_field_name(), pg_field_num(), pg_field_prtlen(), pg_field_size(), pg_field_type(), pg_last_oid(), pg_num_fields(), pg_num_rows(), pg_result_error(), pg_result_status() | pg_free_result() | Výsledek PostgreSQL
pgsql string
printer
printer brush
printer font
printer pen
pspell | pspell_new(), pspell_new_config(), pspell_new_personal() | pspell_add_to_personal(), pspell_add_to_session(), pspell_check(), pspell_clear_session(), pspell_config_ignore(), pspell_config_mode(), pspell_config_personal(), pspell_config_repl(), pspell_config_runtogether(), pspell_config_save_repl(), pspell_save_wordlist(), pspell_store_replacement(), pspell_suggest() | není | Slovník pspell
pspell config | pspell_config_create() | pspell_new_config() | není | Konfigurace pspell
Sablotron XSLT | xslt_create() | xslt_closelog(), xslt_openlog(), xslt_run(), xslt_set_sax_handler(), xslt_errno(), xslt_error(), xslt_fetch_result(), xslt_free() | xslt_free() | XSLT parser
shmop | shmop_open() | shmop_read(), shmop_write(), shmop_size(), shmop_delete() | shmop_close()
sockets file descriptor set | socket() | accept_connect(), bind(), connect(), listen(), read(), write() | close() | Socket
sockets i/o vector
dir | opendir() | readdir(), rewinddir() | closedir() | Handle adresáře
stream | fopen(), tmpfile() | feof(), fflush(), fgetc(), fgetcsv(), fgets(), fgetss(), flock(), fpassthru(), fputs(), fwrite(), fread(), fseek(), ftell(), fstat(), ftruncate(), set_file_buffer(), rewind() | fclose() | Handle souboru
pipe | popen() | feof(), fflush(), fgetc(), fgetcsv(), fgets(), fgetss(), fpassthru(), fputs(), fwrite(), fread() | pclose() | Handle procesu
socket | fsockopen(), pfsockopen() | fflush(), fgetc(), fgetcsv(), fgets(), fgetss(), fpassthru(), fputs(), fwrite(), fread() | fclose() | Handle socketu
sybase-db link | sybase_connect() | sybase_query(), sybase_select_db() | sybase_close() | Spojení na databázi Sybase pomocí knihovny DB
sybase-db link persistent | sybase_pconnect() | sybase_query(), sybase_select_db() | není | Perzistentní Spojení na databázi Sybase pomocí knihovny DB
sybase-db result | sybase_query(), sybase_unbuffered_query() | sybase_data_seek(), sybase_fetch_array(), sybase_fetch_field(), sybase_fetch_object(), sybase_fetch_row(), sybase_field_seek(), sybase_num_fields(), sybase_num_rows(), sybase_result() | sybase_free_result() | Výsledek Sybase pomocí knihovny DB
sybase-ct link | sybase_connect() | sybase_affected_rows(), sybase_query(), sybase_select_db() | sybase_close() | Spojení na databázi Sybase pomocí knihovny CT
sybase-ct link persistent | sybase_pconnect() | sybase_affected_rows(), sybase_query(), sybase_select_db() | není | Perzistentní spojení na databázi Sybase pomocí knihovny CT
sybase-ct result | sybase_query() | sybase_data_seek(), sybase_fetch_array(), sybase_fetch_field(), sybase_fetch_object(), sybase_fetch_row(), sybase_field_seek(), sybase_num_fields(), sybase_num_rows(), sybase_result() | sybase_free_result() | Výsledek Sybase pomocí knihovny CT
sysvsem | sem_get() | sem_acquire() | sem_release() | Semafor System V
sysvshm | shm_attach() | shm_remove(), shm_put_var(), shm_get_var(), shm_remove_var() | shm_detach() | Sdílená paměť System V
wddx | wddx_packet_start() | wddx_add_vars() | wddx_packet_end() | Paket WDDX
xml | xml_parser_create(), xml_parser_create_ns() | xml_set_object(), xml_set_element_handler(), xml_set_character_data_handler(), xml_set_processing_instruction_handler(), xml_set_default_handler(), xml_set_unparsed_entity_decl_handler(), xml_set_notation_decl_handler(), xml_set_external_entity_ref_handler(), xml_parse(), xml_get_error_code(), xml_error_string(), xml_get_current_line_number(), xml_get_current_column_number(), xml_get_current_byte_index(), xml_parse_into_struct(), xml_parser_set_option(), xml_parser_get_option() | xml_parser_free() | XML parser
zlib | gzopen() | gzeof(), gzgetc(), gzgets(), gzgetss(), gzpassthru(), gzputs(), gzread(), gzrewind(), gzseek(), gztell(), gzwrite() | gzclose() | Souboru komprimovaný GZ

Předcházející | Nahoru | Další
Předdefinované konstanty | Domů | O. List of Supported Protocols/Wrappers


Příloha O. List of Supported Protocols/Wrappers

Obsah

Filesystem
Socket
HTTP and HTTPS
FTP and FTPS
PHP input/output streams
Compression Streams
Data (RFC 2397)
Secure Shell 2
Audio Streams
Process Interaction Streams

The following is a list of the various URL style protocols that PHP has built-in for use with the filesystem functions such as fopen() and copy(). In addition to these wrappers, as of PHP 4.3.0, you can write your own wrappers using PHP script and stream_wrapper_register().

Filesystem

All versions of PHP. Explicitly using file:// since PHP 5.0.0.

  • /path/to/file.ext
  • relative/path/to/file.ext
  • fileInCwd.ext
  • C:/path/to/winfile.ext
  • C:\path\to\winfile.ext
  • \\smbserver\share\path\to\winfile.ext
  • file:///path/to/file.ext

Filesystem is the default wrapper used with PHP and represents the local filesystem. When a relative path is specified (a path which does not begin with /, \, \\, or a Windows drive letter) the path provided will be applied against the current working directory. In many cases this is the directory in which the script resides unless it has been changed. Using the CLI sapi, this defaults to the directory from which the script was called.

With some functions, such as fopen() and file_get_contents(), include_path may be optionally searched for relative paths as well.

Tabulka O.1. Wrapper Summary

Attribute | Supported
Restricted by allow_url_fopen | No
Allows Reading | Yes
Allows Writing | Yes
Allows Appending | Yes
Allows Simultaneous Reading and Writing | Yes
Supports stat() | Yes
Supports unlink() | Yes
Supports rename() | Yes
Supports mkdir() | Yes
Supports rmdir() | Yes

Předcházející | Nahoru | Další
N. Seznam typů prostředků | Domů | Socket


HTTP and HTTPS

PHP 3, PHP 4, PHP 5. https:// since PHP 4.3.0

  • http://example.com
  • http://example.com/file.php?var1=val1&var2=val2
  • http://user:password@example.com
  • https://example.com
  • https://example.com/file.php?var1=val1&var2=val2
  • https://user:password@example.com

Allows read-only access to files/resources via HTTP 1.0, using the HTTP GET method. A Host: header is sent with the request to handle name-based virtual hosts. If you have configured a user_agent string using your ini file or the stream context, it will also be included in the request.

Varování

Server Microsoft IIS porušuje při používání SSL komunikační protokol tím, že uzavře spojení bez odeslání indikátoru close_notify. PHP to ohlásí jako "SSL: Fatal Protocol Error", když dosáhne konce toku dat. K vyřešení této situace byste mělo snížit úroveň hlášení chyb (error_reporting) tak, aby nezahrnovala varování. PHP 4.3.7 a vyšší dokáže detekovat chybný software IIS, otevřete-li stream za použití wrapperu https:// a bude automaticky potlačovat příslušná varování. Použijete-li však k vytvoření ssl:// socketu funkci fsockopen(), zůstáváte odpovědni za detekci a potlačení varování.

Redirects have been supported since PHP 4.0.5; if you are using an earlier version you will need to include trailing slashes in your URLs. If it's important to know the URL of the resource where your document came from (after all redirects have been processed), you'll need to process the series of response headers returned by the stream.

<?php
$url = 'http://www.example.com/redirecting_page.php';

$fp = fopen($url, 'r');

/* Prior to PHP 4.3.0 use $http_response_header
   instead of stream_get_meta_data() */
$meta_data = stream_get_meta_data($fp);
foreach($meta_data['wrapper_data'] as $response) {

  /* Were we redirected? */
  if (substr(strtolower($response), 0, 10) == 'location: ') {
    /* update $url with where we were redirected to */
    $url = substr($response, 18);
  }

}

?>

Příklad O.2. Fetch a page and send POST data

<?php

$postdata = http_build_query(
    array(
        'var1' => 'some content',
        'var2' => 'doh'
    )
);

$opts = array('http' =>
    array(
        'method'  => 'POST',
        'header'  => 'Content-type: application/x-www-form-urlencoded',
        'content' => $postdata
    )
);

$context  = stream_context_create($opts);

$result = file_get_contents('http://example.com/submit.php', false, $context);

?>

The stream allows access to the body of the resource; the headers are stored in the $http_response_header variable. Since PHP 4.3.0, the headers are available using stream_get_meta_data().

HTTP connections are read-only; you cannot write data or copy files to an HTTP resource.

Poznámka: HTTPS is supported starting from PHP 4.3.0, if you have compiled in support for OpenSSL.

Tabulka O.2. Wrapper Summary

Attribute | Supported
Restricted by allow_url_fopen | Yes
Allows Reading | Yes
Allows Writing | No
Allows Appending | No
Allows Simultaneous Reading and Writing | N/A
Supports stat() | No
Supports unlink() | No
Supports rename() | No
Supports mkdir() | No
Supports rmdir() | No

Tabulka O.3. Context options

Name | Usage | Default
method | GET, POST, or any other HTTP method supported by the remote server. | GET
header | Additional headers to be sent during request. Values in this option will override other values (such as User-agent:, Host:, and Authentication:). |
user_agent | Value to send with User-Agent: header. This value will only be used if user-agent is not specified in the header context option above. | php.ini setting: user_agent
content | Additional data to be sent after the headers. Typically used with POST or PUT requests. |
proxy | URI specifying address of proxy server. (e.g. tcp://proxy.example.com:5100). HTTPS proxying (through HTTP proxies) only works in PHP 5.1.0 or greater. |
request_fulluri | When set to TRUE, the entire URI will be used when constructing the request. (i.e. GET http://www.example.com/path/to/file.html HTTP/1.0). While this is a non-standard request format, some proxy servers require it. | FALSE
max_redirects | The max number of redirects to follow. Value 1 or less means that no redirects are followed. Added in PHP 5.1.0. | 20
protocol_version | HTTP protocol version. Added in PHP 5.1.0. | 1.0
timeout | Read timeout in seconds, specified by a float (e.g. 10.5). Added in PHP 5.2.1. | default_socket_timeout

Underlying socket stream context options: Additional context options may be supported by the underlying transport For http:// streams, refer to context options for the tcp:// transport. For https:// streams, refer to context options for the ssl:// transport.

Custom headers may be sent with an HTTP request prior to version 5 by taking advantage of a side-effect in the handling of the user_agent INI setting. Set user_agent to any valid string (such as the default PHP/version setting) followed by a carriage-return/line-feed pair and any additional headers. This method works in PHP 4 and all later versions.

Příklad O.3. Sending custom headers with an HTTP request

<?php
ini_set('user_agent', "PHP\r\nX-MyCustomHeader: Foo");

$fp = fopen('http://www.example.com/index.php', 'r');
?>

Results in the following request being sent:

GET /index.php HTTP/1.0
Host: www.example.com
User-Agent: PHP
X-MyCustomHeader: Foo

Předcházející | Nahoru | Další
Socket | Domů | FTP and FTPS


FTP and FTPS

PHP 3, PHP 4, PHP 5. ftps:// since PHP 4.3.0

  • ftp://example.com/pub/file.txt
  • ftp://user:password@example.com/pub/file.txt
  • ftps://example.com/pub/file.txt
  • ftps://user:password@example.com/pub/file.txt

Allows read access to existing files and creation of new files via FTP. If the server does not support passive mode ftp, the connection will fail.

You can open files for either reading or writing, but not both simultaneously. If the remote file already exists on the ftp server and you attempt to open it for writing but have not specified the context option overwrite, the connection will fail. If you need to overwrite existing files over ftp, specify the overwrite option in the context and open the file for writing. Alternatively, you can use the FTP extension.

Appending: As of PHP 5.0.0 files may be appended via the ftp:// URL wrapper. In prior versions, attempting to append to a file via ftp:// will result in failure.

ftps:// was introduced in PHP 4.3.0. It is the same as ftp://, but attempts to negotiate a secure connection with the ftp server. If the server does not support SSL, then the connection falls back to regular unencrypted ftp.

Poznámka: FTPS is supported starting from PHP 4.3.0, if you have compiled in support for OpenSSL.

Tabulka O.4. Wrapper Summary

Attribute | PHP 4 | PHP 5
Restricted by allow_url_fopen | Yes | Yes
Allows Reading | Yes | Yes
Allows Writing | Yes (new files only) | Yes (new files/existing files with overwrite)
Allows Appending | No | Yes
Allows Simultaneous Reading and Writing | No | No
Supports stat() | No | As of PHP 5.0.0: filesize(), filetype(), file_exists(), is_file(), and is_dir() elements only. As of PHP 5.1.0: filemtime().
Supports unlink() | No | Yes
Supports rename() | No | Yes
Supports mkdir() | No | Yes
Supports rmdir() | No | Yes

Tabulka O.5. Context options (as of PHP 5.0.0)

Name | Usage | Default
overwrite | Allow overwriting of already existing files on remote server. Applies to write mode (uploading) only. | FALSE (Disabled)
resume_pos | File offset at which to begin transfer. Applies to read mode (downloading) only. | 0 (Beginning of File)
proxy (PHP 5.1.0 or greater) | Proxy FTP request via http proxy server. Applies to file read operations only. Ex: tcp://squid.example.com:8000 |

Underlying socket stream context options: Additional context options may be supported by the underlying transport For ftp:// streams, refer to context options for the tcp:// transport. For ftps:// streams, refer to context options for the ssl:// transport.

Předcházející | Nahoru | Další
HTTP and HTTPS | Domů | PHP input/output streams


PHP input/output streams

  • php://stdin
  • php://stdout
  • php://stderr
  • php://output
  • php://input
  • php://filter (available since PHP 5.0.0)
  • php://memory (available since PHP 5.1.0)
  • php://temp (available since PHP 5.1.0)

php://stdin, php://stdout and php://stderr allow access to the corresponding input or output stream of the PHP process. The stream references a duplicate file descriptor, so if you open php://stdin and later close it, you close only your copy of the descriptor--the actual stream referenced by STDIN is unaffected. Note that PHP exhibited buggy behavior in this regard until PHP 5.2.1. It is recommended that you simply use the constants STDIN, STDOUT and STDERR instead of manually opening streams using these wrappers.

php://output allows you to write to the output buffer mechanism in the same way as print() and echo().

php://input allows you to read raw POST data. It is a less memory intensive alternative to $HTTP_RAW_POST_DATA and does not need any special php.ini directives. php://input is not available with enctype="multipart/form-data".

php://stdin and php://input are read-only, whereas php://stdout, php://stderr and php://output are write-only.

php://filter is a kind of meta-wrapper designed to permit the application of filters to a stream at the time of opening. This is useful with all-in-one file functions such as readfile(), file(), and file_get_contents() where there is otherwise no opportunity to apply a filter to the stream prior the contents being read.

The php://filter target takes the following 'parameters' as parts of its 'path'.

  • /resource=<stream to be filtered> (required) This parameter must be located at the end of your php://filter specification and should point to the stream which you want filtered.

    <?php
    /* This is equivalent to simply:
       readfile("http://www.example.com");
       since no filters are actually specified */

    readfile("php://filter/resource=http://www.example.com");
    ?>

  • /read=<filter list to apply to read chain> (optional) This parameter takes one or more filternames separated by the pipe character |.

    <?php
    /* This will output the contents of
       www.example.com entirely in uppercase */
    readfile("php://filter/read=string.toupper/resource=http://www.example.com");

    /* This will do the same as above
       but will also ROT13 encode it */
    readfile("php://filter/read=string.toupper|string.rot13/resource=http://www.example.com");
    ?>

  • /write=<filter list to apply to write chain> (optional) This parameter takes one or more filternames separated by the pipe character |.

    <?php
    /* This will filter the string "Hello World"
       through the rot13 filter, then write to
       example.txt in the current directory */
    file_put_contents("php://filter/write=string.rot13/resource=example.txt","Hello World");
    ?>

  • /<filter list to apply to both chains> (optional) Any filter lists which are not prefixed specifically by read= or write= will be applied to both the read and write chains (as appropriate).

The php://memory wrapper stores the data in the memory. php://temp behaves similarly, but uses a temporary file for storing the data when a certain memory limit is reached (the default is 2 MB).

The php://temp wrapper takes the following 'parameters' as parts of its 'path':

  • /maxmemory:<number of bytes> (optional). This parameter allows changing the default value for the memory limit (when the data is moved to a temporary file).

    <?php
    $fiveMBs     = 5 * 1024 * 1024;
    $fp = fopen("php://temp/maxmemory:$fiveMBs", 'r+');

    fputs($fp, "hello\n");

    // read what we have written
    rewind($fp);
    echo     stream_get_contents($fp);
    ?>

Tabulka O.6. Wrapper Summary (For php://filter, refer to summary of wrapper being filtered.)

Attribute | Supported
Restricted by allow_url_fopen | No
Restricted by allow_url_include | php://input, php://stdin, php://memory and php://temp only.
Allows Reading | php://stdin, php://input, php://memory and php://temp only.
Allows Writing | php://stdout, php://stderr, php://output, php://memory and php://temp only.
Allows Appending | php://stdout, php://stderr, php://output, php://memory and php://temp only. (Equivalent to writing)
Allows Simultaneous Reading and Writing | php://memory and php://temp only.
Supports stat() | php://memory and php://temp only.
Supports unlink() | No
Supports rename() | No
Supports mkdir() | No
Supports rmdir() | No

Předcházející | Nahoru | Další
FTP and FTPS | Domů | Compression Streams


Compression Streams

zlib: PHP 4.0.4 - PHP 4.2.3 (systems with fopencookie only)

compress.zlib:// and compress.bzip2:// PHP 4.3.0 and up

  • zlib:
  • compress.zlib://
  • compress.bzip2://

zlib: works like gzopen(), except that the stream can be used with fread() and the other filesystem functions. This is deprecated as of PHP 4.3.0 due to ambiguities with filenames containing ':' characters; use compress.zlib:// instead.

compress.zlib:// and compress.bzip2:// are equivalent to gzopen() and bzopen() respectively, and operate even on systems that do not support fopencookie.

Tabulka O.7. Wrapper Summary

Attribute | Supported
Restricted by allow_url_fopen | No
Allows Reading | Yes
Allows Writing | Yes
Allows Appending | Yes
Allows Simultaneous Reading and Writing | No
Supports stat() | No, use the normal file:// wrapper to stat compressed files.
Supports unlink() | No, use the normal file:// wrapper to unlink compressed files.
Supports rename() | No
Supports mkdir() | No
Supports rmdir() | No

ZIP extension registers zip: wrapper.

Předcházející | Nahoru | Další
PHP input/output streams | Domů | Data (RFC 2397)


Audio Streams

ogg:// PHP 4.3.0 and up (PECL)

  • ogg://soundfile.ogg
  • ogg:///path/to/soundfile.ogg
  • ogg://http://www.example.com/path/to/soundstream.ogg

This wrapper is not enabled by default: In order to use the ogg:// wrapper you must install the » OGG/Vorbis extension available from » PECL.

Files opened for reading via the ogg:// wrapper are treated as compressed audio encoded using the OGG/Vorbis codec. Similarly, files opened for writing or appending via the ogg:// wrapper are writen as compressed audio data. stream_get_meta_data(), when used on an OGG/Vorbis file opened for reading will return various details about the stream including the vendor tag, any included comments, the number of channels, the sampling rate, and the encoding rate range described by: bitrate_lower, bitrate_upper, bitrate_nominal, and bitrate_window.

Tabulka O.11. Wrapper Summary

Attribute | Supported
Restricted by allow_url_fopen | No
Allows Reading | Yes
Allows Writing | Yes
Allows Appending | Yes
Allows Simultaneous Reading and Writing | No
Supports stat() | No
Supports unlink() | No
Supports rename() | No
Supports mkdir() | No
Supports rmdir() | No

Tabulka O.12. Context options

Name | Usage | Default | Mode
pcm_mode | PCM encoding to apply while reading, one of: OGGVORBIS_PCM_U8, OGGVORBIS_PCM_S8, OGGVORBIS_PCM_U16_BE, OGGVORBIS_PCM_S16_BE, OGGVORBIS_PCM_U16_LE, and OGGVORBIS_PCM_S16_LE. (8 vs 16 bit, signed or unsigned, big or little endian) | OGGVORBIS_PCM_S16_LE | Read
rate | Sampling rate of input data, expressed in Hz | 44100 | Write/Append
bitrate | When given as an integer, the fixed bitrate at which to encode. (16000 to 131072) When given as a float, the variable bitrate quality to use. (-1.0 to 1.0) | 128000 | Write/Append
channels | The number of audio channels to encode, typically 1 (Mono), or 2 (Stero). May range as high as 16. | 2 | Write/Append
comments | An array of string values to encode into the track header. |  | Write/Append

Předcházející | Nahoru | Další
Secure Shell 2 | Domů | Process Interaction Streams


Příloha P. Seznam dostupných filtrů

Obsah

Řetězcové filtry
Konverzní filtry
Kompresní filtry
Šifrovací filtry

Toto je seznam několika vestavěných streamových filtrů pro použití s stream_filter_append(). Vaše verze PHP může obsahovat více (nebo méně) filtrů, než je zde uvedeno.

Stojí za to připomenout lehkou asymetrii mezi stream_filter_append() a stream_filter_prepend(). Každý PHP stream obsahuje malý buffer pro čtení, kam se ukládají bloky dat přečtených ze souborového systému nebo jiného prostředku kvůli co nejefektivnějšímu zpracování. Ihned poté, co jsou data načtena ze zdroje do vnitřního bufferu streamu, jsou zpracována všemi přiřazenými filtry, ať už je PHP aplikace aktuálně připravena je přijmout či nikoli. Pokud jsou v bufferu data v okamžiku, kdy je připojen nový filtr, tato data se ve filtru okamžitě zpracují, takže jejich uložení v bufferu zdá transparentní. Pokud jsou však v bufferu data a nový filtr je předřazen, data v bufferu se tímto filtrem nezpracují. Místo toho se čeká, až se bude načítat ze zdroje další blok dat.

K získání seznamu filtrů instalovaných ve vaší verzi PHP použijte funkci stream_get_filters().

Řetězcové filtry

Každý z těchto filtrů dělá přesně to, co vyplývá z jeho názvu a koresponduje s chováním funkcí pro zpracování řetězců, které jsou vestavěny v PHP. Pro více informací o daném filtru se podívejte na manuálovou stránku odpovídající funkce.

string.rot13 (od PHP 4.3.0) Použití tohoto filtru je ekvivalentní zpracování veškerých dat ze streamu funkcí str_rot13().

Příklad P.1. string.rot13

<?php
$fp = fopen('php://output', 'w');
stream_filter_append($fp, 'string.rot13');
fwrite($fp, "This is a test.\n");
/* Vypíše:  Guvf vf n grfg.   */
?>

string.toupper (od PHP 5.0.0) Použití tohoto filtru je ekvivalentní zpracování veškerých dat ze streamu funkcí strtoupper().

Příklad P.2. string.toupper

<?php
$fp = fopen('php://output', 'w');
stream_filter_append($fp, 'string.toupper');
fwrite($fp, "Toto je test.\n");
/* Vypíše:  TOTO JE TEST.   */
?>

string.tolower (od PHP 5.0.0) Použití tohoto filtru je ekvivalentní zpracování veškerých dat ze streamu funkcí strtolower().

Příklad P.3. string.tolower

<?php
$fp = fopen('php://output', 'w');
stream_filter_append($fp, 'string.tolower');
fwrite($fp, "Toto je test.\n");
/* Vypíše:  toto je test.   */
?>

string.strip_tags (od PHP 5.0.0) Použití tohoto filtru je ekvivalentní zpracování veškerých dat ze streamu funkcí strip_tags(). Přijímí parametry v jedné ze dvou forem: Buď jako řetězec obsahující seznam značek podobný druhému parametru funkce strip_tags(), anebo jako pole názvů značek.

Příklad P.4. string.strip_tags

<?php
$fp = fopen('php://output', 'w');
stream_filter_append($fp, 'string.strip_tags', STREAM_FILTER_WRITE, "<b><i><u>");
fwrite($fp, "<b>tučný text</b> se zvětší na <h1>nadpis úrovně 1</h1>\n");
fclose($fp);
/* Vypíše:  <b>tučný text</b> se zvětší na nadpis úrovně 1   */

$fp = fopen('php://output', 'w');
stream_filter_append($fp, 'string.strip_tags', STREAM_FILTER_WRITE, array('b','i','u'));
fwrite($fp, "<b>tučný text</b> se zvětší na <h1>nadpis úrovně 1</h1>\n");
fclose($fp);
/* Vypíše:  <b>tučný text</b> se zvětší na nadpis úrovně 1   */
?>

Předcházející | Nahoru | Další
Process Interaction Streams | Domů | Konverzní filtry


Konverzní filtry

Podobně jako filtry string.*, také filtry convert.* provádějí akce odpovídající jejich názvům. Konverzní filtry byly přidány ve verzi PHP 5.0.0. Pro více informací o daném filtru se podívejte na manuálovou stránku odpovídající funkce.

convert.base64-encode a convert.base64-decode Použití těchto filtrů je ekvivalentní zpracování veškerých dat ze streamu funkcí base64_encode(), resp. base64_decode(). convert.base64-encode podporuje parametry poskytnuté jako asociativní pole. Pokud je dán parametr line-length, výstup base64 bude rozdělen do úseků o délce line-length znaků. Je-li dán parametr line-break-chars, každý úsek bude oddělen danými znaky. Tyto parametry mají stejný efekt jako použití base64_encode() s chunk_split().

Příklad P.5. convert.base64-encode & convert.base64-decode

<?php
$fp = fopen('php://output', 'w');
stream_filter_append($fp, 'convert.base64-encode');
fwrite($fp, "This is a test.\n");
fclose($fp);
/* Vypíše:  VGhpcyBpcyBhIHRlc3QuCg==  */

$param = array('line-length' => 8, 'line-break-chars' => "\r\n");
$fp = fopen('php://output', 'w');
stream_filter_append($fp, 'convert.base64-encode', STREAM_FILTER_WRITE, $param);
fwrite($fp, "This is a test.\n");
fclose($fp);
/* Vypíše:  VGhpcyBp
          :  cyBhIHRl
          :  c3QuCg==  */

$fp = fopen('php://output', 'w');
stream_filter_append($fp, 'convert.base64-decode');
fwrite($fp, "VGhpcyBpcyBhIHRlc3QuCg==");
fclose($fp);
/* Vypíše:  This is a test.  */
?>

convert.quoted-printable-encode a convert.quoted-printable-decode Použití dekódovacího filtru je ekvivalentní zpracování veškerých dat ze streamu funkcí quoted_printable_decode(). Filtr convert.quoted-printable-encode nemá žádný funkční ekvivalent. convert.quoted-printable-encode podporuje parametry poskytnuté jako asociativní pole. K parametrům podporovaným filtrem convert.base64-encode, podporuje convert.quoted-printable-encode navíc boolovské argumenty binary a force-encode-first. convert.base64-decode podporuje pouze parametr line-break-chars jako pomůcku pro odstranění nadbytečných znaků v zakódovaných datech.

Příklad P.6. convert.quoted-printable-encode & convert.quoted-printable-decode

<?php
$fp = fopen('php://output', 'w');
stream_filter_append($fp, 'convert.quoted-printable-encode');
fwrite($fp, "This is a test.\n");
/* Outputs:  =This is a test.=0A  */
?>

Předcházející | Nahoru | Další
P. Seznam dostupných filtrů | Domů | Kompresní filtry


Kompresní filtry

Zatímco Kompresní wrappery poskytují cestu k vytváření kompatibilních GZIP a BZ2 souborů v místním souborovém systému, nejsou schopny poskytnout zobecněnou kompresi síťových streamů, ani možnost začít s nekomprimovaným streamem a změnit ho na komprimovaný. Kompresní filtry lze ovšem kdykoli aplikovat na libovolný stream.

Poznámka: Kompresní filtry negenerují hlavičky a ukončovací sekvence, jak to dělají konzolové utility jako gzip. Pouze komprimují a dekomprimují užitečné části datových streamů.

zlib.deflate (komprese) a zlib.inflate (dekomprese) jsou implementace kompresních metod popsaných v » RFC 1951. Filtr deflate přijímá až tři parametry předané jako asociativní pole. level udává, jakou účinnost komprese použít (1-9). Vyšší čísla vedou k menšímu objemu dat za cenu delšího času zpracování. Existují také dvě speciální kompresní úrovně: 0 (žádná komprese) a -1 (vnitřní výchozí hodnota zlib - momentálně 6). window je dvojkový logaritmus velikosti kompresního okna. Vyšší hodnoty (až 15 -- 32768 B) vedou k lepší kompresi při větších nárocích na paměť. kdežto nižší (od 9 -- 512 B) znamenají horší kompresi za menší spotřeby paměti. Výchozí hodnota parametru window je nyní 15. memory udává, kolik paměti by se mělo alokovat. Rozsah platných hodnot je od 1 (minimální alokace) do 9 (maximální alokace). Tato hodnota má vliv pouze na rychlost, neovlivňuje účinnost komprese.

Poznámka: Protože úroveň komprese je nejčastěji používaným parametrem, lze ji alternativně udat také jako obyčejnou celočíselnou hodnotu (namísto prvku pole).

Kompresní filtry zlib.* jsou k dispozici v PHP od verze 5.1.0, pokud je zapnuta podpora zlib. Jsou dostupné též jako backport ve verzi 5.0.x po nainstalování balíku » zlib_filter z » PECL. Tyto filtry nejsou dostupné v PHP 4.

Příklad P.7. zlib.deflate a zlib.inflate

<?php
$params = array('level' => 6, 'window' => 15, 'memory' => 9);

$original_text = "Toto je test.\nToto je pouze test.\nToto není důležitý řetězec.\n";
echo "Původní text je " . strlen($original_text) . " znaků dlouhý.\n";

$fp = fopen('test.deflated', 'w');
stream_filter_append($fp, 'zlib.deflate', STREAM_FILTER_WRITE, $params);
fwrite($fp, $original_text);
fclose($fp);

echo "Komprimovaný soubor je " . filesize('test.deflated') . " B velký.\n";
echo "Původní text byl:\n";
/* Použij readfile a zlib.inflate k dekompresi "za letu" */
readfile('php://filter/zlib.inflate/resource=test.deflated');

/* Vygeneruje výstup:

Původní text je 70 znaků dlouhý.
Komprimovaný soubor je 56 B velký.
Původní text byl:
Toto je test.
Toto je pouze test.
Toto není důležitý řetězec.

 */
?>

Příklad P.8. jednoduché zlib.deflate

<?php
$original_text = "Toto je test.\nToto je pouze test.\nToto není důležitý řetězec.\n";
echo "P?vodní text je " . strlen($original_text) . " znaků dlouhý.\n";

$fp = fopen('test.deflated', 'w');
/* zde "6" indikuje úroveň komprese 6 */
stream_filter_append($fp, 'zlib.deflate', STREAM_FILTER_WRITE, 6);
fwrite($fp, $original_text);
fclose($fp);

echo "Komprimovaný soubor je " . filesize('test.deflated') . " B velký.\n";

/*  Vygeneruje výstup:

Původní text je 70 znaků dlouhý.
Komprimovaný soubor je 56 B velký.

 */
?>

bzip2.compress a bzip2.decompress pracují stejným způsobem jako filtry zlib popsané výše. Filtr bzip2.compress přijímá až dva parametry poskytnuté jako prvky asociativního pole: blocks je hodnota typu integer od 1 do 9, udávající počet 100KB bloků paměti, které se alokují pro zpracování. work je také typu integer, a to v rozmezí 0 až 250. Říká, jak velké úsilí se má vynaložit s normální kompresní metodou, než se přejde na pomalejší, ale spolehlivější metodu. Ladění tohoto parametru má vliv pouze na rychlost komprese. Nemění se tím ani velikost komprimovaného výstupu, ani využití paměti. Hodnota 0 znamená, že knihovna bzip použije vnitřní výchozí hodnotu. Filtr bzip2.decompress přijímá pouze jeden parametr, který se předává buď jako normální pravdivostní hodnota, nebo jako prvek small v asociativním poli. small, pokud má hodnotu TRUE, říká knihovně bzip, že se má k dekompresi použít minimální množství paměti na úkor rychlosti.

Kompresní filtry bzip2.* jsou dostupné od verze 5.1.0, pokud je zapnuta podpora bz2. Jsou dostupné též jako backport ve verzi 5.0.x po nainstalování balíku » bz2_filter z » PECL. Tyto filtry nejsou dostupné v PHP 4.

Příklad P.9. bzip2.compress a bzip2.decompress

<?php
$param = array('blocks' => 9, 'work' => 0);

echo "Původní soubor je " . filesize('LICENSE') . " B velký.\n";

$fp = fopen('LICENSE.compressed', 'w');
stream_filter_append($fp, 'bzip2.compress', STREAM_FILTER_WRITE, $param);
fwrite($fp, file_get_contents('LICENSE'));
fclose($fp);

echo "Komprimovaný soubor je " . filesize('LICENSE.compressed') . " B velký.\n";

/* Vygenerovaný výstup:

Původní soubor je 3288 B velký.
Komprimovaný soubor je 1488 B velký.

 */
?>

Předcházející | Nahoru | Další
Konverzní filtry | Domů | Šifrovací filtry


Příloha Q. Seznam podporovaných socketových transportů

Obsah

Internetová oblast: TCP, UDP, SSL a TLS
Unixová oblast: Unix a UDG

Toto je seznam různých socketových transportů v URL stylu, které byly vestavěny do PHP k použití se socketovými funkcemi založenými na streamech, jako je fsockopen() a stream_socket_client(). Tyto transporty nelze použít s rozšířením Sockets Extension.

K získání seznamu transportů instalovaných ve vaší verzi PHP použijte funkci stream_get_transports().

Internetová oblast: TCP, UDP, SSL a TLS

PHP 3, PHP 4, PHP 5. ssl:// & tls:// od PHP 4.3.0 sslv2:// & sslv3:// od PHP 5.0.2

Poznámka: Není-li specifikován žádný transport, předpokládá se tcp://.

  • 127.0.0.1
  • fe80::1
  • www.example.com
  • tcp://127.0.0.1
  • tcp://fe80::1
  • tcp://www.example.com
  • udp://www.example.com
  • ssl://www.example.com
  • sslv2://www.example.com
  • sslv3://www.example.com
  • tls://www.example.com

Internetové sockety očekávají spolu s cílovou adresou číslo portu. V případě funkce fsockopen() se port specifikuje v samostatném parametru a proto nemá vliv na formátování URL transportu. U stream_socket_client() a souvisejících funkcí, podobně jako u tradičních URL, se však číslo portu specifikuje přidáním k URL transportu (a odděluje se dvojtečkou).

  • tcp://127.0.0.1:80
  • tcp://[fe80::1]:80
  • tcp://www.example.com:80

Číselné adresy IPv6 s čísly portů: Ve druhém příkladu výše, přestože příklady pro IPv4 a jmennou adresu jsou ponechány nedotčené při přidání dvojtečky a čísla portu, adresa IPv6 je uzavřena do hranatých závorek: [fe80::1]. Je to kvůli rozlišení mezi dvojtečkami použitými v IPv6 adrese a tou, která odděluje číslo portu.

Transporty ssl:// a tls:// (dostupné pouze v případě, že se do PHP zakompiluje podpora OpenSSL) jsou rozšířením transportu tcp://, které zahrnuje podporu SSL šifrování. Zatímco v PHP 4.3.0 se musí podpora OpenSSL kompilovat do PHP staticky, od verze PHP 5.0.0 ji lze kompilovat staticky i jako modul.

ssl:// se bude pokoušet vyjednat spojení SSL V2 nebo SSL V3, v záležitosti na schopnostech a nastavení vzdáleného stroje. sslv2:// a sslv3:// explicitně vybere protokol SSL V2 nebo SSL V3.

Tabulka Q.1. Kontextové volby pro ssl:// a tls:// transporty (od PHP 4.3.2)

Název | Použití | Výchozí
verify_peer | TRUE nebo FALSE. Vyžádá ověření použitého SSL certifikátu. | FALSE
allow_self_signed | TRUE nebo FALSE. Povolí použití certifikátu podepsaného sebou samým. | FALSE
cafile | Umístění souboru certifikačních autorit, který by se měl používat v kontextu funkce verify_peer k ověření totožnosti vzdáleného stroje, v místní souborovém systému. |
capath | Pokud cafile není specifikován nebo tam nelze certifikát najít, bude se použitelný certifikát hledat v adresáři určeném capath. capath musí být správný hashovaný adresář s certifikáty. |
local_cert | Cesta v souborovém systému k souboru místního certifikátu. Musí to být soubor zakódovaný PEM, obsahující váš certifikát a soukromý klíč. Volitelně může obsahovat i certifikátový řetěz vydavatelů. |
passphrase | Heslo, kterým byl zakódován váš soubor local_cert. |
CN_match | Očekávaná položka Common Name (CN). PHP provede omezenou kontrolu pomocí wildcards. Nevyhoví-li Common Name, pokus o spojení selže. |

Poznámka: Protože ssl:// je bázový transport pro wrappery https:// a ftps://, jakékoli kontextové volby vztahující se k ssl:// se vztahují také na https:// a ftps://.

Předcházející | Nahoru | Další
Šifrovací filtry | Domů | Unixová oblast: Unix a UDG


Unixová oblast: Unix a UDG

unix:// od PHP 3, udg:// od PHP 5

  • unix:///tmp/mysock
  • udg:///tmp/mysock

unix:// poskytuje přístup k socketovému streamovému spojení v unixové oblasti (doméně). udg:// poskytuje alternativní transport na socket v unixovové oblasti za použití uživatelského datagramového protokolu.

Unixové sockety, narozdíl od socketů internetových, neočekávají číslo portu. U funkce fsockopen() by měl být parametr portno nastaven na nulu (0).

Předcházející | Nahoru | Další
Q. Seznam podporovaných socketových transportů | Domů | R. Tabulky porovnání datových typů v PHP


Příloha R. Tabulky porovnání datových typů v PHP

Následující tabulky ukazují chování PHP typů a porovnávacích operatorů, jak pro volné, tak pro striktní porovnávání. Tento doplněk se také vztahuje k manuálové sekci o manipulaci s typy. Inspirace byla čerpána z různých uživatelských komentářů a z práce na » BlueShoes.

Před použitím těchto tabulek je důležité pochopit typy a jejich významy. Například "42" je string (řetězec), kdežto 42 je integer (celé číslo). FALSE je boolean, kdežto "false" je string.

Poznámka: HTML formuláře nepředávají celá čísla, čísla v plovoucí řádové čárce ani pravdivostní hodnoty; předávají řetězce. Ke zjištění, zda se jedná o číselný řetězec, můžete použít funkci is_numeric().

Poznámka: Jednoduché if ($x), když $x není definováno, vygeneruje chybu úrovně E_NOTICE. Namísto toho zvolte použití empty() nebo isset() a/nebo své proměnné inicializujte.

Tabulka R.1. Porovnání $x v PHP funkcích

Výraz | gettype() | empty() | is_null() | isset() | boolean : if($x)
$x = ""; | string | TRUE | FALSE | TRUE | FALSE
$x = NULL | NULL | TRUE | TRUE | FALSE | FALSE
var $x; | NULL | TRUE | TRUE | FALSE | FALSE
$x není definováno | NULL | TRUE | TRUE | FALSE | FALSE
$x = array(); | array | TRUE | FALSE | TRUE | FALSE
$x = false; | boolean | TRUE | FALSE | TRUE | FALSE
$x = true; | boolean | FALSE | FALSE | TRUE | TRUE
$x = 1; | integer | FALSE | FALSE | TRUE | TRUE
$x = 42; | integer | FALSE | FALSE | TRUE | TRUE
$x = 0; | integer | TRUE | FALSE | TRUE | FALSE
$x = -1; | integer | FALSE | FALSE | TRUE | TRUE
$x = "1"; | string | FALSE | FALSE | TRUE | TRUE
$x = "0"; | string | TRUE | FALSE | TRUE | FALSE
$x = "-1"; | string | FALSE | FALSE | TRUE | TRUE
$x = "php"; | string | FALSE | FALSE | TRUE | TRUE
$x = "true"; | string | FALSE | FALSE | TRUE | TRUE
$x = "false"; | string | FALSE | FALSE | TRUE | TRUE

Tabulka R.2. Volné porovnání pomocí ==

 | TRUE | FALSE | 1 | 0 | -1 | "1" | "0" | "-1" | NULL | array() | "php"
TRUE | TRUE | FALSE | TRUE | FALSE | TRUE | TRUE | FALSE | TRUE | FALSE | FALSE | TRUE
FALSE | FALSE | TRUE | FALSE | TRUE | FALSE | FALSE | TRUE | FALSE | TRUE | TRUE | FALSE
1 | TRUE | FALSE | TRUE | FALSE | FALSE | TRUE | FALSE | FALSE | FALSE | FALSE | FALSE
0 | FALSE | TRUE | FALSE | TRUE | FALSE | FALSE | TRUE | FALSE | TRUE | FALSE | TRUE
-1 | TRUE | FALSE | FALSE | FALSE | TRUE | FALSE | FALSE | TRUE | FALSE | FALSE | FALSE
"1" | TRUE | FALSE | TRUE | FALSE | FALSE | TRUE | FALSE | FALSE | FALSE | FALSE | FALSE
"0" | FALSE | TRUE | FALSE | TRUE | FALSE | FALSE | TRUE | FALSE | FALSE | FALSE | FALSE
"-1" | TRUE | FALSE | FALSE | FALSE | TRUE | FALSE | FALSE | TRUE | FALSE | FALSE | FALSE
NULL | FALSE | TRUE | FALSE | TRUE | FALSE | FALSE | FALSE | FALSE | TRUE | TRUE | FALSE
array() | FALSE | TRUE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | TRUE | TRUE | FALSE
"php" | TRUE | FALSE | FALSE | TRUE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | TRUE

Tabulka R.3. Striktní porovnání pomocí ===

 | TRUE | FALSE | 1 | 0 | -1 | "1" | "0" | "-1" | NULL | array() | "php"
TRUE | TRUE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE
FALSE | FALSE | TRUE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE
1 | FALSE | FALSE | TRUE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE
0 | FALSE | FALSE | FALSE | TRUE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE
-1 | FALSE | FALSE | FALSE | FALSE | TRUE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE
"1" | FALSE | FALSE | FALSE | FALSE | FALSE | TRUE | FALSE | FALSE | FALSE | FALSE | FALSE
"0" | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | TRUE | FALSE | FALSE | FALSE | FALSE
"-1" | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | TRUE | FALSE | FALSE | FALSE
NULL | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | TRUE | FALSE | FALSE
array() | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | TRUE | FALSE
"php" | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | FALSE | TRUE

Poznámka pro PHP 3.0: Hodnota řetězce "0" se v PHP 3 považuje za neprázdnou. V PHP 4 se toto chování změnilo a řetězec je nyní považován za prázdný.

Předcházející | Nahoru | Další
Unixová oblast: Unix a UDG | Domů | S. Seznam tokenů parseru


Příloha S. Seznam tokenů parseru

Různé části jazyka PHP jsou vnitřně reprezentovány typy jako T_SR. PHP vypisuje identifikátory, jako je tento, v parsovacích chybách, jako: "Parse error: unexpected T_SR, expecting ',' or ';' in script.php on line 10."

Předpokládá se, že víte, co T_SR znamená. Pro každého, kdo to neví, je zde tabulka těchto identifikátorů, PHP syntaxe a odkazy na příslušná místa v manulálu.

Tabulka S.1. Tokeny

Token | Syntaxe | Odkaz
T_ABSTRACT | abstract | „Class Abstraction“ (k dispozici od PHP 5.0.0)
T_AND_EQUAL | &= | operátory přiřazení
T_ARRAY | array() | array(), syntaxe pole
T_ARRAY_CAST | (array) | přetypování
T_AS | as | foreach
T_BAD_CHARACTER |  | cokoliv pod ASCII 32 kromě \t (0x09), \n (0x0a) a \r (0x0d)
T_BOOLEAN_AND | && | logické operátory
T_BOOLEAN_OR | || | logické operátory
T_BOOL_CAST | (bool) or (boolean) | přetypování
T_BREAK | break | break
T_CASE | case | switch
T_CATCH | catch | 21 – „Exceptions“ (k dispozici od PHP 5.0.0)
T_CHARACTER |  |
T_CLASS | class | třídy a objekty
T_CLONE | clone | třídy a objekty. Pouze PHP 5.
T_CLOSE_TAG | ?> nebo %> |
T_COMMENT | // or #, a /* */ v PHP 5 | komentáře
T_CONCAT_EQUAL | .= | operátory přiřazení
T_CONST | const |
T_CONSTANT_ENCAPSED_STRING | "foo" or 'bar' | syntaxe řetězců
T_CONTINUE | continue |
T_CURLY_OPEN |  |
T_DEC | -- | inkrementační/dekrementační operátory
T_DECLARE | declare | declare
T_DEFAULT | default | switch
T_DIV_EQUAL | /= | operátory přiřazenís
T_DNUMBER | 0.12, etc | čísla v plovoucí řádové čárce
T_DOC_COMMENT | /** */ | komentáře stylu PHPDoc (pouze PHP 5)
T_DO | do | do..while
T_DOLLAR_OPEN_CURLY_BRACES | ${ | parsovaná syntaxe komplexní proměnné
T_DOUBLE_ARROW | => | syntaxe pole
T_DOUBLE_CAST | (real), (double) nebo (float) | přetypování
T_DOUBLE_COLON | :: | viz T_PAAMAYIM_NEKUDOTAYIM níže
T_ECHO | echo | echo()
T_ELSE | else | else
T_ELSEIF | elseif | elseif
T_EMPTY | empty | empty()
T_ENCAPSED_AND_WHITESPACE |  |
T_ENDDECLARE | enddeclare | declare, alternativní syntaxe
T_ENDFOR | endfor | for, alternativní syntaxe
T_ENDFOREACH | endforeach | foreach, alternativní syntaxe
T_ENDIF | endif | if, alternativní syntaxe
T_ENDSWITCH | endswitch | switch, alternativní syntaxe
T_ENDWHILE | endwhile | while, alternativní syntaxe
T_END_HEREDOC |  | syntaxe heredoc
T_EVAL | eval() | eval()
T_EXIT | exit or die | exit(), die()
T_EXTENDS | extends | extends, třídy a objekty
T_FILE | __FILE__ | konstanty
T_FINAL | final | „Final Keyword“ (k dispozici od PHP 5.0.0)
T_FOR | for | for
T_FOREACH | foreach | foreach
T_FUNCTION | function or cfunction | funkce
T_GLOBAL | global | rozsah platnosti proměnných
T_HALT_COMPILER | __halt_compiler() | __halt_compiler (k dispozici od PHP 5.1.0)
T_IF | if | if
T_IMPLEMENTS | implements | „Object Interfaces“ (k dispozici od PHP 5.0.0)
T_INC | ++ | inkrementační/dekrementační operátory
T_INCLUDE | include() | include()
T_INCLUDE_ONCE | include_once() | include_once()
T_INLINE_HTML |  |
T_INSTANCEOF | instanceof | typové operátory (pouze PHP5)
T_INT_CAST | (int) nebo (integer) | přetypování
T_INTERFACE | interface | „Object Interfaces“ (k dispozici od PHP 5.0.0)
T_ISSET | isset() | isset()
T_IS_EQUAL | == | porovnávací operátory
T_IS_GREATER_OR_EQUAL | >= | porovnávací operátory
T_IS_IDENTICAL | === | porovnávací operátory
T_IS_NOT_EQUAL | != or <> | porovnávací operátory
T_IS_NOT_IDENTICAL | !== | porovnávací operátory
T_IS_SMALLER_OR_EQUAL | <= | porovnávací operátory
T_LINE | __LINE__ | konstanty
T_LIST | list() | list()
T_LNUMBER | 123, 012, 0x1ac, atd. | celá čísla
T_LOGICAL_AND | and | logické operátory
T_LOGICAL_OR | or | logické operátory
T_LOGICAL_XOR | xor | logické operátory
T_MINUS_EQUAL | -= | operátory přiřazení
T_ML_COMMENT | /* a */ | komentáře (pouze PHP 4)
T_MOD_EQUAL | %= | operátory přiřazení
T_MUL_EQUAL | *= | operátory přiřazení
T_NEW | new | třídy a objekty
T_NUM_STRING |  |
T_OBJECT_CAST | (object) | přetypování
T_OBJECT_OPERATOR | -> | třídy a objekty
T_OLD_FUNCTION | old_function | old_function
T_OPEN_TAG | <?php, <? nebo <% | přechod z HTML
T_OPEN_TAG_WITH_ECHO | <?= nebo <%= | přechod z HTML
T_OR_EQUAL | |= | operátory přiřazení
T_PAAMAYIM_NEKUDOTAYIM | :: | ::. Definováno také jaké T_DOUBLE_COLON.
T_PLUS_EQUAL | += | operátory přiřazení
T_PRINT | print() | print()
T_PRIVATE | private | třídy a objekty. Pouze PHP 5.
T_PUBLIC | public | třídy a objekty. Pouze PHP 5.
T_PROTECTED | protected | třídy a objekty. Pouze PHP 5.
T_REQUIRE | require() | require()
T_REQUIRE_ONCE | require_once() | require_once()
T_RETURN | return | návratové hodnoty
T_SL | << | bitové operátory
T_SL_EQUAL | <<= | operátory přiřazení
T_SR | >> | bitové operátory
T_SR_EQUAL | >>= | operátory přiřazení
T_START_HEREDOC | <<< | syntaxe heredoc
T_STATIC | static | rozsah platnosti proměnných
T_STRING |  |
T_STRING_CAST | (string) | přetypování
T_STRING_VARNAME |  |
T_SWITCH | switch | switch
T_THROW | throw | 21 – „Exceptions“ (k dispozici od PHP 5.0.0)
T_TRY | try | 21 – „Exceptions“ (k dispozici od PHP 5.0.0)
T_UNSET | unset() | unset()
T_UNSET_CAST | (unset) | (not documented; přetypuje na NULL)
T_USE | use | (neimplementováno)
T_VAR | var | třídy a objekty
T_VARIABLE | $foo | proměnné
T_WHILE | while | while, do..while
T_WHITESPACE |  |
T_XOR_EQUAL | ^= | operátory přiřazení
T_FUNC_C | __FUNCTION__ | konstanty, od PHP 4.3.0
T_CLASS_C | __CLASS__ | konstanty, od PHP 4.3.0

Viz také token_name().

Předcházející | Nahoru | Další
R. Tabulky porovnání datových typů v PHP | Domů | T. Userland Naming Guide


Příloha U. O tomto manuálu

Obsah

Formáty
O uživatelských poznámkách
Jak číst definice funkcí (prototypy)
Verze PHP dokumentované v tomto manuálu
Jak najít více informací o PHP
Jak pomoci zlepšit dokumentaci
Jak generujeme formáty
Překlady

Formáty

Tento PHP manuál je poskytován v různých formátech. Tyto formáty se dají rozdělit do dvou skupin: formáty pro prohlížení on-line a balíky pro stahování.

Poznámka: Někteří vydavatelé vydali tištěné verze tohoto manuálu. Žádné z nich nedoporučujeme, protože velmi rychle zastarávají.

Manuál si lze přečíst on-line na » http://www.php.net/ a mnoha zrcadlech. Pro nejrychlejší přístup byste si měli vybrat zrcadlo umístěné co nejblíže k vám. HTML verze manuálu existuje v "holém" HTML formátu (vhodném pro tisk) nebo v HTML formátu integrujícím manuál do vzhledu a chování samotných stránek PHP.

Dvěma podstatnými výhodami on-line formátů manuálu oproti většině off-line formátů je integrace uživatelských poznámek a » URL odkazů, které lze použít k rychlému přístupu k požadovaným částem manuálu. Očividnou nevýhodou je, že k prohlížení této verze manuálu nutno být on-line.

Existuje více off-line formátů manuálu a formát pro vás nejvhodnější závisí na použitém operačním systému a na osobním stylu čtení. Pro informaci o tom, jak je manuál generován v tolika formátech, si přečtěte sekci 'Jak generujeme formáty' v tomto dodatku.

Pro nejvíce platforem se hodí manuál v HTML a jako prostý text. HTML formát je poskytován jak jako jediný HTML soubor, tak jako balíček souborů podle jednotlivých sekcí (což ve výsledku znamená kolekci tisíců souborů). Tyto verze poskytujeme komprimované, k získání souborů z archivů je potřeba nějaký dekompresní nástroj.

Pro platformu Windows je k dispozici verze Windows HTML Help pro použití s aplikací Windows HTML Help. Tato verze fulltextové vyhledávání, úplný rejstřík a záložky. Mnoho populárních vývojových prostředí pro vývoj v PHP se také integruje s touto verzí dokumentace, čímž k ní poskytují snadný přístup. Existují i prohlížeče CHM pro Linux. Zkuste stránky » xCHM nebo » GnoCHM.

Existuje také » rozšířená CHM verze, která se aktualizuje méně často, ale nabízí mnohem více možností. Kvůli použitým technologiím však funguje pouze na Microsoft Windows.

Předcházející | Nahoru | Další
Tips | Domů | O uživatelských poznámkách


O uživatelských poznámkách

Uživatelské poznámky hrají důležitou roli ve vývoji tohoto manuálu. Umožněním čtenářům manuálu přidávat příklady a další vysvětlení přímo z jejich prohlížeče jsme schopni zabudovat zpětnou vazbu do hlavního textu manuálu. A než jsou poznámky zpracovány, mohou být vidět v podobě, v jaké je uživatelé poslali, v on-line (a některých off-line) formátech.

Poznámka: Uživatelské poznámky nejsou moderovány před jejich zobrazením on-line, takže kvalita textu nebo příkladů kódu a jejich věrohodnost nemohou být zaručeny (ne, že by byla zaručena kvalita nebo přesnost samotného manuálu).

Poznámka: Pro licenční účely jsou uživatelské poznámky považovány za součást PHP manuálu a proto jsou kryty stejnou licencí jako tato dokumentace (tj. v tuto chvíli Open Publication License). Pro více detailů viz Copyright manuálu.

Předcházející | Nahoru | Další
U. O tomto manuálu | Domů | Jak číst definice funkcí (prototypy)


Jak číst definice funkcí (prototypy)

Každá funkce v manuálu je pro rychlou referenci zdokumentována. Když víte, jak číst a chápat tyto texty, naučíte se PHP mnohem snadněji. Namísto spoléhání na příklady nebo na vystřihování/vkládání, by měl každý vědět, jak číst definice (prototypy) funkcí. Nuže, začněme:

Prerekvizita: Zakladní pochopení typů : Přestože PHP je slabě typový jazyk, je důležité mít základní znalosti o typech, protože mají důležitý význam.

Definice funkcí nám říkají, jaký typ hodnoty je vracen. Jako náš první příklad použijme definici pro funkci strlen():

strlen

(PHP 3, PHP 4, PHP 5)
strlen -- Vrací délku řetězce

Popis
int strlen ( string str )

Vrací délku řetězce.

Tabulka U.1. Vysvětlení definice funkce

Část | Popis
strlen | Název funkce.
(PHP 3, PHP 4, PHP 5) | strlen() je k dispozici ve všech verzích PHP 3, PHP 4 a PHP 5
int | Typ hodnoty, který tato funkce vrací, což je integer (např. délka řetězce je měřena číselně).
( string str ) | První (a v tomto případě také jediný) parametr/argument pro tuto funkci je nazván str a je typu string.

Výše uvedenou definici funkce může genericky přepsat:

      návratový typ    název funkce    ( typ parametru   název parametru )

Mnoho funkcí má více parametrů, jako např. in_array(). Prototy pak vypadá následovně:

      bool in_array ( mixed needle, array haystack [, bool strict])

Co to znamená? in_array() vrací hodnotu typu boolean, TRUE při úspěchu (je-li parametr needle nalezen v haystack), nebo FALSE při selhání (needle se v haystack) nenajde). První parametr je nazván needle a může být mnoha různých typů, proto ho označujeme "mixed" (smíšený). Tento smíšený parametr needle (tj. "co hledáme") může být jak skalární hodnota (string, integer, nebo float), tak pole. Parametr haystack (pole, ve kterém hledáme) je druhý parametr. Třetí nepovinný parametr je nazván strict. Všechny nepovinné parametry se uvádějí v [ hranatých závorkách ]. Manuál uvádí, že parametr strict má výchozí (boolovskou) hodnotu FALSE. O tom, jak každá z funkcí pracuje, se píše na příslušných stránkách manuálu.

Existují také funkce se složitější informací o verzi PHP. Vezměme si jako příklad funkci html_entity_decode():

      (PHP 4 >= 4.3.0, PHP 5)

To znamená, že tato funkce nebyla dostupná v PHP 3, a je dostupná jen ve vydaných verzích od PHP 4.3.0.

Předcházející | Nahoru | Další
O uživatelských poznámkách | Domů | Verze PHP dokumentované v tomto manuálu


Verze PHP dokumentované v tomto manuálu

Tato dokumentace obsahuje informace o PHP 4 i PHP 5, s poznámkami o migraci a kompatibilitě ohledně PHP 3. Chování, parametr, návratová hodnota a další změny mezi různými verzemi PHP jsou dokumentovány v poznámkách a vloženém textu v manuálu.

Můžete najít kusy dokumentace pro CVS verzi PHP, což vždycky znamená nejpozdější vývojovou verzi dostupnou přes systém správy verzí CVS nebo jako » snapshot Nejste-li vývojář samotného PHP a netrpíte posedlostí používat nejpozdější vývojovou verzi PHP, možnosti označené jako "dostupné v CVS" pro vás nejsou dostupné. Tyto možnosti však budou pravděpodobně dostupné v příští stabilní verzi PHP. Pro stažení CVS verze se podívejte na stránku o » anonymním CVS přístupu.

Také můžete narazit na dokumentaci pro verzi PHP, která ještě nebyla vydána (něco jako PHP 5.0.0, když poslední stabilní verze je 4.3.x). Většinou to není chyba v dokumentaci. Často se přidává vysvětlení možností, které v aktuální vydané verzi nejsou dostupné, ale budou dostupné ve známe budoucí verzi PHP. Do PHP se nové vlastnosti přidávají typicky pouze ve "velkých" (major) verzích, jinak se pouze opravují chyby. Ve formátu A.B.C znamená nová major verze zvýšení čísla A nebo B, kdežto minor verze zvyšuje číslo C. Je např. neobvyklé, aby byla vlastnost dokumenentována jako dostupná od verze PHP x.1.x, když poslední verze je x.0.x. Nezapomeňte také, že manuál je psán v přítomném, nikoli budoucím čase.

Předcházející | Nahoru | Další
Jak číst definice funkcí (prototypy) | Domů | Jak najít více informací o PHP


Jak najít více informací o PHP

Tento manuál se nepokouší poskytovat instrukce o obecných programovacích technikách. Úplně čerstvému programátorovi, nebo stále ještě začátečníkovi, se může zdát obtížné naučit se programovat v PHP pouze podle tohoto manuálu. Proto je lepší místo toho hledat text více orientovaný na začátečníky. Nebo knihu, viz také seznam knih týkajících se PHP: » http://www.php.net/books.php.

Existuje mnoho aktivních e-mailových diskusních skupin pro diskusi o všech aspektech programování v PHP. Při problémech zvažte použití těchto diskusních skupin. Možnosti podpory, včetně diskusních skupin, jsou k dispozici na » http://www.php.net/support.php. Dále, na » http://www.php.net/links.php je seznam stránek zaměřených na články, fóra a galerie kódu pro PHP.

Předcházející | Nahoru | Další
Verze PHP dokumentované v tomto manuálu | Domů | Jak pomoci zlepšit dokumentaci


Jak pomoci zlepšit dokumentaci

Jsou dvě cesty, jak můžete pomoci zlepšit tuto dokumentaci.

Pokud v manuálu najdete chyby (v kterémkoli jazyce), oznamte je prosím pomocí bug systému na » http://bugs.php.net/. Klasifikujte chybu jako "Documentation Problem". Můžete také poslat problémy spojené s konkrétními manuálovými formáty zde. Všechny problémy spojené s dokumentací, včetně těch souvisejících s formáty manuálu, by se měly posílat jako chybová hlášení.

Poznámka: Nezneužívejte prosím bug systém odesíláním žádostí o pomoc. Použijte namísto toho některou z mnoha » možností podpory.

Při přidávání poznámek mohou uživatelé poskytnout dodatečné příklady a vysvětlení pro ostatní čtenáře. Avšak neposílejte prosím pomocí tohoto anotačního systému hlášení o chybách. O anotacích se můžete více dozvědět v části 'O uživatelských poznámkách'.

PHP manuál se překládá do mnoha jazyků. Umíte-li angličtinu a nějaký cizí jazyk, můžete také pomoci zlepšit manuál prací v překladatelském týmu. Chcete-li začí nový překlad nebo pomoci s překladovým projektem, čtěte prosím » http://doc.php.net/php/dochowto/.

Dokumentační projekt PHP má IRC kanál, kde se zdržuje mnoho autorů manuálu. Navštivte #phpdoc na irc.freenode.net a diskutujte o cestách, jak zlepšit dokumentaci PHP.

Předcházející | Nahoru | Další
Jak najít více informací o PHP | Domů | Jak generujeme formáty


Jak generujeme formáty

Tento manuál je napsán v XML s použitím » DocBook XML DTD, » DSSSL (Document Style and Semantics Specification Language) pro formátování a experimentálně » XSLT (Extensible Stylesheet Language Transformations) pro údržbu a formátování.

Použití XML jako zdrojového formátu dává možnost generovat mnoho výstupních formátů ze zdrojových souborů a udržovat pouze jediný zdrojový dokument pro všechny formáty. Nástroji použitými pro formátování HTML a TeX verzí jsou » Jade, jehož autorem je » James Clark, a » The Modular DocBook Stylesheets kde je autorem » Norman Walsh. Používáme » Microsoft HTML Help Workshop ke generování formátu Windows HTML Help a, samozřejmě, PHP samotné pro dodatečné konverze a formátování.

Manuál se generuje v různých jazycích a formátech, viz » http://www.php.net/docs.php. Zdrojové kódy v XML lze stáhnout z CVS a prohlížet na » http://cvs.php.net/. Dokumentace je uložena v modulu phpdoc (česká v phpdoc-cs).

Předcházející | Nahoru | Další
Jak pomoci zlepšit dokumentaci | Domů | Překlady


Překlady

Manuál PHP je dostupný nejen v různých formátech, ale také v různých jazycích. Text manuálu se píše nejdřív v angličtině, a potom týmy lidí po celém světě dávají péči jeho překládání do svých rodných jazyků. Nebyla-li nějaká specifická část nebo kapitola dosud přeložena, sestavovací systém manuálu použije anglickou verzi.

Lidé, kteří dokumentaci překládají, vycházejí z XML zdrojového kódu dostupného na » http://cvs.php.net/ a překládají ho do svého mateřského jazyka. Nepoužívají generované verze (jako HTML nebo holý text). Je to sestavovací systém, který zajistí konverzi z XML do lidsky čitelných formátů.

Poznámka: Chcete-li pomoci překládat dokumentaci to vašeho rodného jazyka, vejděte prosím v kontakt s překladatelským/dokumentačním týmem tak, že si přihlásíte odběr zpráv z konference phpdoc: pošlete prázdnou zprávu na » phpdoc-subscribe@lists.php.net. Adresa konference je phpdoc@lists.php.net. Pošlete zprávu, ve které uvedete, že se zajímáte o překládání manuálu do nějakého jazyka a někdo vám odpoví. Pomůže vám se začátkem nového překladu nebo kontaktovat již aktivní dokumentační tým pro zvolený jazyk.

V tuto chvíli je manuál dostupný, ať už plně či částečně, v těchto jazycích: brazilská portugalština, čeština, čínština (zjednodušená), čínština (Hong Kong Cantonese), čínština (tradiční), holandština, finština, francouzština, němčina, řečtina, hebrejština, maďarština, italština, japonština, korejština, polština, rumunština, ruština, slovenština, slovinština, španělština, švédština a turečtina.

Všechny lze stáhnout zde: » http://www.php.net/docs.php.

Předcházející | Nahoru | Další
Jak generujeme formáty | Domů | V. Open Publication License


Příloha V. Open Publication License

Obsah

I. POŽADAVKY NEMODIFIKOVANÉ I MODIFIKOVANÉ VERZE
II. AUTORSKÁ PRÁVA
III. ROZSAH LICENCE
IV. POŽADAVKY NA MODIFIKOVANÉ PRÁCE
V. PRAKTICKÁ DOPORUČENÍ
VI. MOŽNOSTI LICENCE

v1.0, 8. 6. 1999

I. POŽADAVKY NEMODIFIKOVANÉ I MODIFIKOVANÉ VERZE

Práce "Open Publication" smějí být reprodukovány a šířeny jako celek nebo po částech, na jakémkoli fyzickém nebo elektronickém médiu, za podmínky, že jsou dodržena pravidla této licence a že je tato licence nebo přímý odkaz na ni (s jakýmikoli možnostmi zvolenými autorem (autory) a/nebo vydavatelem) zobrazena v reprodukci.

Správná forma přímého odkazování je tato:

Copyright (c) <rok> by <jméno autora nebo pověřené osoby>. Tento materiál smí být šířen pouze podle pravidel a podmínek stanovených v Open Publication License, vX.Y nebo pozdější (nejnovější verze je aktuálně k dispozici na » http://www.opencontent.org/openpub/

Za odkazem musí bezprostředně následovat možnosti zvolené autorem (autory) a/nebo vydavatelem dokumentu (viz oddíl VI). Komerční redistribuce materiálu licencovaného pod Open Publication License je povolena. Jakákoli publikace ve standardní (tištěné, papírové) knize vyžaduje citaci originálního vydavatele a autora. Jména vydavatele a autora budou vytištěna na všech vnějších stranách knihy. Vytištěné jméno vydavatele bude stejně velké jako název práce a bude uveden údaj o vlastnictví práv v souvislosti s prací.

Předcházející | Nahoru | Další
Překlady | Domů | II. AUTORSKÁ PRÁVA


II. AUTORSKÁ PRÁVA

Autorská práva ke každému dílu krytému Open Publication License jsou vlastněna autorem (autory) nebo pověřenou osobou.

Předcházející | Nahoru | Další
V. Open Publication License | Domů | III. ROZSAH LICENCE


III. ROZSAH LICENCE

Následující podmínky platí pro všechny práce pod Open Publication License, není-li v dokumentu uvedeno jinak.

Pouhá agregace (sdružování) prací pod Open Publication License nebo jejich částí s jinými pracemi nebo programy na stejném médiu nevyvolá účinek této licence na tyto ostatní práce. Souborná práce musí obsahovat informaci o zahrnutí materiálu krytého Open Publication License a odpovídající informacu o autorských právech.

ODDĚLITELNOST. Není-li některá část této licence vynutitelná v některé jurisdikci, zbývající části licence zůstávají v platnosti.

ŽÁDNÉ ZÁRUKY. Práce pod Open Publication License jsou licencovány a poskytovány "tak, jak jsou" bez jakékoli záruky, výslovné ani vyplývající, včetně, nikoli však pouze, vyplývajících záruk obchodovatelnosti nebo vhodnosti k určitému účelu, anebo záruky vyloučení zásahu do cizích práv.

Předcházející | Nahoru | Další
II. AUTORSKÁ PRÁVA | Domů | IV. POŽADAVKY NA MODIFIKOVANÉ PRÁCE


IV. POŽADAVKY NA MODIFIKOVANÉ PRÁCE

Všechny modifikované verze dokumentů krytých touto licencí, včetně překladů, antologií, kompilací a částečných dokumnetů, musí splňovat následující požadavky:

  1. Modifikovaná verze musí být jako taková označena.
  2. Osoba provádějící modifikaci musí být identifikována a modifikace datována.
  3. Souhlas originálního autora a vydavatele (lze-li použít) musí být zajištěn v souladu s normálními akademickými citačními praktikami.
  4. Musí být identifikováno umístění originálního nemodifikovaného dokumentu.
  5. Jméno originálního autora (autorů) nelze použít ve vztahu k provedeným změnám v dokumentu (ve smyslu "souhlas autora s obsahem modifikace") bez svolení tohoto autora.

Předcházející | Nahoru | Další
III. ROZSAH LICENCE | Domů | V. PRAKTICKÁ DOPORUČENÍ


V. PRAKTICKÁ DOPORUČENÍ

K požadavkům této licence je navíc vyžadaváno a vřele doporučováno pro redistributory:

  1. Šíříte-li práce kryté Open Publication License jako výtisky nebi CD-ROM, zašlete e-mailové oznámení autorům obsahu, který šíříte, alespoň 30 dní před uzavřením vašeho rukopisu nebo média, abyste dali autorům čas poskytnout aktualizované dokumenty. Toto oznámení by mělo popisovat modifikace dokumentu (pokud k nim došlo).
  2. Všechny podstatné modifikace (včetně mazání) je třeba jasně označit v dokumentu nebo popsat v příloze dokumentu.
  3. Konečně, i když to není pod touto licencí povinné, je vhodné nabídnout autorům zdarma kopii výtisku nebo CD-ROM s prací krytou Open Publication License.

Předcházející | Nahoru | Další
IV. POŽADAVKY NA MODIFIKOVANÉ PRÁCE | Domů | VI. MOŽNOSTI LICENCE


VI. MOŽNOSTI LICENCE

Autor (autoři) a/nebo vydavatel mohou zvolit jisté možnosti nabízené Open Publication License přidáním určitého dodatku k licenci. Tyto volby jsou nedílnou součástí exempláře licence a musí být přiloženy k licenci (nebo odkazu na ni) v odvozených pracích.

A. Distribuce podstatně modifikovaných verzí bez explicitního svolení autora (autorů) je zakázána. "Podstatná modifikace" je definována jako změna sémantického obsahu dokumentu, nezahrnuje pouhé změny formátu ani typografické opravy.

V tomto případě přidejte k odkazu na licenci nebo k její kopii frázi 'Distribuce podstatně modifikovaných verzí tohoto dokumentu je bez explicitního souhlasu vlastníka autorských práv zakázána'.

B. Distribuovat jakoukoli publikaci této práce nebo prací odvozených, ať již jako celek nebo některé části, ve formě standardní (papírové) knihy ke komerčním účelům, je bez předchozího získání souhlasu vlastníka autorských práv zakázáno.

V tomto případě přidejte k odkazu na licenci nebo k její kopii frázi 'Distribuce této práce nebo prací odvozených, ve formě standardní (papírové) knihy, je bez přechozího získání souhlasu vlastníka autorských práv zakázána.'

Důležité upozornění: Tento překlad je pouze pro informaci a nemá žádnou právní váhu. Právní účinky má pouze anglický originál licenčních podmínek a případné autorizované překlady do jiných jazyků (včetně češtiny).

Předcházející | Nahoru | Další
V. PRAKTICKÁ DOPORUČENÍ | Domů | W. Rejstřík funkcí


Příloha W. Rejstřík funkcí

Obsah

Rejstřík funkcí

Rejstřík funkcí

_

__halt_compiler()

A

abs()
acos()
acosh()
addcslashes()
addslashes()
aggregate()
aggregate_info()
aggregate_methods()
aggregate_methods_by_list()
aggregate_methods_by_regexp()
aggregate_properties()
aggregate_properties_by_list()
aggregate_properties_by_regexp()
aggregation_info()
apache_child_terminate()
apache_get_modules()
apache_get_version()
apache_getenv()
apache_lookup_uri()
apache_note()
apache_request_headers()
apache_reset_timeout()
apache_response_headers()
apache_setenv()
apc_add()
apc_cache_info()
apc_clear_cache()
apc_compile_file()
apc_define_constants()
apc_delete()
apc_fetch()
apc_load_constants()
apc_sma_info()
apc_store()
apd_breakpoint()
apd_callstack()
apd_clunk()
apd_continue()
apd_croak()
apd_dump_function_table()
apd_dump_persistent_resources()
apd_dump_regular_resources()
apd_echo()
apd_get_active_symbols()
apd_set_pprof_trace()
apd_set_session()
apd_set_session_trace()
apd_set_socket_session_trace()
array()
array_change_key_case()
array_chunk()
array_combine()
array_count_values()
array_diff()
array_diff_assoc()
array_diff_key()
array_diff_uassoc()
array_diff_ukey()
array_fill()
array_fill_keys()
array_filter()
array_flip()
array_intersect()
array_intersect_assoc()
array_intersect_key()
array_intersect_uassoc()
array_intersect_ukey()
array_key_exists()
array_keys()
array_map()
array_merge()
array_merge_recursive()
array_multisort()
array_pad()
array_pop()
array_product()
array_push()
array_rand()
array_reduce()
array_reverse()
array_search()
array_shift()
array_slice()
array_splice()
array_sum()
array_udiff()
array_udiff_assoc()
array_udiff_uassoc()
array_uintersect()
array_uintersect_assoc()
array_uintersect_uassoc()
array_unique()
array_unshift()
array_values()
array_walk()
array_walk_recursive()
ArrayIterator::current()
ArrayIterator::key()
ArrayIterator::next()
ArrayIterator::rewind()
ArrayIterator::seek()
ArrayIterator::valid()
ArrayObject::__construct()
ArrayObject::append()
ArrayObject::count()
ArrayObject::getIterator()
ArrayObject::offsetExists()
ArrayObject::offsetGet()
ArrayObject::offsetSet()
ArrayObject::offsetUnset()
arsort()
ascii2ebcdic()
asin()
asinh()
asort()
aspell_check()
aspell_check_raw()
aspell_new()
aspell_suggest()
assert()
assert_options()
atan()
atan2()
atanh()

B

base64_decode()
base64_encode()
base_convert()
basename()
bbcode_add_element()
bbcode_create()
bbcode_destroy()
bbcode_parse()
bcadd()
bccomp()
bcdiv()
bcmod()
bcmul()
bcompiler_load()
bcompiler_load_exe()
bcompiler_parse_class()
bcompiler_read()
bcompiler_write_class()
bcompiler_write_constant()
bcompiler_write_exe_footer()
bcompiler_write_file()
bcompiler_write_footer()
bcompiler_write_function()
bcompiler_write_functions_from_file()
bcompiler_write_header()
bcompiler_write_included_filename()
bcpow()
bcpowmod()
bcscale()
bcsqrt()
bcsub()
bin2hex()
bind_textdomain_codeset()
bindec()
bindtextdomain()
bzclose()
bzcompress()
bzdecompress()
bzerrno()
bzerror()
bzerrstr()
bzflush()
bzopen()
bzread()
bzwrite()

C

CachingIterator::__toString()
CachingIterator::hasNext()
CachingIterator::next()
CachingIterator::rewind()
CachingIterator::valid()
CachingRecursiveIterator::getChildren()
CachingRecursiveIterator::hasChildren()
cal_days_in_month()
cal_from_jd()
cal_info()
cal_to_jd()
call_user_func()
call_user_func_array()
call_user_method()
call_user_method_array()
ccvs_add()
ccvs_auth()
ccvs_command()
ccvs_count()
ccvs_delete()
ccvs_done()
ccvs_init()
ccvs_lookup()
ccvs_new()
ccvs_report()
ccvs_return()
ccvs_reverse()
ccvs_sale()
ccvs_status()
ccvs_textvalue()
ccvs_void()
ceil()
chdir()
checkdate()
checkdnsrr()
chgrp()
chmod()
chop()
chown()
chr()
chroot()
chunk_split()
class_exists()
class_implements()
class_parents()
classkit_import()
classkit_method_add()
classkit_method_copy()
classkit_method_redefine()
classkit_method_remove()
classkit_method_rename()
clearstatcache()
closedir()
closelog()
com()
com_addref()
com_create_guid()
com_event_sink()
com_get()
com_get_active_object()
com_invoke()
com_isenum()
com_load()
com_load_typelib()
com_message_pump()
com_print_typeinfo()
com_propget()
com_propput()
com_propset()
com_release()
com_set()
compact()
configuration()
connection_aborted()
connection_status()
connection_timeout()
constant()
constants()
constants()
constants()
convert_cyr_string()
convert_uudecode()
convert_uuencode()
copy()
cos()
cosh()
count()
count_chars()
cpdf_add_annotation()
cpdf_add_outline()
cpdf_arc()
cpdf_begin_text()
cpdf_circle()
cpdf_clip()
cpdf_close()
cpdf_closepath()
cpdf_closepath_fill_stroke()
cpdf_closepath_stroke()
cpdf_continue_text()
cpdf_curveto()
cpdf_end_text()
cpdf_fill()
cpdf_fill_stroke()
cpdf_finalize()
cpdf_finalize_page()
cpdf_global_set_document_limits()
cpdf_import_jpeg()
cpdf_lineto()
cpdf_moveto()
cpdf_newpath()
cpdf_open()
cpdf_output_buffer()
cpdf_page_init()
cpdf_place_inline_image()
cpdf_rect()
cpdf_restore()
cpdf_rlineto()
cpdf_rmoveto()
cpdf_rotate()
cpdf_rotate_text()
cpdf_save()
cpdf_save_to_file()
cpdf_scale()
cpdf_set_action_url()
cpdf_set_char_spacing()
cpdf_set_creator()
cpdf_set_current_page()
cpdf_set_font()
cpdf_set_font_directories()
cpdf_set_font_map_file()
cpdf_set_horiz_scaling()
cpdf_set_keywords()
cpdf_set_leading()
cpdf_set_page_animation()
cpdf_set_subject()
cpdf_set_text_matrix()
cpdf_set_text_pos()
cpdf_set_text_rendering()
cpdf_set_text_rise()
cpdf_set_title()
cpdf_set_viewer_preferences()
cpdf_set_word_spacing()
cpdf_setdash()
cpdf_setflat()
cpdf_setgray()
cpdf_setgray_fill()
cpdf_setgray_stroke()
cpdf_setlinecap()
cpdf_setlinejoin()
cpdf_setlinewidth()
cpdf_setmiterlimit()
cpdf_setrgbcolor()
cpdf_setrgbcolor_fill()
cpdf_setrgbcolor_stroke()
cpdf_show()
cpdf_show_xy()
cpdf_stringwidth()
cpdf_stroke()
cpdf_text()
cpdf_translate()
crack_check()
crack_closedict()
crack_getlastmessage()
crack_opendict()
crc32()
create_function()
crypt()
ctype_alnum()
ctype_alpha()
ctype_cntrl()
ctype_digit()
ctype_graph()
ctype_lower()
ctype_print()
ctype_punct()
ctype_space()
ctype_upper()
ctype_xdigit()
curl_close()
curl_copy_handle()
curl_errno()
curl_error()
curl_exec()
curl_getinfo()
curl_init()
curl_multi_add_handle()
curl_multi_close()
curl_multi_exec()
curl_multi_getcontent()
curl_multi_info_read()
curl_multi_init()
curl_multi_remove_handle()
curl_multi_select()
curl_setopt()
curl_setopt_array()
curl_version()
current()
cybercash_base64_decode()
cybercash_base64_encode()
cybercash_decr()
cybercash_encr()
cybermut_creerformulairecm()
cybermut_creerreponsecm()
cybermut_testmac()
cyrus_authenticate()
cyrus_bind()
cyrus_close()
cyrus_connect()
cyrus_query()
cyrus_unbind()

D

date()
date_create()
date_date_set()
date_default_timezone_get()
date_default_timezone_set()
date_format()
date_isodate_set()
date_modify()
date_offset_get()
date_parse()
date_sun_info()
date_sunrise()
date_sunset()
date_time_set()
date_timezone_get()
date_timezone_set()
db2_autocommit()
db2_bind_param()
db2_client_info()
db2_close()
db2_column_privileges()
db2_columns()
db2_commit()
db2_conn_error()
db2_conn_errormsg()
db2_connect()
db2_cursor_type()
db2_escape_string()
db2_exec()
db2_execute()
db2_fetch_array()
db2_fetch_assoc()
db2_fetch_both()
db2_fetch_object()
db2_fetch_row()
db2_field_display_size()
db2_field_name()
db2_field_num()
db2_field_precision()
db2_field_scale()
db2_field_type()
db2_field_width()
db2_foreign_keys()
db2_free_result()
db2_free_stmt()
db2_get_option()
db2_lob_read()
db2_next_result()
db2_num_fields()
db2_num_rows()
db2_pconnect()
db2_prepare()
db2_primary_keys()
db2_procedure_columns()
db2_procedures()
db2_result()
db2_rollback()
db2_server_info()
db2_set_option()
db2_special_columns()
db2_statistics()
db2_stmt_error()
db2_stmt_errormsg()
db2_table_privileges()
db2_tables()
dba_close()
dba_delete()
dba_exists()
dba_fetch()
dba_firstkey()
dba_handlers()
dba_insert()
dba_key_split()
dba_list()
dba_nextkey()
dba_open()
dba_optimize()
dba_popen()
dba_replace()
dba_sync()
dbase_add_record()
dbase_close()
dbase_create()
dbase_delete_record()
dbase_get_header_info()
dbase_get_record()
dbase_get_record_with_names()
dbase_numfields()
dbase_numrecords()
dbase_open()
dbase_pack()
dbase_replace_record()
dblist()
dbmclose()
dbmdelete()
dbmexists()
dbmfetch()
dbmfirstkey()
dbminsert()
dbmnextkey()
dbmopen()
dbmreplace()
dbplus_add()
dbplus_aql()
dbplus_chdir()
dbplus_close()
dbplus_curr()
dbplus_errcode()
dbplus_errno()
dbplus_find()
dbplus_first()
dbplus_flush()
dbplus_freealllocks()
dbplus_freelock()
dbplus_freerlocks()
dbplus_getlock()
dbplus_getunique()
dbplus_info()
dbplus_last()
dbplus_lockrel()
dbplus_next()
dbplus_open()
dbplus_prev()
dbplus_rchperm()
dbplus_rcreate()
dbplus_rcrtexact()
dbplus_rcrtlike()
dbplus_resolve()
dbplus_restorepos()
dbplus_rkeys()
dbplus_ropen()
dbplus_rquery()
dbplus_rrename()
dbplus_rsecindex()
dbplus_runlink()
dbplus_rzap()
dbplus_savepos()
dbplus_setindex()
dbplus_setindexbynumber()
dbplus_sql()
dbplus_tcl()
dbplus_tremove()
dbplus_undo()
dbplus_undoprepare()
dbplus_unlockrel()
dbplus_unselect()
dbplus_update()
dbplus_xlockrel()
dbplus_xunlockrel()
dbx_close()
dbx_compare()
dbx_connect()
dbx_error()
dbx_escape_string()
dbx_fetch_row()
dbx_query()
dbx_sort()
dcgettext()
dcngettext()
deaggregate()
debug_backtrace()
debug_print_backtrace()
debug_zval_dump()
debugger_off()
debugger_on()
decbin()
dechex()
decoct()
define()
define_syslog_variables()
defined()
deg2rad()
delete()
dgettext()
die()
dio_close()
dio_fcntl()
dio_open()
dio_read()
dio_seek()
dio_stat()
dio_tcsetattr()
dio_truncate()
dio_write()
dir()
DirectoryIterator::__construct()
DirectoryIterator::current()
DirectoryIterator::getATime()
DirectoryIterator::getCTime()
DirectoryIterator::getFilename()
DirectoryIterator::getGroup()
DirectoryIterator::getInode()
DirectoryIterator::getMTime()
DirectoryIterator::getOwner()
DirectoryIterator::getPath()
DirectoryIterator::getPathname()
DirectoryIterator::getPerms()
DirectoryIterator::getSize()
DirectoryIterator::getType()
DirectoryIterator::isDir()
DirectoryIterator::isDot()
DirectoryIterator::isExecutable()
DirectoryIterator::isFile()
DirectoryIterator::isLink()
DirectoryIterator::isReadable()
DirectoryIterator::isWritable()
DirectoryIterator::key()
DirectoryIterator::next()
DirectoryIterator::rewind()
DirectoryIterator::valid()
dirname()
disk_free_space()
disk_total_space()
diskfreespace()
dl()
dngettext()
dns_check_record()
dns_get_mx()
dns_get_record()
dom_import_simplexml()
DOMAttr->__construct()()
DOMAttr->isId()()
DomAttribute->name()
DomAttribute->set_value()
DomAttribute->specified()
DomAttribute->value()
DOMCharacterData->appendData()()
DOMCharacterData->deleteData()()
DOMCharacterData->insertData()()
DOMCharacterData->replaceData()()
DOMCharacterData->substringData()()
DOMComment->__construct()()
DOMDocument->__construct()()
DomDocument->add_root()
DomDocument->create_attribute()
DomDocument->create_cdata_section()
DomDocument->create_comment()
DomDocument->create_element()
DomDocument->create_element_ns()
DomDocument->create_entity_reference()
DomDocument->create_processing_instruction()
DomDocument->create_text_node()
DOMDocument->createAttribute()()
DOMDocument->createAttributeNS()()
DOMDocument->createCDATASection()()
DOMDocument->createComment()()
DOMDocument->createDocumentFragment()()
DOMDocument->createElement()()
DOMDocument->createElementNS()()
DOMDocument->createEntityReference()()
DOMDocument->createProcessingInstruction()()
DOMDocument->createTextNode()()
DomDocument->doctype()
DomDocument->document_element()
DomDocument->dump_file()
DomDocument->dump_mem()
DomDocument->get_element_by_id()
DomDocument->get_elements_by_tagname()
DOMDocument->getElementById()()
DOMDocument->getElementsByTagName()()
DOMDocument->getElementsByTagNameNS()()
DomDocument->html_dump_mem()
DOMDocument->importNode()()
DOMDocument->load()()
DOMDocument->loadHTML()()
DOMDocument->loadHTMLFile()()
DOMDocument->loadXML()()
DOMDocument->normalizeDocument()()
DOMDocument->registerNodeClass()()
DOMDocument->relaxNGValidate()()
DOMDocument->relaxNGValidateSource()()
DOMDocument->save()()
DOMDocument->saveHTML()()
DOMDocument->saveHTMLFile()()
DOMDocument->saveXML()()
DOMDocument->schemaValidate()()
DOMDocument->schemaValidateSource()()
DOMDocument->validate()()
DomDocument->xinclude()
DOMDocument->xinclude()()
DOMDocumentFragment->appendXML()()
DomDocumentType->entities()()
DomDocumentType->internal_subset()()
DomDocumentType->name()()
DomDocumentType->notations()()
DomDocumentType->public_id()()
DomDocumentType->system_id()()
DOMElement->__construct()()
DomElement->get_attribute()()
DomElement->get_attribute_node()()
DomElement->get_elements_by_tagname()()
DOMElement->getAttribute()()
DOMElement->getAttributeNode()()
DOMElement->getAttributeNodeNS()()
DOMElement->getAttributeNS()()
DOMElement->getElementsByTagName()()
DOMElement->getElementsByTagNameNS()()
DomElement->has_attribute()()
DOMElement->hasAttribute()()
DOMElement->hasAttributeNS()()
DomElement->remove_attribute()()
DOMElement->removeAttribute()()
DOMElement->removeAttributeNode()()
DOMElement->removeAttributeNS()()
DomElement->set_attribute()()
DomElement->set_attribute_node()()
DOMElement->setAttribute()()
DOMElement->setAttributeNode()()
DOMElement->setAttributeNodeNS()()
DOMElement->setAttributeNS()()
DOMElement->setIdAttribute()()
DOMElement->setIdAttributeNode()()
DOMElement->setIdAttributeNS()()
DomElement->tagname()()
DOMEntityReference->__construct()()
DOMImplementation->__construct()()
DOMImplementation->createDocument()()
DOMImplementation->createDocumentType()()
DOMImplementation->hasFeature()()
DOMNamedNodeMap->getNamedItem()()
DOMNamedNodeMap->getNamedItemNS()()
DOMNamedNodeMap->item()()
DomNode->add_namespace()
DomNode->append_child()
DomNode->append_sibling()
DOMNode->appendChild()()
DomNode->attributes()
DomNode->child_nodes()
DomNode->clone_node()
DOMNode->cloneNode()()
DomNode->dump_node()
DomNode->first_child()
DomNode->get_content()
DomNode->has_attributes()
DomNode->has_child_nodes()
DOMNode->hasAttributes()()
DOMNode->hasChildNodes()()
DomNode->insert_before()
DOMNode->insertBefore()()
DomNode->is_blank_node()
DOMNode->isDefaultNamespace()()
DOMNode->isSameNode()()
DOMNode->isSupported()()
DomNode->last_child()
DOMNode->lookupNamespaceURI()()
DOMNode->lookupPrefix()()
DomNode->next_sibling()
DomNode->node_name()
DomNode->node_type()
DomNode->node_value()
DOMNode->normalize()()
DomNode->owner_document()
DomNode->parent_node()
DomNode->prefix()
DomNode->previous_sibling()
DomNode->remove_child()
DOMNode->removeChild()()
DomNode->replace_child()
DomNode->replace_node()
DOMNode->replaceChild()()
DomNode->set_content()
DomNode->set_name()
DomNode->set_namespace()
DomNode->unlink_node()
DOMNodelist->item()()
DOMProcessingInstruction->__construct()()
DomProcessingInstruction->data()
DomProcessingInstruction->target()
DOMText->__construct()()
DOMText->isWhitespaceInElementContent()()
DOMText->splitText()()
domxml_new_doc()
domxml_open_file()
domxml_open_mem()
domxml_version()
domxml_xmltree()
domxml_xslt_stylesheet()
domxml_xslt_stylesheet_doc()
domxml_xslt_stylesheet_file()
domxml_xslt_version()
DOMXPath->__construct()()
DOMXPath->evaluate()()
DOMXPath->query()()
DOMXPath->registerNamespace()()
DomXsltStylesheet->process()()
DomXsltStylesheet->result_dump_file()()
DomXsltStylesheet->result_dump_mem()()
dotnet()
dotnet_load()
doubleval()

E

each()
easter_date()
easter_days()
ebcdic2ascii()
echo()
empty()
enchant_broker_describe()
enchant_broker_dict_exists()
enchant_broker_free()
enchant_broker_free_dict()
enchant_broker_get_error()
enchant_broker_init()
enchant_broker_list_dicts()
enchant_broker_request_dict()
enchant_broker_request_pwl_dict()
enchant_broker_set_ordering()
enchant_dict_add_to_personal()
enchant_dict_add_to_session()
enchant_dict_check()
enchant_dict_describe()
enchant_dict_get_error()
enchant_dict_is_in_session()
enchant_dict_quick_check()
enchant_dict_store_replacement()
enchant_dict_suggest()
end()
ereg()
ereg_replace()
eregi()
eregi_replace()
error_get_last()
error_log()
error_reporting()
escapeshellarg()
escapeshellcmd()
eval()
exec()
exif_imagetype()
exif_read_data()
exif_tagname()
exif_thumbnail()
exit()
exp()
expect_expectl()
expect_popen()
explode()
expm1()
extension_loaded()
extract()
ezmlm_hash()

F

fam_cancel_monitor()
fam_close()
fam_monitor_collection()
fam_monitor_directory()
fam_monitor_file()
fam_next_event()
fam_open()
fam_pending()
fam_resume_monitor()
fam_suspend_monitor()
fbsql_affected_rows()
fbsql_autocommit()
fbsql_blob_size()
fbsql_change_user()
fbsql_clob_size()
fbsql_close()
fbsql_commit()
fbsql_connect()
fbsql_create_blob()
fbsql_create_clob()
fbsql_create_db()
fbsql_data_seek()
fbsql_database()
fbsql_database_password()
fbsql_db_query()
fbsql_db_status()
fbsql_drop_db()
fbsql_errno()
fbsql_error()
fbsql_fetch_array()
fbsql_fetch_assoc()
fbsql_fetch_field()
fbsql_fetch_lengths()
fbsql_fetch_object()
fbsql_fetch_row()
fbsql_field_flags()
fbsql_field_len()
fbsql_field_name()
fbsql_field_seek()
fbsql_field_table()
fbsql_field_type()
fbsql_free_result()
fbsql_get_autostart_info()
fbsql_hostname()
fbsql_insert_id()
fbsql_list_dbs()
fbsql_list_fields()
fbsql_list_tables()
fbsql_next_result()
fbsql_num_fields()
fbsql_num_rows()
fbsql_password()
fbsql_pconnect()
fbsql_query()
fbsql_read_blob()
fbsql_read_clob()
fbsql_result()
fbsql_rollback()
fbsql_rows_fetched()
fbsql_select_db()
fbsql_set_characterset()
fbsql_set_lob_mode()
fbsql_set_password()
fbsql_set_transaction()
fbsql_start_db()
fbsql_stop_db()
fbsql_table_name()
fbsql_tablename()
fbsql_username()
fbsql_warnings()
fclose()
fdf_add_doc_javascript()
fdf_add_template()
fdf_close()
fdf_create()
fdf_enum_values()
fdf_errno()
fdf_error()
fdf_get_ap()
fdf_get_attachment()
fdf_get_encoding()
fdf_get_file()
fdf_get_flags()
fdf_get_opt()
fdf_get_status()
fdf_get_value()
fdf_get_version()
fdf_header()
fdf_next_field_name()
fdf_open()
fdf_open_string()
fdf_remove_item()
fdf_save()
fdf_save_string()
fdf_set_ap()
fdf_set_encoding()
fdf_set_file()
fdf_set_flags()
fdf_set_javascript_action()
fdf_set_on_import_javascript()
fdf_set_opt()
fdf_set_status()
fdf_set_submit_form_action()
fdf_set_target_frame()
fdf_set_value()
fdf_set_version()
feof()
fflush()
fgetc()
fgetcsv()
fgets()
fgetss()
file()
file_exists()
file_get_contents()
file_put_contents()
fileatime()
filectime()
filegroup()
fileinode()
filemtime()
fileowner()
fileperms()
filepro()
filepro_fieldcount()
filepro_fieldname()
filepro_fieldtype()
filepro_fieldwidth()
filepro_retrieve()
filepro_rowcount()
filesize()
filetype()
filter_has_var()
filter_id()
filter_input()
filter_input_array()
filter_list()
filter_var()
filter_var_array()
FilterIterator::current()
FilterIterator::getInnerIterator()
FilterIterator::key()
FilterIterator::next()
FilterIterator::rewind()
FilterIterator::valid()
finfo->__construct()()
finfo_buffer()
finfo_close()
finfo_file()
finfo_open()
finfo_set_flags()
floatval()
flock()
floor()
flush()
fmod()
fnmatch()
fopen()
fpassthru()
fprintf()
fputcsv()
fputs()
fread()
frenchtojd()
fribidi_log2vis()
fscanf()
fseek()
fsockopen()
fstat()
ftell()
ftok()
ftp_alloc()
ftp_cdup()
ftp_chdir()
ftp_chmod()
ftp_close()
ftp_connect()
ftp_delete()
ftp_exec()
ftp_fget()
ftp_fput()
ftp_get()
ftp_get_option()
ftp_login()
ftp_mdtm()
ftp_mkdir()
ftp_nb_continue()
ftp_nb_fget()
ftp_nb_fput()
ftp_nb_get()
ftp_nb_put()
ftp_nlist()
ftp_pasv()
ftp_put()
ftp_pwd()
ftp_quit()
ftp_raw()
ftp_rawlist()
ftp_rename()
ftp_rmdir()
ftp_set_option()
ftp_site()
ftp_size()
ftp_ssl_connect()
ftp_systype()
ftruncate()
func_get_arg()
func_get_args()
func_num_args()
function_exists()
fwrite()

G

gd_info()
geoip_country_code3_by_name()
geoip_country_code_by_name()
geoip_country_name_by_name()
geoip_database_info()
geoip_db_avail()
geoip_db_filename()
geoip_db_get_all_info()
geoip_id_by_name()
geoip_org_by_name()
geoip_record_by_name()
geoip_region_by_name()
get_browser()
get_cfg_var()
get_class()
get_class_methods()
get_class_vars()
get_current_user()
get_declared_classes()
get_declared_interfaces()
get_defined_constants()
get_defined_functions()
get_defined_vars()
get_extension_funcs()
get_headers()
get_html_translation_table()
get_include_path()
get_included_files()
get_loaded_extensions()
get_magic_quotes_gpc()
get_magic_quotes_runtime()
get_meta_tags()
get_object_vars()
get_parent_class()
get_required_files()
get_resource_type()
getallheaders()
getcwd()
getdate()
getenv()
gethostbyaddr()
gethostbyname()
gethostbynamel()
getimagesize()
getlastmod()
getmxrr()
getmygid()
getmyinode()
getmypid()
getmyuid()
getopt()
getprotobyname()
getprotobynumber()
getrandmax()
getrusage()
getservbyname()
getservbyport()
gettext()
gettimeofday()
gettype()
glob()
gmdate()
gmmktime()
gmp_abs()
gmp_add()
gmp_and()
gmp_clrbit()
gmp_cmp()
gmp_com()
gmp_div()
gmp_div_q()
gmp_div_qr()
gmp_div_r()
gmp_divexact()
gmp_fact()
gmp_gcd()
gmp_gcdext()
gmp_hamdist()
gmp_init()
gmp_intval()
gmp_invert()
gmp_jacobi()
gmp_legendre()
gmp_mod()
gmp_mul()
gmp_neg()
gmp_nextprime()
gmp_or()
gmp_perfect_square()
gmp_popcount()
gmp_pow()
gmp_powm()
gmp_prob_prime()
gmp_random()
gmp_scan0()
gmp_scan1()
gmp_setbit()
gmp_sign()
gmp_sqrt()
gmp_sqrtrem()
gmp_strval()
gmp_sub()
gmp_testbit()
gmp_xor()
gmstrftime()
gnupg_adddecryptkey()
gnupg_addencryptkey()
gnupg_addsignkey()
gnupg_cleardecryptkeys()
gnupg_clearencryptkeys()
gnupg_clearsignkeys()
gnupg_decrypt()
gnupg_decryptverify()
gnupg_encrypt()
gnupg_encryptsign()
gnupg_export()
gnupg_geterror()
gnupg_getprotocol()
gnupg_import()
gnupg_keyinfo()
gnupg_setarmor()
gnupg_seterrormode()
gnupg_setsignmode()
gnupg_sign()
gnupg_verify()
gopher_parsedir()
gregoriantojd()
gzclose()
gzcompress()
gzdecode()
gzdeflate()
gzencode()
gzeof()
gzfile()
gzgetc()
gzgets()
gzgetss()
gzinflate()
gzopen()
gzpassthru()
gzputs()
gzread()
gzrewind()
gzseek()
gztell()
gzuncompress()
gzwrite()

H

haruannotation()
HaruAnnotation::setBorderStyle()
HaruAnnotation::setHighlightMode()
HaruAnnotation::setIcon()
HaruAnnotation::setOpened()
harudestination()
HaruDestination::setFit()
HaruDestination::setFitB()
HaruDestination::setFitBH()
HaruDestination::setFitBV()
HaruDestination::setFitH()
HaruDestination::setFitR()
HaruDestination::setFitV()
HaruDestination::setXYZ()
harudoc()
HaruDoc::__construct()
HaruDoc::addPage()
HaruDoc::addPageLabel()
HaruDoc::createOutline()
HaruDoc::getCurrentEncoder()
HaruDoc::getCurrentPage()
HaruDoc::getEncoder()
HaruDoc::getFont()
HaruDoc::getInfoAttr()
HaruDoc::getPageLayout()
HaruDoc::getPageMode()
HaruDoc::getStreamSize()
HaruDoc::insertPage()
HaruDoc::loadJPEG()
HaruDoc::loadPNG()
HaruDoc::loadRaw()
HaruDoc::loadTTC()
HaruDoc::loadTTF()
HaruDoc::loadType1()
HaruDoc::output()
HaruDoc::readFromStream()
HaruDoc::resetError()
HaruDoc::resetStream()
HaruDoc::save()
HaruDoc::saveToStream()
HaruDoc::setCompressionMode()
HaruDoc::setCurrentEncoder()
HaruDoc::setEncryptionMode()
HaruDoc::setInfoAttr()
HaruDoc::setInfoDateAttr()
HaruDoc::setOpenAction()
HaruDoc::setPageLayout()
HaruDoc::setPageMode()
HaruDoc::setPagesConfiguration()
HaruDoc::setPassword()
HaruDoc::setPermission()
HaruDoc::useCNSEncodings()
HaruDoc::useCNSFonts()
HaruDoc::useCNTEncodings()
HaruDoc::useCNTFonts()
HaruDoc::useJPEncodings()
HaruDoc::useJPFonts()
HaruDoc::useKREncodings()
HaruDoc::useKRFonts()
haruencoder()
HaruEncoder::getByteType()
HaruEncoder::getType()
HaruEncoder::getUnicode()
HaruEncoder::getWritingMode()
haruexception()
harufont()
HaruFont::getAscent()
HaruFont::getCapHeight()
HaruFont::getDescent()
HaruFont::getEncodingName()
HaruFont::getFontName()
HaruFont::getTextWidth()
HaruFont::getUnicodeWidth()
HaruFont::getXHeight()
HaruFont::measureText()
haruimage()
HaruImage::getBitsPerComponent()
HaruImage::getColorSpace()
HaruImage::getHeight()
HaruImage::getSize()
HaruImage::getWidth()
HaruImage::setColorMask()
HaruImage::setMaskImage()
haruoutline()
HaruOutline::setDestination()
HaruOutline::setOpened()
harupage()
HaruPage::arc()
HaruPage::beginText()
HaruPage::circle()
HaruPage::closePath()
HaruPage::concat()
HaruPage::createDestination()
HaruPage::createLinkAnnotation()
HaruPage::createTextAnnotation()
HaruPage::createURLAnnotation()
HaruPage::curveTo()
HaruPage::curveTo2()
HaruPage::curveTo3()
HaruPage::drawImage()
HaruPage::ellipse()
HaruPage::endPath()
HaruPage::endText()
HaruPage::eofill()
HaruPage::eoFillStroke()
HaruPage::fill()
HaruPage::fillStroke()
HaruPage::getCharSpace()
HaruPage::getCMYKFill()
HaruPage::getCMYKStroke()
HaruPage::getCurrentFont()
HaruPage::getCurrentFontSize()
HaruPage::getCurrentPos()
HaruPage::getCurrentTextPos()
HaruPage::getDash()
HaruPage::getFillingColorSpace()
HaruPage::getFlatness()
HaruPage::getGMode()
HaruPage::getGrayFill()
HaruPage::getGrayStroke()
HaruPage::getHeight()
HaruPage::getHorizontalScaling()
HaruPage::getLineCap()
HaruPage::getLineJoin()
HaruPage::getLineWidth()
HaruPage::getMiterLimit()
HaruPage::getRGBFill()
HaruPage::getRGBStroke()
HaruPage::getStrokingColorSpace()
HaruPage::getTextLeading()
HaruPage::getTextMatrix()
HaruPage::getTextRenderingMode()
HaruPage::getTextRise()
HaruPage::getTextWidth()
HaruPage::getTransMatrix()
HaruPage::getWidth()
HaruPage::getWordSpace()
HaruPage::lineTo()
HaruPage::measureText()
HaruPage::moveTextPos()
HaruPage::moveTo()
HaruPage::moveToNextLine()
HaruPage::rectangle()
HaruPage::setCharSpace()
HaruPage::setCMYKFill()
HaruPage::setCMYKStroke()
HaruPage::setDash()
HaruPage::setFlatness()
HaruPage::setFontAndSize()
HaruPage::setGrayFill()
HaruPage::setGrayStroke()
HaruPage::setHeight()
HaruPage::setHorizontalScaling()
HaruPage::setLineCap()
HaruPage::setLineJoin()
HaruPage::setLineWidth()
HaruPage::setMiterLimit()
HaruPage::setRGBFill()
HaruPage::setRGBStroke()
HaruPage::setRotate()
HaruPage::setSize()
HaruPage::setSlideShow()
HaruPage::setTextLeading()
HaruPage::setTextMatrix()
HaruPage::setTextRenderingMode()
HaruPage::setTextRise()
HaruPage::setWidth()
HaruPage::setWordSpace()
HaruPage::showText()
HaruPage::showTextNextLine()
HaruPage::stroke()
HaruPage::textOut()
HaruPage::textRect()
hash()
hash_algos()
hash_file()
hash_final()
hash_hmac()
hash_hmac_file()
hash_init()
hash_update()
hash_update_file()
hash_update_stream()
header()
headers_list()
headers_sent()
hebrev()
hebrevc()
hexdec()
highlight_file()
highlight_string()
html_entity_decode()
htmlentities()
htmlspecialchars()
htmlspecialchars_decode()
http_build_cookie()
http_build_query()
http_build_str()
http_build_url()
http_cache_etag()
http_cache_last_modified()
http_chunked_decode()
http_date()
http_deflate()
http_get()
http_get_request_body()
http_get_request_body_stream()
http_get_request_headers()
http_head()
http_inflate()
http_match_etag()
http_match_modified()
http_match_request_header()
http_negotiate_charset()
http_negotiate_content_type()
http_negotiate_language()
http_parse_cookie()
http_parse_headers()
http_parse_message()
http_parse_params()
http_persistent_handles_clean()
http_persistent_handles_count()
http_persistent_handles_ident()
http_post_data()
http_post_fields()
http_put_data()
http_put_file()
http_put_stream()
http_redirect()
http_request()
http_request_body_encode()
http_request_method_exists()
http_request_method_name()
http_request_method_register()
http_request_method_unregister()
http_send_content_disposition()
http_send_content_type()
http_send_data()
http_send_file()
http_send_last_modified()
http_send_status()
http_send_stream()
http_support()
http_throttle()
httpdeflatestream()
HttpDeflateStream::__construct()
HttpDeflateStream::factory()
HttpDeflateStream::finish()
HttpDeflateStream::flush()
HttpDeflateStream::update()
httpinflatestream()
HttpInflateStream::__construct()
HttpInflateStream::factory()
HttpInflateStream::finish()
HttpInflateStream::flush()
HttpInflateStream::update()
httpmessage()
HttpMessage::__construct()
HttpMessage::addHeaders()
HttpMessage::detach()
HttpMessage::factory()
HttpMessage::fromEnv()
HttpMessage::fromString()
HttpMessage::getBody()
HttpMessage::getHeader()
HttpMessage::getHeaders()
HttpMessage::getHttpVersion()
HttpMessage::getParentMessage()
HttpMessage::getRequestMethod()
HttpMessage::getRequestUrl()
HttpMessage::getResponseCode()
HttpMessage::getResponseStatus()
HttpMessage::getType()
HttpMessage::guessContentType()
HttpMessage::prepend()
HttpMessage::reverse()
HttpMessage::send()
HttpMessage::setBody()
HttpMessage::setHeaders()
HttpMessage::setHttpVersion()
HttpMessage::setRequestMethod()
HttpMessage::setRequestUrl()
HttpMessage::setResponseCode()
HttpMessage::setResponseStatus()
HttpMessage::setType()
HttpMessage::toMessageTypeObject()
HttpMessage::toString()
httpquerystring()
HttpQueryString::__construct()
HttpQueryString::get()
HttpQueryString::mod()
HttpQueryString::set()
HttpQueryString::singleton()
HttpQueryString::toArray()
HttpQueryString::toString()
HttpQueryString::xlate()
httprequest()
HttpRequest::__construct()
HttpRequest::addCookies()
HttpRequest::addHeaders()
HttpRequest::addPostFields()
HttpRequest::addPostFile()
HttpRequest::addPutData()
HttpRequest::addQueryData()
HttpRequest::addRawPostData()
HttpRequest::addSslOptions()
HttpRequest::clearHistory()
HttpRequest::enableCookies()
HttpRequest::getContentType()
HttpRequest::getCookies()
HttpRequest::getHeaders()
HttpRequest::getHistory()
HttpRequest::getMethod()
HttpRequest::getOptions()
HttpRequest::getPostFields()
HttpRequest::getPostFiles()
HttpRequest::getPutData()
HttpRequest::getPutFile()
HttpRequest::getQueryData()
HttpRequest::getRawPostData()
HttpRequest::getRawRequestMessage()
HttpRequest::getRawResponseMessage()
HttpRequest::getRequestMessage()
HttpRequest::getResponseBody()
HttpRequest::getResponseCode()
HttpRequest::getResponseCookies()
HttpRequest::getResponseData()
HttpRequest::getResponseHeader()
HttpRequest::getResponseInfo()
HttpRequest::getResponseMessage()
HttpRequest::getResponseStatus()
HttpRequest::getSslOptions()
HttpRequest::getUrl()
HttpRequest::resetCookies()
HttpRequest::send()
HttpRequest::setContentType()
HttpRequest::setCookies()
HttpRequest::setHeaders()
HttpRequest::setMethod()
HttpRequest::setOptions()
HttpRequest::setPostFields()
HttpRequest::setPostFiles()
HttpRequest::setPutData()
HttpRequest::setPutFile()
HttpRequest::setQueryData()
HttpRequest::setRawPostData()
HttpRequest::setSslOptions()
HttpRequest::setUrl()
httprequestpool()
HttpRequestPool::__construct()
HttpRequestPool::__destruct()
HttpRequestPool::attach()
HttpRequestPool::detach()
HttpRequestPool::getAttachedRequests()
HttpRequestPool::getFinishedRequests()
HttpRequestPool::reset()
HttpRequestPool::send()
HttpRequestPool::socketPerform()
HttpRequestPool::socketSelect()
httpresponse()
HttpResponse::capture()
HttpResponse::getBufferSize()
HttpResponse::getCache()
HttpResponse::getCacheControl()
HttpResponse::getContentDisposition()
HttpResponse::getContentType()
HttpResponse::getData()
HttpResponse::getETag()
HttpResponse::getFile()
HttpResponse::getGzip()
HttpResponse::getHeader()
HttpResponse::getLastModified()
HttpResponse::getRequestBody()
HttpResponse::getRequestBodyStream()
HttpResponse::getRequestHeaders()
HttpResponse::getStream()
HttpResponse::getThrottleDelay()
HttpResponse::guessContentType()
HttpResponse::redirect()
HttpResponse::send()
HttpResponse::setBufferSize()
HttpResponse::setCache()
HttpResponse::setCacheControl()
HttpResponse::setContentDisposition()
HttpResponse::setContentType()
HttpResponse::setData()
HttpResponse::setETag()
HttpResponse::setFile()
HttpResponse::setGzip()
HttpResponse::setHeader()
HttpResponse::setLastModified()
HttpResponse::setStream()
HttpResponse::setThrottleDelay()
HttpResponse::status()
hw_api->checkin()
hw_api->checkout()
hw_api->children()
hw_api->content()
hw_api->copy()
hw_api->dbstat()
hw_api->dcstat()
hw_api->dstanchors()
hw_api->dstofsrcanchor()
hw_api->find()
hw_api->ftstat()
hw_api->hwstat()
hw_api->identify()
hw_api->info()
hw_api->insert()
hw_api->insertanchor()
hw_api->insertcollection()
hw_api->insertdocument()
hw_api->link()
hw_api->lock()
hw_api->move()
hw_api->object()
hw_api->objectbyanchor()
hw_api->parents()
hw_api->remove()
hw_api->replace()
hw_api->setcommittedversion()
hw_api->srcanchors()
hw_api->srcsofdst()
hw_api->unlock()
hw_api->user()
hw_api->userlist()
hw_api_attribute()
hw_api_attribute->key()
hw_api_attribute->langdepvalue()
hw_api_attribute->value()
hw_api_attribute->values()
hw_api_content()
hw_api_content->mimetype()
hw_api_content->read()
hw_api_error->count()
hw_api_error->reason()
hw_api_object()
hw_api_object->assign()
hw_api_object->attreditable()
hw_api_object->count()
hw_api_object->insert()
hw_api_object->remove()
hw_api_object->title()
hw_api_object->value()
hw_api_reason->description()
hw_api_reason->type()
hw_array2objrec()
hw_changeobject()
hw_children()
hw_childrenobj()
hw_close()
hw_connect()
hw_connection_info()
hw_cp()
hw_deleteobject()
hw_docbyanchor()
hw_docbyanchorobj()
hw_document_attributes()
hw_document_bodytag()
hw_document_content()
hw_document_setcontent()
hw_document_size()
hw_dummy()
hw_edittext()
hw_error()
hw_errormsg()
hw_free_document()
hw_getanchors()
hw_getanchorsobj()
hw_getandlock()
hw_getchildcoll()
hw_getchildcollobj()
hw_getchilddoccoll()
hw_getchilddoccollobj()
hw_getobject()
hw_getobjectbyquery()
hw_getobjectbyquerycoll()
hw_getobjectbyquerycollobj()
hw_getobjectbyqueryobj()
hw_getparents()
hw_getparentsobj()
hw_getrellink()
hw_getremote()
hw_getremotechildren()
hw_getsrcbydestobj()
hw_gettext()
hw_getusername()
hw_identify()
hw_incollections()
hw_info()
hw_inscoll()
hw_insdoc()
hw_insertanchors()
hw_insertdocument()
hw_insertobject()
hw_mapid()
hw_modifyobject()
hw_mv()
hw_new_document()
hw_objrec2array()
hw_output_document()
hw_pconnect()
hw_pipedocument()
hw_root()
hw_setlinkroot()
hw_stat()
hw_unlock()
hw_who()
hwapi_hgcsp()
hypot()

I

ibase_add_user()
ibase_affected_rows()
ibase_backup()
ibase_blob_add()
ibase_blob_cancel()
ibase_blob_close()
ibase_blob_create()
ibase_blob_echo()
ibase_blob_get()
ibase_blob_import()
ibase_blob_info()
ibase_blob_open()
ibase_close()
ibase_commit()
ibase_commit_ret()
ibase_connect()
ibase_db_info()
ibase_delete_user()
ibase_drop_db()
ibase_errcode()
ibase_errmsg()
ibase_execute()
ibase_fetch_assoc()
ibase_fetch_object()
ibase_fetch_row()
ibase_field_info()
ibase_free_event_handler()
ibase_free_query()
ibase_free_result()
ibase_gen_id()
ibase_maintain_db()
ibase_modify_user()
ibase_name_result()
ibase_num_fields()
ibase_num_params()
ibase_param_info()
ibase_pconnect()
ibase_prepare()
ibase_query()
ibase_restore()
ibase_rollback()
ibase_rollback_ret()
ibase_server_info()
ibase_service_attach()
ibase_service_detach()
ibase_set_event_handler()
ibase_timefmt()
ibase_trans()
ibase_wait_event()
iconv()
iconv_get_encoding()
iconv_mime_decode()
iconv_mime_decode_headers()
iconv_mime_encode()
iconv_set_encoding()
iconv_strlen()
iconv_strpos()
iconv_strrpos()
iconv_substr()
id3_get_frame_long_name()
id3_get_frame_short_name()
id3_get_genre_id()
id3_get_genre_list()
id3_get_genre_name()
id3_get_tag()
id3_get_version()
id3_remove_tag()
id3_set_tag()
idate()
ifx_affected_rows()
ifx_blobinfile_mode()
ifx_byteasvarchar()
ifx_close()
ifx_connect()
ifx_copy_blob()
ifx_create_blob()
ifx_create_char()
ifx_do()
ifx_error()
ifx_errormsg()
ifx_fetch_row()
ifx_fieldproperties()
ifx_fieldtypes()
ifx_free_blob()
ifx_free_char()
ifx_free_result()
ifx_get_blob()
ifx_get_char()
ifx_getsqlca()
ifx_htmltbl_result()
ifx_nullformat()
ifx_num_fields()
ifx_num_rows()
ifx_pconnect()
ifx_prepare()
ifx_query()
ifx_textasvarchar()
ifx_update_blob()
ifx_update_char()
ifxus_close_slob()
ifxus_create_slob()
ifxus_free_slob()
ifxus_open_slob()
ifxus_read_slob()
ifxus_seek_slob()
ifxus_tell_slob()
ifxus_write_slob()
ignore_user_abort()
iis_add_server()
iis_get_dir_security()
iis_get_script_map()
iis_get_server_by_comment()
iis_get_server_by_path()
iis_get_server_rights()
iis_get_service_state()
iis_remove_server()
iis_set_app_settings()
iis_set_dir_security()
iis_set_script_map()
iis_set_server_rights()
iis_start_server()
iis_start_service()
iis_stop_server()
iis_stop_service()
image2wbmp()
image_type_to_extension()
image_type_to_mime_type()
imagealphablending()
imageantialias()
imagearc()
imagechar()
imagecharup()
imagecolorallocate()
imagecolorallocatealpha()
imagecolorat()
imagecolorclosest()
imagecolorclosestalpha()
imagecolorclosesthwb()
imagecolordeallocate()
imagecolorexact()
imagecolorexactalpha()
imagecolormatch()
imagecolorresolve()
imagecolorresolvealpha()
imagecolorset()
imagecolorsforindex()
imagecolorstotal()
imagecolortransparent()
imageconvolution()
imagecopy()
imagecopymerge()
imagecopymergegray()
imagecopyresampled()
imagecopyresized()
imagecreate()
imagecreatefromgd()
imagecreatefromgd2()
imagecreatefromgd2part()
imagecreatefromgif()
imagecreatefromjpeg()
imagecreatefrompng()
imagecreatefromstring()
imagecreatefromwbmp()
imagecreatefromxbm()
imagecreatefromxpm()
imagecreatetruecolor()
imagedashedline()
imagedestroy()
imageellipse()
imagefill()
imagefilledarc()
imagefilledellipse()
imagefilledpolygon()
imagefilledrectangle()
imagefilltoborder()
imagefilter()
imagefontheight()
imagefontwidth()
imageftbbox()
imagefttext()
imagegammacorrect()
imagegd()
imagegd2()
imagegif()
imagegrabscreen()
imagegrabwindow()
imageinterlace()
imageistruecolor()
imagejpeg()
imagelayereffect()
imageline()
imageloadfont()
imagepalettecopy()
imagepng()
imagepolygon()
imagepsbbox()
imagepsencodefont()
imagepsextendfont()
imagepsfreefont()
imagepsloadfont()
imagepsslantfont()
imagepstext()
imagerectangle()
imagerotate()
imagesavealpha()
imagesetbrush()
imagesetpixel()
imagesetstyle()
imagesetthickness()
imagesettile()
imagestring()
imagestringup()
imagesx()
imagesy()
imagetruecolortopalette()
imagettfbbox()
imagettftext()
imagetypes()
imagewbmp()
imagexbm()
imagick()
Imagick::__construct()
Imagick::adaptiveBlurImage()
Imagick::adaptiveResizeImage()
Imagick::adaptiveSharpenImage()
Imagick::adaptiveThresholdImage()
Imagick::addImage()
Imagick::addNoiseImage()
Imagick::affineTransformImage()
Imagick::annotateImage()
Imagick::appendImages()
Imagick::averageImages()
Imagick::blackThresholdImage()
Imagick::blurImage()
Imagick::borderImage()
Imagick::charcoalImage()
Imagick::chopImage()
Imagick::clear()
Imagick::clipImage()
Imagick::clipPathImage()
Imagick::clone()
Imagick::coalesceImages()
Imagick::colorFloodfillImage()
Imagick::colorizeImage()
Imagick::combineImages()
Imagick::commentImage()
Imagick::compareImageChannels()
Imagick::compareImageLayers()
Imagick::compositeImage()
Imagick::contrastImage()
Imagick::contrastStretchImage()
Imagick::convolveImage()
Imagick::cropImage()
Imagick::cropThumbnailImage()
Imagick::current()
Imagick::cycleColormapImage()
Imagick::deconstructImages()
Imagick::despeckleImage()
Imagick::destroy()
Imagick::displayImage()
Imagick::displayImages()
Imagick::drawImage()
Imagick::edgeImage()
Imagick::embossImage()
Imagick::enhanceImage()
Imagick::equalizeImage()
Imagick::evaluateImage()
Imagick::flattenImages()
Imagick::flipImage()
Imagick::flopImage()
Imagick::frameImage()
Imagick::fxImage()
Imagick::gammaImage()
Imagick::gaussianBlurImage()
Imagick::getCompression()
Imagick::getCompressionQuality()
Imagick::getCopyright()
Imagick::getFilename()
Imagick::getFormat()
Imagick::getHomeURL()
Imagick::getImage()
Imagick::getImageBackgroundColor()
Imagick::getImageBlob()
Imagick::getImageBluePrimary()
Imagick::getImageBorderColor()
Imagick::getImageChannelDepth()
Imagick::getImageChannelDistortion()
Imagick::getImageChannelExtrema()
Imagick::getImageChannelMean()
Imagick::getImageChannelStatistics()
Imagick::getImageColormapColor()
Imagick::getImageColors()
Imagick::getImageColorspace()
Imagick::getImageCompose()
Imagick::getImageDelay()
Imagick::getImageDepth()
Imagick::getImageDispose()
Imagick::getImageDistortion()
Imagick::getImageExtrema()
Imagick::getImageFilename()
Imagick::getImageFormat()
Imagick::getImageGamma()
Imagick::getImageGeometry()
Imagick::getImageGreenPrimary()
Imagick::getImageHeight()
Imagick::getImageHistogram()
Imagick::getImageIndex()
Imagick::getImageInterlaceScheme()
Imagick::getImageInterpolateMethod()
Imagick::getImageIterations()
Imagick::getImageMatte()
Imagick::getImageMatteColor()
Imagick::getImagePage()
Imagick::getImagePixelColor()
Imagick::getImageProfile()
Imagick::getImageProperty()
Imagick::getImageRedPrimary()
Imagick::getImageRegion()
Imagick::getImageRenderingIntent()
Imagick::getImageResolution()
Imagick::getImageScene()
Imagick::getImageSignature()
Imagick::getImageSize()
Imagick::getImageTicksPerSecond()
Imagick::getImageTotalInkDensity()
Imagick::getImageType()
Imagick::getImageUnits()
Imagick::getImageVirtualPixelMethod()
Imagick::getImageWhitePoint()
Imagick::getImageWidth()
Imagick::getInterlaceScheme()
Imagick::getNumberImages()
Imagick::getOption()
Imagick::getPackageName()
Imagick::getPage()
Imagick::getPixelIterator()
Imagick::getPixelRegionIterator()
Imagick::getQuantumDepth()
Imagick::getQuantumRange()
Imagick::getReleaseDate()
Imagick::getResource()
Imagick::getResourceLimit()
Imagick::getSamplingFactors()
Imagick::getSize()
Imagick::getSizeOffset()
Imagick::getVersion()
Imagick::hasNextImage()
Imagick::hasPreviousImage()
Imagick::identifyImage()
Imagick::implodeImage()
Imagick::labelImage()
Imagick::levelImage()
Imagick::linearStretchImage()
Imagick::magnifyImage()
Imagick::matteFloodfillImage()
Imagick::medianFilterImage()
Imagick::minifyImage()
Imagick::modulateImage()
Imagick::montageImage()
Imagick::morphImages()
Imagick::mosaicImages()
Imagick::motionBlurImage()
Imagick::negateImage()
Imagick::newImage()
Imagick::newPseudoImage()
Imagick::nextImage()
Imagick::normalizeImage()
Imagick::oilPaintImage()
Imagick::optimizeImageLayers()
Imagick::paintOpaqueImage()
Imagick::paintTransparentImage()
Imagick::pingImage()
Imagick::pingImageBlob()
Imagick::pingImageFile()
Imagick::polaroidImage()
Imagick::posterizeImage()
Imagick::previousImage()
Imagick::profileImage()
Imagick::queryFontMetrics()
Imagick::queryFonts()
Imagick::queryFormats()
Imagick::radialBlurImage()
Imagick::raiseImage()
Imagick::randomThresholdImage()
Imagick::readImage()
Imagick::readImageBlob()
Imagick::readImageFile()
Imagick::reduceNoiseImage()
Imagick::removeImage()
Imagick::removeImageProfile()
Imagick::render()
Imagick::resampleImage()
Imagick::resizeImage()
Imagick::rollImage()
Imagick::rotateImage()
Imagick::roundCorners()
Imagick::sampleImage()
Imagick::scaleImage()
Imagick::separateImageChannel()
Imagick::sepiaToneImage()
Imagick::setBackgroundColor()
Imagick::setCompression()
Imagick::setCompressionQuality()
Imagick::setFilename()
Imagick::setFirstIterator()
Imagick::setFormat()
Imagick::setImageBackgroundColor()
Imagick::setImageBias()
Imagick::setImageBluePrimary()
Imagick::setImageBorderColor()
Imagick::setImageChannelDepth()
Imagick::setImageColormapColor()
Imagick::setImageColorspace()
Imagick::setImageCompose()
Imagick::setImageCompression()
Imagick::setImageDelay()
Imagick::setImageDepth()
Imagick::setImageDispose()
Imagick::setImageExtent()
Imagick::setImageFilename()
Imagick::setImageFormat()
Imagick::setImageGamma()
Imagick::setImageGreenPrimary()
Imagick::setImageIndex()
Imagick::setImageInterlaceScheme()
Imagick::setImageInterpolateMethod()
Imagick::setImageIterations()
Imagick::setImageMatte()
Imagick::setImageMatteColor()
Imagick::setImagePage()
Imagick::setImageProfile()
Imagick::setImageProperty()
Imagick::setImageRedPrimary()
Imagick::setImageRenderingIntent()
Imagick::setImageResolution()
Imagick::setImageScene()
Imagick::setImageTicksPerSecond()
Imagick::setImageType()
Imagick::setImageUnits()
Imagick::setImageVirtualPixelMethod()
Imagick::setImageWhitePoint()
Imagick::setInterlaceScheme()
Imagick::setOption()
Imagick::setPage()
Imagick::setResolution()
Imagick::setResourceLimit()
Imagick::setSamplingFactors()
Imagick::setSize()
Imagick::setSizeOffset()
Imagick::setType()
Imagick::shadeImage()
Imagick::shadowImage()
Imagick::sharpenImage()
Imagick::shaveImage()
Imagick::shearImage()
Imagick::sigmoidalContrastImage()
Imagick::sketchImage()
Imagick::solarizeImage()
Imagick::spliceImage()
Imagick::spreadImage()
Imagick::steganoImage()
Imagick::stereoImage()
Imagick::stripImage()
Imagick::swirlImage()
Imagick::textureImage()
Imagick::thresholdImage()
Imagick::thumbnailImage()
Imagick::tintImage()
Imagick::transverseImage()
Imagick::trimImage()
Imagick::uniqueImageColors()
Imagick::unsharpMaskImage()
Imagick::valid()
Imagick::vignetteImage()
Imagick::waveImage()
Imagick::whiteThresholdImage()
Imagick::writeImage()
Imagick::writeImages()
ImagickDraw::__construct()
ImagickDraw::affine()
ImagickDraw::annotation()
ImagickDraw::arc()
ImagickDraw::bezier()
ImagickDraw::circle()
ImagickDraw::clear()
ImagickDraw::clone()
ImagickDraw::color()
ImagickDraw::comment()
ImagickDraw::composite()
ImagickDraw::destroy()
ImagickDraw::ellipse()
ImagickDraw::getClipPath()
ImagickDraw::getClipRule()
ImagickDraw::getClipUnits()
ImagickDraw::getFillColor()
ImagickDraw::getFillOpacity()
ImagickDraw::getFillRule()
ImagickDraw::getFont()
ImagickDraw::getFontFamily()
ImagickDraw::getFontSize()
ImagickDraw::getFontStyle()
ImagickDraw::getFontWeight()
ImagickDraw::getGravity()
ImagickDraw::getStrokeAntialias()
ImagickDraw::getStrokeColor()
ImagickDraw::getStrokeDashArray()
ImagickDraw::getStrokeDashOffset()
ImagickDraw::getStrokeLineCap()
ImagickDraw::getStrokeLineJoin()
ImagickDraw::getStrokeMiterLimit()
ImagickDraw::getStrokeOpacity()
ImagickDraw::getStrokeWidth()
ImagickDraw::getTextAlignment()
ImagickDraw::getTextAntialias()
ImagickDraw::getTextDecoration()
ImagickDraw::getTextEncoding()
ImagickDraw::getTextUnderColor()
ImagickDraw::getVectorGraphics()
ImagickDraw::line()
ImagickDraw::matte()
ImagickDraw::pathClose()
ImagickDraw::pathCurveToAbsolute()
ImagickDraw::pathCurveToQuadraticBezierAbsolute()
ImagickDraw::pathCurveToQuadraticBezierRelative()
ImagickDraw::pathCurveToQuadraticBezierSmoothAbsolute()
ImagickDraw::pathCurveToQuadraticBezierSmoothRelative()
ImagickDraw::pathCurveToRelative()
ImagickDraw::pathCurveToSmoothAbsolute()
ImagickDraw::pathCurveToSmoothRelative()
ImagickDraw::pathEllipticArcAbsolute()
ImagickDraw::pathEllipticArcRelative()
ImagickDraw::pathFinish()
ImagickDraw::pathLineToAbsolute()
ImagickDraw::pathLineToHorizontalAbsolute()
ImagickDraw::pathLineToHorizontalRelative()
ImagickDraw::pathLineToRelative()
ImagickDraw::pathLineToVerticalAbsolute()
ImagickDraw::pathLineToVerticalRelative()
ImagickDraw::pathMoveToAbsolute()
ImagickDraw::pathMoveToRelative()
ImagickDraw::pathStart()
ImagickDraw::point()
ImagickDraw::polygon()
ImagickDraw::polyline()
ImagickDraw::pop()
ImagickDraw::popClipPath()
ImagickDraw::popDefs()
ImagickDraw::popPattern()
ImagickDraw::push()
ImagickDraw::pushClipPath()
ImagickDraw::pushDefs()
ImagickDraw::pushPattern()
ImagickDraw::rectangle()
ImagickDraw::render()
ImagickDraw::rotate()
ImagickDraw::roundRectangle()
ImagickDraw::scale()
ImagickDraw::setClipPath()
ImagickDraw::setClipRule()
ImagickDraw::setClipUnits()
ImagickDraw::setFillAlpha()
ImagickDraw::setFillColor()
ImagickDraw::setFillOpacity()
ImagickDraw::setFillPatternURL()
ImagickDraw::setFillRule()
ImagickDraw::setFont()
ImagickDraw::setFontFamily()
ImagickDraw::setFontSize()
ImagickDraw::setFontStretch()
ImagickDraw::setFontStyle()
ImagickDraw::setFontWeight()
ImagickDraw::setGravity()
ImagickDraw::setStrokeAlpha()
ImagickDraw::setStrokeAntialias()
ImagickDraw::setStrokeColor()
ImagickDraw::setStrokeDashArray()
ImagickDraw::setStrokeDashOffset()
ImagickDraw::setStrokeLineCap()
ImagickDraw::setStrokeLineJoin()
ImagickDraw::setStrokeMiterLimit()
ImagickDraw::setStrokeOpacity()
ImagickDraw::setStrokePatternURL()
ImagickDraw::setStrokeWidth()
ImagickDraw::setTextAlignment()
ImagickDraw::setTextAntialias()
ImagickDraw::setTextDecoration()
ImagickDraw::setTextEncoding()
ImagickDraw::setTextUnderColor()
ImagickDraw::setVectorGraphics()
ImagickDraw::setViewbox()
ImagickDraw::skewX()
ImagickDraw::skewY()
ImagickDraw::translate()
ImagickPixel::__construct()
ImagickPixel::clear()
ImagickPixel::destroy()
ImagickPixel::getColor()
ImagickPixel::getColorCount()
ImagickPixel::getColorValue()
ImagickPixel::getHSL()
ImagickPixel::isSimilar()
ImagickPixel::setColor()
ImagickPixel::setColorValue()
ImagickPixel::setHSL()
ImagickPixelIterator::__construct()
ImagickPixelIterator::clear()
ImagickPixelIterator::destroy()
ImagickPixelIterator::getCurrentIteratorRow()
ImagickPixelIterator::getIteratorRow()
ImagickPixelIterator::getNextIteratorRow()
ImagickPixelIterator::getPreviousIteratorRow()
ImagickPixelIterator::newPixelIterator()
ImagickPixelIterator::newPixelRegionIterator()
ImagickPixelIterator::resetIterator()
ImagickPixelIterator::setIteratorFirstRow()
ImagickPixelIterator::setIteratorLastRow()
ImagickPixelIterator::setIteratorRow()
ImagickPixelIterator::syncIterator()
imap_8bit()
imap_alerts()
imap_append()
imap_base64()
imap_binary()
imap_body()
imap_bodystruct()
imap_check()
imap_clearflag_full()
imap_close()
imap_createmailbox()
imap_delete()
imap_deletemailbox()
imap_errors()
imap_expunge()
imap_fetch_overview()
imap_fetchbody()
imap_fetchheader()
imap_fetchstructure()
imap_get_quota()
imap_get_quotaroot()
imap_getacl()
imap_getmailboxes()
imap_getsubscribed()
imap_header()
imap_headerinfo()
imap_headers()
imap_last_error()
imap_list()
imap_listmailbox()
imap_listscan()
imap_listsubscribed()
imap_lsub()
imap_mail()
imap_mail_compose()
imap_mail_copy()
imap_mail_move()
imap_mailboxmsginfo()
imap_mime_header_decode()
imap_msgno()
imap_num_msg()
imap_num_recent()
imap_open()
imap_ping()
imap_qprint()
imap_renamemailbox()
imap_reopen()
imap_rfc822_parse_adrlist()
imap_rfc822_parse_headers()
imap_rfc822_write_address()
imap_savebody()
imap_scanmailbox()
imap_search()
imap_set_quota()
imap_setacl()
imap_setflag_full()
imap_sort()
imap_status()
imap_subscribe()
imap_thread()
imap_timeout()
imap_uid()
imap_undelete()
imap_unsubscribe()
imap_utf7_decode()
imap_utf7_encode()
imap_utf8()
implode()
import_request_variables()
in_array()
inet_ntop()
inet_pton()
ingres_autocommit()
ingres_close()
ingres_commit()
ingres_connect()
ingres_cursor()
ingres_errno()
ingres_error()
ingres_errsqlstate()
ingres_fetch_array()
ingres_fetch_object()
ingres_fetch_row()
ingres_field_length()
ingres_field_name()
ingres_field_nullable()
ingres_field_precision()
ingres_field_scale()
ingres_field_type()
ingres_num_fields()
ingres_num_rows()
ingres_pconnect()
ingres_query()
ingres_rollback()
ini_alter()
ini_get()
ini_get_all()
ini_restore()
ini_set()
installation()
installation()
interface_exists()
intval()
ip2long()
iptcembed()
iptcparse()
ircg_channel_mode()
ircg_disconnect()
ircg_eval_ecmascript_params()
ircg_fetch_error_msg()
ircg_get_username()
ircg_html_encode()
ircg_ignore_add()
ircg_ignore_del()
ircg_invite()
ircg_is_conn_alive()
ircg_join()
ircg_kick()
ircg_list()
ircg_lookup_format_messages()
ircg_lusers()
ircg_msg()
ircg_names()
ircg_nick()
ircg_nickname_escape()
ircg_nickname_unescape()
ircg_notice()
ircg_oper()
ircg_part()
ircg_pconnect()
ircg_register_format_messages()
ircg_set_current()
ircg_set_file()
ircg_set_on_die()
ircg_topic()
ircg_who()
ircg_whois()
is_a()
is_array()
is_binary()
is_bool()
is_buffer()
is_callable()
is_dir()
is_double()
is_executable()
is_file()
is_finite()
is_float()
is_infinite()
is_int()
is_integer()
is_link()
is_long()
is_nan()
is_null()
is_numeric()
is_object()
is_readable()
is_real()
is_resource()
is_scalar()
is_soap_fault()
is_string()
is_subclass_of()
is_unicode()
is_uploaded_file()
is_writable()
is_writeable()
isset()
iterator_count()
iterator_to_array()

J

java_last_exception_clear()
java_last_exception_get()
jddayofweek()
jdmonthname()
jdtofrench()
jdtogregorian()
jdtojewish()
jdtojulian()
jdtounix()
jewishtojd()
join()
jpeg2wbmp()
json_decode()
json_encode()
juliantojd()

K

kadm5_chpass_principal()
kadm5_create_principal()
kadm5_delete_principal()
kadm5_destroy()
kadm5_flush()
kadm5_get_policies()
kadm5_get_principal()
kadm5_get_principals()
kadm5_init_with_password()
kadm5_modify_principal()
key()
krsort()
ksort()

L

lcg_value()
lchgrp()
lchown()
ldap_8859_to_t61()
ldap_add()
ldap_bind()
ldap_close()
ldap_compare()
ldap_connect()
ldap_count_entries()
ldap_delete()
ldap_dn2ufn()
ldap_err2str()
ldap_errno()
ldap_error()
ldap_explode_dn()
ldap_first_attribute()
ldap_first_entry()
ldap_first_reference()
ldap_free_result()
ldap_get_attributes()
ldap_get_dn()
ldap_get_entries()
ldap_get_option()
ldap_get_values()
ldap_get_values_len()
ldap_list()
ldap_mod_add()
ldap_mod_del()
ldap_mod_replace()
ldap_modify()
ldap_next_attribute()
ldap_next_entry()
ldap_next_reference()
ldap_parse_reference()
ldap_parse_result()
ldap_read()
ldap_rename()
ldap_sasl_bind()
ldap_search()
ldap_set_option()
ldap_set_rebind_proc()
ldap_sort()
ldap_start_tls()
ldap_t61_to_8859()
ldap_unbind()
levenshtein()
libxml_clear_errors()
libxml_get_errors()
libxml_get_last_error()
libxml_set_streams_context()
libxml_use_internal_errors()
LimitIterator::getPosition()
LimitIterator::next()
LimitIterator::rewind()
LimitIterator::seek()
LimitIterator::valid()
link()
linkinfo()
list()
locale_get_default()
locale_set_default()
localeconv()
localtime()
log()
log10()
log1p()
long2ip()
lstat()
ltrim()
lzf_compress()
lzf_decompress()
lzf_optimized_for()

M

m_checkstatus()
m_completeauthorizations()
m_connect()
m_connectionerror()
m_deletetrans()
m_destroyconn()
m_destroyengine()
m_getcell()
m_getcellbynum()
m_getcommadelimited()
m_getheader()
m_initconn()
m_initengine()
m_iscommadelimited()
m_maxconntimeout()
m_monitor()
m_numcolumns()
m_numrows()
m_parsecommadelimited()
m_responsekeys()
m_responseparam()
m_returnstatus()
m_setblocking()
m_setdropfile()
m_setip()
m_setssl()
m_setssl_cafile()
m_setssl_files()
m_settimeout()
m_sslcert_gen_hash()
m_transactionssent()
m_transinqueue()
m_transkeyval()
m_transnew()
m_transsend()
m_uwait()
m_validateidentifier()
m_verifyconnection()
m_verifysslcert()
mail()
mailparse_determine_best_xfer_encoding()
mailparse_msg_create()
mailparse_msg_extract_part()
mailparse_msg_extract_part_file()
mailparse_msg_extract_whole_part_file()
mailparse_msg_free()
mailparse_msg_get_part()
mailparse_msg_get_part_data()
mailparse_msg_get_structure()
mailparse_msg_parse()
mailparse_msg_parse_file()
mailparse_rfc822_parse_addresses()
mailparse_stream_encode()
mailparse_uudecode_all()
main()
max()
maxdb()()
maxdb->affected_rows()
maxdb->auto_commit()
maxdb->change_user()
maxdb->character_set_name()
maxdb->close()
maxdb->close_long_data()
maxdb->commit()
maxdb->disable_reads_from_master()
maxdb->errno()
maxdb->fetch_assoc()
maxdb->field_count()
maxdb->get_host_info()
maxdb->info()
maxdb->insert_id()
maxdb->kill()
maxdb->more_results()
maxdb->multi_query()
maxdb->next_result()
maxdb->options()
maxdb->ping()
maxdb->prepare()
maxdb->protocol_version()
maxdb->query()
maxdb->real_connect()
maxdb->real_escape_string()
maxdb->real_query()
maxdb->rollback()
maxdb->rpl_query_type()
maxdb->select_db()
maxdb->send_query()
maxdb->server_info()
maxdb->sqlstate()
maxdb->ssl_set()
maxdb->stat()
maxdb->stmt_init()
maxdb->store_result()
maxdb->store_result()
maxdb->thread_id()
maxdb->use_result()
maxdb->warning_count()
maxdb_affected_rows()
maxdb_autocommit()
maxdb_bind_param()
maxdb_bind_result()
maxdb_change_user()
maxdb_character_set_name()
maxdb_client_encoding()
maxdb_close()
maxdb_close_long_data()
maxdb_commit()
maxdb_connect()
maxdb_connect_errno()
maxdb_connect_error()
maxdb_data_seek()
maxdb_debug()
maxdb_disable_reads_from_master()
maxdb_disable_rpl_parse()
maxdb_dump_debug_info()
maxdb_embedded_connect()
maxdb_enable_reads_from_master()
maxdb_enable_rpl_parse()
maxdb_errno()
maxdb_error()
maxdb_escape_string()
maxdb_execute()
maxdb_fetch()
maxdb_fetch_array()
maxdb_fetch_assoc()
maxdb_fetch_field()
maxdb_fetch_field_direct()
maxdb_fetch_fields()
maxdb_fetch_lengths()
maxdb_fetch_object()
maxdb_fetch_row()
maxdb_field_count()
maxdb_field_seek()
maxdb_field_tell()
maxdb_free_result()
maxdb_get_client_info()
maxdb_get_client_version()
maxdb_get_host_info()
maxdb_get_metadata()
maxdb_get_proto_info()
maxdb_get_server_info()
maxdb_get_server_version()
maxdb_info()
maxdb_init()
maxdb_insert_id()
maxdb_kill()
maxdb_master_query()
maxdb_more_results()
maxdb_multi_query()
maxdb_next_result()
maxdb_num_fields()
maxdb_num_rows()
maxdb_options()
maxdb_param_count()
maxdb_ping()
maxdb_prepare()
maxdb_query()
maxdb_real_connect()
maxdb_real_escape_string()
maxdb_real_query()
maxdb_report()
maxdb_rollback()
maxdb_rpl_parse_enabled()
maxdb_rpl_probe()
maxdb_rpl_query_type()
maxdb_select_db()
maxdb_send_long_data()
maxdb_send_query()
maxdb_server_end()
maxdb_server_init()
maxdb_set_opt()
maxdb_sqlstate()
maxdb_ssl_set()
maxdb_stat()
maxdb_stmt->affected_rows()
maxdb_stmt->close()
maxdb_stmt->errno()
maxdb_stmt->error()
maxdb_stmt_affected_rows()
maxdb_stmt_bind_param()
maxdb_stmt_bind_result()
maxdb_stmt_close()
maxdb_stmt_close_long_data()
maxdb_stmt_data_seek()
maxdb_stmt_errno()
maxdb_stmt_error()
maxdb_stmt_execute()
maxdb_stmt_fetch()
maxdb_stmt_free_result()
maxdb_stmt_init()
maxdb_stmt_num_rows()
maxdb_stmt_param_count()
maxdb_stmt_prepare()
maxdb_stmt_reset()
maxdb_stmt_result_metadata()
maxdb_stmt_send_long_data()
maxdb_stmt_sqlstate()
maxdb_stmt_store_result()
maxdb_store_result()
maxdb_thread_id()
maxdb_thread_safe()
maxdb_use_result()
maxdb_warning_count()
mb_check_encoding()
mb_convert_case()
mb_convert_encoding()
mb_convert_kana()
mb_convert_variables()
mb_decode_mimeheader()
mb_decode_numericentity()
mb_detect_encoding()
mb_detect_order()
mb_encode_mimeheader()
mb_encode_numericentity()
mb_ereg()
mb_ereg_match()
mb_ereg_replace()
mb_ereg_search()
mb_ereg_search_getpos()
mb_ereg_search_getregs()
mb_ereg_search_init()
mb_ereg_search_pos()
mb_ereg_search_regs()
mb_ereg_search_setpos()
mb_eregi()
mb_eregi_replace()
mb_get_info()
mb_http_input()
mb_http_output()
mb_internal_encoding()
mb_language()
mb_output_handler()
mb_parse_str()
mb_preferred_mime_name()
mb_regex_encoding()
mb_regex_set_options()
mb_send_mail()
mb_split()
mb_strcut()
mb_strimwidth()
mb_stripos()
mb_stristr()
mb_strlen()
mb_strpos()
mb_strrchr()
mb_strrichr()
mb_strripos()
mb_strrpos()
mb_strstr()
mb_strtolower()
mb_strtoupper()
mb_strwidth()
mb_substitute_character()
mb_substr()
mb_substr_count()
mcal_append_event()
mcal_close()
mcal_create_calendar()
mcal_date_compare()
mcal_date_valid()
mcal_day_of_week()
mcal_day_of_year()
mcal_days_in_month()
mcal_delete_calendar()
mcal_delete_event()
mcal_event_add_attribute()
mcal_event_init()
mcal_event_set_alarm()
mcal_event_set_category()
mcal_event_set_class()
mcal_event_set_description()
mcal_event_set_end()
mcal_event_set_recur_daily()
mcal_event_set_recur_monthly_mday()
mcal_event_set_recur_monthly_wday()
mcal_event_set_recur_none()
mcal_event_set_recur_weekly()
mcal_event_set_recur_yearly()
mcal_event_set_start()
mcal_event_set_title()
mcal_expunge()
mcal_fetch_current_stream_event()
mcal_fetch_event()
mcal_is_leap_year()
mcal_list_alarms()
mcal_list_events()
mcal_next_recurrence()
mcal_open()
mcal_popen()
mcal_rename_calendar()
mcal_reopen()
mcal_snooze()
mcal_store_event()
mcal_time_valid()
mcal_week_of_year()
mcrypt_cbc()
mcrypt_cfb()
mcrypt_create_iv()
mcrypt_decrypt()
mcrypt_ecb()
mcrypt_enc_get_algorithms_name()
mcrypt_enc_get_block_size()
mcrypt_enc_get_iv_size()
mcrypt_enc_get_key_size()
mcrypt_enc_get_modes_name()
mcrypt_enc_get_supported_key_sizes()
mcrypt_enc_is_block_algorithm()
mcrypt_enc_is_block_algorithm_mode()
mcrypt_enc_is_block_mode()
mcrypt_enc_self_test()
mcrypt_encrypt()
mcrypt_generic()
mcrypt_generic_deinit()
mcrypt_generic_end()
mcrypt_generic_init()
mcrypt_get_block_size()
mcrypt_get_cipher_name()
mcrypt_get_iv_size()
mcrypt_get_key_size()
mcrypt_list_algorithms()
mcrypt_list_modes()
mcrypt_module_close()
mcrypt_module_get_algo_block_size()
mcrypt_module_get_algo_key_size()
mcrypt_module_get_supported_key_sizes()
mcrypt_module_is_block_algorithm()
mcrypt_module_is_block_algorithm_mode()
mcrypt_module_is_block_mode()
mcrypt_module_open()
mcrypt_module_self_test()
mcrypt_ofb()
md5()
md5_file()
mdecrypt_generic()
Memcache::add()
Memcache::addServer()
Memcache::close()
Memcache::connect()
Memcache::decrement()
Memcache::delete()
Memcache::flush()
Memcache::get()
Memcache::getExtendedStats()
Memcache::getServerStatus()
Memcache::getStats()
Memcache::getVersion()
Memcache::increment()
Memcache::pconnect()
Memcache::replace()
Memcache::set()
Memcache::setCompressThreshold()
Memcache::setServerParams()
memcache_debug()
memory_get_peak_usage()
memory_get_usage()
metaphone()
method_exists()
mhash()
mhash_count()
mhash_get_block_size()
mhash_get_hash_name()
mhash_keygen_s2k()
microtime()
mime_content_type()
min()
ming_keypress()
ming_setcubicthreshold()
ming_setscale()
ming_setswfcompression()
ming_useconstants()
ming_useswfversion()
mkdir()
mktime()
money_format()
move_uploaded_file()
msession_connect()
msession_count()
msession_create()
msession_destroy()
msession_disconnect()
msession_find()
msession_get()
msession_get_array()
msession_get_data()
msession_inc()
msession_list()
msession_listvar()
msession_lock()
msession_plugin()
msession_randstr()
msession_set()
msession_set_array()
msession_set_data()
msession_timeout()
msession_uniq()
msession_unlock()
msg_get_queue()
msg_receive()
msg_remove_queue()
msg_send()
msg_set_queue()
msg_stat_queue()
msql()
msql_affected_rows()
msql_close()
msql_connect()
msql_create_db()
msql_createdb()
msql_data_seek()
msql_db_query()
msql_dbname()
msql_drop_db()
msql_error()
msql_fetch_array()
msql_fetch_field()
msql_fetch_object()
msql_fetch_row()
msql_field_flags()
msql_field_len()
msql_field_name()
msql_field_seek()
msql_field_table()
msql_field_type()
msql_fieldflags()
msql_fieldlen()
msql_fieldname()
msql_fieldtable()
msql_fieldtype()
msql_free_result()
msql_list_dbs()
msql_list_fields()
msql_list_tables()
msql_num_fields()
msql_num_rows()
msql_numfields()
msql_numrows()
msql_pconnect()
msql_query()
msql_regcase()
msql_result()
msql_select_db()
msql_tablename()
mssql_bind()
mssql_close()
mssql_connect()
mssql_data_seek()
mssql_execute()
mssql_fetch_array()
mssql_fetch_assoc()
mssql_fetch_batch()
mssql_fetch_field()
mssql_fetch_object()
mssql_fetch_row()
mssql_field_length()
mssql_field_name()
mssql_field_seek()
mssql_field_type()
mssql_free_result()
mssql_free_statement()
mssql_get_last_message()
mssql_guid_string()
mssql_init()
mssql_min_error_severity()
mssql_min_message_severity()
mssql_next_result()
mssql_num_fields()
mssql_num_rows()
mssql_pconnect()
mssql_query()
mssql_result()
mssql_rows_affected()
mssql_select_db()
mt_getrandmax()
mt_rand()
mt_srand()
muscat_close()
muscat_get()
muscat_give()
muscat_setup()
muscat_setup_net()
mysql_affected_rows()
mysql_change_user()
mysql_client_encoding()
mysql_close()
mysql_connect()
mysql_create_db()
mysql_data_seek()
mysql_db_name()
mysql_db_query()
mysql_drop_db()
mysql_errno()
mysql_error()
mysql_escape_string()
mysql_fetch_array()
mysql_fetch_assoc()
mysql_fetch_field()
mysql_fetch_lengths()
mysql_fetch_object()
mysql_fetch_row()
mysql_field_flags()
mysql_field_len()
mysql_field_name()
mysql_field_seek()
mysql_field_table()
mysql_field_type()
mysql_free_result()
mysql_get_client_info()
mysql_get_host_info()
mysql_get_proto_info()
mysql_get_server_info()
mysql_info()
mysql_insert_id()
mysql_list_dbs()
mysql_list_fields()
mysql_list_processes()
mysql_list_tables()
mysql_num_fields()
mysql_num_rows()
mysql_pconnect()
mysql_ping()
mysql_query()
mysql_real_escape_string()
mysql_result()
mysql_select_db()
mysql_set_charset()
mysql_stat()
mysql_tablename()
mysql_thread_id()
mysql_unbuffered_query()
mysqli->__construct()()
mysqli->affected_rows()
mysqli->autocommit()()
mysqli->change_user()()
mysqli->character_set_name()()
mysqli->close()()
mysqli->commit()()
mysqli->debug()()
mysqli->disable_reads_from_master()()
mysqli->dump_debug_info()()
mysqli->errno()
mysqli->fetch_assoc()()
mysqli->field_count()()
mysqli->host_info()
mysqli->info()
mysqli->insert_id()
mysqli->kill()()
mysqli->more_results()
mysqli->multi_query()()
mysqli->next_result()()
mysqli->options()()
mysqli->ping()()
mysqli->prepare()()
mysqli->protocol_version()
mysqli->query()()
mysqli->real_connect()()
mysqli->real_escape_string()()
mysqli->real_query()()
mysqli->rollback()()
mysqli->rpl_query_type()()
mysqli->select_db()()
mysqli->send_query()()
mysqli->server_info()
mysqli->server_version()
mysqli->set_charset()
mysqli->sqlstate()
mysqli->ssl_set()()
mysqli->stat()()
mysqli->stmt_init()()
mysqli->store_result()()
mysqli->thread_id()
mysqli->use_result()()
mysqli->warning_count()
mysqli_affected_rows()
mysqli_autocommit()
mysqli_bind_param()
mysqli_bind_result()
mysqli_change_user()
mysqli_character_set_name()
mysqli_client_encoding()
mysqli_close()
mysqli_commit()
mysqli_connect()
mysqli_connect_errno()
mysqli_connect_error()
mysqli_data_seek()
mysqli_debug()
mysqli_disable_reads_from_master()
mysqli_disable_rpl_parse()
mysqli_dump_debug_info()
mysqli_embedded_server_end()
mysqli_embedded_server_start()
mysqli_enable_reads_from_master()
mysqli_enable_rpl_parse()
mysqli_errno()
mysqli_error()
mysqli_escape_string()
mysqli_execute()
mysqli_fetch()
mysqli_fetch_array()
mysqli_fetch_assoc()
mysqli_fetch_field()
mysqli_fetch_field_direct()
mysqli_fetch_fields()
mysqli_fetch_lengths()
mysqli_fetch_object()
mysqli_fetch_row()
mysqli_field_count()
mysqli_field_seek()
mysqli_field_tell()
mysqli_free_result()
mysqli_get_charset()
mysqli_get_client_info()
mysqli_get_client_version()
mysqli_get_host_info()
mysqli_get_metadata()
mysqli_get_proto_info()
mysqli_get_server_info()
mysqli_get_server_version()
mysqli_get_warnings()
mysqli_info()
mysqli_init()
mysqli_insert_id()
mysqli_kill()
mysqli_master_query()
mysqli_more_results()
mysqli_multi_query()
mysqli_next_result()
mysqli_num_fields()
mysqli_num_rows()
mysqli_options()
mysqli_param_count()
mysqli_ping()
mysqli_prepare()
mysqli_query()
mysqli_real_connect()
mysqli_real_escape_string()
mysqli_real_query()
mysqli_report()
mysqli_rollback()
mysqli_rpl_parse_enabled()
mysqli_rpl_probe()
mysqli_rpl_query_type()
mysqli_select_db()
mysqli_send_long_data()
mysqli_send_query()
mysqli_server_end()
mysqli_server_init()
mysqli_set_charset()
mysqli_set_local_infile_default()
mysqli_set_local_infile_handler()
mysqli_set_opt()
mysqli_slave_query()
mysqli_sqlstate()
mysqli_ssl_set()
mysqli_stat()
mysqli_stmt->affected_rows()
mysqli_stmt->close()()
mysqli_stmt->errno()
mysqli_stmt->error()
mysqli_stmt->sqlstate()()
mysqli_stmt->store_result()()
mysqli_stmt_affected_rows()
mysqli_stmt_attr_get()
mysqli_stmt_attr_set()
mysqli_stmt_bind_param()
mysqli_stmt_bind_result()
mysqli_stmt_close()
mysqli_stmt_data_seek()
mysqli_stmt_errno()
mysqli_stmt_error()
mysqli_stmt_execute()
mysqli_stmt_fetch()
mysqli_stmt_field_count()
mysqli_stmt_free_result()
mysqli_stmt_get_warnings()
mysqli_stmt_init()
mysqli_stmt_insert_id()
mysqli_stmt_num_rows()
mysqli_stmt_param_count()
mysqli_stmt_prepare()
mysqli_stmt_reset()
mysqli_stmt_result_metadata()
mysqli_stmt_send_long_data()
mysqli_stmt_sqlstate()
mysqli_stmt_store_result()
mysqli_store_result()
mysqli_thread_id()
mysqli_thread_safe()
mysqli_use_result()
mysqli_warning_count()

N

natcasesort()
natsort()
ncurses_addch()
ncurses_addchnstr()
ncurses_addchstr()
ncurses_addnstr()
ncurses_addstr()
ncurses_assume_default_colors()
ncurses_attroff()
ncurses_attron()
ncurses_attrset()
ncurses_baudrate()
ncurses_beep()
ncurses_bkgd()
ncurses_bkgdset()
ncurses_border()
ncurses_bottom_panel()
ncurses_can_change_color()
ncurses_cbreak()
ncurses_clear()
ncurses_clrtobot()
ncurses_clrtoeol()
ncurses_color_content()
ncurses_color_set()
ncurses_curs_set()
ncurses_def_prog_mode()
ncurses_def_shell_mode()
ncurses_define_key()
ncurses_del_panel()
ncurses_delay_output()
ncurses_delch()
ncurses_deleteln()
ncurses_delwin()
ncurses_doupdate()
ncurses_echo()
ncurses_echochar()
ncurses_end()
ncurses_erase()
ncurses_erasechar()
ncurses_filter()
ncurses_flash()
ncurses_flushinp()
ncurses_getch()
ncurses_getmaxyx()
ncurses_getmouse()
ncurses_getyx()
ncurses_halfdelay()
ncurses_has_colors()
ncurses_has_ic()
ncurses_has_il()
ncurses_has_key()
ncurses_hide_panel()
ncurses_hline()
ncurses_inch()
ncurses_init()
ncurses_init_color()
ncurses_init_pair()
ncurses_insch()
ncurses_insdelln()
ncurses_insertln()
ncurses_insstr()
ncurses_instr()
ncurses_isendwin()
ncurses_keyok()
ncurses_keypad()
ncurses_killchar()
ncurses_longname()
ncurses_meta()
ncurses_mouse_trafo()
ncurses_mouseinterval()
ncurses_mousemask()
ncurses_move()
ncurses_move_panel()
ncurses_mvaddch()
ncurses_mvaddchnstr()
ncurses_mvaddchstr()
ncurses_mvaddnstr()
ncurses_mvaddstr()
ncurses_mvcur()
ncurses_mvdelch()
ncurses_mvgetch()
ncurses_mvhline()
ncurses_mvinch()
ncurses_mvvline()
ncurses_mvwaddstr()
ncurses_napms()
ncurses_new_panel()
ncurses_newpad()
ncurses_newwin()
ncurses_nl()
ncurses_nocbreak()
ncurses_noecho()
ncurses_nonl()
ncurses_noqiflush()
ncurses_noraw()
ncurses_pair_content()
ncurses_panel_above()
ncurses_panel_below()
ncurses_panel_window()
ncurses_pnoutrefresh()
ncurses_prefresh()
ncurses_putp()
ncurses_qiflush()
ncurses_raw()
ncurses_refresh()
ncurses_replace_panel()
ncurses_reset_prog_mode()
ncurses_reset_shell_mode()
ncurses_resetty()
ncurses_savetty()
ncurses_scr_dump()
ncurses_scr_init()
ncurses_scr_restore()
ncurses_scr_set()
ncurses_scrl()
ncurses_show_panel()
ncurses_slk_attr()
ncurses_slk_attroff()
ncurses_slk_attron()
ncurses_slk_attrset()
ncurses_slk_clear()
ncurses_slk_color()
ncurses_slk_init()
ncurses_slk_noutrefresh()
ncurses_slk_refresh()
ncurses_slk_restore()
ncurses_slk_set()
ncurses_slk_touch()
ncurses_standend()
ncurses_standout()
ncurses_start_color()
ncurses_termattrs()
ncurses_termname()
ncurses_timeout()
ncurses_top_panel()
ncurses_typeahead()
ncurses_ungetch()
ncurses_ungetmouse()
ncurses_update_panels()
ncurses_use_default_colors()
ncurses_use_env()
ncurses_use_extended_names()
ncurses_vidattr()
ncurses_vline()
ncurses_waddch()
ncurses_waddstr()
ncurses_wattroff()
ncurses_wattron()
ncurses_wattrset()
ncurses_wborder()
ncurses_wclear()
ncurses_wcolor_set()
ncurses_werase()
ncurses_wgetch()
ncurses_whline()
ncurses_wmouse_trafo()
ncurses_wmove()
ncurses_wnoutrefresh()
ncurses_wrefresh()
ncurses_wstandend()
ncurses_wstandout()
ncurses_wvline()
newt_bell()
newt_button()
newt_button_bar()
newt_centered_window()
newt_checkbox()
newt_checkbox_get_value()
newt_checkbox_set_flags()
newt_checkbox_set_value()
newt_checkbox_tree()
newt_checkbox_tree_add_item()
newt_checkbox_tree_find_item()
newt_checkbox_tree_get_current()
newt_checkbox_tree_get_entry_value()
newt_checkbox_tree_get_multi_selection()
newt_checkbox_tree_get_selection()
newt_checkbox_tree_multi()
newt_checkbox_tree_set_current()
newt_checkbox_tree_set_entry()
newt_checkbox_tree_set_entry_value()
newt_checkbox_tree_set_width()
newt_clear_key_buffer()
newt_cls()
newt_compact_button()
newt_component_add_callback()
newt_component_takes_focus()
newt_create_grid()
newt_cursor_off()
newt_cursor_on()
newt_delay()
newt_draw_form()
newt_draw_root_text()
newt_entry()
newt_entry_get_value()
newt_entry_set()
newt_entry_set_filter()
newt_entry_set_flags()
newt_finished()
newt_form()
newt_form_add_component()
newt_form_add_components()
newt_form_add_hot_key()
newt_form_destroy()
newt_form_get_current()
newt_form_run()
newt_form_set_background()
newt_form_set_height()
newt_form_set_size()
newt_form_set_timer()
newt_form_set_width()
newt_form_watch_fd()
newt_get_screen_size()
newt_grid_add_components_to_form()
newt_grid_basic_window()
newt_grid_free()
newt_grid_get_size()
newt_grid_h_close_stacked()
newt_grid_h_stacked()
newt_grid_place()
newt_grid_set_field()
newt_grid_simple_window()
newt_grid_v_close_stacked()
newt_grid_v_stacked()
newt_grid_wrapped_window()
newt_grid_wrapped_window_at()
newt_init()
newt_label()
newt_label_set_text()
newt_listbox()
newt_listbox_append_entry()
newt_listbox_clear()
newt_listbox_clear_selection()
newt_listbox_delete_entry()
newt_listbox_get_current()
newt_listbox_get_selection()
newt_listbox_insert_entry()
newt_listbox_item_count()
newt_listbox_select_item()
newt_listbox_set_current()
newt_listbox_set_current_by_key()
newt_listbox_set_data()
newt_listbox_set_entry()
newt_listbox_set_width()
newt_listitem()
newt_listitem_get_data()
newt_listitem_set()
newt_open_window()
newt_pop_help_line()
newt_pop_window()
newt_push_help_line()
newt_radio_get_current()
newt_radiobutton()
newt_redraw_help_line()
newt_reflow_text()
newt_refresh()
newt_resize_screen()
newt_resume()
newt_run_form()
newt_scale()
newt_scale_set()
newt_scrollbar_set()
newt_set_help_callback()
newt_set_suspend_callback()
newt_suspend()
newt_textbox()
newt_textbox_get_num_lines()
newt_textbox_reflowed()
newt_textbox_set_height()
newt_textbox_set_text()
newt_vertical_scrollbar()
newt_wait_for_key()
newt_win_choice()
newt_win_entries()
newt_win_menu()
newt_win_message()
newt_win_messagev()
newt_win_ternary()
next()
ngettext()
nl2br()
nl_langinfo()
notes_body()
notes_copy_db()
notes_create_db()
notes_create_note()
notes_drop_db()
notes_find_note()
notes_header_info()
notes_list_msgs()
notes_mark_read()
notes_mark_unread()
notes_nav_create()
notes_search()
notes_unread()
notes_version()
nsapi_request_headers()
nsapi_response_headers()
nsapi_virtual()
number_format()

O

ob_clean()
ob_deflatehandler()
ob_end_clean()
ob_end_flush()
ob_etaghandler()
ob_flush()
ob_get_clean()
ob_get_contents()
ob_get_flush()
ob_get_length()
ob_get_level()
ob_get_status()
ob_gzhandler()
ob_iconv_handler()
ob_implicit_flush()
ob_inflatehandler()
ob_list_handlers()
ob_start()
ob_tidyhandler()
OCI-Collection->append()
OCI-Collection->assign()
OCI-Collection->assignElem()
OCI-Collection->free()
OCI-Collection->getElem()
OCI-Collection->max()
OCI-Collection->size()
OCI-Collection->trim()
OCI-Lob->append()
OCI-Lob->close()
OCI-Lob->eof()
OCI-Lob->erase()
OCI-Lob->export()
OCI-Lob->flush()
OCI-Lob->free()
OCI-Lob->getBuffering()
OCI-Lob->import()
OCI-Lob->load()
OCI-Lob->read()
OCI-Lob->rewind()
OCI-Lob->save()
OCI-Lob->saveFile()
OCI-Lob->seek()
OCI-Lob->setBuffering()
OCI-Lob->size()
OCI-Lob->tell()
OCI-Lob->truncate()
OCI-Lob->write()
OCI-Lob->writeTemporary()
OCI-Lob->writeToFile()
oci_bind_array_by_name()
oci_bind_by_name()
oci_cancel()
oci_close()
oci_commit()
oci_connect()
oci_define_by_name()
oci_error()
oci_execute()
oci_fetch()
oci_fetch_all()
oci_fetch_array()
oci_fetch_assoc()
oci_fetch_object()
oci_fetch_row()
oci_field_is_null()
oci_field_name()
oci_field_precision()
oci_field_scale()
oci_field_size()
oci_field_type()
oci_field_type_raw()
oci_free_statement()
oci_internal_debug()
oci_lob_copy()
oci_lob_is_equal()
oci_new_collection()
oci_new_connect()
oci_new_cursor()
oci_new_descriptor()
oci_num_fields()
oci_num_rows()
oci_parse()
oci_password_change()
oci_pconnect()
oci_result()
oci_rollback()
oci_server_version()
oci_set_prefetch()
oci_statement_type()
ocibindbyname()
ocicancel()
ocicloselob()
ocicollappend()
ocicollassign()
ocicollassignelem()
ocicollgetelem()
ocicollmax()
ocicollsize()
ocicolltrim()
ocicolumnisnull()
ocicolumnname()
ocicolumnprecision()
ocicolumnscale()
ocicolumnsize()
ocicolumntype()
ocicolumntyperaw()
ocicommit()
ocidefinebyname()
ocierror()
ociexecute()
ocifetch()
ocifetchinto()
ocifetchstatement()
ocifreecollection()
ocifreecursor()
ocifreedesc()
ocifreestatement()
ociinternaldebug()
ociloadlob()
ocilogoff()
ocilogon()
ocinewcollection()
ocinewcursor()
ocinewdescriptor()
ocinlogon()
ocinumcols()
ociparse()
ociplogon()
ociresult()
ocirollback()
ocirowcount()
ocisavelob()
ocisavelobfile()
ociserverversion()
ocisetprefetch()
ocistatementtype()
ociwritelobtofile()
ociwritetemporarylob()
octdec()
odbc_autocommit()
odbc_binmode()
odbc_close()
odbc_close_all()
odbc_columnprivileges()
odbc_columns()
odbc_commit()
odbc_connect()
odbc_cursor()
odbc_data_source()
odbc_do()
odbc_error()
odbc_errormsg()
odbc_exec()
odbc_execute()
odbc_fetch_array()
odbc_fetch_into()
odbc_fetch_object()
odbc_fetch_row()
odbc_field_len()
odbc_field_name()
odbc_field_num()
odbc_field_precision()
odbc_field_scale()
odbc_field_type()
odbc_foreignkeys()
odbc_free_result()
odbc_gettypeinfo()
odbc_longreadlen()
odbc_next_result()
odbc_num_fields()
odbc_num_rows()
odbc_pconnect()
odbc_prepare()
odbc_primarykeys()
odbc_procedurecolumns()
odbc_procedures()
odbc_result()
odbc_result_all()
odbc_rollback()
odbc_setoption()
odbc_specialcolumns()
odbc_statistics()
odbc_tableprivileges()
odbc_tables()
openal_buffer_create()
openal_buffer_data()
openal_buffer_destroy()
openal_buffer_get()
openal_buffer_loadwav()
openal_context_create()
openal_context_current()
openal_context_destroy()
openal_context_process()
openal_context_suspend()
openal_device_close()
openal_device_open()
openal_listener_get()
openal_listener_set()
openal_source_create()
openal_source_destroy()
openal_source_get()
openal_source_pause()
openal_source_play()
openal_source_rewind()
openal_source_set()
openal_source_stop()
openal_stream()
opendir()
openlog()
openssl_csr_export()
openssl_csr_export_to_file()
openssl_csr_get_public_key()
openssl_csr_get_subject()
openssl_csr_new()
openssl_csr_sign()
openssl_error_string()
openssl_free_key()
openssl_get_privatekey()
openssl_get_publickey()
openssl_open()
openssl_pkcs7_decrypt()
openssl_pkcs7_encrypt()
openssl_pkcs7_sign()
openssl_pkcs7_verify()
openssl_pkey_export()
openssl_pkey_export_to_file()
openssl_pkey_free()
openssl_pkey_get_details()
openssl_pkey_get_private()
openssl_pkey_get_public()
openssl_pkey_new()
openssl_private_decrypt()
openssl_private_encrypt()
openssl_public_decrypt()
openssl_public_encrypt()
openssl_seal()
openssl_sign()
openssl_verify()
openssl_x509_check_private_key()
openssl_x509_checkpurpose()
openssl_x509_export()
openssl_x509_export_to_file()
openssl_x509_free()
openssl_x509_parse()
openssl_x509_read()
ora_bind()
ora_close()
ora_columnname()
ora_columnsize()
ora_columntype()
ora_commit()
ora_commitoff()
ora_commiton()
ora_do()
ora_error()
ora_errorcode()
ora_exec()
ora_fetch()
ora_fetch_into()
ora_getcolumn()
ora_logoff()
ora_logon()
ora_numcols()
ora_numrows()
ora_open()
ora_parse()
ora_plogon()
ora_rollback()
orbitenum()
orbitobject()
orbitstruct()
ord()
output_add_rewrite_var()
output_reset_rewrite_vars()
overload()
override_function()
ovrimos_close()
ovrimos_commit()
ovrimos_connect()
ovrimos_cursor()
ovrimos_exec()
ovrimos_execute()
ovrimos_fetch_into()
ovrimos_fetch_row()
ovrimos_field_len()
ovrimos_field_name()
ovrimos_field_num()
ovrimos_field_type()
ovrimos_free_result()
ovrimos_longreadlen()
ovrimos_num_fields()
ovrimos_num_rows()
ovrimos_prepare()
ovrimos_result()
ovrimos_result_all()
ovrimos_rollback()

P

pack()
ParentIterator::getChildren()
ParentIterator::hasChildren()
ParentIterator::next()
ParentIterator::rewind()
parse_ini_file()
parse_str()
parse_url()
parsekit_compile_file()
parsekit_compile_string()
parsekit_func_arginfo()
passthru()
pathinfo()
pclose()
pcntl_alarm()
pcntl_exec()
pcntl_fork()
pcntl_getpriority()
pcntl_setpriority()
pcntl_signal()
pcntl_wait()
pcntl_waitpid()
pcntl_wexitstatus()
pcntl_wifexited()
pcntl_wifsignaled()
pcntl_wifstopped()
pcntl_wstopsig()
pcntl_wtermsig()
pdf_activate_item()
pdf_add_annotation()
pdf_add_bookmark()
pdf_add_launchlink()
pdf_add_locallink()
pdf_add_nameddest()
pdf_add_note()
pdf_add_outline()
pdf_add_pdflink()
pdf_add_table_cell()
pdf_add_textflow()
pdf_add_thumbnail()
pdf_add_weblink()
pdf_arc()
pdf_arcn()
pdf_attach_file()
pdf_begin_document()
pdf_begin_font()
pdf_begin_glyph()
pdf_begin_item()
pdf_begin_layer()
pdf_begin_page()
pdf_begin_page_ext()
pdf_begin_pattern()
pdf_begin_template()
pdf_begin_template_ext()
pdf_circle()
pdf_clip()
pdf_close()
pdf_close_image()
pdf_close_pdi()
pdf_close_pdi_page()
pdf_closepath()
pdf_closepath_fill_stroke()
pdf_closepath_stroke()
pdf_concat()
pdf_continue_text()
pdf_create_3dview()
pdf_create_action()
pdf_create_annotation()
pdf_create_bookmark()
pdf_create_field()
pdf_create_fieldgroup()
pdf_create_gstate()
pdf_create_pvf()
pdf_create_textflow()
pdf_curveto()
pdf_define_layer()
pdf_delete()
pdf_delete_pvf()
pdf_delete_table()
pdf_delete_textflow()
pdf_encoding_set_char()
pdf_end_document()
pdf_end_font()
pdf_end_glyph()
pdf_end_item()
pdf_end_layer()
pdf_end_page()
pdf_end_page_ext()
pdf_end_pattern()
pdf_end_template()
pdf_endpath()
pdf_fill()
pdf_fill_imageblock()
pdf_fill_pdfblock()
pdf_fill_stroke()
pdf_fill_textblock()
pdf_findfont()
pdf_fit_image()
pdf_fit_pdi_page()
pdf_fit_table()
pdf_fit_textflow()
pdf_fit_textline()
pdf_get_apiname()
pdf_get_buffer()
pdf_get_errmsg()
pdf_get_errnum()
pdf_get_font()
pdf_get_fontname()
pdf_get_fontsize()
pdf_get_image_height()
pdf_get_image_width()
pdf_get_majorversion()
pdf_get_minorversion()
pdf_get_parameter()
pdf_get_pdi_parameter()
pdf_get_pdi_value()
pdf_get_value()
pdf_info_font()
pdf_info_matchbox()
pdf_info_table()
pdf_info_textflow()
pdf_info_textline()
pdf_initgraphics()
pdf_lineto()
pdf_load_3ddata()
pdf_load_font()
pdf_load_iccprofile()
pdf_load_image()
pdf_makespotcolor()
pdf_moveto()
pdf_new()
pdf_open_ccitt()
pdf_open_file()
pdf_open_gif()
pdf_open_image()
pdf_open_image_file()
pdf_open_jpeg()
pdf_open_memory_image()
pdf_open_pdi()
pdf_open_pdi_page()
pdf_open_tiff()
pdf_pcos_get_number()
pdf_pcos_get_stream()
pdf_pcos_get_string()
pdf_place_image()
pdf_place_pdi_page()
pdf_process_pdi()
pdf_rect()
pdf_restore()
pdf_resume_page()
pdf_rotate()
pdf_save()
pdf_scale()
pdf_set_border_color()
pdf_set_border_dash()
pdf_set_border_style()
pdf_set_char_spacing()
pdf_set_duration()
pdf_set_gstate()
pdf_set_horiz_scaling()
pdf_set_info()
pdf_set_info_author()
pdf_set_info_creator()
pdf_set_info_keywords()
pdf_set_info_subject()
pdf_set_info_title()
pdf_set_layer_dependency()
pdf_set_leading()
pdf_set_parameter()
pdf_set_text_matrix()
pdf_set_text_pos()
pdf_set_text_rendering()
pdf_set_text_rise()
pdf_set_value()
pdf_set_word_spacing()
pdf_setcolor()
pdf_setdash()
pdf_setdashpattern()
pdf_setflat()
pdf_setfont()
pdf_setgray()
pdf_setgray_fill()
pdf_setgray_stroke()
pdf_setlinecap()
pdf_setlinejoin()
pdf_setlinewidth()
pdf_setmatrix()
pdf_setmiterlimit()
pdf_setpolydash()
pdf_setrgbcolor()
pdf_setrgbcolor_fill()
pdf_setrgbcolor_stroke()
pdf_shading()
pdf_shading_pattern()
pdf_shfill()
pdf_show()
pdf_show_boxed()
pdf_show_xy()
pdf_skew()
pdf_stringwidth()
pdf_stroke()
pdf_suspend_page()
pdf_translate()
pdf_utf16_to_utf8()
pdf_utf32_to_utf16()
pdf_utf8_to_utf16()
PDO->__construct()()
PDO->beginTransaction()()
PDO->commit()()
PDO->errorCode()()
PDO->errorInfo()()
PDO->exec()()
PDO->getAttribute()()
PDO->getAvailableDrivers()()
PDO->lastInsertId()()
PDO->prepare()()
PDO->query()()
PDO->quote()()
PDO->rollBack()()
PDO->setAttribute()()
PDO->sqliteCreateAggregate()()
PDO->sqliteCreateFunction()()
PDO::pgsqlLOBCreate()
PDO::pgsqlLOBOpen()
PDO::pgsqlLOBUnlink()
PDOStatement->bindColumn()()
PDOStatement->bindParam()()
PDOStatement->bindValue()()
PDOStatement->closeCursor()()
PDOStatement->columnCount()()
PDOStatement->errorCode()()
PDOStatement->errorInfo()()
PDOStatement->execute()()
PDOStatement->fetch()()
PDOStatement->fetchAll()()
PDOStatement->fetchColumn()()
PDOStatement->fetchObject()()
PDOStatement->getAttribute()()
PDOStatement->getColumnMeta()()
PDOStatement->nextRowset()()
PDOStatement->rowCount()()
PDOStatement->setAttribute()()
PDOStatement->setFetchMode()()
pfpro_cleanup()
pfpro_init()
pfpro_process()
pfpro_process_raw()
pfpro_version()
pfsockopen()
pg_affected_rows()
pg_cancel_query()
pg_client_encoding()
pg_close()
pg_connect()
pg_connection_busy()
pg_connection_reset()
pg_connection_status()
pg_convert()
pg_copy_from()
pg_copy_to()
pg_dbname()
pg_delete()
pg_end_copy()
pg_escape_bytea()
pg_escape_string()
pg_execute()
pg_fetch_all()
pg_fetch_all_columns()
pg_fetch_array()
pg_fetch_assoc()
pg_fetch_object()
pg_fetch_result()
pg_fetch_row()
pg_field_is_null()
pg_field_name()
pg_field_num()
pg_field_prtlen()
pg_field_size()
pg_field_table()
pg_field_type()
pg_field_type_oid()
pg_free_result()
pg_get_notify()
pg_get_pid()
pg_get_result()
pg_host()
pg_insert()
pg_last_error()
pg_last_notice()
pg_last_oid()
pg_lo_close()
pg_lo_create()
pg_lo_export()
pg_lo_import()
pg_lo_open()
pg_lo_read()
pg_lo_read_all()
pg_lo_seek()
pg_lo_tell()
pg_lo_unlink()
pg_lo_write()
pg_meta_data()
pg_num_fields()
pg_num_rows()
pg_options()
pg_parameter_status()
pg_pconnect()
pg_ping()
pg_port()
pg_prepare()
pg_put_line()
pg_query()
pg_query_params()
pg_result_error()
pg_result_error_field()
pg_result_seek()
pg_result_status()
pg_select()
pg_send_execute()
pg_send_prepare()
pg_send_query()
pg_send_query_params()
pg_set_client_encoding()
pg_set_error_verbosity()
pg_trace()
pg_transaction_status()
pg_tty()
pg_unescape_bytea()
pg_untrace()
pg_update()
pg_version()
Phar->compressAllFilesBZIP2()
Phar->compressAllFilesGZ()
Phar->count()
Phar->getMetaData()
Phar->getModified()
Phar->getSignature()
Phar->getStub()
Phar->getVersion()
Phar->isBuffering()
Phar->setMetaData()
Phar->setStub()
Phar->startBuffering()
Phar->stopBuffering()
Phar->uncompressAllFiles()
Phar::__construct()
Phar::apiVersion()
Phar::canCompress()
Phar::canWrite()
Phar::loadPhar()
Phar::mapPhar()
Phar::offsetExists()
Phar::offsetGet()
Phar::offsetSet()
Phar::offsetUnset()
PharFileInfo->chmod()
PharFileInfo->getCompressedSize()
PharFileInfo->getCRC32()
PharFileInfo->getMetaData()
PharFileInfo->getPharFlags()
PharFileInfo->isCompressed()
PharFileInfo->isCompressedBZIP2()
PharFileInfo->isCompressedGZ()
PharFileInfo->isCRCChecked()
PharFileInfo->setCompressedBZIP2()
PharFileInfo->setCompressedGZ()
PharFileInfo->setMetaData()
PharFileInfo->setUncompressed()
PharFileInfo::__construct()
php_check_syntax()
php_ini_scanned_files()
php_logo_guid()
php_sapi_name()
php_strip_whitespace()
php_uname()
phpcredits()
phpinfo()
phpversion()
pi()
png2wbmp()
popen()
pos()
posix_access()
posix_ctermid()
posix_get_last_error()
posix_getcwd()
posix_getegid()
posix_geteuid()
posix_getgid()
posix_getgrgid()
posix_getgrnam()
posix_getgroups()
posix_getlogin()
posix_getpgid()
posix_getpgrp()
posix_getpid()
posix_getppid()
posix_getpwnam()
posix_getpwuid()
posix_getrlimit()
posix_getsid()
posix_getuid()
posix_initgroups()
posix_isatty()
posix_kill()
posix_mkfifo()
posix_mknod()
posix_setegid()
posix_seteuid()
posix_setgid()
posix_setpgid()
posix_setsid()
posix_setuid()
posix_strerror()
posix_times()
posix_ttyname()
posix_uname()
pow()
preg_grep()
preg_last_error()
preg_match()
preg_match_all()
preg_quote()
preg_replace()
preg_replace_callback()
preg_split()
prev()
print()
print_r()
printer_abort()
printer_close()
printer_create_brush()
printer_create_dc()
printer_create_font()
printer_create_pen()
printer_delete_brush()
printer_delete_dc()
printer_delete_font()
printer_delete_pen()
printer_draw_bmp()
printer_draw_chord()
printer_draw_elipse()
printer_draw_line()
printer_draw_pie()
printer_draw_rectangle()
printer_draw_roundrect()
printer_draw_text()
printer_end_doc()
printer_end_page()
printer_get_option()
printer_list()
printer_logical_fontheight()
printer_open()
printer_select_brush()
printer_select_font()
printer_select_pen()
printer_set_option()
printer_start_doc()
printer_start_page()
printer_write()
printf()
proc_close()
proc_get_status()
proc_nice()
proc_open()
proc_terminate()
property_exists()
ps_add_bookmark()
ps_add_launchlink()
ps_add_locallink()
ps_add_note()
ps_add_pdflink()
ps_add_weblink()
ps_arc()
ps_arcn()
ps_begin_page()
ps_begin_pattern()
ps_begin_template()
ps_circle()
ps_clip()
ps_close()
ps_close_image()
ps_closepath()
ps_closepath_stroke()
ps_continue_text()
ps_curveto()
ps_delete()
ps_end_page()
ps_end_pattern()
ps_end_template()
ps_fill()
ps_fill_stroke()
ps_findfont()
ps_get_buffer()
ps_get_parameter()
ps_get_value()
ps_hyphenate()
ps_include_file()
ps_lineto()
ps_makespotcolor()
ps_moveto()
ps_new()
ps_open_file()
ps_open_image()
ps_open_image_file()
ps_open_memory_image()
ps_place_image()
ps_rect()
ps_restore()
ps_rotate()
ps_save()
ps_scale()
ps_set_border_color()
ps_set_border_dash()
ps_set_border_style()
ps_set_info()
ps_set_parameter()
ps_set_text_pos()
ps_set_value()
ps_setcolor()
ps_setdash()
ps_setflat()
ps_setfont()
ps_setgray()
ps_setlinecap()
ps_setlinejoin()
ps_setlinewidth()
ps_setmiterlimit()
ps_setoverprintmode()
ps_setpolydash()
ps_shading()
ps_shading_pattern()
ps_shfill()
ps_show()
ps_show2()
ps_show_boxed()
ps_show_xy()
ps_show_xy2()
ps_string_geometry()
ps_stringwidth()
ps_stroke()
ps_symbol()
ps_symbol_name()
ps_symbol_width()
ps_translate()
pspell_add_to_personal()
pspell_add_to_session()
pspell_check()
pspell_clear_session()
pspell_config_create()
pspell_config_data_dir()
pspell_config_dict_dir()
pspell_config_ignore()
pspell_config_mode()
pspell_config_personal()
pspell_config_repl()
pspell_config_runtogether()
pspell_config_save_repl()
pspell_new()
pspell_new_config()
pspell_new_personal()
pspell_save_wordlist()
pspell_store_replacement()
pspell_suggest()
putenv()
px_close()
px_create_fp()
px_date2string()
px_delete()
px_delete_record()
px_get_field()
px_get_info()
px_get_parameter()
px_get_record()
px_get_schema()
px_get_value()
px_insert_record()
px_new()
px_numfields()
px_numrecords()
px_open_fp()
px_put_record()
px_retrieve_record()
px_set_blob_file()
px_set_parameter()
px_set_tablename()
px_set_targetencoding()
px_set_value()
px_timestamp2string()
px_update_record()

Q

qdom_error()
qdom_tree()
quoted_printable_decode()
quotemeta()

R

rad2deg()
radius_acct_open()
radius_add_server()
radius_auth_open()
radius_close()
radius_config()
radius_create_request()
radius_cvt_addr()
radius_cvt_int()
radius_cvt_string()
radius_demangle()
radius_demangle_mppe_key()
radius_get_attr()
radius_get_vendor_attr()
radius_put_addr()
radius_put_attr()
radius_put_int()
radius_put_string()
radius_put_vendor_addr()
radius_put_vendor_attr()
radius_put_vendor_int()
radius_put_vendor_string()
radius_request_authenticator()
radius_send_request()
radius_server_secret()
radius_strerror()
rand()
range()
Rar::extract()
Rar::getAttr()
Rar::getCrc()
Rar::getFileTime()
Rar::getHostOs()
Rar::getMethod()
Rar::getName()
Rar::getPackedSize()
Rar::getUnpackedSize()
Rar::getVersion()
rar_close()
rar_entry_get()
rar_list()
rar_open()
rawurldecode()
rawurlencode()
read_exif_data()
readdir()
readfile()
readgzfile()
readline()
readline_add_history()
readline_callback_handler_install()
readline_callback_handler_remove()
readline_callback_read_char()
readline_clear_history()
readline_completion_function()
readline_info()
readline_list_history()
readline_on_new_line()
readline_read_history()
readline_redisplay()
readline_write_history()
readlink()
realpath()
recode()
recode_file()
recode_string()
RecursiveDirectoryIterator::getChildren()
RecursiveDirectoryIterator::hasChildren()
RecursiveDirectoryIterator::key()
RecursiveDirectoryIterator::next()
RecursiveDirectoryIterator::rewind()
RecursiveIteratorIterator::current()
RecursiveIteratorIterator::getDepth()
RecursiveIteratorIterator::getSubIterator()
RecursiveIteratorIterator::key()
RecursiveIteratorIterator::next()
RecursiveIteratorIterator::rewind()
RecursiveIteratorIterator::valid()
register_shutdown_function()
register_tick_function()
rename()
rename_function()
reset()
resources()
restore_error_handler()
restore_exception_handler()
restore_include_path()
result->current_field()
result->current_field()
result->data_seek()
result->data_seek()()
result->fetch_array()
result->fetch_array()()
result->fetch_field()
result->fetch_field()()
result->fetch_field_direct()
result->fetch_field_direct()()
result->fetch_fields()
result->fetch_fields()()
result->fetch_object()
result->fetch_object()()
result->fetch_row()
result->fetch_row()()
result->field_count()
result->field_count()
result->field_seek()
result->field_seek()()
result->free()
result->free()()
result->lengths()
result->lengths()()
result->num_rows()
rewind()
rewinddir()
rmdir()
round()
rpm_close()
rpm_get_tag()
rpm_is_valid()
rpm_open()
rpm_version()
rsort()
rtrim()
runkit_class_adopt()
runkit_class_emancipate()
runkit_constant_add()
runkit_constant_redefine()
runkit_constant_remove()
runkit_function_add()
runkit_function_copy()
runkit_function_redefine()
runkit_function_remove()
runkit_function_rename()
runkit_import()
runkit_lint()
runkit_lint_file()
runkit_method_add()
runkit_method_copy()
runkit_method_redefine()
runkit_method_remove()
runkit_method_rename()
runkit_return_value_used()
runkit_sandbox()
runkit_sandbox_output_handler()
runkit_sandbox_parent()
runkit_superglobals()

S

SAMConnection->__construct()()
SAMConnection->commit()()
SAMConnection->connect()()
SAMConnection->disconnect()()
SAMConnection->errno()
SAMConnection->error()
SAMConnection->isConnected()()
SAMConnection->peek()()
SAMConnection->peekAll()()
SAMConnection->receive()()
SAMConnection->remove()()
SAMConnection->rollback()()
SAMConnection->send()()
SAMConnection->subscribe()()
SAMConnection->unsubscribe()()
SAMConnection::setDebug()()
SAMMessage->__construct()()
SAMMessage->body()
SAMMessage->header()
satellite_caught_exception()
satellite_exception_id()
satellite_exception_value()
satellite_get_repository_id()
satellite_load_idl()
satellite_object_to_string()
SCA::createDataObject()
SCA::getService()
SCA_LocalProxy::createDataObject()
SCA_SoapProxy::createDataObject()
scandir()
SDO_DAS_ChangeSummary::beginLogging()
SDO_DAS_ChangeSummary::endLogging()
SDO_DAS_ChangeSummary::getChangedDataObjects()
SDO_DAS_ChangeSummary::getChangeType()
SDO_DAS_ChangeSummary::getOldContainer()
SDO_DAS_ChangeSummary::getOldValues()
SDO_DAS_ChangeSummary::isLogging()
SDO_DAS_DataFactory::addPropertyToType()
SDO_DAS_DataFactory::addType()
SDO_DAS_DataFactory::getDataFactory()
SDO_DAS_DataObject::getChangeSummary()
SDO_DAS_Relational::__construct()
SDO_DAS_Relational::applyChanges()
SDO_DAS_Relational::createRootDataObject()
SDO_DAS_Relational::executePreparedQuery()
SDO_DAS_Relational::executeQuery()
SDO_DAS_Setting::getListIndex()
SDO_DAS_Setting::getPropertyIndex()
SDO_DAS_Setting::getPropertyName()
SDO_DAS_Setting::getValue()
SDO_DAS_Setting::isSet()
SDO_DAS_XML::addTypes()
SDO_DAS_XML::create()
SDO_DAS_XML::createDataObject()
SDO_DAS_XML::createDocument()
SDO_DAS_XML::loadFile()
SDO_DAS_XML::loadString()
SDO_DAS_XML::saveFile()
SDO_DAS_XML::saveString()
SDO_DAS_XML_Document::getRootDataObject()
SDO_DAS_XML_Document::getRootElementName()
SDO_DAS_XML_Document::getRootElementURI()
SDO_DAS_XML_Document::setEncoding()
SDO_DAS_XML_Document::setXMLDeclaration()
SDO_DAS_XML_Document::setXMLVersion()
SDO_DataFactory::create()
SDO_DataObject::clear()
SDO_DataObject::createDataObject()
SDO_DataObject::getContainer()
SDO_DataObject::getSequence()
SDO_DataObject::getTypeName()
SDO_DataObject::getTypeNamespaceURI()
SDO_Exception::getCause()
SDO_List::insert()
SDO_Model_Property::getContainingType()
SDO_Model_Property::getDefault()
SDO_Model_Property::getName()
SDO_Model_Property::getType()
SDO_Model_Property::isContainment()
SDO_Model_Property::isMany()
SDO_Model_ReflectionDataObject::__construct()
SDO_Model_ReflectionDataObject::export()
SDO_Model_ReflectionDataObject::getContainmentProperty()
SDO_Model_ReflectionDataObject::getInstanceProperties()
SDO_Model_ReflectionDataObject::getType()
SDO_Model_Type::getBaseType()
SDO_Model_Type::getName()
SDO_Model_Type::getNamespaceURI()
SDO_Model_Type::getProperties()
SDO_Model_Type::getProperty()
SDO_Model_Type::isAbstractType()
SDO_Model_Type::isDataType()
SDO_Model_Type::isInstance()
SDO_Model_Type::isOpenType()
SDO_Model_Type::isSequencedType()
SDO_Sequence::getProperty()
SDO_Sequence::insert()
SDO_Sequence::move()
sem_acquire()
sem_get()
sem_release()
sem_remove()
serialize()
sesam_affected_rows()
sesam_commit()
sesam_connect()
sesam_diagnostic()
sesam_disconnect()
sesam_errormsg()
sesam_execimm()
sesam_fetch_array()
sesam_fetch_result()
sesam_fetch_row()
sesam_field_array()
sesam_field_name()
sesam_free_result()
sesam_num_fields()
sesam_query()
sesam_rollback()
sesam_seek_row()
sesam_settransaction()
session_cache_expire()
session_cache_limiter()
session_commit()
session_decode()
session_destroy()
session_encode()
session_get_cookie_params()
session_id()
session_is_registered()
session_module_name()
session_name()
session_pgsql_add_error()
session_pgsql_get_error()
session_pgsql_get_field()
session_pgsql_reset()
session_pgsql_set_field()
session_pgsql_status()
session_regenerate_id()
session_register()
session_save_path()
session_set_cookie_params()
session_set_save_handler()
session_start()
session_unregister()
session_unset()
session_write_close()
set_error_handler()
set_exception_handler()
set_file_buffer()
set_include_path()
set_magic_quotes_runtime()
set_time_limit()
setcookie()
setlocale()
setrawcookie()
settype()
sha1()
sha1_file()
shell_exec()
shm_attach()
shm_detach()
shm_get_var()
shm_put_var()
shm_remove()
shm_remove_var()
shmop_close()
shmop_delete()
shmop_open()
shmop_read()
shmop_size()
shmop_write()
show_source()
shuffle()
similar_text()
simplexml_import_dom()
simplexml_load_file()
simplexml_load_string()
SimpleXMLElement->__construct()()
SimpleXMLElement->addAttribute()()
SimpleXMLElement->addChild()()
SimpleXMLElement->asXML()()
SimpleXMLElement->attributes()()
SimpleXMLElement->children()()
SimpleXMLElement->getDocNamespaces()()
SimpleXMLElement->getName()()
SimpleXMLElement->getNamespaces()()
SimpleXMLElement->registerXPathNamespace()()
SimpleXMLElement->xpath()()
SimpleXMLIterator::current()
SimpleXMLIterator::getChildren()
SimpleXMLIterator::hasChildren()
SimpleXMLIterator::key()
SimpleXMLIterator::next()
SimpleXMLIterator::rewind()
SimpleXMLIterator::valid()
sin()
sinh()
sizeof()
sleep()
snmp_get_quick_print()
snmp_get_valueretrieval()
snmp_read_mib()
snmp_set_enum_print()
snmp_set_oid_numeric_print()
snmp_set_oid_output_format()
snmp_set_quick_print()
snmp_set_valueretrieval()
snmpget()
snmpgetnext()
snmprealwalk()
snmpset()
snmpwalk()
snmpwalkoid()
SoapClient->__call()()
SoapClient->__construct()()
SoapClient->__doRequest()()
SoapClient->__getFunctions()()
SoapClient->__getLastRequest()()
SoapClient->__getLastRequestHeaders()()
SoapClient->__getLastResponse()()
SoapClient->__getLastResponseHeaders()()
SoapClient->__getTypes()()
SoapClient->__setCookie()()
SoapClient->__soapCall()()
SoapFault->__construct()()
SoapHeader->__construct()()
SoapParam->__construct()()
SoapServer->__construct()()
SoapServer->addFunction()()
SoapServer->fault()()
SoapServer->getFunctions()()
SoapServer->handle()()
SoapServer->setClass()()
SoapServer->setPersistence()()
SoapVar->__construct()()
socket_accept()
socket_bind()
socket_clear_error()
socket_close()
socket_connect()
socket_create()
socket_create_listen()
socket_create_pair()
socket_get_option()
socket_get_status()
socket_getpeername()
socket_getsockname()
socket_last_error()
socket_listen()
socket_read()
socket_recv()
socket_recvfrom()
socket_select()
socket_send()
socket_sendto()
socket_set_block()
socket_set_blocking()
socket_set_nonblock()
socket_set_option()
socket_set_timeout()
socket_shutdown()
socket_strerror()
socket_write()
sort()
soundex()
spl_autoload()
spl_autoload_call()
spl_autoload_extensions()
spl_autoload_functions()
spl_autoload_register()
spl_autoload_unregister()
spl_classes()
spl_object_hash()
split()
spliti()
sprintf()
sql_regcase()
sqlite_array_query()
sqlite_busy_timeout()
sqlite_changes()
sqlite_close()
sqlite_column()
sqlite_create_aggregate()
sqlite_create_function()
sqlite_current()
sqlite_error_string()
sqlite_escape_string()
sqlite_exec()
sqlite_factory()
sqlite_fetch_all()
sqlite_fetch_array()
sqlite_fetch_column_types()
sqlite_fetch_object()
sqlite_fetch_single()
sqlite_fetch_string()
sqlite_field_name()
sqlite_has_more()
sqlite_has_prev()
sqlite_key()
sqlite_last_error()
sqlite_last_insert_rowid()
sqlite_libencoding()
sqlite_libversion()
sqlite_next()
sqlite_num_fields()
sqlite_num_rows()
sqlite_open()
sqlite_popen()
sqlite_prev()
sqlite_query()
sqlite_rewind()
sqlite_seek()
sqlite_single_query()
sqlite_udf_decode_binary()
sqlite_udf_encode_binary()
sqlite_unbuffered_query()
sqlite_valid()
SQLiteDatabase->arrayQuery()
SQLiteDatabase->busyTimeout()
SQLiteDatabase->changes()
SQLiteDatabase->createAggregate()
SQLiteDatabase->createFunction()
SQLiteDatabase->exec()
SQLiteDatabase->fetchColumnTypes()
SQLiteDatabase->lastError()
SQLiteDatabase->lastInsertRowid()
SQLiteDatabase->query()
SQLiteDatabase->singleQuery()
SQLiteDatabase->unbufferedQuery()
SQLiteResult->column()
SQLiteResult->current()
SQLiteResult->fetch()
SQLiteResult->fetchAll()
SQLiteResult->fetchObject()
SQLiteResult->fetchSingle()
SQLiteResult->fieldName()
SQLiteResult->hasPrev()
SQLiteResult->key()
SQLiteResult->next()
SQLiteResult->numFields()
SQLiteResult->numRows()
SQLiteResult->prev()
SQLiteResult->rewind()
SQLiteResult->seek()
SQLiteResult->valid()
SQLiteUnbuffered->column()
SQLiteUnbuffered->current()
SQLiteUnbuffered->fetch()
SQLiteUnbuffered->fetchAll()
SQLiteUnbuffered->fetchObject()
SQLiteUnbuffered->fetchSingle()
SQLiteUnbuffered->fieldName()
SQLiteUnbuffered->next()
SQLiteUnbuffered->numFields()
SQLiteUnbuffered->valid()
sqrt()
srand()
sscanf()
ssh2_auth_hostbased_file()
ssh2_auth_none()
ssh2_auth_password()
ssh2_auth_pubkey_file()
ssh2_connect()
ssh2_exec()
ssh2_fetch_stream()
ssh2_fingerprint()
ssh2_methods_negotiated()
ssh2_publickey_add()
ssh2_publickey_init()
ssh2_publickey_list()
ssh2_publickey_remove()
ssh2_scp_recv()
ssh2_scp_send()
ssh2_sftp()
ssh2_sftp_lstat()
ssh2_sftp_mkdir()
ssh2_sftp_readlink()
ssh2_sftp_realpath()
ssh2_sftp_rename()
ssh2_sftp_rmdir()
ssh2_sftp_stat()
ssh2_sftp_symlink()
ssh2_sftp_unlink()
ssh2_shell()
ssh2_tunnel()
stat()
stats_absolute_deviation()
stats_cdf_beta()
stats_cdf_binomial()
stats_cdf_cauchy()
stats_cdf_chisquare()
stats_cdf_exponential()
stats_cdf_f()
stats_cdf_gamma()
stats_cdf_laplace()
stats_cdf_logistic()
stats_cdf_negative_binomial()
stats_cdf_noncentral_chisquare()
stats_cdf_noncentral_f()
stats_cdf_poisson()
stats_cdf_t()
stats_cdf_uniform()
stats_cdf_weibull()
stats_covariance()
stats_den_uniform()
stats_dens_beta()
stats_dens_cauchy()
stats_dens_chisquare()
stats_dens_exponential()
stats_dens_f()
stats_dens_gamma()
stats_dens_laplace()
stats_dens_logistic()
stats_dens_negative_binomial()
stats_dens_normal()
stats_dens_pmf_binomial()
stats_dens_pmf_hypergeometric()
stats_dens_pmf_poisson()
stats_dens_t()
stats_dens_weibull()
stats_harmonic_mean()
stats_kurtosis()
stats_rand_gen_beta()
stats_rand_gen_chisquare()
stats_rand_gen_exponential()
stats_rand_gen_f()
stats_rand_gen_funiform()
stats_rand_gen_gamma()
stats_rand_gen_ibinomial()
stats_rand_gen_ibinomial_negative()
stats_rand_gen_int()
stats_rand_gen_ipoisson()
stats_rand_gen_iuniform()
stats_rand_gen_noncenral_chisquare()
stats_rand_gen_noncentral_f()
stats_rand_gen_noncentral_t()
stats_rand_gen_normal()
stats_rand_gen_t()
stats_rand_get_seeds()
stats_rand_phrase_to_seeds()
stats_rand_ranf()
stats_rand_setall()
stats_skew()
stats_standard_deviation()
stats_stat_binomial_coef()
stats_stat_correlation()
stats_stat_gennch()
stats_stat_independent_t()
stats_stat_innerproduct()
stats_stat_noncentral_t()
stats_stat_paired_t()
stats_stat_percentile()
stats_stat_powersum()
stats_variance()
stmt->bind_param()
stmt->bind_param()()
stmt->bind_result()
stmt->bind_result()()
stmt->close_long_data()
stmt->data_seek()
stmt->data_seek()()
stmt->execute()
stmt->execute()()
stmt->fetch()
stmt->fetch()()
stmt->free_result()
stmt->free_result()()
stmt->num_rows()
stmt->num_rows()
stmt->param_count()
stmt->param_count()
stmt->prepare()
stmt->prepare()()
stmt->reset()
stmt->reset()()
stmt->result_metadata()()
stmt->send_long_data()
stmt->send_long_data()()
str_getcsv()
str_ireplace()
str_pad()
str_repeat()
str_replace()
str_rot13()
str_shuffle()
str_split()
str_word_count()
strcasecmp()
strchr()
strcmp()
strcoll()
strcspn()
stream_bucket_append()
stream_bucket_make_writeable()
stream_bucket_new()
stream_bucket_prepend()
stream_context_create()
stream_context_get_default()
stream_context_get_options()
stream_context_set_option()
stream_context_set_params()
stream_copy_to_stream()
stream_encoding()
stream_filter_append()
stream_filter_prepend()
stream_filter_register()
stream_filter_remove()
stream_get_contents()
stream_get_filters()
stream_get_line()
stream_get_meta_data()
stream_get_transports()
stream_get_wrappers()
stream_register_wrapper()
stream_resolve_include_path()
stream_select()
stream_set_blocking()
stream_set_timeout()
stream_set_write_buffer()
stream_socket_accept()
stream_socket_client()
stream_socket_enable_crypto()
stream_socket_get_name()
stream_socket_pair()
stream_socket_recvfrom()
stream_socket_sendto()
stream_socket_server()
stream_socket_shutdown()
stream_wrapper_register()
stream_wrapper_restore()
stream_wrapper_unregister()
strftime()
strip_tags()
stripcslashes()
stripos()
stripslashes()
stristr()
strlen()
strnatcasecmp()
strnatcmp()
strncasecmp()
strncmp()
strpbrk()
strpos()
strptime()
strrchr()
strrev()
strripos()
strrpos()
strspn()
strstr()
strtok()
strtolower()
strtotime()
strtoupper()
strtr()
strval()
substr()
substr_compare()
substr_count()
substr_replace()
svn_add()
svn_auth_get_parameter()
svn_auth_set_parameter()
svn_cat()
svn_checkout()
svn_cleanup()
svn_client_version()
svn_commit()
svn_diff()
svn_fs_abort_txn()
svn_fs_apply_text()
svn_fs_begin_txn2()
svn_fs_change_node_prop()
svn_fs_check_path()
svn_fs_contents_changed()
svn_fs_copy()
svn_fs_delete()
svn_fs_dir_entries()
svn_fs_file_contents()
svn_fs_file_length()
svn_fs_is_dir()
svn_fs_is_file()
svn_fs_make_dir()
svn_fs_make_file()
svn_fs_node_created_rev()
svn_fs_node_prop()
svn_fs_props_changed()
svn_fs_revision_prop()
svn_fs_revision_root()
svn_fs_txn_root()
svn_fs_youngest_rev()
svn_import()
svn_log()
svn_ls()
svn_repos_create()
svn_repos_fs()
svn_repos_fs_begin_txn_for_commit()
svn_repos_fs_commit_txn()
svn_repos_hotcopy()
svn_repos_open()
svn_repos_recover()
svn_status()
svn_update()
swf_actiongeturl()
swf_actiongotoframe()
swf_actiongotolabel()
swf_actionnextframe()
swf_actionplay()
swf_actionprevframe()
swf_actionsettarget()
swf_actionstop()
swf_actiontogglequality()
swf_actionwaitforframe()
swf_addbuttonrecord()
swf_addcolor()
swf_closefile()
swf_definebitmap()
swf_definefont()
swf_defineline()
swf_definepoly()
swf_definerect()
swf_definetext()
swf_endbutton()
swf_enddoaction()
swf_endshape()
swf_endsymbol()
swf_fontsize()
swf_fontslant()
swf_fonttracking()
swf_getbitmapinfo()
swf_getfontinfo()
swf_getframe()
swf_labelframe()
swf_lookat()
swf_modifyobject()
swf_mulcolor()
swf_nextid()
swf_oncondition()
swf_openfile()
swf_ortho()
swf_ortho2()
swf_perspective()
swf_placeobject()
swf_polarview()
swf_popmatrix()
swf_posround()
swf_pushmatrix()
swf_removeobject()
swf_rotate()
swf_scale()
swf_setfont()
swf_setframe()
swf_shapearc()
swf_shapecurveto()
swf_shapecurveto3()
swf_shapefillbitmapclip()
swf_shapefillbitmaptile()
swf_shapefilloff()
swf_shapefillsolid()
swf_shapelinesolid()
swf_shapelineto()
swf_shapemoveto()
swf_showframe()
swf_startbutton()
swf_startdoaction()
swf_startshape()
swf_startsymbol()
swf_textwidth()
swf_translate()
swf_viewport()
swfaction()
SWFAction->__construct()()
swfbitmap()
SWFBitmap->__construct()()
SWFBitmap->getHeight()()
SWFBitmap->getWidth()()
swfbutton()
SWFButton->__construct()()
SWFButton->addAction()()
SWFButton->addASound()()
SWFButton->addShape()()
SWFButton->setAction()()
SWFButton->setDown()()
SWFButton->setHit()()
SWFButton->setMenu()()
SWFButton->setOver()()
SWFButton->setUp()()
swfdisplayitem()
SWFDisplayItem->addAction()()
SWFDisplayItem->addColor()()
SWFDisplayItem->endMask()()
SWFDisplayItem->getRot()()
SWFDisplayItem->getX()()
SWFDisplayItem->getXScale()()
SWFDisplayItem->getXSkew()()
SWFDisplayItem->getY()()
SWFDisplayItem->getYScale()()
SWFDisplayItem->getYSkew()()
SWFDisplayItem->move()()
SWFDisplayItem->moveTo()()
SWFDisplayItem->multColor()()
SWFDisplayItem->remove()()
SWFDisplayItem->rotate()()
SWFDisplayItem->rotateTo()()
SWFDisplayItem->scale()()
SWFDisplayItem->scaleTo()()
SWFDisplayItem->setDepth()()
SWFDisplayItem->setMaskLevel()()
SWFDisplayItem->setMatrix()()
SWFDisplayItem->setName()()
SWFDisplayItem->setRatio()()
SWFDisplayItem->skewX()()
SWFDisplayItem->skewXTo()()
SWFDisplayItem->skewY()()
SWFDisplayItem->skewYTo()()
swffill()
SWFFill->moveTo()()
SWFFill->rotateTo()()
SWFFill->scaleTo()()
SWFFill->skewXTo()()
SWFFill->skewYTo()()
swffont()
SWFFont->__construct()()
SWFFont->getAscent()()
SWFFont->getDescent()()
SWFFont->getLeading()()
SWFFont->getShape()()
SWFFont->getUTF8Width()()
SWFFont->getWidth()()
swffontchar()
SWFFontChar->addChars()()
SWFFontChar->addUTF8Chars()()
swfgradient()
SWFGradient->__construct()()
SWFGradient->addEntry()()
swfmorph()
SWFMorph->__construct()()
SWFMorph->getShape1()()
SWFMorph->getShape2()()
swfmovie()
SWFMovie->__construct()()
SWFMovie->add()()
SWFMovie->addExport()()
SWFMovie->addFont()()
SWFMovie->importChar()()
SWFMovie->importFont()()
SWFMovie->labelFrame()()
SWFMovie->nextFrame()()
SWFMovie->output()()
SWFMovie->remove()()
SWFMovie->save()()
SWFMovie->saveToFile()()
SWFMovie->setbackground()()
SWFMovie->setDimension()()
SWFMovie->setFrames()()
SWFMovie->setRate()()
SWFMovie->startSound()()
SWFMovie->stopSound()()
SWFMovie->streamMP3()()
SWFMovie->writeExports()()
swfprebuiltclip()
SWFPrebuiltClip->__construct()()
swfshape()
SWFShape->__construct()()
SWFShape->addFill()()
SWFShape->drawArc()()
SWFShape->drawCircle()()
SWFShape->drawCubic()()
SWFShape->drawCubicTo()()
SWFShape->drawCurve()()
SWFShape->drawCurveTo()()
SWFShape->drawGlyph()()
SWFShape->drawLine()()
SWFShape->drawLineTo()()
SWFShape->movePen()()
SWFShape->movePenTo()()
SWFShape->setLeftFill()()
SWFShape->setLine()()
SWFShape->setRightFill()()
swfsound()
swfsound()
swfsoundinstance()
SWFSoundInstance->loopCount()()
SWFSoundInstance->loopInPoint()()
SWFSoundInstance->loopOutPoint()()
SWFSoundInstance->noMultiple()()
swfsprite()
SWFSprite->__construct()()
SWFSprite->add()()
SWFSprite->labelFrame()()
SWFSprite->nextFrame()()
SWFSprite->remove()()
SWFSprite->setFrames()()
SWFSprite->startSound()()
SWFSprite->stopSound()()
swftext()
SWFText->__construct()()
SWFText->addString()()
SWFText->addUTF8String()()
SWFText->getAscent()()
SWFText->getDescent()()
SWFText->getLeading()()
SWFText->getUTF8Width()()
SWFText->getWidth()()
SWFText->moveTo()()
SWFText->setColor()()
SWFText->setFont()()
SWFText->setHeight()()
SWFText->setSpacing()()
swftextfield()
SWFTextField->__construct()()
SWFTextField->addChars()()
SWFTextField->addString()()
SWFTextField->align()()
SWFTextField->setBounds()()
SWFTextField->setColor()()
SWFTextField->setFont()()
SWFTextField->setHeight()()
SWFTextField->setIndentation()()
SWFTextField->setLeftMargin()()
SWFTextField->setLineSpacing()()
SWFTextField->setMargins()()
SWFTextField->setName()()
SWFTextField->setPadding()()
SWFTextField->setRightMargin()()
swfvideostream()
SWFVideoStream->__construct()()
SWFVideoStream->getNumFrames()()
SWFVideoStream->setDimension()()
Swish->getMetaList()
Swish->getPropertyList()
Swish->prepare()
Swish->query()
Swish::__construct()
SwishResult->getMetaList()
SwishResult->stem()
SwishResults->getParsedWords()
SwishResults->getRemovedStopwords()
SwishResults->nextResult()
SwishResults->seekResult()
SwishSearch->execute()
SwishSearch->resetLimit()
SwishSearch->setLimit()
SwishSearch->setPhraseDelimiter()
SwishSearch->setSort()
SwishSearch->setStructure()
sybase_affected_rows()
sybase_close()
sybase_connect()
sybase_data_seek()
sybase_deadlock_retry_count()
sybase_fetch_array()
sybase_fetch_assoc()
sybase_fetch_field()
sybase_fetch_object()
sybase_fetch_row()
sybase_field_seek()
sybase_free_result()
sybase_get_last_message()
sybase_min_client_severity()
sybase_min_error_severity()
sybase_min_message_severity()
sybase_min_server_severity()
sybase_num_fields()
sybase_num_rows()
sybase_pconnect()
sybase_query()
sybase_result()
sybase_select_db()
sybase_set_message_handler()
sybase_unbuffered_query()
symlink()
sys_get_temp_dir()
sys_getloadavg()
syslog()
system()

T

tan()
tanh()
tcpwrap_check()
tempnam()
textdomain()
tidy::__construct()
tidy_access_count()
tidy_clean_repair()
tidy_config_count()
tidy_diagnose()
tidy_error_count()
tidy_get_body()
tidy_get_config()
tidy_get_error_buffer()
tidy_get_head()
tidy_get_html()
tidy_get_html_ver()
tidy_get_opt_doc()
tidy_get_output()
tidy_get_release()
tidy_get_root()
tidy_get_status()
tidy_getopt()
tidy_is_xhtml()
tidy_is_xml()
tidy_load_config()
tidy_node->get_attr()
tidy_node->get_nodes()
tidy_node->next()
tidy_node->prev()
tidy_parse_file()
tidy_parse_string()
tidy_repair_file()
tidy_repair_string()
tidy_reset_config()
tidy_save_config()
tidy_set_encoding()
tidy_setopt()
tidy_warning_count()
tidyNode->hasChildren()
tidyNode->hasSiblings()
tidyNode->isAsp()
tidyNode->isComment()
tidyNode->isHtml()
tidyNode->isJste()
tidyNode->isPhp()
tidyNode->isText()
tidyNode::getParent()
time()
time_nanosleep()
time_sleep_until()
timezone_abbreviations_list()
timezone_identifiers_list()
timezone_name_from_abbr()
timezone_name_get()
timezone_offset_get()
timezone_open()
timezone_transitions_get()
tmpfile()
token_get_all()
token_name()
touch()
trigger_error()
trim()

U

uasort()
ucfirst()
ucwords()
udm_add_search_limit()
udm_alloc_agent()
udm_alloc_agent_array()
udm_api_version()
udm_cat_list()
udm_cat_path()
udm_check_charset()
udm_check_stored()
udm_clear_search_limits()
udm_close_stored()
udm_crc32()
udm_errno()
udm_error()
udm_find()
udm_free_agent()
udm_free_ispell_data()
udm_free_res()
udm_get_doc_count()
udm_get_res_field()
udm_get_res_param()
udm_hash32()
udm_load_ispell_data()
udm_open_stored()
udm_set_agent_param()
uksort()
umask()
unicode_decode()
unicode_encode()
unicode_get_error_mode()
unicode_get_subst_char()
unicode_semantics()
unicode_set_error_mode()
unicode_set_subst_char()
uniqid()
unixtojd()
unlink()
unpack()
unregister_tick_function()
unserialize()
unset()
urldecode()
urlencode()
usage()
use_soap_error_handler()
user_error()
usleep()
usort()
utf8_decode()
utf8_encode()

V

var_dump()
var_export()
variant()
variant_abs()
variant_add()
variant_and()
variant_cast()
variant_cat()
variant_cmp()
variant_date_from_timestamp()
variant_date_to_timestamp()
variant_div()
variant_eqv()
variant_fix()
variant_get_type()
variant_idiv()
variant_imp()
variant_int()
variant_mod()
variant_mul()
variant_neg()
variant_not()
variant_or()
variant_pow()
variant_round()
variant_set()
variant_set_type()
variant_sub()
variant_xor()
version_compare()
vfprintf()
virtual()
vpopmail_add_alias_domain()
vpopmail_add_alias_domain_ex()
vpopmail_add_domain()
vpopmail_add_domain_ex()
vpopmail_add_user()
vpopmail_alias_add()
vpopmail_alias_del()
vpopmail_alias_del_domain()
vpopmail_alias_get()
vpopmail_alias_get_all()
vpopmail_auth_user()
vpopmail_del_domain()
vpopmail_del_domain_ex()
vpopmail_del_user()
vpopmail_error()
vpopmail_passwd()
vpopmail_set_user_quota()
vprintf()
vsprintf()

W

w32api_deftype()
w32api_init_dtype()
w32api_invoke_function()
w32api_register_function()
w32api_set_call_method()
wddx_add_vars()
wddx_deserialize()
wddx_packet_end()
wddx_packet_start()
wddx_serialize_value()
wddx_serialize_vars()
wddx_unserialize()
win32_create_service()
win32_delete_service()
win32_get_last_control_message()
win32_ps_list_procs()
win32_ps_stat_mem()
win32_ps_stat_proc()
win32_query_service_status()
win32_set_service_status()
win32_start_service()
win32_start_service_ctrl_dispatcher()
win32_stop_service()
wordwrap()

X

xattr_get()
xattr_list()
xattr_remove()
xattr_set()
xattr_supported()
xdiff_file_diff()
xdiff_file_diff_binary()
xdiff_file_merge3()
xdiff_file_patch()
xdiff_file_patch_binary()
xdiff_string_diff()
xdiff_string_diff_binary()
xdiff_string_merge3()
xdiff_string_patch()
xdiff_string_patch_binary()
xml_error_string()
xml_get_current_byte_index()
xml_get_current_column_number()
xml_get_current_line_number()
xml_get_error_code()
xml_parse()
xml_parse_into_struct()
xml_parser_create()
xml_parser_create_ns()
xml_parser_free()
xml_parser_get_option()
xml_parser_set_option()
xml_set_character_data_handler()
xml_set_default_handler()
xml_set_element_handler()
xml_set_end_namespace_decl_handler()
xml_set_external_entity_ref_handler()
xml_set_notation_decl_handler()
xml_set_object()
xml_set_processing_instruction_handler()
xml_set_start_namespace_decl_handler()
xml_set_unparsed_entity_decl_handler()
XMLReader::close()
XMLReader::expand()
XMLReader::getAttribute()
XMLReader::getAttributeNo()
XMLReader::getAttributeNs()
XMLReader::getParserProperty()
XMLReader::isValid()
XMLReader::lookupNamespace()
XMLReader::moveToAttribute()
XMLReader::moveToAttributeNo()
XMLReader::moveToAttributeNs()
XMLReader::moveToElement()
XMLReader::moveToFirstAttribute()
XMLReader::moveToNextAttribute()
XMLReader::next()
XMLReader::open()
XMLReader::read()
XMLReader::setParserProperty()
XMLReader::setRelaxNGSchema()
XMLReader::setRelaxNGSchemaSource()
XMLReader::XML()
xmlrpc_decode()
xmlrpc_decode_request()
xmlrpc_encode()
xmlrpc_encode_request()
xmlrpc_get_type()
xmlrpc_is_fault()
xmlrpc_parse_method_descriptions()
xmlrpc_server_add_introspection_data()
xmlrpc_server_call_method()
xmlrpc_server_create()
xmlrpc_server_destroy()
xmlrpc_server_register_introspection_callback()
xmlrpc_server_register_method()
xmlrpc_set_type()
XMLWriter::endAttribute()
XMLWriter::endCData()
XMLWriter::endComment()
XMLWriter::endDocument()
XMLWriter::endDTD()
XMLWriter::endDTDAttlist()
XMLWriter::endDTDElement()
XMLWriter::endDTDEntity()
XMLWriter::endElement()
XMLWriter::endPI()
XMLWriter::flush()
XMLWriter::fullEndElement()
XMLWriter::openMemory()
XMLWriter::openURI()
XMLWriter::outputMemory()
XMLWriter::setIndent()
XMLWriter::setIndentString()
XMLWriter::startAttribute()
XMLWriter::startAttributeNS()
XMLWriter::startCData()
XMLWriter::startComment()
XMLWriter::startDocument()
XMLWriter::startDTD()
XMLWriter::startDTDAttlist()
XMLWriter::startDTDElement()
XMLWriter::startDTDEntity()
XMLWriter::startElement()
XMLWriter::startElementNS()
XMLWriter::startPI()
XMLWriter::text()
XMLWriter::writeAttribute()
XMLWriter::writeAttributeNS()
XMLWriter::writeCData()
XMLWriter::writeComment()
XMLWriter::writeDTD()
XMLWriter::writeDTDAttlist()
XMLWriter::writeDTDElement()
XMLWriter::writeDTDEntity()
XMLWriter::writeElement()
XMLWriter::writeElementNS()
XMLWriter::writePI()
XMLWriter::writeRaw()
xpath_eval()
xpath_eval_expression()
xpath_new_context()
xpath_register_ns()
xpath_register_ns_auto()
xptr_eval()
xptr_new_context()
xslt_backend_info()
xslt_backend_name()
xslt_backend_version()
xslt_create()
xslt_errno()
xslt_error()
xslt_free()
xslt_getopt()
xslt_process()
xslt_set_base()
xslt_set_encoding()
xslt_set_error_handler()
xslt_set_log()
xslt_set_object()
xslt_set_sax_handler()
xslt_set_sax_handlers()
xslt_set_scheme_handler()
xslt_set_scheme_handlers()
xslt_setopt()
XSLTProcessor::__construct()
XSLTProcessor::getParameter()
XSLTProcessor::hasExsltSupport()
XSLTProcessor::importStylesheet()
XSLTProcessor::registerPHPFunctions()
XSLTProcessor::removeParameter()
XSLTProcessor::setParameter()
XSLTProcessor::transformToDoc()
XSLTProcessor::transformToURI()
XSLTProcessor::transformToXML()

Y

yaz_addinfo()
yaz_ccl_conf()
yaz_ccl_parse()
yaz_close()
yaz_connect()
yaz_database()
yaz_element()
yaz_errno()
yaz_error()
yaz_es()
yaz_es_result()
yaz_get_option()
yaz_hits()
yaz_itemorder()
yaz_present()
yaz_range()
yaz_record()
yaz_scan()
yaz_scan_result()
yaz_schema()
yaz_search()
yaz_set_option()
yaz_sort()
yaz_syntax()
yaz_wait()
yp_all()
yp_cat()
yp_err_string()
yp_errno()
yp_first()
yp_get_default_domain()
yp_master()
yp_match()
yp_next()
yp_order()

Z

zend_logo_guid()
zend_thread_id()
zend_version()
zip_close()
zip_entry_close()
zip_entry_compressedsize()
zip_entry_compressionmethod()
zip_entry_filesize()
zip_entry_name()
zip_entry_open()
zip_entry_read()
zip_open()
zip_read()
ZipArchive::addEmptyDir()
ZipArchive::addFile()
ZipArchive::addFromString()
ZipArchive::close()
ZipArchive::deleteIndex()
ZipArchive::deleteName()
ZipArchive::extractTo()
ZipArchive::getArchiveComment()
ZipArchive::getCommentIndex()
ZipArchive::getCommentName()
ZipArchive::getFromIndex()
ZipArchive::getFromName()
ZipArchive::getNameIndex()
ZipArchive::getStream()
ZipArchive::locateName()
ZipArchive::open()
ZipArchive::renameIndex()
ZipArchive::renameName()
ZipArchive::setArchiveComment()
ZipArchive::setCommentIndex()
ZipArchive::setCommentName()
ZipArchive::statIndex()
ZipArchive::statName()
ZipArchive::unchangeAll()
ZipArchive::unchangeArchive()
ZipArchive::unchangeIndex()
ZipArchive::unchangeName()
zlib_get_coding_type()

Předcházející | Nahoru | Další
VI. MOŽNOSTI LICENCE | Domů | X. Co zde chybí


Příloha X. Co zde chybí

Předcházející | Nahoru | Další
W. Rejstřík funkcí | Domů | X. Vydání HTML Help


Copyright

Manuál PHP

Copyright

Tento manuál je © Copyright 1997 - 2006 PHP Documentation Group. Tento materiál lze distribuovat pouze takovým způsobem a za takových podmínek, jak stanovuje Open Publication License, v1.0 nebo pozdější. Kopie Open Publication License je distribuována s tímto manuálem, (nejnovější verze je v tuto chvíli k dispozici na » http://www.opencontent.org/openpub/).

Distribuce podstatně změněných verzí tohoto dokumentu bez výslovného povolení vlastníků autorských práv je zakázána.

Distribuce této práce nebo prací odvozených v jakékoli standardní (papírové) knižní formě bez předchozího souhlasu vlastníků autorských práv je zakázána.

Zajímáte-li se o redistribuci nebo republikaci tohoto dokumentu, celého nebo jeho části, změněného či nezměněného, a máte nějaké otázky, kontaktuje prosím držitele autorských práv na » doc-license@lists.php.net. Nezapomeňte, že je tato adresa namapována na veřejně archivovanou konferenci.

Sekce zend této dokumentace je založena na počátečním příspěvku Zend Technologies.

Nahoru
Domů


Část IX. Appendices

Obsah

A. Historie PHP a souvisejících projektů
B. Migrating from PHP 5.1.x to PHP 5.2.x
C. Migrating from PHP 5.0.x to PHP 5.1.x
D. Migrating from PHP 4 to PHP 5
E. Přechod z PHP 3 na PHP 4
F. Přechod z PHP/FI 2 na PHP 3
G. Ladění (debugging) PHP
H. Konfigurační volby
I. Direktivy php.ini
J. List of Supported Timezones
K. Kategorizace rozšíření
L. Seznam aliasů funkcí
M. List of Reserved Words
N. Seznam typů prostředků
O. List of Supported Protocols/Wrappers
P. Seznam dostupných filtrů
Q. Seznam podporovaných socketových transportů
R. Tabulky porovnání datových typů v PHP
S. Seznam tokenů parseru
T. Userland Naming Guide
U. O tomto manuálu
V. Open Publication License
W. Rejstřík funkcí
X. Co zde chybí
Předcházející | Nahoru | Další
72. Ostatní otázky | Domů | A. Historie PHP a souvisejících projektů


Kapitola 73. O tomto vydání

PHP manuál ve vydání Windows HTML Help je zaměřen na vývojáře, kteří chtějí mít manuál stále po ruce, a rádi by četli manuálové stránky a uživatelské poznámky bez čekání na stahování stránek ze vzdálených serverů. Toto vydání obsahuje úplný manuál + uživatelské poznámky, a to se všemi možnostmi, které poskytuje prohlížeč nápovědy.

Předcházející | Nahoru | Další
X. Vydání HTML Help | Domů | 74. Použití prohlížeče HTML nápovědy


Kapitola 79. CHM Edition Credits

Tato rozšířená verze manuálu PHP by nikdy nevznikla, kdyby se tito lidé nepomohli svými příspěvky do projektu (uváděné pořadí o ničem nevypovídá):

  • Holger Eggert; vytvořil dva základní designy a poskytl mnoho užitečných tipů
  • Gonzalo De la Pena Andreu; přidal mnoho komentářů, na kterých lze stavět při tvorbě skinovatelného rozhraní
  • Olexandr Vynnychenko; přidal nespočetně komentářů a celou dobu testoval
  • Brendan Ferguson; poskytl mnoho optimalizací a vylepšení HTML a JavaScriptu pro manuálové stránky
  • Sandor Hojtsy; naprogramoval aplikaci pro manuálové preference
  • A konečně (ale nikoli pouze) všichni, kdo poskytli odezvu přes e-malovou konferenci a v "uživatelském dozoru".

Předcházející | Nahoru
CSS classes | Domů


Kapitola 77. Integrating the PHP Manual

Poznámka: The information provided here is mainly aimed at IDE authors, or advanced users who would like to integrate this CHM file to their favorite IDEs or other production environment components.

There are several editors out there with support for CHM integration, but you may need to know a few things about what the CHM contains to successfully integrate the manual into your environment.

The CHM is built using XSL style sheets from XML sources. This is unique currently in the PHP Manual family, as all other versions are generated using DSSSL style sheets. This also means, that non-intentional rendering differences may come up. A special conversion script is run on the XSLT output, adding several cute features, and packing up the manual with the preferences files and skin examples.

If you never worked with CHMs, you can think of them as compressed files with OS supported access for files inside and some added search and index support. However CHMs can only be viewed using the HTML Help Viewer, you can directly access files inside them using a special URL prefix, the CHM file name and the file you request from inside. As all the help content is stored in HTML files, you can show pages of the CHM in Internet Explorer.

Assume that you placed your php_manual_en.chm to c:\phpmanual the index file in the manual (which you see the first time) can be accessed with the following URL: mk:@MSITStore:C:\phpmanual\php_manual_en.chm::/_index.html. Here mk:@MSITStore: is the special "protocol", C:\phpmanual\php_manual_en.chm is the CHM with it's full path. The /_index.html part is the path to the index file inside the CHM and :: is just what you need to put between the CHM path and this file path.

Poznámka: All files are in the root directory of the CHM, unlike the previous CHM versions which included a language directory. Images, style sheets and other supplemental files have names starting with an underscore (like the main index shown above), to avoid name collisions.

The names of generated files follow the same rules as the online manual, except that the extension is .html and not .php. The most important is that function documentation files are named function.FUNCNAME.html where FUNCNAME is the function name, with all underscores converted to hyphens. Some examples are function.echo.html, function.mysql-close.html, function.imagecopy.html.

Using all this information, you can show a manual page for a function requested by a user. A simple example is included in the distribution, named php_quickref.hta. This is a » HTML Application to demonstrate the simple process of showing a manual page for a function. The quickRef() function defined therein does the job.

If you would like to integrate the manual into an IDE without direct support for the PHP manual (actually the underscore to hyphen conversion), you can use the included _function.html file to access a function page. This file is simply a redirector, and can be parameterized via the URL, as _function.html#mysql_close. This page will redirect you to the mysql_close function page (function.mysql-close.html) automatically. You can provide the full path of this file if your IDE supports context sensitive help, and provide the IDE specified string as the parameter. An example for this is the UltraEdit 9 intergation (see the edition's website).

The index of the manual (accessible via the index tab on the navigation pane) can also be used for integrational purposes. All the HTML pages are included in the index with their titles as index terms (including function description pages).

If you are a desktop application developer and would like to tightly integrate the CHM into your program (such as displaying the TOC tree in your IDE's help box), you can find more information at » http://www.helpware.net/, as well as links to other useful resources. The official site for HTML Help is at » http://msdn.microsoft.com/library/en-us/htmlhelp/html/vsconhh1start.asp.

Předcházející | Nahoru | Další
Presentational Specialities | Domů | 78. Skin development


Kapitola 75. The Full Text Search

Obsah

General searching rules
Searching for words or phrases
Defining search terms
Using nested expressions when searching
Manual Content and User Note Separation

This edition of the PHP Manual includes an advanced full text search possibility provided by the viewer application. This enables users to search through every word in the help file to find a match. For example, if a user does a full-text search on the word "Apache", every topic that contains the word "Apache" will be listed. Advanced full-text search allows a user to search using boolean, wildcard, and nested expressions. A user can also limit the search to previous results, match similar words, or search topic titles only.

The usage of the search feature is fairly straightforward. Click on the search tab, type in the desired words and press ENTER (or click on "List Topics"). Then you'll receive a list of matches from the PHP Manual (and the notes). You can use the button with a right arrow on it to add boolean operators to your search (or you can type them in). As you see the results, you can use the column headings (Title, Location and Rank) to sort the topic list. The default order is by Rank. You can also adjust some parameters at the bottom of this tab.

The words found are highlighted on the current page in the Topic pane by default. You can turn off this feature by choosing the "Search Highlight Off" menu item in the Options menu. To can get this feature back similarly. If you are viewing a long topic, only the first 500 instances of a search word or phrase will be highlighted, due to a limitation of the viewer.

General searching rules

A basic search consists of the word or phrase you want to find. You can use wildcard expressions, nested expressions, boolean operators, similar word matches, a previous results list, or topic titles to further define your search.

The basic rules for formulating queries are as follows:

  • Searches are not case-sensitive, so you can type your search in uppercase or lowercase characters.
  • You may search for any combination of letters (a-z) and numbers (0-9). You cannot search for single letters (a, b, c, etc.) and common words, like: an, and, as, at, be, but, by, do, for, from, have, he, in, it, not, of, on, or, she, that, the, there, they, this, to, we, which, with, you.
  • Punctuation marks such as the period (.), colon (:), semicolon (;), comma (,), and hyphen (-) are ignored during a search.
  • Group the elements of your search using double quotes or parentheses to set apart each element. You cannot search for quotation marks.

Poznámka: If you are searching for a file name with an extension, you should group the entire string in double quotes, ("filename.ext"). Otherwise, the period will break the file name into two separate terms. The default operation between terms is AND, so you will create the logical equivalent to "filename AND ext."

Předcházející | Nahoru | Další
74. Použití prohlížeče HTML nápovědy | Domů | Searching for words or phrases


Using nested expressions when searching

Nested expressions allow you to create complex searches for information. For example, "html AND ((smtp OR pop3) NEAR mail)" finds topics containing the word "html" along with the words "smtp" and "mail" close together, or containing "html" along with the words "pop3" and "mail" close together.

The basic rules for searching help topics using nested expressions are as follows:

  • You can use parentheses to nest expressions within a query. The expressions in parentheses are evaluated before the rest of the query.
  • If a query does not contain a nested expression, it is evaluated from left to right. For example: "mail NOT pop3 OR smtp" finds topics containing the word "mail" without the word "pop3" or topics containing the word "smtp". On the other hand, "mail NOT (pop3 OR smtp)" finds topics containing the word "mail" without either of the words "pop3" or "smtp".
  • You cannot nest expressions more than five levels deep.

Předcházející | Nahoru | Další
Defining search terms | Domů | Manual Content and User Note Separation


Manual Content and User Note Separation

The manual content and the user notes are separated to php_manual_LANG.chm and php_manual_notes.chm. There were several resons to do this, including:

  • This way you can update the user notes and the manual independently as you need.
  • You can have more than one language of the manual, while only need to have one notes file. All the CHM files need to be in the same directory, and all translations need to share the same preferences if you would not like to have more then one notes file.
  • You can bookmark manual pages with notes, or just a notes part of a page separately.
  • You can "turn off" user note display and user note search results by simply deleting php_manual_notes.chm, moving it out of the directory or renaming it.
All these benefits lead us to provide the manual the way you can see it right now. This distribution had the effect on the full text search that you get search results from the manual content and from the user notes as separate ones. The "Location" column shows the source of the result, also enabling you to "add precedence" to manual content results with ordering the results by "Location". User note page titles are also prefixed with "N:" to make them easily distinguishable in the favorites list (there's no location info in the favorites list).

Předcházející | Nahoru | Další
Using nested expressions when searching | Domů | 76. Specialities of this Edition


Defining search terms

The AND, OR, NOT, and NEAR operators enable you to precisely define your search by creating a relationship between search terms. The following table shows how you can use each of these operators. If no operator is specified, AND is used. For example, the query "server cgi security" is equivalent to "server AND cgi AND security".

Tabulka 75.2. Search operators

Search for | Example | Results
Both terms in the same topic | http AND apache | Topics containing both the words "http" and "apache".
Either term in a topic | ming OR swflib | Topics containing either the word "ming" or the word "swflib" or both.
The first term without the second term | xml NOT expat | Topics containing the word "xml" but not the word "expat".
Both terms in the same topic, close together | database NEAR security | Topics containing the word "database" within eight words of the word "security".

Poznámka: The |, &, and ! characters can also be used in place of OR AND and NOT respectively. This may not work if you use a very old version of the viewer.

Předcházející | Nahoru | Další
Searching for words or phrases | Domů | Using nested expressions when searching


Searching for words or phrases

You can search for words or phrases and use wildcard expressions. Wildcard expressions allow you to search for one or more characters using a question mark or asterisk. The table below describes the results of these different kinds of searches.

Tabulka 75.1. Word and phrase searches

Search for | Example | Results
A single word | select | Topics that contain the word "select". (You will also find its grammatical variations, such as "selector" and "selection".)
A phrase "new operator" or new operator

Topics that contain the literal phrase "new operator" and all its grammatical variations.

Without the quotation marks, the query is equivalent to specifying "new AND operator," which will find topics containing both of the individual words, instead of the phrase.

Wildcard expressions esc* or HT??

Results for the first example include topics that contain the terms "ESC", "escape", "escalation", and so on. The asterisk cannot be the only character in the term.

Results for the second example include topics that contain the terms "HTTP", "HTML" and so on. The question mark cannot be the only character in the term.

Poznámka: Select the Match similar words check box to include minor grammatical variations for the phrase you search. This feature only locates variations of the word with common suffixes. For example, a search on the word "add" will find "added," but it will not find "additive". This option is independent of other options or syntax. If you do a titles-only search, variations in titles will be matched. If you use quotes (or any other query operator) any variation of the word can appear; for example, "stemmed search" will also match "stemming search".

Předcházející | Nahoru | Další
75. The Full Text Search | Domů | Defining search terms


Kapitola 78. Skin development

Obsah

Page Display Process
Page Elements
CSS classes

This edition of the PHP Manual allows users to choose from skins to display the contents, as well as develop custom skins to meet some special needs. We decided to support skins because we realized that one skin cannot satisfy everybody's needs in a such heavily used edition.

We included two skins by default inside the CHM. These cannot be modified or removed, so if you have the CHM, you have these two skins inside. The Low skin is optimized for small window display, the High skin is a variation of the Low one with some graphics added to spice it up.

A skin must have at least two files, a skin loader JavaScript file and a CSS file. The two inline skins have these files inside the CHM. The skin loader JS should at least load in the CSS file and display the page contents to the viewer. Theoretically there are two kinds of skins: CSS skins and Full skins. CSS skins only modify the CSS and does not amend the page layout. Full skins also modify the page layout. We have included sample skins for both the CSS skin type and the Full skin type ("greenlinks" and "headernostalgia" respectively).

Varování

Note that though the current skin development methods are quite final, there may be heavy changes in used CSS classes or page elements while we refine the skin development ideas. As this edition is currently in development stage, the information described herein is not to be considered completely stable.

Page Display Process

If you are going to develop your own skin, you should know how one page is loaded and displayed to the user, and how a skin fits in this process. For these paragraphs, we assume that you have put your CHM into c:\phpmanual, so it's accessible as c:\phpmanual\php_manual_LANG.chm (where LANG is the language code), and you would like to see the function page of "echo", which is function.echo.html inside the CHM. See the sections about integration for more information on CHM contents.

  • First of all the HTML content is loaded in from function.echo.html from inside the CHM.
  • At the top of this file, there is a HTML <script> tag, which loads in the _script.js file from the CHM. This file contains all the JS code needed to move on with the process. Most importantly this JS defines many variables (like where the CHM is, or what is the actual page viewed) and many functions to print out the context menu or handle online functions.
  • At last _script.js loads in the preferences file from outside the CHM (c:\phpmanual\php_manual_prefs.js in our example). This JS file defines the preference variables, and calls back prefHandler() which is also defined in _script.js.
  • That function loads in the skin JS file as the preferences dictate. The skin JS file should load in the needed CSS file, and define a displayPage() function, which displays the page if called.
  • The HTML file (function.echo.html in this example) also contains a function call to load in the user notes, which simply puts the notes into this HTML file using DHTML to be displayed as if they were here before...
  • The HTML file also contains a body onload attribute which calls the skin-defined displayPage() function to show the page to the user. This is the last function called, it should present the page in it's complete form to the user.
Every action is synchronized with calling back a function in the previously loaded file when the JS is in memory. The notes loading and skin JS loading is only synchronized with the page's onload event (which as the Microsoft documentation says only fires if the page is completely loaded).

This load and callback chain may seem to be too complicated, but so far this seemed to be the best way to do as many things as possible parallel, while also synchronize some calls.

As you can see your skin JavaScript file is loaded in by _script.js and it's displayPage() function is called by the body onload event.

Předcházející | Nahoru | Další
77. Integrating the PHP Manual | Domů | Page Elements


CSS classes

We cannot provide accurate documentation currently on usable CSS classes, as some of the DocBook XSL sheets classes are not used and some classes are added. Please see the sample CSS files included for first time reference.

Předcházející | Nahoru | Další
Page Elements | Domů | 79. CHM Edition Credits


Page Elements

The PHP Manual pages are all HTML files with several HTML tags in them for both presentational and divisional purposes. The HTML pages contain divisions to be used for skinning purposes and misc divisions added by the DocBook XSL sheets.

A HTML page can be either a function reference page or another kind of page (like a feature description). Skins should get ready to skin these two kinds of pages separately most of the time (depending on the actual design).

The pages are structured using <div> tags with appropriate IDs to ease the skin writers work. A page consists of these parts:

  • <div id="pageContent"></div> contains all the page contents. This begins right after <body> and ends just before </body>. This division is hidden by default, you need to show it after you are ready with the page rewriting process.
  • <div id="pageHeaders"></div> contains the page header parts. This includes the text only main title (in a <span id="pageTitle"></span>) and function properties, in case this is a function page (contained in <span id="funcPurpose"></span>, <span id="funcAvail"></span> and <span id="funcUsage"></span>). In case one of these three is not available, the current page is not a function page.
  • <div id="pageText"></div> contains the majority of the page contents, including examples, manual notes, warnings, etc. This also includes see also parts for now, as we still cannot differentiate between see also and normal text parts (may be a thing to change in the future).
  • <div id="pageNotes"></div> contains the user notes (itself loaded in from another HTML file by JS). It contains a heading, and then a <div> without ID for every user note and spans in that divs for every element of a user note (with "email", "date" and "text" IDs respectively).
  • <div id="pageNav"></div> contains the
navigation table, which is further divided into spans (<span
id="navPrev"></span>, <span
id="navPath"></span>, <span
id="navNext"></span>, <span
id="navOnline"></span>, <span
id="navThisOnline"></span> and <span
id="navReportBug"></span>), where navThisOnline
and navReportBug is inside navOnline.
If you would like to rewrite the page, you should first read in the parts you need from the page to JS variables, then clear the contents of pageContent (or just the part you would like to rewrite), write in the new content and show the pageContent div for the user. If you would not like to make any structural changes, you can simply display the pageContent div and only specify a special style sheet in your skin JS file (see the "greenlinks" skin for an example).

You can find a "Full skin" developed to show you how to make skins built on top of this structure. The skin name is "headernostalgia". It rewrites the header part and removes the footer navigational table.

Předcházející | Nahoru | Další
78. Skin development | Domů | CSS classes


Kapitola 76. Specialities of this Edition

Obsah

User Preferences
Presentational Specialities

The Windows HTML Help Edition of the PHP Manual over-performs the presentational and interactive capabilities offered by other editions (including the online manual). This was possible because currently CHMs can only be viewed on Windows using Internet explorer, so we can develop for one browser family and one operating system. Viewers for other OSes may be developed in the future by third parties.

User Preferences

Most of the interactive features of this manual are provided by the viewer application (including full text search, index, favorites list), but we extended this list with PHP Manual specific tools. All these can be adjusted to your needs using a simple desktop application named php_manual_prefs.exe. If you run this program you can see three groups of settings: Online Functions, Context Menu, and Skin. All your settings are stored in php_manual_prefs.js.

Online functions enable you to have elements connected to websites. The two ones you can see on all manual pages are "This page online" and "Report a bug". As you can figure out the first one shows you the same page in the online manual, the second one opens a page from » http://bugs.php.net/ and prefills some bug data for you. You need to select a mirror site to use for "php.net sensitive" online functions. We recommend choosing a close mirror site to get the best speed. Other components that may be limited by this online functions setting include context menu items opening new websites ("Google search selection" for example). Custom designs may also include elements restricted by this setting.

The context menu settings enables you to choose which context menu you prefer. This application provides you with an option to define your own context menu adding elements to it from a predefined set. You can have this custom context menu for the right click of your mouse, and have the original menu for CTRL+right click, or the opposite way. Three special types of custom context menu items exist:

Tabulka 76.1. Context menu items

Type | Examples | Comments
Page Jump | Function Reference, Function Index | These items jump to a specific page in the CHM. Page Jump options are not restricted to point inside the CHM though. They can point to websites or other resources. Page jump options with a protocol part in the URL open in new window.
Function Call | Print page, Select all, Copy selection to clipboard, Google Search Selection | These are "function calls" for internally defined context menu functions. The last two examples have the speciality that they only show up in the menu if you rightclicked on a selection. Currently there is no way to extend the context menu with skin defined functions.
Special display | Google SearchBox, AlltheWeb SearchBox | These are displayed as HTML forms, where you can enter search keywords, press ENTER, and receive a new window with the search issued in the appropriate search engine. Currently there is no way to extend the set of specially displayed context menu items.

Possible context menu elements and their "abstract implementations" are stored in context.ini. You have the ability to add possible page jump options there, but there is no way currently to extend the context menu system with user (skin) defined functions. The possible mirror sites are listed in mirrors.ini. Feel free to suggest more bundled context menu items to us at » php-doc-chm@lists.php.net.

The skins setting enables you to choose from the two bundled default skins, or from any user defined skins. The Low skin is optimized to display correctly at any small size, the High skin is optimized for your viewing pleasure. Other skins may be developed according to our skins development guide. The recommended place for skins on the file system is the skins/SKINNAME subfolder of the PHP Manual directory. Though this is not required, some skins may define other rules (not recommended). We included sample skins for you to see examples of how to develop skins for the PHP Manual.

You have three buttons to choose from at the bottom. The Apply button applies your changes without exiting, the OK button applies and closes the application, the Cancel button does not modify your settings and closes the program.

Předcházející | Nahoru | Další
Manual Content and User Note Separation | Domů | Presentational Specialities


Presentational Specialities

This edition of the PHP Manual is highly optimized for screen presentation. Skins may be developed to better support printing, as this was not the goal of the included skins. This approach allowed us to make many modifications to the presentation of different parts of the manual.

The first thing you'll notice is that all examples are color coded, using the PHP function show_source(). The actual colors used are defined by CSS classes. Examples also have links to PHP functions used in them to provide quick access to reference material. All code examples have a "copy to clipboard" link by the side of them with which you can copy the text contents of the example to the clipboard.

External links are marked with a special » sign, and open in a new browser window. We also included the "path to this page" information on all pages for you to easily identify where you are and navigate as needed.

Other parts of the manual are quite similar to the online ones by default, though custom skins can modify many elements on the pages.

Předcházející | Nahoru | Další
76. Specialities of this Edition | Domů | 77. Integrating the PHP Manual


Kapitola 74. Použití prohlížeče HTML nápovědy

Obsah

Panel nástrojů HTML nápovědy

Po dvojkliku na souboru CHM se otevře okno prohlížeče HTML nápovědy se třemi panely. Na levé straně okna je navigační panel. Obsahuje čtyři navigační karty s oušky: Obsah, Rejstřík, Vyhledávat a Oblíbené. Na pravé straně je panel témat. Zobrazuje vybrané téma nápovědy, resp. implicitní téma po startu. Třetím panelem je panel nástrojů, umístěný pod titulkovou lištou okna.

Všimněte si, že když otevřete CHM poprvé, může mít okno nějaké podivné rozměry a pozici. Potom si ale systém Windows zapamatuje pozici a rozměr okna a naposledy použitou kartu. Všechno, včetně oblíbených položek, se uloží do souboru hh.dat. Pokud přesunete soubor do jiného adresáře, zapamatované nastavení budou ztracena (včetně oblíbených položek!). Nahradíte-li CHM soubor novější verzí se stejným názvem, nevzniknou žádné problémy. Názvy souborů a cesty se ukládají do souboru hh.dat.

Panel nástrojů HTML nápovědy

Když si prohlížíte PHP manuál, panel nástrojů HTML nápovědy obsahuje následující ikony:

  • Skrýt/Zobrazit - Skryje/zobrazí navigační panel.
  • Nalézt - Nalezne téma na kartě s obsahem (v případě, že jste příslušné téma otevřeli pomocí vyhledávání, rejstříku nebo oblíbených položek a chtěli byste vědět, kde se nachází v obsahu).
  • Zpět - Návrat zpět v historii.
  • Vpřed - Pohyb dopředu v historii.
  • Obnovit - Aktualizuje zobrazenou stránku.
  • Domů - Otevře výchozí stránku CHM.
  • Tisk - Otevře dialog pro tisk.
  • Možnosti - Rozbalení nabídky s možnostmi prohlížeče.
Použití panelu nástrojů je opravdu jednoduché, mnoho ikon má velmi blízko ke svým ekvivalentům v Internet Exploreru.

Předcházející | Nahoru | Další
73. O tomto vydání | Domů | 75. The Full Text Search


Část X. Vydání HTML Help

Obsah

73. O tomto vydání
74. Použití prohlížeče HTML nápovědy
75. The Full Text Search
76. Specialities of this Edition
77. Integrating the PHP Manual
78. Skin development
79. CHM Edition Credits
Předcházející | Nahoru | Další
X. Co zde chybí | Domů | 73. O tomto vydání


Kapitola 9. Runtime Configuration

Obsah

The configuration file
How to change configuration settings

The configuration file

The configuration file (called php3.ini in PHP 3, and simply php.ini as of PHP 4) is read when PHP starts up. For the server module versions of PHP, this happens only once when the web server is started. For the CGI and CLI version, it happens on every invocation.

php.ini is searched in these locations (in order):

  • SAPI module specific location (PHPIniDir directive in Apache 2, -c command line option in CGI and CLI, php_ini parameter in NSAPI, PHP_INI_PATH environment variable in THTTPD)

  • The PHPRC environment variable. Before PHP 5.2.0 this was checked after the registry key mentioned below.

  • As of PHP 5.2.0, the following registry locations are searched in order: HKEY_LOCAL_MACHINE\SOFTWARE\PHP\x.y.z\IniFilePath, HKEY_LOCAL_MACHINE\SOFTWARE\PHP\x.y\IniFilePath and HKEY_LOCAL_MACHINE\SOFTWARE\PHP\x\IniFilePath, where x, y and z mean the PHP major, minor and release versions.

  • HKEY_LOCAL_MACHINE\SOFTWARE\PHP\IniFilePath (Windows Registry location)

  • Current working directory (except CLI)

  • The web server's directory (for SAPI modules), or directory of PHP (otherwise in Windows)

  • Windows directory (C:\windows or C:\winnt) (for Windows), or --with-config-file-path compile time option

If php-SAPI.ini exists (where SAPI is used SAPI, so the filename is e.g. php-cli.ini or php-apache.ini), it's used instead of php.ini. SAPI name can be determined by php_sapi_name().

Poznámka: The Apache web server changes the directory to root at startup causing PHP to attempt to read php.ini from the root filesystem if it exists.

The php.ini directives handled by extensions are documented respectively on the pages of the extensions themselves. The list of the core directives is available in the appendix. Probably not all PHP directives are documented in the manual though. For a complete list of directives available in your PHP version, please read your well commented php.ini file. Alternatively, you may find the » the latest php.ini from CVS helpful too.

Příklad 9.1. php.ini example

; any text on a line after an unquoted semicolon (;) is ignored
[php] ; section markers (text within square brackets) are also ignored
; Boolean values can be set to either:
;    true, on, yes
; or false, off, no, none
register_globals = off
track_errors = yes

; you can enclose strings in double-quotes
include_path = ".:/usr/local/lib/php"

; backslashes are treated the same as any other character
include_path = ".;c:\php\lib"

Since PHP 5.1.0, it is possible to refer to existing .ini variables from within .ini files. Example: open_basedir = ${open_basedir} ":/new/dir".

Předcházející | Nahoru | Další
Bug reports | Domů | How to change configuration settings


How to change configuration settings

Running PHP as an Apache module

When using PHP as an Apache module, you can also change the configuration settings using directives in Apache configuration files (e.g. httpd.conf) and .htaccess files. You will need "AllowOverride Options" or "AllowOverride All" privileges to do so.

With PHP 4 and PHP 5, there are several Apache directives that allow you to change the PHP configuration from within the Apache configuration files. For a listing of which directives are PHP_INI_ALL, PHP_INI_PERDIR, or PHP_INI_SYSTEM, have a look at the List of php.ini directives appendix.

Poznámka: With PHP 3, there are Apache directives that correspond to each configuration setting in the php3.ini name, except the name is prefixed by "php3_".

php_value name value

Sets the value of the specified directive. Can be used only with PHP_INI_ALL and PHP_INI_PERDIR type directives. To clear a previously set value use none as the value.

Poznámka: Don't use php_value to set boolean values. php_flag (see below) should be used instead.

php_flag name on|off

Used to set a boolean configuration directive. Can be used only with PHP_INI_ALL and PHP_INI_PERDIR type directives.

php_admin_value name value

Sets the value of the specified directive. This can not be used in .htaccess files. Any directive type set with php_admin_value can not be overridden by .htaccess. To clear a previously set value use none as the value.

php_admin_flag name on|off

Used to set a boolean configuration directive. This can not be used in .htaccess files. Any directive type set with php_admin_flag can not be overridden by .htaccess.

Příklad 9.2. Apache configuration example

<IfModule mod_php5.c>
  php_value include_path ".:/usr/local/lib/php"
  php_admin_flag safe_mode on
</IfModule>
<IfModule mod_php4.c>
  php_value include_path ".:/usr/local/lib/php"
  php_admin_flag safe_mode on
</IfModule>
<IfModule mod_php3.c>
  php3_include_path ".:/usr/local/lib/php"
  php3_safe_mode on
</IfModule>

Výstraha

PHP constants do not exist outside of PHP. For example, in httpd.conf you can not use PHP constants such as E_ALL or E_NOTICE to set the error_reporting directive as they will have no meaning and will evaluate to 0. Use the associated bitmask values instead. These constants can be used in php.ini

Changing PHP configuration via the Windows registry

When running PHP on Windows, the configuration values can be modified on a per-directory basis using the Windows registry. The configuration values are stored in the registry key HKLM\SOFTWARE\PHP\Per Directory Values, in the sub-keys corresponding to the path names. For example, configuration values for the directory c:\inetpub\wwwroot would be stored in the key HKLM\SOFTWARE\PHP\Per Directory Values\c\inetpub\wwwroot. The settings for the directory would be active for any script running from this directory or any subdirectory of it. The values under the key should have the name of the PHP configuration directive and the string value. PHP constants in the values are not parsed. However, only configuration values changeable in PHP_INI_USER can be set this way, PHP_INI_PERDIR values can not.

Other interfaces to PHP

Regardless of how you run PHP, you can change certain values at runtime of your scripts through ini_set(). See the documentation on the ini_set() page for more information.

If you are interested in a complete list of configuration settings on your system with their current values, you can execute the phpinfo() function, and review the resulting page. You can also access the values of individual configuration directives at runtime using ini_get() or get_cfg_var().

Předcházející | Nahoru | Další
9. Runtime Configuration | Domů | III. Reference jazyka


break

break ukončuje provádění aktuálního příkazu for, foreach while, do..while nebo switch.

break akceptuje nepovinný číselný argument, který říká, z kolika vnořených struktur se má vyskočit.

$arr = array ('jedna', 'dvě', 'tři', 'čtyři', 'stop', 'pět');
while (list (, $val) = each ($arr)) {
    if ($val == 'stop') {
        break;    /* Tady byste mohli napsat také 'break 1;'. */
    }
    echo "$val<br>\n";
}

/* Použití nepovinného argumentu. */

$i = 0;
while (++$i) {
    switch ($i) {
    case 5:
        echo "Při 5<br>\n";
        break 1;  /* Ukončuje pouze switch. */
    case 10:
        echo "Při 10; konec<br>\n";
        break 2;  /* Ukončuje switch a while. */
    default:
        break;
    }
}

Předcházející | Nahoru | Další
foreach | Domů | continue


continue

continue se používá uvnitř cyklů k přeskočení zbytku aktuální iterace a bezprostřednímu přechodu na následující iteraci.

continue akceptuje nepovinný číselný argument, který říká, kolik úrovní cyklů se má naráz dokončit.

while (list ($key, $value) = each ($arr)) {
    if (!($key % 2)) { // přeskoč sudé členy
        continue;
    }
    do_something_odd ($value);
}

$i = 0;
while ($i++ &lt; 5) {
    echo "Vnější<br>\n";
    while (1) {
        echo "&nbsp;&nbsp;Střední<br>\n";
        while (1) {
            echo "&nbsp;&nbsp;Vnitřní<br>\n";
            continue 3;
        }
        echo "Toto se nikdy nevytiskne.<br>\n";
    }
    echo "Ani tohle se neprovádí.<br>\n";
}

Předcházející | Nahoru | Další
break | Domů | switch


declare

Příkaz declare se používá k nastavení prováděcích direktiv pro blok kódu. Syntaxe declare je podobná syntaxi ostatnícj příkazů pro řízení toku:

declare (directive) statement

Část directive umožňuje nastavit chování bloku, který má být ovlivněn pomocí declare. V současnosti je rozpoznávána pouze jediná direktiva: ticks. (Pro více informací viz níže - direktiva ticks)

Část statement bloku declare bude provedena - jak bude provedena a jaké vedlejší efekty nastanou během provádění může záležet na direktivě nastavené v bloku directive.

Ticks

Tick je událost, která nastane pro každých N nízkoúrovňových příkazů provedených parserem uvnitř bloku declare. Hodnota N je specifikována pomocí ticks=N uvnitř sekce directive bloku declare.

Událost(i), která nastane při každém ticku, se specifikuje pomocí register_tick_function(). Více podrobností - viz příklad níže. Uvědomte si, že na každý tick může nastat více než jedna událost.

Příklad 16.1. Profile a section of PHP code

<pre>
<?php
// A function that records the time when it is called
function profile ($dump = FALSE)
{
    static $profile;

    // Return the times stored in profile, then erase it
    if ($dump) {
        $temp = $profile;
        unset ($profile);
        return ($temp);
    }

    $profile[] = microtime ();
}

// Set up a tick handler
register_tick_function("profile");

// Initialize the function before the declare block
profile ();

// Run a block of code, throw a tick every 2nd statement
declare (ticks=2) {
    for ($x = 1; $x < 50; ++$x) {
        echo similar_text (md5($x), md5($x*$x)), "&lt;br&gt;";
    }
}

// Display the data stored in the profiler
print_r (profile (TRUE));
?>
</pre>

The example profiles the PHP code within the 'declare' block, recording the time at which every second low-level statement in the block was executed. This information can then be used to find the slow areas within particular segments of code. This process can be performed using other methods: using ticks is more convenient and easier to implement.

Ticks are well suited for debugging, implementing simple multitasking, backgrounded I/O and many other tasks.

See also register_tick_function() and unregister_tick_function().

Předcházející | Nahoru | Další
switch | Domů | return


do..while

Cykly do..while jsou velmi podobné cyklům while kromě toho, že pravdivost výrazu se testuje na konci každé iterace namísto jejího začátku. Hlavní rozdíl oproti běžným cyklům while je ten, že první iterace cyklu do..while se provede vždy (pravdivostní výraz je testován až na konci iterace), což u cyklu while není zaručeno (pravdivostní výraz je testován na začátku iterace; pokud je ohodnocen jako FALSE, provádění cyklu hned skončí).

Toto je jediná syntaxe pro cykly do..while:

$i = 0;
do {
   print $i;
} while ($i>0);

Výše uvedený cyklus by se provedl právě jednou, protože po první iteraci, když se testuje pravdivostní výraz, je tento ohodnocen jako FALSE ($i není větší než 0) a provádění cyklu končí.

Pokročilí programátoři v C mohou znát i odlišné použití cyklu do..while. Kód se uzavře do do..while(0) a použije se příkaz break. To umožňuje přerušit provádění cyklu uprostřed kódu, jak je znázorněno v tomto příkladu:

do {
    if ($i < 5) {
        print "i není dost velké";
        break;
    }
    $i *= $factor;
    if ($i < $minimum_limit) {
        break;
    }
    print "i je ok";

     ...zpracuj i...

} while(0);

Nedělejte si nic z toho, že tomu hned a beze zbytku nerozumíte. Můžete psát skripty, a to i velmi účinné skripty, i bez použití této 'finty'.

Předcházející | Nahoru | Další
while | Domů | for


else

Často také můžete chtít něco provádět, pokud je jistá podmínka splněna, a něco jiného, když splněna není. To umožňuje příkaz else. else rozšiřuje příkaz if o provádění kódu v případě, že výraz v příkazu if je ohodnocen jako FALSE. Například následující kód vypíše a je větší než b, pokud $a je větší než $b, a a NENÍ větší než b v ostatních případech:

if ($a > $b) {
    print "a je větší než b";
} else {
    print "a NENÍ větší než b";
}
Příkaz v else se provádí, pouze pokud je výraz v if ohodnocen jako FALSE, a pokud by zde byly nějaké výrazy elseif - pouze pokud by byly také ohodnoceny jako FALSE (viz elseif).

Předcházející | Nahoru | Další
16. Řídicí struktury | Domů | elseif


elseif

Jak název napovídá, elseif, je kombinací if a else. Stejně jako else, rozšiřuje příkaz if k provádění odlišných příkazů v případě, že jevýraz původního příkazu if ohodnocen jako FALSE. Tedy, narozdíl od else, se provádí pouze tehdy, je-li výraz v podmínce elseif ohodnocen jako TRUE. Například následující kód vypíše a je větší než b, a se rovná b nebo a je menší než b:

if ($a > $b) {
    print "a je větší než b";
} elseif ($a == $b) {
    print "a se rovná b";
} else {
    print "a je menší než b";
}

V rámci jednoho příkazu if může být více příkazů elseif. Provádí se první příkaz elseif (pokud vůbec nějaký), jehož výraz je ohodnocen TRUE. V PHP můžete napsat i 'else if' (dvěma slovy), chování bude naprosto totožné jako u 'elseif' (jedním slovem). Syntaktický význam je mírně odlišný (znáte-li C, je to stejné), avšak ve výsledku dostaneme přesně totožné chování.

Příkaz elseif se provádí, pouze jsou-li příslušný (bezprostředně předcházející) výraz příkazu if a výrazy všech příslušných předcházejících příkazů elseif ohodnoceny jako FALSE, a konkrétní výraz v elseif ohodnocen jako TRUE.

Předcházející | Nahoru | Další
else | Domů | Alternativní syntaxe řídicích struktur


for

Cykly for jsou nejsložitějšími cykly v PHP. Chovají se stejně, jako jejich soukmenovci v C. Syntaxe cyklu for je následující:

for (expr1; expr2; expr3) statement

První výraz (expr1) je ohodnocen (proveden) jednou, bezpodmínečně, na začátku cyklu.

Na začátku každé iterace je ohodnocen výraz expr2. Pokud má hodnotu TRUE, cyklus pokračuje a zpracovává se kód uvnitř cyklu. Je-li naopak jeho hodnota FALSE, provádění cyklu končí.

Na konci každé iterace se ohodnotí (provede) výraz expr3.

Každý z výrazů může být prázdný. Prázdný výraz expr2 znamená, že cyklus bude probíhat nekonečně dlouho (PHP, stejně jako C, implicitně předpokládá hodnotu TRUE). To nemusí být tak bez užitku, jak si můžete myslet. Často můžete totiž chtít ukončit cyklus pomocí podmíněného příkazu break, namísto použití pravdivostního výrazu v příkazu cyklu for.

Předpokládejme následující příklady. Všechny zobrazí čísla od 1 do 10:

/* příklad 1 */

for ($i = 1; $i <= 10; $i++) {
    print $i;
}

/* příklad 2 */

for ($i = 1;;$i++) {
    if ($i > 10) {
        break;
    }
    print $i;
}

/* příklad 3 */

$i = 1;
for (;;) {
    if ($i > 10) {
        break;
    }
    print $i;
    $i++;
}

/* příklad 4 */

for ($i = 1; $i <= 10; print $i, $i++);

První příklad samozřejmě vypadá nejlépe (nebo možná i ten čtvrtý), ale můžete přijít na to, že schopnost používat prázdné výrazy v cyklech for nemusí být někdy úplně k zahození.

PHP podporuje pro cykly for také alternativní "dvojtečkovou syntaxi".

for (expr1; expr2; expr3): statement; ...; endfor;

Jiné jazyky mají příkaz foreach k traverzování polí nebo hashů. V PHP 3 nic takového není, PHP 4 ano (viz foreach). V PHP 3 můžete k dosažení stejného efektu kombinovat while s funkcemi list() a each(). Příklady najdete v dokumentaci.

Předcházející | Nahoru | Další
do..while | Domů | foreach


foreach

PHP 4 (ne PHP 3) zahrnuje příkaz foreach, podobně jako Perl a různé další jazyky. To poskytuje snadný způsob k iteraci přes pole. Existují dvě syntaxe; ta druhá je menším, avšak užitečným rozšířením té první:

foreach(array_expression as $value) statement
foreach(array_expression as $key => $value) statement

První forma traverzuje pole dané výrazem array_expression. V každé iteraci je hodnota aktuálního elementu přiřazena do $value a vnitřní ukazatel na pole je zvýšen o jednotku (tzn. v příští iteraci budete hledět na následující element).

Druhá forma dělá totéž, kromě toho, že aktuální klíč elementu bude v každé iteraci přiřazen do proměnné $key.

Poznámka: Když foreach začne provádění první iterace, je vnitřní ukazatel automaticky nastaven na první element pole. To znamená, že před foreach nemusíte volat reset().

Poznámka: Uvědomte si také, že foreach pracuje na kopii specifikovaného pole, nikoli na poli samotném, proto ukazatel na pole není modifikován tak, jako příkazem each() a změny na vráceném elementu se na původním poli neprojeví.

Poznámka: foreach nepodporuje možnost potlačit chybová hlášení použitím '@'.

Můžete si všimnout, že následující příklady jsou funkčně totožné:

reset ($arr);
while (list(, $value) = each ($arr)) {
    echo "Hodnota: $value<br>\n";
}

foreach ($arr as $value) {
    echo "Hodnota: $value<br>\n";
}
Následující příklady jsou rovněž funkčně totožné:
reset ($arr);
while (list($key, $value) = each ($arr)) {
    echo "Klíč: $key; Hodnota: $value<br>\n";
}

foreach ($arr as $key => $value) {
    echo "Klíč: $key; Hodnota: $value<br>\n";
}

Další příklady demonstrující použítí:

/* foreach příklad 1: pouze hodnota */

$a = array (1, 2, 3, 17);

foreach ($a as $v) {
   print "Současná hodnota \$a: $v.\n";
}

/* foreach příklad 2: hodnota (pro ilustraci je vypsán i klíč) */

$a = array (1, 2, 3, 17);

$i = 0; /* pouze pro ilustrativní účely */

foreach($a as $v) {
    print "\$a[$i] => $v.\n";
    $i++;
}

/* foreach příklad 3: klíč a hodnota */

$a = array (
    "jedna" => 1,
    "dvě" => 2,
    "tři" => 3,
    "sedmnáct" => 17
);

foreach($a as $k => $v) {
    print "\$a[$k] => $v.\n";
}

/* foreach příklad 4: vícerozměrná pole */

$a[0][0] = "a";
$a[0][1] = "b";
$a[1][0] = "y";
$a[1][1] = "z";

foreach($a as $v1) {
    foreach ($v1 as $v2) {
        print "$v2\n";
    }
}

/* foreach příklad 5: dynamická pole */

foreach(array(1, 2, 3, 4, 5) as $v) {
    print "$v\n";
}

Předcházející | Nahoru | Další
for | Domů | break


switch

Příkaz switch je podobná sérii příkazů IF, testujících tentýž výraz. V mnoha případech můžete chtít porovnávat stejnou proměnnou (nebo výraz) s mnoha různými hodnotami a provádět různé kusy kódu v závislosti na tom, které hodnotě se rovná. To je přesně to, k čemu je switch.

Následující dva příklady představují dva odlišné způsoby, jak napsat totéž; jeden používá sérii podmínek if, zatímco druhý je založen na příkazu switch:

if ($i == 0) {
    print "i se rovná 0";
}
if ($i == 1) {
    print "i se rovná 1";
}
if ($i == 2) {
    print "i se rovná 2";
}

switch ($i) {
    case 0:
        print "i se rovná 0";
        break;
    case 1:
        print "i se rovná 1";
        break;
    case 2:
        print "i se rovná 2";
        break;
}

Je důležité pochopit, jak se příkaz switch provádí, aby se zabránilo chybám. Příkaz switch provádí řádek po řádku (resp. příkaz po příkazu). Na začátku není proveden žádný kód. Pouze tehdy, když se najde case s hodnotou odpovídající hodnotě výrazu u switch, začne PHP provádět následující příkazy. Vykonávání kódu pokračuje, dokud se nedosáhne konce bloku switch nebo prvního příkazu break. Pokud nenapíšete na konec bloku po case příkaz break, bude PHP pokračovat v provádění dalších příkazů (po dalším case). Například:

switch ($i) {
    case 0:
        print "i se rovná 0";
    case 1:
        print "i se rovná 1";
    case 2:
        print "i se rovná 2";
}

Zde, pokud se $i rovná 0, se budou provádět všechny příkazy "print"! Pokud se $i rovná 1, PHP provede poslední dva příkazy, a pouze rovná-li se $i číslu 2, obdržíte "očekávané" chování a zobrazí se pouze "i se rovná 2". Takže je důležité nezapomenout na příkaz break (kromě případu, kdy ho chcete vynechat záměrně k dosažení určitého cíle).

V příkazu switch se podmínka testuje pouze jednou a výsledek se porovnává s každou hodnotou v case. V případě elseif se podmínka pokaždé testuje znovu. Pokud je vaše podmínka komplikovanější než jednoduché porovnání a/nebo je uvnitř cyklu, switch může být rychlejší.

Seznam příkazů za case může být také prázdný, což jednoduše předá řízení následujícímu case.

switch ($i) {
    case 0:
    case 1:
    case 2:
        print "i je menší než 3, ale nezáporné";
        break;
    case 3:
        print "i je 3";
}

Speciální case je "default". Vyhovuje všem ostatním hodnotám, které nejsou pokryty některým z ostatních case a má být vždy jako poslední. Například:

switch ($i) {
    case 0:
        print "i se rovná 0";
        break;
    case 1:
        print "i se rovná 1";
        break;
    case 2:
        print "i se rovná 2";
        break;
    default:
        print "i se nerovná 0, 1 ani 2";
}

Výraz v case může být libovolný výraz, jehož hodnota je jednoduchého typu, tj. celé nebo reálné číslo nebo řetězec. Pole ani objekty nelze použít, ledaže by odkazovaly na jednoduchý typ.

Alternativní syntaxe pro příkazy switch je podporována. Pro víc informací viz Alternativní syntaxe řídicích struktur .

switch ($i):
    case 0:
        print "i se rovná 0";
        break;
    case 1:
        print "i se rovná 1";
        break;
    case 2:
        print "i se rovná 2";
        break;
    default:
        print "i se nerovná 0, 1 ani 2";
endswitch;

Předcházející | Nahoru | Další
continue | Domů | declare


while

Cykly while jsou nejjednodušším typem cyklů v PHP. Chovají se jako jejich protějšci v C. Základí formát příkazu while je tento:

while (expr) statement

Význam příkazu while je snadno pochopitelný. Říká PHP, že má provádět vnořený(é) příkaz(y) tak dlouho, dokud je výraz ve while roven TRUE. Hodnota výrazu je testována pokaždé na začátku cyklu (v každé iteraci), takže i když se tato hodnota během provádění vnořených příkazů změní, provede se zbytek kódu uvnitř cyklu - v konkrétní iteraci - až do konce (každé provedení kódu uvnitř cyklu je jedna iterace). Někdy, když je výraz ve while ohodnocen jako FALSE již při vstupu do cyklu, vnořený kód se neprovede vůbec.

Podobně, jako v případě if, můžete i zde seskupovat příkazy uvnitř cyklu while ohraničením tohoto kódu složenými závorkami nebo za použití alternativní syntaxe:

while (expr): statement ... endwhile;

Následující příklady jsou identické, oba vypíší čísla od 1 do 10:

/* příklad 1 */

$i = 1;
while ($i <= 10) {
    print $i++;  /* vytištěná hodnota by byla rovna
                    $i před inkrementací
                    (post-inkrementace) */
}

/* příklad 2 */

$i = 1;
while ($i <= 10):
    print $i;
    $i++;
endwhile;

Předcházející | Nahoru | Další
Alternativní syntaxe řídicích struktur | Domů | do..while


Příloha K. Kategorizace rozšíření

Obsah

Účel
Členství
Stav

Tento dodatek kategorizuje víc než 150 rozšíření, zdokumentovaných v PHP manuálu, podle různých kritérií.

Účel

Základní rozšíření PHP

Rozšíření vztahující se k proměnným a typům

  • Arrays

  • Classkit

  • Třídy/Objekty

  • ctype

  • Filter

  • Funkce

  • Object Aggregation

  • Variables handling

Zpracování textu

  • PCRE

  • POSIX Regex

  • Řetězce

  • xdiff

Změny chování PHP

  • APC

  • APD

  • bcompiler

  • Errors and Logging

  • http

  • PHP volby/info

  • Řízení výstupu

  • runkit

Rozšíření sessions

  • Msession

  • muscat

  • Sessions

  • Session PgSQL

Jiná základní rozšíření

  • GeoIP

  • JSON

  • Různé

  • Parsekit

  • SPL

  • tidy

  • Tokenizer

  • URL

Databázová rozšíření

Abstrakční hladiny

  • dba

  • dbx

  • PDO

  • SDO-DAS-Relational

  • ODBC

Dodavatelsky speficická databázová rozšíření

  • dBase

  • DB++

  • FrontBase

  • filePro

  • Firebird/InterBase

  • ibm_db2

  • Informix

  • Ingres II

  • MaxDB

  • mSQL

  • MS SQL Server

  • MySQL

  • mysqli

  • OCI8

  • Oracle

  • OvrimosSQL

  • Paradox

  • MS SQL Server (PDO)

  • Firebird/Interbase (PDO)

  • IBM (PDO)

  • Informix (PDO)

  • MySQL (PDO)

  • Oracle (PDO)

  • ODBC and DB2 (PDO)

  • PostgreSQL (PDO)

  • SQLite (PDO)

  • PostgreSQL

  • SQLite

  • Sybase

XML manipulace

  • DOM

  • DOM XML

  • libxml

  • qtdom

  • SCA

  • SDO

  • SDO DAS XML

  • SimpleXML

  • XML

  • XMLReader

  • XMLWriter

  • XSL

  • XSLT

Webové služby

  • SOAP

  • WDDX

  • XML-RPC

Zpracování platebních karet

  • Cybercash

  • CyberMUT

  • MCVE

  • Verisign Payflow Pro

Matematika a kryptografie

Matematická rozšíření

  • BC math

  • GMP

  • Matematika

  • Statistics

Kryptografická rozšíření

  • Crack

  • hash

  • mcrypt

  • mhash

  • OpenSSL

Lidský jazyk a podpora kódování znaků

  • enchant

  • FriBiDi

  • gettext

  • i18n

  • iconv

  • Multibyte String

  • Pspell

  • Recode

  • Unicode

Souborový systém a správa procesů

Rozšíření týkající se souborových systémů

  • Direct IO

  • Adresáře

  • fam

  • Fileinfo

  • Filesystém

  • Mimetype

  • xattr

Rozšíření pro správu procesů

  • Spouštění programů

  • Expect

  • PCNTL

  • POSIX

  • Semaphore

  • shmop

Přístupové služby

Poštovní rozšíření

  • Cyrus IMAP

  • IMAP

  • Mail

  • Mailparse

  • vpopmail

Autentizační služby

  • kadm5

  • radius

Ostatní služby

  • CURL

  • FTP

  • Hyperwave

  • Hyperwave API

  • IRC Gateway

  • Java

  • LDAP

  • Memcache

  • mnoGoSearch

  • gopher

  • Síť

  • YP/NIS

  • Lotus Notes

  • SAM

  • SNMP

  • Sockets

  • ssh2

  • Streams

  • SVN

  • TCP Wrappers

  • YAZ

Kompresní rozšíření

  • Bzip2

  • LZF

  • phar

  • Rar

  • Zip

  • Zlib

Rozšíření týkající se kalendáře a událostí

  • Kalendář

  • Datum/čas

  • MCAL

Rozšíření specifická pro konkrétní oblast

Netextový MIME výstup

  • ClibPDF

  • FDF

  • gnupg

  • haru

  • Ming (flash)

  • PDF

  • PS

  • RPMReader

  • SWF

  • swish

Zpracování a generování obrázků

  • Exif

  • Image

  • Imagick Image Library

Manipulace s formáty zvuku

  • id3

  • OGG/Vorbis

  • openal

Rozšíření specifická pro příkazovou řádku

  • Ncurses

  • Newt

  • Readline

Rozšíření pouze pro Windows

  • COM

  • .NET

  • Printer

  • W32api

  • win32ps

  • win32service

Serverově specifická rozšíření

  • Apache

  • IIS Functions

  • NSAPI

Předcházející | Nahoru | Další
List of timezones in the group Others | Domů | Členství


Členství

Základní (jaderná) rozšíření

V tuto chvíli nejsou rozšířeními. Jsou součástí jádra PHP a nelze je kompilačními volbami vyloučit z PHP.

  • Arrays

  • Třídy/Objekty

  • Datum/čas

  • Adresáře

  • Errors and Logging

  • Spouštění programů

  • Filesystém

  • Funkce

  • i18n

  • PHP volby/info

  • Mail

  • Matematika

  • Různé

  • Síť

  • Řízení výstupu

  • POSIX Regex

  • Sessions

  • Streams

  • Řetězce

  • Tokenizer

  • Unicode

  • URL

  • Variables handling

Přibalená rozšíření

Tato rozšíření jsou přibalena k PHP.

  • Apache

  • BC math

  • Bzip2

  • Kalendář

  • COM

  • ctype

  • CURL

  • dba

  • dBase

  • DOM

  • .NET

  • Exif

  • FrontBase

  • FDF

  • FTP

  • gettext

  • GMP

  • hash

  • Firebird/InterBase

  • iconv

  • Informix

  • Image

  • IMAP

  • JSON

  • LDAP

  • libxml

  • Multibyte String

  • mcrypt

  • mhash

  • Mimetype

  • Ming (flash)

  • mSQL

  • MS SQL Server

  • MySQL

  • mysqli

  • Ncurses

  • NSAPI

  • Object Aggregation

  • OCI8

  • OpenSSL

  • PCNTL

  • PCRE

  • PDO

  • MS SQL Server (PDO)

  • Firebird/Interbase (PDO)

  • MySQL (PDO)

  • Oracle (PDO)

  • ODBC and DB2 (PDO)

  • PostgreSQL (PDO)

  • SQLite (PDO)

  • PostgreSQL

  • POSIX

  • Pspell

  • Readline

  • Recode

  • Semaphore

  • shmop

  • SimpleXML

  • SNMP

  • SOAP

  • Sockets

  • SPL

  • SQLite

  • SVN

  • Sybase

  • tidy

  • ODBC

  • WDDX

  • XML

  • XMLReader

  • XML-RPC

  • XSL

  • XSLT

  • Zip

  • Zlib

Externí rozšíření

Ke kompilaci těchto rozšíření budou potřeba externí knihovny.

  • BBCode

  • Bzip2

  • ClibPDF

  • Crack

  • CURL

  • dBase

  • DB++

  • dbx

  • DOM

  • DOM XML

  • enchant

  • fam

  • FrontBase

  • FDF

  • Fileinfo

  • FriBiDi

  • GeoIP

  • gettext

  • GMP

  • haru

  • Hyperwave

  • Hyperwave API

  • i18n

  • Firebird/InterBase

  • ibm_db2

  • Informix

  • Imagick Image Library

  • IMAP

  • Ingres II

  • IRC Gateway

  • Java

  • LDAP

  • libxml

  • MaxDB

  • MCAL

  • mcrypt

  • Memcache

  • mhash

  • Ming (flash)

  • mnoGoSearch

  • Msession

  • mSQL

  • MS SQL Server

  • muscat

  • MySQL

  • mysqli

  • Ncurses

  • Newt

  • OCI8

  • OGG/Vorbis

  • openal

  • OpenSSL

  • Oracle

  • OvrimosSQL

  • Paradox

  • PDF

  • MS SQL Server (PDO)

  • Firebird/Interbase (PDO)

  • IBM (PDO)

  • Informix (PDO)

  • MySQL (PDO)

  • Oracle (PDO)

  • ODBC and DB2 (PDO)

  • PostgreSQL (PDO)

  • Verisign Payflow Pro

  • PostgreSQL

  • PS

  • Pspell

  • qtdom

  • radius

  • Rar

  • Readline

  • Recode

  • Session PgSQL

  • SimpleXML

  • SNMP

  • SOAP

  • ssh2

  • SWF

  • swish

  • Sybase

  • tidy

  • Unicode

  • ODBC

  • vpopmail

  • WDDX

  • xattr

  • xdiff

  • XML

  • XMLReader

  • XSL

  • XSLT

  • YAZ

Rozšíření PECL

Tato rozšíření jsou k dispozici na » PECL. Existuje ještě více rozšíření PECL, ale nejsou ještě zdokumentována v PHP manuálu.

  • APC

  • APD

  • BBCode

  • bcompiler

  • Classkit

  • ClibPDF

  • Crack

  • Cybercash

  • CyberMUT

  • Cyrus IMAP

  • DB++

  • dbx

  • Direct IO

  • DOM XML

  • enchant

  • Expect

  • fam

  • Fileinfo

  • filePro

  • Filter

  • FriBiDi

  • GeoIP

  • gnupg

  • haru

  • hash

  • http

  • Hyperwave

  • Hyperwave API

  • ibm_db2

  • id3

  • IIS Functions

  • Imagick Image Library

  • Ingres II

  • IRC Gateway

  • Java

  • JSON

  • kadm5

  • LZF

  • Mailparse

  • MaxDB

  • MCAL

  • MCVE

  • Memcache

  • mnoGoSearch

  • Msession

  • muscat

  • Ncurses

  • gopher

  • Newt

  • YP/NIS

  • Lotus Notes

  • OGG/Vorbis

  • openal

  • Oracle

  • OvrimosSQL

  • Paradox

  • Parsekit

  • PDF

  • PDO

  • MS SQL Server (PDO)

  • Firebird/Interbase (PDO)

  • IBM (PDO)

  • Informix (PDO)

  • MySQL (PDO)

  • Oracle (PDO)

  • ODBC and DB2 (PDO)

  • PostgreSQL (PDO)

  • SQLite (PDO)

  • Verisign Payflow Pro

  • phar

  • Printer

  • PS

  • qtdom

  • radius

  • Rar

  • RPMReader

  • runkit

  • SAM

  • SCA

  • SDO

  • SDO DAS XML

  • SDO-DAS-Relational

  • Session PgSQL

  • ssh2

  • Statistics

  • SVN

  • SWF

  • swish

  • TCP Wrappers

  • tidy

  • vpopmail

  • W32api

  • win32ps

  • win32service

  • xattr

  • xdiff

  • XMLReader

  • XMLWriter

  • YAZ

  • Zip

Předcházející | Nahoru | Další
K. Kategorizace rozšíření | Domů | Stav


Stav

Tato část seznamu obsahuje rozšíření, která nejsou určena k produkčnímu nasazení - jsou příliš "stará" (zavržená) nebo "nová" (experimentální).

Zavržená rozšíření

Tato rozšíření byla zavržena, obvykle ve prospěch jiných rozšíření.

  • Aspell

  • CCVS

  • ClibPDF

  • DBM

  • Mimetype

  • Oracle

  • Object overloading

  • Satellite

  • SESAM

Experimentální rozšíření

Chování těchto rozšíření - včetně názvů jejich funkcí a čehokoli dalšího zdokumentovaného o těchto rozšíření - se může v dalších verzích PHP bez varování změnit. Tato rozšíření používáte na vlastní nebezpečí..

  • bcompiler

  • DB++

  • .NET

  • haru

  • hash

  • Imagick Image Library

  • Java

  • Ming (flash)

  • muscat

  • Ncurses

  • Newt

  • Lotus Notes

  • Object Aggregation

  • Paradox

  • MS SQL Server (PDO)

  • Firebird/Interbase (PDO)

  • Oracle (PDO)

  • PS

  • qtdom

  • SCA

  • SDO-DAS-Relational

  • swish

  • vpopmail

  • W32api

  • XML-RPC

Předcházející | Nahoru | Další
Členství | Domů | L. Seznam aliasů funkcí


Šifrovací filtry

mcrypt.* a mdecrypt.* poskytují symetrické šifrování a dešifrování pomocí libmcrypt. Obě sady filtrů podporují stejné algoritmy dostupné pro mcrypt extension ve formě mcrypt.ciphername, kde ciphername je název šifry, jak byl předán do funkce mcrypt_module_open(). K dispozici je také těchto pět parametrů filtru:

Tabulka P.1. parametry filtru mcrypt

Parametr | Vyžadován? | Výchozí | Ukázky hodnot
mode | nepovinný | cbc | cbc, cfb, ecb, nofb, ofb, stream
algorithms_dir | nepovinný | ini_get('mcrypt.algorithms_dir') | Umístění modulů algoritmů
modes_dir | nepovinný | ini_get('mcrypt.modes_dir') | Umístění modulů režimů
iv | povinný | N/A | Typicky 8, 16, nebo 32 B binárních dat. Záleží na šifře.
key | povinný | N/A | Typicky 8, 16, nebo 32 B binárních dat. Záleží na šifře.

Příklad P.10. šifrování souboru pomocí 3DES

<?php
$passphrase = 'My secret';

/* Převeď lidsky čitelné heslo
 * na reprodukovatelný pár iv/key
 */
$iv = substr(md5('iv'.$passphrase, true), 0, 8);
$key = substr(md5('pass1'.$passphrase, true) .
               md5('pass2'.$passphrase, true), 0, 24);
$opts = array('iv'=>$iv, 'key'=>$key);

$fp = fopen('secert-file.enc', 'wb');
stream_filter_append($fp, 'mcrypt.tripledes', STREAM_FILTER_WRITE, $opts);
fwrite($fp, 'Secret secret secret data');
fclose($fp);
?>

Příklad P.11. ?tení za?ifrovaného souboru

<?php
$passphrase = 'My secret';

/* Převeď lidsky čitelné heslo
 * na reprodukovatelný pár iv/key
 */
$iv = substr(md5('iv'.$passphrase, true), 0, 8);
$key = substr(md5('pass1'.$passphrase, true) .
               md5('pass2'.$passphrase, true), 0, 24);
$opts = array('iv'=>$iv, 'key'=>$key);

$fp = fopen('secert-file.enc', 'rb');
stream_filter_append($fp, 'mdecrypt.tripledes', STREAM_FILTER_WRITE, $opts);
$data = rtrim(stream_get_contents($fp));
fclose($fp);

echo $data;
?>

Předcházející | Nahoru | Další
Kompresní filtry | Domů | Q. Seznam podporovaných socketových transportů


apache_reset_timeout

(PHP 5 >= 5.1.0)

apache_reset_timeout — Reset the Apache write timer

Popis

bool apache_reset_timeout ( void )

apache_reset_timeout() resets the Apache write timer, which defaults to 300 seconds. With set_time_limit(0); ignore_user_abort(true) and periodic apache_reset_timeout() calls, Apache can theoretically run forever.

This function requires Apache 1.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Poznámky

Poznámka: Tyto funkce jsou v bezpečném režimu (safe-mode) deaktivovány.

Předcházející | Nahoru | Další
apache_request_headers | Domů | apache_response_headers


apc_add

(PECL apc:3.0.13-3.0.14)

apc_add — Cache a variable in the data store (only if it's not stored)

Popis

bool apc_add ( string $key, mixed $var [, int $ttl] )

Poznámka: Unlike many other mechanisms in PHP, variables stored using apc_add() will persist between requests (until the value is removed from the cache).

Seznam parametrů

key

Store the variable using this name. keys are cache-unique, so attempting to use apc_add() to store data with a key that already exists will not overwrite the existing data, and will instead return FALSE. (This is the only difference between apc_add() and apc_store().)

var

The variable to store

ttl

Time To Live; store var in the cache for ttl seconds. After the ttl has passed, the stored variable will be expunged from the cache (on the next request). If no ttl is supplied (or if the ttl is 0), the value will persist until it is removed from the cache manually, or otherwise fails to exist in the cache (clear, restart, etc.).

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 158. A apc_add() example

<?php
$bar = 'BAR';
apc_add('foo', $bar);
var_dump(apc_fetch('foo'));
echo "\n";
$bar = 'NEVER GETS SET';
apc_add('foo', $bar);
var_dump(apc_fetch('foo'));
echo "\n";
?>

Výše uvedený příklad vypíše:

string(3) "BAR"
string(3) "BAR"

Viz také

apc_store()
apc_fetch()
apc_delete()

Předcházející | Nahoru | Další
III. Alternative PHP Cache | Domů | apc_cache_info


apc_cache_info

(PECL apc:2.0-3.0.9)

apc_cache_info — Retrieves cached information (and meta-data) from APC's data store

Popis

array apc_cache_info ( [string $cache_type [, bool $limited]] )

Návratové hodnoty

Array of cached data (and meta-data), or FALSE on failure

Poznámka: apc_cache_info() will raise a warning if it is unable to retrieve APC cache data. This typically occurs when APC is not enabled.

Seznam parametrů

cache_type

If cache_type is "user", information about the user cache will be returned; otherwise, information about the system cache (cached files) will be returned.

limited

If limited is TRUE, the return value will exclude the individual list of cache entries. This is usefull when trying to optimize calls for statistics gathering.

ChangeLog (záznam změn)

Verze | Popis
3.0.11 | The limited parameter was introduced.

Příklady

Příklad 159. A apc_cache_info() example

<?php
print_r(apc_cache_info());
?>

Výše uvedený příklad vypíše něco jako:

Array
(
    [num_slots] => 2000
    [ttl] => 0
    [num_hits] => 9
    [num_misses] => 3
    [start_time] => 1123958803
    [cache_list] => Array
        (
            [0] => Array
                (
                    [filename] => /path/to/apc_test.php
                    [device] => 29954
                    [inode] => 1130511
                    [type] => file
                    [num_hits] => 1
                    [mtime] => 1123960686
                    [creation_time] => 1123960696
                    [deletion_time] => 0
                    [access_time] => 1123962864
                    [ref_count] => 1
                    [mem_size] => 677
                )
            [1] => Array (...iterates for each cached file)
)

Viz také

APC configuration directives

Předcházející | Nahoru | Další
apc_add | Domů | apc_clear_cache


apc_clear_cache

(PECL apc:2.0-3.0.9)

apc_clear_cache — Clears the APC cache

Popis

bool apc_clear_cache ( [string $cache_type] )

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Seznam parametrů

cache_type

If cache_type is "user", the user cache will be cleared; otherwise, the system cache (cached files) will be cleared.

Předcházející | Nahoru | Další
apc_cache_info | Domů | apc_compile_file


apc_compile_file

(PECL apc:3.0.13-3.0.14)

apc_compile_file — Stores a file in the bytecode cache, bypassing all filters.

Popis

bool apc_compile_file ( string $filename )

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Seznam parametrů

filename

Full or relative path to a PHP file that will be compiled and stored in the bytecode cache.

Předcházející | Nahoru | Další
apc_clear_cache | Domů | apc_define_constants


apc_define_constants

(PECL apc:3.0.0-3.0.9)

apc_define_constants — Defines a set of constants for retrieval and mass-definition

Popis

bool apc_define_constants ( string $key, array $constants [, bool $case_sensitive] )

define() is notoriously slow. Since the main benefit of APC is to increase the performance of scripts/applications, this mechanism is provided to streamline the process of mass constant definition. However, this function does not perform as well as anticipated.

For a better-performing solution, try the » hidef extension from PECL.

Poznámka: To remove a set of stored constants (without clearing the entire cache), an empty array may be passed as the constants parameter, effectively clearing the stored value(s).

Seznam parametrů

key

The key serves as the name of the constant set being stored. This key is used to retrieve the stored constants in apc_load_constants().

constants

An associative array of constant_name => value pairs. The constant_name must follow the normal constant naming rules. value must evaluate to a scalar value.

case_sensitive

The default behaviour for constants is to be declared case-sensitive; i.e. CONSTANT and Constant represent different values. If this parameter evaluates to FALSE the constants will be declared as case-insensitive symbols.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 160. apc_define_constants() example

<?php
$constants = array(
    'ONE'   => 1,
    'TWO'   => 2,
    'THREE' => 3,
);
apc_define_constants('numbers', $constants);
echo ONE, TWO, THREE;
?>

Výše uvedený příklad vypíše:

123

Viz také

apc_load_constants()
define()
constant()
Or the PHP constants reference

Předcházející | Nahoru | Další
apc_compile_file | Domů | apc_delete


apc_delete

(PECL apc:3.0.0-3.0.9)

apc_delete — Removes a stored variable from the cache

Popis

bool apc_delete ( string $key )

Seznam parametrů

key

The key used to store the value (with apc_store()).

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 161. A apc_delete() example

<?php
$bar = 'BAR';
apc_store('foo', $bar);
apc_delete('foo');
// this is obviously useless in this form
?>

Viz také

apc_store()
apc_fetch()

Předcházející | Nahoru | Další
apc_define_constants | Domů | apc_fetch


apc_fetch

(PECL apc:3.0.0-3.0.9)

apc_fetch — Fetch a stored variable from the cache

Popis

mixed apc_fetch ( string $key )

Seznam parametrů

key

The key used to store the value (with apc_store()).

Návratové hodnoty

The stored variable on success; FALSE on failure

Příklady

Příklad 162. A apc_fetch() example

<?php
$bar = 'BAR';
apc_store('foo', $bar);
var_dump(apc_fetch('foo'));
?>

Výše uvedený příklad vypíše:

string(3) "BAR"

Viz také

apc_store()
apc_delete()

Předcházející | Nahoru | Další
apc_delete | Domů | apc_load_constants


apc_load_constants

(PECL apc:3.0.0-3.0.9)

apc_load_constants — Loads a set of constants from the cache

Popis

bool apc_load_constants ( string $key [, bool $case_sensitive] )

Seznam parametrů

key

The name of the constant set (that was stored with apc_define_constants()) to be retrieved.

case_sensitive

The default behaviour for constants is to be declared case-sensitive; i.e. CONSTANT and Constant represent different values. If this parameter evaluates to FALSE the constants will be declared as case-insensitive symbols.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 163. apc_load_constants() example

<?php
$constants = array(
    'ONE'   => 1,
    'TWO'   => 2,
    'THREE' => 3,
);
apc_define_constants('numbers', $constants);
apc_load_constants('numbers');
echo ONE, TWO, THREE;
?>

Výše uvedený příklad vypíše:

123

Viz také

apc_define_constants()
define()
constant()
Or the PHP constants reference

Předcházející | Nahoru | Další
apc_fetch | Domů | apc_sma_info


apc_sma_info

(PECL apc:2.0-3.0.9)

apc_sma_info — Retrieves APC's Shared Memory Allocation information

Popis

array apc_sma_info ( [bool $limited] )

Seznam parametrů

limited

Návratové hodnoty

Array of Shared Memory Allocation data; FALSE on failure.

Příklady

Příklad 164. A apc_sma_info() example

<?php
print_r(apc_sma_info());
?>

Výše uvedený příklad vypíše něco jako:

Array
(
    [num_seg] => 1
    [seg_size] => 31457280
    [avail_mem] => 31448408
    [block_lists] => Array
        (
            [0] => Array
                (
                    [0] => Array
                        (
                            [size] => 31448408
                            [offset] => 8864
                        )

                )

        )

)

Viz také

APC configuration directives

Předcházející | Nahoru | Další
apc_load_constants | Domů | apc_store


apc_store

(PECL apc:3.0.0-3.0.9)

apc_store — Cache a variable in the data store

Popis

bool apc_store ( string $key, mixed $var [, int $ttl] )

Poznámka: Unlike many other mechanisms in PHP, variables stored using apc_store() will persist between requests (until the value is removed from the cache).

Seznam parametrů

key

Store the variable using this name. keys are cache-unique, so storing a second value with the same key will overwrite the original value.

var

The variable to store

ttl

Time To Live; store var in the cache for ttl seconds. After the ttl has passed, the stored variable will be expunged from the cache (on the next request). If no ttl is supplied (or if the ttl is 0), the value will persist until it is removed from the cache manually, or otherwise fails to exist in the cache (clear, restart, etc.).

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 165. A apc_store() example

<?php
$bar = 'BAR';
apc_store('foo', $bar);
var_dump(apc_fetch('foo'));
?>

Výše uvedený příklad vypíše:

string(3) "BAR"

Viz také

apc_add()
apc_fetch()
apc_delete()

Předcházející | Nahoru | Další
apc_sma_info | Domů | IV. Advanced PHP debugger


array_fill_keys

(PHP 5 >= 5.2.0)

array_fill_keys — Fill an array with values, specifying keys

Popis

array array_fill_keys ( array $keys, mixed $value )

Fills an array with the value of the value parameter, using the values of the keys array as keys.

Seznam parametrů

keys

Array of values that will be used as keys

value

Either an string or an array of values

Návratové hodnoty

Returns the filled array

Příklady

Příklad 192. array_fill_keys() example

<?php
$keys = array('foo', 5, 10, 'bar');
$a = array_fill_keys($keys, 'banana');
print_r($a);
?>

Výše uvedený příklad vypíše:

Array
(
    [foo] => banana
    [5] => banana
    [10] => banana
    [bar] => banana
)

Viz také

array_fill()
array_combine()

Předcházející | Nahoru | Další
array_diff | Domů | array_fill


array_product

(PHP 5 >= 5.1.0)

array_product — Calculate the product of values in an array

Description

number array_product ( array $array )

array_product() returns the product of values in an array as an integer or float.

Příklad 215. array_product() examples

<?php

$a = array(2, 4, 6, 8);
echo "product(a) = " . array_product($a) . "\n";

?>

Výše uvedený příklad vypíše:

product(a) = 384

Předcházející | Nahoru | Další
array_pop | Domů | array_push


bbcode_add_element

(PECL bbcode:0.9.0-0.9.1)

bbcode_add_element — Adds a bbcode element

Popis

bool bbcode_add_element ( resource $bbcode_container, string $tag_name, array $tag_rules )

Adds a tag to an existing BBCode_Container tag_set using tag_rules.

Seznam parametrů

bbcode_container

BBCode_Container resource, returned by bbcode_create().

tag_name

The new tag to add to the BBCode_Container tag_set.

tag_rules

An associative array containing the parsing rules; see bbcode_create() for the available keys.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
VII. BBCode Functions | Domů | bbcode_add_smiley


bbcode_add_smiley

(No version information available, might be only in CVS)

bbcode_add_smiley — Adds a smiley to the parser

Popis

bool bbcode_add_smiley ( resource $bbcode_container, string $smiley, string $replace_by )

Adds a smiley to the parser

Seznam parametrů

bbcode_container

BBCode_Container resource, returned by bbcode_create().

smiley

The string that will be replaced when found.

replace_by

The string that replace smiley when found.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 265. bbcode_add_smiley() usage example

<?php
/*
 * Prepare the rule set
 */
$arrayBBCode=array(
    ''=>         array('type'=>BBCODE_TYPE_ROOT,
                       'childs'=>'!i'),
    'b'=>        array('type'=>BBCODE_TYPE_NOARG,
                       'open_tag'=>'<b>',
                       'close_tag'=>'</b>'),
    'u'=>        array('type'=>BBCODE_TYPE_NOARG,
                       'open_tag'=>'<u>',
                       'close_tag'=>'</u>',
                       'flags'=>BBCODE_FLAGS_SMILEYS_OFF),
    'i'=>        array('type'=>BBCODE_TYPE_NOARG,
                       'open_tag'=>'<i>',
                       'close_tag'=>'</i>',
                       'childs'=>'b'),
);
/*
 * Parsed Text
 */
$text=<<<EOF
[i] No parse Test [/i] :)
[b] Parsed, with smiley :( [/b]
[u] Parsed, with no smiley :D [/u]
EOF;
/*
 * Init the parser
 */
$BBHandler=bbcode_create($arrayBBCode);
/*
 * Add Smiley rules to parser
 */
bbcode_add_smiley($BBHandler, ":)", "<img src=\"smiley.gif\" alt=\":)\" />");
bbcode_add_smiley($BBHandler, ":(", "<img src=\"sad.gif\" alt=\":(\" />");
bbcode_add_smiley($BBHandler, ":D", "<img src=\"happy.gif\" alt=\":D\" />");
bbcode_add_smiley($BBHandler, ":p", "<img src=\"tong.gif\" alt=\":p\" />");
bbcode_add_smiley($BBHandler, ":|", "<img src=\"special.gif\" alt=\":|\" />");
bbcode_add_smiley($BBHandler, ":6:", "<img src=\"six.gif\" alt=\":6:\" />");
/*
 * Parse the text
 */
echo bbcode_parse($BBHandler,$text);
?>

Výše uvedený příklad vypíše:

[i] No parse Test [/i] <img src="smiley.gif" alt=":)" />
<b> Parsed, with smiley <img src="sad.gif" alt=":(" /> </b>
<u> Parsed, with no smiley :D </u>

Předcházející | Nahoru | Další
bbcode_add_element | Domů | bbcode_create


bbcode_create

(PECL bbcode:0.9.0-0.9.1)

bbcode_create — Create a BBCode Resource

Popis

resource bbcode_create ( [array $bbcode_initial_tags] )

This function returns a new BBCode Resource used to parse BBCode strings.

Seznam parametrů

bbcode_initial_tags

An associative array containing the tag names as keys and parameters required to correctly parse BBCode as their value. The following key/value pairs are supported:

  • flags optional - a flag set based on the BBCODE_FLAGS_* constants.
  • type required - an int indicating the type of tag. Use the BBCODE_TYPE_* constants.
  • open_tag required - the HTML replacement string for the open tag.
  • close_tag required - the HTML replacement string for the close tag.
  • default_arg optional - use this value as the default argument if none is provided and tag_type is of type OPTARG.
  • content_handling optional - Gives the callback used for modification of the content. Object Oriented Notation supported only since 0.10.1 callback prototype is string name(string $content, string $argument)
  • param_handling optional - Gives the callback used for modification of the argument. Object Oriented Notation supported only since 0.10.1 callback prototype is string name(string $content, string $argument)
  • childs optional - List of accepted child for the tag. The format of the list is a comma separated string. If the list starts with ! it will be the list of rejected child for the tag.
  • parent optional - List of accepted child for the tag. The format of the list is a comma separated string.

Návratové hodnoty

Returns a BBCode_Container

Příklady

Příklad 266. bbcode_create() example

<?php
$arrayBBCode=array(
    ''=>         array('type'=>BBCODE_TYPE_ROOT,  'childs'=>'!i'),
    'i'=>        array('type'=>BBCODE_TYPE_NOARG, 'open_tag'=>'<i>',
                    'close_tag'=>'</i>', 'childs'=>'b'),
    'url'=>      array('type'=>BBCODE_TYPE_OPTARG,
                    'open_tag'=>'<a href="{PARAM}">', 'close_tag'=>'</a>',
                    'default_arg'=>'{CONTENT}',
                    'childs'=>'b,i'),
    'img'=>      array('type'=>BBCODE_TYPE_NOARG,
                    'open_tag'=>'<img src="', 'close_tag'=>'" />',
                    'childs'=>''),
    'b'=>        array('type'=>BBCODE_TYPE_NOARG, 'open_tag'=>'<b>',
                    'close_tag'=>'</b>'),
);
$text=<<<EOF
[b]Bold Text[/b]
[i]Italic Text[/i]
[url]http://www.php.net/[/url]
[url=http://pecl.php.net/][b]Content Text[/b][/url]
[img]http://static.php.net/www.php.net/images/php.gif[/img]
[url=http://www.php.net/]
[img]http://static.php.net/www.php.net/images/php.gif[/img]
[/url]
EOF;
$BBHandler=bbcode_create($arrayBBCode);
echo bbcode_parse($BBHandler,$text);
?>

Výše uvedený příklad vypíše:

<b>Bold Text</b>
<i>Italic Text</i>
<a href="http://www.php.net/">http://www.php.net/</a>
<a href="http://pecl.php.net/"><b>Content Text</b></a>
<img src="http://static.php.net/www.php.net/images/php.gif" />
<a href="http://www.php.net/">
[img]http://static.php.net/www.php.net/images/php.gif[/img]
</a>

Předcházející | Nahoru | Další
bbcode_add_smiley | Domů | bbcode_destroy


bbcode_destroy

(PECL bbcode:0.9.0-0.9.1)

bbcode_destroy — Close BBCode_container resource

Popis

bool bbcode_destroy ( resource $bbcode_container )

This function closes the resource opened by bbcode_create().

Seznam parametrů

bbcode

BBCode_Container resource returned by bbcode_create().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
bbcode_create | Domů | bbcode_parse


bbcode_parse

(PECL bbcode:0.9.0-0.9.1)

bbcode_parse — Parse a string following a given rule set

Popis

string bbcode_parse ( resource $bbcode_container, string $to_parse )

This function parse the string to_parse following the rules in the bbcode_container created by bbcode_create()

Seznam parametrů

bbcode_container

BBCode_Container resource returned by bbcode_create().

to_parse

The string we need to parse.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
bbcode_destroy | Domů | bbcode_set_arg_parser


bbcode_set_arg_parser

(No version information available, might be only in CVS)

bbcode_set_arg_parser — Attach another parser in order to use another rule set for argument parsing

Popis

bool bbcode_set_arg_parser ( resource $bbcode_container, resource $bbcode_arg_parser )

Attaches another parser to the bbcode_container. This parser is used only when arguments must be parsed. If this function is not used, the default argument parser is the parser itself.

Seznam parametrů

bbcode_container

BBCode_Container resource, returned by bbcode_create().

bbcode_arg_parser

BBCode_Container resource, returned by bbcode_create(). It will be used only for parsed arguments

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 267. bbcode_set_arg_parser() usage example

<?php
/*
 * Generating bbcode ruleset for main parser
 */
$arrayBBCode=array(
    'quote'=>    array('type'=>BBCODE_TYPE_ARG,
                       'open_tag'=>'<quote><h4>Source: {PARAM}</h4>',
                       'close_tag'=>'</quote>',
                       'flags'=>BBCODE_FLAGS_REMOVE_IF_EMPTY|BBCODE_FLAGS_ARG_PARSING),
    'b'=>        array('type'=>BBCODE_TYPE_NOARG,
                       'open_tag'=>'<b>', 'close_tag'=>'</b>',
                       'flags'=>BBCODE_FLAGS_REMOVE_IF_EMPTY),
    'u'=>        array('type'=>BBCODE_TYPE_NOARG,
                       'open_tag'=>'<u>', 'close_tag'=>'</u>',
                       'flags'=>BBCODE_FLAGS_SMILEYS_OFF | BBCODE_FLAGS_REMOVE_IF_EMPTY | BBCODE_FLAGS_SMILEYS_OFF),
    'i'=>        array('type'=>BBCODE_TYPE_NOARG,
                       'open_tag'=>'<i>', 'close_tag'=>'</i>',
                       'flags'=>BBCODE_FLAGS_REMOVE_IF_EMPTY),
);
/*
 * Generating bbcode ruleset for argument parser
 */
$arrayBBCode_arg=array(
    'b'=>        array('type'=>BBCODE_TYPE_NOARG,
                       'open_tag'=>'<b class="sub">', 'close_tag'=>'</b>',
                       'flags'=>BBCODE_FLAGS_REMOVE_IF_EMPTY),
    'u'=>        array('type'=>BBCODE_TYPE_NOARG,
                       'open_tag'=>'<u>', 'close_tag'=>'</u>',
                       'flags'=>BBCODE_FLAGS_SMILEYS_OFF | BBCODE_FLAGS_REMOVE_IF_EMPTY | BBCODE_FLAGS_SMILEYS_OFF),
    'i'=>        array('type'=>BBCODE_TYPE_NOARG,
                       'open_tag'=>'<i>', 'close_tag'=>'</i>',
                       'flags'=>BBCODE_FLAGS_REMOVE_IF_EMPTY),
);
/*
 * Text we are going to parse
 */
$text=<<<EOF
[quote="[b]Test[/b]"]
Foo :)
[/quote]
[b]Bar example :)[/b] :)
EOF;
/*
 * Init the two parsers
 */
$BBHandler=bbcode_create($arrayBBCode);
$BBArgHandler=bbcode_create($arrayBBCode_arg);
/*
 * Setting Flags on the parsers
 */
bbcode_set_flags($BBHandler,
                 BBCODE_CORRECT_REOPEN_TAGS|BBCODE_DEFAULT_SMILEYS_ON|BBCODE_ARG_DOUBLE_QUOTE|
                 BBCODE_ARG_SINGLE_QUOTE|BBCODE_ARG_HTML_QUOTE,BBCODE_SET_FLAGS_SET);
bbcode_set_flags($BBArgHandler,
                 BBCODE_CORRECT_REOPEN_TAGS|BBCODE_DEFAULT_SMILEYS_ON|BBCODE_ARG_DOUBLE_QUOTE|
                 BBCODE_ARG_SINGLE_QUOTE|BBCODE_ARG_HTML_QUOTE,BBCODE_SET_FLAGS_SET);
/*
 * Setting $BBArgHandler as the BBHandler argument parser
 */
bbcode_set_arg_parser($BBHandler,$BBArgHandler);
/*
 * Adding Smileys handling rules to Main parser
 */
bbcode_add_smiley($BBHandler, ":)", "<img src=\"smiley.gif\" alt=\":)\" />");
/*
 * Use the main parser to parse text
 */
echo bbcode_parse($BBHandler,$text);
?>

Výše uvedený příklad vypíše:

<quote><h4>Source: <b class="sub">Test</b></h4>
Foo <img src="smiley.gif" alt=":)" />
</quote>
<b>Bar example :)</b> <img src="smiley.gif" alt=":)" />

Předcházející | Nahoru | Další
bbcode_parse | Domů | bbcode_set_flags


bbcode_set_flags

(No version information available, might be only in CVS)

bbcode_set_flags — Set or alter parser options

Popis

bool bbcode_set_flags ( resource $bbcode_container, int $flags [, int $mode] )

Set or alter parser options

Seznam parametrů

bbcode_container

BBCode_Container resource, returned by bbcode_create().

flags

The flag set that must be applied to the bbcode_container options

mode

One of the BBCODE_SET_FLAGS_* constant to set, unset a specific flag set or to replace the flag set by flags.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 268. bbcode_set_flags() usage example

<?php
/*
 * Preparing RuleSet
 */
$arrayBBCode=array(
    'b'=>        array('type'=>BBCODE_TYPE_NOARG,
                       'open_tag'=>'<b>', 'close_tag'=>'</b>'),
    'u'=>        array('type'=>BBCODE_TYPE_NOARG,
                       'open_tag'=>'<u>', 'close_tag'=>'</u>'),
    'i'=>        array('type'=>BBCODE_TYPE_NOARG,
                       'open_tag'=>'<i>', 'close_tag'=>'</i>'),
);
/*
 * Paired incorrectly nested BBCode
 */
$text="[i] Parser [b] Auto Correction [/i] at work [/b]\n";
$BBHandler=bbcode_create($arrayBBCode);
echo bbcode_parse($BBHandler,$text);
// Enabling reopening of automaticaly closed elements
bbcode_set_flags($BBHandler,BBCODE_CORRECT_REOPEN_TAGS,
                 BBCODE_SET_FLAGS_SET);
echo bbcode_parse($BBHandler,$text);

/*
 * Unpaired incorrectly nested BBCode
 */
$text="[i] Parser [b] Auto Correction [/i] at work\n";
echo bbcode_parse($BBHandler,$text);
// Enabling automatic close of pending tags
bbcode_set_flags($BBHandler,
                 BBCODE_CORRECT_REOPEN_TAGS|BBCODE_AUTO_CORRECT,
                 BBCODE_SET_FLAGS_SET);
echo bbcode_parse($BBHandler,$text);
?>

Výše uvedený příklad vypíše:

<i> Parser <b> Auto Correction </b></i> at work
<i> Parser <b> Auto Correction </b></i><b> at work </b>
<i> Parser [b] Auto Correction </i> at work
<i> Parser <b> Auto Correction </b></i><b> at work
</b>

Předcházející | Nahoru | Další
bbcode_set_arg_parser | Domů | VIII. BCMath funkce pro výpočty s libovolnou přesností


bcompiler_load

(PECL bcompiler:0.4-0.8)

bcompiler_load — Reads and creates classes from a bz compressed file

Popis

bool bcompiler_load ( string $filename )

Reads data from a bzcompressed file and creates classes from the bytecodes.

Seznam parametrů

filename

The bzcompressed file path, as a string.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 270. bcompiler_load() example

<?php

bcompiler_load("/tmp/example");

print_r(get_defined_classes());

?>

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Poznámka: Please use include or require statements to parse bytecodes, it's more portable and convenient way than using this function.

Please note that this function won't execute script body code contained in the bytecode file.

Viz také

bcompiler_load_exe()

Předcházející | Nahoru | Další
bcompiler_load_exe | Domů | bcompiler_parse_class


bcompiler_load_exe

(PECL bcompiler:0.4-0.8)

bcompiler_load_exe — Reads and creates classes from a bcompiler exe file

Popis

bool bcompiler_load_exe ( string $filename )

Reads data from a bcompiler exe file and creates classes from the bytecodes.

Seznam parametrů

filename

The exe file path, as a string.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 269. bcompiler_load() example

<?php

bcompiler_load_exe("/tmp/example.exe");
print_r(get_defined_classes());

?>

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Viz také

bcompiler_load()

Předcházející | Nahoru | Další
IX. PHP bytecode Compiler | Domů | bcompiler_load


bcompiler_parse_class

(PECL bcompiler:0.4-0.8)

bcompiler_parse_class — Reads the bytecodes of a class and calls back to a user function

Popis

bool bcompiler_parse_class ( string $class, string $callback )

Reads the bytecodes of a class and calls back to a user function.

Seznam parametrů

class

The class name, as a string.

callback

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 271. bcompiler_parse_class() example

<?php

function readByteCodes($data) {
    print_r($data);
}

bcompiler_parse_class("DB","readByteCodes");

?>

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Poznámka: This function has been removed from bcompiler and is no longer available as of bcompiler 0.5.

Předcházející | Nahoru | Další
bcompiler_load | Domů | bcompiler_read


bcompiler_read

(PECL bcompiler:0.4-0.8)

bcompiler_read — Reads and creates classes from a filehandle

Popis

bool bcompiler_read ( resource $filehandle )

Reads data from a open file handle and creates classes from the bytecodes.

Seznam parametrů

filehandle

A file handle as returned by fopen().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 272. bcompiler_read() example

<?php
$fh = fopen("/tmp/example","r");
bcompiler_read($fh);
fclose($fh);
print_r(get_defined_classes());

?>

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Poznámka: Please use include or require statements to parse bytecodes, it's more portable and convenient way than using this function.

Please note that this function won't execute script body code contained in the bytecode file.

Předcházející | Nahoru | Další
bcompiler_parse_class | Domů | bcompiler_write_class


bcompiler_write_class

(PECL bcompiler:0.4-0.8)

bcompiler_write_class — Writes an defined class as bytecodes

Popis

bool bcompiler_write_class ( resource $filehandle, string $className [, string $extends] )

Reads the bytecodes from PHP for an existing class, and writes them to the open file handle.

Seznam parametrů

filehandle

A file handle as returned by fopen().

className

The class name, as a string.

extends

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 273. bcompiler_write_class() example

<?php
$fh = fopen("/tmp/example","w");
bcompiler_write_header($fh);
bcompiler_write_class($fh,"DB");
// you must write DB_common before DB_mysql, as DB_mysql extends DB_common.
bcompiler_write_class($fh,"DB_common");
bcompiler_write_class($fh,"DB_mysql");
bcompiler_write_footer($fh);
fclose($fh);

?>

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Poznámka: This function does not perform dependency checking, so make sure you write the classes in an order that will not result in an undefined class error occurring when you load it.

Viz také

bcompiler_write_header()
bcompiler_write_footer()

Předcházející | Nahoru | Další
bcompiler_read | Domů | bcompiler_write_constant


bcompiler_write_constant

(PECL bcompiler:0.5-0.8)

bcompiler_write_constant — Writes a defined constant as bytecodes

Popis

bool bcompiler_write_constant ( resource $filehandle, string $constantName )

Reads the bytecodes from PHP for an existing constant, and writes them to the open file handle.

Seznam parametrů

filehandle

A file handle as returned by fopen().

constantName

The name of the defined constant, as a string.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 274. bcompiler_write_constant() example

<?php
define("MODULE_MAX", 30);

$fh = fopen("/tmp/example","w");
bcompiler_write_header($fh);
bcompiler_write_constant($fh,"MODULE_MAX");
bcompiler_write_footer($fh);
fclose($fh);

?>

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Viz také

bcompiler_write_header()
bcompiler_write_footer()

Předcházející | Nahoru | Další
bcompiler_write_class | Domů | bcompiler_write_exe_footer


bcompiler_write_exe_footer

(PECL bcompiler:0.4-0.8)

bcompiler_write_exe_footer — Writes the start pos, and sig to the end of a exe type file

Popis

bool bcompiler_write_exe_footer ( resource $filehandle, int $startpos )

An EXE (or self executable) file consists of 3 parts:
The stub (executable code, e.g. a compiled C program) that loads PHP interpreter, bcompiler extension, stored Bytecodes and initiates a call for the specified function (e.g. main) or class method (e.g. main::main)
The Bytecodes (uncompressed only for the moment)
The bcompiler EXE footer

To obtain a suitable stub you can compile php_embed-based stub phpe.c located in the examples/embed directory on bcompiler's CVS.

Seznam parametrů

filehandle

A file handle as returned by fopen().

startpos

The file position at which the Bytecodes start, and can be obtained using ftell().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 275. bcompiler_write_footer() example

<?php

/* creating the output file (example.exe) */
$fh = fopen("example.exe", "w");

/* 1) writing a stub (phpe.exe) */
$size = filesize("phpe.exe");
$fr = fopen("phpe.exe", "r");
fwrite($fh, fread($fr, $size), $size);
$startpos = ftell($fh);

/* 2) writing bytecodes */
bcompiler_write_header($fh);
bcompiler_write_class($fh, "myclass");
bcompiler_write_function($fh, "main");
bcompiler_write_footer($fh);

/* 3) writing EXE footer */
bcompiler_write_exe_footer($fh, $startpos);

/* closing the output file */
fclose($fh);
?>

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Viz také

bcompiler_write_header()
bcompiler_write_class()
bcompiler_write_footer()

Předcházející | Nahoru | Další
bcompiler_write_constant | Domů | bcompiler_write_file


bcompiler_write_file

(PECL bcompiler:0.6-0.8)

bcompiler_write_file — Writes a php source file as bytecodes

Popis

bool bcompiler_write_file ( resource $filehandle, string $filename )

This function complies specified source file into bytecodes, and writes them to the open file handle.

Seznam parametrů

filehandle

A file handle as returned by fopen().

filename

The source file path, as a string.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 276. bcompiler_write_file() example

<?php
$fh = fopen("example.phb", "w");
bcompiler_write_header($fh);
bcompiler_write_file($fh, "example.php");
bcompiler_write_footer($fh);
fclose($fh);
/* the following should be equivalent:
include "example.php";
   and
include "example.phb";
*/
?>

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Viz také

bcompiler_write_header()
bcompiler_write_footer()

Předcházející | Nahoru | Další
bcompiler_write_exe_footer | Domů | bcompiler_write_footer


bcompiler_write_footer

(PECL bcompiler:0.4-0.8)

bcompiler_write_footer — Writes the single character \x00 to indicate End of compiled data

Popis

bool bcompiler_write_footer ( resource $filehandle )

Writes the single character \x00 to indicate End of compiled data.

Seznam parametrů

filehandle

A file handle as returned by fopen().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 277. bcompiler_write_footer() example

<?php
$fh = fopen("/tmp/example","w");
bcompiler_write_header($fh);
bcompiler_write_class($fh,"DB");
bcompiler_write_class($fh,"DB_common");
bcompiler_write_footer($fh);
fclose($fh);

?>

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Viz také

bcompiler_write_header()

Předcházející | Nahoru | Další
bcompiler_write_file | Domů | bcompiler_write_function


bcompiler_write_function

(PECL bcompiler:0.5-0.8)

bcompiler_write_function — Writes an defined function as bytecodes

Popis

bool bcompiler_write_function ( resource $filehandle, string $functionName )

Reads the bytecodes from PHP for an existing function, and writes them to the open file handle. Order is not important, (eg. if function b uses function a, and you compile it like the example below, it will work perfectly OK).

Seznam parametrů

filehandle

A file handle as returned by fopen().

functionName

The function name, as a string.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 278. bcompiler_write_function() example

<?php
$fh = fopen("/tmp/example","w");
bcompiler_write_header($fh);
bcompiler_write_function($fh,"my_function_a");
bcompiler_write_function($fh,"my_function_b");
bcompiler_write_footer($fh);
fclose($fh);

?>

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Viz také

bcompiler_write_header()
bcompiler_write_footer()

Předcházející | Nahoru | Další
bcompiler_write_footer | Domů | bcompiler_write_functions_from_file


bcompiler_write_functions_from_file

(PECL bcompiler:0.5-0.8)

bcompiler_write_functions_from_file — Writes all functions defined in a file as bytecodes

Popis

bool bcompiler_write_functions_from_file ( resource $filehandle, string $fileName )

Searches for all functions declared in the given file, and writes their correspondent bytecodes to the open file handle.

Seznam parametrů

filehandle

A file handle as returned by fopen().

fileName

The file to be compiled. You must always include or require the file you intend to compile.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 279. bcompiler_write_functions_from_file() example

<?php
require('module.php');

$fh = fopen("/tmp/example","w");
bcompiler_write_header($fh);
bcompiler_write_functions_from_file($fh,'module.php');
bcompiler_write_footer($fh);
fclose($fh);

?>

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Viz také

bcompiler_write_header()
bcompiler_write_footer()

Předcházející | Nahoru | Další
bcompiler_write_function | Domů | bcompiler_write_header


bcompiler_write_header

(PECL bcompiler:0.3-0.8)

bcompiler_write_header — Writes the bcompiler header

Popis

bool bcompiler_write_header ( resource $filehandle [, string $write_ver] )

Writes the header part of a bcompiler file.

Seznam parametrů

filehandle

A file handle as returned by fopen().

write_ver

Can be used to write bytecode in a previously used format, so that you can use it with older versions of bcompiler.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 280. bcompiler_write_header() example

<?php
$fh = fopen("/tmp/example","w");
bcompiler_write_header($fh);
bcompiler_write_class($fh,"DB");
bcompiler_write_footer($fh);
fclose($fh);

?>

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Viz také

bcompiler_write_footer()

Předcházející | Nahoru | Další
bcompiler_write_functions_from_file | Domů | bcompiler_write_included_filename


bcompiler_write_included_filename

(PECL bcompiler:0.5-0.8)

bcompiler_write_included_filename — Writes an included file as bytecodes

Popis

bool bcompiler_write_included_filename ( resource $filehandle, string $filename )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
bcompiler_write_header | Domů | X. Kompresní funkce bzip2


curl_setopt_array

(PHP 5 >= 5.1.3)

curl_setopt_array — Set multiple options for a cURL transfer

Popis

bool curl_setopt_array ( resource $ch, array $options )

Sets multiple options for a cURL session. This function is useful for setting a large amount of cURL options without repetitively calling curl_setopt().

Seznam parametrů

ch

A cURL handle returned by curl_init().

options

An array specifying which options to set and their values. The keys should be valid curl_setopt() constants or their integer equivalents.

Návratové hodnoty

Returns TRUE if all options were successfully set. If an option could not be successfully set, FALSE is immediately returned, ignoring any future options in the options array.

Příklady

Příklad 340. Initializing a new cURL session and fetching a web page

<?php
// create a new cURL resource
$ch = curl_init();

// set URL and other appropriate options
$options = array(CURLOPT_URL => 'http://www.example.com/',
                 CURLOPT_HEADER => false
                );

curl_setopt_array($ch, $options);

// grab URL and pass it to the browser
curl_exec($ch);

// close cURL resource, and free up system resources
curl_close($ch);
?>

Prior to PHP 5.1.4 this function can be simulated with:

Příklad 341. Our own implementation of curl_setopt_array()

<?php
if (!function_exists('curl_setopt_array')) {
   function curl_setopt_array(&$ch, $curl_options)
   {
       foreach ($curl_options as $option => $value) {
           if (!curl_setopt($ch, $option, $value)) {
               return false;
           }
       }
       return true;
   }
}
?>

Viz také

curl_setopt()

Předcházející | Nahoru | Další
curl_multi_select | Domů | curl_setopt


cybermut_creerformulairecm

(PHP 4 >= 4.0.5, PECL cybermut:1.0-1.1)

cybermut_creerformulairecm — Generate HTML form of request for payment

Popis

string cybermut_creerformulairecm ( string $url_cm, string $version, string $tpe, string $price, string $ref_command, string $text_free, string $url_return, string $url_return_ok, string $url_return_err, string $language, string $code_company, string $text_button )

cybermut_creerformulairecm() is used to generate the HTML form of request for payment.

Viz také

cybermut_testmac()
cybermut_creerreponsecm()

Předcházející | Nahoru | Další
XXI. Credit Mutuel CyberMUT functions | Domů | cybermut_creerreponsecm


cybermut_creerreponsecm

(PHP 4 >= 4.0.5, PECL cybermut:1.0-1.1)

cybermut_creerreponsecm — Generate the delivery's acknowledgement of the payment's confirmation

Popis

string cybermut_creerreponsecm ( string $sentence )

The parameter is "OK" if the message of confirmation of the payment were correctly authenticated by cybermut_testmac(). Any other chain is regarded as an error message.

Návratové hodnoty

Returns a string containing the message of acknowledgement of delivery.

Viz také

cybermut_creerformulairecm()
cybermut_testmac()

Předcházející | Nahoru | Další
cybermut_creerformulairecm | Domů | cybermut_testmac


cybermut_testmac

(PHP 4 >= 4.0.5, PECL cybermut:1.0-1.1)

cybermut_testmac — Make sure that there was no data diddling contained in the received message of confirmation

Popis

bool cybermut_testmac ( string $code_mac, string $version, string $tpe, string $cdate, string $price, string $ref_command, string $text_free, string $code_return )

cybermut_testmac() is used to make sure that there was no data diddling contained in the received message of confirmation. Pay attention to parameters code_return and text_free, which cannot be evaluated as is, because of the dash.

Viz také

cybermut_creerformulairecm()
cybermut_creerreponsecm()

Předcházející | Nahoru | Další
cybermut_creerreponsecm | Domů | XXII. Cyrus IMAP administration Functions


date_create

(PHP 5 >= 5.1.0)

date_create — Returns new DateTime object

Popis

DateTime date_create ( [string $time [, DateTimeZone $timezone]] )
DateTime DateTime::__construct ( [string $time [, DateTimeZone $timezone]] )

Seznam parametrů

time

String in a format accepted by strtotime(), defaults to "now".

timezone

Time zone of the time.

Návratové hodnoty

Returns DateTime object on success or FALSE on failure.

Předcházející | Nahoru | Další
checkdate | Domů | date_date_set


date_date_set

(PHP 5 >= 5.1.0)

date_date_set — Sets the date

Popis

void date_date_set ( DateTime $object, int $year, int $month, int $day )
void DateTime::setDate ( int $year, int $month, int $day )

Seznam parametrů

object

DateTime object.

year

Year of the date.

month

Month of the date.

day

Day of the date.

Návratové hodnoty

Returns NULL on success or FALSE on failure.

Viz také

date_isodate_set()
date_time_set()

Předcházející | Nahoru | Další
date_create | Domů | date_default_timezone_get


date_default_timezone_get

(PHP 5 >= 5.1.0)

date_default_timezone_get — Gets the default timezone used by all date/time functions in a script

Popis

string date_default_timezone_get ( void )

This functions returns the default timezone, using the following "guess" order:

  • The timezone set using the date_default_timezone_set() function (if any)

  • The TZ environment variable (if non empty)

  • The date.timezone ini option (if set)

  • "magical" guess (if the operating system supports it)

  • If none of the above options succeeds, return UTC

Návratové hodnoty

Returns a string.

Viz také

date_default_timezone_set()

Předcházející | Nahoru | Další
date_date_set | Domů | date_default_timezone_set


date_default_timezone_set

(PHP 5 >= 5.1.0)

date_default_timezone_set — Sets the default timezone used by all date/time functions in a script

Popis

bool date_default_timezone_set ( string $timezone_identifier )

date_default_timezone_set() sets the default timezone used by all date/time functions.

Poznámka: Since PHP 5.1.0 (when the date/time functions were rewritten), every call to a date/time function will generate a E_NOTICE if the timezone isn't valid, and/or a E_STRICT message if using the system settings or the TZ environment variable.

Instead of using this function to set the default timezone in your script, you can also use the INI setting date.timezone to set the default timezone.

Seznam parametrů

timezone_identifier

The timezone identifier, like UTC or Europe/Lisbon. The list of valid identifiers is available in the J – „List of Supported Timezones“.

Návratové hodnoty

This function returns FALSE if the timezone_identifier isn't valid, or TRUE otherwise.

ChangeLog (záznam změn)

Verze | Popis
5.1.2 | The function started to validate the timezone_identifier parameter.

Viz také

date_default_timezone_get()

Předcházející | Nahoru | Další
date_default_timezone_get | Domů | date_format


date_format

(PHP 5 >= 5.1.0)

date_format — Returns date formatted according to given format

Popis

string date_format ( DateTime $object, string $format )
string DateTime::format ( string $format )

Seznam parametrů

object

DateTime object.

format

Format accepted by date().

Návratové hodnoty

Returns formatted date on success or FALSE on failure.

Viz také

date()

Předcházející | Nahoru | Další
date_default_timezone_set | Domů | date_isodate_set


date_isodate_set

(PHP 5 >= 5.1.0)

date_isodate_set — Sets the ISO date

Popis

void date_isodate_set ( DateTime $object, int $year, int $week [, int $day] )
void DateTime::setISODate ( int $year, int $week [, int $day] )

Seznam parametrů

object

DateTime object.

year

Year of the date.

week

Week of the date.

day

Day of the date.

Návratové hodnoty

Returns NULL on success or FALSE on failure.

Viz také

date_date_set()

Předcházející | Nahoru | Další
date_format | Domů | date_modify


date_modify

(PHP 5 >= 5.1.0)

date_modify — Alters the timestamp

Popis

void date_modify ( DateTime $object, string $modify )
void DateTime::modify ( string $modify )

Seznam parametrů

object

DateTime object.

modify

String in a relative format accepted by strtotime().

Návratové hodnoty

Returns NULL on success or FALSE on failure.

Příklady

Příklad 342. A date_modify() example

<?php
$date = new DateTime("2006-12-12");
$date->modify("+1 day");
echo $date->format("Y-m-d");
?>

Výše uvedený příklad vypíše:

2006-12-13

Viz také

strtotime()

Předcházející | Nahoru | Další
date_isodate_set | Domů | date_offset_get


date_offset_get

(PHP 5 >= 5.1.0)

date_offset_get — Returns the daylight saving time offset

Popis

int date_offset_get ( DateTime $object )
int DateTime::getOffset ( void )

Seznam parametrů

object

DateTime object.

Návratové hodnoty

Returns DST offset in seconds on success or FALSE on failure.

Předcházející | Nahoru | Další
date_modify | Domů | date_parse


date_parse

(PHP 5 >= 5.1.3)

date_parse — Returns associative array with detailed info about given date

Popis

array date_parse ( string $date )

Seznam parametrů

date

Date in format accepted by strtotime().

Návratové hodnoty

Returns array on success or FALSE on failure.

Příklady

Příklad 343. A date_parse() example

<?php
print_r(date_parse("2006-12-12 10:00:00.5"));
?>

Výše uvedený příklad vypíše:

Array
(
    [year] => 2006
    [month] => 12
    [day] => 12
    [hour] => 10
    [minute] => 0
    [second] => 0
    [fraction] => 0.5
    [warning_count] => 0
    [warnings] => Array()
    [error_count] => 0
    [errors] => Array()
    [is_localtime] =>
)

Viz také

getdate()

Předcházející | Nahoru | Další
date_offset_get | Domů | date_sun_info


date_sun_info

(PHP 5 >= 5.1.2)

date_sun_info — Returns an array with information about sunset/sunrise and twilight begin/end

Popis

array date_sun_info ( int $time, float $latitude, float $longitude )

Seznam parametrů

time

Timestamp.

latitude

Latitude in degrees.

longitude

Longitude in degrees.

Návratové hodnoty

Returns array on success or FALSE on failure.

Příklady

Příklad 344. A date_sun_info() example

<?php
$sun_info = date_sun_info(strtotime("2006-12-12"), 31.7667, 35.2333);
foreach ($sun_info as $key => $val) {
    echo "$key: " . date("H:i:s", $val) . "\n";
}
?>

Výše uvedený příklad vypíše:

sunrise: 05:52:11
sunset: 15:41:21
transit: 10:46:46
civil_twilight_begin: 05:24:08
civil_twilight_end: 16:09:24
nautical_twilight_begin: 04:52:25
nautical_twilight_end: 16:41:06
astronomical_twilight_begin: 04:21:32
astronomical_twilight_end: 17:12:00

Viz také

date_sunrise()
date_sunset()

Předcházející | Nahoru | Další
date_parse | Domů | date_sunrise


date_time_set

(PHP 5 >= 5.1.0)

date_time_set — Sets the time

Popis

void date_time_set ( DateTime $object, int $hour, int $minute [, int $second] )
void DateTime::setTime ( int $hour, int $minute [, int $second] )

Seznam parametrů

object

DateTime object.

hour

Hour of the time.

minute

Minute of the time.

second

Second of the time.

Návratové hodnoty

Returns NULL on success or FALSE on failure.

Viz také

date_date_set()

Předcházející | Nahoru | Další
date_sunset | Domů | date_timezone_get


date_timezone_get

(PHP 5 >= 5.1.0)

date_timezone_get — Return time zone relative to given DateTime

Popis

DateTimeZone date_timezone_get ( DateTime $object )
DateTimeZone DateTime::getTimezone ( void )

Seznam parametrů

object

DateTime object.

Návratové hodnoty

Returns DateTimeZone object on success or FALSE on failure.

Viz také

date_timezone_set()

Předcházející | Nahoru | Další
date_time_set | Domů | date_timezone_set


date_timezone_set

(PHP 5 >= 5.1.0)

date_timezone_set — Sets the time zone for the DateTime object

Popis

void date_timezone_set ( DateTime $object, DateTimeZone $timezone )
void DateTime::setTimezone ( DateTimeZone $timezone )

Seznam parametrů

object

DateTime object.

timezone

Desired time zone.

Návratové hodnoty

Returns NULL on success or FALSE on failure.

Viz také

date_timezone_get()

Předcházející | Nahoru | Další
date_timezone_get | Domů | date


db2_autocommit

(PECL ibm_db2:1.0-1.6.2)

db2_autocommit — Returns or sets the AUTOCOMMIT state for a database connection

Popis

mixed db2_autocommit ( resource $connection [, bool $value] )

Sets or gets the AUTOCOMMIT behavior of the specified connection resource.

Seznam parametrů

connection

A valid database connection resource variable as returned from db2_connect() or db2_pconnect().

value

One of the following constants:

DB2_AUTOCOMMIT_OFF

Turns AUTOCOMMIT off.

DB2_AUTOCOMMIT_ON

Turns AUTOCOMMIT on.

Návratové hodnoty

When db2_autocommit() receives only the connection parameter, it returns the current state of AUTOCOMMIT for the requested connection as an integer value. A value of 0 indicates that AUTOCOMMIT is off, while a value of 1 indicates that AUTOCOMMIT is on.

When db2_autocommit() receives both the connection parameter and autocommit parameter, it attempts to set the AUTOCOMMIT state of the requested connection to the corresponding state. Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 762. Retrieving the AUTOCOMMIT value for a connection

In the following example, a connection which has been created with AUTOCOMMIT turned off is tested with the db2_autocommit() function.

<?php
$options = array('autocommit' => DB2_AUTOCOMMIT_OFF);
$conn = db2_connect($database, $user, $password, $options);
$ac = db2_autocommit($conn);
if ($ac == 0) {
    print "$ac -- AUTOCOMMIT is off.";
} else {
    print "$ac -- AUTOCOMMIT is on.";
}
?>

Výše uvedený příklad vypíše:

0 -- AUTOCOMMIT is off.

Příklad 763. Setting the AUTOCOMMIT value for a connection

In the following example, a connection which was initially created with AUTOCOMMIT turned off has its behavior changed to turn AUTOCOMMIT on.

<?php
$options = array('autocommit' => DB2_AUTOCOMMIT_OFF);
$conn = db2_connect($database, $user, $password, $options);

// Turn AUTOCOMMIT on
$rc = db2_autocommit($conn, DB2_AUTOCOMMIT_ON);
if ($rc) {
    print "Turning AUTOCOMMIT on succeeded.\n";
}

// Check AUTOCOMMIT state
$ac = db2_autocommit($conn);
if ($ac == 0) {
    print "$ac -- AUTOCOMMIT is off.";
} else {
    print "$ac -- AUTOCOMMIT is on.";
}
?>

Výše uvedený příklad vypíše:

Turning AUTOCOMMIT on succeeded.
1 -- AUTOCOMMIT is on.

Viz také

db2_connect()
db2_pconnect()

Předcházející | Nahoru | Další
LXI. IBM DB2, Cloudscape and Apache Derby Functions | Domů | db2_bind_param


db2_bind_param

(PECL ibm_db2:1.0-1.6.2)

db2_bind_param — Binds a PHP variable to an SQL statement parameter

Popis

bool db2_bind_param ( resource $stmt, int $parameter-number, string $variable-name [, int $parameter-type [, int $data-type [, int $precision [, int $scale]]]] )

Binds a PHP variable to an SQL statement parameter in a statement resource returned by db2_prepare(). This function gives you more control over the parameter type, data type, precision, and scale for the parameter than simply passing the variable as part of the optional input array to db2_execute().

Seznam parametrů

stmt

A prepared statement returned from db2_prepare().

parameter-number

Specifies the 1-indexed position of the parameter in the prepared statement.

variable-name

A string specifying the name of the PHP variable to bind to the parameter specified by parameter-number.

parameter-type

A constant specifying whether the PHP variable should be bound to the SQL parameter as an input parameter (DB2_PARAM_IN), an output parameter (DB2_PARAM_OUT), or as a parameter that accepts input and returns output (DB2_PARAM_INOUT). To avoid memory overhead, you can also specify DB2_PARAM_FILE to bind the PHP variable to the name of a file that contains large object (BLOB, CLOB, or DBCLOB) data.

data-type

A constant specifying the SQL data type that the PHP variable should be bound as: one of DB2_BINARY, DB2_CHAR, DB2_DOUBLE, or DB2_LONG .

precision

Specifies the precision with which the variable should be bound to the database.

scale

Specifies the scale with which the variable should be bound to the database.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 764. Binding PHP variables to a prepared statement

The SQL statement in the following example uses two input parameters in the WHERE clause. We call db2_bind_param() to bind two PHP variables to the corresponding SQL parameters. Notice that the PHP variables do not have to be declared or assigned before the call to db2_bind_param(); in the example, $lower_limit is assigned a value before the call to db2_bind_param(), but $upper_limit is assigned a value after the call to db2_bind_param(). The variables must be bound and, for parameters that accept input, must have any value assigned, before calling db2_execute().

<?php

$sql = 'SELECT name, breed, weight FROM animals
    WHERE weight > ? AND weight < ?';
$conn = db2_connect($database, $user, $password);
$stmt = db2_prepare($conn, $sql);

// We can declare the variable before calling db2_bind_param()
$lower_limit = 1;

db2_bind_param($stmt, 1, "lower_limit", DB2_PARAM_IN);
db2_bind_param($stmt, 2, "upper_limit", DB2_PARAM_IN);

// We can also declare the variable after calling db2_bind_param()
$upper_limit = 15.0;

if (db2_execute($stmt)) {
    while ($row = db2_fetch_array($stmt)) {
        print "{$row[0]}, {$row[1]}, {$row[2]}\n";
    }
}
?>

Výše uvedený příklad vypíše:

Pook, cat, 3.2
Rickety Ride, goat, 9.7
Peaches, dog, 12.3

Příklad 765. Calling stored procedures with IN and OUT parameters

The stored procedure match_animal in the following example accepts three different parameters:

  1. an input (IN) parameter that accepts the name of the first animal as input

  2. an input-output (INOUT) parameter that accepts the name of the second animal as input and returns the string TRUE if an animal in the database matches that name

  3. an output (OUT) parameter that returns the sum of the weight of the two identified animals

In addition, the stored procedure returns a result set consisting of the animals listed in alphabetic order starting at the animal corresponding to the input value of the first parameter and ending at the animal corresponding to the input value of the second parameter.

<?php

$sql = 'CALL match_animal(?, ?, ?)';
$conn = db2_connect($database, $user, $password);
$stmt = db2_prepare($conn, $sql);

$name = "Peaches";
$second_name = "Rickety Ride";
$weight = 0;

db2_bind_param($stmt, 1, "name", DB2_PARAM_IN);
db2_bind_param($stmt, 2, "second_name", DB2_PARAM_INOUT);
db2_bind_param($stmt, 3, "weight", DB2_PARAM_OUT);

print "Values of bound parameters _before_ CALL:\n";
print "  1: {$name} 2: {$second_name} 3: {$weight}\n\n";

if (db2_execute($stmt)) {
    print "Values of bound parameters _after_ CALL:\n";
    print "  1: {$name} 2: {$second_name} 3: {$weight}\n\n";

    print "Results:\n";
    while ($row = db2_fetch_array($stmt)) {
        print "  {$row[0]}, {$row[1]}, {$row[2]}\n";
    }
}
?>

Výše uvedený příklad vypíše:

Values of bound parameters _before_ CALL:
  1: Peaches 2: Rickety Ride 3: 0

Values of bound parameters _after_ CALL:
  1: Peaches 2: TRUE 3: 22

Results:
  Peaches, dog, 12.3
  Pook, cat, 3.2
  Rickety Ride, goat, 9.7

Příklad 766. Inserting a binary large object (BLOB) directly from a file

The data for large objects are typically stored in files, such as XML documents or audio files. Rather than reading an entire file into a PHP variable, and then binding that PHP variable into an SQL statement, you can avoid some memory overhead by binding the file directly to the input parameter of your SQL statement. The following example demonstrates how to bind a file directly into a BLOB column.

<?php
$stmt = db2_prepare($conn, "INSERT INTO animal_pictures(picture) VALUES (?)");

$picture = "/opt/albums/spook/grooming.jpg";
$rc = db2_bind_param($stmt, 1, "picture", DB2_PARAM_FILE);
$rc = db2_execute($stmt);
?>

Viz také

db2_execute()
db2_prepare()

Předcházející | Nahoru | Další
db2_autocommit | Domů | db2_client_info


db2_client_info

(PECL ibm_db2:1.1.1-1.6.2)

db2_client_info — Returns an object with properties that describe the DB2 database client

Popis

object db2_client_info ( resource $connection )

This function returns an object with read-only properties that return information about the DB2 database client. The following table lists the DB2 client properties:

Tabulka 116. DB2 client properties

Property name | Return type | Description
APPL_CODEPAGE | int | The application code page.
CONN_CODEPAGE | int | The code page for the current connection.
DATA_SOURCE_NAME | string | The data source name (DSN) used to create the current connection to the database.
DRIVER_NAME | string | The name of the library that implements the DB2 Call Level Interface (CLI) specification.
DRIVER_ODBC_VER | string | The version of ODBC that the DB2 client supports. This returns a string "MM.mm" where MM is the major version and mm is the minor version. The DB2 client always returns "03.51".
DRIVER_VER | string | The version of the client, in the form of a string "MM.mm.uuuu" where MM is the major version, mm is the minor version, and uuuu is the update. For example, "08.02.0001" represents major version 8, minor version 2, update 1.
ODBC_SQL_CONFORMANCE string

The level of ODBC SQL grammar supported by the client:

MINIMUM

Supports the minimum ODBC SQL grammar.

CORE

Supports the core ODBC SQL grammar.

EXTENDED

Supports extended ODBC SQL grammar.

ODBC_VER | string | The version of ODBC that the ODBC driver manager supports. This returns a string "MM.mm.rrrr" where MM is the major version, mm is the minor version, and rrrr is the release. The DB2 client always returns "03.01.0000".

Seznam parametrů

connection

Specifies an active DB2 client connection.

Návratové hodnoty

Returns an object on a successful call. Returns FALSE on failure.

Příklady

Příklad 767. A db2_client_info() example

To retrieve information about the client, you must pass a valid database connection resource to db2_client_info().

<?php
$conn = db2_connect( 'SAMPLE', 'db2inst1', 'ibmdb2' );
$client = db2_client_info( $conn );

if ($client) {
    echo "DRIVER_NAME: ";           var_dump( $client->DRIVER_NAME );
    echo "DRIVER_VER: ";            var_dump( $client->DRIVER_VER );
    echo "DATA_SOURCE_NAME: ";      var_dump( $client->DATA_SOURCE_NAME );
    echo "DRIVER_ODBC_VER: ";       var_dump( $client->DRIVER_ODBC_VER );
    echo "ODBC_VER: ";              var_dump( $client->ODBC_VER );
    echo "ODBC_SQL_CONFORMANCE: ";  var_dump( $client->ODBC_SQL_CONFORMANCE );
    echo "APPL_CODEPAGE: ";         var_dump( $client->APPL_CODEPAGE );
    echo "CONN_CODEPAGE: ";         var_dump( $client->CONN_CODEPAGE );
}
else {
    echo "Error retrieving client information.
     Perhaps your database connection was invalid.";
}
db2_close($conn);

?>

Výše uvedený příklad vypíše:

DRIVER_NAME: string(8) "libdb2.a"
DRIVER_VER: string(10) "08.02.0001"
DATA_SOURCE_NAME: string(6) "SAMPLE"
DRIVER_ODBC_VER: string(5) "03.51"
ODBC_VER: string(10) "03.01.0000"
ODBC_SQL_CONFORMANCE: string(8) "EXTENDED"
APPL_CODEPAGE: int(819)
CONN_CODEPAGE: int(819)

Viz také

db2_server_info()

Předcházející | Nahoru | Další
db2_bind_param | Domů | db2_close


db2_close

(PECL ibm_db2:1.0-1.6.2)

db2_close — Closes a database connection

Popis

bool db2_close ( resource $connection )

This function closes a DB2 client connection created with db2_connect() and returns the corresponding resources to the database server.

If you attempt to close a persistent DB2 client connection created with db2_pconnect(), the close request is ignored and the persistent DB2 client connection remains available for the next caller.

Seznam parametrů

connection

Specifies an active DB2 client connection.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 768. Closing a connection

The following example demonstrates a successful attempt to close a connection to an IBM DB2, Cloudscape, or Apache Derby database.

<?php
$conn = db2_connect('SAMPLE', 'db2inst1', 'ibmdb2');
$rc = db2_close($conn);
if ($rc) {
    echo "Connection was successfully closed.";
}
?>

Výše uvedený příklad vypíše:

Connection was successfully closed.

Viz také

db2_connect()
db2_pconnect()

Předcházející | Nahoru | Další
db2_client_info | Domů | db2_column_privileges


db2_column_privileges

(PECL ibm_db2:1.0-1.6.2)

db2_column_privileges — Returns a result set listing the columns and associated privileges for a table

Popis

resource db2_column_privileges ( resource $connection [, string $qualifier [, string $schema [, string $table-name [, string $column-name]]]] )

Returns a result set listing the columns and associated privileges for a table.

Seznam parametrů

connection

A valid connection to an IBM DB2, Cloudscape, or Apache Derby database.

qualifier

A qualifier for DB2 databases running on OS/390 or z/OS servers. For other databases, pass NULL or an empty string.

schema

The schema which contains the tables. To match all schemas, pass NULL or an empty string.

table-name

The name of the table or view. To match all tables in the database, pass NULL or an empty string.

column-name

The name of the column. To match all columns in the table, pass NULL or an empty string.

Návratové hodnoty

Returns a statement resource with a result set containing rows describing the column privileges for columns matching the specified parameters. The rows are composed of the following columns:

Column name | Description
TABLE_CAT | Name of the catalog. The value is NULL if this table does not have catalogs.
TABLE_SCHEM | Name of the schema.
TABLE_NAME | Name of the table or view.
COLUMN_NAME | Name of the column.
GRANTOR | Authorization ID of the user who granted the privilege.
GRANTEE | Authorization ID of the user to whom the privilege was granted.
PRIVILEGE | The privilege for the column.
IS_GRANTABLE | Whether the GRANTEE is permitted to grant this privilege to other users.

Viz také

db2_columns()
db2_foreign_keys()
db2_primary_keys()
db2_procedure_columns()
db2_procedures()
db2_special_columns()
db2_statistics()
db2_table_privileges()
db2_tables()

Předcházející | Nahoru | Další
db2_close | Domů | db2_columns


db2_columns

(PECL ibm_db2:1.0-1.6.2)

db2_columns — Returns a result set listing the columns and associated metadata for a table

Popis

resource db2_columns ( resource $connection [, string $qualifier [, string $schema [, string $table-name [, string $column-name]]]] )

Returns a result set listing the columns and associated metadata for a table.

Seznam parametrů

connection

A valid connection to an IBM DB2, Cloudscape, or Apache Derby database.

qualifier

A qualifier for DB2 databases running on OS/390 or z/OS servers. For other databases, pass NULL or an empty string.

schema

The schema which contains the tables. To match all schemas, pass '%'.

table-name

The name of the table or view. To match all tables in the database, pass NULL or an empty string.

column-name

The name of the column. To match all columns in the table, pass NULL or an empty string.

Návratové hodnoty

Returns a statement resource with a result set containing rows describing the columns matching the specified parameters. The rows are composed of the following columns:

Column name | Description
TABLE_CAT | Name of the catalog. The value is NULL if this table does not have catalogs.
TABLE_SCHEM | Name of the schema.
TABLE_NAME | Name of the table or view.
COLUMN_NAME | Name of the column.
DATA_TYPE | The SQL data type for the column represented as an integer value.
TYPE_NAME | A string representing the data type for the column.
COLUMN_SIZE | An integer value representing the size of the column.
BUFFER_LENGTH | Maximum number of bytes necessary to store data from this column.
DECIMAL_DIGITS | The scale of the column, or NULL where scale is not applicable.
NUM_PREC_RADIX | An integer value of either 10 (representing an exact numeric data type), 2 (representing an approximate numeric data type), or NULL (representing a data type for which radix is not applicable).
NULLABLE | An integer value representing whether the column is nullable or not.
REMARKS | Description of the column.
COLUMN_DEF | Default value for the column.
SQL_DATA_TYPE | An integer value representing the size of the column.
SQL_DATETIME_SUB | Returns an integer value representing a datetime subtype code, or NULL for SQL data types to which this does not apply.
CHAR_OCTET_LENGTH | Maximum length in octets for a character data type column, which matches COLUMN_SIZE for single-byte character set data, or NULL for non-character data types.
ORDINAL_POSITION | The 1-indexed position of the column in the table.
IS_NULLABLE | A string value where 'YES' means that the column is nullable and 'NO' means that the column is not nullable.

Viz také

db2_column_privileges()
db2_foreign_keys()
db2_primary_keys()
db2_procedure_columns()
db2_procedures()
db2_special_columns()
db2_statistics()
db2_table_privileges()
db2_tables()

Předcházející | Nahoru | Další
db2_column_privileges | Domů | db2_commit


db2_commit

(PECL ibm_db2:1.0-1.6.2)

db2_commit — Commits a transaction

Popis

bool db2_commit ( resource $connection )

Commits an in-progress transaction on the specified connection resource and begins a new transaction. PHP applications normally default to AUTOCOMMIT mode, so db2_commit() is not necessary unless AUTOCOMMIT has been turned off for the connection resource.

Poznámka: If the specified connection resource is a persistent connection, all transactions in progress for all applications using that persistent connection will be committed. For this reason, persistent connections are not recommended for use in applications that require transactions.

Seznam parametrů

connection

A valid database connection resource variable as returned from db2_connect() or db2_pconnect().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

db2_autocommit()
db2_rollback()

Předcházející | Nahoru | Další
db2_columns | Domů | db2_conn_error


db2_conn_error

(PECL ibm_db2:1.0-1.6.2)

db2_conn_error — Returns a string containing the SQLSTATE returned by the last connection attempt

Popis

string db2_conn_error ( [resource $connection] )

db2_conn_error() returns an SQLSTATE value representing the reason the last attempt to connect to a database failed. As db2_connect() returns FALSE in the event of a failed connection attempt, you do not pass any parameters to db2_conn_error() to retrieve the SQLSTATE value.

If, however, the connection was successful but becomes invalid over time, you can pass the connection parameter to retrieve the SQLSTATE value for a specific connection.

To learn what the SQLSTATE value means, you can issue the following command at a DB2 Command Line Processor prompt: db2 '? sqlstate-value'. You can also call db2_conn_errormsg() to retrieve an explicit error message and the associated SQLCODE value.

Seznam parametrů

connection

A connection resource associated with a connection that initially succeeded, but which over time became invalid.

Návratové hodnoty

Returns the SQLSTATE value resulting from a failed connection attempt. Returns an empty string if there is no error associated with the last connection attempt.

Příklady

Příklad 769. Retrieving an SQLSTATE value for a failed connection attempt

The following example demonstrates how to return an SQLSTATE value after deliberately passing invalid parameters to db2_connect().

<?php
$conn = db2_connect('badname', 'baduser', 'badpassword');
if (!$conn) {
    print "SQLSTATE value: " . db2_conn_error();
}
?>

Výše uvedený příklad vypíše:

SQLSTATE value: 08001

Viz také

db2_conn_errormsg()
db2_connect()
db2_stmt_error()
db2_stmt_errormsg()

Předcházející | Nahoru | Další
db2_commit | Domů | db2_conn_errormsg


db2_conn_errormsg

(PECL ibm_db2:1.0-1.6.2)

db2_conn_errormsg — Returns the last connection error message and SQLCODE value

Popis

string db2_conn_errormsg ( [resource $connection] )

db2_conn_errormsg() returns an error message and SQLCODE value representing the reason the last database connection attempt failed. As db2_connect() returns FALSE in the event of a failed connection attempt, do not pass any parameters to db2_conn_errormsg() to retrieve the associated error message and SQLCODE value.

If, however, the connection was successful but becomes invalid over time, you can pass the connection parameter to retrieve the associated error message and SQLCODE value for a specific connection.

Seznam parametrů

connection

A connection resource associated with a connection that initially succeeded, but which over time became invalid.

Návratové hodnoty

Returns a string containing the error message and SQLCODE value resulting from a failed connection attempt. If there is no error associated with the last connection attempt, db2_conn_errormsg() returns an empty string.

Příklady

Příklad 770. Retrieving the error message returned by a failed connection attempt

The following example demonstrates how to return an error message and SQLCODE value after deliberately passing invalid parameters to db2_connect().

<?php
$conn = db2_connect('badname', 'baduser', 'badpassword');
if (!$conn) {
    print db2_conn_errormsg();
}
?>

Výše uvedený příklad vypíše:

[IBM][CLI Driver] SQL1013N  The database alias name
or database name "BADNAME" could not be found.  SQLSTATE=42705
 SQLCODE=-1013

Viz také

db2_conn_error()
db2_connect()
db2_stmt_error()
db2_stmt_errormsg()

Předcházející | Nahoru | Další
db2_conn_error | Domů | db2_connect


db2_connect

(PECL ibm_db2:1.0-1.6.2)

db2_connect — Returns a connection to a database

Popis

resource db2_connect ( string $database, string $username, string $password [, array $options] )

Creates a new connection to an IBM DB2 Universal Database, IBM Cloudscape, or Apache Derby database.

Seznam parametrů

database

For a cataloged connection to a database, database represents the database alias in the DB2 client catalog.

For an uncataloged connection to a database, database represents a complete connection string in the following format:

DATABASE=database;HOSTNAME=hostname;PORT=port;PROTOCOL=TCPIP;UID=username;PWD=password;

where the parameters represent the following values:

database

The name of the database.

hostname

The hostname or IP address of the database server.

port

The TCP/IP port on which the database is listening for requests.

username

The username with which you are connecting to the database.

password

The password with which you are connecting to the database.

username

The username with which you are connecting to the database.

For uncataloged connections, you must pass a NULL value or empty string.

password

The password with which you are connecting to the database.

For uncataloged connections, you must pass a NULL value or empty string.

options

An associative array of connection options that affect the behavior of the connection, where valid array keys include:

autocommit

Passing the DB2_AUTOCOMMIT_ON value turns autocommit on for this connection handle.

Passing the DB2_AUTOCOMMIT_OFF value turns autocommit off for this connection handle.

DB2_ATTR_CASE

Passing the DB2_CASE_NATURAL value specifies that column names are returned in natural case.

Passing the DB2_CASE_LOWER value specifies that column names are returned in lower case.

Passing the DB2_CASE_UPPER value specifies that column names are returned in upper case.

CURSOR

Passing the DB2_FORWARD_ONLY value specifies a forward-only cursor for a statement resource. This is the default cursor type and is supported on all database servers.

Passing the DB2_SCROLLABLE value specifies a scrollable cursor for a statement resource. This mode enables random access to rows in a result set, but currently is supported only by IBM DB2 Universal Database.

The following new i5/OS options are available as of ibm_db2 version 1.5.1. Note: prior versions of ibm_db2 do not support these new i5 options.

i5_lib

A character value that indicates the default library that will be used for resolving unqualified file references. This is not valid if the connection is using system naming mode.

i5_naming

DB2_I5_NAMING_ON value turns on DB2 UDB CLI iSeries system naming mode. Files are qualified using the slash (/) delimiter. Unqualified files are resolved using the library list for the job.

DB2_I5_NAMING_OFF value turns off DB2 UDB CLI default naming mode, which is SQL naming. Files are qualified using the period (.) delimiter. Unqualified files are resolved using either the default library or the current user ID.

i5_commit

The i5_commit attribute should be set before the db2_connect(). If the value is changed after the connection has been established, and the connection is to a remote data source, the change does not take effect until the next successful db2_connect() for the connection handle.

Note: php.ini setting ibm_db2.i5_allow_commit==0 or DB2_I5_TXN_NO_COMMIT is the default, but may be overridden with the i5_commit option.

DB2_I5_TXN_NO_COMMIT - Commitment control is not used.

DB2_I5_TXN_READ_UNCOMMITTED - Dirty reads, nonrepeatable reads, and phantoms are possible.

DB2_I5_TXN_READ_COMMITTED - Dirty reads are not possible. Nonrepeatable reads, and phantoms are possible.

DB2_I5_TXN_REPEATABLE_READ - Dirty reads and nonrepeatable reads are not possible. Phantoms are possible.

DB2_I5_TXN_SERIALIZABLE - Transactions are serializable. Dirty reads, non-repeatable reads, and phantoms are not possible

i5_query_optimize

DB2_FIRST_IO All queries are optimized with the goal of returning the first page of output as fast as possible. This goal works well when the output is controlled by a user who is most likely to cancel the query after viewing the first page of output data. Queries coded with an OPTIMIZE FOR nnn ROWS clause honor the goal specified by the clause.

DB2_ALL_IO All queries are optimized with the goal of running the entire query to completion in the shortest amount of elapsed time. This is a good option when the output of a query is being written to a file or report, or the interface is queuing the output data. Queries coded with an OPTIMIZE FOR nnn ROWS clause honor the goal specified by the clause. This is the default.

i5_dbcs_alloc

DB2_I5_DBCS_ALLOC_ON value turns on DB2 6X allocation scheme for DBCS translation column size growth.

DB2_I5_DBCS_ALLOC_OFF value turns off DB2 6X allocation scheme for DBCS translation column size growth.

Note: php.ini setting ibm_db2.i5_dbcs_alloc==0 or DB2_I5_DBCS_ALLOC_OFF is the default, but may be overridden with the i5_dbcs_alloc option.

i5_date_fmt

SQL_FMT_ISO - The International Organization for Standardization (ISO) date format yyyy-mm-dd is used. This is the default.

DB2_I5_FMT_USA - The United States date format mm/dd/yyyy is used.

DB2_I5_FMT_EUR - The European date format dd.mm.yyyy is used.

DB2_I5_FMT_JIS - The Japanese Industrial Standard date format yyyy-mm-dd is used.

DB2_I5_FMT_MDY - The date format mm/dd/yyyy is used.

DB2_I5_FMT_DMY - The date format dd/mm/yyyy is used.

DB2_I5_FMT_YMD - The date format yy/mm/dd is used.

DB2_I5_FMT_JUL - The Julian date format yy/ddd is used.

DB2_I5_FMT_JOB - The job default is used.

i5_date_sep

DB2_I5_SEP_SLASH - A slash ( / ) is used as the date separator. This is the default.

DB2_I5_SEP_DASH - A dash ( - ) is used as the date separator.

DB2_I5_SEP_PERIOD - A period ( . ) is used as the date separator.

DB2_I5_SEP_COMMA - A comma ( , ) is used as the date separator.

DB2_I5_SEP_BLANK - A blank is used as the date separator.

DB2_I5_SEP_JOB - The job default is used

i5_time_fmt

DB2_I5_FMT_ISO - The International Organization for Standardization (ISO) time format hh.mm.ss is used. This is the default.

DB2_I5_FMT_USA - The United States time format hh:mmxx is used, where xx is AM or PM.

DB2_I5_FMT_EUR - The European time format hh.mm.ss is used.

DB2_I5_FMT_JIS - The Japanese Industrial Standard time format hh:mm:ss is used.

DB2_I5_FMT_HMS - The hh:mm:ss format is used.

i5_time_sep

DB2_I5_SEP_COLON - A colon ( : ) is used as the time separator. This is the default.

DB2_I5_SEP_PERIOD - A period ( . ) is used as the time separator.

DB2_I5_SEP_COMMA - A comma ( , ) is used as the time separator.

DB2_I5_SEP_BLANK - A blank is used as the time separator.

DB2_I5_SEP_JOB - The job default is used.

i5_decimal_sep

DB2_I5_SEP_PERIOD - A period ( . ) is used as the decimal separator. This is the default.

DB2_I5_SEP_COMMA - A comma ( , ) is used as the decimal separator.

DB2_I5_SEP_JOB - The job default is used.

Návratové hodnoty

Returns a connection handle resource if the connection attempt is successful. If the connection attempt fails, db2_connect() returns FALSE.

Příklady

Příklad 771. Creating a cataloged connection

Cataloged connections require you to have previously cataloged the target database through the DB2 Command Line Processor (CLP) or DB2 Configuration Assistant.

<?php
$database = 'SAMPLE';
$user = 'db2inst1';
$password = 'ibmdb2';

$conn = db2_connect($database, $user, $password);

if ($conn) {
    echo "Connection succeeded.";
    db2_close($conn);
}
else {
    echo "Connection failed.";
}
?>

Výše uvedený příklad vypíše:

Connection succeeded.

Příklad 772. Creating an uncataloged connection

An uncataloged connection enables you to dynamically connect to a database.

<?php
$database = 'SAMPLE';
$user = 'db2inst1';
$password = 'ibmdb2';
$hostname = 'localhost';
$port = 50000;

$conn_string = "DRIVER={IBM DB2 ODBC DRIVER};DATABASE=$database;" .
  "HOSTNAME=$hostname;PORT=$port;PROTOCOL=TCPIP;UID=$user;PWD=$password;";
$conn = db2_connect($conn_string, '', '');

if ($conn) {
    echo "Connection succeeded.";
    db2_close($conn);
}
else {
    echo "Connection failed.";
}
?>

Výše uvedený příklad vypíše:

Connection succeeded.

Příklad 773. Creating a connection with autocommit off by default

Passing an array of options to db2_connect() enables you to modify the default behavior of the connection handle.

<?php
$database = 'SAMPLE';
$user = 'db2inst1';
$password = 'ibmdb2';
$options = array('autocommit' => DB2_AUTOCOMMIT_OFF);

$conn = db2_connect($database, $user, $password, $options);

if ($conn) {
    echo "Connection succeeded.\n";
    if (db2_autocommit($conn)) {
         echo "Autocommit is on.\n";
    }
    else {
         echo "Autocommit is off.\n";
    }
    db2_close($conn);
}
else {
    echo "Connection failed.";
}
?>

Výše uvedený příklad vypíše:

Connection succeeded.
Autocommit is off.

Příklad 774. i5/OS best performance

To achieve best performance for your i5/OS ibm_db2 1.5.1 PHP application use the default host, userid, and password for your db2_connect().

<?php
  $library = "ADC";
  $i5 = db2_connect("", "", "", array("i5_lib"=>"qsys2"));
  $result = db2_exec($i5,
       "select * from systables where table_schema = '$library'");
  while ($row = db2_fetch_both($result)) {
     echo $row['TABLE_NAME']."</br>";
  }
  db2_close($i5);
?>

Výše uvedený příklad vypíše:

ANIMALS
NAMES
PICTURES

Viz také

db2_close()
db2_pconnect()

Předcházející | Nahoru | Další
db2_conn_errormsg | Domů | db2_cursor_type


db2_cursor_type

(PECL ibm_db2:1.0-1.6.2)

db2_cursor_type — Returns the cursor type used by a statement resource

Popis

int db2_cursor_type ( resource $stmt )

Returns the cursor type used by a statement resource. Use this to determine if you are working with a forward-only cursor or scrollable cursor.

Seznam parametrů

stmt

A valid statement resource.

Návratové hodnoty

Returns either DB2_FORWARD_ONLY if the statement resource uses a forward-only cursor or DB2_SCROLLABLE if the statement resource uses a scrollable cursor.

Viz také

db2_prepare()

Předcházející | Nahoru | Další
db2_connect | Domů | db2_escape_string


db2_escape_string

(PECL ibm_db2:1.6.0-1.6.2)

db2_escape_string — Used to escape certain characters.

Popis

string db2_escape_string ( string $string_literal )

Prepends backslashes to special characters in the string argument.

Seznam parametrů

string_literal

The string that contains special characters that need to be modified. Characters that are prepended with a backslash are \x00, \n, \r, \, ', " and \x1a.

Návratové hodnoty

Returns string_literal with the special characters noted above prepended with backslashes.

Příklady

Příklad 775. A db2_escape_string() example

Result of using the db2_escape_string() function

<?php

$conn = db2_connect($database, $user, $password);

if ($conn) {
    $str[0] = "All characters: \x00 , \n , \r , \ , ' , \" , \x1a .";
    $str[1] = "Backslash (\). Single quote ('). Double quote (\")";
    $str[2] = "The NULL character \0 must be quoted as well";
    $str[3] = "Intersting characters: \x1a , \x00 .";
    $str[4] = "Nothing to quote";
    $str[5] = 200676;
    $str[6] = "";

    foreach( $str as $string ) {
        echo "db2_escape_string: " . db2_escape_string($string). "\n";
    }
}
?>

Výše uvedený příklad vypíše:

db2_escape_string: All characters: \0 , \n , \r , \\ , \' , \" , \Z .
db2_escape_string: Backslash (\\). Single quote (\'). Double quote (\")
db2_escape_string: The NULL character \0 must be quoted as well
db2_escape_string: Intersting characters: \Z , \0 .
db2_escape_string: Nothing to quote
db2_escape_string: 200676
db2_escape_string:

Viz také

db2_prepare()

Předcházející | Nahoru | Další
db2_cursor_type | Domů | db2_exec


db2_exec

(PECL ibm_db2:1.0-1.6.2)

db2_exec — Executes an SQL statement directly

Popis

resource db2_exec ( resource $connection, string $statement [, array $options] )

Executes an SQL statement directly.

If you plan to interpolate PHP variables into the SQL statement, understand that this is one of the more common security exposures. Consider calling db2_prepare() to prepare an SQL statement with parameter markers for input values. Then you can call db2_execute() to pass in the input values and avoid SQL injection attacks.

If you plan to repeatedly issue the same SQL statement with different parameters, consider calling db2_prepare() and db2_execute() to enable the database server to reuse its access plan and increase the efficiency of your database access.

Seznam parametrů

connection

A valid database connection resource variable as returned from db2_connect() or db2_pconnect().

statement

An SQL statement. The statement cannot contain any parameter markers.

options

An associative array containing statement options. You can use this parameter to request a scrollable cursor on database servers that support this functionality.

cursor

Passing the DB2_FORWARD_ONLY value requests a forward-only cursor for this SQL statement. This is the default type of cursor, and it is supported by all database servers. It is also much faster than a scrollable cursor.

Passing the DB2_SCROLLABLE value requests a scrollable cursor for this SQL statement. This type of cursor enables you to fetch rows non-sequentially from the database server. However, it is only supported by DB2 servers, and is much slower than forward-only cursors.

Návratové hodnoty

Returns a statement resource if the SQL statement was issued successfully, or FALSE if the database failed to execute the SQL statement.

Příklady

Příklad 776. Creating a table with db2_exec()

The following example uses db2_exec() to issue a set of DDL statements in the process of creating a table.

<?php
$conn = db2_connect($database, $user, $password);

// Create the test table
$create = 'CREATE TABLE animals (id INTEGER, breed VARCHAR(32),
    name CHAR(16), weight DECIMAL(7,2))';
$result = db2_exec($conn, $create);
if ($result) {
    print "Successfully created the table.\n";
}

// Populate the test table
$animals = array(
    array(0, 'cat', 'Pook', 3.2),
    array(1, 'dog', 'Peaches', 12.3),
    array(2, 'horse', 'Smarty', 350.0),
    array(3, 'gold fish', 'Bubbles', 0.1),
    array(4, 'budgerigar', 'Gizmo', 0.2),
    array(5, 'goat', 'Rickety Ride', 9.7),
    array(6, 'llama', 'Sweater', 150)
);

foreach ($animals as $animal) {
    $rc = db2_exec($conn, "INSERT INTO animals (id, breed, name, weight)
      VALUES ({$animal[0]}, '{$animal[1]}', '{$animal[2]}', {$animal[3]})");
    if ($rc) {
        print "Insert... ";
    }
}
?>

Výše uvedený příklad vypíše:

Successfully created the table.
Insert... Insert... Insert... Insert... Insert... Insert... Insert...

Příklad 777. Executing a SELECT statement with a scrollable cursor

The following example demonstrates how to request a scrollable cursor for an SQL statement issued by db2_exec().

<?php
$conn = db2_connect($database, $user, $password);
$sql = "SELECT name FROM animals
    WHERE weight < 10.0
    ORDER BY name";
if ($conn) {
    require_once('prepare.inc');
    $stmt = db2_exec($conn, $sql, array('cursor' => DB2_SCROLLABLE));
    while ($row = db2_fetch_array($stmt)) {
        print "$row[0]\n";
    }
}
?>

Výše uvedený příklad vypíše:

Bubbles
Gizmo
Pook
Rickety Ride

Příklad 778. Returning XML data as a SQL ResultSet

The following example demonstrates how to work with documents stored in a XML column using the SAMPLE database. Using some pretty simple SQL/XML, this example returns some of the nodes in a XML document in a SQL ResultSet format that most users are familiar with.

<?php

$conn = db2_connect("SAMPLE", "db2inst1", "ibmdb2");

$query = 'SELECT * FROM XMLTABLE(
    XMLNAMESPACES (DEFAULT \'http://posample.org\'),
    \'db2-fn:xmlcolumn("CUSTOMER.INFO")/customerinfo\'
    COLUMNS
    "CID" VARCHAR (50) PATH \'@Cid\',
    "NAME" VARCHAR (50) PATH \'name\',
    "PHONE" VARCHAR (50) PATH \'phone [ @type = "work"]\'
    ) AS T
    WHERE NAME = \'Kathy Smith\'
    ';
$stmt = db2_exec($conn, $query);

while($row = db2_fetch_object($stmt)){
    printf("$row->CID     $row->NAME     $row->PHONE\n");
}
db2_close($conn);

?>

Výše uvedený příklad vypíše:

1000     Kathy Smith     416-555-1358
1001     Kathy Smith     905-555-7258

Příklad 779. Performing a "JOIN" with XML data

The following example works with documents stored in 2 different XML columns in the SAMPLE database. It creates 2 temporary tables from the XML documents from 2 different columns and returns a SQL ResultSet with information regarding shipping status for the customer.

<?php

$conn = db2_connect("SAMPLE", "db2inst1", "ibmdb2");

$query = '
    SELECT A.CID, A.NAME, A.PHONE, C.PONUM, C.STATUS
    FROM
    XMLTABLE(
    XMLNAMESPACES (DEFAULT \'http://posample.org\'),
    \'db2-fn:xmlcolumn("CUSTOMER.INFO")/customerinfo\'
    COLUMNS
    "CID" BIGINT PATH \'@Cid\',
    "NAME" VARCHAR (50) PATH \'name\',
    "PHONE" VARCHAR (50) PATH \'phone [ @type = "work"]\'
    ) as A,
    PURCHASEORDER AS B,
    XMLTABLE (
    XMLNAMESPACES (DEFAULT \'http://posample.org\'),
    \'db2-fn:xmlcolumn("PURCHASEORDER.PORDER")/PurchaseOrder\'
    COLUMNS
    "PONUM"  BIGINT PATH \'@PoNum\',
    "STATUS" VARCHAR (50) PATH \'@Status\'
    ) as C
    WHERE A.CID = B.CUSTID AND
    B.POID = C.PONUM AND
    A.NAME = \'Kathy Smith\'
';

$stmt = db2_exec($conn, $query);

while($row = db2_fetch_object($stmt)){
    printf("$row->CID     $row->NAME     $row->PHONE     $row->PONUM     $row->STATUS\n");
}

db2_close($conn);

?>

Výše uvedený příklad vypíše:

1001     Kathy Smith     905-555-7258     5002     Shipped

Příklad 780. Returning SQL data as part of a larger XML document

The following example works with a portion of the PRODUCT.DESCRIPTION documents in the SAMPLE database. It creates a XML document containing product description (XML data) and pricing info (SQL data).

<?php

$conn = db2_connect("SAMPLE", "db2inst1", "ibmdb2");

$query = '
SELECT
XMLSERIALIZE(
XMLQUERY(\'
    declare boundary-space strip;
    declare default element namespace "http://posample.org";
    <promoList> {
    for $prod in $doc/product
    where $prod/description/price < 10.00
    order by $prod/description/price ascending
    return(
        <promoitem> {
        $prod,
        <startdate> {$start} </startdate>,
        <enddate> {$end} </enddate>,
        <promoprice> {$promo} </promoprice>
        } </promoitem>
    )
    } </promoList>
\' passing by ref DESCRIPTION AS "doc",
PROMOSTART as "start",
PROMOEND as "end",
PROMOPRICE as "promo"
RETURNING SEQUENCE)
AS CLOB (32000))
AS NEW_PRODUCT_INFO
FROM PRODUCT
WHERE PID = \'100-100-01\'
';

$stmt = db2_exec($conn, $query);

while($row = db2_fetch_array($stmt)){
    printf("$row[0]\n");
}
db2_close($conn);

?>

Výše uvedený příklad vypíše:

<promoList xmlns="http://posample.org">
    <promoitem>
    <product pid="100-100-01">
        <description>
            <name>Snow Shovel, Basic 22 inch</name>
            <details>Basic Snow Shovel, 22 inches wide, straight handle with D-Grip</details>
            <price>9.99</price>
            <weight>1 kg</weight>
        </description>
    </product>
    <startdate>2004-11-19</startdate>
    <enddate>2004-12-19</enddate>
    <promoprice>7.25</promoprice>
    </promoitem>
</promoList>

Viz také

db2_execute()
db2_prepare()

Předcházející | Nahoru | Další
db2_escape_string | Domů | db2_execute


db2_execute

(PECL ibm_db2:1.0-1.6.2)

db2_execute — Executes a prepared SQL statement

Popis

bool db2_execute ( resource $stmt [, array $parameters] )

db2_execute() executes an SQL statement that was prepared by db2_prepare().

If the SQL statement returns a result set, for example, a SELECT statement or a CALL to a stored procedure that returns one or more result sets, you can retrieve a row as an array from the stmt resource using db2_fetch_assoc(), db2_fetch_both(), or db2_fetch_array(). Alternatively, you can use db2_fetch_row() to move the result set pointer to the next row and fetch a column at a time from that row with db2_result().

Refer to db2_prepare() for a brief discussion of the advantages of using db2_prepare() and db2_execute() rather than db2_exec().

Seznam parametrů

stmt

A prepared statement returned from db2_prepare().

parameters

An array of input parameters matching any parameter markers contained in the prepared statement.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 781. Preparing and executing an SQL statement with parameter markers

The following example prepares an INSERT statement that accepts four parameter markers, then iterates over an array of arrays containing the input values to be passed to db2_execute().

<?php
$pet = array(0, 'cat', 'Pook', 3.2);

$insert = 'INSERT INTO animals (id, breed, name, weight)
    VALUES (?, ?, ?, ?)';

$stmt = db2_prepare($conn, $insert);
if ($stmt) {
    $result = db2_execute($stmt, $pet);
    if ($result) {
        print "Successfully added new pet.";
    }
}
?>

Výše uvedený příklad vypíše:

Successfully added new pet.

Příklad 782. Calling a stored procedure with an OUT parameter

The following example prepares a CALL statement that accepts one parameter marker representing an OUT parameter, binds the PHP variable $my_pets to the parameter using db2_bind_param(), then issues db2_execute() to execute the CALL statement. After the CALL to the stored procedure has been made, the value of $num_pets changes to reflect the value returned by the stored procedure for that OUT parameter.

<?php
$num_pets = 0;
$res = db2_prepare($conn, "CALL count_my_pets(?)");
$rc = db2_bind_param($res, 1, "num_pets", DB2_PARAM_OUT);
$rc = db2_execute($res);
print "I have $num_pets pets!";
?>

Výše uvedený příklad vypíše:

I have 7 pets!

Příklad 783. Returning XML data as a SQL ResultSet

The following example demonstrates how to work with documents stored in a XML column using the SAMPLE database. Using some pretty simple SQL/XML, this example returns some of the nodes in a XML document in a SQL ResultSet format that most users are familiar with.

<?php

$conn = db2_connect("SAMPLE", "db2inst1", "ibmdb2");

$query = 'SELECT * FROM XMLTABLE(
    XMLNAMESPACES (DEFAULT \'http://posample.org\'),
    \'db2-fn:xmlcolumn("CUSTOMER.INFO")/customerinfo\'
    COLUMNS
    "CID" VARCHAR (50) PATH \'@Cid\',
    "NAME" VARCHAR (50) PATH \'name\',
    "PHONE" VARCHAR (50) PATH \'phone [ @type = "work"]\'
    ) AS T
    WHERE NAME = ?
    ';

$stmt = db2_prepare($conn, $query);

$name = 'Kathy Smith';

if ($stmt) {
    db2_bind_param($stmt, 1, "name", DB2_PARAM_IN);
    db2_execute($stmt);

    while($row = db2_fetch_object($stmt)){
    printf("$row->CID     $row->NAME     $row->PHONE\n");
    }
}
db2_close($conn);

?>

Výše uvedený příklad vypíše:

1000     Kathy Smith     416-555-1358
1001     Kathy Smith     905-555-7258

Příklad 784. Performing a "JOIN" with XML data

The following example works with documents stored in 2 different XML columns in the SAMPLE database. It creates 2 temporary tables from the XML documents from 2 different columns and returns a SQL ResultSet with information regarding shipping status for the customer.

<?php

$conn = db2_connect("SAMPLE", "db2inst1", "ibmdb2");

$query = '
SELECT A.CID, A.NAME, A.PHONE, C.PONUM, C.STATUS
FROM
XMLTABLE(
XMLNAMESPACES (DEFAULT \'http://posample.org\'),
\'db2-fn:xmlcolumn("CUSTOMER.INFO")/customerinfo\'
COLUMNS
"CID" BIGINT PATH \'@Cid\',
"NAME" VARCHAR (50) PATH \'name\',
"PHONE" VARCHAR (50) PATH \'phone [ @type = "work"]\'
) as A,
PURCHASEORDER AS B,
XMLTABLE (
XMLNAMESPACES (DEFAULT \'http://posample.org\'),
\'db2-fn:xmlcolumn("PURCHASEORDER.PORDER")/PurchaseOrder\'
COLUMNS
"PONUM"  BIGINT PATH \'@PoNum\',
"STATUS" VARCHAR (50) PATH \'@Status\'
) as C
WHERE A.CID = B.CUSTID AND
    B.POID = C.PONUM AND
    A.NAME = ?
';

$stmt = db2_prepare($conn, $query);

$name = 'Kathy Smith';

if ($stmt) {
    db2_bind_param($stmt, 1, "name", DB2_PARAM_IN);
    db2_execute($stmt);

    while($row = db2_fetch_object($stmt)){
    printf("$row->CID     $row->NAME     $row->PHONE     $row->PONUM     $row->STATUS\n");
    }
}

db2_close($conn);

?>

Výše uvedený příklad vypíše:

1001     Kathy Smith     905-555-7258     5002     Shipped

Příklad 785. Returning SQL data as part of a larger XML document

The following example works with a portion of the PRODUCT.DESCRIPTION documents in the SAMPLE database. It creates a XML document containing product description (XML data) and pricing info (SQL data).

<?php

$conn = db2_connect("SAMPLE", "db2inst1", "ibmdb2");

$query = '
SELECT
XMLSERIALIZE(
XMLQUERY(\'
    declare boundary-space strip;
    declare default element namespace "http://posample.org";
    <promoList> {
    for $prod in $doc/product
    where $prod/description/price < 10.00
    order by $prod/description/price ascending
    return(
        <promoitem> {
        $prod,
        <startdate> {$start} </startdate>,
        <enddate> {$end} </enddate>,
        <promoprice> {$promo} </promoprice>
            } </promoitem>
    )
    } </promoList>
\' passing by ref DESCRIPTION AS "doc",
PROMOSTART as "start",
PROMOEND as "end",
PROMOPRICE as "promo"
RETURNING SEQUENCE)
AS CLOB (32000))
AS NEW_PRODUCT_INFO
FROM PRODUCT
WHERE PID = ?
';

$stmt = db2_prepare($conn, $query);

$pid = "100-100-01";

if ($stmt) {
    db2_bind_param($stmt, 1, "pid", DB2_PARAM_IN);
    db2_execute($stmt);

    while($row = db2_fetch_array($stmt)){
    printf("$row[0]\n");
    }
}

db2_close($conn);

?>

Výše uvedený příklad vypíše:

<promoList xmlns="http://posample.org">
    <promoitem>
    <product pid="100-100-01">
        <description>
            <name>Snow Shovel, Basic 22 inch</name>
            <details>Basic Snow Shovel, 22 inches wide, straight handle with D-Grip</details>
            <price>9.99</price>
            <weight>1 kg</weight>
        </description>
    </product>
    <startdate>2004-11-19</startdate>
    <enddate>2004-12-19</enddate>
    <promoprice>7.25</promoprice>
    </promoitem>
</promoList>

Viz také

db2_exec()
db2_fetch_array()
db2_fetch_assoc()
db2_fetch_both()
db2_fetch_row()
db2_prepare()
db2_result()

Předcházející | Nahoru | Další
db2_exec | Domů | db2_fetch_array


db2_fetch_array

(PECL ibm_db2:1.0.1-1.6.2)

db2_fetch_array — Returns an array, indexed by column position, representing a row in a result set

Popis

array db2_fetch_array ( resource $stmt [, int $row_number] )

Returns an array, indexed by column position, representing a row in a result set. The columns are 0-indexed.

Seznam parametrů

stmt

A valid stmt resource containing a result set.

row_number

Requests a specific 1-indexed row from the result set. Passing this parameter results in a PHP warning if the result set uses a forward-only cursor.

Návratové hodnoty

Returns a 0-indexed array with column values indexed by the column position representing the next or requested row in the result set. Returns FALSE if there are no rows left in the result set, or if the row requested by row_number does not exist in the result set.

Příklady

Příklad 786. Iterating through a forward-only cursor

If you call db2_fetch_array() without a specific row number, it automatically retrieves the next row in the result set.

<?php

$sql = "SELECT id, name, breed, weight FROM animals ORDER BY breed";
$stmt = db2_prepare($conn, $sql);
$result = db2_execute($stmt);

while ($row = db2_fetch_array($stmt)) {
    printf ("%-5d %-16s %-32s %10s\n",
        $row[0], $row[1], $row[2], $row[3]);
}
?>

Výše uvedený příklad vypíše:

0     Pook             cat                                    3.20
5     Rickety Ride     goat                                   9.70
2     Smarty           horse                                350.00

Příklad 787. Retrieving specific rows with db2_fetch_array() from a scrollable cursor

If your result set uses a scrollable cursor, you can call db2_fetch_array() with a specific row number. The following example retrieves every other row in the result set, starting with the second row.

<?php

$sql = "SELECT id, name, breed, weight FROM animals ORDER BY breed";
$result = db2_exec($stmt, $sql, array('cursor' => DB2_SCROLLABLE));

$i=2;
while ($row = db2_fetch_array($result, $i)) {
    printf ("%-5d %-16s %-32s %10s\n",
        $row[0], $row[1], $row[2], $row[3]);
    $i = $i + 2;
}
?>

Výše uvedený příklad vypíše:

0     Pook             cat                                    3.20
5     Rickety Ride     goat                                   9.70
2     Smarty           horse                                350.00

Viz také

db2_fetch_assoc()
db2_fetch_both()
db2_fetch_object()
db2_fetch_row()
db2_result()

Předcházející | Nahoru | Další
db2_execute | Domů | db2_fetch_assoc


db2_fetch_assoc

(PECL ibm_db2:1.0-1.6.2)

db2_fetch_assoc — Returns an array, indexed by column name, representing a row in a result set

Popis

array db2_fetch_assoc ( resource $stmt [, int $row_number] )

Returns an array, indexed by column name, representing a row in a result set.

Seznam parametrů

stmt

A valid stmt resource containing a result set.

row_number

Requests a specific 1-indexed row from the result set. Passing this parameter results in a PHP warning if the result set uses a forward-only cursor.

Návratové hodnoty

Returns an associative array with column values indexed by the column name representing the next or requested row in the result set. Returns FALSE if there are no rows left in the result set, or if the row requested by row_number does not exist in the result set.

Příklady

Příklad 788. Iterating through a forward-only cursor

If you call db2_fetch_assoc() without a specific row number, it automatically retrieves the next row in the result set.

<?php

$sql = "SELECT id, name, breed, weight FROM animals ORDER BY breed";
$stmt = db2_prepare($conn, $sql);
$result = db2_execute($stmt);

while ($row = db2_fetch_assoc($stmt)) {
    printf ("%-5d %-16s %-32s %10s\n",
        $row['ID'], $row['NAME'], $row['BREED'], $row['WEIGHT']);
}
?>

Výše uvedený příklad vypíše:

0     Pook             cat                                    3.20
5     Rickety Ride     goat                                   9.70
2     Smarty           horse                                350.00

Příklad 789. Retrieving specific rows with db2_fetch_assoc() from a scrollable cursor

If your result set uses a scrollable cursor, you can call db2_fetch_assoc() with a specific row number. The following example retrieves every other row in the result set, starting with the second row.

<?php

$sql = "SELECT id, name, breed, weight FROM animals ORDER BY breed";
$result = db2_exec($stmt, $sql, array('cursor' => DB2_SCROLLABLE));

$i=2;
while ($row = db2_fetch_assoc($result, $i)) {
    printf ("%-5d %-16s %-32s %10s\n",
        $row['ID'], $row['NAME'], $row['BREED'], $row['WEIGHT']);
    $i = $i + 2;
}
?>

Výše uvedený příklad vypíše:

0     Pook             cat                                    3.20
5     Rickety Ride     goat                                   9.70
2     Smarty           horse                                350.00

Viz také

db2_fetch_array()
db2_fetch_both()
db2_fetch_object()
db2_fetch_row()
db2_result()

Předcházející | Nahoru | Další
db2_fetch_array | Domů | db2_fetch_both


db2_fetch_both

(PECL ibm_db2:1.0-1.6.2)

db2_fetch_both — Returns an array, indexed by both column name and position, representing a row in a result set

Popis

array db2_fetch_both ( resource $stmt [, int $row_number] )

Returns an array, indexed by both column name and position, representing a
row in a result set. Note that the row returned by
db2_fetch_both() requires more memory than the
single-indexed arrays returned by db2_fetch_assoc() or
db2_fetch_array().

Seznam parametrů

stmt

A valid stmt resource containing a result set.

row_number

Requests a specific 1-indexed row from the result set. Passing this parameter results in a PHP warning if the result set uses a forward-only cursor.

Návratové hodnoty

Returns an associative array with column values indexed by both the column name and 0-indexed column number. The array represents the next or requested row in the result set. Returns FALSE if there are no rows left in the result set, or if the row requested by row_number does not exist in the result set.

Příklady

Příklad 790. Iterating through a forward-only cursor

If you call db2_fetch_both() without a specific row number, it automatically retrieves the next row in the result set. The following example accesses columns in the returned array by both column name and by numeric index.

<?php

$sql = "SELECT id, name, breed, weight FROM animals ORDER BY breed";
$stmt = db2_prepare($conn, $sql);
$result = db2_execute($stmt);

while ($row = db2_fetch_both($stmt)) {
    printf ("%-5d %-16s %-32s %10s\n",
        $row['ID'], $row[0], $row['BREED'], $row[3]);
}
?>

Výše uvedený příklad vypíše:

0     Pook             cat                                    3.20
5     Rickety Ride     goat                                   9.70
2     Smarty           horse                                350.00

Příklad 791. Retrieving specific rows with db2_fetch_both() from a scrollable cursor

If your result set uses a scrollable cursor, you can call db2_fetch_both() with a specific row number. The following example retrieves every other row in the result set, starting with the second row.

<?php

$sql = "SELECT id, name, breed, weight FROM animals ORDER BY breed";
$result = db2_exec($stmt, $sql, array('cursor' => DB2_SCROLLABLE));

$i=2;
while ($row = db2_fetch_both($result, $i)) {
    printf ("%-5d %-16s %-32s %10s\n",
        $row[0], $row['NAME'], $row[2], $row['WEIGHT']);
    $i = $i + 2;
}
?>

Výše uvedený příklad vypíše:

0     Pook             cat                                    3.20
5     Rickety Ride     goat                                   9.70
2     Smarty           horse                                350.00

Viz také

db2_fetch_array()
db2_fetch_assoc()
db2_fetch_object()
db2_fetch_row()
db2_result()

Předcházející | Nahoru | Další
db2_fetch_assoc | Domů | db2_fetch_object


db2_fetch_object

(PECL ibm_db2:1.0-1.6.2)

db2_fetch_object — Returns an object with properties representing columns in the fetched row

Popis

object db2_fetch_object ( resource $stmt [, int $row_number] )

Returns an object in which each property represents a column returned in the row fetched from a result set.

Seznam parametrů

stmt

A valid stmt resource containing a result set.

row_number

Requests a specific 1-indexed row from the result set. Passing this parameter results in a PHP warning if the result set uses a forward-only cursor.

Návratové hodnoty

Returns an object representing a single row in the result set. The properties of the object map to the names of the columns in the result set.

The IBM DB2, Cloudscape, and Apache Derby database servers typically fold column names to upper-case, so the object properties will reflect that case.

If your SELECT statement calls a scalar function to modify the value of a column, the database servers return the column number as the name of the column in the result set. If you prefer a more descriptive column name and object property, you can use the AS clause to assign a name to the column in the result set.

Returns FALSE if no row was retrieved.

Příklady

Příklad 792. A db2_fetch_object() example

The following example issues a SELECT statement with a scalar function, RTRIM, that removes whitespace from the end of the column. Rather than creating an object with the properties "BREED" and "2", we use the AS clause in the SELECT statement to assign the name "name" to the modified column. The database server folds the column names to upper-case, resulting in an object with the properties "BREED" and "NAME".

<?php
$conn = db2_connect($database, $user, $password);

$sql = "SELECT breed, RTRIM(name) AS name
    FROM animals
    WHERE id = ?";

if ($conn) {
    $stmt = db2_prepare($conn, $sql);
    db2_execute($stmt, array(0));

    while ($pet = db2_fetch_object($stmt)) {
        echo "Come here, {$pet->NAME}, my little {$pet->BREED}!";
    }
    db2_close($conn);
}
?>

Výše uvedený příklad vypíše:

Come here, Pook, my little cat!

Viz také

db2_fetch_array()
db2_fetch_assoc()
db2_fetch_both()
db2_fetch_row()
db2_result()

Předcházející | Nahoru | Další
db2_fetch_both | Domů | db2_fetch_row


db2_fetch_row

(PECL ibm_db2:1.0-1.6.2)

db2_fetch_row — Sets the result set pointer to the next row or requested row

Popis

bool db2_fetch_row ( resource $stmt [, int $row_number] )

Use db2_fetch_row() to iterate through a result set, or to point to a specific row in a result set if you requested a scrollable cursor.

To retrieve individual fields from the result set, call the db2_result() function.

Rather than calling db2_fetch_row() and db2_result(), most applications will call one of db2_fetch_assoc(), db2_fetch_both(), or db2_fetch_array() to advance the result set pointer and return a complete row as an array.

Seznam parametrů

stmt

A valid stmt resource.

row_number

With scrollable cursors, you can request a specific row number in the result set. Row numbering is 1-indexed.

Návratové hodnoty

Returns TRUE if the requested row exists in the result set. Returns FALSE if the requested row does not exist in the result set.

Příklady

Příklad 793. Iterating through a result set

The following example demonstrates how to iterate through a result set with db2_fetch_row() and retrieve columns from the result set with db2_result().

<?php
$sql = 'SELECT name, breed FROM animals WHERE weight < ?';
$stmt = db2_prepare($conn, $sql);
db2_execute($stmt, array(10));
while (db2_fetch_row($stmt)) {
    $name = db2_result($stmt, 0);
    $breed = db2_result($stmt, 1);
    print "$name $breed";
}
?>

Výše uvedený příklad vypíše:

cat Pook
gold fish Bubbles
budgerigar Gizmo
goat Rickety Ride

Příklad 794. i5/OS recommended alternatives to db2_fetch_row/db2_result

On i5/OS it is recommended that you use db2_fetch_both(), db2_fetch_array(), or db2_fetch_object() over db2_fetch_row()/db2_result(). In general db2_fetch_row()/db2_result() have more issues with various column types in EBCIDIC to ASCII translation, including possible truncation in DBCS applications. You may also find the performance of db2_fetch_both(), db2_fetch_array(), and db2_fetch_object() to be superior to db2_fetch_row()/db2_result().

<?php
  $conn = db2_connect("","","");
  $sql = 'SELECT SPECIFIC_SCHEMA, SPECIFIC_NAME, ROUTINE_SCHEMA, ROUTINE_NAME, ROUTINE_TYPE, ROUTINE_CREATED, ROUTINE_BODY, IN_PARMS, OUT_PARMS, INOUT_PARMS, PARAMETER_STYLE, EXTERNAL_NAME, EXTERNAL_LANGUAGE FROM QSYS2.SYSROUTINES FETCH FIRST 2 ROWS ONLY';
  $stmt = db2_exec($conn, $sql, array('cursor' => DB2_SCROLLABLE));
  while ($row = db2_fetch_both($stmt)){
    echo "<br>db2_fetch_both {$row['SPECIFIC_NAME']} {$row['ROUTINE_CREATED']} {$row[5]}";
  }
  $stmt = db2_exec($conn, $sql, array('cursor' => DB2_SCROLLABLE));
  while ($row = db2_fetch_array($stmt)){
    echo "<br>db2_fetch_array {$row[1]}  {$row[5]}";
  }
  $stmt = db2_exec($conn, $sql, array('cursor' => DB2_SCROLLABLE));
  while ($row = db2_fetch_object($stmt)){
    echo "<br>db2_fetch_object {$row->SPECIFIC_NAME} {$row->ROUTINE_CREATED}";
  }
  db2_close($conn);
?>

Výše uvedený příklad vypíše:

db2_fetch_both MATCH_ANIMAL 2006-08-25-17.10.23.775000 2006-08-25-17.10.23.775000
db2_fetch_both MULTIRESULTS 2006-10-17-10.11.05.308000 2006-10-17-10.11.05.308000
db2_fetch_array MATCH_ANIMAL 2006-08-25-17.10.23.775000
db2_fetch_array MULTIRESULTS 2006-10-17-10.11.05.308000
db2_fetch_object MATCH_ANIMAL 2006-08-25-17.10.23.775000
db2_fetch_object MULTIRESULTS 2006-10-17-10.11.05.308000

Viz také

db2_fetch_array()
db2_fetch_assoc()
db2_fetch_both()
db2_fetch_object()
db2_result()

Předcházející | Nahoru | Další
db2_fetch_object | Domů | db2_field_display_size


db2_field_display_size

(PECL ibm_db2:1.0-1.6.2)

db2_field_display_size — Returns the maximum number of bytes required to display a column

Popis

int db2_field_display_size ( resource $stmt, mixed $column )

Returns the maximum number of bytes required to display a column in a result set.

Seznam parametrů

stmt

Specifies a statement resource containing a result set.

column

Specifies the column in the result set. This can either be an integer representing the 0-indexed position of the column, or a string containing the name of the column.

Návratové hodnoty

Returns an integer value with the maximum number of bytes required to display the specified column. If the column does not exist in the result set, db2_field_display_size() returns FALSE.

Viz také

db2_field_name()
db2_field_num()
db2_field_precision()
db2_field_scale()
db2_field_type()
db2_field_width()

Předcházející | Nahoru | Další
db2_fetch_row | Domů | db2_field_name


db2_field_name

(PECL ibm_db2:1.0-1.6.2)

db2_field_name — Returns the name of the column in the result set

Popis

string db2_field_name ( resource $stmt, mixed $column )

Returns the name of the specified column in the result set.

Seznam parametrů

stmt

Specifies a statement resource containing a result set.

column

Specifies the column in the result set. This can either be an integer representing the 0-indexed position of the column, or a string containing the name of the column.

Návratové hodnoty

Returns a string containing the name of the specified column. If the specified column does not exist in the result set, db2_field_name() returns FALSE.

Viz také

db2_field_display_size()
db2_field_num()
db2_field_precision()
db2_field_scale()
db2_field_type()
db2_field_width()

Předcházející | Nahoru | Další
db2_field_display_size | Domů | db2_field_num


db2_field_num

(PECL ibm_db2:1.0-1.6.2)

db2_field_num — Returns the position of the named column in a result set

Popis

int db2_field_num ( resource $stmt, mixed $column )

Returns the position of the named column in a result set.

Seznam parametrů

stmt

Specifies a statement resource containing a result set.

column

Specifies the column in the result set. This can either be an integer representing the 0-indexed position of the column, or a string containing the name of the column.

Návratové hodnoty

Returns an integer containing the 0-indexed position of the named column in the result set. If the specified column does not exist in the result set, db2_field_num() returns FALSE.

Viz také

db2_field_display_size()
db2_field_name()
db2_field_precision()
db2_field_scale()
db2_field_type()
db2_field_width()

Předcházející | Nahoru | Další
db2_field_name | Domů | db2_field_precision


db2_field_precision

(PECL ibm_db2:1.0-1.6.2)

db2_field_precision — Returns the precision of the indicated column in a result set

Popis

int db2_field_precision ( resource $stmt, mixed $column )

Returns the precision of the indicated column in a result set.

Seznam parametrů

stmt

Specifies a statement resource containing a result set.

column

Specifies the column in the result set. This can either be an integer representing the 0-indexed position of the column, or a string containing the name of the column.

Návratové hodnoty

Returns an integer containing the precision of the specified column. If the specified column does not exist in the result set, db2_field_precision() returns FALSE.

Viz také

db2_field_display_size()
db2_field_name()
db2_field_num()
db2_field_scale()
db2_field_type()
db2_field_width()

Předcházející | Nahoru | Další
db2_field_num | Domů | db2_field_scale


db2_field_scale

(PECL ibm_db2:1.0-1.6.2)

db2_field_scale — Returns the scale of the indicated column in a result set

Popis

int db2_field_scale ( resource $stmt, mixed $column )

Returns the scale of the indicated column in a result set.

Seznam parametrů

stmt

Specifies a statement resource containing a result set.

column

Specifies the column in the result set. This can either be an integer representing the 0-indexed position of the column, or a string containing the name of the column.

Návratové hodnoty

Returns an integer containing the scale of the specified column. If the specified column does not exist in the result set, db2_field_scale() returns FALSE.

Viz také

db2_field_display_size()
db2_field_name()
db2_field_num()
db2_field_precision()
db2_field_type()
db2_field_width()

Předcházející | Nahoru | Další
db2_field_precision | Domů | db2_field_type


db2_field_type

(PECL ibm_db2:1.0-1.6.2)

db2_field_type — Returns the data type of the indicated column in a result set

Popis

string db2_field_type ( resource $stmt, mixed $column )

Returns the data type of the indicated column in a result set.

Seznam parametrů

stmt

Specifies a statement resource containing a result set.

column

Specifies the column in the result set. This can either be an integer representing the 0-indexed position of the column, or a string containing the name of the column.

Návratové hodnoty

Returns a string containing the defined data type of the specified column. If the specified column does not exist in the result set, db2_field_type() returns FALSE.

Viz také

db2_field_display_size()
db2_field_name()
db2_field_num()
db2_field_precision()
db2_field_scale()
db2_field_width()

Předcházející | Nahoru | Další
db2_field_scale | Domů | db2_field_width


db2_field_width

(PECL ibm_db2:1.0-1.6.2)

db2_field_width — Returns the width of the current value of the indicated column in a result set

Popis

int db2_field_width ( resource $stmt, mixed $column )

Returns the width of the current value of the indicated column in a result set. This is the maximum width of the column for a fixed-length data type, or the actual width of the column for a variable-length data type.

Seznam parametrů

stmt

Specifies a statement resource containing a result set.

column

Specifies the column in the result set. This can either be an integer representing the 0-indexed position of the column, or a string containing the name of the column.

Návratové hodnoty

Returns an integer containing the width of the specified character or binary data type column in a result set. If the specified column does not exist in the result set, db2_field_width() returns FALSE.

Viz také

db2_field_display_size()
db2_field_name()
db2_field_num()
db2_field_precision()
db2_field_scale()
db2_field_type()

Předcházející | Nahoru | Další
db2_field_type | Domů | db2_foreign_keys


db2_foreign_keys

(PECL ibm_db2:1.0-1.6.2)

db2_foreign_keys — Returns a result set listing the foreign keys for a table

Popis

resource db2_foreign_keys ( resource $connection, string $qualifier, string $schema, string $table-name )

Returns a result set listing the foreign keys for a table.

Seznam parametrů

connection

A valid connection to an IBM DB2, Cloudscape, or Apache Derby database.

qualifier

A qualifier for DB2 databases running on OS/390 or z/OS servers. For other databases, pass NULL or an empty string.

schema

The schema which contains the tables. If schema is NULL, db2_foreign_keys() matches the schema for the current connection.

table-name

The name of the table.

Návratové hodnoty

Returns a statement resource with a result set containing rows describing the foreign keys for the specified table. The result set is composed of the following columns:

Column name | Description
PKTABLE_CAT | Name of the catalog for the table containing the primary key. The value is NULL if this table does not have catalogs.
PKTABLE_SCHEM | Name of the schema for the table containing the primary key.
PKTABLE_NAME | Name of the table containing the primary key.
PKCOLUMN_NAME | Name of the column containing the primary key.
FKTABLE_CAT | Name of the catalog for the table containing the foreign key. The value is NULL if this table does not have catalogs.
FKTABLE_SCHEM | Name of the schema for the table containing the foreign key.
FKTABLE_NAME | Name of the table containing the foreign key.
FKCOLUMN_NAME | Name of the column containing the foreign key.
KEY_SEQ | 1-indexed position of the column in the key.
UPDATE_RULE | Integer value representing the action applied to the foreign key when the SQL operation is UPDATE.
DELETE_RULE | Integer value representing the action applied to the foreign key when the SQL operation is DELETE.
FK_NAME | The name of the foreign key.
PK_NAME | The name of the primary key.
DEFERRABILITY | An integer value representing whether the foreign key deferrability is SQL_INITIALLY_DEFERRED, SQL_INITIALLY_IMMEDIATE, or SQL_NOT_DEFERRABLE.

Viz také

db2_column_privileges()
db2_columns()
db2_primary_keys()
db2_procedure_columns()
db2_procedures()
db2_special_columns()
db2_statistics()
db2_table_privileges()
db2_tables()

Předcházející | Nahoru | Další
db2_field_width | Domů | db2_free_result


db2_free_result

(PECL ibm_db2:1.0-1.6.2)

db2_free_result — Frees resources associated with a result set

Popis

bool db2_free_result ( resource $stmt )

Frees the system and database resources that are associated with a result set. These resources are freed implicitly when a script finishes, but you can call db2_free_result() to explicitly free the result set resources before the end of the script.

Seznam parametrů

stmt

A valid statement resource.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

db2_free_stmt()

Předcházející | Nahoru | Další
db2_foreign_keys | Domů | db2_free_stmt


db2_free_stmt

(PECL ibm_db2:1.0-1.6.2)

db2_free_stmt — Frees resources associated with the indicated statement resource

Popis

bool db2_free_stmt ( resource $stmt )

Frees the system and database resources that are associated with a statement resource. These resources are freed implicitly when a script finishes, but you can call db2_free_stmt() to explicitly free the statement resources before the end of the script.

Seznam parametrů

stmt

A valid statement resource.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

db2_free_result()

Předcházející | Nahoru | Další
db2_free_result | Domů | db2_get_option


db2_get_option

(PECL ibm_db2:1.6.0-1.6.2)

db2_get_option — Retrieves an option value for a statement resource or a connection resource

Popis

string db2_get_option ( resource $resource, string $option )

Retrieves the value of a specified option value for a statement resource or a connection resource.

Seznam parametrů

resource

A valid statement resource as returned from db2_prepare() or a valid connection resource as returned from db2_connect() or db2_pconnect().

option

A valid statement or connection options. The following new options are available as of ibm_db2 version 1.6.0. They provide useful tracking information that can be set during execution with db2_get_option().

Note: Prior versions of ibm_db2 do not support these new options.

When the value in each option is being set, some servers might not handle the entire length provided and might truncate the value.

To ensure that the data specified in each option is converted correctly when transmitted to a host system, use only the characters A through Z, 0 through 9, and the underscore (_) or period (.).

userid

SQL_ATTR_INFO_USERID - A pointer to a null-terminated character string used to identify the client user ID sent to the host database server when using DB2 Connect.

Note: DB2 for z/OS and OS/390 servers support up to a length of 16 characters. This user-id is not to be confused with the authentication user-id, it is for identification purposes only and is not used for any authorization.

acctstr

SQL_ATTR_INFO_ACCTSTR - A pointer to a null-terminated character string used to identify the client accounting string sent to the host database server when using DB2 Connect.

Note: DB2 for z/OS and OS/390 servers support up to a length of 200 characters.

applname

SQL_ATTR_INFO_APPLNAME - A pointer to a null-terminated character string used to identify the client application name sent to the host database server when using DB2 Connect.

Note: DB2 for z/OS and OS/390 servers support up to a length of 32 characters.

wrkstnname

SQL_ATTR_INFO_WRKSTNNAME - A pointer to a null-terminated character string used to identify the client workstation name sent to the host database server when using DB2 Connect.

Note: DB2 for z/OS and OS/390 servers support up to a length of 18 characters.

The following table specifies which options are compatible with the available resource types:

Tabulka 117. Resource-Parameter Matrix

Key | Value | Resource Type
 |  | Connection | Statement | Result Set
userid | SQL_ATTR_INFO_USERID | X | X | -
acctstr | SQL_ATTR_INFO_ACCTSTR | X | X | -
applname | SQL_ATTR_INFO_APPLNAME | X | X | -
wrkstnname | SQL_ATTR_INFO_WRKSTNNAME | X | X | -

Návratové hodnoty

Returns the current setting of the connection attribute provided on success or FALSE on failure.

Příklady

Příklad 795. Setting and retrieving parameters through a connection resource

<?php
/* Database Connection Parameters */
$database = 'SAMPLE';
$user     = 'db2inst1';
$password = 'ibmdb2';

/* Obtain Connection Resource */
$conn = db2_connect($database, $user, $password);

echo "Client attributes passed through conection string:\n";

/* Create the associative options array with valid key-value pairs */
/* Assign the attributes through connection string */
/* Access the options specified */
$options1 = array('userid' => 'db2inst1');
$conn1 = db2_connect($database, $user, $password, $options1);
$val = db2_get_option($conn1, 'userid');
echo $val . "\n";

$options2 = array('acctstr' => 'account');
$conn2 = db2_connect($database, $user, $password, $options2);
$val = db2_get_option($conn2, 'acctstr');
echo $val . "\n";

$options3 = array('applname' => 'myapp');
$conn3 = db2_connect($database, $user, $password, $options3);
$val = db2_get_option($conn3, 'applname');
echo $val . "\n";

$options4 = array('wrkstnname' => 'workstation');
$conn4 = db2_connect($database, $user, $password, $options4);
$val = db2_get_option($conn4, 'wrkstnname');
echo $val . "\n";

echo "Client attributes passed post-conection:\n";

/* Create the associative options array with valid key-value pairs */
/* Assign the attributes after a connection is made */
/* Access the options specified */
$options5 = array('userid' => 'db2inst1');
$conn5 = db2_connect($database, $user, $password);
$rc = db2_set_option($conn5, $options5, 1);
$val = db2_get_option($conn5, 'userid');
echo $val . "\n";

$options6 = array('acctstr' => 'account');
$conn6 = db2_connect($database, $user, $password);
$rc = db2_set_option($conn6, $options6, 1);
$val = db2_get_option($conn6, 'acctstr');
echo $val . "\n";

$options7 = array('applname' => 'myapp');
$conn7 = db2_connect($database, $user, $password);
$rc = db2_set_option($conn7, $options7, 1);
$val = db2_get_option($conn7, 'applname');
echo $val . "\n";

$options8 = array('wrkstnname' => 'workstation');
$conn8 = db2_connect($database, $user, $password);
$rc = db2_set_option($conn8, $options8, 1);
$val = db2_get_option($conn8, 'wrkstnname');
echo $val . "\n";
?>

Výše uvedený příklad vypíše:

Client attributes passed through conection string:
db2inst1
account
myapp
workstation
Client attributes passed post-connection:
db2inst1
account
myapp
workstation

Viz také

db2_connect()
db2_cursor_type()
db2_exec()
db2_set_option()
db2_pconnect()
db2_prepare()

Předcházející | Nahoru | Další
db2_free_stmt | Domů | db2_lob_read


db2_lob_read

(PECL ibm_db2:1.6.0-1.6.2)

db2_lob_read — Gets a user defined size of LOB files with each invocation

Popis

string db2_lob_read ( resource $stmt, int $colnum, int $length )

Use db2_lob_read() to iterate through a specified column of a result set and retrieve a user defined size of LOB data.

Seznam parametrů

stmt

A valid stmt resource containing LOB data.

colnum

A valid column number in the result set of the stmt resource.

length

The size of the LOB data to be retrieved from the stmt resource.

Návratové hodnoty

Returns the amount of data the user specifies. Returns FALSE if the data cannot be retrieved.

Příklady

Příklad 796. Iterating through different types of data

<?php

/* Database Connection Parameters */
$db = 'SAMPLE';
$username = 'db2inst1';
$password = 'ibmdb2';

/* Obtain Connection Resource */
$conn = db2_connect($db,$username,$password);

if ($conn) {
    $drop = 'DROP TABLE clob_stream';
    $result = @db2_exec( $conn, $drop );

    $create = 'CREATE TABLE clob_stream (id INTEGER, my_clob CLOB)';
    $result = db2_exec( $conn, $create );

    $variable = "";
    $stmt = db2_prepare($conn, "INSERT INTO clob_stream (id,my_clob) VALUES (1, ?)");
    $variable = "THIS IS A CLOB TEST. THIS IS A CLOB TEST.";
    db2_bind_param($stmt, 1, "variable", DB2_PARAM_IN);
    db2_execute($stmt);

    $sql = "SELECT id,my_clob FROM clob_stream";
    $result = db2_prepare($conn, $sql);
    db2_execute($result);
    db2_fetch_row($result);
    $i = 0;
    /* Read LOB data */
    while ($data = db2_lob_read($result, 2, 6)) {
        echo "Loop $i: $data\n";
        $i = $i + 1;
    }

    $drop = 'DROP TABLE blob_stream';
    $result = @db2_exec( $conn, $drop );

    $create = 'CREATE TABLE blob_stream (id INTEGER, my_blob CLOB)';
    $result = db2_exec( $conn, $create );

    $variable = "";
    $stmt = db2_prepare($conn, "INSERT INTO blob_stream (id,my_blob) VALUES (1, ?)");
    $variable = "THIS IS A BLOB TEST. THIS IS A BLOB TEST.";
    db2_bind_param($stmt, 1, "variable", DB2_PARAM_IN);
    db2_execute($stmt);

    $sql = "SELECT id,my_blob FROM blob_stream";
    $result = db2_prepare($conn, $sql);
    db2_execute($result);
    db2_fetch_row($result);
    $i = 0;
    /* Read LOB data */
    while ($data = db2_lob_read($result, 2, 6)) {
        echo "Loop $i: $data\n";
        $i = $i + 1;
    }
} else {
    echo 'no connection: ' . db2_conn_errormsg();
}

?>

Výše uvedený příklad vypíše:

Loop 0: THIS I
Loop 1: S A CL
Loop 2: OB TES
Loop 3: T. THI
Loop 4: S IS A
Loop 5:  CLOB
Loop 6: TEST.
Loop 0: THIS I
Loop 1: S A BL
Loop 2: OB TES
Loop 3: T. THI
Loop 4: S IS A
Loop 5:  BLOB
Loop 6: TEST.

Viz také

db2_bind_param()
db2_exec()
db2_execute()
db2_fetch_row()
db2_prepare()
db2_result()

Předcházející | Nahoru | Další
db2_get_option | Domů | db2_next_result


db2_next_result

(PECL ibm_db2:1.0-1.6.2)

db2_next_result — Requests the next result set from a stored procedure

Popis

resource db2_next_result ( resource $stmt )

A stored procedure can return zero or more result sets. While you handle the first result set in exactly the same way you would handle the results returned by a simple SELECT statement, to fetch the second and subsequent result sets from a stored procedure you must call the db2_next_result() function and return the result to a uniquely named PHP variable.

Seznam parametrů

stmt

A prepared statement returned from db2_exec() or db2_execute().

Návratové hodnoty

Returns a new statement resource containing the next result set if the stored procedure returned another result set. Returns FALSE if the stored procedure did not return another result set.

Příklady

Příklad 797. Calling a stored procedure that returns multiple result sets

In the following example, we call a stored procedure that returns three result sets. The first result set is fetched directly from the same statement resource on which we invoked the CALL statement, while the second and third result sets are fetched from statement resources returned from our calls to the db2_next_result() function.

<?php
$conn = db2_connect($database, $user, $password);

if ($conn) {
  $stmt = db2_exec($conn, 'CALL multiResults()');

  print "Fetching first result set\n";
  while ($row = db2_fetch_array($stmt)) {
    var_dump($row);
  }

  print "\nFetching second result set\n";
  $res = db2_next_result($stmt);
  if ($res) {
    while ($row = db2_fetch_array($res)) {
      var_dump($row);
    }
  }

  print "\nFetching third result set\n";
  $res2 = db2_next_result($stmt);
  if ($res2) {
    while ($row = db2_fetch_array($res2)) {
      var_dump($row);
    }
  }

  db2_close($conn);
}
?>

Výše uvedený příklad vypíše:

Fetching first result set
array(2) {
  [0]=>
  string(16) "Bubbles         "
  [1]=>
  int(3)
}
array(2) {
  [0]=>
  string(16) "Gizmo           "
  [1]=>
  int(4)
}

Fetching second result set
array(4) {
  [0]=>
  string(16) "Sweater         "
  [1]=>
  int(6)
  [2]=>
  string(5) "llama"
  [3]=>
  string(6) "150.00"
}
array(4) {
  [0]=>
  string(16) "Smarty          "
  [1]=>
  int(2)
  [2]=>
  string(5) "horse"
  [3]=>
  string(6) "350.00"
}

Fetching third result set
array(1) {
  [0]=>
  string(16) "Bubbles         "
}
array(1) {
  [0]=>
  string(16) "Gizmo           "
}

Předcházející | Nahoru | Další
db2_lob_read | Domů | db2_num_fields


db2_num_fields

(PECL ibm_db2:1.0-1.6.2)

db2_num_fields — Returns the number of fields contained in a result set

Popis

int db2_num_fields ( resource $stmt )

Returns the number of fields contained in a result set. This is most useful for handling the result sets returned by dynamically generated queries, or for result sets returned by stored procedures, where your application cannot otherwise know how to retrieve and use the results.

Seznam parametrů

stmt

A valid statement resource containing a result set.

Návratové hodnoty

Returns an integer value representing the number of fields in the result set associated with the specified statement resource. Returns FALSE if the statement resource is not a valid input value.

Příklady

Příklad 798. Retrieving the number of fields in a result set

The following example demonstrates how to retrieve the number of fields returned in a result set.

<?php

$sql = "SELECT id, name, breed, weight FROM animals ORDER BY breed";
$stmt = db2_prepare($conn, $sql);
db2_execute($stmt, $sql);
$columns = db2_num_fields($stmt);

echo "There are {$columns} columns in the result set.";
?>

Výše uvedený příklad vypíše:

There are 4 columns in the result set.

Viz také

db2_execute()
db2_field_display_size()
db2_field_name()
db2_field_num()
db2_field_precision()
db2_field_scale()
db2_field_type()
db2_field_width()

Předcházející | Nahoru | Další
db2_next_result | Domů | db2_num_rows


db2_num_rows

(PECL ibm_db2:1.0-1.6.2)

db2_num_rows — Returns the number of rows affected by an SQL statement

Popis

int db2_num_rows ( resource $stmt )

Returns the number of rows deleted, inserted, or updated by an SQL statement.

To determine the number of rows that will be returned by a SELECT statement, issue SELECT COUNT(*) with the same predicates as your intended SELECT statement and retrieve the value.

If your application logic checks the number of rows returned by a SELECT statement and branches if the number of rows is 0, consider modifying your application to attempt to return the first row with one of db2_fetch_assoc(), db2_fetch_both(), db2_fetch_array(), or db2_fetch_row(), and branch if the fetch function returns FALSE.

Poznámka: If you issue a SELECT statement using a scrollable cursor, db2_num_rows() returns the number of rows returned by the SELECT statement. However, the overhead associated with scrollable cursors significantly degrades the performance of your application, so if this is the only reason you are considering using scrollable cursors, you should use a forward-only cursor and either call SELECT COUNT(*) or rely on the boolean return value of the fetch functions to achieve the equivalent functionality with much better performance.

Seznam parametrů

stmt

A valid stmt resource containing a result set.

Návratové hodnoty

Returns the number of rows affected by the last SQL statement issued by the specified statement handle.

Předcházející | Nahoru | Další
db2_num_fields | Domů | db2_pconnect


db2_pconnect

(PECL ibm_db2:1.0-1.6.2)

db2_pconnect — Returns a persistent connection to a database

Popis

resource db2_pconnect ( string $database, string $username, string $password [, array $options] )

Returns a persistent connection to an IBM DB2 Universal Database, IBM Cloudscape, or Apache Derby database. For more information on persistent connections, refer to 42 – „Persistentní databázová spojení“.

Calling db2_close() on a persistent connection always returns TRUE, but the underlying DB2 client connection remains open and waiting to serve the next matching db2_pconnect() request.

Seznam parametrů

database

The database alias in the DB2 client catalog.

username

The username with which you are connecting to the database.

password

The password with which you are connecting to the database.

options

An associative array of connection options that affect the behavior of the connection, where valid array keys include:

autocommit

Passing the DB2_AUTOCOMMIT_ON value turns autocommit on for this connection handle.

Passing the DB2_AUTOCOMMIT_OFF value turns autocommit off for this connection handle.

DB2_ATTR_CASE

Passing the DB2_CASE_NATURAL value specifies that column names are returned in natural case.

Passing the DB2_CASE_LOWER value specifies that column names are returned in lower case.

Passing the DB2_CASE_UPPER value specifies that column names are returned in upper case.

CURSOR

Passing the DB2_FORWARD_ONLY value specifies a forward-only cursor for a statement resource. This is the default cursor type and is supported on all database servers.

Passing the DB2_SCROLLABLE value specifies a scrollable cursor for a statement resource. This mode enables random access to rows in a result set, but currently is supported only by IBM DB2 Universal Database.

Návratové hodnoty

Returns a connection handle resource if the connection attempt is successful. db2_pconnect() tries to reuse an existing connection resource that exactly matches the database, username, and password parameters. If the connection attempt fails, db2_pconnect() returns FALSE.

Příklady

Příklad 799. A db2_pconnect() example

In the following example, the first call to db2_pconnect() returns a new persistent connection resource. The second call to db2_pconnect() returns a persistent connection resource that simply reuses the first persistent connection resource.

<?php
$database = 'SAMPLE';
$user = 'db2inst1';
$password = 'ibmdb2';

$pconn = db2_pconnect($database, $user, $password);

if ($pconn) {
    echo "Persistent connection succeeded.";
}
else {
    echo "Persistent connection failed.";
}

$pconn2 = db2_pconnect($database, $user, $password);
if ($pconn) {
    echo "Second persistent connection succeeded.";
}
else {
    echo "Second persistent connection failed.";
}
?>

Výše uvedený příklad vypíše:

Persistent connection succeeded.
Second persistent connection succeeded.

Viz také

db2_connect()

Předcházející | Nahoru | Další
db2_num_rows | Domů | db2_prepare


db2_prepare

(PECL ibm_db2:1.0-1.6.2)

db2_prepare — Prepares an SQL statement to be executed

Popis

resource db2_prepare ( resource $connection, string $statement [, array $options] )

db2_prepare() creates a prepared SQL statement which can include 0 or more parameter markers (? characters) representing parameters for input, output, or input/output. You can pass parameters to the prepared statement using db2_bind_param(), or for input values only, as an array passed to db2_execute().

There are three main advantages to using prepared statements in your application:

  • Performance: when you prepare a statement, the database server creates an optimized access plan for retrieving data with that statement. Subsequently issuing the prepared statement with db2_execute() enables the statements to reuse that access plan and avoids the overhead of dynamically creating a new access plan for every statement you issue.

  • Security: when you prepare a statement, you can include parameter markers for input values. When you execute a prepared statement with input values for placeholders, the database server checks each input value to ensure that the type matches the column definition or parameter definition.

  • Advanced functionality: Parameter markers not only enable you to pass input values to prepared SQL statements, they also enable you to retrieve OUT and INOUT parameters from stored procedures using db2_bind_param().

Seznam parametrů

connection

A valid database connection resource variable as returned from db2_connect() or db2_pconnect().

statement

An SQL statement, optionally containing one or more parameter markers..

options

An associative array containing statement options. You can use this parameter to request a scrollable cursor on database servers that support this functionality.

cursor

Passing the DB2_FORWARD_ONLY value requests a forward-only cursor for this SQL statement. This is the default type of cursor, and it is supported by all database servers. It is also much faster than a scrollable cursor.

Passing the DB2_SCROLLABLE value requests a scrollable cursor for this SQL statement. This type of cursor enables you to fetch rows non-sequentially from the database server. However, it is only supported by DB2 servers, and is much slower than forward-only cursors.

Návratové hodnoty

Returns a statement resource if the SQL statement was successfully parsed and prepared by the database server. Returns FALSE if the database server returned an error. You can determine which error was returned by calling db2_stmt_error() or db2_stmt_errormsg().

Příklady

Příklad 800. Preparing and executing an SQL statement with parameter markers

The following example prepares an INSERT statement that accepts four parameter markers, then iterates over an array of arrays containing the input values to be passed to db2_execute().

<?php
$animals = array(
    array(0, 'cat', 'Pook', 3.2),
    array(1, 'dog', 'Peaches', 12.3),
    array(2, 'horse', 'Smarty', 350.0),
);

$insert = 'INSERT INTO animals (id, breed, name, weight)
    VALUES (?, ?, ?, ?)';
$stmt = db2_prepare($conn, $insert);
if ($stmt) {
    foreach ($animals as $animal) {
        $result = db2_execute($stmt, $animal);
    }
}
?>

Viz také

db2_bind_param()
db2_execute()
db2_stmt_error()
db2_stmt_errormsg()

Předcházející | Nahoru | Další
db2_pconnect | Domů | db2_primary_keys


db2_primary_keys

(PECL ibm_db2:1.0-1.6.2)

db2_primary_keys — Returns a result set listing primary keys for a table

Popis

resource db2_primary_keys ( resource $connection, string $qualifier, string $schema, string $table-name )

Returns a result set listing the primary keys for a table.

Seznam parametrů

connection

A valid connection to an IBM DB2, Cloudscape, or Apache Derby database.

qualifier

A qualifier for DB2 databases running on OS/390 or z/OS servers. For other databases, pass NULL or an empty string.

schema

The schema which contains the tables. If schema is NULL, db2_primary_keys() matches the schema for the current connection.

table-name

The name of the table.

Návratové hodnoty

Returns a statement resource with a result set containing rows describing the primary keys for the specified table. The result set is composed of the following columns:

Column name | Description
TABLE_CAT | Name of the catalog for the table containing the primary key. The value is NULL if this table does not have catalogs.
TABLE_SCHEM | Name of the schema for the table containing the primary key.
TABLE_NAME | Name of the table containing the primary key.
COLUMN_NAME | Name of the column containing the primary key.
KEY_SEQ | 1-indexed position of the column in the key.
PK_NAME | The name of the primary key.

Viz také

db2_column_privileges()
db2_columns()
db2_foreign_keys()
db2_procedure_columns()
db2_procedures()
db2_special_columns()
db2_statistics()
db2_table_privileges()
db2_tables()

Předcházející | Nahoru | Další
db2_prepare | Domů | db2_procedure_columns


db2_procedure_columns

(PECL ibm_db2:1.0-1.6.2)

db2_procedure_columns — Returns a result set listing stored procedure parameters

Popis

resource db2_procedure_columns ( resource $connection, string $qualifier, string $schema, string $procedure, string $parameter )

Returns a result set listing the parameters for one or more stored procedures.

Seznam parametrů

connection

A valid connection to an IBM DB2, Cloudscape, or Apache Derby database.

qualifier

A qualifier for DB2 databases running on OS/390 or z/OS servers. For other databases, pass NULL or an empty string.

schema

The schema which contains the procedures. This parameter accepts a search pattern containing _ and % as wildcards.

procedure

The name of the procedure. This parameter accepts a search pattern containing _ and % as wildcards.

parameter

The name of the parameter. This parameter accepts a search pattern containing _ and % as wildcards. If this parameter is NULL, all parameters for the specified stored procedures are returned.

Návratové hodnoty

Returns a statement resource with a result set containing rows describing the parameters for the stored procedures matching the specified parameters. The rows are composed of the following columns:

Column name | Description
PROCEDURE_CAT | The catalog that contains the procedure. The value is NULL if this table does not have catalogs.
PROCEDURE_SCHEM | Name of the schema that contains the stored procedure.
PROCEDURE_NAME | Name of the procedure.
COLUMN_NAME | Name of the parameter.
COLUMN_TYPE

An integer value representing the type of the parameter:

Return value | Parameter type
1 (SQL_PARAM_INPUT) | Input (IN) parameter.
2 (SQL_PARAM_INPUT_OUTPUT) | Input/output (INOUT) parameter.
3 (SQL_PARAM_OUTPUT) | Output (OUT) parameter.

DATA_TYPE | The SQL data type for the parameter represented as an integer value.
TYPE_NAME | A string representing the data type for the parameter.
COLUMN_SIZE | An integer value representing the size of the parameter.
BUFFER_LENGTH | Maximum number of bytes necessary to store data for this parameter.
DECIMAL_DIGITS | The scale of the parameter, or NULL where scale is not applicable.
NUM_PREC_RADIX | An integer value of either 10 (representing an exact numeric data type), 2 (representing an approximate numeric data type), or NULL (representing a data type for which radix is not applicable).
NULLABLE | An integer value representing whether the parameter is nullable or not.
REMARKS | Description of the parameter.
COLUMN_DEF | Default value for the parameter.
SQL_DATA_TYPE | An integer value representing the size of the parameter.
SQL_DATETIME_SUB | Returns an integer value representing a datetime subtype code, or NULL for SQL data types to which this does not apply.
CHAR_OCTET_LENGTH | Maximum length in octets for a character data type parameter, which matches COLUMN_SIZE for single-byte character set data, or NULL for non-character data types.
ORDINAL_POSITION | The 1-indexed position of the parameter in the CALL statement.
IS_NULLABLE | A string value where 'YES' means that the parameter accepts or returns NULL values and 'NO' means that the parameter does not accept or return NULL values.

Viz také

db2_column_privileges()
db2_columns()
db2_foreign_keys()
db2_primary_keys()
db2_procedures()
db2_special_columns()
db2_statistics()
db2_table_privileges()
db2_tables()

Předcházející | Nahoru | Další
db2_primary_keys | Domů | db2_procedures


db2_procedures

(PECL ibm_db2:1.0-1.6.2)

db2_procedures — Returns a result set listing the stored procedures registered in a database

Popis

resource db2_procedures ( resource $connection, string $qualifier, string $schema, string $procedure )

Returns a result set listing the stored procedures registered in a database.

Seznam parametrů

connection

A valid connection to an IBM DB2, Cloudscape, or Apache Derby database.

qualifier

A qualifier for DB2 databases running on OS/390 or z/OS servers. For other databases, pass NULL or an empty string.

schema

The schema which contains the procedures. This parameter accepts a search pattern containing _ and % as wildcards.

procedure

The name of the procedure. This parameter accepts a search pattern containing _ and % as wildcards.

Návratové hodnoty

Returns a statement resource with a result set containing rows describing the stored procedures matching the specified parameters. The rows are composed of the following columns:

Column name | Description
PROCEDURE_CAT | The catalog that contains the procedure. The value is NULL if this table does not have catalogs.
PROCEDURE_SCHEM | Name of the schema that contains the stored procedure.
PROCEDURE_NAME | Name of the procedure.
NUM_INPUT_PARAMS | Number of input (IN) parameters for the stored procedure.
NUM_OUTPUT_PARAMS | Number of output (OUT) parameters for the stored procedure.
NUM_RESULT_SETS | Number of result sets returned by the stored procedure.
REMARKS | Any comments about the stored procedure.
PROCEDURE_TYPE | Always returns 1, indicating that the stored procedure does not return a return value.

Viz také

db2_column_privileges()
db2_columns()
db2_foreign_keys()
db2_primary_keys()
db2_procedure_columns()
db2_special_columns()
db2_statistics()
db2_table_privileges()
db2_tables()

Předcházející | Nahoru | Další
db2_procedure_columns | Domů | db2_result


db2_result

(PECL ibm_db2:1.0-1.6.2)

db2_result — Returns a single column from a row in the result set

Popis

mixed db2_result ( resource $stmt, mixed $column )

Use db2_result() to return the value of a specified column in the current row of a result set. You must call db2_fetch_row() before calling db2_result() to set the location of the result set pointer.

Seznam parametrů

stmt

A valid stmt resource.

column

Either an integer mapping to the 0-indexed field in the result set, or a string matching the name of the column.

Návratové hodnoty

Returns the value of the requested field if the field exists in the result set. Returns NULL if the field does not exist, and issues a warning.

Příklady

Příklad 801. A db2_result() example

The following example demonstrates how to iterate through a result set with db2_fetch_row() and retrieve columns from the result set with db2_result().

<?php
$sql = 'SELECT name, breed FROM animals WHERE weight < ?';
$stmt = db2_prepare($conn, $sql);
db2_execute($stmt, array(10));
while (db2_fetch_row($stmt)) {
    $name = db2_result($stmt, 0);
    $breed = db2_result($stmt, 'BREED');
    print "$name $breed";
}
?>

Výše uvedený příklad vypíše:

cat Pook
gold fish Bubbles
budgerigar Gizmo
goat Rickety Ride

Viz také

db2_fetch_array()
db2_fetch_assoc()
db2_fetch_both()
db2_fetch_object()
db2_fetch_row()

Předcházející | Nahoru | Další
db2_procedures | Domů | db2_rollback


db2_rollback

(PECL ibm_db2:1.0-1.6.2)

db2_rollback — Rolls back a transaction

Popis

bool db2_rollback ( resource $connection )

Rolls back an in-progress transaction on the specified connection resource and begins a new transaction. PHP applications normally default to AUTOCOMMIT mode, so db2_rollback() normally has no effect unless AUTOCOMMIT has been turned off for the connection resource.

Poznámka: If the specified connection resource is a persistent connection, all transactions in progress for all applications using that persistent connection will be rolled back. For this reason, persistent connections are not recommended for use in applications that require transactions.

Seznam parametrů

connection

A valid database connection resource variable as returned from db2_connect() or db2_pconnect().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 802. Rolling back a DELETE statement

In the following example, we count the number of rows in a table, turn off AUTOCOMMIT mode on a database connection, delete all of the rows in the table and return the count of 0 to prove that the rows have been removed. We then issue db2_rollback() and return the updated count of rows in the table to show that the number is the same as before we issued the DELETE statement. The return to the original state of the table demonstrates that the roll back of the transaction succeeded.

<?php
$conn = db2_connect($database, $user, $password);

if ($conn) {
    $stmt = db2_exec($conn, "SELECT count(*) FROM animals");
    $res = db2_fetch_array( $stmt );
    echo $res[0] . "\n";

    // Turn AUTOCOMMIT off
    db2_autocommit($conn, DB2_AUTOCOMMIT_OFF);

    // Delete all rows from ANIMALS
    db2_exec($conn, "DELETE FROM animals");

    $stmt = db2_exec($conn, "SELECT count(*) FROM animals");
    $res = db2_fetch_array( $stmt );
    echo $res[0] . "\n";

    // Roll back the DELETE statement
    db2_rollback( $conn );

    $stmt = db2_exec( $conn, "SELECT count(*) FROM animals" );
    $res = db2_fetch_array( $stmt );
    echo $res[0] . "\n";
    db2_close($conn);
}
?>

Výše uvedený příklad vypíše:

7
0
7

Viz také

db2_autocommit()
db2_commit()

Předcházející | Nahoru | Další
db2_result | Domů | db2_server_info


db2_server_info

(PECL ibm_db2:1.1.1-1.6.2)

db2_server_info — Returns an object with properties that describe the DB2 database server

Popis

object db2_server_info ( resource $connection )

This function returns an object with read-only properties that return information about the IBM DB2, Cloudscape, or Apache Derby database server. The following table lists the database server properties:

Tabulka 118. Database server properties

Property name | Return type | Description
DBMS_NAME | string | The name of the database server to which you are connected. For DB2 servers this is a combination of DB2 followed by the operating system on which the database server is running.
DBMS_VER | string | The version of the database server, in the form of a string "MM.mm.uuuu" where MM is the major version, mm is the minor version, and uuuu is the update. For example, "08.02.0001" represents major version 8, minor version 2, update 1.
DB_CODEPAGE | int | The code page of the database to which you are connected.
DB_NAME | string | The name of the database to which you are connected.
DFT_ISOLATION string

The default transaction isolation level supported by the server:

UR

Uncommitted read: changes are immediately visible by all concurrent transactions.

CS

Cursor stability: a row read by one transaction can be altered and committed by a second concurrent transaction.

RS

Read stability: a transaction can add or remove rows matching a search condition or a pending transaction.

RR

Repeatable read: data affected by pending transaction is not available to other transactions.

NC

No commit: any changes are visible at the end of a successful operation. Explicit commits and rollbacks are not allowed.

IDENTIFIER_QUOTE_CHAR | string | The character used to delimit an identifier.
INST_NAME | string | The instance on the database server that contains the database.
ISOLATION_OPTION | array | An array of the isolation options supported by the database server. The isolation options are described in the DFT_ISOLATION property.
KEYWORDS | array | An array of the keywords reserved by the database server.
LIKE_ESCAPE_CLAUSE | bool | TRUE if the database server supports the use of % and _ wildcard characters. FALSE if the database server does not support these wildcard characters.
MAX_COL_NAME_LEN | int | Maximum length of a column name supported by the database server, expressed in bytes.
MAX_IDENTIFIER_LEN | int | Maximum length of an SQL identifier supported by the database server, expressed in characters.
MAX_INDEX_SIZE | int | Maximum size of columns combined in an index supported by the database server, expressed in bytes.
MAX_PROC_NAME_LEN | int | Maximum length of a procedure name supported by the database server, expressed in bytes.
MAX_ROW_SIZE | int | Maximum length of a row in a base table supported by the database server, expressed in bytes.
MAX_SCHEMA_NAME_LEN | int | Maximum length of a schema name supported by the database server, expressed in bytes.
MAX_STATEMENT_LEN | int | Maximum length of an SQL statement supported by the database server, expressed in bytes.
MAX_TABLE_NAME_LEN | int | Maximum length of a table name supported by the database server, expressed in bytes.
NON_NULLABLE_COLUMNS | bool | TRUE if the database server supports columns that can be defined as NOT NULL, FALSE if the database server does not support columns defined as NOT NULL.
PROCEDURES | bool | TRUE if the database server supports the use of the CALL statement to call stored procedures, FALSE if the database server does not support the CALL statement.
SPECIAL_CHARS | string | A string containing all of the characters other than a-Z, 0-9, and underscore that can be used in an identifier name.
SQL_CONFORMANCE string

The level of conformance to the ANSI/ISO SQL-92 specification offered by the database server:

ENTRY

Entry-level SQL-92 compliance.

FIPS127

FIPS-127-2 transitional compliance.

FULL

Full level SQL-92 compliance.

INTERMEDIATE

Intermediate level SQL-92 compliance.

Seznam parametrů

connection

Specifies an active DB2 client connection.

Návratové hodnoty

Returns an object on a successful call. Returns FALSE on failure.

Příklady

Příklad 803. A db2_server_info() example

To retrieve information about the server, you must pass a valid database connection resource to db2_server_info().

<?php

$conn = db2_connect('sample', 'db2inst1', 'ibmdb2');

$server = db2_server_info( $conn );

if ($server) {
    echo "DBMS_NAME: ";                 var_dump( $server->DBMS_NAME );
    echo "DBMS_VER: ";                  var_dump( $server->DBMS_VER );
    echo "DB_CODEPAGE: ";               var_dump( $server->DB_CODEPAGE );
    echo "DB_NAME: ";                   var_dump( $server->DB_NAME );
    echo "INST_NAME: ";                 var_dump( $server->INST_NAME );
    echo "SPECIAL_CHARS: ";             var_dump( $server->SPECIAL_CHARS );
    echo "KEYWORDS: ";                  var_dump( sizeof($server->KEYWORDS) );
    echo "DFT_ISOLATION: ";             var_dump( $server->DFT_ISOLATION );
    echo "ISOLATION_OPTION: ";
    $il = '';
    foreach( $server->ISOLATION_OPTION as $opt )
    {
       $il .= $opt." ";
    }
    var_dump( $il );
    echo "SQL_CONFORMANCE: ";           var_dump( $server->SQL_CONFORMANCE );
    echo "PROCEDURES: ";                var_dump( $server->PROCEDURES );
    echo "IDENTIFIER_QUOTE_CHAR: ";     var_dump( $server->IDENTIFIER_QUOTE_CHAR );
    echo "LIKE_ESCAPE_CLAUSE: ";        var_dump( $server->LIKE_ESCAPE_CLAUSE );
    echo "MAX_COL_NAME_LEN: ";          var_dump( $server->MAX_COL_NAME_LEN );
    echo "MAX_ROW_SIZE: ";              var_dump( $server->MAX_ROW_SIZE );
    echo "MAX_IDENTIFIER_LEN: ";        var_dump( $server->MAX_IDENTIFIER_LEN );
    echo "MAX_INDEX_SIZE: ";            var_dump( $server->MAX_INDEX_SIZE );
    echo "MAX_PROC_NAME_LEN: ";         var_dump( $server->MAX_PROC_NAME_LEN );
    echo "MAX_SCHEMA_NAME_LEN: ";       var_dump( $server->MAX_SCHEMA_NAME_LEN );
    echo "MAX_STATEMENT_LEN: ";         var_dump( $server->MAX_STATEMENT_LEN );
    echo "MAX_TABLE_NAME_LEN: ";        var_dump( $server->MAX_TABLE_NAME_LEN );
    echo "NON_NULLABLE_COLUMNS: ";      var_dump( $server->NON_NULLABLE_COLUMNS );

    db2_close($conn);
}
?>

Výše uvedený příklad vypíše:

DBMS_NAME: string(9) "DB2/LINUX"
DBMS_VER: string(10) "08.02.0000"
DB_CODEPAGE: int(1208)
DB_NAME: string(6) "SAMPLE"
INST_NAME: string(8) "db2inst1"
SPECIAL_CHARS: string(2) "@#"
KEYWORDS: int(179)
DFT_ISOLATION: string(2) "CS"
ISOLATION_OPTION: string(12) "UR CS RS RR "
SQL_CONFORMANCE: string(7) "FIPS127"
PROCEDURES: bool(true)
IDENTIFIER_QUOTE_CHAR: string(1) """
LIKE_ESCAPE_CLAUSE: bool(true)
MAX_COL_NAME_LEN: int(30)
MAX_ROW_SIZE: int(32677)
MAX_IDENTIFIER_LEN: int(18)
MAX_INDEX_SIZE: int(1024)
MAX_PROC_NAME_LEN: int(128)
MAX_SCHEMA_NAME_LEN: int(30)
MAX_STATEMENT_LEN: int(2097152)
MAX_TABLE_NAME_LEN: int(128)
NON_NULLABLE_COLUMNS: bool(true)

Viz také

db2_client_info()

Předcházející | Nahoru | Další
db2_rollback | Domů | db2_set_option


db2_set_option

(PECL ibm_db2:1.0-1.6.2)

db2_set_option — Set options for connection or statement resources

Popis

bool db2_set_option ( resource $resource, array $options, int $type )

Sets options for a statement resource or a connection resource. You cannot set options for result set resources.

Seznam parametrů

resource

A valid statement resource as returned from db2_prepare() or a valid connection resource as returned from db2_connect() or db2_pconnect().

options

An associative array containing valid statement or connection options. This parameter can be used to change autocommit values, cursor types (scrollable or forward), and to specify the case of the column names (lower, upper, or natural) that will appear in a result set.

autocommit

Passing DB2_AUTOCOMMIT_ON turns autocommit on for the specified connection resource.

Passing DB2_AUTOCOMMIT_OFF turns autocommit off for the specified connection resource.

cursor

Passing DB2_FORWARD_ONLY specifies a forward-only cursor for a statement resource. This is the default cursor type, and is supported by all database servers.

Passing DB2_SCROLLABLE specifies a scrollable cursor for a statement resource. Scrollable cursors enable result set rows to be accessed in non-sequential order, but are only supported by IBM DB2 Universal Database databases.

binmode

Passing DB2_BINARY specifies that binary data will be returned as is. This is the default mode. This is the equivalent of setting ibm_db2.binmode=1 in php.ini.

Passing DB2_CONVERT specifies that binary data will be converted to hexadecimal encoding, and will be returned as such. This is the equivalent of setting ibm_db2.binmode=2 in php.ini.

Passing DB2_PASSTHRU specifies that binary data will be converted to NULL. This is the equivalent of setting ibm_db2.binmode=3 in php.ini.

db2_attr_case

Passing DB2_CASE_LOWER specifies that column names of the result set are returned in lower case.

Passing DB2_CASE_UPPER specifies that column names of the result set are returned in upper case.

Passing DB2_CASE_NATURAL specifies that column names of the result set are returned in natural case.

deferred_prepare

Passing DB2_DEFERRED_PREPARE_ON turns deferred prepare on for the specified statement resource.

Passing DB2_DEFERRED_PREPARE_OFF turns deferred prepare off for the specified statement resource.

The following new i5/OS options are available as of ibm_db2 version 1.5.1.

Note: Prior versions of ibm_db2 do not support these new i5 options.

i5_fetch_only

DB2_I5_FETCH_ON - Cursors are read-only and cannot be used for positioned updates or deletes. This is the default unless SQL_ATTR_FOR_FETCH_ONLY environment has been set to SQL_FALSE.

DB2_I5_FETCH_OFF - Cursors can be used for positioned updates and deletes.

The following new options are available as of ibm_db2 version 1.6.0. They provide useful tracking information that can be accessed during execution with db2_get_option().

Note: Prior versions of ibm_db2 do not support these new options.

When the value in each option is being set, some servers might not handle the entire length provided and might truncate the value.

To ensure that the data specified in each option is converted correctly when transmitted to a host system, use only the characters A through Z, 0 through 9, and the underscore (_) or period (.).

userid

SQL_ATTR_INFO_USERID - A pointer to a null-terminated character string used to identify the client user ID sent to the host database server when using DB2 Connect.

Note: DB2 for z/OS and OS/390 servers support up to a length of 16 characters. This user-id is not to be confused with the authentication user-id, it is for identification purposes only and is not used for any authorization.

acctstr

SQL_ATTR_INFO_ACCTSTR - A pointer to a null-terminated character string used to identify the client accounting string sent to the host database server when using DB2 Connect.

Note: DB2 for z/OS and OS/390 servers support up to a length of 200 characters.

applname

SQL_ATTR_INFO_APPLNAME - A pointer to a null-terminated character string used to identify the client application name sent to the host database server when using DB2 Connect.

Note: DB2 for z/OS and OS/390 servers support up to a length of 32 characters.

wrkstnname

SQL_ATTR_INFO_WRKSTNNAME - A pointer to a null-terminated character string used to identify the client workstation name sent to the host database server when using DB2 Connect.

Note: DB2 for z/OS and OS/390 servers support up to a length of 18 characters.

type

An integer value that specifies the type of resource that was passed into the function. The type of resource and this value must correspond.

Passing 1 as the value specifies that a connection resource has been passed into the function.

Passing any integer not equal to 1 as the value specifies that a statement resource has been passed into the function.

The following table specifies which options are compatible with the available resource types:

Tabulka 119. Resource-Parameter Matrix

Key | Value | Resource Type
 |  | Connection | Statement | Result Set
autocommit | DB2_AUTOCOMMIT_ON | X | - | -
autocommit | DB2_AUTOCOMMIT_OFF | X | - | -
cursor | DB2_SCROLLABLE | - | X | -
cursor | DB2_FORWARD_ONLY | - | X | -
binmode | DB2_BINARY | X | X | -
binmode | DB2_CONVERT | X | X | -
binmode | DB2_PASSTHRU | X | X | -
db2_attr_case | DB2_CASE_LOWER | X | X | -
db2_attr_case | DB2_CASE_UPPER | X | X | -
db2_attr_case | DB2_CASE_NATURAL | X | X | -
deferred_prepare | DB2_DEFERRED_PREPARE_ON | - | X | -
deferred_prepare | DB2_DEFERRED_PREPARE_OFF | - | X | -
i5_fetch_only | DB2_I5_FETCH_ON | - | X | -
i5_fetch_only | DB2_I5_FETCH_OFF | - | X | -
userid | SQL_ATTR_INFO_USERID | X | X | -
acctstr | SQL_ATTR_INFO_ACCTSTR | X | X | -
applname | SQL_ATTR_INFO_APPLNAME | X | X | -
wrkstnname | SQL_ATTR_INFO_WRKSTNNAME | X | X | -

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 804. Setting one parameter with a connection resource

<?php
/* Database Connection Parameters */
$database = 'SAMPLE';
$hostname = 'localhost';
$port = 50000;
$protocol = 'TCPIP';
$username = 'db2inst1';
$password = 'ibmdb2';

/* Connection String */
$conn_string = "DRIVER={IBM DB2 ODBC DRIVER};DATABASE=$database;";
$conn_string .= "HOSTNAME=$hostname;PORT=$port;PROTOCOL=$protocol;";
$conn_string .= "UID=$username;PWD=$password;";

/* Obtain Connection Resource */
$conn = db2_connect($conn_string, '', '');

/* Create the associative options array with valid key-value pairs */
$options = array('autocommit' => DB2_AUTOCOMMIT_ON);

/* Call the function using the correct resource, options array, and type values */
$result = db2_set_option($conn, $options, 1);

/* Check if all options could be set correctly */
if($result)
{
  echo 'Options Set Successfully';
}
else
{
  echo 'Could Not Set Options';
}
?>

Výše uvedený příklad vypíše:

Options Set Successfully

Příklad 805. Setting multiple parameters with a connection resource

<?php
/* Database Connection Parameters */
$database = 'SAMPLE';
$hostname = 'localhost';
$port = 50000;
$protocol = 'TCPIP';
$username = 'db2inst1';
$password = 'ibmdb2';

/* Connection String */
$conn_string = "DRIVER={IBM DB2 ODBC DRIVER};DATABASE=$database;";
$conn_string .= "HOSTNAME=$hostname;PORT=$port;PROTOCOL=$protocol;";
$conn_string .= "UID=$username;PWD=$password;";

/* Obtain Connection Resource */
$conn = db2_connect($conn_string, '', '');

/* Create the associative options array with valid key-value pairs */
$options = array('autocommit' => DB2_AUTOCOMMIT_OFF,
                    'binmode' => DB2_PASSTHRU,
              'db2_attr_case' => DB2_CASE_UPPER,
                     'cursor' => DB2_SCROLLABLE);

/* Call the function using the correct resource, options array, and type values */
$result = db2_set_option($conn, $options, 1);

/* Check if all options could be set correctly */
if($result)
{
  echo 'Options Set Successfully';
}
else
{
  echo 'Could Not Set Options';
}
?>

Výše uvedený příklad vypíše:

Options Set Successfully

Příklad 806. Setting multiple parameters with an invalid key

<?php
/* Database Connection Parameters */
$database = 'SAMPLE';
$hostname = 'localhost';
$port = 50000;
$protocol = 'TCPIP';
$username = 'db2inst1';
$password = 'ibmdb2';

/* Connection String */
$conn_string = "DRIVER={IBM DB2 ODBC DRIVER};DATABASE=$database;";
$conn_string .= "HOSTNAME=$hostname;PORT=$port;PROTOCOL=$protocol;";
$conn_string .= "UID=$username;PWD=$password;";

/* Obtain Connection Resource */
$conn = db2_connect($conn_string, '', '');

/* Create the associative options array with valid key-value pairs */
$options = array('autocommit' => DB2_AUTOCOMMIT_OFF,
             'MY_INVALID_KEY' => DB2_PASSTHRU,
              'db2_attr_case' => DB2_CASE_UPPER,
                     'cursor' => DB2_SCROLLABLE);

/* Call the function using the correct resource, options array, and type values */
$result = db2_set_option($conn, $options, 1);

/* Check if all options could be set correctly */
if($result)
{
  echo 'Options Set Successfully';
}
else
{
  echo 'Could Not Set Options';
}
?>

Výše uvedený příklad vypíše:

Could Not Set Options

Příklad 807. Setting multiple parameters with an invalid value

<?php
/* Database Connection Parameters */
$database = 'SAMPLE';
$hostname = 'localhost';
$port = 50000;
$protocol = 'TCPIP';
$username = 'db2inst1';
$password = 'ibmdb2';

/* Connection String */
$conn_string = "DRIVER={IBM DB2 ODBC DRIVER};DATABASE=$database;";
$conn_string .= "HOSTNAME=$hostname;PORT=$port;PROTOCOL=$protocol;";
$conn_string .= "UID=$username;PWD=$password;";

/* Obtain Connection Resource */
$conn = db2_connect($conn_string, '', '');

/* Create the associative options array with valid key-value pairs */
$options = array('autocommit' => DB2_AUTOCOMMIT_OFF,
                    'binmode' => 'INVALID_VALUE',
              'db2_attr_case' => DB2_CASE_UPPER,
                     'cursor' => DB2_SCROLLABLE);

/* Call the function using the correct resource, options array, and type values */
$result = db2_set_option($conn, $options, 1);

/* Check if all options could be set correctly */
if($result)
{
  echo 'Options Set Successfully';
}
else
{
  echo 'Could Not Set Options';
}
?>

Výše uvedený příklad vypíše:

Could Not Set Options

Příklad 808. Setting multiple parameters with a connection resource and the wrong type

<?php
/* Database Connection Parameters */
$database = 'SAMPLE';
$hostname = 'localhost';
$port = 50000;
$protocol = 'TCPIP';
$username = 'db2inst1';
$password = 'ibmdb2';

/* Connection String */
$conn_string = "DRIVER={IBM DB2 ODBC DRIVER};DATABASE=$database;";
$conn_string .= "HOSTNAME=$hostname;PORT=$port;PROTOCOL=$protocol;";
$conn_string .= "UID=$username;PWD=$password;";

/* Obtain Connection Resource */
$conn = db2_connect($conn_string, '', '');

/* Create the associative options array with valid key-value pairs */
$options = array('autocommit' => DB2_AUTOCOMMIT_OFF,
                    'binmode' => DB2_PASSTHRU,
              'db2_attr_case' => DB2_CASE_UPPER,
                     'cursor' => DB2_SCROLLABLE);

/* Call the function using the correct resource, options array, and the wrong type value */
$result = db2_set_option($conn, $options, 2);

/* Check if all options could be set correctly */
if($result)
{
  echo 'Options Set Successfully';
}
else
{
  echo 'Could Not Set Options';
}
?>

Výše uvedený příklad vypíše:

Could Not Set Options

Příklad 809. Setting multiple parameters with the wrong resource

<?php
/* Database Connection Parameters */
$database = 'SAMPLE';
$hostname = 'localhost';
$port = 50000;
$protocol = 'TCPIP';
$username = 'db2inst1';
$password = 'ibmdb2';

/* Connection String */
$conn_string = "DRIVER={IBM DB2 ODBC DRIVER};DATABASE=$database;";
$conn_string .= "HOSTNAME=$hostname;PORT=$port;PROTOCOL=$protocol;";
$conn_string .= "UID=$username;PWD=$password;";

/* Obtain Connection Resource */
$conn = db2_connect($conn_string, '', '');

/* Create the associative options array with valid key-value pairs */
$options = array('autocommit' => DB2_AUTOCOMMIT_OFF,
                    'binmode' => DB2_PASSTHRU,
              'db2_attr_case' => DB2_CASE_UPPER,
                     'cursor' => DB2_SCROLLABLE);

$stmt = db2_prepare($conn, 'SELECT * FROM EMPLOYEE');

/* Call the function using the wrong resource, and the correct options array, and type values */
$result = db2_set_option($stmt, $options, 1);

/* Check if all options could be set correctly */
if($result)
{
  echo 'Options Set Successfully';
}
else
{
  echo 'Could Not Set Options';
}
?>

Výše uvedený příklad vypíše:

Could Not Set Options

Příklad 810. Putting it all together

<?php
/* Database Connection Parameters */
$database = 'SAMPLE';
$hostname = 'localhost';
$port = 50000;
$protocol = 'TCPIP';
$username = 'db2inst1';
$password = 'ibmdb2';

/* Connection String */
$conn_string = "DRIVER={IBM DB2 ODBC DRIVER};DATABASE=$database;";
$conn_string .= "HOSTNAME=$hostname;PORT=$port;PROTOCOL=$protocol;";
$conn_string .= "UID=$username;PWD=$password;";

/* Obtain Connection Resource */
$conn = db2_connect($conn_string, '', '');

/* Create the associative options array with valid key-value pairs */
$options = array('db2_attr_case' => DB2_CASE_LOWER,
                        'cursor' => DB2_SCROLLABLE);

$stmt = db2_prepare($conn, 'SELECT * FROM EMPLOYEE WHERE EMPNO = ? OR EMPNO = ?');

/* Call the function using the correct resource, options array, and type values */
$option_result = db2_set_option($stmt, $options, 2);
$result = db2_execute($stmt, array('000130', '000140'));

/* Get Row 2 before Row 1 since Scrollable Cursor */
print_r(db2_fetch_assoc($stmt, 2));
print '<br /><br />';
print_r(db2_fetch_assoc($stmt, 1));

?>

Výše uvedený příklad vypíše:

Array
(
    [empno] => 000140
    [firstnme] => HEATHER
    [midinit] => A
    [lastname] => NICHOLLS
    [workdept] => C01
    [phoneno] => 1793
    [hiredate] => 1976-12-15
    [job] => ANALYST
    [edlevel] => 18
    [sex] => F
    [birthdate] => 1946-01-19
    [salary] => 28420.00
    [bonus] => 600.00
    [comm] => 2274.00
)

Array
(
    [empno] => 000130
    [firstnme] => DELORES
    [midinit] => M
    [lastname] => QUINTANA
    [workdept] => C01
    [phoneno] => 4578
    [hiredate] => 1971-07-28
    [job] => ANALYST
    [edlevel] => 16
    [sex] => F
    [birthdate] => 1925-09-15
    [salary] => 23800.00
    [bonus] => 500.00
    [comm] => 1904.00
)

Příklad 811. i5/OS cursors are read-only

<?php
  $conn = db2_connect("", "", "", array("i5_lib"=>"nobody"));
  $stmt = db2_prepare($conn, 'select * from names where first = ?');
  $name = "first2";
  db2_bind_param($stmt, 1, "name", DB2_PARAM_IN);
  $options = array("i5_fetch_only"=>DB2_I5_FETCH_ON);
  db2_set_option($stmt,$options,0);
  if (db2_execute($stmt)) {
    while ($row = db2_fetch_array($stmt)) {
      echo "{$row[0]} {$row[1]}";
    }
  }
?>

Výše uvedený příklad vypíše:

first2 last2

Viz také

db2_connect()
db2_pconnect()
db2_exec()
db2_prepare()
db2_cursor_type()

Předcházející | Nahoru | Další
db2_server_info | Domů | db2_special_columns


db2_special_columns

(PECL ibm_db2:1.0-1.6.2)

db2_special_columns — Returns a result set listing the unique row identifier columns for a table

Popis

resource db2_special_columns ( resource $connection, string $qualifier, string $schema, string $table_name, int $scope )

Returns a result set listing the unique row identifier columns for a table.

Seznam parametrů

connection

A valid connection to an IBM DB2, Cloudscape, or Apache Derby database.

qualifier

A qualifier for DB2 databases running on OS/390 or z/OS servers. For other databases, pass NULL or an empty string.

schema

The schema which contains the tables.

table_name

The name of the table.

scope

Integer value representing the minimum duration for which the unique row identifier is valid. This can be one of the following values:

Integer value | SQL constant | Description
0 | SQL_SCOPE_CURROW | Row identifier is valid only while the cursor is positioned on the row.
1 | SQL_SCOPE_TRANSACTION | Row identifier is valid for the duration of the transaction.
2 | SQL_SCOPE_SESSION | Row identifier is valid for the duration of the connection.

Návratové hodnoty

Returns a statement resource with a result set containing rows with unique row identifier information for a table. The rows are composed of the following columns:

Column name | Description
SCOPE

Integer value | SQL constant | Description
0 | SQL_SCOPE_CURROW | Row identifier is valid only while the cursor is positioned on the row.
1 | SQL_SCOPE_TRANSACTION | Row identifier is valid for the duration of the transaction.
2 | SQL_SCOPE_SESSION | Row identifier is valid for the duration of the connection.

COLUMN_NAME | Name of the unique column.
DATA_TYPE | SQL data type for the column.
TYPE_NAME | Character string representation of the SQL data type for the column.
COLUMN_SIZE | An integer value representing the size of the column.
BUFFER_LENGTH | Maximum number of bytes necessary to store data from this column.
DECIMAL_DIGITS | The scale of the column, or NULL where scale is not applicable.
NUM_PREC_RADIX | An integer value of either 10 (representing an exact numeric data type), 2 (representing an approximate numeric data type), or NULL (representing a data type for which radix is not applicable).
PSEUDO_COLUMN | Always returns 1.

Viz také

db2_column_privileges()
db2_columns()
db2_foreign_keys()
db2_primary_keys()
db2_procedure_columns()
db2_procedures()
db2_statistics()
db2_table_privileges()
db2_tables()

Předcházející | Nahoru | Další
db2_set_option | Domů | db2_statistics


db2_statistics

(PECL ibm_db2:1.0-1.6.2)

db2_statistics — Returns a result set listing the index and statistics for a table

Popis

resource db2_statistics ( resource $connection, string $qualifier, string $schema, string $table-name, bool $unique )

Returns a result set listing the index and statistics for a table.

Seznam parametrů

connection

A valid connection to an IBM DB2, Cloudscape, or Apache Derby database.

qualifier

A qualifier for DB2 databases running on OS/390 or z/OS servers. For other databases, pass NULL or an empty string.

schema

The schema that contains the targeted table. If this parameter is NULL, the statistics and indexes are returned for the schema of the current user.

table_name

The name of the table.

unique

An integer value representing the type of index information to return.

0

Return only the information for unique indexes on the table.

1

Return the information for all indexes on the table.

Návratové hodnoty

Returns a statement resource with a result set containing rows describing the statistics and indexes for the base tables matching the specified parameters. The rows are composed of the following columns:

Column name | Description
TABLE_CAT | The catalog that contains the table. The value is NULL if this table does not have catalogs.
TABLE_SCHEM | Name of the schema that contains the table.
TABLE_NAME | Name of the table.
NON_UNIQUE

An integer value representing whether the index prohibits unique values, or whether the row represents statistics on the table itself:

Return value | Parameter type
0 (SQL_FALSE) | The index allows duplicate values.
1 (SQL_TRUE) | The index values must be unique.
NULL | This row is statistics information for the table itself.

INDEX_QUALIFIER | A string value representing the qualifier that would have to be prepended to INDEX_NAME to fully qualify the index.
INDEX_NAME | A string representing the name of the index.
TYPE

An integer value representing the type of information contained in this row of the result set:

Return value | Parameter type
0 (SQL_TABLE_STAT) | The row contains statistics about the table itself.
1 (SQL_INDEX_CLUSTERED) | The row contains information about a clustered index.
2 (SQL_INDEX_HASH) | The row contains information about a hashed index.
3 (SQL_INDEX_OTHER) | The row contains information about a type of index that is neither clustered nor hashed.

ORDINAL_POSITION | The 1-indexed position of the column in the index. NULL if the row contains statistics information about the table itself.
COLUMN_NAME | The name of the column in the index. NULL if the row contains statistics information about the table itself.
ASC_OR_DESC | A if the column is sorted in ascending order, D if the column is sorted in descending order, NULL if the row contains statistics information about the table itself.
CARDINALITY

If the row contains information about an index, this column contains an integer value representing the number of unique values in the index.

If the row contains information about the table itself, this column contains an integer value representing the number of rows in the table.

PAGES

If the row contains information about an index, this column contains an integer value representing the number of pages used to store the index.

If the row contains information about the table itself, this column contains an integer value representing the number of pages used to store the table.

FILTER_CONDITION | Always returns NULL.

Viz také

db2_column_privileges()
db2_columns()
db2_foreign_keys()
db2_primary_keys()
db2_procedure_columns()
db2_procedures()
db2_special_columns()
db2_table_privileges()
db2_tables()

Předcházející | Nahoru | Další
db2_special_columns | Domů | db2_stmt_error


db2_stmt_error

(PECL ibm_db2:1.0-1.6.2)

db2_stmt_error — Returns a string containing the SQLSTATE returned by an SQL statement

Popis

string db2_stmt_error ( [resource $stmt] )

Returns a string containing the SQLSTATE value returned by an SQL statement.

If you do not pass a statement resource as an argument to db2_stmt_error(), the driver returns the SQLSTATE value associated with the last attempt to return a statement resource, for example, from db2_prepare() or db2_exec().

To learn what the SQLSTATE value means, you can issue the following command at a DB2 Command Line Processor prompt: db2 '? sqlstate-value'. You can also call db2_stmt_errormsg() to retrieve an explicit error message and the associated SQLCODE value.

Seznam parametrů

stmt

A valid statement resource.

Návratové hodnoty

Returns a string containing an SQLSTATE value.

Viz také

db2_conn_error()
db2_conn_errormsg()
db2_stmt_errormsg()

Předcházející | Nahoru | Další
db2_statistics | Domů | db2_stmt_errormsg


db2_stmt_errormsg

(PECL ibm_db2:1.0-1.6.2)

db2_stmt_errormsg — Returns a string containing the last SQL statement error message

Popis

string db2_stmt_errormsg ( [resource $stmt] )

Returns a string containing the last SQL statement error message.

If you do not pass a statement resource as an argument to db2_stmt_errormsg(), the driver returns the error message associated with the last attempt to return a statement resource, for example, from db2_prepare() or db2_exec().

Seznam parametrů

stmt

A valid statement resource.

Návratové hodnoty

Returns a string containing the error message and SQLCODE value for the last error that occurred issuing an SQL statement.

Viz také

db2_conn_error()
db2_conn_errormsg()
db2_stmt_error()

Předcházející | Nahoru | Další
db2_stmt_error | Domů | db2_table_privileges


db2_table_privileges

(PECL ibm_db2:1.0-1.6.2)

db2_table_privileges — Returns a result set listing the tables and associated privileges in a database

Popis

resource db2_table_privileges ( resource $connection [, string $qualifier [, string $schema [, string $table_name]]] )

Returns a result set listing the tables and associated privileges in a database.

Seznam parametrů

connection

A valid connection to an IBM DB2, Cloudscape, or Apache Derby database.

qualifier

A qualifier for DB2 databases running on OS/390 or z/OS servers. For other databases, pass NULL or an empty string.

schema

The schema which contains the tables. This parameter accepts a search pattern containing _ and % as wildcards.

table_name

The name of the table. This parameter accepts a search pattern containing _ and % as wildcards.

Návratové hodnoty

Returns a statement resource with a result set containing rows describing the privileges for the tables that match the specified parameters. The rows are composed of the following columns:

Column name | Description
TABLE_CAT | The catalog that contains the table. The value is NULL if this table does not have catalogs.
TABLE_SCHEM | Name of the schema that contains the table.
TABLE_NAME | Name of the table.
GRANTOR | Authorization ID of the user who granted the privilege.
GRANTEE | Authorization ID of the user to whom the privilege was granted.
PRIVILEGE | The privilege that has been granted. This can be one of ALTER, CONTROL, DELETE, INDEX, INSERT, REFERENCES, SELECT, or UPDATE.
IS_GRANTABLE | A string value of "YES" or "NO" indicating whether the grantee can grant the privilege to other users.

Viz také

db2_column_privileges()
db2_columns()
db2_foreign_keys()
db2_primary_keys()
db2_procedure_columns()
db2_procedures()
db2_special_columns()
db2_statistics()
db2_tables()

Předcházející | Nahoru | Další
db2_stmt_errormsg | Domů | db2_tables


db2_tables

(PECL ibm_db2:1.0-1.6.2)

db2_tables — Returns a result set listing the tables and associated metadata in a database

Popis

resource db2_tables ( resource $connection [, string $qualifier [, string $schema [, string $table-name [, string $table-type]]]] )

Returns a result set listing the tables and associated metadata in a database.

Seznam parametrů

connection

A valid connection to an IBM DB2, Cloudscape, or Apache Derby database.

qualifier

A qualifier for DB2 databases running on OS/390 or z/OS servers. For other databases, pass NULL or an empty string.

schema

The schema which contains the tables. This parameter accepts a search pattern containing _ and % as wildcards.

table-name

The name of the table. This parameter accepts a search pattern containing _ and % as wildcards.

table-type

A list of comma-delimited table type identifiers. To match all table types, pass NULL or an empty string. Valid table type identifiers include: ALIAS, HIERARCHY TABLE, INOPERATIVE VIEW, NICKNAME, MATERIALIZED QUERY TABLE, SYSTEM TABLE, TABLE, TYPED TABLE, TYPED VIEW, and VIEW.

Návratové hodnoty

Returns a statement resource with a result set containing rows describing the tables that match the specified parameters. The rows are composed of the following columns:

Column name | Description
TABLE_CAT | The catalog that contains the table. The value is NULL if this table does not have catalogs.
TABLE_SCHEM | Name of the schema that contains the table.
TABLE_NAME | Name of the table.
TABLE_TYPE | Table type identifier for the table.
REMARKS | Description of the table.

Viz také

db2_column_privileges()
db2_columns()
db2_foreign_keys()
db2_primary_keys()
db2_procedure_columns()
db2_procedures()
db2_special_columns()
db2_statistics()
db2_table_privileges()

Předcházející | Nahoru | Další
db2_table_privileges | Domů | LXII. iconv Functions


DOMAttr->__construct()

(PHP 5)

DOMAttr->__construct() — Creates a new DOMAttr object

Popis

class DOMAttr {
__construct ( string $name [, string $value] )
}

Creates a new DOMAttr object. This object is read only. It may be appended to a document, but additional nodes may not be appended to this node until the node is associated with a document. To create a writeable node, use DOMDocument->createAttribute().

Seznam parametrů

name

The tag name of the attribute.

value

The value of the attribute.

Příklady

Příklad 406. Creating a new DOMAttr

<?php

$dom = new DOMDocument('1.0', 'iso-8859-1');
$element = $dom->appendChild(new DOMElement('root'));
$attr = $element->setAttributeNode(new DOMAttr('attr', 'attrvalue'));
echo $dom->saveXML(); /* <?xml version="1.0" encoding="iso-8859-1"?><root attr="attrvalue" /> */

?>

Viz také

DOMDocument->createAttribute()

Předcházející | Nahoru | Další
XXXI. DOM Functions | Domů | DOMAttr->isId()


DOMComment->__construct()

(PHP 5)

DOMComment->__construct() — Creates a new DOMComment object

Popis

class DOMComment {
__construct ( [string $value] )
}

Creates a new DOMComment object. This object is read only. It may be appended to a document, but additional nodes may not be appended to this node until the node is associated with a document. To create a writeable node, use DOMDocument->createComment().

Seznam parametrů

value

The value of the comment.

Příklady

Příklad 408. Creating a new DOMComment

<?php

$dom = new DOMDocument('1.0', 'iso-8859-1');
$element = $dom->appendChild(new DOMElement('root'));
$comment = $element->appendChild(new DOMComment('root comment'));
echo $dom->saveXML(); /* <?xml version="1.0" encoding="iso-8859-1"?><root><!--root comment--></root> */

?>

Viz také

DOMDocument->createComment()

Předcházející | Nahoru | Další
DOMCharacterData->substringData() | Domů | DOMDocument->__construct()


DOMDocument->__construct()

(PHP 5)

DOMDocument->__construct() — Creates a new DOMDocument object

Popis

class DOMDocument {
__construct ( [string $version [, string $encoding]] )
}

Creates a new DOMDocument object.

Seznam parametrů

version

The version number of the document as part of the XML declaration.

encoding

The encoding of the document as part of the XML declaration.

Příklady

Příklad 409. Creating a new DOMDocument

<?php

$dom = new DOMDocument('1.0', 'iso-8859-1');

echo $dom->saveXML(); /* <?xml version="1.0" encoding="iso-8859-1"?> */

?>

Viz také

DOMImplementation->createDocument()

Předcházející | Nahoru | Další
DOMComment->__construct() | Domů | DOMDocument->createAttribute()


DOMDocument->normalizeDocument()

(No version information available, might be only in CVS)

DOMDocument->normalizeDocument() — Normalizes the document

Popis

class DOMDocument {
void normalizeDocument ( void )
}

This method acts as if you saved and then loaded the document, putting the document in a "normal" form.

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

» The DOM Specification
DOMNode->normalize()

Předcházející | Nahoru | Další
DOMDocument->loadXML() | Domů | DOMDocument->registerNodeClass()


DOMDocument->registerNodeClass()

(PHP 5 >= 5.2.0)

DOMDocument->registerNodeClass() — Register extended class used to create base node type

Popis

class DOMDocument {
bool registerNodeClass ( string $baseclass, string $extendedclass )
}

This method allows you to register your own extended DOM class to be used afterward by the PHP DOM extension.

This method is not part of the DOM standard.

Seznam parametrů

baseclass

The DOM class that you want to extend. You can find a list of these classes in the chapter introduction.

Of course, you won't be able to register a class extending DOMDocument but you can always start your document by instanciating your own extending class.

extendedclass

Your extended class name. If NULL is provided, any previously registered class extending baseclass will be removed.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

ChangeLog (záznam změn)

Verze | Popis
PHP 5.2.2 | Prior to 5.2.2, a previously registered extendedclass had to be unregistered before being able to register a new class extending the same baseclass.

Příklady

Příklad 419. Adding a new method to DOMElement to ease our code

<?php

class myElement extends DOMElement {
   function appendElement($name) {
      return $this->appendChild(new myElement($name));
   }
}

class myDocument extends DOMDocument {
   function setRoot($name) {
      return $this->appendChild(new myElement($name));
   }
}

$doc = new myDocument();
$doc->registerNodeClass('DOMElement', 'myElement');

// From now on, adding an element to another costs only one method call !
$root = $doc->setRoot('root');
$child = $root->appendElement('child');
$child->setAttribute('foo', 'bar');

echo $doc->saveXML();

?>

Výše uvedený příklad vypíše:

<?xml version="1.0" ?>
<root><child foo="bar"/></root>

Předcházející | Nahoru | Další
DOMDocument->normalizeDocument() | Domů | DOMDocument->relaxNGValidate()


DOMDocumentFragment->appendXML()

(PHP 5 >= 5.1.0)

DOMDocumentFragment->appendXML() — Append raw XML data

Popis

class DOMDocumentFragment {
bool appendXML ( string $data )
}

Appends raw XML data to a DOMDocumentFragment.

This method is not part of the DOM standard. It was created as a simplier approach for appending an XML DocumentFragment in a DOMDocument.

If you want to stick to the standards, you will have to create a temporary DOMDocument with a dummy root and then loop through the child nodes of the root of your XML data to append them.

Seznam parametrů

data

XML to append.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 426. Appending XML data to your document

<?php
$doc = new DOMDocument();
$doc->loadXML("<root/>");
$f = $doc->createDocumentFragment();
$f->appendXML("<foo>text</foo><bar>text2</bar>");
$doc->documentElement->appendChild($f);
echo $doc->saveXML();
?>

Výše uvedený příklad vypíše:

<?xml version="1.0" ?>
<root><foo>text</foo><bar>text2</bar></root>

Předcházející | Nahoru | Další
DOMDocument->xinclude() | Domů | DOMElement->__construct()


DOMElement->__construct()

(PHP 5)

DOMElement->__construct() — Creates a new DOMElement object

Popis

class DOMElement {
__construct ( string $name [, string $value [, string $namespaceURI]] )
}

Creates a new DOMElement object. This object is read only. It may be appended to a document, but additional nodes may not be appended to this node until the node is associated with a document. To create a writeable node, use DOMDocument->createElement() or DOMDocument->createElementNS().

Seznam parametrů

name

The tag name of the element. When also passing in namespaceURI, the element name may take a prefix to be associated with the URI.

value

The value of the element.

namespaceURI

A namespace URI to create the element within a specific namespace.

Příklady

Příklad 427. Creating a new DOMElement

<?php

$dom = new DOMDocument('1.0', 'iso-8859-1');
$element = $dom->appendChild(new DOMElement('root'));
$element_ns = new DOMElement('pr:node1', 'thisvalue', 'http://xyz');
$element->appendChild($element_ns);
echo $dom->saveXML(); /* <?xml version="1.0" encoding="iso-8859-1"?>
<root><pr:node1 xmlns:pr="http://xyz">thisvalue</pr:node1></root> */

?>

Viz také

DOMDocument->createElement()
DOMDocument->createElementNS()

Předcházející | Nahoru | Další
DOMDocumentFragment->appendXML() | Domů | DOMElement->getAttribute()


DOMElement->setIdAttribute()

(No version information available, might be only in CVS)

DOMElement->setIdAttribute() — Declares the attribute specified by name to be of type ID

Popis

class DOMElement {
void setIdAttribute ( string $name, bool $isId )
}

Declares the attribute name to be of type ID.

Seznam parametrů

name

The name of the attribute.

isId

Set it to TRUE if you want name to be of type ID, FALSE otherwise.

Návratové hodnoty

Nevrací se žádná hodnota.

Errors/Exceptions

DOM_NO_MODIFICATION_ALLOWED_ERR

Raised if the node is readonly.

DOM_NOT_FOUND

Raised if name is not an attribute of this element.

Viz také

DOMDocument->getElementById()
DOMElement->setIdAttributeNode()
DOMElement->setIdAttributeNS()

Předcházející | Nahoru | Další
DOMElement->setAttributeNS() | Domů | DOMElement->setIdAttributeNode()


DOMElement->setIdAttributeNode()

(No version information available, might be only in CVS)

DOMElement->setIdAttributeNode() — Declares the attribute specified by node to be of type ID

Popis

class DOMElement {
void setIdAttributeNode ( DOMAttr $attr, bool $isId )
}

Declares the attribute specified by attr to be of type ID.

Seznam parametrů

attr

The attribute node.

isId

Set it to TRUE if you want name to be of type ID, FALSE otherwise.

Návratové hodnoty

Nevrací se žádná hodnota.

Errors/Exceptions

DOM_NO_MODIFICATION_ALLOWED_ERR

Raised if the node is readonly.

DOM_NOT_FOUND

Raised if name is not an attribute of this element.

Viz také

DOMDocument->getElementById()
DOMElement->setIdAttribute()
DOMElement->setIdAttributeNS()

Předcházející | Nahoru | Další
DOMElement->setIdAttribute() | Domů | DOMElement->setIdAttributeNS()


DOMElement->setIdAttributeNS()

(No version information available, might be only in CVS)

DOMElement->setIdAttributeNS() — Declares the attribute specified by local name and namespace URI to be of type ID

Popis

class DOMElement {
void setIdAttributeNS ( string $namespaceURI, string $localName, bool $isId )
}

Declares the attribute specified by localName and namespaceURI to be of type ID.

Seznam parametrů

namespaceURI

The namespace URI of the attribute.

localName

The local name of the attribute, as prefix:tagname.

isId

Set it to TRUE if you want name to be of type ID, FALSE otherwise.

Návratové hodnoty

Nevrací se žádná hodnota.

Errors/Exceptions

DOM_NO_MODIFICATION_ALLOWED_ERR

Raised if the node is readonly.

DOM_NOT_FOUND

Raised if name is not an attribute of this element.

Viz také

DOMDocument->getElementById()
DOMElement->setIdAttribute()
DOMElement->setIdAttributeNode()

Předcházející | Nahoru | Další
DOMElement->setIdAttributeNode() | Domů | DOMEntityReference->__construct()


DOMEntityReference->__construct()

(PHP 5)

DOMEntityReference->__construct() — Creates a new DOMEntityReference object

Popis

class DOMEntityReference {
__construct ( string $name )
}

Creates a new DOMEntityReference object.

Seznam parametrů

name

The name of the entity reference.

Příklady

Příklad 429. Creating a new DOMEntityReference

<?php

$dom = new DOMDocument('1.0', 'iso-8859-1');
$element = $dom->appendChild(new DOMElement('root'));
$entity = $element->appendChild(new DOMEntityReference('nbsp'));
echo $dom->saveXML(); /* <?xml version="1.0" encoding="iso-8859-1"?><root>&nbsp;</root> */

?>

Viz také

DOMDocument->createEntityReference()

Předcházející | Nahoru | Další
DOMElement->setIdAttributeNS() | Domů | DOMImplementation->__construct()


DOMImplementation->__construct()

(No version information available, might be only in CVS)

DOMImplementation->__construct() — Creates a new DOMImplementation object

Popis

class DOMImplementation {
__construct ( void )
}

Creates a new DOMImplementation object.

Předcházející | Nahoru | Další
DOMEntityReference->__construct() | Domů | DOMImplementation->createDocument()


DOMNode->isDefaultNamespace()

(No version information available, might be only in CVS)

DOMNode->isDefaultNamespace() — Checks if the specified namespaceURI is the default namespace or not

Popis

class DOMNode {
bool isDefaultNamespace ( string $namespaceURI )
}

Tells whether namespaceURI is the default namespace.

Seznam parametrů

namespaceURI

The namespace URI to look for.

Návratové hodnoty

Return TRUE if namespaceURI is the default namespace, FALSE otherwise.

Předcházející | Nahoru | Další
DOMNode->insertBefore() | Domů | DOMNode->isSameNode()


DOMProcessingInstruction->__construct()

(PHP 5)

DOMProcessingInstruction->__construct() — Creates a new DOMProcessingInstruction object

Popis

class DOMProcessingInstruction {
__construct ( string $name [, string $value] )
}

Creates a new DOMProcessingInstruction object. This object is read only. It may be appended to a document, but additional nodes may not be appended to this node until the node is associated with a document. To create a writeable node, use DOMDocument->createProcessingInstruction().

Seznam parametrů

name

The tag name of the processing instruction.

value

The value of the processing instruction.

Příklady

Příklad 435. Creating a new DOMProcessingInstruction

<?php

$dom = new DOMDocument('1.0', 'UTF-8');
$html = $dom->appendChild(new DOMElement('html'));
$body = $html->appendChild(new DOMElement('body'));
$pinode = new DOMProcessingInstruction('php', 'echo "Hello World"; ');
$body->appendChild($pinode);
echo $dom->saveXML();

?>

Výše uvedený příklad vypíše:

<?xml version="1.0" encoding="UTF-8" ?>
<html><body><?php echo "Hello World"; ?></body></html>

Viz také

DOMDocument->createProcessingInstruction()

Předcházející | Nahoru | Další
DOMNodelist->item() | Domů | DOMText->__construct()


DOMText->__construct()

(PHP 5)

DOMText->__construct() — Creates a new DOMText object

Popis

class DOMText {
__construct ( [string $value] )
}

Creates a new DOMText object.

Seznam parametrů

value

The value of the text node. If not supplied an empty text node is created.

Příklady

Příklad 436. Creating a new DOMText

<?php

$dom = new DOMDocument('1.0', 'iso-8859-1');
$element = $dom->appendChild(new DOMElement('root'));
$text = $element->appendChild(new DOMText('root value'));
echo $dom->saveXML(); /* <?xml version="1.0" encoding="iso-8859-1"?><root>root value</root> */

?>

Viz také

DOMDocument->createTextNode()

Předcházející | Nahoru | Další
DOMProcessingInstruction->__construct() | Domů | DOMText->isWhitespaceInElementContent()


DOMXPath->__construct()

(PHP 5)

DOMXPath->__construct() — Creates a new DOMXPath object

Popis

class DOMXPath {
__construct ( DOMDocument $doc )
}

Creates a new DOMXPath object.

Seznam parametrů

doc

The DOMDocument associated with the DOMXPath.

Předcházející | Nahoru | Další
DOMText->splitText() | Domů | DOMXPath->evaluate()


DOMXPath->evaluate()

(No version information available, might be only in CVS)

DOMXPath->evaluate() — Evaluates the given XPath expression and returns a typed result if possible.

Popis

class DOMXPath {
mixed evaluate ( string $expression [, DOMNode $contextnode] )
}

Executes the given XPath expression and returns a typed result if possible.

Seznam parametrů

expression

The XPath expression to execute.

contextnode

The optional contextnode can be specified for doing relative XPath queries. By default, the queries are relative to the root element.

Návratové hodnoty

Returns a typed result if possible or a DOMNodeList containing all nodes matching the given XPath expression.

Příklady

Příklad 437. Getting the count of all the english books

<?php

$doc = new DOMDocument;

$doc->load('book.xml');

$xpath = new DOMXPath($doc);

$tbody = $doc->getElementsByTagName('tbody')->item(0);

// our query is relative to the tbody node
$query = 'count(row/entry[. = "en"])';

$entries = $xpath->evaluate($query, $tbody);
echo "There are $entries english books\n";

?>

Výše uvedený příklad vypíše:

There are 2 english books

Viz také

DOMXPath->query()

Předcházející | Nahoru | Další
DOMXPath->__construct() | Domů | DOMXPath->query()


DomAttribute->set_value

(No version information available, might be only in CVS)

DomAttribute->set_value — Sets the value of an attribute

Popis

class DomAttribute {
bool set_value ( string $content )
}

This function sets the value of an attribute.

Seznam parametrů

content

The new value.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Migrating to PHP 5

Set the value property of DOMAttr.

Viz také

DomAttribute->value

Předcházející | Nahoru | Další
DomAttribute->name | Domů | DomAttribute->specified


DomElement->set_attribute_node()

(No version information available, might be only in CVS)

DomElement->set_attribute_node() — Adds new attribute

Popis

class DomElement {
DomNode set_attribute_node ( DomNode $attr )
}

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
DomElement->remove_attribute() | Domů | DomElement->set_attribute()


domxml_xslt_version

(PHP 4 >= 4.2.0)

domxml_xslt_version — Gets the XSLT library version

Popis

int domxml_xslt_version ( void )

Gets the XSLT library version.

Návratové hodnoty

Returns the version number of the XSLT library, as an integer.

Příklady

Příklad 470. domxml_xslt_version() Example

<?php

echo domxml_xslt_version();

?>

Výše uvedený příklad vypíše něco jako:

10112

Viz také

domxml_version()

Předcházející | Nahoru | Další
domxml_xslt_stylesheet | Domů | xpath_eval_expression


enchant_broker_describe

(PECL enchant:0.1-1.0.1)

enchant_broker_describe — Enumerates the Enchant providers

Popis

array enchant_broker_describe ( resource $broker )

Enumerates the Enchant providers and tells you some rudimentary information about them. The same info is provided through phpinfo().

Seznam parametrů

broker

Broker resource

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 473. List the backends provided by the given broker

<?php
$r = enchant_broker_init();
$bprovides = enchant_broker_describe($r);
echo "Current broker provides the following backend(s):\n";
print_r($bprovides);

?>

Výše uvedený příklad vypíše něco jako:

Current broker provides the following backend(s):
Array
(
    [0] => Array
        (
            [name] => aspell
            [desc] => Aspell Provider
            [file] => /usr/lib/enchant/libenchant_aspell.so
        )

    [1] => Array
        (
            [name] => hspell
            [desc] => Hspell Provider
            [file] => /usr/lib/enchant/libenchant_hspell.so
        )

    [2] => Array
        (
            [name] => ispell
            [desc] => Ispell Provider
            [file] => /usr/lib/enchant/libenchant_ispell.so
        )

    [3] => Array
        (
            [name] => myspell
            [desc] => Myspell Provider
            [file] => /usr/lib/enchant/libenchant_myspell.so
        )

)

Předcházející | Nahoru | Další
XXXIII. enchant Functions | Domů | enchant_broker_dict_exists


enchant_broker_dict_exists

(PECL enchant:0.1-1.0.1)

enchant_broker_dict_exists — Whether a dictionary exists or not. Using non-empty tag

Popis

bool enchant_broker_dict_exists ( resource $broker, string $tag )

Tells if a dictionary exists or not, using a non-empty tags

Seznam parametrů

broker

Broker resource

tag

non-empty tag in the LOCALE format, ex: us_US, ch_DE, etc.

Návratové hodnoty

Returns TRUE when the tag exist or FALSE when not.

Příklady

Příklad 474. A enchant_broker_dict_exists() example

<?php
$tag = 'en_US';
$r = enchant_broker_init();
if (enchant_broker_dict_exists($r,$tag)) {
    echo $tag . " dictionary found.\n";
}
?>

Viz také

enchant_broker_describe()

Předcházející | Nahoru | Další
enchant_broker_describe | Domů | enchant_broker_free_dict


enchant_broker_free

(PECL enchant:0.1-1.0.1)

enchant_broker_free — Free the broker resource and its dictionnaries

Popis

bool enchant_broker_free ( resource $broker )

Free a broker resource with all its dictionaries.

Seznam parametrů

broker

Broker resource

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

enchant_broker_init()

Předcházející | Nahoru | Další
enchant_broker_free_dict | Domů | enchant_broker_get_error


enchant_broker_free_dict

(PECL enchant:0.1-1.0.1)

enchant_broker_free_dict — Free a dictionary resource

Popis

bool enchant_broker_free_dict ( resource $dict )

Free a dictionary resource.

Seznam parametrů

dict

Dictionary resource.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

enchant_broker_request_dict()
enchant_broker_request_pwl_dict()

Předcházející | Nahoru | Další
enchant_broker_dict_exists | Domů | enchant_broker_free


enchant_broker_get_error

(PECL enchant:0.1-1.0.1)

enchant_broker_get_error — Returns the last error of the broker

Popis

string enchant_broker_get_error ( resource $broker )

Returns the last error which occurred in this broker.

Seznam parametrů

broker

Broker resource.

Návratové hodnoty

Return the msg string if an error was found or FALSE

Předcházející | Nahoru | Další
enchant_broker_free | Domů | enchant_broker_init


enchant_broker_init

(PECL enchant:0.1-1.0.1)

enchant_broker_init — create a new broker object capable of requesting

Popis

resource enchant_broker_init ( void )

Seznam parametrů

Návratové hodnoty

Returns a broker resource on success or FALSE.

Viz také

enchant_broker_free()

Předcházející | Nahoru | Další
enchant_broker_get_error | Domů | enchant_broker_list_dicts


enchant_broker_list_dicts

(PECL enchant:1.0.1)

enchant_broker_list_dicts — Returns a list of available dictionaries

Popis

mixed enchant_broker_list_dicts ( resource $broker )

Returns a list of available dictionaries with their details.

Seznam parametrů

broker

Broker resource

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 475. List all available dictionaries for one broker

<?php
$r = enchant_broker_init();
$dicts = enchant_broker_list_dicts($r);
print_r($dicts);
?>

Výše uvedený příklad vypíše něco jako:

Array
(
    [0] => Array
        (
            [lang_tag] => de
            [provider_name] => aspell
            [provider_desc] => Aspell Provider
            [provider_file] => /usr/lib/enchant/libenchant_aspell.so
        )

    [1] => Array
        (
            [lang_tag] => de_DE
            [provider_name] => aspell
            [provider_desc] => Aspell Provider
            [provider_file] => /usr/lib/enchant/libenchant_aspell.so
        )

    [3] => Array
        (
            [lang_tag] => en
            [provider_name] => aspell
            [provider_desc] => Aspell Provider
            [provider_file] => /usr/lib/enchant/libenchant_aspell.so
        )

    [4] => Array
        (
            [lang_tag] => en_GB
            [provider_name] => aspell
            [provider_desc] => Aspell Provider
            [provider_file] => /usr/lib/enchant/libenchant_aspell.so
        )

    [5] => Array
        (
            [lang_tag] => en_US
            [provider_name] => aspell
            [provider_desc] => Aspell Provider
            [provider_file] => /usr/lib/enchant/libenchant_aspell.so
        )

    [6] => Array
        (
            [lang_tag] => hi_IN
            [provider_name] => myspell
            [provider_desc] => Myspell Provider
            [provider_file] => /usr/lib/enchant/libenchant_myspell.so
        )

)

Viz také

enchant_broker_describe ()

Předcházející | Nahoru | Další
enchant_broker_init | Domů | enchant_broker_request_dict


enchant_broker_request_dict

(PECL enchant:0.1-1.0.1)

enchant_broker_request_dict — create a new dictionary using a tag

Popis

resource enchant_broker_request_dict ( resource $broker, string $tag )

create a new dictionary using tag, the non-empty language tag you wish to request a dictionary for ("en_US", "de_DE", ...)

Seznam parametrů

broker

Broker resource

tag

A tag describing the locale, for example en_US, de_DE

Návratové hodnoty

Returns a dictionary resource on success or FALSE on failure.

Příklady

Příklad 476. A enchant_broker_request_dict() example

Check if a dictionary exists using enchant_broker_dict_exists() and request it.

<?php
$tag = 'en_US';
$broker = enchant_broker_init();
if (enchant_broker_dict_exists($broker,$tag)) {
    $dict = enchant_broker_request_dict($r, $tag);
}
?>

Viz také

enchant_dict_describe()
enchant_broker_dict_exists()
enchant_broker_dict_free()

Předcházející | Nahoru | Další
enchant_broker_list_dicts | Domů | enchant_broker_request_pwl_dict


enchant_broker_request_pwl_dict

(PECL enchant:0.1-1.0.1)

enchant_broker_request_pwl_dict — creates a dictionary using a PWL file. A PWL file is personal word file one word per line.

Popis

resource enchant_broker_request_pwl_dict ( resource $broker, string $filename )

creates a dictionary using a PWL file. A PWL file is personal word file one word per line.

Seznam parametrů

broker

Broker resource

filename

Path to the PWL file.

Návratové hodnoty

Returns a dictionary resource on success or FALSE on failure.

Viz také

enchant_dict_describe()
enchant_broker_dict_exists()
enchant_broker_dict_free()

Předcházející | Nahoru | Další
enchant_broker_request_dict | Domů | enchant_broker_set_ordering


enchant_broker_set_ordering

(PECL enchant:0.1-1.0.1)

enchant_broker_set_ordering — Declares a preference of dictionaries to use for the language

Popis

bool enchant_broker_set_ordering ( resource $broker, string $tag, string $ordering )

Declares a preference of dictionaries to use for the language described/referred to by 'tag'. The ordering is a comma delimited list of provider names. As a special exception, the "*" tag can be used as a language tag to declare a default ordering for any language that does not explicitly declare an ordering.

Seznam parametrů

broker

Broker resource

tag

Language tag. The special "*" tag can be used as a language tag to declare a default ordering for any language that does not explicitly declare an ordering.

ordering

Comma delimited list of provider names

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
enchant_broker_request_pwl_dict | Domů | enchant_dict_add_to_personal


enchant_dict_add_to_personal

(PECL enchant:0.1-1.0.1)

enchant_dict_add_to_personal — add a word to personal word list

Popis

void enchant_dict_add_to_personal ( resource $dict, string $word )

Add a word to personal word list of the given dictionary.

Seznam parametrů

dict

Dictionary resource

word

The word to add

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

enchant_broker_request_pwl_dict()
enchant_broker_request_dict()

Předcházející | Nahoru | Další
enchant_broker_set_ordering | Domů | enchant_dict_add_to_session


enchant_dict_add_to_session

(PECL enchant:0.1-1.0.1)

enchant_dict_add_to_session — add 'word' to this spell-checking session

Popis

void enchant_dict_add_to_session ( resource $dict, string $word )

Add a word to the given dictionary. It will be added only for the active spell-checking session.

Seznam parametrů

dict

Dictionary resource

word

The word to add

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

enchant_broker_request_dict()

Předcházející | Nahoru | Další
enchant_dict_add_to_personal | Domů | enchant_dict_check


enchant_dict_check

(PECL enchant:0.1-1.0.1)

enchant_dict_check — Check whether a word is correctly spelled or not.

Popis

bool enchant_dict_check ( resource $dict, string $word )

If the word is correctly spelled return TRUE, otherwise return FALSE

Seznam parametrů

dict

Dictionary resource

word

The word to check

Návratové hodnoty

Returns TRUE if the word is spelled correctly, FALSE if not.

Předcházející | Nahoru | Další
enchant_dict_add_to_session | Domů | enchant_dict_describe


enchant_dict_describe

(PECL enchant:0.1-1.0.1)

enchant_dict_describe — Describes an individual dictionary

Popis

mixed enchant_dict_describe ( resource $dict )

Returns the details of the dictionary.

Seznam parametrů

dict

Dictinaray resource

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 477. A enchant_dict_describe() example

Check if a dictionary exists using enchant_broker_dict_exists() and show the detail of it.

<?php
$tag = 'en_US';
$broker = enchant_broker_init();
if (enchant_broker_dict_exists($broker,$tag)) {
    $dict = enchant_broker_request_dict($r, $tag);
    $dict_details = enchant_dict_describe($dict);
    print_r($dict_details);
}
?>

Výše uvedený příklad vypíše něco jako:

Array
(
    [lang] => en_US
    [name] => aspell
    [desc] => Aspell Provider
    [file] => /usr/lib/enchant/libenchant_aspell.so
)

Předcházející | Nahoru | Další
enchant_dict_check | Domů | enchant_dict_get_error


enchant_dict_get_error

(PECL enchant:0.1-1.0.1)

enchant_dict_get_error — Returns the last error of the current spelling-session

Popis

string enchant_dict_get_error ( resource $dict )

Returns the last error of the current spelling-session

Seznam parametrů

dict

Dictinaray resource

Návratové hodnoty

Returns the error message as string or FALSE if no error occurred.

Předcházející | Nahoru | Další
enchant_dict_describe | Domů | enchant_dict_is_in_session


enchant_dict_is_in_session

(PECL enchant:0.1-1.0.1)

enchant_dict_is_in_session — whether or not 'word' exists in this spelling-session

Popis

bool enchant_dict_is_in_session ( resource $dict, string $word )

Tells whether or not a word already exists in the current session.

Seznam parametrů

dict

Dictionary resource

word

The word to lookup

Návratové hodnoty

Returns TRUE if the word exists or FALSE

Viz také

enchant_dict_add_to_session()

Předcházející | Nahoru | Další
enchant_dict_get_error | Domů | enchant_dict_quick_check


enchant_dict_quick_check

(PECL enchant:0.2.0-1.0.1)

enchant_dict_quick_check — Check the word is correctly spelled and provide suggestions

Popis

bool enchant_dict_quick_check ( resource $dict, string $word [, array &$suggestions] )

If the word is correctly spelled return TRUE, otherwise return FALSE, if suggestions variable is provided, fill it with spelling alternatives.

Seznam parametrů

dict

Dictionary resource

word

The word to check

suggestions

If the word is not correctly spelled, this variable will contain an array of suggestions.

Návratové hodnoty

Returns TRUE if the word is correctly spelled or FALSE

Příklady

Příklad 478. A enchant_dict_quick_check() example

<?php
$tag = 'en_US';
$r = enchant_broker_init();

if (enchant_broker_dict_exists($r,$tag)) {
    $d = enchant_broker_request_dict($r, $tag);
    enchant_dict_quick_check($d, 'soong', $suggs);
    print_r($suggs);
}
?>

Výše uvedený příklad vypíše něco jako:

Array
(
    [0] => song
    [1] => snog
    [2] => soon
    [3] => Sang
    [4] => Sung
    [5] => sang
    [6] => sung
    [7] => sponge
    [8] => spongy
    [9] => snag
    [10] => snug
    [11] => sonic
    [12] => sing
    [13] => songs
    [14] => Son
    [15] => Sonja
    [16] => Synge
    [17] => son
    [18] => Sejong
    [19] => sarong
    [20] => sooner
    [21] => Sony
    [22] => sown
    [23] => scone
    [24] => song's
)

Viz také

enchant_dict_check()
enchant_dict_suggest()

Předcházející | Nahoru | Další
enchant_dict_is_in_session | Domů | enchant_dict_store_replacement


enchant_dict_store_replacement

(PECL enchant:0.1-1.0.1)

enchant_dict_store_replacement — add a correction for a word.

Popis

void enchant_dict_store_replacement ( resource $dict, string $mis, string $cor )

Add a correction for 'mis' using 'cor'. Notes that you replaced @mis with @cor, so it's possibly more likely that future occurrences of @mis will be replaced with @cor. So it might bump @cor up in the suggestion list.

Seznam parametrů

dict

Dictionary resource

mis

The work to fix

cor

The correct word

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
enchant_dict_quick_check | Domů | enchant_dict_suggest


enchant_dict_suggest

(PECL enchant:0.1-1.0.1)

enchant_dict_suggest — Will return a list of values if any of those pre-conditions are not met.

Popis

array enchant_dict_suggest ( resource $dict, string $word )

Seznam parametrů

dict

Dictionary resource

word

Word to use for the suggestions.

Návratové hodnoty

Will returns an array of suggestions if the word is bad spelled.

Příklady

Příklad 479. A enchant_dict_suggest() example

<?php
$tag = 'en_US';
$r = enchant_broker_init();
if (enchant_broker_dict_exists($r,$tag)) {
    $d = enchant_broker_request_dict($r, $tag);

    $spellerrors = enchant_dict_check($d, "soong");
    echo "found $spellerrors spell errors\n";
    if ($spellerrors) {
        $suggs = enchant_dict_suggest($d, "soong");
        echo "Suggestions for 'soong':";
        print_r($suggs);
    }
    enchant_broker_free_dict($d);
}
enchant_broker_free($r);
?>

Viz také

enchant_dict_check()
enchant_dict_quick_check()

Předcházející | Nahoru | Další
enchant_dict_store_replacement | Domů | XXXIV. Error Handling and Logging Functions


error_get_last

(PHP 5 >= 5.2.0)

error_get_last — Get the last occurred error

Popis

array error_get_last ( void )

Gets information about the last error that occured.

Návratové hodnoty

Returns an associative array describing the last error with keys "type", "message", "file" and "line". Returns NULL if there hasn't been an error yet.

Příklady

Příklad 483. An error_get_last() example

<?php
echo $a;
print_r(error_get_last());
?>

Výše uvedený příklad vypíše něco jako:

Array
(
    [type] => 8
    [message] => Undefined variable: a
    [file] => C:\WWW\index.php
    [line] => 2
)

Viz také

Error constants
Variable $php_errormsg
Directive display_errors

Předcházející | Nahoru | Další
debug_print_backtrace | Domů | error_log


expect_expectl

(PECL expect:0.1-0.2.2)

expect_expectl — Waits until the output from a process matches one of the patterns, a specified time period has passed, or an EOF is seen

Popis

int expect_expectl ( resource $expect, array $cases [, array &$match] )

Waits until the output from a process matches one of the patterns, a specified time period has passed, or an EOF is seen.

If match is provided, then it is filled with the result of search. The matched string can be found in match[0]. The match substrings (according to the parentheses) in the original pattern can be found in match[1], match[2], and so on, up to match[9] (the limitation of libexpect).

Seznam parametrů

expect

An Expect stream, previously opened with expect_popen().

cases

An array of expect cases. Each expect case is an indexed array, as described in the following table:

Tabulka 81. Expect Case Array

Index Key | Value Type | Description | Is Mandatory | Default Value
0 | string | pattern, that will be matched against the output from the stream | yes
1 | mixed | value, that will be returned by this function, if the pattern matches | yes
2 | integer | pattern type, one of: EXP_GLOB, EXP_EXACT or EXP_REGEXP | no | EXP_GLOB

Návratové hodnoty

Returns value associated with the pattern that was matched.

On failure this function returns: EXP_EOF, EXP_TIMEOUT or EXP_FULLBUFFER

ChangeLog (záznam změn)

Verze | Popis
0.2.1 | Prior to version 0.2.1, in match parameter a match string was returned, not an array of match substrings.

Příklady

Příklad 495. expect_expectl() example

<?php
// Copies file from remote host:
ini_set ("expect.timeout", 30);

$stream = fopen ("expect://scp user@remotehost:/var/log/messages /home/user/messages.txt", "r");

$cases = array (
  array (0 => "password:", 1 => PASSWORD),
  array (0 => "yes/no)?", 1 => YESNO)
);

while (true) {
 switch (expect_expectl ($stream, $cases))
 {
  case PASSWORD:
   fwrite ($stream, "password\n");
   break;

  case YESNO:
   fwrite ($stream, "yes\n");
   break;

  case EXP_TIMEOUT:
  case EXP_EOF:
   break 2;

  default:
   die ("Error has occurred!\n");
 }
}

fclose ($stream);
?>

Viz také

expect_popen()

Předcházející | Nahoru | Další
XXXVI. Expect Functions | Domů | expect_popen


expect_popen

(PECL expect:0.1-0.2.2)

expect_popen — Execute command via Bourne shell, and open the PTY stream to the process

Popis

resource expect_popen ( string $command )

Execute command via Bourne shell, and open the PTY stream to the process.

Seznam parametrů

command

Command to execute.

Návratové hodnoty

Returns an open PTY stream to the process'es stdio, stdout and stderr.

On failure this function returns FALSE.

Příklady

Příklad 496. expect_popen() example

<?php
// Login to the PHP.net CVS repository:
$stream = expect_popen ("cvs -d :pserver:anonymous@cvs.php.net:/repository login");
sleep (3);
fwrite ($stream, "phpfi\n");
fclose ($stream);
?>

Viz také

popen()

Předcházející | Nahoru | Další
expect_expectl | Domů | XXXVII. File Alteration Monitor Functions


fbsql_rows_fetched

(PHP 5 >= 5.1.0)

fbsql_rows_fetched — Get the number of rows affected by the last statement

Popis

int fbsql_rows_fetched ( resource $result )

Gets the number of rows affected by the last statement.

Seznam parametrů

result

A result identifier returned by fbsql_query() or fbsql_db_query().

Návratové hodnoty

Returns the number of rows, as an integer.

Předcházející | Nahoru | Další
fbsql_rollback | Domů | fbsql_select_db


fbsql_set_characterset

(PHP 5 >= 5.1.0)

fbsql_set_characterset — Change input/output character set

Popis

void fbsql_set_characterset ( resource $link_identifier, int $characterset [, int $in_out_both] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
fbsql_select_db | Domů | fbsql_set_lob_mode


fbsql_table_name

(PHP 4 >= 4.2.0, PHP 5)

fbsql_table_name — Get table name of field

Popis

string fbsql_table_name ( resource $result, int $index )

fbsql_table_name() gets the name of the current table in the given result set.

The fbsql_num_rows() function may be used to determine the number of tables in the result pointer.

Seznam parametrů

result

A result pointer returned by fbsql_list_tables().

index

Integer index for the current table.

Návratové hodnoty

Returns the name of the table, as a string.

Příklady

Příklad 571. fbsql_table_name() example

<?php
fbsql_connect("localhost", "_SYSTEM", "");
$result = fbsql_list_tables("wisconsin");
$i = 0;
while ($i < fbsql_num_rows($result)) {
    $tb_names[$i] = fbsql_table_name($result, $i);
    echo $tb_names[$i] . "<br />";
    $i++;
}
?>

Předcházející | Nahoru | Další
fbsql_stop_db | Domů | fbsql_tablename


filter_has_var

(PHP 5 >= 5.2.0, PECL filter:0.11.0)

filter_has_var — Checks if variable of specified type exists

Popis

bool filter_has_var ( int $type, string $variable_name )

Seznam parametrů

type

One of INPUT_GET, INPUT_POST, INPUT_COOKIE, INPUT_SERVER, INPUT_ENV.

variable_name

Name of a variable to check.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
XLII. Filter Functions | Domů | filter_id


filter_id

(PHP 5 >= 5.2.0, PECL filter:0.11.0)

filter_id — Returns the filter ID belonging to a named filter

Popis

int filter_id ( string $filtername )

Seznam parametrů

filtername

Name of a filter to get.

Návratové hodnoty

ID of a filter on success or NULL if filter doesn't exist.

Viz také

filter_list()

Předcházející | Nahoru | Další
filter_has_var | Domů | filter_input_array


filter_input

(PHP 5 >= 5.2.0, PECL filter:0.11.0)

filter_input — Gets variable from outside PHP and optionally filters it

Popis

mixed filter_input ( int $type, string $variable_name [, int $filter [, mixed $options]] )

Seznam parametrů

type

One of INPUT_GET, INPUT_POST, INPUT_COOKIE, INPUT_SERVER, INPUT_ENV, INPUT_SESSION (not implemented yet) and INPUT_REQUEST (not implemented yet).

variable_name

Name of a variable to get.

filter

Filter to apply. Defaults to FILTER_DEFAULT.

options

Associative array of options or bitwise disjunction of flags. If filter accepts options, flags can be provided in "flags" field of array.

Návratové hodnoty

Value of the requested variable on success, FALSE if the filter fails, or NULL if the variable_name variable is not set. If the flag FILTER_NULL_ON_FAILURE is used, it returns FALSE if the variable is not set and NULL if the filter fails.

Příklady

Příklad 532. A filter_input() example

<?php
$search_html = filter_input(INPUT_GET, 'search', FILTER_SANITIZE_SPECIAL_CHARS);
$search_url = filter_input(INPUT_GET, 'search', FILTER_SANITIZE_ENCODED);
echo "You have searched for $search_html.\n";
echo "<a href='?search=$search_url'>Search again.</a>";
?>

Výše uvedený příklad vypíše něco jako:

You have searched for Me &#38; son.
<a href='?search=Me%20%26%20son'>Search again.</a>

Viz také

filter_var()
filter_input_array()
filter_var_array()

Předcházející | Nahoru | Další
filter_input_array | Domů | filter_list


filter_input_array

(PHP 5 >= 5.2.0, PECL filter:0.11.0)

filter_input_array — Gets multiple variables from outside PHP and optionally filters them

Popis

mixed filter_input_array ( int $type [, mixed $definition] )

This function is useful for retrieving many values without repetitively calling filter_input().

Seznam parametrů

type

One of INPUT_GET, INPUT_POST, INPUT_COOKIE, INPUT_SERVER, INPUT_ENV, INPUT_SESSION, or INPUT_REQUEST.

definition

An array defining the arguments. A valid key is a string containing a variable name and a valid value is either a filter type, or an array optionally specifying the filter, flags and options. If the value is an array, valid keys are filter which specifies the filter type, flags which specifies any flags that apply to the filter, and options which specifies any options that apply to the filter. See the example below for a better understanding.

This parameter can be also an integer holding a filter constant. Then all values in the input array are filtered by this filter.

Návratové hodnoty

An array containing the values of the requested variables on success, or FALSE on failure. An array value will be FALSE if the filter fails, or NULL if the variable is not set. Or if the flag FILTER_NULL_ON_FAILURE is used, it returns FALSE if the variable is not set and NULL if the filter fails.

Příklady

Příklad 531. A filter_input_array() example

<?php
error_reporting(E_ALL | E_STRICT);
/* data actually came from POST
$_POST = array(
    'product_id'    => 'libgd<script>',
    'component'     => '10',
    'versions'      => '2.0.33',
    'testscalar'    => array('2', '23', '10', '12'),
    'testarray'     => '2',
);
*/

$args = array(
    'product_id'   => FILTER_SANITIZE_ENCODED,
    'component'    => array('filter'    => FILTER_VALIDATE_INT,
                            'flags'     => FILTER_REQUIRE_ARRAY,
                            'options'   => array('min_range' => 1, 'max_range' => 10)
                           ),
    'versions'     => FILTER_SANITIZE_ENCODED,
    'doesnotexist' => FILTER_VALIDATE_INT,
    'testscalar'   => array(
                            'filter' => FILTER_VALIDATE_INT,
                            'flags'  => FILTER_REQUIRE_SCALAR,
                           ),
    'testarray'    => array(
                            'filter' => FILTER_VALIDATE_INT,
                            'flags'  => FILTER_REQUIRE_ARRAY,
                           )

);

$myinputs = filter_input_array(INPUT_POST, $args);

var_dump($myinputs);
echo "\n";
?>

Výše uvedený příklad vypíše:

array(6) {
  ["product_id"]=>
  array(1) {
    [0]=>
    string(17) "libgd%3Cscript%3E"
  }
  ["component"]=>
  array(1) {
    [0]=>
    int(10)
  }
  ["versions"]=>
  array(1) {
    [0]=>
    string(6) "2.0.33"
  }
  ["doesnotexist"]=>
  NULL
  ["testscalar"]=>
  bool(false)
  ["testarray"]=>
  array(1) {
    [0]=>
    int(2)
  }
}

Viz také

filter_input()
filter_var_array()

Předcházející | Nahoru | Další
filter_id | Domů | filter_input


filter_list

(PHP 5 >= 5.2.0, PECL filter:0.11.0)

filter_list — Returns a list of all supported filters

Popis

array filter_list ( void )

Návratové hodnoty

Returns an array of names of all supported filters, empty array if there are no such filters. Indexes of this array are not filter IDs, they can be obtained with filter_id() from a name instead.

Příklady

Příklad 533. A filter_list() example

<?php
print_r(filter_list());
?>

Výše uvedený příklad vypíše něco jako:

Array
(
    [0] => int
    [1] => boolean
    [2] => float
    [3] => validate_regexp
    [4] => validate_url
    [5] => validate_email
    [6] => validate_ip
    [7] => string
    [8] => stripped
    [9] => encoded
    [10] => special_chars
    [11] => unsafe_raw
    [12] => email
    [13] => url
    [14] => number_int
    [15] => number_float
    [16] => magic_quotes
    [17] => callback
)

Předcházející | Nahoru | Další
filter_input | Domů | filter_var_array


filter_var

(PHP 5 >= 5.2.0, PECL filter:0.11.0)

filter_var — Filters a variable with a specified filter

Popis

mixed filter_var ( mixed $variable [, int $filter [, mixed $options]] )

Seznam parametrů

variable

Value to filter.

filter

ID of a filter to use. Defaults to FILTER_SANITIZE_STRING.

options

Associative array of options or bitwise disjunction of flags. If filter accepts options, flags can be provided in "flags" field of array. For the "callback" filter, callback type should be passed.

Návratové hodnoty

Returns the filtered data, or FALSE if the filter fails.

Příklady

Příklad 535. A filter_var() example

<?php
var_dump(filter_var('bob@example.com', FILTER_VALIDATE_EMAIL));
var_dump(filter_var('example.com', FILTER_VALIDATE_URL, FILTER_FLAG_SCHEME_REQUIRED));
?>

Výše uvedený příklad vypíše:

string(15) "bob@example.com"
bool(false)

Viz také

filter_var_array()
filter_input()
filter_input_array()
informace typu callback

Předcházející | Nahoru | Další
filter_var_array | Domů | XLIII. Firebird/InterBase Functions


filter_var_array

(PHP 5 >= 5.2.0, PECL filter:0.11.0)

filter_var_array — Gets multiple variables and optionally filters them

Popis

mixed filter_var_array ( array $data [, mixed $definition] )

This function is useful for retrieving many values without repetitively calling filter_var().

Seznam parametrů

data

An array with string keys containing the data to filter.

definition

An array defining the arguments. A valid key is a string containing a variable name and a valid value is either a filter type, or an array optionally specifying the filter, flags and options. If the value is an array, valid keys are filter which specifies the filter type, flags which specifies any flags that apply to the filter, and options which specifies any options that apply to the filter. See the example below for a better understanding.

This parameter can be also an integer holding a filter constant. Then all values in the input array are filtered by this filter.

Návratové hodnoty

An array containing the values of the requested variables on success, or FALSE on failure. An array value will be FALSE if the filter fails, or NULL if the variable is not set.

Příklady

Příklad 534. A filter_var_array() example

<?php
error_reporting(E_ALL | E_STRICT);
$data = array(
    'product_id'    => 'libgd<script>',
    'component'     => '10',
    'versions'      => '2.0.33',
    'testscalar'    => array('2', '23', '10', '12'),
    'testarray'     => '2',
);

$args = array(
    'product_id'   => FILTER_SANITIZE_ENCODED,
    'component'    => array('filter'    => FILTER_VALIDATE_INT,
                            'flags'     => FILTER_FORCE_ARRAY,
                            'options'   => array('min_range' => 1, 'max_range' => 10)
                           ),
    'versions'     => FILTER_SANITIZE_ENCODED,
    'doesnotexist' => FILTER_VALIDATE_INT,
    'testscalar'   => array(
                            'filter' => FILTER_VALIDATE_INT,
                            'flags'  => FILTER_REQUIRE_SCALAR,
                           ),
    'testarray'    => array(
                            'filter' => FILTER_VALIDATE_INT,
                            'flags'  => FILTER_FORCE_ARRAY,
                           )

);

$myinputs = filter_var_array($data, $args);

var_dump($myinputs);
echo "\n";
?>

Výše uvedený příklad vypíše:

array(6) {
  ["product_id"]=>
  array(1) {
    [0]=>
    string(17) "libgd%3Cscript%3E"
  }
  ["component"]=>
  array(1) {
    [0]=>
    int(10)
  }
  ["versions"]=>
  array(1) {
    [0]=>
    string(6) "2.0.33"
  }
  ["doesnotexist"]=>
  NULL
  ["testscalar"]=>
  bool(false)
  ["testarray"]=>
  array(1) {
    [0]=>
    int(2)
  }
}

Viz také

filter_input_array()
filter_var()
filter_input()

Předcházející | Nahoru | Další
filter_list | Domů | filter_var


finfo_buffer

(PECL fileinfo:0.1-1.0.4)

finfo_buffer — Return information about a string buffer

Popis

string finfo_buffer ( resource $finfo, string $string [, int $options [, resource $context]] )
class finfo {
string buffer ( string $string [, int $options [, resource $context]] )
}

This function is used to get information about binary data in a string.

Seznam parametrů

finfo

Fileinfo resource returned by finfo_open().

string

Content of a file to be checked.

options

One or disjunction of more Fileinfo constants.

context

Návratové hodnoty

Returns a textual description of the string argument, or FALSE if an error occurred.

Příklady

Příklad 506. A finfo_buffer() example

<?php
$finfo = new finfo(FILEINFO_MIME);
echo $finfo->buffer($_POST["script"]) . "\n";
?>

Výše uvedený příklad vypíše něco jako:

application/x-sh

Viz také

finfo_file()

Předcházející | Nahoru | Další
XXXIX. Fileinfo Functions | Domů | finfo_close


finfo_close

(PECL fileinfo:0.1-1.0.4)

finfo_close — Close fileinfo resource

Popis

bool finfo_close ( resource $finfo )
class finfo {
  __destruct();
}

This function closes the resource opened by finfo_open().

Seznam parametrů

finfo

Fileinfo resource returned by finfo_open().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
finfo_buffer | Domů | finfo_file


finfo_file

(PECL fileinfo:0.1-1.0.4)

finfo_file — Return information about a file

Popis

string finfo_file ( resource $finfo, string $file_name [, int $options [, resource $context]] )
class finfo {
string file ( string $file_name [, int $options [, resource $context]] )
}

This function is used to get information about a file.

Seznam parametrů

finfo

Fileinfo resource returned by finfo_open().

file_name

Name of a file to be checked.

options

One or disjunction of more Fileinfo constants.

context

For a description of contexts, refer to Streams.

Návratové hodnoty

Returns a textual description of the contents of the filename argument, or FALSE if an error occurred.

Příklady

Příklad 507. A finfo_file() example

<?php
$finfo = finfo_open(FILEINFO_MIME); // return mime type ala mimetype extension
foreach (glob("*") as $filename) {
    echo finfo_file($finfo, $filename) . "\n";
}
finfo_close($finfo);
?>

Výše uvedený příklad vypíše něco jako:

text/html
image/gif
application/vnd.ms-excel

Viz také

finfo_buffer()

Předcházející | Nahoru | Další
finfo_close | Domů | finfo_open


finfo_open

Předcházející XXXIX. Fileinfo Functions Další

finfo_open,

(PECL fileinfo:0.1-1.0.4)

finfo_open, finfo->__construct() — Create a new fileinfo resource

Popis

Procedural style

resource finfo_open ( [int $options [, string $arg]] )

Object oriented style (constructor):

class finfo {
__construct ( [int $options [, string $magic_file]] )
}

This function opens a magic database and returns its resource.

Seznam parametrů

options

One or disjunction of more Fileinfo constants.

magic_file

Name of a magic database file, usually something like /path/to/magic.mime. If not specified, the MAGIC environment variable is used. If this variable is not set either, /usr/share/misc/magic is used by default. A .mime and/or .mgc suffix is added if needed.

Návratové hodnoty

Returns a magic database resource on success or FALSE on failure.

Příklady

Příklad 508. Object oriented style

<?php
$finfo = new finfo(FILEINFO_MIME, "/usr/share/misc/magic"); // return mime type ala mimetype extension

if (!$finfo) {
    echo "Opening fileinfo database failed";
    exit();
}

/* get mime-type for a specific file */
$filename = "/usr/local/something.txt";
echo $finfo->file($filename);

/* close connection */
$finfo->close();
?>

Příklad 509. Procedural style

<?php
$finfo = finfo_open(FILEINFO_MIME, "/usr/share/misc/magic"); // return mime type ala mimetype extension

if (!$finfo) {
    echo "Opening fileinfo database failed";
    exit();
}

/* get mime-type for a specific file */
$filename = "/usr/local/something.txt";
echo finfo_file($finfo, $filename);

/* close connection */
finfo_close($finfo);
?>

Výše uvedený příklad vypíše:

text/plain

Viz také

finfo_close()

Předcházející | Nahoru | Další
finfo_file | Domů | finfo_set_flags


finfo_set_flags

(PECL fileinfo:0.1-1.0.4)

finfo_set_flags — Set libmagic configuration options

Popis

bool finfo_set_flags ( resource $finfo, int $options )
class finfo {
bool set_flags ( int $options )
}

This function sets various Fileinfo options. Options can be set also directly in finfo_open() or other Fileinfo functions.

Seznam parametrů

finfo

Fileinfo resource returned by finfo_open().

options

One or disjunction of more Fileinfo constants.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
finfo_open | Domů | XL. filePro funkce


geoip_country_code3_by_name

(PECL geoip:0.2.0-1.0.1)

geoip_country_code3_by_name — Get the three letter country code

Popis

string geoip_country_code3_by_name ( string $hostname )

The geoip_country_code3_by_name() function will return the three letter country code corresponding to a hostname or an IP address.

Seznam parametrů

hostname

The hostname or IP address whose location is to be looked-up.

Návratové hodnoty

Returns the three letter country code on success, or FALSE if the address cannot be found in the database.

Příklady

Příklad 616. A geoip_country_code3_by_name() example

This will print where the host example.com is located.

<?php
$country = geoip_country_code3_by_name('www.example.com');
if ($country) {
    echo 'This host is located in: ' . $country;
}
?>

Výše uvedený příklad vypíše:

This host is located in: USA

Viz také

geoip_country_code_by_name()
geoip_country_name_by_name()

Předcházející | Nahoru | Další
geoip_country_code_by_name | Domů | geoip_country_name_by_name


geoip_country_code_by_name

(PECL geoip:0.2.0-1.0.1)

geoip_country_code_by_name — Get the two letter country code

Popis

string geoip_country_code_by_name ( string $hostname )

The geoip_country_code_by_name() function will return the two letter country code corresponding to a hostname or an IP address.

Seznam parametrů

hostname

The hostname or IP address whose location is to be looked-up.

Návratové hodnoty

Returns the two letter ISO country code on success, or FALSE if the address cannot be found in the database.

Příklady

Příklad 615. A geoip_country_code_by_name() example

This will print where the host example.com is located.

<?php
$country = geoip_country_code_by_name('www.example.com');
if ($country) {
    echo 'This host is located in: ' . $country;
}
?>

Výše uvedený příklad vypíše:

This host is located in: US

Viz také

geoip_country_code3_by_name()
geoip_country_name_by_name()

Předcházející | Nahoru | Další
XLIX. GeoIP Functions | Domů | geoip_country_code3_by_name


geoip_country_name_by_name

(PECL geoip:0.2.0-1.0.1)

geoip_country_name_by_name — Get the full country name

Popis

string geoip_country_name_by_name ( string $hostname )

The geoip_country_name_by_name() function will return the full country name corresponding to a hostname or an IP address.

Seznam parametrů

hostname

The hostname or IP address whose location is to be looked-up.

Návratové hodnoty

Returns the country name on success, or FALSE if the address cannot be found in the database.

Příklady

Příklad 617. A geoip_country_name_by_name() example

This will print where the host example.com is located.

<?php
$country = geoip_country_name_by_name('www.example.com');
if ($country) {
    echo 'This host is located in: ' . $country;
}
?>

Výše uvedený příklad vypíše:

 This host is located in: United States

Viz také

geoip_country_code_by_name()
geoip_country_code3_by_name()

Předcházející | Nahoru | Další
geoip_country_code3_by_name | Domů | geoip_database_info


geoip_database_info

(PECL geoip:0.2.0-1.0.1)

geoip_database_info — Get GeoIP Database information

Popis

string geoip_database_info ( [int $database] )

The geoip_database_info() function returns the corresponding GeoIP Database version as it is defined inside the binary file.

If this function is called without arguments, it returns the version of the GeoIP Free Country Edition.

Seznam parametrů

database

The database type as an integer. You can use the various constants defined with this extension (ie: GEOIP_*_EDITION).

Návratové hodnoty

Returns the corresponding database version, or NULL on error.

Příklady

Příklad 618. A geoip_region_by_name() example

This will output the current database version string.

<?php
print geoip_database_info(GEOIP_COUNTRY_EDITION);
?>

Výše uvedený příklad vypíše:

GEO-106FREE 20060801 Build 1 Copyright (c) 2006 MaxMind LLC All Rights Reserved

Předcházející | Nahoru | Další
geoip_country_name_by_name | Domů | geoip_db_avail


geoip_db_avail

(PECL geoip:1.0.1)

geoip_db_avail — Determine if GeoIP Database is available

Popis

bool geoip_db_avail ( int $database )

The geoip_db_avail() function returns if the corresponding GeoIP Database is available and can be opened on disk.

It does not indicate if the file is a proper database, only if it is readable.

Seznam parametrů

database

The database type as an integer. You can use the various constants defined with this extension (ie: GEOIP_*_EDITION).

Návratové hodnoty

Returns TRUE is database exists, FALSE if not found, or NULL on error.

Příklady

Příklad 619. A geoip_db_avail() example

This will output the current database version string.

<?php

if (geoip_db_avail(GEOIP_COUNTRY_EDITION))
    print geoip_database_info(GEOIP_COUNTRY_EDITION);
?>

Výše uvedený příklad vypíše:

GEO-106FREE 20080801 Build 1 Copyright (c) 2006 MaxMind LLC All Rights Reserved

Předcházející | Nahoru | Další
geoip_database_info | Domů | geoip_db_filename


geoip_db_filename

(PECL geoip:1.0.1)

geoip_db_filename — Returns the filename of the corresponding GeoIP Database

Popis

string geoip_db_filename ( int $database )

The geoip_db_filename() function returns the filename of the corresponding GeoIP Database.

It does not indicate if the file exists or not on disk, only where the library is looking for the database.

Seznam parametrů

database

The database type as an integer. You can use the various constants defined with this extension (ie: GEOIP_*_EDITION).

Návratové hodnoty

Returns the filename of the corresponding database, or NULL on error.

Příklady

Příklad 620. A geoip_db_filename() example

This will output the filename of the corresponding database.

<?php

print geoip_db_filename(GEOIP_COUNTRY_EDITION);

?>

Výše uvedený příklad vypíše:

/usr/share/GeoIP/GeoIP.dat

Předcházející | Nahoru | Další
geoip_db_avail | Domů | geoip_db_get_all_info


geoip_db_get_all_info

(PECL geoip:1.0.1)

geoip_db_get_all_info — Returns detailed informations about all GeoIP database types

Popis

array geoip_db_get_all_info ( void )

The geoip_db_get_all_info() function will return detailed informations as a multi-dimensional array about all the GeoIP database types.

This function is available even if no databases are installed. It will simply list them as non-available.

The names of the different keys of the returning associative array are as follows:

  • "available" -- Boolean, indicate if DB is available (see geoip_db_avail())
  • "description" -- The database description
  • "filename" -- The database filename on disk (see geoip_db_filename())

Návratové hodnoty

Returns the associative array.

Příklady

Příklad 621. A geoip_db_get_all_info() example

This will print the array containing all the informations.

<?php
$infos = geoip_db_get_all_info();
if (is_array($infos)) {
    var_dump($infos);
}
?>

Výše uvedený příklad vypíše:

array(11) {
  [1]=>
  array(3) {
    ["available"]=>
    bool(true)
    ["description"]=>
    string(21) "GeoIP Country Edition"
    ["filename"]=>
    string(32) "/usr/share/GeoIP/GeoIP.dat"
  }

[ ... ]

  [11]=>
  array(3) {
    ["available"]=>
    bool(false)
    ["description"]=>
    string(25) "GeoIP Domain Name Edition"
    ["filename"]=>
    string(38) "/usr/share/GeoIP/GeoIPDomain.dat"
  }
}

Příklad 622. A geoip_db_get_all_info() example

You can use the various constants as keys to get only parts of the information.

<?php
$infos = geoip_db_get_all_info();
if ($infos[GEOIP_COUNTRY_EDITION]['available']) {
    echo $infos[GEOIP_COUNTRY_EDITION]['description'];
}
?>

Výše uvedený příklad vypíše:

GeoIP Country Edition

Předcházející | Nahoru | Další
geoip_db_filename | Domů | geoip_id_by_name


geoip_id_by_name

(PECL geoip:0.2.0-1.0.1)

geoip_id_by_name — Get the Internet connection speed

Popis

int geoip_id_by_name ( string $hostname )

The geoip_id_by_name() function will return the country and region corresponding to a hostname or an IP address.

The return value is numeric and can be compared to the following constants:

  • GEOIP_UNKNOWN_SPEED
  • GEOIP_DIALUP_SPEED
  • GEOIP_CABLEDSL_SPEED
  • GEOIP_CORPORATE_SPEED

Seznam parametrů

hostname

The hostname or IP address whose net speed is to be looked-up.

Návratové hodnoty

Returns the net speed.

Příklady

Příklad 623. A geoip_id_by_name() example

This will output the net speed of the host example.com.

<?php
$netspeed = geoip_id_by_name('www.example.com');

echo 'The connection type is ';

switch ($netspeed) {
    case GEOIP_DIALUP_SPEED:
        echo 'dial-up';
        break;
    case GEOIP_CABLEDSL_SPEED:
        echo 'cable or DSL';
        break;
    case GEOIP_CORPORATE_SPEED:
        echo 'corporate';
        break;
    case GEOIP_UNKNOWN_SPEED:
    default:
        echo 'unknown';
}
?>

Výše uvedený příklad vypíše:

The connection type is corporate

Předcházející | Nahoru | Další
geoip_db_get_all_info | Domů | geoip_isp_by_name


geoip_isp_by_name

(No version information available, might be only in CVS)

geoip_isp_by_name — Get the Internet Service Provider (ISP) name

Popis

string geoip_isp_by_name ( string $hostname )

The geoip_isp_by_name() function will return the name of the Internet Service Provider (ISP) that an IP is assigned to.

This function is currently only available to users who have bought a commercial GeoIP ISP Edition. A warning will be issued if the proper database cannot be located.

Seznam parametrů

hostname

The hostname or IP address.

Návratové hodnoty

Returns the ISP name on success, or FALSE if the address cannot be found in the database.

Příklady

Příklad 624. A geoip_isp_by_name() example

This will print the ISP name of host example.com.

<?php
$isp = geoip_isp_by_name('www.example.com');
if ($isp) {
    echo 'This host IP is from ISP: ' . $isp;
}
?>

Výše uvedený příklad vypíše:

This host IP is allocated to: ICANN c/o Internet Assigned Numbers Authority

Předcházející | Nahoru | Další
geoip_id_by_name | Domů | geoip_org_by_name


geoip_org_by_name

(PECL geoip:0.2.0-1.0.1)

geoip_org_by_name — Get the organization name

Popis

string geoip_org_by_name ( string $hostname )

The geoip_org_by_name() function will return the name of the organization that an IP is assigned to.

This function is currently only available to users who have bought a commercial GeoIP Organization, ISP or AS Edition. A warning will be issued if the proper database cannot be located.

Seznam parametrů

hostname

The hostname or IP address.

Návratové hodnoty

Returns the organization name on success, or FALSE if the address cannot be found in the database.

Příklady

Příklad 625. A geoip_org_by_name() example

This will print to whom the host example.com IP is allocated.

<?php
$org = geoip_country_code_by_name('www.example.com');
if ($org) {
    echo 'This host IP is allocated to: ' . $org;
}
?>

Výše uvedený příklad vypíše:

This host IP is allocated to: ICANN c/o Internet Assigned Numbers Authority

Předcházející | Nahoru | Další
geoip_isp_by_name | Domů | geoip_record_by_name


geoip_record_by_name

(PECL geoip:0.2.0-1.0.1)

geoip_record_by_name — Returns the detailed City information found in the GeoIP Database

Popis

array geoip_record_by_name ( string $hostname )

The geoip_record_by_name() function will return the record information corresponding to a hostname or an IP address.

This function is available for both GeoLite City Edition and commercial GeoIP City Edition. A warning will be issued if the proper database cannot be located.

The names of the different keys of the returning associative array are as follows:

  • "country_code" -- Two letter country code (see geoip_country_code_by_name())
  • "region" -- The region code (ex: CA for California)
  • "city" -- The city.
  • "postal_code" -- The Postal Code, FSA or Zip Code.
  • "latitude" -- The Latitude as signed double.
  • "longitude" -- The Longitude as signed double.
  • "dma_code"
  • "area_code" -- The PSTN area code (ex: 212)

Seznam parametrů

hostname

The hostname or IP address whose record is to be looked-up.

Návratové hodnoty

Returns the associative array on success, or FALSE if the address cannot be found in the database.

Příklady

Příklad 626. A geoip_record_by_name() example

This will print the array containing the record of host example.com.

<?php
$record = geoip_record_by_name('www.example.com');
if ($record) {
    print_r($record);
}
?>

Výše uvedený příklad vypíše:

Array
(
    [country_code] => US
    [region] => CA
    [city] => Marina Del Rey
    [postal_code] =>
    [latitude] => 33.9776992798
    [longitude] => -118.435096741
    [dma_code] => 803
    [area_code] => 310
)

Předcházející | Nahoru | Další
geoip_org_by_name | Domů | geoip_region_by_name


geoip_region_by_name

(PECL geoip:0.2.0-1.0.1)

geoip_region_by_name — Get the country code and region

Popis

array geoip_region_by_name ( string $hostname )

The geoip_region_by_name() function will return the country and region corresponding to a hostname or an IP address.

This function is currently only available to users who have bought a commercial GeoIP Region Edition. A warning will be issued if the proper database cannot be located.

The names of the different keys of the returning associative array are as follows:

  • "country_code" -- Two letter country code (see geoip_country_code_by_name())
  • "region" -- The region code (ex: CA for California)

Seznam parametrů

hostname

The hostname or IP address whose region is to be looked-up.

Návratové hodnoty

Returns the associative array on success, or FALSE if the address cannot be found in the database.

Příklady

Příklad 627. A geoip_region_by_name() example

This will print the array containing the country code and region of the host example.com.

<?php
$region = geoip_region_by_name('www.example.com');
if ($region) {
    print_r($region);
}
?>

Výše uvedený příklad vypíše:

Array
(
    [country_code] => US
    [region] => CA
)

Předcházející | Nahoru | Další
geoip_record_by_name | Domů | L. Gettext


gmp_nextprime

(PHP 5 >= 5.2.0)

gmp_nextprime — Find next prime number

Popis

resource gmp_nextprime ( int $a )

Find next prime number

Seznam parametrů

a

It can be either a GMP number resource, or a numeric string given that it is possible to convert the latter to a number.

Návratové hodnoty

Return the next prime number greater than a, as a GMP number.

Příklady

Příklad 653. gmp_nextprime() example

<?php
$prime1 = gmp_nextprime(10); // next prime number greater than 10
$prime2 = gmp_nextprime(-1000); // next prime number greater than -1000

echo gmp_strval($prime1) . "\n";
echo gmp_strval($prime2) . "\n";
?>

Výše uvedený příklad vypíše:

11
-997

Poznámky

Poznámka: This function uses a probabilistic algorithm to identify primes and chances to get a composite number are extremely small.

Předcházející | Nahoru | Další
gmp_neg | Domů | gmp_or


gmp_testbit

(No version information available, might be only in CVS)

gmp_testbit — Tests if a bit is set

Popis

bool gmp_testbit ( resource $a, int $index )

Tests if the specified bit is set.

Seznam parametrů

a

It can be either a GMP number resource, or a numeric string given that it is possible to convert the latter to a number.

index

The bit to test

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Errors/Exceptions

E_WARNING is issued when index is less than zero.

Příklady

Příklad 669. gmp_testbit() example

<?php
$n = gmp_init("1000000");
var_dump(gmp_testbit($n, 1));
gmp_setbit($n, 1);
var_dump(gmp_testbit($n, 1));
?>

Výše uvedený příklad vypíše:

bool(false)
bool(true)

Viz také

gmp_setbit()
gmp_clrbit()

Předcházející | Nahoru | Další
gmp_sub | Domů | gmp_xor


gnupg_adddecryptkey

(PECL gnupg:0.5-1.3.1)

gnupg_adddecryptkey — Add a key for decryption

Popis

bool gnupg_adddecryptkey ( resource $identifier, string $fingerprint, string $passphrase )

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 673. Procedural gnupg_adddecryptkey() example

<?php
$res = gnupg_init();
gnupg_adddecryptkey($res,"8660281B6051D071D94B5B230549F9DC851566DC","test");
?>

Příklad 674. OO gnupg_adddecryptkey() example

<?php
$gpg = new gnupg();
$gpg -> adddecryptkey("8660281B6051D071D94B5B230549F9DC851566DC","test");
?>

Předcházející | Nahoru | Další
LII. gnupg Funkce | Domů | gnupg_addencryptkey


gnupg_addencryptkey

(PECL gnupg:0.5-1.3.1)

gnupg_addencryptkey — Add a key for encryption

Popis

bool gnupg_addencryptkey ( resource $identifier, string $fingerprint )

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 675. Procedural gnupg_addencryptkey() example

<?php
$res = gnupg_init();
gnupg_addencryptkey($res,"8660281B6051D071D94B5B230549F9DC851566DC");
?>

Příklad 676. OO gnupg_addencryptkey() example

<?php
$gpg = new gnupg();
$gpg -> addencryptkey("8660281B6051D071D94B5B230549F9DC851566DC");
?>

Předcházející | Nahoru | Další
gnupg_adddecryptkey | Domů | gnupg_addsignkey


gnupg_addsignkey

(PECL gnupg:0.5-1.3.1)

gnupg_addsignkey — Add a key for signing

Popis

bool gnupg_addsignkey ( resource $identifier, string $fingerprint [, string $passphrase] )

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 677. Procedural gnupg_addsignkey() example

<?php
$res = gnupg_init();
gnupg_addsignkey($res,"8660281B6051D071D94B5B230549F9DC851566DC","test");
?>

Příklad 678. OO gnupg_addsignkey() example

<?php
$gpg = new gnupg();
$gpg -> addsignkey("8660281B6051D071D94B5B230549F9DC851566DC","test");
?>

Předcházející | Nahoru | Další
gnupg_addencryptkey | Domů | gnupg_cleardecryptkeys


gnupg_cleardecryptkeys

(No version information available, might be only in CVS)

gnupg_cleardecryptkeys — Removes all keys which were set for decryption before

Popis

bool gnupg_cleardecryptkeys ( resource $identifier )

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 679. Procedural gnupg_cleardecryptkeys() example

<?php
$res = gnupg_init();
gnupg_cleardecryptkeys($res);
?>

Příklad 680. OO gnupg_cleardecryptkeys() example

<?php
$gpg = new gnupg();
$gpg -> cleardecryptkeys();
?>

Předcházející | Nahoru | Další
gnupg_addsignkey | Domů | gnupg_clearencryptkeys


gnupg_clearencryptkeys

(PECL gnupg:0.5-1.3.1)

gnupg_clearencryptkeys — Removes all keys which were set for encryption before

Popis

bool gnupg_clearencryptkeys ( resource $identifier )

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 681. Procedural gnupg_clearencryptkeys() example

<?php
$res = gnupg_init();
gnupg_clearencryptkeys($res);
?>

Příklad 682. OO gnupg_clearencryptkeys() example

<?php
$gpg = new gnupg();
$gpg -> clearencryptkeys();
?>

Předcházející | Nahoru | Další
gnupg_cleardecryptkeys | Domů | gnupg_clearsignkeys


gnupg_clearsignkeys

(No version information available, might be only in CVS)

gnupg_clearsignkeys — Removes all keys which were set for signing before

Popis

bool gnupg_clearsignkeys ( resource $identifier )

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 683. Procedural gnupg_clearsignkeys() example

<?php
$res = gnupg_init();
gnupg_clearsignkeys($res);
?>

Příklad 684. OO gnupg_clearsignkeys() example

<?php
$gpg = new gnupg();
$gpg -> clearsignkeys();
?>

Předcházející | Nahoru | Další
gnupg_clearencryptkeys | Domů | gnupg_decrypt


gnupg_decrypt

(PECL gnupg:0.1-1.3.1)

gnupg_decrypt — Decrypts a given text

Popis

string gnupg_decrypt ( resource $identifier, string $text )

Decrypts the given text with the keys, which were set with gnupg_adddecryptkey before.

Návratové hodnoty

On success, this function returns the decrypted text. On failure, this function returns FALSE.

Příklady

Příklad 685. Procedural gnupg_decrypt() example

<?php
$res = gnupg_init();
gnupg_adddecryptkey($res,"8660281B6051D071D94B5B230549F9DC851566DC","test");
$plain = gnupg_decrypt($res,$encrypted_text);
echo $plain;
?>

Příklad 686. OO gnupg_encrypt() example

<?php
$gpg = new gnupg();
$gpg -> adddecryptkey("8660281B6051D071D94B5B230549F9DC851566DC","test");
$plain = $gpg -> decrypt($encrypted_text);
echo $plain;
?>

Předcházející | Nahoru | Další
gnupg_clearsignkeys | Domů | gnupg_decryptverify


gnupg_decryptverify

(PECL gnupg:0.2-1.3.1)

gnupg_decryptverify — Decrypts and verifies a given text

Popis

array gnupg_decryptverify ( resource $identifier, string $text, string &$plaintext )

Decrypts and verifies a given text and returns information about the signature. The parameter plaintext gets filled with the decrypted text.

Návratové hodnoty

On success, this function returns information about the signature and fills the plaintext parameter with the decrypted text. On failure, this function returns FALSE.

Příklady

Příklad 687. Procedural gnupg_decryptverify() example

<?php
$plaintext = "";
$res = gnupg_init();
gnupg_adddecryptkey($res,"8660281B6051D071D94B5B230549F9DC851566DC","test");
$info = gnupg_decryptverify($res,$text,$plaintext);
print_r($info);
?>

Příklad 688. OO gnupg_decryptverify() example

<?php
$plaintext = "";
$gpg = new gnupg();
$gpg -> adddecryptkey("8660281B6051D071D94B5B230549F9DC851566DC","test");
$info = $gpg -> decryptverify($text,$plaintext);
print_r($info);
?>

Předcházející | Nahoru | Další
gnupg_decrypt | Domů | gnupg_encrypt


gnupg_encrypt

(PECL gnupg:0.1-1.3.1)

gnupg_encrypt — Encrypts a given text

Popis

string gnupg_encrypt ( resource $identifier, string $plaintext )

Encrypts the given plaintext with the keys, which were set with gnupg_addencryptkey before and returns the encrypted text.

Návratové hodnoty

On success, this function returns the encrypted text. On failure, this function returns FALSE.

Příklady

Příklad 689. Procedural gnupg_encrypt() example

<?php
$res = gnupg_init();
gnupg_addencryptkey($res,"8660281B6051D071D94B5B230549F9DC851566DC");
$enc = gnupg_encrypt($res, "just a test");
echo $enc;
?>

Příklad 690. OO gnupg_encrypt() example

<?php
$gpg = new gnupg();
$gpg -> addencryptkey("8660281B6051D071D94B5B230549F9DC851566DC");
$enc = $gpg -> encrypt("just a test");
echo $enc;
?>

Předcházející | Nahoru | Další
gnupg_decryptverify | Domů | gnupg_encryptsign


gnupg_encryptsign

(No version information available, might be only in CVS)

gnupg_encryptsign — Encrypts and signs a given text

Popis

string gnupg_encryptsign ( resource $identifier, string $plaintext )

Encrypts and signs the given plaintext with the keys, which were set with gnupg_addsignkey and gnupg_addencryptkey before and returns the encrypted and signed text.

Návratové hodnoty

On success, this function returns the encrypted and signed text. On failure, this function returns FALSE.

Příklady

Příklad 691. Procedural gnupg_encryptsign() example

<?php
$res = gnupg_init();
gnupg_addencryptkey($res,"8660281B6051D071D94B5B230549F9DC851566DC");
gnupg_addsignkey($res,"8660281B6051D071D94B5B230549F9DC851566DC","test");
$enc = gnupg_encryptsign($res, "just a test");
echo $enc;
?>

Příklad 692. OO gnupg_encryptsign() example

<?php
$gpg = new gnupg();
$gpg -> addencryptkey("8660281B6051D071D94B5B230549F9DC851566DC");
$gpg -> addsignkey("8660281B6051D071D94B5B230549F9DC851566DC","test");
$enc = $gpg -> encryptsign("just a test");
echo $enc;
?>

Předcházející | Nahoru | Další
gnupg_encrypt | Domů | gnupg_export


gnupg_export

(PECL gnupg:0.1-1.3.1)

gnupg_export — Exports a key

Popis

string gnupg_export ( resource $identifier, string $fingerprint )

Exports the key fingerprint.

Návratové hodnoty

On success, this function returns the keydata. On failure, this function returns FALSE.

Příklady

Příklad 693. Procedural gnupg_export() example

<?php
$res = gnupg_init();
$export = gnupg_export($res,"8660281B6051D071D94B5B230549F9DC851566DC");
echo $export;
?>

Příklad 694. OO gnupg_export() example

<?php
$gpg = new gnupg();
$export = $gpg -> export("8660281B6051D071D94B5B230549F9DC851566DC");
?>

Předcházející | Nahoru | Další
gnupg_encryptsign | Domů | gnupg_geterror


gnupg_geterror

(PECL gnupg:0.1-1.3.1)

gnupg_geterror — Returns the errortext, if a function fails

Popis

string gnupg_geterror ( resource $identifier )

Návratové hodnoty

Returns an errortext, if an error has occurred, otherwise FALSE.

Příklady

Příklad 695. Procedural gnupg_geterror() example

<?php
$res = gnupg_init();
echo gnupg_geterror($res);
?>

Příklad 696. OO gnupg_geterror() example

<?php
$gpg = new gnupg();
echo $gpg -> geterror();
?>

Předcházející | Nahoru | Další
gnupg_export | Domů | gnupg_getprotocol


gnupg_getprotocol

(PECL gnupg:0.1-1.3.1)

gnupg_getprotocol — Returns the currently active protocol for all operations

Popis

int gnupg_getprotocol ( resource $identifier )

Návratové hodnoty

Returns the currently active protocol, which can be one of GNUPG_PROTOCOL_OpenPGP or GNUPG_PROTOCOL_CMS.

Příklady

Příklad 697. Procedural gnupg_getprotocol() example

<?php
$res = gnupg_init();
echo gnupg_getprotocol($res);
?>

Příklad 698. OO gnupg_getprotocol() example

<?php
$gpg = new gnupg();
echo $gpg -> getprotocol();
?>

Předcházející | Nahoru | Další
gnupg_geterror | Domů | gnupg_import


gnupg_import

(PECL gnupg:0.3-1.3.1)

gnupg_import — Imports a key

Popis

array gnupg_import ( resource $identifier, string $keydata )

Imports the key keydata and returns an array with information about the importprocess.

Návratové hodnoty

On success, this function returns and info-array about the importprocess. On failure, this function returns FALSE.

Příklady

Příklad 699. Procedural gnupg_import() example

<?php
$res = gnupg_init();
$info = gnupg_import($res,$keydata);
print_r($info);
?>

Příklad 700. OO gnupg_import() example

<?php
$gpg = new gnupg();
$info = $gpg -> import($keydata);
print_r($info);
?>

Předcházející | Nahoru | Další
gnupg_getprotocol | Domů | gnupg_keyinfo


gnupg_keyinfo

(PECL gnupg:0.1-1.3.1)

gnupg_keyinfo — Returns an array with information about all keys that matches the given pattern

Popis

array gnupg_keyinfo ( resource $identifier, string $pattern )

Návratové hodnoty

Returns an array with information about all keys that matches the given pattern or FALSE, if an error has occurred.

Příklady

Příklad 701. Procedural gnupg_keyinfo() example

<?php
$res = gnupg_init();
$info = gnupg_keyinfo($res, 'test');
print_r($info);
?>

Příklad 702. OO gnupg_keyinfo() example

<?php
$gpg = new gnupg();
$info = $gpg -> keyinfo("test");
print_r($info);
?>

Předcházející | Nahoru | Další
gnupg_import | Domů | gnupg_setarmor


gnupg_setarmor

(PECL gnupg:0.1-1.3.1)

gnupg_setarmor — Toggle armored output

Popis

bool gnupg_setarmor ( resource $identifier, int $armor )

Pass a non-zero integer-value to this function to enable armored-output (default). Pass 0 to disable armored output.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 703. Procedural gnupg_setarmor() example

<?php
$res = gnupg_init();
gnupg_setarmor($res,1); // enable armored output;
gnupg_setarmor($res,0); // disable armored output;
?>

Příklad 704. OO gnupg_setarmor() example

<?php
$gpg = new gnupg();
$gpg -> setarmor(1); // enable armored output;
$gpg -> setarmor(0); // disable armored output;
?>

Předcházející | Nahoru | Další
gnupg_keyinfo | Domů | gnupg_seterrormode


gnupg_seterrormode

(PECL gnupg:0.6-1.3.1)

gnupg_seterrormode — Sets the mode for error_reporting

Popis

void gnupg_seterrormode ( resource $identifier, int $errormode )

errormode takes a constant indicating what type of error_reporting should be used. The possible values are GNUPG_ERROR_WARNING, GNUPG_ERROR_EXCEPTION and GNUPG_ERROR_SILENT. By default GNUPG_ERROR_SILENT is used.

Návratové hodnoty

Nevrací se žádná hodnota.

Příklady

Příklad 705. Procedural gnupg_seterrormode() example

<?php
$res = gnupg_init();
gnupg_seterrormode($res,GNUPG_ERROR_WARNING); // raise a PHP-Warning in case of an error
?>

Příklad 706. OO gnupg_seterrormode() example

<?php
$gpg = new gnupg();
$gpg -> seterrormode(gnupg::ERROR_EXCEPTION); // throw an exception in case of an error
?>

Předcházející | Nahoru | Další
gnupg_setarmor | Domů | gnupg_setsignmode


gnupg_setsignmode

(PECL gnupg:0.1-1.3.1)

gnupg_setsignmode — Sets the mode for signing

Popis

bool gnupg_setsignmode ( resource $identifier, int $signmode )

signmode takes a constant indicating what type of signature should be produced. The possible values are GNUPG_SIG_MODE_NORMAL, GNUPG_SIG_MODE_DETACH and GNUPG_SIG_MODE_CLEAR. By default GNUPG_SIG_MODE_CLEAR is used.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 707. Procedural gnupg_setsignmode() example

<?php
$res = gnupg_init();
gnupg_setsignmode($res,GNUPG_SIG_MODE_DETACH); // produce a detached signature
?>

Příklad 708. OO gnupg_setsignmode() example

<?php
$gpg = new gnupg();
$gpg -> setsignmode(gnupg::SIG_MODE_DETACH); // produce a detached signature
?>

Předcházející | Nahoru | Další
gnupg_seterrormode | Domů | gnupg_sign


gnupg_sign

(PECL gnupg:0.1-1.3.1)

gnupg_sign — Signs a given text

Popis

string gnupg_sign ( resource $identifier, string $plaintext )

Signs the given plaintext with the keys, which were set with gnupg_addsignkey before and returns the signed text or the signature, depending on what was set with gnupg_setsignmode.

Návratové hodnoty

On success, this function returns the signed text or the signature. On failure, this function returns FALSE.

Příklady

Příklad 709. Procedural gnupg_sign() example

<?php
$res = gnupg_init();
gnupg_addsignkey($res,"8660281B6051D071D94B5B230549F9DC851566DC","test");
$signed = gnupg_sign($res, "just a test");
echo $signed;
?>

Příklad 710. OO gnupg_sign() example

<?php
$gpg = new gnupg();
$gpg -> setsignkey("8660281B6051D071D94B5B230549F9DC851566DC","test");
$signed = $gpg -> sign("just a test");
echo $signed;
?>

Předcházející | Nahoru | Další
gnupg_setsignmode | Domů | gnupg_verify


gnupg_verify

(PECL gnupg:0.1-1.3.1)

gnupg_verify — Verifies a signed text

Popis

array gnupg_verify ( resource $identifier, string $signed_text, string $signature [, string &$plaintext] )

Verifies the given signed_text and returns information about the signature. To verify a clearsigned text, set signature to FALSE. If the optional parameter plaintext is passed, it is filled with the plaintext.

Návratové hodnoty

On success, this function returns informations about the signature. On failure, this function returns FALSE.

Příklady

Příklad 711. Procedural gnupg_verify() example

<?php
$plaintext = "";
$res = gnupg_init();
// clearsigned
$info = gnupg_verify($res,$signed_text,false,$plaintext);
print_r($info);
// detached signature
$info = gnupg_verify($res,$signed_text,$signature);
print_r($info);
?>

Příklad 712. OO gnupg_verify() example

<?php
$plaintext = "";
$gpg = new gnupg();
// clearsigned
$info = $gpg -> verify($signed_text,false,$plaintext);
print_r($info);
// detached signature
$info = $gpg -> verify($signed_text,$signature);
print_r($info);
?>

Předcházející | Nahoru | Další
gnupg_sign | Domů | LIII. Net_Gopher


gopher_parsedir

(PECL net_gopher:0.1-1.0.0)

gopher_parsedir — Translate a gopher formatted directory entry into an associative array.

Popis

array gopher_parsedir ( string $dirent )

gopher_parsedir() parses a gopher formatted directory entry into an associative array.

While gopher returns text/plain documents for actual document requests. A request to a directory (such as /) will return specially encoded series of lines with each line being one directory entry or information line.

Seznam parametrů

dirent

The directory entry.

Návratové hodnoty

Returns an associative array whose components are:

  • type - One of the GOPHER_XXX constants.
  • title - The name of the resource.
  • path - The path of the resource.
  • host - The domain name of the host that has this document (or directory).
  • port - The port at which to connect on host.

Upon failure, the additional data entry of the returned array will hold the parsed line.

Příklady

Příklad 713. Hypothetical output from gopher://gopher.example.com/

0All about my gopher site.               /allabout.txt               gopher.example.com    70
9A picture of my cat.                    /pics/cat.png               gopher.example.com    70
1A collection of my writings.            /stories                    gopher.example.com    70
hThe HTTP version of this site.          URL:http://www.example.com  gopher.example.com    70
1Mirror of this site in Spain.           /                           gopher.ejemplo.co.es  70
iWelcome to my gopher site.                                          error.host            1
iPlease select one of the options above                              error.host            1
iSend complaints to /dev/null                                        error.host            1
iLong live gopher!                                                   error.host            1

In the example above, the root directory at gopher.example.com knows about one DOCUMENT identified by 0 located at gopher://gopher.example.com:70/allabout.txt. It also knows about two other directory (which have their own listing files) at gopher://gopher.exmaple.com:70/stories and at gopher://gopher.ejemplo.co.es:70/. In addition there is a binary file, a link to an HTTP url, and several informative lines.

By passing each line of the directory listing into gopher_parsedir(), an associative array is formed containing a parsed out version of the data.

Příklad 714. Using gopher_parsedir()

<?php
$directory = file("gopher://gopher.example.com");

foreach($directory as $dirent) {
    print_r(gopher_parsedir($dirent));
}
?>

Výše uvedený příklad vypíše:

Array (
  [type] => 0
  [title] => All about my gopher site.
  [path] => /allabout.txt
  [host] => gopher.example.com
  [port] => 70
)
Array (
  [type] => 9
  [title] => A picture of my cat.
  [path] => /pics/cat.png
  [host] => gopher.example.com
  [port] => 70
)
Array (
  [type] => 1
  [title] => A collection of my writings.
  [path] => /stories
  [host] => gopher.example.com
  [port] => 70
)
Array (
  [type] => 254
  [title] => The HTTP version of this site.
  [path] => URL:http://www.example.com
  [host] => gopher.example.com
  [port] => 70
)
Array (
  [type] => 1
  [title] => Mirror of this site in Spain.
  [path] => /
  [host] => gopher.ejemplo.co.es
  [port] => 70
)
Array (
  [type] => 255
  [title] => Welcome to my gopher site.
  [path] =>
  [host] => error.host
  [port] => 1
)
Array (
  [type] => 255
  [title] => Please select one of the options above.
  [path] =>
  [host] => error.host
  [port] => 1
)
Array (
  [type] => 255
  [title] => Send complaints to /dev/null
  [path] =>
  [host] => error.host
  [port] => 1
)
Array (
  [type] => 255
  [title] => Long live gopher!
  [path] =>
  [host] => error.host
  [port] => 1
)

Předcházející | Nahoru | Další
LIII. Net_Gopher | Domů | LIV. Haru PDF Functions


gzdecode

(No version information available, might be only in CVS)

gzdecode — Decodes a gzip compressed string

Popis

string gzdecode ( string $data [, int $length] )

This function returns a decoded version of the input data.

Seznam parametrů

data

The data to decode, encoded by gzencode().

length

The maximum length of data to decode.

Návratové hodnoty

The decoded string, or FALSE if an error occurred.

Viz také

gzencode()

Předcházející | Nahoru | Další
gzcompress | Domů | gzdeflate


__halt_compiler

(No version information available, might be only in CVS)

__halt_compiler — Halts the compiler execution

Popis

void __halt_compiler ( void )

Halts the execution of the compiler. This can be useful to embed data in PHP scripts, like the installation files.

Byte position of the data start can be determined by the __COMPILER_HALT_OFFSET__ constant which is defined only if there is a __halt_compiler() presented in the file.

Návratové hodnoty

Nevrací se žádná hodnota.

Příklady

Příklad 1193. A __halt_compiler() example

<?php

// open this file
$fp = fopen(__FILE__, 'r');

// seek file pointer to data
fseek($fp, __COMPILER_HALT_OFFSET__);

// and output it
var_dump(stream_get_contents($fp));

// the end of the script execution
__halt_compiler();the installation data (eg. tar, gz, PHP, etc.)

Poznámky

Poznámka: __halt_compiler() can only be used from the outermost scope.

Předcházející | Nahoru | Další
get_browser | Domů | highlight_file


HaruAnnotation::setBorderStyle

(PECL haru:0.0.1)

HaruAnnotation::setBorderStyle — Set the border style of the annotation

Popis

bool HaruAnnotation::setBorderStyle ( float $width, int $dash_on, int $dash_off )

Defines the style of the border of the annotation. This function may be used with link annotations only.

Seznam parametrů

width

The width of the border line.

dash_on

The dash style.

dash_off

The dash style.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruDestination | Domů | HaruAnnotation::setHighlightMode


HaruAnnotation::setHighlightMode

(PECL haru:0.0.1)

HaruAnnotation::setHighlightMode — Set the highlighting mode of the annotation

Popis

bool HaruAnnotation::setHighlightMode ( int $mode )

Defines the appearance of the annotation when clicked. This function may be used with link annotations only.

Seznam parametrů

mode

The highlighting mode of the annotation. Can take only these values:

HaruAnnotation::NO_HIGHLIGHT - no highlighting.
HaruAnnotation::INVERT_BOX - invert the contents of the annotation.
HaruAnnotation::INVERT_BORDER - invert the border of the annotation.
HaruAnnotation::DOWN_APPEARANCE - dent the annotation.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruAnnotation::setBorderStyle | Domů | HaruAnnotation::setIcon


HaruAnnotation::setIcon

(PECL haru:0.0.1)

HaruAnnotation::setIcon — Set the icon style of the annotation

Popis

bool HaruAnnotation::setIcon ( int $icon )

Defines the style of the annotation icon. This function may be used with text annotations only.

Seznam parametrů

icon

The style of the icon. Can take only these values:

HaruAnnotation::ICON_COMMENT
HaruAnnotation::ICON_KEY
HaruAnnotation::ICON_NOTE
HaruAnnotation::ICON_HELP
HaruAnnotation::ICON_NEW_PARAGRAPH
HaruAnnotation::ICON_PARAGRAPH
HaruAnnotation::ICON_INSERT

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruAnnotation::setHighlightMode | Domů | HaruAnnotation::setOpened


HaruAnnotation::setOpened

(PECL haru:0.0.1)

HaruAnnotation::setOpened — Set the initial state of the annotation

Popis

bool HaruAnnotation::setOpened ( bool $opened )

Defines whether the annotation is initially displayed open. This function may be used with text annotations only.

Seznam parametrů

opened

TRUE means the annotation is initially displayed open, FALSE - means it's closed.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruAnnotation::setIcon | Domů | HaruDestination::setFit


HaruDestination::setFit

(PECL haru:0.0.1)

HaruDestination::setFit — Set the appearance of the page to fit the window

Popis

bool HaruDestination::setFit ( void )

Defines the appearance of the page to fit the window.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruAnnotation::setOpened | Domů | HaruDestination::setFitB


HaruDestination::setFitB

(PECL haru:0.0.1)

HaruDestination::setFitB — Set the appearance of the page to fit the bounding box of the page within the window

Popis

bool HaruDestination::setFitB ( void )

Defines the appearance of the page to fit the bounding box of the page within the window.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruDestination::setFit | Domů | HaruDestination::setFitBH


HaruDestination::setFitBH

(PECL haru:0.0.1)

HaruDestination::setFitBH — Set the appearance of the page to fit the width of the bounding box

Popis

bool HaruDestination::setFitBH ( float $top )

Defines the appearance of the page to magnifying to fit the width of the bounding box and setting the top position of the page to the value of top.

Seznam parametrů

top

The top coordinates of the page.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruDestination::setFitB | Domů | HaruDestination::setFitBV


HaruDestination::setFitBV

(PECL haru:0.0.1)

HaruDestination::setFitBV — Set the appearance of the page to fit the height of the boudning box

Popis

bool HaruDestination::setFitBV ( float $left )

Defines the appearance of the page to magnifying to fit the height of the bounding box and setting the left position of the page to the value of left.

Seznam parametrů

left

The left coordinates of the page.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruDestination::setFitBH | Domů | HaruDestination::setFitH


HaruDestination::setFitH

(PECL haru:0.0.1)

HaruDestination::setFitH — Set the appearance of the page to fit the window width

Popis

bool HaruDestination::setFitH ( float $top )

Defines the appearance of the page to fit the window width and sets the top position of the page to the value of top.

Seznam parametrů

top

The top position of the page.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruDestination::setFitBV | Domů | HaruDestination::setFitR


HaruDestination::setFitR

(PECL haru:0.0.1)

HaruDestination::setFitR — Set the appearance of the page to fit the specified rectangle

Popis

bool HaruDestination::setFitR ( float $left, float $bottom, float $right, float $top )

Defines the appearance of the page to fit the rectangle by the parameters.

Seznam parametrů

left

The left coordinates of the page.

bottom

The bottom coordinates of the page.

right

The right coordinates of the page.

top

The top coordinates of the page.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruDestination::setFitH | Domů | HaruDestination::setFitV


HaruDestination::setFitV

(PECL haru:0.0.1)

HaruDestination::setFitV — Set the appearance of the page to fit the window height

Popis

bool HaruDestination::setFitV ( float $left )

Defines the appearance of the page to fit the window height.

Seznam parametrů

left

The left position of the page.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruDestination::setFitR | Domů | HaruDestination::setXYZ


HaruDestination::setXYZ

(PECL haru:0.0.1)

HaruDestination::setXYZ — Set the appearance of the page

Popis

bool HaruDestination::setXYZ ( float $left, float $top, float $zoom )

Defines the appearance of the page using three parameters: left, top and zoom.

Seznam parametrů

left

The left position of the page.

top

The top position of the page.

zoom

The magnification factor. The value must be between 0.08 (8%) and 32 (3200%).

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruDestination::setFitV | Domů | HaruDoc::addPage


HaruDoc::addPage

(PECL haru:0.0.1)

HaruDoc::addPage — Add new page to the document

Popis

object HaruDoc::addPage ( void )

Adds new page to the document and returns new HaruPage instance.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruDoc::insertPage()

Předcházející | Nahoru | Další
HaruDestination::setXYZ | Domů | HaruDoc::addPageLabel


HaruDoc::addPageLabel

(PECL haru:0.0.1)

HaruDoc::addPageLabel — Set the numbering style for the specified range of pages

Popis

bool HaruDoc::addPageLabel ( int $first_page, int $style, int $first_num [, string $prefix] )

Set the numbering style for the specified range of pages.

Seznam parametrů

first_page

The first page included into the labeling range.

style

The numbering style. The following values are allowed:

HaruPage::NUM_STYLE_DECIMAL - page label is displayed using decimal numerals.
HaruPage::NUM_STYLE_UPPER_ROMAN - page label is displayed using uppercase Roman numerals.
HaruPage::NUM_STYLE_LOWER_ROMAN - page label is displayed using lowercase Roman numerals.
HaruPage::NUM_STYLE_UPPER_LETTER - page label is displayed using uppercase letters (from A to Z).
HaruPage::NUM_STYLE_LOWER_LETTERS - page label is displayed using lowercase letters (from a to z).

first_num

The first page number in this range.

prefix

The prefix for the page label. Optional, empty by default.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruDoc::addPage | Domů | HaruDoc::__construct


HaruDoc::__construct

(PECL haru:0.0.1)

HaruDoc::__construct — Construct new HaruDoc instance

Popis

void HaruDoc::__construct ( void )

Constructs new HaruDoc instance.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruDoc::addPageLabel | Domů | HaruDoc::createOutline


HaruDoc::createOutline

(PECL haru:0.0.1)

HaruDoc::createOutline — Create a HaruOutline instance

Popis

object HaruDoc::createOutline ( string $title [, object $parent_outline [, object $encoder]] )

Creates and returns new HaruOutline instance.

Seznam parametrů

title

The caption of new outline object.

parent_outline

A valid HaruOutline instance or NULL.

encoder

A valid HaruEncoder instance or NULL.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruDoc::__construct | Domů | HaruDoc::getCurrentEncoder


HaruDoc::getCurrentEncoder

(PECL haru:0.0.1)

HaruDoc::getCurrentEncoder — Get HaruEncoder currently used in the document

Popis

object HaruDoc::getCurrentEncoder ( void )

Returns HaruEncoder currently used in the document or FALSE if encoder is not set.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruDoc::setCurrentEncoder()

Předcházející | Nahoru | Další
HaruDoc::createOutline | Domů | HaruDoc::getCurrentPage


HaruDoc::getCurrentPage

(PECL haru:0.0.1)

HaruDoc::getCurrentPage — Return current page of the document

Popis

object HaruDoc::getCurrentPage ( void )

Get current page of the document. Returns HaruPage instance on success or FALSE if there is no current page at the moment.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruDoc::getCurrentEncoder | Domů | HaruDoc::getEncoder


HaruDoc::getEncoder

(PECL haru:0.0.1)

HaruDoc::getEncoder — Get HaruEncoder instance for the specified encoding

Popis

object HaruDoc::getEncoder ( string $encoding )

Returns HaruEncoder instance for the specified encoding.

Seznam parametrů

encoding

The encoding name. See Builtin Encodings for the list of allowed values.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruDoc::setCurrentEncoder()
HaruDoc::getCurrentEncoder()

Předcházející | Nahoru | Další
HaruDoc::getCurrentPage | Domů | HaruDoc::getFont


HaruDoc::getFont

(PECL haru:0.0.1)

HaruDoc::getFont — Get HaruFont instance

Popis

object HaruDoc::getFont ( string $fontname [, string $encoding] )

Creates and returns HaruFont instance with the specified fontname and encoding.

Seznam parametrů

fontname

The name of the font. See Builtin Fonts for the list of builtin fonts. You can also use the name of a font loaded via HaruDoc::loadTTF(), HaruDoc::loadTTC() and HaruDoc::loadType1().

encoding

The encoding to use. See Builtin Encodings for the list of supported encodings.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruPage::setFontAndSize()
HaruPage::getCurrentFont()

Předcházející | Nahoru | Další
HaruDoc::getEncoder | Domů | HaruDoc::getInfoAttr


HaruDoc::getInfoAttr

(PECL haru:0.0.1)

HaruDoc::getInfoAttr — Get current value of the specified document attribute

Popis

string HaruDoc::getInfoAttr ( int $type )

Returns the string value of the specified document attribute.

Seznam parametrů

type

The type of the attribute. The following values are available:

HaruDoc::INFO_AUTHOR
HaruDoc::INFO_CREATOR
HaruDoc::INFO_TITLE
HaruDoc::INFO_SUBJECT
HaruDoc::INFO_KEYWORDS
HaruDoc::INFO_CREATION_DATE
HaruDoc::INFO_MOD_DATE

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruDoc::setInfoAttr()
HaruDoc::setInfoDateAttr()

Předcházející | Nahoru | Další
HaruDoc::getFont | Domů | HaruDoc::getPageLayout


HaruDoc::getPageLayout

(PECL haru:0.0.1)

HaruDoc::getPageLayout — Get current page layout

Popis

int HaruDoc::getPageLayout ( void )

Returns the page layout currently set in the document or FALSE if page layout was not set. See HaruDoc::setPageLayout() for the list of possible values.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruDoc::setPageLayout()

Předcházející | Nahoru | Další
HaruDoc::getInfoAttr | Domů | HaruDoc::getPageMode


HaruDoc::getPageMode

(PECL haru:0.0.1)

HaruDoc::getPageMode — Get current page mode

Popis

int HaruDoc::getPageMode ( void )

Returns the page mode currently set in the document. See HaruDoc::setPageMode() for the list of possible values.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruDoc::setPageMode()

Předcházející | Nahoru | Další
HaruDoc::getPageLayout | Domů | HaruDoc::getStreamSize


HaruDoc::getStreamSize

(PECL haru:0.0.1)

HaruDoc::getStreamSize — Get the size of the temporary stream

Popis

int HaruDoc::getStreamSize ( void )

Returns the size of the data in the temporary stream of the document. The size is zero if the document was not saved to the temporary stream.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruDoc::saveToStream()
HaruDoc::resetStream()
HaruDoc::readFromStream()

Předcházející | Nahoru | Další
HaruDoc::getPageMode | Domů | HaruDoc::insertPage


HaruDoc::insertPage

(PECL haru:0.0.1)

HaruDoc::insertPage — Insert new page just before the specified page

Popis

object HaruDoc::insertPage ( object $page )

Creates new page and inserts just before the specified page. Returns new HaruPage instance.

Seznam parametrů

page

A valid HaruPage instance.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruDoc::addPage()

Předcházející | Nahoru | Další
HaruDoc::getStreamSize | Domů | HaruDoc::loadJPEG


HaruDoc::loadJPEG

(PECL haru:0.0.1)

HaruDoc::loadJPEG — Load JPEG image and return new HaruImage instance

Popis

object HaruDoc::loadJPEG ( string $filename )

Loads the specified JPEG image and returns new HaruImage instance.

Seznam parametrů

filename

A valid JPEG image file.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruDoc::loadPNG()
HaruDoc::loadRAW()

Předcházející | Nahoru | Další
HaruDoc::insertPage | Domů | HaruDoc::loadPNG


HaruDoc::loadPNG

(PECL haru:0.0.1)

HaruDoc::loadPNG — Load PNG image and return HaruImage instance

Popis

object HaruDoc::loadPNG ( string $filename [, bool $deferred] )

Loads PNG image and returns HaruImage instance. You can set deferred parameter to TRUE for deferred data loading, in this case only size and color are loaded immediately. Default value of deferred is FALSE.

Libharu might be built without libpng support, in this case each call to this function would result in exception.

Seznam parametrů

filename

The name of a PNG image file.

deferred

Do not load data immediately. Defaults to FALSE.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruDoc::loadJPEG()
HaruDoc::loadRAW()

Předcházející | Nahoru | Další
HaruDoc::loadJPEG | Domů | HaruDoc::loadRaw


HaruDoc::loadRaw

(PECL haru:0.0.1)

HaruDoc::loadRaw — Load RAW image and return HaruImage instance

Popis

object HaruDoc::loadRaw ( string $filename, int $width, int $height, int $color_space )

Loads RAW image and returns new HaruImage instance.

Seznam parametrů

filename

The name of a RAW image file.

width

The width of the image.

height

The height of the image.

color_space

The color space of the image. Can be one of the following values:

HaruDoc::CS_DEVICE_GRAY
HaruDoc::CS_DEVICE_RGB
HaruDoc::CS_DEVICE_CMYK

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruDoc::loadJPEG()
HaruDoc::loadPNG()

Předcházející | Nahoru | Další
HaruDoc::loadPNG | Domů | HaruDoc::loadTTC


HaruDoc::loadTTC

(PECL haru:0.0.1)

HaruDoc::loadTTC — Load the font with the specified index from TTC file

Popis

string HaruDoc::loadTTC ( string $fontfile, int $index [, bool $embed] )

Loads the TrueType font with the specified index from a TrueType collection file.

Seznam parametrů

fontfile

The TrueType collection file.

index

The index of the font in the collection file.

embed

When set to TRUE, the glyph data of the font is embedded into the PDF file, otherwise only the matrix data is included. Defaults to FALSE.

Návratové hodnoty

Returns the name of the loaded font on success.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruDoc::loadTTF()
HaruDoc::loadType1()

Předcházející | Nahoru | Další
HaruDoc::loadRaw | Domů | HaruDoc::loadTTF


HaruDoc::loadTTF

(PECL haru:0.0.1)

HaruDoc::loadTTF — Load TTF font file

Popis

string HaruDoc::loadTTF ( string $fontfile [, bool $embed] )

Loads the given TTF file and (optionally) embed its data into the document.

Seznam parametrů

fontfile

The TTF file to load.

embed

When set to TRUE, the glyph data of the font is embedded into the PDF file, otherwise only the matrix data is included. Defaults to FALSE.

Návratové hodnoty

Returns the name of the loaded font on success.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruDoc::loadTTC()
HaruDoc::loadType1()

Předcházející | Nahoru | Další
HaruDoc::loadTTC | Domů | HaruDoc::loadType1


HaruDoc::loadType1

(PECL haru:0.0.1)

HaruDoc::loadType1 — Load Type1 font

Popis

string HaruDoc::loadType1 ( string $afmfile [, string $pfmfile] )

Loads Type1 font from the given file and registers it in the PDF document.

Seznam parametrů

afmfile

Path to an AFM file.

pfmfile

Path to a PFA/PFB file, optional. If it's not set only the glyph data of the font is embedded into the PDF document.

Návratové hodnoty

Returns the name of the loaded font on success.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruDoc::loadTTC()
HaruDoc::loadTTF()

Předcházející | Nahoru | Další
HaruDoc::loadTTF | Domů | HaruDoc::output


HaruDoc::output

(PECL haru:0.0.1)

HaruDoc::output — Write the document data to the output buffer

Popis

bool HaruDoc::output ( void )

Writes the document data into standard output.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruDoc::save()

Předcházející | Nahoru | Další
HaruDoc::loadType1 | Domů | HaruDoc::readFromStream


HaruDoc::readFromStream

(PECL haru:0.0.1)

HaruDoc::readFromStream — Read data from the temporary stream

Popis

string HaruDoc::readFromStream ( int $bytes )

Returns data from the temporary stream. The bytes parameter specifies how much bytes to read, though the stream may contain less bytes than requested.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruDoc::saveToStream()
HaruDoc::resetStream()
HaruDoc::getStreamSize()

Předcházející | Nahoru | Další
HaruDoc::output | Domů | HaruDoc::resetError


HaruDoc::resetError

(PECL haru:0.0.1)

HaruDoc::resetError — Reset error state of the document handle

Popis

bool HaruDoc::resetError ( void )

Once an error code is set, most of the operations, including I/O processing functions cannot be performed. In case if you want to continue after the cause of the error has been fixed, you have to invoke this function in order to reset the document error state.

Návratové hodnoty

Always succeedes and returns TRUE.

Předcházející | Nahoru | Další
HaruDoc::readFromStream | Domů | HaruDoc::resetStream


HaruDoc::resetStream

(PECL haru:0.0.1)

HaruDoc::resetStream — Rewind the temporary stream

Popis

bool HaruDoc::resetStream ( void )

Rewinds the temporary stream of the document.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruDoc::saveToStream()
HaruDoc::getStreamSize()
HaruDoc::readFromStream()

Předcházející | Nahoru | Další
HaruDoc::resetError | Domů | HaruDoc::save


HaruDoc::save

(PECL haru:0.0.1)

HaruDoc::save — Save the document into the specified file

Popis

bool HaruDoc::save ( string $file )

Saves the document into the specified file.

Seznam parametrů

file

The file to save the document to.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruDoc::output()

Předcházející | Nahoru | Další
HaruDoc::resetStream | Domů | HaruDoc::saveToStream


HaruDoc::saveToStream

(PECL haru:0.0.1)

HaruDoc::saveToStream — Save the document into a temporary stream

Popis

bool HaruDoc::saveToStream ( void )

Saves the document data into a temporary stream.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruDoc::resetStream()
HaruDoc::getStreamSize()
HaruDoc::readFromStream()

Předcházející | Nahoru | Další
HaruDoc::save | Domů | HaruDoc::setCompressionMode


HaruDoc::setCompressionMode

(PECL haru:0.0.1)

HaruDoc::setCompressionMode — Set compression mode for the document

Popis

bool HaruDoc::setCompressionMode ( int $mode )

Defines compression mode for the document. In case when libharu was compiled without Zlib support this function will always throw HaruException.

Seznam parametrů

mode

The compression mode to use. The value is a combination of the following flags:

HaruDoc::COMP_NONE - all contents is not compressed.
HaruDoc::COMP_TEXT - compress the text data.
HaruDoc::COMP_IMAGE - compress the image data.
HaruDoc::COMP_METADATA - compress other data (fonts, cmaps).
HaruDoc::COMP_ALL - compress all data.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruDoc::saveToStream | Domů | HaruDoc::setCurrentEncoder


HaruDoc::setCurrentEncoder

(PECL haru:0.0.1)

HaruDoc::setCurrentEncoder — Set the current encoder for the document

Popis

bool HaruDoc::setCurrentEncoder ( string $encoding )

Defines the encoder currently used in the document.

Seznam parametrů

encoding

The name of the encoding to use. See Builtin Encodings for the list of allowed values.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruDoc::setCompressionMode | Domů | HaruDoc::setEncryptionMode


HaruDoc::setEncryptionMode

(PECL haru:0.0.1)

HaruDoc::setEncryptionMode — Set encryption mode for the document

Popis

bool HaruDoc::setEncryptionMode ( int $mode [, int $key_len] )

Defines encryption mode for the document. The encryption mode cannot be set before setting the password.

Seznam parametrů

mode

The encryption mode to use. Can be one of the following:

HaruDoc::ENCRYPT_R2 - use "revision2" algorithm.
HaruDoc::ENCRYPT_R3 - use "revision3" algorithm. Using this value bumps the version of PDF to 1.4.

key_len

The encryption key length in bytes. This parameter is optional and used only when mode is HaruDoc::ENCRYPT_R3. The default value is 5 (40bit).

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruDoc::setPassword()
HaruDoc::setPermission()

Předcházející | Nahoru | Další
HaruDoc::setCurrentEncoder | Domů | HaruDoc::setInfoAttr


HaruDoc::setInfoAttr

(PECL haru:0.0.1)

HaruDoc::setInfoAttr — Set the info attribute of the document

Popis

bool HaruDoc::setInfoAttr ( int $type, string $info )

Defines an info attribute. Uses the current encoding of the document.

Seznam parametrů

type

The type of the attribute. Can be one of the following:

HaruDoc::INFO_AUTHOR
HaruDoc::INFO_CREATOR
HaruDoc::INFO_TITLE
HaruDoc::INFO_SUBJECT
HaruDoc::INFO_KEYWORDS

info

The value of the attribute.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruDoc::setInfoDateAttr()

Předcházející | Nahoru | Další
HaruDoc::setEncryptionMode | Domů | HaruDoc::setInfoDateAttr


HaruDoc::setInfoDateAttr

(PECL haru:0.0.1)

HaruDoc::setInfoDateAttr — Set the datetime info attributes of the document

Popis

bool HaruDoc::setInfoDateAttr ( int $type, int $year, int $month, int $day, int $hour, int $min, int $sec, string $ind, int $off_hour, int $off_min )

Sets the datetime info attributes of the document.

Seznam parametrů

type

The type of the attribute. Can be one of the following:

HaruDoc::INFO_CREATION_DATE
HaruDoc::INFO_MOD_DATE

year

month

Between 1 and 12.

day

Between 1 and 31, 30, 29 or 28 (different for each month).

hour

Between 0 and 23.

min

Between 0 and 59.

sec

Between 0 and 59.

ind

The timezone relation to UTC, can be "", " ", "+", "-" and "Z".

off_hour

If ind is not " " or "", values between 0 and 23 are valid. Otherwise, this parameter is ignored.

off_min

If ind is not " " or "", values between 0 and 59 are valid. Otherwise, this parameter is ignored.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruDoc::setInfoAttr()

Předcházející | Nahoru | Další
HaruDoc::setInfoAttr | Domů | HaruDoc::setOpenAction


HaruDoc::setOpenAction

(PECL haru:0.0.1)

HaruDoc::setOpenAction — Define which page is shown when the document is opened

Popis

bool HaruDoc::setOpenAction ( object $destination )

Defines wich page should be shown when the document is opened.

Seznam parametrů

destination

A valid HaruDestination instance.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruDoc::setInfoDateAttr | Domů | HaruDoc::setPageLayout


HaruDoc::setPageLayout

(PECL haru:0.0.1)

HaruDoc::setPageLayout — Set how pages should be displayed

Popis

bool HaruDoc::setPageLayout ( int $layout )

Defines how pages should be displayed.

Seznam parametrů

layout

The following values are accepted:

HaruDoc::PAGE_LAYOUT_SINGLE - only one page is displayed.
HaruDoc::PAGE_LAYOUT_ONE_COLUMN - display the pages in one column.
HaruDoc::PAGE_LAYOUT_TWO_COLUMN_LEFT - display pages in two columns, first page left.
HaruDoc::PAGE_LAYOUT_TWO_COLUMN_RIGHT - display pages in two columns, first page right.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruDoc::getPageLayout()

Předcházející | Nahoru | Další
HaruDoc::setOpenAction | Domů | HaruDoc::setPageMode


HaruDoc::setPageMode

(PECL haru:0.0.1)

HaruDoc::setPageMode — Set how the document should be displayed

Popis

bool HaruDoc::setPageMode ( int $mode )

Defines how the document should be displayed.

Seznam parametrů

mode

The following values are accepted:

HaruDoc::PAGE_MODE_USE_NONE - display the document with neither outline nor thumbnail.
HaruDoc::PAGE_MODE_USE_OUTLINE - display the document with outline pane.
HaruDoc::PAGE_MODE_USE_THUMBS - display the document with thumbnail pane.
HaruDoc::PAGE_MODE_FULL_SCREEN - display the document with full screen mode.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruDoc::getPageMode()

Předcházející | Nahoru | Další
HaruDoc::setPageLayout | Domů | HaruDoc::setPagesConfiguration


HaruDoc::setPagesConfiguration

(PECL haru:0.0.1)

HaruDoc::setPagesConfiguration — Set the number of pages per set of pages

Popis

bool HaruDoc::setPagesConfiguration ( int $page_per_pages )

By default the document has one pages object as a root for all pages. All page objects are create as branches of this object. One pages object can contain only 8191, therefore the maximum number of pages per document is 8191. But you can change that fact by setting page_per_pages parameter, so that the root pages object contains 8191 more pages (not page) objects, which in turn contain 8191 pages each. So the maximum number of pages in the document becomes 8191*page_per_pages.

Seznam parametrů

page_per_pages

The numbers of pages that a pages object can contain.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruDoc::setPageMode | Domů | HaruDoc::setPassword


HaruDoc::setPassword

(PECL haru:0.0.1)

HaruDoc::setPassword — Set owner and user passwords for the document

Popis

bool HaruDoc::setPassword ( string $owner_password, string $user_password )

Defines owner and user passwords for the document. Setting the passwords makes the document contents encrypted.

Seznam parametrů

owner_password

The password of the owner, which can change permissions of the document. Empty password is not accepted. Owner's password cannot be the same as the user's password.

user_password

The password of the user. Can be empty.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruDoc::setEncryptionMode()
HaruDoc::setPermission()

Předcházející | Nahoru | Další
HaruDoc::setPagesConfiguration | Domů | HaruDoc::setPermission


HaruDoc::setPermission

(PECL haru:0.0.1)

HaruDoc::setPermission — Set permissions for the document

Popis

bool HaruDoc::setPermission ( int $permission )

Defines permissions for the document.

Seznam parametrů

permission

The values is a combination of these flags:

HaruDoc::ENABLE_READ - user can read the document.
HaruDoc::ENABLE_PRINT - user can print the document.
HaruDoc::ENABLE_EDIT_ALL - user can edit the contents of the document other than annotations and form fields.
HaruDoc::ENABLE_COPY - user can copy the text and the graphics of the document.
HaruDoc::ENABLE_EDIT - user can add or modify the annotations and form fields of the document.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruDoc::setPassword()
HaruDoc::setEncryptionMode()

Předcházející | Nahoru | Další
HaruDoc::setPassword | Domů | HaruDoc::useCNSEncodings


HaruDoc::useCNSEncodings

(PECL haru:0.0.1)

HaruDoc::useCNSEncodings — Enable Chinese simplified encodings

Popis

bool HaruDoc::useCNSEncodings ( void )

Enables Chinese simplified encodings.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruDoc::useCNSFonts()

Předcházející | Nahoru | Další
HaruDoc::setPermission | Domů | HaruDoc::useCNSFonts


HaruDoc::useCNSFonts

(PECL haru:0.0.1)

HaruDoc::useCNSFonts — Enable builtin Chinese simplified fonts

Popis

bool HaruDoc::useCNSFonts ( void )

Enableis builtin Chinese simplified fonts.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruDoc::useCNSEncodings()

Předcházející | Nahoru | Další
HaruDoc::useCNSEncodings | Domů | HaruDoc::useCNTEncodings


HaruDoc::useCNTEncodings

(PECL haru:0.0.1)

HaruDoc::useCNTEncodings — Enable Chinese traditional encodings

Popis

bool HaruDoc::useCNTEncodings ( void )

Enables Chinese traditional encodings.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruDoc::useCNTFonts()

Předcházející | Nahoru | Další
HaruDoc::useCNSFonts | Domů | HaruDoc::useCNTFonts


HaruDoc::useCNTFonts

(PECL haru:0.0.1)

HaruDoc::useCNTFonts — Enable builtin Chinese traditional fonts

Popis

bool HaruDoc::useCNTFonts ( void )

Enables builtin Chinese traditional fonts.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruDoc::useCNTEncodings()

Předcházející | Nahoru | Další
HaruDoc::useCNTEncodings | Domů | HaruDoc::useJPEncodings


HaruDoc::useJPEncodings

(PECL haru:0.0.1)

HaruDoc::useJPEncodings — Enable Japanese encodings

Popis

bool HaruDoc::useJPEncodings ( void )

Enables Japanese encodings.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruDoc::useJPFonts()

Předcházející | Nahoru | Další
HaruDoc::useCNTFonts | Domů | HaruDoc::useJPFonts


HaruDoc::useJPFonts

(PECL haru:0.0.1)

HaruDoc::useJPFonts — Enable builtin Japanese fonts

Popis

bool HaruDoc::useJPFonts ( void )

Enables builtin Japanese fonts.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruDoc::useJPEncodings()

Předcházející | Nahoru | Další
HaruDoc::useJPEncodings | Domů | HaruDoc::useKREncodings


HaruDoc::useKREncodings

(PECL haru:0.0.1)

HaruDoc::useKREncodings — Enable Korean encodings

Popis

bool HaruDoc::useKREncodings ( void )

Enables Korean encodings.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruDoc::useKRFonts()

Předcházející | Nahoru | Další
HaruDoc::useJPFonts | Domů | HaruDoc::useKRFonts


HaruDoc::useKRFonts

(PECL haru:0.0.1)

HaruDoc::useKRFonts — Enable builtin Korean fonts

Popis

bool HaruDoc::useKRFonts ( void )

Enables builtin Korean fonts.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruDoc::useKREncodings()

Předcházející | Nahoru | Další
HaruDoc::useKREncodings | Domů | HaruEncoder::getByteType


HaruEncoder::getByteType

(PECL haru:0.0.1)

HaruEncoder::getByteType — Get the type of the byte in the text

Popis

int HaruEncoder::getByteType ( string $text, int $index )

Returns the type of the byte in the text on the specified position. The result is one of the following values:
HaruEncoder::BYTE_TYPE_SINGLE - single byte character.
HaruEncoder::BYTE_TYPE_LEAD - lead byte of a double-byte character.
HaruEncoder::BYTE_TYPE_TRAIL - trailing byte of a double-byte character.
HaruEncoder::BYTE_TYPE_UNKNOWN - invalid encoder or cannot detect the byte type.

Seznam parametrů

text

The text.

index

The position in the text.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruDoc::useKRFonts | Domů | HaruEncoder::getType


HaruEncoder::getType

(PECL haru:0.0.1)

HaruEncoder::getType — Get the type of the encoder

Popis

int HaruEncoder::getType ( void )

Returns the type of the encoder. The result is one of the followin values:
HaruEncoder::TYPE_SINGLE_BYTE - the encoder is for single byte characters.
HaruEncoder::TYPE_DOUBLE_BYTE - the encoder is for multibyte characters.
HaruEncoder::TYPE_UNINITIALIZED - the encoder is not initialized.
HaruEncoder::UNKNOWN - the encoder is invalid.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruEncoder::getByteType | Domů | HaruEncoder::getUnicode


HaruEncoder::getUnicode

(PECL haru:0.0.1)

HaruEncoder::getUnicode — Convert the specified character to unicode

Popis

int HaruEncoder::getUnicode ( int $character )

Converts the specified character to unicode.

Seznam parametrů

character

The character code to convert.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruEncoder::getType | Domů | HaruEncoder::getWritingMode


HaruEncoder::getWritingMode

(PECL haru:0.0.1)

HaruEncoder::getWritingMode — Get the writing mode of the encoder

Popis

int HaruEncoder::getWritingMode ( void )

Returns the writing mode of the encoder. The result value is on of the following:
HaruEncoder::WMODE_HORIZONTAL - horizontal writing mode.
HaruEncoder::WMODE_VERTICAL - vertical writing mode.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruEncoder::getUnicode | Domů | HaruFont::getAscent


HaruFont::getAscent

(PECL haru:0.0.1)

HaruFont::getAscent — Get the vertical ascent of the font

Popis

int HaruFont::getAscent ( void )

Returns the vertical ascent of the font.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruEncoder::getWritingMode | Domů | HaruFont::getCapHeight


HaruFont::getCapHeight

(PECL haru:0.0.1)

HaruFont::getCapHeight — Get the distance from the baseline of uppercase letters

Popis

int HaruFont::getCapHeight ( void )

Returns the distance from the baseline of uppercase letters.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruFont::getAscent | Domů | HaruFont::getDescent


HaruFont::getDescent

(PECL haru:0.0.1)

HaruFont::getDescent — Get the vertical descent of the font

Popis

int HaruFont::getDescent ( void )

Return the vertical descent of the font.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruFont::getCapHeight | Domů | HaruFont::getEncodingName


HaruFont::getEncodingName

(PECL haru:0.0.1)

HaruFont::getEncodingName — Get the name of the encoding

Popis

string HaruFont::getEncodingName ( void )

Returns the name of the font encoding.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruFont::getDescent | Domů | HaruFont::getFontName


HaruFont::getFontName

(PECL haru:0.0.1)

HaruFont::getFontName — Get the name of the font

Popis

string HaruFont::getFontName ( void )

Returns the name of the font.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruFont::getEncodingName | Domů | HaruFont::getTextWidth


HaruFont::getTextWidth

(PECL haru:0.0.1)

HaruFont::getTextWidth — Get the total width of the text, number of characters, number of words and number of spaces

Popis

array HaruFont::getTextWidth ( string $text )

Returns the total width of the text, number of characters, number of words and number of spaces in the given text.

Seznam parametrů

text

The text to measure.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruFont::getFontName | Domů | HaruFont::getUnicodeWidth


HaruFont::getUnicodeWidth

(PECL haru:0.0.1)

HaruFont::getUnicodeWidth — Get the width of the character in the font

Popis

int HaruFont::getUnicodeWidth ( int $character )

Returns the width of the character in the font.

Seznam parametrů

character

The code of the character.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruFont::getTextWidth | Domů | HaruFont::getXHeight


HaruFont::getXHeight

(PECL haru:0.0.1)

HaruFont::getXHeight — Get the distance from the baseline of lowercase letters

Popis

int HaruFont::getXHeight ( void )

Returns the distance from the baseline of lowercase letters.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruFont::getUnicodeWidth | Domů | HaruFont::measureText


HaruFont::measureText

(PECL haru:0.0.1)

HaruFont::measureText — Calculate the number of characters which can be included within the specified width

Popis

int HaruFont::measureText ( string $text, float $width, float $font_size, float $char_space, float $word_space [, bool $word_wrap] )

Returns the number of characters which can be included within the specified width.

Seznam parametrů

text

The text to fit the width.

width

The width of the area to put the text to.

font_size

The size of the font.

char_space

The character spacing.

word_space

The word spacing.

word_wrap

When this parameter is set to TRUE the function "emulates" word wrapping and doesn't include the part of the current word if reached the end of the area. Defaults to FALSE.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruFont::getXHeight | Domů | HaruImage::getBitsPerComponent


HaruImage::getBitsPerComponent

(PECL haru:0.0.1)

HaruImage::getBitsPerComponent — Get the number of bits used to describe each color component of the image

Popis

int HaruImage::getBitsPerComponent ( void )

Returns the number of bits used to describe each color component of the image.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruFont::measureText | Domů | HaruImage::getColorSpace


HaruImage::getColorSpace

(PECL haru:0.0.1)

HaruImage::getColorSpace — Get the name of the color space

Popis

string HaruImage::getColorSpace ( void )

Returns the name of the color space of the image. The name is one of the following values:
"DeviceGray"
"DeviceRGB"
"DeviceCMYK"
"Indexed"

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruImage::getBitsPerComponent | Domů | HaruImage::getHeight


HaruImage::getHeight

(PECL haru:0.0.1)

HaruImage::getHeight — Get the height of the image

Popis

int HaruImage::getHeight ( void )

Returns the height of the image.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruImage::getColorSpace | Domů | HaruImage::getSize


HaruImage::getSize

(PECL haru:0.0.1)

HaruImage::getSize — Get size of the image

Popis

array HaruImage::getSize ( void )

Returns an array with two elements: width and height, which contain appropriate dimensions of the image.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruImage::getHeight | Domů | HaruImage::getWidth


HaruImage::getWidth

(PECL haru:0.0.1)

HaruImage::getWidth — Get the width of the image

Popis

int HaruImage::getWidth ( void )

Returns the width of the image.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruImage::getSize | Domů | HaruImage::setColorMask


HaruImage::setColorMask

(PECL haru:0.0.1)

HaruImage::setColorMask — Set the color mask of the image

Popis

bool HaruImage::setColorMask ( int $rmin, int $rmax, int $gmin, int $gmax, int $bmin, int $bmax )

Defines the transparent color of the image using the RGB range values. The color within the range is displayed as a transparent color. The color space of the image must be RGB.

Seznam parametrů

rmin

The lower limit of red. Must be between 0 and 255.

rmax

The upper limit of red. Must be between 0 and 255.

gmin

The lower limit of green. Must be between 0 and 255.

gmax

The upper limit of green. Must be between 0 and 255.

bmin

The lower limit of blue. Must be between 0 and 255.

bmax

The upper limit of blue. Must be between 0 and 255.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruImage::getWidth | Domů | HaruImage::setMaskImage


HaruImage::setMaskImage

(PECL haru:0.0.1)

HaruImage::setMaskImage — Set the image mask

Popis

bool HaruImage::setMaskImage ( object $mask_image )

Sets the image used as image-mask. It must be 1bit gray-scale color image.

Seznam parametrů

mask_image

A valid HaruImage instance.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruImage::setColorMask | Domů | HaruOutline::setDestination


HaruOutline::setDestination

(PECL haru:0.0.1)

HaruOutline::setDestination — Set the destination for the outline

Popis

bool HaruOutline::setDestination ( object $destination )

Sets a destination object which becomes a target to jump to when the outline is clicked.

Seznam parametrů

destination

A valid HaruDestination instance.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruImage::setMaskImage | Domů | HaruOutline::setOpened


HaruOutline::setOpened

(PECL haru:0.0.1)

HaruOutline::setOpened — Set the initial state of the outline

Popis

bool HaruOutline::setOpened ( bool $opened )

Defines whether this node is opened or not when the outline is displayed for the first time.

Seznam parametrů

opened

TRUE means open, FALSE - closed.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruOutline::setDestination | Domů | HaruPage::arc


HaruPage::arc

(PECL haru:0.0.1)

HaruPage::arc — Append an arc to the current path

Popis

bool HaruPage::arc ( float $x, float $y, float $ray, float $ang1, float $ang2 )

Appends an arc to the current path.

Seznam parametrů

x

Horizontal coordinate of the center.

y

Vertical coordinate of the center.

ray

The ray of the arc.

ang1

The angle of the beginning.

ang2

The angle of the end. Must be greater than ang1.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruOutline::setOpened | Domů | HaruPage::beginText


HaruPage::beginText

(PECL haru:0.0.1)

HaruPage::beginText — Begin a text object and set the current text position to (0,0)

Popis

bool HaruPage::beginText ( void )

Begins new text object and sets the current text position to (0,0).

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruPage::arc | Domů | HaruPage::circle


HaruPage::circle

(PECL haru:0.0.1)

HaruPage::circle — Append a circle to the current path

Popis

bool HaruPage::circle ( float $x, float $y, float $ray )

Appends a circle to the current path.

Seznam parametrů

x

Horizontal coordinate of the center point.

y

Vertical coordinate of the center point.

ray

The ray of the circle.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruPage::beginText | Domů | HaruPage::closePath


HaruPage::closePath

(PECL haru:0.0.1)

HaruPage::closePath — Append a straight line from the current point to the start point of the path

Popis

bool HaruPage::closePath ( void )

Appends a straight line from the current point to the start point of the path.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruPage::circle | Domů | HaruPage::concat


HaruPage::concat

(PECL haru:0.0.1)

HaruPage::concat — Concatenate current transformation matrix of the page and the specified matrix

Popis

bool HaruPage::concat ( float $a, float $b, float $c, float $d, float $x, float $y )

Concatenates current transformation matrix of the page and the specified matrix.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruPage::closePath | Domů | HaruPage::createDestination


HaruPage::createDestination

(PECL haru:0.0.1)

HaruPage::createDestination — Create new HaruDestination instance

Popis

object HaruPage::createDestination ( void )

Creates and returns new HaruDestination instance.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruPage::concat | Domů | HaruPage::createLinkAnnotation


HaruPage::createLinkAnnotation

(PECL haru:0.0.1)

HaruPage::createLinkAnnotation — Create new HaruAnnotation instance

Popis

object HaruPage::createLinkAnnotation ( array $rectangle, object $destination )

Creates and returns new HaruAnnotation instance.

Seznam parametrů

rectangle

An array with 4 coordinates of the clickable area.

destination

Valid HaruDestination instance.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruPage::createDestination | Domů | HaruPage::createTextAnnotation


HaruPage::createTextAnnotation

(PECL haru:0.0.1)

HaruPage::createTextAnnotation — Create new HaruAnnotation instance

Popis

object HaruPage::createTextAnnotation ( array $rectangle, string $text [, object $encoder] )

Creates and returns new HaruAnnotation instance.

Seznam parametrů

rectangle

An array with 4 coordinates of the annotation area.

text

The text to be displayed.

encoder

Optional HaruEncoder instance.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruPage::createLinkAnnotation | Domů | HaruPage::createURLAnnotation


HaruPage::createURLAnnotation

(PECL haru:0.0.1)

HaruPage::createURLAnnotation — Create and return new HaruAnnotation instance

Popis

object HaruPage::createURLAnnotation ( array $rectangle, string $url )

Creates and returns new HaruAnnotation instance.

Seznam parametrů

rectangle

An array with 4 coordinates of the clickable area.

url

The URL to open.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruPage::createTextAnnotation | Domů | HaruPage::curveTo2


HaruPage::curveTo

(PECL haru:0.0.1)

HaruPage::curveTo — Append a Bezier curve to the current path

Popis

bool HaruPage::curveTo ( float $x1, float $y1, float $x2, float $y2, float $x3, float $y3 )

Append a Bezier curve to the current path. The point (x1, y1) and the point (x2, y2) are used as the control points for a Bezier curve and current point is moved to the point (x3, y3).

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruPage::curveTo3 | Domů | HaruPage::drawImage


HaruPage::curveTo2

(PECL haru:0.0.1)

HaruPage::curveTo2 — Append a Bezier curve to the current path

Popis

bool HaruPage::curveTo2 ( float $x2, float $y2, float $x3, float $y3 )

Appends a Bezier curve to the current path. The current point and the point (x2, y2) are used as the control points for the Bezier curve and current point is moved to the point (x3, y3).

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruPage::createURLAnnotation | Domů | HaruPage::curveTo3


HaruPage::curveTo3

(PECL haru:0.0.1)

HaruPage::curveTo3 — Append a Bezier curve to the current path

Popis

bool HaruPage::curveTo3 ( float $x1, float $y1, float $x3, float $y3 )

Appends a Bezier curve to the current path. The point (x1, y1) and the point (x3, y3) are used as the control points for a Bezier curve and current point is moved to the point (x3, y3).

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruPage::curveTo2 | Domů | HaruPage::curveTo


HaruPage::drawImage

(PECL haru:0.0.1)

HaruPage::drawImage — Show image at the page

Popis

bool HaruPage::drawImage ( object $image, float $x, float $y, float $width, float $height )

Show image at the page.

Seznam parametrů

image

Valid HaruImage instance.

x

The left border of the area where the image is displayed.

y

The lower border of the area where the image is displayed.

width

The width of the image area.

height

The height of the image area.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruPage::curveTo | Domů | HaruPage::ellipse


HaruPage::ellipse

(PECL haru:0.0.1)

HaruPage::ellipse — Append an ellipse to the current path

Popis

bool HaruPage::ellipse ( float $x, float $y, float $xray, float $yray )

Appends an ellipse to the current path.

Seznam parametrů

x

Horizontal coordinate of the center.

y

Vertical coordinate of the center.

xray

The ray of the ellipse in the x direction.

yray

The ray of the ellipse in the y direction.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruPage::drawImage | Domů | HaruPage::endPath


HaruPage::endPath

(PECL haru:0.0.1)

HaruPage::endPath — End current path object without filling and painting operations

Popis

bool HaruPage::endPath ( void )

Ends current path object without performing filling and painting operations.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruPage::ellipse | Domů | HaruPage::endText


HaruPage::endText

(PECL haru:0.0.1)

HaruPage::endText — End current text object

Popis

bool HaruPage::endText ( void )

Finalizes current text object.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruPage::endPath | Domů | HaruPage::eofill


HaruPage::eofill

(PECL haru:0.0.1)

HaruPage::eofill — Fill current path using even-odd rule

Popis

bool HaruPage::eofill ( void )

Fills current path using even-odd rule.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruPage::endText | Domů | HaruPage::eoFillStroke


HaruPage::eoFillStroke

(PECL haru:0.0.1)

HaruPage::eoFillStroke — Fill current path using even-odd rule, then paint the path

Popis

bool HaruPage::eoFillStroke ( [bool $close_path] )

Fills current path using even-odd rule, then paints the path.

Seznam parametrů

close_path

Optional parameter. When set to TRUE, the function closes the current path. Default to FALSE.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruPage::eofill | Domů | HaruPage::fill


HaruPage::fill

(PECL haru:0.0.1)

HaruPage::fill — Fill current path using nonzero winding number rule

Popis

bool HaruPage::fill ( void )

Fills current path using nonzero winding number rule.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruPage::eoFillStroke | Domů | HaruPage::fillStroke


HaruPage::fillStroke

(PECL haru:0.0.1)

HaruPage::fillStroke — Fill current path using nonzero winding number rule, then paint the path

Popis

bool HaruPage::fillStroke ( [bool $close_path] )

Fills current path using nonzero winding number rule, then paints the path.

Seznam parametrů

close_path

Optional parameter. When set to TRUE, the function closes the current path. Default to FALSE.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruPage::fill | Domů | HaruPage::getCharSpace


HaruPage::getCharSpace

(PECL haru:0.0.1)

HaruPage::getCharSpace — Get the current value of character spacing

Popis

float HaruPage::getCharSpace ( void )

Returns the current value of character spacing.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruPage::fillStroke | Domů | HaruPage::getCMYKFill


HaruPage::getCMYKFill

(PECL haru:0.0.1)

HaruPage::getCMYKFill — Get the current filling color

Popis

array HaruPage::getCMYKFill ( void )

Returns the current filling color as an array with 4 elements ("c", "m", "y" and "k").

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruPage::getCharSpace | Domů | HaruPage::getCMYKStroke


HaruPage::getCMYKStroke

(PECL haru:0.0.1)

HaruPage::getCMYKStroke — Get the current stroking color

Popis

array HaruPage::getCMYKStroke ( void )

Returns the current stroking color as an array with 4 elements ("c", "m", "y" and "k").

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruPage::getCMYKFill | Domů | HaruPage::getCurrentFont


HaruPage::getCurrentFont

(PECL haru:0.0.1)

HaruPage::getCurrentFont — Get the currently used font

Popis

object HaruPage::getCurrentFont ( void )

Returns the currently used font as an instance of HaruFont.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruPage::getCMYKStroke | Domů | HaruPage::getCurrentFontSize


HaruPage::getCurrentFontSize

(PECL haru:0.0.1)

HaruPage::getCurrentFontSize — Get the current font size

Popis

float HaruPage::getCurrentFontSize ( void )

Returns the current font size.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruPage::getCurrentFont | Domů | HaruPage::getCurrentPos


HaruPage::getCurrentPos

(PECL haru:0.0.1)

HaruPage::getCurrentPos — Get the current position for path painting

Popis

array HaruPage::getCurrentPos ( void )

Returns the current position for path painting as an array of with two elements - "x" and "y".

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruPage::getCurrentFontSize | Domů | HaruPage::getCurrentTextPos


HaruPage::getCurrentTextPos

(PECL haru:0.0.1)

HaruPage::getCurrentTextPos — Get the current position for text printing

Popis

array HaruPage::getCurrentTextPos ( void )

Returns the current position for text printing as an array with 2 elements - "x" and "y".

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruPage::getCurrentPos | Domů | HaruPage::getDash


HaruPage::getDash

(PECL haru:0.0.1)

HaruPage::getDash — Get the current dash pattern

Popis

array HaruPage::getDash ( void )

Returns the current dash pattern as an array of two elements - "pattern" and "phase" or FALSE if dash pattern was not set. See HaruPage::setDash() for more information on dash patterns.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruPage::setDash()

Předcházející | Nahoru | Další
HaruPage::getCurrentTextPos | Domů | HaruPage::getFillingColorSpace


HaruPage::getFillingColorSpace

(PECL haru:0.0.1)

HaruPage::getFillingColorSpace — Get the current filling color space

Popis

int HaruPage::getFillingColorSpace ( void )

Returns the current filling color space. The result value is one of the following:
HaruDoc::CS_DEVICE_GRAY
HaruDoc::CS_DEVICE_RGB
HaruDoc::CS_DEVICE_CMYK
HaruDoc::CS_CAL_GRAY
HaruDoc::CS_CAL_RGB
HaruDoc::CS_LAB
HaruDoc::CS_ICC_BASED
HaruDoc::CS_SEPARATION
HaruDoc::CS_DEVICE_N
HaruDoc::CS_INDEXED
HaruDoc::CS_PATTERN

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruPage::getDash | Domů | HaruPage::getFlatness


HaruPage::getFlatness

(PECL haru:0.0.1)

HaruPage::getFlatness — Get the flatness of the page

Popis

float HaruPage::getFlatness ( void )

Returns the flatness of the page.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruPage::setFlatness()

Předcházející | Nahoru | Další
HaruPage::getFillingColorSpace | Domů | HaruPage::getGMode


HaruPage::getGMode

(PECL haru:0.0.1)

HaruPage::getGMode — Get the current graphics mode

Popis

int HaruPage::getGMode ( void )

Returns the current graphics mode. The result value is one of the following:
HaruPage::GMODE_PAGE_DESCRIPTION
HaruPage::GMODE_TEXT_OBJECT
HaruPage::GMODE_PATH_OBJECT
HaruPage::GMODE_CLIPPING_PATH
HaruPage::GMODE_SHADING
HaruPage::GMODE_INLINE_IMAGE
HaruPage::GMODE_EXTERNAL_OBJECT

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruPage::getFlatness | Domů | HaruPage::getGrayFill


HaruPage::getGrayFill

(PECL haru:0.0.1)

HaruPage::getGrayFill — Get the current filling color

Popis

float HaruPage::getGrayFill ( void )

Returns the current filling color.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruPage::setGrayFill()

Předcházející | Nahoru | Další
HaruPage::getGMode | Domů | HaruPage::getGrayStroke


HaruPage::getGrayStroke

(PECL haru:0.0.1)

HaruPage::getGrayStroke — Get the current stroking color

Popis

float HaruPage::getGrayStroke ( void )

Returns the current stroking color.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruPage::setGrayStroke()

Předcházející | Nahoru | Další
HaruPage::getGrayFill | Domů | HaruPage::getHeight


HaruPage::getHeight

(PECL haru:0.0.1)

HaruPage::getHeight — Get the height of the page

Popis

float HaruPage::getHeight ( void )

Returns the height of the page.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruPage::setHeight()

Předcházející | Nahoru | Další
HaruPage::getGrayStroke | Domů | HaruPage::getHorizontalScaling


HaruPage::getHorizontalScaling

(PECL haru:0.0.1)

HaruPage::getHorizontalScaling — Get the current value of horizontal scaling

Popis

float HaruPage::getHorizontalScaling ( void )

Returns the current value of horizontal scaling.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruPage::setHorizontalScaling()

Předcházející | Nahoru | Další
HaruPage::getHeight | Domů | HaruPage::getLineCap


HaruPage::getLineCap

(PECL haru:0.0.1)

HaruPage::getLineCap — Get the current line cap style

Popis

int HaruPage::getLineCap ( void )

Returns the current line cap style. The result value is one of the following:
HaruPage::BUTT_END - the line is squared off at the endpoint of the path.
HaruPage::ROUND_END - the end of the line becomes a semicircle with center in the end point of the path.
HaruPage::PROJECTING_SCUARE_END - the line continues to the point that exceeds half of the stroke width the end point.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruPage::setLineCap()

Předcházející | Nahoru | Další
HaruPage::getHorizontalScaling | Domů | HaruPage::getLineJoin


HaruPage::getLineJoin

(PECL haru:0.0.1)

HaruPage::getLineJoin — Get the current line join style

Popis

int HaruPage::getLineJoin ( void )

Returns the current line join style. The result value is one of the following:
HaruPage::MITER_JOIN
HaruPage::ROUND_JOIN
HaruPage::BEVEL_JOIN

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruPage::setLineJoin()

Předcházející | Nahoru | Další
HaruPage::getLineCap | Domů | HaruPage::getLineWidth


HaruPage::getLineWidth

(PECL haru:0.0.1)

HaruPage::getLineWidth — Get the current line width

Popis

float HaruPage::getLineWidth ( void )

Returns the current line width.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruPage::setLineWidth()

Předcházející | Nahoru | Další
HaruPage::getLineJoin | Domů | HaruPage::getMiterLimit


HaruPage::getMiterLimit

(PECL haru:0.0.1)

HaruPage::getMiterLimit — Get the value of miter limit

Popis

float HaruPage::getMiterLimit ( void )

Returns the value of miter limit.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruPage::setMiterLimit()

Předcházející | Nahoru | Další
HaruPage::getLineWidth | Domů | HaruPage::getRGBFill


HaruPage::getRGBFill

(PECL haru:0.0.1)

HaruPage::getRGBFill — Get the current filling color

Popis

array HaruPage::getRGBFill ( void )

Returns the current filling color as an array with 3 elements: "r", "g" and "b".

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruPage::setRGBFill()

Předcházející | Nahoru | Další
HaruPage::getMiterLimit | Domů | HaruPage::getRGBStroke


HaruPage::getRGBStroke

(PECL haru:0.0.1)

HaruPage::getRGBStroke — Get the current stroking color

Popis

array HaruPage::getRGBStroke ( void )

Returns the current stroking color.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruPage::setRGBStroke()

Předcházející | Nahoru | Další
HaruPage::getRGBFill | Domů | HaruPage::getStrokingColorSpace


HaruPage::getStrokingColorSpace

(PECL haru:0.0.1)

HaruPage::getStrokingColorSpace — Get the current stroking color space

Popis

int HaruPage::getStrokingColorSpace ( void )

Returns the current stroking color space. The list of return values is the same as for HaruPage::getFillingColorSpace().

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruPage::getFillingColorSpace()

Předcházející | Nahoru | Další
HaruPage::getRGBStroke | Domů | HaruPage::getTextLeading


HaruPage::getTextLeading

(PECL haru:0.0.1)

HaruPage::getTextLeading — Get the current value of line spacing

Popis

float HaruPage::getTextLeading ( void )

Returns the current value of line spacing.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruPage::setTextLeading()

Předcházející | Nahoru | Další
HaruPage::getStrokingColorSpace | Domů | HaruPage::getTextMatrix


HaruPage::getTextMatrix

(PECL haru:0.0.1)

HaruPage::getTextMatrix — Get the current text transformation matrix of the page

Popis

array HaruPage::getTextMatrix ( void )

Returns the current text transformation matrix of the page as an array of 6 elements: "a", "b", "c", "d", "x" and "y".

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruPage::setTextMatrix()

Předcházející | Nahoru | Další
HaruPage::getTextLeading | Domů | HaruPage::getTextRenderingMode


HaruPage::getTextRenderingMode

(PECL haru:0.0.1)

HaruPage::getTextRenderingMode — Get the current text rendering mode

Popis

int HaruPage::getTextRenderingMode ( void )

Returns the current text rendering mode. The result value is one of the following:
HaruPage::FILL
HaruPage::STROKE
HaruPage::FILL_THEN_STROKE
HaruPage::INVISIBLE
HaruPage::FILL_CLIPPING
HaruPage::STROKE_CLIPPING
HaruPage::FILL_STROKE_CLIPPING
HaruPage::CLIPPING

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruPage::setTextRenderingMode()

Předcházející | Nahoru | Další
HaruPage::getTextMatrix | Domů | HaruPage::getTextRise


HaruPage::getTextRise

(PECL haru:0.0.1)

HaruPage::getTextRise — Get the current value of text rising

Popis

float HaruPage::getTextRise ( void )

Returns the current value of text rising.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruPage::setTextRise()

Předcházející | Nahoru | Další
HaruPage::getTextRenderingMode | Domů | HaruPage::getTextWidth


HaruPage::getTextWidth

(PECL haru:0.0.1)

HaruPage::getTextWidth — Get the width of the text using current fontsize, character spacing and word spacing

Popis

float HaruPage::getTextWidth ( string $text )

Returns the width of the text using current fontsize, character spacing and word spacing.

Seznam parametrů

text

The text to measure.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruPage::measureText()

Předcházející | Nahoru | Další
HaruPage::getTextRise | Domů | HaruPage::getTransMatrix


HaruPage::getTransMatrix

(PECL haru:0.0.1)

HaruPage::getTransMatrix — Get the current transformation matrix of the page

Popis

array HaruPage::getTransMatrix ( void )

Returns the current transformation matrix of the page as an array of 6 elements: "a", "b", "c", "d", "x" and "y".

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruPage::concat()

Předcházející | Nahoru | Další
HaruPage::getTextWidth | Domů | HaruPage::getWidth


HaruPage::getWidth

(PECL haru:0.0.1)

HaruPage::getWidth — Get the width of the page

Popis

float HaruPage::getWidth ( void )

Returns the width of the page.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruPage::setWidth()

Předcházející | Nahoru | Další
HaruPage::getTransMatrix | Domů | HaruPage::getWordSpace


HaruPage::getWordSpace

(PECL haru:0.0.1)

HaruPage::getWordSpace — Get the current value of word spacing

Popis

float HaruPage::getWordSpace ( void )

Returns the current value of word spacing.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruPage::setWordSpace()

Předcházející | Nahoru | Další
HaruPage::getWidth | Domů | HaruPage::lineTo


HaruPage::lineTo

(PECL haru:0.0.1)

HaruPage::lineTo — Draw a line from the current point to the specified point

Popis

bool HaruPage::lineTo ( float $x, float $y )

Draws a line from the current point to the specified point.

Seznam parametrů

x

y

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruPage::curveTo()
HaruPage::curveTo2()
HaruPage::curveTo3()

Předcházející | Nahoru | Další
HaruPage::getWordSpace | Domů | HaruPage::measureText


HaruPage::measureText

(PECL haru:0.0.1)

HaruPage::measureText — Calculate the number of characters which can be included within the specified width

Popis

int HaruPage::measureText ( string $text, float $width [, bool $wordwrap] )

Returns the number of characters which can be included within the specified width.

Seznam parametrů

text

The text to measure.

width

The width of the area to put the text to.

wordwrap

When this parameter is set to TRUE the function "emulates" word wrapping and doesn't include the part of the current word if reached the end of the area. Defaults to FALSE.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruFont::measureText()

Předcházející | Nahoru | Další
HaruPage::lineTo | Domů | HaruPage::moveTextPos


HaruPage::moveTextPos

(PECL haru:0.0.1)

HaruPage::moveTextPos — Move text position to the specified offset

Popis

bool HaruPage::moveTextPos ( float $x, float $y [, bool $set_leading] )

Moves text position to the specified offset. If the start position of the current line is (x1, y1), the start of the next line is (x1 + x, y1 + y). If optional parameter set_leading is TRUE, the function sets the text leading to -y. The default value of set_leading is FALSE.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruPage::moveToNextLine()

Předcházející | Nahoru | Další
HaruPage::measureText | Domů | HaruPage::moveTo


HaruPage::moveTo

(PECL haru:0.0.1)

HaruPage::moveTo — Set starting point for new drawing path

Popis

bool HaruPage::moveTo ( float $x, float $y )

Defines starting point for new drawing path.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruPage::moveTextPos | Domů | HaruPage::moveToNextLine


HaruPage::moveToNextLine

(PECL haru:0.0.1)

HaruPage::moveToNextLine — Move text position to the start of the next line

Popis

bool HaruPage::moveToNextLine ( void )

Moves text position to the start of the next line.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruPage::moveTextPos()

Předcházející | Nahoru | Další
HaruPage::moveTo | Domů | HaruPage::rectangle


HaruPage::rectangle

(PECL haru:0.0.1)

HaruPage::rectangle — Append a rectangle to the current path

Popis

bool HaruPage::rectangle ( float $x, float $y, float $width, float $height )

Appends a rectangle to the current drawing path.

Seznam parametrů

x

The left border of the rectangle.

y

The lower border of the rectangle.

width

The width of the rectangle.

height

The height of the rectangle.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruPage::moveToNextLine | Domů | HaruPage::setCharSpace


HaruPage::setCharSpace

(PECL haru:0.0.1)

HaruPage::setCharSpace — Set character spacing for the page

Popis

bool HaruPage::setCharSpace ( float $char_space )

Defines character spacing for the page.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruPage::getCharSpace()

Předcházející | Nahoru | Další
HaruPage::rectangle | Domů | HaruPage::setCMYKFill


HaruPage::setCMYKFill

(PECL haru:0.0.1)

HaruPage::setCMYKFill — Set filling color for the page

Popis

bool HaruPage::setCMYKFill ( float $c, float $m, float $y, float $k )

Defines filling color for the page.

Seznam parametrů

c

m

y

k

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruPage::getCMYKFill()

Předcházející | Nahoru | Další
HaruPage::setCharSpace | Domů | HaruPage::setCMYKStroke


HaruPage::setCMYKStroke

(PECL haru:0.0.1)

HaruPage::setCMYKStroke — Set stroking color for the page

Popis

bool HaruPage::setCMYKStroke ( float $c, float $m, float $y, float $k )

Defines stroking color for the page.

Seznam parametrů

c

m

y

k

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruPage::getCMYKStroke()

Předcházející | Nahoru | Další
HaruPage::setCMYKFill | Domů | HaruPage::setDash


HaruPage::setDash

(PECL haru:0.0.1)

HaruPage::setDash — Set the dash pattern for the page

Popis

bool HaruPage::setDash ( array $pattern, int $phase )

Defines the dash pattern for the page.

Seznam parametrů

pattern

An array (8 elements max) which contains a pattern of dashes and gaps used for lines on the page.

phase

The phase on which the pattern begins.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruPage::getDash()

Předcházející | Nahoru | Další
HaruPage::setCMYKStroke | Domů | HaruPage::setFlatness


HaruPage::setFlatness

(PECL haru:0.0.1)

HaruPage::setFlatness — Set flatness for the page

Popis

bool HaruPage::setFlatness ( float $flatness )

Defines flatness for the page.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruPage::getFlatness()

Předcházející | Nahoru | Další
HaruPage::setDash | Domů | HaruPage::setFontAndSize


HaruPage::setFontAndSize

(PECL haru:0.0.1)

HaruPage::setFontAndSize — Set font and fontsize for the page

Popis

bool HaruPage::setFontAndSize ( object $font, float $size )

Defines current font and its size for the page.

Seznam parametrů

font

A valid HaruFont instance.

size

The size of the font.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruDoc::getFont()

Předcházející | Nahoru | Další
HaruPage::setFlatness | Domů | HaruPage::setGrayFill


HaruPage::setGrayFill

(PECL haru:0.0.1)

HaruPage::setGrayFill — Set filling color for the page

Popis

bool HaruPage::setGrayFill ( float $value )

Defines filling color for the page.

Seznam parametrů

value

The value of gray level between 0 and 1.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruPage::getGrayFill()

Předcházející | Nahoru | Další
HaruPage::setFontAndSize | Domů | HaruPage::setGrayStroke


HaruPage::setGrayStroke

(PECL haru:0.0.1)

HaruPage::setGrayStroke — Sets stroking color for the page

Popis

bool HaruPage::setGrayStroke ( float $value )

Defines stroking color for the page.

Seznam parametrů

value

The value of gray level between 0 and 1.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruPage::getGrayStroke()

Předcházející | Nahoru | Další
HaruPage::setGrayFill | Domů | HaruPage::setHeight


HaruPage::setHeight

(PECL haru:0.0.1)

HaruPage::setHeight — Set height of the page

Popis

bool HaruPage::setHeight ( float $height )

Defines height of the page.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruPage::getHeight()

Předcházející | Nahoru | Další
HaruPage::setGrayStroke | Domů | HaruPage::setHorizontalScaling


HaruPage::setHorizontalScaling

(PECL haru:0.0.1)

HaruPage::setHorizontalScaling — Set horizontal scaling for the page

Popis

bool HaruPage::setHorizontalScaling ( float $scaling )

Defines horizontal scaling for text showing on the page. The initial value is 100.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruPage::getHorizontalScaling()

Předcházející | Nahoru | Další
HaruPage::setHeight | Domů | HaruPage::setLineCap


HaruPage::setLineCap

(PECL haru:0.0.1)

HaruPage::setLineCap — Set the shape to be used at the ends of lines

Popis

bool HaruPage::setLineCap ( int $cap )

Defines the shape to be used at the ends of lines.

Seznam parametrů

cap

Must be one of the following values:

HaruPage::BUTT_END - the line is squared off at the endpoint of the path.
HaruPage::ROUND_END - the end of the line becomes a semicircle with center in the end point of the path.
HaruPage::PROJECTING_SCUARE_END - the line continues to the point that exceeds half of the stroke width the end point.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruPage::getLineCap()

Předcházející | Nahoru | Další
HaruPage::setHorizontalScaling | Domů | HaruPage::setLineJoin


HaruPage::setLineJoin

(PECL haru:0.0.1)

HaruPage::setLineJoin — Set line join style for the page

Popis

bool HaruPage::setLineJoin ( int $join )

Defines line join style for the page.

Seznam parametrů

join

Must be one of the following values:

HaruPage::MITER_JOIN
HaruPage::ROUND_JOIN
HaruPage::BEVEL_JOIN

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruPage::getLineJoin()

Předcházející | Nahoru | Další
HaruPage::setLineCap | Domů | HaruPage::setLineWidth


HaruPage::setLineWidth

(PECL haru:0.0.1)

HaruPage::setLineWidth — Set line width for the page

Popis

bool HaruPage::setLineWidth ( float $width )

Defines line width for the page.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruPage::getLineWidth()

Předcházející | Nahoru | Další
HaruPage::setLineJoin | Domů | HaruPage::setMiterLimit


HaruPage::setMiterLimit

(PECL haru:0.0.1)

HaruPage::setMiterLimit — Set the current value of the miter limit of the page

Popis

bool HaruPage::setMiterLimit ( float $limit )

Defines the current value of the miter limit of the page.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruPage::getMiterLimit()

Předcházející | Nahoru | Další
HaruPage::setLineWidth | Domů | HaruPage::setRGBFill


HaruPage::setRGBFill

(PECL haru:0.0.1)

HaruPage::setRGBFill — Set filling color for the page

Popis

bool HaruPage::setRGBFill ( float $r, float $g, float $b )

Defines filling color for the page. All values must be between 0 and 1.

Seznam parametrů

r

g

b

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruPage::getRGBFill()

Předcházející | Nahoru | Další
HaruPage::setMiterLimit | Domů | HaruPage::setRGBStroke


HaruPage::setRGBStroke

(PECL haru:0.0.1)

HaruPage::setRGBStroke — Set stroking color for the page

Popis

bool HaruPage::setRGBStroke ( float $r, float $g, float $b )

Defines stroking color for the page. All values must be between 0 and 1.

Seznam parametrů

r

g

b

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruPage::getRGBStroke()

Předcházející | Nahoru | Další
HaruPage::setRGBFill | Domů | HaruPage::setRotate


HaruPage::setRotate

(PECL haru:0.0.1)

HaruPage::setRotate — Set rotation angle of the page

Popis

bool HaruPage::setRotate ( int $angle )

Defines rotation angle of the page.

Seznam parametrů

angle

Must be a multiple of 90 degrees.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruPage::setRGBStroke | Domů | HaruPage::setSize


HaruPage::setSize

(PECL haru:0.0.1)

HaruPage::setSize — Set size and direction of the page

Popis

bool HaruPage::setSize ( int $size, int $direction )

Changes size and direction of the page to a predefined format.

Seznam parametrů

size

Must be one of the following values:

HaruPage::SIZE_LETTER
HaruPage::SIZE_LEGAL
HaruPage::SIZE_A3
HaruPage::SIZE_A4
HaruPage::SIZE_A5
HaruPage::SIZE_B4
HaruPage::SIZE_B5
HaruPage::SIZE_EXECUTIVE
HaruPage::SIZE_US4x6
HaruPage::SIZE_US4x8
HaruPage::SIZE_US5x7
HaruPage::SIZE_COMM10

direction

Must be one of the following values:

HaruPage::PORTRAIT
HaruPage::LANDSCAPE

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruPage::setWidth()
HaruPage::setHeight()

Předcházející | Nahoru | Další
HaruPage::setRotate | Domů | HaruPage::setSlideShow


HaruPage::setSlideShow

(PECL haru:0.0.1)

HaruPage::setSlideShow — Set transition style for the page

Popis

bool HaruPage::setSlideShow ( int $type, float $disp_time, float $trans_time )

Defines transition style for the page.

Seznam parametrů

type

Must be one of the following values:

HaruPage::TS_WIPE_RIGHT
HaruPage::TS_WIPE_LEFT
HaruPage::TS_WIPE_UP
HaruPage::TS_WIPE_DOWN
HaruPage::TS_BARN_DOORS_HORIZONTAL_OUT
HaruPage::TS_BARN_DOORS_HORIZONTAL_IN
HaruPage::TS_BARN_DOORS_VERTICAL_OUT
HaruPage::TS_BARN_DOORS_VERTICAL_IN
HaruPage::TS_BOX_OUT
HaruPage::TS_BOX_IN
HaruPage::TS_BLINDS_HORIZONTAL
HaruPage::TS_BLINDS_VERTICAL
HaruPage::TS_DISSOLVE
HaruPage::TS_GLITTER_RIGHT
HaruPage::TS_GLITTER_DOWN
HaruPage::TS_GLITTER_TOP_LEFT_TO_BOTTOM_RIGHT
HaruPage::TS_REPLACE

disp_time

The display duration of the page in seconds.

trans_time

The duration of the transition effect in seconds.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruPage::setSize | Domů | HaruPage::setTextLeading


HaruPage::setTextLeading

(PECL haru:0.0.1)

HaruPage::setTextLeading — Set text leading (line spacing) for the page

Popis

bool HaruPage::setTextLeading ( float $text_leading )

Defines line spacing for the page.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruPage::getTextLeading()

Předcházející | Nahoru | Další
HaruPage::setSlideShow | Domů | HaruPage::setTextMatrix


HaruPage::setTextMatrix

(PECL haru:0.0.1)

HaruPage::setTextMatrix — Set the current text transformation matrix of the page

Popis

bool HaruPage::setTextMatrix ( float $a, float $b, float $c, float $d, float $x, float $y )

Defines the text transformation matrix of the page.

Seznam parametrů

a

b

c

d

x

y

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruPage::getTextMatrix()

Předcházející | Nahoru | Další
HaruPage::setTextLeading | Domů | HaruPage::setTextRenderingMode


HaruPage::setTextRenderingMode

(PECL haru:0.0.1)

HaruPage::setTextRenderingMode — Set text rendering mode for the page

Popis

bool HaruPage::setTextRenderingMode ( int $mode )

Defines text rendering mode for the page.

Seznam parametrů

mode

Must be one of the following values:

HaruPage::FILL
HaruPage::STROKE
HaruPage::FILL_THEN_STROKE
HaruPage::INVISIBLE
HaruPage::FILL_CLIPPING
HaruPage::STROKE_CLIPPING
HaruPage::FILL_STROKE_CLIPPING
HaruPage::CLIPPING

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruPage::getTextRenderingMode()

Předcházející | Nahoru | Další
HaruPage::setTextMatrix | Domů | HaruPage::setTextRise


HaruPage::setTextRise

(PECL haru:0.0.1)

HaruPage::setTextRise — Set the current value of text rising

Popis

bool HaruPage::setTextRise ( float $rise )

Defines the current value of text rising.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruPage::getTextRise()

Předcházející | Nahoru | Další
HaruPage::setTextRenderingMode | Domů | HaruPage::setWidth


HaruPage::setWidth

(PECL haru:0.0.1)

HaruPage::setWidth — Set width of the page

Popis

bool HaruPage::setWidth ( float $width )

Defines width of the page.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruPage::getWidth()

Předcházející | Nahoru | Další
HaruPage::setTextRise | Domů | HaruPage::setWordSpace


HaruPage::setWordSpace

(PECL haru:0.0.1)

HaruPage::setWordSpace — Set word spacing for the page

Popis

bool HaruPage::setWordSpace ( float $word_space )

Defines word spacing for the page.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruPage::getWordSpace()

Předcházející | Nahoru | Další
HaruPage::setWidth | Domů | HaruPage::showText


HaruPage::showText

(PECL haru:0.0.1)

HaruPage::showText — Print text at the current position of the page

Popis

bool HaruPage::showText ( string $text )

Prints out the text at the current position of the page.

Seznam parametrů

text

The text to show.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruPage::showTextNextLine()
HaruPage::textOut()

Předcházející | Nahoru | Další
HaruPage::setWordSpace | Domů | HaruPage::showTextNextLine


HaruPage::showTextNextLine

(PECL haru:0.0.1)

HaruPage::showTextNextLine — Move the current position to the start of the next line and print the text

Popis

bool HaruPage::showTextNextLine ( string $text [, float $word_space [, float $char_space]] )

Moves the current position to the start of the next line and print out the text.

Seznam parametrů

text

The text to show.

word_space

The word spacing.

char_space

The character spacing.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruPage::showText()
HaruPage::textOut()

Předcházející | Nahoru | Další
HaruPage::showText | Domů | HaruPage::stroke


HaruPage::stroke

(PECL haru:0.0.1)

HaruPage::stroke — Paint current path

Popis

bool HaruPage::stroke ( [bool $close_path] )

Paints the current path.

Seznam parametrů

close_path

Closes the current path if set to TRUE. Defaults to FALSE.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Předcházející | Nahoru | Další
HaruPage::showTextNextLine | Domů | HaruPage::textOut


HaruPage::textOut

(PECL haru:0.0.1)

HaruPage::textOut — Print the text on the specified position

Popis

bool HaruPage::textOut ( float $x, float $y, string $text )

Prints the text on the specified position.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruPage::showTextNextLine()
HaruPage::showText()

Předcházející | Nahoru | Další
HaruPage::stroke | Domů | HaruPage::textRect


HaruPage::textRect

(PECL haru:0.0.1)

HaruPage::textRect — Print the text inside the specified region

Popis

bool HaruPage::textRect ( float $left, float $top, float $right, float $bottom, string $text [, int $align] )

Prints the text inside the specified region.

Seznam parametrů

left

Left border of the text area.

top

Top border of the text area.

right

Right border of the text area.

bottom

Lower border of the text area.

text

The text to print.

align

Text alignment. Must be one of the following values:

HaruPage::TALING_LEFT
HaruPage::TALING_RIGHT
HaruPage::TALING_CENTER
HaruPage::TALING_JUSTIFY

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws HaruException on error.

Viz také

HaruPage::showTextNextLine()
HaruPage::showText()
HaruPage::textOut()

Předcházející | Nahoru | Další
HaruPage::textOut | Domů | LV. hash Functions


hash

(PHP 5 >= 5.1.2, PECL hash:1.1-1.5)

hash — Generate a hash value (message digest)

Popis

string hash ( string $algo, string $data [, bool $raw_output] )

Seznam parametrů

algo

Name of selected hashing algorithm (i.e. "md5", "sha256", "haval160,4", etc..)

data

Message to be hashed.

raw_output

When set to TRUE, outputs raw binary data. Default value (FALSE) outputs lowercase hexits.

Návratové hodnoty

Returns a string containing the calculated message digest as lowercase hexits unless raw_output is set to true in which case the raw binary representation of the message digest is returned.

Příklady

Příklad 723. A hash() example

<?php
echo hash('ripemd160', 'The quick brown fox jumped over the lazy dog.');
?>

Výše uvedený příklad vypíše:

ec457d0a974c48d5685a7efa03d137dc8bbde7e3

Viz také

hash_file()
hash_hmac()
hash_init()

Předcházející | Nahoru | Další
hash_update | Domů | LVI. HTTP


hash_algos

(PHP 5 >= 5.1.2, PECL hash:1.1-1.5)

hash_algos — Return a list of registered hashing algorithms

Popis

array hash_algos ( void )

Návratové hodnoty

Returns a numerically indexed array containing the list of supported hashing algorithms.

Příklady

Příklad 716. hash_algos() example

As of PHP 5.1.2, hash_algos() will return the following list of algorithm names.

<?php
print_r(hash_algos());
?>

Výše uvedený příklad vypíše:

Array
(
    [0] => md4
    [1] => md5
    [2] => sha1
    [3] => sha256
    [4] => sha384
    [5] => sha512
    [6] => ripemd128
    [7] => ripemd160
    [8] => whirlpool
    [9] => tiger128,3
    [10] => tiger160,3
    [11] => tiger192,3
    [12] => tiger128,4
    [13] => tiger160,4
    [14] => tiger192,4
    [15] => snefru
    [16] => gost
    [17] => adler32
    [18] => crc32
    [19] => crc32b
    [20] => haval128,3
    [21] => haval160,3
    [22] => haval192,3
    [23] => haval224,3
    [24] => haval256,3
    [25] => haval128,4
    [26] => haval160,4
    [27] => haval192,4
    [28] => haval224,4
    [29] => haval256,4
    [30] => haval128,5
    [31] => haval160,5
    [32] => haval192,5
    [33] => haval224,5
    [34] => haval256,5
)

Předcházející | Nahoru | Další
LV. hash Functions | Domů | hash_file


hash_file

(PHP 5 >= 5.1.2, PECL hash:1.1-1.5)

hash_file — Generate a hash value using the contents of a given file

Popis

string hash_file ( string $algo, string $filename [, bool $raw_output] )

Seznam parametrů

algo

Name of selected hashing algorithm (i.e. "md5", "sha256", "haval160,4", etc..)

filename

URL describing location of file to be hashed; Supports fopen wrappers.

raw_output

When set to TRUE, outputs raw binary data. Default value (FALSE) outputs lowercase hexits.

Návratové hodnoty

Returns a string containing the calculated message digest as lowercase hexits unless raw_output is set to true in which case the raw binary representation of the message digest is returned.

Příklady

Příklad 717. Using hash_file()

<?php
/* Create a file to calculate hash of */
file_put_contents('example.txt', 'The quick brown fox jumped over the lazy dog.');

echo hash_file('md5', 'example.txt');
?>

Výše uvedený příklad vypíše:

5c6ffbdd40d9556b73a21e63c3e0e904

Viz také

hash()
hash_hmac_file()
hash_update_file()

Předcházející | Nahoru | Další
hash_algos | Domů | hash_final


hash_final

(PHP 5 >= 5.1.2, PECL hash:1.1-1.5)

hash_final — Finalize an incremental hash and return resulting digest

Popis

string hash_final ( resource $context [, bool $raw_output] )

Seznam parametrů

context

Hashing context returned by hash_init().

raw_output

When set to TRUE, outputs raw binary data. Default value (FALSE) outputs lowercase hexits.

Návratové hodnoty

Returns a string containing the calculated message digest as lowercase hexits unless raw_output is set to true in which case the raw binary representation of the message digest is returned.

Příklady

Příklad 718. hash_final() example

<?php
$ctx = hash_init('sha1');
hash_update($ctx, 'The quick brown fox jumped over the lazy dog.');
echo hash_final($ctx);
?>

Výše uvedený příklad vypíše:

c0854fb9fb03c41cce3802cb0d220529e6eef94e

Viz také

hash_init()
hash_update()
hash_update_stream()
hash_update_file()

Předcházející | Nahoru | Další
hash_file | Domů | hash_hmac_file


hash_hmac

(PHP 5 >= 5.1.2, PECL hash:1.1-1.5)

hash_hmac — Generate a keyed hash value using the HMAC method

Popis

string hash_hmac ( string $algo, string $data, string $key [, bool $raw_output] )

Seznam parametrů

algo

Name of selected hashing algorithm (i.e. "md5", "sha256", "haval160,4", etc..)

data

Message to be hashed.

key

Shared secret key used for generating the HMAC variant of the message digest.

raw_output

When set to TRUE, outputs raw binary data. Default value (FALSE) outputs lowercase hexits.

Návratové hodnoty

Returns a string containing the calculated message digest as lowercase hexits unless raw_output is set to true in which case the raw binary representation of the message digest is returned.

Příklady

Příklad 720. hash_hmac() example

<?php
echo hash_hmac('ripemd160', 'The quick brown fox jumped over the lazy dog.', 'secret');
?>

Výše uvedený příklad vypíše:

b8e7ae12510bdfb1812e463a7f086122cf37e4f7

Viz také

hash()
hash_init()
hash_hmac_file()

Předcházející | Nahoru | Další
hash_hmac_file | Domů | hash_init


hash_hmac_file

(PHP 5 >= 5.1.2, PECL hash:1.1-1.5)

hash_hmac_file — Generate a keyed hash value using the HMAC method and the contents of a given file

Popis

string hash_hmac_file ( string $algo, string $filename, string $key [, bool $raw_output] )

Seznam parametrů

algo

Name of selected hashing algorithm (i.e. "md5", "sha256", "haval160,4", etc..)

filename

URL describing location of file to be hashed; Supports fopen wrappers.

key

Shared secret key used for generating the HMAC variant of the message digest.

raw_output

When set to TRUE, outputs raw binary data. Default value (FALSE) outputs lowercase hexits.

Návratové hodnoty

Returns a string containing the calculated message digest as lowercase hexits unless raw_output is set to true in which case the raw binary representation of the message digest is returned.

Příklady

Příklad 719. hash_hmac_file() example

<?php
/* Create a file to calculate hash of */
file_put_contents('example.txt', 'The quick brown fox jumped over the lazy dog.');

echo hash_hmac_file('md5', 'example.txt', 'secret');
?>

Výše uvedený příklad vypíše:

7eb2b5c37443418fc77c136dd20e859c

Viz také

hash_hmac()
hash_file()

Předcházející | Nahoru | Další
hash_final | Domů | hash_hmac


hash_init

(PHP 5 >= 5.1.2, PECL hash:1.1-1.5)

hash_init — Initialize an incremental hashing context

Popis

resource hash_init ( string $algo [, int $options, string $key] )

Seznam parametrů

algo

Name of selected hashing algorithm (i.e. "md5", "sha256", "haval160,4", etc..)

options

Optional settings for hash generation, currently supports only one option: HASH_HMAC. When specified, the key must be specified.

key

When HASH_HMAC is specified for options, a shared secret key to be used with the HMAC hashing method must be supplied in this parameter.

Návratové hodnoty

Returns a Hashing Context resource for use with hash_update(), hash_update_stream(), hash_update_file(), and hash_final().

Příklady

Příklad 721. Incremental hashing example

<?php
$ctx = hash_init('md5');
hash_update($ctx, 'The quick brown fox ');
hash_update($ctx, 'jumped over the lazy dog.');
echo hash_final($ctx);
?>

Výše uvedený příklad vypíše:

5c6ffbdd40d9556b73a21e63c3e0e904

Viz také

hash()
hash_file()
hash_hmac()
hash_hmac_file()

Předcházející | Nahoru | Další
hash_hmac | Domů | hash_update_file


hash_update

(PHP 5 >= 5.1.2, PECL hash:1.1-1.5)

hash_update — Pump data into an active hashing context

Popis

bool hash_update ( resource $context, string $data )

Seznam parametrů

context

Hashing context returned by hash_init().

data

Message to be included in the hash digest.

Návratové hodnoty

Returns TRUE.

Viz také

hash_init()
hash_update_file()
hash_update_stream()
hash_final()

Předcházející | Nahoru | Další
hash_update_stream | Domů | hash


hash_update_file

(PHP 5 >= 5.1.2, PECL hash:1.1-1.5)

hash_update_file — Pump data into an active hashing context from a file

Popis

bool hash_update_file ( resource $context, string $filename [, resource $context] )

Seznam parametrů

context

Hashing context returned by hash_init().

filename

URL describing location of file to be hashed; Supports fopen wrappers.

context

Stream context as returned by stream_context_create().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

hash_init()
hash_update()
hash_update_stream()
hash_final()
hash()
hash_file()

Předcházející | Nahoru | Další
hash_init | Domů | hash_update_stream


hash_update_stream

(PHP 5 >= 5.1.2, PECL hash:1.1-1.5)

hash_update_stream — Pump data into an active hashing context from an open stream

Popis

int hash_update_stream ( resource $context, resource $handle [, int $length] )

Seznam parametrů

context

Hashing context returned by hash_init().

handle

Open file handle as returned by any stream creation function.

length

Maximum number of characters to copy from handle into the hashing context.

Návratové hodnoty

Actual number of bytes added to the hashing context from handle.

Příklady

Příklad 722. hash_update_stream() example

<?php
$fp = tmpfile();
fwrite($fp, 'The quick brown fox jumped over the lazy dog.');
rewind($fp);

$ctx = hash_init('md5');
hash_update_stream($ctx, $fp);
echo hash_final($ctx);
?>

Výše uvedený příklad vypíše:

5c6ffbdd40d9556b73a21e63c3e0e904

Viz také

hash_init()
hash_update()
hash_final()
hash()
hash_file()

Předcházející | Nahoru | Další
hash_update_file | Domů | hash_update


htmlspecialchars_decode

(PHP 5 >= 5.1.0)

htmlspecialchars_decode — Convert special HTML entities back to characters

Popis

string htmlspecialchars_decode ( string $string [, int $quote_style] )

This function is the opposite of htmlspecialchars(). It converts special HTML entities back to characters.

The converted entities are: &amp;, &quot; (when ENT_NOQUOTES is not set), &#039; (when ENT_QUOTES is set), &lt; and &gt;.

Seznam parametrů

string

The string to decode

quote_style

The quote style. One of the following constants:

Tabulka 300. quote_style constants

Constant Name | Description
ENT_COMPAT | Will convert double-quotes and leave single-quotes alone (default)
ENT_QUOTES | Will convert both double and single quotes
ENT_NOQUOTES | Will leave both double and single quotes unconverted

Návratové hodnoty

Returns the decoded string.

Příklady

Příklad 2197. A htmlspecialchars_decode() example

<?php
$str = '<p>this -&gt; &quot;</p>';

echo htmlspecialchars_decode($str);

// note that here the quotes aren't converted
echo htmlspecialchars_decode($str, ENT_NOQUOTES);
?>

Výše uvedený příklad vypíše:

<p>this -> "</p>
<p>this -> &quot;</p>

Viz také

htmlspecialchars()
html_entity_decode()
get_html_translation_table()

Předcházející | Nahoru | Další
htmlentities | Domů | htmlspecialchars


http_build_cookie

(PECL pecl_http:1.2.0-1.5.5)

http_build_cookie — Build cookie string

Popis

string http_build_cookie ( array $cookie )

Build a cookie string from an array/object like returned by http_parse_cookie().

Seznam parametrů

cookie

a cookie list like returned from http_parse_cookie()

Návratové hodnoty

Returns the cookie(s) as string.

Viz také

http_parse_cookie()

Předcházející | Nahoru | Další
http_match_request_header | Domů | http_negotiate_charset


http_build_str

(PECL pecl_http:0.23.0-1.5.5)

http_build_str — Build query string

Popis

string http_build_str ( array $query [, string $prefix [, string $arg_separator]] )

Opponent to parse_str().

Seznam parametrů

query

associative array of query string parameters

prefix

top level prefix

arg_separator

argument separator to use (by default the INI setting arg_separator.output will be used, or "&" if neither is set

Návratové hodnoty

Returns the built query as string on success or FALSE on failure.

Viz také

standard http_build_query()
http_build_url()

Předcházející | Nahoru | Další
http_throttle | Domů | http_build_url


http_build_url

(PECL pecl_http:0.21.0-1.5.5)

http_build_url — Build an URL

Popis

string http_build_url ( [mixed $url [, mixed $parts [, int $flags = HTTP_URL_REPLACE [, array &$new_url]]]] )

Build an URL.

The parts of the second URL will be merged into the first according to the flags argument.

Seznam parametrů

url

(part(s) of) an URL in form of a string or associative array like parse_url() returns

parts

same as the first argument

flags

a bitmask of binary or'ed HTTP_URL constants; HTTP_URL_REPLACE is the default

new_url

if set, it will be filled with the parts of the composed url like parse_url() would return

Návratové hodnoty

Returns the new URL as string on success or FALSE on failure.

Příklady

Příklad 751. A http_build_url() example

<?php
echo http_build_url("http://user@www.example.com/pub/index.php?a=b#files",
    array(
        "scheme" => "ftp",
        "host" => "ftp.example.com",
        "path" => "files/current/",
        "query" => "a=c"
    ),
    HTTP_URL_STRIP_AUTH | HTTP_URL_JOIN_PATH | HTTP_URL_JOIN_QUERY | HTTP_URL_STRIP_FRAGMENT
);
?>

Výše uvedený příklad vypíše:

ftp://ftp.example.com/pub/files/current/?a=b&a=c

Viz také

parse_url()
http_build_str()

Předcházející | Nahoru | Další
http_build_str | Domů | LVII. Hyperwave Functions


http_cache_etag

(PECL pecl_http:0.1.0-1.5.5)

http_cache_etag — Caching by ETag

Popis

bool http_cache_etag ( [string $etag] )

Attempts to cache the sent entity by its ETag, either supplied or generated by the hash algorithm specified by the INI setting http.etag.mode.

If the clients If-None-Match header matches the supplied/calculated ETag, the body is considered cached on the clients side and a 304 Not Modified status code is issued.

A log entry is written to the cache log if the INI setting http.log.cache is set and the cache attempt was successful.

Poznámka: This function may be used in conjunction with http_send_data(), http_send_file() , a http_send_stream().

If this function is used outside the http_send_*() API, it facilitates the ob_etaghandler().

Seznam parametrů

etag

custom ETag

Návratové hodnoty

Returns FALSE or exits on success with 304 Not Modified if the entity is cached. See the INI setting http.force_exit for what "exits" means.

Příklady

Příklad 733. A http_cache_etag() example

<?php
http_cache_etag();
http_send_data("data");
?>

Viz také

http_cache_last_modified()
ob_etaghandler()
http_match_etag()
the HttpResponse class if you are using PHP-5.1 and above

Předcházející | Nahoru | Další
HttpResponse::status | Domů | http_cache_last_modified


http_cache_last_modified

(PECL pecl_http:0.1.0-1.5.5)

http_cache_last_modified — Caching by last modification

Popis

bool http_cache_last_modified ( [int $timestamp_or_expires] )

Attempts to cache the sent entity by its last modification date.

If the supplied argument is greater than 0, it is handled as timestamp and will be sent as date of last modification. If it is 0 or omitted, the current time will be sent as Last-Modified date. If it's negative, it is handled as expiration time in seconds, which means that if the requested last modification date is not between the calculated timespan, the Last-Modified header is updated and the actual body will be sent.

A log entry will be written to the cache log if the INI setting http.log.cache is set and the cache attempt was successful.

Poznámka: This function may be used in conjunction with http_send_data(), http_send_file() , a http_send_stream().

Seznam parametrů

timestamp_or_expires

Unix timestamp

Návratové hodnoty

Returns FALSE or exits on success with 304 Not Modified if the entity is cached. See the INI setting http.force_exit for what "exits" means.

Příklady

Příklad 734. A http_cache_last_modified() example

Caching for 5 seconds.

<?php
http_cache_last_modified(-5);
printf("%s\n", http_date());
?>

Viz také

http_cache_etag()
the HttpResponse class if you are using PHP-5.1 and above

Předcházející | Nahoru | Další
http_cache_etag | Domů | http_chunked_decode


http_chunked_decode

(PECL pecl_http:0.1.0-1.5.5)

http_chunked_decode — Decode chunked-encoded data

Popis

string http_chunked_decode ( string $encoded )

Decodes a string which is HTTP-chunked encoded.

Seznam parametrů

encoded

chunked encoded string

Návratové hodnoty

Returns the decoded string on success or FALSE on failure.

Příklady

Příklad 735. A http_chunked_decode() example

<?php
$string = "".
    "05\r\n".
    "this \r\n".
    "07\r\n".
    "string \r\n".
    "12\r\n".
    "is chunked encoded\r\n".
    "01\n\r\n".
    "00";
echo http_chunked_decode($string);
?>

Výše uvedený příklad vypíše:

this string is chunked encoded

Předcházející | Nahoru | Další
http_cache_last_modified | Domů | http_deflate


http_date

(PECL pecl_http:0.1.0-1.5.5)

http_date — Compose HTTP RFC compliant date

Popis

string http_date ( [int $timestamp] )

Compose a valid HTTP date regarding RFC 1123 looking like: Wed, 22 Dec 2004 11:34:47 GMT.

Seznam parametrů

timestamp

Unix timestamp; current time if omitted

Návratové hodnoty

Returns the HTTP date as string.

Viz také

date()

Předcházející | Nahoru | Další
http_get_request_headers | Domů | http_support


http_deflate

(PECL pecl_http:0.15.0-1.5.5)

http_deflate — Deflate data

Popis

string http_deflate ( string $data [, int $flags = 0] )

Compress data with gzip, zlib AKA deflate or raw deflate encoding.

See the deflate constants table for possible values for the flags parameter.

Seznam parametrů

data

String containing the data that should be encoded

flags

deflate options

Návratové hodnoty

Returns the encoded string on success, or NULL on failure.

Viz také

http_inflate()
HttpDeflateStream

Předcházející | Nahoru | Další
http_chunked_decode | Domů | http_inflate


http_get

(PECL pecl_http:0.1.0-1.5.5)

http_get — Perform GET request

Popis

string http_get ( string $url [, array $options [, array &$info]] )

Performs an HTTP GET request on the supplied url.

See the full list of request options.

Seznam parametrů

url

URL

options

request options

info

Will be filled with request/response information

Návratové hodnoty

Returns the HTTP response(s) as string on success, or FALSE on failure.

Příklady

Příklad 746. A http_get() example

<?php
$response = http_get("http://www.example.com/", array("timeout"=>1), $info);
print_r($info);
?>

Výše uvedený příklad vypíše:

array (
  'effective_url' => 'http://www.example.com/',
  'response_code' => 302,
  'connect_code' => 0,
  'filetime' => -1,
  'total_time' => 0.212348,
  'namelookup_time' => 0.038296,
  'connect_time' => 0.104144,
  'pretransfer_time' => 0.104307,
  'starttransfer_time' => 0.212077,
  'redirect_time' => 0,
  'redirect_count' => 0,
  'size_upload' => 0,
  'size_download' => 218,
  'speed_download' => 1026,
  'speed_upload' => 0,
  'header_size' => 307,
  'request_size' => 103,
  'ssl_verifyresult' => 0,
  'ssl_engines' =>
  array (
    0 => 'dynamic',
    1 => 'cswift',
    2 => 'chil',
    3 => 'atalla',
    4 => 'nuron',
    5 => 'ubsec',
    6 => 'aep',
    7 => 'sureware',
    8 => '4758cca',
  ),
  'content_length_download' => 218,
  'content_length_upload' => 0,
  'content_type' => 'text/html',
  'httpauth_avail' => 0,
  'proxyauth_avail' => 0,
  'num_connects' => 1,
  'os_errno' => 0,
  'error' => '',
)

Předcházející | Nahoru | Další
http_persistent_handles_clean | Domů | http_head


http_get_request_body

(PECL pecl_http:0.10.0-1.5.5)

http_get_request_body — Get request body as string

Popis

string http_get_request_body ( void )

Get the raw request body (e.g. POST or PUT data).

This function can not be used after http_get_request_body_stream() if the request method was another than POST.

Seznam parametrů

Návratové hodnoty

Returns the raw request body as string on success or NULL on failure.

Viz také

http_get_request_body_stream()
http_get_request_headers()
the HttpResponse class if you are using PHP-5.1 and above

Předcházející | Nahoru | Další
http_get_request_body_stream | Domů | http_get_request_headers


http_get_request_body_stream

(PECL pecl_http:0.22.0-1.5.5)

http_get_request_body_stream — Get request body as stream

Popis

resource http_get_request_body_stream ( void )

Create a stream to read the raw request body (e.g. POST or PUT data).

This function can only be used once if the request method was another than POST.

Seznam parametrů

Návratové hodnoty

Returns the raw request body as stream on success or NULL on failure.

Viz také

http_get_request_body()
http_get_request_headers()
the HttpResponse class if you are using PHP-5.1 and above

Předcházející | Nahoru | Další
http_inflate | Domů | http_get_request_body


http_get_request_headers

(PECL pecl_http:0.10.0-1.5.5)

http_get_request_headers — Get request headers as array

Popis

array http_get_request_headers ( void )

Get a list of incoming HTTP headers.

Seznam parametrů

Návratové hodnoty

Returns an associative array of incoming request headers.

Viz také

http_get_request_body()
http_get_request_body_stream()
the HttpResponse class if you are using PHP-5.1 and above

Předcházející | Nahoru | Další
http_get_request_body | Domů | http_date


http_head

(PECL pecl_http:0.1.0-1.5.5)

http_head — Perform HEAD request

Popis

string http_head ( [string $url [, array $options [, array &$info]]] )

Performs an HTTP HEAD request on the supplied url.

See the full list of request options.

Seznam parametrů

url

URL

options

request options

info

Request/response information

Návratové hodnoty

Returns the HTTP response(s) as string on success, or FALSE on failure.

Předcházející | Nahoru | Další
http_get | Domů | http_post_data


http_inflate

(PECL pecl_http:0.15.0-1.5.5)

http_inflate — Inflate data

Popis

string http_inflate ( string $data )

Decompress data compressed with either gzip, deflate AKA zlib or raw deflate encoding.

Seznam parametrů

data

string containing the compressed data

Návratové hodnoty

Returns the decoded string on success, or NULL on failure.

Viz také

http_deflate()
HttpInflateStream

Předcházející | Nahoru | Další
http_deflate | Domů | http_get_request_body_stream


http_match_etag

(PECL pecl_http:0.1.0-1.5.5)

http_match_etag — Match ETag

Popis

bool http_match_etag ( string $etag [, bool $for_range = FALSE] )

Matches the given ETag against the clients If-Match resp. If-None-Match HTTP headers.

Seznam parametrů

etag

the ETag to match

for_range

if set to TRUE, the header usually used to validate HTTP ranges will be checked

Návratové hodnoty

Returns TRUE if ETag matches or the header contained the asterisk ("*"), else FALSE.

Viz také

http_match_last_modified()
http_match_request_header()
http_cache_etag()
http_cache_last_modified()
ob_etaghandler()

Předcházející | Nahoru | Další
http_support | Domů | http_match_modified


http_match_modified

(PECL pecl_http:0.1.0-1.5.5)

http_match_modified — Match last modification

Popis

bool http_match_modified ( [int $timestamp [, bool $for_range = FALSE]] )

Matches the given Unix timestamp against the clients If-Modified-Since resp. If-Unmodified-Since HTTP headers.

Seznam parametrů

timestamp

Unix timestamp; current time, if omitted

for_range

if set to TRUE, the header usually used to validate HTTP ranges will be checked

Návratové hodnoty

Returns TRUE if timestamp represents an earlier date than the header, else FALSE.

Viz také

http_match_etag()
http_match_request_header()
http_cache_etag()
http_cache_last_modified()

Předcházející | Nahoru | Další
http_match_etag | Domů | http_match_request_header


http_match_request_header

(PECL pecl_http:0.10.0-1.5.5)

http_match_request_header — Match any header

Popis

bool http_match_request_header ( string $header, string $value [, bool $match_case = FALSE] )

Match an incoming HTTP header.

Seznam parametrů

header

the header name (case-insensitive)

value

the header value that should be compared

match_case

whether the value should be compared case sensitively

Návratové hodnoty

Returns TRUE if header value matches, else FALSE.

Viz také

http_match_etag()
http_match_last_modified()

Předcházející | Nahoru | Další
http_match_modified | Domů | http_build_cookie


http_negotiate_charset

(PECL pecl_http:0.1.0-1.5.5)

http_negotiate_charset — Negotiate clients preferred character set

Popis

string http_negotiate_charset ( array $supported [, array &$result] )

This function negotiates the clients preferred charset based on its Accept-Charset HTTP header. The qualifier is recognized and charsets without qualifier are rated highest.

Seznam parametrů

supported

array containing the supported charsets as values

result

will be filled with an array containing the negotiation results

Návratové hodnoty

Returns the negotiated charset or the default charset (i.e. first array entry) if none match.

Příklady

Příklad 737. Using http_negotiate_charset()

<?php
$charsets = array(
        'iso-8859-1', // default
        'iso-8859-2',
        'iso-8859-15',
        'utf-8'
);

$pref = http_negotiate_charset($charsets, $result);

if (strcmp($pref, 'iso-8859-1')) {
        iconv_set_encoding('internal_encoding', 'iso-8859-1');
        iconv_set_encoding('output_encoding', $pref);
        ob_start('ob_iconv_handler');
}

print_r($result);
?>

Předcházející | Nahoru | Další
http_build_cookie | Domů | http_negotiate_content_type


http_negotiate_content_type

(PECL pecl_http:0.19.0-1.5.5)

http_negotiate_content_type — Negotiate clients preferred content type

Popis

string http_negotiate_content_type ( array $supported [, array &$result] )

This function negotiates the clients preferred content type based on its Accept HTTP header. The qualifier is recognized and content types without qualifier are rated highest.

Seznam parametrů

supported

array containing the supported content types as values

result

will be filled with an array containing the negotiation results

Návratové hodnoty

Returns the negotiated content type or the default content type (i.e. first array entry) if none match.

Příklady

Příklad 738. Using http_negotiate_content_type()

<?php
$content_types = array('application/xhtml+xml', 'text/html');
http_send_content_type(http_negotiate_content_type($content_types));
?>

Předcházející | Nahoru | Další
http_negotiate_charset | Domů | http_negotiate_language


http_negotiate_language

(PECL pecl_http:0.1.0-1.5.5)

http_negotiate_language — Negotiate clients preferred language

Popis

string http_negotiate_language ( array $supported [, array &$result] )

This function negotiates the clients preferred language based on its Accept-Language HTTP header. The qualifier is recognized and languages without qualifier are rated highest. The qualifier will be decreased by 10% for partial matches (i.e. matching primary language).

Seznam parametrů

supported

array containing the supported languages as values

result

will be filled with an array containing the negotiation results

Návratové hodnoty

Returns the negotiated language or the default language (i.e. first array entry) if none match.

Příklady

Příklad 739. Using http_negotiate_language()

<?php
$langs = array(
        'en-US',// default
        'fr',
        'fr-FR',
        'de',
        'de-DE',
        'de-AT',
        'de-CH',
);

include './langs/'. http_negotiate_language($langs, $result) .'.php';

print_r($result);
?>

Předcházející | Nahoru | Další
http_negotiate_content_type | Domů | ob_deflatehandler


http_parse_cookie

(PECL pecl_http:0.20.0-1.5.5)

http_parse_cookie — Parse HTTP cookie

Popis

object http_parse_cookie ( string $cookie [, int $flags [, array $allowed_extras]] )

Parses HTTP cookies like sent in a response into a struct.

Seznam parametrů

cookie

string containing the value of a Set-Cookie response header

flags

parse flags (HTTP_COOKIE_PARSE_RAW)

allowed_extras

array containing recognized extra keys; by default all unknown keys will be treated as cookie names

Návratové hodnoty

Returns a stdClass object on success or FALSE on failure.

Příklady

Příklad 740. Using http_parse_cookie()

<?php
print_r(http_parse_cookie("foo=bar; bar=baz; path=/; domain=example.com; comment=; secure", 0, array("comment")));
?>

Výše uvedený příklad vypíše:

stdClass Object
(
  [cookies] => Array
  (
    [foo] => bar
    [bar] => baz
  )

  [extras] => Array
  (
    [comment] =>
  )

  [flags] => 16
  [expires] => 0
  [path] => /
  [domain] => example.com
)

Viz také

http_parse_headers()
http_parse_message()
http_build_cookie()

Předcházející | Nahoru | Další
ob_inflatehandler | Domů | http_parse_headers


http_parse_headers

(PECL pecl_http:0.10.0-1.5.5)

http_parse_headers — Parse HTTP headers

Popis

array http_parse_headers ( string $header )

Parses HTTP headers into an associative array.

Seznam parametrů

header

string containing HTTP headers

Návratové hodnoty

Returns an array on success, or FALSE on failure.

Příklady

Příklad 741. Using http_parse_headers()

<?php
$headers = "content-type: text/html; charset=UTF-8\r\n".
  "Server: Funky/1.0\r\n".
  "Set-Cookie: foo=bar\r\n".
  "Set-Cookie: baz=quux\r\n".
  "Folded: works\r\n\ttoo\r\n";
print_r(http_parse_headers($headers));
?>

Výše uvedený příklad vypíše:

Array
(
  [Content-Type] => text/html; chatset=UTF-8
  [Server] => Funky/1.0
  [Set-Cookie] => Array
  (
    [0] => foo=bar
    [1] => baz=quux
  )
  [Folded] => works
    too
)

Viz také

http_parse_message()
http_parse_cookie()

Předcházející | Nahoru | Další
http_parse_cookie | Domů | http_parse_message


http_parse_message

(PECL pecl_http:0.12.0-1.5.5)

http_parse_message — Parse HTTP messages

Popis

object http_parse_message ( string $message )

Parses the HTTP message into a simple recursive object.

Seznam parametrů

message

string containing a single HTTP message or several consecutive HTTP messages

Návratové hodnoty

Returns a hierarchical object structure of the parsed messages.

Příklady

Příklad 742. Using http_parse_message()

<?php
define ('URL', 'http://www.example.com/');
print_r(http_parse_message(http_get(URL, array('redirect' => 3))));
?>

Výše uvedený příklad vypíše něco jako:

stdClass object
(
  [type] => 2
  [httpVersion] => 1.1
  [responseCode] => 200
  [headers] => Array
  (
    [Content-Length] => 3
    [Server] => Apache
  )
  [body] => Hi!
  [parentMessage] => stdClass object
  (
    [type] => 2
    [httpVersion] => 1.1
    [responseCode] => 302
    [headers] => Array
    (
      [Content-Length] => 0
      [Location] => ...
    )
    [body] =>
    [parentMessage] => ...
  )
)

Viz také

http_parse_headers()
the HttpMessage class

Předcházející | Nahoru | Další
http_parse_headers | Domů | http_parse_params


http_parse_params

(PECL pecl_http:1.0.0-1.5.5)

http_parse_params — Parse parameter list

Popis

object http_parse_params ( string $param [, int $flags = HTTP_PARAMS_DEFAULT] )

Parse parameter list.

See the params parsing constants table for possible values of the flags argument.

Seznam parametrů

param

Parameters

flags

Parse flags

Návratové hodnoty

Returns parameter list as stdClass object.

Příklady

Příklad 743. A http_parse_params() example

<?php
var_dump(http_parse_params("text/html; charset=\"utf8\""));
?>

Výše uvedený příklad vypíše:

object(stdClass)#1 (1) {
  ["params"]=>
  array(2) {
    [0]=>
    string(9) "text/html"
    [1]=>
    array(1) {
      ["charset"]=>
      string(4) "utf8"
    }
  }
}

Viz také

http_parse_headers()
http_parse_cookie()
http_parse_message()

Předcházející | Nahoru | Další
http_parse_message | Domů | http_persistent_handles_count


http_persistent_handles_clean

(PECL pecl_http:1.5.0-1.5.5)

http_persistent_handles_clean — Clean up persistent handles

Popis

string http_persistent_handles_clean ( [string $ident] )

Clean up (close) persistent handles, optionally identified with ident.

Seznam parametrů

clean

the identification string

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

http_persistent_handles_ident()
http_persistent_handles_count()

Předcházející | Nahoru | Další
http_persistent_handles_ident | Domů | http_get


http_persistent_handles_count

(PECL pecl_http:1.5.0-1.5.5)

http_persistent_handles_count — Stat persistent handles

Popis

object http_persistent_handles_count ( void )

List statistics about persistent handles usage.

Seznam parametrů

Návratové hodnoty

Returns persistent handles statistics as stdClass object on success or FALSE on failure.

Příklady

Příklad 744. A http_persistent_handles_count() example

<?php
print_r(http_persistent_handles_count());
?>

Výše uvedený příklad vypíše:

stdClass Object
(
    [http_request] => Array
        (
            [GLOBAL] => Array
                (
                    [used] => 0
                    [free] => 1
                )

        )

    [http_request_datashare] => Array
        (
            [GLOBAL] => Array
                (
                    [used] => 1
                    [free] => 0
                )

        )

    [http_request_pool] => Array
        (
        )

)

Viz také

http_persistent_handles_ident()
http_persistent_handles_clean()

Předcházející | Nahoru | Další
http_parse_params | Domů | http_persistent_handles_ident


http_persistent_handles_ident

(PECL pecl_http:1.5.0-1.5.5)

http_persistent_handles_ident — Get/set ident of persistent handles

Popis

string http_persistent_handles_ident ( string $ident )

Query or define the ident of persistent handles.

Seznam parametrů

ident

the identification string

Návratové hodnoty

Returns the prior ident as string on success or FALSE on failure.

Příklady

Příklad 745. A http_persistent_handles_ident() example

<?php
echo http_persistent_handles_ident("CUSTOM"), "\n";
echo http_persistent_handles_ident("MyApp1"), "\n";
http_get("http://www.example.com/");
print_r(http_persistent_handles_count());
?>

Výše uvedený příklad vypíše:

GLOBAL
CUSTOM
stdClass Object
(
    [http_request] => Array
        (
            [MyApp1] => Array
                (
                    [used] => 0
                    [free] => 1
                )

        )

    [http_request_datashare] => Array
        (
            [GLOBAL] => Array
                (
                    [used] => 1
                    [free] => 0
                )

        )

    [http_request_pool] => Array
        (
        )

)

Viz také

http_persistent_handles_count()
http_persistent_handles_clean()

Předcházející | Nahoru | Další
http_persistent_handles_count | Domů | http_persistent_handles_clean


http_post_data

(PECL pecl_http:0.1.0-1.5.5)

http_post_data — Perform POST request with pre-encoded data

Popis

string http_post_data ( string $url [, string $data [, array $options [, array &$info]]] )

Performs an HTTP POST request on the supplied url.

See the full list of request options.

Seznam parametrů

url

URL

data

String containing the pre-encoded post data

options

request options

info

Request/response information

Návratové hodnoty

Returns the HTTP response(s) as string on success, or FALSE on failure.

Předcházející | Nahoru | Další
http_head | Domů | http_post_fields


http_post_fields

(PECL pecl_http:0.10.0-1.5.5)

http_post_fields — Perform POST request with data to be encoded

Popis

string http_post_fields ( string $url [, array $data [, array $files [, array $options [, array &$info]]]] )

Performs an HTTP POST request on the supplied url.

See the full list of request options.

Seznam parametrů

url

URL

data

Associative array of POST values

files

Array of files to post

options

request options

info

Request/response information

Návratové hodnoty

Returns the HTTP response(s) as string on success, or FALSE on failure.

Příklady

Příklad 747. A http_post_fields() example

<?php
$fields = array(
    'name' => 'mike',
    'pass' => 'se_ret'
);
$files = array(
    array(
        'name' => 'uimg',
        'type' => 'image/jpeg',
        'file' => './profile.jpg',
    )
);

$response = http_post_fields("http://www.example.com/", $fields, $files);
?>

Předcházející | Nahoru | Další
http_post_data | Domů | http_put_data


http_put_data

(PECL pecl_http:0.25.0-1.5.5)

http_put_data — Perform PUT request with data

Popis

string http_put_data ( string $url [, string $data [, array $options [, array &$info]]] )

Performs an HTTP PUT request on the supplied url.

See the full list of request options.

Seznam parametrů

url

URL

data

PUT request body

options

request options

info

Request/response information

Návratové hodnoty

Returns the HTTP response(s) as string on success, or FALSE on failure.

Předcházející | Nahoru | Další
http_post_fields | Domů | http_put_file


http_put_file

(PECL pecl_http:0.10.0-1.5.5)

http_put_file — Perform PUT request with file

Popis

string http_put_file ( string $url [, string $file [, array $options [, array &$info]]] )

Performs an HTTP PUT request on the supplied url.

See the full list of request options.

Seznam parametrů

url

URL

file

The file to put

options

request options

info

Request/response information

Návratové hodnoty

Returns the HTTP response(s) as string on success, or FALSE on failure.

Předcházející | Nahoru | Další
http_put_data | Domů | http_put_stream


http_put_stream

(PECL pecl_http:0.10.0-1.5.5)

http_put_stream — Perform PUT request with stream

Popis

string http_put_stream ( string $url [, resource $stream [, array $options [, array &$info]]] )

Performs an HTTP PUT request on the supplied url.

See the full list of request options.

Seznam parametrů

url

URL

stream

The stream to read the PUT request body from

options

request options

info

Request/response information

Návratové hodnoty

Returns the HTTP response(s) as string on success, or FALSE on failure.

Předcházející | Nahoru | Další
http_put_file | Domů | http_request_method_exists


http_redirect

(PECL pecl_http:0.1.0-1.5.5)

http_redirect — Issue HTTP redirect

Popis

void http_redirect ( [string $url [, array $params [, bool $session = FALSE [, int $status]]]] )

Redirect to the given url.

The supplied url will be expanded with http_build_url(), the params array will be treated with http_build_str() and the session identification will be appended if session is true. The HTTP response code will be set according to status. You can use one of the redirect constants for convenience. Please see » RFC 2616 for which redirect response code to use in which situation. By default PHP will decide which response status fits best.

To be RFC compliant, "Redirecting to <a>URL</a>." will be displayed, if the client doesn't redirect immediately, and the request method was another one than HEAD.

A log entry will be written to the redirect log, if the INI setting http.log.redirect is set and the redirect attempt was successful.

Seznam parametrů

url

the URL to redirect to

params

associative array of query parameters

session

whether to append session information

status

custom response status code

Návratové hodnoty

Returns FALSE or exits on success with the specified redirection status code. See the INI setting http.force_exit for what "exits" means.

Příklady

Příklad 748. A http_redirect() example

<?php
http_redirect("relpath", array("name" => "value"), true, HTTP_REDIRECT_PERM);
?>

Výše uvedený příklad vypíše:

HTTP/1.1 301 Moved Permanently
X-Powered-By: PHP/5.2.2
Content-Type: text/html
Location: http://www.example.com/curdir/relpath?name=value&PHPSESSID=abc

Redirecting to <a href="http://www.example.com/curdir/relpath?name=value&PHPSESSID=abc">http://www.example.com/curdir/relpath?name=value&PHPSESSID=abc</a>.

Viz také

the HttpResponse class if you are using PHP-5.1 and above

Předcházející | Nahoru | Další
http_request_body_encode | Domů | http_send_content_disposition


http_request

(PECL pecl_http:1.0.0-1.5.5)

http_request — Perform custom request

Popis

string http_request ( int $method [, string $url [, string $body [, array $options [, array &$info]]]] )

Performs a custom HTTP request on the supplied url.

See the full list of request options.

Seznam parametrů

method

Request method

url

URL

body

Request body

options

request options

info

Request/response information

Návratové hodnoty

Returns the HTTP response(s) as string on success, or FALSE on failure.

Předcházející | Nahoru | Další
http_request_method_unregister | Domů | http_request_body_encode


http_request_body_encode

(PECL pecl_http:1.0.0-1.5.5)

http_request_body_encode — Encode request body

Popis

string http_request_body_encode ( array $fields, array $files )

Generate x-www-form-urlencoded resp. form-data encoded request body.

Seznam parametrů

fields

POST fields

files

POST files

Návratové hodnoty

Returns encoded string on success, or FALSE on failure

Předcházející | Nahoru | Další
http_request | Domů | http_redirect


http_request_method_exists

(PECL pecl_http:0.10.0-1.5.5)

http_request_method_exists — Check whether request method exists

Popis

int http_request_method_exists ( mixed $method )

Check if a request method is registered (or available by default).

Seznam parametrů

method

request method name or ID

Návratové hodnoty

Returns TRUE if the request method is known, else FALSE.

Předcházející | Nahoru | Další
http_put_stream | Domů | http_request_method_name


http_request_method_name

(PECL pecl_http:0.10.0-1.5.5)

http_request_method_name — Get request method name

Popis

string http_request_method_name ( int $method )

Get the literal string representation of a standard or registered request method.

Seznam parametrů

method

request method ID

Návratové hodnoty

Returns the request method name as string on success, or FALSE on failure.

Předcházející | Nahoru | Další
http_request_method_exists | Domů | http_request_method_register


http_request_method_register

(PECL pecl_http:0.10.0-1.5.5)

http_request_method_register — Register request method

Popis

int http_request_method_register ( string $method )

Register a custom request method.

Seznam parametrů

method

the request method name to register

Návratové hodnoty

Returns the ID of the request method on success, or FALSE on failure.

Předcházející | Nahoru | Další
http_request_method_name | Domů | http_request_method_unregister


http_request_method_unregister

(PECL pecl_http:0.10.0-1.5.5)

http_request_method_unregister — Unregister request method

Popis

bool http_request_method_unregister ( mixed $method )

Unregister a previously registered custom request method.

Seznam parametrů

method

The request method name or ID

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
http_request_method_register | Domů | http_request


http_send_content_disposition

(PECL pecl_http:0.10.0-1.5.5)

http_send_content_disposition — Send Content-Disposition

Popis

bool http_send_content_disposition ( string $filename [, bool $inline = FALSE] )

Send the Content-Disposition. The Content-Disposition header is very useful if the data actually sent came from a file or something similar, that should be "saved" by the client/user (i.e. by browsers "Save as..." popup window).

Poznámka: This function is supposed to be used in conjunction with http_send_data(), http_send_file() , a http_send_stream().

Seznam parametrů

filename

the file name the "Save as..." dialog should display

inline

if set to TRUE and the user agent knows how to handle the content type, it will probably not cause the popup window to be shown

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

http_send_data()
http_send_file()
http_send_stream()
the HttpResponse class if you are using PHP-5.1 and above

Předcházející | Nahoru | Další
http_redirect | Domů | http_send_content_type


http_send_content_type

(PECL pecl_http:0.10.0-1.5.5)

http_send_content_type — Send Content-Type

Popis

bool http_send_content_type ( [string $content_type = 'application/x-octetstream'] )

Send the Content-Type of the sent entity.

Poznámka: This function is supposed to be used in conjunction with http_send_data(), http_send_file() , a http_send_stream().

Seznam parametrů

content_type

the desired content type (primary/secondary)

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Errors/Exceptions

Raises an E_WARNING when the content_type doesn't seem to contain a primary and a secondary part.

Viz také

http_send_data()
http_send_file()
http_send_stream()
the HttpResponse class if you are using PHP-5.1 and above

Předcházející | Nahoru | Další
http_send_content_disposition | Domů | http_send_data


http_send_data

(PECL pecl_http:0.1.0-1.5.5)

http_send_data — Send arbitrary data

Popis

bool http_send_data ( string $data )

Sends raw data with support for (multiple) range requests.

Seznam parametrů

data

data to send

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

http_send_file()
http_send_stream()
http_throttle()
http_send_content_type()
http_send_content_disposition()
the HttpResponse class if you are using PHP-5.1 and above

Předcházející | Nahoru | Další
http_send_content_type | Domů | http_send_file


http_send_file

(PECL pecl_http:0.1.0-1.5.5)

http_send_file — Send file

Popis

bool http_send_file ( string $file )

Sends a file with support for (multiple) range requests.

This functions behaviour and further action is dependent on the following INI settings: http.send.not_found_404 , a http.log.not_found.

If the INI setting http.send.not_found_404 is enabled and the INI setting http.log.not_found points to a writable file, a log message is written when the file was not found.

Seznam parametrů

file

the file to send

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 749. A http_send_file() example

<?php
http_send_content_disposition("document.pdf", true);
http_send_content_type("application/pdf");
http_throttle(0.1, 2048);
http_send_file("../report.pdf");
?>

Výše uvedený příklad vypíše:

HTTP/1.1 206 Partial Content
X-Powered-By: PHP/5.2.2
Accept-Ranges: bytes
Content-Length: 12345
Content-Range: bytes 0-12344
Content-Type: application/pdf
Content-Disposition: inline; filename="document.pdf"

%PDF...

Viz také

http_send_data()
http_send_stream()
http_throttle()
http_send_content_type()
http_send_content_disposition()
the HttpResponse class if you are using PHP-5.1 and above

Předcházející | Nahoru | Další
http_send_data | Domů | http_send_last_modified


http_send_last_modified

(PECL pecl_http:0.1.0-1.5.5)

http_send_last_modified — Send Last-Modified

Popis

bool http_send_last_modified ( [int $timestamp] )

Send a Last-Modified header with a valid HTTP date.

Poznámka: This function is supposed to be used in conjunction with http_send_data(), http_send_file() , a http_send_stream().

Seznam parametrů

timestamp

a Unix timestamp, converted to a valid HTTP date; if omitted, the current time will be sent

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

the HttpResponse class if you are using PHP-5.1 and above

Předcházející | Nahoru | Další
http_send_file | Domů | http_send_status


http_send_status

(PECL pecl_http:0.1.0-1.5.5)

http_send_status — Send HTTP response status

Popis

bool http_send_status ( int $status )

Send HTTP status code.

Seznam parametrů

status

HTTP status code (100-599)

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

the HttpResponse class if you are using PHP-5.1 and above

Předcházející | Nahoru | Další
http_send_last_modified | Domů | http_send_stream


http_send_stream

(PECL pecl_http:0.1.0-1.5.5)

http_send_stream — Send stream

Popis

bool http_send_stream ( resource $stream )

Sends an already opened stream with support for (multiple) range requests.

Seznam parametrů

stream

stream to read from (must be seekable)

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

http_send_data()
http_send_file()
http_throttle()
http_send_content_type()
http_send_content_disposition()
the HttpResponse class if you are using PHP-5.1 and above

Předcházející | Nahoru | Další
http_send_status | Domů | http_throttle


http_support

(PECL pecl_http:0.15.0-1.5.5)

http_support — Check built-in HTTP support

Popis

int http_support ( [int $feature = 0] )

Check for features that require external libraries.

See the feature support constants table for possible values for the feature argument.

Seznam parametrů

feature

feature to probe for

Návratové hodnoty

Returns integer, whether requested feature is supported, or a bitmask with all supported features if feature was omitted.

Příklady

Příklad 736. A http_support() example

<?php
if (!http_support(HTTP_SUPPORT_REQUESTS)) {
    die("Need HTTP request support!\n");
}
?>

Předcházející | Nahoru | Další
http_date | Domů | http_match_etag


http_throttle

(PECL pecl_http:0.10.0-1.5.5)

http_throttle — HTTP throttling

Popis

void http_throttle ( [float $sec [, int $bytes = 40960]] )

Sets the throttle delay and send buffer size.

Poznámka: This function is supposed to be used in conjunction with http_send_data(), http_send_file() , a http_send_stream().

Poznámka: Provides a basic throttling mechanism, which will yield the current process respectively thread until the entity has been completely sent.

Poznámka: This may not work as expected with the following SAPI(s): FastCGI.

Seznam parametrů

sec

seconds to sleep after each chunk sent

bytes

the chunk size in bytes

Příklady

Příklad 750. A http_throttle() example

Send file with approximately 20 kbyte/s.

<?php
// ~ 20 kbyte/s
# http_throttle(1, 20000);
# http_throttle(0.5, 10000);
http_throttle(0.1, 2000);
http_send_file('document.pdf');
?>
?>

Viz také

http_send_data()
http_send_file()
http_send_stream()
the HttpResponse class if you are using PHP-5.1 and above

Předcházející | Nahoru | Další
http_send_stream | Domů | http_build_str


HttpDeflateStream::__construct

(PECL pecl_http:0.21.0-1.5.5)

HttpDeflateStream::__construct — HttpDeflateStream class constructor

Popis

public void HttpDeflateStream::__construct ( [int $flags = 0] )

Creates a new HttpDeflateStream object instance.

See the deflate stream constants table for possible flags.

Seznam parametrů

flags

initialization flags

Viz také

HttpDeflateStream::factory()

Předcházející | Nahoru | Další
HttpDeflateStream::factory | Domů | HttpDeflateStream::update


HttpDeflateStream::factory

(PECL pecl_http:1.4.0-1.5.5)

HttpDeflateStream::factory — HttpDeflateStream class factory

Popis

public HttpDeflateStream HttpDeflateStream::factory ( [int $flags = 0 [, string $class_name = 'HttpDeflateStream']] )

Creates a new HttpDeflateStream object instance.

See the deflate stream constants table for possible flags.

Seznam parametrů

flags

initialization flags

class_name

name of a subclass of HttpDeflateStream

Viz také

HttpDeflateStream::__construct()

Předcházející | Nahoru | Další
HttpDeflateStream | Domů | HttpDeflateStream::__construct


HttpDeflateStream::finish

(PECL pecl_http:0.21.0-1.5.5)

HttpDeflateStream::finish — Finalize deflate stream

Popis

public string HttpDeflateStream::finish ( [string $data] )

Finalizes the deflate stream. The deflate stream can be reused after finalizing.

Seznam parametrů

data

data to deflate

Návratové hodnoty

Returns the final part of deflated data.

Předcházející | Nahoru | Další
HttpDeflateStream::flush | Domů | HttpInflateStream


HttpDeflateStream::flush

(PECL pecl_http:0.21.0-1.5.5)

HttpDeflateStream::flush — Flush deflate stream

Popis

public string HttpDeflateStream::flush ( [string $data] )

Flushes the deflate stream.

Seznam parametrů

data

more data to deflate

Návratové hodnoty

Returns some deflated data as string on success or FALSE on failure.

Předcházející | Nahoru | Další
HttpDeflateStream::update | Domů | HttpDeflateStream::finish


HttpDeflateStream::update

(PECL pecl_http:0.21.0-1.5.5)

HttpDeflateStream::update — Update deflate stream

Popis

public string HttpDeflateStream::update ( string $data )

Passes more data through the deflate stream.

Seznam parametrů

data

data to deflate

Návratové hodnoty

Returns deflated data on success or FALSE on failure.

Předcházející | Nahoru | Další
HttpDeflateStream::__construct | Domů | HttpDeflateStream::flush


HttpInflateStream::__construct

(PECL pecl_http:1.0.0-1.5.5)

HttpInflateStream::__construct — HttpInflateStream class constructor

Popis

public void HttpInflateStream::__construct ( [int $flags = 0] )

Creates a new HttpInflateStream object instance.

See the inflate constants table for possible flags.

Seznam parametrů

flags

initialization flags

Viz také

HttpInflateStream::factory()

Předcházející | Nahoru | Další
HttpInflateStream::factory | Domů | HttpInflateStream::update


HttpInflateStream::factory

(PECL pecl_http:1.4.0-1.5.5)

HttpInflateStream::factory — HttpInflateStream class factory

Popis

public HttpInflateStream HttpInflateStream::factory ( [int $flags = 0 [, string $class_name = 'HttpInflateStream']] )

Creates a new HttpInflateStream object instance.

See the inflate constants table for possible flags.

Seznam parametrů

flags

initialization flags

class_name

name of a subclass of HttpInflateStream

Viz také

HttpInflateStream::__construct()

Předcházející | Nahoru | Další
HttpInflateStream | Domů | HttpInflateStream::__construct


HttpInflateStream::finish

(PECL pecl_http:0.21.0-1.5.5)

HttpInflateStream::finish — Finalize inflate stream

Popis

public string HttpInflateStream::finish ( [string $data] )

Finalizes the inflate stream. The inflate stream can be reused after finalizing.

Seznam parametrů

data

data to inflate

Návratové hodnoty

Returns the final part of inflated data.

Předcházející | Nahoru | Další
HttpInflateStream::flush | Domů | HttpRequest


HttpInflateStream::flush

(PECL pecl_http:0.21.0-1.5.5)

HttpInflateStream::flush — Flush inflate stream

Popis

public string HttpInflateStream::flush ( [string $data] )

Flushes the inflate stream.

Poznámka: Flushing usually has no effect on inflate streams.

Seznam parametrů

data

more data to inflate

Návratové hodnoty

Returns some inflated data as string on success or FALSE on failure.

Předcházející | Nahoru | Další
HttpInflateStream::update | Domů | HttpInflateStream::finish


HttpInflateStream::update

(PECL pecl_http:0.21.0-1.5.5)

HttpInflateStream::update — Update inflate stream

Popis

public string HttpInflateStream::update ( string $data )

Passes more data through the inflate stream.

Seznam parametrů

data

data to inflate

Návratové hodnoty

Returns inflated data on success or FALSE on failure.

Předcházející | Nahoru | Další
HttpInflateStream::__construct | Domů | HttpInflateStream::flush


HttpMessage::addHeaders

(PECL pecl_http:0.10.0-1.5.5)

HttpMessage::addHeaders — Add headers

Popis

public void HttpMessage::addHeaders ( array $headers [, bool $append = FALSE] )

Add headers. If append is true, headers with the same name will be separated, else overwritten.

Seznam parametrů

headers

associative array containing the additional HTTP headers to add to the messages existing headers

append

if true, and a header with the same name of one to add exists already, this respective header will be converted to an array containing both header values, otherwise it will be overwritten with the new header value

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
HttpMessage::getHeader | Domů | HttpMessage::setHeaders


HttpMessage::__construct

(PECL pecl_http:0.10.0-1.5.5)

HttpMessage::__construct — HttpMessage constructor

Popis

public void HttpMessage::__construct ( [string $message] )

Instantiate a new HttpMessage object.

The constructed object will actually represent the last message of the passed string. If there were prior messages, those can be accessed by HttpMessage::getParentMessage().

Seznam parametrů

message

a single or several consecutive HTTP messages

Errors/Exceptions

Throws HttpMalformedHeaderException.

Předcházející | Nahoru | Další
HttpMessage | Domů | HttpMessage::factory


HttpMessage::detach

(PECL pecl_http:0.22.0-1.5.5)

HttpMessage::detach — Detach HttpMessage

Popis

public HttpMessage HttpMessage::detach ( void )

Returns a clone of an HttpMessage object detached from any parent messages.

Seznam parametrů

Návratové hodnoty

Returns detached HttpMessage object copy.

Předcházející | Nahoru | Další
HttpMessage::guessContentType | Domů | HttpMessage::prepend


HttpMessage::factory

(PECL pecl_http:1.4.0-1.5.5)

HttpMessage::factory — Create HttpMessage from string

Popis

static public HttpMessage HttpMessage::factory ( [string $raw_message [, string $class_name = 'HttpMessage']] )

Create an HttpMessage object from a string.

Seznam parametrů

raw_message

a single or several consecutive HTTP messages

class_name

a class extending HttpMessage

Návratové hodnoty

Returns an HttpMessage object on success or NULL on failure.

Errors/Exceptions

Throws HttpMalformedHeadersException.

Viz také

HttpMessage::fromEnv().

Předcházející | Nahoru | Další
HttpMessage::__construct | Domů | HttpMessage::fromEnv


HttpMessage::fromEnv

(PECL pecl_http:1.5.0-1.5.5)

HttpMessage::fromEnv — Create HttpMessage from environment

Popis

static public HttpMessage HttpMessage::fromEnv ( int $message_type [, string $class_name = 'HttpMessage'] )

Create an HttpMessage object from script environment.

Seznam parametrů

message_type

The message type. See HttpMessage type constants.

class_name

a class extending HttpMessage

Návratové hodnoty

Returns an HttpMessage object on success or NULL on failure.

Viz také

HttpMessage::factory().

Předcházející | Nahoru | Další
HttpMessage::factory | Domů | HttpMessage::fromString


HttpMessage::fromString

(PECL pecl_http:0.10.0-1.3.3)

HttpMessage::fromString — Create HttpMessage from string

Popis

static public HttpMessage HttpMessage::fromString ( [string $raw_message [, string $class_name = 'HttpMessage']] )

Create an HttpMessage object from a string.

Tento alias funkce je zavržený a existuje pouze z důvodu zpětné kompatibility. Doporučuje se tuto funkci nepoužívat, neboť může být jednoho dne odstraněna z PHP.

Seznam parametrů

raw_message

a single or several consecutive HTTP messages

class_name

a class extending HttpMessage

Návratové hodnoty

Returns an HttpMessage object on success or NULL on failure.

Errors/Exceptions

Throws HttpMalformedHeadersException.

Viz také

HttpMessage::factory().

Předcházející | Nahoru | Další
HttpMessage::fromEnv | Domů | HttpMessage::toString


HttpMessage::getBody

(PECL pecl_http:0.10.0-1.5.5)

HttpMessage::getBody — Get message body

Popis

public string HttpMessage::getBody ( void )

Get the body of the parsed HttpMessage.

Návratové hodnoty

Returns the message body as string.

Předcházející | Nahoru | Další
HttpMessage::setHeaders | Domů | HttpMessage::setBody


HttpMessage::getHeader

(PECL pecl_http:1.1.0-1.5.5)

HttpMessage::getHeader — Get header

Popis

public string HttpMessage::getHeader ( string $header )

Get message header.

Seznam parametrů

header

header name

Návratové hodnoty

Returns the header value on success or NULL if the header does not exist.

Předcházející | Nahoru | Další
HttpMessage::getHeaders | Domů | HttpMessage::addHeaders


HttpMessage::getHeaders

(PECL pecl_http:0.10.0-1.5.5)

HttpMessage::getHeaders — Get message headers

Popis

public array HttpMessage::getHeaders ( void )

Get message headers.

Návratové hodnoty

Returns an associative array containing the messages HTTP headers.

Předcházející | Nahoru | Další
HttpMessage::setHttpVersion | Domů | HttpMessage::getHeader


HttpMessage::getHttpVersion

(PECL pecl_http:0.10.0-1.5.5)

HttpMessage::getHttpVersion — Get HTTP version

Popis

public string HttpMessage::getHttpVersion ( void )

Get the HTTP Protocol Version of the Message.

Návratové hodnoty

Returns the HTTP protocol version as string.

Předcházející | Nahoru | Další
HttpMessage::setType | Domů | HttpMessage::setHttpVersion


HttpMessage::getParentMessage

(PECL pecl_http:0.10.0-1.5.5)

HttpMessage::getParentMessage — Get parent message

Popis

public HttpMessage HttpMessage::getParentMessage ( void )

Get parent Message.

Návratové hodnoty

Returns the parent HttpMessage object.

Errors/Exceptions

Throws HttpRuntimeException.

Předcházející | Nahoru | Další
HttpMessage::send | Domů | HttpMessage::getType


HttpMessage::getRequestMethod

(PECL pecl_http:0.10.0-1.5.5)

HttpMessage::getRequestMethod — Get request method

Popis

public string HttpMessage::getRequestMethod ( void )

Get the Request Method of the Message.

Návratové hodnoty

Returns the request method name on success, or FALSE if the message is not of type HttpMessage::TYPE_REQUEST.

Předcházející | Nahoru | Další
HttpMessage::setBody | Domů | HttpMessage::setRequestMethod


HttpMessage::getRequestUrl

(PECL pecl_http:0.21.0-1.5.5)

HttpMessage::getRequestUrl — Get request URL

Popis

public string HttpMessage::getRequestUrl ( void )

Get the Request URL of the Message.

Seznam parametrů

Návratové hodnoty

Returns the request URL as string on success, or FALSE if the message is not of type HttpMessage::TYPE_REQUEST.

Předcházející | Nahoru | Další
HttpMessage::setRequestMethod | Domů | HttpMessage::setRequestUrl


HttpMessage::getResponseCode

(PECL pecl_http:0.10.0-1.5.5)

HttpMessage::getResponseCode — Get response code

Popis

public int HttpMessage::getResponseCode ( void )

Get the Response Code of the Message.

Návratové hodnoty

Returns the HTTP response code if the message is of type HttpMessage::TYPE_RESPONSE, else FALSE.

Předcházející | Nahoru | Další
HttpMessage::setRequestUrl | Domů | HttpMessage::setResponseCode


HttpMessage::getResponseStatus

(PECL pecl_http:0.23.0-1.5.5)

HttpMessage::getResponseStatus — Get response status

Popis

public string HttpMessage::getResponseStatus ( void )

Get the Response Status of the message (i.e. the string following the response code).

Návratové hodnoty

Returns the HTTP response status string if the message is of type HttpMessage::TYPE_RESPONSE, else FALSE.

Předcházející | Nahoru | Další
HttpMessage::setResponseCode | Domů | HttpMessage::setResponseStatus


HttpMessage::getType

(PECL pecl_http:0.10.0-1.5.5)

HttpMessage::getType — Get message type

Popis

public int HttpMessage::getType ( void )

Get Message Type. Either HTTP_MSG_NONE, HTTP_MSG_REQUEST or HTTP_MSG_RESPONSE.

Návratové hodnoty

Returns the HttpMessage::TYPE.

Předcházející | Nahoru | Další
HttpMessage::getParentMessage | Domů | HttpMessage::setType


HttpMessage::guessContentType

(PECL pecl_http:1.0.0-1.5.5)

HttpMessage::guessContentType — Guess content type

Popis

public string HttpMessage::guessContentType ( string $magic_file [, int $magic_mode = MAGIC_MIME] )

Attempts to guess the content type of the message body through libmagic.

Seznam parametrů

magic_file

the magic.mime database to use

magic_mode

flags for libmagic

Návratové hodnoty

Returns the guessed content type on success, or FALSE on failure.

Errors/Exceptions

Throws HttpRuntimeException, HttpInvalidParamException.

Předcházející | Nahoru | Další
HttpMessage::toMessageTypeObject | Domů | HttpMessage::detach


HttpMessage::prepend

(PECL pecl_http:0.22.0-1.5.5)

HttpMessage::prepend — Prepend message(s)

Popis

public void HttpMessage::prepend ( HttpMessage $message [, bool $top = TRUE] )

Prepends message(s) to the HTTP message.

Seznam parametrů

message

HttpMessage object to prepend

top

whether to prepend to the top most or right this message

Errors/Exceptions

Throws HttpInvalidParamException if the message is located within the same message chain.

Předcházející | Nahoru | Další
HttpMessage::detach | Domů | HttpMessage::reverse


HttpMessage::reverse

(PECL pecl_http:0.23.0-1.5.5)

HttpMessage::reverse — Reverse message chain

Popis

public HttpMessage HttpMessage::reverse ( void )

Reorders the message chain in reverse order.

Návratové hodnoty

Returns the most parent HttpMessage object.

Předcházející | Nahoru | Další
HttpMessage::prepend | Domů | HttpMessage::send


HttpMessage::send

(PECL pecl_http:0.10.0-1.5.5)

HttpMessage::send — Send message

Popis

public bool HttpMessage::send ( void )

Send the Message according to its type as Response or Request.

This provides limited functionality compared to HttpRequest and HttpResponse.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
HttpMessage::reverse | Domů | HttpMessage::getParentMessage


HttpMessage::setBody

(PECL pecl_http:0.14.0-1.5.5)

HttpMessage::setBody — Set message body

Popis

public void HttpMessage::setBody ( string $body )

Set the body of the HttpMessage.

Poznámka: Don't forget to update any headers accordingly.

Seznam parametrů

body

the new body of the message

Předcházející | Nahoru | Další
HttpMessage::getBody | Domů | HttpMessage::getRequestMethod


HttpMessage::setHeaders

(PECL pecl_http:0.10.0-1.5.5)

HttpMessage::setHeaders — Set headers

Popis

public void HttpMessage::setHeaders ( array $headers )

Sets new headers.

Seznam parametrů

headers

associative array containing the new HTTP headers, which will replace all previous HTTP headers of the message

Předcházející | Nahoru | Další
HttpMessage::addHeaders | Domů | HttpMessage::getBody


HttpMessage::setHttpVersion

(PECL pecl_http:0.10.0-1.5.5)

HttpMessage::setHttpVersion — Set HTTP version

Popis

public bool HttpMessage::setHttpVersion ( string $version )

Set the HTTP Protocol version of the Message.

Seznam parametrů

version

the HTTP protocol version

Návratové hodnoty

Returns TRUE on success, or FALSE if supplied version is out of range (1.0/1.1).

Předcházející | Nahoru | Další
HttpMessage::getHttpVersion | Domů | HttpMessage::getHeaders


HttpMessage::setRequestMethod

(PECL pecl_http:0.10.0-1.5.5)

HttpMessage::setRequestMethod — Set request method

Popis

public bool HttpMessage::setRequestMethod ( string $method )

Set the Request Method of the HTTP Message.

Seznam parametrů

method

the request method name

Návratové hodnoty

Returns TRUE on success, or FALSE if the message is not of type HttpMessage::TYPE_REQUEST or an invalid request method was supplied.

Předcházející | Nahoru | Další
HttpMessage::getRequestMethod | Domů | HttpMessage::getRequestUrl


HttpMessage::setRequestUrl

(PECL pecl_http:0.21.0-1.5.5)

HttpMessage::setRequestUrl — Set request URL

Popis

public bool HttpMessage::setRequestUrl ( string $url )

Set the Request URL of the HTTP Message.

Seznam parametrů

url

the request URL

Návratové hodnoty

Returns TRUE on success, or FALSE if the message is not of type HttpMessage::TYPE_REQUEST or supplied URL was empty.

Předcházející | Nahoru | Další
HttpMessage::getRequestUrl | Domů | HttpMessage::getResponseCode


HttpMessage::setResponseCode

(PECL pecl_http:0.10.0-1.5.5)

HttpMessage::setResponseCode — Set response code

Popis

public bool HttpMessage::setResponseCode ( int $code )

Set the response code of an HTTP Response Message.

Seznam parametrů

code

HTTP response code

Návratové hodnoty

Returns TRUE on success, or FALSE if the message is not of type HttpMessage::TYPE_RESPONSE or the response code is out of range (100-510).

Předcházející | Nahoru | Další
HttpMessage::getResponseCode | Domů | HttpMessage::getResponseStatus


HttpMessage::setResponseStatus

(PECL pecl_http:0.23.0-1.5.5)

HttpMessage::setResponseStatus — Set response status

Popis

public bool HttpMessage::setResponseStatus ( string $status )

Set the Response Status of the HTTP message (i.e. the string following the response code).

Seznam parametrů

status

the response status text

Návratové hodnoty

Returns TRUE on success or FALSE if the message is not of type HttpMessage::TYPE_RESPONSE.

Předcházející | Nahoru | Další
HttpMessage::getResponseStatus | Domů | HttpQueryString


HttpMessage::setType

(PECL pecl_http:0.10.0-1.5.5)

HttpMessage::setType — Set message type

Popis

public void HttpMessage::setType ( int $type )

Set Message Type. Either HTTP_MSG_NONE, HTTP_MSG_REQUEST or HTTP_MSG_RESPONSE.

Seznam parametrů

type

the HttpMessage::TYPE

Předcházející | Nahoru | Další
HttpMessage::getType | Domů | HttpMessage::getHttpVersion


HttpMessage::toMessageTypeObject

(PECL pecl_http:0.22.0-1.5.5)

HttpMessage::toMessageTypeObject — Create HTTP object regarding message type

Popis

public HttpRequest|HttpResponse HttpMessage::toMessageTypeObject ( void )

Creates an object regarding to the type of the message.

Seznam parametrů

Návratové hodnoty

Returns either an HttpRequest or HttpResponse object on success, or NULL on failure.

Errors/Exceptions

Throws HttpRuntimeException, HttpMessageTypeException, HttpHeaderException.

Předcházející | Nahoru | Další
HttpMessage::toString | Domů | HttpMessage::guessContentType


HttpMessage::toString

(PECL pecl_http:0.10.0-1.5.5)

HttpMessage::toString — Get string representation

Popis

public string HttpMessage::toString ( [bool $include_parent = FALSE] )

Get the string representation of the Message.

Seznam parametrů

include_parent

specifies whether the returned string should also contain any parent messages

Návratové hodnoty

Returns the message as string.

Předcházející | Nahoru | Další
HttpMessage::fromString | Domů | HttpMessage::toMessageTypeObject


HttpQueryString::__construct

(PECL pecl_http:0.22.0-1.5.5)

HttpQueryString::__construct — HttpQueryString constructor

Popis

final public void HttpQueryString::__construct ( [bool $global = TRUE [, mixed $add]] )

Creates a new HttpQueryString object instance.

Operates on and modifies $_GET and $_SERVER['QUERY_STRING'] if global is TRUE.

Seznam parametrů

global

whether to operate on $_GET and $_SERVER['QUERY_STRING']

add

additional/initial query string parameters

Errors/Exceptions

Throws HttpRuntimeException.

Předcházející | Nahoru | Další
HttpQueryString | Domů | HttpQueryString::singleton


HttpQueryString::get

(PECL pecl_http:0.22.0-1.5.5)

HttpQueryString::get — Get (part of) query string

Popis

public mixed HttpQueryString::get ( [string $key [, mixed $type = 0 [, mixed $defval = NULL [, bool $delete = FALSE]]]] )

Get (part of) the query string.

The type parameter is either one of the HttpQueryString::TYPE_* constants or a type abbreviation like "b" for bool, "i" for int, "f" for float, "s" for string, "a" for array and "o" for a stdClass object.

Seznam parametrů

key

key of the query string param to retrieve

type

which variable type to enforce

defval

default value if key does not exist

delete

whether to remove the key/value pair from the query string

Návratové hodnoty

Returns the value of the query string param or the whole query string if no key was specified on success or defval if key does not exist.

Předcházející | Nahoru | Další
HttpQueryString::singleton | Domů | HttpQueryString::mod


HttpQueryString::mod

(PECL pecl_http:1.1.0-1.5.5)

HttpQueryString::mod — Modifiy query string copy

Popis

public HttpQueryString HttpQueryString::mod ( mixed $params )

Copies the query string object and sets provided params at the clone.

Seznam parametrů

params

query string params to add

Návratové hodnoty

Returns a new HttpQueryString object

Předcházející | Nahoru | Další
HttpQueryString::get | Domů | HttpQueryString::set


HttpQueryString::set

(PECL pecl_http:0.22.0-1.5.5)

HttpQueryString::set — Set query string params

Popis

public string HttpQueryString::set ( mixed $params )

Set query string entry/entries. NULL values will unset the variable.

Seznam parametrů

params

query string params to add

Návratové hodnoty

Returns the current query string.

Předcházející | Nahoru | Další
HttpQueryString::mod | Domů | HttpQueryString::toArray


HttpQueryString::singleton

(PECL pecl_http:0.25.0-1.5.5)

HttpQueryString::singleton — HttpQueryString singleton

Popis

static public HttpQueryString HttpQueryString::singleton ( [bool $global = TRUE] )

Get a single instance (differentiates between the global setting).

Seznam parametrů

global

whether to operate on $_GET and $_SERVER['QUERY_STRING']

Návratové hodnoty

Returns always the same HttpQueryString instance regarding the global setting.

Errors/Exceptions

Throws HttpRuntimeException.

Předcházející | Nahoru | Další
HttpQueryString::__construct | Domů | HttpQueryString::get


HttpQueryString::toArray

(PECL pecl_http:0.22.0-1.5.5)

HttpQueryString::toArray — Get query string as array

Popis

public array HttpQueryString::toArray ( void )

Get the query string represented as associative array.

Návratové hodnoty

Returns the array representation of the query string.

Předcházející | Nahoru | Další
HttpQueryString::set | Domů | HttpQueryString::toString


HttpQueryString::toString

(PECL pecl_http:0.22.0-1.5.5)

HttpQueryString::toString — Get query string

Popis

public string HttpQueryString::toString ( void )

Get the query string.

Seznam parametrů

Návratové hodnoty

Returns the string representation of the query string.

Předcházející | Nahoru | Další
HttpQueryString::toArray | Domů | HttpQueryString::xlate


HttpQueryString::xlate

(PECL pecl_http:0.25.0-1.5.5)

HttpQueryString::xlate — Change query strings charset

Popis

public bool HttpQueryString::xlate ( string $ie, string $oe )

Converts the query string from the source encoding ie to the target encoding oe.

Varování

Don't use any character set that can contain NUL bytes like UTF-16.

Poznámka: This method requires ext/iconv to be enabled and loaded.

Seznam parametrů

ie

input encoding

oe

output encoding

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
HttpQueryString::toString | Domů | HttpDeflateStream


HttpRequest::addCookies

(PECL pecl_http:0.10.0-1.5.5)

HttpRequest::addCookies — Add cookies

Popis

public bool HttpRequest::addCookies ( array $cookies )

Add custom cookies.

Poznámka: The request option encodecookies controls whether the cookie values should be urlencode()d.

Poznámka: Affects any request method.

Seznam parametrů

cookies

an associative array containing any cookie name/value pairs to add

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 726. A HttpRequest::addCookies() example

<?php
$r = new HttpRequest;
$r->addCookies(
    array(
        "cookie_name" => "cookie value",
    )
);
?>

Viz také

HttpRequest::setCookies()

Předcházející | Nahoru | Další
HttpRequest | Domů | HttpRequest::addHeaders


HttpRequest::addHeaders

(PECL pecl_http:0.10.0-1.5.5)

HttpRequest::addHeaders — Add headers

Popis

public bool HttpRequest::addHeaders ( array $headers )

Add request header name/value pairs.

Seznam parametrů

headers

an associative array as parameter containing additional header name/value pairs

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
HttpRequest::addCookies | Domů | HttpRequest::addPostFields


HttpRequest::addPostFields

(PECL pecl_http:0.10.0-1.5.5)

HttpRequest::addPostFields — Add post fields

Popis

public bool HttpRequest::addPostFields ( array $post_data )

Adds POST data entries, leaving previously set unchanged, unless a post entry with the same name already exists.

Affects only POST and custom requests.

Seznam parametrů

post_data

an associative array as parameter containing the post fields

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
HttpRequest::addHeaders | Domů | HttpRequest::addPostFile


HttpRequest::addPostFile

(PECL pecl_http:0.10.0-1.5.5)

HttpRequest::addPostFile — Add post file

Popis

public bool HttpRequest::addPostFile ( string $name, string $file [, string $content_type = 'application/x-octetstream'] )

Add a file to the POST request, leaving previously set files unchanged.

Affects only POST and custom requests. Cannot be used with raw post data.

Seznam parametrů

name

the form element name

file

the path to the file

content_type

the content type of the file

Návratové hodnoty

Returns TRUE on success, or FALSE if the content type seems not to contain a primary and a secondary content type part.

Předcházející | Nahoru | Další
HttpRequest::addPostFields | Domů | HttpRequest::addPutData


HttpRequest::addPutData

(PECL pecl_http:0.25.0-1.5.5)

HttpRequest::addPutData — Add put data

Popis

public bool HttpRequest::addPutData ( string $put_data )

Add PUT data, leaving previously set PUT data unchanged.

Affects only PUT requests.

Seznam parametrů

put_data

the data to concatenate

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
HttpRequest::addPostFile | Domů | HttpRequest::addQueryData


HttpRequest::addQueryData

(PECL pecl_http:0.10.0-1.5.5)

HttpRequest::addQueryData — Add query data

Popis

public bool HttpRequest::addQueryData ( array $query_params )

Add parameters to the query parameter list, leaving previously set unchanged.

Affects any request type.

Seznam parametrů

query_params

an associative array as parameter containing the query fields to add

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
HttpRequest::addPutData | Domů | HttpRequest::addRawPostData


HttpRequest::addRawPostData

(PECL pecl_http:0.14.0-1.4.1)

HttpRequest::addRawPostData — Add raw post data

Popis

public bool HttpRequest::addRawPostData ( string $raw_post_data )

Add raw post data, leaving previously set raw post data unchanged.

Affects only POST and custom requests.

Seznam parametrů

raw_post_data

the raw post data to concatenate

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
HttpRequest::addQueryData | Domů | HttpRequest::addSslOptions


HttpRequest::addSslOptions

(PECL pecl_http:0.12.0-1.5.5)

HttpRequest::addSslOptions — Add ssl options

Popis

public bool HttpRequest::addSslOptions ( array $options )

Set additional SSL options.

Seznam parametrů

options

an associative array as parameter containing additional SSL specific options

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
HttpRequest::addRawPostData | Domů | HttpRequest::clearHistory


HttpRequest::clearHistory

(PECL pecl_http:0.15.0-1.5.5)

HttpRequest::clearHistory — Clear history

Popis

public void HttpRequest::clearHistory ( void )

Clears all history messages.

Poznámka: History is only logged if recordHistory was enabled.

Předcházející | Nahoru | Další
HttpRequest::addSslOptions | Domů | HttpRequest::__construct


HttpRequest::__construct

(PECL pecl_http:0.10.0-1.5.5)

HttpRequest::__construct — HttpRequest constructor

Popis

public void HttpRequest::__construct ( [string $url [, int $request_method = HTTP_METH_GET [, array $options]]] )

Instantiate a new HttpRequest object.

Seznam parametrů

url

the target request url

request_method

the request method to use

options

an associative array with request options

Errors/Exceptions

Throws HttpException.

Předcházející | Nahoru | Další
HttpRequest::clearHistory | Domů | HttpRequest::enableCookies


HttpRequest::enableCookies

(PECL pecl_http:1.0.0-1.5.5)

HttpRequest::enableCookies — Enable cookies

Popis

public bool HttpRequest::enableCookies ( void )

Enable automatic sending of received cookies.

Poznámka: Note that cuutomly set cookies will be sent anyway.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
HttpRequest::__construct | Domů | HttpRequest::getContentType


HttpRequest::getContentType

(PECL pecl_http:0.10.0-1.5.5)

HttpRequest::getContentType — Get content type

Popis

public string HttpRequest::getContentType ( void )

Get the previously set content type.

Návratové hodnoty

Returns the previously set content type as string.

Předcházející | Nahoru | Další
HttpRequest::enableCookies | Domů | HttpRequest::getCookies


HttpRequest::getCookies

(PECL pecl_http:0.10.0-1.5.5)

HttpRequest::getCookies — Get cookies

Popis

public array HttpRequest::getCookies ( void )

Get previously set cookies.

Návratové hodnoty

Returns an associative array containing any previously set cookies.

Předcházející | Nahoru | Další
HttpRequest::getContentType | Domů | HttpRequest::getHeaders


HttpRequest::getHeaders

(PECL pecl_http:0.10.0-1.5.5)

HttpRequest::getHeaders — Get headers

Popis

public array HttpRequest::getHeaders ( void )

Get previously set request headers.

Návratové hodnoty

Returns an associative array containing all currently set headers.

Předcházející | Nahoru | Další
HttpRequest::getCookies | Domů | HttpRequest::getHistory


HttpRequest::getHistory

(PECL pecl_http:0.15.0-1.5.5)

HttpRequest::getHistory — Get history

Popis

public HttpMessage HttpRequest::getHistory ( void )

Get all sent requests and received responses as an HttpMessage object.

If you want to record history, set the instance variable HttpRequest::recordHistory to TRUE.

The returned object references the last received response, use HttpMessage::getParentMessage()() to access the data of previously sent requests and received responses.

Návratové hodnoty

Returns an HttpMessage object representing the complete request/response history.

Errors/Exceptions

Throws HttpRuntimeException.

Předcházející | Nahoru | Další
HttpRequest::getHeaders | Domů | HttpRequest::getMethod


HttpRequest::getMethod

(PECL pecl_http:0.10.0-1.5.5)

HttpRequest::getMethod — Get method

Popis

public int HttpRequest::getMethod ( void )

Get the previously set request method.

Návratové hodnoty

Returns the currently set request method.

Předcházející | Nahoru | Další
HttpRequest::getHistory | Domů | HttpRequest::getOptions


HttpRequest::getOptions

(PECL pecl_http:0.10.0-1.5.5)

HttpRequest::getOptions — Get options

Popis

public array HttpRequest::getOptions ( void )

Get currently set options.

Návratové hodnoty

Returns an associative array containing currently set options.

Předcházející | Nahoru | Další
HttpRequest::getMethod | Domů | HttpRequest::getPostFields


HttpRequest::getPostFields

(PECL pecl_http:0.10.0-1.5.5)

HttpRequest::getPostFields — Get post fields

Popis

public array HttpRequest::getPostFields ( void )

Get previously set POST data.

Seznam parametrů

Návratové hodnoty

Returns the currently set post fields as associative array.

Předcházející | Nahoru | Další
HttpRequest::getOptions | Domů | HttpRequest::getPostFiles


HttpRequest::getPostFiles

(PECL pecl_http:0.10.0-1.5.5)

HttpRequest::getPostFiles — Get post files

Popis

public array HttpRequest::getPostFiles ( void )

Get all previously added POST files.

Návratové hodnoty

Returns an array containing currently set post files.

Předcházející | Nahoru | Další
HttpRequest::getPostFields | Domů | HttpRequest::getPutData


HttpRequest::getPutData

(PECL pecl_http:0.25.0-1.5.5)

HttpRequest::getPutData — Get put data

Popis

public string HttpRequest::getPutData ( void )

Get previously set PUT data.

Návratové hodnoty

Returns a string containing the currently set PUT data.

Předcházející | Nahoru | Další
HttpRequest::getPostFiles | Domů | HttpRequest::getPutFile


HttpRequest::getPutFile

(PECL pecl_http:0.10.0-1.5.5)

HttpRequest::getPutFile — Get put file

Popis

public string HttpRequest::getPutFile ( void )

Get previously set put file.

Návratové hodnoty

Returns a string containing the path to the currently set put file.

Předcházející | Nahoru | Další
HttpRequest::getPutData | Domů | HttpRequest::getQueryData


HttpRequest::getQueryData

(PECL pecl_http:0.10.0-1.5.5)

HttpRequest::getQueryData — Get query data

Popis

public string HttpRequest::getQueryData ( void )

Get the current query data in form of an urlencoded query string.

Návratové hodnoty

Returns a string containing the urlencoded query.

Předcházející | Nahoru | Další
HttpRequest::getPutFile | Domů | HttpRequest::getRawPostData


HttpRequest::getRawPostData

(PECL pecl_http:0.14.0-1.4.1)

HttpRequest::getRawPostData — Get raw post data

Popis

public string HttpRequest::getRawPostData ( void )

Get previously set raw post data.

Seznam parametrů

Návratové hodnoty

Returns a string containing the currently set raw post data.

Předcházející | Nahoru | Další
HttpRequest::getQueryData | Domů | HttpRequest::getRawRequestMessage


HttpRequest::getRawRequestMessage

(PECL pecl_http:0.21.0-1.5.5)

HttpRequest::getRawRequestMessage — Get raw request message

Popis

public string HttpRequest::getRawRequestMessage ( void )

Get sent HTTP message.

Seznam parametrů

Návratové hodnoty

Returns an HttpMessage in a form of a string.

Předcházející | Nahoru | Další
HttpRequest::getRawPostData | Domů | HttpRequest::getRawResponseMessage


HttpRequest::getRawResponseMessage

(PECL pecl_http:0.21.0-1.5.5)

HttpRequest::getRawResponseMessage — Get raw response message

Popis

public string HttpRequest::getRawResponseMessage ( void )

Get the entire HTTP response.

Seznam parametrů

Návratové hodnoty

Returns the complete web server response, including the headers in a form of a string.

Předcházející | Nahoru | Další
HttpRequest::getRawRequestMessage | Domů | HttpRequest::getRequestMessage


HttpRequest::getRequestMessage

(PECL pecl_http:0.11.0-1.5.5)

HttpRequest::getRequestMessage — Get request message

Popis

public HttpMessage HttpRequest::getRequestMessage ( void )

Get sent HTTP message.

If redirects were allowed and several responses were received, the data references the last received response. Use HttpMessage::getParentMessage() to access the data of previously sent requests within this request cycle.

Poznámka: Note that the internal request message is immutable, that means that the request message received through HttpRequest::getRequestMessage() will always look the same for the same request, regardless of any changes you may have made to the returned object.

Návratové hodnoty

Returns an HttpMessage object representing the sent request.

Errors/Exceptions

Throws HttpMalformedHeadersException, HttpEncodingException.

Předcházející | Nahoru | Další
HttpRequest::getRawResponseMessage | Domů | HttpRequest::getResponseBody


HttpRequest::getResponseBody

(PECL pecl_http:0.10.0-1.5.5)

HttpRequest::getResponseBody — Get response body

Popis

public string HttpRequest::getResponseBody ( void )

Get the response body after the request has been sent.

If redirects were allowed and several responses were received, the data references the last received response.

Seznam parametrů

Návratové hodnoty

Returns a string containing the response body.

Předcházející | Nahoru | Další
HttpRequest::getRequestMessage | Domů | HttpRequest::getResponseCode


HttpRequest::getResponseCode

(PECL pecl_http:0.10.0-1.5.5)

HttpRequest::getResponseCode — Get response code

Popis

public int HttpRequest::getResponseCode ( void )

Get the response code after the request has been sent.

If redirects were allowed and several responses were received, the data references the last received response.

Návratové hodnoty

Returns an int representing the response code.

Předcházející | Nahoru | Další
HttpRequest::getResponseBody | Domů | HttpRequest::getResponseCookies


HttpRequest::getResponseCookies

(PECL pecl_http:0.23.0-1.5.5)

HttpRequest::getResponseCookies — Get response cookie(s)

Popis

public array HttpRequest::getResponseCookies ( [int $flags [, array $allowed_extras]] )

Get response cookie(s) after the request has been sent.

If redirects were allowed and several responses were received, the data references the last received response.

Seznam parametrů

flags

http_parse_cookie() flags

allowed_extras

allowed keys treated as extra information instead of cookie names

Návratové hodnoty

Returns an array of stdClass objects like http_parse_cookie() would return.

Předcházející | Nahoru | Další
HttpRequest::getResponseCode | Domů | HttpRequest::getResponseData


HttpRequest::getResponseData

(PECL pecl_http:0.10.0-1.5.5)

HttpRequest::getResponseData — Get response data

Popis

public array HttpRequest::getResponseData ( void )

* Get all response data after the request has been sent.

If redirects were allowed and several responses were received, the data references the last received response.

Návratové hodnoty

Returns an associative array with the key "headers" containing an associative array holding all response headers, as well as the key "body" containing a string with the response body.

Předcházející | Nahoru | Další
HttpRequest::getResponseCookies | Domů | HttpRequest::getResponseHeader


HttpRequest::getResponseHeader

(PECL pecl_http:0.10.0-1.5.5)

HttpRequest::getResponseHeader — Get response header(s)

Popis

public mixed HttpRequest::getResponseHeader ( [string $name] )

Get response header(s) after the request has been sent.

If redirects were allowed and several responses were received, the data references the last received response.

Seznam parametrů

name

header to read; if empty, all response headers will be returned

Návratové hodnoty

Returns either a string with the value of the header matching name if requested, FALSE on failure, or an associative array containing all response headers.

Předcházející | Nahoru | Další
HttpRequest::getResponseData | Domů | HttpRequest::getResponseInfo


HttpRequest::getResponseInfo

(PECL pecl_http:0.10.0-1.5.5)

HttpRequest::getResponseInfo — Get response info

Popis

public mixed HttpRequest::getResponseInfo ( [string $name] )

Get response info after the request has been sent.

See http_get() for a full list of returned info.

If redirects were allowed and several responses were received, the data references the last received response.

Seznam parametrů

name

the info to read; if empty or omitted, an associative array containing all available info will be returned

Návratové hodnoty

Returns either a scalar containing the value of the info matching name if requested, FALSE on failure, or an associative array containing all available info.

Předcházející | Nahoru | Další
HttpRequest::getResponseHeader | Domů | HttpRequest::getResponseMessage


HttpRequest::getResponseMessage

(PECL pecl_http:0.10.0-1.5.5)

HttpRequest::getResponseMessage — Get response message

Popis

public HttpMessage HttpRequest::getResponseMessage ( void )

Get the full response as HttpMessage object after the request has been sent.

If redirects were allowed and several responses were received, the data references the last received response. Use HttpMessage::getParentMessage() to access the data of previously received responses within this request cycle.

Návratové hodnoty

Returns an HttpMessage object of the response.

Errors/Exceptions

Throws HttpException, HttpRuntimeException.

Předcházející | Nahoru | Další
HttpRequest::getResponseInfo | Domů | HttpRequest::getResponseStatus


HttpRequest::getResponseStatus

(PECL pecl_http:0.23.0-1.5.5)

HttpRequest::getResponseStatus — Get response status

Popis

public string HttpRequest::getResponseStatus ( void )

Get the response status (i.e. the string after the response code) after the message has been sent.

Návratové hodnoty

Returns a string containing the response status text.

Předcházející | Nahoru | Další
HttpRequest::getResponseMessage | Domů | HttpRequest::getSslOptions


HttpRequest::getSslOptions

(No version information available, might be only in CVS)

HttpRequest::getSslOptions — Get ssl options

Popis

public array HttpRequest::getSslOptions ( void )

Get previously set SSL options.

Návratové hodnoty

Returns an associative array containing any previously set SSL options.

Předcházející | Nahoru | Další
HttpRequest::getResponseStatus | Domů | HttpRequest::getUrl


HttpRequest::getUrl

(PECL pecl_http:0.10.0-1.5.5)

HttpRequest::getUrl — Get url

Popis

public string HttpRequest::getUrl ( void )

Get the previously set request URL.

Návratové hodnoty

Returns the currently set request url as string.

Předcházející | Nahoru | Další
HttpRequest::getSslOptions | Domů | HttpRequest::resetCookies


HttpRequest::resetCookies

(PECL pecl_http:1.0.0-1.5.5)

HttpRequest::resetCookies — Reset cookies

Popis

public bool HttpRequest::resetCookies ( [bool $session_only = FALSE] )

Reset all automatically received/sent cookies.

Poznámka: Note that customly set cookies are not affected.

Seznam parametrů

session_only

whether only session cookies should be reset (needs libcurl >= v7.15.4, else libcurl >= v7.14.1)

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
HttpRequest::getUrl | Domů | HttpRequest::send


HttpRequest::send

(PECL pecl_http:0.10.0-1.5.5)

HttpRequest::send — Send request

Popis

public HttpMessage HttpRequest::send ( void )

Send the HTTP request.

Poznámka: While an exception may be thrown, the transfer could have succeeded at least partially, so you might want to check the return values of various HttpRequest::getResponse*() methods.

Návratové hodnoty

Returns the received response as HttpMessage object.

Errors/Exceptions

Throws HttpRuntimeException, HttpRequestException, HttpMalformedHeaderException, HttpEncodingException.

Příklady

Příklad 727. GET example

<?php
$r = new HttpRequest('http://example.com/feed.rss', HttpRequest::METH_GET);
$r->setOptions(array('lastmodified' => filemtime('local.rss')));
$r->addQueryData(array('category' => 3));
try {
    $r->send();
    if ($r->getResponseCode() == 200) {
        file_put_contents('local.rss', $r->getResponseBody());
    }
} catch (HttpException $ex) {
    echo $ex;
}
?>

Příklad 728. POST example

<?php
$r = new HttpRequest('http://example.com/form.php', HttpRequest::METH_POST);
$r->setOptions(array('cookies' => array('lang' => 'de')));
$r->addPostFields(array('user' => 'mike', 'pass' => 's3c|r3t'));
$r->addPostFile('image', 'profile.jpg', 'image/jpeg');
try {
    echo $r->send()->getBody();
} catch (HttpException $ex) {
    echo $ex;
}
?>

Předcházející | Nahoru | Další
HttpRequest::resetCookies | Domů | HttpRequest::setContentType


HttpRequest::setContentType

(PECL pecl_http:0.10.0-1.5.5)

HttpRequest::setContentType — Set content type

Popis

public bool HttpRequest::setContentType ( string $content_type )

Set the content type the post request should have.

Seznam parametrů

content_type

the content type of the request (primary/secondary)

Návratové hodnoty

Returns TRUE on success, or FALSE if the content type does not seem to contain a primary and a secondary part.

Předcházející | Nahoru | Další
HttpRequest::send | Domů | HttpRequest::setCookies


HttpRequest::setCookies

(PECL pecl_http:0.12.0-1.5.5)

HttpRequest::setCookies — Set cookies

Popis

public bool HttpRequest::setCookies ( [array $cookies] )

Set custom cookies.

Seznam parametrů

cookies

an associative array as parameter containing cookie name/value pairs; if empty or omitted, all previously set cookies will be unset

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
HttpRequest::setContentType | Domů | HttpRequest::setHeaders


HttpRequest::setHeaders

(PECL pecl_http:0.12.0-1.5.5)

HttpRequest::setHeaders — Set headers

Popis

public bool HttpRequest::setHeaders ( [array $headers] )

Set request header name/value pairs.

Seznam parametrů

headers

an associative array as parameter containing header name/value pairs; if empty or omitted, all previously set headers will be unset

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
HttpRequest::setCookies | Domů | HttpRequest::setMethod


HttpRequest::setMethod

(PECL pecl_http:0.10.0-1.5.5)

HttpRequest::setMethod — Set method

Popis

public bool HttpRequest::setMethod ( int $request_method )

Set the request method.

Seznam parametrů

request_method

the request method to use

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
HttpRequest::setHeaders | Domů | HttpRequest::setOptions


HttpRequest::setOptions

(PECL pecl_http:0.10.0-1.5.5)

HttpRequest::setOptions — Set options

Popis

public bool HttpRequest::setOptions ( [array $options] )

Set the request options to use.

See the full list of request options.

Seznam parametrů

options

an associative array, which values will overwrite the currently set request options; if empty or omitted, the options of the HttpRequest object will be reset

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
HttpRequest::setMethod | Domů | HttpRequest::setPostFields


HttpRequest::setPostFields

(PECL pecl_http:0.10.0-1.5.5)

HttpRequest::setPostFields — Set post fields

Popis

public bool HttpRequest::setPostFields ( array $post_data )

Set the POST data entries, overwriting previously set POST data.

Affects only POST and custom requests.

Seznam parametrů

post_data

an associative array containing the post fields; if empty, the post data will be unset

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
HttpRequest::setOptions | Domů | HttpRequest::setPostFiles


HttpRequest::setPostFiles

(PECL pecl_http:0.10.0-1.5.5)

HttpRequest::setPostFiles — Set post files

Popis

public bool HttpRequest::setPostFiles ( array $post_files )

Set files to post, overwriting previously set post files.

Affects only POST and requests. Cannot be used with raw post data.

Seznam parametrů

post_files

an array containing the files to post; if empty, the post files will be unset

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
HttpRequest::setPostFields | Domů | HttpRequest::setPutData


HttpRequest::setPutData

(PECL pecl_http:0.25.0-1.5.5)

HttpRequest::setPutData — Set put data

Popis

public bool HttpRequest::setPutData ( [string $put_data] )

Set PUT data to send, overwriting previously set PUT data.

Affects only PUT requests.

Only either PUT data or PUT file can be used for each request. PUT data has higher precedence and will be used even if a PUT file is set.

Seznam parametrů

put_data

the data to upload

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
HttpRequest::setPostFiles | Domů | HttpRequest::setPutFile


HttpRequest::setPutFile

(PECL pecl_http:0.10.0-1.5.5)

HttpRequest::setPutFile — Set put file

Popis

public bool HttpRequest::setPutFile ( [string $file] )

Set file to put. Affects only PUT requests.

Seznam parametrů

file

the path to the file to send; if empty or omitted the put file will be unset

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
HttpRequest::setPutData | Domů | HttpRequest::setQueryData


HttpRequest::setQueryData

(PECL pecl_http:0.10.0-1.5.5)

HttpRequest::setQueryData — Set query data

Popis

public bool HttpRequest::setQueryData ( mixed $query_data )

Set the URL query parameters to use, overwriting previously set query parameters.

Affects any request types.

Seznam parametrů

query_data

a string or associative array parameter containing the pre-encoded query string or to be encoded query fields; if empty, the query data will be unset

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
HttpRequest::setPutFile | Domů | HttpRequest::setRawPostData


HttpRequest::setRawPostData

(PECL pecl_http:0.14.0-1.4.1)

HttpRequest::setRawPostData — Set raw post data

Popis

public bool HttpRequest::setRawPostData ( [string $raw_post_data] )

Set raw post data to send, overwriting previously set raw post data. Don't forget to specify a content type. Affects only POST and custom requests.

Only either post fields or raw post data can be used for each request. Raw post data has higher precedence and will be used even if post fields are set.

Seznam parametrů

raw_post_data

raw post data

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
HttpRequest::setQueryData | Domů | HttpRequest::setSslOptions


HttpRequest::setSslOptions

(PECL pecl_http:0.10.0-1.5.5)

HttpRequest::setSslOptions — Set ssl options

Popis

public bool HttpRequest::setSslOptions ( [array $options] )

Set SSL options.

Seznam parametrů

options

an associative array containing any SSL specific options; if empty or omitted, the SSL options will be reset

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
HttpRequest::setRawPostData | Domů | HttpRequest::setUrl


HttpRequest::setUrl

(PECL pecl_http:0.10.0-1.5.5)

HttpRequest::setUrl — Set URL

Popis

public bool HttpRequest::setUrl ( string $url )

Set the request URL.

Seznam parametrů

url

the request url

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
HttpRequest::setSslOptions | Domů | HttpRequestPool


HttpRequestPool::attach

(PECL pecl_http:0.10.0-1.5.5)

HttpRequestPool::attach — Attach HttpRequest

Popis

public bool HttpRequestPool::attach ( HttpRequest $request )

Attach an HttpRequest object to this HttpRequestPool.

Varování

Set all options prior attaching!

Seznam parametrů

request

an HttpRequest object not already attached to any HttpRequestPool object

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Errors/Exceptions

Throws HttpInvalidParamException, HttpRequestException, HttpRequestPoolException, HttpEncodingException.

Předcházející | Nahoru | Další
HttpRequestPool | Domů | HttpRequestPool::__construct


HttpRequestPool::__construct

(PECL pecl_http:0.10.0-1.5.5)

HttpRequestPool::__construct — HttpRequestPool constructor

Popis

void HttpRequestPool::__construct ( [HttpRequest $request] )

Instantiate a new HttpRequestPool object. An HttpRequestPool is able to send several HttpRequests in parallel.

Accepts virtually infinite optional parameters each referencing an HttpRequest object.

Seznam parametrů

request

HttpRequest object to attach

Errors/Exceptions

Throws HttpRequestPoolException (HttpRequestException, HttpInvalidParamException).

Příklady

Příklad 729. A HttpRequestPool example

<?php
try {
    $pool = new HttpRequestPool(
        new HttpRequest('http://www.google.com/', HttpRequest::METH_HEAD),
        new HttpRequest('http://www.php.net/', HttpRequest::METH_HEAD)
    );
    $pool->send();
    foreach($pool as $request) {
        printf("%s is %s (%d)\n",
            $request->getUrl(),
            $request->getResponseCode() ? 'alive' : 'not alive',
            $request->getResponseCode()
        );
    }
} catch (HttpException $e) {
    echo $e;
}
?>

Předcházející | Nahoru | Další
HttpRequestPool::attach | Domů | HttpRequestPool::__destruct


HttpRequestPool::__destruct

(PECL pecl_http:0.10.0-1.5.5)

HttpRequestPool::__destruct — HttpRequestPool destructor

Popis

void HttpRequestPool::__destruct ( void )

Clean up HttpRequestPool object.

Předcházející | Nahoru | Další
HttpRequestPool::__construct | Domů | HttpRequestPool::detach


HttpRequestPool::detach

(PECL pecl_http:0.10.0-1.5.5)

HttpRequestPool::detach — Detach HttpRequest

Popis

bool HttpRequestPool::detach ( HttpRequest $request )

Detach an HttpRequest object from this HttpRequestPool.

Seznam parametrů

request

an HttpRequest object attached to this HttpRequestPool object

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Errors/Exceptions

Throws HttpInvalidParamException, HttpRequestPoolException.

Předcházející | Nahoru | Další
HttpRequestPool::__destruct | Domů | HttpRequestPool::getAttachedRequests


HttpRequestPool::getAttachedRequests

(PECL pecl_http:0.16.0-1.5.5)

HttpRequestPool::getAttachedRequests — Get attached requests

Popis

array HttpRequestPool::getAttachedRequests ( void )

Get attached HttpRequest objects.

Seznam parametrů

Návratové hodnoty

Returns an array containing all currently attached HttpRequest objects.

Předcházející | Nahoru | Další
HttpRequestPool::detach | Domů | HttpRequestPool::getFinishedRequests


HttpRequestPool::getFinishedRequests

(PECL pecl_http:0.16.0-1.5.5)

HttpRequestPool::getFinishedRequests — Get finished requests

Popis

array HttpRequestPool::getFinishedRequests ( void )

Get attached HttpRequest objects that already have finished their work.

Seznam parametrů

Návratové hodnoty

Returns an array containing all attached HttpRequest objects that already have finished their work.

Předcházející | Nahoru | Další
HttpRequestPool::getAttachedRequests | Domů | HttpRequestPool::reset


HttpRequestPool::reset

(PECL pecl_http:0.10.0-1.5.5)

HttpRequestPool::reset — Reset request pool

Popis

void HttpRequestPool::reset ( void )

Detach all attached HttpRequest objects.

Předcházející | Nahoru | Další
HttpRequestPool::getFinishedRequests | Domů | HttpRequestPool::send


HttpRequestPool::send

(PECL pecl_http:0.10.0-1.5.5)

HttpRequestPool::send — Send all requests

Popis

bool HttpRequestPool::send ( void )

Send all attached HttpRequest objects in parallel.

Seznam parametrů

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Errors/Exceptions

Throws HttpRequestPoolException (HttpSocketException, HttpRequestException, HttpMalformedHeaderException).

Předcházející | Nahoru | Další
HttpRequestPool::reset | Domů | HttpRequestPool::socketPerform


HttpRequestPool::socketPerform

(PECL pecl_http:0.15.0-1.5.5)

HttpRequestPool::socketPerform — Perform socket actions

Popis

protected bool HttpRequestPool::socketPerform ( void )

Returns TRUE until each request has finished its transaction.

Návratové hodnoty

Returns TRUE until each request has finished its transaction.

Příklady

Příklad 730. A HttpRequestPool::socketPerform() example

<?php
class MyPool extends HttpRequestPool
{
    public function send()
    {
        while ($this->socketPerform()) {
            if (!$this->socketSelect()) {
                throw new HttpSocketExcpetion;
            }
        }
    }

    protected final function socketPerform()
    {
        $result = parent::socketPerform();
        foreach ($this->getFinishedRequests() as $r) {
            $this->detach($r);
            // handle response of finished request
        }
        return $result;
    }
}
?>

Předcházející | Nahoru | Další
HttpRequestPool::send | Domů | HttpRequestPool::socketSelect


HttpRequestPool::socketSelect

(PECL pecl_http:0.10.0-1.5.5)

HttpRequestPool::socketSelect — Perform socket select

Popis

protected bool HttpRequestPool::socketSelect ( void )

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
HttpRequestPool::socketPerform | Domů | HttpResponse


HttpResponse::capture

(PECL pecl_http:0.10.0-1.5.5)

HttpResponse::capture — Capture script output

Popis

static void HttpResponse::capture ( void )

Capture script output.

Příklady

Příklad 731. A HttpResponse::capture() example

<?php
HttpResponse::setCache(true);
HttpResponse::capture();
// script follows
?>

Viz také

HttpResponse::send()

Předcházející | Nahoru | Další
HttpResponse | Domů | HttpResponse::getBufferSize


HttpResponse::getBufferSize

(PECL pecl_http:0.10.0-1.5.5)

HttpResponse::getBufferSize — Get buffer size

Popis

static int HttpResponse::getBufferSize ( void )

Get current buffer size.

Návratové hodnoty

Returns an int representing the current buffer size in bytes.

Viz také

HttpResponse::setBufferSize()
HttpResponse::getThrottleDelay()
HttpResponse::setThrottleDelay()

Předcházející | Nahoru | Další
HttpResponse::capture | Domů | HttpResponse::getCacheControl


HttpResponse::getCache

(PECL pecl_http:0.10.0-1.5.5)

HttpResponse::getCache — Get cache

Popis

static bool HttpResponse::getCache ( void )

Get current caching setting.

Návratové hodnoty

Returns TRUE if caching should be attempted, else FALSE.

Viz také

HttpResponse::setCacheControl()
HttpResponse::getCacheControl()
HttpResponse::setCache()

Předcházející | Nahoru | Další
HttpResponse::getCacheControl | Domů | HttpResponse::getContentDisposition


HttpResponse::getCacheControl

(PECL pecl_http:0.10.0-1.5.5)

HttpResponse::getCacheControl — Get cache control

Popis

static string HttpResponse::getCacheControl ( void )

Get current Cache-Control header setting.

Návratové hodnoty

Returns the current cache control setting as a string like sent in a header.

Viz také

HttpResponse::setCacheControl()
HttpResponse::setCache()
HttpResponse::getCachel()

Předcházející | Nahoru | Další
HttpResponse::getBufferSize | Domů | HttpResponse::getCache


HttpResponse::getContentDisposition

(PECL pecl_http:0.10.0-1.5.5)

HttpResponse::getContentDisposition — Get content disposition

Popis

static string HttpResponse::getContentDisposition ( void )

Get current Content-Disposition setting.

Návratové hodnoty

Returns the current content disposition as string like sent in a header.

Viz také

HttpResponse::setContentDisposition()
HttpResponse::getContentType()
HttpResponse::setContentType()

Předcházející | Nahoru | Další
HttpResponse::getCache | Domů | HttpResponse::getContentType


HttpResponse::getContentType

(PECL pecl_http:0.10.0-1.5.5)

HttpResponse::getContentType — Get content type

Popis

static string HttpResponse::getContentType ( void )

Get current Content-Type header setting.

Návratové hodnoty

Returns the currently set content type as string.

Viz také

HttpResponse::getContentDisposition()
HttpResponse::setContentDisposition()
HttpResponse::setContentType()
HttpResponse::guessContentType()

Předcházející | Nahoru | Další
HttpResponse::getContentDisposition | Domů | HttpResponse::getData


HttpResponse::getData

(PECL pecl_http:0.10.0-1.5.5)

HttpResponse::getData — Get data

Popis

static string HttpResponse::getData ( void )

Get the previously set data to be sent.

Návratové hodnoty

Returns a string containing the previously set data to send.

Viz také

HttpResponse::setData()
HttpResponse::getFile()
HttpResponse::setFile()
HttpResponse::getStream()
HttpResponse::setStream()

Předcházející | Nahoru | Další
HttpResponse::getContentType | Domů | HttpResponse::getETag


HttpResponse::getETag

(PECL pecl_http:0.10.0-1.5.5)

HttpResponse::getETag — Get ETag

Popis

static string HttpResponse::getETag ( void )

Get calculated or previously set custom ETag.

Návratové hodnoty

Returns the calculated or previously set ETag as unquoted string.

Viz také

HttpResponse::getLastModified()
HttpResponse::setLastModified()
HttpResponse::setETag()

Předcházející | Nahoru | Další
HttpResponse::getData | Domů | HttpResponse::getFile


HttpResponse::getFile

(PECL pecl_http:0.10.0-1.5.5)

HttpResponse::getFile — Get file

Popis

static string HttpResponse::getFile ( void )

Get the previously set file to be sent.

Návratové hodnoty

Returns the previously set path to the file to send as string.

Viz také

HttpResponse::getData()
HttpResponse::setData()
HttpResponse::setFile()
HttpResponse::getStream()
HttpResponse::setStream()

Předcházející | Nahoru | Další
HttpResponse::getETag | Domů | HttpResponse::getGzip


HttpResponse::getGzip

(PECL pecl_http:0.10.0-1.5.5)

HttpResponse::getGzip — Get gzip

Popis

static bool HttpResponse::getGzip ( void )

Get current gzip'ing setting.

Návratové hodnoty

Returns TRUE if GZip compression is enabled, else FALSE.

Viz také

HttpResponse::setGzip()

Předcházející | Nahoru | Další
HttpResponse::getFile | Domů | HttpResponse::getHeader


HttpResponse::getHeader

(PECL pecl_http:0.12.0-1.5.5)

HttpResponse::getHeader — Get header

Popis

static mixed HttpResponse::getHeader ( [string $name] )

Get header(s) about to be sent.

Poznámka: This may not work as expected with the following SAPI(s): Apache2 w/PHP < 5.1.3.

Seznam parametrů

name

specifies the name of the header to read; if empty or omitted, an associative array with all headers will be returned

Návratové hodnoty

Returns either a string containing the value of the header matching name, FALSE on failure, or an associative array with all headers.

Viz také

HttpResponse::setHeader()

Předcházející | Nahoru | Další
HttpResponse::getGzip | Domů | HttpResponse::getLastModified


HttpResponse::getLastModified

(PECL pecl_http:0.12.0-1.5.5)

HttpResponse::getLastModified — Get last modified

Popis

static int HttpResponse::getLastModified ( void )

Get calculated or previously set custom Last-Modified date.

Návratové hodnoty

Returns the calculated or previously set Unix timestamp.

Viz také

HttpResponse::setLastModified()
HttpResponse::getETag()
HttpResponse::setETag()

Předcházející | Nahoru | Další
HttpResponse::getHeader | Domů | HttpResponse::getStream


HttpResponse::getRequestBody

(No version information available, might be only in CVS)

HttpResponse::getRequestBody — Get request body

Popis

static string HttpResponse::getRequestBody ( void )

Tato funkce je aliasem: http_get_request_body().

Předcházející | Nahoru | Další
HttpResponse::getThrottleDelay | Domů | HttpResponse::getRequestBodyStream


HttpResponse::getRequestBodyStream

(No version information available, might be only in CVS)

HttpResponse::getRequestBodyStream — Get request body stream

Popis

static resource HttpResponse::getRequestBodyStream ( void )

Tato funkce je aliasem: http_get_request_body_stream().

Předcházející | Nahoru | Další
HttpResponse::getRequestBody | Domů | HttpResponse::getRequestHeaders


HttpResponse::getRequestHeaders

(No version information available, might be only in CVS)

HttpResponse::getRequestHeaders — Get request headers

Popis

static array HttpResponse::getRequestHeaders ( void )

Tato funkce je aliasem: http_get_request_headers().

Předcházející | Nahoru | Další
HttpResponse::getRequestBodyStream | Domů | HttpResponse::guessContentType


HttpResponse::getStream

(PECL pecl_http:0.10.0-1.5.5)

HttpResponse::getStream — Get Stream

Popis

static resource HttpResponse::getStream ( void )

Get the previously set resource to be sent.

Seznam parametrů

Návratové hodnoty

Returns the previously set resource.

Viz také

HttpResponse::getData()
HttpResponse::setData()
HttpResponse::getFile()
HttpResponse::setFile()
HttpResponse::setStream()

Předcházející | Nahoru | Další
HttpResponse::getLastModified | Domů | HttpResponse::getThrottleDelay


HttpResponse::getThrottleDelay

(PECL pecl_http:0.10.0-1.5.5)

HttpResponse::getThrottleDelay — Get throttle delay

Popis

static double HttpResponse::getThrottleDelay ( void )

Get the current throttle delay.

Návratové hodnoty

Returns a double representing the throttle delay in seconds.

Viz také

HttpResponse::getBufferSize()
HttpResponse::setBufferSize()
HttpResponse::setThrottleDelay()

Předcházející | Nahoru | Další
HttpResponse::getStream | Domů | HttpResponse::getRequestBody


HttpResponse::guessContentType

(PECL pecl_http:0.13.0-1.5.5)

HttpResponse::guessContentType — Guess content type

Popis

static string HttpResponse::guessContentType ( string $magic_file [, int $magic_mode=MAGIC_MIME] )

Attempts to guess the content type of supplied payload through libmagic.

If the attempt is successful, the guessed Content-Type will automatically be set as response Content-Type.

Seznam parametrů

magic_file

specifies the magic.mime database to use

magic_mode

flags for libmagic

Návratové hodnoty

Returns the guessed content type on success, or FALSE on failure.

Errors/Exceptions

Throws HttpRuntimeException, HttpInvalidParamException.

Viz také

HttpResponse::getContentType()
HttpResponse::setContentType()

Předcházející | Nahoru | Další
HttpResponse::getRequestHeaders | Domů | HttpResponse::redirect


HttpResponse::redirect

(No version information available, might be only in CVS)

HttpResponse::redirect — Redirect

Popis

static void HttpResponse::redirect ( [string $url [, array $params [, bool $session = FALSE [, int $status]]]] )

Tato funkce je aliasem: http_redirect().

Předcházející | Nahoru | Další
HttpResponse::guessContentType | Domů | HttpResponse::send


HttpResponse::send

(PECL pecl_http:0.10.0-1.5.5)

HttpResponse::send — Send response

Popis

static bool HttpResponse::send ( [bool $clean_ob = TRUE] )

Finally send the entity.

A successful caching attempt will exit PHP, and write a log entry if the INI setting http.log.cache is set. See the INI setting http.force_exit for what "exits" means.

Seznam parametrů

clean_ob

whether to destroy all previously started output handlers and their buffers

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 732. A HttpResponse::send() example

<?php
HttpResponse::setCache(true);
HttpResponse::setContentType('application/pdf');
HttpResponse::setContentDisposition("$user.pdf", false);
HttpResponse::setFile('sheet.pdf');
HttpResponse::send();
?>

Viz také

HttpResponse::capture()

Předcházející | Nahoru | Další
HttpResponse::redirect | Domů | HttpResponse::setBufferSize


HttpResponse::setBufferSize

(PECL pecl_http:0.10.0-1.5.5)

HttpResponse::setBufferSize — Set buffer size

Popis

static bool HttpResponse::setBufferSize ( int $bytes )

Sets the send buffer size of the throttling mechanism.

Poznámka: Provides a basic throttling mechanism, which will yield the current process respectively thread until the entity has been completely sent.

Poznámka: This may not work as expected with the following SAPI(s): FastCGI.

Seznam parametrů

bytes

the chunk size in bytes

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

HttpResponse::getBufferSize()
HttpResponse::getThrottleDelay()
HttpResponse::setThrottleDelay()

Předcházející | Nahoru | Další
HttpResponse::send | Domů | HttpResponse::setCacheControl


HttpResponse::setCache

(PECL pecl_http:0.10.0-1.5.5)

HttpResponse::setCache — Set cache

Popis

static bool HttpResponse::setCache ( bool $cache )

Whether it should be attempted to cache the entity.

This will result in necessary caching headers and checks of clients If-Modified-Since and If-None-Match headers. If one of those headers matches a 304 Not Modified status code will be issued.

Poznámka: If you're using sessions, be sure that you set session.cache_limiter to something more appropriate than "no-cache"!

Seznam parametrů

cache

whether caching should be attempted

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

HttpResponse::setCacheControl()
HttpResponse::getCacheControl()
HttpResponse::getCachel()

Předcházející | Nahoru | Další
HttpResponse::setCacheControl | Domů | HttpResponse::setContentDisposition


HttpResponse::setCacheControl

(PECL pecl_http:0.10.0-1.5.5)

HttpResponse::setCacheControl — Set cache control

Popis

static bool HttpResponse::setCacheControl ( string $control [, int $max_age = 0 [, bool $must_revalidate = TRUE]] )

Define a custom Cache-Control header, usually being private or public;

Seznam parametrů

control

the primary cache control setting

max_age

the max-age in seconds, suggesting how long the cache entry is valid on the client side

must_revalidate

whether the cached entity should be revalidated by the client for every request

Návratové hodnoty

Returns TRUE on success, or FALSE if control does not match one of public, private or no-cache.

Viz také

HttpResponse::getCacheControl()
HttpResponse::setCache()
HttpResponse::getCache()

Předcházející | Nahoru | Další
HttpResponse::setBufferSize | Domů | HttpResponse::setCache


HttpResponse::setContentDisposition

(PECL pecl_http:0.10.0-1.5.5)

HttpResponse::setContentDisposition — Set content disposition

Popis

static bool HttpResponse::setContentDisposition ( string $filename [, bool $inline = FALSE] )

Set the Content-Disposition. The Content-Disposition header is very useful if the data actually sent came from a file or something similar, that should be "saved" by the client/user (i.e. by browsers "Save as..." popup window).

Seznam parametrů

filename

the file name the "Save as..." dialog should display

inline

if set to true and the user agent knows how to handle the content type, it will probably not cause the popup window to be shown

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

HttpResponse::getContentDisposition()
HttpResponse::getContentType()
HttpResponse::setContentType()

Předcházející | Nahoru | Další
HttpResponse::setCache | Domů | HttpResponse::setContentType


HttpResponse::setContentType

(PECL pecl_http:0.10.0-1.5.5)

HttpResponse::setContentType — Set content type

Popis

static bool HttpResponse::setContentType ( string $content_type )

Set the Content-Type of the sent entity.

Seznam parametrů

content_type

the content type of the sent entity (primary/secondary)

Návratové hodnoty

Returns TRUE on success, or FALSE if the content type does not seem to contain a primary and secondary content type part.

Viz také

HttpResponse::getContentDisposition()
HttpResponse::setContentDisposition()
HttpResponse::getContentType()
HttpResponse::guessContentType()

Předcházející | Nahoru | Další
HttpResponse::setContentDisposition | Domů | HttpResponse::setData


HttpResponse::setData

(PECL pecl_http:0.10.0-1.5.5)

HttpResponse::setData — Set data

Popis

static bool HttpResponse::setData ( mixed $data )

Set the data to be sent.

Poznámka: Previously calculated or defined ETag and Last-Modified will be recalculated and redefined.

Seznam parametrů

data

data to send

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

HttpResponse::getData()
HttpResponse::getFile()
HttpResponse::setFile()
HttpResponse::getStream()
HttpResponse::setStream()

Předcházející | Nahoru | Další
HttpResponse::setContentType | Domů | HttpResponse::setETag


HttpResponse::setETag

(PECL pecl_http:0.10.0-1.5.5)

HttpResponse::setETag — Set ETag

Popis

static bool HttpResponse::setETag ( string $etag )

Set a custom ETag. Use this only if you know what you're doing.

Seznam parametrů

etag

unquoted string as parameter containing the ETag

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

HttpResponse::getLastModified()
HttpResponse::setLastModified()
HttpResponse::getETag()

Předcházející | Nahoru | Další
HttpResponse::setData | Domů | HttpResponse::setFile


HttpResponse::setFile

(PECL pecl_http:0.10.0-1.5.5)

HttpResponse::setFile — Set file

Popis

static bool HttpResponse::setFile ( string $file )

Set the file to be sent.

Poznámka: Previously calculated or defined ETag and Last-Modified will be recalculated and redefined.

Seznam parametrů

file

the path to the file to send

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

HttpResponse::getData()
HttpResponse::setData()
HttpResponse::getFile()
HttpResponse::getStream()
HttpResponse::setStream()

Předcházející | Nahoru | Další
HttpResponse::setETag | Domů | HttpResponse::setGzip


HttpResponse::setGzip

(PECL pecl_http:0.10.0-1.5.5)

HttpResponse::setGzip — Set gzip

Popis

static bool HttpResponse::setGzip ( bool $gzip )

Enable on-thy-fly gzip'ing of the sent entity.

Seznam parametrů

gzip

whether GZip compression should be enabled

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

HttpResponse::getGzip()

Předcházející | Nahoru | Další
HttpResponse::setFile | Domů | HttpResponse::setHeader


HttpResponse::setHeader

(PECL pecl_http:0.12.0-1.5.5)

HttpResponse::setHeader — Set header

Popis

static bool HttpResponse::setHeader ( string $name [, mixed $value [, bool $replace = TRUE]] )

Send an HTTP header.

Seznam parametrů

name

the name of the header

value

the value of the header; if not set, no header with this name will be sent

replace

whether an existing header should be replaced

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

HttpResponse::getHeader()

Předcházející | Nahoru | Další
HttpResponse::setGzip | Domů | HttpResponse::setLastModified


HttpResponse::setLastModified

(PECL pecl_http:0.12.0-1.5.5)

HttpResponse::setLastModified — Set last modified

Popis

static bool HttpResponse::setLastModified ( int $timestamp )

Set a custom Last-Modified date.

Seznam parametrů

timestamp

Unix timestamp representing the last modification time of the sent entity

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

HttpResponse::getLastModified()
HttpResponse::getETag()
HttpResponse::setETag()

Předcházející | Nahoru | Další
HttpResponse::setHeader | Domů | HttpResponse::setStream


HttpResponse::setStream

(PECL pecl_http:0.10.0-1.5.5)

HttpResponse::setStream — Set stream

Popis

static bool HttpResponse::setStream ( resource $stream )

Set the resource to be sent.

Poznámka: Previously calculated or defined ETag and Last-Modified will be recalculated and redefined.

Seznam parametrů

stream

already opened stream from which the data to send will be read

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

HttpResponse::getData()
HttpResponse::setData()
HttpResponse::getFile()
HttpResponse::setFile()
HttpResponse::getStream()

Předcházející | Nahoru | Další
HttpResponse::setLastModified | Domů | HttpResponse::setThrottleDelay


HttpResponse::setThrottleDelay

(PECL pecl_http:0.10.0-1.5.5)

HttpResponse::setThrottleDelay — Set throttle delay

Popis

static bool HttpResponse::setThrottleDelay ( float $seconds )

Sets the throttle delay.

Poznámka: Provides a basic throttling mechanism, which will yield the current process respectively thread until the entity has been completely sent.

Poznámka: This may not work as expected with the following SAPI(s): FastCGI.

Seznam parametrů

seconds

seconds to sleep after each chunk sent

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

HttpResponse::getBufferSize()
HttpResponse::setBufferSize()
HttpResponse::getThrottleDelay()

Předcházející | Nahoru | Další
HttpResponse::setStream | Domů | HttpResponse::status


HttpResponse::status

(No version information available, might be only in CVS)

HttpResponse::status — Send HTTP response status

Popis

static bool HttpResponse::status ( int $status )

Tato funkce je aliasem: http_send_status().

Předcházející | Nahoru | Další
HttpResponse::setThrottleDelay | Domů | http_cache_etag


id3_get_frame_long_name

(PECL id3:0.2)

id3_get_frame_long_name — Get the long name of an ID3v2 frame

Popis

string id3_get_frame_long_name ( string $frameId )

id3_get_frame_long_name() returns the long name for an ID3v2 frame.

Seznam parametrů

frameId

An ID3v2 frame

Návratové hodnoty

Returns the frame long name or FALSE on errors.

Příklady

Příklad 819. id3_get_frame_long_name() example

<?php
$longName = id3_get_frame_long_name("TOLY");
echo $longName;
?>

Výše uvedený příklad vypíše:

Original lyricist(s)/text writer(s)

Viz také

id3_get_frame_short_name()

Předcházející | Nahoru | Další
LXIII. ID3 Functions | Domů | id3_get_frame_short_name


id3_get_frame_short_name

(PECL id3:0.2)

id3_get_frame_short_name — Get the short name of an ID3v2 frame

Popis

string id3_get_frame_short_name ( string $frameId )

id3_get_frame_short_name() returns the short name for an ID3v2 frame.

Seznam parametrů

frameId

An ID3v2 frame

Návratové hodnoty

Returns the frame short name or FALSE on errors.

The values returned by id3_get_short_name() are used in the array returned by id3_get_tag().

Příklady

Příklad 820. id3_get_frame_short_name() example

<?php
$shortName = id3_get_frame_short_name("TOLY");
echo $shortName;
?>

Výše uvedený příklad vypíše:

originalLyricist

Viz také

id3_get_frame_long_name()

Předcházející | Nahoru | Další
id3_get_frame_long_name | Domů | id3_get_genre_id


iis_add_server

(No version information available, might be only in CVS)

iis_add_server — Creates a new virtual web server

Popis

int iis_add_server ( string $path, string $comment, string $server_ip, int $port, string $host_name, int $rights, int $start_server )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
LXIV. IIS Administration Functions | Domů | iis_get_dir_security


iis_get_dir_security

(No version information available, might be only in CVS)

iis_get_dir_security — Gets Directory Security

Popis

int iis_get_dir_security ( int $server_instance, string $virtual_path )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
iis_add_server | Domů | iis_get_script_map


iis_get_script_map

(No version information available, might be only in CVS)

iis_get_script_map — Gets script mapping on a virtual directory for a specific extension

Popis

string iis_get_script_map ( int $server_instance, string $virtual_path, string $script_extension )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
iis_get_dir_security | Domů | iis_get_server_by_comment


iis_get_server_by_comment

(No version information available, might be only in CVS)

iis_get_server_by_comment — Return the instance number associated with the Comment

Popis

int iis_get_server_by_comment ( string $comment )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
iis_get_script_map | Domů | iis_get_server_by_path


iis_get_server_by_path

(No version information available, might be only in CVS)

iis_get_server_by_path — Return the instance number associated with the Path

Popis

int iis_get_server_by_path ( string $path )

Each virtual server in IIS is associated with an instance number. iis_get_server_by_path() finds the instance number from the actual path to the root directory.

Seznam parametrů

path

The path to the root directory

Návratové hodnoty

Returns the server instance number.

Předcházející | Nahoru | Další
iis_get_server_by_comment | Domů | iis_get_server_rights


iis_get_server_rights

(No version information available, might be only in CVS)

iis_get_server_rights — Gets server rights

Popis

int iis_get_server_rights ( int $server_instance, string $virtual_path )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
iis_get_server_by_path | Domů | iis_get_service_state


iis_get_service_state

(No version information available, might be only in CVS)

iis_get_service_state — Returns the state for the service defined by ServiceId

Popis

int iis_get_service_state ( string $service_id )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
iis_get_server_rights | Domů | iis_remove_server


iis_remove_server

(No version information available, might be only in CVS)

iis_remove_server — Removes the virtual web server indicated by ServerInstance

Popis

int iis_remove_server ( int $server_instance )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
iis_get_service_state | Domů | iis_set_app_settings


iis_set_app_settings

(No version information available, might be only in CVS)

iis_set_app_settings — Creates application scope for a virtual directory

Popis

int iis_set_app_settings ( int $server_instance, string $virtual_path, string $application_scope )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
iis_remove_server | Domů | iis_set_dir_security


iis_set_dir_security

(No version information available, might be only in CVS)

iis_set_dir_security — Sets Directory Security

Popis

int iis_set_dir_security ( int $server_instance, string $virtual_path, int $directory_flags )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
iis_set_app_settings | Domů | iis_set_script_map


iis_set_script_map

(No version information available, might be only in CVS)

iis_set_script_map — Sets script mapping on a virtual directory

Popis

int iis_set_script_map ( int $server_instance, string $virtual_path, string $script_extension, string $engine_path, int $allow_scripting )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
iis_set_dir_security | Domů | iis_set_server_rights


iis_set_server_rights

(No version information available, might be only in CVS)

iis_set_server_rights — Sets server rights

Popis

int iis_set_server_rights ( int $server_instance, string $virtual_path, int $directory_flags )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
iis_set_script_map | Domů | iis_start_server


iis_start_server

(No version information available, might be only in CVS)

iis_start_server — Starts the virtual web server

Popis

int iis_start_server ( int $server_instance )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
iis_set_server_rights | Domů | iis_start_service


iis_start_service

(No version information available, might be only in CVS)

iis_start_service — Starts the service defined by ServiceId

Popis

int iis_start_service ( string $service_id )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
iis_start_server | Domů | iis_stop_server


iis_stop_server

(No version information available, might be only in CVS)

iis_stop_server — Stops the virtual web server

Popis

int iis_stop_server ( int $server_instance )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
iis_start_service | Domů | iis_stop_service


iis_stop_service

(No version information available, might be only in CVS)

iis_stop_service — Stops the service defined by ServiceId

Popis

int iis_stop_service ( string $service_id )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
iis_stop_server | Domů | LXV. Image Functions


imageconvolution

(PHP 5 >= 5.1.0)

imageconvolution — Apply a 3x3 convolution matrix, using coefficient and offset

Popis

bool imageconvolution ( resource $image, array $matrix, float $div, float $offset )

Applies a convolution matrix on the image, using the given coefficient and offset.

Seznam parametrů

image

An image resource, returned by one of the image creation functions, such as imagecreatetruecolor().

matrix

A 3x3 matrix: an array of three arrays of three floats.

div

The divisor of the result of the convolution, used for normalization.

offset

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 845. Embossing the PHP.net logo

<?php
$image = imagecreatefromgif('http://www.php.net/images/php.gif');

$emboss = array(array(2, 0, 0), array(0, -1, 0), array(0, 0, -1));
imageconvolution($image, $emboss, 1, 127);

header('Content-Type: image/png');
imagepng($image, null, 9);
?>

Výše uvedený příklad vypíše:

Příklad 846. Gaussian blur

<?php
$image = imagecreatetruecolor(180,40);

// Writes the text and apply a gaussian blur on the image
imagestring($image, 5, 10, 8, 'Gaussian Blur Text', 0x00ff00);
$gaussian = array(array(1.0, 2.0, 1.0), array(2.0, 4.0, 2.0), array(1.0, 2.0, 1.0));
imageconvolution($image, $gaussian, 16, 0);

// Rewrites the text for comparison
imagestring($image, 5, 10, 18, 'Gaussian Blur Text', 0x00ff00);

header('Content-Type: image/png');
imagepng($image, null, 9);
?>

Výše uvedený příklad vypíše:

Poznámky

Poznámka: Tato funce je k dispozici jen tehdy, bylo-li PHP zkompilováno s přibalenou verzí knihovny GD.

Viz také

imagefilter()

Předcházející | Nahoru | Další
imagecolortransparent | Domů | imagecopy


imagegrabscreen

(PHP 5 >= 5.2.2)

imagegrabscreen — Captures the whole screen

Popis

resource imagegrabscreen ( void )

Grabs a screenshot of the whole screen.

Návratové hodnoty

Returns an image resource identifier on success, FALSE on failure.

Příklady

Příklad 865. imagegrabscreen() example

This example demonstrates how to take a screenshot of the current screen and save it as a png image.

<?php
$im = imagegrabscreen();
imagepng($im, "myscreenshot.png");
?>

Poznámky

Poznámka: This function is only available on Windows.

Viz také

imagegrabwindow()

Předcházející | Nahoru | Další
imagegif | Domů | imagegrabwindow


imagegrabwindow

(PHP 5 >= 5.2.2)

imagegrabwindow — Captures a window

Popis

resource imagegrabwindow ( int $window [, int $client_area] )

Grabs a window or its client area using a windows handle (HWND property in COM instance)

Seznam parametrů

window

The HWND window ID

client_area

Include the client area of the application window

Návratové hodnoty

Returns an image resource identifier on success, FALSE on failure.

Errors/Exceptions

E_NOTICE is issued if window_handle is invalid window handle. E_WARNING is issued if the Windows API is too old.

Příklady

Příklad 866. imagegrabwindow() example

Capture a window (IE for example)

<?php
$browser = new COM("InternetExplorer.Application");
$handle = $browser->HWND;
$browser->Visible = true;
$im = imagegrabwindow($handle);
$browser->Quit();
imagepng($im, "iesnap.png");
?>

Capture a window (IE for example) but with its content

<?php
$browser = new COM("InternetExplorer.Application");
$handle = $browser->HWND;
$browser->Visible = true;
$browser->Navigate("http://www.libgd.org");

/* Still working? */
while ($browser->Busy) {
    com_message_pump(4000);
}
$im = imagegrabwindow($handle, 0);
$browser->Quit();
imagepng($im, "iesnap.png");
?>

Poznámky

Poznámka: This function is only available on Windows.

Viz také

imagegrabscreen()

Předcházející | Nahoru | Další
imagegrabscreen | Domů | imageinterlace


Imagick::adaptiveBlurImage

(No version information available, might be only in CVS)

Imagick::adaptiveBlurImage — Adds adaptive blur filter to image

Popis

bool Imagick::adaptiveBlurImage ( float $radius, float $sigma [, int $channel] )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Adds an adaptive blur filter to image. The intensity of an adaptive blur depends is dramatically decreased at edge of the image, whereas a standard blur is uniform across the image.

Seznam parametrů

radius

The radius of the Gaussian, in pixels, not counting the center pixel. Provide a value of 0 and the radius will be chosen automagically.

sigma

The standard deviation of the Gaussian, in pixels.

channel

Provide any channel constant that is valid for your channel mode. To apply to more than one channel, combine channeltype constants using bitwise operators. Defaults to Imagick::CHANNEL_ALL. Refer to this list of channel constants.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws ImagickException on error.

Příklady

Příklad 881. Using Imagick::adaptiveBlurImage():

Adaptively blur an image, then display to the browser.

<?php

header('Content-type: image/jpeg');

$image = new Imagick('test.jpg');

$image->adaptiveBlurImage(5,3);
echo $image;

?>

Viz také

Imagick::blurImage()
Imagick::motionBlurImage()
Imagick::radialBlurImage()

Předcházející | Nahoru | Další
Imagick | Domů | Imagick::adaptiveResizeImage


Imagick::adaptiveResizeImage

(No version information available, might be only in CVS)

Imagick::adaptiveResizeImage — Adaptively resize image with data dependent triangulation

Popis

bool Imagick::adaptiveResizeImage ( int $columns, int $rows )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Adaptively resize image with data-dependent triangulation. Avoids blurring across sharp color changes. Most useful when used to shrink images slightly to a slightly smaller "web size"; may not look good when a full-sized image is adaptively resized to a thumbnail.

Seznam parametrů

columns

The number of columns in the scaled image.

rows

The number of rows in the scaled image.

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws ImagickException on error.

Příklady

Příklad 882. Using Imagick::adaptiveResizeImage()

Resize an image to a standard size for the web. This method works best when resizing to a size only slightly smaller than the previous image size.

<?php
header('Content-type: image/jpeg');

$image = new Imagick('image.jpg');
$image->adaptiveResizeImage(1024,768);

echo $image;
?>

Viz také

Imagick::chopImage()
Imagick::cropImage()
Imagick::magnifyImage()
Imagick::minifyImage()
Imagick::resizeImage()
Imagick::scaleImage()
Imagick::shaveImage()
Imagick::thumbnailImage()
Imagick::trimImage()

Předcházející | Nahoru | Další
Imagick::adaptiveBlurImage | Domů | Imagick::adaptiveSharpenImage


Imagick::adaptiveSharpenImage

(No version information available, might be only in CVS)

Imagick::adaptiveSharpenImage — Adaptively sharpen the image

Popis

bool Imagick::adaptiveSharpenImage ( float $radius, float $sigma [, int $channel] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Adaptively sharpen the image by sharpening more intensely near image edges and less intensely far from edges.

Seznam parametrů

radius

The radius of the Gaussian, in pixels, not counting the center pixel. Use 0 for auto-select.

sigma

The standard deviation of the Gaussian, in pixels.

channel

Provide any channel constant that is valid for your channel mode. To apply to more than one channel, combine channeltype constants using bitwise operators. Defaults to Imagick::CHANNEL_ALL. Refer to this list of channel constants.

Návratové hodnoty

Returns TRUE on success.

Příklady

Příklad 883. A Imagick::adaptiveSharpenImage() example

Adaptively sharpen the image with radius 2 and sigma 1.

<?php
try {
    $image = new Imagick('image.png');
    $image->adaptiveSharpenImage(2,1);
} catch(ImagickException $e) {
    echo 'Error: ' , $e->getMessage();
    die();
}
header('Content-type: image/png');
echo $image;
?>

Viz také

Imagick::sharpenImage()

Předcházející | Nahoru | Další
Imagick::adaptiveResizeImage | Domů | Imagick::adaptiveThresholdImage


Imagick::adaptiveThresholdImage

(No version information available, might be only in CVS)

Imagick::adaptiveThresholdImage — Selects a threshold for each pixel based on a range of intensity

Popis

bool Imagick::adaptiveThresholdImage ( int $width, int $height, int $offset )

Selects an individual threshold for each pixel based on the range of intensity values in its local neighborhood. This allows for thresholding of an image whose global intensity histogram doesn't contain distinctive peaks.

Seznam parametrů

width

Width of the local neighborhood.

height

Height of the local neighborhood.

offset

The mean offset

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::adaptiveSharpenImage | Domů | Imagick::addImage


Imagick::addImage

(No version information available, might be only in CVS)

Imagick::addImage — Adds new image to Imagick object image list

Popis

bool Imagick::addImage ( Imagick $source )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Adds new image to Imagick object from the current position of the source object. After the operation iterator position is moved at the end of the list.

Seznam parametrů

source

The source Imagick object

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::adaptiveThresholdImage | Domů | Imagick::addNoiseImage


Imagick::addNoiseImage

(No version information available, might be only in CVS)

Imagick::addNoiseImage — Adds random noise to the image

Popis

bool Imagick::addNoiseImage ( int $noise_type [, int $channel] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Adds random noise to the image.

Seznam parametrů

noise_type

The type of the noise. Refer to this list of noise constants.

channel

Provide any channel constant that is valid for your channel mode. To apply to more than one channel, combine channeltype constants using bitwise operators. Defaults to Imagick::CHANNEL_ALL. Refer to this list of channel constants.

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::addImage | Domů | Imagick::affineTransformImage


Imagick::affineTransformImage

(No version information available, might be only in CVS)

Imagick::affineTransformImage — Transforms an image

Popis

bool Imagick::affineTransformImage ( ImagickDraw $matrix )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Transforms an image as dictated by the affine matrix.

Seznam parametrů

matrix

The affine matrix

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::addNoiseImage | Domů | Imagick::annotateImage


Imagick::annotateImage

(No version information available, might be only in CVS)

Imagick::annotateImage — Annotates an image with text

Popis

bool Imagick::annotateImage ( ImagickDraw $draw_settings, float $x, float $y, float $angle, string $text )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Annotates an image with text.

Seznam parametrů

draw_settings

The ImagickDraw object that contains settings for drawing the text

x

Horizontal offset in pixels to the left of text

y

Vertical offset in pixels to the baseline of text

angle

The angle at which to write the text

text

The string to draw

Návratové hodnoty

Returns TRUE on success.

Příklady

Příklad 884. Using Imagick::annotateImage():

Annotate text on an empty image

<?php
/* Create some objects */
$image = new Imagick();
$draw = new ImagickDraw();
$pixel = new ImagickPixel( 'gray' );

/* New image */
$image->newImage(800, 75, $pixel);

/* Black text */
$pixel->setColor('black');

/* Font properties */
$draw->setFont('Bookman-DemiItalic');
$draw->setFontSize( 30 );

/* Create text */
$image->annotateImage($draw, 10, 45, 0, 'The quick brown fox jumps over the lazy dog');

/* Give image a format */
$image->setImageFormat('png');

/* Output the image with headers */
header('Content-type: image/png');
echo $image;

?>

Viz také

ImagickDraw::annotation()
ImagickDraw::setFont()

Předcházející | Nahoru | Další
Imagick::affineTransformImage | Domů | Imagick::appendImages


Imagick::appendImages

(No version information available, might be only in CVS)

Imagick::appendImages — Append a set of images

Popis

Imagick Imagick::appendImages ( bool $stack )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Append a set of images.

Seznam parametrů

stack

The direction of the stack (top to bottom or bottom to top)

Návratové hodnoty

Returns Imagick instance on success, throws ImagickException on failure.

Předcházející | Nahoru | Další
Imagick::annotateImage | Domů | Imagick::averageImages


Imagick::averageImages

(No version information available, might be only in CVS)

Imagick::averageImages — Average a set of images

Popis

Imagick Imagick::averageImages ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Average a set of images.

Návratové hodnoty

Returns a new Imagick object on success, throws ImagickException on failure.

Předcházející | Nahoru | Další
Imagick::appendImages | Domů | Imagick::blackThresholdImage


Imagick::blackThresholdImage

(No version information available, might be only in CVS)

Imagick::blackThresholdImage — Forces all pixels below the threshold into black

Popis

bool Imagick::blackThresholdImage ( ImagickPixel $threshold )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Is like Imagick::thresholdImage() but forces all pixels below the threshold into black while leaving all pixels above the threshold unchanged.

Seznam parametrů

threshold

The threshold below which everything turns black

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::averageImages | Domů | Imagick::blurImage


Imagick::blurImage

(No version information available, might be only in CVS)

Imagick::blurImage — Adds blur filter to image

Popis

bool Imagick::blurImage ( float $radius, float $sigma [, int $channel] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Adds blur filter to image. Optional third parameter to blur a specific channel.

Seznam parametrů

radius

Blur radius

sigma

Standard deviation

channel

The Channeltype constant. When not supplied, all channels are blurred.

Návratové hodnoty

Returns TRUE on success.

Příklady

Příklad 885. Using Imagick::blurImage():

Blur an image, then display to the browser.

<?php

header('Content-type: image/jpeg');

$image = new Imagick('test.jpg');

$image->blurImage(5,3);
echo $image;

?>

Viz také

Imagick::adaptiveBlurImage()
Imagick::motionBlurImage()
Imagick::radialBlurImage()

Předcházející | Nahoru | Další
Imagick::blackThresholdImage | Domů | Imagick::borderImage


Imagick::borderImage

(No version information available, might be only in CVS)

Imagick::borderImage — Surrounds the image with a border

Popis

bool Imagick::borderImage ( ImagickPixel $bordercolor, int $width, int $height )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Surrounds the image with a border of the color defined by the bordercolor ImagickPixel object.

Seznam parametrů

bordercolor

ImagickPixel object containing the border color

width

Border width

height

Border height

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::blurImage | Domů | Imagick::charcoalImage


Imagick::charcoalImage

(No version information available, might be only in CVS)

Imagick::charcoalImage — Simulates a charcoal drawing

Popis

bool Imagick::charcoalImage ( float $radius, float $sigma )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Simulates a charcoal drawing.

Seznam parametrů

radius

The radius of the Gaussian, in pixels, not counting the center pixel

sigma

The standard deviation of the Gaussian, in pixels

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::borderImage | Domů | Imagick::chopImage


Imagick::chopImage

(No version information available, might be only in CVS)

Imagick::chopImage — Removes a region of an image and trims

Popis

bool Imagick::chopImage ( int $width, int $height, int $x, int $y )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Removes a region of an image and collapses the image to occupy the removed portion.

Seznam parametrů

width

Width of the chopped area

height

Height of the chopped area

x

X origo of the chopped area

y

Y origo of the chopped area

Návratové hodnoty

Returns TRUE on success.

Příklady

Příklad 886. Using Imagick::chopImage():

Example of using Imagick::chopImage

<?php
/* Create some objects */
$image = new Imagick();
$pixel = new ImagickPixel( 'gray' );

/* New image */
$image->newImage(400, 200, $pixel);

/* Chop image */
$image->chopImage(200, 200, 0, 0);

/* Give image a format */
$image->setImageFormat('png');

/* Output the image with headers */
header('Content-type: image/png');
echo $image;

?>

Viz také

Imagick::cropImage()

Předcházející | Nahoru | Další
Imagick::charcoalImage | Domů | Imagick::clear


Imagick::clear

(No version information available, might be only in CVS)

Imagick::clear — Clears all resources associated to Imagick object

Popis

bool Imagick::clear ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Clears all resources associated to Imagick object

Seznam parametrů

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::chopImage | Domů | Imagick::clipImage


Imagick::clipImage

(No version information available, might be only in CVS)

Imagick::clipImage — Clips along the first path from the 8BIM profile

Popis

bool Imagick::clipImage ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Clips along the first path from the 8BIM profile, if present.

Seznam parametrů

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::clear | Domů | Imagick::clipPathImage


Imagick::clipPathImage

(No version information available, might be only in CVS)

Imagick::clipPathImage — Clips along the named paths from the 8BIM profile

Popis

bool Imagick::clipPathImage ( string $pathname, bool $inside )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Clips along the named paths from the 8BIM profile, if present. Later operations take effect inside the path. It may be a number if preceded with #, to work on a numbered path, e.g., "#1" to use the first path.

Seznam parametrů

pathname

The name of the path

inside

If true later operations take effect inside clipping path. Otherwise later operations take effect outside clipping path.

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::clipImage | Domů | Imagick::clone


Imagick::clone

(No version information available, might be only in CVS)

Imagick::clone — Makes an exact copy of the Imagick object

Popis

Imagick Imagick::clone ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Makes an exact copy of the Imagick object.

Seznam parametrů

Návratové hodnoty

What the function returns, first on success, then on failure. See also the &return.success; entity

Předcházející | Nahoru | Další
Imagick::clipPathImage | Domů | Imagick::coalesceImages


Imagick::clutImage

(No version information available, might be only in CVS)

Imagick::clutImage — Replaces colors in the image from a color lookup table

Popis

bool Imagick::clutImage ( Imagick $lookup_table [, int $channel] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Replaces colors in the image from a color lookup table. Optional second parameter to replace colors in a specific channel. This method is available if Imagick is compiled against ImageMagick 6.3.5-7 or newer.

Seznam parametrů

lookup_table

Imagick object containing the color lookup table

channel

The Channeltype constant. When not supplied, all channels are replaced.

Návratové hodnoty

Returns TRUE on success.

Příklady

Příklad 887. Using Imagick::clutImage():

Replace colors in the image from a color lookup table.

<?php
$image = new Imagick('test.jpg');
$clut = new Imagick();
$clut->newImage(1, 1, new ImagickPixel('black'));
$image->clutImage( $clut );
$image->writeImage( 'test_out.jpg' );
?>

Viz také

Imagick::adaptiveBlurImage()
Imagick::motionBlurImage()
Imagick::radialBlurImage()

Předcházející | Nahoru | Další
Imagick::colorizeImage | Domů | Imagick::combineImages


Imagick::coalesceImages

(No version information available, might be only in CVS)

Imagick::coalesceImages — Composites a set of images

Popis

Imagick Imagick::coalesceImages ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Composites a set of images while respecting any page offsets and disposal methods. GIF, MIFF, and MNG animation sequences typically start with an image background and each subsequent image varies in size and offset. Returns a new Imagick object where each image in the sequence is the same size as the first and composited with the next image in the sequence.

Seznam parametrů

Návratové hodnoty

Returns a new Imagick object on success, throws ImagickException on failure.

Předcházející | Nahoru | Další
Imagick::clone | Domů | Imagick::colorFloodfillImage


Imagick::colorFloodfillImage

(No version information available, might be only in CVS)

Imagick::colorFloodfillImage — Changes the color value of any pixel that matches target

Popis

bool Imagick::colorFloodfillImage ( ImagickPixel $fill, float $fuzz, ImagickPixel $bordercolor, int $x, int $y )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Changes the color value of any pixel that matches target and is an immediate neighbor.

Seznam parametrů

fill

ImagickPixel object containing the fill color

fuzz

The amount of fuzz. For example, set fuzz to 10 and the color red at intensities of 100 and 102 respectively are now interpreted as the same color for the purposes of the floodfill.

bordercolor

ImagickPixel object containing the border color

x

X start position of the floodfill

y

Y start position of the floodfill

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::coalesceImages | Domů | Imagick::colorizeImage


Imagick::colorizeImage

(No version information available, might be only in CVS)

Imagick::colorizeImage — Blends the fill color with the image

Popis

bool Imagick::colorizeImage ( ImagickPixel $colorize, ImagickPixel $opacity )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Blends the fill color with each pixel in the image.

Seznam parametrů

colorize

Colorize ImagickPixel object

opacity

Opacity ImagickPixel object

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::colorFloodfillImage | Domů | Imagick::clutImage


Imagick::combineImages

(No version information available, might be only in CVS)

Imagick::combineImages — Combines one or more images into a single image

Popis

Imagick Imagick::combineImages ( int $channelType )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Combines one or more images into a single image. The grayscale value of the pixels of each image in the sequence is assigned in order to the specified channels of the combined image. The typical ordering would be image 1 => Red, 2 => Green, 3 => Blue, etc.

Seznam parametrů

channelType

Provide any channel constant that is valid for your channel mode. To apply to more than one channel, combine channeltype constants using bitwise operators. Defaults to Imagick::CHANNEL_ALL. Refer to this list of channel constants.

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::clutImage | Domů | Imagick::commentImage


Imagick::commentImage

(No version information available, might be only in CVS)

Imagick::commentImage — Adds a comment to your image

Popis

bool Imagick::commentImage ( string $comment )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Adds a comment to your image.

Seznam parametrů

comment

The comment to add

Návratové hodnoty

Returns TRUE on success.

Příklady

Příklad 888. Using Imagick::commentImage():

Commenting an image and retrieving the comment:

<?php

/* Create new Imagick object */
$im = new imagick();

/* Create an empty image */
$im->newImage(100, 100, new ImagickPixel("red"));

/* Add comment to the image */
$im->commentImage("Hello World!");

/* Display the comment */
echo $im->getImageProperty("comment");

?>

Předcházející | Nahoru | Další
Imagick::combineImages | Domů | Imagick::compareImageChannels


Imagick::compareImageChannels

(No version information available, might be only in CVS)

Imagick::compareImageChannels — Returns the difference in one or more images

Popis

Imagick Imagick::compareImageChannels ( Imagick $image, int $channelType, int $metricType )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Compares one or more images and returns the difference image.

Seznam parametrů

image

Imagick object containing the image to compare.

channelType

Provide any channel constant that is valid for your channel mode. To apply to more than one channel, combine channeltype constants using bitwise operators. Defaults to Imagick::CHANNEL_ALL. Refer to this list of channel constants.

metricType

One of the metric type constants.

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::commentImage | Domů | Imagick::compareImageLayers


Imagick::compareImageLayers

(No version information available, might be only in CVS)

Imagick::compareImageLayers — Returns the maximum bounding region between images

Popis

Imagick Imagick::compareImageLayers ( int $method )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Compares each image with the next in a sequence and returns the maximum bounding region of any pixel differences it discovers.

Seznam parametrů

method

One of the layer method constants.

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::compareImageChannels | Domů | Imagick::compositeImage


Imagick::compareImages

(No version information available, might be only in CVS)

Imagick::compareImages — Compares an image to a reconstructed image

Popis

array Imagick::compareImages ( Imagick $compare, int $metric )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns an array containing a reconstructed image and the difference between images.

Seznam parametrů

compare

An image to compare to.

metric

Provide a valid metric type constant. Refer to this list of metic constants.

Návratové hodnoty

Returns TRUE on success.

Příklady

Příklad 890. Using Imagick::compareImages():

Compare images and display the reconstructed image

<?php

$image1 = new imagick("image1.png");
$image2 = new imagick("image2.png");

$result = $image1->compareImage($image2, Imagick::METRIC_MEANSQUAREERROR);
$result[0]->setImageFormat("png");

header("Content-Type: image/png");
echo $result[0];

?>

Předcházející | Nahoru | Další
Imagick::morphImages | Domů | Imagick::mosaicImages


Imagick::compositeImage

(No version information available, might be only in CVS)

Imagick::compositeImage — Composite one image onto another

Popis

bool Imagick::compositeImage ( Imagick $composite_object, int $composite, int $x, int $y [, int $channel] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Composite one image onto another at the specified offset.

Seznam parametrů

composite_object

Imagick object which holds the composite image

compose

Composite operator. See Composite Operator Constants

x

The column offset of the composited image

y

The row offset of the composited image

channel

Provide any channel constant that is valid for your channel mode. To apply to more than one channel, combine channeltype constants using bitwise operators. Defaults to Imagick::CHANNEL_ALL. Refer to this list of channel constants.

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::compareImageLayers | Domů | Imagick::__construct


Imagick::__construct

(No version information available, might be only in CVS)

Imagick::__construct — The Imagick constructor

Popis

Imagick Imagick::__construct ( [mixed $files] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

The Imagick constructor

Seznam parametrů

files

The path to an image to load or array of paths

Návratové hodnoty

Returns a new Imagick object on success, throws ImagickException on failure.

Předcházející | Nahoru | Další
Imagick::compositeImage | Domů | Imagick::contrastImage


Imagick::contrastImage

(No version information available, might be only in CVS)

Imagick::contrastImage — Change the contrast of the image

Popis

bool Imagick::contrastImage ( bool $sharpen )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Enhances the intensity differences between the lighter and darker elements of the image. Set sharpen to a value other than 0 to increase the image contrast otherwise the contrast is reduced.

Seznam parametrů

sharpen

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::__construct | Domů | Imagick::contrastStretchImage


Imagick::contrastStretchImage

(No version information available, might be only in CVS)

Imagick::contrastStretchImage — Enhances the contrast of a color image

Popis

bool Imagick::contrastStretchImage ( float $black_point, float $white_point [, int $channel] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Enhances the contrast of a color image by adjusting the pixels color to span the entire range of colors available

Seznam parametrů

black_point

white_point

channel

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::contrastImage | Domů | Imagick::convolveImage


Imagick::convolveImage

(No version information available, might be only in CVS)

Imagick::convolveImage — Applies a custom convolution kernel to the image

Popis

bool Imagick::convolveImage ( array $kernel [, int $channel] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Applies a custom convolution kernel to the image.

Seznam parametrů

kernel

The convolution kernel

channel

Provide any channel constant that is valid for your channel mode. To apply to more than one channel, combine channeltype constants using bitwise operators. Defaults to Imagick::CHANNEL_ALL. Refer to this list of channel constants.

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::contrastStretchImage | Domů | Imagick::cropImage


Imagick::cropImage

(No version information available, might be only in CVS)

Imagick::cropImage — Extracts a region of the image

Popis

bool Imagick::cropImage ( int $width, int $height, int $x, int $y )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Extracts a region of the image.

Seznam parametrů

width

height

x

y

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::convolveImage | Domů | Imagick::current


Imagick::cropThumbnailImage

(No version information available, might be only in CVS)

Imagick::cropThumbnailImage — Creates a crop thumbnail

Popis

bool Imagick::cropThumbnailImage ( int $width, int $height )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Creates a fixed size thumbnail by first scaling the image down and cropping a specified area from the center.

Seznam parametrů

width

height of the thumbnail

height

height of the thumbnail

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::displayImages | Domů | Imagick::roundCorners


Imagick::current

(No version information available, might be only in CVS)

Imagick::current — Sets image pointer at the correct sequence

Popis

Imagick Imagick::current ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns reference to the current imagick object with image pointer at the correct sequence.

Seznam parametrů

Návratové hodnoty

Returns self on success, throws ImagickException on failure.

Předcházející | Nahoru | Další
Imagick::cropImage | Domů | Imagick::cycleColormapImage


Imagick::cycleColormapImage

(No version information available, might be only in CVS)

Imagick::cycleColormapImage — Displaces an image's colormap

Popis

bool Imagick::cycleColormapImage ( int $displace )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Displaces an image's colormap by a given number of positions. If you cycle the colormap a number of times you can produce a psychedelic effect.

Seznam parametrů

displace

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::current | Domů | Imagick::deconstructImages


Imagick::deconstructImages

(No version information available, might be only in CVS)

Imagick::deconstructImages — Returns certain pixel differences between images

Popis

bool Imagick::deconstructImages ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Compares each image with the next in a sequence and returns the maximum bounding region of any pixel differences it discovers.

Seznam parametrů

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::cycleColormapImage | Domů | Imagick::despeckleImage


Imagick::despeckleImage

(No version information available, might be only in CVS)

Imagick::despeckleImage — Reduces the speckle noise in an image

Popis

bool Imagick::despeckleImage ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Reduces the speckle noise in an image while perserving the edges of the original image.

Seznam parametrů

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::deconstructImages | Domů | Imagick::destroy


Imagick::destroy

(No version information available, might be only in CVS)

Imagick::destroy — Destroys the Imagick object

Popis

bool Imagick::destroy ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Destroys the Imagick object

Seznam parametrů

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::despeckleImage | Domů | Imagick::drawImage


Imagick::displayImage

(No version information available, might be only in CVS)

Imagick::displayImage — Displays an image

Popis

bool Imagick::displayImage ( string $servername )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

This method displays an image on a X server.

Seznam parametrů

servername

The X server name

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::writeImage | Domů | Imagick::displayImages


Imagick::displayImages

(No version information available, might be only in CVS)

Imagick::displayImages — Displays an image or image sequence

Popis

bool Imagick::displayImages ( string $servername )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Displays an image or image sequence on a X server.

Seznam parametrů

servername

The X server name

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::displayImage | Domů | Imagick::cropThumbnailImage


Imagick::distortImage

(No version information available, might be only in CVS)

Imagick::distortImage — Distorts an image using various distortion methods

Popis

bool Imagick::distortImage ( int $method, array $arguments, bool $bestfit )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Distorts an image using various distortion methods, by mapping color lookups of the source image to a new destination image usally of the same size as the source image, unless 'bestfit' is set to true. If 'bestfit' is enabled, and distortion allows it, the destination image is adjusted to ensure the whole source 'image' will just fit within the final destination image, which will be sized and offset accordingly. Also in many cases the virtual offset of the source image will be taken into account in the mapping. This functionality is present if Imagick is compiled against ImageMagick 6.3.6 or later.

Seznam parametrů

method

The method of image distortion. See distortion constants

arguments

The arguments for this distortion method

bestfit

Attempt to resize destination to fit distorted source

Návratové hodnoty

Returns TRUE on success.

Errors/Exceptions

Throws ImagickException on error.

Příklady

Příklad 891. Using Imagick::distortImage():

Distort an image and write it to the disk.

<?php

$im = new imagick( "example.jpg" );

$im->distortImage( Imagick::DISTORTION_PERSPECTIVE, array( 7,40, 4,30, 4,124, 4,123, 85,122, 100,123, 85,2, 100,30 ), true );

$im->writeImage( "example_out.jpg" );

?>

Viz také

Imagick::blurImage()
Imagick::motionBlurImage()
Imagick::radialBlurImage()

Předcházející | Nahoru | Další
Imagick::negateImage | Domů | Imagick::newImage


Imagick::drawImage

(No version information available, might be only in CVS)

Imagick::drawImage — Renders the ImagickDrawing object on the current image

Popis

bool Imagick::drawImage ( ImagickDraw $drawing_wand )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Renders the ImagickDrawing object on the current image.

Seznam parametrů

drawing_wand

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::destroy | Domů | Imagick::edgeImage


Imagick::edgeImage

(No version information available, might be only in CVS)

Imagick::edgeImage — Enhance edges within the image

Popis

bool Imagick::edgeImage ( float $radius )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Enhance edges within the image with a convolution filter of the given radius. Use a radius of 0 and Edge() selects a suitable radius for you.

Seznam parametrů

radius

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::drawImage | Domů | Imagick::embossImage


Imagick::embossImage

(No version information available, might be only in CVS)

Imagick::embossImage — Returns a grayscale image with a three-dimensional effect

Popis

bool Imagick::embossImage ( float $radius, float $sigma )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns a grayscale image with a three-dimensional effect. We convolve the image with a Gaussian operator of the given radius and standard deviation (sigma). For reasonable results, radius should be larger than sigma. Use a radius of 0 and it will choose a suitable radius for you.

Seznam parametrů

radius

sigma

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::edgeImage | Domů | Imagick::enhanceImage


Imagick::enhanceImage

(No version information available, might be only in CVS)

Imagick::enhanceImage — Improves the quality of a noisy image

Popis

bool Imagick::enhanceImage ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Applies a digital filter that improves the quality of a noisy image.

Seznam parametrů

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::embossImage | Domů | Imagick::equalizeImage


Imagick::equalizeImage

(No version information available, might be only in CVS)

Imagick::equalizeImage — Equalizes the image histogram

Popis

bool Imagick::equalizeImage ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Equalizes the image histogram.

Seznam parametrů

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::enhanceImage | Domů | Imagick::evaluateImage


Imagick::evaluateImage

(No version information available, might be only in CVS)

Imagick::evaluateImage — Applies an expression to an image

Popis

bool Imagick::evaluateImage ( int $op, float $constant [, int $channel] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Applys an arithmetic, relational, or logical expression to an image. Use these operators to lighten or darken an image, to increase or decrease contrast in an image, or to produce the "negative" of an image.

Seznam parametrů

op

constant

channel

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::equalizeImage | Domů | Imagick::flattenImages


Imagick::flattenImages

(No version information available, might be only in CVS)

Imagick::flattenImages — Merges a sequence of images

Popis

bool Imagick::flattenImages ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Merges a sequence of images. This is useful for combining Photoshop layers into a single image.

Seznam parametrů

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::evaluateImage | Domů | Imagick::flipImage


Imagick::flipImage

(No version information available, might be only in CVS)

Imagick::flipImage — Creates a vertical mirror image

Popis

bool Imagick::flipImage ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Creates a vertical mirror image by reflecting the pixels around the central x-axis.

Seznam parametrů

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::flattenImages | Domů | Imagick::flopImage


Imagick::flopImage

(No version information available, might be only in CVS)

Imagick::flopImage — Creates a horizontal mirror image

Popis

bool Imagick::flopImage ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Creates a horizontal mirror image by reflecting the pixels around the central y-axis.

Seznam parametrů

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::flipImage | Domů | Imagick::frameImage


Imagick::frameImage

(No version information available, might be only in CVS)

Imagick::frameImage — Adds a simulated three-dimensional border

Popis

bool Imagick::frameImage ( ImagickPixel $matte_color, int $width, int $height, int $inner_bevel, int $outer_bevel )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Adds a simulated three-dimensional border around the image. The width and height specify the border width of the vertical and horizontal sides of the frame. The inner and outer bevels indicate the width of the inner and outer shadows of the frame.

Seznam parametrů

matte_color

width

height

inner_bevel

outer_bevel

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::flopImage | Domů | Imagick::fxImage


Imagick::fxImage

(No version information available, might be only in CVS)

Imagick::fxImage — Evaluate expression for each pixel in the image

Popis

bool Imagick::fxImage ( string $expression [, int $channel] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Evaluate expression for each pixel in the image.

Seznam parametrů

expression

channel

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::frameImage | Domů | Imagick::gammaImage


Imagick::gammaImage

(No version information available, might be only in CVS)

Imagick::gammaImage — Gamma-corrects an image

Popis

bool Imagick::gammaImage ( float $gamma [, int $channel] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Gamma-corrects an image. The same image viewed on different devices will have perceptual differences in the way the image's intensities are represented on the screen. Specify individual gamma levels for the red, green, and blue channels, or adjust all three with the gamma parameter. Values typically range from 0.8 to 2.3.

Seznam parametrů

gamma

channel

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::fxImage | Domů | Imagick::gaussianBlurImage


Imagick::gaussianBlurImage

(No version information available, might be only in CVS)

Imagick::gaussianBlurImage — Blurs an image

Popis

bool Imagick::gaussianBlurImage ( float $radius, float $sigma [, int $channel] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Blurs an image. We convolve the image with a Gaussian operator of the given radius and standard deviation (sigma). For reasonable results, the radius should be larger than sigma. Use a radius of 0 and selects a suitable radius for you.

Seznam parametrů

radius

sigma

channel

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::gammaImage | Domů | Imagick::getCompressionQuality


Imagick::getCompression

(No version information available, might be only in CVS)

Imagick::getCompression — Gets the object compression type

Popis

int Imagick::getCompression ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Gets the object compression type.

Seznam parametrů

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::getCompressionQuality | Domů | Imagick::getCopyright


Imagick::getCompressionQuality

(No version information available, might be only in CVS)

Imagick::getCompressionQuality — Gets the object compression quality

Popis

int Imagick::getCompressionQuality ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Gets the object compression quality.

Seznam parametrů

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::gaussianBlurImage | Domů | Imagick::getCompression


Imagick::getCopyright

(No version information available, might be only in CVS)

Imagick::getCopyright — Returns the ImageMagick API copyright as a string constant

Popis

string Imagick::getCopyright ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the ImageMagick API copyright as a string constant.

Seznam parametrů

Návratové hodnoty

Returns a string containing the copyright notice of Imagemagick and Magickwand C API.

Předcházející | Nahoru | Další
Imagick::getCompression | Domů | Imagick::getFilename


Imagick::getFilename

(No version information available, might be only in CVS)

Imagick::getFilename — The filename associated with an image sequence

Popis

string Imagick::getFilename ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the filename associated with an image sequence.

Seznam parametrů

Návratové hodnoty

Returns a string on success, throws ImagickException on failure.

Předcházející | Nahoru | Další
Imagick::getCopyright | Domů | Imagick::getFormat


Imagick::getFormat

(No version information available, might be only in CVS)

Imagick::getFormat — Returns the format of the Imagick object

Popis

string Imagick::getFormat ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the format of the Imagick object.

Seznam parametrů

Návratové hodnoty

Returns the format of the image and throwns an ImagickException on failure.

Předcházející | Nahoru | Další
Imagick::getFilename | Domů | Imagick::getHomeURL


Imagick::getHomeURL

(No version information available, might be only in CVS)

Imagick::getHomeURL — Returns the ImageMagick home URL

Popis

string Imagick::getHomeURL ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the ImageMagick home URL.

Seznam parametrů

Návratové hodnoty

Returns a linke to the imagemagick homepage.

Předcházející | Nahoru | Další
Imagick::getFormat | Domů | Imagick::getImageBackgroundColor


Imagick::getImage

(No version information available, might be only in CVS)

Imagick::getImage — Returns a new Imagick object

Popis

Imagick Imagick::getImage ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns a new Imagick object with the current image sequence.

Seznam parametrů

Návratové hodnoty

Returns a new Imagick object with the current image sequence, throwing ImagickException on error.

Předcházející | Nahoru | Další
Imagick::getImageWidth | Domů | Imagick::getInterlaceScheme


Imagick::getImageBackgroundColor

(No version information available, might be only in CVS)

Imagick::getImageBackgroundColor — Returns the image background color

Popis

ImagickPixel Imagick::getImageBackgroundColor ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the image background color.

Seznam parametrů

Návratové hodnoty

Returns an ImagickPixel set to the background color of the image, throws ImagickException on failure.

Předcházející | Nahoru | Další
Imagick::getHomeURL | Domů | Imagick::getImageBlob


Imagick::getImageBlob

(No version information available, might be only in CVS)

Imagick::getImageBlob — Returns the image sequence as a blob

Popis

string Imagick::getImageBlob ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Implements direct to memory image formats. It returns the image sequence as a string. The format of the image determines the format of the returned blob (GIF, JPEG, PNG, etc.). To return a different image format, use Imagick::SetImageFormat().

Seznam parametrů

Návratové hodnoty

Returns a string containing the image. On failure, throws ImagickException.

Předcházející | Nahoru | Další
Imagick::getImageBackgroundColor | Domů | Imagick::getImageBluePrimary


Imagick::getImageBluePrimary

(No version information available, might be only in CVS)

Imagick::getImageBluePrimary — Returns the chromaticy blue primary point

Popis

ImagickPixel Imagick::getImageBluePrimary ( float $x, float $y )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the chromaticy blue primary point for the image.

Seznam parametrů

x

y

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::getImageBlob | Domů | Imagick::getImageBorderColor


Imagick::getImageBorderColor

(No version information available, might be only in CVS)

Imagick::getImageBorderColor — Returns the image border color

Popis

ImagickPixel Imagick::getImageBorderColor ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the image border color.

Seznam parametrů

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::getImageBluePrimary | Domů | Imagick::getImageChannelDepth


Imagick::getImageChannelDepth

(No version information available, might be only in CVS)

Imagick::getImageChannelDepth — Gets the depth for a particular image channel

Popis

int Imagick::getImageChannelDepth ( int $channelType )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Gets the depth for a particular image channel.

Seznam parametrů

expression

channel

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::getImageBorderColor | Domů | Imagick::getImageChannelDistortion


Imagick::getImageChannelDistortion

(No version information available, might be only in CVS)

Imagick::getImageChannelDistortion — Compares image channels of an image to a reconstructed image

Popis

float Imagick::getImageChannelDistortion ( Imagick $reference, int $channel, int $metric )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Compares one or more image channels of an image to a reconstructed image and returns the specified distortion metric.

Seznam parametrů

reference

channel

metric

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::getImageChannelDepth | Domů | Imagick::getImageChannelExtrema


Imagick::getImageChannelExtrema

(No version information available, might be only in CVS)

Imagick::getImageChannelExtrema — Gets the extrema for one or more image channels

Popis

array Imagick::getImageChannelExtrema ( int $channel )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Gets the extrema for one or more image channels. Return value is an associative array with the keys "minima" and "maxima".

Seznam parametrů

channel

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::getImageChannelDistortion | Domů | Imagick::getImageChannelMean


Imagick::getImageChannelMean

(No version information available, might be only in CVS)

Imagick::getImageChannelMean — Gets the mean and standard deviation

Popis

array Imagick::getImageChannelMean ( int $channel )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Gets the mean and standard deviation of one or more image channels. Return value is an associative array with the keys "mean" and "standardDeviation".

Seznam parametrů

channel

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::getImageChannelExtrema | Domů | Imagick::getImageChannelStatistics


Imagick::getImageChannelStatistics

(No version information available, might be only in CVS)

Imagick::getImageChannelStatistics — Returns statistics for each channel in the image

Popis

array Imagick::getImageChannelStatistics ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns statistics for each channel in the image. The statistics incude the channel depth, its minima and maxima, the mean, and the standard deviation. You can access the red channel mean, for example, like this:

Seznam parametrů

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::getImageChannelMean | Domů | Imagick::getImageColormapColor


Imagick::getImageColormapColor

(No version information available, might be only in CVS)

Imagick::getImageColormapColor — Returns the color of the specified colormap index

Popis

ImagickPixel Imagick::getImageColormapColor ( int $index )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the color of the specified colormap index.

Seznam parametrů

index

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::getImageChannelStatistics | Domů | Imagick::getImageColorspace


Imagick::getImageColors

(No version information available, might be only in CVS)

Imagick::getImageColors — Gets the number of unique colors in the image

Popis

int Imagick::getImageColors ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Gets the number of unique colors in the image.

Seznam parametrů

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::getImageColorspace | Domů | Imagick::getImageCompose


Imagick::getImageColorspace

(No version information available, might be only in CVS)

Imagick::getImageColorspace — Gets the image colorspace

Popis

int Imagick::getImageColorspace ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Gets the image colorspace.

Seznam parametrů

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::getImageColormapColor | Domů | Imagick::getImageColors


Imagick::getImageCompose

(No version information available, might be only in CVS)

Imagick::getImageCompose — Returns the composite operator associated with the image

Popis

int Imagick::getImageCompose ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the composite operator associated with the image.

Seznam parametrů

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::getImageColors | Domů | Imagick::getImageDelay


Imagick::getImageDelay

(No version information available, might be only in CVS)

Imagick::getImageDelay — Gets the image delay

Popis

int Imagick::getImageDelay ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Gets the image delay.

Seznam parametrů

Návratové hodnoty

Returns the image delay and throws ImagickException on failure.

Předcházející | Nahoru | Další
Imagick::getImageCompose | Domů | Imagick::getImageDepth


Imagick::getImageDepth

(No version information available, might be only in CVS)

Imagick::getImageDepth — Gets the image depth

Popis

int Imagick::getImageDepth ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Gets the image depth.

Seznam parametrů

Návratové hodnoty

What the function returns, first on success, then on failure. See also the &return.success; entity

Předcházející | Nahoru | Další
Imagick::getImageDelay | Domů | Imagick::getImageDispose


Imagick::getImageDispose

(No version information available, might be only in CVS)

Imagick::getImageDispose — Gets the image disposal method

Popis

int Imagick::getImageDispose ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Gets the image disposal method.

Seznam parametrů

Návratové hodnoty

Returns the dispose method on success, throws an ImagickException on failure.

Předcházející | Nahoru | Další
Imagick::getImageDepth | Domů | Imagick::getImageDistortion


Imagick::getImageDistortion

(No version information available, might be only in CVS)

Imagick::getImageDistortion — Compares an image to a reconstructed image

Popis

float Imagick::getImageDistortion ( MagickWand $reference, int $metric )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Compares an image to a reconstructed image and returns the specified distortion metric.

Seznam parametrů

reference

metric

Návratové hodnoty

Returns the distortion metric used on the image (or the best guess thereof). Throws an exception on error.

Předcházející | Nahoru | Další
Imagick::getImageDispose | Domů | Imagick::getImageExtrema


Imagick::getImageExtrema

(No version information available, might be only in CVS)

Imagick::getImageExtrema — Gets the extrema for the image

Popis

array Imagick::getImageExtrema ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Gets the extrema for the image. Returns an associative array with the keys "min" and "max".

Seznam parametrů

Návratové hodnoty

Returns an associative array with the keys "min" and "max". Throws ImagickException on failure.

Předcházející | Nahoru | Další
Imagick::getImageDistortion | Domů | Imagick::getImageFilename


Imagick::getImageFilename

(No version information available, might be only in CVS)

Imagick::getImageFilename — Returns the filename of a particular image in a sequence

Popis

string Imagick::getImageFilename ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the filename of a particular image in a sequence.

Seznam parametrů

Návratové hodnoty

Returns a string with the filename of the image. Throws an ImagickException on failure.

Předcházející | Nahoru | Další
Imagick::getImageExtrema | Domů | Imagick::getImageSize


Imagick::getImageFormat

(No version information available, might be only in CVS)

Imagick::getImageFormat — Returns the format of a particular image in a sequence

Popis

string Imagick::getImageFormat ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the format of a particular image in a sequence.

Seznam parametrů

Návratové hodnoty

Returns a string containing the image format on success, throws ImagickException on failure.

Předcházející | Nahoru | Další
Imagick::getImageLength | Domů | Imagick::getImageGamma


Imagick::getImageGamma

(No version information available, might be only in CVS)

Imagick::getImageGamma — Gets the image gamma

Popis

float Imagick::getImageGamma ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Gets the image gamma.

Seznam parametrů

Návratové hodnoty

Returns the image gamma on success, throws ImagickException on failure.

Předcházející | Nahoru | Další
Imagick::getImageFormat | Domů | Imagick::getImageGeometry


Imagick::getImageGeometry

(No version information available, might be only in CVS)

Imagick::getImageGeometry — Gets the width and height as an associative array

Popis

array Imagick::getImageGeometry ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the width and height as an associative array.

Seznam parametrů

Návratové hodnoty

Returns an array with the width/height of the image, throws ImagickException on error.

Předcházející | Nahoru | Další
Imagick::getImageGamma | Domů | Imagick::getImageGreenPrimary


Imagick::getImageGreenPrimary

(No version information available, might be only in CVS)

Imagick::getImageGreenPrimary — Returns the chromaticy green primary point

Popis

array Imagick::getImageGreenPrimary ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the chromaticy green primary point. Returns an array with the keys "x" and "y".

Seznam parametrů

Návratové hodnoty

Returns an array with the keys "x" and "y" on success, throws an ImagickException on failure.

Předcházející | Nahoru | Další
Imagick::getImageGeometry | Domů | Imagick::getImageHeight


Imagick::getImageHeight

(No version information available, might be only in CVS)

Imagick::getImageHeight — Returns the image height

Popis

int Imagick::getImageHeight ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the image height.

Seznam parametrů

Návratové hodnoty

Returns the image height in pixels, throws ImagickException on error.

Předcházející | Nahoru | Další
Imagick::getImageGreenPrimary | Domů | Imagick::getImageHistogram


Imagick::getImageHistogram

(No version information available, might be only in CVS)

Imagick::getImageHistogram — Gets the image histogram

Popis

array Imagick::getImageHistogram ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the image histogram as an array of ImagickPixel objects.

Seznam parametrů

Návratové hodnoty

Returns the image histogram as an array of ImagickPixel objects, throwing ImagickException on error.

Předcházející | Nahoru | Další
Imagick::getImageHeight | Domů | Imagick::getImageIndex


Imagick::getImageIndex

(No version information available, might be only in CVS)

Imagick::getImageIndex — Gets the index of the current active image

Popis

int Imagick::getImageIndex ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the index of the current active image within the Imagick object. This method has been deprecated. See Imagick::getIteratorIndex

Seznam parametrů

Návratové hodnoty

Returns an integer containing the index of the image in the stack, throwing ImagickException on error.

Předcházející | Nahoru | Další
Imagick::getImageHistogram | Domů | Imagick::getIteratorIndex


Imagick::getImageInterlaceScheme

(No version information available, might be only in CVS)

Imagick::getImageInterlaceScheme — Gets the image interlace scheme

Popis

int Imagick::getImageInterlaceScheme ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Gets the image interlace scheme.

Seznam parametrů

Návratové hodnoty

Returns the interlace scheme as an integer on success, throwing ImagickException on failure.

Předcházející | Nahoru | Další
Imagick::getIteratorIndex | Domů | Imagick::getImageInterpolateMethod


Imagick::getImageInterpolateMethod

(No version information available, might be only in CVS)

Imagick::getImageInterpolateMethod — Returns the interpolation method

Popis

int Imagick::getImageInterpolateMethod ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the interpolation method for the sepcified image.

Seznam parametrů

Návratové hodnoty

Returns the interpolate method on success, throws ImagickException on error.

Předcházející | Nahoru | Další
Imagick::getImageInterlaceScheme | Domů | Imagick::getImageIterations


Imagick::getImageIterations

(No version information available, might be only in CVS)

Imagick::getImageIterations — Gets the image iterations

Popis

int Imagick::getImageIterations ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Gets the image iterations.

Seznam parametrů

Návratové hodnoty

Returns the image iterations as an integer, throws ImagickException on failure.

Předcházející | Nahoru | Další
Imagick::getImageInterpolateMethod | Domů | Imagick::getImageMatteColor


Imagick::getImageLength

(No version information available, might be only in CVS)

Imagick::getImageLength — Returns the image length in bytes

Popis

int Imagick::getImageLength ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the image length in bytes

Seznam parametrů

Návratové hodnoty

Returns an int containing the current image size.

Předcházející | Nahoru | Další
Imagick::getImageSize | Domů | Imagick::getImageFormat


Imagick::getImageMatte

(No version information available, might be only in CVS)

Imagick::getImageMatte — Return if the image has a matte channel

Popis

int Imagick::getImageMatte ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns true if the image has a matte channel otherwise false.

Seznam parametrů

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
Imagick::getImageMatteColor | Domů | Imagick::getImagePage


Imagick::getImageMatteColor

(No version information available, might be only in CVS)

Imagick::getImageMatteColor — Returns the image matte color

Popis

ImagickPixel Imagick::getImageMatteColor ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the image matte color.

Seznam parametrů

Návratové hodnoty

What the function returns, first on success, then on failure. See also the &return.success; entity

Předcházející | Nahoru | Další
Imagick::getImageIterations | Domů | Imagick::getImageMatte


Imagick::getImageOrientation

(No version information available, might be only in CVS)

Imagick::getImageOrientation — Gets the image orientation.

Popis

int Imagick::getImageOrientation ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Gets the image orientation. The return value is one of the orientation constants.

Seznam parametrů

Návratové hodnoty

Returns an int on success, throws ImagickException on failure.

Předcházející | Nahoru | Další
Imagick::getInterlaceScheme | Domů | Imagick::getNumberImages


Imagick::getImagePage

(No version information available, might be only in CVS)

Imagick::getImagePage — Returns the page geometry

Popis

array Imagick::getImagePage ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the page geometry associated with the image in an array with the keys "width", "height", "x", and "y".

Seznam parametrů

Návratové hodnoty

Returns the page geometry associated with the image in an array with the keys "width", "height", "x", and "y".

Předcházející | Nahoru | Další
Imagick::getImageMatte | Domů | Imagick::getImagePixelColor


Imagick::getImagePixelColor

(No version information available, might be only in CVS)

Imagick::getImagePixelColor — Returns the color of the specified pixel

Popis

ImagickPixel Imagick::getImagePixelColor ( int $x, int $y )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the color of the specified pixel.

Seznam parametrů

x

y

Návratové hodnoty

Returns an ImagickPixel instance for the color at the coordinates given, throws ImagickException on error.

Předcházející | Nahoru | Další
Imagick::getImagePage | Domů | Imagick::getImageProfile


Imagick::getImageProfile

(No version information available, might be only in CVS)

Imagick::getImageProfile — Returns the named image profile

Popis

string Imagick::getImageProfile ( string $name )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the named image profile.

Seznam parametrů

name

Návratové hodnoty

Returns a string containing the image profile, throws ImagickException on error.

Předcházející | Nahoru | Další
Imagick::getImagePixelColor | Domů | Imagick::getImageProfiles


Imagick::getImageProfiles

(No version information available, might be only in CVS)

Imagick::getImageProfiles — Returns the image profiles

Popis

array Imagick::getImageProfiles ( [string $pattern [, bool $only_names]] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns all associated profiles that match the pattern. If true is passed as second parameter only the profile names are returned. This method is present if Imagick is compiled against ImageMagick 6.3.5-9 or later.

Seznam parametrů

pattern

The pattern for profile names. Defaults to "*"

only_names

Whether to return only profile names

Návratové hodnoty

Returns an array containing the image profiles or profile names.

Předcházející | Nahoru | Další
Imagick::getImageProfile | Domů | Imagick::getImageProperty


Imagick::getImageProperties

(No version information available, might be only in CVS)

Imagick::getImageProperties — Returns the image properties

Popis

array Imagick::getImageProperties ( [string $pattern [, bool $only_names]] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns all associated properties that match the pattern. If true is passed as second parameter only the property names are returned. This method is present if Imagick is compiled against ImageMagick 6.3.5-9 or later.

Seznam parametrů

pattern

The pattern for property names. Defaults to "*"

only_names

Whether to return only property names

Návratové hodnoty

Returns an array containing the image properties or property names.

Příklady

Příklad 889. Using Imagick::getImageProperties():

An example of extracting EXIF information.

<?php

/* Create the object */
$im = new imagick("/path/to/example.jpg");

/* Get the EXIF information */
$exifArray = $im->getImageProperties("exif:*");

/* Loop trough the exif properties */
foreach ($exifArray as $name => $property)
{
    echo "{$name} => {$property}<br />\n";
}

?>

Předcházející | Nahoru | Další
Imagick::getImageProperty | Domů | Imagick::getImageRedPrimary


Imagick::getImageProperty

(No version information available, might be only in CVS)

Imagick::getImageProperty — Returns the named image property

Popis

string Imagick::getImageProperty ( string $name )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the named image profile.

Seznam parametrů

name

name of the property (for example Exif:DateTime)

Návratové hodnoty

Returns a string containing the image property, false if a property with the given name does not exist.

Předcházející | Nahoru | Další
Imagick::getImageProfiles | Domů | Imagick::getImageProperties


Imagick::getImageRedPrimary

(No version information available, might be only in CVS)

Imagick::getImageRedPrimary — Returns the chromaticy red primary point

Popis

array Imagick::getImageRedPrimary ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the chromaticy red primary point as an array with the keys "x" and "y".

Seznam parametrů

Návratové hodnoty

Returns the chromaticy red primary point as an array with the keys "x" and "y", throwing ImagickException on error.

Předcházející | Nahoru | Další
Imagick::getImageProperties | Domů | Imagick::getImageRegion


Imagick::getImageRegion

(No version information available, might be only in CVS)

Imagick::getImageRegion — Extracts a region of the image

Popis

bool Imagick::getImageRegion ( int $width, int $height, int $x, int $y )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Extracts a region of the image and returns it as a a new wand.

Seznam parametrů

width

height

x

y

Návratové hodnoty

Extracts a region of the image and returns it as a a new wand, throwing ImagickException on error.

Předcházející | Nahoru | Další
Imagick::getImageRedPrimary | Domů | Imagick::getImageRenderingIntent


Imagick::getImageRenderingIntent

(No version information available, might be only in CVS)

Imagick::getImageRenderingIntent — Gets the image rendering intent

Popis

int Imagick::getImageRenderingIntent ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Gets the image rendering intent.

Seznam parametrů

Návratové hodnoty

Returns the image rendering intent, throwing ImagickException on error.

Předcházející | Nahoru | Další
Imagick::getImageRegion | Domů | Imagick::getImageResolution


Imagick::getImageResolution

(No version information available, might be only in CVS)

Imagick::getImageResolution — Gets the image X and Y resolution

Popis

array Imagick::getImageResolution ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Gets the image X and Y resolution.

Seznam parametrů

Návratové hodnoty

Returns the resolution as an array and throws ImagickException on error.

Předcházející | Nahoru | Další
Imagick::getImageRenderingIntent | Domů | Imagick::getImageScene


Imagick::getImageScene

(No version information available, might be only in CVS)

Imagick::getImageScene — Gets the image scene

Popis

int Imagick::getImageScene ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Gets the image scene.

Seznam parametrů

Návratové hodnoty

Returns the image scene, throwing ImagickException on error.

Předcházející | Nahoru | Další
Imagick::getImageResolution | Domů | Imagick::getImageSignature


Imagick::getImageSignature

(No version information available, might be only in CVS)

Imagick::getImageSignature — Generates an SHA-256 message digest

Popis

string Imagick::getImageSignature ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Generates an SHA-256 message digest for the image pixel stream.

Seznam parametrů

Návratové hodnoty

Returns a string containing the SHA-256 hash of the file, throwing an ImagickException on error.

Předcházející | Nahoru | Další
Imagick::getImageScene | Domů | Imagick::getImageTicksPerSecond


Imagick::getImageSize

(No version information available, might be only in CVS)

Imagick::getImageSize — Returns the image length in bytes

Popis

int Imagick::getImageSize ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the image length in bytes

Seznam parametrů

Návratové hodnoty

Returns an int containing the current image size.

Předcházející | Nahoru | Další
Imagick::getImageFilename | Domů | Imagick::getImageLength


Imagick::getImageTicksPerSecond

(No version information available, might be only in CVS)

Imagick::getImageTicksPerSecond — Gets the image ticks-per-second

Popis

int Imagick::getImageTicksPerSecond ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Gets the image ticks-per-second.

Seznam parametrů

Návratové hodnoty

Returns the image ticks-per-second, throwing ImagickException on error.

Předcházející | Nahoru | Další
Imagick::getImageSignature | Domů | Imagick::getImageTotalInkDensity


Imagick::getImageTotalInkDensity

(No version information available, might be only in CVS)

Imagick::getImageTotalInkDensity — Gets the image total ink density

Popis

float Imagick::getImageTotalInkDensity ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Gets the image total ink density.

Seznam parametrů

Návratové hodnoty

Returns the image total ink density of the image, throwing ImagickException on error.

Předcházející | Nahoru | Další
Imagick::getImageTicksPerSecond | Domů | Imagick::getImageType


Imagick::getImageType

(No version information available, might be only in CVS)

Imagick::getImageType — Gets the potential image type

Popis

int Imagick::getImageType ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Gets the potential image type.

Seznam parametrů

Návratové hodnoty

Retruns the potential image type, throwing ImagickException on error.

Předcházející | Nahoru | Další
Imagick::getImageTotalInkDensity | Domů | Imagick::getImageUnits


Imagick::getImageUnits

(No version information available, might be only in CVS)

Imagick::getImageUnits — Gets the image units of resolution

Popis

int Imagick::getImageUnits ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Gets the image units of resolution.

Seznam parametrů

Návratové hodnoty

Returns the image units of resolution, throwing ImagickException on failure.

Předcházející | Nahoru | Další
Imagick::getImageType | Domů | Imagick::getImageVirtualPixelMethod


Imagick::getImageVirtualPixelMethod

(No version information available, might be only in CVS)

Imagick::getImageVirtualPixelMethod — Returns the virtual pixel method

Popis

int Imagick::getImageVirtualPixelMethod ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the virtual pixel method for the specified image.

Seznam parametrů

Návratové hodnoty

Returns the virtual pixel method on success, ImagickException on failure.

Předcházející | Nahoru | Další
Imagick::getImageUnits | Domů | Imagick::getImageWhitePoint


Imagick::getImageWhitePoint

(No version information available, might be only in CVS)

Imagick::getImageWhitePoint — Returns the chromaticy white point

Popis

array Imagick::getImageWhitePoint ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the chromaticy white point as an associative array with the keys "x" and "y".

Seznam parametrů

Návratové hodnoty

Returns the chromaticy white point as an associative array with the keys "x" and "y", throws ImagickException on error.

Předcházející | Nahoru | Další
Imagick::getImageVirtualPixelMethod | Domů | Imagick::getImageWidth


Imagick::getImageWidth

(No version information available, might be only in CVS)

Imagick::getImageWidth — Returns the image width

Popis

int Imagick::getImageWidth ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the image width.

Seznam parametrů

Návratové hodnoty

Returns the image width, throwing ImagickException on error.

Předcházející | Nahoru | Další
Imagick::getImageWhitePoint | Domů | Imagick::getImage


Imagick::getInterlaceScheme

(No version information available, might be only in CVS)

Imagick::getInterlaceScheme — Gets the object interlace scheme

Popis

int Imagick::getInterlaceScheme ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Gets the object interlace scheme.

Seznam parametrů

Návratové hodnoty

Gets the wand interlace scheme, throwing ImagickException on error.

Předcházející | Nahoru | Další
Imagick::getImage | Domů | Imagick::getImageOrientation


Imagick::getIteratorIndex

(No version information available, might be only in CVS)

Imagick::getIteratorIndex — Gets the index of the current active image

Popis

int Imagick::getIteratorIndex ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the index of the current active image within the Imagick object.

Seznam parametrů

Návratové hodnoty

Returns an integer containing the index of the image in the stack, throwing ImagickException on error.

Předcházející | Nahoru | Další
Imagick::getImageIndex | Domů | Imagick::getImageInterlaceScheme


Imagick::getNumberImages

(No version information available, might be only in CVS)

Imagick::getNumberImages — Returns the number of images in the object

Popis

int Imagick::getNumberImages ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the number of images associated with Imagick object.

Seznam parametrů

Návratové hodnoty

Returns the number of images associated with Imagick object, throwing ImagickException on failure.

Předcházející | Nahoru | Další
Imagick::getImageOrientation | Domů | Imagick::getOption


Imagick::getOption

(No version information available, might be only in CVS)

Imagick::getOption — Returns a value associated with the specified key

Popis

string Imagick::getOption ( string $key )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns a value associated with a wand and the specified key.

Seznam parametrů

key

Návratové hodnoty

Returns a value associated with a wand and the specified key, throwing ImagickException on error.

Předcházející | Nahoru | Další
Imagick::getNumberImages | Domů | Imagick::getPackageName


Imagick::getPackageName

(No version information available, might be only in CVS)

Imagick::getPackageName — Returns the ImageMagick package name

Popis

string Imagick::getPackageName ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the ImageMagick package name.

Seznam parametrů

Návratové hodnoty

Returns the ImageMagick package name as a string, throwing ImagickException on error.

Předcházející | Nahoru | Další
Imagick::getOption | Domů | Imagick::getPage


Imagick::getPage

(No version information available, might be only in CVS)

Imagick::getPage — Returns the page geometry

Popis

array Imagick::getPage ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the page geometry associated with the Imagick object in an associative array with the keys "width", "height", "x", and "y".

Seznam parametrů

Návratové hodnoty

Returns the page geometry associated with the Imagick object in an associative array with the keys "width", "height", "x", and "y", throwing ImagickException on error.

Předcházející | Nahoru | Další
Imagick::getPackageName | Domů | Imagick::getPixelIterator


Imagick::getPixelIterator

(No version information available, might be only in CVS)

Imagick::getPixelIterator — Returns a MagickPixelIterator

Popis

ImagickPixelIterator Imagick::getPixelIterator ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns a MagickPixelIterator.

Seznam parametrů

Návratové hodnoty

Returns an ImagickPixelIterator on success, throwing ImagickException on failure.

Předcházející | Nahoru | Další
Imagick::getPage | Domů | Imagick::getPixelRegionIterator


Imagick::getPixelRegionIterator

(No version information available, might be only in CVS)

Imagick::getPixelRegionIterator — Get an ImagickPixelIterator for an image section

Popis

ImagickPixelIterator Imagick::getPixelRegionIterator ( int $x, int $y, int $columns, int $rows )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Get an ImagickPixelIterator for an image section.

Seznam parametrů

x

y

columns

rows

Návratové hodnoty

Returns an ImagickPixelIterator for an image section, throwing ImagickException on error.

Předcházející | Nahoru | Další
Imagick::getPixelIterator | Domů | Imagick::getQuantumDepth


Imagick::getQuantumDepth

(No version information available, might be only in CVS)

Imagick::getQuantumDepth — Gets the quantum depth

Popis

array Imagick::getQuantumDepth ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the Imagick quantum depth as a string.

Seznam parametrů

Návratové hodnoty

Returns the Imagick quantum depth as a string, throwing ImagickException on error.

Předcházející | Nahoru | Další
Imagick::getPixelRegionIterator | Domů | Imagick::getQuantumRange


Imagick::getQuantumRange

(No version information available, might be only in CVS)

Imagick::getQuantumRange — Returns the Imagick quantum range

Popis

array Imagick::getQuantumRange ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the Imagick quantum range as a string.

Seznam parametrů

Návratové hodnoty

Returns the Imagick quantum range as a string, throwing ImagickException on error.

Předcházející | Nahoru | Další
Imagick::getQuantumDepth | Domů | Imagick::getReleaseDate


Imagick::getReleaseDate

(No version information available, might be only in CVS)

Imagick::getReleaseDate — Returns the ImageMagick release date

Popis

string Imagick::getReleaseDate ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the ImageMagick release date as a string.

Seznam parametrů

Návratové hodnoty

Returns the ImageMagick release date as a string, throwing ImagickException on error.

Předcházející | Nahoru | Další
Imagick::getQuantumRange | Domů | Imagick::getResourceLimit


Imagick::getResource

(No version information available, might be only in CVS)

Imagick::getResource — Returns the specified resource's memory usage

Popis

int Imagick::getResource ( int $type )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the specified resource's memory usage in megabytes.

Seznam parametrů

type

Návratové hodnoty

Returns the specified resource's memory usage in megabytes, throwing ImagickException on error.

Předcházející | Nahoru | Další
Imagick::getResourceLimit | Domů | Imagick::getSamplingFactors


Imagick::getResourceLimit

(No version information available, might be only in CVS)

Imagick::getResourceLimit — Returns the specified resource limit

Popis

int Imagick::getResourceLimit ( int $type )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the specified resource limit in megabytes.

Seznam parametrů

type

Návratové hodnoty

Returns the specified resource limit in megabytes, throwing ImagickException on error.

Předcházející | Nahoru | Další
Imagick::getReleaseDate | Domů | Imagick::getResource


Imagick::getSamplingFactors

(No version information available, might be only in CVS)

Imagick::getSamplingFactors — Gets the horizontal and vertical sampling factor

Popis

array Imagick::getSamplingFactors ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Gets the horizontal and vertical sampling factor.

Seznam parametrů

Návratové hodnoty

Returns an associative array with the horizontal and vertical sampling factors of the image. Throws ImagickException on error.

Předcházející | Nahoru | Další
Imagick::getResource | Domů | Imagick::getSizeOffset


Imagick::getSize

(No version information available, might be only in CVS)

Imagick::getSize — Returns the size associated with the Imagick object

Popis

array Imagick::getSize ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the size associated with the Imagick object as an array with the keys "columns" and "rows".

Seznam parametrů

Návratové hodnoty

Returns the size associated with the Imagick object as an array with the keys "columns" and "rows".

Předcházející | Nahoru | Další
Imagick::getSizeOffset | Domů | Imagick::getVersion


Imagick::getSizeOffset

(No version information available, might be only in CVS)

Imagick::getSizeOffset — Returns the size offset

Popis

int Imagick::getSizeOffset ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the size offset associated with the Imagick object.

Seznam parametrů

Návratové hodnoty

Returns the size offset associated with the Imagick object, throwing ImagickException on error.

Předcházející | Nahoru | Další
Imagick::getSamplingFactors | Domů | Imagick::getSize


Imagick::getVersion

(No version information available, might be only in CVS)

Imagick::getVersion — Returns the ImageMagick API version

Popis

array Imagick::getVersion ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the ImageMagick API version as a string and as a number.

Seznam parametrů

Návratové hodnoty

Returns the ImageMagick API version as a string and as a number, throwing ImagickException on error.

Předcházející | Nahoru | Další
Imagick::getSize | Domů | Imagick::hasNextImage


Imagick::hasNextImage

(No version information available, might be only in CVS)

Imagick::hasNextImage — Checks if the object has more images

Popis

bool Imagick::hasNextImage ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns true if the object has more images when traversing the list in the forward direction

Seznam parametrů

Návratové hodnoty

Returns true if the object has more images when traversing the list in the forward direction, throwing ImagickException on error.

Předcházející | Nahoru | Další
Imagick::getVersion | Domů | Imagick::hasPreviousImage


Imagick::hasPreviousImage

(No version information available, might be only in CVS)

Imagick::hasPreviousImage — Checks if the object has a previous image

Popis

bool Imagick::hasPreviousImage ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns true if the object has more images when traversing the list in the reverse direction

Seznam parametrů

Návratové hodnoty

Returns true if the object has more images when traversing the list in the reverse direction, throwing ImagickException on failure.

Předcházející | Nahoru | Další
Imagick::hasNextImage | Domů | Imagick::identifyImage


Imagick::identifyImage

(No version information available, might be only in CVS)

Imagick::identifyImage — Identifies an image and fetches attributes

Popis

string Imagick::identifyImage ( [bool $appendRawOutput] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Identifies an image and returns the attributes. Attributes include the image width, height, size, and others.

Seznam parametrů

appendRawOutput

Návratové hodnoty

Identifies an image and returns the attributes. Attributes include the image width, height, size, and others. Throws ImagickException on error.

Předcházející | Nahoru | Další
Imagick::hasPreviousImage | Domů | Imagick::implodeImage


Imagick::implodeImage

(No version information available, might be only in CVS)

Imagick::implodeImage — Creates a new image as a copy

Popis

bool Imagick::implodeImage ( float $radius )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Creates a new image that is a copy of an existing one with the image pixels "imploded" by the specified percentage.

Seznam parametrů

radius

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::identifyImage | Domů | Imagick::labelImage


Imagick::labelImage

(No version information available, might be only in CVS)

Imagick::labelImage — Adds a label to an image

Popis

bool Imagick::labelImage ( string $label )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Adds a label to an image

Seznam parametrů

label

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::implodeImage | Domů | Imagick::levelImage


Imagick::levelImage

(No version information available, might be only in CVS)

Imagick::levelImage — Adjusts the levels of an image

Popis

bool Imagick::levelImage ( float $blackPoint, float $gamma, float $whitePoint [, int $channel] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Adjusts the levels of an image by scaling the colors falling between specified white and black points to the full available quantum range. The parameters provided represent the black, mid, and white points. The black point specifies the darkest color in the image. Colors darker than the black point are set to zero. Mid point specifies a gamma correction to apply to the image. White point specifies the lightest color in the image. Colors brighter than the white point are set to the maximum quantum value.

Seznam parametrů

blackPoint

gamma

whitePoint

channel

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::labelImage | Domů | Imagick::linearStretchImage


Imagick::linearStretchImage

(No version information available, might be only in CVS)

Imagick::linearStretchImage — Stretches with saturation the image intensity

Popis

bool Imagick::linearStretchImage ( float $blackPoint, float $whitePoint )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Stretches with saturation the image intensity.

Seznam parametrů

blackPoint

whitePoint

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::levelImage | Domů | Imagick::magnifyImage


Imagick::magnifyImage

(No version information available, might be only in CVS)

Imagick::magnifyImage — Scales an image proportionally 2x

Popis

bool Imagick::magnifyImage ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Is a convenience method that scales an image proportionally to twice its original size.

Seznam parametrů

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::linearStretchImage | Domů | Imagick::matteFloodfillImage


Imagick::matteFloodfillImage

(No version information available, might be only in CVS)

Imagick::matteFloodfillImage — Changes the transparency value of a color

Popis

bool Imagick::matteFloodfillImage ( float $alpha, float $fuzz, ImagickPixel $bordercolor, int $x, int $y )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Changes the transparency value of any pixel that matches target and is an immediate neighbor. If the method FillToBorderMethod is specified, the transparency value is changed for any neighbor pixel that does not match the bordercolor member of image.

Seznam parametrů

alpha

fuzz

bordercolor

x

y

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::magnifyImage | Domů | Imagick::medianFilterImage


Imagick::medianFilterImage

(No version information available, might be only in CVS)

Imagick::medianFilterImage — Applies a digital filter

Popis

bool Imagick::medianFilterImage ( float $radius )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Applies a digital filter that improves the quality of a noisy image. Each pixel is replaced by the median in a set of neighboring pixels as defined by radius.

Seznam parametrů

radius

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::matteFloodfillImage | Domů | Imagick::minifyImage


Imagick::minifyImage

(No version information available, might be only in CVS)

Imagick::minifyImage — Scales an image proportionally to half its size

Popis

bool Imagick::minifyImage ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Is a convenience method that scales an image proportionally to one-half its original size

Seznam parametrů

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::medianFilterImage | Domů | Imagick::modulateImage


Imagick::modulateImage

(No version information available, might be only in CVS)

Imagick::modulateImage — Control the brightness, saturation, and hue

Popis

bool Imagick::modulateImage ( float $brightness, float $saturation, float $hue )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Lets you control the brightness, saturation, and hue of an image. Hue is the percentage of absolute rotation from the current position. For example 50 results in a counter-clockwise rotation of 90 degrees, 150 results in a clockwise rotation of 90 degrees, with 0 and 200 both resulting in a rotation of 180 degrees.

Seznam parametrů

brightness

saturation

hue

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::minifyImage | Domů | Imagick::montageImage


Imagick::montageImage

(No version information available, might be only in CVS)

Imagick::montageImage — Creates a composite image

Popis

Imagick Imagick::montageImage ( ImagickDraw $drawing_wand, string $tile_geometry, string $thumbnail_geometry, int $mode, string $frame )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Creates a composite image by combining several separate images. he images are tiled on the composite image with the name of the image optionally appearing just below the individual tile.

Seznam parametrů

drawing_wand

tile_geometry

thumbnail_geometry

mode

frame

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::modulateImage | Domů | Imagick::morphImages


Imagick::morphImages

(No version information available, might be only in CVS)

Imagick::morphImages — Method morphs a set of images

Popis

Imagick Imagick::morphImages ( int $number_frames )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Method morphs a set of images. Both the image pixels and size are linearly interpolated to give the appearance of a meta-morphosis from one image to the next.

Seznam parametrů

number_frames

Návratové hodnoty

This method returns a new Imagick object on success and throws an ImagickException on error.

Předcházející | Nahoru | Další
Imagick::montageImage | Domů | Imagick::compareImages


Imagick::mosaicImages

(No version information available, might be only in CVS)

Imagick::mosaicImages — Forms a mosaic from images

Popis

Imagick Imagick::mosaicImages ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Inlays an image sequence to form a single coherent picture. It returns a wand with each image in the sequence composited at the location defined by the page offset of the image.

Seznam parametrů

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::compareImages | Domů | Imagick::motionBlurImage


Imagick::motionBlurImage

(No version information available, might be only in CVS)

Imagick::motionBlurImage — Simulates motion blur

Popis

bool Imagick::motionBlurImage ( float $radius, float $sigma, float $angle )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Simulates motion blur. We convolve the image with a Gaussian operator of the given radius and standard deviation (sigma). For reasonable results, radius should be larger than sigma. Use a radius of 0 and MotionBlurImage() selects a suitable radius for you. Angle gives the angle of the blurring motion.

Seznam parametrů

radius

sigma

angle

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::mosaicImages | Domů | Imagick::negateImage


Imagick::negateImage

(No version information available, might be only in CVS)

Imagick::negateImage — Negates the colors in the reference image

Popis

bool Imagick::negateImage ( bool $gray [, int $channel] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Negates the colors in the reference image. The Grayscale option means that only grayscale values within the image are negated.

Seznam parametrů

gray

channel

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::motionBlurImage | Domů | Imagick::distortImage


Imagick::newImage

(No version information available, might be only in CVS)

Imagick::newImage — Creates a new image

Popis

bool Imagick::newImage ( int $cols, int $rows, ImagickPixel $background [, string $format] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Creates a new image and associates ImagickPixel value as background color

Seznam parametrů

cols

Columns in the new image

rows

Rows in the new image

background

The background color used for this image

format

Image format. This parameter was added in Imagick version 2.0.1.

Návratové hodnoty

Returns TRUE on success.

Příklady

Příklad 892. Using Imagick::newImage():

Create a new image and display it.

<?php

$image = new Imagick();
$image->newImage(100, 100, new ImagickPixel('red'));
$image->setImageFormat('png');

header('Content-type: image/png');
echo $image;

?>

Předcházející | Nahoru | Další
Imagick::distortImage | Domů | Imagick::setImage


Imagick::newPseudoImage

(No version information available, might be only in CVS)

Imagick::newPseudoImage — Creates a new image

Popis

bool Imagick::newPseudoImage ( int $columns, int $rows, string $pseudoString )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Creates a new image using ImageMagick pseudo-formats.

Seznam parametrů

columns

columns in the new image

rows

rows in the new image

pseudoString

string containing pseudo image defition.

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::setImageOpacity | Domů | Imagick::nextImage


Imagick::nextImage

(No version information available, might be only in CVS)

Imagick::nextImage — Moves to the next image

Popis

bool Imagick::nextImage ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Associates the next image in the image list with an Imagick object.

Seznam parametrů

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::newPseudoImage | Domů | Imagick::normalizeImage


Imagick::normalizeImage

(No version information available, might be only in CVS)

Imagick::normalizeImage — Enhances the contrast of a color image

Popis

bool Imagick::normalizeImage ( [int $channel] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Enhances the contrast of a color image by adjusting the pixels color to span the entire range of colors available.

Seznam parametrů

channel

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::nextImage | Domů | Imagick::oilPaintImage


Imagick::oilPaintImage

(No version information available, might be only in CVS)

Imagick::oilPaintImage — Simulates an oil painting

Popis

bool Imagick::oilPaintImage ( float $radius )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Applies a special effect filter that simulates an oil painting. Each pixel is replaced by the most frequent color occurring in a circular region defined by radius.

Seznam parametrů

radius

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::normalizeImage | Domů | Imagick::optimizeImageLayers


Imagick::optimizeImageLayers

(No version information available, might be only in CVS)

Imagick::optimizeImageLayers — Removes repeated portions of images to optimize

Popis

bool Imagick::optimizeImageLayers ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Compares each image the GIF disposed forms of the previous image in the sequence. From this it attempts to select the smallest cropped image to replace each frame, while preserving the results of the animation.

Seznam parametrů

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::oilPaintImage | Domů | Imagick::paintOpaqueImage


Imagick::paintOpaqueImage

(No version information available, might be only in CVS)

Imagick::paintOpaqueImage — Change any pixel that matches color

Popis

bool Imagick::paintOpaqueImage ( ImagickPixel $target, ImagickPixel $fill, float $fuzz [, int $channel] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Changes any pixel that matches color with the color defined by fill.

Seznam parametrů

target

fill

fuzz

channel

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::optimizeImageLayers | Domů | Imagick::paintTransparentImage


Imagick::paintTransparentImage

(No version information available, might be only in CVS)

Imagick::paintTransparentImage — Changes any pixel that matches color with the color defined by fill

Popis

bool Imagick::paintTransparentImage ( Imagick $targetObj, float $alpha, float $fuzz )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Seznam parametrů

targetObj

alpha

fuzz

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::paintOpaqueImage | Domů | Imagick::pingImageBlob


Imagick::pingImage

(No version information available, might be only in CVS)

Imagick::pingImage — Fetch basic attributes about the image

Popis

bool Imagick::pingImage ( string $filename )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

This method can be used to query image width, height, size, and format without reading the whole image in to memory.

Seznam parametrů

filename

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::pingImageFile | Domů | Imagick::posterizeImage


Imagick::pingImageBlob

(No version information available, might be only in CVS)

Imagick::pingImageBlob — Quickly fetch attributes

Popis

bool Imagick::pingImageBlob ( string $image )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

This method can be used to query image width, height, size, and format without reading the whole image to memory.

Seznam parametrů

image

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::paintTransparentImage | Domů | Imagick::pingImageFile


Imagick::pingImageFile

(No version information available, might be only in CVS)

Imagick::pingImageFile — Get basic image attributes in a lightweight manner

Popis

bool Imagick::pingImageFile ( resource $filehandle [, string $fileName] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

This method can be used to query image width, height, size, and format without reading the whole image to memory.

Seznam parametrů

filehandle

fileName

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::pingImageBlob | Domů | Imagick::pingImage


Imagick::polaroidImage

(No version information available, might be only in CVS)

Imagick::polaroidImage — Simulates a Polaroid picture

Popis

bool Imagick::polaroidImage ( ImagickDraw $properties, float $angle )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Simulates a Polaroid picture.

Seznam parametrů

properties

The polaroid properties

angle

The polaroid angle

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::roundCorners | Domů | Imagick::queryFonts


Imagick::posterizeImage

(No version information available, might be only in CVS)

Imagick::posterizeImage — Reduces the image to a limited number of color level

Popis

bool Imagick::posterizeImage ( int $levels, bool $dither )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Reduces the image to a limited number of color level.

Seznam parametrů

levels

dither

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::pingImage | Domů | Imagick::previousImage


Imagick::previousImage

(No version information available, might be only in CVS)

Imagick::previousImage — Move to the previous image in the object

Popis

bool Imagick::previousImage ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Assocates the previous image in an image list with the Imagick object.

Seznam parametrů

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::posterizeImage | Domů | Imagick::profileImage


Imagick::profileImage

(No version information available, might be only in CVS)

Imagick::profileImage — Adds or removes a profile from an image

Popis

bool Imagick::profileImage ( string $name, string $profile )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Adds or removes a ICC, IPTC, or generic profile from an image. If the profile is NULL, it is removed from the image otherwise added. Use a name of '*' and a profile of NULL to remove all profiles from the image.

Seznam parametrů

name

profile

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::previousImage | Domů | Imagick::queryFormats


Imagick::queryFontMetrics

(No version information available, might be only in CVS)

Imagick::queryFontMetrics — Returns an array representing the font metrics

Popis

array Imagick::queryFontMetrics ( ImagickDraw $properties, string $text [, bool $multiline] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns a 13 element array representing the font metrics.

Seznam parametrů

properties

ImagickDraw containing font properties

text

The text

multiline

Multiline parameter. If left empty it is autodetected

Návratové hodnoty

Returns an array containing the formats supported by Imagick, throws ImagickException on error.

Předcházející | Nahoru | Další
Imagick::queryFonts | Domů | ImagickDraw::affine


Imagick::queryFonts

(No version information available, might be only in CVS)

Imagick::queryFonts — Returns the configured fonts

Popis

array Imagick::queryFonts ( [string $pattern] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns formats supported by Imagick.

Seznam parametrů

pattern

The query pattern

Návratové hodnoty

Returns an array containing the configured fonts, throws ImagickException on error.

Předcházející | Nahoru | Další
Imagick::polaroidImage | Domů | Imagick::queryFontMetrics


Imagick::queryFormats

(No version information available, might be only in CVS)

Imagick::queryFormats — Returns formats supported by Imagick

Popis

array Imagick::queryFormats ( [string $pattern] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns formats supported by Imagick.

Seznam parametrů

pattern

Návratové hodnoty

Returns an array containing the formats supported by Imagick, throws ImagickException on error.

Předcházející | Nahoru | Další
Imagick::profileImage | Domů | Imagick::radialBlurImage


Imagick::radialBlurImage

(No version information available, might be only in CVS)

Imagick::radialBlurImage — Radial blurs an image

Popis

bool Imagick::radialBlurImage ( float $angle [, int $channel] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Radial blurs an image.

Seznam parametrů

angle

channel

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::queryFormats | Domů | Imagick::raiseImage


Imagick::raiseImage

(No version information available, might be only in CVS)

Imagick::raiseImage — Creates a simulated 3d button-like effect

Popis

bool Imagick::raiseImage ( int $width, int $height, int $x, int $y, bool $raise )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Creates a simulated three-dimensional button-like effect by lightening and darkening the edges of the image. Members width and height of raise_info define the width of the vertical and horizontal edge of the effect.

Seznam parametrů

width

height

x

y

raise

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::radialBlurImage | Domů | Imagick::randomThresholdImage


Imagick::randomThresholdImage

(No version information available, might be only in CVS)

Imagick::randomThresholdImage — Creates a high-contrast, two-color image

Popis

bool Imagick::randomThresholdImage ( float $low, float $high [, int $channel] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Changes the value of individual pixels based on the intensity of each pixel compared to threshold. The result is a high-contrast, two color image.

Seznam parametrů

low

high

channel

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::raiseImage | Domů | Imagick::readImageBlob


Imagick::readImage

(No version information available, might be only in CVS)

Imagick::readImage — Reads image from filename

Popis

bool Imagick::readImage ( string $filename )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Reads image from filename

Seznam parametrů

filename

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::readImageFile | Domů | Imagick::reduceNoiseImage


Imagick::readImageBlob

(No version information available, might be only in CVS)

Imagick::readImageBlob — Reads image from a binary string

Popis

bool Imagick::readImageBlob ( string $image [, string $filename] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Reads image from a binary string

Seznam parametrů

image

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::randomThresholdImage | Domů | Imagick::readImageFile


Imagick::readImageFile

(No version information available, might be only in CVS)

Imagick::readImageFile — Reads image from open filehandle

Popis

bool Imagick::readImageFile ( resource $filehandle [, string $fileName] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Reads image from open filehandle

Seznam parametrů

filehandle

fileName

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::readImageBlob | Domů | Imagick::readImage


Imagick::reduceNoiseImage

(No version information available, might be only in CVS)

Imagick::reduceNoiseImage — Smooths the contours of an image

Popis

bool Imagick::reduceNoiseImage ( float $radius )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Smooths the contours of an image while still preserving edge information. The algorithm works by replacing each pixel with its neighbor closest in value. A neighbor is defined by radius. Use a radius of 0 and Imagick::reduceNoiseImage() selects a suitable radius for you.

Seznam parametrů

radius

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::readImage | Domů | Imagick::removeImageProfile


Imagick::removeImage

(No version information available, might be only in CVS)

Imagick::removeImage — Removes an image from the image list

Popis

bool Imagick::removeImage ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Removes an image from the image list.

Seznam parametrů

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::removeImageProfile | Domů | Imagick::render


Imagick::removeImageProfile

(No version information available, might be only in CVS)

Imagick::removeImageProfile — Removes the named image profile and returns it

Popis

string Imagick::removeImageProfile ( string $name )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Removes the named image profile and returns it.

Seznam parametrů

name

Návratové hodnoty

Returns a string containing the profile of the image, throwing ImagickException on error.

Předcházející | Nahoru | Další
Imagick::reduceNoiseImage | Domů | Imagick::removeImage


Imagick::render

(No version information available, might be only in CVS)

Imagick::render — Renders all preceding drawing commands

Popis

bool Imagick::render ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Renders all preceding drawing commands.

Seznam parametrů

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::removeImage | Domů | Imagick::resampleImage


Imagick::resampleImage

(No version information available, might be only in CVS)

Imagick::resampleImage — Resample image to desired resolution

Popis

bool Imagick::resampleImage ( float $x_resolution, float $y_resolution, int $filter, float $blur )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Resample image to desired resolution.

Seznam parametrů

x_resolution

y_resolution

filter

blur

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::render | Domů | Imagick::resizeImage


Imagick::resizeImage

(No version information available, might be only in CVS)

Imagick::resizeImage — Scales an image

Popis

bool Imagick::resizeImage ( float $columns, float $rows, int $filter, float $blur )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Scales an image to the desired dimensions with a filter.

Seznam parametrů

columns

rows

filter

blur

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::resampleImage | Domů | Imagick::rollImage


Imagick::rollImage

(No version information available, might be only in CVS)

Imagick::rollImage — Offsets an image

Popis

bool Imagick::rollImage ( int $x, int $y )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Offsets an image as defined by x and y.

Seznam parametrů

x

y

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::resizeImage | Domů | Imagick::rotateImage


Imagick::rotateImage

(No version information available, might be only in CVS)

Imagick::rotateImage — Rotates an image

Popis

bool Imagick::rotateImage ( ImagickPixel $background, float $degrees )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Rotates an image the specified number of degrees. Empty triangles left over from rotating the image are filled with the background color.

Seznam parametrů

background

degrees

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::rollImage | Domů | Imagick::sampleImage


Imagick::roundCorners

(No version information available, might be only in CVS)

Imagick::roundCorners — Rounds image corners

Popis

bool Imagick::roundCorners ( float $x_rounding, float $y_rounding [, float $stroke_width [, float $displace [, float $size_correction]]] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Rounds image corners. Three last parameters are optional and rarely needed.

Seznam parametrů

x_rounding

x rounding

y_rounding

y rounding

stroke_width

stroke width

displace

image displace

size_correction

sise correction

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::cropThumbnailImage | Domů | Imagick::polaroidImage


Imagick::sampleImage

(No version information available, might be only in CVS)

Imagick::sampleImage — Scales an image with pixel sampling

Popis

bool Imagick::sampleImage ( int $columns, int $rows )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Scales an image to the desired dimensions with pixel sampling. Unlike other scaling methods, this method does not introduce any additional color into the scaled image.

Seznam parametrů

columns

rows

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::rotateImage | Domů | Imagick::scaleImage


Imagick::scaleImage

(No version information available, might be only in CVS)

Imagick::scaleImage — Scales the size of an image

Popis

bool Imagick::scaleImage ( int $cols, int $rows )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Scales the size of an image to the given dimensions. The other parameter will be calculated if 0 is passed as either param.

Seznam parametrů

cols

rows

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::sampleImage | Domů | Imagick::separateImageChannel


Imagick::separateImageChannel

(No version information available, might be only in CVS)

Imagick::separateImageChannel — Separates a channel from the image

Popis

bool Imagick::separateImageChannel ( int $channel )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Separates a channel from the image and returns a grayscale image. A channel is a particular color component of each pixel in the image.

Seznam parametrů

channel

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::scaleImage | Domů | Imagick::sepiaToneImage


Imagick::sepiaToneImage

(No version information available, might be only in CVS)

Imagick::sepiaToneImage — Sepia tones an image

Popis

bool Imagick::sepiaToneImage ( float $threshold )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Applies a special effect to the image, similar to the effect achieved in a photo darkroom by sepia toning. Threshold ranges from 0 to QuantumRange and is a measure of the extent of the sepia toning. A threshold of 80 is a good starting point for a reasonable tone.

Seznam parametrů

threshold

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::separateImageChannel | Domů | Imagick::setBackgroundColor


Imagick::setBackgroundColor

(No version information available, might be only in CVS)

Imagick::setBackgroundColor — Sets the object's default background color

Popis

bool Imagick::setBackgroundColor ( ImagickPixel $background )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the object's default background color.

Seznam parametrů

background

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::sepiaToneImage | Domů | Imagick::setCompressionQuality


Imagick::setCompression

(No version information available, might be only in CVS)

Imagick::setCompression — Sets the object's default compression type

Popis

bool Imagick::setCompression ( int $compression )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the object's default compression type

Seznam parametrů

compression

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::setCompressionQuality | Domů | Imagick::setFilename


Imagick::setCompressionQuality

(No version information available, might be only in CVS)

Imagick::setCompressionQuality — Sets the object's default compression quality

Popis

bool Imagick::setCompressionQuality ( int $quality )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the object's default compression quality.

Seznam parametrů

quality

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::setBackgroundColor | Domů | Imagick::setCompression


Imagick::setFilename

(No version information available, might be only in CVS)

Imagick::setFilename — Sets the filename before you read or write the image

Popis

bool Imagick::setFilename ( string $filename )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the filename before you read or write an image file.

Seznam parametrů

filename

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::setCompression | Domů | Imagick::setFirstIterator


Imagick::setFirstIterator

(No version information available, might be only in CVS)

Imagick::setFirstIterator — Sets the Imagick iterator to the first image

Popis

bool Imagick::setFirstIterator ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the Imagick iterator to the first image.

Seznam parametrů

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::setFilename | Domů | Imagick::setLastIterator


Imagick::setFormat

(No version information available, might be only in CVS)

Imagick::setFormat — Sets the format of the Imagick object

Popis

bool Imagick::setFormat ( string $format )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the format of the Imagick object.

Seznam parametrů

format

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::setLastIterator | Domů | Imagick::setImageBackgroundColor


Imagick::setImage

(No version information available, might be only in CVS)

Imagick::setImage — Replaces image in the object

Popis

bool Imagick::setImage ( Imagick $replace )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Replaces the current image sequence with the image from replace object.

Seznam parametrů

replace

The replace Imagick object

Návratové hodnoty

Returns TRUE on success.

Příklady

Příklad 893. A Imagick::setImage() example

An example of using Imagick::setImage()

<?php
/* Create the objects */
$image = new Imagick('source.jpg');
$replace = new Imagick('replace.jpg');

/* source.jpg is replaced with replace.jpg */
$image->setImage($replace);

/* output the image */
header('Content-type: image/jpeg');
echo $image;

?>

Předcházející | Nahoru | Další
Imagick::newImage | Domů | Imagick::setImageOpacity


Imagick::setImageBackgroundColor

(No version information available, might be only in CVS)

Imagick::setImageBackgroundColor — Sets the image background color

Popis

bool Imagick::setImageBackgroundColor ( ImagickPixel $background )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the image background color.

Seznam parametrů

background

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::setFormat | Domů | Imagick::setImageBias


Imagick::setImageBias

(No version information available, might be only in CVS)

Imagick::setImageBias — Sets the image bias for any method that convolves an image

Popis

bool Imagick::setImageBias ( float $bias )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the image bias for any method that convolves an image (e.g. Imagick::ConvolveImage()).

Seznam parametrů

bias

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::setImageBackgroundColor | Domů | Imagick::setImageBluePrimary


Imagick::setImageBluePrimary

(No version information available, might be only in CVS)

Imagick::setImageBluePrimary — Sets the image chromaticity blue primary point

Popis

bool Imagick::setImageBluePrimary ( float $x, float $y )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the image chromaticity blue primary point.

Seznam parametrů

x

y

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::setImageBias | Domů | Imagick::setImageBorderColor


Imagick::setImageBorderColor

(No version information available, might be only in CVS)

Imagick::setImageBorderColor — Sets the image border color

Popis

bool Imagick::setImageBorderColor ( ImagickPixel $border )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the image border color.

Seznam parametrů

border

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::setImageBluePrimary | Domů | Imagick::setImageChannelDepth


Imagick::setImageChannelDepth

(No version information available, might be only in CVS)

Imagick::setImageChannelDepth — Sets the depth of a particular image channel

Popis

bool Imagick::setImageChannelDepth ( int $channel, int $depth )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the depth of a particular image channel.

Seznam parametrů

channel

depth

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::setImageBorderColor | Domů | Imagick::setImageColormapColor


Imagick::setImageColormapColor

(No version information available, might be only in CVS)

Imagick::setImageColormapColor — Sets the color of the specified colormap index

Popis

bool Imagick::setImageColormapColor ( int $index, ImagickPixel $color )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the color of the specified colormap index.

Seznam parametrů

index

color

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::setImageChannelDepth | Domů | Imagick::setImageColorspace


Imagick::setImageColorspace

(No version information available, might be only in CVS)

Imagick::setImageColorspace — Sets the image colorspace

Popis

bool Imagick::setImageColorspace ( int $colorspace )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the image colorspace.

Seznam parametrů

colorspace

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::setImageColormapColor | Domů | Imagick::setImageCompose


Imagick::setImageCompose

(No version information available, might be only in CVS)

Imagick::setImageCompose — Sets the image composite operator

Popis

bool Imagick::setImageCompose ( int $compose )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the image composite operator, useful for specifying how to composite the image thumbnail when using the Imagick::montageImage() method.

Seznam parametrů

compose

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::setImageColorspace | Domů | Imagick::setImageCompression


Imagick::setImageCompression

(No version information available, might be only in CVS)

Imagick::setImageCompression — Sets the image compression

Popis

bool Imagick::setImageCompression ( int $compression )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the image compression.

Seznam parametrů

compression

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::setImageCompose | Domů | Imagick::setImageDelay


Imagick::setImageDelay

(No version information available, might be only in CVS)

Imagick::setImageDelay — Sets the image delay

Popis

bool Imagick::setImageDelay ( int $delay )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the image delay.

Seznam parametrů

delay

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::setImageCompression | Domů | Imagick::setImageDepth


Imagick::setImageDepth

(No version information available, might be only in CVS)

Imagick::setImageDepth — Sets the image depth

Popis

bool Imagick::setImageDepth ( int $depth )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the image depth.

Seznam parametrů

depth

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::setImageDelay | Domů | Imagick::setImageDispose


Imagick::setImageDispose

(No version information available, might be only in CVS)

Imagick::setImageDispose — Sets the image disposal method

Popis

bool Imagick::setImageDispose ( int $dispose )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the image disposal method.

Seznam parametrů

dispose

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::setImageDepth | Domů | Imagick::setImageExtent


Imagick::setImageExtent

(No version information available, might be only in CVS)

Imagick::setImageExtent — Sets the image size

Popis

bool Imagick::setImageExtent ( int $columns, int $rows )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the image size (i.e. columns & rows).

Seznam parametrů

columns

rows

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::setImageDispose | Domů | Imagick::setImageFilename


Imagick::setImageFilename

(No version information available, might be only in CVS)

Imagick::setImageFilename — Sets the filename of a particular image

Popis

bool Imagick::setImageFilename ( string $filename )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the filename of a particular image in a sequence.

Seznam parametrů

filename

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::setImageExtent | Domů | Imagick::setImageFormat


Imagick::setImageFormat

(No version information available, might be only in CVS)

Imagick::setImageFormat — Sets the format of a particular image

Popis

bool Imagick::setImageFormat ( string $format )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the format of a particular image in a sequence.

Seznam parametrů

format

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::setImageFilename | Domů | Imagick::setImageGamma


Imagick::setImageGamma

(No version information available, might be only in CVS)

Imagick::setImageGamma — Sets the image gamma

Popis

bool Imagick::setImageGamma ( float $gamma )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the image gamma.

Seznam parametrů

gamma

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::setImageFormat | Domů | Imagick::setImageGreenPrimary


Imagick::setImageGreenPrimary

(No version information available, might be only in CVS)

Imagick::setImageGreenPrimary — Sets the image chromaticity green primary point

Popis

bool Imagick::setImageGreenPrimary ( float $x, float $y )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the image chromaticity green primary point.

Seznam parametrů

x

y

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::setImageGamma | Domů | Imagick::setImageIndex


Imagick::setImageIndex

(No version information available, might be only in CVS)

Imagick::setImageIndex — Set the iterator position

Popis

bool Imagick::setImageIndex ( int $index )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Set the iterator to the position in the image list specified with the index parameter. This method has been deprecated. See Imagick::setIteratorIndex

Seznam parametrů

index

The position to set the iterator to

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::setImageGreenPrimary | Domů | Imagick::setIteratorIndex


Imagick::setImageInterlaceScheme

(No version information available, might be only in CVS)

Imagick::setImageInterlaceScheme — Sets the image compression

Popis

bool Imagick::setImageInterlaceScheme ( int $interlace_scheme )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the image compression.

Seznam parametrů

interlace_scheme

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::setIteratorIndex | Domů | Imagick::setImageInterpolateMethod


Imagick::setImageInterpolateMethod

(No version information available, might be only in CVS)

Imagick::setImageInterpolateMethod — Sets the image interpolate pixel method

Popis

bool Imagick::setImageInterpolateMethod ( int $method )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the image interpolate pixel method.

Seznam parametrů

method

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::setImageInterlaceScheme | Domů | Imagick::setImageIterations


Imagick::setImageIterations

(No version information available, might be only in CVS)

Imagick::setImageIterations — Sets the image iterations

Popis

bool Imagick::setImageIterations ( int $iterations )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the image iterations.

Seznam parametrů

iterations

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::setImageInterpolateMethod | Domů | Imagick::setImageMatteColor


Imagick::setImageMatte

(No version information available, might be only in CVS)

Imagick::setImageMatte — Sets the image matte channel

Popis

bool Imagick::setImageMatte ( bool $matte )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the image matte channel.

Seznam parametrů

matte

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::setImageMatteColor | Domů | Imagick::setImagePage


Imagick::setImageMatteColor

(No version information available, might be only in CVS)

Imagick::setImageMatteColor — Sets the image matte color

Popis

bool Imagick::setImageMatteColor ( ImagickPixel $matte )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the image matte color.

Seznam parametrů

matte

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::setImageIterations | Domů | Imagick::setImageMatte


Imagick::setImageOpacity

(No version information available, might be only in CVS)

Imagick::setImageOpacity — Sets the image opacity level

Popis

bool Imagick::setImageOpacity ( float $opacity )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the image to the specified opacity level. This method is present if Imagick is compiled against ImageMagick 6.3.1 or later.

Seznam parametrů

opacity

The level of transparency: 1.0 is fully opaque and 0.0 is fully transparent.

Návratové hodnoty

Returns TRUE on success.

Příklady

Příklad 894. A Imagick::setImageOpacity() example

An example of using Imagick::setImageOpacity()

<?php
/* Create the object */
$image = new Imagick('source.png');

/* Set the opacity */
$image->setImageOpacity(0.7);

/* output the image */
header('Content-type: image/png');
echo $image;

?>

Předcházející | Nahoru | Další
Imagick::setImage | Domů | Imagick::newPseudoImage


Imagick::setImageOrientation

(No version information available, might be only in CVS)

Imagick::setImageOrientation — Sets the image orientation.

Popis

bool Imagick::setImageOrientation ( int $orientation )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the image orientation.

Seznam parametrů

orientation

One of the orientation constants

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::setInterlaceScheme | Domů | Imagick::setOption


Imagick::setImagePage

(No version information available, might be only in CVS)

Imagick::setImagePage — Sets the page geometry of the image

Popis

bool Imagick::setImagePage ( int $width, int $height, int $x, int $y )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the page geometry of the image.

Seznam parametrů

width

height

x

y

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::setImageMatte | Domů | Imagick::setImageProfile


Imagick::setImageProfile

(No version information available, might be only in CVS)

Imagick::setImageProfile — Adds a named profile to the Imagick object

Popis

bool Imagick::setImageProfile ( string $name, string $profile )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Adds a named profile to the Imagick object. If a profile with the same name already exists, it is replaced. This method differs from the Imagick::ProfileImage() method in that it does not apply any CMS color profiles.

Seznam parametrů

name

profile

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::setImagePage | Domů | Imagick::setImageProperty


Imagick::setImageProperty

(No version information available, might be only in CVS)

Imagick::setImageProperty — Sets an image property

Popis

bool Imagick::setImageProperty ( string $name, string $value )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets a named property to the image.

Seznam parametrů

name

value

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::setImageProfile | Domů | Imagick::setImageRedPrimary


Imagick::setImageRedPrimary

(No version information available, might be only in CVS)

Imagick::setImageRedPrimary — Sets the image chromaticity red primary point

Popis

bool Imagick::setImageRedPrimary ( float $x, float $y )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the image chromaticity red primary point.

Seznam parametrů

x

y

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::setImageProperty | Domů | Imagick::setImageRenderingIntent


Imagick::setImageRenderingIntent

(No version information available, might be only in CVS)

Imagick::setImageRenderingIntent — Sets the image rendering intent

Popis

bool Imagick::setImageRenderingIntent ( int $rendering_intent )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the image rendering intent.

Seznam parametrů

rendering_intent

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::setImageRedPrimary | Domů | Imagick::setImageResolution


Imagick::setImageResolution

(No version information available, might be only in CVS)

Imagick::setImageResolution — Sets the image resolution

Popis

bool Imagick::setImageResolution ( float $x_resolution, float $y_resolution )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the image resolution.

Seznam parametrů

x_resolution

y_resolution

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::setImageRenderingIntent | Domů | Imagick::setImageScene


Imagick::setImageScene

(No version information available, might be only in CVS)

Imagick::setImageScene — Sets the image scene

Popis

bool Imagick::setImageScene ( int $scene )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the image scene.

Seznam parametrů

scene

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::setImageResolution | Domů | Imagick::setImageTicksPerSecond


Imagick::setImageTicksPerSecond

(No version information available, might be only in CVS)

Imagick::setImageTicksPerSecond — Sets the image ticks-per-second

Popis

bool Imagick::setImageTicksPerSecond ( int $ticks_per-second )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the image ticks-per-second.

Seznam parametrů

ticks_per-second

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::setImageScene | Domů | Imagick::setImageType


Imagick::setImageType

(No version information available, might be only in CVS)

Imagick::setImageType — Sets the image type

Popis

bool Imagick::setImageType ( int $image_type )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the image type.

Seznam parametrů

image_type

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::setImageTicksPerSecond | Domů | Imagick::setImageUnits


Imagick::setImageUnits

(No version information available, might be only in CVS)

Imagick::setImageUnits — Sets the image units of resolution

Popis

bool Imagick::setImageUnits ( int $units )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the image units of resolution.

Seznam parametrů

units

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::setImageType | Domů | Imagick::setImageVirtualPixelMethod


Imagick::setImageVirtualPixelMethod

(No version information available, might be only in CVS)

Imagick::setImageVirtualPixelMethod — Sets the image virtual pixel method

Popis

bool Imagick::setImageVirtualPixelMethod ( int $method )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the image virtual pixel method.

Seznam parametrů

method

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::setImageUnits | Domů | Imagick::setImageWhitePoint


Imagick::setImageWhitePoint

(No version information available, might be only in CVS)

Imagick::setImageWhitePoint — Sets the image chromaticity white point

Popis

bool Imagick::setImageWhitePoint ( float $x, float $y )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the image chromaticity white point.

Seznam parametrů

x

y

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::setImageVirtualPixelMethod | Domů | Imagick::setInterlaceScheme


Imagick::setInterlaceScheme

(No version information available, might be only in CVS)

Imagick::setInterlaceScheme — Sets the image compression

Popis

bool Imagick::setInterlaceScheme ( int $interlace_scheme )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the image compression.

Seznam parametrů

interlace_scheme

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::setImageWhitePoint | Domů | Imagick::setImageOrientation


Imagick::setIteratorIndex

(No version information available, might be only in CVS)

Imagick::setIteratorIndex — Set the iterator position

Popis

bool Imagick::setIteratorIndex ( int $index )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Set the iterator to the position in the image list specified with the index parameter

Seznam parametrů

index

The position to set the iterator to

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::setImageIndex | Domů | Imagick::setImageInterlaceScheme


Imagick::setLastIterator

(No version information available, might be only in CVS)

Imagick::setLastIterator — Sets the Imagick iterator to the last image

Popis

bool Imagick::setLastIterator ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the Imagick iterator to the last image.

Seznam parametrů

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::setFirstIterator | Domů | Imagick::setFormat


Imagick::setOption

(No version information available, might be only in CVS)

Imagick::setOption — Set an option

Popis

bool Imagick::setOption ( string $key, string $value )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Associates one or options with the wand.

Seznam parametrů

key

value

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::setImageOrientation | Domů | Imagick::setPage


Imagick::setPage

(No version information available, might be only in CVS)

Imagick::setPage — Sets the page geometry of the Imagick object

Popis

bool Imagick::setPage ( int $width, int $height, int $x, int $y )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the page geometry of the Imagick object.

Seznam parametrů

width

height

x

y

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::setOption | Domů | Imagick::setResolution


Imagick::setResolution

(No version information available, might be only in CVS)

Imagick::setResolution — Sets the image resolution

Popis

bool Imagick::setResolution ( float $x_resolution, float $y_resolution )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the image resolution.

Seznam parametrů

x_resolution

y_resolution

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::setPage | Domů | Imagick::setResourceLimit


Imagick::setResourceLimit

(No version information available, might be only in CVS)

Imagick::setResourceLimit — Sets the limit for a particular resource in megabytes

Popis

bool Imagick::setResourceLimit ( int $type, int $limit )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the limit for a particular resource in megabytes.

Seznam parametrů

type

limit

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::setResolution | Domů | Imagick::setSamplingFactors


Imagick::setSamplingFactors

(No version information available, might be only in CVS)

Imagick::setSamplingFactors — Sets the image sampling factors

Popis

bool Imagick::setSamplingFactors ( array $factors )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the image sampling factors.

Seznam parametrů

factors

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::setResourceLimit | Domů | Imagick::setSizeOffset


Imagick::setSize

(No version information available, might be only in CVS)

Imagick::setSize — Sets the size of the Imagick object

Popis

bool Imagick::setSize ( int $columns, int $rows )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the size of the Imagick object. Set it before you read a raw image format such as RGB, GRAY, or CMYK.

Seznam parametrů

columns

rows

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::setSizeOffset | Domů | Imagick::setType


Imagick::setSizeOffset

(No version information available, might be only in CVS)

Imagick::setSizeOffset — Sets the size and offset of the Imagick object

Popis

bool Imagick::setSizeOffset ( int $columns, int $rows, int $offset )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the size and offset of the Imagick object. Set it before you read a raw image format such as RGB, GRAY, or CMYK.

Seznam parametrů

columns

rows

offset

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::setSamplingFactors | Domů | Imagick::setSize


Imagick::setType

(No version information available, might be only in CVS)

Imagick::setType — Sets the image type attribute

Popis

bool Imagick::setType ( int $image_type )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the image type attribute.

Seznam parametrů

image_type

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::setSize | Domů | Imagick::shadeImage


Imagick::shadeImage

(No version information available, might be only in CVS)

Imagick::shadeImage — Creates a 3D effect

Popis

bool Imagick::shadeImage ( bool $gray, float $azimuth, float $elevation )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Shines a distant light on an image to create a three-dimensional effect. You control the positioning of the light with azimuth and elevation; azimuth is measured in degrees off the x axis and elevation is measured in pixels above the Z axis.

Seznam parametrů

gray

azimuth

elevation

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::setType | Domů | Imagick::shadowImage


Imagick::shadowImage

(No version information available, might be only in CVS)

Imagick::shadowImage — Simulates an image shadow

Popis

bool Imagick::shadowImage ( float $opacity, float $sigma, int $x, int $y )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Simulates an image shadow.

Seznam parametrů

opacity

sigma

x

y

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::shadeImage | Domů | Imagick::sharpenImage


Imagick::sharpenImage

(No version information available, might be only in CVS)

Imagick::sharpenImage — Sharpens an image

Popis

bool Imagick::sharpenImage ( float $radius, float $sigma [, int $channel] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sharpens an image. We convolve the image with a Gaussian operator of the given radius and standard deviation (sigma). For reasonable results, the radius should be larger than sigma. Use a radius of 0 and selects a suitable radius for you.

Seznam parametrů

radius

sigma

channel

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::shadowImage | Domů | Imagick::shaveImage


Imagick::shaveImage

(No version information available, might be only in CVS)

Imagick::shaveImage — Shaves pixels from the image edges

Popis

bool Imagick::shaveImage ( int $columns, int $rows )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Shaves pixels from the image edges. It allocates the memory necessary for the new Image structure and returns a pointer to the new image.

Seznam parametrů

columns

rows

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::sharpenImage | Domů | Imagick::shearImage


Imagick::shearImage

(No version information available, might be only in CVS)

Imagick::shearImage — Creating a parallelogram

Popis

bool Imagick::shearImage ( ImagickPixel $background, float $x_shear, float $y_shear )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Slides one edge of an image along the X or Y axis, creating a parallelogram. An X direction shear slides an edge along the X axis, while a Y direction shear slides an edge along the Y axis. The amount of the shear is controlled by a shear angle. For X direction shears, x_shear is measured relative to the Y axis, and similarly, for Y direction shears y_shear is measured relative to the X axis. Empty triangles left over from shearing the image are filled with the background color.

Seznam parametrů

background

x_shear

y_shear

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::shaveImage | Domů | Imagick::sigmoidalContrastImage


Imagick::sigmoidalContrastImage

(No version information available, might be only in CVS)

Imagick::sigmoidalContrastImage — Adjusts the contrast of an image

Popis

bool Imagick::sigmoidalContrastImage ( bool $sharpen, float $alpha, float $beta [, int $channel] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Adjusts the contrast of an image with a non-linear sigmoidal contrast algorithm. Increase the contrast of the image using a sigmoidal transfer function without saturating highlights or shadows. Contrast indicates how much to increase the contrast (0 is none; 3 is typical; 20 is pushing it); mid-point indicates where midtones fall in the resultant image (0 is white; 50 is middle-gray; 100 is black). Set sharpen to true to increase the image contrast otherwise the contrast is reduced.

Seznam parametrů

sharpen

alpha

beta

channel

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::shearImage | Domů | Imagick::sketchImage


Imagick::sketchImage

(No version information available, might be only in CVS)

Imagick::sketchImage — Simulates a pencil sketch

Popis

bool Imagick::sketchImage ( float $radius, float $sigma, float $angle )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Simulates a pencil sketch. We convolve the image with a Gaussian operator of the given radius and standard deviation (sigma). For reasonable results, radius should be larger than sigma. Use a radius of 0 and Imagick::sketchImage() selects a suitable radius for you. Angle gives the angle of the blurring motion.

Seznam parametrů

radius

sigma

angle

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::sigmoidalContrastImage | Domů | Imagick::solarizeImage


Imagick::solarizeImage

(No version information available, might be only in CVS)

Imagick::solarizeImage — Applies a solarizing effect to the image

Popis

bool Imagick::solarizeImage ( int $threshold )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Applies a special effect to the image, similar to the effect achieved in a photo darkroom by selectively exposing areas of photo sensitive paper to light. Threshold ranges from 0 to QuantumRange and is a measure of the extent of the solarization.

Seznam parametrů

threshold

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::sketchImage | Domů | Imagick::spliceImage


Imagick::spliceImage

(No version information available, might be only in CVS)

Imagick::spliceImage — Splices a solid color into the image

Popis

bool Imagick::spliceImage ( int $width, int $height, int $x, int $y )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Splices a solid color into the image.

Seznam parametrů

width

height

x

y

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::solarizeImage | Domů | Imagick::spreadImage


Imagick::spreadImage

(No version information available, might be only in CVS)

Imagick::spreadImage — Randomly displaces each pixel in a block

Popis

bool Imagick::spreadImage ( float $radius )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Special effects method that randomly displaces each pixel in a block defined by the radius parameter.

Seznam parametrů

radius

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::spliceImage | Domů | Imagick::steganoImage


Imagick::steganoImage

(No version information available, might be only in CVS)

Imagick::steganoImage — Hides a digital watermark within the image

Popis

Imagick Imagick::steganoImage ( Imagick $watermark_wand, int $offset )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Hides a digital watermark within the image. Recover the hidden watermark later to prove that the authenticity of an image. Offset defines the start position within the image to hide the watermark.

Seznam parametrů

watermark_wand

offset

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::spreadImage | Domů | Imagick::stereoImage


Imagick::stereoImage

(No version information available, might be only in CVS)

Imagick::stereoImage — Composites two images

Popis

bool Imagick::stereoImage ( Imagick $offset_wand )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Composites two images and produces a single image that is the composite of a left and right image of a stereo pair.

Seznam parametrů

offset_wand

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::steganoImage | Domů | Imagick::stripImage


Imagick::stripImage

(No version information available, might be only in CVS)

Imagick::stripImage — Strips an image of all profiles and comments

Popis

bool Imagick::stripImage ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Strips an image of all profiles and comments.

Seznam parametrů

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::stereoImage | Domů | Imagick::swirlImage


Imagick::swirlImage

(No version information available, might be only in CVS)

Imagick::swirlImage — Swirls the pixels about the center of the image

Popis

bool Imagick::swirlImage ( float $degrees )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Swirls the pixels about the center of the image, where degrees indicates the sweep of the arc through which each pixel is moved. You get a more dramatic effect as the degrees move from 1 to 360.

Seznam parametrů

degrees

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::stripImage | Domů | Imagick::textureImage


Imagick::textureImage

(No version information available, might be only in CVS)

Imagick::textureImage — Repeatedly tiles the texture image

Popis

bool Imagick::textureImage ( Imagick $texture_wand )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Repeatedly tiles the texture image across and down the image canvas.

Seznam parametrů

texture_wand

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::swirlImage | Domů | Imagick::thresholdImage


Imagick::thresholdImage

(No version information available, might be only in CVS)

Imagick::thresholdImage — Changes the value of individual pixels based on a threshold

Popis

bool Imagick::thresholdImage ( float $threshold [, int $channel] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Changes the value of individual pixels based on the intensity of each pixel compared to threshold. The result is a high-contrast, two color image.

Seznam parametrů

threshold

channel

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::textureImage | Domů | Imagick::thumbnailImage


Imagick::thumbnailImage

(No version information available, might be only in CVS)

Imagick::thumbnailImage — Changes the size of an image

Popis

bool Imagick::thumbnailImage ( int $columns, int $rows [, bool $fit] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Changes the size of an image to the given dimensions and removes any associated profiles. The goal is to produce small low cost thumbnail images suited for display on the Web. If true is given as a third parameter then columns and rows parameters are used as maximums for each side. Both sides will be scaled down until the match or are smaller than the parameter given for the side.

Seznam parametrů

columns

Image width

rows

Image height

fit

Whether to force maximum values

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::thresholdImage | Domů | Imagick::tintImage


Imagick::tintImage

(No version information available, might be only in CVS)

Imagick::tintImage — Applies a color vector to each pixel in the image

Popis

bool Imagick::tintImage ( ImagickPixel $tint, ImagickPixel $opacity )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Applies a color vector to each pixel in the image. The length of the vector is 0 for black and white and at its maximum for the midtones. The vector weighing function is f(x)=(1-(4.0*((x-0.5)*(x-0.5)))).

Seznam parametrů

tint

opacity

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::thumbnailImage | Domů | Imagick::transverseImage


Imagick::transverseImage

(No version information available, might be only in CVS)

Imagick::transverseImage — Creates a horizontal mirror image

Popis

bool Imagick::transverseImage ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Creates a horizontal mirror image by reflecting the pixels around the central y-axis while rotating them 270-degrees.

Seznam parametrů

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::tintImage | Domů | Imagick::trimImage


Imagick::trimImage

(No version information available, might be only in CVS)

Imagick::trimImage — Remove edges from the image

Popis

bool Imagick::trimImage ( float $fuzz )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Remove edges that are the background color from the image.

Seznam parametrů

fuzz

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::transverseImage | Domů | Imagick::uniqueImageColors


Imagick::uniqueImageColors

(No version information available, might be only in CVS)

Imagick::uniqueImageColors — Discards all but one of any pixel color

Popis

bool Imagick::uniqueImageColors ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Discards all but one of any pixel color.

Seznam parametrů

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::trimImage | Domů | Imagick::unsharpMaskImage


Imagick::unsharpMaskImage

(No version information available, might be only in CVS)

Imagick::unsharpMaskImage — Sharpens an image

Popis

bool Imagick::unsharpMaskImage ( float $radius, float $sigma, float $amount, float $threshold [, int $channel] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sharpens an image. We convolve the image with a Gaussian operator of the given radius and standard deviation (sigma). For reasonable results, radius should be larger than sigma. Use a radius of 0 and Imagick::UnsharpMaskImage() selects a suitable radius for you.

Seznam parametrů

radius

sigma

amount

threshold

channel

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::uniqueImageColors | Domů | Imagick::valid


Imagick::valid

(No version information available, might be only in CVS)

Imagick::valid — Checks if the current item is valid

Popis

bool Imagick::valid ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Checks if the current item is valid.

Seznam parametrů

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::unsharpMaskImage | Domů | Imagick::vignetteImage


Imagick::vignetteImage

(No version information available, might be only in CVS)

Imagick::vignetteImage — Adds vignette filter to the image

Popis

bool Imagick::vignetteImage ( float $blackPoint, float $whitePoint, int $x, int $y )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Adds vignette filter to the image.

Seznam parametrů

blackPoint

whitePoint

x

y

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::valid | Domů | Imagick::waveImage


Imagick::waveImage

(No version information available, might be only in CVS)

Imagick::waveImage — Adds wave filter to the image

Popis

bool Imagick::waveImage ( float $amplitude, float $length )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Adds wave filter to the image.

Seznam parametrů

amplitude

length

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::vignetteImage | Domů | Imagick::whiteThresholdImage


Imagick::whiteThresholdImage

(No version information available, might be only in CVS)

Imagick::whiteThresholdImage — Force all pixels above the threshold into white

Popis

bool Imagick::whiteThresholdImage ( ImagickPixel $threshold )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Is like Imagick::ThresholdImage() but force all pixels above the threshold into white while leaving all pixels below the threshold unchanged.

Seznam parametrů

threshold

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::waveImage | Domů | Imagick::writeImages


Imagick::writeImage

(No version information available, might be only in CVS)

Imagick::writeImage — Writes an image to the specified filename

Popis

bool Imagick::writeImage ( [string $filename] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Writes an image to the specified filename. If the filename parameter is NULL, the image is written to the filename set by Imagick::ReadImage() or Imagick::SetImageFilename().

Seznam parametrů

filename

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::writeImages | Domů | Imagick::displayImage


Imagick::writeImages

(No version information available, might be only in CVS)

Imagick::writeImages — Writes an image or image sequence

Popis

bool Imagick::writeImages ( string $filename, bool $adjoin )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Writes an image or image sequence.

Seznam parametrů

filename

adjoin

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
Imagick::whiteThresholdImage | Domů | Imagick::writeImage


ImagickDraw::affine

(No version information available, might be only in CVS)

ImagickDraw::affine — Adjusts the current affine transformation matrix

Popis

bool ImagickDraw::affine ( array $affine )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Adjusts the current affine transformation matrix with the specified affine transformation matrix.

Seznam parametrů

affine

Affine matrix parameters

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
Imagick::queryFontMetrics | Domů | ImagickDraw::annotation


ImagickDraw::annotation

(No version information available, might be only in CVS)

ImagickDraw::annotation — Draws text on the image

Popis

bool ImagickDraw::annotation ( float $x, float $y, string $text )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Draws text on the image.

Seznam parametrů

x

The x coordinate where text is drawn

y

The y coordinate where text is drawn

text

The text to draw on the image

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::affine | Domů | ImagickDraw::arc


ImagickDraw::arc

(No version information available, might be only in CVS)

ImagickDraw::arc — Draws an arc

Popis

bool ImagickDraw::arc ( float $sx, float $sy, float $ex, float $ey, float $sd, float $ed )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Draws an arc falling within a specified bounding rectangle on the image.

Seznam parametrů

sx

Starting x ordinate of bounding rectangle

sy

starting y ordinate of bounding rectangle

ex

ending x ordinate of bounding rectangle

ey

ending y ordinate of bounding rectangle

sd

starting degrees of rotation

ed

ending degrees of rotation

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::annotation | Domů | ImagickDraw::bezier


ImagickDraw::bezier

(No version information available, might be only in CVS)

ImagickDraw::bezier — Draws a bezier curve

Popis

bool ImagickDraw::bezier ( array $coordinates )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Draws a bezier curve through a set of points on the image.

Seznam parametrů

coordinates

Multidimensional array like array( array( 'x' => 1, 'y' => 2 ), array( 'x' => 3, 'y' => 4 ) )

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::arc | Domů | ImagickDraw::circle


ImagickDraw::circle

(No version information available, might be only in CVS)

ImagickDraw::circle — Draws a circle

Popis

bool ImagickDraw::circle ( float $ox, float $oy, float $px, float $py )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Draws a circle on the image.

Seznam parametrů

ox

origin x coordinate

oy

origin y coordinate

px

perimeter x coordinate

py

perimeter y coordinate

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::bezier | Domů | ImagickDraw::clear


ImagickDraw::clear

(No version information available, might be only in CVS)

ImagickDraw::clear — Clears the ImagickDraw

Popis

bool ImagickDraw::clear ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Clears the ImagickDraw object of any accumulated commands, and resets the settings it contains to their defaults.

Seznam parametrů

Návratové hodnoty

Returns an ImagickDraw object.

Předcházející | Nahoru | Další
ImagickDraw::circle | Domů | ImagickDraw::clone


ImagickDraw::clone

(No version information available, might be only in CVS)

ImagickDraw::clone — Makes an exact copy of the specified ImagickDraw object

Popis

ImagickDraw ImagickDraw::clone ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Makes an exact copy of the specified ImagickDraw object.

Seznam parametrů

Návratové hodnoty

What the function returns, first on success, then on failure. See also the &return.success; entity

Předcházející | Nahoru | Další
ImagickDraw::clear | Domů | ImagickDraw::color


ImagickDraw::color

(No version information available, might be only in CVS)

ImagickDraw::color — Draws color on image

Popis

bool ImagickDraw::color ( float $x, float $y, int $paintMethod )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Draws color on image using the current fill color, starting at specified position, and using specified paint method.

Seznam parametrů

x

x coordinate of the paint

y

y coordinate of the paint

paintMethod

one of the PAINT_ constants

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::clone | Domů | ImagickDraw::comment


ImagickDraw::comment

(No version information available, might be only in CVS)

ImagickDraw::comment — Adds a comment

Popis

bool ImagickDraw::comment ( string $comment )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Adds a comment to a vector output stream.

Seznam parametrů

comment

The comment string to add to vector output stream

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::color | Domů | ImagickDraw::composite


ImagickDraw::composite

(No version information available, might be only in CVS)

ImagickDraw::composite — Composites an image onto the current image

Popis

bool ImagickDraw::composite ( int $compose, float $x, float $y, float $width, float $height, Imagick $compositeWand )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Composites an image onto the current image, using the specified composition operator, specified position, and at the specified size.

Seznam parametrů

compose

composition operator. One of COMPOSITE_ constants

x

x coordinate of the top left corner

y

y coordinate of the top left corner

width

width of the composition image

height

height of the composition image

compositeWand

the Imagick object where composition image is taken from

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
ImagickDraw::comment | Domů | ImagickDraw::__construct


ImagickDraw::__construct

(No version information available, might be only in CVS)

ImagickDraw::__construct — The ImagickDraw constructor

Popis

ImagickDraw ImagickDraw::__construct ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

The ImagickDraw constructor

Seznam parametrů

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::composite | Domů | ImagickDraw::destroy


ImagickDraw::destroy

(No version information available, might be only in CVS)

ImagickDraw::destroy — Frees all associated resources

Popis

bool ImagickDraw::destroy ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Frees all resources associated with the ImagickDraw object.

Seznam parametrů

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::__construct | Domů | ImagickDraw::ellipse


ImagickDraw::ellipse

(No version information available, might be only in CVS)

ImagickDraw::ellipse — Draws an ellipse on the image

Popis

bool ImagickDraw::ellipse ( float $ox, float $oy, float $rx, float $ry, float $start, float $end )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Draws an ellipse on the image.

Seznam parametrů

ox

oy

rx

ry

start

end

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::destroy | Domů | ImagickDraw::getClipPath


ImagickDraw::getClipPath

(No version information available, might be only in CVS)

ImagickDraw::getClipPath — Obtains the current clipping path ID

Popis

string ImagickDraw::getClipPath ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Obtains the current clipping path ID.

Seznam parametrů

Návratové hodnoty

Returns a string containing the clip path ID or false if no clip path exists.

Předcházející | Nahoru | Další
ImagickDraw::ellipse | Domů | ImagickDraw::getClipRule


ImagickDraw::getClipRule

(No version information available, might be only in CVS)

ImagickDraw::getClipRule — Returns the current polygon fill rule

Popis

int ImagickDraw::getClipRule ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the current polygon fill rule to be used by the clipping path.

Seznam parametrů

Návratové hodnoty

Returns one of the FILLRULE_ constants.

Předcházející | Nahoru | Další
ImagickDraw::getClipPath | Domů | ImagickDraw::getClipUnits


ImagickDraw::getClipUnits

(No version information available, might be only in CVS)

ImagickDraw::getClipUnits — Returns the interpretation of clip path units

Popis

int ImagickDraw::getClipUnits ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the interpretation of clip path units.

Seznam parametrů

Návratové hodnoty

Returns an int on success.

Předcházející | Nahoru | Další
ImagickDraw::getClipRule | Domů | ImagickDraw::getFillColor


ImagickDraw::getFillColor

(No version information available, might be only in CVS)

ImagickDraw::getFillColor — Returns the fill color

Popis

ImagickPixel ImagickDraw::getFillColor ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the fill color used for drawing filled objects.

Seznam parametrů

Návratové hodnoty

Returns an ImagickPixel object.

Předcházející | Nahoru | Další
ImagickDraw::getClipUnits | Domů | ImagickDraw::getFillOpacity


ImagickDraw::getFillOpacity

(No version information available, might be only in CVS)

ImagickDraw::getFillOpacity — Returns the opacity used when drawing

Popis

float ImagickDraw::getFillOpacity ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the opacity used when drawing using the fill color or fill texture. Fully opaque is 1.0.

Seznam parametrů

Návratové hodnoty

What the function returns, first on success, then on failure. See also the &return.success; entity

Předcházející | Nahoru | Další
ImagickDraw::getFillColor | Domů | ImagickDraw::getFillRule


ImagickDraw::getFillRule

(No version information available, might be only in CVS)

ImagickDraw::getFillRule — Returns the fill rule

Popis

int ImagickDraw::getFillRule ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the fill rule used while drawing polygons.

Seznam parametrů

Návratové hodnoty

Returns a FILLRULE_ constant

Předcházející | Nahoru | Další
ImagickDraw::getFillOpacity | Domů | ImagickDraw::getFontFamily


ImagickDraw::getFont

(No version information available, might be only in CVS)

ImagickDraw::getFont — Returns the font

Popis

string ImagickDraw::getFont ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns a string specifying the font used when annotating with text.

Seznam parametrů

Návratové hodnoty

Returns a string on success and false if no font is set.

Předcházející | Nahoru | Další
ImagickDraw::getFontWeight | Domů | ImagickDraw::getGravity


ImagickDraw::getFontFamily

(No version information available, might be only in CVS)

ImagickDraw::getFontFamily — Returns the font family

Popis

string ImagickDraw::getFontFamily ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the font family to use when annotating with text.

Seznam parametrů

Návratové hodnoty

Returns the font family currently selected or false if font family is not set.

Předcházející | Nahoru | Další
ImagickDraw::getFillRule | Domů | ImagickDraw::getFontSize


ImagickDraw::getFontSize

(No version information available, might be only in CVS)

ImagickDraw::getFontSize — Returns the font pointsize

Popis

float ImagickDraw::getFontSize ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the font pointsize used when annotating with text.

Seznam parametrů

Návratové hodnoty

Returns the font size associated with the current ImagickDraw object.

Předcházející | Nahoru | Další
ImagickDraw::getFontFamily | Domů | ImagickDraw::getFontStyle


ImagickDraw::getFontStyle

(No version information available, might be only in CVS)

ImagickDraw::getFontStyle — Returns the font style

Popis

int ImagickDraw::getFontStyle ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the font style used when annotating with text.

Seznam parametrů

Návratové hodnoty

Returns the font style constant (STYLE_) associated with the ImagickDraw object or 0 if no style is set.

Předcházející | Nahoru | Další
ImagickDraw::getFontSize | Domů | ImagickDraw::getFontWeight


ImagickDraw::getFontWeight

(No version information available, might be only in CVS)

ImagickDraw::getFontWeight — Returns the font weight

Popis

int ImagickDraw::getFontWeight ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the font weight used when annotating with text.

Seznam parametrů

Návratové hodnoty

Returns an int on success and 0 if no weight is set.

Předcházející | Nahoru | Další
ImagickDraw::getFontStyle | Domů | ImagickDraw::getFont


ImagickDraw::getGravity

(No version information available, might be only in CVS)

ImagickDraw::getGravity — Returns the text placement gravity

Popis

int ImagickDraw::getGravity ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the text placement gravity used when annotating with text.

Seznam parametrů

Návratové hodnoty

Returns a GRAVITY_ constant on success and 0 if no gravity is set.

Předcházející | Nahoru | Další
ImagickDraw::getFont | Domů | ImagickDraw::getStrokeAntialias


ImagickDraw::getStrokeAntialias

(No version information available, might be only in CVS)

ImagickDraw::getStrokeAntialias — Returns the current stroke antialias setting

Popis

bool ImagickDraw::getStrokeAntialias ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the current stroke antialias setting. Stroked outlines are antialiased by default. When antialiasing is disabled stroked pixels are thresholded to determine if the stroke color or underlying canvas color should be used.

Seznam parametrů

Návratové hodnoty

Returns true if antialiasing is on and false if it is off.

Předcházející | Nahoru | Další
ImagickDraw::getGravity | Domů | ImagickDraw::getStrokeColor


ImagickDraw::getStrokeColor

(No version information available, might be only in CVS)

ImagickDraw::getStrokeColor — Returns the color used for stroking object outlines

Popis

ImagickPixel ImagickDraw::getStrokeColor ( ImagickPixel $stroke_color )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the color used for stroking object outlines.

Seznam parametrů

stroke_color

Návratové hodnoty

Returns an ImagickPixel object which describes the color.

Předcházející | Nahoru | Další
ImagickDraw::getStrokeAntialias | Domů | ImagickDraw::getStrokeDashArray


ImagickDraw::getStrokeDashArray

(No version information available, might be only in CVS)

ImagickDraw::getStrokeDashArray — Returns an array representing the pattern of dashes and gaps used to stroke paths

Popis

array ImagickDraw::getStrokeDashArray ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns an array representing the pattern of dashes and gaps used to stroke paths.

Seznam parametrů

Návratové hodnoty

Returns an array on success and empty array if not set.

Předcházející | Nahoru | Další
ImagickDraw::getStrokeColor | Domů | ImagickDraw::getStrokeDashOffset


ImagickDraw::getStrokeDashOffset

(No version information available, might be only in CVS)

ImagickDraw::getStrokeDashOffset — Returns the offset into the dash pattern to start the dash

Popis

float ImagickDraw::getStrokeDashOffset ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the offset into the dash pattern to start the dash.

Seznam parametrů

Návratové hodnoty

Returns a float representing the offset and 0 if it's not set.

Předcházející | Nahoru | Další
ImagickDraw::getStrokeDashArray | Domů | ImagickDraw::getStrokeLineCap


ImagickDraw::getStrokeLineCap

(No version information available, might be only in CVS)

ImagickDraw::getStrokeLineCap — Returns the shape to be used at the end of open subpaths when they are stroked

Popis

int ImagickDraw::getStrokeLineCap ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the shape to be used at the end of open subpaths when they are stroked.

Seznam parametrů

Návratové hodnoty

Returns one of the LINECAP_ constants or 0 if stroke linecap is not set.

Předcházející | Nahoru | Další
ImagickDraw::getStrokeDashOffset | Domů | ImagickDraw::getStrokeLineJoin


ImagickDraw::getStrokeLineJoin

(No version information available, might be only in CVS)

ImagickDraw::getStrokeLineJoin — Returns the shape to be used at the corners of paths when they are stroked

Popis

int ImagickDraw::getStrokeLineJoin ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the shape to be used at the corners of paths (or other vector shapes) when they are stroked.

Seznam parametrů

Návratové hodnoty

Returns one of the LINEJOIN_ constants or 0 if stroke line join is not set.

Předcházející | Nahoru | Další
ImagickDraw::getStrokeLineCap | Domů | ImagickDraw::getStrokeMiterLimit


ImagickDraw::getStrokeMiterLimit

(No version information available, might be only in CVS)

ImagickDraw::getStrokeMiterLimit — Returns the stroke miter limit

Popis

int ImagickDraw::getStrokeMiterLimit ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the miter limit. When two line segments meet at a sharp angle and miter joins have been specified for 'lineJoin', it is possible for the miter to extend far beyond the thickness of the line stroking the path. The miterLimit' imposes a limit on the ratio of the miter length to the 'lineWidth'.

Seznam parametrů

Návratové hodnoty

Returns an int describing the miter limit and 0 if no miter limit is set.

Předcházející | Nahoru | Další
ImagickDraw::getStrokeLineJoin | Domů | ImagickDraw::getStrokeOpacity


ImagickDraw::getStrokeOpacity

(No version information available, might be only in CVS)

ImagickDraw::getStrokeOpacity — Returns the opacity of stroked object outlines

Popis

float ImagickDraw::getStrokeOpacity ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the opacity of stroked object outlines.

Seznam parametrů

Návratové hodnoty

Returns a double describing the opacity.

Předcházející | Nahoru | Další
ImagickDraw::getStrokeMiterLimit | Domů | ImagickDraw::getStrokeWidth


ImagickDraw::getStrokeWidth

(No version information available, might be only in CVS)

ImagickDraw::getStrokeWidth — Returns the width of the stroke used to draw object outlines

Popis

float ImagickDraw::getStrokeWidth ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the width of the stroke used to draw object outlines.

Seznam parametrů

Návratové hodnoty

Returns a double describing the stroke width.

Předcházející | Nahoru | Další
ImagickDraw::getStrokeOpacity | Domů | ImagickDraw::getTextAlignment


ImagickDraw::getTextAlignment

(No version information available, might be only in CVS)

ImagickDraw::getTextAlignment — Returns the text alignment

Popis

int ImagickDraw::getTextAlignment ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the alignment applied when annotating with text.

Seznam parametrů

Návratové hodnoty

Returns one of the ALIGN_ constants and 0 if no align is set.

Předcházející | Nahoru | Další
ImagickDraw::getStrokeWidth | Domů | ImagickDraw::getTextAntialias


ImagickDraw::getTextAntialias

(No version information available, might be only in CVS)

ImagickDraw::getTextAntialias — Returns the current text antialias setting

Popis

bool ImagickDraw::getTextAntialias ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the current text antialias setting, which determines whether text is antialiased. Text is antialiased by default.

Seznam parametrů

Návratové hodnoty

Returns true if text is antialiased and false if not.

Předcházející | Nahoru | Další
ImagickDraw::getTextAlignment | Domů | ImagickDraw::getTextDecoration


ImagickDraw::getTextDecoration

(No version information available, might be only in CVS)

ImagickDraw::getTextDecoration — Returns the text decoration

Popis

int ImagickDraw::getTextDecoration ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the decoration applied when annotating with text.

Seznam parametrů

Návratové hodnoty

Returns one of the DECORATION_ constants and 0 if no decoration is set.

Předcházející | Nahoru | Další
ImagickDraw::getTextAntialias | Domů | ImagickDraw::getTextEncoding


ImagickDraw::getTextEncoding

(No version information available, might be only in CVS)

ImagickDraw::getTextEncoding — Returns the code set used for text annotations

Popis

string ImagickDraw::getTextEncoding ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns a string which specifies the code set used for text annotations.

Seznam parametrů

Návratové hodnoty

Returns a string specifying the code set or false if text encoding is not set.

Předcházející | Nahoru | Další
ImagickDraw::getTextDecoration | Domů | ImagickDraw::getTextUnderColor


ImagickDraw::getTextUnderColor

(No version information available, might be only in CVS)

ImagickDraw::getTextUnderColor — Returns the text under color

Popis

ImagickPixel ImagickDraw::getTextUnderColor ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the color of a background rectangle to place under text annotations.

Návratové hodnoty

Returns an ImagickPixel object describing the color.

Předcházející | Nahoru | Další
ImagickDraw::getTextEncoding | Domů | ImagickDraw::getVectorGraphics


ImagickDraw::getVectorGraphics

(No version information available, might be only in CVS)

ImagickDraw::getVectorGraphics — Returns a string containing vector graphics

Popis

string ImagickDraw::getVectorGraphics ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns a string which specifies the vector graphics generated by any graphics calls made since the ImagickDraw object was instantiated.

Seznam parametrů

Návratové hodnoty

Returns a string containing the vector graphics.

Předcházející | Nahoru | Další
ImagickDraw::getTextUnderColor | Domů | ImagickDraw::line


ImagickDraw::line

(No version information available, might be only in CVS)

ImagickDraw::line — Draws a line

Popis

bool ImagickDraw::line ( float $sx, float $sy, float $ex, float $ey )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Draws a line on the image using the current stroke color, stroke opacity, and stroke width.

Seznam parametrů

sx

starting x coordinate

sy

starting y coordinate

ex

ending x coordinate

ey

ending y coordinate

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::getVectorGraphics | Domů | ImagickDraw::matte


ImagickDraw::matte

(No version information available, might be only in CVS)

ImagickDraw::matte — Paints on the image's opacity channel

Popis

bool ImagickDraw::matte ( float $x, float $y, int $paintMethod )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Paints on the image's opacity channel in order to set effected pixels to transparent. to influence the opacity of pixels.

Seznam parametrů

x

x coordinate of the matte

y

y coordinate of the matte

paintMethod

PAINT_ constant

Návratové hodnoty

What the function returns, first on success, then on failure. See also the &return.success; entity

Předcházející | Nahoru | Další
ImagickDraw::line | Domů | ImagickDraw::pathClose


ImagickDraw::pathClose

(No version information available, might be only in CVS)

ImagickDraw::pathClose — Adds a path element to the current path

Popis

bool ImagickDraw::pathClose ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Adds a path element to the current path which closes the current subpath by drawing a straight line from the current point to the current subpath's most recent starting point (usually, the most recent moveto point).

Seznam parametrů

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::matte | Domů | ImagickDraw::pathCurveToAbsolute


ImagickDraw::pathCurveToAbsolute

(No version information available, might be only in CVS)

ImagickDraw::pathCurveToAbsolute — Draws a cubic Bezier curve

Popis

bool ImagickDraw::pathCurveToAbsolute ( float $x1, float $y1, float $x2, float $y2, float $x, float $y )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Draws a cubic Bezier curve from the current point to (x,y) using (x1,y1) as the control point at the beginning of the curve and (x2,y2) as the control point at the end of the curve using absolute coordinates. At the end of the command, the new current point becomes the final (x,y) coordinate pair used in the polybezier.

Seznam parametrů

x1

x coordinate of the first control point

y1

y coordinate of the first control point

x2

x coordinate of the second control point

y2

y coordinate of the first control point

x

x coordinate of the curve end

y

y coordinate of the curve end

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::pathClose | Domů | ImagickDraw::pathCurveToQuadraticBezierAbsolute


ImagickDraw::pathCurveToQuadraticBezierAbsolute

(No version information available, might be only in CVS)

ImagickDraw::pathCurveToQuadraticBezierAbsolute — Draws a quadratic Bezier curve

Popis

bool ImagickDraw::pathCurveToQuadraticBezierAbsolute ( float $x1, float $y1, float $x, float $y )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Draws a quadratic Bezier curve from the current point to (x,y) using (x1,y1) as the control point using absolute coordinates. At the end of the command, the new current point becomes the final (x,y) coordinate pair used in the polybezier.

Seznam parametrů

x1

x coordinate of the control point

y1

y coordinate of the control point

x

x coordinate of the end point

y

y coordinate of the end point

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::pathCurveToAbsolute | Domů | ImagickDraw::pathCurveToQuadraticBezierRelative


ImagickDraw::pathCurveToQuadraticBezierRelative

(No version information available, might be only in CVS)

ImagickDraw::pathCurveToQuadraticBezierRelative — Draws a quadratic Bezier curve

Popis

bool ImagickDraw::pathCurveToQuadraticBezierRelative ( float $x1, float $y1, float $x, float $y )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Draws a quadratic Bezier curve from the current point to (x,y) using (x1,y1) as the control point using relative coordinates. At the end of the command, the new current point becomes the final (x,y) coordinate pair used in the polybezier.

Seznam parametrů

x1

starting x coordinate

y1

starting y coordinate

x

ending x coordinate

y

ending y coordinate

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::pathCurveToQuadraticBezierAbsolute | Domů | ImagickDraw::pathCurveToQuadraticBezierSmoothAbsolute


ImagickDraw::pathCurveToQuadraticBezierSmoothAbsolute

(No version information available, might be only in CVS)

ImagickDraw::pathCurveToQuadraticBezierSmoothAbsolute — Draws a quadratic Bezier curve

Popis

bool ImagickDraw::pathCurveToQuadraticBezierSmoothAbsolute ( float $x, float $y )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Draws a quadratic Bezier curve (using relative coordinates) from the current point to (x,y). The control point is assumed to be the reflection of the control point on the previous command relative to the current point. (If there is no previous command or if the previous command was not a DrawPathCurveToQuadraticBezierAbsolute, DrawPathCurveToQuadraticBezierRelative, DrawPathCurveToQuadraticBezierSmoothAbsolut or DrawPathCurveToQuadraticBezierSmoothRelative, assume the control point is coincident with the current point.). At the end of the command, the new current point becomes the final (x,y) coordinate pair used in the polybezier.

Seznam parametrů

x

ending x coordinate

y

ending y coordinate

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::pathCurveToQuadraticBezierRelative | Domů | ImagickDraw::pathCurveToQuadraticBezierSmoothRelative


ImagickDraw::pathCurveToQuadraticBezierSmoothRelative

(No version information available, might be only in CVS)

ImagickDraw::pathCurveToQuadraticBezierSmoothRelative — Draws a quadratic Bezier curve

Popis

bool ImagickDraw::pathCurveToQuadraticBezierSmoothRelative ( float $x, float $y )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Draws a quadratic Bezier curve (using relative coordinates) from the current point to (x, y). The control point is assumed to be the reflection of the control point on the previous command relative to the current point. (If there is no previous command or if the previous command was not a DrawPathCurveToQuadraticBezierAbsolute, DrawPathCurveToQuadraticBezierRelative, DrawPathCurveToQuadraticBezierSmoothAbsolut or DrawPathCurveToQuadraticBezierSmoothRelative, assume the control point is coincident with the current point). At the end of the command, the new current point becomes the final (x, y) coordinate pair used in the polybezier.

Seznam parametrů

x

ending x coordinate

y

ending y coordinate

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::pathCurveToQuadraticBezierSmoothAbsolute | Domů | ImagickDraw::pathCurveToRelative


ImagickDraw::pathCurveToRelative

(No version information available, might be only in CVS)

ImagickDraw::pathCurveToRelative — Draws a cubic Bezier curve

Popis

bool ImagickDraw::pathCurveToRelative ( float $x1, float $y1, float $x2, float $y2, float $x, float $y )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Draws a cubic Bezier curve from the current point to (x,y) using (x1,y1) as the control point at the beginning of the curve and (x2,y2) as the control point at the end of the curve using relative coordinates. At the end of the command, the new current point becomes the final (x,y) coordinate pair used in the polybezier.

Seznam parametrů

x1

x coordinate of starting control point

y1

y coordinate of starting control point

x2

x coordinate of ending control point

y2

y coordinate of ending control point

x

ending x coordinate

y

ending y coordinate

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::pathCurveToQuadraticBezierSmoothRelative | Domů | ImagickDraw::pathCurveToSmoothAbsolute


ImagickDraw::pathCurveToSmoothAbsolute

(No version information available, might be only in CVS)

ImagickDraw::pathCurveToSmoothAbsolute — Draws a cubic Bezier curve

Popis

bool ImagickDraw::pathCurveToSmoothAbsolute ( float $x2, float $y2, float $x, float $y )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Draws a cubic Bezier curve from the current point to (x,y) using absolute coordinates. The first control point is assumed to be the reflection of the second control point on the previous command relative to the current point. (If there is no previous command or if the previous command was not an DrawPathCurveToAbsolute, DrawPathCurveToRelative, DrawPathCurveToSmoothAbsolute or DrawPathCurveToSmoothRelative, assume the first control point is coincident with the current point.) (x2,y2) is the second control point (i.e., the control point at the end of the curve). At the end of the command, the new current point becomes the final (x,y) coordinate pair used in the polybezier.

Seznam parametrů

x2

x coordinate of the second control point

y2

y coordinate of the second control point

x

x coordinate of the ending point

y

y coordinate of the ending point

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::pathCurveToRelative | Domů | ImagickDraw::pathCurveToSmoothRelative


ImagickDraw::pathCurveToSmoothRelative

(No version information available, might be only in CVS)

ImagickDraw::pathCurveToSmoothRelative — Draws a cubic Bezier curve

Popis

bool ImagickDraw::pathCurveToSmoothRelative ( float $x2, float $y2, float $x, float $y )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Draws a cubic Bezier curve from the current point to (x,y) using relative coordinates. The first control point is assumed to be the reflection of the second control point on the previous command relative to the current point. (If there is no previous command or if the previous command was not an DrawPathCurveToAbsolute, DrawPathCurveToRelative, DrawPathCurveToSmoothAbsolute or DrawPathCurveToSmoothRelative, assume the first control point is coincident with the current point.) (x2,y2) is the second control point (i.e., the control point at the end of the curve). At the end of the command, the new current point becomes the final (x,y) coordinate pair used in the polybezier.

Seznam parametrů

x2

x coordinate of the second control point

y2

y coordinate of the second control point

x

x coordinate of the ending point

y

y coordinate of the ending point

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::pathCurveToSmoothAbsolute | Domů | ImagickDraw::pathEllipticArcAbsolute


ImagickDraw::pathEllipticArcAbsolute

(No version information available, might be only in CVS)

ImagickDraw::pathEllipticArcAbsolute — Draws an elliptical arc

Popis

bool ImagickDraw::pathEllipticArcAbsolute ( float $rx, float $ry, float $x_axis_rotation, bool $large_arc_flag, bool $sweep_flag, float $x, float $y )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Draws an elliptical arc from the current point to (x, y) using absolute coordinates. The size and orientation of the ellipse are defined by two radii (rx, ry) and an xAxisRotation, which indicates how the ellipse as a whole is rotated relative to the current coordinate system. The center (cx, cy) of the ellipse is calculated automatically to satisfy the constraints imposed by the other parameters. largeArcFlag and sweepFlag contribute to the automatic calculations and help determine how the arc is drawn. If largeArcFlag is true then draw the larger of the available arcs. If sweepFlag is true, then draw the arc matching a clock-wise rotation.

Seznam parametrů

rx

x radius

ry

y radius

x_axis_rotation

x axis rotation

large_arc_flag

large arc flag

sweep_flag

sweep flag

x

x coordinate

y

y coordinate

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::pathCurveToSmoothRelative | Domů | ImagickDraw::pathEllipticArcRelative


ImagickDraw::pathEllipticArcRelative

(No version information available, might be only in CVS)

ImagickDraw::pathEllipticArcRelative — Draws an elliptical arc

Popis

bool ImagickDraw::pathEllipticArcRelative ( float $rx, float $ry, float $x_axis_rotation, bool $large_arc_flag, bool $sweep_flag, float $x, float $y )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Draws an elliptical arc from the current point to (x, y) using relative coordinates. The size and orientation of the ellipse are defined by two radii (rx, ry) and an xAxisRotation, which indicates how the ellipse as a whole is rotated relative to the current coordinate system. The center (cx, cy) of the ellipse is calculated automatically to satisfy the constraints imposed by the other parameters. largeArcFlag and sweepFlag contribute to the automatic calculations and help determine how the arc is drawn. If largeArcFlag is true then draw the larger of the available arcs. If sweepFlag is true, then draw the arc matching a clock-wise rotation.

Seznam parametrů

rx

x radius

ry

y radius

x_axis_rotation

x axis rotation

large_arc_flag

large arc flag

sweep_flag

sweep flag

x

x coordinate

y

y coordinate

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::pathEllipticArcAbsolute | Domů | ImagickDraw::pathFinish


ImagickDraw::pathFinish

(No version information available, might be only in CVS)

ImagickDraw::pathFinish — Terminates the current path

Popis

bool ImagickDraw::pathFinish ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Terminates the current path.

Seznam parametrů

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::pathEllipticArcRelative | Domů | ImagickDraw::pathLineToAbsolute


ImagickDraw::pathLineToAbsolute

(No version information available, might be only in CVS)

ImagickDraw::pathLineToAbsolute — Draws a line path

Popis

bool ImagickDraw::pathLineToAbsolute ( float $x, float $y )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Draws a line path from the current point to the given coordinate using absolute coordinates. The coordinate then becomes the new current point.

Seznam parametrů

x

starting x coordinate

y

ending x coordinate

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::pathFinish | Domů | ImagickDraw::pathLineToHorizontalAbsolute


ImagickDraw::pathLineToHorizontalAbsolute

(No version information available, might be only in CVS)

ImagickDraw::pathLineToHorizontalAbsolute — Draws a horizontal line path

Popis

bool ImagickDraw::pathLineToHorizontalAbsolute ( float $x )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Draws a horizontal line path from the current point to the target point using absolute coordinates. The target point then becomes the new current point.

Seznam parametrů

x

x coordinate

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::pathLineToAbsolute | Domů | ImagickDraw::pathLineToHorizontalRelative


ImagickDraw::pathLineToHorizontalRelative

(No version information available, might be only in CVS)

ImagickDraw::pathLineToHorizontalRelative — Draws a horizontal line

Popis

bool ImagickDraw::pathLineToHorizontalRelative ( float $x )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Draws a horizontal line path from the current point to the target point using relative coordinates. The target point then becomes the new current point.

Seznam parametrů

x

x coordinate

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::pathLineToHorizontalAbsolute | Domů | ImagickDraw::pathLineToRelative


ImagickDraw::pathLineToRelative

(No version information available, might be only in CVS)

ImagickDraw::pathLineToRelative — Draws a line path

Popis

bool ImagickDraw::pathLineToRelative ( float $x, float $y )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Draws a line path from the current point to the given coordinate using relative coordinates. The coordinate then becomes the new current point.

Seznam parametrů

x

starting x coordinate

y

starting y coordinate

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::pathLineToHorizontalRelative | Domů | ImagickDraw::pathLineToVerticalAbsolute


ImagickDraw::pathLineToVerticalAbsolute

(No version information available, might be only in CVS)

ImagickDraw::pathLineToVerticalAbsolute — Draws a vertical line

Popis

bool ImagickDraw::pathLineToVerticalAbsolute ( float $y )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Draws a vertical line path from the current point to the target point using absolute coordinates. The target point then becomes the new current point.

Seznam parametrů

y

y coordinate

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::pathLineToRelative | Domů | ImagickDraw::pathLineToVerticalRelative


ImagickDraw::pathLineToVerticalRelative

(No version information available, might be only in CVS)

ImagickDraw::pathLineToVerticalRelative — Draws a vertical line path

Popis

bool ImagickDraw::pathLineToVerticalRelative ( float $y )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Draws a vertical line path from the current point to the target point using relative coordinates. The target point then becomes the new current point.

Seznam parametrů

y

y coordinate

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::pathLineToVerticalAbsolute | Domů | ImagickDraw::pathMoveToAbsolute


ImagickDraw::pathMoveToAbsolute

(No version information available, might be only in CVS)

ImagickDraw::pathMoveToAbsolute — Starts a new sub-path

Popis

bool ImagickDraw::pathMoveToAbsolute ( float $x, float $y )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Starts a new sub-path at the given coordinate using absolute coordinates. The current point then becomes the specified coordinate.

Seznam parametrů

x

x coordinate of the starting point

y

y coordinate of the starting point

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::pathLineToVerticalRelative | Domů | ImagickDraw::pathMoveToRelative


ImagickDraw::pathMoveToRelative

(No version information available, might be only in CVS)

ImagickDraw::pathMoveToRelative — Starts a new sub-path

Popis

bool ImagickDraw::pathMoveToRelative ( float $x, float $y )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Starts a new sub-path at the given coordinate using relative coordinates. The current point then becomes the specified coordinate.

Seznam parametrů

x

target x coordinate

y

target y coordinate

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::pathMoveToAbsolute | Domů | ImagickDraw::pathStart


ImagickDraw::pathStart

(No version information available, might be only in CVS)

ImagickDraw::pathStart — Declares the start of a path drawing list

Popis

bool ImagickDraw::pathStart ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Declares the start of a path drawing list which is terminated by a matching DrawPathFinish() command. All other DrawPath commands must be enclosed between a and a DrawPathFinish() command. This is because path drawing commands are subordinate commands and they do not function by themselves.

Seznam parametrů

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::pathMoveToRelative | Domů | ImagickDraw::point


ImagickDraw::point

(No version information available, might be only in CVS)

ImagickDraw::point — Draws a point

Popis

bool ImagickDraw::point ( float $x, float $y )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Draws a point using the current stroke color and stroke thickness at the specified coordinates.

Seznam parametrů

x

point's x coordinate

y

point's y coordinate

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::pathStart | Domů | ImagickDraw::polygon


ImagickDraw::polygon

(No version information available, might be only in CVS)

ImagickDraw::polygon — Draws a polygon

Popis

bool ImagickDraw::polygon ( array $coordinates )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Draws a polygon using the current stroke, stroke width, and fill color or texture, using the specified array of coordinates.

Seznam parametrů

coordinates

multidimensional array like array( array( 'x' => 3, 'y' => 4 ), array( 'x' => 2, 'y' => 6 ) );

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
ImagickDraw::point | Domů | ImagickDraw::polyline


ImagickDraw::polyline

(No version information available, might be only in CVS)

ImagickDraw::polyline — Draws a polyline

Popis

bool ImagickDraw::polyline ( array $coordinates )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Draws a polyline using the current stroke, stroke width, and fill color or texture, using the specified array of coordinates.

Seznam parametrů

coordinates

array of x and y coordinates: array( array( 'x' => 4, 'y' => 6 ), array( 'x' => 8, 'y' => 10 ) )

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
ImagickDraw::polygon | Domů | ImagickDraw::popClipPath


ImagickDraw::pop

(No version information available, might be only in CVS)

ImagickDraw::pop — Destroys the current ImagickDraw in the stack, and returns to the previously pushed ImagickDraw

Popis

bool ImagickDraw::pop ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Destroys the current ImagickDraw in the stack, and returns to the previously pushed ImagickDraw. Multiple ImagickDraws may exist. It is an error to attempt to pop more ImagickDraws than have been pushed, and it is proper form to pop all ImagickDraws which have been pushed.

Seznam parametrů

Návratové hodnoty

Returns true on success and false on failure.

Předcházející | Nahoru | Další
ImagickDraw::popDefs | Domů | ImagickDraw::popPattern


ImagickDraw::popClipPath

(No version information available, might be only in CVS)

ImagickDraw::popClipPath — Terminates a clip path definition

Popis

bool ImagickDraw::popClipPath ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Terminates a clip path definition.

Seznam parametrů

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::polyline | Domů | ImagickDraw::popDefs


ImagickDraw::popDefs

(No version information available, might be only in CVS)

ImagickDraw::popDefs — Terminates a definition list

Popis

bool ImagickDraw::popDefs ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Terminates a definition list.

Seznam parametrů

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::popClipPath | Domů | ImagickDraw::pop


ImagickDraw::popPattern

(No version information available, might be only in CVS)

ImagickDraw::popPattern — Terminates a pattern definition

Popis

bool ImagickDraw::popPattern ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Terminates a pattern definition.

Seznam parametrů

Návratové hodnoty

Returns true on success and false on failure.

Předcházející | Nahoru | Další
ImagickDraw::pop | Domů | ImagickDraw::pushClipPath


ImagickDraw::push

(No version information available, might be only in CVS)

ImagickDraw::push — Clones the current ImagickDraw and pushes it to the stack

Popis

bool ImagickDraw::push ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Clones the current ImagickDraw to create a new ImagickDraw, which is then added to the ImagickDraw stack. The original drawing ImagickDraw(s) may be returned to by invoking pop(). The ImagickDraws are stored on a ImagickDraw stack. For every Pop there must have already been an equivalent Push.

Seznam parametrů

Návratové hodnoty

Returns true on success and false on failure.

Předcházející | Nahoru | Další
ImagickDraw::pushDefs | Domů | ImagickDraw::pushPattern


ImagickDraw::pushClipPath

(No version information available, might be only in CVS)

ImagickDraw::pushClipPath — Starts a clip path definition

Popis

bool ImagickDraw::pushClipPath ( string $clip_mask_id )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Starts a clip path definition which is comprized of any number of drawing commands and terminated by a ImagickDraw::popClipPath() command.

Seznam parametrů

clip_mask_id

Clip mask Id

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::popPattern | Domů | ImagickDraw::pushDefs


ImagickDraw::pushDefs

(No version information available, might be only in CVS)

ImagickDraw::pushDefs — Indicates that following commands create named elements for early processing

Popis

bool ImagickDraw::pushDefs ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Indicates that commands up to a terminating ImagickDraw::popDefs() command create named elements (e.g. clip-paths, textures, etc.) which may safely be processed earlier for the sake of efficiency.

Seznam parametrů

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::pushClipPath | Domů | ImagickDraw::push


ImagickDraw::pushPattern

(No version information available, might be only in CVS)

ImagickDraw::pushPattern — Indicates that subsequent commands up to a ImagickDraw::opPattern() command comprise the definition of a named pattern

Popis

bool ImagickDraw::pushPattern ( string $pattern_id, float $x, float $y, float $width, float $height )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Indicates that subsequent commands up to a DrawPopPattern() command comprise the definition of a named pattern. The pattern space is assigned top left corner coordinates, a width and height, and becomes its own drawing space. Anything which can be drawn may be used in a pattern definition. Named patterns may be used as stroke or brush definitions.

Seznam parametrů

pattern_id

the pattern Id

x

x coordinate of the top-left corner

y

y coordinate of the top-left corner

width

width of the pattern

height

height of the pattern

Návratové hodnoty

Returns true on success and false on failure.

Předcházející | Nahoru | Další
ImagickDraw::push | Domů | ImagickDraw::rectangle


ImagickDraw::rectangle

(No version information available, might be only in CVS)

ImagickDraw::rectangle — Draws a rectangle

Popis

bool ImagickDraw::rectangle ( float $x1, float $y1, float $x2, float $y2 )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Draws a rectangle given two coordinates and using the current stroke, stroke width, and fill settings.

Seznam parametrů

x1

x coordinate of the top left corner

y1

y coordinate of the top left corner

x2

x coordinate of the bottom right corner

y2

y coordinate of the bottom right corner

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::pushPattern | Domů | ImagickDraw::render


ImagickDraw::render

(No version information available, might be only in CVS)

ImagickDraw::render — Renders all preceding drawing commands onto the image

Popis

bool ImagickDraw::render ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Renders all preceding drawing commands onto the image.

Seznam parametrů

Návratové hodnoty

Returns true on success and false on failure.

Předcházející | Nahoru | Další
ImagickDraw::rectangle | Domů | ImagickDraw::rotate


ImagickDraw::rotate

(No version information available, might be only in CVS)

ImagickDraw::rotate — Applies the specified rotation to the current coordinate space

Popis

bool ImagickDraw::rotate ( float $degrees )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Applies the specified rotation to the current coordinate space.

Seznam parametrů

degrees

degrees to rotate

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::render | Domů | ImagickDraw::roundRectangle


ImagickDraw::roundRectangle

(No version information available, might be only in CVS)

ImagickDraw::roundRectangle — Draws a rounted rectangle

Popis

bool ImagickDraw::roundRectangle ( float $x1, float $y1, float $x2, float $y2, float $rx, float $ry )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Draws a rounted rectangle given two coordinates, x & y corner radiuses and using the current stroke, stroke width, and fill settings.

Seznam parametrů

x1

x coordinate of the top left corner

y1

y coordinate of the top left corner

x2

x coordinate of the bottom right

y2

y coordinate of the bottom right

rx

x rounding

ry

y rounding

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::rotate | Domů | ImagickDraw::scale


ImagickDraw::scale

(No version information available, might be only in CVS)

ImagickDraw::scale — Adjusts the scaling factor

Popis

bool ImagickDraw::scale ( float $x, float $y )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Adjusts the scaling factor to apply in the horizontal and vertical directions to the current coordinate space.

Seznam parametrů

x

horizontal factor

y

vertical factor

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::roundRectangle | Domů | ImagickDraw::setClipPath


ImagickDraw::setClipPath

(No version information available, might be only in CVS)

ImagickDraw::setClipPath — Associates a named clipping path with the image

Popis

bool ImagickDraw::setClipPath ( string $clip_mask )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Associates a named clipping path with the image. Only the areas drawn on by the clipping path will be modified as long as it remains in effect.

Seznam parametrů

clip_mask

the clipping path name

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::scale | Domů | ImagickDraw::setClipRule


ImagickDraw::setClipRule

(No version information available, might be only in CVS)

ImagickDraw::setClipRule — Set the polygon fill rule to be used by the clipping path

Popis

bool ImagickDraw::setClipRule ( int $fill_rule )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Set the polygon fill rule to be used by the clipping path.

Seznam parametrů

fill_rule

FILLRULE_ constant

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::setClipPath | Domů | ImagickDraw::setClipUnits


ImagickDraw::setClipUnits

(No version information available, might be only in CVS)

ImagickDraw::setClipUnits — Sets the interpretation of clip path units

Popis

bool ImagickDraw::setClipUnits ( int $clip_units )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the interpretation of clip path units.

Seznam parametrů

clip_units

the number of clip units

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::setClipRule | Domů | ImagickDraw::setFillAlpha


ImagickDraw::setFillAlpha

(No version information available, might be only in CVS)

ImagickDraw::setFillAlpha — Sets the opacity to use when drawing using the fill color or fill texture

Popis

bool ImagickDraw::setFillAlpha ( float $opacity )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the opacity to use when drawing using the fill color or fill texture. Fully opaque is 1.0.

Seznam parametrů

opacity

fill alpha

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::setClipUnits | Domů | ImagickDraw::setFillColor


ImagickDraw::setFillColor

(No version information available, might be only in CVS)

ImagickDraw::setFillColor — Sets the fill color to be used for drawing filled objects

Popis

bool ImagickDraw::setFillColor ( ImagickPixel $fill_pixel )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the fill color to be used for drawing filled objects.

Seznam parametrů

fill_pixel

ImagickPixel to use to set the color

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::setFillAlpha | Domů | ImagickDraw::setFillOpacity


ImagickDraw::setFillOpacity

(No version information available, might be only in CVS)

ImagickDraw::setFillOpacity — Sets the opacity to use when drawing using the fill color or fill texture

Popis

bool ImagickDraw::setFillOpacity ( float $fillOpacity )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the opacity to use when drawing using the fill color or fill texture. Fully opaque is 1.0.

Seznam parametrů

fillOpacity

the fill opacity

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::setFillColor | Domů | ImagickDraw::setFillPatternURL


ImagickDraw::setFillPatternURL

(No version information available, might be only in CVS)

ImagickDraw::setFillPatternURL — Sets the URL to use as a fill pattern for filling objects

Popis

bool ImagickDraw::setFillPatternURL ( string $fill_url )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the URL to use as a fill pattern for filling objects. Only local URLs ("#identifier") are supported at this time. These local URLs are normally created by defining a named fill pattern with DrawPushPattern/DrawPopPattern.

Seznam parametrů

fill_url

URL to use to obtain fill pattern.

Návratové hodnoty

Returns true on success and false on failure.

Předcházející | Nahoru | Další
ImagickDraw::setFillOpacity | Domů | ImagickDraw::setFillRule


ImagickDraw::setFillRule

(No version information available, might be only in CVS)

ImagickDraw::setFillRule — Sets the fill rule to use while drawing polygons

Popis

bool ImagickDraw::setFillRule ( int $fill_rule )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the fill rule to use while drawing polygons.

Seznam parametrů

fill_rule

FILLRULE_ constant

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::setFillPatternURL | Domů | ImagickDraw::setFontFamily


ImagickDraw::setFont

(No version information available, might be only in CVS)

ImagickDraw::setFont — Sets the fully-specified font to use when annotating with text

Popis

bool ImagickDraw::setFont ( string $font_name )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the fully-specified font to use when annotating with text.

Seznam parametrů

font_name

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
ImagickDraw::setFontWeight | Domů | ImagickDraw::setGravity


ImagickDraw::setFontFamily

(No version information available, might be only in CVS)

ImagickDraw::setFontFamily — Sets the font family to use when annotating with text

Popis

bool ImagickDraw::setFontFamily ( string $font_family )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the font family to use when annotating with text.

Seznam parametrů

font_family

the font family

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
ImagickDraw::setFillRule | Domů | ImagickDraw::setFontSize


ImagickDraw::setFontSize

(No version information available, might be only in CVS)

ImagickDraw::setFontSize — Sets the font pointsize to use when annotating with text

Popis

bool ImagickDraw::setFontSize ( float $pointsize )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the font pointsize to use when annotating with text.

Seznam parametrů

pointsize

the point size

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::setFontFamily | Domů | ImagickDraw::setFontStretch


ImagickDraw::setFontStretch

(No version information available, might be only in CVS)

ImagickDraw::setFontStretch — Sets the font stretch to use when annotating with text

Popis

bool ImagickDraw::setFontStretch ( int $fontStretch )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the font stretch to use when annotating with text. The AnyStretch enumeration acts as a wild-card "don't care" option.

Seznam parametrů

fontStretch

STRETCH_ constant

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::setFontSize | Domů | ImagickDraw::setFontStyle


ImagickDraw::setFontStyle

(No version information available, might be only in CVS)

ImagickDraw::setFontStyle — Sets the font style to use when annotating with text

Popis

bool ImagickDraw::setFontStyle ( int $style )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the font style to use when annotating with text. The AnyStyle enumeration acts as a wild-card "don't care" option.

Seznam parametrů

style

STYLETYPE_ constant

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::setFontStretch | Domů | ImagickDraw::setFontWeight


ImagickDraw::setFontWeight

(No version information available, might be only in CVS)

ImagickDraw::setFontWeight — Sets the font weight

Popis

bool ImagickDraw::setFontWeight ( int $font_weight )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the font weight to use when annotating with text.

Seznam parametrů

font_weight

Návratové hodnoty

Předcházející | Nahoru | Další
ImagickDraw::setFontStyle | Domů | ImagickDraw::setFont


ImagickDraw::setGravity

(No version information available, might be only in CVS)

ImagickDraw::setGravity — Sets the text placement gravity

Popis

bool ImagickDraw::setGravity ( int $gravity )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the text placement gravity to use when annotating with text.

Seznam parametrů

gravity

GRAVITY_ constant

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::setFont | Domů | ImagickDraw::setStrokeAlpha


ImagickDraw::setStrokeAlpha

(No version information available, might be only in CVS)

ImagickDraw::setStrokeAlpha — Specifies the opacity of stroked object outlines

Popis

bool ImagickDraw::setStrokeAlpha ( float $opacity )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Specifies the opacity of stroked object outlines.

Seznam parametrů

opacity

opacity

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::setGravity | Domů | ImagickDraw::setStrokeAntialias


ImagickDraw::setStrokeAntialias

(No version information available, might be only in CVS)

ImagickDraw::setStrokeAntialias — Controls whether stroked outlines are antialiased

Popis

bool ImagickDraw::setStrokeAntialias ( bool $stroke_antialias )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Controls whether stroked outlines are antialiased. Stroked outlines are antialiased by default. When antialiasing is disabled stroked pixels are thresholded to determine if the stroke color or underlying canvas color should be used.

Seznam parametrů

stroke_antialias

the antialias setting

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::setStrokeAlpha | Domů | ImagickDraw::setStrokeColor


ImagickDraw::setStrokeColor

(No version information available, might be only in CVS)

ImagickDraw::setStrokeColor — Sets the color used for stroking object outlines

Popis

bool ImagickDraw::setStrokeColor ( ImagickPixel $stroke_pixel )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the color used for stroking object outlines.

Seznam parametrů

stroke_pixel

the stroke color

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::setStrokeAntialias | Domů | ImagickDraw::setStrokeDashArray


ImagickDraw::setStrokeDashArray

(No version information available, might be only in CVS)

ImagickDraw::setStrokeDashArray — Specifies the pattern of dashes and gaps used to stroke paths

Popis

bool ImagickDraw::setStrokeDashArray ( array $dashArray )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Specifies the pattern of dashes and gaps used to stroke paths. The strokeDashArray represents an array of numbers that specify the lengths of alternating dashes and gaps in pixels. If an odd number of values is provided, then the list of values is repeated to yield an even number of values. To remove an existing dash array, pass a zero number_elements argument and null dash_array. A typical strokeDashArray_ array might contain the members 5 3 2.

Seznam parametrů

dashArray

array of floats

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
ImagickDraw::setStrokeColor | Domů | ImagickDraw::setStrokeDashOffset


ImagickDraw::setStrokeDashOffset

(No version information available, might be only in CVS)

ImagickDraw::setStrokeDashOffset — Specifies the offset into the dash pattern to start the dash

Popis

bool ImagickDraw::setStrokeDashOffset ( float $dash_offset )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Specifies the offset into the dash pattern to start the dash.

Seznam parametrů

dash_offset

dash offset

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::setStrokeDashArray | Domů | ImagickDraw::setStrokeLineCap


ImagickDraw::setStrokeLineCap

(No version information available, might be only in CVS)

ImagickDraw::setStrokeLineCap — Specifies the shape to be used at the end of open subpaths when they are stroked

Popis

bool ImagickDraw::setStrokeLineCap ( int $linecap )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Specifies the shape to be used at the end of open subpaths when they are stroked.

Seznam parametrů

linecap

LINECAP_ constant

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::setStrokeDashOffset | Domů | ImagickDraw::setStrokeLineJoin


ImagickDraw::setStrokeLineJoin

(No version information available, might be only in CVS)

ImagickDraw::setStrokeLineJoin — Specifies the shape to be used at the corners of paths when they are stroked

Popis

bool ImagickDraw::setStrokeLineJoin ( int $linejoin )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Specifies the shape to be used at the corners of paths (or other vector shapes) when they are stroked.

Seznam parametrů

linejoin

LINEJOIN_ constant

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::setStrokeLineCap | Domů | ImagickDraw::setStrokeMiterLimit


ImagickDraw::setStrokeMiterLimit

(No version information available, might be only in CVS)

ImagickDraw::setStrokeMiterLimit — Specifies the miter limit

Popis

bool ImagickDraw::setStrokeMiterLimit ( int $miterlimit )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Specifies the miter limit. When two line segments meet at a sharp angle and miter joins have been specified for 'lineJoin', it is possible for the miter to extend far beyond the thickness of the line stroking the path. The miterLimit' imposes a limit on the ratio of the miter length to the 'lineWidth'.

Seznam parametrů

miterlimit

the miter limit

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::setStrokeLineJoin | Domů | ImagickDraw::setStrokeOpacity


ImagickDraw::setStrokeOpacity

(No version information available, might be only in CVS)

ImagickDraw::setStrokeOpacity — Specifies the opacity of stroked object outlines

Popis

bool ImagickDraw::setStrokeOpacity ( float $stroke_opacity )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Specifies the opacity of stroked object outlines.

Seznam parametrů

stroke_opacity

stroke opacity. 1.0 is fully opaque

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::setStrokeMiterLimit | Domů | ImagickDraw::setStrokePatternURL


ImagickDraw::setStrokePatternURL

(No version information available, might be only in CVS)

ImagickDraw::setStrokePatternURL — Sets the pattern used for stroking object outlines

Popis

bool ImagickDraw::setStrokePatternURL ( string $stroke_url )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the pattern used for stroking object outlines.

Seznam parametrů

stroke_url

stroke URL

Návratové hodnoty

imagick.imagickdraw.return.success;

Předcházející | Nahoru | Další
ImagickDraw::setStrokeOpacity | Domů | ImagickDraw::setStrokeWidth


ImagickDraw::setStrokeWidth

(No version information available, might be only in CVS)

ImagickDraw::setStrokeWidth — Sets the width of the stroke used to draw object outlines

Popis

bool ImagickDraw::setStrokeWidth ( float $stroke_width )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the width of the stroke used to draw object outlines.

Seznam parametrů

stroke_width

stroke width

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::setStrokePatternURL | Domů | ImagickDraw::setTextAlignment


ImagickDraw::setTextAlignment

(No version information available, might be only in CVS)

ImagickDraw::setTextAlignment — Specifies a text alignment

Popis

bool ImagickDraw::setTextAlignment ( int $alignment )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Specifies a text alignment to be applied when annotating with text.

Seznam parametrů

alignment

ALIGN_ constant

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::setStrokeWidth | Domů | ImagickDraw::setTextAntialias


ImagickDraw::setTextAntialias

(No version information available, might be only in CVS)

ImagickDraw::setTextAntialias — Controls whether text is antialiased

Popis

bool ImagickDraw::setTextAntialias ( bool $antiAlias )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Controls whether text is antialiased. Text is antialiased by default.

Seznam parametrů

antiAlias

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::setTextAlignment | Domů | ImagickDraw::setTextDecoration


ImagickDraw::setTextDecoration

(No version information available, might be only in CVS)

ImagickDraw::setTextDecoration — Specifies a decoration

Popis

bool ImagickDraw::setTextDecoration ( int $decoration )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Specifies a decoration to be applied when annotating with text.

Seznam parametrů

decoration

DECORATION_ constant

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::setTextAntialias | Domů | ImagickDraw::setTextEncoding


ImagickDraw::setTextEncoding

(No version information available, might be only in CVS)

ImagickDraw::setTextEncoding — Specifies specifies the text code set

Popis

bool ImagickDraw::setTextEncoding ( string $encoding )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Specifies specifies the code set to use for text annotations. The only character encoding which may be specified at this time is "UTF-8" for representing Unicode as a sequence of bytes. Specify an empty string to set text encoding to the system's default. Successful text annotation using Unicode may require fonts designed to support Unicode.

Seznam parametrů

encoding

the encoding name

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::setTextDecoration | Domů | ImagickDraw::setTextUnderColor


ImagickDraw::setTextUnderColor

(No version information available, might be only in CVS)

ImagickDraw::setTextUnderColor — Specifies the color of a background rectangle

Popis

bool ImagickDraw::setTextUnderColor ( ImagickPixel $under_color )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Specifies the color of a background rectangle to place under text annotations.

Seznam parametrů

under_color

the under color

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::setTextEncoding | Domů | ImagickDraw::setVectorGraphics


ImagickDraw::setVectorGraphics

(No version information available, might be only in CVS)

ImagickDraw::setVectorGraphics — Sets the vector graphics

Popis

bool ImagickDraw::setVectorGraphics ( string $xml )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the vector graphics associated with the specified ImagickDraw object. Use this method with ImagickDraw::getVectorGraphics() as a method to persist the vector graphics state.

Seznam parametrů

xml

xml containing the vector graphics

Návratové hodnoty

Returns true on success and false on failure.

Předcházející | Nahoru | Další
ImagickDraw::setTextUnderColor | Domů | ImagickDraw::setViewbox


ImagickDraw::setViewbox

(No version information available, might be only in CVS)

ImagickDraw::setViewbox — Sets the overall canvas size

Popis

bool ImagickDraw::setViewbox ( int $x1, int $y1, int $x2, int $y2 )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the overall canvas size to be recorded with the drawing vector data. Usually this will be specified using the same size as the canvas image. When the vector data is saved to SVG or MVG formats, the viewbox is use to specify the size of the canvas image that a viewer will render the vector data on.

Seznam parametrů

x1

left x coordinate

y1

left y coordinate

x2

right x coordinate

y2

right y coordinate

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::setVectorGraphics | Domů | ImagickDraw::skewX


ImagickDraw::skewX

(No version information available, might be only in CVS)

ImagickDraw::skewX — Skews the current coordinate system in the horizontal direction

Popis

bool ImagickDraw::skewX ( float $degrees )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Skews the current coordinate system in the horizontal direction.

Seznam parametrů

degrees

degrees to skew

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::setViewbox | Domů | ImagickDraw::skewY


ImagickDraw::skewY

(No version information available, might be only in CVS)

ImagickDraw::skewY — Skews the current coordinate system in the vertical direction

Popis

bool ImagickDraw::skewY ( float $degrees )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Skews the current coordinate system in the vertical direction.

Seznam parametrů

degrees

degrees to skew

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::skewX | Domů | ImagickDraw::translate


ImagickDraw::translate

(No version information available, might be only in CVS)

ImagickDraw::translate — Applies a translation to the current coordinate system

Popis

bool ImagickDraw::translate ( float $x, float $y )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Applies a translation to the current coordinate system which moves the coordinate system origin to the specified coordinate.

Seznam parametrů

x

horizontal translation

y

vertical translation

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ImagickDraw::skewY | Domů | ImagickPixel::clear


ImagickPixel::clear

(No version information available, might be only in CVS)

ImagickPixel::clear — Clears resources associated with this object

Popis

bool ImagickPixel::clear ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Clears the ImagickPixel object, leaving it in a fresh state. This also unsets any color associated with the object.

Seznam parametrů

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
ImagickDraw::translate | Domů | ImagickPixel::__construct


ImagickPixel::__construct

(No version information available, might be only in CVS)

ImagickPixel::__construct — The ImagickPixel constructor

Popis

ImagickPixel ImagickPixel::__construct ( [string $color] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Constructs an ImagickPixel object. If a color is specified, the object is constructed and then initialised with that color before being returned.

Seznam parametrů

color

The optional color string to use as the initial value of this object.

Návratové hodnoty

Returns an ImagickPixel object on success, throwing ImagickPixelException on failure.

Předcházející | Nahoru | Další
ImagickPixel::clear | Domů | ImagickPixel::destroy


ImagickPixel::destroy

(No version information available, might be only in CVS)

ImagickPixel::destroy — Deallocates resources associated with this object

Popis

bool ImagickPixel::destroy ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Deallocates any resources used by the ImagickPixel object, and unsets any associated color. The object should not be used after the destroy function has been called.

Seznam parametrů

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
ImagickPixel::__construct | Domů | ImagickPixel::getColor


ImagickPixel::getColor

(No version information available, might be only in CVS)

ImagickPixel::getColor — Returns the color

Popis

array ImagickPixel::getColor ( [bool $normalized] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the color described by the ImagickPixel object, as an array. If the color has an opacity channel set, this is provided as a fourth value in the list.

Seznam parametrů

normalized

Normalize the color values

Návratové hodnoty

An array of channel values, each normalized if true is given as param. Throws ImagickPixelException on error.

Předcházející | Nahoru | Další
ImagickPixel::destroy | Domů | ImagickPixel::getColorCount


ImagickPixel::getColorCount

(No version information available, might be only in CVS)

ImagickPixel::getColorCount — Returns the color count associated with this color

Popis

int ImagickPixel::getColorCount ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the color count associated with this color.

Seznam parametrů

Návratové hodnoty

Returns the color count as an integer on success, throws ImagickPixelException on failure.

Předcházející | Nahoru | Další
ImagickPixel::getColor | Domů | ImagickPixel::getColorValue


ImagickPixel::getColorValue

(No version information available, might be only in CVS)

ImagickPixel::getColorValue — Gets the normalized value of the provided color channel

Popis

float ImagickPixel::getColorValue ( int $color )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Retrieves the value of the color channel specified, as a floating-point number between 0 and 1.

Seznam parametrů

color

The channel to check, specified as one of the Imagick channel constants.

Návratové hodnoty

The value of the channel, as a normalized floating-point number, throwing ImagickPixelException on error.

Předcházející | Nahoru | Další
ImagickPixel::getColorCount | Domů | ImagickPixel::getHSL


ImagickPixel::getHSL

(No version information available, might be only in CVS)

ImagickPixel::getHSL — Returns the normalized HSL color of the ImagickPixel object

Popis

array ImagickPixel::getHSL ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the normalized HSL color described by the ImagickPixel object, with each of the three values as floating point numbers between 0.0 and 1.0.

Seznam parametrů

Návratové hodnoty

Returns the HSL value in an array with the keys "hue", "saturation", and "luminosity". Throws ImagickPixelException on failure.

Předcházející | Nahoru | Další
ImagickPixel::getColorValue | Domů | ImagickPixel::isSimilar


ImagickPixel::isSimilar

(No version information available, might be only in CVS)

ImagickPixel::isSimilar — Check the distance between this color and another

Popis

bool ImagickPixel::isSimilar ( ImagickPixel $color, float $fuzz )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Checks the distance between the color described by this ImagickPixel object and that of the provided object, by plotting their RGB values on the color cube. If the distance between the two points is less than the fuzz value given, the colors are similar.

Seznam parametrů

color

The ImagickPixel object to compare this object against.

fuzz

The maximum distance within which to consider these colors as similar. The theoretical maximum for this value is the square root of three (1.732).

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
ImagickPixel::getHSL | Domů | ImagickPixel::setColorValue


ImagickPixel::setColor

(No version information available, might be only in CVS)

ImagickPixel::setColor — Sets the color

Popis

bool ImagickPixel::setColor ( string $color )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the color described by the ImagickPixel object, with a string (e.g. "blue", "#0000ff", "rgb(0,0,255)", "cmyk(100,100,100,10)", etc.).

Seznam parametrů

color

The color definition to use in order to initialise the ImagickPixel object.

Návratové hodnoty

Returns true if the specified color was set, false otherwise.

Předcházející | Nahoru | Další
ImagickPixel::setColorValue | Domů | ImagickPixel::setHSL


ImagickPixel::setColorValue

(No version information available, might be only in CVS)

ImagickPixel::setColorValue — Sets the normalized value of one of the channels

Popis

bool ImagickPixel::setColorValue ( int $color, float $value )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the value of the specified channel of this object to the provided value, which should be between 0 and 1. This function can be used to provide an opacity channel to an ImagickPixel object.

Seznam parametrů

color

One of the Imagick channel color constants.

value

The value to set this channel to, ranging from 0 to 1.

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
ImagickPixel::isSimilar | Domů | ImagickPixel::setColor


ImagickPixel::setHSL

(No version information available, might be only in CVS)

ImagickPixel::setHSL — Sets the normalized HSL color

Popis

bool ImagickPixel::setHSL ( float $hue, float $saturation, float $luminosity )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the color described by the ImagickPixel object using normalized values for hue, saturation and luminosity.

Seznam parametrů

hue

The normalized value for hue, described as a fractional arc (between 0 and 1) of the hue circle, where the zero value is red.

saturation

The normalized value for saturation, with 1 as full saturation.

luminosity

The normalized value for luminosity, on a scale from black at 0 to white at 1, with the full HS value at 0.5 luminosity.

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
ImagickPixel::setColor | Domů | ImagickPixelIterator::clear


ImagickPixelIterator::clear

(No version information available, might be only in CVS)

ImagickPixelIterator::clear — Clear resources associated with a PixelIterator

Popis

bool ImagickPixelIterator::clear ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Clear resources associated with a PixelIterator.

Seznam parametrů

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
ImagickPixel::setHSL | Domů | ImagickPixelIterator::__construct


ImagickPixelIterator::__construct

(No version information available, might be only in CVS)

ImagickPixelIterator::__construct — The ImagickPixelIterator constructor

Popis

ImagickPixelIterator ImagickPixelIterator::__construct ( Imagick $wand )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

The ImagickPixelIterator constructor

Seznam parametrů

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
ImagickPixelIterator::clear | Domů | ImagickPixelIterator::destroy


ImagickPixelIterator::destroy

(No version information available, might be only in CVS)

ImagickPixelIterator::destroy — Deallocates resources associated with a PixelIterator

Popis

bool ImagickPixelIterator::destroy ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Deallocates resources associated with a PixelIterator.

Seznam parametrů

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
ImagickPixelIterator::__construct | Domů | ImagickPixelIterator::getCurrentIteratorRow


ImagickPixelIterator::getCurrentIteratorRow

(No version information available, might be only in CVS)

ImagickPixelIterator::getCurrentIteratorRow — Returns the current row of ImagickPixel objects

Popis

array ImagickPixelIterator::getCurrentIteratorRow ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the current row as an array of ImagickPixel objects from the pixel iterator.

Seznam parametrů

Návratové hodnoty

Returns a row as an array of ImagickPixel objects that can themselves be iterated.

Předcházející | Nahoru | Další
ImagickPixelIterator::destroy | Domů | ImagickPixelIterator::getIteratorRow


ImagickPixelIterator::getIteratorRow

(No version information available, might be only in CVS)

ImagickPixelIterator::getIteratorRow — Returns the current pixel iterator row

Popis

int ImagickPixelIterator::getIteratorRow ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the current pixel iterator row.

Seznam parametrů

Návratové hodnoty

Returns the integer offset of the row, throwing ImagickPixelIteratorException on error.

Předcházející | Nahoru | Další
ImagickPixelIterator::getCurrentIteratorRow | Domů | ImagickPixelIterator::getNextIteratorRow


ImagickPixelIterator::getNextIteratorRow

(No version information available, might be only in CVS)

ImagickPixelIterator::getNextIteratorRow — Returns the next row of the pixel iterator

Popis

array ImagickPixelIterator::getNextIteratorRow ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the next row as an array of pixel wands from the pixel iterator.

Seznam parametrů

Návratové hodnoty

Returns ana row as an array of ImagickPixel objects, throwing ImagickPixelIteratorException on error.

Předcházející | Nahoru | Další
ImagickPixelIterator::getIteratorRow | Domů | ImagickPixelIterator::getPreviousIteratorRow


ImagickPixelIterator::getPreviousIteratorRow

(No version information available, might be only in CVS)

ImagickPixelIterator::getPreviousIteratorRow — Returns the previous row

Popis

array ImagickPixelIterator::getPreviousIteratorRow ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the previous row as an array of pixel wands from the pixel iterator.

Seznam parametrů

Návratové hodnoty

Returns the previous row as an array of ImagickPixelWand objects from the ImagickPixelIterator, throwing ImagickPixelIteratorException on error.

Předcházející | Nahoru | Další
ImagickPixelIterator::getNextIteratorRow | Domů | ImagickPixelIterator::newPixelIterator


ImagickPixelIterator::newPixelIterator

(No version information available, might be only in CVS)

ImagickPixelIterator::newPixelIterator — Returns a new pixel iterator

Popis

bool ImagickPixelIterator::newPixelIterator ( Imagick $wand )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns a new pixel iterator.

Seznam parametrů

Návratové hodnoty

Returns TRUE on success. Throwing ImagickPixelIteratorException.

Předcházející | Nahoru | Další
ImagickPixelIterator::getPreviousIteratorRow | Domů | ImagickPixelIterator::newPixelRegionIterator


ImagickPixelIterator::newPixelRegionIterator

(No version information available, might be only in CVS)

ImagickPixelIterator::newPixelRegionIterator — Returns a new pixel iterator

Popis

bool ImagickPixelIterator::newPixelRegionIterator ( Imagick $wand, int $x, int $y, int $columns, int $rows )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns a new pixel iterator.

Seznam parametrů

wand

x

y

columns

rows

Návratové hodnoty

Returns a new ImagickPixelIterator on success; on failure, throws ImagickPixelIteratorException.

Předcházející | Nahoru | Další
ImagickPixelIterator::newPixelIterator | Domů | ImagickPixelIterator::resetIterator


ImagickPixelIterator::resetIterator

(No version information available, might be only in CVS)

ImagickPixelIterator::resetIterator — Resets the pixel iterator

Popis

bool ImagickPixelIterator::resetIterator ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Resets the pixel iterator. Use it in conjunction with ImagickPixelIterator::getNextIteratorRow() to iterate over all the pixels in a pixel container.

Seznam parametrů

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
ImagickPixelIterator::newPixelRegionIterator | Domů | ImagickPixelIterator::setIteratorFirstRow


ImagickPixelIterator::setIteratorFirstRow

(No version information available, might be only in CVS)

ImagickPixelIterator::setIteratorFirstRow — Sets the pixel iterator to the first pixel row

Popis

bool ImagickPixelIterator::setIteratorFirstRow ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the pixel iterator to the first pixel row.

Seznam parametrů

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
ImagickPixelIterator::resetIterator | Domů | ImagickPixelIterator::setIteratorLastRow


ImagickPixelIterator::setIteratorLastRow

(No version information available, might be only in CVS)

ImagickPixelIterator::setIteratorLastRow — Sets the pixel iterator to the last pixel row

Popis

bool ImagickPixelIterator::setIteratorLastRow ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Sets the pixel iterator to the last pixel row.

Seznam parametrů

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
ImagickPixelIterator::setIteratorFirstRow | Domů | ImagickPixelIterator::setIteratorRow


ImagickPixelIterator::setIteratorRow

(No version information available, might be only in CVS)

ImagickPixelIterator::setIteratorRow — Set the pixel iterator row

Popis

bool ImagickPixelIterator::setIteratorRow ( int $row )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Set the pixel iterator row.

Seznam parametrů

row

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
ImagickPixelIterator::setIteratorLastRow | Domů | ImagickPixelIterator::syncIterator


ImagickPixelIterator::syncIterator

(No version information available, might be only in CVS)

ImagickPixelIterator::syncIterator — Syncs the pixel iterator

Popis

bool ImagickPixelIterator::syncIterator ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Syncs the pixel iterator.

Seznam parametrů

Návratové hodnoty

Returns TRUE on success.

Předcházející | Nahoru | Další
ImagickPixelIterator::setIteratorRow | Domů | LXVII. IMAP, POP3 and NNTP Functions


imap_savebody

(PHP 5 >= 5.1.3)

imap_savebody — Save a specific body section to a file

Popis

bool imap_savebody ( resource $imap_stream, mixed $file, int $msg_number [, string $part_number [, int $options]] )

Saves a part or the whole body of the specified message.

Seznam parametrů

imap_stream

An IMAP stream returned by imap_open().

file

The path to the saved file as a string, or a valid file descriptor returned by fopen().

msg_number

The message number

part_number

The part number. It is a string of integers delimited by period which index into a body part list as per the IMAP4 specification

options

A bitmask with one or more of the following:

  • FT_UID - The msg_number is a UID
  • FT_PEEK - Do not set the \Seen flag if not already set
  • FT_INTERNAL - The return string is in internal format, will not canonicalize to CRLF.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

imap_fetchbody()

Předcházející | Nahoru | Další
imap_rfc822_write_address | Domů | imap_scanmailbox


include

Předcházející 16. Řídicí struktury Další

include()

Příkaz include() vloží a ohodnotí specifikovaný soubor.

Níže popsané platí i pro require(). Tyto dva příkazy jsou zcela totožné, kromě toho, jak zpracovávají chyby. include() produkuje Warning (varování), zatímco require() skončí s chybou typu Fatal Error. Jinými slovy, require() použijte tehdy, chcete-li, aby se při chybějícím souboru zastavilo zpracovávání. include() se tak nechová, skript bude nerušeně pokračovat. Ujistěte se také, že máte v pořádku nastavení include_path.

Pokud se vloží soubor, potom kód v něm obsažený dědí kontext proměnné řádku, kde byl vložen. Všechny proměnné dostupné na tomto řádku volajícího souboru budou (od této chvíle) dostupné i ve volaném souboru.

Příklad 16.3. Základní příklad -- include()

vars.php
<?php

$color = 'zelené';
$fruit = 'jablko';

?>

test.php
<?php

echo "Vidím $color $fruit"; // Vidím

include 'vars.php';

echo "Vidím $color $fruit"; // Vidím zelené jablko

?>

Pokud ke vložení dojde uvnitř funkce ve volajícím souboru, potom se všechen kód obsažený ve volaném souboru bude chovat, jako by byl definován uvnitř této funkce -- tedy v rámci kontextu proměnných funkce.

Příklad 16.4. Vkládání uvnitř funkcí

<?php

function foo()
{
global $color;

    include 'vars.php';

    echo "Vidím $color $fruit";
}

/* vars.php je v kontextu foo(), takže      *
 * $fruit NENÍ dostupná mimo tento kontext. *
 * Naopak $color JE, protože je deklarována *
 * jako globální.                           */

foo();                        // Vidím zelené jablko
echo "Vidím $color $fruit";   // Vidím zelené

?>

Při vkládání souboru přejde parsing na začátku souboru z PHP režimu do módu HTML a na jeho konci se vrací zpět do módu PHP. Z tohoho důvodu musí být prováděný PHP kód ve vkládaném souboru uzavřen mezi platnou počáteční a koncovou PHP značku.

Pokud jsou v PHP povoleny "URL fopen wrappery" (což tak implicitně je), můžete specifikovat soubor ke vložení pomocí URL (přes HTTP) namísto lokálního umístění. Pokud přískušný server interpretuje požadovaný soubor jako PHP kód, proměnné mohou být odkazovány pomocí řetězce URL požadavku jako u HTTP GET. Není to úplně totéž jako vložení souboru s děděním kontextu proměnných od rodičovského souboru; skript běží na vzdáleném serveru a výsledek se potom vloží do lokálního skriptu.

Příklad 16.5. include() přes HTTP

<?php

/* Tento příklad předpokládá, že www.example.com je konfigurován k parsování *
 * souborů .php a nikoli souborů .txt. Tedy, 'funguje' zde znamená, že       *
 * proměnné $foo a $bar jsou dostupné uvnitř vkládaného souboru.             */

// Nefunguje; file.txt nebyl na www.example.com zpracován jako PHP
include 'http://www.example.com/file.txt?foo=1&bar=2';

// Nefunguje; hledá soubor 'file.php?foo=1&bar=2' v lokálním systému souborů.
include 'file.php?foo=1&bar=2';

// Funguje.
include 'http://www.example.com/file.php?foo=1&bar=2';

$foo = 1;
$bar = 2;
include 'file.txt';  // Funguje.
include 'file.php';  // Funguje.

?>

Související informace -- viz také Vzdálené soubory, fopen() a file().

Protože include() a require() jsou speciální jazykové příkazy, pokud se provádějí podmíněně, musíte je uzavřít do bloku.

Příklad 16.6. include() a podmíněné bloky

<?php

// Toto je ŠPATNĚ a (jak bylo řečeno) nebude to fungovat.
if ($condition)
    include $file;
else
    include $other;

// Tohle je SPRÁVNĚ.
if ($condition) {
    include $file;
} else {
    include $other;
}

?>

Obsluha návratů: Uvnitř vkládaného souboru lze provést příkaz return() k ukončení provádění souboru a návrat do volajícího skriptu. Je tedy možné z vložených souborů vracet hodnoty. Můžete vzít hodnotu volání include, jako by to byla normální funkce.

Poznámka: V PHP 3 se return nesmí objevit uvnitř bloku, pokud to není funkční blok; tehdy však se však return() týká této funkce a ne celého souboru.

Příklad 16.7. include() a příkaz return()

return.php
<?php

$var = 'PHP';

return $var;

?>

noreturn.php
<?php

$var = 'PHP';

?>

testreturns.php
<?php

$foo = include 'return.php';

echo $foo; // vypíše 'PHP'

$bar = include 'noreturn.php';

echo $bar; // vypíše 1

?>

$bar má hodnotu 1, protože příkaz include byl úspěšný. Všimněte si rozdílu mezi výše uvedenými příklady. První používá ve vkládaném souboru return(), druhý nikoli. Dalšími způsoby, jak přiřadit hodnotu souboru do proměnné, jsou funkce fopen(), file() a použití include() společně s funkcemi řízení výstupu.

Viz také require(), require_once(),
include_once(), readfile(),
virtual(), a
include_path.

Předcházející | Nahoru | Další
require | Domů | require_once


include_once

Předcházející 16. Řídicí struktury Další

include_once()

Příkaz include_once() vloží a ohodnotí specifikovaný soubor během provádění skriptu. Chová se tedy podobně jako include() , s tím rozdílem, že pokud už byl kód ze souboru dříve vložen do skriptu, nebude znovu vkládán. Jak název napovídá, bude vložen právě jednou.

Příkaz include_once() by se měl používat v případech, kde by mohl být během provádění skriptu tentýž soubor vložen a ohodnocen víckrát, a přitom chcete zajistit právě jedno vložení (je třeba se vyhnout redefinicím funkcí, novému přiřazení hodnot atd.).

Příklady na použití require_once() and include_once() najdete v kódu » PEAR přiloženém v nejnovějších distribucích zdrojových kódů PHP.

Poznámka: Příkaz include_once() byl přidán v PHP 4.0.1pl2.

Viz také include(),
require(), require_once(),
get_required_files(),
get_included_files(), readfile(),
a virtual().

Předcházející | Nahoru | Další
require_once | Domů | 17. Funkce


ingres_cursor

(PECL ingres:1.1-1.4.3)

ingres_cursor — Gets a cursor name for a given link resource

Popis

string ingres_cursor ( [resource $link] )

Returns an string containing the active cursor name. If no cursor is active then NULL is returned.

If a link resource is passed to ingres_cursor() it returns the cursor name recorded for the link. If no link is passed then ingres_cursor() returns the cursor name asssociated with the default link.

Seznam parametrů

link

The connection link identifier. If not specified, the last opened link is used.

Návratové hodnoty

Returns an string containing the active cursor name. If no cursor is active then NULL is returned.

Příklady

Příklad 936. ingres_cursor() example

<?php
$link = ingres_connect($database, $user, $password);

ingres_prepare("select * from table", $link);

$cursor_name = ingres_cursor($link);

echo $cursor_name;

?>

Viz také

ingres_prepare()
ingres_execute()

Předcházející | Nahoru | Další
ingres_connect | Domů | ingres_errno


ingres_errno

(PECL ingres:1.1-1.4.3)

ingres_errno — Gets the last ingres error number generated

Popis

int ingres_errno ( [resource $link] )

Returns an integer containing the last error number. If no error was reported 0 is returned.

If a link resource is passed to ingres_errno() it returns the last error recorded for the link. If no link is passed then ingres_errno() returns the last error reported using the default link.

The function, ingres_errno(), should always be called after executing a database query. Calling another function before ingres_errno() is called, will reset or change any error code from the last Ingres function call.

Seznam parametrů

link

The connection link identifier. If not specified, the last opened link is used.

Návratové hodnoty

Returns an integer containing the last error number. If no error was reported 0 is returned.

Příklady

Příklad 937. ingres_errno() example

<?php
$link = ingres_connect($database, $user, $password);

ingres_query("select * from table", $link);

$error_code = ingres_errno($link);

if ( $error_code != 0 ) {
   echo "An error occured - " . $error_code;
}
?>

Viz také

ingres_error()
ingres_errsqlstate()

Předcházející | Nahoru | Další
ingres_cursor | Domů | ingres_error


ingres_error

(PECL ingres:1.1-1.4.3)

ingres_error — Gets a meaningful error message for the last error generated

Popis

string ingres_error ( [resource $link] )

Returns a string containing the last error, or NULL if no error has occurred.

If a link resource is passed to ingres_error() it returns the last error recorded for the link. If no link is passed then ingres_error() returns the last error reported using the default link.

The function, ingres_error(), should always be called after executing any database query. Calling another function before ingres_error() is called will reset or change any error message from the last Ingres function call.

Seznam parametrů

link

The connection link identifier. If not specified, the last opened link is used.

Návratové hodnoty

Returns a string containing the last error, or NULL if no error has occurred.

Příklady

Příklad 938. ingres_error() example

<?php
ingres_connect($database, $user, $password);

ingres_query("select * from table");

$error_text = ingres_error();

if (!is_null($error_text)) {
   echo "An error occured - " . $error_text;
}
?>

Viz také

ingres_errno()
ingres_errsqlstate()

Předcházející | Nahoru | Další
ingres_errno | Domů | ingres_errsqlstate


ingres_errsqlstate

(PECL ingres:1.1-1.4.3)

ingres_errsqlstate — Gets the last SQLSTATE error code generated

Popis

string ingres_errsqlstate ( [resource $link] )

Returns a string containing the last SQLSTATE, or NULL if no error has occurred.

If a link resource is passed to ingres_errsqlstate() it returns the last error recorded for the link. If no link is passed then ingres_errsqlstate() returns the last error reported using the default link.

The function, ingres_errsqlstate(), should always be called after executing any database query. Calling another function before ingres_errsqlstate() is called will reset or change any error message from the last Ingres function call.

Seznam parametrů

link

The connection link identifier. If not specified, the last opened link is used.

Návratové hodnoty

Returns a string containing the last SQLSTATE, or NULL if no error has occurred.

Příklady

Příklad 939. ingres_errsqlstate() example

<?php
ingres_connect($database, $user, $password);

ingres_query("select * from table");

$error_sqlstate = ingres_errsqlstate();

if (!is_null($error_sqlstate)) {
   echo "An error occured - " . $error_sqlstate;
}
?>

Viz také

ingres_errno()
ingres_error()

Předcházející | Nahoru | Další
ingres_error | Domů | ingres_fetch_array


is_binary

(No version information available, might be only in CVS)

is_binary — Finds whether a variable is a native binary string

Popis

bool is_binary ( mixed $var )

Finds whether the given variable is a native binary string.

Seznam parametrů

var

The variable being evaluated.

Návratové hodnoty

Returns TRUE if var is a native binary string, FALSE otherwise.

Viz také

is_buffer()
is_string()
is_unicode()

Předcházející | Nahoru | Další
is_array | Domů | is_bool


is_buffer

(No version information available, might be only in CVS)

is_buffer — Finds whether a variable is a native unicode or binary string

Popis

bool is_buffer ( mixed $var )

Finds whether the given variable is a native unicode or binary string.

Seznam parametrů

var

The variable being evaluated.

Návratové hodnoty

Returns TRUE if var is a native unicode or binary string, FALSE otherwise.

Viz také

is_binary()
is_string()
is_unicode()

Předcházející | Nahoru | Další
is_bool | Domů | is_callable


is_unicode

(No version information available, might be only in CVS)

is_unicode — Finds whether a variable is a unicode string

Popis

bool is_unicode ( mixed $var )

Finds whether the given variable is a unicode string.

Seznam parametrů

var

The variable being evaluated.

Návratové hodnoty

Returns TRUE if var is a unicode string, FALSE otherwise.

Viz také

is_binary()
is_buffer()
is_string()
unicode_encode()

Předcházející | Nahoru | Další
is_string | Domů | isset


json_decode

(PHP 5 >= 5.2.0, PECL json:1.2.0-1.2.1)

json_decode — Decodes a JSON string

Popis

mixed json_decode ( string $json [, bool $assoc] )

Takes a JSON encoded string and converts it into a PHP variable.

Seznam parametrů

json

The json string being decoded.

assoc

When TRUE, returned objects will be converted into associative arrays.

Návratové hodnoty

Returns an object or if the optional assoc parameter is TRUE, an associative array is instead returned.

Příklady

Příklad 949. json_decode() examples

<?php
$json = '{"a":1,"b":2,"c":3,"d":4,"e":5}';

var_dump(json_decode($json));
var_dump(json_decode($json, true));

?>

Výše uvedený příklad vypíše:

object(stdClass)#1 (5) {
    ["a"] => int(1)
    ["b"] => int(2)
    ["c"] => int(3)
    ["d"] => int(4)
    ["e"] => int(5)
}

array(5) {
    ["a"] => int(1)
    ["b"] => int(2)
    ["c"] => int(3)
    ["d"] => int(4)
    ["e"] => int(5)
}

Poznámky

Výstraha

This function will return false if the JSON encoded data is deeper than 127 elements.

ChangeLog (záznam změn)

Verze | Popis
5.2.3 | The nesting limit was increased from 20 to 128

Viz také

json_encode()

Předcházející | Nahoru | Další
LXXIII. JSON Functions | Domů | json_encode


json_encode

(PHP 5 >= 5.2.0, PECL json:1.2.0-1.2.1)

json_encode — Returns the JSON representation of a value

Popis

string json_encode ( mixed $value )

Returns a string containing the JSON representation of value.

Seznam parametrů

value

The value being encoded. Can be any type except a resource.

This function only works with UTF-8 encoded data.

Návratové hodnoty

Returns a JSON encoded string on success.

ChangeLog (záznam změn)

Verze | Popis
5.2.1 | Added support to JSON encode basic types

Příklady

Příklad 950. A json_encode() example

<?php
$arr = array ('a'=>1,'b'=>2,'c'=>3,'d'=>4,'e'=>5);

echo json_encode($arr);
?>

Výše uvedený příklad vypíše:

{"a":1,"b":2,"c":3,"d":4,"e":5}

Viz také

json_decode()

Předcházející | Nahoru | Další
json_decode | Domů | LXXIV. KADM5


kadm5_chpass_principal

(PECL kadm5:0.2.3)

kadm5_chpass_principal — Changes the principal's password

Popis

bool kadm5_chpass_principal ( resource $handle, string $principal, string $password )

kadm5_chpass_principal() sets the new password password for the principal.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 952. Example of changing principal's password

<?php

$handle = kadm5_init_with_password("afs-1", "GONICUS.LOCAL", "admin/admin", "password");

kadm5_chpass_principal($handle, "burbach@GONICUS.LOCAL", "newpassword");

kadm5_destroy($handle);
?>

Předcházející | Nahoru | Další
LXXIV. KADM5 | Domů | kadm5_create_principal


kadm5_create_principal

(PECL kadm5:0.2.3)

kadm5_create_principal — Creates a kerberos principal with the given parameters

Popis

bool kadm5_create_principal ( resource $handle, string $principal [, string $password [, array $options]] )

kadm5_create_principal() creates a principal with the given password. If password is omitted or is NULL, a random key will be generated.

It is possible to specify several optional parameters within the array options. Allowed are the following options: KADM5_PRINC_EXPIRE_TIME, KADM5_PW_EXPIRATION, KADM5_ATTRIBUTES, KADM5_MAX_LIFE, KADM5_KVNO, KADM5_POLICY, KADM5_CLEARPOLICY, KADM5_MAX_RLIFE.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 953. Example of principal's creation

<?php

$handle = kadm5_init_with_password("afs-1", "GONICUS.LOCAL", "admin/admin", "password");

$attributes = KRB5_KDB_REQUIRES_PRE_AUTH | KRB5_KDB_DISALLOW_PROXIABLE;
$options = array(KADM5_PRINC_EXPIRE_TIME => 0,
                 KADM5_POLICY => "default",
                 KADM5_ATTRIBUTES => $attributes);

kadm5_create_principal($handle, "burbach@GONICUS.LOCAL", "password", $options);

kadm5_destroy($handle);
?>

Předcházející | Nahoru | Další
kadm5_chpass_principal | Domů | kadm5_delete_principal


kadm5_delete_principal

(PECL kadm5:0.2.3)

kadm5_delete_principal — Deletes a kerberos principal

Popis

bool kadm5_delete_principal ( resource $handle, string $principal )

kadm5_delete_principal() remove the principal from the Kerberos database.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 954. kadm5_delete_principal() example

<?php

$handle = kadm5_init_with_password("afs-1", "GONICUS.LOCAL", "admin/admin", "password");

kadm5_delete_principal($handle, "burbach@GONICUS.LOCAL");

kadm5_destroy($handle);
?>

Předcházející | Nahoru | Další
kadm5_create_principal | Domů | kadm5_destroy


kadm5_destroy

(PECL kadm5:0.2.3)

kadm5_destroy — Closes the connection to the admin server and releases all related resources

Popis

bool kadm5_destroy ( resource $handle )

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
kadm5_delete_principal | Domů | kadm5_flush


kadm5_flush

(PECL kadm5:0.2.3)

kadm5_flush — Flush all changes to the Kerberos database, leaving the connection to the Kerberos admin server open

Popis

bool kadm5_flush ( resource $handle )

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
kadm5_destroy | Domů | kadm5_get_policies


kadm5_get_policies

(PECL kadm5:0.2.3)

kadm5_get_policies — Gets all policies from the Kerberos database

Popis

array kadm5_get_policies ( resource $handle )

kadm5_get_policies() returns an array containing the policies's names.

Návratové hodnoty

Returns array of policies on success, or FALSE on failure.

Příklady

Příklad 955. kadm5_get_policies() example

<?php
$handle = kadm5_init_with_password("afs-1", "GONICUS.LOCAL", "admin/admin", "password");

print "<h1>get_policies</h1>\n";
foreach (kadm5_get_policies($handle) as $policy) {
    echo "$policy<br />\n";
}

kadm5_destroy($handle);
?>

Předcházející | Nahoru | Další
kadm5_flush | Domů | kadm5_get_principal


kadm5_get_principal

(PECL kadm5:0.2.3)

kadm5_get_principal — Gets the principal's entries from the Kerberos database

Popis

array kadm5_get_principal ( resource $handle, string $principal )

kadm5_get_principal() returns an associative array containing the following keys: KADM5_PRINCIPAL, KADM5_PRINC_EXPIRE_TIME, KADM5_PW_EXPIRATION, KADM5_ATTRIBUTES, KADM5_MAX_LIFE, KADM5_MOD_NAME, KADM5_MOD_TIME, KADM5_KVNO, KADM5_POLICY, KADM5_MAX_RLIFE, KADM5_LAST_SUCCESS, KADM5_LAST_FAILED, KADM5_FAIL_AUTH_COUNT.

Návratové hodnoty

Returns array of options on success, or FALSE on failure.

Příklady

Příklad 956. kadm5_get_principal() example

<?php
$handle = kadm5_init_with_password("afs-1", "GONICUS.LOCAL", "admin/admin", "password");

print "<h1>get_principal burbach@GONICUS.LOCAL</h1>\n";

$options = kadm5_get_principal($handle, "burbach@GONICUS.LOCAL" );

foreach ($options as $key => $value) {
    echo "$key: $value<br />\n";
}

kadm5_destroy($handle);
?>

Předcházející | Nahoru | Další
kadm5_get_policies | Domů | kadm5_get_principals


kadm5_get_principals

(PECL kadm5:0.2.3)

kadm5_get_principals — Gets all principals from the Kerberos database

Popis

array kadm5_get_principals ( resource $handle )

kadm5_get_principals() returns an array containing the principals's names.

Návratové hodnoty

Returns array of principals on success, or FALSE on failure.

Příklady

Příklad 957. kadm5_get_principals() example

<?php
$handle = kadm5_init_with_password("afs-1", "GONICUS.LOCAL", "admin/admin", "password");

print "<h1>get_principals</h1>\n";
foreach (kadm5_get_principals($handle) as $principal) {
    echo "$principal<br />\n";
}

kadm5_destroy($handle);
?>

Předcházející | Nahoru | Další
kadm5_get_principal | Domů | kadm5_init_with_password


kadm5_init_with_password

(PECL kadm5:0.2.3)

kadm5_init_with_password — Opens a connection to the KADM5 library and initializes any neccessary state information

Popis

resource kadm5_init_with_password ( string $admin_server, string $realm, string $principal, string $password )

kadm5_init_with_password() opens a connection with the KADM5 library using the principal and the given password to obtain initial credentials from the admin_server. The parameter realm defines the authentication domain for the connection.

Návratové hodnoty

Returns a KADM5 handle on success, or FALSE on failure.

Příklady

Příklad 958. KADM5 initialization example

<?php

$handle = kadm5_init_with_password("afs-1", "GONICUS.LOCAL", "admin/admin", "password");

$attributes = KRB5_KDB_REQUIRES_PRE_AUTH | KRB5_KDB_DISALLOW_PROXIABLE;
$options = array(KADM5_PRINC_EXPIRE_TIME => 0,
                 KADM5_POLICY => "default",
                 KADM5_ATTRIBUTES => $attributes);

kadm5_create_principal($handle, "burbach@GONICUS.LOCAL", "password", $options);

kadm5_destroy($handle);
?>

Poznámky

Poznámka: Connection should be closed after use with kadm5_destroy().

Viz také

kadm5_destroy()

Předcházející | Nahoru | Další
kadm5_get_principals | Domů | kadm5_modify_principal


kadm5_modify_principal

(PECL kadm5:0.2.3)

kadm5_modify_principal — Modifies a kerberos principal with the given parameters

Popis

bool kadm5_modify_principal ( resource $handle, string $principal, array $options )

kadm5_modify_principal() modifies a principal according to the given options. Allowed are the following options: KADM5_PRINC_EXPIRE_TIME, KADM5_PW_EXPIRATION, KADM5_ATTRIBUTES, KADM5_MAX_LIFE, KADM5_KVNO, KADM5_POLICY, KADM5_CLEARPOLICY, KADM5_MAX_RLIFE, KADM5_FAIL_AUTH_COUNT.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 959. Example of modifying principal

<?php

$handle = kadm5_init_with_password("afs-1", "GONICUS.LOCAL", "admin/admin", "password");

$attributes = KRB5_KDB_REQUIRES_PRE_AUTH;
$options = array(KADM5_PRINC_EXPIRE_TIME => 3451234,
                 KADM5_POLICY => "gonicus",
                 KADM5_ATTRIBUTES => $attributes);

kadm5_modify_principal($handle, "burbach@GONICUS.LOCAL", $options);

kadm5_destroy($handle);
?>

Předcházející | Nahoru | Další
kadm5_init_with_password | Domů | LXXV. LDAP Functions


lchgrp

(PHP 5 >= 5.1.2)

lchgrp — Changes group ownership of symlink

Popis

bool lchgrp ( string $filename, mixed $group )

Attempts to change the group of the symlink filename to group.

Only the superuser may change the group of a symlink arbitrarily; other users may change the group of a symlink to any group of which that user is a member.

Seznam parametrů

filename

Path to the symlink.

group

The group specified by name or number.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Poznámky

Poznámka: Tato funkce nebude pracovat se vzdálenými soubory, protože zkoumaný soubor musí být dostupný přes filesystém serveru.

Poznámka: Pokud je zapnut bezpečný režim (safe-mode), PHP kontroluje, zda soubory/adresáře, se kterými pracujete, mají stejné UID jako spuštěný skript.

Viz také

chgrp()
lchown()
chown()
chmod()

Předcházející | Nahoru | Další
is_writeable | Domů | lchown


lchown

(PHP 5 >= 5.1.2)

lchown — Changes user ownership of symlink

Popis

bool lchown ( string $filename, mixed $user )

Attempts to change the owner of the symlink filename to user user.

Only the superuser may change the owner of a symlink.

Seznam parametrů

filename

Path to the file.

user

User name or number.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Poznámky

Poznámka: Tato funkce nebude pracovat se vzdálenými soubory, protože zkoumaný soubor musí být dostupný přes filesystém serveru.

Poznámka: Pokud je zapnut bezpečný režim (safe-mode), PHP kontroluje, zda soubory/adresáře, se kterými pracujete, mají stejné UID jako spuštěný skript.

Viz také

chgrp()
lchgrp()
chgrp()
chmod()

Předcházející | Nahoru | Další
lchgrp | Domů | link


libxml_clear_errors

(PHP 5 >= 5.1.0)

libxml_clear_errors — Clear libxml error buffer

Popis

void libxml_clear_errors ( void )

libxml_clear_errors() clears the libxml error buffer.

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

libxml_get_errors()
libxml_get_last_error()

Předcházející | Nahoru | Další
LXXVI. libxml Functions | Domů | libxml_get_errors


libxml_get_errors

(PHP 5 >= 5.1.0)

libxml_get_errors — Retrieve array of errors

Popis

array libxml_get_errors ( void )

Retrieve array of errors.

Návratové hodnoty

Returns an array with LibXMLError objects if there are any errors in the buffer, or an empty array otherwise.

Příklady

Příklad 976. A libxml_get_errors() example

This example demonstrates how to build a simple libxml error handler.

<?php

libxml_use_internal_errors(true);

$xmlstr = <<< XML
<?xml version='1.0' standalone='yes'?>
<movies>
 <movie>
  <titles>PHP: Behind the Parser</title>
 </movie>
</movies>
XML;

$doc = simplexml_load_string($xmlstr);
$xml = explode("\n", $xmlstr);

if (!$doc) {
    $errors = libxml_get_errors();

    foreach ($errors as $error) {
        echo display_xml_error($error, $xml);
    }

    libxml_clear_errors();
}

function display_xml_error($error, $xml)
{
    $return  = $xml[$error->line - 1] . "\n";
    $return .= str_repeat('-', $error->column) . "^\n";

    switch ($error->level) {
        case LIBXML_ERR_WARNING:
            $return .= "Warning $error->code: ";
            break;
         case LIBXML_ERR_ERROR:
            $return .= "Error $error->code: ";
            break;
        case LIBXML_ERR_FATAL:
            $return .= "Fatal Error $error->code: ";
            break;
    }

    $return .= trim($error->message) .
               "\n  Line: $error->line" .
               "\n  Column: $error->column";

    if ($error->file) {
        $return .= "\n  File: $error->file";
    }

    return "$return\n\n--------------------------------------------\n\n";
}

?>

Výše uvedený příklad vypíše:

  <titles>PHP: Behind the Parser</title>
^
Fatal Error 76: Opening and ending tag mismatch: titles line 4 and title
  Line: 4
  Column: 0

--------------------------------------------

Viz také

libxml_get_last_error()
libxml_clear_errors()

Předcházející | Nahoru | Další
libxml_clear_errors | Domů | libxml_get_last_error


libxml_get_last_error

(PHP 5 >= 5.1.0)

libxml_get_last_error — Retrieve last error from libxml

Popis

LibXMLError libxml_get_last_error ( void )

Retrieve last error from libxml.

Návratové hodnoty

Returns a LibXMLError object if there is any error in the buffer, FALSE otherwise.

Viz také

libxml_get_errors()
libxml_clear_errors()

Předcházející | Nahoru | Další
libxml_get_errors | Domů | libxml_set_streams_context


libxml_set_streams_context

(PHP 5)

libxml_set_streams_context — Set the streams context for the next libxml document load or write

Popis

void libxml_set_streams_context ( resource $streams_context )

Sets the streams context for the next libxml document load or write.

Seznam parametrů

streams_context

The stream context resource (created with stream_context_create())

Návratové hodnoty

Nevrací se žádná hodnota.

Příklady

Příklad 977. A libxml_set_streams_context() example

<?php

$opts = array(
    'http' => array(
        'user_agent' => 'PHP libxml agent',
    )
);

$context = stream_context_create($opts);
libxml_set_streams_context($context);

// request a file through HTTP
$doc = DOMDocument::load('http://www.example.com/file.xml');

?>

Viz také

stream_context_create()

Předcházející | Nahoru | Další
libxml_get_last_error | Domů | libxml_use_internal_errors


libxml_use_internal_errors

(PHP 5 >= 5.1.0)

libxml_use_internal_errors — Disable libxml errors and allow user to fetch error information as needed

Popis

bool libxml_use_internal_errors ( [bool $use_errors] )

libxml_use_internal_errors() allows you to disable standard libxml errors and enable user error handling.

Seznam parametrů

use_errors

Whether to enable user error handling. Defaults to FALSE.

Návratové hodnoty

This function returns the previous value of use_errors.

Příklady

Příklad 978. A libxml_use_internal_errors() example

This example demonstrates the basic usage of libxml errors and the value returned by this function.

<?php

// enable user error handling
var_dump(libxml_use_internal_errors(true));

$doc = DOMDocument::load('file.xml');

if (!$doc) {
    $errors = libxml_get_errors();
    foreach ($errors as $error) {
        // handle errors here
    }

    libxml_clear_errors();
}

?>

Výše uvedený příklad vypíše:

bool(false)

Viz také

libxml_clear_errors()
libxml_get_errors()

Předcházející | Nahoru | Další
libxml_set_streams_context | Domů | LXXVII. Lotus Notes Functions


locale_get_default

(No version information available, might be only in CVS)

locale_get_default — Get the default Locale

Popis

string locale_get_default ( void )

This function returns the default Locale, which is used by PHP to localize certain features. Please note that this isn't influenced by setlocale() or the system settings.

Návratové hodnoty

Returns a string with the current Locale.

Příklady

Příklad 758. A locale_get_default() example

<?php

// get the default Locale
echo locale_get_default();

//set a new Locale...
locale_set_default('pt_PT');

// ... and print it
echo locale_get_default();

?>

Výše uvedený příklad vypíše:

en_US_POSIX
pt_PT

Viz také

locale_set_default()

Předcházející | Nahoru | Další
LIX. i18n Funkce | Domů | locale_set_default


locale_set_default

(No version information available, might be only in CVS)

locale_set_default — Set the default Locale

Popis

bool locale_set_default ( string $name )

Sets the default Locale for PHP programs. Please note that this has nothing to do with setlocale() nor with the system locale.

Seznam parametrů

name

The new Locale name. A comprehensive list of the supported locales is available at » http://demo.icu-project.org/icu-bin/locexp.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 759. A locale_set_default() example

This example demonstrates a possible usage of locale_set_default() to localize the sort() functions.

<?php

// the list of the strings to sort
$array = array(
    'caramelo',
    'cacto',
    'caçada'
);

// set our locale (Portuguese, in this case)
locale_set_default('pt_PT');

// sort using the locale we previously set
sort($array, SORT_LOCALE_STRING);

print_r($array);
?>

Výše uvedený příklad vypíše:

Array
(
    [0] => caçada
    [1] => cacto
    [2] => caramelo
)

If we didn't use the locale, PHP would sort the string using the ASCII characters value, thus returning (wrongly):

Array
(
    [0] => cacto
    [1] => caramelo
    [2] => caçada
)

Viz také

locale_get_default()

Předcházející | Nahoru | Další
locale_get_default | Domů | LX. IBM Functions (PDO_IBM)


m_checkstatus

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve:1.0.0-5.2.2)

m_checkstatus — Check to see if a transaction has completed

Popis

int m_checkstatus ( resource $conn, int $identifier )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

conn

An MCVE_CONN resource returned by m_initengine().

identifier

Návratové hodnoty

Předcházející | Nahoru | Další
LXXXV. MCVE (Monetra) Payment Functions | Domů | m_completeauthorizations


m_completeauthorizations

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve:1.0.0-5.2.2)

m_completeauthorizations — Number of complete authorizations in queue, returning an array of their identifiers

Popis

int m_completeauthorizations ( resource $conn, int &$array )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

conn

An MCVE_CONN resource returned by m_initengine().

array

Its description

Návratové hodnoty

What the function returns, first on success, then on failure. See also the &return.success; entity

Předcházející | Nahoru | Další
m_checkstatus | Domů | m_connect


m_connect

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve:1.0.0-5.2.2)

m_connect — Establish the connection to MCVE

Popis

int m_connect ( resource $conn )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

conn

An MCVE_CONN resource returned by m_initengine().

Návratové hodnoty

Předcházející | Nahoru | Další
m_completeauthorizations | Domů | m_connectionerror


m_connectionerror

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve:1.0.0-5.2.2)

m_connectionerror — Get a textual representation of why a connection failed

Popis

string m_connectionerror ( resource $conn )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

conn

An MCVE_CONN resource returned by m_initengine().

Návratové hodnoty

Předcházející | Nahoru | Další
m_connect | Domů | m_deletetrans


m_deletetrans

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve:1.0.0-5.2.2)

m_deletetrans — Delete specified transaction from MCVE_CONN structure

Popis

bool m_deletetrans ( resource $conn, int $identifier )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

conn

An MCVE_CONN resource returned by m_initengine().

identifier

Návratové hodnoty

Předcházející | Nahoru | Další
m_connectionerror | Domů | m_destroyconn


m_destroyconn

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve:1.0.0-5.2.2)

m_destroyconn — Destroy the connection and MCVE_CONN structure

Popis

bool m_destroyconn ( resource $conn )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

conn

An MCVE_CONN resource returned by m_initengine().

Návratové hodnoty

Returns TRUE.

Viz také

m_initconn()

Předcházející | Nahoru | Další
m_deletetrans | Domů | m_destroyengine


m_destroyengine

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve:1.0.0-5.2.2)

m_destroyengine — Free memory associated with IP/SSL connectivity

Popis

void m_destroyengine ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
m_destroyconn | Domů | m_getcell


m_getcell

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve:1.0.0-5.2.2)

m_getcell — Get a specific cell from a comma delimited response by column name

Popis

string m_getcell ( resource $conn, int $identifier, string $column, int $row )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

conn

An MCVE_CONN resource returned by m_initengine().

identifier

column

row

Návratové hodnoty

Předcházející | Nahoru | Další
m_destroyengine | Domů | m_getcellbynum


m_getcellbynum

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve:1.0.0-5.2.2)

m_getcellbynum — Get a specific cell from a comma delimited response by column number

Popis

string m_getcellbynum ( resource $conn, int $identifier, int $column, int $row )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

conn

An MCVE_CONN resource returned by m_initengine().

identifier

column

row

Návratové hodnoty

Předcházející | Nahoru | Další
m_getcell | Domů | m_getcommadelimited


m_getcommadelimited

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve:1.0.0-5.2.2)

m_getcommadelimited — Get the RAW comma delimited data returned from MCVE

Popis

string m_getcommadelimited ( resource $conn, int $identifier )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

conn

An MCVE_CONN resource returned by m_initengine().

identifier

Návratové hodnoty

Předcházející | Nahoru | Další
m_getcellbynum | Domů | m_getheader


m_getheader

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve:1.0.0-5.2.2)

m_getheader — Get the name of the column in a comma-delimited response

Popis

string m_getheader ( resource $conn, int $identifier, int $column_num )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

conn

An MCVE_CONN resource returned by m_initengine().

identifier

column_num

Návratové hodnoty

Předcházející | Nahoru | Další
m_getcommadelimited | Domů | m_initconn


m_initconn

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve:1.0.0-5.2.2)

m_initconn — Create and initialize an MCVE_CONN structure

Popis

resource m_initconn ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Návratové hodnoty

Returns an MCVE_CONN resource.

Viz také

m_destroyconn()

Předcházející | Nahoru | Další
m_getheader | Domů | m_initengine


m_initengine

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve:1.0.0-5.2.2)

m_initengine — Ready the client for IP/SSL Communication

Popis

int m_initengine ( string $location )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

location

Návratové hodnoty

Předcházející | Nahoru | Další
m_initconn | Domů | m_iscommadelimited


m_iscommadelimited

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve:1.0.0-5.2.2)

m_iscommadelimited — Checks to see if response is comma delimited

Popis

int m_iscommadelimited ( resource $conn, int $identifier )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

conn

An MCVE_CONN resource returned by m_initengine().

identifier

Návratové hodnoty

Předcházející | Nahoru | Další
m_initengine | Domů | m_maxconntimeout


m_maxconntimeout

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve:1.0.0-5.2.2)

m_maxconntimeout — The maximum amount of time the API will attempt a connection to MCVE

Popis

bool m_maxconntimeout ( resource $conn, int $secs )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

conn

An MCVE_CONN resource returned by m_initengine().

secs

Návratové hodnoty

Předcházející | Nahoru | Další
m_iscommadelimited | Domů | m_monitor


m_monitor

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve:1.0.0-5.2.2)

m_monitor — Perform communication with MCVE (send/receive data) Non-blocking

Popis

int m_monitor ( resource $conn )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

conn

An MCVE_CONN resource returned by m_initengine().

Návratové hodnoty

Předcházející | Nahoru | Další
m_maxconntimeout | Domů | m_numcolumns


m_numcolumns

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve:1.0.0-5.2.2)

m_numcolumns — Number of columns returned in a comma delimited response

Popis

int m_numcolumns ( resource $conn, int $identifier )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

conn

An MCVE_CONN resource returned by m_initengine().

identifier

Návratové hodnoty

Předcházející | Nahoru | Další
m_monitor | Domů | m_numrows


m_numrows

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve:1.0.0-5.2.2)

m_numrows — Number of rows returned in a comma delimited response

Popis

int m_numrows ( resource $conn, int $identifier )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

conn

An MCVE_CONN resource returned by m_initengine().

identifier

Návratové hodnoty

Předcházející | Nahoru | Další
m_numcolumns | Domů | m_parsecommadelimited


m_parsecommadelimited

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve:1.0.0-5.2.2)

m_parsecommadelimited — Parse the comma delimited response so m_getcell, etc will work

Popis

int m_parsecommadelimited ( resource $conn, int $identifier )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

conn

An MCVE_CONN resource returned by m_initengine().

identifier

Návratové hodnoty

Předcházející | Nahoru | Další
m_numrows | Domů | m_responsekeys


m_responsekeys

(PHP 5 >= 5.0.5, PECL mcve:1.0.0-5.2.2)

m_responsekeys — Returns array of strings which represents the keys that can be used for response parameters on this transaction

Popis

array m_responsekeys ( resource $conn, int $identifier )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

conn

An MCVE_CONN resource returned by m_initengine().

identifier

Návratové hodnoty

Předcházející | Nahoru | Další
m_parsecommadelimited | Domů | m_responseparam


m_responseparam

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve:1.0.0-5.2.2)

m_responseparam — Get a custom response parameter

Popis

string m_responseparam ( resource $conn, int $identifier, string $key )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

conn

An MCVE_CONN resource returned by m_initengine().

identifier

key

Návratové hodnoty

Předcházející | Nahoru | Další
m_responsekeys | Domů | m_returnstatus


m_returnstatus

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve:1.0.0-5.2.2)

m_returnstatus — Check to see if the transaction was successful

Popis

int m_returnstatus ( resource $conn, int $identifier )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

conn

An MCVE_CONN resource returned by m_initengine().

identifier

Návratové hodnoty

Předcházející | Nahoru | Další
m_responseparam | Domů | m_setblocking


m_setblocking

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve:1.0.0-5.2.2)

m_setblocking — Set blocking/non-blocking mode for connection

Popis

int m_setblocking ( resource $conn, int $tf )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

conn

An MCVE_CONN resource returned by m_initengine().

tf

Návratové hodnoty

Předcházející | Nahoru | Další
m_returnstatus | Domů | m_setdropfile


m_setdropfile

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve:1.0.0-5.2.2)

m_setdropfile — Set the connection method to Drop-File

Popis

int m_setdropfile ( resource $conn, string $directory )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

conn

An MCVE_CONN resource returned by m_initengine().

directory

Návratové hodnoty

Předcházející | Nahoru | Další
m_setblocking | Domů | m_setip


m_setip

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve:1.0.0-5.2.2)

m_setip — Set the connection method to IP

Popis

int m_setip ( resource $conn, string $host, int $port )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

conn

An MCVE_CONN resource returned by m_initengine().

host

port

Návratové hodnoty

Předcházející | Nahoru | Další
m_setdropfile | Domů | m_setssl_cafile


m_setssl

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve:1.0.0-5.2.2)

m_setssl — Set the connection method to SSL

Popis

int m_setssl ( resource $conn, string $host, int $port )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

conn

An MCVE_CONN resource returned by m_initengine().

host

port

Návratové hodnoty

Předcházející | Nahoru | Další
m_setssl_files | Domů | m_settimeout


m_setssl_cafile

(PHP 5 >= 5.0.5, PECL mcve:1.0.0-5.2.2)

m_setssl_cafile — Set SSL CA (Certificate Authority) file for verification of server certificate

Popis

int m_setssl_cafile ( resource $conn, string $cafile )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

conn

An MCVE_CONN resource returned by m_initengine().

cafile

Návratové hodnoty

Předcházející | Nahoru | Další
m_setip | Domů | m_setssl_files


m_setssl_files

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve:1.0.0-5.2.2)

m_setssl_files — Set certificate key files and certificates if server requires client certificate verification

Popis

int m_setssl_files ( resource $conn, string $sslkeyfile, string $sslcertfile )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

conn

An MCVE_CONN resource returned by m_initengine().

sslkeyfile

sslcertfile

Návratové hodnoty

Předcházející | Nahoru | Další
m_setssl_cafile | Domů | m_setssl


m_settimeout

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve:1.0.0-5.2.2)

m_settimeout — Set maximum transaction time (per trans)

Popis

int m_settimeout ( resource $conn, int $seconds )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

conn

An MCVE_CONN resource returned by m_initengine().

seconds

Návratové hodnoty

Předcházející | Nahoru | Další
m_setssl | Domů | m_sslcert_gen_hash


m_sslcert_gen_hash

(PECL mcve:5.2.0-5.2.2)

m_sslcert_gen_hash — Generate hash for SSL client certificate verification

Popis

string m_sslcert_gen_hash ( string $filename )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

filename

Návratové hodnoty

Předcházející | Nahoru | Další
m_settimeout | Domů | m_transactionssent


m_transactionssent

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve:1.0.0-5.2.2)

m_transactionssent — Check to see if outgoing buffer is clear

Popis

int m_transactionssent ( resource $conn )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

conn

An MCVE_CONN resource returned by m_initengine().

Návratové hodnoty

Předcházející | Nahoru | Další
m_sslcert_gen_hash | Domů | m_transinqueue


m_transinqueue

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve:1.0.0-5.2.2)

m_transinqueue — Number of transactions in client-queue

Popis

int m_transinqueue ( resource $conn )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

conn

An MCVE_CONN resource returned by m_initengine().

Návratové hodnoty

Předcházející | Nahoru | Další
m_transactionssent | Domů | m_transkeyval


m_transkeyval

(PHP 5 >= 5.0.5, PECL mcve:1.0.0-5.2.2)

m_transkeyval — Add key/value pair to a transaction. Replaces deprecated transparam()

Popis

int m_transkeyval ( resource $conn, int $identifier, string $key, string $value )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

conn

An MCVE_CONN resource returned by m_initengine().

identifier

key

value

Návratové hodnoty

Předcházející | Nahoru | Další
m_transinqueue | Domů | m_transnew


m_transnew

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve:1.0.0-5.2.2)

m_transnew — Start a new transaction

Popis

int m_transnew ( resource $conn )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

conn

An MCVE_CONN resource returned by m_initengine().

Návratové hodnoty

Předcházející | Nahoru | Další
m_transkeyval | Domů | m_transsend


m_transsend

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve:1.0.0-5.2.2)

m_transsend — Finalize and send the transaction

Popis

int m_transsend ( resource $conn, int $identifier )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

conn

An MCVE_CONN resource returned by m_initengine().

identifier

Návratové hodnoty

Předcházející | Nahoru | Další
m_transnew | Domů | m_uwait


m_uwait

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve:1.0.0-5.2.2)

m_uwait — Wait x microsecs

Popis

int m_uwait ( int $microsecs )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

microsecs

Návratové hodnoty

Předcházející | Nahoru | Další
m_transsend | Domů | m_validateidentifier


m_validateidentifier

(PHP 5 >= 5.0.5, PECL mcve:1.0.0-5.2.2)

m_validateidentifier — Whether or not to validate the passed identifier on any transaction it is passed to

Popis

int m_validateidentifier ( resource $conn, int $tf )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

conn

An MCVE_CONN resource returned by m_initengine().

tf

Návratové hodnoty

Předcházející | Nahoru | Další
m_uwait | Domů | m_verifyconnection


m_verifyconnection

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve:1.0.0-5.2.2)

m_verifyconnection — Set whether or not to PING upon connect to verify connection

Popis

bool m_verifyconnection ( resource $conn, int $tf )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

conn

An MCVE_CONN resource returned by m_initengine().

tf

Návratové hodnoty

Předcházející | Nahoru | Další
m_validateidentifier | Domů | m_verifysslcert


m_verifysslcert

(PHP 4 >= 4.3.9, PHP 5 <= 5.0.5, PECL mcve:1.0.0-5.2.2)

m_verifysslcert — Set whether or not to verify the server ssl certificate

Popis

bool m_verifysslcert ( resource $conn, int $tf )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

conn

An MCVE_CONN resource returned by m_initengine().

tf

Návratové hodnoty

Předcházející | Nahoru | Další
m_verifyconnection | Domů | LXXXVI. Memcache Functions


mailparse_msg_extract_whole_part_file

(PECL mailparse:0.9-2.1.1)

mailparse_msg_extract_whole_part_file — Extracts a message section including headers without decoding the transfer encoding

Popis

string mailparse_msg_extract_whole_part_file ( resource $mimemail, string $filename [, callback $callbackfunc] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

mimemail

A valid MIME resource.

filename

callbackfunc

Návratové hodnoty

Viz také

mailparse_msg_extract_part()
mailparse_msg_extract_part_file()

Předcházející | Nahoru | Další
mailparse_msg_extract_part | Domů | mailparse_msg_free


maxdb_affected_rows

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_affected_rows,

(PECL maxdb:1.0-7.6.00.38)

maxdb_affected_rows, maxdb->affected_rows — Gets the number of affected rows in a previous MaxDB operation

Popis

Procedural style:

int maxdb_affected_rows ( resource $link )

Object oriented style (property):

class maxdb {
int affected_rows
}

maxdb_affected_rows() returns the number of rows affected by the last INSERT, UPDATE, or DELETE query associated with the provided link parameter. If this number cannot be determined, this function will return -1.

Poznámka: For SELECT statements maxdb_affected_rows() works like maxdb_num_rows().

The maxdb_affected_rows() function only works with queries which modify a table. In order to return the number of rows from a SELECT query, use the maxdb_num_rows() function instead.

Návratové hodnoty

An integer greater than zero indicates the number of rows affected or retrieved. Zero indicates that no records where updated for an UPDATE statement, no rows matched the WHERE clause in the query or that no query has yet been executed. -1 indicates that the number of rows affected can not be determined.

Příklady

Příklad 1004. Object oriented style

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

maxdb_report (MAXDB_REPORT_OFF);
$maxdb->query("DROP TABLE mycustomer");
maxdb_report (MAXDB_REPORT_ERROR);

/* Insert rows */
$maxdb->query("CREATE TABLE mycustomer AS SELECT * from hotel.customer");
printf("Affected rows (INSERT): %d\n", $maxdb->affected_rows);

$maxdb->query("ALTER TABLE mycustomer ADD Status int default 0");

/* update rows */
$maxdb->query("UPDATE mycustomer SET Status=1 WHERE cno > 50");
printf("Affected rows (UPDATE): %d\n", $maxdb->affected_rows);

/* delete rows */
$maxdb->query("DELETE FROM mycustomer WHERE cno < 50");
printf("Affected rows (DELETE): %d\n", $maxdb->affected_rows);

/* select all rows */
$result = $maxdb->query("SELECT title FROM mycustomer");
printf("Affected rows (SELECT): %d\n", $maxdb->affected_rows);

$result->close();

/* Delete table Language */
$maxdb->query("DROP TABLE mycustomer");

/* close connection */
$maxdb->close();
?>

Příklad 1005. Procedural style

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

if (!$link) {
   printf("Can't connect to localhost. Error: %s\n", maxdb_connect_error());
   exit();
}

maxdb_report (MAXDB_REPORT_OFF);
maxdb_query($link,"DROP TABLE mycustomer");
maxdb_report (MAXDB_REPORT_ERROR);

/* Insert rows */
maxdb_query($link, "CREATE TABLE mycustomer AS SELECT * from hotel.customer");
printf("Affected rows (INSERT): %d\n", maxdb_affected_rows($link));

maxdb_query($link, "ALTER TABLE mycustomer ADD Status int default 0");

/* update rows */
maxdb_query($link, "UPDATE mycustomer SET Status=1 WHERE cno > 50");
printf("Affected rows (UPDATE): %d\n", maxdb_affected_rows($link));

/* delete rows */
maxdb_query($link, "DELETE FROM mycustomer WHERE cno < 50");
printf("Affected rows (DELETE): %d\n", maxdb_affected_rows($link));

/* select all rows */
$result = maxdb_query($link, "SELECT title FROM mycustomer");
printf("Affected rows (SELECT): %d\n", maxdb_affected_rows($link));

maxdb_free_result($result);

/* Delete table Language */
maxdb_query($link, "DROP TABLE mycustomer");

/* close connection */
maxdb_close($link);
?>

The above examples would produce the following output:

Affected rows (INSERT): 15
Affected rows (UPDATE): 15
Affected rows (DELETE): 0
Affected rows (SELECT): 15

Viz také

maxdb_num_rows()
maxdb_info()

Předcházející | Nahoru | Další
LXXXII. MaxDB PHP Extension | Domů | maxdb_autocommit


maxdb_autocommit

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_autocommit,

(PECL maxdb:1.0-7.6.00.38)

maxdb_autocommit, maxdb->auto_commit — Turns on or off auto-commiting database modifications

Popis

Procedural style:

bool maxdb_autocommit ( resource $link, bool $mode )

Object oriented style (method)

class maxdb {
bool auto_commit ( bool $mode )
}

maxdb_autocommit() is used to turn on or off auto-commit mode on queries for the database connection represented by the link resource.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1006. Object oriented style

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* turn autocommit on */
$maxdb->autocommit(TRUE);

/* close connection */
$maxdb->close();
?>

Příklad 1007. Procedural style

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

if (!$link) {
   printf("Can't connect to localhost. Error: %s\n", maxdb_connect_error());
   exit();
}

/* turn autocommit on */
maxdb_autocommit($link, TRUE);

/* close connection */
maxdb_close($link);
?>

The above examples would produce no output.

Viz také

maxdb_commit()
maxdb_rollback()

Předcházející | Nahoru | Další
maxdb_affected_rows | Domů | maxdb_bind_param


maxdb_bind_param

(PECL maxdb:1.0)

maxdb_bind_param — Alias pro maxdb_stmt_bind_param()

Popis

Tato funkce je aliasem: maxdb_stmt_bind_param()

Tento alias funkce je zavržený a existuje pouze z důvodu zpětné kompatibility. Doporučuje se tuto funkci nepoužívat, neboť může být jednoho dne odstraněna z PHP.

Předcházející | Nahoru | Další
maxdb_autocommit | Domů | maxdb_bind_result


maxdb_bind_result

(PECL maxdb:1.0)

maxdb_bind_result — Alias pro maxdb_stmt_bind_result()

Popis

Tato funkce je aliasem: maxdb_stmt_bind_result().

Tento alias funkce je zavržený a existuje pouze z důvodu zpětné kompatibility. Doporučuje se tuto funkci nepoužívat, neboť může být jednoho dne odstraněna z PHP.

Předcházející | Nahoru | Další
maxdb_bind_param | Domů | maxdb_change_user


maxdb_change_user

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_change_user,

(PECL maxdb:1.0-7.6.00.38)

maxdb_change_user, maxdb->change_user — Changes the user of the specified database connection

Popis

Procedural style:

bool maxdb_change_user ( resource $link, string $user, string $password, string $database )

Object oriented style (method):

class maxdb {
bool change_user ( string $user, string $password, string $database )
}

maxdb_change_user() is used to change the user of the specified database connection as given by the link parameter and to set the current database to that specified by the database parameter.

In order to successfully change users a valid username and password parameters must be provided and that user must have sufficient permissions to access the desired database. If for any reason authorization fails, the current user authentication will remain.

Poznámka: Using this command will always cause the current database connection to behave as if was a completely new database connection, regardless of if the operation was completed successfully. This reset includes performing a rollback on any active transactions, closing all temporary tables, and unlocking all locked tables.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1008. Object oriented style

<?php

/* connect database test */
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

if ($result = $maxdb->query("SELECT * FROM dual")) {
   $row = $result->fetch_row();
   printf("Result: %s\n", $row[0]);
   $result->free();
}

/* reset all and select a new database */
if (!$maxdb->change_user("DBADMIN", "SECRET", "DEMODB")) {
  printf("Database not running\n");
} else {
  printf("Database running\n");
}

/* close connection */
$maxdb->close();
?>

Příklad 1009. Procedural style

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (!$link) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

if ($result = maxdb_query($link, "SELECT * FROM dual")) {
   $row = maxdb_fetch_row($result);
   printf("Result: %s\n", $row[0]);
   maxdb_free_result($result);
}

/* reset all and select a new database */
if (!maxdb_change_user($link, "DBADMIN", "SECRET", "DEMODB")) {
  printf("Database not running\n");
} else {
  printf("Database running\n");
}

/* close connection */
maxdb_close($link);
?>

The above examples would produce the following output:

Result: a
Database running

Viz také

maxdb_connect()
maxdb_select_db()

Předcházející | Nahoru | Další
maxdb_bind_result | Domů | maxdb_character_set_name


maxdb_character_set_name

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_character_set_name,

(PECL maxdb:1.0-7.6.00.38)

maxdb_character_set_name, maxdb->character_set_name — Returns the default character set for the database connection

Popis

Procedural style:

string maxdb_character_set_name ( resource $link )

Object oriented style (method):

class maxdb {
string character_set_name ( void )
}

Returns the current character set for the database connection specified by the link parameter.

Návratové hodnoty

The default character set for the current connection, either ascii or unicode.

Příklady

Příklad 1010. Object oriented style

<?php
/* Open a connection */
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* Print current character set */
$charset = $maxdb->character_set_name();
printf ("Current character set is %s\n", $charset);

$maxdb->close();
?>

Příklad 1011. Procedural style

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (!$link) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* Print current character set */
$charset = maxdb_character_set_name($link);
printf ("Current character set is %s\n",$charset);

/* close connection */
maxdb_close($link);
?>

The above examples would be produce the following output:

Current character set is ascii

Viz také

maxdb_client_encoding()
maxdb_real_escape_string()

Předcházející | Nahoru | Další
maxdb_change_user | Domů | maxdb_client_encoding


maxdb_client_encoding

(PECL maxdb:1.0)

maxdb_client_encoding — Alias pro maxdb_character_set_name()

Popis

Tato funkce je aliasem: maxdb_character_set_name().

Tento alias funkce je zavržený a existuje pouze z důvodu zpětné kompatibility. Doporučuje se tuto funkci nepoužívat, neboť může být jednoho dne odstraněna z PHP.

Předcházející | Nahoru | Další
maxdb_character_set_name | Domů | maxdb_close_long_data


maxdb_close

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_close,

(PECL maxdb:1.0-7.6.00.38)

maxdb_close, maxdb->close — Closes a previously opened database connection

Popis

Procedural style:

bool maxdb_close ( resource $link )

Object oriented style (method):

class maxdb {
bool close ( void )
}

The maxdb_close() function closes a previously opened database connection specified by the link parameter.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

maxdb_connect()
maxdb_init()
maxdb_real_connect()

Předcházející | Nahoru | Další
maxdb_close_long_data | Domů | maxdb_commit


maxdb_close_long_data

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_close_long_data,

(PECL maxdb:1.0-7.6.00.38)

maxdb_close_long_data, maxdb->close_long_data — Alias pro maxdb_stmt_close_long_data()

Popis

Tato funkce je aliasem: maxdb_stmt_close_long_data().

Tento alias funkce je zavržený a existuje pouze z důvodu zpětné kompatibility. Doporučuje se tuto funkci nepoužívat, neboť může být jednoho dne odstraněna z PHP.

Předcházející | Nahoru | Další
maxdb_client_encoding | Domů | maxdb_close


maxdb_commit

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_commit,

(PECL maxdb:1.0-7.6.00.38)

maxdb_commit, maxdb->commit — Commits the current transaction

Popis

Procedural style:

bool maxdb_commit ( resource $link )

Object oriented style (method)

class maxdb {
bool commit ( void )
}

Commits the current transaction for the database connection specified by the link parameter.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1012. Object oriented style

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* set autocommit to off */
$maxdb->autocommit(FALSE);

maxdb_report (MAXDB_REPORT_OFF);
$maxdb->query("DROP TABLE mycustomer");
maxdb_report (MAXDB_REPORT_ERROR);

$maxdb->query("CREATE TABLE mycustomer LIKE hotel.customer");

/* Insert some values */
$maxdb->query("INSERT INTO mycustomer VALUES (3000,'Mrs','Jenny','Porter','10580','1340 N.Ash Street, #3')");
$maxdb->query("INSERT INTO mycustomer VALUES (3100,'Mr','Peter','Brown','48226','1001 34th Str., APT.3')");

/* commit transaction */
$maxdb->commit();

/* close connection */
$maxdb->close();
?>

Příklad 1013. Procedural style

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (!$link) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* set autocommit to off */
maxdb_autocommit($link, FALSE);

maxdb_report (MAXDB_REPORT_OFF);
maxdb_query($link,"DROP TABLE mycustomer");
maxdb_report (MAXDB_REPORT_ERROR);

maxdb_query($link, "CREATE TABLE mycustomer LIKE hotel.customer");

/* Insert some values */
maxdb_query($link, "INSERT INTO mycustomer VALUES (3000,'Mrs','Jenny','Porter','10580','1340 N.Ash Street, #3')");
maxdb_query($link, "INSERT INTO mycustomer VALUES (3100,'Mr','Peter','Brown','48226','1001 34th Str., APT.3')");

/* commit transaction */
maxdb_commit($link);

/* close connection */
maxdb_close($link);
?>

The above examples produces no output.

Viz také

maxdb_autocommit()
maxdb_rollback()

Předcházející | Nahoru | Další
maxdb_close | Domů | maxdb_connect_errno


maxdb_connect

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_connect,

(PECL maxdb:1.0-7.6.00.38)

maxdb_connect, maxdb() — Open a new connection to the MaxDB server

Popis

Procedural style

resource maxdb_connect ( [string $host [, string $username [, string $passwd [, string $dbname [, int $port [, string $socket]]]]]] )

Object oriented style (constructor):

class maxdb {
__construct ( [string $host [, string $username [, string $passwd [, string $dbname [, int $port [, string $socket]]]]]] )
}

The maxdb_connect() function attempts to open a connection to the MaxDB Server running on host which can be either a host name or an IP address. Passing the string "localhost" to this parameter, the local host is assumed. If successful, the maxdb_connect() will return an resource representing the connection to the database, or FALSE on failure.

The username and password parameters specify the username and password under which to connect to the MaxDB server. If the password is not provided (the NULL value is passed), the MaxDB server will attempt to authenticate the user against the maxdb.default_pw in php.ini.

The dbname parameter if provided will specify the default database to be used when performing queries. If not provied, the entry maxdb.default_db in php.ini is used.

The port and socket parameters are ignored for the MaxDB server.

Návratové hodnoty

Returns a resource which represents the connection to a MaxDB Server or FALSE if the connection failed.

Příklady

Příklad 1016. Object oriented style

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

printf("Host information: %s\n", $maxdb->host_info);

/* close connection */
$maxdb->close();
?>

Příklad 1017. Procedural style

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (!$link) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

printf("Host information: %s\n", maxdb_get_host_info($link));

/* close connection */
maxdb_close($link);
?>

The above examples would produce the following output:

Host information: localhost

Předcházející | Nahoru | Další
maxdb_connect_error | Domů | maxdb_data_seek


maxdb_connect_errno

(PECL maxdb:1.0-7.6.00.38)

maxdb_connect_errno — Returns the error code from last connect call

Popis

int maxdb_connect_errno ( void )

The maxdb_connect_errno() function will return the last error code number for last call to maxdb_connect(). If no errors have occured, this function will return zero.

Návratové hodnoty

An error code value for the last call to maxdb_connect(), if it failed. zero means no error occurred.

Příklady

Příklad 1014. maxdb_connect_errno sample

<?php
$link = maxdb_connect("localhost", "XXXXXXXX", "YYYYYYYYY");

if (!$link) {
   printf("Can't connect to localhost. Errorcode: %d\n", maxdb_connect_errno());
}
?>

The above example would produce the following output:

PHP Warning:  maxdb_connect(): -4008 POS(1) Unknown user name/password combination [08004] <...>
Can't connect to localhost. Errorcode: -4008

Viz také

maxdb_connect()
maxdb_connect_error()
maxdb_errno()
maxdb_error()
maxdb_sqlstate()

Předcházející | Nahoru | Další
maxdb_commit | Domů | maxdb_connect_error


maxdb_connect_error

(PECL maxdb:1.0-7.6.00.38)

maxdb_connect_error — Returns a string description of the last connect error

Popis

string maxdb_connect_error ( void )

The maxdb_connect_error() function is identical to the corresponding maxdb_connect_errno() function in every way, except instead of returning an integer error code the maxdb_connect_error() function will return a string representation of the last error to occur for the last maxdb_connect() call. If no error has occured, this function will return an empty string.

Návratové hodnoty

A string that describes the error. An empty string if no error occurred.

Příklady

Příklad 1015. maxdb_connect_error sample

<?php

$link = maxdb_connect("localhost", "nonexisting_user", "");

if (!$link) {
   printf("Can't connect to localhost. Error: %s\n", maxdb_connect_error());
}
?>

The above example would produce the following output:

PHP Warning:  maxdb_connect(): -4008 POS(1) Unknown user name/password combination <...>
Can't connect to localhost. Error: POS(1) Unknown user name/password combination

Viz také

maxdb_connect()
maxdb_connect_errno()
maxdb_errno()
maxdb_error()
maxdb_sqlstate()

Předcházející | Nahoru | Další
maxdb_connect_errno | Domů | maxdb_connect


maxdb_data_seek

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_data_seek,

(PECL maxdb:1.0-7.6.00.38)

maxdb_data_seek, result->data_seek — Adjusts the result pointer to an arbitary row in the result

Popis

Procedural style:

bool maxdb_data_seek ( resource $result, int $offset )

Object oriented style (method):

class result {
bool data_seek ( int $offset )
}

The maxdb_data_seek() function seeks to an arbitrary result pointer specified by the offset in the result set represented by result. The offset parameter must be between zero and the total number of rows minus one (0..maxdb_num_rows() - 1).

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1018. Object oriented style

<?php
/* Open a connection */
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query = "SELECT name, state FROM hotel.city ORDER BY name";
if ($result = $maxdb->query( $query)) {

   /* seek to row no. 10 */
   $result->data_seek(10);

   /* fetch row */
   $row = $result->fetch_row();

   printf ("City: %s  State: %s\n", $row[0], $row[1]);

   /* free result set*/
   $result->close();
}

/* close connection */
$maxdb->close();
?>

Příklad 1019. Procedural style

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (!$link) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query = "SELECT name, state FROM hotel.city ORDER BY name";

if ($result = maxdb_query($link, $query)) {

   /* seek to row no. 400 */
   maxdb_data_seek($result, 10);

   /* fetch row */
   $row = maxdb_fetch_row($result);

   printf ("City: %s  State: %s\n", $row[0], $row[1]);

   /* free result set*/
   maxdb_free_result($result);
}

/* close connection */
maxdb_close($link);
?>

The above examples would produce the following output:

City: Irvine  State: CA

Viz také

maxdb_store_result()
maxdb_fetch_row()
maxdb_num_rows()

Předcházející | Nahoru | Další
maxdb_connect | Domů | maxdb_debug


maxdb_debug

(PECL maxdb:1.0-7.6.00.38)

maxdb_debug — Performs debugging operations

Popis

void maxdb_debug ( string $debug )

The maxdb_debug() can be used to trace the SQLDBC communication. The following strings can be used as a parameter to maxdb_debug():

TRACE SHORT ON|OFF - Enables/disables method call trace.
TRACE LONG ON|OFF - Enables/disables method argument and detail debug trace.
TRACE PACKET ON|OFF|<size> - Enables/disables packet trace, limiting the size of the traced object to the specified number of bytes, or 1000 if no size is specified.
TRACE SQL ON|OFF - Enables/disables high level api trace.
TRACE TIMESTAMP ON|OFF - Enables/disables a timestamp prefix on each line that is traced.
TRACE SIZE <size> - Limits the size of the trace file to <size> bytes, at least 8192 bytes are required.

Návratové hodnoty

maxdb_debug() doesn't return any value.

Příklady

Příklad 1020. Procedural style

<?php

maxdb_debug("trace packet 200");

$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (!$link) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* close connection */
maxdb_close($link);
?>

The above example produces no output.

Předcházející | Nahoru | Další
maxdb_data_seek | Domů | maxdb_disable_reads_from_master


maxdb_disable_reads_from_master

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_disable_reads_from_master,

(PECL maxdb:1.0-7.6.00.38)

maxdb_disable_reads_from_master, maxdb->disable_reads_from_master — Disable reads from master

Popis

Procedural style:

bool maxdb_disable_reads_from_master ( resource $link )

Object oriented style (method):

class maxdb {
void disable_reads_from_master ( void )
}
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
maxdb_debug | Domů | maxdb_disable_rpl_parse


maxdb_disable_rpl_parse

(PECL maxdb:1.0-7.6.00.38)

maxdb_disable_rpl_parse — Disable RPL parse

Popis

bool maxdb_disable_rpl_parse ( resource $link )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
maxdb_disable_reads_from_master | Domů | maxdb_dump_debug_info


maxdb_dump_debug_info

(PECL maxdb:1.0-7.6.00.38)

maxdb_dump_debug_info — Dump debugging information into the log

Popis

bool maxdb_dump_debug_info ( resource $link )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
maxdb_disable_rpl_parse | Domů | maxdb_embedded_connect


maxdb_embedded_connect

(PECL maxdb:1.0-7.6.00.38)

maxdb_embedded_connect — Open a connection to an embedded MaxDB server

Popis

resource maxdb_embedded_connect ( [string $dbname] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
maxdb_dump_debug_info | Domů | maxdb_enable_reads_from_master


maxdb_enable_reads_from_master

(PECL maxdb:1.0-7.6.00.38)

maxdb_enable_reads_from_master — Enable reads from master

Popis

bool maxdb_enable_reads_from_master ( resource $link )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
maxdb_embedded_connect | Domů | maxdb_enable_rpl_parse


maxdb_enable_rpl_parse

(PECL maxdb:1.0-7.6.00.38)

maxdb_enable_rpl_parse — Enable RPL parse

Popis

bool maxdb_enable_rpl_parse ( resource $link )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
maxdb_enable_reads_from_master | Domů | maxdb_errno


maxdb_errno

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_errno,

(PECL maxdb:1.0-7.6.00.38)

maxdb_errno, maxdb->errno — Returns the error code for the most recent function call

Popis

Procedural style:

int maxdb_errno ( resource $link )

Object oriented style (property):

class maxdb {
int errno
}

The maxdb_errno() function will return the last error code for the most recent MaxDB function call that can succeed or fail with respect to the database link defined by the link parameter. If no errors have occured, this function will return zero.

Návratové hodnoty

An error code value for the last call, if it failed. zero means no error occurred.

Příklady

Příklad 1021. Object oriented style

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

if (!$maxdb->query("SELECT xxx FROM hotel.city")) {
   printf("Errorcode: %d\n", $maxdb->errno);
}

/* close connection */
$maxdb->close();
?>

Příklad 1022. Procedural style

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

if (!maxdb_query($link, "SELECT xxx FROM hotel.city")) {
   printf("Errorcode: %d\n", maxdb_errno($link));
}

/* close connection */
maxdb_close($link);
?>

The above examples would produce the following output:

PHP Warning:  maxdb_query(): -4005 POS(8) Unknown column name:XXX [42000] <...>
Errorcode: -4005

Viz také

maxdb_connect_errno()
maxdb_connect_error()
maxdb_error()
maxdb_sqlstate()

Předcházející | Nahoru | Další
maxdb_enable_rpl_parse | Domů | maxdb_error


maxdb_error

(PECL maxdb:1.0-7.6.00.38)

maxdb_error — Returns a string description of the last error

Popis

Procedural style:

string maxdb_error ( resource $link )

Object oriented style (property)

class maxdb {
string error
}

The maxdb_error() function is identical to the corresponding maxdb_errno() function in every way, except instead of returning an integer error code the maxdb_error() function will return a string representation of the last error to occur for the database connection represented by the link parameter. If no error has occured, this function will return an empty string.

Návratové hodnoty

A string that describes the error. An empty string if no error occurred.

Příklady

Příklad 1023. Object oriented style

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

if (!$maxdb->query("SELECT xxx FROM hotel.city")) {
   printf("Errormessage: %s\n", $maxdb->error);
}

/* close connection */
$maxdb->close();
?>

Příklad 1024. Procedural style

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

if (!maxdb_query($link, "SELECT xxx FROM hotel.city")) {
   printf("Errormessgae: %s\n", maxdb_error($link));
}

/* close connection */
maxdb_close($link);
?>

The above examples would produce the following output:

PHP Warning:  maxdb_query(): -4005 POS(8) Unknown column name:XXX [42000]
Errormessgae: POS(8) Unknown column name:XXX

Viz také

maxdb_connect_errno()
maxdb_connect_error()
maxdb_errno()
maxdb_sqlstate()

Předcházející | Nahoru | Další
maxdb_errno | Domů | maxdb_escape_string


maxdb_escape_string

(PECL maxdb:1.0)

maxdb_escape_string — Alias pro maxdb_real_escape_string()

Popis

Tato funkce je aliasem: maxdb_real_escape_string().

Předcházející | Nahoru | Další
maxdb_error | Domů | maxdb_execute


maxdb_execute

(PECL maxdb:1.0)

maxdb_execute — Alias pro maxdb_stmt_execute()

Popis

Tato funkce je aliasem: maxdb_stmt_execute().

Tento alias funkce je zavržený a existuje pouze z důvodu zpětné kompatibility. Doporučuje se tuto funkci nepoužívat, neboť může být jednoho dne odstraněna z PHP.

Předcházející | Nahoru | Další
maxdb_escape_string | Domů | maxdb_fetch_array


maxdb_fetch

(PECL maxdb:1.0)

maxdb_fetch — Alias pro maxdb_stmt_fetch()

Popis

Tato funkce je aliasem: maxdb_stmt_fetch().

Tento alias funkce je zavržený a existuje pouze z důvodu zpětné kompatibility. Doporučuje se tuto funkci nepoužívat, neboť může být jednoho dne odstraněna z PHP.

Předcházející | Nahoru | Další
maxdb_fetch_row | Domů | maxdb_field_count


maxdb_fetch_array

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_fetch_array,

(PECL maxdb:1.0-7.6.00.38)

maxdb_fetch_array, result->fetch_array — Fetch a result row as an associative, a numeric array, or both

Popis

Procedural style:

mixed maxdb_fetch_array ( resource $result [, int $resulttype] )

Object oriented style (method):

class result {
mixed fetch_array ( [int $resulttype] )
}

Returns an array that corresponds to the fetched row or NULL if there are no more rows for the resultset represented by the result parameter.

maxdb_fetch_array() is an extended version of the maxdb_fetch_row() function. In addition to storing the data in the numeric indices of the result array, the maxdb_fetch_array() function can also store the data in associative indices, using the field names of the result set as keys.

Poznámka: Názvy polí vrácené touto funkcí rozlišují velikost písmen.

Poznámka: Tato funkce nastavuje pole s hodnotou NULL na hodnotu PHP NULL.

If two or more columns of the result have the same field names, the last column will take precedence and overwrite the earlier data. In order to access multiple columns with the same name, the numerically indexed version of the row must be used.

The optional second argument resulttype is a constant indicating what type of array should be produced from the current row data. The possible values for this parameter are the constants MAXDB_ASSOC, MAXDB_ASSOC_UPPER, MAXDB_ASSOC_LOWER, MAXDB_NUM, or MAXDB_BOTH. By default the maxdb_fetch_array() function will assume MAXDB_BOTH, which is a combination of MAXDB_NUM and MAXDB_ASSOC for this parameter.

By using the MAXDB_ASSOC constant this function will behave identically to the maxdb_fetch_assoc(), while MAXDB_NUM will behave identically to the maxdb_fetch_row() function. The final option MAXDB_BOTH will create a single array with the attributes of both.

By using the MAXDB_ASSOC_UPPER constant, the behaviour of this function is identical to the use of MAXDB_ASSOC except the array index of a column is the fieldname in upper case.

By using the MAXDB_ASSOC_LOWER constant, the behaviour of this function is identical to the use of MAXDB_ASSOC except the array index of a column is the fieldname in lower case.

Návratové hodnoty

Returns an array that corresponds to the fetched row or NULL if there are no more rows in resultset.

Příklady

Příklad 1025. Object oriented style

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query = "SELECT name, state FROM hotel.city ORDER by zip";
$result = $maxdb->query($query);

/* numeric array */
$row = $result->fetch_array(MAXDB_NUM);
printf ("%s (%s)\n", $row[0], $row[1]);

/* associative array */
$row = $result->fetch_array(MAXDB_ASSOC);
printf ("%s (%s)\n", $row["NAME"], $row["STATE"]);

/* associative and numeric array */
$row = $result->fetch_array(MAXDB_BOTH);
printf ("%s (%s)\n", $row[0], $row["STATE"]);

/* free result set */
$result->close();

/* close connection */
$maxdb->close();
?>

Příklad 1026. Procedural style

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query = "SELECT name, state FROM hotel.city ORDER by zip";
$result = maxdb_query($link, $query);

/* numeric array */
$row = maxdb_fetch_array($result, MAXDB_NUM);
printf ("%s (%s)\n", $row[0], $row[1]);

/* associative array */
$row = maxdb_fetch_array($result, MAXDB_ASSOC);
printf ("%s (%s)\n", $row["NAME"], $row["STATE"]);

/* associative and numeric array */
$row = maxdb_fetch_array($result, MAXDB_BOTH);
printf ("%s (%s)\n", $row[0], $row["STATE"]);

/* free result set */
maxdb_free_result($result);

/* close connection */
maxdb_close($link);
?>

The above examples would produce the following output:

New York (NY)
New York (NY)
Long Island (NY)

Viz také

maxdb_fetch_assoc()
maxdb_fetch_row()
maxdb_fetch_resource()

Předcházející | Nahoru | Další
maxdb_execute | Domů | maxdb_fetch_assoc


maxdb_fetch_assoc

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_fetch_assoc,

(PECL maxdb:1.0-7.6.00.38)

maxdb_fetch_assoc, maxdb->fetch_assoc — Fetch a result row as an associative array

Popis

Procedural style:

array maxdb_fetch_assoc ( resource $result )

Object oriented style (method):

class result {
array fetch_assoc ( void )
}

Returns an associative array that corresponds to the fetched row or NULL if there are no more rows.

The maxdb_fetch_assoc() function is used to return an associative array representing the next row in the result set for the result represented by the result parameter, where each key in the array represents the name of one of the result set's columns.

If two or more columns of the result have the same field names, the last column will take precedence. To access the other column(s) of the same name, you either need to access the result with numeric indices by using maxdb_fetch_row() or add alias names.

Poznámka: Názvy polí vrácené touto funkcí rozlišují velikost písmen.

Poznámka: Tato funkce nastavuje pole s hodnotou NULL na hodnotu PHP NULL.

Návratové hodnoty

Returns an array that corresponds to the fetched row or NULL if there are no more rows in resultset.

Příklady

Příklad 1027. Object oriented style

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query = "SELECT name, state FROM hotel.city ORDER by zip";

if ($result = $maxdb->query($query)) {

   /* fetch associative array */
   while ($row = $result->fetch_assoc()) {
       printf ("%s (%s)\n", $row["NAME"], $row["STATE"]);
   }

   /* free result set */
   $result->close();
}

/* close connection */
$maxdb->close();
?>

Příklad 1028. Procedural style

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query = "SELECT name, state FROM hotel.city ORDER by zip";

if ($result = maxdb_query($link, $query)) {

   /* fetch associative array */
   while ($row = maxdb_fetch_assoc($result)) {
       printf ("%s (%s)\n", $row["NAME"], $row["STATE"]);
   }

   /* free result set */
   maxdb_free_result($result);
}

/* close connection */
maxdb_close($link);
?>

The above examples would produce the following output:

New York (NY)
New York (NY)
Long Island (NY)
Albany (NY)
Washington (DC)
Washington (DC)
Washington (DC)
Silver Spring (MD)
Daytona Beach (FL)
Deerfield Beach (FL)
Clearwater (FL)
Cincinnati (OH)
Detroit (MI)
Rosemont (IL)
Chicago (IL)
Chicago (IL)
New Orleans (LA)
Dallas (TX)
Los Angeles (CA)
Hollywood (CA)
Long Beach (CA)
Palm Springs (CA)
Irvine (CA)
Santa Clara (CA)
Portland (OR)

Viz také

maxdb_fetch_array()
maxdb_fetch_row()
maxdb_fetch_resource()

Předcházející | Nahoru | Další
maxdb_fetch_array | Domů | maxdb_fetch_field_direct


maxdb_fetch_field

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_fetch_field,

(PECL maxdb:1.0-7.6.00.38)

maxdb_fetch_field, result->fetch_field — Returns the next field in the result set

Popis

Procedural style:

mixed maxdb_fetch_field ( resource $result )

Object oriented style (method):

class result {
mixed fetch_field ( void )
}

The maxdb_fetch_field() returns the definition of one column of a result set as an resource. Call this function repeatedly to retrieve information about all columns in the result set. maxdb_fetch_field() returns FALSE when no more fields are left.

Návratové hodnoty

Returns an resource which contains field definition informations or FALSE if no field information is available.

Tabulka 154. Object properties

Property | Description
name | The name of the column
max_length | The maximum width of the field for the result set.
type | The data type used for this field
decimals | The number of decimals used (for integer fields)

Příklady

Příklad 1031. Object oriented style

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query = "SELECT name, cno from hotel.customer ORDER BY cno";

if ($result = $maxdb->query($query)) {

   /* Get field information for all columns */
   while ($finfo = $result->fetch_field()) {

       printf("Name:     %s\n", $finfo->name);
       printf("Table:    %s\n", $finfo->table);
       printf("max. Len: %d\n", $finfo->max_length);
       printf("Flags:    %d\n", $finfo->flags);
       printf("Type:     %d\n\n", $finfo->type);
   }
   $result->close();
}

/* close connection */
$maxdb->close();
?>

Příklad 1032. Procedural style

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query = "SELECT name, cno from hotel.customer ORDER BY cno";

if ($result = maxdb_query($link, $query)) {

   /* Get field information for all fields */
   while ($finfo = maxdb_fetch_field($result)) {

       printf("Name:     %s\n", $finfo->name);
       printf("Table:    %s\n", $finfo->table);
       printf("max. Len: %d\n", $finfo->max_length);
       printf("Flags:    %d\n", $finfo->flags);
       printf("Type:     %d\n\n", $finfo->type);
   }
   maxdb_free_result($result);
}

/* close connection */
maxdb_close($link);
?>

The above examples would produce the following output:

Name:     NAME
Table:
max. Len: 10
Flags:    -1
Type:     2

Name:     CNO
Table:
max. Len: 4
Flags:    -1
Type:     0

Viz také

maxdb_num_fields()
maxdb_fetch_field_direct()
maxdb_fetch_fields()
maxdb_field_seek()

Předcházející | Nahoru | Další
maxdb_fetch_field_direct | Domů | maxdb_fetch_fields


maxdb_fetch_field_direct

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_fetch_field_direct,

(PECL maxdb:1.0-7.6.00.38)

maxdb_fetch_field_direct, result->fetch_field_direct — Fetch meta-data for a single field

Popis

Procedural style:

mixed maxdb_fetch_field_direct ( resource $result, int $fieldnr )

Object oriented style (method):

class result {
mixed fetch_field_direct ( int $fieldnr )
}

maxdb_fetch_field_direct() returns an resource which contains field definition informations from specified resultset. The value of fieldnr must be in the range from 0 to number of fields - 1.

Návratové hodnoty

Returns an resource which contains field definition informations or FALSE if no field information for specified fieldnr is available.

Tabulka 153. Object attributes

Attribute | Description
name | The name of the column
max_length | The maximum width of the field for the result set.
type | The data type used for this field
decimals | The number of decimals used (for integer fields)

Příklady

Příklad 1029. Object oriented style

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query = "SELECT name, cno from hotel.customer ORDER BY name";

if ($result = $maxdb->query($query)) {

   /* Get field information for column 'SurfaceArea' */
   $finfo = $result->fetch_field_direct(1);

   printf("Name:     %s\n", $finfo->name);
   printf("Table:    %s\n", $finfo->table);
   printf("max. Len: %d\n", $finfo->max_length);
   printf("Flags:    %d\n", $finfo->flags);
   printf("Type:     %d\n", $finfo->type);

   $result->close();
}

/* close connection */
$maxdb->close();
?>

Příklad 1030. Procedural style

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query = "SELECT name, cno from hotel.customer ORDER BY name";

if ($result = maxdb_query($link, $query)) {

   /* Get field information for column 'cno' */
   $finfo = maxdb_fetch_field_direct($result, 1);

   printf("Name:     %s\n", $finfo->name);
   printf("Table:    %s\n", $finfo->table);
   printf("max. Len: %d\n", $finfo->max_length);
   printf("Flags:    %d\n", $finfo->flags);
   printf("Type:     %d\n", $finfo->type);

   maxdb_free_result($result);
}

/* close connection */
maxdb_close($link);
?>

The above examples would produce the following output:

Name:     CNO
Table:
max. Len: 4
Flags:    -1
Type:     0

Viz také

maxdb_num_fields()
maxdb_fetch_field()
maxdb_fetch_fields()

Předcházející | Nahoru | Další
maxdb_fetch_assoc | Domů | maxdb_fetch_field


maxdb_fetch_fields

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_fetch_fields,

(PECL maxdb:1.0-7.6.00.38)

maxdb_fetch_fields, result->fetch_fields — Returns an array of resources representing the fields in a result set

Popis

Procedural Style:

mixed maxdb_fetch_fields ( resource $result )

Object oriented style (method):

class result {
mixed fetch_fields ( void )
}

This function serves an identical purpose to the maxdb_fetch_field() function with the single difference that, instead of returning one resource at a time for each field, the columns are returned as an array of resources.

Návratové hodnoty

Returns an array of resources which contains field definition informations or FALSE if no field information is available.

Tabulka 155. Object properties

Property | Description
name | The name of the column
max_length | The maximum width of the field for the result set.
type | The data type used for this field
decimals | The number of decimals used (for integer fields)

Příklady

Příklad 1033. Object oriented style

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query = "SELECT name, cno from hotel.customer ORDER BY cno";

if ($result = $maxdb->query($query)) {

   /* Get field information for all columns */
   $finfo = $result->fetch_fields();

   foreach ($finfo as $val) {
       printf("Name:     %s\n", $val->name);
       printf("Table:    %s\n", $val->table);
       printf("max. Len: %d\n", $val->max_length);
       printf("Flags:    %d\n", $val->flags);
       printf("Type:     %d\n\n", $val->type);
   }
   $result->close();
}

/* close connection */
$maxdb->close();
?>

Příklad 1034. Procedural style

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query = "SELECT name, cno from hotel.customer ORDER BY cno";

if ($result = maxdb_query($link, $query)) {

   /* Get field information for all columns */
   $finfo = maxdb_fetch_fields($result);

   foreach ($finfo as $val) {
       printf("Name:     %s\n", $val->name);
       printf("Table:    %s\n", $val->table);
       printf("max. Len: %d\n", $val->max_length);
       printf("Flags:    %d\n", $val->flags);
       printf("Type:     %d\n\n", $val->type);
   }
   maxdb_free_result($result);
}

/* close connection */
maxdb_close($link);
?>

The above examples would produce the following output:

Name:     NAME
Table:
max. Len: 10
Flags:    -1
Type:     2

Name:     CNO
Table:
max. Len: 4
Flags:    -1
Type:     0

Viz také

maxdb_num_fields()
maxdb_fetch_field()
maxdb_fetch_field_direct()

Předcházející | Nahoru | Další
maxdb_fetch_field | Domů | maxdb_fetch_lengths


maxdb_fetch_lengths

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_fetch_lengths,

(PECL maxdb:1.0-7.6.00.38)

maxdb_fetch_lengths, result->lengths — Returns the lengths of the columns of the current row in the result set

Popis

Procedural style:

array maxdb_fetch_lengths ( resource $result )

Object oriented style (property):

class result {
array lengths
}

The maxdb_fetch_lengths() function returns an array containing the lengths of every column of the current row within the result set represented by the result parameter. If successful, a numerically indexed array representing the lengths of each column is returned or FALSE on failure.

Návratové hodnoty

An array of integers representing the size of each column (not including any terminating null characters). FALSE if an error occurred.

maxdb_fetch_lengths() is valid only for the current row of the result set. It returns FALSE if you call it before calling maxdb_fetch_row/array/resource or after retrieving all rows in the result.

Příklady

Příklad 1035. Object oriented style

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query = "SELECT * from hotel.customer WHERE cno = 3000";

if ($result = $maxdb->query($query)) {

   $row = $result->fetch_row();

   /* display column lengths */
   foreach ($result->lengths as $i => $val) {
       printf("Field %2d has Length %2d\n", $i+1, $val);
   }
   $result->close();
}

/* close connection */
$maxdb->close();
?>

Příklad 1036. Procedural style

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query = "SELECT * from hotel.customer WHERE cno = 3000";

if ($result = maxdb_query($link, $query)) {

   $row = maxdb_fetch_row($result);

   /* display column lengths */
   foreach (maxdb_fetch_lengths($result) as $i => $val) {
       printf("Field %2d has Length %2d\n", $i+1, $val);
   }
   maxdb_free_result($result);
}

/* close connection */
maxdb_close($link);
?>

The above examples would produce the following output:

Field  1 has Length  4
Field  2 has Length  3
Field  3 has Length  5
Field  4 has Length  6
Field  5 has Length  5
Field  6 has Length 21

Předcházející | Nahoru | Další
maxdb_fetch_fields | Domů | maxdb_fetch_object


maxdb_fetch_object

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_fetch_object,

(PECL maxdb:1.0-7.6.00.38)

maxdb_fetch_object, result->fetch_object — Returns the current row of a result set as an object

Popis

Procedural style:

object maxdb_fetch_object ( object $result )

Object oriented style (method):

class result {
object fetch_object ( void )
}

The maxdb_fetch_object() will return the current row result set as an object where the attributes of the object represent the names of the fields found within the result set. If no more rows exist in the current result set, NULL is returned.

Návratové hodnoty

Returns an object that corresponds to the fetched row or NULL if there are no more rows in resultset.

Poznámka: Názvy polí vrácené touto funkcí rozlišují velikost písmen.

Poznámka: Tato funkce nastavuje pole s hodnotou NULL na hodnotu PHP NULL.

Příklady

Příklad 1037. Object oriented style

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query = "SELECT name, state FROM hotel.city ORDER by zip";

if ($result = $maxdb->query($query)) {

   /* fetch object array */
   while ($obj = $result->fetch_object()) {
       printf ("%s (%s)\n", $obj->NAME, $obj->STATE);
   }

   /* free result set */
   $result->close();
}

/* close connection */
$maxdb->close();
?>

Příklad 1038. Procedural style

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query = "SELECT name, state FROM hotel.city ORDER by zip";

if ($result = maxdb_query($link, $query)) {

   /* fetch object array */
   while ($obj = maxdb_fetch_object($result)) {
       printf ("%s (%s)\n", $obj->NAME, $obj->STATE);
   }

   /* free result set */
   maxdb_free_result($result);
}

/* close connection */
maxdb_close($link);
?>

The above examples would produce the following output:

New York (NY)
New York (NY)
Long Island (NY)
Albany (NY)
Washington (DC)
Washington (DC)
Washington (DC)
Silver Spring (MD)
Daytona Beach (FL)
Deerfield Beach (FL)
Clearwater (FL)
Cincinnati (OH)
Detroit (MI)
Rosemont (IL)
Chicago (IL)
Chicago (IL)
New Orleans (LA)
Dallas (TX)
Los Angeles (CA)
Hollywood (CA)
Long Beach (CA)
Palm Springs (CA)
Irvine (CA)
Santa Clara (CA)
Portland (OR)

Viz také

maxdb_fetch_array()
maxdb_fetch_assoc()
maxdb_fetch_row()

Předcházející | Nahoru | Další
maxdb_fetch_lengths | Domů | maxdb_fetch_row


maxdb_fetch_row

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_fetch_row,

(PECL maxdb:1.0-7.6.00.38)

maxdb_fetch_row, result->fetch_row — Get a result row as an enumerated array

Popis

Procedural style:

mixed maxdb_fetch_row ( resource $result )

Object oriented style (method):

class result {
mixed fetch_row ( void )
}

Returns an array that corresponds to the fetched row, or NULL if there are no more rows.

maxdb_fetch_row() fetches one row of data from the result set represented by result and returns it as an enumerated array, where each column is stored in an array offset starting from 0 (zero). Each subsequent call to the maxdb_fetch_row() function will return the next row within the result set, or FALSE if there are no more rows.

Návratové hodnoty

maxdb_fetch_row() returns an array that corresponds to the fetched row or NULL if there are no more rows in result set.

Poznámka: Tato funkce nastavuje pole s hodnotou NULL na hodnotu PHP NULL.

Příklady

Příklad 1039. Object oriented style

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query = "SELECT name, state FROM hotel.city ORDER by zip";

if ($result = $maxdb->query($query)) {

   /* fetch enumerated array */
   while ($row = $result->fetch_row()) {
       printf ("%s (%s)\n", $row[0], $row[1]);
   }

   /* free result set */
   $result->close();
}

/* close connection */
$maxdb->close();
?>

Příklad 1040. Procedural style

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query = "SELECT name, state FROM hotel.city ORDER by zip";

if ($result = maxdb_query($link, $query)) {

   /* fetch enumerated array */
   while ($row = maxdb_fetch_row($result)) {
       printf ("%s (%s)\n", $row[0], $row[1]);
   }

   /* free result set */
   maxdb_free_result($result);
}

/* close connection */
maxdb_close($link);
?>

The above examples would produce the following output:

New York (NY)
New York (NY)
Long Island (NY)
Albany (NY)
Washington (DC)
Washington (DC)
Washington (DC)
Silver Spring (MD)
Daytona Beach (FL)
Deerfield Beach (FL)
Clearwater (FL)
Cincinnati (OH)
Detroit (MI)
Rosemont (IL)
Chicago (IL)
Chicago (IL)
New Orleans (LA)
Dallas (TX)
Los Angeles (CA)
Hollywood (CA)
Long Beach (CA)
Palm Springs (CA)
Irvine (CA)
Santa Clara (CA)
Portland (OR)

Viz také

maxdb_fetch_array()
maxdb_fetch_assoc()
maxdb_fetch_resource()

Předcházející | Nahoru | Další
maxdb_fetch_object | Domů | maxdb_fetch


maxdb_field_count

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_field_count,

(PECL maxdb:1.0-7.6.00.38)

maxdb_field_count, maxdb->field_count — Returns the number of columns for the most recent query

Popis

Procedural style:

int maxdb_field_count ( resource $link )

Object oriented style (method):

class maxdb {
int field_count ( void )
}

Returns the number of columns for the most recent query on the connection represented by the link parameter. This function can be useful when using the maxdb_store_result() function to determine if the query should have produced a non-empty result set or not without knowing the nature of the query.

Návratové hodnoty

An integer representing the number of fields in a result set.

Příklady

Příklad 1041. Object oriented style

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

maxdb_report (MAXDB_REPORT_OFF);
$maxdb->query("DROP TABLE friends");
maxdb_report (MAXDB_REPORT_ERROR);

$maxdb->query( "CREATE TABLE friends (id int, name varchar(20))");

$maxdb->query( "INSERT INTO friends VALUES (1,'Hartmut')");
$maxdb->query( "INSERT INTO friends VALUES (2, 'Ulf')");

if ($maxdb->field_count()) {
   /* this was a select/show or describe query */
   $result = $maxdb->store_result();

   /* process resultset */
   $row = $result->fetch_row();

   /* free resultset */
   $result->close();
}

/* close connection */
$maxdb->close();
?>

Příklad 1042. Procedural style

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

maxdb_report (MAXDB_REPORT_OFF);
maxdb_query($link,"DROP TABLE friends");
maxdb_report (MAXDB_REPORT_ERROR);

maxdb_query($link, "CREATE TABLE friends (id int, name varchar(20))");

maxdb_query($link, "INSERT INTO friends VALUES (1,'Hartmut')");
maxdb_query($link, "INSERT INTO friends VALUES (2, 'Ulf')");

if (maxdb_field_count($link)) {
   /* this was a select/show or describe query */
   $result = maxdb_store_result($link);

   /* process resultset */
   $row = maxdb_fetch_row($result);

   /* free resultset */
   maxdb_free_result($result);
}

/* close connection */
maxdb_close($link);
?>

The above example produces no output.

Předcházející | Nahoru | Další
maxdb_fetch | Domů | maxdb_field_seek


maxdb_field_seek

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_field_seek,

(PECL maxdb:1.0-7.6.00.38)

maxdb_field_seek, result->field_seek — Set result pointer to a specified field offset

Popis

Procedural style:

bool maxdb_field_seek ( resource $result, int $fieldnr )

Object oriented style (method):

class result {
bool field_seek ( int $fieldnr )
}

Sets the field cursor to the given offset. The next call to maxdb_fetch_field() will retrieve the field definition of the column associated with that offset.

Poznámka: To seek to the beginning of a row, pass an offset value of zero.

Návratové hodnoty

maxdb_field_seek() returns previuos value of field cursor.

Příklady

Příklad 1043. Object oriented style

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query = "SELECT name, cno from hotel.customer ORDER BY cno";

if ($result = $maxdb->query($query)) {

   /* Get field information for 2nd column */
   $result->field_seek(1);
   $finfo = $result->fetch_field();

   printf("Name:     %s\n", $finfo->name);
   printf("Table:    %s\n", $finfo->table);
   printf("max. Len: %d\n", $finfo->max_length);
   printf("Flags:    %d\n", $finfo->flags);
   printf("Type:     %d\n\n", $finfo->type);

   $result->close();
}

/* close connection */
$maxdb->close();
?>

Příklad 1044. Procedural style

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query = "SELECT name, cno from hotel.customer ORDER BY cno";

if ($result = maxdb_query($link, $query)) {

   /* Get field information for 2nd column */
   maxdb_field_seek($result, 1);
   $finfo = maxdb_fetch_field($result);

   printf("Name:     %s\n", $finfo->name);
   printf("Table:    %s\n", $finfo->table);
   printf("max. Len: %d\n", $finfo->max_length);
   printf("Flags:    %d\n", $finfo->flags);
   printf("Type:     %d\n\n", $finfo->type);

   maxdb_free_result($result);
}

/* close connection */
maxdb_close($link);
?>

The above examples would produce the following output:

Name:     NAME
Table:
max. Len: 10
Flags:    -1
Type:     2

Viz také

maxdb_fetch_field()

Předcházející | Nahoru | Další
maxdb_field_count | Domů | maxdb_field_tell


maxdb_field_tell

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_field_tell,

(PECL maxdb:1.0-7.6.00.38)

maxdb_field_tell, result->current_field — Get current field offset of a result pointer

Popis

Procedural style:

int maxdb_field_tell ( resource $result )

Object oriented style (property):

class result {
int current_field
}

Returns the position of the field cursor used for the last maxdb_fetch_field() call. This value can be used as an argument to maxdb_field_seek().

Návratové hodnoty

Returns current offset of field cursor.

Příklady

Příklad 1045. Object oriented style

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query = "SELECT name, cno from hotel.customer ORDER BY cno";

if ($result = $maxdb->query($query)) {

   /* Get field information for all columns */
   while ($finfo = $result->fetch_field()) {

       /* get fieldpointer offset */
       $currentfield = $result->current_field;

       printf("Column    %d:\n", $currentfield);
       printf("Name:     %s\n", $finfo->name);
       printf("Table:    %s\n", $finfo->table);
       printf("max. Len: %d\n", $finfo->max_length);
       printf("Flags:    %d\n", $finfo->flags);
       printf("Type:     %d\n\n", $finfo->type);
   }
   $result->close();
}

/* close connection */
$maxdb->close();
?>

Příklad 1046. Procedural style

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query = "SELECT name, cno from hotel.customer ORDER BY cno";

if ($result = maxdb_query($link, $query)) {

   /* Get field information for all fields */
   while ($finfo = maxdb_fetch_field($result)) {

       /* get fieldpointer offset */
       $currentfield = maxdb_field_tell($result);

       printf("Column    %d:\n", $currentfield);
       printf("Name:     %s\n", $finfo->name);
       printf("Table:    %s\n", $finfo->table);
       printf("max. Len: %d\n", $finfo->max_length);
       printf("Flags:    %d\n", $finfo->flags);
       printf("Type:     %d\n\n", $finfo->type);
   }
   maxdb_free_result($result);
}

/* close connection */
maxdb_close($link);
?>

The above examples would produce the following output:

Column    1:
Name:     NAME
Table:
max. Len: 10
Flags:    -1
Type:     2

Column    2:
Name:     CNO
Table:
max. Len: 4
Flags:    -1
Type:     0

Viz také

maxdb_fetch_field()
maxdb_field_seek()

Předcházející | Nahoru | Další
maxdb_field_seek | Domů | maxdb_free_result


maxdb_free_result

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_free_result,

(PECL maxdb:1.0-7.6.00.38)

maxdb_free_result, result->free — Frees the memory associated with a result

Popis

Procedural style:

void maxdb_free_result ( resource $result )

Object oriented style (method):

class result {
void free ( void )
}

The maxdb_free_result() function frees the memory associated with the result represented by the result parameter, which was allocated by maxdb_query(), maxdb_store_result() or maxdb_use_result().

Poznámka: You should always free your result with maxdb_free_result(), when your result resource is not needed anymore.

Návratové hodnoty

This function doesn't return any value.

Viz také

maxdb_query()
maxdb_stmt_store_result()
maxdb_store_result()
maxdb_use_result()

Předcházející | Nahoru | Další
maxdb_field_tell | Domů | maxdb_get_client_info


maxdb_get_client_info

(PECL maxdb:1.0-7.6.00.38)

maxdb_get_client_info — Returns the MaxDB client version as a string

Popis

string maxdb_get_client_info ( void )

The maxdb_get_client_info() function is used to return a string representing the client version being used in the MaxDB extension.

Návratové hodnoty

A string that represents the MaxDB client library version

Příklady

Příklad 1047. maxdb_get_client_info

<?php

/* We don't need a connection to determine
   the version of MaxDB client library */

printf("Client library version: %s\n", maxdb_get_client_info());
?>

The above examples would produce the following output:

Client library version: libSQLDBC <...>

Viz také

maxdb_get_client_version()
maxdb_get_server_info()
maxdb_get_server_version()

Předcházející | Nahoru | Další
maxdb_free_result | Domů | maxdb_get_client_version


maxdb_get_client_version

(PECL maxdb:1.0-7.6.00.38)

maxdb_get_client_version — Get MaxDB client info

Popis

int maxdb_get_client_version ( void )

Returns client version number as an integer.

Návratové hodnoty

A number that represents the MaxDB client library version in format: main_version*10000 + minor_version *100 + sub_version. For example, 7.5.0 is returned as 70500.

This is useful to quickly determine the version of the client library to know if some capability exists.

Příklady

Příklad 1048. maxdb_get_client_version

<?php

/* We don't need a connection to determine
   the version of MaxDB client library */

printf("Client library version: %d\n", maxdb_get_client_version());
?>

The above examples would produce the following output:

Client library version: 7.<...>

Viz také

maxdb_get_client_info()
maxdb_get_server_info()
maxdb_get_server_version()

Předcházející | Nahoru | Další
maxdb_get_client_info | Domů | maxdb_get_host_info


maxdb_get_host_info

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_get_host_info,

(PECL maxdb:1.0-7.6.00.38)

maxdb_get_host_info, maxdb->get_host_info — Returns a string representing the type of connection used

Popis

Procdural style:

string maxdb_get_host_info ( resource $link )

Object oriented style (property):

class maxdb {
string host_info
}

The maxdb_get_host_info() function returns a string describing the connection represented by the link parameter is using.

Návratové hodnoty

A character string representing the server hostname and the connection type.

Příklady

Příklad 1049. Object oriented style

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* print host information */
printf("Host info: %s\n", $maxdb->host_info);

/* close connection */
$maxdb->close();
?>

Příklad 1050. Procedural style

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* print host information */
printf("Host info: %s\n", maxdb_get_host_info($link));

/* close connection */
maxdb_close($link);
?>

The above examples would produce the following output:

Host info: localhost

Viz také

maxdb_get_proto_info()

Předcházející | Nahoru | Další
maxdb_get_client_version | Domů | maxdb_get_metadata


maxdb_get_metadata

(PECL maxdb:1.0)

maxdb_get_metadata — Alias pro maxdb_stmt_result_metadata()

Popis

Tato funkce je aliasem: maxdb_stmt_result_metadata().

Tento alias funkce je zavržený a existuje pouze z důvodu zpětné kompatibility. Doporučuje se tuto funkci nepoužívat, neboť může být jednoho dne odstraněna z PHP.

Předcházející | Nahoru | Další
maxdb_get_host_info | Domů | maxdb_get_proto_info


maxdb_get_proto_info

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_get_proto_info,

(PECL maxdb:1.0-7.6.00.38)

maxdb_get_proto_info, maxdb->protocol_version — Returns the version of the MaxDB protocol used

Popis

Procedural style:

int maxdb_get_proto_info ( resource $link )

Object oriented style (property):

class maxdb {
string protocol_version
}

Returns an integer representing the MaxDB protocol version used by the connection represented by the link parameter.

Návratové hodnoty

Returns an integer representing the protocol version (constant 10).

Příklady

Příklad 1051. Object oriented style

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* print protocol version */
printf("Protocol version: %d\n", $maxdb->protocol_version);

/* close connection */
$maxdb->close();
?>

Příklad 1052. Procedural style

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* print protocol version */
printf("Protocol version: %d\n", maxdb_get_proto_info($link));

/* close connection */
maxdb_close($link);
?>

The above examples would produce the following output:

Protocol version: 10

Viz také

maxdb_get_host_info()

Předcházející | Nahoru | Další
maxdb_get_metadata | Domů | maxdb_get_server_info


maxdb_get_server_info

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_get_server_info,

(PECL maxdb:1.0-7.6.00.38)

maxdb_get_server_info, maxdb->server_info — Returns the version of the MaxDB server

Popis

Procedural style:

string maxdb_get_server_info ( resource $link )

Object oriented style (property):

class maxdb {
string server_info
}

Returns a string representing the version of the MaxDB server that the MaxDB extension is connected to (represented by the link parameter).

Návratové hodnoty

A character string representing the server version.

Příklady

Příklad 1053. Object oriented style

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* print server version */
printf("Server version: %s\n", $maxdb->server_info);

/* close connection */
$maxdb->close();
?>

Příklad 1054. Procedural style

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* print server version */
printf("Server version: %s\n", maxdb_get_server_info($link));

/* close connection */
maxdb_close($link);
?>

The above examples would produce the following output:

Server version: Kernel    7<...>

Viz také

maxdb_get_client_info()
maxdb_get_client_version()
maxdb_get_server_version()

Předcházející | Nahoru | Další
maxdb_get_proto_info | Domů | maxdb_get_server_version


maxdb_get_server_version

(PECL maxdb:1.0-7.6.00.38)

maxdb_get_server_version — Returns the version of the MaxDB server as an integer

Popis

Procedural style:

int maxdb_get_server_version ( resource $link )

Object oriented style (property):

class maxdb {
int server_version
}

The maxdb_get_server_version() function returns the version of the server connected to (represented by the link parameter) as an integer.

The form of this version number is main_version * 10000 + minor_version * 100 + sub_version (i.e. version 7.5.0 is 70500).

Návratové hodnoty

An integer representing the server version.

Příklady

Příklad 1055. Object oriented style

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* print server version */
printf("Server version: %d\n", $maxdb->server_version);

/* close connection */
$maxdb->close();
?>

Příklad 1056. Procedural style

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* print server version */
printf("Server version: %d\n", maxdb_get_server_version($link));

/* close connection */
maxdb_close($link);
?>

The above examples would produce the following output:

Server version: 7<...>

Viz také

maxdb_get_client_info()
maxdb_get_client_version()
maxdb_get_server_info()

Předcházející | Nahoru | Další
maxdb_get_server_info | Domů | maxdb_info


maxdb_info

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_info,

(PECL maxdb:1.0-7.6.00.38)

maxdb_info, maxdb->info — Retrieves information about the most recently executed query

Popis

Procedural style:

string maxdb_info ( resource $link )

Object oriented style (property)

class maxdb {
string info
}

The maxdb_info() function returns a string providing information about the last query executed. The nature of this string is provided below:

Tabulka 156. Possible maxdb_info return values

Query type | Example result string
INSERT INTO...SELECT... | Records: 100 Duplicates: 0 Warnings: 0
INSERT INTO...VALUES (...),(...),(...) | Records: 3 Duplicates: 0 Warnings: 0
LOAD DATA INFILE ... | Records: 1 Deleted: 0 Skipped: 0 Warnings: 0
ALTER TABLE ... | Records: 3 Duplicates: 0 Warnings: 0
UPDATE ... | Rows matched: 40 Changed: 40 Warnings: 0

Poznámka: Queries which do not fall into one of the above formats are not supported. In these situations, maxdb_info() will return an empty string.

Návratové hodnoty

A character string representing additional information about the most recently executed query.

Příklady

Příklad 1057. Object oriented style

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$maxdb->query("CREATE TABLE temp.t1 LIKE hotel.city");

/* INSERT INTO .. SELECT */
$maxdb->query("INSERT INTO temp.t1 SELECT * FROM hotel.city");
printf("%s\n", $maxdb->info);

/* close connection */
$maxdb->close();
?>

Příklad 1058. Procedural style

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

maxdb_query($link, "CREATE TABLE temp.t1 LIKE hotel.city");

/* INSERT INTO .. SELECT */
maxdb_query($link, "INSERT INTO temp.t1 SELECT * FROM hotel.city");
printf("%s\n", maxdb_info($link));

/* close connection */
maxdb_close($link);
?>

The above examples would produce the following output:

Records: 25 Duplicates: 0 Warnings: 0

Viz také

maxdb_affected_rows()
maxdb_warning_count()
maxdb_num_rows()

Předcházející | Nahoru | Další
maxdb_get_server_version | Domů | maxdb_init


maxdb_init

(PECL maxdb:1.0-7.6.00.38)

maxdb_init — Initializes MaxDB and returns an resource for use with maxdb_real_connect

Popis

resource maxdb_init ( void )

Allocates or initializes a MaxDB resource suitable for maxdb_options() and maxdb_real_connect().

Poznámka: Any subsequent calls to any maxdb function (except maxdb_options()) will fail until maxdb_real_connect() was called.

Návratové hodnoty

Returns an resource.

Viz také

maxdb_options()
maxdb_close()
maxdb_real_connect()
maxdb_connect()

Předcházející | Nahoru | Další
maxdb_info | Domů | maxdb_insert_id


maxdb_insert_id

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_insert_id,

(PECL maxdb:1.0-7.6.00.38)

maxdb_insert_id, maxdb->insert_id — Returns the auto generated id used in the last query

Popis

Procedural style:

mixed maxdb_insert_id ( resource $link )

Object oriented style (property):

class maxdb {
mixed insert_id
}

The maxdb_insert_id() function returns the ID generated by a query on a table with a column having the DEFAULT SERIAL attribute. If the last query wasn't an INSERT or UPDATE statement or if the modified table does not have a column with the DEFAULT SERIAL attribute, this function will return zero.

Návratové hodnoty

The value of the DEFAULT SERIAL field that was updated by the previous query. Returns zero if there was no previous query on the connection or if the query did not update an DEFAULT_SERIAL value.

Poznámka: If the number is greater than maximal int value, maxdb_insert_id() will return a string.

Příklady

Příklad 1059. Object oriented style

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

maxdb_report (MAXDB_REPORT_OFF);
$maxdb->query("DROP TABLE mycity");
maxdb_report (MAXDB_REPORT_ERROR);

$maxdb->query("CREATE TABLE mycity LIKE hotel.city");
$maxdb->query("ALTER TABLE mycity ADD id FIXED(11) DEFAULT SERIAL");

$query = "INSERT INTO mycity (zip,name,state) VALUES ('12203','Albany' ,'NY')";
$maxdb->query($query);

printf ("New Record has id %d.\n", $maxdb->insert_id);

/* drop table */
$maxdb->query("DROP TABLE mycity");

/* close connection */
$maxdb->close();
?>

Příklad 1060. Procedural style

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

maxdb_report (MAXDB_REPORT_OFF);
maxdb_query($link,"DROP TABLE mycity");
maxdb_report (MAXDB_REPORT_ERROR);

maxdb_query($link, "CREATE TABLE mycity LIKE hotel.city");
maxdb_query($link, "ALTER TABLE mycity ADD id FIXED(11) DEFAULT SERIAL");

$query = "INSERT INTO mycity (zip,name,state) VALUES ('12203','Albany' ,'NY')";
maxdb_query($link, $query);

printf ("New Record has id %d.\n", maxdb_insert_id($link));

/* drop table */
maxdb_query($link, "DROP TABLE mycity");

/* close connection */
maxdb_close($link);
?>

The above examples would produce the following output:

New Record has id 1.

Předcházející | Nahoru | Další
maxdb_init | Domů | maxdb_kill


maxdb_kill

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_kill,

(PECL maxdb:1.0-7.6.00.38)

maxdb_kill, maxdb->kill — Disconnects from a MaxDB server

Popis

Procedural style:

bool maxdb_kill ( resource $link, int $processid )

Object oriented style (method)

class maxdb {
bool kill ( int $processid )
}

This function is used to disconnect from a MaxDB server specified by the processid parameter.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1061. Object oriented style

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* determine our thread id */
$thread_id = $maxdb->thread_id;

/* Kill connection */
$maxdb->kill($thread_id);

/* This should produce an error */
if (!$maxdb->query("CREATE TABLE myCity LIKE City")) {
   printf("Error: %s\n", $maxdb->error);
   exit;
}

/* close connection */
$maxdb->close();
?>

Příklad 1062. Procedural style

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* determine our thread id */
$thread_id = maxdb_thread_id($link);

/* Kill connection */
maxdb_kill($link, $thread_id);

/* This should produce an error */
if (!maxdb_query($link, "CREATE TABLE myCity LIKE City")) {
   printf("Error: %s\n", maxdb_error($link));
   exit;
}

/* close connection */
maxdb_close($link);
?>

The above examples would produce the following output:

Error: Session not connected

Viz také

maxdb_thread_id()

Předcházející | Nahoru | Další
maxdb_insert_id | Domů | maxdb_master_query


maxdb_master_query

(PECL maxdb:1.0-7.6.00.38)

maxdb_master_query — Enforce execution of a query on the master in a master/slave setup

Popis

bool maxdb_master_query ( resource $link, string $query )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
maxdb_kill | Domů | maxdb_more_results


maxdb_more_results

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_more_results,

(PECL maxdb:1.0-7.6.00.38)

maxdb_more_results, maxdb->more_results — Check if there any more query results from a multi query

Popis

bool maxdb_more_results ( resource $link )

maxdb_more_results() indicates if one or more result sets are available from a previous call to maxdb_multi_query().

Návratové hodnoty

Always FALSE.

Příklady

See maxdb_multi_query().

Viz také

maxdb_multi_query()
maxdb_next_result()
maxdb_store_result()
maxdb_use_result()

Předcházející | Nahoru | Další
maxdb_master_query | Domů | maxdb_multi_query


maxdb_multi_query

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_multi_query,

(PECL maxdb:1.0-7.6.00.38)

maxdb_multi_query, maxdb->multi_query — Performs a query on the database

Popis

Procedural style:

bool maxdb_multi_query ( resource $link, string $query )

Object oriented style (method):

class maxdb {
bool multi_query ( string $query )
}

The maxdb_multi_query() works like the function maxdb_query(). Multiple queries are not yet supported.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1063. Object oriented style

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query  = "SELECT * FROM dual";

/* execute multi query */
if ($maxdb->multi_query($query)) {
   do {
       /* store first result set */
       if ($result = $maxdb->store_result()) {
           while ($row = $result->fetch_row()) {
               printf("%s\n", $row[0]);
           }
           $result->close();
       }
       /* print divider */
       if ($maxdb->more_results()) {
           printf("-----------------\n");
       }
   } while ($maxdb->next_result());
}

/* close connection */
$maxdb->close();
?>

Příklad 1064. Procedural style

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query = "SELECT * FROM dual";

/* execute multi query */
if (maxdb_multi_query($link, $query)) {
   do {
       /* store first result set */
       if ($result = maxdb_store_result($link)) {
           while ($row = maxdb_fetch_row($result)) {
               printf("%s\n", $row[0]);
           }
           maxdb_free_result($result);
       }
       /* print divider */
       if (maxdb_more_results($link)) {
           printf("-----------------\n");
       }
   } while (maxdb_next_result($link));
}

/* close connection */
maxdb_close($link);
?>

The above examples would produce the following output:

a

Viz také

maxdb_use_result()
maxdb_store_result()
maxdb_next_result()
maxdb_more_results()

Předcházející | Nahoru | Další
maxdb_more_results | Domů | maxdb_next_result


maxdb_next_result

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_next_result,

(PECL maxdb:1.0-7.6.00.38)

maxdb_next_result, maxdb->next_result — Prepare next result from multi_query

Popis

bool maxdb_next_result ( resource $link )

Since multiple queries are not yet supported, maxdb_next_result() returns always FALSE.

Návratové hodnoty

Returns FALSE.

Viz také

maxdb_multi_query()
maxdb_more_results()
maxdb_store_result()
maxdb_use_result()

Předcházející | Nahoru | Další
maxdb_multi_query | Domů | maxdb_num_fields


maxdb_num_fields

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_num_fields,

(PECL maxdb:1.0-7.6.00.38)

maxdb_num_fields, result->field_count — Get the number of fields in a result

Popis

Procedural style:

int maxdb_num_fields ( resource $result )

Object oriented style (property):

class result {
int field_count
}

maxdb_num_fields() returns the number of fields from specified result set.

Návratové hodnoty

The number of fields from a result set

Příklady

Příklad 1065. Object oriented style

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

if ($result = $maxdb->query("SELECT * FROM hotel.city ORDER BY zip")) {

   /* determine number of fields in result set */
   $field_cnt = $result->field_count;

   printf("Result set has %d fields.\n", $field_cnt);

   /* close result set */
   $result->close();
}

/* close connection */
$maxdb->close();
?>

Příklad 1066. Procedural style

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

if ($result = maxdb_query($link, "SELECT * FROM hotel.city ORDER BY zip")) {

   /* determine number of fields in result set */
   $field_cnt = maxdb_num_fields($result);

   printf("Result set has %d fields.\n", $field_cnt);

   /* close result set */
   maxdb_free_result($result);
}

/* close connection */
maxdb_close($link);
?>

The above examples would produce the following output:

Result set has 3 fields.

Viz také

maxdb_fetch_field()

Předcházející | Nahoru | Další
maxdb_next_result | Domů | maxdb_num_rows


maxdb_num_rows

(PECL maxdb:1.0-7.6.00.38)

maxdb_num_rows — Gets the number of rows in a result

Popis

Procedural style:

int maxdb_num_rows ( resource $result )

Object oriented style (property):

class maxdb {
int num_rows
}

Returns the number of rows in the result set.

The use of maxdb_num_rows() depends on whether you use buffered or unbuffered result sets. In case you use unbuffered resultsets maxdb_num_rows() will not correct the correct number of rows until all the rows in the result have been retrieved.

Návratové hodnoty

Returns number of rows in the result set.

Poznámka: If the number of rows is greater than maximal int value, the number will be returned as a string.

Příklady

Příklad 1067. Object oriented style

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

if ($result = $maxdb->query("SELECT cno, name FROM hotel.customer ORDER BY name")) {

   /* determine number of rows result set */
   $row_cnt = $result->num_rows;

   printf("Result set has %d rows.\n", $row_cnt);

   /* close result set */
   $result->close();
}

/* close connection */
$maxdb->close();
?>

Příklad 1068. Procedural style

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

if ($result = maxdb_query($link, "SELECT cno, name FROM hotel.customer ORDER BY name")) {

   /* determine number of rows result set */
   $row_cnt = maxdb_num_rows($result);

   printf("Result set has %d rows.\n", $row_cnt);

   /* close result set */
   maxdb_free_result($result);
}

/* close connection */
maxdb_close($link);
?>

The above examples would produce the following output:

Result set has 15 rows.

Viz také

maxdb_affected_rows()
maxdb_store_result()
maxdb_use_result()
maxdb_query()

Předcházející | Nahoru | Další
maxdb_num_fields | Domů | maxdb_options


maxdb_options

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_options,

(PECL maxdb:1.0-7.6.00.38)

maxdb_options, maxdb->options — Set options

Popis

Procedural style:

bool maxdb_options ( resource $link, int $option, mixed $value )

Object oriented style (method)

class maxdb {
bool options ( int $option, mixed $value )
}

maxdb_options() can be used to set extra connect options and affect behavior for a connection.

This function may be called multiple times to set several options.

maxdb_options() should be called after maxdb_init() and before maxdb_real_connect().

The parameter option is the option that you want to set, the value is the value for the option. For detailed description of the options see » http://dev.mysql.com/doc/maxdb/ The parameter option can be one of the following values:

Tabulka 157. Valid options

Name | Description
MAXDB_COMPNAME | The component name used to initialise the SQLDBC runtime environment.
MAXDB_APPLICATION | The application to be connected to the database.
MAXDB_APPVERSION | The version of the application.
MAXDB_SQLMODE | The SQL mode.
MAXDB_UNICODE | TRUE, if the connection is an unicode (UCS2) client or FALSE, if not.
MAXDB_TIMEOUT | The maximum allowed time of inactivity after which the connection to the database is closed by the system.
MAXDB_ISOLATIONLEVEL | Specifies whether and how shared locks and exclusive locks are implicitly requested or released.
MAXDB_PACKETCOUNT | The number of different request packets used for the connection.
MAXDB_STATEMENTCACHESIZE | The number of prepared statements to be cached for the connection for re-use.
MAXDB_CURSORPREFIX | The prefix to use for result tables that are automatically named.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

See maxdb_real_connect().

Viz také

maxdb_init()
maxdb_real_connect()

Předcházející | Nahoru | Další
maxdb_num_rows | Domů | maxdb_param_count


maxdb_param_count

(PECL maxdb:1.0)

maxdb_param_count — Alias pro maxdb_stmt_param_count()

Popis

Tato funkce je aliasem: maxdb_stmt_param_count().

Tento alias funkce je zavržený a existuje pouze z důvodu zpětné kompatibility. Doporučuje se tuto funkci nepoužívat, neboť může být jednoho dne odstraněna z PHP.

Předcházející | Nahoru | Další
maxdb_options | Domů | maxdb_ping


maxdb_ping

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_ping,

(PECL maxdb:1.0-7.6.00.38)

maxdb_ping, maxdb->ping — Pings a server connection, or tries to reconnect if the connection has gone down

Popis

Procedural style:

bool maxdb_ping ( resource $link )

Object oriented style (method):

class maxdb {
bool ping ( void )
}

Checks whether the connection to the server is working. If it has gone down, and global option maxdb.reconnect is enabled an automatic reconnection is attempted.

This function can be used by clients that remain idle for a long while, to check whether the server has closed the connection and reconnect if necessary.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1069. Object oriented style

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* check if server is alive */
if ($maxdb->ping()) {
   printf ("Our connection is ok!\n");
} else {
   printf ("Error: %s\n", $maxdb->error);
}

/* close connection */
$maxdb->close();
?>

Příklad 1070. Procedural style

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* check if server is alive */
if (maxdb_ping($link)) {
   printf ("Our connection is ok!\n");
} else {
   printf ("Error: %s\n", maxdb_error($link));
}

/* close connection */
maxdb_close($link);
?>

The above examples would produce the following output:

Our connection is ok!

Předcházející | Nahoru | Další
maxdb_param_count | Domů | maxdb_prepare


maxdb_prepare

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_prepare,

(PECL maxdb:1.0-7.6.00.38)

maxdb_prepare, maxdb->prepare — Prepare a SQL statement for execution

Popis

Procedure style:

resource maxdb_prepare ( resource $link, string $query )

Object oriented style (method)

class stmt {
resource prepare ( string $query )
}

maxdb_prepare() prepares the SQL query pointed to by the null-terminated string query, and returns a statement handle to be used for further operations on the statement. The query must consist of a single SQL statement.

Poznámka: You should not add a terminating semicolon or \g to the statement.

The parameter query can include one or more parameter markers in the SQL statement by embedding question mark (?) characters at the appropriate positions.

Poznámka: The markers are legal only in certain places in SQL statements. For example, they are allowed in the VALUES() list of an INSERT statement (to specify column values for a row), or in a comparison with a column in a WHERE clause to specify a comparison value.

However, they are not allowed for identifiers (such as table or column names), in the select list that names the columns to be returned by a SELECT statement), or to specify both operands of a binary operator such as the = equal sign. The latter restriction is necessary because it would be impossible to determine the parameter type. In general, parameters are legal only in Data Manipulation Languange (DML) statements, and not in Data Defination Language (DDL) statements.

The parameter markers must be bound to application variables using maxdb_stmt_bind_param() and/or maxdb_stmt_bind_result() before executing the statement or fetching rows.

Návratové hodnoty

maxdb_prepare() returns a statement resource or FALSE if an error occured.

Příklady

Příklad 1071. Object oriented style

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$city = "Rosemont";

/* create a prepared statement */
if ($stmt = $maxdb->prepare("SELECT state FROM hotel.city WHERE name=?")) {

   /* bind parameters for markers */
   $stmt->bind_param("s", $city);

   /* execute query */
   $stmt->execute();

   /* bind result variables */
   $stmt->bind_result($district);

   /* fetch value */
   $stmt->fetch();

   printf("%s is in district %s\n", $city, $district);

   /* close statement */
   $stmt->close();
}

/* close connection */
$maxdb->close();
?>

Příklad 1072. Procedural style

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$city = "Rosemont";

/* create a prepared statement */
if ($stmt = maxdb_prepare($link, "SELECT state FROM hotel.city WHERE name=?")) {

   /* bind parameters for markers */
   maxdb_stmt_bind_param($stmt, "s", $city);

   /* execute query */
   maxdb_stmt_execute($stmt);

  /* bind result variables */
   maxdb_stmt_bind_result($stmt, $district);

   /* fetch value */
   maxdb_stmt_fetch($stmt);

   printf("%s is in district %s\n", $city, $district);

   /* close statement */
   maxdb_stmt_close($stmt);
}

/* close connection */
maxdb_close($link);
?>

The above examples would produce the following output:

Rosemont is in district IL

Viz také

maxdb_stmt_execute()
maxdb_stmt_fetch()
maxdb_stmt_bind_param()
maxdb_stmt_bind_result()
maxdb_stmt_close()

Předcházející | Nahoru | Další
maxdb_ping | Domů | maxdb_query


maxdb_query

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_query,

(PECL maxdb:1.0-7.6.00.38)

maxdb_query, maxdb->query — Performs a query on the database

Popis

Procedural style:

mixed maxdb_query ( resource $link, string $query [, int $resultmode] )

Object oriented style (method):

class maxdb {
mixed query ( string $query )
}

The maxdb_query() function is used to simplify the act of performing a query against the database represented by the link parameter.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání. For SELECT, SHOW, DESCRIBE or EXPLAIN maxdb_query() will return a result resource.

Příklady

Příklad 1073. Object oriented style

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* Create table doesn't return a resultset */
if ($maxdb->query("CREATE TABLE temp.mycity LIKE hotel.city") === TRUE) {
   printf("Table mycity successfully created.\n");
}

/* Select queries return a resultset */
if ($result = $maxdb->query("SELECT name FROM hotel.city")) {
   printf("Select returned %d rows.\n", $result->num_rows);

   /* free result set */
   $result->close();
}

/* If we have to retrieve large amount of data we use MAXDB_USE_RESULT */
if ($result = $maxdb->query("SELECT * FROM hotel.city", MAXDB_USE_RESULT)) {
   $result->close();
}

$maxdb->close();
?>

Příklad 1074. Procedural style

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* Create table doesn't return a resultset */
if (maxdb_query($link, "CREATE TABLE temp.mycity LIKE hotel.city") === TRUE) {
   printf("Table mycity successfully created.\n");
}

/* Select queries return a resultset */
if ($result = maxdb_query($link, "SELECT name FROM hotel.city")) {
   printf("Select returned %d rows.\n", maxdb_num_rows($result));

   /* free result set */
   maxdb_free_result($result);
}

/* If we have to retrieve large amount of data we use MAXDB_USE_RESULT */
if ($result = maxdb_query($link, "SELECT * FROM hotel.city", MAXDB_USE_RESULT)) {
   maxdb_free_result($result);
}

maxdb_close($link);
?>

The above examples would produce the following output:

Table mycity successfully created.
Select returned 25 rows.

Viz také

maxdb_real_query()
maxdb_multi_query()
maxdb_free_result()

Předcházející | Nahoru | Další
maxdb_prepare | Domů | maxdb_real_connect


maxdb_real_connect

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_real_connect,

(PECL maxdb:1.0-7.6.00.38)

maxdb_real_connect, maxdb->real_connect — Opens a connection to a MaxDB server

Popis

Procedural style

bool maxdb_real_connect ( resource $link [, string $hostname [, string $username [, string $passwd [, string $dbname [, int $port [, string $socket]]]]]] )

Object oriented style (method)

class maxdb {
bool real_connect ( [string $hostname [, string $username [, string $passwd [, string $dbname [, int $port [, string $socket]]]]]] )
}

maxdb_real_connect() attempts to establish a connection to a MaxDB database engine running on hostname.

This function differs from maxdb_connect():

  • maxdb_real_connect() needs a valid resource which has to be created by function maxdb_init()

  • With function maxdb_options() you can set various options for connection.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1075. Object oriented style

<?php

/* create a connection object which is not connected */
$maxdb = maxdb_init();

/* set connection options */
$maxdb->options(MAXDB_UNICODE, "FALSE");
$maxdb->options(MAXDB_TIMEOUT, 5);

/* connect to server */
$maxdb->real_connect('localhost', 'MONA', 'RED', 'DEMODB');

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

printf ("Connection: %s\n.", $maxdb->host_info);

$maxdb->close();
?>

Příklad 1076. Procedural style

<?php

/* create a connection object which is not connected */
$link = maxdb_init();

/* set connection options */
maxdb_options($link, MAXDB_UNICODE, "FALSE");
maxdb_options($link, MAXDB_TIMEOUT, 5);

/* connect to server */
maxdb_real_connect($link, 'localhost', 'MONA', 'RED', 'DEMODB');

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

printf ("Connection: %s\n.", maxdb_get_host_info($link));

maxdb_close($link);
?>

The above examples would produce the following output:

Connection: localhost <...>

Viz také

maxdb_connect()
maxdb_init()
maxdb_options()
maxdb_ssl_set()
maxdb_close()

Předcházející | Nahoru | Další
maxdb_query | Domů | maxdb_real_escape_string


maxdb_real_escape_string

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_real_escape_string,

(PECL maxdb:1.0-7.6.00.38)

maxdb_real_escape_string, maxdb->real_escape_string — Escapes special characters in a string for use in a SQL statement, taking into account the current charset of the connection

Popis

Procedural style:

string maxdb_real_escape_string ( resource $link, string $escapestr )

Object oriented style (method):

class maxdb {
string real_escape_sring ( string $escapestr )
}

This function is used to create a legal SQL string that you can use in a SQL statement. The string escapestr is encoded to an escaped SQL string, taking into account the current character set of the connection.

Characters encoded are ', ".

Návratové hodnoty

Returns an escaped string.

Příklady

Příklad 1077. Object oriented style

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$maxdb->query("CREATE TABLE temp.mycity LIKE hotel.city");

$city = "'s Hertogenbosch";

/* this query will fail, cause we didn't escape $city */
if (!$maxdb->query("INSERT into temp.mycity VALUES ('11111','$city','NY')")) {
   printf("Error: %s\n", $maxdb->sqlstate);
}

$city = $maxdb->real_escape_string($city);

/* this query with escaped $city will work */
if ($maxdb->query("INSERT into temp.mycity VALUES ('22222','$city','NY')")) {
   printf("%d Row inserted.\n", $maxdb->affected_rows);
}

$maxdb->close();
?>

Příklad 1078. Procedural style

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

maxdb_query($link, "CREATE TABLE temp.mycity LIKE hotel.city");

$city = "'s Hertogenbosch";

/* this query will fail, cause we didn't escape $city */
if (!maxdb_query($link, "INSERT into temp.mycity VALUES ('11111','$city','NY')")) {
   printf("Error: %s\n", maxdb_sqlstate($link));
}

$city = maxdb_real_escape_string($link, $city);

/* this query with escaped $city will work */
if (maxdb_query($link, "INSERT into temp.mycity VALUES ('22222','$city','NY')")) {
   printf("%d Row inserted.\n", maxdb_affected_rows($link));
}

maxdb_close($link);
?>

The above examples would produce the following output:

Warning: maxdb_query(): -5016 POS(43) Missing delimiter: ) <...>
Error: 42000
1 Row inserted.

Viz také

maxdb_character_set_name()

Předcházející | Nahoru | Další
maxdb_real_connect | Domů | maxdb_real_query


maxdb_real_query

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_real_query,

(PECL maxdb:1.0-7.6.00.38)

maxdb_real_query, maxdb->real_query — Execute an SQL query

Popis

Procedural style

bool maxdb_real_query ( resource $link, string $query )

Object oriented style (method):

class maxdb {
bool real_query ( string $query )
}

The maxdb_real_query() is functionally identical with the maxdb_query().

Poznámka: In order to determine if a given query should return a result set or not, see maxdb_field_count().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

maxdb_query()
maxdb_store_result()
maxdb_use_result()

Předcházející | Nahoru | Další
maxdb_real_escape_string | Domů | maxdb_report


maxdb_report

(PECL maxdb:1.0)

maxdb_report — Enables or disables internal report functions

Popis

bool maxdb_report ( int $flags )

Příklady

Příklad 1079. Procedural style

<?php
/* activate reporting */
maxdb_report(MAXDB_REPORT_ERROR);

$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* this query should report an error */
$result = maxdb_query($link,"SELECT Name FROM Nonexistingtable WHERE population > 50000");

maxdb_close($link);
?>

The above examples would produce the following output:

Warning: maxdb_query(): -4004 POS(18) Unknown table name:NONEXISTINGTABLE <...>

Předcházející | Nahoru | Další
maxdb_real_query | Domů | maxdb_rollback


maxdb_rollback

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_rollback,

(PECL maxdb:1.0-7.6.00.38)

maxdb_rollback, maxdb->rollback — Rolls back current transaction

Popis

bool maxdb_rollback ( resource $link )
class maxdb {
bool rollback ( void )
}

Rollbacks the current transaction for the database specified by the link parameter.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1080. Object oriented style

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* disable autocommit */
$maxdb->autocommit(FALSE);

$maxdb->query("CREATE TABLE temp.mycity LIKE hotel.city");
$maxdb->query("INSERT INTO temp.mycity SELECT * FROM hotel.city");

/* commit insert */
$maxdb->commit();

/* delete all rows */
$maxdb->query("DELETE FROM temp.mycity");

if ($result = $maxdb->query("SELECT COUNT(*) FROM temp.mycity")) {
   $row = $result->fetch_row();
   printf("%d rows in table mycity.\n", $row[0]);
   /* Free result */
   $result->close();
}

/* Rollback */
$maxdb->rollback();

if ($result = $maxdb->query("SELECT COUNT(*) FROM temp.mycity")) {
   $row = $result->fetch_row();
   printf("%d rows in table mycity (after rollback).\n", $row[0]);
   /* Free result */
   $result->close();
}

/* Drop table myCity */
$maxdb->query("DROP TABLE temp.mycity");

$maxdb->close();
?>

Příklad 1081. Procedural style

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* disable autocommit */
maxdb_autocommit($link, FALSE);

maxdb_query($link, "CREATE TABLE temp.mycity LIKE hotel.city");
maxdb_query($link, "INSERT INTO temp.mycity SELECT * FROM hotel.city");

/* commit insert */
maxdb_commit($link);

/* delete all rows */
maxdb_query($link, "DELETE FROM temp.mycity");

if ($result = maxdb_query($link, "SELECT COUNT(*) FROM temp.mycity")) {
   $row = maxdb_fetch_row($result);
   printf("%d rows in table mycity.\n", $row[0]);
   /* Free result */
   maxdb_free_result($result);
}

/* Rollback */
maxdb_rollback($link);

if ($result = maxdb_query($link, "SELECT COUNT(*) FROM temp.mycity")) {
   $row = maxdb_fetch_row($result);
   printf("%d rows in table mycity (after rollback).\n", $row[0]);
   /* Free result */
   maxdb_free_result($result);
}

/* Drop table myCity */
maxdb_query($link, "DROP TABLE temp.mycity");

maxdb_close($link);
?>

The above examples would produce the following output:

0 rows in table mycity.
25 rows in table mycity (after rollback).

Viz také

maxdb_commit()
maxdb_autocommit()

Předcházející | Nahoru | Další
maxdb_report | Domů | maxdb_rpl_parse_enabled


maxdb_rpl_parse_enabled

(PECL maxdb:1.0-7.6.00.38)

maxdb_rpl_parse_enabled — Check if RPL parse is enabled

Popis

int maxdb_rpl_parse_enabled ( resource $link )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
maxdb_rollback | Domů | maxdb_rpl_probe


maxdb_rpl_probe

(PECL maxdb:1.0-7.6.00.38)

maxdb_rpl_probe — RPL probe

Popis

bool maxdb_rpl_probe ( resource $link )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
maxdb_rpl_parse_enabled | Domů | maxdb_rpl_query_type


maxdb_rpl_query_type

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_rpl_query_type,

(PECL maxdb:1.0-7.6.00.38)

maxdb_rpl_query_type, maxdb->rpl_query_type — Returns RPL query type

Popis

int maxdb_rpl_query_type ( resource $link )

Object oriented style (method)

class maxdb {
int rpl_query_type ( void )
}
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
maxdb_rpl_probe | Domů | maxdb_select_db


maxdb_select_db

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_select_db,

(PECL maxdb:1.0-7.6.00.38)

maxdb_select_db, maxdb->select_db — Selects the default database for database queries

Popis

bool maxdb_select_db ( resource $link, string $dbname )

The maxdb_select_db() function selects the default database (specified by the dbname parameter) to be used when performing queries against the database connection represented by the link parameter.

Poznámka: This function should only be used to change the default database for the connection. You can select the default database with 4th parameter in maxdb_connect().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1082. Object oriented style

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* return name of current default database */
if ($result = $maxdb->query("SELECT SERVERDB FROM USERS WHERE USERNAME='MONA'")) {
   $row = $result->fetch_row();
   printf("Default database is %s.\n", $row[0]);
   $result->close();
}

/* change db to non existing db */
$maxdb->select_db("XXXXXXXX");

/* return name of current default database */
if ($result = $maxdb->query("SELECT SERVERDB FROM USERS WHERE USERNAME='MONA'")) {
   $row = $result->fetch_row();
   printf("Default database is %s.\n", $row[0]);
   $result->close();
}

$maxdb->close();
?>

Příklad 1083. Procedural style

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* return name of current default database */
if ($result = maxdb_query($link, "SELECT SERVERDB FROM USERS WHERE USERNAME='MONA'")) {
   $row = maxdb_fetch_row($result);
   printf("Default database is %s.\n", $row[0]);
   maxdb_free_result($result);
}

/* change db to non existing db */
maxdb_select_db($link, "XXXXXXXX");

/* return name of current default database */
if ($result = maxdb_query($link, "SELECT SERVERDB FROM USERS WHERE USERNAME='MONA'")) {
   $row = maxdb_fetch_row($result);
   printf("Default database is %s.\n", $row[0]);
   maxdb_free_result($result);
}

maxdb_close($link);
?>

The above examples would produce the following output:

Default database is <...>.

Warning: maxdb_select_db(): -10709 Connection failed (RTE:database not running) <...>

Warning: maxdb_query(): -10821 Session not connected [] <...>

Warning: maxdb_close(): -10821 Session not connected [] <...>

Viz také

maxdb_connect()
maxdb_real_connect()

Předcházející | Nahoru | Další
maxdb_rpl_query_type | Domů | maxdb_send_long_data


maxdb_send_long_data

(PECL maxdb:1.0-7.6.00.38)

maxdb_send_long_data — Alias pro maxdb_stmt_send_long_data()

Popis

Tato funkce je aliasem: maxdb_stmt_send_long_data().

Tento alias funkce je zavržený a existuje pouze z důvodu zpětné kompatibility. Doporučuje se tuto funkci nepoužívat, neboť může být jednoho dne odstraněna z PHP.

Předcházející | Nahoru | Další
maxdb_select_db | Domů | maxdb_send_query


maxdb_send_query

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_send_query,

(PECL maxdb:1.0-7.6.00.38)

maxdb_send_query, maxdb->send_query — Send the query and return

Popis

bool maxdb_send_query ( resource $link, string $query )

Object oriented style (method)

class maxdb {
bool send_query ( string $query )
}
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
maxdb_send_long_data | Domů | maxdb_server_end


maxdb_server_end

(PECL maxdb:1.0-7.6.00.38)

maxdb_server_end — Shut down the embedded server

Popis

void maxdb_server_end ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
maxdb_send_query | Domů | maxdb_server_init


maxdb_server_init

(PECL maxdb:1.0-7.6.00.38)

maxdb_server_init — Initialize embedded server

Popis

bool maxdb_server_init ( [array $server [, array $groups]] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
maxdb_server_end | Domů | maxdb_set_opt


maxdb_set_opt

(PECL maxdb:1.0)

maxdb_set_opt — Alias pro maxdb_options()

Popis

Tato funkce je aliasem: maxdb_options().

Předcházející | Nahoru | Další
maxdb_server_init | Domů | maxdb_sqlstate


maxdb_sqlstate

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_sqlstate,

(PECL maxdb:1.0-7.6.00.38)

maxdb_sqlstate, maxdb->sqlstate — Returns the SQLSTATE error from previous MaxDB operation

Popis

Procedural style:

string maxdb_sqlstate ( resource $link )

Object oriented style (property):

class maxdb {
string sqlstate
}

Returns a string containing the SQLSTATE error code for the last error. The error code consists of five characters. '00000' means no error. The values are specified by ANSI SQL and ODBC.

Poznámka: Note that not all MaxDB errors are yet mapped to SQLSTATE's. The value HY000 (general error) is used for unmapped errors.

Návratové hodnoty

Returns a string containing the SQLSTATE error code for the last error. The error code consists of five characters. '00000' means no error.

Příklady

Příklad 1084. Object oriented style

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* Table City already exists, so we should get an error */
if (!$maxdb->query("CREATE TABLE hotel.city (ID INT, Name VARCHAR(30))")) {
   printf("Error - SQLSTATE %s.\n", $maxdb->sqlstate);
}

$maxdb->close();
?>

Příklad 1085. Procedural style

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* Table City already exists, so we should get an error */
if (!maxdb_query($link, "CREATE TABLE hotel.city (ID INT, Name VARCHAR(30))")) {
   printf("Error - SQLSTATE %s.\n", maxdb_sqlstate($link));
}

maxdb_close($link);
?>

The above examples would produce the following output:

Warning: maxdb_query(): -6000 POS(20) Duplicate table name:CITY [I6000] <...>
Error - SQLSTATE I6000.

Viz také

maxdb_errno()
maxdb_error()

Předcházející | Nahoru | Další
maxdb_set_opt | Domů | maxdb_ssl_set


maxdb_ssl_set

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_ssl_set,

(PECL maxdb:1.0-7.6.00.38)

maxdb_ssl_set, maxdb->ssl_set — Used for establishing secure connections using SSL

Popis

Procedural style:

bool maxdb_ssl_set ( resource $link, string $key, string $cert, string $ca, string $capath, string $cipher )

Object oriented style (method):

class maxdb {
bool ssl_set ( string $key, string $cert, string $ca, string $capath, string $cipher )
}
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
maxdb_sqlstate | Domů | maxdb_stat


maxdb_stat

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_stat,

(PECL maxdb:1.0-7.6.00.38)

maxdb_stat, maxdb->stat — Gets the current system status

Popis

Procedural style:

string maxdb_stat ( resource $link )

Object oriented style (method):

class maxdb {
string maxdb->stat ( void )
}

maxdb_stat() returns a string containing several information about the MaxDB server running.

Návratové hodnoty

A string describing the server status. FALSE if an error occurred.

Příklady

Příklad 1086. Object oriented style

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

printf ("System status: %s\n", $maxdb->stat());

$maxdb->close();
?>

Příklad 1087. Procedural style

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

printf("System status: %s\n", maxdb_stat($link));

maxdb_close($link);
?>

The above examples would produce the following output:

System status: Kernel    7<...>

Viz také

maxdb_get_server_info()

Předcházející | Nahoru | Další
maxdb_ssl_set | Domů | maxdb_stmt_affected_rows


maxdb_stmt_affected_rows

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_stmt_affected_rows,

(PECL maxdb:1.0-7.6.00.38)

maxdb_stmt_affected_rows, maxdb_stmt->affected_rows — Returns the total number of rows changed, deleted, or inserted by the last executed statement

Popis

Procedural style :

int maxdb_stmt_affected_rows ( resource $stmt )

Object oriented style (property):

class stmt {
int affected_rows
}

maxdb_stmt_affected_rows() returns the number of rows affected by INSERT, UPDATE, or DELETE query. If the last query was invalid or the number of rows can not determined, this function will return -1.

Návratové hodnoty

An integer greater than zero indicates the number of rows affected or retrieved. Zero indicates that no records where updated for an UPDATE/DELETE statement, no rows matched the WHERE clause in the query or that no query has yet been executed. -1 indicates that the query has returned an error or the number of rows can not determined.

Příklady

Příklad 1088. Object oriented style

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* create temp table */
$maxdb->query("CREATE TABLE temp.mycity LIKE hotel.city");

$query = "INSERT INTO temp.mycity SELECT * FROM hotel.city WHERE state LIKE ?";

/* prepare statement */
if ($stmt = $maxdb->prepare($query)) {

   /* Bind variable for placeholder */
   $code = 'N%';
   $stmt->bind_param("s", $code);

   /* execute statement */
   $stmt->execute();

   printf("rows inserted: %d\n", $stmt->affected_rows);

   /* close statement */
   $stmt->close();
}

/* close connection */
$maxdb->close();
?>

Příklad 1089. Procedural style

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* create temp table */
maxdb_query($link, "CREATE TABLE temp.mycity LIKE hotel.city");

$query = "INSERT INTO temp.mycity SELECT * FROM hotel.city WHERE state LIKE ?";

/* prepare statement */
if ($stmt = maxdb_prepare($link, $query)) {

   /* Bind variable for placeholder */
   $code = 'N%';
   maxdb_stmt_bind_param($stmt, "s", $code);

   /* execute statement */
   maxdb_stmt_execute($stmt);

   printf("rows inserted: %d\n", maxdb_stmt_affected_rows($stmt));

   /* close statement */
   maxdb_stmt_close($stmt);
}

/* close connection */
maxdb_close($link);
?>

The above examples would produce the following output:

rows inserted: 4

Viz také

maxdb_stmt_num_rows()
maxdb_prepare()

Předcházející | Nahoru | Další
maxdb_stat | Domů | maxdb_stmt_bind_param


maxdb_stmt_bind_param

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_stmt_bind_param,

(PECL maxdb:1.0-7.6.00.38)

maxdb_stmt_bind_param, stmt->bind_param — Binds variables to a prepared statement as parameters

Popis

Procedural style:

bool maxdb_stmt_bind_param ( resource $stmt, string $types, mixed &$var1 [, mixed &$...] )

Object oriented style (method):

class stmt {
bool bind_param ( string $types, mixed &$var1 [, mixed &$...] )
}

Procedural style (extended syntax):

bool maxdb_stmt_bind_param ( resource $stmt, string $types, array &$var )

Object oriented style (method) (extended syntax):

class stmt {
bool bind_param ( string $types, array &$var )
}

maxdb_stmt_bind_param() is used to bind variables for the parameter markers in the SQL statement that was passed to maxdb_prepare(). The string types contains one or more characters which specify the types for the corresponding bind variables.

The extended syntax of maxdb_stmt_bind_param() allows to give the parameters as an array instead of a variable list of PHP variables to the function. If the array variable has not been used before calling maxdb_stmt_bind_param(), it has to be initialized as an emtpy array. See the examples how to use maxdb_stmt_bind_param() with extended syntax.

Variables for SELECT INTO SQL statements can also be bound using maxdb_stmt_bind_param(). Parameters for database procedures can be bound using maxdb_stmt_bind_param(). See the examples how to use maxdb_stmt_bind_param() in this cases.

If a variable bound as INTO variable to a SQL statement was used before, the content of this variable is overwritten by the data of the SELECT INTO statement. A reference to this variable will be invalid after a call to maxdb_stmt_bind_param().

For INOUT parameters of database procedures the content of the bound INOUT variable is overwritten by the output value of the database procedure. A reference to this variable will be invalid after a call to maxdb_stmt_bind_param().

Tabulka 158. Type specification chars

Character | Description
i | corresponding variable has type integer
d | corresponding variable has type double
s | corresponding variable has type string
b | corresponding variable is a blob and will be sent in packages

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1090. Object oriented style

<?php
$maxdb = new maxdb('localhost', 'MONA', 'RED', 'DEMODB');

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$maxdb->query ("CREATE TABLE temp.mycity LIKE hotel.city");
$maxdb->query ("INSERT INTO temp.mycity SELECT * FROM hotel.city");

$stmt = $maxdb->prepare("INSERT INTO temp.mycity VALUES (?, ?, ?)");
$stmt->bind_param('sss', $zip, $name, $state);

$zip = '11111';
$name = 'Georgetown';
$state = 'NY';

/* execute prepared statement */
$stmt->execute();

printf("%d Row inserted.\n", $stmt->affected_rows);

/* close statement and connection */
$stmt->close();

/* Clean up table CountryLanguage */
$maxdb->query("DELETE FROM temp.mycity WHERE name='Georgetown'");
printf("%d Row deleted.\n", $maxdb->affected_rows);

/* close connection */
$maxdb->close();
?>

Příklad 1091. Procedural style

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (!$link) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

maxdb_query ($link, "CREATE TABLE temp.mycity LIKE hotel.city");
maxdb_query ($link, "INSERT INTO temp.mycity SELECT * FROM hotel.city");

$stmt = maxdb_prepare($link, "INSERT INTO temp.mycity VALUES (?, ?, ?)");
maxdb_stmt_bind_param($stmt, 'sss', $zip, $name, $state);

$zip = '11111';
$name = 'Georgetown';
$state = 'NY';

/* execute prepared statement */
maxdb_stmt_execute($stmt);

printf("%d Row inserted.\n", maxdb_stmt_affected_rows($stmt));

/* close statement and connection */
maxdb_stmt_close($stmt);

/* Clean up table CountryLanguage */
maxdb_query($link, "DELETE FROM temp.mycity WHERE name='Georgetown'");
printf("%d Row deleted.\n", maxdb_affected_rows($link));

/* close connection */
maxdb_close($link);
?>

The above examples would produce the following output:

1 Row inserted.
1 Row deleted.

Příklad 1092. Procedural style (SELECT INTO)

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (!$link) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* Performing SQL query */
$stmt = maxdb_prepare ($link, "SELECT price INTO ? FROM hotel.room where hno = ? and type = ?");
if (!$stmt) {
  printf ("Prepare failed: %s\n", maxdb_error($link));
}

$hno = "50";
$rtype = "suite";

maxdb_stmt_bind_param($stmt, 'dss', $price, $hno, $rtype);
maxdb_stmt_execute($stmt);

printf ("%f\n", $price);

maxdb_stmt_close ($stmt);
?>

The above examples would produce the following output:

21.600000

Příklad 1093. Procedural style (DB procedure)

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (!$link) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

maxdb_report (MAXDB_REPORT_OFF);
maxdb_query($link,"DROP DBPROC test_proc");
maxdb_report (MAXDB_REPORT_ERROR);

$query = "create dbproc test_proc (INOUT e_text char(72)) AS select * from SYSDBA.DUAL; fetch into :e_text;";

maxdb_query($link, $query);

/* Performing SQL query */
$stmt = maxdb_prepare ($link, "CALL test_proc (?)");
if (!$stmt) {
  printf ("Prepare failed: %s\n", maxdb_error($link));
}

maxdb_stmt_bind_param($stmt, 's', $result);
maxdb_stmt_execute($stmt);

printf ("%s\n", $result);

maxdb_stmt_close ($stmt);
?>

The above examples would produce the following output:

a

Příklad 1094. Object oriented style (extended syntax)

<?php
$maxdb = new maxdb('localhost', 'MONA', 'RED', 'DEMODB');

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$maxdb->query ("CREATE TABLE temp.mycity LIKE hotel.city");
$maxdb->query ("INSERT INTO temp.mycity SELECT * FROM hotel.city");

$stmt = $maxdb->prepare("INSERT INTO temp.mycity VALUES (?, ?, ?)");

$arr = array();

$stmt->bind_param('iss', $arr);

$arr[0] = 11111;
$arr[1] = 'Georgetown';
$arr[2] = 'NY';

/* execute prepared statement */
$stmt->execute();

printf("%d Row inserted.\n", maxdb_stmt_affected_rows($stmt));

$arr[0] = 22222;
$arr[1] = 'New Orleans';
$arr[2] = 'LA';

/* execute prepared statement */
$stmt->execute();

printf("%d Row inserted.\n", $stmt->affected_rows);

/* close statement and connection */
$stmt->close();

$result = $maxdb->query("SELECT * from temp.mycity WHERE zip = '11111' OR zip = '22222'");
if ($result) {
  while ($row = $result->fetch_row()) {
    printf ("%s %s %s\n", $row[0], $row[1], $row[2]);
  }
}

/* Clean up table CountryLanguage */
$maxdb->query("DELETE FROM temp.mycity WHERE name='Georgetown'");
$maxdb->query("DELETE FROM temp.mycity WHERE name='New Orleans'");
printf("%d Rows deleted.\n", $maxdb->affected_rows);

/* close connection */
$maxdb->close();
?>

The above examples would produce the following output:

1 Row inserted.
1 Row inserted.
11111 Georgetown NY
22222 New Orleans LA
2 Rows deleted.

Viz také

maxdb_stmt_bind_result()
maxdb_stmt_execute()
maxdb_stmt_fetch()
maxdb_prepare()
maxdb_stmt_send_long_data()
maxdb_stmt_errno()
maxdb_stmt_error()

Předcházející | Nahoru | Další
maxdb_stmt_affected_rows | Domů | maxdb_stmt_bind_result


maxdb_stmt_bind_result

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_stmt_bind_result,

(PECL maxdb:1.0-7.6.00.38)

maxdb_stmt_bind_result, stmt->bind_result — Binds variables to a prepared statement for result storage

Popis

Procedural style:

bool maxdb_stmt_bind_result ( resource $stmt, mixed &$var1 [, mixed &$...] )

Object oriented style (method):

class stmt {
bool bind_result ( mixed &$var1 [, mixed &$...] )
}

maxdb_stmt_bind_result() is used to associate (bind) columns in the result set to variables. When maxdb_stmt_fetch() is called to fetch data, the MaxDB client/server protocol places the data for the bound columns into the specified variables var1, ....

Poznámka: Note that all columns must be bound prior to calling maxdb_stmt_fetch(). Depending on column types bound variables can silently change to the corresponding PHP type.

A column can be bound or rebound at any time, even after a result set has been partially retrieved. The new binding takes effect the next time maxdb_stmt_fetch() is called.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1095. Object oriented style

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* prepare statement */
if ($stmt = $maxdb->prepare("SELECT zip, name FROM hotel.city ORDER BY name")) {
   $stmt->execute();

   /* bind variables to prepared statement */
   $stmt->bind_result($col1, $col2);

   /* fetch values */
   while ($stmt->fetch()) {
       printf("%s %s\n", $col1, $col2);
   }

   /* close statement */
   $stmt->close();
}
/* close connection */
$maxdb->close();

?>

Příklad 1096. Procedural style

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (!$link) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* prepare statement */
if ($stmt = maxdb_prepare($link, "SELECT zip, name FROM hotel.city ORDER BY name")) {
   maxdb_stmt_execute($stmt);

   /* bind variables to prepared statement */
   maxdb_stmt_bind_result($stmt, $col1, $col2);

   /* fetch values */
   while (maxdb_stmt_fetch($stmt)) {
       printf("%s %s\n", $col1, $col2);
   }

   /* close statement */
   maxdb_stmt_close($stmt);
}

/* close connection */
maxdb_close($link);
?>

The above examples would produce the following output:

12203 Albany
60601 Chicago
60615 Chicago
45211 Cincinnati
33575 Clearwater
75243 Dallas
32018 Daytona Beach
33441 Deerfield Beach
48226 Detroit
90029 Hollywood
92714 Irvine
90804 Long Beach
11788 Long Island
90018 Los Angeles
70112 New Orleans
10019 New York
10580 New York
92262 Palm Springs
97213 Portland
60018 Rosemont
95054 Santa Clara
20903 Silver Spring
20005 Washington
20019 Washington
20037 Washington

Viz také

maxdb_stmt_bind_param()
maxdb_stmt_execute()
maxdb_stmt_fetch()
maxdb_prepare()
maxdb_stmt_prepare()
maxdb_stmt_init()
maxdb_stmt_errno()
maxdb_stmt_error()

Předcházející | Nahoru | Další
maxdb_stmt_bind_param | Domů | maxdb_stmt_close_long_data


maxdb_stmt_close

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_stmt_close,

(PECL maxdb:1.0-7.6.00.38)

maxdb_stmt_close, maxdb_stmt->close — Closes a prepared statement

Popis

Procedural style:

bool maxdb_stmt_close ( resource $stmt )

Object oriented style (method):

class maxdb_stmt {
bool maxdb_stmt->close ( void )
}

Closes a prepared statement. maxdb_stmt_close() also deallocates the statement handle pointed to by stmt. If the current statement has pending or unread results, this function cancels them so that the next query can be executed.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

maxdb_prepare()

Předcházející | Nahoru | Další
maxdb_stmt_close_long_data | Domů | maxdb_stmt_data_seek


maxdb_stmt_close_long_data

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_stmt_close_long_data,

(PECL maxdb:1.0)

maxdb_stmt_close_long_data, stmt->close_long_data — Ends a sequence of maxdb_stmt_send_long_data()

Popis

Procedural style:

bool maxdb_stmt_close_long_data ( resource $stmt, int $param_nr )

Object oriented style (method):

class maxdb_stmt {
bool maxdb_stmt->close_long_data ( void )
}

This function has to be called after a sequence of maxdb_stmt_send_long_data(), that was started after maxdb_execute().

param_nr indicates which parameter to associate the end of data with. Parameters are numbered beginning with 0.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

maxdb_prepare()
maxdb_stmt_bind_param()

Předcházející | Nahoru | Další
maxdb_stmt_bind_result | Domů | maxdb_stmt_close


maxdb_stmt_data_seek

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_stmt_data_seek,

(PECL maxdb:1.0-7.6.00.38)

maxdb_stmt_data_seek, stmt->data_seek — Seeks to an arbitray row in statement result set

Popis

Procedural style:

bool maxdb_stmt_data_seek ( resource $statement, int $offset )

Object oriented style (method):

class stmt {
bool data_seek ( int $offset )
}

The maxdb_stmt_data_seek() function seeks to an arbitrary result pointer specified by the offset in the statement result set represented by statement. The offset parameter must be between zero and the total number of rows minus one (0..maxdb_stmt_num_rows() - 1).

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1097. Object oriented style

<?php
/* Open a connection */
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query = "SELECT name, zip FROM hotel.city ORDER BY name";
if ($stmt = $maxdb->prepare($query)) {

   /* execute query */
   $stmt->execute();

   /* bind result variables */
   $stmt->bind_result($name, $code);

   /* store result */
   $stmt->store_result();

   /* seek to row no. 5 */
   $stmt->data_seek(5);

   /* fetch values */
   $stmt->fetch();

   printf ("City: %s  Zip: %s\n", $name, $code);

   /* close statement */
   $stmt->close();
}

/* close connection */
$maxdb->close();
?>

Příklad 1098. Procedural style

<?php
/* Open a connection */
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query = "SELECT name, zip FROM hotel.city ORDER BY name";
if ($stmt = maxdb_prepare($link, $query)) {

   /* execute query */
   maxdb_stmt_execute($stmt);

   /* bind result variables */
   maxdb_stmt_bind_result($stmt, $name, $code);

   /* store result */
   maxdb_stmt_store_result($stmt);

   /* seek to row no. 5 */
   maxdb_stmt_data_seek($stmt, 5);

   /* fetch values */
   maxdb_stmt_fetch($stmt);

   printf ("City: %s  Zip: %s\n", $name, $code);

   /* close statement */
   maxdb_stmt_close($stmt);
}

/* close connection */
maxdb_close($link);
?>

The above examples would produce the following output:

City: Dallas  Zip: 75243

Viz také

maxdb_prepare()

Předcházející | Nahoru | Další
maxdb_stmt_close | Domů | maxdb_stmt_errno


maxdb_stmt_errno

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_stmt_errno,

(PECL maxdb:1.0-7.6.00.38)

maxdb_stmt_errno, maxdb_stmt->errno — Returns the error code for the most recent statement call

Popis

Procedural style :

int maxdb_stmt_errno ( resource $stmt )

Object oriented style (property):

class stmt {
int errno
}

For the statement specified by stmt, maxdb_stmt_errno() returns the error code for the most recently invoked statement function that can succeed or fail.

Poznámka: For possible error codes see documentation of SQLDBC: » http://dev.mysql.com/doc/maxdb/.

Návratové hodnoty

An error code value. Zero means no error occurred.

Viz také

maxdb_stmt_error()
maxdb_stmt_sqlstate()

Příklady

Příklad 1099. Object oriented style

<?php
/* Open a connection */
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$maxdb->query("CREATE TABLE temp.mycity LIKE hotel.city");
$maxdb->query("INSERT INTO temp.mycity SELECT * FROM hotel.city");

$query = "SELECT name, zip FROM temp.mycity ORDER BY name";
if ($stmt = $maxdb->prepare($query)) {

   /* drop table */
   $maxdb->query("DROP TABLE temp.mycity");

   /* execute query */
   $stmt->execute();

   printf("Error: %d.\n", $stmt->errno);

   /* close statement */
   $stmt->close();
}

/* close connection */
$maxdb->close();
?>

Příklad 1100. Procedural style

<?php
/* Open a connection */
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

maxdb_query($link, "CREATE TABLE temp.mycity LIKE hotel.city");
maxdb_query($link, "INSERT INTO temp.mycity SELECT * FROM hotel.city");

$query = "SELECT name, zip FROM temp.mycity ORDER BY name";
if ($stmt = maxdb_prepare($link, $query)) {

   /* drop table */
   maxdb_query($link, "DROP TABLE temp.mycity");

   /* execute query */
   maxdb_stmt_execute($stmt);

   printf("Error: %d.\n", maxdb_stmt_errno($stmt));

   /* close statement */
   maxdb_stmt_close($stmt);
}

/* close connection */
maxdb_close($link);
?>

The above examples would produce the following output:

Warning: maxdb_stmt_execute(): -4004 POS(23) Unknown table name:MYCITY [42000] <...>
Error: -4004.

Viz také

maxdb_stmt_error()
maxdb_stmt_sqlstate()

Předcházející | Nahoru | Další
maxdb_stmt_data_seek | Domů | maxdb_stmt_error


maxdb_stmt_error

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_stmt_error,

(PECL maxdb:1.0-7.6.00.38)

maxdb_stmt_error, maxdb_stmt->error — Returns a string description for last statement error

Popis

Procedural style:

string maxdb_stmt_error ( resource $stmt )

Object oriented style (property):

class stmt {
string error
}

For the statement specified by stmt, maxdb_stmt_error() returns a containing the error message for the most recently invoked statement function that can succeed or fail.

Návratové hodnoty

A string that describes the error. An empty string if no error occurred.

Příklady

Příklad 1101. Object oriented style

<?php
/* Open a connection */
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$maxdb->query("CREATE TABLE temp.mycity LIKE hotel.city");
$maxdb->query("INSERT INTO temp.mycity SELECT * FROM hotel.city");

$query = "SELECT name, zip FROM temp.mycity ORDER BY name";
if ($stmt = $maxdb->prepare($query)) {

   /* drop table */
   $maxdb->query("DROP TABLE temp.mycity");

   /* execute query */
   $stmt->execute();

   printf("Error: %s.\n", $stmt->error);

   /* close statement */
   $stmt->close();
}

/* close connection */
$maxdb->close();
?>

Příklad 1102. Procedural style

<?php
/* Open a connection */
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

maxdb_query($link, "CREATE TABLE temp.mycity LIKE hotel.city");
maxdb_query($link, "INSERT INTO temp.mycity SELECT * FROM hotel.city");

$query = "SELECT name, zip FROM temp.mycity ORDER BY name";
if ($stmt = maxdb_prepare($link, $query)) {

   /* drop table */
   maxdb_query($link, "DROP TABLE temp.mycity");

   /* execute query */
   maxdb_stmt_execute($stmt);

   printf("Error: %s.\n", maxdb_stmt_error($stmt));

   /* close statement */
   maxdb_stmt_close($stmt);
}

/* close connection */
maxdb_close($link);
?>

The above examples would produce the following output:

Warning: maxdb_stmt_execute(): -4004 POS(23) Unknown table name:MYCITY [42000] <...>
Error: POS(23) Unknown table name:MYCITY.

Viz také

maxdb_stmt_errno()
maxdb_stmt_sqlstate()

Předcházející | Nahoru | Další
maxdb_stmt_errno | Domů | maxdb_stmt_execute


maxdb_stmt_execute

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_stmt_execute,

(PECL maxdb:1.0-7.6.00.38)

maxdb_stmt_execute, stmt->execute — Executes a prepared Query

Popis

Procedural style:

bool maxdb_stmt_execute ( resource $stmt )

Object oriented style (method):

class stmt {
bool execute ( void )
}

The maxdb_stmt_execute() function executes a query that has been previously prepared using the maxdb_prepare() function represented by the stmt resource. When executed any parameter markers which exist will automatically be replaced with the appropiate data.

If the statement is UPDATE, DELETE, or INSERT, the total number of affected rows can be determined by using the maxdb_stmt_affected_rows() function. Likewise, if the query yields a result set the maxdb_fetch() function is used.

Poznámka: When using maxdb_stmt_execute(), the maxdb_fetch() function must be used to fetch the data prior to preforming any additional queries.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1103. Object oriented style

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$maxdb->query("CREATE TABLE temp.mycity LIKE hotel.city");

/* Prepare an insert statement */
$query = "INSERT INTO temp.mycity (zip, name, state) VALUES (?,?,?)";
$stmt = $maxdb->prepare($query);

$stmt->bind_param("sss", $val1, $val2, $val3);

$val1 = '11111';
$val2 = 'Georgetown';
$val3 = 'NY';

/* Execute the statement */
$stmt->execute();

$val1 = '22222';
$val2 = 'Hubbatown';
$val3 = 'CA';

/* Execute the statement */
$stmt->execute();

/* close statement */
$stmt->close();

/* retrieve all rows from myCity */
$query = "SELECT zip, name, state FROM temp.mycity";
if ($result = $maxdb->query($query)) {
   while ($row = $result->fetch_row()) {
       printf("%s (%s,%s)\n", $row[0], $row[1], $row[2]);
   }
   /* free result set */
   $result->close();
}

/* remove table */
$maxdb->query("DROP TABLE temp.mycity");

/* close connection */
$maxdb->close();
?>

Příklad 1104. Procedural style

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

maxdb_query($link, "CREATE TABLE temp.mycity LIKE hotel.city");

/* Prepare an insert statement */
$query = "INSERT INTO temp.mycity (zip, name, state) VALUES (?,?,?)";
$stmt = maxdb_prepare($link, $query);

maxdb_stmt_bind_param($stmt, "sss", $val1, $val2, $val3);

$val1 = '11111';
$val2 = 'Georgetown';
$val3 = 'NY';

/* Execute the statement */
maxdb_stmt_execute($stmt);

$val1 = '22222';
$val2 = 'Hubbatown';
$val3 = 'CA';

/* Execute the statement */
maxdb_stmt_execute($stmt);

/* close statement */
maxdb_stmt_close($stmt);

/* retrieve all rows from myCity */
$query = "SELECT zip, name, state FROM temp.mycity";
if ($result = maxdb_query($link, $query)) {
   while ($row = maxdb_fetch_row($result)) {
       printf("%s (%s,%s)\n", $row[0], $row[1], $row[2]);
   }
   /* free result set */
   maxdb_free_result($result);
}

/* remove table */
maxdb_query($link, "DROP TABLE temp.mycity");

/* close connection */
maxdb_close($link);
?>

The above examples would produce the following output:

11111 (Georgetown,NY)
22222 (Hubbatown,CA)

Viz také

maxdb_prepare()
maxdb_stmt_bind_param()

Předcházející | Nahoru | Další
maxdb_stmt_error | Domů | maxdb_stmt_fetch


maxdb_stmt_fetch

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_stmt_fetch,

(PECL maxdb:1.0-7.6.00.38)

maxdb_stmt_fetch, stmt->fetch — Fetch results from a prepared statement into the bound variables

Popis

Procedural style:

bool maxdb_stmt_fetch ( resource $stmt )

Object oriented style (method):

class stmt {
bool fetch ( void )
}

maxdb_stmt_fetch() returns row data using the variables bound by maxdb_stmt_bind_result().

Poznámka: Note that all columns must be bound by the application before calling maxdb_stmt_fetch().

Návratové hodnoty

Tabulka 159. Return values

Value | Description
TRUE | Success. Data has been fetched
FALSE | Error occured
NULL | No more rows/data exists

Příklady

Příklad 1105. Object oriented style

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query = "SELECT zip, name FROM hotel.city ORDER by name";

if ($stmt = $maxdb->prepare($query)) {

   /* execute statement */
   $stmt->execute();

   /* bind result variables */
   $stmt->bind_result($name, $code);

   /* fetch values */
   while ($stmt->fetch()) {
       printf ("%s (%s)\n", $name, $code);
   }

   /* close statement */
   $stmt->close();
}

/* close connection */
$maxdb->close();
?>

Příklad 1106. Procedural style

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query = "SELECT zip, name FROM hotel.city ORDER by name";

if ($stmt = maxdb_prepare($link, $query)) {

   /* execute statement */
   maxdb_stmt_execute($stmt);

   /* bind result variables */
   maxdb_stmt_bind_result($stmt, $name, $code);

   /* fetch values */
   while (maxdb_stmt_fetch($stmt)) {
       printf ("%s (%s)\n", $name, $code);
   }

   /* close statement */
   maxdb_stmt_close($stmt);
}

/* close connection */
maxdb_close($link);
?>

The above examples would produce the following output:

12203 (Albany)
60601 (Chicago)
60615 (Chicago)
45211 (Cincinnati)
33575 (Clearwater)
75243 (Dallas)
32018 (Daytona Beach)
33441 (Deerfield Beach)
48226 (Detroit)
90029 (Hollywood)
92714 (Irvine)
90804 (Long Beach)
11788 (Long Island)
90018 (Los Angeles)
70112 (New Orleans)
10019 (New York)
10580 (New York)
92262 (Palm Springs)
97213 (Portland)
60018 (Rosemont)
95054 (Santa Clara)
20903 (Silver Spring)
20005 (Washington)
20019 (Washington)
20037 (Washington)

Viz také

maxdb_prepare()
maxdb_stmt_errno()
maxdb_stmt_error()
maxdb_stmt_bind_result()

Předcházející | Nahoru | Další
maxdb_stmt_execute | Domů | maxdb_stmt_free_result


maxdb_stmt_free_result

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_stmt_free_result,

(PECL maxdb:1.0-7.6.00.38)

maxdb_stmt_free_result, stmt->free_result — Frees stored result memory for the given statement handle

Popis

Procedural style:

void maxdb_stmt_free_result ( resource $stmt )

Object oriented style (method):

class stmt {
void free_result ( void )
}

The maxdb_stmt_free_result() function frees the result memory associated with the statement represented by the stmt parameter, which was allocated by maxdb_stmt_store_result().

Návratové hodnoty

This function doesn't return any value.

Viz také

maxdb_stmt_store_result()

Předcházející | Nahoru | Další
maxdb_stmt_fetch | Domů | maxdb_stmt_init


maxdb_stmt_init

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_stmt_init,

(PECL maxdb:1.0-7.6.00.38)

maxdb_stmt_init, maxdb->stmt_init — Initializes a statement and returns an resource for use with maxdb_stmt_prepare

Popis

Procedural style :

resource maxdb_stmt_init ( resource $link )

Object oriented style (property):

class maxdb {
object stmt_init ( void )
}

Allocates and initializes a statement resource suitable for maxdb_stmt_prepare().

Poznámka: Any subsequent calls to any maxdb_stmt function will fail until maxdb_stmt_prepare() was called.

Návratové hodnoty

Returns an resource.

Viz také

maxdb_stmt_prepare()

Předcházející | Nahoru | Další
maxdb_stmt_free_result | Domů | maxdb_stmt_num_rows


maxdb_stmt_num_rows

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_stmt_num_rows,

(PECL maxdb:1.0-7.6.00.38)

maxdb_stmt_num_rows, stmt->num_rows — Return the number of rows in statements result set

Popis

Procedural style :

int maxdb_stmt_num_rows ( resource $stmt )

Object oriented style (property):

class stmt {
int num_rows
}

Returns the number of rows in the result set.

Návratové hodnoty

An integer representing the number of rows in result set.

Příklady

Příklad 1107. Object oriented style

<?php
/* Open a connection */
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query = "SELECT zip, name FROM hotel.city ORDER BY name";
if ($stmt = $maxdb->prepare($query)) {

   /* execute query */
   $stmt->execute();

   /* store result */
   $stmt->store_result();

   printf("Number of rows: %d.\n", $stmt->num_rows);

   /* close statement */
   $stmt->close();
}

/* close connection */
$maxdb->close();
?>

Příklad 1108. Procedural style

<?php
/* Open a connection */
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query = "SELECT zip, name FROM hotel.city ORDER BY name";
if ($stmt = maxdb_prepare($link, $query)) {

   /* execute query */
   maxdb_stmt_execute($stmt);

   /* store result */
   maxdb_stmt_store_result($stmt);

   printf("Number of rows: %d.\n", maxdb_stmt_num_rows($stmt));

   /* close statement */
   maxdb_stmt_close($stmt);
}

/* close connection */
maxdb_close($link);
?>

The above examples would produce the following output:

Number of rows: 25.

Viz také

maxdb_stmt_affected_rows()
maxdb_prepare()
maxdb_stmt_store_result()

Předcházející | Nahoru | Další
maxdb_stmt_init | Domů | maxdb_stmt_param_count


maxdb_stmt_param_count

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_stmt_param_count,

(PECL maxdb:1.0-7.6.00.38)

maxdb_stmt_param_count, stmt->param_count — Returns the number of parameter for the given statement

Popis

Procedural style:

int maxdb_stmt_param_count ( resource $stmt )

Object oriented style (property):

class stmt {
int param_count
}

maxdb_stmt_param_count() returns the number of parameter markers present in the prepared statement.

Návratové hodnoty

returns an integer representing the number of parameters.

Příklady

Příklad 1109. Object oriented style

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

if ($stmt = $maxdb->prepare("SELECT name FROM hotel.city WHERE name=? OR state=?")) {

   $marker = $stmt->param_count;
   printf("Statement has %d markers.\n", $marker);

   /* close statement */
   $stmt->close();
}

/* close connection */
$maxdb->close();
?>

Příklad 1110. Procedural style

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

if ($stmt = maxdb_prepare($link, "SELECT name FROM hotel.city WHERE name=? OR state=?")) {

   $marker = maxdb_stmt_param_count($stmt);
   printf("Statement has %d markers.\n", $marker);

   /* close statement */
   maxdb_stmt_close($stmt);
}

/* close connection */
maxdb_close($link);
?>

The above examples would produce the following output:

Statement has 2 markers.

Viz také

maxdb_prepare()

Předcházející | Nahoru | Další
maxdb_stmt_num_rows | Domů | maxdb_stmt_prepare


maxdb_stmt_prepare

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_stmt_prepare,

(PECL maxdb:1.0-7.6.00.38)

maxdb_stmt_prepare, stmt->prepare — Prepare a SQL statement for execution

Popis

Procedure style:

bool maxdb_stmt_prepare ( resource $stmt, string $query )

Object oriented style (method)

class stmt {
mixed prepare ( string $query )
}

maxdb_stmt_prepare() prepares the SQL query pointed to by the null-terminated string query. The statement resource has to be allocated by maxdb_stmt_init(). The query must consist of a single SQL statement.

Poznámka: You should not add a terminating semicolon or \g to the statement.

The parameter query can include one or more parameter markers in the SQL statement by embedding question mark (?) characters at the appropriate positions.

Poznámka: The markers are legal only in certain places in SQL statements. For example, they are allowed in the VALUES() list of an INSERT statement (to specify column values for a row), or in a comparison with a column in a WHERE clause to specify a comparison value.

However, they are not allowed for identifiers (such as table or column names), in the select list that names the columns to be returned by a SELECT statement), or to specify both operands of a binary operator such as the = equal sign. The latter restriction is necessary because it would be impossible to determine the parameter type. In general, parameters are legal only in Data Manipulation Languange (DML) statements, and not in Data Defination Language (DDL) statements.

The parameter markers must be bound to application variables using maxdb_stmt_bind_param() and/or maxdb_stmt_bind_result() before executing the statement or fetching rows.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1111. Object oriented style

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$city = "Portland";

/* create a prepared statement */
$stmt =  $maxdb->stmt_init();
if ($stmt->prepare("SELECT state FROM hotel.city WHERE name=?")) {

   /* bind parameters for markers */
   $stmt->bind_param("s", $city);

   /* execute query */
   $stmt->execute();

   /* bind result variables */
   $stmt->bind_result($district);

   /* fetch value */
   $stmt->fetch();

   printf("%s is in district %s\n", $city, $district);

   /* close statement */
   $stmt->close();
}

/* close connection */
$maxdb->close();
?>

Příklad 1112. Procedural style

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$city = "Portland";

/* create a prepared statement */
$stmt = maxdb_stmt_init($link);
if (maxdb_stmt_prepare($stmt, "SELECT state FROM hotel.city WHERE name=?")) {

   /* bind parameters for markers */
   maxdb_stmt_bind_param($stmt, "s", $city);

   /* execute query */
   maxdb_stmt_execute($stmt);

   /* bind result variables */
   maxdb_stmt_bind_result($stmt, $district);

   /* fetch value */
   maxdb_stmt_fetch($stmt);

   printf("%s is in district %s\n", $city, $district);

   /* close statement */
   maxdb_stmt_close($stmt);
}

/* close connection */
maxdb_close($link);
?>

The above examples would produce the following output:

Portland is in district OR

Viz také

maxdb_stmt_init()
maxdb_stmt_execute()
maxdb_stmt_fetch()
maxdb_stmt_bind_param()
maxdb_stmt_bind_result()
maxdb_stmt_close()

Předcházející | Nahoru | Další
maxdb_stmt_param_count | Domů | maxdb_stmt_reset


maxdb_stmt_reset

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_stmt_reset,

(PECL maxdb:1.0-7.6.00.38)

maxdb_stmt_reset, stmt->reset — Resets a prepared statement

Popis

Procedural style:

bool maxdb_stmt_reset ( resource $stmt )

Object oriented style (method):

class stmt {
bool reset ( void )
}
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
maxdb_stmt_prepare | Domů | maxdb_stmt_result_metadata


maxdb_stmt_result_metadata

(PECL maxdb:1.0-7.6.00.38)

maxdb_stmt_result_metadata — Returns result set metadata from a prepared statement

Popis

Procedural style:

resource maxdb_stmt_result_metadata ( resource $stmt )

Object oriented style (method):

class stmt {
resource result_metadata ( void )
}

If a statement passed to maxdb_prepare() is one that produces a result set, maxdb_stmt_result_metadata() returns the result resource that can be used to process the meta information such as total number of fields and individual field information.

Poznámka: This result set pointer can be passed as an argument to any of the field-based functions that process result set metadata, such as:

  • maxdb_num_fields()

  • maxdb_fetch_field()

  • maxdb_fetch_field_direct()

  • maxdb_fetch_fields()

  • maxdb_field_count()

  • maxdb_field_seek()

  • maxdb_field_tell()

  • maxdb_free_result()

The result set structure should be freed when you are done with it, which you can do by passing it to maxdb_free_result()

Poznámka: The result set returned by maxdb_stmt_result_metadata() contains only metadata. It does not contain any row results. The rows are obtained by using the statement handle with maxdb_fetch().

Návratové hodnoty

maxdb_stmt_result_metadata() returns a result resource or FALSE if an error occured.

Příklady

Příklad 1113. Object oriented style

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

$maxdb->query("CREATE TABLE temp.friends (id int, name varchar(20))");

$maxdb->query("INSERT INTO temp.friends VALUES (1,'Hartmut')");
$maxdb->query("INSERT INTO temp.friends VALUES (2, 'Ulf')");

$stmt = $maxdb->prepare("SELECT id, name FROM temp.friends");
$stmt->execute();

/* get resultset for metadata */
$result = $stmt->result_metadata();

/* retrieve field information from metadata result set */
$field = $result->fetch_field();

printf("Fieldname: %s\n", $field->name);

/* close resultset */
$result->close();

/* close connection */
$maxdb->close();
?>

Příklad 1114. Procedural style

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

maxdb_query($link, "CREATE TABLE temp.friends (id int, name varchar(20))");

maxdb_query($link, "INSERT INTO temp.friends VALUES (1,'Hartmut')");
maxdb_query($link, "INSERT INTO temp.friends VALUES (2, 'Ulf')");

$stmt = maxdb_prepare($link, "SELECT id, name FROM temp.friends");
maxdb_stmt_execute($stmt);

/* get resultset for metadata */
$result = maxdb_stmt_result_metadata($stmt);

/* retrieve field information from metadata result set */
$field = maxdb_fetch_field($result);

printf("Fieldname: %s\n", $field->name);

/* close resultset */
maxdb_free_result($result);

/* close connection */
maxdb_close($link);
?>

The above examples would produce the following output:

Fieldname: ID

Viz také

maxdb_prepare()
maxdb_free_result()

Předcházející | Nahoru | Další
maxdb_stmt_reset | Domů | maxdb_stmt_send_long_data


maxdb_stmt_send_long_data

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_stmt_send_long_data,

(PECL maxdb:1.0)

maxdb_stmt_send_long_data, stmt->send_long_data — Send data in blocks

Popis

Procedural style:

bool maxdb_stmt_send_long_data ( resource $stmt, int $param_nr, string $data )

Object oriented style (method)

class stmt {
bool stmt_send_long_data ( int $param_nr, string $data )
}

Allows to send parameter data to the server in pieces (or chunks). This function can be called multiple times to send the parts of a character or binary data value for a column, which must be one of the TEXT or BLOB datatypes.

param_nr indicates which parameter to associate the data with. Parameters are numbered beginning with 0. data is a string containing data to be sent.

Poznámka: For efficiency reasons, this function should be used after calling maxdb_execute(). In this case, the data is not stored on the client side. The end of the sequence must end with a call to maxdb_stmt_close_long_data().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

maxdb_prepare()
maxdb_stmt_bind_param()

Předcházející | Nahoru | Další
maxdb_stmt_result_metadata | Domů | maxdb_stmt_sqlstate


maxdb_stmt_sqlstate

(PECL maxdb:1.0-7.6.00.38)

maxdb_stmt_sqlstate — Returns SQLSTATE error from previous statement operation

Popis

string maxdb_stmt_sqlstate ( resource $stmt )

Returns a string containing the SQLSTATE error code for the most recently invoked prepared statement function that can succeed or fail. The error code consists of five characters. '00000' means no error. The values are specified by ANSI SQL and ODBC.

Poznámka: Note that not all MaxDB errors are yet mapped to SQLSTATE's. The value HY000 (general error) is used for unmapped errors.

Návratové hodnoty

Returns a string containing the SQLSTATE error code for the last error. The error code consists of five characters. '00000' means no error.

Příklady

Příklad 1115. Object oriented style

<?php
/* Open a connection */
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$maxdb->query("CREATE TABLE temp.mycity LIKE hotel.city");
$maxdb->query("INSERT INTO temp.mycity SELECT * FROM hotel.city");

$query = "SELECT name, zip FROM temp.mycity ORDER BY name";
if ($stmt = $maxdb->prepare($query)) {

   /* drop table */
   $maxdb->query("DROP TABLE temp.mycity");

   /* execute query */
   $stmt->execute();

   printf("Error: %s.\n", $stmt->sqlstate);

   /* close statement */
   $stmt->close();
}

/* close connection */
$maxdb->close();
?>

Příklad 1116. Procedural style

<?php
/* Open a connection */
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

maxdb_query($link, "CREATE TABLE temp.mycity LIKE hotel.city");
maxdb_query($link, "INSERT INTO temp.mycity SELECT * FROM hotel.city");

$query = "SELECT name, zip FROM temp.mycity ORDER BY name";
if ($stmt = maxdb_prepare($link, $query)) {

   /* drop table */
   maxdb_query($link, "DROP TABLE temp.mycity");

   /* execute query */
   maxdb_stmt_execute($stmt);

   printf("Error: %s.\n", maxdb_stmt_sqlstate($stmt));

   /* close statement */
   maxdb_stmt_close($stmt);
}

/* close connection */
maxdb_close($link);
?>

The above examples would produce the following output:

Warning: maxdb_stmt_execute(): -4004 POS(23) Unknown table name:MYCITY [42000] <...>
Error: 42000.

Viz také

maxdb_stmt_errno()
maxdb_stmt_error()

Předcházející | Nahoru | Další
maxdb_stmt_send_long_data | Domů | maxdb_stmt_store_result


maxdb_stmt_store_result

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_stmt_store_result,

(PECL maxdb:1.0-7.6.00.38)

maxdb_stmt_store_result, maxdb->store_result — Transfers a result set from a prepared statement

Popis

Procedural style:

bool maxdb_stmt_store_result ( resource $stmt )

Object oriented style (method):

class maxdb {
object store_result ( void )
}

maxdb_stmt_store_result() has no functionally effect and should not be used for retrieving data from MaxDB server.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1117. Object oriented style

<?php
/* Open a connection */
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query = "SELECT name, zip FROM hotel.city ORDER BY name";
if ($stmt = $maxdb->prepare($query)) {

   /* execute query */
   $stmt->execute();

   /* store result */
   $stmt->store_result();

   printf("Number of rows: %d.\n", $stmt->num_rows);

   /* free result */
   $stmt->free_result();

   /* close statement */
   $stmt->close();
}

/* close connection */
$maxdb->close();
?>

Příklad 1118. Procedural style

<?php
/* Open a connection */
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query = "SELECT name, zip FROM hotel.city ORDER BY name";
if ($stmt = maxdb_prepare($link, $query)) {

   /* execute query */
   maxdb_stmt_execute($stmt);

   /* store result */
   maxdb_stmt_store_result($stmt);

   printf("Number of rows: %d.\n", maxdb_stmt_num_rows($stmt));

   /* free result */
   maxdb_stmt_free_result($stmt);

   /* close statement */
   maxdb_stmt_close($stmt);
}

/* close connection */
maxdb_close($link);
?>

The above examples would produce the following output:

Number of rows: 25.

Viz také

maxdb_prepare()
maxdb_stmt_result_metadata()
maxdb_fetch()

Předcházející | Nahoru | Další
maxdb_stmt_sqlstate | Domů | maxdb_store_result


maxdb_store_result

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_store_result,

(PECL maxdb:1.0-7.6.00.38)

maxdb_store_result, maxdb->store_result — Transfers a result set from the last query

Popis

Procedural style:

resource maxdb_store_result ( resource $link )

Object oriented style (method):

class maxdb {
object store_result ( void )
}

This function has no functionally effect.

Návratové hodnoty

Returns a result resource or FALSE if an error occurred.

Příklady

See maxdb_multi_query().

Viz také

maxdb_real_query()
maxdb_use_result()

Předcházející | Nahoru | Další
maxdb_stmt_store_result | Domů | maxdb_thread_id


maxdb_thread_id

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_thread_id,

(PECL maxdb:1.0-7.6.00.38)

maxdb_thread_id, maxdb->thread_id — Returns the thread ID for the current connection

Popis

Procedural style:

int maxdb_thread_id ( resource $link )

Object oriented style (property):

class maxdb {
int thread_id
}

The maxdb_thread_id() function returns the thread ID for the current connection which can then be killed using the maxdb_kill() function. If the connection is lost and you reconnect with maxdb_ping(), the thread ID will be other. Therefore you should get the thread ID only when you need it.

Poznámka: The thread ID is assigned on a connection-by-connection basis. Hence, if the connection is broken and then re-established a new thread ID will be assigned.

Návratové hodnoty

maxdb_thread_id() returns the Thread ID for the current connection.

Příklady

Příklad 1119. Object oriented style

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* determine our thread id */
$thread_id = $maxdb->thread_id;

/* Kill connection */
$maxdb->kill($thread_id);

/* This should produce an error */
if (!$maxdb->query("CREATE TABLE mycity LIKE hotel.city")) {
   printf("Error: %s\n", $maxdb->error);
   exit;
}

/* close connection */
$maxdb->close();
?>

Příklad 1120. Procedural style

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* determine our thread id */
$thread_id = maxdb_thread_id($link);

/* Kill connection */
maxdb_kill($link, $thread_id);

/* This should produce an error */
if (!maxdb_query($link, "CREATE TABLE mycity LIKE hotel.city")) {
   printf("Error: %s\n", maxdb_error($link));
   exit;
}

/* close connection */
maxdb_close($link);
?>

The above examples would produce the following output:

Warning: maxdb_query(): -10821 Session not connected <...>
Error: Session not connected

Viz také

maxdb_kill()

Předcházející | Nahoru | Další
maxdb_store_result | Domů | maxdb_thread_safe


maxdb_thread_safe

(No version information available, might be only in CVS)

maxdb_thread_safe — Returns whether thread safety is given or not

Popis

Procedural style:

bool maxdb_thread_safe ( void )

maxdb_thread_safe() indicates whether the client library is compiled as thread-safe.

Návratové hodnoty

TRUE if the client library is thread-safe, otherwise FALSE.

Předcházející | Nahoru | Další
maxdb_thread_id | Domů | maxdb_use_result


maxdb_use_result

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_use_result,

(PECL maxdb:1.0-7.6.00.38)

maxdb_use_result, maxdb->use_result — Initiate a result set retrieval

Popis

Procedural style:

resource maxdb_use_result ( resource $link )

Object oriented style (method):

class maxdb {
resource use_result ( void )
}

maxdb_use_result() has no effect.

Návratové hodnoty

Returns result or FALSE in case of error.

Příklady

Příklad 1121. Object oriented style

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query  = "SELECT * FROM DUAL";

/* execute multi query */
if ($maxdb->multi_query($query)) {
   do {
       /* store first result set */
       if ($result = $maxdb->use_result()) {
           while ($row = $result->fetch_row()) {
               printf("%s\n", $row[0]);
           }
           $result->close();
       }
       /* print divider */
       if ($maxdb->more_results()) {
           printf("-----------------\n");
       }
   } while ($maxdb->next_result());
}

/* close connection */
$maxdb->close();
?>

Příklad 1122. Procedural style

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$query  = "SELECT * FROM DUAL";

/* execute multi query */
if (maxdb_multi_query($link, $query)) {
   do {
       /* store first result set */
       if ($result = maxdb_use_result($link)) {
           while ($row = maxdb_fetch_row($result)) {
               printf("%s\n", $row[0]);
           }
           maxdb_free_result($result);
       }
       /* print divider */
       if (maxdb_more_results($link)) {
           printf("-----------------\n");
       }
   } while (maxdb_next_result($link));
}

/* close connection */
maxdb_close($link);
?>

The above examples would produce the following output:

a

Viz také

maxdb_real_query()
maxdb_store_result()

Předcházející | Nahoru | Další
maxdb_thread_safe | Domů | maxdb_warning_count


maxdb_warning_count

Předcházející LXXXII. MaxDB PHP Extension Další

maxdb_warning_count,

(PECL maxdb:1.0-7.6.00.38)

maxdb_warning_count, maxdb->warning_count — Returns the number of warnings from the last query for the given link

Popis

Procedural style:

int maxdb_warning_count ( resource $link )

Object oriented style (property):

class maxdb {
int warning_count
}

maxdb_warning_count() returns the number of warnings from the last query in the connection represented by the link parameter.

Návratové hodnoty

Number of warnings or zero if there are no warnings.

Příklady

Příklad 1123. Object oriented style

<?php
$maxdb = new maxdb("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

$maxdb->query("CREATE TABLE temp.mycity LIKE hotel.city");

/* a remarkable city in Wales */
$query = "INSERT INTO temp.mycity (zip, name) VALUES('11111',
       'Llanfairpwllgwyngyllgogerychwyrndrobwllllantysiliogogogoch')";

$maxdb->query($query);

printf ("Number of warning: %d\n", $maxdb->warning_count);

/* close connection */
$maxdb->close();
?>

Příklad 1124. Procedural style

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

maxdb_query($link, "CREATE TABLE temp.mycity LIKE hotel.city");

/* a remarkable long city name in Wales */
$query = "INSERT INTO temp.mycity (zip, name) VALUES('11111',
       'Llanfairpwllgwyngyllgogerychwyrndrobwllllantysiliogogogoch')";

maxdb_query($link, $query);

printf ("Number of warning: %d\n", maxdb_warning_count($link));

/* close connection */
maxdb_close($link);
?>

The above examples would produce the following output:

Warning: maxdb_query(): -8004 POS(62) Constant must be compatible with column type and length <...>
Number of warning: 0

Viz také

maxdb_errno()
maxdb_error()
maxdb_sqlstate()

Předcházející | Nahoru | Další
maxdb_use_result | Domů | LXXXIII. MCAL Functions


mb_check_encoding

(PHP 4 >= 4.4.3, PHP 5 >= 5.1.3)

mb_check_encoding — Check if the string is valid for the specified encoding

Popis

bool mb_check_encoding ( [string $var [, string $encoding]] )

mb_check_encoding() checks if the specified byte stream is valid for the specified encoding. It is useful to prevent so-called "Invalid Encoding Attack".

Seznam parametrů

var

byte stream to check. If it is omitted, this function checks all the input from the beginning of the request.

encoding

Expected encoding.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
XCVI. Multibyte String Functions | Domů | mb_convert_case


mb_stripos

(PHP 5 >= 5.2.0)

mb_stripos — Finds position of first occurrence of a string within another, case insensitive

Popis

int mb_stripos ( string $haystack, string $needle [, int $offset [, string $encoding]] )

mb_stripos() returns the numeric position of the first occurrence of needle in the haystack string. Unlike mb_strpos(), mb_stripos() is case-insensitive. If needle is not found, it returns FALSE.

Seznam parametrů

haystack

The string from which to get the position of the first occurrence of needle

needle

The string to find in haystack

offset

The position in haystack to start searching

encoding

Character encoding name to use. If it is omitted, internal character encoding is used.

Návratové hodnoty

Return the numeric position of the first occurrence of needle in the haystack string, or FALSE if needle is not found.

Viz také

stripos()
strpos()
mb_strpos()

Předcházející | Nahoru | Další
mb_strimwidth | Domů | mb_stristr


mb_stristr

(PHP 5 >= 5.2.0)

mb_stristr — Finds first occurrence of a string within another, case insensitive

Popis

string mb_stristr ( string $haystack, string $needle [, bool $part [, string $encoding]] )

mb_stristr() finds the first occurrence of needle in haystack and returns the portion of haystack. Unlike mb_strstr(), mb_stristr() is case-insensitive. If needle is not found, it returns FALSE.

Seznam parametrů

haystack

The string from which to get the first occurrence of needle

needle

The string to find in haystack

part

Determines which portion of haystack this function returns. If set to TRUE, it returns all of haystack from the beginning to the first occurrence of needle. If set to FALSE, it returns all of haystack from the first occurrence of needle to the end, Default value is FALSE.

encoding

Character encoding name to use. If it is omitted, internal character encoding is used.

Návratové hodnoty

Returns the portion of haystack, or FALSE if needle is not found.

Viz také

stristr()
strstr()
mb_strstr()

Předcházející | Nahoru | Další
mb_stripos | Domů | mb_strlen


mb_strrchr

(PHP 5 >= 5.2.0)

mb_strrchr — Finds the last occurrence of a character in a string within another

Popis

string mb_strrchr ( string $haystack, string $needle [, bool $part [, string $encoding]] )

mb_strrchr() finds the last occurrence of needle in haystack and returns the portion of haystack. If needle is not found, it returns FALSE.

Seznam parametrů

haystack

The string from which to get the last occurrence of needle

needle

The string to find in haystack

part

Determines which portion of haystack this function returns. If set to TRUE, it returns all of haystack from the beginning to the last occurrence of needle. If set to FALSE, it returns all of haystack from the last occurrence of needle to the end, Default value is FALSE.

encoding

Character encoding name to use. If it is omitted, internal character encoding is used.

Návratové hodnoty

Returns the portion of haystack. or FALSE if needle is not found.

Viz také

strrchr()
mb_strstr()
mb_strrichr()

Předcházející | Nahoru | Další
mb_strpos | Domů | mb_strrichr


mb_strrichr

(PHP 5 >= 5.2.0)

mb_strrichr — Finds the last occurrence of a character in a string within another, case insensitive

Popis

string mb_strrichr ( string $haystack, string $needle [, bool $part [, string $encoding]] )

mb_strrichr() finds the last occurrence of needle in haystack and returns the portion of haystack. Unlike mb_strrchr(), mb_strrichr() is case-insensitive. If needle is not found, it returns FALSE.

Seznam parametrů

haystack

The string from which to get the last occurrence of needle

needle

The string to find in haystack

part

Determines which portion of haystack this function returns. If set to TRUE, it returns all of haystack from the beginning to the last occurrence of needle. If set to FALSE, it returns all of haystack from the last occurrence of needle to the end, Default value is FALSE.

encoding

Character encoding name to use. If it is omitted, internal character encoding is used.

Návratové hodnoty

Returns the portion of haystack. or FALSE if needle is not found.

Viz také

mb_stristr()
mb_strrchr()

Předcházející | Nahoru | Další
mb_strrchr | Domů | mb_strripos


mb_strripos

(PHP 5 >= 5.2.0)

mb_strripos — Finds position of last occurrence of a string within another, case insensitive

Popis

int mb_strripos ( string $haystack, string $needle [, int $offset [, string $encoding]] )

mb_strripos() performs multi-byte safe strripos() operation based on number of characters. needle position is counted from the beginning of haystack. First character's position is 0. Second character position is 1. Unlike mb_strrpos(), mb_strripos() is case-insensitive.

Seznam parametrů

haystack

The string from which to get the position of the last occurrence of needle

needle

The string to find in haystack

offset

The position in haystack to start searching

encoding

Character encoding name to use. If it is omitted, internal character encoding is used.

Návratové hodnoty

Return the numeric position of the last occurrence of needle in the haystack string, or FALSE if needle is not found.

Viz také

strripos()
strrpos()
mb_strrpos()

Předcházející | Nahoru | Další
mb_strrichr | Domů | mb_strrpos


mb_strstr

(PHP 5 >= 5.2.0)

mb_strstr — Finds first occurrence of a string within another

Popis

string mb_strstr ( string $haystack, string $needle [, bool $part [, string $encoding]] )

mb_strstr() finds the first occurrence of needle in haystack and returns the portion of haystack. If needle is not found, it returns FALSE.

Seznam parametrů

haystack

The string from which to get the first occurrence of needle

needle

The string to find in haystack

part

Determines which portion of haystack this function returns. If set to TRUE, it returns all of haystack from the beginning to the first occurrence of needle. If set to FALSE, it returns all of haystack from the first occurrence of needle to the end, Default value is FALSE.

encoding

Character encoding name to use. If it is omitted, internal character encoding is used.

Návratové hodnoty

Returns the portion of haystack, or FALSE if needle is not found.

Viz také

stristr()
strstr()
mb_stristr()

Předcházející | Nahoru | Další
mb_strrpos | Domů | mb_strtolower


Memcache::addServer

(No version information available, might be only in CVS)

Memcache::addServer — Add a memcached server to connection pool

Popis

bool Memcache::addServer ( string $host [, int $port [, bool $persistent [, int $weight [, int $timeout [, int $retry_interval [, bool $status [, callback $failure_callback]]]]]]] )

Memcache::addServer() adds a server to the connection pool. The connection, which was opened using Memcache::addServer() will be automatically closed at the end of script execution, you can also close it manually with Memcache::close(). You can also use the memcache_add_server() function.

When using this method (as opposed to Memcache::connect()() and Memcache::pconnect()()) the network connection is not established until actually needed. Thus there is no overhead in adding a large number of servers to the pool, even though they might not all be used.

Failover may occur at any stage in any of the methods, as long as other servers are available the request the user won't notice. Any kind of socket or Memcached server level errors (except out-of-memory) may trigger the failover. Normal client errors such as adding an existing key will not trigger a failover.

Poznámka: This function has been added to Memcache version 2.0.0.

Seznam parametrů

host

Point to the host where memcached is listening for connections. This parameter may also specify other transports like unix:///path/to/memcached.sock to use UNIX domain sockets, in this case port must also be set to 0.

port

Point to the port where memcached is listening for connections. This parameter is optional and its default value is 11211. Set this parameter to 0 when using UNIX domain sockets.

persistent

Controls the use of a persistent connection. Default to TRUE.

weight

Number of buckets to create for this server which in turn control its probability of it being selected. The probability is relative to the total weight of all servers.

timeout

Value in seconds which will be used for connecting to the daemon. Think twice before changing the default value of 1 second - you can lose all the advantages of caching if your connection is too slow.

retry_interval

Controls how often a failed server will be retried, the default value is 15 seconds. Setting this parameter to -1 disables automatic retry. Neither this nor the persistent parameter has any effect when the extension is loaded dynamically via dl().

Each failed connection struct has its own timeout and before it has expired the struct will be skipped when selecting backends to serve a request. Once expired the connection will be successfully reconnected or marked as failed for another retry_interval seconds. The typical effect is that each web server child will retry the connection about every retry_interval seconds when serving a page.

status

Controls if the server should be flagged as online. Setting this parameter to FALSE and retry_interval to -1 allows a failed server to be kept in the pool so as not to affect the key distribution algoritm. Requests for this server will then failover or fail immediatly depending on the memcache.allow_failover setting. Default to TRUE, meaning the server should be considered online.

failure_callback

Allows the user to specify a callback function to run upon encountering an error. The callback is run before failover is attemped. The function takes two parameters, the hostname and port of the failed server.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1145. Memcache::addServer() example

<?php

/* OO API */

$memcache = new Memcache;
$memcache->addServer('memcache_host', 11211);
$memcache->addServer('memcache_host2', 11211);

/* procedural API */

$memcache_obj = memcache_connect('memcache_host', 11211);
memcache_add_server($memcache_obj, 'memcache_host2', 11211);

?>

Viz také

Memcache::connect()
Memcache::pconnect()
Memcache::close()
Memcache::setServerParams()
Memcache::getServerStatus()

Předcházející | Nahoru | Další
Memcache::add | Domů | Memcache::close


Memcache::getExtendedStats

(No version information available, might be only in CVS)

Memcache::getExtendedStats — Get statistics from all servers in pool

Popis

array Memcache::getExtendedStats ( [string $type [, int $slabid [, int $limit]]] )

Memcache::getExtendedStats() returns a two-dimensional associative array with server statistics. Array keys correspond to host:port of server and values contain the individual server statistics. A failed server will have its corresponding entry set to FALSE. You can also use the memcache_get_extended_stats() function.

Poznámka: This function has been added to Memcache version 2.0.0.

Seznam parametrů

type

The type of statistics to fetch. Valid values are {reset, malloc, maps, cachedump, slabs, items, sizes}. According to the memcached protocol spec these additional arguments "are subject to change for the convenience of memcache developers".

slabid

Used in conjunction with type set to cachedump to identify the slab to dump from. The cachedump command ties up the server and is strictly to be used for debugging purposes.

limit

Used in conjunction with type set to cachedump to limit the number of entries to dump. Default value is 100.

Návratové hodnoty

Returns a two-dimensional associative array of server statistics or FALSE on failure.

Příklady

Příklad 1152. Memcache::getExtendedStats() example

<?php
    $memcache_obj = new Memcache;
    $memcache_obj->addServer('memcache_host', 11211);
    $memcache_obj->addServer('failed_host', 11211);

    $stats = $memcache_obj->getExtendedStats();
    print_r($stats);
?>

Výše uvedený příklad vypíše:

Array
(
    [memcache_host:11211] => Array
        (
            [pid] => 3756
            [uptime] => 603011
            [time] => 1133810435
            [version] => 1.1.12
            [rusage_user] => 0.451931
            [rusage_system] => 0.634903
            [curr_items] => 2483
            [total_items] => 3079
            [bytes] => 2718136
            [curr_connections] => 2
            [total_connections] => 807
            [connection_structures] => 13
            [cmd_get] => 9748
            [cmd_set] => 3096
            [get_hits] => 5976
            [get_misses] => 3772
            [bytes_read] => 3448968
            [bytes_written] => 2318883
            [limit_maxbytes] => 33554432
        )

    [failed_host:11211] => false
)

Viz také

Memcache::getVersion()
Memcache::getStats()

Předcházející | Nahoru | Další
Memcache::get | Domů | Memcache::getServerStatus


Memcache::getServerStatus

(No version information available, might be only in CVS)

Memcache::getServerStatus — Returns server status

Popis

int Memcache::getServerStatus ( string $host [, int $port] )

Memcache::getServerStatus() returns a the servers online/offline status. You can also use memcache_get_server_status() function.

Poznámka: This function has been added to Memcache version 2.1.0.

Seznam parametrů

host

Point to the host where memcached is listening for connections.

port

Point to the port where memcached is listening for connections. This parameter is optional and its default value is 11211.

Návratové hodnoty

Returns a the servers status. 0 if server is failed, non-zero otherwise

Příklady

Příklad 1153. Memcache::getServerStatus() example

<?php

/* OO API */
$memcache = new Memcache;
$memcache->addServer('memcache_host', 11211);
echo $memcache->getServerStatus('memcache_host', 11211);

/* procedural API */
$memcache = memcache_connect('memcache_host', 11211);
echo memcache_get_server_status($memcache, 'memcache_host', 11211);

?>

Viz také

Memcache::addServer()
Memcache::setServerParams()

Předcházející | Nahoru | Další
Memcache::getExtendedStats | Domů | Memcache::getStats


Memcache::setCompressThreshold

(No version information available, might be only in CVS)

Memcache::setCompressThreshold — Enable automatic compression of large values

Popis

bool Memcache::setCompressThreshold ( int $threshold [, float $min_savings] )

Memcache::setCompressThreshold() enables automatic compression of large values. You can also use the memcache_set_compress_threshold() function.

Poznámka: This function has been added to Memcache version 2.0.0.

Seznam parametrů

threshold

Controls the minimum value length before attempting to compress automatically.

min_saving

Specifies the minimum amount of savings to actually store the value compressed. The supplied value must be between 0 and 1. Default value is 0.2 giving a minimum 20% compression savings.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1160. Memcache::setCompressThreshold() example

<?php

/* OO API */

$memcache_obj = new Memcache;
$memcache_obj->addServer('memcache_host', 11211);
$memcache_obj->setCompressThreshold(20000, 0.2);

/* procedural API */

$memcache_obj = memcache_connect('memcache_host', 11211);
memcache_set_compress_threshold($memcache_obj, 20000, 0.2);

?>

Předcházející | Nahoru | Další
Memcache::set | Domů | Memcache::setServerParams


Memcache::setServerParams

(No version information available, might be only in CVS)

Memcache::setServerParams — Changes server parameters and status at runtime

Popis

bool Memcache::setServerParams ( string $host [, int $port [, int $timeout [, int $retry_interval [, bool $status [, callback $failure_callback]]]]] )

Memcache::setServerParams() changes server parameters at runtime. You can also use the memcache_set_server_params() function.

Poznámka: This function has been added to Memcache version 2.1.0.

Seznam parametrů

host

Point to the host where memcached is listening for connections.

port

Point to the port where memcached is listening for connections. This parameter is optional and its default value is 11211.

timeout

Value in seconds which will be used for connecting to the daemon. Think twice before changing the default value of 1 second - you can lose all the advantages of caching if your connection is too slow.

retry_interval

Controls how often a failed server will be retried, the default value is 15 seconds. Setting this parameter to -1 disables automatic retry. Neither this nor the persistent parameter has any effect when the extension is loaded dynamically via dl().

status

Controls if the server should be flagged as online. Setting this parameter to FALSE and retry_interval to -1 allows a failed server to be kept in the pool so as not to affect the key distribution algoritm. Requests for this server will then failover or fail immediatly depending on the memcache.allow_failover setting. Default to TRUE, meaning the server should be considered online.

failure_callback

Allows the user to specify a callback function to run upon encountering an error. The callback is run before failover is attemped. The function takes two parameters, the hostname and port of the failed server.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1161. Memcache::setServerParams() example

<?php

function _callback_memcache_failure($host, $port) {
    print "memcache '$host:$port' failed";
}

/* OO API */

$memcache = new Memcache;

// Add the server in offline mode
$memcache->addServer('memcache_host', 11211, false, 1, 1, -1, false);

// Bring the server back online
$memcache->setServerParams('memcache_host', 11211, 1, 15, true, '_callback_memcache_failure');

/* procedural API */

$memcache_obj = memcache_connect('memcache_host', 11211);
memcache_set_server_params($memcache_obj, 'memcache_host', 11211, 1, 15, true, '_callback_memcache_failure');

?>

Viz také

Memcache::addServer()
Memcache::getServerStatus()

Předcházející | Nahoru | Další
Memcache::setCompressThreshold | Domů | LXXXVII. Mhash funkce


memory_get_peak_usage

(PHP 5 >= 5.2.0)

memory_get_peak_usage — Returns the peak of memory allocated by PHP

Popis

int memory_get_peak_usage ( [bool $real_usage] )

Returns the peak of memory, in bytes, that's been allocated to your PHP script.

Seznam parametrů

real_usage

Set this to TRUE to get the real size of memory allocated from system. If not set or FALSE only the memory used by emalloc() is reported.

Návratové hodnoty

Returns the memory peak in bytes.

ChangeLog (záznam změn)

Verze | Popis
5.2.1 | Compiling with --enable-memory-limit is no longer required for this function to exist.
5.2.0 | real_usage was added.

Viz také

memory_get_usage()
memory_limit

Předcházející | Nahoru | Další
main | Domů | memory_get_usage


ming_keypress

(PHP 5)

ming_keypress — Returns the action flag for keyPress(char)

Popis

int ming_keypress ( string $char )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
SWFVideoStream->setDimension() | Domů | ming_setcubicthreshold


ming_setswfcompression

(PHP 5 >= 5.2.1)

ming_setswfcompression — Sets the SWF output compression

Popis

void ming_setswfcompression ( int $level )

Sets the SWF output compression level.

Seznam parametrů

level

The new compression level. Should be a value between 1 and 9 inclusive.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ming_setscale | Domů | ming_useconstants


ming_useconstants

(PHP 5)

ming_useconstants — Use constant pool

Popis

void ming_useconstants ( int $use )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
ming_setswfcompression | Domů | ming_useswfversion


mysql_set_charset

(PHP 5 >= 5.2.3)

mysql_set_charset — Sets the client character set

Popis

bool mysql_set_charset ( string $charset [, resource $link_identifier] )

Sets the default character set for the current connection.

Seznam parametrů

charset

A valid character set name.

link_identifier

Připojení na MySQL. Není-li specifikován identifikátor připojení, předpokládá se poslední otevřené pomocí mysql_connect(). Není-li nalezeno, zkusí se vytvořit nové, jako kdyby se zavolala funkce mysql_connect() bez argumentů. Nepodařilo-li se připojení nalézt ani vytvořit, vygeneruje se varování na úrovni E_WARNING.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Poznámky

Poznámka: This function requires MySQL 5.0.7 or later.

Předcházející | Nahoru | Další
mysql_select_db | Domů | mysql_stat


mysqli_embedded_server_end

(PHP 5 >= 5.1.0)

mysqli_embedded_server_end

Popis

void mysqli_embedded_server_end ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
mysqli_dump_debug_info | Domů | mysqli_embedded_server_start


mysqli_embedded_server_start

(PHP 5 >= 5.1.0)

mysqli_embedded_server_start

Popis

bool mysqli_embedded_server_start ( bool $start, array $arguments, array $groups )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
mysqli_embedded_server_end | Domů | mysqli_enable_reads_from_master


mysqli_get_charset

(PHP 5 >= 5.1.0)

mysqli_get_charset — Returns a character set object

Popis

object mysqli_get_charset ( mysqli $link )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
mysqli_free_result | Domů | mysqli_get_client_info


mysqli_get_warnings

(PHP 5 >= 5.1.0)

mysqli_get_warnings

Popis

object mysqli_get_warnings ( mysqli $link )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
mysqli_get_server_version | Domů | mysqli_info


mysqli_set_charset

Předcházející C. MySQL Improved Extension Další

mysqli_set_charset,

(PHP 5 >= 5.0.5)

mysqli_set_charset, mysqli->set_charset — Sets the default client character set

Popis

Procedural style:

bool mysqli_set_charset ( mysqli $link, string $charset )

Object oriented style (method):

class mysqli {
bool set_charset ( string $charset )
}

Sets the default character set to be used when sending data from and to the database server.

Seznam parametrů

link

Procedural style only: A link identifier returned by mysqli_connect() or mysqli_init()

charset

The charset to be set as default.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Poznámky

Poznámka: To use this function on a Windows platform you need MySQL client library version 4.1.11 or above (for MySQL 5.0 you need 5.0.6 or above). It can be downloaded at » http://dev.mysql.com/downloads/connector/php/.

Příklady

Příklad 1363. Object oriented style

<?php
$mysqli = new mysqli("localhost", "my_user", "my_password", "test");

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* change character set to utf8 */
if (!$mysqli->set_charset("utf8")) {
    printf("Error loading character set utf8: %s\n", $mysqli->error);
} else {
    printf("Current character set: %s\n", $mysqli->character_set_name());
}

$mysqli->close();
?>

Příklad 1364. Procedural style

<?php
$link = mysqli_connect('localhost', 'my_user', 'my_password', 'test');

/* check connection */
if (mysqli_connect_errno()) {
    printf("Connect failed: %s\n", mysqli_connect_error());
    exit();
}

/* change character set to utf8 */
if (!mysqli_set_charset($link, "utf8")) {
    printf("Error loading character set utf8: %s\n", mysqli_error($link));
} else {
    printf("Current character set: %s\n", mysqli_character_set_name($link));
}

mysqli_close($link);
?>

Výše uvedený příklad vypíše:

Current character set: utf8

Viz také

mysqli_character_set_name()
mysqli_real_escape_string()

Předcházející | Nahoru | Další
mysqli_server_init | Domů | mysqli_set_local_infile_default


mysqli_set_local_infile_default

(PHP 5)

mysqli_set_local_infile_default — Unsets user defined handler for load local infile command

Popis

void mysqli_set_local_infile_default ( mysqli $link )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
mysqli_set_charset | Domů | mysqli_set_local_infile_handler


mysqli_set_local_infile_handler

(PHP 5)

mysqli_set_local_infile_handler — Set callback functions for LOAD DATA LOCAL INFILE command

Popis

bool mysqli_set_local_infile_handler ( mysqli $link, callback $read_func )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
mysqli_set_local_infile_default | Domů | mysqli_set_opt


mysqli_slave_query

(PHP 5)

mysqli_slave_query — Force execution of a query on a slave in a master/slave setup

Popis

bool mysqli_slave_query ( mysqli $link, string $query )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
mysqli_set_opt | Domů | mysqli_sqlstate


mysqli_stmt_attr_get

(PHP 5)

mysqli_stmt_attr_get

Popis

int mysqli_stmt_attr_get ( mysqli_stmt $stmt, int $attr )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
mysqli_stmt_affected_rows | Domů | mysqli_stmt_attr_set


mysqli_stmt_attr_set

(PHP 5)

mysqli_stmt_attr_set

Popis

bool mysqli_stmt_attr_set ( mysqli_stmt $stmt, int $attr, int $mode )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
mysqli_stmt_attr_get | Domů | mysqli_stmt_bind_param


mysqli_stmt_field_count

(PHP 5)

mysqli_stmt_field_count — Returns the number of field in the given statement

Popis

int mysqli_stmt_field_count ( mysqli_stmt $stmt )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
mysqli_stmt_fetch | Domů | mysqli_stmt_free_result


mysqli_stmt_get_warnings

(PHP 5 >= 5.1.0)

mysqli_stmt_get_warnings

Popis

object mysqli_stmt_get_warnings ( mysqli_stmt $stmt )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
mysqli_stmt_free_result | Domů | mysqli_stmt_init


mysqli_stmt_insert_id

(PHP 5)

mysqli_stmt_insert_id — Get the ID generated from the previous INSERT operation

Popis

mixed mysqli_stmt_insert_id ( mysqli_stmt $stmt )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
mysqli_stmt_init | Domů | mysqli_stmt_num_rows


newt_bell

(PECL newt:0.1-1.1)

newt_bell — Send a beep to the terminal

Popis

void newt_bell ( void )

This function sends a beep to the terminal.

Poznámka: Depending on the terminal's settings, this beep may or may not be audible.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
CIII. Newt Functions | Domů | newt_button_bar


newt_button

(PECL newt:0.1-1.1)

newt_button — Create a new button

Popis

resource newt_button ( int $left, int $top, string $text )

Creates a new button.

Seznam parametrů

left

X-coordinate of the button.

top

Y-coordinate of the button.

text

The text which should be displayed in the button.

Návratové hodnoty

Returns a resource link to the created button component, or FALSE on error.

Příklady

Příklad 1420. A newt_button() example

<?php

$form = newt_form();

$ok_button = newt_button(5, 12, "Run Tool");

newt_form_add_component($form, $ok_button);

?>

Viz také

newt_button_bar()

Předcházející | Nahoru | Další
newt_button_bar | Domů | newt_centered_window


newt_button_bar

(PECL newt:0.1-1.1)

newt_button_bar — This function returns a grid containing the buttons created.

Popis

resource newt_button_bar ( array &$buttons )

This function returns a grid containing the buttons created.

Seznam parametrů

buttons

Návratové hodnoty

Returns grid containing the buttons created.

Předcházející | Nahoru | Další
newt_bell | Domů | newt_button


newt_centered_window

(PECL newt:0.1-1.1)

newt_centered_window — Open a centered window of the specified size

Popis

int newt_centered_window ( int $width, int $height [, string $title] )

Open a centered window of the specified size.

Seznam parametrů

width

Window width

height

Window height

title

Window title

Návratové hodnoty

Undefined value.

Viz také

newt_pop_window()
newt_open_window()

Předcházející | Nahoru | Další
newt_button | Domů | newt_checkbox_get_value


newt_checkbox

(PECL newt:0.1-1.1)

newt_checkbox

Popis

resource newt_checkbox ( int $left, int $top, string $text, string $def_value [, string $seq] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

left

top

text

def_value

seq

Návratové hodnoty

Předcházející | Nahoru | Další
newt_checkbox_tree | Domů | newt_clear_key_buffer


newt_checkbox_get_value

(PECL newt:0.1-1.1)

newt_checkbox_get_value — Retreives value of checkox resource

Popis

string newt_checkbox_get_value ( resource $checkbox )

This function returns the character in the sequence which indicates the current value of the checkbox.

Seznam parametrů

checkbox

Návratové hodnoty

Returns character indicating the value of the checkbox.

Předcházející | Nahoru | Další
newt_centered_window | Domů | newt_checkbox_set_flags


newt_checkbox_set_flags

(PECL newt:0.1-1.1)

newt_checkbox_set_flags — Configures checkbox resource

Popis

void newt_checkbox_set_flags ( resource $checkbox, int $flags, int $sense )

This function allows to set various flags on checkbox resource.

Seznam parametrů

checkbox

flags

sense

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
newt_checkbox_get_value | Domů | newt_checkbox_set_value


newt_checkbox_set_value

(PECL newt:0.1-1.1)

newt_checkbox_set_value — Sets the value of the checkbox

Popis

void newt_checkbox_set_value ( resource $checkbox, string $value )

This function allows to set the current value of the checkbox resource.

Seznam parametrů

checkbox

value

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
newt_checkbox_set_flags | Domů | newt_checkbox_tree_add_item


newt_checkbox_tree

(PECL newt:0.1-1.1)

newt_checkbox_tree

Popis

resource newt_checkbox_tree ( int $left, int $top, int $height [, int $flags] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

left

top

height

flags

Návratové hodnoty

Předcházející | Nahoru | Další
newt_checkbox_tree_set_width | Domů | newt_checkbox


newt_checkbox_tree_add_item

(PECL newt:0.1-1.1)

newt_checkbox_tree_add_item — Adds new item to the checkbox tree

Popis

void newt_checkbox_tree_add_item ( resource $checkboxtree, string $text, mixed $data, int $flags, int $index [, int $...] )

This function allows to add new item to the checkbox tree.

Seznam parametrů

checkboxtree

text

data

flags

index

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
newt_checkbox_set_value | Domů | newt_checkbox_tree_find_item


newt_checkbox_tree_find_item

(PECL newt:0.1-1.1)

newt_checkbox_tree_find_item — Finds an item in the checkbox tree

Popis

array newt_checkbox_tree_find_item ( resource $checkboxtree, mixed $data )

Finds an item in the checkbox tree by item's data.

Seznam parametrů

checkboxtree

data

Návratové hodnoty

Returns checkbox tree item resource, or NULL if it wasn't found.

Předcházející | Nahoru | Další
newt_checkbox_tree_add_item | Domů | newt_checkbox_tree_get_current


newt_checkbox_tree_get_current

(PECL newt:0.1-1.1)

newt_checkbox_tree_get_current — Returns checkbox tree selected item

Popis

mixed newt_checkbox_tree_get_current ( resource $checkboxtree )

This method returns checkbox tree selected tem.

Seznam parametrů

checkboxtree

Návratové hodnoty

Returns current (selected) checkbox tree item.

Předcházející | Nahoru | Další
newt_checkbox_tree_find_item | Domů | newt_checkbox_tree_get_entry_value


newt_checkbox_tree_get_entry_value

(PECL newt:0.1-1.1)

newt_checkbox_tree_get_entry_value

Popis

string newt_checkbox_tree_get_entry_value ( resource $checkboxtree, mixed $data )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

checkboxtree

data

Návratové hodnoty

Předcházející | Nahoru | Další
newt_checkbox_tree_get_current | Domů | newt_checkbox_tree_get_multi_selection


newt_checkbox_tree_get_multi_selection

(PECL newt:0.1-1.1)

newt_checkbox_tree_get_multi_selection

Popis

array newt_checkbox_tree_get_multi_selection ( resource $checkboxtree, string $seqnum )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

checkboxtree

seqnum

Návratové hodnoty

Předcházející | Nahoru | Další
newt_checkbox_tree_get_entry_value | Domů | newt_checkbox_tree_get_selection


newt_checkbox_tree_get_selection

(PECL newt:0.1-1.1)

newt_checkbox_tree_get_selection

Popis

array newt_checkbox_tree_get_selection ( resource $checkboxtree )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

checkboxtree

Návratové hodnoty

Předcházející | Nahoru | Další
newt_checkbox_tree_get_multi_selection | Domů | newt_checkbox_tree_multi


newt_checkbox_tree_multi

(PECL newt:0.1-1.1)

newt_checkbox_tree_multi

Popis

resource newt_checkbox_tree_multi ( int $left, int $top, int $height, string $seq [, int $flags] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

left

top

height

seq

flags

Návratové hodnoty

Předcházející | Nahoru | Další
newt_checkbox_tree_get_selection | Domů | newt_checkbox_tree_set_current


newt_checkbox_tree_set_current

(PECL newt:0.1-1.1)

newt_checkbox_tree_set_current

Popis

void newt_checkbox_tree_set_current ( resource $checkboxtree, mixed $data )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

checkboxtree

data

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
newt_checkbox_tree_multi | Domů | newt_checkbox_tree_set_entry_value


newt_checkbox_tree_set_entry

(PECL newt:0.1-1.1)

newt_checkbox_tree_set_entry

Popis

void newt_checkbox_tree_set_entry ( resource $checkboxtree, mixed $data, string $text )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

checkboxtree

data

text

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
newt_checkbox_tree_set_entry_value | Domů | newt_checkbox_tree_set_width


newt_checkbox_tree_set_entry_value

(PECL newt:0.1-1.1)

newt_checkbox_tree_set_entry_value

Popis

void newt_checkbox_tree_set_entry_value ( resource $checkboxtree, mixed $data, string $value )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

checkboxtree

data

value

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
newt_checkbox_tree_set_current | Domů | newt_checkbox_tree_set_entry


newt_checkbox_tree_set_width

(PECL newt:0.1-1.1)

newt_checkbox_tree_set_width

Popis

void newt_checkbox_tree_set_width ( resource $checkbox_tree, int $width )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

checkbox_tree

width

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
newt_checkbox_tree_set_entry | Domů | newt_checkbox_tree


newt_clear_key_buffer

(PECL newt:0.1-1.1)

newt_clear_key_buffer — Discards the contents of the terminal's input buffer without waiting for additional input

Popis

void newt_clear_key_buffer ( void )

Discards the contents of the terminal's input buffer without waiting for additional input.

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

newt_wait_for_key()

Předcházející | Nahoru | Další
newt_checkbox | Domů | newt_cls


newt_cls

(PECL newt:0.1-1.1)

newt_cls

Popis

void newt_cls ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
newt_clear_key_buffer | Domů | newt_compact_button


newt_compact_button

(PECL newt:0.1-1.1)

newt_compact_button

Popis

resource newt_compact_button ( int $left, int $top, string $text )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

left

top

text

Návratové hodnoty

Předcházející | Nahoru | Další
newt_cls | Domů | newt_component_add_callback


newt_component_add_callback

(PECL newt:0.1-1.1)

newt_component_add_callback

Popis

void newt_component_add_callback ( resource $component, mixed $func_name, mixed $data )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

component

func_name

data

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
newt_compact_button | Domů | newt_component_takes_focus


newt_component_takes_focus

(PECL newt:0.1-1.1)

newt_component_takes_focus

Popis

void newt_component_takes_focus ( resource $component, bool $takes_focus )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

component

takes_focus

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
newt_component_add_callback | Domů | newt_create_grid


newt_create_grid

(PECL newt:0.1-1.1)

newt_create_grid

Popis

resource newt_create_grid ( int $cols, int $rows )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

cols

rows

Návratové hodnoty

Předcházející | Nahoru | Další
newt_component_takes_focus | Domů | newt_cursor_off


newt_cursor_off

(PECL newt:0.1-1.1)

newt_cursor_off

Popis

void newt_cursor_off ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
newt_create_grid | Domů | newt_cursor_on


newt_cursor_on

(PECL newt:0.1-1.1)

newt_cursor_on

Popis

void newt_cursor_on ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
newt_cursor_off | Domů | newt_delay


newt_delay

(PECL newt:0.1-1.1)

newt_delay

Popis

void newt_delay ( int $microseconds )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

microseconds

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
newt_cursor_on | Domů | newt_draw_form


newt_draw_form

(PECL newt:0.1-1.1)

newt_draw_form

Popis

void newt_draw_form ( resource $form )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

form

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
newt_delay | Domů | newt_draw_root_text


newt_draw_root_text

(PECL newt:0.1-1.1)

newt_draw_root_text — Displays the string text at the position indicated

Popis

void newt_draw_root_text ( int $left, int $top, string $text )

Displays the string text at the position indicated.

Seznam parametrů

left

Column number

Poznámka: If left is negative, the position is measured from the opposite side of the screen.

top

Line number

Poznámka: If top is negative, the position is measured from the opposite side of the screen.

text

Text to display.

Návratové hodnoty

Nevrací se žádná hodnota.

Příklady

Příklad 1421. A newt_draw_root_text() example

This code demonstrates drawing of titles in the both corners of the screen.

<?php
 newt_init();
 newt_cls();

 newt_draw_root_text (2, 0, "Some root text");
 newt_refresh();
 sleep(1);

 newt_draw_root_text (-30, 0, "Root text in the other corner");
 newt_refresh();
 sleep(1);

 newt_finished();
?>

Viz také

newt_push_help_line()
newt_pop_help_line()

Předcházející | Nahoru | Další
newt_draw_form | Domů | newt_entry_get_value


newt_entry

(PECL newt:0.1-1.1)

newt_entry

Popis

resource newt_entry ( int $left, int $top, int $width [, string $init_value [, int $flags]] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

left

top

width

init_value

flags

Návratové hodnoty

Předcházející | Nahoru | Další
newt_entry_set | Domů | newt_finished


newt_entry_get_value

(PECL newt:0.1-1.1)

newt_entry_get_value

Popis

string newt_entry_get_value ( resource $entry )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

entry

Návratové hodnoty

Předcházející | Nahoru | Další
newt_draw_root_text | Domů | newt_entry_set_filter


newt_entry_set

(PECL newt:0.1-1.1)

newt_entry_set

Popis

void newt_entry_set ( resource $entry, string $value [, bool $cursor_at_end] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

entry

value

cursor_at_end

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
newt_entry_set_flags | Domů | newt_entry


newt_entry_set_filter

(PECL newt:0.1-1.1)

newt_entry_set_filter

Popis

void newt_entry_set_filter ( resource $entry, callback $filter, mixed $data )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

entry

filter

data

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
newt_entry_get_value | Domů | newt_entry_set_flags


newt_entry_set_flags

(PECL newt:0.1-1.1)

newt_entry_set_flags

Popis

void newt_entry_set_flags ( resource $entry, int $flags, int $sense )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

entry

flags

sense

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
newt_entry_set_filter | Domů | newt_entry_set


newt_finished

(PECL newt:0.1-1.1)

newt_finished — Uninitializes newt interface

Popis

int newt_finished ( void )

Uninitializes newt interface. This function be called, when program is ready to exit.

Návratové hodnoty

Returns 1 on success, 0 on failure.

Viz také

newt_init()

Předcházející | Nahoru | Další
newt_entry | Domů | newt_form_add_component


newt_form

(PECL newt:0.1-1.1)

newt_form — Create a form

Popis

resource newt_form ( [resource $vert_bar [, string $help [, int $flags]]] )

Create a new form.

Seznam parametrů

vert_bar

Vertical scrollbar which should be associated with the form

help

Help text string

flags

Various flags

Návratové hodnoty

Returns a resource link to the created form component, or FALSE on error.

Příklady

Příklad 1424. A newt_form() example

Displays a single button "Quit", which closes the application once it's pressed.

<?php
newt_init();
newt_cls();

$myform = newt_form();
$button = newt_button (5, 12, "Quit");

newt_form_add_component ($myform, $button);
newt_refresh ();
newt_run_form ($myform);

newt_finished ();
newt_form_destroy ($myform);
?>

Viz také

newt_form_run()
newt_run_form()
newt_form_add_component()
newt_form_add_components()
newt_form_destroy()

Předcházející | Nahoru | Další
newt_form_watch_fd | Domů | newt_get_screen_size


newt_form_add_component

(PECL newt:0.1-1.1)

newt_form_add_component — Adds a single component to the form

Popis

void newt_form_add_component ( resource $form, resource $component )

Adds a single component to the form.

Seznam parametrů

form

Form to which component will be added

component

Component to add to the form

Návratové hodnoty

Nevrací se žádná hodnota.

Příklady

Příklad 1422. A newt_form_add_component() example

<?php
$form = newt_form();

$options = array("Authentication configuration", "Firewall configuration",
"Mouse configuration", "Network configuration", "Printer configuration",
"System services");

$list = newt_listbox(3, 2, 10);

foreach ($options as $l_item) {
    newt_listbox_add_entry($list, $l_item, $l_item);
}

newt_form_add_component($form, $list);
?>

Viz také

newt_form_add_components()

Předcházející | Nahoru | Další
newt_finished | Domů | newt_form_add_components


newt_form_add_components

(PECL newt:0.1-1.1)

newt_form_add_components — Add several components to the form

Popis

void newt_form_add_components ( resource $form, array $components )

Adds several components to the form.

Seznam parametrů

form

Form to which components will be added

components

Array of components to add to the form

Návratové hodnoty

Nevrací se žádná hodnota.

Příklady

Příklad 1423. A newt_form_add_components() example

<?php
$form = newt_form();

$b1 = newt_button(5, 12, "Run Tool");
$b2 = newt_button(21, 12, "Quit");

newt_form_add_components($form, array($b1, $b2));
?>

Viz také

newt_form_add_component()

Předcházející | Nahoru | Další
newt_form_add_component | Domů | newt_form_add_hot_key


newt_form_add_hot_key

(PECL newt:0.1-1.1)

newt_form_add_hot_key

Popis

void newt_form_add_hot_key ( resource $form, int $key )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

form

key

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
newt_form_add_components | Domů | newt_form_destroy


newt_form_destroy

(PECL newt:0.1-1.1)

newt_form_destroy — Destroys a form

Popis

void newt_form_destroy ( resource $form )

This function frees the memory resources used by the form and all of the components which have been added to the form (including those components which are on subforms). Once a form has been destroyed, none of the form's components can be used.

Seznam parametrů

form

Form component, which is going to be destroyed

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

newt_form_run()
newt_run_form()

Předcházející | Nahoru | Další
newt_form_add_hot_key | Domů | newt_form_get_current


newt_form_get_current

(PECL newt:0.1-1.1)

newt_form_get_current

Popis

resource newt_form_get_current ( resource $form )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

form

Návratové hodnoty

Předcházející | Nahoru | Další
newt_form_destroy | Domů | newt_form_run


newt_form_run

(PECL newt:0.1-1.1)

newt_form_run — Runs a form

Popis

void newt_form_run ( resource $form, array &$exit_struct )

This function runs the form passed to it.

Seznam parametrů

form

Form component

exit_struct

Array, used for returning information after running the form component. Keys and values are described in the following table:

Tabulka 212. Form Exit Structure

Index Key | Value Type | Description
reason | integer | The reason, why the form has been exited. Possible values are defined here.
watch | resource | Resource link, specified in newt_form_watch_fd()
key | integer | Hotkey
component | resource | Component, which caused the form to exit

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

newt_run_form()

Předcházející | Nahoru | Další
newt_form_get_current | Domů | newt_form_set_background


newt_form_set_background

(PECL newt:0.1-1.1)

newt_form_set_background

Popis

void newt_form_set_background ( resource $from, int $background )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

from

background

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
newt_form_run | Domů | newt_form_set_height


newt_form_set_height

(PECL newt:0.1-1.1)

newt_form_set_height

Popis

void newt_form_set_height ( resource $form, int $height )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

form

height

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
newt_form_set_background | Domů | newt_form_set_size


newt_form_set_size

(PECL newt:0.1-1.1)

newt_form_set_size

Popis

void newt_form_set_size ( resource $form )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

form

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
newt_form_set_height | Domů | newt_form_set_timer


newt_form_set_timer

(PECL newt:0.1-1.1)

newt_form_set_timer

Popis

void newt_form_set_timer ( resource $form, int $milliseconds )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

form

milliseconds

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
newt_form_set_size | Domů | newt_form_set_width


newt_form_set_width

(PECL newt:0.1-1.1)

newt_form_set_width

Popis

void newt_form_set_width ( resource $form, int $width )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

form

width

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
newt_form_set_timer | Domů | newt_form_watch_fd


newt_form_watch_fd

(PECL newt:0.1-1.1)

newt_form_watch_fd

Popis

void newt_form_watch_fd ( resource $form, resource $stream [, int $flags] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

form

stream

flags

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
newt_form_set_width | Domů | newt_form


newt_get_screen_size

(PECL newt:0.1-1.1)

newt_get_screen_size — Fills in the passed references with the current size of the terminal

Popis

void newt_get_screen_size ( int &$cols, int &$rows )

Fills in the passed references with the current size of the terminal.

Seznam parametrů

cols

Number of columns in the terminal

rows

Number of rows in the terminal

Návratové hodnoty

Nevrací se žádná hodnota.

Příklady

Příklad 1425. A newt_get_screen_size() example

This code prints out the screen size of your terminal.

<?php
 newt_init();
 newt_get_screen_size (&$cols, &$rows);
 newt_finished();

 print "Your terminal size is: {$cols}x{$rows}\n";
?>

Výše uvedený příklad vypíše:

Your terminal size is: 138x47

Předcházející | Nahoru | Další
newt_form | Domů | newt_grid_add_components_to_form


newt_grid_add_components_to_form

(PECL newt:0.1-1.1)

newt_grid_add_components_to_form

Popis

void newt_grid_add_components_to_form ( resource $grid, resource $form, bool $recurse )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

grid

form

recurse

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
newt_get_screen_size | Domů | newt_grid_basic_window


newt_grid_basic_window

(PECL newt:0.1-1.1)

newt_grid_basic_window

Popis

resource newt_grid_basic_window ( resource $text, resource $middle, resource $buttons )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

text

middle

buttons

Návratové hodnoty

Předcházející | Nahoru | Další
newt_grid_add_components_to_form | Domů | newt_grid_free


newt_grid_free

(PECL newt:0.1-1.1)

newt_grid_free

Popis

void newt_grid_free ( resource $grid, bool $recurse )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

grid

recurse

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
newt_grid_basic_window | Domů | newt_grid_get_size


newt_grid_get_size

(PECL newt:0.1-1.1)

newt_grid_get_size

Popis

void newt_grid_get_size ( resouce $grid, int &$width, int &$height )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

grid

width

height

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
newt_grid_free | Domů | newt_grid_h_close_stacked


newt_grid_h_close_stacked

(PECL newt:0.1-1.1)

newt_grid_h_close_stacked

Popis

resource newt_grid_h_close_stacked ( int $element1_type, resource $element1 [, int $... [, resource $...]] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

element1_type

element1

Návratové hodnoty

Předcházející | Nahoru | Další
newt_grid_get_size | Domů | newt_grid_h_stacked


newt_grid_h_stacked

(PECL newt:0.1-1.1)

newt_grid_h_stacked

Popis

resource newt_grid_h_stacked ( int $element1_type, resource $element1 [, int $... [, resource $...]] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

element1_type

element1

Návratové hodnoty

Předcházející | Nahoru | Další
newt_grid_h_close_stacked | Domů | newt_grid_place


newt_grid_place

(PECL newt:0.1-1.1)

newt_grid_place

Popis

void newt_grid_place ( resource $grid, int $left, int $top )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

grid

left

top

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
newt_grid_h_stacked | Domů | newt_grid_set_field


newt_grid_set_field

(PECL newt:0.1-1.1)

newt_grid_set_field

Popis

void newt_grid_set_field ( resource $grid, int $col, int $row, int $type, resource $val, int $pad_left, int $pad_top, int $pad_right, int $pad_bottom, int $anchor [, int $flags] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

grid

col

row

type

val

pad_left

pad_top

pad_right

pad_bottom

anchor

flags

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
newt_grid_place | Domů | newt_grid_simple_window


newt_grid_simple_window

(PECL newt:0.1-1.1)

newt_grid_simple_window

Popis

resource newt_grid_simple_window ( resource $text, resource $middle, resource $buttons )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

text

middle

buttons

Návratové hodnoty

Předcházející | Nahoru | Další
newt_grid_set_field | Domů | newt_grid_v_close_stacked


newt_grid_v_close_stacked

(PECL newt:0.1-1.1)

newt_grid_v_close_stacked

Popis

resource newt_grid_v_close_stacked ( int $element1_type, resource $element1 [, int $... [, resource $...]] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

element1_type

element1

Návratové hodnoty

Předcházející | Nahoru | Další
newt_grid_simple_window | Domů | newt_grid_v_stacked


newt_grid_v_stacked

(PECL newt:0.1-1.1)

newt_grid_v_stacked

Popis

resource newt_grid_v_stacked ( int $element1_type, resource $element1 [, int $... [, resource $...]] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

element1_type

element1

Návratové hodnoty

Předcházející | Nahoru | Další
newt_grid_v_close_stacked | Domů | newt_grid_wrapped_window_at


newt_grid_wrapped_window

(PECL newt:0.1-1.1)

newt_grid_wrapped_window

Popis

void newt_grid_wrapped_window ( resource $grid, string $title )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

grid

title

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
newt_grid_wrapped_window_at | Domů | newt_init


newt_grid_wrapped_window_at

(PECL newt:0.1-1.1)

newt_grid_wrapped_window_at

Popis

void newt_grid_wrapped_window_at ( resource $grid, string $title, int $left, int $top )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

grid

title

left

top

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
newt_grid_v_stacked | Domů | newt_grid_wrapped_window


newt_init

(PECL newt:0.1-1.1)

newt_init — Initialize newt

Popis

int newt_init ( void )

Initializes the newt interface. This function must be called before any other newt function.

Návratové hodnoty

Returns 1 on success, 0 on failure.

Viz také

newt_finished()

Předcházející | Nahoru | Další
newt_grid_wrapped_window | Domů | newt_label_set_text


newt_label

(PECL newt:0.1-1.1)

newt_label

Popis

resource newt_label ( int $left, int $top, string $text )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

left

top

text

Návratové hodnoty

Předcházející | Nahoru | Další
newt_label_set_text | Domů | newt_listbox_append_entry


newt_label_set_text

(PECL newt:0.1-1.1)

newt_label_set_text

Popis

void newt_label_set_text ( resource $label, string $text )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

label

text

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
newt_init | Domů | newt_label


newt_listbox

(PECL newt:0.1-1.1)

newt_listbox

Popis

resource newt_listbox ( int $left, int $top, int $height [, int $flags] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

left

top

height

flags

Návratové hodnoty

Předcházející | Nahoru | Další
newt_listbox_set_width | Domů | newt_listitem_get_data


newt_listbox_append_entry

(PECL newt:0.1-1.1)

newt_listbox_append_entry

Popis

void newt_listbox_append_entry ( resource $listbox, string $text, mixed $data )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

listbox

text

data

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
newt_label | Domů | newt_listbox_clear_selection


newt_listbox_clear

(PECL newt:0.1-1.1)

newt_listbox_clear

Popis

void newt_listbox_clear ( resource $listobx )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

listobx

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
newt_listbox_clear_selection | Domů | newt_listbox_delete_entry


newt_listbox_clear_selection

(PECL newt:0.1-1.1)

newt_listbox_clear_selection

Popis

void newt_listbox_clear_selection ( resource $listbox )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

listbox

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
newt_listbox_append_entry | Domů | newt_listbox_clear


newt_listbox_delete_entry

(PECL newt:0.1-1.1)

newt_listbox_delete_entry

Popis

void newt_listbox_delete_entry ( resource $listbox, mixed $key )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

listbox

key

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
newt_listbox_clear | Domů | newt_listbox_get_current


newt_listbox_get_current

(PECL newt:0.1-1.1)

newt_listbox_get_current

Popis

string newt_listbox_get_current ( resource $listbox )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

listbox

Návratové hodnoty

Předcházející | Nahoru | Další
newt_listbox_delete_entry | Domů | newt_listbox_get_selection


newt_listbox_get_selection

(PECL newt:0.1-1.1)

newt_listbox_get_selection

Popis

array newt_listbox_get_selection ( resource $listbox )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

listbox

Návratové hodnoty

Předcházející | Nahoru | Další
newt_listbox_get_current | Domů | newt_listbox_insert_entry


newt_listbox_insert_entry

(PECL newt:0.1-1.1)

newt_listbox_insert_entry

Popis

void newt_listbox_insert_entry ( resource $listbox, string $text, mixed $data, mixed $key )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

listbox

text

data

key

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
newt_listbox_get_selection | Domů | newt_listbox_item_count


newt_listbox_item_count

(PECL newt:0.1-1.1)

newt_listbox_item_count

Popis

int newt_listbox_item_count ( resource $listbox )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

listbox

Návratové hodnoty

Předcházející | Nahoru | Další
newt_listbox_insert_entry | Domů | newt_listbox_select_item


newt_listbox_select_item

(PECL newt:0.1-1.1)

newt_listbox_select_item

Popis

void newt_listbox_select_item ( resource $listbox, mixed $key, int $sense )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

listbox

key

sense

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
newt_listbox_item_count | Domů | newt_listbox_set_current_by_key


newt_listbox_set_current

(PECL newt:0.1-1.1)

newt_listbox_set_current

Popis

void newt_listbox_set_current ( resource $listbox, int $num )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

listbox

num

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
newt_listbox_set_current_by_key | Domů | newt_listbox_set_data


newt_listbox_set_current_by_key

(PECL newt:0.1-1.1)

newt_listbox_set_current_by_key

Popis

void newt_listbox_set_current_by_key ( resource $listbox, mixed $key )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

listbox

key

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
newt_listbox_select_item | Domů | newt_listbox_set_current


newt_listbox_set_data

(PECL newt:0.1-1.1)

newt_listbox_set_data

Popis

void newt_listbox_set_data ( resource $listbox, int $num, mixed $data )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

listbox

num

data

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
newt_listbox_set_current | Domů | newt_listbox_set_entry


newt_listbox_set_entry

(PECL newt:0.1-1.1)

newt_listbox_set_entry

Popis

void newt_listbox_set_entry ( resource $listbox, int $num, string $text )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

listbox

num

text

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
newt_listbox_set_data | Domů | newt_listbox_set_width


newt_listbox_set_width

(PECL newt:0.1-1.1)

newt_listbox_set_width

Popis

void newt_listbox_set_width ( resource $listbox, int $width )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

listbox

width

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
newt_listbox_set_entry | Domů | newt_listbox


newt_listitem

(PECL newt:0.1-1.1)

newt_listitem

Popis

resource newt_listitem ( int $left, int $top, string $text, bool $is_default, resouce $prev_item, mixed $data [, int $flags] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

left

top

text

is_default

prev_item

data

flags

Návratové hodnoty

Předcházející | Nahoru | Další
newt_listitem_set | Domů | newt_open_window


newt_listitem_get_data

(PECL newt:0.1-1.1)

newt_listitem_get_data

Popis

mixed newt_listitem_get_data ( resource $item )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

item

Návratové hodnoty

Předcházející | Nahoru | Další
newt_listbox | Domů | newt_listitem_set


newt_listitem_set

(PECL newt:0.1-1.1)

newt_listitem_set

Popis

void newt_listitem_set ( resource $item, string $text )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

item

text

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
newt_listitem_get_data | Domů | newt_listitem


newt_open_window

(PECL newt:0.1-1.1)

newt_open_window — Open a window of the specified size and position

Popis

int newt_open_window ( int $left, int $top, int $width, int $height [, string $title] )

Open a window of the specified size and position.

Seznam parametrů

left

Location of the upper left-hand corner of the window (column number)

top

Location of the upper left-hand corner of the window (row number)

width

Window width

height

Window height

title

Window title

Návratové hodnoty

Returns 1 on success, 0 on failure.

Viz také

newt_pop_window()
newt_centered_window()

Předcházející | Nahoru | Další
newt_listitem | Domů | newt_pop_help_line


newt_pop_help_line

(PECL newt:0.1-1.1)

newt_pop_help_line — Replaces the current help line with the one from the stack

Popis

void newt_pop_help_line ( void )

Replaces the current help line with the one from the stack.

Poznámka: It's important not to call to newt_pop_help_line() more than newt_push_help_line().

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

newt_push_help_line()

Předcházející | Nahoru | Další
newt_open_window | Domů | newt_pop_window


newt_pop_window

(PECL newt:0.1-1.1)

newt_pop_window — Removes the top window from the display

Popis

void newt_pop_window ( void )

Removes the top window from the display, and redraws the display areas which the window overwrote.

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

newt_open_window()
newt_centered_window()

Předcházející | Nahoru | Další
newt_pop_help_line | Domů | newt_push_help_line


newt_push_help_line

(PECL newt:0.1-1.1)

newt_push_help_line — Saves the current help line on a stack, and displays the new line

Popis

void newt_push_help_line ( [string $text] )

Saves the current help line on a stack, and displays the new line.

Seznam parametrů

text

New help text message

Poznámka: If not specified, the help line is cleared.

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

newt_pop_help_line()

Předcházející | Nahoru | Další
newt_pop_window | Domů | newt_radio_get_current


newt_radio_get_current

(PECL newt:0.1-1.1)

newt_radio_get_current

Popis

resource newt_radio_get_current ( resource $set_member )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

set_member

Návratové hodnoty

Předcházející | Nahoru | Další
newt_push_help_line | Domů | newt_radiobutton


newt_radiobutton

(PECL newt:0.1-1.1)

newt_radiobutton

Popis

resource newt_radiobutton ( int $left, int $top, string $text, bool $is_default [, resource $prev_button] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

left

top

text

is_default

prev_button

Návratové hodnoty

Předcházející | Nahoru | Další
newt_radio_get_current | Domů | newt_redraw_help_line


newt_redraw_help_line

(PECL newt:0.1-1.1)

newt_redraw_help_line

Popis

void newt_redraw_help_line ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
newt_radiobutton | Domů | newt_reflow_text


newt_reflow_text

(PECL newt:0.1-1.1)

newt_reflow_text

Popis

string newt_reflow_text ( string $text, int $width, int $flex_down, int $flex_up, int &$actual_width, int &$actual_height )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

text

width

flex_down

flex_up

actual_width

actual_height

Návratové hodnoty

Předcházející | Nahoru | Další
newt_redraw_help_line | Domů | newt_refresh


newt_refresh

(PECL newt:0.1-1.1)

newt_refresh — Updates modified portions of the screen

Popis

void newt_refresh ( void )

To increase performance, newt only updates the display when it needs to, not when the program tells it to write to the terminal. Applications can force newt to immediately update modified portions of the screen by calling this function.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
newt_reflow_text | Domů | newt_resize_screen


newt_resize_screen

(PECL newt:0.1-1.1)

newt_resize_screen

Popis

void newt_resize_screen ( [bool $redraw] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

redraw

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
newt_refresh | Domů | newt_resume


newt_resume

(PECL newt:0.1-1.1)

newt_resume — Resume using the newt interface after calling newt_suspend()

Popis

void newt_resume ( void )

Resume using the newt interface after calling newt_suspend().

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

newt_suspend()

Předcházející | Nahoru | Další
newt_resize_screen | Domů | newt_run_form


newt_run_form

(PECL newt:0.1-1.1)

newt_run_form — Runs a form

Popis

resource newt_run_form ( resource $form )

This function runs the form passed to it.

Seznam parametrů

form

Form component

Návratové hodnoty

The component which caused the form to stop running.

Poznámka: Notice that this function doesn't fit in with newt's normal naming convention. It is an older interface which will not work for all forms. It was left in newt only for legacy applications. It is a simpler interface than the new newt_form_run() though, and is still used quite often as a result. When an application is done with a form, it destroys the form and all of the components the form contains.

Viz také

newt_form_run()
newt_form_destroy()

Předcházející | Nahoru | Další
newt_resume | Domů | newt_scale_set


newt_scale

(PECL newt:0.1-1.1)

newt_scale

Popis

resource newt_scale ( int $left, int $top, int $width, int $full_value )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

left

top

width

full_value

Návratové hodnoty

Předcházející | Nahoru | Další
newt_scale_set | Domů | newt_scrollbar_set


newt_scale_set

(PECL newt:0.1-1.1)

newt_scale_set

Popis

void newt_scale_set ( resource $scale, int $amount )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

scale

amount

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
newt_run_form | Domů | newt_scale


newt_scrollbar_set

(PECL newt:0.1-1.1)

newt_scrollbar_set

Popis

void newt_scrollbar_set ( resource $scrollbar, int $where, int $total )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

scrollbar

where

total

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
newt_scale | Domů | newt_set_help_callback


newt_set_help_callback

(PECL newt:0.1-1.1)

newt_set_help_callback

Popis

void newt_set_help_callback ( mixed $function )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

function

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
newt_scrollbar_set | Domů | newt_set_suspend_callback


newt_set_suspend_callback

(PECL newt:0.1-1.1)

newt_set_suspend_callback — Set a callback function which gets invoked when user presses the suspend key

Popis

void newt_set_suspend_callback ( callback $function, mixed $data )

Set a callback function which gets invoked when user presses the suspend key (normally ^Z). If no suspend callback is registered, the suspend keystroke is ignored.

Seznam parametrů

function

A callback function, which accepts one argument: data

data

This data is been passed to the callback function

Viz také

newt_suspend()
newt_resume()

Předcházející | Nahoru | Další
newt_set_help_callback | Domů | newt_suspend


newt_suspend

(PECL newt:0.1-1.1)

newt_suspend — Tells newt to return the terminal to its initial state

Popis

void newt_suspend ( void )

Tells newt to return the terminal to its initial state. Once this is done, the application can suspend itself (by sending itself a SIGTSTP, fork a child program, or do whatever else it likes).

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

newt_resume()

Předcházející | Nahoru | Další
newt_set_suspend_callback | Domů | newt_textbox_get_num_lines


newt_textbox

(PECL newt:0.1-1.1)

newt_textbox

Popis

resource newt_textbox ( int $left, int $top, int $width, int $height [, int $flags] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

left

top

width

height

flags

Návratové hodnoty

Předcházející | Nahoru | Další
newt_textbox_set_text | Domů | newt_vertical_scrollbar


newt_textbox_get_num_lines

(PECL newt:0.1-1.1)

newt_textbox_get_num_lines

Popis

int newt_textbox_get_num_lines ( resource $textbox )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

textbox

Návratové hodnoty

Předcházející | Nahoru | Další
newt_suspend | Domů | newt_textbox_reflowed


newt_textbox_reflowed

(PECL newt:0.1-1.1)

newt_textbox_reflowed

Popis

resource newt_textbox_reflowed ( int $left, int $top, char $*text, int $width, int $flex_down, int $flex_up [, int $flags] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

left

top

*text

width

flex_down

flex_up

flags

Návratové hodnoty

Předcházející | Nahoru | Další
newt_textbox_get_num_lines | Domů | newt_textbox_set_height


newt_textbox_set_height

(PECL newt:0.1-1.1)

newt_textbox_set_height

Popis

void newt_textbox_set_height ( resource $textbox, int $height )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

textbox

height

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
newt_textbox_reflowed | Domů | newt_textbox_set_text


newt_textbox_set_text

(PECL newt:0.1-1.1)

newt_textbox_set_text

Popis

void newt_textbox_set_text ( resource $textbox, string $text )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

textbox

text

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
newt_textbox_set_height | Domů | newt_textbox


newt_vertical_scrollbar

(PECL newt:0.1-1.1)

newt_vertical_scrollbar

Popis

resource newt_vertical_scrollbar ( int $left, int $top, int $height [, int $normal_colorset [, int $thumb_colorset]] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

left

top

height

normal_colorset

thumb_colorset

Návratové hodnoty

Předcházející | Nahoru | Další
newt_textbox | Domů | newt_wait_for_key


newt_wait_for_key

(PECL newt:0.1-1.1)

newt_wait_for_key — Doesn't return until a key has been pressed

Popis

void newt_wait_for_key ( void )

This function doesn't return until a key has been pressed. The keystroke is then ignored. If a key is already in the terminal's buffer, this function discards a keystroke and returns immediately.

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

newt_clear_key_buffer()

Předcházející | Nahoru | Další
newt_vertical_scrollbar | Domů | newt_win_choice


newt_win_choice

(PECL newt:0.1-1.1)

newt_win_choice

Popis

int newt_win_choice ( string $title, string $button1_text, string $button2_text, string $format [, mixed $args [, mixed $...]] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

title

button1_text

button2_text

format

args

Návratové hodnoty

Předcházející | Nahoru | Další
newt_wait_for_key | Domů | newt_win_entries


newt_win_entries

(PECL newt:0.1-1.1)

newt_win_entries

Popis

int newt_win_entries ( string $title, string $text, int $suggested_width, int $flex_down, int $flex_up, int $data_width, array &$items, string $button1 [, string $...] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

title

text

suggested_width

flex_down

flex_up

data_width

items

button1

button2

Návratové hodnoty

Příklady

Příklad 1426. A newt_win_entries() example

<?php

newt_init();
newt_cls();

$entries[] = array('text' => 'First name:', 'value' => &$f_name);
$entries[] = array('text' => 'Last name:',  'value' => &$l_name);

$rc = newt_win_entries("User information", "Please enter your credentials:", 50, 7, 7, 30, $entries, "Ok", "Back");
newt_finished ();

if ($rc != 2) {
    echo "Your name is: $f_name $l_name\n";
}
?>

Předcházející | Nahoru | Další
newt_win_choice | Domů | newt_win_menu


newt_win_menu

(PECL newt:0.1-1.1)

newt_win_menu

Popis

int newt_win_menu ( string $title, string $text, int $suggestedWidth, int $flexDown, int $flexUp, int $maxListHeight, array $items, int &$listItem [, string $button1 [, string $...]] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

title

text

suggestedWidth

flexDown

flexUp

maxListHeight

items

listItem

button1

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
newt_win_entries | Domů | newt_win_message


newt_win_message

(PECL newt:0.1-1.1)

newt_win_message

Popis

void newt_win_message ( string $title, string $button_text, string $format [, mixed $args [, mixed $...]] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

title

button_text

format

args

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
newt_win_menu | Domů | newt_win_messagev


newt_win_messagev

(PECL newt:0.1-1.1)

newt_win_messagev

Popis

void newt_win_messagev ( string $title, string $button_text, string $format, array $args )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

title

button_text

format

args

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
newt_win_message | Domů | newt_win_ternary


newt_win_ternary

(PECL newt:0.1-1.1)

newt_win_ternary

Popis

int newt_win_ternary ( string $title, string $button1_text, string $button2_text, string $button3_text, string $format [, mixed $args [, mixed $...]] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

title

Its description

button1_text

Its description

button2_text

Its description

button3_text

Its description

format

Its description

args

Its description

Návratové hodnoty

What the function returns, first on success, then on failure. See also the &return.success; entity

Předcházející | Nahoru | Další
newt_win_messagev | Domů | CIV. NSAPI-specific Functions


ob_deflatehandler

(PECL pecl_http:0.21.0-1.5.5)

ob_deflatehandler — Deflate output handler

Popis

string ob_deflatehandler ( string $data, int $mode )

For use with ob_start().

Poznámka: This output handler can only be used once.

The deflate output buffer handler can only be used once.

It conflicts with ob_gzhandler() and zlib.output_compression as well and should not be used after mbstring extension's mb_output_handler() and session extension's URL-Rewriter (AKA session.use_trans_sid).

Viz také

ob_inflatehandler()
ob_start()

Předcházející | Nahoru | Další
http_negotiate_language | Domů | ob_etaghandler


ob_etaghandler

(PECL pecl_http:0.10.0-1.5.5)

ob_etaghandler — ETag output handler

Popis

string ob_etaghandler ( string $data, int $mode )

For use with ob_start().

Output buffer handler generating an ETag with the hash algorithm specified with the INI setting http.etag.mode.

This output handler is used by http_cache_etag().

Viz také

http_cache_etag()
http_match_etag()

Předcházející | Nahoru | Další
ob_deflatehandler | Domů | ob_inflatehandler


ob_inflatehandler

(PECL pecl_http:0.21.0-1.5.5)

ob_inflatehandler — Inflate output handler

Popis

string ob_inflatehandler ( string $data, int $mode )

For use with ob_start().

Same restrictions as with ob_deflatehandler() apply.

Viz také

ob_deflatehandler()
ob_start()

Předcházející | Nahoru | Další
ob_etaghandler | Domů | http_parse_cookie


oci_bind_array_by_name

(PHP 5 >= 5.1.2, PECL oci8:1.2.0-1.2.4)

oci_bind_array_by_name — Binds PHP array to Oracle PL/SQL array by name

Popis

bool oci_bind_array_by_name ( resource $statement, string $name, array &$var_array, int $max_table_length [, int $max_item_length [, int $type]] )

Binds the PHP array var_array to the Oracle placeholder name, which points to Oracle PL/SQL array. Whether it will be used for input or output will be determined at run-time.

Seznam parametrů

statement

A valid OCI statement identifier.

name

The Oracle placeholder.

var_array

An array.

max_table_length

Sets the maximum length both for incoming and result arrays.

max_item_length

Sets maximum length for array items. If not specified or equals to -1, oci_bind_array_by_name() will use find the longest element in the incoming array and will use it as maximum length for array items.

type

Should be used to set the type of PL/SQL array items. See list of available types below:

  • SQLT_NUM - for arrays of NUMBER.

  • SQLT_INT - for arrays of INTEGER (Note: INTEGER it is actually a synonym for NUMBER(38), but SQLT_NUM type won't work in this case even though they are synonyms).

  • SQLT_FLT - for arrays of FLOAT.

  • SQLT_AFC - for arrays of CHAR.

  • SQLT_CHR - for arrays of VARCHAR2.

  • SQLT_VCS - for arrays of VARCHAR.

  • SQLT_AVC - for arrays of CHARZ.

  • SQLT_STR - for arrays of STRING.

  • SQLT_LVC - for arrays of LONG VARCHAR.

  • SQLT_ODT - for arrays of DATE.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1438. oci_bind_array_by_name() example

<?php

$c = oci_connect("scott", "tiger");

$create = "CREATE TABLE bind_example(name VARCHAR(20))";
$statement = oci_parse($c, $create);
oci_execute($statement);

$create_pkg = "
CREATE OR REPLACE PACKAGE ARRAYBINDPKG1 AS
  TYPE ARRTYPE IS TABLE OF VARCHAR(20) INDEX BY BINARY_INTEGER;
  PROCEDURE iobind(c1 IN OUT ARRTYPE);
END ARRAYBINDPKG1;";
$statement = oci_parse($c, $create_pkg);
oci_execute($statement);

$create_pkg_body = "
CREATE OR REPLACE PACKAGE BODY ARRAYBINDPKG1 AS
  CURSOR CUR IS SELECT name FROM bind_example;
  PROCEDURE iobind(c1 IN OUT ARRTYPE) IS
    BEGIN
    FOR i IN 1..5 LOOP
      INSERT INTO bind_example VALUES (c1(i));
    END LOOP;
    IF NOT CUR%ISOPEN THEN
      OPEN CUR;
    END IF;
    FOR i IN REVERSE 1..5 LOOP
      FETCH CUR INTO c1(i);
      IF CUR%NOTFOUND THEN
        CLOSE CUR;
        EXIT;
      END IF;
    END LOOP;
  END iobind;
END ARRAYBINDPKG1;";
$statement = oci_parse($c, $create_pkg_body);
oci_execute($statement);

$statement = oci_parse($c, "BEGIN ARRAYBINDPKG1.iobind(:c1); END;");

$array = array("one", "two", "three", "four", "five");

oci_bind_array_by_name($statement, ":c1", $array, 5, -1, SQLT_CHR);

oci_execute($statement);

var_dump($array);

?>

Poznámky

Poznámka: This function is available since OCI8 release 1.2.

Předcházející | Nahoru | Další
CVII. Oracle Functions | Domů | oci_bind_by_name


OCI-Collection->assignElem

(No version information available, might be only in CVS)

OCI-Collection->assignElem — Assigns a value to the element of the collection

Popis

class OCI-Collection {
bool assignElem ( int $index, mixed $value )
}

Assigns a value to the element with index index.

Seznam parametrů

index

The element index. First index is 1.

value

Can be a string or a number.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

OCI-Collection->getElem

Předcházející | Nahoru | Další
OCI-Collection->assign | Domů | OCI-Collection->free


OCI-Collection->getElem

(No version information available, might be only in CVS)

OCI-Collection->getElem — Returns value of the element

Popis

class OCI-Collection {
mixed getElem ( int $index )
}

Returns element's value with the index index (1-based).

Seznam parametrů

index

The element index. First index is 1.

Návratové hodnoty

Returns FALSE if such element doesn't exist; NULL if element is NULL; string if element is column of a string datatype or number if element is numeric field.

Viz také

OCI-Collection->assignElem

Předcházející | Nahoru | Další
OCI-Collection->free | Domů | OCI-Collection->max


OCI-Lob->free

(No version information available, might be only in CVS)

OCI-Lob->free — Frees resources associated with the LOB descriptor

Popis

class OCI-Lob {
bool free ( void )
}

Frees resources associated with the descriptor, previously allocated with oci_new_descriptor().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
OCI-Lob->flush | Domů | OCI-Lob->getBuffering


OCI-Lob->getBuffering

(No version information available, might be only in CVS)

OCI-Lob->getBuffering — Returns current state of buffering for the large object

Popis

class OCI-Lob {
bool getBuffering ( void )
}

Tells whether the buffering for the large object is on or off.

Návratové hodnoty

Returns FALSE if buffering for the large object is off and TRUE if buffering is used.

Viz také

OCI-Lob->setBuffering

Předcházející | Nahoru | Další
OCI-Lob->free | Domů | OCI-Lob->import


OCI-Lob->saveFile

(No version information available, might be only in CVS)

OCI-Lob->saveFile — Alias pro oci_lob_import()

Popis

Tato funkce je aliasem: oci_lob_import().

Předcházející | Nahoru | Další
OCI-Lob->save | Domů | OCI-Lob->seek


OCI-Lob->setBuffering

(No version information available, might be only in CVS)

OCI-Lob->setBuffering — Changes current state of buffering for the large object

Popis

class OCI-Lob {
bool setBuffering ( bool $on_off )
}

Sets the buffering for the large object, depending on the value of the on_off parameter.

Use of this function may provide performance improvements by buffering small reads and writes of LOBs by reducing the number of network round-trips and LOB versions. oci_lob_flush() should be used to flush buffers, when you have finished working with the large object.

Seznam parametrů

on_off

TRUE for on and FALSE for off.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání. Repeated calls to this method with the same flag will return TRUE.

Viz také

OCI-Lob->getBuffering

Předcházející | Nahoru | Další
OCI-Lob->seek | Domů | OCI-Lob->size


OCI-Lob->writeTemporary

(No version information available, might be only in CVS)

OCI-Lob->writeTemporary — Writes temporary large object

Popis

class OCI-Lob {
bool writeTemporary ( string $data [, int $lob_type] )
}

Creates a temporary large object and writes data to it.

You should use OCI-Lob->close when you are done with this object.

Seznam parametrů

data

The data to write.

lob_type

Can be one of the following:

OCI_TEMP_BLOB is used to create temporary BLOBs
OCI_TEMP_CLOB (default value) is used to create temporary CLOBs

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

OCI-Lob->close

Předcházející | Nahoru | Další
OCI-Lob->write | Domů | OCI-Lob->writeToFile


OCI-Lob->writeToFile

(No version information available, might be only in CVS)

OCI-Lob->writeToFile — Alias pro oci_lob_export()

Popis

Tato funkce je aliasem: oci_lob_export().

Předcházející | Nahoru | Další
OCI-Lob->writeTemporary | Domů | oci_new_collection


openssl_csr_get_public_key

(PHP 5 >= 5.2.0)

openssl_csr_get_public_key — Returns the public key of a CERT

Popis

resource openssl_csr_get_public_key ( mixed $csr [, bool $use_shortnames] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
openssl_csr_export | Domů | openssl_csr_get_subject


openssl_csr_get_subject

(PHP 5 >= 5.2.0)

openssl_csr_get_subject — Returns the subject of a CERT

Popis

array openssl_csr_get_subject ( mixed $csr [, bool $use_shortnames] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
openssl_csr_get_public_key | Domů | openssl_csr_new


openssl_pkcs12_export

(PHP 5 >= 5.2.2)

openssl_pkcs12_export — Exports a PKCS#12 Compatible Certificate Store File to variable.

Popis

bool openssl_pkcs12_export ( mixed $x509, string &$out, mixed $priv_key, string $pass [, array $args] )

openssl_pkcs12_export() stores x509 into a string named by out in a PKCS#12 file format.

Seznam parametrů

x509

out

On success, this will hold the PKCS#12.

priv_key

Private key component of PKCS#12 file.

pass

Encryption password for unlocking the PKCS#12 file.

args

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
openssl_pkcs12_export_to_file | Domů | openssl_pkcs12_read


openssl_pkcs12_export_to_file

(PHP 5 >= 5.2.2)

openssl_pkcs12_export_to_file — Exports a PKCS#12 Compatible Certificate Store File

Popis

bool openssl_pkcs12_export_to_file ( mixed $x509, string $filename, mixed $priv_key, string $pass [, array $args] )

openssl_pkcs12_export_to_file() stores x509 into a file named by filename in a PKCS#12 file format.

Seznam parametrů

x509

filename

Path to the output file.

priv_key

Private key component of PKCS#12 file.

pass

Encryption password for unlocking the PKCS#12 file.

args

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
openssl_open | Domů | openssl_pkcs12_export


openssl_pkcs12_read

(PHP 5 >= 5.2.2)

openssl_pkcs12_read — Parse a PKCS#12 Certificate Store into an array

Popis

bool openssl_pkcs12_read ( mixed $PKCS12, array &$certs, string $pass )

openssl_pkcs12_read() parses the PKCS#12 certificate store supplied by PKCS12 into a array named certs.

Seznam parametrů

PKCS12

certs

On success, this will hold the Certificate Store Data.

pass

Encryption password for unlocking the PKCS#12 file.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
openssl_pkcs12_export | Domů | openssl_pkcs7_decrypt


openssl_pkey_free

(PHP 4 >= 4.2.0, PHP 5)

openssl_pkey_free — Frees a private key

Popis

void openssl_pkey_free ( resource $key )

This function frees a private key created by openssl_pkey_new().

Seznam parametrů

key

Resource holding the key.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
openssl_pkey_export | Domů | openssl_pkey_get_details


openssl_pkey_get_details

(PHP 5 >= 5.2.0)

openssl_pkey_get_details — Returns an array with the key details

Popis

array openssl_pkey_get_details ( resource $key )

This function returns the key details (bits, key, type).

Seznam parametrů

key

Resource holding the key.

Návratové hodnoty

Returns an array with the key details in success or FALSE in failure. Returned array has indexes bits (number of bits), key (string representation of the public key) and type (type of the key which is one of OPENSSL_KEYTYPE_RSA, OPENSSL_KEYTYPE_DSA, OPENSSL_KEYTYPE_DH, OPENSSL_KEYTYPE_EC or -1 meaning unknown).

Předcházející | Nahoru | Další
openssl_pkey_free | Domů | openssl_pkey_get_private


OrbitEnum

(No version information available, might be only in CVS)

OrbitEnum — Use CORBA enums

Popis

new OrbitEnum ( string $id )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

This class represents the enumeration identified with the id parameter.

Seznam parametrů

id

Can be either the name of the enumeration (e.g "MyEnum"), or the full repository id (e.g. "IDL:MyEnum:1.0").

Příklady

Příklad 1928. Sample IDL file

enum MyEnum {
    a,b,c,d,e
};

Příklad 1929. PHP code for accessing MyEnum

<?php
$enum = new OrbitEnum ("MyEnum");

echo $enum->a;    /* write 0 */
echo $enum->c;    /* write 2 */
echo $enum->e;    /* write 4 */
?>

Předcházející | Nahoru | Další
CXLI. Satellite CORBA klient extenze | Domů | OrbitObject


OrbitObject

(No version information available, might be only in CVS)

OrbitObject — Access CORBA objects

Popis

new OrbitObject ( string $ior )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

This class provides access to a CORBA object.

Seznam parametrů

ior

Should be a string containing the IOR (Interoperable Object Reference) that identifies the remote object.

Příklady

Příklad 1930. Sample IDL file

interface MyInterface {
    void SetInfo (string info);
    string GetInfo();

    attribute int value;
}

Příklad 1931. PHP code for accessing MyInterface

<?php
$obj = new OrbitObject ($ior);

$obj->SetInfo ("A 2GooD object");

echo $obj->GetInfo();

$obj->value = 42;

echo $obj->value;
?>

Předcházející | Nahoru | Další
OrbitEnum | Domů | OrbitStruct


OrbitStruct

(No version information available, might be only in CVS)

OrbitStruct — Use CORBA structs

Popis

new OrbitStruct ( string $id )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

This class represents the structure identified with the id parameter.

Seznam parametrů

id

Can be either the name of the struct (e.g "MyStruct"), or the full repository id (e.g. "IDL:MyStruct:1.0").

Příklady

Příklad 1932. Sample IDL file

struct MyStruct {
    short shortvalue;
    string stringvalue;
};

interface SomeInterface {
  void SetValues (MyStruct values);
  MyStruct GetValues();
}

Příklad 1933. PHP code for accessing MyStruct

<?php
$obj = new OrbitObject ($ior);

$initial_values = new OrbitStruct ("IDL:MyStruct:1.0");
$initial_values->shortvalue = 42;
$initial_values->stringvalue = "HGTTG";

$obj->SetValues ($initial_values);

$values = $obj->GetValues();

echo $values->shortvalue;
echo $values->stringvalue;
?>

Předcházející | Nahoru | Další
OrbitObject | Domů | satellite_caught_exception


PDF_activate_item

(PECL pdflib:2.0-2.1.3)

PDF_activate_item — Activate structure element or other content item

Popis

bool PDF_activate_item ( resource $pdfdoc, int $id )

Activates a previously created structure element or other content item. Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
CXXI. PDF funkce | Domů | PDF_add_annotation


PDF_add_nameddest

(PECL pdflib:2.0-2.1.3)

PDF_add_nameddest — Create named destination

Popis

bool PDF_add_nameddest ( resource $pdfdoc, string $name, string $optlist )

Creates a named destination on an arbitrary page in the current document. Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
PDF_add_locallink | Domů | PDF_add_note


PDF_add_table_cell

(PECL pdflib:2.1.0-2.1.3)

PDF_add_table_cell — Add a cell to a new or existing table

Popis

int PDF_add_table_cell ( resource $pdfdoc, int $table, int $column, int $row, string $text, string $optlist )

Adds a cell to a new or existing table.

Předcházející | Nahoru | Další
PDF_add_pdflink | Domů | PDF_add_textflow


PDF_add_textflow

(PECL pdflib:2.1.0-2.1.3)

PDF_add_textflow — Create Textflow or add text to existing Textflow

Popis

int PDF_add_textflow ( resource $pdfdoc, int $textflow, string $text, string $optlist )

Creates a Textflow object, or adds text and explicit options to an existing Textflow.

Předcházející | Nahoru | Další
PDF_add_table_cell | Domů | PDF_add_thumbnail


PDF_begin_document

(PECL pdflib:2.0-2.1.3)

PDF_begin_document — Create new PDF file

Popis

int PDF_begin_document ( resource $pdfdoc, string $filename, string $optlist )

Creates a new PDF file subject to various options.

Předcházející | Nahoru | Další
PDF_attach_file | Domů | PDF_begin_font


PDF_begin_font

(PECL pdflib:2.0-2.1.3)

PDF_begin_font — Start a Type 3 font definition

Popis

bool PDF_begin_font ( resource $pdfdoc, string $filename, float $a, float $b, float $c, float $d, float $e, float $f, string $optlist )

Starts a Type 3 font definition.

Předcházející | Nahoru | Další
PDF_begin_document | Domů | PDF_begin_glyph


PDF_begin_glyph

(PECL pdflib:2.0-2.1.3)

PDF_begin_glyph — Start glyph definition for Type 3 font

Popis

bool PDF_begin_glyph ( resource $pdfdoc, string $glyphname, float $wx, float $llx, float $lly, float $urx, float $ury )

Starts a glyph definition for a Type 3 font.

Předcházející | Nahoru | Další
PDF_begin_font | Domů | PDF_begin_item


PDF_begin_item

(PECL pdflib:2.0-2.1.3)

PDF_begin_item — Open structure element or other content item

Popis

int PDF_begin_item ( resource $pdfdoc, string $tag, string $optlist )

Opens a structure element or other content item with attributes supplied as options.

Předcházející | Nahoru | Další
PDF_begin_glyph | Domů | PDF_begin_layer


PDF_begin_layer

(PECL pdflib:2.0-2.1.3)

PDF_begin_layer — Start layer

Popis

bool PDF_begin_layer ( resource $pdfdoc, int $layer )

Starts a layer for subsequent output on the page. Vrací TRUE při úspěchu, FALSE při selhání.

This function requires PDF 1.5.

Předcházející | Nahoru | Další
PDF_begin_item | Domů | PDF_begin_page_ext


PDF_begin_page_ext

(PECL pdflib:2.0-2.1.3)

PDF_begin_page_ext — Start new page

Popis

bool PDF_begin_page_ext ( resource $pdfdoc, float $width, float $height, string $optlist )

Adds a new page to the document, and specifies various options. The parameters width and height are the dimensions of the new page in points. Vrací TRUE při úspěchu, FALSE při selhání.

Tabulka 239. Common Page Sizes in Points

name | size
A0 | 2380?3368
A1 | 1684?2380
A2 | 1190?1684
A3 | 842?1190
A4 | 595?842
A5 | 421?595
A6 | 297?421
B5 | 501?709
letter (8.5"?11") | 612?792
legal (8.5"?14") | 612?1008
ledger (17"?11") | 1224?792
11"?17" | 792?1224

Předcházející | Nahoru | Další
PDF_begin_layer | Domů | pdf_begin_page


PDF_begin_template_ext

(PECL pdflib:2.1.0-2.1.3)

PDF_begin_template_ext — Start template definition

Popis

int PDF_begin_template_ext ( resource $pdfdoc, float $width, float $height, string $optlist )

Starts a new template definition.

Předcházející | Nahoru | Další
PDF_begin_pattern | Domů | PDF_begin_template


PDF_create_3dview

(PECL pdflib:2.1.0-2.1.3)

PDF_create_3dview — Create 3D view

Popis

int PDF_create_3dview ( resource $pdfdoc, string $username, string $optlist )

Creates a 3D view.

This function requires PDF 1.6.

Předcházející | Nahoru | Další
PDF_continue_text | Domů | PDF_create_action


PDF_create_action

(PECL pdflib:2.0-2.1.3)

PDF_create_action — Create action for objects or events

Popis

int PDF_create_action ( resource $pdfdoc, string $type, string $optlist )

Creates an action which can be applied to various objects and events.

Předcházející | Nahoru | Další
PDF_create_3dview | Domů | PDF_create_annotation


PDF_create_annotation

(PECL pdflib:2.0-2.1.3)

PDF_create_annotation — Create rectangular annotation

Popis

bool PDF_create_annotation ( resource $pdfdoc, float $llx, float $lly, float $urx, float $ury, string $type, string $optlist )

Creates a rectangular annotation on the current page.

Předcházející | Nahoru | Další
PDF_create_action | Domů | PDF_create_bookmark


PDF_create_bookmark

(PECL pdflib:2.0-2.1.3)

PDF_create_bookmark — Create bookmark

Popis

int PDF_create_bookmark ( resource $pdfdoc, string $text, string $optlist )

Creates a bookmark subject to various options.

Předcházející | Nahoru | Další
PDF_create_annotation | Domů | PDF_create_field


PDF_create_field

(PECL pdflib:2.0-2.1.3)

PDF_create_field — Create form field

Popis

bool PDF_create_field ( resource $pdfdoc, float $llx, float $lly, float $urx, float $ury, string $name, string $type, string $optlist )

Creates a form field on the current page subject to various options.

Předcházející | Nahoru | Další
PDF_create_bookmark | Domů | PDF_create_fieldgroup


PDF_create_fieldgroup

(PECL pdflib:2.0-2.1.3)

PDF_create_fieldgroup — Create form field group

Popis

bool PDF_create_fieldgroup ( resource $pdfdoc, string $name, string $optlist )

Creates a form field group subject to various options.

Předcházející | Nahoru | Další
PDF_create_field | Domů | PDF_create_gstate


PDF_create_gstate

(PECL pdflib:2.0-2.1.3)

PDF_create_gstate — Create graphics state object

Popis

int PDF_create_gstate ( resource $pdfdoc, string $optlist )

Creates a graphics state object subject to various options.

Předcházející | Nahoru | Další
PDF_create_fieldgroup | Domů | PDF_create_pvf


PDF_create_pvf

(PECL pdflib:2.0-2.1.3)

PDF_create_pvf — Create PDFlib virtual file

Popis

bool PDF_create_pvf ( resource $pdfdoc, string $filename, string $data, string $optlist )

Creates a named virtual read-only file from data provided in memory.

Předcházející | Nahoru | Další
PDF_create_gstate | Domů | PDF_create_textflow


PDF_create_textflow

(PECL pdflib:2.0-2.1.3)

PDF_create_textflow — Create textflow object

Popis

int PDF_create_textflow ( resource $pdfdoc, string $text, string $optlist )

Preprocesses text for later formatting and creates a textflow object.

Předcházející | Nahoru | Další
PDF_create_pvf | Domů | PDF_curveto


PDF_define_layer

(PECL pdflib:2.0-2.1.3)

PDF_define_layer — Create layer definition

Popis

int PDF_define_layer ( resource $pdfdoc, string $name, string $optlist )

Creates a new layer definition.

This function requires PDF 1.5.

Předcházející | Nahoru | Další
PDF_curveto | Domů | PDF_delete_pvf


PDF_delete_pvf

(PECL pdflib:2.0-2.1.3)

PDF_delete_pvf — Delete PDFlib virtual file

Popis

int PDF_delete_pvf ( resource $pdfdoc, string $filename )

Deletes a named virtual file and frees its data structures (but not the contents).

Předcházející | Nahoru | Další
PDF_define_layer | Domů | PDF_delete_table


PDF_delete_table

(PECL pdflib:2.1.0-2.1.3)

PDF_delete_table — Delete table object

Popis

bool PDF_delete_table ( resource $pdfdoc, int $table, string $optlist )

Deletes a table and all associated data structures.

Předcházející | Nahoru | Další
PDF_delete_pvf | Domů | PDF_delete_textflow


PDF_delete_textflow

(PECL pdflib:2.0-2.1.3)

PDF_delete_textflow — Delete textflow object

Popis

bool PDF_delete_textflow ( resource $pdfdoc, int $textflow )

Deletes a textflow and the associated data structures.

Předcházející | Nahoru | Další
PDF_delete_table | Domů | PDF_delete


PDF_encoding_set_char

(PECL pdflib:2.0-2.1.3)

PDF_encoding_set_char — Add glyph name and/or Unicode value

Popis

bool PDF_encoding_set_char ( resource $pdfdoc, string $encoding, int $slot, string $glyphname, int $uv )

Adds a glyph name and/or Unicode value to a custom encoding.

Předcházející | Nahoru | Další
PDF_delete | Domů | PDF_end_document


PDF_end_document

(PECL pdflib:2.0-2.1.3)

PDF_end_document — Close PDF file

Popis

bool PDF_end_document ( resource $pdfdoc, string $optlist )

Closes the generated PDF file and applies various options.

Předcházející | Nahoru | Další
PDF_encoding_set_char | Domů | PDF_end_font


PDF_end_font

(PECL pdflib:2.0-2.1.3)

PDF_end_font — Terminate Type 3 font definition

Popis

bool PDF_end_font ( resource $pdfdoc )

Terminates a Type 3 font definition.

Předcházející | Nahoru | Další
PDF_end_document | Domů | PDF_end_glyph


PDF_end_glyph

(PECL pdflib:2.0-2.1.3)

PDF_end_glyph — Terminate glyph definition for Type 3 font

Popis

bool PDF_end_glyph ( resource $pdfdoc )

Terminates a glyph definition for a Type 3 font.

Předcházející | Nahoru | Další
PDF_end_font | Domů | PDF_end_item


PDF_end_item

(PECL pdflib:2.0-2.1.3)

PDF_end_item — Close structure element or other content item

Popis

bool PDF_end_item ( resource $pdfdoc, int $id )

Closes a structure element or other content item.

Předcházející | Nahoru | Další
PDF_end_glyph | Domů | PDF_end_layer


PDF_end_layer

(PECL pdflib:2.0-2.1.3)

PDF_end_layer — Deactivate all active layers

Popis

bool PDF_end_layer ( resource $pdfdoc )

Deactivates all active layers. Vrací TRUE při úspěchu, FALSE při selhání.

This function requires PDF 1.5.

Předcházející | Nahoru | Další
PDF_end_item | Domů | PDF_end_page_ext


PDF_end_page_ext

(PECL pdflib:2.0-2.1.3)

PDF_end_page_ext — Finish page

Popis

bool PDF_end_page_ext ( resource $pdfdoc, string $optlist )

Finishes a page, and applies various options. Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
PDF_end_layer | Domů | pdf_end_page


PDF_fill_imageblock

(PECL pdflib:2.0-2.1.3)

PDF_fill_imageblock — Fill image block with variable data

Popis

int PDF_fill_imageblock ( resource $pdfdoc, int $page, string $blockname, int $image, string $optlist )

Fills an image block with variable data according to its properties.

This function is only available in the PDFlib Personalization Server (PPS).

Předcházející | Nahoru | Další
PDF_endpath | Domů | PDF_fill_pdfblock


PDF_fill_pdfblock

(PECL pdflib:2.0-2.1.3)

PDF_fill_pdfblock — Fill PDF block with variable data

Popis

int PDF_fill_pdfblock ( resource $pdfdoc, int $page, string $blockname, int $contents, string $optlist )

Fills a PDF block with variable data according to its properties.

This function is only available in the PDFlib Personalization Server (PPS).

Předcházející | Nahoru | Další
PDF_fill_imageblock | Domů | PDF_fill_stroke


PDF_fill_textblock

(PECL pdflib:2.0-2.1.3)

PDF_fill_textblock — Fill text block with variable data

Popis

int PDF_fill_textblock ( resource $pdfdoc, int $page, string $blockname, string $text, string $optlist )

Fills a text block with variable data according to its properties.

This function is only available in the PDFlib Personalization Server (PPS).

Předcházející | Nahoru | Další
PDF_fill_stroke | Domů | PDF_fill


PDF_fit_image

(PECL pdflib:2.0-2.1.3)

PDF_fit_image — Place image or template

Popis

bool PDF_fit_image ( resource $pdfdoc, int $image, float $x, float $y, string $optlist )

Places an image or template on the page, subject to various options. Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
PDF_findfont | Domů | PDF_fit_pdi_page


PDF_fit_pdi_page

(PECL pdflib:2.0-2.1.3)

PDF_fit_pdi_page — Place imported PDF page

Popis

bool PDF_fit_pdi_page ( resource $pdfdoc, int $page, float $x, float $y, string $optlist )

Places an imported PDF page on the page, subject to various options. Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
PDF_fit_image | Domů | PDF_fit_table


PDF_fit_table

(PECL pdflib:2.1.0-2.1.3)

PDF_fit_table — Place table on page

Popis

string PDF_fit_table ( resource $pdfdoc, int $table, float $llx, float $lly, float $urx, float $ury, string $optlist )

Places a table on the page fully or partially.

Předcházející | Nahoru | Další
PDF_fit_pdi_page | Domů | PDF_fit_textflow


PDF_fit_textflow

(PECL pdflib:2.0-2.1.3)

PDF_fit_textflow — Format textflow in rectangular area

Popis

string PDF_fit_textflow ( resource $pdfdoc, int $textflow, float $llx, float $lly, float $urx, float $ury, string $optlist )

Formats the next portion of a textflow into a rectangular area.

Předcházející | Nahoru | Další
PDF_fit_table | Domů | PDF_fit_textline


PDF_fit_textline

(PECL pdflib:2.0-2.1.3)

PDF_fit_textline — Place single line of text

Popis

bool PDF_fit_textline ( resource $pdfdoc, string $text, float $x, float $y, string $optlist )

Places a single line of text on the page, subject to various options. Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
PDF_fit_textflow | Domů | PDF_get_apiname


PDF_get_apiname

(PECL pdflib:2.0-2.1.3)

PDF_get_apiname — Get name of unsuccessfull API function

Popis

string PDF_get_apiname ( resource $pdfdoc )

Gets the name of the API function which threw the last exception or failed.

Předcházející | Nahoru | Další
PDF_fit_textline | Domů | PDF_get_buffer


PDF_get_errmsg

(PECL pdflib:2.0-2.1.3)

PDF_get_errmsg — Get error text

Popis

string PDF_get_errmsg ( resource $pdfdoc )

Gets the text of the last thrown exception or the reason for a failed function call.

Předcházející | Nahoru | Další
PDF_get_buffer | Domů | PDF_get_errnum


PDF_get_errnum

(PECL pdflib:2.0-2.1.3)

PDF_get_errnum — Get error number

Popis

int PDF_get_errnum ( resource $pdfdoc )

Gets the number of the last thrown exception or the reason for a failed function call.

Předcházející | Nahoru | Další
PDF_get_errmsg | Domů | PDF_get_font


PDF_info_font

(PECL pdflib:2.1.0-2.1.3)

PDF_info_font — Query detailed information about a loaded font

Popis

float PDF_info-font ( resource $pdfdoc, int $font, string $keyword, string $optlist )

Queries detailed information about a loaded font.

Předcházející | Nahoru | Další
PDF_get_value | Domů | PDF_info_matchbox


PDF_info_matchbox

(PECL pdflib:2.1.0-2.1.3)

PDF_info_matchbox — Query matchbox information

Popis

float PDF_info_matchbox ( resource $pdfdoc, string $boxname, int $num, string $keyword )

Queries information about a matchbox on the current page.

Předcházející | Nahoru | Další
PDF_info_font | Domů | PDF_info_table


PDF_info_table

(PECL pdflib:2.1.0-2.1.3)

PDF_info_table — Retrieve table information

Popis

float PDF_info_table ( resource $pdfdoc, int $table, string $keyword )

Retrieves table information related to the most recently placed table instance.

Předcházející | Nahoru | Další
PDF_info_matchbox | Domů | PDF_info_textflow


PDF_info_textflow

(PECL pdflib:2.0-2.1.3)

PDF_info_textflow — Query textflow state

Popis

float PDF_info_textflow ( resource $pdfdoc, int $textflow, string $keyword )

Queries the current state of a textflow.

Předcházející | Nahoru | Další
PDF_info_table | Domů | PDF_info_textline


PDF_info_textline

(PECL pdflib:2.1.0-2.1.3)

PDF_info_textline — Perform textline formatting and query metrics

Popis

float PDF_info_textline ( resource $pdfdoc, string $text, string $keyword, string $optlist )

Performs textline formatting and queries the resulting metrics.

Předcházející | Nahoru | Další
PDF_info_textflow | Domů | PDF_initgraphics


PDF_load_3ddata

(PECL pdflib:2.1.0-2.1.3)

PDF_load_3ddata — Load 3D model

Popis

int PDF_load_3ddata ( resource $pdfdoc, string $filename, string $optlist )

Loads a 3D model from a disk-based or virtual file.

This function requires PDF 1.6.

Předcházející | Nahoru | Další
PDF_lineto | Domů | PDF_load_font


PDF_load_font

(PECL pdflib:2.0-2.1.3)

PDF_load_font — Search and prepare font

Popis

int PDF_load_font ( resource $pdfdoc, string $fontname, string $encoding, string $optlist )

Searches for a font and prepares it for later use.

Předcházející | Nahoru | Další
PDF_load_3ddata | Domů | PDF_load_iccprofile


PDF_load_iccprofile

(PECL pdflib:2.0-2.1.3)

PDF_load_iccprofile — Search and prepare ICC profile

Popis

int PDF_load_iccprofile ( resource $pdfdoc, string $profilename, string $optlist )

Searches for an ICC profile, and prepares it for later use.

Předcházející | Nahoru | Další
PDF_load_font | Domů | PDF_load_image


PDF_load_image

(PECL pdflib:2.0-2.1.3)

PDF_load_image — Open image file

Popis

int PDF_load_image ( resource $pdfdoc, string $imagetype, string $filename, string $optlist )

Opens a disk-based or virtual image file subject to various options.

Předcházející | Nahoru | Další
PDF_load_iccprofile | Domů | PDF_makespotcolor


PDF_pcos_get_number

(PECL pdflib:2.1.0-2.1.3)

PDF_pcos_get_number — Get value of pCOS path with type number or boolean

Popis

float PDF_pcos_get_number ( resource $p, int $doc, string $path )

Gets the value of a pCOS path with type number or boolean.

Předcházející | Nahoru | Další
PDF_open_tiff | Domů | PDF_pcos_get_stream


PDF_pcos_get_stream

(PECL pdflib:2.1.0-2.1.3)

PDF_pcos_get_stream — Get contents of pCOS path with type stream, fstream, or string

Popis

string PDF_pcos_get_stream ( resource $p, int $doc, string $optlist, string $path )

Gets the contents of a pCOS path with type stream, fstream, or string.

Předcházející | Nahoru | Další
PDF_pcos_get_number | Domů | PDF_pcos_get_string


PDF_pcos_get_string

(PECL pdflib:2.1.0-2.1.3)

PDF_pcos_get_string — Get value of pCOS path with type name, string, or boolean

Popis

string PDF_pcos_get_string ( resource $p, int $doc, string $path )

Gets the value of a pCOS path with type name, string, or boolean.

Předcházející | Nahoru | Další
PDF_pcos_get_stream | Domů | PDF_place_image


PDF_process_pdi

(PECL pdflib:2.0-2.1.3)

PDF_process_pdi — Process imported PDF document

Popis

int PDF_process_pdi ( resource $pdfdoc, int $doc, int $page, string $optlist )

Processes certain elements of an imported PDF document.

Předcházející | Nahoru | Další
PDF_place_pdi_page | Domů | PDF_rect


PDF_resume_page

(PECL pdflib:2.0-2.1.3)

PDF_resume_page — Resume page

Popis

bool PDF_resume_page ( resource $pdfdoc, string $optlist )

Resumes a page to add more content to it.

Předcházející | Nahoru | Další
PDF_restore | Domů | PDF_rotate


PDF_set_gstate

(PECL pdflib:2.0-2.1.3)

PDF_set_gstate — Activate graphics state object

Popis

bool PDF_set_gstate ( resource $pdfdoc, int $gstate )

Activates a graphics state object.

Předcházející | Nahoru | Další
PDF_set_duration | Domů | PDF_set_horiz_scaling


PDF_set_layer_dependency

(PECL pdflib:2.0-2.1.3)

PDF_set_layer_dependency — Define relationships among layers

Popis

bool PDF_set_layer_dependency ( resource $pdfdoc, string $type, string $optlist )

Defines hierarchical and group relationships among layers. Vrací TRUE při úspěchu, FALSE při selhání.

This function requires PDF 1.5.

Předcházející | Nahoru | Další
pdf_set_info | Domů | pdf_set_leading


PDF_setdashpattern

(PECL pdflib:2.0-2.1.3)

PDF_setdashpattern — Set dash pattern

Popis

bool PDF_setdashpattern ( resource $pdfdoc, string $optlist )

Sets a dash pattern defined by an option list. Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
PDF_setdash | Domů | PDF_setflat


PDF_shading

(PECL pdflib:2.0-2.1.3)

PDF_shading — Define blend

Popis

int PDF_shading ( resource $pdfdoc, string $shtype, float $x0, float $y0, float $x1, float $y1, float $c1, float $c2, float $c3, float $c4, string $optlist )

Defines a blend from the current fill color to another color.

This function requires PDF 1.4 or above.

Předcházející | Nahoru | Další
PDF_shading_pattern | Domů | PDF_shfill


PDF_shading_pattern

(PECL pdflib:2.0-2.1.3)

PDF_shading_pattern — Define shading pattern

Popis

int PDF_shading_pattern ( resource $pdfdoc, int $shading, string $optlist )

Defines a shading pattern using a shading object.

This function requires PDF 1.4 or above.

Předcházející | Nahoru | Další
PDF_setrgbcolor | Domů | PDF_shading


PDF_shfill

(PECL pdflib:2.0-2.1.3)

PDF_shfill — Fill area with shading

Popis

bool PDF_shfill ( resource $pdfdoc, int $shading )

Fills an area with a shading, based on a shading object.

This function requires PDF 1.4 or above.

Předcházející | Nahoru | Další
PDF_shading | Domů | pdf_show_boxed


PDF_suspend_page

(PECL pdflib:2.0-2.1.3)

PDF_suspend_page — Suspend page

Popis

bool PDF_suspend_page ( resource $pdfdoc, string $optlist )

Suspends the current page so that it can later be resumed with PDF_resume_page().

Předcházející | Nahoru | Další
PDF_stroke | Domů | PDF_translate


PDF_utf8_to_utf16

(PECL pdflib:2.0.3-2.1.3)

PDF_utf8_to_utf16 — Convert string from UTF-8 to UTF-16

Popis

string PDF_utf8_to_utf16 ( resource $pdfdoc, string $utf8string, string $ordering )

Converts a string from UTF-8 format to UTF-16.

Předcházející | Nahoru | Další
PDF_utf32_to_utf16 | Domů | CXXII. PDO Functions


PDF_utf16_to_utf8

(PECL pdflib:2.0.3-2.1.3)

PDF_utf16_to_utf8 — Convert string from UTF-16 to UTF-8

Popis

string PDF_utf16_to_utf8 ( resource $pdfdoc, string $utf16string )

Converts a string from UTF-16 format to UTF-8.

Předcházející | Nahoru | Další
PDF_translate | Domů | PDF_utf32_to_utf16


PDF_utf32_to_utf16

(No version information available, might be only in CVS)

PDF_utf32_to_utf16 — Convert string from UTF-32 to UTF-16

Popis

string PDF_utf32_to_utf16 ( resource $pdfdoc, string $utf32string, string $ordering )

Converts a string from UTF-32 format to UTF-16.

Předcházející | Nahoru | Další
PDF_utf16_to_utf8 | Domů | PDF_utf8_to_utf16


PDO->getAttribute()

(PHP 5 >= 5.1.0, PECL pdo:0.2-1.0.3)

PDO->getAttribute() — Retrieve a database connection attribute

Popis

class PDO {
mixed getAttribute ( int $attribute )
}

This function returns the value of a database connection attribute. To retrieve PDOStatement attributes, refer to PDOStatement->getAttribute().

Note that some database/driver combinations may not support all of the database connection attributes.

Seznam parametrů

attribute

One of the PDO::ATTR_* constants. The constants that apply to database connections are as follows:

PDO::ATTR_AUTOCOMMIT
PDO::ATTR_CASE
PDO::ATTR_CLIENT_VERSION
PDO::ATTR_CONNECTION_STATUS
PDO::ATTR_DRIVER_NAME
PDO::ATTR_ERRMODE
PDO::ATTR_ORACLE_NULLS
PDO::ATTR_PERSISTENT
PDO::ATTR_PREFETCH
PDO::ATTR_SERVER_INFO
PDO::ATTR_SERVER_VERSION
PDO::ATTR_TIMEOUT

Návratové hodnoty

A successful call returns the value of the requested PDO attribute. An unsuccessful call returns null.

Příklady

Příklad 1565. Retrieving database connection attributes

<?php
$conn = new PDO('odbc:sample', 'db2inst1', 'ibmdb2');
$attributes = array(
    "AUTOCOMMIT", "ERRMODE", "CASE", "CLIENT_VERSION", "CONNECTION_STATUS",
    "ORACLE_NULLS", "PERSISTENT", "PREFETCH", "SERVER_INFO", "SERVER_VERSION",
    "TIMEOUT"
);

foreach ($attributes as $val) {
    echo "PDO::ATTR_$val: ";
    echo $conn->getAttribute(constant("PDO::ATTR_$val")) . "\n";
}
?>

Viz také

PDO->setAttribute()
PDOStatement->getAttribute()
PDOStatement->setAttribute()

Předcházející | Nahoru | Další
PDO->exec() | Domů | PDO->getAvailableDrivers()


PDO->getAvailableDrivers()

(No version information available, might be only in CVS)

PDO->getAvailableDrivers() — Return an array of available PDO drivers

Popis

class PDO {
array getAvailableDrivers ( void )
}

This function returns all currently available PDO drivers which can be used in DSN parameter of PDO->__construct(). This is a static method.

Návratové hodnoty

PDO->getAvailableDrivers() returns an array of PDO driver names. If no drivers are available, it returns an empty array.

Příklady

Příklad 1566. A PDO->getAvailableDrivers() example

<?php
print_r(PDO::getAvailableDrivers());
?>

Výše uvedený příklad vypíše něco jako:

Array
(
    [0] => mysql
    [1] => sqlite
)

Předcházející | Nahoru | Další
PDO->getAttribute() | Domů | PDO->lastInsertId()


PDO::pgsqlLOBCreate

(PHP 5 >= 5.1.2, PECL pdo_pgsql:1.0.1-1.0.2)

PDO::pgsqlLOBCreate — Creates a new large object

Popis

string PDO::pgsqlLOBCreate ( void )

PDO::pgsqlLOBCreate() creates a large object and returns the OID of that object. You may then open a stream on the object using PDO::pgsqlLOBOpen() to read or write data to it. The OID can be stored in columns of type OID and be used to reference the large object, without causing the row to grow arbitrarily large. The large object will continue to live in the database until it is removed by calling PDO::pgsqlLOBUnlink().

Large objects can be up to 2GB in size, but are cumbersome to use; you need to ensure that PDO::pgsqlLOBUnlink() is called prior to deleting the last row that references its OID from your database. In addition, large objects have no access controls. As an alternative, try the bytea column type; recent versions of PostgreSQL allow bytea columns of up to 1GB in size and transparently manage the storage for optimal row size.

Poznámka: This function must be called within a transaction.

Seznam parametrů

PDO::pgsqlLOBCreate() takes no parameters.

Návratové hodnoty

Returns the OID of the newly created large object on success, or FALSE on failure.

Příklady

Příklad 1777. A PDO::pgsqlLOBCreate() example

This example creates a new large object and copies the contents of a file into it. The OID is then stored into a table.

<?php
$db = new PDO('pgsql:dbname=test host=localhost', $user, $pass);
$db->setAttribute(PDO::ATTR_ERRMODE, PDO::ERRMODE_EXCEPTION);
$db->beginTransaction();
$oid = $db->pgsqlLOBCreate();
$stream = $db->pgsqlLOBOpen($oid, 'w');
$local = fopen($filename, 'rb');
stream_copy_to_stream($local, $stream);
$local = null;
$stream = null;
$stmt = $db->prepare("INSERT INTO BLOBS (ident, oid) VALUES (?, ?)");
$stmt->execute(array($some_id, $oid));
$db->commit();
?>

Viz také

PDO::pgsqlLOBOpen()
PDO::pgsqlLOBUnlink()
pg_lo_create()

Předcházející | Nahoru | Další
PDO_PGSQL DSN | Domů | PDO::pgsqlLOBOpen


PDO::pgsqlLOBOpen

(PHP 5 >= 5.1.2, PECL pdo_pgsql:1.0.1-1.0.2)

PDO::pgsqlLOBOpen — Opens an existing large object stream

Popis

resource PDO::pgsqlLOBOpen ( string $oid [, string $mode] )

PDO::pgsqlLOBOpen() opens a stream to access the data referenced by oid. If mode is r, the stream is opened for reading, if mode is w, then the stream will be opened for writing. You can use all the usual filesystem functions, such as fread(), fwrite() and fgets() to manipulate the contents of the stream.

Poznámka: This function, and all manipulations of the large object, must be called and carried out within a transaction.

Seznam parametrů

oid

A large object identifier.

mode

If mode is r, open the stream for reading. If mode is w, open the stream for writing.

Návratové hodnoty

Returns a stream resource on success, or FALSE on failure.

Příklady

Příklad 1778. A PDO::pgsqlLOBOpen() example

Following on from the PDO::pgsqlLOBCreate() example, this code snippet retrieves the large object from the database and outputs it to the browser.

<?php
$db = new PDO('pgsql:dbname=test host=localhost', $user, $pass);
$db->setAttribute(PDO::ATTR_ERRMODE, PDO::ERRMODE_EXCEPTION);
$db->beginTransaction();
$stmt = $db->prepare("select oid from BLOBS where ident = ?");
$stmt->execute(array($some_id));
$stmt->bindColumn('oid', $lob, PDO::PARAM_LOB);
$stmt->fetch(PDO::FETCH_BOUND);
fpassthru($lob);
?>

Viz také

PDO::pgsqlLOBCreate()
PDO::pgsqlLOBUnlink()
pg_lo_open()

Předcházející | Nahoru | Další
PDO::pgsqlLOBCreate | Domů | PDO::pgsqlLOBUnlink


PDO::pgsqlLOBUnlink

(PHP 5 >= 5.1.2, PECL pdo_pgsql:1.0.1-1.0.2)

PDO::pgsqlLOBUnlink — Deletes the large object

Popis

bool PDO::pgsqlLOBUnlink ( string $oid )

Deletes a large object from the database identified by OID.

Poznámka: This function must be called within a transaction.

Seznam parametrů

oid

A large object identifier

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1779. A PDO::pgsqlLOBUnlink() example

This example unlinks a large object from the database prior to deleting the row that references it from the blobs table we've been using in our PDO::pgsqlLOBCreate() and PDO::pgsqlLOBOpen() examples.

<?php
$db = new PDO('pgsql:dbname=test host=localhost', $user, $pass);
$db->setAttribute(PDO::ATTR_ERRMODE, PDO::ERRMODE_EXCEPTION);
$db->beginTransaction();
$db->pgsqlLOBUnlink($oid);
$stmt = $db->prepare("DELETE FROM BLOBS where ident = ?");
$stmt->execute(array($some_id));
$db->commit();
?>

Viz také

PDO::pgsqlLOBOpen()
PDO::pgsqlLOBCreate()

Předcházející | Nahoru | Další
PDO::pgsqlLOBOpen | Domů | CXXIX. Printer Functions


PDO->query()

(PHP 5 >= 5.1.0, PECL pdo:0.2-1.0.3)

PDO->query() — Executes an SQL statement, returning a result set as a PDOStatement object

Popis

class PDO {
PDOStatement query ( string $statement )
} class PDO {
PDOStatement query ( string $statement, int $PDO::FETCH_COLUMN, int $colno )
} class PDO {
PDOStatement query ( string $statement, int $PDO::FETCH_CLASS, string $classname, array $ctorargs )
} class PDO {
PDOStatement query ( string $statement, int $PDO::FETCH_INTO, object $object )
}

PDO->query() executes an SQL statement in a single function call, returning the result set (if any) returned by the statement as a PDOStatement object.

For a query that you need to issue multiple times, you will realize better performance if you prepare a PDOStatement object using PDO->prepare() and issue the statement with multiple calls to PDOStatement->execute().

If you do not fetch all of the data in a result set before issuing your next call to PDO->query(), your call may fail. Call PDOStatement->closeCursor() to release the database resources associated with the PDOStatement object before issuing your next call to PDO->query().

Poznámka: Although this function is only documented as having a single parameter, you may pass additional arguments to this function. They will be treated as though you called PDOStatement->setFetchMode() on the resultant statement object.

Seznam parametrů

statement

The SQL statement to prepare and execute.

Návratové hodnoty

PDO->query() returns a PDOStatement object.

Příklady

Příklad 1569. Demonstrate PDO::query

A nice feature of PDO->query() is that it enables you to iterate over the rowset returned by a successfully executed SELECT statement.

<?php
function getFruit($conn) {
    $sql = 'SELECT name, colour, calories FROM fruit ORDER BY name';
    foreach ($conn->query($sql) as $row) {
        print $row['NAME'] . "\t";
        print $row['COLOUR'] . "\t";
        print $row['CALORIES'] . "\n";
    }
}
?>

Výše uvedený příklad vypíše:

apple   red     150
banana  yellow  250
kiwi    brown   75
lemon   yellow  25
orange  orange  300
pear    green   150
watermelon      pink    90

Viz také

PDO->exec()
PDO->prepare()
PDOStatement->execute()

Předcházející | Nahoru | Další
PDO->prepare() | Domů | PDO->quote()


PDO->quote()

(PHP 5 >= 5.1.0, PECL pdo:0.2.1-1.0.3)

PDO->quote() — Quotes a string for use in a query.

Popis

class PDO {
string quote ( string $string [, int $parameter_type] )
}

PDO->quote() places quotes around the input string (if required) and escapes special characters within the input string, using a quoting style appropriate to the underlying driver.

If you are using this function to build SQL statements, you are strongly recommended to use PDO->prepare() to prepare SQL statements with bound parameters instead of using PDO->quote() to interpolate user input into a SQL statement. Prepared statements with bound parameters are not only more portable, more convenient, immune to SQL injection, but are often much faster to execute than interpolated queries, as both the server and client side can cache a compiled form of the query.

Not all PDO drivers implement this method (notably PDO_ODBC). Consider using prepared statements instead.

Seznam parametrů

string

The string to be quoted.

parameter_type

Provides a data type hint for drivers that have alternate quoting styles. The default value is PDO::PARAM_STR.

Návratové hodnoty

Returns a quoted string that is theoretically safe to pass into an SQL statement. Returns FALSE if the driver does not support quoting in this way.

Příklady

Příklad 1570. Quoting a normal string

<?php
$conn = new PDO('sqlite:/home/lynn/music.sql3');

/* Simple string */
$string = 'Nice';
print "Unquoted string: $string\n";
print "Quoted string: " . $conn->quote($string) . "\n";
?>

Výše uvedený příklad vypíše:

Unquoted string: Nice
Quoted string: 'Nice'

Příklad 1571. Quoting a dangerous string

<?php
$conn = new PDO('sqlite:/home/lynn/music.sql3');

/* Dangerous string */
$string = 'Naughty \' string';
print "Unquoted string: $string\n";
print "Quoted string:" . $conn->quote($string) . "\n";
?>

Výše uvedený příklad vypíše:

Unquoted string: Naughty ' string
Quoted string: 'Naughty '' string'

Příklad 1572. Quoting a complex string

<?php
$conn = new PDO('sqlite:/home/lynn/music.sql3');

/* Complex string */
$string = "Co'mpl''ex \"st'\"ring";
print "Unquoted string: $string\n";
print "Quoted string: " . $conn->quote($string) . "\n";
?>

Výše uvedený příklad vypíše:

Unquoted string: Co'mpl''ex "st'"ring
Quoted string: 'Co''mpl''''ex "st''"ring'

Viz také

PDO->prepare()
PDOStatement->execute()

Předcházející | Nahoru | Další
PDO->query() | Domů | PDO->rollBack()


PDO->sqliteCreateAggregate()

(No version information available, might be only in CVS)

PDO->sqliteCreateAggregate() — Registers an aggregating User Defined Function for use in SQL statements

Popis

class PDO {
bool sqliteCreateAggregate ( string $function_name, callback $step_func, callback $finalize_func [, int $num_args] )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

This method is similar to PDO->sqliteCreateFunction() except that it registers functions that can be used to calculate a result aggregated across all the rows of a query.

The key difference between this method and PDO->sqliteCreateFunction() is that two functions are required to manage the aggregate.

Seznam parametrů

function_name

The name of the function used in SQL statements.

step_func

Callback function called for each row of the result set. Your PHP function should accumulate the result and store it in the aggregation context.

This function need to be defined as: step ( mixed $context, int $rownumber, mixed $value1 [, mixed $value2 [, mixed $..]] )

context will be NULL for the first row; on subsequent rows it will have the value that was previously returned from the step function; you should use this to maintain the aggregate state.

rownumber will hold the current row number.

finalize_func

Callback function to aggregate the "stepped" data from each row. Once all the rows have been processed, this function will be called and it should then take the data from the aggregation context and return the result. Callback functions should return a type understood by SQLite (i.e. scalar type).

This function need to be defined as: fini ( mixed $context, int $rownumber )

context will hold the return value from the very last call to the step function.

rownumber will hold the number of rows over which the aggregate was performed.

The return value of this function will be used as the return value for the aggregate.

num_args

Hint to the SQLite parser if the callback function accepts a predetermined number of arguments.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 2128. max_length aggregation function example

<?php
$data = array(
   'one',
   'two',
   'three',
   'four',
   'five',
   'six',
   'seven',
   'eight',
   'nine',
   'ten',
   );
$db = new PDO('sqlite::memory:');
$db->exec("CREATE TABLE strings(a)");
$insert = $db->prepare('INSERT INTO strings VALUES (?)');
foreach ($data as $str) {
    $insert->execute(array($str));
}
$insert = null;

function max_len_step(&$context, $rownumber, $string)
{
    if (strlen($string) > $context) {
        $context = strlen($string);
    }
}

function max_len_finalize(&$context, $rownumber)
{
    return $context;
}

$db->sqliteCreateAggregate('max_len', 'max_len_step', 'max_len_finalize');

var_dump($db->query('SELECT max_len(a) from strings')->fetchAll());

?>

In this example, we are creating an aggregating function that will calculate the length of the longest string in one of the columns of the table. For each row, the max_len_step function is called and passed a context parameter. The context parameter is just like any other PHP variable and be set to hold an array or even an object value. In this example, we are simply using it to hold the maximum length we have seen so far; if the string has a length longer than the current maximum, we update the context to hold this new maximum length.

After all of the rows have been processed, SQLite calls the max_len_finalize function to determine the aggregate result. Here, we could perform some kind of calculation based on the data found in the context. In our simple example though, we have been calculating the result as the query progressed, so we simply need to return the context value.

Tip

It is NOT recommended for you to store a copy of the values in the context and then process them at the end, as you would cause SQLite to use a lot of memory to process the query - just think of how much memory you would need if a million rows were stored in memory, each containing a string 32 bytes in length.

Tip

You can use PDO->sqliteCreateFunction() and PDO->sqliteCreateAggregate() to override SQLite native SQL functions.

Poznámka: This method is not available with the SQLite2 driver. Use the old style sqlite API for that instead.

Viz také

PDO->sqliteCreateFunction()
sqlite_create_function()
sqlite_create_aggregate()

Předcházející | Nahoru | Další
PDO_SQLITE DSN | Domů | PDO->sqliteCreateFunction()


PDO->sqliteCreateFunction()

(No version information available, might be only in CVS)

PDO->sqliteCreateFunction() — Registers a User Defined Function for use in SQL statements

Popis

class PDO {
bool sqliteCreateFunction ( string $function_name, callback $callback [, int $num_args] )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

This method allows you to register a PHP function with SQLite as an UDF (User Defined Function), so that it can be called from within your SQL statements.

The UDF can be used in any SQL statement that can call functions, such as SELECT and UPDATE statements and also in triggers.

Seznam parametrů

function_name

The name of the function used in SQL statements.

callback

Callback function to handle the defined SQL function.

Poznámka: Callback functions should return a type understood by SQLite (i.e. scalar type).

num_args

Hint to the SQLite parser if the callback function accepts a predetermined number of arguments.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 2129. PDO::sqliteCreateFunction() example

<?php
function md5_and_reverse($string)
{
    return strrev(md5($string));
}

$db = new PDO('sqlite:sqlitedb');
$db->sqliteCreateFunction('md5rev', 'md5_and_reverse', 1);
$rows = $db->query('SELECT md5rev(filename) FROM files')->fetchAll();
?>

In this example, we have a function that calculates the md5 sum of a string, and then reverses it. When the SQL statement executes, it returns the value of the filename transformed by our function. The data returned in $rows contains the processed result.

The beauty of this technique is that you do not need to process the result using a foreach() loop after you have queried for the data.

Tip

You can use PDO->sqliteCreateFunction() and PDO->sqliteCreateAggregate() to override SQLite native SQL functions.

Poznámka: This method is not available with the SQLite2 driver. Use the old style sqlite API for that instead.

Viz také

PDO->sqliteCreateAggregate()
sqlite_create_function()
sqlite_create_aggregate()

Předcházející | Nahoru | Další
PDO->sqliteCreateAggregate() | Domů | CLVIII. Secure Shell2 Functions


PDOStatement->bindValue()

(PHP 5 >= 5.1.0, PECL pdo:1.0-1.0.3)

PDOStatement->bindValue() — Binds a value to a parameter

Popis

class PDOStatement {
bool bindValue ( mixed $parameter, mixed $value [, int $data_type] )
}

Binds a value to a corresponding named or question mark placeholder in the SQL statement that was use to prepare the statement.

Seznam parametrů

parameter

Parameter identifier. For a prepared statement using named placeholders, this will be a parameter name of the form :name. For a prepared statement using question mark placeholders, this will be the 1-indexed position of the parameter.

value

The value to bind to the parameter.

data_type

Explicit data type for the parameter using the PDO::PARAM_* constants. Defaults to PHP native type.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1578. Execute a prepared statement with named placeholders

<?php
/* Execute a prepared statement by binding PHP variables */
$calories = 150;
$colour = 'red';
$sth = $dbh->prepare('SELECT name, colour, calories
    FROM fruit
    WHERE calories < :calories AND colour = :colour');
$sth->bindValue(':calories', $calories, PDO::PARAM_INT);
$sth->bindValue(':colour', $colour, PDO::PARAM_STR);
$sth->execute();
?>

Příklad 1579. Execute a prepared statement with question mark placeholders

<?php
/* Execute a prepared statement by binding PHP variables */
$calories = 150;
$colour = 'red';
$sth = $dbh->prepare('SELECT name, colour, calories
    FROM fruit
    WHERE calories < ? AND colour = ?');
$sth->bindValue(1, $calories, PDO::PARAM_INT);
$sth->bindValue(2, $colour, PDO::PARAM_STR);
$sth->execute();
?>

Viz také

PDO->prepare()
PDOStatement->execute()
PDOStatement->bindParam()

Předcházející | Nahoru | Další
PDOStatement->bindParam() | Domů | PDOStatement->closeCursor()


PDOStatement->closeCursor()

(PHP 5 >= 5.1.0, PECL pdo:0.9-1.0.3)

PDOStatement->closeCursor() — Closes the cursor, enabling the statement to be executed again.

Popis

class PDOStatement {
bool closeCursor ( void )
}

PDOStatement->closeCursor() frees up the connection to the server so that other SQL statements may be issued, but leaves the statement in a state that enables it to be executed again.

This method is useful for database drivers that do not support executing a PDOStatement object when a previously executed PDOStatement object still has unfetched rows. If your database driver suffers from this limitation, the problem may manifest itself in an out-of-sequence error.

PDOStatement->closeCursor() is implemented either as an optional driver specific method (allowing for maximum efficiency), or as the generic PDO fallback if no driver specific function is installed. The PDO generic fallback is semantically the same as writing the following code in your PHP script: <?php
do {
    while ($stmt->fetch())
        ;
    if (!$stmt->nextRowset())
        break;
} while (true);
?>

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1580. A PDOStatement->closeCursor() example

In the following example, the $stmt PDOStatement object returns multiple rows but the application fetches only the first row, leaving the PDOStatement object in a state of having unfetched rows. To ensure that the application will work with all database drivers, the author inserts a call to PDOStatement->closeCursor() on $stmt before executing the $otherStmt PDOStatement object.

<?php
/* Create a PDOStatement object */
$stmt = $dbh->prepare('SELECT foo FROM bar');

/* Create a second PDOStatement object */
$otherStmt = $dbh->prepare('SELECT foobaz FROM foobar');

/* Execute the first statement */
$stmt->execute();

/* Fetch only the first row from the results */
$stmt->fetch();

/* The following call to closeCursor() may be required by some drivers */
$stmt->closeCursor();

/* Now we can execute the second statement */
$otherStmt->execute();
?>

Viz také

PDOStatement->execute()

Předcházející | Nahoru | Další
PDOStatement->bindValue() | Domů | PDOStatement->columnCount()


PDOStatement->columnCount()

(PHP 5 >= 5.1.0, PECL pdo:0.2-1.0.3)

PDOStatement->columnCount() — Returns the number of columns in the result set

Popis

class PDOStatement {
int columnCount ( void )
}

Use PDOStatement->columnCount() to return the number of columns in the result set represented by the PDOStatement object.

If the PDOStatement object was returned from PDO->query(), the column count is immediately available.

If the PDOStatement object was returned from PDO->prepare(), an accurate column count will not be available until you invoke PDOStatement->execute().

Návratové hodnoty

Returns the number of columns in the result set represented by the PDOStatement object. If there is no result set, PDOStatement->columnCount() returns 0.

Příklady

Příklad 1581. Counting columns

This example demonstrates how PDOStatement->columnCount() operates with and without a result set.

<?php
$dbh = new PDO('odbc:sample', 'db2inst1', 'ibmdb2');

$sth = $dbh->prepare("SELECT name, colour FROM fruit");

/* Count the number of columns in the (non-existent) result set */
$colcount = $sth->columnCount();
print("Before execute(), result set has $colcount columns (should be 0)\n");

$sth->execute();

/* Count the number of columns in the result set */
$colcount = $sth->columnCount();
print("After execute(), result set has $colcount columns (should be 2)\n");

?>

Výše uvedený příklad vypíše:

Before execute(), result set has 0 columns (should be 0)
After execute(), result set has 2 columns (should be 2)

Viz také

PDO->prepare()
PDOStatement->execute()
PDOStatement->rowCount()

Předcházející | Nahoru | Další
PDOStatement->closeCursor() | Domů | PDOStatement->errorCode()


PDOStatement->fetchColumn()

(PHP 5 >= 5.1.0, PECL pdo:0.9-1.0.3)

PDOStatement->fetchColumn() — Returns a single column from the next row of a result set

Popis

class PDOStatement {
string fetchColumn ( [int $column_number] )
}

Returns a single column from the next row of a result set or FALSE if there are no more rows.

Seznam parametrů

column_number

0-indexed number of the column you wish to retrieve from the row. If no value is supplied, PDOStatement->fetchColumn() fetches the first column.

Návratové hodnoty

PDOStatement->fetchColumn() returns a single column in the next row of a result set.

Varování

There is no way to return another column from the same row if you use PDOStatement->fetchColumn() to retrieve data.

Příklady

Příklad 1593. Return first column of the next row

<?php
$sth = $dbh->prepare("SELECT name, colour FROM fruit");
$sth->execute();

/* Fetch the first column from the next row in the result set */
print("Fetch the first column from the next row in the result set:\n");
$result = $sth->fetchColumn();
print("name = $result\n");

print("Fetch the second column from the next row in the result set:\n");
$result = $sth->fetchColumn(1);
print("colour = $result\n");
?>

Výše uvedený příklad vypíše:

Fetch the first column from the next row in the result set:
name = lemon
Fetch the second column from the next row in the result set:
colour = red

Viz také

PDO->query()
PDOStatement->fetch()
PDOStatement->fetchAll()
PDO->prepare()
PDOStatement->setFetchMode()

Předcházející | Nahoru | Další
PDOStatement->fetchAll() | Domů | PDOStatement->fetchObject()


PDOStatement->fetchObject()

(PHP 5 >= 5.1.0, PECL pdo:0.2.4-1.0.3)

PDOStatement->fetchObject() — Fetches the next row and returns it as an object.

Popis

class PDOStatement {
mixed fetchObject ( [string $class_name [, array $ctor_args]] )
}

Fetches the next row and returns it as an object. This function is an
alternative to PDOStatement->fetch() with
PDO::FETCH_CLASS or
PDO::FETCH_OBJ style.

Seznam parametrů

class_name

Name of the created class, defaults to stdClass.

ctor_args

Elements of this array are passed to the constructor.

Návratové hodnoty

Returns an instance of the required class with property names that correspond to the column names or FALSE in case of an error.

Viz také

PDOStatement->fetch()

Předcházející | Nahoru | Další
PDOStatement->fetchColumn() | Domů | PDOStatement->getAttribute()


PDOStatement->getAttribute()

(PHP 5 >= 5.1.0, PECL pdo:0.2-1.0.3)

PDOStatement->getAttribute() — Retrieve a statement attribute

Popis

class PDOStatement {
mixed getAttribute ( int $attribute )
}

Gets an attribute of the statement. Currently, no generic attributes exist but only driver specific:

  • PDO::ATTR_CURSOR_NAME (Firebird and ODBC specific): Get the name of cursor for UPDATE ... WHERE CURRENT OF.

Návratové hodnoty

Returns the attribute value.

Viz také

PDO->getAttribute()
PDO->setAttribute()
PDOStatement->setAttribute()

Předcházející | Nahoru | Další
PDOStatement->fetchObject() | Domů | PDOStatement->getColumnMeta()


PDOStatement->getColumnMeta()

(PHP 5 >= 5.1.0, PECL pdo:0.2-1.0.3)

PDOStatement->getColumnMeta() — Returns metadata for a column in a result set

Popis

class PDOStatement {
array getColumnMeta ( int $column )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Retrieves the metadata for a 0-indexed column in a result set as an associative array.

Varování

Not all PDO drivers support PDOStatement->getColumnMeta().

Seznam parametrů

column

The 0-indexed column in the result set.

Návratové hodnoty

Returns an associative array containing the following values representing the metadata for a single column:

Tabulka 241. Column metadata

Name | Value
native_type | The PHP native type used to represent the column value.
driver:decl_type | The SQL type used to represent the column value in the database. If the column in the result set is the result of a function, this value is not returned by PDOStatement->getColumnMeta().
flags | Any flags set for this column.
name | The name of this column as returned by the database.
table | The name of this column's table as returned by the database.
len | The length of this column. Normally -1 for types other than floating point decimals.
precision | The numeric precision of this column. Normally 0 for types other than floating point decimals.
pdo_type | The type of this column as represented by the PDO::PARAM_* constants.

Returns FALSE if the requested column does not exist in the result set, or if no result set exists.

ChangeLog (záznam změn)

Verze | Popis
5.2.3 | table field

Příklady

Příklad 1594. Retrieving column metadata

The following example shows the results of retrieving the metadata for a single column generated by a function (COUNT) in a PDO_SQLITE driver.

<?php
$select = $DB->query('SELECT COUNT(*) FROM fruit');
$meta = $select->getColumnMeta(0);
var_dump($meta);
?>

Výše uvedený příklad vypíše:

array(6) {
  ["native_type"]=>
  string(7) "integer"
  ["flags"]=>
  array(0) {
  }
  ["name"]=>
  string(8) "COUNT(*)"
  ["len"]=>
  int(-1)
  ["precision"]=>
  int(0)
  ["pdo_type"]=>
  int(2)
}

Viz také

PDOStatement->columnCount()
PDOStatement->rowCount()

Předcházející | Nahoru | Další
PDOStatement->getAttribute() | Domů | PDOStatement->nextRowset()


PDOStatement->nextRowset()

(PHP 5 >= 5.1.0, PECL pdo:0.2-1.0.3)

PDOStatement->nextRowset() — Advances to the next rowset in a multi-rowset statement handle

Popis

class PDOStatement {
bool nextRowset ( void )
}

Some database servers support stored procedures that return more than one rowset (also known as a result set). PDOStatement->nextRowset() enables you to access the second and subsequent rowsets associated with a PDOStatement object. Each rowset can have a different set of columns from the preceding rowset.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1595. Fetching multiple rowsets returned from a stored procedure

The following example shows how to call a stored procedure, MULTIPLE_ROWSETS, that returns three rowsets. We use a do / while loop to loop over the PDOStatement->nextRowset() method, which returns false and terminates the loop when no more rowsets can be returned.

<?php
$sql = 'CALL multiple_rowsets()';
$stmt = $conn->query($sql);
$i = 1;
do {
    $rowset = $stmt->fetchAll(PDO::FETCH_NUM);
    if ($rowset) {
        printResultSet($rowset, $i);
    }
    $i++;
} while ($stmt->nextRowset());

function printResultSet(&$rowset, $i) {
    print "Result set $i:\n";
    foreach ($rowset as $row) {
        foreach ($row as $col) {
            print $col . "\t";
        }
        print "\n";
    }
    print "\n";
}
?>

Výše uvedený příklad vypíše:

Result set 1:
apple    red
banana   yellow

Result set 2:
orange   orange    150
banana   yellow    175

Result set 3:
lime     green
apple    red
banana   yellow

Viz také

PDOStatement->columnCount()
PDOStatement->execute()
PDOStatement->getColumnMeta()
PDO->query()

Předcházející | Nahoru | Další
PDOStatement->getColumnMeta() | Domů | PDOStatement->rowCount()


PDOStatement->setAttribute()

(PHP 5 >= 5.1.0, PECL pdo:0.2-1.0.3)

PDOStatement->setAttribute() — Set a statement attribute

Popis

class PDOStatement {
bool setAttribute ( int $attribute, mixed $value )
}

Sets an attribute on the statement. Currently, no generic attributes are set but only driver specific:

  • PDO::ATTR_CURSOR_NAME (Firebird and ODBC specific): Set the name of cursor for UPDATE ... WHERE CURRENT OF.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

PDO->getAttribute()
PDO->setAttribute()
PDOStatement->getAttribute()

Předcházející | Nahoru | Další
PDOStatement->rowCount() | Domů | PDOStatement->setFetchMode()


PDOStatement->setFetchMode()

(PHP 5 >= 5.1.0, PECL pdo:0.2-1.0.3)

PDOStatement->setFetchMode() — Set the default fetch mode for this statement

Popis

class PDOStatement {
bool setFetchMode ( int $mode )
} class PDOStatement {
bool setFetchMode ( int $PDO::FETCH_COLUMN, int $colno )
} class PDOStatement {
bool setFetchMode ( int $PDO::FETCH_CLASS, string $classname, array $ctorargs )
} class PDOStatement {
bool setFetchMode ( int $PDO::FETCH_INTO, object $object )
}

Seznam parametrů

mode

The fetch mode must be one of the PDO::FETCH_* constants.

Návratové hodnoty

Returns 1 on success or FALSE on failure.

Příklady

Příklad 1598. Setting the fetch mode

The following example demonstrates how PDOStatement->setFetchMode() changes the default fetch mode for a PDOStatement object.

<?php
$sql = 'SELECT name, colour, calories FROM fruit';
try {
  $stmt = $dbh->query($sql);
  $result = $stmt->setFetchMode(PDO::FETCH_NUM);
  while ($row = $stmt->fetch()) {
    print $row[0] . "\t" . $row[1] . "\t" . $row[2] . "\n";
  }
}
catch (PDOException $e) {
  print $e->getMessage();
}
?>

Výše uvedený příklad vypíše:

apple   red     150
banana  yellow  250
orange  orange  300
kiwi    brown   75
lemon   yellow  25
pear    green   150
watermelon      pink    90

Předcházející | Nahoru | Další
PDOStatement->setAttribute() | Domů | CXXIII. Phar archive stream and classes


pg_execute

(PHP 5 >= 5.1.0)

pg_execute — Sends a request to execute a prepared statement with given parameters, and waits for the result.

Popis

resource pg_execute ( resource $connection, string $stmtname, array $params )
resource pg_execute ( string $stmtname, array $params )

Sends a request to execute a prepared statement with given parameters, and waits for the result.

pg_execute() is like pg_query_params(), but the command to be executed is specified by naming a previously-prepared statement, instead of giving a query string. This feature allows commands that will be used repeatedly to be parsed and planned just once, rather than each time they are executed. The statement must have been prepared previously in the current session. pg_execute() is supported only against PostgreSQL 7.4 or higher connections; it will fail when using earlier versions.

The parameters are identical to pg_query_params(), except that the name of a prepared statement is given instead of a query string.

Seznam parametrů

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

stmtname

The name of the prepared statement to execute. if "" is specified, then the unnamed statement is executed. The name must have been previously prepared using pg_prepare(), pg_send_prepare() or a PREPARE SQL command.

params

An array of parameter values to substitute for the $1, $2, etc. placeholders in the original prepared query string. The number of elements in the array must match the number of placeholders.

Varování

Elements are converted to strings by calling this function.

Návratové hodnoty

A query result resource on success, or FALSE on failure.

Příklady

Příklad 1709. Using pg_execute()

<?php
// Connect to a database named "mary"
$dbconn = pg_connect("dbname=mary");

// Prepare a query for execution
$result = pg_prepare($dbconn, "my_query", 'SELECT * FROM shops WHERE name = $1');

// Execute the prepared query.  Note that it is not necessary to escape
// the string "Joe's Widgets" in any way
$result = pg_execute($dbconn, "my_query", array("Joe's Widgets"));

// Execute the same prepared query, this time with a different parameter
$result = pg_execute($dbconn, "my_query", array("Clothes Clothes Clothes"));

?>

Viz také

pg_prepare()
pg_send_prepare()
pg_query_params()

Předcházející | Nahoru | Další
pg_escape_string | Domů | pg_fetch_all_columns


pg_fetch_all_columns

(PHP 5 >= 5.1.0)

pg_fetch_all_columns — Fetches all rows in a particular result column as an array

Popis

array pg_fetch_all_columns ( resource $result [, int $column] )

pg_fetch_all_columns() returns an array that contains all rows (records) in a particular column of the result resource.

Poznámka: Tato funkce nastavuje pole s hodnotou NULL na hodnotu PHP NULL.

Seznam parametrů

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

column

Column number, zero-based, to be retrieved from the result resource. Defaults to the first column if not specified.

Návratové hodnoty

An array with all values in the result column.

FALSE is returned if column is larger than the number of columns in the result, or on any other error.

Příklady

Příklad 1710. pg_fetch_all_columns() example

<?php
$conn = pg_pconnect("dbname=publisher");
if (!$conn) {
  echo "An error occured.\n";
  exit;
}

$result = pg_query($conn, "SELECT title, name, address FROM authors");
if (!$result) {
  echo "An error occured.\n";
  exit;
}

// Get an array of all author names
$arr = pg_fetch_all_columns($result, 1);

var_dump($arr);

?>

Viz také

pg_fetch_all()

Předcházející | Nahoru | Další
pg_execute | Domů | pg_fetch_all


pg_field_table

(PHP 5 >= 5.2.0)

pg_field_table — Returns the name or oid of the tables field

Popis

mixed pg_field_table ( resource $result, int $field_number [, bool $oid_only] )

pg_field_table() returns the name of the table that field belongs to, or the table's oid if oid_only is TRUE.

Seznam parametrů

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

field_number

Field number, starting from 0.

oid_only

By default the tables name that field belongs to is returned but if oid_only is set to TRUE, then the oid will instead be returned.

Návratové hodnoty

On success either the fields table name or oid. Or, FALSE on failure.

Příklady

Příklad 1722. Getting table information about a field

<?php
$dbconn = pg_connect("dbname=publisher") or die("Could not connect");

$res = pg_query($dbconn, "SELECT bar FROM foo");

echo pg_field_table($res, 0);
echo pg_field_table($res, 0, true);

$res = pg_query($dbconn, "SELECT version()");
var_dump(pg_field_table($res, 0));
?>

Výše uvedený příklad vypíše něco jako:

foo
14379580

bool(false)

Poznámky

Poznámka: Returning the oid is much faster than returning the table name because fetching the table name requires a query to the database system table.

Viz také

pg_field_name()
pg_field_type()

Předcházející | Nahoru | Další
pg_field_size | Domů | pg_field_type_oid


pg_field_type_oid

(PHP 5 >= 5.1.0)

pg_field_type_oid — Returns the type ID (OID) for the corresponding field number

Popis

int pg_field_type_oid ( resource $result, int $field_number )

pg_field_type_oid() returns an integer containing the OID of the base type of the given field_number in the given PostgreSQL result resource.

You can get more information about the field type by querying PostgreSQL's pg_type system table using the OID obtained with this function. The PostgreSQL format_type() function will convert a type OID into an SQL standard type name.

Poznámka: If the field uses a PostgreSQL domain (rather than a basic type), it is the OID of the domain's underlying type that is returned, rather than the OID of the domain itself.

Seznam parametrů

result

PostgreSQL query result resource, returned by pg_query(), pg_query_params() or pg_execute() (among others).

field_number

Field number, starting from 0.

Návratové hodnoty

The OID of the field's base type. FALSE is returned on error.

Příklady

Příklad 1723. Getting information about fields

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

  // Assume 'title' is a varchar type
  $res = pg_query($dbconn, "select title from authors where author = 'Orwell'");

  echo "Title field type OID: ", pg_field_type_oid($res, 0);
?>

Výše uvedený příklad vypíše:

Title field type OID: 1043

Viz také

pg_field_type()
pg_field_prtlen()
pg_field_name()

Předcházející | Nahoru | Další
pg_field_table | Domů | pg_field_type


pg_prepare

(PHP 5 >= 5.1.0)

pg_prepare — Submits a request to create a prepared statement with the given parameters, and waits for completion.

Popis

resource pg_prepare ( resource $connection, string $stmtname, string $query )
resource pg_prepare ( string $stmtname, string $query )

pg_prepare() creates a prepared statement for later execution with pg_execute() or pg_send_execute(). This feature allows commands that will be used repeatedly to be parsed and planned just once, rather than each time they are executed. pg_prepare() is supported only against PostgreSQL 7.4 or higher connections; it will fail when using earlier versions.

The function creates a prepared statement named stmtname from the query string, which must contain a single SQL command. stmtname may be "" to create an unnamed statement, in which case any pre-existing unnamed statement is automatically replaced; otherwise it is an error if the statement name is already defined in the current session. If any parameters are used, they are referred to in the query as $1, $2, etc.

Prepared statements for use with pg_prepare() can also be created by executing SQL PREPARE statements. (But pg_prepare() is more flexible since it does not require parameter types to be pre-specified.) Also, although there is no PHP function for deleting a prepared statement, the SQL DEALLOCATE statement can be used for that purpose.

Seznam parametrů

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

stmtname

The name to give the prepared statement. Must be unique per-connection. If "" is specified, then an unnamed statement is created, overwriting any previously defined unnamed statement.

query

The parameterised SQL statement. Must contain only a single statement. (multiple statements separated by semi-colons are not allowed.) If any parameters are used, they are referred to as $1, $2, etc.

Návratové hodnoty

A query result resource on success, or FALSE on failure.

Příklady

Příklad 1753. Using pg_prepare()

<?php
// Connect to a database named "mary"
$dbconn = pg_connect("dbname=mary");

// Prepare a query for execution
$result = pg_prepare($dbconn, "my_query", 'SELECT * FROM shops WHERE name = $1');

// Execute the prepared query.  Note that it is not necessary to escape
// the string "Joe's Widgets" in any way
$result = pg_execute($dbconn, "my_query", array("Joe's Widgets"));

// Execute the same prepared query, this time with a different parameter
$result = pg_execute($dbconn, "my_query", array("Clothes Clothes Clothes"));

?>

Viz také

pg_execute()
pg_send_execute()

Předcházející | Nahoru | Další
pg_port | Domů | pg_put_line


pg_query_params

(PHP 5 >= 5.1.0)

pg_query_params — Submits a command to the server and waits for the result, with the ability to pass parameters separately from the SQL command text.

Popis

resource pg_query_params ( resource $connection, string $query, array $params )
resource pg_query_params ( string $query, array $params )

Submits a command to the server and waits for the result, with the ability to pass parameters separately from the SQL command text.

pg_query_params() is like pg_query(), but offers additional functionality: parameter values can be specified separately from the command string proper. pg_query_params() is supported only against PostgreSQL 7.4 or higher connections; it will fail when using earlier versions.

If parameters are used, they are referred to in the query string as $1, $2, etc. params specifies the actual values of the parameters. A NULL value in this array means the corresponding parameter is SQL NULL.

The primary advantage of pg_query_params() over pg_query() is that parameter values may be separated from the query string, thus avoiding the need for tedious and error-prone quoting and escaping. Unlike pg_query(), pg_query_params() allows at most one SQL command in the given string. (There can be semicolons in it, but not more than one nonempty command.)

Seznam parametrů

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

query

The parameterised SQL statement. Must contain only a single statement. (multiple statements separated by semi-colons are not allowed.) If any parameters are used, they are referred to as $1, $2, etc.

params

An array of parameter values to substitute for the $1, $2, etc. placeholders in the original prepared query string. The number of elements in the array must match the number of placeholders.

Návratové hodnoty

A query result resource on success, or FALSE on failure.

Příklady

Příklad 1755. Using pg_query_params()

<?php
// Connect to a database named "mary"
$dbconn = pg_connect("dbname=mary");

// Find all shops named Joe's Widgets.  Note that it is not necessary to
// escape "Joe's Widgets"
$result = pg_query_params($dbconn, 'SELECT * FROM shops WHERE name = $1', array("Joe's Widgets"));

// Compare against just using pg_query
$str = pg_escape_string("Joe's Widgets");
$result = pg_query($dbconn, "SELECT * FROM shops WHERE name = '{$str}'");

?>

Viz také

pg_query()

Předcházející | Nahoru | Další
pg_put_line | Domů | pg_query


pg_result_error_field

(PHP 5 >= 5.1.0)

pg_result_error_field — Returns an individual field of an error report.

Popis

string pg_result_error_field ( resource $result, int $fieldcode )

pg_result_error_field() returns one of the detailed error message fields associated with result resource. It is only available against a PostgreSQL 7.4 or above server. The error field is specified by the fieldcode.

Because pg_query() and pg_query_params() return FALSE if the query fails, you must use pg_send_query() and pg_get_result() to get the result handle.

If you need to get additional error information from failed pg_query() queries, use pg_set_error_verbosity() and pg_last_error() and then parse the result.

Seznam parametrů

result

A PostgreSQL query result resource from a previously executed statement.

fieldcode

Possible fieldcode values are: PGSQL_DIAG_SEVERITY, PGSQL_DIAG_SQLSTATE, PGSQL_DIAG_MESSAGE_PRIMARY, PGSQL_DIAG_MESSAGE_DETAIL, PGSQL_DIAG_MESSAGE_HINT, PGSQL_DIAG_STATEMENT_POSITION, PGSQL_DIAG_INTERNAL_POSITION (PostgreSQL 8.0+ only), PGSQL_DIAG_INTERNAL_QUERY (PostgreSQL 8.0+ only), PGSQL_DIAG_CONTEXT, PGSQL_DIAG_SOURCE_FILE, PGSQL_DIAG_SOURCE_LINE or PGSQL_DIAG_SOURCE_FUNCTION.

Návratové hodnoty

A string containing the contents of the error field, NULL if the field does not exist or FALSE on failure.

Příklady

Příklad 1758. pg_result_error_field() example

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

  if (!pg_connection_busy($dbconn)) {
      pg_send_query($dbconn, "select * from doesnotexist;");
  }

  $res1 = pg_get_result($dbconn);
  echo pg_result_error_field($res1, PGSQL_DIAG_SQLSTATE);
?>

Viz také

pg_result_error()

Předcházející | Nahoru | Další
pg_query | Domů | pg_result_error


pg_send_execute

(PHP 5 >= 5.1.0)

pg_send_execute — Sends a request to execute a prepared statement with given parameters, without waiting for the result(s).

Popis

bool pg_send_execute ( resource $connection, string $stmtname, array $params )

Sends a request to execute a prepared statement with given parameters, without waiting for the result(s).

This is similar to pg_send_query_params(), but the command to be executed is specified by naming a previously-prepared statement, instead of giving a query string. The function's parameters are handled identically to pg_execute(). Like pg_execute(), it will not work on pre-7.4 versions of PostgreSQL.

Seznam parametrů

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

stmtname

The name of the prepared statement to execute. if "" is specified, then the unnamed statement is executed. The name must have been previously prepared using pg_prepare(), pg_send_prepare() or a PREPARE SQL command.

params

An array of parameter values to substitute for the $1, $2, etc. placeholders in the original prepared query string. The number of elements in the array must match the number of placeholders.

Návratové hodnoty

Returns TRUE on success, FALSE on failure. Use pg_get_result() to determine the query result.

Příklady

Příklad 1763. Using pg_send_execute()

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

  // Prepare a query for execution
  if (!pg_connection_busy($dbconn)) {
    pg_send_prepare($dbconn, "my_query", 'SELECT * FROM shops WHERE name = $1');
    $res1 = pg_get_result($dbconn);
  }

  // Execute the prepared query.  Note that it is not necessary to escape
  // the string "Joe's Widgets" in any way
  if (!pg_connection_busy($dbconn)) {
    pg_send_execute($dbconn, "my_query", array("Joe's Widgets"));
    $res2 = pg_get_result($dbconn);
  }

  // Execute the same prepared query, this time with a different parameter
  if (!pg_connection_busy($dbconn)) {
    pg_send_execute($dbconn, "my_query", array("Clothes Clothes Clothes"));
    $res3 = pg_get_result($dbconn);
  }

?>

Viz také

pg_prepare()
pg_send_prepare()
pg_execute()

Předcházející | Nahoru | Další
pg_select | Domů | pg_send_prepare


pg_send_prepare

(PHP 5 >= 5.1.0)

pg_send_prepare — Sends a request to create a prepared statement with the given parameters, without waiting for completion.

Popis

bool pg_send_prepare ( resource $connection, string $stmtname, string $query )

Sends a request to create a prepared statement with the given parameters, without waiting for completion.

This is an asynchronous version of pg_prepare(): it returns TRUE if it was able to dispatch the request, and FALSE if not. After a successful call, call pg_get_result() to determine whether the server successfully created the prepared statement. The function's parameters are handled identically to pg_prepare(). Like pg_prepare(), it will not work on pre-7.4 versions of PostgreSQL.

Seznam parametrů

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

stmtname

The name to give the prepared statement. Must be unique per-connection. If "" is specified, then an unnamed statement is created, overwriting any previously defined unnamed statement.

query

The parameterised SQL statement. Must contain only a single statement. (multiple statements separated by semi-colons are not allowed.) If any parameters are used, they are referred to as $1, $2, etc.

Návratové hodnoty

Returns TRUE on success, FALSE on failure. Use pg_get_result() to determine the query result.

Příklady

Příklad 1764. Using pg_send_prepare()

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

  // Prepare a query for execution
  if (!pg_connection_busy($dbconn)) {
    pg_send_prepare($dbconn, "my_query", 'SELECT * FROM shops WHERE name = $1');
    $res1 = pg_get_result($dbconn);
  }

  // Execute the prepared query.  Note that it is not necessary to escape
  // the string "Joe's Widgets" in any way
  if (!pg_connection_busy($dbconn)) {
    pg_send_execute($dbconn, "my_query", array("Joe's Widgets"));
    $res2 = pg_get_result($dbconn);
  }

  // Execute the same prepared query, this time with a different parameter
  if (!pg_connection_busy($dbconn)) {
    pg_send_execute($dbconn, "my_query", array("Clothes Clothes Clothes"));
    $res3 = pg_get_result($dbconn);
  }

?>

Viz také

pg_connect()
pg_pconnect()
pg_execute()
pg_send_execute()
pg_send_query_params()

Předcházející | Nahoru | Další
pg_send_execute | Domů | pg_send_query_params


pg_send_query_params

(PHP 5 >= 5.1.0)

pg_send_query_params — Submits a command and separate parameters to the server without waiting for the result(s).

Popis

bool pg_send_query_params ( resource $connection, string $query, array $params )

Submits a command and separate parameters to the server without waiting for the result(s).

This is equivalent to pg_send_query() except that query parameters can be specified separately from the query string. The function's parameters are handled identically to pg_query_params(). Like pg_query_params(), it will not work on pre-7.4 PostgreSQL connections, and it allows only one command in the query string.

Seznam parametrů

connection

PostgreSQL database connection resource.

query

The parameterised SQL statement. Must contain only a single statement. (multiple statements separated by semi-colons are not allowed.) If any parameters are used, they are referred to as $1, $2, etc.

params

An array of parameter values to substitute for the $1, $2, etc. placeholders in the original prepared query string. The number of elements in the array must match the number of placeholders.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Use pg_get_result() to determine the query result.

Příklady

Příklad 1765. Using pg_send_query_params()

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

  // Using parameters.  Note that it is not necessary to quote or escape
  // the parameter.
  pg_send_query_params($dbconn, 'select count(*) from authors where city = $1', array('Perth'));

  // Compare against basic pg_send_query usage
  $str = pg_escape_string('Perth');
  pg_send_query($dbconn, "select count(*) from authors where city = '${str}'");
?>

Viz také

pg_send_query()

Předcházející | Nahoru | Další
pg_send_prepare | Domů | pg_send_query


pg_set_error_verbosity

(PHP 5 >= 5.1.0)

pg_set_error_verbosity — Determines the verbosity of messages returned by pg_last_error() and pg_result_error().

Popis

int pg_set_error_verbosity ( resource $connection, int $verbosity )
int pg_set_error_verbosity ( int $verbosity )

Determines the verbosity of messages returned by pg_last_error() and pg_result_error().

pg_set_error_verbosity() sets the verbosity mode, returning the connection's previous setting. In PGSQL_ERRORS_TERSE mode, returned messages include severity, primary text, and position only; this will normally fit on a single line. The default mode (PGSQL_ERRORS_DEFAULT) produces messages that include the above plus any detail, hint, or context fields (these may span multiple lines). The PGSQL_ERRORS_VERBOSE mode includes all available fields. Changing the verbosity does not affect the messages available from already-existing result objects, only subsequently-created ones.

Seznam parametrů

connection

PostgreSQL database connection resource. When connection is not present, the default connection is used. The default connection is the last connection made by pg_connect() or pg_pconnect().

verbosity

The required verbosity: PGSQL_ERRORS_TERSE, PGSQL_ERRORS_DEFAULT or PGSQL_ERRORS_VERBOSE.

Návratové hodnoty

The previous verbosity level: PGSQL_ERRORS_TERSE, PGSQL_ERRORS_DEFAULT or PGSQL_ERRORS_VERBOSE.

Příklady

Příklad 1768. pg_set_error_verbosity() example

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");

  if (!pg_connection_busy($dbconn)) {
      pg_send_query($dbconn, "select * from doesnotexist;");
  }

  pg_set_error_verbosity($dbconn, PGSQL_ERRORS_VERBOSE);
  $res1 = pg_get_result($dbconn);
  echo pg_result_error($res1);
?>

Viz také

pg_last_error()
pg_result_error()

Předcházející | Nahoru | Další
pg_set_client_encoding | Domů | pg_trace


pg_transaction_status

(PHP 5 >= 5.1.0)

pg_transaction_status — Returns the current in-transaction status of the server.

Popis

int pg_transaction_status ( resource $connection )

Returns the current in-transaction status of the server.

Výstraha

pg_transaction_status() will give incorrect results when using a PostgreSQL 7.3 server that has the parameter autocommit set to off. The server-side autocommit feature has been deprecated and does not exist in later server versions.

Seznam parametrů

connection

PostgreSQL database connection resource.

Návratové hodnoty

The status can be PGSQL_TRANSACTION_IDLE (currently idle), PGSQL_TRANSACTION_ACTIVE (a command is in progress), PGSQL_TRANSACTION_INTRANS (idle, in a valid transaction block), or PGSQL_TRANSACTION_INERROR (idle, in a failed transaction block). PGSQL_TRANSACTION_UNKNOWN is reported if the connection is bad. PGSQL_TRANSACTION_ACTIVE is reported only when a query has been sent to the server and not yet completed.

Příklady

Příklad 1770. pg_transaction_status() example

<?php
  $dbconn = pg_connect("dbname=publisher") or die("Could not connect");
  $stat = pg_transaction_status($dbconn);
  if ($stat === PGSQL_TRANSACTION_UNKNOWN) {
      echo 'Connection is bad';
  } else if ($stat === PGSQL_TRANSACTION_IDLE) {
      echo 'Connection is currently idle';
  } else {
      echo 'Connection is in a transaction state';
  }
?>

Předcházející | Nahoru | Další
pg_trace | Domů | pg_tty


Phar::apiVersion

(PECL phar:1.0.0-1.2.1)

Phar::apiVersion — Returns the api version

Popis

string Phar::apiVersion ( void )

Return the API version of the phar file format that will be used when creating phars. The Phar extension supports reading API version 1.0.0 or newer.

Seznam parametrů

Návratové hodnoty

The API version string as in "1.0.0".

Příklady

Příklad 1600. A Phar::apiVersion() example

<?php
echo Phar::apiVersion();
?>

Výše uvedený příklad vypíše:

1.0.0

Předcházející | Nahoru | Další
CXXIII. Phar archive stream and classes | Domů | Phar::canCompress


Phar::canCompress

(PECL phar:1.0.0-1.2.1)

Phar::canCompress — Returns whether phar extension supports compression using either zlib or bzip2

Popis

bool Phar::canCompress ( [int $type] )

This should be used to test whether compression is possible prior to loading a phar archive containing compressed files.

Seznam parametrů

type

Either Phar::GZ or Phar::BZ2 can be used to test whether compression is possible with a specific compression algorithm (zlib or bzip2).

Návratové hodnoty

TRUE if compression/decompression is available, FALSE if not.

Příklady

Příklad 1601. A Phar::canCompress() example

<?php
if (Phar::canCompress()) {
    echo file_get_contents('phar://compressedphar.phar/internal/file.txt');
} else {
    echo 'no compression available';
}
?>

Viz také

PharFileInfo::isCompressed()

Předcházející | Nahoru | Další
Phar::apiVersion | Domů | Phar::canWrite


Phar::canWrite

(PECL phar:1.0.0-1.2.1)

Phar::canWrite — Returns whether phar extension supports writing and creating phars

Popis

bool Phar::canWrite ( void )

This method determines whether write access has been disabled in the system php.ini via the phar.readonly ini variable.

Seznam parametrů

Návratové hodnoty

TRUE if write access is enabled, FALSE if it is disabled.

Příklady

Příklad 1602. A Phar::canWrite() example

<?php
if (Phar::canWrite()) {
    file_put_contents('phar://myphar.phar/file.txt', 'hi there');
}
?>

Viz také

phar.readonly

Předcházející | Nahoru | Další
Phar::canCompress | Domů | Phar->compressAllFilesBZIP2


Phar->compressAllFilesBZIP2

(PECL phar:1.0.0-1.2.1)

Phar->compressAllFilesBZIP2 — Compresses all files in the current Phar archive using Bzip2 compression

Popis

bool Phar->compressAllFilesBZIP2 ( void )

This method compresses all files in the Phar archive using bzip2 compression. The bzip2 extension must be enabled to take advantage of this feature. In addition, if any files are already compressed using gzip compression, the zlib extension must be enabled in order to decompress the files prior to re-compressing with bzip2 compression. As with all functionality that modifies the contents of a phar, the phar.readonly INI variable must be off in order to succeed.

Errors/Exceptions

Throws BadMethodCallException if the phar.readonly INI variable is on, the bzip2 extension is not available, or if any files are compressed using gzip compression and the zlib extension is not enabled.

Příklady

Příklad 1603. A Phar->compressAllFilesBZIP2() example

<?php
$p = new Phar('/path/to/my.phar', 0, 'my.phar');
$p['myfile.txt'] = 'hi';
$p['myfile2.txt'] = 'hi';
foreach ($p as $file) {
    var_dump($file->getFileName());
    var_dump($file->isCompressed());
    var_dump($file->isCompressedBZIP2());
    var_dump($file->isCompressedGZ());
}
$p->compressAllFilesBZIP2();
foreach ($p as $file) {
    var_dump($file->getFileName());
    var_dump($file->isCompressed());
    var_dump($file->isCompressedBZIP2());
    var_dump($file->isCompressedGZ());
}
?>

Výše uvedený příklad vypíše:

string(10) "myfile.txt"
bool(false)
bool(false)
bool(false)
string(11) "myfile2.txt"
bool(false)
bool(false)
bool(false)
string(10) "myfile.txt"
bool(true)
bool(true)
bool(false)
string(11) "myfile2.txt"
bool(true)
bool(true)
bool(false)

Viz také

PharFileInfo->isCompressedGZ()
PharFileInfo->isCompressed()
PharFileInfo->isCompressedGZ()
PharFileInfo->isCompressed()
Phar->uncompressAllFiles()
Phar->compressAllFilesGZ()

Předcházející | Nahoru | Další
Phar::canWrite | Domů | Phar->compressAllFilesGZ


Phar->compressAllFilesGZ

(PECL phar:1.0.0-1.2.1)

Phar->compressAllFilesGZ — Compresses all files in the current Phar archive using Gzip compression

Popis

bool Phar->compressAllFilesGZ ( void )

This method compresses all files in the Phar archive using gzip compression. The zlib extension must be enabled to take advantage of this feature. In addition, if any files are already compressed using bzip2 compression, the bzip2 extension must be enabled in order to decompress the files prior to re-compressing with gzip compression. As with all functionality that modifies the contents of a phar, the phar.readonly INI variable must be off in order to succeed.

Errors/Exceptions

Throws BadMethodCallException if the phar.readonly INI variable is on, the zlib extension is not available, or if any files are compressed using bzip2 compression and the bzip2 extension is not enabled.

Příklady

Příklad 1604. A Phar->compressAllFilesGZ() example

<?php
$p = new Phar('/path/to/my.phar', 0, 'my.phar');
$p['myfile.txt'] = 'hi';
$p['myfile2.txt'] = 'hi';
foreach ($p as $file) {
    var_dump($file->getFileName());
    var_dump($file->isCompressed());
    var_dump($file->isCompressedBZIP2());
    var_dump($file->isCompressedGZ());
}
$p->compressAllFilesGZ();
foreach ($p as $file) {
    var_dump($file->getFileName());
    var_dump($file->isCompressed());
    var_dump($file->isCompressedBZIP2());
    var_dump($file->isCompressedGZ());
}
?>

Výše uvedený příklad vypíše:

string(10) "myfile.txt"
bool(false)
bool(false)
bool(false)
string(11) "myfile2.txt"
bool(false)
bool(false)
bool(false)
string(10) "myfile.txt"
bool(true)
bool(false)
bool(true)
string(11) "myfile2.txt"
bool(true)
bool(false)
bool(true)

Viz také

PharFileInfo->getCompressedSize()
PharFileInfo->isCompressedGZ()
PharFileInfo->isCompressed()
PharFileInfo->isCompressedGZ()
PharFileInfo->isCompressed()
Phar->uncompressAllFiles()
Phar->compressAllFilesBZIP2()

Předcházející | Nahoru | Další
Phar->compressAllFilesBZIP2 | Domů | Phar::__construct


Phar::__construct

(PECL phar:1.0.0-1.2.1)

Phar::__construct — Construct a Phar archive object

Popis

void Phar::__construct ( string $fname [, int $flags [, string $alias]] )

Seznam parametrů

fname

Path to an existing Phar archive

flags

flags to pass to parent class RecursiveDirectoryIterator. See » SPL RecursiveDirectoryIterator docs

alias

Alias with which this Phar archive should be referred to in calls to stream functionality.

Errors/Exceptions

Throws BadMethodCallException if called twice, UnexpectedValueException if the phar archive can't be opened.

Příklady

Příklad 1605. A Phar::__construct() example

<?php
try {
    $p = new Phar('/path/to/my.phar', CURRENT_AS_FILEINFO | KEY_AS_FILENAME,
                  'my.phar');
} catch (UnexpectedValueException $e) {
    die('Could not open my.phar');
} catch (BadMethodCallException $e) {
    echo 'technically, this cannot happen';
}
// this works now
echo file_get_contents('phar://my.phar/example.txt');
// and works as if we had typed
echo file_get_contents('phar:///path/to/my.phar/example.txt');
?>

Předcházející | Nahoru | Další
Phar->compressAllFilesGZ | Domů | Phar->count


Phar->count

(PECL phar:1.0.0-1.2.1)

Phar->count — Returns the number of entries (files) in the Phar archive

Popis

int Phar->count ( void )

Seznam parametrů

Návratové hodnoty

The number of files contained within this phar, or 0 (the number zero) if none.

Příklady

Příklad 1606. A Phar->count() example

<?php
// make sure it doesn't exist
@unlink('brandnewphar.phar');
try {
    $p = new Phar(dirname(__FILE__) . '/brandnewphar.phar', 0, 'brandnewphar.phar');
} catch (Exception $e) {
    echo 'Could not create phar:', $e;
}
echo 'The new phar has ' . $p->count() . " entries\n";
$p['file.txt'] = 'hi';
echo 'The new phar has ' . $p->count() . " entries\n";
?>

Výše uvedený příklad vypíše:

The new phar has 0 entries
The new phar has 1 entries

Předcházející | Nahoru | Další
Phar::__construct | Domů | Phar->getMetaData


Phar->getMetaData

(PECL phar:1.0.0-1.2.1)

Phar->getMetaData — Returns phar archive meta-data

Popis

int Phar->getMetaData ( void )

Seznam parametrů

Návratové hodnoty

any PHP variable that can be serialized and is stored as meta-data for the Phar archive, or NULL if no meta-data is stored.

Příklady

Příklad 1607. A Phar->getMetaData() example

<?php
// make sure it doesn't exist
@unlink('brandnewphar.phar');
try {
    $p = new Phar(dirname(__FILE__) . '/brandnewphar.phar', 0, 'brandnewphar.phar');
} catch (Exception $e) {
    echo 'Could not create phar:', $e;
}
$p['file.php'] = '<?php echo "hello";';
$p->setMetaData(array('bootstrap' => 'file.php'));
var_dump($p->getMetaData());
?>

Výše uvedený příklad vypíše:

array(1) {
  ["bootstrap"]=>
  string(8) "file.php"
}

Viz také

PharFileInfo->setMetaData()

Předcházející | Nahoru | Další
Phar->count | Domů | Phar->getModified


Phar->getModified

(PECL phar:1.0.0-1.2.1)

Phar->getModified — Return whether phar was modified

Popis

bool Phar->getModified ( void )

This method can be used to determine whether a phar has either had an internal file deleted, or contents of a file changed in some way.

Seznam parametrů

Návratové hodnoty

TRUE if the phar has been modified since opened, FALSE if not.

Předcházející | Nahoru | Další
Phar->getMetaData | Domů | Phar->getSignature


Phar->getSignature

(PECL phar:1.0.0-1.2.1)

Phar->getSignature — Return MD5/SHA1 signature of a Phar archive

Popis

array Phar->getSignature ( void )

Returns the verification signature of a phar archive in a hexadecimal string.

Seznam parametrů

Návratové hodnoty

Array with the opened archive's signature in "hash" key and "md5" or "sha1" in "hash_type". This signature is a hash calculated on the entire phar's contents, and may be used to verify the integrity of the archive. A valid signature is absolutely required of all phars if the phar.require_hash INI variable is set to true.

Předcházející | Nahoru | Další
Phar->getModified | Domů | Phar->getStub


Phar->getStub

(PECL phar:1.0.0-1.2.1)

Phar->getStub — Return the PHP loader or bootstrap stub of a Phar archive

Popis

string Phar->getStub ( void )

One of the features that differentiates a Phar archive from other familiar archive formats like tar or zip is that a Phar archive is explicitly designed to be included to allow distributing an application or library that can be run without extraction directly from the archive. In order to accomplish this, Phar archives contain a bootstrap loader, or stub written in PHP that can perform any action.

Varování

All stubs must end with __HALT_COMPILER(); or the file is not a valid Phar archive.

Návratové hodnoty

Returns a string containing the contents of the bootstrap loader (stub) of the current Phar archive.

Errors/Exceptions

Throws RuntimeException if it is not possible to read the stub from the Phar archive.

Příklady

Příklad 1608. A Phar->getStub() example

$p = new Phar('/path/to/my.phar', 0, 'my.phar');
echo $p->getStub();
echo "==NEXT==\n";
$p->setStub("<?php
function __autoload($class)
{
    include 'phar://' . str_replace('_', '/', $class);
}
Phar::mapPhar('myphar.phar');
include 'phar://myphar.phar/startup.php';
__HALT_COMPILER();");
echo $p->getStub();

Výše uvedený příklad vypíše:

<?php __HALT_COMPILER();
==NEXT==
<?php
function __autoload($class)
{
    include 'phar://' . str_replace('_', '/', $class);
}
Phar::mapPhar('myphar.phar');
include 'phar://myphar.phar/startup.php';
__HALT_COMPILER();

Viz také

Phar->setStub()

Předcházející | Nahoru | Další
Phar->getSignature | Domů | Phar->getVersion


Phar->getVersion

(PECL phar:1.0.0-1.2.1)

Phar->getVersion — Return version info of Phar archive

Popis

string Phar->getVersion ( void )

Returns the API version of an opened Phar archive.

Seznam parametrů

Návratové hodnoty

The opened archive's API version. This is not to be confused with the API version that the loaded phar extension will use to create new phars. Each Phar archive has the API version hard-coded into its manifest. See Phar file format documentation for more information.

Viz také

Phar::apiVersion()

Předcházející | Nahoru | Další
Phar->getStub | Domů | Phar->isBuffering


Phar->isBuffering

(PECL phar:1.0.0-1.2.1)

Phar->isBuffering — Used to determine whether Phar write operations are being buffered, or are flushing directly to disk

Popis

bool Phar->isBuffering ( void )

This method can be used to determine whether a Phar will save changes to disk immediately, or whether a call to Phar->stopBuffering() is needed to enable saving changes.

Phar write buffering is per-archive, buffering active for the foo.phar Phar archive does not affect changes to the bar.phar Phar archive.

Příklady

Příklad 1609. A Phar->isBuffering() example

<?php
$p = new Phar(dirname(__FILE__) . '/brandnewphar.phar', 0, 'brandnewphar.phar');
$p2 = new Phar('existingphar.phar');
$p['file1.txt'] = 'hi';
var_dump($p->isBuffering());
var_dump($p2->isBuffering());
?>
=2=
<?php
$p->startBuffering();
var_dump($p->isBuffering());
var_dump($p2->isBuffering());
$p->stopBuffering();
?>
=3=
<?php
var_dump($p->isBuffering());
var_dump($p2->isBuffering());
?>

Výše uvedený příklad vypíše:

bool(false)
bool(false)
=2=
bool(true)
bool(false)
=3=
bool(false)
bool(false)

Viz také

Phar->startBuffering()
Phar->stopBuffering()

Předcházející | Nahoru | Další
Phar->getVersion | Domů | Phar::loadPhar


Phar::loadPhar

(PECL phar:1.0.0-1.2.1)

Phar::loadPhar — Loads any phar archive with an alias

Popis

mixed Phar::loadPhar ( string $filename [, string $alias] )

This can be used to read the contents of an external Phar archive. This is most useful for assigning an alias to a phar so that subsequent references to the phar can use the shorter alias, or for loading Phar archives that only contain data and are not intended for execution/inclusion in PHP scripts.

Seznam parametrů

filename

the full or relative path to the phar archive to open

alias

The alias that may be used to refer to the phar archive. Note that many phar archives specify an explicit alias inside the phar archive, and a PharException will be thrown if a new alias is specified in this case.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Errors/Exceptions

PharException is thrown if an alias is passed in and the phar archive already has an explicit alias

Příklady

Příklad 1610. A Phar::loadPhar() example

Phar::loadPhar can be used anywhere to load an external Phar archive, whereas Phar::mapPhar should be used in a loader stub for a Phar.

<?php
try {
    Phar::loadPhar('/path/to/phar.phar', 'my.phar');
    echo file_get_contents('phar://my.phar/file.txt');
} catch (PharException $e) {
    echo $e;
}
?>

Viz také

Phar::mapPhar()

Předcházející | Nahoru | Další
Phar->isBuffering | Domů | Phar::mapPhar


Phar::mapPhar

(PECL phar:1.0.0-1.2.1)

Phar::mapPhar — Reads the currently executed file (a phar) and registers its manifest

Popis

mixed Phar::mapPhar ( [string $alias [, int $dataoffset]] )

This static method can only be used inside a Phar archive's loader stub in order to initialize the phar when it is directly executed, or when it is included in another script.

Seznam parametrů

alias

The alias with which this phar should be referred to.

dataoffset

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Errors/Exceptions

PharException is thrown if not called directly within PHP execution, if no __HALT_COMPILER(); token is found in the current source file, or if the file cannot be opened for reading.

Příklady

Příklad 1611. A Phar::mapPhar() example

mapPhar should be used only inside a phar's loader stub. Use loadPhar to load an external phar into memory.

Here is a sample Phar loader stub that uses mapPhar.

<?php
function __autoload($class)
{
    include 'phar://me.phar/' . str_replace('_', '/', $class) . '.php';
}
try {
    Phar::mapPhar('me.phar');
    include 'phar://me.phar/startup.php';
} catch (PharException $e) {
    echo $e->getMessage();
    die('Cannot initialize Phar');
}
__HALT_COMPILER();

Viz také

Phar::loadPhar()

Předcházející | Nahoru | Další
Phar::loadPhar | Domů | Phar::offsetExists


Phar::offsetExists

(PECL phar:1.0.0-1.2.1)

Phar::offsetExists — determines whether a file exists in the phar

Popis

bool Phar::offsetExists ( string $offset )

This is an implementation of the ArrayAccess interface allowing direct manipulation of the contents of a Phar archive using array access brackets.

offsetExists() is called whenever isset() is called.

Seznam parametrů

offset

The filename (relative path) to look for in a Phar.

Návratové hodnoty

Returns TRUE if the file exists within the phar, or FALSE if not.

Příklady

Příklad 1612. A Phar::offsetExists() example

<?php
$p = new Phar(dirname(__FILE__) . '/my.phar', 0, 'my.phar');
$p['firstfile.txt'] = 'first file';
$p['secondfile.txt'] = 'second file';
// the next set of lines call offsetExists() indirectly
var_dump(isset($p['firstfile.txt']));
var_dump(isset($p['nothere.txt']));
?>

Výše uvedený příklad vypíše:

bool(true)
bool(false)

Viz také

Phar::offsetGet()
Phar::offsetSet()
Phar::offsetUnset()

Předcházející | Nahoru | Další
Phar::mapPhar | Domů | Phar::offsetGet


Phar::offsetGet

(PECL phar:1.0.0-1.2.1)

Phar::offsetGet — get a PharFileInfo object for a specific file

Popis

int Phar::offsetGet ( string $offset )

This is an implementation of the ArrayAccess interface allowing direct manipulation of the contents of a Phar archive using array access brackets. offsetGet is used for retrieving files from a Phar archive.

Seznam parametrů

offset

The filename (relative path) to look for in a Phar.

Návratové hodnoty

A PharFileInfo object is returned that can be used to iterate over a file's contents or to retrieve information about the current file.

Errors/Exceptions

This method throws BadMethodCallException if the file does not exist in the Phar archive.

Příklady

Příklad 1613. A Phar::offsetGet() example

As with all classes that implement the ArrayAccess interface, offsetGet is automatically called when using the [] angle bracket operator

<?php
$p = new Phar(dirname(__FILE__) . '/myphar.phar', 0, 'myphar.phar');
$p['exists.txt'] = "file exists\n";
try {
    // automatically calls offsetGet()
    echo $p['exists.txt'];
    echo $p['doesnotexist.txt'];
} catch (BadMethodCallException $e) {
    echo $e;
}
?>

Výše uvedený příklad vypíše:

file exists
Entry doesnotexist.txt does not exist

Viz také

Phar::offsetExists()
Phar::offsetSet()
Phar::offsetUnset()

Předcházející | Nahoru | Další
Phar::offsetExists | Domů | Phar::offsetSet


Phar::offsetSet

(PECL phar:1.0.0-1.2.1)

Phar::offsetSet — set the contents of an internal file to those of an external file

Popis

void Phar::offsetSet ( string $offset, string $value )

This is an implementation of the ArrayAccess interface allowing direct manipulation of the contents of a Phar archive using array access brackets. offsetSet is used for modifying an existing file, or adding a new file to a Phar archive.

Seznam parametrů

offset

The filename (relative path) to modify in a Phar.

value

Content of the file.

Návratové hodnoty

No return values.

Errors/Exceptions

if phar.readonly is 1, BadMethodCallException is thrown, as modifying a Phar is only allowed when phar.readonly is set to 0. Throws PharException if there are any problems flushing changes made to the Phar archive to disk.

Příklady

Příklad 1614. A Phar::offsetSet() example

offsetSet should not be accessed directly, but instead used via array access with the [] operator.

<?php
$p = new Phar('/path/to/my.phar', 0, 'my.phar');
try {
    // calls offsetSet
    $p['file.txt'] = 'Hi there';
} catch (Exception $e) {
    echo 'Could not modify file.txt:', $e;
}
?>

Viz také

Phar::offsetExists()
Phar::offsetGet()
Phar::offsetUnset()

Předcházející | Nahoru | Další
Phar::offsetGet | Domů | Phar::offsetUnset


Phar::offsetUnset

(PECL phar:1.0.0-1.2.1)

Phar::offsetUnset — remove a file from a phar

Popis

bool Phar::offsetUnset ( string $offset )

This is an implementation of the ArrayAccess interface allowing direct manipulation of the contents of a Phar archive using array access brackets. offsetUnset is used for deleting an existing file, and is called by the unset() language construct.

Seznam parametrů

offset

The filename (relative path) to modify in a Phar.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Errors/Exceptions

if phar.readonly is 1, BadMethodCallException is thrown, as modifying a Phar is only allowed when phar.readonly is set to 0. Throws PharException if there are any problems flushing changes made to the Phar archive to disk.

Příklady

Příklad 1615. A Phar::offsetUnset() example

<?php
$p = new Phar('/path/to/my.phar', 0, 'my.phar');
try {
    // deletes file.txt from my.phar by calling offsetUnset
    unset($p['file.txt']);
} catch (Exception $e) {
    echo 'Could not delete file.txt: ', $e;
}
?>

Viz také

Phar::offsetExists()
Phar::offsetGet()
Phar::offsetSet()

Předcházející | Nahoru | Další
Phar::offsetSet | Domů | Phar->setMetaData


Phar->setMetaData

(PECL phar:1.0.0-1.2.1)

Phar->setMetaData — Sets phar archive meta-data

Popis

void Phar->setMetaData ( mixed $metadata )

setMetaData() should only be used to store customized data that describes something about the phar archive as a complete entity. PharFileInfo->setMetaData() should be used for file-specific meta-data. Meta-data can significantly slow down the performance of loading a phar archive if the data is large. As with all functionality that modifies the contents of a phar, the phar.readonly INI variable must be off in order to succeed.

Some possible uses for meta-data include specifying which file within the archive should be used to bootstrap the archive, or the location of a file manifest like » PEAR's package.xml file. However, any useful data that describes the phar archive may be stored.

Seznam parametrů

metadata

Any PHP variable containing information to store that describes the phar archive

Příklady

Příklad 1616. A Phar->setMetaData() example

<?php
// make sure it doesn't exist
@unlink('brandnewphar.phar');
try {
    $p = new Phar(dirname(__FILE__) . '/brandnewphar.phar', 0, 'brandnewphar.phar');
    $p['file.php'] = '<?php echo "hello"';
    $p->setMetaData(array('bootstrap' => 'file.php'));
    var_dump($p->getMetaData());
} catch (Exception $e) {
    echo 'Could not create and/or modify phar:', $e;
}
?>

Výše uvedený příklad vypíše:

array(1) {
  ["bootstrap"]=>
  string(8) "file.php"
}

Viz také

Phar->getMetaData()

Předcházející | Nahoru | Další
Phar::offsetUnset | Domů | Phar->setStub


Phar->setStub

(PECL phar:1.0.0-1.2.1)

Phar->setStub — Used to set the PHP loader or bootstrap stub of a Phar archive

Popis

void Phar->setStub ( string $stub )

This method is used to add a PHP bootstrap loader stub to a new Phar archive, or to replace the loader stub in an existing Phar archive.

The loader stub for a Phar archive is used whenever an archive is included directly as in this example:

<?php
include 'myphar.phar';
?>

The loader is not accessed when including a file through the phar stream wrapper like so:

<?php
include 'phar://myphar.phar/somefile.php';
?>

Errors/Exceptions

UnexpectedValueException is thrown if phar.readonly is enabled in php.ini. PharException is thrown if any problems are encountered flushing changes to disk.

Příklady

Příklad 1617. A Phar->setStub() example

<?php
try {
    $p = new Phar(dirname(__FILE__) . '/brandnewphar.phar', 0, 'brandnewphar.phar');
    $p['a.php'] = '<?php var_dump("Hello");';
    $p->setStub('<?php var_dump("First"); Phar::mapPhar("brandnewphar.phar"); __HALT_COMPILER(); ?>');
    include 'phar://brandnewphar.phar/a.php';
    var_dump($p->getStub());
    $p['b.php'] = '<?php var_dump("World");';
    $p->setStub('<?php var_dump("Second"); Phar::mapPhar("brandnewphar.phar"); __HALT_COMPILER(); ?>');
    include 'phar://brandnewphar.phar/b.php';
    var_dump($p->getStub());
} catch (Exception $e) {
    echo 'Write operations failed on brandnewphar.phar: ', $e;
}
?>

Výše uvedený příklad vypíše:

string(5) "Hello"
string(82) "<?php var_dump("First"); Phar::mapPhar("brandnewphar.phar"); __HALT_COMPILER(); ?>"
string(5) "World"
string(83) "<?php var_dump("Second"); Phar::mapPhar("brandnewphar.phar"); __HALT_COMPILER(); ?>"

Viz také

Phar->getStub()

Předcházející | Nahoru | Další
Phar->setMetaData | Domů | Phar->startBuffering


Phar->startBuffering

(PECL phar:1.0.0-1.2.1)

Phar->startBuffering — Start buffering Phar write operations, do not modify the Phar object on disk

Popis

void Phar->startBuffering ( void )

Although technically unnecessary, the startBuffering() method can provide a significant performance boost when creating or modifying a Phar archive with a large number of files. Ordinarily, every time a file within a Phar archive is created or modified in any way, the entire Phar archive will be recreated with the changes. In this way, the archive will be up-to-date with the activity performed on it.

However, this can be unnecessary when simply creating a new Phar archive, when it would make more sense to write the entire archive out at once. Similarly, it is often necessary to make a series of changes and to ensure that they all are possible before making any changes on disk, similar to the relational database concept of transactions. the startBuffering()/stopBuffering() pair of methods is provided for this purpose.

Phar write buffering is per-archive, buffering active for the foo.phar Phar archive does not affect changes to the bar.phar Phar archive.

Příklady

Příklad 1618. A Phar->startBuffering() example

<?php
// make sure it doesn't exist
@unlink('brandnewphar.phar');
try {
    $p = new Phar(dirname(__FILE__) . '/brandnewphar.phar', 0, 'brandnewphar.phar');
} catch (Exception $e) {
    echo 'Could not create phar:', $e;
}
echo 'The new phar has ' . $p->count() . " entries\n";
$p->startBuffering();
$p['file.txt'] = 'hi';
$p['file2.txt'] = 'there';
$p['file2.txt']->setCompressedGZ();
$p['file3.txt'] = 'babyface';
$p['file3.txt']->setMetaData(42);
$p->setStub("<?php
function __autoload($class)
{
    include 'phar://myphar.phar/' . str_replace('_', '/', $class) . '.php';
}
Phar::mapPhar('myphar.phar');
include 'phar://myphar.phar/startup.php';
__HALT_COMPILER();");
$p->stopBuffering();
?>

Viz také

Phar->stopBuffering()
Phar->isBuffering()

Předcházející | Nahoru | Další
Phar->setStub | Domů | Phar->stopBuffering


Phar->stopBuffering

(PECL phar:1.0.0-1.2.1)

Phar->stopBuffering — Stop buffering write requests to the Phar archive, and save changes to disk

Popis

void Phar->stopBuffering ( void )

stopBuffering() is used in conjunction with the startBuffering() method. startBuffering() can provide a significant performance boost when creating or modifying a Phar archive with a large number of files. Ordinarily, every time a file within a Phar archive is created or modified in any way, the entire Phar archive will be recreated with the changes. In this way, the archive will be up-to-date with the activity performed on it.

However, this can be unnecessary when simply creating a new Phar archive, when it would make more sense to write the entire archive out at once. Similarly, it is often necessary to make a series of changes and to ensure that they all are possible before making any changes on disk, similar to the relational database concept of transactions. The startBuffering()/stopBuffering() pair of methods is provided for this purpose.

Phar write buffering is per-archive, buffering active for the foo.phar Phar archive does not affect changes to the bar.phar Phar archive.

Errors/Exceptions

PharException is thrown if any problems are encountered flushing changes to disk.

Příklady

Příklad 1619. A Phar->stopBuffering() example

<?php
$p = new Phar(dirname(__FILE__) . '/brandnewphar.phar', 0, 'brandnewphar.phar');
$p['file1.txt'] = 'hi';
$p->startBuffering();
var_dump($p->getStub());
$p->setStub("<?php
function __autoload(\$class)
{
    include 'phar://brandnewphar.phar/' . str_replace('_', '/', \$class) . '.php';
}
Phar::mapPhar('brandnewphar.phar');
include 'phar://brandnewphar.phar/startup.php';
__HALT_COMPILER();");
$p->stopBuffering();
var_dump($p->getStub());
?>

Výše uvedený příklad vypíše:

string(24) "<?php __HALT_COMPILER();"
string(195) "<?php
function __autoload($class)
{
    include 'phar://' . str_replace('_', '/', $class);
}
Phar::mapPhar('brandnewphar.phar');
include 'phar://brandnewphar.phar/startup.php';
__HALT_COMPILER();"

Viz také

Phar->startBuffering()
Phar->isBuffering()

Předcházející | Nahoru | Další
Phar->startBuffering | Domů | Phar->uncompressAllFiles


Phar->uncompressAllFiles

(PECL phar:1.0.0-1.2.1)

Phar->uncompressAllFiles — Uncompresses all files in the current Phar archive

Popis

bool Phar->uncompressAllFiles ( void )

This method decompresses all files in the Phar archive. If any files are already compressed using gzip compression, the zlib extension must be enabled in order to decompress the files, and any files compressed using bzip2 compression require the bzip2 extension to decompress the files. As with all functionality that modifies the contents of a phar, the phar.readonly INI variable must be off in order to succeed.

Errors/Exceptions

Throws BadMethodCallException if the phar.readonly INI variable is on, the bzip2 extension is not enabled and any files are compressed using bzip2 compression, or if any files are compressed using gzip compression and the zlib extension is not enabled.

Příklady

Příklad 1620. A Phar->uncompressAllFiles() example

<?php
try {
    $p = new Phar('/path/to/my.phar', 0, 'my.phar');
    $p['myfile.txt'] = 'hi';
    $p['myfile2.txt'] = 'hi';
    $p->compressAllFilesGZ();
    foreach ($p as $file) {
        var_dump($file->getFileName());
        var_dump($file->isCompressed());
        var_dump($file->isCompressedBZIP2());
        var_dump($file->isCompressedGZ());
    }
    $p->uncompressAllFiles();
    foreach ($p as $file) {
        var_dump($file->getFileName());
        var_dump($file->isCompressed());
        var_dump($file->isCompressedBZIP2());
        var_dump($file->isCompressedGZ());
    }
} catch (Exception $e) {
    echo 'Write operations failed on my.phar: ', $e;
}
?>

Výše uvedený příklad vypíše:

string(10) "myfile.txt"
bool(true)
bool(false)
bool(true)
string(11) "myfile2.txt"
bool(true)
bool(false)
bool(true)
string(10) "myfile.txt"
bool(false)
bool(false)
bool(false)
string(11) "myfile2.txt"
bool(false)
bool(false)
bool(false)

Viz také

PharFileInfo->isCompressedGZ()
PharFileInfo->isCompressed()
PharFileInfo->isCompressedGZ()
PharFileInfo->isCompressed()
Phar->compressAllFilesBZIP2()
Phar->compressAllFilesGZ()

Předcházející | Nahoru | Další
Phar->stopBuffering | Domů | PharFileInfo->chmod


PharFileInfo->chmod

(PECL phar:1.0.0-1.2.1)

PharFileInfo->chmod — Sets file-specific permission bits

Popis

void PharFileInfo->chmod ( int $permissions )

PharFileInfo->chmod() allows setting of the executable file permissions bit, as well as read-only bits. Writeable bits are ignored, and set at runtime based on the phar.readonly INI variable.

Seznam parametrů

permissions

permissions (see chmod())

Příklady

Příklad 1621. A PharFileInfo->chmod() example

<?php
// make sure it doesn't exist
@unlink('brandnewphar.phar');
try {
    $p = new Phar(dirname(__FILE__) . '/brandnewphar.phar', 0, 'brandnewphar.phar');
    $p['file.sh'] = '#!/usr/local/lib/php
    <?php echo "hi"; ?>';
    // set executable bit
    $p['file.sh']->chmod(0555);
    var_dump($p['file.sh']->isExecutable());
} catch (Exception $e) {
    echo 'Could not create/modify phar: ', $e;
}
?>

Výše uvedený příklad vypíše:

bool(true)

Předcházející | Nahoru | Další
Phar->uncompressAllFiles | Domů | PharFileInfo::__construct


PharFileInfo::__construct

(PECL phar:1.0.0-1.2.1)

PharFileInfo::__construct — Construct a Phar entry object

Popis

void PharFileInfo::__construct ( string $entry )

This should not be called directly. Instead, a PharFileInfo object is initialized by calling Phar::offsetGet() through array access.

Seznam parametrů

entry

The full url to retrieve a file. If you wish to retrieve the information for the file my/file.php from the phar boo.phar, the entry should be phar://boo.phar/my/file.php.

Errors/Exceptions

Throws BadMethodCallException if __construct() is called twice. Throws UnexpectedValueException if the phar URL requested is malformed, the requested phar cannot be opened, or the file can't be found within the phar.

Příklady

Příklad 1622. A PharFileInfo::__construct() example

<?php
try {
    $p = new Phar('/path/to/my.phar', 0, 'my.phar');
    $p['testfile.txt'] = "hi\nthere\ndude";
    $file = $p['testfile.txt'];
    foreach ($file as $line => $text) {
        echo "line number $line: $text";
    }
    // this also works
    $file = new PharFileInfo('phar:///path/to/my.phar/testfile.txt');
    foreach ($file as $line => $text) {
        echo "line number $line: $text";
    }
} catch (Exception $e) {
    echo 'Phar operations failed: ', $e;
}
?>

Výše uvedený příklad vypíše:

line number 1: hi
line number 2: there
line number 3: dude
line number 1: hi
line number 2: there
line number 3: dude

Předcházející | Nahoru | Další
PharFileInfo->chmod | Domů | PharFileInfo->getCompressedSize


PharFileInfo->getCompressedSize

(PECL phar:1.0.0-1.2.1)

PharFileInfo->getCompressedSize — Returns the actual size of the file (with compression) inside the Phar archive

Popis

int PharFileInfo->getCompressedSize ( void )

This returns the size of the file within the Phar archive. Uncompressed files will return the same value for getCompressedSize as they will with filesize()

Návratové hodnoty

The size in bytes of the file within the Phar archive on disk.

Příklady

Příklad 1623. A PharFileInfo->getCompressedSize() example

<?php
try {
    $p = new Phar('/path/to/my.phar', 0, 'my.phar');
    $p['myfile.txt'] = 'hi';
    $file = $p['myfile.txt'];
    echo $file->getCompressedSize();
} catch (Exception $e) {
    echo 'Write operations failed on my.phar: ', $e;
}
?>

Výše uvedený příklad vypíše:

2

Viz také

PharFileInfo->isCompressed()

Předcházející | Nahoru | Další
PharFileInfo::__construct | Domů | PharFileInfo->getCRC32


PharFileInfo->getCRC32

(PECL phar:1.0.0-1.2.1)

PharFileInfo->getCRC32 — Returns CRC32 code or throws an exception if not CRC checked

Popis

int PharFileInfo->getCRC32 ( void )

This returns the crc32() checksum of the file within the Phar archive.

Návratové hodnoty

The crc32() checksum of the file within the Phar archive.

Errors/Exceptions

Throws BadMethodCallException if the file has not yet had its CRC32 verified. This should be impossible with normal use, as the CRC is verified upon opening the file for reading or writing.

Příklady

Příklad 1624. A PharFileInfo->getCRC32() example

<?php
try {
    $p = new Phar('/path/to/my.phar', 0, 'my.phar');
    $p['myfile.txt'] = 'hi';
    $file = $p['myfile.txt'];
    echo $file->getCRC32();
} catch (Exception $e) {
    echo 'Write operations on my.phar.phar failed: ', $e;
}
?>

Výše uvedený příklad vypíše:

3633523372

Předcházející | Nahoru | Další
PharFileInfo->getCompressedSize | Domů | PharFileInfo->getMetaData


PharFileInfo->getMetaData

(PECL phar:1.0.0-1.2.1)

PharFileInfo->getMetaData — Returns file-specific meta-data saved with a file

Popis

int PharFileInfo->getMetaData ( void )

Return meta-data that was saved in the Phar archive's manifest for this file.

Seznam parametrů

Návratové hodnoty

any PHP variable that can be serialized and is stored as meta-data for the file, or NULL if no meta-data is stored.

Příklady

Příklad 1625. A PharFileInfo->getMetaData() example

<?php
// make sure it doesn't exist
@unlink('brandnewphar.phar');
try {
    $p = new Phar(dirname(__FILE__) . '/brandnewphar.phar', 0, 'brandnewphar.phar');
    $p['file.txt'] = 'hello';
    $p['file.txt']->setMetaData(array('user' => 'bill', 'mime-type' => 'text/plain'));
    var_dump($p['file.txt']->getMetaData());
} catch (Exception $e) {
    echo 'Could not create/modify brandnewphar.phar: ', $e;
}
?>

Výše uvedený příklad vypíše:

array(2) {
  ["user"]=>
  string(4) "bill"
  ["mime-type"]=>
  string(10) "text/plain"
}

Viz také

PharFileInfo->setMetaData()

Předcházející | Nahoru | Další
PharFileInfo->getCRC32 | Domů | PharFileInfo->getPharFlags


PharFileInfo->getPharFlags

(PECL phar:1.0.0-1.2.1)

PharFileInfo->getPharFlags — Returns the Phar file entry flags

Popis

int PharFileInfo->getPharFlags ( void )

This returns the flags set in the manifest for a Phar. This will always return 0 in the current implementation.

Návratové hodnoty

The Phar flags (always 0 in the current implementation)

Příklady

Příklad 1626. A PharFileInfo->getPharFlags() example

<?php
try {
    $p = new Phar('/path/to/my.phar', 0, 'my.phar');
    $p['myfile.txt'] = 'hi';
    $file = $p['myfile.txt'];
    var_dump($file->getPharFlags());
} catch (Exception $e) {
    echo 'Could not create/modify my.phar: ', $e;
}
?>

Výše uvedený příklad vypíše:

int(0)

Předcházející | Nahoru | Další
PharFileInfo->getMetaData | Domů | PharFileInfo->isCompressed


PharFileInfo->isCompressed

(PECL phar:1.0.0-1.2.1)

PharFileInfo->isCompressed — Returns whether the entry is compressed

Popis

bool PharFileInfo->isCompressed ( void )

This returns whether a file is compressed within a Phar archive with either Gzip or Bzip2 compression.

Návratové hodnoty

TRUE if the file is compressed within the Phar archive, FALSE if not.

Příklady

Příklad 1627. A PharFileInfo->isCompressed() example

<?php
try {
    $p = new Phar('/path/to/my.phar', 0, 'my.phar');
    $p['myfile.txt'] = 'hi';
    $p['myfile2.txt'] = 'hi';
    $p['myfile2.txt']->setCompressedGZ();
    $file = $p['myfile.txt'];
    $file2 = $p['myfile2.txt'];
    var_dump($file->isCompressed());
    var_dump($file2->isCompressed());
} catch (Exception $e) {
    echo 'Create/modify on phar my.phar failed: ', $e;
}
?>

Výše uvedený příklad vypíše:

bool(false)
bool(true)

Viz také

PharFileInfo->getCompressedSize()
PharFileInfo->isCompressedGZ()
PharFileInfo->isCompressedBZIP2()

Předcházející | Nahoru | Další
PharFileInfo->getPharFlags | Domů | PharFileInfo->isCompressedBZIP2


PharFileInfo->isCompressedBZIP2

(PECL phar:1.0.0-1.2.1)

PharFileInfo->isCompressedBZIP2 — Returns whether the entry is compressed using bzip2

Popis

bool PharFileInfo->isCompressedBZIP2 ( void )

This returns whether a file is compressed within a Phar archive with Bzip2 compression.

Návratové hodnoty

TRUE if the file is compressed within the Phar archive using Bzip2, FALSE if not.

Příklady

Příklad 1628. A PharFileInfo->isCompressedBZIP2() example

<?php
try {
    $p = new Phar('/path/to/my.phar', 0, 'my.phar');
    $p['myfile.txt'] = 'hi';
    $p['myfile2.txt'] = 'hi';
    $p['myfile3.txt'] = 'hi';
    $p['myfile2.txt']->setCompressedGZ();
    $p['myfile3.txt']->setCompressedBZIP2();
    $file = $p['myfile.txt'];
    $file2 = $p['myfile2.txt'];
    $file3 = $p['myfile3.txt'];
    var_dump($file->isCompressedBZIP2());
    var_dump($file2->isCompressedBZIP2());
    var_dump($file3->isCompressedBZIP2());
} catch (Exception $e) {
    echo 'Create/modify on phar my.phar failed: ', $e;
}
?>

Výše uvedený příklad vypíše:

bool(false)
bool(false)
bool(true)

Viz také

PharFileInfo->getCompressedSize()
PharFileInfo->isCompressedGZ()
PharFileInfo->isCompressed()

Předcházející | Nahoru | Další
PharFileInfo->isCompressed | Domů | PharFileInfo->isCompressedGZ


PharFileInfo->isCompressedGZ

(PECL phar:1.0.0-1.2.1)

PharFileInfo->isCompressedGZ — Returns whether the entry is compressed using gz

Popis

bool PharFileInfo->isCompressedGZ ( void )

This returns whether a file is compressed within a Phar archive with Gzip compression.

Návratové hodnoty

TRUE if the file is compressed within the Phar archive using Gzip, FALSE if not.

Příklady

Příklad 1629. A PharFileInfo->isCompressedGZ() example

<?php
try {
    $p = new Phar('/path/to/my.phar', 0, 'my.phar');
    $p['myfile.txt'] = 'hi';
    $p['myfile2.txt'] = 'hi';
    $p['myfile3.txt'] = 'hi';
    $p['myfile2.txt']->setCompressedGZ();
    $p['myfile3.txt']->setCompressedBZIP2();
    $file = $p['myfile.txt'];
    $file2 = $p['myfile2.txt'];
    $file3 = $p['myfile3.txt'];
    var_dump($file->isCompressedGZ());
    var_dump($file2->isCompressedGZ());
    var_dump($file3->isCompressedGZ());
} catch (Exception $e) {
    echo 'Create/modify on phar my.phar failed: ', $e;
}
?>

Výše uvedený příklad vypíše:

bool(false)
bool(true)
bool(false)

Viz také

PharFileInfo->getCompressedSize()
PharFileInfo->isCompressedBZIP2()
PharFileInfo->isCompressed()

Předcházející | Nahoru | Další
PharFileInfo->isCompressedBZIP2 | Domů | PharFileInfo->isCRCChecked


PharFileInfo->isCRCChecked

(PECL phar:1.0.0-1.2.1)

PharFileInfo->isCRCChecked — Returns whether file entry has had its CRC verified

Popis

bool PharFileInfo->isCRCChecked ( void )

This returns whether a file within a Phar archive has had its CRC verified.

Návratové hodnoty

TRUE if the file has had its CRC verified, FALSE if not.

Příklady

Příklad 1630. A PharFileInfo->isCRCChecked() example

<?php
try {
    $p = new Phar('/path/to/my.phar', 0, 'my.phar');
    $p['myfile.txt'] = 'hi';
    $file = $p['myfile.txt'];
    var_dump($file->isCRCChecked());
} catch (Exception $e) {
    echo 'Create/modify operations failed on my.phar: ', $e;
}
?>

Výše uvedený příklad vypíše:

bool(true)

Předcházející | Nahoru | Další
PharFileInfo->isCompressedGZ | Domů | PharFileInfo->setCompressedBZIP2


PharFileInfo->setCompressedBZIP2

(PECL phar:1.0.0-1.2.1)

PharFileInfo->setCompressedBZIP2 — Compresses the current Phar entry within the phar using Bzip2 compression

Popis

bool PharFileInfo->setCompressedBZIP2 ( void )

This method compresses the file inside the Phar archive using bzip2 compression. The bzip2 extension must be enabled to take advantage of this feature. In addition, if the file is already compressed using gzip compression, the zlib extension must be enabled in order to decompress the file. As with all functionality that modifies the contents of a phar, the phar.readonly INI variable must be off in order to succeed.

Errors/Exceptions

Throws BadMethodCallException if the phar.readonly INI variable is on, or if the bzip2 extension is not available.

Příklady

Příklad 1631. A PharFileInfo->setCompressedBZIP2() example

<?php
try {
    $p = new Phar('/path/to/my.phar', 0, 'my.phar');
    $p['myfile.txt'] = 'hi';
    $file = $p['myfile.txt'];
    var_dump($file->isCompressedBZIP2());
    $p['myfile.txt']->setCompressedBZIP2();
    var_dump($file->isCompressedBZIP2());
} catch (Exception $e) {
    echo 'Create/modify operations on my.phar failed: ', $e;
}
?>

Výše uvedený příklad vypíše:

bool(false)
bool(true)

Viz také

PharFileInfo->getCompressedSize()
PharFileInfo->isCompressedGZ()
PharFileInfo->isCompressed()
PharFileInfo->isCompressedGZ()
PharFileInfo->isCompressed()
Phar->compressAllFilesBZIP2()

Předcházející | Nahoru | Další
PharFileInfo->isCRCChecked | Domů | PharFileInfo->setCompressedGZ


PharFileInfo->setCompressedGZ

(PECL phar:1.0.0-1.2.1)

PharFileInfo->setCompressedGZ — Compresses the current Phar entry within the phar using gz compression

Popis

bool PharFileInfo->setCompressedGZ ( void )

This method compresses the file inside the Phar archive using gzip compression. The zlib extension must be enabled to take advantage of this feature. In addition, if the file is already compressed using bzip2 compression, the bzip2 extension must be enabled in order to decompress the file. As with all functionality that modifies the contents of a phar, the phar.readonly INI variable must be off in order to succeed.

Errors/Exceptions

Throws BadMethodCallException if the phar.readonly INI variable is on, or if the zlib extension is not available.

Příklady

Příklad 1632. A PharFileInfo->setCompressedGZ() example

<?php
try {
    $p = new Phar('/path/to/my.phar', 0, 'my.phar');
    $p['myfile.txt'] = 'hi';
    $file = $p['myfile.txt'];
    var_dump($file->isCompressedGZ());
    $p['myfile.txt']->setCompressedGZ();
    var_dump($file->isCompressedGZ());
} catch (Exception $e) {
    echo 'Create/modify operations on my.phar failed: ', $e;
}
?>

Výše uvedený příklad vypíše:

bool(false)
bool(true)

Viz také

PharFileInfo->getCompressedSize()
PharFileInfo->isCompressedBZIP2()
PharFileInfo->isCompressed()
PharFileInfo->isCompressedBZIP2()
PharFileInfo->isCompressed()
Phar->compressAllFilesGZ()

Předcházející | Nahoru | Další
PharFileInfo->setCompressedBZIP2 | Domů | PharFileInfo->setMetaData


PharFileInfo->setMetaData

(PECL phar:1.0.0-1.2.1)

PharFileInfo->setMetaData — Sets file-specific meta-data saved with a file

Popis

void PharFileInfo->setMetaData ( mixed $metadata )

setMetaData() should only be used to store customized data in a file that cannot be represented with existing information stored with a file. Meta-data can significantly slow down the performance of loading a phar archive if the data is large, or if there are many files containing meta-data. It is important to note that file permissions are natively supported inside a phar; it is possible to set them with the PharFileInfo->chmod() method. As with all functionality that modifies the contents of a phar, the phar.readonly INI variable must be off in order to succeed.

Some possible uses for meta-data include passing a user/group that should be set when a file is extracted from the phar to disk. Other uses could include explicitly specifying a MIME type to return. However, any useful data that describes a file, but should not be contained inside of it may be stored.

Seznam parametrů

metadata

Any PHP variable containing information to store alongside a file

Příklady

Příklad 1633. A PharFileInfo->setMetaData() example

<?php
// make sure it doesn't exist
@unlink('brandnewphar.phar');
try {
    $p = new Phar(dirname(__FILE__) . '/brandnewphar.phar', 0, 'brandnewphar.phar');
    $p['file.txt'] = 'hello';
    $p['file.txt']->setMetaData(array('user' => 'bill', 'mime-type' => 'text/plain'));
    var_dump($p['file.txt']->getMetaData());
} catch (Exception $e) {
    echo 'Could not create/modify phar: ', $e;
}
?>

Výše uvedený příklad vypíše:

array(2) {
  ["user"]=>
  string(4) "bill"
  ["mime-type"]=>
  string(10) "text/plain"
}

Viz také

PharFileInfo->getMetaData()

Předcházející | Nahoru | Další
PharFileInfo->setCompressedGZ | Domů | PharFileInfo->setUncompressed


PharFileInfo->setUncompressed

(PECL phar:1.0.0-1.2.1)

PharFileInfo->setUncompressed — Uncompresses the current Phar entry within the phar, if it is compressed

Popis

bool PharFileInfo->setUncompressed ( void )

This method decompresses the file inside the Phar archive. Depending on how the file is compressed, the bzip2 or zlib extensions must be enabled to take advantage of this feature. As with all functionality that modifies the contents of a phar, the phar.readonly INI variable must be off in order to succeed.

Errors/Exceptions

Throws BadMethodCallException if the phar.readonly INI variable is on, or if the bzip2/zlib extension is not available.

Příklady

Příklad 1634. A PharFileInfo->setUncompressed() example

<?php
try {
    $p = new Phar('/path/to/my.phar', 0, 'my.phar');
    $p['myfile.txt'] = 'hi';
    $file = $p['myfile.txt'];
    $file->setCompressedGZ();
    var_dump($file->isCompressed());
    $p['myfile.txt']->setUncompressed();
    var_dump($file->isCompressed());
} catch (Exception $e) {
    echo 'Create/modify failed for my.phar: ', $e;
}
?>

Výše uvedený příklad vypíše:

bool(true)
bool(false)

Viz také

PharFileInfo->getCompressedSize()
PharFileInfo->isCompressedGZ()
PharFileInfo->isCompressedBZIP2()
PharFileInfo->isCompressedGZ()
PharFileInfo->isCompressed()
Phar->uncompressAllFiles()

Předcházející | Nahoru | Další
PharFileInfo->setMetaData | Domů | CXXIV. PHP volby a informace


posix_access

(PHP 5 >= 5.1.0)

posix_access — Determine accessibility of a file

Popis

bool posix_access ( string $file [, int $mode] )

posix_access() checks the user's permission of a file.

Seznam parametrů

file

The name of the file to be tested.

mode

A mask consisting of one or more of POSIX_F_OK, POSIX_R_OK, POSIX_W_OK and POSIX_X_OK. Defaults to POSIX_F_OK.

POSIX_R_OK, POSIX_W_OK and POSIX_X_OK request checking whether the file exists and has read, write and execute permissions, respectively. POSIX_F_OK just requests checking for the existence of the file.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1655. posix_access() example

This example will check if the $file is readable and writable, otherwise will print an error message.

<?php

$file = 'some_file';

if (posix_access($file, POSIX_R_OK | POSIX_W_OK)) {
    echo 'The file is readable and writable!';

} else {
    $error = posix_get_last_error();

    echo "Error $error: " . posix_strerror($error);
}

?>

Poznámky

Poznámka: Pokud je zapnut bezpečný režim (safe-mode), PHP kontroluje, zda soubory/adresáře, se kterými pracujete, mají stejné UID jako spuštěný skript.

Viz také

posix_get_last_error()
posix_strerror()

Předcházející | Nahoru | Další
CXXV. POSIX Functions | Domů | posix_ctermid


posix_initgroups

(PHP 5 >= 5.2.0)

posix_initgroups — Calculate the group access list

Popis

bool posix_initgroups ( string $name, int $base_group_id )

Calculates the group access list for the user specified in name.

Seznam parametrů

name

The user to calculate the list for.

base_group_id

Typically the group number from the password file.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

The Unix manual page for initgroups(3).

Předcházející | Nahoru | Další
posix_getuid | Domů | posix_isatty


posix_mknod

(PHP 5 >= 5.1.0)

posix_mknod — Create a special or ordinary file (POSIX.1)

Popis

bool posix_mknod ( string $pathname, int $mode [, int $major [, int $minor]] )

Creates a special or ordinary file.

Seznam parametrů

pathname

The file to create

mode

This parameter is constructed by a bitwise OR between file type (one of the following constants: POSIX_S_IFREG, POSIX_S_IFCHR, POSIX_S_IFBLK, POSIX_S_IFIFO or POSIX_S_IFSOCK) and permissions.

major

The major device kernel identifier (required to pass when using S_IFCHR or S_IFBLK).

minor

The minor device kernel identifier (defaults to 0).

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1674. A posix_mknod() example

<?php

$file = '/tmp/tmpfile';  // file name
$type = POSIX_S_IFBLK;   // file type
$permissions = 0777;     // octal
$major = 1;
$minor = 8;              // /dev/random

if (!posix_mknod($file, $type | $permissions, $major, $minor)) {
    die('Error ' . posix_get_last_error() . ': ' . posix_strerror(posix_get_last_error()));
}

?>

Viz také

posix_mkfifo()

Předcházející | Nahoru | Další
posix_mkfifo | Domů | posix_setegid


preg_last_error

(PHP 5 >= 5.2.0)

preg_last_error — Returns the error code of the last PCRE regex execution

Popis

int preg_last_error ( void )

Returns the error code of the last PCRE regex execution.

Návratové hodnoty

Returns one of the following constants (explained on their own page):
PREG_NO_ERROR
PREG_INTERNAL_ERROR
PREG_BACKTRACK_LIMIT_ERROR (see also pcre.backtrack_limit)
PREG_RECURSION_LIMIT_ERROR (see also pcre.recursion_limit)
PREG_BAD_UTF8_ERROR

Předcházející | Nahoru | Další
preg_grep | Domů | preg_match_all


property_exists

(PHP 5 >= 5.1.0)

property_exists — Checks if the object or class has a property

Popis

bool property_exists ( mixed $class, string $property )

This function checks if the given property exists in the specified class (and if it is accessible from the current scope).

Poznámka: As opposed with isset(), property_exists() returns TRUE even if the property has the value NULL.

Seznam parametrů

class

The class name or an object of the class to test for

property

The name of the property

Návratové hodnoty

Returns TRUE if the property exists, FALSE if it doesn't exist or NULL in case of an error.

Příklady

Příklad 301. A property_exists() example

<?php

class myClass {
    public $mine;
    private $xpto;

    static function test() {
        var_dump(property_exists('myClass', 'xpto')); // true, it can be accessed from here
    }
}

var_dump(property_exists('myClass', 'mine'));   //true
var_dump(property_exists(new myClass, 'mine')); //true
var_dump(property_exists('myClass', 'xpto'));   //false, isn't public
myClass::test();

?>

Viz také

method_exists()

Předcházející | Nahoru | Další
method_exists | Domů | XIV. Classkit Functions


ps_add_bookmark

(PECL ps:1.1.0-1.3.5)

ps_add_bookmark — Add bookmark to current page

Popis

int ps_add_bookmark ( resource $psdoc, string $text [, int $parent [, int $open]] )

Adds a bookmark for the current page. Bookmarks usually appear in PDF-Viewers left of the page in a hierarchical tree. Clicking on a bookmark will jump to the given page.

The bookmark has no meaning if the document is printed or viewed, but it will be used if the document is converted to pdf by either Acrobat Distiller™ or Ghostview.

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

text

The text used for displaying the bookmark.

parent

A bookmark previously created by this function which is used as the parent of the new bookmark.

open

If open is unequal to zero the bookmark will be shown open by the pdf viewer.

Návratové hodnoty

The returned value is a reference for the bookmark. It is only used if the bookmark shall be used as a parent. The value is greater zero if the function succeeds. In case of an error zero will be returned.

Viz také

ps_add_launchlink()
ps_add_pdflink()
ps_add_weblink()

Předcházející | Nahoru | Další
CXXXI. PostScript document creation | Domů | ps_add_launchlink


ps_add_launchlink

(PECL ps:1.1.0-1.3.5)

ps_add_launchlink — Adds link which launches file

Popis

bool ps_add_launchlink ( resource $psdoc, float $llx, float $lly, float $urx, float $ury, string $filename )

Places a hyperlink at the given position pointing to a file program which is being started when clicked on. The hyperlink's source position is a rectangle with its lower left corner at (llx, lly) and its upper right corner at (urx, ury). The rectangle has by default a thin blue border.

The hyperlink will not be visible if the document is printed or viewed but it will show up if the document is converted to pdf by either Acrobat Distiller™ or Ghostview.

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

llx

The x-coordinate of the lower left corner.

lly

The y-coordinate of the lower left corner.

urx

The x-coordinate of the upper right corner.

ury

The y-coordinate of the upper right corner.

filename

The path of the program to be started, when the link is clicked on.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ps_add_locallink()
ps_add_pdflink()
ps_add_weblink()

Předcházející | Nahoru | Další
ps_add_bookmark | Domů | ps_add_locallink


ps_add_locallink

(PECL ps:1.1.0-1.3.5)

ps_add_locallink — Adds link to a page in the same document

Popis

bool ps_add_locallink ( resource $psdoc, float $llx, float $lly, float $urx, float $ury, int $page, string $dest )

Places a hyperlink at the given position pointing to a page in the same document. Clicking on the link will jump to the given page. The first page in a document has number 1.

The hyperlink's source position is a rectangle with its lower left corner at (llx, lly) and its upper right corner at (urx, ury). The rectangle has by default a thin blue border.

The hyperlink will not be visible if the document is printed or viewed but it will show up if the document is converted to pdf by either Acrobat Distiller™ or Ghostview.

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

llx

The x-coordinate of the lower left corner.

lly

The y-coordinate of the lower left corner.

urx

The x-coordinate of the upper right corner.

ury

The y-coordinate of the upper right corner.

page

The number of the page displayed when clicking on the link.

dest

The parameter dest determines how the document is being viewed. It can be fitpage, fitwidth, fitheight, or fitbbox.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ps_add_launchlink()
ps_add_pdflink()
ps_add_weblink()

Předcházející | Nahoru | Další
ps_add_launchlink | Domů | ps_add_note


ps_add_note

(PECL ps:1.1.0-1.3.5)

ps_add_note — Adds note to current page

Popis

bool ps_add_note ( resource $psdoc, float $llx, float $lly, float $urx, float $ury, string $contents, string $title, string $icon, int $open )

Adds a note at a certain position on the page. Notes are like little rectangular sheets with text on it, which can be placed anywhere on a page. They are shown either folded or unfolded. If unfolded, the specified icon is used as a placeholder.

The note will not be visible if the document is printed or viewed but it will show up if the document is converted to pdf by either Acrobat Distiller™ or Ghostview.

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

llx

The x-coordinate of the lower left corner.

lly

The y-coordinate of the lower left corner.

urx

The x-coordinate of the upper right corner.

ury

The y-coordinate of the upper right corner.

contents

The text of the note.

title

The title of the note as displayed in the header of the note.

icon

The icon shown if the note is folded. This parameter can be set to comment, insert, note, paragraph, newparagraph, key, or help.

open

If open is unequal to zero the note will be shown unfolded after opening the document with a pdf viewer.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ps_add_pdflink()
ps_add_launchlink()
ps_add_locallink()
ps_add_weblink()

Předcházející | Nahoru | Další
ps_add_locallink | Domů | ps_add_pdflink


ps_add_pdflink

(PECL ps:1.1.0-1.3.5)

ps_add_pdflink — Adds link to a page in a second pdf document

Popis

bool ps_add_pdflink ( resource $psdoc, float $llx, float $lly, float $urx, float $ury, string $filename, int $page, string $dest )

Places a hyperlink at the given position pointing to a second pdf document. Clicking on the link will branch to the document at the given page. The first page in a document has number 1.

The hyperlink's source position is a rectangle with its lower left corner at (llx, lly) and its upper right corner at (urx, ury). The rectangle has by default a thin blue border.

The hyperlink will not be visible if the document is printed or viewed but it will show up if the document is converted to pdf by either Acrobat Distiller™ or Ghostview.

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

llx

The x-coordinate of the lower left corner.

lly

The y-coordinate of the lower left corner.

urx

The x-coordinate of the upper right corner.

ury

The y-coordinate of the upper right corner.

filename

The name of the pdf document to be opened when clicking on this link.

page

The page number of the destination pdf document

dest

The parameter dest determines how the document is being viewed. It can be fitpage, fitwidth, fitheight, or fitbbox.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ps_add_launchlink()
ps_add_locallink()
ps_add_weblink()

Předcházející | Nahoru | Další
ps_add_note | Domů | ps_add_weblink


ps_add_weblink

(PECL ps:1.1.0-1.3.5)

ps_add_weblink — Adds link to a web location

Popis

bool ps_add_weblink ( resource $psdoc, float $llx, float $lly, float $urx, float $ury, string $url )

Places a hyperlink at the given position pointing to a web page. The hyperlink's source position is a rectangle with its lower left corner at (llx, lly) and its upper right corner at (urx, ury). The rectangle has by default a thin blue border.

The hyperlink will not be visible if the document is printed or viewed but it will show up if the document is converted to pdf by either Acrobat Distiller™ or Ghostview.

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

llx

The x-coordinate of the lower left corner.

lly

The y-coordinate of the lower left corner.

urx

The x-coordinate of the upper right corner.

ury

The y-coordinate of the upper right corner.

url

The url of the hyperlink to be opened when clicking on this link, e.g. http://www.php.net.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ps_add_launchlink()
ps_add_locallink()
ps_add_pdflink()

Předcházející | Nahoru | Další
ps_add_pdflink | Domů | ps_arc


ps_arc

(PECL ps:1.1.0-1.3.5)

ps_arc — Draws an arc counterclockwise

Popis

bool ps_arc ( resource $psdoc, float $x, float $y, float $radius, float $alpha, float $beta )

Draws a portion of a circle with at middle point at (x, y). The arc starts at an angle of alpha and ends at an angle of beta. It is drawn counterclockwise (use ps_arcn() to draw clockwise). The subpath added to the current path starts on the arc at angle alpha and ends on the arc at angle beta.

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

x

The x-coordinate of the circle's middle point.

y

The y-coordinate of the circle's middle point.

radius

The radius of the circle

alpha

The start angle given in degrees.

beta

The end angle given in degrees.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ps_arcn()

Předcházející | Nahoru | Další
ps_add_weblink | Domů | ps_arcn


ps_arcn

(PECL ps:1.1.0-1.3.5)

ps_arcn — Draws an arc clockwise

Popis

bool ps_arcn ( resource $psdoc, float $x, float $y, float $radius, float $alpha, float $beta )

Draws a portion of a circle with at middle point at (x, y). The arc starts at an angle of alpha and ends at an angle of beta. It is drawn clockwise (use ps_arc() to draw counterclockwise). The subpath added to the current path starts on the arc at angle beta and ends on the arc at angle alpha.

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

x

The x-coordinate of the circle's middle point.

y

The y-coordinate of the circle's middle point.

radius

The radius of the circle

alpha

The starting angle given in degrees.

beta

The end angle given in degrees.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ps_arc()

Předcházející | Nahoru | Další
ps_arc | Domů | ps_begin_page


ps_begin_page

(PECL ps:1.1.0-1.3.5)

ps_begin_page — Start a new page

Popis

bool ps_begin_page ( resource $psdoc, float $width, float $height )

Starts a new page. Although the parameters width and height imply a different page size for each page, this is not possible in PostScript. The first call of ps_begin_page() will set the page size for the whole document. Consecutive calls will have no effect, except for creating a new page. The situation is different if you intent to convert the PostScript document into PDF. This function places pdfmarks into the document which can set the size for each page indiviually. The resulting PDF document will have different page sizes.

Though PostScript does not know different page sizes, pslib places a bounding box for each page into the document. This size is evaluated by some PostScript viewers and will have precedence over the BoundingBox in the Header of the document. This can lead to unexpected results when you set a BoundingBox whose lower left corner is not (0, 0), because the bounding box of the page will always have a lower left corner (0, 0) and overwrites the global setting.

Each page is encapsulated into save/restore. This means, that most of the settings made on one page will not be retained on the next page.

If there is up to the first call of ps_begin_page() no call of ps_findfont(), then the header of the PostScript document will be output and the bounding box will be set to the size of the first page. The lower left corner of the bounding box is set to (0, 0). If ps_findfont() was called before, then the header has been output already, and the document will not have a valid bounding box. In order to prevent this, one should call ps_set_info() to set the info field BoundingBox and possibly Orientation before any ps_findfont() or ps_begin_page() calls.

Poznámka: Up to version 0.2.6 of pslib, this function will always overwrite the BoundingBox and Orientation, if it has been set before with ps_set_info() and ps_findfont() has not been called before.

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

width

The width of the page in pixel, e.g. 596 for A4 format.

height

The height of the page in pixel, e.g. 842 for A4 format.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ps_end_page()
ps_findfont()
ps_set_info()

Předcházející | Nahoru | Další
ps_arcn | Domů | ps_begin_pattern


ps_begin_pattern

(PECL ps:1.2.0-1.3.5)

ps_begin_pattern — Start a new pattern

Popis

int ps_begin_pattern ( resource $psdoc, float $width, float $height, float $xstep, float $ystep, int $painttype )

Starts a new pattern. A pattern is like a page containing e.g. a drawing which can be used for filling areas. It is used like a color by calling ps_setcolor() and setting the color space to pattern.

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

width

The width of the pattern in pixel.

height

The height of the pattern in pixel.

x-step

The distance in pixel of placements of the pattern in horizontal direction.

y-step

The distance in pixel of placements of the pattern in vertical direction.

painttype

Must be 1 or 2.

Návratové hodnoty

The identifier of the pattern or FALSE in case of an error.

Příklady

Příklad 1803. Creating and using a pattern

<?php
$ps = ps_new();

if (!ps_open_file($ps, "pattern.ps")) {
  print "Cannot open PostScript file\n";
  exit;
}

ps_set_parameter($ps, "warning", "true");
ps_set_info($ps, "Creator", "pattern.php");
ps_set_info($ps, "Author", "Uwe Steinmann");
ps_set_info($ps, "Title", "Pattern example");

$pspattern = ps_begin_pattern($ps, 10.0, 10.0, 10.0, 10.0, 1);
ps_setlinewidth($ps, 0.2);
ps_setcolor($ps, "stroke", "rgb", 0.0, 0.0, 1.0, 0.0);
ps_moveto($ps, 0, 0);
ps_lineto($ps, 7, 7);
ps_stroke($ps);
ps_moveto($ps, 0, 7);
ps_lineto($ps, 7, 0);
ps_stroke($ps);
ps_end_pattern($ps);

ps_begin_page($ps, 596, 842);
ps_setcolor($ps, "both", "pattern", $pspattern, 0.0, 0.0, 0.0);
ps_rect($ps, 50, 400, 200, 200);
ps_fill($ps);
ps_end_page($ps);

ps_close($ps);
ps_delete($ps);
?>

Viz také

ps_end_pattern()
ps_setcolor()
ps_shading_pattern()

Předcházející | Nahoru | Další
ps_begin_page | Domů | ps_begin_template


ps_begin_template

(PECL ps:1.2.0-1.3.5)

ps_begin_template — Start a new template

Popis

int ps_begin_template ( resource $psdoc, float $width, float $height )

Starts a new template. A template is called a form in the postscript language. It is created similar to a pattern but used like an image. Templates are often used for drawings which are placed several times through out the document, e.g. like a company logo. All drawing functions may be used within a template. The template will not be drawn until it is placed by ps_place_image().

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

width

The width of the template in pixel.

height

The height of the template in pixel.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1804. Creating and using a template

<?php
$ps = ps_new();

if (!ps_open_file($ps, "template.ps")) {
  print "Cannot open PostScript file\n";
  exit;
}

ps_set_parameter($ps, "warning", "true");
ps_set_info($ps, "Creator", "template.php");
ps_set_info($ps, "Author", "Uwe Steinmann");
ps_set_info($ps, "Title", "Template example");

$pstemplate = ps_begin_template($ps, 30.0, 30.0);
ps_moveto($ps, 0, 0);
ps_lineto($ps, 30, 30);
ps_moveto($ps, 0, 30);
ps_lineto($ps, 30, 0);
ps_stroke($ps);
ps_end_template($ps);

ps_begin_page($ps, 596, 842);
ps_place_image($ps, $pstemplate, 20.0, 20.0, 1.0);
ps_place_image($ps, $pstemplate, 50.0, 30.0, 0.5);
ps_place_image($ps, $pstemplate, 70.0, 70.0, 0.6);
ps_place_image($ps, $pstemplate, 30.0, 50.0, 1.3);
ps_end_page($ps);

ps_close($ps);
ps_delete($ps);
?>

Viz také

ps_end_template()

Předcházející | Nahoru | Další
ps_begin_pattern | Domů | ps_circle


ps_circle

(PECL ps:1.1.0-1.3.5)

ps_circle — Draws a circle

Popis

bool ps_circle ( resource $psdoc, float $x, float $y, float $radius )

Draws a circle with its middle point at (x, y). The circle starts and ends at position (x+radius, y). If this function is called outside a path it will start a new path. If it is called within a path it will add the circle as a subpath. If the last drawing operation does not end in point (x+radius, y) then there will be a gap in the path.

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

x

The x-coordinate of the circle's middle point.

y

The y-coordinate of the circle's middle point.

radius

The radius of the circle

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ps_arc()
ps_arcn()

Předcházející | Nahoru | Další
ps_begin_template | Domů | ps_clip


ps_clip

(PECL ps:1.1.0-1.3.5)

ps_clip — Clips drawing to current path

Popis

bool ps_clip ( resource $psdoc )

Takes the current path and uses it to define the border of a clipping area. Everything drawn outside of that area will not be visible.

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ps_closepath()

Předcházející | Nahoru | Další
ps_circle | Domů | ps_close_image


ps_close

(PECL ps:1.1.0-1.3.5)

ps_close — Closes a PostScript document

Popis

bool ps_close ( resource $psdoc )

Closes the PostScript document.

This function writes the trailer of the PostScript document. It also writes the bookmark tree. ps_close() does not free any resources, which is done by ps_delete().

This function is also called by ps_delete() if it has not been called before.

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ps_open_file()
ps_delete()

Předcházející | Nahoru | Další
ps_close_image | Domů | ps_closepath_stroke


ps_close_image

(PECL ps:1.1.0-1.3.5)

ps_close_image — Closes image and frees memory

Popis

void ps_close_image ( resource $psdoc, int $imageid )

Closes an image and frees its resources. Once an image is closed it cannot be used anymore.

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

imageid

Resource identifier of the image as returned by ps_open_image() or ps_open_image_file().

Návratové hodnoty

Returns NULL on success or FALSE on failure.

Viz také

ps_open_image()
ps_open_image_file()

Předcházející | Nahoru | Další
ps_clip | Domů | ps_close


ps_closepath

(PECL ps:1.1.0-1.3.5)

ps_closepath — Closes path

Popis

bool ps_closepath ( resource $psdoc )

Connects the last point with the first point of a path. The resulting path can be used for stroking, filling, clipping, etc..

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ps_clip()
ps_closepath_stroke()

Předcházející | Nahoru | Další
ps_closepath_stroke | Domů | ps_continue_text


ps_closepath_stroke

(PECL ps:1.1.0-1.3.5)

ps_closepath_stroke — Closes and strokes path

Popis

bool ps_closepath_stroke ( resource $psdoc )

Connects the last point with first point of a path and draws the resulting closed line.

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ps_closepath()

Předcházející | Nahoru | Další
ps_close | Domů | ps_closepath


ps_continue_text

(PECL ps:1.1.0-1.3.5)

ps_continue_text — Continue text in next line

Popis

bool ps_continue_text ( resource $psdoc, string $text )

Output a text one line below the last line. The line spacing is taken from the value "leading" which must be set with ps_set_value(). The actual position of the text is determined by the values "textx" and "texty" which can be requested with ps_get_value()

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

text

The text to output.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ps_show()
ps_show_xy()
ps_show_boxed()

Předcházející | Nahoru | Další
ps_closepath | Domů | ps_curveto


ps_curveto

(PECL ps:1.1.0-1.3.5)

ps_curveto — Draws a curve

Popis

bool ps_curveto ( resource $psdoc, float $x1, float $y1, float $x2, float $y2, float $x3, float $y3 )

Add a section of a cubic Bézier curve described by the three given control points to the current path.

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

x1

x-coordinate of first control point.

y1

y-coordinate of first control point.

x2

x-coordinate of second control point.

y2

y-coordinate of second control point.

x3

x-coordinate of third control point.

y3

y-coordinate of third control point.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ps_lineto()

Předcházející | Nahoru | Další
ps_continue_text | Domů | ps_delete


ps_delete

(PECL ps:1.1.0-1.3.5)

ps_delete — Deletes all resources of a PostScript document

Popis

bool ps_delete ( resource $psdoc )

Mainly frees memory used by the document. Also closes a file, if it was not closed before with ps_close(). You should in any case close the file with ps_close() before, because ps_close() not just closes the file but also outputs a trailor containing PostScript comments like the number of pages in the document and adding the bookmark hierarchy.

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ps_close()

Předcházející | Nahoru | Další
ps_curveto | Domů | ps_end_page


ps_end_page

(PECL ps:1.1.0-1.3.5)

ps_end_page — End a page

Popis

bool ps_end_page ( resource $psdoc )

Ends a page which was started with ps_begin_page(). Ending a page will leave the current drawing context, which e.g. requires to reload fonts if they were loading within the page, and to set many other drawing parameters like the line width, or color..

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ps_begin_page()

Předcházející | Nahoru | Další
ps_delete | Domů | ps_end_pattern


ps_end_pattern

(PECL ps:1.2.0-1.3.5)

ps_end_pattern — End a pattern

Popis

bool ps_end_pattern ( resource $psdoc )

Ends a pattern which was started with ps_begin_pattern(). Once a pattern has been ended, it can be used like a color to fill areas.

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ps_begin_pattern()

Předcházející | Nahoru | Další
ps_end_page | Domů | ps_end_template


ps_end_template

(PECL ps:1.2.0-1.3.5)

ps_end_template — End a template

Popis

bool ps_end_template ( resource $psdoc )

Ends a template which was started with ps_begin_template(). Once a template has been ended, it can be used like an image.

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ps_begin_template()

Předcházející | Nahoru | Další
ps_end_pattern | Domů | ps_fill_stroke


ps_fill

(PECL ps:1.1.0-1.3.5)

ps_fill — Fills the current path

Popis

bool ps_fill ( resource $psdoc )

Fills the path constructed with previously called drawing functions like ps_lineto().

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ps_fill_stroke()
ps_stroke()

Předcházející | Nahoru | Další
ps_fill_stroke | Domů | ps_findfont


ps_fill_stroke

(PECL ps:1.1.0-1.3.5)

ps_fill_stroke — Fills and strokes the current path

Popis

bool ps_fill_stroke ( resource $psdoc )

Fills and draws the path constructed with previously called drawing functions like ps_lineto().

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ps_fill()
ps_stroke()

Předcházející | Nahoru | Další
ps_end_template | Domů | ps_fill


ps_findfont

(PECL ps:1.1.0-1.3.5)

ps_findfont — Loads a font

Popis

int ps_findfont ( resource $psdoc, string $fontname, string $encoding [, bool $embed] )

Loads a font for later use. Before text is output with a loaded font it must be set with ps_setfont(). This function needs the adobe font metric file in order to calculate the space used up by the characters. A font which is loaded within a page will only be available on that page. Fonts which are to be used in the complete document have to be loaded before the first call of ps_begin_page(). Calling ps_findfont() between pages will make that font available for all following pages.

The name of the afm file must be fontname.afm. If the font shall be embedded the file fontname.pfb containing the font outline must be present as well.

Calling ps_findfont() before the first page requires to output the postscript header which includes the BoundingBox for the whole document. Usually the BoundingBox is set with the first call of ps_begin_page() which now comes after ps_findfont(). Consequently the BoundingBox has not been set and a warning will be issued when ps_findfont() is called. In order to prevent this situation, one should call ps_set_parameter() to set the BoundingBox before ps_findfont() is called.

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

fontname

The name of the font.

encoding

ps_findfont() will try to load the file passed in the parameter encoding. Encoding files are of the same syntax as those used by dvips(1). They contain a font encoding vector (which is currently not used but must be present) and a list of extra ligatures to extend the list of ligatures derived from the afm file.

encoding can be NULL or the empty string if the default encoding (TeXBase1) shall be used.

If the encoding is set to builtin then there will be no reencoding and the font specific encoding will be used. This is very useful with symbol fonts.

embed

If set to a value >0 the font will be embedded into the document. This requires the font outline (.pfb file) to be present.

Návratové hodnoty

Returns the identifier of the font or zero in case of an error. The identifier is a positive number.

Viz také

ps_begin_page()
ps_setfont()

Předcházející | Nahoru | Další
ps_fill | Domů | ps_get_buffer


ps_get_buffer

(PECL ps:1.1.0-1.3.5)

ps_get_buffer — Fetches the full buffer containig the generated PS data

Popis

string ps_get_buffer ( resource $psdoc )

This function is not implemented yet. It will always return an empty string. The idea for a later implementation is to write the contents of the postscript file into an internal buffer if in memory creation is requested, and retrieve the buffer content with this function. Currently, documents created in memory are send to the browser without buffering.

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

Viz také

ps_open_file()

Předcházející | Nahoru | Další
ps_findfont | Domů | ps_get_parameter


ps_get_parameter

(PECL ps:1.1.0-1.3.5)

ps_get_parameter — Gets certain parameters

Popis

string ps_get_parameter ( resource $psdoc, string $name [, float $modifier] )

Gets several parameters which were directly set by ps_set_parameter() or indirectly by one of the other functions. Parameters are by definition string values. This function cannot be used to retrieve resources which were also set by ps_set_parameter().

The parameter name can have the following values.

fontname

The name of the currently active font or the font whose identifier is passed in parameter modifier.

fontencoding

The encoding of the currently active font.

dottedversion

The version of the underlying pslib library in the format <major>.<minor>.<subminor>

scope

The current drawing scope. Can be object, document, null, page, pattern, path, template, prolog, font, glyph.

ligaturedisolvechar

The character which dissolves a ligature. If your are using a font which contains the ligature `ff' and `|' is the char to dissolve the ligature, then `f|f' will result in two `f' instead of the ligature `ff'.

imageencoding

The encoding used for encoding images. Can be either hex or 85. hex encoding uses two bytes in the postscript file each byte in the image. 85 stand for Ascii85 encoding.

linenumbermode

Set to paragraph if lines are numbered within a paragraph or box if they are numbered within the surrounding box.

linebreak

Only used if text is output with ps_show_boxed(). If set to true a carriage return will add a line break.

parbreak

Only used if text is output with ps_show_boxed(). If set to true a carriage return will start a new paragraph.

hyphenation

Only used if text is output with ps_show_boxed(). If set to true the paragraph will be hyphenated if a hypen dictionary is set and exists.

hyphendict

Filename of the dictionary used for hyphenation pattern.

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

name

Name of the parameter.

modifier

An identifier needed if a parameter of a resource is requested, e.g. the size of an image. In such a case the resource id is passed.

Návratové hodnoty

Returns the value of the parameter or FALSE in case of an error.

Viz také

ps_set_parameter()

Předcházející | Nahoru | Další
ps_get_buffer | Domů | ps_get_value


ps_get_value

(PECL ps:1.1.0-1.3.5)

ps_get_value — Gets certain values

Popis

float ps_get_value ( resource $psdoc, string $name [, float $modifier] )

Gets several values which were set by ps_set_value(). Values are by definition float values.

The parameter name can have the following values.

fontsize

The size of the currently active font or the font whose identifier is passed in parameter modifier.

font

The currently active font itself.

imagewidth

The width of the image whose id is passed in the parameter modifier.

imageheight

The height of the image whose id is passed in the parameter modifier.

capheight

The height of a capital M in the currently active font or the font whose identifier is passed in parameter modifier.

ascender

The ascender of the currently active font or the font whose identifier is passed in parameter modifier.

descender

The descender of the currently active font or the font whose identifier is passed in parameter modifier.

italicangle

The italicangle of the currently active font or the font whose identifier is passed in parameter modifier.

underlineposition

The underlineposition of the currently active font or the font whose identifier is passed in parameter modifier.

underlinethickness

The underlinethickness of the currently active font or the font whose identifier is passed in parameter modifier.

textx

The current x-position for text output.

texty

The current y-position for text output.

textrendering

The current mode for text rendering.

textrise

The space by which text is risen above the base line.

leading

The distance between text lines in points.

wordspacing

The space between words as a multiple of the width of a space char.

charspacing

The space between chars. If charspacing is != 0.0 ligatures will always be dissolved.

hyphenminchars

Minimum number of chars hyphenated at the end of a word.

parindent

Indention of the first n line in a paragraph.

numindentlines

Number of line in a paragraph to indent if parindent != 0.0.

parskip

Distance between paragraphs.

linenumberspace

Overall space in front of each line for the line number.

linenumbersep

Space between the line and the line number.

major

The major version number of pslib.

minor

The minor version number of pslib.

subminor, revision

The subminor version number of pslib.

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

name

Name of the value.

modifier

The parameter modifier specifies the resource for which the value is to be retrieved. This can be the id of a font or an image.

Návratové hodnoty

Returns the value of the parameter or FALSE.

Viz také

ps_set_value()

Předcházející | Nahoru | Další
ps_get_parameter | Domů | ps_hyphenate


ps_hyphenate

(PECL ps:1.1.1-1.3.5)

ps_hyphenate — Hyphenates a word

Popis

array ps_hyphenate ( resource $psdoc, string $text )

Hyphenates the passed word. ps_hyphenate() evaluates the value hyphenminchars (set by ps_set_value()) and the parameter hyphendict (set by ps_set_parameter()). hyphendict must be set before calling this function.

This function requires the locale category LC_CTYPE to be set properly. This is done when the extension is initialized by using the environment variables. On Unix systems read the man page of locale for more information.

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

text

text should not contain any non alpha characters. Possible positions for breaks are returned in an array of interger numbers. Each number is the position of the char in text after which a hyphenation can take place.

Návratové hodnoty

An array of integers indicating the position of possible breaks in the text or FALSE in case of an error.

Příklady

Příklad 1805. Hyphennate a text

<?php
$word = "Koordinatensystem";
$psdoc = ps_new();
ps_set_parameter($psdoc, "hyphendict", "hyph_de.dic");
$hyphens = ps_hyphenate($psdoc, $word);
for($i=0; $i<strlen($word); $i++) {
  echo $word[$i];
  if(in_array($i, $hyphens))
    echo "-";
}
ps_delete($psdoc);
?>

Výše uvedený příklad vypíše:

Ko-ordi-na-ten-sys-tem

Viz také

ps_show_boxed()
locale(1)

Předcházející | Nahoru | Další
ps_get_value | Domů | ps_include_file


ps_include_file

(PECL ps:1.3.4-1.3.5)

ps_include_file — Reads an external file with raw PostScript code

Popis

bool ps_include_file ( resource $psdoc, string $file )

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

file

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
ps_hyphenate | Domů | ps_lineto


ps_lineto

(PECL ps:1.1.0-1.3.5)

ps_lineto — Draws a line

Popis

bool ps_lineto ( resource $psdoc, float $x, float $y )

Adds a straight line from the current point to the given coordinates to the current path. Use ps_moveto() to set the starting point of the line.

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

x

x-coordinate of the end point of the line.

y

y-coordinate of the end point of the line.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1806. Drawing a rectangle

<?php
$ps = ps_new();
if (!ps_open_file($ps, "rectangle.ps")) {
  print "Cannot open PostScript file\n";
  exit;
}

ps_set_info($ps, "Creator", "rectangle.php");
ps_set_info($ps, "Author", "Uwe Steinmann");
ps_set_info($ps, "Title", "Lineto example");

ps_begin_page($ps, 596, 842);
ps_moveto($ps, 100, 100);
ps_lineto($ps, 100, 200);
ps_lineto($ps, 200, 200);
ps_lineto($ps, 200, 100);
ps_lineto($ps, 100, 100);
ps_stroke($ps);
ps_end_page($ps);

ps_delete($ps);
?>

Viz také

ps_moveto()

Předcházející | Nahoru | Další
ps_include_file | Domů | ps_makespotcolor


ps_makespotcolor

(PECL ps:1.1.0-1.3.5)

ps_makespotcolor — Create spot color

Popis

int ps_makespotcolor ( resource $psdoc, string $name [, float $reserved] )

Creates a spot color from the current fill color. The fill color must be defined in rgb, cmyk or gray colorspace. The spot color name can be an arbitrary name. A spot color can be set as any color with ps_setcolor(). When the document is not printed but displayed by an postscript viewer the given color in the specified color space is use.

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

name

Name of the spot color, e.g. Pantone 5565.

Návratové hodnoty

The id of the new spot color or 0 in case of an error.

Příklady

Příklad 1807. Creating and using a spot color

<?php
$ps = ps_new();
if (!ps_open_file($ps, "spotcolor.ps")) {
  print "Cannot open PostScript file\n";
  exit;
}

ps_set_info($ps, "Creator", "spotcolor.php");
ps_set_info($ps, "Author", "Uwe Steinmann");
ps_set_info($ps, "Title", "Spot color example");

ps_begin_page($ps, 596, 842);
ps_setcolor($ps, "fill", "cmyk", 0.37, 0.0, 0.34, 0.34);
$spotcolor = ps_makespotcolor($ps, "PANTONE 5565 C", 0);
ps_setcolor($ps, "fill", "spot", $spotcolor, 0.5, 0.0, 0.0);
ps_moveto($ps, 100, 100);
ps_lineto($ps, 100, 200);
ps_lineto($ps, 200, 200);
ps_lineto($ps, 200, 100);
ps_lineto($ps, 100, 100);
ps_fill($ps);
ps_end_page($ps);

ps_delete($ps);
?>

This example creates the spot color "PANTONE 5565 C" which is a darker green (olive) and fills a rectangle with 50% intensity.

Viz také

ps_setcolor()

Předcházející | Nahoru | Další
ps_lineto | Domů | ps_moveto


ps_moveto

(PECL ps:1.1.0-1.3.5)

ps_moveto — Sets current point

Popis

bool ps_moveto ( resource $psdoc, float $x, float $y )

Sets the current point to new coordinates. If this is the first call of ps_moveto() after a previous path has been ended then it will start a new path. If this function is called in the middle of a path it will just set the current point and start a subpath.

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

x

x-coordinate of the point to move to.

y

y-coordinate of the point to move to.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ps_lineto()

Předcházející | Nahoru | Další
ps_makespotcolor | Domů | ps_new


ps_new

(PECL ps:1.1.0-1.3.5)

ps_new — Creates a new PostScript document object

Popis

resource ps_new ( void )

Creates a new document instance. It does not create the file on disk or in memory, it just sets up everything. ps_new() is usually followed by a call of ps_open_file() to actually create the postscript document.

Návratové hodnoty

Resource of PostScript document or FALSE on failure. The return value is passed to all other functions as the first argument.

Viz také

ps_delete()

Předcházející | Nahoru | Další
ps_moveto | Domů | ps_open_file


ps_open_file

(PECL ps:1.1.0-1.3.5)

ps_open_file — Opens a file for output

Popis

bool ps_open_file ( resource $psdoc [, string $filename] )

Creates a new file on disk and writes the PostScript document into it. The file will be closed when ps_close() is called.

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

filename

The name of the postscript file. If filename is not passed the document will be created in memory and all output will go straight to the browser.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ps_close()

Předcházející | Nahoru | Další
ps_new | Domů | ps_open_image_file


ps_open_image

(PECL ps:1.1.0-1.3.5)

ps_open_image — Reads an image for later placement

Popis

int ps_open_image ( resource $psdoc, string $type, string $source, string $data, int $lenght, int $width, int $height, int $components, int $bpc, string $params )

Reads an image which is already available in memory. The parameter source is currently not evaluated and assumed to be memory. The image data is a sequence of pixels starting in th upper left corner and ending in the lower right corner. Each pixel consists of components color components, and each component has bpc bits.

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

type

The type of the image. Possible values are png, jpeg, or eps.

source

Not used.

data

The image data.

length

The length of the image data.

width

The width of the image.

height

The height of the image.

components

The number of components for each pixel. This can be 1 (gray scale images), 3 (rgb images), or 4 (cmyk, rgba images).

bpc

Number of bits per component (quite often 8).

params

Návratové hodnoty

Returns identifier of image or zero in case of an error. The identifier is a positive number greater than 0.

Viz také

ps_open_image_file()
ps_place_image()
ps_close_image()

Předcházející | Nahoru | Další
ps_open_image_file | Domů | ps_open_memory_image


ps_open_image_file

(PECL ps:1.1.0-1.3.5)

ps_open_image_file — Opens image from file

Popis

int ps_open_image_file ( resource $psdoc, string $type, string $filename [, string $stringparam [, int $intparam]] )

Loads an image for later use.

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

type

The type of the image. Possible values are png, jpeg, or eps.

filename

The name of the file containing the image data.

stringparam

Not used.

intparam

Not used.

Návratové hodnoty

Returns identifier of image or zero in case of an error. The identifier is a positive number greater than 0.

Viz také

ps_open_image()
ps_place_image()
ps_close_image()

Předcházející | Nahoru | Další
ps_open_file | Domů | ps_open_image


ps_open_memory_image

(PECL ps:1.1.0-1.3.5)

ps_open_memory_image — Takes an GD image and returns an image for placement in a PS document

Popis

int ps_open_memory_image ( resource $psdoc, int $gd )

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

gd

Předcházející | Nahoru | Další
ps_open_image | Domů | ps_place_image


ps_place_image

(PECL ps:1.1.0-1.3.5)

ps_place_image — Places image on the page

Popis

bool ps_place_image ( resource $psdoc, int $imageid, float $x, float $y, float $scale )

Places a formerly loaded image on the page. The image can be scaled. If the image shall be rotated as well, you will have to rotate the coordinate system before with ps_rotate().

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

imageid

The resource identifier of the image as returned by ps_open_image() or ps_open_image_file().

x

x-coordinate of the lower left corner of the image.

y

y-coordinate of the lower left corner of the image.

scale

The scaling factor for the image. A scale of 1.0 will result in a resolution of 72 dpi, because each pixel is equivalent to 1 point.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ps_open_image()
ps_open_image_file()

Předcházející | Nahoru | Další
ps_open_memory_image | Domů | ps_rect


ps_rect

(PECL ps:1.1.0-1.3.5)

ps_rect — Draws a rectangle

Popis

bool ps_rect ( resource $psdoc, float $x, float $y, float $width, float $height )

Draws a rectangle with its lower left corner at (x, y). The rectangle starts and ends in its lower left corner. If this function is called outside a path it will start a new path. If it is called within a path it will add the rectangle as a subpath. If the last drawing operation does not end in the lower left corner then there will be a gap in the path.

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

x

x-coordinate of the lower left corner of the rectangle.

y

y-coordinate of the lower left corner of the rectangle.

width

The width of the image.

height

The height of the image.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ps_arc()
ps_cirle()
ps_lineto()

Předcházející | Nahoru | Další
ps_place_image | Domů | ps_restore


ps_restore

(PECL ps:1.1.0-1.3.5)

ps_restore — Restore previously save context

Popis

bool ps_restore ( resource $psdoc )

Restores a previously saved graphics context. Any call of ps_save() must be accompanied by a call to ps_restore(). All coordinate transformations, line style settings, color settings, etc. are being restored to the state before the call of ps_save().

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ps_save()

Předcházející | Nahoru | Další
ps_rect | Domů | ps_rotate


ps_rotate

(PECL ps:1.1.0-1.3.5)

ps_rotate — Sets rotation factor

Popis

bool ps_rotate ( resource $psdoc, float $rot )

Sets the rotation of the coordinate system.

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

rot

Angle of rotation in degree.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1808. Rotation of the coordinate system

<?php
function rectangle($ps) {
    ps_moveto($ps, 0, 0);
    ps_lineto($ps, 0, 50);
    ps_lineto($ps, 50, 50);
    ps_lineto($ps, 50, 0);
    ps_lineto($ps, 0, 0);
    ps_stroke($ps);
}

$ps = ps_new();
if (!ps_open_file($ps, "rotation.ps")) {
  print "Cannot open PostScript file\n";
  exit;
}

ps_set_info($ps, "Creator", "rotation.php");
ps_set_info($ps, "Author", "Uwe Steinmann");
ps_set_info($ps, "Title", "Rotation example");
ps_set_info($ps, "BoundingBox", "0 0 596 842");

$psfont = ps_findfont($ps, "Helvetica", "", 0);

ps_begin_page($ps, 596, 842);
ps_set_text_pos($ps, 100, 100);
ps_save($ps);
ps_translate($ps, 100, 100);
ps_rotate($ps, 45);
rectangle($ps);
ps_restore($ps);
ps_setfont($ps, $psfont, 8.0);
ps_show($ps, "Text without rotation");
ps_end_page($ps);

ps_delete($ps);
?>

The above example illustrates a very common way of rotating a graphic (in this case just a rectangle) by simply rotating the coordinate system. Since the graphic's coordinate system assumes (0,0) to be the origin, the page coordinate system is also translated to place the graphics not on the edge of the page. Pay attention to the order of ps_translate() and ps_rotate(). In the above case the rectancle is rotated around the point (100, 100) in the untranslated coordinate system. Switching the two statements has a completely different result.

In order to output the following text at the original position, all modifications of the coordinate system are encapsulated in ps_save() and ps_restore().

Viz také

ps_scale()
ps_translate()

Předcházející | Nahoru | Další
ps_restore | Domů | ps_save


ps_save

(PECL ps:1.1.0-1.3.5)

ps_save — Save current context

Popis

bool ps_save ( resource $psdoc )

Saves the current graphics context, containing colors, translation and rotation settings and some more. A saved context can be restored with ps_restore().

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ps_restore()

Předcházející | Nahoru | Další
ps_rotate | Domů | ps_scale


ps_scale

(PECL ps:1.1.0-1.3.5)

ps_scale — Sets scaling factor

Popis

bool ps_scale ( resource $psdoc, float $x, float $y )

Sets horizontal and vertical scaling of the coordinate system.

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

x

Scaling factor in horizontal direction.

y

Scaling factor in vertical direction.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ps_rotate()
ps_translate()

Předcházející | Nahoru | Další
ps_save | Domů | ps_set_border_color


ps_set_border_color

(PECL ps:1.1.0-1.3.5)

ps_set_border_color — Sets color of border for annotations

Popis

bool ps_set_border_color ( resource $psdoc, float $red, float $green, float $blue )

Links added with one of the functions ps_add_weblink(), ps_add_pdflink(), etc. will be displayed with a surounded rectangle when the postscript document is converted to pdf and viewed in a pdf viewer. This rectangle is not visible in the postscript document. This function sets the color of the rectangle's border line.

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

red

The red component of the border color.

green

The green component of the border color.

blue

The blue component of the border color.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ps_set_border_dash()
ps_set_border_style()

Předcházející | Nahoru | Další
ps_scale | Domů | ps_set_border_dash


ps_set_border_dash

(PECL ps:1.1.0-1.3.5)

ps_set_border_dash — Sets length of dashes for border of annotations

Popis

bool ps_set_border_dash ( resource $psdoc, float $black, float $white )

Links added with one of the functions ps_add_weblink(), ps_add_pdflink(), etc. will be displayed with a surounded rectangle when the postscript document is converted to pdf and viewed in a pdf viewer. This rectangle is not visible in the postscript document. This function sets the length of the black and white portion of a dashed border line.

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

black

The length of the dash.

white

The length of the gap between dashes.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ps_set_border_color()
ps_set_border_style()

Předcházející | Nahoru | Další
ps_set_border_color | Domů | ps_set_border_style


ps_set_border_style

(PECL ps:1.1.0-1.3.5)

ps_set_border_style — Sets border style of annotations

Popis

bool ps_set_border_style ( resource $psdoc, string $style, float $width )

Links added with one of the functions ps_add_weblink(), ps_add_pdflink(), etc. will be displayed with a surounded rectangle when the postscript document is converted to pdf and viewed in a pdf viewer. This rectangle is not visible in the postscript document. This function sets the appearance and width of the border line.

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

style

style can be solid or dashed.

width

The line width of the border.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ps_set_border_color()
ps_set_border_dash()

Předcházející | Nahoru | Další
ps_set_border_dash | Domů | ps_set_info


ps_set_info

(PECL ps:1.1.0-1.3.5)

ps_set_info — Sets information fields of document

Popis

bool ps_set_info ( resource $p, string $key, string $val )

Sets certain information fields of the document. This fields will be shown as a comment in the header of the PostScript file. If the document is converted to pdf this fields will also be used for the document information.

The BoundingBox is usually set to the value given to the first page. This only works if ps_findfont() has not been called before. In such cases the BoundingBox would be left unset unless you set it explicitly with this function.

This function will have no effect anymore when the header of the postscript file has been already written. It must be called before the first page or the first call of ps_findfont().

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

key

The name of the information field to set. The values which can be set are Keywords, Subject, Title, Creator, Author, BoundingBox, and Orientation. Be aware that some of them has a meaning to PostScript viewers.

value

The value of the information field. The field Orientation can be set to either Portrait or Landscape. The BoundingBox is a string consisting of four numbers. The first two numbers are the coordinates of the lower left corner of the page. The last two numbers are the coordinates of the upper right corner.

Poznámka: Up to version 0.2.6 of pslib, the BoundingBox and Orientation will be overwritten by ps_begin_page(), unless ps_findfont() has been called before.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ps_findfont()
ps_begin_page()

Předcházející | Nahoru | Další
ps_set_border_style | Domů | ps_set_parameter


ps_set_parameter

(PECL ps:1.1.0-1.3.5)

ps_set_parameter — Sets certain parameters

Popis

bool ps_set_parameter ( resource $psdoc, string $name, string $value )

Sets several parameters which are used by many functions. Parameters are by definition string values.

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

name

For a list of possible names see ps_get_parameter().

value

The value of the parameter.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ps_get_parameters()
ps_set_value()

Předcházející | Nahoru | Další
ps_set_info | Domů | ps_set_text_pos


ps_set_text_pos

(PECL ps:1.1.0-1.3.5)

ps_set_text_pos — Sets position for text output

Popis

bool ps_set_text_pos ( resource $psdoc, float $x, float $y )

Set the position for the next text output. You may alternatively set the x and y value separately by calling ps_set_value() and choosing textx respectively texty as the value name.

If you want to output text at a certain position it is more convenient to use ps_show_xy() instead of setting the text position and calling ps_show().

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

x

x-coordinate of the new text position.

y

y-coordinate of the new text position.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1809. Placing text at a given position

<?php
$ps = ps_new();
if (!ps_open_file($ps, "text.ps")) {
  print "Cannot open PostScript file\n";
  exit;
}

ps_set_info($ps, "Creator", "rectangle.php");
ps_set_info($ps, "Author", "Uwe Steinmann");
ps_set_info($ps, "Title", "Text placement example");

ps_begin_page($ps, 596, 842);
$psfont = ps_findfont($ps, "Helvetica", "", 0);
ps_setfont($ps, $psfont, 8.0);
ps_show_xy($ps, "Some text at (100, 100)", 100, 100);

ps_set_value($ps, "textx", 100);
ps_set_value($ps, "texty", 120);
ps_show($ps, "Some text at (100, 120)");
ps_end_page($ps);

ps_delete($ps);
?>

Viz také

ps_set_value()
ps_show()

Předcházející | Nahoru | Další
ps_set_parameter | Domů | ps_set_value


ps_set_value

(PECL ps:1.1.0-1.3.5)

ps_set_value — Sets certain values

Popis

bool ps_set_value ( resource $psdoc, string $name, float $value )

Sets several values which are used by many functions. Parameters are by definition float values.

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

name

The name can be one of the following:

textrendering

The way how text is shown.

textx

The x coordinate for text output.

texty

The y coordinate for text output.

wordspacing

The distance between words relative to the width of a space.

leading

The distance between lines in pixels.

value

The value of the parameter.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ps_get_value()
ps_set_parameter()

Předcházející | Nahoru | Další
ps_set_text_pos | Domů | ps_setcolor


ps_setcolor

(PECL ps:1.1.0-1.3.5)

ps_setcolor — Sets current color

Popis

bool ps_setcolor ( resource $psdoc, string $type, string $colorspace, float $c1, float $c2, float $c3, float $c4 )

Sets the color for drawing, filling, or both.

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

type

The parameter type can be both, fill, or fillstroke.

colorspace

The colorspace should be one of gray, rgb, cmyk, spot, pattern. Depending on the colorspace either only the first, the first three or all parameters will be used.

c1

Depending on the colorspace this is either the red component (rgb), the cyan component (cmyk), the gray value (gray), the identifier of the spot color or the identifier of the pattern.

c2

Depending on the colorspace this is either the green component (rgb), the magenta component (cmyk).

c3

Depending on the colorspace this is either the blue component (rgb), the yellow component (cmyk).

c4

This must only be set in cmyk colorspace and specifies the black component.

Bugs

The second parameter is currently not always evaluated. The color is sometimes set for filling and drawing just as if fillstroke were passed.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
ps_set_value | Domů | ps_setdash


ps_setdash

(PECL ps:1.1.0-1.3.5)

ps_setdash — Sets appearance of a dashed line

Popis

bool ps_setdash ( resource $psdoc, float $on, float $off )

Sets the length of the black and white portions of a dashed line.

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

on

The length of the dash.

off

The length of the gap between dashes.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ps_setpolydash()

Předcházející | Nahoru | Další
ps_setcolor | Domů | ps_setflat


ps_setflat

(PECL ps:1.1.0-1.3.5)

ps_setflat — Sets flatness

Popis

bool ps_setflat ( resource $psdoc, float $value )

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

value

The value must be between 0.2 and 1.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
ps_setdash | Domů | ps_setfont


ps_setfont

(PECL ps:1.1.0-1.3.5)

ps_setfont — Sets font to use for following output

Popis

bool ps_setfont ( resource $psdoc, int $fontid, float $size )

Sets a font, which has to be loaded before with ps_findfont(). Outputting text without setting a font results in an error.

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

fontid

The font identifier as returned by ps_findfont().

size

The size of the font.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ps_findfont()
ps_set_text_pos() for an example.

Předcházející | Nahoru | Další
ps_setflat | Domů | ps_setgray


ps_setgray

(PECL ps:1.1.0-1.1.1)

ps_setgray — Sets gray value

Popis

bool ps_setgray ( resource $psdoc, float $gray )

Sets the gray value for all following drawing operations.

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

gray

The value must be between 0 (white) and 1 (black).

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ps_setcolor()

Předcházející | Nahoru | Další
ps_setfont | Domů | ps_setlinecap


ps_setlinecap

(PECL ps:1.1.0-1.3.5)

ps_setlinecap — Sets appearance of line ends

Popis

bool ps_setlinecap ( resource $psdoc, int $type )

Sets how line ends look like.

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

type

The type of line ends. Possible values are PS_LINECAP_BUTT, PS_LINECAP_ROUND, or PS_LINECAP_SQUARED.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ps_setlinejoin()
ps_setlinewidth()
ps_setmiterlimit()

Předcházející | Nahoru | Další
ps_setgray | Domů | ps_setlinejoin


ps_setlinejoin

(PECL ps:1.1.0-1.3.5)

ps_setlinejoin — Sets how contected lines are joined

Popis

bool ps_setlinejoin ( resource $psdoc, int $type )

Sets how lines are joined.

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

type

The way lines are joined. Possible values are PS_LINEJOIN_MITER, PS_LINEJOIN_ROUND, or PS_LINEJOIN_BEVEL.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ps_setlinecap()
ps_setlinewidth()
ps_setmiterlimit()

Předcházející | Nahoru | Další
ps_setlinecap | Domů | ps_setlinewidth


ps_setlinewidth

(PECL ps:1.1.0-1.3.5)

ps_setlinewidth — Sets width of a line

Popis

bool ps_setlinewidth ( resource $psdoc, float $width )

Sets the line width for all following drawing operations.

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

width

The width of lines in points.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ps_setlinecap()
ps_setlinejoin()
ps_setmiterlimit()

Předcházející | Nahoru | Další
ps_setlinejoin | Domů | ps_setmiterlimit


ps_setmiterlimit

(PECL ps:1.1.0-1.3.5)

ps_setmiterlimit — Sets the miter limit

Popis

bool ps_setmiterlimit ( resource $psdoc, float $value )

If two lines join in a small angle and the line join is set to PS_LINEJOIN_MITER, then the resulting spike will be very long. The miter limit is the maximum ratio of the miter length (the length of the spike) and the line width.

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

value

The maximum ratio between the miter length and the line width. Larger values (> 10) will result in very long spikes when two lines meet in a small angle. Keep the default unless you know what you are doing.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ps_setlinecap()
ps_setlinejoin()
ps_setlinewidth()

Předcházející | Nahoru | Další
ps_setlinewidth | Domů | ps_setoverprintmode


ps_setoverprintmode

(PECL ps:1.3.0-1.3.5)

ps_setoverprintmode — Sets overprint mode

Popis

bool ps_setoverprintmode ( resource $psdoc, int $mode )

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

mode

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
ps_setmiterlimit | Domů | ps_setpolydash


ps_setpolydash

(PECL ps:1.1.0-1.3.5)

ps_setpolydash — Sets appearance of a dashed line

Popis

bool ps_setpolydash ( resource $psdoc, float $arr )

Sets the length of the black and white portions of a dashed line. ps_setpolydash() is used to set more complicated dash patterns.

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

arr

arr is a list of length elements alternately for the black and white portion.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1810. Drawing a dashed line

<?php
$ps = ps_new();
if (!ps_open_file($ps, "polydash.ps")) {
   print "Cannot open PostScript file\n";
     exit;
}

ps_set_info($ps, "Creator", "polydash.php");
ps_set_info($ps, "Author", "Uwe Steinmann");
ps_set_info($ps, "Title", "Poly dash example");

ps_begin_page($ps, 596, 842);
ps_setpolydash($ps, array(10, 5, 2, 5));
ps_moveto($ps, 100, 100);
ps_lineto($ps, 200, 200);
ps_stroke($ps);
ps_end_page($ps);

ps_delete($ps);
?>

This example draws a line with a 10 and 2 points long line, and gaps of 5 points inbetween.

Viz také

ps_setdash()

Předcházející | Nahoru | Další
ps_setoverprintmode | Domů | ps_shading_pattern


ps_shading

(PECL ps:1.3.0-1.3.5)

ps_shading — Creates a shading for later use

Popis

int ps_shading ( resource $psdoc, string $type, float $x0, float $y0, float $x1, float $y1, float $c1, float $c2, float $c3, float $c4, string $optlist )

Creates a shading, which can be used by ps_shfill() or ps_shading_pattern().

The color of the shading can be in any color space except for pattern.

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

type

The type of shading can be either radial or axial. Each shading starts with the current fill color and ends with the given color values passed in the parameters c1 to c4 (see ps_setcolor() for their meaning).

x0, x1, y0, y1

The coordinates x0, y0, x1, y1 are the start and end point of the shading. If the type of shading is radial the two points are the middle points of a starting and ending circle.

c1, c2, c3, c4

See ps_setcolor() for their meaning.

optlist

If the shading is of type radial the optlist must also contain the parameters r0 and r1 with the radius of the start and end circle.

Návratové hodnoty

Returns the identifier of the pattern or FALSE in case of an error.

Viz také

ps_shading_pattern()
ps_shfill()

Předcházející | Nahoru | Další
ps_shading_pattern | Domů | ps_shfill


ps_shading_pattern

(PECL ps:1.3.0-1.3.5)

ps_shading_pattern — Creates a pattern based on a shading

Popis

int ps_shading_pattern ( resource $psdoc, int $shadingid, string $optlist )

Creates a pattern based on a shading, which has to be created before with ps_shading(). Shading patterns can be used like regular patterns.

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

shadingid

The identifier of a shading previously created with ps_shading().

optlist

This argument is not currently used.

Návratové hodnoty

The identifier of the pattern or FALSE in case of an error.

Viz také

ps_shading()
ps_shfill()

Předcházející | Nahoru | Další
ps_setpolydash | Domů | ps_shading


ps_shfill

(PECL ps:1.3.0-1.3.5)

ps_shfill — Fills an area with a shading

Popis

bool ps_shfill ( resource $psdoc, int $shadingid )

Fills an area with a shading, which has to be created before with ps_shading(). This is an alternative way to creating a pattern from a shading ps_shading_pattern() and using the pattern as the filling color.

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

shadingid

The identifier of a shading previously created with ps_shading().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ps_shading()
ps_shading_pattern()

Předcházející | Nahoru | Další
ps_shading | Domů | ps_show_boxed


ps_show

(PECL ps:1.1.0-1.3.5)

ps_show — Output text

Popis

bool ps_show ( resource $psdoc, string $text )

Output a text at the current text position. The text position can be set by storing the x and y coordinates into the values textx and texty with the function ps_set_value(). The function will issue an error if a font was not set before with ps_setfont().

ps_show() evaluates the following parameters and values as set by ps_set_parameter() and ps_set_value().

charspacing (value)

Distance between two consecutive glyphs. If this value is unequal to zero then all ligatures will be resolved. Values less than zero are allowed.

kerning (parameter)

Setting this parameter to "false" will turn off kerning. Kerning is turned on by default.

ligatures (parameter)

Setting this parameter to "false" will turn off the use of ligatures. Ligatures are turned on by default.

underline (parameter)

Setting this parameter to "true" will turn on underlining. Underlining is turned off by default.

overline (parameter)

Setting this parameter to "true" will turn on overlining. Overlining is turned off by default.

strikeout (parameter)

Setting this parameter to "true" will turn on striking out. Striking out is turned off by default.

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

text

The text to be output.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ps_continue_text()
ps_show_xy()
ps_setfont()

Předcházející | Nahoru | Další
ps_show2 | Domů | ps_string_geometry


ps_show2

(PECL ps:1.1.0-1.3.5)

ps_show2 — Output a text at current position

Popis

bool ps_show2 ( resource $psdoc, string $text, int $len )

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

text

len

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
ps_show_xy | Domů | ps_show


ps_show_boxed

(PECL ps:1.1.0-1.3.5)

ps_show_boxed — Output text in a box

Popis

int ps_show_boxed ( resource $psdoc, string $text, float $left, float $bottom, float $width, float $height, string $hmode [, string $feature] )

Outputs a text in a given box. The lower left corner of the box is at (left, bottom). Line breaks will be inserted where needed. Multiple spaces are treated as one. Tabulators are treated as spaces.

The text will be hyphenated if the parameter hyphenation is set to true and the parameter hyphendict contains a valid filename for a hyphenation file. The line spacing is taken from the value leading. Paragraphs can be separated by an empty line just like in TeX. If the value parindent is set to value > 0.0 then the first n lines will be indented. The number n of lines is set by the parameter numindentlines. In order to prevent indenting of the first m paragraphs set the value parindentskip to a positive number.

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

text

The text to be output into the given box.

left

x-coordinate of the lower left corner of the box.

bottom

y-coordinate of the lower left corner of the box.

width

Width of the box.

height

Height of the box.

hmode

The parameter hmode can be "justify", "fulljustify", "right", "left", or "center". The difference of "justify" and "fulljustify" just affects the last line of the box. In fulljustify mode the last line will be left and right justified unless this is also the last line of paragraph. In justify mode it will always be left justified.

feature

Used parameters

The output of ps_show_boxed() can be configured with several parameters and values which must be set with either ps_set_parameter() or ps_set_value(). Beside the parameters and values which affect text output, the following parameters and values are evaluated.

leading (value)

Distance between baselines of two consecutive lines.

linebreak (parameter)

Set to "true" if you want a carriage return to start a new line instead of treating it as a space. Defaults to "false".

parbreak (parameter)

Set to "true" if you want a carriage return on a single line to start a new paragraph instead of treating it as a space. Defaults to "true".

hyphenation (parameter)

Set to "true" in order to turn hyphenation on. This requires a dictionary to be set with the parameter "hyphendict". Defaults to "false".

hyphendict (parameter)

Filename of the dictionary used for hyphenation pattern (see below).

hyphenminchar (value)

The number of chars which must at least be left over before or after the hyphen. This implies that only words of at least two times this value will be hyphenated. The default value is three. Setting a value of zero will result in the default value.

parindent (value)

Set the amount of space in pixel for indenting the first m lines of a paragraph. m can be set with the value "numindentlines".

parskip (value)

Set the amount of extra space in pixel between paragraphs. Defaults to 0 which will result in a normal line distance.

numindentlines (value)

Number of lines from the start of the paragraph which will be indented. Defaults to 1.

parindentskip (value)

Number of paragraphs in the box whose first lines will not be indented. This defaults to 0. This is useful for paragraphs right after a section heading or text being continued in a second box. In both case one would set this to 1.

linenumbermode (parameter)

Set how lines are to be numbered. Possible values are "box" for numbering lines in the whole box or "paragraph" to number lines within each paragraph.

linenumberspace (value)

The space for the column left of the numbered line containing the line number. The line number will be right justified into this column. Defaults to 20.

linenumbersep (value)

The space between the column with line numbers and the line itself. Defaults to 5.

Hyphenation

Text is hyphenated if the parameter hyphenation is set to true and a valid hyphenation dictionary is set. pslib does not ship its own hyphenation dictionary but uses one from openoffice, scribus or koffice. You can find their dictionaries for different languages in one of the following directories if the software is installed:
/usr/share/apps/koffice/hyphdicts/
/usr/lib/scribus/dicts/
/usr/lib/openoffice/share/dict/ooo/
Currently scribus appears to have the most complete hyphenation dictionaries.

Návratové hodnoty

Number of characters that could not be written.

Viz také

ps_continue_text()

Předcházející | Nahoru | Další
ps_shfill | Domů | ps_show_xy2


ps_show_xy

(PECL ps:1.1.0-1.3.5)

ps_show_xy — Output text at given position

Popis

bool ps_show_xy ( resource $psdoc, string $text, float $x, float $y )

Output a text at the given text position.

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

text

The text to be output.

x

x-coordinate of the lower left corner of the box surrounding the text.

y

y-coordinate of the lower left corner of the box surrounding the text.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ps_continue_text()
ps_show()

Předcházející | Nahoru | Další
ps_show_xy2 | Domů | ps_show2


ps_show_xy2

(PECL ps:1.1.0-1.3.5)

ps_show_xy2 — Output text at position

Popis

bool ps_show_xy2 ( resource $psdoc, string $text, int $len, float $xcoor, float $ycoor )

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
ps_show_boxed | Domů | ps_show_xy


ps_string_geometry

(PECL ps:1.2.0-1.3.5)

ps_string_geometry — Gets geometry of a string

Popis

array ps_string_geometry ( resource $psdoc, string $text [, int $fontid [, float $size]] )

This function is similar to ps_stringwidth() but returns an array of dimensions containing the width, ascender, and descender of the text.

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

text

The text for which the geometry is to be calculated.

fontid

The identifier of the font to be used. If not font is specified the current font will be used.

size

The size of the font. If no size is specified the current size is used.

Návratové hodnoty

An array of the dimensions of a string. The element 'width' contains the width of the string as returned by ps_stringwidth(). The element 'descender' contains the maximum descender and 'ascender' the maximum ascender of the string.

Viz také

ps_continue_text()
ps_stringwidth()

Předcházející | Nahoru | Další
ps_show | Domů | ps_stringwidth


ps_stringwidth

(PECL ps:1.1.0-1.3.5)

ps_stringwidth — Gets width of a string

Popis

float ps_stringwidth ( resource $psdoc, string $text [, int $fontid [, float $size]] )

Calculates the width of a string in points if it was output in the given font and font size. This function needs an Adobe font metrics file to calculate the precise width. If kerning is turned on, it will be taken into account.

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

text

The text for which the width is to be calculated.

fontid

The identifier of the font to be used. If not font is specified the current font will be used.

size

The size of the font. If no size is specified the current size is used.

Návratové hodnoty

Width of a string in points.

Viz také

ps_string_geometry()

Předcházející | Nahoru | Další
ps_string_geometry | Domů | ps_stroke


ps_stroke

(PECL ps:1.1.0-1.3.5)

ps_stroke — Draws the current path

Popis

bool ps_stroke ( resource $psdoc )

Draws the path constructed with previously called drawing functions like ps_lineto().

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ps_closepath_stroke()
ps_fill()
ps_fill_stroke()

Předcházející | Nahoru | Další
ps_stringwidth | Domů | ps_symbol_name


ps_symbol

(PECL ps:1.2.0-1.3.5)

ps_symbol — Output a glyph

Popis

bool ps_symbol ( resource $psdoc, int $ord )

Output the glyph at position ord in the font encoding vector of the current font. The font encoding for a font can be set when loading the font with ps_findfont().

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

ord

The position of the glyph in the font encoding vector.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

ps_symbol_name()
ps_symbol_width()

Předcházející | Nahoru | Další
ps_symbol_width | Domů | ps_translate


ps_symbol_name

(PECL ps:1.2.0-1.3.5)

ps_symbol_name — Gets name of a glyph

Popis

string ps_symbol_name ( resource $psdoc, int $ord [, int $fontid] )

This function needs an Adobe font metrics file to know which glyphs are available.

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

ord

The parameter ord is the position of the glyph in the font encoding vector.

fontid

The identifier of the font to be used. If not font is specified the current font will be used.

Návratové hodnoty

The name of a glyph in the given font.

Viz také

ps_symbol()
ps_symbol_width()

Předcházející | Nahoru | Další
ps_stroke | Domů | ps_symbol_width


ps_symbol_width

(PECL ps:1.2.0-1.3.5)

ps_symbol_width — Gets width of a glyph

Popis

float ps_symbol_width ( resource $psdoc, int $ord [, int $fontid [, float $size]] )

Calculates the width of a glyph in points if it was output in the given font and font size. This function needs an Adobe font metrics file to calculate the precise width.

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

ord

The position of the glyph in the font encoding vector.

fontid

The identifier of the font to be used. If not font is specified the current font will be used.

size

The size of the font. If no size is specified the current size is used.

Návratové hodnoty

The width of a glyph in points.

Viz také

ps_symbol()
ps_symbol_name()

Předcházející | Nahoru | Další
ps_symbol_name | Domů | ps_symbol


ps_translate

(PECL ps:1.1.0-1.3.5)

ps_translate — Sets translation

Popis

bool ps_translate ( resource $psdoc, float $x, float $y )

Sets a new initial point of the coordinate system.

Seznam parametrů

psdoc

Resource identifier of the postscript file as returned by ps_new().

x

x-coordinate of the origin of the translated coordinate system.

y

y-coordinate of the origin of the translated coordinate system.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1811. Translation of the coordinate system

<?php
function rectangle($ps) {
    ps_moveto($ps, 0, 0);
    ps_lineto($ps, 0, 50);
    ps_lineto($ps, 50, 50);
    ps_lineto($ps, 50, 0);
    ps_lineto($ps, 0, 0);
    ps_stroke($ps);
}

$ps = ps_new();
if (!ps_open_file($ps, "translate.ps")) {
  print "Cannot open PostScript file\n";
  exit;
}

ps_set_info($ps, "Creator", "translate.php");
ps_set_info($ps, "Author", "Uwe Steinmann");
ps_set_info($ps, "Title", "Translated example");
ps_set_info($ps, "BoundingBox", "0 0 596 842");

$psfont = ps_findfont($ps, "Helvetica", "", 0);

ps_begin_page($ps, 596, 842);
ps_set_text_pos($ps, 100, 100);
ps_translate($ps, 500, 750);
rectangle($ps);
ps_translate($ps, -500, -750);
ps_setfont($ps, $psfont, 8.0);
ps_show($ps, "Text at initial position");
ps_end_page($ps);

ps_begin_page($ps, 596, 842);
ps_set_text_pos($ps, 100, 100);
ps_save($ps);
ps_translate($ps, 500, 750);
rectangle($ps);
ps_restore($ps);
ps_setfont($ps, $psfont, 8.0);
ps_show($ps, "Text at initial position");
ps_end_page($ps);

ps_delete($ps);
?>

The above example demonstrates two possible ways to place a graphic (in this case just a rectangle) at any position on the page, while the graphic itself uses its own coordinate system. The trick is to change the origin of the current coordinate system before drawing the rectangle. The translation has to undone after the graphic has been drawn.

On the second page a slightly different and more elegant approach is applied. Instead of undoing the translation with a second call of ps_translate() the graphics context is saved before modifying the coordinate system and restored after drawing the rectangle.

Viz také

ps_scale()
ps_rotate()

Předcházející | Nahoru | Další
ps_symbol | Domů | CXXXII. Pspell Functions


px_close

(PECL paradox:1.0-1.4.1)

px_close — Closes a paradox database

Popis

bool px_close ( resource $pxdoc )

Closes the paradox database. This function will not close the file. You will have to call fclose() afterwards.

Seznam parametrů

pxdoc

Resource identifier of the paradox database as returned by px_new().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

px_open_fp()
The example at px_new()

Předcházející | Nahoru | Další
CXVII. Paradox File Access | Domů | px_create_fp


px_create_fp

(PECL paradox:1.0-1.4.1)

px_create_fp — Create a new paradox database

Popis

bool px_create_fp ( resource $pxdoc, resource $file, array $fielddesc )

Create a new paradox database file. The actual file has to be opened before with fopen(). Make sure the file is writable.

Poznámka: Calling this functions issues a warning about an empty tablename which can be safely ignored. Just set the tablename afterwards with px_set_parameter().

Poznámka: This function is highly experimental, due to insufficient documentation of the paradox file format. Database files created with this function can be opened by px_open_fp() and has been successfully opened by the Paradox software, but your milage may vary.

Seznam parametrů

pxdoc

Resource identifier of the paradox database as returned by px_new().

file

File handle as returned by fopen().

fielddesc

fielddesc is an array containing one element for each field specification. A field specification is an array itself with either two or three elements.The first element is always a string value used as the name of the field. It may not be larger than ten characters. The second element contains the field type which is one of the constants listed in the table Constants for field types. In the case of a character field or bcd field, you will have to provide a third element specifying the length respectively the precesion of the field. If your field specification contains blob fields, you will have to make sure to either make the field large enough for all field values to fit or specify a blob file with px_set_blob_file() for storing the blobs. If this is not done the field data is truncated.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1503. Creating a Paradox database with two fields

<?php
if(!$pxdoc = px_new()) {
  /* Error handling */
}
$fp = fopen("test.db", "w+");
$fields = array(array("col1", "S"), array("col2", "I"));
if(!px_create_fp($pxdoc, $fp, $fields)) {
  /* Error handling */
}
px_set_parameter($pxdoc, "tablename", "testtable");
for($i=-50; $i<50; $i++) {
  $rec = array($i, -$i);
  px_put_record($pxdoc, $rec);
}
px_close($pxdoc);
px_delete($pxdoc);
fclose($fp);
?>

Viz také

px_new()
px_put_record()
fopen()

Předcházející | Nahoru | Další
px_close | Domů | px_date2string


px_date2string

(PECL paradox:1.4.0-1.4.1)

px_date2string — Converts a date into a string.

Popis

string px_date2string ( resource $pxdoc, int $value, string $format )

Turns a date as it stored in the paradox file into human readable format. Paradox dates are the number of days since 1.1.0000. This function is just for convenience. It can be easily replaced by some math and the calendar functions as demonstrated in the example below.

Seznam parametrů

pxdoc

Resource identifier of the paradox database as returned by px_new().

value

Value as stored in paradox database field of type PX_FIELD_DATE.

format

String format similar to the format used by date(). The placeholders support by this function is a subset of those supported by date() (Y, y, m, n, d, j, L).

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1504. Turn a paradox date into a human readable form

<?php
$px = px_new();

/* make up a date as it could be stored in */
/* a date field of a paradox db. */
/* 700000 days since 1.1.0000. */
$days = 700000;

/* Use the calendar functions to print a */
/* human readable format of the date */
echo jdtogregorian($days+1721425)."\n";
/* px_date2string() outputs the same */
echo px_date2string($px, $days, "n/d/Y")."\n";

px_delete($px);
?>

Výše uvedený příklad vypíše:

7/15/1917
7/15/1917

Viz také

px_timestamp2string()
jdtogregorian()

Předcházející | Nahoru | Další
px_create_fp | Domů | px_delete_record


px_delete

(PECL paradox:1.0-1.4.1)

px_delete — Deletes resource of paradox database

Popis

bool px_delete ( resource $pxdoc )

Deletes the resource of the paradox file and frees all memory.

Seznam parametrů

pxdoc

Resource identifier of the paradox database as returned by px_new().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
px_delete_record | Domů | px_get_field


px_delete_record

(PECL paradox:1.4.0-1.4.1)

px_delete_record — Deletes record from paradox database

Popis

bool px_delete_record ( resource $pxdoc, int $num )

This function deletes a record from the database. It does not free the space in the database file but just marks it as deleted. Inserting a new record afterwards will reuse the space.

Poznámka: This function is only available if pxlib >= 0.6.0 is used.

Seznam parametrů

pxdoc

Resource identifier of the paradox database as returned by px_new().

num

The record number is an artificial number counting records in the order as they are stored in the database. The first record has number 0.

Předcházející | Nahoru | Další
px_date2string | Domů | px_delete


px_get_field

(PECL paradox:1.0-1.4.1)

px_get_field — Returns the specification of a single field

Popis

array px_get_field ( resource $pxdoc, int $fieldno )

Seznam parametrů

pxdoc

Resource identifier of the paradox database as returned by px_new().

fieldno

Number of the field. The first field has number 0. Specifying a field number less than 0 and greater or equal the number of fields will trigger an error.

Návratové hodnoty

Returns the specification of the fieldno'th database field as an associated array. The array contains three fields named name, type, and size.

Předcházející | Nahoru | Další
px_delete | Domů | px_get_info


px_get_info

(PECL paradox:1.0-1.4.1)

px_get_info — Return lots of information about a paradox file

Popis

array px_get_info ( resource $pxdoc )

Seznam parametrů

pxdoc

Resource identifier of the paradox database as returned by px_new().

Návratové hodnoty

Returns an associated array with lots of information about a paradox file. This array is likely to be extended in the future.

fileversion

Version of file multiplied by 10, e.g. 70.

tablename

Name of table as stored in the file. If the database was created by pxlib, then this will be the name of the file without the extension.

numrecords

Number of records in this table.

numfields

Number of fields in this table.

headersize

Number of bytes used for the header. This is usually 0x800.

recordsize

Number of bytes used for each record. This is the sum of all field sizes (available since version 1.4.2).

maxtablesize

This value multiplied by 0x400 is the size of a data block in bytes. The maximum number of records in a datablock is the integer part of (maxtablesize * 0x400 - 8) / recordsize.

numdatablocks

The number of data blocks in the file. Each data block contains a certain number of records which depends on the record size and the data block size (maxtablesize). Data blocks may not necessarily be completely filled.

numindexfields

Number of fields used for the primary index. The fields do always start with field number 1.

codepage

The DOS codepage which was used for encoding fields with character data. If the target encoding is not set with px_set_targetencoding() this will be the encoding for character fields when records are being accessed with px_get_record() or px_retrieve_record().

Viz také

px_numfields()
px_numrecords()

Předcházející | Nahoru | Další
px_get_field | Domů | px_get_parameter


px_get_parameter

(PECL paradox:1.1.0-1.4.1)

px_get_parameter — Gets a parameter

Popis

string px_get_parameter ( resource $pxdoc, string $name )

Gets various parameters.

Seznam parametrů

pxdoc

Resource identifier of the paradox database as returned by px_new().

name

The name can be one of the following:

tablename

The name of the table as it will be stored in the database header.

targetencoding

The encoding for the output. Data which is being read from character fields with px_get_record() or px_retrieve_record() is recoded into the targetencoding. If it is not set, then the data will be delivered as stored in the database file.

inputencoding

The encoding of the input data which is to be stored into the database. When storing data of character fields in the database, the data is expected to be delivered in this encoding.

Návratové hodnoty

Returns the value of the parameter or FALSE on failure.

Předcházející | Nahoru | Další
px_get_info | Domů | px_get_record


px_get_record

(PECL paradox:1.0-1.4.1)

px_get_record — Returns record of paradox database

Popis

array px_get_record ( resource $pxdoc, int $num [, int $mode] )

Seznam parametrů

pxdoc

Resource identifier of the paradox database as returned by px_new().

num

The record number is an artificial number counting records in the order as they are stored in the database. The first record has number 0.

mode

The optional mode can be PX_KEYTOLOWER or PX_KEYTOUPPER in order to convert the keys of the returned array into lower or upper case. If mode is not passed or is 0, then the key will be exactly like the field name. The element values will contain the field values. NULL values will be retained and are different from 0.0, 0 or the empty string. Fields of type PX_FIELD_TIME will be returned as an integer counting the number of milliseconds starting at midnight. A timestamp (PX_FIELD_TIMESTAMP) and date (PX_FIELD_DATE) are floating point respectively int values counting milliseconds respectively days starting at the beginning of julian calendar. Use the functions px-timestamp2string() and px-date2string() to convert them into a character representation.

Návratové hodnoty

Returns the num'th record from the paradox database. The record is returned as an associated array with its keys being the field names.

Viz také

px_retrieve_record()

Předcházející | Nahoru | Další
px_get_parameter | Domů | px_get_schema


px_get_schema

(PECL paradox:1.0-1.4.1)

px_get_schema — Returns the database schema

Popis

array px_get_schema ( resource $pxdoc [, int $mode] )

px_get_schema() returns the database schema.

Seznam parametrů

pxdoc

Resource identifier of the paradox database as returned by px_new().

mode

If the optional mode is PX_KEYTOLOWER or PX_KEYTOUPPER the keys of the returned array will be converted to lower or upper case. If mode is 0 or not passed at all, then the key name will be identical to the field name.

Návratové hodnoty

Returns the schema of a database file as an associated array. The key name is equal to the field name. Each array element is itself an associated array containing the two fields type and size. type is one of the constants in table Constants for field types. size is the number of bytes this field consumes in the record. The total of all field sizes is equal to the record size as it can be retrieved with px-get-info().

Předcházející | Nahoru | Další
px_get_record | Domů | px_get_value


px_get_value

(PECL paradox:1.1.0-1.4.1)

px_get_value — Gets a value

Popis

float px_get_value ( resource $pxdoc, string $name )

Gets various values.

Seznam parametrů

pxdoc

Resource identifier of the paradox database as returned by px_new().

name

name can be one of the following.

numprimkeys

The number of primary keys. Paradox databases always use the first numprimkeys fields for the primary index.

Návratové hodnoty

Returns the value of the parameter or FALSE on failure.

Předcházející | Nahoru | Další
px_get_schema | Domů | px_insert_record


px_insert_record

(PECL paradox:1.4.0-1.4.1)

px_insert_record — Inserts record into paradox database

Popis

int px_insert_record ( resource $pxdoc, array $data )

Inserts a new record into the database. The record is not necessarily inserted at the end of the database, but may be inserted at any position depending on where the first free slot is found.

The record data is passed as an array of field values. The elements in the array must correspond to the fields in the database. If the array has less elements than fields in the database, the remaining fields will be set to null.

Most field values can be passed as its equivalent php type e.g. a long value is used for fields of type PX_FIELD_LONG, PX_FIELD_SHORT and PX_FIELD_AUTOINC, a double values is used for fields of type PX_FIELD_CURRENCY and PX_FIELD_NUMBER. Field values for blob and alpha fields are passed as strings.

Fields of type PX_FIELD_TIME and PX_FIELD_DATE both require a long value. In the first case this is the number of milliseconds since midnight. In the second case this is the number of days since 1.1.0000. Below there are two examples to convert the current date or timestamp into a value suitable for one of paradox's date/time fields.

Poznámka: This function is only available if pxlib >= 0.6.0 is used.

Seznam parametrů

pxdoc

Resource identifier of the paradox database as returned by px_new().

data

Associated or indexed array containing the field values as e.g. returned by px_retrieve_record().

Návratové hodnoty

Returns FALSE on failure or the record number in case of success.

Příklady

Příklad 1505. Set the date/time fields in a paradox database to the current date/time

<?php
$px = px_new();
$fp = fopen("test.db", "w+");
px_create_fp($px, $fp, array(array("timestamp", "@"), array("time", "T"), array("date", "D")));

$curdate = getdate();
$jd = gregoriantojd($curdate["mon"], $curdate["mday"], $curdate["year"]);
$days = $jd - 1721425; /* Number of days between 1.1.4714 b.c. and 1.1.0000 */
$secs = $curdate["hours"]*3600 + $curdate["minutes"]*60 + $curdate["seconds"];
px_insert_record($px, array($days*86400000.0 + $secs*1000.0, $secs*1000.0, $days));

$curtimestamp = microtime(true);
$days = (int) ($curtimestamp/86400);
$secs = $curtimestamp - ($days * 86400.0);
$days += 2440588; /* Number of days between 1.1.4714 b.c. and 1.1.1970 */
$days -= 1721425; /* Number of days between 1.1.4714 b.c. and 1.1.0000 */
px_insert_record($px, array($days*86400000.0 + $secs*1000.0, $secs*1000.0, $days));
for($i=0; $i<2; $i++) {
    $rec = px_retrieve_record($px, $i);
    echo px_timestamp2string($px, $rec["timestamp"], "n/d/Y H:i:s")."\n";
    echo px_date2string($px, $rec["date"], "n/d/Y")."\n";
}
px_close($px);
px_delete($px);
?>

Výše uvedený příklad vypíše:

2/21/2006 21:42:30
2/21/2006
2/21/2006 20:42:30
2/21/2006

The Julian day count as passed to jdtogregorian() has a different base of 1.1.4714 b.c. and must therefore be calculated by adding 1721425 to the day count used in the paradox file. Turning the day count into a timestamp is easily done by multiplying with 86400000.0 to obtain milli seconds.

Viz také

px_update_record()

Předcházející | Nahoru | Další
px_get_value | Domů | px_new


px_new

(PECL paradox:1.0-1.4.1)

px_new — Create a new paradox object

Popis

resource px_new ( void )

Create a new paradox object. You will have to call this function before any further functions. px_new() does not create any file on the disk, it just creates an instance of a paradox object. This function must not be called if the object oriented interface is used. Use new paradox_db() instead.

Návratové hodnoty

Returns FALSE on failure.

Příklady

Příklad 1506. Opening a Paradox database

<?php
if(!$pxdoc = px_new()) {
  /* Error handling */
}
$fp = fopen("test.db", "r");
if(!px_open_fp($pxdoc, $fp)) {
  /* Error handling */
}
// ...
px_close($pxdoc);
px_delete($pxdoc);
fclose($fp);
?>

If you prefer the object oriented API, then the above example will look like the following.

Příklad 1507. Opening a Paradox database

<?php
$fp = fopen("test.db", "r");
$pxdoc = new paradox_db();
if(!$pxdoc->open_fp($fp)) {
  /* Error handling */
}
// ...
$pxdoc->close();
fclose($fp);
?>

Viz také

px_delete()
px_open_fp()

Předcházející | Nahoru | Další
px_insert_record | Domů | px_numfields


px_numfields

(PECL paradox:1.0-1.4.1)

px_numfields — Returns number of fields in a database

Popis

int px_numfields ( resource $pxdoc )

Get the number of fields in a database file.

Seznam parametrů

pxdoc

Resource identifier of the paradox database as returned by px_new().

Návratové hodnoty

Returns the number of fields in a database file. The return value of this function is identical to the element numfields in the array returned by px_get_info().

Předcházející | Nahoru | Další
px_new | Domů | px_numrecords


px_numrecords

(PECL paradox:1.0-1.4.1)

px_numrecords — Returns number of records in a database

Popis

int px_numrecords ( resource $pxdoc )

Get the number of records in a database file.

Seznam parametrů

pxdoc

Resource identifier of the paradox database as returned by px_new().

Návratové hodnoty

Returns the number of records in a database file. The return value of this function is identical to the element numrecords in the array returned by px_get_info().

Předcházející | Nahoru | Další
px_numfields | Domů | px_open_fp


px_open_fp

(PECL paradox:1.0-1.4.1)

px_open_fp — Open paradox database

Popis

bool px_open_fp ( resource $pxdoc, resource $file )

Open an existing paradox database file. The actual file has to be opened before with fopen(). This function can also be used to open primary index files and tread them like a paradox database. This is supported for those who would like to investigate a primary index. It cannot be used to accelerate access to a database file.

Seznam parametrů

pxdoc

Resource identifier of the paradox database as returned by px_new().

file

file is the return value from fopen() with the actual database file as parameter. Make sure the database is writable if you plan to update or insert records.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

fopen()
The example at px_new()

Předcházející | Nahoru | Další
px_numrecords | Domů | px_put_record


px_put_record

(PECL paradox:1.0-1.4.1)

px_put_record — Stores record into paradox database

Popis

bool px_put_record ( resource $pxdoc, array $record [, int $recpos] )

Stores a record into a paradox database. The record is always added at the end of the database, regardless of any free slots. Use px_insert_record() to add a new record into the first free slot found in the database.

Seznam parametrů

pxdoc

Resource identifier of the paradox database as returned by px_new().

record

Associated or indexed array containing the field values as e.g. returned by px_retrieve_record().

recpos

This optional parameter may be used to specify a record number greater than the current number of records in the database. The function will add as many empty records as needed. There is hardly any need for this parameter.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
px_open_fp | Domů | px_retrieve_record


px_retrieve_record

(PECL paradox:1.4.0-1.4.1)

px_retrieve_record — Returns record of paradox database

Popis

array px_retrieve_record ( resource $pxdoc, int $num [, int $mode] )

This function is very similar to px_get_record() but uses internally a different approach to retrieve the data. It relies on pxlib for reading each single field value, which usually results in support for more field types.

Poznámka: This function is only available if pxlib >= 0.6.0 is used.

Seznam parametrů

pxdoc

Resource identifier of the paradox database as returned by px_new().

num

The record number is an artificial number counting records in the order as they are stored in the database. The first record has number 0.

mode

The optional mode can be PX_KEYTOLOWER or PX_KEYTOUPPER in order to convert the keys into lower or upper case. If mode is not passed or is 0, then the key will be exactly like the field name. The element values will contain the field values. NULL values will be retained and are different from 0.0, 0 or the empty string. Fields of type PX_FIELD_TIME will be returned as an integer counting the number of milliseconds starting at midnight. A timestamp is a floating point value also counting milliseconds starting at the beginning of julian calendar.

Návratové hodnoty

Returns the num'th record from the paradox database. The record is returned as an associated array with its keys being the field names.

Viz také

px_get_record()

Předcházející | Nahoru | Další
px_put_record | Domů | px_set_blob_file


px_set_blob_file

(PECL paradox:1.3.0-1.4.1)

px_set_blob_file — Sets the file where blobs are read from

Popis

bool px_set_blob_file ( resource $pxdoc, string $filename )

Sets the name of the file where blobs are going to be read from or written into. Without calling this function, px_get_record() or px_retrieve_record() will only return data in blob fields if the data is part of the record and not stored in the blob file. Blob data is stored in the record if it is small enough to fit in the size of the blob field.

Calling px_put_record(),
px_insert_record(), or
px_update_record() without calling
px_set_blob_file() will result in truncated blob fields
unless the data fits into the database file.

Calling this function twice will close the first blob file and open the new one.

Seznam parametrů

pxdoc

Resource identifier of the paradox database as returned by px_new().

filename

The name of the file. Its extension should be .MB.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
px_retrieve_record | Domů | px_set_parameter


px_set_parameter

(PECL paradox:1.1.0-1.4.1)

px_set_parameter — Sets a parameter

Popis

bool px_set_parameter ( resource $pxdoc, string $name, string $value )

Sets various parameters.

Seznam parametrů

pxdoc

Resource identifier of the paradox database as returned by px_new().

name

Depending on the parameter you want to set, name can be one of the following.

tablename

The name of the table as it will be stored in the database header.

targetencoding

The encoding for the output. Data which is being read from character fields is recoded into the targetencoding.

inputencoding

The encoding of the input data which is to be stored into the database.

value

The value of parameter to set. For inputencoding and targetencoding this must be the name of the encoding as understood by iconv or recode, e.g. iso-8859-1, utf-8, cp850.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

px_get_info() to determine the DOS code page.

Předcházející | Nahoru | Další
px_set_blob_file | Domů | px_set_tablename


px_set_tablename

(PECL paradox:1.0-1.4.1)

px_set_tablename — Sets the name of a table (deprecated)

Popis

void px_set_tablename ( resource $pxdoc, string $name )

Sets the table name of a paradox database, which was created with px_create_fp(). This function is deprecated use px_set_parameter() instead.

Seznam parametrů

pxdoc

Resource identifier of the paradox database as returned by px_new().

tablename

The name of the table. If it is not set explicitly it will be set to the name of the database file.

Návratové hodnoty

Returns NULL on success or FALSE on failure.

Viz také

px_set_parameter()

Předcházející | Nahoru | Další
px_set_parameter | Domů | px_set_targetencoding


px_set_targetencoding

(PECL paradox:1.0-1.4.1)

px_set_targetencoding — Sets the encoding for character fields (deprecated)

Popis

bool px_set_targetencoding ( resource $pxdoc, string $encoding )

Set the encoding for data retrieved from a character field. All character fields will be recoded to the encoding set by this function. If the encoding is not set, the character data will be returned in the DOS code page encoding as specified in the database file. The encoding can be any string identifier known to iconv or recode. On Unix systems run iconv -l for a list of available encodings.

This function is deprecated and should be replaced by calling px_set_parameter().

See also px_get_info() to determine the DOS code page as stored in the database file.

Seznam parametrů

pxdoc

Resource identifier of the paradox database as returned by px_new().

encoding

The encoding for the output. Data which is being read from character fields is recoded into the targetencoding.

Návratové hodnoty

Returns FALSE if the encoding could not be set, e.g. the encoding is unknown, or pxlib does not support recoding at all. In the second case a warning will be issued.

Viz také

px_set_parameter()

Předcházející | Nahoru | Další
px_set_tablename | Domů | px_set_value


px_set_value

(PECL paradox:1.1.0-1.4.1)

px_set_value — Sets a value

Popis

bool px_set_value ( resource $pxdoc, string $name, float $value )

Sets various values.

Seznam parametrů

pxdoc

Resource identifier of the paradox database as returned by px_new().

name

name can be one of the following.

numprimkeys

The number of primary keys. Paradox databases always use the first numprimkeys fields for the primary index.

value

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

px_set_parameter()

Předcházející | Nahoru | Další
px_set_targetencoding | Domů | px_timestamp2string


px_timestamp2string

(PECL paradox:1.4.0-1.4.1)

px_timestamp2string — Converts the timestamp into a string.

Popis

string px_timestamp2string ( resource $pxdoc, float $value, string $format )

Turns a timestamp as it stored in the paradox file into human readable format. Paradox timestamps are the number of milliseconds since 1.1.0000. This function is just for convenience. It can be easily replaced by some math and the calendar functions as demonstrated in the following example.

Seznam parametrů

pxdoc

Resource identifier of the paradox database.

value

Value as stored in paradox database field of type PX_FIELD_TIME, or PX_FIELD_TIMESTAMP.

format

String format similar to the format used by date(). The placeholders support by this function is a subset of those supported by date() (Y, y, m, n, d, j, H, h, G, g, i, s, A, a, L).

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1508. Turn a paradox timestamp into a human readable form

<?php
$px = px_new();

/* make up a date as it could be stored in */
/* a date field of a paradox db. */
/* 700000 days since 1.1.0000. */
$days = 700000;

/* Use the calendar functions to print a */
/* human readable format of the date */
echo jdtogregorian($days+1721425)."\n";

/* Turn it into a timestamp as it stored in a paradox database */
/* Timestamps are stored in milli seconds since 1.1.0000 */
$stamp = $days * 86400.0 * 1000.0;
/* Add one hour */
$stamp += 3600000.0;
/* The following will output '7/15/1917 01:00:00'. */
echo px_timestamp2string($px, $stamp, "n/d/Y H:i:s")."\n";

px_delete($px);
?>

Výše uvedený příklad vypíše:

7/15/1917
7/15/1917 01:00:00

The Julian day count as passed to jdtogregorian() has a different base of 1.1.4714 b.c. and must therefore be calculated by adding 1721425 to the day count used in the paradox file. Turning the day count into a timestamp is easily done by multiplying with 86400000.0 to obtain milli seconds.

Viz také

px_date2string()
jdtogregorian()

Předcházející | Nahoru | Další
px_set_value | Domů | px_update_record


px_update_record

(PECL paradox:1.4.0-1.4.1)

px_update_record — Updates record in paradox database

Popis

bool px_update_record ( resource $pxdoc, array $data, int $num )

Updates an exiting record in the database. The record starts at 0.

The record data is passed as an array of field values. The elements in the array must correspond to the fields in the database. If the array has less elements than fields in the database, the remaining fields will be set to null.

Poznámka: This function is only available if pxlib >= 0.6.0 is used.

Seznam parametrů

pxdoc

Resource identifier of the paradox database as returned by px_new().

data

Associated array containing the field values as returned by px_retrieve_record().

num

The record number is an artificial number counting records in the order as they are stored in the database. The first record has number 0.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

px_insert_record()

Předcházející | Nahoru | Další
px_timestamp2string | Domů | CXVIII. Parsekit Functions


radius_acct_open

(PECL radius:1.1-1.2.5)

radius_acct_open — Creates a Radius handle for accounting

Popis

resource radius_acct_open ( void )

Návratové hodnoty

Returns a handle on success, FALSE on error. This function only fails if insufficient memory is available.

Příklady

Příklad 1827. radius_acct_open() example

<?php
$res = radius_acct_open ()
    or die ("Could not create handle");
print("Handle successfully created");
?>

Předcházející | Nahoru | Další
CXXXIV. Radius | Domů | radius_add_server


radius_add_server

(PECL radius:1.1-1.2.5)

radius_add_server — Adds a server

Popis

bool radius_add_server ( resource $radius_handle, string $hostname, int $port, string $secret, int $timeout, int $max_tries )

radius_add_server() may be called multiple times, and it may be used together with radius_config(). At most 10 servers may be specified. When multiple servers are given, they are tried in round-robin fashion until a valid response is received, or until each server's max_tries limit has been reached.

Seznam parametrů

radius_handle

hostname

The hostname parameter specifies the server host, either as a fully qualified domain name or as a dotted-quad IP address in text form.

port

The port specifies the UDP port to contact on the server. If port is given as 0, the library looks up the radius/udp or radacct/udp service in the network services database, and uses the port found there. If no entry is found, the library uses the standard Radius ports, 1812 for authentication and 1813 for accounting.

secret

The shared secret for the server host is passed to the secret parameter. The Radius protocol ignores all but the leading 128 bytes of the shared secret.

timeout

The timeout for receiving replies from the server is passed to the timeout parameter, in units of seconds.

max_tries

The maximum number of repeated requests to make before giving up is passed into the max_tries.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1828. radius_add_server() example

<?php
if (!radius_add_server($res, 'radius.example.com', 1812, 'testing123', 3, 3)) {
    echo 'RadiusError:' . radius_strerror($res). "\n<br>";
    exit;
}
?>

Viz také

radius_config()

Předcházející | Nahoru | Další
radius_acct_open | Domů | radius_auth_open


radius_auth_open

(PECL radius:1.1-1.2.5)

radius_auth_open — Creates a Radius handle for authentication

Popis

resource radius_auth_open ( void )

Návratové hodnoty

Returns a handle on success, FALSE on error. This function only fails if insufficient memory is available.

Příklady

Příklad 1829. radius_auth_open() example

<?php
$radh = radius_auth_open()
    or die ("Could not create handle");
echo "Handle successfully created";
?>

Předcházející | Nahoru | Další
radius_add_server | Domů | radius_close


radius_close

(PECL radius:1.1-1.2.5)

radius_close — Frees all ressources

Popis

bool radius_close ( resource $radius_handle )

It is not needed to call this function because php frees all resources at the end of each request.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
radius_auth_open | Domů | radius_config


radius_config

(PECL radius:1.1-1.2.5)

radius_config — Causes the library to read the given configuration file

Popis

bool radius_config ( resource $radius_handle, string $file )

Before issuing any Radius requests, the library must be made aware of the servers it can contact. The easiest way to configure the library is to call radius_config(). radius_config() causes the library to read a configuration file whose format is described in » radius.conf.

Seznam parametrů

radius_handle

file

The pathname of the configuration file is passed as the file argument to radius_config(). The library can also be configured programmatically by calls to radius_add_server().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

radius_add_server()

Předcházející | Nahoru | Další
radius_close | Domů | radius_create_request


radius_create_request

(PECL radius:1.1-1.2.5)

radius_create_request — Create accounting or authentication request

Popis

bool radius_create_request ( resource $radius_handle, int $type )

A Radius request consists of a code specifying the kind of request, and zero or more attributes which provide additional information. To begin constructing a new request, call radius_create_request().

Poznámka: Attention: You must call this function, before you can put any attribute!

Seznam parametrů

radius_handle

Type is RADIUS_ACCESS_REQUEST or RADIUS_ACCOUNTING_REQUEST.

type

Its description

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1830. radius_create_request() example

<?php
if (!radius_create_request($res, RADIUS_ACCESS_REQUEST)) {
    echo 'RadiusError:' . radius_strerror($res). "\n<br />";
    exit;
}
?>

Viz také

radius_send_request()

Předcházející | Nahoru | Další
radius_config | Domů | radius_cvt_addr


radius_cvt_addr

(PECL radius:1.1-1.2.5)

radius_cvt_addr — Converts raw data to IP-Address

Popis

string radius_cvt_addr ( string $data )

Příklady

Příklad 1831. radius_cvt_addr() example

<?php
while ($resa = radius_get_attr($res)) {

    if (!is_array($resa)) {
        printf ("Error getting attribute: %s\n",  radius_strerror($res));
        exit;
    }

    $attr = $resa['attr'];
    $data = $resa['data'];

    switch ($attr) {

    case RADIUS_FRAMED_IP_ADDRESS:
        $ip = radius_cvt_addr($data);
        echo "IP: $ip<br>\n";
        break;

    case RADIUS_FRAMED_IP_NETMASK:
        $mask = radius_cvt_addr($data);
        echo "MASK: $mask<br>\n";
        break;
    }
}
?>

Viz také

radius_cvt_int()
radius_cvt_string()

Předcházející | Nahoru | Další
radius_create_request | Domů | radius_cvt_int


radius_cvt_int

(PECL radius:1.1-1.2.5)

radius_cvt_int — Converts raw data to integer

Popis

int radius_cvt_int ( string $data )

Příklady

Příklad 1832. radius_cvt_int() example

<?php
while ($resa = radius_get_attr($res)) {

    if (!is_array($resa)) {
        printf ("Error getting attribute: %s\n",  radius_strerror($res));
        exit;
    }

    $attr = $resa['attr'];
    $data = $resa['data'];

    switch ($attr) {

    case RADIUS_FRAMED_MTU:
        $mtu = radius_cvt_int($data);
        echo "MTU: $mtu<br>\n";
        break;
    }
}
?>

Viz také

radius_cvt_addr()
radius_cvt_string()

Předcházející | Nahoru | Další
radius_cvt_addr | Domů | radius_cvt_string


radius_cvt_string

(PECL radius:1.1-1.2.5)

radius_cvt_string — Converts raw data to string

Popis

string radius_cvt_string ( string $data )

Příklady

Příklad 1833. radius_cvt_string() example

<?php
while ($resa = radius_get_attr($res)) {

    if (!is_array($resa)) {
        printf ("Error getting attribute: %s\n",  radius_strerror($res));
        exit;
    }

    $attr = $resa['attr'];
    $data = $resa['data'];

    switch ($attr) {

    case RADIUS_FILTER_ID:
        $id = radius_cvt_string($data);
        echo "Filter ID: $id<br>\n";
        break;
    }
}
?>

Viz také

radius_cvt_addr()
radius_cvt_int()

Předcházející | Nahoru | Další
radius_cvt_int | Domů | radius_demangle_mppe_key


radius_demangle

(PECL radius:1.2-1.2.5)

radius_demangle — Demangles data

Popis

string radius_demangle ( resource $radius_handle, string $mangled )

Some data (Passwords, MS-CHAPv1 MPPE-Keys) is mangled for security reasons, and must be demangled before you can use them.

Návratové hodnoty

Returns the demangled string, or FALSE on error.

Předcházející | Nahoru | Další
radius_demangle_mppe_key | Domů | radius_get_attr


radius_demangle_mppe_key

(PECL radius:1.2-1.2.5)

radius_demangle_mppe_key — Derives mppe-keys from mangled data

Popis

string radius_demangle_mppe_key ( resource $radius_handle, string $mangled )

When using MPPE with MS-CHAPv2, the send- and recv-keys are mangled (see » RFC 2548), however this function is useless, because I don't think that there is or will be a PPTP-MPPE implementation in PHP.

Návratové hodnoty

Returns the demangled string, or FALSE on error.

Předcházející | Nahoru | Další
radius_cvt_string | Domů | radius_demangle


radius_get_attr

(PECL radius:1.1-1.2.5)

radius_get_attr — Extracts an attribute

Popis

mixed radius_get_attr ( resource $radius_handle )

Like Radius requests, each response may contain zero or more attributes. After a response has been received successfully by radius_send_request(), its attributes can be extracted one by one using radius_get_attr(). Each time radius_get_attr() is called, it gets the next attribute from the current response.

Návratové hodnoty

Returns an associative array containing the attribute-type and the data, or error number <= 0.

Příklady

Příklad 1834. radius_get_attr() example

<?php
while ($resa = radius_get_attr($res)) {

    if (!is_array($resa)) {
        printf("Error getting attribute: %s\n",  radius_strerror($res));
        exit;
    }

    $attr = $resa['attr'];
    $data = $resa['data'];
    printf("Got Attr:%d %d Bytes %s\n", $attr, strlen($data), bin2hex($data));
}
?>

Viz také

radius_put_attr()
radius_get_vendor_attr()
radius_put_vendor_attr()
radius_send_request()

Předcházející | Nahoru | Další
radius_demangle | Domů | radius_get_vendor_attr


radius_get_vendor_attr

(PECL radius:1.1-1.2.5)

radius_get_vendor_attr — Extracts a vendor specific attribute

Popis

array radius_get_vendor_attr ( string $data )

If radius_get_attr() returns RADIUS_VENDOR_SPECIFIC, radius_get_vendor_attr() may be called to determine the vendor.

Návratové hodnoty

Returns an associative array containing the attribute-type, vendor and the data, or FALSE on error.

Příklady

Příklad 1835. radius_get_vendor_attr() example

<?php
while ($resa = radius_get_attr($res)) {

    if (!is_array($resa)) {
        printf ("Error getting attribute: %s\n",  radius_strerror($res));
        exit;
    }

    $attr = $resa['attr'];
    $data = $resa['data'];
    printf("Got Attr:%d %d Bytes %s\n", $attr, strlen($data), bin2hex($data));
    if ($attr == RADIUS_VENDOR_SPECIFIC) {

        $resv = radius_get_vendor_attr($data);
        if (is_array($resv)) {
            $vendor = $resv['vendor'];
            $attrv = $resv['attr'];
            $datav = $resv['data'];
            printf("Got Vendor Attr:%d %d Bytes %s\n", $attrv, strlen($datav), bin2hex($datav));
        }

    }
}
?>

Viz také

radius_get_attr()
radius_put_vendor_attr()

Předcházející | Nahoru | Další
radius_get_attr | Domů | radius_put_addr


radius_put_addr

(PECL radius:1.1-1.2.5)

radius_put_addr — Attaches an IP-Address attribute

Popis

bool radius_put_addr ( resource $radius_handle, int $type, string $addr )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
radius_get_vendor_attr | Domů | radius_put_attr


radius_put_attr

(PECL radius:1.1-1.2.5)

radius_put_attr — Attaches a binary attribute

Popis

bool radius_put_attr ( resource $radius_handle, int $type, string $value )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1836. radius_put_attr() example

<?php
mt_srand(time());
$chall = mt_rand();
$chapval = md5(pack('Ca*',1 , 'sepp' . $chall));
$pass = pack('CH*', 1, $chapval);
if (!radius_put_attr($res, RADIUS_CHAP_PASSWORD, $pass)) {
    echo 'RadiusError:' . radius_strerror($res). "\n<br />";
    exit;
}
?>

Viz také

radius_get_attr()
radius_get_vendor_attr()
radius_put_vendor_attr()

Předcházející | Nahoru | Další
radius_put_addr | Domů | radius_put_int


radius_put_int

(PECL radius:1.1-1.2.5)

radius_put_int — Attaches an integer attribute

Popis

bool radius_put_int ( resource $radius_handle, int $type, int $value )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1837. radius_put_int() example

<?php
if (!radius_put_int($res, RAD_FRAMED_PROTOCOL, RAD_PPP)) {
   echo 'RadiusError:' . radius_strerror($res). "\n<br />";
   exit;
}
?>

Viz také

radius_put_string()
radius_put_vendor_int()
radius_put_vendor_string()

Předcházející | Nahoru | Další
radius_put_attr | Domů | radius_put_string


radius_put_string

(PECL radius:1.1-1.2.5)

radius_put_string — Attaches a string attribute

Popis

bool radius_put_string ( resource $radius_handle, int $type, string $value )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1838. radius_put_string() example

<?php
if (!radius_put_string($res, RADIUS_USER_NAME, 'billy')) {
    echo 'RadiusError:' . radius_strerror($res). "\n<br />";
    exit;
}
?>

Viz také

radius_put_int()
radius_put_vendor_int()
radius_put_vendor_string()

Předcházející | Nahoru | Další
radius_put_int | Domů | radius_put_vendor_addr


radius_put_vendor_addr

(PECL radius:1.1-1.2.5)

radius_put_vendor_addr — Attaches a vendor specific IP-Address attribute

Popis

bool radius_put_vendor_addr ( resource $radius_handle, int $vendor, int $type, string $addr )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
radius_put_string | Domů | radius_put_vendor_attr


radius_put_vendor_attr

(PECL radius:1.1-1.2.5)

radius_put_vendor_attr — Attaches a vendor specific binary attribute

Popis

bool radius_put_vendor_attr ( resource $radius_handle, int $vendor, int $type, string $value )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1839. radius_put_vendor_attr() example

<?php
if (!radius_put_vendor_attr($res, RADIUS_VENDOR_MICROSOFT, RAD_MICROSOFT_MS_CHAP_CHALLENGE, $challenge)) {
    echo 'RadiusError:' . radius_strerror($res). "\n<br />";
    exit;
}
?>

Předcházející | Nahoru | Další
radius_put_vendor_addr | Domů | radius_put_vendor_int


radius_put_vendor_int

(PECL radius:1.1-1.2.5)

radius_put_vendor_int — Attaches a vendor specific integer attribute

Popis

bool radius_put_vendor_int ( resource $radius_handle, int $vendor, int $type, int $value )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
radius_put_vendor_attr | Domů | radius_put_vendor_string


radius_put_vendor_string

(PECL radius:1.1-1.2.5)

radius_put_vendor_string — Attaches a vendor specific string attribute

Popis

bool radius_put_vendor_string ( resource $radius_handle, int $vendor, int $type, string $value )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
radius_put_vendor_int | Domů | radius_request_authenticator


radius_request_authenticator

(PECL radius:1.1-1.2.5)

radius_request_authenticator — Returns the request authenticator

Popis

string radius_request_authenticator ( resource $radius_handle )

The request authenticator is needed for demangling mangled data like passwords and encryption-keys.

Návratové hodnoty

Returns the request authenticator as string, or FALSE on error.

Viz také

radius_demangle()

Předcházející | Nahoru | Další
radius_put_vendor_string | Domů | radius_send_request


radius_send_request

(PECL radius:1.1-1.2.5)

radius_send_request — Sends the request and waites for a reply

Popis

int radius_send_request ( resource $radius_handle )

After the Radius request has been constructed, it is sent by radius_send_request().

The radius_send_request() function sends the request and waits for a valid reply, retrying the defined servers in round-robin fashion as necessary.

Návratové hodnoty

If a valid response is received, radius_send_request() returns the Radius code which specifies the type of the response. This will typically be RADIUS_ACCESS_ACCEPT, RADIUS_ACCESS_REJECT, or RADIUS_ACCESS_CHALLENGE. If no valid response is received, radius_send_request() returns FALSE.

Viz také

radius_create_request()

Předcházející | Nahoru | Další
radius_request_authenticator | Domů | radius_server_secret


radius_server_secret

(PECL radius:1.1-1.2.5)

radius_server_secret — Returns the shared secret

Popis

string radius_server_secret ( resource $radius_handle )

The shared secret is needed as salt for demangling mangled data like passwords and encryption-keys.

Návratové hodnoty

Returns the server's shared secret as string, or FALSE on error.

Předcházející | Nahoru | Další
radius_send_request | Domů | radius_strerror


radius_strerror

(PECL radius:1.1-1.2.5)

radius_strerror — Returns an error message

Popis

string radius_strerror ( resource $radius_handle )

If Radius-functions fail then they record an error message. This error message can be retrieved with this function.

Návratové hodnoty

Returns error messages as string from failed radius functions.

Předcházející | Nahoru | Další
radius_server_secret | Domů | CXXXV. Rar Functions


require

Předcházející 16. Řídicí struktury Další

require()

Příkaz require() vloží a ohodnotí specifikovaný soubor.

require() vloží a ohodnotí specifikovaný soubor. Podrobné informace o tom, jak vkládání pracuje, jsou popsány v dokumentaci o include().

require() a include() jsou totožné, kromě toho, jak zpracovávají chyby. include() vyprodukuje E_WARNING (varování), zatímco require() skončí s chybou typu E_ERROR (velmi vážná chyba). Jinak řečeno, nerozpakujte se použít require(), pokud chcete, aby nepřítomnost souboru zastavila zpracování stránky. include() se takto nechová, skript bude nerušeně pokračovat. Ujistěte se také, že máte v pořádku nastavení include_path.

Příklad 16.2. Základní příklady použití require()

<?php

require 'prepend.php';

require $somefile;

require ('somefile.txt');

?>

Další příklady -- viz dokumentace include().

Poznámka: U verzí před PHP 4.0.2 platí toto: require() se vždy pokusí přečíst příslušný soubor, kromě případu, že se řádek s tímto příkazem nemůže nikdy provést. Podmíněný výraz require() neovlivňuje. Avšak pokud se řádek, na kterém require() leží, vůbec neprovádí, nebude se provádět ani kód v příslušném souboru. Podobně je tomu i v případě cyklů -- ani ty neovlivňují chování require(). Přestože kód obsažený ve vkládaném souboru je stále předmětem opakování, samotné require() se provede pouze jednou.

Viz také include(), require_once(),
include_once(), eval(),
file(), readfile(),
virtual() a include_path.

Předcházející | Nahoru | Další
return | Domů | include


require_once

Předcházející 16. Řídicí struktury Další

require_once()

Příkaz require_once() vloží a ohodnotí specifikovaný soubor během provádění skriptu. Chová se tedy podobně jako require(), s tím rozdílem, že pokud už byl kód ze souboru dříve vložen do skriptu, nebude znovu vkládán. Více informací o chování příkazu -- viz příkaz require().

Příkaz require_once() by se měl používat v případech, kde by mohl být během provádění skriptu tentýž soubor vložen a ohodnocen víckrát, a přitom chcete zajistit právě jedno vložení (je třeba se vyhnout redefinicím funkcí, novému přiřazení hodnot atd.).

Příklady na použití require_once() a include_once() najdete v kódu » PEAR přiloženém v nejnovějších distribucích zdrojových kódů PHP.

Poznámka: Příkaz require_once() byl přidán v PHP 4.0.1pl2.

Viz také: require(),
include(), include_once(),
get_required_files(),
get_included_files(), readfile(),
a virtual().

Předcházející | Nahoru | Další
include | Domů | include_once


rpm_close

(PECL rpmreader:0.1-0.3)

rpm_close — Closes an RPM file

Popis

bool rpm_close ( resource $rpmr )

rpm_close() will close an RPM file pointer.

Seznam parametrů

rpmr

A file pointer resource successfully opened by rpm_open().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1858. rpm_close() example

<?php

$file = "/path/to/file.rpm";
$rpmr = rpm_open($file);

rpm_close($rpmr);

?>

Viz také

rpm_open()

Předcházející | Nahoru | Další
CXXXVIII. RPM Header Reading Funkce | Domů | rpm_get_tag


rpm_get_tag

(PECL rpmreader:0.1-0.3)

rpm_get_tag — Retrieves a header tag from an RPM file

Popis

mixed rpm_get_tag ( resource $rpmr, int $tagnum )

rpm_get_tag() will retrieve a given tag from the RPM file's header and return it.

Seznam parametrů

rpmr

A file pointer resource successfully opened by rpm_open().

tagnum

The tag number to retrieve from the RPM header. This value can be specified using the list of constants defined by this module.

Návratové hodnoty

The return value can be of various types depending on the tagnum supplied to the function.

Příklady

Příklad 1859. rpm_get_tag() example

<?php

$file = "/path/to/file.rpm";
$rpmr = rpm_open($file);

$name = rpm_get_tag($rpmr, RPMREADER_NAME);
echo "$name<br>\n";

rpm_close($rpmr);

?>

Viz také

rpm_open()
rpm_close()

Předcházející | Nahoru | Další
rpm_close | Domů | rpm_is_valid


rpm_is_valid

(PECL rpmreader:0.1-0.3)

rpm_is_valid — Tests a filename for validity as an RPM file

Popis

bool rpm_is_valid ( string $filename )

rpm_is_valid() will test an RPM file for validity as an RPM file. This is not the same as rpm_open() as it only checks the file for validity but does not return a file pointer to be used by further functions.

Seznam parametrů

filename

The filename of the RPM file you wish to check for validity.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1860. rpm_is_valid() example

<?php

$file = "/path/to/file.rpm";

if (rpm_is_valid($file)) {
    echo "File is recognized as an RPM file.<br>\n";
}
else {
    echo "File is not recognized as an RPM file.<br>\n";
}

?>

Předcházející | Nahoru | Další
rpm_get_tag | Domů | rpm_open


rpm_open

(PECL rpmreader:0.1-0.3)

rpm_open — Opens an RPM file

Popis

resource rpm_open ( string $filename )

rpm_open() will open an RPM file and will determine if the file is a valid RPM file.

Seznam parametrů

filename

The filename of the RPM file you wish to open.

Návratové hodnoty

If the open succeeds, then rpm_open() will return a file pointer resource to the newly opened file. On error, the function will return FALSE.

Příklady

Příklad 1861. rpm_open() example

<?php

$file = "/path/to/file.rpm";
$rpmr = rpm_open($file);

rpm_close($rpmr);

?>

Viz také

rpm_close()

Předcházející | Nahoru | Další
rpm_is_valid | Domů | rpm_version


rpm_version

(PECL rpmreader:0.3)

rpm_version — Returns a string representing the current version of the rpmreader extension

Popis

string rpm_version ( void )

rpm_version() will return the current version of the rpmreader extension.

Návratové hodnoty

rpm_version() will return a string representing the rpmreader version currently loaded in PHP.

Příklady

Příklad 1862. rpm_version() example

<?php

$rpmr_ver = rpm_version();

echo "$rpmr_ver<br />\n";

?>

Předcházející | Nahoru | Další
rpm_open | Domů | CXXXIX. runkit Functions


runkit_class_adopt

(PECL runkit:0.7-0.9)

runkit_class_adopt — Convert a base class to an inherited class, add ancestral methods when appropriate

Popis

bool runkit_class_adopt ( string $classname, string $parentname )

Seznam parametrů

classname

Name of class to be adopted

parentname

Parent class which child class is extending

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1870. A runkit_class_adopt() example

<?php
class myParent {
  function parentFunc() {
    echo "Parent Function Output\n";
  }
}

class myChild {
}

runkit_class_adopt('myChild','myParent');
myChild::parentFunc();
?>

Výše uvedený příklad vypíše:

Parent Function Output

Viz také

runkit_class_emancipate()

Předcházející | Nahoru | Další
Runkit_Sandbox_Parent | Domů | runkit_class_emancipate


runkit_class_emancipate

(PECL runkit:0.7-0.9)

runkit_class_emancipate — Convert an inherited class to a base class, removes any method whose scope is ancestral

Popis

bool runkit_class_emancipate ( string $classname )

Seznam parametrů

classname

Name of class to emancipate

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1871. A runkit_class_emancipate() example

<?php
class myParent {
  function parentFunc () {
    echo "Parent Function Output\n";
  }
}
class myChild extends myParent {
}

myChild::parentFunc();
runkit_class_emancipate('myChild');
myChild::parentFunc();
?>

Výše uvedený příklad vypíše:

Parent Function Output
Fatal error: Call to undefined function:  parentFunc() in example.php on line 12

Viz také

runkit_class_adopt()

Předcházející | Nahoru | Další
runkit_class_adopt | Domů | runkit_constant_add


runkit_constant_add

(PECL runkit:0.7-0.9)

runkit_constant_add — Similar to define(), but allows defining in class definitions as well

Popis

bool runkit_constant_add ( string $constname, mixed $value )

Seznam parametrů

constname

Name of constant to declare. Either a string to indicate a global constant, or classname::constname to indicate a class constant.

value

NULL, Bool, Long, Double, String, or Resource value to store in the new constant.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

define()
runkit_constant_redefine()
runkit_constant_remove()

Předcházející | Nahoru | Další
runkit_class_emancipate | Domů | runkit_constant_redefine


runkit_constant_redefine

(PECL runkit:0.7-0.9)

runkit_constant_redefine — Redefine an already defined constant

Popis

bool runkit_constant_redefine ( string $constname, mixed $newvalue )

Seznam parametrů

constname

Constant to redefine. Either string indicating global constant, or classname::constname indicating class constant.

newvalue

New value to assign to constant.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

runkit_constant_add()
runkit_constant_remove()

Předcházející | Nahoru | Další
runkit_constant_add | Domů | runkit_constant_remove


runkit_constant_remove

(PECL runkit:0.7-0.9)

runkit_constant_remove — Remove/Delete an already defined constant

Popis

bool runkit_constant_remove ( string $constname )

Seznam parametrů

constname

Name of constant to remove. Either a string indicating a global constant, or classname::constname indicating a class constant.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

define()
runkit_constant_add()
runkit_constant_redefine()

Předcházející | Nahoru | Další
runkit_constant_redefine | Domů | runkit_function_add


runkit_function_add

(PECL runkit:0.7-0.9)

runkit_function_add — Add a new function, similar to create_function()

Popis

bool runkit_function_add ( string $funcname, string $arglist, string $code )

Seznam parametrů

funcname

Name of function to be created

arglist

Comma separated argument list

code

Code making up the function

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1872. A runkit_function_add() example

<?php
runkit_function_add('testme','$a,$b','echo "The value of a is $a\n"; echo "The value of b is $b\n";');
testme(1,2);
?>

Výše uvedený příklad vypíše:

The value of a is 1
The value of b is 2

Viz také

create_function()
runkit_function_redefine()
runkit_function_copy()
runkit_function_rename()
runkit_function_remove()
runkit_method_add()

Předcházející | Nahoru | Další
runkit_constant_remove | Domů | runkit_function_copy


runkit_function_copy

(PECL runkit:0.7-0.9)

runkit_function_copy — Copy a function to a new function name

Popis

bool runkit_function_copy ( string $funcname, string $targetname )

Seznam parametrů

funcname

Name of existing function

targetname

Name of new function to copy definition to

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1873. A runkit_function_copy() example

<?php
function original() {
  echo "In a function\n";
}
runkit_function_copy('original','duplicate');
original();
duplicate();
?>

Výše uvedený příklad vypíše:

In a function
In a function

Viz také

runkit_function_add()
runkit_function_redefine()
runkit_function_rename()
runkit_function_remove()

Předcházející | Nahoru | Další
runkit_function_add | Domů | runkit_function_redefine


runkit_function_redefine

(PECL runkit:0.7-0.9)

runkit_function_redefine — Replace a function definition with a new implementation

Popis

bool runkit_function_redefine ( string $funcname, string $arglist, string $code )

Poznámka: Implicitně lze odstraňovat, přejmenovávat nebo modifikovat pouze uživatelské funkce. Pro možnost předefinovávat vnitřní funkce musíte povolit nastavení runkit.internal_override v systémovém konfiguračním souboru php.ini.

Seznam parametrů

funcname

Name of function to redefine

arglist

New list of arguments to be accepted by function

code

New code implementation

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1874. A runkit_function_redefine() example

<?php
function testme() {
  echo "Original Testme Implementation\n";
}
testme();
runkit_function_redefine('testme','','echo "New Testme Implementation\n";');
testme();
?>

Výše uvedený příklad vypíše:

Original Testme Implementation
New Testme Implementation

Viz také

runkit_function_add()
runkit_function_copy()
runkit_function_rename()
runkit_function_remove()

Předcházející | Nahoru | Další
runkit_function_copy | Domů | runkit_function_remove


runkit_function_remove

(PECL runkit:0.7-0.9)

runkit_function_remove — Remove a function definition

Popis

bool runkit_function_remove ( string $funcname )

Poznámka: Implicitně lze odstraňovat, přejmenovávat nebo modifikovat pouze uživatelské funkce. Pro možnost předefinovávat vnitřní funkce musíte povolit nastavení runkit.internal_override v systémovém konfiguračním souboru php.ini.

Seznam parametrů

funcname

Name of function to be deleted

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

runkit_function_add()
runkit_function_copy()
runkit_function_redefine()
runkit_function_rename()

Předcházející | Nahoru | Další
runkit_function_redefine | Domů | runkit_function_rename


runkit_function_rename

(PECL runkit:0.7-0.9)

runkit_function_rename — Change a function's name

Popis

bool runkit_function_rename ( string $funcname, string $newname )

Poznámka: Implicitně lze odstraňovat, přejmenovávat nebo modifikovat pouze uživatelské funkce. Pro možnost předefinovávat vnitřní funkce musíte povolit nastavení runkit.internal_override v systémovém konfiguračním souboru php.ini.

Seznam parametrů

funcname

Current function name

newname

New function name

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

runkit_function_add()
runkit_function_copy()
runkit_function_redefine()
runkit_function_remove()

Předcházející | Nahoru | Další
runkit_function_remove | Domů | runkit_import


runkit_import

(PECL runkit:0.7-0.9)

runkit_import — Process a PHP file importing function and class definitions, overwriting where appropriate

Popis

bool runkit_import ( string $filename [, int $flags] )

Similar to include() however any code residing outside of a function or class is simply ignored. Additionally, depending on the value of flags, any functions or classes which already exist in the currently running environment will be automatically overwritten by their new definitions.

Seznam parametrů

filename

Filename to import function and class definitions from

flags

Bitwise OR of the RUNKIT_IMPORT_* family of constants.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
runkit_function_rename | Domů | runkit_lint_file


runkit_lint

(PECL runkit:0.7-0.9)

runkit_lint — Check the PHP syntax of the specified php code

Popis

bool runkit_lint ( string $code )

The runkit_lint() function performs a syntax (lint) check on the specified php code testing for scripting errors. This is similar to using php -l from the command line except runkit_lint() accepts actual code rather than a filename.

Poznámka: Podpora sandboxu (potřebná pro runkit_lint(), runkit_lint_file(), a třídu Runkit_Sandbox) je dostupná jen v PHP 5.1 nebo speciálně patchovaných verzích PHP 5.0, a vyžaduje zapnutou threadovou bezpečnost. Pro více informací viz soubor README přiložený k runkit balíku.

Seznam parametrů

code

PHP Code to be lint checked

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

runkit_lint_file()

Předcházející | Nahoru | Další
runkit_lint_file | Domů | runkit_method_add


runkit_lint_file

(PECL runkit:0.7-0.9)

runkit_lint_file — Check the PHP syntax of the specified file

Popis

bool runkit_lint_file ( string $filename )

The runkit_lint_file() function performs a syntax (lint) check on the specified filename testing for scripting errors. This is similar to using php -l from the commandline.

Poznámka: Podpora sandboxu (potřebná pro runkit_lint(), runkit_lint_file(), a třídu Runkit_Sandbox) je dostupná jen v PHP 5.1 nebo speciálně patchovaných verzích PHP 5.0, a vyžaduje zapnutou threadovou bezpečnost. Pro více informací viz soubor README přiložený k runkit balíku.

Seznam parametrů

filename

File containing PHP Code to be lint checked

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

runkit_lint()

Předcházející | Nahoru | Další
runkit_import | Domů | runkit_lint


runkit_method_add

(PECL runkit:0.7-0.9)

runkit_method_add — Dynamically adds a new method to a given class

Popis

bool runkit_method_add ( string $classname, string $methodname, string $args, string $code [, int $flags] )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Seznam parametrů

classname

The class to which this method will be added

methodname

The name of the method to add

args

Comma-delimited list of arguments for the newly-created method

code

The code to be evaluated when methodname is called

flags

The type of method to create, can be RUNKIT_ACC_PUBLIC, RUNKIT_ACC_PROTECTED or RUNKIT_ACC_PRIVATE

Poznámka: This parameter is only used as of PHP 5, because, prior to this, all methods were public.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1875. runkit_method_add() example

<?php
class Example {
    function foo() {
        echo "foo!\n";
    }
}

// create an Example object
$e = new Example();

// Add a new public method
runkit_method_add(
    'Example',
    'add',
    '$num1, $num2',
    'return $num1 + $num2;',
    RUNKIT_ACC_PUBLIC
);

// add 12 + 4
echo $e->add(12, 4);
?>

Výše uvedený příklad vypíše:

16

Viz také

runkit_method_copy()
runkit_method_redefine()
runkit_method_remove()
runkit_method_rename()
runkit_function_add()

Předcházející | Nahoru | Další
runkit_lint | Domů | runkit_method_copy


runkit_method_copy

(PECL runkit:0.7-0.9)

runkit_method_copy — Copies a method from class to another

Popis

bool runkit_method_copy ( string $dClass, string $dMethod, string $sClass [, string $sMethod] )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Seznam parametrů

dClass

Destination class for copied method

dMethod

Destination method name

sClass

Source class of the method to copy

sMethod

Name of the method to copy from the source class. If this parameter is omitted, the value of dMethod is assumed.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1876. runkit_method_copy() example

<?php
class Foo {
    function example() {
        return "foo!\n";
    }
}

class Bar {
    // initially, no methods
}

// copy the example() method from the Foo class to the Bar class, as baz()
runkit_method_copy('Bar', 'baz', 'Foo', 'example');

// output copied function
echo Bar::baz();
?>

Výše uvedený příklad vypíše:

foo!

Viz také

runkit_method_add()
runkit_method_redefine()
runkit_method_remove()
runkit_method_rename()
runkit_function_copy()

Předcházející | Nahoru | Další
runkit_method_add | Domů | runkit_method_redefine


runkit_method_redefine

(PECL runkit:0.7-0.9)

runkit_method_redefine — Dynamically changes the code of the given method

Popis

bool runkit_method_redefine ( string $classname, string $methodname, string $args, string $code [, int $flags] )

Poznámka: Tuto funkci nelze použít k manipulaci s aktuálně běžící metodou (nebo metodou v řetězu).

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Seznam parametrů

classname

The class in which to redefine the method

methodname

The name of the method to redefine

args

Comma-delimited list of arguments for the redefined method

code

The new code to be evaluated when methodname is called

flags

The redefined method can be RUNKIT_ACC_PUBLIC, RUNKIT_ACC_PROTECTED or RUNKIT_ACC_PRIVATE

Poznámka: This parameter is only used as of PHP 5, because, prior to this, all methods were public.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1877. runkit_method_redefine() example

<?php
class Example {
    function foo() {
        return "foo!\n";
    }
}

// create an Example object
$e = new Example();

// output Example::foo() (before redefine)
echo "Before: " . $e->foo();

// Redefine the 'foo' method
runkit_method_redefine(
    'Example',
    'foo',
    '',
    'return "bar!\n";',
    RUNKIT_ACC_PUBLIC
);

// output Example::foo() (after redefine)
echo "After: " . $e->foo();
?>

Výše uvedený příklad vypíše:

Before: foo!
After: bar!

Viz také

runkit_method_add()
runkit_method_copy()
runkit_method_remove()
runkit_method_rename()
runkit_function_redefine()

Předcházející | Nahoru | Další
runkit_method_copy | Domů | runkit_method_remove


runkit_method_remove

(PECL runkit:0.7-0.9)

runkit_method_remove — Dynamically removes the given method

Popis

bool runkit_method_remove ( string $classname, string $methodname )

Poznámka: Tuto funkci nelze použít k manipulaci s aktuálně běžící metodou (nebo metodou v řetězu).

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Seznam parametrů

classname

The class in which to remove the method

methodname

The name of the method to remove

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1878. runkit_method_remove() example

<?php
class Example {
    function foo() {
        return "foo!\n";
    }

    function bar() {
        return "bar!\n";
    }
}

// Remove the 'foo' method
runkit_method_remove(
    'Example',
    'foo'
);

echo implode(' ', get_class_methods('Example'));

?>

Výše uvedený příklad vypíše:

bar

Viz také

runkit_method_add()
runkit_method_copy()
runkit_method_redefine()
runkit_method_rename()
runkit_function_remove()

Předcházející | Nahoru | Další
runkit_method_redefine | Domů | runkit_method_rename


runkit_method_rename

(PECL runkit:0.7-0.9)

runkit_method_rename — Dynamically changes the name of the given method

Popis

bool runkit_method_rename ( string $classname, string $methodname, string $newname )

Poznámka: Tuto funkci nelze použít k manipulaci s aktuálně běžící metodou (nebo metodou v řetězu).

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Seznam parametrů

classname

The class in which to rename the method

methodname

The name of the method to rename

newname

The new name to give to the renamed method

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1879. runkit_method_rename() example

<?php
class Example {
    function foo() {
        return "foo!\n";
    }
}

// Rename the 'foo' method to 'bar'
runkit_method_rename(
    'Example',
    'foo',
    'bar'
);

// output renamed function
echo Example::bar();
?>

Výše uvedený příklad vypíše:

foo!

Viz také

runkit_method_add()
runkit_method_copy()
runkit_method_redefine()
runkit_method_remove()
runkit_function_rename()

Předcházející | Nahoru | Další
runkit_method_remove | Domů | runkit_return_value_used


runkit_return_value_used

(PECL runkit:0.8-0.9)

runkit_return_value_used — Determines if the current functions return value will be used

Popis

bool runkit_return_value_used ( void )

Návratové hodnoty

Returns TRUE if the function's return value is used by the calling scope, otherwise FALSE

Příklady

Příklad 1880. runkit_return_value_used() example

<?php
function foo() {
  var_dump(runkit_return_value_used());
}

foo();
$f = foo();
?>

Výše uvedený příklad vypíše:

bool(false)
bool(true)

Předcházející | Nahoru | Další
runkit_method_rename | Domů | runkit_sandbox_output_handler


runkit_sandbox_output_handler

(PECL runkit:0.7-0.9)

runkit_sandbox_output_handler — Specify a function to capture and/or process output from a runkit sandbox

Popis

mixed runkit_sandbox_output_handler ( object $sandbox [, mixed $callback] )

Ordinarily, anything output (such as with echo() or print()) will be output as though it were printed from the parent's scope. Using runkit_sandbox_output_handler() however, output generated by the sandbox (including errors), can be captured by a function outside of the sandbox.

Poznámka: Podpora sandboxu (potřebná pro runkit_lint(), runkit_lint_file(), a třídu Runkit_Sandbox) je dostupná jen v PHP 5.1 nebo speciálně patchovaných verzích PHP 5.0, a vyžaduje zapnutou threadovou bezpečnost. Pro více informací viz soubor README přiložený k runkit balíku.

Deprecated: As of runkit version 0.5, this function is deprecated and is scheduled to be removed from the package prior to a 1.0 release. The output handler for a given Runkit_Sandbox instance may be read/set using the array offset syntax shown on the Runkit_Sandbox class definition page.

Seznam parametrů

sandbox

Object instance of Runkit_Sandbox class on which to set output handling.

callback

Name of a function which expects one parameter. Output generated by sandbox will be passed to this callback. Anything returned by the callback will be displayed normally. If this parameter is not passed then output handling will not be changed. If a non-truth value is passed, output handling will be disabled and will revert to direct display.

Návratové hodnoty

Returns the name of the previously defined output handler callback, or FALSE if no handler was previously defined.

Příklady

Příklad 1881. Feeding output to a variable

<?php
function capture_output($str) {
  $GLOBALS['sandbox_output'] .= $str;

  return '';
}

$sandbox_output = '';

$php = new Runkit_Sandbox();
runkit_sandbox_output_handler($php, 'capture_output');
$php->echo("Hello\n");
$php->eval('var_dump("Excuse me");');
$php->die("I lost myself.");
unset($php);

echo "Sandbox Complete\n\n";
echo $sandbox_output;
?>

Výše uvedený příklad vypíše:

Sandbox Complete

Hello
string(9) "Excuse me"
I lost myself.

Předcházející | Nahoru | Další
runkit_return_value_used | Domů | runkit_superglobals


runkit_superglobals

(PECL runkit:0.7-0.9)

runkit_superglobals — Return numerically indexed array of registered superglobals

Popis

array runkit_superglobals ( void )

Návratové hodnoty

Returns a numerically indexed array of the currently registered superglobals. i.e. _GET, _POST, _REQUEST, _COOKIE, _SESSION, _SERVER, _ENV, _FILES

Viz také

Variable Scope

Předcházející | Nahoru | Další
runkit_sandbox_output_handler | Domů | CXL. SAM - Simple Asynchronous Messaging


SAMConnection->commit()

(No version information available, might be only in CVS)

SAMConnection->commit() — Commits (completes) the current unit of work.

Popis

class SAMConnection {
bool commit ( void )
}

Calling the "commit" method on a Connection object commits (completes) all in-flight transactions that are part of the current unit of work.

Návratové hodnoty

This method returns FALSE if an error occurs.

Příklady

Příklad 1896. Committing the current unit of work

<?php
  if (!$conn->commit()) {
    // The commit failed!
    echo "Commit failed ($conn->errno) $conn->error";
  }
?>

Viz také

SAMConnection->rollback()

Předcházející | Nahoru | Další
CXL. SAM - Simple Asynchronous Messaging | Domů | SAMConnection->connect()


SAMConnection->connect()

(No version information available, might be only in CVS)

SAMConnection->connect() — Establishes a connection to a Messaging Server

Popis

class SAMConnection {
bool connect ( string $protocol [, array $properties] )
}

Calling the "connect" method on a SAMConnection object connects the PHP script to a messaging server. No messages can be sent or received until a connection is made.

Seznam parametrů

Návratové hodnoty

This method returns FALSE if an error occurs.

Příklady

Příklad 1897. Creating a connection to a Messaging Server using the IBM MQSeries protocol (WMQ)

<?php

$conn->connect(SAM_WMQ, array(SAM_HOST => 'Myhost.myco.com', SAM_PORT => 1506, SAM_BROKER => 'MyBroker'));

?>

Příklad 1898. Creating a connection with application transaction control and default host and port values

<?php

$conn->connect(SAM_WMQ, array(SAM_BROKER => 'MyBroker', SAM_TRANSACTIONS => SAM_MANUAL));

?>

Příklad 1899. Creating a connection to a Messaging Server using the IBM WebSphere Platform Messaging protocol (WPM)

<?php

$conn->connect(SAM_WPM, array(SAM_ENDPOINTS => 'localhost:7278:BootstrapBasicMessaging',
                              SAM_BUS => 'Bus1', SAM_TARGETCHAIN => 'InboundBasicMessaging'));

?>

Viz také

SAMConnection->isConnected()
SAMConnection->disconnect()

Předcházející | Nahoru | Další
SAMConnection->commit() | Domů | SAMConnection->__construct()


SAMConnection->__construct()

(No version information available, might be only in CVS)

SAMConnection->__construct() — Creates a new connection to a Messaging Server

Popis

class SAMConnection {
__construct ( $ )
}

Creates a new SAMConnection object.

Příklady

Příklad 1900. Creating a connection object and connecting to a Messaging Server

<?php

$conn = new SAMConnection();
$conn->connect(SAM_WMQ, array(SAM_HOST => localhost, SAM_PORT => 1414, SAM_BROKER => 'bull'));

?>

Předcházející | Nahoru | Další
SAMConnection->connect() | Domů | SAMConnection->disconnect()


SAMConnection->disconnect()

(No version information available, might be only in CVS)

SAMConnection->disconnect() — Disconnects from a Messaging Server

Popis

class SAMConnection {
bool disconnect ( void )
}

Calling the "disconnect" method on a SAMConnection object disconnects the PHP script from a messaging server. No messages can be sent or received after a connection has been disconnected.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 1901. Disconnecting from a Messaging Server

<?php

$conn->disconnect();

?>

Viz také

SAMConnection->isConnected()
SAMConnection->connect()

Předcházející | Nahoru | Další
SAMConnection->__construct() | Domů | SAMConnection->errno


SAMConnection->errno

(No version information available, might be only in CVS)

SAMConnection->errno — Contains the unique numeric error code of the last executed SAM operation.

Description

class SAMConnection {
int errno
}

Contains the numeric error code of the last executed SAM operation on this connection. If the last operation completed successfully this property contains 0.

Návratové hodnoty

An integer greater than zero indicates the last error type encountered on the connection. Zero indicates that the last operation on this connection completed successfully.

Příklady

Příklad 1902. Using the error number and description properties

<?php
$conn = new SAMConnection();
$conn->connect(SAM_WMQ, array(SAM_HOST => 'localhost', SAM_PORT => 1506));
$msg = new SAMMessage('This is a simple text item');
if (!$conn->send('topic://test', $msg)) {
    // The Send failed!
    echo "Send failed ($conn->errno) $conn->error";
}
?>

Viz také

SAMConnection->error

Předcházející | Nahoru | Další
SAMConnection->disconnect() | Domů | SAMConnection->error


SAMConnection->error

(No version information available, might be only in CVS)

SAMConnection->error — Contains the text description of the last failed SAM operation.

Popis

class SAMConnection {
string error
}

Contains the text description of the last failed SAM operation on this connection. If the last operation completed successfully this property contains an empty string.

Návratové hodnoty

A string containing the text description of the last error type encountered on the connection. An empty string indicates that the last operation on this connection completed successfully.

Příklady

Příklad 1903. Using the error number and description properties

<?php
$conn = new SAMConnection();
$conn->connect(SAM_WMQ, array(SAM_HOST => 'localhost', SAM_PORT => 1506));
$msg = new SAMMessage('This is a simple text item');
if (!$conn->send('topic://test', $msg)) {
    // The Send failed!
    echo "Send failed ($conn->errno) $conn->error";
}
?>

Viz také

SAMConnection->errno

Předcházející | Nahoru | Další
SAMConnection->errno | Domů | SAMConnection->isConnected()


SAMConnection->isConnected()

(No version information available, might be only in CVS)

SAMConnection->isConnected() — Queries whether a connection is established to a Messaging Server

Popis

class SAMConnection {
bool isConnected ( void )
}

Calling the "isConnected" method on a Connection object will check whether the PHP script is connected to a messaging server. No messages can be sent or received unless a connection has been established with a Messaging server.

Návratové hodnoty

This method returns TRUE if the SAMConnection object is successfully connected to a Messaging server or FALSE otherwise.

Příklady

Příklad 1904. Checking whether there us a connection to a Messaging Server

<?php

if ($conn->isConnected()) {
  echo 'Connection is active.'
} else {
  echo 'No active connection!'
}

?>

Viz také

SAMConnection->disconnect()
SAMConnection->connect()

Předcházející | Nahoru | Další
SAMConnection->error | Domů | SAMConnection->peek()


SAMConnection->peek()

(No version information available, might be only in CVS)

SAMConnection->peek() — Read a message from a queue without removing it from the queue.

Popis

class SAMConnection {
SAMMessage peek ( string $target [, array $properties] )
}

Seznam parametrů

target

The identity of the queue from which to peek the message.

properties

An optional associative array of properties describing other parameters to control the peek operation.

Property name | Possible values
SAM_CORRELID | This is the target correlation id string of the message. This would typically have been returned by a "send" request.
SAM_MESSAGEID | This is the message id string of the message which is to be peeked.

Návratové hodnoty

This method returns a SAMMessage object or FALSE if an error occurs.

Příklady

Příklad 1905. Retrieve the next message from a queue without removing it

<?php
$msg = $conn->peek('queue://receive/test');

if (!$msg) {
  // The peek failed!
  echo "Peek failed ($conn->errno) $conn->error";
}
?>

Příklad 1906. Retrieve a specific message from a queue without removing it from the queue

<?php

$msg = $conn->peek('queue://receive/test', array(SAM_MESSAGEID => $messageId));

?>

Viz také

SAMConnection->peekAll()

Předcházející | Nahoru | Další
SAMConnection->isConnected() | Domů | SAMConnection->peekAll()


SAMConnection->peekAll()

(No version information available, might be only in CVS)

SAMConnection->peekAll() — Read one or more messages from a queue without removing it from the queue.

Popis

class SAMConnection {
array peekAll ( string $target [, array $properties] )
}

Seznam parametrů

target

The identity of the queue from which messages should be peeked.

properties

An optional associative array of properties describing other parameters to control the peek operation.

Property name | Possible values
SAM_CORRELID | This is the target correlation id string of messages to be peeked. This would typically have been returned by a "send" request.
SAM_MESSAGEID | This is the message id string of a message which is to be peeked.

Návratové hodnoty

This method returns an array of SAMMessage objects or FALSE if an error occurs.

Příklady

Příklad 1907. Retrieve all messages in a queue without removing them

<?php
$msgArray = $conn->peekAll('queue://receive/test');
if ($msgArray) {
   foreach ( $msgArray as $key => $msg) {
       echo "Message $key: body = $msg->body\n";
   }
} else {
   echo "PeekAll failed ($conn->errno) $conn->error";
}
?>

Příklad 1908. Retrieve all messages from a queue with a matching correlation id

<?php

   $msgArray = $conn->peekAll('queue://receive/test', array(SAM_CORRELID => $correlId ));
   if ($msgArray) {

      foreach ( $msgArray as $key => $msg) {
            echo "Message $key: body = $msg->body\n";
         }
      }
   else
      echo "PeekAll failed ($conn->errno) $conn->error";
   }

?>

Viz také

SAMConnection->peek()

Předcházející | Nahoru | Další
SAMConnection->peek() | Domů | SAMConnection->receive()


SAMConnection->receive()

(No version information available, might be only in CVS)

SAMConnection->receive() — Receive a message from a queue or subscription.

Popis

class SAMConnection {
SAMMessage receive ( string $target [, array $properties] )
}

Seznam parametrů

target

The identity of the queue, topic or subscription from which to receive the message.

properties

An optional associative array of properties describing other parameters to control the receive operation.

Property name | Possible values
SAM_CORRELID | Used to request selection of the message to receive based upon the correlation id string of the message.
SAM_MESSAGEID | Used to request selection of the message to receive based upon the message id string of the message.
SAM_WAIT | Timeout value in milliseconds to control how long the request should block waiting to receive a message before returning with a failure if no message is available on the queue or topic. The default value is 0 meaning wait indefinitely and should be used with caution as the request may wait until the overall PHP script processing time limit has expired if no message becomes available.

Návratové hodnoty

This method returns a SAMMessage object or FALSE if an error occurs.

Příklady

Příklad 1909. Receiving a message from a queue

<?php
$msg = $conn->receive('queue://receive/test');

if (!$msg) {
  // The receive failed!
  echo "Receive failed ($conn->errno) $conn->error";
}
?>

Příklad 1910. Receiving a message from a queue with options

In this example the SAM_CORRELID option is used to specify a correlation id string to be used to identify the message to receive. A wait timeout of 10 seconds is also specified.

<?php

$msg = $conn->receive('queue://receive/test', array(SAM_CORRELID => $token, SAM_WAIT => 10000));

?>

Příklad 1911. Receiving a message from a subscription

In this example we show how to receive a message from a subscription id.

<?php
$msg = $conn->receive($subscriptionName);

if (!$msg) {
  // The receive failed!
  echo "Receive failed ($conn->errno) $conn->error";
}
?>

Please note that $subscriptionName is a subscription id returned from an earlier subscribe call.

Viz také

SAMConnection->send()

Předcházející | Nahoru | Další
SAMConnection->peekAll() | Domů | SAMConnection->remove()


SAMConnection->remove()

(No version information available, might be only in CVS)

SAMConnection->remove() — Remove a message from a queue.

Popis

class SAMConnection {
SAMMessage remove ( string $target [, array $properties] )
}

Removes a message from a queue.

Seznam parametrů

target

The identity of the queue from which to remove the message.

properties

An optional associative array of properties describing other parameters to control the remove operation.

Property name | Possible values
SAM_CORRELID | This is the target correlation id string of the message. This would typically have been returned by a "send" request.
SAM_MESSAGEID | This is the message id string of the message which is to be removed.

Návratové hodnoty

This method returns FALSE if an error occurs.

Příklady

Příklad 1912. Removing a message from a queue by message id

<?php
if (!$conn->remove('queue://receive/test', array(SAM_MESSAGEID => $messageId))) {
  // The remove failed!
  echo "Remove failed ($conn->errno) $conn->error";
}
?>

Předcházející | Nahoru | Další
SAMConnection->receive() | Domů | SAMConnection->rollback()


SAMConnection->rollback()

(No version information available, might be only in CVS)

SAMConnection->rollback() — Cancels (rolls back) an in-flight unit of work.

Popis

class SAMConnection {
bool rollback ( void )
}

Rolls back an in-flight unit of work.

Návratové hodnoty

This method returns FALSE if an error occurs.

Příklady

Příklad 1913. Cancelling an in-flight unit of work

<?php
if (!$conn->rollback()) {
  // The rollback failed!
  echo "Rollback failed ($conn->errno) $conn->error";
}
?>

Viz také

SAMConnection->commit()

Předcházející | Nahoru | Další
SAMConnection->remove() | Domů | SAMConnection->send()


SAMConnection->send()

(No version information available, might be only in CVS)

SAMConnection->send() — Send a message to a queue or publish an item to a topic.

Popis

class SAMConnection {
string send ( string $target, SAMMessage $msg [, array $properties] )
}

The "send" method is used to send a message to a specific queue or to publish to a specific topic. The method returns a correlation id that can be used as a selector to identify reply or response messages when these are requested.

Seznam parametrů

target

If sending a message, the identity of the queue (queue://queuename) or if publishing to a topic the identity of the topic (topic://topicname) to which the message is to be delivered.

msg

The message to be sent or published.

properties

An optional associative array of properties describing other parameters to control the receive operation.

Property name | Possible values
SAM_DELIVERYMODE | Indicates whether the messaging server should enusre delivery or whether it is acceptable for messages to be lost in the case of system failures. The value of this property may be set to either SAM_PERSISTENT, to indicate that message loss is not acceptable, or SAM_NON_PERSISTENT, if message loss is acceptable. The resulting behaviour of the send will vary depending on the capabilities of the messaging server the PHP script is currently connected to. If the server does not support persistent messages and SAM_PERSISTENT is specified the send request will fail with an error indication showing the capability is not available.
SAM_PRIORITY | A numeric value between 0 and 9 indicating the desired message delivery priority. A priority value of 0 indicates the lowest priority while 9 indicates highest priority. If no priority is specified a default will be assigned which is dependent on the messaging server being used.
SAM_CORRELID | A string to be assigned as a correlation id for this message. If no value is given the messaging server may assign a value automatically.
SAM_TIMETOLIVE | A time in milliseconds indicating how long the messaging server should retain the message on a queue before discarding it. The default value is 0 indicating the message should be retained indefinitely.
SAM_WMQ_TARGET_CLIENT | This property is only valid when using WebSphere MQ and indicates whether or not an RFH2 header should be included with the message. This option may be set to either 'jms' or 'mq'. The default is 'jms' which means that an RFH2 header is included. If the value 'mq' is specified then no RFH2 is included with the message.

Návratové hodnoty

A correlation id string that can be used in a subsequent receive call as a selector to obtain any reply or response that has been requested or FALSE if an error occurred.

Poznámka: A correlation id will only be returned for a successful send to a queue destination (queue://xxxx) in which case it will reflect the message identitiy of the message on the queue. In the case of a send being used to publish data to a topic the return value will be TRUE as no correlation id is availabe for return.

Příklady

Příklad 1914. Send a message to a queue

<?php
$msg = new SAMMessage('This is a simple text message');
$correlId = $conn->send('queue://send/test', $msg);
if (!$correlId) {
    // The send failed!
    echo "Send failed ($conn->errno) $conn->error";
}

?>

Příklad 1915. Publish a message to a topic

<?php
$msg = new SAMMessage('This is a simple text item');
if (!$conn->send('topic://test', $msg)) {
    // The Send failed!
    echo "Send failed ($conn->errno) $conn->error";
}
?>

Příklad 1916. Send a request and receive a response

<?php
$msg = new SAMMessage('This is a simple text message');
$msg->header->SAM_REPLY_TO = 'queue://receive/test';
$correlid = $conn->send('queue://send/test', $msg);

if (!$correlid) {
    // The Send failed!
    echo "Send failed ($conn->errno) $conn->error";
} else {
    $resp = $conn->receive('queue://receive/test', array(SAM_CORRELID => $correlid));
}
?>

Viz také

SAMConnection->receive()

Předcházející | Nahoru | Další
SAMConnection->rollback() | Domů | SAMConnection::setDebug()


SAMConnection::setDebug()

(No version information available, might be only in CVS)

SAMConnection::setDebug() — Turn on or off additional debugging output.

Popis

The "setdebug" method is used to turn on or off additional debugging output. The SAM framework will provide method/function entry and exit trace data plus additional information. Protocol specific implementations also provide extra output.

class SAMConnection {
void send ( bool $switch )
}

Seznam parametrů

switch

If this parameter is set to TRUE additional debugging output will be provided. If the value is set to FALSE output of additional information will be stopped.

Příklady

Příklad 1917. Turn on debugging output

<?php
$conn->setdebug(TRUE);
?>

Příklad 1918. Turn off debugging output

<?php
$conn->setdebug(FALSE);
?>

Předcházející | Nahoru | Další
SAMConnection->send() | Domů | SAMConnection->subscribe()


SAMConnection->subscribe()

(No version information available, might be only in CVS)

SAMConnection->subscribe() — Create a subscription to a specified topic.

Popis

class SAMConnection {
string subscribe ( string $targetTopic )
}

The "subscribe" method is used to create a new subscription to a specified topic.

Seznam parametrů

targetTopic

The identity of the topic (topic://topicname) to subscribe to.

Návratové hodnoty

A subscription identifier that can be used in a subsequent receive call as a selector to obtain any topic data or FALSE if an error occurred. The subscription identifier should be used in the receive call in place of the simple topic name.

Příklady

Příklad 1919. Subscribe to a topic

<?php
$subid = $conn->subscribe('topic://A');
if (!$subid) {
  // The subscribe failed!
  echo "Subscribe failed ($conn->errno) $conn->error";
}
?>

Viz také

SAMConnection->unsubscribe()

Předcházející | Nahoru | Další
SAMConnection::setDebug() | Domů | SAMConnection->unsubscribe()


SAMConnection->unsubscribe()

(No version information available, might be only in CVS)

SAMConnection->unsubscribe() — Cancel a subscription to a specified topic.

Popis

class SAMConnection {
bool unsubscribe ( string $subscriptionId [, string $targetTopic] )
}

The "unsubscribe" method is used to delete an existing subscription to a specified topic.

Seznam parametrů

subscriptionId

The identifier of an existing subscription as returned by a call to the subscribe method.

Návratové hodnoty

This method returns FALSE if an error occurs.

Příklady

Příklad 1920. Delete a subscription

<?php
if (!$conn->unsubscribe($subid)) {
    // The unsubscribe failed!
    echo "Unsubscribe failed ($conn->errno) $conn->error";
}
?>

Viz také

SAMConnection->subscribe()

Předcházející | Nahoru | Další
SAMConnection->subscribe() | Domů | SAMMessage->body


SAMMessage->body

(No version information available, might be only in CVS)

SAMMessage->body — The body of the message.

Popis

class SAMMessage {
string nody
}

The "body" property contains the actual body of the message. It may not always be set.

Příklady

Příklad 1921. Setting a text string into the body of a message

<?php
$msg = new SAMMessage();
$msg->body = 'This is a simple message';

?>

Viz také

SAMMessage->header

Předcházející | Nahoru | Další
SAMConnection->unsubscribe() | Domů | SAMMessage->__construct()


SAMMessage->__construct()

(No version information available, might be only in CVS)

SAMMessage->__construct() — Creates a new Message object

Popis

class SAMMessage {
__construct ( [mixed $body] )
}

Creates a new SAMMessage object optionally specifying a message body.

Seznam parametrů

body

The optional body for the message.

Příklady

Příklad 1922. Creating a message

<?php

$msg = new SAMMessage();

?>

Příklad 1923. Creating a message with a simple text payload

<?php

$msg = new SAMMessage('This is a simple text message');

?>

Předcházející | Nahoru | Další
SAMMessage->body | Domů | SAMMessage->header


SAMMessage->header

(No version information available, might be only in CVS)

SAMMessage->header — The header properties of the message.

Popis

class SAMMessage {
object header
}

The header property is a container for any system or user properties that area associated with the message.

Properties may be assigned by the sender of a message to control the way the messaging systems handles it or may be assigned by the messaging system itself to tell the recipient extra information about the message or the way in which it has been handled.

Some properties are understood by SAM in which case constants have been defined for them. The majority of properties however are ignored by the SAM implementation and simply passed through to the underlying messaging systems allowing the application to use messaging specific property names or to define its own "user" properties.

The SAM defined properties are as follows:

Property name | Possible values
SAM_MESSAGEID | When a message is received this field contains the unique identifier of the message as allocated by the underlying messaging system. When sending a message this field is ignored.
SAM_REPLY_TO | A string providing the identity of the queue on to which responses to this message should be posted.
SAM_TYPE

An indication of the type of message to be sent. The value may be SAM_TEXT indicating the contents of the message body is a text string, or SAM_BYTES indicating the contents of the message body are some application defined format.

The way in which this property is used may depend on the underlying messaging server. For instance a messaging server that supports the JMS (Java Message Service) specification may interpret this value and send messages of type "jms_text" and "jms_bytes". In addition, if the SAM_TYPE property is set to SAM_TEXT the data provided for the message body is expected to be a UTF8 encoded string.

When setting the values of properties it is often useful to give a hint as to the format in which the property should be delivered to the messaging system. By default property values are delivered as text and the following simple syntax may be used to set a value:

Příklad 1924. Setting a text format property using the default syntax

<?php
$msg = new SAMMessage();

$msg->header->myPropertyName = 'textData';
?>

If it is desired to pass type information an alternative syntax may be used where the value and the type hint are passed in an associative array:

Příklad 1925. Setting a text format property using a type hint

<?php
$msg = new SAMMessage();

$msg->header->myPropertyName = array('textData', SAM_STRING);
?>

When passing a type hint the type entry should be one of the SAM defined constant values as defined by the following table:

Constant | Type description
SAM_BOOLEAN | Any value passed will be interpreted as logical true or false. If the value cannot be interpreted as a PHP boolean value the value passed to the messaging system is undefined.
SAM_BYTE | An 8-bit signed integer value. SAM will attempt to convert the property value specified into a single byte value to pass to the messaging system. If a string value is passed an attempt will be made to interpret the string as a numeric value. If the numeric value cannot be expressed as an 8-bit signed binary value data may be lost in the conversion.
SAM_DOUBLE | A long floating point value. SAM will attempt to convert the property value specified into a floating point value with 15 digits of precision. If a string value is passed an attempt will be made to interpret the string as a numeric value. If the passed value cannot be expressed as a 15 digit floating point value data may be lost in the conversion.
SAM_FLOAT | A short floating point value. SAM will attempt to convert the property value specified into a floating point value with 7 digits of precision. If a string value is passed an attempt will be made to interpret the string as a numeric value. If the passed value cannot be expressed as a 7 digit floating point value data may be lost in the conversion.
SAM_INT | An 32-bit signed integer value. SAM will attempt to convert the property value specified into a 32-bit value to pass to the messaging system. If a string value is passed an attempt will be made to interpret the string as a numeric value. If the numeric value cannot be expressed as an 32-bit signed binary value data may be lost in the conversion.
SAM_LONG | An 64-bit signed integer value. SAM will attempt to convert the property value specified into a 64-bit value to pass to the messaging system. If a string value is passed an attempt will be made to interpret the string as a numeric value. If the numeric value cannot be expressed as an 64-bit signed binary value data may be lost in the conversion.
SAM_STRING | SAM will interpret the property value specified as a string and pass it to the messaging system accordingly.

Příklady

Příklad 1926. Setting properties as the sender of a message

<?php
$msg = new SAMMessage('This is a test message');

// defining SAM specific properties...
$msg->header->SAM_REPLY_TO = 'queue://test/replyQueue';

// defining arbitrary properties...
//
// a default string property
$msg->header->myStringProp1 = 'a string property';
// a string property with a type hint
$msg->header->myStringProp2 = array('another string property', SAM_STRING);

// a boolean property
$msg->header->myBoolProp = array(FALSE, SAM_BOOL);

// numeric format properties
$msg->header->myIntProp = array(32768, SAM_INT);
$msg->header->myLongProp = array(9876543, SAM_LONG);
$msg->header->myByteProp1 = array(123, SAM_BYTE);
$msg->header->myByteProp2 = array('12', SAM_BYTE);
$msg->header->myFloatProp = array(3.141592, SAM_FLOAT);
$msg->header->myDoubleProp = array(3.14159265358979, SAM_DOUBLE);
?>

Příklad 1927. Retreiving property values from a message

<?php

// accessing an application specific property
$intProp = $msg->header->'MyIntProp';

// accessing a messaging system specific property
$encoding = $msg->header->'JMS_IBM_Msgtype';

?>

Viz také

SAMMessage->body

Předcházející | Nahoru | Další
SAMMessage->__construct() | Domů | CXLI. Satellite CORBA klient extenze


satellite_caught_exception

(PHP 4 >= 4.0.3)

satellite_caught_exception — Zjistit, jestli byla v předchozí funkci zachycena výjimka

Popis

bool satellite_caught_exception ( void )

Tato funkce vrací TRUE, pokud byla zachycena výjimka.

Příklad 1934. Ukázkový IDL soubor

/* ++?????++ Out of Cheese Error. Redo From Start. */
exception OutOfCheeseError {
    int parameter;
}

interface AnotherInterface {
    void AskWhy() raises (OutOfCheeseError);
}

Příklad 1935. PHP kód pro zpracování CORBA výjimek

<?php
$obj = new OrbitObject ($ior);

$obj->AskWhy();

if (satellite_caught_exception()) {
    if ("IDL:OutOfCheeseError:1.0" == satellite_exception_id()) {
        $exception = satellite_exception_value();
        echo $exception->parameter;
    }
}
?>

Předcházející | Nahoru | Další
OrbitStruct | Domů | satellite_exception_id


satellite_exception_id

(PHP 4 >= 4.0.3)

satellite_exception_id — Zjistit repository id poslední výjimky

Popis

string satellite_exception_id ( void )

Vrací řetězec obsahující repository id (napr. "IDL:MyException:1.0".). Ukázkové použití viz satellite_caught_exception().

Předcházející | Nahoru | Další
satellite_caught_exception | Domů | satellite_exception_value


satellite_exception_value

(PHP 4 >= 4.0.3)

satellite_exception_value — Získat strukturu poslední výjimky

Popis

OrbitStruct satellite_exception_value ( void )

Vrátí strukturu výjimky. Ukázkové použití viz satellite_caught_exception().

Předcházející | Nahoru | Další
satellite_exception_id | Domů | satellite_get_repository_id


satellite_get_repository_id

(PHP 4 >= 4.0.3)

satellite_get_repository_id — NOT IMPLEMENTED

Popis

int satellite_get_repository_id ( object $obj )

Not implemented.

Předcházející | Nahoru | Další
satellite_exception_value | Domů | satellite_load_idl


satellite_load_idl

(PHP 4 >= 4.0.3)

satellite_load_idl — Instruct the type manager to load an IDL file

Popis

bool satellite_load_idl ( string $file )

Load an IDL file into Satellite.

Předcházející | Nahoru | Další
satellite_get_repository_id | Domů | satellite_object_to_string


satellite_object_to_string

(PHP 4 >= 4.0.7)

satellite_object_to_string — Convert an object to its string representation

Popis

string satellite_object_to_string ( object $obj )

Convert an object to its string representation (IOR).

Předcházející | Nahoru | Další
satellite_load_idl | Domů | CXLII. SCA Functions


SCA::createDataObject

(No version information available, might be only in CVS)

SCA::createDataObject — create an SDO

Popis

SDO_DataObject SCA::createDataObject ( string $type_namespace_uri, string $type_name )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

This method is used inside an SCA component that needs to create an SDO to return. The parameters are the desired SDO's namespace URI and type name. The namespace and type must be defined in one of the schema files which are specfied on the @types annotation within the component.

Seznam parametrů

type_namespace_uri

The namespace of the type.

type_name

The name of the type.

Návratové hodnoty

Returns the newly created SDO_DataObject.

Errors/Exceptions

SDO_TypeNotFoundException

Thrown if the namespaceURI and typeName do not correspond to a type in any of the schema files specified in the @types annotations.

Předcházející | Nahoru | Další
SCA_SoapProxy::createDataObject | Domů | SCA::getService


SCA::getService

(No version information available, might be only in CVS)

SCA::getService — Obtain a proxy for a service

Popis

mixed SCA::getService ( string $target [, string $binding [, array $config]] )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Examine the target and initialise and return a proxy of the appropriate sort. If the target is for a local PHP component the returned proxy will be an SCA_LocalProxy. If the target is for a WSDL file, the returned proxy will be a SCA_SoapProxy.

Seznam parametrů

target

An absolute or relative path to the target service or service description (e.g. a URL to a json-rpc service description, a PHP component, a WSDL file, and so on.). A relative path, if specified, is resolved relative to the location of the script issuing the getService() call, and not against the include_path or current working directory.

binding

The binding (i.e. protocol) to use to communicate with the service (e.g binding.jsonrpc for a json-rpc service). Note, some service types can be deduced from the target parameter (e.g. if the target parameter ends in .wsdl then SCA will assume binding.soap). Any binding which can be specified in an annotation can be specified here. For example 'binding.soap' is equivalent to the '@binding.soap' annotation.

config

Any additional configuration prioperties for the binding (e.g. array('location' => 'http://example.org')). Any binding configuration which can be specified in an annotation can be specified here. For example, 'location' is equivalent to the '@location' annotation to configure the location of a target soap service.

Návratové hodnoty

The SCA_LocalProxy or SCA_SoapProxy.

Příklady

Příklad 1950. An SCA::getService() example

This example shows how to get a proxy to an email soap service described by EmailService.wsdl and located at http://example.org.

<?php
include 'SCA/SCA.php';
$service = SCA::getService('EmailService.wsdl', 'binding.soap', array('location' => 'http://example.org'));
$service->send(...);
?>

Výše uvedený příklad vypíše:

Předcházející | Nahoru | Další
SCA::createDataObject | Domů | CXLIII. SDO Functions


SCA_LocalProxy::createDataObject

(No version information available, might be only in CVS)

SCA_LocalProxy::createDataObject — create an SDO

Popis

SDO_DataObject SCA_LocalProxy::createDataObject ( string $type_namespace_uri, string $type_name )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

This method is used inside either an ordinary PHP script or an SCA component that needs to create an SDO to pass to a local service. The parameters are the desired SDO's namespace URI and type name. The namespace and type must be defined in the interface of the component that is to be called, so the namespace and type must be defined in one of the schema files which are specfied on the @types annotation within the component for which the SCA_LocalProxy object is a proxy.

Seznam parametrů

type_namespace_uri

The namespace of the type.

type_name

The name of the type.

Návratové hodnoty

Returns the newly created SDO_DataObject.

Errors/Exceptions

SDO_TypeNotFoundException

Thrown if the namespaceURI and typeName do not correspond to a type in any of the schema files specified in the @types annotations within the component for which the SCA_LocalProxy object is a proxy..

Předcházející | Nahoru | Další
CXLII. SCA Functions | Domů | SCA_SoapProxy::createDataObject


SCA_SoapProxy::createDataObject

(No version information available, might be only in CVS)

SCA_SoapProxy::createDataObject — create an SDO

Popis

SDO_DataObject SCA_SoapProxy::createDataObject ( string $type_namespace_uri, string $type_name )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

This method is used inside either an ordinary PHP script or an SCA component that needs to create an SDO to pass to a web service. The parameters are the desired SDO's namespace URI and type name. The namespace and type must be defined in the interface of the component that is to be called, so the namespace and type must be defined within the WSDL for the web service. If the web service is also an SCA component then the types will have been defined within one of the schema files which are specfied on the @types annotation within the component for which the SCA_SoapProxy object is a proxy.

Seznam parametrů

type_namespace_uri

The namespace of the type.

type_name

The name of the type.

Návratové hodnoty

Returns the newly created SDO_DataObject.

Errors/Exceptions

SDO_TypeNotFoundException

Thrown if the namespaceURI and typeName do not correspond to a type found in the WSDL that was used to initialise this SCA_SoapProxy.

Předcházející | Nahoru | Další
SCA_LocalProxy::createDataObject | Domů | SCA::createDataObject


SDO_DAS_ChangeSummary::beginLogging

(No version information available, might be only in CVS)

SDO_DAS_ChangeSummary::beginLogging — Begin change logging

Popis

void SDO_DAS_ChangeSummary::beginLogging ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Begin logging changes made to the SDO_DataObject.

Seznam parametrů

None.

Návratové hodnoty

None.

Předcházející | Nahoru | Další
CXLIII. SDO Functions | Domů | SDO_DAS_ChangeSummary::endLogging


SDO_DAS_ChangeSummary::endLogging

(No version information available, might be only in CVS)

SDO_DAS_ChangeSummary::endLogging — End change logging

Popis

void SDO_DAS_ChangeSummary::endLogging ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

End logging changes made to an SDO_DataObject.

Seznam parametrů

None.

Návratové hodnoty

None.

Předcházející | Nahoru | Další
SDO_DAS_ChangeSummary::beginLogging | Domů | SDO_DAS_ChangeSummary::getChangeType


SDO_DAS_ChangeSummary::getChangedDataObjects

(No version information available, might be only in CVS)

SDO_DAS_ChangeSummary::getChangedDataObjects — Get the changed data objects from a change summary

Popis

SDO_List SDO_DAS_ChangeSummary::getChangedDataObjects ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Get an SDO_List of the SDO_DataObjects which have been changed. These data objects can then be used to identify the types of change made to each, along with the old values.

Seznam parametrů

None.

Návratové hodnoty

Returns an SDO_List of SDO_DataObjects.

Předcházející | Nahoru | Další
SDO_DAS_ChangeSummary::getChangeType | Domů | SDO_DAS_ChangeSummary::getOldContainer


SDO_DAS_ChangeSummary::getChangeType

(No version information available, might be only in CVS)

SDO_DAS_ChangeSummary::getChangeType — Get the type of change made to an SDO_DataObject

Popis

int SDO_DAS_ChangeSummary::getChangeType ( SDO_DataObject $dataObject )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Get the type of change which has been made to the supplied SDO_DataObject.

Seznam parametrů

dataObject

The SDO_DataObject which has been changed.

Návratové hodnoty

The type of change which has been made. The change type is expressed as an enumeration and will be one of the following four values:

  • SDO_DAS_ChangeSummary::NONE

  • SDO_DAS_ChangeSummary::MODIFICATION

  • SDO_DAS_ChangeSummary::ADDITION

  • SDO_DAS_ChangeSummary::DELETION

Předcházející | Nahoru | Další
SDO_DAS_ChangeSummary::endLogging | Domů | SDO_DAS_ChangeSummary::getChangedDataObjects


SDO_DAS_ChangeSummary::getOldContainer

(No version information available, might be only in CVS)

SDO_DAS_ChangeSummary::getOldContainer — Get the old container for a deleted SDO_DataObject

Popis

SDO_DataObject SDO_DAS_ChangeSummary::getOldContainer ( SDO_DataObject $data_object )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Get the old container (SDO_DataObject) for a deleted SDO_DataObject.

Seznam parametrů

data_object

The SDO_DataObject which has been deleted and whose container we wish to identify.

Návratové hodnoty

The old containing data object of the deleted SDO_DataObject.

Předcházející | Nahoru | Další
SDO_DAS_ChangeSummary::getChangedDataObjects | Domů | SDO_DAS_ChangeSummary::getOldValues


SDO_DAS_ChangeSummary::getOldValues

(No version information available, might be only in CVS)

SDO_DAS_ChangeSummary::getOldValues — Get the old values for a given changed SDO_DataObject

Popis

SDO_List SDO_DAS_ChangeSummary::getOldValues ( SDO_DataObject $data_object )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Get a list of the old values for a given changed SDO_DataObject. Returns a list of SDO_DAS_Settings describing the old values for the changed properties of the SDO_DataObject.

Seznam parametrů

data_object

The data object which has been changed.

Návratové hodnoty

A list of SDO_DAS_Settings describing the old values for the changed properties of the SDO_DataObject. If the change type is SDO_DAS_ChangeSummary::ADDITION, this list is empty.

Předcházející | Nahoru | Další
SDO_DAS_ChangeSummary::getOldContainer | Domů | SDO_DAS_ChangeSummary::isLogging


SDO_DAS_ChangeSummary::isLogging

(No version information available, might be only in CVS)

SDO_DAS_ChangeSummary::isLogging — Test to see whether change logging is switched on

Popis

bool SDO_DAS_ChangeSummary::isLogging ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Test to see whether change logging is switched on.

Seznam parametrů

None.

Návratové hodnoty

Returns TRUE if change logging is on, otherwise returns FALSE.

Předcházející | Nahoru | Další
SDO_DAS_ChangeSummary::getOldValues | Domů | SDO_DAS_DataFactory::addPropertyToType


SDO_DAS_DataFactory::addPropertyToType

(No version information available, might be only in CVS)

SDO_DAS_DataFactory::addPropertyToType — Adds a property to a type

Popis

void SDO_DAS_DataFactory::addPropertyToType ( string $parent_type_namespace_uri, string $parent_type_name, string $property_name, string $type_namespace_uri, string $type_name [, array $options] )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Adds a property to a type. The type must already be known to the SDO_DAS_DataFactory (i.e. have been added using addType()). The property becomes a property of the type. This is how the graph model for the structure of an SDO_DataObject is built.

Seznam parametrů

parent_type_namespace_uri

The namespace URI for the parent type.

parent_type_name

The type name for the parent type.

property_name

The name by which the property will be known in the parent type.

type_namespace_uri

The namespace URI for the type of the property.

type_name

The type name for the type of the property

options

This array holds one or more key=>value pairs to set attribute values for the property. The optional keywords are:

many

A flag to say whether the property is many-valued. A value of 'true' adds the property as a many-valued property (default is 'false').

readOnly

A flag to say whether the property is read-only. A value of 'true' means the property value cannot be modified through the SDO application APIs (default is 'false').

containment

A flag to say whether the property is contained by the parent. A value of 'true' means the property is contained by the parent. A value of 'false' results in a non-containment reference (default is 'true'). This flag is only interpreted when adding properties which are data object types, otherwise it is ignored.

default

A default value for the property. Omitting this key means that the property does not have a default value. A property can only have a default value if it is a single-valued data type (primitive).

Návratové hodnoty

None.

ChangeLog (záznam změn)

Verze | Popis
0.5.2 | Optional parameters many, readOnly, and containment deprecated in favour of the options array.

Příklady

Příklad 1973. A SDO_DAS_DataFactory::addPropertyToType() example

The following adds an 'addressline' property to a Person type. The person type is identified by its namespace, 'PersonNS', and type name, 'PersonType'. The type of the 'addressline' property is a many-valued SDO data type (primitive) with namespace 'commonj.sdo' and type name 'String'.

<?php
  $df->addPropertyToType('PersonNS', 'PersonType',
    'addressline', 'commonj.sdo', 'String', array('many'=>true));
?>

Předcházející | Nahoru | Další
SDO_DAS_ChangeSummary::isLogging | Domů | SDO_DAS_DataFactory::addType


SDO_DAS_DataFactory::addType

(No version information available, might be only in CVS)

SDO_DAS_DataFactory::addType — Add a new type to a model

Popis

void SDO_DAS_DataFactory::addType ( string $type_namespace_uri, string $type_name [, array $options] )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Add a new type to the SDO_DAS_DataFactory, defined by its namespace and type name. The type becomes part of the model of data objects that the data factory can create.

Seznam parametrů

type_namespace_uri

The namespace of the type.

type_name

The name of the type.

options

This array holds one or more key=>value pairs to set attribute values for the type. The optional keywords are:

open

A flag to say whether the type is open. An SDO_DataObject whose type is open can have properties added to them which are not described by the type. This capability is used to support working with XML documents whose schema support open content such as that described by an <xsd:any> element. The default value is 'false'.

sequenced

A flag to say whether the type is sequenced. Sequenced types can have the ordering across properties preserved and can contain unstructured text. The default value is 'false'. For more information on sequenced types see the section on Working with Sequenced Data Objects.

basetype

If specified, an array of namespace URI and type name strings for the type from which this type is derived. An example of the use of base types is when a type derived in an XML schema inherits from another type by using <extension base="...">.

Návratové hodnoty

None.

Příklady

Příklad 1974. A SDO_DAS_DataFactory::addType() example

The following adds a new data object type of 'CompanyType' where that type belongs to the namespace 'CompanyNS'.

<?php
  $df->addType('CompanyNS', 'CompanyType');
?>

Předcházející | Nahoru | Další
SDO_DAS_DataFactory::addPropertyToType | Domů | SDO_DAS_DataFactory::getDataFactory


SDO_DAS_DataFactory::getDataFactory

(No version information available, might be only in CVS)

SDO_DAS_DataFactory::getDataFactory — Get a data factory instance

Popis

SDO_DAS_DataFactory SDO_DAS_DataFactory::getDataFactory ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Static method to get an instance of an SDO_DAS_DataFactory. This instance is initially only configured with the basic SDO types. A Data Access Service is responsible for populating the data factory model and then allowing PHP applications to create SDOs based on the model through the SDO_DataFactory interface. PHP applications should always obtain a data factory from a configured Data Access Service, not through this interface.

Seznam parametrů

None.

Návratové hodnoty

Returns an SDO_DAS_DataFactory.

Předcházející | Nahoru | Další
SDO_DAS_DataFactory::addType | Domů | SDO_DAS_DataObject::getChangeSummary


SDO_DAS_DataObject::getChangeSummary

(No version information available, might be only in CVS)

SDO_DAS_DataObject::getChangeSummary — Get a data object's change summary

Popis

SDO_DAS_ChangeSummary SDO_DAS_DataObject::getChangeSummary ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Get the SDO_DAS_ChangeSummary for an SDO_DAS_DataObject, or NULL if it does not have one.

Seznam parametrů

None.

Návratové hodnoty

Returns the SDO_DAS_ChangeSummary for an SDO_DAS_DataObject, or NULL if it does not have one.

Předcházející | Nahoru | Další
SDO_DAS_DataFactory::getDataFactory | Domů | SDO_DAS_Setting::getListIndex


SDO_DAS_Relational::applyChanges

(No version information available, might be only in CVS)

SDO_DAS_Relational::applyChanges — Applies the changes made to a data graph back to the database.

Popis

void SDO_DAS_Relational::applyChanges ( PDO $database_handle, SDODataObject $root_data_object )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Given a PDO database handle and the special root object of a data graph, examine the change summary in the datagraph and applies the changes to the database. The changes that it can apply can be creations of data objects, deletes of data objects, and modifications to properties of data objects.

Seznam parametrů

PDO_database_handle

Constructed using the PDO extension. A typical line to construct a PDO database handle might look like this: $dbh = new PDO("mysql:dbname=COMPANYDB;host=localhost",DATABASE_USER,DATABASE_PASSWORD);

root_data_object

The special root object which is at the top of every SDO data graph.

Návratové hodnoty

None. Note however that the datagraph that was passed is still intact and usable. Furthermore, if data objects were created and written back to a table with autogenerated primary keys, then those primary keys will now be set in the data objects. If the changes were successfully written, then the change summary associated with the datagraph will have been cleared, so that it is possible to now make further changes to the data graph and apply those changes in turn. In this way it is possible to work with the same data graph and apply changes repeatedly.

Errors/Exceptions

SDO_DAS_Relational::applyChanges() can throw an SDO_DAS_Relational_Exception if it is unable to apply all the changes correctly.

The Relational DAS starts a database transaction before beginning to apply the changes and will commit the transaction only if they are all successful. The Relational DAS generates qualified update and delete statements which contain a where clause that specifies that the row to be updated or deleted must contain the same values that it did when the data was first retrieved. This is how the the optimistic concurrency is implemented. If any of the qualified update or delete statements fails to update or delete their target row, it may be because the data has been altered in the database in the meantime. In any event, if any update fails for any reason, the transaction is rolled back and an exception thrown. The exception will contain the generated SQL statement that failed.

The Relational DAS also catches any PDO exceptions and obtains PDO diagnostic information which it includes in an SDO_DAS_Relational_Exception which it then throws.

Příklady

Please see the Examples section in the general information about the Relational DAS for many examples of calling this method. Please see also the section on Tracing to see how you can see what SQL statements are generated by the Relational DAS.

Předcházející | Nahoru | Další
CXLV. SDO Relational Data Access Service Functions | Domů | SDO_DAS_Relational::__construct


SDO_DAS_Relational::__construct

(No version information available, might be only in CVS)

SDO_DAS_Relational::__construct — Creates an instance of a Relational Data Access Service

Popis

SDO_DAS_Relational SDO_DAS_Relational::__construct ( array $database_metadata [, string $application_root_type [, array $SDO_containment_references_metadata]] )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Constructs an instance of a Relational Data Access Service from the passed metadata.

Seznam parametrů

database_metadata

An array containing one or more table definitions, each of which is an associative array containing the keys name, columns, PK, and optionally, FK. For a full discussion of the metadata, see the metadata section in the general information about the Relational DAS.

application_root_type

The root of each data graph is an object of a special root type and the application data objects come below that. Of the various application types in the SDO model, one has to be the the application type immediately below the root of the data graph. If there is only one table in the database metadata, so the application root type can be inferred, this argument can be omitted.

SDO_containment_references_metadata

An array containing one or more definitions of a containment relation, each of which is an associative array containing the keys parent and child. The containment relations describe how the types in the model are connected to form a tree. The type specified as the application root type must be present as one of the parent types in the containment references. If the application only needs to work with one table at a time, and there are no containment relations in the model, this argument can be omitted. For a full discussion of the metadata, see the metadata section in the general information about the Relational DAS.

Návratové hodnoty

Returns an SDO_DAS_Relational object on success.

Errors/Exceptions

SDO_DAS_Relational::__construct() throws a SDO_DAS_Relational_Exception if any problems are found in the metadata.

Příklady

For a full discussion of the metadata, see the metadata section in the general information about the Relational DAS.

Předcházející | Nahoru | Další
SDO_DAS_Relational::applyChanges | Domů | SDO_DAS_Relational::createRootDataObject


SDO_DAS_Relational::createRootDataObject

(No version information available, might be only in CVS)

SDO_DAS_Relational::createRootDataObject — Returns the special root object in an otherwise empty data graph. Used when creating a data graph from scratch.

Popis

SDODataObject SDO_DAS_Relational::createRootDataObject ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the special root object at the top of an otherwise empty data graph. This call is used when the application wants to create a data graph from scratch, without having called executeQuery() to create a data graph.

The special root object has one multi-valued containment property, with a name of the application root type that was passed when the Relational DAS was constructed. The property can take values of only that type. The only thing that the application can usefully do with the root type is to call createDataObject() on it, passing the name of the application root type, in order to create a data object of their own application type.

Seznam parametrů

None.

Návratové hodnoty

The root object.

Errors/Exceptions

None.

Příklady

Please see the Examples section in the general information about the Relational DAS for many examples of calling this method.

Předcházející | Nahoru | Další
SDO_DAS_Relational::__construct | Domů | SDO_DAS_Relational::executePreparedQuery


SDO_DAS_Relational::executePreparedQuery

(No version information available, might be only in CVS)

SDO_DAS_Relational::executePreparedQuery — Executes an SQL query passed as a prepared statement, with a list of values to substitute for placeholders, and return the results as a normalised data graph.

Popis

SDODataObject SDO_DAS_Relational::executePreparedQuery ( PDO $database_handle, PDOStatement $prepared_statement, array $value_list [, array $column_specifier] )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Executes a given query against the relational database, using the supplied PDO database handle. Differs from the simpler executeQuery() in that it takes a prepared statement and a list of values. This is the appropriate call to use either when the statement is to executed a number of times with different arguments, and there is therefore a performance benefit to be had from preparing the statement only once, or when the the SQL statement is to contain varying values taken from a source that cannot be completely trusted. In this latter case it may be unsafe to construct the SQL statement by simply concatenating the parts of the statement together, since the values may contain pieces of SQL. To guard against this, a so-called SQL injection attack, it is safer to prepare the SQL statement with placeholders (also known as parameter markers, denoted by '?') and supply a list of the values to be substituted as a separate argument. Otherwise this function is the same as executeQuery() in that it uses the model that it built from the the metadata to interpret the result set and returns a data graph.

Seznam parametrů

PDO_database_handle

Constructed using the PDO extension. A typical line to construct a PDO database handle might look like this: $dbh = new PDO("mysql:dbname=COMPANYDB;host=localhost",DATABASE_USER,DATABASE_PASSWORD);

prepared_statement

A prepared SQL statement to be executed against the database. This will have been prepared by PDO's prepare() method.

value_list

An array of the values to be substituted into the SQL statement in place of the placeholders. In the event that there are no placeholders or parameter markers in the SQL statement then this argument can be specified as NULL or as an empty array;

column_specifier

The Relational DAS needs to examine the result set and for every column, know which table and which column of that table it came from. In some circumstances it can find this information for itself, but sometimes it cannot. In these cases a column specifier is needed, which is an array that identifies the columns. Each entry in the array is simply a string in the form table-name.column_name.

The column specifier is needed when there are duplicate column names in the database metadata, For example, in the database used within the examples, all the tables have both a id and a name column. When the Relational DAS fetches the result set from PDO it can do so with the PDO_FETCH_ASSOC attribute, which will cause the columns in the results set to be labelled with the column name, but will not distinguish duplicates. So this will only work when there are no duplicates possible in the results set.

To summarise, specify a column specifier array whenever there is any uncertainty about which column could be from which table and only omit it when every column name in the database metadata is unique.

All of the examples in the Examples use a column specifier. There is one example in the Scenarios directory of the installation that does not: that which works with just the employee table, and because it works with just one table, there can not exist duplicate column names.

Návratové hodnoty

Returns a data graph. Specifically, it returns a root object of a special type. Under this root object will be the data from the result set. The root object will have a multi-valued containment property with the same name as the application root type specified on the constructor, and that property will contain one or more data objects of the application root type.

In the event that the query returns no data, the special root object will still be returned but the containment property for the application root type will be empty.

Errors/Exceptions

SDO_DAS_Relational::executePreparedQuery() can throw an SDO_DAS_Relational_Exception if it is unable to construct the data graph correctly. This can occur for a number of reasons: for example if it finds that it does not have primary keys in the result set for all the objects. It also catches any PDO exceptions and obtains PDO diagnostic information which it includes in an SDO_DAS_Relational_Exception which it then throws.

Příklady

Příklad 1991. Retrieving a data object using executePreparedQuery()

In this example a single data object is retrieved from the database - or possibly more than one if there is more than one company called 'Acme'. For each company returned, the name and id properties are echoed.

Other examples of the use of executePreparedQuery() can be found in the example code supplied in sdo/DAS/Relational/Scenarios .

<?php
require_once 'SDO/DAS/Relational.php';
require_once 'company_metadata.inc.php';

/**************************************************************
 * Construct the DAS with the metadata
 ***************************************************************/
$das = new SDO_DAS_Relational ($database_metadata,'company',$SDO_reference_metadata);

/**************************************************************
 * Get a database connection
 ***************************************************************/
$dbh = new PDO(PDO_DSN,DATABASE_USER,DATABASE_PASSWORD);

/**************************************************************
 * Issue a query to obtain a company object - possibly more if they exist
 * Use a prepared query with a placeholder.
 ***************************************************************/
$name = 'Acme';
$pdo_stmt = $dbh->prepare('select name, id from company where name=?');
$root = $das->executePreparedQuery(
    $dbh,
    $pdo_stmt,
    array($name),
    array('company.name', 'company.id'));

/**************************************************************
 * Echo name and id
 ***************************************************************/
foreach ($root['company'] as $company) {
    echo "Company obtained from the database has name = " .
    $company['name'] . " and id " . $company['id'] . "\n";
}
?>

Předcházející | Nahoru | Další
SDO_DAS_Relational::createRootDataObject | Domů | SDO_DAS_Relational::executeQuery


SDO_DAS_Relational::executeQuery

(No version information available, might be only in CVS)

SDO_DAS_Relational::executeQuery — Executes a given SQL query against a relational database and returns the results as a normalised data graph.

Popis

SDODataObject SDO_DAS_Relational::executeQuery ( PDO $database_handle, string $SQL_statement [, array $column_specifier] )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Executes a given query against the relational database, using the supplied PDO database handle. Uses the model that it built from the the metadata to interpret the result set. Returns a data graph.

Seznam parametrů

PDO_database_handle

Constructed using the PDO extension. A typical line to construct a PDO database handle might look like this: $dbh = new PDO("mysql:dbname=COMPANYDB;host=localhost",DATABASE_USER,DATABASE_PASSWORD);

SQL_statement

The SQL statement to be executed against the database.

column_specifier

The Relational DAS needs to examine the result set and for every column, know which table and which column of that table it came from. In some circumstances it can find this information for itself, but sometimes it cannot. In these cases a column specifier is needed, which is an array that identifies the columns. Each entry in the array is simply a string in the form table-name.column_name.

The column specifier is needed when there are duplicate column names in the database metadata. For example, in the database used within the examples, all the tables have both a id and a name column. When the Relational DAS fetches the result set from PDO it can do so with the PDO_FETCH_ASSOC attribute, which will cause the columns in the results set to be labelled with the column name, but will not distinguish duplicates. So this will only work when there are no duplicates possible in the results set.

To summarise, specify a column specifier array whenever there is any uncertainty about which column could be from which table and only omit it when every column name in the database metadata is unique.

All of the examples in the Examples use a column specifier. There is one example in the Scenarios directory of the installation that does not: that which works with just the employee table, and because it works with just one table, there can not exist duplicate column names.

Návratové hodnoty

Returns a data graph. Specifically, it returns a root object of a special type. Under this root object will be the data from the result set. The root object will have a multi-valued containment property with the same name as the application root type specified on the constructor, and that property will contain one or more data objects of the application root type.

In the event that the query returns no data, the special root object will still be returned but the containment property for the application root type will be empty.

Errors/Exceptions

SDO_DAS_Relational::executeQuery() can throw an SDO_DAS_Relational_Exception if it is unable to construct the data graph correctly. This can occur for a number of reasons: for example if it finds that it does not have primary keys in the result set for all the objects. It also catches any PDO exceptions and obtains PDO diagnostic information which it includes in an SDO_DAS_Relational_Exception which it then throws.

Příklady

Please see the Examples section in the general information about the Relational DAS for many examples of calling this method.

Předcházející | Nahoru | Další
SDO_DAS_Relational::executePreparedQuery | Domů | CXLVI. Semaphore, Shared Memory and IPC Functions


SDO_DAS_Setting::getListIndex

(No version information available, might be only in CVS)

SDO_DAS_Setting::getListIndex — Get the list index for a changed many-valued property

Popis

int SDO_DAS_Setting::getListIndex ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Get the list index for a modification made to an element of a many-valued property. For example, if we modified the third element of a many-valued property we could obtain an SDO_DAS_Setting from the change summary corresponding to that modification. A call to getListIndex() on that setting would return the value 2 (lists are indexed from zero).

Seznam parametrů

None.

Návratové hodnoty

The list index for the element of the many-valued property which has been changed.

Předcházející | Nahoru | Další
SDO_DAS_DataObject::getChangeSummary | Domů | SDO_DAS_Setting::getPropertyIndex


SDO_DAS_Setting::getPropertyIndex

(No version information available, might be only in CVS)

SDO_DAS_Setting::getPropertyIndex — Get the property index for a changed property

Popis

int SDO_DAS_Setting::getPropertyIndex ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the property index for the changed property. This index identifies the property which was modified in data object.

Seznam parametrů

None.

Návratové hodnoty

The property index for a changed property.

Předcházející | Nahoru | Další
SDO_DAS_Setting::getListIndex | Domů | SDO_DAS_Setting::getPropertyName


SDO_DAS_Setting::getPropertyName

(No version information available, might be only in CVS)

SDO_DAS_Setting::getPropertyName — Get the property name for a changed property

Popis

string SDO_DAS_Setting::getPropertyName ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the property name for the changed property. This name identifies the property which was modified in data object.

Seznam parametrů

None.

Návratové hodnoty

The property name for a changed property.

Předcházející | Nahoru | Další
SDO_DAS_Setting::getPropertyIndex | Domů | SDO_DAS_Setting::getValue


SDO_DAS_Setting::getValue

(No version information available, might be only in CVS)

SDO_DAS_Setting::getValue — Get the old value for the changed property

Popis

mixed SDO_DAS_Setting::getValue ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the old value for the changed property. This can be used by a Data Access Service when writing updates to a data source. The DAS uses the old value to detect conflicts by comparing it with the current value in the data source. If they do not match, then the data source has been updated since the data object was originally populated, and therefore writing any new updates risks compromising the integrity of the data.

Seznam parametrů

None.

Návratové hodnoty

Returns the old value of the changed property.

Předcházející | Nahoru | Další
SDO_DAS_Setting::getPropertyName | Domů | SDO_DAS_Setting::isSet


SDO_DAS_Setting::isSet

(No version information available, might be only in CVS)

SDO_DAS_Setting::isSet — Test whether a property was set prior to being modified

Popis

bool SDO_DAS_Setting::isSet ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Test whether a property was set prior to being modified. If it was set prior to being modified then the SDO_DAS_Setting will also contain the old value.

Seznam parametrů

None.

Návratové hodnoty

Returns TRUE if the property was set prior to being modified, otherwise returns FALSE.

Předcházející | Nahoru | Další
SDO_DAS_Setting::getValue | Domů | SDO_DataFactory::create


SDO_DAS_XML::addTypes

(No version information available, might be only in CVS)

SDO_DAS_XML::addTypes — To load a second or subsequent schema file to a SDO_DAS_XML object

Popis

void SDO_DAS_XML::addTypes ( string $xsd_file )

Load a second or subsequent schema file to an XML DAS that has already been created with the static method create(). Although the file may be any valid schema file, a likely reason for using this method is to add a schema file containing definitions of extra complex types, hence the name. See Example 4 of the parent document for an example.

Seznam parametrů

xsd_file

Path to XSD Schema file.

Návratové hodnoty

None if successful, otherwise throws an exception as described below.

Errors/Exceptions

SDO_TypeNotFoundException

Thrown if a type is not defined in the underlying model.

SDO_DAS_XML_ParserException

Thrown for any problems while parsing the given XSD File.

SDO_DAS_XML_FileException

Thrown if the specified file cannot be found.

Předcházející | Nahoru | Další
SDO_DAS_XML_Document::setXMLVersion | Domů | SDO_DAS_XML::create


SDO_DAS_XML::create

(No version information available, might be only in CVS)

SDO_DAS_XML::create — To create SDO_DAS_XML object for a given schema file

Popis

SDO_DAS_XML SDO_DAS_XML::create ( [mixed $xsd_file [, string $key]] )

This is the only static method of SDO_DAS_XML class. Used to instantiate SDO_DAS_XML object.

Seznam parametrů

xsd_file

Path to XSD Schema file. This is optional. If omitted a DAS will be created that only has the SDO base types defined. Schema files can then be loaded with the addTypes() method. Can be string or array of values.

key

Návratové hodnoty

Returns SDO_DAS_XML object on success otherwise throws an exception as described below.

Errors/Exceptions

SDO_TypeNotFoundException

Thrown if a type is not defined in the underlying model.

SDO_DAS_XML_ParserException

Thrown for any problems while parsing the given XSD File.

SDO_DAS_XML_FileException

Thrown if the specified file cannot be found.

Předcházející | Nahoru | Další
SDO_DAS_XML::addTypes | Domů | SDO_DAS_XML::createDataObject


SDO_DAS_XML::createDataObject

(No version information available, might be only in CVS)

SDO_DAS_XML::createDataObject — Creates SDO_DataObject for a given namespace URI and type name

Popis

SDO_DataObject SDO_DAS_XML::createDataObject ( string $namespace_uri, string $type_name )

Creates SDO_DataObject for a given namespace URI and type name. The type should be defined in the underlying model otherwise SDO_TypeNotFoundException will be thrown.

Seznam parametrů

namespace_uri

Namespace URI of the type name.

type_name

Type Name.

Návratové hodnoty

Returns SDO_DataObject on success.

Errors/Exceptions

SDO_TypeNotFoundException

Thrown if a type is not defined in the underlying model.

Předcházející | Nahoru | Další
SDO_DAS_XML::create | Domů | SDO_DAS_XML::createDocument


SDO_DAS_XML::createDocument

(No version information available, might be only in CVS)

SDO_DAS_XML::createDocument — Creates an XML Document object from scratch, without the need to load a document from a file or string.

Popis

SDO_DAS_XML_Document SDO_DAS_XML::createDocument ( [string $document_element_name] )
SDO_DAS_XML_Document SDO_DAS_XML::createDocument ( string $document_element_namespace_URI, string $document_element_name [, SDO_DataObject $dataobject] )

Creates an XML Document object. This will contain just one empty root element on which none of the properties will have been set. The purpose of this call is to allow an application to create an XML document from scratch without the need to load a document from a file or string. The document that is created will be as if a document had been loaded that contained just a single empty document element with no attributes set or elements within it.

createDocument() may need to be told what the document element is. This will not be necessary in simple cases. When there is no ambiguity then no parameter need be passed to the method. However it is possible to load more than one schema file into the same XML DAS and in this case there may be more than one possible document element defined: furthermore it is even possible that there are two possible document elements that differ only in the namespace. To cope with these cases it is possible to specify either the document element name, or both the document element name and namespace to the method.

Seznam parametrů

document_element_name

The name of the document element. Only needed if there is more than one possibility.

document_element_namespace_URI

The namespace part of the document element name. Only needed if there is more than one possible document element with the same name.

dataobject

Návratové hodnoty

Returns an SDO_XML_DAS_Document object on success.

Errors/Exceptions

SDO_UnsupportedOperationException

Thrown if an element name or element name and namespace URI is passed, but not found in the underlying model.

Předcházející | Nahoru | Další
SDO_DAS_XML::createDataObject | Domů | SDO_DAS_XML::loadFile


SDO_DAS_XML_Document::getRootDataObject

(No version information available, might be only in CVS)

SDO_DAS_XML_Document::getRootDataObject — Returns the root SDO_DataObject

Popis

SDO_DataObject SDO_DAS_XML_Document::getRootDataObject ( void )

Returns the root SDO_DataObject.

Seznam parametrů

Návratové hodnoty

Returns the root SDO_DataObject.

Předcházející | Nahoru | Další
CXLIV. SDO XML Data Access Service Functions | Domů | SDO_DAS_XML_Document::getRootElementName


SDO_DAS_XML_Document::getRootElementName

(No version information available, might be only in CVS)

SDO_DAS_XML_Document::getRootElementName — Returns root element's name

Popis

string SDO_DAS_XML_Document::getRootElementName ( void )

Returns root element's name.

Seznam parametrů

Návratové hodnoty

Returns root element's name.

Předcházející | Nahoru | Další
SDO_DAS_XML_Document::getRootDataObject | Domů | SDO_DAS_XML_Document::getRootElementURI


SDO_DAS_XML_Document::getRootElementURI

(No version information available, might be only in CVS)

SDO_DAS_XML_Document::getRootElementURI — Returns root element's URI string

Popis

string SDO_DAS_XML_Document::getRootElementURI ( void )

Returns root element's URI string.

Seznam parametrů

Návratové hodnoty

Returns root element's URI string.

Předcházející | Nahoru | Další
SDO_DAS_XML_Document::getRootElementName | Domů | SDO_DAS_XML_Document::setEncoding


SDO_DAS_XML_Document::setEncoding

(No version information available, might be only in CVS)

SDO_DAS_XML_Document::setEncoding — Sets the given string as encoding

Popis

void SDO_DAS_XML_Document::setEncoding ( string $encoding )

Sets the given string as encoding.

Seznam parametrů

encoding

Encoding string.

Návratové hodnoty

None.

Předcházející | Nahoru | Další
SDO_DAS_XML_Document::getRootElementURI | Domů | SDO_DAS_XML_Document::setXMLDeclaration


SDO_DAS_XML_Document::setXMLDeclaration

(No version information available, might be only in CVS)

SDO_DAS_XML_Document::setXMLDeclaration — Sets the xml declaration

Popis

void SDO_DAS_XML_Document::setXMLDeclaration ( bool $xmlDeclatation )

Controls whether an XML declaration will be generated at the start of the XML document. Set to true to generate the XML declaration, or false to suppress it.

Seznam parametrů

xmlDeclatation

Boolean value to set the XML declaration.

Návratové hodnoty

None.

Předcházející | Nahoru | Další
SDO_DAS_XML_Document::setEncoding | Domů | SDO_DAS_XML_Document::setXMLVersion


SDO_DAS_XML_Document::setXMLVersion

(No version information available, might be only in CVS)

SDO_DAS_XML_Document::setXMLVersion — Sets the given string as xml version

Popis

void SDO_DAS_XML_Document::setXMLVersion ( string $xmlVersion )

Sets the given string as xml version.

Seznam parametrů

xmlVersion

xml version string.

Návratové hodnoty

None.

Předcházející | Nahoru | Další
SDO_DAS_XML_Document::setXMLDeclaration | Domů | SDO_DAS_XML::addTypes


SDO_DAS_XML::loadFile

(No version information available, might be only in CVS)

SDO_DAS_XML::loadFile — Returns SDO_DAS_XML_Document object for a given path to xml instance document

Popis

SDO_XMLDocument SDO_DAS_XML::loadFile ( string $xml_file )

Constructs the tree of SDO_DataObjects from the given address to xml instance document. Returns SDO_DAS_XML_Document Object. Use SDO_DAS_XML_Document::getRootDataObject method to get root data object.

Seznam parametrů

xml_file

Path to Instance document. This can be a path to a local file or it can be a URL.

Návratové hodnoty

Returns SDO_DAS_XML_Document object on Success or throws exception as described.

Errors/Exceptions

SDO_TypeNotFoundException

Thrown if a type is not defined by the underlying model.

SDO_PropertyNotFoundException

Thrown if a property within a type is not defined in the underlying model.

SDO_DAS_XML_ParserException

Thrown for any problems while parsing the given XSD File.

SDO_DAS_XML_FileException

Thrown if the specified file cannot be found.

Předcházející | Nahoru | Další
SDO_DAS_XML::createDocument | Domů | SDO_DAS_XML::loadString


SDO_DAS_XML::loadString

(No version information available, might be only in CVS)

SDO_DAS_XML::loadString — Returns SDO_DAS_XML_Document for a given xml instance string

Popis

SDO_DAS_XML_Document SDO_DAS_XML::loadString ( string $xml_string )

Constructs the tree of SDO_DataObjects from the given xml instance string. Returns SDO_DAS_XML_Document Object. Use SDO_DAS_XML_Document::getRootDataObject method to get root data object.

Seznam parametrů

xml_string

xml string.

Návratové hodnoty

Returns SDO_DAS_XML_Document object on Success or throws exception as described.

Errors/Exceptions

SDO_TypeNotFoundException

Thrown if a type is not defined by the underlying model.

SDO_PropertyNotFoundException

Thrown if the a property within a type is not defined in the underlying model.

SDO_DAS_XML_ParserException

Thrown for any problems while parsing the given XSD File.

Předcházející | Nahoru | Další
SDO_DAS_XML::loadFile | Domů | SDO_DAS_XML::saveFile


SDO_DAS_XML::saveFile

(No version information available, might be only in CVS)

SDO_DAS_XML::saveFile — Saves the SDO_DAS_XML_Document object to a file

Popis

void SDO_DAS_XML::saveFile ( SDO_XMLDocument $xdoc, string $xml_file [, int $indent] )

Saves the SDO_DAS_XML_Document object to a file.

Seznam parametrů

xdoc

SDO_DAS_XML_Document object.

xml_file

xml file.

indent

Optional argument to specify that the xml should be formatted. A non-negative integer is the amount to indent each level of the xml. So, the integer 2, for example, will indent the xml so that each contained element is two spaces further to the right than its containing element. The integer 0 will cause the xml to be completely left-aligned. The integer -1 means no formatting - the xml will come out on one long line.

Návratové hodnoty

None.

Errors/Exceptions

SDO_DAS_XML_FileException

Thrown if the specified file cannot be found.

Předcházející | Nahoru | Další
SDO_DAS_XML::loadString | Domů | SDO_DAS_XML::saveString


SDO_DAS_XML::saveString

(No version information available, might be only in CVS)

SDO_DAS_XML::saveString — Saves the SDO_DAS_XML_Document object to a string

Popis

string SDO_DAS_XML::saveString ( SDO_XMLDocument $xdoc [, int $indent] )

Saves the SDO_DAS_XML_Document object to string.

Seznam parametrů

xdoc

SDO_DAS_XML_Document object.

indent

Optional argument to specify that the xml should be formatted. A non-negative integer is the amount to indent each level of the xml. So, the integer 2, for example, will indent the xml so that each contained element is two spaces further to the right than its containing element. The integer 0 will cause the xml to be completely left-aligned. The integer -1 means no formatting - the xml will come out on one long line.

Návratové hodnoty

xml string.

Předcházející | Nahoru | Další
SDO_DAS_XML::saveFile | Domů | CXLV. SDO Relational Data Access Service Functions


SDO_DataFactory::create

(No version information available, might be only in CVS)

SDO_DataFactory::create — Create an SDO_DataObject

Popis

void SDO_DataFactory::create ( string $type_namespace_uri, string $type_name )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Create a new SDO_DataObject given the data object's namespace URI and type name.

Seznam parametrů

type_namespace_uri

The namespace of the type.

type_name

The name of the type.

Návratové hodnoty

Returns the newly created SDO_DataObject.

Errors/Exceptions

SDO_TypeNotFoundException

Thrown if the namespaceURI and typeName do not correspond to a type known to this data factory.

Předcházející | Nahoru | Další
SDO_DAS_Setting::isSet | Domů | SDO_DataObject::clear


SDO_DataObject::clear

(No version information available, might be only in CVS)

SDO_DataObject::clear — Clear an SDO_DataObject's properties

Popis

void SDO_DataObject::clear ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Clear an SDO_DataObject's properties. Read-only properties are unaffected. Subsequent calls to isset() for the data object will return FALSE.

Seznam parametrů

None.

Návratové hodnoty

No return values.

Předcházející | Nahoru | Další
SDO_DataFactory::create | Domů | SDO_DataObject::createDataObject


SDO_DataObject::createDataObject

(No version information available, might be only in CVS)

SDO_DataObject::createDataObject — Create a child SDO_DataObject

Popis

SDO_DataObject SDO_DataObject::createDataObject ( mixed $identifier )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Create a child SDO_DataObject of the default type for the property identified. The data object is automatically inserted into the tree and a reference to it is returned.

Seznam parametrů

identifier

Identifies the property for the data object type to be created. Can be either a property name (string), a property index (int), or an SDO_Model_Property.

Návratové hodnoty

Returns the newly created SDO_DataObject.

Errors/Exceptions

SDO_PropertyNotFoundException

Thrown if the identifier does not correspond to a property of the data object.

Předcházející | Nahoru | Další
SDO_DataObject::clear | Domů | SDO_DataObject::getContainer


SDO_DataObject::getContainer

(No version information available, might be only in CVS)

SDO_DataObject::getContainer — Get a data object's container

Popis

SDO_DataObject SDO_DataObject::getContainer ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Get the data object which contains this data object.

Seznam parametrů

None.

Návratové hodnoty

Returns the SDO_DataObject which contains this SDO_DataObject, or returns NULL if this is a root SDO_DataObject (i.e. it has no container).

Předcházející | Nahoru | Další
SDO_DataObject::createDataObject | Domů | SDO_DataObject::getSequence


SDO_DataObject::getSequence

(No version information available, might be only in CVS)

SDO_DataObject::getSequence — Get the sequence for a data object

Popis

SDO_Sequence SDO_DataObject::getSequence ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Return the SDO_Sequence for this SDO_DataObject. Accessing the SDO_DataObject through the SDO_Sequence interface acts on the same SDO_DataObject instance data, but preserves ordering across properties.

Seznam parametrů

None.

Návratové hodnoty

The SDO_Sequence for this SDO_DataObject, or returns NULL if the SDO_DataObject is not of a type which can have a sequence.

Předcházející | Nahoru | Další
SDO_DataObject::getContainer | Domů | SDO_DataObject::getTypeName


SDO_DataObject::getTypeName

(No version information available, might be only in CVS)

SDO_DataObject::getTypeName — Return the name of the type for a data object.

Popis

string SDO_DataObject::getTypeName ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Return the name of the type for a data object. A convenience method corresponding to SDO_Model_ReflectionDataObject::getType().getName().

Seznam parametrů

None.

Návratové hodnoty

The name of the type for the data object.

Předcházející | Nahoru | Další
SDO_DataObject::getSequence | Domů | SDO_DataObject::getTypeNamespaceURI


SDO_DataObject::getTypeNamespaceURI

(No version information available, might be only in CVS)

SDO_DataObject::getTypeNamespaceURI — Return the namespace URI of the type for a data object.

Popis

string SDO_DataObject::getTypeNamespaceURI ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Return the namespace URI of the type for a data object. A convenience method corresponding to SDO_Model_ReflectionDataObject::getType().getNamespaceURI().

Seznam parametrů

None.

Návratové hodnoty

The namespace URI of the type for the data object.

Předcházející | Nahoru | Další
SDO_DataObject::getTypeName | Domů | SDO_Exception::getCause


SDO_Exception::getCause

(No version information available, might be only in CVS)

SDO_Exception::getCause — Get the cause of the exception.

Popis

mixed SDO_Exception::getCause ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the cause of this exception or NULL if the cause is nonexistent or unknown. Typically the cause will be an SDO_CPPException object, which may be used to obtain additional diagnostic information.

Seznam parametrů

None.

Návratové hodnoty

Returns the cause of this exception or NULL if the cause is nonexistent or unknown.

Předcházející | Nahoru | Další
SDO_DataObject::getTypeNamespaceURI | Domů | SDO_List::insert


SDO_List::insert

(No version information available, might be only in CVS)

SDO_List::insert — Insert into a list

Popis

void SDO_List::insert ( mixed $value [, int $index] )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Insert a new element at a specified position in the list. All subsequent list items are moved up.

Seznam parametrů

value

The new value to be inserted. This can be either a primitive or an SDO_DataObject.

index

The position at which to insert the new element. If this argument is not specified then the new value will be appended.

Návratové hodnoty

None.

Errors/Exceptions

SDO_IndexOutOfBoundsException

Thrown if the list index is less than zero or greater than the size of the list.

SDO_InvalidConversionException

Thrown if the type of the new value does not match the type for the list (e.g. the type of the many-valued property that the list represents).

Předcházející | Nahoru | Další
SDO_Exception::getCause | Domů | SDO_Model_Property::getContainingType


SDO_Model_Property::getContainingType

(No version information available, might be only in CVS)

SDO_Model_Property::getContainingType — Get the SDO_Model_Type which contains this property

Popis

SDO_Model_Type SDO_Model_Property::getContainingType ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the SDO_Model_Type which contains this property.

Seznam parametrů

None.

Návratové hodnoty

Returns the SDO_Model_Type which contains this property.

Předcházející | Nahoru | Další
SDO_List::insert | Domů | SDO_Model_Property::getDefault


SDO_Model_Property::getDefault

(No version information available, might be only in CVS)

SDO_Model_Property::getDefault — Get the default value for the property

Popis

mixed SDO_Model_Property::getDefault ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the default value for the property. Only primitive data type properties can have default values.

Seznam parametrů

None.

Návratové hodnoty

Returns the default value for the property.

Předcházející | Nahoru | Další
SDO_Model_Property::getContainingType | Domů | SDO_Model_Property::getName


SDO_Model_Property::getName

(No version information available, might be only in CVS)

SDO_Model_Property::getName — Get the name of the SDO_Model_Property

Popis

string SDO_Model_Property::getName ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the name of the SDO_Model_Property.

Seznam parametrů

None.

Návratové hodnoty

Returns the name of the SDO_Model_Property.

Předcházející | Nahoru | Další
SDO_Model_Property::getDefault | Domů | SDO_Model_Property::getType


SDO_Model_Property::getType

(No version information available, might be only in CVS)

SDO_Model_Property::getType — Get the SDO_Model_Type of the property

Popis

SDO_Model_Type SDO_Model_Property::getType ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Get the SDO_Model_Type of the property. The SDO_Model_Type describes the type information for the property, such as its type name, namespace URI, whether it is a primitive data type, and so on.

Seznam parametrů

None.

Návratové hodnoty

Returns the SDO_Model_Type describing the property's type information.

Předcházející | Nahoru | Další
SDO_Model_Property::getName | Domů | SDO_Model_Property::isContainment


SDO_Model_Property::isContainment

(No version information available, might be only in CVS)

SDO_Model_Property::isContainment — Test to see if the property defines a containment relationship

Popis

bool SDO_Model_Property::isContainment ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Test to see if the property corresponds to a containment relationship. Returns TRUE if the property defines a containment relationship, or FALSE if it is reference.

Seznam parametrů

None.

Návratové hodnoty

Returns TRUE if the property defines a containment relationship, or FALSE if it is reference.

Předcházející | Nahoru | Další
SDO_Model_Property::getType | Domů | SDO_Model_Property::isMany


SDO_Model_Property::isMany

(No version information available, might be only in CVS)

SDO_Model_Property::isMany — Test to see if the property is many-valued

Popis

bool SDO_Model_Property::isMany ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Test to see if the property is many-valued. Returns TRUE if this is a many-valued property, otherwise returns FALSE.

Seznam parametrů

None.

Návratové hodnoty

Returns TRUE if this is a many-valued property, otherwise returns FALSE.

Předcházející | Nahoru | Další
SDO_Model_Property::isContainment | Domů | SDO_Model_ReflectionDataObject::__construct


SDO_Model_ReflectionDataObject::__construct

(No version information available, might be only in CVS)

SDO_Model_ReflectionDataObject::__construct — Construct an SDO_Model_ReflectionDataObject

Popis

SDO_Model_ReflectionDataObject SDO_Model_ReflectionDataObject::__construct ( SDO_DataObject $data_object )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Construct an SDO_Model_ReflectionDataObject to reflect on an SDO_DataObject. Reflecting on an SDO_DataObject gives access to information about its model. The model contains information such as the data object's type, and whether that type is sequenced (preserves ordering across properties) or open (each instance can have its model extended). The model also holds information about the data object's properties, any default values they may have, and so on.

Seznam parametrů

data_object

The SDO_DataObject being reflected upon.

Návratové hodnoty

None.

Předcházející | Nahoru | Další
SDO_Model_Property::isMany | Domů | SDO_Model_ReflectionDataObject::export


SDO_Model_ReflectionDataObject::export

(No version information available, might be only in CVS)

SDO_Model_ReflectionDataObject::export — Get a string describing the SDO_DataObject.

Popis

mixed SDO_Model_ReflectionDataObject::export ( SDO_Model_ReflectionDataObject $rdo [, bool $return] )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Get a string describing the SDO_DataObject. The default behaviour is to print the output, but if TRUE is specified for return, it is returned as a string.

Seznam parametrů

rdo

An SDO_Model_ReflectionDataObject.

return

If TRUE, return the output as a string, otherwise print it.

Návratové hodnoty

Returns the output if TRUE is specified for return, otherwise NULL.

Předcházející | Nahoru | Další
SDO_Model_ReflectionDataObject::__construct | Domů | SDO_Model_ReflectionDataObject::getContainmentProperty


SDO_Model_ReflectionDataObject::getContainmentProperty

(No version information available, might be only in CVS)

SDO_Model_ReflectionDataObject::getContainmentProperty — Get the property which defines the containment relationship to the data object

Popis

SDO_Model_Property SDO_Model_ReflectionDataObject::getContainmentProperty ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Get the SDO_Model_Property that contains the SDO_DataObject. This method is used to navigate up to the parent's property which contains the data object which has been reflected upon.

Seznam parametrů

None.

Návratové hodnoty

Returns the container's SDO_Model_Property which references the SDO_DataObject, or NULL if it is a root SDO_DataObject.

Předcházející | Nahoru | Další
SDO_Model_ReflectionDataObject::export | Domů | SDO_Model_ReflectionDataObject::getInstanceProperties


SDO_Model_ReflectionDataObject::getInstanceProperties

(No version information available, might be only in CVS)

SDO_Model_ReflectionDataObject::getInstanceProperties — Get the instance properties of the SDO_DataObject

Popis

array SDO_Model_ReflectionDataObject::getInstanceProperties ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Get the instance properties for the SDO_DataObject. The instance properties consist of all the properties defined on the data object's type, plus any instance properties from open content (if the data object is an open type).

Seznam parametrů

None.

Návratové hodnoty

An array of SDO_Model_Property objects.

Předcházející | Nahoru | Další
SDO_Model_ReflectionDataObject::getContainmentProperty | Domů | SDO_Model_ReflectionDataObject::getType


SDO_Model_ReflectionDataObject::getType

(No version information available, might be only in CVS)

SDO_Model_ReflectionDataObject::getType — Get the SDO_Model_Type for the SDO_DataObject

Popis

SDO_Model_Type SDO_Model_ReflectionDataObject::getType ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the SDO_Model_Type for the SDO_DataObject. The SDO_Model_Type holds all the information about the data object's type, such as namespace URI, type name, whether it is a primitive data type, and so on.

Seznam parametrů

None.

Návratové hodnoty

Returns the SDO_Model_Type for the SDO_DataObject.

Předcházející | Nahoru | Další
SDO_Model_ReflectionDataObject::getInstanceProperties | Domů | SDO_Model_Type::getBaseType


SDO_Model_Type::getBaseType

(No version information available, might be only in CVS)

SDO_Model_Type::getBaseType — Get the base type for this type

Popis

SDO_Model_Type SDO_Model_Type::getBaseType ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Get the base type for this type. Returns the SDO_Model_Type for the base type if this type inherits from another, otherwise returns NULL. An example of when base types occur is when a type defined in XML schema inherits from another type by using <extension base="..."> .

Seznam parametrů

None.

Návratové hodnoty

Returns the SDO_Model_Type for the base type if this type inherits from another, otherwise returns NULL.

Předcházející | Nahoru | Další
SDO_Model_ReflectionDataObject::getType | Domů | SDO_Model_Type::getName


SDO_Model_Type::getName

(No version information available, might be only in CVS)

SDO_Model_Type::getName — Get the name of the type

Popis

string SDO_Model_Type::getName ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the name of the type. The combination of type name and namespace URI is used to uniquely identify the type.

Seznam parametrů

None.

Návratové hodnoty

Returns the name of the type.

Předcházející | Nahoru | Další
SDO_Model_Type::getBaseType | Domů | SDO_Model_Type::getNamespaceURI


SDO_Model_Type::getNamespaceURI

(No version information available, might be only in CVS)

SDO_Model_Type::getNamespaceURI — Get the namespace URI of the type

Popis

string SDO_Model_Type::getNamespaceURI ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Returns the namespace URI of the type. The combination of namespace URI and type name is used to uniquely identify the type.

Seznam parametrů

None.

Návratové hodnoty

Returns the namespace URI of the type.

Předcházející | Nahoru | Další
SDO_Model_Type::getName | Domů | SDO_Model_Type::getProperties


SDO_Model_Type::getProperties

(No version information available, might be only in CVS)

SDO_Model_Type::getProperties — Get the SDO_Model_Property objects defined for the type

Popis

array SDO_Model_Type::getProperties ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Get an array of SDO_Model_Property objects describing the properties defined for the SDO_Model_Type. Each SDO_Model_Property holds information such as the property name, default value, and so on.

Seznam parametrů

None.

Návratové hodnoty

Returns an array of SDO_Model_Property objects.

Předcházející | Nahoru | Další
SDO_Model_Type::getNamespaceURI | Domů | SDO_Model_Type::getProperty


SDO_Model_Type::getProperty

(No version information available, might be only in CVS)

SDO_Model_Type::getProperty — Get an SDO_Model_Property of the type

Popis

SDO_Model_Property SDO_Model_Type::getProperty ( mixed $identifier )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Get an SDO_Model_Property of the type, identified by its property index or property name.

Seznam parametrů

identifier

The property index or property name.

Návratové hodnoty

Returns the SDO_Model_Property.

Předcházející | Nahoru | Další
SDO_Model_Type::getProperties | Domů | SDO_Model_Type::isAbstractType


SDO_Model_Type::isAbstractType

(No version information available, might be only in CVS)

SDO_Model_Type::isAbstractType — Test to see if this SDO_Model_Type is an abstract data type

Popis

bool SDO_Model_Type::isAbstractType ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Test to see if this SDO_Model_Type is an abstract data type. Returns TRUE if this type is abstract, that is, no SDO_DataObject of this type can be instantiated, though other types may inherit from it.

Seznam parametrů

None.

Návratové hodnoty

Returns TRUE if this type is an abstract data type, otherwise returns FALSE.

Předcházející | Nahoru | Další
SDO_Model_Type::getProperty | Domů | SDO_Model_Type::isDataType


SDO_Model_Type::isDataType

(No version information available, might be only in CVS)

SDO_Model_Type::isDataType — Test to see if this SDO_Model_Type is a primitive data type

Popis

bool SDO_Model_Type::isDataType ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Test to see if this SDO_Model_Type is a primitive data type. Returns TRUE if this type is a primitive data type, otherwise returns FALSE.

Seznam parametrů

None.

Návratové hodnoty

Returns TRUE if this type is a primitive data type, otherwise returns FALSE.

Předcházející | Nahoru | Další
SDO_Model_Type::isAbstractType | Domů | SDO_Model_Type::isInstance


SDO_Model_Type::isInstance

(No version information available, might be only in CVS)

SDO_Model_Type::isInstance — Test for an SDO_DataObject being an instance of this SDO_Model_Type

Popis

bool SDO_Model_Type::isInstance ( SDO_DataObject $data_object )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Test for an SDO_DataObject being an instance of this SDO_Model_Type. Returns TRUE if the SDO_DataObject provided is an instance of this SDO_Model_Type, or a derived type, otherwise returns FALSE.

Seznam parametrů

data_object

The SDO_DataObject to be tested.

Návratové hodnoty

Returns TRUE if the SDO_DataObject provided is an instance of this SDO_Model_Type, or a derived type, otherwise returns FALSE.

Předcházející | Nahoru | Další
SDO_Model_Type::isDataType | Domů | SDO_Model_Type::isOpenType


SDO_Model_Type::isOpenType

(No version information available, might be only in CVS)

SDO_Model_Type::isOpenType — Test to see if this type is an open type

Popis

bool SDO_Model_Type::isOpenType ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Test to see if this type is open. Returns TRUE if this type is open, otherwise returns FALSE. An SDO_DataObject whose type is open can have properties added to them which are not described by the type. This capability is used to support working with XML documents whose schema support open content, such as that defined by an <xsd:any> element.

Seznam parametrů

None.

Návratové hodnoty

Returns TRUE if this type is open, otherwise returns FALSE.

Předcházející | Nahoru | Další
SDO_Model_Type::isInstance | Domů | SDO_Model_Type::isSequencedType


SDO_Model_Type::isSequencedType

(No version information available, might be only in CVS)

SDO_Model_Type::isSequencedType — Test to see if this is a sequenced type

Popis

bool SDO_Model_Type::isSequencedType ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Test to see if this is a sequenced type. Returns TRUE if this type is sequence, otherwise returns FALSE. Sequenced types can have the ordering across properties preserved and can contain unstructured text. For more information on sequenced types see the section on Working with Sequenced Data Objects.

Seznam parametrů

None.

Návratové hodnoty

Returns TRUE if this type is sequence, otherwise return FALSE.

Předcházející | Nahoru | Další
SDO_Model_Type::isOpenType | Domů | SDO_Sequence::getProperty


SDO_Sequence::getProperty

(No version information available, might be only in CVS)

SDO_Sequence::getProperty — Return the property for the specified sequence index.

Popis

SDO_Model_Property SDO_Sequence::getProperty ( int $sequence_index )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Return the property for the specified sequence index.

Seznam parametrů

sequence_index

The position of the element in the sequence.

Návratové hodnoty

An SDO_Model_Property. A return value of NULL means the sequence element does not belong to a property and must therefore be unstructured text.

Errors/Exceptions

SDO_IndexOutOfBoundsException

Thrown if the sequence index is less than zero or greater than the size of the sequence.

Předcházející | Nahoru | Další
SDO_Model_Type::isSequencedType | Domů | SDO_Sequence::insert


SDO_Sequence::insert

(No version information available, might be only in CVS)

SDO_Sequence::insert — Insert into a sequence

Popis

void SDO_Sequence::insert ( mixed $value [, int $sequenceIndex [, mixed $propertyIdentifier]] )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Insert a new element at a specified position in the sequence. All subsequent sequence items are moved up.

Seznam parametrů

value

The new value to be inserted. This can be either a primitive or an SDO_DataObject.

sequenceIndex

The position at which to insert the new element. Default is NULL, which results in the new value being appended to the sequence.

propertyIdentifier

Either a property index, a property name, or an SDO_Model_Property, used to identify a property in the sequence's corresponding SDO_DataObject. A value of NULL signifies unstructured text.

Návratové hodnoty

None.

Errors/Exceptions

SDO_IndexOutOfBoundsException

Thrown if the sequence index is less than zero or greater than the size of the sequence.

SDO_InvalidConversionException

Thrown if the type of the new value cannot be juggled to match the type for the specified data object property.

Předcházející | Nahoru | Další
SDO_Sequence::getProperty | Domů | SDO_Sequence::move


SDO_Sequence::move

(No version information available, might be only in CVS)

SDO_Sequence::move — Move an item to another sequence position

Popis

void SDO_Sequence::move ( int $toIndex, int $fromIndex )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Modify the position of the item in the sequence, without altering the value of the property in the SDO_DataObject.

Seznam parametrů

toIndex

The destination sequence index. If this index is less than zero or greater than the size of the sequence then the value is appended.

fromIndex

The source sequence index.

Návratové hodnoty

None.

Errors/Exceptions

SDO_IndexOutOfBoundsException

Thrown if the fromIndex sequence index is less than zero or greater than the size of the sequence.

Předcházející | Nahoru | Další
SDO_Sequence::insert | Domů | CXLIV. SDO XML Data Access Service Functions


session_pgsql_add_error

(No version information available, might be only in CVS)

session_pgsql_add_error — Increments error counts and sets last error message

Popis

bool session_pgsql_add_error ( int $error_level [, string $error_message] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

error_level

error_message

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

session_pgsql_get_error()

Předcházející | Nahoru | Další
CXLVIII. PostgreSQL Session Save Handler | Domů | session_pgsql_get_error


session_pgsql_get_error

(No version information available, might be only in CVS)

session_pgsql_get_error — Returns number of errors and last error message

Popis

array session_pgsql_get_error ( [bool $with_error_message] )

Get the number of errors and optional the error messages.

Seznam parametrů

with_error_message

Set to TRUE the literal error message for each error is also returned.

Návratové hodnoty

The number of errors are returned as array.

Viz také

session_pgsql_add_error()

Předcházející | Nahoru | Další
session_pgsql_add_error | Domů | session_pgsql_get_field


session_pgsql_get_field

(No version information available, might be only in CVS)

session_pgsql_get_field — Get custom field value

Popis

string session_pgsql_get_field ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Viz také

session_pgsql_set_field()

Předcházející | Nahoru | Další
session_pgsql_get_error | Domů | session_pgsql_reset


session_pgsql_reset

(No version information available, might be only in CVS)

session_pgsql_reset — Reset connection to session database servers

Popis

bool session_pgsql_reset ( void )

Reset the connection to the session database servers.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
session_pgsql_get_field | Domů | session_pgsql_set_field


session_pgsql_set_field

(No version information available, might be only in CVS)

session_pgsql_set_field — Set custom field value

Popis

bool session_pgsql_set_field ( string $value )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

value

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

session_pgsql_get_field()

Předcházející | Nahoru | Další
session_pgsql_reset | Domů | session_pgsql_status


session_pgsql_status

(No version information available, might be only in CVS)

session_pgsql_status — Get current save handler status

Popis

array session_pgsql_status ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
session_pgsql_set_field | Domů | CXLIX. Session Handling Functions


SimpleXMLElement->addAttribute()

(PHP 5 >= 5.1.3)

SimpleXMLElement->addAttribute() — Adds an attribute to the SimpleXML element

Popis

class SimpleXMLElement {
void addAttribute ( string $name, string $value [, string $namespace] )
}

Adds an attribute to the SimpleXML element.

Seznam parametrů

name

The name of the attribute to add.

value

The value of the attribute.

namespace

If specified, the namespace to which the attribute belongs.

Návratové hodnoty

Nevrací se žádná hodnota.

Příklady

Příklad 2034. Add attributes and children to a SimpleXML element

<?php

include 'example.php';

$sxe = new SimpleXMLElement($xmlstr);
$sxe->addAttribute('type', 'documentary');

$movie = $sxe->addChild('movie');
$movie->addChild('title', 'PHP2: More Parser Stories');
$movie->addChild('plot', 'This is all about the people who make it work.');

$characters = $movie->addChild('characters');
$character  = $characters->addChild('character');
$character->addChild('name', 'Mr. Parser');
$character->addChild('actor', 'John Doe');

$rating = $movie->addChild('rating', '5');
$rating->addAttribute('type', 'stars');

echo $sxe->asXML();

?>

Viz také

SimpleXMLElement->addChild()

Předcházející | Nahoru | Další
CLI. SimpleXML functions | Domů | SimpleXMLElement->addChild()


SimpleXMLElement->addChild()

(PHP 5 >= 5.1.3)

SimpleXMLElement->addChild() — Adds a child element to the XML node

Popis

class SimpleXMLElement {
SimpleXMLElement addChild ( string $name [, string $value [, string $namespace]] )
}

Adds a child element to the node and returns a SimpleXMLElement of the child.

Seznam parametrů

name

The name of the child element to add.

value

If specified, the value of the child element.

namespace

If specified, the namespace to which the child element belongs.

Návratové hodnoty

The addChild method returns a SimpleXMLElement object representing the child added to the XML node.

Příklady

Příklad 2035. Add attributes and children to a SimpleXML element

<?php

include 'example.php';

$sxe = new SimpleXMLElement($xmlstr);
$sxe->addAttribute('type', 'documentary');

$movie = $sxe->addChild('movie');
$movie->addChild('title', 'PHP2: More Parser Stories');
$movie->addChild('plot', 'This is all about the people who make it work.');

$characters = $movie->addChild('characters');
$character  = $characters->addChild('character');
$character->addChild('name', 'Mr. Parser');
$character->addChild('actor', 'John Doe');

$rating = $movie->addChild('rating', '5');
$rating->addAttribute('type', 'stars');

echo $sxe->asXML();

?>

Viz také

SimpleXMLElement->addAttribute()

Předcházející | Nahoru | Další
SimpleXMLElement->addAttribute() | Domů | SimpleXMLElement->asXML()


SimpleXMLElement->__construct()

(No version information available, might be only in CVS)

SimpleXMLElement->__construct() — Creates a new SimpleXMLElement object

Popis

class SimpleXMLElement {
__construct ( string $data [, int $options [, bool $data_is_url [, string $ns [, bool $is_prefix]]]] )
}

Creates a new SimpleXMLElement object.

Seznam parametrů

data

A well-formed XML string or the path or URL to an XML document if data_is_url is TRUE.

options

Optionally used to specify additional Libxml parameters.

data_is_url

By default, data_is_url is FALSE. Use TRUE to specify that data is a path or URL to an XML document instead of string data.

ns

is_prefix

Návratové hodnoty

Returns a SimpleXMLElement object representing data.

Errors/Exceptions

Produces an E_WARNING error message for each error found in the XML data and throws an exception if errors were detected.

Příklady

Příklad 2040. Create a SimpleXMLElement object

<?php

include 'example.php';

$sxe = new SimpleXMLElement($xmlstr);
echo $sxe->movie[0]->title;

?>

Příklad 2041. Create a SimpleXMLElement object from a URL

<?php

$sxe = new SimpleXMLElement('http://example.org/document.xml', NULL, TRUE);
echo $sxe->asXML();

?>

Viz také

simplexml_load_string
simplexml_load_file

Předcházející | Nahoru | Další
SimpleXMLElement->children() | Domů | SimpleXMLElement->getDocNamespaces()


SimpleXMLElement->getDocNamespaces()

(PHP 5 >= 5.1.2)

SimpleXMLElement->getDocNamespaces() — Returns namespaces declared in document

Popis

class SimpleXMLElement {
array getDocNamespaces ( [bool $recursive] )
}

Returns namespaces declared in document

Seznam parametrů

recursive

If specified, returns all namespaces declared in parent and child nodes. Otherwise, returns only namespaces declared in root node.

Návratové hodnoty

The getDocNamespaces method returns an array of namespace names with their associated URIs.

Příklady

Příklad 2042. Get document namespaces

<?php

$xml = <<<XML
<?xml version="1.0" standalone="yes"?>
<people xmlns:p="http://example.org/ns">
    <p:person id="1">John Doe</p:person>
    <p:person id="2">Susie Q. Public</p:person>
</people>
XML;

$sxe = new SimpleXMLElement($xml);

$namespaces = $sxe->getDocNamespaces();
var_dump($namespaces);

?>

Příklad 2043. Working with multiple namespaces

<?php

$xml = <<<XML
<?xml version="1.0" standalone="yes"?>
<people xmlns:p="http://example.org/ns" xmlns:t="http://example.org/test">
    <p:person t:id="1">John Doe</p:person>
    <p:person t:id="2" a:addr="123 Street" xmlns:a="http://example.org/addr">
        Susie Q. Public
    </p:person>
</people>
XML;

$sxe = new SimpleXMLElement($xml);

$namespaces = $sxe->getDocNamespaces(TRUE);
var_dump($namespaces);

?>

Viz také

SimpleXMLElement->getNamespaces()
SimpleXMLElement->registerXPathNamespace()

Předcházející | Nahoru | Další
SimpleXMLElement->__construct() | Domů | SimpleXMLElement->getName()


SimpleXMLElement->getName()

(PHP 5 >= 5.1.3)

SimpleXMLElement->getName() — Gets the name of the XML element

Popis

class SimpleXMLElement {
string getName ( void )
}

Gets the name of the XML element.

Návratové hodnoty

The getName method returns as a string the name of the XML tag referenced by the SimpleXMLElement object.

Příklady

Příklad 2044. Get XML element names

<?php

$sxe = new SimpleXMLElement($xmlstr);

echo $sxe->getName() . "\n";

foreach ($sxe->children() as $child)
{
    echo $child->getName() . "\n";
}

?>

Předcházející | Nahoru | Další
SimpleXMLElement->getDocNamespaces() | Domů | SimpleXMLElement->getNamespaces()


SimpleXMLElement->getNamespaces()

(PHP 5 >= 5.1.2)

SimpleXMLElement->getNamespaces() — Returns namespaces used in document

Popis

class SimpleXMLElement {
array getNamespaces ( [bool $recursive] )
}

Returns namespaces used in document

Seznam parametrů

recursive

If specified, returns all namespaces used in parent and child nodes. Otherwise, returns only namespaces used in root node.

Návratové hodnoty

The getNamespaces method returns an array of namespace names with their associated URIs.

Příklady

Příklad 2045. Get document namespaces in use

<?php

$xml = <<<XML
<?xml version="1.0" standalone="yes"?>
<people xmlns:p="http://example.org/ns" xmlns:t="http://example.org/test">
    <p:person id="1">John Doe</p:person>
    <p:person id="2">Susie Q. Public</p:person>
</people>
XML;

$sxe = new SimpleXMLElement($xml);

$namespaces = $sxe->getNamespaces(true);
var_dump($namespaces);

?>

Výše uvedený příklad vypíše:

array(1) {
  ["p"]=>
  string(21) "http://example.org/ns"
}

Viz také

SimpleXMLElement->getDocNamespaces()
SimpleXMLElement->registerXPathNamespace()

Předcházející | Nahoru | Další
SimpleXMLElement->getName() | Domů | SimpleXMLElement->registerXPathNamespace()


SimpleXMLElement->registerXPathNamespace()

(PHP 5 >= 5.2.0)

SimpleXMLElement->registerXPathNamespace() — Creates a prefix/ns context for the next XPath query

Popis

class SimpleXMLElement {
bool registerXPathNamespace ( string $prefix, string $ns )
}

Creates a prefix/ns context for the next XPath query. In particular, this is helpful if the provider of the given XML document alters the namespace prefixes. registerXPathNamespace will create a prefix for the associated namespace, allowing one to access nodes in that namespace without the need to change code to allow for the new prefixes dictated by the provider.

Seznam parametrů

prefix

The namespace prefix to use in the XPath query for the namespace given in ns.

ns

The namespace to use for the XPath query. This must match a namespace in use by the XML document or the XPath query using prefix will not return any results.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 2046. Setting a namespace prefix to use in an XPath query

<?php

$xml = <<<EOD
<book xmlns:chap="http://example.org/chapter-title">
    <title>My Book</title>
    <chapter id="1">
        <chap:title>Chapter 1</chap:title>
        <para>Donec velit. Nullam eget tellus vitae tortor gravida scelerisque.
            In orci lorem, cursus imperdiet, ultricies non, hendrerit et, orci.
            Nulla facilisi. Nullam velit nisl, laoreet id, condimentum ut,
            ultricies id, mauris.</para>
    </chapter>
    <chapter id="2">
        <chap:title>Chapter 2</chap:title>
        <para>Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Proin
            gravida. Phasellus tincidunt massa vel urna. Proin adipiscing quam
            vitae odio. Sed dictum. Ut tincidunt lorem ac lorem. Duis eros
            tellus, pharetra id, faucibus eu, dapibus dictum, odio.</para>
    </chapter>
</book>
EOD;

$sxe = new SimpleXMLElement($xml);

$sxe->registerXPathNamespace('c', 'http://example.org/chapter-title');
$result = $sxe->xpath('//c:title');

foreach ($result as $title) {
  echo $title . "\n";
}

?>

Notice how the XML document shown in the example sets a namespace with a prefix of chap. Imagine that this document (or another one like it) may have used a prefix of c in the past for the same namespace. Since it has changed, the XPath query will no longer return the proper results and the query will require modification. Using registerXPathNamespace avoids future modification of the query even if the provider changes the namespace prefix.

Viz také

SimpleXMLElement->getDocNamespaces()
SimpleXMLElement->getNamespaces()

Předcházející | Nahoru | Další
SimpleXMLElement->getNamespaces() | Domů | SimpleXMLElement->xpath()


snmp_set_oid_output_format

(PHP 5 >= 5.2.0)

snmp_set_oid_output_format — Set the OID output format

Popis

void snmp_set_oid_output_format ( int $oid_format )

snmp_set_oid_output_format() sets the output format to be full or numeric.

Seznam parametrů

oid_format

Set it to SNMP_OID_OUTPUT_FULL if you want a full output, SNMP_OID_OUTPUT_NUMERIC otherwise.

Návratové hodnoty

Nevrací se žádná hodnota.

Poznámky

Poznámka: snmp_set_oid_output_format() is only available when using the UCD SNMP library. This function is not available when using the Windows SNMP library.

Předcházející | Nahoru | Další
snmp_set_oid_numeric_print | Domů | snmp_set_quick_print


SoapClient->__call()

(PHP 5 >= 5.0.1)

SoapClient->__call() — Calls a SOAP function (deprecated)

Popis

class SoapClient {
mixed __call ( string $function_name, array $arguments [, array $options [, array $input_headers [, array $output_headers]]] )
}

This method is deprecated. Use SoapClient->__soapCall() instead of it.

Předcházející | Nahoru | Další
is_soap_fault | Domů | SoapClient->__construct()


SoapClient->__construct()

(No version information available, might be only in CVS)

SoapClient->__construct() — SoapClient constructor

Popis

class SoapClient {
__construct ( mixed $wsdl [, array $options] )
}

This constructor creates SoapClient objects in WSDL or non-WSDL mode.

Seznam parametrů

wsdl

URI of the WSDL file or NULL if working in non-WSDL mode.

Poznámka: During development stage, you may want to disable WSDL caching by the mean of the soap.wsdl_cache_ttl php.ini setting, otherwise changes made to the WSDL file will have no effect until soap.wsdl_cache_ttl is expired.

options

An array of options. If working in WSDL mode, this parameter is optional. If working in non-WSDL mode, you must set the location and uri options, where location is the URL to request and uri is the target namespace of the SOAP service.

The style and use options only work in non-WSDL mode. In WSDL mode, they come from the WSDL file.

The soap_version option specifies whether to use SOAP 1.1, or SOAP 1.2 client.

For HTTP authentication, you may use the login and password options. For making an HTTP connection through a proxy server, use the options proxy_host, proxy_port, proxy_login and proxy_password. For HTTPS client certificate authentication use local_cert and passphrase options.

The compression option allows to use compression of HTTP SOAP requests and responses.

The encoding option defines internal character encoding. This option does not change the encoding of SOAP requests (it is always utf-8), but converts strings into it.

The classmap option can be used to map some WSDL types to PHP classes. This option must be an array with WSDL types as keys and names of PHP classes as values.

Setting the boolean trace option enables use of the
methods
SoapClient->__getLastRequest,

SoapClient->__getLastRequestHeaders,

SoapClient->__getLastResponse and

SoapClient->__getLastResponseHeaders.

The exceptions option is a boolean value defining whether soap errors throw exceptions of type SoapFault.

The connection_timeout option defines a timeout in seconds for the connection to the SOAP service. This option does not define a timeout for services with slow responses. To limit the time to wait for calls to finish the default_socket_timeout setting is available.

The typemap option is an array of type mappings. Type mapping is an array with keys type_name, type_ns (namespace URI), from_xml (callback accepting one string parameter) and to_xml (callback accepting one object parameter).

Other options are stream_context, features, cache_wsdl and user_agent.

Příklady

Příklad 2058. SoapClient examples

<?php

$client = new SoapClient("some.wsdl");

$client = new SoapClient("some.wsdl", array('soap_version'   => SOAP_1_2));

$client = new SoapClient("some.wsdl", array('login'          => "some_name",
                                            'password'       => "some_password"));

$client = new SoapClient("some.wsdl", array('proxy_host'     => "localhost",
                                            'proxy_port'     => 8080));

$client = new SoapClient("some.wsdl", array('proxy_host'     => "localhost",
                                            'proxy_port'     => 8080,
                                            'proxy_login'    => "some_name",
                                            'proxy_password' => "some_password"));

$client = new SoapClient("some.wsdl", array('local_cert'     => "cert_key.pem"));

$client = new SoapClient(null, array('location' => "http://localhost/soap.php",
                                     'uri'      => "http://test-uri/"));

$client = new SoapClient(null, array('location' => "http://localhost/soap.php",
                                     'uri'      => "http://test-uri/",
                                     'style'    => SOAP_DOCUMENT,
                                     'use'      => SOAP_LITERAL));

$client = new SoapClient("some.wsdl",
  array('compression' => SOAP_COMPRESSION_ACCEPT | SOAP_COMPRESSION_GZIP));

$server = new SoapClient("some.wsdl", array('encoding'=>'ISO-8859-1'));

class MyBook {
    public $title;
    public $author;
}

$server = new SoapClient("books.wsdl", array('classmap' => array('book' => "MyBook")));

?>

Předcházející | Nahoru | Další
SoapClient->__call() | Domů | SoapClient->__doRequest()


SoapClient->__doRequest()

(PHP 5 >= 5.0.1)

SoapClient->__doRequest() — Performs a SOAP request

Popis

class SoapClient {
string __doRequest ( string $request, string $location, string $action, int $version [, int $one_way] )
}

Performs SOAP request over HTTP.

This method can be overridden in subclasses to implement different transport layers, perform additional XML processing or other purpose.

Seznam parametrů

request

The XML SOAP request.

location

The URL to request.

action

The SOAP action.

version

The SOAP version.

one_way

Návratové hodnoty

The XML SOAP response.

ChangeLog (záznam změn)

Verze | Popis
5.1.3 | The one_way parameter was added.

Příklady

Příklad 2059. Some examples

<?php
function Add($x,$y) {
  return $x+$y;
}

class LocalSoapClient extends SoapClient {

  function __construct($wsdl, $options) {
    parent::__construct($wsdl, $options);
    $this->server = new SoapServer($wsdl, $options);
    $this->server->addFunction('Add');
  }

  function __doRequest($request, $location, $action, $version) {
    ob_start();
    $this->server->handle($request);
    $response = ob_get_contents();
    ob_end_clean();
    return $response;
  }

}

$x = new LocalSoapClient(NULL,array('location'=>'test://',
                                   'uri'=>'http://testuri.org'));
var_dump($x->Add(3,4));
?>

Předcházející | Nahoru | Další
SoapClient->__construct() | Domů | SoapClient->__getFunctions()


SoapClient->__getFunctions()

(PHP 5 >= 5.0.1)

SoapClient->__getFunctions() — Returns list of SOAP functions

Popis

class SoapClient {
array __getFunctions ( void )
}

Returns the list of SOAP functions.

Poznámka: This function works only in WSDL mode.

Návratové hodnoty

The list of SOAP functions.

Příklady

Příklad 2060. SoapClient->__getFunctions() example

<?php
$client = new SoapClient('some.wsdl');
var_dump($client->__getFunctions());
?>

Viz také

SoapClient->__construct()

Předcházející | Nahoru | Další
SoapClient->__doRequest() | Domů | SoapClient->__getLastRequest()


SoapClient->__getLastRequest()

(PHP 5 >= 5.0.1)

SoapClient->__getLastRequest() — Returns last SOAP request

Popis

class SoapClient {
string __getLastRequest ( void )
}

Poznámka: This method works only if the SoapClient object was created with the trace option.

Návratové hodnoty

The last SOAP request.

Příklady

Příklad 2061. SoapClient->__getLastRequest() example

<?php
$client = SoapClient("some.wsdl", array('trace' => 1));
$result = $client->SomeFunction();
echo "REQUEST:\n" . $client->__getLastRequest() . "\n";
?>

Viz také

SoapClient->__construct()
SoapClient->__getLastRequestHeaders()
SoapClient->__getLastResponse()
SoapClient->__getLastResponseHeaders()

Předcházející | Nahoru | Další
SoapClient->__getFunctions() | Domů | SoapClient->__getLastRequestHeaders()


SoapClient->__getLastRequestHeaders()

(PHP 5 >= 5.0.1)

SoapClient->__getLastRequestHeaders() — Returns last SOAP request headers

Popis

class SoapClient {
string __getLastRequestHeaders ( void )
}

Poznámka: This method works only if the SoapClient object was created with the trace option.

Návratové hodnoty

The last SOAP request headers.

Viz také

SoapClient->__construct()
SoapClient->__getLastRequest()
SoapClient->__getLastResponse()
SoapClient->__getLastResponseHeaders()

Předcházející | Nahoru | Další
SoapClient->__getLastRequest() | Domů | SoapClient->__getLastResponse()


SoapClient->__getLastResponse()

(PHP 5 >= 5.0.1)

SoapClient->__getLastResponse() — Returns last SOAP response.

Popis

class SoapClient {
string __getLastResponse ( void )
}

Poznámka: This method works only if the SoapClient object was created with the trace option.

Návratové hodnoty

The last SOAP response.

Příklady

Příklad 2062. SoapClient->__getLastResponse() example

<?php
$client = SoapClient("some.wsdl", array('trace' => 1));
$result = $client->SomeFunction();
echo "RESPONSE:\n" . $client->__getLastResponse() . "\n";
?>

Viz také

SoapClient->__construct()
SoapClient->__getLastResponseHeaders()
SoapClient->__getLastRequest()
SoapClient->__getLastRequestHeaders()

Předcházející | Nahoru | Další
SoapClient->__getLastRequestHeaders() | Domů | SoapClient->__getLastResponseHeaders()


SoapClient->__getLastResponseHeaders()

(PHP 5 >= 5.0.1)

SoapClient->__getLastResponseHeaders() — Returns last SOAP response headers.

Popis

class SoapClient {
string __getLastResponseHeaders ( void )
}

Poznámka: This method works only if the SoapClient object was created with the trace option.

Návratové hodnoty

The last SOAP response headers.

Viz také

SoapClient->__construct()
SoapClient->__getLastResponse()
SoapClient->__getLastRequest()
SoapClient->__getLastRequestHeaders()

Předcházející | Nahoru | Další
SoapClient->__getLastResponse() | Domů | SoapClient->__getTypes()


SoapClient->__getTypes()

(PHP 5 >= 5.0.1)

SoapClient->__getTypes() — Returns list of SOAP types

Popis

class SoapClient {
array __getTypes ( void )
}

This function works only in WSDL mode.

Návratové hodnoty

The list of SOAP types.

Příklady

Příklad 2063. SoapClient->__getTypes() example

<?php
$client = new SoapClient("some.wsdl");
var_dump($client->__getTypes());
?>

Viz také

SoapClient->__construct()

Předcházející | Nahoru | Další
SoapClient->__getLastResponseHeaders() | Domů | SoapClient->__setCookie()


SoapClient->__setCookie()

(PHP 5 >= 5.0.4)

SoapClient->__setCookie() — Sets the cookie that will be sent with the SOAP request

Popis

class SoapClient {
void __setCookie ( string $name [, string $value] )
}

Defines a cookie to be sent along with the SOAP requests.

Poznámka: Calling this method will affect all following calls to SoapClient methods.

Seznam parametrů

name

The name of the cookie.

value

The value of the cookie. If not specified, the cookie will be deleted.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
SoapClient->__getTypes() | Domů | SoapClient->__soapCall()


SoapClient->__soapCall()

(No version information available, might be only in CVS)

SoapClient->__soapCall() — Calls a SOAP function

Popis

class SoapClient {
mixed __soapCall ( string $function_name, array $arguments [, array $options [, mixed $input_headers [, array &$output_headers]]] )
}

This is a low level API function that is used to make a SOAP call. Usually, in WSDL mode, you can simply call SOAP functions as SoapClient methods. This method useful in non-WSDL mode when soapaction is unknown, uri differs from the default or when sending and/or receiving SOAP Headers.

On error, a call to a SOAP function can cause PHP to throw exceptions or return a SoapFault object if exceptions are disabled. To check if the function call failed to catch the SoapFault exceptions, check the result with is_soap_fault().

Návratové hodnoty

SOAP functions may return one, or multiple values. If only one value is returned by the SOAP function, the return value of __soapCall will be a simple value (e.g. an integer, a string, etc). If multiple values are returned, __soapCall will return an associative array of named output parameters.

Příklady

Příklad 2064. SoapClient->__soapCall() Examples

<?php

$client = new SoapClient("some.wsdl");
$client->SomeFunction($a, $b, $c);

$client->__soapCall("SomeFunction", array($a, $b, $c));
$client->__soapCall("SomeFunction", array($a, $b, $c), NULL,
                    new SoapHeader(), $output_headers);

$client = new SoapClient(null, array('location' => "http://localhost/soap.php",
                                     'uri'      => "http://test-uri/"));
$client->SomeFunction($a, $b, $c);
$client->__soapCall("SomeFunction", array($a, $b, $c));
$client->__soapCall("SomeFunction", array($a, $b, $c),
                    array('soapaction' => 'some_action',
                          'uri'        => 'some_uri'));
?>

Viz také

SoapClient->__construct()
SoapParam->__construct()
SoapVar->__construct()
SoapHeader->__construct()
SoapFault->__construct()
is_soap_fault()

Předcházející | Nahoru | Další
SoapClient->__setCookie() | Domů | SoapFault->__construct()


SoapFault->__construct()

(No version information available, might be only in CVS)

SoapFault->__construct() — SoapFault constructor

Popis

class SoapFault {
__construct ( string $faultcode, string $faultstring [, string $faultactor [, mixed $detail [, string $faultname [, SoapHeader $headerfault]]]] )
}

This class is useful when you would like to send SOAP fault responses from the PHP handler. faultcode, faultstring, faultactor and details are standard elements of SOAP Fault;

Seznam parametrů

faultcode

The error code of the SoapFault.

faultstring

The error message of the SoapFault.

faultactor

A string identifying the actor that caused the error.

detail

faultname

Can be used to select the proper fault encoding from WSDL.

headerfault

Can be used during SOAP header handling to report an error in the response header.

Příklady

Příklad 2065. Some examples

<?php
function test($x)
{
    return new SoapFault("Server", "Some error message");
}

$server = new SoapServer(null, array('uri' => "http://test-uri/"));
$server->addFunction("test");
$server->handle();
?>

It is possible to use PHP exception mechanism to throw SOAP Fault.

Příklad 2066. Some examples

<?php
function test($x)
{
    throw new SoapFault("Server", "Some error message");
}

$server = new SoapServer(null, array('uri' => "http://test-uri/"));
$server->addFunction("test");
$server->handle();
?>

Viz také

SoapClient->__construct()
SoapClient->__soapCall()
SoapVar->__construct()
SoapParam->__construct()
SoapFault->__construct()
is_soap_fault()

Předcházející | Nahoru | Další
SoapClient->__soapCall() | Domů | SoapHeader->__construct()


SoapHeader->__construct()

(No version information available, might be only in CVS)

SoapHeader->__construct() — SoapHeader constructor

Popis

class SoapHeader {
__construct ( string $namespace, string $name [, mixed $data [, bool $mustUnderstand [, mixed $actor]]] )
}

Constructs a new SoapHeader object.

Seznam parametrů

namespace

The namespace of the SOAP header element.

name

The name of the SOAP header element.

data

A SOAP header's content. It can be a PHP value or a SoapVar object.

mustUnderstand

Value of the mustUnderstand attribute of the SOAP header element.

actor

Value of the actor attribute of the SOAP header element.

Příklady

Příklad 2067. Some examples

<?php
$client = new SoapClient(null, array('location' => "http://localhost/soap.php",
                                     'uri'      => "http://test-uri/"));
$client->__soapCall("echoVoid", null, null,
                new SoapHeader('http://soapinterop.org/echoheader/',
                               'echoMeStringRequest',
                               'hello world'));
?>

Viz také

SoapClient->__soapCall()
SoapVar->__construct()
SoapParam->__construct()

Předcházející | Nahoru | Další
SoapFault->__construct() | Domů | SoapParam->__construct()


SoapParam->__construct()

(No version information available, might be only in CVS)

SoapParam->__construct() — SoapParam constructor

Popis

class SoapParam {
__construct ( mixed $data, string $name )
}

Constructs a new SoapParam object.

Seznam parametrů

data

The data to pass or return. You can pass this parameter directly as PHP value, but in this case it will be named as paramN and the SOAP Service may not understand it.

name

The parameter name.

Příklady

Příklad 2068. Some examples

<?php
$client = new SoapClient(null,array('location' => "http://localhost/soap.php",
                                    'uri'      => "http://test-uri/"));
$client->SomeFunction(new SoapParam($a, "a"),
                      new SoapParam($b, "b"),
                      new SoapParam($c, "c"));
?>

Viz také

SoapClient->__soapCall()
SoapVar->__construct()

Předcházející | Nahoru | Další
SoapHeader->__construct() | Domů | SoapServer->addFunction()


SoapServer->addFunction()

(PHP 5 >= 5.0.1)

SoapServer->addFunction() — Adds one or several functions those will handle SOAP requests

Popis

class SoapServer {
void addFunction ( mixed $functions )
}

Exports one or more functions for remote clients.

Seznam parametrů

functions

To export one function, pass the function name into this parameter as a string.

To export several functions, pass an array of function names.

To export all the functions, pass a special constant SOAP_FUNCTIONS_ALL.

Poznámka: functions must receive all input arguments in the same order as defined in the WSDL file (They should not receive any output parameters as arguments) and return one or more values. To return several values they must return an array with named output parameters.

Návratové hodnoty

Nevrací se žádná hodnota.

Příklady

Příklad 2069. Some examples

<?php

function echoString($inputString)
{
    return $inputString;
}

$server->addFunction("echoString");

function echoTwoStrings($inputString1, $inputString2)
{
    return array("outputString1" => $inputString1,
                 "outputString2" => $inputString2);
}
$server->addFunction(array("echoString", "echoTwoStrings"));

$server->addFunction(SOAP_FUNCTIONS_ALL);

?>

Viz také

SoapServer->__construct()
SoapServer->setClass()

Předcházející | Nahoru | Další
SoapParam->__construct() | Domů | SoapServer->__construct()


SoapServer->__construct()

(No version information available, might be only in CVS)

SoapServer->__construct() — SoapServer constructor

Popis

class SoapServer {
__construct ( mixed $wsdl [, array $options] )
}

This constructor allows the creation of SoapServer objects in WSDL or non-WSDL mode.

Seznam parametrů

wsdl

If you want the WSDL mode, you must set this to the URI of a WSDL file. In the other case, you must set this to NULL and set the uri option.

options

Allow setting a default SOAP version (soap_version), internal character encoding (encoding), and actor URI (actor).

The classmap option can be used to map some WSDL types to PHP classes. This option must be an array with WSDL types as keys and names of PHP classes as values.

The typemap option is an array of type mappings. Type mapping is an array with keys type_name, type_ns (namespace URI), from_xml (callback accepting one string parameter) and to_xml (callback accepting one object parameter).

Other options are features and cache_wsdl.

Příklady

Příklad 2070. Some examples

<?php

$server = new SoapServer("some.wsdl");

$server = new SoapServer("some.wsdl", array('soap_version' => SOAP_1_2));

$server = new SoapServer("some.wsdl", array('actor' => "http://example.org/ts-tests/C"));

$server = new SoapServer("some.wsdl", array('encoding'=>'ISO-8859-1'));

$server = new SoapServer(null, array('uri' => "http://test-uri/"));

class MyBook {
    public $title;
    public $author;
}

$server = new SoapServer("books.wsdl", array('classmap' => array('book' => "MyBook")));

?>

Předcházející | Nahoru | Další
SoapServer->addFunction() | Domů | SoapServer->fault()


SoapServer->fault()

(No version information available, might be only in CVS)

SoapServer->fault() — Issue SoapServer fault indicating an error

Popis

class SoapServer {
void fault ( string $code, string $string [, string $actor [, mixed $details [, string $name]]] )
}
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Viz také

SoapFault->__construct()

Předcházející | Nahoru | Další
SoapServer->__construct() | Domů | SoapServer->getFunctions()


SoapServer->getFunctions()

(PHP 5 >= 5.0.1)

SoapServer->getFunctions() — Returns list of defined functions

Popis

class SoapServer {
array getFunctions ( void )
}

This method returns the list of all functions added by SoapServer->addFunction() or SoapServer->setClass().

Návratové hodnoty

The list of all functions.

Příklady

Příklad 2071. Some examples

<?php
$server = new SoapServer(NULL, array("uri" => "http://test-uri"));
$server->addFunction(SOAP_FUNCTIONS_ALL);
if ($_SERVER["REQUEST_METHOD"] == "POST") {
  $server->handle();
} else {
  echo "This SOAP server can handle following functions: ";
  $functions = $server->getFunctions();
  foreach($functions as $func) {
    echo $func . "\n";
  }
}
?>

Viz také

SoapServer->__construct()
SoapServer->addFunction()
SoapServer->setClass()

Předcházející | Nahoru | Další
SoapServer->fault() | Domů | SoapServer->handle()


SoapServer->handle()

(PHP 5 >= 5.0.1)

SoapServer->handle() — Handles a SOAP request

Popis

class SoapServer {
void handle ( [string $soap_request] )
}

Processes a SOAP request, calls necessary functions, and sends a response back.

Seznam parametrů

soap_request

The SOAP request. If this argument is omitted, the request is supposed to be in the $HTTP_RAW_POST_DATA PHP variable.

Návratové hodnoty

Nevrací se žádná hodnota.

Příklady

Příklad 2072. Some examples

<?php
function test($x)
{
    return $x;
}

$server = new SoapServer(null, array('uri' => "http://test-uri/"));
$server->addFunction("test");
$server->handle();
?>

Viz také

SoapServer->__construct()

Předcházející | Nahoru | Další
SoapServer->getFunctions() | Domů | SoapServer->setClass()


SoapServer->setClass()

(PHP 5 >= 5.0.1)

SoapServer->setClass() — Sets class which will handle SOAP requests

Popis

class SoapServer {
void setClass ( string $class_name [, mixed $args [, mixed $...]] )
}

Exports all methods from specified class.

The object can be made persistent across request for a given PHP session with the SoapServer->setPersistence() method.

Seznam parametrů

class_name

The name of the exported class.

args

These optional parameters will be passed to the default class constructor during object creation.

Návratové hodnoty

Nevrací se žádná hodnota.

Příklady

Příklad 2073. Some examples

<?php

class foo {
    function foo()
    {
    }
}
$server->setClass("foo");

class bar {
    function bar($x, $y)
    {
    }
}
$server->setClass("bar", $arg1, $arg2);

?>

Viz také

SoapServer->__construct()
SoapServer->addFunction()
SoapServer->setPersistence()

Předcházející | Nahoru | Další
SoapServer->handle() | Domů | SoapServer->setPersistence()


SoapServer->setPersistence()

(PHP 5 >= 5.1.2)

SoapServer->setPersistence() — Sets persistence mode of SoapServer

Popis

class SoapServer {
void setPersistence ( int $mode )
}

This function allows saving data between requests in a PHP session. It works only with a server that exports functions from a class with SoapServer->setClass().

Seznam parametrů

mode

One of the SOAP_PERSISTENCE_XXX constants.

Návratové hodnoty

Nevrací se žádná hodnota.

Příklady

Příklad 2074. Some examples

<?php

$server->setPersistence(SOAP_PERSISTENCE_SESSION);

$server->setPersistence(SOAP_PERSISTENCE_REQUEST);

?>

Poznámka: The persistence SOAP_PERSISTENCE_SESSION makes persistent only object of given class, but not the class static data. You may use $this->bar instead of self::$bar.

Viz také

SoapServer->__construct()
SoapServer->setClass()

Předcházející | Nahoru | Další
SoapServer->setClass() | Domů | SoapVar->__construct()


SoapVar->__construct()

(No version information available, might be only in CVS)

SoapVar->__construct() — SoapVar constructor

Popis

class SoapVar {
__construct ( mixed $data, int $encoding [, string $type_name [, string $type_namespace [, string $node_name [, string $node_namespace]]]] )
}

Constructs a new SoapVar object.

Seznam parametrů

data

The data to pass or return.

encoding

The encoding ID, one of the XSD_... constants.

type_name

The type name.

type_namespace

The type namespace.

node_name

The XML node name.

node_namespace

The XML node namespace.

Příklady

Příklad 2075. Some examples

<?php
class SOAPStruct {
    function SOAPStruct($s, $i, $f)
    {
        $this->varString = $s;
        $this->varInt = $i;
        $this->varFloat = $f;
    }
}
$client = new SoapClient(null, array('location' => "http://localhost/soap.php",
                                     'uri'      => "http://test-uri/"));
$struct = new SOAPStruct('arg', 34, 325.325);
$soapstruct = new SoapVar($struct, SOAP_ENC_OBJECT, "SOAPStruct", "http://soapinterop.org/xsd");
$client->echoStruct(new SoapParam($soapstruct, "inputStruct"));
?>

Viz také

SoapClient->__soapCall()
SoapParam->__construct()

Předcházející | Nahoru | Další
SoapServer->setPersistence() | Domů | use_soap_error_handler


spl_autoload

(PHP 5 >= 5.1.2)

spl_autoload — Default implementation for __autoload()

Description

void spl_autoload ( string $class_name [, string $file_extensions] )

This function is intended to be used as a default implementation for __autoload(). If nothing else is specified and autoload_register() is called without any parameters then this functions will be used for any later call to __autoload(). By default it checks all include paths to contain filenames built up by the lowercase class name appended by the filename extensions .inc and .php.

Předcházející | Nahoru | Další
spl_autoload_unregister | Domů | spl_classes


spl_autoload_call

(PHP 5 >= 5.1.2)

spl_autoload_call — Try all registered __autoload() function to load the requested class

Description

void spl_autoload_call ( string $class_name )

This function can be used to manually search for a class or interface using the registered __autoload functions.

Předcházející | Nahoru | Další
iterator_to_array | Domů | spl_autoload_extensions


spl_autoload_extensions

(PHP 5 >= 5.1.2)

spl_autoload_extensions — Register and return default file extensions for spl_autoload

Description

string spl_autoload_extensions ( [string $file_extensions] )

This function allows to modify and check the file extensions the built in __autoload fallback function spl_autoload will be using. When calling without an argument it simply returns the current list of extensions each separated by comma. To modify the list of file extensions simply invoke the functions with the new list of file extensions to use in a single string with each extensions separated by comma.

Předcházející | Nahoru | Další
spl_autoload_call | Domů | spl_autoload_functions


spl_autoload_functions

(PHP 5 >= 5.1.2)

spl_autoload_functions — Return all registered __autoload() functions

Description

array spl_autoload_functions ( void )

This function returns an array of all registered __autoload functions. If the autoload stack is not activated then the return value is false. If no function is registered the return value will be an empty array.

Předcházející | Nahoru | Další
spl_autoload_extensions | Domů | spl_autoload_register


spl_autoload_register

(PHP 5 >= 5.1.2)

spl_autoload_register — Register given function as __autoload() implementation

Description

bool spl_autoload_register ( [callback $autoload_function] )

Register a function with the spl provided __autoload stack. If the stack is not yet activated it will be activated. If no parameter is provided the default implementation spl_autoload will be registered. When registering is successful the return value is true and upon failure false is being returned.

If your code has an existing __autoload function then this function must explicitly registered on the __autoload stack. This is because spl_autoload_register() will effectively replace the engine cache for the __autoload function by either spl_autoload() or spl_autoload_call().

Předcházející | Nahoru | Další
spl_autoload_functions | Domů | spl_autoload_unregister


spl_autoload_unregister

(PHP 5 >= 5.1.2)

spl_autoload_unregister — Unregister given function as __autoload() implementation

Description

bool spl_autoload_unregister ( mixed $autoload_function )

Unregister a function from the spl provided __autoload stack. If the stack is activated and empty after unregistering the given function then it will be deactivated. When unregistering is successful the return value is true and upon failure false is being returned.

When this function results in the autoload stack being activated an existing __autoload function will not be reactivated.

Předcházející | Nahoru | Další
spl_autoload_register | Domů | spl_autoload


spl_object_hash

(PHP 5 >= 5.2.0)

spl_object_hash — Return hash id for given object

Description

string spl_object_hash ( object $obj )

This function returns an unique identifier for the object. This id can be used as a hash key for storing objects or for identifying an object.

Seznam parametrů

object

Any object.

Návratové hodnoty

Returns a string that is unique for each object and is always the same for the same object.

Příklady

Příklad 2102. A spl_object_hash() example

<?php
$id = spl_object_hash($object);
$storage[$id] = $object;
?>

Předcházející | Nahoru | Další
spl_classes | Domů | CLVI. SQLite Functions


sqlite_key

Předcházející CLVI. SQLite Functions Další

sqlite_key,

(PHP 5 >= 5.1.0)

sqlite_key, SQLiteResult->key — Returns the current row index

Popis

int sqlite_key ( resource $result )

Object oriented style (method):

class SQLiteResult {
int key ( void )
}

sqlite_key() returns the current row index of the buffered result set result.

Seznam parametrů

result

The SQLite result resource. This parameter is not required when using the object-oriented method.

Poznámka: Tuto funkci nelze použít s nebufferovaným přístupem k výsledkům.

Návratové hodnoty

Returns the current row index of the buffered result set result.

ChangeLog (záznam změn)

Verze | Popis
5.0.4 | Prior to PHP 5.0.4, sqlite_key() was only able to be called as a method on a SQLiteResult object, not procedurally.

Viz také

sqlite_next()
sqlite_current()
sqlite_rewind()

Předcházející | Nahoru | Další
sqlite_has_prev | Domů | sqlite_last_error


sqlite_valid

Předcházející CLVI. SQLite Functions Další

sqlite_valid,

(PHP 5)

sqlite_valid, SQLiteResult->valid, SQLiteUnbuffered->valid — Returns whether more rows are available

Popis

bool sqlite_valid ( resource $result )

Object oriented style (method):

class SQLiteResult {
bool valid ( void )
} class SQLiteUnbuffered {
bool valid ( void )
}

Finds whether more rows are available from the given result handle.

Seznam parametrů

result

The SQLite result resource. This parameter is not required when using the object-oriented method.

Poznámka: Tuto funkci nelze použít s nebufferovaným přístupem k výsledkům.

Návratové hodnoty

Returns TRUE if there are more rows available from the result handle, or FALSE otherwise.

Viz také

sqlite_num_rows()
sqlite_changes()

Předcházející | Nahoru | Další
sqlite_unbuffered_query | Domů | CLVII. SQLite Functions (PDO_SQLITE)


ssh2_auth_hostbased_file

(PECL ssh2:0.10-0.9)

ssh2_auth_hostbased_file — Authenticate using a public hostkey

Popis

bool ssh2_auth_hostbased_file ( resource $session, string $username, string $hostname, string $pubkeyfile, string $privkeyfile [, string $passphrase [, string $local_username]] )

Authenticate using a public hostkey read from a file.

Seznam parametrů

session

An SSH connection link identifier, obtained from a call to ssh2_connect().

username

hostname

pubkeyfile

privkeyfile

passphrase

If privkeyfile is encrypted (which it should be), the passphrase must be provided.

local_username

If local_username is omitted, then the value for username will be used for it.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 2130. Authentication using a public hostkey

<?php
$connection = ssh2_connect('shell.example.com', 22, array('hostkey'=>'ssh-rsa'));

if (ssh2_auth_hostbased_file($connection, 'remoteusername', 'myhost.example.com',
                             '/usr/local/etc/hostkey_rsa.pub',
                             '/usr/local/etc/hostkey_rsa', 'secret',
                             'localusername')) {
  echo "Public Key Hostbased Authentication Successful\n";
} else {
  die('Public Key Hostbased Authentication Failed');
}
?>

Poznámky

Poznámka: ssh2_auth_hostbased_file() requires libssh2 >= 0.7 and PHP/SSH2 >= 0.7

Předcházející | Nahoru | Další
CLVIII. Secure Shell2 Functions | Domů | ssh2_auth_none


ssh2_auth_none

(PECL ssh2:0.10-0.9)

ssh2_auth_none — Authenticate as "none"

Popis

mixed ssh2_auth_none ( resource $session, string $username )

Attempt "none" authentication which usually will (and should) fail. As part of the failure, this function will return an array of accepted authentication methods.

Seznam parametrů

session

An SSH connection link identifier, obtained from a call to ssh2_connect().

username

Remote user name.

Návratové hodnoty

Returns TRUE if the server doesc accept "none" as an authentication method, or an array of accepted authentication methods on failure.

Příklady

Příklad 2131. Retreiving a list of authentication methods

<?php
$connection = ssh2_connect('shell.example.com', 22);

$auth_methods = ssh2_auth_none($connection, 'user');

if (in_array('password', $auth_methods)) {
  echo "Server supports password based authentication\n";
}
?>

Předcházející | Nahoru | Další
ssh2_auth_hostbased_file | Domů | ssh2_auth_password


ssh2_auth_password

(PECL ssh2:0.10-0.9)

ssh2_auth_password — Authenticate over SSH using a plain password

Popis

bool ssh2_auth_password ( resource $session, string $username, string $password )

Authenticate over SSH using a plain password

Seznam parametrů

session

An SSH connection link identifier, obtained from a call to ssh2_connect().

username

Remote user name.

password

Password for username

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 2132. Authenticating with a password

<?php
$connection = ssh2_connect('shell.example.com', 22);

if (ssh2_auth_password($connection, 'username', 'secret')) {
  echo "Authentication Successful!\n";
} else {
  die('Authentication Failed...');
}
?>

Předcházející | Nahoru | Další
ssh2_auth_none | Domů | ssh2_auth_pubkey_file


ssh2_auth_pubkey_file

(PECL ssh2:0.10-0.9)

ssh2_auth_pubkey_file — Authenticate using a public key

Popis

bool ssh2_auth_pubkey_file ( resource $session, string $username, string $pubkeyfile, string $privkeyfile [, string $passphrase] )

Authenticate using a public key read from a file.

Seznam parametrů

session

An SSH connection link identifier, obtained from a call to ssh2_connect().

username

pubkeyfile

privkeyfile

passphrase

If privkeyfile is encrypted (which it should be), the passphrase must be provided.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 2133. Authentication using a public key

<?php
$connection = ssh2_connect('shell.example.com', 22, array('hostkey'=>'ssh-rsa'));

if (ssh2_auth_pubkey_file($connection, 'username',
                          '/home/username/.ssh/id_rsa.pub',
                          '/home/username/.ssh/id_rsa', 'secret')) {
  echo "Public Key Authentication Successful\n";
} else {
  die('Public Key Authentication Failed');
}
?>

Předcházející | Nahoru | Další
ssh2_auth_password | Domů | ssh2_connect


ssh2_connect

(PECL ssh2:0.10-0.9)

ssh2_connect — Connect to an SSH server

Popis

resource ssh2_connect ( string $host [, int $port [, array $methods [, array $callbacks]]] )

Establish a connection to a remote SSH server.

Once connected, the client should verify the server's hostkey using ssh2_fingerprint(), then authenticate using either password or public key.

Seznam parametrů

host

port

methods

methods may be an associative array with up to four parameters as described below.

Tabulka 291. methods may be an associative array with any or all of the following parameters.

Index | Meaning | Supported Values*
kex | List of key exchange methods to advertise, comma separated in order of preference. | diffie-hellman-group1-sha1, diffie-hellman-group14-sha1, and diffie-hellman-group-exchange-sha1
hostkey | List of hostkey methods to advertise, come separated in order of preference. | ssh-rsa and ssh-dss
client_to_server | Associative array containing crypt, compression, and message authentication code (MAC) method preferences for messages sent from client to server.
server_to_client | Associative array containing crypt, compression, and message authentication code (MAC) method preferences for messages sent from client to server.

* - Supported Values are dependent on methods supported by underlying library. See » libssh2 documentation for additional information.

Tabulka 292. client_to_server and server_to_client may be an associative array with any or all of the following parameters.

Index | Meaning | Supported Values*
crypt | List of crypto methods to advertise, comma separated in order of preference. | rijndael-cbc@lysator.liu.se, aes256-cbc, aes192-cbc, aes128-cbc, 3des-cbc, blowfish-cbc, cast128-cbc, arcfour, and none**
comp | List of compression methods to advertise, comma separated in order of preference. | zlib and none
mac | List of MAC methods to advertise, come separated in order of preference. | hmac-sha1, hmac-sha1-96, hmac-ripemd160, hmac-ripemd160@openssh.com, and none**

Crypt and MAC method "none": For security reasons, none is disabled by the underlying » libssh2 library unless explicitly enabled during build time by using the appropriate ./configure options. See documentation for the underlying library for more information.

callbacks

callbacks may be an associative array with any or all of the following parameters.

Tabulka 293. Callbacks parameters

Index | Meaning | Prototype
ignore | Name of function to call when an SSH2_MSG_IGNORE packet is received | void ignore_cb($message)
debug | Name of function to call when an SSH2_MSG_DEBUG packet is received | void debug_cb($message, $language, $always_display)
macerror | Name of function to call when a packet is received but the message authentication code failed. If the callback returns TRUE, the mismatch will be ignored, otherwise the connection will be terminated. | bool macerror_cb($packet)
disconnect | Name of function to call when an SSH2_MSG_DISCONNECT packet is received | void disconnect_cb($reason, $message, $language)

Návratové hodnoty

Returns a resource on success, or FALSE on error.

Příklady

Příklad 2134. ssh2_connect() example

Open a connection forcing 3des-cbc when sending packets, any strength aes cipher when receiving packets, no compression in either direction, and Group1 key exchange.

<?php
/* Notify the user if the server terminates the connection */
function my_ssh_disconnect($reason, $message, $language) {
  printf("Server disconnected with reason code [%d] and message: %s\n",
         $reason, $message);
}

$methods = array(
  'kex' => 'diffie-hellman-group1-sha1',
  'client_to_server' => array(
    'crypt' => '3des-cbc',
    'comp' => 'none'),
  'server_to_client' => array(
    'crypt' => 'aes256-cbc,aes192-cbc,aes128-cbc',
    'comp' => 'none'));

$callbacks = array('disconnect' => 'my_ssh_disconnect');

$connection = ssh2_connect('shell.example.com', 22, $methods, $callbacks);
if (!$connection) die('Connection failed');
?>

Viz také

ssh2_fingerprint()
ssh2_auth_none()
ssh2_auth_password()
ssh2_auth_pubkey_file()

Předcházející | Nahoru | Další
ssh2_auth_pubkey_file | Domů | ssh2_exec


ssh2_exec

(PECL ssh2:0.10-0.9)

ssh2_exec — Execute a command on a remote server

Popis

resource ssh2_exec ( resource $session, string $command [, string $pty [, array $env [, int $width [, int $height [, int $width_height_type]]]]] )

Execute a command at the remote end and allocate a channel for it.

Seznam parametrů

session

An SSH connection link identifier, obtained from a call to ssh2_connect().

command

pty

env

env may be passed as an associative array of name/value pairs to set in the target environment.

width

Width of the virtual terminal.

height

Height of the virtual terminal.

width_height_type

width_height_type should be one of SSH2_TERM_UNIT_CHARS or SSH2_TERM_UNIT_PIXELS.

Návratové hodnoty

Returns a stream on success or FALSE on failure.

Příklady

Příklad 2135. Executing a command

<?php
$connection = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($connection, 'username', 'password');

$stream = ssh2_exec($connection, '/usr/local/bin/php -i');
?>

Viz také

ssh2_connect()
ssh2_shell()
ssh2_tunnel()

Předcházející | Nahoru | Další
ssh2_connect | Domů | ssh2_fetch_stream


ssh2_fetch_stream

(PECL ssh2:0.10-0.9)

ssh2_fetch_stream — Fetch an extended data stream

Popis

resource ssh2_fetch_stream ( resource $channel, int $streamid )

Fetches an alternate substream associated with an SSH2 channel stream. The SSH2 protocol currently defines only one substream, STDERR, which has a substream ID of SSH2_STREAM_STDERR (defined as 1).

Seznam parametrů

channel

streamid

An SSH2 channel stream.

Návratové hodnoty

Returns the requested stream resource.

Příklady

Příklad 2136. Opening a shell and retrieving the stderr stream associated with it

<?php
$connection = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($connection, 'username', 'password');

$stdio_stream = ssh2_shell($connection);
$stderr_stream = ssh2_fetch_stream($stdio_stream, SSH2_STREAM_STDERR);
?>

Viz také

ssh2_shell()
ssh2_exec()
ssh2_connect()

Předcházející | Nahoru | Další
ssh2_exec | Domů | ssh2_fingerprint


ssh2_fingerprint

(PECL ssh2:0.10-0.9)

ssh2_fingerprint — Retreive fingerprint of remote server

Popis

string ssh2_fingerprint ( resource $session [, int $flags] )

Returns a server hostkey hash from an active session.

Seznam parametrů

session

An SSH connection link identifier, obtained from a call to ssh2_connect().

flags

flags may be either of SSH2_FINGERPRINT_MD5 or SSH2_FINGERPRINT_SHA1 logically ORed with SSH2_FINGERPRINT_HEX or SSH2_FINGERPRINT_RAW. Defaults to SSH2_FINGERPRINT_MD5 | SSH2_FINGERPRINT_HEX.

Návratové hodnoty

Returns the hostkey hash as a string.

Příklady

Příklad 2137. Checking the fingerprint against a known value

<?php
$known_host = '6F89C2F0A719B30CC38ABDF90755F2E4';

$connection = ssh2_connect('shell.example.com', 22);

$fingerprint = ssh2_fingerprint($connection,
               SSH2_FINGERPRINT_MD5 | SSH2_FINGERPRINT_HEX);

if ($fingerprint != $known_host) {
  die("HOSTKEY MISMATCH!\n" .
      "Possible Man-In-The-Middle Attack?");
}
?>

Předcházející | Nahoru | Další
ssh2_fetch_stream | Domů | ssh2_methods_negotiated


ssh2_methods_negotiated

(PECL ssh2:0.10-0.9)

ssh2_methods_negotiated — Return list of negotiated methods

Popis

array ssh2_methods_negotiated ( resource $session )

Returns list of negotiated methods.

Seznam parametrů

session

An SSH connection link identifier, obtained from a call to ssh2_connect().

Návratové hodnoty

Příklady

Příklad 2138. Determining what methods were negotiated

<?php
$connection = ssh2_connect('shell.example.com', 22);
$methods = ssh2_methods_negotiated($connection);

echo "Encryption keys were negotiated using: {$methods['kex']}\n";
echo "Server identified using an {$methods['hostkey']} with ";
echo "fingerprint: " . ssh2_fingerprint($connection) . "\n";

echo "Client to Server packets will use methods:\n";
echo "\tCrypt: {$methods['client_to_server']['crypt']}\n";
echo "\tComp: {$methods['client_to_server']['comp']}\n";
echo "\tMAC: {$methods['client_to_server']['mac']}\n";

echo "Server to Client packets will use methods:\n";
echo "\tCrypt: {$methods['server_to_client']['crypt']}\n";
echo "\tComp: {$methods['server_to_client']['comp']}\n";
echo "\tMAC: {$methods['server_to_client']['mac']}\n";

?>

Viz také

ssh2_connect()

Předcházející | Nahoru | Další
ssh2_fingerprint | Domů | ssh2_publickey_add


ssh2_publickey_add

(PECL ssh2:0.10)

ssh2_publickey_add — Add an authorized publickey

Popis

bool ssh2_publickey_add ( resource $pkey, string $algoname, string $blob [, bool $overwrite [, array $attributes]] )

Poznámka: Subsystém veřejných klíčů se používá pro správu veřejných klíčů na serveru, na kterém je klient již autentizován. K autentizaci na vzdáleném systému pomocí veřejného klíče použijte místo toho funkci ssh2_auth_pubkey_file().

Seznam parametrů

pkey

Publickey Subsystem resource created by ssh2_publickey_init().

algoname

Publickey algorithm (e.g.): ssh-dss, ssh-rsa

blob

Publickey blob as raw binary data

overwrite

If the specified key already exists, should it be overwritten?

attributes

Associative array of attributes to assign to this public key. Refer to ietf-secsh-publickey-subsystem for a list of supported attributes. To mark an attribute as mandatory, precede its name with an asterisk. If the server is unable to support an attribute marked mandatory, it will abort the add process.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 2139. Adding a publickey with ssh2_publickey_add()

<?php
$ssh2 = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($ssh2, 'jdoe', 'password');
$pkey = ssh2_publickey_init($ssh2);

$keyblob = base64_decode('
AAAAB3NzaC1yc2EAAAABIwAAAIEA5HVt6VqSGd5PTrLRdjNONxXH1tVFGn0
Bd26BF0aCP9qyJRlvdJ3j4WBeX4ZmrveGrjMgkseSYc4xZ26sDHwfL351xj
zaLpipu\BGRrw17mWVBhuCExo476ri5tQFzbTc54VEHYckxQ16CjSTibI5X
69GmnYC9PNqEYq/1TP+HF10=');

ssh2_publickey_add($ssh2, 'ssh-rsa', $keyblob, false, array('comment'=>"John's Key"));
?>

Viz také

ssh2_publickey_init()
ssh2_publickey_remove()
ssh2_publickey_list()

Předcházející | Nahoru | Další
ssh2_methods_negotiated | Domů | ssh2_publickey_init


ssh2_publickey_init

(PECL ssh2:0.10)

ssh2_publickey_init — Initialize Publickey subsystem

Popis

resource ssh2_publickey_init ( resource $session )

Request the Publickey subsystem from an already connected SSH2 server.

The publickey subsystem allows an already connected and authenticated client to manage the list of authorized public keys stored on the target server in an implementation agnostic manner. If the remote server does not support the publickey subsystem, the ssh2_publickey_init() function will return FALSE.

Seznam parametrů

session

Návratové hodnoty

Returns an SSH2 Publickey Subsystem resource for use with all other ssh2_publickey_*() methods, or FALSE on failure.

Poznámky

Poznámka: Subsystém veřejných klíčů se používá pro správu veřejných klíčů na serveru, na kterém je klient již autentizován. K autentizaci na vzdáleném systému pomocí veřejného klíče použijte místo toho funkci ssh2_auth_pubkey_file().

Viz také

ssh2_publickey_add()
ssh2_publickey_remove()
ssh2_publickey_list()

Předcházející | Nahoru | Další
ssh2_publickey_add | Domů | ssh2_publickey_list


ssh2_publickey_list

(PECL ssh2:0.10)

ssh2_publickey_list — List currently authorized publickeys

Popis

array ssh2_publickey_list ( resource $pkey )

List currently authorized publickeys.

Seznam parametrů

pkey

Publickey Subsystem resource

Návratové hodnoty

Returns a numerically indexed array of keys, each of which is an associative array containing: name, blob, and attrs elements.

Tabulka 294. Publickey elements

Array Key | Meaning
name | Name of algorithm used by this publickey, for example: ssh-dss or ssh-rsa.
blob | Publickey blob as raw binary data.
attrs | Attributes assigned to this publickey. The most common attribute, and the only one supported by publickey version 1 servers, is comment, which may be any freeform string.

Příklady

Příklad 2140. Listing authorized keys with ssh2_publickey_list()

<?php
$ssh2 = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($ssh2, 'jdoe', 'secret');
$pkey = ssh2_publickey_init($ssh2);

$list = ssh2_publickey_list($pkey);

foreach($list as $key) {
  echo "Key: {$key['name']}\n";
  echo "Blob: " . chunk_split(base64_encode($key['blob']), 40, "\n") . "\n";
  echo "Comment: {$key['attrs']['comment']}\n\n";
}
?>

Výše uvedený příklad vypíše:

Key: ssh-rsa
Blob: AAAAB3NzaC1yc2EAAAABIwAAAIEA5HVt6VqSGd5P
TrLRdjNONxXH1tVFGn0Bd26BF0aCP9qyJRlvdJ3j
4WBeX4ZmrveGrjMgkseSYc4xZ26sDHwfL351xjza
Lpipu\BGRrw17mWVBhuCExo476ri5tQFzbTc54VE
HYckxQ16CjSTibI5X69GmnYC9PNqEYq/1TP+HF10
Comment: John's Key

Key: ssh-rsa
Blob: AAAAB3NzaHVt6VqSGd5C1yc2EAAAABIwA232dnJA
AIEA5HVt6VqSGd5PTrLRdjNONxX/1TP+HF1HVt6V
qSGd50H1tVFGn0BB3NzaC1yc2EAd26BF0aCP9qyJ
RlvdJ3j4WBeX4ZmrveGrjMgkseSYc4xZ26HVt6Vq
SGd5sDHwfL351xjzaLpipu\BGB3NzaC1yc2EA/1T
Comment: Alice's Key

Poznámky

Poznámka: Subsystém veřejných klíčů se používá pro správu veřejných klíčů na serveru, na kterém je klient již autentizován. K autentizaci na vzdáleném systému pomocí veřejného klíče použijte místo toho funkci ssh2_auth_pubkey_file().

Viz také

ssh2_publickey_init()
ssh2_publickey_add()
ssh2_publickey_remove()

Předcházející | Nahoru | Další
ssh2_publickey_init | Domů | ssh2_publickey_remove


ssh2_publickey_remove

(PECL ssh2:0.10)

ssh2_publickey_remove — Remove an authorized publickey

Popis

bool ssh2_publickey_remove ( resource $pkey, string $algoname, string $blob )

Removes an authorized publickey.

Seznam parametrů

pkey

Publickey Subsystem Resource

algoname

Publickey algorithm (e.g.): ssh-dss, ssh-rsa

blob

Publickey blob as raw binary data

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Poznámky

Poznámka: Subsystém veřejných klíčů se používá pro správu veřejných klíčů na serveru, na kterém je klient již autentizován. K autentizaci na vzdáleném systému pomocí veřejného klíče použijte místo toho funkci ssh2_auth_pubkey_file().

Viz také

ssh2_publickey_init()
ssh2_publickey_add()
ssh2_publickey_list()

Předcházející | Nahoru | Další
ssh2_publickey_list | Domů | ssh2_scp_recv


ssh2_scp_recv

(PECL ssh2:0.10-0.9)

ssh2_scp_recv — Request a file via SCP

Popis

bool ssh2_scp_recv ( resource $session, string $remote_file, string $local_file )

Copy a file from the remote server to the local filesystem using the SCP protocol.

Seznam parametrů

session

An SSH connection link identifier, obtained from a call to ssh2_connect().

remote_file

Path to the remote file.

local_file

Path to the local file.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 2141. Downloading a file via SCP

<?php
$connection = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($connection, 'username', 'password');

ssh2_scp_recv($connection, '/remote/filename', '/local/filename');
?>

Viz také

ssh2_scp_send()
copy()

Předcházející | Nahoru | Další
ssh2_publickey_remove | Domů | ssh2_scp_send


ssh2_scp_send

(PECL ssh2:0.10-0.9)

ssh2_scp_send — Send a file via SCP

Popis

bool ssh2_scp_send ( resource $session, string $local_file, string $remote_file [, int $create_mode] )

Copy a file from the local filesystem to the remote server using the SCP protocol.

Seznam parametrů

session

An SSH connection link identifier, obtained from a call to ssh2_connect().

local_file

Path to the local file.

remote_file

Path to the remote file.

create_mode

The file will be created with the mode specified by create_mode.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 2142. Uploading a file via SCP

<?php
$connection = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($connection, 'username', 'password');

ssh2_scp_send($connection, '/local/filename', '/remote/filename', 0644);
?>

Viz také

ssh2_scp_recv()
copy()

Předcházející | Nahoru | Další
ssh2_scp_recv | Domů | ssh2_sftp_lstat


ssh2_sftp

(PECL ssh2:0.10-0.9)

ssh2_sftp — Initialize SFTP subsystem

Popis

resource ssh2_sftp ( resource $session )

Request the SFTP subsystem from an already connected SSH2 server.

Seznam parametrů

session

An SSH connection link identifier, obtained from a call to ssh2_connect().

Návratové hodnoty

This method returns an SSH2 SFTP resource for use with all other ssh2_sftp_*() methods and the ssh2.sftp:// fopen wrapper.

Příklady

Příklad 2152. Opening a file via SFTP

<?php
$connection = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($connection, 'username', 'password');

$sftp = ssh2_sftp($connection);

$stream = fopen("ssh2.sftp://$sftp/path/to/file", 'r');
?>

Viz také

ssh2_scp_recv()
ssh2_scp_send()

Předcházející | Nahoru | Další
ssh2_sftp_unlink | Domů | ssh2_shell


ssh2_sftp_lstat

(PECL ssh2:0.10-0.9)

ssh2_sftp_lstat — Stat a symbolic link

Popis

array ssh2_sftp_lstat ( resource $sftp, string $path )

Stats a symbolic link on the remote filesystem without following the link.

This function is similar to using the lstat() function with the ssh2.sftp:// wrapper in PHP5 and returns the same values.

Seznam parametrů

sftp

path

Path to the remote symbolic link.

Návratové hodnoty

See the documentation for stat() for details on the values which may be returned.

Příklady

Příklad 2143. Stating a symbolic link via SFTP

<?php
$connection = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($connection, 'username', 'password');

$sftp = ssh2_sftp($connection);
$statinfo = ssh2_sftp_lstat($sftp, '/path/to/symlink');

$filesize = $statinfo['size'];
$group = $statinfo['gid'];
$owner = $statinfo['uid'];
$atime = $statinfo['atime'];
$mtime = $statinfo['mtime'];
$mode = $statinfo['mode'];
?>

Viz také

ssh2_sftp_stat()
lstat()
stat()

Předcházející | Nahoru | Další
ssh2_scp_send | Domů | ssh2_sftp_mkdir


ssh2_sftp_mkdir

(PECL ssh2:0.10-0.9)

ssh2_sftp_mkdir — Create a directory

Popis

bool ssh2_sftp_mkdir ( resource $sftp, string $dirname [, int $mode [, bool $recursive]] )

Creates a directory on the remote file server with permissions set to mode.

This function is similar to using mkdir() with the ssh2.sftp:// wrapper.

Seznam parametrů

sftp

An SSH2 SFTP resource opened by ssh2_sftp().

dirname

Path of the new directory.

mode

Permissions on the new directory.

recursive

If recursive is TRUE any parent directories required for dirname will be automatically created as well.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 2144. Creating a directory on a remote server

<?php
$connection = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($connection, 'username', 'password');
$sftp = ssh2_sftp($connection);

ssh2_sftp_mkdir($sftp, '/home/username/newdir');
/* Or:  mkdir("ssh2.sftp://$sftp/home/username/newdir"); */
?>

Viz také

mkdir()
ssh2_sftp_rmdir()

Předcházející | Nahoru | Další
ssh2_sftp_lstat | Domů | ssh2_sftp_readlink


ssh2_sftp_readlink

(PECL ssh2:0.10-0.9)

ssh2_sftp_readlink — Return the target of a symbolic link

Popis

string ssh2_sftp_readlink ( resource $sftp, string $link )

Returns the target of a symbolic link.

Seznam parametrů

sftp

An SSH2 SFTP resource opened by ssh2_sftp().

link

Path of the symbolic link.

Návratové hodnoty

Returns the target of the symbolic link.

Příklady

Příklad 2145. Reading a symbolic link

<?php
$connection = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($connection, 'username', 'password');
$sftp = ssh2_sftp($connection);

$target = ssh2_sftp_readlink($sftp, '/tmp/mysql.sock');
/* $target is now (e.g.): '/var/run/mysql.sock' */
?>

Viz také

readlink()
ssh2_sftp_symlink()

Předcházející | Nahoru | Další
ssh2_sftp_mkdir | Domů | ssh2_sftp_realpath


ssh2_sftp_realpath

(PECL ssh2:0.10-0.9)

ssh2_sftp_realpath — Resolve the realpath of a provided path string

Popis

string ssh2_sftp_realpath ( resource $sftp, string $filename )

Translates filename into the effective real path on the remote filesystem.

Seznam parametrů

sftp

An SSH2 SFTP resource opened by ssh2_sftp().

filename

Návratové hodnoty

Returns the real path as a string.

Příklady

Příklad 2146. Resolving a pathname

<?php
$connection = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($connection, 'username', 'password');
$sftp = ssh2_sftp($connection);

$realpath = ssh2_sftp_realpath($sftp, '/home/username/../../../..//./usr/../etc/passwd');
/* $realpath is now: '/etc/passwd' */
?>

Viz také

realpath()
ssh2_sftp_symlink()
ssh2_sftp_readlink()

Předcházející | Nahoru | Další
ssh2_sftp_readlink | Domů | ssh2_sftp_rename


ssh2_sftp_rename

(PECL ssh2:0.10-0.9)

ssh2_sftp_rename — Rename a remote file

Popis

bool ssh2_sftp_rename ( resource $sftp, string $from, string $to )

Renames a file on the remote filesystem.

Seznam parametrů

sftp

An SSH2 SFTP resource opened by ssh2_sftp().

from

to

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 2147. Renaming a file via sftp

<?php
$connection = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($connection, 'username', 'password');
$sftp = ssh2_sftp($connection);

ssh2_sftp_rename($sftp, '/home/username/oldname', '/home/username/newname');
?>

Viz také

rename()

Předcházející | Nahoru | Další
ssh2_sftp_realpath | Domů | ssh2_sftp_rmdir


ssh2_sftp_rmdir

(PECL ssh2:0.10-0.9)

ssh2_sftp_rmdir — Remove a directory

Popis

bool ssh2_sftp_rmdir ( resource $sftp, string $dirname )

Removes a directory from the remote file server.

This function is similar to using rmdir() with the ssh2.sftp:// wrapper.

Seznam parametrů

sftp

An SSH2 SFTP resource opened by ssh2_sftp().

dirname

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 2148. Removing a directory on a remote server

<?php
$connection = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($connection, 'username', 'password');
$sftp = ssh2_sftp($connection);

ssh2_sftp_rmdir($sftp, '/home/username/deltodel');
/* Or:  rmdir("ssh2.sftp://$sftp/home/username/dirtodel"); */
?>

Viz také

rmdir()
ssh2_sftp_mkdir()

Předcházející | Nahoru | Další
ssh2_sftp_rename | Domů | ssh2_sftp_stat


ssh2_sftp_stat

(PECL ssh2:0.10-0.9)

ssh2_sftp_stat — Stat a file on a remote filesystem

Popis

array ssh2_sftp_stat ( resource $sftp, string $path )

Stats a file on the remote filesystem following any symbolic links.

This function is similar to using the stat() function with the ssh2.sftp:// wrapper in PHP5 and returns the same values.

Seznam parametrů

sftp

An SSH2 SFTP resource opened by ssh2_sftp().

path

Návratové hodnoty

See the documentation for stat() for details on the values which may be returned.

Příklady

Příklad 2149. Stating a file via SFTP

<?php
$connection = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($connection, 'username', 'password');

$sftp = ssh2_sftp($connection);
$statinfo = ssh2_sftp_stat($sftp, '/path/to/file');

$filesize = $statinfo['size'];
$group = $statinfo['gid'];
$owner = $statinfo['uid'];
$atime = $statinfo['atime'];
$mtime = $statinfo['mtime'];
$mode = $statinfo['mode'];
?>

Viz také

ssh2_sftp_lstat()
lstat()
stat()

Předcházející | Nahoru | Další
ssh2_sftp_rmdir | Domů | ssh2_sftp_symlink


ssh2_sftp_symlink

(PECL ssh2:0.10-0.9)

ssh2_sftp_symlink — Create a symlink

Popis

bool ssh2_sftp_symlink ( resource $sftp, string $target, string $link )

Creates a symbolic link named link on the remote filesystem pointing to target.

Seznam parametrů

sftp

An SSH2 SFTP resource opened by ssh2_sftp().

target

Target of the symbolic link.

link

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 2150. Creating a symbolic link

<?php
$connection = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($connection, 'username', 'password');
$sftp = ssh2_sftp($connection);

ssh2_sftp_symlink($sftp, '/var/run/mysql.sock', '/tmp/mysql.sock');
?>

Viz také

ssh2_sftp_readlink()
symlink()

Předcházející | Nahoru | Další
ssh2_sftp_stat | Domů | ssh2_sftp_unlink


ssh2_sftp_unlink

(PECL ssh2:0.10-0.9)

ssh2_sftp_unlink — Delete a file

Popis

bool ssh2_sftp_unlink ( resource $sftp, string $filename )

Deletes a file on the remote filesystem.

Seznam parametrů

sftp

An SSH2 SFTP resource opened by ssh2_sftp().

filename

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 2151. Deleting a file

<?php
$connection = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($connection, 'username', 'password');
$sftp = ssh2_sftp($connection);

ssh2_sftp_unlink($sftp, '/home/username/stale_file');
?>

Viz také

unlink()

Předcházející | Nahoru | Další
ssh2_sftp_symlink | Domů | ssh2_sftp


ssh2_shell

(PECL ssh2:0.10-0.9)

ssh2_shell — Request an interactive shell

Popis

resource ssh2_shell ( resource $session [, string $term_type [, array $env [, int $width [, int $height [, int $width_height_type]]]]] )

Open a shell at the remote end and allocate a stream for it.

Seznam parametrů

session

An SSH connection link identifier, obtained from a call to ssh2_connect().

term_type

term_type should correspond to one of the entries in the target system's /etc/termcap file and defaults to vanilla.

env

env may be passed as an associative array of name/value pairs to set in the target environment.

width

Width of the virtual terminal.

height

Height of the virtual terminal.

width_height_type

width_height_type should be one of SSH2_TERM_UNIT_CHARS or SSH2_TERM_UNIT_PIXELS.

Návratové hodnoty

Příklady

Příklad 2153. Executing a command

<?php
$connection = ssh2_connect('shell.example.com', 22);
ssh2_auth_password($connection, 'username', 'password');

$stream = ssh2_shell($connection, 'vt102', null, 80, 24, SSH2_TERM_UNIT_CHARS);
?>

Viz také

ssh2_exec()
ssh2_tunnel()
ssh2_fetch_stream()

Předcházející | Nahoru | Další
ssh2_sftp | Domů | ssh2_tunnel


ssh2_tunnel

(PECL ssh2:0.10-0.9)

ssh2_tunnel — Open a tunnel through a remote server

Popis

resource ssh2_tunnel ( resource $session, string $host, int $port )

Open a socket stream to an arbitrary host/port by way of the currently connected SSH server.

Seznam parametrů

session

An SSH connection link identifier, obtained from a call to ssh2_connect().

host

port

Návratové hodnoty

Příklady

Příklad 2154. Opening a tunnel to an arbitrary host

<?php
$connection = ssh2_connect('shell.example.com', 22);
ssh2_auth_pubkey_file($connection, 'username', 'id_dsa.pub', 'id_dsa');

$tunnel = ssh2_tunnel($connection, '10.0.0.101', 12345);
?>

Viz také

ssh2_connect()
fsockopen()

Předcházející | Nahoru | Další
ssh2_shell | Domů | CLIX. Statistics Functions


stats_absolute_deviation

(PECL stats:1.0.0-1.0.2)

stats_absolute_deviation — Returns the absolute deviation of an array of values

Popis

float stats_absolute_deviation ( array $a )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

a

Návratové hodnoty

Předcházející | Nahoru | Další
CLIX. Statistics Functions | Domů | stats_cdf_beta


stats_cdf_beta

(PECL stats:1.0.0-1.0.2)

stats_cdf_beta — CDF function for BETA Distribution. Calculates any one parameter of the beta distribution given values for the others.

Popis

float stats_cdf_beta ( float $par1, float $par2, float $par3, int $which )

Method Cumulative distribution function (P) is calculated directly by code associated with the following reference. DiDinato, A. R. and Morris, A. H. Algorithm 708: Significant Digit Computation of the Incomplete Beta Function Ratios. ACM Trans. Math. Softw. 18 (1993), 360-373. Computation of other parameters involve a search for a value that produces the desired value of P. The search relies on the monotinicity of P with the other parameter. Note The beta density is proportional to t^(A-1) * (1-t)^(B-1) Arguments P -- The integral from 0 to X of the chi-square distribution. Input range: [0, 1]. Q -- 1-P. Input range: [0, 1]. P + Q = 1.0. X -- Upper limit of integration of beta density. Input range: [0,1]. Search range: [0,1] Y -- 1-X. Input range: [0,1]. Search range: [0,1] X + Y = 1.0. A -- The first parameter of the beta density. Input range: (0, +infinity). Search range: [1D-100,1D100] B -- The second parameter of the beta density. Input range: (0, +infinity). Search range: [1D-100,1D100] STATUS -- 0 if calculation completed correctly -I if input parameter number I is out of range 1 if answer appears to be lower than lowest search bound 2 if answer appears to be higher than greatest search bound 3 if P + Q .ne. 1 4 if X + Y .ne. 1 BOUND -- Undefined if STATUS is 0 Bound exceeded by parameter number I if STATUS is negative. Lower search bound if STATUS is 1. Upper search bound if STATUS is 2.

Seznam parametrů

par1

par2

par3

which

Integer indicating which of the next four argument values is to be calculated from the others. Legal range: 1..4 iwhich = 1 : Calculate P and Q from X,Y,A and B iwhich = 2 : Calculate X and Y from P,Q,A and B iwhich = 3 : Calculate A from P,Q,X,Y and B iwhich = 4 : Calculate B from P,Q,X,Y and A

Návratové hodnoty

STATUS -- 0 if calculation completed correctly -I if input parameter number I is out of range 1 if answer appears to be lower than lowest search bound 2 if answer appears to be higher than greatest search bound 3 if P + Q .ne. 1 4 if X + Y .ne. 1

Předcházející | Nahoru | Další
stats_absolute_deviation | Domů | stats_cdf_binomial


stats_cdf_binomial

(PECL stats:1.0.0-1.0.2)

stats_cdf_binomial — Calculates any one parameter of the binomial distribution given values for the others.

Popis

float stats_cdf_binomial ( float $par1, float $par2, float $par3, int $which )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

par1

par2

par3

which

Návratové hodnoty

Předcházející | Nahoru | Další
stats_cdf_beta | Domů | stats_cdf_cauchy


stats_cdf_cauchy

(PECL stats:1.0.0-1.0.2)

stats_cdf_cauchy — Not documented

Popis

float stats_cdf_cauchy ( float $par1, float $par2, float $par3, int $which )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

par1

par2

par3

which

Návratové hodnoty

Předcházející | Nahoru | Další
stats_cdf_binomial | Domů | stats_cdf_chisquare


stats_cdf_chisquare

(PECL stats:1.0.0-1.0.2)

stats_cdf_chisquare — Calculates any one parameter of the chi-square distribution given values for the others.

Popis

float stats_cdf_chisquare ( float $par1, float $par2, int $which )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

par1

par2

which

Návratové hodnoty

Předcházející | Nahoru | Další
stats_cdf_cauchy | Domů | stats_cdf_exponential


stats_cdf_exponential

(PECL stats:1.0.0-1.0.2)

stats_cdf_exponential — Not documented

Popis

float stats_cdf_exponential ( float $par1, float $par2, int $which )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

par1

par2

which

Návratové hodnoty

Předcházející | Nahoru | Další
stats_cdf_chisquare | Domů | stats_cdf_f


stats_cdf_f

(PECL stats:1.0.0-1.0.2)

stats_cdf_f — Calculates any one parameter of the F distribution given values for the others.

Popis

float stats_cdf_f ( float $par1, float $par2, float $par3, int $which )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

par1

par2

par3

which

Návratové hodnoty

Předcházející | Nahoru | Další
stats_cdf_exponential | Domů | stats_cdf_gamma


stats_cdf_gamma

(PECL stats:1.0.0-1.0.2)

stats_cdf_gamma — Calculates any one parameter of the gamma distribution given values for the others.

Popis

float stats_cdf_gamma ( float $par1, float $par2, float $par3, int $which )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

par1

par2

par3

which

Návratové hodnoty

Předcházející | Nahoru | Další
stats_cdf_f | Domů | stats_cdf_laplace


stats_cdf_laplace

(PECL stats:1.0.0-1.0.2)

stats_cdf_laplace — Not documented

Popis

float stats_cdf_laplace ( float $par1, float $par2, float $par3, int $which )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

par1

par2

par3

which

Návratové hodnoty

Předcházející | Nahoru | Další
stats_cdf_gamma | Domů | stats_cdf_logistic


stats_cdf_logistic

(PECL stats:1.0.0-1.0.2)

stats_cdf_logistic — Not documented

Popis

float stats_cdf_logistic ( float $par1, float $par2, float $par3, int $which )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

par1

par2

par3

which

Návratové hodnoty

Předcházející | Nahoru | Další
stats_cdf_laplace | Domů | stats_cdf_negative_binomial


stats_cdf_negative_binomial

(PECL stats:1.0.0-1.0.2)

stats_cdf_negative_binomial — Calculates any one parameter of the negative binomial distribution given values for the others.

Popis

float stats_cdf_negative_binomial ( float $par1, float $par2, float $par3, int $which )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

par1

par2

par3

which

Návratové hodnoty

Předcházející | Nahoru | Další
stats_cdf_logistic | Domů | stats_cdf_noncentral_chisquare


stats_cdf_noncentral_chisquare

(PECL stats:1.0.0-1.0.2)

stats_cdf_noncentral_chisquare — Calculates any one parameter of the non-central chi-square distribution given values for the others.

Popis

float stats_cdf_noncentral_chisquare ( float $par1, float $par2, float $par3, int $which )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

par1

par2

par3

which

Návratové hodnoty

Předcházející | Nahoru | Další
stats_cdf_negative_binomial | Domů | stats_cdf_noncentral_f


stats_cdf_noncentral_f

(PECL stats:1.0.0-1.0.2)

stats_cdf_noncentral_f — Calculates any one parameter of the Non-central F distribution given values for the others.

Popis

float stats_cdf_noncentral_f ( float $par1, float $par2, float $par3, float $par4, int $which )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

par1

par2

par3

par4

which

Návratové hodnoty

Předcházející | Nahoru | Další
stats_cdf_noncentral_chisquare | Domů | stats_cdf_poisson


stats_cdf_poisson

(PECL stats:1.0.0-1.0.2)

stats_cdf_poisson — Calculates any one parameter of the Poisson distribution given values for the others.

Popis

float stats_cdf_poisson ( float $par1, float $par2, int $which )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

par1

par2

which

Návratové hodnoty

Předcházející | Nahoru | Další
stats_cdf_noncentral_f | Domů | stats_cdf_t


stats_cdf_t

(PECL stats:1.0.0-1.0.2)

stats_cdf_t — Calculates any one parameter of the T distribution given values for the others.

Popis

float stats_cdf_t ( float $par1, float $par2, int $which )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

par1

par2

which

Návratové hodnoty

Předcházející | Nahoru | Další
stats_cdf_poisson | Domů | stats_cdf_uniform


stats_cdf_uniform

(PECL stats:1.0.0-1.0.2)

stats_cdf_uniform — Not documented

Popis

float stats_cdf_uniform ( float $par1, float $par2, float $par3, int $which )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

par1

par2

par3

which

Návratové hodnoty

Předcházející | Nahoru | Další
stats_cdf_t | Domů | stats_cdf_weibull


stats_cdf_weibull

(PECL stats:1.0.0-1.0.2)

stats_cdf_weibull — Not documented

Popis

float stats_cdf_weibull ( float $par1, float $par2, float $par3, int $which )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

par1

par2

par3

which

Návratové hodnoty

Předcházející | Nahoru | Další
stats_cdf_uniform | Domů | stats_covariance


stats_covariance

(PECL stats:1.0.0-1.0.2)

stats_covariance — Computes the covariance of two data sets

Popis

float stats_covariance ( array $a, array $b )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

a

b

Návratové hodnoty

Předcházející | Nahoru | Další
stats_cdf_weibull | Domů | stats_den_uniform


stats_den_uniform

(PECL stats:1.0.0-1.0.2)

stats_den_uniform — Not documented

Popis

float stats_den_uniform ( float $x, float $a, float $b )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

x

a

b

Návratové hodnoty

Předcházející | Nahoru | Další
stats_covariance | Domů | stats_dens_beta


stats_dens_beta

(PECL stats:1.0.0-1.0.2)

stats_dens_beta — Not documented

Popis

float stats_dens_beta ( float $x, float $a, float $b )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

x

a

b

Návratové hodnoty

Předcházející | Nahoru | Další
stats_den_uniform | Domů | stats_dens_cauchy


stats_dens_cauchy

(PECL stats:1.0.0-1.0.2)

stats_dens_cauchy — Not documented

Popis

float stats_dens_cauchy ( float $x, float $ave, float $stdev )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

x

ave

stdev

Návratové hodnoty

Předcházející | Nahoru | Další
stats_dens_beta | Domů | stats_dens_chisquare


stats_dens_chisquare

(PECL stats:1.0.0-1.0.2)

stats_dens_chisquare — Not documented

Popis

float stats_dens_chisquare ( float $x, float $dfr )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

x

dfr

Návratové hodnoty

Předcházející | Nahoru | Další
stats_dens_cauchy | Domů | stats_dens_exponential


stats_dens_exponential

(PECL stats:1.0.0-1.0.2)

stats_dens_exponential — Not documented

Popis

float stats_dens_exponential ( float $x, float $scale )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

x

scale

Návratové hodnoty

Předcházející | Nahoru | Další
stats_dens_chisquare | Domů | stats_dens_f


stats_dens_f

(PECL stats:1.0.0-1.0.2)

stats_dens_f

Popis

float stats_dens_f ( float $x, float $dfr1, float $dfr2 )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

x

dfr1

dfr2

Návratové hodnoty

Předcházející | Nahoru | Další
stats_dens_exponential | Domů | stats_dens_gamma


stats_dens_gamma

(PECL stats:1.0.0-1.0.2)

stats_dens_gamma — Not documented

Popis

float stats_dens_gamma ( float $x, float $shape, float $scale )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

x

shape

scale

Návratové hodnoty

Předcházející | Nahoru | Další
stats_dens_f | Domů | stats_dens_laplace


stats_dens_laplace

(PECL stats:1.0.0-1.0.2)

stats_dens_laplace — Not documented

Popis

float stats_dens_laplace ( float $x, float $ave, float $stdev )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

x

ave

stdev

Návratové hodnoty

Předcházející | Nahoru | Další
stats_dens_gamma | Domů | stats_dens_logistic


stats_dens_logistic

(PECL stats:1.0.0-1.0.2)

stats_dens_logistic — Not documented

Popis

float stats_dens_logistic ( float $x, float $ave, float $stdev )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

x

ave

stdev

Návratové hodnoty

Předcházející | Nahoru | Další
stats_dens_laplace | Domů | stats_dens_negative_binomial


stats_dens_negative_binomial

(PECL stats:1.0.0-1.0.2)

stats_dens_negative_binomial — Not documented

Popis

float stats_dens_negative_binomial ( float $x, float $n, float $pi )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

x

n

pi

Návratové hodnoty

Předcházející | Nahoru | Další
stats_dens_logistic | Domů | stats_dens_normal


stats_dens_normal

(PECL stats:1.0.0-1.0.2)

stats_dens_normal — Not documented

Popis

float stats_dens_normal ( float $x, float $ave, float $stdev )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

x

ave

stdev

Návratové hodnoty

Předcházející | Nahoru | Další
stats_dens_negative_binomial | Domů | stats_dens_pmf_binomial


stats_dens_pmf_binomial

(PECL stats:1.0.0-1.0.2)

stats_dens_pmf_binomial — Not documented

Popis

float stats_dens_pmf_binomial ( float $x, float $n, float $pi )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

x

n

pi

Návratové hodnoty

Předcházející | Nahoru | Další
stats_dens_normal | Domů | stats_dens_pmf_hypergeometric


stats_dens_pmf_hypergeometric

(PECL stats:1.0.0-1.0.2)

stats_dens_pmf_hypergeometric

Popis

float stats_dens_pmf_hypergeometric ( float $n1, float $n2, float $N1, float $N2 )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

n1

n2

N1

N2

Návratové hodnoty

Předcházející | Nahoru | Další
stats_dens_pmf_binomial | Domů | stats_dens_pmf_poisson


stats_dens_pmf_poisson

(PECL stats:1.0.0-1.0.2)

stats_dens_pmf_poisson — Not documented

Popis

float stats_dens_pmf_poisson ( float $x, float $lb )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

x

lb

Návratové hodnoty

Předcházející | Nahoru | Další
stats_dens_pmf_hypergeometric | Domů | stats_dens_t


stats_dens_t

(PECL stats:1.0.0-1.0.2)

stats_dens_t — Not documented

Popis

float stats_dens_t ( float $x, float $dfr )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

x

dfr

Návratové hodnoty

Předcházející | Nahoru | Další
stats_dens_pmf_poisson | Domů | stats_dens_weibull


stats_dens_weibull

(PECL stats:1.0.0-1.0.2)

stats_dens_weibull — Not documented

Popis

float stats_dens_weibull ( float $x, float $a, float $b )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

x

a

b

Návratové hodnoty

Předcházející | Nahoru | Další
stats_dens_t | Domů | stats_harmonic_mean


stats_harmonic_mean

(PECL stats:1.0.0-1.0.2)

stats_harmonic_mean — Returns the harmonic mean of an array of values

Popis

number stats_harmonic_mean ( array $a )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

a

Návratové hodnoty

Předcházející | Nahoru | Další
stats_dens_weibull | Domů | stats_kurtosis


stats_kurtosis

(PECL stats:1.0.0-1.0.2)

stats_kurtosis — Computes the kurtosis of the data in the array

Popis

float stats_kurtosis ( array $a )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

a

Návratové hodnoty

Předcházející | Nahoru | Další
stats_harmonic_mean | Domů | stats_rand_gen_beta


stats_rand_gen_beta

(PECL stats:1.0.0-1.0.2)

stats_rand_gen_beta — Generates beta random deviate

Popis

float stats_rand_gen_beta ( float $a, float $b )

Returns a random deviate from the beta distribution with parameters A and B. The density of the beta is x^(a-1) * (1-x)^(b-1) / B(a,b) for 0 < x <. Method R. C. H. Cheng.

Seznam parametrů

a

b

Návratové hodnoty

Předcházející | Nahoru | Další
stats_kurtosis | Domů | stats_rand_gen_chisquare


stats_rand_gen_chisquare

(PECL stats:1.0.0-1.0.2)

stats_rand_gen_chisquare — Generates random deviate from the distribution of a chisquare with "df" degrees of freedom random variable.

Popis

float stats_rand_gen_chisquare ( float $df )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

df

Návratové hodnoty

Předcházející | Nahoru | Další
stats_rand_gen_beta | Domů | stats_rand_gen_exponential


stats_rand_gen_exponential

(PECL stats:1.0.0-1.0.2)

stats_rand_gen_exponential — Generates a single random deviate from an exponential distribution with mean "av"

Popis

float stats_rand_gen_exponential ( float $av )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

av

Návratové hodnoty

Předcházející | Nahoru | Další
stats_rand_gen_chisquare | Domů | stats_rand_gen_f


stats_rand_gen_f

(PECL stats:1.0.0-1.0.2)

stats_rand_gen_f — Generates a random deviate

Popis

float stats_rand_gen_f ( float $dfn, float $dfd )

Generates a random deviate from the F (variance ratio) distribution with "dfn" degrees of freedom in the numerator and "dfd" degrees of freedom in the denominator. Method : directly generates ratio of chisquare variates.

Seznam parametrů

dfn

dfd

Návratové hodnoty

Předcházející | Nahoru | Další
stats_rand_gen_exponential | Domů | stats_rand_gen_funiform


stats_rand_gen_funiform

(PECL stats:1.0.0-1.0.2)

stats_rand_gen_funiform — Generates uniform float between low (exclusive) and high (exclusive)

Popis

float stats_rand_gen_funiform ( float $low, float $high )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

low

high

Návratové hodnoty

Předcházející | Nahoru | Další
stats_rand_gen_f | Domů | stats_rand_gen_gamma


stats_rand_gen_gamma

(PECL stats:1.0.0-1.0.2)

stats_rand_gen_gamma — Generates random deviates from a gamma distribution

Popis

float stats_rand_gen_gamma ( float $a, float $r )

Generates random deviates from the gamma distribution whose density is (A**R)/Gamma(R) * X**(R-1) * Exp(-A*X).

Seznam parametrů

a

location parameter of Gamma distribution (a > 0).

r

shape parameter of Gamma distribution (r > 0).

Návratové hodnoty

Předcházející | Nahoru | Další
stats_rand_gen_funiform | Domů | stats_rand_gen_ibinomial_negative


stats_rand_gen_ibinomial

(PECL stats:1.0.0-1.0.2)

stats_rand_gen_ibinomial — Generates a single random deviate from a binomial distribution whose number of trials is "n" (n >= 0) and whose probability of an event in each trial is "pp" ([0;1]). Method : algorithm BTPE

Popis

int stats_rand_gen_ibinomial ( int $n, float $pp )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

n

pp

Návratové hodnoty

Předcházející | Nahoru | Další
stats_rand_gen_ibinomial_negative | Domů | stats_rand_gen_int


stats_rand_gen_ibinomial_negative

(PECL stats:1.0.0-1.0.2)

stats_rand_gen_ibinomial_negative — Generates a single random deviate from a negative binomial distribution. Arguments : n - the number of trials in the negative binomial distribution from which a random deviate is to be generated (n > 0), p - the probability of an event (0 < p < 1)).

Popis

int stats_rand_gen_ibinomial_negative ( int $n, float $p )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

n

p

Návratové hodnoty

Předcházející | Nahoru | Další
stats_rand_gen_gamma | Domů | stats_rand_gen_ibinomial


stats_rand_gen_int

(PECL stats:1.0.0-1.0.2)

stats_rand_gen_int — Generates random integer between 1 and 2147483562

Popis

int stats_rand_gen_int ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

Návratové hodnoty

Předcházející | Nahoru | Další
stats_rand_gen_ibinomial | Domů | stats_rand_gen_ipoisson


stats_rand_gen_ipoisson

(PECL stats:1.0.0-1.0.2)

stats_rand_gen_ipoisson — Generates a single random deviate from a Poisson distribution with mean "mu" (mu >= 0.0).

Popis

int stats_rand_gen_ipoisson ( float $mu )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

mu

Návratové hodnoty

Předcházející | Nahoru | Další
stats_rand_gen_int | Domů | stats_rand_gen_iuniform


stats_rand_gen_iuniform

(PECL stats:1.0.0-1.0.2)

stats_rand_gen_iuniform — Generates integer uniformly distributed between LOW (inclusive) and HIGH (inclusive)

Popis

int stats_rand_gen_iuniform ( int $low, int $high )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

low

high

Návratové hodnoty

Předcházející | Nahoru | Další
stats_rand_gen_ipoisson | Domů | stats_rand_gen_noncenral_chisquare


stats_rand_gen_noncenral_chisquare

(PECL stats:1.0.0-1.0.2)

stats_rand_gen_noncenral_chisquare — Generates random deviate from the distribution of a noncentral chisquare with "df" degrees of freedom and noncentrality parameter "xnonc". d must be >= 1.0, xnonc must >= 0.0

Popis

float stats_rand_gen_noncenral_chisquare ( float $df, float $xnonc )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

df

xnonc

Návratové hodnoty

Předcházející | Nahoru | Další
stats_rand_gen_iuniform | Domů | stats_rand_gen_noncentral_f


stats_rand_gen_noncentral_f

(PECL stats:1.0.0-1.0.2)

stats_rand_gen_noncentral_f — Generates a random deviate from the noncentral F (variance ratio) distribution with "dfn" degrees of freedom in the numerator, and "dfd" degrees of freedom in the denominator, and noncentrality parameter "xnonc". Method : directly generates ratio of noncentral numerator chisquare variate to central denominator chisquare variate.

Popis

float stats_rand_gen_noncentral_f ( float $dfn, float $dfd, float $xnonc )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

dfn

dfd

xnonc

Návratové hodnoty

Předcházející | Nahoru | Další
stats_rand_gen_noncenral_chisquare | Domů | stats_rand_gen_noncentral_t


stats_rand_gen_noncentral_t

(PECL stats:1.0.0-1.0.2)

stats_rand_gen_noncentral_t — Generates a single random deviate from a noncentral T distribution

Popis

float stats_rand_gen_noncentral_t ( float $df, float $xnonc )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

df

xnonc

Návratové hodnoty

Předcházející | Nahoru | Další
stats_rand_gen_noncentral_f | Domů | stats_rand_gen_normal


stats_rand_gen_normal

(PECL stats:1.0.0-1.0.2)

stats_rand_gen_normal — Generates a single random deviate from a normal distribution with mean, av, and standard deviation, sd (sd >= 0). Method : Renames SNORM from TOMS as slightly modified by BWB to use RANF instead of SUNIF.

Popis

float stats_rand_gen_normal ( float $av, float $sd )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

av

sd

Návratové hodnoty

Předcházející | Nahoru | Další
stats_rand_gen_noncentral_t | Domů | stats_rand_gen_t


stats_rand_gen_t

(PECL stats:1.0.0-1.0.2)

stats_rand_gen_t — Generates a single random deviate from a T distribution

Popis

float stats_rand_gen_t ( float $df )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

df

Návratové hodnoty

Předcházející | Nahoru | Další
stats_rand_gen_normal | Domů | stats_rand_get_seeds


stats_rand_get_seeds

(PECL stats:1.0.0-1.0.2)

stats_rand_get_seeds — Not documented

Popis

array stats_rand_get_seeds ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

Návratové hodnoty

Předcházející | Nahoru | Další
stats_rand_gen_t | Domů | stats_rand_phrase_to_seeds


stats_rand_phrase_to_seeds

(PECL stats:1.0.0-1.0.2)

stats_rand_phrase_to_seeds — generate two seeds for the RGN random number generator

Popis

array stats_rand_phrase_to_seeds ( string $phrase )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

phrase

Návratové hodnoty

Předcházející | Nahoru | Další
stats_rand_get_seeds | Domů | stats_rand_ranf


stats_rand_ranf

(PECL stats:1.0.0-1.0.2)

stats_rand_ranf — Returns a random floating point number from a uniform distribution over 0 - 1 (endpoints of this interval are not returned) using the current generator

Popis

float stats_rand_ranf ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

Návratové hodnoty

Předcházející | Nahoru | Další
stats_rand_phrase_to_seeds | Domů | stats_rand_setall


stats_rand_setall

(PECL stats:1.0.0-1.0.2)

stats_rand_setall — Not documented

Popis

void stats_rand_setall ( int $iseed1, int $iseed2 )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

iseed1

iseed2

Návratové hodnoty

Předcházející | Nahoru | Další
stats_rand_ranf | Domů | stats_skew


stats_skew

(PECL stats:1.0.0-1.0.2)

stats_skew — Computes the skewness of the data in the array

Popis

float stats_skew ( array $a )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

a

Návratové hodnoty

Předcházející | Nahoru | Další
stats_rand_setall | Domů | stats_standard_deviation


stats_standard_deviation

(PECL stats:1.0.0-1.0.2)

stats_standard_deviation — Returns the standard deviation

Popis

float stats_standard_deviation ( array $a [, bool $sample] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

a

sample

Návratové hodnoty

Předcházející | Nahoru | Další
stats_skew | Domů | stats_stat_binomial_coef


stats_stat_binomial_coef

(PECL stats:1.0.0-1.0.2)

stats_stat_binomial_coef — Not documented

Popis

float stats_stat_binomial_coef ( int $x, int $n )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

x

n

Návratové hodnoty

Předcházející | Nahoru | Další
stats_standard_deviation | Domů | stats_stat_correlation


stats_stat_correlation

(PECL stats:1.0.0-1.0.2)

stats_stat_correlation — Not documented

Popis

float stats_stat_correlation ( array $arr1, array $arr2 )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

arr1

arr2

Návratové hodnoty

Předcházející | Nahoru | Další
stats_stat_binomial_coef | Domů | stats_stat_gennch


stats_stat_gennch

(PECL stats:1.0.0-1.0.2)

stats_stat_gennch — Not documented

Popis

float stats_stat_gennch ( int $n )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

n

Návratové hodnoty

Předcházející | Nahoru | Další
stats_stat_correlation | Domů | stats_stat_independent_t


stats_stat_independent_t

(PECL stats:1.0.0-1.0.2)

stats_stat_independent_t — Not documented

Popis

float stats_stat_independent_t ( array $arr1, array $arr2 )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

arr1

arr2

Návratové hodnoty

Předcházející | Nahoru | Další
stats_stat_gennch | Domů | stats_stat_innerproduct


stats_stat_innerproduct

(PECL stats:1.0.0-1.0.2)

stats_stat_innerproduct

Popis

float stats_stat_innerproduct ( array $arr1, array $arr2 )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

arr1

arr2

Návratové hodnoty

Předcházející | Nahoru | Další
stats_stat_independent_t | Domů | stats_stat_noncentral_t


stats_stat_noncentral_t

(PECL stats:1.0.0-1.0.2)

stats_stat_noncentral_t — Calculates any one parameter of the noncentral t distribution give values for the others.

Popis

float stats_stat_noncentral_t ( float $par1, float $par2, float $par3, int $which )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

par1

par2

par3

which

Návratové hodnoty

Předcházející | Nahoru | Další
stats_stat_innerproduct | Domů | stats_stat_paired_t


stats_stat_paired_t

(PECL stats:1.0.0-1.0.2)

stats_stat_paired_t — Not documented

Popis

float stats_stat_paired_t ( array $arr1, array $arr2 )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

arr1

arr2

Návratové hodnoty

Předcházející | Nahoru | Další
stats_stat_noncentral_t | Domů | stats_stat_percentile


stats_stat_percentile

(PECL stats:1.0.0-1.0.2)

stats_stat_percentile — Not documented

Popis

float stats_stat_percentile ( float $df, float $xnonc )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

df

xnonc

Návratové hodnoty

Předcházející | Nahoru | Další
stats_stat_paired_t | Domů | stats_stat_powersum


stats_stat_powersum

(PECL stats:1.0.0-1.0.2)

stats_stat_powersum — Not documented

Popis

float stats_stat_powersum ( array $arr, float $power )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

arr

power

Návratové hodnoty

Předcházející | Nahoru | Další
stats_stat_percentile | Domů | stats_variance


stats_variance

(PECL stats:1.0.0-1.0.2)

stats_variance — Returns the population variance

Popis

float stats_variance ( array $a [, bool $sample] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

a

sample

Návratové hodnoty

Předcházející | Nahoru | Další
stats_stat_powersum | Domů | CLX. Stream Functions


str_getcsv

(No version information available, might be only in CVS)

str_getcsv — Parse a CSV string into an array

Popis

array str_getcsv ( string $input [, string $delimiter [, string $enclosure [, string $escape]]] )

Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Viz také

fgetcsv()

Předcházející | Nahoru | Další
sscanf | Domů | str_ireplace


stream_bucket_append

(PHP 5)

stream_bucket_append — Append bucket to brigade

Popis

void stream_bucket_append ( resource $brigade, resource $bucket )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
CLX. Stream Functions | Domů | stream_bucket_make_writeable


stream_bucket_make_writeable

(PHP 5)

stream_bucket_make_writeable — Return a bucket object from the brigade for operating on

Popis

object stream_bucket_make_writeable ( resource $brigade )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
stream_bucket_append | Domů | stream_bucket_new


stream_bucket_new

(PHP 5)

stream_bucket_new — Create a new bucket for use on the current stream

Popis

object stream_bucket_new ( resource $stream, string $buffer )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
stream_bucket_make_writeable | Domů | stream_bucket_prepend


stream_bucket_prepend

(PHP 5)

stream_bucket_prepend — Prepend bucket to brigade

Popis

void stream_bucket_prepend ( resource $brigade, resource $bucket )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
stream_bucket_new | Domů | stream_context_create


stream_encoding

(No version information available, might be only in CVS)

stream_encoding — Set character set for stream encoding

Popis

bool stream_encoding ( resource $stream [, string $encoding] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
stream_copy_to_stream | Domů | stream_filter_append


stream_resolve_include_path

(No version information available, might be only in CVS)

stream_resolve_include_path — Determine what file will be opened by calls to fopen() with a relative path

Popis

string stream_resolve_include_path ( string $filename [, resource $context] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
stream_register_wrapper | Domů | stream_select


stream_socket_pair

(PHP 5 >= 5.1.0)

stream_socket_pair — Creates a pair of connected, indistinguishable socket streams

Popis

array stream_socket_pair ( int $domain, int $type, int $protocol )

stream_socket_pair() creates a pair of connected, indistinguishable socket streams. This function is commonly used in IPC (Inter-Process Communication).

Seznam parametrů

domain

The protocol family to be used: STREAM_PF_INET, STREAM_PF_INET6 or STREAM_PF_UNIX

type

The type of communication to be used: STREAM_SOCK_DGRAM, STREAM_SOCK_RAW, STREAM_SOCK_RDM, STREAM_SOCK_SEQPACKET or STREAM_SOCK_STREAM

protocol

The protocol to be used: STREAM_IPPROTO_ICMP, STREAM_IPPROTO_IP, STREAM_IPPROTO_RAW, STREAM_IPPROTO_TCP or STREAM_IPPROTO_UDP

Poznámka: Please consult the Streams constant list for further details on each constant.

Návratové hodnoty

Returns an array with the two socket resources on success, or FALSE on failure.

Příklady

Příklad 2175. A stream_socket_pair() example

This example shows the basic usage of stream_socket_pair() in Inter-Process Comunication.

<?php

$sockets = stream_socket_pair(STREAM_PF_UNIX, STREAM_SOCK_STREAM, STREAM_IPPROTO_IP);
$pid     = pcntl_fork();

if ($pid == -1) {
     die('could not fork');

} else if ($pid) {
     /* parent */
    fclose($sockets[0]);

    fwrite($sockets[1], "child PID: $pid\n");
    echo fgets($sockets[1]);

    fclose($sockets[1]);

} else {
    /* child */
    fclose($sockets[1]);

    fwrite($sockets[0], "message from child\n");
    echo fgets($sockets[0]);

    fclose($sockets[0]);
}

?>

Výše uvedený příklad vypíše něco jako:

child PID: 1378
message from child

Předcházející | Nahoru | Další
stream_socket_get_name | Domů | stream_socket_recvfrom


stream_socket_shutdown

(PHP 5 >= 5.2.1)

stream_socket_shutdown — Shutdown a full-duplex connection

Popis

bool stream_socket_shutdown ( resource $stream, int $how )

Shutdowns (partially or not) a full-duplex connection.

Seznam parametrů

stream

An open stream (opened with stream_socket_client(), for example)

how

One of the following constants: STREAM_SHUT_RD (disable further receptions), STREAM_SHUT_WR (disable further transmissions) or STREAM_SHUT_RDWR (disable further receptions and transmissions).

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 2180. A stream_socket_shutdown() example

<?php

$server = stream_socket_server('tcp://127.0.0.1:1337');
$client = stream_socket_client('tcp://127.0.0.1:1337');

var_dump(fputs($client, "hello"));

stream_socket_shutdown($client, STREAM_SHUT_WR);
var_dump(fputs($client, "hello")); // doesn't work now

?>

Výše uvedený příklad vypíše něco jako:

int(5)

Notice: fputs(): send of 5 bytes failed with errno=32 Broken pipe in test.php on line 9
int(0)

Viz také

fclose()

Předcházející | Nahoru | Další
stream_socket_server | Domů | stream_wrapper_register


svn_add

(PECL svn:0.1-0.2)

svn_add — Schedules the addition of an item in a working directory

Popis

bool svn_add ( string $path [, bool $recursive [, bool $force]] )

Adds the file, directory or symbolic link at path to the working directory. The item will be added to the repository the next time you call svn_commit() on the working copy.

Seznam parametrů

path

Path of item to add.

Poznámka: Relative paths will be resolved as if the current working directory was the one that contains the PHP binary. To use the calling script's working directory, use realpath() or dirname(__FILE__).

recursive

If item is directory, whether or not to recursively add all of its contents. Default is TRUE

force

If true, Subversion will recurse into already versioned directories in order to add unversioned files that may be hiding in those directories. Default is FALSE

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Příklady

Příklad 2249. svn_add() example

In a working directory where svn status returns:

$ svn status
?      foobar.txt

...this code:

<?php
svn_add('foobar.txt');
?>

...will schedule foobar.txt for addition into the repository.

Viz také

» SVN documentation on svn add

Předcházející | Nahoru | Další
CLXII. Subversion Funkce | Domů | svn_auth_get_parameter


svn_auth_get_parameter

(PECL svn:0.1-0.2)

svn_auth_get_parameter — Retrieves authentication parameter

Popis

string svn_auth_get_parameter ( string $key )

Retrieves authentication parameter at key. For a list of valid keys and their meanings, consult the authentication constants list.

Seznam parametrů

key

String key name. Use the authentication constants defined by this extension to specify a key.

Návratové hodnoty

Returns the string value of the parameter at key; returns NULL if parameter does not exist.

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Viz také

svn_auth_set_parameter()
Authentication constants

Předcházející | Nahoru | Další
svn_add | Domů | svn_auth_set_parameter


svn_auth_set_parameter

(PECL svn:0.1-0.2)

svn_auth_set_parameter — Sets an authentication parameter

Popis

void svn_auth_set_parameter ( string $key, string $value )

Sets authentication parameter at key to value. For a list of valid keys and their meanings, consult the authentication constants list.

Seznam parametrů

key

String key name. Use the authentication constants defined by this extension to specify a key.

value

String value to set to parameter at key. Format of value varies with the parameter.

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Příklady

Příklad 2250. Default authentication example

This example configures SVN so that the default username to use is 'Bob' and the default password is 'abc123':

<?php
svn_auth_set_parameter(SVN_AUTH_PARAM_DEFAULT_USERNAME, 'Bob');
svn_auth_set_parameter(SVN_AUTH_PARAM_DEFAULT_PASSWORD, 'abc123');
?>

Viz také

svn_auth_get_parameter()
Authentication constants

Předcházející | Nahoru | Další
svn_auth_get_parameter | Domů | svn_cat


svn_cat

(PECL svn:0.1-0.2)

svn_cat — Returns the contents of a file in a repository

Popis

string svn_cat ( string $repos_url [, int $revision_no] )

Returns the contents of the URL repos_url to a file in the repository, optionally at revision number revision_no.

Seznam parametrů

repos_url

String URL path to item in a repository.

revision_no

Integer revision number of item to retrieve, default is the HEAD revision.

Návratové hodnoty

Returns the string contents of the item from the repository on success, and FALSE on failure.

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Příklady

Příklad 2251. Basic example

This example retrieves the contents of a file at revision 28:

<?php
$contents = svn_cat('http://www.example.com/svnroot/calc/gui.c', 28)
?>

Viz také

svn_list()
» SVN documentation on svn cat

Předcházející | Nahoru | Další
svn_auth_set_parameter | Domů | svn_checkout


svn_checkout

(PECL svn:0.1-0.2)

svn_checkout — Checks out a working copy from the repository

Popis

bool svn_checkout ( string $repos, string $targetpath [, int $revision] )

Checks out a working copy from the repository at repos to targetpath at revision revision.

Seznam parametrů

repos

String URL path to directory in repository to check out.

targetpath

String local path to directory to check out in to

Poznámka: Relative paths will be resolved as if the current working directory was the one that contains the PHP binary. To use the calling script's working directory, use realpath() or dirname(__FILE__).

revision

Integer revision number of repository to check out. Default is HEAD, the most recent revision.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Příklady

Příklad 2252. Basic example

This example demonstrates how to check out a directory from a repository to a directory named calc:

<?php
svn_checkout('http://www.example.com/svnroot/calc/trunk', dirname(__FILE__) . '/calc');
?>

The dirname(__FILE__) call is necessary in order to convert the calc relative path into an absolute one. If calc exists, you can also use realpath() to retrieve an absolute path.

Viz také

svn_add()
svn_commit()
svn_status()
svn_update()
» SVN documentation on svn checkout

Předcházející | Nahoru | Další
svn_cat | Domů | svn_cleanup


svn_cleanup

(PECL svn:0.1-0.2)

svn_cleanup — Recursively cleanup a working copy directory, finishing incomplete operations and removing locks

Popis

bool svn_cleanup ( string $workingdir )

Recursively cleanup working copy directory workingdir, finishing any incomplete operations and removing working copy locks. Use when a working copy is in limbo and needs to be usable again.

Seznam parametrů

workingdir

String path to local working directory to cleanup

Poznámka: Relative paths will be resolved as if the current working directory was the one that contains the PHP binary. To use the calling script's working directory, use realpath() or dirname(__FILE__).

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Příklady

Příklad 2253. Basic example

This example demonstrates clean up of a working copy in a directory named help-me:

<?php
svn_cleanup(realpath('help-me'));
?>

The realpath() call is necessary due to SVN's quirky handling of relative paths.

Viz také

update()
» SVN documentation on svn cleanup

Předcházející | Nahoru | Další
svn_checkout | Domů | svn_client_version


svn_client_version

(PECL svn:0.1-0.2)

svn_client_version — Returns the version of the SVN client libraries

Popis

string svn_client_version ( void )

Returns the version of the SVN client libraries

Návratové hodnoty

String version number, usually in form of x.y.z.

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Příklady

Příklad 2254. Basic example

<?php
echo svn_client_version();
?>

Výše uvedený příklad vypíše něco jako:

1.3.1

Předcházející | Nahoru | Další
svn_cleanup | Domů | svn_commit


svn_commit

(PECL svn:0.1-0.2)

svn_commit — Sends changes from the local working copy to the repository

Popis

array svn_commit ( string $log, array $targets [, bool $dontrecurse] )

Commits changes made in the local working copy files enumerated in the targets array to the repository, with the log message log. Directories in the targets array will be recursively committed unless dontrecurse is set to true.

Poznámka: This function does not have any parameters for specifying authentication, so a username and password must be set using svn_auth_set_parameter()

Seznam parametrů

log

String log text to commit

targets

Array of local paths of files to be committed

Varování

This parameter must be an array, a string for a single target is not acceptable.

Poznámka: Relative paths will be resolved as if the current working directory was the one that contains the PHP binary. To use the calling script's working directory, use realpath() or dirname(__FILE__).

dontrecurse

Boolean flag to disable recursive committing of directories in the targets array. Default is FALSE.

Návratové hodnoty

Returns array in form of:

array(
    0 => integer revision number of commit
    1 => string ISO 8601 date and time of commit
    2 => name of committer
)

Returns FALSE on failure.

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Příklady

Příklad 2255. Basic example

This example commits the calculator directory to a repository, using the username Bob and the password abc123 (hopefully, his password is stronger):

<?php
svn_auth_set_parameter(SVN_AUTH_PARAM_DEFAULT_USERNAME, 'Bob');
svn_auth_set_parameter(SVN_AUTH_PARAM_DEFAULT_PASSWORD, 'abc123');
var_dump(svn_commit('Log message of Bob\'s commit', array(realpath('calculator'))));
?>

Výše uvedený příklad vypíše:

array(
  0 => 1415,
  1 => '2007-05-26T01:44:28.453125Z',
  2 => 'Bob'
)

Viz také

svn_auth_set_parameter()
» SVN documentation on svn commit

Předcházející | Nahoru | Další
svn_client_version | Domů | svn_diff


svn_diff

(PECL svn:0.1-0.2)

svn_diff — Recursively diffs two paths

Popis

array svn_diff ( string $path1, int $rev1, string $path2, int $rev2 )

Recursively diffs two paths, path1 and path2.

Poznámka: This is not a general-purpose diff utility. Only local files that are versioned may be diffed: other files will fail.

Seznam parametrů

path1

First path to diff. This can be a URL to a file/directory in an SVN repository or a local file/directory path.

Poznámka: Relative paths will be resolved as if the current working directory was the one that contains the PHP binary. To use the calling script's working directory, use realpath() or dirname(__FILE__).

Varování

If a local file path has only backslashes and no forward slashes, this extension will fail to find the path. Always replace all backslashes with forward slashes when using this function.

rev1

First path's revision number. Use SVN_REVISON_HEAD to specify the most recent revision.

path2

Second path to diff. See path1 for description.

rev2

Second path's revision number. See rev2 for description.

Návratové hodnoty

Returns an array-list consisting of two streams: the first is the diff output and the second contains error stream output. The streams can be read using fread(). Returns FALSE or NULL on error.

The diff output will, by default, be in the form of Subversion's custom unified diff format, but an » external diff engine may be used depending on Subversion's configuration.

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Příklady

Příklad 2256. Basic example

This example demonstrates the basic usage of this function, and the retrieval of contents from the stream:

<?php
list($diff, $errors) = svn_diff(
    'http://www.example.com/svnroot/trunk/foo', SVN_REVISION_HEAD,
    'http://www.example.com/svnroot/branches/dev/foo', SVN_REVISION_HEAD
);
if (!$diff) exit;
$contents = '';
while (!feof($diff)) {
  $contents .= fread($diff, 8192);
}
fclose($diff);
fclose($errors);
var_dump($contents);
?>

Výše uvedený příklad vypíše:

Index: http://www.example.com/svnroot/trunk/foo
===================================================================
--- http://www.example.com/svnroot/trunk/foo        (.../foo) (revision 23)
+++ http://www.example.com/svnroot/branches/dev/foo (.../foo) (revision 27)
 // further diff output

Příklad 2257. Diffing two revisions of a repository path

This example implements a wrapper function that allows a user to easily diff two revisions of the same item using an external repository path (the default syntax is somewhat verbose):

<?php
function svn_diff_same_item($path, $rev1, $rev2) {
    return svn_diff($path, $rev1, $path, $rev2);
}
?>

Příklad 2258. Portably diffing two local files

This example implements a wrapper function that portably diffs two local files, compensating for the realpath() fix and the backslashes bug:

<?php
function svn_diff_local($path1, $rev1, $path2, $rev2) {
    $path1 = str_replace('\\', '/', realpath($path1));
    $path2 = str_replace('\\', '/', realpath($path2));
    return svn_diff($path1, $rev1, $path2, $rev2);
}
?>

Viz také

» SVN documentation on svn diff

Předcházející | Nahoru | Další
svn_commit | Domů | svn_fs_abort_txn


svn_fs_abort_txn

(PECL svn:0.2)

svn_fs_abort_txn — Abort a transaction, returns true if everything is ok, false othewise

Popis

bool svn_fs_abort_txn ( resource $txn )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Abort a transaction, returns true if everything is ok, false othewise

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
svn_diff | Domů | svn_fs_apply_text


svn_fs_apply_text

(PECL svn:0.2)

svn_fs_apply_text — Creates and returns a stream that will be used to replace

Popis

resource svn_fs_apply_text ( resource $root, string $path )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Creates and returns a stream that will be used to replace

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
svn_fs_abort_txn | Domů | svn_fs_begin_txn2


svn_fs_begin_txn2

(PECL svn:0.2)

svn_fs_begin_txn2 — Create a new transaction

Popis

resource svn_fs_begin_txn2 ( resource $repos, int $rev )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Create a new transaction

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
svn_fs_apply_text | Domů | svn_fs_change_node_prop


svn_fs_change_node_prop

(PECL svn:0.2)

svn_fs_change_node_prop — Return true if everything is ok, false otherwise

Popis

bool svn_fs_change_node_prop ( resource $root, string $path, string $name, string $value )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Return true if everything is ok, false otherwise

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
svn_fs_begin_txn2 | Domů | svn_fs_check_path


svn_fs_check_path

(PECL svn:0.1-0.2)

svn_fs_check_path — Determines what kind of item lives at path in a given repository fsroot

Popis

int svn_fs_check_path ( resource $fsroot, string $path )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Determines what kind of item lives at path in a given repository fsroot

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
svn_fs_change_node_prop | Domů | svn_fs_contents_changed


svn_fs_contents_changed

(PECL svn:0.2)

svn_fs_contents_changed — Return true if content is different, false otherwise

Popis

bool svn_fs_contents_changed ( resource $root1, string $path1, resource $root2, string $path2 )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Return true if content is different, false otherwise

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
svn_fs_check_path | Domů | svn_fs_copy


svn_fs_copy

(PECL svn:0.2)

svn_fs_copy — Copies a file or a directory, returns true if all is ok, false otherwise

Popis

bool svn_fs_copy ( resource $from_root, string $from_path, resource $to_root, string $to_path )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Copies a file or a directory, returns true if all is ok, false otherwise

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
svn_fs_contents_changed | Domů | svn_fs_delete


svn_fs_delete

(PECL svn:0.2)

svn_fs_delete — Deletes a file or a directory, return true if all is ok, false otherwise

Popis

bool svn_fs_delete ( resource $root, string $path )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Deletes a file or a directory, return true if all is ok, false otherwise

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
svn_fs_copy | Domů | svn_fs_dir_entries


svn_fs_dir_entries

(PECL svn:0.1-0.2)

svn_fs_dir_entries — Enumerates the directory entries under path; returns a hash of dir names to file type

Popis

array svn_fs_dir_entries ( resource $fsroot, string $path )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Enumerates the directory entries under path; returns a hash of dir names to file type

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
svn_fs_delete | Domů | svn_fs_file_contents


svn_fs_file_contents

(PECL svn:0.1-0.2)

svn_fs_file_contents — Returns a stream to access the contents of a file from a given version of the fs

Popis

resource svn_fs_file_contents ( resource $fsroot, string $path )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Returns a stream to access the contents of a file from a given version of the fs

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
svn_fs_dir_entries | Domů | svn_fs_file_length


svn_fs_file_length

(PECL svn:0.1-0.2)

svn_fs_file_length — Returns the length of a file from a given version of the fs

Popis

int svn_fs_file_length ( resource $fsroot, string $path )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Returns the length of a file from a given version of the fs

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
svn_fs_file_contents | Domů | svn_fs_is_dir


svn_fs_is_dir

(PECL svn:0.2)

svn_fs_is_dir — Return true if the path points to a directory, false otherwise

Popis

bool svn_fs_is_dir ( resource $root, string $path )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Return true if the path points to a directory, false otherwise

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
svn_fs_file_length | Domů | svn_fs_is_file


svn_fs_is_file

(PECL svn:0.2)

svn_fs_is_file — Return true if the path points to a file, false otherwise

Popis

bool svn_fs_is_file ( resource $root, string $path )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Return true if the path points to a file, false otherwise

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
svn_fs_is_dir | Domů | svn_fs_make_dir


svn_fs_make_dir

(PECL svn:0.2)

svn_fs_make_dir — Creates a new empty directory, returns true if all is ok, false otherwise

Popis

bool svn_fs_make_dir ( resource $root, string $path )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Creates a new empty directory, returns true if all is ok, false otherwise

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
svn_fs_is_file | Domů | svn_fs_make_file


svn_fs_make_file

(PECL svn:0.2)

svn_fs_make_file — Creates a new empty file, returns true if all is ok, false otherwise

Popis

bool svn_fs_make_file ( resource $root, string $path )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Creates a new empty file, returns true if all is ok, false otherwise

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
svn_fs_make_dir | Domů | svn_fs_node_created_rev


svn_fs_node_created_rev

(PECL svn:0.1-0.2)

svn_fs_node_created_rev — Returns the revision in which path under fsroot was created

Popis

int svn_fs_node_created_rev ( resource $fsroot, string $path )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Returns the revision in which path under fsroot was created

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
svn_fs_make_file | Domů | svn_fs_node_prop


svn_fs_node_prop

(PECL svn:0.1-0.2)

svn_fs_node_prop — Returns the value of a property for a node

Popis

string svn_fs_node_prop ( resource $fsroot, string $path, string $propname )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Returns the value of a property for a node

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
svn_fs_node_created_rev | Domů | svn_fs_props_changed


svn_fs_props_changed

(PECL svn:0.2)

svn_fs_props_changed — Return true if props are different, false otherwise

Popis

bool svn_fs_props_changed ( resource $root1, string $path1, resource $root2, string $path2 )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Return true if props are different, false otherwise

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
svn_fs_node_prop | Domů | svn_fs_revision_prop


svn_fs_revision_prop

(PECL svn:0.1-0.2)

svn_fs_revision_prop — Fetches the value of a named property

Popis

string svn_fs_revision_prop ( resource $fs, int $revnum, string $propname )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Fetches the value of a named property

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
svn_fs_props_changed | Domů | svn_fs_revision_root


svn_fs_revision_root

(PECL svn:0.1-0.2)

svn_fs_revision_root — Get a handle on a specific version of the repository root

Popis

resource svn_fs_revision_root ( resource $fs, int $revnum )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Get a handle on a specific version of the repository root

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
svn_fs_revision_prop | Domů | svn_fs_txn_root


svn_fs_txn_root

(PECL svn:0.2)

svn_fs_txn_root — Creates and returns a transaction root

Popis

resource svn_fs_txn_root ( resource $txn )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Creates and returns a transaction root

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
svn_fs_revision_root | Domů | svn_fs_youngest_rev


svn_fs_youngest_rev

(PECL svn:0.1-0.2)

svn_fs_youngest_rev — Returns the number of the youngest revision in the filesystem

Popis

int svn_fs_youngest_rev ( resource $fs )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Returns the number of the youngest revision in the filesystem

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
svn_fs_txn_root | Domů | svn_import


svn_import

(PECL svn:0.2)

svn_import — Imports an unversioned path into a repository

Popis

bool svn_import ( string $path, string $url, bool $nonrecursive )

Commits unversioned path into repository at url. If path is a directory and nonrecursive is FALSE, the directory will be imported recursively.

Seznam parametrů

path

Path of file or directory to import.

Poznámka: Relative paths will be resolved as if the current working directory was the one that contains the PHP binary. To use the calling script's working directory, use realpath() or dirname(__FILE__).

url

Repository URL to import into.

nonrecursive

Whether or not to refrain from recursively processing directories.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Příklady

Příklad 2259. Basic example

This example demonstrates a basic use-case of this function. To import a directory named new-files into the repository at http://www.example.com/svnroot/incoming/abc, use:

<?php
svn_import(realpath('new-files'), 'http://www.example.com/svnroot/incoming/abc', false);
?>

Viz také

svn_add()
» SVN documentation for svn import

Předcházející | Nahoru | Další
svn_fs_youngest_rev | Domů | svn_log


svn_log

(PECL svn:0.1-0.2)

svn_log — Returns the commit log messages of a repository URL

Popis

array svn_log ( string $repos_url [, int $revision_no] )

svn_log() returns the complete history of the item at the repository URL repos_url, or the history of a specific revision if revision_no is set. This function is equivalent to svn log --verbose -r $revision_no $repos_url.

Varování

For repositories with large histories, the output may be quite large (one array item for every revision of the item). This function does not support the --limit NUM flag, nor does it support revision ranges (revision_no must be an integer).

Seznam parametrů

repos_url

Repository URL of the item to retrieve log history from.

revision_no

Revision number of the log to retrieve. Use SVN_REVISON_HEAD to retrieve the log for the most recent revision.

Návratové hodnoty

On success, this function returns an array file listing in the format of:

[0] => Array, ordered most recent (highest) revision first
(
    [rev] => integer revision number
    [author] => string author name
    [msg] => string log message
    [date] => string date formatted per ISO 8601, i.e. date('c')
    [paths] => Array, describing changed files
        (
            [0] => Array
                (
                    [action] => string letter signifying change
                    [path] =>  absolute repository path of changed file
                )
            [1] => ...
        )
)
[1] => ...

Poznámka: The output will always be a numerically indexed array of arrays, even when there are none or only one log message(s).

The value of action is a subset of the » status output in the first column, where possible values are:

Tabulka 302. Actions

Letter | Description
M | Item/props was modified
A | Item was added
D | Item was deleted
R | Item was replaced

If no changes were made to the item, an empty array is returned.

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Příklady

Příklad 2260. svn_log() example

<?php
print_r( svn_log('http://www.example.com/', 23) );
?>

Výše uvedený příklad vypíše něco jako:

Array
(
    [0] => Array
    (
        [rev] => 23
        [author] => 'joe'
        [msg] => 'Add cheese and salami to our sandwich.'
        [date] => '2007-04-06T16:00:27-04:00'
        [paths] => Array
            (
                [0] => Array
                    (
                        [action] => 'M'
                        [path] =>  '/sandwich.txt'
                    )
            )
    )
)

Příklad 2261. Simulating --limit with svn and svn_log()

This sample function simulates the --limit switch by using the SVN executable to return a list of revisions, which are then losslessly accessed using svn_log().

Poznámka: This function will perform a total of limit + 1 requests: the first request to pull the required revisions, and each one after to retrieve the log item for that request.

<?php
/**
 * Retrieves the last $limit log entries.
 * @param $repos_url Repository URL of item to get logs for
 * @param $limit Integer limit of items
 */
function svn_log_limit($repos_url, $limit) {
    $limit = (int) $limit;
    if ($limit <= 0) return array();
    // -q flag used to prevent server from sending log messages
    $output = shell_exec("svn log -q --limit $limit $repos_url");
    preg_match_all('/^r(\d+) /m', $output, $matches);
    $ret = array();
    foreach ($matches[1] as $rev) {
        $log = svn_log($repos_url, (int) $rev);
        $ret[] = $log[0]; // log is only one item long
    }
    return $ret;
}
?>

Viz také

» SVN documentation on svn log

Předcházející | Nahoru | Další
svn_import | Domů | svn_ls


svn_ls

(PECL svn:0.1-0.2)

svn_ls — Returns list of directory contents in repository URL, optionally at revision number

Popis

array svn_ls ( string $repos_url [, int $revision_no] )

This function queries the repository URL and returns a list of files and directories, optionally from a specific revision. This is equivalent to svn list $repos_url[@$revision_no]

Poznámka: This function does not work with working copies. repos_url must be a repository URL.

Seznam parametrů

url

URL of the repository, eg. http://www.example.com/svnroot. To access a local Subversion repository via filesystem, use the file URI scheme, eg. file:///home/user/svn-repos

revision

Integer revision number to retrieve listing of. When omitted, the HEAD revision is used.

Návratové hodnoty

On success, this function returns an array file listing in the format of:

[0] => Array
    (
        [created_rev] => integer revision number of last edit
        [last_author] => string author name of last edit
        [size] => integer byte file size of file
        [time] => string date of last edit in form 'M d H:i'
                  or 'M d Y', depending on how old the file is
        [time_t] => integer unix timestamp of last edit
        [name] => name of file/directory
        [type] => type, can be 'file' or 'dir'
    )
[1] => ...

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Příklady

Příklad 2262. svn_ls() example

<?php
print_r( svn_ls('http://www.example.com/svnroot/') );
?>

Výše uvedený příklad vypíše něco jako:

Array
(
    [0] => Array
        (
            [created_rev] => 20
            [last_author] => Joe
            [size] => 0
            [time] => Apr 02 09:28
            [time_t] => 1175520529
            [name] => tags
            [type] => dir
        )
    [1] => Array
        (
            [created_rev] => 23
            [last_author] => Bob
            [size] => 0
            [time] => Apr 02 15:15
            [time_t] => 1175541322
            [name] => trunk
            [type] => dir
        )
)

Viz také

» SVN documentation on svn list

Předcházející | Nahoru | Další
svn_log | Domů | svn_repos_create


svn_repos_create

(PECL svn:0.1-0.2)

svn_repos_create — Create a new subversion repository at path

Popis

resource svn_repos_create ( string $path [, array $config [, array $fsconfig]] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Create a new subversion repository at path

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
svn_ls | Domů | svn_repos_fs_begin_txn_for_commit


svn_repos_fs

(PECL svn:0.1-0.2)

svn_repos_fs — Gets a handle on the filesystem for a repository

Popis

resource svn_repos_fs ( resource $repos )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Gets a handle on the filesystem for a repository

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
svn_repos_fs_commit_txn | Domů | svn_repos_hotcopy


svn_repos_fs_begin_txn_for_commit

(PECL svn:0.2)

svn_repos_fs_begin_txn_for_commit — Create a new transaction

Popis

resource svn_repos_fs_begin_txn_for_commit ( resource $repos, int $rev, string $author, string $log_msg )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Create a new transaction

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
svn_repos_create | Domů | svn_repos_fs_commit_txn


svn_repos_fs_commit_txn

(PECL svn:0.2)

svn_repos_fs_commit_txn — Commits a transaction and returns the new revision

Popis

int svn_repos_fs_commit_txn ( resource $txn )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Commits a transaction and returns the new revision

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
svn_repos_fs_begin_txn_for_commit | Domů | svn_repos_fs


svn_repos_hotcopy

(PECL svn:0.1-0.2)

svn_repos_hotcopy — Make a hot-copy of the repos at repospath; copy it to destpath

Popis

bool svn_repos_hotcopy ( string $repospath, string $destpath, bool $cleanlogs )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Make a hot-copy of the repos at repospath; copy it to destpath

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
svn_repos_fs | Domů | svn_repos_open


svn_repos_open

(PECL svn:0.1-0.2)

svn_repos_open — Open a shared lock on a repository.

Popis

resource svn_repos_open ( string $path )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Open a shared lock on a repository.

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
svn_repos_hotcopy | Domů | svn_repos_recover


svn_repos_recover

(PECL svn:0.1-0.2)

svn_repos_recover — Run recovery procedures on the repository located at path.

Popis

bool svn_repos_recover ( string $path )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Run recovery procedures on the repository located at path.

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Předcházející | Nahoru | Další
svn_repos_open | Domů | svn_status


svn_status

(PECL svn:0.1-0.2)

svn_status — Returns the status of working copy files and directories

Popis

array svn_status ( string $path [, bool $recursive [, bool $get_all [, bool $update [, bool $no_ignore]]]] )

Returns the status of working copy files and directories, giving modifications, additions, deletions and other changes to items in the working copy.

Seznam parametrů

path

Local path to file or directory to retrieve status of.

Poznámka: Relative paths will be resolved as if the current working directory was the one that contains the PHP binary. To use the calling script's working directory, use realpath() or dirname(__FILE__).

recursive

Whether or not to recursively descend into directories to retrieve status. Default is TRUE.

get_all

Whether or not to return all items, regardless of modification status. Default is FALSE.

update

Whether or not to return information from the server on whether or not the working copy is up-to-date (specifically, entries will be added for items that are out-of-date along with the regular modification checks). Default is FALSE.

no_ignore

Whether or not to disregard svn:ignore properties when scanning for new files. Default is FALSE.

Návratové hodnoty

Returns a numerically indexed array of associative arrays detailing the status of items in the repository:

Array (
    [0] => Array (
        // information on item
    )
    [1] => ...
)

The information on the item is an associative array that can contain the following keys:

path
String path to file/directory of this entry on local filesystem.
text_status
Status of item's text. Refer to status constants for possible values.
repos_text_status
Status of item's text in repository. Only accurate if update was set to TRUE. Refer to status constants for possible values.
prop_status
Status of item's properties. Refer to status constants for possible values.
repos_prop_status
Status of item's property in repository. Only accurate if update was set to TRUE. Refer to status constants for possible values.
locked
Whether or not the item is locked. (Only set if TRUE.)
copied
Whether or not the item was copied (scheduled for addition with history). (Only set if TRUE.)
switched
Whether or not the item was switched using the switch command. (Only set if TRUE)

These keys are only set if the item is versioned:

name
Base name of item in repository.
url
URL of item in repository.
repos
Base URL of repository.
revision
Integer revision of item in working copy.
kind
Type of item, i.e. file or directory. Refer to type constants for possible values.
schedule

Scheduled action for item, i.e. addition or deletion. Constants for these magic numbers are not available, they can be emulated by using:

<?php
if (!defined('svn_wc_schedule_normal')) {
    define('svn_wc_schedule_normal',  0); // nothing special
    define('svn_wc_schedule_add',     1); // item will be added
    define('svn_wc_schedule_delete',  2); // item will be deleted
    define('svn_wc_schedule_replace', 3); // item will be added and deleted
}
?>
deleted
Whether or not the item was deleted, but parent revision lags behind. (Only set if TRUE.)
absent
Whether or not the item is absent, that is, Subversion knows that there should be something there but there isn't. (Only set if TRUE.)
incomplete
Whether or not the entries file for a directory is incomplete. (Only set if TRUE.)
cmt_date
Integer Unix timestamp of last commit date. (Unaffected by update.)
cmt_rev
Integer revision of last commit. (Unaffected by update.)
cmt_author
String author of last commit. (Unaffected by update.)
prop_time
Integer Unix timestamp of last up-to-date time for properties
text_time
Integer Unix timestamp of last up-to-date time for text

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Příklady

Příklad 2263. Basic example

This example demonstrates a basic, theoretical usage of this function.

<?php
print_r(svn_status(realpath('wc')));
?>

Výše uvedený příklad vypíše něco jako:

Array (
    [0] => Array (
        [path] => /home/bob/wc/sandwich.txt
        [text_status] => 8 // item was modified
        [repos_text_status] => 1 // no information available, use update
        [prop_status] => 3 // no changes
        [repos_prop_status] => 1 // no information available, use update
        [name] => sandwich.txt
        [url] => http://www.example.com/svnroot/deli/trunk/sandwich.txt
        [repos] => http://www.example.com/svnroot/
        [revision] => 123
        [kind] => 1 // file
        [schedule] => 0 // no special actions scheduled
        [cmt_date] => 1165543135
        [cmt_rev] => 120
        [cmt_author] => Alice
        [prop_time] => 1180201728
        [text_time] => 1180201729
    )
)

Viz také

svn_update()
svn_log()
» SVN documentation for svn status

Předcházející | Nahoru | Další
svn_repos_recover | Domů | svn_update


svn_update

(PECL svn:0.1-0.2)

svn_update — Update working copy

Popis

int svn_update ( string $path [, int $revno [, bool $recurse]] )

Update working copy at path to revision revno. If recurse is true, directories will be recursively updated.

Seznam parametrů

path

Path to local working copy.

Poznámka: Relative paths will be resolved as if the current working directory was the one that contains the PHP binary. To use the calling script's working directory, use realpath() or dirname(__FILE__).

revno

Revision number to update to, default is SVN_REVISION_HEAD.

recurse

Whether or not to recursively update directories, default is TRUE.

Návratové hodnoty

Returns new revision number on success, returns FALSE on failure.

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Příklady

Příklad 2264. Basic example

This example demonstrates basic usage of this function:

<?php
echo svn_update(realpath('working-copy'));
?>

Výše uvedený příklad vypíše něco jako:

234

Viz také

svn_checkout()
svn_commit()
» SVN documentation for svn update

Předcházející | Nahoru | Další
svn_status | Domů | CLXIII. Shockwave Flash Functions


SWFAction->__construct()

(PHP 5)

SWFAction->__construct() — Creates a new SWFAction

Popis

class SWFAction {
SWFAction __construct ( string $script )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Creates a new SWFAction and compiles the given script in it.

Seznam parametrů

script

An ActionScript snippet to associate with the SWFAction. See SWFAction for more details.

Předcházející | Nahoru | Další
SWFAction | Domů | SWFBitmap


SWFBitmap->__construct()

(PHP 5)

SWFBitmap->__construct() — Loads Bitmap object

Popis

class SWFBitmap {
SWFBitmap __construct ( mixed $file [, mixed $alphafile] )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Creates the new SWFBitmap object from the given file.

Seznam parametrů

For both parameters you can provide a file pointer returned by fopen() or the image data, as a binary string.

file

Poznámka: We can only deal with baseline (frame 0) jpegs, no baseline optimized or progressive scan jpegs!

You can't import png images directly, though- have to use the png2dbl utility to make a dbl ("define bits lossless") file from the png. The reason for this is that I don't want a dependency on the png library in ming- autoconf should solve this, but that's not set up yet.

alphafile

An MSK file to be used as an alpha mask for a JPEG image.

Příklady

Příklad 1171. Importing a DBL file

<?php
$s = new SWFShape();
$f = $s->addFill(new SWFBitmap(file_get_contents("image.dbl")));
$s->setRightFill($f);

$s->drawLine(32, 0);
$s->drawLine(0, 32);
$s->drawLine(-32, 0);
$s->drawLine(0, -32);

$m = new SWFMovie();
$m->setDimension(32, 32);
$m->add($s);

header('Content-type: application/x-shockwave-flash');
$m->output();
?>

Příklad 1172. Using an alpha mask

<?php

$s = new SWFShape();

// .msk file generated with "gif2mask" utility
$f = $s->addFill(new SWFBitmap(file_get_contents("alphafill.jpg"), file_get_contents("alphafill.msk")));
$s->setRightFill($f);

$s->drawLine(640, 0);
$s->drawLine(0, 480);
$s->drawLine(-640, 0);
$s->drawLine(0, -480);

$c = new SWFShape();
$c->setRightFill($c->addFill(0x99, 0x99, 0x99));
$c->drawLine(40, 0);
$c->drawLine(0, 40);
$c->drawLine(-40, 0);
$c->drawLine(0, -40);

$m = new SWFMovie();
$m->setDimension(640, 480);
$m->setBackground(0xcc, 0xcc, 0xcc);

// draw checkerboard background
for ($y=0; $y<480; $y+=40) {
  for ($x=0; $x<640; $x+=80) {
    $i = $m->add($c);
    $i->moveTo($x, $y);
  }

  $y+=40;

  for ($x=40; $x<640; $x+=80) {
    $i = $m->add($c);
    $i->moveTo($x, $y);
  }
}

$m->add($s);

header('Content-type: application/x-shockwave-flash');
$m->output();
?>

Předcházející | Nahoru | Další
SWFBitmap | Domů | SWFBitmap->getHeight()


SWFButton->addASound()

(PHP 5)

SWFButton->addASound() — Associates a sound with a button transition

Popis

class SWFButton {
SWFSoundInstance addASound ( SWFSound $sound, int $flags )
}
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
SWFButton->addAction() | Domů | SWFButton->addShape()


SWFButton->__construct()

(PHP 5)

SWFButton->__construct() — Creates a new Button

Popis

class SWFButton {
SWFButton __construct ( void )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Creates a new Button.

Příklady

This simple example will show your usual interactions with buttons : rollover, rollon, mouseup, mousedown, noaction.

Příklad 1173. Usual interactions with buttons

<?php

$f = new SWFFont("_serif");

$p = new SWFSprite();

function label($string)
{
  global $f;

  $t = new SWFTextField();
  $t->setFont($f);
  $t->addString($string);
  $t->setHeight(200);
  $t->setBounds(3200, 200);
  return $t;
}

function addLabel($string)
{
  global $p;

  $i = $p->add(label($string));
  $p->nextFrame();
  $p->remove($i);
}

$p->add(new SWFAction("stop();"));
addLabel("NO ACTION");
addLabel("SWFBUTTON_MOUSEUP");
addLabel("SWFBUTTON_MOUSEDOWN");
addLabel("SWFBUTTON_MOUSEOVER");
addLabel("SWFBUTTON_MOUSEOUT");
addLabel("SWFBUTTON_MOUSEUPOUTSIDE");
addLabel("SWFBUTTON_DRAGOVER");
addLabel("SWFBUTTON_DRAGOUT");

function rect($r, $g, $b)
{
  $s = new SWFShape();
  $s->setRightFill($s->addFill($r, $g, $b));
  $s->drawLine(600, 0);
  $s->drawLine(0, 600);
  $s->drawLine(-600, 0);
  $s->drawLine(0, -600);

  return $s;
}

$b = new SWFButton();
$b->addShape(rect(0xff, 0, 0), SWFBUTTON_UP | SWFBUTTON_HIT);
$b->addShape(rect(0, 0xff, 0), SWFBUTTON_OVER);
$b->addShape(rect(0, 0, 0xff), SWFBUTTON_DOWN);

$b->addAction(new SWFAction("setTarget('/label'); gotoFrame(1);"),
          SWFBUTTON_MOUSEUP);

$b->addAction(new SWFAction("setTarget('/label'); gotoFrame(2);"),
      SWFBUTTON_MOUSEDOWN);

$b->addAction(new SWFAction("setTarget('/label'); gotoFrame(3);"),
      SWFBUTTON_MOUSEOVER);

$b->addAction(new SWFAction("setTarget('/label'); gotoFrame(4);"),
      SWFBUTTON_MOUSEOUT);

$b->addAction(new SWFAction("setTarget('/label'); gotoFrame(5);"),
      SWFBUTTON_MOUSEUPOUTSIDE);

$b->addAction(new SWFAction("setTarget('/label'); gotoFrame(6);"),
      SWFBUTTON_DRAGOVER);

$b->addAction(new SWFAction("setTarget('/label'); gotoFrame(7);"),
      SWFBUTTON_DRAGOUT);

$m = new SWFMovie();
$m->setDimension(4000, 3000);

$i = $m->add($p);
$i->setName("label");
$i->moveTo(400, 1900);

$i = $m->add($b);
$i->moveTo(400, 900);

header('Content-type: application/x-shockwave-flash');
$m->output();
?>

This simple example will enables you to drag draw a big red button on the windows. No drag-and-drop, just moving around.

Příklad 1174. Drag example

<?php

$s = new SWFShape();
$s->setRightFill($s->addFill(0xff, 0, 0));
$s->drawLine(1000,0);
$s->drawLine(0,1000);
$s->drawLine(-1000,0);
$s->drawLine(0,-1000);

$b = new SWFButton();
$b->addShape($s, SWFBUTTON_HIT | SWFBUTTON_UP | SWFBUTTON_DOWN | SWFBUTTON_OVER);

$b->addAction(new SWFAction("startDrag('/test', 0);"), // '0' means don't lock to mouse
      SWFBUTTON_MOUSEDOWN);

$b->addAction(new SWFAction("stopDrag();"),
      SWFBUTTON_MOUSEUP | SWFBUTTON_MOUSEUPOUTSIDE);

$p = new SWFSprite();
$p->add($b);
$p->nextFrame();

$m = new SWFMovie();
$i = $m->add($p);
$i->setName('test');
$i->moveTo(1000,1000);

header('Content-type: application/x-shockwave-flash');
$m->output();
?>

Předcházející | Nahoru | Další
SWFButton | Domů | SWFButton->addAction()


SWFButton->setMenu()

(PHP 5)

SWFButton->setMenu() — enable track as menu button behaviour

Popis

class SWFButton {
void setMenu ( int $flag )
}
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

flag

This parameter can be used for a slight different behavior of buttons. You can set it to 0 (off) or 1 (on).

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
SWFButton->setHit() | Domů | SWFButton->setOver()


SWFDisplayItem->addAction()

(PHP 5)

SWFDisplayItem->addAction() — Adds this SWFAction to the given SWFSprite instance

Popis

class SWFDisplayItem {
void addAction ( SWFAction $action, int $flags )
}
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

action

An SWFAction, returned by SWFAction->__construct().

flags

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

SWFAction

Předcházející | Nahoru | Další
SWFDisplayItem | Domů | SWFDisplayItem->addColor()


SWFDisplayItem->endMask()

(PHP 5)

SWFDisplayItem->endMask() — Another way of defining a MASK layer

Popis

class SWFDisplayItem {
void endMask ( void )
}
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
SWFDisplayItem->addColor() | Domů | SWFDisplayItem->getRot()


SWFDisplayItem->getRot()

(No version information available, might be only in CVS)

SWFDisplayItem->getRot()

Popis

class SWFDisplayItem {
float getRot ( void )
}
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
SWFDisplayItem->endMask() | Domů | SWFDisplayItem->getX()


SWFDisplayItem->getX()

(No version information available, might be only in CVS)

SWFDisplayItem->getX()

Popis

class SWFDisplayItem {
float getX ( void )
}
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Viz také

SWFDisplayItem->getY()

Předcházející | Nahoru | Další
SWFDisplayItem->getRot() | Domů | SWFDisplayItem->getXScale()


SWFDisplayItem->getXScale()

(No version information available, might be only in CVS)

SWFDisplayItem->getXScale()

Popis

class SWFDisplayItem {
float getXScale ( void )
}
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Viz také

SWFDisplayItem->getYScale()

Předcházející | Nahoru | Další
SWFDisplayItem->getX() | Domů | SWFDisplayItem->getXSkew()


SWFDisplayItem->getXSkew()

(No version information available, might be only in CVS)

SWFDisplayItem->getXSkew()

Popis

class SWFDisplayItem {
float getXSkew ( void )
}
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Viz také

SWFDisplayItem->getYSkew()

Předcházející | Nahoru | Další
SWFDisplayItem->getXScale() | Domů | SWFDisplayItem->getY()


SWFDisplayItem->getY()

(No version information available, might be only in CVS)

SWFDisplayItem->getY()

Popis

class SWFDisplayItem {
float getY ( void )
}
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Viz také

SWFDisplayItem->getX()

Předcházející | Nahoru | Další
SWFDisplayItem->getXSkew() | Domů | SWFDisplayItem->getYScale()


SWFDisplayItem->getYScale()

(No version information available, might be only in CVS)

SWFDisplayItem->getYScale()

Popis

class SWFDisplayItem {
float getYScale ( void )
}
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Viz také

SWFDisplayItem->getXScale()

Předcházející | Nahoru | Další
SWFDisplayItem->getY() | Domů | SWFDisplayItem->getYSkew()


SWFDisplayItem->getYSkew()

(No version information available, might be only in CVS)

SWFDisplayItem->getYSkew()

Popis

class SWFDisplayItem {
float getYSkew ( void )
}
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Viz také

SWFDisplayItem->getXSkew()

Předcházející | Nahoru | Další
SWFDisplayItem->getYScale() | Domů | SWFDisplayItem->move()


SWFDisplayItem->setMaskLevel()

(PHP 5)

SWFDisplayItem->setMaskLevel() — Defines a MASK layer at level

Popis

class SWFDisplayItem {
void setMaskLevel ( int $level )
}
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
SWFDisplayItem->setDepth() | Domů | SWFDisplayItem->setMatrix()


SWFDisplayItem->setMatrix()

(PHP 5)

SWFDisplayItem->setMatrix() — Sets the item's transform matrix

Popis

class SWFDisplayItem {
void setMatrix ( float $a, float $b, float $c, float $d, float $x, float $y )
}
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
SWFDisplayItem->setMaskLevel() | Domů | SWFDisplayItem->setName()


SWFFont->__construct()

(PHP 5)

SWFFont->__construct() — Loads a font definition

Popis

class SWFFont {
SWFFont __construct ( string $filename )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

If filename is the name of an FDB file (i.e., it ends in ".fdb"), load the font definition found in said file. Otherwise, create a browser-defined font reference.

FDB ("font definition block") is a very simple wrapper for the SWF DefineFont2 block which contains a full description of a font. One may create FDB files from SWT Generator template files with the included makefdb utility- look in the util directory off the main ming distribution directory.

Browser-defined fonts don't contain any information about the font other than its name. It is assumed that the font definition will be provided by the movie player. The fonts _serif, _sans, and _typewriter should always be available. For example: <?php
$f = newSWFFont("_sans");
?> will give you the standard sans-serif font, probably the same as what you'd get with <font name="sans-serif"> in HTML.

Předcházející | Nahoru | Další
SWFFont | Domů | SWFFont->getAscent()


SWFFont->getAscent()

(PHP 5)

SWFFont->getAscent() — Returns the ascent of the font, or 0 if not available

Popis

class SWFFont {
float getAscent ( void )
}
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Viz také

SWFFont->getDescent()

Předcházející | Nahoru | Další
SWFFont->__construct() | Domů | SWFFont->getDescent()


SWFFont->getDescent()

(PHP 5)

SWFFont->getDescent() — Returns the descent of the font, or 0 if not available

Popis

class SWFFont {
float getDescent ( void )
}
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Viz také

SWFFont->getAscent()

Předcházející | Nahoru | Další
SWFFont->getAscent() | Domů | SWFFont->getLeading()


SWFFont->getLeading()

(PHP 5)

SWFFont->getLeading() — Returns the leading of the font, or 0 if not available

Popis

class SWFFont {
float getLeading ( void )
}
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
SWFFont->getDescent() | Domů | SWFFont->getShape()


SWFFont->getShape()

(PHP 5)

SWFFont->getShape() — Returns the glyph shape of a char as a text string

Popis

class SWFFont {
string getShape ( int $code )
}
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
SWFFont->getLeading() | Domů | SWFFont->getUTF8Width()


SWFFont->getUTF8Width()

(PHP 5)

SWFFont->getUTF8Width() — Calculates the width of the given string in this font at full height

Popis

class SWFFont {
float getUTF8Width ( string $string )
}
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Viz také

SWFFont->getWidth()

Předcházející | Nahoru | Další
SWFFont->getShape() | Domů | SWFFont->getWidth()


SWFFontChar->addChars()

(PHP 5)

SWFFontChar->addChars() — Adds characters to a font for exporting font

Popis

class SWFFontChar {
void addChars ( string $char )
}
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

SWFFontChar->addUTF8Chars()

Předcházející | Nahoru | Další
SWFFontChar | Domů | SWFFontChar->addUTF8Chars()


SWFFontChar->addUTF8Chars()

(No version information available, might be only in CVS)

SWFFontChar->addUTF8Chars() — Adds characters to a font for exporting font

Popis

class SWFFontChar {
void addUTF8Chars ( string $char )
}
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

SWFFontChar->addChars()

Předcházející | Nahoru | Další
SWFFontChar->addChars() | Domů | SWFGradient


SWFGradient->__construct()

(PHP 5)

SWFGradient->__construct() — Creates a gradient object

Popis

class SWFGradient {
SWFGradient __construct ( void )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

swfgradient() creates a new SWFGradient object.

After you've added the entries to your gradient, you can use the gradient in a shape fill with the swfshape->addfill() method.

SWFGradient has the following methods : swfgradient->addentry().

This simple example will draw a big black-to-white gradient as background, and a reddish disc in its center.

Příklad 1178. swfgradient() example

<?php

  $m = new SWFMovie();
  $m->setDimension(320, 240);

  $s = new SWFShape();

  // first gradient- black to white
  $g = new SWFGradient();
  $g->addEntry(0.0, 0, 0, 0);
  $g->addEntry(1.0, 0xff, 0xff, 0xff);

  $f = $s->addFill($g, SWFFILL_LINEAR_GRADIENT);
  $f->scaleTo(0.01);
  $f->moveTo(160, 120);
  $s->setRightFill($f);
  $s->drawLine(320, 0);
  $s->drawLine(0, 240);
  $s->drawLine(-320, 0);
  $s->drawLine(0, -240);

  $m->add($s);

  $s = new SWFShape();

  // second gradient- radial gradient from red to transparent
  $g = new SWFGradient();
  $g->addEntry(0.0, 0xff, 0, 0, 0xff);
  $g->addEntry(1.0, 0xff, 0, 0, 0);

  $f = $s->addFill($g, SWFFILL_RADIAL_GRADIENT);
  $f->scaleTo(0.005);
  $f->moveTo(160, 120);
  $s->setRightFill($f);
  $s->drawLine(320, 0);
  $s->drawLine(0, 240);
  $s->drawLine(-320, 0);
  $s->drawLine(0, -240);

  $m->add($s);

  header('Content-type: application/x-shockwave-flash');
  $m->output();
?>

Předcházející | Nahoru | Další
SWFGradient | Domů | SWFGradient->addEntry()


SWFMorph->__construct()

(PHP 5)

SWFMorph->__construct() — Creates a new SWFMorph object

Popis

class SWFMorph {
SWFMorph __construct ( void )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Creates a new SWFMorph object.

Also called a "shape tween". This thing lets you make those tacky twisting things that make your computer choke. Oh, joy!

Příklady

This simple example will morph a big red square into a smaller blue black-bordered square.

Příklad 1179. swfmorph() example

<?php
  $p = new SWFMorph();

  $s = $p->getShape1();
  $s->setLine(0, 0, 0, 0);

  /* Note that this is backwards from normal shapes (left instead of right).
     I have no idea why, but this seems to work.. */

  $s->setLeftFill($s->addFill(0xff, 0, 0));
  $s->movePenTo(-1000,-1000);
  $s->drawLine(2000,0);
  $s->drawLine(0,2000);
  $s->drawLine(-2000,0);
  $s->drawLine(0,-2000);

  $s = $p->getShape2();
  $s->setLine(60,0,0,0);
  $s->setLeftFill($s->addFill(0, 0, 0xff));
  $s->movePenTo(0,-1000);
  $s->drawLine(1000,1000);
  $s->drawLine(-1000,1000);
  $s->drawLine(-1000,-1000);
  $s->drawLine(1000,-1000);

  $m = new SWFMovie();
  $m->setDimension(3000,2000);
  $m->setBackground(0xff, 0xff, 0xff);

  $i = $m->add($p);
  $i->moveTo(1500,1000);

  for ($r=0.0; $r<=1.0; $r+=0.1) {
    $i->setRatio($r);
    $m->nextFrame();
  }

  header('Content-type: application/x-shockwave-flash');
  $m->output();
?>

Předcházející | Nahoru | Další
SWFMorph | Domů | SWFMorph->getShape1()


SWFMovie->addExport()

(No version information available, might be only in CVS)

SWFMovie->addExport()

Popis

class SWFMovie {
void addExport ( SWFCharacter $char, string $name )
}
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
SWFMovie->add() | Domů | SWFMovie->addFont()


SWFMovie->addFont()

(No version information available, might be only in CVS)

SWFMovie->addFont()

Popis

class SWFMovie {
mixed addFont ( SWFFont $font )
}
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
SWFMovie->addExport() | Domů | SWFMovie->importChar()


SWFMovie->__construct()

(PHP 5)

SWFMovie->__construct() — Creates a new movie object, representing an SWF version 4 movie

Popis

class SWFMovie {
SWFMovie __construct ( int $version )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Creates a new movie object, representing an SWF movie.

Seznam parametrů

version

The desired SWF version. Default is 4.

Předcházející | Nahoru | Další
SWFMovie | Domů | SWFMovie->add()


SWFMovie->importChar()

(No version information available, might be only in CVS)

SWFMovie->importChar()

Popis

class SWFMovie {
SWFSprite importChar ( string $libswf, string $name )
}
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Viz také

SWFMovie->importFont()

Předcházející | Nahoru | Další
SWFMovie->addFont() | Domů | SWFMovie->importFont()


SWFMovie->importFont()

(No version information available, might be only in CVS)

SWFMovie->importFont()

Popis

class SWFMovie {
SWFFontChar importFont ( string $libswf, string $name )
}
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Viz také

SWFMovie->importChar()

Předcházející | Nahoru | Další
SWFMovie->importChar() | Domů | SWFMovie->labelFrame()


SWFMovie->labelFrame()

(PHP 5)

SWFMovie->labelFrame() — Labels a frame

Popis

class SWFMovie {
void labelFrame ( string $label )
}
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
SWFMovie->importFont() | Domů | SWFMovie->nextFrame()


SWFMovie->saveToFile()

(PHP 5)

SWFMovie->saveToFile()

Popis

class SWFMovie {
int saveToFile ( stream $x [, int $compression] )
}
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

X

compression

The compression level can be a value between 0 and 9, defining the SWF compression similar to gzip compression.

This parameter is only available as of Flash MX (6).

Návratové hodnoty

Return the number of bytes written or FALSE on error.

Viz také

SWFMovie->output()
SWFMovie->save()

Předcházející | Nahoru | Další
SWFMovie->save() | Domů | SWFMovie->setbackground()


SWFMovie->startSound()

(No version information available, might be only in CVS)

SWFMovie->startSound()

Popis

class SWFMovie {
SWFSoundInstance startSound ( SWFSound $sound )
}
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Viz také

SWFMovie->stopSound()

Předcházející | Nahoru | Další
SWFMovie->setRate() | Domů | SWFMovie->stopSound()


SWFMovie->stopSound()

(No version information available, might be only in CVS)

SWFMovie->stopSound()

Popis

class SWFMovie {
void stopSound ( SWFSound $sound )
}
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

SWFMovie->startSound()

Předcházející | Nahoru | Další
SWFMovie->startSound() | Domů | SWFMovie->streamMP3()


SWFMovie->writeExports()

(No version information available, might be only in CVS)

SWFMovie->writeExports()

Popis

class SWFMovie {
void writeExports ( void )
}
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
SWFMovie->streamMP3() | Domů | SWFPrebuiltClip


SWFPrebuiltClip->__construct()

(No version information available, might be only in CVS)

SWFPrebuiltClip->__construct() — Returns a SWFPrebuiltClip object

Popis

class SWFPrebuiltClip {
SWFPrebuiltClip __construct ( [string $file] )
}
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
SWFPrebuiltClip | Domů | SWFShape


SWFShape->__construct()

(PHP 5)

SWFShape->__construct() — Creates a new shape object

Popis

class SWFShape {
SWFShape __construct ( void )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Created a new SWFShape object.

Příklady

This simple example will draw a big red elliptic quadrant.

Příklad 1182. swfshape() example

<?php
$s = new SWFShape();
$s->setLine(40, 0x7f, 0, 0);
$s->setRightFill($s->addFill(0xff, 0, 0));
$s->movePenTo(200, 200);
$s->drawLineTo(6200, 200);
$s->drawLineTo(6200, 4600);
$s->drawCurveTo(200, 4600, 200, 200);

$m = new SWFMovie();
$m->setDimension(6400, 4800);
$m->setRate(12.0);
$m->add($s);
$m->nextFrame();

header('Content-type: application/x-shockwave-flash');
$m->output();
?>

Předcházející | Nahoru | Další
SWFShape | Domů | SWFShape->addFill()


SWFShape->drawArc()

(PHP 5)

SWFShape->drawArc() — Draws an arc of radius r centered at the current location, from angle startAngle to angle endAngle measured clockwise from 12 o'clock

Popis

class SWFShape {
void drawArc ( float $r, float $startAngle, float $endAngle )
}
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

SWFShape->drawCircle()

Předcházející | Nahoru | Další
SWFShape->addFill() | Domů | SWFShape->drawCircle()


SWFShape->drawCircle()

(PHP 5)

SWFShape->drawCircle() — Draws a circle of radius r centered at the current location, in a counter-clockwise fashion

Popis

class SWFShape {
void drawCircle ( float $r )
}
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
SWFShape->drawArc() | Domů | SWFShape->drawCubic()


SWFShape->drawCubic()

(PHP 5)

SWFShape->drawCubic() — Draws a cubic bezier curve using the current position and the three given points as control points

Popis

class SWFShape {
int drawCubic ( float $bx, float $by, float $cx, float $cy, float $dx, float $dy )
}
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Viz také

SWFShape->drawCubicTo()

Předcházející | Nahoru | Další
SWFShape->drawCircle() | Domů | SWFShape->drawCubicTo()


SWFShape->drawCubicTo()

(No version information available, might be only in CVS)

SWFShape->drawCubicTo() — Draws a cubic bezier curve using the current position and the three given points as control points

Popis

class SWFShape {
int drawCubicTo ( float $bx, float $by, float $cx, float $cy, float $dx, float $dy )
}
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Viz také

SWFShape->drawCubic()

Předcházející | Nahoru | Další
SWFShape->drawCubic() | Domů | SWFShape->drawCurve()


SWFShape->drawGlyph()

(PHP 5)

SWFShape->drawGlyph() — Draws the first character in the given string into the shape using the glyph definition from the given font

Popis

class SWFShape {
void drawGlyph ( SWFFont $font, string $character [, int $size] )
}
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
SWFShape->drawCurveTo() | Domů | SWFShape->drawLine()


SWFSound

(No version information available, might be only in CVS)

SWFSound — Returns a new SWFSound object from given file

Popis

class SWFSound {
SWFSound __construct ( string $filename, int $flags )
}
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
SWFSound | Domů | SWFSoundInstance


SWFSoundInstance->loopCount()

(No version information available, might be only in CVS)

SWFSoundInstance->loopCount()

Popis

class SWFSoundInstance {
void loopCount ( int $point )
}
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

point

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

SWFSoundInstance->loopOutPoint()

Předcházející | Nahoru | Další
SWFSoundInstance | Domů | SWFSoundInstance->loopInPoint()


SWFSoundInstance->loopInPoint()

(No version information available, might be only in CVS)

SWFSoundInstance->loopInPoint()

Popis

class SWFSoundInstance {
void loopInPoint ( int $point )
}
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

point

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

SWFSoundInstance->loopOutPoint()

Předcházející | Nahoru | Další
SWFSoundInstance->loopCount() | Domů | SWFSoundInstance->loopOutPoint()


SWFSoundInstance->loopOutPoint()

(No version information available, might be only in CVS)

SWFSoundInstance->loopOutPoint()

Popis

class SWFSoundInstance {
void loopOutPoint ( int $point )
}
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Seznam parametrů

point

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

SWFSoundInstance->loopInPoint()

Předcházející | Nahoru | Další
SWFSoundInstance->loopInPoint() | Domů | SWFSoundInstance->noMultiple()


SWFSoundInstance->noMultiple()

(No version information available, might be only in CVS)

SWFSoundInstance->noMultiple()

Popis

class SWFSoundInstance {
void noMultiple ( void )
}
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
SWFSoundInstance->loopOutPoint() | Domů | SWFSprite


SWFSprite->__construct()

(PHP 5)

SWFSprite->__construct() — Creates a movie clip (a sprite)

Popis

class SWFSprite {
SWFSprite __construct ( void )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Creates a new SWFSprite object.

Předcházející | Nahoru | Další
SWFSprite | Domů | SWFSprite->add()


SWFSprite->labelFrame()

(PHP 5)

SWFSprite->labelFrame() — Labels frame

Popis

class SWFSprite {
void labelFrame ( string $label )
}
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
SWFSprite->add() | Domů | SWFSprite->nextFrame()


SWFSprite->startSound()

(No version information available, might be only in CVS)

SWFSprite->startSound()

Popis

class SWFSprite {
SWFSoundInstance startSound ( SWFSound $sount )
}
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Viz také

SWFSprite->stopSound()

Předcházející | Nahoru | Další
SWFSprite->setFrames() | Domů | SWFSprite->stopSound()


SWFSprite->stopSound()

(No version information available, might be only in CVS)

SWFSprite->stopSound()

Popis

class SWFSprite {
void stopSound ( SWFSound $sount )
}
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

SWFSprite->startSound()

Předcházející | Nahoru | Další
SWFSprite->startSound() | Domů | SWFText


SWFText->addUTF8String()

(PHP 5)

SWFText->addUTF8String() — Writes the given text into this SWFText object at the current pen position, using the current font, height, spacing, and color

Popis

class SWFText {
void addUTF8String ( string $text )
}
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

SWFText->addString()

Předcházející | Nahoru | Další
SWFText->addString() | Domů | SWFText->getAscent()


SWFText->__construct()

(PHP 5)

SWFText->__construct() — Creates a new SWFText object

Popis

class SWFText {
void __construct ( void )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Creates a new SWFText object, fresh for manipulating.

Příklady

This simple example will draw a big yellow "PHP generates Flash with Ming" text, on white background.

Příklad 1186. swftext() example

<?php
$f = new SWFFont("Techno.fdb");
$t = new SWFText();
$t->setFont($f);
$t->moveTo(200, 2400);
$t->setColor(0xff, 0xff, 0);
$t->setHeight(1200);
$t->addString("PHP generates Flash with Ming!!");

$m = new SWFMovie();
$m->setDimension(5400, 3600);

$m->add($t);

header('Content-type: application/x-shockwave-flash');
$m->output();
?>

Předcházející | Nahoru | Další
SWFText | Domů | SWFText->addString()


SWFText->getAscent()

(PHP 5)

SWFText->getAscent() — Returns the ascent of the current font at its current size, or 0 if not available

Popis

class SWFText {
float getAscent ( void )
}
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Viz také

SWFText->getDescent()

Předcházející | Nahoru | Další
SWFText->addUTF8String() | Domů | SWFText->getDescent()


SWFText->getDescent()

(PHP 5)

SWFText->getDescent() — Returns the descent of the current font at its current size, or 0 if not available

Popis

class SWFText {
float getDescent ( void )
}
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Viz také

SWFText->getAscent()

Předcházející | Nahoru | Další
SWFText->getAscent() | Domů | SWFText->getLeading()


SWFText->getLeading()

(PHP 5)

SWFText->getLeading() — Returns the leading of the current font at its current size, or 0 if not available

Popis

class SWFText {
float getLeading ( void )
}
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
SWFText->getDescent() | Domů | SWFText->getUTF8Width()


SWFText->getUTF8Width()

(PHP 5)

SWFText->getUTF8Width() — calculates the width of the given string in this text objects current font and size

Popis

class SWFText {
float getUTF8Width ( string $string )
}
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Viz také

SWFText->getWidth()

Předcházející | Nahoru | Další
SWFText->getLeading() | Domů | SWFText->getWidth()


SWFTextField->addChars()

(PHP 5)

SWFTextField->addChars() — adds characters to a font that will be available within a textfield

Popis

class SWFTextField {
void addChars ( string $chars )
}
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Návratové hodnoty

Nevrací se žádná hodnota.

Viz také

SWFTextField->addString()

Předcházející | Nahoru | Další
SWFTextField->__construct() | Domů | SWFTextField->addString()


SWFTextField->__construct()

(PHP 5)

SWFTextField->__construct() — Creates a text field object

Popis

class SWFTextField {
SWFTextField __construct ( [int $flags] )
}
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

swftextfield() creates a new text field object. Text Fields are less flexible than swftext() objects- they can't be rotated, scaled non-proportionally, or skewed, but they can be used as form entries, and they can use browser-defined fonts.

The optional flags change the text field's behavior. It has the following possibles values :

  • SWFTEXTFIELD_DRAWBOX draws the outline of the textfield
  • SWFTEXTFIELD_HASLENGTH
  • SWFTEXTFIELD_HTML allows text markup using HTML-tags
  • SWFTEXTFIELD_MULTILINE allows multiple lines
  • SWFTEXTFIELD_NOEDIT indicates that the field shouldn't be user-editable
  • SWFTEXTFIELD_NOSELECT makes the field non-selectable
  • SWFTEXTFIELD_PASSWORD obscures the data entry
  • SWFTEXTFIELD_WORDWRAP allows text to wrap
Flags are combined with the bitwise OR operation. For example, <?php
$t = newSWFTextField(SWFTEXTFIELD_PASSWORD | SWFTEXTFIELD_NOEDIT);
?> creates a totally useless non-editable password field.

SWFTextField has the following methods : swftextfield->setfont(),
swftextfield->setbounds(), swftextfield->align(),
swftextfield->setheight(), swftextfield->setleftmargin(),
swftextfield->setrightmargin(), swftextfield->setmargins(),
swftextfield->setindentation(), swftextfield->setlinespacing(),
swftextfield->setcolor(), swftextfield->setname() and
swftextfield->addstring().

Předcházející | Nahoru | Další
SWFTextField | Domů | SWFTextField->addChars()


SWFTextField->setPadding()

(PHP 5)

SWFTextField->setPadding() — Sets the padding of this textfield

Popis

class SWFTextField {
void setPadding ( float $padding )
}
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
SWFTextField->setName() | Domů | SWFTextField->setRightMargin()


SWFVideoStream->__construct()

(No version information available, might be only in CVS)

SWFVideoStream->__construct() — Returns a SWFVideoStream object

Popis

class SWFVideoStream {
SWFVideoStream __construct ( [string $file] )
}
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
SWFVideoStream | Domů | SWFVideoStream->getNumFrames()


SWFVideoStream->getNumFrames()

(No version information available, might be only in CVS)

SWFVideoStream->getNumFrames()

Popis

class SWFVideoStream {
int getNumFrames ( void )
}
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
SWFVideoStream->__construct() | Domů | SWFVideoStream->setDimension()


SWFVideoStream->setDimension()

(No version information available, might be only in CVS)

SWFVideoStream->setDimension()

Popis

class SWFVideoStream {
void setDimension ( int $x, int $y )
}
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Návratové hodnoty

Nevrací se žádná hodnota.

Předcházející | Nahoru | Další
SWFVideoStream->getNumFrames() | Domů | ming_keypress


Swish::__construct

(PECL swish:0.1-0.3.0)

Swish::__construct — Construct a Swish object

Popis

void Swish::__construct ( string $index_names )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Seznam parametrů

index_names

The list of index files separated by spaces.

Errors/Exceptions

Throws SwishException on error.

Příklady

Příklad 2269. A Swish::__construct() example

<?php

try {
    $swish = new Swish("index1 index2");
} catch (SwishException $e) {
    echo $e->getMessage(), "\n";
}

foreach ($swish->indexes as $index) {
    var_dump($index["name"]);
    var_dump($index["headers"]["Total Words"]);
}

?>

Výše uvedený příklad vypíše něco jako:

string(6) "index1"
int(1888)
string(6) "index2"
int(2429)

Předcházející | Nahoru | Další
CLXIV. Swish Functions | Domů | Swish->getMetaList


Swish->getMetaList

(PECL swish:0.1-0.3.0)

Swish->getMetaList — Get the list of meta entries for the index

Popis

array Swish->getMetaList ( string $index_name )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Seznam parametrů

index_name

The name of the index file.

Návratové hodnoty

Returns an array of meta entries for the given index.

Příklady

Příklad 2270. Basic Swish->getMetaList() example

<?php

try {

    $swish = new Swish("index.swish-e");
    var_dump($swish->getMetaList("index.swish-e"));

} catch (SwishException $e) {
    echo $e->getMessage(), "\n";
}

?>

Výše uvedený příklad vypíše něco jako:

array(1) {
  [0]=>
  array(3) {
    ["Name"]=>
    string(12) "swishdefault"
    ["Type"]=>
    int(0)
    ["ID"]=>
    int(1)
  }
}

Předcházející | Nahoru | Další
Swish::__construct | Domů | Swish->getPropertyList


Swish->getPropertyList

(PECL swish:0.1-0.3.0)

Swish->getPropertyList — Get the list of properties for the index

Popis

array Swish->getPropertyList ( string $index_name )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Seznam parametrů

index_name

The name of the index file.

Návratové hodnoty

Returns an array of properties for the given index.

Příklady

Příklad 2271. Basic Swish->getPropertyList() example

<?php

try {

    $swish = new Swish("index.swish-e");
    $properties = $swish->getPropertyList("index.swish-e");
    foreach ($properties as $prop) {
        echo $prop["Name"],"\n";
    }

} catch (SwishException $e) {
    echo $e->getMessage(), "\n";
}

?>

Výše uvedený příklad vypíše něco jako:

swishreccount
swishrank
swishfilenum
swishdbfile
swishdocpath
swishtitle
swishdocsize
swishlastmodified

Předcházející | Nahoru | Další
Swish->getMetaList | Domů | Swish->prepare


Swish->prepare

(PECL swish:0.1-0.3.0)

Swish->prepare — Prepare a search query

Popis

object Swish->prepare ( [string $query] )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Prepare and return a search object, which you can later use for unlimited number of queries.

Seznam parametrů

query

Optional query string. The query can be also set using SwishSearch->execute() method.

Návratové hodnoty

Returns SwishSearch object.

Errors/Exceptions

Throws SwishException on error.

Příklady

Příklad 2272. Basic Swish->prepare() example

<?php

try {

    $swish = new Swish("index.swish-e");
    $search = $swish->prepare("search query");
    $results = $search->execute();
    echo "Found: ", $results->hits, " hits\n";

    $results = $search->execute("new search");

    echo "Found: ", $results->hits, " hits\n";
} catch (SwishException $e) {
    echo $e->getMessage(), "\n";
}

?>

Výše uvedený příklad vypíše něco jako:

Found: 2 hits
Found: 5 hits

Předcházející | Nahoru | Další
Swish->getPropertyList | Domů | Swish->query


Swish->query

(PECL swish:0.1-0.3.0)

Swish->query — Execute a query and return results object

Popis

object Swish->query ( string $query )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

A quick method to execute a search with default parameters.

Seznam parametrů

query

Query string.

Návratové hodnoty

Returns SwishResults object.

Errors/Exceptions

Throws SwishException on error.

Příklady

Příklad 2273. Basic Swish->query() example

<?php

try {

    $swish = new Swish("index.swish-e");
    $results = $swish->query("test query");

    echo "Found: ", $results->hits, " hits\n";

} catch (SwishException $e) {
    echo $e->getMessage(), "\n";
}

?>

Výše uvedený příklad vypíše něco jako:

Found: 1 hits

Předcházející | Nahoru | Další
Swish->prepare | Domů | SwishResult->getMetaList


SwishResult->getMetaList

(PECL swish:0.1-0.3.0)

SwishResult->getMetaList — Get a list of meta entries

Popis

array SwishResult->getMetaList ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Návratové hodnoty

Returns the same array as swish->getmetalist(), but uses the index file from the result handle.

Předcházející | Nahoru | Další
Swish->query | Domů | SwishResult->stem


SwishResult->stem

(PECL swish:0.1-0.3.0)

SwishResult->stem — Stems the given word

Popis

array SwishResult->stem ( string $word )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Stems the word based on the fuzzy mode used during indexing. Each result object is linked with its index, so the results are based on this index.

Seznam parametrů

word

The word to stem.

Návratové hodnoty

Returns array containing the stemmed word variants (usually just one).

Errors/Exceptions

Throws SwishException on error.

Příklady

Příklad 2274. Basic () example

<?php

try {

    $swish = new Swish("ext/swish/tests/index.swish-e");
    $results = $swish->query("testing OR others");

    if ($result = $results->nextResult()) {
        var_dump($result->stem("testing")); //the results fully depend on the stemmer used in th index
        var_dump($result->stem("others"));
    }

} catch (SwishException $e) {
    echo "Error: ", $e->getMessage(), "\n";
}

?>

Výše uvedený příklad vypíše něco jako:

array(1) {
  [0]=>
  string(4) "test"
}
array(1) {
  [0]=>
  string(5) "other"
}

Předcházející | Nahoru | Další
SwishResult->getMetaList | Domů | SwishResults->getParsedWords


SwishResults->getParsedWords

(PECL swish:0.1-0.3.0)

SwishResults->getParsedWords — Get an array of parsed words

Popis

array SwishResults->getParsedWords ( string $index_name )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Seznam parametrů

indexi_name

The name of the index used to initialize Swish object.

Návratové hodnoty

An array of parsed words with stopwords removed. The list of parsed words may be useful for highlighting search terms in the results.

Příklady

Příklad 2275. Basic SwishResults->getParsedWords() example

<?php

try {

    $swish = new Swish("index.swish-e");
    $results = $swish->query("'some characters' and numbers");

    var_dump($results->getParsedWords("index.swish-e"));
    var_dump($results->indexes[0]['parsed_words']); //same result in a different way

} catch (SwishException $e) {
    echo "Error: ", $e->getMessage(), "\n";
}

?>

Výše uvedený příklad vypíše něco jako:

array(4) {
  [0]=>
  string(4) "some"
  [1]=>
  string(10) "characters"
  [2]=>
  string(3) "and"
  [3]=>
  string(7) "numbers"
}
array(4) {
  [0]=>
  string(4) "some"
  [1]=>
  string(10) "characters"
  [2]=>
  string(3) "and"
  [3]=>
  string(7) "numbers"
}

Předcházející | Nahoru | Další
SwishResult->stem | Domů | SwishResults->getRemovedStopwords


SwishResults->getRemovedStopwords

(PECL swish:0.1-0.3.0)

SwishResults->getRemovedStopwords — Get an array of stopwords removed from the query

Popis

array SwishResults->getRemovedStopwords ( string $index_name )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Seznam parametrů

index_name

The name of the index used to initialize Swish object.

Návratové hodnoty

Returns array of stopwords removed from the query.

Předcházející | Nahoru | Další
SwishResults->getParsedWords | Domů | SwishResults->nextResult


SwishResults->nextResult

(PECL swish:0.1-0.3.0)

SwishResults->nextResult — Get the next search result

Popis

object SwishResults->nextResult ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Návratové hodnoty

Returns the next SwishResult object in the result set or FALSE if there are no more results available.

Příklady

Příklad 2276. Basic SwishResults->nextResult() example

<?php

try {

    $swish = new Swish("index.swish-e");
    $search = $swish->prepare();

    $results = $search->execute("lost");
    while($result = $results->nextResult()) {
        /* do something with the result object */
    }

} catch (SwishException $e) {
    echo $e->getMessage(), "\n";
}

?>

Předcházející | Nahoru | Další
SwishResults->getRemovedStopwords | Domů | SwishResults->seekResult


SwishResults->seekResult

(PECL swish:0.1-0.3.0)

SwishResults->seekResult — Set current seek pointer to the given position

Popis

int SwishResults->seekResult ( int $position )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Seznam parametrů

position

Zero-based position number. Cannot be less than zero.

Návratové hodnoty

Returns new position value on success.

Errors/Exceptions

Throws SwishException on error.

Příklady

Příklad 2277. Basic SwishResults->seekResult() example

<?php

try {

    $swish = new Swish("index.swish-e");
    $search = $swish->prepare();

    $results = $search->execute("lost");

    var_dump($results->seekResult(0)); //this will succeed
    var_dump($results->seekResult(100)); //this will fail

} catch (SwishException $e) {
    echo "Error: ", $e->getMessage(), "\n";
}

?>

Výše uvedený příklad vypíše něco jako:

int(0)
Error: No more results

Předcházející | Nahoru | Další
SwishResults->nextResult | Domů | SwishSearch->execute


SwishSearch->execute

(PECL swish:0.1-0.3.0)

SwishSearch->execute — Execute the search and get the results

Popis

object SwishSearch->execute ( [string $query] )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Searches the index file(s) based on the parameters set in the search object.

Seznam parametrů

query

The query string is an optional parameter, it can be also set using Swish->prepare() method. The query string is preserved between executions, so you can set it once, but execute the search multiple times.

Návratové hodnoty

Returns SwishResults object.

Errors/Exceptions

Throws SwishException on error.

Příklady

Příklad 2278. Basic SwishSearch->execute() example

<?php

try {

    $swish = new Swish("index.swish-e");
    $search = $swish->prepare();

    $results = $search->execute("query");
    echo "First query found: ", $results->hits, " hits\n";

    $results = $search->execute("new OR query");
    echo "Second query found: ", $results->hits, " hits\n";

} catch (SwishException $e) {
    echo $e->getMessage(), "\n";
}

?>

Výše uvedený příklad vypíše něco jako:

First query found: 2 hits
Second query found: 12 hits

Předcházející | Nahoru | Další
SwishResults->seekResult | Domů | SwishSearch->resetLimit


SwishSearch->resetLimit

(PECL swish:0.1-0.3.0)

SwishSearch->resetLimit — Reset the search limits

Popis

void SwishSearch->resetLimit ( void )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Reset the search limits previous set by SwishSearch->setLimit.

Návratové hodnoty

Nevrací se žádná hodnota.

Příklady

Příklad 2279. Basic SwishSearch->resetLimit() example

<?php

try {

    $swish = new Swish("index.swish-e");
    $search = $swish->prepare();

    $results = $search->execute("time");
    echo "First query found: ", $results->hits, " hits\n";

    $search->setLimit("swishdocsize", "3000", "6000"); //limit by document size, from 3000 to 6000 bytes
    $results = $search->execute("time");
    echo "Second query found: ", $results->hits, " hits\n";

    $search->resetLimit();
    $results = $search->execute("time");
    echo "Third query found: ", $results->hits, " hits\n";

} catch (SwishException $e) {
    echo $e->getMessage(), "\n";
}

?>

Výše uvedený příklad vypíše něco jako:

First query found: 5 hits
Second query found: 2 hits
Third query found: 5 hits

Předcházející | Nahoru | Další
SwishSearch->execute | Domů | SwishSearch->setLimit


SwishSearch->setLimit

(PECL swish:0.1-0.3.0)

SwishSearch->setLimit — Set the search limits

Popis

void SwishSearch->setLimit ( string $property, string $low, string $high )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Seznam parametrů

property

Search result property name.

low

The lowest value of the property.

high

The highest value of the property.

Návratové hodnoty

Nevrací se žádná hodnota.

Errors/Exceptions

Throws SwishException on error.

Příklady

Příklad 2280. Basic SwishSearch->setLimit() example

<?php
try {

    $swish = new Swish("index.swish-e");
    $search = $swish->prepare();

    $results = $search->execute("time");
    echo "First query found: ", $results->hits, " hits\n";

    $i = 0;
    while($result = $results->nextResult()) {
        echo "Hit #", ++$i, " - ", $result->swishdocsize, " bytes\n";
    }

    $search->setLimit("swishdocsize", "3000", "6000"); //limit by document size, from 3000 to 6000 bytes
    $results = $search->execute("time");
    echo "Second query found: ", $results->hits, " hits\n";

    $i = 0;
    while($result = $results->nextResult()) {
        echo "Hit #", ++$i, " - ", $result->swishdocsize, " bytes\n";
    }

} catch (SwishException $e) {
    echo $e->getMessage(), "\n";
}

?>

Výše uvedený příklad vypíše něco jako:

First query found: 5 hits
Hit #1 - 4261 bytes
Hit #2 - 37937 bytes
Hit #3 - 7126 bytes
Hit #4 - 15427 bytes
Hit #5 - 4768 bytes
Second query found: 2 hits
Hit #1 - 4261 bytes
Hit #2 - 4768 bytes

Předcházející | Nahoru | Další
SwishSearch->resetLimit | Domů | SwishSearch->setPhraseDelimiter


SwishSearch->setPhraseDelimiter

(PECL swish:0.1-0.3.0)

SwishSearch->setPhraseDelimiter — Set the phrase delimiter

Popis

void SwishSearch->setPhraseDelimiter ( string $delimiter )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Seznam parametrů

delimiter

Phrase delimiter character. The default delimiter is double-quotes.

Návratové hodnoty

Nevrací se žádná hodnota.

Příklady

Příklad 2281. Basic SwishSearch->setPhraseDelimiter() example

<?php

try {

    $swish = new Swish("index.swish-e");
    $search = $swish->prepare();

    $results = $search->execute('"every time"'); //looking for "every time"
    echo "First query found: ", $results->hits, " hits\n";

    $search->setPhraseDelimiter("'");
    $results = $search->execute("'every time'"); //the same query, but using different delimiter
    echo "Second query found: ", $results->hits, " hits\n";

    $search->setPhraseDelimiter('"');
    $results = $search->execute("'every time'"); //looking for "every" and "time"
    echo "Third query found: ", $results->hits, " hits\n";

    //let's look at parsed words
    var_dump($results->getParsedWords("index.swish-e"));

} catch (SwishException $e) {
    echo $e->getMessage(), "\n";
}

?>

Výše uvedený příklad vypíše něco jako:

First query found: 1 hits
Second query found: 1 hits
Third query found: 2 hits
array(2) {
  [0]=>
  string(5) "every"
  [1]=>
  string(4) "time"
}

Předcházející | Nahoru | Další
SwishSearch->setLimit | Domů | SwishSearch->setSort


SwishSearch->setSort

(PECL swish:0.1-0.3.0)

SwishSearch->setSort — Set the sort order

Popis

void SwishSearch->setSort ( string $sort )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Seznam parametrů

sort

Sort order of the results is a string containing name of a result property combined with sort direction ("asc" or "desc"). Examples: "swishrank desc", "swishdocpath asc", "swishtitle asc", "swishdocsize desc", "swishlastmodified desc" etc.

Návratové hodnoty

Nevrací se žádná hodnota.

Příklady

Příklad 2282. Basic SwishSearch->setSort() example

<?php

try {

    $swish = new Swish("index.swish-e");
    $search = $swish->prepare();

    $results = $search->execute("time");
    echo "First query found: ", $results->hits, " hits\n";

    $i = 0;
    while($result = $results->nextResult()) {
        echo "Hit #", ++$i, " - ", $result->swishdocsize, " bytes\n";
    }

    $search->setSort("swishdocsize desc"); //sort by document size
    $results = $search->execute("time");
    echo "Second query found: ", $results->hits, " hits\n";

    $i = 0;
    while($result = $results->nextResult()) {
        echo "Hit #", ++$i, " - ", $result->swishdocsize, " bytes\n";
    }

} catch (SwishException $e) {
    echo $e->getMessage(), "\n";
}

?>

Výše uvedený příklad vypíše něco jako:

First query found: 5 hits
Hit #1 - 4261 bytes
Hit #2 - 37937 bytes
Hit #3 - 7126 bytes
Hit #4 - 15427 bytes
Hit #5 - 4768 bytes
Second query found: 5 hits
Hit #1 - 37937 bytes
Hit #2 - 15427 bytes
Hit #3 - 7126 bytes
Hit #4 - 4768 bytes
Hit #5 - 4261 bytes

Předcházející | Nahoru | Další
SwishSearch->setPhraseDelimiter | Domů | SwishSearch->setStructure


SwishSearch->setStructure

(PECL swish:0.1-0.3.0)

SwishSearch->setStructure — Set the structure flag in the search object

Popis

void SwishSearch->setStructure ( int $structure )
Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Seznam parametrů

structure

The structure flag a bitmask is used to limit search to certain parts of HTML documents (like title, meta, body etc.). Its possible values are listed below. To combine several values use bitwise OR operator, see example below.

  • Swish::IN_FILE

  • Swish::IN_TITLE

  • Swish::IN_HEAD

  • Swish::IN_BODY

  • Swish::IN_COMMENTS

  • Swish::IN_HEADER

  • Swish::IN_EMPHASIZED

  • Swish::IN_META

Návratové hodnoty

Nevrací se žádná hodnota.

Příklady

Příklad 2283. Basic SwishSearch->setStructure() example

<?php

try {

    $swish = new Swish("index.swish-e");
    $search = $swish->prepare();

    $results = $search->execute("time");
    echo "First query found: ", $results->hits, " hits\n";

    $search->setStructure(Swish::IN_TITLE|Swish::IN_HEAD); //search in title and head
    $results = $search->execute("time");
    echo "Second query found: ", $results->hits, " hits\n";

    $search->setStructure(Swish::IN_ALL); //search in whole document, the default value
    $results = $search->execute("time");
    echo "Third query found: ", $results->hits, " hits\n";

} catch (SwishException $e) {
    echo $e->getMessage(), "\n";
}

?>

Výše uvedený příklad vypíše něco jako:

First query found: 5 hits
Second query found: 0 hits
Third query found: 5 hits

Předcházející | Nahoru | Další
SwishSearch->setSort | Domů | CLXV. Sybase Functions


sys_get_temp_dir

(PHP 5 >= 5.2.1)

sys_get_temp_dir — Returns directory path used for temporary files

Popis

string sys_get_temp_dir ( void )

Returns the path of the directory PHP stores temporary files in by default.

Návratové hodnoty

Returns the path of the temporary directory.

Viz také

tmpfile()
tempnam()

Předcházející | Nahoru | Další
set_time_limit | Domů | version_compare


sys_getloadavg

(PHP 5 >= 5.1.3)

sys_getloadavg — Gets system load average

Popis

array sys_getloadavg ( void )

Returns three samples representing the average system load (the number of processes in the system run queue) over the last 1, 5 and 15 minutes, respectively.

Návratové hodnoty

Returns an array with three samples (last 1, 5 and 15 minutes).

Příklady

Příklad 1197. A sys_getloadavg() example

<?php
$load = sys_getloadavg();
if ($load[0] > 80) {
    header('HTTP/1.1 503 Too busy, try again later');
    die('Server too busy. Please try again later.');
}
?>

Poznámky

Poznámka: Tato funkce není implementována na platformách Windows.

Předcházející | Nahoru | Další
sleep | Domů | time_nanosleep


tidy_get_opt_doc

(PHP 5 >= 5.1.0)

tidy_get_opt_doc — Returns the documentation for the given option name

Popis

Procedural style:

string tidy_get_opt_doc ( tidy $object, string $optname )

Object oriented style:

string tidy->getOptDoc ( string $optname )

tidy_get_opt_doc() returns the documentation for the given option name.

Poznámka: You need at least libtidy from 25 April, 2005 for this function be available.

Seznam parametrů

object

A tidy object

optname

The option name

Návratové hodnoty

Returns a string if the option exists and has documentation available, or FALSE otherwise.

Příklady

Příklad 2308. Print all options along with their documentation and default value

<?php

$tidy = new tidy;
$config = $tidy->getConfig();

ksort($config);

foreach ($config as $opt => $val) {

    if (!$doc = $tidy->getOptDoc($opt))
        $doc = 'no documentation available!';

    $val = ($tidy->getOpt($opt) === true)  ? 'true'  : $val;
    $val = ($tidy->getOpt($opt) === false) ? 'false' : $val;

    echo "<p><b>$opt</b> (default: '$val')<br />".
         "$doc</p><hr />\n";
}

?>

Viz také

tidy_get_config()
tidy_getopt()

Předcházející | Nahoru | Další
tidy_get_html | Domů | tidy_get_output


tidyNode::getParent

(PHP 5 >= 5.2.2)

tidyNode::getParent — returns the parent node of the current node

Popis

tidyNode tidyNode::getParent ( void )

Returns the parent node of the current node.

Návratové hodnoty

Returns a tidyNode if the node has a parent, or NULL otherwise.

Předcházející | Nahoru | Další
tidyNode->isText | Domů | CLXVIII. Tokenizer Functions


tidyNode->hasChildren

(PHP 5 >= 5.0.1)

tidyNode->hasChildren — Returns true if this node has children

Description

bool tidyNode->hasChildren ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Poznámka: This function was named tidy_node->has_children() in PHP 4/Tidy 1.

Předcházející | Nahoru | Další
tidy_warning_count | Domů | tidyNode->hasSiblings


tidyNode->hasSiblings

(PHP 5 >= 5.0.1)

tidyNode->hasSiblings — Returns true if this node has siblings

Description

bool tidyNode->hasSiblings ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Poznámka: This function was named tidy_node->has_siblings() in PHP 4/Tidy 1.

Předcházející | Nahoru | Další
tidyNode->hasChildren | Domů | tidyNode->isAsp


tidyNode->isComment

(PHP 5 >= 5.0.1)

tidyNode->isComment — Returns true if this node represents a comment

Description

bool tidyNode->isComment ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Poznámka: This function was named tidy_node->is_comment() in PHP 4/Tidy 1.

Předcházející | Nahoru | Další
tidyNode->isAsp | Domů | tidyNode->isHtml


tidyNode->isHtml

(PHP 5 >= 5.0.1)

tidyNode->isHtml — Returns true if this node is part of a HTML document

Description

bool tidyNode->isHtml ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Poznámka: This function was named tidy_node->is_html() in PHP 4/Tidy 1.

Předcházející | Nahoru | Další
tidyNode->isComment | Domů | tidyNode->isJste


tidyNode->isJste

(PHP 5 >= 5.0.1)

tidyNode->isJste — Returns true if this node is JSTE

Description

bool tidyNode->isJste ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Poznámka: This function was named tidy_node->is_jste() in PHP 4/Tidy 1.

Předcházející | Nahoru | Další
tidyNode->isHtml | Domů | tidyNode->isPhp


tidyNode->isText

(PHP 5 >= 5.0.1)

tidyNode->isText — Returns true if this node represents text (no markup)

Description

bool tidyNode->isText ( void )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Poznámka: This function was named tidy_node->is_text() in PHP 4/Tidy 1.

Předcházející | Nahoru | Další
tidyNode->isPhp | Domů | tidyNode::getParent


time_sleep_until

(PHP 5 >= 5.1.0)

time_sleep_until — Make the script sleep until the specified time

Popis

bool time_sleep_until ( float $timestamp )

Makes the script sleep until the specified timestamp.

Seznam parametrů

timestamp

The timestamp when the script should wake.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Errors/Exceptions

If the specified timestamp is in the past, this function will generate a E_WARNING.

Příklady

Příklad 1199. A time_sleep_until() example

<?php

//returns false and generates a warning
var_dump(time_sleep_until(time()-1));

// may only work on faster computers, will sleep up to 0.2 seconds
var_dump(time_sleep_until(time()+0.2));

?>

Poznámky

Poznámka: All signals will be delivered after the script wakes up.

Poznámka: Tato funkce není implementována na platformách Windows.

Viz také

sleep()
usleep()
time_nanosleep()

Předcházející | Nahoru | Další
time_nanosleep | Domů | uniqid


timezone_abbreviations_list

(PHP 5 >= 5.1.0)

timezone_abbreviations_list — Returns associative array containing dst, offset and the timezone name

Popis

array timezone_abbreviations_list ( void )
array DateTimeZone::listAbbreviations ( void )

Návratové hodnoty

Returns array on success or FALSE on failure.

Příklady

Příklad 364. A timezone_abbreviations_list() example

<?php
$timezone_abbreviations = DateTimeZone::listAbbreviations();
print_r($timezone_abbreviations["acst"]);
?>

Výše uvedený příklad vypíše něco jako:

Array
(
    [0] => Array
        (
            [dst] => 1
            [offset] => -14400
            [timezone_id] => America/Porto_Acre
        )

    [1] => Array
        (
            [dst] => 1
            [offset] => -14400
            [timezone_id] => America/Eirunepe
        )

    [2] => Array
        (
            [dst] => 1
            [offset] => -14400
            [timezone_id] => America/Rio_Branco
        )

    [3] => Array
        (
            [dst] => 1
            [offset] => -14400
            [timezone_id] => Brazil/Acre
        )

)

Viz také

timezone_identifiers_list()

Předcházející | Nahoru | Další
time | Domů | timezone_identifiers_list


timezone_identifiers_list

(PHP 5 >= 5.1.0)

timezone_identifiers_list — Returns numerically index array with all timezone identifiers

Popis

array timezone_identifiers_list ( void )
array DateTimeZone::listIdentifiers ( void )

Návratové hodnoty

Returns array on success or FALSE on failure.

Příklady

Příklad 365. A timezone_identifiers_list() example

<?php
$timezone_identifiers = DateTimeZone::listIdentifiers();
for ($i=0; $i < 5; $i++) {
    echo "$timezone_identifiers[$i]\n";
}
?>

Výše uvedený příklad vypíše něco jako:

Africa/Abidjan
Africa/Accra
Africa/Addis_Ababa
Africa/Algiers
Africa/Asmera

Viz také

timezone_abbreviations_list()

Předcházející | Nahoru | Další
timezone_abbreviations_list | Domů | timezone_name_from_abbr


timezone_name_from_abbr

(PHP 5 >= 5.1.3)

timezone_name_from_abbr — Returns the timezone name from abbrevation

Popis

string timezone_name_from_abbr ( string $abbr [, int $gmtOffset [, int $isdst]] )

Seznam parametrů

abbr

Time zone abbreviation.

gmtOffset

Offset from GMT in seconds. Defaults to -1 which means that first found time zone corresponding to abbr is returned. Otherwise exact offset is searched and only if not found then the first time zone with any offset is returned.

isdst

Daylight saving time indicator. If abbr doesn't exist then the time zone is searched solely by offset and isdst.

Návratové hodnoty

Returns time zone name on success or FALSE on failure.

Příklady

Příklad 366. A timezone_name_from_abbr() example

<?php
echo timezone_name_from_abbr("CET") . "\n";
echo timezone_name_from_abbr("", 3600, 0) . "\n";
?>

Výše uvedený příklad vypíše něco jako:

Europe/Berlin
Europe/Paris

Viz také

timezone_abbreviations_list()

Předcházející | Nahoru | Další
timezone_identifiers_list | Domů | timezone_name_get


timezone_name_get

(PHP 5 >= 5.1.0)

timezone_name_get — Returns the name of the timezone

Popis

string timezone_name_get ( DateTimeZone $object )
string DateTimeZone::getName ( void )

Seznam parametrů

object

DateTimeZone object.

Návratové hodnoty

Returns time zone name on success or FALSE on failure.

Předcházející | Nahoru | Další
timezone_name_from_abbr | Domů | timezone_offset_get


timezone_offset_get

(PHP 5 >= 5.1.0)

timezone_offset_get — Returns the timezone offset from GMT

Popis

int timezone_offset_get ( DateTimeZone $object, DateTime $datetime )
int DateTimeZone::getOffset ( DateTime $datetime )

This function returns the offset to GMT for the date/time specified in the datetime parameter. The GMT offset is calculated with the timezone information contained in the DateTime object being used.

Seznam parametrů

object

DateTimeZone object.

datetime

DateTime that contains the date/time to compute the offset from.

Návratové hodnoty

Returns time zone offset in seconds on success or FALSE on failure.

Příklady

Příklad 367. timezone_offset_get() examples

<?php
// Create two timezone objects, one for Taipei (Taiwan) and one for
// Tokyo (Japan)
$dateTimeZoneTaipei = new DateTimeZone("Asia/Taipei");
$dateTimeZoneJapan = new DateTimeZone("Asia/Tokyo");

// Create two DateTime objects that will contain the same Unix timestamp, but
// have different timezones attached to them.
$dateTimeTaipei = new DateTime("now", $dateTimeZoneTaipei);
$dateTimeJapan = new DateTime("now", $dateTimeZoneJapan);

// Calculate the GMT offset for the date/time contained in the $dateTimeTaipei
// object, but using the timezone rules as defined for Tokyo
// ($dateTimeZoneJapan).
$timeOffset = $dateTimeZoneJapan->getOffset($dateTimeTaipei);

// Should show int(32400) (for dates after Sat Sep 8 01:00:00 1951 JST).
var_dump($timeOffset);
?>

Předcházející | Nahoru | Další
timezone_name_get | Domů | timezone_open


timezone_open

(PHP 5 >= 5.1.0)

timezone_open — Returns new DateTimeZone object

Popis

DateTimeZone timezone_open ( string $timezone )
DateTimeZone DateTimeZone::__construct ( string $timezone )

Seznam parametrů

timezone

Time zone identifier as full name (e.g. Europe/Prague) or abbreviation (e.g. CET).

Návratové hodnoty

Returns DateTimeZone object on success or FALSE on failure.

Předcházející | Nahoru | Další
timezone_offset_get | Domů | timezone_transitions_get


timezone_transitions_get

(PHP 5 >= 5.2.0)

timezone_transitions_get — Returns all transitions for the timezone

Popis

array timezone_transitions_get ( DateTimeZone $object )
array DateTimeZone::getTransitions ( void )

Seznam parametrů

object

DateTimeZone object.

Návratové hodnoty

Returns numerically indexed array containing associative array with all transitions on success or FALSE on failure.

Příklady

Příklad 368. A timezone_transitions_get() example

<?php
$timezone = new DateTimeZone("CET");
print_r(reset($timezone->getTransitions()));
?>

Výše uvedený příklad vypíše něco jako:

Array
(
    [ts] => -1693706400
    [time] => 1916-04-30T22:00:00+0000
    [offset] => 7200
    [isdst] => 1
    [abbr] => CEST
)

Předcházející | Nahoru | Další
timezone_open | Domů | XXIV. DB++ Functions


unicode_decode

(No version information available, might be only in CVS)

unicode_decode — Convert a binary string into a Unicode string

Popis

unicode unicode_decode ( string $input, string $encoding [, int $errmode] )

Convert a binary string encoded in encoding to a unicode string.

Seznam parametrů

input

Try string that is converted.

encoding

The encoding of input.

errmode

Conversion error mode. This parameter determines the action to take when the converter cannot convert a character. For a list of available modes, refer to unicode_set_error_mode(). If the parameter is not set, the global error mode is used.

Návratové hodnoty

A unicode string or FALSE on failure.

Errors/Exceptions

Emits a E_WARNING level error if a converter cannot be created for the desired encoding.

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Viz také

unicode_set_error_mode()
unicode_semantics()
unicode_encode()

Předcházející | Nahoru | Další
CLXIX. Unicode Functions | Domů | unicode_encode


unicode_encode

(No version information available, might be only in CVS)

unicode_encode — Convert a unicode string in any encoding

Popis

string unicode_encode ( unicode $input, string $encoding [, int $errmode] )

Takes a unicode string and converts it to a string in the specified encoding.

Seznam parametrů

input

The unicode string that is converted.

encoding

The new encoding for input.

errmode

Conversion error mode. This parameter determines the action to take when the converter cannot convert a character. For a list of available modes, refer to unicode_set_error_mode(). If the parameter is not set, the global error mode is used.

Návratové hodnoty

A string on success, or FALSE on failure.

Errors/Exceptions

Emits a E_WARNING level error if a converter cannot be created for the desired encoding.

Příklady

Příklad 2324. A unicode_encode() example

Note: The characters will be seen instead of entities in the output.

<?php
header ('Content-Type: text/plain; charset=ISO-8859-2');

$encoded = unicode_encode ('\u0150\u0179', 'ISO-8859-2');

echo 'Unicode semantics: ', ini_get ('unicode_semantics'), PHP_EOL;
echo 'The string itself:', $encoded, PHP_EOL;
echo 'The length of the string: ', strlen ($encoded);
?>

Výše uvedený příklad vypíše něco jako:

Unicode semantics: 1
The string itself: &#336;&#377;
The length of the string: 2

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Viz také

unicode_set_error_mode()
unicode_semantics()
unicode_decode()

Předcházející | Nahoru | Další
unicode_decode | Domů | unicode_get_error_mode


unicode_get_error_mode

(No version information available, might be only in CVS)

unicode_get_error_mode — Get the error mode for strings conversions

Popis

int unicode_get_error_mode ( int $direction )

Return the current error mode for string conversions in direction.

Seznam parametrů

direction

Get the error mode for conversion direction. This can either be FROM_UNICODE or TO_UNICODE. See unicode_set_error_mode() for more details.

Návratové hodnoty

This function returns one of the error mode constants or FALSE on failure.

Errors/Exceptions

Emits a E_WARNING level error if direction is invalid.

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Viz také

unicode_set_error_mode()
unicode_encode()
unicode_decode()

Předcházející | Nahoru | Další
unicode_encode | Domů | unicode_get_subst_char


unicode_get_subst_char

(No version information available, might be only in CVS)

unicode_get_subst_char — Get the substitution character for string conversion errors

Popis

unicode unicode_get_subst_char ( void )

Return the substitution character for string conversion errors set by unicode_set_subst_char().

Návratové hodnoty

The unicode substitution character is returned.

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Viz také

unicode_set_error_mode()
unicode_set_subst_char()

Předcházející | Nahoru | Další
unicode_get_error_mode | Domů | unicode_semantics


unicode_semantics

(No version information available, might be only in CVS)

unicode_semantics — Check whether unicode semantics is enabled

Popis

bool unicode_semantics ( void )

unicode_semantics() checks whether unicode semantics is enabled.

Návratové hodnoty

Returns TRUE or FALSE.

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Viz také

unicode_encode()
unicode_decode()

Předcházející | Nahoru | Další
unicode_get_subst_char | Domů | unicode_set_error_mode


unicode_set_error_mode

(No version information available, might be only in CVS)

unicode_set_error_mode — Set the error mode for strings conversions

Popis

bool unicode_set_error_mode ( int $direction, int $mode )

This function sets the error mode for string conversions between different encodings. An error can occur during conversion when an illegal character is encountered or if a character cannot be represented into the new encoding. By default, when an error is encountered, the conversion stops.

Seznam parametrů

direction

The direction sets the conversion direction to which the error mode will apply. This can either be FROM_UNICODE, which will set the error mode for conversions from a unicode string to a binary string or TO_UNICODE, which will set the error mode for conversions from a binary string to a unicode string.

mode

mode determines how the conversion errors are handled. It should be one of the following constants:

Tabulka 313. Available modes

Mode | Description
U_CONV_ERROR_STOP | Stop the conversion. This is the default mode.
U_CONV_ERROR_SKIP | Skip the character.
U_CONV_ERROR_SUBST | Substitute the character. The substituting character can be set with unicode_set_subst_char().
U_CONV_ERROR_ESCAPE_UNICODE | Escape the faulty bytes and represent them in the Unicode character format.
U_CONV_ERROR_ESCAPE_ICU | Escape the faulty bytes and represent them in the ICU character format.
U_CONV_ERROR_ESCAPE_JAVA | Escape the faulty bytes and print them in the Java character format.
U_CONV_ERROR_ESCAPE_XML_DEC | Escape the faulty bytes and represent them in decimal format.
U_CONV_ERROR_ESCAPE_XML_HEX | Escape the faulty bytes and represent them in hexadecimal format.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Errors/Exceptions

Emits a E_WARNING level error if the direction or the mode are invalid.

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Viz také

unicode_encode()
unicode_decode()

Předcházející | Nahoru | Další
unicode_semantics | Domů | unicode_set_subst_char


unicode_set_subst_char

(No version information available, might be only in CVS)

unicode_set_subst_char — Set the substitution character for string conversion errors

Popis

bool unicode_set_subst_char ( unicode $character )

When converting a string from or to unicode, an invalid or unconvertable character may be encountered. When the conversion error mode is set to U_CONV_ERROR_SUBST, the character that caused the error is substituted by a character set by this function. The default substitution character is ?.

Seznam parametrů

character

The substitution character to use.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Errors/Exceptions

Emits a E_WARNING level error if character is invalid.

Poznámky

Varování

Tato funkce je EXPERIMENTÁLNÍ. Chování této funkce, její název a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může BEZ OHLÁŠENÍ změnit. Berte to v úvahu a používejte tuto funkci na vlastní nebezpečí.

Viz také

unicode_set_error_mode()
unicode_get_error_mode()
unicode_encode()
unicode_decode()

Předcházející | Nahoru | Další
unicode_set_error_mode | Domů | CLXX. URL funkce


use_soap_error_handler

(PHP 5)

use_soap_error_handler — Set whether to use the SOAP error handler and return the former value

Popis

bool use_soap_error_handler ( [bool $handler] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Předcházející | Nahoru | Další
SoapVar->__construct() | Domů | CLIV. Socket Functions


wddx_unserialize

(No version information available, might be only in CVS)

wddx_unserialize — Unserializes a WDDX packet

Popis

mixed wddx_unserialize ( string $packet )

Unserializes a WDDX packet.

Seznam parametrů

packet

A WDDX packet, as a string or stream.

Návratové hodnoty

Returns the unserialized value which can be a string, a number or an array. Note that structures are unserialized into associative arrays.

Předcházející | Nahoru | Další
wddx_serialize_vars | Domů | CLXXVI. win32ps Functions


win32_create_service

(No version information available, might be only in CVS)

win32_create_service — Creates a new service entry in the SCM database

Popis

mixed win32_create_service ( array $details [, string $machine] )

Seznam parametrů

details

An array of service details:

service

The short name of the service. This is the name that you will use to control the service using the net command. The service must be unique (no two services can share the same name), and, ideally, should avoid having spaces in the name.

display

The display name of the service. This is the name that you will see in the Services Applet.

user

The name of the user account under which you want the service to run. If omitted, the service will run as the LocalSystem account. If the username is specified, you must also provide a password.

password

The password that corresponds to the user.

path

The full path to the executable module that will be launched when the service is started. If omitted, the path to the current PHP process will be used.

params

Command line parameters to pass to the service when it starts. If you want to run a PHP script as the service, then the first parameter should be the full path to the PHP script that you intend to run.

load_order

Controls the load_order. This is not yet fully supported.

svc_type

Sets the service type. If omitted, the default value is WIN32_SERVICE_WIN32_OWN_PROCESS. Don't change this unless you know what you're doing.

start_type

Specifies how the service should be started. The default is WIN32_SERVICE_AUTO_START which means the the service will be launched when the machine starts up.

error_control

Informs the SCM what it should do when it detects a problem with the service. The default is WIN32_SERVER_ERROR_IGNORE. Changing this value is not yet fully supported.

machine

The optional machine name on which you want to create a service. If omitted, it will use the local machine.

Návratové hodnoty

Returns TRUE on success, otherwise returns a win32 error code.

Příklady

Příklad 2376. A win32_create_service() example

Any text that describes the purpose of the example, or what goes on in the example should go here (inside the <?php
$x = win32_create_service(array(
        'service' => 'dummyphp',
        'display' => 'sample dummy PHP service',
        'params' => __FILE__ . ' run',
));
debug_zval_dump($x);
?>

Viz také

win32_delete_service()

Předcházející | Nahoru | Další
CLXXVII. win32service Functions | Domů | win32_delete_service


win32_delete_service

(No version information available, might be only in CVS)

win32_delete_service — Deletes a service entry from the SCM database

Popis

int win32_delete_service ( string $servicename [, string $machine] )

Attempts to delete a service from the SCM database. Administrative privileges are required for this to succeed.

This function really just marks the service for deletion. If other processes (such as the Services Applet) are open, then the deletion will be deferred until those applications are closed. If a service is marked for deletion, further attempts to delete it will fail, and attempts to create a new service with that name will also fail.

Seznam parametrů

servicename

The short name of the service.

machine

The optional machine name. If omitted, the local machine will be used.

Návratové hodnoty

Returns TRUE on success, or a win32 error code on failure.

Příklady

Příklad 2377. A win32_delete_service() example

Deletes the dummyphp service.

<?php
win32_delete_service('dummyphp');
?>

Předcházející | Nahoru | Další
win32_create_service | Domů | win32_get_last_control_message


win32_get_last_control_message

(No version information available, might be only in CVS)

win32_get_last_control_message — Returns the last control message that was sent to this service

Popis

int win32_get_last_control_message ( void )

Returns the control code that was last sent to this service process. When running as a service you should periodically check this to determine if your service needs to stop running.

Návratové hodnoty

Returns a control constant; one of WIN32_SERVICE_CONTROL_CONTINUE, WIN32_SERVICE_CONTROL_INTERROGATE, WIN32_SERVICE_CONTROL_PAUSE, WIN32_SERVICE_CONTROL_STOP, WIN32_SERVICE_CONTROL_HARDWAREPROFILECHANGE, WIN32_SERVICE_CONTROL_POWEREVENT, WIN32_SERVICE_CONTROL_SESSIONCHANGE.

Viz také

win32_start_service_ctrl_dispatcher()

Předcházející | Nahoru | Další
win32_delete_service | Domů | win32_query_service_status


win32_ps_list_procs

(PECL win32ps:1.0.1)

win32_ps_list_procs — List running processes

Popis

array win32_ps_list_procs ( void )

Retrieves statistics about all running processes.

Návratové hodnoty

Returns FALSE on failure, or an array consisting of process statistics like win32_ps_stat_proc() returns for all running processes on success.

Viz také

win32_ps_stat_proc()

Předcházející | Nahoru | Další
CLXXVI. win32ps Functions | Domů | win32_ps_stat_mem


win32_ps_stat_mem

(PECL win32ps:1.0.1)

win32_ps_stat_mem — Stat memory utilization

Popis

array win32_ps_stat_mem ( void )

Retrieves statistics about the global memory utilization.

Návratové hodnoty

Returns FALSE on failure, or an array consisting of the following information on success:

load

The current memory load in percent of physical memory.

unit

This is always 1024, and indicates that the following values are the count of 1024 bytes.

total_phys

The amount of total physical memory.

avail_phys

The amount of still available physical memory.

total_pagefile

The amount of total pageable memory (physical memory + paging file).

avail_pagefile

The amount of still available pageable memory (physical memory + paging file).

total_virtual

The amount of total virtual memory for a process.

avail_virtual

The amount of still available virtual memory for a process.

Předcházející | Nahoru | Další
win32_ps_list_procs | Domů | win32_ps_stat_proc


win32_ps_stat_proc

(PECL win32ps:1.0.1)

win32_ps_stat_proc — Stat process

Popis

array win32_ps_stat_proc ( [int $pid] )

Retrieves statistics about the process with the process id pid.

Seznam parametrů

pid

The process id of the process to stat. If omitted, the id of the current process.

Návratové hodnoty

Returns FALSE on failure, or an array consisting of the following information on success:

pid

The process id.

exe

The path to the executable image.

mem

An array containing information about the following memory utilization indicators: page_fault_count, peak_working_set_size, working_set_size, quota_peak_paged_pool_usage, quota_paged_pool_usage, quota_peak_non_paged_pool_usage, quota_non_paged_pool_usage, pagefile_usage and peak_pagefile_usage.

tms

An array containing information about the following CPU time utilization indicators: created, kernel and user.

Viz také

win32_ps_list_procs()

Předcházející | Nahoru | Další
win32_ps_stat_mem | Domů | CLXXVII. win32service Functions


win32_query_service_status

(No version information available, might be only in CVS)

win32_query_service_status — Queries the status of a service

Popis

mixed win32_query_service_status ( string $servicename [, string $machine] )

Queries the current status for a service, returning an array of information.

Seznam parametrů

servicename

The short name of the service.

machine

The optional machine name. If omitted, the local machine will be used.

Návratové hodnoty

Returns FALSE on failure, otherwise returns an array consisting of the following information:

ServiceType

The dwServiceType.

CurrentState

The dwCurrentState.

ControlsAccepted

Which service controls are accepted by the service.

Win32ExitCode

If the service exited, the return code from the process.

ServiceSpecificExitCode

If the service exited with an error condition, the service specific code that is logged in the event log is visible here.

CheckPoint

If the service is shutting down, holds the current check point number. This is used by the SCM as a kind of heart-beat to detect a wedged service process. The value of the check point is best interpreted in conjunction with the WaitHint value.

WaitHint

If the service is shutting down it will set WaitHint to a checkpoint value that will indicate 100% completion. This can be used to implement a progress indicator.

ProcessId

The Windows process identifier. If 0, the process is not running.

ServiceFlags

The dwServiceFlags.

Předcházející | Nahoru | Další
win32_get_last_control_message | Domů | win32_set_service_status


win32_set_service_status

(No version information available, might be only in CVS)

win32_set_service_status — Update the service status

Popis

bool win32_set_service_status ( int $status )

Informs the SCM of the current status of a running service. This call is only valid for a running service process.

Seznam parametrů

status

The service status code, one of WIN32_SERVICE_RUNNING, WIN32_SERVICE_STOPPED, WIN32_SERVICE_STOP_PENDING, WIN32_SERVICE_START_PENDING, WIN32_SERVICE_CONTINUE_PENDING, WIN32_SERVICE_PAUSE_PENDING, WIN32_SERVICE_PAUSED.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

win32_start_service_ctrl_dispatcher()

Předcházející | Nahoru | Další
win32_query_service_status | Domů | win32_start_service_ctrl_dispatcher


win32_start_service

(No version information available, might be only in CVS)

win32_start_service — Starts a service

Popis

int win32_start_service ( string $servicename [, string $machine] )

Attempts to start the named service. Usually requires administrative privileges.

Seznam parametrů

servicename

The short name of the service.

machine

Optional machine name. If omitted, the local machine is used.

Návratové hodnoty

Returns WIN32_NO_ERROR on success, or some other win32 error code on failure.

Viz také

win32_stop_service()

Předcházející | Nahoru | Další
win32_start_service_ctrl_dispatcher | Domů | win32_stop_service


win32_start_service_ctrl_dispatcher

(No version information available, might be only in CVS)

win32_start_service_ctrl_dispatcher — Registers the script with the SCM, so that it can act as the service with the given name

Popis

mixed win32_start_service_ctrl_dispatcher ( string $name )

When launched via the Service Control Manager, a service process is required to "check-in" with it to establish service monitoring and communication facilities. This function performs the check-in by spawning a thread to handle the lower-level communication with the service control manager.

Once started, the service process should continue to check-in with the service control manager so that it can determine if it should terminate. This is achieved by periodically calling win32_get_last_control_message() and handling the return code appropriately.

Seznam parametrů

name

The short-name of the service, as registered by win32_create_service().

Návratové hodnoty

Returns TRUE on success, otherwise FALSE or a win32 error code.

Příklady

Příklad 2378. A win32_start_service_ctrl_dispatcher() example

Any text that describes the purpose of the example, or what goes on in the example should go here (inside the

<?php
if (!win32_start_service_ctrl_dispatcher('dummyphp')) {
  die("I'm probably not running under the service control manager");
}

while (WIN32_SERVICE_CONTROL_STOP != win32_get_last_control_message()) {
  # do some work here, trying not to take more than around 30 seconds
  # before coming back into the loop again
}
?>

Viz také

win32_get_last_control_message()

Předcházející | Nahoru | Další
win32_set_service_status | Domů | win32_start_service


win32_stop_service

(No version information available, might be only in CVS)

win32_stop_service — Stops a service

Popis

int win32_stop_service ( string $servicename [, string $machine] )

Stops a named service. Requires administrative privileges.

Seznam parametrů

servicename

The short name of the service.

machine

Optional machine name. If omitted, the local machine is used.

Návratové hodnoty

Returns WIN32_NO_ERROR on success, or a win32 error code on failure.

Viz také

win32_start_service()

Předcházející | Nahoru | Další
win32_start_service | Domů | CLXXVIII. xattr Functions


XMLReader::close

(PHP 5 >= 5.1.2)

XMLReader::close — Close the XMLReader input

Popis

class XMLReader {
bool close ( void )
}

Closes the input the XMLReader object is currently parsing.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

XMLReader::open
XMLReader::XML

Předcházející | Nahoru | Další
CLXXXII. XMLReader functions | Domů | XMLReader::expand


XMLReader::expand

(PHP 5 >= 5.1.2)

XMLReader::expand — Returns a copy of the current node as a DOM object

Popis

class XMLReader {
DOMNode expand ( void )
}

This method copies the current node and returns the appropriate DOM object.

Návratové hodnoty

The resulting DOMNode or FALSE on error.

Předcházející | Nahoru | Další
XMLReader::close | Domů | XMLReader::getAttribute


XMLReader::getAttribute

(PHP 5 >= 5.1.2)

XMLReader::getAttribute — Get the value of a named attribute

Popis

class XMLReader {
string getAttribute ( string $name )
}

Returns the value of a named attribute or an empty string if attribute does not exist or not positioned on an element node.

Seznam parametrů

name

The name of the attribute.

Návratové hodnoty

The value of the attribute, or an empty string if no attribute with the given name is found or not positioned of element.

Viz také

XMLReader::getAttributeNo
XMLReader::getAttributeNs

Předcházející | Nahoru | Další
XMLReader::expand | Domů | XMLReader::getAttributeNo


XMLReader::getAttributeNo

(PHP 5 >= 5.1.2)

XMLReader::getAttributeNo — Get the value of an attribute by index

Popis

class XMLReader {
string getAttributeNo ( int $index )
}

Returns the value of an attribute based on its position or an empty string if attribute does not exist or not positioned on an element node.

Seznam parametrů

index

The position of the attribute.

Návratové hodnoty

The value of the attribute, or an empty string if no attribute exists at index or not positioned of element.

Viz také

XMLReader::getAttribute
XMLReader::getAttributeNs

Předcházející | Nahoru | Další
XMLReader::getAttribute | Domů | XMLReader::getAttributeNs


XMLReader::getAttributeNs

(PHP 5 >= 5.1.2)

XMLReader::getAttributeNs — Get the value of an attribute by localname and URI

Popis

class XMLReader {
string getAttributeNs ( string $localName, string $namespaceURI )
}

Returns the value of an attribute by name and namespace URI or an empty string if attribute does not exist or not positioned on an element node.

Seznam parametrů

localName

The local name.

namespaceURI

The namespace URI.

Návratové hodnoty

The value of the attribute, or an empty string if no attribute with the given localName and namespaceURI is found or not positioned of element.

Viz také

XMLReader::getAttribute
XMLReader::getAttributeNo

Předcházející | Nahoru | Další
XMLReader::getAttributeNo | Domů | XMLReader::getParserProperty


XMLReader::getParserProperty

(PHP 5 >= 5.1.2)

XMLReader::getParserProperty — Indicates if specified property has been set

Popis

class XMLReader {
bool getParserProperty ( int $property )
}

Indicates if specified property has been set.

Seznam parametrů

property

One of the parser option constants.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

XMLReader::setParserProperty

Předcházející | Nahoru | Další
XMLReader::getAttributeNs | Domů | XMLReader::isValid


XMLReader::isValid

(PHP 5 >= 5.1.2)

XMLReader::isValid — Indicates if the parsed document is valid

Popis

class XMLReader {
bool isValid ( void )
}

Returns a boolean indicating if the document being parsed is currently valid.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

XMLReader::setParserProperty
XMLReader::setRelaxNGSchema
XMLReader::setRelaxNGSchemaSource

Předcházející | Nahoru | Další
XMLReader::getParserProperty | Domů | XMLReader::lookupNamespace


XMLReader::lookupNamespace

(PHP 5 >= 5.1.2)

XMLReader::lookupNamespace — Lookup namespace for a prefix

Popis

class XMLReader {
bool lookupNamespace ( string $prefix )
}

Lookup in scope namespace for a given prefix.

Seznam parametrů

prefix

String containing the prefix.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
XMLReader::isValid | Domů | XMLReader::moveToAttribute


XMLReader::moveToAttribute

(PHP 5 >= 5.1.2)

XMLReader::moveToAttribute — Move cursor to a named attribute

Popis

class XMLReader {
bool moveToAttribute ( string $name )
}

Positions cursor on the named attribute.

Seznam parametrů

name

The name of the attribute.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

XMLReader::moveToElement
XMLReader::moveToAttributeNo
XMLReader::moveToAttributeNs
XMLReader::moveToFirstAttribute

Předcházející | Nahoru | Další
XMLReader::lookupNamespace | Domů | XMLReader::moveToAttributeNo


XMLReader::moveToAttributeNo

(PHP 5 >= 5.1.2)

XMLReader::moveToAttributeNo — Move cursor to an attribute by index

Popis

class XMLReader {
bool moveToAttributeNo ( int $index )
}

Positions cursor on attribute based on its position.

Seznam parametrů

index

The position of the attribute.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

XMLReader::moveToElement
XMLReader::moveToAttribute
XMLReader::moveToAttributeNs
XMLReader::moveToFirstAttribute

Předcházející | Nahoru | Další
XMLReader::moveToAttribute | Domů | XMLReader::moveToAttributeNs


XMLReader::moveToAttributeNs

(PHP 5 >= 5.1.2)

XMLReader::moveToAttributeNs — Move cursor to a named attribute

Popis

class XMLReader {
bool moveToAttributeNs ( string $localName, string $namespaceURI )
}

Positions cursor on the named attribute in specified namespace.

Seznam parametrů

localName

The local name.

namespaceURI

The namespace URI.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

XMLReader::moveToElement
XMLReader::moveToAttribute
XMLReader::moveToAttributeNo
XMLReader::moveToFirstAttribute

Předcházející | Nahoru | Další
XMLReader::moveToAttributeNo | Domů | XMLReader::moveToElement


XMLReader::moveToElement

(PHP 5 >= 5.1.2)

XMLReader::moveToElement — Position cursor on the parent Element of current Attribute

Popis

class XMLReader {
bool moveToElement ( void )
}

Moves cursor to the parent Element of current Attribute.

Návratové hodnoty

Returns TRUE if successful and FALSE if it fails or not positioned on Attribute when this method is called.

Viz také

XMLReader::moveToAttribute
XMLReader::moveToAttributeNo
XMLReader::moveToAttributeNs
XMLReader::moveToFirstAttribute

Předcházející | Nahoru | Další
XMLReader::moveToAttributeNs | Domů | XMLReader::moveToFirstAttribute


XMLReader::moveToFirstAttribute

(PHP 5 >= 5.1.2)

XMLReader::moveToFirstAttribute — Position cursor on the first Attribute

Popis

class XMLReader {
bool moveToFirstAttribute ( void )
}

Moves cursor to the first Attribute.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

XMLReader::moveToElement
XMLReader::moveToAttribute
XMLReader::moveToAttributeNo
XMLReader::moveToAttributeNs
XMLReader::moveToNextAttribute

Předcházející | Nahoru | Další
XMLReader::moveToElement | Domů | XMLReader::moveToNextAttribute


XMLReader::moveToNextAttribute

(PHP 5 >= 5.1.2)

XMLReader::moveToNextAttribute — Position cursor on the next Attribute

Popis

class XMLReader {
bool moveToNextAttribute ( void )
}

Moves cursor to the next Attribute if positioned on an Attribute or moves to first attribute if positioned on an Element.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

XMLReader::moveToElement
XMLReader::moveToAttribute
XMLReader::moveToAttributeNo
XMLReader::moveToAttributeNs
XMLReader::moveToFirstAttribute

Předcházející | Nahoru | Další
XMLReader::moveToFirstAttribute | Domů | XMLReader::next


XMLReader::next

(PHP 5 >= 5.1.2)

XMLReader::next — Move cursor to next node skipping all subtrees

Popis

class XMLReader {
bool next ( [string $localname] )
}

Positions cursor on the next node skipping all subtrees.

Seznam parametrů

localname

The name of the next node to move to.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

XMLReader::next
XMLReader::moveToElement
XMLReader::moveToAttribute

Předcházející | Nahoru | Další
XMLReader::moveToNextAttribute | Domů | XMLReader::open


XMLReader::open

(PHP 5 >= 5.1.2)

XMLReader::open — Set the URI containing the XML to parse

Popis

class XMLReader {
bool open ( string $URI [, string $encoding [, int $options]] )
}

Set the URI containing the XML document to be parsed.

Seznam parametrů

URI

URI pointing to the document.

encoding

The document encoding or NULL.

options

A bitmask of the XMLReader Options constants.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

ChangeLog (záznam změn)

Verze | Popis
5.2.0 | encoding and options were added.

Viz také

XMLReader::XML
XMLReader::close

Předcházející | Nahoru | Další
XMLReader::next | Domů | XMLReader::read


XMLReader::read

(PHP 5 >= 5.1.2)

XMLReader::read — Move to next node in document

Popis

class XMLReader {
bool read ( void )
}

Moves cursor to the next node in the document.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

XMLReader::moveToElement
XMLReader::moveToAttribute
XMLReader::next

Předcházející | Nahoru | Další
XMLReader::open | Domů | XMLReader::setParserProperty


XMLReader::setParserProperty

(PHP 5 >= 5.1.2)

XMLReader::setParserProperty — Set or Unset parser options

Popis

class XMLReader {
bool setParserProperty ( int $property, bool $value )
}

Set or Unset parser option for the parser. The options must be set
after xmlreader-open() or
xmlreader-xml() are called and before
the first xmlreader-read() call.

Seznam parametrů

property

One of the parser option constants.

value

If set to TRUE the option will be enabled otherwise will be disabled.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
XMLReader::read | Domů | XMLReader::setRelaxNGSchema


XMLReader::setRelaxNGSchema

(PHP 5 >= 5.2.0)

XMLReader::setRelaxNGSchema — Set the filename or URI for a RelaxNG Schema

Popis

class XMLReader {
bool setRelaxNGSchema ( string $filename )
}

Set the filename or URI for the RelaxNG Schema to use for validation.

Seznam parametrů

filename

filename or URI pointing to a RelaxNG Schema.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

XMLReader::setRelaxNGSchemaSource

Předcházející | Nahoru | Další
XMLReader::setParserProperty | Domů | XMLReader::setRelaxNGSchemaSource


XMLReader::setRelaxNGSchemaSource

(PHP 5 >= 5.1.2)

XMLReader::setRelaxNGSchemaSource — Set the data containing a RelaxNG Schema

Popis

class XMLReader {
bool setRelaxNGSchemaSource ( string $source )
}

Set the data containing a RelaxNG Schema to use for validation.

Seznam parametrů

source

String containing the RelaxNG Schema.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

XMLReader::setRelaxNGSchema

Předcházející | Nahoru | Další
XMLReader::setRelaxNGSchema | Domů | XMLReader::XML


XMLReader::XML

(PHP 5 >= 5.1.2)

XMLReader::XML — Set the data containing the XML to parse

Popis

class XMLReader {
bool xml ( string $source [, string $encoding [, int $options]] )
}

Set the data containing the XML to parse.

Seznam parametrů

source

String containing the XML to be parsed.

encoding

The document encoding or NULL.

options

A bitmask of the XMLReader Options constants.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

ChangeLog (záznam změn)

Verze | Popis
5.2.0 | encoding and options were added.

Viz také

XMLReader::open
XMLReader::close

Předcházející | Nahoru | Další
XMLReader::setRelaxNGSchemaSource | Domů | CLXXXIII. XMLWriter Functions


XMLWriter::endAttribute

(No version information available, might be only in CVS)

XMLWriter::endAttribute — End attribute

Popis

Object oriented style:

class XMLWriter {
bool endAttribute ( void )
}

Procedural style:

bool xmlwriter_end_attribute ( resource $xmlwriter )

Ends the current attribute.

Seznam parametrů

xmlwriter

Only for procedural calls. The XMLWriter resource that is being modified. This resource comes from a call to xmlwriter_open_uri() or xmlwriter_open_memory().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

XMLWriter::startAttribute
XMLWriter::startAttributeNS
XMLWriter::writeAttribute
XMLWriter::writeAttributeNS

Předcházející | Nahoru | Další
CLXXXIII. XMLWriter Functions | Domů | XMLWriter::endCData


XMLWriter::endCData

(No version information available, might be only in CVS)

XMLWriter::endCData — End current CDATA

Popis

Object oriented style:

class XMLWriter {
bool endCData ( void )
}

Procedural style:

bool xmlwriter_end_cdata ( resource $xmlwriter )

Ends the current CDATA section.

Seznam parametrů

xmlwriter

Only for procedural calls. The XMLWriter resource that is being modified. This resource comes from a call to xmlwriter_open_uri() or xmlwriter_open_memory().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

XMLWriter::startCData
XMLWriter::writeCData

Předcházející | Nahoru | Další
XMLWriter::endAttribute | Domů | XMLWriter::endComment


XMLWriter::endComment

(No version information available, might be only in CVS)

XMLWriter::endComment — Create end comment

Popis

Object oriented style:

class XMLWriter {
bool endComment ( void )
}

Procedural style:

bool xmlwriter_end_comment ( resource $xmlwriter )

Ends the current comment.

Seznam parametrů

xmlwriter

Only for procedural calls. The XMLWriter resource that is being modified. This resource comes from a call to xmlwriter_open_uri() or xmlwriter_open_memory().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

XMLWriter::startComment
XMLWriter::writeComment

Předcházející | Nahoru | Další
XMLWriter::endCData | Domů | XMLWriter::endDocument


XMLWriter::endDocument

(No version information available, might be only in CVS)

XMLWriter::endDocument — End current document

Popis

Object oriented style:

class XMLWriter {
bool endDocument ( void )
}

Procedural style:

bool xmlwriter_end_document ( resource $xmlwriter )

Ends the current document.

Seznam parametrů

xmlwriter

Only for procedural calls. The XMLWriter resource that is being modified. This resource comes from a call to xmlwriter_open_uri() or xmlwriter_open_memory().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

XMLWriter::startDocument

Předcházející | Nahoru | Další
XMLWriter::endComment | Domů | XMLWriter::endDTDAttlist


XMLWriter::endDTD

(No version information available, might be only in CVS)

XMLWriter::endDTD — End current DTD

Popis

Object oriented style:

class XMLWriter {
bool endDTD ( void )
}

Procedural style:

bool xmlwriter_end_dtd ( resource $xmlwriter )

Ends the DTD of the document.

Seznam parametrů

xmlwriter

Only for procedural calls. The XMLWriter resource that is being modified. This resource comes from a call to xmlwriter_open_uri() or xmlwriter_open_memory().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

XMLWriter::startDTD
XMLWriter::writeDTD

Předcházející | Nahoru | Další
XMLWriter::endDTDEntity | Domů | XMLWriter::endElement


XMLWriter::endDTDAttlist

(No version information available, might be only in CVS)

XMLWriter::endDTDAttlist — End current DTD AttList

Popis

Object oriented style:

class XMLWriter {
bool endDTDAttlist ( void )
}

Procedural style:

bool xmlwriter_end_dtd_attlist ( resource $xmlwriter )

Ends the current DTD attribute list.

Seznam parametrů

xmlwriter

Only for procedural calls. The XMLWriter resource that is being modified. This resource comes from a call to xmlwriter_open_uri() or xmlwriter_open_memory().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

XMLWriter::startDTDAttlist
XMLWriter::writeDTDAttlist

Předcházející | Nahoru | Další
XMLWriter::endDocument | Domů | XMLWriter::endDTDElement


XMLWriter::endDTDElement

(No version information available, might be only in CVS)

XMLWriter::endDTDElement — End current DTD element

Popis

Object oriented style:

class XMLWriter {
bool endDTDElement ( void )
}

Procedural style:

bool xmlwriter_end_dtd_element ( resource $xmlwriter )

Ends the current DTD element.

Seznam parametrů

xmlwriter

Only for procedural calls. The XMLWriter resource that is being modified. This resource comes from a call to xmlwriter_open_uri() or xmlwriter_open_memory().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

XMLWriter::startDTDElement
XMLWriter::writeDTDElement

Předcházející | Nahoru | Další
XMLWriter::endDTDAttlist | Domů | XMLWriter::endDTDEntity


XMLWriter::endDTDEntity

(No version information available, might be only in CVS)

XMLWriter::endDTDEntity — End current DTD Entity

Popis

Object oriented style:

class XMLWriter {
bool endDTDEntity ( void )
}

Procedural style:

bool xmlwriter_end_dtd_entity ( resource $xmlwriter )

Ends the current DTD entity.

Seznam parametrů

xmlwriter

Only for procedural calls. The XMLWriter resource that is being modified. This resource comes from a call to xmlwriter_open_uri() or xmlwriter_open_memory().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

XMLWriter::startDTDEntity
XMLWriter::writeDTDEntity

Předcházející | Nahoru | Další
XMLWriter::endDTDElement | Domů | XMLWriter::endDTD


XMLWriter::endElement

(No version information available, might be only in CVS)

XMLWriter::endElement — End current element

Popis

Object oriented style:

class XMLWriter {
bool endElement ( void )
}

Procedural style:

bool xmlwriter_end_element ( resource $xmlwriter )

Ends the current element.

Seznam parametrů

xmlwriter

Only for procedural calls. The XMLWriter resource that is being modified. This resource comes from a call to xmlwriter_open_uri() or xmlwriter_open_memory().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

XMLWriter::startElement
XMLWriter::writeElement

Předcházející | Nahoru | Další
XMLWriter::endDTD | Domů | XMLWriter::endPI


XMLWriter::endPI

(No version information available, might be only in CVS)

XMLWriter::endPI — End current PI

Popis

Object oriented style:

class XMLWriter {
bool endPI ( void )
}

Procedural style:

bool xmlwriter_end_pi ( resource $xmlwriter )

Ends the current processing instruction.

Seznam parametrů

xmlwriter

Only for procedural calls. The XMLWriter resource that is being modified. This resource comes from a call to xmlwriter_open_uri() or xmlwriter_open_memory().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

XMLWriter::startPI
XMLWriter::writePI

Předcházející | Nahoru | Další
XMLWriter::endElement | Domů | XMLWriter::flush


XMLWriter::flush

(No version information available, might be only in CVS)

XMLWriter::flush — Flush current buffer

Popis

Object oriented style:

class XMLWriter {
mixed flush ( [bool $empty] )
}

Procedural style:

mixed xmlwriter_flush ( resource $xmlwriter [, bool $empty] )

Flushes the current buffer.

Seznam parametrů

xmlwriter

Only for procedural calls. The XMLWriter resource that is being modified. This resource comes from a call to xmlwriter_open_uri() or xmlwriter_open_memory().

empty

Whether to empty the buffer or no. Default is TRUE.

Návratové hodnoty

If you opened the writer in memory, this function returns the generated XML buffer, Else, if using URI, this function will write the buffer and return the number of written bytes.

Předcházející | Nahoru | Další
XMLWriter::endPI | Domů | XMLWriter::fullEndElement


XMLWriter::fullEndElement

(No version information available, might be only in CVS)

XMLWriter::fullEndElement — End current element

Popis

Object oriented style:

class XMLWriter {
bool fullEndElement ( void )
}

Procedural style:

bool xmlwriter_full_end_element ( resource $xmlwriter )

End the current xml element. Writes an end tag even if the element is empty.

Seznam parametrů

xmlwriter

Only for procedural calls. The XMLWriter resource that is being modified. This resource comes from a call to xmlwriter_open_uri() or xmlwriter_open_memory().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

XMLWriter::endElement

Předcházející | Nahoru | Další
XMLWriter::flush | Domů | XMLWriter::openMemory


XMLWriter::openMemory

(No version information available, might be only in CVS)

XMLWriter::openMemory — Create new xmlwriter using memory for string output

Popis

Object oriented style:

class XMLWriter {
bool openMemory ( void )
}

Procedural style:

resource xmlwriter_open_memory ( void )

Creates a new XMLWriter using memory for string output.

Seznam parametrů

Návratové hodnoty

Object oriented style: Vrací TRUE při úspěchu, FALSE při selhání..

Procedural style: Returns a new xmlwriter resource for later use with the xmlwriter functions on success, FALSE on error.

Viz také

XMLWriter::openURI

Předcházející | Nahoru | Další
XMLWriter::fullEndElement | Domů | XMLWriter::openURI


XMLWriter::openURI

(No version information available, might be only in CVS)

XMLWriter::openURI — Create new xmlwriter using source uri for output

Popis

Object oriented style:

class XMLWriter {
bool openURI ( string $uri )
}

Procedural style:

resource xmlwriter_open_uri ( string $uri )

Creates a new XMLWriter using uri for the output.

Seznam parametrů

uri

The URI of the resource for the output.

Návratové hodnoty

Object oriented style: Vrací TRUE při úspěchu, FALSE při selhání..

Procedural style: Returns a new xmlwriter resource for later use with the xmlwriter functions on success, FALSE on error.

Viz také

XMLWriter::openMemory

Předcházející | Nahoru | Další
XMLWriter::openMemory | Domů | XMLWriter::outputMemory


XMLWriter::outputMemory

(No version information available, might be only in CVS)

XMLWriter::outputMemory — Returns current buffer

Popis

Object oriented style:

class XMLWriter {
bool outputMemory ( [bool $flush] )
}

Procedural style:

string xmlwriter_output_memory ( resource $xmlwriter [, bool $flush] )

Returns the current buffer.

Seznam parametrů

xmlwriter

Only for procedural calls. The XMLWriter resource that is being modified. This resource comes from a call to xmlwriter_open_uri() or xmlwriter_open_memory().

flush

Whether to flush the output buffer or no. Default is TRUE.

Návratové hodnoty

Returns the current buffer as a string.

Viz také

XMLWriter::flush

Předcházející | Nahoru | Další
XMLWriter::openURI | Domů | XMLWriter::setIndentString


XMLWriter::setIndent

(No version information available, might be only in CVS)

XMLWriter::setIndent — Toggle indentation on/off

Popis

Object oriented style:

class XMLWriter {
bool setIndent ( bool $indent )
}

Procedural style:

bool xmlwriter_set_indent ( resource $xmlwriter, bool $indent )

Toggles indentation on or off.

Seznam parametrů

xmlwriter

Only for procedural calls. The XMLWriter resource that is being modified. This resource comes from a call to xmlwriter_open_uri() or xmlwriter_open_memory().

indent

Whether indentation is enabled. Defaults to FALSE.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

XMLWriter::setIndentString

Předcházející | Nahoru | Další
XMLWriter::setIndentString | Domů | XMLWriter::startAttributeNS


XMLWriter::setIndentString

(No version information available, might be only in CVS)

XMLWriter::setIndentString — Set string used for indenting

Popis

Object oriented style:

class XMLWriter {
bool setIndentString ( string $indentString )
}

Procedural style:

bool xmlwriter_set_indent_string ( resource $xmlwriter, string $indentString )

Sets the string which will be used to indent each element/attribute of the resulting xml.

Seznam parametrů

xmlwriter

Only for procedural calls. The XMLWriter resource that is being modified. This resource comes from a call to xmlwriter_open_uri() or xmlwriter_open_memory().

indentString

The indentation string.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

XMLWriter::setIndent

Předcházející | Nahoru | Další
XMLWriter::outputMemory | Domů | XMLWriter::setIndent


XMLWriter::startAttribute

(No version information available, might be only in CVS)

XMLWriter::startAttribute — Create start attribute

Popis

Object oriented style:

class XMLWriter {
bool startAttribute ( string $name )
}

Procedural style:

bool xmlwriter_start_attribute ( resource $xmlwriter, string $name )

Starts an attribute.

Seznam parametrů

xmlwriter

Only for procedural calls. The XMLWriter resource that is being modified. This resource comes from a call to xmlwriter_open_uri() or xmlwriter_open_memory().

name

The attribute name.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

XMLWriter::startAttributeNS
XMLWriter::endAttribute
XMLWriter::writeAttribute
XMLWriter::writeAttributeNS

Předcházející | Nahoru | Další
XMLWriter::startAttributeNS | Domů | XMLWriter::startCData


XMLWriter::startAttributeNS

(No version information available, might be only in CVS)

XMLWriter::startAttributeNS — Create start namespaced attribute

Popis

Object oriented style:

class XMLWriter {
bool startAttributeNS ( string $prefix, string $name, string $uri )
}

Procedural style:

bool xmlwriter_start_attribute_ns ( resource $xmlwriter, string $prefix, string $name, string $uri )

Starts a namespaced attribute.

Seznam parametrů

xmlwriter

Only for procedural calls. The XMLWriter resource that is being modified. This resource comes from a call to xmlwriter_open_uri() or xmlwriter_open_memory().

prefix

The namespace prefix.

name

The attribute name.

uri

The namespace URI.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

XMLWriter::startAttribute
XMLWriter::endAttribute
XMLWriter::writeAttribute
XMLWriter::writeAttributeNS

Předcházející | Nahoru | Další
XMLWriter::setIndent | Domů | XMLWriter::startAttribute


XMLWriter::startCData

(No version information available, might be only in CVS)

XMLWriter::startCData — Create start CDATA tag

Popis

Object oriented style:

class XMLWriter {
bool startCData ( void )
}

Procedural style:

bool xmlwriter_start_cdata ( resource $xmlwriter )

Starts a CDATA.

Seznam parametrů

xmlwriter

Only for procedural calls. The XMLWriter resource that is being modified. This resource comes from a call to xmlwriter_open_uri() or xmlwriter_open_memory().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

XMLWriter::endCData
XMLWriter::writeCData

Předcházející | Nahoru | Další
XMLWriter::startAttribute | Domů | XMLWriter::startComment


XMLWriter::startComment

(No version information available, might be only in CVS)

XMLWriter::startComment — Create start comment

Popis

Object oriented style:

class XMLWriter {
bool startComment ( void )
}

Procedural style:

bool xmlwriter_start_comment ( resource $xmlwriter )

Starts a comment.

Seznam parametrů

xmlwriter

Only for procedural calls. The XMLWriter resource that is being modified. This resource comes from a call to xmlwriter_open_uri() or xmlwriter_open_memory().

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

XMLWriter::endComment
XMLWriter::writeComment

Předcházející | Nahoru | Další
XMLWriter::startCData | Domů | XMLWriter::startDocument


XMLWriter::startDocument

(No version information available, might be only in CVS)

XMLWriter::startDocument — Create document tag

Popis

Object oriented style:

class XMLWriter {
bool startDocument ( [string $version [, string $encoding [, string $standalone]]] )
}

Procedural style:

bool xmlwriter_start_document ( resource $xmlwriter [, string $version [, string $encoding [, string $standalone]]] )

Starts a document.

Seznam parametrů

xmlwriter

Only for procedural calls. The XMLWriter resource that is being modified. This resource comes from a call to xmlwriter_open_uri() or xmlwriter_open_memory().

version

The version number of the document as part of the XML declaration. Defaults to 1.0.

encoding

The encoding of the document as part of the XML declaration. NULL by default.

standalone

yes or no. NULL by default.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

XMLWriter::endDocument

Předcházející | Nahoru | Další
XMLWriter::startComment | Domů | XMLWriter::startDTDAttlist


XMLWriter::startDTD

(No version information available, might be only in CVS)

XMLWriter::startDTD — Create start DTD tag

Popis

Object oriented style:

class XMLWriter {
bool startDTD ( string $qualifiedName [, string $publicId [, string $systemId]] )
}

Procedural style:

bool xmlwriter_start_dtd ( resource $xmlwriter, string $qualifiedName [, string $publicId [, string $systemId]] )

Starts a DTD.

Seznam parametrů

xmlwriter

Only for procedural calls. The XMLWriter resource that is being modified. This resource comes from a call to xmlwriter_open_uri() or xmlwriter_open_memory().

qualifiedName

The qualified name of the document type to create.

publicId

The external subset public identifier.

systemId

The external subset system identifier.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

XMLWriter::endDTD
XMLWriter::writeDTD

Předcházející | Nahoru | Další
XMLWriter::startDTDEntity | Domů | XMLWriter::startElementNS


XMLWriter::startDTDAttlist

(No version information available, might be only in CVS)

XMLWriter::startDTDAttlist — Create start DTD AttList

Popis

Object oriented style:

class XMLWriter {
bool startDTDAttlist ( string $name )
}

Procedural style:

bool xmlwriter_start_dtd_attlist ( resource $xmlwriter, string $name )

Starts a DTD attribute list.

Seznam parametrů

xmlwriter

Only for procedural calls. The XMLWriter resource that is being modified. This resource comes from a call to xmlwriter_open_uri() or xmlwriter_open_memory().

name

The attribute list name.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

XMLWriter::endDTDAttlist
XMLWriter::writeDTDAttlist

Předcházející | Nahoru | Další
XMLWriter::startDocument | Domů | XMLWriter::startDTDElement


XMLWriter::startDTDElement

(No version information available, might be only in CVS)

XMLWriter::startDTDElement — Create start DTD element

Popis

Object oriented style:

class XMLWriter {
bool startDTDElement ( string $qualifiedName )
}

Procedural style:

bool xmlwriter_start_dtd_element ( resource $xmlwriter, string $qualifiedName )

Starts a DTD element.

Seznam parametrů

xmlwriter

Only for procedural calls. The XMLWriter resource that is being modified. This resource comes from a call to xmlwriter_open_uri() or xmlwriter_open_memory().

qualifiedName

The qualified name of the document type to create.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

XMLWriter::endDTDElement
XMLWriter::writeDTDElement

Předcházející | Nahoru | Další
XMLWriter::startDTDAttlist | Domů | XMLWriter::startDTDEntity


XMLWriter::startDTDEntity

(No version information available, might be only in CVS)

XMLWriter::startDTDEntity — Create start DTD Entity

Popis

Object oriented style:

class XMLWriter {
bool startDTDEntity ( string $name, bool $isparam )
}

Procedural style:

bool xmlwriter_start_dtd_entity ( resource $xmlwriter, string $name, bool $isparam )

Starts a DTD entity.

Seznam parametrů

xmlwriter

Only for procedural calls. The XMLWriter resource that is being modified. This resource comes from a call to xmlwriter_open_uri() or xmlwriter_open_memory().

name

The name of the entity.

isparam

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

XMLWriter::endDTDEntity
XMLWriter::writeDTDEntity

Předcházející | Nahoru | Další
XMLWriter::startDTDElement | Domů | XMLWriter::startDTD


XMLWriter::startElement

(No version information available, might be only in CVS)

XMLWriter::startElement — Create start element tag

Popis

Object oriented style:

class XMLWriter {
bool startElement ( string $name )
}

Procedural style:

bool xmlwriter_start_element ( resource $xmlwriter, string $name )

Starts an element.

Seznam parametrů

xmlwriter

Only for procedural calls. The XMLWriter resource that is being modified. This resource comes from a call to xmlwriter_open_uri() or xmlwriter_open_memory().

name

The element name.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

XMLWriter::endElement
XMLWriter::writeElement

Předcházející | Nahoru | Další
XMLWriter::startElementNS | Domů | XMLWriter::startPI


XMLWriter::startElementNS

(No version information available, might be only in CVS)

XMLWriter::startElementNS — Create start namespaced element tag

Popis

Object oriented style:

class XMLWriter {
bool startElementNS ( string $prefix, string $name, string $uri )
}

Procedural style:

bool xmlwriter_start_element_ns ( resource $xmlwriter, string $prefix, string $name, string $uri )

Starts a namespaced element.

Seznam parametrů

xmlwriter

Only for procedural calls. The XMLWriter resource that is being modified. This resource comes from a call to xmlwriter_open_uri() or xmlwriter_open_memory().

prefix

The namespace prefix.

name

The element name.

uri

The namespace URI.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

XMLWriter::endElement
XMLWriter::writeElementNS

Předcházející | Nahoru | Další
XMLWriter::startDTD | Domů | XMLWriter::startElement


XMLWriter::startPI

(No version information available, might be only in CVS)

XMLWriter::startPI — Create start PI tag

Popis

Object oriented style:

class XMLWriter {
bool startPI ( string $target )
}

Procedural style:

bool xmlwriter_start_pi ( resource $xmlwriter, string $target )

Starts a processing instruction tag.

Seznam parametrů

xmlwriter

Only for procedural calls. The XMLWriter resource that is being modified. This resource comes from a call to xmlwriter_open_uri() or xmlwriter_open_memory().

target

The target of the processing instruction.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

XMLWriter::endPI
XMLWriter::writePI

Předcházející | Nahoru | Další
XMLWriter::startElement | Domů | XMLWriter::text


XMLWriter::text

(No version information available, might be only in CVS)

XMLWriter::text — Write text

Popis

Object oriented style:

class XMLWriter {
bool text ( string $content )
}

Procedural style:

bool xmlwriter_text ( resource $xmlwriter, string $content )

Writes a text.

Seznam parametrů

xmlwriter

Only for procedural calls. The XMLWriter resource that is being modified. This resource comes from a call to xmlwriter_open_uri() or xmlwriter_open_memory().

content

The contents of the text.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
XMLWriter::startPI | Domů | XMLWriter::writeAttributeNS


XMLWriter::writeAttribute

(No version information available, might be only in CVS)

XMLWriter::writeAttribute — Write full attribute

Popis

Object oriented style:

class XMLWriter {
bool writeAttribute ( string $name, string $value )
}

Procedural style:

bool xmlwriter_write_attribute ( resource $xmlwriter, string $name, string $value )

Writes a full attribute.

Seznam parametrů

xmlwriter

Only for procedural calls. The XMLWriter resource that is being modified. This resource comes from a call to xmlwriter_open_uri() or xmlwriter_open_memory().

name

The name of the attribute.

value

The value of the attribute.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

XMLWriter::writeAttributeNS
XMLWriter::startAttribute
XMLWriter::startAttributeNS
XMLWriter::endAttribute

Předcházející | Nahoru | Další
XMLWriter::writeAttributeNS | Domů | XMLWriter::writeCData


XMLWriter::writeAttributeNS

(No version information available, might be only in CVS)

XMLWriter::writeAttributeNS — Write full namespaced attribute

Popis

Object oriented style:

class XMLWriter {
bool writeAttributeNS ( string $prefix, string $name, string $uri, string $content )
}

Procedural style:

bool xmlwriter_write_attribute_ns ( resource $xmlwriter, string $prefix, string $name, string $uri, string $content )

Writes a full namespaced attribute.

Seznam parametrů

xmlwriter

Only for procedural calls. The XMLWriter resource that is being modified. This resource comes from a call to xmlwriter_open_uri() or xmlwriter_open_memory().

prefix

The namespace prefix.

name

The attribute name.

uri

The namespace URI.

content

The attribute value.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

XMLWriter::writeAttribute
XMLWriter::startAttribute
XMLWriter::startAttributeNS
XMLWriter::endAttribute

Předcházející | Nahoru | Další
XMLWriter::text | Domů | XMLWriter::writeAttribute


XMLWriter::writeCData

(No version information available, might be only in CVS)

XMLWriter::writeCData — Write full CDATA tag

Popis

Object oriented style:

class XMLWriter {
bool writeCData ( string $content )
}

Procedural style:

bool xmlwriter_write_cdata ( resource $xmlwriter, string $content )

Writes a full CDATA.

Seznam parametrů

xmlwriter

Only for procedural calls. The XMLWriter resource that is being modified. This resource comes from a call to xmlwriter_open_uri() or xmlwriter_open_memory().

content

The contents of the CDATA.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

XMLWriter::startCData
XMLWriter::endCData

Předcházející | Nahoru | Další
XMLWriter::writeAttribute | Domů | XMLWriter::writeComment


XMLWriter::writeComment

(No version information available, might be only in CVS)

XMLWriter::writeComment — Write full comment tag

Popis

Object oriented style:

class XMLWriter {
bool writeComment ( string $content )
}

Procedural style:

bool xmlwriter_write_comment ( resource $xmlwriter, string $content )

Writes a full comment.

Seznam parametrů

xmlwriter

Only for procedural calls. The XMLWriter resource that is being modified. This resource comes from a call to xmlwriter_open_uri() or xmlwriter_open_memory().

content

The contents of the comment.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

XMLWriter::startComment
XMLWriter::endComment

Předcházející | Nahoru | Další
XMLWriter::writeCData | Domů | XMLWriter::writeDTDAttlist


XMLWriter::writeDTD

(No version information available, might be only in CVS)

XMLWriter::writeDTD — Write full DTD tag

Popis

Object oriented style:

class XMLWriter {
bool writeDTD ( string $name [, string $publicId [, string $systemId [, string $subset]]] )
}

Procedural style:

bool xmlwriter_write_dtd ( resource $xmlwriter, string $name [, string $publicId [, string $systemId [, string $subset]]] )

Writes a full DTD.

Seznam parametrů

xmlwriter

Only for procedural calls. The XMLWriter resource that is being modified. This resource comes from a call to xmlwriter_open_uri() or xmlwriter_open_memory().

name

The DTD name.

publicId

The external subset public identifier.

systemId

The external subset system identifier.

subset

The content of the DTD.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

XMLWriter::startDTD
XMLWriter::endDTD

Předcházející | Nahoru | Další
XMLWriter::writeDTDEntity | Domů | XMLWriter::writeElementNS


XMLWriter::writeDTDAttlist

(No version information available, might be only in CVS)

XMLWriter::writeDTDAttlist — Write full DTD AttList tag

Popis

Object oriented style:

class XMLWriter {
bool writeDTDAttlist ( string $name, string $content )
}

Procedural style:

bool xmlwriter_write_dtd_attlist ( resource $xmlwriter, string $name, string $content )

Writes a DTD attribute list.

Seznam parametrů

xmlwriter

Only for procedural calls. The XMLWriter resource that is being modified. This resource comes from a call to xmlwriter_open_uri() or xmlwriter_open_memory().

name

The name of the DTD attribute list.

content

The content of the DTD attribute list.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

XMLWriter::startDTDAttlist
XMLWriter::endDTDAttlist

Předcházející | Nahoru | Další
XMLWriter::writeComment | Domů | XMLWriter::writeDTDElement


XMLWriter::writeDTDElement

(No version information available, might be only in CVS)

XMLWriter::writeDTDElement — Write full DTD element tag

Popis

Object oriented style:

class XMLWriter {
bool writeDTDElement ( string $name, string $content )
}

Procedural style:

bool xmlwriter_write_dtd_element ( resource $xmlwriter, string $name, string $content )

Writes a full DTD element.

Seznam parametrů

xmlwriter

Only for procedural calls. The XMLWriter resource that is being modified. This resource comes from a call to xmlwriter_open_uri() or xmlwriter_open_memory().

name

The name of the DTD element.

content

The content of the element.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

XMLWriter::startDTDElement
XMLWriter::endDTDElement

Předcházející | Nahoru | Další
XMLWriter::writeDTDAttlist | Domů | XMLWriter::writeDTDEntity


XMLWriter::writeDTDEntity

(No version information available, might be only in CVS)

XMLWriter::writeDTDEntity — Write full DTD Entity tag

Popis

Object oriented style:

class XMLWriter {
bool writeDTDEntity ( string $name, string $content )
}

Procedural style:

bool xmlwriter_write_dtd_entity ( resource $xmlwriter, string $name, string $content )

Writes a full DTD entity.

Seznam parametrů

xmlwriter

Only for procedural calls. The XMLWriter resource that is being modified. This resource comes from a call to xmlwriter_open_uri() or xmlwriter_open_memory().

name

The name of the entity.

content

The content of the entity.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

XMLWriter::startDTDEntity
XMLWriter::endDTDEntity

Předcházející | Nahoru | Další
XMLWriter::writeDTDElement | Domů | XMLWriter::writeDTD


XMLWriter::writeElement

(No version information available, might be only in CVS)

XMLWriter::writeElement — Write full element tag

Popis

Object oriented style:

class XMLWriter {
bool writeElement ( string $name [, string $content] )
}

Procedural style:

bool xmlwriter_write_element ( resource $xmlwriter, string $name [, string $content] )

Writes a full element tag.

Seznam parametrů

xmlwriter

Only for procedural calls. The XMLWriter resource that is being modified. This resource comes from a call to xmlwriter_open_uri() or xmlwriter_open_memory().

name

The element name.

content

The element contents.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

ChangeLog (záznam změn)

Verze | Popis
PHP 5.2.3 | The content parameter became optional.

Viz také

XMLWriter::startElement
XMLWriter::endElement
XMLWriter::writeElementNS

Předcházející | Nahoru | Další
XMLWriter::writeElementNS | Domů | XMLWriter::writePI


XMLWriter::writeElementNS

(No version information available, might be only in CVS)

XMLWriter::writeElementNS — Write full namesapced element tag

Popis

Object oriented style:

class XMLWriter {
bool writeElementNS ( string $prefix, string $name, string $uri [, string $content] )
}

Procedural style:

bool xmlwriter_write_element_ns ( resource $xmlwriter, string $prefix, string $name, string $uri [, string $content] )

Writes a full namesapced element tag.

Seznam parametrů

xmlwriter

Only for procedural calls. The XMLWriter resource that is being modified. This resource comes from a call to xmlwriter_open_uri() or xmlwriter_open_memory().

prefix

The namespace prefix.

name

The element name.

uri

The namespace URI.

content

The element contents.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

ChangeLog (záznam změn)

Verze | Popis
PHP 5.2.3 | The content parameter became optional.

Viz také

XMLWriter::startElementNS
XMLWriter::endElement
XMLWriter::writeElement

Předcházející | Nahoru | Další
XMLWriter::writeDTD | Domů | XMLWriter::writeElement


XMLWriter::writePI

(No version information available, might be only in CVS)

XMLWriter::writePI — Writes a PI

Popis

Object oriented style:

class XMLWriter {
bool writePI ( string $target, string $content )
}

Procedural style:

bool xmlwriter_write_pi ( resource $xmlwriter, string $target, string $content )

Writes a processing instruction.

Seznam parametrů

xmlwriter

Only for procedural calls. The XMLWriter resource that is being modified. This resource comes from a call to xmlwriter_open_uri() or xmlwriter_open_memory().

target

The target of the processing instruction.

content

The content of the processing instruction.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

XMLWriter::startPI
XMLWriter::endPI

Předcházející | Nahoru | Další
XMLWriter::writeElement | Domů | XMLWriter::writeRaw


XMLWriter::writeRaw

(No version information available, might be only in CVS)

XMLWriter::writeRaw — Write a raw XML text

Popis

Object oriented style:

class XMLWriter {
bool writeRaw ( string $content )
}

Procedural style:

bool xmlwriter_write_raw ( resource $xmlwriter, string $content )

Writes a raw xml text.

Seznam parametrů

xmlwriter

Only for procedural calls. The XMLWriter resource that is being modified. This resource comes from a call to xmlwriter_open_uri() or xmlwriter_open_memory().

content

The text string to write.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

XMLWriter::text

Předcházející | Nahoru | Další
XMLWriter::writePI | Domů | CLXXXIV. XSL functions


xpath_register_ns

(PHP 4 >= 4.2.0)

xpath_register_ns — Register the given namespace in the passed XPath context

Popis

bool xpath_register_ns ( XPathContext $xpath_context, string $prefix, string $uri )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

xpath_register_ns_auto()

Předcházející | Nahoru | Další
xpath_register_ns_auto | Domů | xptr_eval


xpath_register_ns_auto

(No version information available, might be only in CVS)

xpath_register_ns_auto — Register the given namespace in the passed XPath context

Popis

bool xpath_register_ns_auto ( XPathContext $xpath_context [, object $context_node] )
Varování

Tato funkce ještě není zdokumentována, k dispozici je pouze seznam argumentů.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Viz také

xpath_register_ns()

Předcházející | Nahoru | Další
xpath_new_context | Domů | xpath_register_ns


XSLTProcessor::__construct

(No version information available, might be only in CVS)

XSLTProcessor::__construct — Creates a new XSLTProcessor object

Popis

class XSLTProcessor {
__construct ( void )
}

Creates a new XSLTProcessor object.

Příklady

Příklad 2406. Creating an XSLTProcessor

<?php

$doc = new DOMDocument();
$xsl = new XSLTProcessor();

$doc->load($xsl_filename);
$xsl->importStyleSheet($doc);

$doc->load($xml_filename);
echo $xsl->transformToXML($doc);

?>

Předcházející | Nahoru | Další
CLXXXIV. XSL functions | Domů | XSLTProcessor::getParameter


yaz_es

(PECL yaz:0.9-1.0.9)

yaz_es — Prepares for an Extended Service Request

Popis

void yaz_es ( resource $id, string $type, array $args )

This function prepares for an Extended Service Request. Extended Services is family of various Z39.50 facilities, such as Record Update, Item Order, Database administration etc.

Poznámka: Many Z39.50 Servers do not support Extended Services.

The yaz_es() creates an Extended Service Request packages and puts it into a queue of operations. Use yaz_wait() to send the request(s) to the server. After completion of yaz_wait() the result of the Extended Service operation should be expected with a call to yaz_es_result().

Seznam parametrů

id

The connection resource returned by yaz_connect().

type

A string which represents the type of the Extended Service: itemorder (Item Order), create (Create Database), drop (Drop Database), commit (Commit Operation), update (Update Record), xmlupdate (XML Update). Each type is specified in the following section.

args

An array with extended service options plus package specific options. The options are identical to those offered in the C API of ZOOM C. Refer to the ZOOM » Extended Services.

Návratové hodnoty

Nevrací se žádná hodnota.

Příklady

Příklad 2426. Record Update

<?php
$con = yaz_connect("myhost/database");
$args = array (
    "record" => "<gils><title>some title</title></gils>",
    "syntax" => "xml",
    "action" => "specialUpdate"
);
yaz_es($con, "update", $args);
yaz_wait();
$result = yaz_es_result($id);
?>

Viz také

yaz_es_result()

Předcházející | Nahoru | Další
yaz_es_result | Domů | yaz_get_option


zend_thread_id

(PHP 5)

zend_thread_id — Returns a unique identifier for the current thread

Popis

int zend_thread_id ( void )

This function returns an unique identifier for the current thread.

Návratové hodnoty

Returns the thread id as an integer.

Poznámky

Poznámka: This function is only available if PHP has been built with ZTS (Zend Thread Safety) support.

Předcházející | Nahoru | Další
zend_logo_guid | Domů | zend_version


ZipArchive::addEmptyDir

(No version information available, might be only in CVS)

ZipArchive::addEmptyDir — Add a new directory

Popis

bool ZipArchive::addEmptyDir ( string $dirname )

Adds an empty directory in the archive.

Seznam parametrů

dirname

The directory to add.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 2443. Create a new directory in an archive

<?php
$zip = new ZipArchive;
if ($zip->open('test.zip') === TRUE) {
    if($zip->addEmptyDir('newDirectory')) {
        echo 'Created a new root directory';
    } else {
        echo 'Could not create the directory';
    }
    $zip->close();
} else {
    echo 'failed';
}
?>

Předcházející | Nahoru | Další
zip_read | Domů | ZipArchive::addFile


ZipArchive::addFile

(No version information available, might be only in CVS)

ZipArchive::addFile — Adds a file to a ZIP archive from the given path

Popis

bool ZipArchive::addFile ( string $filename [, string $localname] )

Adds a file to a ZIP archive from a given path

Seznam parametrů

filename

The path to the file to add.

localname

local name inside ZIP archive.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

This example opens a ZIP file archive test.zip and add the file /path/to/index.txt. as newname.txt.

Příklad 2444. Open and extract

<?php
$zip = new ZipArchive;
if ($zip->open('test.zip') === TRUE) {
    $zip->addFile('/path/to/index.txt', 'newname.txt');
    $zip->close();
    echo 'ok';
} else {
    echo 'failed';
}
?>

Předcházející | Nahoru | Další
ZipArchive::addEmptyDir | Domů | ZipArchive::addFromString


ZipArchive::addFromString

(No version information available, might be only in CVS)

ZipArchive::addFromString — Add a file to a ZIP archive using its contents

Popis

bool ZipArchive::addFromString ( string $localname, string $contents )

Add a file to a ZIP archive using its contents.

Seznam parametrů

localname

The name of the entry to create.

contents

The contents to use to create the entry. It is used in a binary safe mode.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 2445. Add an entry to a new archive

<?php
$zip = new ZipArchive;
$res = $zip->open('test.zip', ZipArchive::CREATE);
if ($res === TRUE) {
    $zip->addFromString('test.txt', 'file content goes here');
    $zip->close();
    echo 'ok';
} else {
    echo 'failed';
}
?>

Příklad 2446. Add file to a directory inside an archive

<?php
$zip = new ZipArchive;
if ($zip->open('test.zip') === TRUE) {
    $zip->addFromString('dir/test.txt', 'file content goes here');
    $zip->close();
    echo 'ok';
} else {
    echo 'failed';
}
?>

Předcházející | Nahoru | Další
ZipArchive::addFile | Domů | ZipArchive::close


ZipArchive::close

(No version information available, might be only in CVS)

ZipArchive::close — Close the active archive (opened or newly created)

Popis

bool ZipArchive::close ( void )

Close opened or created archive and save changes. This method is automatically called at the end of the script.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
ZipArchive::addFromString | Domů | ZipArchive::deleteIndex


ZipArchive::deleteIndex

(No version information available, might be only in CVS)

ZipArchive::deleteIndex — delete an entry in the archive using its index

Popis

bool ZipArchive::deleteIndex ( int $index )

Delete an entry in the archive using its index.

Seznam parametrů

index

Index of the entry to delete.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 2447. Delete file from archive using its index

<?php
$zip = new ZipArchive;
if ($zip->open('test.zip') === TRUE) {
    $zip->deleteIndex(2);
    $zip->close();
    echo 'ok';
} else {
    echo 'failed';
}
?>

Předcházející | Nahoru | Další
ZipArchive::close | Domů | ZipArchive::deleteName


ZipArchive::deleteName

(No version information available, might be only in CVS)

ZipArchive::deleteName — delete an entry in the archive using its name

Popis

bool ZipArchive::deleteName ( string $name )

Delete an entry in the archive using its name.

Seznam parametrů

name

Name of the entry to delete.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 2448. Delete file from archive using its name

<?php
$zip = new ZipArchive;
if ($zip->open('test1.zip') === TRUE) {
    $zip->deleteName('testfromfile.php');
    $zip->close();
    echo 'ok';
} else {
    echo 'failed';
}
?>

Předcházející | Nahoru | Další
ZipArchive::deleteIndex | Domů | ZipArchive::extractTo


ZipArchive::extractTo

(No version information available, might be only in CVS)

ZipArchive::extractTo — Extract the archive contents

Popis

mixed ZipArchive::extractTo ( string $destination [, mixed $entries] )

Extract the complete archive or the given files to the specified destination.

Seznam parametrů

destination

Location where to extract the files.

entries

The entries to extract. It accepts either a single entry name or an array of names.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

This example opens a ZIP file archive, reads each file in the archive and prints out its contents. The test2.zip archive used in this example is one of the test archives in the ZZIPlib source distribution.

Příklad 2449. Extract all entries

<?php
$zip = new ZipArchive;
if ($zip->open('test.zip') === TRUE) {
    $zip->extractTo('/my/destination/dir/');
    $zip->close();
    echo 'ok';
} else {
    echo 'failed';
}
?>

Příklad 2450. Extract only two entries

<?php
$zip = new ZipArchive;
$res = $zip->open('test_im.zip');
if ($res === TRUE) {
    $zip->extractTo('/my/destination/dir/', array('pear_item.gif', 'testfromfile.php'));
    $zip->close();
    echo 'ok';
} else {
    echo 'failed';
}
?>

Předcházející | Nahoru | Další
ZipArchive::deleteName | Domů | ZipArchive::getArchiveComment


ZipArchive::getArchiveComment

(No version information available, might be only in CVS)

ZipArchive::getArchiveComment — Returns the Zip archive comment

Popis

string ZipArchive::getArchiveComment ( void )

Returns the Zip archive comment.

Návratové hodnoty

Returns the Zip archive comment or FALSE on failure.

Příklady

Příklad 2451. Dump an archive comment

<?php
$zip = new ZipArchive;
$res = $zip->open('test_with_comment.zip')
if ($res === TRUE) {
    var_dump($zip->getArchiveComment());
    /* Or using the archive property */
    var_dump($zip->comment);
} else {
    echo 'failed, code:' . $res;
}
?>

Předcházející | Nahoru | Další
ZipArchive::extractTo | Domů | ZipArchive::getCommentIndex


ZipArchive::getCommentIndex

(No version information available, might be only in CVS)

ZipArchive::getCommentIndex — Returns the comment of an entry using the entry index

Popis

string ZipArchive::getCommentIndex ( int $index [, int $flags] )

Returns the comment of an entry using the entry index.

Seznam parametrů

index

Index of the entry

flags

If flags is set to ZIPARCHIVE::FL_UNCHANGED, the original unchanged comment is returned.

Návratové hodnoty

Returns the comment on success or FALSE on failure.

Příklady

Příklad 2452. Dump an entry comment

<?php
$zip = new ZipArchive;
$res = $zip->open('test1.zip')
if ($res === TRUE) {
    var_dump($zip->getCommentIndex(1));
} else {
    echo 'failed, code:' . $res;
}
?>

Předcházející | Nahoru | Další
ZipArchive::getArchiveComment | Domů | ZipArchive::getCommentName


ZipArchive::getCommentName

(No version information available, might be only in CVS)

ZipArchive::getCommentName — Returns the comment of an entry using the entry name

Popis

string ZipArchive::getCommentName ( string $name [, int $flags] )

Returns the comment of an entry using the entry name.

Seznam parametrů

name

Name of the entry

flags

If flags is set to ZIPARCHIVE::FL_UNCHANGED, the original unchanged comment is returned.

Návratové hodnoty

Returns the comment on success or FALSE on failure.

Příklady

Příklad 2453. Dump an entry comment

<?php
$zip = new ZipArchive;
$res = $zip->open('test1.zip')
if ($res === TRUE) {
    var_dump($zip->getCommentName('test/entry1.txt'));
} else {
    echo 'failed, code:' . $res;
}
?>

Předcházející | Nahoru | Další
ZipArchive::getCommentIndex | Domů | ZipArchive::getFromIndex


ZipArchive::getFromIndex

(No version information available, might be only in CVS)

ZipArchive::getFromIndex — Returns the entry contents using its index.

Popis

mixed ZipArchive::getFromIndex ( int $index [, int $flags] )

Returns the entry contents using its index.

Seznam parametrů

index

Index of the entry

flags

The flags to use to open the archive. the following values may be ORed to it.

  • ZIPARCHIVE::FL_UNCHANGED

  • ZIPARCHIVE::FL_COMPRESSED

Návratové hodnoty

Returns the contents of the entry on success or FALSE on failure.

Příklady

Příklad 2454. Get the file contents

<?php
$zip = new ZipArchive;
if ($zip->open('test.zip') === TRUE) {
    echo $zip->getFromIndex(2);
    $zip->close();
} else {
    echo 'failed';
}
?>

Předcházející | Nahoru | Další
ZipArchive::getCommentName | Domů | ZipArchive::getFromName


ZipArchive::getFromName

(No version information available, might be only in CVS)

ZipArchive::getFromName — Returns the entry contents using its name.

Popis

mixed ZipArchive::getFromName ( string $name [, int $flags] )

Returns the entry contents using its name.

Seznam parametrů

name

Name of the entry

flags

The flags to use to open the archive. the following values may be ORed to it.

  • ZIPARCHIVE::FL_UNCHANGED

  • ZIPARCHIVE::FL_COMPRESSED

Návratové hodnoty

Returns the contents of the entry on success or FALSE on failure.

Příklady

Příklad 2455. Get the file contents

<?php
$zip = new ZipArchive;
if ($zip->open('test1.zip') === TRUE) {
    echo $zip->getFromName('testfromfile.php');
    $zip->close();
} else {
    echo 'failed';
}
?>

Příklad 2456. Convert an image from a zip entry

<?php
$z = new ZipArchive();
if ($z->open(dirname(__FILE__) . '/test_im.zip')) {
    $im_string = $z->getFromName("pear_item.gif");
    $im = imagecreatefromstring($im_string);
    imagepng($im, 'b.png');
}
?>

Předcházející | Nahoru | Další
ZipArchive::getFromIndex | Domů | ZipArchive::getNameIndex


ZipArchive::getNameIndex

(No version information available, might be only in CVS)

ZipArchive::getNameIndex — Returns the name of an entry using its index

Popis

string ZipArchive::getNameIndex ( int $index )

Returns the name of an entry using its index.

Seznam parametrů

index

Index of the entry.

Návratové hodnoty

Returns the name on success or FALSE on failure.

Předcházející | Nahoru | Další
ZipArchive::getFromName | Domů | ZipArchive::getStream


ZipArchive::getStream

(No version information available, might be only in CVS)

ZipArchive::getStream — Get a file handler to the entry defined by its name (read only).

Popis

resource ZipArchive::getStream ( string $name )

Get a file handler to the entry defined by its name. For now it only supports read operations.

Seznam parametrů

name

The name of the entry to use.

Návratové hodnoty

Returns a file pointer (resource) on success or FALSE on failure.

Příklady

Příklad 2457. Get the entry contents with fread and store it.

<?php
$content = '';
$z = new ZipArchive();
if ($z->open('test.zip')) {
    $fp = $z->getStream('test');
    if(!$fp) exit("failed\n");

    while (!feof($fp)) {
        $contents .= fread($fp, 2);
    }

    fclose($fp);
    file_put_contents('t',$contents);
    echo "done.\n";
}
?>

Příklad 2458. Same as the previous example but with fopen and the zip stream wrapper

<?php
$fp = fopen('zip://' . dirname(__FILE__) . '/test.zip#test', 'r');
if (!$fp) {
    exit("cannot open\n");
}
while (!feof($fp)) {
    $contents .= fread($fp, 2);
    echo "$contents\n";
}
fclose($fp);
echo "done.\n";
?>

Příklad 2459. Stream wrapper and image, can be used with the xml function as well

<?php
$im = imagecreatefromgif('zip://' . dirname(__FILE__) . '/test_im.zip#pear_item.gif');
imagepng($im, 'a.png');
?>

Předcházející | Nahoru | Další
ZipArchive::getNameIndex | Domů | ZipArchive::locateName


ZipArchive::locateName

(No version information available, might be only in CVS)

ZipArchive::locateName — Returns the index of the entry in the archive

Popis

mixed ZipArchive::locateName ( string $name [, int $flags] )

Locates an entry using its name.

Seznam parametrů

name

The name of the entry to look up

flags

The function returns the index of the file named fname in archive. The flags are specified by ORing the following values, or 0 for none of them.

  • ZIPARCHIVE::FL_NOCASE

  • ZIPARCHIVE::FL_NODIR

Návratové hodnoty

Returns the index of the entry on success or FALSE on failure.

Příklady

Příklad 2460. Create an archive and then use it with locateName

<?php
$file = 'testlocate.zip';

$zip = new ZipArchive;
if ($zip->open($file, ZIPARCHIVE::CREATE) !== TRUE) {
    exit('failed');
}

$zip->addFromString('entry1.txt', 'entry #1');
$zip->addFromString('entry2.txt', 'entry #2');
$zip->addFromString('dir/entry2d.txt', 'entry #2');

if (!$zip->status == ZIPARCHIVE::ER_OK) {
    echo "failed to write zip\n";
}
$zip->close();

if ($zip->open($file) !== TRUE) {
    exit('failed');
}

echo $zip->locateName('entry1.txt') . "\n";
echo $zip->locateName('eNtry2.txt') . "\n";
echo $zip->locateName('eNtry2.txt', ZIPARCHIVE::FL_NOCASE) . "\n";
echo $zip->locateName('enTRy2d.txt', ZIPARCHIVE::FL_NOCASE|ZIPARCHIVE::FL_NODIR) . "\n";
$zip->close();

?>

Předcházející | Nahoru | Další
ZipArchive::getStream | Domů | ZipArchive::open


ZipArchive::open

(No version information available, might be only in CVS)

ZipArchive::open — Open a ZIP file archive

Popis

mixed ZipArchive::open ( string $filename [, int $flags] )

Opens a new zip archive for reading, writing or modifying.

Seznam parametrů

filename

The file name of the ZIP archive to open.

flags

The mode to use to open the archive.

  • ZIPARCHIVE::OVERWRITE

  • ZIPARCHIVE::CREATE

  • ZIPARCHIVE::EXCL

  • ZIPARCHIVE::CHECKCONS

Návratové hodnoty

Error codes

Returns TRUE on success or the error code.

  • ZIPARCHIVE::ER_EXISTS

  • ZIPARCHIVE::ER_INCONS

  • ZIPARCHIVE::ER_INVAL

  • ZIPARCHIVE::ER_MEMORY

  • ZIPARCHIVE::ER_NOENT

  • ZIPARCHIVE::ER_NOZIP

  • ZIPARCHIVE::ER_OPEN

  • ZIPARCHIVE::ER_READ

  • ZIPARCHIVE::ER_SEEK

Příklady

This example opens a ZIP file archive, reads each file in the archive and prints out its contents. The test2.zip archive used in this example is one of the test archives in the ZZIPlib source distribution.

Příklad 2461. Open and extract

<?php
$zip = new ZipArchive;
$res = $zip->open('test.zip')
if ($res === TRUE) {
    echo 'ok';
    $zip->extractTo('test');
    $zip->close();
} else {
    echo 'failed, code:' . $res;
}
?>

Příklad 2462. Create an archive

<?php
$zip = new ZipArchive;
$res = $zip->open('test.zip', ZipArchive::CREATE);
if ($res === TRUE) {
    $zip->addFromString('test.txt', 'file content goes here');
    $zip->addFile('data.txt', 'entryname.txt');
    $zip->close();
    echo 'ok';
} else {
    echo 'failed';
}
?>

Předcházející | Nahoru | Další
ZipArchive::locateName | Domů | ZipArchive::renameIndex


ZipArchive::renameIndex

(No version information available, might be only in CVS)

ZipArchive::renameIndex — Renames an entry defined by its index

Popis

bool ZipArchive::renameIndex ( int $index, string $newname )

Renames an entry defined by its index.

Seznam parametrů

index

Index of the entry to rename.

newname

New name.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 2463. Rename one entry

<?php
$zip = new ZipArchive;
$res = $zip->open('test.zip')
if ($res === TRUE) {
    $zip->renameIndex(2,'newname.txt');
    $zip->close();
} else {
    echo 'failed, code:' . $res;
}
?>

Předcházející | Nahoru | Další
ZipArchive::open | Domů | ZipArchive::renameName


ZipArchive::renameName

(No version information available, might be only in CVS)

ZipArchive::renameName — Renames an entry defined by its name

Popis

bool ZipArchive::renameName ( string $name, string $newname )

Renames an entry defined by its index.

Seznam parametrů

name

Name of the entry to rename.

newname

New name.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 2464. Rename one entry

<?php
$zip = new ZipArchive;
$res = $zip->open('test.zip');
if ($res === TRUE) {
    $zip->renameName('currentname.txt','newname.txt');
    $zip->close();
} else {
    echo 'failed, code:' . $res;
}
?>

Předcházející | Nahoru | Další
ZipArchive::renameIndex | Domů | ZipArchive::setArchiveComment


ZipArchive::setArchiveComment

(No version information available, might be only in CVS)

ZipArchive::setArchiveComment — Set the comment of a ZIP archive

Popis

mixed ZipArchive::setArchiveComment ( string $comment )

Set the comment of a ZIP archive.

Seznam parametrů

comment

The contents of the comment.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 2465. Create an archive and set a comment

<?php
$zip = new ZipArchive;
$res = $zip->open('test.zip', ZipArchive::CREATE);
if ($res === TRUE) {
    $zip->addFromString('test.txt', 'file content goes here');
    $z->setArchiveComment('new archive comment');
    $zip->close();
    echo 'ok';
} else {
    echo 'failed';
}
?>

Předcházející | Nahoru | Další
ZipArchive::renameName | Domů | ZipArchive::setCommentIndex


ZipArchive::setCommentIndex

(No version information available, might be only in CVS)

ZipArchive::setCommentIndex — Set the comment of an entry defined by its index

Popis

mixed ZipArchive::setCommentIndex ( int $index, string $comment )

Set the comment of an entry defined by its index.

Seznam parametrů

index

Index of the entry.

comment

The contents of the comment.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 2466. Open an archive and set a comment for an entry

<?php
$zip = new ZipArchive;
$res = $zip->open('test.zip');
if ($res === TRUE) {
    $z->setCommentIndex(2, 'new entry comment');
    $zip->close();
    echo 'ok';
} else {
    echo 'failed';
}
?>

Předcházející | Nahoru | Další
ZipArchive::setArchiveComment | Domů | ZipArchive::setCommentName


ZipArchive::setCommentName

(No version information available, might be only in CVS)

ZipArchive::setCommentName — Set the comment of an entry defined by its name

Popis

mixed ZipArchive::setCommentName ( string $name, string $comment )

Set the comment of an entry defined by its name.

Seznam parametrů

name

Name of the entry.

comment

The contents of the comment.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Příklady

Příklad 2467. Open an archive and set a comment for an entry

<?php
$zip = new ZipArchive;
$res = $zip->open('test.zip');
if ($res === TRUE) {
    $z->setCommentName('entry1.txt', 'new entry comment');
    $zip->close();
    echo 'ok';
} else {
    echo 'failed';
}
?>

Předcházející | Nahoru | Další
ZipArchive::setCommentIndex | Domů | ZipArchive::statIndex


ZipArchive::statIndex

(No version information available, might be only in CVS)

ZipArchive::statIndex — Get the details of an entry defined by its index.

Popis

mixed ZipArchive::statIndex ( int $index [, int $flags] )

The function obtains information about the entry defined by its index.

Seznam parametrů

index

Index of the entry

flags

ZIPARCHIVE::FL_UNCHANGED may be ORed to it to request information about the original file in the archive, ignoring any changes made.

Návratové hodnoty

Returns an array containing the entry details or FALSE on failure.

Příklady

Příklad 2468. Dump the stat info of an entry

<?php
$zip = new ZipArchive;
$res = $zip->open('test.zip')
if ($res === TRUE) {
    print_r($zip->statIndex(3));
    $zip->close();
} else {
    echo 'failed, code:' . $res;
}
?>

Výše uvedený příklad vypíše něco jako:

Array
(
    [name] => foobar/baz
    [index] => 3
    [crc] => 499465816
    [size] => 27
    [mtime] => 1123164748
    [comp_size] => 24
    [comp_method] => 8
)

Předcházející | Nahoru | Další
ZipArchive::setCommentName | Domů | ZipArchive::statName


ZipArchive::statName

(No version information available, might be only in CVS)

ZipArchive::statName — Get the details of an entry defined by its name.

Popis

mixed ZipArchive::statName ( name $name [, int $flags] )

The function obtains information about the entry defined by its name.

Seznam parametrů

name

Name of the entry

flags

The flags argument specifies how the name lookup should be done. Also, ZIPARCHIVE::FL_UNCHANGED may be ORed to it to request information about the original file in the archive, ignoring any changes made.

  • ZIPARCHIVE::FL_NOCASE

  • ZIPARCHIVE::FL_NODIR

  • ZIPARCHIVE::FL_UNCHANGED

Návratové hodnoty

Returns an array containing the entry details or FALSE on failure.

Příklady

Příklad 2469. Dump the stat info of an entry

<?php
$zip = new ZipArchive;
$res = $zip->open('test.zip')
if ($res === TRUE) {
    print_r($zip->statName('foobar/baz'));
    $zip->close();
} else {
    echo 'failed, code:' . $res;
}
?>

Výše uvedený příklad vypíše něco jako:

Array
(
    [name] => foobar/baz
    [index] => 3
    [crc] => 499465816
    [size] => 27
    [mtime] => 1123164748
    [comp_size] => 24
    [comp_method] => 8
)

Předcházející | Nahoru | Další
ZipArchive::statIndex | Domů | ZipArchive::unchangeAll


ZipArchive::unchangeAll

(No version information available, might be only in CVS)

ZipArchive::unchangeAll — Undo all changes done in the archive.

Popis

mixed ZipArchive::unchangeAll ( void )

Undo all changes done in the archive.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
ZipArchive::statName | Domů | ZipArchive::unchangeArchive


ZipArchive::unchangeArchive

(No version information available, might be only in CVS)

ZipArchive::unchangeArchive — Revert all global changes done in the archive.

Popis

mixed ZipArchive::unchangeArchive ( void )

Revert all global changes to the archive archive. For now, this only reverts archive comment changes.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
ZipArchive::unchangeAll | Domů | ZipArchive::unchangeIndex


ZipArchive::unchangeIndex

(No version information available, might be only in CVS)

ZipArchive::unchangeIndex — Revert all changes done to an entry at the given index.

Popis

mixed ZipArchive::unchangeIndex ( int $index )

Revert all changes done to an entry at the given index.

Seznam parametrů

index

Index of the entry.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
ZipArchive::unchangeArchive | Domů | ZipArchive::unchangeName


ZipArchive::unchangeName

(No version information available, might be only in CVS)

ZipArchive::unchangeName — Revert all changes done to an entry with the given name.

Popis

mixed ZipArchive::unchangeName ( string $name )

Revert all changes done to an entry.

Seznam parametrů

name

Name of the entry.

Návratové hodnoty

Vrací TRUE při úspěchu, FALSE při selhání.

Předcházející | Nahoru | Další
ZipArchive::unchangeIndex | Domů | CLXXXIX. Zlib Compression Functions


old_function

Klausule old_function umožňuje deklarovat funkci s identickou syntaxí jako v PHP/FI2 (kromě toho, že musíte 'function' nahradit 'old_function'.

Toto je zavržená možnost a měla by být používána pouze PHP/FI2->PHP 3 konvertorem.

Varování

Funkce deklarované jako old_function nelze volat z interního kódu PHP. To mj. znamená, že je nemůžete používat ve funkcích jako usort(), array_walk(), a register_shutdown_function(). Toto omezení můžete obejít napsáním wrapperu (v normální PHP 3 formě), z něhož voláte old_function.

Předcházející | Nahoru | Další
Návratové hodnoty | Domů | Funkce v proměnných


HaruAnnotation

(No version information available, might be only in CVS)

HaruAnnotation — Haru PDF Annotation Class

Přehled

   class HaruAnnotation

Class Members

Předdefinované konstanty

Tabulka 100.

Type | Name | Description
int | HaruAnnotation::NO_HIGHLIGHT |
int | HaruAnnotation::INVERT_BOX |
int | HaruAnnotation::INVERT_BORDER |
int | HaruAnnotation::DOWN_APPEARANCE |
int | HaruAnnotation::ICON_COMMENT |
int | HaruAnnotation::ICON_KEY |
int | HaruAnnotation::ICON_NOTE |
int | HaruAnnotation::ICON_HELP |
int | HaruAnnotation::ICON_NEW_PARAGRAPH |
int | HaruAnnotation::ICON_PARAGRAPH |
int | HaruAnnotation::ICON_INSERT |

Metody

HaruAnnotation::setBorderStyle()
HaruAnnotation::setHighlightMode()
HaruAnnotation::setIcon()
HaruAnnotation::setOpened()
Předcházející | Nahoru | Další
HaruOutline | Domů | HaruDestination


HaruDestination

(No version information available, might be only in CVS)

HaruDestination — Haru PDF Destination Class

Přehled

   class HaruDestination

Class Members

Metody

HaruDestination::setFitBH()
HaruDestination::setFitBV()
HaruDestination::setFitB()
HaruDestination::setFitH()
HaruDestination::setFitR()
HaruDestination::setFitV()
HaruDestination::setFit()
HaruDestination::setXYZ()
Předcházející | Nahoru | Další
HaruAnnotation | Domů | HaruAnnotation::setBorderStyle


HaruDoc

(No version information available, might be only in CVS)

HaruDoc — Haru PDF Document Class

Přehled

   class HaruDoc

Class Members

Předdefinované konstanty

Tabulka 97.

Type | Name | Description
int | HaruDoc::CS_DEVICE_GRAY |
int | HaruDoc::CS_DEVICE_RGB |
int | HaruDoc::CS_DEVICE_CMYK |
int | HaruDoc::CS_CAL_GRAY |
int | HaruDoc::CS_CAL_RGB |
int | HaruDoc::CS_LAB |
int | HaruDoc::CS_ICC_BASED |
int | HaruDoc::CS_SEPARATION |
int | HaruDoc::CS_DEVICE_N |
int | HaruDoc::CS_INDEXED |
int | HaruDoc::CS_PATTERN |
int | HaruDoc::ENABLE_READ |
int | HaruDoc::ENABLE_PRINT |
int | HaruDoc::ENABLE_EDIT_ALL |
int | HaruDoc::ENABLE_COPY |
int | HaruDoc::ENABLE_EDIT |
int | HaruDoc::ENCRYPT_R2 |
int | HaruDoc::ENCRYPT_R3 |
int | HaruDoc::INFO_AUTHOR |
int | HaruDoc::INFO_CREATOR |
int | HaruDoc::INFO_TITLE |
int | HaruDoc::INFO_SUBJECT |
int | HaruDoc::INFO_KEYWORDS |
int | HaruDoc::INFO_CREATION_DATE |
int | HaruDoc::INFO_MOD_DATE |
int | HaruDoc::COMP_NONE |
int | HaruDoc::COMP_TEXT |
int | HaruDoc::COMP_IMAGE |
int | HaruDoc::COMP_METADATA |
int | HaruDoc::COMP_ALL |
int | HaruDoc::PAGE_LAYOUT_SINGLE |
int | HaruDoc::PAGE_LAYOUT_ONE_COLUMN |
int | HaruDoc::PAGE_LAYOUT_TWO_COLUMN_LEFT |
int | HaruDoc::PAGE_LAYOUT_TWO_COLUMN_RIGHT |
int | HaruDoc::PAGE_MODE_USE_NONE |
int | HaruDoc::PAGE_MODE_USE_OUTLINE |
int | HaruDoc::PAGE_MODE_USE_THUMBS |
int | HaruDoc::PAGE_MODE_FULL_SCREEN |

Metody

HaruDoc::__construct()
HaruDoc::addPageLabel()
HaruDoc::addPage()
HaruDoc::createOutline()
HaruDoc::getCurrentEncoder()
HaruDoc::getCurrentPage()
HaruDoc::getEncoder()
HaruDoc::getFont()
HaruDoc::getInfoAttr()
HaruDoc::getPageLayout()
HaruDoc::getPageMode()
HaruDoc::getStreamSize()
HaruDoc::insertPage()
HaruDoc::loadJPEG()
HaruDoc::loadPNG()
HaruDoc::loadRAW()
HaruDoc::loadTTC()
HaruDoc::loadTTC()
HaruDoc::loadType1()
HaruDoc::output()
HaruDoc::readFromStream()
HaruDoc::resetError()
HaruDoc::resetStream()
HaruDoc::save()
HaruDoc::setCompressionMode()
HaruDoc::setCurrentEncoder()
HaruDoc::setEncryptionMode()
HaruDoc::setInfoAttr()
HaruDoc::setInfoDateAttr()
HaruDoc::setOpenAction()
HaruDoc::setPageLayout()
HaruDoc::setPageMode()
HaruDoc::setPagesConfiguration()
HaruDoc::setPassword()
HaruDoc::setPermission()
HaruDoc::useCNSEncodings()
HaruDoc::useCNSFonts()
HaruDoc::useCNTEncodings()
HaruDoc::useCNTFonts()
HaruDoc::useJPEncodings()
HaruDoc::useJPFonts()
HaruDoc::useKREncodings()
HaruDoc::useKRFonts()
Předcházející | Nahoru | Další
HaruException | Domů | HaruPage


HaruEncoder

(No version information available, might be only in CVS)

HaruEncoder — Haru PDF Encoder Class

Přehled

   class HaruEncoder

Class Members

Předdefinované konstanty

Tabulka 99.

Type | Name | Description
int | HaruEncoder::TYPE_SINGLE_BYTE |
int | HaruEncoder::TYPE_DOUBLE_BYTE |
int | HaruEncoder::TYPE_UNINITIALIZED |
int | HaruEncoder::UNKNOWN |
int | HaruEncoder::WMODE_HORIZONTAL |
int | HaruEncoder::WMODE_VERTICAL |
int | HaruEncoder::BYTE_TYPE_SINGLE |
int | HaruEncoder::BYTE_TYPE_LEAD |
int | HaruEncoder::BYTE_TYPE_TRAIL |
int | HaruEncoder::BYTE_TYPE_UNKNOWN |

Metody

HaruEncoder::getByteType()
HaruEncoder:: getType()
HaruEncoder::getUnicode()
HaruEncoder::getWritingMode()
Předcházející | Nahoru | Další
HaruImage | Domů | HaruOutline


HaruException

(No version information available, might be only in CVS)

HaruException — Haru PDF Exception Class

Přehled

   class HaruException

Class Members

Metody

Předcházející | Nahoru | Další
LIV. Haru PDF Functions | Domů | HaruDoc


HaruFont

(No version information available, might be only in CVS)

HaruFont — Haru PDF Font Class

Přehled

   class HaruFont

Class Members

Metody

HaruFont::getAscent()
HaruFont::getCapHeight()
HaruFont::getDescent()
HaruFont::getEncodingName()
HaruFont::getFontName()
HaruFont::getTextWidth()
HaruFont::getUnicodeWidth()
HaruFont::getXHeight()
HaruFont::measureText()
Předcházející | Nahoru | Další
HaruPage | Domů | HaruImage


HaruImage

(No version information available, might be only in CVS)

HaruImage — Haru PDF Image Class

Přehled

   class HaruImage

Class Members

Metody

HaruImage::getBitsPerComponent()
HaruImage::getColorSpace()
HaruImage::getHeight()
HaruImage::getSize()
HaruImage::getWidth()
HaruImage::setColorMask()
HaruImage::setMaskImage()
Předcházející | Nahoru | Další
HaruFont | Domů | HaruEncoder


HaruOutline

(No version information available, might be only in CVS)

HaruOutline — Haru PDF Outline Class

Přehled

   class HaruOutline

Class Members

Metody

HaruOutline::setDestination()
HaruOutline::setOpened()
Předcházející | Nahoru | Další
HaruEncoder | Domů | HaruAnnotation


HaruPage

(No version information available, might be only in CVS)

HaruPage — Haru PDF Page Class

Přehled

   class HaruPage

Class Members

Předdefinované konstanty

Tabulka 98.

Type | Name | Description
int | HaruPage::GMODE_PAGE_DESCRIPTION |
int | HaruPage::GMODE_TEXT_OBJECT |
int | HaruPage::GMODE_PATH_OBJECT |
int | HaruPage::GMODE_CLIPPING_PATH |
int | HaruPage::GMODE_SHADING |
int | HaruPage::GMODE_INLINE_IMAGE |
int | HaruPage::GMODE_EXTERNAL_OBJECT |
int | HaruPage::BUTT_END |
int | HaruPage::ROUND_END |
int | HaruPage::PROJECTING_SCUARE_END |
int | HaruPage::MITER_JOIN |
int | HaruPage::ROUND_JOIN |
int | HaruPage::BEVEL_JOIN |
int | HaruPage::FILL |
int | HaruPage::STROKE |
int | HaruPage::FILL_THEN_STROKE |
int | HaruPage::INVISIBLE |
int | HaruPage::FILL_CLIPPING |
int | HaruPage::STROKE_CLIPPING |
int | HaruPage::FILL_STROKE_CLIPPING |
int | HaruPage::CLIPPING |
int | HaruPage::TALIGN_LEFT |
int | HaruPage::TALIGN_RIGHT |
int | HaruPage::TALIGN_CENTER |
int | HaruPage::TALIGN_JUSTIFY |
int | HaruPage::SIZE_LETTER |
int | HaruPage::SIZE_LEGAL |
int | HaruPage::SIZE_A3 |
int | HaruPage::SIZE_A4 |
int | HaruPage::SIZE_A5 |
int | HaruPage::SIZE_B4 |
int | HaruPage::SIZE_B5 |
int | HaruPage::SIZE_EXECUTIVE |
int | HaruPage::SIZE_US4x6 |
int | HaruPage::SIZE_US4x8 |
int | HaruPage::SIZE_US5x7 |
int | HaruPage::SIZE_COMM10 |
int | HaruPage::PORTRAIT |
int | HaruPage::LANDSCAPE |
int | HaruPage::TS_WIPE_LIGHT |
int | HaruPage::TS_WIPE_UP |
int | HaruPage::TS_WIPE_LEFT |
int | HaruPage::TS_WIPE_DOWN |
int | HaruPage::TS_BARN_DOORS_HORIZONTAL_OUT |
int | HaruPage::TS_BARN_DOORS_HORIZONTAL_IN |
int | HaruPage::TS_BARN_DOORS_VERTICAL_OUT |
int | HaruPage::TS_BARN_DOORS_VERTICAL_IN |
int | HaruPage::TS_BOX_OUT |
int | HaruPage::TS_BOX_IN |
int | HaruPage::TS_BLINDS_HORIZONTAL |
int | HaruPage::TS_BLINDS_VERTICAL |
int | HaruPage::TS_DISSOLVE |
int | HaruPage::TS_GLITTER_RIGHT |
int | HaruPage::TS_GLITTER_DOWN |
int | HaruPage::TS_GLITTER_TOP_LEFT_TO_BOTTOM_RIGHT |
int | HaruPage::TS_REPLACE |
int | HaruPage::NUM_STYLE_DECIMAL |
int | HaruPage::NUM_STYLE_UPPER_ROMAN |
int | HaruPage::NUM_STYLE_LOWER_ROMAN |
int | HaruPage::NUM_STYLE_UPPER_LETTERS |
int | HaruPage::NUM_STYLE_LOWER_LETTERS |

Metody

HaruPage::arc()
HaruPage::beginText()
HaruPage::circle()
HaruPage::closePath()
HaruPage::concat()
HaruPage::createDestination()
HaruPage::createLinkAnnotation()
HaruPage::createTextAnnotation()
HaruPage::createUrlAnnotation()
HaruPage::curveTo()
HaruPage::curveTo2()
HaruPage::curveTo3()
HaruPage::drawImage()
HaruPage::ellipse()
HaruPage::endPath()
HaruPage::endText()
HaruPage::eofillStroke()
HaruPage::eofill()
HaruPage::fillStroke()
HaruPage::fill()
HaruPage::getCharSpace()
HaruPage::getCMYKFill()
HaruPage::getCMYKStroke()
HaruPage::getCurrentFontSize()
HaruPage::getCurrentFont()
HaruPage::getCurrentPos()
HaruPage::getCurrentTextPos()
HaruPage::getDash()
HaruPage::getFillingColorSpace()
HaruPage::getFlatness()
HaruPage::getGMode()
HaruPage::getGrayFill()
HaruPage::getGrayStroke()
HaruPage::getHeight()
HaruPage::getHorizontalScaling()
HaruPage::getLineCap()
HaruPage::getLineJoin()
HaruPage::getLineWidth()
HaruPage::getMiterLimit()
HaruPage::getRGBFill()
HaruPage::getRGBStroke()
HaruPage::getStrokingColorSpace()
HaruPage::getTextLeading()
HaruPage::getTextMatrix()
HaruPage::getTextRenderingMode()
HaruPage::getTextRise()
HaruPage::getTextWidth()
HaruPage::getTransMatrix()
HaruPage::getWidth()
HaruPage::getWordSpace()
HaruPage::lineTo()
HaruPage::measureText()
HaruPage::moveTextPos()
HaruPage::moveToNextLine()
HaruPage::moveTo()
HaruPage::rectangle()
HaruPage::setCharSpace()
HaruPage::setCMYKFill()
HaruPage::setCMYKStroke()
HaruPage::setDash()
HaruPage::setFlatness()
HaruPage::setFontAndSize()
HaruPage::setGrayFill()
HaruPage::setGrayStroke()
HaruPage::setHeight()
HaruPage::setHorizontalScaling()
HaruPage::setLineCap()
HaruPage::setLineJoin()
HaruPage::setLineWidth()
HaruPage::setMiterLimit()
HaruPage::setRGBFill()
HaruPage::setRGBStroke()
HaruPage::setRotate()
HaruPage::setSize()
HaruPage::setSlideShow()
HaruPage::setTextLeading()
HaruPage::setTextMatrix()
HaruPage::setTextTenderingMode()
HaruPage::setWidth()
HaruPage::setWordSpace()
HaruPage::showTextNextLine()
HaruPage::showText()
HaruPage::stroke()
HaruPage::textOut()
HaruPage::textRect()
Předcházející | Nahoru | Další
HaruDoc | Domů | HaruFont


Configuration

(No version information available, might be only in CVS)

Configuration — http module configuration directives

Konfigurace běhu

Chování těchto funkcí je ovlivněno nastavením parametrů v php.ini.

Tabulka 101. HTTP Configuration Options

Name | Default | Changeable | Description
http.etag.mode | "MD5" | PHP_INI_ALL | The hashing algorithm used to generate the ETag. MD5, SHA1, and CRC32 are always available. If the hash xtension is enabled, any hashing algorithms this extension provides are available, too.
http.log.cache | "" | PHP_INI_ALL | The path (or stream wrapper url) to a log file in which to write successful cache hits.
http.log.redirect | "" | PHP_INI_ALL | The path (or stream wrapper url) to a log file in which to write redirects.
http.log.not_found | "" | PHP_INI_ALL | The path (or stream wrapper url) to a log file in which to write "file not found" errors.
http.log.allowed_methods | "" | PHP_INI_ALL | The path (or stream wrapper url) to a log file in which to write "allowed methods" violations.
http.log.composite | "" | PHP_INI_ALL | The path (or stream wrapper url) to a log file in which to write all events.
http.request.methods.allowed | "" | PHP_INI_ALL | Allowed request methods. If a client issues a request with a request method other than listed here, PHP exits with a status of "405 Method not allowed". See the INI setting http.force_exit for what "exits" means.
http.request.methods.custom | "" | PHP_INI_PERDIR|PHP_INI_SYSTEM | Custom request methods. If you want to use any non-standard request methods, you can register them with this INI setting or http_request_method_register().
http.request.datashare.cookie | "0" | PHP_INI_SYSTEM | Whether the global HttpRequestDataShare should by default share cookie information.
http.request.datashare.dns | "1" | PHP_INI_SYSTEM | Whether the global HttpRequestDataShare should by default share name lookup information.
http.request.datashare.ssl | "0" | PHP_INI_SYSTEM | Whether the global HttpRequestDataShare should by default share SSL session information. This is not yet implemented in libcurl.
http.request.datashare.connect | "0" | PHP_INI_SYSTEM | Whether the global HttpRequestDataShare should by default share connect information. This is not yet implemented in libcurl.
http.persistent.handles.limit | "-1" | PHP_INI_SYSTEM | The maximum amount of persistent handles to keep alive.
http.persistent.handles.ident | "GLOBAL" | PHP_INI_ALL | The ident of persistent handles.
http.send.inflate.start_auto | "0" | PHP_INI_PERDIR|PHP_INI_SYSTEM | Whether to automatically start the inflate output handler.
http.send.inflate.start_flags | "0" | PHP_INI_ALL | Initialization settings for the inflate output handler.
http.send.deflate.start_auto | "0" | PHP_INI_PERDIR|PHP_INI_SYSTEM | Whether to automatically start the deflate output handler.
http.send.deflate.start_flags | "0" | PHP_INI_ALL | Initialization settings for the deflate output handler. See deflate constants.
http.send.not_found_404 | "1" | PHP_INI_ALL | Whether to automatically exit with a status of "404 Not found", if http_send_file() was not able to find the specified file. See the INI setting http.force_exit for what "exits" means.
http.only_exceptions | "0" | PHP_INI_ALL | Whether all notices/warnings/errors should be thrown as exceptions.
http.force_exit | "1" | PHP_INI_ALL | Each occasion where "exits with a status of..." is mentioned, usually causes the halt of the scripting engine. Disable this option if you alternatively want to start a discarding (dev/null) output handler and continue script execution.

Předcházející | Nahoru | Další
Installation | Domů | Resources


Constants

(No version information available, might be only in CVS)

Constants — predefined http module constants

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

Constants usable with http_support()

HTTP_SUPPORT (integer)
querying for this constant will always return TRUE
HTTP_SUPPORT_REQUESTS (integer)
whether support to issue HTTP requests is given, ie. libcurl support was compiled in
HTTP_SUPPORT_MAGICMIME (integer)
whether support to guess the Content-Type of HTTP messages is given, ie. libmagic support was compiled in
HTTP_SUPPORT_ENCODINGS (integer)
whether support for zlib encodings is given, ie. libz support was compiled in
HTTP_SUPPORT_SSLREQUESTS (integer)
whether support to issue HTTP requests over SSL is givem, ie. linked libcurl was built with SSL support

Constants usable with http_parse_params()

HTTP_PARAMS_ALLOW_COMMA (integer)
allow commans additionally to semicolons as separator
HTTP_PARAMS_ALLOW_FAILURE (integer)
continue parsing after an error occurred
HTTP_PARAMS_RAISE_ERROR (integer)
raise PHP warnings on parse errors
HTTP_PARAMS_DEFAULT (integer)
all three values above, bitwise or'ed

Constants usable with http_parse_cookie() and its return value

HTTP_COOKIE_PARSE_RAW (integer)
don't urldecode values
HTTP_COOKIE_SECURE (integer)
whether "secure" was found in the cookie's parameters list
HTTP_COOKIE_HTTPONLY (integer)
whether "httpOnly" was found in the cookie's parameter list

Constants usable with http_deflate() and HttpDeflateStream

HTTP_DEFLATE_LEVEL_DEF (integer)
HTTP_DEFLATE_LEVEL_MIN (integer)
HTTP_DEFLATE_LEVEL_MAX (integer)
HTTP_DEFLATE_TYPE_ZLIB (integer)
HTTP_DEFLATE_TYPE_GZIP (integer)
HTTP_DEFLATE_TYPE_RAW (integer)
HTTP_DEFLATE_STRATEGY_DEF (integer)
HTTP_DEFLATE_STRATEGY_FILT (integer)
HTTP_DEFLATE_STRATEGY_HUFF (integer)
HTTP_DEFLATE_STRATEGY_RLE (integer)
HTTP_DEFLATE_STRATEGY_FIXED (integer)

Constants usable with HttpDeflateStream and HttpInflateStream

HTTP_ENCODING_STREAM_FLUSH_NONE (integer)
don't flush
HTTP_ENCODING_STREAM_FLUSH_SYNC (integer)
synchronized flush only
HTTP_ENCODING_STREAM_FLUSH_FULL (integer)
full data flush

Constants used for error reporting and Exceptions

HTTP_E_RUNTIME (integer)
runtime error
HTTP_E_INVALID_PARAM (integer)
an invalid parameter was passed
HTTP_E_HEADER (integer)
header() or similar operation failed
HTTP_E_MALFORMED_HEADERS (integer)
HTTP header parse error
HTTP_E_REQUEST_METHOD (integer)
unknown/invalid request method
HTTP_E_MESSAGE_TYPE (integer)
with operation incompatible message type
HTTP_E_ENCODING (integer)
encoding/decoding error
HTTP_E_REQUEST (integer)
request failure
HTTP_E_REQUEST_POOL (integer)
request pool failure
HTTP_E_SOCKET (integer)
socket exception
HTTP_E_RESPONSE (integer)
response failure
HTTP_E_URL (integer)
invalid URL
HTTP_E_QUERYSTRING (integer)
querystring operation failure

Constants usable with HttpMessage

HTTP_MSG_NONE (integer)
the message is of no specific type
HTTP_MSG_REQUEST (integer)
request style message
HTTP_MSG_RESPONSE (integer)
response style message

Constants usable with HttpQueryString

HTTP_QUERYSTRING_TYPE_BOOL (integer)
HTTP_QUERYSTRING_TYPE_INT (integer)
HTTP_QUERYSTRING_TYPE_FLOAT (integer)
HTTP_QUERYSTRING_TYPE_STRING (integer)
HTTP_QUERYSTRING_TYPE_ARRAY (integer)
HTTP_QUERYSTRING_TYPE_OBJECT (integer)

Constants used for the httpauthtype request option

HTTP_AUTH_BASIC (integer)
use "basic" authentication
HTTP_AUTH_DIGEST (integer)
use "digest" authentication
HTTP_AUTH_NTLM (integer)
use "NTLM" authentication
HTTP_AUTH_GSSNEG (integer)
use "GSS-NEGOTIATE" authentication
HTTP_AUTH_ANY (integer)
try any authentication scheme

Constants used for the HTTP protocol version request option

HTTP_VERSION_ANY (integer)
no specific HTTP protocol version
HTTP_VERSION_1_0 (integer)
HTTP version 1.0
HTTP_VERSION_1_1 (integer)
HTTP version 1.1

Constants used for the SSL protocol type and version request option

HTTP_SSL_VERSION_ANY (integer)
no specific SSL protocol version
HTTP_SSL_VERSION_TLSv1 (integer)
use TLSv1 only
HTTP_SSL_VERSION_SSLv3 (integer)
use SSLv3 only
HTTP_SSL_VERSION_SSLv2 (integer)
use SSLv2 only

Constants used for the proxytype request option

HTTP_PROXY_SOCKS4 (integer)
the proxy is a SOCKS4 type proxy
HTTP_PROXY_SOCKS5 (integer)
the proxy is a SOCKS5 type proxy
HTTP_PROXY_HTTP (integer)
standard HTTP proxy

Constants used for the ipresolve request option

HTTP_IPRESOLVE_V4 (integer)
use IPv4 only for name lookups
HTTP_IPRESOLVE_V6 (integer)
use IPv6 only for name lookups
HTTP_IPRESOLVE_ANY (integer)
use any IP mechanism only for name lookups

Predefined HTTP request method constants

HTTP_METH_GET (integer)
HTTP_METH_HEAD (integer)
HTTP_METH_POST (integer)
HTTP_METH_PUT (integer)
HTTP_METH_DELETE (integer)
HTTP_METH_OPTIONS (integer)
HTTP_METH_TRACE (integer)
HTTP_METH_CONNECT (integer)
HTTP_METH_PROPFIND (integer)
HTTP_METH_PROPPATCH (integer)
HTTP_METH_MKCOL (integer)
HTTP_METH_COPY (integer)
HTTP_METH_MOVE (integer)
HTTP_METH_LOCK (integer)
HTTP_METH_UNLOCK (integer)
HTTP_METH_VERSION_CONTROL (integer)
HTTP_METH_REPORT (integer)
HTTP_METH_CHECKOUT (integer)
HTTP_METH_CHECKIN (integer)
HTTP_METH_UNCHECKOUT (integer)
HTTP_METH_MKWORKSPACE (integer)
HTTP_METH_UPDATE (integer)
HTTP_METH_LABEL (integer)
HTTP_METH_MERGE (integer)
HTTP_METH_BASELINE_CONTROL (integer)
HTTP_METH_MKACTIVITY (integer)
HTTP_METH_ACL (integer)

Constants usable with http_redirect()

HTTP_REDIRECT (integer)
guess applicable redirect method
HTTP_REDIRECT_PERM (integer)
permanent redirect (301 Moved permanently)
HTTP_REDIRECT_FOUND (integer)

standard redirect (302 Found)

Poznámka: RFC 1945 and RFC 2068 specify that the client is not allowed to change the method on the redirected request. However, most existing user agent implementations treat 302 as if it were a 303 response, performing a GET on the Location field-value regardless of the original request method. The status codes 303 and 307 have been added for servers that wish to make unambiguously clear which kind of reaction is expected of the client.

HTTP_REDIRECT_POST (integer)
redirect applicable to POST requests (303 See other)
HTTP_REDIRECT_PROXY (integer)
proxy redirect (305 Use proxy)
HTTP_REDIRECT_TEMP (integer)
temporary redirect (307 Temporary Redirect)

Constants usable with http_build_url()

HTTP_URL_REPLACE (integer)
replace every part of the first URL when there's one of the second URL
HTTP_URL_JOIN_PATH (integer)
join relative paths
HTTP_URL_JOIN_QUERY (integer)
join query strings
HTTP_URL_STRIP_USER (integer)
strip any user authentication information
HTTP_URL_STRIP_PASS (integer)
strip any password authentication information
HTTP_URL_STRIP_AUTH (integer)
strip any authentication information
HTTP_URL_STRIP_PORT (integer)
strip explicit port numbers
HTTP_URL_STRIP_PATH (integer)
strip complete path
HTTP_URL_STRIP_QUERY (integer)
strip query string
HTTP_URL_STRIP_FRAGMENT (integer)
strip any fragments (#identifier)
HTTP_URL_STRIP_ALL (integer)
strip anything but scheme and host
Předcházející | Nahoru | Další
Resources | Domů | Request Options


HttpDeflateStream

(No version information available, might be only in CVS)

HttpDeflateStream — HTTP Deflate Stream Class

Přehled

class HttpDeflateStream

Class Members

Předdefinované konstanty

Tabulka 107.

Type | Name | Description
int | TYPE_GZIP | gzip encoding
int | TYPE_ZLIB | zlib AKA deflate encoding
int | TYPE_RAW | raw deflate encoding
int | LEVEL_DEF | default compression level
int | LEVEL_MIN | minimum compression level
int | LEVEL_MAX | maximum compression level
int | STRATEGY_DEF | default strategy
int | STRATEGY_FILT | filtered strategy
int | STRATEGY_HUFF | Huffman strategy
int | STRATEGY_RLE | RLE strategy
int | STRATEGY_FIXED | fixed strategy
int | FLUSH_NONE | no forced flush
int | FLUSH_SYNC | synching flush
int | FLUSH_FULL | full flush

Metody

HttpDeflateStream::factory()
HttpDeflateStream::__construct()
HttpDeflateStream::update()
HttpDeflateStream:: flush()
HttpDeflateStream::finish()

Příklady

Příklad 724. A HttpDeflateStream example

<?php
$stream = new HttpDeflateStream(
    HttpDeflateStream::TYPE_GZIP |
    HttpDeflateStream::LEVEL_MAX |
    HttpDeflateStream::FLUSH_SYNC);

echo $stream->update($data);
echo $stream->finish();
?>

Předcházející | Nahoru | Další
HttpQueryString::xlate | Domů | HttpDeflateStream::factory


HttpInflateStream

(No version information available, might be only in CVS)

HttpInflateStream — HTTP Inflate Stream

Přehled

   class HttpInflateStream

Class Members

Constants

Tabulka 108.

Type | Name | Description
int | FLUSH_NONE | no forced flush
int | FLUSH_SYNC | synching flush
int | FLUSH_FULL | full flush

Poznámka: Flushing usually has no effect on inflate streams.

Metody

HttpInflateStream::factory()
HttpInflateStream::__construct()
HttpInflateStream::update()
HttpInflateStream:: flush()
HttpInflateStream::finish()

Příklady

Příklad 725. A HttpInflateStream example

<?php
$stream = new HttpInflateStream;
echo $stream->update($data);
echo $stream->finish();
?>

Předcházející | Nahoru | Další
HttpDeflateStream::finish | Domů | HttpInflateStream::factory


HttpMessage

(No version information available, might be only in CVS)

HttpMessage — HTTP Message Class

Přehled

   class HttpMessage implements Iterator, Countable, Serializable

Class Members

Vlastnosti

Tabulka 102. Instance Properties

Modifiers | Type | Name | Description
protected | int | type | message type
protected | string | body | message body
protected | float | httpVersion | HTTP protocol version
protected | array | headers | message headers
protected | string | requestMethod | request method name
protected | requestUrl | string | request URL
protected | int | responseCode | response code
protected | string | responseStatus | response status message
protected | HttpMessage | parentMessage | reference to parent message

Poznámka: None of these default properties can be accessed by reference, array key/index notation nor be used in increment or decrement operations.

Předdefinované konstanty

Tabulka 103.

Type | Name | Description
int | TYPE_NONE | message has is of no specific type
int | TYPE_REQUEST | message is a request style HTTP message
int | TYPE_RESPONSE | message is a response style HTTP message

Metody

HttpMessage::construct()
HttpMessage::factory()
HttpMessage::fromEnv()
HttpMessage::fromString()
HttpMessage::toString()
HttpMessage::toMessageTypeObject()
HttpMessage::guessContentType()
HttpMessage::detach()
HttpMessage::prepend()
HttpMessage::reverse()
HttpMessage::send()
HttpMessage::getParentMessage()
HttpMessage:: getType()
HttpMessage:: setType()
HttpMessage::getHttpVersion()
HttpMessage::setHttpVersion()
HttpMessage::getHeaders()
HttpMessage::getHeader()
HttpMessage::addHeaders()
HttpMessage::setHeaders()
HttpMessage::getBody()
HttpMessage::setBody()
HttpMessage::getRequestMethod()
HttpMessage::setRequestMethod()
HttpMessage::getRequestUrl()
HttpMessage::setRequestUrl()
HttpMessage::getResponseCode()
HttpMessage::setResponseCode()
HttpMessage::getResponseStatus()
HttpMessage::setResponseStatus()
Předcházející | Nahoru | Další
Request Options | Domů | HttpMessage::__construct


HttpQueryString

(No version information available, might be only in CVS)

HttpQueryString — HTTP Query String Class

Přehled

   class HttpQueryString implements Serializable, ArrayAccess

Class Members

Vlastnosti

Tabulka 104. Instance Properties

Modifiers | Type | Name | Description
private | array | queryArray | query parameters
private | string | queryString | serialized query parameters

Tabulka 105. Static Properties

Modifiers | Type | Name | Description
private | array | instance | holds singletons

Předdefinované konstanty

Tabulka 106.

Type | Name | Description
int | TYPE_BOOL | retrieve query param as bool
int | TYPE_INT | retrieve query param as int
int | TYPE_FLOAT | retrieve query param as float
int | TYPE_STRING | retrieve query param as string
int | TYPE_ARRAY | retrieve query param as array
int | TYPE_OBJECT | retrieve query param as object

Metody

HttpQueryString::construct()
HttpQueryString::singleton()
HttpQueryString::get()
HttpQueryString::mod()
HttpQueryString::set()
HttpQueryString::toArray()
HttpQueryString::toString()
HttpQueryString::xlate()
Předcházející | Nahoru | Další
HttpMessage::setResponseStatus | Domů | HttpQueryString::__construct


HttpRequest

(No version information available, might be only in CVS)

HttpRequest — HTTP Request Class

Přehled

   class HttpRequest

Class Members

Vlastnosti

Tabulka 109. Instance Properties

Modifiers | Type | Name | Description
protected | array | options | request options to configure the request; see request options
protected | array | postFields | form data: array("fieldname" => "fieldvalue")
protected | array | postFiles | files to upload: array(array("name" => "image", "file" => "/home/u/images/u.png", "type" => "image/png"))
protected | array | responseInfo | information (statistical) about the request/response; see Request/response information
protected | HttpMessage | responseMessage | the response message
protected | integer | responseCode | the numerical response code
protected | string | responseStatus | the literal response status text
protected | integer | method | the request method to use
protected | string | url | the request url
protected | string | contentType | the content type to use for raw post requests
protected | string | rawPostData | raw post data
protected | string | queryData | query parameters
protected | string | putFile | the file to upload with a PUT request
protected | string | putData | raw data to upload with a PUT request
protected | HttpMessage | history | the whole request/response history if history logging is enabled
public | boolean | recordHistory | whether to enable history logging

Předdefinované konstanty

Tabulka 110.

Type | Name | Description
integer | METH_GET | GET request method
integer | METH_HEAD | HEAD request method
integer | METH_POST | POST request method
integer | METH_PUT | PUT request method
integer | METH_DELETE | DELETE request method
integer | METH_OPTIONS | OPTIONS request method
integer | METH_TRACE | TRACE request method
integer | METH_CONNECT | CONNECT request method
integer | METH_PROPFIND | PROPFIND request method
integer | METH_PROPPATCH | PROPPATCH request method
integer | METH_MKCOL | MKCOL request method
integer | METH_COPY | COPY request method
integer | METH_MOVE | MOVE request method
integer | METH_LOCK | LOCK request method
integer | METH_UNLOCK | UNLOCK request method
integer | METH_VERSION_CONTROL | VERSION-CONTROL request method
integer | METH_REPORT | REPORT request method
integer | METH_CHECKOUT | CHECKOUT request method
integer | METH_CHECKIN | CHECKIN request method
integer | METH_UNCHECKOUT | UNCHECKOUT request method
integer | METH_MKWORKSPACE | MKWORKSPACE request method
integer | METH_UPDATE | UPDATE request method
integer | METH_LABEL | LABEL request method
integer | METH_MERGE | MERGE request method
integer | METH_BASELINE_CONTROL | BASELINE-CONTROL request method
integer | METH_MKACTIVITY | MKACTIVITY request method
integer | METH_ACL | ACL request method
integer | VERSION_1_0 | HTTP protocol version 1.0
integer | VERSION_1_1 | HTTP protocol version 1.1
integer | VERSION_ANY | any HTTP protocol version
integer | AUTH_BASIC | basic authentication
integer | AUTH_DIGEST | digest authentication
integer | AUTH_NTLM | NTLM authentication
integer | AUTH_GSSNEG | GSS negotiate authentication
integer | AUTH_ANY | any authentication
integer | PROXY_SOCKS4 | SOCKS v4 proxy
integer | PROXY_SOCKS5 | SOCKS v5 proxy
integer | PROXY_HTTP | HTTP proxy
integer | SSL_VERSION_TLSv1 | use TLS v1
integer | SSL_VERSION_SSLv2 | use SSL v2
integer | SSL_VERSION_SSLv3 | use SSL v3
integer | SSL_VERSION_ANY | use any SSL/TLS method
integer | IPRESOLVE_V4 | resolve via IPv4 only
integer | IPRESOLVE_V6 | resolve via IPv6 only
integer | IPRESOLVE_ANY | use any resolving methods

Metody

HttpRequest::construct()
HttpRequest::getOptions()
HttpRequest::setOptions()
HttpRequest::getSslOptions()
HttpRequest::addSslOptions()
HttpRequest::setSslOptions()
HttpRequest::getUrl()
HttpRequest::setUrl()
HttpRequest::getMethod()
HttpRequest::setMethod()
HttpRequest::enableCookies()
HttpRequest::resetCookies()
HttpRequest::getCookies()
HttpRequest::addCookies()
HttpRequest::setCookies()
HttpRequest::getHeaders()
HttpRequest::addHeaders()
HttpRequest::setHeaders()
HttpRequest::getContentType()
HttpRequest::setContentType()
HttpRequest::getQueryData()
HttpRequest::addQueryData()
HttpRequest::setQueryData()
HttpRequest::getPostFields()
HttpRequest::addPostFields()
HttpRequest::setPostFields()
HttpRequest::getPostFiles()
HttpRequest::addPostFile()
HttpRequest::setPostFiles()
HttpRequest::getRawPostData()
HttpRequest::addRawPostData()
HttpRequest::setRawPostData()
HttpRequest::getPutData()
HttpRequest::addPutData()
HttpRequest::setPutData()
HttpRequest::getPutFile()
HttpRequest::setPutFile()
HttpRequest::send()
HttpRequest::getRequestMessage()
HttpRequest::getRawRequestMessage()
HttpRequest::getResponseMessage()
HttpRequest::getRawResponseMessage()
HttpRequest::getResponseCode()
HttpRequest::getResponseStatus()
HttpRequest::getResponseHeader()
HttpRequest::getResponseCookies()
HttpRequest::getResponseBody()
HttpRequest::getResponseData()
HttpRequest::getResponseInfo()
HttpRequest::clearHistory()
HttpRequest::getHistory()
Předcházející | Nahoru | Další
HttpInflateStream::finish | Domů | HttpRequest::addCookies


HttpRequestPool

(No version information available, might be only in CVS)

HttpRequestPool — HTTP Request Pool Class

Přehled

   class HttpRequest implements Iterator, Countable

Class Members

Vlastnosti

The HttpRequestPool class does not have any properties.

Předdefinované konstanty

The HttpRequestPool class does not have any constants.

Metody

HttpRequestPool::construct()
HttpRequestPool::destruct()
HttpRequestPool::attach()
HttpRequestPool::detach()
HttpRequestPool::getAttachedRequests()
HttpRequestPool::getFinishedRequests()
HttpRequestPool:: reset()
HttpRequestPool::send()
HttpRequestPool::socketPerform()
HttpRequestPool::socketSelect()
Předcházející | Nahoru | Další
HttpRequest::setUrl | Domů | HttpRequestPool::attach


HttpResponse

(No version information available, might be only in CVS)

HttpResponse — HTTP Response Class

Přehled

static class HttpResponse

Class Members

Vlastnosti

Tabulka 111. Static Properties

Modifiers | Type | Name | Description
protected | boolean | cache | whether caching the response should be attempted
protected | boolean | gzip | whether the sent entity should be gzip'ed on the fly
protected | string | eTag | the generated or custom ETag
protected | integer | lastModified | the generated or custom timestamp of last modification
protected | string | cacheControl | Cache-Control setting
protected | string | contentType | the Content-Type of the sent entity
protected | string | contentDisposition | the Content-Disposition of the sent entity
protected | integer | bufferSize | the chunk buffer size used for throttling
protected | double | throttleDelay | the seconds to delay when throttling

Předdefinované konstanty

Tabulka 112.

Type | Name | Description
integer | REDIRECT | guess applicable redirect method
integer | REDIRECT_PERM | permanent redirect (301 Moved permanently)
integer | REDIRECT_FOUND | standard redirect (302 Found)
integer | REDIRECT_POST | redirect applicable to POST requests (303 See other)
integer | REDIRECT_PROXY | proxy redirect (305 Use proxy)
integer | REDIRECT_TEMP | temporary redirect (307 Temporary Redirect)

Metody

HttpResponse::getBufferSize()
HttpResponse::setBufferSize()
HttpResponse::getCacheControl()
HttpResponse::setCacheControl()
HttpResponse::getCache()
HttpResponse::setCache()
HttpResponse::getContentDisposition()
HttpResponse::setContentDisposition()
HttpResponse::getContentType()
HttpResponse::setContentType()
HttpResponse::getData()
HttpResponse::setData()
HttpResponse::getETag()
HttpResponse::setETag()
HttpResponse::getFile()
HttpResponse::setFile()
HttpResponse::getGzip()
HttpResponse::setGzip()
HttpResponse::getHeader()
HttpResponse::setHeader()
HttpResponse::getLastModified()
HttpResponse::setLastModified()
HttpResponse::getStream()
HttpResponse::setStream()
HttpResponse::getThrottleDelay()
HttpResponse::setThrottleDelay()
HttpResponse::redirect()
HttpResponse::capture()
HttpResponse::send()
HttpResponse::guessContentType()
HttpResponse::redirect()
HttpResponse::status()
HttpResponse::getRequestHeaders()
HttpResponse::getRequestBody()
HttpResponse::getRequestBodyStream()
Předcházející | Nahoru | Další
HttpRequestPool::socketSelect | Domů | HttpResponse::capture


Installation

(No version information available, might be only in CVS)

Installation — Installing the HTTP extension

Instalace

Toto rozšíření » PECL není přibaleno k PHP.

Informace o instalaci tohoto PECL rozšíření lze najít v kapitole manuálu nazvané Instalace rozšíření PECL. Další informace, jako nové verze, soubory ke stažení, zdrojové soubory, správcovské informace a CHANGELOG, lze najít zde: » http://pecl.php.net/package/pecl_http.

Poznámka: The official name of this extension is pecl_http.

Tuto DLL knihovnu pro rozšíření PECL můžete stahovat ze stránky » PHP Downloads nebo z » http://snaps.php.net/.

Installation requirements on Windows

In order to be able to load this extension on Windows, you additionally need to load the following PHP extensions: hash, iconv , a SPL.

Installation requirements on other platforms

The extension must be built with » libcurl support to enable request functionality (--with-http-curl-requests). A library version equal or greater to v7.12.3 is required.

To enable support for sending and receiving compressed responses, the extension must be built with » zlib support (--with-http-zlib-compression). A library version equal or greater than v1.2.2 is required.

Content type quessing can be enabled by building this extension with » libmagic support (--with-http-magic-mime).

Předcházející | Nahoru | Další
LVI. HTTP | Domů | Configuration


Request Options

(No version information available, might be only in CVS)

Request Options — options usable with the HttpRequest class and request functions

Overview

Options related to time outs

timeout (integer)
seconds the whole request may take to complete
connecttimeout (integer)
seconds the connect, including name resolving, may take
dns_cache_timeout (integer)
seconds after an dns cache entry times out

Options related to urls

url (string)
the request url
port (integer)
use another port as specified in the url
redirect (integer)
whether and how many redirects to follow; defaults to 0
unrestrictedauth (bool)
whether to continue sending credentials on redirects to a different host
referer (string)
the refererring url to send

Options related to cookies

encodecookies (bool)
whether custom cookies should be urlencode()d prior sending
cookies (array)
list of cookies as associative array like array("cookie" => "value")
cookiestore (string)
path to a file where cookies are/will be stored
cookiesession (bool)
don't load session cookies from cookiestore if TRUE

Options related to headers

useragent (string)
the user agent to send; defaults to PECL::HTTP/x.y.z (PHP/x.y.z); omitted if explicitly set to an empty string
lastmodified (int)
timestamp for If-(Un)Modified-Since header
etag (string)
quoted etag for If-(None-)Match header
headers (array)
list of custom headers as associative array like array("header" => "value")

Options related to authentication

httpauth (string)
http credentials in "user:pass" format
httpauthtype (int)
HTTP authentication type constant
(array)

Options related to proxies

proxyhost (string)
proxy host in "host[:port]" format
proxyport (int)
use another proxy port as specified in proxyhost
proxytype (int)
HTTP proxy type constant
proxyauth (string)
proxy credentials in "user:pass" format
proxyauthtype (int)
HTTP authentication type constant

Options related to the transfer

compress (bool)
whether to request and accept a gzip/deflate content encoded response
resume (int)
start the download at the specified byte offset if server support is given (indicated by a 206 response code)
range (array)
array of arrays, each containing two integers, specifying the ranges to download if server support is given (indicated by a 206 response code); only recognized if the resume option is empty

Options imposing limits

maxfilesize (integer)
maximum file size that should be downloaded; has no effect, if the size of the requested entity is unknown (eg. dynamic pages with chunked transfer encoding etc.)
low_speed_limit (int)
the lowest transfer speed a successful request may have
low_speed_time (int)
the time in which low_speed_limit must be transferred for a successful request
max_send_speed (int)
maximum send speed in bytes per second
max_recv_speed (int)
maximum receive speed in bytes per second

Callback options

onprogress (callback)
progress callback

Network options

interface (string)
outgoing network interface (ifname, ip or hostname)
portrange (array)
2 integers specifying outgoing portrange to try

SSL options

ssl (array)

Poznámka: SSL options are set through an array with the single "ssl" request option name.

cert (string)
path to certificate
certtype (string)
type of certificate
certpasswd (string)
password for certificate
key (string)
path to key
keytype (string)
type of key
keypasswd (string)
pasword for key
engine (string)
ssl engine to use
version (int)
ssl version to use
verifypeer (bool)
whether to verify the peer
verifyhost (bool)
whether to verify the host
cipher_list (string)
list of allowed ciphers
cainfo (string)
capath (string)
random_file (string)
egdsocket (string)
Předcházející | Nahoru | Další
Constants | Domů | HttpMessage


Resources

(No version information available, might be only in CVS)

Resources — Resources created by the HTTP extension

Typy prostředků

This extension defines a stream resource returned by http_get_request_body_stream() and (thereafter) HttpResponse::getStream().

Předcházející | Nahoru | Další
Configuration | Domů | Constants


Constants

(No version information available, might be only in CVS)

Constants — Imagick class constants

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

Colortype constants

imagick::COLOR_BLACK (integer)
imagick::COLOR_BLUE (integer)
imagick::COLOR_CYAN (integer)
Cyan
imagick::COLOR_GREEN (integer)
Green
imagick::COLOR_RED (integer)
Red
imagick::COLOR_YELLOW (integer)
Yellow
imagick::COLOR_MAGENTA (integer)
Magenta
imagick::COLOR_OPACITY (integer)
Opacity
imagick::COLOR_ALPHA (integer)
Alpha
imagick::COLOR_FUZZ (integer)
Fuzz

Dispose type constants

imagick::DISPOSE_UNRECOGNIZED (integer)
Unrecognized
imagick::DISPOSE_UNRECOGNIZED (integer)
Unrecognized
imagick::DISPOSE_UNDEFINED (integer)
Undefined
imagick::DISPOSE_NONE (integer)
None
imagick::DISPOSE_BACKGROUND (integer)
Background
imagick::DISPOSE_PREVIOUS (integer)
Previous

Composite Operator Constants

imagick::COMPOSITE_OVER (integer)
Overlay one image over the next
imagick::COMPOSITE_IN (integer)
Replaces the inside of one layer with another
imagick::COMPOSITE_OUT (integer)
Replaces the outside of one layer with another
imagick::COMPOSITE_ATOP (integer)
Composites the inside of one layer with the other
imagick::COMPOSITE_XOR (integer)
The part of the source that lies outside of the destination is combined with the part of the destination that lies outside the source.
imagick::COMPOSITE_PLUS (integer)
The source is added to the destination and replaces the destination.
imagick::COMPOSITE_MINUS (integer)
The source is subtracted to the destination and replaces the destination.
imagick::COMPOSITE_ADD (integer)
Deprecated
imagick::COMPOSITE_SUBTRACT (integer)
Deprecated
imagick::COMPOSITE_DIFFERENCE (integer)
The difference in color values. Good for comparing images.
imagick::COMPOSITE_BUMPMAP (integer)
The same as COMPOSITE_MULTIPLY, except the source is converted to greyscale first.
imagick::COMPOSITE_COPY (integer)
Simply place the source on top of the destination.
imagick::COMPOSITE_DISPLACE (integer)
imagick::COMPOSITE_DEFAULT (integer)

Montage Mode constants

imagick::MONTAGEMODE_FRAME (integer)
imagick::MONTAGEMODE_UNFRAME (integer)
imagick::MONTAGEMODE_CONCATENATE (integer)

Style constants

imagick::STYLE_NORMAL (integer)
imagick::STYLE_ITALIC (integer)
imagick::STYLE_OBLIQUE (integer)
imagick::STYLE_ANY (integer)

Filter constants

imagick::FILTER_UNDEFINED (integer)
imagick::FILTER_POINT (integer)
imagick::FILTER_BOX (integer)
imagick::FILTER_TRIANGLE (integer)
imagick::FILTER_HERMITE (integer)
imagick::FILTER_HANNING (integer)
imagick::FILTER_HAMMING (integer)
imagick::FILTER_BLACKMAN (integer)
imagick::FILTER_GAUSSIAN (integer)
imagick::FILTER_QUADRATIC (integer)
imagick::FILTER_CUBIC (integer)
imagick::FILTER_CATROM (integer)
imagick::FILTER_MITCHELL (integer)
imagick::FILTER_LANCZOS (integer)
imagick::FILTER_BESSEL (integer)
imagick::FILTER_SINC (integer)

Image type constants

imagick::IMGTYPE_UNDEFINED (integer)
imagick::IMGTYPE_BILEVEL (integer)
imagick::IMGTYPE_GRAYSCALE (integer)
imagick::IMGTYPE_GRAYSCALEMATTE (integer)
imagick::IMGTYPE_PALETTE (integer)
imagick::IMGTYPE_PALETTEMATTE (integer)
imagick::IMGTYPE_TRUECOLOR (integer)
imagick::IMGTYPE_TRUECOLORMATTE (integer)
imagick::IMGTYPE_COLORSEPARATION (integer)
imagick::IMGTYPE_COLORSEPARATIONMATTE (integer)
imagick::IMGTYPE_OPTIMIZE (integer)

Resolution constants

imagick::RESOLUTION_UNDEFINED (integer)
imagick::RESOLUTION_PIXELSPERINCH (integer)
imagick::RESOLUTION_PIXELSPERCENTIMETER (integer)

Compression constants

imagick::COMPRESSION_UNDEFINED (integer)
imagick::COMPRESSION_NO (integer)
imagick::COMPRESSION_BZIP (integer)
imagick::COMPRESSION_FAX (integer)
imagick::COMPRESSION_GROUP4 (integer)
imagick::COMPRESSION_JPEG (integer)
imagick::COMPRESSION_JPEG2000 (integer)
imagick::COMPRESSION_LOSSLESSJPEG (integer)
imagick::COMPRESSION_LZW (integer)
imagick::COMPRESSION_RLE (integer)
imagick::COMPRESSION_ZIP (integer)

Paint constants

imagick::PAINT_POINT (integer)
imagick::PAINT_REPLACE (integer)
imagick::PAINT_FLOODFILL (integer)
imagick::PAINT_FILLTOBORDER (integer)
imagick::PAINT_RESET (integer)

Gravity constants

imagick::GRAVITY_NORTHWEST (integer)
imagick::GRAVITY_NORTH (integer)
imagick::GRAVITY_NORTHEAST (integer)
imagick::GRAVITY_WEST (integer)
imagick::GRAVITY_CENTER (integer)
imagick::GRAVITY_EAST (integer)
imagick::GRAVITY_SOUTHWEST (integer)
imagick::GRAVITY_SOUTH (integer)
imagick::GRAVITY_SOUTHEAST (integer)

Stretch constants

imagick::STRETCH_NORMAL (integer)
imagick::STRETCH_ULTRACONDENSED (integer)
imagick::STRETCH_CONDENSED (integer)
imagick::STRETCH_SEMICONDENSED (integer)
imagick::STRETCH_SEMIEXPANDED (integer)
imagick::STRETCH_EXPANDED (integer)
imagick::STRETCH_EXTRAEXPANDED (integer)
imagick::STRETCH_ULTRAEXPANDED (integer)
imagick::STRETCH_ANY (integer)

Align constants

imagick::ALIGN_UNDEFINED (integer)
imagick::ALIGN_LEFT (integer)
imagick::ALIGN_CENTER (integer)
imagick::ALIGN_RIGHT (integer)

Decoration constants

imagick::DECORATION_NO (integer)
imagick::DECORATION_UNDERLINE (integer)
imagick::DECORATION_OVERLINE (integer)
imagick::DECORATION_LINETROUGH (integer)

Noise constants

imagick::NOISE_UNIFORM (integer)
imagick::NOISE_GAUSSIAN (integer)
imagick::NOISE_MULTIPLICATIVEGAUSSIAN (integer)
imagick::NOISE_IMPULSE (integer)
imagick::NOISE_LAPLACIAN (integer)
imagick::NOISE_POISSON (integer)

Channel constants

imagick::CHANNEL_UNDEFINED (integer)
imagick::CHANNEL_RED (integer)
imagick::CHANNEL_GRAY (integer)
imagick::CHANNEL_CYAN (integer)
imagick::CHANNEL_GREEN (integer)
imagick::CHANNEL_MAGENTA (integer)
imagick::CHANNEL_BLUE (integer)
imagick::CHANNEL_YELLOW (integer)
imagick::CHANNEL_ALPHA (integer)
imagick::CHANNEL_OPACITY (integer)
imagick::CHANNEL_MATTE (integer)
imagick::CHANNEL_BLACK (integer)
imagick::CHANNEL_INDEX (integer)
imagick::CHANNEL_ALL (integer)

Metric constants

imagick::METRIC_UNDEFINED (integer)
imagick::METRIC_MEANABSOLUTEERROR (integer)
imagick::METRIC_MEANSQUAREERROR (integer)
imagick::METRIC_PEAKABSOLUTEERROR (integer)
imagick::METRIC_PEAKSIGNALTONOISERATIO (integer)
imagick::METRIC_ROOTMEANSQUAREDERROR (integer)

Pixel constants

imagick::PIXEL_CHAR (integer)
imagick::PIXEL_DOUBLE (integer)
imagick::PIXEL_FLOAT (integer)
imagick::PIXEL_INTEGER (integer)
imagick::PIXEL_LONG (integer)
imagick::PIXEL_QUANTUM (integer)
imagick::PIXEL_SHORT (integer)

Evaluate Operator constants

imagick::EVALUATE_UNDEFINED (integer)
imagick::EVALUATE_ADD (integer)
imagick::EVALUATE_AND (integer)
imagick::EVALUATE_DIVIDE (integer)
imagick::EVALUATE_LEFTSHIFT (integer)
imagick::EVALUATE_MAX (integer)
imagick::EVALUATE_MIN (integer)
imagick::EVALUATE_MULTIPLY (integer)
imagick::EVALUATE_OR (integer)
imagick::EVALUATE_RIGHTSHIFT (integer)
imagick::EVALUATE_SET (integer)
imagick::EVALUATE_SUBTRACT (integer)
imagick::EVALUATE_XOR (integer)

Colorspace constants

imagick::COLORSPACE_UNDEFINED (integer)
imagick::COLORSPACE_RGB (integer)
imagick::COLORSPACE_GRAY (integer)
imagick::COLORSPACE_TRANSPARENT (integer)
imagick::COLORSPACE_OHTA (integer)
imagick::COLORSPACE_LAB (integer)
imagick::COLORSPACE_XYZ (integer)
imagick::COLORSPACE_YCBCR (integer)
imagick::COLORSPACE_YCC (integer)
imagick::COLORSPACE_YIQ (integer)
imagick::COLORSPACE_YPBPR (integer)
imagick::COLORSPACE_YUV (integer)
imagick::COLORSPACE_CMYK (integer)
imagick::COLORSPACE_SRGB (integer)
imagick::COLORSPACE_HSB (integer)
imagick::COLORSPACE_HSL (integer)
imagick::COLORSPACE_HWB (integer)
imagick::COLORSPACE_REC601LUMA (integer)
imagick::COLORSPACE_REC709LUMA (integer)
imagick::COLORSPACE_LOG (integer)

Virtual Pixel Method constants

imagick::VIRTUALPIXELMETHOD_UNDEFINED (integer)
imagick::VIRTUALPIXELMETHOD_BACKGROUND (integer)
imagick::VIRTUALPIXELMETHOD_CONSTANT (integer)
imagick::VIRTUALPIXELMETHOD_EDGE (integer)
imagick::VIRTUALPIXELMETHOD_MIRROR (integer)
imagick::VIRTUALPIXELMETHOD_TILE (integer)
imagick::VIRTUALPIXELMETHOD_TRANSPARENT (integer)

Preview constants

imagick::PREVIEW_UNDEFINED (integer)
imagick::PREVIEW_ROTATE (integer)
imagick::PREVIEW_SHEAR (integer)
imagick::PREVIEW_ROLL (integer)
imagick::PREVIEW_HUE (integer)
imagick::PREVIEW_SATURATION (integer)
imagick::PREVIEW_BRIGHTNESS (integer)
imagick::PREVIEW_GAMMA (integer)
imagick::PREVIEW_SPIFF (integer)
imagick::PREVIEW_DULL (integer)
imagick::PREVIEW_GRAYSCALE (integer)
imagick::PREVIEW_QUANTIZE (integer)
imagick::PREVIEW_DESPECKLE (integer)
imagick::PREVIEW_REDUCENOISE (integer)
imagick::PREVIEW_ADDNOISE (integer)
imagick::PREVIEW_SHARPEN (integer)
imagick::PREVIEW_BLUR (integer)
imagick::PREVIEW_THRESHOLD (integer)
imagick::PREVIEW_EDGEDETECT (integer)
imagick::PREVIEW_SPREAD (integer)
imagick::PREVIEW_SOLARIZE (integer)
imagick::PREVIEW_SHADE (integer)
imagick::PREVIEW_RAISE (integer)
imagick::PREVIEW_SEGMENT (integer)
imagick::PREVIEW_SWIRL (integer)
imagick::PREVIEW_IMPLODE (integer)
imagick::PREVIEW_WAVE (integer)
imagick::PREVIEW_OILPAINT (integer)
imagick::PREVIEW_CHARCOALDRAWING (integer)
imagick::PREVIEW_JPEG (integer)

Rendering Intent constants

imagick::RENDERINGINTENT_UNDEFINED (integer)
imagick::RENDERINGINTENT_SATURATION (integer)
imagick::RENDERINGINTENT_PERCEPTUAL (integer)
imagick::RENDERINGINTENT_ABSOLUTE (integer)
imagick::RENDERINGINTENT_RELATIVE (integer)

Interlace constants (imagick::INTERLACE_GIF, imagick::INTERLACE_JPEG, imagick::INTERLACE_PNG are only available if Imagick is compiled against Imagemagick 6.3.5 or newer)

imagick::INTERLACE_UNDEFINED (integer)
imagick::INTERLACE_NO (integer)
imagick::INTERLACE_LINE (integer)
imagick::INTERLACE_PLANE (integer)
imagick::INTERLACE_PARTITION (integer)
imagick::INTERLACE_JPEG (integer)
imagick::INTERLACE_GIF (integer)
imagick::INTERLACE_PNG (integer)

Fillrule constants

imagick::FILLRULE_UNDEFINED (integer)
imagick::FILLRULE_EVENODD (integer)
imagick::FILLRULE_NONZERO (integer)

Pathunit constants

imagick::PATHUNITS_UNDEFINED (integer)
imagick::PATHUNITS_USERSPACE (integer)
imagick::PATHUNITS_USERSPACEONUSE (integer)
imagick::PATHUNITS_OBJECTBOUNDINGBOX (integer)

Linecap constants

imagick::LINECAP_UNDEFINED (integer)
imagick::LINECAP_BUTT (integer)
imagick::LINECAP_ROUND (integer)
imagick::LINECAP_SQUARE (integer)

Line Join constants

imagick::LINEJOIN_UNDEFINED (integer)
imagick::LINEJOIN_MITER (integer)
imagick::LINEJOIN_ROUND (integer)
imagick::LINEJOIN_BEVEL (integer)

Resourcetype constants

imagick::RESOURCETYPE_UNDEFINED (integer)
imagick::RESOURCETYPE_AREA (integer)
imagick::RESOURCETYPE_DISK (integer)
imagick::RESOURCETYPE_FILE (integer)
imagick::RESOURCETYPE_MAP (integer)
imagick::RESOURCETYPE_MEMORY (integer)

Layer Method constants (available if compiled against ImageMagick 6.3.3 or later)

imagick::LAYERMETHOD_UNDEFINED (integer)
imagick::LAYERMETHOD_COALESCE (integer)
imagick::LAYERMETHOD_COMPAREANY (integer)
imagick::LAYERMETHOD_COMPARECLEAR (integer)
imagick::LAYERMETHOD_COMPAREOVERLAY (integer)
imagick::LAYERMETHOD_DISPOSE (integer)
imagick::LAYERMETHOD_OPTIMIZE (integer)
imagick::LAYERMETHOD_OPTIMIZEIMAGE (integer)
imagick::LAYERMETHOD_OPTIMIZEPLUS (integer)
imagick::LAYERMETHOD_OPTIMIZETRANS (integer)
imagick::LAYERMETHOD_REMOVEDUPS (integer)
imagick::LAYERMETHOD_REMOVEZERO (integer)
imagick::LAYERMETHOD_COMPOSITE (integer)

Orientation constants (available if compiled against ImageMagick 6.3.4 or later)

imagick::ORIENTATION_UNDEFINED (integer)
imagick::ORIENTATION_TOPLEFT (integer)
imagick::ORIENTATION_TOPRIGHT (integer)
imagick::ORIENTATION_BOTTOMRIGHT (integer)
imagick::ORIENTATION_BOTTOMLEFT (integer)
imagick::ORIENTATION_LEFTTOP (integer)
imagick::ORIENTATION_RIGHTTOP (integer)
imagick::ORIENTATION_RIGHTBOTTOM (integer)
imagick::ORIENTATION_LEFTBOTTOM (integer)

Distortion constants (available if compiled against ImageMagick 6.3.6 or later)

imagick::DISTORTION_UNDEFINED (integer)
imagick::DISTORTION_AFFINE (integer)
imagick::DISTORTION_AFFINEPROJECTION (integer)
imagick::DISTORTION_ARC (integer)
imagick::DISTORTION_BILINEAR (integer)
imagick::DISTORTION_PERSPECTIVE (integer)
imagick::DISTORTION_PERSPECTIVEPROJECTION (integer)
imagick::DISTORTION_SCALEROTATETRANSLATE (integer)
Předcházející | Nahoru | Další
LXVI. Imagick Image Library | Domů | Installation


Imagick

(No version information available, might be only in CVS)

Imagick — Imagick Class

Přehled

   class Imagick implements Iterator, Traversable

Image methods and global methods

The Imagick class has the ability to hold and operate on multiple images simultaneously. This is achieved through an internal stack. There is always an internal pointer that points at the current image. Some functions operate on all images in the Imagick class, but most operate only on the current image in the internal stack. As a convention, method names can contain the word Image to denote they affect only the current image in the stack.

Class Methods

Because there are so many methods, here is a handy list of methods, somewhat reduced to their general purpose:

Tabulka 135. Class methods by purpose

Image effects | Get methods | Set methods | Read/write images | Other
adaptiveBlurImage | getCompression | setBackgroundColor | __construct | clear
adaptiveResizeImage | getFilename | setCompressionQuality | addImage | clone
adaptiveSharpenImage | getFormat | setCompression | appendImages | current
adaptiveTresholdImage | getImageBackgroundColor | setFilename | getFilename | destroy
addNoiseImage | getImageBlob | setFormat | getFormat | getCopyright
affinetransformimage | getImageBluePrimary | setImageBackgroundColor | getImageFilename | getHomeURL
annotateImage | getImageBorderColor | setFirstIterator | getImageFormat | commentImage
averageImages | getImageChannelDepth | setImageBias | getImage | getNumberImages
blackThresholdImage | getImageChannelDistortion | setImageBluePrimary | setImageFilename | getReleaseDate
blurImage | getImageChannelExtrema | setImageBorderColor | setImageFormat | getVersion
borderImage | getImageChannelMean | setImageChannelDepth | readImageFile | hasNextImage
charcoalImage | getImageChannelStatistics | setImageColormapColor | readImage | hasPreviousImage
chopImage | getImageColormapColor | setImageColorSpace | writeImages | labelImage
clipImage | getImageColorspace | setImageCompose | writeImage | newImage
clipPathImage | getImageColors | setImageCompression |  | newPseudoImage
coalesceImages | getImageCompose | setImageDelay |  | nextImage
colorFloodFillImage | getImageDelay | setImageDepth |  | pingImageBlob
colorizeImage | getImageDepth | setImageDispose |  | pingImageFile
combineImages | getImageDispose | setImageDispose |  | pingImage
compareImageChannels | getImageDistortion | setImageExtent |  | previousImage
compareImageLayers | getImageExtrema | setImageFilename |  | profileImage
compositeImage | getImageFilename | setImageFormat |  | queryFormats
contrastImage | getImageFormat | setImageGamma |  | removeImageProfile
constrastStretchImage | getImageGamma | setImageGreenPrimary |  | removeImage
convolveImage | getImageGeometry | setImageIndex |  | setFirstIterator
cropImage | getImageGreenPrimary | setImageInterpolateMethod |  | setImageIndex
cycleColormapImage | getImageHeight | setImageIterations |  | valid
deconstructImages | getImageHistogram | setImageMatteColor |  |
drawImage | getImageIndex | setImageMatte |  |
edgeImage | getImageInterlaceScheme | setImagePage |  |
embossImage | getImageInterpolateMethod | setImageProfile |  |
enhanceImage | getImageIterations | setImageProperty |  |
equalizeImage | getImageMatteColor | setImageRedPrimary |  |
evaluateImage | getImageMatte | setImageRenderingIntent |  |
flattenImages | getImagePage | setImageResolution |  |
flipImage | getImagePixelColor | setImageScene |  |
flopImage | getImageProfile | setImageTicksPerSecond |  |
imageImage | getImageProperty | setImageType |  |
fxImage | getImageRedPrimary | setImageUnits |  |
gammaImage | getImageRegion | setImageVirtualPixelMethod |  |
gaussianBlurImage | getImageRenderingIntent | setImageWhitepoint |  |
implodeImage | getImageResolution | setInterlaceScheme |  |
levelImage | getImageScene | setOption |  |
linearStretchImage | getImageSignature | setPage |  |
magnifyImage | getImageTicksPerSecond | setResolution |  |
matteFloodFilleImage | getImageTotalInkDensity | setResourceLimit |  |
medianFilterImage | getImageType | setSamplingFactors |  |
minifyImage | getImageUnits | setSizeOffset |  |
modulateImage | getImageVirtualPixelMethod | setSize |  |
montageImage | getImageWhitepoint | setType |  |
morphImages | getImageWidth |  |  |
mosaicImages | getImage |  |  |
motionBlurImage | getInterlaceScheme |  |  |
negateImage | getNumberImages |  |  |
normalizeImage | getOption |  |  |
oilPaintImage | getPackageName |  |  |
optimizeImageLayers | getPage |  |  |
paintOpaqueImage | getPixelIterator |  |  |
paintTransparentImage | getPixelRegionIterator |  |  |
posterizeImage | getQuantumDepth |  |  |
radialBlurImage | getQuantumRange |  |  |
raiseImage | getResourceLimit |  |  |
randomThresholdImage | getResource |  |  |
reduceNoiseImage | getSamplingFactors |  |  |
render | getSizeOffset |  |  |
resampleImage | getSize |  |  |
resizeImage | identifyImage |  |  |
rollImage | getImageSize |  |  |
rotateImage |  |  |  |
sampleImage |  |  |  |
scaleImage |  |  |  |
separateImageChannel |  |  |  |
sepiaToneImage |  |  |  |
shadeImage |  |  |  |
shadowImage |  |  |  |
sharpenImage |  |  |  |
shaveImage |  |  |  |
shearImage |  |  |  |
sigmoidalContrastImage |  |  |  |
sketchImage |  |  |  |
solarizeImage |  |  |  |
spliceImage |  |  |  |
spreadImage |  |  |  |
steganoImage |  |  |  |
stereoImage |  |  |  |
stripImage |  |  |  |
swirlImage |  |  |  |
textureImage |  |  |  |
thresholdImage |  |  |  |
thumbnailImage |  |  |  |
tintImage |  |  |  |
transverseImage |  |  |  |
trimImage |  |  |  |
uniqueImageColors |  |  |  |
unsharpMaskImage |  |  |  |
vignetteImage |  |  |  |
waveImage |  |  |  |
whiteThresholdImage |  |  |  |

Předcházející | Nahoru | Další
Installation | Domů | Imagick::adaptiveBlurImage


Installation

(No version information available, might be only in CVS)

Installation — Installing the Imagick extension

Instalace

Toto rozšíření » PECL není přibaleno k PHP.

Informace o instalaci tohoto PECL rozšíření lze najít v kapitole manuálu nazvané Instalace rozšíření PECL. Další informace, jako nové verze, soubory ke stažení, zdrojové soubory, správcovské informace a CHANGELOG, lze najít zde: » http://pecl.php.net/package/imagick.

Poznámka: The official name of this extension is imagick.

Tuto DLL knihovnu pro rozšíření PECL můžete stahovat ze stránky » PHP Downloads nebo z » http://snaps.php.net/.

Installation requirements on other platforms

PHP >= 5.2.1 and ImageMagick >= 6.2.4 is required. The amount of formats supported is by Imagick is entirely dependent upon the amount of formats supported by your ImageMagick installation. For example, Imagemagick requires ghostscript to conduct PDF operations.

Installation requirements on Windows

Version information does not differ from that above. There are binaries available from http://imagemagick.org/ so that you can load this extension on Windows without need for a compiler.

Předcházející | Nahoru | Další
Constants | Domů | Imagick


Příloha I. Direktivy php.ini

Obsah

Seznam direktiv php.ini
Popis základních direktiv php.ini

Seznam direktiv php.ini

Tento seznam obsahuje direktivy php.ini, kterými můžete nastavovat konfiguraci PHP.

Tabulka I.1. Konfigurační volby

Název | Výchozí | Lze měnit | Přehled změn (changelog)
allow_call_time_pass_reference | "1" | PHP_INI_PERDIR | PHP_INI_ALL v PHP <= 4.0.0.
allow_url_fopen | "1" | PHP_INI_SYSTEM | PHP_INI_ALL v PHP <= 4.3.4. K dispozici od PHP 4.0.4.
allow_url_include | "0" | PHP_INI_SYSTEM | K dispozici od PHP 6.0.0.
always_populate_raw_post_data | "0" | PHP_INI_PERDIR | PHP_INI_ALL v PHP <= 4.2.3. K dispozici od PHP 4.1.0.
apc.cache_by_default | "1" | PHP_INI_SYSTEM |
apc.enabled | "1" | PHP_INI_ALL |
apc.enable_cli | "0" | PHP_INI_SYSTEM |
apc.file_update_protection | "2" | PHP_INI_SYSTEM |
apc.filters | NULL | PHP_INI_SYSTEM |
apc.gc_ttl | "3600" | PHP_INI_SYSTEM |
apc.max_file_size | "1M" | PHP_INI_SYSTEM |
apc.mmap_file_mask | NULL | PHP_INI_SYSTEM |
apc.num_files_hint | "1000" | PHP_INI_SYSTEM |
apc.optimization | "0" | PHP_INI_ALL |
apc.shm_segments | "1" | PHP_INI_SYSTEM |
apc.shm_size | "30" | PHP_INI_SYSTEM |
apc.slam_defense | "0" | PHP_INI_SYSTEM |
apc.ttl | "0" | PHP_INI_SYSTEM |
apc.user_entries_hint | "100" | PHP_INI_SYSTEM |
apc.user_ttl | "0" | PHP_INI_SYSTEM |
apd.dumpdir | NULL | PHP_INI_ALL |
apd.statement_tracing | "0" | PHP_INI_ALL |
arg_separator.input | "&" | PHP_INI_PERDIR | K dispozici od PHP 4.0.5.
arg_separator.output | "&" | PHP_INI_ALL | K dispozici od PHP 4.0.5.
asp_tags | "0" | PHP_INI_PERDIR | PHP_INI_ALL v PHP <= 4.0.0.
assert.active | "1" | PHP_INI_ALL |
assert.bail | "0" | PHP_INI_ALL |
assert.callback | NULL | PHP_INI_ALL |
assert.quiet_eval | "0" | PHP_INI_ALL |
assert.warning | "1" | PHP_INI_ALL |
auto_append_file | NULL | PHP_INI_PERDIR | PHP_INI_ALL v PHP <= 4.2.3.
auto_detect_line_endings | "0" | PHP_INI_ALL | K dispozici od PHP 4.3.0.
auto_globals_jit | "1" | PHP_INI_PERDIR | K dispozici od PHP 5.0.0.
auto_prepend_file | NULL | PHP_INI_PERDIR | PHP_INI_ALL v PHP <= 4.2.3.
bcmath.scale | "0" | PHP_INI_ALL |
bcompiler.enabled | "1" | PHP_INI_ALL |
birdstep.max_links | "-1" | PHP_INI_ALL | K dispozici od PHP 4.2.0.
blenc.key_file | "/usr/local/etc/blenckeys" | PHP_INI_ALL |
browscap | NULL | PHP_INI_SYSTEM |
cgi.discard_path | "0" | PHP_INI_ALL | K dispozici od PHP 6.0.0.
cgi.fix_pathinfo | "1" | PHP_INI_ALL | K dispozici od PHP 4.3.0.
cgi.force_redirect | "1" | PHP_INI_ALL | K dispozici od PHP 4.2.0.
cgi.nph | "0" | PHP_INI_ALL | K dispozici od PHP 4.3.5.
cgi.redirect_status_env | NULL | PHP_INI_ALL | K dispozici od PHP 4.2.0.
cgi.rfc2616_headers | "0" | PHP_INI_ALL | K dispozici od PHP 4.3.0.
child_terminate | "0" | PHP_INI_ALL | K dispozici od PHP 4.0.5.
com.allow_dcom | "0" | PHP_INI_SYSTEM | K dispozici od PHP 4.0.5.
com.autoregister_casesensitive | "1" | PHP_INI_ALL | PHP_INI_SYSTEM v PHP 4. K dispozici od PHP 4.1.0.
com.autoregister_typelib | "0" | PHP_INI_ALL | PHP_INI_SYSTEM v PHP 4. K dispozici od PHP 4.1.0.
com.autoregister_verbose | "0" | PHP_INI_ALL | PHP_INI_SYSTEM v PHP 4. K dispozici od PHP 4.1.0.
com.code_page | "" | PHP_INI_ALL | K dispozici od PHP 5.0.0.
com.typelib_file | "" | PHP_INI_SYSTEM | K dispozici od PHP 4.0.5.
crack.default_dictionary | NULL | PHP_INI_PERDIR | K dispozici od PHP 4.0.5.
daffodildb.default_host | "localhost" | PHP_INI_ALL |
daffodildb.default_password | "daffodil" | PHP_INI_ALL |
daffodildb.default_socket | NULL | PHP_INI_ALL |
daffodildb.default_user | "DAFFODIL" | PHP_INI_ALL |
daffodildb.port | "3456" | PHP_INI_ALL |
date.default_latitude | "31.7667" | PHP_INI_ALL | K dispozici od PHP 5.0.0.
date.default_longitude | "35.2333" | PHP_INI_ALL | K dispozici od PHP 5.0.0.
date.sunrise_zenith | "90.83" | PHP_INI_ALL | K dispozici od PHP 5.0.0.
date.sunset_zenith | "90.83" | PHP_INI_ALL | K dispozici od PHP 5.0.0.
date.timezone | "" | PHP_INI_ALL | K dispozici od PHP 5.1.0.
dba.default_handler | "" | PHP_INI_ALL | K dispozici od PHP 4.3.3.
dbx.colnames_case | "unchanged" | PHP_INI_SYSTEM | K dispozici od PHP 4.3.0.
default_charset | "" | PHP_INI_ALL |
default_mimetype | "text/html" | PHP_INI_ALL |
default_socket_timeout | "60" | PHP_INI_ALL | K dispozici od PHP 4.3.0.
define_syslog_variables | "0" | PHP_INI_ALL |
disable_classes | "" | pouze php.ini | K dispozici od PHP 4.3.2.
disable_functions | "" | pouze php.ini | K dispozici od PHP 4.0.1.
display_errors | "1" | PHP_INI_ALL |
display_startup_errors | "0" | PHP_INI_ALL | K dispozici od PHP 4.0.3.
docref_ext | "" | PHP_INI_ALL | K dispozici od PHP 4.3.2.
docref_root | "" | PHP_INI_ALL | K dispozici od PHP 4.3.0.
doc_root | NULL | PHP_INI_SYSTEM |
enable_dl | "1" | PHP_INI_SYSTEM |
engine | "1" | PHP_INI_ALL | K dispozici od PHP 4.0.5.
error_append_string | NULL | PHP_INI_ALL |
error_log | NULL | PHP_INI_ALL |
error_prepend_string | NULL | PHP_INI_ALL |
error_reporting | NULL | PHP_INI_ALL |
exif.decode_jis_intel | "JIS" | PHP_INI_ALL | K dispozici od PHP 4.3.0.
exif.decode_jis_motorola | "JIS" | PHP_INI_ALL | K dispozici od PHP 4.3.0.
exif.decode_unicode_intel | "UCS-2LE" | PHP_INI_ALL | K dispozici od PHP 4.3.0.
exif.decode_unicode_motorola | "UCS-2BE" | PHP_INI_ALL | K dispozici od PHP 4.3.0.
exif.encode_jis | "" | PHP_INI_ALL | K dispozici od PHP 4.3.0.
exif.encode_unicode | "ISO-8859-15" | PHP_INI_ALL | K dispozici od PHP 4.3.0.
expect.logfile | "" | PHP_INI_ALL |
expect.loguser | "1" | PHP_INI_ALL |
expect.timeout | "10" | PHP_INI_ALL |
expose_php | "1" | pouze php.ini |
extension_dir | "/path/to/php" | PHP_INI_SYSTEM |
fastcgi.impersonate | "0" | PHP_INI_ALL | K dispozici od PHP 4.3.0.
fastcgi.logging | "1" | PHP_INI_ALL | K dispozici od PHP 4.4.0.
fbsql.allow_persistent | "1" | PHP_INI_SYSTEM | K dispozici od PHP 4.2.0.
fbsql.autocommit | "1" | PHP_INI_SYSTEM | K dispozici od PHP 4.0.6.
fbsql.batchsize | "1000" | PHP_INI_ALL | K dispozici od PHP 5.1.0.
fbsql.default_database | "" | PHP_INI_SYSTEM | K dispozici od PHP 4.0.6.
fbsql.default_database_password | "" | PHP_INI_SYSTEM | K dispozici od PHP 4.0.6.
fbsql.default_host | NULL | PHP_INI_SYSTEM | K dispozici od PHP 4.0.6.
fbsql.default_password | "" | PHP_INI_SYSTEM | K dispozici od PHP 4.0.6.
fbsql.default_user | "_SYSTEM" | PHP_INI_SYSTEM | K dispozici od PHP 4.0.6.
fbsql.generate_warnings | "0" | PHP_INI_SYSTEM | K dispozici od PHP 4.0.6.
fbsql.max_connections | "128" | PHP_INI_SYSTEM | K dispozici od PHP 4.0.6.
fbsql.max_links | "128" | PHP_INI_SYSTEM | K dispozici od PHP 4.0.6.
fbsql.max_persistent | "-1" | PHP_INI_SYSTEM | K dispozici od PHP 4.0.6.
fbsql.max_results | "128" | PHP_INI_SYSTEM | K dispozici od PHP 4.0.6.
file_uploads | "1" | PHP_INI_SYSTEM | PHP_INI_ALL v PHP <= 4.2.3. K dispozici od PHP 4.0.3.
filter.default | "string" | PHP_INI_ALL |
filter.default_flags | NULL | PHP_INI_ALL |
from | "" | PHP_INI_ALL |
highlight.bg | "#FFFFFF" | PHP_INI_ALL |
highlight.comment | "#FF8000" | PHP_INI_ALL |
highlight.default | "#0000BB" | PHP_INI_ALL |
highlight.html | "#000000" | PHP_INI_ALL |
highlight.keyword | "#007700" | PHP_INI_ALL |
highlight.string | "#DD0000" | PHP_INI_ALL |
html_errors | "1" | PHP_INI_ALL | PHP_INI_SYSTEM v PHP <= 4.2.3. K dispozici od PHP 4.0.2.
http.allowed_methods | "" | PHP_INI_ALL |
http.allowed_methods_log | "" | PHP_INI_ALL |
http.cache_log | "" | PHP_INI_ALL |
http.composite_log | "" | PHP_INI_ALL |
http.etag_mode | "MD5" | PHP_INI_ALL |
http.force_exit | "1" | PHP_INI_ALL |
http.ob_deflate_auto | "0" | PHP_INI_PERDIR |
http.ob_deflate_flags | "0" | PHP_INI_ALL |
http.ob_inflate_auto | "0" | PHP_INI_PERDIR |
http.ob_inflate_flags | "0" | PHP_INI_ALL |
http.only_exceptions | "0" | PHP_INI_ALL |
http.redirect_log | "" | PHP_INI_ALL |
hyperwave.allow_persistent | "0" | PHP_INI_SYSTEM | K dispozici od PHP 4.3.2.
hyperwave.default_port | "418" | PHP_INI_ALL |
ibase.allow_persistent | "1" | PHP_INI_SYSTEM |
ibase.dateformat | "%Y-%m-%d" | PHP_INI_ALL |
ibase.default_charset | NULL | PHP_INI_ALL | K dispozici od PHP 5.0.0.
ibase.default_db | NULL | PHP_INI_SYSTEM | K dispozici od PHP 5.0.0.
ibase.default_password | NULL | PHP_INI_ALL |
ibase.default_user | NULL | PHP_INI_ALL |
ibase.max_links | "-1" | PHP_INI_SYSTEM |
ibase.max_persistent | "-1" | PHP_INI_SYSTEM |
ibase.timeformat | "%H:%M:%S" | PHP_INI_ALL |
ibase.timestampformat | "%Y-%m-%d %H:%M:%S" | PHP_INI_ALL |
ibm_db2.binmode | "1" | PHP_INI_ALL |
ibm_db2.instance_name | NULL | PHP_INI_SYSTEM |
iconv.input_encoding | "ISO-8859-1" | PHP_INI_ALL | K dispozici od PHP 4.0.5.
iconv.internal_encoding | "ISO-8859-1" | PHP_INI_ALL | K dispozici od PHP 4.0.5.
iconv.output_encoding | "ISO-8859-1" | PHP_INI_ALL | K dispozici od PHP 4.0.5.
ifx.allow_persistent | "1" | PHP_INI_SYSTEM |
ifx.blobinfile | "1" | PHP_INI_ALL |
ifx.byteasvarchar | "0" | PHP_INI_ALL |
ifx.charasvarchar | "0" | PHP_INI_ALL |
ifx.default_host | NULL | PHP_INI_SYSTEM |
ifx.default_password | NULL | PHP_INI_SYSTEM |
ifx.default_user | NULL | PHP_INI_SYSTEM |
ifx.max_links | "-1" | PHP_INI_SYSTEM |
ifx.max_persistent | "-1" | PHP_INI_SYSTEM |
ifx.nullformat | "0" | PHP_INI_ALL |
ifx.textasvarchar | "0" | PHP_INI_ALL |
ignore_repeated_errors | "0" | PHP_INI_ALL | K dispozici od PHP 4.3.0.
ignore_repeated_source | "0" | PHP_INI_ALL | K dispozici od PHP 4.3.0.
ignore_user_abort | "0" | PHP_INI_ALL |
implicit_flush | "0" | PHP_INI_ALL | PHP_INI_PERDIR v PHP <= 4.2.3.
include_path | ".;/path/to/php/pear" | PHP_INI_ALL |
ingres.allow_persistent | "1" | PHP_INI_SYSTEM | K dispozici od PHP 4.0.2.
ingres.blob_segment_length | "4096" | PHP_INI_ALL |
ingres.cursor_mode | "0" | PHP_INI_ALL |
ingres.default_database | NULL | PHP_INI_ALL | K dispozici od PHP 4.0.2.
ingres.default_password | NULL | PHP_INI_ALL | K dispozici od PHP 4.0.2.
ingres.default_user | NULL | PHP_INI_ALL | K dispozici od PHP 4.0.2.
ingres.max_links | "-1" | PHP_INI_SYSTEM | K dispozici od PHP 4.0.2.
ingres.max_persistent | "-1" | PHP_INI_SYSTEM | K dispozici od PHP 4.0.2.
ingres.report_db_warnings | "1" | PHP_INI_ALL |
ingres.timeout | "-1" | PHP_INI_ALL |
ingres.trace_connect | "0" | PHP_INI_ALL |
ircg.control_user | "nobody" | PHP_INI_ALL | K dispozici od PHP 5.0.0.
ircg.keep_alive_interval | "60" | PHP_INI_ALL | K dispozici od PHP 5.0.0.
ircg.max_format_message_sets | "12" | PHP_INI_ALL | K dispozici od PHP 5.0.0.
ircg.shared_mem_size | "6000000" | PHP_INI_ALL | K dispozici od PHP 5.0.0.
ircg.work_dir | "/tmp/ircg" | PHP_INI_ALL | K dispozici od PHP 5.0.0.
last_modified | "0" | PHP_INI_ALL | K dispozici od PHP 4.0.5.
ldap.max_links | "-1" | PHP_INI_SYSTEM |
log_errors | "0" | PHP_INI_ALL |
log_errors_max_len | "1024" | PHP_INI_ALL | K dispozici od PHP 4.3.0.
magic_quotes_gpc | "1" | PHP_INI_PERDIR | PHP_INI_ALL v PHP <= 4.2.3.
magic_quotes_runtime | "0" | PHP_INI_ALL |
magic_quotes_sybase | "0" | PHP_INI_ALL |
mail.force_extra_parameters | NULL | PHP_INI_PERDIR | K dispozici od PHP 5.0.0.
mailparse.def_charset | "us-ascii" | PHP_INI_ALL | K dispozici od PHP 4.1.0.
maxdb.default_db | NULL | PHP_INI_ALL |
maxdb.default_host | NULL | PHP_INI_ALL |
maxdb.default_pw | NULL | PHP_INI_ALL |
maxdb.default_user | NULL | PHP_INI_ALL |
maxdb.long_readlen | "200" | PHP_INI_ALL |
max_execution_time | "30" | PHP_INI_ALL |
max_input_time | "-1" | PHP_INI_PERDIR | K dispozici od PHP 4.3.0.
mbstring.detect_order | NULL | PHP_INI_ALL | K dispozici od PHP 4.0.6.
mbstring.encoding_translation | "0" | PHP_INI_PERDIR | K dispozici od PHP 4.3.0.
mbstring.func_overload | "0" | PHP_INI_PERDIR | PHP_INI_SYSTEM v PHP <= 4.2.3. K dispozici od PHP 4.2.0.
mbstring.http_input | "pass" | PHP_INI_ALL | K dispozici od PHP 4.0.6.
mbstring.http_output | "pass" | PHP_INI_ALL | K dispozici od PHP 4.0.6.
mbstring.internal_encoding | NULL | PHP_INI_ALL | K dispozici od PHP 4.0.6.
mbstring.language | "neutral" | PHP_INI_PERDIR | K dispozici od PHP 4.3.0.
mbstring.script_encoding | NULL | PHP_INI_ALL | K dispozici od PHP 4.3.0.
mbstring.strict_detection | "0" | PHP_INI_ALL | K dispozici od PHP 5.1.2.
mbstring.substitute_character | NULL | PHP_INI_ALL | K dispozici od PHP 4.0.6.
mcrypt.algorithms_dir | NULL | PHP_INI_ALL | K dispozici od PHP 4.0.2.
mcrypt.modes_dir | NULL | PHP_INI_ALL | K dispozici od PHP 4.0.2.
memory_limit | "8M" | PHP_INI_ALL |
mime_magic.debug | "0" | PHP_INI_SYSTEM | K dispozici od PHP 5.0.0.
mime_magic.magicfile | "/path/to/php/magic.mime" | PHP_INI_SYSTEM | K dispozici od PHP 4.3.0.
msql.allow_persistent | "1" | PHP_INI_ALL |
msql.max_links | "-1" | PHP_INI_ALL |
msql.max_persistent | "-1" | PHP_INI_ALL |
mssql.allow_persistent | "1" | PHP_INI_SYSTEM |
mssql.batchsize | "0" | PHP_INI_ALL | K dispozici od PHP 4.0.4.
mssql.charset | "" | PHP_INI_ALL | K dispozici od PHP 5.1.2.
mssql.compatability_mode | "0" | PHP_INI_ALL |
mssql.connect_timeout | "5" | PHP_INI_ALL |
mssql.datetimeconvert | "1" | PHP_INI_ALL | K dispozici od PHP 4.2.0.
mssql.max_links | "-1" | PHP_INI_SYSTEM |
mssql.max_persistent | "-1" | PHP_INI_SYSTEM |
mssql.max_procs | "-1" | PHP_INI_ALL | K dispozici od PHP 4.3.0.
mssql.min_error_severity | "10" | PHP_INI_ALL |
mssql.min_message_severity | "10" | PHP_INI_ALL |
mssql.secure_connection | "0" | PHP_INI_SYSTEM | K dispozici od PHP 4.3.0.
mssql.textlimit | "-1" | PHP_INI_ALL |
mssql.textsize | "-1" | PHP_INI_ALL |
mssql.timeout | "60" | PHP_INI_ALL | K dispozici od PHP 4.1.0.
mysql.allow_persistent | "1" | PHP_INI_SYSTEM |
mysql.connect_timeout | "60" | PHP_INI_ALL | PHP_INI_SYSTEM v PHP <= 4.3.2. K dispozici od PHP 4.3.0.
mysql.default_host | NULL | PHP_INI_ALL |
mysql.default_password | NULL | PHP_INI_ALL |
mysql.default_port | NULL | PHP_INI_ALL |
mysql.default_socket | NULL | PHP_INI_ALL | K dispozici od PHP 4.0.1.
mysql.default_user | NULL | PHP_INI_ALL |
mysql.max_links | "-1" | PHP_INI_SYSTEM |
mysql.max_persistent | "-1" | PHP_INI_SYSTEM |
mysql.trace_mode | "0" | PHP_INI_ALL | K dispozici od PHP 4.3.0.
mysqli.default_host | NULL | PHP_INI_ALL | K dispozici od PHP 5.0.0.
mysqli.default_port | "3306" | PHP_INI_ALL | K dispozici od PHP 5.0.0.
mysqli.default_pw | NULL | PHP_INI_ALL | K dispozici od PHP 5.0.0.
mysqli.default_socket | NULL | PHP_INI_ALL | K dispozici od PHP 5.0.0.
mysqli.default_user | NULL | PHP_INI_ALL | K dispozici od PHP 5.0.0.
mysqli.max_links | "-1" | PHP_INI_SYSTEM | K dispozici od PHP 5.0.0.
mysqli.reconnect | "0" | PHP_INI_SYSTEM | K dispozici od PHP 5.0.0.
namazu.debugmode | "0" | PHP_INI_ALL |
namazu.lang | NULL | PHP_INI_ALL |
namazu.loggingmode | "0" | PHP_INI_ALL |
namazu.sortmethod | NULL | PHP_INI_ALL |
namazu.sortorder | NULL | PHP_INI_ALL |
nsapi.read_timeout | "60" | PHP_INI_ALL | K dispozici od PHP 4.3.3.
oci8.default_prefetch | "10" | PHP_INI_SYSTEM | K dispozici od PHP 5.1.2.
oci8.max_persistent | "-1" | PHP_INI_SYSTEM | K dispozici od PHP 5.1.2.
oci8.old_oci_close_semantics | "0" | PHP_INI_SYSTEM | K dispozici od PHP 5.1.2.
oci8.persistent_timeout | "-1" | PHP_INI_SYSTEM | K dispozici od PHP 5.1.2.
oci8.ping_interval | "60" | PHP_INI_SYSTEM | K dispozici od PHP 5.1.2.
oci8.privileged_connect | "0" | PHP_INI_SYSTEM | K dispozici od PHP 5.1.2.
oci8.statement_cache_size | "20" | PHP_INI_SYSTEM | K dispozici od PHP 5.1.2.
odbc.allow_persistent | "1" | PHP_INI_SYSTEM |
odbc.check_persistent | "1" | PHP_INI_SYSTEM |
odbc.defaultbinmode | "1" | PHP_INI_ALL |
odbc.defaultlrl | "4096" | PHP_INI_ALL |
odbc.default_db | NULL | PHP_INI_ALL |
odbc.default_pw | NULL | PHP_INI_ALL |
odbc.default_user | NULL | PHP_INI_ALL |
odbc.max_links | "-1" | PHP_INI_SYSTEM |
odbc.max_persistent | "-1" | PHP_INI_SYSTEM |
opendirectory.max_refs | "-1" | PHP_INI_ALL |
opendirectory.separator | "/" | PHP_INI_ALL |
open_basedir | NULL | PHP_INI_SYSTEM |
oracle.allow_persistent | "-1" | PHP_INI_ALL |
oracle.max_links | "-1" | PHP_INI_ALL |
oracle.max_persistent | "-1" | PHP_INI_ALL |
output_buffering | "0" | PHP_INI_PERDIR |
output_handler | NULL | PHP_INI_PERDIR | K dispozici od PHP 4.0.4.
pdo_odbc.connection_pooling | "strict" | PHP_INI_ALL | K dispozici od PHP 5.1.0.
pfpro.defaulthost | "test-payflow.verisign.com" | PHP_INI_ALL | K dispozici od PHP 4.0.2.
pfpro.defaultport | "443" | PHP_INI_ALL | K dispozici od PHP 4.0.2.
pfpro.defaulttimeout | "30" | PHP_INI_ALL | K dispozici od PHP 4.0.2.
pfpro.proxyaddress | "" | PHP_INI_ALL | K dispozici od PHP 4.0.2.
pfpro.proxylogon | "" | PHP_INI_ALL | K dispozici od PHP 4.0.2.
pfpro.proxypassword | "" | PHP_INI_ALL | K dispozici od PHP 4.0.2.
pfpro.proxyport | "" | PHP_INI_ALL | K dispozici od PHP 4.0.2.
pgsql.allow_persistent | "1" | PHP_INI_SYSTEM |
pgsql.auto_reset_persistent | "0" | PHP_INI_SYSTEM | K dispozici od PHP 4.2.0.
pgsql.ignore_notice | "0" | PHP_INI_ALL | K dispozici od PHP 4.3.0.
pgsql.log_notice | "0" | PHP_INI_ALL | K dispozici od PHP 4.3.0.
pgsql.max_links | "-1" | PHP_INI_SYSTEM |
pgsql.max_persistent | "-1" | PHP_INI_SYSTEM |
post_max_size | "8M" | PHP_INI_PERDIR | PHP_INI_SYSTEM v PHP <= 4.2.3. K dispozici od PHP 4.0.3.
precision | "14" | PHP_INI_ALL |
printer.default_printer | "" | PHP_INI_ALL |
realpath_cache_size | "16K" | PHP_INI_SYSTEM | K dispozici od PHP 5.1.0.
realpath_cache_ttl | "120" | PHP_INI_SYSTEM | K dispozici od PHP 5.1.0.
register_argc_argv | "1" | PHP_INI_PERDIR | PHP_INI_ALL v PHP <= 4.2.3.
register_globals | "0" | PHP_INI_PERDIR | PHP_INI_ALL v PHP <= 4.2.3.
register_long_arrays | "1" | PHP_INI_PERDIR | K dispozici od PHP 5.0.0.
report_memleaks | "1" | PHP_INI_ALL | K dispozici od PHP 4.3.0.
report_zend_debug | "1" | PHP_INI_ALL | K dispozici od PHP 5.0.0.
runkit.internal_override | "0" | PHP_INI_SYSTEM |
runkit.superglobal | "" | PHP_INI_PERDIR |
safe_mode | "0" | PHP_INI_SYSTEM |
safe_mode_allowed_env_vars | "PHP_" | PHP_INI_SYSTEM |
safe_mode_exec_dir | "" | PHP_INI_SYSTEM |
safe_mode_gid | "0" | PHP_INI_SYSTEM | K dispozici od PHP 4.1.0.
safe_mode_include_dir | NULL | PHP_INI_SYSTEM | K dispozici od PHP 4.1.0.
safe_mode_protected_env_vars | "LD_LIBRARY_PATH" | PHP_INI_SYSTEM |
sendmail_from | NULL | PHP_INI_ALL |
sendmail_path | NULL | PHP_INI_SYSTEM |
serialize_precision | "100" | PHP_INI_ALL | K dispozici od PHP 4.3.2.
session.auto_start | "0" | PHP_INI_ALL |
session.bug_compat_42 | "1" | PHP_INI_ALL | K dispozici od PHP 4.3.0.
session.bug_compat_warn | "1" | PHP_INI_ALL | K dispozici od PHP 4.3.0.
session.cache_expire | "180" | PHP_INI_ALL |
session.cache_limiter | "nocache" | PHP_INI_ALL |
session.cookie_domain | "" | PHP_INI_ALL |
session.cookie_lifetime | "0" | PHP_INI_ALL |
session.cookie_path | "/" | PHP_INI_ALL |
session.cookie_secure | "" | PHP_INI_ALL | K dispozici od PHP 4.0.4.
session.entropy_file | "" | PHP_INI_ALL |
session.entropy_length | "0" | PHP_INI_ALL |
session.gc_divisor | "100" | PHP_INI_ALL | K dispozici od PHP 4.3.2.
session.gc_maxlifetime | "1440" | PHP_INI_ALL |
session.gc_probability | "1" | PHP_INI_ALL |
session.hash_bits_per_character | "4" | PHP_INI_ALL | K dispozici od PHP 5.0.0.
session.hash_function | "0" | PHP_INI_ALL | K dispozici od PHP 5.0.0.
session.name | "PHPSESSID" | PHP_INI_ALL |
session.referer_check | "" | PHP_INI_ALL |
session.save_handler | "files" | PHP_INI_ALL |
session.save_path | "" | PHP_INI_ALL |
session.serialize_handler | "php" | PHP_INI_ALL |
session.use_cookies | "1" | PHP_INI_ALL |
session.use_only_cookies | "1" | PHP_INI_ALL | K dispozici od PHP 4.3.0.
session.use_trans_sid | "0" | PHP_INI_ALL | PHP_INI_ALL v PHP <= 4.2.3. PHP_INI_PERDIR v PHP < 5. K dispozici od PHP 4.0.3.
session_pgsql.create_table | "1" | PHP_INI_SYSTEM |
session_pgsql.db | "host=localhost dbname=php_session user=nobody" | PHP_INI_SYSTEM |
session_pgsql.disable | "0" | PHP_INI_SYSTEM |
session_pgsql.failover_mode | "0" | PHP_INI_SYSTEM |
session_pgsql.gc_interval | "3600" | PHP_INI_SYSTEM |
session_pgsql.keep_expired | "0" | PHP_INI_SYSTEM |
session_pgsql.sem_file_name | "/tmp/php_session_pgsql" | PHP_INI_SYSTEM |
session_pgsql.serializable | "0" | PHP_INI_SYSTEM |
session_pgsql.short_circuit | "0" | PHP_INI_SYSTEM |
session_pgsql.use_app_vars | "0" | PHP_INI_SYSTEM |
session_pgsql.vacuum_interval | "21600" | PHP_INI_SYSTEM |
short_open_tag | "1" | PHP_INI_PERDIR | PHP_INI_ALL v PHP <= 4.0.0.
simple_cvs.authMethod | "0" | PHP_INI_ALL |
simple_cvs.compressionLevel | "0" | PHP_INI_ALL |
simple_cvs.cvsRoot | "0" | PHP_INI_ALL |
simple_cvs.host | "0" | PHP_INI_ALL |
simple_cvs.moduleName | "0" | PHP_INI_ALL |
simple_cvs.userName | "0" | PHP_INI_ALL |
simple_cvs.workingDir | "0" | PHP_INI_ALL |
SMTP | "localhost" | PHP_INI_ALL |
smtp_port | "25" | PHP_INI_ALL | K dispozici od PHP 4.3.0.
soap.wsdl_cache_dir | "/tmp" | PHP_INI_ALL | K dispozici od PHP 5.0.0.
soap.wsdl_cache_enabled | "1" | PHP_INI_ALL | K dispozici od PHP 5.0.0.
soap.wsdl_cache_ttl | "86400" | PHP_INI_ALL | K dispozici od PHP 5.0.0.
sql.safe_mode | "0" | PHP_INI_SYSTEM |
sqlite.assoc_case | "0" | PHP_INI_ALL | K dispozici od PHP 5.0.0.
sybase.allow_persistent | "1" | PHP_INI_ALL | PHP_INI_ALL v PHP <= 4.0.2. PHP_INI_SYSTEM v PHP <= 4.0.3.
sybase.compatability_mode | "0" | PHP_INI_ALL |
sybase.interface_file | "" | PHP_INI_ALL |
sybase.max_links | "-1" | PHP_INI_ALL | PHP_INI_ALL v PHP <= 4.0.2. PHP_INI_SYSTEM v PHP <= 4.0.3.
sybase.max_persistent | "-1" | PHP_INI_ALL | PHP_INI_ALL v PHP <= 4.0.2. PHP_INI_SYSTEM v PHP <= 4.0.3.
sybase.min_error_severity | "10" | PHP_INI_ALL |
sybase.min_message_severity | "10" | PHP_INI_ALL |
sybct.allow_persistent | "1" | PHP_INI_SYSTEM | PHP_INI_ALL v PHP <= 4.0.2. K dispozici od PHP 4.0.2.
sybct.deadlock_retry_count | "0" | PHP_INI_ALL | K dispozici od PHP 4.3.0.
sybct.hostname | NULL | PHP_INI_ALL | K dispozici od PHP 4.0.2.
sybct.login_timeout | "-1" | PHP_INI_ALL | K dispozici od PHP 4.0.2.
sybct.max_links | "-1" | PHP_INI_SYSTEM | PHP_INI_ALL v PHP <= 4.0.2. K dispozici od PHP 4.0.2.
sybct.max_persistent | "-1" | PHP_INI_SYSTEM | PHP_INI_ALL v PHP <= 4.0.2. K dispozici od PHP 4.0.2.
sybct.min_client_severity | "10" | PHP_INI_ALL | K dispozici od PHP 4.0.2.
sybct.min_server_severity | "10" | PHP_INI_ALL | K dispozici od PHP 4.0.2.
sybct.packet_size | "0" | PHP_INI_ALL | K dispozici od PHP 4.3.5.
sybct.timeout | "0" | PHP_INI_ALL | K dispozici od PHP 4.0.2.
sysvshm.init_mem | "10000" | PHP_INI_ALL |
tidy.clean_output | "0" | PHP_INI_PERDIR | K dispozici od PHP 5.0.0.
tidy.default_config | "" | PHP_INI_SYSTEM | K dispozici od PHP 5.0.0.
track_errors | "0" | PHP_INI_ALL |
unicode.fallback_encoding | NULL | PHP_INI_ALL | K dispozici od PHP 6.0.0.
unicode.from_error_mode | "2" | PHP_INI_ALL | K dispozici od PHP 6.0.0.
unicode.from_error_subst_char | "3f" | PHP_INI_ALL | K dispozici od PHP 6.0.0.
unicode.http_input_encoding | NULL | PHP_INI_ALL | K dispozici od PHP 6.0.0.
unicode.output_encoding | NULL | PHP_INI_ALL | K dispozici od PHP 6.0.0.
unicode.runtime_encoding | NULL | PHP_INI_ALL | K dispozici od PHP 6.0.0.
unicode.script_encoding | NULL | PHP_INI_ALL | K dispozici od PHP 6.0.0.
unicode_semantics | "off" | PHP_INI_PERDIR | K dispozici od PHP 6.0.0.
unserialize_callback_func | NULL | PHP_INI_ALL | K dispozici od PHP 4.2.0.
upload_max_filesize | "2M" | PHP_INI_PERDIR | PHP_INI_ALL v PHP <= 4.2.3.
upload_tmp_dir | NULL | PHP_INI_SYSTEM |
url_rewriter.tags | "a=href,area=href,frame=src,form=,fieldset=" | PHP_INI_ALL | K dispozici od PHP 4.0.4.
user_agent | NULL | PHP_INI_ALL | K dispozici od PHP 4.3.0.
user_dir | NULL | PHP_INI_SYSTEM |
valkyrie.auto_validate | "0" | PHP_INI_ALL |
valkyrie.config_path | NULL | PHP_INI_ALL |
variables_order | "EGPCS" | PHP_INI_PERDIR | PHP_INI_ALL v PHP <= 5.0.5.
xbithack | "0" | PHP_INI_ALL | K dispozici od PHP 4.0.5.
xmlrpc_errors | "0" | PHP_INI_SYSTEM | K dispozici od PHP 4.1.0.
xmlrpc_error_number | "0" | PHP_INI_ALL | K dispozici od PHP 4.1.0.
xmms.path | "/usr/bin/xmms" | PHP_INI_ALL |
xmms.session | "0" | PHP_INI_ALL |
y2k_compliance | "1" | PHP_INI_ALL |
yaz.keepalive | "120" | PHP_INI_ALL |
yaz.log_file | NULL | PHP_INI_ALL | K dispozici od PHP 4.3.0.
yaz.log_mask | NULL | PHP_INI_ALL |
yaz.max_links | "100" | PHP_INI_ALL | K dispozici od PHP 4.3.0.
zend.ze1_compatibility_mode | "0" | PHP_INI_ALL | K dispozici od PHP 5.0.0.
zlib.output_compression | "0" | PHP_INI_ALL | K dispozici od PHP 4.0.5.
zlib.output_compression_level | "-1" | PHP_INI_ALL | K dispozici od PHP 4.3.0.
zlib.output_handler | "" | PHP_INI_ALL | K dispozici od PHP 4.3.0.

Tabulka I.2. Definice konstant PHP_INI_*

Konstanta | Hodnota | Význam
PHP_INI_USER | 1 | Položku lze nastavit ve Windows registry
PHP_INI_PERDIR | 2 | Položku lze nastavit v php.ini, .htaccess nebo httpd.conf
PHP_INI_SYSTEM | 4 | Položku lze nastavit v php.ini nebo httpd.conf
PHP_INI_ALL | 7 | Položku lze nastavit kdekoliv

Předcházející | Nahoru | Další
H. Konfigurační volby | Domů | Popis základních direktiv php.ini


Popis základních direktiv php.ini

Tento seznam zahrnuje základní direktivy php.ini, kterými můžete nastavovat konfiguraci PHP. Direktivy obsluhované pomocí rozšíření jsou sepsány (včetně detailů) v dokumentačních stránkách příslušných rozšíření. Např. informace o direktivách týkajících se sessions lze najít na stránkách o sessions.

Volby httpd

Tabulka I.3. Volby httpd

Název | Default | Lze měnit | Přehled změn (changelog)
async_send | "0" | PHP_INI_ALL |

Jazykové volby

Tabulka I.4. Jazykové a ostatní konfigurační volby

Název | Výchozí | Lze měnit | Přehled změn (changelog)
short_open_tag | "1" | PHP_INI_PERDIR | PHP_INI_ALL v PHP <= 4.0.0.
asp_tags | "0" | PHP_INI_PERDIR | PHP_INI_ALL v PHP <= 4.0.0.
precision | "14" | PHP_INI_ALL |
y2k_compliance | "1" | PHP_INI_ALL |
allow_call_time_pass_reference | "1" | PHP_INI_PERDIR | PHP_INI_ALL v PHP <= 4.0.0.
expose_php | "1" | pouze php.ini |
zend.ze1_compatibility_mode | "0" | PHP_INI_ALL | K dispozici od PHP 5.0.0.

Zde je stručný popis konfiguračních direktiv.

short_open_tag boolean

Říká, zda by měla být povolena krátká forma (<? ?>) otevírací značky PHP. Chcete-li používat PHP v kombinaci s XML, můžete tuto volbu vypnout kvůli možnosti vkládat <?xml ?>. Jinak můžete pomocí PHP tisknout například: <?php echo '<?xml version="1.0"'; ?>. Pokud je však krátká forma vypnuta, musíte používat dlouhou formu otevírací značky PHP (<?php ?>).

Poznámka: Tato direktiva má dopady i na zkratku <?=, která je totožná s <? echo. Použití této zkratky vyžaduje, aby byla volba short_open_tag zapnuta.

asp_tags boolean

Povolí používání značek <% %> jako v ASP, navíc k obvyklým značkám <?php ?>. Zahrnuje to též zkratku pro tisk hodnot proměnných: <%= $value %>. Pro více informací viz Escaping from HTML.

Poznámka: Support for ASP-style tags was added in 3.0.4.

precision integer
The number of significant digits displayed in floating point numbers.
y2k_compliance boolean
Enforce year 2000 compliance (will cause problems with non-compliant browsers)
allow_call_time_pass_reference boolean

Whether to warn when arguments are passed by reference at function call time. This method is deprecated and is likely to be unsupported in future versions of PHP/Zend. The encouraged method of specifying which arguments should be passed by reference is in the function declaration. You're encouraged to try and turn this option Off and make sure your scripts work properly with it in order to ensure they will work with future versions of the language (you will receive a warning each time you use this feature).

Passing arguments by reference at function call time was deprecated for code cleanliness reason. Function can modify its argument in undocumented way if it didn't declared that the argument is passed by reference. To prevent side-effects it's better to specify which arguments are passed by reference in function declaration only.

See also References Explained.

expose_php boolean

Decides whether PHP may expose the fact that it is installed on the server (e.g. by adding its signature to the Web server header). It is no security threat in any way, but it makes it possible to determine whether you use PHP on your server or not.

zend.ze1_compatibility_mode boolean

Enable compatibility mode with Zend Engine 1 (PHP 4). It affects the cloning, casting (objects with no properties cast to FALSE or 0), and comparing of objects. In this mode, objects are passed by value instead of reference by default.

See also the section titled Migrating from PHP 4 to PHP 5.

Resource Limits

Tabulka I.5. Resource Limits

Název | Výchozí | Lze měnit | Přehled změn (changelog)
memory_limit | "8M" | PHP_INI_ALL |

Zde je stručný popis konfiguračních direktiv.

memory_limit integer

This sets the maximum amount of memory in bytes that a script is allowed to allocate. This helps prevent poorly written scripts for eating up all available memory on a server. In order to use this directive you must have enabled it at compile time. So, your configure line would have included: --enable-memory-limit. Note that you have to set it to -1 if you don't want any limit for your memory.

As of PHP 4.3.2, and when memory_limit is enabled, the PHP function memory_get_usage() is made available.

Připoužítí typu integer je hodnota měřena v bytech. Můžete také použít zkrácenou notaci, jak je popsáno tomto FAQ.

See also: max_execution_time.

Performance Tuning

Tabulka I.6. Performance Tuning

Název | Výchozí | Lze měnit | Přehled změn (changelog)
realpath_cache_size | "16K" | PHP_INI_SYSTEM | K dispozici od PHP 5.1.0.
realpath_cache_ttl | "120" | PHP_INI_SYSTEM | K dispozici od PHP 5.1.0.

Zde je stručný popis konfiguračních direktiv.

realpath_cache_size integer

Determines the size of the realpath cache to be used by PHP. This value should be increased on systems where PHP opens many files, to reflect the quantity of the file operations performed.

realpath_cache_ttl integer

Duration of time (in seconds) for which to cache realpath information for a given file or directory. For systems with rarely changing files, consider increasing the value.

Data Handling

Tabulka I.7. Data Handling Configuration Options

Název | Výchozí | Lze měnit | Přehled změn (changelog)
track_vars | "On" | PHP_INI_?? |
arg_separator.output | "&" | PHP_INI_ALL | K dispozici od PHP 4.0.5.
arg_separator.input | "&" | PHP_INI_PERDIR | K dispozici od PHP 4.0.5.
variables_order | "EGPCS" | PHP_INI_PERDIR | PHP_INI_ALL v PHP <= 5.0.5.
auto_globals_jit | "1" | PHP_INI_PERDIR | K dispozici od PHP 5.0.0.
register_globals | "0" | PHP_INI_PERDIR | PHP_INI_ALL v PHP <= 4.2.3.
register_argc_argv | "1" | PHP_INI_PERDIR | PHP_INI_ALL v PHP <= 4.2.3.
register_long_arrays | "1" | PHP_INI_PERDIR | K dispozici od PHP 5.0.0.
post_max_size | "8M" | PHP_INI_PERDIR | PHP_INI_SYSTEM v PHP <= 4.2.3. K dispozici od PHP 4.0.3.
gpc_order | "GPC" | PHP_INI_ALL |
auto_prepend_file | NULL | PHP_INI_PERDIR | PHP_INI_ALL v PHP <= 4.2.3.
auto_append_file | NULL | PHP_INI_PERDIR | PHP_INI_ALL v PHP <= 4.2.3.
default_mimetype | "text/html" | PHP_INI_ALL |
default_charset | "" | PHP_INI_ALL |
always_populate_raw_post_data | "0" | PHP_INI_PERDIR | PHP_INI_ALL v PHP <= 4.2.3. K dispozici od PHP 4.1.0.
allow_webdav_methods | "0" | PHP_INI_PERDIR |

Zde je stručný popis konfiguračních direktiv.

track_vars boolean

If enabled, then Environment, GET, POST, Cookie, and Server variables can be found in the global associative arrays $_ENV, $_GET, $_POST, $_COOKIE, and $_SERVER.

Note that as of PHP 4.0.3, track_vars is always turned on.

arg_separator.output string

The separator used in PHP generated URLs to separate arguments.

arg_separator.input string

List of separator(s) used by PHP to parse input URLs into variables.

Poznámka: Every character in this directive is considered as separator!

variables_order string

Set the order of the EGPCS (Environment, GET, POST, Cookie, Server) variable parsing. The default setting of this directive is "EGPCS". Setting this to "GP", for example, will cause PHP to completely ignore environment variables, cookies and server variables, and to overwrite any GET method variables with POST-method variables of the same name.

See also register_globals.

auto_globals_jit boolean

When enabled, the SERVER and ENV variables are created when they're first used (Just In Time) instead of when the script starts. If these variables are not used within a script, having this directive on will result in a performance gain.

The PHP directives register_globals, register_long_arrays, and register_argc_argv must be disabled for this directive to have any affect. Since PHP 5.1.3 it is not necessary to have register_argc_argv disabled.

register_globals boolean

Whether or not to register the EGPCS (Environment, GET, POST, Cookie, Server) variables as global variables.

As of » PHP 4.2.0, this directive defaults to off.

Please read the security chapter on Using register_globals for related information.

Please note that register_globals cannot be set at runtime (ini_set()). Although, you can use .htaccess if your host allows it as described above. An example .htaccess entry: php_flag register_globals off.

Poznámka: register_globals is affected by the variables_order directive.

This directive was removed in PHP 6.0.0.

register_argc_argv boolean

Tells PHP whether to declare the argv & argc variables (that would contain the GET information).

See also command line. Also, this directive became available in PHP 4.0.0 and was always "on" before that.

register_long_arrays boolean

Tells PHP whether or not to register the deprecated long $HTTP_*_VARS type predefined variables. When On (default), long predefined PHP variables like $HTTP_GET_VARS will be defined. If you're not using them, it's recommended to turn them off, for performance reasons. Instead, use the superglobal arrays, like $_GET.

This directive became available in PHP 5.0.0 and was dropped in PHP 6.0.0.

post_max_size integer

Sets max size of post data allowed. This setting also affects file upload. To upload large files, this value must be larger than upload_max_filesize.

If memory limit is enabled by your configure script, memory_limit also affects file uploading. Generally speaking, memory_limit should be larger than post_max_size.

Připoužítí typu integer je hodnota měřena v bytech. Můžete také použít zkrácenou notaci, jak je popsáno tomto FAQ.

If the size of post data is greater than post_max_size, the $_POST and $_FILES superglobals are empty. This can be tracked in various ways, e.g. by passing the $_GET variable to the script processing the data, i.e. <form action="edit.php?processed=1">, and then checking if $_GET['processed'] is set.

gpc_order string

Set the order of GET/POST/COOKIE variable parsing. The default setting of this directive is "GPC". Setting this to "GP", for example, will cause PHP to completely ignore cookies and to overwrite any GET method variables with POST-method variables of the same name.

Poznámka: This option is not available in PHP 4. Use variables_order instead.

auto_prepend_file string

Specifies the name of a file that is automatically parsed before the main file. The file is included as if it was called with the include() function, so include_path is used.

The special value none disables auto-prepending.

auto_append_file string

Specifies the name of a file that is automatically parsed after the main file. The file is included as if it was called with the include() function, so include_path is used.

The special value none disables auto-appending.

Poznámka: If the script is terminated with exit(), auto-append will not occur.

default_mimetype string

default_charset string

As of 4.0b4, PHP always outputs a character encoding by default in the Content-type: header. To disable sending of the charset, simply set it to be empty.

always_populate_raw_post_data boolean

Always populate the $HTTP_RAW_POST_DATA containing the raw POST data. Otherwise, the variable is populated only with unrecognized MIME type of the data. However, the preferred method for accessing the raw POST data is php://input. $HTTP_RAW_POST_DATA is not available with enctype="multipart/form-data".

allow_webdav_methods boolean

Allow handling of WebDAV http requests within PHP scripts (eg. PROPFIND, PROPPATCH, MOVE, COPY, etc.). This directive does not exist as of PHP 4.3.2. If you want to get the post data of those requests, you have to set always_populate_raw_post_data as well.

See also: magic_quotes_gpc, magic_quotes_runtime, and magic_quotes_sybase.

Paths and Directories

Tabulka I.8. Paths and Directories Configuration Options

Název | Výchozí | Lze měnit | Přehled změn (changelog)
include_path | ".;/path/to/php/pear" | PHP_INI_ALL |
doc_root | NULL | PHP_INI_SYSTEM |
user_dir | NULL | PHP_INI_SYSTEM |
extension_dir | "/path/to/php" | PHP_INI_SYSTEM |
extension | NULL | pouze php.ini |
cgi.fix_pathinfo | "1" | PHP_INI_ALL | K dispozici od PHP 4.3.0.
cgi.force_redirect | "1" | PHP_INI_ALL | K dispozici od PHP 4.2.0.
cgi.redirect_status_env | NULL | PHP_INI_ALL | K dispozici od PHP 4.2.0.
fastcgi.impersonate | "0" | PHP_INI_ALL | K dispozici od PHP 4.3.0.
cgi.rfc2616_headers | "0" | PHP_INI_ALL | K dispozici od PHP 4.3.0.

Zde je stručný popis konfiguračních direktiv.

include_path string

Specifies a list of directories where the require(), include() and fopen_with_path() functions look for files. The format is like the system's PATH environment variable: a list of directories separated with a colon in Unix or semicolon in Windows.

Příklad I.1. Unix include_path

include_path=".:/php/includes"

Příklad I.2. Windows include_path

include_path=".;c:\php\includes"

Using a . in the include path allows for relative includes as it means the current directory.

doc_root string

PHP's "root directory" on the server. Only used if non-empty. If PHP is configured with bezpečný režim, no files outside this directory are served. If PHP was not compiled with FORCE_REDIRECT, you should set doc_root if you are running PHP as a CGI under any web server (other than IIS). The alternative is to use the cgi.force_redirect configuration below.

user_dir string

The base name of the directory used on a user's home directory for PHP files, for example public_html .

extension_dir string

In what directory PHP should look for dynamically loadable extensions. See also: enable_dl, and dl().

extension string

Which dynamically loadable extensions to load when PHP starts up.

cgi.fix_pathinfo boolean

Provides real PATH_INFO/PATH_TRANSLATED support for CGI. PHP's previous behaviour was to set PATH_TRANSLATED to SCRIPT_FILENAME, and to not grok what PATH_INFO is. For more information on PATH_INFO, see the cgi specs. Setting this to 1 will cause PHP CGI to fix it's paths to conform to the spec. A setting of zero causes PHP to behave as before. Default is zero. You should fix your scripts to use SCRIPT_FILENAME rather than PATH_TRANSLATED.

cgi.force_redirect boolean

cgi.force_redirect is necessary to provide security running PHP as a CGI under most web servers. Left undefined, PHP turns this on by default. You can turn it off at your own risk.

Poznámka: Windows Users: You can safely turn this off for IIS, in fact, you must. To get OmniHTTPD or Xitami to work you must turn it off.

cgi.redirect_status_env string

If cgi.force_redirect is turned on, and you are not running under Apache or Netscape (iPlanet) web servers, you may need to set an environment variable name that PHP will look for to know it is OK to continue execution.

Poznámka: Setting this variable may cause security issues, know what you are doing first.

fastcgi.impersonate string

FastCGI under IIS (on WINNT based OS) supports the ability to impersonate security tokens of the calling client. This allows IIS to define the security context that the request runs under. mod_fastcgi under Apache does not currently support this feature (03/17/2002) Set to 1 if running under IIS. Default is zero.

cgi.rfc2616_headers int

Tells PHP what type of headers to use when sending HTTP response code. If it's set 0, PHP sends a Status: header that is supported by Apache and other web servers. When this option is set to 1, PHP will send » RFC 2616 compliant headers. Leave it set to 0 unless you know what you're doing.

File Uploads

Tabulka I.9. File Uploads Configuration Options

Název | Výchozí | Lze měnit | Přehled změn (changelog)
file_uploads | "1" | PHP_INI_SYSTEM | PHP_INI_ALL v PHP <= 4.2.3. K dispozici od PHP 4.0.3.
upload_tmp_dir | NULL | PHP_INI_SYSTEM |
upload_max_filesize | "2M" | PHP_INI_PERDIR | PHP_INI_ALL v PHP <= 4.2.3.

Zde je stručný popis konfiguračních direktiv.

file_uploads boolean

Whether or not to allow HTTP file uploads. See also the upload_max_filesize, upload_tmp_dir, and post_max_size directives.

Připoužítí typu integer je hodnota měřena v bytech. Můžete také použít zkrácenou notaci, jak je popsáno tomto FAQ.

upload_tmp_dir string

The temporary directory used for storing files when doing file upload. Must be writable by whatever user PHP is running as. If not specified PHP will use the system's default.

upload_max_filesize integer

The maximum size of an uploaded file.

Připoužítí typu integer je hodnota měřena v bytech. Můžete také použít zkrácenou notaci, jak je popsáno tomto FAQ.

General SQL

Tabulka I.10. General SQL Configuration Options

Název | Výchozí | Lze měnit | Přehled změn (changelog)
sql.safe_mode | "0" | PHP_INI_SYSTEM |

Zde je stručný popis konfiguračních direktiv.

sql.safe_mode boolean

If turned on, database connect functions that specify default values will use those values in place of supplied arguments. For default values see connect function documentation for the relevant database.

Debugger Configuration Directives

Výstraha

Only PHP 3 implements a default debugger, for more information see G – „Ladění (debugging) PHP“.

debugger.host string

DNS name or IP address of host used by the debugger.

debugger.port string

Port number used by the debugger.

debugger.enabled boolean

Whether the debugger is enabled.

Předcházející | Nahoru | Další
I. Direktivy php.ini | Domů | J. List of Supported Timezones


Část II. Instalace a konfigurace

Obsah

3. Obecné instalační úvahy
4. Installation on Unix systems
5. Installation on Mac OS X
6. Installation on Windows systems
7. Installation of PECL extensions
8. Problems?
9. Runtime Configuration
Předcházející | Nahoru | Další
A co dál? | Domů | 3. Obecné instalační úvahy


Kapitola 3. Obecné instalační úvahy

Než začnete s instalací, musíte nejdřív vědět, k čemu chcete PHP používat. Existují tři hlavní oblasti, kde můžete PHP použít, jak je napsáno v sekci Co dokáže PHP?:

  • Skriptování na straně serveru
  • Skriptování v příkazovém řádku
  • Psaní desktopových aplikací

Pro první a nejčastější formu potřebujete tři věci: samotné PHP, webový server a webový prohlížeč. Prohlížeč pravděpodobně už máte, a v závislosti na nastavení vašeho operačního systému, už asi máte také webový server (např. Apache v Linuxu a MacOS X; IIS ve Windows). Můžete si též pronajmout webový prostor u nějaké společnosti. Nemusíte tedy sami nastavovat vůbec nic, jen napsat své PHP skripty, nahrát je na server, který máte pronajatý, a pozorovat výsledky ve svém prohlížeči.

Pokud nastavujete server a PHP sami, máte na výběr dvě metody propojení PHP se serverem. Pro mnoho serverů má PHP přímý modul rozhraní (též nazývaný SAPI). Mezi tyto servery patří Apache, Microsoft Internet Information Server, Netscape a iPlanet. Mnohé další servery podporují ISAPI, modul rozhraní od Microsoftu (např. OmniHTTPd). Pokud PHP nepodporuje modul pro váš server, vždy ho ještě můžete použít jako CGI nebo FastCGI procesor. To znamená, že si svůj server nastavíte pro používání spustitelných CGI programů ke zpracování veškerých požadavků PHP souborů na serveru.

Máte-li zájem používat PHP pro skriptování z příkazové řádky (např. psát skripty, které vám automaticky vygenerují nějaké obrázky, pokud jste offline, nebo zpracování textových souborů na základě nějakých argumentů, které jim zadáte), vždy potřebujete spustitelný program pro příkazovou řádku. Pro více informací si přečtěte sekci o psaní PHP aplikací v příkazové řádce. V tomto případě nepotřebujete žádný server ani prohlížeč.

S PHP můžete také psát desktopové GUI aplikace pomocí rozšíření PHP-GTK. Je to úplně odlišný přístup než psaní webových stránek, protože neprodukujete žádné HTML, nýbrž spravujete okna a objekty v nich. Pro více informací o PHP-GTK navštivte prosím » stránku věnovanou tomuto rozšíření. PHP-GTK není zahrnuto v oficiální distribuci PHP.

Počínaje tímto, budete se v této sekci zabývat nastavování PHP pro webový server na Unixech a Windows se serverovým modulem rozhraní a spustitelným souborem CGI. V následujících sekcích též najdete informace o spustitelném programu pro příkazovou řádku.

Zdrojové kódy PHP a binární distribuce pro Windows lze najít na » http://www.php.net/downloads.php. Doporučujeme vám vybrat si pro stažení distribuce » zrcadlo, které je k vám nejblíž.

Předcházející | Nahoru | Další
II. Instalace a konfigurace | Domů | 4. Installation on Unix systems


Kapitola 5. Installation on Mac OS X

Obsah

Using Packages
Using the bundled PHP
Compiling for OS X Server
Compiling for MacOS X Client

This section contains notes and hints specific to installing PHP on Mac OS X. There are two slightly different versions of Mac OS X, Client and Server, our manual deals with installing PHP on both systems. Note that PHP is not available for MacOS 9 and earlier versions.

Using Packages

There are a few pre-packaged and pre-compiled versions of PHP for Mac OS X. This can help in setting up a standard configuration, but if you need to have a different set of features (such as a secure server, or a different database driver), you may need to build PHP and/or your web server yourself. If you are unfamiliar with building and compiling your own software, it's worth checking whether somebody has already built a packaged version of PHP with the features you need.

The following resources offer easy to install packages and precompiled binaries for PHP on Mac OS:

  • MacPorts: » http://www.macports.org/
  • Entropy: » http://www.entropy.ch/software/macosx/php/
  • Fink: » http://fink.sourceforge.net/

Předcházející | Nahoru | Další
Debian GNU/Linux installation notes | Domů | Using the bundled PHP


Using the bundled PHP

PHP has come standard with Macs since OS X version 10.0.0. Enabling PHP with the default web server requires uncommenting a few lines in the Apache configuration file httpd.conf whereas the CGI and/or CLI are enabled by default (easily accessible via the Terminal program).

Enabling PHP using the instructions below is meant for quickly setting up a local development environment. It's highly recommended to always upgrade PHP to the newest version. Like most live software, newer versions are created to fix bugs and add features and PHP being is no different. See the appropriate MAC OS X installation documentation for further details. The following instructions are geared towards a beginner with details provided for getting a default setup to work. All users are encouraged to compile, or install a new packaged version.

The standard installation type is using mod_php, and enabling the bundled mod_php on Mac OS X for the Apache web server (the default web server, that is accessible via System Preferences) involves the following steps:

  1. Locate and open the Apache configuration file. By default, the location is as follows: /etc/httpd/httpd.conf

    Using Finder or Spotlight to find this file may prove difficult as by default it's private and owned by the root user.

    Poznámka: One way to open this is by using a Unix based text editor in the Terminal, for example nano, and because the file is owned by root we'll use the sudo command to open it (as root) so for example type the following into the Terminal Application (after, it will prompt for a password): sudo nano /etc/httpd/httpd.conf

    Noteworthy nano commands: ^w (search), ^o (save), and ^x (exit) where ^ represents the Ctrl key.

  2. With a text editor, uncomment the lines (by removing the #) that look similar to the following (these two lines are often not together, locate them both in the file):

# LoadModule php4_module libexec/httpd/libphp4.so

# AddModule mod_php4.c

    Notice the location/path. When building PHP in the future, the above files should be replaced or commented out.

  3. Be sure the desired extensions will parse as PHP (examples: .php .html and .inc)

    Due to the following statement already existing in httpd.conf (as of Mac Panther), once PHP is enabled the .php files will automatically parse as PHP.

<IfModule mod_php4.c>
    # If php is turned on, we respect .php and .phps files.
    AddType application/x-httpd-php .php
    AddType application/x-httpd-php-source .phps

    # Since most users will want index.php to work we
    # also automatically enable index.php
    <IfModule mod_dir.c>
        DirectoryIndex index.html index.php
    </IfModule>
</IfModule>

  4. Be sure the DirectoryIndex loads the desired default index file

    This is also set in httpd.conf. Typically index.php and index.html are used. By default index.php is enabled because it's also in the PHP check shown above. Adjust accordingly.

  5. Set the php.ini location or use the default

    A typical default location on Mac OS X is /usr/local/php/php.ini and a call to phpinfo() will reveal this information. If a php.ini is not used, PHP will use all default values. See also the related FAQ on finding php.ini.

  6. Locate or set the DocumentRoot

    This is the root directory for all the web files. Files in this directory are served from the web server so the PHP files will parse as PHP before outputting them to the browser. A typical default path is /Library/WebServer/Documents but this can be set to anything in httpd.conf. Alternatively, the default DocumentRoot for individual users is /Users/yourusername/Sites

  7. Create a phpinfo() file

    The phpinfo() function will display information about PHP. Consider creating a file in the DocumentRoot with the following PHP code: <?php phpinfo(); ?>

  8. Restart Apache, and load the PHP file created above

    To restart, either execute sudo apachectl graceful in the shell or stop/start the "Personal Web Server" option in the OS X System Preferences. By default, loading local files in the browser will have an URL like so: http://localhost/info.php Or using the DocumentRoot in the user directory is another option and would end up looking like: http://localhost/~yourusername/info.php

The CLI (or CGI in older versions) is appropriately named php and likely exists as /usr/bin/php. Open up the terminal, read the command line section of the PHP manual, and execute php -v to check the PHP version of this PHP binary. A call to phpinfo() will also reveal this information.

Předcházející | Nahoru | Další
5. Installation on Mac OS X | Domů | Compiling for OS X Server


Compiling for MacOS X Client

The following instructions will help you install a PHP module for the Apache web server included in MacOS X. This version includes support for the MySQL and PostgreSQL databases. These instructions are graciously provided by » Marc Liyanage.

Varování

Be careful when you do this, you could screw up your Apache web server!

Do this to install:

  1. Open a terminal window.
  2. Type wget http://www.diax.ch/users/liyanage/software/macosx/libphp4.so.gz, wait for the download to finish.
  3. Type gunzip libphp4.so.gz.
  4. Type sudo apxs -i -a -n php4 libphp4.so

  5. Now type sudo open -a TextEdit /etc/httpd/httpd.conf. TextEdit will open with the web server configuration file. Locate these two lines towards the end of the file: (Use the Find command)

#AddType application/x-httpd-php .php
#AddType application/x-httpd-php-source .phps

    Remove the two hash marks (#), then save the file and quit TextEdit.

  6. Finally, type sudo apachectl graceful to restart the web server.

PHP should now be up and running. You can test it by dropping a file into your Sites folder which is called test.php. Into that file, write this line: <?php phpinfo() ?>.

Now open up 127.0.0.1/~your_username/test.php in your web browser. You should see a status table with information about the PHP module.

Předcházející | Nahoru | Další
Compiling for OS X Server | Domů | 6. Installation on Windows systems


Compiling for OS X Server

Mac OS X Server install.

  1. Get the latest distributions of Apache and PHP.

  2. Untar them, and run the configure program on Apache like so.

./configure --exec-prefix=/usr \
--localstatedir=/var \
--mandir=/usr/share/man \
--libexecdir=/System/Library/Apache/Modules \
--iconsdir=/System/Library/Apache/Icons \
--includedir=/System/Library/Frameworks/Apache.framework/Versions/1.3/Headers \
--enable-shared=max \
--enable-module=most \
--target=apache

  3. If you want the compiler to do some optimization, you may also want to add this line:

setenv OPTIM=-O2

  4. Next, go to the PHP 4 source directory and configure it.

./configure --prefix=/usr \
    --sysconfdir=/etc \
    --localstatedir=/var \
    --mandir=/usr/share/man \
    --with-xml \
    --with-apache=/src/apache_1.3.12

    If you have any other additions (MySQL, GD, etc.), be sure to add them here. For the --with-apache string, put in the path to your apache source directory, for example /src/apache_1.3.12.

  5. Type make and make install. This will add a directory to your Apache source directory under src/modules/php4.

  6. Now, reconfigure Apache to build in PHP 4.

./configure --exec-prefix=/usr \
--localstatedir=/var \
--mandir=/usr/share/man \
--libexecdir=/System/Library/Apache/Modules \
--iconsdir=/System/Library/Apache/Icons \
--includedir=/System/Library/Frameworks/Apache.framework/Versions/1.3/Headers \
--enable-shared=max \
--enable-module=most \
--target=apache \
--activate-module=src/modules/php4/libphp4.a

    You may get a message telling you that libmodphp4.a is out of date. If so, go to the src/modules/php4 directory inside your Apache source directory and run this command: ranlib libmodphp4.a. Then go back to the root of the Apache source directory and run the above configure command again. That'll bring the link table up to date. Run make and make install again.

  7. Copy and rename the php.ini-dist file to your bin directory from your PHP 4 source directory: cp php.ini-dist /usr/local/bin/php.ini or (if your don't have a local directory) cp php.ini-dist /usr/bin/php.ini.

Předcházející | Nahoru | Další
Using the bundled PHP | Domů | Compiling for MacOS X Client


Kapitola 7. Installation of PECL extensions

Obsah

Introduction to PECL Installations
Downloading PECL extensions
PECL for Windows users
Compiling shared PECL extensions with the pecl command
Compiling shared PECL extensions with phpize
Compiling PECL extensions statically into PHP

Introduction to PECL Installations

» PECL is a repository of PHP extensions that are made available to you via the » PEAR packaging system. This section of the manual is intended to demonstrate how to obtain and install PECL extensions.

These instructions assume /your/phpsrcdir/ is the path to the PHP source distribution, and that extname is the name of the PECL extension. Adjust accordingly. These instructions also assume a familiarity with the » pear command. The information in the PEAR manual for the pear command also applies to the pecl command.

To be useful, a shared extension must be built, installed, and loaded. The methods described below provide you with various instructions on how to build and install the extensions, but they do not automatically load them. Extensions can be loaded by adding an extension directive. To this php.ini file, or through the use of the dl() function.

When building PHP modules, it's important to have known-good versions of the required tools (autoconf, automake, libtool, etc.) See the » Anonymous CVS Instructions for details on the required tools, and required versions.

Předcházející | Nahoru | Další
Installation of extensions on Windows | Domů | Downloading PECL extensions


Downloading PECL extensions

There are several options for downloading PECL extensions, such as:

  • » http://pecl.php.net/

    The PECL web site contains information about the different extensions that are offered by the PHP Development Team. The information available here includes: ChangeLog, release notes, requirements and other similar details.

  • pecl download extname

    PECL extensions that have releases listed on the PECL web site are available for download and installation using the » pecl command. Specific revisions may also be specified.

  • CVS

    Most PECL extensions also reside in CVS. A web-based view may be seen at » http://cvs.php.net/pecl/. To download straight from CVS, the following sequence of commands may be used. Note that phpfi is the password for user cvsread:

    $ cvs -d:pserver:cvsread@cvs.php.net:/repository login
$ cvs -d:pserver:cvsread@cvs.php.net:/repository co pecl/extname

  • Windows downloads

    Windows users may find compiled PECL binaries by downloading the Collection of PECL modules from the » PHP Downloads page, or by retrieving a » PECL Snapshot or an extension DLL on » PECL4WIN. To compile PHP under Windows, read the appropriate chapter.

Předcházející | Nahoru | Další
7. Installation of PECL extensions | Domů | PECL for Windows users


Compiling shared PECL extensions with the pecl command

PECL makes it easy to create shared PHP extensions. Using the » pecl command, do the following:

$ pecl install extname

This will download the source for extname, compile, and install extname.so into your extension_dir. extname.so may then be loaded via php.ini

By default, the pecl command will not install packages that are marked with the alpha or beta state. If no stable packages are available, you may install a beta package using the following command:

$ pecl install extname-beta

You may also install a specific version using this variant:

$ pecl install extname-0.1

Poznámka: After enabling the extension in php.ini, restarting the web service is required for the changes to be picked up.

Předcházející | Nahoru | Další
PECL for Windows users | Domů | Compiling shared PECL extensions with phpize


Compiling shared PECL extensions with phpize

Sometimes, using the pecl installer is not an option. This could be because you're behind a firewall, or it could be because the extension you want to install is not available as a PECL compatible package, such as unreleased extensions from CVS. If you need to build such an extension, you can use the lower-level build tools to perform the build manually.

The phpize command is used to prepare the build environment for a PHP extension. In the following sample, the sources for an extension are in a directory named extname:

$ cd extname
$ phpize
$ ./configure
$ make
# make install

A successful install will have created extname.so and put it into the PHP extensions directory. You'll need to and adjust php.ini and add an extension=extname.so line before you can use the extension.

If the system is missing the phpize command, and precompiled packages (like RPM's) are used, be sure to also install the appropriate devel version of the PHP package as they often include the phpize command along with the appropriate header files to build PHP and its extensions.

Execute phpize --help to display additional usage information.

Předcházející | Nahoru | Další
Compiling shared PECL extensions with the pecl command | Domů | Compiling PECL extensions statically into PHP


Compiling PECL extensions statically into PHP

You might find that you need to build a PECL extension statically into your PHP binary. To do this, you'll need to place the extension source under the php-src/ext/ directory and tell the PHP build system to regenerate its configure script.

$ cd /your/phpsrcdir/ext
$ pecl download extname
$ gzip -d < extname.tgz | tar -xvf -
$ mv extname-x.x.x extname

This will result in the following directory:

    /your/phpsrcdir/ext/extname

From here, force PHP to rebuild the configure script, and then build PHP as normal:

$ cd /your/phpsrcdir
$ rm configure
$ ./buildconf --force
$ ./configure --help
$ ./configure --with-extname --enable-someotherext --with-foobar
$ make
$ make install

Poznámka: To run the 'buildconf' script you need autoconf 2.13 and automake 1.4+ (newer versions of autoconf may work, but are not supported).

Whether --enable-extname or --with-extname is used depends on the extension. Typically an extension that does not require external libraries uses --enable. To be sure, run the following after buildconf:

$ ./configure --help | grep extname

Předcházející | Nahoru | Další
Compiling shared PECL extensions with phpize | Domů | 8. Problems?


PECL for Windows users

As with any other PHP extension DLL, installation is as simple as copying the PECL extension DLLs into the extension_dir folder and loading them from php.ini. For example, add the following line to your php.ini:

extension=php_extname.dll

After doing this, restart the web service.

Předcházející | Nahoru | Další
Downloading PECL extensions | Domů | Compiling shared PECL extensions with the pecl command


Kapitola 8. Problems?

Obsah

Read the FAQ
Other problems
Bug reports

Read the FAQ

Some problems are more common than others. The most common ones are listed in the PHP FAQ, part of this manual.

Předcházející | Nahoru | Další
Compiling PECL extensions statically into PHP | Domů | Other problems


Bug reports

If you think you have found a bug in PHP, please report it. The PHP developers probably don't know about it, and unless you report it, chances are it won't be fixed. You can report bugs using the bug-tracking system at » http://bugs.php.net/. Please do not send bug reports in mailing list or personal letters. The bug system is also suitable to submit feature requests.

Read the » How to report a bug document before submitting any bug reports!

Předcházející | Nahoru | Další
Other problems | Domů | 9. Runtime Configuration


Other problems

If you are still stuck, someone on the PHP installation mailing list may be able to help you. You should check out the archive first, in case someone already answered someone else who had the same problem as you. The archives are available from the support page on » http://www.php.net/support.php. To subscribe to the PHP installation mailing list, send an empty mail to » php-install-subscribe@lists.php.net. The mailing list address is » php-install@lists.php.net.

If you want to get help on the mailing list, please try to be precise and give the necessary details about your environment (which operating system, what PHP version, what web server, if you are running PHP as CGI or a server module, bezpečný režim, etc...), and preferably enough code to make others able to reproduce and test your problem.

Předcházející | Nahoru | Další
8. Problems? | Domů | Bug reports


Kapitola 4. Installation on Unix systems

Obsah

Apache 1.3.x on Unix systems
Apache 2.0 on Unix systems
Caudium
fhttpd related notes
Sun, iPlanet and Netscape servers on Sun Solaris
CGI and command line setups
HP-UX specific installation notes
OpenBSD installation notes
Solaris specific installation tips
Debian GNU/Linux installation notes

This section will guide you through the general configuration and installation of PHP on Unix systems. Be sure to investigate any sections specific to your platform or web server before you begin the process.

As our manual outlines in the General Installation Considerations section, we are mainly dealing with web centric setups of PHP in this section, although we will cover setting up PHP for command line usage as well.

There are several ways to install PHP for the Unix platform, either with a compile and configure process, or through various pre-packaged methods. This documentation is mainly focused around the process of compiling and configuring PHP. Many Unix like systems have some sort of package installation system. This can assist in setting up a standard configuration, but if you need to have a different set of features (such as a secure server, or a different database driver), you may need to build PHP and/or your web server. If you are unfamiliar with building and compiling your own software, it is worth checking to see whether somebody has already built a packaged version of PHP with the features you need.

Prerequisite knowledge and software for compiling:

  • Basic Unix skills (being able to operate "make" and a C compiler)
  • An ANSI C compiler
  • flex: Version 2.5.4
  • bison: Version 1.28 (preferred), 1.35, or 1.75
  • A web server
  • Any module specific components (such as gd, pdf libs, etc.)

The initial PHP setup and configuration process is controlled by the use of the command line options of the configure script. You could get a list of all available options along with short explanations running ./configure --help. Our manual documents the different options separately. You will find the core options in the appendix, while the different extension specific options are descibed on the reference pages.

When PHP is configured, you are ready to build the module and/or executables. The command make should take care of this. If it fails and you can't figure out why, see the Problems section.

Apache 1.3.x on Unix systems

This section contains notes and hints specific to Apache installs of PHP on Unix platforms. We also have instructions and notes for Apache 2 on a separate page.

You can select arguments to add to the configure on line 10 below from the list of core configure options and from extension specific options described at the respective places in the manual. The version numbers have been omitted here, to ensure the instructions are not incorrect. You will need to replace the 'xxx' here with the correct values from your files.

Příklad 4.1. Installation Instructions (Apache Shared Module Version) for PHP

1.  gunzip apache_xxx.tar.gz
2.  tar -xvf apache_xxx.tar
3.  gunzip php-xxx.tar.gz
4.  tar -xvf php-xxx.tar
5.  cd apache_xxx
6.  ./configure --prefix=/www --enable-module=so
7.  make
8.  make install
9.  cd ../php-xxx

10. Now, configure your PHP.  This is where you customize your PHP
    with various options, like which extensions will be enabled.  Do a
    ./configure --help for a list of available options.  In our example
    we'll do a simple configure with Apache 1 and MySQL support.  Your
    path to apxs may differ from our example.

      ./configure --with-mysql --with-apxs=/www/bin/apxs

11. make
12. make install

    If you decide to change your configure options after installation,
    you only need to repeat the last three steps. You only need to
    restart apache for the new module to take effect. A recompile of
    Apache is not needed.

    Note that unless told otherwise, 'make install' will also install PEAR,
    various PHP tools such as phpize, install the PHP CLI, and more.

13. Setup your php.ini file:

      cp php.ini-dist /usr/local/lib/php.ini

    You may edit your .ini file to set PHP options.  If you prefer your
    php.ini in another location, use --with-config-file-path=/some/path in
    step 10.

    If you instead choose php.ini-recommended, be certain to read the list
    of changes within, as they affect how PHP behaves.

14. Edit your httpd.conf to load the PHP module.  The path on the right hand
    side of the LoadModule statement must point to the path of the PHP
    module on your system.  The make install from above may have already
    added this for you, but be sure to check.

    For PHP 4:

      LoadModule php4_module libexec/libphp4.so

    For PHP 5:

      LoadModule php5_module libexec/libphp5.so

15. And in the AddModule section of httpd.conf, somewhere under the
    ClearModuleList, add this:

    For PHP 4:

      AddModule mod_php4.c

    For PHP 5:

      AddModule mod_php5.c

16. Tell Apache to parse certain extensions as PHP.  For example,
    let's have Apache parse the .php extension as PHP.  You could
    have any extension(s) parse as PHP by simply adding more, with
    each separated by a space.  We'll add .phtml to demonstrate.

      AddType application/x-httpd-php .php .phtml

    It's also common to setup the .phps extension to show highlighted PHP
    source, this can be done with:

      AddType application/x-httpd-php-source .phps

17. Use your normal procedure for starting the Apache server. (You must
    stop and restart the server, not just cause the server to reload by
    using a HUP or USR1 signal.)

Alternatively, to install PHP as a static object:

Příklad 4.2. Installation Instructions (Static Module Installation for Apache) for PHP

1.  gunzip -c apache_1.3.x.tar.gz | tar xf -
2.  cd apache_1.3.x
3.  ./configure
4.  cd ..

5.  gunzip -c php-5.x.y.tar.gz | tar xf -
6.  cd php-5.x.y
7.  ./configure --with-mysql --with-apache=../apache_1.3.x
8.  make
9.  make install

10. cd ../apache_1.3.x

11. ./configure --prefix=/www --activate-module=src/modules/php5/libphp5.a
    (The above line is correct! Yes, we know libphp5.a does not exist at this
    stage. It isn't supposed to. It will be created.)

12. make
    (you should now have an httpd binary which you can copy to your Apache bin dir if
    it is your first install then you need to "make install" as well)

13. cd ../php-5.x.y
14. cp php.ini-dist /usr/local/lib/php.ini

15. You can edit /usr/local/lib/php.ini file to set PHP options.
    Edit your httpd.conf or srm.conf file and add:
    AddType application/x-httpd-php .php

Poznámka: Replace php-5 by php-4 and php5 by php4 in PHP 4.

Depending on your Apache install and Unix variant, there are many possible ways to stop and restart the server. Below are some typical lines used in restarting the server, for different apache/unix installations. You should replace /path/to/ with the path to these applications on your systems.

Příklad 4.3. Example commands for restarting Apache

1. Several Linux and SysV variants:
/etc/rc.d/init.d/httpd restart

2. Using apachectl scripts:
/path/to/apachectl stop
/path/to/apachectl start

3. httpdctl and httpsdctl (Using OpenSSL), similar to apachectl:
/path/to/httpsdctl stop
/path/to/httpsdctl start

4. Using mod_ssl, or another SSL server, you may want to manually
stop and start:
/path/to/apachectl stop
/path/to/apachectl startssl

The locations of the apachectl and http(s)dctl binaries often vary. If your system has locate or whereis or which commands, these can assist you in finding your server control programs.

Different examples of compiling PHP for apache are as follows:

./configure --with-apxs --with-pgsql

This will create a libphp5.so (or libphp4.so in PHP 4) shared library that is loaded into Apache using a LoadModule line in Apache's httpd.conf file. The PostgreSQL support is embedded into this library.

./configure --with-apxs --with-pgsql=shared

This will create a libphp4.so shared library for Apache, but it will also create a pgsql.so shared library that is loaded into PHP either by using the extension directive in php.ini file or by loading it explicitly in a script using the dl() function.

./configure --with-apache=/path/to/apache_source --with-pgsql

This will create a libmodphp5.a library, a mod_php5.c and some accompanying files and copy this into the src/modules/php5 directory in the Apache source tree. Then you compile Apache using --activate-module=src/modules/php5/libphp5.a and the Apache build system will create libphp5.a and link it statically into the httpd binary (replace php5 by php4 in PHP 4). The PostgreSQL support is included directly into this httpd binary, so the final result here is a single httpd binary that includes all of Apache and all of PHP.

./configure --with-apache=/path/to/apache_source --with-pgsql=shared

Same as before, except instead of including PostgreSQL support directly into the final httpd you will get a pgsql.so shared library that you can load into PHP from either the php.ini file or directly using dl().

When choosing to build PHP in different ways, you should consider the advantages and drawbacks of each method. Building as a shared object will mean that you can compile apache separately, and don't have to recompile everything as you add to, or change, PHP. Building PHP into apache (static method) means that PHP will load and run faster. For more information, see the Apache » web page on DSO support.

Poznámka: Apache's default httpd.conf currently ships with a section that looks like this:

User nobody
Group "#-1"
Unless you change that to "Group nogroup" or something like that ("Group daemon" is also very common) PHP will not be able to open files.

Poznámka: Make sure you specify the installed version of apxs when using --with-apxs=/path/to/apxs. You must NOT use the apxs version that is in the apache sources but the one that is actually installed on your system.

Předcházející | Nahoru | Další
3. Obecné instalační úvahy | Domů | Apache 2.0 on Unix systems


Apache 2.0 on Unix systems

This section contains notes and hints specific to Apache 2.0 installs of PHP on Unix systems.

Varování

Nedoporučujeme používat vláknovou verzi MPM s Apache 2 v produkčním prostředí. Místo toho použijte MPM s preforkem procesů, anebo použijte Apache 1. Víc informací o tom, proč, si můžete přečíst v související FAQ části nazvané Apache2 s vláknovým MPM

You are highly encouraged to take a look at the » Apache Documentation to get a basic understanding of the Apache 2.0 Server.

PHP and Apache 2.0.x compatibility notes: The following versions of PHP are known to work with the most recent version of Apache 2.0.x:

  • PHP 4.3.0 or later available at » http://www.php.net/downloads.php.
  • the latest stable development version. Get the source code » http://snaps.php.net/php5-latest.tar.gz or download binaries for Windows » http://snaps.php.net/win32/php5-win32-latest.zip.
  • a prerelease version downloadable from » http://qa.php.net/.
  • you have always the option to obtain PHP through » anonymous CVS.
These versions of PHP are compatible to Apache 2.0.40 and later.

Apache 2.0 SAPI-support started with PHP 4.2.0. PHP 4.2.3 works with Apache 2.0.39, don't use any other version of Apache with PHP 4.2.3. However, the recommended setup is to use PHP 4.3.0 or later with the most recent version of Apache2.

All mentioned versions of PHP will work still with Apache 1.3.x.

Download the most recent version of » Apache 2.0 and a fitting PHP version from the above mentioned places. This quick guide covers only the basics to get started with Apache 2.0 and PHP. For more information read the » Apache Documentation. The version numbers have been omitted here, to ensure the instructions are not incorrect. You will need to replace the 'NN' here with the correct values from your files.

Příklad 4.4. Installation Instructions (Apache 2 Shared Module Version)

1.  gzip -d httpd-2_0_NN.tar.gz
2.  tar xvf httpd-2_0_NN.tar
3.  gunzip php-NN.tar.gz
4.  tar -xvf php-NN.tar
5.  cd httpd-2_0_NN
6.  ./configure --enable-so
7.  make
8.  make install

    Now you have Apache 2.0.NN available under /usr/local/apache2,
    configured with loadable module support and the standard MPM prefork.
    To test the installation use your normal procedure for starting
    the Apache server, e.g.:
    /usr/local/apache2/bin/apachectl start
    and stop the server to go on with the configuration for PHP:
    /usr/local/apache2/bin/apachectl stop.

9.  cd ../php-NN

10. Now, configure your PHP.  This is where you customize your PHP
    with various options, like which extensions will be enabled.  Do a
    ./configure --help for a list of available options.  In our example
    we'll do a simple configure with Apache 2 and MySQL support.  Your
    path to apxs may differ, in fact, the binary may even be named apxs2 on
    your system.

      ./configure --with-apxs2=/usr/local/apache2/bin/apxs --with-mysql

11. make
12. make install

    If you decide to change your configure options after installation,
    you only need to repeat the last three steps. You only need to
    restart apache for the new module to take effect. A recompile of
    Apache is not needed.

    Note that unless told otherwise, 'make install' will also install PEAR,
    various PHP tools such as phpize, install the PHP CLI, and more.

13. Setup your php.ini

    cp php.ini-dist /usr/local/lib/php.ini

    You may edit your .ini file to set PHP options.  If you prefer having
    php.ini in another location, use --with-config-file-path=/some/path in
    step 10.

    If you instead choose php.ini-recommended, be certain to read the list
    of changes within, as they affect how PHP behaves.

14. Edit your httpd.conf to load the PHP module.  The path on the right hand
    side of the LoadModule statement must point to the path of the PHP
    module on your system.  The make install from above may have already
    added this for you, but be sure to check.

    For PHP 4:

      LoadModule php4_module modules/libphp4.so

    For PHP 5:

      LoadModule php5_module modules/libphp5.so

15. Tell Apache to parse certain extensions as PHP.  For example,
    let's have Apache parse the .php extension as PHP.  You could
    have any extension(s) parse as PHP by simply adding more, with
    each separated by a space.  We'll add .phtml to demonstrate.

      AddType application/x-httpd-php .php .phtml

    It's also common to setup the .phps extension to show highlighted PHP
    source, this can be done with:

      AddType application/x-httpd-php-source .phps

16. Use your normal procedure for starting the Apache server, e.g.:

      /usr/local/apache2/bin/apachectl start

Following the steps above you will have a running Apache 2.0 with support for PHP as SAPI module. Of course there are many more configuration options available for both, Apache and PHP. For more information use ./configure --help in the corresponding source tree. In case you wish to build a multithreaded version of Apache 2.0 you must overwrite the standard MPM-Module prefork either with worker or perchild. To do so append to your configure line in step 6 above either the option --with-mpm=worker or --with-mpm=perchild. Take care about the consequences and understand what you are doing. For more information read the Apache documentation about the » MPM-Modules.

Poznámka: If you want to use content negotiation, read the Apache MultiViews FAQ.

Poznámka: To build a multithreaded version of Apache your system must support threads. This also implies to build PHP with experimental Zend Thread Safety (ZTS). Therefore not all extensions might be available. The recommended setup is to build Apache with the standard prefork MPM-Module.

Předcházející | Nahoru | Další
4. Installation on Unix systems | Domů | Caudium


Caudium

PHP 4 can be built as a Pike module for the » Caudium webserver. Note that this is not supported with PHP 3. Follow the simple instructions below to install PHP 4 for Caudium.

Příklad 4.5. Caudium Installation Instructions

1.  Make sure you have Caudium installed prior to attempting to
    install PHP 4. For PHP 4 to work correctly, you will need Pike
    7.0.268 or newer. For the sake of this example we assume that
    Caudium is installed in /opt/caudium/server/.
2.  Change directory to php-x.y.z (where x.y.z is the version number).
3.  ./configure --with-caudium=/opt/caudium/server
4.  make
5.  make install
6.  Restart Caudium if it's currently running.
7.  Log into the graphical configuration interface and go to the
    virtual server where you want to add PHP 4 support.
8.  Click Add Module and locate and then add the PHP 4 Script Support module.
9.  If the documentation says that the 'PHP 4 interpreter isn't
    available', make sure that you restarted the server. If you did
    check /opt/caudium/logs/debug/default.1 for any errors related to
    <filename>PHP4.so</filename>. Also make sure that
    <filename>caudium/server/lib/[pike-version]/PHP4.so</filename>
    is present.
10. Configure the PHP Script Support module if needed.

You can of course compile your Caudium module with support for the various extensions available in PHP 4. See the reference pages for extension specific configure options.

Poznámka: When compiling PHP 4 with MySQL support you must make sure that the normal MySQL client code is used. Otherwise there might be conflicts if your Pike already has MySQL support. You do this by specifying a MySQL install directory the --with-mysql option.

Předcházející | Nahoru | Další
Apache 2.0 on Unix systems | Domů | fhttpd related notes


CGI and command line setups

The default is to build PHP as a CGI program. This creates a command line interpreter, which can be used for CGI processing, or for non-web-related PHP scripting. If you are running a web server PHP has module support for, you should generally go for that solution for performance reasons. However, the CGI version enables users to run different PHP-enabled pages under different user-ids.

Varování

Při používání konfigurace s CGI je váš server otevřen mnoha možným útokům. Přečtěte si prosím naši sekci bezpečnosti CGI, abyste se naučili bránit se proti takovým útokům.

As of PHP 4.3.0, some important additions have happened to PHP. A new SAPI named CLI also exists and it has the same name as the CGI binary. What is installed at {PREFIX}/bin/php depends on your configure line and this is described in detail in the manual section named Using PHP from the command line. For further details please read that section of the manual.

Testing

If you have built PHP as a CGI program, you may test your build by typing make test. It is always a good idea to test your build. This way you may catch a problem with PHP on your platform early instead of having to struggle with it later.

Benchmarking

If you have built PHP 3 as a CGI program, you may benchmark your build by typing make bench. Note that if bezpečný režim is on by default, the benchmark may not be able to finish if it takes longer then the 30 seconds allowed. This is because the set_time_limit() can not be used in bezpečný režim. Use the max_execution_time configuration setting to control this time for your own scripts. make bench ignores the configuration file.

Poznámka: make bench is only available for PHP 3.

Using Variables

Some server supplied environment variables are not defined in the current » CGI/1.1 specification. Only the following variables are defined there: AUTH_TYPE, CONTENT_LENGTH, CONTENT_TYPE, GATEWAY_INTERFACE, PATH_INFO, PATH_TRANSLATED, QUERY_STRING, REMOTE_ADDR, REMOTE_HOST, REMOTE_IDENT, REMOTE_USER, REQUEST_METHOD, SCRIPT_NAME, SERVER_NAME, SERVER_PORT, SERVER_PROTOCOL, and SERVER_SOFTWARE. Everything else should be treated as 'vendor extensions'.

Předcházející | Nahoru | Další
Sun, iPlanet and Netscape servers on Sun Solaris | Domů | HP-UX specific installation notes


Debian GNU/Linux installation notes

This section contains notes and hints specific to installing PHP on » Debian GNU/Linux.

Using APT

While you can just download the PHP source and compile it yourself, using Debian's packaging system is the simplest and cleanest method of installing PHP. If you are not familiar with building software on Linux, this is the way to go.

The first decision you need to make is whether you want to install Apache 1.3.x or Apache 2.x. The corresponding PHP packages are respectively named libapache-mod-php* and libapache2-mod-php*. The steps given below will use Apache 1.3.x. Please note that, as of this writing, there is no official Debian packages of PHP 5. Then the steps given below will install PHP 4.

PHP is available in Debian as CGI or CLI flavour too, named respectively php4-cgi and php4-cli. If you need them, you'll just have to reproduce the following steps with the good package names. Another special package you'd want to install is php4-pear. It contains a minimal PEAR installation and the pear commandline utility.

If you need more recent packages of PHP than the Debian's stable ones or if some PHP modules lacks the Debian official repository, perhaps you should take a look at » http://www.apt-get.org/. One of the results found should be » Dotdeb. This unofficial repository is maintained by » Guillaume Plessis and contains Debian packages of the most recent versions of PHP 4 and PHP 5. To use it, just add the to following two lines to your /etc/apt/sources.lists and run apt-get update :

Příklad 4.7. The two Dotdeb related lines

deb http://packages.dotdeb.org stable all
deb-src http://packages.dotdeb.org stable all

The last thing to consider is whether your list of packages is up to date. If you have not updated it recently, you need to run apt-get update before anything else. This way, you will be using the most recent stable version of the Apache and PHP packages.

Now that everything is in place, you can use the following example to install Apache and PHP:

Příklad 4.8. Debian Install Example with Apache 1.3

# apt-get install libapache-mod-php4

APT will automatically install the PHP 4 module for Apache 1.3, and all its dependencies and then activate it. If you're not asked to restart Apache during the install process, you'll have to do it manually :

Příklad 4.9. Stopping and starting Apache once PHP 4 is installed

# /etc/init.d/apache stop
# /etc/init.d/apache start

Better control on configuration

In the last section, PHP was installed with only core modules. This may not be what you want and you will soon discover that you need more activated modules, like MySQL, cURL, GD, etc.

When you compile PHP from source yourself, you need to activate modules via the configure command. With APT, you just have to install additional packages. They're all named 'php4-*' (or 'php5-*' if you installed PHP 5 from a third party repository).

Příklad 4.10. Getting the list of PHP additional packages

# dpkg -l 'php4-*'

As you can see from the last output, there's a lot of PHP modules that you can install (excluding the php4-cgi, php4-cli or php4-pear special packages). Look at them closely and choose what you need. If you choose a module and you do not have the proper libraries, APT will automatically install all the dependencies for you.

If you choose to add the MySQL, cURL and GD support to PHP the command will look something like this:

Příklad 4.11. Install PHP with MySQL, cURL and GD

# apt-get install php4-mysql php4-curl php4-gd

APT will automatically add the appropriate lines to your different php.ini (/etc/php4/apache/php.ini, /etc/php4/cgi/php.ini, etc).

Příklad 4.12. These lines activate MySQL, cURL and GD into PHP

extension=mysql.so
extension=curl.so
extension=gd.so

You'll only have to stop/start Apache as previously to activate the modules.

Common Problems

  • If you see the PHP source instead of the result the script should produce, APT has probably not included /etc/apache/conf.d/php4 in your Apache 1.3 configuration. Please ensure that the following line is present in your /etc/apache/httpd.conf file then stop/start Apache:

    Příklad 4.13. This line activates PHP 4 into Apache

# Include /etc/apache/conf.d/

  • If you installed an additional module and if its functions are not available in your scripts, please ensure that the appropriate line is present in your php.ini, as seen before. APT may fail during the installation of the additional module, due to a confusing debconf configuration.
Předcházející | Nahoru | Další
Solaris specific installation tips | Domů | 5. Installation on Mac OS X


fhttpd related notes

To build PHP as an fhttpd module, answer "yes" to "Build as an fhttpd module?" (the --with-fhttpd=DIR option to configure) and specify the fhttpd source base directory. The default directory is /usr/local/src/fhttpd. If you are running fhttpd, building PHP as a module will give better performance, more control and remote execution capability.

Poznámka: Support for fhttpd is no longer available as of PHP 4.3.0.

Předcházející | Nahoru | Další
Caudium | Domů | Sun, iPlanet and Netscape servers on Sun Solaris


HP-UX specific installation notes

This section contains notes and hints specific to installing PHP on HP-UX systems.

There are two main options for installing PHP on HP-UX systems. Either compile it, or install a pre-compiled binary.

Official pre-compiled packages are located here: » http://software.hp.com/

Until this manual section is rewritten, the documentation about compiling PHP (and related extensions) on HP-UX systems has been removed. For now, consider reading the following external resource: » Building Apache and PHP on HP-UX 11.11

Předcházející | Nahoru | Další
CGI and command line setups | Domů | OpenBSD installation notes


OpenBSD installation notes

This section contains notes and hints specific to installing PHP on » OpenBSD 3.6.

Using Binary Packages

Using binary packages to install PHP on OpenBSD is the recommended and simplest method. The core package has been separated from the various modules, and each can be installed and removed independently from the others. The files you need can be found on your OpenBSD CD or on the FTP site.

The main package you need to install is php4-core-4.3.8.tgz, which contains the basic engine (plus gettext and iconv). Next, take a look at the module packages, such as php4-mysql-4.3.8.tgz or php4-imap-4.3.8.tgz. You need to use the phpxs command to activate and deactivate these modules in your php.ini.

Příklad 4.6. OpenBSD Package Install Example

# pkg_add php4-core-4.3.8.tgz
# /usr/local/sbin/phpxs -s
# cp /usr/local/share/doc/php4/php.ini-recommended /var/www/conf/php.ini
  (add in mysql)
# pkg_add php4-mysql-4.3.8.tgz
# /usr/local/sbin/phpxs -a mysql
  (add in imap)
# pkg_add php4-imap-4.3.8.tgz
# /usr/local/sbin/phpxs -a imap
  (remove mysql as a test)
# pkg_delete php4-mysql-4.3.8
# /usr/local/sbin/phpxs -r mysql
  (install the PEAR libraries)
# pkg_add php4-pear-4.3.8.tgz

Read the » packages(7) manual page for more information about binary packages on OpenBSD.

Using Ports

You can also compile up PHP from source using the » ports tree. However, this is only recommended for users familiar with OpenBSD. The PHP 4 port is split into two sub-directories: core and extensions. The extensions directory generates sub-packages for all of the supported PHP modules. If you find you do not want to create some of these modules, use the no_* FLAVOR. For example, to skip building the imap module, set the FLAVOR to no_imap.

Common Problems

  • The default install of Apache runs inside a » chroot(2) jail, which will restrict PHP scripts to accessing files under /var/www. You will therefore need to create a /var/www/tmp directory for PHP session files to be stored, or use an alternative session backend. In addition, database sockets need to be placed inside the jail or listen on the localhost interface. If you use network functions, some files from /etc such as /etc/resolv.conf and /etc/services will need to be moved into /var/www/etc. The OpenBSD PEAR package automatically installs into the correct chroot directories, so no special modification is needed there. More information on the OpenBSD Apache is available in the » OpenBSD FAQ.
  • The OpenBSD 3.6 package for the » gd extension requires XFree86 to be installed. If you do not wish to use some of the font features that require X11, install the php4-gd-4.3.8-no_x11.tgz package instead.

Older Releases

Older releases of OpenBSD used the FLAVORS system to compile up a statically linked PHP. Since it is hard to generate binary packages using this method, it is now deprecated. You can still use the old stable ports trees if you wish, but they are unsupported by the OpenBSD team. If you have any comments about this, the current maintainer for the port is Anil Madhavapeddy (avsm at openbsd dot org).

Předcházející | Nahoru | Další
HP-UX specific installation notes | Domů | Solaris specific installation tips


Solaris specific installation tips

This section contains notes and hints specific to installing PHP on Solaris systems.

Required software

Solaris installs often lack C compilers and their related tools. Read this FAQ for information on why using GNU versions for some of these tools is necessary. The required software is as follows:

  • gcc (recommended, other C compilers may work)
  • make
  • flex
  • bison
  • m4
  • autoconf
  • automake
  • perl
  • gzip
  • tar
  • GNU sed
In addition, you will need to install (and possibly compile) any additional software specific to your configuration, such as Oracle or MySQL.

Using Packages

You can simplify the Solaris install process by using pkgadd to install most of your needed components.

Předcházející | Nahoru | Další
OpenBSD installation notes | Domů | Debian GNU/Linux installation notes


Sun, iPlanet and Netscape servers on Sun Solaris

This section contains notes and hints specific to Sun Java System Web Server, Sun ONE Web Server, iPlanet and Netscape server installs of PHP on Sun Solaris.

From PHP 4.3.3 on you can use PHP scripts with the NSAPI module to generate custom directory listings and error pages. Additional functions for Apache compatibility are also available. For support in current web servers read the note about subrequests.

You can find more information about setting up PHP for the Netscape Enterprise Server (NES) here: » http://benoit.noss.free.fr/php/install-php4.html

To build PHP with Sun JSWS/Sun ONE WS/iPlanet/Netscape web servers, enter the proper install directory for the --with-nsapi=[DIR] option. The default directory is usually /opt/netscape/suitespot/. Please also read /php-xxx-version/sapi/nsapi/nsapi-readme.txt.

  1. Install the following packages from » http://www.sunfreeware.com/ or another download site:

    autoconf-2.13
    automake-1.4
    bison-1_25-sol26-sparc-local
    flex-2_5_4a-sol26-sparc-local
    gcc-2_95_2-sol26-sparc-local
    gzip-1.2.4-sol26-sparc-local
    m4-1_4-sol26-sparc-local
    make-3_76_1-sol26-sparc-local
    mysql-3.23.24-beta (if you want mysql support)
    perl-5_005_03-sol26-sparc-local
    tar-1.13 (GNU tar)

  2. Make sure your path includes the proper directories PATH=.:/usr/local/bin:/usr/sbin:/usr/bin:/usr/ccs/bin and make it available to your system export PATH.
  3. gunzip php-x.x.x.tar.gz (if you have a .gz dist, otherwise go to 4).
  4. tar xvf php-x.x.x.tar
  5. Change to your extracted PHP directory: cd ../php-x.x.x

  6. For the following step, make sure /opt/netscape/suitespot/ is where your netscape server is installed. Otherwise, change to the correct path and run:

./configure --with-mysql=/usr/local/mysql \
--with-nsapi=/opt/netscape/suitespot/ \
--enable-libgcc

  7. Run make followed by make install.

After performing the base install and reading the appropriate readme file, you may need to perform some additional configuration steps.

Configuration Instructions for Sun/iPlanet/Netscape.

Firstly you may need to add some paths to the LD_LIBRARY_PATH environment for the server to find all the shared libs. This can best done in the start script for your web server. The start script is often located in: /path/to/server/https-servername/start. You may also need to edit the configuration files that are located in: /path/to/server/https-servername/config/.

  1. Add the following line to mime.types (you can do that by the administration server):

type=magnus-internal/x-httpd-php exts=php

  2. Edit magnus.conf (for servers >= 6) or obj.conf (for servers < 6) and add the following, shlib will vary depending on your system, it will be something like /opt/netscape/suitespot/bin/libphp4.so. You should place the following lines after mime types init.

Init fn="load-modules" funcs="php4_init,php4_execute,php4_auth_trans" shlib="/opt/netscape/suitespot/bin/libphp4.so"
Init fn="php4_init" LateInit="yes" errorString="Failed to initialize PHP!" [php_ini="/path/to/php.ini"]

    (PHP >= 4.3.3) The php_ini parameter is optional but with it you can place your php.ini in your web server config directory.

  3. Configure the default object in obj.conf (for virtual server classes [version 6.0+] in their vserver.obj.conf):

<Object name="default">
.
.
.
.#NOTE this next line should happen after all 'ObjectType' and before all 'AddLog' lines
Service fn="php4_execute" type="magnus-internal/x-httpd-php" [inikey=value inikey=value ...]
.
.
</Object>

    (PHP >= 4.3.3) As additional parameters you can add some special php.ini-values, for example you can set a docroot="/path/to/docroot" specific to the context php4_execute is called. For boolean ini-keys please use 0/1 as value, not "On","Off",... (this will not work correctly), e.g. zlib.output_compression=1 instead of zlib.output_compression="On"

  4. This is only needed if you want to configure a directory that only consists of PHP scripts (same like a cgi-bin directory):

<Object name="x-httpd-php">
ObjectType fn="force-type" type="magnus-internal/x-httpd-php"
Service fn=php4_execute [inikey=value inikey=value ...]
</Object>

    After that you can configure a directory in the Administration server and assign it the style x-httpd-php. All files in it will get executed as PHP. This is nice to hide PHP usage by renaming files to .html.

  5. Setup of authentication: PHP authentication cannot be used with any other authentication. ALL AUTHENTICATION IS PASSED TO YOUR PHP SCRIPT. To configure PHP Authentication for the entire server, add the following line to your default object:

<Object name="default">
AuthTrans fn=php4_auth_trans
.
.
.
</Object>

  6. To use PHP Authentication on a single directory, add the following:

<Object ppath="d:\path\to\authenticated\dir\*">
AuthTrans fn=php4_auth_trans
</Object>

Poznámka: The stacksize that PHP uses depends on the configuration of the web server. If you get crashes with very large PHP scripts, it is recommended to raise it with the Admin Server (in the section "MAGNUS EDITOR").

CGI environment and recommended modifications in php.ini

Important when writing PHP scripts is the fact that Sun JSWS/Sun ONE WS/iPlanet/Netscape is a multithreaded web server. Because of that all requests are running in the same process space (the space of the web server itself) and this space has only one environment. If you want to get CGI variables like PATH_INFO, HTTP_HOST etc. it is not the correct way to try this in the old PHP 3.x way with getenv() or a similar way (register globals to environment, $_ENV). You would only get the environment of the running web server without any valid CGI variables!

Poznámka: Why are there (invalid) CGI variables in the environment?

Answer: This is because you started the web server process from the admin server which runs the startup script of the web server, you wanted to start, as a CGI script (a CGI script inside of the admin server!). This is why the environment of the started web server has some CGI environment variables in it. You can test this by starting the web server not from the administration server. Use the command line as root user and start it manually - you will see there are no CGI-like environment variables.

Simply change your scripts to get CGI variables in the correct way for PHP 4.x by using the superglobal $_SERVER. If you have older scripts which use $HTTP_HOST, etc., you should turn on register_globals in php.ini and change the variable order too (important: remove "E" from it, because you do not need the environment here):

variables_order = "GPCS"
register_globals = On

Special use for error pages or self-made directory listings (PHP >= 4.3.3)

You can use PHP to generate the error pages for "404 Not Found" or similar. Add the following line to the object in obj.conf for every error page you want to overwrite:

Error fn="php4_execute" code=XXX script="/path/to/script.php" [inikey=value inikey=value...]
where XXX is the HTTP error code. Please delete any other Error directives which could interfere with yours. If you want to place a page for all errors that could exist, leave the code parameter out. Your script can get the HTTP status code with $_SERVER['ERROR_TYPE'].

Another possibility is to generate self-made directory listings. Just create a PHP script which displays a directory listing and replace the corresponding default Service line for type="magnus-internal/directory" in obj.conf with the following:

Service fn="php4_execute" type="magnus-internal/directory" script="/path/to/script.php" [inikey=value inikey=value...]
For both error and directory listing pages the original URI and translated URI are in the variables $_SERVER['PATH_INFO'] and $_SERVER['PATH_TRANSLATED'].

Note about nsapi_virtual() and subrequests (PHP >= 4.3.3)

The NSAPI module now supports the nsapi_virtual() function (alias: virtual()) to make subrequests on the web server and insert the result in the web page. This function uses some undocumented features from the NSAPI library. On Unix the module automatically looks for the needed functions and uses them if available. If not, nsapi_virtual() is disabled.

Poznámka: But be warned: Support for nsapi_virtual() is EXPERIMENTAL!!!

Předcházející | Nahoru | Další
fhttpd related notes | Domů | CGI and command line setups


Kapitola 6. Installation on Windows systems

Obsah

Windows Installer (PHP 5.2 and later)
Windows Installer (PHP 5.1.0 and earlier)
Manual Installation Steps
ActiveScript
Microsoft IIS / PWS
Apache 1.3.x on Microsoft Windows
Apache 2.0.x on Microsoft Windows
Sun, iPlanet and Netscape servers on Microsoft Windows
OmniHTTPd Server
Sambar Server on Microsoft Windows
Xitami on Microsoft Windows
Building from source
Installation of extensions on Windows

This section applies to Windows 98/Me and Windows NT/2000/XP/2003. PHP will not work on 16 bit platforms such as Windows 3.1 and sometimes we refer to the supported Windows platforms as Win32. Windows 95 is no longer supported as of PHP 4.3.0.

There are two main ways to install PHP for Windows: either manually or by using the installer.

If you have Microsoft Visual Studio, you can also build PHP from the original source code.

Once you have PHP installed on your Windows system, you may also want to load various extensions for added functionality.

Varování

There are several all-in-one installers over the Internet, but none of those are endorsed by PHP.net, as we believe that using one of the official windows packages from » http://www.php.net/downloads.php is the best choice to have your system secure and optimised.

Windows Installer (PHP 5.2 and later)

The Windows PHP installer for later versions of PHP is built using MSI technology using the Wix Toolkit (» http://wix.sourceforge.net/). It will install and configure PHP and all the built-in and PECL extensions, as well as configure many of the popular web servers such as IIS, Apache, and Xitami.

First, install your selected HTTP (web) server on your system, and make sure that it works. Then proceed with one of the following install types.

Normal Install

Run the MSI installer and follow the instructions provided by the installation wizard. You will be prompted to select the Web Server you wish to configure first, along with any configuration details needed.

You will then be prompted to select which features and extensions you wish to install and enable. By selecting "Will be installed on local hard drive" in the drop-down menu for each item you can trigger whether to install the feature or not. By selecting "Entire feature will be installed on local hard drive", you will be able to install all sub-features of the included feature ( for example by selecting this options for the feature "PDO" you will install all PDO Drivers ).

Varování

It is not recommended to install all extensions by default, since many other them require dependencies from outside PHP in order to function properly. Instead, use the Installation Repair Mode that can be triggered thru the 'Add/Remove Programs' control panel to enable or disable extensions and features after installation.

The installer then sets up PHP to be used in Windows and the php.ini file, and configures certain web servers to use PHP. The installer will currently configure IIS, Apache, Xitami, and Sambar Server; if you are using a different web server you'll need to configure it manually.

Silent Install

The installer also supports a silent mode, which is helpful for Systems Administrators to deploy PHP easily. To use silent mode:

msiexec.exe /i php-VERSION-win32-install.msi /q

You can control the install directory by passing it as a parameter to the install. For example, to install to e:\php:

msiexec.exe /i php-VERSION-win32-install.msi /q INSTALLDIR=e:\php
You can also use the same syntax to specify the Apache Configuration Directory (APACHEDIR), the Sambar Server directory (SAMBARDIR), and the Xitami Server directory (XITAMIDIR).

You can also specify what features to install. For example, to install the mysqli extension and the CGI executable:

msiexec.exe /i php-VERSION-win32-install.msi /q ADDLOCAL=cgi,ext_php_mysqli

The current list of Features to install is as follows:

MainExecutable - php.exe executable
ScriptExecutable - php-win.exe executable
ext_php_* - the various extensions ( for example: ext_php_mysql for MySQL )
apache13 - Apache 1.3 module
apache20 - Apache 2.0 module
apache22 - Apache 2,2 module
apacheCGI - Apache CGI executable
iis4ISAPI - IIS ISAPI module
iis4CGI - IIS CGI executable
NSAPI - Sun/iPlanet/Netscape server module
Xitami - Xitami CGI executable
Sambar - Sambar Server ISAPI module
CGI - php-cgi.exe executable
PEAR - PEAR installer
Manual - PHP Manual in CHM Format

For more information on installing MSI installers from the command line, visit » http://msdn.microsoft.com/library/en-us/msi/setup/command_line_options.asp

Upgrading PHP with the Install

To upgrade, run the installer either graphically or from the command line as normal. The installer will read your current install options, remove your old installation, and reinstall PHP with the same options as before. It is recommended that you use this method of keeping PHP updated instead of manually replacing the files in the installation directory.

Předcházející | Nahoru | Další
Compiling for MacOS X Client | Domů | Windows Installer (PHP 5.1.0 and earlier)


ActiveScript

This section contains notes specific to the ActiveScript installation.

ActiveScript is a Windows only SAPI that enables you to use PHP script in any ActiveScript compliant host, like Windows Script Host, ASP/ASP.NET, Windows Script Components or Microsoft Scriptlet control.

As of PHP 5.0.1, ActiveScript has been moved to the » PECL repository. Tuto DLL knihovnu pro rozšíření PECL můžete stahovat ze stránky » PHP Downloads nebo z » http://snaps.php.net/.

Poznámka: You should read the manual installation steps first!

After installing PHP, you should download the ActiveScript DLL (php5activescript.dll) and place it in the main PHP folder (e.g. C:\php).

After having all the files needed, you must register the DLL on your system. To achieve this, open a Command Prompt window (located in the Start Menu). Then go to your PHP directory by typing something like cd C:\php. To register the DLL just type regsvr32 php5activescript.dll.

To test if ActiveScript is working, create a new file, named test.wsf (the extension is very important) and type:

<job id="test">

 <script language="PHPScript">
  $WScript->Echo("Hello World!");
 </script>

</job>
Save and double-click on the file. If you receive a little window saying "Hello World!" you're done.

Poznámka: In PHP 4, the engine was named 'ActivePHP', so if you are using PHP 4, you should replace 'PHPScript' with 'ActivePHP' in the above example.

Poznámka: ActiveScript doesn't use the default php.ini file. Instead, it will look only in the same directory as the .exe that caused it to load. You should create php-activescript.ini and place it in that folder, if you wish to load extensions, etc.

Předcházející | Nahoru | Další
Manual Installation Steps | Domů | Microsoft IIS / PWS


Apache 1.3.x on Microsoft Windows

This section contains notes and hints specific to Apache 1.3.x installs of PHP on Microsoft Windows systems. There are also instructions and notes for Apache 2 on a separate page.

Poznámka: Please read the manual installation steps first!

There are two ways to set up PHP to work with Apache 1.3.x on Windows. One is to use the CGI binary (php.exe for PHP 4 and php-cgi.exe for PHP 5), the other is to use the Apache Module DLL. In either case you need to edit your httpd.conf to configure Apache to work with PHP, and then restart the server.

It is worth noting here that now the SAPI module has been made more stable under Windows, we recommend it's use above the CGI binary, since it is more transparent and secure.

Although there can be a few variations of configuring PHP under Apache, these are simple enough to be used by the newcomer. Please consult the Apache Documentation for further configuration directives.

After changing the configuration file, remember to restart the server, for example, NET STOP APACHE followed by NET START APACHE, if you run Apache as a Windows Service, or use your regular shortcuts.

Poznámka: Nezapomeňte, že když přidáváte cesty do konfiguračních souborů Apache na Windows, všechna zpětná lomítka, jako c:\directory\file.ext, se musí převést na dopředná, jako c:/directory/file.ext. Pro adresáře může být potřeba také ukončovací lomítko.

Installing as an Apache module

You should add the following lines to your Apache httpd.conf file:

Příklad 6.3. PHP as an Apache 1.3.x module

This assumes PHP is installed to c:\php. Adjust the path if this is not the case.

For PHP 4:

# Add to the end of the LoadModule section
# Don't forget to copy this file from the sapi directory!
LoadModule php4_module "C:/php/php4apache.dll"

# Add to the end of the AddModule section
AddModule mod_php4.c

For PHP 5:

# Add to the end of the LoadModule section
LoadModule php5_module "C:/php/php5apache.dll"

# Add to the end of the AddModule section
AddModule mod_php5.c

For both:

# Add this line inside the <IfModule mod_mime.c> conditional brace
AddType application/x-httpd-php .php

# For syntax highlighted .phps files, also add
AddType application/x-httpd-php-source .phps

Installing as a CGI binary

If you unzipped the PHP package to C:\php\ as described in the Manual Installation Steps section, you need to insert these lines to your Apache configuration file to set up the CGI binary:

Příklad 6.4. PHP and Apache 1.3.x as CGI

ScriptAlias /php/ "c:/php/"
AddType application/x-httpd-php .php

# For PHP 4
Action application/x-httpd-php "/php/php.exe"

# For PHP 5
Action application/x-httpd-php "/php/php-cgi.exe"

# specify the directory where php.ini is
SetEnv PHPRC C:/php

Note that the second line in the list above can be found in the actual versions of httpd.conf, but it is commented out. Remember also to substitute the c:/php/ for your actual path to PHP.

Varování

Při používání konfigurace s CGI je váš server otevřen mnoha možným útokům. Přečtěte si prosím naši sekci bezpečnosti CGI, abyste se naučili bránit se proti takovým útokům.

If you would like to present PHP source files syntax highlighted, there is no such convenient option as with the module version of PHP. If you chose to configure Apache to use PHP as a CGI binary, you will need to use the highlight_file() function. To do this simply create a PHP script file and add this code: <?php highlight_file('some_php_script.php'); ?>.

Předcházející | Nahoru | Další
Microsoft IIS / PWS | Domů | Apache 2.0.x on Microsoft Windows


Apache 2.0.x on Microsoft Windows

This section contains notes and hints specific to Apache 2.0.x installs of PHP on Microsoft Windows systems. We also have instructions and notes for Apache 1.3.x users on a separate page.

Poznámka: You should read the manual installation steps first!

Apache 2.2.x Support: Users of Apache 2.2.x may use the documentation below except the appropriate DLL file is named php5apache2_2.dll and it only exists as of PHP 5.2.0. See also » http://snaps.php.net/

Varování

Nedoporučujeme používat vláknovou verzi MPM s Apache 2 v produkčním prostředí. Místo toho použijte MPM s preforkem procesů, anebo použijte Apache 1. Víc informací o tom, proč, si můžete přečíst v související FAQ části nazvané Apache2 s vláknovým MPM

You are highly encouraged to take a look at the » Apache Documentation to get a basic understanding of the Apache 2.0.x Server. Also consider to read the » Windows specific notes for Apache 2.0.x before reading on here.

PHP and Apache 2.0.x compatibility notes: The following versions of PHP are known to work with the most recent version of Apache 2.0.x:

  • PHP 4.3.0 or later available at » http://www.php.net/downloads.php.
  • the latest stable development version. Get the source code » http://snaps.php.net/php5-latest.tar.gz or download binaries for Windows » http://snaps.php.net/win32/php5-win32-latest.zip.
  • a prerelease version downloadable from » http://qa.php.net/.
  • you have always the option to obtain PHP through » anonymous CVS.
These versions of PHP are compatible to Apache 2.0.40 and later.

Apache 2.0 SAPI-support started with PHP 4.2.0. PHP 4.2.3 works with Apache 2.0.39, don't use any other version of Apache with PHP 4.2.3. However, the recommended setup is to use PHP 4.3.0 or later with the most recent version of Apache2.

All mentioned versions of PHP will work still with Apache 1.3.x.

Varování

Apache 2.0.x is designed to run on Windows NT 4.0, Windows 2000 or Windows XP. At this time, support for Windows 9x is incomplete. Apache 2.0.x is not expected to work on those platforms at this time.

Download the most recent version of » Apache 2.0.x and a fitting PHP version. Follow the Manual Installation Steps and come back to go on with the integration of PHP and Apache.

There are two ways to set up PHP to work with Apache 2.0.x on Windows. One is to use the CGI binary the other is to use the Apache module DLL. In either case you need to edit your httpd.conf to configure Apache to work with PHP and then restart the server.

Poznámka: Nezapomeňte, že když přidáváte cesty do konfiguračních souborů Apache na Windows, všechna zpětná lomítka, jako c:\directory\file.ext, se musí převést na dopředná, jako c:/directory/file.ext. Pro adresáře může být potřeba také ukončovací lomítko.

Installing as a CGI binary

You need to insert these three lines to your Apache httpd.conf configuration file to set up the CGI binary:

Příklad 6.5. PHP and Apache 2.0 as CGI

ScriptAlias /php/ "c:/php/"
AddType application/x-httpd-php .php

# For PHP 4
Action application/x-httpd-php "/php/php.exe"

# For PHP 5
Action application/x-httpd-php "/php/php-cgi.exe"

Varování

Při používání konfigurace s CGI je váš server otevřen mnoha možným útokům. Přečtěte si prosím naši sekci bezpečnosti CGI, abyste se naučili bránit se proti takovým útokům.

Installing as an Apache module

You need to insert these two lines to your Apache httpd.conf configuration file to set up the PHP module for Apache 2.0:

Příklad 6.6. PHP and Apache 2.0 as Module

# For PHP 4 do something like this:
LoadModule php4_module "c:/php/php4apache2.dll"
# Don't forget to copy the php4apache2.dll file from the sapi directory!
AddType application/x-httpd-php .php

# For PHP 5 do something like this:
LoadModule php5_module "c:/php/php5apache2.dll"
AddType application/x-httpd-php .php

# configure the path to php.ini
PHPIniDir "C:/php"

Poznámka: Remember to substitute your actual path to PHP for the c:/php/ in the above examples. Take care to use either php4apache2.dll or php5apache2.dll in your LoadModule directive and not php4apache.dll or php5apache.dll as the latter ones are designed to run with Apache 1.3.x.

Poznámka: If you want to use content negotiation, read related FAQ.

Varování

Don't mix up your installation with DLL files from different PHP versions. You have the only choice to use the DLL's and extensions that ship with your downloaded PHP version.

Předcházející | Nahoru | Další
Apache 1.3.x on Microsoft Windows | Domů | Sun, iPlanet and Netscape servers on Microsoft Windows


Building from source

This chapter teaches how to compile PHP from sources on windows, using Microsoft's tools. To compile PHP with cygwin, please refer to 4 – „Installation on Unix systems“.

Build Environment

To compile and build PHP you need a Microsoft Development Environment. The following environments are supported:

  • Microsoft Visual C++ 6.0 (official)
  • Microsoft Visual C++ .NET
  • Microsoft Visual C++ 2005, Windows Platform SDK and .NET Framework SDK (current)

While VC6 (Microsoft Visual C++ 6.0) is used to perform official Windows builds, it can no longer be downloaded from Microsoft's website. New users seeking to build PHP for free must use Microsoft Visual C++ 2005 Express Edition and its auxiliary components.

Setting up Microsoft Visual C++ 2005 Express

Poznámka: Combined, these components are very large and will require over one gigabyte of disk space.

Setting up Microsoft Visual C++ 2005 Express is rather involved, and requires the installation of three separate packages and various compatibility changes. Be sure to keep track of the paths in which these programs are installed into. Download and install the following programs:

  • » Microsoft Visual C++ 2005 Express
  • » Microsoft Windows Server 2005 Platform SDK
  • » .NET Framework 2.0 Software Development Kit

There are a few post-installation steps:

  • » MSVC 2005 Express must be configured to use Windows Platform SDK. It is not necessary to perform step two, as PHP does not use the graphical user interface.
  • Windows Platform SDK contains a file named WinResrc.h usually in Include folder inside the SDK's installation directory. This needs to be copied and renamed to winres.h, the name PHP uses for the file.

Finally, when using MSVC 2005 Express from the command line, several environment variables must be set up. vsvars32.bat usually found in C:\Program Files\Microsoft Visual Studio 8\Common7\Tools (search for the file if otherwise) contains these declarations. The PATH, INCLUDE and LIB environment variables need the corresponding bin, include and lib directories of the two newly installed SDKs added to them.

Poznámka: The .NET SDK paths may already be present in the vsvars32.bat file, as this SDK installs itself into the same directory as Microsoft Visual C++ 2005 Express.

Libraries

To extract the downloaded files you will also need a ZIP extraction utility. Windows XP and newer already include this functionality built-in.

Before you get started, you have to download:

  • the win32 buildtools from the PHP site at » http://www.php.net/extra/win32build.zip.
  • the source code for the DNS name resolver used by PHP from » http://www.php.net/extra/bindlib_w32.zip. This is a replacement for the resolv.lib library included in win32build.zip.
  • If you plan to compile PHP as a Apache module you will also need the » Apache sources.

Finally, you are going to need the source to PHP itself. You can get the latest development version using » anonymous CVS, a » snapshot or the most recent released » source tarball.

Putting it all together

After downloading the required packages you have to extract them in a proper place:

  • Create a working directory where all files end up after extracting, e.g: C:\work.
  • Create the directory win32build under your working directory (C:\work) and unzip win32build.zip into it.
  • Create the directory bindlib_w32 under your working directory (C:\work) and unzip bindlib_w32.zip into it.
  • Extract the downloaded PHP source code into your working directory (C:\work).
  • Build the libraries you are going to need (or download the binaries if available) and place the headers and libs in the C:\work\win32build\include and C:\work\win32build\lib directories, respectively.
  • If you don't have cygwin installed with bison and flex, you also need to make the C:\work\win32build\bin directory available in the PATH, so that thoses tools can be found by the configure script.
Following this steps your directory structure looks like this:

+--C:\work
|  |
|  +--bindlib_w32
|  |  |
|  |  +--arpa
|  |  |
|  |  +--conf
|  |  |
|  |  +--...
|  |
|  +--php-5.x.x
|  |  |
|  |  +--build
|  |  |
|  |  +--...
|  |  |
|  |  +--win32
|  |  |
|  |  +--...
|  |
|  +--win32build
|  |  |
|  |  +--bin
|  |  |
|  |  +--include
|  |  |
|  |  +--lib

If you aren't using » Cygwin, you must also create the directories C:\usr\local\lib and then copy bison.simple from C:\work\win32build\bin to C:\usr\local\lib.

Poznámka: If you want to use PEAR and the comfortable command line installer, the CLI-SAPI is mandatory. For more information about PEAR and the installer read the documentation at the » PEAR website.

Build resolv.lib

You must build the resolv.lib library. Decide whether you want to have debug symbols available (bindlib - Win32 Debug) or not (bindlib - Win32 Release), but please remember the choice you made, because the debug build will only link with PHP when it is also built in debug mode. Build the appropriate configuration:

  • For GUI users, launch VC++, by double-clicking in C:\work\bindlib_w32\bindlib.dsw. Then select Build=>Rebuild All.

  • For command line users, make sure that you either have the C++ environment variables registered, or have run vcvars.bat, and then execute one of the following commands:

    • msdev bindlib.dsp /MAKE "bindlib - Win32 Debug"
    • msdev bindlib.dsp /MAKE "bindlib - Win32 Release"
At this point, you should have a usable resolv.lib in either your C:\work\bindlib_w32\Debug or Release subdirectories. Copy this file into your C:\work\win32build\lib directory over the file by the same name found in there.

Building PHP using the new build system [PHP >=5 only]

This chapter explains how to compile PHP >=5 using the new build system, which is CLI-based and very similar with the main PHP's Unix build system.

Poznámka: This build system isn't available in PHP 4. Please refer to „Building PHP using DSW files [PHP 4]“ instead.

Before starting, be sure you have read „Putting it all together“ and you have built all needed libraries, like » Libxml or » ICU (needed for PHP >= 6).

First you should open a Visual Studio Command Prompt, which should be available under the Start menu. A regular Command Prompt window shouldn't work, as probably it doesn't have the necessary environment variables set. Then type something like cd C:\work\php-5.x.x to enter in the PHP source dir. Now you are ready to start configuring PHP.

The second step is running the buildconf batch file to make the configure script, by scanning the folder for config.w32 files. By default this command will also search in the following directories: pecl; ..\pecl; pecl\rpc; ..\pecl\rpc. Since PHP 5.1.0, you can change this behaviour by using the --add-modules-dir argument (e.g. cscript /nologo win32/build/buildconf.js --add-modules-dir=../php-gtk2 --add-modules-dir=../pecl).

The third step is configuring. To view the list of the available configuration options type cscript /nologo configure.js --help. After choosing the options that you will enable/disable, type something like: cscript /nologo configure.js --disable-foo --enable-fun-ext. Using --enable-foo=shared will attempt to build the 'foo' extension as a shared, dynamically loadable module.

The last step is compiling. To achieve this just issue the command nmake. The generated files (e.g. .exe and .dll) will be placed in either Release_TS or Debug_TS directories (if built with Thread safety), or in the Release or Debug directories otherwise.

Optionally you may also run PHP's test suite, by typing nmake test. If you want to run just a specific test, you may use the 'TESTS' variable (e.g. nmake /D TESTS=ext/sqlite/tests test - will only run sqlite's tests). To delete the files that were created during the compilation, you can use the nmake clean command.

A very useful configure option to build snapshots is --enable-snapshot-build, which add a new compiling mode (nmake build-snap). This tries to build every extension available (as shared, by default), but it will ignore build errors in individual extensions or SAPI.

Building PHP using DSW files [PHP 4]

Compiling PHP using the DSW files isn't supported as of PHP 5, as a much more flexible system was made available. Anyway, you can still use them, but keep in mind that they are not maintained very often, so you can have compiling problems. To compile PHP 4 for windows, this is the only available way though.

Configure MVC ++

The first step is to configure MVC++ to prepare for compiling. Launch Microsoft Visual C++, and from the menu select Tools => Options. In the dialog, select the directories tab. Sequentially change the dropdown to Executables, Includes, and Library files. Your entries should look like this:

  • Executable files: C:\work\win32build\bin, Cygwin users: C:\cygwin\bin
  • Include files: C:\work\win32build\include
  • Library files: C:\work\win32build\lib

Compiling

The best way to get started is to build the CGI version:

  • For GUI users, launch VC++, and then select File => Open Workspace and select C:\work\php-4.x.x\win32\php4ts.dsw. Then select Build=>Set Active Configuration and select the desired configuration, either php4ts - Win32 Debug_TS or php4ts - Win32 Release_TS. Finally select Build=>Rebuild All.

  • For command line users, make sure that you either have the C++ environment variables registered, or have run vcvars.bat, and then execute one of the following commands from the C:\work\php-4.x.x\win32 directory:

    • msdev php4ts.dsp /MAKE "php4ts - Win32 Debug_TS"
    • msdev php4ts.dsp /MAKE "php4ts - Win32 Release_TS"
    • At this point, you should have a usable php.exe in either your C:\work\php-4.x.x\Debug_TS or Release_TS subdirectories.

It is possible to do minor customization to the build process by editing the main/config.win32.h file. For example you can change the default location of php.ini, the built-in extensions, and the default location for your extensions.

Next you may want to build the CLI version which is designed to use PHP from the command line. The steps are the same as for building the CGI version, except you have to select the php4ts_cli - Win32 Debug_TS or php4ts_cli - Win32 Release_TS project file. After a successful compiling run you will find the php.exe in either the directory Release_TS\cli\ or Debug_TS\cli\.

In order to build the SAPI module (php4isapi.dll) for integrating PHP with Microsoft IIS, set your active configuration to php4isapi-whatever-config and build the desired dll.

Předcházející | Nahoru | Další
Xitami on Microsoft Windows | Domů | Installation of extensions on Windows


Installation of extensions on Windows

After installing PHP and a web server on Windows, you will probably want to install some extensions for added functionality. You can choose which extensions you would like to load when PHP starts by modifying your php.ini. You can also load a module dynamically in your script using dl().

The DLLs for PHP extensions are prefixed with php_.

Many extensions are built into the Windows version of PHP. This means additional DLL files, and the extension directive, are not used to load these extensions. The Windows PHP Extensions table lists extensions that require, or used to require, additional PHP DLL files. Here's a list of built in extensions:

In PHP 4 (updated PHP 4.3.11): BCMath, Caledar, COM, Ctype, FTP, MySQL, ODBC, Overload, PCRE, Session, Tokenizer, WDDX, XML, a Zlib

In PHP 5 (updated PHP 5.0.4), the following changes exist. Built in: DOM, LibXML, Iconv, SimpleXML, SPL, a SQLite. And the following are no longer built in: MySQL and Overload.

The default location PHP searches for extensions is C:\php4\extensions in PHP 4 and C:\php5 in PHP 5. To change this setting to reflect your setup of PHP edit your php.ini file:

  • You will need to change the extension_dir setting to point to the directory where your extensions lives, or where you have placed your php_*.dll files. For example:

extension_dir = C:\php\extensions

  • Enable the extension(s) in php.ini you want to use by uncommenting the extension=php_*.dll lines in php.ini. This is done by deleting the leading ; from the extension you want to load.

    Příklad 6.8. Enable Bzip2 extension for PHP-Windows

// change the following line from ...
;extension=php_bz2.dll

// ... to
extension=php_bz2.dll

  • Some of the extensions need extra DLLs to work. Couple of them can be found in the distribution package, in the C:\php\dlls\ folder in PHP 4 or in the main folder in PHP 5, but some, for example Oracle (php_oci8.dll) require DLLs which are not bundled with the distribution package. If you are installing PHP 4, copy the bundled DLLs from C:\php\dlls folder to the main C:\php folder. Don't forget to include C:\php in the system PATH (this process is explained in a separate FAQ entry).

  • Some of these DLLs are not bundled with the PHP distribution. See each extensions documentation page for details. Also, read the manual section titled Installation of PECL extensions for details on PECL. An increasingly large number of PHP extensions are found in PECL, and these extensions require a separate download.

Poznámka: If you are running a server module version of PHP remember to restart your web server to reflect your changes to php.ini.

The following table describes some of the extensions available and required additional dlls.

Tabulka 6.1. PHP Extensions

Extension | Description | Notes
php_bz2.dll | bzip2 compression functions | None
php_calendar.dll | Calendar conversion functions | Built in since PHP 4.0.3
php_cpdf.dll | ClibPDF functions | None
php_crack.dll | Crack functions | None
php_ctype.dll | ctype family functions | Built in since PHP 4.3.0
php_curl.dll | CURL, Client URL library functions | Requires: libeay32.dll, ssleay32.dll (bundled)
php_cybercash.dll | Cybercash payment functions | PHP <= 4.2.0
php_db.dll | DBM functions | Deprecated. Use DBA instead (php_dba.dll)
php_dba.dll | DBA: DataBase (dbm-style) Abstraction layer functions | None
php_dbase.dll | dBase functions | None
php_dbx.dll | dbx functions |
php_domxml.dll | DOM XML functions | PHP <= 4.2.0 requires: libxml2.dll (bundled) PHP >= 4.3.0 requires: iconv.dll (bundled)
php_dotnet.dll | .NET functions | PHP <= 4.1.1
php_exif.dll | EXIF functions | php_mbstring.dll. And, php_exif.dll must be loaded after php_mbstring.dll in php.ini.
php_fbsql.dll | FrontBase functions | PHP <= 4.2.0
php_fdf.dll | FDF: Forms Data Format functions. | Requires: fdftk.dll (bundled)
php_filepro.dll | filePro functions | Read-only access
php_ftp.dll | FTP functions | Built-in since PHP 4.0.3
php_gd.dll | GD library image functions | Removed in PHP 4.3.2. Also note that truecolor functions are not available in GD1, instead, use php_gd2.dll.
php_gd2.dll | GD library image functions | GD2
php_gettext.dll | Gettext functions | PHP <= 4.2.0 requires gnu_gettext.dll (bundled), PHP >= 4.2.3 requires libintl-1.dll, iconv.dll (bundled).
php_hyperwave.dll | HyperWave functions | None
php_iconv.dll | ICONV characterset conversion | Requires: iconv-1.3.dll (bundled), PHP >=4.2.1 iconv.dll
php_ifx.dll | Informix functions | Requires: Informix libraries
php_iisfunc.dll | IIS management functions | None
php_imap.dll | IMAP POP3 and NNTP functions | None
php_ingres.dll | Ingres II functions | Requires: Ingres II libraries
php_interbase.dll | InterBase functions | Requires: gds32.dll (bundled)
php_java.dll | Java functions | PHP <= 4.0.6 requires: jvm.dll (bundled)
php_ldap.dll | LDAP functions | PHP <= 4.2.0 requires libsasl.dll (bundled), PHP >= 4.3.0 requires libeay32.dll, ssleay32.dll (bundled)
php_mbstring.dll | Multi-Byte String functions | None
php_mcrypt.dll | Mcrypt Encryption functions | Requires: libmcrypt.dll
php_mhash.dll | Mhash functions | PHP >= 4.3.0 requires: libmhash.dll (bundled)
php_mime_magic.dll | Mimetype functions | Requires: magic.mime (bundled)
php_ming.dll | Ming functions for Flash | None
php_msql.dll | mSQL functions | Requires: msql.dll (bundled)
php_mssql.dll | MSSQL functions | Requires: ntwdblib.dll (bundled)
php_mysql.dll | MySQL functions | PHP >= 5.0.0, requires libmysql.dll (bundled)
php_mysqli.dll | MySQLi functions | PHP >= 5.0.0, requires libmysql.dll (libmysqli.dll in PHP <= 5.0.2) (bundled)
php_oci8.dll | Oracle 8 functions | Requires: Oracle 8.1+ client libraries
php_openssl.dll | OpenSSL functions | Requires: libeay32.dll (bundled)
php_oracle.dll | Oracle functions | Requires: Oracle 7 client libraries
php_overload.dll | Object overloading functions | Built in since PHP 4.3.0
php_pdf.dll | PDF functions | None
php_pgsql.dll | PostgreSQL functions | None
php_printer.dll | Printer functions | None
php_shmop.dll | Shared Memory functions | None
php_snmp.dll | SNMP get and walk functions | NT only!
php_soap.dll | SOAP functions | PHP >= 5.0.0
php_sockets.dll | Socket functions | None
php_sybase_ct.dll | Sybase functions | Requires: Sybase client libraries
php_tidy.dll | Tidy functions | PHP >= 5.0.0
php_tokenizer.dll | Tokenizer functions | Built in since PHP 4.3.0
php_w32api.dll | W32api functions | None
php_xmlrpc.dll | XML-RPC functions | PHP >= 4.2.1 requires: iconv.dll (bundled)
php_xslt.dll | XSLT functions | PHP <= 4.2.0 requires sablot.dll, expat.dll (bundled). PHP >= 4.2.1 requires sablot.dll, expat.dll, iconv.dll (bundled).
php_yaz.dll | YAZ functions | Requires: yaz.dll (bundled)
php_zip.dll | Zip File functions | Read only access
php_zlib.dll | ZLib compression functions | Built in since PHP 4.3.0

Předcházející | Nahoru | Další
Building from source | Domů | 7. Installation of PECL extensions


Microsoft IIS / PWS

This section contains notes and hints specific to IIS (Microsoft Internet Information Server).

Varování

Při používání konfigurace s CGI je váš server otevřen mnoha možným útokům. Přečtěte si prosím naši sekci bezpečnosti CGI, abyste se naučili bránit se proti takovým útokům.

General considerations for all installations of PHP with IIS or PWS

  • First, read the Manual Installation Instructions. Do not skip this step as it provides crucial information for installing PHP on Windows.
  • CGI users must set the cgi.force_redirect PHP directive to 0 inside php.ini. Read the faq on cgi.force_redirect for important details. Also, CGI users may want to set the cgi.redirect_status_env directive. When using directives, be sure these directives aren't commented out inside php.ini.
  • The PHP 4 CGI is named php.exe while in PHP 5 it's php-cgi.exe. In PHP 5, php.exe is the CLI, and not the CGI.
  • Modify the Windows PATH environment variable to include the PHP directory. This way the PHP DLL files and PHP executables can all remain in the PHP directory without cluttering up the Windows system directory. For more details, see the FAQ on Setting the PATH.
  • The IIS user (usually IUSR_MACHINENAME) needs permission to read various files and directories, such as php.ini, docroot, and the session tmp directory.
  • Be sure the extension_dir and doc_root PHP directives are appropriately set in php.ini. These directives depend on the system that PHP is being installed on. In PHP 4, the extension_dir is extensions while with PHP 5 it's ext. So, an example PHP 5 extensions_dir value is "c:\php\ext" and an example IIS doc_root value is "c:\Inetpub\wwwroot".
  • PHP extension DLL files, such as php_mysql.dll and php_curl.dll, are found in the zip package of the PHP download (not the PHP installer). In PHP 5, many extensions are part of PECL and can be downloaded in the "Collection of PECL modules" package. Files such as php_zip.dll and php_ssh2.dll. » Download PHP files here.
  • When defining the executable, the 'check that file exists' box may also be checked. For a small performance penalty, the IIS (or PWS) will check that the script file exists and sort out authentication before firing up PHP. This means that the web server will provide sensible 404 style error messages instead of CGI errors complaining that PHP did not output any data.
  • The PHP executable is distributed as a 32bit application. If you are running a 64bit version of Windows you will either need to rebuild the binary yourself, or make sure IIS is configured to also run 32bit extensions. You can usually turn this on by using the IIS Administration script as follows: Cscript.exe adsutil.vbs SET W3SVC/AppPools/Enable32bitAppOnWin64 1

Windows NT/200x/XP and IIS 4 or newer

PHP may be installed as a CGI binary, or with the ISAPI module. In either case, you need to start the Microsoft Management Console (may appear as 'Internet Services Manager', either in your Windows NT 4.0 Option Pack branch or the Control Panel=>Administrative Tools under Windows 2000/XP). Then right click on your Web server node (this will most probably appear as 'Default Web Server'), and select 'Properties'.

If you want to use the CGI binary, do the following:

  • Under 'Home Directory', 'Virtual Directory', or 'Directory', do the following:
  • Change the Execute Permissions to 'Scripts only'
  • Click on the 'Configuration' button, and choose the Application Mappings tab. Click Add and set the Executable path to the appropriate CGI file. An example PHP 5 value is: C:\php\php-cgi.exe Supply .php as the extension. Leave 'Method exclusions' blank, and check the 'Script engine' checkbox. Now, click OK a few times.
  • Set up the appropriate security. (This is done in Internet Service Manager), and if your NT Server uses NTFS file system, add execute rights for I_USR_ to the directory that contains php.exe / php-cgi.exe.

To use the ISAPI module, do the following:

  • If you don't want to perform HTTP Authentication using PHP, you can (and should) skip this step. Under ISAPI Filters, add a new ISAPI filter. Use PHP as the filter name, and supply a path to the php4isapi.dll / php5isapi.dll.
  • Under 'Home Directory', 'Virtual Directory', or 'Directory', do the following:
  • Change the Execute Permissions to 'Scripts only'
  • Click on the 'Configuration' button, and choose the Application Mappings tab. Click Add and set the Executable path to the appropriate ISAPI DLL. An example PHP 5 value is: C:\php\php5isapi.dll Supply .php as the extension. Leave 'Method exclusions' blank, and check the 'Script engine' checkbox. Now, click OK a few times.
  • Stop IIS completely (NET STOP iisadmin)
  • Start IIS again (NET START w3svc)

With IIS 6 (2003 Server), open up the IIS Manager, go to Web Service Extensions, choose "Add a new Web service extension", enter in a name such as PHP, choose the Add button and for the value browse to either the ISAPI file (php4isapi.dll or php5isapi.dll) or CGI (php.exe or php-cgi.exe) then check "Set extension status to Allowed" and click OK.

In order to use index.php as a default content page, do the following: From within the Documents tab, choose Add. Type in index.php and click OK. Adjust the order by choosing Move Up or Move Down. This is similar to setting DirectoryIndex with Apache.

The steps above must be repeated for each extension that is to be associated with PHP scripts. .php is the most common although .php3 may be required for legacy applications.

If you experience 100% CPU usage after some time, turn off the IIS setting Cache ISAPI Application.

Windows and PWS 4

PWS 4 does not support ISAPI, only PHP CGI should be used.

  • Edit the enclosed pws-php4cgi.reg / pws-php5cgi.reg file (look into the SAPI folder for PHP 4, or in the main folder for PHP 5) to reflect the location of your php.exe / php-cgi.exe. Backslashes should be escaped, for example: [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\w3svc\parameters\Script Map] ".php"="C:\\php\\php.exe" (change to C:\\php\\php-cgi.exe if you are using PHP 5) Now merge this registery file into your system; you may do this by double-clicking it.
  • In the PWS Manager, right click on a given directory you want to add PHP support to, and select Properties. Check the 'Execute' checkbox, and confirm.

Windows and PWS/IIS 3

The recommended method for configuring these servers is to use the REG file included with the distribution (pws-php4cgi.reg in the SAPI folder for PHP 4, or pws-php5cgi.reg in the main folder for PHP 5). You may want to edit this file and make sure the extensions and PHP install directories match your configuration. Or you can follow the steps below to do it manually.

Varování

These steps involve working directly with the Windows registry. One error here can leave your system in an unstable state. We highly recommend that you back up your registry first. The PHP Development team will not be held responsible if you damage your registry.

  • Run Regedit.
  • Navigate to: HKEY_LOCAL_MACHINE /System /CurrentControlSet /Services /W3Svc /Parameters /ScriptMap.
  • On the edit menu select: New->String Value.
  • Type in the extension you wish to use for your php scripts. For example .php
  • Double click on the new string value and enter the path to php.exe in the value data field. ex: C:\php\php.exe "%s" %s for PHP 4, or C:\php\php-cgi.exe "%s" %s for PHP 5.
  • Repeat these steps for each extension you wish to associate with PHP scripts.

The following steps do not affect the web server installation and only apply if you want your PHP scripts to be executed when they are run from the command line (ex. run C:\myscripts\test.php) or by double clicking on them in a directory viewer window. You may wish to skip these steps as you might prefer the PHP files to load into a text editor when you double click on them.

  • Navigate to: HKEY_CLASSES_ROOT
  • On the edit menu select: New->Key.
  • Name the key to the extension you setup in the previous section. ex: .php
  • Highlight the new key and in the right side pane, double click the "default value" and enter phpfile.
  • Repeat the last step for each extension you set up in the previous section.
  • Now create another New->Key under HKEY_CLASSES_ROOT and name it phpfile.
  • Highlight the new key phpfile and in the right side pane, double click the "default value" and enter PHP Script.
  • Right click on the phpfile key and select New->Key, name it Shell.
  • Right click on the Shell key and select New->Key, name it open.
  • Right click on the open key and select New->Key, name it command.
  • Highlight the new key command and in the right side pane, double click the "default value" and enter the path to php.exe. ex: c:\php\php.exe -q %1. (don't forget the %1).
  • Exit Regedit.
  • If using PWS on Windows, reboot to reload the registry.

PWS and IIS 3 users now have a fully operational system. IIS 3 users can use a nifty » tool from Steven Genusa to configure their script maps.

Předcházející | Nahoru | Další
ActiveScript | Domů | Apache 1.3.x on Microsoft Windows


Windows Installer (PHP 5.1.0 and earlier)

The Windows PHP installer is available from the downloads page at » http://www.php.net/downloads.php. This installs the CGI version of PHP and for IIS, PWS, and Xitami, it configures the web server as well. The installer does not include any extra external PHP extensions (php_*.dll) as you'll only find those in the Windows Zip Package and PECL downloads.

Poznámka: While the Windows installer is an easy way to make PHP work, it is restricted in many aspects as, for example, the automatic setup of extensions is not supported. Use of the installer isn't the preferred method for installing PHP.

First, install your selected HTTP (web) server on your system, and make sure that it works.

Run the executable installer and follow the instructions provided by the installation wizard. Two types of installation are supported - standard, which provides sensible defaults for all the settings it can, and advanced, which asks questions as it goes along.

The installation wizard gathers enough information to set up the php.ini file, and configure certain web servers to use PHP. One of the web servers the PHP installer does not configure for is Apache, so you'll need to configure it manually.

Once the installation has completed, the installer will inform you if you need to restart your system, restart the server, or just start using PHP.

Varování

Be aware, that this setup of PHP is not secure. If you would like to have a secure PHP setup, you'd better go on the manual way, and set every option carefully. This automatically working setup gives you an instantly working PHP installation, but it is not meant to be used on online servers.

Předcházející | Nahoru | Další
6. Installation on Windows systems | Domů | Manual Installation Steps


Manual Installation Steps

This install guide will help you manually install and configure PHP with a web server on Microsoft Windows. To get started you'll need to download the zip binary distribution from the downloads page at » http://www.php.net/downloads.php.

Although there are many all-in-one installation kits, and we also distribute a PHP installer for Microsoft Windows, we recommend you take the time to setup PHP yourself as this will provide you with a better understanding of the system, and enables you to install PHP extensions easily when needed.

Upgrading from a previous PHP version: Previous editions of the manual suggest moving various ini and DLL files into your SYSTEM (i.e. C:\WINDOWS) folder and while this simplifies the installation procedure it makes upgrading difficult. We advise you remove all of these files (like php.ini and PHP related DLLs from the Windows SYSTEM folder) before moving on with a new PHP installation. Be sure to backup these files as you might break the entire system. The old php.ini might be useful in setting up the new PHP as well. And as you'll soon learn, the preferred method for installing PHP is to keep all PHP related files in one directory and have this directory available to your systems PATH.

MDAC requirements: If you use Microsoft Windows 98/NT4 download the latest version of the Microsoft Data Access Components (MDAC) for your platform. MDAC is available at » http://msdn.microsoft.com/data/. This requirement exists because ODBC is built into the distributed Windows binaries.

The following steps should be completed on all installations before any server specific instructions are performed:

Extract the distribution file into a directory of your choice. If you are installing PHP 4, extract to C:\, as the zip file expands to a foldername like php-4.3.7-Win32. If you are installing PHP 5, extract to C:\php as the zip file doesn't expand as in PHP 4. You may choose a different location but do not have spaces in the path (like C:\Program Files\PHP) as some web servers will crash if you do.

The directory structure extracted from the zip is different for PHP versions 4 and 5 and look like as follows:

Příklad 6.1. PHP 4 package structure

c:\php
   |
   +--cli
   |  |
   |  |-php.exe           -- CLI executable - ONLY for command line scripting
   |
   +--dlls                -- support DLLs required by some extensions
   |  |
   |  |-expat.dll
   |  |
   |  |-fdftk.dll
   |  |
   |  |-...
   |
   +--extensions          -- extension DLLs for PHP
   |  |
   |  |-php_bz2.dll
   |  |
   |  |-php_cpdf.dll
   |  |
   |  |-..
   |
   +--mibs                -- support files for SNMP
   |
   +--openssl             -- support files for Openssl
   |
   +--pdf-related         -- support files for PDF
   |
   +--sapi                -- SAPI (server module support) DLLs
   |  |
   |  |-php4apache.dll
   |  |
   |  |-php4apache2.dll
   |  |
   |  |-..
   |
   +--PEAR                -- initial copy of PEAR
   |
   |
   |-go-pear.bat          -- PEAR setup script
   |
   |-..
   |
   |-php.exe              -- CGI executable
   |
   |-..
   |
   |-php.ini-dist         -- default php.ini settings
   |
   |-php.ini-recommended  -- recommended php.ini settings
   |
   |-php4ts.dll           -- core PHP DLL
   |
   |-...

Or:

Příklad 6.2. PHP 5 package structure

c:\php
   |
   +--dev
   |  |
   |  |-php5ts.lib
   |
   +--ext                 -- extension DLLs for PHP
   |  |
   |  |-php_bz2.dll
   |  |
   |  |-php_cpdf.dll
   |  |
   |  |-..
   |
   +--extras
   |  |
   |  +--mibs             -- support files for SNMP
   |  |
   |  +--openssl          -- support files for Openssl
   |  |
   |  +--pdf-related      -- support files for PDF
   |  |
   |  |-mime.magic
   |
   +--pear                -- initial copy of PEAR
   |
   |
   |-go-pear.bat          -- PEAR setup script
   |
   |-fdftk.dll
   |
   |-..
   |
   |-php-cgi.exe          -- CGI executable
   |
   |-php-win.exe          -- executes scripts without an opened command prompt
   |
   |-php.exe              -- CLI executable - ONLY for command line scripting
   |
   |-..
   |
   |-php.ini-dist         -- default php.ini settings
   |
   |-php.ini-recommended  -- recommended php.ini settings
   |
   |-php5activescript.dll
   |
   |-php5apache.dll
   |
   |-php5apache2.dll
   |
   |-..
   |
   |-php5ts.dll           -- core PHP DLL
   |
   |-...

Notice the differences and similarities. Both PHP 4 and PHP 5 have a CGI executable, a CLI executable, and server modules, but they are located in different folders and/or have different names. While PHP 4 packages have the server modules in the sapi folder, PHP 5 distributions have no such directory and instead they're in the PHP folder root. The supporting DLLs for the PHP 5 extensions are also not in a seperate directory.

Poznámka: In PHP 4, you should move all files located in the dll and sapi folders to the main folder (e.g. C:\php).

Here is a list of server modules shipped with PHP 4 and PHP 5:

  • sapi/php4activescript.dll (php5activescript.dll) - ActiveScript engine, allowing you to embed PHP in your Windows applications.

  • sapi/php4apache.dll (php5apache.dll) - Apache 1.3.x module.

  • sapi/php4apache2.dll (php5apache2.dll) - Apache 2.0.x module.

  • sapi/php5apache2_2.dll - Apache 2.2.x module.

  • sapi/php4isapi.dll (php5isapi.dll) - ISAPI Module for ISAPI compliant web servers like IIS 4.0/PWS 4.0 or newer.

  • sapi/php4nsapi.dll (php5nsapi.dll) - Sun/iPlanet/Netscape server module.

  • sapi/php4pi3web.dll (no equivalent in PHP 5) - Pi3Web server module.

Server modules provide significantly better performance and additional functionality compared to the CGI binary. The CLI version is designed to let you use PHP for command line scripting. More information about CLI is available in the chapter about using PHP from the command line.

Varování

The SAPI modules have been significantly improved as of the 4.1 release, however, in older systems you may encounter server errors or other server modules failing, such as ASP.

The CGI and CLI binaries, and the web server modules all require the php4ts.dll (php5ts.dll) file to be available to them. You have to make sure that this file can be found by your PHP installation. The search order for this DLL is as follows:

  • The same directory from where php.exe is called, or in case you use a SAPI module, the web server's directory (e.g. C:\Program Files\Apache Group\Apache2\bin).

  • Any directory in your Windows PATH environment variable.

To make php4ts.dll / php5ts.dll available you have three options: copy the file to the Windows system directory, copy the file to the web server's directory, or add your PHP directory, C:\php to the PATH. For better maintenance, we advise you to follow the last option, add C:\php to the PATH, because it will be simpler to upgrade PHP in the future. Read more about how to add your PHP directory to PATH in the corresponding FAQ entry (and then don't forget to restart the computer - logoff isn't enough).

The next step is to set up a valid configuration file for PHP, php.ini. There are two ini files distributed in the zip file, php.ini-dist and php.ini-recommended. We advise you to use php.ini-recommended, because we optimized the default settings in this file for performance, and security. Read this well documented file carefully because it has changes from php.ini-dist that will drastically affect your setup. Some examples are display_errors being off and magic_quotes_gpc being off. In addition to reading these, study the ini settings and set every element manually yourself. If you would like to achieve the best security, then this is the way for you, although PHP works fine with these default ini files. Copy your chosen ini-file to a directory that PHP is able to find and rename it to php.ini. PHP searches for php.ini in the locations described in „The configuration file“ section.

If you are running Apache 2, the simpler option is to use the PHPIniDir directive (read the installation on Apache 2 page), otherwise your best option is to set the PHPRC environment variable. This process is explained in the following FAQ entry.

Poznámka: If you're using NTFS on Windows NT, 2000, XP or 2003, make sure that the user running the web server has read permissions to your php.ini (e.g. make it readable by Everyone).

The following steps are optional:

  • Edit your new php.ini file. If you plan to use OmniHTTPd, do not follow the next step. Set the doc_root to point to your web servers document_root. For example:

doc_root = c:\inetpub\wwwroot // for IIS/PWS

doc_root = c:\apache\htdocs // for Apache

  • Choose the extensions you would like to load when PHP starts. See the section about Windows extensions, about how to set up one, and what is already built in. Note that on a new installation it is advisable to first get PHP working and tested without any extensions before enabling them in php.ini.
  • On PWS and IIS, you can set the browscap configuration setting to point to: c:\windows\system\inetsrv\browscap.ini on Windows 9x/Me, c:\winnt\system32\inetsrv\browscap.ini on NT/2000, and c:\windows\system32\inetsrv\browscap.ini on XP. For an up-to-date browscap.ini, read the following FAQ.

PHP is now setup on your system. The next step is to choose a web server, and enable it to run PHP. Choose a web server from the table of contents.

Předcházející | Nahoru | Další
Windows Installer (PHP 5.1.0 and earlier) | Domů | ActiveScript


OmniHTTPd Server

This section contains notes and hints specific to » OmniHTTPd on Windows.

Poznámka: You should read the manual installation steps first!

Varování

Při používání konfigurace s CGI je váš server otevřen mnoha možným útokům. Přečtěte si prosím naši sekci bezpečnosti CGI, abyste se naučili bránit se proti takovým útokům.

You need to complete the following steps to make PHP work with OmniHTTPd. This is a CGI executable setup. SAPI is supported by OmniHTTPd, but some tests have shown that it is not so stable to use PHP as an ISAPI module.

Important for CGI users: Read the faq on cgi.force_redirect for important details. This directive needs to be set to 0.

  1. Install OmniHTTPd server.

  2. Right click on the blue OmniHTTPd icon in the system tray and select Properties

  3. Click on Web Server Global Settings

  4. On the 'External' tab, enter: virtual = .php | actual = c:\php\php.exe (use php-cgi.exe if installing PHP 5), and use the Add button.

  5. On the Mime tab, enter: virtual = wwwserver/stdcgi | actual = .php, and use the Add button.

  6. Click OK

Repeat steps 2 - 6 for each extension you want to associate with PHP.

Poznámka: Some OmniHTTPd packages come with built in PHP support. You can choose at setup time to do a custom setup, and uncheck the PHP component. We recommend you to use the latest PHP binaries. Some OmniHTTPd servers come with PHP 4 beta distributions, so you should choose not to set up the built in support, but install your own. If the server is already on your machine, use the Replace button in Step 4 and 5 to set the new, correct information.

Předcházející | Nahoru | Další
Sun, iPlanet and Netscape servers on Microsoft Windows | Domů | Sambar Server on Microsoft Windows


Sambar Server on Microsoft Windows

This section contains notes and hints specific to the » Sambar Server for Windows.

Poznámka: You should read the manual installation steps first!

This list describes how to set up the ISAPI module to work with the Sambar server on Windows.

  • Find the file called mappings.ini (in the config directory) in the Sambar install directory.

  • Open mappings.ini and add the following line under [ISAPI]:

    Příklad 6.7. ISAPI configuration of Sambar

#for PHP 4
*.php = c:\php\php4isapi.dll

#for PHP 5
*.php = c:\php\php5isapi.dll

    (This line assumes that PHP was installed in c:\php.)

  • Now restart the Sambar server for the changes to take effect.

Poznámka: If you intend to use PHP to communicate with resources which are held on a different computer on your network, then you will need to alter the account used by the Sambar Server Service. The default account used for the Sambar Server Service is LocalSystem which will not have access to remote resources. The account can be amended by using the Services option from within the Windows Control Panel Administation Tools.

Předcházející | Nahoru | Další
OmniHTTPd Server | Domů | Xitami on Microsoft Windows


Sun, iPlanet and Netscape servers on Microsoft Windows

This section contains notes and hints specific to Sun Java System Web Server, Sun ONE Web Server, iPlanet and Netscape server installs of PHP on Windows.

From PHP 4.3.3 on you can use PHP scripts with the NSAPI module to generate custom directory listings and error pages. Additional functions for Apache compatibility are also available. For support in current web servers read the note about subrequests.

CGI setup on Sun, iPlanet and Netscape servers

To install PHP as a CGI handler, do the following:

  • Copy php4ts.dll to your systemroot (the directory where you installed Windows)

  • Make a file association from the command line. Type the following two lines:

assoc .php=PHPScript
ftype PHPScript=c:\php\php.exe %1 %*

  • In the Netscape Enterprise Administration Server create a dummy shellcgi directory and remove it just after (this step creates 5 important lines in obj.conf and allow the web server to handle shellcgi scripts).
  • In the Netscape Enterprise Administration Server create a new mime type (Category: type, Content-Type: magnus-internal/shellcgi, File Suffix:php).
  • Do it for each web server instance you want PHP to run

More details about setting up PHP as a CGI executable can be found here: » http://benoit.noss.free.fr/php/install-php.html

NSAPI setup on Sun, iPlanet and Netscape servers

To install PHP with NSAPI, do the following:

  • Copy php4ts.dll to your systemroot (the directory where you installed Windows)

  • Make a file association from the command line. Type the following two lines:

assoc .php=PHPScript
ftype PHPScript=c:\php\php.exe %1 %*

  • In the Netscape Enterprise Administration Server create a new mime type (Category: type, Content-Type: magnus-internal/x-httpd-php, File Suffix: php).

  • Edit magnus.conf (for servers >= 6) or obj.conf (for servers < 6) and add the following: You should place the lines after mime types init.

Init fn="load-modules" funcs="php4_init,php4_execute,php4_auth_trans" shlib="c:/php/sapi/php4nsapi.dll"
Init fn="php4_init" LateInit="yes" errorString="Failed to initialise PHP!" [php_ini="c:/path/to/php.ini"]
    (PHP >= 4.3.3) The php_ini parameter is optional but with it you can place your php.ini in your web server configuration directory.

  • Configure the default object in obj.conf (for virtual server classes [Sun Web Server 6.0+] in their vserver.obj.conf): In the <Object name="default"> section, place this line necessarily after all 'ObjectType' and before all 'AddLog' lines:

Service fn="php4_execute" type="magnus-internal/x-httpd-php" [inikey=value inikey=value ...]
    (PHP >= 4.3.3) As additional parameters you can add some special php.ini-values, for example you can set a docroot="/path/to/docroot" specific to the context php4_execute is called. For boolean ini-keys please use 0/1 as value, not "On","Off",... (this will not work correctly), e.g. zlib.output_compression=1 instead of zlib.output_compression="On"

  • This is only needed if you want to configure a directory that only consists of PHP scripts (same like a cgi-bin directory):

<Object name="x-httpd-php">
ObjectType fn="force-type" type="magnus-internal/x-httpd-php"
Service fn=php4_execute [inikey=value inikey=value ...]
</Object>
    After that you can configure a directory in the Administration server and assign it the style x-httpd-php. All files in it will get executed as PHP. This is nice to hide PHP usage by renaming files to .html.

  • Restart your web service and apply changes
  • Do it for each web server instance you want PHP to run

Poznámka: More details about setting up PHP as an NSAPI filter can be found here: » http://benoit.noss.free.fr/php/install-php4.html

Poznámka: The stacksize that PHP uses depends on the configuration of the web server. If you get crashes with very large PHP scripts, it is recommended to raise it with the Admin Server (in the section "MAGNUS EDITOR").

CGI environment and recommended modifications in php.ini

Important when writing PHP scripts is the fact that Sun JSWS/Sun ONE WS/iPlanet/Netscape is a multithreaded web server. Because of that all requests are running in the same process space (the space of the web server itself) and this space has only one environment. If you want to get CGI variables like PATH_INFO, HTTP_HOST etc. it is not the correct way to try this in the old PHP 3.x way with getenv() or a similar way (register globals to environment, $_ENV). You would only get the environment of the running web server without any valid CGI variables!

Poznámka: Why are there (invalid) CGI variables in the environment?

Answer: This is because you started the web server process from the admin server which runs the startup script of the web server, you wanted to start, as a CGI script (a CGI script inside of the admin server!). This is why the environment of the started web server has some CGI environment variables in it. You can test this by starting the web server not from the administration server. Use the command line as root user and start it manually - you will see there are no CGI-like environment variables.

Simply change your scripts to get CGI variables in the correct way for PHP 4.x by using the superglobal $_SERVER. If you have older scripts which use $HTTP_HOST, etc., you should turn on register_globals in php.ini and change the variable order too (important: remove "E" from it, because you do not need the environment here):

variables_order = "GPCS"
register_globals = On

Special use for error pages or self-made directory listings (PHP >= 4.3.3)

You can use PHP to generate the error pages for "404 Not Found" or similar. Add the following line to the object in obj.conf for every error page you want to overwrite:

Error fn="php4_execute" code=XXX script="/path/to/script.php" [inikey=value inikey=value...]
where XXX is the HTTP error code. Please delete any other Error directives which could interfere with yours. If you want to place a page for all errors that could exist, leave the code parameter out. Your script can get the HTTP status code with $_SERVER['ERROR_TYPE'].

Another possibility is to generate self-made directory listings. Just create a PHP script which displays a directory listing and replace the corresponding default Service line for type="magnus-internal/directory" in obj.conf with the following:

Service fn="php4_execute" type="magnus-internal/directory" script="/path/to/script.php" [inikey=value inikey=value...]
For both error and directory listing pages the original URI and translated URI are in the variables $_SERVER['PATH_INFO'] and $_SERVER['PATH_TRANSLATED'].

Note about nsapi_virtual() and subrequests (PHP >= 4.3.3)

The NSAPI module now supports the nsapi_virtual() function (alias: virtual()) to make subrequests on the web server and insert the result in the web page. The problem is, that this function uses some undocumented features from the NSAPI library.

Under Unix this is not a problem, because the module automatically looks for the needed functions and uses them if available. If not, nsapi_virtual() is disabled.

Under Windows limitations in the DLL handling need the use of a automatic detection of the most recent ns-httpdXX.dll file. This is tested for servers till version 6.1. If a newer version of the Sun server is used, the detection fails and nsapi_virtual() is disabled.

If this is the case, try the following: Add the following parameter to php4_init in magnus.conf/obj.conf:

Init fn=php4_init ... server_lib="ns-httpdXX.dll"
where XX is the correct DLL version number. To get it, look in the server-root for the correct DLL name. The DLL with the biggest filesize is the right one.

You can check the status by using the phpinfo() function.

Poznámka: But be warned: Support for nsapi_virtual() is EXPERIMENTAL!!!

Předcházející | Nahoru | Další
Apache 2.0.x on Microsoft Windows | Domů | OmniHTTPd Server


Xitami on Microsoft Windows

This section contains notes and hints specific to » Xitami on Windows.

Poznámka: You should read the manual installation steps first!

This list describes how to set up the PHP CGI binary to work with Xitami on Windows.

Important for CGI users: Read the faq on cgi.force_redirect for important details. This directive needs to be set to 0. If you want to use $_SERVER['PHP_SELF'] you have to enable the cgi.fix_pathinfo directive.

Varování

Při používání konfigurace s CGI je váš server otevřen mnoha možným útokům. Přečtěte si prosím naši sekci bezpečnosti CGI, abyste se naučili bránit se proti takovým útokům.

  • Make sure the web server is running, and point your browser to xitamis admin console (usually http://127.0.0.1/admin), and click on Configuration.

  • Navigate to the Filters, and put the extension which PHP should parse (i.e. .php) into the field File extensions (.xxx).

  • In Filter command or script put the path and name of your PHP CGI executable i.e. C:\php\php.exe for PHP 4, or C:\php\php-cgi.exe for PHP 5.

  • Press the 'Save' icon.

  • Restart the server to reflect changes.

Předcházející | Nahoru | Další
Sambar Server on Microsoft Windows | Domů | Building from source


Část VII. PHP at the Core: A Hacker's Guide to the Zend Engine

The Zend API has evolved considerably over time, as PHP has become a more robust and widespread language. With the introduction of PHP 5 came the Zend Engine 2 (ZE2). ZE2 came with an almost entirely new Object-Oriented Programming (OOP) model, as well as improvements in most aspects of the API. PHP 6, which is still under active development at the time of this writing, introduces the Zend Engine 3 (ZE3), which brings full Unicode support to the language.

Varování

This documentation is still under heavy development. The original Zend documentation is preserved in its entirety in the Zend Engine 1 section for those who need it before this documentation is completed.

This section of the manual is devoted to ZE2. While PHP 4.3 is still in widespread use, the differences in how extensions are written in ZE1 are small; a short reference to them is given in an appendix to this section. ZE3's API may yet change significantly, and is covered in another appendix. It will be more fully documented when PHP 6 enters a beta testing stage.

The documentation in this section is current as of PHP 5.2.3, the most recent stable release at the time of this writing. Notable differences in the minor PHP 5 releases (5.0, 5.1, and 5.2) are given as appropriate.

Obsah

45. The PHP 5 build system
46. Extension structure
47. Memory management
48. Working with variables
49. Writing functions
50. Working with classes and objects
51. Working with resources
52. Working with INI settings
53. Working with streams
54. PDO Driver How-To
55. Extension FAQs
56. Zend Engine 2 API reference
57. Zend Engine 1
58. The future: PHP 6 and Zend Engine 3
Předcházející | Nahoru | Další
zlib_get_coding_type | Domů | 45. The PHP 5 build system


Kapitola 56. Zend Engine 2 API reference

Předcházející | Nahoru | Další
55. Extension FAQs | Domů | 57. Zend Engine 1


Kapitola 45. The PHP 5 build system

Obsah

Building PHP for extension development
The ext_skel script
Talking to the UNIX build system: config.m4
Talking to the Windows build system: config.w32

With all the functionality and flexibility available in PHP 5, it is no surprise that it consists of several thousand files and over one million lines of source code. Equally unsurprising is the necessity of a build system to manage so much data. This section describes how to set PHP up for extension development, the layout of an extension within the PHP source tree, and how to interface your extension with the build system.

Building PHP for extension development

In a typical PHP installation, the need for high performance almost always results in optimization at the cost of debugging facilities. This is a reasonable tradeoff for production use, but when developing an extension it falls short. What we need is a build of PHP which will give us some hints what has gone wrong when something does.

The Zend Engine provides a memory manager which is capable of tracking memory leaks in extensions and providing detailed debugging information. This tracking is disabled by default, as is thread-safety. To turn them on, pass the --enable-debug and --enable-maintainer-zts options to configure, along with whatever options you typically use. For instructions on building PHP from source, see the instructions at 3 – „Obecné instalační úvahy“. A typical configure line might look like this:

$ ./configure --prefix=/where/to/install/php --enable-debug --enable-maintainer-zts --enable-cgi --enable-cli --with-mysql=/path/to/mysql

Předcházející | Nahoru | Další
VII. PHP at the Core: A Hacker's Guide to the Zend Engine | Domů | The ext_skel script


Talking to the UNIX build system: config.m4

The config.m4 file for an extension tells the UNIX build system what configure options your extension supports, what external libraries and includes you require, and what source files are to be compiled as part of it. A reference to all the commonly used autoconf macros, both PHP-specific and those built into autoconf, is given in the 56 – „Zend Engine 2 API reference“ section.

Tip

When developing a PHP extension, it is strongly recommended that autoconf version 2.13 be installed, despite the newer releases which are available. Version 2.13 is recognized as a common denominator of autoconf availability, usability, and user base. Using later versions will sometimes produce cosmetic differences from the expected output of configure.

Příklad 45.1. An example config.m4 file

dnl $Id: configunix.xml,v 1.3 2007/06/28 04:45:10 gwynne Exp $
dnl config.m4 for extension example

PHP_ARG_WITH(example, for example support,
[  --with-example[=FILE]       Include example support. File is the optional path to example-config])
PHP_ARG_ENABLE(example-debug, whether to enable debugging support in example,
[  --enable-example-debug        example: Enable debugging support in example], no, no)
PHP_ARG_WITH(example-extra, for extra libraries for example,
[  --with-example-extra=DIR      example: Location of extra libraries for example], no, no)

dnl Check whether the extension is enabled at all
if test "$PHP_EXAMPLE" != "no"; then

  dnl Check for example-config. First try any path that was given to us, then look in $PATH
  AC_MSG_CHECKING([for example-config])
  EXAMPLE_CONFIG="example-config"
  if test "$PHP_EXAMPLE" != "yes"; then
    EXAMPLE_PATH=$PHP_EXAMPLE
  else
    EXAMPLE_PATH=`$php_shtool path $EXAMPLE_CONFIG`
  fi

  dnl If a usable example-config was found, use it
  if test -f "$EXAMPLE_PATH" && test -x "$EXAMPLE_PATH" && $EXAMPLE_PATH --version > /dev/null 2>&1; then
    AC_MSG_RESULT([$EXAMPLE_PATH])
    EXAMPLE_LIB_NAME=`$EXAMPLE_PATH --libname`
    EXAMPLE_INCDIRS=`$EXAMPLE_PATH --incdirs`
    EXAMPLE_LIBS=`$EXAMPLE_PATH --libs`

    dnl Check that the library works properly
    PHP_CHECK_LIBRARY($EXAMPLE_LIB_NAME, example_critical_function,
    [
      dnl Add the necessary include dirs
      PHP_EVAL_INCLINE($EXAMPLE_INCDIRS)
      dnl Add the necessary libraries and library dirs
      PHP_EVAL_LIBLINE($EXAMPLE_LIBS, EXAMPLE_SHARED_LIBADD)
    ],[
      dnl Bail out
      AC_MSG_ERROR([example library not found. Check config.log for more information.])
    ],[$EXAMPLE_LIBS]
    )
  else
    dnl No usable example-config, bail
    AC_MSG_RESULT([not found])
    AC_MSG_ERROR([Please check your example installation.])
  fi

  dnl Check whether to enable debugging
  if test "$PHP_EXAMPLE_DEBUG" != "no"; then
    dnl Yes, so set the C macro
    AC_DEFINE(USE_EXAMPLE_DEBUG,1,[Include debugging support in example])
  fi

  dnl Check for the extra support
  if test "$PHP_EXAMPLE_EXTRA" != "no"; then
    if test "$PHP_EXAMPLE_EXTRA" == "yes"; then
      AC_MSG_ERROR([You must specify a path when using --with-example-extra])
    fi

    PHP_CHECK_LIBRARY(example-extra, example_critical_extra_function,
    [
      dnl Add the neccessary paths
      PHP_ADD_INCLUDE($PHP_EXAMPLE_EXTRA/include)
      PHP_ADD_LIBRARY_WITH_PATH(example-extra, $PHP_EXAMPLE_EXTRA/lib, EXAMPLE_SHARED_LIBADD)
      AC_DEFINE(HAVE_EXAMPLEEXTRALIB,1,[Whether example-extra support is present and requested])
      EXAMPLE_SOURCES="$EXAMPLE_SOURCES example_extra.c"
    ],[
      AC_MSG_ERROR([example-extra lib not found. See config.log for more information.])
    ],[-L$PHP_EXAMPLE_EXTRA/lib]
    )
  fi

  dnl Finally, tell the build system about the extension and what files are needed
  PHP_NEW_EXTENSION(example, example.c $EXAMPLE_SOURCES, $ext_shared)
  PHP_SUBST(EXAMPLE_SHARED_LIBADD)
fi

A short introduction to autoconf syntax

config.m4 files are written using the GNU autoconf syntax. It can be described in a nutshell as shell scripting augmented by a powerful macro language. Comments are delimited by the string dnl, and strings are quoted using left and right brackets (e.g. [ and ]). Quoting of strings can be nested as many times as needed. A full reference to the syntax can be found in the autoconf manual at » http://www.gnu.org/software/autoconf/manual/.

PHP_ARG_*: Giving users the option

The very first thing seen in the example config.m4 above, aside from a couple of comments, are three lines using PHP_ARG_WITH() and PHP_ARG_ENABLE(). These provide configure with the options and help text seen when running ./configure --help. As the names suggest, the difference between the two is whether they create a --with-* option or an --enable-* option. Every extension should provide at least one or the other with the extension name, so that users can choose whether or not to build the extension into PHP. By convention, PHP_ARG_WITH() is used for an option which takes a parameter, such as the location of a library or program required by an extension, while PHP_ARG_ENABLE() is used for an option which represents a simple flag.

Příklad 45.2. Sample configure output

$ ./configure --help
...
  --with-example[=FILE]       Include example support. FILE is the optional path to example-config
  --enable-example-debug        example: Enable debugging support in example
  --with-example-extra=DIR      example: Location of extra libraries for example
...

$ ./configure --with-example=/some/library/path/example-config --disable-example-debug --with-example-extra=/another/library/path
...
checking for example support... yes
checking whether to enable debugging support in example... no
checking for extra libraries for example... /another/library/path
...

Poznámka: Regardless of the order in which options are specified on the command line when configure is called, the checks will be run in the order they are specified in config.m4.

Processing the user's choices

Now that config.m4 can provide the user with some choices of what to do, it's time to act upon those choices. In the example above, the obvious default for all three options, if any of them are unspecified, is "no". As a matter of convention, it is best to use this as the default for the option which enables the extension, as it will be overridden by phpize for extensions built separately, and should not clutter the extension space by default when being built into PHP. The code to process the three options is by far the most complicated.

Handling the --with-example[=FILE] option

The first check made of the --with-example[=FILE] option is whether it was set at all. As this option controls the inclusion of the entire extension, if it was unspecified, given in the negative form (--without-example), or given the value "no", nothing else is done at all. In the example above, it is specified with the value /some/library/path/example-config, so the first test succeeds.

Next, the code calls AC_MSG_CHECKING(), an autoconf macro which outputs a standard "checking for something" line, and checks whether the user gave an explicit path to the fictional example-config. In this example, PHP_EXAMPLE got the value /some/library/path/example-config, which is now copied into the EXAMPLE_PATH variable. Had the user specified only --with-example, the code would have executed $php_shtool path $EXAMPLE_CONFIG, which would try to guess the location of example-config using the user's current PATH. Either way, the next step is to check whether the chosen EXAMPLE_PATH is a regular file, is executable, and can be run successfully. If so, AC_MSG_RESULT() is called, which completes the output line started by AC_MSG_CHECKING(). Otherwise, AC_MSG_ERROR() is called, which prints the given message and halts configure immediately.

The code now determines some site-specific configuration information by running example-config several times. The next call is to PHP_CHECK_LIBRARY(), a macro provided by the PHP buildsystem as a wrapper around autoconf's AC_CHECK_LIB(). PHP_CHECK_LIBRARY() attempts to compile, link, and run a program which calls the symbol specified by the second parameter in the library specified by the first, using the string given in the fifth as extra linker options. If the attempt succeeds, the script given in the third parameter is run. This script tells the PHP buildsystem to extract include paths, library paths, and library names from the raw option strings example-config provided. If the attempt fails, the script in the fourth parameter is run instead. In this case, AC_MSG_ERROR() is called to stop processing.

Handling the --enable-example-debug option

Processing the --enable-example-debug is much simpler. A simple check for its truth value is performed. If that check succeeds, AC_DEFINE() is called to make the C macro USE_EXAMPLE_DEBUG available to the source of the extension. The third parameter is a comment string for config.h; it is safe to leave this empty, and often is.

Handling the --with-example-extra=DIR option

For the sake of this example, the fictional "extra" functionality requested by the --with-example-extra=DIR option does not share the fictional example-config program, nor does it have any default paths to search. Therefore, the user is required to provide the installation prefix of the necessary library. This setup is somewhat unlikely in a real-world extension, but is considered illustrative.

The code begins in a now-familiar way by checking the truth value of PHP_EXAMPLE_EXTRA. If a negative form was provided, no further processing is done; the user did not request extra functionality. If a positive form was provided without a parameter, AC_MSG_ERROR() is called to halt processing. The next step is another invocation of PHP_CHECK_LIBRARY(). This time, since there is no set of predefined compiler options provided, PHP_ADD_INCLUDE() and PHP_ADD_LIBRARY_WITH_PATH() are used to construct the necessary include paths, library paths, and library flags for the extra functionality. AC_DEFINE() is also called to indicate to the code that the extra functionality was both requested and available, and a variable is set to tell later code that there are extra source files to build. If the check fails, the familiar AC_MSG_ERROR() is called. A different way to handle the failure would have been to call AC_MSG_WARNING() instead, e.g.:

      AC_MSG_WARNING([example-extra lib not found. example will be built without extra functionality.])

In this case, configure would print a warning message rather than an error, and continue processing. Which way such failures are handled is a design decision left to the extension developer.

Telling the buildsystem what was decided

With all the necessary includes and libraries specified, with all the options processed and macros defined, one more thing remains to be done: The build system must be told to build the extension itself, and which files are to be used for that. To do this, the PHP_NEW_EXTENSION() macro is called. The first parameter is the name of the extension, which is the same as the name of the directory containing it. The second parameter is the list of all source files which are part of the extension. See PHP_ADD_BUILD_DIR() for information about adding source files in subdirectories to the build process. The third parameter should always be $ext_shared, a value which was determined by configure when PHP_ARG_WITH() was called for --with-example[=FILE]. The fourth parameter specifies a "SAPI class", and is only useful for extensions which require the CGI or CLI SAPIs specifically. It should be left empty in all other cases. The fifth parameter specifies a list of flags to be added to CFLAGS while building the extension; the sixth is a boolean value which, if "yes", will force the entire extension to be built using $CXX instead of $CC. All parameters after the third are optional. Finally, PHP_SUBST() is called to enable shared builds of the extension. See 55 – „Extension FAQs“ for more information on disabling support for building an extension in shared mode.

Předcházející | Nahoru | Další
The ext_skel script | Domů | Talking to the Windows build system: config.w32


Talking to the Windows build system: config.w32

An extension's config.w32 file is similar in usage to the config.m4 file, with two critical differences: first, it is used for Windows builds, and second, it is written in JavaScript. This section makes no attempt to cover JavaScript syntax. For the moment, this section is incomplete in lieu of a Win32 testbed, and an experimental-only port of the example config.m4 is the only example provided.

Příklad 45.3. An example config.w32 file

// $Id: configwin.xml,v 1.3 2007/06/28 04:45:10 gwynne Exp $
// vim:ft=javascript

ARG_WITH("example", "for example support", "no");
ARG_ENABLE("example-debug", "for debugging support in example", "no")
ARG_WITH("example-extra", "for extra functionality in example", "no")
if (PHP_EXAMPLE != "no") {
    if (CHECK_LIB("libexample.lib", "example", PHP_EXAMPLE) &&
        CHECK_HEADER_ADD_INCLUDE("example.h", "CFLAGS_EXAMPLE", PHP_EXAMPLE + "\\include")) {

        if (PHP_EXAMPLE_DEBUG != "no") {
            AC_DEFINE('USE_EXAMPLE_DEBUG', 1, 'Debug support in example');
        }

        if (PHP_EXAMPLE_EXTRA != "no" &&
            CHECK_LIB("libexample-extra.lib", "example", PHP_EXAMPLE) &&
            CHECK_HEADER_ADD_INCLUDE("example-extra.h", "CFLAGS_EXAMPLE", PHP_EXAMPLE + ";" + PHP_PHP_BUILD + "\\include") {
            AC_DEFINE('HAVE_EXAMPLEEXTRA', 1, 'Extra functionality in example');
            HAVE_EXTRA = 1;
        } else {
            WARNING( "extra example functionality not enabled, lib not found" );
        }

        EXTENSION("example", "example.c");
        if (HAVE_EXTRA == 1) {
            ADD_SOURCES("example-extra.c");
        }
    } else {
        WARNING( "example not enabled; libraries not found" );
    }
}

Předcházející | Nahoru | Další
Talking to the UNIX build system: config.m4 | Domů | 46. Extension structure


The ext_skel script

A Zend extension is composed of several files common to all extensions. As the details of many of those files are similar from extension to extension, it can be laborous to duplicate the content for each one. Fortunately, there is a script which can do all of the initial setup for you. It's called ext_skel, and it's been distributed with PHP since 4.0.

Running ext_skel with no parameters produces this output in PHP 5.2.2:

php-5.2.2/ext$ ./ext_skel
./ext_skel --extname=module [--proto=file] [--stubs=file] [--xml[=file]]
           [--skel=dir] [--full-xml] [--no-help]

  --extname=module   module is the name of your extension
  --proto=file       file contains prototypes of functions to create
  --stubs=file       generate only function stubs in file
  --xml              generate xml documentation to be added to phpdoc-cvs
  --skel=dir         path to the skeleton directory
  --full-xml         generate xml documentation for a self-contained extension
                     (not yet implemented)
  --no-help          don't try to be nice and create comments in the code
                     and helper functions to test if the module compiled
Generally, when developing a new extension the only parameters you will be interested in are --extname and --no-help. Unless you are already experienced with the structure of an extension, you will not want to use --no-help; specifying it causes ext_skel to leave out many helpful comments in the files it generates.

This leaves you with --extname, which tells ext_skel what the name of your extension is. This "name" is an all-lowercase identifier containing only letters and underscores which is unique among everything in the ext/ folder of your PHP distribution.

The --proto option is intended to allow the developer to specify a header file from which a set of PHP functions will be created, ostensibly for the purpose of developing an extension based on a library, but it often functions poorly with most modern header files. A test run on the zlib.h header resulted in a very large number of empty and nonsense prototypes in the ext_skel output files. The --xml and --full-xml options are entirely nonfunctional thus far. The --skel option can be used to specify a modified set of skeleton files to work from, a topic which is beyond the scope of this section.

Předcházející | Nahoru | Další
45. The PHP 5 build system | Domů | Talking to the UNIX build system: config.m4


Kapitola 55. Extension FAQs

Předcházející | Nahoru | Další
Error handling | Domů | 56. Zend Engine 2 API reference


Kapitola 49. Writing functions

PHP is also known as a Glue language, and extending it, can be easily done with those extensions generators. When you use ext_skel and a prototype file to generate the C function stubs, you will notice that all of the exported functions created have a simple prototype such as the following: PHP_FUNCTION(func_name)

Předcházející | Nahoru | Další
48. Working with variables | Domů | 50. Working with classes and objects


Kapitola 52. Working with INI settings

Předcházející | Nahoru | Další
51. Working with resources | Domů | 53. Working with streams


Kapitola 47. Memory management

Předcházející | Nahoru | Další
Testing an extension | Domů | 48. Working with variables


Kapitola 50. Working with classes and objects

Předcházející | Nahoru | Další
49. Writing functions | Domů | 51. Working with resources


Kapitola 54. PDO Driver How-To

Předcházející VII. PHP at the Core: A Hacker's Guide to the Zend Engine Další

PDO Driver How-To

Abstrakt

The purpose of this How-To is to provide a basic understanding of the steps required to write a database driver that interfaces with the PDO layer. Please note that this is still an evolving API and as such, subject to change. This document was prepared based on version 0.3 of PDO. The learning curve is steep; expect to spend a lot of time on the prerequisites.

Obsah

Prerequisites
Preparation and Housekeeping
Fleshing out your skeleton
Building
Testing
Packaging and distribution
pdo_dbh_t definition
pdo_stmt_t definition
Constants
Error handling

Prerequisites

The following is list of prerequisites and assumptions needed for writing a PDO database driver:

  1. A working target database, examples, demos, etc. working as per vendor specifications;

  2. A working development environment:

    1. Linux: standard development tools, gcc, ld, make, autoconf, automake, etc., versions dependent on distribution;

    2. Other Unix: standard development tools supplied by vendor plus the GNU development tool set;

    3. Win32: Visual Studio compiler suite;

  3. A working PHP environment version 5.0.3 or higher with a working PEAR extension version 1.3.5 or higher;

  4. A working PDO environment (can be installed using 'sudo pecl install PDO'), including the headers which will be needed to access the PDO type definitions and function declarations;

  5. A good working knowledge of the C programming language;

  6. A good working knowledge of the way to write a PHP extension; George Schlossnagle's Advanced PHP Programming (published by Developer's Library, chapters 21 and 22) is recommended;

  7. Finally, a familiarity with the Zend API that forms the heart of PHP, in particular paying attention to the memory management aspects.

Předcházející | Nahoru | Další
53. Working with streams | Domů | Preparation and Housekeeping


Building

The build process is designed to work with PEAR (see » http://pear.php.net/ for more information about PEAR). There are two files that are used to assist in configuring your package for building. The first is config.m4 which is the autoconf configuration file for all platforms except Win32. The second is config.w32 which is a build configuration file for use on Win32. Skeleton files for these are built for you when you first set up your project. You then need to customize them to fit the needs of your project. Once you've customized your config files, you can build your driver using the following sequence of commands:

Before first build:

$ sudo pecl install PDO

For each build:

$ cd pdo_SKEL
$ phpize
$ ./configure
$ make
$ sudo make install

The process can then be repeated as necessary during the development process.

Předcházející | Nahoru | Další
Fleshing out your skeleton | Domů | Testing


Constants

Tabulka 54.1. Database and Statement Attributes Table

Attribute

Valid value(s)

PDO_ATTR_AUTOCOMMIT

BOOL

TRUE if autocommit is set, FALSE otherwise.

dbh->auto_commit contains value. Processed by PDO directly.

PDO_ATTR_PREFETCH

LONG

Value of the prefetch size in drivers that support it.

PDO_ATTR_TIMEOUT

LONG

How long to wait for a db operation before timing out.

PDO_ATTR_ERRMODE

LONG

Processed and handled by PDO

PDO_ATTR_SERVER_VERSION

STRING

The „human-readable“ string representing the Server/Version this driver is currently connected to.

PDO_ATTR_CLIENT_VERSION

STRING

The „human-readable“ string representing the Client/Version this driver supports.

PDO_ATTR_SERVER_INFO

STRING

The „human-readable“ description of the Server.

PDO_ATTR_CONNECTION_STATUS

LONG

Values not yet defined

PDO_ATTR_CASE

LONG

Processed and handled by PDO.

PDO_ATTR_CURSOR_NAME

STRING

String representing the name for a database cursor for use in „where current in <name>“ SQL statements.

PDO_ATTR_CURSOR

LONG

PDO_CURSOR_FWDONLY

Forward only cursor

PDO_CURSOR_SCROLL

Scrollable cursor

The values for the attributes above are all defined in terms of the Zend API. The Zend API contains macros that can be used to convert a *zval to a value. These macros are defined in the Zend header file, zend_API.h in the Zend directory of your PHP build directory. Some of these attributes can be used with the statement attribute handlers such as the PDO_ATTR_CURSOR and PDO_ATTR_CURSOR_NAME. See the statement attribute handling functions for more information.

Předcházející | Nahoru | Další
pdo_stmt_t definition | Domů | Error handling


Error handling

Error handling is implemented using a hand-shaking protocol between PDO and the database driver code. The database driver code signals PDO that an error has occurred via a failure (0) return from any of the interface functions. If a zero is returned, set the field error_code in the control block appropriate to the context (either the pdo_dbh_t or pdo_stmt_t block). In practice, it is probably a good idea to set the field in both blocks to the same value to ensure the correct one is getting used.

The error_mode field is a six-byte field containing a 5 character ASCIIZ SQLSTATE identifier code. This code drives the error message process. The SQLSTATE code is used to look up an error message in the internal PDO error message table (see pdo_sqlstate.c for a list of error codes and their messages). If the code is not known to PDO, a default „Unknown Message“ value will be used.

In addition to the SQLSTATE code and error message, PDO will call the driver-specific fetch_err() routine to obtain supplemental data for the particular error condition. This routine is passed an array into which the driver may place additional information. This array has slot positions assigned to particular types of supplemental info:

  1. A native error code. This will frequently be an error code obtained from the database API.

  2. A descriptive string. This string can contain any additional information related to the failure. Database drivers typically include information such as an error message, code location of the failure, and any additional descriptive information the driver developer feels worthy of inclusion. It is generally a good idea to include all diagnostic information obtainable from the database interface at the time of the failure. For driver-detected errors (such as memory allocation problems), the driver developer can define whatever error information that seems appropriate.

Předcházející | Nahoru | Další
Constants | Domů | 55. Extension FAQs


Fleshing out your skeleton

Major Structures and Attributes

The major structures, pdo_dbh_t and pdo_stmt_t are defined and explained in Appendix A and B respectively. Database and Statement attributes are defined in Appendix C. Error handling is explained in Appendix D.

pdo_SKEL.c: PHP extension glue

function entries

static function_entry pdo_SKEL_functions[] = {
  { NULL, NULL, NULL }
};

This structure is used to register functions into the global php function namespace. PDO drivers should try to avoid doing this, so it is recommended that you leave this structure initialized to NULL, as shown in the synopsis above.

Module entry

/* {{{ pdo_SKEL_module_entry */
#if ZEND_EXTENSION_API_NO >= 220050617
static zend_module_dep pdo_SKEL_deps[] = {
    ZEND_MOD_REQUIRED("pdo")
    {NULL, NULL, NULL}
};
#endif
/* }}} */

zend_module_entry pdo_SKEL_module_entry = {
#if ZEND_EXTENSION_API_NO >= 220050617
    STANDARD_MODULE_HEADER_EX, NULL,
    pdo_SKEL_deps,
#else
    STANDARD_MODULE_HEADER,
#endif
    "pdo_SKEL",
    pdo_SKEL_functions,
    PHP_MINIT(pdo_SKEL),
    PHP_MSHUTDOWN(pdo_SKEL),
    NULL,
    NULL,
    PHP_MINFO(pdo_SKEL),
    PHP_PDO_<DB>_MODULE_VERSION,
    STANDARD_MODULE_PROPERTIES
};
/* }}} */

#ifdef COMPILE_DL_PDO_<DB>
ZEND_GET_MODULE(pdo_db)
#endif

A structure of type zend_module_entry called pdo_SKEL_module_entry must be declared and should include reference to the pdo_SKEL_functions table defined previously.

Standard PHP Module Extension Functions

PHP_MINIT_FUNCTION

/* {{{ PHP_MINIT_FUNCTION */
PHP_MINIT_FUNCTION(pdo_SKEL)
{
    return php_pdo_register_driver(&pdo_SKEL_driver);
}
/* }}} */

This standard PHP extension function should be used to register your driver with the PDO layer. This is done by calling the php_pdo_register_driver() function passing a pointer to a structure of type pdo_driver_t typically named pdo_SKEL_driver. A pdo_driver_t contains a header that is generated using the PDO_DRIVER_HEADER(SKEL) macro and pdo_SKEL_handle_factory() function pointer. The actual function is described during the discussion of the SKEL_dbh.c unit.

PHP_MSHUTDOWN_FUNCTION

/* {{{ PHP_MSHUTDOWN_FUNCTION */
PHP_MSHUTDOWN_FUNCTION(pdo_SKEL)
{
    php_pdo_unregister_driver(&pdo_SKEL_driver);
    return SUCCESS;
}
/* }}} */

This standard PHP extension function is used to unregister your driver from the PDO layer. This is done by calling the php_pdo_unregister_driver() function, passing the same pdo_SKEL_driver structure that was passed in the init function above.

PHP_MINFO_FUNCTION

This is again a standard PHP extension function. Its purpose is to display information regarding the module when the phpinfo() is called from a script. The convention is to display the version of the module and also what version of the db you are dependent on, along with any other configuration style information that might be relevant.

SKEL_driver.c: Driver implementation

This unit implements all of the database handling methods that support the PDO database handle object. It also contains the error fetching routines. All of these functions will typically need to access the global variable pool. Therefore, it is necessary to use the Zend macro TSRMLS_DC macro at the end of each of these statements. Consult the Zend programmer documentation for more information on this macro.

pdo_SKEL_error

static int pdo_SKEL_error(pdo_dbh_t *dbh,
  pdo_stmt_t *stmt, const char *file, int line TSRMLS_DC)

The purpose of this function is to be used as a generic error handling function within the driver. It is called by the driver when an error occurs within the driver. If an error occurs that is not related to SQLSTATE, the driver should set either dbh->error_code or stmt->error_code to an SQLSTATE that most closely matches the error or the generic SQLSTATE error „HY000“. The file pdo_sqlstate.c in the PDO source contains a table of commonly used SQLSTATE codes that the PDO code explicitly recognizes. This setting of the error code should be done prior to calling this function.; This function should set the global pdo_err variable to the error found in either the dbh or the stmt (if the variable stmt is not NULL).

dbh

Pointer to the database handle initialized by the handle factory

stmt

Pointer to the current statement or NULL. If NULL, the error is derived by error code found in the dbh.

file

The source file where the error occurred or NULL if not available.

line

The line number within the source file if available.

If the dbh member methods is NULL (which implies that the error is being raised from within the PDO constructor), this function should call the zend_throw_exception_ex() function otherwise it should return the error code. This function is usually called using a helper macro that customizes the calling sequence for either database handling errors or statement handling errors.

Příklad 54.1. Example macros for invoking pdo_SKEL_error

#define pdo_SKEL_drv_error(what) \
    pdo_SKEL_error(dbh, NULL, what, __FILE__, __LINE__ TSRMLS_CC)
#define pdo_SKEL_drv_error(what) \
    pdo_SKEL_error(dbh, NULL, what, __FILE__, __LINE__ TSRMLS_CC)

For more info on error handling, see „Error handling“.

Poznámka: Despite being documented here, the PDO driver interface does not specify that this function be present; it is merely a convenient way to handle errors, and it just happens to be equally convenient for the majority of database client library APIs to structure your driver implementation in this way.

pdo_SKEL_fetch_error_func

static int pdo_SKEL_fetch_error_func(pdo_dbh_t *dbh, pdo_stmt_t *stmt,
    zval *info TSRMLS_DC)

The purpose of this function is to obtain additional information about the last error that was triggered. This includes the driver specific error code and a human readable string. It may also include additional information if appropriate. This function is called as a result of the PHP script calling the PDO::errorInfo() method.

dbh

Pointer to the database handle initialized by the handle factory

stmt

Pointer to the most current statement or NULL. If NULL, the error translated is derived by error code found in the dbh.

info

A hash table containing error codes and messages.

The error_func should return two pieces of information as successive array elements. The first item is expected to be a numeric error code, the second item is a descriptive string. The best way to set this item is by using add_next_index. Note that the type of the first argument need not be long; use whichever type most closely matches the error code returned by the underlying database API.

/* now add the error information. */
/* These need to be added in a specific order */
add_next_index_long(info, error_code);   /* driver specific error code */
add_next_index_string(info, message, 0); /* readable error message */

This function should return 1 if information is available, 0 if the driver does not have additional info.

SKEL_handle_closer

static int SKEL_handle_closer(pdo_dbh_t *dbh TSRMLS_DC)

This function will be called by PDO to close an open database.

dbh

Pointer to the database handle initialized by the handle factory

This should do whatever database specific activity that needs to be accomplished to close the open database. PDO ignores the return value from this function.

SKEL_handle_preparer

static int SKEL_handle_preparer(pdo_dbh_t *dbh, const char *sql,
long sql_len, pdo_stmt_t *stmt, zval *driver_options TSRMLS_DC)

This function will be called by PDO in response to PDO::query() and PDO::prepare() calls from the PHP script. The purpose of the function is to prepare raw SQL for execution, storing whatever state is appropriate into the stmt that is passed in.

dbh

Pointer to the database handle initialized by the handle factory

sql

Pointer to a character string containing the SQL statement to be prepared.

sql_len

The length of the SQL statement.

Stmt

Pointer to the returned statement or NULL if an error occurs.

driver_options

Any driver specific/defined options.

This function is essentially the constructor for a stmt object. This function is responsible for processing statement options, and setting driver-specific option fields in the pdo_stmt_t structure.

PDO does not process any statement options on the driver's behalf before calling the preparer function. It is your responsibility to process them before you return, raising an error for any unknown options that are passed.

One very important responsibility of this function is the processing of SQL statement parameters. At the time of this call, PDO does not know if your driver supports binding parameters into prepared statements, nor does it know if it supports named or positional parameter naming conventions.

Your driver is responsible for setting stmt->supports_placeholders as appropriate for the underlying database. This may involve some run-time determination on the part of your driver, if this setting depends on the version of the database server to which it is connected. If your driver doesn't directly support both named and positional parameter conventions, you should use the pdo_parse_params() API to have PDO rewrite the query to take advantage of the support provided by your database.

Příklad 54.2. Using pdo_parse_params

    int ret;
    char *nsql = NULL;
    int nsql_len = 0;

    /* before we prepare, we need to peek at the query; if it uses named parameters,
     * we want PDO to rewrite them for us */
    stmt->supports_placeholders = PDO_PLACEHOLDER_POSITIONAL;
    ret = pdo_parse_params(stmt, (char*)sql, sql_len, &nsql, &nsql_len TSRMLS_CC);

    if (ret == 1) {
        /* query was re-written */
        sql = nsql;
    } else if (ret == -1) {
        /* couldn't grok it */
        strcpy(dbh->error_code, stmt->error_code);
        return 0;
    }

    /* now proceed to prepare the query in "sql" */

Possible values for supports_placeholders are: PDO_PLACEHOLDER_NAMED, PDO_PLACEHOLDER_POSITIONAL and PDO_PLACEHOLDER_NONE. If the driver doesn't support prepare statements at all, then this function should simply allocate any state that it might need, and then return:

Příklad 54.3. Implementing preparer for drivers that don't support native prepared statements

static int SKEL_handle_preparer(pdo_dbh_t *dbh, const char *sql,
    long sql_len, pdo_stmt_t *stmt, zval *driver_options TSRMLS_DC)
{
    pdo_SKEL_db_handle *H = (pdo_SKEL_db_handle *)dbh->driver_data;
    pdo_SKEL_stmt *S = ecalloc(1, sizeof(pdo_SKEL_stmt));

    S->H = H;
    stmt->driver_data = S;
    stmt->methods = &SKEL_stmt_methods;
    stmt->supports_placeholders = PDO_PLACEHOLDER_NONE;

    return 1;
}

This function returns 1 on success or 0 on failure.

SKEL_handle_doer

static long SKEL_handle_doer(pdo_dbh_t *dbh, const char *sql, long sql_len TSRMLS_DC)

This function will be called by PDO to execute a raw SQL statement. No pdo_stmt_t is created.

dbh

Pointer to the database handle initialized by the handle factory

sql

Pointer to a character string containing the SQL statement to be prepared.

sql_len

The length of the SQL statement.

This function returns 1 on success or 0 on failure.

SKEL_handle_quoter

static int SKEL_handle_quoter(pdo_dbh_t *dbh, const char *unquoted,
  int unquoted_len, char **quoted, int quoted_len, enum pdo_param_type param_type TSRMLS_DC)

This function will be called by PDO to turn an unquoted string into a quoted string for use in a query.

dbh

Pointer to the database handle initialized by the handle factory

unquoted

Pointer to a character string containing the string to be quoted.

unquoted_len

The length of the string to be quoted.

quoted

Pointer to the address where a pointer to the newly quoted string will be returned.

quoted_len

The length of the new string.

param_type

A driver specific hint for driver that have alternate quoting styles

This function is called in response to a call to PDO::quote() or when the driver has set supports_placeholder to PDO_PLACEHOLDER_NONE. The purpose is to quote a parameter when building SQL statements.

If your driver does not support native prepared statements, implementation of this function is required.

This function returns 1 if the quoting process reformatted the string, and 0 if it was not necessary to change the string. The original string will be used unchanged with a 0 return.

SKEL_handle_begin

static int SKEL_handle_begin(pdo_dbh_t *dbh TSRMLS_DC)

This function will be called by PDO to begin a database transaction.

dbh

Pointer to the database handle initialized by the handle factory

This should do whatever database specific activity that needs to be accomplished to begin a transaction. This function returns 1 for success or 0 if an error occurred.

SKEL_handle_commit

static int SKEL_handle_commit(pdo_dbh_t *dbh TSRMLS_DC)

This function will be called by PDO to end a database transaction.

dbh

Pointer to the database handle initialized by the handle factory

This should do whatever database specific activity that needs to be accomplished to commit a transaction. This function returns 1 for success or 0 if an error occurred.

SKEL_handle_rollback

static int SKEL_handle_rollback( pdo_dbh_t *dbh TSRMLS_DC)

This function will be called by PDO to rollback a database transaction.

dbh

Pointer to the database handle initialized by the handle factory

This should do whatever database specific activity that needs to be accomplished to rollback a transaction. This function returns 1 for success or 0 if an error occurred.

SKEL_handle_get_attribute

static int SKEL_handle_get_attribute(pdo_dbh_t *dbh, long attr, zval *return_value TSRMLS_DC)

This function will be called by PDO to retrieve a database attribute.

dbh

Pointer to the database handle initialized by the handle factory

attr

long value of one of the PDO_ATTR_xxxx types. See 54.1 – „Database and Statement Attributes Table“ for valid attributes.

return_value

The returned value for the attribute.

It is up to the driver to decide which attributes will be supported for a particular implementation. It is not necessary for a driver to supply this function. PDO driver handles the PDO_ATTR_PERSISTENT, PDO_ATTR_CASE, PDO_ATTR_ORACLE_NULLS, and PDO_ATTR_ERRMODE attributes directly.

This function returns 1 on success or 0 on failure.

SKEL_handle_set_attribute

static int SKEL_handle_set_attribute(pdo_dbh_t *dbh, long attr, zval *val TSRMLS_DC)

This function will be called by PDO to set a database attribute, usually in response to a script calling PDO::setAttribute().

dbh

Pointer to the database handle initialized by the handle factory

attr

long value of one of the PDO_ATTR_xxxx types. See 54.1 – „Database and Statement Attributes Table“ for valid attributes.

val

The new value for the attribute.

It is up to the driver to decide which attributes will be supported for a particular implementation. It is not necessary for a driver to provide this function if it does not need to support additional attributes. The PDO driver handles the PDO_ATTR_CASE, PDO_ATTR_ORACLE_NULLS, and PDO_ATTR_ERRMODE attributes directly.

This function returns 1 on success or 0 on failure.

SKEL_handle_last_id

static char * SKEL_handle_last_id(pdo_dbh_t *dbh, const char *name, unsigned int len TSRMLS_DC)

This function will be called by PDO to retrieve the ID of the last inserted row.

dbh

Pointer to the database handle initialized by the handle factory

name

string representing a table or sequence name.

len

the length of the name parameter.

This function returns a character string containing the id of the last inserted row on success or NULL on failure. This is an optional function.

SKEL_check_liveness

static int SKEL_check_liveness(pdo_dbh_t *dbh TSRMLS_DC)

This function will be called by PDO to test whether or not a persistent connection to a database is alive and ready for use.

dbh

Pointer to the database handle initialized by the handle factory

This function returns 1 if the database connection is alive and ready for use, otherwise it should return 0 to indicate failure or lack of support.

Poznámka: This is an optional function.

SKEL_get_driver_methods

static function_entry *SKEL_get_driver_methods(pdo_dbh_t *dbh, int kind TSRMLS_DC)

This function will be called by PDO in response to a call to any method that is not a part of either the PDO or PDOStatement classes. It's purpose is to allow the driver to provide additional driver specific methods to those classes.

dbh

Pointer to the database handle initialized by the handle factory

kind

One of the following:

PDO_DBH_DRIVER_METHOD_KIND_DBH

Set when the method call was attempted on an instance of the PDO class. The driver should return a pointer a function_entry table for any methods it wants to add to that class, or NULL if there are none.

PDO_DBH_DRIVER_METHOD_KIND_STMT

Set when the method call was attempted on an instance of the PDOStatement class. The driver should return a pointer to a function_entry table for any methods it wants to add to that class, or NULL if there are none.

This function returns a pointer to the function_entry table requested, or NULL there are no driver specific methods.

SKEL_handle_factory

static int SKEL_handle_factory(pdo_dbh_t *dbh, zval *driver_options TSRMLS_DC)

This function will be called by PDO to create a database handle. For most databases this involves establishing a connection to the database. In some cases, a persistent connection may be requested, in other cases connection pooling may be requested. All of these are database/driver dependent.

dbh

Pointer to the database handle initialized by the handle factory

driver_options

An array of driver options, keyed by integer option number. See 54.1 – „Database and Statement Attributes Table“ for a list of possible attributes.

This function should fill in the passed database handle structure with its driver specific information on success and return 1, otherwise it should return 0 to indicate failure.

PDO processes the AUTOCOMMIT and PERSISTENT driver options before calling the handle_factory. It is the handle factory's responsibility to process other options.

Driver method table

A static structure of type pdo_dbh_methods named SKEL_methods must be declared and initialized to the function pointers for each defined function. If a function is not supported or not implemented the value for that function pointer should be set to NULL.

pdo_SKEL_driver

A structure of type pdo_driver_t named pdo_SKEL_driver should be declared. The PDO_DRIVER_HEADER(SKEL) macro should be used to declare the header and the function pointer to the handle factory function should set.

SKEL_statement.c: Statement implementation

This unit implements all of the database statement handling methods that support the PDO statement object.

SKEL_stmt_dtor

static int SKEL_stmt_dtor(pdo_stmt_t *stmt TSRMLS_DC)

This function will be called by PDO to destroy a previously constructed statement object.

stmt

Pointer to the statement structure initialized by SKEL_handle_preparer.

This should do whatever is necessary to free up any driver specific storage allocated for the statement. The return value from this function is ignored.

SKEL_stmt_execute

static int SKEL_stmt_execute(pdo_stmt_t *stmt TSRMLS_DC)

This function will be called by PDO to execute the prepared SQL statement in the passed statement object.

stmt

Pointer to the statement structure initialized by SKEL_handle_preparer.

This function returns 1 for success or 0 in the event of failure.

SKEL_stmt_fetch

static int SKEL_stmt_fetch(pdo_stmt_t *stmt, enum pdo_fetch_orientation ori,
   long offset TSRMLS_DC)

This function will be called by PDO to fetch a row from a previously executed statement object.

stmt

Pointer to the statement structure initialized by SKEL_handle_preparer.

ori

One of PDO_FETCH_ORI_xxx which will determine which row will be fetched.

offset

If ori is set to PDO_FETCH_ORI_ABS or PDO_FETCH_ORI_REL, offset represents the row desired or the row relative to the current position, respectively. Otherwise, this value is ignored.

The results of this fetch are driver dependent and the data is usually stored in the driver_data member of the pdo_stmt_t object. The ori and offset parameters are only meaningful if the statement represents a scrollable cursor. This function returns 1 for success or 0 in the event of failure.

SKEL_stmt_param_hook

static int SKEL_stmt_param_hook(pdo_stmt_t *stmt,
  struct pdo_bound_param_data *param, enum pdo_param_event event_type TSRMLS_DC)

This function will be called by PDO for handling of both bound parameters and bound columns.

stmt

Pointer to the statement structure initialized by SKEL_handle_preparer.

param

The structure describing either a statement parameter or a bound column.

event_type

The type of event to occur for this parameter, one of the following:

PDO_PARAM_EVT_ALLOC

Called when PDO allocates the binding. Occurs as part of PDOStatement::bindParam(), PDOStatement::bindValue() or as part of an implicit bind when calling PDOStatement::execute(). This is your opportunity to take some action at this point; drivers that implement native prepared statements will typically want to query the parameter information, reconcile the type with that requested by the script, allocate an appropriately sized buffer and then bind the parameter to that buffer. You should not rely on the type or value of the zval at param->parameter at this point in time.

PDO_PARAM_EVT_FREE

Called once per parameter as part of cleanup. You should release any resources associated with that parameter now.

PDO_PARAM_EXEC_PRE

Called once for each parameter immediately before calling SKEL_stmt_execute; take this opportunity to make any final adjustments ready for execution. In particular, you should note that variables bound via PDOStatement::bindParam() are only legal to touch now, and not any sooner.

PDO_PARAM_EXEC_POST

Called once for each parameter immediately after calling SKEL_stmt_execute; take this opportunity to make any post-execution actions that might be required by your driver.

PDO_PARAM_FETCH_PRE

Called once for each parameter immediately prior to calling SKEL_stmt_fetch.

PDO_PARAM_FETCH_POST

Called once for each parameter immediately after calling SKEL_stmt_fetch.

This hook will be called for each bound parameter and bound column in the statement. For ALLOC and FREE events, a single call will be made for each parameter or column. The param structure contains a driver_data field that the driver can use to store implementation specific information about each of the parameters.

For all other events, PDO may call you multiple times as the script issues PDOStatement::execute() and PDOStatement::fetch() calls.

If this is a bound parameter, the is_param flag in the param structure is set, otherwise the param structure refers to a bound column.

This function returns 1 for success or 0 in the event of failure.

SKEL_stmt_describe_col

static int SKEL_stmt_describe_col(pdo_stmt_t *stmt, int colno TSRMLS_DC)

This function will be called by PDO to query information about a particular column.

stmt

Pointer to the statement structure initialized by SKEL_handle_preparer.

colno

The column number to be queried.

The driver should populate the pdo_stmt_t member columns(colno) with the appropriate information. This function returns 1 for success or 0 in the event of failure.

SKEL_stmt_get_col_data

static int SKEL_stmt_get_col_data(pdo_stmt_t *stmt, int colno,
  char **ptr, unsigned long *len, int *caller_frees TSRMLS_DC)

This function will be called by PDO to retrieve data from the specified column.

stmt

Pointer to the statement structure initialized by SKEL_handle_preparer.

colno

The column number to be queried.

ptr

Pointer to the retrieved data.

len

The length of the data pointed to by ptr.

caller_frees

If set, ptr should point to emalloc'd memory and the main PDO driver will free it as soon as it is done with it. Otherwise, it will be the responsibility of the driver to free any allocated memory as a result of this call.

The driver should return the resultant data and length of that data in the ptr and len variables respectively. It should be noted that the main PDO driver expects the driver to manage the lifetime of the data. This function returns 1 for success or 0 in the event of failure.

SKEL_stmt_set_attr

static int SKEL_stmt_set_attr(pdo_stmt_t *stmt, long attr, zval *val TSRMLS_DC)

This function will be called by PDO to allow the setting of driver specific attributes for a statement object.

stmt

Pointer to the statement structure initialized by SKEL_handle_preparer.

attr

long value of one of the PDO_ATTR_xxxx types. See 54.1 – „Database and Statement Attributes Table“ for valid attributes.

val

The new value for the attribute.

This function is driver dependent and allows the driver the capability to set database specific attributes for a statement. This function returns 1 for success or 0 in the event of failure. This is an optional function. If the driver does not support additional settable attributes, it can be NULLed in the method table. The PDO driver does not handle any settable attributes on the database driver's behalf.

SKEL_stmt_get_attr

static int SKEL_stmt_get_attr(pdo_stmt_t *stmt, long attr, zval
   *return_value TSRMLS_DC)

This function will be called by PDO to allow the retrieval of driver specific attributes for a statement object.

stmt

Pointer to the statement structure initialized by SKEL_handle_preparer.

attr

long value of one of the PDO_ATTR_xxxx types. See 54.1 – „Database and Statement Attributes Table“ for valid attributes.

return_value

The returned value for the attribute.

This function is driver dependent and allows the driver the capability to retrieve a previously set database specific attribute for a statement. This function returns 1 for success or 0 in the event of failure. This is an optional function. If the driver does not support additional gettable attributes, it can be NULLed in the method table. The PDO driver does not handle any settable attributes on the database driver's behalf.

SKEL_stmt_get_col_meta

static int SKEL_stmt_get_col_meta(pdo_stmt_t *stmt, int colno,
   zval *return_value TSRMLS_DC)
Varování

This function is not well defined and is subject to change.

This function will be called by PDO to retrieve meta data from the specified column.

stmt

Pointer to the statement structure initialized by SKEL_handle_preparer.

colno

The column number for which data is to be retrieved.

return_value

Holds the returned meta data.

The driver author should consult the documentation for this function that can be found in the php_pdo_driver.h header as this will be the most current. This function returns 1 for success or 0 in the event of failure. The database driver does not need to provide this function.

Statement handling method table

A static structure of type pdo_stmt_methods named SKEL_stmt_methods should be declared and initialized to the function pointers for each defined function. If a function is not supported or not implemented the value for that function pointer should be set to NULL.

Předcházející | Nahoru | Další
Preparation and Housekeeping | Domů | Building


Packaging and distribution

Creating a package

PDO drivers are released via PECL; all the usual rules for PECL extensions apply. Packaging is accomplished by creating a valid package.xml file and then running:

$ pecl package

This will create a tarball named PDO_SKEL-X.Y.Z.tgz.

Before releasing the package, you should test that it builds correctly; if you've made a mistake in your config.m4 or package.xml files, the package may not function correctly. You can test the build, without installing anything, using the following invocation:

$ pecl build package.xml

Once this is proven to work, you can test installation:

$ pecl package
$ sudo pecl install PDO_SKEL-X.Y.X.tgz

Full details about package.xml can be found in the PEAR Programmer's documentation (» http://pear.php.net/manual/).

Releasing the package

A PDO driver is released via the PHP Extension Community Library (PECL). Information about PECL can be found at » http://pecl.php.net/index.php.

Předcházející | Nahoru | Další
Testing | Domů | pdo_dbh_t definition


pdo_dbh_t definition

All fields should be treated as read-only by the driver, unless explicitly stated otherwise.

Obrázek 54.1. pdo_dbh_t

/* represents a connection to a database */
struct _pdo_dbh_t {
    /* driver specific methods */
    struct pdo_dbh_methods *methods;
    /* driver specific data */
    void *driver_data;

    /* credentials */
    char *username, *password;

    /* if true, then data stored and pointed at by this handle must all be
     * persistently allocated */
    unsigned is_persistent:1;

    /* if true, driver should act as though a COMMIT were executed between
     * each executed statement; otherwise, COMMIT must be carried out manually
     * */
    unsigned auto_commit:1;

    /* if true, the driver requires that memory be allocated explicitly for
     * the columns that are returned */
    unsigned alloc_own_columns:1;

    /* if true, commit or rollBack is allowed to be called */
    unsigned in_txn:1;

    /* max length a single character can become after correct quoting */
    unsigned max_escaped_char_length:3;

    /* data source string used to open this handle */
    const char *data_source;
    unsigned long data_source_len;

    /* the global error code. */
    pdo_error_type error_code;

    enum pdo_case_conversion native_case, desired_case;
};

1

The driver must set this during SKEL_handle_factory().

2

This item is for use by the driver; the intended usage is to store a pointer (during SKEL_handle_factory()) to whatever instance data is required to maintain a connection to the database.

3

The username and password that were passed into the PDO constructor. The driver should use these values when it initiates a connection to the database.

4

If this is set to 1, then any data that is referenced by the dbh, including whatever structure your driver allocates, MUST be allocated persistently. This is easy to achieve; rather than using the usual emalloc() simply use pemalloc() and pass the value of this flag as the last parameter. Failure to use the appropriate kind of memory can lead to serious memory faults, resulting (in the best case) a hard crash, and in the worst case, an exploitable memory problem.

If, for whatever reason, your driver is not suitable to run persistently, you MUST check this flag in your SKEL_handle_factory() and raise an appropriate error.

5

You should check this value in your SKEL_handle_doer() and SKEL_stmt_execute() functions; if it evaluates to true, you must attempt to commit the query now. Most database implementations offer an auto-commit mode that handles this automatically.

6

If your database client library API operates by fetching data into a caller-supplied buffer, you should set this flag to 1 during your SKEL_handle_factory(). When set, PDO will call your SKEL_stmt_describer() earlier than it would otherwise. This early call allows you to determine those buffer sizes and issue appropriate calls to the database client library.

If your database client library API simply returns pointers to its own internal buffers for you to copy after each fetch call, you should leave this value set to 0.

7

If your driver doesn't support native prepared statements (supports_placeholders is set to PDO_PLACEHOLDER_NONE), you must set this value to the maximum length that can be taken up by a single character when it is quoted by your SKEL_handle_quoter() function. This value is used to calculate the amount of buffer space required when PDO executes the statement.

8

This holds the value of the DSN that was passed into the PDO constructor. If your driver implementation needed to modify the DSN for whatever reason, it should update this member during SKEL_handle_factory(). Modifying this member should be avoided. If you do change it, you must ensure that data_source_len is also correct.

9

Whenever an error occurs during a call to one of your driver methods, you should set this member to the SQLSTATE code that best describes the error and return an error. In this HOW-TO, the suggested practice is to call SKEL_handle_error() when an error is detected, and have it set the error code.

10

Your driver should set this during SKEL_handle_factory(); the value should reflect how the database returns the names of the columns in result sets. If the name matches the case that was used in the query, set it to PDO_CASE_NATURAL (this is actually the default). If the column names are always returned in upper case, set it to PDO_CASE_UPPER. If the column names are always returned in lower case, set it to PDO_CASE_LOWER. The value you set is used to determine if PDO should perform case folding when the user sets the PDO_ATTR_CASE attribute.

Předcházející | Nahoru | Další
Packaging and distribution | Domů | pdo_stmt_t definition


pdo_stmt_t definition

All fields should be treated as read-only unless explicitly stated otherwise.

Obrázek 54.2. pdo_stmt_t

/* represents a prepared statement */
struct _pdo_stmt_t {
    /* driver specifics */
    struct pdo_stmt_methods *methods;
    void *driver_data;

    /* if true, we've already successfully executed this statement at least
     * once */
    unsigned executed:1;
    /* if true, the statement supports placeholders and can implement
     * bindParam() for its prepared statements, if false, PDO should
     * emulate prepare and bind on its behalf */
    unsigned supports_placeholders:2;

    /* the number of columns in the result set; not valid until after
     * the statement has been executed at least once.  In some cases, might
     * not be valid until fetch (at the driver level) has been called at least once.
     * */
    int column_count;
    struct pdo_column_data *columns;

    /* points at the dbh that this statement was prepared on */
    pdo_dbh_t *dbh;

    /* keep track of bound input parameters.  Some drivers support
     * input/output parameters, but you can't rely on that working */
    HashTable *bound_params;
    /* When rewriting from named to positional, this maps positions to names */
    HashTable *bound_param_map;
    /* keep track of PHP variables bound to named (or positional) columns
     * in the result set */
    HashTable *bound_columns;

    /* not always meaningful */
    long row_count;

    /* used to hold the statement's current query */
    char *query_string;
    int query_stringlen;

    /* the copy of the query with expanded binds ONLY for emulated-prepare drivers */
    char *active_query_string;
    int active_query_stringlen;

    /* the cursor specific error code. */
    pdo_error_type error_code;

    /* used by the query parser for driver specific
     * parameter naming (see pgsql driver for example) */
    const char *named_rewrite_template;
};

1 | The driver must set this during SKEL_handle_preparer().
2 | This item is for use by the driver; the intended usage is to store a pointer (during SKEL_handle_factory()) to whatever instance data is required to maintain a connection to the database.
3 | This is set by PDO after the statement has been executed for the first time. Your driver can inspect this value to determine if it can skip one-time actions as an optimization.
4 | Discussed in more detail in „SKEL_handle_preparer“.
5 | Your driver is responsible for setting this field to the number of columns available in a result set. This is usually set during SKEL_stmt_execute() but with some database implementations, the column count may not be available until SKEL_stmt_fetch() has been called at least once. Drivers that implement SKEL_stmt_next_rowset() should update the column count when a new rowset is available.
6 | PDO will allocate this field based on the value that you set for the column count. You are responsible for populating each column during SKEL_stmt_describe(). You must set the precision, maxlen, name, namelen and param_type members for each column. The name is expected to be allocated using emalloc(); PDO will call efree() at the appropriate time.
Předcházející | Nahoru | Další
pdo_dbh_t definition | Domů | Constants


Preparation and Housekeeping

Source directory layout

The source directory for a typical PDO driver is laid out as follows, where SKEL represents a shortened form of the name of the database that the driver is going to connect to. Even though SKEL is presented here in uppercase (for clarity), the convention is to use lowercase characters.

pdo_SKEL/
  config.m4                  # unix build script
  config.w32                 # win32 build script
  CREDITS
  package.xml                # meta information about the package
  pdo_SKEL.c                 # standard PHP extension glue
  php_pdo_SKEL.h
  php_pdo_SKEL_int.h         # driver private header
  SKEL_dbh.c                 # contains the implementation of the PDO driver interface
  SKEL_stmt.c                # contains the implementation of the PDO statement interface
  tests/

The contents of these files are defined later in this document.

Creating a skeleton

The easiest way to get started is to use the ext_skel shell script found in the PHP build tree in the ext directory. This will build a skeleton directory containing a lot of the files listed above. It can be build by executing the following command from within the ext directory:

./ext_skel --extname=pdo_SKEL

This will generate a directory called pdo_SKEL containing the skeleton files that you can then modify. This directory should then be moved out of the php extension directory . PDO is a PECL extension and should not be included in the standard extension directory. As long as you have PHP and PDO installed, you should be able to build from any directory.

Standard Includes

Build Specific Headers

The header file config.h is generated by the configure process for the platform for the which the driver is being built. If this header is present, the HAVE_CONFIG_H compiler variable is set. This variable should be tested for and if set, the file config.h should be included in the compilation unit.

PHP Headers

The following standard public php headers should be included in each source module:

  1. php.h

  2. php_ini.h

  3. ext/standard/info.h

PDO Interface Headers

The following standard public PDO header files are also included in each source module:

pdo/php_pdo.h

This header file contains definitions of the initialization and shutdown functions in the main driver as well as definitions of global PDO variables.

pdo/php_pdo_driver.h

This header contains the types and API contracts that are used to write a PDO driver. It also contains method signature for calling back into the PDO layer and registering/unregistering your driver with PDO. Most importantly, this header file contains the type definitions for PDO database handles and statements. The two main structures a driver has to deal with, pdo_dbh_t and pdo_stmt_t, are described in more detail in Appendix A and B.

Driver Specific Headers

The typical PDO driver has two header files that are specific to the database implementation. This does not preclude the use of more depending on the implementation. The following two headers are, by convention, standard:

php_pdo_SKEL.h

This header file is virtually an exact duplicate in functionality and content of the previously defined pdo/php_pdo.h that has been specifically tailored for your database. If your driver requires the use of global variables they should be defined using the ZEND_BEGIN_MODULE_GLOBALS and ZEND_END_MODULE_GLOBALS macros. Macros are then used to access these variables. This macro is usually named PDO_SKEL_G(v) where v is global variable to be accessed. Consult the Zend programmer documentation for more information.

php_pdo_SKEL_int.h

This header file typically contains type definitions and function declarations specific to the driver implementation. It also should contain the db specific definitions of a pdo_SKEL_handle and pdo_SKEL_stmt structures. These are the names of the private data structures that are then referenced by the driver_data members of the handle and statement structures.

Optional Headers

Depending on the implementation details for a particular driver it may be necessary to include the following header:

#include <zend_exceptions.h>

Předcházející | Nahoru | Další
54. PDO Driver How-To | Domů | Fleshing out your skeleton


Testing

PDO has a set of "core" tests that all drivers should pass before being released. They're designed to run from the PHP source distribution, so running the tests for your driver requires moving things around a bit. The suggested procedure is to obtain the latest PHP 5.1 snapshot and perform the following step:

$ cp -r pdo_SKEL /path/to/php-5.1/ext

This will allow the test harness to run your tests. The next thing you need to do is create a test that will redirect into the PDO common core tests. The convention is to name this file common.phpt; it should be placed in the tests subdirectory that was created by ext_skel when you created your extension skeleton. The content of this file should look something like the following:

--TEST--
SKEL
--SKIPIF--
<?php # vim:ft=php
if (!extension_loaded('pdo_SKEL')) print 'skip'; ?>
--REDIRECTTEST--
if (false !== getenv('PDO_SKEL_TEST_DSN')) {
# user set them from their shell
   $config['ENV']['PDOTEST_DSN'] = getenv('PDO_SKEL_TEST_DSN');
   $config['ENV']['PDOTEST_USER'] = getenv('PDO_SKEL_TEST_USER');
   $config['ENV']['PDOTEST_PASS'] = getenv('PDO_SKEL_TEST_PASS');
   if (false !== getenv('PDO_SKEL_TEST_ATTR')) {
      $config['ENV']['PDOTEST_ATTR'] = getenv('PDO_SKEL_TEST_ATTR');
   }
   return $config;
}
return array(
   'ENV' => array(
           'PDOTEST_DSN' => 'SKEL:dsn',
           'PDOTEST_USER' => 'username',
           'PDOTEST_PASS' => 'password'
       ),
   'TESTS' => 'ext/pdo/tests'
   );

This will cause the common core tests to be run, passing the values of PDOTEST_DSN, PDOTEST_USER and PDOTEST_PASS to the PDO constructor as the dsn, username and password parameters. It will first check the environment, so that appropriate values can be passed in when the test harness is run, rather than hard-coding the database credentials into the test file.

The test harness can be invoked as follows:

$ cd /path/to/php-5.1
$ make TESTS=ext/pdo_SKEL/tests PDO_SKEL_TEST_DSN="skel:dsn" \
 PDO_SKEL_TEST_USER=user PDO_SKEL_TEST_PASS=pass test

Předcházející | Nahoru | Další
Building | Domů | Packaging and distribution


Kapitola 51. Working with resources

Předcházející | Nahoru | Další
50. Working with classes and objects | Domů | 52. Working with INI settings


Kapitola 53. Working with streams

Předcházející | Nahoru | Další
52. Working with INI settings | Domů | 54. PDO Driver How-To


Kapitola 46. Extension structure

Obsah

Files which make up an extension
The zend_module structure
Extension globals
Life cycle of an extension
Testing an extension

Many extension-writing guides focus on simple examples first and ignore the requirements of more complex implementations until later. Often such guides must repeat themselves over and over in order to describe these new features. This section describes extension structure from the perspective of a mature, practical implementation, in order to prepare users for needs and issues they will almost always encounter in the process of extension development.

Files which make up an extension

Whether created by hand, using ext_skel, or by an alternate extension generator, such as » CodeGen, all extensions will have at least four files:

config.m4

UNIX build system configuration (see „Talking to the UNIX build system: config.m4“)

config.w32

Windows buildsystem configuration (see „Talking to the Windows build system: config.w32“)

php_example.h

When building an extension as static module into the PHP binary the build system expects a header file with php_ prepended to the extension name which includes a declaration for a pointer to the extension's module structure. This file usually contains additional macros, prototypes, and globals, just like any header.

example.c

Main extension source file. By convention, the name of this file is the extension name, but this is not a requirement. This file contains the module structure declaration, INI entries, management functions, userspace functions, and other requirements of an extension.

The buildsystem files are discussed elsewhere; this section concentrates on the rest. These four files make up the bare minimum for an extension, which may also contain any number of headers, source files, unit tests, and other support files. The list of files in a realistic extension might look like this:

Příklad 46.1. Files in an example "real" extension, in no particular order

ext/
 example/
  .cvsignore
  config.m4
  config.w32
  example_util.h
  example_util.c
  php_example.h
  example.c
  package.xml
  CREDITS
  tests/
   critical_function_001.phpt
   critical_function_002.phpt
   optional_function_001.phpt
   optional_function_002.phpt

Non-source files

The .cvsignore file is used for extensions which are checked into one of the PHP CVS repositories (usually » PECL); the one generated by ext_skel contains:

.deps
*.lo
*.la

These lines tell CVS to ignore interim files generated by the PHP buildsystem. This is only a convenience, and can be omitted completely without ill effect.

The CREDITS file lists the contributors and/or maintainers of the extension in plain text format. The main purpose of this file is generating the credits information for bundled extensions as used by phpcredits(). By convention the first line of the file should hold the name of the extension, the second a comma separated list of contributors. The contributors are usually ordered by the chronological order of their contributions. In a » PECL package, this information is already maintained in package.xml, for example. This is another file which can be omitted without ill effect.

The package.xml file is specific to » PECL-based extensions; it is a metainformation file which gives details about an extension's dependencies, authors, installation requirements, and other tidbits. In an extension not being hosted in » PECL, this file is extraneous.

Předcházející | Nahoru | Další
Talking to the Windows build system: config.w32 | Domů | The zend_module structure


Extension globals

Předcházející | Nahoru | Další
The zend_module structure | Domů | Life cycle of an extension


Life cycle of an extension

Předcházející | Nahoru | Další
Extension globals | Domů | Testing an extension


The zend_module structure

The main source file of a PHP extension contains several new constructs for a C programmer. The most important of these, the one touched first when starting a new extension, is the zend_module structure. This structure contains a wealth of information that tells the Zend Engine about the extension's dependencies, version, callbacks, and other critical data. The structure has mutated considerably over time; this section will focus on the structure as it has appeared since PHP 5.0, and will identify the very few parts which have changed in PHP 5.1 and 5.2.

The zend_module declaration from example.c looks like this before any code has been written (the example file was generated by ext_skel --extname=example):

Příklad 46.2. zend_module declaration in an example extension

/* {{{ example_module_entry
 */
zend_module_entry example_module_entry = {
#if ZEND_MODULE_API_NO >= 20010901
    STANDARD_MODULE_HEADER,
#endif
    "example",
    example_functions,
    PHP_MINIT(example),
    PHP_MSHUTDOWN(example),
    PHP_RINIT(example),        /* Replace with NULL if there's nothing to do at request start */
    PHP_RSHUTDOWN(example),    /* Replace with NULL if there's nothing to do at request end */
    PHP_MINFO(example),
#if ZEND_MODULE_API_NO >= 20010901
    "0.1", /* Replace with version number for your extension */
#endif
    STANDARD_MODULE_PROPERTIES
};
/* }}} */

This may look a bit daunting at first glance, but most of it is very simple to understand. Here's the declaration of zend_module from zend_modules.h in PHP 5.2, along with a few relevant nearby constants:

Příklad 46.3. zend_module definition in PHP 5.2

#define ZEND_MODULE_API_NO 20060613
struct _zend_module_entry {
    unsigned short size;
    unsigned int zend_api;
    unsigned char zend_debug;
    unsigned char zts;
    struct _zend_ini_entry *ini_entry;
    struct _zend_module_dep *deps;
    char *name;
    struct _zend_function_entry *functions;
    int (*module_startup_func)(INIT_FUNC_ARGS);
    int (*module_shutdown_func)(SHUTDOWN_FUNC_ARGS);
    int (*request_startup_func)(INIT_FUNC_ARGS);
    int (*request_shutdown_func)(SHUTDOWN_FUNC_ARGS);
    void (*info_func)(ZEND_MODULE_INFO_FUNC_ARGS);
    char *version;
    size_t globals_size;
#ifdef ZTS
    ts_rsrc_id* globals_id_ptr;
#else
    void* globals_ptr;
#endif
    void (*globals_ctor)(void *global TSRMLS_DC);
    void (*globals_dtor)(void *global TSRMLS_DC);
    int (*post_deactivate_func)(void);
    int module_started;
    unsigned char type;
    void *handle;
    int module_number;
};
#define STANDARD_MODULE_HEADER_EX sizeof(zend_module_entry), ZEND_MODULE_API_NO, ZEND_DEBUG, USING_ZTS
#define STANDARD_MODULE_HEADER \
    STANDARD_MODULE_HEADER_EX, NULL, NULL
#define ZE2_STANDARD_MODULE_HEADER \
    STANDARD_MODULE_HEADER_EX, ini_entries, NULL

#define STANDARD_MODULE_PROPERTIES_EX 0, 0, NULL, 0

Předcházející | Nahoru | Další
46. Extension structure | Domů | Extension globals


Testing an extension

Předcházející | Nahoru | Další
Life cycle of an extension | Domů | 47. Memory management


Kapitola 48. Working with variables

Předcházející | Nahoru | Další
47. Memory management | Domů | 49. Writing functions


Kapitola 57. Zend Engine 1

Obsah

Old introduction
Streams API for PHP Extension Authors
Zend API: 'Hackování' jádra PHP
TSRM API

Zend Engine 1 is the internal engine used by PHP for the entire version 4 release line. It is no longer considered active, but PHP 4 is still in widespread use, so the old ZE1 documentation is preserved here exactly as it was.

Old introduction

If you are about to begin developing PHP or Zend extensions, you need to prepare yourself for the programming environment provided by the various APIs. This part of the documentation tries to introduce the APIs provided by the different PHP and Zend Engine versions available. Since most of the information available here is somewhat outdated, you'll want to read various files found in the PHP source, files such as README.SELF-CONTAINED-EXTENSIONS and README.EXT_SKEL in addition to the manual.

Předcházející | Nahoru | Další
56. Zend Engine 2 API reference | Domů | Streams API for PHP Extension Authors


Streams API for PHP Extension Authors

Overview

The PHP Streams API introduces a unified approach to the handling of files and sockets in PHP extension. Using a single API with standard functions for common operations, the streams API allows your extension to access files, sockets, URLs, memory and script-defined objects. Streams is a run-time extensible API that allows dynamically loaded modules (and scripts!) to register new streams.

The aim of the Streams API is to make it comfortable for developers to open files, URLs and other streamable data sources with a unified API that is easy to understand. The API is more or less based on the ANSI C stdio family of functions (with identical semantics for most of the main functions), so C programmers will have a feeling of familiarity with streams.

The streams API operates on a couple of different levels: at the base level, the API defines php_stream objects to represent streamable data sources. On a slightly higher level, the API defines php_stream_wrapper objects which "wrap" around the lower level API to provide support for retrieving data and meta-data from URLs. An additional context parameter, accepted by most stream creation functions, is passed to the wrapper's stream_opener method to fine-tune the behavior of the wrapper.

Any stream, once opened, can also have any number of filters applied to it, which process data as it is read from/written to the stream.

Streams can be cast (converted) into other types of file-handles, so that they can be used with third-party libraries without a great deal of trouble. This allows those libraries to access data directly from URL sources. If your system has the fopencookie() or funopen() function, you can even pass any PHP stream to any library that uses ANSI stdio!

Poznámka: The functions in this chapter are for use in the PHP source code and are not PHP functions. Userland stream functions can be found in the Stream Reference.

Streams Basics

Using streams is very much like using ANSI stdio functions. The main difference is in how you obtain the stream handle to begin with. In most cases, you will use php_stream_open_wrapper() to obtain the stream handle. This function works very much like fopen, as can be seen from the example below:

Příklad 57.1. simple stream example that displays the PHP home page

php_stream * stream = php_stream_open_wrapper("http://www.php.net", "rb", REPORT_ERRORS, NULL);
if (stream) {
    while(!php_stream_eof(stream)) {
        char buf[1024];

        if (php_stream_gets(stream, buf, sizeof(buf))) {
            printf(buf);
        } else {
            break;
        }
    }
    php_stream_close(stream);
}

The table below shows the Streams equivalents of the more common ANSI stdio functions. Unless noted otherwise, the semantics of the functions are identical.

Tabulka 57.1. ANSI stdio equivalent functions in the Streams API

ANSI Stdio Function | PHP Streams Function | Notes
fopen | php_stream_open_wrapper | Streams includes additional parameters
fclose | php_stream_close |
fgets | php_stream_gets |
fread | php_stream_read | The nmemb parameter is assumed to have a value of 1, so the prototype looks more like read(2)
fwrite | php_stream_write | The nmemb parameter is assumed to have a value of 1, so the prototype looks more like write(2)
fseek | php_stream_seek |
ftell | php_stream_tell |
rewind | php_stream_rewind |
feof | php_stream_eof |
fgetc | php_stream_getc |
fputc | php_stream_putc |
fflush | php_stream_flush |
puts | php_stream_puts | Same semantics as puts, NOT fputs
fstat | php_stream_stat | Streams has a richer stat structure

Streams as Resources

All streams are registered as resources when they are created. This ensures that they will be properly cleaned up even if there is some fatal error. All of the filesystem functions in PHP operate on streams resources - that means that your extensions can accept regular PHP file pointers as parameters to, and return streams from their functions. The streams API makes this process as painless as possible:

Příklad 57.2. How to accept a stream as a parameter

PHP_FUNCTION(example_write_hello)
{
    zval *zstream;
    php_stream *stream;

    if (FAILURE == zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC, "r", &zstream))
        return;

    php_stream_from_zval(stream, &zstream);

    /* you can now use the stream.  However, you do not "own" the
        stream, the script does.  That means you MUST NOT close the
        stream, because it will cause PHP to crash! */

    php_stream_write(stream, "hello\n");

    RETURN_TRUE();
}

Příklad 57.3. How to return a stream from a function

PHP_FUNCTION(example_open_php_home_page)
{
    php_stream *stream;

    stream = php_stream_open_wrapper("http://www.php.net", "rb", REPORT_ERRORS, NULL);

    php_stream_to_zval(stream, return_value);

    /* after this point, the stream is "owned" by the script.
        If you close it now, you will crash PHP! */
}

Since streams are automatically cleaned up, it's tempting to think that we can get away with being sloppy programmers and not bother to close the streams when we are done with them. Although such an approach might work, it is not a good idea for a number of reasons: streams hold locks on system resources while they are open, so leaving a file open after you have finished with it could prevent other processes from accessing it. If a script deals with a large number of files, the accumulation of the resources used, both in terms of memory and the sheer number of open files, can cause web server requests to fail. Sounds bad, doesn't it? The streams API includes some magic that helps you to keep your code clean - if a stream is not closed by your code when it should be, you will find some helpful debugging information in you web server error log.

Poznámka: Always use a debug build of PHP when developing an extension (--enable-debug when running configure), as a lot of effort has been made to warn you about memory and stream leaks.

In some cases, it is useful to keep a stream open for the duration of a request, to act as a log or trace file for example. Writing the code to safely clean up such a stream is not difficult, but it's several lines of code that are not strictly needed. To save yourself the trouble of writing the code, you can mark a stream as being OK for auto cleanup. What this means is that the streams API will not emit a warning when it is time to auto-cleanup a stream. To do this, you can use php_stream_auto_cleanup().

Streams open options

These constants affect the operation of stream factory functions.

IGNORE_PATH
This is the default option for streams; it requests that the include_path is not to be searched for the requested file.
USE_PATH
Requests that the include_path is to be searched for the requested file.
IGNORE_URL
Requests that registered URL wrappers are to be ignored when opening the stream. Other non-URL wrappers will be taken into consideration when decoding the path. There is no opposite form for this flag; the streams API will use all registered wrappers by default.
IGNORE_URL_WIN
On Windows systems, this is equivalent to IGNORE_URL. On all other systems, this flag has no effect.
ENFORCE_SAFE_MODE
Requests that the underlying stream implementation perform safe_mode checks on the file before opening the file. Omitting this flag will skip safe_mode checks and allow opening of any file that the PHP process has rights to access.
REPORT_ERRORS
If this flag is set, and there was an error during the opening of the file or URL, the streams API will call the php_error function for you. This is useful because the path may contain username/password information that should not be displayed in the browser output (it would be a security risk to do so). When the streams API raises the error, it first strips username/password information from the path, making the error message safe to display in the browser.
STREAM_MUST_SEEK

This flag is useful when your extension really must be able to randomly seek around in a stream. Some streams may not be seekable in their native form, so this flag asks the streams API to check to see if the stream does support seeking. If it does not, it will copy the stream into temporary storage (which may be a temporary file or a memory stream) which does support seeking. Please note that this flag is not useful when you want to seek the stream and write to it, because the stream you are accessing might not be bound to the actual resource you requested.

Poznámka: If the requested resource is network based, this flag will cause the opener to block until the whole contents have been downloaded.

STREAM_WILL_CAST

If your extension is using a third-party library that expects a FILE* or file descriptor, you can use this flag to request the streams API to open the resource but avoid buffering. You can then use php_stream_cast() to retrieve the FILE* or file descriptor that the library requires.

The is particularly useful when accessing HTTP URLs where the start of the actual stream data is found after an indeterminate offset into the stream.

Since this option disables buffering at the streams API level, you may experience lower performance when using streams functions on the stream; this is deemed acceptable because you have told streams that you will be using the functions to match the underlying stream implementation. Only use this option when you are sure you need it.

Předcházející | Nahoru | Další
57. Zend Engine 1 | Domů | Zend API: 'Hackování' jádra PHP


TSRM API

Předcházející | Nahoru | Další
Zend API: 'Hackování' jádra PHP | Domů | 58. The future: PHP 6 and Zend Engine 3


Zend API: 'Hackování' jádra PHP

Introduction

Those who know don't talk.

Those who talk don't know.

Sometimes, PHP "as is" simply isn't enough. Although these cases are rare for the average user, professional applications will soon lead PHP to the edge of its capabilities, in terms of either speed or functionality. New functionality cannot always be implemented natively due to language restrictions and inconveniences that arise when having to carry around a huge library of default code appended to every single script, so another method needs to be found for overcoming these eventual lacks in PHP.

As soon as this point is reached, it's time to touch the heart of PHP and take a look at its core, the C code that makes PHP go.

Varování

This information is currently rather outdated, parts of it only cover early stages of the ZendEngine 1.0 API as it was used in early versions of PHP 4.

More recent information may be found in the various README files that come with the PHP source and the » Internals section on the Zend website.

Overview

"Extending PHP" is easier said than done. PHP has evolved to a full-fledged tool consisting of a few megabytes of source code, and to hack a system like this quite a few things have to be learned and considered. When structuring this chapter, we finally decided on the "learn by doing" approach. This is not the most scientific and professional approach, but the method that's the most fun and gives the best end results. In the following sections, you'll learn quickly how to get the most basic extensions to work almost instantly. After that, you'll learn about Zend's advanced API functionality. The alternative would have been to try to impart the functionality, design, tips, tricks, etc. as a whole, all at once, thus giving a complete look at the big picture before doing anything practical. Although this is the "better" method, as no dirty hacks have to be made, it can be very frustrating as well as energy- and time-consuming, which is why we've decided on the direct approach.

Note that even though this chapter tries to impart as much knowledge as possible about the inner workings of PHP, it's impossible to really give a complete guide to extending PHP that works 100% of the time in all cases. PHP is such a huge and complex package that its inner workings can only be understood if you make yourself familiar with it by practicing, so we encourage you to work with the source.

What Is Zend? and What Is PHP?

The name Zend refers to the language engine, PHP's core. The term PHP refers to the complete system as it appears from the outside. This might sound a bit confusing at first, but it's not that complicated ( see below). To implement a Web script interpreter, you need three parts:

  1. The interpreter part analyzes the input code, translates it, and executes it.

  2. The functionality part implements the functionality of the language (its functions, etc.).

  3. The interface part talks to the Web server, etc.

Zend takes part 1 completely and a bit of part 2; PHP takes parts 2 and 3. Together they form the complete PHP package. Zend itself really forms only the language core, implementing PHP at its very basics with some predefined functions. PHP contains all the modules that actually create the language's outstanding capabilities.

The following sections discuss where PHP can be extended and how it's done.

Extension Possibilities

As shown above, PHP can be extended primarily at three points: external modules, built-in modules, and the Zend engine. The following sections discuss these options.

External Modules

External modules can be loaded at script runtime using the function dl(). This function loads a shared object from disk and makes its functionality available to the script to which it's being bound. After the script is terminated, the external module is discarded from memory. This method has both advantages and disadvantages, as described in the following table:

Advantages | Disadvantages
External modules don't require recompiling of PHP. | The shared objects need to be loaded every time a script is being executed (every hit), which is very slow.
The size of PHP remains small by "outsourcing" certain functionality. | External additional files clutter up the disk.
 | Every script that wants to use an external module's functionality has to specifically include a call to dl(), or the extension tag in php.ini needs to be modified (which is not always a suitable solution).
To sum up, external modules are great for third-party products, small additions to PHP that are rarely used, or just for testing purposes. To develop additional functionality quickly, external modules provide the best results. For frequent usage, larger implementations, and complex code, the disadvantages outweigh the advantages.

Third parties might consider using the extension tag in php.ini to create additional external modules to PHP. These external modules are completely detached from the main package, which is a very handy feature in commercial environments. Commercial distributors can simply ship disks or archives containing only their additional modules, without the need to create fixed and solid PHP binaries that don't allow other modules to be bound to them.

Built-in Modules

Built-in modules are compiled directly into PHP and carried around with every PHP process; their functionality is instantly available to every script that's being run. Like external modules, built-in modules have advantages and disadvantages, as described in the following table:

Advantages | Disadvantages
No need to load the module specifically; the functionality is instantly available. | Changes to built-in modules require recompiling of PHP.
No external files clutter up the disk; everything resides in the PHP binary. | The PHP binary grows and consumes more memory.
Built-in modules are best when you have a solid library of functions that remains relatively unchanged, requires better than poor-to-average performance, or is used frequently by many scripts on your site. The need to recompile PHP is quickly compensated by the benefit in speed and ease of use. However, built-in modules are not ideal when rapid development of small additions is required.

The Zend Engine

Of course, extensions can also be implemented directly in the Zend engine. This strategy is good if you need a change in the language behavior or require special functions to be built directly into the language core. In general, however, modifications to the Zend engine should be avoided. Changes here result in incompatibilities with the rest of the world, and hardly anyone will ever adapt to specially patched Zend engines. Modifications can't be detached from the main PHP sources and are overridden with the next update using the "official" source repositories. Therefore, this method is generally considered bad practice and, due to its rarity, is not covered in this book.

Source Layout

Poznámka: Prior to working through the rest of this chapter, you should retrieve clean, unmodified source trees of your favorite Web server. We're working with Apache (available at » http://www.apache.org/) and, of course, with PHP (available at » http://www.php.net/ - does it need to be said?).

Make sure that you can compile a working PHP environment by yourself! We won't go into this issue here, however, as you should already have this most basic ability when studying this chapter.

Before we start discussing code issues, you should familiarize yourself with the source tree to be able to quickly navigate through PHP's files. This is a must-have ability to implement and debug extensions.

The following table describes the contents of the major directories.

Directory | Contents
php-src | Main PHP source files and main header files; here you'll find all of PHP's API definitions, macros, etc. (important). Everything else is below this directory.
php-src/ext | Repository for dynamic and built-in modules; by default, these are the "official" PHP modules that have been integrated into the main source tree. From PHP 4.0, it's possible to compile these standard extensions as dynamic loadable modules (at least, those that support it).
php-src/main | This directory contains the main php macros and definitions. (important)
php-src/pear | Directory for the PHP Extension and Application Repository. This directory contains core PEAR files.
php-src/sapi | Contains the code for the different server abstraction layers.
TSRM | Location of the "Thread Safe Resource Manager" (TSRM) for Zend and PHP.
ZendEngine2 | Location of the Zend Engine files; here you'll find all of Zend's API definitions, macros, etc. (important).

Discussing all the files included in the PHP package is beyond the scope of this chapter. However, you should take a close look at the following files:

  • php-src/main/php.h, located in the main PHP directory. This file contains most of PHP's macro and API definitions.

  • php-src/Zend/zend.h, located in the main Zend directory. This file contains most of Zend's macros and definitions.

  • php-src/Zend/zend_API.h, also located in the Zend directory, which defines Zend's API.

You should also follow some sub-inclusions from these files; for example, the ones relating to the Zend executor, the PHP initialization file support, and such. After reading these files, take the time to navigate around the package a little to see the interdependencies of all files and modules - how they relate to each other and especially how they make use of each other. This also helps you to adapt to the coding style in which PHP is authored. To extend PHP, you should quickly adapt to this style.

Extension Conventions

Zend is built using certain conventions; to avoid breaking its standards, you should follow the rules described in the following sections.

Macros

For almost every important task, Zend ships predefined macros that are extremely handy. The tables and figures in the following sections describe most of the basic functions, structures, and macros. The macro definitions can be found mainly in zend.h and zend_API.h. We suggest that you take a close look at these files after having studied this chapter. (Although you can go ahead and read them now, not everything will make sense to you yet.)

Memory Management

Resource management is a crucial issue, especially in server software. One of the most valuable resources is memory, and memory management should be handled with extreme care. Memory management has been partially abstracted in Zend, and you should stick to this abstraction for obvious reasons: Due to the abstraction, Zend gets full control over all memory allocations. Zend is able to determine whether a block is in use, automatically freeing unused blocks and blocks with lost references, and thus prevent memory leaks. The functions to be used are described in the following table:

Function | Description
emalloc() | Serves as replacement for malloc().
efree() | Serves as replacement for free().
estrdup() | Serves as replacement for strdup().
estrndup() | Serves as replacement for strndup(). Faster than estrdup() and binary-safe. This is the recommended function to use if you know the string length prior to duplicating it.
ecalloc() | Serves as replacement for calloc().
erealloc() | Serves as replacement for realloc().
emalloc(), estrdup(), estrndup(), ecalloc(), and erealloc() allocate internal memory; efree() frees these previously allocated blocks. Memory handled by the e*() functions is considered local to the current process and is discarded as soon as the script executed by this process is terminated.
Varování

To allocate resident memory that survives termination of the current script, you can use malloc() and free(). This should only be done with extreme care, however, and only in conjunction with demands of the Zend API; otherwise, you risk memory leaks.

Zend also features a thread-safe resource manager to provide better native support for multithreaded Web servers. This requires you to allocate local structures for all of your global variables to allow concurrent threads to be run. Because the thread-safe mode of Zend was not finished back when this was written, it is not yet extensively covered here.

Directory and File Functions

The following directory and file functions should be used in Zend modules. They behave exactly like their C counterparts, but provide virtual working directory support on the thread level.

Zend Function | Regular C Function
V_GETCWD() | getcwd()
V_FOPEN() | fopen()
V_OPEN() | open()
V_CHDIR() | chdir()
V_GETWD() | getwd()
V_CHDIR_FILE() | Takes a file path as an argument and changes the current working directory to that file's directory.
V_STAT() | stat()
V_LSTAT() | lstat()

String Handling

Strings are handled a bit differently by the Zend engine than other values such as integers, Booleans, etc., which don't require additional memory allocation for storing their values. If you want to return a string from a function, introduce a new string variable to the symbol table, or do something similar, you have to make sure that the memory the string will be occupying has previously been allocated, using the aforementioned e*() functions for allocation. (This might not make much sense to you yet; just keep it somewhere in your head for now - we'll get back to it shortly.)

Complex Types

Complex types such as arrays and objects require different treatment. Zend features a single API for these types - they're stored using hash tables.

Poznámka: To reduce complexity in the following source examples, we're only working with simple types such as integers at first. A discussion about creating more advanced types follows later in this chapter.

PHP's Automatic Build System

PHP 4 features an automatic build system that's very flexible. All modules reside in a subdirectory of the ext directory. In addition to its own sources, each module consists of a config.m4 file, for extension configuration. (for example, see » http://www.gnu.org/software/m4/manual/m4.html)

All these stub files are generated automatically, along with .cvsignore, by a little shell script named ext_skel that resides in the ext directory. As argument it takes the name of the module that you want to create. The shell script then creates a directory of the same name, along with the appropriate stub files.

Step by step, the process looks like this:

:~/cvs/php4/ext:> ./ext_skel --extname=my_module
Creating directory my_module
Creating basic files: config.m4 .cvsignore my_module.c php_my_module.h CREDITS EXPERIMENTAL tests/001.phpt my_module.php [done].

To use your new extension, you will have to execute the following steps:

1.  $ cd ..
2.  $ vi ext/my_module/config.m4
3.  $ ./buildconf
4.  $ ./configure --[with|enable]-my_module
5.  $ make
6.  $ ./php -f ext/my_module/my_module.php
7.  $ vi ext/my_module/my_module.c
8.  $ make

Repeat steps 3-6 until you are satisfied with ext/my_module/config.m4 and
step 6 confirms that your module is compiled into PHP. Then, start writing
code and repeat the last two steps as often as necessary.
This instruction creates the aforementioned files. To include the new module in the automatic configuration and build process, you have to run buildconf, which regenerates the configure script by searching through the ext directory and including all found config.m4 files.

The default config.m4 shown in 57.4 – „The default config.m4.“ is a bit more complex:

Příklad 57.4. The default config.m4.

dnl $Id: build.xml,v 1.3 2007/11/01 16:40:36 rquadling Exp $
dnl config.m4 for extension my_module

dnl Comments in this file start with the string 'dnl'.
dnl Remove where necessary. This file will not work
dnl without editing.

dnl If your extension references something external, use with:

dnl PHP_ARG_WITH(my_module, for my_module support,
dnl Make sure that the comment is aligned:
dnl [  --with-my_module             Include my_module support])

dnl Otherwise use enable:

dnl PHP_ARG_ENABLE(my_module, whether to enable my_module support,
dnl Make sure that the comment is aligned:
dnl [  --enable-my_module           Enable my_module support])

if test "$PHP_MY_MODULE" != "no"; then
  dnl Write more examples of tests here...

  dnl # --with-my_module -> check with-path
  dnl SEARCH_PATH="/usr/local /usr"     # you might want to change this
  dnl SEARCH_FOR="/include/my_module.h"  # you most likely want to change this
  dnl if test -r $PHP_MY_MODULE/; then # path given as parameter
  dnl   MY_MODULE_DIR=$PHP_MY_MODULE
  dnl else # search default path list
  dnl   AC_MSG_CHECKING([for my_module files in default path])
  dnl   for i in $SEARCH_PATH ; do
  dnl     if test -r $i/$SEARCH_FOR; then
  dnl       MY_MODULE_DIR=$i
  dnl       AC_MSG_RESULT(found in $i)
  dnl     fi
  dnl   done
  dnl fi
  dnl
  dnl if test -z "$MY_MODULE_DIR"; then
  dnl   AC_MSG_RESULT([not found])
  dnl   AC_MSG_ERROR([Please reinstall the my_module distribution])
  dnl fi

  dnl # --with-my_module -> add include path
  dnl PHP_ADD_INCLUDE($MY_MODULE_DIR/include)

  dnl # --with-my_module -> chech for lib and symbol presence
  dnl LIBNAME=my_module # you may want to change this
  dnl LIBSYMBOL=my_module # you most likely want to change this

  dnl PHP_CHECK_LIBRARY($LIBNAME,$LIBSYMBOL,
  dnl [
  dnl   PHP_ADD_LIBRARY_WITH_PATH($LIBNAME, $MY_MODULE_DIR/lib, MY_MODULE_SHARED_LIBADD)
  dnl   AC_DEFINE(HAVE_MY_MODULELIB,1,[ ])
  dnl ],[
  dnl   AC_MSG_ERROR([wrong my_module lib version or lib not found])
  dnl ],[
  dnl   -L$MY_MODULE_DIR/lib -lm -ldl
  dnl ])
  dnl
  dnl PHP_SUBST(MY_MODULE_SHARED_LIBADD)

  PHP_NEW_EXTENSION(my_module, my_module.c, $ext_shared)
fi

If you're unfamiliar with M4 files (now is certainly a good time to get familiar), this might be a bit confusing at first; but it's actually quite easy.

Note: Everything prefixed with dnl is treated as a comment and is not parsed.

The config.m4 file is responsible for parsing the command-line options passed to configure at configuration time. This means that it has to check for required external files and do similar configuration and setup tasks.

The default file creates two configuration directives in the configure script: --with-my_module and --enable-my_module. Use the first option when referring external files (such as the --with-apache directive that refers to the Apache directory). Use the second option when the user simply has to decide whether to enable your extension. Regardless of which option you use, you should uncomment the other, unnecessary one; that is, if you're using --enable-my_module, you should remove support for --with-my_module, and vice versa.

By default, the config.m4 file created by ext_skel accepts both directives and automatically enables your extension. Enabling the extension is done by using the PHP_EXTENSION macro. To change the default behavior to include your module into the PHP binary when desired by the user (by explicitly specifying --enable-my_module or --with-my_module), change the test for $PHP_MY_MODULE to == "yes":

if test "$PHP_MY_MODULE" == "yes"; then dnl
    Action.. PHP_EXTENSION(my_module, $ext_shared)
    fi
This would require you to use --enable-my_module each time when reconfiguring and recompiling PHP.

Note: Be sure to run buildconf every time you change config.m4!

We'll go into more details on the M4 macros available to your configuration scripts later in this chapter. For now, we'll simply use the default files.

Creating Extensions

We'll start with the creation of a very simple extension at first, which basically does nothing more than implement a function that returns the integer it receives as parameter. 57.5 – „A simple extension.“ shows the source.

Příklad 57.5. A simple extension.

/* include standard header */
#include "php.h"

/* declaration of functions to be exported */
ZEND_FUNCTION(first_module);

/* compiled function list so Zend knows what's in this module */
zend_function_entry firstmod_functions[] =
{
    ZEND_FE(first_module, NULL)
    {NULL, NULL, NULL}
};

/* compiled module information */
zend_module_entry firstmod_module_entry =
{
    STANDARD_MODULE_HEADER,
    "First Module",
    firstmod_functions,
    NULL,
    NULL,
    NULL,
    NULL,
    NULL,
    NO_VERSION_YET,
    STANDARD_MODULE_PROPERTIES
};

/* implement standard "stub" routine to introduce ourselves to Zend */
#if COMPILE_DL_FIRST_MODULE
ZEND_GET_MODULE(firstmod)
#endif

/* implement function that is meant to be made available to PHP */
ZEND_FUNCTION(first_module)
{
    long parameter;

    if (zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC, "l", &amp;parameter) == FAILURE) {
        return;
    }

    RETURN_LONG(parameter);
}

This code contains a complete PHP module. We'll explain the source code in detail shortly, but first we'd like to discuss the build process. (This will allow the impatient to experiment before we dive into API discussions.)

Poznámka: The example source makes use of some features introduced with the Zend version used in PHP 4.1.0 and above, it won't compile with older PHP 4.0.x versions.

Compiling Modules

There are basically two ways to compile modules:

  • Use the provided "make" mechanism in the ext directory, which also allows building of dynamic loadable modules.

  • Compile the sources manually.

The first method should definitely be favored, since, as of PHP 4.0, this has been standardized into a sophisticated build process. The fact that it is so sophisticated is also its drawback, unfortunately - it's hard to understand at first. We'll provide a more detailed introduction to this later in the chapter, but first let's work with the default files.

The second method is good for those who (for some reason) don't have the full PHP source tree available, don't have access to all files, or just like to juggle with their keyboard. These cases should be extremely rare, but for the sake of completeness we'll also describe this method.

Compiling Using Make.

To compile the sample sources using the standard mechanism, copy all their subdirectories to the ext directory of your PHP source tree. Then run buildconf, which will create an updated configure script containing appropriate options for the new extension. By default, all the sample sources are disabled, so you don't have to fear breaking your build process.

After you run buildconf, configure --help shows the following additional modules:

  --enable-array_experiments   BOOK: Enables array experiments
  --enable-call_userland       BOOK: Enables userland module
  --enable-cross_conversion    BOOK: Enables cross-conversion module
  --enable-first_module        BOOK: Enables first module
  --enable-infoprint           BOOK: Enables infoprint module
  --enable-reference_test      BOOK: Enables reference test module
  --enable-resource_test       BOOK: Enables resource test module
  --enable-variable_creation   BOOK: Enables variable-creation module

The module shown earlier in 57.5 – „A simple extension.“ can be enabled with --enable-first_module or --enable-first_module=yes.

Compiling Manually.

To compile your modules manually, you need the following commands:

Action | Command
Compiling | cc -fpic -DCOMPILE_DL_FIRST_MODULE=1 -I/usr/local/include -I. -I.. -I../Zend -c -o <your_object_file> <your_c_file>
Linking | cc -shared -L/usr/local/lib -rdynamic -o <your_module_file> <your_object_file(s)>

The command to compile the module simply instructs the compiler to generate position-independent code (-fpic shouldn't be omitted) and additionally defines the constant COMPILE_DL_FIRST_MODULE to tell the module code that it's compiled as a dynamically loadable module (the test module above checks for this; we'll discuss it shortly). After these options, it specifies a number of standard include paths that should be used as the minimal set to compile the source files.

Note: All include paths in the example are relative to the directory ext. If you're compiling from another directory, change the pathnames accordingly. Required items are the PHP directory, the Zend directory, and (if necessary), the directory in which your module resides.

The link command is also a plain vanilla command instructing linkage as a dynamic module.

You can include optimization options in the compilation command, although these have been omitted in this example (but some are included in the makefile template described in an earlier section).

Note: Compiling and linking manually as a static module into the PHP binary involves very long instructions and thus is not discussed here. (It's not very efficient to type all those commands.)

Using Extensions

Depending on the build process you selected, you should either end up with a new PHP binary to be linked into your Web server (or run as CGI), or with an .so (shared object) file. If you compiled the example file first_module.c as a shared object, your result file should be first_module.so. To use it, you first have to copy it to a place from which it's accessible to PHP. For a simple test procedure, you can copy it to your htdocs directory and try it with the source in 57.6 – „A test file for first_module.so.“. If you compiled it into the PHP binary, omit the call to dl(), as the module's functionality is instantly available to your scripts.

Varování

For security reasons, you should not put your dynamic modules into publicly accessible directories. Even though it can be done and it simplifies testing, you should put them into a separate directory in production environments.

Příklad 57.6. A test file for first_module.so.

<?php

// remove next comment if necessary
// dl("first_module.so");

$param = 2;
$return = first_module($param);

print("We sent '$param' and got '$return'");

?>

Calling this PHP file should output the following:

We sent '2' and got '2'

If required, the dynamic loadable module is loaded by calling the dl() function. This function looks for the specified shared object, loads it, and makes its functions available to PHP. The module exports the function first_module(), which accepts a single parameter, converts it to an integer, and returns the result of the conversion.

If you've gotten this far, congratulations! You just built your first extension to PHP.

Troubleshooting

Actually, not much troubleshooting can be done when compiling static or dynamic modules. The only problem that could arise is that the compiler will complain about missing definitions or something similar. In this case, make sure that all header files are available and that you specified their path correctly in the compilation command. To be sure that everything is located correctly, extract a clean PHP source tree and use the automatic build in the ext directory with the fresh files; this will guarantee a safe compilation environment. If this fails, try manual compilation.

PHP might also complain about missing functions in your module. (This shouldn't happen with the sample sources if you didn't modify them.) If the names of external functions you're trying to access from your module are misspelled, they'll remain as "unlinked symbols" in the symbol table. During dynamic loading and linkage by PHP, they won't resolve because of the typing errors - there are no corresponding symbols in the main binary. Look for incorrect declarations in your module file or incorrectly written external references. Note that this problem is specific to dynamic loadable modules; it doesn't occur with static modules. Errors in static modules show up at compile time.

Source Discussion

Now that you've got a safe build environment and you're able to include the modules into PHP files, it's time to discuss how everything works.

Module Structure

All PHP modules follow a common structure:

  • Header file inclusions (to include all required macros, API definitions, etc.)

  • C declaration of exported functions (required to declare the Zend function block)

  • Declaration of the Zend function block

  • Declaration of the Zend module block

  • Implementation of get_module()

  • Implementation of all exported functions

Header File Inclusions

The only header file you really have to include for your modules is php.h, located in the PHP directory. This file makes all macros and API definitions required to build new modules available to your code.

Tip: It's good practice to create a separate header file for your module that contains module-specific definitions. This header file should contain all the forward definitions for exported functions and include php.h. If you created your module using ext_skel you already have such a header file prepared.

Declaring Exported Functions

To declare functions that are to be exported (i.e., made available to PHP as new native functions), Zend provides a set of macros. A sample declaration looks like this:

ZEND_FUNCTION ( my_function );

ZEND_FUNCTION declares a new C function that complies with Zend's internal API. This means that the function is of type void and accepts INTERNAL_FUNCTION_PARAMETERS (another macro) as parameters. Additionally, it prefixes the function name with zif. The immediately expanded version of the above definitions would look like this:

void zif_my_function ( INTERNAL_FUNCTION_PARAMETERS );
Expanding INTERNAL_FUNCTION_PARAMETERS results in the following:

void zif_my_function( int ht
                    , zval * return_value
                    , zval * this_ptr
                    , int return_value_used
                    , zend_executor_globals * executor_globals
                    );

Since the interpreter and executor core have been separated from the main PHP package, a second API defining macros and function sets has evolved: the Zend API. As the Zend API now handles quite a few of the responsibilities that previously belonged to PHP, a lot of PHP functions have been reduced to macros aliasing to calls into the Zend API. The recommended practice is to use the Zend API wherever possible, as the old API is only preserved for compatibility reasons. For example, the types zval and pval are identical. zval is Zend's definition; pval is PHP's definition (actually, pval is an alias for zval now). As the macro INTERNAL_FUNCTION_PARAMETERS is a Zend macro, the above declaration contains zval. When writing code, you should always use zval to conform to the new Zend API.

The parameter list of this declaration is very important; you should keep these parameters in mind (see 57.2 – „Zend's Parameters to Functions Called from PHP“ for descriptions).

Tabulka 57.2. Zend's Parameters to Functions Called from PHP

Parameter | Description
ht | The number of arguments passed to the Zend function. You should not touch this directly, but instead use ZEND_NUM_ARGS() to obtain the value.
return_value | This variable is used to pass any return values of your function back to PHP. Access to this variable is best done using the predefined macros. For a description of these see below.
this_ptr | Using this variable, you can gain access to the object in which your function is contained, if it's used within an object. Use the function getThis() to obtain this pointer.
return_value_used | This flag indicates whether an eventual return value from this function will actually be used by the calling script. 0 indicates that the return value is not used; 1 indicates that the caller expects a return value. Evaluation of this flag can be done to verify correct usage of the function as well as speed optimizations in case returning a value requires expensive operations (for an example, see how array.c makes use of this).
executor_globals | This variable points to global settings of the Zend engine. You'll find this useful when creating new variables, for example (more about this later). The executor globals can also be introduced to your function by using the macro TSRMLS_FETCH().

Declaration of the Zend Function Block

Now that you have declared the functions to be exported, you also have to introduce them to Zend. Introducing the list of functions is done by using an array of zend_function_entry. This array consecutively contains all functions that are to be made available externally, with the function's name as it should appear in PHP and its name as defined in the C source. Internally, zend_function_entry is defined as shown in 57.7 – „Internal declaration of zend_function_entry.“.

Příklad 57.7. Internal declaration of zend_function_entry.

typedef struct _zend_function_entry {
    char *fname;
    void (*handler)(INTERNAL_FUNCTION_PARAMETERS);
    unsigned char *func_arg_types;
} zend_function_entry;

Entry | Description
fname | Denotes the function name as seen in PHP (for example, fopen, mysql_connect, or, in our example, first_module).
handler | Pointer to the C function responsible for handling calls to this function. For example, see the standard macro INTERNAL_FUNCTION_PARAMETERS discussed earlier.
func_arg_types | Allows you to mark certain parameters so that they're forced to be passed by reference. You usually should set this to NULL.

In the example above, the declaration looks like this:

zend_function_entry firstmod_functions[] =
{
    ZEND_FE(first_module, NULL)
    {NULL, NULL, NULL}
};
You can see that the last entry in the list always has to be {NULL, NULL, NULL}. This marker has to be set for Zend to know when the end of the list of exported functions is reached.

Poznámka: You cannot use the predefined macros for the end marker, as these would try to refer to a function named "NULL"!

The macro ZEND_FE (short for 'Zend Function Entry') simply expands to a structure entry in zend_function_entry. Note that these macros introduce a special naming scheme to your functions - your C functions will be prefixed with zif_, meaning that ZEND_FE(first_module) will refer to a C function zif_first_module(). If you want to mix macro usage with hand-coded entries (not a good practice), keep this in mind.

Tip: Compilation errors that refer to functions named zif_*() relate to functions defined with ZEND_FE.

57.3 – „Macros for Defining Functions“ shows a list of all the macros that you can use to define functions.

Tabulka 57.3. Macros for Defining Functions

Macro Name | Description
ZEND_FE(name, arg_types) | Defines a function entry of the name name in zend_function_entry. Requires a corresponding C function. arg_types needs to be set to NULL. This function uses automatic C function name generation by prefixing the PHP function name with zif_. For example, ZEND_FE("first_module", NULL) introduces a function first_module() to PHP and links it to the C function zif_first_module(). Use in conjunction with ZEND_FUNCTION.
ZEND_NAMED_FE(php_name, name, arg_types) | Defines a function that will be available to PHP by the name php_name and links it to the corresponding C function name. arg_types needs to be set to NULL. Use this function if you don't want the automatic name prefixing introduced by ZEND_FE. Use in conjunction with ZEND_NAMED_FUNCTION.
ZEND_FALIAS(name, alias, arg_types) | Defines an alias named alias for name. arg_types needs to be set to NULL. Doesn't require a corresponding C function; refers to the alias target instead.
PHP_FE(name, arg_types) | Old PHP API equivalent of ZEND_FE.
PHP_NAMED_FE(runtime_name, name, arg_types) | Old PHP API equivalent of ZEND_NAMED_FE.

Note: You can't use ZEND_FE in conjunction with PHP_FUNCTION, or PHP_FE in conjunction with ZEND_FUNCTION. However, it's perfectly legal to mix ZEND_FE and ZEND_FUNCTION with PHP_FE and PHP_FUNCTION when staying with the same macro set for each function to be declared. But mixing is not recommended; instead, you're advised to use the ZEND_* macros only.

Declaration of the Zend Module Block

This block is stored in the structure zend_module_entry and contains all necessary information to describe the contents of this module to Zend. You can see the internal definition of this module in 57.8 – „Internal declaration of zend_module_entry.“.

Příklad 57.8. Internal declaration of zend_module_entry.

typedef struct _zend_module_entry zend_module_entry;

    struct _zend_module_entry {
    unsigned short size;
    unsigned int zend_api;
    unsigned char zend_debug;
    unsigned char zts;
    char *name;
    zend_function_entry *functions;
    int (*module_startup_func)(INIT_FUNC_ARGS);
    int (*module_shutdown_func)(SHUTDOWN_FUNC_ARGS);
    int (*request_startup_func)(INIT_FUNC_ARGS);
    int (*request_shutdown_func)(SHUTDOWN_FUNC_ARGS);
    void (*info_func)(ZEND_MODULE_INFO_FUNC_ARGS);
    char *version;

[ Rest of the structure is not interesting here ]

};

Entry | Description
size, zend_api, zend_debug and zts | Usually filled with the "STANDARD_MODULE_HEADER", which fills these four members with the size of the whole zend_module_entry, the ZEND_MODULE_API_NO, whether it is a debug build or normal build (ZEND_DEBUG) and if ZTS is enabled (USING_ZTS).
name | Contains the module name (for example, "File functions", "Socket functions", "Crypt", etc.). This name will show up in phpinfo(), in the section "Additional Modules."
functions | Points to the Zend function block, discussed in the preceding section.
module_startup_func | This function is called once upon module initialization and can be used to do one-time initialization steps (such as initial memory allocation, etc.). To indicate a failure during initialization, return FAILURE; otherwise, SUCCESS. To mark this field as unused, use NULL. To declare a function, use the macro ZEND_MINIT.
module_shutdown_func | This function is called once upon module shutdown and can be used to do one-time deinitialization steps (such as memory deallocation). This is the counterpart to module_startup_func(). To indicate a failure during deinitialization, return FAILURE; otherwise, SUCCESS. To mark this field as unused, use NULL. To declare a function, use the macro ZEND_MSHUTDOWN.
request_startup_func | This function is called once upon every page request and can be used to do one-time initialization steps that are required to process a request. To indicate a failure here, return FAILURE; otherwise, SUCCESS. Note: As dynamic loadable modules are loaded only on page requests, the request startup function is called right after the module startup function (both initialization events happen at the same time). To mark this field as unused, use NULL. To declare a function, use the macro ZEND_RINIT.
request_shutdown_func | This function is called once after every page request and works as counterpart to request_startup_func(). To indicate a failure here, return FAILURE; otherwise, SUCCESS. Note: As dynamic loadable modules are loaded only on page requests, the request shutdown function is immediately followed by a call to the module shutdown handler (both deinitialization events happen at the same time). To mark this field as unused, use NULL. To declare a function, use the macro ZEND_RSHUTDOWN.
info_func | When phpinfo() is called in a script, Zend cycles through all loaded modules and calls this function. Every module then has the chance to print its own "footprint" into the output page. Generally this is used to dump environmental or statistical information. To mark this field as unused, use NULL. To declare a function, use the macro ZEND_MINFO.
version | The version of the module. You can use NO_VERSION_YET if you don't want to give the module a version number yet, but we really recommend that you add a version string here. Such a version string can look like this (in chronological order): "2.5-dev", "2.5RC1", "2.5" or "2.5pl3".
Remaining structure elements | These are used internally and can be prefilled by using the macro STANDARD_MODULE_PROPERTIES_EX. You should not assign any values to them. Use STANDARD_MODULE_PROPERTIES_EX only if you use global startup and shutdown functions; otherwise, use STANDARD_MODULE_PROPERTIES directly.

In our example, this structure is implemented as follows:

zend_module_entry firstmod_module_entry =
{
    STANDARD_MODULE_HEADER,
    "First Module",
    firstmod_functions,
    NULL, NULL, NULL, NULL, NULL,
    NO_VERSION_YET,
    STANDARD_MODULE_PROPERTIES,
};
This is basically the easiest and most minimal set of values you could ever use. The module name is set to First Module, then the function list is referenced, after which all startup and shutdown functions are marked as being unused.

For reference purposes, you can find a list of the macros involved in declared startup and shutdown functions in 57.4 – „Macros to Declare Startup and Shutdown Functions“. These are not used in our basic example yet, but will be demonstrated later on. You should make use of these macros to declare your startup and shutdown functions, as these require special arguments to be passed (INIT_FUNC_ARGS and SHUTDOWN_FUNC_ARGS), which are automatically included into the function declaration when using the predefined macros. If you declare your functions manually and the PHP developers decide that a change in the argument list is necessary, you'll have to change your module sources to remain compatible.

Tabulka 57.4. Macros to Declare Startup and Shutdown Functions

Macro | Description
ZEND_MINIT(module) | Declares a function for module startup. The generated name will be zend_minit_<module> (for example, zend_minit_first_module). Use in conjunction with ZEND_MINIT_FUNCTION.
ZEND_MSHUTDOWN(module) | Declares a function for module shutdown. The generated name will be zend_mshutdown_<module> (for example, zend_mshutdown_first_module). Use in conjunction with ZEND_MSHUTDOWN_FUNCTION.
ZEND_RINIT(module) | Declares a function for request startup. The generated name will be zend_rinit_<module> (for example, zend_rinit_first_module). Use in conjunction with ZEND_RINIT_FUNCTION.
ZEND_RSHUTDOWN(module) | Declares a function for request shutdown. The generated name will be zend_rshutdown_<module> (for example, zend_rshutdown_first_module). Use in conjunction with ZEND_RSHUTDOWN_FUNCTION.
ZEND_MINFO(module) | Declares a function for printing module information, used when phpinfo() is called. The generated name will be zend_info_<module> (for example, zend_info_first_module). Use in conjunction with ZEND_MINFO_FUNCTION.

Creation of get_module()

This function is special to all dynamic loadable modules. Take a look at the creation via the ZEND_GET_MODULE macro first:

#if COMPILE_DL_FIRSTMOD
     ZEND_GET_MODULE(firstmod)
#endif

The function implementation is surrounded by a conditional compilation statement. This is needed since the function get_module() is only required if your module is built as a dynamic extension. By specifying a definition of COMPILE_DL_FIRSTMOD in the compiler command (see above for a discussion of the compilation instructions required to build a dynamic extension), you can instruct your module whether you intend to build it as a dynamic extension or as a built-in module. If you want a built-in module, the implementation of get_module() is simply left out.

get_module() is called by Zend at load time of the module. You can think of it as being invoked by the dl() call in your script. Its purpose is to pass the module information block back to Zend in order to inform the engine about the module contents.

If you don't implement a get_module() function in your dynamic loadable module, Zend will compliment you with an error message when trying to access it.

Implementation of All Exported Functions

Implementing the exported functions is the final step. The example function in first_module looks like this:

ZEND_FUNCTION(first_module)
{
    long parameter;

    if (zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC, "l", &amp;parameter) == FAILURE) {
        return;
    }

    RETURN_LONG(parameter);
}
The function declaration is done using ZEND_FUNCTION, which corresponds to ZEND_FE in the function entry table (discussed earlier).

After the declaration, code for checking and retrieving the function's arguments, argument conversion, and return value generation follows (more on this later).

Summary

That's it, basically - there's nothing more to implementing PHP modules. Built-in modules are structured similarly to dynamic modules, so, equipped with the information presented in the previous sections, you'll be able to fight the odds when encountering PHP module source files.

Now, in the following sections, read on about how to make use of PHP's internals to build powerful extensions.

Accepting Arguments

One of the most important issues for language extensions is accepting and dealing with data passed via arguments. Most extensions are built to deal with specific input data (or require parameters to perform their specific actions), and function arguments are the only real way to exchange data between the PHP level and the C level. Of course, there's also the possibility of exchanging data using predefined global values (which is also discussed later), but this should be avoided by all means, as it's extremely bad practice.

PHP doesn't make use of any formal function declarations; this is why call syntax is always completely dynamic and never checked for errors. Checking for correct call syntax is left to the user code. For example, it's possible to call a function using only one argument at one time and four arguments the next time - both invocations are syntactically absolutely correct.

Determining the Number of Arguments

Since PHP doesn't have formal function definitions with support for call syntax checking, and since PHP features variable arguments, sometimes you need to find out with how many arguments your function has been called. You can use the ZEND_NUM_ARGS macro in this case. In previous versions of PHP, this macro retrieved the number of arguments with which the function has been called based on the function's hash table entry, ht, which is passed in the INTERNAL_FUNCTION_PARAMETERS list. As ht itself now contains the number of arguments that have been passed to the function, ZEND_NUM_ARGS has been stripped down to a dummy macro (see its definition in zend_API.h). But it's still good practice to use it, to remain compatible with future changes in the call interface. Note: The old PHP equivalent of this macro is ARG_COUNT.

The following code checks for the correct number of arguments:

if(ZEND_NUM_ARGS() != 2) WRONG_PARAM_COUNT;
If the function is not called with two arguments, it exits with an error message. The code snippet above makes use of the tool macro WRONG_PARAM_COUNT, which can be used to generate a standard error message like: "Warning: Wrong parameter count for firstmodule() in /home/www/htdocs/firstmod.php on line 5"

This macro prints a default error message and then returns to the caller. Its definition can also be found in zend_API.h and looks like this:

ZEND_API void wrong_param_count(void);

#define WRONG_PARAM_COUNT { wrong_param_count(); return; }
As you can see, it calls an internal function named wrong_param_count() that's responsible for printing the warning. For details on generating customized error messages, see the later section "Printing Information."

Retrieving Arguments

New parameter parsing API : This chapter documents the new Zend parameter parsing API introduced by Andrei Zmievski. It was introduced in the development stage between PHP 4.0.6 and 4.1.0 .

Parsing parameters is a very common operation and it may get a bit tedious. It would also be nice to have standardized error checking and error messages. Since PHP 4.1.0, there is a way to do just that by using the new parameter parsing API. It greatly simplifies the process of receiving parameters, but it has a drawback in that it can't be used for functions that expect variable number of parameters. But since the vast majority of functions do not fall into those categories, this parsing API is recommended as the new standard way.

The prototype for parameter parsing function looks like this:

int zend_parse_parameters(int num_args TSRMLS_DC, char *type_spec, ...);
The first argument to this function is supposed to be the number of actual parameters passed to your function, so ZEND_NUM_ARGS() can be used for that. The second parameter should always be TSRMLS_CC macro. The third argument is a string that specifies the number and types of arguments your function is expecting, similar to how printf format string specifies the number and format of the output values it should operate on. And finally the rest of the arguments are pointers to variables which should receive the values from the parameters.

zend_parse_parameters() also performs type conversions whenever possible, so that you always receive the data in the format you asked for. Any type of scalar can be converted to another one, but conversions between complex types (arrays, objects, and resources) and scalar types are not allowed.

If the parameters could be obtained successfully and there were no errors during type conversion, the function will return SUCCESS, otherwise it will return FAILURE. The function will output informative error messages, if the number of received parameters does not match the requested number, or if type conversion could not be performed.

Here are some sample error messages:

     Warning - ini_get_all() requires at most 1 parameter, 2 given
     Warning - wddx_deserialize() expects parameter 1 to be string, array given
Of course each error message is accompanied by the filename and line number on which it occurs.

Here is the full list of type specifiers:

  • l - long

  • d - double

  • s - string (with possible null bytes) and its length

  • b - boolean

  • r - resource, stored in zval*

  • a - array, stored in zval*

  • o - object (of any class), stored in zval*

  • O - object (of class specified by class entry), stored in zval*

  • z - the actual zval*

The following characters also have a meaning in the specifier string:

  • | - indicates that the remaining parameters are optional. The storage variables corresponding to these parameters should be initialized to default values by the extension, since they will not be touched by the parsing function if the parameters are not passed.

  • / - the parsing function will call SEPARATE_ZVAL_IF_NOT_REF() on the parameter it follows, to provide a copy of the parameter, unless it's a reference.

  • ! - the parameter it follows can be of specified type or NULL (only applies to a, o, O, r, and z). If NULL value is passed by the user, the storage pointer will be set to NULL.

The best way to illustrate the usage of this function is through examples:

/* Gets a long, a string and its length, and a zval. */
long l;
char *s;
int s_len;
zval *param;
if (zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC,
                          "lsz", &l, &s, &s_len, &param) == FAILURE) {
    return;
}

/* Gets an object of class specified by my_ce, and an optional double. */
zval *obj;
double d = 0.5;
if (zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC,
                          "O|d", &obj, my_ce, &d) == FAILURE) {
    return;
}

/* Gets an object or null, and an array.
   If null is passed for object, obj will be set to NULL. */
zval *obj;
zval *arr;
if (zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC, "O!a", &obj, &arr) == FAILURE) {
    return;
}

/* Gets a separated array. */
zval *arr;
if (zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC, "a/", &arr) == FAILURE) {
    return;
}

/* Get only the first three parameters (useful for varargs functions). */
zval *z;
zend_bool b;
zval *r;
if (zend_parse_parameters(3, "zbr!", &z, &b, &r) == FAILURE) {
    return;
}

Note that in the last example we pass 3 for the number of received parameters, instead of ZEND_NUM_ARGS(). What this lets us do is receive the least number of parameters if our function expects a variable number of them. Of course, if you want to operate on the rest of the parameters, you will have to use zend_get_parameters_array_ex() to obtain them.

The parsing function has an extended version that allows for an additional flags argument that controls its actions.

int zend_parse_parameters_ex(int flags, int num_args TSRMLS_DC, char *type_spec, ...);

The only flag you can pass currently is ZEND_PARSE_PARAMS_QUIET, which instructs the function to not output any error messages during its operation. This is useful for functions that expect several sets of completely different arguments, but you will have to output your own error messages.

For example, here is how you would get either a set of three longs or a string:

long l1, l2, l3;
char *s;
if (zend_parse_parameters_ex(ZEND_PARSE_PARAMS_QUIET,
                             ZEND_NUM_ARGS() TSRMLS_CC,
                             "lll", &l1, &l2, &l3) == SUCCESS) {
    /* manipulate longs */
} else if (zend_parse_parameters_ex(ZEND_PARSE_PARAMS_QUIET,
                                    ZEND_NUM_ARGS(), "s", &s, &s_len) == SUCCESS) {
    /* manipulate string */
} else {
    php_error(E_WARNING, "%s() takes either three long values or a string as argument",
              get_active_function_name(TSRMLS_C));
    return;
}

With all the abovementioned ways of receiving function parameters you should have a good handle on this process. For even more example, look through the source code for extensions that are shipped with PHP - they illustrate every conceivable situation.

Old way of retrieving arguments (deprecated)

Deprecated parameter parsing API : This API is deprecated and superseded by the new ZEND parameter parsing API.

After having checked the number of arguments, you need to get access to the arguments themselves. This is done with the help of zend_get_parameters_ex():

zval **parameter;

if(zend_get_parameters_ex(1, &parameter) != SUCCESS)
  WRONG_PARAM_COUNT;
All arguments are stored in a zval container, which needs to be pointed to twice. The snippet above tries to retrieve one argument and make it available to us via the parameter pointer.

zend_get_parameters_ex() accepts at least two arguments. The first argument is the number of arguments to retrieve (which should match the number of arguments with which the function has been called; this is why it's important to check for correct call syntax). The second argument (and all following arguments) are pointers to pointers to pointers to zvals. (Confusing, isn't it?) All these pointers are required because Zend works internally with **zval; to adjust a local **zval in our function,zend_get_parameters_ex() requires a pointer to it.

The return value of zend_get_parameters_ex() can either be SUCCESS or FAILURE, indicating (unsurprisingly) success or failure of the argument processing. A failure is most likely related to an incorrect number of arguments being specified, in which case you should exit with WRONG_PARAM_COUNT.

To retrieve more than one argument, you can use a similar snippet:

zval **param1, **param2, **param3, **param4;

if(zend_get_parameters_ex(4, &param1, &param2, &param3, &param4) != SUCCESS)
    WRONG_PARAM_COUNT;

zend_get_parameters_ex() only checks whether you're trying to retrieve too many parameters. If the function is called with five arguments, but you're only retrieving three of them with zend_get_parameters_ex(), you won't get an error but will get the first three parameters instead. Subsequent calls of zend_get_parameters_ex() won't retrieve the remaining arguments, but will get the same arguments again.

Dealing with a Variable Number of Arguments/Optional Parameters

If your function is meant to accept a variable number of arguments, the snippets just described are sometimes suboptimal solutions. You have to create a line calling zend_get_parameters_ex() for every possible number of arguments, which is often unsatisfying.

For this case, you can use the function zend_get_parameters_array_ex(), which accepts the number of parameters to retrieve and an array in which to store them:

zval **parameter_array[4];

/* get the number of arguments */
argument_count = ZEND_NUM_ARGS();

/* see if it satisfies our minimal request (2 arguments) */
/* and our maximal acceptance (4 arguments) */
if(argument_count < 2 || argument_count > 4)
    WRONG_PARAM_COUNT;

/* argument count is correct, now retrieve arguments */
if(zend_get_parameters_array_ex(argument_count, parameter_array) != SUCCESS)
    WRONG_PARAM_COUNT;
First, the number of arguments is checked to make sure that it's in the accepted range. After that, zend_get_parameters_array_ex() is used to fill parameter_array with valid pointers to the argument values.

A very clever implementation of this can be found in the code handling PHP's fsockopen() located in ext/standard/fsock.c, as shown in 57.9 – „PHP's implementation of variable arguments in fsockopen().“. Don't worry if you don't know all the functions used in this source yet; we'll get to them shortly.

Příklad 57.9. PHP's implementation of variable arguments in fsockopen().

pval **args[5];
int *sock=emalloc(sizeof(int));
int *sockp;
int arg_count=ARG_COUNT(ht);
int socketd = -1;
unsigned char udp = 0;
struct timeval timeout = { 60, 0 };
unsigned short portno;
unsigned long conv;
char *key = NULL;
FLS_FETCH();

if (arg_count > 5 || arg_count < 2 || zend_get_parameters_array_ex(arg_count,args)==FAILURE) {
    CLOSE_SOCK(1);
    WRONG_PARAM_COUNT;
}

switch(arg_count) {
    case 5:
        convert_to_double_ex(args[4]);
        conv = (unsigned long) (Z_DVAL_PP(args[4]) * 1000000.0);
        timeout.tv_sec = conv / 1000000;
        timeout.tv_usec = conv % 1000000;
        /* fall-through */
    case 4:
        if (!PZVAL_IS_REF(*args[3])) {
            php_error(E_WARNING,"error string argument to fsockopen not passed by reference");
        }
        pval_copy_constructor(*args[3]);
        ZVAL_EMPTY_STRING(*args[3]);
        /* fall-through */
    case 3:
        if (!PZVAL_IS_REF(*args[2])) {
            php_error(E_WARNING,"error argument to fsockopen not passed by reference");
            return;
        }
        ZVAL_LONG(*args[2], 0);
        break;
}

convert_to_string_ex(args[0]);
convert_to_long_ex(args[1]);
portno = (unsigned short) Z_LVAL_P(args[1]);

key = emalloc(Z_STRLEN_P(args[0]) + 10);

fsockopen() accepts two, three, four, or five parameters. After the obligatory variable declarations, the function checks for the correct range of arguments. Then it uses a fall-through mechanism in a switch() statement to deal with all arguments. The switch() statement starts with the maximum number of arguments being passed (five). After that, it automatically processes the case of four arguments being passed, then three, by omitting the otherwise obligatory break keyword in all stages. After having processed the last case, it exits the switch() statement and does the minimal argument processing needed if the function is invoked with only two arguments.

This multiple-stage type of processing, similar to a stairway, allows convenient processing of a variable number of arguments.

Accessing Arguments

To access arguments, it's necessary for each argument to have a clearly defined type. Again, PHP's extremely dynamic nature introduces some quirks. Because PHP never does any kind of type checking, it's possible for a caller to pass any kind of data to your functions, whether you want it or not. If you expect an integer, for example, the caller might pass an array, and vice versa - PHP simply won't notice.

To work around this, you have to use a set of API functions to force a type conversion on every argument that's being passed (see 57.5 – „Argument Conversion Functions“).

Note: All conversion functions expect a **zval as parameter.

Tabulka 57.5. Argument Conversion Functions

Function | Description
convert_to_boolean_ex() | Forces conversion to a Boolean type. Boolean values remain untouched. Longs, doubles, and strings containing 0 as well as NULL values will result in Boolean 0 (FALSE). Arrays and objects are converted based on the number of entries or properties, respectively, that they have. Empty arrays and objects are converted to FALSE; otherwise, to TRUE. All other values result in a Boolean 1 (TRUE).
convert_to_long_ex() | Forces conversion to a long, the default integer type. NULL values, Booleans, resources, and of course longs remain untouched. Doubles are truncated. Strings containing an integer are converted to their corresponding numeric representation, otherwise resulting in 0. Arrays and objects are converted to 0 if empty, 1 otherwise.
convert_to_double_ex() | Forces conversion to a double, the default floating-point type. NULL values, Booleans, resources, longs, and of course doubles remain untouched. Strings containing a number are converted to their corresponding numeric representation, otherwise resulting in 0.0. Arrays and objects are converted to 0.0 if empty, 1.0 otherwise.
convert_to_string_ex() | Forces conversion to a string. Strings remain untouched. NULL values are converted to an empty string. Booleans containing TRUE are converted to "1", otherwise resulting in an empty string. Longs and doubles are converted to their corresponding string representation. Arrays are converted to the string "Array" and objects to the string "Object".
convert_to_array_ex(value) | Forces conversion to an array. Arrays remain untouched. Objects are converted to an array by assigning all their properties to the array table. All property names are used as keys, property contents as values. NULL values are converted to an empty array. All other values are converted to an array that contains the specific source value in the element with the key 0.
convert_to_object_ex(value) | Forces conversion to an object. Objects remain untouched. NULL values are converted to an empty object. Arrays are converted to objects by introducing their keys as properties into the objects and their values as corresponding property contents in the object. All other types result in an object with the property scalar , having the corresponding source value as content.
convert_to_null_ex(value) | Forces the type to become a NULL value, meaning empty.

Poznámka: You can find a demonstration of the behavior in cross_conversion.php on the accompanying CD-ROM.

Using these functions on your arguments will ensure type safety for all data that's passed to you. If the supplied type doesn't match the required type, PHP forces dummy contents on the resulting value (empty strings, arrays, or objects, 0 for numeric values, FALSE for Booleans) to ensure a defined state.

Following is a quote from the sample module discussed previously, which makes use of the conversion functions:

zval **parameter;

if((ZEND_NUM_ARGS() != 1) || (zend_get_parameters_ex(1, &parameter) != SUCCESS))
{
    WRONG_PARAM_COUNT;
}

convert_to_long_ex(parameter);

RETURN_LONG(Z_LVAL_P(parameter));
After retrieving the parameter pointer, the parameter value is converted to a long (an integer), which also forms the return value of this function. Understanding access to the contents of the value requires a short discussion of the zval type, whose definition is shown in 57.10 – „PHP/Zend zval type definition.“.

Příklad 57.10. PHP/Zend zval type definition.

typedef pval zval;

typedef struct _zval_struct zval;

typedef union _zvalue_value {
    long lval;                 /* long value */
    double dval;               /* double value */
    struct {
        char *val;
        int len;
    } str;
    HashTable *ht;             /* hash table value */
    struct {
        zend_class_entry *ce;
        HashTable *properties;
    } obj;
} zvalue_value;

struct _zval_struct {
    /* Variable information */
    zvalue_value value;        /* value */
    unsigned char type;        /* active type */
    unsigned char is_ref;
    short refcount;
};

Actually, pval (defined in php.h) is only an alias of zval (defined in zend.h), which in turn refers to _zval_struct. This is a most interesting structure. _zval_struct is the "master" structure, containing the value structure, type, and reference information. The substructure zvalue_value is a union that contains the variable's contents. Depending on the variable's type, you'll have to access different members of this union. For a description of both structures, see 57.6 – „Zend zval Structure“, 57.7 – „Zend zvalue_value Structure“ and 57.8 – „Zend Variable Type Constants“.

Tabulka 57.6. Zend zval Structure

Entry | Description
value | Union containing this variable's contents. See 57.7 – „Zend zvalue_value Structure“ for a description.
type | Contains this variable's type. For a list of available types, see 57.8 – „Zend Variable Type Constants“.
is_ref | 0 means that this variable is not a reference; 1 means that this variable is a reference to another variable.
refcount | The number of references that exist for this variable. For every new reference to the value stored in this variable, this counter is increased by 1. For every lost reference, this counter is decreased by 1. When the reference counter reaches 0, no references exist to this value anymore, which causes automatic freeing of the value.

Tabulka 57.7. Zend zvalue_value Structure

Entry | Description
lval | Use this property if the variable is of the type IS_LONG, IS_BOOLEAN, or IS_RESOURCE.
dval | Use this property if the variable is of the type IS_DOUBLE.
str | This structure can be used to access variables of the type IS_STRING. The member len contains the string length; the member val points to the string itself. Zend uses C strings; thus, the string length contains a trailing 0x00.
ht | This entry points to the variable's hash table entry if the variable is an array.
obj | Use this property if the variable is of the type IS_OBJECT.

Tabulka 57.8. Zend Variable Type Constants

Constant | Description
IS_NULL | Denotes a NULL (empty) value.
IS_LONG | A long (integer) value.
IS_DOUBLE | A double (floating point) value.
IS_STRING | A string.
IS_ARRAY | Denotes an array.
IS_OBJECT | An object.
IS_BOOL | A Boolean value.
IS_RESOURCE | A resource (for a discussion of resources, see the appropriate section below).
IS_CONSTANT | A constant (defined) value.

To access a long you access zval.value.lval, to access a double you use zval.value.dval, and so on. Because all values are stored in a union, trying to access data with incorrect union members results in meaningless output.

Accessing arrays and objects is a bit more complicated and is discussed later.

Dealing with Arguments Passed by Reference

If your function accepts arguments passed by reference that you intend to modify, you need to take some precautions.

What we didn't say yet is that under the circumstances presented so far, you don't have write access to any zval containers designating function parameters that have been passed to you. Of course, you can change any zval containers that you created within your function, but you mustn't change any zvals that refer to Zend-internal data!

We've only discussed the so-called *_ex() API so far. You may have noticed that the API functions we've used are called zend_get_parameters_ex() instead of zend_get_parameters(), convert_to_long_ex() instead of convert_to_long(), etc. The *_ex() functions form the so-called new "extended" Zend API. They give a minor speed increase over the old API, but as a tradeoff are only meant for providing read-only access.

Because Zend works internally with references, different variables may reference the same value. Write access to a zval container requires this container to contain an isolated value, meaning a value that's not referenced by any other containers. If a zval container were referenced by other containers and you changed the referenced zval, you would automatically change the contents of the other containers referencing this zval (because they'd simply point to the changed value and thus change their own value as well).

zend_get_parameters_ex() doesn't care about this situation, but simply returns a pointer to the desired zval containers, whether they consist of references or not. Its corresponding function in the traditional API, zend_get_parameters(), immediately checks for referenced values. If it finds a reference, it creates a new, isolated zval container; copies the referenced data into this newly allocated space; and then returns a pointer to the new, isolated value.

This action is called zval separation (or pval separation). Because the *_ex() API doesn't perform zval separation, it's considerably faster, while at the same time disabling write access.

To change parameters, however, write access is required. Zend deals with this situation in a special way: Whenever a parameter to a function is passed by reference, it performs automatic zval separation. This means that whenever you're calling a function like this in PHP, Zend will automatically ensure that $parameter is being passed as an isolated value, rendering it to a write-safe state:

my_function(&amp;$parameter);

But this is not the case with regular parameters! All other parameters that are not passed by reference are in a read-only state.

This requires you to make sure that you're really working with a reference - otherwise you might produce unwanted results. To check for a parameter being passed by reference, you can use the macro PZVAL_IS_REF. This macro accepts a zval* to check if it is a reference or not. Examples are given in in 57.11 – „Testing for referenced parameter passing.“.

Příklad 57.11. Testing for referenced parameter passing.

zval *parameter;

if (zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC, "z", &parameter) == FAILURE)
    return;

/* check for parameter being passed by reference */
if (!PZVAL_IS_REF(parameter)) {
{
    zend_error(E_WARNING, "Parameter wasn't passed by reference");
    RETURN_NULL();
}

/* make changes to the parameter */
ZVAL_LONG(parameter, 10);

Assuring Write Safety for Other Parameters

You might run into a situation in which you need write access to a parameter that's retrieved with zend_get_parameters_ex() but not passed by reference. For this case, you can use the macro SEPARATE_ZVAL, which does a zval separation on the provided container. The newly generated zval is detached from internal data and has only a local scope, meaning that it can be changed or destroyed without implying global changes in the script context:

zval **parameter;

/* retrieve parameter */
zend_get_parameters_ex(1, &parameter);

/* at this stage, <parameter> still is connected */
/* to Zend's internal data buffers */

/* make <parameter> write-safe */
SEPARATE_ZVAL(parameter);

/* now we can safely modify <parameter> */
/* without implying global changes */
SEPARATE_ZVAL uses emalloc() to allocate the new zval container, which means that even if you don't deallocate this memory yourself, it will be destroyed automatically upon script termination. However, doing a lot of calls to this macro without freeing the resulting containers will clutter up your RAM.

Note: As you can easily work around the lack of write access in the "traditional" API (with zend_get_parameters() and so on), this API seems to be obsolete, and is not discussed further in this chapter.

Creating Variables

When exchanging data from your own extensions with PHP scripts, one of the most important issues is the creation of variables. This section shows you how to deal with the variable types that PHP supports.

Overview

To create new variables that can be seen "from the outside" by the executing script, you need to allocate a new zval container, fill this container with meaningful values, and then introduce it to Zend's internal symbol table. This basic process is common to all variable creations:

zval *new_variable;

/* allocate and initialize new container */
MAKE_STD_ZVAL(new_variable);

/* set type and variable contents here, see the following sections */

/* introduce this variable by the name "new_variable_name" into the symbol table */
ZEND_SET_SYMBOL(EG(active_symbol_table), "new_variable_name", new_variable);

/* the variable is now accessible to the script by using $new_variable_name */

The macro MAKE_STD_ZVAL allocates a new zval container using ALLOC_ZVAL and initializes it using INIT_ZVAL. As implemented in Zend at the time of this writing, initializing means setting the reference count to 1 and clearing the is_ref flag, but this process could be extended later - this is why it's a good idea to keep using MAKE_STD_ZVAL instead of only using ALLOC_ZVAL. If you want to optimize for speed (and you don't have to explicitly initialize the zval container here), you can use ALLOC_ZVAL, but this isn't recommended because it doesn't ensure data integrity.

ZEND_SET_SYMBOL takes care of introducing the new variable to Zend's symbol table. This macro checks whether the value already exists in the symbol table and converts the new symbol to a reference if so (with automatic deallocation of the old zval container). This is the preferred method if speed is not a crucial issue and you'd like to keep memory usage low.

Note that ZEND_SET_SYMBOL makes use of the Zend executor globals via the macro EG. By specifying EG(active_symbol_table), you get access to the currently active symbol table, dealing with the active, local scope. The local scope may differ depending on whether the function was invoked from within a function.

If you need to optimize for speed and don't care about optimal memory usage, you can omit the check for an existing variable with the same value and instead force insertion into the symbol table by using zend_hash_update():

zval *new_variable;

/* allocate and initialize new container */
MAKE_STD_ZVAL(new_variable);

/* set type and variable contents here, see the following sections */

/* introduce this variable by the name "new_variable_name" into the symbol table */
zend_hash_update(
    EG(active_symbol_table),
    "new_variable_name",
    strlen("new_variable_name") + 1,
    &amp;new_variable,
    sizeof(zval *),
    NULL
);
This is actually the standard method used in most modules.

The variables generated with the snippet above will always be of local scope, so they reside in the context in which the function has been called. To create new variables in the global scope, use the same method but refer to another symbol table:

zval *new_variable;

// allocate and initialize new container
MAKE_STD_ZVAL(new_variable);

//
// set type and variable contents here
//

// introduce this variable by the name "new_variable_name" into the global symbol table
ZEND_SET_SYMBOL(&amp;EG(symbol_table), "new_variable_name", new_variable);
The macro ZEND_SET_SYMBOL is now being called with a reference to the main, global symbol table by referring EG(symbol_table).

Note: The active_symbol_table variable is a pointer, but symbol_table is not. This is why you have to use EG(active_symbol_table) and &EG(symbol_table) as parameters to ZEND_SET_SYMBOL - it requires a pointer.

Similarly, to get a more efficient version, you can hardcode the symbol table update:

zval *new_variable;

// allocate and initialize new container
MAKE_STD_ZVAL(new_variable);

//
// set type and variable contents here
//

// introduce this variable by the name "new_variable_name" into the global symbol table
zend_hash_update(
    &amp;EG(symbol_table),
    "new_variable_name",
    strlen("new_variable_name") + 1,
    &amp;new_variable,
    sizeof(zval *),
    NULL
);
57.12 – „Creating variables with different scopes.“ shows a sample source that creates two variables - local_variable with a local scope and global_variable with a global scope (see Figure 9.7). The full example can be found on the CD-ROM.

Note: You can see that the global variable is actually not accessible from within the function. This is because it's not imported into the local scope using global $global_variable; in the PHP source.

Příklad 57.12. Creating variables with different scopes.

ZEND_FUNCTION(variable_creation)
{
    zval *new_var1, *new_var2;

    MAKE_STD_ZVAL(new_var1);
    MAKE_STD_ZVAL(new_var2);

    ZVAL_LONG(new_var1, 10);
    ZVAL_LONG(new_var2, 5);

    ZEND_SET_SYMBOL(EG(active_symbol_table), "local_variable", new_var1);
    ZEND_SET_SYMBOL(&amp;EG(symbol_table), "global_variable", new_var2);

    RETURN_NULL();

}

Longs (Integers)

Now let's get to the assignment of data to variables, starting with longs. Longs are PHP's integers and are very simple to store. Looking at the zval.value container structure discussed earlier in this chapter, you can see that the long data type is directly contained in the union, namely in the lval field. The corresponding type value for longs is IS_LONG (see 57.13 – „Creation of a long.“).

Příklad 57.13. Creation of a long.

zval *new_long;

MAKE_STD_ZVAL(new_long);

new_long-&gt;type = IS_LONG;
new_long-&gt;value.lval = 10;

Alternatively, you can use the macro ZVAL_LONG:

zval *new_long;

MAKE_STD_ZVAL(new_long);
ZVAL_LONG(new_long, 10);

Doubles (Floats)

Doubles are PHP's floats and are as easy to assign as longs, because their value is also contained directly in the union. The member in the zval.value container is dval; the corresponding type is IS_DOUBLE.

zval *new_double;

MAKE_STD_ZVAL(new_double);

new_double-&gt;type = IS_DOUBLE;
new_double-&gt;value.dval = 3.45;
Alternatively, you can use the macro ZVAL_DOUBLE:

zval *new_double;

MAKE_STD_ZVAL(new_double);
ZVAL_DOUBLE(new_double, 3.45);

Strings

Strings need slightly more effort. As mentioned earlier, all strings that will be associated with Zend's internal data structures need to be allocated using Zend's own memory-management functions. Referencing of static strings or strings allocated with standard routines is not allowed. To assign strings, you have to access the structure str in the zval.value container. The corresponding type is IS_STRING:

zval *new_string;
char *string_contents = "This is a new string variable";

MAKE_STD_ZVAL(new_string);

new_string-&gt;type = IS_STRING;
new_string-&gt;value.str.len = strlen(string_contents);
new_string-&gt;value.str.val = estrdup(string_contents);
    </programlisting>
    Note the usage of Zend's <function>estrdup</function> here.
    Of course, you can also use the predefined macro
    <literal>ZVAL_STRING</literal>:
    <programlisting>
zval *new_string;
char *string_contents = "This is a new string variable";

MAKE_STD_ZVAL(new_string);
ZVAL_STRING(new_string, string_contents, 1);
ZVAL_STRING accepts a third parameter that indicates whether the supplied string contents should be duplicated (using estrdup()). Setting this parameter to 1 causes the string to be duplicated; 0 simply uses the supplied pointer for the variable contents. This is most useful if you want to create a new variable referring to a string that's already allocated in Zend internal memory.

If you want to truncate the string at a certain position or you already know its length, you can use ZVAL_STRINGL(zval, string, length, duplicate), which accepts an explicit string length to be set for the new string. This macro is faster than ZVAL_STRING and also binary-safe.

To create empty strings, set the string length to 0 and use empty_string as contents:

new_string-&gt;type = IS_STRING;
new_string-&gt;value.str.len = 0;
new_string-&gt;value.str.val = empty_string;
Of course, there's a macro for this as well (ZVAL_EMPTY_STRING):

MAKE_STD_ZVAL(new_string);
ZVAL_EMPTY_STRING(new_string);

Booleans

Booleans are created just like longs, but have the type IS_BOOL. Allowed values in lval are 0 and 1:

zval *new_bool;

MAKE_STD_ZVAL(new_bool);

new_bool-&gt;type = IS_BOOL;
new_bool-&gt;value.lval = 1;
The corresponding macros for this type are ZVAL_BOOL (allowing specification of the value) as well as ZVAL_TRUE and ZVAL_FALSE (which explicitly set the value to TRUE and FALSE, respectively).

Arrays

Arrays are stored using Zend's internal hash tables, which can be accessed using the zend_hash_*() API. For every array that you want to create, you need a new hash table handle, which will be stored in the ht member of the zval.value container.

There's a whole API solely for the creation of arrays, which is extremely handy. To start a new array, you call array_init().

zval *new_array;

MAKE_STD_ZVAL(new_array);

array_init(new_array);
array_init() always returns SUCCESS.

To add new elements to the array, you can use numerous functions, depending on what you want to do. 57.9 – „Zend's API for Associative Arrays“, 57.10 – „Zend's API for Indexed Arrays, Part 1“ and 57.11 – „Zend's API for Indexed Arrays, Part 2“ describe these functions. All functions return FAILURE on failure and SUCCESS on success.

Tabulka 57.9. Zend's API for Associative Arrays

Function | Description
add_assoc_long(zval *array, char *key, long n);() | Adds an element of type long.
add_assoc_unset(zval *array, char *key);() | Adds an unset element.
add_assoc_bool(zval *array, char *key, int b);() | Adds a Boolean element.
add_assoc_resource(zval *array, char *key, int r);() | Adds a resource to the array.
add_assoc_double(zval *array, char *key, double d);() | Adds a floating-point value.
add_assoc_string(zval *array, char *key, char *str, int duplicate);() | Adds a string to the array. The flag duplicate specifies whether the string contents have to be copied to Zend internal memory.
add_assoc_stringl(zval *array, char *key, char *str, uint length, int duplicate); () | Adds a string with the desired length length to the array. Otherwise, behaves like add_assoc_string().
add_assoc_zval(zval *array, char *key, zval *value);() | Adds a zval to the array. Useful for adding other arrays, objects, streams, etc...

Tabulka 57.10. Zend's API for Indexed Arrays, Part 1

Function | Description
add_index_long(zval *array, uint idx, long n);() | Adds an element of type long.
add_index_unset(zval *array, uint idx);() | Adds an unset element.
add_index_bool(zval *array, uint idx, int b);() | Adds a Boolean element.
add_index_resource(zval *array, uint idx, int r);() | Adds a resource to the array.
add_index_double(zval *array, uint idx, double d);() | Adds a floating-point value.
add_index_string(zval *array, uint idx, char *str, int duplicate);() | Adds a string to the array. The flag duplicate specifies whether the string contents have to be copied to Zend internal memory.
add_index_stringl(zval *array, uint idx, char *str, uint length, int duplicate);() | Adds a string with the desired length length to the array. This function is faster and binary-safe. Otherwise, behaves like add_index_string().
add_index_zval(zval *array, uint idx, zval *value);() | Adds a zval to the array. Useful for adding other arrays, objects, streams, etc...

Tabulka 57.11. Zend's API for Indexed Arrays, Part 2

Function | Description
add_next_index_long(zval *array, long n);() | Adds an element of type long.
add_next_index_unset(zval *array);() | Adds an unset element.
add_next_index_bool(zval *array, int b);() | Adds a Boolean element.
add_next_index_resource(zval *array, int r);() | Adds a resource to the array.
add_next_index_double(zval *array, double d);() | Adds a floating-point value.
add_next_index_string(zval *array, char *str, int duplicate);() | Adds a string to the array. The flag duplicate specifies whether the string contents have to be copied to Zend internal memory.
add_next_index_stringl(zval *array, char *str, uint length, int duplicate);() | Adds a string with the desired length length to the array. This function is faster and binary-safe. Otherwise, behaves like add_index_string().
add_next_index_zval(zval *array, zval *value);() | Adds a zval to the array. Useful for adding other arrays, objects, streams, etc...

All these functions provide a handy abstraction to Zend's internal hash API. Of course, you can also use the hash functions directly - for example, if you already have a zval container allocated that you want to insert into an array. This is done using zend_hash_update() for associative arrays (see 57.14 – „Adding an element to an associative array.“) and zend_hash_index_update() for indexed arrays (see 57.15 – „Adding an element to an indexed array.“):

Příklad 57.14. Adding an element to an associative array.

zval *new_array, *new_element;
char *key = "element_key";

MAKE_STD_ZVAL(new_array);
MAKE_STD_ZVAL(new_element);

array_init(new_array);

ZVAL_LONG(new_element, 10);

if(zend_hash_update(new_array-&gt;value.ht, key, strlen(key) + 1, (void *)&amp;new_element, sizeof(zval *), NULL) == FAILURE)
{
    // do error handling here
}

Příklad 57.15. Adding an element to an indexed array.

zval *new_array, *new_element;
int key = 2;

MAKE_STD_ZVAL(new_array);
MAKE_STD_ZVAL(new_element);

array_init(new_array);

ZVAL_LONG(new_element, 10);

if(zend_hash_index_update(new_array-&gt;value.ht, key, (void *)&amp;new_element, sizeof(zval *), NULL) == FAILURE)
{
    // do error handling here
}

To emulate the functionality of add_next_index_*(), you can use this:

zend_hash_next_index_insert(ht, zval **new_element, sizeof(zval *), NULL)

Note: To return arrays from a function, use array_init() and all following actions on the predefined variable return_value (given as argument to your exported function; see the earlier discussion of the call interface). You do not have to use MAKE_STD_ZVAL on this.

Tip: To avoid having to write new_array->value.ht every time, you can use HASH_OF(new_array), which is also recommended for compatibility and style reasons.

Objects

Since objects can be converted to arrays (and vice versa), you might have already guessed that they have a lot of similarities to arrays in PHP. Objects are maintained with the same hash functions, but there's a different API for creating them.

To initialize an object, you use the function object_init():

zval *new_object;

MAKE_STD_ZVAL(new_object);

if(object_init(new_object) != SUCCESS)
{
    // do error handling here
}
You can use the functions described in 57.12 – „Zend's API for Object Creation“ to add members to your object.

Tabulka 57.12. Zend's API for Object Creation

Function | Description
add_property_long(zval *object, char *key, long l);() | Adds a long to the object.
add_property_unset(zval *object, char *key);() | Adds an unset property to the object.
add_property_bool(zval *object, char *key, int b);() | Adds a Boolean to the object.
add_property_resource(zval *object, char *key, long r);() | Adds a resource to the object.
add_property_double(zval *object, char *key, double d);() | Adds a double to the object.
add_property_string(zval *object, char *key, char *str, int duplicate);() | Adds a string to the object.
add_property_stringl(zval *object, char *key, char *str, uint length, int duplicate);() | Adds a string of the specified length to the object. This function is faster than add_property_string() and also binary-safe.
add_property_zval(zval *obect, char *key, zval *container):() | Adds a zval container to the object. This is useful if you have to add properties which aren't simple types like integers or strings but arrays or other objects.

Resources

Resources are a special kind of data type in PHP. The term resources doesn't really refer to any special kind of data, but to an abstraction method for maintaining any kind of information. Resources are kept in a special resource list within Zend. Each entry in the list has a correspondending type definition that denotes the kind of resource to which it refers. Zend then internally manages all references to this resource. Access to a resource is never possible directly - only via a provided API. As soon as all references to a specific resource are lost, a corresponding shutdown function is called.

For example, resources are used to store database links and file descriptors. The de facto standard implementation can be found in the MySQL module, but other modules such as the Oracle module also make use of resources.

Poznámka: In fact, a resource can be a pointer to anything you need to handle in your functions (e.g. pointer to a structure) and the user only has to pass a single resource variable to your function.

To create a new resource you need to register a resource destruction handler for it. Since you can store any kind of data as a resource, Zend needs to know how to free this resource if its not longer needed. This works by registering your own resource destruction handler to Zend which in turn gets called by Zend whenever your resource can be freed (whether manually or automatically). Registering your resource handler within Zend returns you the resource type handle for that resource. This handle is needed whenever you want to access a resource of this type later and is most of time stored in a global static variable within your extension. There is no need to worry about thread safety here because you only register your resource handler once during module initialization.

The Zend function to register your resource handler is defined as:

ZEND_API int zend_register_list_destructors_ex(rsrc_dtor_func_t ld, rsrc_dtor_func_t pld, char *type_name, int module_number);

There are two different kinds of resource destruction handlers you can pass to this function: a handler for normal resources and a handler for persistent resources. Persistent resources are for example used for database connection. When registering a resource, either of these handlers must be given. For the other handler just pass NULL.

zend_register_list_destructors_ex() accepts the following parameters:

ld | Normal resource destruction handler callback
pld | Pesistent resource destruction handler callback
type_name | A string specifying the name of your resource. It's always a good thing to specify a unique name within PHP for the resource type so when the user for example calls var_dump($resource); he also gets the name of the resource.
module_number | The module_number is automatically available in your PHP_MINIT_FUNCTION function and therefore you just pass it over.
The return value is a unique integer ID for your resource type.

The resource destruction handler (either normal or persistent resources) has the following prototype:

void resource_destruction_handler(zend_rsrc_list_entry *rsrc TSRMLS_DC);
The passed rsrc is a pointer to the following structure:

typedef struct _zend_rsrc_list_entry {

    void *ptr;
    int type;
    int refcount;

} zend_rsrc_list_entry;
The member void *ptr is the actual pointer to your resource.

Now we know how to start things, we define our own resource we want register within Zend. It is only a simple structure with two integer members:

typedef struct {

    int resource_link;
    int resource_type;

} my_resource;
Our resource destruction handler is probably going to look something like this:

void my_destruction_handler(zend_rsrc_list_entry *rsrc TSRMLS_DC) {

    // You most likely cast the void pointer to your structure type

    my_resource *my_rsrc = (my_resource *) rsrc->ptr;

    // Now do whatever needs to be done with you resource. Closing
    // Files, Sockets, freeing additional memory, etc.
    // Also, don't forget to actually free the memory for your resource too!

    do_whatever_needs_to_be_done_with_the_resource(my_rsrc);
}

Poznámka: One important thing to mention: If your resource is a rather complex structure which also contains pointers to memory you allocated during runtime you have to free them before freeing the resource itself!

Now that we have defined

  1. what our resource is and

  2. our resource destruction handler

we can go on and do the rest of the steps:

  1. create a global variable within the extension holding the resource ID so it can be accessed from every function which needs it

  2. define the resource name

  3. write the resource destruction handler

  4. and finally register the handler

    // Somewhere in your extension, define the variable for your registered resources.
    // If you wondered what 'le' stands for: it simply means 'list entry'.
    static int le_myresource;

    // It's nice to define your resource name somewhere
    #define le_myresource_name  "My type of resource"

    [...]

    // Now actually define our resource destruction handler
    void my_destruction_handler(zend_rsrc_list_entry *rsrc TSRMLS_DC) {

        my_resource *my_rsrc = (my_resource *) rsrc->ptr;
        do_whatever_needs_to_be_done_with_the_resource(my_rsrc);
    }

    [...]

    PHP_MINIT_FUNCTION(my_extension) {

        // Note that 'module_number' is already provided through the
        // PHP_MINIT_FUNCTION() function definition.

        le_myresource = zend_register_list_destructors_ex(my_destruction_handler, NULL, le_myresource_name, module_number);

        // You can register additional resources, initialize
        // your global vars, constants, whatever.
    }

To actually register a new resource you use can either use the zend_register_resource() function or the ZEND_REGISTER_RESOURE() macro, both defined in zend_list.h . Although the arguments for both map 1:1 it's a good idea to always use macros to be upwards compatible:

int ZEND_REGISTER_RESOURCE(zval *rsrc_result, void *rsrc_pointer, int rsrc_type);

rsrc_result | This is an already initialized zval * container.
rsrc_pointer | Your resource pointer you want to store.
rsrc_type | The type which you received when you registered the resource destruction handler. If you followed the naming scheme this would be le_myresource.
The return value is a unique integer identifier for that resource.

What is really going on when you register a new resource is it gets inserted in an internal list in Zend and the result is just stored in the given zval * container:

    rsrc_id = zend_list_insert(rsrc_pointer, rsrc_type);

    if (rsrc_result) {
        rsrc_result->value.lval = rsrc_id;
        rsrc_result->type = IS_RESOURCE;
    }

    return rsrc_id;
The returned rsrc_id uniquely identifies the newly registered resource. You can use the macro RETURN_RESOURE to return it to the user:
    RETURN_RESOURCE(rsrc_id)

Poznámka: It is common practice that if you want to return the resource immediately to the user you specify the return_value as the zval * container.

Zend now keeps track of all references to this resource. As soon as all references to the resource are lost, the destructor that you previously registered for this resource is called. The nice thing about this setup is that you don't have to worry about memory leakages introduced by allocations in your module - just register all memory allocations that your calling script will refer to as resources. As soon as the script decides it doesn't need them anymore, Zend will find out and tell you.

Now that the user got his resource, at some point he is passing it back to one of your functions. The value.lval inside the zval * container contains the key to your resource and thus can be used to fetch the resource with the following macro: ZEND_FETCH_RESOURCE:

ZEND_FETCH_RESOURCE(rsrc, rsrc_type, rsrc_id, default_rsrc_id, resource_type_name, resource_type)

rsrc | This is your pointer which will point to your previously registered resource.
rsrc_type | This is the typecast argument for your pointer, e.g. myresource *.
rsrc_id | This is the address of the zval *container the user passed to your function, e.g. &z_resource if zval *z_resource is given.
default_rsrc_id | This integer specifies the default resource ID if no resource could be fetched or -1.
resource_type_name | This is the name of the requested resource. It's a string and is used when the resource can't be found or is invalid to form a meaningful error message.
resource_type | The resource_type you got back when registering the resource destruction handler. In our example this was le_myresource.
This macro has no return value. It is for the developers convenience and takes care of TSRMLS arguments passing and also does check if the resource could be fetched. It throws a warning message and returns the current PHP function with NULL if there was a problem retrieving the resource.

To force removal of a resource from the list, use the function zend_list_delete(). You can also force the reference count to increase if you know that you're creating another reference for a previously allocated value (for example, if you're automatically reusing a default database link). For this case, use the function zend_list_addref(). To search for previously allocated resource entries, use zend_list_find(). The complete API can be found in zend_list.h.

Macros for Automatic Global Variable Creation

In addition to the macros discussed earlier, a few macros allow easy creation of simple global variables. These are nice to know in case you want to introduce global flags, for example. This is somewhat bad practice, but Table 57.13 – „Macros for Global Variable Creation“ describes macros that do exactly this task. They don't need any zval allocation; you simply have to supply a variable name and value.

Tabulka 57.13. Macros for Global Variable Creation

Macro | Description
SET_VAR_STRING(name, value) | Creates a new string.
SET_VAR_STRINGL(name, value, length) | Creates a new string of the specified length. This macro is faster than SET_VAR_STRING and also binary-safe.
SET_VAR_LONG(name, value) | Creates a new long.
SET_VAR_DOUBLE(name, value) | Creates a new double.

Creating Constants

Zend supports the creation of true constants (as opposed to regular variables). Constants are accessed without the typical dollar sign ($) prefix and are available in all scopes. Examples include TRUE and FALSE, to name just two.

To create your own constants, you can use the macros in 57.14 – „Macros for Creating Constants“. All the macros create a constant with the specified name and value.

You can also specify flags for each constant:

  • CONST_CS - This constant's name is to be treated as case sensitive.

  • CONST_PERSISTENT - This constant is persistent and won't be "forgotten" when the current process carrying this constant shuts down.

To use the flags, combine them using a inary OR:
 // register a new constant of type "long"
     REGISTER_LONG_CONSTANT("NEW_MEANINGFUL_CONSTANT", 324, CONST_CS |
     CONST_PERSISTENT);
There are two types of macros - REGISTER_*_CONSTANT andREGISTER_MAIN_*_CONSTANT. The first type creates constants bound to the current module. These constants are dumped from the symbol table as soon as the module that registered the constant is unloaded from memory. The second type creates constants that remain in the symbol table independently of the module.

Tabulka 57.14. Macros for Creating Constants

Macro | Description
REGISTER_LONG_CONSTANT(name, value, flags) REGISTER_MAIN_LONG_CONSTANT(name, value, flags) | Registers a new constant of type long.
REGISTER_DOUBLE_CONSTANT(name, value, flags) REGISTER_MAIN_DOUBLE_CONSTANT(name, value, flags) | Registers a new constant of type double.
REGISTER_STRING_CONSTANT(name, value, flags) REGISTER_MAIN_STRING_CONSTANT(name, value, flags) | Registers a new constant of type string. The specified string must reside in Zend's internal memory.
REGISTER_STRINGL_CONSTANT(name, value, length, flags) REGISTER_MAIN_STRINGL_CONSTANT(name, value, length, flags) | Registers a new constant of type string. The string length is explicitly set to length. The specified string must reside in Zend's internal memory.

Duplicating Variable Contents: The Copy Constructor

Sooner or later, you may need to assign the contents of one zval container to another. This is easier said than done, since the zval container doesn't contain only type information, but also references to places in Zend's internal data. For example, depending on their size, arrays and objects may be nested with lots of hash table entries. By assigning one zval to another, you avoid duplicating the hash table entries, using only a reference to them (at most).

To copy this complex kind of data, use the copy constructor. Copy constructors are typically defined in languages that support operator overloading, with the express purpose of copying complex types. If you define an object in such a language, you have the possibility of overloading the "=" operator, which is usually responsible for assigning the contents of the rvalue (result of the evaluation of the right side of the operator) to the lvalue (same for the left side).

Overloading means assigning a different meaning to this operator, and is usually used to assign a function call to an operator. Whenever this operator would be used on such an object in a program, this function would be called with the lvalue and rvalue as parameters. Equipped with that information, it can perform the operation it intends the "=" operator to have (usually an extended form of copying).

This same form of "extended copying" is also necessary for PHP's zval containers. Again, in the case of an array, this extended copying would imply re-creation of all hash table entries relating to this array. For strings, proper memory allocation would have to be assured, and so on.

Zend ships with such a function, called zend_copy_ctor() (the previous PHP equivalent was pval_copy_constructor()).

A most useful demonstration is a function that accepts a complex type as argument, modifies it, and then returns the argument:

zval *parameter;

if (zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC, "z", &amp;parameter) == FAILURE)
   return;
}

// do modifications to the parameter here

// now we want to return the modified container:
*return_value = *parameter;
zval_copy_ctor(return_value);

The first part of the function is plain-vanilla argument retrieval. After the (left out) modifications, however, it gets interesting: The container of parameter is assigned to the (predefined) return_value container. Now, in order to effectively duplicate its contents, the copy constructor is called. The copy constructor works directly with the supplied argument, and the standard return values are FAILURE on failure and SUCCESS on success.

If you omit the call to the copy constructor in this example, both parameter and return_value would point to the same internal data, meaning that return_value would be an illegal additional reference to the same data structures. Whenever changes occurred in the data that parameter points to, return_value might be affected. Thus, in order to create separate copies, the copy constructor must be used.

The copy constructor's counterpart in the Zend API, the destructor zval_dtor(), does the opposite of the constructor.

Returning Values

Returning values from your functions to PHP was described briefly in an earlier section; this section gives the details. Return values are passed via the return_value variable, which is passed to your functions as argument. The return_value argument consists of a zval container (see the earlier discussion of the call interface) that you can freely modify. The container itself is already allocated, so you don't have to run MAKE_STD_ZVAL on it. Instead, you can access its members directly.

To make returning values from functions easier and to prevent hassles with accessing the internal structures of the zval container, a set of predefined macros is available (as usual). These macros automatically set the correspondent type and value, as described in 57.15 – „Predefined Macros for Returning Values from a Function“ and 57.16 – „Predefined Macros for Setting the Return Value of a Function“.

Poznámka: The macros in 57.15 – „Predefined Macros for Returning Values from a Function“ automatically return from your function, those in 57.16 – „Predefined Macros for Setting the Return Value of a Function“ only set the return value; they don't return from your function.

Tabulka 57.15. Predefined Macros for Returning Values from a Function

Macro | Description
RETURN_RESOURCE(resource) | Returns a resource.
RETURN_BOOL(bool) | Returns a Boolean.
RETURN_NULL() | Returns nothing (a NULL value).
RETURN_LONG(long) | Returns a long.
RETURN_DOUBLE(double) | Returns a double.
RETURN_STRING(string, duplicate) | Returns a string. The duplicate flag indicates whether the string should be duplicated using estrdup().
RETURN_STRINGL(string, length, duplicate) | Returns a string of the specified length; otherwise, behaves like RETURN_STRING. This macro is faster and binary-safe, however.
RETURN_EMPTY_STRING() | Returns an empty string.
RETURN_FALSE | Returns Boolean false.
RETURN_TRUE | Returns Boolean true.

Tabulka 57.16. Predefined Macros for Setting the Return Value of a Function

Macro | Description
RETVAL_RESOURCE(resource) | Sets the return value to the specified resource.
RETVAL_BOOL(bool) | Sets the return value to the specified Boolean value.
RETVAL_NULL | Sets the return value to NULL.
RETVAL_LONG(long) | Sets the return value to the specified long.
RETVAL_DOUBLE(double) | Sets the return value to the specified double.
RETVAL_STRING(string, duplicate) | Sets the return value to the specified string and duplicates it to Zend internal memory if desired (see also RETURN_STRING).
RETVAL_STRINGL(string, length, duplicate) | Sets the return value to the specified string and forces the length to become length (see also RETVAL_STRING). This macro is faster and binary-safe, and should be used whenever the string length is known.
RETVAL_EMPTY_STRING | Sets the return value to an empty string.
RETVAL_FALSE | Sets the return value to Boolean false.
RETVAL_TRUE | Sets the return value to Boolean true.

Complex types such as arrays and objects can be returned by using array_init() and object_init(), as well as the corresponding hash functions on return_value. Since these types cannot be constructed of trivial information, there are no predefined macros for them.

Printing Information

Often it's necessary to print messages to the output stream from your module, just as print() would be used within a script. PHP offers functions for most generic tasks, such as printing warning messages, generating output for phpinfo(), and so on. The following sections provide more details. Examples of these functions can be found on the CD-ROM.

zend_printf()

zend_printf() works like the standard printf(), except that it prints to Zend's output stream.

zend_error()

zend_error() can be used to generate error messages. This function accepts two arguments; the first is the error type (see zend_errors.h), and the second is the error message.

zend_error(E_WARNING, "This function has been called with empty arguments");
57.17 – „Zend's Predefined Error Messages.“ shows a list of possible values (see below). These values are also referred to in php.ini. Depending on which error type you choose, your messages will be logged.

Tabulka 57.17. Zend's Predefined Error Messages.

Error | Description
E_ERROR | Signals an error and terminates execution of the script immediately.
E_WARNING | Signals a generic warning. Execution continues.
E_PARSE | Signals a parser error. Execution continues.
E_NOTICE | Signals a notice. Execution continues. Note that by default the display of this type of error messages is turned off in php.ini.
E_CORE_ERROR | Internal error by the core; shouldn't be used by user-written modules.
E_COMPILE_ERROR | Internal error by the compiler; shouldn't be used by user-written modules.
E_COMPILE_WARNING | Internal warning by the compiler; shouldn't be used by user-written modules.

Including Output in phpinfo()

After creating a real module, you'll want to show information about the module in phpinfo() (in addition to the module name, which appears in the module list by default). PHP allows you to create your own section in the phpinfo() output with the ZEND_MINFO() function. This function should be placed in the module descriptor block (discussed earlier) and is always called whenever a script calls phpinfo().

PHP automatically prints a section in phpinfo() for you if you specify the ZEND_MINFO function, including the module name in the heading. Everything else must be formatted and printed by you.

Typically, you can print an HTML table header using php_info_print_table_start() and then use the standard functions php_info_print_table_header() and php_info_print_table_row(). As arguments, both take the number of columns (as integers) and the column contents (as strings). 57.16 – „ Source code and screenshot for output in phpinfo. “ shows a source example and its output. To print the table footer, use php_info_print_table_end().

Příklad 57.16. Source code and screenshot for output in phpinfo().

php_info_print_table_start();
php_info_print_table_header(2, "First column", "Second column");
php_info_print_table_row(2, "Entry in first row", "Another entry");
php_info_print_table_row(2, "Just to fill", "another row here");
php_info_print_table_end();

Execution Information

You can also print execution information, such as the current file being executed. The name of the function currently being executed can be retrieved using the function get_active_function_name(). This function returns a pointer to the function name and doesn't accept any arguments. To retrieve the name of the file currently being executed, use zend_get_executed_filename(). This function accesses the executor globals, which are passed to it using the TSRMLS_C macro. The executor globals are automatically available to every function that's called directly by Zend (they're part of the INTERNAL_FUNCTION_PARAMETERS described earlier in this chapter). If you want to access the executor globals in another function that doesn't have them available automatically, call the macro TSRMLS_FETCH() once in that function; this will introduce them to your local scope.

Finally, the line number currently being executed can be retrieved using the function zend_get_executed_lineno(). This function also requires the executor globals as arguments. For examples of these functions, see 57.17 – „Printing execution information.“.

Příklad 57.17. Printing execution information.

zend_printf("The name of the current function is %s&lt;br&gt;", get_active_function_name(TSRMLS_C));
zend_printf("The file currently executed is %s&lt;br&gt;", zend_get_executed_filename(TSRMLS_C));
zend_printf("The current line being executed is %i&lt;br&gt;", zend_get_executed_lineno(TSRMLS_C));

Startup and Shutdown Functions

Startup and shutdown functions can be used for one-time initialization and deinitialization of your modules. As discussed earlier in this chapter (see the description of the Zend module descriptor block), there are module, and request startup and shutdown events.

The module startup and shutdown functions are called whenever a module is loaded and needs initialization; the request startup and shutdown functions are called every time a request is processed (meaning that a file is being executed).

For dynamic extensions, module and request startup/shutdown events happen at the same time.

Declaration and implementation of these functions can be done with macros; see the earlier section "Declaration of the Zend Module Block" for details.

Calling User Functions

You can call user functions from your own modules, which is very handy when implementing callbacks; for example, for array walking, searching, or simply for event-based programs.

User functions can be called with the function call_user_function_ex(). It requires a hash value for the function table you want to access, a pointer to an object (if you want to call a method), the function name, return value, number of arguments, argument array, and a flag indicating whether you want to perform zval separation.

ZEND_API int call_user_function_ex(HashTable *function_table, zval *object,
zval *function_name, zval **retval_ptr_ptr,
int param_count, zval **params[],
int no_separation);

Note that you don't have to specify both function_table and object; either will do. If you want to call a method, you have to supply the object that contains this method, in which case call_user_function()automatically sets the function table to this object's function table. Otherwise, you only need to specify function_table and can set object to NULL.

Usually, the default function table is the "root" function table containing all function entries. This function table is part of the compiler globals and can be accessed using the macro CG. To introduce the compiler globals to your function, call the macro TSRMLS_FETCH once.

The function name is specified in a zval container. This might be a bit surprising at first, but is quite a logical step, since most of the time you'll accept function names as parameters from calling functions within your script, which in turn are contained in zval containers again. Thus, you only have to pass your arguments through to this function. This zval must be of type IS_STRING.

The next argument consists of a pointer to the return value. You don't have to allocate memory for this container; the function will do so by itself. However, you have to destroy this container (using zval_dtor()) afterward!

Next is the parameter count as integer and an array containing all necessary parameters. The last argument specifies whether the function should perform zval separation - this should always be set to 0. If set to 1, the function consumes less memory but fails if any of the parameters need separation.

57.18 – „Calling user functions.“ shows a small demonstration of calling a user function. The code calls a function that's supplied to it as argument and directly passes this function's return value through as its own return value. Note the use of the constructor and destructor calls at the end - it might not be necessary to do it this way here (since they should be separate values, the assignment might be safe), but this is bulletproof.

Příklad 57.18. Calling user functions.

zval **function_name;
zval *retval;

if((ZEND_NUM_ARGS() != 1) || (zend_get_parameters_ex(1, &function_name) != SUCCESS))
{
    WRONG_PARAM_COUNT;
}

if((*function_name)->type != IS_STRING)
{
    zend_error(E_ERROR, "Function requires string argument");
}

TSRMSLS_FETCH();

if(call_user_function_ex(CG(function_table), NULL, *function_name, &retval, 0, NULL, 0) != SUCCESS)
{
    zend_error(E_ERROR, "Function call failed");
}

zend_printf("We have %i as type\n", retval->type);

*return_value = *retval;
zval_copy_ctor(return_value);
zval_ptr_dtor(&retval);

<?php

dl("call_userland.so");

function test_function()
{
    echo "We are in the test function!\n";
    return 'hello';
}

$return_value = call_userland("test_function");

echo "Return value: '$return_value'";
?>

Výše uvedený příklad vypíše:

We are in the test function!
We have 3 as type
Return value: 'hello'

Initialization File Support

PHP 4 features a redesigned initialization file support. It's now possible to specify default initialization entries directly in your code, read and change these values at runtime, and create message handlers for change notifications.

To create an .ini section in your own module, use the macros PHP_INI_BEGIN() to mark the beginning of such a section and PHP_INI_END() to mark its end. In between you can use PHP_INI_ENTRY() to create entries.

PHP_INI_BEGIN()
PHP_INI_ENTRY("first_ini_entry",  "has_string_value", PHP_INI_ALL, NULL)
PHP_INI_ENTRY("second_ini_entry", "2",                PHP_INI_SYSTEM, OnChangeSecond)
PHP_INI_ENTRY("third_ini_entry",  "xyz",              PHP_INI_USER, NULL)
PHP_INI_END()
The PHP_INI_ENTRY() macro accepts four parameters: the entry name, the entry value, its change permissions, and a pointer to a change-notification handler. Both entry name and value must be specified as strings, regardless of whether they really are strings or integers.

The permissions are grouped into three sections:PHP_INI_SYSTEM allows a change only directly in the php.ini file; PHP_INI_USER allows a change to be overridden by a user at runtime using additional configuration files, such as .htaccess; and PHP_INI_ALL allows changes to be made without restrictions. There's also a fourth level, PHP_INI_PERDIR, for which we couldn't verify its behavior yet.

The fourth parameter consists of a pointer to a change-notification handler. Whenever one of these initialization entries is changed, this handler is called. Such a handler can be declared using the PHP_INI_MH macro:

PHP_INI_MH(OnChangeSecond);             // handler for ini-entry "second_ini_entry"

// specify ini-entries here

PHP_INI_MH(OnChangeSecond)
{

    zend_printf("Message caught, our ini entry has been changed to %s&lt;br&gt;", new_value);

    return(SUCCESS);

}
The new value is given to the change handler as string in the variable new_value. When looking at the definition of PHP_INI_MH, you actually have a few parameters to use:

#define PHP_INI_MH(name) int name(php_ini_entry *entry, char *new_value,
                                  uint new_value_length, void *mh_arg1,
                                  void *mh_arg2, void *mh_arg3)
All these definitions can be found in php_ini.h. Your message handler will have access to a structure that contains the full entry, the new value, its length, and three optional arguments. These optional arguments can be specified with the additional macros PHP_INI_ENTRY1 (allowing one additional argument), PHP_INI_ENTRY2 (allowing two additional arguments), and PHP_INI_ENTRY3 (allowing three additional arguments).

The change-notification handlers should be used to cache initialization entries locally for faster access or to perform certain tasks that are required if a value changes. For example, if a constant connection to a certain host is required by a module and someone changes the hostname, automatically terminate the old connection and attempt a new one.

Access to initialization entries can also be handled with the macros shown in 57.18 – „Macros to Access Initialization Entries in PHP“.

Tabulka 57.18. Macros to Access Initialization Entries in PHP

Macro | Description
INI_INT(name) | Returns the current value of entry name as integer (long).
INI_FLT(name) | Returns the current value of entry name as float (double).
INI_STR(name) | Returns the current value of entry name as string. Note: This string is not duplicated, but instead points to internal data. Further access requires duplication to local memory.
INI_BOOL(name) | Returns the current value of entry name as Boolean (defined as zend_bool, which currently means unsigned char).
INI_ORIG_INT(name) | Returns the original value of entry name as integer (long).
INI_ORIG_FLT(name) | Returns the original value of entry name as float (double).
INI_ORIG_STR(name) | Returns the original value of entry name as string. Note: This string is not duplicated, but instead points to internal data. Further access requires duplication to local memory.
INI_ORIG_BOOL(name) | Returns the original value of entry name as Boolean (defined as zend_bool, which currently means unsigned char).

Finally, you have to introduce your initialization entries to PHP. This can be done in the module startup and shutdown functions, using the macros REGISTER_INI_ENTRIES() and UNREGISTER_INI_ENTRIES():

ZEND_MINIT_FUNCTION(mymodule)
{

    REGISTER_INI_ENTRIES();

}

ZEND_MSHUTDOWN_FUNCTION(mymodule)
{

    UNREGISTER_INI_ENTRIES();

}

Where to Go from Here

You've learned a lot about PHP. You now know how to create dynamic loadable modules and statically linked extensions. You've learned how PHP and Zend deal with internal storage of variables and how you can create and access these variables. You know quite a set of tool functions that do a lot of routine tasks such as printing informational texts, automatically introducing variables to the symbol table, and so on.

Even though this chapter often had a mostly "referential" character, we hope that it gave you insight on how to start writing your own extensions. For the sake of space, we had to leave out a lot; we suggest that you take the time to study the header files and some modules (especially the ones in the ext/standard directory and the MySQL module, as these implement commonly known functionality). This will give you an idea of how other people have used the API functions - particularly those that didn't make it into this chapter.

Reference: Some Configuration Macros

config.m4

The file config.m4 is processed by buildconf and must contain all the instructions to be executed during configuration. For example, these can include tests for required external files, such as header files, libraries, and so on. PHP defines a set of macros that can be used in this process, the most useful of which are described in 57.19 – „M4 Macros for config.m4“.

Tabulka 57.19. M4 Macros for config.m4

Macro | Description
AC_MSG_CHECKING(message) | Prints a "checking <message>" text during configure.
AC_MSG_RESULT(value) | Gives the result to AC_MSG_CHECKING; should specify either yes or no as value.
AC_MSG_ERROR(message) | Prints message as error message during configure and aborts the script.
AC_DEFINE(name,value,description) | Adds #define to php_config.h with the value of value and a comment that says description (this is useful for conditional compilation of your module).
AC_ADD_INCLUDE(path) | Adds a compiler include path; for example, used if the module needs to add search paths for header files.
AC_ADD_LIBRARY_WITH_PATH(libraryname,librarypath) | Specifies an additional library to link.
AC_ARG_WITH(modulename,description,unconditionaltest,conditionaltest) | Quite a powerful macro, adding the module with description to the configure --help output. PHP checks whether the option --with-<modulename> is given to the configure script. If so, it runs the script unconditionaltest (for example, --with-myext=yes), in which case the value of the option is contained in the variable $withval. Otherwise, it executes conditionaltest.
PHP_EXTENSION(modulename, [shared]) | This macro is a must to call for PHP to configure your extension. You can supply a second argument in addition to your module name, indicating whether you intend compilation as a shared module. This will result in a definition at compile time for your source as COMPILE_DL_<modulename>.

API Macros

A set of macros was introduced into Zend's API that simplify access to zval containers (see 57.20 – „API Macros for Accessing zval Containers“).

Tabulka 57.20. API Macros for Accessing zval Containers

Macro | Refers to
Z_LVAL(zval) | (zval).value.lval
Z_DVAL(zval) | (zval).value.dval
Z_STRVAL(zval) | (zval).value.str.val
Z_STRLEN(zval) | (zval).value.str.len
Z_ARRVAL(zval) | (zval).value.ht
Z_LVAL_P(zval) | (*zval).value.lval
Z_DVAL_P(zval) | (*zval).value.dval
Z_STRVAL_P(zval_p) | (*zval).value.str.val
Z_STRLEN_P(zval_p) | (*zval).value.str.len
Z_ARRVAL_P(zval_p) | (*zval).value.ht
Z_LVAL_PP(zval_pp) | (**zval).value.lval
Z_DVAL_PP(zval_pp) | (**zval).value.dval
Z_STRVAL_PP(zval_pp) | (**zval).value.str.val
Z_STRLEN_PP(zval_pp) | (**zval).value.str.len
Z_ARRVAL_PP(zval_pp) | (**zval).value.ht

Předcházející | Nahoru | Další
Streams API for PHP Extension Authors | Domů | TSRM API


Kapitola 58. The future: PHP 6 and Zend Engine 3

Předcházející | Nahoru | Další
TSRM API | Domů | VIII. FAQ: Často kladené otázky


extends

Often you need classes with similar variables and functions to another existing class. In fact, it is good practice to define a generic class which can be used in all your projects and adapt this class for the needs of each of your specific projects. To facilitate this, classes can be extensions of other classes. The extended or derived class has all variables and functions of the base class (this is called 'inheritance' despite the fact that nobody died) and what you add in the extended definition. It is not possible to subtract from a class, that is, to undefine any existing functions or variables. An extended class is always dependent on a single base class, that is, multiple inheritance is not supported. Classes are extended using the keyword 'extends'.

<?php
class Named_Cart extends Cart {
    var $owner;

    function set_owner ($name) {
        $this->owner = $name;
    }
}
?>

This defines a class Named_Cart that has all variables and functions of Cart plus an additional variable $owner and an additional function set_owner(). You create a named cart the usual way and can now set and get the carts owner. You can still use normal cart functions on named carts:

<?php
$ncart = new Named_Cart;    // Create a named cart
$ncart->set_owner("kris");  // Name that cart
print $ncart->owner;        // print the cart owners name
$ncart->add_item("10", 1);  // (inherited functionality from cart)
?>

This is also called a "parent-child" relationship. You create a class, parent, and use extends to create a new class based on the parent class: the child class. You can even use this new child class and create another class based on this child class.

Poznámka: Classes must be defined before they are used! If you want the class Named_Cart to extend the class Cart, you will have to define the class Cart first. If you want to create another class called Yellow_named_cart based on the class Named_Cart you have to define Named_Cart first. To make it short: the order in which the classes are defined is important.

Předcházející | Nahoru | Další
18. Classes and Objects (PHP 4) | Domů | Constructors


Scope Resolution Operator (::)

Výstraha

The following is valid for PHP 4 and later only.

Sometimes it is useful to refer to functions and variables in base classes or to refer to functions in classes that have not yet any instances. The :: operator is being used for this.

<?php
class A {
    function example() {
        echo "I am the original function A::example().<br />\n";
    }
}

class B extends A {
    function example() {
        echo "I am the redefined function B::example().<br />\n";
        A::example();
    }
}

// there is no object of class A.
// this will print
//   I am the original function A::example().<br />
A::example();

// create an object of class B.
$b = new B;

// this will print
//   I am the redefined function B::example().<br />
//   I am the original function A::example().<br />
$b->example();
?>

The above example calls the function example() in class A, but there is no object of class A, so that we cannot write $a->example() or similar. Instead we call example() as a 'class function', that is, as a function of the class itself, not any object of that class.

There are class functions, but there are no class variables. In fact, there is no object at all at the time of the call. Thus, a class function may not use any object variables (but it can use local and global variables), and it may not use $this at all.

In the above example, class B redefines the function example(). The original definition in class A is shadowed and no longer available, unless you are referring specifically to the implementation of example() in class A using the ::-operator. Write A::example() to do this (in fact, you should be writing parent::example(), as shown in the next section).

In this context, there is a current object and it may have object variables. Thus, when used from WITHIN an object function, you may use $this and object variables.

Předcházející | Nahoru | Další
Constructors | Domů | parent


parent

You may find yourself writing code that refers to variables and functions in base classes. This is particularly true if your derived class is a refinement or specialisation of code in your base class.

Instead of using the literal name of the base class in your code, you should be using the special name parent, which refers to the name of your base class as given in the extends declaration of your class. By doing this, you avoid using the name of your base class in more than one place. Should your inheritance tree change during implementation, the change is easily made by simply changing the extends declaration of your class.

<?php
class A {
    function example() {
        echo "I am A::example() and provide basic functionality.<br />\n";
    }
}

class B extends A {
    function example() {
        echo "I am B::example() and provide additional functionality.<br />\n";
        parent::example();
    }
}

$b = new B;

// This will call B::example(), which will in turn call A::example().
$b->example();
?>
Předcházející | Nahoru | Další
Scope Resolution Operator (::) | Domů | Serializing objects - objects in sessions


Kapitola 21. Exceptions

Obsah

Extending Exceptions

PHP 5 has an exception model similar to that of other programming languages. An exception can be thrown, and caught ("catched") within PHP. Code may be surrounded in a try block, to facilitate the catching of potential exceptions. Each try must have at least one corresponding catch block. Multiple catch blocks can be used to catch different classes of exeptions. Normal execution (when no exception is thrown within the try block, or when a catch matching the thrown exception's class is not present) will continue after that last catch block defined in sequence. Exceptions can be thrown (or re-thrown) within a catch block.

When an exception is thrown, code following the statement will not be executed, and PHP will attempt to find the first matching catch block. If an exception is not caught, a PHP Fatal Error will be issued with an "Uncaught Exception ..." message, unless a handler has been defined with set_exception_handler().

Příklad 21.1. Throwing an Exception

<?php
function inverse($x) {
    if (!$x) {
        throw new Exception('Division by zero.');
    }
    else return 1/$x;
}

try {
    echo inverse(5) . "\n";
    echo inverse(0) . "\n";
} catch (Exception $e) {
    echo 'Caught exception: ',  $e->getMessage(), "\n";
}

// Continue execution
echo 'Hello World';
?>

Výše uvedený příklad vypíše:

0.2
Caught exception: Division by zero.
Hello World

Extending Exceptions

A User defined Exception class can be defined by extending the built-in Exception class. The members and properties below, show what is accessible within the child class that derives from the built-in Exception class.

Příklad 21.2. The Built in Exception class

<?php
class Exception
{
    protected $message = 'Unknown exception';   // exception message
    protected $code = 0;                        // user defined exception code
    protected $file;                            // source filename of exception
    protected $line;                            // source line of exception

    function __construct($message = null, $code = 0);

    final function getMessage();                // message of exception
    final function getCode();                   // code of exception
    final function getFile();                   // source filename
    final function getLine();                   // source line
    final function getTrace();                  // an array of the backtrace()
    final function getTraceAsString();          // formated string of trace

    /* Overrideable */
    function __toString();                       // formated string for display
}
?>

If a class extends the built-in Exception class and re-defines the constructor, it is highly recomended that it also call parent::__construct() to ensure all available data has been properly assigned. The __toString() method can be overriden to provide a custom output when the object is presented as a string.

Příklad 21.3. Extending the Exception class

<?php
/**
 * Define a custom exception class
 */
class MyException extends Exception
{
    // Redefine the exception so message isn't optional
    public function __construct($message, $code = 0) {
        // some code

        // make sure everything is assigned properly
        parent::__construct($message, $code);
    }

    // custom string representation of object
    public function __toString() {
        return __CLASS__ . ": [{$this->code}]: {$this->message}\n";
    }

    public function customFunction() {
        echo "A Custom function for this type of exception\n";
    }
}

/**
 * Create a class to test the exception
 */
class TestException
{
    public $var;

    const THROW_NONE    = 0;
    const THROW_CUSTOM  = 1;
    const THROW_DEFAULT = 2;

    function __construct($avalue = self::THROW_NONE) {

        switch ($avalue) {
            case self::THROW_CUSTOM:
                // throw custom exception
                throw new MyException('1 is an invalid parameter', 5);
                break;

            case self::THROW_DEFAULT:
                // throw default one.
                throw new Exception('2 isnt allowed as a parameter', 6);
                break;

            default:
                // No exception, object will be created.
                $this->var = $avalue;
                break;
        }
    }
}

// Example 1
try {
    $o = new TestException(TestException::THROW_CUSTOM);
} catch (MyException $e) {      // Will be caught
    echo "Caught my exception\n", $e;
    $e->customFunction();
} catch (Exception $e) {        // Skipped
    echo "Caught Default Exception\n", $e;
}

// Continue execution
var_dump($o);
echo "\n\n";

// Example 2
try {
    $o = new TestException(TestException::THROW_DEFAULT);
} catch (MyException $e) {      // Doesn't match this type
    echo "Caught my exception\n", $e;
    $e->customFunction();
} catch (Exception $e) {        // Will be caught
    echo "Caught Default Exception\n", $e;
}

// Continue execution
var_dump($o);
echo "\n\n";

// Example 3
try {
    $o = new TestException(TestException::THROW_CUSTOM);
} catch (Exception $e) {        // Will be caught
    echo "Default Exception caught\n", $e;
}

// Continue execution
var_dump($o);
echo "\n\n";

// Example 4
try {
    $o = new TestException();
} catch (Exception $e) {        // Skipped, no exception
    echo "Default Exception caught\n", $e;
}

// Continue execution
var_dump($o);
echo "\n\n";
?>

Předcházející | Nahoru | Další
Name resolution rules | Domů | 22. Vysvětlení referencí (odkazů)


Kapitola 20. Namespaces

Obsah

Namespaces overview
Namespace definition
Using namespaces
Global space
__NAMESPACE__
Name resolution rules

Namespaces overview

Namespaces in PHP are designed to solve scoping problem in large PHP libraries. In PHP, all class definitions are global. Thus, when a library author creates various utility or public API classes for the library, he must be aware of the possibility that other libraries with similar functionality would exist and thus choose unique names so that these libraries could be used together. Usually it is solved by prefixing the class names with an unique string - e.g., database classes would have prefix My_Library_DB, etc. As the library grows, prefixes add up, leading to the very long names.

The namespaces allow the developer to manage naming scopes without using the long names each time the class is referred to, and solve the problem of shared globals space without making code unreadable.

Namespaces are available in PHP as of PHP 5.3.0. This section is experimental and subject to changes.

Předcházející | Nahoru | Další
Late Static Bindings | Domů | Namespace definition


__NAMESPACE__

The compile-time constant __NAMESPACE__ is defined to the name of the current namespace. Outside namespace this constant has the value of empty string. This constant is useful when one needs to compose full name for local namespaced names.

Příklad 20.5. Using __NAMESPACE__

<?php
namespace A::B::C;

function foo() {
// do stuff
}

set_error_handler(__NAMESPACE__ . "::foo");
?>

Předcházející | Nahoru | Další
Global space | Domů | Name resolution rules


Namespace definition

The namespace is declared using namespace keyword, which should be at the very beginning of the file. Example:

Příklad 20.1. Defining namespace

<?php
    namespace MyProject::DB;

    const CONNECT_OK = 1;

    class Connection { /* ... */ }

    function connect() { /* ... */  }

?>

Same namespace name can be used in multiple files.

Namespace can contain class, constant and function definitions, but no free code.

Namespace definition does the following:

  • Inside namespace, all class, function and constant names in definitions are automatically prefixed with namespace name. The class name is always the full name, i.e. in the example above the class is called MyProject::DB::Connection.
  • Constant definitions create constant which is composed of namespace name and constant name. Like class constants, namespace constant can only contains static values.

  • Unqualified class name (i.e., name not containing ::) is resolved at runtime following this procedure:

    1. Class is looked up inside the current namespace (i.e. prefixing the name with the current namespace name) without attempting to autoload.
    2. Class is looked up inside the global namespace without attempting to autoload.
    3. Autoloading for name in current namespace is attempted.
    4. If previous failed, lookup fails.

  • Unqualified function name (i.e., name not containing ::) is looked up at runtime first in the current namespace and then in the global space.

  • Unqualified constant names are looked up first at current namespace and then among globally defined constants.

See also the full name resolution rules.

Předcházející | Nahoru | Další
20. Namespaces | Domů | Using namespaces


Global space

Without any namespace definition, all class and function definitions are placed into the global space - as it was in PHP before namespaces were supported. Prefixing a name with :: will specify that the name is required from the global space even in the context of the namespace.

Příklad 20.4. Using global space specification

<?php
    namespace A::B::C;

 /* This function is A::B::C::fopen */
    function fopen() {
         /* ... */
         $f = ::fopen(...); // call global fopen
         return $f;
    }
?>

Předcházející | Nahoru | Další
Using namespaces | Domů | __NAMESPACE__


Name resolution rules

Names are resolved following these resolution rules:

  1. All qualified names are translated during compilation according to current import rules. In example, if the namespace A::B::C is imported, a call to C::D::e() is translated to A::B::C::D::e().
  2. Unqualified class names are translated during compilation according to current import rules (full name substituted for short imported name). In example, if the namespace A::B::C is imported, new C() is translated to new A::B::C().
  3. Inside namespace, calls to unqualified functions that are defined in the current namespace (and are known at the time the call is parsed) are interpreted as calls to these namespace functions, at compile time.

  4. Inside namespace (say A::B), calls to unqualified functions that are not defined in current namespace are resolved at run-time. Here is how a call to function foo() is resolved:

    1. It looks for a function from the current namespace : A::B::foo().
    2. It tries to find and call the internal function foo().

    To call a user defined function in the global namespace, ::foo() has to be used.

  5. Inside namespace (say A::B), calls to unqualified class names are resolved at run-time. Here is how a call to new C() is resolved:

    1. It looks for a class from the current namespace : A::B::C().
    2. It tries to find and call the internal class C().
    3. It attemts to autoload A::B::C(). C().

    To reference a user defined class in the global namespace, new ::C() has to be used.

  6. Calls to qualified functions are resolved at run-time. Here is how a call to A::B::foo() is resolved:

    1. It looks for a function foo() in the namespace A::B.
    2. It looks for a class A::B and call its static method foo(). It will autoload the class if necessary.
  7. Qualified class names are resolved in compile-time as class from corresponding namespace. For example, new A::B::C() refers to class C from namespace >A::B.

Příklad 20.6. Name resolutions illustrated

<?php
namespace A;

// function calls

foo();      // first tries to call "foo" defined in namespace "A"
            // then calls internal function "foo"

::foo();    // calls function "foo" defined in global scope

// class references

new B();    // first tries to create object of class "B" defined in namespace "A"
            // then creates object of internal class "B"

new ::B();  // creates object of class "B" defined in global scope

// static methods/namespace functions from another namespace

B::foo();   // first tries to call function "foo" from namespace "A::B"
            // then calls method "foo" of internal class "B"

::B::foo(); // first tries to call function "foo" from namespace "B"
            // then calls method "foo" of class "B" from global scope

// static methods/namespace functions of current namespace

A::foo();   // first tries to call function "foo" from namespace "A::A"
            // then tries to call method "foo" of class "A" from namespace "A"
            // then tries to call function "foo" from namespace "A"
            // then calls method "foo" of internal class "A"

::A::foo(); // first tries to call function "foo" from namespace "A"
            // then calls method "foo" of class "A" from global scope
?>

Předcházející | Nahoru | Další
__NAMESPACE__ | Domů | 21. Exceptions


Using namespaces

Every class and function in a namespace can be referred to by the full name - e.g. MyProject::DB::Connection or MyProject::DB::connect - at any time.

Příklad 20.2. Using namespaced name

<?php
    require 'MyProject/Db/Connection.php';
    $x = new MyProject::DB::Connection;
    MyProject::DB::connect();
?>

Namespaces can be imported into current context (global or namespace) using the use operator. The syntax for the operator is:

<?php
/* ... */
use Some::Name as Othername;

// The simplified form of use:
use Foo::Bar;
// which is the same as :
use Foo::Bar as Bar;
?>
The imported name works as follows: every time that the compiler encounters the local name Othername (as stand-alone name or as prefix to the longer name separated by ::) the imported name Some::Name is substituted instead.

use can be used only in global scope, not inside function or class. Imported names have effect from the point of import to the end of the current file. It is recommended to put imports at the beginning of the file to avoid confusion.

Příklad 20.3. Importing and accessing namespace

<?php
    require 'MyProject/Db/Connection.php';
    use MyProject::DB;
    use MyProject::DB::Connection as DbConnection;

    $x = new MyProject::DB::Connection();
    $y = new DB::connection();
    $z = new DbConnection();
    DB::connect();
?>

Poznámka: The import operation is compile-time only, all local names are converted to their full equivalents by the compiler. Note that it won't translate names in strings, so callbacks can't rely on import rules.

Předcházející | Nahoru | Další
Namespace definition | Domů | Global space


Late Static Bindings

As of PHP 5.3.0, PHP implements a feature called late static bindings which can be used to reference the called class in a context of static inheritance.

This feature was named "late static bindings" with an internal perspective in mind. "Late binding" comes from the fact that static:: will no longer be resolved using the class where the method is defined but it will rather be computed using runtime information. It was also called a "static binding" as it can be used for (but is not limited to) static method calls.

Limitations of self::

Static references to the current class like self:: or __CLASS__ are resolved using the class in which the function belongs, as in where it was defined:

Příklad 19.42. self:: usage

<?php
class A {
    public static function who() {
        echo __CLASS__;
    }
    public static function test() {
        self::who();
    }
}

class B extends A {
    public static function who() {
         echo __CLASS__;
    }
}

B::test();
?>

Výše uvedený příklad vypíše:

A

Late Static Bindings' usage

Late static bindings tries to solve that limitation by introducing a keyword that references the class that was initially called at runtime. Basically, a keyword that would allow you to reference B from test() in the previous example. It was decided not to introduce a new keyword but rather use static that was already reserved.

Příklad 19.43. static:: simple usage

<?php
class A {
    public static function who() {
        echo __CLASS__;
    }
    public static function test() {
        static::who(); // Here comes Late Static Bindings
    }
}

class B extends A {
    public static function who() {
         echo __CLASS__;
    }
}

B::test();
?>

Výše uvedený příklad vypíše:

B

Poznámka: static:: does not work like $this for static methods! $this-> follows the rules of inheritance while static:: doesn't. This difference is detailed later on this manual page.

Příklad 19.44. static:: usage in a non-static context

<?php
class TestChild extends TestParent {
    public function __construct() {
        static::who();
    }

    public function test() {
        $o = new TestParent();
    }

    public static function who() {
        echo __CLASS__."\n";
    }
}

class TestParent {
    public function __construct() {
        static::who();
    }

    public static function who() {
        echo __CLASS__."\n";
    }
}
$o = new TestChild;
$o->test();

?>

Výše uvedený příklad vypíše:

TestChild
TestParent

Poznámka: Late static bindings' resolution will stop at a fully resolved static call with no fallback.

Příklad 19.45. Fully resolved static calls

<?php
class A {
    public static function foo() {
        static::who();
    }

    public static function who() {
        echo __CLASS__."\n";
    }
}

class B extends A {
    public static function test() {
        A::foo();
    }

    public static function who() {
        echo __CLASS__."\n";
    }
}

B::test();
?>

Výše uvedený příklad vypíše:

A

Edge cases

There are lots of different ways to trigger a method call in PHP, like callbacks or magic methods. As late static bindings base their resolution on runtime information, it might give unexpected results in so-called edge cases.

Příklad 19.46. Late static bindings inside magic methods

<?php
class A {

   protected static function who() {
        echo __CLASS__."\n";
   }

   public function __get($var) {
       return static::who();
   }
}

class B extends A {

   protected static function who() {
        echo __CLASS__."\n";
   }
}

$b = new B;
$b->foo;
?>

Výše uvedený příklad vypíše:

B

Předcházející | Nahoru | Další
Type Hinting | Domů | 20. Namespaces


Constructors

Constructors are functions in a class that are automatically called when you create a new instance of a class with new. A function becomes a constructor, when it has the same name as the class. If a class has no constructor, the constructor of the base class will be called, if it exists.

<?php
class Auto_Cart extends Cart {
    function Auto_Cart() {
        $this->add_item("10", 1);
    }
}
?>

This defines a class Auto_Cart that is a Cart plus a constructor which initializes the cart with one item of article number "10" each time a new Auto_Cart is being made with "new". Constructors can take arguments and these arguments can be optional, which makes them much more useful. To be able to still use the class without parameters, all parameters to constructors should be made optional by providing default values.

<?php
class Constructor_Cart extends Cart {
    function Constructor_Cart($item = "10", $num = 1) {
        $this->add_item ($item, $num);
    }
}

// Shop the same old boring stuff.
$default_cart = new Constructor_Cart;

// Shop for real...
$different_cart = new Constructor_Cart("20", 17);
?>

You also can use the @ operator to mute errors occurring in the constructor, e.g. @new.

<?php
class A
{
    function A()
    {
        echo "I am the constructor of A.<br />\n";
    }

    function B()
    {
        echo "I am a regular function named B in class A.<br />\n";
        echo "I am not a constructor in A.<br />\n";
    }
}

class B extends A
{
}

// This will call B() as a constructor
$b = new B;
?>

The function B() in class A will suddenly become a constructor in class B, although it was never intended to be. PHP 4 does not care if the function is being defined in class B, or if it has been inherited.

Výstraha

PHP 4 doesn't call constructors of the base class automatically from a constructor of a derived class. It is your responsibility to propagate the call to constructors upstream where appropriate.

Destructors are functions that are called automatically when an object is destroyed, either with unset() or by simply going out of scope. There are no destructors in PHP. You may use register_shutdown_function() instead to simulate most effects of destructors.

Předcházející | Nahoru | Další
extends | Domů | Scope Resolution Operator (::)


The magic functions __sleep and __wakeup

serialize() checks if your class has a function with the magic name __sleep. If so, that function is being run prior to any serialization. It can clean up the object and is supposed to return an array with the names of all variables of that object that should be serialized. If the method doesn't return anything then NULL is serialized and E_NOTICE is issued.

The intended use of __sleep is to commit pending data or perform similar cleanup tasks. Also, the function is useful if you have very large objects which need not be saved completely.

Conversely, unserialize() checks for the presence of a function with the magic name __wakeup. If present, this function can reconstruct any resources that object may have.

The intended use of __wakeup is to reestablish any database connections that may have been lost during serialization and perform other reinitialization tasks.

Předcházející | Nahoru | Další
Serializing objects - objects in sessions | Domů | References inside the constructor


Typové operátory

Operátor instanceof se pou?ívá pro zjištění informace o tom, jestli je objekt odvozen z dané třídy nebo jejího potomka nebo zda implementuje dané rozhraní.

Předcházející | Nahoru | Další
Řetězcové operátory | Domů | 16. Řídicí struktury


empty("0")

Asi nejkontroverznější změnou v chování je změna ve funkci empty(). Řetězec obsahující pouze znak '0' (nula) je nyní považován za prázdný, což v PHP 3 nebylo.

Toto nové chování má smysl u aplikací pro web tam, kde všechna vstupní pole vrací řetězce, i když je požadován číselný vstup, a se schopností PHP provádět automatickou typovou konverzi. Na druhou stranu může v některých případech vést k chybnému chování, jehož příčiny se špatně zjištují, pokud nevíte, co máte hledat.

Předcházející | Nahoru | Další
Inicializátory | Domů | Chybějící funkce


Příloha C. Migrating from PHP 5.0.x to PHP 5.1.x

Obsah

Key PHP 5.1.x features
Changes in reference handling
Reading []
Integer values in function parameters
Class and object changes
Extensions
Date/time support
Changes in database support
Checking for E_STRICT

Key PHP 5.1.x features

Some of the key features of PHP 5.1.x include:

  • A complete rewrite of date handling code, with improved timezone support.

  • Significant performance improvements compared to PHP 5.0.X.

  • PDO extension is now enabled by default.

  • Over 30 new functions in various extensions and built-in functionality.

  • Over 400 various bug fixes.

Předcházející | Nahoru | Další
Other Enhancements | Domů | Changes in reference handling


Changes in database support

  • PDO overview

  • Changes in MySQL support

  • Changes in SQLite support

PDO overview

PHP Data Objects (PDO) were introduced as a PECL extension under PHP 5.0, and became part of the core PHP distribution in PHP 5.1.x. The PDO extension provides a consistent interface for database access, and is used alongside database-specific PDO drivers. Each driver may also have database-specific functions of its own, but basic data access functionality such as issuing queries and fetching data is covered by PDO functions, using the driver named in PDO::__construct().

Note that the PDO extension, and its drivers, are intended to be built as shared extensions. This will enable straightforward driver upgrades from PECL, without forcing you to rebuild all of PHP.

At the point of the PHP 5.1.x release, PDO is more than ready for widespread testing and could be adopted in most situations. However, it is important to understand that PDO and its drivers are comparatively young and may be missing certain database-specific features; evaluate PDO carefully before you use it in new projects.

Legacy code will generally rely on the pre-existing database extensions, which are still maintained.

Changes in MySQL support

In PHP 4, MySQL 3 support was built-in. With the release of PHP 5.0 there were two MySQL extensions, named 'mysql' and 'mysqli', which were designed to support MySQL < 4.1 and MySQL 4.1 and up, respectively. With the introduction of PDO, which provides a very fast interface to all the database APIs supported by PHP, the PDO_MYSQL driver can support any of the current versions (MySQL 3, 4 or 5) in PHP code written for PDO, depending on the MySQL library version used during compilation. The older MySQL extensions remain in place for reasons of back compatibility, but are not enabled by default.

Changes in SQLite support

In PHP 5.0.x, SQLite 2 support was provided by the built-in sqlite extension, which was also available as a PECL extension in PHP 4.3 and PHP 4.4. With the introduction of PDO, the sqlite extension doubles up to act as a 'sqlite2' driver for PDO; it is due to this that the sqlite extension in PHP 5.1.x has a dependency upon the PDO extension.

PHP 5.1.x ships with a number of alternative interfaces to sqlite:

The sqlite extension provides the "classic" sqlite procedural/OO API that you may have used in prior versions of PHP. It also provides the PDO 'sqlite2' driver, which allows you to access legacy SQLite 2 databases using the PDO API.

PDO_SQLITE provides the 'sqlite' version 3 driver. SQLite version 3 is vastly superior to SQLite version 2, but the file formats of the two versions are not compatible.

If your SQLite-based project is already written and working against earlier PHP versions, then you can continue to use ext/sqlite without problems, but will need to explicitly enable both PDO and sqlite. New projects should use PDO and the 'sqlite' (version 3) driver, as this is faster than SQLite 2, has improved locking concurrency, and supports both prepared statements and binary columns natively.

You must enable PDO to use the SQLite extension. If you want to build the PDO extension as a shared extension, then the SQLite extension must also be built shared. The same holds true for any extension that provides a PDO driver

Předcházející | Nahoru | Další
Date/time support | Domů | Checking for E_STRICT


Date/time support

Date/time support has been fully rewritten in PHP 5.1.x, and no longer uses the system settings to 'know' the timezone in operation. It will instead utilize, in the following order:

  • The timezone set using the date_default_timezone_set() function (if any)

  • The TZ environment variable (if non empty)

  • "magical" guess (if the operating system supports it)

  • If none of the above options succeeds, UTC

To ensure accuracy (and avoid an E_STRICT warning), you will need to define your timezone in your php.ini using the following format:

date.timezone = Europe/London

The supported timezones are listed, in this format, in the timezones appendix.

Also note that strtotime() now returns FALSE on failure, instead of -1.

Předcházející | Nahoru | Další
Extensions | Domů | Changes in database support


Checking for E_STRICT

If you only have a single script to check, you can pick up E_STRICT errors using PHP's commandline lint facility:

    php -d error_reporting=4095 -l script_to_check.php

For larger projects, the shell script below will achieve the same task:

#!/bin/sh

directory=$1

shift

# These extensions are checked
extensions="php inc"

check_file ()
{
  echo -ne "Doing PHP syntax check on $1 ..."

  # Options:
  ERRORS=`/www/php/bin/php -d display_errors=1 -d html_errors=0 -d error_prepend_string=" " -d error_append_string=" " -d error_reporting=4095 -l $1 | grep -v "No syntax errors detected"`

  if test -z "$ERRORS"; then
    echo -ne "OK."
  else
    echo -e "Errors found!\n$ERRORS"
  fi

  echo
}

# loop over remaining file args
for FILE in "$@" ; do
  for ext in $extensions; do
     if echo $FILE | grep "\.$ext$" > /dev/null; then
       if test -f $FILE; then
         check_file "$FILE"
       fi
     fi
  done
done

Předcházející | Nahoru | Další
Changes in database support | Domů | D. Migrating from PHP 4 to PHP 5


Extensions

  • Extensions that are gone from the PHP core

  • Class constants in new PHP 5.1.x extensions

Extensions that are gone from the PHP core

One of the first things you're likely to notice when you download PHP 5.1.x is that several of the older extensions have disappeared. Those extensions that are still actively maintained are available in the PHP Extension Community Library (PECL), at » http://pecl.php.net/. Windows binaries are built regularly, and you can obtain the binaries for PECL extensions built against PHP 5.1.x from » http://pecl4win.php.net/.

Tabulka C.1. Removed extensions

Extension | Alternative/Status
ext/cpdf | pecl/pdflib
ext/dbx | pecl/dbx
ext/dio | pecl/dio
ext/fam | Not actively maintained
ext/ingres_ii | pecl/ingres
ext/ircg | Not actively maintained
ext/mcve | pecl/mcve
ext/mnogosearch | Not actively maintained
ext/oracle | ext/oci8 or ext/pdo_oci
ext/ovrimos | Not actively maintained
ext/pfpro | Not actively maintained
ext/w32api | » pecl/ffi
ext/yp | Not actively maintained
ext/activescript | » pecl/activescript

Modules in PECL that are not actively maintained (i.e. have not been supported for some time, have no active maintainer working on them currently, and do not have any PECL package releases), are still available in CVS at » http://cvs.php.net/pecl. However, unreleased PHP modules are by their nature unsupported, and your mileage may vary when attempting to install or use them.

Class constants in new PHP 5.1.x extensions

The Zend Engine 2.1 API allows extension developers to declare class constants in object oriented extensions. New extensions written for PHP 5.1.x, including SPL, PDO, XMLReader and date, have their constants in the format PDO::CLASS_CONSTANT rather than in the C format PDO_CLASS_CONSTANT in order to minimise pollution of the global namespace in PHP.

Předcházející | Nahoru | Další
Class and object changes | Domů | Date/time support


Integer values in function parameters

With the advent of PHP 5.0.x, a new parameter parsing API was introduced which is used by a large number of PHP functions. In all versions of PHP between 5.0.x and 5.1.x, the handling of integer values was very strict and would reject non-well formed numeric values when a PHP function expected an integer. These checks have now been relaxed to support non-well formed numeric strings such as " 123" and "123 ", and will no longer fail as they did under PHP 5.0.x. However, to promote code safety and input validation, PHP functions will now emit an E_NOTICE when such strings are passed as integers.

Předcházející | Nahoru | Další
Reading [] | Domů | Class and object changes


Class and object changes

  • instanceof, is_a(), is_subclass_of() and catch

  • Abstract private methods

  • Access modifiers in interfaces

  • Changes in inheritance rules

  • Class constants

instanceof, is_a(), is_subclass_of() and catch

In PHP 5.0, is_a() was deprecated and replaced by the instanceof operator. There were some issues with the initial implementation of instanceof, which relied on __autoload() to search for missing classes. If the class was not present, instanceof would throw a fatal E_ERROR due to the failure of __autoload() to discover that class. The same behaviour occurred in the catch operator and the is_subclass_of() function, for the same reason.

None of these functions or operators call __autoload() in PHP 5.1.x, and the class_exists() workarounds used in code written for PHP 5.0.x, while not problematic in any way, are no longer necessary.

Abstract private methods

Abstract private methods were supported between PHP 5.0.0 and PHP 5.0.4, but were then disallowed on the grounds that the behaviours of private and abstract are mutually exclusive.

Access modifiers in interfaces

Under PHP 5.0, function declarations in interfaces were treated in exactly the same way as function declarations in classes. This has not been the case since October 2004, at which point only the public access modifier was allowed in interface function declarations. Since April 2005 - which pre-dates the PHP 5.0b1 release - the static modifier has also been allowed. However, the protected and private modifiers will now throw an E_ERROR, as will abstract. Note that this change should not affect your existing code, as none of these modifiers makes sense in the context of interfaces anyway.

Changes in inheritance rules

Under PHP 5.0, it was possible to have a function declaration in a derived class that did not match the declaration of the same function in the base class, e.g.

This code will cause an E_STRICT error to be emitted under PHP 5.1.x.

<?php
class Base {
    function &return_by_ref() {
        $r = 1;
        return $r;
    }
}

class Derived extends Base {
    function return_by_ref() {
        return 1;
    }
}
?>

Class constants

Under PHP 5.0.x, the following code was valid:

Under PHP 5.1.x, redefinition of a class constant will throw a fatal E_ERROR.

<?php
class test {
    const foobar = 'foo';
    const foobar = 'bar';
}

?>
Předcházející | Nahoru | Další
Integer values in function parameters | Domů | Extensions


Reading []

<?php
class XmlTest {

    function test_ref(&$test) {
        $test = "ok";
    }

    function test($test) { }

    function run() {
        $ar = array();
        $this->test_ref($ar[]);
        var_dump($ar);
        $this->test($ar[]);
    }
}

$o = new XmlTest();
$o->run();
?>

This should always have thrown a fatal E_ERROR, because [] cannot be used for reading in PHP. It is invalid code in PHP 4.4.2 and PHP 5.0.5 upward.

Předcházející | Nahoru | Další
Changes in reference handling | Domů | Integer values in function parameters


Changes in reference handling

  • Overview

  • Code that worked under PHP 4.3.x, but now fails

  • Code that worked under PHP 4.3.x, but now throws an error

  • Code that failed under PHP 4.3.x, but now works

  • Code that should have worked under PHP 5.0.x

  • Warnings that came and went

Overview

From the PHP script writer's point of view, the change most likely to impact legacy code is in the way that references are handled in all PHP versions post-dating the PHP 4.4.0 release.

Until and including PHP 4.3, it was possible to send, assign or return variables by reference that should really be returned by value, such as a constant, a temporary value (e.g. the result of an expression), or the result of a function that had itself been returned by value, as here:

<?php
$foo = "123";

function return_value() {
    global $foo;
    return $foo;
}

$bar = &return_value();
?>

Although this code would usually work as expected under PHP 4.3, in the general case the result is undefined. The Zend Engine could not act correctly on these values as references. This bug could and did lead to various hard-to-reproduce memory corruption problems, particularly where the code base was large.

In PHP 4.4.0, PHP 5.0.4 and all subsequent PHP releases, the Engine was fixed to 'know' when the reference operation is being used on a value that should not be referenced. The actual value is now used in such cases, and a warning is emitted. The warning takes the form of an E_NOTICE in PHP 4.4.0 and up, and E_STRICT in PHP 5.0.4 and up.

Code that could potentially produce memory corruption can no longer do so. However, some legacy code might work differently as a result.

Code that worked under PHP 4.3, but now fails

<?php
function func(&$arraykey) {
    return $arraykey; // function returns by value!
}

$array = array('a', 'b', 'c');
foreach (array_keys($array) as $key) {
    $y = &func($array[$key]);
    $z[] =& $y;
}

var_dump($z);
?>
<

Running the above script under any version of PHP that pre-dates the reference fix would produce this output:

array(3) {
  [0]=>
  &string(1) "a"
  [1]=>
  &string(1) "b"
  [2]=>
  &string(1) "c"
}

Following the reference fix, the same code would result in:

array(3) {
  [0]=>
  &string(1) "c"
  [1]=>
  &string(1) "c"
  [2]=>
  &string(1) "c"
}

This is because, following the changes, func() assigns by value. The value of $y is re-assigned, and reference-binding is preserved from $z. Prior to the fix, the value was assigned by reference, leading $y to be re-bound on each assignment. The attempt to bind to a temporary value by reference was the cause of the memory corruption.

Such code can be made to work identically in both the pre-fix and the post-fix PHP versions. The signature of func() can be altered to return by reference, or the reference assignment can be removed from the result of func().

<?php
function func() {
    return 'function return';
}

$x = 'original value';
$y =& $x;
$y = &func();
echo $x;
?>

In PHP 4.3 $x would be 'original value', whereas after the changes it would be 'function return' - remember that where the function does not return by reference, the reference assignment is converted to a regular assignment. Again, this can be brought to a common base, either by forcing func() to return by reference or by eliminating the by-reference assignment.

Code that worked under PHP 4.3.x, but now throws an error

<?php
class Foo {

    function getThis() {
        return $this;
    }

    function destroyThis() {
        $baz =& $this->getThis();
    }
}

$bar = new Foo();
$bar->destroyThis();
var_dump($bar);
?>

In PHP 5.0.3, $bar evaluated to NULL instead of returning an object. That happened because getThis() returns by value, but the value here is assigned by reference. Although it now works in the expected way, this is actually invalid code which will throw an E_NOTICE under PHP 4.4 or an E_STRICT under PHP 5.0.4 and up.

Code that failed under PHP 4.3.x, but now works

<?php
function &f() {
    $x = "foo";
    var_dump($x);
    print "$x\n";
    return($a);
}

for ($i = 0; $i < 3; $i++) {
    $h = &f();
}
?>

In PHP 4.3 the third call to var_dump() produces NULL, due to the memory corruption caused by returning an uninitialized value by reference. This is valid code in PHP 5.0.4 and up, but threw errors in earlier releases of PHP.

<?php
$arr = array('a1' => array('alfa' => 'ok'));
$arr =& $arr['a1'];
echo '-'.$arr['alfa']."-\n";
?>

Until PHP 5.0.5, it wasn't possible to assign an array element by reference in this way. It now is.

Code that should have worked under PHP 5.0.x

There are a couple of instances of bugs reported under PHP 5.0 prior to the reference fixes which now 'work'. However, in both cases errors are thrown by PHP 5.1.x, because the code was invalid in the first place. Returning values by reference using self:: now works in the general case but throws an E_STRICT warning, and although your mileage may vary when assigning by reference to an overloaded object, you will still see an E_ERROR when you try it, even where the assignment itself appears to work.

Warnings that came and went

Nested calls to functions returning by reference are valid code under both PHP 4.3.x and PHP 5.1.x, but threw an unwarranted E_NOTICE or E_STRICT under the intervening PHP releases.

<?php
function & foo() {
    $var = 'ok';
    return $var;
}

function & bar() {
    return foo();
}

$a =& bar();
echo "$a\n";
?>
Předcházející | Nahoru | Další
C. Migrating from PHP 5.0.x to PHP 5.1.x | Domů | Reading []


Příloha B. Migrating from PHP 5.1.x to PHP 5.2.x

Obsah

What has changed in PHP 5.2.x
Backward Incompatible Changes
New Error Messages
Changes in PHP datetime support
New Parameters
New Functions
New Methods
Removed Extensions
New Extensions
New Classes
New Global Constants
New Class Constants
New INI Configuration Directives
Error Reporting
Other Enhancements

What has changed in PHP 5.2.x

Most improvements in PHP 5.2.x have no impact on existing code. There are a few incompatibilities and new error messages that should be considered, and code should be tested before switching PHP versions in production environments.

If the system is being upgraded from PHP 5.0.x, the manual section titled Upgrade Notes for PHP 5.1.x should also be read.

Similarly, if the system is being upgraded from PHP 4, the manual section titled Migrating from PHP 4 to PHP 5 should be read as well.

Předcházející | Nahoru | Další
Ostatní publikace o PHP | Domů | Backward Incompatible Changes


New Class Constants

pdo:

  • PDO::ATTR_DEFAULT_FETCH_MODE
  • PDO::FETCH_PROPS_LATE

  • PDO::FETCH_KEY_PAIR

    Fetches a 2 column result set into an associated array. (Added in PHP 5.2.3)

spl:

  • CachingIterator::FULL_CACHE
  • CachingIterator::TOSTRING_USE_INNER
  • SplFileObject::READ_AHEAD
  • SplFileObject::READ_CSV
  • SplFileObject::SKIP_EMPTY
Předcházející | Nahoru | Další
New Global Constants | Domů | New INI Configuration Directives


New Classes

The following classes were introduced in PHP 5.2.0:

  • DateTime
  • DateTimeZone

  • RegexIterator - extends FilterIterator; implements Iterator, Traversable, OuterIterator

    Constants:

    • RegexIterator::ALL_MATCHES
    • RegexIterator::GET_MATCH
    • RegexIterator::MATCH
    • RegexIterator::REPLACE
    • RegexIterator::SPLIT
    • RegexIterator::USE_KEY

    Properties:

    • public replacement

    Methods:

    • RegexIterator::__construct(Iterator it, string regex [, int mode [, int flags [, int preg_flags]]]) - Create an RegexIterator from another iterator and a regular expression
    • bool RegexIterator::accept() - Match (string)current() against regular expression
    • bool RegexIterator::getFlags() - Returns current operation flags
    • bool RegexIterator::getMode() - Returns current operation mode
    • bool RegexIterator::getPregFlags() - Returns current PREG flags (if in use or NULL)
    • bool RegexIterator::setFlags(int new_flags) - Set operation flags
    • bool RegexIterator::setMode(int new_mode) - Set new operation mode
    • bool RegexIterator::setPregFlags(int new_flags) - Set PREG flags

  • RecursiveRegexIterator

    Constants:

    • RecursiveRegexIterator::ALL_MATCHES
    • RecursiveRegexIterator::GET_MATCH
    • RecursiveRegexIterator::MATCH
    • RecursiveRegexIterator::REPLACE
    • RecursiveRegexIterator::SPLIT
    • RecursiveRegexIterator::USE_KEY

    Methods:

    • RecursiveRegexIterator::__construct(RecursiveIterator it, string regex [, int mode [, int flags [, int preg_flags]]]) - Create an RecursiveRegexIterator from another recursive iterator and a regular expression
    • RecursiveRegexIterator RecursiveRegexIterator::getChildren() - Return the inner iterator's children contained in a RecursiveRegexIterator
    • bool RecursiveRegexIterator::hasChildren() - Check whether the inner iterator's current element has children
Předcházející | Nahoru | Další
New Extensions | Domů | New Global Constants


Changes in PHP datetime support

Since PHP 5.1.0, there has been an extension named date in the PHP core. This is the new implementation of PHP's datetime support. Although it will attempt to guess your system's timezone setting, you should set the timezone manually. You can do this in any of three ways:

  • in your php.ini using the date.timezone INI directive
  • on your system using the TZ environmental variable
  • from your script using the convenience function date_default_timezone_set()

All supported timezones are listed in the PHP Manual.

With the advent of PHP 5.2.x, there are object representations of the date and timezone, named DateTime and DateTimeZone respectively. The methods map to existing procedural date functions.

Předcházející | Nahoru | Další
New Error Messages | Domů | New Parameters


New Error Messages

Below are the new error messages that have not been discussed elsewhere in this document.

Příklad B.1. In PHP Core

<?php
echo " ";
session_regenerate_id();
/*  Warning:  session_regenerate_id(): Cannot regenerate
    session id - headers already sent in filename on line n */

str_word_count("string", 4);
/* Warning:  str_word_count(): Invalid format value 4
   in filename on line n */

strripos("foo", "f", 4);
/* Notice:  strripos(): Offset is greater than the
   length of haystack string in filename on line n */

strrpos("foo", "f", 4);
/* Notice:  strrpos(): Offset is greater than the
   length of haystack string in filename on line n */

/* As of PHP 5.2.1, when allow_url_include is OFF (default) */
include "php://input";
/* Warning:  include(): URL file-access is disabled
   in the server configuration in filename on line n */
?>

Příklad B.2. Object Oriented Code in PHP Core

<?php
interface foo {
}
class bar implements foo, foo {
}
/* Fatal error: Class bar cannot implement previously
   implemented interface foo in filename on line n */

class foo {
    public $bar;
    function __get($var)
    {
        return $this->bar;
    }
}

$foo = new foo;
$bar =& $foo->prop;
/* Notice: Indirect modification of overloaded property
   foo::$prop has no effect in filename on line n */

class foo implements iterator {
    public function current() {
    }
    public function next() {
    }
    public function key() {
    }
    public function valid() {
    }
    public function rewind() {
    }
}

$foo = new foo();
foreach($foo as &$ref) {}
/* Fatal error: An iterator cannot be used with foreach
   by reference in filename on line n */

class foo {
    private function __construct() {
    }
}
class bar extends foo {
    public function __construct() {
        parent::__construct();
        /* Fatal error:  Cannot call private
           foo::__construct() in filename on line n */
    }
}
new bar;

stream_filter_register("", "class");
/* Warning:  stream_filter_register(): Filter name
   cannot be empty in filename on line n */

stream_filter_register("filter", "");
/* Warning:  stream_filter_register(): Class name
   cannot be empty in filename on line n */

Příklad B.3. In the bzip2 Extension

<?php
bzopen("", "w");
/* Warning:  bzopen(): filename cannot be empty
   in filename on line n */

bzopen("foo", "a");
/* Warning:  bzopen(): 'a' is not a valid mode for
   bzopen(). Only 'w' and 'r' are supported in
   filename on line n */

$fp = fopen("foo", "w");
bzopen($fp, "r");
/* Warning:  bzopen(): cannot read from a stream
   opened in write only mode in filename on line n */
?>

Příklad B.4. In the datetime Extension

<?php
strtotime("today", "now");
/* Warning:  strtotime() expects parameter 2 to be
   long, string given in filename on line n */

/* As of PHP 5.2.1 */
new DateTime(new stdclass);
/* Fatal error: Uncaught exception 'Exception' with
   message 'DateTime::__construct() expects parameter
   1 to be string, object given' in filename:n */
?>

Příklad B.5. In the dBase Extension

<?php
dbase_open("foo", -1);
/* Warning: Invalid access mode -1 in filename on line n */

/* As of PHP 5.2.1 */
dbase_open("foo", null);
/* Warning: The filename cannot be empty in filename on line n */
?>

Příklad B.6. In the mcrypt Extension

<?php
$key = "this is a secret key";
$td = mcrypt_module_open('tripledes', '', 'ecb', '');
$iv = mcrypt_create_iv (mcrypt_enc_get_iv_size($td),
                        MCRYPT_RAND);
mcrypt_generic_init($td, $key, $iv);
$encrypted_data = mcrypt_generic($td, "");
/* Warning: mcrypt_generic(): An empty string was
   passed in filename on line n */
?>

Příklad B.7. In the oci8 Extension

<?php
oci_connect("user", "pass", "db", "bogus_charset");
/* Warning: Invalid character set name:
   bogus_charset in filename on line n */

$oci = oci_connect("user", "pass", "db");
oci_password_change($oci, "", "old", "new");
/* Warning: username cannot be empty in filename
   on line n */

oci_password_change($oci, "user", "", "new");
/* Warning: old password cannot be empty in filename
   on line n */

oci_password_change($oci, "user", "old", "");
/* Warning: new password cannot be empty in filename
   on line n */
?>

Příklad B.8. In the SPL Extension

<?php
$obj = new SplFileObject(__FILE__);
$obj->fgetcsv("foo");
/* Warning:  SplFileObject::fgetcsv(): delimiter must
   be a character in filename on line n */

$obj->fgetcsv(",", "foo");
/* Warning:  SplFileObject::fgetcsv(): enclosure must
   be a character in filename on line n */
?>

Příklad B.9. In the Semaphore (sysvmsg) extension

<?php
/* Warning:  maximum size of the message has to be
   greater then zero in filename on line n */
?>

Příklad B.10. A 5.2.1+ Zip Example

<?php
$obj = new ZipArchive();
$obj->open('archive.zip');
$obj->setCommentName('', 'comment');
/* Notice:  ZipArchive::setCommentName(): Empty string
   as entry name in filename on line n */

/* As of PHP 5.2.1 */
$obj->getCommentName('');
/* Notice:  ZipArchive::getCommentName(): Empty string
   as entry name in filename on line n */
?>

Předcházející | Nahoru | Další
Backward Incompatible Changes | Domů | Changes in PHP datetime support


Error Reporting

Some of the existing E_ERROR conditions have been converted to something that can be caught with a user-defined error handler. If an E_RECOVERABLE_ERROR is not handled, it will behave in the same way as E_ERROR behaves in all versions of PHP. Errors of this type are logged as Catchable fatal error.

This change means that the value of the E_ALL error_reporting constant is now 6143, where the previous value was 2047. Because PHP constants have no meaning outside of PHP, in some cases the integer value is used instead so these will need to be adjusted. So for example by setting the error_reporting mode from either the httpd.conf or the .htaccess files, the value has to be changed accordingly. The same applies when the numeric values are used rather than the constants in PHP scripts.

As a side-effect of a change made to prevent duplicate error messages when track_errors is On, it is now necessary to return FALSE from user defined error handlers in order to populate $php_errormsg. This provides a fine-grain control over the levels of messages stored.

Předcházející | Nahoru | Další
New INI Configuration Directives | Domů | Other Enhancements


New Functions

PHP 5.2.x introduced some new functions:

PHP Core:

  • array_fill_keys() - Create an array using the elements of the first parameter as keys, each initialized to val
  • error_get_last() - Get the last occurred error as associative array. Returns NULL if there hasn't been an error yet
  • image_type_to_extension() - Get file extension for image-type returned by getimagesize, exif_read_data, exif_thumbnail, exif_imagetype
  • memory_get_peak_usage() - Returns the peak allocated by PHP memory
  • sys_get_temp_dir() - Returns directory path used for temporary files. (Added in 5.2.1)
  • timezone_abbreviations_list() - Returns associative array containing DST, offset and the timezone name
  • timezone_identifiers_list() - Returns numerically indexed array with all timezone identifiers
  • timezone_name_from_abbr() - Returns the timezone name from abbreviation
  • stream_socket_shutdown() - Causes all or part of a full-duplex connection on the socket associated with stream to be shut down. As of PHP 5.2.1.

Image:

  • imagegrabscreen() - Grabs a screenshot of the whole screen. As of PHP 5.2.2.
  • imagegrabwindow() - Captures a window. As of PHP 5.2.2.

mbstring:

  • mb_list_encodings_alias_names() - Returns an array of all supported entity encodings
  • mb_list_mime_names() - Returns an array or string of all supported mime names
  • mb_stripos() - Finds position of first occurrence of a string within another, case insensitive
  • mb_stristr() - Finds first occurrence of a string within another, case insensitive
  • mb_strrchr() - Finds the last occurrence of a character in a string within another
  • mb_strrichr() - Finds the last occurrence of a character in a string within another, case insensitive
  • mb_strripos() - Finds position of last occurrence of a string within another, case insensitive
  • mb_strstr() - Finds first occurrence of a string within another

ming (As of PHP 5.2.1):

  • void ming_setSWFCompression(int num) - Sets output compression
  • void swfmovie::namedanchor(string name) - Creates anchor
  • void swfmovie::protect([string pasword]) - Protects

openssl:

  • openssl_csr_get_public_key() - Extracts public key from a CERT and prepares it for use
  • openssl_csr_get_subject() - Returns the subject of a CERT
  • openssl_pkey_get_details() - Returns an array with the key details (bits, pkey, type)

spl:

  • spl_object_hash() - Return hash id for given object
  • int iterator_apply(Traversable it, mixed function [, mixed params]) - Calls a function for every element in an iterator

pcre:

  • preg_last_error() - Returns the error code of the last regex execution

pgsql:

  • pg_field_table() - Returns the name of the table field belongs to, or table's oid if oid_only is true

posix:

  • posix_initgroups() - Calculate the group access list for the user specified in name

gmp:

  • gmp_nextprime() - Finds next prime of a

xmlwriter:

  • xmlwriter_full_end_element() - End current element - returns FALSE on error
  • xmlwriter_write_raw() - Write text - returns FALSE on error
  • xmlwriter_start_dtd_entity() - Create start DTD Entity - returns FALSE on error
  • xmlwriter_end_dtd_entity() - End current DTD Entity - returns FALSE on error
  • xmlwriter_write_dtd_entity() - Write full DTD Entity tag - returns FALSE on error
Předcházející | Nahoru | Další
New Parameters | Domů | New Methods


New Global Constants

PHP Core:

  • M_EULER
  • M_LNPI
  • M_SQRT3
  • M_SQRTPI
  • PATHINFO_FILENAME
  • PREG_BACKTRACK_LIMIT_ERROR
  • PREG_BAD_UTF8_ERROR
  • PREG_INTERNAL_ERROR
  • PREG_NO_ERROR
  • PREG_RECURSION_LIMIT_ERROR
  • UPLOAD_ERR_EXTENSION
  • STREAM_SHUT_RD
  • STREAM_SHUT_WR
  • STREAM_SHUT_RDWR

curl:

  • CURLE_FILESIZE_EXCEEDED
  • CURLE_FTP_SSL_FAILED
  • CURLE_LDAP_INVALID_URL
  • CURLFTPAUTH_DEFAULT
  • CURLFTPAUTH_SSL
  • CURLFTPAUTH_TLS
  • CURLFTPSSL_ALL
  • CURLFTPSSL_CONTROL
  • CURLFTPSSL_NONE
  • CURLFTPSSL_TRY
  • CURLOPT_FTP_SSL
  • CURLOPT_FTPSSLAUTH

  • CURLOPT_TCP_NODELAY

    Added in PHP 5.2.1.

  • CURLOPT_TIMEOUT_MS

    Added in PHP 5.2.3

  • CURLOPT_CONNECTTIMEOUT_MS

    Added in PHP 5.2.3

GMP:

  • GMP_VERSION

    Added in PHP 5.2.2.

ming:

  • SWFTEXTFIELD_USEFONT
  • SWFTEXTFIELD_AUTOSIZE
  • SWF_SOUND_NOT_COMPRESSED
  • SWF_SOUND_ADPCM_COMPRESSED
  • SWF_SOUND_MP3_COMPRESSED
  • SWF_SOUND_NOT_COMPRESSED_LE
  • SWF_SOUND_NELLY_COMPRESSED
  • SWF_SOUND_5KHZ
  • SWF_SOUND_11KHZ
  • SWF_SOUND_22KHZ
  • SWF_SOUND_44KHZ
  • SWF_SOUND_8BITS
  • SWF_SOUND_16BITS
  • SWF_SOUND_MONO
  • SWF_SOUND_STEREO

openssl:

  • OPENSSL_VERSION_NUMBER
  • OPENSSL_VERSION_TEXT

snmp:

  • SNMP_OID_OUTPUT_FULL
  • SNMP_OID_OUTPUT_NUMERIC

Semaphore:

  • MSG_EAGAIN
  • MSG_ENOMSG
Předcházející | Nahoru | Další
New Classes | Domů | New Class Constants


Backward Incompatible Changes

Although most existing PHP 5 code should work without changes, you should pay attention to the following backward incompatible changes:

  • getrusage() returns NULL when passed incompatible arguments as of PHP 5.2.1.
  • ZipArchive::setCommentName() returns TRUE on success as of PHP 5.2.1.
  • ZipArchive::setCommentIndex() returns TRUE on success as of PHP 5.2.1.
  • SplFileObject::getFilename() returns the filename, not relative/path/to/file, as of PHP 5.2.1.

  • Changed priority of PHPRC environment variable on Win32

    The PHPRC environment variable now takes priority over the path stored in the Windows registry.

  • CLI SAPI no longer checks cwd for php.ini or the php-cli.ini file

    In PHP 5.1.x an undocumented feature was added that made the CLI binary check the current working directory for a PHP configuration file, potentially leading to unpredictable behavior if an unexpected configuration file were read. This functionality was removed in 5.2.0, and PHP will no longer search CWD for the presence of php.ini or php-cli.ini files. See also the command line section of the manual.

  • Added a warning when performing modulus 0 operations

    In earlier versions of PHP, performing integer % 0 did not emit any warning messages, instead returning an unexpected return value of FALSE. As of PHP 5.2.0, this operation will emit an E_WARNING, as is the case in all other instances where division by zero is performed.

    <?php
    print 10 % 0;
    /* Warning:  Division by zero in filename on line n */
    ?>

  • Changed __toString() to be called wherever applicable.

    The magic method __toString() will now be called in a string context, that is, anywhere an object is used as a string.

    The fallback of returning a string that contains the object identifier was dropped in PHP 5.2.0. It became problematic because an object identifier cannot be considered unique. This change will mean that your application is flawed if you have relied on the object identifier as a return value. An attempt to use that value as a string will now result in a catchable fatal error.

    <?php
    class foo {}
    $foo = new foo;
    print     $foo;
    /* Catchable fatal error:  Object of class foo could
       not be converted to string in filename on line n */
    ?>

    Even with __toString(), objects cannot be used as array indices or keys. We may add built-in hash support for this at a later date, but as of PHP 5.2.x you will need to either provide your own hashing or use the new SPL function spl_object_hash().

    Exceptions can not be thrown from __toString() methods.

    <?php
    class foo {
        public function     __toString() {
            throw new     Exception;
        }
    }

    try {
        print new     foo;
            /* Fatal error:  Method foo::__toString() must
           not throw an exception in filename on line n */
    } catch(Exception $e) {}
    ?>

  • Dropped abstract static class functions.

    Due to an oversight, PHP 5.0.x and 5.1.x allowed abstract static functions in classes. As of PHP 5.2.x, only interfaces can have them.

    <?php
    abstract class foo {
        abstract static function     bar();
            /* Strict Standards:  Static function foo::bar()
           should not be abstract in filename on line n */
    }
    ?>
  • Oracle extension requires at least Oracle 10 on Windows.

  • Added RFC2397 (data: stream) support.

    The introduction of the 'data' URL scheme has the potential to lead to a change of behavior under Windows. If you are working with a NTFS file system and making use of meta streams in your application, and if you just happen to be using a file with the name 'data:' that is accessed without any path information - it won't work any more. The fix is to use the 'file:' protocol when accessing it.

    See also » RFC 2397

    <?php
    /* when allow_url_include is OFF (default) */
    include "data:;base64,PD9waHAgcGhwaW5mbygpOz8+";
    /* Warning:  include(): URL file-access is disabled
       in the server configuration in filename on line n */
    ?>

  • Regression in glob() patterns

    In version 5.2.4 a security fix caused a regression for patterns of the form "/foo/*/bar/*". Since version 5.2.5 instead of raising a warning the glob() function will return false when openbase_dir restrictions are violated.

Předcházející | Nahoru | Další
B. Migrating from PHP 5.1.x to PHP 5.2.x | Domů | New Error Messages


New Methods

New methods were introduced in 5.2.0:

dom:

  • DOMDocument::registerNodeClass() - Register extended class used to create base node type
  • DOMElement::setIDAttribute() - Declares the attribute specified by name to be of type ID
  • DOMElement::setIDAttributeNode() - Declares the attribute specified by node to be of type ID
  • DOMElement::setIDAttributeNS() - Declares the attribute specified by local name and namespace URI to be of type ID
  • DOMNode::C14N([bool exclusive [, bool with_comments [, array xpath [, array ns_prefixes]]]]) - Canonicalize nodes to a string
  • DOMNode::C14NFile(string uri [, bool exclusive [, bool with_comments [, array xpath [, array ns_prefixes]]]]) - Canonicalize nodes to a file
  • DOMNode::getNodePath() - Gets an xpath for a node

soap:

  • SoapServer::setObject(object obj) - Sets object which will handle SOAP requests

spl:

  • int ArrayObject::asort(void) - Sort the entries by values
  • int ArrayObject::ksort(void) - Sort the entries by key
  • int ArrayObject::natcasesort(void) - Sort the entries by key using case insensitive "natural order" algorithm.
  • int ArrayObject::natsort(void) - Sort the entries by values using "natural order" algorithm.
  • int ArrayObject::uasort(callback cmp_function) - Sort the entries by values user defined function
  • int ArrayObject::uksort(callback cmp_function) - Sort the entries by key using user defined function.
  • ArrayIterator AppendIterator::getArrayIterator() - Get access to inner ArrayIterator
  • int AppendIterator::getIteratorIndex() - Get index of iterator
  • bool CachingIterator::getCache() - Return the cache
  • int CachingIterator::getFlags() - Return the internal flags
  • bool CachingIterator::offsetExists(mixed index) - Return whether the requested index exists
  • string CachingIterator::offsetGet(mixed index) - Return the internal cache if used
  • void CachingIterator::offsetSet(mixed index, mixed newval) - Set given index in cache
  • void CachingIterator::offsetUnset(mixed index) - Unset given index in cache
  • void CachingIterator::setFlags() - Set the internal flags
  • array("delimiter" =>, "enclosure" =>) SplFileObject::getCsvControl(void) - Get the delimiter and enclosure character used in fgetcsv
  • void SplFileObject::setCsvControl([string delimiter = ',' [, string enclosure = '"']]) - Set the delimiter and enclosure character used in fgetcsv

Tidy

  • tidyNode tidyNode::getParent(void) - Returns the parent node of the current node (Added in PHP 5.2.2)

XMLReader

  • boolean XMLReader::setSchema(string filename) - Use W3C XSD schema to validate the document as it is processed. Activation is only possible before the first Read()

zip:

  • ZipArchive::addEmptyDir() - Creates an empty directory in the archive
Předcházející | Nahoru | Další
New Functions | Domů | Removed Extensions


New Extensions

The following are new extensions added (by default) as of PHP 5.2.0:

  • Filter - validates and filters data, and is designed for use with insecure data such as user input. This extension is enabled by default; the default mode RAW does not impact input data in any way.
  • JSON - implements the JavaScript Object Notation (JSON) data interchange format. This extension is enabled by default.
  • Zip - enables you to transparently read or write ZIP compressed archives and the files inside them.
Předcházející | Nahoru | Další
Removed Extensions | Domů | New Classes


New INI Configuration Directives

New php.ini directives introduced in PHP 5.2.0:

  • allow_url_include

    This useful option makes it possible to differentiate between standard file operations on remote files, and the inclusion of remote files. While the former is usually desirable, the latter can be a security risk if used naively. Starting with PHP 5.2.0, you can allow remote file operations while disallowing the inclusion of remote files in local scripts. In fact, this is the default configuration.

  • pcre.backtrack_limit

    PCRE's backtracking limit.

  • pcre.recursion_limit

    PCRE's recursion limit. Please note that if you set this value to a high number you may consume all the available process stack and eventually crash PHP (due to reaching the stack size limit imposed by the Operating System).

  • session.cookie_httponly

    Marks the cookie as accessible only through the HTTP protocol. This means that the cookie won't be accessible by scripting languages, such as JavaScript. This setting can effectively help to reduce identity theft through XSS attacks (although it is not supported by all browsers).

New directives in PHP 5.2.2:

  • max_input_nesting_level

    Limits how deep input variables can be nested, default is 64.

Předcházející | Nahoru | Další
New Class Constants | Domů | Error Reporting


Other Enhancements

  • Improved memory manager and increased default memory limit.

    The new memory manager allocates less memory and works faster than the previous incarnation. It allocates memory from the system in large blocks, and then manages the heap by itself. The memory_limit value in php.ini is checked, not for each emalloc() call (as before), but for actual blocks requested from the system. This means that memory_limit is far more accurate than it used to be, since the old memory manager didn't calculate all the memory overhead used by the malloc library.

    Thanks to this new-found accuracy memory usage may appear to have increased, although actually it has not. To accommodate this apparent increase, the default memory_limit setting was also increased - from 8 to 16 megabytes.

  • Added support for constructors in interfaces to force constructor signature checks in implementations.

    Starting with PHP 5.2.0, interfaces can have constructors. However, if you choose to declare a constructor in an interface, each class implementing that interface MUST include a constructor with a signature matching that of the base interface constructor. By 'signature' we mean the parameter and return type definitions, including any type hints and including whether the data is passed by reference or by value.

Předcházející | Nahoru | Další
Error Reporting | Domů | C. Migrating from PHP 5.0.x to PHP 5.1.x


New Parameters

Some functions were given new, optional, parameters in PHP 5.2.x:

PHP Core:

  • htmlentities() - added double_encode in PHP 5.2.3.
  • htmlspecialchars() - added double_encode in PHP 5.2.3.
  • base64_decode() - added strict
  • setcookie() - added httponly
  • setrawcookie() - added httponly
  • session_set_cookie_params() - added httponly
  • memory_get_usage() - added real_usage
  • get_loaded_extensions() - added zend_extensions in PHP 5.2.4

curl:

  • curl_multi_info_read() - added msgs_in_queue

datetime

  • date() - added "u" (milliseconds) format character in PHP 5.2.2

imap:

  • imap_open() - added n_retries
  • imap_reopen() - added n_retries

mbstring:

  • mb_strrpos() - added offset

    Varování

    The offset parameter was put in the position the encoding parameter used to be. Backward compatibility has been provided by allowing encoding to be specified as the third parameter. Using this backward compatibility mode is not recommended because it will be removed in a future release of PHP.

ming:

  • swfmovie::streamMP3() - added skip in PHP 5.2.1

openssl:

  • openssl_verify() - added signature_algo

pgsql:

  • pg_escape_bytea() - added connection
  • pg_escape_string() - added connection

simplexml:

  • SimpleXMLElement::__construct() - added is_prefix
  • SimpleXMLElement::attributes() - added is_prefix
  • SimpleXMLElement::children() - added is_prefix
  • simplexml_load_file() - added is_prefix
  • simplexml_load_string() - added is_prefix

spl:

  • array iterator_to_array(Traversable it [, bool use_keys = true]) - added use_keys in PHP 5.2.1

xmlreader:

  • XMLReader::open() - added encoding and options
  • XMLReader::XML() - added encoding and options

XMLWriter:

  • XMLWriter::WriteElement() - the content became optional in PHP 5.2.3
  • XMLWriter::WriteElementNs() - the content became optional in PHP 5.2.3
Předcházející | Nahoru | Další
Changes in PHP datetime support | Domů | New Functions


Removed Extensions

These extensions have been moved to PECL and are no longer part of the PHP distribution. The PECL package version of these extensions will be created according to user demand.

  • filePro
  • Hyperwave API
Předcházející | Nahoru | Další
New Methods | Domů | New Extensions


old_function

Příkaz old_function vám umožňuje deklarovat funkci pomocí syntaxe identické s PHP/FI2 (kromě toho, že klíčové slovo 'function' musíte nahradit slovem 'old_function'.

Tato vlastnost je zastaralí a měla by se používat pouze v konvertoru PHP/FI2->PHP 3.

Varování

Funkce deklarované jako old_function nelze volat z vnitřního kódu PHP. To kromě jiného znamená, že tyto funkce nelze použít ve funkcích jako usort(), array_walk() a register_shutdown_function(). Toto omezení můžete obejít napsání wrapperové funkce (v normálním formátu PHP 3) a z ní zavoláte old_function.

Předcházející | Nahoru | Další
F. Přechod z PHP/FI 2 na PHP 3 | Domů | Otvírací/uzavírací značky (start/end tags)


Návratové hodnoty TRUE/FALSE

Většina vnitřních funkcí byla přepsána tak, aby vracela TRUE v případě úspěchu a FALSE při selhání, narozdíl od původních hodnot 0 a -1 v PHP/FI 2.0. Nové chování umožňuje logičtější programování, jako $fp = fopen("/your/file") nebo fail("darn!");. Protože v PHP/FI 2.0 nebyla jasná pravidla, v kterých případech se vyskakovalo z funkce při selhání, většina skriptů bude pravděpodobně muset být zkontrolována ručně po použití konvertoru z 2.0 na 3.0.

Příklad F.9. Přechod z 2.0: návratové hodnoty, starý kód

$fp = fopen($file, "r");
if ($fp == -1);
    echo("Could not open $file for reading<br>\n");
endif;

Příklad F.10. Přechod z 2.0: návratové hodnoty, nový kód

$fp = @fopen($file, "r") or print("Could not open $file for reading<br>\n");

Předcházející | Nahoru | Další
Zkrácené vyhodnocení logických výrazů | Domů | Jiné nekompatibility


SWFAction

(No version information available, might be only in CVS)

SWFAction — SWFAction Class

Popis

The script syntax is based on the C language, but with a lot taken out- the SWF bytecode machine is just too simpleminded to do a lot of things we might like. For instance, we can't implement function calls without a tremendous amount of hackery because the jump bytecode has a hardcoded offset value. No pushing your calling address to the stack and returning- every function would have to know exactly where to return to.

So what's left? The compiler recognises the following tokens:

  • break
  • for
  • continue
  • if
  • else
  • do
  • while

There is no typed data; all values in the SWF action machine are stored as strings. The following functions can be used in expressions:

time()
Returns the number of milliseconds (?) elapsed since the movie started.
random(seed)
Returns a pseudo-random number in the range 0-seed.
length(expr)
Returns the length of the given expression.
int(number)
Returns the given number rounded down to the nearest integer.
concat(expr, expr)
Returns the concatenation of the given expressions.
ord(expr)
Returns the ASCII code for the given character
chr(num)
Returns the character for the given ASCII code
substr(string, location, length)
Returns the substring of length length at location location of the given string string.

Additionally, the following commands may be used:

duplicateClip(clip, name, depth)
Duplicate the named movie clip (aka sprite). The new movie clip has name name and is at depth depth.
removeClip(expr)
Removes the named movie clip.
trace(expr)
Write the given expression to the trace log. Doubtful that the browser plugin does anything with this.
startDrag(target, lock, [left, top, right, bottom])
Start dragging the movie clip target. The lock argument indicates whether to lock the mouse (?)- use 0 (FALSE) or 1 (TRUE). Optional parameters define a bounding area for the dragging.
stopDrag()
Stop dragging my heart around. And this movie clip, too.
callFrame(expr)
Call the named frame as a function.
getURL(url, target, [method])
Load the given URL into the named target. The target argument corresponds to HTML document targets (such as "_top" or "_blank"). The optional method argument can be POST or GET if you want to submit variables back to the server.
loadMovie(url, target)
Load the given URL into the named target. The target argument can be a frame name (I think), or one of the magical values "_level0" (replaces current movie) or "_level1" (loads new movie on top of current movie).
nextFrame()
Go to the next frame.
prevFrame()
Go to the last (or, rather, previous) frame.
play()
Start playing the movie.
stop()
Stop playing the movie.
toggleQuality()
Toggle between high and low quality.
stopSounds()
Stop playing all sounds.
gotoFrame(num)
Go to frame number num. Frame numbers start at 0.
gotoFrame(name)
Go to the frame named name. Which does a lot of good, since I haven't added frame labels yet.
setTarget(expr)
Sets the context for action. Or so they say- I really have no idea what this does.
And there's one weird extra thing. The expression frameLoaded(num) can be used in if statements and while loops to check if the given frame number has been loaded yet. Well, it's supposed to, anyway, but I've never tested it and I seriously doubt it actually works. You can just use /:framesLoaded instead.

Movie clips (all together now- aka sprites) have properties. You can read all of them (or can you?), you can set some of them, and here they are:

  • x
  • y
  • xScale
  • yScale
  • currentFrame - (read-only)
  • totalFrames - (read-only)
  • alpha - transparency level
  • visible - 1=on, 0=off (?)
  • width - (read-only)
  • height - (read-only)
  • rotation
  • target - (read-only) (???)
  • framesLoaded - (read-only)
  • name
  • dropTarget - (read-only) (???)
  • url - (read-only) (???)
  • highQuality - 1=high, 0=low (?)
  • focusRect - (???)
  • soundBufTime - (???)
So, setting a sprite's x position is as simple as /box.x = 100;. Why the slash in front of the box, though? That's how flash keeps track of the sprites in the movie, just like a Unix filesystem- here it shows that box is at the top level. If the sprite named box had another sprite named biff inside of it, you'd set its x position with /box/biff.x = 100;. At least, I think so; correct me if I'm wrong here.

Class Members

Metody

SWFAction->__construct()

Příklady

This simple example will move the red square across the window.

Příklad 1168. swfaction() example

<?php
  $s = new SWFShape();
  $f = $s->addFill(0xff, 0, 0);
  $s->setRightFill($f);

  $s->movePenTo(-500, -500);
  $s->drawLineTo(500, -500);
  $s->drawLineTo(500, 500);
  $s->drawLineTo(-500, 500);
  $s->drawLineTo(-500, -500);

  $p = new SWFSprite();
  $i = $p->add($s);
  $i->setDepth(1);
  $p->nextFrame();

  for ($n=0; $n<5; ++$n) {
    $i->rotate(-15);
    $p->nextFrame();
  }

  $m = new SWFMovie();
  $m->setBackground(0xff, 0xff, 0xff);
  $m->setDimension(6000, 4000);

  $i = $m->add($p);
  $i->setDepth(1);
  $i->moveTo(-500,2000);
  $i->setName("box");

  $m->add(new SWFAction("/box.x += 3;"));
  $m->nextFrame();
  $m->add(new SWFAction("gotoFrame(0); play();"));
  $m->nextFrame();

  header('Content-type: application/x-shockwave-flash');
  $m->output();
?>

This simple example tracks down your mouse on the screen.

Příklad 1169. swfaction() example

<?php

  $m = new SWFMovie();
  $m->setRate(36.0);
  $m->setDimension(1200, 800);
  $m->setBackground(0, 0, 0);

  /* mouse tracking sprite - empty, but follows mouse so we can
     get its x and y coordinates */

  $i = $m->add(new SWFSprite());
  $i->setName('mouse');

  $m->add(new SWFAction("
    startDrag('/mouse', 1); /* '1' means lock sprite to the mouse */
  "));

  /* might as well turn off antialiasing, since these are just squares. */

  $m->add(new SWFAction("
    this.quality = 0;
  "));

  /* morphing box */
  $r = new SWFMorph();
  $s = $r->getShape1();

  /* Note this is backwards from normal shapes.  No idea why. */
  $s->setLeftFill($s->addFill(0xff, 0xff, 0xff));
  $s->movePenTo(-40, -40);
  $s->drawLine(80, 0);
  $s->drawLine(0, 80);
  $s->drawLine(-80, 0);
  $s->drawLine(0, -80);

  $s = $r->getShape2();

  $s->setLeftFill($s->addFill(0x00, 0x00, 0x00));
  $s->movePenTo(-1, -1);
  $s->drawLine(2, 0);
  $s->drawLine(0, 2);
  $s->drawLine(-2, 0);
  $s->drawLine(0, -2);

  /* sprite container for morphing box -
     this is just a timeline w/ the box morphing */

  $box = new SWFSprite();
  $box->add(new SWFAction("
    stop();
  "));
  $i = $box->add($r);

  for ($n=0; $n<=20; ++$n) {
    $i->setRatio($n/20);
    $box->nextFrame();
  }

  /* this container sprite allows us to use the same action code many times */

  $cell = new SWFSprite();
  $i = $cell->add($box);
  $i->setName('box');

  $cell->add(new SWFAction("

    setTarget('box');

    /* ...x means the x coordinate of the parent, i.e. (..).x */
    dx = (/mouse.x + random(6)-3 - ...x)/5;
    dy = (/mouse.y + random(6)-3 - ...y)/5;
    gotoFrame(int(dx*dx + dy*dy));

  "));

  $cell->nextFrame();
  $cell->add(new SWFAction("

    gotoFrame(0);
    play();

  "));

  $cell->nextFrame();

  /* finally, add a bunch of the cells to the movie */

  for ($x=0; $x<12; ++$x) {
    for ($y=0; $y<8; ++$y) {
      $i = $m->add($cell);
      $i->moveTo(100*$x+50, 100*$y+50);
    }
  }

  $m->nextFrame();

  $m->add(new SWFAction("

    gotoFrame(1);
    play();

  "));

  header('Content-type: application/x-shockwave-flash');
  $m->output();
?>

Same as above, but with nice colored balls...

Příklad 1170. swfaction() example

<?php

  $m = new SWFMovie();
  $m->setDimension(11000, 8000);
  $m->setBackground(0x00, 0x00, 0x00);

  $m->add(new SWFAction("

this.quality = 0;
/frames.visible = 0;
startDrag('/mouse', 1);

  "));

  // mouse tracking sprite
  $t = new SWFSprite();
  $i = $m->add($t);
  $i->setName('mouse');

  $g = new SWFGradient();
  $g->addEntry(0, 0xff, 0xff, 0xff, 0xff);
  $g->addEntry(0.1, 0xff, 0xff, 0xff, 0xff);
  $g->addEntry(0.5, 0xff, 0xff, 0xff, 0x5f);
  $g->addEntry(1.0, 0xff, 0xff, 0xff, 0);

  // gradient shape thing
  $s = new SWFShape();
  $f = $s->addFill($g, SWFFILL_RADIAL_GRADIENT);
  $f->scaleTo(0.03);
  $s->setRightFill($f);
  $s->movePenTo(-600, -600);
  $s->drawLine(1200, 0);
  $s->drawLine(0, 1200);
  $s->drawLine(-1200, 0);
  $s->drawLine(0, -1200);

  // need to make this a sprite so we can multColor it
  $p = new SWFSprite();
  $p->add($s);
  $p->nextFrame();

  // put the shape in here, each frame a different color
  $q = new SWFSprite();
  $q->add(new SWFAction("gotoFrame(random(7)+1); stop();"));
  $i = $q->add($p);

  $i->multColor(1.0, 1.0, 1.0);
  $q->nextFrame();
  $i->multColor(1.0, 0.5, 0.5);
  $q->nextFrame();
  $i->multColor(1.0, 0.75, 0.5);
  $q->nextFrame();
  $i->multColor(1.0, 1.0, 0.5);
  $q->nextFrame();
  $i->multColor(0.5, 1.0, 0.5);
  $q->nextFrame();
  $i->multColor(0.5, 0.5, 1.0);
  $q->nextFrame();
  $i->multColor(1.0, 0.5, 1.0);
  $q->nextFrame();

  // finally, this one contains the action code
  $p = new SWFSprite();
  $i = $p->add($q);
  $i->setName('frames');
  $p->add(new SWFAction("

dx = (/:mousex-/:lastx)/3 + random(10)-5;
dy = (/:mousey-/:lasty)/3;
x = /:mousex;
y = /:mousey;
alpha = 100;

  "));
  $p->nextFrame();

  $p->add(new SWFAction("

this.x = x;
this.y = y;
this.alpha = alpha;
x += dx;
y += dy;
dy += 3;
alpha -= 8;

  "));
  $p->nextFrame();

  $p->add(new SWFAction("prevFrame(); play();"));
  $p->nextFrame();

  $i = $m->add($p);
  $i->setName('frames');
  $m->nextFrame();

  $m->add(new SWFAction("

lastx = mousex;
lasty = mousey;
mousex = /mouse.x;
mousey = /mouse.y;

++num;

if (num == 11)
  num = 1;

removeClip('char' & num);
duplicateClip(/frames, 'char' & num, num);

  "));

  $m->nextFrame();
  $m->add(new SWFAction("prevFrame(); play();"));

  header('Content-type: application/x-shockwave-flash');
  $m->output();
?>

Předcházející | Nahoru | Další
LXXXIX. Ming functions for Flash | Domů | SWFAction->__construct()


SWFBitmap

(No version information available, might be only in CVS)

SWFBitmap — SWFBitmap Class

Popis

Class Members

Metody

SWFBitmap->__construct()
SWFBitmap->getHeight()
SWFBitmap->getWidth()
Předcházející | Nahoru | Další
SWFAction->__construct() | Domů | SWFBitmap->__construct()


SWFButton

(No version information available, might be only in CVS)

SWFButton — SWFButton Class

Popis

Class Members

Metody

SWFButton->__construct()
SWFButton->addAction()
SWFButton->addASound()
SWFButton->addShape()
SWFButton->setAction()
SWFButton->setDown()
SWFButton->setHit()
SWFButton->setMenu()
SWFButton->setOver()
SWFButton->setUp()
Předcházející | Nahoru | Další
SWFBitmap->getWidth() | Domů | SWFButton->__construct()


SWFDisplayItem

(No version information available, might be only in CVS)

SWFDisplayItem — SWFDisplayItem Class

Popis

Class Members

Metody

SWFDisplayItem->addAction()
SWFDisplayItem->addColor()
SWFDisplayItem->endMask()
SWFDisplayItem->getRot()
SWFDisplayItem->getX()
SWFDisplayItem->getXScale()
SWFDisplayItem->getXSkew()
SWFDisplayItem->getY()
SWFDisplayItem->getYScale()
SWFDisplayItem->getYSkew()
SWFDisplayItem->move()
SWFDisplayItem->moveTo()
SWFDisplayItem->multColor()
SWFDisplayItem->remove()
SWFDisplayItem->rotate()
SWFDisplayItem->rotateTo()
SWFDisplayItem->scale()
SWFDisplayItem->scaleTo()
SWFDisplayItem->setDepth()
SWFDisplayItem->setMaskLevel()
SWFDisplayItem->setMatrix()
SWFDisplayItem->setName()
SWFDisplayItem->setRatio()
SWFDisplayItem->skewX()
SWFDisplayItem->skewXTo()
SWFDisplayItem->skewY()
SWFDisplayItem->skewYTo()
Předcházející | Nahoru | Další
SWFButton->setUp() | Domů | SWFDisplayItem->addAction()


SWFFill

(No version information available, might be only in CVS)

SWFFill — SWFFill Class

Popis

The SWFFill object allows you to transform (scale, skew, rotate) bitmap and gradient fills.

swffill objects are created by the SWFShape->addFill() method.

Class Members

Metody

SWFFill->moveTo()
SWFFill->rotateTo()
SWFFill->scaleTo()
SWFFill->skewXTo()
SWFFill->skewYTo()
Předcházející | Nahoru | Další
SWFDisplayItem->skewYTo() | Domů | SWFFill->moveTo()


SWFFont

(No version information available, might be only in CVS)

SWFFont — SWFFont Class

Popis

The SWFFont object represent a reference to the font definition, for us with SWFText->setFont() and SWFTextField->setFont().

Class Members

Metody

SWFFont->__construct()
SWFFont->getAscent()
SWFFont->getDescent()
SWFFont->getLeading()
SWFFont->getShape()
SWFFont->getUTF8Width()
SWFFont->getWidth()
Předcházející | Nahoru | Další
SWFFill->skewYTo() | Domů | SWFFont->__construct()


SWFFontChar

(No version information available, might be only in CVS)

SWFFontChar — SWFFontChar Class

Popis

Class Members

Metody

SWFFontChar->addChars()
SWFFontChar->addUTF8Chars()
Předcházející | Nahoru | Další
SWFFont->getWidth() | Domů | SWFFontChar->addChars()


SWFGradient

(No version information available, might be only in CVS)

SWFGradient — SWFGradient Class

Popis

Class Members

Metody

SWFGradient->__construct()
SWFGradient->addEntry()
Předcházející | Nahoru | Další
SWFFontChar->addUTF8Chars() | Domů | SWFGradient->__construct()


SWFMorph

(No version information available, might be only in CVS)

SWFMorph — SWFMorph Class

Popis

The methods here are sort of weird. It would make more sense to just have newSWFMorph(shape1, shape2);, but as things are now, shape2 needs to know that it's the second part of a morph. (This, because it starts writing its output as soon as it gets drawing commands- if it kept its own description of its shapes and wrote on completion this and some other things would be much easier.)

Class Members

Metody

SWFMorph->__construct()
SWFMorph->getShape1()
SWFMorph->getShape2()
Předcházející | Nahoru | Další
SWFGradient->addEntry() | Domů | SWFMorph->__construct()


SWFMovie

(No version information available, might be only in CVS)

SWFMovie — SWFMovie Class

Popis

SWFMovie is a movie object representing an SWF movie.

Class Members

Metody

SWFMovie->__construct()
SWFMovie->add()
SWFMovie->addExport()
SWFMovie->addFont()
SWFMovie->importChar()
SWFMovie->importFont()
SWFMovie->labelFrame()
SWFMovie->nextFrame()
SWFMovie->output()
SWFMovie->remove()
SWFMovie->save()
SWFMovie->saveToFile()
SWFMovie->setbackground()
SWFMovie->setDimension()
SWFMovie->setFrames()
SWFMovie->setRate()
SWFMovie->startSound()
SWFMovie->stopSound()
SWFMovie->streamMP3()
SWFMovie->writeExports()
Předcházející | Nahoru | Další
SWFMorph->getShape2() | Domů | SWFMovie->__construct()


SWFPrebuiltClip

(No version information available, might be only in CVS)

SWFPrebuiltClip — SWFPrebuiltClip Class

Popis

Class Members

Metody

SWFPrebuiltClip->__construct()
Předcházející | Nahoru | Další
SWFMovie->writeExports() | Domů | SWFPrebuiltClip->__construct()


SWFShape

(No version information available, might be only in CVS)

SWFShape — SWFShape Class

Popis

Class Members

Metody

SWFShape->__construct()
SWFShape->addFill()
SWFShape->drawArc()
SWFShape->drawCircle()
SWFShape->drawCubic()
SWFShape->drawCubicTo()
SWFShape->drawCurve()
SWFShape->drawCurveTo()
SWFShape->drawGlyph()
SWFShape->drawLine()
SWFShape->drawLineTo()
SWFShape->movePen()
SWFShape->movePenTo()
SWFShape->setLeftFill()
SWFShape->setLine()
SWFShape->setRightFill()
Předcházející | Nahoru | Další
SWFPrebuiltClip->__construct() | Domů | SWFShape->__construct()


SWFSound

(No version information available, might be only in CVS)

SWFSound — SWFSound Class

Popis

Class Members

Metody

SWFSound
Předcházející | Nahoru | Další
SWFShape->setRightFill() | Domů | SWFSound


SWFSoundInstance

(No version information available, might be only in CVS)

SWFSoundInstance — SWFSoundInstance Class

Popis

SWFSoundInstance objects are returned by the SWFSprite->startSound() and SWFMovie->startSound() methods.

Class Members

Metody

SWFSoundInstance->loopCount()
SWFSoundInstance->loopInPoint()
SWFSoundInstance->loopOutPoint()
SWFSoundInstance->noMultiple()
Předcházející | Nahoru | Další
SWFSound | Domů | SWFSoundInstance->loopCount()


SWFSprite

(No version information available, might be only in CVS)

SWFSprite — SWFSprite Class

Popis

An SWFSprite is also known as a "movie clip", this allows one to create objects which are animated in their own timelines. Hence, the sprite has most of the same methods as the movie.

Class Members

Metody

SWFSprite->__construct()
SWFSprite->add()
SWFSprite->labelFrame()
SWFSprite->nextFrame()
SWFSprite->remove()
SWFSprite->setFrames()
SWFSprite->startSound()
SWFSprite->stopSound()

Příklady

This simple example will spin gracefully a big red square.

Příklad 1185. swfsprite() example

<?php
$s = new SWFShape();
$s->setRightFill($s->addFill(0xff, 0, 0));
$s->movePenTo(-500, -500);
$s->drawLineTo(500, -500);
$s->drawLineTo(500, 500);
$s->drawLineTo(-500, 500);
$s->drawLineTo(-500, -500);

$p = new SWFSprite();
$i = $p->add($s);
$p->nextFrame();
$i->rotate(15);
$p->nextFrame();
$i->rotate(15);
$p->nextFrame();
$i->rotate(15);
$p->nextFrame();
$i->rotate(15);
$p->nextFrame();
$i->rotate(15);
$p->nextFrame();

$m = new SWFMovie();
$i = $m->add($p);
$i->moveTo(1500, 1000);
$i->setName("blah");

$m->setBackground(0xff, 0xff, 0xff);
$m->setDimension(3000, 2000);

header('Content-type: application/x-shockwave-flash');
$m->output();
?>

Předcházející | Nahoru | Další
SWFSoundInstance->noMultiple() | Domů | SWFSprite->__construct()


SWFText

(No version information available, might be only in CVS)

SWFText — SWFText Class

Popis

Class Members

Metody

SWFText->__construct()
SWFText->addString()
SWFText->addUTF8String()
SWFText->getAscent()
SWFText->getDescent()
SWFText->getLeading()
SWFText->getUTF8Width()
SWFText->getWidth()
SWFText->moveTo()
SWFText->setColor()
SWFText->setFont()
SWFText->setHeight()
SWFText->setSpacing()
Předcházející | Nahoru | Další
SWFSprite->stopSound() | Domů | SWFText->__construct()


SWFTextField

(No version information available, might be only in CVS)

SWFTextField — SWFTextField Class

Popis

Class Members

Metody

SWFTextField->__construct()
SWFTextField->addChars()
SWFTextField->addString()
SWFTextField->align()
SWFTextField->setBounds()
SWFTextField->setColor()
SWFTextField->setFont()
SWFTextField->setHeight()
SWFTextField->setIndentation()
SWFTextField->setLeftMargin()
SWFTextField->setLineSpacing()
SWFTextField->setMargins()
SWFTextField->setName()
SWFTextField->setPadding()
SWFTextField->setRightMargin()
Předcházející | Nahoru | Další
SWFText->setSpacing() | Domů | SWFTextField->__construct()


SWFVideoStream

(No version information available, might be only in CVS)

SWFVideoStream — SWFVideoStream Class

Popis

Class Members

Metody

SWFVideoStream->__construct()
SWFVideoStream->getNumFrames()
SWFVideoStream->setDimension()
Předcházející | Nahoru | Další
SWFTextField->setRightMargin() | Domů | SWFVideoStream->__construct()


Usage

(No version information available, might be only in CVS)

Usage — Examples on using the ogg:// wrapper.

Příklady

Příklad 1473. Reading an OGG/Vorbis file

<?php
dl("oggvorbis.so");

/* By default, ogg:// will decode to Signed 16-bit Little Endian */
$fp = fopen('ogg://myaudio.ogg', 'r');

/* Collect some information about the file. */
$metadata = stream_get_meta_data($fp);

/* Inspect the first song (usually the only song,
   but OGG/Vorbis files may be chained) */
$songdata = $metadata['wrapper_data'][0];

echo "OGG/Vorbis file encoded by: {$songdata['vendor']}\n.";
echo "  {$songdata['channels']} channels of {$songdata['rate']}Hz sampling encoded at {$songdata['bitrate_nominal']}bps.\n";
foreach($songdata['comments'] as $comment) {
    echo "  $comment\n";
}

while ($audio_data = fread($fp, 8192)) {
  /* Do something with the PCM audio we're extracting from the OGG.
     Copying to /dev/dsp is a good target on linux systems,
     just remember to setup the device for your sampling mode first. */
}

fclose($fp);

?>

Příklad 1474. Encode an audio file to OGG/Vorbis

<?php
dl('oggvorbis.so');

$context = stream_context_create(array('ogg'=>array(
             'pcm_mode' => OGGVORBIS_PCM_S8,  /* Signed 8bit audio */
             'rate' => 44100,                 /* 44kHz CD quality */
             'bitrate' => 0.5,                /* Midquality VBR */
             'channels' => 1,                 /* Mono */
             'serialno' => 12345)));          /* Unique within our stream */

/* Open file for appending.  This will "chain" a second OGG stream at the end of the first. */
$ogg = fopen('ogg://mysong.ogg', 'a', false, $context);

$pcm = fopen('mysample.pcm', 'r');

/* Compress the raw PCM audio from mysample.pcm into mysong.ogg */
stream_copy_to_stream($pcm, $ogg);

fclose($pcm);
fclose($ogg);
?>

Předcházející | Nahoru | Další
CX. oggvorbis | Domů | CXI. OpenAL Audio Bindings


Constants

(No version information available, might be only in CVS)

Constants — Printer Predefined Constants

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

PRINTER_COPIES (integer)
PRINTER_MODE (integer)
PRINTER_TITLE (integer)
PRINTER_DEVICENAME (integer)
PRINTER_DRIVERVERSION (integer)
PRINTER_OUTPUT_FILE (integer)
PRINTER_RESOLUTION_Y (integer)
PRINTER_RESOLUTION_X (integer)
PRINTER_SCALE (integer)
PRINTER_BACKGROUND_COLOR (integer)
PRINTER_PAPER_LENGTH (integer)
PRINTER_PAPER_WIDTH (integer)
PRINTER_PAPER_FORMAT (integer)
PRINTER_FORMAT_CUSTOM (integer)
PRINTER_FORMAT_LETTER (integer)
PRINTER_FORMAT_LEGAL (integer)
PRINTER_FORMAT_A3 (integer)
PRINTER_FORMAT_A4 (integer)
PRINTER_FORMAT_A5 (integer)
PRINTER_FORMAT_B4 (integer)
PRINTER_FORMAT_B5 (integer)
PRINTER_FORMAT_FOLIO (integer)
PRINTER_ORIENTATION (integer)
PRINTER_ORIENTATION_PORTRAIT (integer)
PRINTER_ORIENTATION_LANDSCAPE (integer)
PRINTER_TEXT_COLOR (integer)
PRINTER_TEXT_ALIGN (integer)
PRINTER_TA_BASELINE (integer)
PRINTER_TA_BOTTOM (integer)
PRINTER_TA_TOP (integer)
PRINTER_TA_CENTER (integer)
PRINTER_TA_LEFT (integer)
PRINTER_TA_RIGHT (integer)
PRINTER_PEN_SOLID (integer)
PRINTER_PEN_DASH (integer)
PRINTER_PEN_DOT (integer)
PRINTER_PEN_DASHDOT (integer)
PRINTER_PEN_DASHDOTDOT (integer)
PRINTER_PEN_INVISIBLE (integer)
PRINTER_BRUSH_SOLID (integer)
PRINTER_BRUSH_CUSTOM (integer)
PRINTER_BRUSH_DIAGONAL (integer)
PRINTER_BRUSH_CROSS (integer)
PRINTER_BRUSH_DIAGCROSS (integer)
PRINTER_BRUSH_FDIAGONAL (integer)
PRINTER_BRUSH_HORIZONTAL (integer)
PRINTER_BRUSH_VERTICAL (integer)
PRINTER_FW_THIN (integer)
PRINTER_FW_ULTRALIGHT (integer)
PRINTER_FW_LIGHT (integer)
PRINTER_FW_NORMAL (integer)
PRINTER_FW_MEDIUM (integer)
PRINTER_FW_BOLD (integer)
PRINTER_FW_ULTRABOLD (integer)
PRINTER_FW_HEAVY (integer)
PRINTER_ENUM_LOCAL (integer)
PRINTER_ENUM_NAME (integer)
PRINTER_ENUM_SHARED (integer)
PRINTER_ENUM_DEFAULT (integer)
PRINTER_ENUM_CONNECTIONS (integer)
PRINTER_ENUM_NETWORK (integer)
PRINTER_ENUM_REMOTE (integer)
Předcházející | Nahoru | Další
CXXIX. Printer Functions | Domů | printer_abort


Alternative PHP Cache

Předcházející VI. Reference funkcí Další

III. Alternative PHP Cache

Úvod

The Alternative PHP Cache (APC) is a free and open opcode cache for PHP. It was conceived of to provide a free, open, and robust framework for caching and optimizing PHP intermediate code.

Instalace

Toto rozšíření » PECL není přibaleno k PHP.

Informace o instalaci tohoto PECL rozšíření lze najít v kapitole manuálu nazvané Instalace rozšíření PECL. Další informace, jako nové verze, soubory ke stažení, zdrojové soubory, správcovské informace a CHANGELOG, lze najít zde: » http://pecl.php.net/package/apc.

Tuto DLL knihovnu pro rozšíření PECL můžete stahovat ze stránky » PHP Downloads nebo z » http://snaps.php.net/.

Poznámka: On Windows, APC needs a temp path to exist, and be writable by the web server. It checks TMP, TEMP, USERPROFILE environment variables in that order and finally tries the WINDOWS directory if none of those are set.

Poznámka: For more in-depth, highly technical implementation details, see the » developer-supplied TECHNOTES file .

Konfigurace běhu

Chování těchto funkcí je ovlivněno nastavením parametrů v php.ini.

Although the default APC settings are fine for many installations, serious users should consider tuning the following parameters.

There are two main decisions you have to make. First, how much shared memory do you want to set aside for APC, and second, whether you want APC to check if a file has been modified on every request. The two ini directives involved here are apc.shm_size and apc.stat. Read the sections on these two directives carefully below.

Once you have a running server, you should copy the apc.php script that comes with the extension to somewhere in your docroot and load it up in your browser. It provides you with a detailed look at what is happening in your cache. If you have GD enabled in PHP, it will even have pretty graphs. First thing to check is of course that it is actually caching files. Assuming it is working you should then pay close attention to the Cache full count number on the left. That tells you the number of times the cache has filled up and has had to forcefully clean up any entries not accessed within the last apc.ttl seconds. You should configure your cache to minimize this number. If you are constantly filling your cache, the resulting cache churn is going to hurt performance. You should either set more memory aside for APC, or use apc.filters to cache fewer scripts.

Tabulka 12. APC configuration options

Name | Default | Changeable | Changelog
apc.enabled | "1" | PHP_INI_SYSTEM | PHP_INI_SYSTEM in APC 2. PHP_INI_ALL in APC <= 3.0.12.
apc.shm_segments | "1" | PHP_INI_SYSTEM |
apc.shm_size | "30" | PHP_INI_SYSTEM |
apc.optimization | "0" | PHP_INI_ALL | PHP_INI_SYSTEM in APC 2. Removed in APC 3.0.13.
apc.num_files_hint | "1000" | PHP_INI_SYSTEM |
apc.user_entries_hint | "4096" | PHP_INI_SYSTEM | Available since APC 3.0.0.
apc.ttl | "0" | PHP_INI_SYSTEM | Available since APC 3.0.0.
apc.user_ttl | "0" | PHP_INI_SYSTEM | Available since APC 3.0.0.
apc.gc_ttl | "3600" | PHP_INI_SYSTEM |
apc.cache_by_default | "1" | PHP_INI_ALL | PHP_INI_SYSTEM in APC <= 3.0.12. Available since APC 3.0.0.
apc.filters | NULL | PHP_INI_SYSTEM |
apc.mmap_file_mask | NULL | PHP_INI_SYSTEM |
apc.slam_defense | "0" | PHP_INI_SYSTEM | Available since APC 3.0.0.
apc.file_update_protection | "2" | PHP_INI_SYSTEM | Available since APC 3.0.6.
apc.enable_cli | "0" | PHP_INI_SYSTEM | Available since APC 3.0.7.
apc.max_file_size | "1M" | PHP_INI_SYSTEM | Available since APC 3.0.7.
apc.stat | "1" | PHP_INI_SYSTEM | Available since APC 3.0.10.
apc.write_lock | "1" | PHP_INI_SYSTEM | Available since APC 3.0.11.
apc.report_autofilter | "0" | PHP_INI_SYSTEM | Available since APC 3.0.11.
apc.include_once_override | "0" | PHP_INI_SYSTEM | Available since APC 3.0.12.
apc.rfc1867 | "0" | PHP_INI_SYSTEM | Available since APC 3.0.13.
apc.rfc1867_prefix | "upload_" | PHP_INI_SYSTEM |
apc.rfc1867_name | "APC_UPLOAD_PROGRESS" | PHP_INI_SYSTEM |
apc.rfc1867_freq | "0" | PHP_INI_SYSTEM |
apc.localcache | "0" | PHP_INI_SYSTEM | Available since APC 3.0.14.
apc.localcache.size | "512" | PHP_INI_SYSTEM | Available since APC 3.0.14.

Pro další detaily a definice konstant PHP_INI_*, viz dokumentace k ini_set().

Zde je stručný popis konfiguračních direktiv.

apc.enabled boolean

apc.enabled can be set to 0 to disable APC. This is primarily useful when APC is statically compiled into PHP, since there is no other way to disable it (when compiled as a DSO, the extension line in php.ini can just be commented-out).

apc.shm_segments integer

The number of shared memory segments to allocate for the compiler cache. If APC is running out of shared memory but you have already set apc.shm_size as high as your system allows, you can try raising this value.

apc.shm_size integer

The size of each shared memory segment in MB. By default, some systems (including most BSD variants) have very low limits on the size of a shared memory segment.

apc.optimization integer

The optimization level. Zero disables the optimizer, and higher values use more aggressive optimizations. Expect very modest speed improvements. This is experimental.

apc.num_files_hint integer

A "hint" about the number of distinct source files that will be included or requested on your web server. Set to zero or omit if you're not sure; this setting is mainly useful for sites that have many thousands of source files.

apc.user_entries_hint integer

Just like apc.num_files_hint, a "hint" about the number of distinct user cache variables to store. Set to zero or omit if not sure.

apc.ttl integer

The number of seconds a cache entry is allowed to idle in a slot in case this cache entry slot is needed by another entry. Leaving this at zero means that your cache could potentially fill up with stale entries while newer entries won't be cached.

apc.user_ttl integer

The number of seconds a user cache entry is allowed to idle in a slot in case this cache entry slot is needed by another entry. Leaving this at zero means that your cache could potentially fill up with stale entries while newer entries won't be cached.

apc.gc_ttl integer

The number of seconds that a cache entry may remain on the garbage-collection list. This value provides a fail-safe in the event that a server process dies while executing a cached source file; if that source file is modified, the memory allocated for the old version will not be reclaimed until this TTL reached. Set to zero to disable this feature.

apc.cache_by_default boolean

On by default, but can be set to off and used in conjunction with positive apc.filters so that files are only cached if matched by a positive filter.

apc.filters string

A comma-separated list of POSIX extended regular expressions. If any pattern matches the source filename, the file will not be cached. Note that the filename used for matching is the one passed to include/require, not the absolute path. If the first character of the expression is a + then the expression will be additive in the sense that any files matched by the expression will be cached, and if the first character is a - then anything matched will not be cached. The - case is the default, so it can be left off.

apc.mmap_file_mask string

If compiled with MMAP support by using --enable-mmap this is the mktemp-style file_mask to pass to the mmap module for determing whether your mmap'ed memory region is going to be file-backed or shared memory backed. For straight file-backed mmap, set it to something like /tmp/apc.XXXXXX (exactly 6 Xs). To use POSIX-style shm_open/mmap put a .shm somewhere in your mask. e.g. /apc.shm.XXXXXX You can also set it to /dev/zero to use your kernel's /dev/zero interface to anonymous mmap'ed memory. Leaving it undefined will force an anonymous mmap.

apc.slam_defense integer

On very busy servers whenever you start the server or modify files you can create a race of many processes all trying to cache the same file at the same time. This option sets the percentage of processes that will skip trying to cache an uncached file. Or think of it as the probability of a single process to skip caching. For example, setting apc.slam_defense to 75 would mean that there is a 75% chance that the process will not cache an uncached file. So, the higher the setting the greater the defense against cache slams. Setting this to 0 disables this feature.

Deprecated by apc.write_lock.

apc.file_update_protection integer

When you modify a file on a live web server you really should do so in an atomic manner. That is, write to a temporary file and rename (mv) the file into its permanent position when it is ready. Many text editors, cp, tar and other such programs don't do this. This means that there is a chance that a file is accessed (and cached) while it is still being written to. This apc.file_update_protection setting puts a delay on caching brand new files. The default is 2 seconds which means that if the modification timestamp (mtime) on a file shows that it is less than 2 seconds old when it is accessed, it will not be cached. The unfortunate person who accessed this half-written file will still see weirdness, but at least it won't persist. If you are certain you always atomically update your files by using something like rsync which does this correctly, you can turn this protection off by setting it to 0. If you have a system that is flooded with io causing some update procedure to take longer than 2 seconds, you may want to increase this a bit.

apc.enable_cli integer

Mostly for testing and debugging. Setting this enables APC for the CLI version of PHP. Normally you wouldn't want to create, populate and tear down the APC cache on every CLI request, but for various test scenarios it is handy to be able to enable APC for the CLI version of APC easily.

apc.max_file_size integer

Prevent files larger than this value from getting cached. Defaults to 1M.

apc.stat integer

Be careful if you change this setting. The default is for this to be On which means that APC will stat (check) the script on each request to see if it has been modified. If it has been modified it will recompile and cache the new version. If you turn this setting off, it will not check. That means that in order to have changes become active you need to restart your web server. On a production server where you rarely change the code, turning stats off can produce a significant performance boost.

For included/required files this option applies as well, but note that if you are using relative path includes (any path that doesn't start with / on Unix) APC has to check in order to uniquely identify the file. If you use absolute path includes APC can skip the stat and use that absolute path as the unique identifier for the file.

apc.write_lock boolean

On busy servers when you first start up the server, or when many files are modified, you can end up with all your processes trying to compile and cache the same files. With write_lock enabled, only one process at a time will try to compile an uncached script while the other processes will run uncached instead of sitting around waiting on a lock.

apc.report_autofilter boolean

Logs any scripts that were automatically excluded from being cached due to early/late binding issues.

apc.include_once_override boolean

Optimize include_once() and require_once() calls and avoid the expensive system calls used.

apc.rfc1867 boolean

RFC1867 File Upload Progress hook handler is only available if you compiled APC against PHP 5.2.0 or later. When enabled, any file uploads which includes a field called APC_UPLOAD_PROGRESS before the file field in an upload form will cause APC to automatically create an upload_key user cache entry where key is the value of the APC_UPLOAD_PROGRESS form entry.

Note that the file upload tracking is not threadsafe at this point, so new uploads that happen while a previous one is still going will disable the tracking for the previous.

Příklad 157. An apc.rfc1867 example

<?php
print_r(apc_fetch("upload_$_POST[APC_UPLOAD_PROGRESS]"));
?>

Výše uvedený příklad vypíše něco jako:

Array
(
    [total] => 1142543
    [current] => 1142543
    [rate] => 1828068.8
    [filename] => test
    [name] => file
    [temp_filename] => /tmp/php8F
    [cancel_upload] => 0
    [done] => 1
)

apc.rfc1867_prefix string

Key prefix to use for the user cache entry generated by rfc1867 upload progress functionality.

apc.rfc1867_name string

Specify the hidden form entry name that activates APC upload progress and specifies the user cache key suffix.

apc.rfc1867_freq string

The frequency that updates should be made to the user cache entry for upload progress. This can take the form of a percentage of the total file size or a size in bytes optionally suffixed with 'k', 'm', or 'g' for kilobytes, megabytes, or gigabytes respectively (case insensitive). A setting of 0 updates as often as possible, which may cause slower uploads.

apc.localcache boolean

This enables a lock-free local process shadow-cache which reduces lock contention when the cache is being written to.

apc.localcache.size integer

The size of the local process shadow-cache, should be set to a sufficently large value, approximately half of apc.num_files_hint.

Typy prostředků

Toto rozšíření nemá definován žádný typ prostředku (resource).

Předdefinované konstanty

Toto rozšíření nemá definovány žádné konstanty.

Obsah

apc_add — Cache a variable in the data store (only if it's not stored)
apc_cache_info — Retrieves cached information (and meta-data) from APC's data store
apc_clear_cache — Clears the APC cache
apc_compile_file — Stores a file in the bytecode cache, bypassing all filters.
apc_define_constants — Defines a set of constants for retrieval and mass-definition
apc_delete — Removes a stored variable from the cache
apc_fetch — Fetch a stored variable from the cache
apc_load_constants — Loads a set of constants from the cache
apc_sma_info — Retrieves APC's Shared Memory Allocation information
apc_store — Cache a variable in the data store
Předcházející | Nahoru | Další
virtual | Domů | apc_add


BBCode Functions

Předcházející VI. Reference funkcí Další

VII. BBCode Functions

Úvod

This extension aims to help parse BBCode text in order to convert it to HTML or another markup language. It uses one pass parsing and provides great speed improvement over the common approach based on regular expressions. Further more, it helps provide valid HTML by reordering open / close tags and by automatically closing unclosed tags.

Since 0.10.1 It supports argument quoting with single quotes, double quotes and HTML escaped double quotes.

Instalace

Informace o instalaci tohoto PECL rozšíření lze najít v kapitole manuálu nazvané Instalace rozšíření PECL. Další informace, jako nové verze, soubory ke stažení, zdrojové soubory, správcovské informace a CHANGELOG, lze najít zde: » http://pecl.php.net/package/bbcode

An alternative solution, written in PHP, is the PEAR package » HTML_BBCodeParser.

Konfigurace běhu

Toto rozšíření nemá definováno žádné konfigurační direktivy.

Typy prostředků

One resource is used in the BBCode extension: a BBCode_Container returned by bbcode_create().

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

BBCODE_TYPE_NOARG (integer)
This BBCode tag does not accept any arguments.
BBCODE_TYPE_SINGLE (integer)
This BBCode tag does not have a corresponding close tag.
BBCODE_TYPE_ARG (integer)
This BBCode tag need an argument.
BBCODE_TYPE_OPTARG (integer)
This BBCode tag accept an optional argument.
BBCODE_TYPE_ROOT (integer)
This BBCode tag is the special tag root (nesting level 0).
BBCODE_FLAGS_ARG_PARSING (integer)
This BBCode tag require argument sub-parsing (the argument is also parsed by the BBCode extension). As Of 0.10.2 another parser can be used as argument parser.
BBCODE_FLAGS_CDATA_NOT_ALLOWED (integer)
This BBCode Tag does not accept content (it voids it automatically).
BBCODE_FLAGS_SMILEYS_ON (integer) - since 0.10.2
This BBCode Tag accepts smileys.
BBCODE_FLAGS_SMILEYS_OFF (integer) - since 0.10.2
This BBCode Tag does not accept smileys.
BBCODE_FLAGS_ONE_OPEN_PER_LEVEL (integer) - since 0.10.2
This BBCode Tag automatically closes if another tag of the same type is found at the same nesting level.
BBCODE_FLAGS_REMOVE_IF_EMPTY (integer) - since 0.10.2
This BBCode Tag is automatically removed if content is empty it allows to produce ligther HTML.
BBCODE_FLAGS_DENY_REOPEN_CHILD (integer) - since 0.10.3
This BBCode Tag does not allow unclosed childs to reopen when automatically closed.
BBCODE_ARG_DOUBLE_QUOTE (integer) - since 0.10.2
This is a parser option allowing argument quoting with double quotes (")
BBCODE_ARG_SINGLE_QUOTE (integer) - since 0.10.2
This is a parser option allowing argument quoting with single quotes (')
BBCODE_ARG_HTML_QUOTE (integer) - since 0.10.2
This is a parser option allowing argument quoting with HTML version of double quotes (&quot;)
BBCODE_AUTO_CORRECT (integer) - since 0.10.2
This is a parser option changing the way errors are treated. It automatically closes tag in the order they are opened. And treat tags with only an open tag as if there were a close tag present.
BBCODE_CORRECT_REOPEN_TAGS (integer) - since 0.10.2
This is a parser option changing the way errors are treated. It automatically reopens tag if close tags are not in the good order.
BBCODE_DISABLE_TREE_BUILD (integer) - since 0.10.2
This is a parser option disabling the BBCode parsing it can be useful if only the "smiley" replacement must be used.
BBCODE_DEFAULT_SMILEYS_ON (integer) - since 0.10.2
This is a parser option setting smileys to ON if no flag is given at tag level.
BBCODE_DEFAULT_SMILEYS_OFF (integer) - since 0.10.2
This is a parser option setting smileys to OFF if no flag is given at tag level.
BBCODE_FORCE_SMILEYS_OFF (integer) - since 0.10.2
This is a parser option disabling completely the smileys parsing.
BBCODE_SMILEYS_CASE_INSENSITIVE (integer) - since 0.10.3
Use a case insensitive Detection for smileys instead of a simple binary search.
BBCODE_SET_FLAGS_SET (integer) - since 0.10.2
This permits to SET the complete flag set on a parser.
BBCODE_SET_FLAGS_ADD (integer) - since 0.10.2
This permits to switch a flag set ON on a parser.
BBCODE_SET_FLAGS_REMOVE (integer) - since 0.10.2
This permits to switch a flag set OFF on a parser.

Obsah

bbcode_add_element — Adds a bbcode element
bbcode_add_smiley — Adds a smiley to the parser
bbcode_create — Create a BBCode Resource
bbcode_destroy — Close BBCode_container resource
bbcode_parse — Parse a string following a given rule set
bbcode_set_arg_parser — Attach another parser in order to use another rule set for argument parsing
bbcode_set_flags — Set or alter parser options
Předcházející | Nahoru | Další
aspell_suggest | Domů | bbcode_add_element


PHP bytecode Compiler

Předcházející VI. Reference funkcí Další

IX. PHP bytecode Compiler

Úvod

Varování

Toto rozšíření je EXPERIMENTÁLNÍ. Chování tohoto rozšíření, názvy funkcí a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může bez ohlášení změnit. Berte to v úvahu a používejte tento modul na vlastní nebezpečí.

Bcompiler was written for several reasons:
To encode entire script in a proprietary PHP application
To encode some classes and/or functions in a proprietary PHP application
To enable the production of php-gtk applications that could be used on client desktops, without the need for a php.exe.
To do the feasibility study for a PHP to C converter
The first of these goals is achieved using the bcompiler_write_header(), bcompiler_write_file() and bcompiler_write_footer() functions. The bytecode files can be written as either uncompressed or plain. To use the generated bytecode, you can simply include it with include or require statements.

The second of these goals is achieved using the bcompiler_write_header(), bcompiler_write_class(), bcompiler_write_footer(), bcompiler_read(), and bcompiler_load() functions. The bytecode files can be written as either uncompressed or plain. The bcompiler_load() reads a bzip compressed bytecode file, which tends to be 1/3 of the size of the original file.

To create EXE type files, bcompiler has to be used with a modified sapi file or a version of PHP which has been compiled as a shared library. In this scenario, bcompiler reads the compressed bytecode from the end of the exe file.

bcompiler can improve performance by about 30% when used with uncompressed bytecodes only. But keep in mind that uncompressed bytecode can be up to 5 times larger than the original source code. Using bytecode compression can save your space, but decompression requires much more time than parsing a source. bcompiler also does not do any bytecode optimization, this could be added in the future...

In terms of code protection, it is safe to say that it would be impossible to recreate the exact source code that it was built from, and without the accompanying source code comments. It would effectively be useless to use the bcompiler bytecodes to recreate and modify a class. However it is possible to retrieve data from a bcompiled bytecode file - so don't put your private passwords or anything in it.

Instalace

short installation note:

  • You need at least PHP 4.3.0 for the compression to work
  • To install on PHP 4.3.0 and later at the Unix command prompt type pear install bcompiler
  • To install on Windows, until the binary package distribution mechanism is finished please search the archives of the pear-general mailing list for pre-built packages. (or send an email to it if you could not find a reference)
  • To install on older versions you need to make some slight changes to the build.
  • untar the bcompiler.tgz archive into php4/ext.(Get it directly from PECL » http://pecl.php.net/get/bcompiler)
  • If the new directory is now called something like bcompiler-0.x, then you should rename it to bcompiler (except you only want to build it as self-contained php-module).
  • If you are using versions before PHP 4.3.0, the you will need to copy the Makefile.in.old to Makefile.in and config.m4.old to config.m4.
  • run phpize in ext/bcompiler
  • run ./buildconf in php4
  • run configure with --enable-bcompiler (and your other options)
  • make; make install
  • that's it.

Contact Information

If you have comments, bugfixes, enhancements or want to help developing this beast, you can drop me a mail at » alan_k@php.net. Any help is very welcome.

Obsah

bcompiler_load_exe — Reads and creates classes from a bcompiler exe file
bcompiler_load — Reads and creates classes from a bz compressed file
bcompiler_parse_class — Reads the bytecodes of a class and calls back to a user function
bcompiler_read — Reads and creates classes from a filehandle
bcompiler_write_class — Writes an defined class as bytecodes
bcompiler_write_constant — Writes a defined constant as bytecodes
bcompiler_write_exe_footer — Writes the start pos, and sig to the end of a exe type file
bcompiler_write_file — Writes a php source file as bytecodes
bcompiler_write_footer — Writes the single character \x00 to indicate End of compiled data
bcompiler_write_function — Writes an defined function as bytecodes
bcompiler_write_functions_from_file — Writes all functions defined in a file as bytecodes
bcompiler_write_header — Writes the bcompiler header
bcompiler_write_included_filename — Writes an included file as bytecodes
Předcházející | Nahoru | Další
bcsub | Domů | bcompiler_load_exe


Credit Mutuel CyberMUT functions

Předcházející VI. Reference funkcí Další

XXI. Credit Mutuel CyberMUT functions

Úvod

This extension allows you to process credit cards transactions using » Credit Mutuel CyberMUT system.

CyberMUT is a popular Web Payment Service in France, provided by the Credit Mutuel bank. If you are foreign in France, these functions will not be useful for you.

The use of these functions is almost identical to the original functions, except for the parameters of return for CreerFormulaireCM and CreerReponseCM, which are returned directly by functions PHP, whereas they had passed in reference in the original functions.

Poznámka: Toto rozšíření není k dispozici na platformách Windows.

Poznámka: Toto rozšíření bylo přesunuto do repozitáře PECL a již nebude součástí balíku PHP.4.3.0

Požadavky

You will require the appropriate SDK for your platform, which may be sent to you after your CyberMUT's subscription (contact them via Web, or go to the nearest Credit Mutuel).

Poznámka: These functions only provide a link to CyberMUT SDK. Be sure to read the CyberMUT Developers Guide for full details of the required parameters.

Obsah

cybermut_creerformulairecm — Generate HTML form of request for payment
cybermut_creerreponsecm — Generate the delivery's acknowledgement of the payment's confirmation
cybermut_testmac — Make sure that there was no data diddling contained in the received message of confirmation
Předcházející | Nahoru | Další
cybercash_encr | Domů | cybermut_creerformulairecm


enchant Functions

Předcházející VI. Reference funkcí Další

XXXIII. enchant Functions

Úvod

Enchant is the PHP binding for the » Enchant library. Enchant steps in to provide uniformity and conformity on top of all spelling libraries, and implement certain features that may be lacking in any individual provider library. Everything should "just work" for any and every definition of "just working."

Enchat supports the following backends:

  • Aspell/Pspell (intends to replace Ispell)

  • Ispell (old as sin, could be interpreted as a defacto standard)

  • MySpell/Hunspell (an OOo projects, also used by Mozilla)

  • Uspell (primarily Yiddish, Hebrew, and Eastern European languages - hosted in AbiWord's CVS under the module "uspell")

  • Hspell (Hebrew)

  • AppleSpell (Mac OSX)

Požadavky

This version uses the functions of the » Enchant library by Dom Lachowicz. You need Enchant 1.2.4 or later.

Instalace

Informace o instalaci tohoto PECL rozšíření lze najít v kapitole manuálu nazvané Instalace rozšíření PECL. Další informace, jako nové verze, soubory ke stažení, zdrojové soubory, správcovské informace a CHANGELOG, lze najít zde: » http://pecl.php.net/package/enchant.

Konfigurace běhu

Toto rozšíření nemá definováno žádné konfigurační direktivy.

Typy prostředků

There are two types of resources in this extension. The first one is the broker (backends manager) and the second is for the dictionary.

Příklady

Příklad 472. Enchant Usage Example

<?php
$tag = 'en_US';
$r = enchant_broker_init();
$bprovides = enchant_broker_describe($r);
echo "Current broker provides the following backend(s):\n";
print_r($bprovides);

$dicts = enchant_broker_list_dicts($r);
print_r($dicts);
if (enchant_broker_dict_exists($r,$tag)) {
    $d = enchant_broker_request_dict($r, $tag);
    $dprovides = enchant_dict_describe($d);
    echo "dictionary $tag provides:\n";
    $spellerrors = enchant_dict_check($d, "soong");
    print_r($dprovides);
    echo "found $spellerrors spell errors\n";
    if ($spellerrors) {
        $suggs = enchant_dict_suggest($d, "soong");
        echo "Suggestions for 'soong':";
        print_r($suggs);
    }
    enchant_broker_free_dict($d);
} else {
}
enchant_broker_free($r);
?>

Obsah

enchant_broker_describe — Enumerates the Enchant providers
enchant_broker_dict_exists — Whether a dictionary exists or not. Using non-empty tag
enchant_broker_free_dict — Free a dictionary resource
enchant_broker_free — Free the broker resource and its dictionnaries
enchant_broker_get_error — Returns the last error of the broker
enchant_broker_init — create a new broker object capable of requesting
enchant_broker_list_dicts — Returns a list of available dictionaries
enchant_broker_request_dict — create a new dictionary using a tag
enchant_broker_request_pwl_dict — creates a dictionary using a PWL file. A PWL file is personal word file one word per line.
enchant_broker_set_ordering — Declares a preference of dictionaries to use for the language
enchant_dict_add_to_personal — add a word to personal word list
enchant_dict_add_to_session — add 'word' to this spell-checking session
enchant_dict_check — Check whether a word is correctly spelled or not.
enchant_dict_describe — Describes an individual dictionary
enchant_dict_get_error — Returns the last error of the current spelling-session
enchant_dict_is_in_session — whether or not 'word' exists in this spelling-session
enchant_dict_quick_check — Check the word is correctly spelled and provide suggestions
enchant_dict_store_replacement — add a correction for a word.
enchant_dict_suggest — Will return a list of values if any of those pre-conditions are not met.
Předcházející | Nahoru | Další
xptr_new_context | Domů | enchant_broker_describe


Expect Functions

Předcházející VI. Reference funkcí Další

XXXVI. Expect Functions

Úvod

This extension allows to interact with processes through PTY. You may consider using the expect:// wrapper with the filesystem functions which provide a simpler and more intuitive interface.

Požadavky

This module uses the functions of the » expect library. You need libexpect version >= 5.43.0.

Instalace

Toto rozšíření » PECL není přibaleno k PHP. Informace o instalaci tohoto PECL rozšíření lze najít v kapitole manuálu nazvané Instalace rozšíření PECL. Další informace, jako nové verze, soubory ke stažení, zdrojové soubory, správcovské informace a CHANGELOG, lze najít zde: » http://pecl.php.net/package/expect.

V PHP 4 lze zdroje k těmto rozšířením PECL najít v adresáři ext/ ve zdrojích PHP source or nebo přes výše uvedený odkaz na PECL. In order to use these functions you must compile PHP with expect support by using the --with-expect[=DIR] configure option.

Windows users will enable php_expect.dll inside of php.ini in order to use these functions. V PHP 4 je tato DLL knihovna umístěna v adresáři extensions/ v downloadu binárních souborů PHP pro Windows. Tuto DLL knihovnu pro rozšíření PECL můžete stahovat ze stránky » PHP Downloads nebo z » http://snaps.php.net/.

Konfigurace běhu

Chování těchto funkcí je ovlivněno nastavením parametrů v php.ini.

In order to configure expect extension, there are configuration options in the configuration file php.ini.

Tabulka 80. Expect Konfigurační volby

Jméno | Výchozí | Měnitelné | Changelog
expect.timeout | "10" | PHP_INI_ALL |
expect.loguser | "1" | PHP_INI_ALL |
expect.logfile | "" | PHP_INI_ALL |

Pro další detaily a definice konstant PHP_INI_*, viz dokumentace k ini_set().

Zde je stručný popis konfiguračních direktiv.

expect.timeout integer

The timeout period for waiting for the data, when using the expect_expectl() function.

A value of "-1" disables a timeout from occurring.

Poznámka: A value of "0" causes the expect_expectl() function to return immediately.

expect.loguser boolean

Whether expect should send any output from the spawned process to stdout. Since interactive programs typically echo their input, this usually suffices to show both sides of the conversation.

expect.logfile string

Name of the file, where the output from the spawned process will be written. If this file doesn't exist, it will be created.

Poznámka: If this configuration is not empty, the output is written regardless of the value of expect.loguser.

Typy prostředků

expect_popen() returns an open PTY stream used by expect_expectl().

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

EXP_GLOB (integer)
Indicates that the pattern is a glob-style string pattern.
EXP_EXACT (integer)
Indicates that the pattern is an exact string.
EXP_REGEXP (integer)
Indicates that the pattern is a regexp-style string pattern.
EXP_EOF (integer)
Value, returned by expect_expectl(), when EOF is reached.
EXP_TIMEOUT (integer)
Value, returned by expect_expectl() upon timeout of seconds, specified in value of expect.timeout
EXP_FULLBUFFER (integer)
Value, returned by expect_expectl() if no pattern have been matched.

Příklady

This example connects to the remote host via SSH, and prints the remote uptime.

Příklad 493. Expect Usage Example

<?php
ini_set ("expect.loguser", "Off");

$stream = fopen ("expect://ssh root@remotehost uptime", "r");

$cases = array (
  array (0 => "password:", 1 => PASSWORD)
);

switch (expect_expectl ($stream, $cases)) {
 case PASSWORD:
  fwrite ($stream, "password\n");
  break;

 default:
  die ("Error was occurred while connecting to the remote host!\n");
}

while ($line = fgets ($stream)) {
  print $line;
}
fclose ($stream);
?>

The following example connects to the remote host, determines whether installed OS is for 32 or 64 bit, then runs update for specific package.

Příklad 494. Another Expect Usage Example

<?php
ini_set ("expect.timeout", -1);
ini_set ("expect.loguser", "Off");

$stream = expect_popen ("ssh root@remotehost");

while (true) {
    switch (expect_expectl ($stream, array (
            array ("password:", PASSWORD), // SSH is asking for password
            array ("yes/no)?", YESNO), // SSH is asking whether to store the host entry
            array ("~$ ", SHELL, EXP_EXACT), // We've got the shell!
    ))) {
        case PASSWORD:
            fwrite ($stream, "secret\n");
            break;

        case YESNO:
            fwrite ($stream, "yes\n");
            break;

        case SHELL:
            fwrite ($stream, "uname -a\n");
            while (true) {
                    switch (expect_expectl ($stream, array (
                            array ("~$ ", SHELL, EXP_EXACT), // We've got the shell!
                            array ("^Linux.*$", UNAME, EXP_REGEXP), // uname -a output
                    ), $match)) {
                        case UNAME:
                            $uname .= $match[0];
                            break;

                        case SHELL:
                            // Run update:
                            if (strstr ($uname, "x86_64")) {
                                    fwrite ($stream, "rpm -Uhv http://mirrorsite/somepath/some_64bit.rpm\n");
                            } else {
                                    fwrite ($stream, "rpm -Uhv http://mirrorsite/somepath/some_32bit.rpm\n");
                            }
                            fwrite ($stream, "exit\n");
                            break 2;

                        case EXP_TIMEOUT:
                        case EXP_EOF:
                            break 2;

                        default:
                            die ("Error has occurred!\n");
                    }
            }
            break 2;

        case EXP_TIMEOUT:
        case EXP_EOF:
            break 2;

        default:
            die ("Error has occurred!\n");
    }
}

fclose ($stream);
?>

Obsah

expect_expectl — Waits until the output from a process matches one of the patterns, a specified time period has passed, or an EOF is seen
expect_popen — Execute command via Bourne shell, and open the PTY stream to the process
Předcházející | Nahoru | Další
read_exif_data | Domů | expect_expectl


Fileinfo Functions

Předcházející VI. Reference funkcí Další

XXXIX. Fileinfo Functions

Úvod

The functions in this module try to guess the content type and encoding of a file by looking for certain magic byte sequences at specific positions within the file. While this is not a bullet proof approach the heuristics used do a very good job.

Požadavky

magic_open library is needed to build this extension.

Instalace

Informace o instalaci tohoto PECL rozšíření lze najít v kapitole manuálu nazvané Instalace rozšíření PECL. Další informace, jako nové verze, soubory ke stažení, zdrojové soubory, správcovské informace a CHANGELOG, lze najít zde: » http://pecl.php.net/package/fileinfo

Konfigurace běhu

Toto rozšíření nemá definováno žádné konfigurační direktivy.

Typy prostředků

There is one resource used in Fileinfo extension: a magic database descriptor returned by finfo_open().

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

FILEINFO_NONE (integer)
No special handling.
FILEINFO_SYMLINK (integer)
Follow symlinks.
FILEINFO_MIME (integer)
Return a mime string, instead of a textual description.
FILEINFO_COMPRESS (integer)
Decompress compressed files.
FILEINFO_DEVICES (integer)
Look at the contents of blocks or character special devices.
FILEINFO_CONTINUE (integer)
Return all matches, not just the first.
FILEINFO_PRESERVE_ATIME (integer)
If possible preserve the original access time.
FILEINFO_RAW (integer)
Don't translate unprintable characters to a \ooo octal representation.

Obsah

finfo_buffer — Return information about a string buffer
finfo_close — Close fileinfo resource
finfo_file — Return information about a file
finfo_open — Create a new fileinfo resource
finfo_set_flags — Set libmagic configuration options
Předcházející | Nahoru | Další
fdf_set_version | Domů | finfo_buffer


Filter Functions

Předcházející VI. Reference funkcí Další

XLII. Filter Functions

Úvod

This extension serves to validate and filter data coming from some insecure source, such as user input.

The following filters currently exist; be sure to read the Filter Constants section for information that describes the behavior of each constant:

Tabulka 86. Existing filters

ID | Name | Options | Flags | Description
FILTER_VALIDATE_INT | "int" | min_range, max_range | FILTER_FLAG_ALLOW_OCTAL, FILTER_FLAG_ALLOW_HEX | Validates value as integer, optionally from the specified range.
FILTER_VALIDATE_BOOLEAN | "boolean" |  | FILTER_NULL_ON_FAILURE | Returns TRUE for "1", "true", "on" and "yes". Returns FALSE otherwise. If FILTER_NULL_ON_FAILURE is set, FALSE is returned only for "0", "false", "off", "no", and "", and NULL is returned for all non-boolean values.
FILTER_VALIDATE_FLOAT | "float" | decimal | FILTER_FLAG_ALLOW_THOUSAND | Validates value as float.
FILTER_VALIDATE_REGEXP | "validate_regexp" | regexp |  | Validates value against regexp, a Perl-compatible regular expression.
FILTER_VALIDATE_URL | "validate_url" |  | FILTER_FLAG_PATH_REQUIRED, FILTER_FLAG_QUERY_REQUIRED | Validates value as URL, optionally with required components.
FILTER_VALIDATE_EMAIL | "validate_email" |  |  | Validates value as e-mail.
FILTER_VALIDATE_IP | "validate_ip" |  | FILTER_FLAG_IPV4, FILTER_FLAG_IPV6, FILTER_FLAG_NO_PRIV_RANGE, FILTER_FLAG_NO_RES_RANGE | Validates value as IP address, optionally only IPv4 or IPv6 or not from private or reserved ranges.
FILTER_SANITIZE_STRING | "string" |  | FILTER_FLAG_NO_ENCODE_QUOTES, FILTER_FLAG_STRIP_LOW, FILTER_FLAG_STRIP_HIGH, FILTER_FLAG_ENCODE_LOW, FILTER_FLAG_ENCODE_HIGH, FILTER_FLAG_ENCODE_AMP | Strip tags, optionally strip or encode special characters.
FILTER_SANITIZE_STRIPPED | "stripped" |  |  | Alias of "string" filter.
FILTER_SANITIZE_ENCODED | "encoded" |  | FILTER_FLAG_STRIP_LOW, FILTER_FLAG_STRIP_HIGH, FILTER_FLAG_ENCODE_LOW, FILTER_FLAG_ENCODE_HIGH | URL-encode string, optionally strip or encode special characters.
FILTER_SANITIZE_SPECIAL_CHARS | "special_chars" |  | FILTER_FLAG_STRIP_LOW, FILTER_FLAG_STRIP_HIGH, FILTER_FLAG_ENCODE_HIGH | HTML-escape '"<>& and characters with ASCII value less than 32, optionally strip or encode other special characters.
FILTER_UNSAFE_RAW | "unsafe_raw" |  | FILTER_FLAG_STRIP_LOW, FILTER_FLAG_STRIP_HIGH, FILTER_FLAG_ENCODE_LOW, FILTER_FLAG_ENCODE_HIGH, FILTER_FLAG_ENCODE_AMP | Do nothing, optionally strip or encode special characters.
FILTER_SANITIZE_EMAIL | "email" |  |  | Remove all characters except letters, digits and !#$%&'*+-/=?^_`{|}~@.[].
FILTER_SANITIZE_URL | "url" |  |  | Remove all characters except letters, digits and $-_.+!*'(),{}|\\^~[]`<>#%";/?:@&=.
FILTER_SANITIZE_NUMBER_INT | "number_int" |  |  | Remove all characters except digits, plus and minus sign.
FILTER_SANITIZE_NUMBER_FLOAT | "number_float" |  | FILTER_FLAG_ALLOW_FRACTION, FILTER_FLAG_ALLOW_THOUSAND, FILTER_FLAG_ALLOW_SCIENTIFIC | Remove all characters except digits, +- and optionally .,eE.
FILTER_SANITIZE_MAGIC_QUOTES | "magic_quotes" |  |  | Apply addslashes().
FILTER_CALLBACK | "callback" | callback function or method |  | Call user-defined function to filter data.

Požadavky

Tyto funkce jsou k dispozici jako součást standardního modulu, který je vždy dostupný.

Instalace

A short installation note: just type

$ pecl install filter
in your console.

Konfigurace běhu

Chování těchto funkcí je ovlivněno nastavením parametrů v php.ini.

Tabulka 87. Filter Configuration Options

Name | Default | Changeable | Changelog
filter.default | "unsafe_raw" | PHP_INI_PERDIR | PHP_INI_ALL in filter <= 0.9.4. Available since PHP 5.2.0.
filter.default_flags | NULL | PHP_INI_PERDIR | PHP_INI_ALL in filter <= 0.9.4. Available since PHP 5.2.0.

Pro další detaily a definice konstant PHP_INI_*, viz dokumentace k ini_set().

Zde je stručný popis konfiguračních direktiv.

filter.default string

Filter all $_GET, $_POST, $_COOKIE and $_REQUEST data by this filter. Original data can be accessed through filter_input().

Accepts the name of the filter you like to use by default. See the existing filter list for the list of the filter names.

filter.default_flags integer

Default flags

Typy prostředků

Toto rozšíření nemá definován žádný typ prostředku (resource).

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

INPUT_POST (integer)
POST variables.
INPUT_GET (integer)
GET variables.
INPUT_COOKIE (integer)
COOKIE variables.
INPUT_ENV (integer)
ENV variables.
INPUT_SERVER (integer)
SERVER variables.
INPUT_SESSION (integer)
SESSION variables. (not implemented yet)
INPUT_REQUEST (integer)
REQUEST variables. (not implemented yet)
FILTER_FLAG_NONE (integer)
No flags.
FILTER_REQUIRE_SCALAR (integer)
Flag used to require scalar as input
FILTER_REQUIRE_ARRAY (integer)
Require an array as input.
FILTER_FORCE_ARRAY (integer)
Always returns an array.
FILTER_NULL_ON_FAILURE (integer)
Use NULL instead of FALSE on failure.
FILTER_VALIDATE_INT (integer)
ID of "int" filter.
FILTER_VALIDATE_BOOLEAN (integer)
ID of "boolean" filter.
FILTER_VALIDATE_FLOAT (integer)
ID of "float" filter.
FILTER_VALIDATE_REGEXP (integer)
ID of "validate_regexp" filter.
FILTER_VALIDATE_URL (integer)
ID of "validate_url" filter.
FILTER_VALIDATE_EMAIL (integer)
ID of "validate_email" filter.
FILTER_VALIDATE_IP (integer)
ID of "validate_ip" filter.
FILTER_DEFAULT (integer)
ID of default ("string") filter.
FILTER_UNSAFE_RAW (integer)
ID of "unsafe_raw" filter.
FILTER_SANITIZE_STRING (integer)
ID of "string" filter.
FILTER_SANITIZE_STRIPPED (integer)
ID of "stripped" filter.
FILTER_SANITIZE_ENCODED (integer)
ID of "encoded" filter.
FILTER_SANITIZE_SPECIAL_CHARS (integer)
ID of "special_chars" filter.
FILTER_SANITIZE_EMAIL (integer)
ID of "email" filter.
FILTER_SANITIZE_URL (integer)
ID of "url" filter.
FILTER_SANITIZE_NUMBER_INT (integer)
ID of "number_int" filter.
FILTER_SANITIZE_NUMBER_FLOAT (integer)
ID of "number_float" filter.
FILTER_SANITIZE_MAGIC_QUOTES (integer)
ID of "magic_quotes" filter.
FILTER_CALLBACK (integer)
ID of "callback" filter.
FILTER_FLAG_ALLOW_OCTAL (integer)
Allow octal notation (0[0-7]+) in "int" filter.
FILTER_FLAG_ALLOW_HEX (integer)
Allow hex notation (0x[0-9a-fA-F]+) in "int" filter.
FILTER_FLAG_STRIP_LOW (integer)
Strip characters with ASCII value less than 32.
FILTER_FLAG_STRIP_HIGH (integer)
Strip characters with ASCII value greater than 127.
FILTER_FLAG_ENCODE_LOW (integer)
Encode characters with ASCII value less than 32.
FILTER_FLAG_ENCODE_HIGH (integer)
Encode characters with ASCII value greater than 127.
FILTER_FLAG_ENCODE_AMP (integer)
Encode &.
FILTER_FLAG_NO_ENCODE_QUOTES (integer)
Don't encode ' and ".
FILTER_FLAG_EMPTY_STRING_NULL (integer)
(No use for now.)
FILTER_FLAG_ALLOW_FRACTION (integer)
Allow fractional part in "number_float" filter.
FILTER_FLAG_ALLOW_THOUSAND (integer)
Allow thousand separator (,) in "number_float" filter.
FILTER_FLAG_ALLOW_SCIENTIFIC (integer)
Allow scientific notation (e, E) in "number_float" filter.
FILTER_FLAG_SCHEME_REQUIRED (integer)
Require scheme in "validate_url" filter.
FILTER_FLAG_HOST_REQUIRED (integer)
Require host in "validate_url" filter.
FILTER_FLAG_PATH_REQUIRED (integer)
Require path in "validate_url" filter.
FILTER_FLAG_QUERY_REQUIRED (integer)
Require query in "validate_url" filter.
FILTER_FLAG_IPV4 (integer)
Allow only IPv4 address in "validate_ip" filter.
FILTER_FLAG_IPV6 (integer)
Allow only IPv6 address in "validate_ip" filter.
FILTER_FLAG_NO_RES_RANGE (integer)
Deny reserved addresses in "validate_ip" filter.
FILTER_FLAG_NO_PRIV_RANGE (integer)
Deny private addresses in "validate_ip" filter.

Obsah

filter_has_var — Checks if variable of specified type exists
filter_id — Returns the filter ID belonging to a named filter
filter_input_array — Gets multiple variables from outside PHP and optionally filters them
filter_input — Gets variable from outside PHP and optionally filters it
filter_list — Returns a list of all supported filters
filter_var_array — Gets multiple variables and optionally filters them
filter_var — Filters a variable with a specified filter
Předcházející | Nahoru | Další
unlink | Domů | filter_has_var


GeoIP Functions

Předcházející VI. Reference funkcí Další

XLIX. GeoIP Functions

Úvod

The GeoIP extension allows you to find the location of an IP address. City, State, Country, Longitude, Latitude, and other information as all, such as ISP and connection type can be obtained with the help of GeoIP.

Požadavky

This extension requires the GeoIP C library version 1.4.0 or higher to be installed. You can grab the latest version from » http://www.maxmind.com/app/c and compile it yourself.

By default, you will only have access to the Free GeoIP Country or GeoLite City databases. While this module can work with other types of database, you must buy a commercial license from » Maxmind.

Instalace

Toto rozšíření » PECL není přibaleno k PHP.

Informace o instalaci tohoto PECL rozšíření lze najít v kapitole manuálu nazvané Instalace rozšíření PECL. Další informace, jako nové verze, soubory ke stažení, zdrojové soubory, správcovské informace a CHANGELOG, lze najít zde: » http://pecl.php.net/package/geoip.

Typy prostředků

Toto rozšíření nemá definován žádný typ prostředku (resource).

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

GEOIP_COUNTRY_EDITION (integer)
GEOIP_REGION_EDITION_REV0 (integer)
GEOIP_CITY_EDITION_REV0 (integer)
GEOIP_ORG_EDITION (integer)
GEOIP_ISP_EDITION (integer)
GEOIP_CITY_EDITION_REV1 (integer)
GEOIP_REGION_EDITION_REV1 (integer)
GEOIP_PROXY_EDITION (integer)
GEOIP_ASNUM_EDITION (integer)
GEOIP_NETSPEED_EDITION (integer)
GEOIP_DOMAIN_EDITION (integer)

The following constants are for net speed:

GEOIP_UNKNOWN_SPEED (integer)
GEOIP_DIALUP_SPEED (integer)
GEOIP_CABLEDSL_SPEED (integer)
GEOIP_CORPORATE_SPEED (integer)

Obsah

geoip_country_code_by_name — Get the two letter country code
geoip_country_code3_by_name — Get the three letter country code
geoip_country_name_by_name — Get the full country name
geoip_database_info — Get GeoIP Database information
geoip_db_avail — Determine if GeoIP Database is available
geoip_db_filename — Returns the filename of the corresponding GeoIP Database
geoip_db_get_all_info — Returns detailed informations about all GeoIP database types
geoip_id_by_name — Get the Internet connection speed
geoip_isp_by_name — Get the Internet Service Provider (ISP) name
geoip_org_by_name — Get the organization name
geoip_record_by_name — Returns the detailed City information found in the GeoIP Database
geoip_region_by_name — Get the country code and region
Předcházející | Nahoru | Další
unregister_tick_function | Domů | geoip_country_code_by_name


gnupg Funkce

Předcházející VI. Reference funkcí Další

LII. gnupg Funkce

Úvod

This module allows you to interact with » gnupg.

Požadavky

The gnupg extension requires PHP 4.3. To use this extension in an OO style, PHP 5 is required.

This extension requires the » gpgme library

Instalace

The gnupg-extension is not bundled with PHP. It is a » PECL extension and can be located here: » http://pecl.php.net/package/gnupg.

Předdefinované konstanty

GNUPG_SIG_MODE_NORMAL (integer)
GNUPG_SIG_MODE_DETACH (integer)
GNUPG_SIG_MODE_CLEAR (integer)
GNUPG_VALIDITY_UNKNOWN (integer)
GNUPG_VALIDITY_UNDEFINED (integer)
GNUPG_VALIDITY_NEVER (integer)
GNUPG_VALIDITY_MARGINAL (integer)
GNUPG_VALIDITY_FULL (integer)
GNUPG_VALIDITY_ULTIMATE (integer)
GNUPG_PROTOCOL_OpenPGP (integer)
GNUPG_PROTOCOL_CMS (integer)
GNUPG_SIGSUM_VALID (integer)
GNUPG_SIGSUM_GREEN (integer)
GNUPG_SIGSUM_RED (integer)
GNUPG_SIGSUM_KEY_REVOKED (integer)
GNUPG_SIGSUM_KEY_EXPIRED (integer)
GNUPG_SIGSUM_KEY_MISSING (integer)
GNUPG_SIGSUM_SIG_EXPIRED (integer)
GNUPG_SIGSUM_CRL_MISSING (integer)
GNUPG_SIGSUM_CRL_TOO_OLD (integer)
GNUPG_SIGSUM_BAD_POLICY (integer)
GNUPG_SIGSUM_SYS_ERROR (integer)
GNUPG_ERROR_WARNING (integer)
GNUPG_ERROR_EXCEPTION (integer)
GNUPG_ERROR_SILENT (integer)

Poznámky

This extension makes use of the keyring of the current user. This keyring is normally located in ~./.gnupg/. To specify a custom location, store the path to the keyring in the environment variable GNUPGHOME. See putenv for more information how to do this.

Some functions require the specification of a key. This specification can be anything that refers to an unique key (userid, key-id, fingerprint, ...). This documentation uses the fingerprint in all examples.

keylistiterator

    This extension also comes with an Iterator for your keyring.

<?php
// create a new iterator for listing all public keys that matches 'example'
$iterator = new gnupg_keylistiterator("example");
foreach($iterator as $fingerprint => $userid){
echo $fingerprint." -> ".$userid."\n";
}
?>

Příklady

This example will clearsign a given text.

Příklad 671. gnupg clearsign example (procedural)

<?php
// init gnupg
$res = gnupg_init();
// not really needed. Clearsign is default
gnupg_setsignmode($res,GNUPG_SIG_MODE_CLEAR);
// add key with passphrase 'test' for signing
gnupg_addsignkey($res,"8660281B6051D071D94B5B230549F9DC851566DC","test");
// sign
$signed = gnupg_sign($res,"just a test");
echo $signed;
?>

Příklad 672. gnupg clearsign example (OO)

<?php
// new class
$gnupg = new gnupg();
// not really needed. Clearsign is default
$gnupg->setsignmode(gnupg::SIG_MODE_CLEAR);
// add key with passphrase 'test' for signing
$gnupg->addsignkey("8660281B6051D071D94B5B230549F9DC851566DC","test");
// sign
$signed = $gnupg->sign("just a test");
echo $signed;
?>

Obsah

gnupg_adddecryptkey — Add a key for decryption
gnupg_addencryptkey — Add a key for encryption
gnupg_addsignkey — Add a key for signing
gnupg_cleardecryptkeys — Removes all keys which were set for decryption before
gnupg_clearencryptkeys — Removes all keys which were set for encryption before
gnupg_clearsignkeys — Removes all keys which were set for signing before
gnupg_decrypt — Decrypts a given text
gnupg_decryptverify — Decrypts and verifies a given text
gnupg_encrypt — Encrypts a given text
gnupg_encryptsign — Encrypts and signs a given text
gnupg_export — Exports a key
gnupg_geterror — Returns the errortext, if a function fails
gnupg_getprotocol — Returns the currently active protocol for all operations
gnupg_import — Imports a key
gnupg_keyinfo — Returns an array with information about all keys that matches the given pattern
gnupg_setarmor — Toggle armored output
gnupg_seterrormode — Sets the mode for error_reporting
gnupg_setsignmode — Sets the mode for signing
gnupg_sign — Signs a given text
gnupg_verify — Verifies a signed text
Předcházející | Nahoru | Další
gmp_xor | Domů | gnupg_adddecryptkey


Haru PDF Functions

Předcházející VI. Reference funkcí Další

LIV. Haru PDF Functions

Úvod

The PECL/haru extension provides bindings for Haru Free PDF Library - free, cross platform, opensource software library for generating PDF files.

You can find the library here: » http://libharu.sourceforge.net.

Varování

Toto rozšíření je EXPERIMENTÁLNÍ. Chování tohoto rozšíření, názvy funkcí a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může bez ohlášení změnit. Berte to v úvahu a používejte tento modul na vlastní nebezpečí.

Požadavky

You need to install libharu first to be able to use PECL/haru. PECL/haru is tested with libharu 2.0.8, older versions might or might not work for you. PECL/haru also requires PHP 5.1.3 or newer.

Instalace

Informace o instalaci tohoto PECL rozšíření lze najít v kapitole manuálu nazvané Instalace rozšíření PECL. Další informace, jako nové verze, soubory ke stažení, zdrojové soubory, správcovské informace a CHANGELOG, lze najít zde: » http://pecl.php.net/package/haru.

The latest PECL/haru Win32 DLL can be downloaded here: » php_haru.dll.

Konfigurace běhu

Toto rozšíření nemá definováno žádné konfigurační direktivy.

Příklady

Příklad 715. Basic PECL/haru example

<?php

$doc = new HaruDoc;

$doc->setPageMode(HaruDoc::PAGE_MODE_USE_THUMBS); /* show thumbnails */

$page = $doc->addPage(); /* add page to the document */
$page->setSize(HaruPage::SIZE_A4, HaruPage::LANDSCAPE); /* set the page to use A4 landscape format */

$courier = $doc->getFont("Courier-Bold"); /* we'll use the bundled font a few lines below */

$page->setRGBStroke(0, 0, 0); /* set colors */
$page->setRGBFill(0.7, 0.8, 0.9);
$page->rectangle(150, 150, 550, 250); /* draw a rectangle */

$page->fillStroke(); /* fill and stroke it */

$page->setDash(array(3, 3), 0); /* set dash style for lines at this page */
$page->setFontAndSize($courier, 60); /* set font and size */

$page->setRGBStroke(0.5, 0.5, 0.1); /* set line color */
$page->setRGBFill(1, 1, 1); /* set filling color */

$page->setTextRenderingMode(HaruPage::FILL_THEN_STROKE); /* fill and stroke text */

/* print the text */
$page->beginText();
$page->textOut(210, 270, "Hello World!");
$page->endText();

$doc->save("/tmp/test.pdf"); /* save the document into a file */

?>

Open the result document in your favourite PDF viewer and you should see a light-blue rectangle and white "Hello World!" on it.

Předdefinované třídy

HaruException
HaruDoc
HaruPage
HaruFont
HaruImage
HaruEncoder
HaruOutline
HaruAnnotation
HaruDestination

Builtin Fonts And Encodings

Builtin Fonts

These Base14 fonts are built-in into PDF and all viewers can display them. Using these fonts may decrease the size of the result file and make the processing faster, avoiding loading external fonts. However the fonts support only latin1 character set and you have to load external fonts if you need to use an other character set.

The Base14 fonts:

  • Courier

  • Courier-Bold

  • Courier-Oblique

  • Courier-BoldOblique

  • Helvetica

  • Helvetica-Bold

  • Helvetica-Oblique

  • Helvetica-BoldOblique

  • Times-Roman

  • Times-Bold

  • Times-Italic

  • Times-BoldItalic

  • Symbol

  • ZapfDingbats

Builtin Encodings

Tabulka 95. Single-byte character set encodings

Name | Description
StandardEncoding | The default encoding of PDF.
MacRomanEncoding | The standard encoding of Mac OS.
WinAnsiEncoding | The standard encoding of Windows.
FontSpecific | The font built-in encoding.
ISO8859-2 | Latin2 (East European)
ISO8859-3 | Latin3 (South European)
ISO8859-4 | Latin4 (North European)
ISO8859-5 | Cyrillic
ISO8859-6 | Arabic
ISO8859-7 | Greek
ISO8859-8 | Hebrew
ISO8859-9 | Latin5 (Turkish)
ISO8859-10 | Latin6 (Nordic)
ISO8859-11 | Thai
ISO8859-13 | Latin7 (Baltic Rim)
ISO8859-14 | Latin8 (Celtic)
ISO8859-15 | Latin9
ISO8859-16 | Latin10
CP1250 | MS Windows Codepage 1250.
CP1251 | MS Windows Codepage 1251.
CP1252 | MS Windows Codepage 1252.
CP1253 | MS Windows Codepage 1253.
CP1254 | MS Windows Codepage 1254.
CP1255 | MS Windows Codepage 1255.
CP1256 | MS Windows Codepage 1256.
CP1257 | MS Windows Codepage 1257.
CP1258 | MS Windows Codepage 1258.
KOI8-R | Cyrillic character set.

Tabulka 96. Multi-byte character set encodings

Name | Description
GB-EUC-H | EUC-CN encoding.
GB-EUC-V | Vertical writing version of GB-EUC-H.
GBK-EUC-H | Microsoft Code Page 936 (lfCharSet 0x86) GBK encoding.
GBK-EUC-V | Vertical writing version of GBK-EUC-H.
ETen-B5-H | Microsoft Code Page 950 (lfCharSet 0x88) Big Five character set with ETen extensions.
ETen-B5-V | Vertical writing version of ETen-B5-H.
90ms-RKSJ-H | Microsoft Code Page 932, JIS X 0208 character.
90ms-RKSJ-V | Vertical writing version of 90ms-RKSJ-V.
90msp-RKSJ-H | Microsoft Code Page 932, JIS X 0208 character (proportional).
EUC-H | JIS X 0208 character set, EUC-JP encoding.
EUC-V | Vertical writing version of EUC-H.
KSC-EUC-H | KS X 1001:1992 character set, EUC-KR encoding.
KSC-EUC-V | Vertical writing version of KSC-EUC-V.
KSCms-UHC-H | Microsoft Code Page 949 (lfCharSet 0x81), KS X 1001:1992 character set plus 8822 additional hangul, Unified Hangul Code (UHC) encoding (proportional).
KSCms-UHC-HW-H | Microsoft Code Page 949 (lfCharSet 0x81), KS X 1001:1992 character set plus 8822 additional hangul, Unified Hangul Code (UHC) encoding (fixed width).
KSCms-UHC-HW-V | Vertical writing version of KSCms-UHC-HW-H.

Obsah

HaruException — Haru PDF Exception Class
HaruDoc — Haru PDF Document Class
HaruPage — Haru PDF Page Class
HaruFont — Haru PDF Font Class
HaruImage — Haru PDF Image Class
HaruEncoder — Haru PDF Encoder Class
HaruOutline — Haru PDF Outline Class
HaruAnnotation — Haru PDF Annotation Class
HaruDestination — Haru PDF Destination Class
HaruAnnotation::setBorderStyle — Set the border style of the annotation
HaruAnnotation::setHighlightMode — Set the highlighting mode of the annotation
HaruAnnotation::setIcon — Set the icon style of the annotation
HaruAnnotation::setOpened — Set the initial state of the annotation
HaruDestination::setFit — Set the appearance of the page to fit the window
HaruDestination::setFitB — Set the appearance of the page to fit the bounding box of the page within the window
HaruDestination::setFitBH — Set the appearance of the page to fit the width of the bounding box
HaruDestination::setFitBV — Set the appearance of the page to fit the height of the boudning box
HaruDestination::setFitH — Set the appearance of the page to fit the window width
HaruDestination::setFitR — Set the appearance of the page to fit the specified rectangle
HaruDestination::setFitV — Set the appearance of the page to fit the window height
HaruDestination::setXYZ — Set the appearance of the page
HaruDoc::addPage — Add new page to the document
HaruDoc::addPageLabel — Set the numbering style for the specified range of pages
HaruDoc::__construct — Construct new HaruDoc instance
HaruDoc::createOutline — Create a HaruOutline instance
HaruDoc::getCurrentEncoder — Get HaruEncoder currently used in the document
HaruDoc::getCurrentPage — Return current page of the document
HaruDoc::getEncoder — Get HaruEncoder instance for the specified encoding
HaruDoc::getFont — Get HaruFont instance
HaruDoc::getInfoAttr — Get current value of the specified document attribute
HaruDoc::getPageLayout — Get current page layout
HaruDoc::getPageMode — Get current page mode
HaruDoc::getStreamSize — Get the size of the temporary stream
HaruDoc::insertPage — Insert new page just before the specified page
HaruDoc::loadJPEG — Load JPEG image and return new HaruImage instance
HaruDoc::loadPNG — Load PNG image and return HaruImage instance
HaruDoc::loadRaw — Load RAW image and return HaruImage instance
HaruDoc::loadTTC — Load the font with the specified index from TTC file
HaruDoc::loadTTF — Load TTF font file
HaruDoc::loadType1 — Load Type1 font
HaruDoc::output — Write the document data to the output buffer
HaruDoc::readFromStream — Read data from the temporary stream
HaruDoc::resetError — Reset error state of the document handle
HaruDoc::resetStream — Rewind the temporary stream
HaruDoc::save — Save the document into the specified file
HaruDoc::saveToStream — Save the document into a temporary stream
HaruDoc::setCompressionMode — Set compression mode for the document
HaruDoc::setCurrentEncoder — Set the current encoder for the document
HaruDoc::setEncryptionMode — Set encryption mode for the document
HaruDoc::setInfoAttr — Set the info attribute of the document
HaruDoc::setInfoDateAttr — Set the datetime info attributes of the document
HaruDoc::setOpenAction — Define which page is shown when the document is opened
HaruDoc::setPageLayout — Set how pages should be displayed
HaruDoc::setPageMode — Set how the document should be displayed
HaruDoc::setPagesConfiguration — Set the number of pages per set of pages
HaruDoc::setPassword — Set owner and user passwords for the document
HaruDoc::setPermission — Set permissions for the document
HaruDoc::useCNSEncodings — Enable Chinese simplified encodings
HaruDoc::useCNSFonts — Enable builtin Chinese simplified fonts
HaruDoc::useCNTEncodings — Enable Chinese traditional encodings
HaruDoc::useCNTFonts — Enable builtin Chinese traditional fonts
HaruDoc::useJPEncodings — Enable Japanese encodings
HaruDoc::useJPFonts — Enable builtin Japanese fonts
HaruDoc::useKREncodings — Enable Korean encodings
HaruDoc::useKRFonts — Enable builtin Korean fonts
HaruEncoder::getByteType — Get the type of the byte in the text
HaruEncoder::getType — Get the type of the encoder
HaruEncoder::getUnicode — Convert the specified character to unicode
HaruEncoder::getWritingMode — Get the writing mode of the encoder
HaruFont::getAscent — Get the vertical ascent of the font
HaruFont::getCapHeight — Get the distance from the baseline of uppercase letters
HaruFont::getDescent — Get the vertical descent of the font
HaruFont::getEncodingName — Get the name of the encoding
HaruFont::getFontName — Get the name of the font
HaruFont::getTextWidth — Get the total width of the text, number of characters, number of words and number of spaces
HaruFont::getUnicodeWidth — Get the width of the character in the font
HaruFont::getXHeight — Get the distance from the baseline of lowercase letters
HaruFont::measureText — Calculate the number of characters which can be included within the specified width
HaruImage::getBitsPerComponent — Get the number of bits used to describe each color component of the image
HaruImage::getColorSpace — Get the name of the color space
HaruImage::getHeight — Get the height of the image
HaruImage::getSize — Get size of the image
HaruImage::getWidth — Get the width of the image
HaruImage::setColorMask — Set the color mask of the image
HaruImage::setMaskImage — Set the image mask
HaruOutline::setDestination — Set the destination for the outline
HaruOutline::setOpened — Set the initial state of the outline
HaruPage::arc — Append an arc to the current path
HaruPage::beginText — Begin a text object and set the current text position to (0,0)
HaruPage::circle — Append a circle to the current path
HaruPage::closePath — Append a straight line from the current point to the start point of the path
HaruPage::concat — Concatenate current transformation matrix of the page and the specified matrix
HaruPage::createDestination — Create new HaruDestination instance
HaruPage::createLinkAnnotation — Create new HaruAnnotation instance
HaruPage::createTextAnnotation — Create new HaruAnnotation instance
HaruPage::createURLAnnotation — Create and return new HaruAnnotation instance
HaruPage::curveTo2 — Append a Bezier curve to the current path
HaruPage::curveTo3 — Append a Bezier curve to the current path
HaruPage::curveTo — Append a Bezier curve to the current path
HaruPage::drawImage — Show image at the page
HaruPage::ellipse — Append an ellipse to the current path
HaruPage::endPath — End current path object without filling and painting operations
HaruPage::endText — End current text object
HaruPage::eofill — Fill current path using even-odd rule
HaruPage::eoFillStroke — Fill current path using even-odd rule, then paint the path
HaruPage::fill — Fill current path using nonzero winding number rule
HaruPage::fillStroke — Fill current path using nonzero winding number rule, then paint the path
HaruPage::getCharSpace — Get the current value of character spacing
HaruPage::getCMYKFill — Get the current filling color
HaruPage::getCMYKStroke — Get the current stroking color
HaruPage::getCurrentFont — Get the currently used font
HaruPage::getCurrentFontSize — Get the current font size
HaruPage::getCurrentPos — Get the current position for path painting
HaruPage::getCurrentTextPos — Get the current position for text printing
HaruPage::getDash — Get the current dash pattern
HaruPage::getFillingColorSpace — Get the current filling color space
HaruPage::getFlatness — Get the flatness of the page
HaruPage::getGMode — Get the current graphics mode
HaruPage::getGrayFill — Get the current filling color
HaruPage::getGrayStroke — Get the current stroking color
HaruPage::getHeight — Get the height of the page
HaruPage::getHorizontalScaling — Get the current value of horizontal scaling
HaruPage::getLineCap — Get the current line cap style
HaruPage::getLineJoin — Get the current line join style
HaruPage::getLineWidth — Get the current line width
HaruPage::getMiterLimit — Get the value of miter limit
HaruPage::getRGBFill — Get the current filling color
HaruPage::getRGBStroke — Get the current stroking color
HaruPage::getStrokingColorSpace — Get the current stroking color space
HaruPage::getTextLeading — Get the current value of line spacing
HaruPage::getTextMatrix — Get the current text transformation matrix of the page
HaruPage::getTextRenderingMode — Get the current text rendering mode
HaruPage::getTextRise — Get the current value of text rising
HaruPage::getTextWidth — Get the width of the text using current fontsize, character spacing and word spacing
HaruPage::getTransMatrix — Get the current transformation matrix of the page
HaruPage::getWidth — Get the width of the page
HaruPage::getWordSpace — Get the current value of word spacing
HaruPage::lineTo — Draw a line from the current point to the specified point
HaruPage::measureText — Calculate the number of characters which can be included within the specified width
HaruPage::moveTextPos — Move text position to the specified offset
HaruPage::moveTo — Set starting point for new drawing path
HaruPage::moveToNextLine — Move text position to the start of the next line
HaruPage::rectangle — Append a rectangle to the current path
HaruPage::setCharSpace — Set character spacing for the page
HaruPage::setCMYKFill — Set filling color for the page
HaruPage::setCMYKStroke — Set stroking color for the page
HaruPage::setDash — Set the dash pattern for the page
HaruPage::setFlatness — Set flatness for the page
HaruPage::setFontAndSize — Set font and fontsize for the page
HaruPage::setGrayFill — Set filling color for the page
HaruPage::setGrayStroke — Sets stroking color for the page
HaruPage::setHeight — Set height of the page
HaruPage::setHorizontalScaling — Set horizontal scaling for the page
HaruPage::setLineCap — Set the shape to be used at the ends of lines
HaruPage::setLineJoin — Set line join style for the page
HaruPage::setLineWidth — Set line width for the page
HaruPage::setMiterLimit — Set the current value of the miter limit of the page
HaruPage::setRGBFill — Set filling color for the page
HaruPage::setRGBStroke — Set stroking color for the page
HaruPage::setRotate — Set rotation angle of the page
HaruPage::setSize — Set size and direction of the page
HaruPage::setSlideShow — Set transition style for the page
HaruPage::setTextLeading — Set text leading (line spacing) for the page
HaruPage::setTextMatrix — Set the current text transformation matrix of the page
HaruPage::setTextRenderingMode — Set text rendering mode for the page
HaruPage::setTextRise — Set the current value of text rising
HaruPage::setWidth — Set width of the page
HaruPage::setWordSpace — Set word spacing for the page
HaruPage::showText — Print text at the current position of the page
HaruPage::showTextNextLine — Move the current position to the start of the next line and print the text
HaruPage::stroke — Paint current path
HaruPage::textOut — Print the text on the specified position
HaruPage::textRect — Print the text inside the specified region
Předcházející | Nahoru | Další
gopher_parsedir | Domů | HaruException


hash Functions

Předcházející VI. Reference funkcí Další

LV. hash Functions

Úvod

Message Digest (hash) engine. Allows direct or incremental processing of arbitrary length messages using a variety of hashing algorithms.

Požadavky

The Hash extension requires no external libraries and is enabled by default as of PHP 5.1.2. It may be explicitly disabled by using the --disable-hash switch to configure. Earlier versions of PHP may incorporate the Hash extension by installing the » PECL module.

Typy prostředků

This extension defines a Hashing Context resource returned by hash_init().

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

HASH_HMAC (integer)
Optional flag for hash_init(). Indicates that the HMAC digest-keying algorithm should be applied to the current hashing context.

Obsah

hash_algos — Return a list of registered hashing algorithms
hash_file — Generate a hash value using the contents of a given file
hash_final — Finalize an incremental hash and return resulting digest
hash_hmac_file — Generate a keyed hash value using the HMAC method and the contents of a given file
hash_hmac — Generate a keyed hash value using the HMAC method
hash_init — Initialize an incremental hashing context
hash_update_file — Pump data into an active hashing context from a file
hash_update_stream — Pump data into an active hashing context from an open stream
hash_update — Pump data into an active hashing context
hash — Generate a hash value (message digest)
Předcházející | Nahoru | Další
HaruPage::textRect | Domů | hash_algos


i18n Funkce

Předcházející VI. Reference funkcí Další

LIX. i18n Funkce

Úvod

I18n (short for internationalization) are means of adapting an application for different languages and cultures. The scope of i18n support includes support for local date and time, currency, measures, number formatting and strings in different encoding. Native support for i18n and l10n (localization) appeared in PHP6.

Please note that in PHP6, POSIX locales are obsoleted by the set of locales included with the ICU library.

Varování

This extension is still in development and it isn't available to public yet.

Požadavky

The Unicode Extension.

Obsah

locale_get_default — Get the default Locale
locale_set_default — Set the default Locale
Předcházející | Nahoru | Další
hw_api->userlist | Domů | locale_get_default


IBM DB2, Cloudscape and Apache Derby Functions

Předcházející VI. Reference funkcí Další

LXI. IBM DB2, Cloudscape and Apache Derby Functions

Úvod

These functions enable you to access IBM DB2 Universal Database, IBM Cloudscape, and Apache Derby databases using the DB2 Call Level Interface (DB2 CLI).

Požadavky

To connect to IBM DB2 Universal Database for Linux, UNIX, and Windows, or IBM Cloudscape, or Apache Derby, you must install an IBM DB2 Universal Database client on the same computer on which you are running PHP. The extension has been developed and tested with DB2 Version 8.2.

To connect to IBM DB2 Universal Database for z/OS or iSeries, you also require IBM DB2 Connect or the equivalent DRDA gateway software.

Requirements on Linux or Unix

The user invoking the PHP executable or SAPI must specify the DB2 instance before accessing these functions. You can set the name of the DB2 instance in php.ini using the ibm_db2.instance_name configuration option, or you can source the DB2 instance profile before invoking the PHP executable.

If you created a DB2 instance named db2inst1 in /home/db2inst1/, for example, you can add the following line to php.ini:

ibm_db2.instance_name=db2inst1
If you do not set this option in php.ini, you must issue the following command to modify your environment variables to enable access to DB2:

bash$ source /home/db2inst1/sqllib/db2profile
To enable your PHP-enabled Web server to access these functions, you must either set the ibm_db2.instance_name configuration option in php.ini, or source the DB2 instance environment in your Web server start script (typically /etc/init.d/httpd or /etc/init.d/apache).

Instalace

To build the ibm_db2 extension, the DB2 application development header files and libraries must be installed on your system. DB2 does not install these by default, so you may have to return to your DB2 installer and add this option. The header files are included with the DB2 Application Development Client freely available for download from the IBM DB2 Universal Database » support site.

If you add the DB2 application development header files and libraries to a Linux or Unix operating system on which DB2 was already installed, you must issue the command db2iupdt -e to update the symbolic links to the header files and libraries in your DB2 instances.

ibm_db2 is a » PECL extension, so follow the instructions in 7 – „Installation of PECL extensions“ to install the ibm_db2 extension for PHP. Issue the configure command to point to the location of your DB2 header files and libraries as follows:

bash$ ./configure --with-IBM_DB2=/path/to/DB2
The configure command defaults to /opt/IBM/db2/V8.1.

Note for IIS users: If you are using the ibm_db2 driver with Microsoft Internet Information Server (IIS) you may have to do the following:

Install DB2 with extended operating system security.
Add the PHP binary path to the PATH system environment variable (default C:\php\).
Create another system environment variable equal to the path where the PHP.INI file is located (eg: PHPRC = C:\php\).
Add the IUSR_COMPUTERNAME to the DB2USERS group.

Konfigurace běhu

Chování těchto funkcí je ovlivněno nastavením parametrů v php.ini.

Tabulka 115. ibm_db2 Konfigurační volby

Jméno | Výchozí | Měnitelné | Changelog
ibm_db2.binmode | "1" | PHP_INI_ALL |
ibm_db2.i5_allow_commit | "0" | PHP_INI_SYSTEM | Available since ibm_db2 1.4.9.
ibm_db2.i5_dbcs_alloc | "0" | PHP_INI_SYSTEM | Available since ibm_db2 1.5.0.
ibm_db2.instance_name | NULL | PHP_INI_SYSTEM | Available since ibm_db2 1.0.2.

Zde je stručný popis konfiguračních direktiv.

ibm_db2.binmode integer

This option controls the mode used for converting to and from binary data in the PHP application.

  • 1 (DB2_BINARY)

  • 2 (DB2_CONVERT)

  • 3 (DB2_PASSTHRU)

ibm_db2.i5_allow_commit integer

This option controls the commit mode used for i5 schema collections in the PHP application.

  • 0 no commit (see i5_commit for override)

  • 1 allow commit (see i5_commit for override)

ibm_db2.i5_dbcs_alloc integer

This option controls the internal ibm_db2 allocation scheme for large DBCS column buffers.

  • 0 no expanded allocations (see i5_dbcs_alloc for override)

  • 1 use expanded allocations (see i5_dbcs_alloc for override)

ibm_db2.instance_name string

On Linux and UNIX operating systems, this option defines the name of the instance to use for cataloged database connections. If this option is set, its value overrides the DB2INSTANCE environment variable setting.

This option is ignored on Windows operating systems.

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

DB2_BINARY (integer)
Specifies that binary data shall be returned as is. This is the default mode.
DB2_CONVERT (integer)
Specifies that binary data shall be converted to a hexadecimal encoding and returned as an ASCII string.
DB2_PASSTHRU (integer)
Specifies that binary data shall be converted to a NULL value.
DB2_SCROLLABLE (integer)
Specifies a scrollable cursor for a statement resource. This mode enables random access to rows in a result set, but currently is supported only by IBM DB2 Universal Database.
DB2_FORWARD_ONLY (integer)
Specifies a forward-only cursor for a statement resource. This is the default cursor type and is supported on all database servers.
DB2_PARAM_IN (integer)
Specifies the PHP variable should be bound as an IN parameter for a stored procedure.
DB2_PARAM_OUT (integer)
Specifies the PHP variable should be bound as an OUT parameter for a stored procedure.
DB2_PARAM_INOUT (integer)
Specifies the PHP variable should be bound as an INOUT parameter for a stored procedure.
DB2_PARAM_FILE (integer)
Specifies that the column should be bound directly to a file for input.
DB2_AUTOCOMMIT_ON (integer)
Specifies that autocommit should be turned on.
DB2_AUTOCOMMIT_OFF (integer)
Specifies that autocommit should be turned off.
DB2_DOUBLE (integer)
Specifies that the variable should be bound as a DOUBLE, FLOAT, or REAL data type.
DB2_LONG (integer)
Specifies that the variable should be bound as a SMALLINT, INTEGER, or BIGINT data type.
DB2_CHAR (integer)
Specifies that the variable should be bound as a CHAR or VARCHAR data type.
DB2_CASE_NATURAL (integer)
Specifies that column names will be returned in their natural case.
DB2_CASE_LOWER (integer)
Specifies that column names will be returned in lower case.
DB2_CASE_UPPER (integer)
Specifies that column names will be returned in upper case.
DB2_DEFERRED_PREPARE_ON (integer)
Specifies that deferred prepare should be turned on for the specified statement resource.
DB2_DEFERRED_PREPARE_OFF (integer)
Specifies that deferred prepare should be turned off for the specified statement resource.

Typy prostředků

The ibm_db2 extension returns connection resources, statement resources, and result set resources.

Obsah

db2_autocommit — Returns or sets the AUTOCOMMIT state for a database connection
db2_bind_param — Binds a PHP variable to an SQL statement parameter
db2_client_info — Returns an object with properties that describe the DB2 database client
db2_close — Closes a database connection
db2_column_privileges — Returns a result set listing the columns and associated privileges for a table
db2_columns — Returns a result set listing the columns and associated metadata for a table
db2_commit — Commits a transaction
db2_conn_error — Returns a string containing the SQLSTATE returned by the last connection attempt
db2_conn_errormsg — Returns the last connection error message and SQLCODE value
db2_connect — Returns a connection to a database
db2_cursor_type — Returns the cursor type used by a statement resource
db2_escape_string — Used to escape certain characters.
db2_exec — Executes an SQL statement directly
db2_execute — Executes a prepared SQL statement
db2_fetch_array — Returns an array, indexed by column position, representing a row in a result set
db2_fetch_assoc — Returns an array, indexed by column name, representing a row in a result set
db2_fetch_both — Returns an array, indexed by both column name and position, representing a row in a result set
db2_fetch_object — Returns an object with properties representing columns in the fetched row
db2_fetch_row — Sets the result set pointer to the next row or requested row
db2_field_display_size — Returns the maximum number of bytes required to display a column
db2_field_name — Returns the name of the column in the result set
db2_field_num — Returns the position of the named column in a result set
db2_field_precision — Returns the precision of the indicated column in a result set
db2_field_scale — Returns the scale of the indicated column in a result set
db2_field_type — Returns the data type of the indicated column in a result set
db2_field_width — Returns the width of the current value of the indicated column in a result set
db2_foreign_keys — Returns a result set listing the foreign keys for a table
db2_free_result — Frees resources associated with a result set
db2_free_stmt — Frees resources associated with the indicated statement resource
db2_get_option — Retrieves an option value for a statement resource or a connection resource
db2_lob_read — Gets a user defined size of LOB files with each invocation
db2_next_result — Requests the next result set from a stored procedure
db2_num_fields — Returns the number of fields contained in a result set
db2_num_rows — Returns the number of rows affected by an SQL statement
db2_pconnect — Returns a persistent connection to a database
db2_prepare — Prepares an SQL statement to be executed
db2_primary_keys — Returns a result set listing primary keys for a table
db2_procedure_columns — Returns a result set listing stored procedure parameters
db2_procedures — Returns a result set listing the stored procedures registered in a database
db2_result — Returns a single column from a row in the result set
db2_rollback — Rolls back a transaction
db2_server_info — Returns an object with properties that describe the DB2 database server
db2_set_option — Set options for connection or statement resources
db2_special_columns — Returns a result set listing the unique row identifier columns for a table
db2_statistics — Returns a result set listing the index and statistics for a table
db2_stmt_error — Returns a string containing the SQLSTATE returned by an SQL statement
db2_stmt_errormsg — Returns a string containing the last SQL statement error message
db2_table_privileges — Returns a result set listing the tables and associated privileges in a database
db2_tables — Returns a result set listing the tables and associated metadata in a database
Předcházející | Nahoru | Další
PDO_IBM DSN | Domů | db2_autocommit


IIS Administration Functions

Předcházející VI. Reference funkcí Další

LXIV. IIS Administration Functions

Úvod

Toto rozšíření » PECL není přibaleno k PHP. This extension is available for Win32 only. It provides functions to administrate Microsoft Internet Information Server (IIS). The extension includes function to create web sites and virtual directories as well as configuring security and script mapping. These functions have been added in PHP 4.

In order to use these functions you must enable the php_iisfunc.dll DLL inside of php.ini. Tuto DLL knihovnu pro rozšíření PECL můžete stahovat ze stránky » PHP Downloads nebo z » http://snaps.php.net/.

Požadavky

Tyto funkce jsou k dispozici jako součást standardního modulu, který je vždy dostupný.

Instalace

K používání těchto funkcí není třeba žádná instalace, jsou součástí jádra PHP.

Konfigurace běhu

Toto rozšíření nemá definováno žádné konfigurační direktivy.

Typy prostředků

Toto rozšíření nemá definován žádný typ prostředku (resource).

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

IIS_READ (integer)
IIS_WRITE (integer)
IIS_EXECUTE (integer)
IIS_SCRIPT (integer)
IIS_ANONYMOUS (integer)
IIS_BASIC (integer)
IIS_NTLM (integer)
IIS_STARTING (integer)
IIS_STOPPED (integer)
IIS_PAUSED (integer)
IIS_RUNNING (integer)

Obsah

iis_add_server — Creates a new virtual web server
iis_get_dir_security — Gets Directory Security
iis_get_script_map — Gets script mapping on a virtual directory for a specific extension
iis_get_server_by_comment — Return the instance number associated with the Comment
iis_get_server_by_path — Return the instance number associated with the Path
iis_get_server_rights — Gets server rights
iis_get_service_state — Returns the state for the service defined by ServiceId
iis_remove_server — Removes the virtual web server indicated by ServerInstance
iis_set_app_settings — Creates application scope for a virtual directory
iis_set_dir_security — Sets Directory Security
iis_set_script_map — Sets script mapping on a virtual directory
iis_set_server_rights — Sets server rights
iis_start_server — Starts the virtual web server
iis_start_service — Starts the service defined by ServiceId
iis_stop_server — Stops the virtual web server
iis_stop_service — Stops the service defined by ServiceId
Předcházející | Nahoru | Další
id3_set_tag | Domů | iis_add_server


Imagick Image Library

Předcházející VI. Reference funkcí Další

LXVI. Imagick Image Library

Úvod

Varování

Toto rozšíření je EXPERIMENTÁLNÍ. Chování tohoto rozšíření, názvy funkcí a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může bez ohlášení změnit. Berte to v úvahu a používejte tento modul na vlastní nebezpečí.

Imagick is a native php extension to create and modify images using the ImageMagick API.

ImageMagick® is a software suite to create, edit, and compose bitmap images.. It can read, convert and write images in a variety of formats (over 100) including DPX, EXR, GIF, JPEG, JPEG-2000, PDF, PhotoCD, PNG, Postscript, SVG, and TIFF.

Copyright 1999-2007 ImageMagick Studio LLC, a non-profit organization dedicated to making software imaging solutions freely available.

Příklady

Imagick makes image manipulation in PHP extremely easy through an OO interface. Here is a quick example on how to make a thumbnail:

Příklad 879. Creating a thumbnail in Imagick

<?php

header('Content-type: image/jpeg');

$image = new Imagick('image.jpg');

// If 0 is provided as a width or height parameter,
// aspect ratio is maintained
$image->thumbnailImage(100, 0);

echo $image;

?>

Using SPL and other OO features supported in Imagick, it can be simple to resize all files in a directory (useful for batch resizing large digital camera images to be web viewable). Here we use resize, as we might want to retain certain meta-data:

Příklad 880. Make a thumbnail of all JPG files in a directory

<?php

$images = new Imagick(glob('images/*.JPG'));

foreach($images as $image) {

    // Providing 0 forces thumbnailImage to maintain aspect ratio
    $image->thumbnailImage(1024,0);

}

$images->writeImages();

?>

Obsah

Constants — Imagick class constants
Installation — Installing the Imagick extension
Imagick — Imagick Class
Imagick::adaptiveBlurImage — Adds adaptive blur filter to image
Imagick::adaptiveResizeImage — Adaptively resize image with data dependent triangulation
Imagick::adaptiveSharpenImage — Adaptively sharpen the image
Imagick::adaptiveThresholdImage — Selects a threshold for each pixel based on a range of intensity
Imagick::addImage — Adds new image to Imagick object image list
Imagick::addNoiseImage — Adds random noise to the image
Imagick::affineTransformImage — Transforms an image
Imagick::annotateImage — Annotates an image with text
Imagick::appendImages — Append a set of images
Imagick::averageImages — Average a set of images
Imagick::blackThresholdImage — Forces all pixels below the threshold into black
Imagick::blurImage — Adds blur filter to image
Imagick::borderImage — Surrounds the image with a border
Imagick::charcoalImage — Simulates a charcoal drawing
Imagick::chopImage — Removes a region of an image and trims
Imagick::clear — Clears all resources associated to Imagick object
Imagick::clipImage — Clips along the first path from the 8BIM profile
Imagick::clipPathImage — Clips along the named paths from the 8BIM profile
Imagick::clone — Makes an exact copy of the Imagick object
Imagick::coalesceImages — Composites a set of images
Imagick::colorFloodfillImage — Changes the color value of any pixel that matches target
Imagick::colorizeImage — Blends the fill color with the image
Imagick::clutImage — Replaces colors in the image from a color lookup table
Imagick::combineImages — Combines one or more images into a single image
Imagick::commentImage — Adds a comment to your image
Imagick::compareImageChannels — Returns the difference in one or more images
Imagick::compareImageLayers — Returns the maximum bounding region between images
Imagick::compositeImage — Composite one image onto another
Imagick::__construct — The Imagick constructor
Imagick::contrastImage — Change the contrast of the image
Imagick::contrastStretchImage — Enhances the contrast of a color image
Imagick::convolveImage — Applies a custom convolution kernel to the image
Imagick::cropImage — Extracts a region of the image
Imagick::current — Sets image pointer at the correct sequence
Imagick::cycleColormapImage — Displaces an image's colormap
Imagick::deconstructImages — Returns certain pixel differences between images
Imagick::despeckleImage — Reduces the speckle noise in an image
Imagick::destroy — Destroys the Imagick object
Imagick::drawImage — Renders the ImagickDrawing object on the current image
Imagick::edgeImage — Enhance edges within the image
Imagick::embossImage — Returns a grayscale image with a three-dimensional effect
Imagick::enhanceImage — Improves the quality of a noisy image
Imagick::equalizeImage — Equalizes the image histogram
Imagick::evaluateImage — Applies an expression to an image
Imagick::flattenImages — Merges a sequence of images
Imagick::flipImage — Creates a vertical mirror image
Imagick::flopImage — Creates a horizontal mirror image
Imagick::frameImage — Adds a simulated three-dimensional border
Imagick::fxImage — Evaluate expression for each pixel in the image
Imagick::gammaImage — Gamma-corrects an image
Imagick::gaussianBlurImage — Blurs an image
Imagick::getCompressionQuality — Gets the object compression quality
Imagick::getCompression — Gets the object compression type
Imagick::getCopyright — Returns the ImageMagick API copyright as a string constant
Imagick::getFilename — The filename associated with an image sequence
Imagick::getFormat — Returns the format of the Imagick object
Imagick::getHomeURL — Returns the ImageMagick home URL
Imagick::getImageBackgroundColor — Returns the image background color
Imagick::getImageBlob — Returns the image sequence as a blob
Imagick::getImageBluePrimary — Returns the chromaticy blue primary point
Imagick::getImageBorderColor — Returns the image border color
Imagick::getImageChannelDepth — Gets the depth for a particular image channel
Imagick::getImageChannelDistortion — Compares image channels of an image to a reconstructed image
Imagick::getImageChannelExtrema — Gets the extrema for one or more image channels
Imagick::getImageChannelMean — Gets the mean and standard deviation
Imagick::getImageChannelStatistics — Returns statistics for each channel in the image
Imagick::getImageColormapColor — Returns the color of the specified colormap index
Imagick::getImageColorspace — Gets the image colorspace
Imagick::getImageColors — Gets the number of unique colors in the image
Imagick::getImageCompose — Returns the composite operator associated with the image
Imagick::getImageDelay — Gets the image delay
Imagick::getImageDepth — Gets the image depth
Imagick::getImageDispose — Gets the image disposal method
Imagick::getImageDistortion — Compares an image to a reconstructed image
Imagick::getImageExtrema — Gets the extrema for the image
Imagick::getImageFilename — Returns the filename of a particular image in a sequence
Imagick::getImageSize — Returns the image length in bytes
Imagick::getImageLength — Returns the image length in bytes
Imagick::getImageFormat — Returns the format of a particular image in a sequence
Imagick::getImageGamma — Gets the image gamma
Imagick::getImageGeometry — Gets the width and height as an associative array
Imagick::getImageGreenPrimary — Returns the chromaticy green primary point
Imagick::getImageHeight — Returns the image height
Imagick::getImageHistogram — Gets the image histogram
Imagick::getImageIndex — Gets the index of the current active image
Imagick::getIteratorIndex — Gets the index of the current active image
Imagick::getImageInterlaceScheme — Gets the image interlace scheme
Imagick::getImageInterpolateMethod — Returns the interpolation method
Imagick::getImageIterations — Gets the image iterations
Imagick::getImageMatteColor — Returns the image matte color
Imagick::getImageMatte — Return if the image has a matte channel
Imagick::getImagePage — Returns the page geometry
Imagick::getImagePixelColor — Returns the color of the specified pixel
Imagick::getImageProfile — Returns the named image profile
Imagick::getImageProfiles — Returns the image profiles
Imagick::getImageProperty — Returns the named image property
Imagick::getImageProperties — Returns the image properties
Imagick::getImageRedPrimary — Returns the chromaticy red primary point
Imagick::getImageRegion — Extracts a region of the image
Imagick::getImageRenderingIntent — Gets the image rendering intent
Imagick::getImageResolution — Gets the image X and Y resolution
Imagick::getImageScene — Gets the image scene
Imagick::getImageSignature — Generates an SHA-256 message digest
Imagick::getImageTicksPerSecond — Gets the image ticks-per-second
Imagick::getImageTotalInkDensity — Gets the image total ink density
Imagick::getImageType — Gets the potential image type
Imagick::getImageUnits — Gets the image units of resolution
Imagick::getImageVirtualPixelMethod — Returns the virtual pixel method
Imagick::getImageWhitePoint — Returns the chromaticy white point
Imagick::getImageWidth — Returns the image width
Imagick::getImage — Returns a new Imagick object
Imagick::getInterlaceScheme — Gets the object interlace scheme
Imagick::getImageOrientation — Gets the image orientation.
Imagick::getNumberImages — Returns the number of images in the object
Imagick::getOption — Returns a value associated with the specified key
Imagick::getPackageName — Returns the ImageMagick package name
Imagick::getPage — Returns the page geometry
Imagick::getPixelIterator — Returns a MagickPixelIterator
Imagick::getPixelRegionIterator — Get an ImagickPixelIterator for an image section
Imagick::getQuantumDepth — Gets the quantum depth
Imagick::getQuantumRange — Returns the Imagick quantum range
Imagick::getReleaseDate — Returns the ImageMagick release date
Imagick::getResourceLimit — Returns the specified resource limit
Imagick::getResource — Returns the specified resource's memory usage
Imagick::getSamplingFactors — Gets the horizontal and vertical sampling factor
Imagick::getSizeOffset — Returns the size offset
Imagick::getSize — Returns the size associated with the Imagick object
Imagick::getVersion — Returns the ImageMagick API version
Imagick::hasNextImage — Checks if the object has more images
Imagick::hasPreviousImage — Checks if the object has a previous image
Imagick::identifyImage — Identifies an image and fetches attributes
Imagick::implodeImage — Creates a new image as a copy
Imagick::labelImage — Adds a label to an image
Imagick::levelImage — Adjusts the levels of an image
Imagick::linearStretchImage — Stretches with saturation the image intensity
Imagick::magnifyImage — Scales an image proportionally 2x
Imagick::matteFloodfillImage — Changes the transparency value of a color
Imagick::medianFilterImage — Applies a digital filter
Imagick::minifyImage — Scales an image proportionally to half its size
Imagick::modulateImage — Control the brightness, saturation, and hue
Imagick::montageImage — Creates a composite image
Imagick::morphImages — Method morphs a set of images
Imagick::compareImages — Compares an image to a reconstructed image
Imagick::mosaicImages — Forms a mosaic from images
Imagick::motionBlurImage — Simulates motion blur
Imagick::negateImage — Negates the colors in the reference image
Imagick::distortImage — Distorts an image using various distortion methods
Imagick::newImage — Creates a new image
Imagick::setImage — Replaces image in the object
Imagick::setImageOpacity — Sets the image opacity level
Imagick::newPseudoImage — Creates a new image
Imagick::nextImage — Moves to the next image
Imagick::normalizeImage — Enhances the contrast of a color image
Imagick::oilPaintImage — Simulates an oil painting
Imagick::optimizeImageLayers — Removes repeated portions of images to optimize
Imagick::paintOpaqueImage — Change any pixel that matches color
Imagick::paintTransparentImage — Changes any pixel that matches color with the color defined by fill
Imagick::pingImageBlob — Quickly fetch attributes
Imagick::pingImageFile — Get basic image attributes in a lightweight manner
Imagick::pingImage — Fetch basic attributes about the image
Imagick::posterizeImage — Reduces the image to a limited number of color level
Imagick::previousImage — Move to the previous image in the object
Imagick::profileImage — Adds or removes a profile from an image
Imagick::queryFormats — Returns formats supported by Imagick
Imagick::radialBlurImage — Radial blurs an image
Imagick::raiseImage — Creates a simulated 3d button-like effect
Imagick::randomThresholdImage — Creates a high-contrast, two-color image
Imagick::readImageBlob — Reads image from a binary string
Imagick::readImageFile — Reads image from open filehandle
Imagick::readImage — Reads image from filename
Imagick::reduceNoiseImage — Smooths the contours of an image
Imagick::removeImageProfile — Removes the named image profile and returns it
Imagick::removeImage — Removes an image from the image list
Imagick::render — Renders all preceding drawing commands
Imagick::resampleImage — Resample image to desired resolution
Imagick::resizeImage — Scales an image
Imagick::rollImage — Offsets an image
Imagick::rotateImage — Rotates an image
Imagick::sampleImage — Scales an image with pixel sampling
Imagick::scaleImage — Scales the size of an image
Imagick::separateImageChannel — Separates a channel from the image
Imagick::sepiaToneImage — Sepia tones an image
Imagick::setBackgroundColor — Sets the object's default background color
Imagick::setCompressionQuality — Sets the object's default compression quality
Imagick::setCompression — Sets the object's default compression type
Imagick::setFilename — Sets the filename before you read or write the image
Imagick::setFirstIterator — Sets the Imagick iterator to the first image
Imagick::setLastIterator — Sets the Imagick iterator to the last image
Imagick::setFormat — Sets the format of the Imagick object
Imagick::setImageBackgroundColor — Sets the image background color
Imagick::setImageBias — Sets the image bias for any method that convolves an image
Imagick::setImageBluePrimary — Sets the image chromaticity blue primary point
Imagick::setImageBorderColor — Sets the image border color
Imagick::setImageChannelDepth — Sets the depth of a particular image channel
Imagick::setImageColormapColor — Sets the color of the specified colormap index
Imagick::setImageColorspace — Sets the image colorspace
Imagick::setImageCompose — Sets the image composite operator
Imagick::setImageCompression — Sets the image compression
Imagick::setImageDelay — Sets the image delay
Imagick::setImageDepth — Sets the image depth
Imagick::setImageDispose — Sets the image disposal method
Imagick::setImageExtent — Sets the image size
Imagick::setImageFilename — Sets the filename of a particular image
Imagick::setImageFormat — Sets the format of a particular image
Imagick::setImageGamma — Sets the image gamma
Imagick::setImageGreenPrimary — Sets the image chromaticity green primary point
Imagick::setImageIndex — Set the iterator position
Imagick::setIteratorIndex — Set the iterator position
Imagick::setImageInterlaceScheme — Sets the image compression
Imagick::setImageInterpolateMethod — Sets the image interpolate pixel method
Imagick::setImageIterations — Sets the image iterations
Imagick::setImageMatteColor — Sets the image matte color
Imagick::setImageMatte — Sets the image matte channel
Imagick::setImagePage — Sets the page geometry of the image
Imagick::setImageProfile — Adds a named profile to the Imagick object
Imagick::setImageProperty — Sets an image property
Imagick::setImageRedPrimary — Sets the image chromaticity red primary point
Imagick::setImageRenderingIntent — Sets the image rendering intent
Imagick::setImageResolution — Sets the image resolution
Imagick::setImageScene — Sets the image scene
Imagick::setImageTicksPerSecond — Sets the image ticks-per-second
Imagick::setImageType — Sets the image type
Imagick::setImageUnits — Sets the image units of resolution
Imagick::setImageVirtualPixelMethod — Sets the image virtual pixel method
Imagick::setImageWhitePoint — Sets the image chromaticity white point
Imagick::setInterlaceScheme — Sets the image compression
Imagick::setImageOrientation — Sets the image orientation.
Imagick::setOption — Set an option
Imagick::setPage — Sets the page geometry of the Imagick object
Imagick::setResolution — Sets the image resolution
Imagick::setResourceLimit — Sets the limit for a particular resource in megabytes
Imagick::setSamplingFactors — Sets the image sampling factors
Imagick::setSizeOffset — Sets the size and offset of the Imagick object
Imagick::setSize — Sets the size of the Imagick object
Imagick::setType — Sets the image type attribute
Imagick::shadeImage — Creates a 3D effect
Imagick::shadowImage — Simulates an image shadow
Imagick::sharpenImage — Sharpens an image
Imagick::shaveImage — Shaves pixels from the image edges
Imagick::shearImage — Creating a parallelogram
Imagick::sigmoidalContrastImage — Adjusts the contrast of an image
Imagick::sketchImage — Simulates a pencil sketch
Imagick::solarizeImage — Applies a solarizing effect to the image
Imagick::spliceImage — Splices a solid color into the image
Imagick::spreadImage — Randomly displaces each pixel in a block
Imagick::steganoImage — Hides a digital watermark within the image
Imagick::stereoImage — Composites two images
Imagick::stripImage — Strips an image of all profiles and comments
Imagick::swirlImage — Swirls the pixels about the center of the image
Imagick::textureImage — Repeatedly tiles the texture image
Imagick::thresholdImage — Changes the value of individual pixels based on a threshold
Imagick::thumbnailImage — Changes the size of an image
Imagick::tintImage — Applies a color vector to each pixel in the image
Imagick::transverseImage — Creates a horizontal mirror image
Imagick::trimImage — Remove edges from the image
Imagick::uniqueImageColors — Discards all but one of any pixel color
Imagick::unsharpMaskImage — Sharpens an image
Imagick::valid — Checks if the current item is valid
Imagick::vignetteImage — Adds vignette filter to the image
Imagick::waveImage — Adds wave filter to the image
Imagick::whiteThresholdImage — Force all pixels above the threshold into white
Imagick::writeImages — Writes an image or image sequence
Imagick::writeImage — Writes an image to the specified filename
Imagick::displayImage — Displays an image
Imagick::displayImages — Displays an image or image sequence
Imagick::cropThumbnailImage — Creates a crop thumbnail
Imagick::roundCorners — Rounds image corners
Imagick::polaroidImage — Simulates a Polaroid picture
Imagick::queryFonts — Returns the configured fonts
Imagick::queryFontMetrics — Returns an array representing the font metrics
ImagickDraw::affine — Adjusts the current affine transformation matrix
ImagickDraw::annotation — Draws text on the image
ImagickDraw::arc — Draws an arc
ImagickDraw::bezier — Draws a bezier curve
ImagickDraw::circle — Draws a circle
ImagickDraw::clear — Clears the ImagickDraw
ImagickDraw::clone — Makes an exact copy of the specified ImagickDraw object
ImagickDraw::color — Draws color on image
ImagickDraw::comment — Adds a comment
ImagickDraw::composite — Composites an image onto the current image
ImagickDraw::__construct — The ImagickDraw constructor
ImagickDraw::destroy — Frees all associated resources
ImagickDraw::ellipse — Draws an ellipse on the image
ImagickDraw::getClipPath — Obtains the current clipping path ID
ImagickDraw::getClipRule — Returns the current polygon fill rule
ImagickDraw::getClipUnits — Returns the interpretation of clip path units
ImagickDraw::getFillColor — Returns the fill color
ImagickDraw::getFillOpacity — Returns the opacity used when drawing
ImagickDraw::getFillRule — Returns the fill rule
ImagickDraw::getFontFamily — Returns the font family
ImagickDraw::getFontSize — Returns the font pointsize
ImagickDraw::getFontStyle — Returns the font style
ImagickDraw::getFontWeight — Returns the font weight
ImagickDraw::getFont — Returns the font
ImagickDraw::getGravity — Returns the text placement gravity
ImagickDraw::getStrokeAntialias — Returns the current stroke antialias setting
ImagickDraw::getStrokeColor — Returns the color used for stroking object outlines
ImagickDraw::getStrokeDashArray — Returns an array representing the pattern of dashes and gaps used to stroke paths
ImagickDraw::getStrokeDashOffset — Returns the offset into the dash pattern to start the dash
ImagickDraw::getStrokeLineCap — Returns the shape to be used at the end of open subpaths when they are stroked
ImagickDraw::getStrokeLineJoin — Returns the shape to be used at the corners of paths when they are stroked
ImagickDraw::getStrokeMiterLimit — Returns the stroke miter limit
ImagickDraw::getStrokeOpacity — Returns the opacity of stroked object outlines
ImagickDraw::getStrokeWidth — Returns the width of the stroke used to draw object outlines
ImagickDraw::getTextAlignment — Returns the text alignment
ImagickDraw::getTextAntialias — Returns the current text antialias setting
ImagickDraw::getTextDecoration — Returns the text decoration
ImagickDraw::getTextEncoding — Returns the code set used for text annotations
ImagickDraw::getTextUnderColor — Returns the text under color
ImagickDraw::getVectorGraphics — Returns a string containing vector graphics
ImagickDraw::line — Draws a line
ImagickDraw::matte — Paints on the image's opacity channel
ImagickDraw::pathClose — Adds a path element to the current path
ImagickDraw::pathCurveToAbsolute — Draws a cubic Bezier curve
ImagickDraw::pathCurveToQuadraticBezierAbsolute — Draws a quadratic Bezier curve
ImagickDraw::pathCurveToQuadraticBezierRelative — Draws a quadratic Bezier curve
ImagickDraw::pathCurveToQuadraticBezierSmoothAbsolute — Draws a quadratic Bezier curve
ImagickDraw::pathCurveToQuadraticBezierSmoothRelative — Draws a quadratic Bezier curve
ImagickDraw::pathCurveToRelative — Draws a cubic Bezier curve
ImagickDraw::pathCurveToSmoothAbsolute — Draws a cubic Bezier curve
ImagickDraw::pathCurveToSmoothRelative — Draws a cubic Bezier curve
ImagickDraw::pathEllipticArcAbsolute — Draws an elliptical arc
ImagickDraw::pathEllipticArcRelative — Draws an elliptical arc
ImagickDraw::pathFinish — Terminates the current path
ImagickDraw::pathLineToAbsolute — Draws a line path
ImagickDraw::pathLineToHorizontalAbsolute — Draws a horizontal line path
ImagickDraw::pathLineToHorizontalRelative — Draws a horizontal line
ImagickDraw::pathLineToRelative — Draws a line path
ImagickDraw::pathLineToVerticalAbsolute — Draws a vertical line
ImagickDraw::pathLineToVerticalRelative — Draws a vertical line path
ImagickDraw::pathMoveToAbsolute — Starts a new sub-path
ImagickDraw::pathMoveToRelative — Starts a new sub-path
ImagickDraw::pathStart — Declares the start of a path drawing list
ImagickDraw::point — Draws a point
ImagickDraw::polygon — Draws a polygon
ImagickDraw::polyline — Draws a polyline
ImagickDraw::popClipPath — Terminates a clip path definition
ImagickDraw::popDefs — Terminates a definition list
ImagickDraw::pop — Destroys the current ImagickDraw in the stack, and returns to the previously pushed ImagickDraw
ImagickDraw::popPattern — Terminates a pattern definition
ImagickDraw::pushClipPath — Starts a clip path definition
ImagickDraw::pushDefs — Indicates that following commands create named elements for early processing
ImagickDraw::push — Clones the current ImagickDraw and pushes it to the stack
ImagickDraw::pushPattern — Indicates that subsequent commands up to a ImagickDraw::opPattern() command comprise the definition of a named pattern
ImagickDraw::rectangle — Draws a rectangle
ImagickDraw::render — Renders all preceding drawing commands onto the image
ImagickDraw::rotate — Applies the specified rotation to the current coordinate space
ImagickDraw::roundRectangle — Draws a rounted rectangle
ImagickDraw::scale — Adjusts the scaling factor
ImagickDraw::setClipPath — Associates a named clipping path with the image
ImagickDraw::setClipRule — Set the polygon fill rule to be used by the clipping path
ImagickDraw::setClipUnits — Sets the interpretation of clip path units
ImagickDraw::setFillAlpha — Sets the opacity to use when drawing using the fill color or fill texture
ImagickDraw::setFillColor — Sets the fill color to be used for drawing filled objects
ImagickDraw::setFillOpacity — Sets the opacity to use when drawing using the fill color or fill texture
ImagickDraw::setFillPatternURL — Sets the URL to use as a fill pattern for filling objects
ImagickDraw::setFillRule — Sets the fill rule to use while drawing polygons
ImagickDraw::setFontFamily — Sets the font family to use when annotating with text
ImagickDraw::setFontSize — Sets the font pointsize to use when annotating with text
ImagickDraw::setFontStretch — Sets the font stretch to use when annotating with text
ImagickDraw::setFontStyle — Sets the font style to use when annotating with text
ImagickDraw::setFontWeight — Sets the font weight
ImagickDraw::setFont — Sets the fully-specified font to use when annotating with text
ImagickDraw::setGravity — Sets the text placement gravity
ImagickDraw::setStrokeAlpha — Specifies the opacity of stroked object outlines
ImagickDraw::setStrokeAntialias — Controls whether stroked outlines are antialiased
ImagickDraw::setStrokeColor — Sets the color used for stroking object outlines
ImagickDraw::setStrokeDashArray — Specifies the pattern of dashes and gaps used to stroke paths
ImagickDraw::setStrokeDashOffset — Specifies the offset into the dash pattern to start the dash
ImagickDraw::setStrokeLineCap — Specifies the shape to be used at the end of open subpaths when they are stroked
ImagickDraw::setStrokeLineJoin — Specifies the shape to be used at the corners of paths when they are stroked
ImagickDraw::setStrokeMiterLimit — Specifies the miter limit
ImagickDraw::setStrokeOpacity — Specifies the opacity of stroked object outlines
ImagickDraw::setStrokePatternURL — Sets the pattern used for stroking object outlines
ImagickDraw::setStrokeWidth — Sets the width of the stroke used to draw object outlines
ImagickDraw::setTextAlignment — Specifies a text alignment
ImagickDraw::setTextAntialias — Controls whether text is antialiased
ImagickDraw::setTextDecoration — Specifies a decoration
ImagickDraw::setTextEncoding — Specifies specifies the text code set
ImagickDraw::setTextUnderColor — Specifies the color of a background rectangle
ImagickDraw::setVectorGraphics — Sets the vector graphics
ImagickDraw::setViewbox — Sets the overall canvas size
ImagickDraw::skewX — Skews the current coordinate system in the horizontal direction
ImagickDraw::skewY — Skews the current coordinate system in the vertical direction
ImagickDraw::translate — Applies a translation to the current coordinate system
ImagickPixel::clear — Clears resources associated with this object
ImagickPixel::__construct — The ImagickPixel constructor
ImagickPixel::destroy — Deallocates resources associated with this object
ImagickPixel::getColor — Returns the color
ImagickPixel::getColorCount — Returns the color count associated with this color
ImagickPixel::getColorValue — Gets the normalized value of the provided color channel
ImagickPixel::getHSL — Returns the normalized HSL color of the ImagickPixel object
ImagickPixel::isSimilar — Check the distance between this color and another
ImagickPixel::setColorValue — Sets the normalized value of one of the channels
ImagickPixel::setColor — Sets the color
ImagickPixel::setHSL — Sets the normalized HSL color
ImagickPixelIterator::clear — Clear resources associated with a PixelIterator
ImagickPixelIterator::__construct — The ImagickPixelIterator constructor
ImagickPixelIterator::destroy — Deallocates resources associated with a PixelIterator
ImagickPixelIterator::getCurrentIteratorRow — Returns the current row of ImagickPixel objects
ImagickPixelIterator::getIteratorRow — Returns the current pixel iterator row
ImagickPixelIterator::getNextIteratorRow — Returns the next row of the pixel iterator
ImagickPixelIterator::getPreviousIteratorRow — Returns the previous row
ImagickPixelIterator::newPixelIterator — Returns a new pixel iterator
ImagickPixelIterator::newPixelRegionIterator — Returns a new pixel iterator
ImagickPixelIterator::resetIterator — Resets the pixel iterator
ImagickPixelIterator::setIteratorFirstRow — Sets the pixel iterator to the first pixel row
ImagickPixelIterator::setIteratorLastRow — Sets the pixel iterator to the last pixel row
ImagickPixelIterator::setIteratorRow — Set the pixel iterator row
ImagickPixelIterator::syncIterator — Syncs the pixel iterator
Předcházející | Nahoru | Další
png2wbmp | Domů | Constants


JSON Functions

Předcházející VI. Reference funkcí Další

LXXIII. JSON Functions

Úvod

This extension implements the » JavaScript Object Notation (JSON) data-interchange format. The decoding is handled by a parser based on the JSON_checker by Douglas Crockford.

Požadavky

As of PHP 5.2.0, the JSON extension is bundled and compiled into PHP by default.

Informace o instalaci tohoto PECL rozšíření lze najít v kapitole manuálu nazvané Instalace rozšíření PECL. Další informace, jako nové verze, soubory ke stažení, zdrojové soubory, správcovské informace a CHANGELOG, lze najít zde: » http://pecl.php.net/package/json

Obsah

json_decode — Decodes a JSON string
json_encode — Returns the JSON representation of a value
Předcházející | Nahoru | Další
java_last_exception_get | Domů | json_decode


KADM5

Předcházející VI. Reference funkcí Další

LXXIV. KADM5

Úvod

These package allows you to access Kerberos V administration servers. You can create, modify, and delete Kerberos V principals and policies.

More information about Kerberos can be found at » http://web.mit.edu/kerberos/www/.

Documentation for Kerberos and KADM5 can be found at » http://web.mit.edu/kerberos/www/krb5-1.2/krb5-1.2.8/doc/admin_toc.html.

Typy prostředků

This extension defines a KADM5 handle returned by kadm5_init_with_password().

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

Constants for Attribute Flags

The functions kadm5_create_principal(),
kadm5_modify_principal(), and
kadm5_modify_principal() allow to specify
special attributes using a bitfield. The symbols are defined below:

Tabulka 144. Attributes for use by the KDC

constant
KRB5_KDB_DISALLOW_POSTDATED
KRB5_KDB_DISALLOW_FORWARDABLE
KRB5_KDB_DISALLOW_TGT_BASED
KRB5_KDB_DISALLOW_RENEWABLE
KRB5_KDB_DISALLOW_PROXIABLE
KRB5_KDB_DISALLOW_DUP_SKEY
KRB5_KDB_DISALLOW_ALL_TIX
KRB5_KDB_REQUIRES_PRE_AUTH
KRB5_KDB_REQUIRES_HW_AUTH
KRB5_KDB_REQUIRES_PWCHANGE
KRB5_KDB_DISALLOW_SVR
KRB5_KDB_PWCHANGE_SERVER
KRB5_KDB_SUPPORT_DESMD5
KRB5_KDB_NEW_PRINC

Constants for Options

The functions kadm5_create_principal(),
kadm5_modify_principal(), and
kadm5_get_principal() allow to specify or return
principal's options as an associative array. The keys for the associative
array are defined as string constants below:

Tabulka 145. Options for creating/modifying/retrieving principals

constant | funcdef | description
KADM5_PRINCIPAL | long | The expire time of the princial as a Kerberos timestamp.
KADM5_PRINC_EXPIRE_TIME | long | The expire time of the princial as a Kerberos timestamp.
KADM5_LAST_PW_CHANGE | long | The time this principal's password was last changed.
KADM5_PW_EXPIRATION | long | The expire time of the principal's current password, as a Kerberos timestamp.
KADM5_MAX_LIFE | long | The maximum lifetime of any Kerberos ticket issued to this principal.
KADM5_MAX_RLIFE | long | The maximum renewable lifetime of any Kerberos ticket issued to or for this principal.
KADM5_MOD_NAME | string | The name of the Kerberos principal that most recently modified this principal.
KADM5_MOD_TIME | long | The time this principal was last modified, as a Kerberos timestamp.
KADM5_KVNO | long | The version of the principal's current key.
KADM5_POLICY | string | The name of the policy controlling this principal.
KADM5_CLEARPOLICY | long | Standard procedure is to assign the 'default' policy to new principals. KADM5_CLEARPOLICY suppresses this behaviour.
KADM5_LAST_SUCCESS | long | The KDC time of the last successfull AS_REQ.
KADM5_LAST_FAILED | long | The KDC time of the last failed AS_REQ.
KADM5_FAIL_AUTH_COUNT | long | The number of consecutive failed AS_REQs.
KADM5_RANDKEY | long | Generates a random password for the principal. The parameter password will be ignored.
KADM5_ATTRIBUTES | long | A bitfield of attributes for use by the KDC.

Příklady

This simple example shows how to connect, query, print resulting principals and disconnect from a KADM5 database.

Příklad 951. KADM5 extension overview example

<?php

  $handle = kadm5_init_with_password("afs-1", "GONICUS.LOCAL", "admin/admin", "password");

  print "<h1>get_principals</h1>\n";
  $principals = kadm5_get_principals($handle);
  for( $i=0; $i<count($principals); $i++)
      print "$principals[$i]<br>\n";

  print "<h1>get_policies</h1>\n";
  $policies = kadm5_get_policies($handle);
  for( $i=0; $i<count($policies); $i++)
      print "$policies[$i]<br>\n";

  print "<h1>get_principal burbach@GONICUS.LOCAL</h1>\n";

  $options = kadm5_get_principal($handle, "burbach@GONICUS.LOCAL" );
  $keys = array_keys($options);
  for( $i=0; $i<count($keys); $i++) {
    $value = $options[$keys[$i]];
    print "$keys[$i]: $value<br>\n";
  }

  $options = array(KADM5_PRINC_EXPIRE_TIME => 0);
  kadm5_modify_principal($handle, "burbach@GONICUS.LOCAL", $options);

  kadm5_destroy($handle);
?>

Contact Information

If you have comments, bugfixes, enhancements or want to help in developing this you can send me a mail at » holger.burbach@gonicus.de. The project homepage can be found at » http://oss.gonicus.de/project/?group_id=7.

Obsah

kadm5_chpass_principal — Changes the principal's password
kadm5_create_principal — Creates a kerberos principal with the given parameters
kadm5_delete_principal — Deletes a kerberos principal
kadm5_destroy — Closes the connection to the admin server and releases all related resources
kadm5_flush — Flush all changes to the Kerberos database, leaving the connection to the Kerberos admin server open
kadm5_get_policies — Gets all policies from the Kerberos database
kadm5_get_principal — Gets the principal's entries from the Kerberos database
kadm5_get_principals — Gets all principals from the Kerberos database
kadm5_init_with_password — Opens a connection to the KADM5 library and initializes any neccessary state information
kadm5_modify_principal — Modifies a kerberos principal with the given parameters
Předcházející | Nahoru | Další
json_encode | Domů | kadm5_chpass_principal


libxml Functions

Předcházející VI. Reference funkcí Další

LXXVI. libxml Functions

Úvod

These functions/constants are available since PHP 5.1.0 and if you have compiled one of the extensions based on libxml, like DOM, SimpleXML and XSLT.

Požadavky

This extension requires » libxml >= 2.6.0.

Předdefinované třídy

LibXMLError

Vlastnosti

  • code - the error's code

  • column - the column where the error occurred. Please note that this property isn't entirely implemented in libxml and therefore 0 is often returned.

  • file - the filename, or empty if the XML was loaded from a string

  • level - the severity of the error (one of the following constants: LIBXML_ERR_WARNING, LIBXML_ERR_ERROR or LIBXML_ERR_FATAL)

  • line - the line where the error occurred

  • message - the error message

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

LIBXML_COMPACT (integer)

Activate small nodes allocation optimization. This may speed up your application without needing to change the code.

Poznámka: Only available in Libxml >= 2.6.21

LIBXML_DTDATTR (integer)
Default DTD attributes
LIBXML_DTDLOAD (integer)
Load the external subset
LIBXML_DTDVALID (integer)
Validate with the DTD
LIBXML_NOBLANKS (integer)
Remove blank nodes
LIBXML_NOCDATA (integer)
Merge CDATA as text nodes
LIBXML_NOEMPTYTAG (integer)

Expand empty tags (e.g. <br/> to <br></br>)

Poznámka: This option is currently just available in the DOMDocument->save() and DOMDocument->saveXML() functions.

LIBXML_NOENT (integer)
Substitute entities
LIBXML_NOERROR (integer)
Suppress error reports
LIBXML_NONET (integer)
Disable network access when loading documents
LIBXML_NOWARNING (integer)
Suppress warning reports
LIBXML_NOXMLDECL (integer)

Drop the XML declaration when saving a document

Poznámka: Only available in Libxml >= 2.6.21

LIBXML_NSCLEAN (integer)
Remove redundant namespaces declarations
LIBXML_XINCLUDE (integer)
Implement XInclude substitution
LIBXML_ERR_ERROR (integer)
A recoverable error
LIBXML_ERR_FATAL (integer)
A fatal error
LIBXML_ERR_NONE (integer)
No errors
LIBXML_ERR_WARNING (integer)
A simple warning
LIBXML_VERSION (integer)
libxml version like 20605 or 20617
LIBXML_DOTTED_VERSION (string)
libxml version like 2.6.5 or 2.6.17

Obsah

libxml_clear_errors — Clear libxml error buffer
libxml_get_errors — Retrieve array of errors
libxml_get_last_error — Retrieve last error from libxml
libxml_set_streams_context — Set the streams context for the next libxml document load or write
libxml_use_internal_errors — Disable libxml errors and allow user to fetch error information as needed
Předcházející | Nahoru | Další
ldap_unbind | Domů | libxml_clear_errors


MaxDB PHP Extension

Předcházející VI. Reference funkcí Další

LXXXII. MaxDB PHP Extension

Úvod

The MaxDB PHP extension allows you to access the functionality provided by MaxDB 7.5.0 and above. More information about the MaxDB Database server can be found at » http://www.mysql.com/products/maxdb/.

The MaxDB PHP extension is compatible to the MySQL mysqli extension. There are only minor differences in the behaviour of some functions due to the differences of the underlying database servers, MaxDB and MySQL.

The main differences to mysqli are in the following functions:

maxdb_character_set_name() - Returns only ascii or unicode.
maxdb_get_client_info() - Returns a different version string.
maxdb_get_client_version() - Returns a different version string.
maxdb_get_host_info() - Returns localhost or hostname.
maxdb_get_server_info() - Returns a different version string.
maxdb_get_server_version() - Returns a different version string.
maxdb_kill() - Only disconnects the session.
maxdb_multi_query() - Can not handle multiple SQL statements.
maxdb_next_result() - Function returns always false.
maxdb_options() - Supports a different set of options.
maxdb_report() - Supports a different report mode.
maxdb_stat() - Returns a different system status string.
maxdb_stmt_store_result() - Is not necessary for MaxDB.
maxdb_store_result() - Is not necessary for MaxDB.

Documentation for MaxDB can be found at » http://dev.mysql.com/doc/maxdb/.

Požadavky

In order to have these functions available, you must compile PHP with MaxDB support. Additionally, you must have the MaxDB SQLDBC runtime library available to access the MaxDB server.

Documentation for MaxDB SQLDBC can be found at » http://dev.mysql.com/doc/maxdb/.

Download the MaxDB SQLDBC package from » http://dev.mysql.com/downloads/maxdb/clients.html.

Instalace

By using the --with-maxdb[=DIR] configuration option you enable PHP to access MaxDB databases. [DIR] points to the directory that contains the installed MaxDB SQLDBC package.

Windows users will need to enable php_maxdb.dll inside of php.ini.

Konfigurace běhu

Chování těchto funkcí je ovlivněno nastavením parametrů v php.ini.

Tabulka 150. MaxDB Configuration Options

Name | Default | Changeable | Changelog
maxdb.default_host | NULL | PHP_INI_ALL |
maxdb.default_db | NULL | PHP_INI_ALL |
maxdb.default_user | NULL | PHP_INI_ALL |
maxdb.default_pw | NULL | PHP_INI_ALL |
maxdb.long_readlen | "200" | PHP_INI_ALL |

Pro další detaily a definice konstant PHP_INI_*, viz dokumentace k ini_set().

Zde je stručný popis konfiguračních direktiv.

maxdb.default_host string

The default server host to use when connecting to the database server if no other host is specified.

maxdb.default_db string

The default server database to use when connecting if no other database is specified.

maxdb.default_user string

The default user name to use when connecting to the database server if no other name is specified.

maxdb.default_pw string

The default password to use when connecting to the database server if no other password is specified.

maxdb.long_readlen integer

The default maximum length of bytes that is transferred to the client if long data is retrieved from the MaxDB database server.

Předdefinované třídy

maxdb

Represents a connection between PHP and a MaxDB database.

Konstruktory

  • maxdb - construct a new maxdb object

Metody

  • autocommit - turns on or off auto-commiting database modifications

  • change_user - changes the user of the specified database connection

  • character_set_name - returns the default character set for the database connection

  • close - closes a previously opened connection

  • commit - commits the current transaction

  • connect - opens a new connection to MaxDB database server

  • debug - performs debugging operations

  • dump_debug_info - dumps debug information

  • get_client_info - returns client version

  • get_host_info - returns type of connection used

  • get_server_info - returns version of the MaxDB server

  • get_server_version - returns version of the MaxDB server

  • init - initializes maxdb object

  • info - retrieves information about the most recently executed query

  • kill - asks the server to kill a MaxDB thread

  • multi_query - performs multiple queries

  • more_results - check if more results exist from currently executed multi-query

  • next_result - reads next result from currently executed multi-query

  • options - set options

  • ping - pings a server connection or reconnects if there is no connection

  • prepare - prepares a SQL query

  • query - performs a query

  • real_connect - attempts to open a connection to MaxDB database server

  • escape_string - escapes special characters in a string for use in a SQL statement, taking into account the current charset of the connection

  • rollback - rolls back the current transaction

  • select_db - selects the default database

  • ssl_set - sets ssl parameters

  • stat - gets the current system status

  • stmt_init- initializes a statement for use with maxdb_stmt_prepare

  • store_result - transfers a resultset from last query

  • use_result - transfers an unbuffered resultset from last query

  • thread-safe - returns whether thread safety is given or not

Vlastnosti

  • affected_rows - gets the number of affected rows in a previous MaxDB operation

  • client_info - returns the MaxDB client version as a string

  • client_version - returns the MaxDB client version as an integer

  • errno - returns the error code for the most recent function call

  • error - returns the error string for the most recent function call

  • field_count - returns the number of columns for the most recent query

  • host_info - returns a string representing the type of connection used

  • info - retrieves information about the most recently executed query

  • insert_id - returns the auto generated id used in the last query

  • protocol_version - returns the version of the MaxDB protocol used

  • sqlstate - returns a string containing the SQLSTATE error code for the last error

  • thread_id - returns the thread ID for the current connection

  • warning_count - returns the number of warnings generated during execution of the previous SQL statement

maxdb_stmt

Represents a prepared statement.

Metody

  • bind_param - binds variables to a prepared statement

  • bind_result - binds variables to a prepared statement for result storage

  • close - closes a prepared statement

  • data-seek - seeks to an arbitrary row in a statement result set

  • execute - executes a prepared statement

  • fetch - fetches result from a prepared statement into bound variables

  • free_result - frees stored result memory for the given statement handle

  • result_metadata - retrieves a resultset from a prepared statement for metadata information

  • prepare - prepares a SQL query

  • send_long_data - sends data in chunks

  • close_long_data - end sending long data

  • reset - resets a prepared statement

  • store_result - buffers complete resultset from a prepared statement

Vlastnosti

  • affected_rows - returns affected rows from last statement execution

  • errno - returns errorcode for last statement function

  • errno - returns errormessage for last statement function

  • param_count - returns number of parameter for a given prepare statement

  • sqlstate - returns a string containing the SQLSTATE error code for the last statement function

maxdb_result

Represents the result set obtained from a query against the database.

Metody

  • close - closes resultset

  • data_seek - moves internal result pointer

  • fetch_field - gets column information from a resultset

  • fetch_fields - gets information for all columns from a resulset

  • fetch_field_direct - gets column information for specified column

  • fetch_array - fetches a result row as an associative array, a numeric array, or both.

  • fetch_assoc - fetches a result row as an associative array

  • fetch_object - fetches a result row as an object

  • fetch_row - gets a result row as an enumerated array

  • close - frees result memory

  • field_seek - set result pointer to a specified field offset

Vlastnosti

  • current_field - returns offset of current fieldpointer

  • field_count - returns number of fields in resultset

  • lengths - returns an array of columnlengths

  • num_rows - returns number of rows in resultset

Typy prostředků

This extension defines resources.

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

The following constants to use with maxdb_options() are defined. For further description of these constants see » http://dev.mysql.com/doc/maxdb/.

Tabulka 151. MaxDB PHP client constants

Constant | Description
MAXDB_COMPNAME | The component name used to initialise the SQLDBC runtime environment.
MAXDB_APPLICATION | The application to be connected to the database.
MAXDB_APPVERSION | The version of the application.
MAXDB_SQLMODE | The SQL mode.
MAXDB_UNICODE | TRUE, if the connection is an unicode (UCS2) client or FALSE, if not.
MAXDB_TIMEOUT | The maximum allowed time of inactivity after which the connection to the database is closed by the system.
MAXDB_ISOLATIONLEVEL | Specifies whether and how shared locks and exclusive locks are implicitly requested or released.
MAXDB_PACKETCOUNT | The number of different request packets used for the connection.
MAXDB_STATEMENTCACHESIZE | The number of prepared statements to be cached for the connection for re-use.
MAXDB_CURSORPREFIX | The prefix to use for result tables that are automatically named.

The function maxdb_fetch_array() uses a constant for the different types of result arrays. The following constants are defined:

Tabulka 152. MaxDB fetch constants

Constant | Description
MAXDB_ASSOC | Columns are returned into the array having the fieldname as the array index.
MAXDB_ASSOC_UPPER | Columns are returned into the array having the upper case fieldname as the array index.
MAXDB_ASSOC_LOWER | Columns are returned into the array having the lower case fieldname as the array index.
MAXDB_BOTH | Columns are returned into the array having both a numerical index and the fieldname as the array index.
MAXDB_NUM | Columns are returned into the array having a numerical index to the fields. This index starts with 0, the first field in the result.

Příklady

All examples in the MaxDB PHP documentation use the HOTELDB demo database from MaxDB. More about this database can be found at » http://dev.mysql.com/doc/maxdb/en/98/11b83fa6b33c17e10000000a114084/frameset.htm.

To use the examples in the MaxDB PHP documentation, you have to load the tutorial data into your database. Then you have to set maxdb.default_db in php.ini to the database that contains the tutorial data.

This simple example shows how to connect, execute a query, print resulting rows and disconnect from a MaxDB database.

Příklad 1001. MaxDB extension overview example

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (maxdb_connect_errno()) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* Performing SQL query */
$query = "SELECT * FROM hotel.city";
$result = maxdb_query($link, $query) or die("Query failed : " . maxdb_error());

/* Printing results in HTML */
echo "<table>\n";
while ($line = maxdb_fetch_array($result, MAXDB_ASSOC)) {
    echo "  <tr>\n";
    foreach ($line as $col_value) {
        echo "    <td>$col_value</td>\n";
    }
    echo "  </tr>\n";
}
echo "</table>\n";

/* Free resultset */
maxdb_free_result($result);

/* Closing connection */
maxdb_close($link);
?>

The following example shows how to bind variables to a SELECT INTO statement.

Příklad 1002. Example for use of SELECT INTO statements

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (!$link) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

/* Performing SQL query */
$stmt = maxdb_prepare ($link, "SELECT percentage INTO ? FROM hotel.countrylanguage where language = ?");
if (!$stmt) {
  printf ("Prepare failed: %s\n", maxdb_error($link));
}

$name = "Mbundu";

maxdb_stmt_bind_param($stmt, 'ds', $percentage, $name);
maxdb_stmt_execute($stmt);

printf ("%f\n", $percentage);

maxdb_stmt_close ($stmt);
?>

The following example shows how to use MaxDB database procedures.

Příklad 1003. Example fore using database procedures

<?php
$link = maxdb_connect("localhost", "MONA", "RED", "DEMODB");

/* check connection */
if (!$link) {
   printf("Connect failed: %s\n", maxdb_connect_error());
   exit();
}

maxdb_report (MAXDB_REPORT_OFF);
maxdb_query($link,"DROP DBPROC test_proc");
maxdb_report (MAXDB_REPORT_ERROR);

$query = "create dbproc test_proc (INOUT e_text char(72)) AS select * from SYSDBA.DUAL; fetch into :e_text;";

maxdb_query($link, $query);

/* Performing SQL query */
$stmt = maxdb_prepare ($link, "CALL test_proc (?)");
if (!$stmt) {
  printf ("Prepare failed: %s\n", maxdb_error($link));
}

maxdb_stmt_bind_param($stmt, 's', $result);
maxdb_stmt_execute($stmt);

printf ("%s\n", $result);

maxdb_stmt_close ($stmt);
?>

Obsah

maxdb_affected_rows — Gets the number of affected rows in a previous MaxDB operation
maxdb_autocommit — Turns on or off auto-commiting database modifications
maxdb_bind_param — Alias pro maxdb_stmt_bind_param()
maxdb_bind_result — Alias pro maxdb_stmt_bind_result()
maxdb_change_user — Changes the user of the specified database connection
maxdb_character_set_name — Returns the default character set for the database connection
maxdb_client_encoding — Alias pro maxdb_character_set_name()
maxdb_close_long_data — Alias pro maxdb_stmt_close_long_data()
maxdb_close — Closes a previously opened database connection
maxdb_commit — Commits the current transaction
maxdb_connect_errno — Returns the error code from last connect call
maxdb_connect_error — Returns a string description of the last connect error
maxdb_connect — Open a new connection to the MaxDB server
maxdb_data_seek — Adjusts the result pointer to an arbitary row in the result
maxdb_debug — Performs debugging operations
maxdb_disable_reads_from_master — Disable reads from master
maxdb_disable_rpl_parse — Disable RPL parse
maxdb_dump_debug_info — Dump debugging information into the log
maxdb_embedded_connect — Open a connection to an embedded MaxDB server
maxdb_enable_reads_from_master — Enable reads from master
maxdb_enable_rpl_parse — Enable RPL parse
maxdb_errno — Returns the error code for the most recent function call
maxdb_error — Returns a string description of the last error
maxdb_escape_string — Alias pro maxdb_real_escape_string()
maxdb_execute — Alias pro maxdb_stmt_execute()
maxdb_fetch_array — Fetch a result row as an associative, a numeric array, or both
maxdb_fetch_assoc — Fetch a result row as an associative array
maxdb_fetch_field_direct — Fetch meta-data for a single field
maxdb_fetch_field — Returns the next field in the result set
maxdb_fetch_fields — Returns an array of resources representing the fields in a result set
maxdb_fetch_lengths — Returns the lengths of the columns of the current row in the result set
maxdb_fetch_object — Returns the current row of a result set as an object
maxdb_fetch_row — Get a result row as an enumerated array
maxdb_fetch — Alias pro maxdb_stmt_fetch()
maxdb_field_count — Returns the number of columns for the most recent query
maxdb_field_seek — Set result pointer to a specified field offset
maxdb_field_tell — Get current field offset of a result pointer
maxdb_free_result — Frees the memory associated with a result
maxdb_get_client_info — Returns the MaxDB client version as a string
maxdb_get_client_version — Get MaxDB client info
maxdb_get_host_info — Returns a string representing the type of connection used
maxdb_get_metadata — Alias pro maxdb_stmt_result_metadata()
maxdb_get_proto_info — Returns the version of the MaxDB protocol used
maxdb_get_server_info — Returns the version of the MaxDB server
maxdb_get_server_version — Returns the version of the MaxDB server as an integer
maxdb_info — Retrieves information about the most recently executed query
maxdb_init — Initializes MaxDB and returns an resource for use with maxdb_real_connect
maxdb_insert_id — Returns the auto generated id used in the last query
maxdb_kill — Disconnects from a MaxDB server
maxdb_master_query — Enforce execution of a query on the master in a master/slave setup
maxdb_more_results — Check if there any more query results from a multi query
maxdb_multi_query — Performs a query on the database
maxdb_next_result — Prepare next result from multi_query
maxdb_num_fields — Get the number of fields in a result
maxdb_num_rows — Gets the number of rows in a result
maxdb_options — Set options
maxdb_param_count — Alias pro maxdb_stmt_param_count()
maxdb_ping — Pings a server connection, or tries to reconnect if the connection has gone down
maxdb_prepare — Prepare a SQL statement for execution
maxdb_query — Performs a query on the database
maxdb_real_connect — Opens a connection to a MaxDB server
maxdb_real_escape_string — Escapes special characters in a string for use in a SQL statement, taking into account the current charset of the connection
maxdb_real_query — Execute an SQL query
maxdb_report — Enables or disables internal report functions
maxdb_rollback — Rolls back current transaction
maxdb_rpl_parse_enabled — Check if RPL parse is enabled
maxdb_rpl_probe — RPL probe
maxdb_rpl_query_type — Returns RPL query type
maxdb_select_db — Selects the default database for database queries
maxdb_send_long_data — Alias pro maxdb_stmt_send_long_data()
maxdb_send_query — Send the query and return
maxdb_server_end — Shut down the embedded server
maxdb_server_init — Initialize embedded server
maxdb_set_opt — Alias pro maxdb_options()
maxdb_sqlstate — Returns the SQLSTATE error from previous MaxDB operation
maxdb_ssl_set — Used for establishing secure connections using SSL
maxdb_stat — Gets the current system status
maxdb_stmt_affected_rows — Returns the total number of rows changed, deleted, or inserted by the last executed statement
maxdb_stmt_bind_param — Binds variables to a prepared statement as parameters
maxdb_stmt_bind_result — Binds variables to a prepared statement for result storage
maxdb_stmt_close_long_data — Ends a sequence of maxdb_stmt_send_long_data()
maxdb_stmt_close — Closes a prepared statement
maxdb_stmt_data_seek — Seeks to an arbitray row in statement result set
maxdb_stmt_errno — Returns the error code for the most recent statement call
maxdb_stmt_error — Returns a string description for last statement error
maxdb_stmt_execute — Executes a prepared Query
maxdb_stmt_fetch — Fetch results from a prepared statement into the bound variables
maxdb_stmt_free_result — Frees stored result memory for the given statement handle
maxdb_stmt_init — Initializes a statement and returns an resource for use with maxdb_stmt_prepare
maxdb_stmt_num_rows — Return the number of rows in statements result set
maxdb_stmt_param_count — Returns the number of parameter for the given statement
maxdb_stmt_prepare — Prepare a SQL statement for execution
maxdb_stmt_reset — Resets a prepared statement
maxdb_stmt_result_metadata — Returns result set metadata from a prepared statement
maxdb_stmt_send_long_data — Send data in blocks
maxdb_stmt_sqlstate — Returns SQLSTATE error from previous statement operation
maxdb_stmt_store_result — Transfers a result set from a prepared statement
maxdb_store_result — Transfers a result set from the last query
maxdb_thread_id — Returns the thread ID for the current connection
maxdb_thread_safe — Returns whether thread safety is given or not
maxdb_use_result — Initiate a result set retrieval
maxdb_warning_count — Returns the number of warnings from the last query for the given link
Předcházející | Nahoru | Další
tanh | Domů | maxdb_affected_rows


Net_Gopher

Předcházející VI. Reference funkcí Další

LIII. Net_Gopher

Úvod

The gopher protocol, as defined by » RFC 1436, is generally considered the ancestor of the modern HTTP protocol. However, gopher was also intended to provide references to non-gopher resources including telnet, wais, nntp, and even http. This extension adds gopher support to PHP's URL Wrappers, and provides a helper function gopher_parsedir() to make sense of gopher formatted directory listings.

Požadavky

Instalace

Prerequisite: PHP 4.3.0 or higher.

Informace o instalaci tohoto PECL rozšíření lze najít v kapitole manuálu nazvané Instalace rozšíření PECL. Další informace, jako nové verze, soubory ke stažení, zdrojové soubory, správcovské informace a CHANGELOG, lze najít zde: » http://pecl.php.net/package/net_gopher

Konfigurace běhu

Toto rozšíření nemá definováno žádné konfigurační direktivy.

Typy prostředků

Toto rozšíření nemá definován žádný typ prostředku (resource).

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

Tabulka 94. Net_Gopher constants

Constant | Value | Description
GOPHER_DOCUMENT | 0 | Standard text/plain document.
GOPHER_DIRECTORY | 1 | A resource containing a gopher formatted directory listing.
GOPHER_BINHEX | 4 | A BinHex encoded binary file.
GOPHER_DOSBINARY | 5 | A DOS formatted binary archive.
GOPHER_UUENCODED | 6 | A UUEncoded file.
GOPHER_BINARY | 9 | A generic binary file.
GOPHER_INFO | 255 | An Informational entry
GOPHER_HTTP | 254 | A reference to an HTTP resource.
GOPHER_UNKNOWN | -1 | An unrecognized entry.

Příklady

<?php
readfile("gopher://gopher.example.com/somedocument");
?>

Obsah

gopher_parsedir — Translate a gopher formatted directory entry into an associative array.
Předcházející | Nahoru | Další
gnupg_verify | Domů | gopher_parsedir


Newt Functions

Předcházející VI. Reference funkcí Další

CIII. Newt Functions

Úvod

This is a PHP language extension for RedHat Newt library, a terminal-based window and widget library for writing applications with user friendly interface. Once this extension is enabled in PHP it will provide the use of Newt widgets, such as windows, buttons, checkboxes, radiobuttons, labels, editboxes, scrolls, textareas, scales, etc. Use of this extension if very similar to the original Newt API of C programming language.

Požadavky

This module uses the functions of the RedHat Newt library. You need libnewt version >= 0.51.0.

Instalace

Toto rozšíření » PECL není přibaleno k PHP. Informace o instalaci tohoto PECL rozšíření lze najít v kapitole manuálu nazvané Instalace rozšíření PECL. Další informace, jako nové verze, soubory ke stažení, zdrojové soubory, správcovské informace a CHANGELOG, lze najít zde: » http://pecl.php.net/package/newt.

V PHP 4 lze zdroje k těmto rozšířením PECL najít v adresáři ext/ ve zdrojích PHP source or nebo přes výše uvedený odkaz na PECL. In order to use these functions you must compile CGI or CLI PHP with newt support by using the --with-newt[=DIR] configure option.

Poznámka: This extension is not available for Windows platform.

You may need also curses and slang libraries, in order to compile this extension. To specify locations of these libraries, use the following configuration options: --with-curses-dir=/path/to/libcurses --with-slang-dir=/path/to/libslang

Typy prostředků

This extension uses two resource types: "newt component" and "newt grid". Resource type "newt component" is returned by functions, which create common newt widgets (for example: newt_button()) Resource type "newt grid" is a special link identifier for components, returned by newt grid factory functions (for example: newt_create_grid())

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

Newt form exit reasons

Tabulka 198. Newt form exit reasons

constant | meaning
NEWT_EXIT_HOTKEY | hotkey defined by newt_form_add_hot_key() was pressed
NEWT_EXIT_COMPONENT | some component has caused form to exit
NEWT_EXIT_FDREADY | file descriptor specified in newt_form_watch_fd() is ready to be read or written to
NEWT_EXIT_TIMER | time specified in newt_form_set_timer() has elapsed

Newt colorsets

Tabulka 199. Newt colorsets

constant | meaning
NEWT_COLORSET_ROOT |
NEWT_COLORSET_BORDER |
NEWT_COLORSET_WINDOW |
NEWT_COLORSET_SHADOW |
NEWT_COLORSET_TITLE |
NEWT_COLORSET_BUTTON |
NEWT_COLORSET_ACTBUTTON |
NEWT_COLORSET_CHECKBOX |
NEWT_COLORSET_ACTCHECKBOX |
NEWT_COLORSET_ENTRY |
NEWT_COLORSET_LABEL |
NEWT_COLORSET_LISTBOX |
NEWT_COLORSET_ACTLISTBOX |
NEWT_COLORSET_TEXTBOX |
NEWT_COLORSET_ACTTEXTBOX |
NEWT_COLORSET_HELPLINE |
NEWT_COLORSET_ROOTTEXT |
NEWT_COLORSET_ROOTTEXT |
NEWT_COLORSET_EMPTYSCALE |
NEWT_COLORSET_FULLSCALE |
NEWT_COLORSET_DISENTRY |
NEWT_COLORSET_COMPACTBUTTON |
NEWT_COLORSET_ACTSELLISTBOX |
NEWT_COLORSET_SELLISTBOX |

Newt argument flags

Tabulka 200. Newt argument flags

constant | meaning
NEWT_ARG_LAST |
NEWT_ARG_APPEND |

Newt Flags Sense

Tabulka 201. Newt Flags Sense

constant | meaning
NEWT_FLAGS_SET |
NEWT_FLAGS_RESET |
NEWT_FLAGS_TOGGLE |

Newt Components Flags

Tabulka 202. Newt Components Flags

constant | meaning
NEWT_FLAG_RETURNEXIT | Exit form, when component is activated
NEWT_FLAG_HIDDEN | Component is hidden
NEWT_FLAG_SCROLL | Component is scrollable
NEWT_FLAG_DISABLED | Component is disabled
NEWT_FLAG_BORDER |
NEWT_FLAG_WRAP | Wrap text
NEWT_FLAG_NOF12 | Don't exit form on pressing F12
NEWT_FLAG_MULTIPLE |
NEWT_FLAG_SELECTED | Component is selected
NEWT_FLAG_CHECKBOX | Component is checkbox
NEWT_FLAG_PASSWORD | Entry component is password entry
NEWT_FLAG_SHOWCURSOR | Show cursor

File Descriptor Flags

Tabulka 203. File Descriptor Flags

constant | meaning
NEWT_FD_READ |
NEWT_FD_WRITE |
NEWT_FD_EXCEPT |

Checkbox Tree Flags

Tabulka 204. Checkbox Tree Flags

constant | meaning
NEWT_CHECKBOXTREE_UNSELECTABLE |
NEWT_CHECKBOXTREE_HIDE_BOX |
NEWT_CHECKBOXTREE_COLLAPSED |
NEWT_CHECKBOXTREE_EXPANDED |
NEWT_CHECKBOXTREE_UNSELECTED |
NEWT_CHECKBOXTREE_SELECTED |

Entry Flags

Tabulka 205. Entry Flags

constant | meaning
NEWT_ENTRY_SCROLL |
NEWT_ENTRY_HIDDEN |
NEWT_ENTRY_RETURNEXIT |
NEWT_ENTRY_DISABLED |

Listbox Flags

Tabulka 206. Listbox Flags

constant | meaning
NEWT_LISTBOX_RETURNEXIT |

Textbox Flags

Tabulka 207. Textbox Flags

constant | meaning
NEWT_TEXTBOX_WRAP | Wrap text in the textbox
NEWT_TEXTBOX_SCROLL | Scroll text in the textbox

Form Flags

Tabulka 208. Form Flags

constant | meaning
NEWT_FORM_NOF12 | Don't exit form on F12 press

Newt Keys

Tabulka 209. Newt Keys

constant | meaning
NEWT_KEY_TAB |
NEWT_KEY_ENTER |
NEWT_KEY_SUSPEND |
NEWT_KEY_ESCAPE |
NEWT_KEY_RETURN |
NEWT_KEY_EXTRA_BASE |
NEWT_KEY_UP |
NEWT_KEY_DOWN |
NEWT_KEY_LEFT |
NEWT_KEY_RIGHT |
NEWT_KEY_BKSPC |
NEWT_KEY_DELETE |
NEWT_KEY_HOME |
NEWT_KEY_END |
NEWT_KEY_UNTAB |
NEWT_KEY_PGUP |
NEWT_KEY_PGDN |
NEWT_KEY_INSERT |
NEWT_KEY_F1 |
NEWT_KEY_F2 |
NEWT_KEY_F3 |
NEWT_KEY_F4 |
NEWT_KEY_F5 |
NEWT_KEY_F6 |
NEWT_KEY_F7 |
NEWT_KEY_F8 |
NEWT_KEY_F9 |
NEWT_KEY_F10 |
NEWT_KEY_F11 |
NEWT_KEY_F12 |
NEWT_KEY_RESIZE |

Newt Anchors

Tabulka 210. Newt Anchors

constant | meaning
NEWT_ANCHOR_LEFT |
NEWT_ANCHOR_RIGHT |
NEWT_ANCHOR_TOP |
NEWT_ANCHOR_BOTTOM |

Grid Flags

Tabulka 211. Grid Flags

constant | meaning
NEWT_GRID_FLAG_GROWX |
NEWT_GRID_FLAG_GROWY |
NEWT_GRID_EMPTY |
NEWT_GRID_COMPONENT |
NEWT_GRID_SUBGRID |

Příklady

This example is a PHP port of RedHat 'setup' utility dialog, executed in text mode.

Příklad 1419. Newt Usage Example

<?php
    newt_init ();
    newt_cls ();

    newt_draw_root_text (0, 0, "Test Mode Setup Utility 1.12");
    newt_push_help_line (null);
    newt_draw_root_text (-30, 0, "(c) 1999-2002 RedHat, Inc");

    newt_get_screen_size (&$rows, &$cols);

    newt_open_window ($rows/2-17, $cols/2-10, 34, 17, "Choose a Tool");

    $form = newt_form ();

    $list = newt_listbox (3, 2, 10);

    foreach (array (
        "Authentication configuration",
        "Firewall configuration",
        "Mouse configuration",
        "Network configuration",
        "Printer configuration",
        "System services") as $l_item)
    {
        newt_listbox_add_entry ($list, $l_item, $l_item);
    }

    $b1 = newt_button (5, 12, "Run Tool");
    $b2 = newt_button (21, 12, "Quit");

    newt_form_add_component ($form, $list);
    newt_form_add_components ($form, array($b1, $b2));

    newt_refresh ();
    newt_run_form ($form);

    newt_pop_window ();
    newt_pop_help_line ();
    newt_finished ();
    newt_form_destroy ($form);
?>

Obsah

newt_bell — Send a beep to the terminal
newt_button_bar — This function returns a grid containing the buttons created.
newt_button — Create a new button
newt_centered_window — Open a centered window of the specified size
newt_checkbox_get_value — Retreives value of checkox resource
newt_checkbox_set_flags — Configures checkbox resource
newt_checkbox_set_value — Sets the value of the checkbox
newt_checkbox_tree_add_item — Adds new item to the checkbox tree
newt_checkbox_tree_find_item — Finds an item in the checkbox tree
newt_checkbox_tree_get_current — Returns checkbox tree selected item
newt_checkbox_tree_get_entry_value
newt_checkbox_tree_get_multi_selection
newt_checkbox_tree_get_selection
newt_checkbox_tree_multi
newt_checkbox_tree_set_current
newt_checkbox_tree_set_entry_value
newt_checkbox_tree_set_entry
newt_checkbox_tree_set_width
newt_checkbox_tree
newt_checkbox
newt_clear_key_buffer — Discards the contents of the terminal's input buffer without waiting for additional input
newt_cls
newt_compact_button
newt_component_add_callback
newt_component_takes_focus
newt_create_grid
newt_cursor_off
newt_cursor_on
newt_delay
newt_draw_form
newt_draw_root_text — Displays the string text at the position indicated
newt_entry_get_value
newt_entry_set_filter
newt_entry_set_flags
newt_entry_set
newt_entry
newt_finished — Uninitializes newt interface
newt_form_add_component — Adds a single component to the form
newt_form_add_components — Add several components to the form
newt_form_add_hot_key
newt_form_destroy — Destroys a form
newt_form_get_current
newt_form_run — Runs a form
newt_form_set_background
newt_form_set_height
newt_form_set_size
newt_form_set_timer
newt_form_set_width
newt_form_watch_fd
newt_form — Create a form
newt_get_screen_size — Fills in the passed references with the current size of the terminal
newt_grid_add_components_to_form
newt_grid_basic_window
newt_grid_free
newt_grid_get_size
newt_grid_h_close_stacked
newt_grid_h_stacked
newt_grid_place
newt_grid_set_field
newt_grid_simple_window
newt_grid_v_close_stacked
newt_grid_v_stacked
newt_grid_wrapped_window_at
newt_grid_wrapped_window
newt_init — Initialize newt
newt_label_set_text
newt_label
newt_listbox_append_entry
newt_listbox_clear_selection
newt_listbox_clear
newt_listbox_delete_entry
newt_listbox_get_current
newt_listbox_get_selection
newt_listbox_insert_entry
newt_listbox_item_count
newt_listbox_select_item
newt_listbox_set_current_by_key
newt_listbox_set_current
newt_listbox_set_data
newt_listbox_set_entry
newt_listbox_set_width
newt_listbox
newt_listitem_get_data
newt_listitem_set
newt_listitem
newt_open_window — Open a window of the specified size and position
newt_pop_help_line — Replaces the current help line with the one from the stack
newt_pop_window — Removes the top window from the display
newt_push_help_line — Saves the current help line on a stack, and displays the new line
newt_radio_get_current
newt_radiobutton
newt_redraw_help_line
newt_reflow_text
newt_refresh — Updates modified portions of the screen
newt_resize_screen
newt_resume — Resume using the newt interface after calling newt_suspend()
newt_run_form — Runs a form
newt_scale_set
newt_scale
newt_scrollbar_set
newt_set_help_callback
newt_set_suspend_callback — Set a callback function which gets invoked when user presses the suspend key
newt_suspend — Tells newt to return the terminal to its initial state
newt_textbox_get_num_lines
newt_textbox_reflowed
newt_textbox_set_height
newt_textbox_set_text
newt_textbox
newt_vertical_scrollbar
newt_wait_for_key — Doesn't return until a key has been pressed
newt_win_choice
newt_win_entries
newt_win_menu
newt_win_message
newt_win_messagev
newt_win_ternary
Předcházející | Nahoru | Další
syslog | Domů | newt_bell


oggvorbis

Předcházející VI. Reference funkcí Další

CX. oggvorbis

Úvod

The OGG/Vorbis file format, as defined by » http://www.vorbis.com/, is a scheme for compressing audio streams by multiple factors with a minimum of quality loss. This extension adds Ogg Vorbis support to PHP's URL Wrappers. When used in read mode, compressed OGG/Vorbis data is expanded to raw PCM audio in one of six PCM encoding formats listed below.

Požadavky

This extension requires PHP >= 4.3.0, » libogg >= 1.0, and » libvorbis >= 1.0.

Konfigurace běhu

Toto rozšíření nemá definováno žádné konfigurační direktivy.

Instalace

Informace o instalaci tohoto PECL rozšíření lze najít v kapitole manuálu nazvané Instalace rozšíření PECL. Další informace, jako nové verze, soubory ke stažení, zdrojové soubory, správcovské informace a CHANGELOG, lze najít zde: » http://pecl.php.net/package/oggvorbis

Context options

Tabulka 221. OGG/Vorbis tuning options

Option | Definition | Relevance | Default
pcm_mode | PCM byte encoding used. See constants below. | Read / Write | OGGVORBIS_PCM_S16_LE
rate | PCM Sampling rate. Measured in Hz. | Write only | 44100
bitrate | Vorbis Average Bitrate Encoding / Variable Bitrate Encoding. Measured in bps (ABR) or Quality level (VBR: 0.0 to 1.0). 128000 ABR is rough equal to 0.4 VBR. | Write only | 128000
channels | Number of PCM channels. 1 == Mono, 2 == Stereo. | Write only | 2
serialno | Serial Number of stream within file. Must be unique within file. Because of the potential to select a duplicate serial number within a chained file, make efforts to manually assign unique numbers when encoding. | Write only | Random
comments | Associative array of file comments. Will be translated to strtoupper($name) . "=$value". Note: This context option is not available in oggvorbis-0.1 | Write only | array('ENCODER' => 'PHP/OggVorbis, http://pear.php.net/oggvorbis')

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

Tabulka 222. OGG/Vorbis supports PCM encodings in the following formats

Constant | Definition
OGGVORBIS_PCM_U8 | Unsigned 8-bit PCM.
OGGVORBIS_PCM_S8 | Signed 8-bit PCM.
OGGVORBIS_PCM_U16_LE | Unsigned 16-bit PCM. Little Endian byte order.
OGGVORBIS_PCM_U16_BE | Unsigned 16-bit PCM. Big Endian byte order.
OGGVORBIS_PCM_S16_LE | Signed 16-bit PCM. Little Endian byte order.
OGGVORBIS_PCM_S16_BE | Signed 16-bit PCM. Big Endian byte order.

Obsah

Usage — Examples on using the ogg:// wrapper.
Předcházející | Nahoru | Další
PDO_ODBC DSN | Domů | Usage


Paradox File Access

Předcházející VI. Reference funkcí Další

CXVII. Paradox File Access

Úvod

Varování

Toto rozšíření je EXPERIMENTÁLNÍ. Chování tohoto rozšíření, názvy funkcí a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může bez ohlášení změnit. Berte to v úvahu a používejte tento modul na vlastní nebezpečí.

This module allows to read and write Paradox databases, primary index files and blob files. Write support has been proven to be quite reliable, though due to lack of documentation the produced files may not in any case be readable by other applications. Encrypted databases can be read without specifying a password if pxlib >= 0.5.0 is used.

Poznámka: This module is also in development and may change, though I don't expect major changes to the API.

Požadavky

You need at least PHP 5.0.0 and pxlib >= 0.4.4 for the basic set of functions. Some newer functions are only available with pxlib >= 0.6.0. Reading and writing of encrypted databases requires at least pxlib >= 0.5.0. The paradox library (pxlib) is available at » http://pxlib.sourceforge.net.

Instalace

Informace o instalaci tohoto PECL rozšíření lze najít v kapitole manuálu nazvané Instalace rozšíření PECL. Další informace, jako nové verze, soubory ke stažení, zdrojové soubory, správcovské informace a CHANGELOG, lze najít zde: » http://pecl.php.net/package/paradox

Make sure you have pxlib installed before. If you install pxlib from an rpm or debian package, do not forget to install the development package as well.

Konfigurace běhu

Toto rozšíření nemá definováno žádné konfigurační direktivy.

Object oriented API

The paradox extension provides also an object oriented API. It consists of only one class called paradox_db. Its methods only differ from the functions in its name and of course the missing first parameter. The following table will list all methods and its equivalent functions.

Tabulka 227. Methods of class paradox_db

Name of method | Equivalent function
Constructor | px_new()
Destructor | px_delete()
open_fp() | px_open_fp()
create_fp() | px_create_fp()
close() | px_close()
numrecords() | px_numrecords()
numfields() | px_numfields()
get_record() | px_get_record()
put_record() | px_put_record()
retrieve_record() | px_retrieve_record()
delete_record() | px_delete_record()
insert_record() | px_insert_record()
update_record() | px_update_record()
get_field() | px_get_field()
get_schema() | px_get_schema()
get_info() | px_get_info()
set_parameter() | px_set_parameter()
get_parameter() | px_get_parameter()
set_value() | px_set_value()
get_value() | px_get_value()
get_info() | px_get_info()
set_targetencoding() | px_set_targetencoding()
set_tablename() | px_set_tablename()
set_blob_file() | px_set_blob_file()
date2string() | px_date2string()
timestamp2string() | px_timestamp2string()

Typy prostředků

px_new() creates a new Paradox object required by all Paradox functions.

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

The following two tables lists all constants defined by the paradox extension.

Tabulka 228. Contants for field types

Name | Meaning
PX_FIELD_ALPHA | Character data with fixed length
PX_FIELD_DATE | Date, number of days since 1.1.0000
PX_FIELD_SHORT | Short integer (2 Bytes)
PX_FIELD_LONG | Long integer (4 Bytes)
PX_FIELD_CURRENCY | same as PX_FIELD_NUMBER
PX_FIELD_NUMBER | Double
PX_FIELD_LOGICAL | Boolean
PX_FIELD_MEMOBLOB | Binary large object
PX_FIELD_BLOB | Binary large object (not supported)
PX_FIELD_FMTMEMOBLOB | Binary large object
PX_FIELD_OLE | OLE object (basically a blob, not supported)
PX_FIELD_GRAPHIC | Graphic (basically a blob, not supported)
PX_FIELD_TIME | time, number of milli seconds since midnight
PX_FIELD_TIMESTAMP | timestamp, number of milli seconds since 1.1.0000
PX_FIELD_AUTOINC | Auto incrementing interger (like PX_FIELD_LONG)
PX_FIELD_BCD | Decimal number stored in bcd format (not supported)
PX_FIELD_BYTES | Array of Bytes with not more than 255 bytes (not supported)
PX_KEYTOLOWER | Turn all field names into lower case
PX_KEYTOUPPER | Turn all field names into upper case

Tabulka 229. Contants for file types

Name | Meaning
PX_FILE_INDEX_DB | Indexed database
PX_FILE_PRIM_INDEX | Primary index
PX_FILE_NON_INDEX_DB | None indexed database
PX_FILE_NON_INC_SEC_INDEX | None incremental secondary index
PX_FILE_SEC_INDEX | Secondary index
PX_FILE_INC_SEC_INDEX | Incremental secondary index
PX_FILE_NON_INC_SEC_INDEX_G | Non incremental secondary index
PX_FILE_SEC_INDEX_G | Secondary index
PX_FILE_INC_SEC_INDEX_G | Non incremental secondary index

Obsah

px_close — Closes a paradox database
px_create_fp — Create a new paradox database
px_date2string — Converts a date into a string.
px_delete_record — Deletes record from paradox database
px_delete — Deletes resource of paradox database
px_get_field — Returns the specification of a single field
px_get_info — Return lots of information about a paradox file
px_get_parameter — Gets a parameter
px_get_record — Returns record of paradox database
px_get_schema — Returns the database schema
px_get_value — Gets a value
px_insert_record — Inserts record into paradox database
px_new — Create a new paradox object
px_numfields — Returns number of fields in a database
px_numrecords — Returns number of records in a database
px_open_fp — Open paradox database
px_put_record — Stores record into paradox database
px_retrieve_record — Returns record of paradox database
px_set_blob_file — Sets the file where blobs are read from
px_set_parameter — Sets a parameter
px_set_tablename — Sets the name of a table (deprecated)
px_set_targetencoding — Sets the encoding for character fields (deprecated)
px_set_value — Sets a value
px_timestamp2string — Converts the timestamp into a string.
px_update_record — Updates record in paradox database
Předcházející | Nahoru | Další
ovrimos_rollback | Domů | px_close


Microsoft SQL Server and Sybase Functions (PDO_DBLIB)

Předcházející VI. Reference funkcí Další

XCIII. Microsoft SQL Server and Sybase Functions (PDO_DBLIB)

Úvod

Varování

Toto rozšíření je EXPERIMENTÁLNÍ. Chování tohoto rozšíření, názvy funkcí a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může bez ohlášení změnit. Berte to v úvahu a používejte tento modul na vlastní nebezpečí.

PDO_DBLIB is a driver that implements the PHP Data Objects (PDO) interface to enable access from PHP to Microsoft SQL Server and Sybase databases through the FreeTDS libary.

On Windows, you should use the PDO_ODBC driver to connect to Microsoft SQL Server and Sybase databases, as the native Windows DB-LIB is ancient, thread un-safe and no longer supported by Microsoft.

Obsah

PDO_DBLIB DSN — Connecting to Microsoft SQL Server and Sybase databases
Předcházející | Nahoru | Další
mssql_select_db | Domů | PDO_DBLIB DSN


PDO_DBLIB DSN

(No version information available, might be only in CVS)

PDO_DBLIB DSN — Connecting to Microsoft SQL Server and Sybase databases

Popis

The PDO_DBLIB Data Source Name (DSN) is composed of the following elements:

DSN prefix

The DSN prefix is sybase: if PDO_DBLIB was linked against the FreeTDS libraries, mssql: if PDO_DBLIB was linked against the Microsoft SQL Server libraries, or dblib: if linked against any other variety of DB-lib.

host

The hostname on which the database server resides.

dbname

The name of the database.

Příklady

Příklad 1211. PDO_DBLIB DSN examples

The following examples show a PDO_DBLIB DSN for connecting to Microsoft SQL Server and Sybase databases:

mssql:host=localhost;dbname=testdb
sybase:host=localhost;dbname=testdb
dblib:host=localhost;dbname=testdb

Předcházející | Nahoru | Další
XCIII. Microsoft SQL Server and Sybase Functions (PDO_DBLIB) | Domů | XCIV. Mohawk Software Session Handler Functions


Firebird/Interbase Functions (PDO_FIREBIRD)

Předcházející VI. Reference funkcí Další

XLIV. Firebird/Interbase Functions (PDO_FIREBIRD)

Úvod

Varování

Toto rozšíření je EXPERIMENTÁLNÍ. Chování tohoto rozšíření, názvy funkcí a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může bez ohlášení změnit. Berte to v úvahu a používejte tento modul na vlastní nebezpečí.

PDO_FIREBIRD is a driver that implements the PHP Data Objects (PDO) interface to enable access from PHP to Firebird and Interbase databases.

Obsah

PDO_FIREBIRD DSN — Connecting to Firebird and Interbase databases
Předcházející | Nahoru | Další
ibase_wait_event | Domů | PDO_FIREBIRD DSN


PDO_FIREBIRD DSN

(No version information available, might be only in CVS)

PDO_FIREBIRD DSN — Connecting to Firebird and Interbase databases

Popis

The PDO_FIREBIRD Data Source Name (DSN) is composed of the following elements:

DSN prefix

The DSN prefix is firebird:.

DataSource

The hostname on which the database server resides.

Port

The port number for the server on which the database is running.

Database

The name of the database.

User

The name of the user that will connect to the database.

Password

The password for the user.

Příklady

Příklad 547. PDO_FIREBIRD DSN examples

The following example shows a PDO_FIREBIRD DSN for connecting to Firebird and Interbase databases:

firebird:User=john;Password=mypass;Database=DATABASE.GDE;DataSource=localhost;Port=3050

Předcházející | Nahoru | Další
XLIV. Firebird/Interbase Functions (PDO_FIREBIRD) | Domů | XLV. FriBiDi Functions


IBM Functions (PDO_IBM)

Předcházející VI. Reference funkcí Další

LX. IBM Functions (PDO_IBM)

Úvod

PDO_IBM is a driver that implements the PHP Data Objects (PDO) interface to enable access from PHP to IBM databases.

Instalace

To build the PDO_IBM extension, the DB2 Client v9.1 or later must be installed on the same system as PHP. The DB2 Client can be downloaded from the IBM » Application Development Site.

Note: The DB2 Client v9.1 or later supports direct access to DB2 for Linux, UNIX, and Windows v8 and v9.1 servers.

The DB2 Client v9.1 also supports access to DB2 UDB for i5 and DB2 UDB for z/OS servers using the separately purchased » DB2 Connect product.

PDO_IBM is a » PECL extension, so follow the instructions in 7 – „Installation of PECL extensions“ to install the PDO_IBM extension. Issue the configure command to point to the location of your DB2 Client header files and libraries as follows:

bash$ ./configure --with-pdo-ibm=/path/to/sqllib[,shared]
The configure command defaults to the value of the DB2DIR environment variable.

Obsah

PDO_IBM DSN — Connecting to IBM databases
Předcházející | Nahoru | Další
locale_set_default | Domů | PDO_IBM DSN


PDO_IBM DSN

(No version information available, might be only in CVS)

PDO_IBM DSN — Connecting to IBM databases

Popis

The PDO_IBM Data Source Name (DSN) is based on the IBM CLI DSN. The major components of the PDO_IBM DSN are:

DSN prefix

The DSN prefix is ibm:.

DSN

The DSN can be any of the following:

  • a) Data source setup using db2cli.ini or odbc.ini

  • b) Catalogued database name i.e. database alias in the DB2 client catalog

  • c) Complete connection string in the following format: DRIVER={IBM DB2 ODBC DRIVER};DATABASE=database;HOSTNAME=hostname;PORT=port;PROTOCOL=TCPIP;UID=username;PWD=password; where the parameters represent the following values:

    database

    The name of the database.

    hostname

    The hostname or IP address of the database server.

    port

    The TCP/IP port on which the database is listening for requests.

    username

    The username with which you are connecting to the database.

    password

    The password with which you are connecting to the database.

Příklady

Příklad 760. PDO_IBM DSN example using db2cli.ini

The following example shows a PDO_IBM DSN for connecting to an DB2 database cataloged as DB2_9 in db2cli.ini:

$db = new PDO("ibm:DSN=DB2_9", "", "");

[DB2_9]
Database=testdb
Protocol=tcpip
Hostname=11.22.33.444
Servicename=56789

Příklad 761. PDO_IBM DSN example using a connection string

The following example shows a PDO_IBM DSN for connecting to an DB2 database named testdb using the DB2 CLI connection string syntax.

$db = new PDO("ibm:DRIVER={IBM DB2 ODBC DRIVER};DATABASE=testdb;" .
  "HOSTNAME=11.22.33.444;PORT=56789;PROTOCOL=TCPIP;", "testuser", "tespass");

Předcházející | Nahoru | Další
LX. IBM Functions (PDO_IBM) | Domů | LXI. IBM DB2, Cloudscape and Apache Derby Functions


Informix Functions (PDO_INFORMIX)

Předcházející VI. Reference funkcí Další

LXIX. Informix Functions (PDO_INFORMIX)

Úvod

PDO_INFORMIX is a driver that implements the PHP Data Objects (PDO) interface to enable access from PHP to Informix databases.

Instalace

To build the PDO_INFORMIX extension, the Informix Client SDK 2.81 UC1 or higher must be installed on the same system as PHP. The Informix Client SDK is available from the » IBM Informix Support Site.

PDO_INFORMIX is a » PECL extension, so follow the instructions in 7 – „Installation of PECL extensions“ to install the PDO_INFORMIX extension. Issue the configure command to point to the location of your Informix Client SDK header files and libraries as follows:

   bash$ ./configure --with-pdo-informix=/path/to/SDK[,shared]
The configure command defaults to the value of the INFORMIXDIR environment variable.

Scrollable cursors

PDO_INFORMIX supports scrollable cursors; however, they are not enabled by default. To enable scrollable cursor support, you must either set ENABLESCROLLABLECURSORS=1 in the corresponding ODBC connection settings in odbc.ini or pass the EnableScrollableCursors=1 clause in the DSN connection string.

Obsah

PDO_INFORMIX DSN — Connecting to Informix databases
Předcházející | Nahoru | Další
ifxus_write_slob | Domů | PDO_INFORMIX DSN


PDO_INFORMIX DSN

(No version information available, might be only in CVS)

PDO_INFORMIX DSN — Connecting to Informix databases

Popis

The PDO_INFORMIX Data Source Name (DSN) is based on the Informix ODBC DSN string. Details on configuring an Informix ODBC DSN are available from the » Informix Dynamic Server Information Center. The major components of the PDO_INFORMIX DSN are:

DSN prefix

The DSN prefix is informix:.

DSN

The DSN can be either a data source setup using odbc.ini or a complete » connection string.

Příklady

Příklad 931. PDO_INFORMIX DSN example using odbc.ini

The following example shows a PDO_INFORMIX DSN for connecting to an Informix database cataloged as Infdrv33 in odbc.ini:

$db = new PDO("informix:DSN=Infdrv33", "", "");

[ODBC Data Sources]
Infdrv33=INFORMIX 3.3 32-BIT

[Infdrv33]
Driver=/opt/informix/csdk_2.81.UC1G2/lib/cli/iclis09b.so
Description=INFORMIX 3.3 32-BIT
Database=common_db
LogonID=testuser
pwd=testpass
Servername=ids_server
DB_LOCALE=en_US.819
OPTIMIZEAUTOCOMMIT=1
ENABLESCROLLABLECURSORS=1

Příklad 932. PDO_INFORMIX DSN example using a connection string

The following example shows a PDO_INFORMIX DSN for connecting to an Informix database named common_db using the Informix connection string syntax.

$db = new PDO("informix:host=host.domain.com; service=9800;
    database=common_db; server=ids_server; protocol=onsoctcp;
    EnableScrollableCursors=1", "testuser", "tespass");

Předcházející | Nahoru | Další
LXIX. Informix Functions (PDO_INFORMIX) | Domů | LXX. Ingres II Functions


MySQL Functions (PDO_MYSQL)

Předcházející VI. Reference funkcí Další

XCIX. MySQL Functions (PDO_MYSQL)

Úvod

PDO_MYSQL is a driver that implements the PHP Data Objects (PDO) interface to enable access from PHP to MySQL 3.x, 4.x and 5.x databases.

PDO_MYSQL will take advantage of native prepared statement support present in MySQL 4.1 and higher. If you're using an older version of the mysql client libraries, PDO will emulate them for you.

Varování

Beware: Some MySQL table types (storage engines) do not support transactions. When writing transactional database code using a table type that does not support transactions, MySQL will pretend that a transaction was initiated successfully. In addition, any DDL queries issued will implicitly commit any pending transactions.

Předdefinované konstanty

Níže uvedené konstanty jsou definovány tímto ovladačem a budou dostupné jen tehdy, bylo-li zakompilováno do PHP nebo dynamicky načteno za běhu. Navíc by se měly tyto konstanty specifické pro ovladač používat jen při použití tohoto ovladače. Používání atributů specifických pro mysql s ovladačem pro postgres může vést k neočekávanému chování. unexpected behaviour. PDO::getAttribute() lze použít k získání atributu PDO_ATTR_DRIVER_NAME pro ověření ovladače v případech, kdy lze kód spouštět s více různými ovladači.

PDO::MYSQL_ATTR_USE_BUFFERED_QUERY (integer)

If this attribute is set to TRUE on a PDOStatement, the MySQL driver will use the buffered versions of the MySQL API. If you're writing portable code, you should use PDOStatement::fetchAll() instead.

Příklad 1281. Forcing queries to be buffered in mysql

<?php
if ($db->getAttribute(PDO::ATTR_DRIVER_NAME) == 'mysql') {
    $stmt = $db->prepare('select * from foo',
        array(PDO::MYSQL_ATTR_USE_BUFFERED_QUERY => true));
} else {
    die("my application only works with mysql; I should use \$stmt->fetchAll() instead");
}
?>

PDO::MYSQL_ATTR_LOCAL_INFILE (integer)

Enable LOAD LOCAL INFILE.

PDO::MYSQL_ATTR_INIT_COMMAND (integer)

Command to execute when connecting to the MySQL server. Will automatically be re-executed when reconnecting.

PDO::MYSQL_ATTR_READ_DEFAULT_FILE (integer)

Read options from the named option file instead of from my.cnf.

PDO::MYSQL_ATTR_READ_DEFAULT_GROUP (integer)

Read options from the named group from my.cnf or the file specified with MYSQL_READ_DEFAULT_FILE.

PDO::MYSQL_ATTR_MAX_BUFFER_SIZE (integer)

Maximum buffer size. Defaults to 1 MiB.

PDO::MYSQL_ATTR_DIRECT_QUERY (integer)

Perform direct queries, don't use prepared statements.

Obsah

PDO_MYSQL DSN — Connecting to MySQL databases
Předcházející | Nahoru | Další
mysql_unbuffered_query | Domů | PDO_MYSQL DSN


PDO_MYSQL DSN

(No version information available, might be only in CVS)

PDO_MYSQL DSN — Connecting to MySQL databases

Popis

The PDO_MYSQL Data Source Name (DSN) is composed of the following elements:

DSN prefix

The DSN prefix is mysql:.

host

The hostname on which the database server resides.

port

The port number where the database server is listening.

dbname

The name of the database.

unix_socket

The MySQL Unix socket (shouldn't be used with host or port).

Příklady

Příklad 1282. PDO_MYSQL DSN examples

The following example shows a PDO_MYSQL DSN for connecting to MySQL databases:

mysql:host=localhost;dbname=testdb

More complete examples:

mysql:host=localhost;port=3307;dbname=testdb
mysql:unix_socket=/tmp/mysql.sock;dbname=testdb

Předcházející | Nahoru | Další
XCIX. MySQL Functions (PDO_MYSQL) | Domů | C. MySQL Improved Extension


Oracle Functions (PDO_OCI)

Předcházející VI. Reference funkcí Další

CXIV. Oracle Functions (PDO_OCI)

Úvod

Varování

Toto rozšíření je EXPERIMENTÁLNÍ. Chování tohoto rozšíření, názvy funkcí a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může bez ohlášení změnit. Berte to v úvahu a používejte tento modul na vlastní nebezpečí.

PDO_OCI is a driver that implements the PHP Data Objects (PDO) interface to enable access from PHP to Oracle databases through the OCI library.

Obsah

PDO_OCI DSN — Connecting to Oracle databases
Předcházející | Nahoru | Další
ora_rollback | Domů | PDO_OCI DSN


PDO_OCI DSN

(No version information available, might be only in CVS)

PDO_OCI DSN — Connecting to Oracle databases

Popis

The PDO_OCI Data Source Name (DSN) is composed of the following elements:

DSN prefix

The DSN prefix is oci:.

dbname (Oracle Instant Client)

The URI for the Oracle Instant Client connection takes the form of dbname=//hostname:port-number/database. If you are connecting to a database defined in tnsnames.ora, use only the name of the database: dbname=database.

charset

The client-side character set for the current environment handle.

Příklady

Příklad 1487. PDO_OCI DSN examples

The following examples show a PDO_OCI DSN for connecting to Oracle databases:

// Connect to a database defined in tnsnames.ora
oci:dbname=mydb

// Connect using the Oracle Instant Client
oci:dbname=//localhost:1521/mydb

Předcházející | Nahoru | Další
CXIV. Oracle Functions (PDO_OCI) | Domů | CXV. Funkce pro řízení výstupu


ODBC and DB2 Functions (PDO_ODBC)

Předcházející VI. Reference funkcí Další

CIX. ODBC and DB2 Functions (PDO_ODBC)

Úvod

PDO_ODBC is a driver that implements the PHP Data Objects (PDO) interface to enable access from PHP to databases through ODBC drivers or through the IBM DB2 Call Level Interface (DB2 CLI) library. PDO_ODBC currently supports three different "flavours" of database drivers:

ibm-db2

Supports access to IBM DB2 Universal Database, Cloudscape, and Apache Derby servers through the free DB2 client.

unixODBC

Supports access to database servers through the unixODBC driver manager and the database's own ODBC drivers.

generic

Offers a compile option for ODBC driver managers that are not explicitly supported by PDO_ODBC.

On Windows, PDO_ODBC is built into the PHP core by default. It is linked against the Windows ODBC Driver Manager so that PHP can connect to any database cataloged as a System DSN, and is the recommended driver for connecting to Microsoft SQL Server databases.

Instalace

Postup 1. PDO_ODBC on UNIX systems

  • As of PHP 5.1, PDO_ODBC is included in the PHP source. You can compile the PDO_ODBC extension as either a static or shared module using the following configure commands.

    ibm_db2

    ./configure --with-pdo-odbc=ibm-db2,/opt/IBM/db2/V8.1/

    To build PDO_ODBC with the ibm-db2 flavour, you have to have previously installed the DB2 application development headers on the same machine on which you are compiling PDO_ODBC. The DB2 application development headers are an installable option in the DB2 servers, and are also available as part of the DB2 Application Development Client freely available for download from the IBM DB2 Universal Database » support site.

    If you do not supply a location for the DB2 libraries and headers to the configure command, PDO_ODBC defaults to /home/db2inst1/sqllib.

    unixODBC

    ./configure --with-pdo-odbc=unixODBC,/usr/local

    If you do not supply a location for the unixODBC libraries and headers to the configure command, PDO_ODBC defaults to /usr/local.

    generic
    ./configure --with-pdo-odbc=generic,/usr/local,libname,ldflags,cflags

Konfigurace běhu

Chování těchto funkcí je ovlivněno nastavením parametrů v php.ini.

Tabulka 220. PDO_ODBC Configuration Options

Name | Default | Changeable | Changelog
pdo_odbc.connection_pooling | "strict" | PHP_INI_ALL | Available since PHP 5.1.0.
pdo_odbc.db2_instance_name | NULL | PHP_INI_SYSTEM | Available since PHP 5.1.1. Removed in PHP 6.0.0.

Pro další detaily a definice konstant PHP_INI_*, viz dokumentace k ini_set().

Zde je stručný popis konfiguračních direktiv.

pdo_odbc.connection_pooling string

Whether to pool ODBC connections. Can be one of "strict", "relaxed" or "off" (equals to ""). The parameter describes how strict the connection manager should be when matching connection parameters to existing pooled connections. strict is the recommend default, and will result in the use of cached connections only when all the connection parameters match exactly. relaxed will result in the use of cached connections when similar connection parameters are used. This can result in increased use of the cache, at the risk of bleeding connection information between (for example) virtual hosts.

This setting can only be changed from the php.ini file, and affects the entire process; any other modules loaded into the process that use the same ODBC libraries will be affected too, including the Unified ODBC extension.

Varování

relaxed matching should not be used on a shared server, for security reasons.

Tip

Leave this setting at the default strict setting unless you have good reason to change it.

pdo_odbc.db2_instance_name string

If you compile PDO_ODBC using the db2 flavour, this setting sets the value of the DB2INSTANCE environment variable on Linux and UNIX operating systems to the specified name of the DB2 instance. This enables PDO_ODBC to resolve the location of the DB2 libraries and make cataloged connections to DB2 databases.

This setting can only be changed from the php.ini file, and affects the entire process; any other modules loaded into the process that use the same ODBC libraries will be affected too, including the Unified ODBC extension.

This setting has no effect on Windows.

Obsah

PDO_ODBC DSN — Connecting to ODBC or DB2 databases
Předcházející | Nahoru | Další
odbc_tables | Domů | PDO_ODBC DSN


PDO_ODBC DSN

(No version information available, might be only in CVS)

PDO_ODBC DSN — Connecting to ODBC or DB2 databases

Popis

The PDO_ODBC Data Source Name (DSN) is composed of the following elements:

DSN prefix

The DSN prefix is odbc:. If you are connecting to a database cataloged in the ODBC driver manager or the DB2 catalog, you can append the cataloged name of the database to the DSN.

DSN

The name of the database as cataloged in the ODBC driver manager or the DB2 catalog. Alternately, you can provide a complete ODBC connection string to connect to a database as described at » http://www.connectionstrings.com/.

UID

The name of the user for the connection. If you specify the user name in the DSN, PDO ignores the value of the user name argument in the PDO constructor.

PWD

The password of the user for the connection. If you specify the password in the DSN, PDO ignores the value of the password argument in the PDO constructor.

Příklady

Příklad 1470. PDO_ODBC DSN example (ODBC driver manager)

The following example shows a PDO_ODBC DSN for connecting to an ODBC database cataloged as testdb in the ODBC driver manager:

odbc:testdb

Příklad 1471. PDO_ODBC DSN example (IBM DB2 uncataloged connection)

The following example shows a PDO_ODBC DSN for connecting to an IBM DB2 database named SAMPLE using the full ODBC DSN syntax:

odbc:DRIVER={IBM DB2 ODBC DRIVER};HOSTNAME=localhost;PORT=50000;DATABASE=SAMPLE;PROTOCOL=TCPIP;UID=db2inst1;PWD=ibmdb2;

Příklad 1472. PDO_ODBC DSN example (Microsoft Access uncataloged connection)

The following example shows a PDO_ODBC DSN for connecting to a Microsoft Access database stored at C:\db.mdb using the full ODBC DSN syntax:

odbc:Driver={Microsoft Access Driver (*.mdb)};Dbq=C:\\db.mdb;Uid=Admin

Předcházející | Nahoru | Další
CIX. ODBC and DB2 Functions (PDO_ODBC) | Domů | CX. oggvorbis


PostgreSQL Functions (PDO_PGSQL)

Předcházející VI. Reference funkcí Další

CXXVIII. PostgreSQL Functions (PDO_PGSQL)

Úvod

PDO_PGSQL is a driver that implements the PHP Data Objects (PDO) interface to enable access from PHP to PostgreSQL databases.

Typy prostředků

This extension defines a stream resource returned by PDO::pgsqlLOBOpen().

Obsah

PDO_PGSQL DSN — Connecting to PostgreSQL databases
PDO::pgsqlLOBCreate — Creates a new large object
PDO::pgsqlLOBOpen — Opens an existing large object stream
PDO::pgsqlLOBUnlink — Deletes the large object
Předcházející | Nahoru | Další
pg_version | Domů | PDO_PGSQL DSN


PDO_PGSQL DSN

(No version information available, might be only in CVS)

PDO_PGSQL DSN — Connecting to PostgreSQL databases

Popis

The PDO_PGSQL Data Source Name (DSN) is composed of the following elements, delimited by spaces:

DSN prefix

The DSN prefix is pgsql:.

host

The hostname on which the database server resides.

port

The port on which the database server is running.

dbname

The name of the database.

user

The name of the user for the connection. If you specify the user name in the DSN, PDO ignores the value of the user name argument in the PDO constructor.

password

The password of the user for the connection. If you specify the password in the DSN, PDO ignores the value of the password argument in the PDO constructor.

Poznámka: The bytea fields are returned as streams.

Příklady

Příklad 1776. PDO_PGSQL DSN examples

The following example shows a PDO_PGSQL DSN for connecting to a PostgreSQL database:

pgsql:host=localhost port=5432 dbname=testdb user=bruce password=mypass

Předcházející | Nahoru | Další
CXXVIII. PostgreSQL Functions (PDO_PGSQL) | Domů | PDO::pgsqlLOBCreate


SQLite Functions (PDO_SQLITE)

Předcházející VI. Reference funkcí Další

CLVII. SQLite Functions (PDO_SQLITE)

Úvod

PDO_SQLITE is a driver that implements the PHP Data Objects (PDO) interface to enable access to SQLite 3 databases.

In PHP 5.1, the SQLite extension also provides a driver for SQLite 2 databases; while it is not technically a part of the PDO_SQLITE driver, it behaves similarly, so it is documented alongside it. The SQLite 2 driver for PDO is provided primarily to make it easier to import legacy sqlite 2 database files into an application that uses the faster, more efficient sqlite 3 driver. As a result, the SQLite 2 driver is not as feature-rich as the SQLite 3 driver.

Obsah

PDO_SQLITE DSN — Connecting to SQLite databases
PDO->sqliteCreateAggregate() — Registers an aggregating User Defined Function for use in SQL statements
PDO->sqliteCreateFunction() — Registers a User Defined Function for use in SQL statements
Předcházející | Nahoru | Další
sqlite_valid | Domů | PDO_SQLITE DSN


PDO_SQLITE DSN

(No version information available, might be only in CVS)

PDO_SQLITE DSN — Connecting to SQLite databases

Popis

The PDO_SQLITE Data Source Name (DSN) is composed of the following elements:

DSN prefix (SQLite 3)

The DSN prefix is sqlite:.

  • To access a database on disk, append the absolute path to the DSN prefix.

  • To create a database in memory, append memory: to the DSN prefix.

DSN prefix (SQLite 2)

The SQLite extension in PHP 5.1 provides a PDO driver that supports accessing and creating SQLite 2 databases. This enables you to access databases you may have created with the SQLite extension in previous versions of PHP.

Poznámka: The sqlite2 driver is only available in PHP 5.1.x if you have enabled both PDO and ext/sqlite. It is not currently available via PECL.

The DSN prefix for connecting to SQLite 2 databases is sqlite2:.

  • To access a database on disk, append the absolute path to the DSN prefix.

  • To create a database in memory, append :memory: to the DSN prefix.

Příklady

Příklad 2127. PDO_SQLITE DSN examples

The following examples show PDO_SQLITE DSN for connecting to SQLite databases:

sqlite:/opt/databases/mydb.sq3
sqlite::memory:
sqlite2:/opt/databases/mydb.sq2
sqlite2::memory:

Předcházející | Nahoru | Další
CLVII. SQLite Functions (PDO_SQLITE) | Domů | PDO->sqliteCreateAggregate()


Phar archive stream and classes

Předcházející VI. Reference funkcí Další

CXXIII. Phar archive stream and classes

Úvod

The phar extension provides the phar stream wrapper and the Phar class for manipulating self-contained PHP Archive (phar) files. The Phar class can be used to create and to extract contents of phar files as well as iterating over their contents.

PHP Archive files (Phars) are special collections of files that can be transparently run right out of the file, similar to Java's jar archive files. Using a phar archive, it is possible to distribute a complete PHP application in a single file that will run out of the file without modification or extraction. Phar archives can also be used to store files for extraction similar to tar or zip archive files. Phars support compression using gzip if the zlib extension is present, and using bzip2 if the bz2 extension is present. In addition, iteration and other features are available if the SPL extension is available. Phar signature verification using md5 or sha1 is natively supported to ensure archive integrity.

The original implementation for Phar archives was in the PEAR package » PHP_Archive, and the implementation details are very similar, although the Phar extension is more full-featured. PHP_Archive has more flexibility in Phar creation, and helpful debugging tools like the PHP_Archive_Manager class, and the Phar extension supports iteration, array access, and directly manipulating Phar contents through a simple interface. PHP_Archive supports creation of Phar archives that can be processed using the Phar extension or PHP_Archive seamlessly, whereas the Phar extension is designed to create extensions that function with the Phar extension. In addition, the Phar extension will continue to work even if the allow_url_include or allow_url_fopen INI variables are disabled, while PHP_Archive-based Phar archives (without the Phar extension) will not function.

Požadavky

Phar requires PHP 5.2.0 or newer. Additional features require the SPL extension in order to take advantage of iteration and array access to a Phar's file contents. The phar stream does not require any additional extensions to function.

You may optionally wish to enable the zlib and bzip2 extensions to take advantage of compressed phar support.

Instalace

Windows binaries may be found at » http://snaps.php.net/. To install, download php_phar.dll to the folder specified by your php.ini file's extension_dir directive. Enable it by adding extension=php_phar.dll to your php.ini and restarting your web server.

extension_dir=c:/php5/exts/
extension=php_phar.dll

Linux, BSD, and other *nix variants can be compiled using the following steps:

  • Either:

    • Run the pear installer for PECL/phar: pecl install phar
    • Copy phar.so from the directory indicated by the build process to the location specified in your php.ini file under extension_dir.
    • Add extension=phar.so to your php.ini

    Or:

    • Set the path to your php.ini via:

      pecl config-set php_ini /path/to/php.ini

    • Run the pear installer for PECL/phar: pecl install phar

  • Restart your web server to reload your php.ini settings.

Development Versions: There are currently no stable versions of PECL/phar, to force installation of the alpha version of PECL/phar execute: pecl install phar-alpha

Compiling PECL/phar without using the PEAR command

Rather than using pecl install phar to automatically download and install PECL/phar, you may download the tarball from » PECL. From the root of the unpacked tarball, run: phpize && ./configure --enable-phar && make to generate phar.so. Once built, continue the installation from step 4 above.

Informace o instalaci tohoto PECL rozšíření lze najít v kapitole manuálu nazvané Instalace rozšíření PECL. Další informace, jako nové verze, soubory ke stažení, zdrojové soubory, správcovské informace a CHANGELOG, lze najít zde: » http://pecl.php.net/package/phar.

Konfigurace běhu

Chování těchto funkcí je ovlivněno nastavením parametrů v php.ini.

Tabulka 242. Filesystem and Streams Configuration Options

Name | Default | Changeable | Changelog
phar.readonly | "1" | PHP_INI_ALL |
phar.require_hash | "1" | PHP_INI_ALL |
phar.extract_list | "" | PHP_INI_ALL | Available since phar 1.1.0.

Zde je stručný popis konfiguračních direktiv.

phar.readonly boolean

This option disables creation or modification of Phar archives using the phar stream or Phar object's write support. This setting should always be enabled on production machines, as the phar extension's convenient write support could allow straightforward creation of a php-based virus when coupled with other common security vulnerabilities.

Poznámka: This setting can only be unset in php.ini due to security reasons. If phar.readonly is disabled in php.ini, the user may enable phar.readonly in a script or disable it later. If phar.readonly is enabled in php.ini, a script may harmlessly "re-enable" the INI variable, but may not disable it.

phar.require_hash boolean

This option will force all opened Phar archives to contain some kind of signature (currently MD5 and SHA1 are supported), and will refuse to process any Phar archive that does not contain a signature.

Poznámka: This setting can only be unset in php.ini due to security reasons. If phar.require_hash is disabled in php.ini, the user may enable phar.require_hash in a script or disable it later. If phar.require_hash is enabled in php.ini, a script may harmlessly "re-enable" the INI variable, but may not disable it.

phar.extract_list string

Allows mappings from a full path to a phar archive or its alias to the location of its extracted files. The format of the parameter is name=archive,name2=archive2. This allows extraction of phar files to disk, and allows phar to act as a kind of mapper to extracted disk files. This is often done for performance reasons, or to assist with debugging a phar.

Příklad 1599. phar.extract_list usage example

in php.ini:
phar.extract_list = archive=/full/path/to/archive/,arch2=/full/path/to/arch2
<?php
include "phar://archive/content.php";
include "phar://arch2/foo.php";
?>

Typy prostředků

The Phar extension provides the phar stream, which allows accessing files contained within a phar transparently. The file format of a Phar is described here

Předdefinované třídy

Phar
PharFileInfo
PharException

Using Phar Archives: Introduction

Phar archives are similar in concept to Java JAR archives, but are tailored to the needs and to the flexibility of PHP applications. A Phar archive is used to distribute a complete PHP application or library in a single file. Unlike Java's implementation of JAR archives, no external tool is required to process or run a PHP Phar archive. A Phar archive application is processed exactly like any other PHP application:

php coolapplication.phar

Using a Phar archive library is identical to using any other PHP library:

<?php
include 'coollibrary.phar';
?>

What makes Phar archives incredibly useful is the phar stream wrapper, which is explained in depth here. Using this stream wrapper, it is possible to access individual files within a phar as if the phar were its own filesystem. The phar stream wrapper supports all read/write operations on files, and opendir() on directories.

<?php
include 'phar://coollibrary.phar/internal/file.php';
header('Content-type: image/jpeg');
// phars can be accessed by full path or by alias
echo file_get_contents('phar:///fullpath/to/coollibrary.phar/images/wow.jpg');
?>

Also provided with the Phar extension is the Phar class, which allows accessing the files of the Phar archive as if it were an associative array, and other functionality. The Phar class is explained here.

<?php
try {
    // open an existing phar
    $p = new Phar('coollibrary.phar');
    foreach ($p as $file) {
        // $file is a PharFileInfo class, and inherits from SplFileInfo
        echo $file->getFileName() . "\n";
        echo $file . "\n"; // display contents;
    }
    if (isset($p['internal/file.php'])) {
        var_dump($p['internal/file.php']->getMetaData());
    }

    // create a new phar - phar.readonly must be 0 in php.ini
    // phar.readonly is enabled by default for security reasons.
    // On production servers, Phars need never be created,
    // only executed.
    if (Phar::canWrite()) {
        $p = new Phar(dirname(__FILE__) . '/newphar.phar', 0, 'newphar.phar');
        // create transaction - nothing is written to newphar.phar
        // until commit() is called, although temporary storage is needed
        $p->begin();
        // add a new file, set its contents
        $p['file1.txt'] = 'Information';
        $fp = fopen('hugefile.dat', 'rb');
        // copy from the stream
        $p['data/hugefile.dat'] = $fp;
        if (Phar::canCompress()) {
            $p['data/hugefile.dat']->setCompressedGZ();
        }
        $p['images/wow.jpg'] = file_get_contents('images/wow.jpg');
        // any value can be saved as file-specific meta-data
        $p['images/wow.jpg']->setMetaData(array('mime-type' => 'image/jpeg'));
        $p['index.php'] = file_get_contents('index.php');
        $p->setMetaData(array('bootstrap' => 'index.php'));
        // set the loader stub
        $p->setStub('<?php
$p = new Phar(__FILE__);
$m = $p->getMetaData();
require "phar://" . __FILE__ . "/" . $m["bootstrap"];
__HALT_COMPILER();');
        // save the phar archive to disk
        $p->commit();
    }
} catch (Exception $e) {
    echo 'Could not open Phar: ', $e;
}
?>

Using Phar Archives: the phar stream wrapper

The Phar stream wrapper fully supports fopen() for read, write or append, unlink(), stat(), fstat(), fseek(), rename() and directory stream operation opendir(). The Phar stream wrapper does not support creating or erasing a directory, as files are stored only as files, and the concept of an abstract directory does not exist.

Individual file compression and per-file metadata can also be manipulated in a Phar archive using stream contexts:

<?php
$context = stream_context_create(array('phar' =>
                                    array('compression' => Phar::GZ)),
                                    array('metadata' => array('user' => 'cellog')));
file_put_contents('phar://my.phar/somefile.php', 0, $context);
?>

The phar stream wrapper does not operate on remote files, and cannot operate on remote files, and so is allowed even when the allow_url_fopen and allow_url_include INI options are disabled.

Although it is possible to create phar archives from scratch just using stream operations, it is best to use the functionality built into the Phar class. The stream wrapper is best used for read operations.

Using Phar Archives: the Phar class

The Phar class supports reading and manipulation of Phar archives, as well as iteration through inherited functionality of the » RecursiveDirectoryIterator class. With support for the ArrayAccess interface, files inside a Phar archive can be accessed as if they were part of an associative array.

It is important to note that when creating a Phar archive, the full path should be passed to the Phar object constructor. Relative paths will fail to initialize.

Assuming that $p is a Phar object initialized as follows:

<?php
$p = new Phar('/path/to/myphar.phar', 0, 'myphar.phar');
?>

An empty Phar archive will be created at /path/to/myphar.phar, or if /path/to/myphar.phar already exists, it will be opened again. The literal myphar.phar deomnstrates the concept of an alias that can be used to reference /path/to/myphar.phar in URLs as in:

<?php
// these two calls to file_get_contents() are equivalent if
// /path/to/myphar.phar has an explicit alias of "myphar.phar"
// in its manifest, or if the phar was initialized with the
// previous example's Phar object setup
$f = file_get_contents('phar:///path/to/myphar.phar/whatever.txt');
$f = file_get_contents('phar://myphar.phar/whatever.txt');
?>

With the newly created $p Phar object, the following is possible:

  • $a = $p['file.php'] creates a PharFileInfo class that refers to the contents of phar://myphar.phar/file.php
  • $p['file.php'] = $v creates a new file (phar://myphar.phar/file.php), or overwrites an existing file within myphar.phar. $v can be either a string or an open file pointer, in which case the entire contents of the file will be used to create the new file.
  • isset($p['file.php']) can be used to determine whether phar://myphar.phar/file.php exists within myphar.phar.
  • unset($p['file.php']) erases phar://myphar.phar/file.php from myphar.phar.

In addition, the Phar object is the only way to access Phar-specific metadata, through Phar->getMetaData(), and the only way to set or retrieve a Phar archive's PHP loader stub through Phar->getStub() and Phar->setStub(). Additionally, compression for the entire Phar archive at once can only be manipulated using the Phar class.

The full list of Phar object functionality is documented below.

The PharFileInfo class extends the » SplFileInfo class, and adds several methods for manipulating Phar-specific details of a file contained within a Phar, such as manipulating compression and metadata.

Phar file format

All Phar files contain three to four sections:

  1. a stub

  2. a manifest describing the contents

  3. the file contents

  4. [optional] a signature for verifying Phar integrity

Phar file stub

A Phar's stub is a simple PHP file. The smallest possible stub follows:

<?php __HALT_COMPILER();

A stub must contain as a minimum, the __HALT_COMPILER(); token at its conclusion. Typically, a stub will contain loader functionality like so:

<?php
Phar::mapPhar();
include 'phar://myphar.phar/index.php';
__HALT_COMPILER();

There are no restrictions on the contents of a Phar stub, except for the requirement that it conclude with __HALT_COMPILER();. The closing PHP tag ?> may be included or omitted, but there can be no more than 1 space between the ; and the close tag ?> or the phar extension will be unable to process the Phar archive's manifest.

Phar Manifest Format

The Phar manifest is a highly optimized format that allows per-file specification of file compression, file permissions, and even user-defined meta-data such as file user or group. All values greater than 1 byte are stored in little-endian byte order, with the exception of the API version, which for historical reasons is stored as 3 nibbles in big-endian order.

All unused flags are reserved for future use, and must not be used to store custom information. Use the per-file meta-data facility to store customized information about particular files.

The basic file format of a Phar archive manifest is as follows:

Tabulka 243. Global Phar manifest format

Size in bytes | Description
4 bytes | Length of manifest in bytes (1 MB limit)
4 bytes | Number of files in the Phar
2 bytes | API version of the Phar manifest (currently 1.0.0)
4 bytes | Global Phar bitmapped flags
4 bytes | Length of Phar alias
?? | Phar alias (length based on previous)
4 bytes | Length of Phar metadata (0 for none)
?? | Serialized Phar Meta-data, stored in serialize() format
at least 24 * number of entries bytes | entries for each file

Global Phar bitmapped flags

Here are the bitmapped flags currently recognized by the Phar extension for the global Phar flat bitmap:

Tabulka 244. Bitmap values recognized

Value | Description
0x00010000 | If set, this Phar contains a verification signature
0x00001000 | If set, this Phar contains at least 1 file that is compressed with zlib compression
0x00002000 | If set, this Phar contains at least 1 file that is compressed with bzip compression

Phar manifest file entry definition

Each file in the manifest contains the following information:

Tabulka 245. Phar Manifest file entry

Size in bytes | Description
4 bytes | Filename length in bytes
?? | Filename (length specified in previous)
4 bytes | Un-compressed file size in bytes
4 bytes | Unix timestamp of file
4 bytes | Compressed file size in bytes
4 bytes | CRC32 checksum of un-compressed file contents
4 bytes | Bit-mapped File-specific flags
4 bytes | Serialized File Meta-data length (0 for none)
?? | Serialized File Meta-data, stored in serialize() format

The File-specific bitmap values recognized are:

Tabulka 246. Bitmap values recognized

Value | Description
0x000001FF | These bits are reserved for defining specific file permissions of a file. Permissions are used for fstat() and can be used to recreate desired permissions upon extraction.
0x00001000 | If set, this file is compressed with zlib compression
0x00002000 | If set, this file is compressed with bzip compression

Phar Signature format

Phars containing a signature always have the signature appended to the end of the Phar archive after the loader, manifest, and file contents. The two signature formats supported at this time are MD5 and SHA1.

Tabulka 247. Signature format

Length in bytes | Description
16 or 20 bytes | The actual signature, 20 bytes for an SHA1 signature, 16 bytes for an MD5 signature.
4 bytes | Signature flags. 0x0001 is used to define an MD5 signature, and 0x0002 is used to define an SHA1 signature.
4 bytes | Magic GBMB used to define the presence of a signature.

Obsah

Phar::apiVersion — Returns the api version
Phar::canCompress — Returns whether phar extension supports compression using either zlib or bzip2
Phar::canWrite — Returns whether phar extension supports writing and creating phars
Phar->compressAllFilesBZIP2 — Compresses all files in the current Phar archive using Bzip2 compression
Phar->compressAllFilesGZ — Compresses all files in the current Phar archive using Gzip compression
Phar::__construct — Construct a Phar archive object
Phar->count — Returns the number of entries (files) in the Phar archive
Phar->getMetaData — Returns phar archive meta-data
Phar->getModified — Return whether phar was modified
Phar->getSignature — Return MD5/SHA1 signature of a Phar archive
Phar->getStub — Return the PHP loader or bootstrap stub of a Phar archive
Phar->getVersion — Return version info of Phar archive
Phar->isBuffering — Used to determine whether Phar write operations are being buffered, or are flushing directly to disk
Phar::loadPhar — Loads any phar archive with an alias
Phar::mapPhar — Reads the currently executed file (a phar) and registers its manifest
Phar::offsetExists — determines whether a file exists in the phar
Phar::offsetGet — get a PharFileInfo object for a specific file
Phar::offsetSet — set the contents of an internal file to those of an external file
Phar::offsetUnset — remove a file from a phar
Phar->setMetaData — Sets phar archive meta-data
Phar->setStub — Used to set the PHP loader or bootstrap stub of a Phar archive
Phar->startBuffering — Start buffering Phar write operations, do not modify the Phar object on disk
Phar->stopBuffering — Stop buffering write requests to the Phar archive, and save changes to disk
Phar->uncompressAllFiles — Uncompresses all files in the current Phar archive
PharFileInfo->chmod — Sets file-specific permission bits
PharFileInfo::__construct — Construct a Phar entry object
PharFileInfo->getCompressedSize — Returns the actual size of the file (with compression) inside the Phar archive
PharFileInfo->getCRC32 — Returns CRC32 code or throws an exception if not CRC checked
PharFileInfo->getMetaData — Returns file-specific meta-data saved with a file
PharFileInfo->getPharFlags — Returns the Phar file entry flags
PharFileInfo->isCompressed — Returns whether the entry is compressed
PharFileInfo->isCompressedBZIP2 — Returns whether the entry is compressed using bzip2
PharFileInfo->isCompressedGZ — Returns whether the entry is compressed using gz
PharFileInfo->isCRCChecked — Returns whether file entry has had its CRC verified
PharFileInfo->setCompressedBZIP2 — Compresses the current Phar entry within the phar using Bzip2 compression
PharFileInfo->setCompressedGZ — Compresses the current Phar entry within the phar using gz compression
PharFileInfo->setMetaData — Sets file-specific meta-data saved with a file
PharFileInfo->setUncompressed — Uncompresses the current Phar entry within the phar, if it is compressed
Předcházející | Nahoru | Další
PDOStatement->setFetchMode() | Domů | Phar::apiVersion


PostScript document creation

Předcházející VI. Reference funkcí Další

CXXXI. PostScript document creation

Úvod

This module allows to create PostScript documents. It has many similarities with the pdf extension. Actually the API is almost identical and one can in many cases just replace the prefix of each function from pdf_ to ps_. This also works for functions which has no meaning in the PostScript document (like adding hyperlinks) but will have an effect if the document is converted to PDF.

Documents created by this extension are sometimes even superior to documents created with the pdf extension, because pslib's text rendering functions can handle kerning, hyphenation and ligatures which results in much better output of boxed text.

Požadavky

You need at least PHP 4.3.0 and pslib >= 0.1.12. The ps library (pslib) is available at » http://pslib.sourceforge.net/.

Instalace

A short installation note: just type

$ pecl install ps
in your console.

Konfigurace běhu

Toto rozšíření nemá definováno žádné konfigurační direktivy.

Typy prostředků

This extension defines a PostScript document resource returned by ps_new().

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

The following two tables lists all constants defined by the ps extension.

Tabulka 261. Contants for line caps

Name | Meaning
ps_LINECAP_BUTT |
ps_LINECAP_ROUND |
ps_LINECAP_SQUARED |

Tabulka 262. Contants for line joins

Name | Meaning
ps_LINEJOIN_MITER |
ps_LINEJOIN_ROUND |
ps_LINEJOIN_BEVEL |

Contact Information

If you have comments, bugfixes, enhancements for either this extension or pslib then please drop me a mail » steinm@php.net. Any help is very welcome.

Obsah

ps_add_bookmark — Add bookmark to current page
ps_add_launchlink — Adds link which launches file
ps_add_locallink — Adds link to a page in the same document
ps_add_note — Adds note to current page
ps_add_pdflink — Adds link to a page in a second pdf document
ps_add_weblink — Adds link to a web location
ps_arc — Draws an arc counterclockwise
ps_arcn — Draws an arc clockwise
ps_begin_page — Start a new page
ps_begin_pattern — Start a new pattern
ps_begin_template — Start a new template
ps_circle — Draws a circle
ps_clip — Clips drawing to current path
ps_close_image — Closes image and frees memory
ps_close — Closes a PostScript document
ps_closepath_stroke — Closes and strokes path
ps_closepath — Closes path
ps_continue_text — Continue text in next line
ps_curveto — Draws a curve
ps_delete — Deletes all resources of a PostScript document
ps_end_page — End a page
ps_end_pattern — End a pattern
ps_end_template — End a template
ps_fill_stroke — Fills and strokes the current path
ps_fill — Fills the current path
ps_findfont — Loads a font
ps_get_buffer — Fetches the full buffer containig the generated PS data
ps_get_parameter — Gets certain parameters
ps_get_value — Gets certain values
ps_hyphenate — Hyphenates a word
ps_include_file — Reads an external file with raw PostScript code
ps_lineto — Draws a line
ps_makespotcolor — Create spot color
ps_moveto — Sets current point
ps_new — Creates a new PostScript document object
ps_open_file — Opens a file for output
ps_open_image_file — Opens image from file
ps_open_image — Reads an image for later placement
ps_open_memory_image — Takes an GD image and returns an image for placement in a PS document
ps_place_image — Places image on the page
ps_rect — Draws a rectangle
ps_restore — Restore previously save context
ps_rotate — Sets rotation factor
ps_save — Save current context
ps_scale — Sets scaling factor
ps_set_border_color — Sets color of border for annotations
ps_set_border_dash — Sets length of dashes for border of annotations
ps_set_border_style — Sets border style of annotations
ps_set_info — Sets information fields of document
ps_set_parameter — Sets certain parameters
ps_set_text_pos — Sets position for text output
ps_set_value — Sets certain values
ps_setcolor — Sets current color
ps_setdash — Sets appearance of a dashed line
ps_setflat — Sets flatness
ps_setfont — Sets font to use for following output
ps_setgray — Sets gray value
ps_setlinecap — Sets appearance of line ends
ps_setlinejoin — Sets how contected lines are joined
ps_setlinewidth — Sets width of a line
ps_setmiterlimit — Sets the miter limit
ps_setoverprintmode — Sets overprint mode
ps_setpolydash — Sets appearance of a dashed line
ps_shading_pattern — Creates a pattern based on a shading
ps_shading — Creates a shading for later use
ps_shfill — Fills an area with a shading
ps_show_boxed — Output text in a box
ps_show_xy2 — Output text at position
ps_show_xy — Output text at given position
ps_show2 — Output a text at current position
ps_show — Output text
ps_string_geometry — Gets geometry of a string
ps_stringwidth — Gets width of a string
ps_stroke — Draws the current path
ps_symbol_name — Gets name of a glyph
ps_symbol_width — Gets width of a glyph
ps_symbol — Output a glyph
ps_translate — Sets translation
Předcházející | Nahoru | Další
system | Domů | ps_add_bookmark


Radius

Předcházející VI. Reference funkcí Další

CXXXIV. Radius

Úvod

This package is based on the libradius of FreeBSD. This PECL adds full support for Radius Authentication (» RFC 2865) and Radius Accounting (» RFC 2866). This package is available for Unix (tested on FreeBSD and Linux) and for Windows.

Poznámka: An exact description for libradius can be found » here. A detailed description of the configuration file can be found » here.

Instalace

Howto install the package?

  • untar the package (usually into php4/ext)
  • rename radius-x.x to radius
  • run ./buildconf in php4
  • run ./configure --enable-radius
  • make; make install
or if you would like to have it as .so:
  • untar the package
  • run phpize in the radius-x.x directory
  • run ./configure in the radius-x.x directory
  • make; make install

For Windows I recommend to use the php_radius.dll from » http://snaps.php.net/. Toto nezahrnuté rozšíření PECL můžete získat z různých stránek s kopiemi PECL (vyberte si repozitář odpovídající vaší verzi PHP): » PECL pro PHP 4.3.x, » PECL pro PHP 5.0.x nebo » PECL Unstable.

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

RADIUS_ACCESS_REQUEST ()
Authentication Request
RADIUS_ACCESS_ACCEPT ()
Access accepted
RADIUS_ACCESS_REJECT ()
Access rejected
RADIUS_ACCOUNTING_REQUEST ()
Accounting request
RADIUS_ACCOUNTING_RESPONSE ()
Accounting response
RADIUS_ACCESS_CHALLENGE ()
Accsess challenge
RADIUS_USER_NAME (string)
Username
RADIUS_USER_PASSWORD (string)
Password
RADIUS_CHAP_PASSWORD (string)
Chap Password: chappass = md5(ident + plaintextpass + challenge)
RADIUS_NAS_IP_ADDRESS (string)
NAS IP-Adress
RADIUS_NAS_PORT (int)
NAS Port
RADIUS_SERVICE_TYPE (int)

Type of Service, one of:

RADIUS_LOGIN
RADIUS_FRAMED
RADIUS_CALLBACK_LOGIN
RADIUS_CALLBACK_FRAMED
RADIUS_OUTBOUND
RADIUS_ADMINISTRATIVE
RADIUS_NAS_PROMPT
RADIUS_AUTHENTICATE_ONLY
RADIUS_CALLBACK_NAS_PROMPT

RADIUS_FRAMED_PROTOCOL (int)

Framed Protocol, one of:

RADIUS_PPP
RADIUS_SLIP
RADIUS_ARAP
RADIUS_GANDALF
RADIUS_XYLOGICS

RADIUS_FRAMED_IP_ADDRESS (string)
IP-Address
RADIUS_FRAMED_IP_NETMASK (string)
Netmask
RADIUS_FRAMED_ROUTING (int)
Routing
RADIUS_FILTER_ID (string)
Filter ID
RADIUS_FRAMED_MTU (int)
MTU
RADIUS_FRAMED_COMPRESSION (int)

Compression, one of:

RADIUS_COMP_NONE
RADIUS_COMP_VJ
RADIUS_COMP_IPXHDR

RADIUS_LOGIN_IP_HOST (string)
Login IP Host
RADIUS_LOGIN_SERVICE (int)
Login Service
RADIUS_LOGIN_TCP_PORT (int)
Login TCP Port
RADIUS_REPLY_MESSAGE (string)
Reply Message
RADIUS_CALLBACK_NUMBER (string)
Callback Number
RADIUS_CALLBACK_ID (string)
Callback ID
RADIUS_FRAMED_ROUTE (string)
Framed Route
RADIUS_FRAMED_IPX_NETWORK (string)
Framed IPX Network
RADIUS_STATE (string)
State
RADIUS_CLASS (int)
Class
RADIUS_VENDOR_SPECIFIC (int)
Vendor specific attribute
RADIUS_SESSION_TIMEOUT (int)
Session timeout
RADIUS_IDLE_TIMEOUT (int)
Idle timeout
RADIUS_TERMINATION_ACTION (int)
Termination action
RADIUS_CALLED_STATION_ID (int)
Called Station Id
RADIUS_CALLING_STATION_ID (string)
Calling Station Id
RADIUS_NAS_IDENTIFIER (int)
NAS ID
RADIUS_PROXY_STATE (int)
Proxy State
RADIUS_LOGIN_LAT_SERVICE (int)
Login LAT Service
RADIUS_LOGIN_LAT_NODE (int)
Login LAT Node
RADIUS_LOGIN_LAT_GROUP (int)
Login LAT Group
RADIUS_FRAMED_APPLETALK_LINK (int)
Framed Appletalk Link
RADIUS_FRAMED_APPLETALK_NETWORK (int)
Framed Appletalk Network
RADIUS_FRAMED_APPLETALK_ZONE (int)
Framed Appletalk Zone
RADIUS_CHAP_CHALLENGE (string)
Challenge
RADIUS_NAS_PORT_TYPE (int)

NAS port type, one of:

RADIUS_ASYNC
RADIUS_SYNC
RADIUS_ISDN_SYNC
RADIUS_ISDN_ASYNC_V120
RADIUS_ISDN_ASYNC_V110
RADIUS_VIRTUAL
RADIUS_PIAFS
RADIUS_HDLC_CLEAR_CHANNEL
RADIUS_X_25
RADIUS_X_75
RADIUS_G_3_FAX
RADIUS_SDSL
RADIUS_ADSL_CAP
RADIUS_ADSL_DMT
RADIUS_IDSL
RADIUS_ETHERNET
RADIUS_XDSL
RADIUS_CABLE
RADIUS_WIRELESS_OTHER
RADIUS_WIRELESS_IEEE_802_11

RADIUS_PORT_LIMIT (int)
Port Limit
RADIUS_LOGIN_LAT_PORT (int)
Login LAT Port
RADIUS_CONNECT_INFO (string)
Connect info
RADIUS_ACCT_STATUS_TYPE (int)

Accounting status type, one of:

RADIUS_START
RADIUS_STOP
RADIUS_ACCOUNTING_ON
RADIUS_ACCOUNTING_OFF

RADIUS_ACCT_DELAY_TIME (int)
Accounting delay time
RADIUS_ACCT_INPUT_OCTETS (int)
Accounting input bytes
RADIUS_ACCT_OUTPUT_OCTETS (int)
Accounting output bytes
RADIUS_ACCT_SESSION_ID (int)
Accounting session ID
RADIUS_ACCT_AUTHENTIC (int)

Accounting authentic, one of:

RADIUS_AUTH_RADIUS
RADIUS_AUTH_LOCAL
RADIUS_AUTH_REMOTE

RADIUS_ACCT_SESSION_TIME (int)
Accounting session time
RADIUS_ACCT_INPUT_PACKETS (int)
Accounting input packets
RADIUS_ACCT_OUTPUT_PACKETS (int)
Accounting output packets
RADIUS_ACCT_TERMINATE_CAUSE (int)

Accounting terminate cause, one of:

RADIUS_TERM_USER_REQUEST
RADIUS_TERM_LOST_CARRIER
RADIUS_TERM_LOST_SERVICE
RADIUS_TERM_IDLE_TIMEOUT
RADIUS_TERM_SESSION_TIMEOUT
RADIUS_TERM_ADMIN_RESET
RADIUS_TERM_ADMIN_REBOOT
RADIUS_TERM_PORT_ERROR
RADIUS_TERM_NAS_ERROR
RADIUS_TERM_NAS_REQUEST
RADIUS_TERM_NAS_REBOOT
RADIUS_TERM_PORT_UNNEEDED
RADIUS_TERM_PORT_PREEMPTED
RADIUS_TERM_PORT_SUSPENDED
RADIUS_TERM_SERVICE_UNAVAILABLE
RADIUS_TERM_CALLBACK
RADIUS_TERM_USER_ERROR
RADIUS_TERM_HOST_REQUEST

RADIUS_ACCT_MULTI_SESSION_ID (string)
Accounting multi session ID
RADIUS_ACCT_LINK_COUNT (int)
Accounting link count
RADIUS_VENDOR_MICROSOFT (int)

Microsoft specific vendor attributes (» RFC 2548), one of:

RADIUS_MICROSOFT_MS_CHAP_RESPONSE
RADIUS_MICROSOFT_MS_CHAP_ERROR
RADIUS_MICROSOFT_MS_CHAP_PW_1
RADIUS_MICROSOFT_MS_CHAP_PW_2
RADIUS_MICROSOFT_MS_CHAP_LM_ENC_PW
RADIUS_MICROSOFT_MS_CHAP_NT_ENC_PW
RADIUS_MICROSOFT_MS_MPPE_ENCRYPTION_POLICY
RADIUS_MICROSOFT_MS_MPPE_ENCRYPTION_TYPES
RADIUS_MICROSOFT_MS_RAS_VENDOR
RADIUS_MICROSOFT_MS_CHAP_DOMAIN
RADIUS_MICROSOFT_MS_CHAP_CHALLENGE
RADIUS_MICROSOFT_MS_CHAP_MPPE_KEYS
RADIUS_MICROSOFT_MS_BAP_USAGE
RADIUS_MICROSOFT_MS_LINK_UTILIZATION_THRESHOLD
RADIUS_MICROSOFT_MS_LINK_DROP_TIME_LIMIT
RADIUS_MICROSOFT_MS_MPPE_SEND_KEY
RADIUS_MICROSOFT_MS_MPPE_RECV_KEY
RADIUS_MICROSOFT_MS_RAS_VERSION
RADIUS_MICROSOFT_MS_OLD_ARAP_PASSWORD
RADIUS_MICROSOFT_MS_NEW_ARAP_PASSWORD
RADIUS_MICROSOFT_MS_ARAP_PASSWORD_CHANGE_REASON
RADIUS_MICROSOFT_MS_FILTER
RADIUS_MICROSOFT_MS_ACCT_AUTH_TYPE
RADIUS_MICROSOFT_MS_ACCT_EAP_TYPE
RADIUS_MICROSOFT_MS_CHAP2_RESPONSE
RADIUS_MICROSOFT_MS_CHAP2_SUCCESS
RADIUS_MICROSOFT_MS_CHAP2_PW
RADIUS_MICROSOFT_MS_PRIMARY_DNS_SERVER
RADIUS_MICROSOFT_MS_SECONDARY_DNS_SERVER
RADIUS_MICROSOFT_MS_PRIMARY_NBNS_SERVER
RADIUS_MICROSOFT_MS_SECONDARY_NBNS_SERVER
RADIUS_MICROSOFT_MS_ARAP_CHALLENGE

Quickstart

Howto start?

  • get a radius resource
  • configure the library
  • create the request
  • put attributes
  • send the request
  • receive attributes
  • close the radius resource (optional)
Take also a look at the examples in this package.

The package contains an example php script. This script demonstrates howto authenticate with radius using PAP or CHAP (md5). If you authenticate with Microsoft Radius servers then its not possible to use CHAP (md5). If you would like to authenticate with Microsoft Servers you have to use MS-CHAPv1 or MS-CHAPv2, but its more complicated, because you need md4, sha1 and des to generate the right data. The enclosed examples demonstrate all authentication-methods, including MS-CHAPv1 and MS-CHAPv2. To get the MS-CHAP to work you need the mcrypt and the mhash extension, starting with version 1.2 of the package, the mcrypt extension is no longer needed.

Contact Information

If you have comments, bugfixes, enhancements or want to help to develop this you can send me a mail at » mbretter@php.net. Binaries for Windows can be downloaded from » here.

Obsah

radius_acct_open — Creates a Radius handle for accounting
radius_add_server — Adds a server
radius_auth_open — Creates a Radius handle for authentication
radius_close — Frees all ressources
radius_config — Causes the library to read the given configuration file
radius_create_request — Create accounting or authentication request
radius_cvt_addr — Converts raw data to IP-Address
radius_cvt_int — Converts raw data to integer
radius_cvt_string — Converts raw data to string
radius_demangle_mppe_key — Derives mppe-keys from mangled data
radius_demangle — Demangles data
radius_get_attr — Extracts an attribute
radius_get_vendor_attr — Extracts a vendor specific attribute
radius_put_addr — Attaches an IP-Address attribute
radius_put_attr — Attaches a binary attribute
radius_put_int — Attaches an integer attribute
radius_put_string — Attaches a string attribute
radius_put_vendor_addr — Attaches a vendor specific IP-Address attribute
radius_put_vendor_attr — Attaches a vendor specific binary attribute
radius_put_vendor_int — Attaches a vendor specific integer attribute
radius_put_vendor_string — Attaches a vendor specific string attribute
radius_request_authenticator — Returns the request authenticator
radius_send_request — Sends the request and waites for a reply
radius_server_secret — Returns the shared secret
radius_strerror — Returns an error message
Předcházející | Nahoru | Další
qdom_tree | Domů | radius_acct_open


RPM Header Reading Funkce

Předcházející VI. Reference funkcí Další

CXXXVIII. RPM Header Reading Funkce

Úvod

This module allows you to read the meta information stored in the headers of a » RedHat Package Manager (» RPM) file.

Požadavky

The RPMReader extension requires PHP 5.

Instalace

Toto rozšíření » PECL není přibaleno k PHP.

Informace o instalaci tohoto PECL rozšíření lze najít v kapitole manuálu nazvané Instalace rozšíření PECL. Další informace, jako nové verze, soubory ke stažení, zdrojové soubory, správcovské informace a CHANGELOG, lze najít zde: » http://pecl.php.net/package/rpmreader.

Typy prostředků

There is one resource type used by the RPMReader module. The resource is a file pointer which identifies the RPM file with which to work.

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

The following list of constants are used to obtain information using the rpm_get_tag() function. These constants represent the tag number to be retrieved from the RPM file's header section. Descriptions are given below as to what data the tag number constants reference.

RPMREADER_MINIMUM (integer)
The minimum valid value of any RPM tag number.
RPMREADER_NAME (integer)
The name of the RPM package.
RPMREADER_VERSION (integer)
The version of the RPM package.
RPMREADER_RELEASE (integer)
The release of the RPM package.
RPMREADER_EPOCH (integer)
RPMREADER_SERIAL (integer)
RPMREADER_SUMMARY (integer)
The summary text of the RPM package.
RPMREADER_DESCRIPTION (integer)
The full description text of the RPM package.
RPMREADER_BUILDTIME (integer)
The date and time when the RPM package was built.
RPMREADER_BUILDHOST (integer)
The name of the host on which the RPM package was built.
RPMREADER_INSTALLTIME (integer)
RPMREADER_SIZE (integer)
The size of the RPM package.
RPMREADER_DISTRIBUTION (integer)
RPMREADER_VENDOR (integer)
RPMREADER_GIF (integer)
RPMREADER_XPM (integer)
RPMREADER_LICENSE (integer)
RPMREADER_COPYRIGHT (integer)
RPMREADER_PACKAGER (integer)
RPMREADER_GROUP (integer)
RPMREADER_SOURCE (integer)
RPMREADER_PATCH (integer)
RPMREADER_URL (integer)
RPMREADER_OS (integer)
RPMREADER_ARCH (integer)
RPMREADER_PREIN (integer)
RPMREADER_POSTIN (integer)
RPMREADER_PREUN (integer)
RPMREADER_POSTUN (integer)
RPMREADER_OLDFILENAMES (integer)
The list of files in an RPM package (deprecated format). The correct way is now to use a combination of 3 tags (RPMREADER_BASENAMES, RPMREADER_DIRINDEXES, RPMREADER_DIRNAMES) in what RPM now calls "CompressedFileNames". This tag is still used in older RPM files that did not use the "CompressedFileNames" method and is maintained for backward compatibility.
RPMREADER_FILESIZES (integer)
RPMREADER_FILESTATES (integer)
RPMREADER_FILEMODES (integer)
RPMREADER_FILERDEVS (integer)
RPMREADER_FILEMTIMES (integer)
RPMREADER_FILEMD5S (integer)
RPMREADER_FILELINKTOS (integer)
RPMREADER_FILEFLAGS (integer)
RPMREADER_FILEUSERNAME (integer)
RPMREADER_FILEGROUPNAME (integer)
RPMREADER_ICON (integer)
RPMREADER_SOURCERPM (integer)
RPMREADER_FILEVERIFYFLAGS (integer)
RPMREADER_ARCHIVESIZE (integer)
RPMREADER_PROVIDENAME (integer)
RPMREADER_PROVIDES (integer)
RPMREADER_REQUIREFLAGS (integer)
RPMREADER_REQUIRENAME (integer)
RPMREADER_REQUIREVERSION (integer)
RPMREADER_CONFLICTFLAGS (integer)
RPMREADER_CONFLICTNAME (integer)
RPMREADER_CONFLICTVERSION (integer)
RPMREADER_EXCLUDEARCH (integer)
RPMREADER_EXCLUDEOS (integer)
RPMREADER_EXCLUSIVEARCH (integer)
RPMREADER_EXCLUSIVEOS (integer)
RPMREADER_RPMVERSION (integer)
RPMREADER_TRIGGERSCRIPTS (integer)
RPMREADER_TRIGGERNAME (integer)
RPMREADER_TRIGGERVERSION (integer)
RPMREADER_TRIGGERFLAGS (integer)
RPMREADER_TRIGGERINDEX (integer)
RPMREADER_VERIFYSCRIPT (integer)
RPMREADER_CHANGELOGTIME (integer)
The list of dates from changelog entries.
RPMREADER_CHANGELOGNAME (integer)
The list of changelog entry names.
RPMREADER_CHANGELOGTEXT (integer)
The list of the text from changelog entries.
RPMREADER_PREINPROG (integer)
RPMREADER_POSTINPROG (integer)
RPMREADER_PREUNPROG (integer)
RPMREADER_POSTUNPROG (integer)
RPMREADER_BUILDARCHS (integer)
RPMREADER_OBSOLETENAME (integer)
RPMREADER_OBSOLETES (integer)
RPMREADER_VERIFYSCRIPTPROG (integer)
RPMREADER_TRIGGERSCRIPTPROG (integer)
RPMREADER_COOKIE (integer)
RPMREADER_FILEDEVICES (integer)
RPMREADER_FILEINODES (integer)
RPMREADER_FILELANGS (integer)
RPMREADER_PREFIXES (integer)
RPMREADER_INSTPREFIXES (integer)
RPMREADER_PROVIDEFLAGS (integer)
RPMREADER_PROVIDEVERSION (integer)
RPMREADER_OBSOLETEFLAGS (integer)
RPMREADER_OBSOLETEVERSION (integer)
RPMREADER_DIRINDEXES (integer)
The list of indices that relate directory names to files in the RPM package. This tag is used in conjunction with RPMREADER_BASENAMES and RPMREADER_DIRNAMES to reconstruct filenames in the RPM package stored with the new "CompressedFileNames" method in RPM.
RPMREADER_BASENAMES (integer)
The list of the names of files in the RPM package without path information. This tag is used in conjunction with RPMREADER_DIRINDEXES and RPMREADER_DIRNAMES to reconstruct filenames in the RPM package stored with the new "CompressedFileNames" method in RPM.
RPMREADER_DIRNAMES (integer)
The list of directory names used by files in the RPM package. This tag is used in conjunction with RPMREADER_BASENAMES and RPMREADER_DIRINDEXES to reconstruct filenames in the RPM package stored with the new "CompressedFileNames" method in RPM.
RPMREADER_OPTFLAGS (integer)
RPMREADER_DISTURL (integer)
RPMREADER_PAYLOADFORMAT (integer)
RPMREADER_PAYLOADCOMPRESSOR (integer)
RPMREADER_PAYLOADFLAGS (integer)
RPMREADER_INSTALLCOLOR (integer)
RPMREADER_INSTALLTID (integer)
RPMREADER_REMOVETID (integer)
RPMREADER_RHNPLATFORM (integer)
RPMREADER_PLATFORM (integer)
RPMREADER_PATCHESNAME (integer)
RPMREADER_PATCHESFLAGS (integer)
RPMREADER_PATCHESVERSION (integer)
RPMREADER_CACHECTIME (integer)
RPMREADER_CACHEPKGPATH (integer)
RPMREADER_CACHEPKGSIZE (integer)
RPMREADER_CACHEPKGMTIME (integer)
RPMREADER_FILECOLORS (integer)
RPMREADER_FILECLASS (integer)
RPMREADER_CLASSDICT (integer)
RPMREADER_FILEDEPENDSX (integer)
RPMREADER_FILEDEPENDSN (integer)
RPMREADER_DEPENDSDICT (integer)
RPMREADER_SOURCEPKGID (integer)
RPMREADER_FILECONTEXTS (integer)
RPMREADER_FSCONTEXTS (integer)
RPMREADER_RECONTEXTS (integer)
RPMREADER_POLICIES (integer)
RPMREADER_MAXIMUM (integer)
The maximum valid value of any RPM tag number.

Příklady

This example will open an RPM file and read the name, version, and release from the RPM file, echo the results, and close the RPM file.

Příklad 1857. Basic RPMReader Example

<?php

$filename = "/path/to/file.rpm";

// open file
$rpmr = rpm_open($filename);

// get "Name" tag
$name = rpm_get_tag($rpmr, RPMREADER_NAME);

// get "Version" tag
$ver = rpm_get_tag($rpmr, RPMREADER_VERSION);

// get "Release" tag
$rel = rpm_get_tag($rpmr, RPMREADER_RELEASE);

echo "$name-$ver-$rel<br>\n";

// close file
rpm_close($rpmr);

?>

Obsah

rpm_close — Closes an RPM file
rpm_get_tag — Retrieves a header tag from an RPM file
rpm_is_valid — Tests a filename for validity as an RPM file
rpm_open — Opens an RPM file
rpm_version — Returns a string representing the current version of the rpmreader extension
Předcházející | Nahoru | Další
recode | Domů | rpm_close


runkit Functions

Předcházející VI. Reference funkcí Další

CXXXIX. runkit Functions

Úvod

The runkit extension provides means to modify constants, user-defined functions, and user-defined classes. It also provides for custom superglobal variables and embeddable sub-interpreters via sandboxing.

Informace o instalaci tohoto PECL rozšíření lze najít v kapitole manuálu nazvané Instalace rozšíření PECL. Další informace, jako nové verze, soubory ke stažení, zdrojové soubory, správcovské informace a CHANGELOG, lze najít zde: » http://pecl.php.net/package/runkit.

This package is meant as a feature added replacement for the » classkit package. When compiled with the --enable-runkit=classkit option to ./configure, it will export classkit compatible function definitions and constants.

Instalace

Toto rozšíření » PECL není přibaleno k PHP.

Informace o instalaci tohoto PECL rozšíření lze najít v kapitole manuálu nazvané Instalace rozšíření PECL. Další informace, jako nové verze, soubory ke stažení, zdrojové soubory, správcovské informace a CHANGELOG, lze najít zde: » http://pecl.php.net/package/runkit.

Tuto DLL knihovnu pro rozšíření PECL můžete stahovat ze stránky » PHP Downloads nebo z » http://snaps.php.net/.

Požadavky

Modifying Constants, Functions, Classes, and Methods works with all releases of PHP 4 and PHP 5. No special requirements are necessary.

Custom Superglobals are only available in PHP 4.2.0 or later.

Sandboxing requires PHP 5.1.0 or later, or PHP 5.0.0 with a special TSRM patch applied. Regardless of which version of PHP is in use it must be compiled with the --enable-maintainer-zts option. See the README file in the runkit package for additional information.

Konfigurace běhu

Chování těchto funkcí je ovlivněno nastavením parametrů v php.ini.

Tabulka 263. Runkit Configuration Options

Name | Default | Changeable | Changelog
runkit.superglobal | "" | PHP_INI_PERDIR |
runkit.internal_override | "0" | PHP_INI_SYSTEM |

Pro další detaily a definice konstant PHP_INI_*, viz dokumentace k ini_set().

Zde je stručný popis konfiguračních direktiv.

runkit.superglobal string

Comma-separated list of variable names to be treated as superglobals. This value should be set in the systemwide php.ini file, but may work in perdir configuration contexts depending on your SAPI.

Příklad 1863. Custom Superglobals with runkit.superglobal=_FOO,_BAR in php.ini

<?php
function show_values() {
  echo "Foo is $_FOO\n";
  echo "Bar is $_BAR\n";
  echo "Baz is $_BAZ\n";
}

$_FOO = 'foo';
$_BAR = 'bar';
$_BAZ = 'baz';

/* Displays foo and bar, but not baz */
show_values();
?>

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

RUNKIT_IMPORT_FUNCTIONS (integer)
runkit_import() flag indicating that normal functions should be imported from the specified file.
RUNKIT_IMPORT_CLASS_METHODS (integer)
runkit_import() flag indicating that class methods should be imported from the specified file.
RUNKIT_IMPORT_CLASS_CONSTS (integer)
runkit_import() flag indicating that class constants should be imported from the specified file. Note that this flag is only meaningful in PHP versions 5.1.0 and above.
RUNKIT_IMPORT_CLASS_PROPS (integer)
runkit_import() flag indicating that class standard properties should be imported from the specified file.
RUNKIT_IMPORT_CLASSES (integer)
runkit_import() flag representing a bitwise OR of the RUNKIT_IMPORT_CLASS_* constants.
RUNKIT_IMPORT_OVERRIDE (integer)
runkit_import() flag indicating that if any of the imported functions, methods, constants, or properties already exist, they should be replaced with the new definitions. If this flag is not set, then any imported definitions which already exist will be discarded.
RUNKIT_ACC_PUBLIC (integer)
PHP 5 specific flag to runkit_method_add()
RUNKIT_ACC_PROTECTED (integer)
PHP 5 specific flag to runkit_method_add()
RUNKIT_ACC_PRIVATE (integer)
PHP 5 specific flag to runkit_method_add()
CLASSKIT_ACC_PUBLIC (integer)
PHP 5 specific flag to classkit_method_add() Only defined when classkit compatibility is enabled.
CLASSKIT_ACC_PROTECTED (integer)
PHP 5 specific flag to classkit_method_add() Only defined when classkit compatibility is enabled.
CLASSKIT_ACC_PRIVATE (integer)
PHP 5 specific flag to classkit_method_add() Only defined when classkit compatibility is enabled.
CLASSKIT_AGGREGATE_OVERRIDE (integer)
PHP 5 specific flag to classkit_import() Only defined when classkit compatibility is enabled.
RUNKIT_VERSION (string)
Defined to the current version of the runkit package.
CLASSKIT_VERSION (string)
Defined to the current version of the runkit package. Only defined when classkit compatibility is enabled.

Obsah

Runkit_Sandbox — Runkit Sandbox Class -- PHP Virtual Machine
Runkit_Sandbox_Parent — Runkit Anti-Sandbox Class
runkit_class_adopt — Convert a base class to an inherited class, add ancestral methods when appropriate
runkit_class_emancipate — Convert an inherited class to a base class, removes any method whose scope is ancestral
runkit_constant_add — Similar to define(), but allows defining in class definitions as well
runkit_constant_redefine — Redefine an already defined constant
runkit_constant_remove — Remove/Delete an already defined constant
runkit_function_add — Add a new function, similar to create_function()
runkit_function_copy — Copy a function to a new function name
runkit_function_redefine — Replace a function definition with a new implementation
runkit_function_remove — Remove a function definition
runkit_function_rename — Change a function's name
runkit_import — Process a PHP file importing function and class definitions, overwriting where appropriate
runkit_lint_file — Check the PHP syntax of the specified file
runkit_lint — Check the PHP syntax of the specified php code
runkit_method_add — Dynamically adds a new method to a given class
runkit_method_copy — Copies a method from class to another
runkit_method_redefine — Dynamically changes the code of the given method
runkit_method_remove — Dynamically removes the given method
runkit_method_rename — Dynamically changes the name of the given method
runkit_return_value_used — Determines if the current functions return value will be used
runkit_sandbox_output_handler — Specify a function to capture and/or process output from a runkit sandbox
runkit_superglobals — Return numerically indexed array of registered superglobals
Předcházející | Nahoru | Další
rpm_version | Domů | Runkit_Sandbox


SAM - Simple Asynchronous Messaging

Předcházející VI. Reference funkcí Další

CXL. SAM - Simple Asynchronous Messaging

Úvod

This extension provides access to the functionality of messaging and queueing systems, such as the IBM WebSphere MQSeries family of products, from PHP scripts. The interface is designed to make it extremely simple to do the more commonly required tasks such as deliver simple text messages to queues while still allowing skilled users to do more complex messaging operations. For many users the complexities of setting up numerous options can be simply ignored.

The SAM extension is a framework that provides a very simple API that can be used to access a number of messaging middleware systems. Currently the package includes built-in support for the MQTT (MQ Telemetry Transport) messaging protocol and support for the IBM Messaging and Queuing middleware products. SAM is designed to be readily extended to support other messaging systems and extension modules may be written in C or PHP.

Instalace

The SAM framework and MQTT support can be built and used without any other prerequisites. Support for protocols other than MQTT is provided via a set of libraries and some client side code referred to as XMS.

If you only intend to use the built-in MQTT support then you can build and configure SAM as an extension or simply refer to "php_sam.php" with a "requires" or "requires_once" clause in your PHP script. In this case you need only install the code without building the extension using the pear installer:

      pecl install -B SAM

Prerequisites

The SAM extension interfaces to the IBM Messaging and Queuing middleware products using a set of libraries and some client side code referred to as XMS. This package is available as a free download in the guise of IBM support pack IA94. There is a description of this package and download links in the article » Introducing XMS - The IBM Message Service API.

If you intend to use SAM to access the Messaging and Queuing infrastructure within WebSphere MQ then you will also need to have installed a local MQ queue manager or installed the WebSphere MQ clients package. The clients package is freely available as a support pack (» MQC6).

If you are only aiming to experiment with sending messages to and from WebSphere Application Server queues using the WebSphere Platform Messaging protocol (WPM) then you do not need to install the MQC6 package.

After installing these packages you will need to ensure the XMS binary and, if you are using it, the MQ client bin directory are included in the PATH environment variable so that Apache and PHP can find the dependent .DLLs/libraries.

Linux installation steps

The sam extension is supplied as a PECL module, which you should be able to download and install in one step as follows:

pecl install sam
(Depending on your php environment, you will probably need to be root to do this.)

Make sure that the module is loaded by PHP, by adding following line to php.ini:

extension=sam.so
If you intend to use the XMS support to access the IBM Messaging and Queuing family you must also enable the SAM XMS extension.

extension=sam_xms.so

If you cannot use the PEAR installer, you can download the extension and build it manually:

pear download sam          #downloads sam-<version>.tgz
tar -xzf sam-<version>.tgz
cd sam-<version>
phpize
./configure
make
make install               #you may need to be root for this step

To work with the very latest source, you'll need to extract it from cvs and build manually as above.

Windows installation steps

You will probably need to build the sam extension for Windows as there are only a limited range of pre-built binaries available from the SAM website. The extension can be built using the standard Windows extension build procedures.

You will need the PHP source tree for the version of PHP you wish to build the SAM extension against which you can obtain from php.net. This should be unpacked into a working directory of your choice.

You will also need the libraries and headers used by PHP extensions available from http://www.php.net/extra/win32build.zip and this should be unzipped so that is in your working directory.

You should have something like:

c:\php-build\-
              |
              |---php-5.0.5--|---build
              |              |---ext
              |              |--- ...
              |
              |---win32build--|---bin
                              |---include
                              |---lib

You will need a compiler such as the free version of Visual Studio C++ Express from the Microsoft web site. Also you need the Microsoft Windows Platform SDK which again can be downloaded from the Microsoft web site.

Obtain the SAM extension source using pear (pecl download sam) or by using CVS and copy the files to a new "sam" directory under the "ext" directory in your PHP source tree.

To build the extension open a build environment window by going to the start menu->all programs->microsoft platform SDK for windows-> open build environment window->windows 200 build environment-> set windows 2000 build environment (retail)

This should open a command prompt with all the environment variables set up to access the platform SDK etc. You then need to set the environment variables for Visual Studio by issuing the command "vcvars32.bat" in the window.

Change directory to your working directory e.g. cd c:\php-build. Then make sure the win32build tools are accessible by adding them to the PATH environment variable:

set PATH=..\win32build\bin;%PATH%

Run the buildconf.bat command. This should rebuild the configure.js file.

Run the cscript command with the appropriate options. To build just the SAM extension framework and MQTT support use:

cscript /nologo configure.js --with-sam
To build the SAM framework and the XMS support use:

cscript /nologo configure.js --with-sam --with-sam_xms="c:\program files\ibm\xms"

The additional parameter passed for sam_xms is the installation path to the XMS libraries and runtime that were installed as described under prerequisites at the top of this page.

You can specify whatever other cscript parameters you require to include or exclude items from the php build or select options.

Assuming all has gone well so far you can now finally run a make for the SAM framework!

nmake php_sam.dll
Also if you are using the XMS support you must make the sam_xms extensions:

nmake php_sam_xms.dll

If you have used Visual Studio 2005 to build the DLLs please see below for additional steps that must be carried out before proceeding further.

The DLLs created (php_sam.dll and optionally php_sam_xms.dll) can now be copied to the subdirectory appropriate for your PHP set-up. Make sure that the module(s) are loaded by PHP, by adding following line to php.ini :

extension=php_sam.dll
If you intend to use the XMS support to access the IBM Messgaing and Queuing family you must also enable the SAM XMS extension.

extension=php_sam_xms.dll

Additional steps for Visual Studio 2005

If you build the SAM extension with the Microsoft Visual Studio 2005 compiler and tools you need to perform an additional step in the build process to ensure the php_sam.dll is able to link with the C runtime libraries at runtime. This step includes the dependancy manifest into the DLL. Switch to the directory where the php_sam.dll has been generated (usually Release_TS or Debug_TS below the php source directory) and issue the following magic incantation:

mt.exe -manifest php_sam.dll.manifest -outputresource:php_sam.dll;2
If you are using the XMS capabilities you will need to do the same with the SAM XMS DLL:

mt.exe -manifest php_sam_xms.dll.manifest -outputresource:php_sam_xms.dll;2

If you build the SAM extension using the compiler and libaries from Microsoft Visual Studio 2005 you will also need to ensure that the runtime components are installed on the system on which you intend to use SAM. This can be accomplished by installing Visual Studio 2005 or by using the freely distributable » runtime package.

Protocol support and mapping

The SAM framework can be extended to support other messaging protocols and connection mechanisms. To add support for a new protocol or connection library a support class has to be defined, either as a C extension or as a PHP script, and a "factory" script must be created. The support class must implement all the methods of the SAMConnection class though it should not inherit from SAMConnection. The factory script will be called by the SAM framework to create an instance of the implemented class. The way SAM chooses which factory to call is based on the protocol specified as the first parameter of the "connect" call.

By default the built-in MQTT support will be used if a connect call specifies a protocol of SAM_MQTT ("mqtt"), for any other protocol SAM will attempt to use the XMS support extension. To add support for additional protocols or to modify the default behavior entries may be added to php.ini in the [sam] section. The default mapping is equivalent to the following entries:

[sam]
sam.factory.mqtt=mqtt
sam.factory.wmq=xms
sam.factory.wmq:client=xms
sam.factory.wmq:bindings=xms
sam.factory.wpm=xms
sam.factory.rtt=xms
As can be seen from these examples the entries take the form of "sam.factory.pppp=xxx" where pppp is the protocol string specified on the connect call and xxx is a factory suffix. Note: SAM defines constants for these protocol strings such that SAM_WMQ=wmq, SAM_WPM=wpm, SAM_RTT=rtt, SAM_MQTT=mqtt, etc.

When identifying the support code to use on a connect call SAM looks up the protocol name in the php.ini entries and then invokes a factory script named sam_factory_xxx.php. If no entry is found the support will default to XMS.

API Usage

Connections

In order to perform any messaging and queueing functions a connection must be established with a messaging server by creating a SAMConnection object and calling its "connect" method, with a set of connection properties, to connect the PHP script to the messaging server. Until such time as the SAMConnection object is destroyed the connection will be maintained and available for use. All SAMConnection objects are destroyed when the PHP script exits.

A set of default properties may be used in connecting to a messaging server but as a minimum the PHP script must specify a protocol to be used.

Příklad 1882. Creating a connection and connecting to a remote WebSphere MQSeries Messaging Server

<?php
   $conn = new SAMConnection();
   $conn->connect(SAM_WMQ, array(SAM_HOST => 'myhost.mycompany.com',
                                 SAM_PORT => 1506,
                                 SAM_BROKER => 'mybroker'));
?>

Příklad 1883. Creating a connection and connecting to a remote WebSphere Application Server

<?php
   $conn = new SAMConnection();
   $conn->connect(SAM_WPM, array(SAM_ENDPOINTS => 'localhost:7278:BootstrapBasicMessaging',
                                 SAM_BUS => 'Bus1',
                                 SAM_TARGETCHAIN => 'InboundBasicMessaging'));
?>

Příklad 1884. Creating a connection and connecting to an MQTT server

<?php
   $conn = new SAMConnection();
   $conn->connect(SAM_MQTT, array(SAM_HOST => 'myhost.mycompany.com',
                                 SAM_PORT => 1883));
?>

Messages

Messages sent to and received from queues are represented by the SAMMessage object. The SAMMessage object encapsulates the body of the message (if one exists) and the header properties associated with the message. A SAMMessage object is either supplied as a parameter to a messaging operation or returned as a result.

Příklad 1885. Creating a message with a simple text body

<?php
$msg = new SAMMessage('This is a simple text message');
?>

Messages may have header properties associated with them that provide control over the transport of the message or further information to the receiving application. By default message properties are delivered to the underlying messaging system as strings and in this case they may be set with the following simple syntax:

Příklad 1886. Setting a text format property using the default syntax

<?php
   $msg->header->myPropertyName = 'textData';
?>

If it is desired to pass type information an alternative syntax may be used where the value and the type hint are passed in an associative array:

Příklad 1887. Setting a property using a type hint

<?php
   $msg->header->myPropertyName = array(3.14159, SAM_FLOAT);
?>

Properties may also be extracted from the header of a message.

Příklad 1888. Retrieving a property from a message header

<?php
   $myProperty = $msg->header->myPropertyName;
?>

Messaging operations

All messaging operations are performed through calls to methods on the connection object. To add a message to a queue the "send" method is used, to obtain a message from a queue the "receive" method is used. Other methods provide publish and subscribe functionality and control of transaction boundaries.

Příklad 1889. Adding a message to a queue and receiving a response

<?php
$msg = new SAMMessage('This is a simple text message');
$msg->header->SAM_REPLY_TO = 'queue://receive/test';
$correlid = $conn->send('queue://send/test', $msg);

if (!$correlid) {
  // The Send failed!
  echo "Send failed ($conn->errno) $conn->error";
} else {
  $resp = $conn->receive('queue://receive/test', array(SAM_CORRELID => $correlid));
}
?>

Publish/Subscribe and suscriptions to topics

SAM allows messages to be sent either to queues or, for WebSphere MQ and WPM, to publish/subscribe topics. A topic desintation is specified to SAM in the usual way, i.e. in the form 'topic://fred', rather than the form 'queue://AQUEUE' used for point to point operation. To use publish/subscribe it is simply necessary to specify the correct broker name on the SAMConnect "connect" call and the desired topic in the destination argument to the SAMConnect "send" and "receive" calls. The PHP interface is otherwise identical to the point to point model.

By default, SAM creates non-durable subscriptions when using publish/subscribe. This means that if a client application is inactive when messages are published to a topic, then it will not receive them when it subsequently restarted. SAM does also allow durable subscriptions to be made to topics when using WPM or WebSphere MQ publish/subscribe. The purpose of these subscriptions is to allow data to be received by a client application even if that client was not active at the time the data was published.

Durable subscriptions are specified by using the SAMConnect "subscribe" call. This method takes the destination topic as an input parameter and returns a subscription identifier that may be used on subsequent "receive" calls. When the subscription is no longer required the SAMConnection "unsubscribe" method should be used to delete the subscription.

Příklad 1890. Creating a durable subscription to a topic

<?php

$subName = $conn->subscribe('topic://A');

if (!$subName) {
   echo "Subscribe failed";
} else {
   # Subscribe was OK
   // ...
}
?>

Příklad 1891. Subscribing to a topic using a WebSphere Platform Messaging (WPM) server

<?php
$conn = new SAMConnection();
// Note: For pub/sub on WPM, when connecting the name of a messaging engine
//   to hold the durable subscription (SAM_WPM_DUR_SUB_HOME) must be specified.
$conn->connect(SAM_WMQ, array(SAM_ENDPOINTS => 'localhost:7278:BootstrapBasicMessaging',
                              SAM_BUS => 'Bus1',
                              SAM_TARGETCHAIN => 'InboundBasicMessaging'
                              SAM_WPM_DUR_SUB_HOME => 'MyMachineNode01.server1-Bus1'));

$subName = $conn->subscribe('topic://A');

if (!$subName) {
   echo "Subscribe failed";
} else {
   # Subscribe was OK
   // ...
}
?>

Příklad 1892. Receiving published data using a durable subscription

<?php

$msg = $conn->receive($subName);
if ($msg) {
   echo "Received a message OK";
} else {
   echo "The receive failed";
}

?>

Příklad 1893. Deleting a durable subscription to a topic

<?php

if (!$conn->unsubscribe($subName)) {
   echo "Unsubscribe failed";
}

?>

Error handling

All SAMConnection methods that provide access to messaging operations return FALSE if an error occurred in processing the request. In addition the SAMConnection object has two properties, "errno" and "error", that provide respectively the error number and text description of the last error to occur on the connection.

Příklad 1894. Handling an error from a method that returns no result

<?php
   if (!$conn->commit()) {
     // The commit failed!
     echo "Commit failed ($conn->errno) $conn->error";
   }
?>

Příklad 1895. Handling an error from a method that returns a result

<?php
$correlid = $conn->send('queue://send/test', $msg);

if (!$correlid) {
  // The Send failed!
  echo "Send failed ($conn->errno) $conn->error";
} else {
  ...
}
?>

Předdefinované třídy

SAMConnection

Object representing a connection to a Messaging Server

Konstruktory

  • new SAMConnection - construct a new connection object to allow connection to a messaging infrastructure.

Metody

  • commit - a method that commits (successfully completes) an in-flight unit of work.

  • connect - a method that connects a PHP script to a messaging server.

  • disconnect - a method that disconnects a PHP script from a messaging server.

  • isConnected - a method that checks whether a PHP script is connected to a messaging server.

  • peek - a method that receives a message from a queue without removing it from the queue.

  • peekAll - a method that receives one or messages from a queue without removing them from the queue.

  • receive - a method that receives a message from a queue or subscription.

  • remove - a method that removes a message from a queue.

  • rollback - a method that cancels (rolls back) an in-flight unit of work.

  • send - a method that sends a message to a queue or posts to a topic

  • setDebug - a method that switches additional debugging output on or off

  • subscribe - a method that creates a subscription to one or more topics

  • unsubscribe - a method that destroys a subscription to one or more topics

Vlastnosti

  • errno - the numeric error code for the last encountered error on this connection. This property is set to 0 if the last operation was successful.

  • error - the text description for the last encountered error on this connection

SAMMessage

Object representing a message to be sent or received

Konstruktory

  • new SAMMessage - construct a new message.

Vlastnosti

  • body - the body of the message.

  • header - the header properties of the message.

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

SAM_AUTO (string)
Automatic behaviour
SAM_BOOLEAN (string)
Type specifier used when setting properties on SAM_Message objects.
SAM_BUS (string)
Connect attribute used to set the name of the enterprise service bus to connect to.
SAM_BYTE (string)
Type specifier used when setting properties on SAM_Message objects.
SAM_BYTES (string)
Message body type descriptor.
SAM_CORRELID (string)
Attribute used on receive, send and remove requests to identify specific messages.
SAM_DELIVERYMODE (string)
Message header property.
SAM_DOUBLE (string)
Type specifier used when setting properties on SAM_Message objects.
SAM_ENDPOINTS (string)
Connect attribute used to define the possible endpoints to connect to.
SAM_FLOAT (string)
Type specifier used when setting properties on SAM_Message objects.
SAM_HOST (string)
Connect attribute used to set the hostname of the required messaging server.
SAM_INT (string)
Type specifier used when setting properties on SAM_Message objects.
SAM_LONG (string)
Type specifier used when setting properties on SAM_Message objects.
SAM_MANUAL (string)
Manual (script controlled) behaviour
SAM_MESSAGEID (string)
Attribute used on receive and remove requests to identify specific messages.
SAM_MQTT (string)
Connect protocol definition for selecting the MQTT (MQ Telemetry Transport) protocol.
SAM_MQTT_CLEANSTART (bool)
Optional connect option to indicate to an MQTT server that all previous connection data for this client should be removed and that subscriptions should be deleted when the client disconnects explicitly or unexpectedly.
SAM_NON_PERSISTENT (string)
Connect attribute value used to request messages are not made persistent on the messaging server.
SAM_PASSWORD (string)
Connect attribute used to define the password to be used for the user account being used to connect to a messaging server that requires authorisation for connections.
SAM_PERSISTENT (string)
Connect attribute value used to request messages are made persistent on the messaging server to protect against loss of messages in the event of failure.
SAM_PORT (string)
Connect attribute used to set the port number on which to communicate with the messaging server.
SAM_PRIORITY (string)
Option name used on send requests to specify a delivery priority value.
SAM_REPLY_TO (string)
Message propery used to specify the queue identity on to which the script expects response or reply messages to be posted.
SAM_RTT (string)
Connect protocol definition for selecting the IBM Realtime Transport protocol for communication with a business integration messaging server.
SAM_STRING (string)
Type specifier used when setting properties on SAM_Message objects.
SAM_TARGETCHAIN (string)
Connection attribute used to set the required target chain identifier.
SAM_TEXT (string)
Message body type descriptor.
SAM_TIMETOLIVE (string)
Message send option name used to specify the length of time a message should be retained in milliseconds.
SAM_TRANSACTIONS (string)
Connection attribute used to set required transactional behaviour. May be set to SAM_AUTO (default) or SAM_MANUAL.
SAM_USERID (string)
Connect attribute used to define the account to being used to connect to a messaging server that requires authorisation for connections.
SAM_WAIT (string)
Receive property used to specify the wait timeout to be used when receiving a message from a queue or subscription.
SAM_WMQ (string)
Connect protocol definition for selecting the IBM WebSphere MQSeries protocol for communication with the desired messaging server.
SAM_WMQ_BINDINGS (string)
Connect protocol definition for selecting the IBM WebSphere MQSeries protocol for communication with a local messaging server.
SAM_WMQ_CLIENT (string)
Connect protocol definition for selecting the IBM WebSphere MQSeries protocol for communication with a remote messaging server.
SAM_WMQ_TARGET_CLIENT (string)
Option name used on send requests to specify the target client mode. This can either be default to 'jms' or 'mq'. The default is 'jms' which means an RFH2 header is sent with the message whereas the 'mq' setting means no RFH2 is included.
SAM_WPM (string)
Connect protocol definition for selecting the IBM WebSphere Platform Messaging protocol for communication with a WebSphere Application Server messaging server.

Obsah

SAMConnection->commit() — Commits (completes) the current unit of work.
SAMConnection->connect() — Establishes a connection to a Messaging Server
SAMConnection->__construct() — Creates a new connection to a Messaging Server
SAMConnection->disconnect() — Disconnects from a Messaging Server
SAMConnection->errno — Contains the unique numeric error code of the last executed SAM operation.
SAMConnection->error — Contains the text description of the last failed SAM operation.
SAMConnection->isConnected() — Queries whether a connection is established to a Messaging Server
SAMConnection->peek() — Read a message from a queue without removing it from the queue.
SAMConnection->peekAll() — Read one or more messages from a queue without removing it from the queue.
SAMConnection->receive() — Receive a message from a queue or subscription.
SAMConnection->remove() — Remove a message from a queue.
SAMConnection->rollback() — Cancels (rolls back) an in-flight unit of work.
SAMConnection->send() — Send a message to a queue or publish an item to a topic.
SAMConnection::setDebug() — Turn on or off additional debugging output.
SAMConnection->subscribe() — Create a subscription to a specified topic.
SAMConnection->unsubscribe() — Cancel a subscription to a specified topic.
SAMMessage->body — The body of the message.
SAMMessage->__construct() — Creates a new Message object
SAMMessage->header — The header properties of the message.
Předcházející | Nahoru | Další
runkit_superglobals | Domů | SAMConnection->commit()


Satellite CORBA klient extenze

Předcházející VI. Reference funkcí Další

CXLI. Satellite CORBA klient extenze

Varování

Toto rozšíření je EXPERIMENTÁLNÍ. Chování tohoto rozšíření, názvy funkcí a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může bez ohlášení změnit. Berte to v úvahu a používejte tento modul na vlastní nebezpečí.

Satellite extenze se používá pro přístup ke CORBA objektům. Vyžaduje idl_directory= položku v php.ini ukazující na cestu kde jsou všechny používané IDL soubory.

Obsah

OrbitEnum — Use CORBA enums
OrbitObject — Access CORBA objects
OrbitStruct — Use CORBA structs
satellite_caught_exception — Zjistit, jestli byla v předchozí funkci zachycena výjimka
satellite_exception_id — Zjistit repository id poslední výjimky
satellite_exception_value — Získat strukturu poslední výjimky
satellite_get_repository_id — NOT IMPLEMENTED
satellite_load_idl — Instruct the type manager to load an IDL file
satellite_object_to_string — Convert an object to its string representation
Předcházející | Nahoru | Další
SAMMessage->header | Domů | OrbitEnum


SCA Functions

Předcházející VI. Reference funkcí Další

CXLII. SCA Functions

Úvod

Varování

Toto rozšíření je EXPERIMENTÁLNÍ. Chování tohoto rozšíření, názvy funkcí a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může bez ohlášení změnit. Berte to v úvahu a používejte tento modul na vlastní nebezpečí.

SCA for PHP makes it possible for a PHP programmer to write reusable components, which can be called in a variety of ways, with an identical interface and with a minimum of fuss. At present components can call each other either locally or via Web services, but in the future it is expected that other ways will be possible. It provides the programmer with a way of doing this which will look as natural as possible in PHP.

SCA components use phpDocumentor-style (see http://www.phpdoc.org/) annotations to declare dependencies on other SCA components or Web services. The SCA for PHP runtime resolves these dependencies at runtime on behalf of the components, and thus allows the PHP programmer to focus on the business logic rather than on locating and obtaining references to dependencies.

The SCA for PHP programming model can be extended to support a number of service types, such as REST and Atompub. However, Web services (more accurately, WSDL defined, SOAP/HTTP services), are the only type currently specified.

Components also use annotations to define the interface which they expose as a service. The SCA for PHP runtime will automatically generate WSDL from these annotations, so that an SCA component is easily exposed as a web service. These annotations are a natural extension to those provided by phpDocumentor. Deploying a Web service can be as simple as placing a PHP component under the document root of a web server.

Components also use annotations to specify data structures (expressed using XML schema complex types) which are then handled using Service Data Objects (SDOs).

A PHP script which is not an SCA component and which contains no annotations can use the services of an SCA component. A PHP script or component can make calls to a web service that is not an SCA component, but using the same system of calls or annotations to obtain a reference.

First we show a single SCA component, ConvertedStockQuote which illustrates many of the features of SCA for PHP. It has one method, getQuote(), which given a stock "ticker" obtains a price quote for that stock, converted to a given currency. We shall be using this example as a basis for explaining the SCA for PHP throughout the rest of this document.

Příklad 1936. A sample SCA component

<?php

include "SCA/SCA.php";

/**
 * Calculate a stock price for a given ticker symbol in a given currency.
 *
 * @service
 * @binding.soap
 */
class ConvertedStockQuote {

    /**
     * The currency exchange rate service to use.
     *
     * @reference
     * @binding.php ../ExchangeRate/ExchangeRate.php
     */
    public $exchange_rate;

    /**
     * The stock quote service to use.
     *
     * @reference
     * @binding.soap ../StockQuote/StockQuote.wsdl
     */
    public $stock_quote;

    /**
     * Get a stock quote for a given ticker symbol in a given currency.
     *
     * @param string $ticker The ticker symbol.
     * @param string $currency What currency to convert the value to.
     * @return float The stock value is the target currency.
     */
    function getQuote($ticker, $currency)
    {
        $quote  = $this->stock_quote->getQuote($ticker);
        $rate   = $this->exchange_rate->getRate($currency);
        return  $rate * $quote;
    }
}
?>

In this example, we see that an SCA component is implemented by a script containing a PHP class and includes SCA.php. The class contains a mixture of business logic and references to other components or services. In the illustrated getQuote() method there is only business logic, but it relies on the instance variables $stock_quote and $exchange_rate having been initialized. These refer to two other components and will be initialized by the SCA runtime with proxies for these two services, whenever this component executes. The annotations for these two services show one to be a local component, which will be called within the same PHP runtime, and one to be a remote component which will be called via a SOAP request. This component also exposes the getQuote() method both locally and as a web service, so it in turn can be called either locally or remotely.

Požadavky

If you want to use SCA to consume or produce Web services then you need PHP 5.2.0 or later, built with the soap extension enabled. If you just want to use local components, and do not wish to use the Web service bindings, then this version of SCA for PHP will also run with PHP 5.1.6.

Instalace

SCA is packaged along with SDO in one combined package on PECL. See http://www.php.net/sdo#sdo.installation for installing the SCA_SDO package from PECL. The SCA code must be on the include path of your PHP installation, for example if it is installed as /usr/local/lib/php/SCA, the include_path directive must include /usr/local/lib/php

Příklady

The examples in the subsequent sections illustrate the following aspects of PHP for SCA:

  • How PHP annotations are used to define PHP classes as SCA components, and how annotations are used to define the services.

  • How an SCA component can be exposed as a Web service

  • How an SCA component can consume a Web service, whether provided by another SCA component or by some other service which knows nothing of SCA

  • How an SCA component can call another SCA component locally (within the same process and on the same call stack)

  • How a client script which is not an SCA component can use the getService call to obtain a proxy for an SCA component.

  • How data structures such as Addresses, or Puchase Orders, are represented as Service Data Objects, and handled.

  • How SCA components are deployed, and in particular how and when WSDL is generated for a service.

  • How parameters are always passed by value (and not by reference) between components, even when the calls are local. This ensures that the semantics of a call do not change depending on the location of a component.

  • How positional parameters to a service are supported, even when the underlying WSDL is document literal wrapped, and naturally supports only named parameters.

  • How business and runtime exceptions are handled.

The structure of a Service Component

A service component is implemented by a class. To identify it as a service component, it contains an @service annotation. The SCA runtime will use the file name of the script to determine the component name, by convention. The class and script file must therefore share the same name.

PHP SCA components always expose a service, and there is no way for a component to be invoked other than to be called as a result of a Web service request, or called directly from another component or from a script. For this reason a valid PHP SCA component will always contain an @service annotation and at least one public method.

Each SCA Component requires that the SCA.php script is included. As well as containing the definition of the SCA class, this script contains executable PHP code that will run whenever the script is called, and which will be responsible for making the component behave as needed.

Výstraha

It is very important that if your file contains other includes, they come before the include for SCA.php. If there are includes after the include for SCA.php, they will not have been processed when the SCA runtime runs your class.

The example below illustrates this overall structure

Příklad 1937. The structure of an SCA for PHP component

<?php

// any includes

include "SCA/SCA.php";

/**
 * @service
 */

class ConvertedStockQuote {

       // instance variables, business logic, including at least one public method

}
?>

Obtaining a proxy for another Service Component

One SCA component can call the service provided by another SCA component. The service a component provides is made up of all of its public methods. SCA for PHP currently provides two ways for one component to call another: either locally (i.e. within the same PHP run-time, and on the same call stack) or remotely if the called component exposes a Web service binding.

In order for one component to call another, the calling component needs a proxy for the called component. This proxy is usually provided as an instance variable in the calling component, though proxies can also be obtained with the SCA::getService() call, as we shall see later. When a component is constructed, proxies are constructed for any instance variable which refer to another component, and these proxies are "injected" into the instance variables. Proxies are always used, whether the component is local or remote, in order to provide identical calling behavior between remote and local calls (for example, local calls are made to always pass data by-value). The proxies know how to locate the required component and to pass the calls made on to them.

Instance variables which are intended to hold proxies for services are indicated by the two PHPDocumentor-style annotations, @reference and @binding. Both annotations are placed in the documentation section for a class instance variable, as shown by the code below.

The @reference annotation before an instance variable indicates that that instance variable is to be initialized with a proxy to a component.

The @binding annotation has two forms @binding.php and @binding.soap, and indicates that the proxy is either for a local component or for a Web service respectively. For both @binding.php and @binding.soap, the annotation gives a target URI.

At the moment, with the annotation-based method of specifying dependencies, the only way to alter the intended target of a reference is to alter the annotation within the component.

In our ConvertedStockQuote example, the $exchange_rate instance variable will be initialized with a proxy to the local ExchangeRate component whenever an instance of the ConvertedStockQuote is constructed.

Příklad 1938. Obtaining a proxy for a local PHP class

<?php
   /**
     * The currency exchange rate service to use.
     *
     * @reference
     * @binding.php ../ExchangeRate/ExchangeRate.php
     */
    public $exchange_rate;
?>

For @binding.php, the URI identifies the location of the script containing the implementation of the component. The component will be called locally. The service provided is the set of public methods of the component. The URI must be a simple pathname, either absolute or relative. The component will be loaded with the PHP include directive, after testing to see if it is already loaded with class_exists(). If the URI is a relative path, it is resolved relative to the component containing the annotation. Note that this is different from the normal PHP behaviour where scripts would be looked for along the PHP include_path, This is intended to provide some location-independence for cross-component references.

If this ExchangeRate service were remote and to be called as a Web service, only the @binding line changes. Instead of giving the location of a PHP class, it gives the location of the WSDL describing the web service. In our example component, this is illustrated by the second reference:

Příklad 1939. Obtaining a proxy for a web service

<?php
/**
     * The stock quote service to use.
     *
     * @reference
     * @binding.soap ../StockQuote/StockQuote.wsdl
     */
    public $stock_quote;
?>

The StockQuote component will be called via a Web service request. In this case the URI for the WSDL can be a simple pathname, or may contain a PHP wrapper and begin, for example, with file:// or http://. In the event that it is a simple pathname, it can be absolute or relative, and if relative will be resolved relative to the component containing the annotation. Note that this is like the behaviour for @binding.php, and different from the normal PHP behaviour where the file would be looked for relative to the PHP current working directory, which would usually be the location of the first script to be called. This behaviour is intended to give consistency across the different bindings and to provide some location-independence for references between components.

Calling another Service Component

The ConvertedStockQuote example also calls the proxies for the two components to which it refers.

Příklad 1940. Calling services

<?php
$quote  = $this->stock_quote->getQuote($ticker);
$rate   = $this->exchange_rate->getRate($currency);
?>

The call to the StockQuote service is a call to a local service; the call to the ExchangeRate service is a call to a remote service. Note that the way the call is made looks the same regardless of whether the call is to a local service or a remote one.

The proxies which have been injected ensure that the way calls to components look and behave are the same way regardless of whether they are to a local or remote service, so that components are not sensitive to whether a call is to a local or a remote service. For example, the proxy for a local service takes copies of the arguments and passes only those copies, to ensure that calls are made to be pass-by-value, as they would be for a remote call. Also, the proxy for a remote service takes the arguments from a positional parameter list and ensures they are packaged properly in a SOAP request and converted back to a positional parameter list at the far end.

In the example above, the $ticker and $currency are clearly PHP scalar types. Components can pass the PHP scalar types string, integer, float and boolean, but data structures on service calls are always passed as Service Data Objects (SDOs). A later section describes how a component can create an SDO to pass on a local or Web service call, or how a component can create an SDO to return. The PHP SDO project documentation describes how to work with the SDO APIs (see the SDO pages.

Locating and calling services from a script which is not an SCA Component

SCA components obtain proxies for other components or services as instance variables annotated with @reference, but this is not possible for a script that is not itself also a component. A client script which is not a component must use the SCA::getService() static method to obtain a proxy for a service, whether local or remote. The getService() method takes a URI as the argument. Typically this is the location of a local PHP script containing a component, or of a wsdl file, and is used in exactly the same way as the targets of the @binding annotations described in the previous section: that is, relative URIs are resolved against the location of the client script and not against the PHP include_path or current working directory.

For example, a script that needed to obtain proxies for the ExchangeRate and StockQuote services but was not a component would use the getService() method as follows:

Příklad 1941. Obtaining a proxy using getService

<?php
$exchange_rate = SCA::getService('../ExchangeRate/ExchangeRate.php');
$stock_quote   = SCA::getService('../StockQuote/StockQuote.wsdl');
?>

Methods on services can then be called on the returned proxy, just as they can in a component.

Příklad 1942. Making calls on the proxy

<?php
$quote  = $stock_quote->getQuote($ticker);
$rate   = $exchange_rate->getRate($currency);
?>

Exposing a Service Component as a Web service

SCA for PHP can generate WSDL from the annotations within a service component, so that it can be easily deployed and exposed as a Web service. To provide SCA with the information it needs to generate the WSDL, it is necessary to add the annotation @binding.soap under the @service annotation and to specify the parameters and return values of the methods using the @param and @return annotations. These annotations will be read when WSDL is generated, and the order and types of the parameters determine the contents of the <schema> section of the WSDL.

SCA for PHP always generates document/literal wrapped WSDL for components that are exposing a Web service. Note that this does not stop components from consuming Web services which are not SCA components and which are documented with WSDL written in a different style.

The scalar types which can be used in the @param annotation are the four common PHP scalar types: boolean, integer, float and string. These are simply mapped to the XML schema types of the same name in the WSDL. The example below, which is a trivial implementation of the StockQuote service that the ConvertedStockQuote component calls, illustrates string and float types.

Příklad 1943. StockQuote Service

<?php

include "SCA/SCA.php";

/**
 * Scaffold implementation for a remote StockQuote Web service.
 *
 * @service
 * @binding.soap
 *
 */
class StockQuote {

    /**
     * Get a stock quote for a given ticker symbol.
     *
     * @param string $ticker The ticker symbol.
     * @return float The stock quote.
     */
    function getQuote($ticker) {
        return 80.9;
  }
}
?>

WSDL much like the following (though with a service location other than 'localhost', probably) would be generated from this service:

Příklad 1944. Generated WSDL

<?xml version="1.0" encoding="UTF-8" ?>
<definitions xmlns="http://schemas.xmlsoap.org/wsdl/" xsi:type="tDefinitions"
xmlns:tns2="http://StockQuote" xmlns:tns="http://schemas.xmlsoap.org/wsdl/"
xmlns:tns3="http://schemas.xmlsoap.org/wsdl/soap/"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" targetNamespace="http://StockQuote">
<types>
<xs:schema xmlns:xs="http://www.w3.org/2001/XMLSchema"
targetNamespace="http://StockQuote">
<xs:element name="getQuote">
<xs:complexType>
<xs:sequence>
<xs:element name="ticker" type="xs:string"/>
</xs:sequence>
</xs:complexType>
</xs:element>
<xs:element name="getQuoteResponse">
<xs:complexType>
<xs:sequence>
<xs:element name="getQuoteReturn" type="xs:float"/>
</xs:sequence>
</xs:complexType>
</xs:element>
</xs:schema>
</types>

<message name="getQuoteRequest">
<part name="getQuoteRequest" element="tns2:getQuote"/>
</message>
<message name="getQuoteResponse">
<part name="return" element="tns2:getQuoteResponse"/>
</message>
<portType name="StockQuotePortType">
<operation name="getQuote">
<input message="tns2:getQuoteRequest"/>
<output message="tns2:getQuoteResponse"/>
</operation>
</portType>
<binding name="StockQuoteBinding" type="tns2:StockQuotePortType">
<operation name="getQuote">
<input>
<tns3:body xsi:type="tBody" use="literal"/>
</input>
<output>
<tns3:body xsi:type="tBody" use="literal"/>
</output>
<tns3:operation xsi:type="tOperation" soapAction=""/>
</operation>
<tns3:binding xsi:type="tBinding" transport="http://schemas.xmlsoap.org/soap/http" style="document"/>
</binding>
<service name="StockQuoteService">
<port name="StockQuotePort" binding="tns2:StockQuoteBinding">
<tns3:address xsi:type="tAddress" location="http://localhost/StockQuote/StockQuote.php"/>
</port>
</service>
</definitions>

<!-- this line identifies this file as WSDL generated by SCA for PHP. Do not remove -->

Deploying an SCA component

There are no special steps needed to deploy a PHP SCA component. It is sufficient to place the component PHP script in its proper place under the web server document root, just like any other PHP script. It is the SCA::initComponent() executable line within each component that will be executed whenever the script is called, and which will be responsible for making the component respond appropriately to Web service calls, local calls, or requests for WSDL.

Obtaining the WSDL for an SCA component offering a Service as a Web service

SCA components that expose a Web service interface (i.e. have an @binding.soap annotation) will return their WSDL definition in response to an HTTP request with a get parameter of "wsdl". The usual way to obtain this is with "?wsdl" on the end of a URL. The example below uses file_get_contents() to obtain WSDL from a service and writes it to a temporary file before then obtaining a proxy for the service in the usual way. You could of course also obtain the WSDL in a browser, or by some other means, and save the file yourself.

Příklad 1945. Generated WSDL

<?php
$wsdl = file_get_contents('http://www.example.com/Services/Example.php?wsdl');
file_put_contents("service.wsdl",$wsdl); //write the wsdl to a file
$service = SCA::getService('service.wsdl');
?>

NOTE: If the wsdl requires imported xsds, these will need to be fetched separately.

Understanding how the WSDL is generated

SCA for PHP generates WSDL for components which contain an @binding.soap annotation after the @service annotation. To generate WSDL, the SCA runtime reflects on the component and examines the @param and @return annotations for each public method, as well as any @types annotations within the component. The information from the @param and @return annotations is used to build the <types> section of the WSDL. Any @types annotations which specify a separate schema file will result in an <import> element for that schema within the WSDL.

Location attribute of the <service> element

At the bottom of the WSDL is the <service> element which uses the location attribute to identify the URL of the service. For example this might look as follows:

Příklad 1946. location attribute

<service name="ConvertedStockQuote"
...
location="http://localhost/ConvertedStockQuote/ConvertedStockQuote.php"/>

Note that this location is relative to the document root of the web server, and cannot be worked out in advance. It can only be worked out once the component is in its proper place under a running web server, when the hostname and port can be known and placed in the WSDL. Detail from the URL that requests the WSDL is used, so for example if the WSDL is generated in response to a request to http://www.example.com:1111/ConvertedStockQuote/ConvertedStockQuote.php?wsdl, a location of http://www.example.com:1111/ConvertedStockQuote/ConvertedStockQuote.php is what will be inserted into the location attribute in the WSDL.

Document/literal wrapped WSDL and positional parameters

SCA for PHP generates WSDL in the document/literal wrapped style. This style encloses the parameters and return types of a method in 'wrappers' which are named after the corresponding method. The <types> element at the top of the WSDL defines each of these wrappers. If we consider the getQuote() method of the ConvertedStockQuote example:

Příklad 1947. method with two arguments

<?php
   /**
     * Get a stock quote for a given ticker symbol in a given currency.
     *
     * @param string $ticker The ticker symbol.
     * @param string $currency What currency to convert the value to.
     * @return float The stock value is the target currency.
     */
    function getQuote($ticker, $currency)
    {
        $quote  = $this->stock_quote->getQuote($ticker);
        $rate   = $this->exchange_rate->getRate($currency);
        return  $rate * $quote;
    }
?>

The WSDL generated to define this method will name both the method and the parameters, and give an XML schema type for the parameters. The types section of the WSDL looks like this:

Příklad 1948. types section illustrating named parameters

<types>
<xs:schema xmlns:xs="http://www.w3.org/2001/XMLSchema"
targetNamespace="http://ConvertedStockQuote">
<xs:element name="getQuote">
<xs:complexType>
<xs:sequence>
<xs:element name="ticker" type="xs:string"/>
<xs:element name="currency" type="xs:string"/>
</xs:sequence>
</xs:complexType>
</xs:element>
<xs:element name="getQuoteResponse">
<xs:complexType>
<xs:sequence>
<xs:element name="getQuoteReturn" type="xs:float"/>
</xs:sequence>
</xs:complexType>
</xs:element>
</xs:schema>
</types>

The SCA run-time has special processing to handle how positional parameter lists in the interface are converted to XML containing named parameters in the soap request, and then back to positional parameter lists again. To see why this matters, consider how a PHP script which used a different interface to make a SOAP call would need to construct the parameter list. A PHP script using the PHP SoapClient, for example, would need to pass the SoapClient a single parameter giving the values for "ticker" and "currency", perhaps as an associative array. To insist that SCA components construct parameter lists to make Web service calls in this way would be to make local and remote calls look different, so a different approach is needed.

When SCA generates WSDL for an SCA component it includes a comment in the WSDL which marks that WSDL as being the interface for an SCA component. In this case, when one SCA component calls another through a Web service, the SCA runtime on the calling end takes the positional parameter list from the call and assigns the values one by one to the named elements in the soap message. For example a call to the getQuote() method defined above that passes the values 'IBM' and 'USD' and looks like this:

$quote = $remote_service->getQuote('IBM','USD');

will result in a soap message containing the following:

<getQuote>
  <ticker>IBM</ticker>
  <currency>USD</currency>
</getQuote>

On the service-providing end, the SCA run-time takes the parameters one by one from the soap message and forms a positional parameter list from them, re-forming the argument list ('IBM','USD').

Výstraha

At both ends the SCA runtime relies on the order in which the parameters appear in the soap message being the same as that in the target method's parameter list. This is ultimately determined by the order of the @param annotations: this determines the order in which the parameters appear in the WSDL and thereby the order in which they appear in the soap message. Therefore it is essential that the order of the @param annotations matches that of the parameters in the method's parameter list.

Working with Data Structures

SCA components can pass and return the four PHP scalar types boolean, integer, float and string, but to pass or return data structures, SCA components use Service Data Objects (SDOs). SDOs are described in much more detail in the SDO pages of this manual. Readers familiar with SDOs will know that they are suitable for representing the sort of structured and semi-structured data that is frequently modeled in XML, and that they serialize very naturally for passing between remote components, or in Web services. SDOs are presently the only supported way to pass and return data structures. It is not possible to pass or return PHP objects, or PHP arrays.

The SCA runtime always assures data is passed by-value, even for local calls. To do this, the SCA runtime copies any SDOs in the parameter list before passing them on, just as it does for scalar types.

How data structures are defined to SCA components

Currently the only mechanism for specifying the location of a data structure definition is by specifying the types in an XML schema file. However, in the future it may be possible to define types in other ways, such as based on PHP classes or interfaces, or based on definitions expressed as associative arrays.

To illustrate the use of SDOs we introduce a new component. The PortfolioMangement service below returns an SDO representing a stock portfolio for a given customer.

Příklad 1949. A Component that uses Data Structures

<?php

include "SCA/SCA.php";

/**
 * Manage the portfolio for a customer.
 *
 * @service
 * @binding.soap
 *
 * @types http://www.example.org/Portfolio PortfolioTypes.xsd
 *
 */
class PortfolioManagement {

    /**
     * Get the stock portfolio for a given customer.
     *
     * @param integer $customer_id The id for the customer
     * @return Portfolio http://www.example.org/Portfolio The stock portfolio (symbols and quantities)
     */
    function getPortfolio($customer_id) {
        // Pretend we just got this from a database
        $portfolio = SCA::createDataObject('http://www.example.org/Portfolio', 'Portfolio');
        $holding = $portfolio->createDataObject('holding');
        $holding->ticker = 'AAPL';
        $holding->number = 100.5;
        $holding = $portfolio->createDataObject('holding');
        $holding->ticker = 'INTL';
        $holding->number = 100.5;
        $holding = $portfolio->createDataObject('holding');
        $holding->ticker = 'IBM';
        $holding->number = 100.5;
        return $portfolio;
    }

}
?>

The @types annotation:

<?php
@types http://www.example.org/Portfolio PortfolioTypes.xsd
?>

indicates that types in the namespace http://www.example.org/Portfolio will be found in the schema file located by the URI PortfolioTypes.xsd. The generated WSDL would reproduce this information with an import statement as follows:

<xs:import schemaLocation="PortfolioTypes.xsd"
namespace="http://www.example.org/Portfolio"/>

so the URI, absolute or relative, must be one that can be resolved when included in the schemaLocation attribute.

Creating SDOs

Readers familiar with SDOs will know that they are always created according to a description of the permitted structure (sometimes referred to as the 'schema' or 'model') and that, rather than creating them directly using 'new', some form of data factory is needed. Often, an existing data object can be used as the data factory, but sometimes, and especially in order to get the first data object, something else must act as the data factory.

In SCA, either the SCA runtime class or the proxies for services, whether local or remote, can act as the data factories for SDOs. The choice of which to use, and when, is described in the next two sections.

We switch to a new example in order to illustrate the creation of SDOs, both to pass to a service, and to be returned from a service.

Creating an SDO to pass to a service

A caller of a service which requires a data structure to be passed in to it uses the proxy to the service as the data factory for the corresponding SDOs. For example, suppose a component makes use of a proxy for a service provided by a local AddressBook component.

<?php
/**
 * @reference
 * @binding.local AddressBook.php
 */
$address_book;
?>

The AddressBook component that it wishes to call is defined as follows:

<?php
/**
* @service
* @binding.soap
* @types http://addressbook ../AddressBook/AddressBook.xsd
*/
class AddressBook {

    /**
     * @param personType $person http://addressbook (a person object)
     * @return addressType http://addressbook (the address object for the person object)
     */
    function lookupAddress($person)  {
        ...
    }
}
?>

The AddressBook component provides a service method called lookupAddress() which uses types from the http://addressbook namespace. The lookupAddress method takes a personType data structure and returns an addressType. Both types are defined in the schema file addressbook.xsd.

Once the component that wishes to use the AddressBook component has been constructed, so that the $address_book instance variable contains a proxy for the service, the calling component can use the proxy in $address_book to create the person SDO, as shown below:

<?php
$william_shakespeare        = $address_book->createDataObject('http://addressbook','personType');
$william_shakespeare ->name = "William Shakespeare";
$address                    = $address_book->lookupAddress($william_shakespeare);
?>

Note, the use of the proxy as the means to create the SDO is not limited to SCA components. If a service is being called from a general PHP script, and the proxy was obtained with getService() then the same approach is used.

<?php
$address_book = SCA::getService('AddressBook.php');
$william_shakespeare = $address_book->createDataObject('http://addressbook','personType');
?>

Creating an SDO to return from a component

A component that needs to create a data object for return to a caller will not have a proxy to use as a data object, In this case it uses the createDataObject() static method on SCA.php. Hence if the AddressBook component described above needed to create an object of type addressType within the namespace http://addressbook, it might do so as follows:

<?php
$address = SCA::createDataObject('http://addressbook','addressType');
?>

Error handling

This section describes how errors are handled. There are two types of errors:

  • SCA runtime exceptions are those that signal problems in the management of the execution of components, and in the interaction with remote services. These might occur due to network or configuration problems.

  • Business exceptions are those that are defined by the programmer. They extend the PHP Exception class, and are thrown and caught deliberately as part of the business logic.

Handling of Runtime exceptions

There are two types of SCA runtime exception:

  • SCA_RuntimeException - signals a problem found by or perhaps occurring within the SCA runtime. This can be thrown for a variety of reasons, many of which can occur regardless of whether a connection is being made to a local or a remote service: an error in one of the annotations within a component, a missing WSDL or php file, and so on. In the case of Web services, an SCA_RuntimeException can also be thrown if a SoapFault is received from a remote Web service and the fault code in the SoapFault indicates that a retry is unlikely to be successful.

  • SCA_ServiceUnavailableException - this is a subclass of SCA_RuntimeException and signals a problem in connecting to or using a remote service, but one which might succeed if retried. In the case of Web services, this exception is thrown if a SoapFault is received with a fault code that indicates that a retry might be successful.

Handling of Business exceptions

Business exceptions may be defined and thrown by a component in the normal way, regardless of whether the component has been called locally or remotely. The SCA runtime does not catch business exceptions that have been thrown by a component called locally, so they will be returned to a caller in the normal way. If a component has been called via a Web service, on the other hand, the SCA runtime on the service providing end does catch business exceptions, and will ensure these are passed back to the calling end and re-thrown. Assuming that the calling end has a definition of the exception (that is, is able to include a file containing the PHP class defining the exception) the re-thrown exception will contain the same details as the original, so that the getLine() and getFile() methods for example will contain the location where the exception was thrown within the business logic. The exception will be passed in the detail field of a soap fault with a fault code of "Client".

Předdefinované třídy

Most of the interface to SCA is through the annotations within SCA components so there are few public classes and methods. The only SCA classes that scripts or components can call are the SCA class itself, and the proxy classes SCA_LocalProxy and SCA_SoapProxy.

SCA

Much of the work of the SCA class is performed when the file SCA.php is included within an SCA component. However, a PHP script may include SCA.php and call the getService() method on the SCA class in order to obtain a proxy for a service. A component will not need to do this as proxies are obtained instead by defining an instance variable with the @reference annotation.

Components that need to create an SDO to return to a caller will need a data factory to call. For this purpose the SCA class supports the createDataObject() method, which will create an SDO according to the model defined by the component's @types annotations. The arguments to createDataObject() are the same as those to SDO's XML Data Access Service.

Metody

  • getService - obtain a proxy for a service

  • createDataObject - create an SDO

SCA_LocalProxy

When getService() is called with the target of a local PHP component, a local proxy is returned. A local proxy is also injected into the instance variables of a component that are defined with an @reference and an @binding.php anotation. When the script or component makes calls on the local proxy, they are passed on to the target component itself.

Components that need to create an SDO to pass to a component will need a data factory to call. For this purpose the SCA_LocalProxy class supports the createDataObject method, which will create an SDO according to the model defined by the components' @types annotations. The arguments to the createDataObject are the same as those to SDO's XML Data Access Service.

Metody

  • createDataObject - create an SDO

SCA_SoapProxy

When getService() is called with the target of a WSDL file, a SOAP proxy is returned. A SOAP proxy is also injected into the instance variables of a component that are defined with an @reference and an @binding.soap anotations. When the script or component makes calls on the SOAP proxy, they are formed into Web service SOAP requests and passed on to the target component, with the help of the PHP Soap extension.

Components that need to create an SDO to pass to a component will need a data factory to call. For this purpose the SCA_SoapProxy class supports the createDataObject method, which will create an SDO according to the model defined within the target WSDL. The arguments to the createDataObject are the same as those to SDO's XML Data Access Service.

Metody

  • createDataObject - create an SDO

Obsah

SCA_LocalProxy::createDataObject — create an SDO
SCA_SoapProxy::createDataObject — create an SDO
SCA::createDataObject — create an SDO
SCA::getService — Obtain a proxy for a service
Předcházející | Nahoru | Další
satellite_object_to_string | Domů | SCA_LocalProxy::createDataObject


SDO Functions

Předcházející VI. Reference funkcí Další

CXLIII. SDO Functions

Úvod

Service Data Objects (SDOs) enable PHP applications to work with data from different sources (like a database query, an XML file, and a spreadsheet) using a single interface.

Each different kind of data source requires a Data Access Service (DAS) to provide access to the data in the data source. In your PHP application, you use a DAS to create an SDO instance that represents some data in the data source. You can then set and get values in the SDO instance using the standard SDO interface. Finally, you use a DAS to write the modified data back to a data source, typically the same one.

See the list of Data Access Services for details on those currently available. In addition to the provided DASs, SDO also provides interfaces to enable others to be implemented (see the section on SDO Data Access Services Interface for more details).

This extension is derived from concepts taken from the » Service Data Objects specification. It includes a version of the » Apache Tuscany SDO for C++ project.

The Structure of a Service Data Object

A Service Data Object instance is made up of a tree of data objects. The tree is defined by containment relationships between the data objects. For example, a Company data object might consist of a number of Department data objects and therefore the Company would have a containment relationship to the Departments.

An SDO may also have non-containment references between data objects in the tree. For example, one Employee data object might reference another Employee to identify a career mentor.

As well as data objects referencing each other, they can also have primitive properties. For example, the Company data object might have a property called "name" of type string, for holding the name of the company (for example, "Acme").

Each of these properties of a data object - containment relationships, non-containment references, or primitive properties - may be many-valued or single-valued. In the above examples, Departments is many-valued and the Company name is single-valued.

In PHP, each SDO data object is represented as a PHP object. The properties of the data object can be accessed using either object syntax or associative array syntax. We'll see some examples of this later.

Požadavky

The SDO extension requires PHP 5.1.0 or higher. It also requires the libxml2 library. Normally libxml2 will already be installed, but if not, it can be downloaded from » http://www.xmlsoft.org/ .

Instalace

Poznámka: Earlier versions of the SDO extension required a separate shared library for the XML DAS. This is now obsolete and any references to php_sdo_das_xml.dll or sdo_das_xml.so should be removed from your php.ini .

Postup 5. Unix systems

  1. The three SDO components - the SDO core, the XML DAS and the Relational DAS - are packaged together with Service Component Architecture (SCA) into one PECL project, SCA_SDO, so you can download SCA and all three parts of SDO with the command:

pecl install SCA_SDO

    This command will build the SDO shared library as well as installing the PHP files that make up SCA and the SDO Relational DAS.

    If you want to use the latest beta version, then instead run:

pecl install SCA_SDO-beta

  2. The pecl command automatically installs the SDO module into your PHP extensions directory. To enable the SDO extension you must add the following line to php.ini :

extension=sdo.so

    For more information about building PECL packages, consult the PECL installation section of the manual.

Postup 6. Windows

  1. The latest SDO DLL can be downloaded from » php_sdo.dll .

    Note that currently the » pecl4win site does not provide this binary at the current release level; you can only download the latest level.

  2. The pecl command automatically installs the SDO module into your PHP extensions directory. To enable the SDO extension you must add the following line to php.ini :

extension=php_sdo.dll

  3. The Relational DAS can be downloaded and installed with the command:

pecl install -B sdo

    The Relational DAS is written in PHP. You may need to update your include_path in php.ini to point to the directory that contains sdo/DAS/Relational .

Postup 7. Building SDO on Linux

This section describes how to build the SDO core and XML DAS on Linux. You would only need to know how to do this if you wish to build a recent version that you have checked out of CVS.

  1. Change to the main extension directory: cd < wherever your sdo code is >

  2. Run phpize , which will set up the environment to compile SDO.

  3. Next, run ./configure; make; make install . Please note, you may need to login as root to install the extension.

  4. Make sure that the module is loaded by PHP, by adding extension=sdo.so to your php.ini file.

Data Access Services

The table below lists the currently provided SDO Data Access Services:

DAS Name | Description
SDO_DAS_XML | An XML Data Access Service supporting reading/writing SDOs as XML documents.
SDO_DAS_Relational | A PDO-based Data Access Service supporting reading/writing SDO to relational databases. Implements an optimistic concurrency policy for updates.

Limitations

Postup 8. Implementation Limitations

The following are limitations in the current SDO implementation:

  • There is no support for multi-byte character sets. This will be considered, depending on community requirements, in the Unicode-enabled version of PHP. See Unicode Functions.

Postup 9. SDO Limitations

The following SDO 2.0 concepts are not supported in the current PHP implementation. It is not necessarily the case that these will all be added over time. Their inclusion will depend on community requirements.

  1. Bi-directional relationships.

  2. Type and property alias names.

  3. Read-only properties.

  4. The Helper classes defined in SDO 2.0 are not directly implemented. However equivalent function is provided in a more natural way for PHP. For example the function of CopyHelper::copy() is provided by applying the PHP clone keyword to a data object.

Příklady

The examples below assume an SDO created with the schema and instance information shown below, using the XML Data Access Service.

The instance document below describes a single company, called 'MegaCorp', which contains a single department, called 'Advanced Technologies'. The Advanced Technologies department contains three employees. The company employeeOfTheMonth is referencing the second employee, 'Jane Doe'.

<?xml version="1.0" encoding="UTF-8" ?>
<company xmlns="companyNS" name="MegaCorp"
employeeOfTheMonth="E0003">
<departments name="Advanced Technologies" location="NY" number="123">
<employees name="John Jones" SN="E0001"/>
<employees name="Jane Doe" SN="E0003"/>
<employees name="Al Smith" SN="E0004" manager="true"/>
</departments>
</company>

The root element of the schema is a company. The company contains departments, and each department contains employees. Each element has a number of attributes to store things like name, serial number, and so on. Finally, the company also has an IDREF attribute which identifies one of the employees as the 'employeeOfTheMonth'.

<xsd:schema
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:sdo="commonj.sdo"
xmlns:sdoxml="commonj.sdo/xml"
xmlns:company="companyNS"
targetNamespace="companyNS">
<xsd:element name="company" type="company:CompanyType"/>
<xsd:complexType name="CompanyType">
<xsd:sequence>
<xsd:element name="departments" type="company:DepartmentType"
maxOccurs="unbounded"/>
</xsd:sequence>
<xsd:attribute name="name" type="xsd:string"/>
<xsd:attribute name="employeeOfTheMonth" type="xsd:IDREF"
sdoxml:propertyType="company:EmployeeType"/>
</xsd:complexType>
<xsd:complexType name="DepartmentType">
<xsd:sequence>
<xsd:element name="employees" type="company:EmployeeType"
maxOccurs="unbounded"/>
</xsd:sequence>
<xsd:attribute name="name" type="xsd:string"/>
<xsd:attribute name="location" type="xsd:string"/>
<xsd:attribute name="number" type="xsd:int"/>
</xsd:complexType>
<xsd:complexType name="EmployeeType">
<xsd:attribute name="name" type="xsd:string"/>
<xsd:attribute name="SN" type="xsd:ID"/>
<xsd:attribute name="manager" type="xsd:boolean"/>
</xsd:complexType>
</xsd:schema>

The XML Data Access Service maps the schema to an SDO. Attributes such as "name" become primitive properties, the sequence of employees becomes a many-valued containment relationship, and so on. Note that the containment relationships are expressed as one complex type within another, whereas non-containment references are expressed in terms of ID and IDREF, with a special sdoxml:propertyType attribute specifying the type of the non-containment reference.

Setting and Getting Property Values

The following examples assume $company is the root of a tree of data objects created from the schema and instance document shown above.

Příklad 1951. Access via property name

Data object properties can be accessed using the object property access syntax. The following sets the company name to 'Acme'.

<?php
  $company->name = 'Acme';
?>

Příklad 1952. Access via property name as array index

We can also access properties using associative array syntax. The simplest form of this uses the property name as the array index. For example, the following sets the company name and gets the employeeOfTheMonth.

<?php
  $company['name'] = 'UltraCorp';
  $eotm = $company['employeeOfTheMonth'];
?>

Příklad 1953. Data Object iteration

We can iterate over the properties of a data object using foreach. The following iterates over the properties of the employee of the month.

<?php
  $eotm = $company->employeeOfTheMonth;
  foreach ($eotm as $name => $value) {
      echo "$name: $value\n";
  }
?>

which will output:

name: Jane Doe
SN: E0003

The 'manager' property is not output, because it has not been set.

Příklad 1954. Access many-valued property by name

Many-valued data object properties can also be accessed using the object property name syntax. The following gets the list of departments.

<?php
  $departments = $company->departments;
?>

Příklad 1955. Many-valued element access

We can access individual elements of many-valued properties using array syntax. The following accesses the first department in the company.

<?php
  $ad_tech_dept = $company->departments[0];
?>

Příklad 1956. Many-valued property iteration

Many-valued properties can also be iterated over using foreach. The following iterates over the company's departments.

<?php
  foreach ($company->departments as $department) {
    // ...
  }
?>

Each iteration will assign the next department in the list to the variable $department.

Příklad 1957. Chained property access

We can chain property references on a single line. The following sets and gets the name of the first department.

<?php
  $company->departments[0]->name = 'Emerging Technologies';
  $dept_name = $company->departments[0]->name;
?>

Using the associative array syntax, this is equivalent to

<?php
  $company['departments'][0]['name'] = 'Emerging Technologies';
  $dept_name = $company['departments'][0]['name'];
?>

In either case, the dept_name variable is set to 'Emerging Technologies'.

Příklad 1958. XPath navigation

The associative array index can be an XPath-like expression. Valid expressions are defined by an augmented sub-set of XPath.

Two forms of indexing into many-valued properties are supported. The first is the standard XPath array syntax with the indexing starting at one, the second is an SDO extension to XPath with an index starting at zero. The standard syntax is:

<?php
  $jane_doe = $company["departments[1]/employees[2]"];
?>

and the SDO XPath extension syntax is:

<?php
  $jane_doe = $company["departments.0/employees.1"];
?>

Both these examples get the second employee from the first department.

Příklad 1959. XPath querying

We can use XPath to query and identify parts of a data object based on instance data. The following retrieves the manager from the 'Advanced Technologies' department.

<?php
 $ad_tech_mgr =
  $company["departments[name='Advanced Technologies']/employees[manager=true]"];
?>

Příklad 1960. Creating child data objects

A data object can be a factory for its child data objects. A child data object is automatically part of the data graph. The following add a new employee to the 'Advanced Technologies' department.

<?php
  $ad_tech_dept = $company["departments[name='Advanced Technologies']"];
  $new_hire = $ad_tech_dept->createDataObject('employees');
  $new_hire->name = 'John Johnson';
  $new_hire->SN = 'E0005';
  $new_hire->manager = false;
?>

Příklad 1961. Unset a primitive property

We can use the isset() and unset() functions to test and remove items from the data object.

The following clears the name of the first department.

<?php
  unset($company->departments[0]->name);
?>

Příklad 1962. Unset a data object

unset can also be used to remove a data object from the tree. The following example shows John Jones leaving the company.

<?php
  unset($company->departments[0]->employees[0]);
?>

Příklad 1963. Unset a referenced data object

The following removes the 'employeeOfTheMonth' from the company. If this were a containment relationship then the employee would be removed from the company (probably not a good idea to sack your best employee each month!), but since this is a non-containment reference, the employee being referenced will remain in the department in the company, but will no longer be accessible via the employeeOfTheMonth property.

<?php
  if (isset($company->employeeOfTheMonth)) {
    unset($company->employeeOfTheMonth);
  }
?>

Příklad 1964. Access via property index

Data object properties can be accessed via their property index using array syntax. The property index is the position at which the property's definition appears in the model (in this case the xml schema). We can see from the schema listing above that the company name attribute is the second company property (the SDO interface makes no distinction between XML attributes and elements). The following sets the company name to 'Acme', with the same result as Access via property name

<?php
  $company[1] = 'Acme';
?>

Using the index directly in this way is likely to be fragile. Normally the property name syntax should be preferred, but the property index may be required in special cases.

Working with Sequenced Data Objects

Sequenced data objects are SDOs which can track property ordering across the properties of a data object. They can also contain unstructured text elements (text element which do not belong to any of the SDO's properties). Sequenced data objects are useful for working with XML documents which allow unstructured text (i.e. mixed=true) or if the elements can be interleaved ( <A/><B/><A/>). This can occur for example when the schema defines maxOccurs>1 on a element which is a complexType with a choice order indicator.

The examples below assume an SDO created with the following schema and instance information, using the XML Data Access Service.

The schema below describes the format of a letter. The letter can optionally contain three properties; date, firstName, and lastName. The schema states mixed="true" which means that unstructured text can be interspersed between the three properties.

<xsd:schema xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:letter="http://letterSchema"
targetNamespace="http://letterSchema">
<xsd:element name="letters" type="letter:FormLetter"/>
<xsd:complexType name="FormLetter" mixed="true">
<xsd:sequence>
<xsd:element name="date" minOccurs="0" type="xsd:string"/>
<xsd:element name="firstName" minOccurs="0" type="xsd:string"/>
<xsd:element name="lastName" minOccurs="0" type="xsd:string"/>
</xsd:sequence>
</xsd:complexType>
</xsd:schema>

The following is an instance letter document. It contains the three letter properties; date, firstName and lastName, and has unstructured text elements for the address and letter body.

<letter:letters xmlns:letter="http://letterSchema">
<date>March 1, 2005</date>
Mutual of Omaha
Wild Kingdom, USA
Dear
<firstName>Casy</firstName>
<lastName>Crocodile</lastName>
Please buy more shark repellent.
Your premium is past due.
</letter:letters>

When loaded, the letter data object will have the sequence and property indices shown in the table below:

Sequence Index | Property Index:Name | Value
0 | 0:date | March 1, 2005
1 | - | Mutual of Omaha
2 | - | Wild Kingdom, USA
3 | - | Dear
4 | 1:firstName | Casy
5 | 2:lastName | Crocodile
6 | - | Please buy more shark repellent.
7 | - | Your premium is past due.

To ensure sequence indices are maintained, sequenced data objects should be manipulated through the SDO_Sequence interface. This allows the data object's instance data to be manipulated in terms of the sequence index as opposed to the property index (shown in the table above). The following examples assume the letter instance has been loaded into a data object referenced by the variable $letter.

Příklad 1965. Getting the SDO_Sequence interface

We obtain a data object's sequence using the getSequence() method. The follow gets the sequence for the letter data object.

<?php
  $letter_seq = $letter->getSequence();
?>

All subsequent examples assume that the $letter_seq variable has been assigned the sequence for the letter data object.

Příklad 1966. Get/set sequence values

We can get and set individual values (including unstructured text) using the sequence index. The following sets the firstName to 'Snappy' and gets the last sequence values (the unstructured text, 'Your premium is past due.').

<?php
  $letter_seq[4] = 'Snappy';
  $text = $letter_seq[count($letter_seq) - 1];
?>

Příklad 1967. Sequence iteration

We can iterate through the individual sequence values using foreach. The following runs through the individual values in sequence order.

<?php
  foreach ($letter->getSequence() as $value) {
    // ...
  }
?>

Příklad 1968. Sequence versus Data Object

Setting values through the data object interface may result in the value not being part of the sequence. A value set through the data object will only be accessible through the sequence if the property was already part of the sequence. The following example sets the lastName through the data object and gets it through the sequence. This is fine because lastName already exists in the sequence. If it had not previously been set, then lastName would be set to 'Smith', but would not be part of the sequence.

<?php
  $letter[2] = 'Smith';
  $last_name = $letter_seq[5];
?>

Příklad 1969. Adding to a sequence

We can add new values to a sequence using the SDO_Sequence::insert() method. The following examples assume that the 'firstName' and 'lastName' properties are initially unset.

<?php
  // Append a firstName value to the sequence
  // value: 'Smith'
  // sequence index: NULL (append)
  // propertyIdentifier: 1 (firtName property index)
  $letter_seq->insert('Smith', NULL, 1);

  // Append a lastName value to the sequence
  // value: 'Jones'
  // sequence index: NULL (append)
  // propertyIdentifier: 'lastName' (lastName property name)
  $letter_seq->insert('Jones', NULL, 'lastName');

  // Append unstructured text
  // value: 'Cancel Subscription.'
  // sequence index: absent (append)
  // propertyIdentifier: absent (unstructured text)
  $letter_seq->insert('Cancel Subscription.');

  // Insert new unstructured text.  Subsequent sequence values
  // are shifted up.
  // value: 'Care of:'
  // sequence index: 1 (insert as second element)
  // propertyIdentifier: absent (unstructured text)
  $letter_seq->insert('Care of:', 1);
?>

Příklad 1970. Removing from a sequence

We can use the isset() and unset() functions to test and remove items from the sequence (Note: unset() currently leaves the values in the data object, but this behaviour is likely to change to also remove the data from the data object). A sequence behaves like a contiguous list; therefore, removing items from the middle will shift entries at higher indices down. The following example tests to see if the first sequence element is set and unsets it if is.

<?php
  if (isset($letter_seq[0])) {
    unset($letter_seq[0]);
  }
?>

Reflecting on Service Data Objects

SDOs have a knowledge of the structure they have been created to represent (the model). For example, a Company SDO created using the Company XML schema above would only be permitted to contain DepartmentType data objects which in turn could only contain EmployeeType data objects.

Sometimes it is useful to be able to access this model information at runtime. For example, this could be used to automatically generate a user interface for populating a data object. The model information is accessed using reflection.

Příklad 1971. Reflecting on a Data Object

The following example shows how we can reflect on an empty Employee data object.

<?php
  // Create the employee data object (e.g. from an XML Data Access Service)
  $employee = ...;
  $reflection = new SDO_Model_ReflectionDataObject($employee);
  print($reflection);
?>

Výše uvedený příklad vypíše:

object(SDO_Model_ReflectionDataObject)#4 { - ROOT OBJECT - Type {
companyNS:EmployeeType[3] { commonj.sdo:String $name;
commonj.sdo:String $SN; commonj.sdo:Boolean $manager; } }

Using print on the SDO_Model_ReflectionDataObject writes out the data object's model. We can see from the output how the type companyNS:EmployeeType has three properties and we can see the names of the properties along with their types. Note, the primitive types are listed as SDO types (e.g. commonj.sdo namespace, String type). It is worth noting that this is the SDO model and when these are surfaced to an application they can be treated as the PHP equivalent types (e.g. string and boolean).

Příklad 1972. Accessing the type information

We can query the type information of a data object using reflection. The following example checks the type corresponds to a data object rather than a primitive and then iterates through the properties of the type, writing out the name of each property ($type and $property are SDO_Model_Type and SDO_Model_Property objects, respectively).

<?php
    // Create the employee data object (e.g. from an XML Data Access Service)
    $employee = ...;
    $reflection = new SDO_Model_ReflectionDataObject($employee);
    $type = $reflection->getType();
    if (! $type->isDataType()) {
        foreach ($type->getProperties() as $property) {
            print $property->getName() . "\n";
        }
    }
?>

Výše uvedený příklad vypíše:

name
SN
manager

Předdefinované třídy

SDO consists of three sets of interfaces. The first set covers those interfaces for use by typical SDO applications. These are identified by the package prefix 'SDO_'. The second set is those used to reflect on, and work with, the model of a data object. These are identified by the package prefix 'SDO_Model_'. Finally, the third set are those use by Data Access Service implementations and are identified by the package prefix 'SDO_DAS_'. The majority of SDO users will not need to use or understand the 'SDO_Model_' and 'SDO_DAS_' interfaces.

SDO Application Programmer Interface

SDO_DataObject

The main interface through which data objects are manipulated. In addition to the methods below, SDO_DataObject extends the ArrayAccess, SDO_PropertyAccess (defines __get() / __set() methods for property access overloading), Iterator, and Countable interfaces.

Metody

  • getSequence - get the sequence for the data object

  • createDataObject - create a child data object

  • clear - unset the properties of a data object

  • getContainer - get the container (also known as 'parent') of this data object

  • getTypeName - get the name of the type for this data object

  • getTypeNamespaceURI - get the namespace URI of the type for this data object

SDO_Sequence

The interface through which sequenced data objects can be accessed to preserve ordering across a data object's properties and to allow unstructured text. SDO_Sequence preserves contiguous indices and therefore inserting or removing elements may shift other elements up or down. In addition to the methods below, SDO_Sequence extends the ArrayAccess, Iterator and Countable interface.

Metody

  • getProperty - get the property for a given sequence index

  • move - move an element from one property index to another

  • insert - insert a new value into the sequence

SDO_List

The interface through which many-valued properties are manipulated. In addition to the method defined below, SDO_List extends ArrayAccess, Iterator and Countable. SDO_List preserves contiguous indices and therefore inserting or removing elements may shift other elements up or down.

Metody

  • insert - insert a new value into the list

SDO_DataFactory

The interface through which data objects can be created. A Data Access Service is responsible for populating the model (i.e. configuring the data factory with the type and structure information for the data objects it can create.) for the factory and can then optionally return an instance of, or implement, the SDO_DataFactory interface.

Metody

  • create - create a new data object

SDO_Exception

An SDO_Exception is thrown when the caller's request cannot be completed. The subclasses of SDO_Exception are:

  • SDO_PropertyNotSetException - the property specified exists but has not been set or does not have a default value

  • SDO_PropertyNotFoundException - the property specified is not part of the data object's type

  • SDO_TypeNotFoundException - the specified namespace URI or type name is unknown

  • SDO_InvalidConversionException - conversion between the types of the assignment is not possible

  • SDO_IndexOutOfBoundsException - the numeric index into a data object, sequence or list is not in the valid range

  • SDO_UnsupportedOperationException - the request cannot be completed because it is not allowed, for example an attempt to set a read-only property.

Metody

One method is added to those inherited from the built in Exception class:

  • getCause - get the cause of this SDO_Exception

SDO Reflection Application Programmer Interfaces

SDO_Model_ReflectionDataObject

The main interface used to reflect on a data object instance to obtain its model type and property information. It is designed to follow the reflection pattern introduced in PHP 5.

Konstruktory

  • __construct - construct a new SDO_Model_ReflectionDataObject.

Metody

  • export - get a string describing the data object.

  • getType - get the SDO_Model_Type for the data object.

  • getInstanceProperties - get the instance properties of the data object.

  • getContainmentProperty - get the property which defines the containment relationship to the data object.

SDO_Model_Type

The interface through which a data object's type information can be retrieved. This interface can be used to find out the type name and namespace URI of the type, whether the type allow open content, and so on.

Metody

  • getName - get the name of the type.

  • getNamespaceURI - get the namespace URI of the type.

  • isInstance - test for a data object being an instance of the type.

  • getProperties - get the properties of the type.

  • getProperty - get a property of the type.

  • isDataType - test to see if this type is a primitive scalar type.

  • isSequencedType - test to see if this is a sequenced type.

  • isOpenType - test to see if this is an open type.

  • isAbstractType - test to see if this is an abstract type.

  • getBaseType - get the base type of this type (if one exists).

SDO_Model_Property

The interface through which a data object's property information can be retrieved. This interface can be used to find out the type of a property, whether a property has a default value, whether the property is contained or reference by its parent, its cardinality, and so on.

Metody

  • getName - get the name of the property.

  • getType - get the type of the property.

  • isMany - test to see if the property is many-valued.

  • isContainment - test to see if the property describes a containment relationship.

  • getContainingType - get the type which contains this property.

  • getDefault - get the default value for a property.

SDO Data Access Service Developer Interfaces

SDO_DAS_DataObject

The interface through which a Data Access Service can access a data object's SDO_DAS_ChangeSummary. The change summary is used by the Data Access Service to check for conflicts when applying changes back to a data source.

Metody

  • getChangeSummary - get the change summary for a data object

SDO_DAS_ChangeSummary

The interface through which the change history of a data object is accessed. The change summary holds information for any modifications on a data object which occurred since logging was activated. In the case of deletions and modifications, the old values are also held in the change summary.

If logging is no longer active then the change summary only holds changes made up to the point when logging was deactivated. Reactivating logging clears the change summary. This is useful when a set of changes have been written out by a DAS and the data object is to be reused.

Metody

  • beginLogging - begin logging changes made to a data object

  • endLogging - end logging changes made to a data object

  • isLogging - test to see if change logging is on

  • getChangedDataObjects - get a list of the data objects which have been changed

  • getChangeType - get the type of change which has been made to a data object

  • getOldValues - get a list of old values for a data object

  • getOldContainer - get the old container data object for a deleted data object

SDO_DAS_Setting

The interface through which the old value for a property is accessed. A list of settings is returned by the change summary method getOldValues() .

Metody

  • getPropertyIndex - get the property index for the changed property

  • getPropertyName - get the property name for the changed property

  • getValue - get the old value for the changed property

  • getListIndex - get the list index for the old value if it was part of a many-valued property

  • isSet - test to see if the property was set prior to being modified

SDO_DAS_DataFactory

The interface for constructing the model for an SDO_DataObject. The SDO_DAS_DataFactory is an abstract class providing a static method which returns a concrete data factory implementation. The implementation is used by Data Access Services to create an SDO model from their model. For example, a Relational Data Access Service might create and populate an SDO_DAS_DataFactory model based on a schema for a relational database.

Metody

  • getDataFactory - static methods for getting a concrete data factory instance

  • addType - add a new type to the SDO model

  • addPropertyToType - add a new property to a type definition in the SDO model

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

SDO_DAS_ChangeSummary::NONE=0 (integer)
Represents a change type of 'none'.
SDO_DAS_ChangeSummary::MODIFICATION=1 (integer)
Represents a change type of 'modification'.
SDO_DAS_ChangeSummary::ADDITION=2 (integer)
Represents a change type of 'addition'.
SDO_DAS_ChangeSummary::DELETION=3 (integer)
Represents a change type of 'deletion'.

Obsah

SDO_DAS_ChangeSummary::beginLogging — Begin change logging
SDO_DAS_ChangeSummary::endLogging — End change logging
SDO_DAS_ChangeSummary::getChangeType — Get the type of change made to an SDO_DataObject
SDO_DAS_ChangeSummary::getChangedDataObjects — Get the changed data objects from a change summary
SDO_DAS_ChangeSummary::getOldContainer — Get the old container for a deleted SDO_DataObject
SDO_DAS_ChangeSummary::getOldValues — Get the old values for a given changed SDO_DataObject
SDO_DAS_ChangeSummary::isLogging — Test to see whether change logging is switched on
SDO_DAS_DataFactory::addPropertyToType — Adds a property to a type
SDO_DAS_DataFactory::addType — Add a new type to a model
SDO_DAS_DataFactory::getDataFactory — Get a data factory instance
SDO_DAS_DataObject::getChangeSummary — Get a data object's change summary
SDO_DAS_Setting::getListIndex — Get the list index for a changed many-valued property
SDO_DAS_Setting::getPropertyIndex — Get the property index for a changed property
SDO_DAS_Setting::getPropertyName — Get the property name for a changed property
SDO_DAS_Setting::getValue — Get the old value for the changed property
SDO_DAS_Setting::isSet — Test whether a property was set prior to being modified
SDO_DataFactory::create — Create an SDO_DataObject
SDO_DataObject::clear — Clear an SDO_DataObject's properties
SDO_DataObject::createDataObject — Create a child SDO_DataObject
SDO_DataObject::getContainer — Get a data object's container
SDO_DataObject::getSequence — Get the sequence for a data object
SDO_DataObject::getTypeName — Return the name of the type for a data object.
SDO_DataObject::getTypeNamespaceURI — Return the namespace URI of the type for a data object.
SDO_Exception::getCause — Get the cause of the exception.
SDO_List::insert — Insert into a list
SDO_Model_Property::getContainingType — Get the SDO_Model_Type which contains this property
SDO_Model_Property::getDefault — Get the default value for the property
SDO_Model_Property::getName — Get the name of the SDO_Model_Property
SDO_Model_Property::getType — Get the SDO_Model_Type of the property
SDO_Model_Property::isContainment — Test to see if the property defines a containment relationship
SDO_Model_Property::isMany — Test to see if the property is many-valued
SDO_Model_ReflectionDataObject::__construct — Construct an SDO_Model_ReflectionDataObject
SDO_Model_ReflectionDataObject::export — Get a string describing the SDO_DataObject.
SDO_Model_ReflectionDataObject::getContainmentProperty — Get the property which defines the containment relationship to the data object
SDO_Model_ReflectionDataObject::getInstanceProperties — Get the instance properties of the SDO_DataObject
SDO_Model_ReflectionDataObject::getType — Get the SDO_Model_Type for the SDO_DataObject
SDO_Model_Type::getBaseType — Get the base type for this type
SDO_Model_Type::getName — Get the name of the type
SDO_Model_Type::getNamespaceURI — Get the namespace URI of the type
SDO_Model_Type::getProperties — Get the SDO_Model_Property objects defined for the type
SDO_Model_Type::getProperty — Get an SDO_Model_Property of the type
SDO_Model_Type::isAbstractType — Test to see if this SDO_Model_Type is an abstract data type
SDO_Model_Type::isDataType — Test to see if this SDO_Model_Type is a primitive data type
SDO_Model_Type::isInstance — Test for an SDO_DataObject being an instance of this SDO_Model_Type
SDO_Model_Type::isOpenType — Test to see if this type is an open type
SDO_Model_Type::isSequencedType — Test to see if this is a sequenced type
SDO_Sequence::getProperty — Return the property for the specified sequence index.
SDO_Sequence::insert — Insert into a sequence
SDO_Sequence::move — Move an item to another sequence position
Předcházející | Nahoru | Další
SCA::getService | Domů | SDO_DAS_ChangeSummary::beginLogging


SDO XML Data Access Service Functions

Předcházející VI. Reference funkcí Další

CXLIV. SDO XML Data Access Service Functions

Úvod

In order to use the XML Data Access Service for Service Data Objects, you will need to understand some of the concepts behind SDO: the data graph, the data object, XPath and property expressions, and so on. If you are not familiar with these ideas, you might want to look first at the section on SDO.

The job of the XML DAS is to move data between the application and an XML data source, which can be either a file or a URL. SDOs are always created and maintained according to a model which defines type names and what property names each type may have. For data which is from XML, this SDO model is built from a schema file written in XML schema language (an xsd file). This schema file is usually passed to the create method when the XMLDAS is initialised. The » SDO 2.0 specification defines the mapping between XML types and SDO types. There are a number of small limitations in the PHP support - not everything which is in the specification can be done - and these limitations are summarised in a later section.

Požadavky

The SDO XML Data Access Service requires PHP 5.1.0 or higher. It is packaged with the SDO extension and requires SDO to have been installed. See the SDO installation instructions for the details of how to do this.

Instalace

The XML Data Access Service is packaged and installed as part of the SDO extension. Please Refer SDO installation instructions.

Příklady

Several of the following examples are based on the letter example described in the SDO documentation. The examples assume the XML Schema for the letter is contained in a file letter.xsd and the letter instance is in the file letter.xml. These two files are reproduced here:

<xsd:schema xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:letter="http://letterSchema"
targetNamespace="http://letterSchema">
<xsd:element name="letters" type="letter:FormLetter"/>
<xsd:complexType name="FormLetter" mixed="true">
<xsd:sequence>
<xsd:element name="date" minOccurs="0" type="xsd:string"/>
<xsd:element name="firstName" minOccurs="0" type="xsd:string"/>
<xsd:element name="lastName" minOccurs="0" type="xsd:string"/>
</xsd:sequence>
</xsd:complexType>
</xsd:schema>

<letter:letters xmlns:letter="http://letterSchema">
<date>March 1, 2005</date>
Mutual of Omaha
Wild Kingdom, USA
Dear
<firstName>Casy</firstName>
<lastName>Crocodile</lastName>
Please buy more shark repellent.
Your premium is past due.
</letter:letters>

Příklad 1975. Loading, altering, and saving an XML document

The following example shows how an XML document can be loaded from a file, altered, and written back.

<?php
/**
 * Load, update, and save an XML document
 */
try {
   $xmldas = SDO_DAS_XML::create("letter.xsd");
   $document = $xmldas->loadFile("letter.xml");
   $root_data_object = $document->getRootDataObject();
   $root_data_object->date = "September 03, 2004";
   $root_data_object->firstName = "Anantoju";
   $root_data_object->lastName = "Madhu";
   $xmldas->saveFile($document, "letter-out.xml");
   echo "New file has been written:\n";
   print file_get_contents("letter-out.xml");
} catch (SDO_Exception $e) {
   print($e->getMessage());
}
?>

An instance of the XML DAS is first obtained from the SDO_DAS_XML::create() method, which is a static method of the SDO_DAS_XML class. The location of the xsd is passed as a parameter. Once we have an instance of the XML DAS initialised with a given schema, we can use it to load the instance document using the loadFile() method. There is also a loadString() method if you want to load an XML instance document from a string. If the instance document loads successfully, you will be returned an object of type SDO_DAS_XML_Document, on which you can call the getRootDataObject() method to get the SDO data object which is the root of the SDO data graph. You can then use SDO operations to change the graph. In this example we alter the date, firstName, and lastName properties. Then we use the saveFile() method to write the changed document back to the file system. The saveFile method has an optional extra integer argument which if specified will cause the XML DAS to format the XML, using the integer as the amount to indent by at each change in level on the document.

This will write the following to letter-out.xml.

<?xml version="1.0" encoding="UTF-8" ?>
<FormLetter xmlns="http://letterSchema" xsi:type="FormLetter" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<date>September 03, 2004</date>
Mutual of Omaha
Wild Kingdom, USA
Dear
<firstName>Anantoju</firstName>
<lastName>Madhu</lastName>
Please buy more shark repellent.
Your premium is past due.
</FormLetter>

Příklad 1976. Creating a new XML document

The previous example loaded the document from a file. This example shows how to create an SDO data graph in memory. In this example it is then saved to an XML string. Furthermore, because the letter contains both structured and unstructured content, it uses the Sequence API as well assignments to properties to construct the data graph.

<?php
/**
 * Create an XML document from scratch
 */
try {
   $xmldas = SDO_DAS_XML::create("letter.xsd");
   try {
       $doc = $xmldas->createDocument();
       $rdo = $doc->getRootDataObject();
       $seq = $rdo->getSequence();
       $seq->insert("April 09, 2005", NULL, 'date');
       $seq->insert("Acme Inc. ", NULL, NULL);
       $seq->insert("United Kingdom. ");
       $seq->insert("Dear", NULL, NULL);
       $seq->insert("Tarun", NULL, "firstName");
       $seq->insert("Nayaraaa", NULL, "lastName");
       $rdo->lastName = "Nayar";
       $seq->insert("Please note that your order number ");
       $seq->insert(12345);
       $seq->insert(" has been dispatched today. Thanks for your business with us.");
       print($xmldas->saveString($doc));
   } catch (SDO_Exception $e) {
       print($e);
   }
} catch (SDO_Exception $e) {
   print("Problem creating an XML document: " . $e->getMessage());
}
?>

The createDocument() method on the XML DAS returns a document object with a single root data object corresponding to an empty document element. The element name of the document element is known from the schema file. If there is any ambiguity about what the document element is, as there can be when more than one schema has been loaded into the same XML DAS, the element name and the namespace URI can be passed to the createDocument() method.

This will emit the following output (line breaks have been inserted for readability):

<?xml version="1.0" encoding="UTF-8" ?>
<FormLetter xmlns="http://letterSchema" xsi:type="FormLetter"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<date>April 09, 2005</date>
Acme Inc. United Kingdom.
Dear
<firstName>Tarun</firstName>
<lastName>Nayar</lastName>
Please note that your order number 12345 has been
dispatched today. Thanks for your business with us.
</FormLetter>

Příklad 1977. Setting XML document properties

This third example shows you how to set the XML version and encoding on the document object. These will be used when the XML is written out. If no XML declaration is wanted at all (perhaps you want to generate the XML as a string to embed in something) then you can use the setXMLDeclaration() method to suppress it.

<?php
/**
 * Illustrate the calls that control the XML declaration
 */
   $xmldas = SDO_DAS_XML::create("letter.xsd");
   $document = $xmldas->loadFile("letter.xml");
   $document->setXMLVersion("1.1");
   $document->setEncoding("ISO-8859-1");
   print($xmldas->saveString($document));
?>

The XML version and encoding are set in the XML declaration at the top of the XML document.

<?xml version="1.1" encoding="ISO-8859-1" ?>
.../...

Příklad 1978. Using an open type

This fourth example illustrates the use of an SDO open type and the use of the createDataObject() method. For this example we use the following two schema:

<schema
xmlns="http://www.w3.org/2001/XMLSchema">

<element name="jungle">
<complexType>
<sequence>
<any minOccurs="0" maxOccurs="unbounded"/>
</sequence>
</complexType>
</element>

</schema>

Note the presence of the any element in the definition. This first schema defines the jungle complex type as containing a sequence of any other type. The other types that the example will use are defined in a second schema file:

<schema xmlns= "http://www.w3.org/2001/XMLSchema">

<complexType name="snakeType">
<sequence>
<element name= "name" type="string"/>
<element name= "length" type="positiveInteger" />
</sequence>
</complexType>

<complexType name="bearType">
<sequence>
<element name= "name" type="string"/>
<element name= "weight" type="positiveInteger" />
</sequence>
</complexType>

<complexType name="pantherType">
<sequence>
<element name= "name" type="string"/>
<element name= "colour" type="string" />
</sequence>
</complexType>

</schema>

Here is the example PHP code that uses these two schema files:

<?php

/**
 * Illustrate open types and the use of the addTypes() method
 */

$xmldas = SDO_DAS_XML::create();
$xmldas->addTypes("jungle.xsd"); // this is an open type i.e. the xsd specifies it can contain "any" type
$xmldas->addTypes('animalTypes.xsd');

$baloo            = $xmldas->createDataObject('','bearType');
$baloo->name      = "Baloo";
$baloo->weight    = 800;

$bagheera         = $xmldas->createDataObject('','pantherType');
$bagheera->name   = "Bagheera";
$bagheera->colour = 'inky black';

$kaa              = $xmldas->createDataObject('','snakeType');
$kaa->name        = "Kaa";
$kaa->length      = 25;

$document         = $xmldas->createDocument();
$do               = $document->getRootDataObject();
$do->bear         = $baloo;
$do->panther      = $bagheera;
$do->snake        = $kaa;

print($xmldas->saveString($document,2));

?>

These two schema files are loaded into the XML DAS with first the create() and addTypes() methods. The createDataObject() method is used to create three separate data objects. In each case the namespaceURI and typename of the type are passed to the createDataObject() method: in this example the namespace URI is blank because no namespace is used in the schema. Once the three data objects - representing a bear, a panther and a snake - have been created, a document object is created with the createDocument() method. In this case there is no ambiguity about what the document element of the document should be - as the second schema file only defines complex types, the document element can only be the global jungle element defined in the first schema. This document will have a single root data object corresponding to an empty document element jungle. As this is an open type, properties can be added at will. When the first assignment is made to $do->bear, a property bear is added to the root data object: likewise for the next two assignments. When the document is written out by the saveString() method, the resulting document is:

<?xml version="1.0" encoding="UTF-8" ?>
<jungle xsi:type="jungle" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<bear xsi:type="bearType">
<name>Baloo</name>
<weight>800</weight>
</bear>
<panther xsi:type="pantherType">
<name>Bagheera</name>
<colour>inky black</colour>
</panther>
<snake xsi:type="snakeType">
<name>Kaa</name>
<length>25</length>
</snake>
</jungle>

Příklad 1979. Finding out what you can from the document

This example is intended to illustrate how you can find the element name and namespace of the document element from the XML Document object, and the SDO type and namespace from the root data object of the XML data object, and how they relate to one another. This can be difficult to understand because there are four method calls: two can be made against the Document object, and two that can be made against any data object including the root data object. Because of the rules that define how the SDO model is derived from the XML model, when the data object concerned is the root object that represents the document object for the document, only three possible values can come back from these four method calls.

The two method calls that can be made against the document are getRootElementName() and getRootEelementURI(). These return the element name and namespace of the document element, respectively.

The two method calls that can be made against any data object are getTypeName() and getTypeNamespaceURI(). These return the SDO type name and type namespace of the data object, respectively.

Always, calling getRootElementURI() on the document object will return the same value as calling getNamespaceURI() on the root data object. Essentially, the information is all derived from the first few lines of the schema file, where there are three distinct pieces of information. For illustration, here again are the first few lines of the letter.xsd that we used above.

<xsd:schema xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:letter="http://letterSchema"
targetNamespace="http://letterSchema">

<xsd:element name="letters" type="letter:FormLetter"/>

<xsd:complexType name="FormLetter" mixed="true">
.../...

The three important values are:

  • letters, the name of the document element

  • FormLetter, the name of the complex type of the document element. This is also the name of the SDO type of the root data object.

  • http://letterSchema, the namespace to which the document element belongs. This is also the namespaceURI of the SDO type of the root data object.

It is part of the XML-SDO mapping rules that when the SDO model is built from the schema file, the typename and namespaceURI of the SDO types for the root element are taken from those of the complex type of the document element, where it exists. Hence in this example the typename of the root data object is FormLetter. In the event that there is no separate complex type definition for the document element, when the the type is defined inline and is anonymous, the SDO type name will be the same as the element name.

The following program loads the letter document and checks the return values from each of the four calls.

<?php
/**
 * Finding out what you can about the document and document element
 * This can be quite hard to understand because there are four calls
 * Two calls are made against the document
 * Two calls are made against the root data object and its model
 * Because of the SDO-XML mapping rules and how the SDO model is derived
 * from the XML model, only three possible values can come back from these four calls.
 * Always, $document->getRootElementURI() == (type of root data object)->namespaceURI
 * Essentially, it all comes form the first few lines of the xsd:
 * <xsd:schema xmlns:xsd="http://www.w3.org/2001/XMLSchema"
 *   xmlns:letter="http://letterSchema"
 *   targetNamespace="http://letterSchema">
 *   <xsd:element name="letters" type="letter:FormLetter"/>
 */

$xmldas = SDO_DAS_XML::create("letter.xsd");
$document = $xmldas->loadFile("letter.xml");
$root_do = $document->getRootDataObject();

/**
 * The "root element name" is the element name of the document element
 * in this case 'letters'
 * This matches the 'name' attribute of the document element in the xsd and matches
 * the element name from the xml
 */
echo "The document element name is " . $document->getRootElementName() . "\n";
assert($document->getRootElementName() == 'letters'); // a property of the document

/**
 * The "root element URI" is the namespace part of the element name of the document element
 * in this case 'http://letterSchema' since 'letters' is in that namespace
 * This is taken from the xsd and matches the namespace picked up from the xml
 */
echo "The document element is in the namespace " . $document->getRootElementURI() . "\n";
assert($document->getRootElementURI() == 'http://letterSchema'); // a property of the document

/**
 * The type name is taken from the SDO model
 * The XML-SDO mapping rules make this either:
 *   The name of the complexType if there is one (in this case there is)
 *   The document element name if there no complexType
 * This is taken from the xsd
 */
echo "The type name of the root data object is " . $root_do->getTypeName() . "\n";
assert($root_do->getTypeName() == 'FormLetter');

/**
 * The type's namespaceURI is taken from the SDO model
 * The XML-SDO mapping rules ensure that this will always be the same as
 * the namepace URI of the document element
 */
echo "The namespaceURI of the root data object is " . $root_do->getTypeNamespaceURI() . "\n";
assert($root_do->getTypeNamespaceURI() == 'http://letterSchema');

?>

The output from this program is as follows:

The document element name is letters
The document element is in the namespace http://letterSchema
The type name of the root data object is FormLetter
The namespaceURI of the root data object is http://letterSchema

Příklad 1980. Printing the SDO model

The XML DAS provides a simple means to see what types and properties have been loaded. The php "print" or "echo" instruction will print out the types and properties.

<?php
/**
 * Illustrate printing out the model
 */

$xmldas = SDO_DAS_XML::create("letter.xsd");
print $xmldas;

?>

The output from this program is as follows:

object(SDO_XML_DAS)#1 {
18 types have been defined. The types and their properties are::
1. commonj.sdo:BigDecimal
2. commonj.sdo:BigInteger
3. commonj.sdo:Boolean
4. commonj.sdo:Byte
5. commonj.sdo:Bytes
6. commonj.sdo:ChangeSummary
7. commonj.sdo:Character
8. commonj.sdo:DataObject
9. commonj.sdo:Date
10. commonj.sdo:Double
11. commonj.sdo:Float
12. commonj.sdo:Integer
13. commonj.sdo:Long
14. commonj.sdo:Short
15. commonj.sdo:String
16. commonj.sdo:URI
17. http://letterSchema:FormLetter
- date (commonj.sdo:String)
- firstName (commonj.sdo:String)
- lastName (commonj.sdo:String)
18. http://letterSchema:RootType
- letters (http://letterSchema:FormLetter)

Předdefinované třídy

The XML DAS provides two main classes. The first is SDO_DAS_XML which is the main class used to fetch the data from the XML source and used to write the data back. The second is the SDO_DAS_XML_Document class, which represents the data in the XML document.

There are also some exception classes which can be thrown if errors are found when looking for or parsing the xsd or xml files.

SDO_DAS_XML

This is the main class of the XML DAS, which is used fetch the data from the xml source and also used to write the data back. Other than the methods to load and save xml files,

Metody

  • create This is a static method available in the SDO_DAS_XML class. Used to construct an SDO_DAS_XML object.

  • addTypes Works in much the same way as create() but used to add the contents of a second or subsequent schema file to an XML DAS that has already been created.

  • createDataObject Can be used to construct an SDO data object of a given type.

  • createDocument Can be used to construct an XML Document object from scratch.

  • loadFile Loads the xml instance document from a file. This file can be at local file system or it can be on a remote host.

  • loadString same as the above method. Loads the xml instance which is available as string.

  • saveFile save SDO_DAS_XML_Document object as a xml file.

  • saveString save SDO_DAS_XML_Document object as a xml string.

SDO_DAS_XML_Document

This class can be used to get to the name and namespace of the document element, and to get to the root data object of the document. Lastly, it can also be used to set the XML version and encoding of a document on output.

Metody

  • getRootDataObject gets the root DataObject.

  • getRootElementName gets the root DataObject's name.

  • getRootElementURI gets the root DataObject's URI.

  • setEncoding sets the encoding string with the given value.

  • setXMLDeclaraion to set/unset the xml declaration.

  • setXMLVersion sets the xml version with the given value.

SDO_DAS_XML_ParserException

Is a subclass of SDO_Exception. Thrown for any parser errors while loading the xsd/xml file.

SDO_DAS_XML_FileException

Is a subclass of SDO_Exception. Thrown by any of the methods that load data from a file, when the file cannot be found.

Limitations compared with SDO 2.0 specification

The » SDO 2.0 specification defines the mapping between XML types and SDO types. With Java SDO, this mapping is implemented by the XMLHelper. With SDO for PHP, this mapping is implemented by the XML Data Access Service. The XML DAS implements the mapping described in the SDO 2.0 specification with some restrictions. A detailed list is of the limitations is:

Postup 10. XML Simple Types

  1. Simple Type with sdoJava:instanceClass - no PHP equivalent provided.

  2. Simple Type with sdoJava:extendedInstanceClass - no PHP equivalent provided.

  3. Simple Type with list of itemType.

  4. Simple Type with union.

Postup 11. XML Complex Types

  • Complex Type with sdo:aliasName - no PHP support for SDO Type aliases.

Postup 12. XSD Attribute

  1. Attribute with sdo:aliasName - no PHP support for SDO property aliases.

  2. Attribute with default value - no PHP support for SDO property defaults.

  3. Attribute with fixed value - no PHP support for SDO read-only properties or default values.

  4. Attribute referencing a DataObject with sdo:propertyType - no support for sdo:propertyType="...".

  5. Attribute with bi-directional property to a DataObject with sdo:oppositeProperty and sdo:propertyType - no PHP support for SDO opposite.

Postup 13. XSD Elements

  1. Element with sdo:aliasName - no PHP support for SDO property aliases.

  2. Element with substitution group.

Postup 14. XSD Elements with Simple Type

  1. Element of SimpleType with default - no PHP support for SDO defaults

  2. Element of SimpleType with fixed value - no PHP support for SDO read-only properties or default values.

  3. Element of SimpleType with sdo:string - no support for sdo:string="true".

  4. Element referencing a DataObject with sdo:propertyType - no support for sdo:propertyType="..."

  5. Element with bi-directional reference to a DataObject with sdo:oppositeProperty and sdo:propertyType - no PHP support for SDO opposite.

Obsah

SDO_DAS_XML_Document::getRootDataObject — Returns the root SDO_DataObject
SDO_DAS_XML_Document::getRootElementName — Returns root element's name
SDO_DAS_XML_Document::getRootElementURI — Returns root element's URI string
SDO_DAS_XML_Document::setEncoding — Sets the given string as encoding
SDO_DAS_XML_Document::setXMLDeclaration — Sets the xml declaration
SDO_DAS_XML_Document::setXMLVersion — Sets the given string as xml version
SDO_DAS_XML::addTypes — To load a second or subsequent schema file to a SDO_DAS_XML object
SDO_DAS_XML::create — To create SDO_DAS_XML object for a given schema file
SDO_DAS_XML::createDataObject — Creates SDO_DataObject for a given namespace URI and type name
SDO_DAS_XML::createDocument — Creates an XML Document object from scratch, without the need to load a document from a file or string.
SDO_DAS_XML::loadFile — Returns SDO_DAS_XML_Document object for a given path to xml instance document
SDO_DAS_XML::loadString — Returns SDO_DAS_XML_Document for a given xml instance string
SDO_DAS_XML::saveFile — Saves the SDO_DAS_XML_Document object to a file
SDO_DAS_XML::saveString — Saves the SDO_DAS_XML_Document object to a string
Předcházející | Nahoru | Další
SDO_Sequence::move | Domů | SDO_DAS_XML_Document::getRootDataObject


SDO Relational Data Access Service Functions

Předcházející VI. Reference funkcí Další

CXLV. SDO Relational Data Access Service Functions

Úvod

Varování

Toto rozšíření je EXPERIMENTÁLNÍ. Chování tohoto rozšíření, názvy funkcí a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může bez ohlášení změnit. Berte to v úvahu a používejte tento modul na vlastní nebezpečí.

In order to use the Relational Data Access Service for Service Data Objects, you will need to understand some of the concepts behind SDO: the data graph, the data object, the disconnected way of working, the change summary, XPath and property expressions, and so on. If you are not familiar with these ideas, you might want to look first at the section on SDO. In addition, the Relational DAS makes use of the PDO extension to isolate itself from specifics of different back-end relational databases. In order to use the Relational DAS you will need to be able to create and pass a PDO database connection; for this reason you might also want to take a look at the section on PDO.

The job of the Relational DAS is to move data between the application and a relational database. In order to do this it needs to be told the mapping between the database entities - tables, columns, primary keys and foreign keys - and the elements of the SDO model - types, properties, containment relationships and so on. You specify this information as metadata when you construct the Relational DAS.

Postup 15. Overview of Operation

  1. The first step is to call the Relational DAS's constructor, passing the metadata that defines the mapping between database and SDO model. There are examples of this below.

  2. The next step might be to call the executeQuery() or executePreparedQuery() methods on the Relational DAS, passing either a literal SQL statement for the DAS to prepare and execute, or a prepared statement with placeholders and a list of values to be inserted. You may also need to specify a small amount of metadata about the query itself, so that the Relational DAS knows exactly what columns will be returned from the database and in what order. You will also need to pass a PDO database connection.

    The return value from executeQuery() or executePreparedQuery() is a normalised data graph containing all the data from the result set. For a query that returns data obtained from a number of tables, this graph will contain a number of data objects, linked by SDO containment relationships. There may also be SDO non-containment references within the data.

    Once the query has been executed and the data graph constructed, there is no need for either that instance of the the Relational DAS or the database connection. There are no locks held on the database. Both the Relational DAS and the PDO database connection can be garbage collected.

  3. Quite possibly the data in the data graph will go through a number of modifications. The data graph can be serialised into the PHP session and so may have a lifetime beyond just one client-server interaction. Data objects can be created and added to the graph, the data objects already in the graph can be deleted, and data objects in the graph can be modified.

  4. Finally, the changes made to the data graph can be applied back to the database using the applyChanges() method of the Relational DAS. For this, another instance of the Relational DAS must be constructed, using the same metadata, and another connection to the database obtained. The connection and the data graph are passed to applyChanges(). At this point the Relational DAS examines the change summary and generates the necessary INSERT, UPDATE and DELETE SQL statements to apply the changes. Any UPDATE and DELETE statements are qualified with the original values of the data so that should the data have changed in the database in the meantime this will be detected. Assuming no such collisions have occurred the changes will be committed to the database. The application can then continue to work with the data graph, make more changes and apply them, or can discard it.

There are other ways of working with the data in the database: it is possible to just create data objects and write them to the database without a preliminary call to executeQuery(), for example. This scenario and others are explored in the Examples section below.

Instalace

The installation instructions for all the SDO components are in the SDO install section of the SDO documentation.

In any case, the essential facts are that the Relational DAS is written in PHP and it should be placed somewhere on the PHP include_path .

Your application will of course need to include the Relational DAS with a statement like this: <?php
require_once 'SDO/DAS/Relational.php';
?>

Požadavky

The Relational DAS requires that the SDO extension be installed. The SDO extension requires a version of PHP 5.1, and the Relational DAS requires a recent version that contains an important fix for PDO. The most up-to-date information about required levels of PHP should be found in the changelog for the package on PECL. At the time of writing, though, the Relational DAS requires the most recent beta level of PHP 5.1, that is PHP 5.1.0.

The Relational DAS uses PDO to access the relational database, and so should run with a variety of different relational databases. At the time of writing it has been tested in the following configurations

  • MySQL 4.1.14, on Windows. The Relational DAS operates correctly with the php_pdo_mysql driver that comes with the pre-built binaries for PHP 5.1.0.

  • MySQL 4.1.13, on Linux. It is necessary to have the most up-to-date PDO driver for MySQL, which comes built in to PHP 5.1.0. It may be necessary to uninstall the usual driver that would have come from PECL using pear uninstall pdo_mysql . You will need to configure PHP with the --with-pdo-mysql option.

  • DB2 8.2 Personal Edition, on Windows. The Relational DAS operates correctly with the php_pdo_odbc driver that comes with the pre-built binaries for PHP 5.1.0.

  • DB2 8.2 Personal Developer's Edition, on Linux. The Developer's Edition is needed because it contains the include files needed when PHP is configured and built. You will need to configure PHP with the --with-pdo-odbc=ibm-db2 option.

The Relational DAS applies changes to the database within a user-delimited transaction: that is, it issues a call to PDO::beginTransaction() before beginning to apply changes, and PDO::commit() or PDO::rollback() on completion. Whichever database is chosen, the database and the PDO driver for the database must support these calls.

Limitations

There are the following limitations in the current release of the Relational DAS:

  • No support for nulls. There is no support for SQL NULL type. It is not legal to assign PHP NULL to a data object property and the Relational DAS will not write that back as a NULL to the database. If nulls are found in the database on a query, the property will remain unset.

  • Only two types of SDO relationship. The metadata described below allows the Relational DAS to model just two types of SDO relationship: multi-valued containment relationships and single-valued non-containment references. In SDO, whether a property describes a single- or multi-valued relationship, and whether it is containment or non-containment, are independent. The full range of possibilities that SDO allows cannot all be defined. There may be relationships that it would be useful to model but which the current implementation cannot manage. One example is a single-valued containment relationship.

  • No support for the full range of SDO data types. The Relational DAS defines all primitive properties in the SDO model as being of type string. SDO defines a richer set of types containing various integer, float, boolean and data and time types. String is adequate for the purposes of the Relational DAS since the combination of PHP, PDO and the database will ensure that values passed as strings will be converted to the proper type before being put in the database. This does affect some scenarios in which the Relational DAS has to work with a data graph that has come from or will go to a different DAS.

  • Only one foreign key per table. The metadata only provides the means to specify one foreign key per table. This foreign key may be mapped to one of the two types of SDO relationship supported. Obviously there are some scenarios that cannot be described under this limitation - it is not possible to have two non-containment references from one table to another for example.

Příklady

This section illustrates how the Relational DAS can be used to create, retrieve, update and delete data in a relational database. Many of the examples are illustrated with a three-table database that contains companies, departments within those companies, and employees that work in those departments. This example is used in a number of places within the SDO literature. See the examples section of the » Service Data Objects specification or the Examples section of the documentation for the SDO extension.

The Relational DAS is constructed with metadata that defines the relational database and how it should be mapped to SDO. The long section that follows describes this metadata and how to construct the Relational DAS. The examples that follow it all assume that this metadata is in an included php file.

The examples below and others can all be found in the Scenarios directory in the Relational DAS package.

The Relational DAS throws exceptions in the event that it finds errors in the metadata or errors when executing SQL statements against the database. For brevity the examples below all omit the use of try/catch blocks around the calls to the Relational DAS.

These examples all differ from the expected use of SDO in two important respects.

First, they show all interactions with the database completed within one script. In this respect these scenarios are not realistic but are chosen to illustrate just the use of the Relational DAS. It is expected that interactions with the database will be separated in time and the data graph serialised and deserialised into the PHP session one or more times as the application interacts with an end user.

Second, all queries executed against the database use hard-coded queries with no variables substituted. In this case it is safe to use the simple executeQuery() call, and this is what the examples illustrate. In practice, though, it is unlikely that the SQL statement is known entirely ahead of time. In order to allow variables to be safely substituted into the SQL queries, without running the risk of injecting SQL with unknown effects, it is safer to use the executePreparedQuery() which takes a prepared SQL statement containing placeholders and a list of values to be substituted.

Specifying the metadata

This first long section describes in detail how the metadata describing the database and the required SDO model is supplied to the Relational DAS.

When the constructor for the Relational DAS is invoked, it needs to be passed several pieces of information. The bulk of the information, passed as an associative array in the first argument to the constructor, tells the Relational DAS what it needs to know about the relational database. It describes the names of the tables, columns, primary keys and foreign keys. It should be fairly easy to understand what is required, and once written it can be placed in a php file and included when needed. The remainder of the information, passed in the second and third arguments to the constructor, tells the Relational DAS what it needs to know about the relationships between objects and the shape of the data graph; it ultimately determines how the data from the database is to be normalised into a graph.

Database metadata

The first argument to the constructor describes the target relational database.

Each table is described by an associative array with up to four keys.

Key | Value
name | The name of the table.
columns | An array listing the names of the columns, in any order.
PK | The name of the column containing the primary key.
FK | An array with two entries, 'from' and 'to', which define a column containing a foreign key, and a table to which the foreign key points. If there are no foreign keys in the table then the 'FK' entry does not need to be specified. Only one foreign key can be specified. Only a foreign key pointing to the primary key of a table can be specified.

<?php
/*****************************************************************
* METADATA DEFINING THE DATABASE
******************************************************************/
$company_table = array (
    'name' => 'company',
    'columns' => array('id', 'name',  'employee_of_the_month'),
    'PK' => 'id',
    'FK' => array (
        'from' => 'employee_of_the_month',
        'to' => 'employee',
        ),
    );
$department_table = array (
    'name' => 'department',
    'columns' => array('id', 'name', 'location', 'number', 'co_id'),
    'PK' => 'id',
    'FK' => array (
        'from' => 'co_id',
        'to' => 'company',
        )
    );
$employee_table = array (
    'name' => 'employee',
    'columns' => array('id', 'name', 'SN', 'manager', 'dept_id'),
    'PK' => 'id',
    'FK' => array (
        'from' => 'dept_id',
        'to' => 'department',
        )
    );
$database_metadata = array($company_table, $department_table, $employee_table);
?>

This metadata corresponds to a relational database that might have been defined to MySQL as:

 create table company (
   id integer auto_increment,
   name char(20),
   employee_of_the_month integer,
   primary key(id)
 );
 create table department (
   id integer auto_increment,
   name char(20),
   location char(10),
   number integer(3),
   co_id integer,
   primary key(id)
 );
 create table employee (
   id integer auto_increment,
   name char(20),
   SN char(4),
   manager tinyint(1),
   dept_id integer,
   primary key(id)
 );

or to DB2 as:

create table company ( \
    id integer not null generated by default as identity,  \
    name varchar(20), \
    employee_of_the_month integer, \
    primary key(id) )
create table department ( \
    id integer not null generated by default as identity, \
    name varchar(20), \
    location varchar(10), \
    number integer, \
    co_id integer, \
    primary key(id) )
create table employee ( \
    id integer not null generated by default as identity, \
    name varchar(20), \
    SN char(4), \
    manager smallint, \
    dept_id integer, \
    primary key(id) )

Note that although in this example there are no foreign keys specified to the database and so the database is not expected to enforce referential integrity, the intention behind the co_id column on the department table and the dept_id column on the employee table is they should contain the primary key of their containing company or department record, respectively. So these two columns are acting as foreign keys.

There is a third foreign key in this example, that from the employee_of_the_month column of the company record to a single row of the employee table. Note the difference in intent between this foreign key and the other two. The employee_of_the_month column represents a single-valued relationship: there can be only one employee of the month for a given company. The co_id and dept_id columns represent multi-valued relationships: a company can contain many departments and a department can contain many employees. This distinction will become evident when the remainder of the metadata picks out the company-department and department-employee relationships as containment relationships.

There are a few simple rules to be followed when constructing the database metadata:

  • All tables must have primary keys, and the primary keys must be specified in the metadata. Without primary keys it is not possible to keep track of object identities. As you can see from the SQL statements that create the tables, primary keys can be auto-generated, that is, generated and assigned by the database when a record is inserted. In this case the auto-generated primary key is obtained from the database and inserted into the data object immediately after the row is inserted into the database.

  • It is not necessary to specify in the metadata all the columns that exist in the database, only those that will be used. For example, if the company table had another column that the application did not want to access with SDO, this need not be specified in the metadata. On the other hand it would have done no harm to specify it: if specified in the metadata but never retrieved, or assigned to by the application, then the unused column will not affect anything.

  • In the database metadata note that the foreign key definitions identify not the destination column in the table which is pointed to, but the table name itself. Strictly, the relational model permits the destination of a foreign key to be a non-primary key. Only foreign keys that point to a primary key are useful for constructing the SDO model, so the metadata specifies the table name. It is understood that the foreign key points to the primary key of the given table.

Given these rules, and given the SQL statements that define the database, the database metadata should be easy to construct.

What the Relational DAS does with the metadata

The Relational DAS uses the database metadata to form most of the SDO model. For each table in the database metadata, an SDO type is defined. Each column which can represent a primitive value (columns which are not defined as foreign keys) are added as properties to the SDO type.

All primitive properties are given a type of string in the SDO model, regardless of their SQL type. When writing values back to the database the Relational DAS will create SQL statements that treat the values as strings, and the database will convert them to the appropriate type.

Foreign keys are interpreted in one of two ways, depending on the metadata in the third argument to the constructor that defines the SDO containment relationships. A discussion of this is therefore deferred until the section on SDO containment relationships below.

Specifying the application root type

The second argument to the constructor is the application root type. The true root of each data graph is an object of a special root type and all application data objects come somewhere below that. Of the various application types in the SDO model, one has to be the application type immediately below the root of the data graph. If there is only one table in the database metadata, the application root type can be inferred, and this argument can be omitted.

Specifying the SDO containment relationships

The third argument to the constructor defines how the types in the model are to be linked together to form a graph. It identifies the parent-child relationships between the types which collectively form a graph. The relationships need to be supported by foreign keys to be found in the data, in a way shortly to be described.

The metadata is an array containing one or more associative arrays, each of which identifies a parent and a child. The example below shows a parent-child relationship from company to department, and another from department to employee. Each of these will become an SDO property defining a multi-valued containment relationship in the SDO model.

<?php
$department_containment = array( 'parent' => 'company', 'child' => 'department');
$employee_containment = array( 'parent' => 'department', 'child' => 'employee');

$SDO_containment_metadata = array($department_containment, $employee_containment);
?>

Foreign keys in the database metadata are interpreted as properties with either multi-valued containment relationships or single-valued non-containment references, depending on whether they have a corresponding SDO containment relationship specified in the metadata. In the example here, the foreign keys from department to company (the co_id column in the department table) and from employee to department (the dept_id column in the employee table) are interpreted as supporting the SDO containment relationships. Each containment relationship mentioned in the SDO containment relationships metadata must have a corresponding foreign key present in the database and defined in the database metadata. The values of the foreign key columns for containment relationships do not appear in the data objects, instead each is represented by a containment relationship from the parent to the child. So the co_id column in the department row in the database, for example, does not appear as a property on the department type, but instead as a containment relationship called department on the company type. Note that the foreign key and the parent-child relationship appear to have opposite senses: the foreign key points from the department to the company, but the parent-child relationship points from company to department.

The third foreign key in this example, the employee_of_the_month , is handled differently. This is not mentioned in the SDO containment relationships metadata. As a consequence this is interpreted in the second way: it becomes a single-valued non-containment reference on the company object, to which can be assigned references to SDO data objects of the employee type. It does appear as a property on the company type. The way to assign a value to it in the SDO data graph is to have a graph that contains an employee object through the containment relationships, and to assign the object to it. This is illustrated in the later examples below.

One-table examples

The following set of examples all use the Relational DAS to work with a data graph containing just one application data object, a single company and the data just to be found the company table. These examples do not exercise the power of SDO or the Relational DAS and of course the same result could be achieved more economically with direct SQL statements but they are intended to illustrate how to work with the Relational DAS.

For this very simple scenario it would be possible to simplify the database metadata to include just the company table - if that were done the second and third arguments to the constructor and the column specifier used in the query example would become optional.

Příklad 1981. Creating a data object

The simplest example is that of creating a single data object and writing it to the database. In this example a single company object is created, its name is set to 'Acme', and the Relational DAS is called to write the changes to the database. The company name is set here using the property name method. See the Examples section on the SDO extension for other ways of accessing the properties of an object.

Data objects can only be created when you have a data object to start with, however. It is for that reason that the first call to the Relational DAS here is to obtain a root object. This is in effect how to ask for an empty data graph - the special root object is the true root of the tree. The company data object is then created with a call to createDataObject() on the root object. This creates the company data object and inserts it in the graph by inserting into a multi-valued containment property on the root object called 'company'.

When the Relational DAS is called to apply the changes a simple insert statement 'INSERT INTO company (name) VALUES ("Acme");' will be constructed and executed. The auto-generated primary key will be set into the data object and the change summary will be reset, so that it would be possible to continue working with the same data object, modify it, and apply the newer changes a second time.

<?php
require_once 'SDO/DAS/Relational.php';
require_once 'company_metadata.inc.php';

/**************************************************************
 * Construct the DAS with the metadata
 ***************************************************************/
$das = new SDO_DAS_Relational ($database_metadata,'company',$SDO_containment_metadata);

/**************************************************************
 * Obtain a root object and create a company object underneath.
 * Make a simple change to the data object.
 ***************************************************************/
$root = $das  -> createRootDataObject();
$acme = $root -> createDataObject('company');

$acme->name = "Acme";

/**************************************************************
 * Get a database connection and write the object to the database
 ***************************************************************/
$dbh = new PDO(PDO_DSN,DATABASE_USER,DATABASE_PASSWORD);
$das -> applyChanges($dbh, $root);
?>

Příklad 1982. Retrieving a data object

In this example a single data object is retrieved from the database - or possibly more than one if there is more than one company called 'Acme'. For each company returned, the name and id properties are echoed.

In this example the third argument to executeQuery(), the column specifier is needed as there are other tables in the metadata with column names of name and id. If there were no possible ambiguity it could be omitted.

<?php
require_once 'SDO/DAS/Relational.php';
require_once 'company_metadata.inc.php';

/**************************************************************
 * Construct the DAS with the metadata
 ***************************************************************/
$das = new SDO_DAS_Relational ($database_metadata,'company',$SDO_containment_metadata);

/**************************************************************
 * Get a database connection
 ***************************************************************/
$dbh = new PDO(PDO_DSN,DATABASE_USER,DATABASE_PASSWORD);

/**************************************************************
 * Issue a query to obtain a company object - possibly more if they exist
 ***************************************************************/
$root = $das->executeQuery($dbh,
           'select name, id from company where name="Acme"',
            array('company.name', 'company.id') );

/**************************************************************
 * Echo name and id
 ***************************************************************/
foreach ($root['company'] as $company) {
    echo "Company obtained from the database has name = " .
    $company['name'] . " and id " . $company['id'] . "\n";
}
?>

Příklad 1983. Updating a data object

This example combines the previous two, in the sense that in order to be updated the object must first be retrieved. The application code reverses the company name (so 'Acme' becomes 'emcA') and then the changes are written back to the database in the same way that they were when the object was created. Because the query searches for the name both ways round the program can be run repeatedly to find the company and reverse its name each time.

In this example the same instance of the Relational DAS is reused for the applyChanges(), as is the PDO database handle. This is quite alright; it also alright to allow the previous instances to be garbage collected and to obtain new instances. No state data regarding the graph is held the Relational DAS once it has returned a data graph to the application. All necessary data is either within the graph itself, or can be reconstructed from the metadata.

<?php
require_once 'SDO/DAS/Relational.php';
require_once 'company_metadata.inc.php';

/**************************************************************
 * Construct the DAS with the metadata
 ***************************************************************/
$das = new SDO_DAS_Relational ($database_metadata,'company',$SDO_containment_metadata);

/**************************************************************
 * Get a database connection
 ***************************************************************/
$dbh = new PDO(PDO_DSN,DATABASE_USER,DATABASE_PASSWORD);

/**************************************************************
 * Issue a query to obtain a company object - possibly more if they exist
 ***************************************************************/
$root = $das->executeQuery($dbh,
    'select name, id from company where name="Acme" or name="emcA"',
    array('company.name', 'company.id') );

/**************************************************************
 * Alter the name of just the first company
 ***************************************************************/
$company = $root['company'][0];
echo "obtained a company with name of " . $company->name . "\n";
$company->name = strrev($company->name);

/**************************************************************
 * Write the change back
 ***************************************************************/
$das->applyChanges($dbh,$root);
?>

Příklad 1984. Deleting a data object

Any companies called 'Acme' or its reverse 'emcA' are retrieved. They are then all deleted from the graph with unset.

In this example they are all deleted in one go by unsetting the containing property (the property defining the containment relationship). It is also possible to delete them individually.

<?php
require_once 'SDO/DAS/Relational.php';
require_once 'company_metadata.inc.php';

/**************************************************************
 * Construct the DAS with the metadata
 ***************************************************************/
$das = new SDO_DAS_Relational ($database_metadata,'company',$SDO_containment_metadata);

/**************************************************************
 * Get a database connection
 ***************************************************************/
$dbh = new PDO(PDO_DSN,DATABASE_USER,DATABASE_PASSWORD);

/**************************************************************
 * Issue a query to obtain a company object - possibly more if they exist
 ***************************************************************/
$root = $das->executeQuery($dbh,
    'select name, id from company where name="Acme" or name="emcA"',
    array('company.name', 'company.id') );

/**************************************************************
 * Delete any companies found from the data graph
 ***************************************************************/
unset($root['company']);

/**************************************************************
 * Write the change(s) back
 ***************************************************************/
$das->applyChanges($dbh,$root);
?>

Two-table examples

The following set of examples all use two tables from the company database: the company and department tables. These examples exercise more of the function of the Relational DAS.

In this series of examples a company and department are created, retrieved, updated, and finally deleted. This illustrates the lifecycle for a data graph containing more than one object. Note that this example clears out the company and department tables at the start so that the exact results of the queries can be known.

You can find these examples combined into one script called 1cd-CRUD in the Scenarios directory in the Relational DAS package.

Příklad 1985. One company, one department - Create

As in the earlier example of creating just one company data object, the first action after constructing the Relational DAS is to call createRootDataObject() to obtain the special root object of the otherwise empty data graph. The company object is then created as a child of the root object, and the department object as a child of the company object.

When it comes to applying the changes, the Relational DAS has to perform special processing to maintain the foreign keys that support the containment relationships, especially if auto-generated primary keys are involved. In this example, the relationship between the auto-generated primary key id in the company table and the co_id column in the department table must be maintained. When inserting a company and department for the first time the Relational DAS has to first insert the company row, then call PDO's getLastInsertId() method to obtain the auto-generated primary key, then add that as the value of the co_id column when inserting the department row.

<?php
require_once 'SDO/DAS/Relational.php';
require_once 'company_metadata.inc.php';

/*************************************************************************************
* Empty out the two tables
*************************************************************************************/
$dbh = new PDO(PDO_DSN,DATABASE_USER,DATABASE_PASSWORD);
$pdo_stmt = $dbh->prepare('DELETE FROM COMPANY;');
$rows_affected = $pdo_stmt->execute();
$pdo_stmt = $dbh->prepare('DELETE FROM DEPARTMENT;');
$rows_affected = $pdo_stmt->execute();

/**************************************************************
* Create a company with name Acme and one department, the Shoe department
***************************************************************/
$dbh = new PDO(PDO_DSN,DATABASE_USER,DATABASE_PASSWORD);
$das = new SDO_DAS_Relational ($database_metadata,'company',$SDO_containment_metadata);

$root = $das -> createRootDataObject();

$acme = $root -> createDataObject('company');
$acme -> name = "Acme";

$shoe = $acme->createDataObject('department');
$shoe->name = 'Shoe';

$das -> applyChanges($dbh, $root);

?>

Příklad 1986. One company, one department - Retrieve and Update

In this case the SQL query passed to executeQuery() performs an inner join to join the data from the company and department tables. Primary keys for both the company and department tables must be included in the query. The result set is re-normalised to form a normalised data graph. Note that a column specifier is passed as the third argument to the executeQuery() call enabling the Relational DAS to know which column is which in the result set.

Note that the co_id column although used in the query is not needed in the result set. In order to understand what the Relational DAS is doing when it builds the data graph it may be helpful to visualise what the result set looks like. Although the data in the database is normalised, so that multiple department rows can point through their foreign key to one company row, the data in the result set is non-normalised: that is, if there is one company and multiple departments, the values for the company are repeated in each row. The Relational DAS has to reverse this process and turn the result set back into a normalised data graph, with just one company object.

In this example the Relational DAS will examine the result set and column specifier, find data for both the company and department tables, find primary keys for both, and interpret each row as containing data for a department and its parent company. If it has not seen data for that company before (it uses the primary key to check) it creates a company object and then a department object underneath it. If it has seen data for that company before and has already created the company object it just creates the department object underneath.

In this way the Relational DAS can retrieve and renormalise data for multiple companies and multiple departments underneath them.

<?php
require_once 'SDO/DAS/Relational.php';
require_once 'company_metadata.inc.php';

/**************************************************************
 * Retrieve the company and Shoe department, then delete Shoe and add IT
 ***************************************************************/
$dbh = new PDO(PDO_DSN,DATABASE_USER,DATABASE_PASSWORD);
$das = new SDO_DAS_Relational ($database_metadata,'company',$SDO_containment_metadata);

$root = $das->executeQuery($dbh,
'select c.id, c.name, d.id, d.name from company c, department d where d.co_id = c.id',
array('company.id','company.name','department.id','department.name'));

$acme = $root['company'][0];            // get the first company - will be 'Acme'
$shoe = $acme['department'][0];         // get the first department underneath - will be 'Shoe'

unset($acme['department'][0]);

$it = $acme->createDataObject('department');
$it->name = 'IT';

$das -> applyChanges($dbh, $root);
?>

Příklad 1987. One company, two departments - Retrieve and Delete

In this example the company and department are retrieved and then deleted. It is not necessary to delete them individually (although that would be possible) - deleting the company object from the data graph also deletes any departments underneath it.

Note the way that the company object is actually deleted using the PHP unset call. The unset has to be performed on the containing property which in this case is the company property on the special root object. You must use: <?php
unset($root['company'][0]);
?> and not: <?php
unset($acme); //WRONG
?> Simply unsetting $acme would destroy the variable but leave the data in the data graph untouched.

<?php
require_once 'SDO/DAS/Relational.php';
require_once 'company_metadata.inc.php';

/**************************************************************
 * Retrieve the company and IT department, then delete the whole company
 ***************************************************************/
$dbh = new PDO(PDO_DSN,DATABASE_USER,DATABASE_PASSWORD);
$das = new SDO_DAS_Relational ($database_metadata,'company',$SDO_containment_metadata);

$root = $das->executeQuery($dbh,
'select c.id, c.name, d.id, d.name from company c, department d where d.co_id = c.id',
array('company.id','company.name','department.id','department.name'));

$acme = $root['company'][0];
$it = $acme['department'][0];

unset($root['company'][0]);

$das -> applyChanges($dbh, $root);

?>

Three-table example

The following examples use all three tables from the company database: the company, department, and employee tables. These introduce the final piece of function not exercised by the examples above: the non-containment reference employee_of_the_month.

Like the examples above for company and department, this set of examples is intended to illustrate the full lifecycle of such a data graph.

Příklad 1988. One company, one department, one employee - Create

In this example a company is created containing one department and just one employee. Note that this example clears out all three tables at the start so that the exact results of the queries can be known.

Note how once the company, department and employee have been created, the employee_of_the_month property of the company can be made to point at the new employee. As this is a non-containment reference, this cannot be done until the employee object has been created within the graph. Non-containment references need to be managed carefully. For example if the employee were now deleted from under the department, it would not be correct to try to save the graph without first clearing or re-assigning the employee_of_the_month property. The closure rule for SDO data graphs requires that any object pointed at by a non-containment reference must also be reachable by containment relationships.

When it comes to inserting the graph into the database, the procedure is similar to the example of inserting the company and department, but employee_of_the_month introduces an extra complexity. The Relational DAS needs to insert the objects working down the tree formed by containment relationships, so company, then department, then employee. This is necessary so that it always has the auto-generated primary key of a parent on hand to include in a child row. But when the company row is inserted the employee who is employee of the month has not yet been inserted and the primary key is not known. The procedure is that after the employee record is inserted and its primary key known, a final step is performed in which the the company record is updated with the employee's primary key.

<?php
require_once 'SDO/DAS/Relational.php';
require_once 'company_metadata.inc.php';

/*************************************************************************************
* Empty out the three tables
*************************************************************************************/
$dbh = new PDO(PDO_DSN,DATABASE_USER,DATABASE_PASSWORD);
$pdo_stmt = $dbh->prepare('DELETE FROM COMPANY;');
$rows_affected = $pdo_stmt->execute();
$pdo_stmt = $dbh->prepare('DELETE FROM DEPARTMENT;');
$rows_affected = $pdo_stmt->execute();
$pdo_stmt = $dbh->prepare('DELETE FROM EMPLOYEE;');
$rows_affected = $pdo_stmt->execute();

/*************************************************************************************
* Create a tiny but complete company.
* The company name is Acme.
* There is one department, Shoe.
* There is one employee, Sue.
* The employee of the month is Sue.
*************************************************************************************/
$das = new SDO_DAS_Relational ($database_metadata,'company',$SDO_containment_metadata);
$dbh = new PDO(PDO_DSN,DATABASE_USER,DATABASE_PASSWORD);

$root             = $das  -> createRootDataObject();
$acme             = $root -> createDataObject('company');
$acme -> name     = "Acme";
$shoe             = $acme -> createDataObject('department');
$shoe -> name     = 'Shoe';
$shoe -> location = 'A-block';
$sue              = $shoe -> createDataObject('employee');
$sue -> name      = 'Sue';
$acme -> employee_of_the_month = $sue;

$das -> applyChanges($dbh, $root);

echo "Wrote back Acme with one department and one employee\n";
?>

Příklad 1989. One company, one department, one employee - Retrieve and update

The SQL statement passed to the Relational DAS is this time an inner join that retrieves data from all three tables. Otherwise this example introduces nothing that has not appeared in a previous example.

The graph is updated by the addition of a new department and employee and some alterations to the name properties of the existing objects in the graph. The combined changes are then written back. The Relational DAS will process and apply an arbitrary mixture of additions, modifications and deletions to and from the data graph.

<?php
require_once 'SDO/DAS/Relational.php';
require_once 'company_metadata.inc.php';

/*************************************************************************************
 * Find the company again and change various aspects.
 * Change the name of the company, department and employee.
 * Add a second department and a new employee.
 * Change the employee of the month.
 *************************************************************************************/
$das = new SDO_DAS_Relational ($database_metadata,'company',$SDO_containment_metadata);
$dbh = new PDO(PDO_DSN,DATABASE_USER,DATABASE_PASSWORD);

$root = $das->executeQuery($dbh,
    "select c.id, c.name, c.employee_of_the_month, d.id, d.name, e.id, e.name " .
    "from company c, department d, employee e " .
    "where e.dept_id = d.id and d.co_id = c.id and c.name='Acme'",
     array('company.id','company.name','company.employee_of_the_month',
     'department.id','department.name','employee.id','employee.name'));
$acme         = $root['company'][0];

$shoe         = $acme->department[0];
$sue          = $shoe -> employee[0];

$it           = $acme->createDataObject('department');
$it->name     = 'IT';
$it->location = 'G-block';
$billy        = $it->createDataObject('employee');
$billy->name  = 'Billy';

$acme->name   = 'MegaCorp';
$shoe->name   = 'Footwear';
$sue->name    = 'Susan';

$acme->employee_of_the_month = $billy;
$das -> applyChanges($dbh, $root);
echo "Wrote back company with extra department and employee and all the names changed (Megacorp/Footwear/Susan)\n";

?>

Příklad 1990. One company, two departments, two employees - Retrieve and delete

The company is retrieved as a complete data graph containing five data objects - the company, two departments and two employees. They are all deleted by deleting the company object. Deleting an object from the graph deletes all the object beneath it in the graph. Five SQL DELETE statements will be generated and executed. As always they will be qualified with a WHERE clause that contains all of the fields that were retrieved, so that any updates to the data in the database in the meantime by another process will be detected.

<?php
require_once 'SDO/DAS/Relational.php';
require_once 'company_metadata.inc.php';

/*************************************************************************************
 * Now read it one more time and delete it.
 * You can delete part, apply the changes, then carry on working with the same graph but
 * care is needed to keep closure - you cannot delete the employee who is eotm without
 * reassigning. For safety here we delete the company all in one go.
 *************************************************************************************/
$das = new SDO_DAS_Relational ($database_metadata,'company',$SDO_containment_metadata);
$dbh = new PDO(PDO_DSN,DATABASE_USER,DATABASE_PASSWORD);

$root = $das->executeQuery($dbh,
    "select c.id, c.name, c.employee_of_the_month, d.id, d.name, e.id, e.name " .
    "from company c, department d, employee e " .
    "where e.dept_id = d.id and d.co_id = c.id and c.name='MegaCorp';",
     array('company.id','company.name','company.employee_of_the_month',
     'department.id','department.name','employee.id','employee.name'));
$megacorp = $root['company'][0];

unset($root['company']);
$das -> applyChanges($dbh, $root);

echo "Deleted the company, departments and employees all in one go.\n";

?>

Tracing

You may be interested in seeing the SQL statements that are generated in order to apply changes back to the database. At the top of the SDO/DAS/Relational.php you will find a number of constants which control whether the process of constructing and executing the SQL statements is to be traced. Try setting DEBUG_EXECUTE_PLAN to TRUE to see the generated SQL statements.

Předdefinované třídy

The Relational DAS provides two classes: the Relational DAS itself and the subclass of Exception that can be thrown. The Relational DAS has four publicly useful calls: the constructor, the createRootDataObject() call to obtain the root object of an empty data graph, the executeQuery() call to obtain a data graph containing data from a relational database, and the applyChanges() call to write changes made to a data graph back to the relational database.

SDO_DAS_Relational

The only object other than an SDO_DAS_Relational_Exception with which the application is expected to interact.

Metody

  • __construct - construct the Relational DAS with a model derived from the passed metadata

  • createRootDataObject - obtain an otherwise empty data graph containing just the special root object

  • executeQuery - execute an SQL query passed as a literal string and return the results as a normalised data graph

  • executePreparedQuery - execute an SQL query passed as a prepared statement, with a list of values to substitute for placeholders, and return the results as a normalised data graph

  • applyChanges - examine the change summary in the data graph and apply those changes back to the database, subject to an assumption of optimistic concurrency

SDO_DAS_Relational_Exception

Is a subclass of PHP's Exception. It adds no behaviour to Exception. Thrown, with useful descriptive text, to signal errors in the metadata or unexpected failures to perform SQL operations.

Obsah

SDO_DAS_Relational::applyChanges — Applies the changes made to a data graph back to the database.
SDO_DAS_Relational::__construct — Creates an instance of a Relational Data Access Service
SDO_DAS_Relational::createRootDataObject — Returns the special root object in an otherwise empty data graph. Used when creating a data graph from scratch.
SDO_DAS_Relational::executePreparedQuery — Executes an SQL query passed as a prepared statement, with a list of values to substitute for placeholders, and return the results as a normalised data graph.
SDO_DAS_Relational::executeQuery — Executes a given SQL query against a relational database and returns the results as a normalised data graph.
Předcházející | Nahoru | Další
SDO_DAS_XML::saveString | Domů | SDO_DAS_Relational::applyChanges


PostgreSQL Session Save Handler

Předcházející VI. Reference funkcí Další

CXLVIII. PostgreSQL Session Save Handler

Úvod

Poznámka: Toto rozšíření není k dispozici na platformách Windows.

This module provides an additional session save handler for the session module using » PostgreSQL as a storage system. A user-level session storage function may also be used - session_set_save_handler(), but this module is written in C and therefore could be twice as fast, compared to a session save handler written in PHP.

Session PgSQL is designed to scale any size of web sites and offers some advanced features:
session tables are created automatically
automatic session table vacuum
better garbage collection
multiple PostgreSQL servers support
automatic database server failover (switching)
automatic database server load balancing if there are multiple PostgreSQL servers.
short circuit UPDATE

Požadavky

You need at least PHP >= 4.3.0, and PostgreSQL >=7.2.0 as database server. libpq that comes with PostgreSQL 7.2.0 or later (and header files to build) and » libmm (and header files).

Instalace

Short installation note:

  • Untar the tar.gz archive into php4/ext (Latest official releases can be found at SourceForge » PHP Form Extension Project)
  • If the new directory is now called something like session_pgsql. You should name it to session_pgsql (except you only want to build it as self-contained php-module).
  • Run ./buildconf in php4
  • Run configure --with-session-pgsql (and your other options)
  • make; make install

Konfigurace běhu

Chování těchto funkcí je ovlivněno nastavením parametrů v php.ini.

PostgreSQL session save handler is still under development. Refer to the README file in the source distribution for configuration details.

Table definitions

Session table definition

CREATE TABLE php_session (
  sess_id            text,
  sess_name          text,
  sess_data          text,
  sess_created       integer,
  sess_modified      integer,
  sess_expire        integer,
  sess_addr_created  text,
  sess_addr_modified text,
  sess_counter       integer,
  sess_error         integer,
  sess_warning       integer,
  sess_notice        integer,
  sess_err_message   text,
  sess_custom        text
);

CREATE INDEX php_session_idx ON php_session USING BTREE (sess_id);

Varování

If you use HASH for INDEX, you'll have a deadlock problem when the server load is very high. Even if it's unlikely to have a deadlock under normal operation, it can occur. Do not use HASH for INDEX.

You may change the session table as long as all fields are defined.

Application variables table definition

CREATE TABLE php_app_vars (
  app_modified       integer,
  app_name           text,
  app_vars           text
);

Contact Information

I have at the moment not very much time to further develop this extension. I will implement more and more features in the near future.

If you have comments, bug fixes, enhancements or want to help developing this, you can drop me a mail at » yohgaki@php.net. Any help is very welcome.

Obsah

session_pgsql_add_error — Increments error counts and sets last error message
session_pgsql_get_error — Returns number of errors and last error message
session_pgsql_get_field — Get custom field value
session_pgsql_reset — Reset connection to session database servers
session_pgsql_set_field — Set custom field value
session_pgsql_status — Get current save handler status
Předcházející | Nahoru | Další
sesam_settransaction | Domů | session_pgsql_add_error


Secure Shell2 Functions

Předcházející VI. Reference funkcí Další

CLVIII. Secure Shell2 Functions

Úvod

Bindings to the » libssh2 library which provide access to resources (shell, remote exec, tunneling, file transfer) on a remote machine using a secure cryptographic transport.

Instalace

Windows binaries may be found at » http://snaps.php.net/. To install, download php_ssh2.dll to the folder specified by your php.ini file's extension_dir directive. Enable it by adding extension=php_ssh2.dll to your php.ini and restarting your web server.

extension_dir=c:/php5/exts/
extension=php_ssh2.dll

Linux, BSD, and other *nix variants can be compiled using the following steps:

  • Download and install » OpenSSL. If you install OpenSSL via your distribution's packaging system be sure to install the development libraries as well. This will typically be a package named openssl-dev, openssl_devel, or some variation thereof.
  • Download and install » libssh2. Typically this means executing the following command from the libssh2 source tree. ./configure && make all install.
  • Run the pear installer for PECL/ssh2: pear install ssh2
  • Copy ssh2.so from the directory indicated by the build process to the location specified in your php.ini file under extension_dir.
  • Add extension=ssh2.so to your php.ini
  • Restart your web server to reload your php.ini settings.

Development Versions: There are currently no stable versions of PECL/ssh2, to force installation of the beta version of PECL/ssh2 execute: pear install ssh2-beta

Compiling PECL/ssh2 without using the PEAR command

Rather than using pear install ssh2 to automatically download and install PECL/ssh2, you may download the tarball from » PECL. From the root of the unpacked tarball, run: phpize && ./configure --with-ssh2 && make to generate ssh2.so. Once built, continue the installation from step 4 above.

Informace o instalaci tohoto PECL rozšíření lze najít v kapitole manuálu nazvané Instalace rozšíření PECL. Další informace, jako nové verze, soubory ke stažení, zdrojové soubory, správcovské informace a CHANGELOG, lze najít zde: » http://pecl.php.net/package/ssh2.

Poznámka: You will need version 0.4 or greater of the libssh2 library (possibly higher, see release notes).

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

SSH2_FINGERPRINT_MD5 (integer)
Flag to ssh2_fingerprint() requesting hostkey fingerprint as an MD5 hash.
SSH2_FINGERPRINT_SHA1 (integer)
Flag to ssh2_fingerprint() requesting hostkey fingerprint as an SHA1 hash.
SSH2_FINGERPRINT_HEX (integer)
Flag to ssh2_fingerprint() requesting hostkey fingerprint as a string of hexits.
SSH2_FINGERPRINT_RAW (integer)
Flag to ssh2_fingerprint() requesting hostkey fingerprint as a raw string of 8-bit characters.
SSH2_TERM_UNIT_CHARS (integer)
Flag to ssh2_shell() specifying that width and height are provided as character sizes.
SSH2_TERM_UNIT_PIXELS (integer)
Flag to ssh2_shell() specifying that width and height are provided in pixel units.
SSH2_DEFAULT_TERM_WIDTH (integer)
Default terminal width requested by ssh2_shell().
SSH2_DEFAULT_TERM_HEIGHT (integer)
Default terminal height requested by ssh2_shell().
SSH2_DEFAULT_TERM_UNIT (integer)
Default terminal units requested by ssh2_shell().
SSH2_STREAM_STDIO (integer)
Flag to ssh2_fetch_stream() requesting STDIO subchannel.
SSH2_STREAM_STDERR (integer)
Flag to ssh2_fetch_stream() requesting STDERR subchannel.
SSH2_DEFAULT_TERMINAL (string)
Default terminal type (e.g. vt102, ansi, xterm, vanilla) requested by ssh2_shell().

Obsah

ssh2_auth_hostbased_file — Authenticate using a public hostkey
ssh2_auth_none — Authenticate as "none"
ssh2_auth_password — Authenticate over SSH using a plain password
ssh2_auth_pubkey_file — Authenticate using a public key
ssh2_connect — Connect to an SSH server
ssh2_exec — Execute a command on a remote server
ssh2_fetch_stream — Fetch an extended data stream
ssh2_fingerprint — Retreive fingerprint of remote server
ssh2_methods_negotiated — Return list of negotiated methods
ssh2_publickey_add — Add an authorized publickey
ssh2_publickey_init — Initialize Publickey subsystem
ssh2_publickey_list — List currently authorized publickeys
ssh2_publickey_remove — Remove an authorized publickey
ssh2_scp_recv — Request a file via SCP
ssh2_scp_send — Send a file via SCP
ssh2_sftp_lstat — Stat a symbolic link
ssh2_sftp_mkdir — Create a directory
ssh2_sftp_readlink — Return the target of a symbolic link
ssh2_sftp_realpath — Resolve the realpath of a provided path string
ssh2_sftp_rename — Rename a remote file
ssh2_sftp_rmdir — Remove a directory
ssh2_sftp_stat — Stat a file on a remote filesystem
ssh2_sftp_symlink — Create a symlink
ssh2_sftp_unlink — Delete a file
ssh2_sftp — Initialize SFTP subsystem
ssh2_shell — Request an interactive shell
ssh2_tunnel — Open a tunnel through a remote server
Předcházející | Nahoru | Další
PDO->sqliteCreateFunction() | Domů | ssh2_auth_hostbased_file


Statistics Functions

Předcházející VI. Reference funkcí Další

CLIX. Statistics Functions

Úvod

This is the statistics extension. It contains few dozens of functions useful for statistical computations. It is a wrapper around 2 scientific libraries, namely DCDFLIB (Library of C routines for Cumulative Distributions Functions, Inverses, and Other parameters) by B. Brown & J. Lavato and RANDLIB by Barry Brown, James Lavato & Kathy Russell. Includes CD and PD functions.

Instalace

Toto rozšíření » PECL není přibaleno k PHP.

Informace o instalaci tohoto PECL rozšíření lze najít v kapitole manuálu nazvané Instalace rozšíření PECL. Další informace, jako nové verze, soubory ke stažení, zdrojové soubory, správcovské informace a CHANGELOG, lze najít zde: » http://pecl.php.net/package/stats.

Tuto DLL knihovnu pro rozšíření PECL můžete stahovat ze stránky » PHP Downloads nebo z » http://snaps.php.net/.

Požadavky

No external libraries are needed. The extension comes bundled with the libraries used.

Obsah

stats_absolute_deviation — Returns the absolute deviation of an array of values
stats_cdf_beta — CDF function for BETA Distribution. Calculates any one parameter of the beta distribution given values for the others.
stats_cdf_binomial — Calculates any one parameter of the binomial distribution given values for the others.
stats_cdf_cauchy — Not documented
stats_cdf_chisquare — Calculates any one parameter of the chi-square distribution given values for the others.
stats_cdf_exponential — Not documented
stats_cdf_f — Calculates any one parameter of the F distribution given values for the others.
stats_cdf_gamma — Calculates any one parameter of the gamma distribution given values for the others.
stats_cdf_laplace — Not documented
stats_cdf_logistic — Not documented
stats_cdf_negative_binomial — Calculates any one parameter of the negative binomial distribution given values for the others.
stats_cdf_noncentral_chisquare — Calculates any one parameter of the non-central chi-square distribution given values for the others.
stats_cdf_noncentral_f — Calculates any one parameter of the Non-central F distribution given values for the others.
stats_cdf_poisson — Calculates any one parameter of the Poisson distribution given values for the others.
stats_cdf_t — Calculates any one parameter of the T distribution given values for the others.
stats_cdf_uniform — Not documented
stats_cdf_weibull — Not documented
stats_covariance — Computes the covariance of two data sets
stats_den_uniform — Not documented
stats_dens_beta — Not documented
stats_dens_cauchy — Not documented
stats_dens_chisquare — Not documented
stats_dens_exponential — Not documented
stats_dens_f
stats_dens_gamma — Not documented
stats_dens_laplace — Not documented
stats_dens_logistic — Not documented
stats_dens_negative_binomial — Not documented
stats_dens_normal — Not documented
stats_dens_pmf_binomial — Not documented
stats_dens_pmf_hypergeometric
stats_dens_pmf_poisson — Not documented
stats_dens_t — Not documented
stats_dens_weibull — Not documented
stats_harmonic_mean — Returns the harmonic mean of an array of values
stats_kurtosis — Computes the kurtosis of the data in the array
stats_rand_gen_beta — Generates beta random deviate
stats_rand_gen_chisquare — Generates random deviate from the distribution of a chisquare with "df" degrees of freedom random variable.
stats_rand_gen_exponential — Generates a single random deviate from an exponential distribution with mean "av"
stats_rand_gen_f — Generates a random deviate
stats_rand_gen_funiform — Generates uniform float between low (exclusive) and high (exclusive)
stats_rand_gen_gamma — Generates random deviates from a gamma distribution
stats_rand_gen_ibinomial_negative — Generates a single random deviate from a negative binomial distribution. Arguments : n - the number of trials in the negative binomial distribution from which a random deviate is to be generated (n > 0), p - the probability of an event (0 < p < 1)).
stats_rand_gen_ibinomial — Generates a single random deviate from a binomial distribution whose number of trials is "n" (n >= 0) and whose probability of an event in each trial is "pp" ([0;1]). Method : algorithm BTPE
stats_rand_gen_int — Generates random integer between 1 and 2147483562
stats_rand_gen_ipoisson — Generates a single random deviate from a Poisson distribution with mean "mu" (mu >= 0.0).
stats_rand_gen_iuniform — Generates integer uniformly distributed between LOW (inclusive) and HIGH (inclusive)
stats_rand_gen_noncenral_chisquare — Generates random deviate from the distribution of a noncentral chisquare with "df" degrees of freedom and noncentrality parameter "xnonc". d must be >= 1.0, xnonc must >= 0.0
stats_rand_gen_noncentral_f — Generates a random deviate from the noncentral F (variance ratio) distribution with "dfn" degrees of freedom in the numerator, and "dfd" degrees of freedom in the denominator, and noncentrality parameter "xnonc". Method : directly generates ratio of noncentral numerator chisquare variate to central denominator chisquare variate.
stats_rand_gen_noncentral_t — Generates a single random deviate from a noncentral T distribution
stats_rand_gen_normal — Generates a single random deviate from a normal distribution with mean, av, and standard deviation, sd (sd >= 0). Method : Renames SNORM from TOMS as slightly modified by BWB to use RANF instead of SUNIF.
stats_rand_gen_t — Generates a single random deviate from a T distribution
stats_rand_get_seeds — Not documented
stats_rand_phrase_to_seeds — generate two seeds for the RGN random number generator
stats_rand_ranf — Returns a random floating point number from a uniform distribution over 0 - 1 (endpoints of this interval are not returned) using the current generator
stats_rand_setall — Not documented
stats_skew — Computes the skewness of the data in the array
stats_standard_deviation — Returns the standard deviation
stats_stat_binomial_coef — Not documented
stats_stat_correlation — Not documented
stats_stat_gennch — Not documented
stats_stat_independent_t — Not documented
stats_stat_innerproduct
stats_stat_noncentral_t — Calculates any one parameter of the noncentral t distribution give values for the others.
stats_stat_paired_t — Not documented
stats_stat_percentile — Not documented
stats_stat_powersum — Not documented
stats_variance — Returns the population variance
Předcházející | Nahoru | Další
ssh2_tunnel | Domů | stats_absolute_deviation


Subversion Funkce

Předcházející VI. Reference funkcí Další

CLXII. Subversion Funkce

Úvod

Varování

Toto rozšíření je EXPERIMENTÁLNÍ. Chování tohoto rozšíření, názvy funkcí a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může bez ohlášení změnit. Berte to v úvahu a používejte tento modul na vlastní nebezpečí.

This extension implements PHP bindings for » Subversion (SVN), a version control system, allowing PHP scripts to communicate with SVN repositories and working copies without direct command line calls to the svn executable.

Požadavky

The Subversion binaries are not necessary to use this extension. However, when compiling the extension, libsvn (the Subversion headers) must be available.

Instalace

Informace o instalaci tohoto PECL rozšíření lze najít v kapitole manuálu nazvané Instalace rozšíření PECL. Další informace, jako nové verze, soubory ke stažení, zdrojové soubory, správcovské informace a CHANGELOG, lze najít zde: » http://pecl.php.net/package/svn

If ./configure is having trouble finding the SVN files (for example, Subversion was installed with a different prefix directory), use ./configure --with-svn=$USR_PATH to specify the directory where the include/subversion-1/ folder is located.

Tuto DLL knihovnu pro rozšíření PECL můžete stahovat ze stránky » PHP Downloads nebo z » http://snaps.php.net/.

Varování

If the extension is compiled against libsvn 1.3, functions that work with working copies will fail when used on working copies created by Subversion 1.4.

Typy prostředků

Subversion's lower-level svn_fs_* functions make use of resources that reference local file-system repositories. They can probably be created using svn_repos_fs() and svn_fs_revision_root(). (verify?)

Toto rozšíření nemá definován žádný typ prostředku (resource).

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

SVN_REVISON_HEAD (integer)
Magic number (-1) specifying the HEAD revision

Constants usable with svn_auth_set_parameter()

SVN_AUTH_PARAM_DEFAULT_USERNAME (string)
Property for default username to use when performing basic authentication
SVN_AUTH_PARAM_DEFAULT_PASSWORD (string)
Property for default password to use when performing basic authentication
SVN_AUTH_PARAM_NON_INTERACTIVE (string)
SVN_AUTH_PARAM_DONT_STORE_PASSWORDS (string)
SVN_AUTH_PARAM_NO_AUTH_CACHE (string)
SVN_AUTH_PARAM_SSL_SERVER_FAILURES (string)
SVN_AUTH_PARAM_SSL_SERVER_CERT_INFO (string)
SVN_AUTH_PARAM_CONFIG (string)
SVN_AUTH_PARAM_SERVER_GROUP (string)
SVN_AUTH_PARAM_CONFIG_DIR (string)
PHP_SVN_AUTH_PARAM_IGNORE_SSL_VERIFY_ERRORS (string)
Custom property for ignoring SSL cert verification errors

Filesystem constants

SVN_FS_CONFIG_FS_TYPE (string)
Configuration key that determines filesystem type
SVN_FS_TYPE_BDB (string)
Filesystem is Berkeley-DB implementation
SVN_FS_TYPE_FSFS (string)
Filesystem is native-filesystem implementation

Reserved property constants

SVN_PROP_REVISION_DATE (string)
svn:date
SVN_PROP_REVISION_ORIG_DATE (string)
svn:original-date
SVN_PROP_REVISION_AUTHOR (string)
svn:author
SVN_PROP_REVISION_LOG (string)
svn:log

Working copy status constants

svn_wc_status_none (int)
Status does not exist
svn_wc_status_unversioned (int)
Item is not versioned in working copy
svn_wc_status_normal (int)
Item exists, nothing else is happening
svn_wc_status_added (int)
Item is scheduled for addition
svn_wc_status_missing (int)
Item is versioned but missing from the working copy
svn_wc_status_deleted (int)
Item is scheduled for deletion
svn_wc_status_replaced (int)
Item was deleted and then re-added
svn_wc_status_modified (int)
Item (text or properties) was modified
svn_wc_status_merged (int)
Item's local modifications were merged with repository modifications
svn_wc_status_conflicted (int)
Item's local modifications conflicted with repository modifications
svn_wc_status_ignored (int)
Item is unversioned but configured to be ignored
svn_wc_status_obstructed (int)
Unversioned item is in the way of a versioned resource
svn_wc_status_external (int)
Unversioned path that is populated using svn:externals
svn_wc_status_incomplete (int)
Directory does not contain complete entries list

Node type constants

svn_node_none (int)
Absent
svn_node_file (int)
File
svn_node_dir (int)
Directory
svn_node_unknown (int)
Something Subversion cannot identify

Obsah

svn_add — Schedules the addition of an item in a working directory
svn_auth_get_parameter — Retrieves authentication parameter
svn_auth_set_parameter — Sets an authentication parameter
svn_cat — Returns the contents of a file in a repository
svn_checkout — Checks out a working copy from the repository
svn_cleanup — Recursively cleanup a working copy directory, finishing incomplete operations and removing locks
svn_client_version — Returns the version of the SVN client libraries
svn_commit — Sends changes from the local working copy to the repository
svn_diff — Recursively diffs two paths
svn_fs_abort_txn — Abort a transaction, returns true if everything is ok, false othewise
svn_fs_apply_text — Creates and returns a stream that will be used to replace
svn_fs_begin_txn2 — Create a new transaction
svn_fs_change_node_prop — Return true if everything is ok, false otherwise
svn_fs_check_path — Determines what kind of item lives at path in a given repository fsroot
svn_fs_contents_changed — Return true if content is different, false otherwise
svn_fs_copy — Copies a file or a directory, returns true if all is ok, false otherwise
svn_fs_delete — Deletes a file or a directory, return true if all is ok, false otherwise
svn_fs_dir_entries — Enumerates the directory entries under path; returns a hash of dir names to file type
svn_fs_file_contents — Returns a stream to access the contents of a file from a given version of the fs
svn_fs_file_length — Returns the length of a file from a given version of the fs
svn_fs_is_dir — Return true if the path points to a directory, false otherwise
svn_fs_is_file — Return true if the path points to a file, false otherwise
svn_fs_make_dir — Creates a new empty directory, returns true if all is ok, false otherwise
svn_fs_make_file — Creates a new empty file, returns true if all is ok, false otherwise
svn_fs_node_created_rev — Returns the revision in which path under fsroot was created
svn_fs_node_prop — Returns the value of a property for a node
svn_fs_props_changed — Return true if props are different, false otherwise
svn_fs_revision_prop — Fetches the value of a named property
svn_fs_revision_root — Get a handle on a specific version of the repository root
svn_fs_txn_root — Creates and returns a transaction root
svn_fs_youngest_rev — Returns the number of the youngest revision in the filesystem
svn_import — Imports an unversioned path into a repository
svn_log — Returns the commit log messages of a repository URL
svn_ls — Returns list of directory contents in repository URL, optionally at revision number
svn_repos_create — Create a new subversion repository at path
svn_repos_fs_begin_txn_for_commit — Create a new transaction
svn_repos_fs_commit_txn — Commits a transaction and returns the new revision
svn_repos_fs — Gets a handle on the filesystem for a repository
svn_repos_hotcopy — Make a hot-copy of the repos at repospath; copy it to destpath
svn_repos_open — Open a shared lock on a repository.
svn_repos_recover — Run recovery procedures on the repository located at path.
svn_status — Returns the status of working copy files and directories
svn_update — Update working copy
Předcházející | Nahoru | Další
wordwrap | Domů | svn_add


Swish Functions

Předcházející VI. Reference funkcí Další

CLXIV. Swish Functions

Úvod

The swish extension provides the bindings for Swish-e API. Swish-e stands for "Simple Web Indexing System for Humans - Enhanced" and is an open source system for indexing and search. Swish-e itself is licensed under GPL license, but uses a clause that allows applications to link against the library if every copy of the combined work is accompanied by the URL to Swish-e source code. Here it is: » http://swish-e.org.

Varování

Toto rozšíření je EXPERIMENTÁLNÍ. Chování tohoto rozšíření, názvy funkcí a všechno ostatní, co je zde zdokumentováno, se v budoucích verzích PHP může bez ohlášení změnit. Berte to v úvahu a používejte tento modul na vlastní nebezpečí.

Požadavky

PECL/swish requires PHP 5.1.3 or newer.

Instalace

Informace o instalaci tohoto PECL rozšíření lze najít v kapitole manuálu nazvané Instalace rozšíření PECL. Další informace, jako nové verze, soubory ke stažení, zdrojové soubory, správcovské informace a CHANGELOG, lze najít zde: » http://pecl.php.net/package/swish.

The latest PECL/swish Win32 DLL can be downloaded here: » php_swish.dll.

Konfigurace běhu

Toto rozšíření nemá definováno žádné konfigurační direktivy.

Příklady

Příklad 2268. Basic search query

<?php

try {

    $swish = new Swish("index.swish-e");
    $results = $swish->query("test OR text");

    echo "Found ", $results->hits, " results\n";
    while ($result = $results->nextResult()) {
        var_dump($result);
        break; //break after the first result
    }

} catch (SwishException $e) {
    echo "Error: ", $e->getMessage(), "\n";
}

?>

Výše uvedený příklad vypíše něco jako:

Found 9 results
object(SwishResult)#3 (8) {
  ["swishreccount"]=>
  int(1)
  ["swishrank"]=>
  int(1000)
  ["swishfilenum"]=>
  int(10)
  ["swishdbfile"]=>
  string(13) "index.swish-e"
  ["swishdocpath"]=>
  string(23) "README.SUBMITTING_PATCH"
  ["swishtitle"]=>
  NULL
  ["swishdocsize"]=>
  int(4557)
  ["swishlastmodified"]=>
  int(1072136752)
}

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

Swish::META_TYPE_UNDEF (integer)
Swish::META_TYPE_STRING (integer)
Swish::META_TYPE_ULONG (integer)
Swish::META_TYPE_DATE (integer)
Swish::IN_FILE_BIT (integer)
Swish::IN_TITLE_BIT (integer)
Swish::IN_HEAD_BIT (integer)
Swish::IN_BODY_BIT (integer)
Swish::IN_COMMENTS_BIT (integer)
Swish::IN_HEADER_BIT (integer)
Swish::IN_EMPHASIZED_BIT (integer)
Swish::IN_META_BIT (integer)
Swish::IN_FILE (integer)
Swish::IN_TITLE (integer)
Swish::IN_HEAD (integer)
Swish::IN_BODY (integer)
Swish::IN_COMMENTS (integer)
Swish::IN_HEADER (integer)
Swish::IN_EMPHASIZED (integer)
Swish::IN_META (integer)
Swish::IN_ALL (integer)

Předdefinované třídy

Předdefinované třídy

Swish

Vlastnosti

  • indexes - the array of indexes used and their properties. Certain list of properties depends on Swish-e version.

Metody

  • Swish::__construct - constructs new Swish object. Throws SwishException on error.

  • Swish->prepare - prepares and returns SwishSearch object. Throws SwishException on error.

  • Swish->query - executes the query and returns SwishResults object. Throws SwishException on error.

  • Swish->getMetaList - returns an array of meta entries for the given index file.

  • Swish->getPropertyList - returns an array of properties for the given index file.

SwishSearch

Metody

  • SwishSearch->setStructure - sets the structure flag in the search object. This flag is used to limit search to certain parts of HTML documents.

  • SwishSearch->setPhraseDelimiter - sets the phrase delimiter character. The default delimiter is double-quotes.

  • SwishSearch->setSort - sets the sort order of the results.

  • SwishSearch->setLimit - sets the limits for the search. Throws SwishException on error.

  • SwishSearch->resetLimit - resets the limits.

  • SwishSearch->execute - executes the query and returns SwishResults object. Throws SwishException on error.

SwishResults

Vlastnosti

  • hits - the number of results in this SwishResults object.

  • indexes - the array of indexes used in the search.

Metody

  • SwishResults->nextResult - returns next SwishResult object or FALSE if no more results are available.

  • SwishResults->seekResult - sets the current seek position in the SwishResults object. Throws SwishException on error.

  • SwishResults->getParsedWords - returns an array of words in the query with stopwords removed.

  • SwishResults->getRemovedStopwords - returns an array of removed stopwords.

SwishResult

Vlastnosti

  • Properties list depends on Swish-e version, see examples.

Metody

  • SwishResult->getMetaList - returns an array of meta entries for the index used in this result.

  • SwishResult->stem - stems the word and returns result as an array of strings. Throws SwishException on error.

SwishException

SwishException extends the built in Exception class and possesses the same set of properties and methods. See „Extending Exceptions“ for more details.

Obsah

Swish::__construct — Construct a Swish object
Swish->getMetaList — Get the list of meta entries for the index
Swish->getPropertyList — Get the list of properties for the index
Swish->prepare — Prepare a search query
Swish->query — Execute a query and return results object
SwishResult->getMetaList — Get a list of meta entries
SwishResult->stem — Stems the given word
SwishResults->getParsedWords — Get an array of parsed words
SwishResults->getRemovedStopwords — Get an array of stopwords removed from the query
SwishResults->nextResult — Get the next search result
SwishResults->seekResult — Set current seek pointer to the given position
SwishSearch->execute — Execute the search and get the results
SwishSearch->resetLimit — Reset the search limits
SwishSearch->setLimit — Set the search limits
SwishSearch->setPhraseDelimiter — Set the phrase delimiter
SwishSearch->setSort — Set the sort order
SwishSearch->setStructure — Set the structure flag in the search object
Předcházející | Nahoru | Další
swf_viewport | Domů | Swish::__construct


Unicode Functions

Předcházející VI. Reference funkcí Další

CLXIX. Unicode Functions

Úvod

Unicode Support.

Varování

This extension is still in development and it isn't available to public yet.

Požadavky

» ICU 3.4 or later is required.

Instalace

First you should download and install ICU:

Příklad 2323. install ICU on Unix

./configure --disable-threads --enable-extras --enable-icuio --enable-layout
make && make install

Then checkout latest PHP and configure it --with-icu-dir=<dir> option, where <dir> was the dir to where you installed ICU. You don't need to explicitly use this option if you install ICU to a standard location.

Konfigurace běhu

Chování těchto funkcí je ovlivněno nastavením parametrů v php.ini.

Tabulka 311. Unicode Configuration Options

Name | Default | Changeable | Changelog
unicode.fallback_encoding | NULL | PHP_INI_ALL | Available since PHP 6.0.0.
unicode.from_error_mode | "2" | PHP_INI_ALL | Available since PHP 6.0.0.
unicode.from_error_subst_char | "3f" | PHP_INI_ALL | Available since PHP 6.0.0.
unicode.http_input_encoding | NULL | PHP_INI_ALL | Available since PHP 6.0.0.
unicode.output_encoding | NULL | PHP_INI_ALL | Available since PHP 6.0.0.
unicode.runtime_encoding | NULL | PHP_INI_ALL | Available since PHP 6.0.0.
unicode.script_encoding | NULL | PHP_INI_ALL | Available since PHP 6.0.0.
unicode.semantics | "0" | PHP_INI_SYSTEM | Available since PHP 6.0.0.

Pro další detaily a definice konstant PHP_INI_*, viz dokumentace k ini_set().

Zde je stručný popis konfiguračních direktiv.

unicode.output_encoding string

Default encoding for output.

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

Tabulka 312.

constant | value | description
U_INVALID_STOP | 0 | stop at first invalid character
U_INVALID_SKIP | 1 | skip invalid characters
U_INVALID_SUBSTITUTE | 2 | replace invalid characters
U_INVALID_ESCAPE | 3 | escape invalid characters

Obsah

unicode_decode — Convert a binary string into a Unicode string
unicode_encode — Convert a unicode string in any encoding
unicode_get_error_mode — Get the error mode for strings conversions
unicode_get_subst_char — Get the substitution character for string conversion errors
unicode_semantics — Check whether unicode semantics is enabled
unicode_set_error_mode — Set the error mode for strings conversions
unicode_set_subst_char — Set the substitution character for string conversion errors
Předcházející | Nahoru | Další
token_name | Domů | unicode_decode


win32ps Functions

Předcházející VI. Reference funkcí Další

CLXXVI. win32ps Functions

Úvod

The win32ps extension is a Windows specific extension that allows PHP retrieve statistics about process and memory utilization.

Požadavky

Windows NT, Windows 2000, Windows XP or Windows Server 2003. Any version of Windows derived from Windows NT should be compatible.

Instalace

Postup 16. Installing from PECL

  1. You can download php_win32ps.dll from » pecl4win.php.net.

  2. Copy the php_win32ps.dll into your extension_dir.

  3. Load the extension from your php.ini

extension=php_win32ps.dll

Příklady

Příklad 2371. Statistics about the current PHP process

<?php
print_r(win32_ps_stat_proc());
/*
    Array
    (
        [pid] => 936
        [exe] => D:\Daten\Source\php-5.1\Debug_TS\php.exe
        [mem] => Array
            (
                [page_fault_count] => 2062
                [peak_working_set_size] => 8396800
                [working_set_size] => 8396800
                [quota_peak_paged_pool_usage] => 32080
                [quota_paged_pool_usage] => 31876
                [quota_peak_non_paged_pool_usage] => 4240
                [quota_non_paged_pool_usage] => 3888
                [pagefile_usage] => 5865472
                [peak_pagefile_usage] => 5865472
            )

        [tms] => Array
            (
                [created] => 0.093
                [kernel] => 0.015
                [user] => 0.062
            )

    )
*/
?>

Příklad 2372. Statistics about global memory utilization

<?php
print_r(win32_ps_stat_mem());
/*
    Array
    (
        [load] => 37
        [unit] => 1024
        [total_phys] => 1048096
        [avail_phys] => 649960
        [total_pagefile] => 2521368
        [avail_pagefile] => 2237940
        [total_virtual] => 2097024
        [avail_virtual] => 2057848
    )
*/
?>

Obsah

win32_ps_list_procs — List running processes
win32_ps_stat_mem — Stat memory utilization
win32_ps_stat_proc — Stat process
Předcházející | Nahoru | Další
wddx_unserialize | Domů | win32_ps_list_procs


win32service Functions

Předcházející VI. Reference funkcí Další

CLXXVII. win32service Functions

Úvod

The win32service extension is a Windows specific extension that allows PHP to communicate with the Service Control Manager to start, stop, register and unregister services, and even allows your PHP scripts to run as a service.

Požadavky

Windows NT, Windows 2000, Windows XP or Windows Server 2003. Any version of Windows derived from Windows NT should be compatible.

Instalace

Postup 17. Installing from PECL

  1. You can download php_win32service.dll from http://snaps.php.net/win32/. Choose the PECL_X_X folder that matches you PHP version.

  2. Copy the php_win32service.dll into your extension_dir.

  3. Load the extension from your php.ini

extension=php_win32service.dll

Příklady

Příklad 2373. Registering a PHP script to run as a service

<?php
win32_create_service(array(
        'service' => 'dummyphp',                 # the name of your service
        'display' => 'sample dummy PHP service', # description
        'params' => 'c:\path\to\script.php run', # path to the script and parameters
    ));
?>

Příklad 2374. Unregistering a service

<?php
win32_delete_service('dummyphp');
?>

Příklad 2375. Running as a service

<?php
if ($argv[1] == 'run') {
  win32_start_service_ctrl_dispatcher('dummyphp');

  while (WIN32_SERVICE_CONTROL_STOP != win32_get_last_control_message()) {
    # do your work here.
    # try not to take up more than 30 seconds before going around the loop
    # again
  }
}
?>

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

WIN32_SERVICE_CONTROL_CONTINUE (integer)
WIN32_SERVICE_CONTROL_INTERROGATE (integer)
WIN32_SERVICE_CONTROL_PAUSE (integer)
WIN32_SERVICE_CONTROL_STOP (integer)
WIN32_SERVICE_CONTROL_HARDWAREPROFILECHANGE (integer)
WIN32_SERVICE_CONTROL_POWEREVENT (integer)
WIN32_SERVICE_CONTROL_SESSIONCHANGE (integer)
WIN32_ERROR_CALL_NOT_IMPLEMENTED (integer)
WIN32_NO_ERROR (integer)
WIN32_SERVICE_RUNNING (integer)
WIN32_SERVICE_STOPPED (integer)
WIN32_SERVICE_STOP_PENDING (integer)
WIN32_SERVICE_WIN32_OWN_PROCESS (integer)
WIN32_SERVICE_INTERACTIVE_PROCESS (integer)
WIN32_SERVICE_STOPPED (integer)
WIN32_SERVICE_START_PENDING (integer)
WIN32_SERVICE_STOP_PENDING (integer)
WIN32_SERVICE_RUNNING (integer)
WIN32_SERVICE_CONTINUE_PENDING (integer)
WIN32_SERVICE_PAUSE_PENDING (integer)
WIN32_SERVICE_PAUSED (integer)
WIN32_SERVICE_ACCEPT_NETBINDCHANGE (integer)
WIN32_SERVICE_ACCEPT_PARAMCHANGE (integer)
WIN32_SERVICE_ACCEPT_PAUSE_CONTINUE (integer)
WIN32_SERVICE_ACCEPT_SHUTDOWN (integer)
WIN32_SERVICE_ACCEPT_STOP (integer)
WIN32_SERVICE_ACCEPT_HARDWAREPROFILECHANGE (integer)
WIN32_SERVICE_ACCEPT_POWEREVENT (integer)
WIN32_SERVICE_ACCEPT_SESSIONCHANGE (integer)
WIN32_SERVICE_FILE_SYSTEM_DRIVER (integer)
WIN32_SERVICE_KERNEL_DRIVER (integer)
WIN32_SERVICE_WIN32_SHARE_PROCESS (integer)
WIN32_SERVICE_RUNS_IN_SYSTEM_PROCESS (integer)

Obsah

win32_create_service — Creates a new service entry in the SCM database
win32_delete_service — Deletes a service entry from the SCM database
win32_get_last_control_message — Returns the last control message that was sent to this service
win32_query_service_status — Queries the status of a service
win32_set_service_status — Update the service status
win32_start_service_ctrl_dispatcher — Registers the script with the SCM, so that it can act as the service with the given name
win32_start_service — Starts a service
win32_stop_service — Stops a service
Předcházející | Nahoru | Další
win32_ps_stat_proc | Domů | win32_create_service


XMLReader functions

Předcházející VI. Reference funkcí Další

CLXXXII. XMLReader functions

Úvod

The XMLReader extension is an XML Pull parser. The reader acts as a cursor going forward on the document stream and stopping at each node on the way.

Encoding

It is important to note that internally, libxml uses the UTF-8 encoding and as such, the encoding of the retrieved contents will always be in UTF-8 encoding.

Instalace

The XMLReader extension is available in PECL as of PHP 5.0.0 and is included and enabled as of PHP 5.1.0 by default. It can be enabled by adding the argument --enable-xmlreader (or --with-xmlreader before 5.1.0) to your configure line. The libxml extension is required.

Předdefinované třídy

XMLReader

Metody

  • XMLReader::close - Close the XMLReader input

  • XMLReader::expand - Export current node to a DOM node

  • XMLReader::getAttribute - Get value of attribute by name

  • XMLReader::getAttributeNo - Get value of attribute by position

  • XMLReader::getAttributeNs - Get value of attribute by name and URI

  • XMLReader::getParserProperty - Indicates if parser property is set or not

  • XMLReader::isValid - Indicates if document is valid

  • XMLReader::lookupNamespace - Get URI for prefix in scope of node

  • XMLReader::moveToAttribute - Positions reader on named attribute

  • XMLReader::moveToAttributeNo - Positions reader on attribute by index

  • XMLReader::moveToAttributeNs - Position reader on attribute by name and URI

  • XMLReader::moveToElement - Move to parent element of current attribute node

  • XMLReader::moveToFirstAttribute - Move to first attribute of node

  • XMLReader::moveToNextAttribute - Move to next attribute of node

  • XMLReader::next - Move to next element skipping children

  • XMLReader::open - Set URI to be parsed

  • XMLReader::read - Move to next node in stream

  • XMLReader::setParserProperty - Set parser property

  • XMLReader::setRelaxNGSchema - Set URI of RelaxNG schema to validate against

  • XMLReader::setRelaxNGSchemaSource - Set string containing RelaxNG schema to validate against

  • XMLReader::XML - Set string of data to be parsed

Vlastnosti

Tabulka 325.

Name | Type | Read-only | Description
attributeCount | int | yes | The number of attributes on the node
baseURI | string | yes | The base URI of the node
depth | int | yes | Depth of the node in the tree starting at 0
hasAttributes | bool | yes | Indicates if node has attributes
hasValue | bool | yes | Indicates if node has a text value
isDefault | bool | yes | Indicates if attribute is defaulted from DTD
isEmptyElement | bool | yes | Indicates if node is an empty element tag
localName | string | yes | The local name of the node
name | string | yes | The qualified name of the node
namespaceURI | string | yes | The URI of the namespace associated with the node
nodeType | int | yes | The node type for the node
prefix | string | yes | The prefix of the namespace associated with the node
value | string | yes | The text value of the node
xmlLang | string | yes | The xml:lang scope which the node resides

Předdefinované konstanty

Tyto konstanty jsou definovány tímto rozšířením a budou k dispozici pouze tehdy, bylo-li rozšíření zkompilováno společně s PHP nebo dynamicky zavedeno za běhu.

Varování

XMLReader uses class constants since PHP 5.1. Prior releases use global constants in the form XMLREADER_ELEMENT.

Tabulka 326. XMLReader Node Types

Constant | Value | Description
XMLReader::NONE (integer) | 0 | No node type
XMLReader::ELEMENT (integer) | 1 | Start element
XMLReader::ATTRIBUTE (integer) | 2 | Attribute node
XMLReader::TEXT (integer) | 3 | Text node
XMLReader::CDATA (integer) | 4 | CDATA node
XMLReader::ENTITY_REF (integer) | 5 | Entity Reference node
XMLReader::ENTITY (integer) | 6 | Entity Declaration node
XMLReader::PI (integer) | 7 | Processing Instruction node
XMLReader::COMMENT (integer) | 8 | Comment node
XMLReader::DOC (integer) | 9 | Document node
XMLReader::DOC_TYPE (integer) | 10 | Document Type node
XMLReader::DOC_FRAGMENT (integer) | 11 | Document Fragment node
XMLReader::NOTATION (integer) | 12 | Notation node
XMLReader::WHITESPACE (integer) | 13 | Whitespace node
XMLReader::SIGNIFICANT_WHITESPACE (integer) | 14 | Significant Whitespace node
XMLReader::END_ELEMENT (integer) | 15 | End Element
XMLReader::END_ENTITY (integer) | 16 | End Entity
XMLReader::XML_DECLARATION (integer) | 17 | XML Declaration node

Tabulka 327. XMLReader Parser Options

Constant | Value | Description
XMLReader::LOADDTD (integer) | 1 | Load DTD but do not validate
XMLReader::DEFAULTATTRS (integer) | 2 | Load DTD and default attributes but do not validate
XMLReader::VALIDATE (integer) | 3 | Load DTD and validate while parsing
XMLReader::SUBST_ENTITIES (integer) | 4 | Substitute entities and expand references

Obsah

XMLReader::close — Close the XMLReader input
XMLReader::expand — Returns a copy of the current node as a DOM object
XMLReader::getAttribute — Get the value of a named attribute
XMLReader::getAttributeNo — Get the value of an attribute by index
XMLReader::getAttributeNs — Get the value of an attribute by localname and URI
XMLReader::getParserProperty — Indicates if specified property has been set
XMLReader::isValid — Indicates if the parsed document is valid
XMLReader::lookupNamespace — Lookup namespace for a prefix
XMLReader::moveToAttribute — Move cursor to a named attribute
XMLReader::moveToAttributeNo — Move cursor to an attribute by index
XMLReader::moveToAttributeNs — Move cursor to a named attribute
XMLReader::moveToElement — Position cursor on the parent Element of current Attribute
XMLReader::moveToFirstAttribute — Position cursor on the first Attribute
XMLReader::moveToNextAttribute — Position cursor on the next Attribute
XMLReader::next — Move cursor to next node skipping all subtrees
XMLReader::open — Set the URI containing the XML to parse
XMLReader::read — Move to next node in document
XMLReader::setParserProperty — Set or Unset parser options
XMLReader::setRelaxNGSchema — Set the filename or URI for a RelaxNG Schema
XMLReader::setRelaxNGSchemaSource — Set the data containing a RelaxNG Schema
XMLReader::XML — Set the data containing the XML to parse
Předcházející | Nahoru | Další
xmlrpc_set_type | Domů | XMLReader::close


XMLWriter Functions

Předcházející VI. Reference funkcí Další

CLXXXIII. XMLWriter Functions

Úvod

This is the XMLWriter extension. It wraps the libxml xmlWriter API.

This extension represents a writer that provides a non-cached, forward-only means of generating streams or files containing XML data.

This extension can be used in an object oriented style or a procedural one. Every method documented describes the alternative procedural call.

Předdefinované třídy

XMLWriter

Metody

  • XMLWriter::endAttribute - End attribute

  • XMLWriter::endCData - End current CDATA

  • XMLWriter::endComment - Create end comment

  • XMLWriter::endDocument - End current document

  • XMLWriter::endDTDAttlist - End current DTD AttList

  • XMLWriter::endDTDElement - End current DTD element

  • XMLWriter::endDTDEntity - End current DTD Entity

  • XMLWriter::endDTD - End current DTD

  • XMLWriter::endElement - End current element

  • XMLWriter::endPI - End current PI

  • XMLWriter::flush - Flush current buffer

  • XMLWriter::fullEndElement - End current element

  • XMLWriter::openMemory - Create new xmlwriter using memory for string output

  • XMLWriter::openURI - Create new xmlwriter using source uri for output

  • XMLWriter::outputMemory - Returns current buffer

  • XMLWriter::setIndentString - Set string used for indenting

  • XMLWriter::setIndent - Toggle indentation on/off

  • XMLWriter::startAttributeNS - Create start namespaced attribute

  • XMLWriter::startAttribute - Create start attribute

  • XMLWriter::startCData - Create start CDATA tag

  • XMLWriter::startComment - Create start comment

  • XMLWriter::startDocument - Create document tag

  • XMLWriter::startDTDAttlist - Create start DTD AttList

  • XMLWriter::startDTDElement - Create start DTD element

  • XMLWriter::startDTDEntity - Create start DTD Entity

  • XMLWriter::startDTD - Create start DTD tag

  • XMLWriter::startElementNS - Create start namespaced element tag

  • XMLWriter::startElement - Create start element tag

  • XMLWriter::startPI - Create start PI tag

  • XMLWriter::text - Write text

  • XMLWriter::writeAttributeNS - Write full namespaced attribute

  • XMLWriter::writeAttribute - Write full attribute

  • XMLWriter::writeCData - Write full CDATA tag

  • XMLWriter::writeComment - Write full comment tag

  • XMLWriter::writeDTDAttlist - Write full DTD AttList tag

  • XMLWriter::writeDTDElement - Write full DTD element tag

  • XMLWriter::writeDTDEntity - Write full DTD Entity tag

  • XMLWriter::writeDTD - Write full DTD tag

  • XMLWriter::writeElementNS - Write full namesapced element tag

  • XMLWriter::writeElement - Write full element tag

  • XMLWriter::writePI - Writes a PI

  • XMLWriter::writeRaw - Write a raw XML text

Typy prostředků

There is one resource used by the procedural version of the XMLWriter extension: returned by xmlwriter_open_memory() or xmlwriter_open_uri().

Předdefinované konstanty

Toto rozšíření nemá definovány žádné konstanty.

Obsah

XMLWriter::endAttribute — End attribute
XMLWriter::endCData — End current CDATA
XMLWriter::endComment — Create end comment
XMLWriter::endDocument — End current document
XMLWriter::endDTDAttlist — End current DTD AttList
XMLWriter::endDTDElement — End current DTD element
XMLWriter::endDTDEntity — End current DTD Entity
XMLWriter::endDTD — End current DTD
XMLWriter::endElement — End current element
XMLWriter::endPI — End current PI
XMLWriter::flush — Flush current buffer
XMLWriter::fullEndElement — End current element
XMLWriter::openMemory — Create new xmlwriter using memory for string output
XMLWriter::openURI — Create new xmlwriter using source uri for output
XMLWriter::outputMemory — Returns current buffer
XMLWriter::setIndentString — Set string used for indenting
XMLWriter::setIndent — Toggle indentation on/off
XMLWriter::startAttributeNS — Create start namespaced attribute
XMLWriter::startAttribute — Create start attribute
XMLWriter::startCData — Create start CDATA tag
XMLWriter::startComment — Create start comment
XMLWriter::startDocument — Create document tag
XMLWriter::startDTDAttlist — Create start DTD AttList
XMLWriter::startDTDElement — Create start DTD element
XMLWriter::startDTDEntity — Create start DTD Entity
XMLWriter::startDTD — Create start DTD tag
XMLWriter::startElementNS — Create start namespaced element tag
XMLWriter::startElement — Create start element tag
XMLWriter::startPI — Create start PI tag
XMLWriter::text — Write text
XMLWriter::writeAttributeNS — Write full namespaced attribute
XMLWriter::writeAttribute — Write full attribute
XMLWriter::writeCData — Write full CDATA tag
XMLWriter::writeComment — Write full comment tag
XMLWriter::writeDTDAttlist — Write full DTD AttList tag
XMLWriter::writeDTDElement — Write full DTD element tag
XMLWriter::writeDTDEntity — Write full DTD Entity tag
XMLWriter::writeDTD — Write full DTD tag
XMLWriter::writeElementNS — Write full namesapced element tag
XMLWriter::writeElement — Write full element tag
XMLWriter::writePI — Writes a PI
XMLWriter::writeRaw — Write a raw XML text
Předcházející | Nahoru | Další
XMLReader::XML | Domů | XMLWriter::endAttribute


Predefined Classes

This section lists standard predefined classes. Miscellaneous extensions define other classes which are described in their reference.

Standard Defined Classes

These classes are defined in the standard set of functions included in the PHP build.

Directory
The class from which dir is instantiated.
stdClass
__PHP_Incomplete_Class

Predefined classes as of PHP 5

These additional predefined classes were introduced in PHP 5.0.0

exception
php_user_filter
Předcházející | Nahoru | Další
Predefined Variables | Domů | Předdefinované konstanty


Předdefinované konstanty

Core Predefined Constants

These constants are defined by the PHP core. This includes PHP, the Zend engine, and SAPI modules.

PHP_VERSION (string)
PHP_OS (string)
PHP_SAPI (string)
Available since PHP 4.2.0. See also php_sapi_name().
PHP_EOL (string)
Available since PHP 4.3.10 and PHP 5.0.2
PHP_INT_MAX (integer)
Available since PHP 4.4.0 and PHP 5.0.5
PHP_INT_SIZE (integer)
Available since PHP 4.4.0 and PHP 5.0.5
DEFAULT_INCLUDE_PATH (string)
PEAR_INSTALL_DIR (string)
PEAR_EXTENSION_DIR (string)
PHP_EXTENSION_DIR (string)
PHP_PREFIX (string)
Available since PHP 4.3.0
PHP_BINDIR (string)
PHP_LIBDIR (string)
PHP_DATADIR (string)
PHP_SYSCONFDIR (string)
PHP_LOCALSTATEDIR (string)
PHP_CONFIG_FILE_PATH (string)
PHP_CONFIG_FILE_SCAN_DIR (string)
PHP_SHLIB_SUFFIX (string)
Available since PHP 4.3.0
PHP_OUTPUT_HANDLER_START (integer)
PHP_OUTPUT_HANDLER_CONT (integer)
PHP_OUTPUT_HANDLER_END (integer)
E_ERROR (integer)
E_WARNING (integer)
E_PARSE (integer)
E_NOTICE (integer)
E_CORE_ERROR (integer)
E_CORE_WARNING (integer)
E_COMPILE_ERROR (integer)
E_COMPILE_WARNING (integer)
E_USER_ERROR (integer)
E_USER_WARNING (integer)
E_USER_NOTICE (integer)
E_ALL (integer)
E_STRICT (integer)
Available since PHP 5.0.0
__COMPILER_HALT_OFFSET__ (integer)
Available since PHP 5.1.0

See also: Magic constants.

Standard Predefined Constants

These constants are defined in PHP by default.

EXTR_OVERWRITE (integer)
EXTR_SKIP (integer)
EXTR_PREFIX_SAME (integer)
EXTR_PREFIX_ALL (integer)
EXTR_PREFIX_INVALID (integer)
EXTR_PREFIX_IF_EXISTS (integer)
EXTR_IF_EXISTS (integer)
SORT_ASC (integer)
SORT_DESC (integer)
SORT_REGULAR (integer)
SORT_NUMERIC (integer)
SORT_STRING (integer)
CASE_LOWER (integer)
CASE_UPPER (integer)
COUNT_NORMAL (integer)
COUNT_RECURSIVE (integer)
ASSERT_ACTIVE (integer)
ASSERT_CALLBACK (integer)
ASSERT_BAIL (integer)
ASSERT_WARNING (integer)
ASSERT_QUIET_EVAL (integer)
CONNECTION_ABORTED (integer)
CONNECTION_NORMAL (integer)
CONNECTION_TIMEOUT (integer)
INI_USER (integer)
INI_PERDIR (integer)
INI_SYSTEM (integer)
INI_ALL (integer)
M_E (float)
M_LOG2E (float)
M_LOG10E (float)
M_LN2 (float)
M_LN10 (float)
M_PI (float)
M_PI_2 (float)
M_PI_4 (float)
M_1_PI (float)
M_2_PI (float)
M_2_SQRTPI (float)
M_SQRT2 (float)
M_SQRT1_2 (float)
CRYPT_SALT_LENGTH (integer)
CRYPT_STD_DES (integer)
CRYPT_EXT_DES (integer)
CRYPT_MD5 (integer)
CRYPT_BLOWFISH (integer)
DIRECTORY_SEPARATOR (string)
SEEK_SET (integer)
SEEK_CUR (integer)
SEEK_END (integer)
LOCK_SH (integer)
LOCK_EX (integer)
LOCK_UN (integer)
LOCK_NB (integer)
HTML_SPECIALCHARS (integer)
HTML_ENTITIES (integer)
ENT_COMPAT (integer)
ENT_QUOTES (integer)
ENT_NOQUOTES (integer)
INFO_GENERAL (integer)
INFO_CREDITS (integer)
INFO_CONFIGURATION (integer)
INFO_MODULES (integer)
INFO_ENVIRONMENT (integer)
INFO_VARIABLES (integer)
INFO_LICENSE (integer)
INFO_ALL (integer)
CREDITS_GROUP (integer)
CREDITS_GENERAL (integer)
CREDITS_SAPI (integer)
CREDITS_MODULES (integer)
CREDITS_DOCS (integer)
CREDITS_FULLPAGE (integer)
CREDITS_QA (integer)
CREDITS_ALL (integer)
STR_PAD_LEFT (integer)
STR_PAD_RIGHT (integer)
STR_PAD_BOTH (integer)
PATHINFO_DIRNAME (integer)
PATHINFO_BASENAME (integer)
PATHINFO_EXTENSION (integer)
PATH_SEPARATOR (string)
CHAR_MAX (integer)
LC_CTYPE (integer)
LC_NUMERIC (integer)
LC_TIME (integer)
LC_COLLATE (integer)
LC_MONETARY (integer)
LC_ALL (integer)
LC_MESSAGES (integer)
ABDAY_1 (integer)
ABDAY_2 (integer)
ABDAY_3 (integer)
ABDAY_4 (integer)
ABDAY_5 (integer)
ABDAY_6 (integer)
ABDAY_7 (integer)
DAY_1 (integer)
DAY_2 (integer)
DAY_3 (integer)
DAY_4 (integer)
DAY_5 (integer)
DAY_6 (integer)
DAY_7 (integer)
ABMON_1 (integer)
ABMON_2 (integer)
ABMON_3 (integer)
ABMON_4 (integer)
ABMON_5 (integer)
ABMON_6 (integer)
ABMON_7 (integer)
ABMON_8 (integer)
ABMON_9 (integer)
ABMON_10 (integer)
ABMON_11 (integer)
ABMON_12 (integer)
MON_1 (integer)
MON_2 (integer)
MON_3 (integer)
MON_4 (integer)
MON_5 (integer)
MON_6 (integer)
MON_7 (integer)
MON_8 (integer)
MON_9 (integer)
MON_10 (integer)
MON_11 (integer)
MON_12 (integer)
AM_STR (integer)
PM_STR (integer)
D_T_FMT (integer)
D_FMT (integer)
T_FMT (integer)
T_FMT_AMPM (integer)
ERA (integer)
ERA_YEAR (integer)
ERA_D_T_FMT (integer)
ERA_D_FMT (integer)
ERA_T_FMT (integer)
ALT_DIGITS (integer)
INT_CURR_SYMBOL (integer)
CURRENCY_SYMBOL (integer)
CRNCYSTR (integer)
MON_DECIMAL_POINT (integer)
MON_THOUSANDS_SEP (integer)
MON_GROUPING (integer)
POSITIVE_SIGN (integer)
NEGATIVE_SIGN (integer)
INT_FRAC_DIGITS (integer)
FRAC_DIGITS (integer)
P_CS_PRECEDES (integer)
P_SEP_BY_SPACE (integer)
N_CS_PRECEDES (integer)
N_SEP_BY_SPACE (integer)
P_SIGN_POSN (integer)
N_SIGN_POSN (integer)
DECIMAL_POINT (integer)
RADIXCHAR (integer)
THOUSANDS_SEP (integer)
THOUSEP (integer)
GROUPING (integer)
YESEXPR (integer)
NOEXPR (integer)
YESSTR (integer)
NOSTR (integer)
CODESET (integer)
LOG_EMERG (integer)
LOG_ALERT (integer)
LOG_CRIT (integer)
LOG_ERR (integer)
LOG_WARNING (integer)
LOG_NOTICE (integer)
LOG_INFO (integer)
LOG_DEBUG (integer)
LOG_KERN (integer)
LOG_USER (integer)
LOG_MAIL (integer)
LOG_DAEMON (integer)
LOG_AUTH (integer)
LOG_SYSLOG (integer)
LOG_LPR (integer)
LOG_NEWS (integer)
LOG_UUCP (integer)
LOG_CRON (integer)
LOG_AUTHPRIV (integer)
LOG_LOCAL0 (integer)
LOG_LOCAL1 (integer)
LOG_LOCAL2 (integer)
LOG_LOCAL3 (integer)
LOG_LOCAL4 (integer)
LOG_LOCAL5 (integer)
LOG_LOCAL6 (integer)
LOG_LOCAL7 (integer)
LOG_PID (integer)
LOG_CONS (integer)
LOG_ODELAY (integer)
LOG_NDELAY (integer)
LOG_NOWAIT (integer)
LOG_PERROR (integer)
Předcházející | Nahoru | Další
Predefined Classes | Domů | N. Seznam typů prostředků


Predefined Variables

Since PHP 4.1.0, the preferred method for retrieving external variables is with the superglobals mentioned below. Before this time, people relied on either register_globals or the long predefined PHP arrays ($HTTP_*_VARS). Od PHP 5.0.0 mohou být dlouhá pole předdefinovaných proměnných deaktivována direktivou register_long_arrays.

Server variables: $_SERVER

Poznámka: Introduced in 4.1.0. In earlier versions, use $HTTP_SERVER_VARS.

$_SERVER is an array containing information such as headers, paths, and script locations. The entries in this array are created by the web server. There is no guarantee that every web server will provide any of these; servers may omit some, or provide others not listed here. That said, a large number of these variables are accounted for in the » CGI 1.1 specification, so you should be able to expect those.

This is a 'superglobal', or automatic global, variable. This simply means that it is available in all scopes throughout a script. You don't need to do a global $_SERVER; to access it within functions or methods, as you do with $HTTP_SERVER_VARS.

$HTTP_SERVER_VARS contains the same initial information, but is not a superglobal. (Note that $HTTP_SERVER_VARS and $_SERVER are different variables and that PHP handles them as such)

If the register_globals directive is set, then these variables will also be made available in the global scope of the script; i.e., separate from the $_SERVER and $HTTP_SERVER_VARS arrays. For related information, see the security chapter titled Using Register Globals. These individual globals are not superglobals.

You may or may not find any of the following elements in $_SERVER. Note that few, if any, of these will be available (or indeed have any meaning) if running PHP on the command line.

'PHP_SELF'

The filename of the currently executing script, relative to the document root. For instance, $_SERVER['PHP_SELF'] in a script at the address http://example.com/test.php/foo.bar would be /test.php/foo.bar. The __FILE__ constant contains the full path and filename of the current (i.e. included) file.

If PHP is running as a command-line processor this variable contains the script name since PHP 4.3.0. Previously it was not available.

'argv'
Array of arguments passed to the script. When the script is run on the command line, this gives C-style access to the command line parameters. When called via the GET method, this will contain the query string.
'argc'
Contains the number of command line parameters passed to the script (if run on the command line).
'GATEWAY_INTERFACE'
What revision of the CGI specification the server is using; i.e. 'CGI/1.1'.
'SERVER_ADDR'
The IP address of the server under which the current script is executing.
'SERVER_NAME'
The name of the server host under which the current script is executing. If the script is running on a virtual host, this will be the value defined for that virtual host.
'SERVER_SOFTWARE'
Server identification string, given in the headers when responding to requests.
'SERVER_PROTOCOL'
Name and revision of the information protocol via which the page was requested; i.e. 'HTTP/1.0';
'REQUEST_METHOD'

Which request method was used to access the page; i.e. 'GET', 'HEAD', 'POST', 'PUT'.

Poznámka: PHP script is terminated after sending headers (it means after producing any output without output buffering) if the request method was HEAD.

'REQUEST_TIME'
The timestamp of the start of the request. Available since PHP 5.1.0.
'QUERY_STRING'
The query string, if any, via which the page was accessed.
'DOCUMENT_ROOT'
The document root directory under which the current script is executing, as defined in the server's configuration file.
'HTTP_ACCEPT'
Contents of the Accept: header from the current request, if there is one.
'HTTP_ACCEPT_CHARSET'
Contents of the Accept-Charset: header from the current request, if there is one. Example: 'iso-8859-1,*,utf-8'.
'HTTP_ACCEPT_ENCODING'
Contents of the Accept-Encoding: header from the current request, if there is one. Example: 'gzip'.
'HTTP_ACCEPT_LANGUAGE'
Contents of the Accept-Language: header from the current request, if there is one. Example: 'en'.
'HTTP_CONNECTION'
Contents of the Connection: header from the current request, if there is one. Example: 'Keep-Alive'.
'HTTP_HOST'
Contents of the Host: header from the current request, if there is one.
'HTTP_REFERER'
The address of the page (if any) which referred the user agent to the current page. This is set by the user agent. Not all user agents will set this, and some provide the ability to modify HTTP_REFERER as a feature. In short, it cannot really be trusted.
'HTTP_USER_AGENT'
Contents of the User-Agent: header from the current request, if there is one. This is a string denoting the user agent being which is accessing the page. A typical example is: Mozilla/4.5 [en] (X11; U; Linux 2.2.9 i586). Among other things, you can use this value with get_browser() to tailor your page's output to the capabilities of the user agent.
'HTTPS'

Set to a non-empty value if the script was queried through the HTTPS protocol.

Note that when using ISAPI with IIS, the value will be off if the request was not made through the HTTPS protocol.

'REMOTE_ADDR'
The IP address from which the user is viewing the current page.
'REMOTE_HOST'

The Host name from which the user is viewing the current page. The reverse dns lookup is based off the REMOTE_ADDR of the user.

Poznámka: Your web server must be configured to create this variable. For example in Apache you'll need HostnameLookups On inside httpd.conf for it to exist. See also gethostbyaddr().

'REMOTE_PORT'
The port being used on the user's machine to communicate with the web server.
'SCRIPT_FILENAME'

The absolute pathname of the currently executing script.

Poznámka: If a script is executed with the CLI, as a relative path, such as file.php or ../file.php, $_SERVER['SCRIPT_FILENAME'] will contain the relative path specified by the user.

'SERVER_ADMIN'
The value given to the SERVER_ADMIN (for Apache) directive in the web server configuration file. If the script is running on a virtual host, this will be the value defined for that virtual host.
'SERVER_PORT'
The port on the server machine being used by the web server for communication. For default setups, this will be '80'; using SSL, for instance, will change this to whatever your defined secure HTTP port is.
'SERVER_SIGNATURE'
String containing the server version and virtual host name which are added to server-generated pages, if enabled.
'PATH_TRANSLATED'

Filesystem- (not document root-) based path to the current script, after the server has done any virtual-to-real mapping.

Poznámka: As of PHP 4.3.2, PATH_TRANSLATED is no longer set implicitly under the Apache 2 SAPI in contrast to the situation in Apache 1, where it's set to the same value as the SCRIPT_FILENAME server variable when it's not populated by Apache. This change was made to comply with the CGI specification that PATH_TRANSLATED should only exist if PATH_INFO is defined.

Apache 2 users may use AcceptPathInfo = On inside httpd.conf to define PATH_INFO.

'SCRIPT_NAME'
Contains the current script's path. This is useful for pages which need to point to themselves. The __FILE__ constant contains the full path and filename of the current (i.e. included) file.
'REQUEST_URI'
The URI which was given in order to access this page; for instance, '/index.html'.
'PHP_AUTH_DIGEST'
When running under Apache as module doing Digest HTTP authentication this variable is set to the 'Authorization' header sent by the client (which you should then use to make the appropriate validation).
'PHP_AUTH_USER'
When running under Apache or IIS (ISAPI on PHP 5) as module doing HTTP authentication this variable is set to the username provided by the user.
'PHP_AUTH_PW'
When running under Apache or IIS (ISAPI on PHP 5) as module doing HTTP authentication this variable is set to the password provided by the user.
'AUTH_TYPE'
When running under Apache as module doing HTTP authenticated this variable is set to the authentication type.

Environment variables: $_ENV

Poznámka: Introduced in 4.1.0. In earlier versions, use $HTTP_ENV_VARS.

These variables are imported into PHP's global namespace from the environment under which the PHP parser is running. Many are provided by the shell under which PHP is running and different systems are likely running different kinds of shells, a definitive list is impossible. Please see your shell's documentation for a list of defined environment variables.

Other environment variables include the CGI variables, placed there regardless of whether PHP is running as a server module or CGI processor.

This is a 'superglobal', or automatic global, variable. This simply means that it is available in all scopes throughout a script. You don't need to do a global $_ENV; to access it within functions or methods, as you do with $HTTP_ENV_VARS.

$HTTP_ENV_VARS contains the same initial information, but is not a superglobal. (Note that $HTTP_ENV_VARS and $_ENV are different variables and that PHP handles them as such)

If the register_globals directive is set, then these variables will also be made available in the global scope of the script; i.e., separate from the $_ENV and $HTTP_ENV_VARS arrays. For related information, see the security chapter titled Using Register Globals. These individual globals are not superglobals.

HTTP Cookies: $_COOKIE

Poznámka: Introduced in 4.1.0. In earlier versions, use $HTTP_COOKIE_VARS.

An associative array of variables passed to the current script via HTTP cookies. Automatically global in any scope.

This is a 'superglobal', or automatic global, variable. This simply means that it is available in all scopes throughout a script. You don't need to do a global $_COOKIE; to access it within functions or methods, as you do with $HTTP_COOKIE_VARS.

$HTTP_COOKIE_VARS contains the same initial information, but is not a superglobal. (Note that $HTTP_COOKIE_VARS and $_COOKIE are different variables and that PHP handles them as such)

If the register_globals directive is set, then these variables will also be made available in the global scope of the script; i.e., separate from the $_COOKIE and $HTTP_COOKIE_VARS arrays. For related information, see the security chapter titled Using Register Globals. These individual globals are not superglobals.

HTTP GET variables: $_GET

Poznámka: Introduced in 4.1.0. In earlier versions, use $HTTP_GET_VARS.

An associative array of variables passed to the current script via the HTTP GET method. Automatically global in any scope.

This is a 'superglobal', or automatic global, variable. This simply means that it is available in all scopes throughout a script. You don't need to do a global $_GET; to access it within functions or methods, as you do with $HTTP_GET_VARS.

$HTTP_GET_VARS contains the same initial information, but is not a superglobal. (Note that $HTTP_GET_VARS and $_GET are different variables and that PHP handles them as such)

If the register_globals directive is set, then these variables will also be made available in the global scope of the script; i.e., separate from the $_GET and $HTTP_GET_VARS arrays. For related information, see the security chapter titled Using Register Globals. These individual globals are not superglobals.

HTTP POST variables: $_POST

Poznámka: Introduced in 4.1.0. In earlier versions, use $HTTP_POST_VARS.

An associative array of variables passed to the current script via the HTTP POST method. Automatically global in any scope.

This is a 'superglobal', or automatic global, variable. This simply means that it is available in all scopes throughout a script. You don't need to do a global $_POST; to access it within functions or methods, as you do with $HTTP_POST_VARS.

$HTTP_POST_VARS contains the same initial information, but is not a superglobal. (Note that $HTTP_POST_VARS and $_POST are different variables and that PHP handles them as such)

If the register_globals directive is set, then these variables will also be made available in the global scope of the script; i.e., separate from the $_POST and $HTTP_POST_VARS arrays. For related information, see the security chapter titled Using Register Globals. These individual globals are not superglobals.

HTTP File upload variables: $_FILES

Poznámka: Introduced in 4.1.0. In earlier versions, use $HTTP_POST_FILES.

An associative array of items uploaded to the current script via the HTTP POST method. Automatically global in any scope.

This is a 'superglobal', or automatic global, variable. This simply means that it is available in all scopes throughout a script. You don't need to do a global $_FILES; to access it within functions or methods, as you do with $HTTP_POST_FILES.

$HTTP_POST_FILES contains the same information, but is not a superglobal. (Note that $HTTP_POST_FILES and $_FILES are different variables and that PHP handles them as such)

If the register_globals directive is set, then these variables will also be made available in the global scope of the script; i.e., separate from the $_FILES and $HTTP_POST_FILES arrays. For related information, see the security chapter titled Using Register Globals. These individual globals are not superglobals.

Request variables: $_REQUEST

Poznámka: Introduced in 4.1.0. There is no equivalent array in earlier versions.

Poznámka: Prior to PHP 4.3.0, $_FILES information was also included in $_REQUEST.

An associative array consisting of the contents of $_GET, $_POST, and $_COOKIE.

This is a 'superglobal', or automatic global, variable. This simply means that it is available in all scopes throughout a script. You don't need to do a global $_REQUEST; to access it within functions or methods.

If the register_globals directive is set, then these variables will also be made available in the global scope of the script; i.e., separate from the $_REQUEST array. For related information, see the security chapter titled Using Register Globals. These individual globals are not superglobals.

Session variables: $_SESSION

Poznámka: Introduced in 4.1.0. In earlier versions, use $HTTP_SESSION_VARS.

An associative array containing session variables available to the current script. See the Session functions documentation for more information on how this is used.

This is a 'superglobal', or automatic global, variable. This simply means that it is available in all scopes throughout a script. You don't need to do a global $_SESSION; to access it within functions or methods, as you do with $HTTP_SESSION_VARS.

$HTTP_SESSION_VARS contains the same information, but is not a superglobal. (Note that $HTTP_SESSION_VARS and $_SESSION are different variables and that PHP handles them as such)

If the register_globals directive is set, then these variables will also be made available in the global scope of the script; i.e., separate from the $_SESSION and $HTTP_SESSION_VARS arrays. For related information, see the security chapter titled Using Register Globals. These individual globals are not superglobals.

Global variables: $GLOBALS

Poznámka: $GLOBALS has been available since PHP 3.0.0.

An associative array containing references to all variables which are currently defined in the global scope of the script. The variable names are the keys of the array.

This is a 'superglobal', or automatic global, variable. This simply means that it is available in all scopes throughout a script. You don't need to do a global $GLOBALS; to access it within functions or methods.

The previous error message: $php_errormsg

$php_errormsg is a variable containing the text of the last error message generated by PHP. This variable will only be available within the scope in which the error occurred, and only if the track_errors configuration option is turned on (it defaults to off).

Raw POST data: $HTTP_RAW_POST_DATA

$HTTP_RAW_POST_DATA contains the raw POST data. See always_populate_raw_post_data

HTTP response headers: $http_response_header

The $http_response_header array is similiar to the get_headers() function. When using the HTTP wrapper $http_response_header will be populated with the HTTP response headers.

Předcházející | Nahoru | Další
M. List of Reserved Words | Domů | Predefined Classes


Runkit_Sandbox

(No version information available, might be only in CVS)

Runkit_Sandbox — Runkit Sandbox Class -- PHP Virtual Machine

Popis

Instantiating the Runkit_Sandbox class creates a new thread with its own scope and program stack. Using a set of options passed to the constructor, this environment may be restricted to a subset of what the primary interpreter can do and provide a safer environment for executing user supplied code.

Poznámka: Podpora sandboxu (potřebná pro runkit_lint(), runkit_lint_file(), a třídu Runkit_Sandbox) je dostupná jen v PHP 5.1 nebo speciálně patchovaných verzích PHP 5.0, a vyžaduje zapnutou threadovou bezpečnost. Pro více informací viz soubor README přiložený k runkit balíku.

Constructor

void Runkit_Sandbox::__construct ( [array $options] )

options is an associative array containing any combination of the special ini options listed below.

safe_mode

If the outer script which is instantiating the Runkit_Sandbox class is configured with safe_mode = off, then safe_mode may be turned on for the sandbox environment. This setting can not be used to disable safe_mode when it's already enabled in the outer script.

safe_mode_gid

If the outer script which is instantiating the Runkit_Sandbox class is configured with safe_mode_gid = on, then safe_mode_gid may be turned off for the sandbox environment. This setting can not be used to enable safe_mode_gid when it's already disabled in the outer script.

safe_mode_include_dir

If the outer script which is instantiating the Runkit_Sandbox class is configured with a safe_mode_include_dir, then a new safe_mode_include_dir may be set for sandbox environments below the currently defined value. safe_mode_include_dir may also be cleared to indicate that the bypass feature is disabled. If safe_mode_include_dir was blank in the outer script, but safe_mode was not enabled, then any arbitrary safe_mode_include_dir may be set while turning safe_mode on.

open_basedir

open_basedir may be set to any path below the current setting of open_basedir. If open_basedir is not set within the global scope, then it is assumed to be the root directory and may be set to any location.

allow_url_fopen

Like safe_mode, this setting can only be made more restrictive, in this case by setting it to FALSE when it is previously set to TRUE

disable_functions

Comma separated list of functions to disable within the sandbox sub-interpreter. This list need not contain the names of the currently disabled functions, they will remain disabled whether listed here or not.

disable_classes

Comma separated list of classes to disable within the sandbox sub-interpreter. This list need not contain the names of the currently disabled classes, they will remain disabled whether listed here or not.

runkit.superglobal

Comma separated list of variables to be treated as superglobals within the sandbox sub-interpreter. These variables will be used in addition to any variables defined internally or through the global runkit.superglobal setting.

runkit.internal_override

Ini option runkit.internal_override may be disabled (but not re-enabled) within sandboxes.

Příklad 1864. Instantiating a restricted sandbox

<?php
$options = array(
  'safe_mode'=>true,
  'open_basedir'=>'/var/www/users/jdoe/',
  'allow_url_fopen'=>'false',
  'disable_functions'=>'exec,shell_exec,passthru,system',
  'disable_classes'=>'myAppClass');
$sandbox = new Runkit_Sandbox($options);
/* Non-protected ini settings may set normally */
$sandbox->ini_set('html_errors',true);
?>

Accessing Variables

All variables in the global scope of the sandbox environment are accessible as properties of the sandbox object. The first thing to note is that because of the way memory between these two threads is managed, object and resource variables can not currently be exchanged between interpreters. Additionally, all arrays are deep copied and any references will be lost. This also means that references between interpreters are not possible.

Příklad 1865. Working with variables in a sandbox

<?php
$sandbox = new Runkit_Sandbox();

$sandbox->foo = 'bar';
$sandbox->eval('echo "$foo\n"; $bar = $foo . "baz";');
echo "{$sandbox->bar}\n";
if (isset($sandbox->foo)) unset($sandbox->foo);
$sandbox->eval('var_dump(isset($foo));');
?>

Výše uvedený příklad vypíše:

bar
barbaz
bool(false)

Calling PHP Functions

Any function defined within the sandbox may be called as
a method on the sandbox object.  This also includes a few
pseudo-function language constructs:  eval(),
include(), include_once(),
require(), require_once(),
echo(), print(),
die(), and exit().

Příklad 1866. Calling sandbox functions

<?php
$sandbox = new Runkit_Sandbox();

echo $sandbox->str_replace('a','f','abc');
?>

Výše uvedený příklad vypíše:

fbc

When passing arguments to a sandbox function, the arguments are taken from the outer instance of PHP. If you wish to pass arguments from the sandbox's scope, be sure to access them as properties of the sandbox object as illustrated above.

Příklad 1867. Passing arguments to sandbox functions

<?php
$sandbox = new Runkit_Sandbox();

$foo = 'bar';
$sandbox->foo = 'baz';
echo $sandbox->str_replace('a',$foo,'a');
echo $sandbox->str_replace('a',$sandbox->foo,'a');
?>

Výše uvedený příklad vypíše:

bar
baz

Changing Sandbox Settings

As of runkit version 0.5, certain Sandbox settings may be modified on the fly using ArrayAccess syntax. Some settings, such as active are read-only and meant to provide status information. Other settings, such as output_handler may be set and read much like a normal array offset. Future settings may be write-only, however no such settings currently exist.

Tabulka 264. Sandbox Settings / Status Indicators

Setting | Type | Purpose | Default
active | Boolean (Read Only) | TRUE if the Sandbox is still in a usable state, FALSE if the request is in bailout due to a call to die(), exit(), or because of a fatal error condition. | TRUE (Initial)
output_handler | Callback | When set to a valid callback, all output generated by the Sandbox instance will be processed through the named function. Sandbox output handlers follow the same calling conventions as the system-wide output handler. | None
parent_access | Boolean | May the sandbox use instances of the Runkit_Sandbox_Parent class? Must be enabled for other Runkit_Sandbox_Parent related settings to work. | FALSE
parent_read | Boolean | May the sandbox read variables in its parent's context? | FALSE
parent_write | Boolean | May the sandbox modify variables in its parent's context? | FALSE
parent_eval | Boolean | May the sandbox evaluate arbitrary code in its parent's context? DANGEROUS | FALSE
parent_include | Boolean | May the sandbox include php code files in its parent's context? DANGEROUS | FALSE
parent_echo | Boolean | May the sandbox echo data in its parent's context effectively bypassing its own output_handler? | FALSE
parent_call | Boolean | May the sandbox call functions in its parent's context? | FALSE
parent_die | Boolean | May the sandbox kill its own parent? (And thus itself) | FALSE
parent_scope | Integer | What scope will parental property access look at? 0 == Global scope, 1 == Calling scope, 2 == Scope preceeding calling scope, 3 == The scope before that, etc..., etc... | 0 (Global)
parent_scope | String | When parent_scope is set to a string value, it refers to a named array variable in the global scope. If the named variable does not exist at the time of access it will be created as an empty array. If the variable exists but it not an array, a dummy array will be created containing a reference to the named global variable. |

Předcházející | Nahoru | Další
CXXXIX. runkit Functions | Domů | Runkit_Sandbox_Parent


Runkit_Sandbox_Parent

(No version information available, might be only in CVS)

Runkit_Sandbox_Parent — Runkit Anti-Sandbox Class

Popis

void Runkit_Sandbox_Parent::__construct ( void )

Instantiating the Runkit_Sandbox_Parent class from within a sandbox environment created from the Runkit_Sandbox class provides some (controlled) means for a sandbox child to access its parent.

Poznámka: Podpora sandboxu (potřebná pro runkit_lint(), runkit_lint_file(), a třídu Runkit_Sandbox) je dostupná jen v PHP 5.1 nebo speciálně patchovaných verzích PHP 5.0, a vyžaduje zapnutou threadovou bezpečnost. Pro více informací viz soubor README přiložený k runkit balíku.

In order for any of the Runkit_Sandbox_Parent features to function. Support must be enabled on a per-sandbox basis by enabling the parent_access flag from the parent's context.

Příklad 1868. Working with variables in a sandbox

<?php
$sandbox = new Runkit_Sandbox();
$sandbox['parent_access'] = true;
?>

Accessing the Parent's Variables

Just as with sandbox variable access, a sandbox parent's variables may be read from and written to as properties of the Runkit_Sandbox_Parent class. Read access to parental variables may be enabled with the parent_read setting (in addition to the base parent_access setting). Write access, in turn, is enabled through the parent_write setting.

Unlike sandbox child variable access, the variable scope is not limited to globals only. By setting the parent_scope setting to an appropriate integer value, other scopes in the active call stack may be inspected instead. A value of 0 (Default) will direct variable access at the global scope. 1 will point variable access at whatever variable scope was active at the time the current block of sandbox code was executed. Higher values progress back through the functions that called the functions that led to the sandbox executing code that tried to access its own parent's variables.

Příklad 1869. Accessing parental variables

<?php
$php = new Runkit_Sandbox();
$php['parent_access'] = true;
$php['parent_read'] = true;

$test = "Global";

$php->eval('$PARENT = new Runkit_Sandbox_Parent;');

$php['parent_scope'] = 0;
one();

$php['parent_scope'] = 1;
one();

$php['parent_scope'] = 2;
one();

$php['parent_scope'] = 3;
one();

$php['parent_scope'] = 4;
one();

$php['parent_scope'] = 5;
one();

function one() {
    $test = "one()";
    two();
}

function two() {
    $test = "two()";
    three();
}

function three() {
    $test = "three()";
    $GLOBALS['php']->eval('var_dump($PARENT->test);');
}
?>

Výše uvedený příklad vypíše:

string(6) "Global"
string(7) "three()"
string(5) "two()"
string(5) "one()"
string(6) "Global"
string(6) "Global"

Calling the Parent's Functions

Just as with sandbox access, a sandbox may access its parents functions providing that the proper settings have been enabled. Enabling parent_call will allow the sandbox to call all functions available to the parent scope. Language constructs are each controlled by their own setting: print() and echo() are enabled with parent_echo. die() and exit() are enabled with parent_die. eval() is enabled with parent_eval while include(), include_once(), require(), and require_once() are enabled through parent_include.

Předcházející | Nahoru | Další
Runkit_Sandbox | Domů | runkit_class_adopt


Příloha J. List of Supported Timezones

Obsah

List of timezones in the group Africa
List of timezones in the group America
List of timezones in the group Antarctica
List of timezones in the group Arctic
List of timezones in the group Asia
List of timezones in the group Atlantic
List of timezones in the group Australia
List of timezones in the group Europe
List of timezones in the group Indian
List of timezones in the group Pacific
List of timezones in the group Others

Here you'll find the complete list of timezones supported by PHP, which are meant to be used with e.g. date_default_timezone_set().

Poznámka: The latest version of the timezone database can be installed via PECL's » timezonedb. For Windows users, a pre-compiled DLL can be downloaded from the PECL4Win site: » php_timezonedb.dll.

List of timezones in the group Africa

Tabulka J.1. Africa

Africa/Abidjan | Africa/Accra | Africa/Addis_Ababa | Africa/Algiers | Africa/Asmera
Africa/Bamako | Africa/Bangui | Africa/Banjul | Africa/Bissau | Africa/Blantyre
Africa/Brazzaville | Africa/Bujumbura | Africa/Cairo | Africa/Casablanca | Africa/Ceuta
Africa/Conakry | Africa/Dakar | Africa/Dar_es_Salaam | Africa/Djibouti | Africa/Douala
Africa/El_Aaiun | Africa/Freetown | Africa/Gaborone | Africa/Harare | Africa/Johannesburg
Africa/Kampala | Africa/Khartoum | Africa/Kigali | Africa/Kinshasa | Africa/Lagos
Africa/Libreville | Africa/Lome | Africa/Luanda | Africa/Lubumbashi | Africa/Lusaka
Africa/Malabo | Africa/Maputo | Africa/Maseru | Africa/Mbabane | Africa/Mogadishu
Africa/Monrovia | Africa/Nairobi | Africa/Ndjamena | Africa/Niamey | Africa/Nouakchott
Africa/Ouagadougou | Africa/Porto-Novo | Africa/Sao_Tome | Africa/Timbuktu | Africa/Tripoli
Africa/Tunis | Africa/Windhoek |  |  |

Předcházející | Nahoru | Další
Popis základních direktiv php.ini | Domů | List of timezones in the group America


List of timezones in the group America

Tabulka J.2. America

America/Adak | America/Anchorage | America/Anguilla | America/Antigua | America/Araguaina
America/Argentina/Buenos_Aires | America/Argentina/Catamarca | America/Argentina/ComodRivadavia | America/Argentina/Cordoba | America/Argentina/Jujuy
America/Argentina/La_Rioja | America/Argentina/Mendoza | America/Argentina/Rio_Gallegos | America/Argentina/San_Juan | America/Argentina/Tucuman
America/Argentina/Ushuaia | America/Aruba | America/Asuncion | America/Atikokan | America/Atka
America/Bahia | America/Barbados | America/Belem | America/Belize | America/Blanc-Sablon
America/Boa_Vista | America/Bogota | America/Boise | America/Buenos_Aires | America/Cambridge_Bay
America/Campo_Grande | America/Cancun | America/Caracas | America/Catamarca | America/Cayenne
America/Cayman | America/Chicago | America/Chihuahua | America/Coral_Harbour | America/Cordoba
America/Costa_Rica | America/Cuiaba | America/Curacao | America/Danmarkshavn | America/Dawson
America/Dawson_Creek | America/Denver | America/Detroit | America/Dominica | America/Edmonton
America/Eirunepe | America/El_Salvador | America/Ensenada | America/Fort_Wayne | America/Fortaleza
America/Glace_Bay | America/Godthab | America/Goose_Bay | America/Grand_Turk | America/Grenada
America/Guadeloupe | America/Guatemala | America/Guayaquil | America/Guyana | America/Halifax
America/Havana | America/Hermosillo | America/Indiana/Indianapolis | America/Indiana/Knox | America/Indiana/Marengo
America/Indiana/Petersburg | America/Indiana/Vevay | America/Indiana/Vincennes | America/Indianapolis | America/Inuvik
America/Iqaluit | America/Jamaica | America/Jujuy | America/Juneau | America/Kentucky/Louisville
America/Kentucky/Monticello | America/Knox_IN | America/La_Paz | America/Lima | America/Los_Angeles
America/Louisville | America/Maceio | America/Managua | America/Manaus | America/Martinique
America/Mazatlan | America/Mendoza | America/Menominee | America/Merida | America/Mexico_City
America/Miquelon | America/Moncton | America/Monterrey | America/Montevideo | America/Montreal
America/Montserrat | America/Nassau | America/New_York | America/Nipigon | America/Nome
America/Noronha | America/North_Dakota/Center | America/North_Dakota/New_Salem | America/Panama | America/Pangnirtung
America/Paramaribo | America/Phoenix | America/Port-au-Prince | America/Port_of_Spain | America/Porto_Acre
America/Porto_Velho | America/Puerto_Rico | America/Rainy_River | America/Rankin_Inlet | America/Recife
America/Regina | America/Rio_Branco | America/Rosario | America/Santiago | America/Santo_Domingo
America/Sao_Paulo | America/Scoresbysund | America/Shiprock | America/St_Johns | America/St_Kitts
America/St_Lucia | America/St_Thomas | America/St_Vincent | America/Swift_Current | America/Tegucigalpa
America/Thule | America/Thunder_Bay | America/Tijuana | America/Toronto | America/Tortola
America/Vancouver | America/Virgin | America/Whitehorse | America/Winnipeg | America/Yakutat
America/Yellowknife |  |  |  |

Předcházející | Nahoru | Další
J. List of Supported Timezones | Domů | List of timezones in the group Antarctica


List of timezones in the group Antarctica

Tabulka J.3. Antarctica

Antarctica/Casey | Antarctica/Davis | Antarctica/DumontDUrville | Antarctica/Mawson | Antarctica/McMurdo
Antarctica/Palmer | Antarctica/Rothera | Antarctica/South_Pole | Antarctica/Syowa | Antarctica/Vostok

Předcházející | Nahoru | Další
List of timezones in the group America | Domů | List of timezones in the group Arctic


List of timezones in the group Arctic

Tabulka J.4. Arctic

Arctic/Longyearbyen

Předcházející | Nahoru | Další
List of timezones in the group Antarctica | Domů | List of timezones in the group Asia


List of timezones in the group Asia

Tabulka J.5. Asia

Asia/Aden | Asia/Almaty | Asia/Amman | Asia/Anadyr | Asia/Aqtau
Asia/Aqtobe | Asia/Ashgabat | Asia/Ashkhabad | Asia/Baghdad | Asia/Bahrain
Asia/Baku | Asia/Bangkok | Asia/Beirut | Asia/Bishkek | Asia/Brunei
Asia/Calcutta | Asia/Choibalsan | Asia/Chongqing | Asia/Chungking | Asia/Colombo
Asia/Dacca | Asia/Damascus | Asia/Dhaka | Asia/Dili | Asia/Dubai
Asia/Dushanbe | Asia/Gaza | Asia/Harbin | Asia/Hong_Kong | Asia/Hovd
Asia/Irkutsk | Asia/Istanbul | Asia/Jakarta | Asia/Jayapura | Asia/Jerusalem
Asia/Kabul | Asia/Kamchatka | Asia/Karachi | Asia/Kashgar | Asia/Katmandu
Asia/Krasnoyarsk | Asia/Kuala_Lumpur | Asia/Kuching | Asia/Kuwait | Asia/Macao
Asia/Macau | Asia/Magadan | Asia/Makassar | Asia/Manila | Asia/Muscat
Asia/Nicosia | Asia/Novosibirsk | Asia/Omsk | Asia/Oral | Asia/Phnom_Penh
Asia/Pontianak | Asia/Pyongyang | Asia/Qatar | Asia/Qyzylorda | Asia/Rangoon
Asia/Riyadh | Asia/Saigon | Asia/Sakhalin | Asia/Samarkand | Asia/Seoul
Asia/Shanghai | Asia/Singapore | Asia/Taipei | Asia/Tashkent | Asia/Tbilisi
Asia/Tehran | Asia/Tel_Aviv | Asia/Thimbu | Asia/Thimphu | Asia/Tokyo
Asia/Ujung_Pandang | Asia/Ulaanbaatar | Asia/Ulan_Bator | Asia/Urumqi | Asia/Vientiane
Asia/Vladivostok | Asia/Yakutsk | Asia/Yekaterinburg | Asia/Yerevan |

Předcházející | Nahoru | Další
List of timezones in the group Arctic | Domů | List of timezones in the group Atlantic


List of timezones in the group Atlantic

Tabulka J.6. Atlantic

Atlantic/Azores | Atlantic/Bermuda | Atlantic/Canary | Atlantic/Cape_Verde | Atlantic/Faeroe
Atlantic/Jan_Mayen | Atlantic/Madeira | Atlantic/Reykjavik | Atlantic/South_Georgia | Atlantic/St_Helena
Atlantic/Stanley |  |  |  |

Předcházející | Nahoru | Další
List of timezones in the group Asia | Domů | List of timezones in the group Australia


List of timezones in the group Australia

Tabulka J.7. Australia

Australia/ACT | Australia/Adelaide | Australia/Brisbane | Australia/Broken_Hill | Australia/Canberra
Australia/Currie | Australia/Darwin | Australia/Hobart | Australia/LHI | Australia/Lindeman
Australia/Lord_Howe | Australia/Melbourne | Australia/North | Australia/NSW | Australia/Perth
Australia/Queensland | Australia/South | Australia/Sydney | Australia/Tasmania | Australia/Victoria
Australia/West | Australia/Yancowinna |  |  |

Předcházející | Nahoru | Další
List of timezones in the group Atlantic | Domů | List of timezones in the group Europe


List of timezones in the group Europe

Tabulka J.8. Europe

Europe/Amsterdam | Europe/Andorra | Europe/Athens | Europe/Belfast | Europe/Belgrade
Europe/Berlin | Europe/Bratislava | Europe/Brussels | Europe/Bucharest | Europe/Budapest
Europe/Chisinau | Europe/Copenhagen | Europe/Dublin | Europe/Gibraltar | Europe/Guernsey
Europe/Helsinki | Europe/Isle_of_Man | Europe/Istanbul | Europe/Jersey | Europe/Kaliningrad
Europe/Kiev | Europe/Lisbon | Europe/Ljubljana | Europe/London | Europe/Luxembourg
Europe/Madrid | Europe/Malta | Europe/Mariehamn | Europe/Minsk | Europe/Monaco
Europe/Moscow | Europe/Nicosia | Europe/Oslo | Europe/Paris | Europe/Prague
Europe/Riga | Europe/Rome | Europe/Samara | Europe/San_Marino | Europe/Sarajevo
Europe/Simferopol | Europe/Skopje | Europe/Sofia | Europe/Stockholm | Europe/Tallinn
Europe/Tirane | Europe/Tiraspol | Europe/Uzhgorod | Europe/Vaduz | Europe/Vatican
Europe/Vienna | Europe/Vilnius | Europe/Volgograd | Europe/Warsaw | Europe/Zagreb
Europe/Zaporozhye | Europe/Zurich |  |  |

Předcházející | Nahoru | Další
List of timezones in the group Australia | Domů | List of timezones in the group Indian


List of timezones in the group Indian

Tabulka J.9. Indian

Indian/Antananarivo | Indian/Chagos | Indian/Christmas | Indian/Cocos | Indian/Comoro
Indian/Kerguelen | Indian/Mahe | Indian/Maldives | Indian/Mauritius | Indian/Mayotte
Indian/Reunion |  |  |  |

Předcházející | Nahoru | Další
List of timezones in the group Europe | Domů | List of timezones in the group Pacific


List of timezones in the group Others

Tabulka J.11. Others

Brazil/Acre | Brazil/DeNoronha | Brazil/East | Brazil/West | Canada/Atlantic
Canada/Central | Canada/East-Saskatchewan | Canada/Eastern | Canada/Mountain | Canada/Newfoundland
Canada/Pacific | Canada/Saskatchewan | Canada/Yukon | CET | Chile/Continental
Chile/EasterIsland | CST6CDT | Cuba | EET | Egypt
Eire | EST | EST5EDT | Etc/GMT | Etc/GMT+0
Etc/GMT+1 | Etc/GMT+10 | Etc/GMT+11 | Etc/GMT+12 | Etc/GMT+2
Etc/GMT+3 | Etc/GMT+4 | Etc/GMT+5 | Etc/GMT+6 | Etc/GMT+7
Etc/GMT+8 | Etc/GMT+9 | Etc/GMT-0 | Etc/GMT-1 | Etc/GMT-10
Etc/GMT-11 | Etc/GMT-12 | Etc/GMT-13 | Etc/GMT-14 | Etc/GMT-2
Etc/GMT-3 | Etc/GMT-4 | Etc/GMT-5 | Etc/GMT-6 | Etc/GMT-7
Etc/GMT-8 | Etc/GMT-9 | Etc/GMT0 | Etc/Greenwich | Etc/UCT
Etc/Universal | Etc/UTC | Etc/Zulu | Factory | GB
GB-Eire | GMT | GMT+0 | GMT-0 | GMT0
Greenwich | Hongkong | HST | Iceland | Iran
Israel | Jamaica | Japan | Kwajalein | Libya
MET | Mexico/BajaNorte | Mexico/BajaSur | Mexico/General | MST
MST7MDT | Navajo | NZ | NZ-CHAT | Poland
Portugal | PRC | PST8PDT | ROC | ROK
Singapore | Turkey | UCT | Universal | US/Alaska
US/Aleutian | US/Arizona | US/Central | US/East-Indiana | US/Eastern
US/Hawaii | US/Indiana-Starke | US/Michigan | US/Mountain | US/Pacific
US/Pacific-New | US/Samoa | UTC | W-SU | WET
Zulu |  |  |  |

Poznámka: Please do not use any of the timezones listed here, they only exist for backward compatible reasons.

Předcházející | Nahoru | Další
List of timezones in the group Pacific | Domů | K. Kategorizace rozšíření


List of timezones in the group Pacific

Tabulka J.10. Pacific

Pacific/Apia | Pacific/Auckland | Pacific/Chatham | Pacific/Easter | Pacific/Efate
Pacific/Enderbury | Pacific/Fakaofo | Pacific/Fiji | Pacific/Funafuti | Pacific/Galapagos
Pacific/Gambier | Pacific/Guadalcanal | Pacific/Guam | Pacific/Honolulu | Pacific/Johnston
Pacific/Kiritimati | Pacific/Kosrae | Pacific/Kwajalein | Pacific/Majuro | Pacific/Marquesas
Pacific/Midway | Pacific/Nauru | Pacific/Niue | Pacific/Norfolk | Pacific/Noumea
Pacific/Pago_Pago | Pacific/Palau | Pacific/Pitcairn | Pacific/Ponape | Pacific/Port_Moresby
Pacific/Rarotonga | Pacific/Saipan | Pacific/Samoa | Pacific/Tahiti | Pacific/Tarawa
Pacific/Tongatapu | Pacific/Truk | Pacific/Wake | Pacific/Wallis | Pacific/Yap

Předcházející | Nahoru | Další
List of timezones in the group Indian | Domů | List of timezones in the group Others


Příloha T. Userland Naming Guide

Obsah

Global Namespace
Rules
Tips

The following is a guide for how to best choose names for identifiers in userland PHP code. When choosing names for any code that creates symbols in the global namespace, it is important to take into account the following guidelines to prevent future versions of PHP from clashing with your symbols.

Global Namespace

Here is an overview of code constructs that go into the global namespace:

  • functions

  • classes

  • interfaces

  • constants (not class constants)

  • variables defined outside of functions/methods

Předcházející | Nahoru | Další
S. Seznam tokenů parseru | Domů | Rules


Rules

The following list gives an overview of which rights the PHP project reserves for itself, when choosing names for new internal identifiers. The definitive guide is the official » CODING STANDARDS:

  • PHP owns the top-level namespace but tries to find decent descriptive names and avoid any obvious clashes.

  • Function names use underscores between words, while class names use the camel case rule (there are some exceptions for older classes and functions).

  • PHP will prefix any global symbols of an extension with the name of the extension. (In the past, there have been numerous exceptions to this rule.) Examples:

    • curl_close()

    • mysql_query()

    • PREG_SPLIT_DELIM_CAPTURE

    • new DOMDocument()

    • strpos() (example of a past mistake)

    • new SplFileObject()

  • Iterators and Exceptions are however simply postfixed with "Iterator" and "Exception." Examples:

    • ArrayIterator

    • LogicException

  • PHP reserves all symbols starting with __ as magical. It is recommended that you do not create symbols starting with __ in PHP unless you want to use documented magical functionality. Examples:

    • __get()

    • __autoload()

Předcházející | Nahoru | Další
T. Userland Naming Guide | Domů | Tips


Tips

In order to write future-proof code, it is recommended that you prefix (or suffix) anything that goes into the global namespace with an uncommon 3-4 letter prefix (or suffix) separated with an underscore. It is recommended that in order to prevent namespace clashes with other userland code that projects research existing prefixes (or suffixes) used in other projects and advertise their chosen prefix (or suffix) appropriately. Examples:

  • MyPx_someFunc()

  • Foo_Date

  • $asdf_dbh

Předcházející | Nahoru | Další
Rules | Domů | U. O tomto manuálu


Data (RFC 2397)

The data: (» RFC 2397) stream wrapper is available since PHP 5.2.0.

Příklad O.4. Print data:// contents

<?php
// prints "I love PHP"
echo file_get_contents('data://text/plain;base64,SSBsb3ZlIFBIUAo=');
?>

Příklad O.5. Fetch the media type

<?php
$fp   = fopen('data://text/plain;base64,', 'r');
$meta = stream_get_meta_data($fp);

// prints "text/plain"
echo $meta['mediatype'];
?>

Tabulka O.8. Wrapper Summary

Attribute | Supported
Restricted by allow_url_fopen | No
Restricted by allow_url_include | Yes
Allows Reading | Yes
Allows Writing | No
Allows Appending | No
Allows Simultaneous Reading and Writing | No
Supports stat() | No
Supports unlink() | No
Supports rename() | No
Supports mkdir() | No
Supports rmdir() | No

Předcházející | Nahoru | Další
Compression Streams | Domů | Secure Shell 2


Process Interaction Streams

expect:// PHP 4.3.0 and up (PECL)

  • expect://command

This wrapper is not enabled by default: In order to use the expect:// wrapper you must install the » Expect extension available from » PECL.

Streams opened via the expect:// wrapper provide access to process'es stdio, stdout and stderr via PTY.

Tabulka O.13. Wrapper Summary

Attribute | Supported
Restricted by allow_url_fopen | No
Allows Reading | Yes
Allows Writing | Yes
Allows Appending | Yes
Allows Simultaneous Reading and Writing | No
Supports stat() | No
Supports unlink() | No
Supports rename() | No
Supports mkdir() | No
Supports rmdir() | No

Předcházející | Nahoru | Další
Audio Streams | Domů | P. Seznam dostupných filtrů


Socket

This section contains the context options supported by the wrappers that work over sockets, like tcp, http or ftp.

As of PHP 5.1.0 only one option is supported, bindto, which can be used to specify the IP address (either IPv4 or IPv6) and/or the port number that PHP will use to access the network. The syntax is ip:port (you can set the IP or the port number to 0 if you want to let the system choose them for you).

Poznámka: As FTP creates two socket connections during normal operation, you cannot specify the port number in the bindto option. So, the only supported syntax is ip:0 for the FTP wrapper.

Příklad O.1. Some examples of how to use the bindto option

<?php
// connect to the internet using the '192.168.0.100' IP
$opts = array('socket' =>
            array('bindto' => '192.168.0.100:0'));

// connect to the internet using the '192.168.0.100' IP and port '7000'
$opts = array('socket' =>
            array('bindto' => '192.168.0.100:7000'));

// connect to the internet using port '7000'
$opts = array('socket' =>
            array('bindto' => '0:7000'));

// create the context...
$context = stream_context_create($opts);

// ...and use it to fetch the data
echo file_get_contents('http://www.example.com', false, $context);

?>

Předcházející | Nahoru | Další
O. List of Supported Protocols/Wrappers | Domů | HTTP and HTTPS


Secure Shell 2

ssh2.shell:// ssh2.exec:// ssh2.tunnel:// ssh2.sftp:// ssh2.scp:// PHP 4.3.0 and up (PECL)

  • ssh2.shell://user:pass@example.com:22/xterm
  • ssh2.exec://user:pass@example.com:22/usr/local/bin/somecmd
  • ssh2.tunnel://user:pass@example.com:22/192.168.0.1:14
  • ssh2.sftp://user:pass@example.com:22/path/to/filename

This wrapper is not enabled by default: In order to use the ssh2.*:// wrappers you must install the » SSH2 extension available from » PECL.

In addition to accepting traditional URI login details, the ssh2 wrappers will also reuse open connections by passing the connection resource in the host portion of the URL.

Příklad O.6. Opening a stream from an active connection

<?php
$session = ssh2_connect('example.com', 22);
ssh2_auth_pubkey_file($session, 'username', '/home/username/.ssh/id_rsa.pub',
                                            '/home/username/.ssh/id_rsa', 'secret');
$stream = fopen("ssh2.tunnel://$session/remote.example.com:1234", 'r');
?>

Tabulka O.9. Wrapper Summary

Attribute | ssh2.shell | ssh2.exec | ssh2.tunnel | ssh2.sftp | ssh2.scp
Restricted by allow_url_fopen | Yes | Yes | Yes | Yes | Yes
Allows Reading | Yes | Yes | Yes | Yes | Yes
Allows Writing | Yes | Yes | Yes | Yes | No
Allows Appending | No | No | No | Yes (When supported by server) | No
Allows Simultaneous Reading and Writing | Yes | Yes | Yes | Yes | No
Supports stat() | No | No | No | Yes | No
Supports unlink() | No | No | No | Yes | No
Supports rename() | No | No | No | Yes | No
Supports mkdir() | No | No | No | Yes | No
Supports rmdir() | No | No | No | Yes | No

Tabulka O.10. Context options

Name | Usage | Default
session | Preconnected ssh2 resource to be reused |
sftp | Preallocated sftp resource to be reused |
methods | Key exchange, hostkey, cipher, compression, and MAC methods to use |
callbacks |  |
username | Username to connect as |
password | Password to use with password authentication |
pubkey_file | Name of public key file to use for authentication |
privkey_file | Name of private key file to use for authentication |
env | Associate array of environment variables to set |
term | Terminal emulation type to request when allocating a pty |
term_width | Width of terminal requested when allocating a pty |
term_height | Height of terminal requested when allocating a pty |
term_units | Units to use with term_width and term_height | SSH2_TERM_UNIT_CHARS

Předcházející | Nahoru | Další
Data (RFC 2397) | Domů | Audio Streams